AT32F435/437 Firmwary Library: Introduction

AT32F435/437 Firmwary Library 2.0.9
AT32F435/437 Peripherals Driver Library
Introduction

The AT32F435_437 Firmware Library is a firmware package which contains the device drivers for all of the peripherals for AT32F435 and AT32F437.

This library provides a set of examples for each peripheral and some application such as the IAP and sLib utilities.

The mamual is structured as follows:

  • AT32F435_437_periph_driver : device drivers
  • AT32F435_periph_examples : examples for AT32F435
  • AT32F435_periph_template : AT32F435 project template for Keil and IAR IDE tools
  • AT32F437_periph_examples : examples for AT32F437
  • AT32F437_periph_template : AT32F437 project template for Keil and IAR IDE tools
  • AT32F435_437_board : AT-START-F435 and AT-START-F437 board setting functions
  • AT32F435_437_middlewares_i2c_application_library : middlewares for I2C application
  • AT32F435_437_middlewares_usbd_class : middlewares for different USB device class
  • AT32F435_437_middlewares_usbh_class : middlewares for different USB host class
  • AT32F435_437_middlewares_usbd_drivers : middlewares for USB device core driver
  • UTILITIES_examples : some applications such as FreeRTOS, sLib and IAP.
Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: Modules

Modules
Here is a list of all modules:
[detail level 1234]
► CMSIS |
► AT32F435_437 |
Library_configuration_section |
Configuration_section_for_cmsis |
Exported_types |
Exported_macro |
Peripheral_memory_map |
► AT32F435_437_system |
AT32F435_437_system_exported_variables |
AT32F435_437_system_exported_functions |
AT32F435_437_system_private_defines |
AT32F435_437_system_private_variables |
AT32F435_437_system_private_functions |
► AT32F435_437_periph_driver |
ERTC_exported_types |
ERTC_exported_functions |
► ACC | ACC driver modules
ACC_exported_constants |
ACC_exported_types |
ACC_exported_functions |
ACC_private_functions |
► ADC | ADC driver modules
ADC_interrupts_definition | Adc interrupt
ADC_flags_definition | Adc flag
ADC_exported_types |
ADC_exported_functions |
ADC_private_functions |
► CAN | CAN driver modules
CAN_timeout_count |
CAN_flags_definition | Can flag
CAN_interrupts_definition | Can interrupt
CAN_exported_types |
CAN_exported_functions |
CAN_private_functions |
► CRC | CRC driver modules
CRC_exported_types |
CRC_exported_functions |
CRC_private_functions |
► CRM | CRM driver modules
CRM_flags_definition | Crm flag
CRM_interrupts_definition | Crm interrupt
CRM_exported_types |
CRM_exported_functions |
CRM_private_functions |
► DAC | DAC driver modules
DAC_exported_types |
DAC_exported_functions |
DAC_private_functions |
► DEBUG | DEBUG driver modules
DEBUG_mode_definition |
DEBUG_exported_types |
DEBUG_exported_functions |
DEBUG_private_functions |
► DMA | DMA driver modules
DMA_interrupts_definition | Dma interrupt
DMA_flags_definition | Edma flag
DMA_exported_types |
DMA_exported_functions |
DMA_private_functions |
► DVP | DVP driver modules
DVP_event_flags_definition | Dvp event flag
DVP_interrupt_flags_definition | Dvp interrupt flag
DVP_interrupts_definition | Dvp interrupt
DVP_exported_types |
DVP_exported_functions |
DVP_private_functions |
► EDMA | EDMA driver modules
EDMA_interrupts_definition | Edma interrupt
EDMA_flags_definition | Edma flag
EDMA_exported_types |
EDMA_exported_functions |
EDMA_private_functions |
► EMAC | EMAC driver modules
EMAC_smi_clock_border_definition | Emac smi clock border
EMAC_interrupts_definition | Emac interrupts
EMAC_mmc_flags_definition | Emac mmc flags
EMAC_packet_definition | Emac packet
EMAC_dma_descriptor_tdes0_definition | Tdes0 definition
EMAC_dma_descriptor_tdes1_definition | Tdes1 descriptor
EMAC_dma_descriptor_tdes2_definition | Tdes2 descriptor
EMAC_dma_descriptor_tdes3_definition | Tdes3 descriptor
EMAC_dma_descriptor_rdes0_definition | Rdes0 descriptor
EMAC_dma_descriptor_rdes1_definition | Rdes1 descriptor
EMAC_dma_descriptor_rdes2_definition | Rdes2 descriptor
EMAC_dma_descriptor_rdes3_definition | Rdes3 descriptor
EMAC_exported_types |
EMAC_exported_functions |
EMAC_private_functions |
► ERTC | ERTC driver modules
ERTC_interrupts_definition | Ertc interrupt
ERTC_flags_definition | Ertc flag
ERTC_private_functions |
► EXINT | EXINT driver modules
EXINT_lines |
EXINT_exported_types |
EXINT_exported_functions |
EXINT_private_functions |
► FLASH | FLASH driver modules
FLASH_exported_constants |
FLASH_exported_types |
FLASH_exported_functions |
FLASH_private_functions |
► GPIO | GPIO driver modules
GPIO_pins_number_definition |
GPIO_exported_types |
GPIO_exported_functions |
GPIO_private_functions |
► I2C | I2C driver modules
I2C_interrupts_definition | I2c interrupt
I2C_flags_definition | I2c flag
I2C_exported_types |
I2C_exported_functions |
I2C_private_functions |
► MISC | MISC driver modules
MISC_vector_table_base_address |
MISC_exported_types |
MISC_exported_functions |
MISC_private_functions |
► PWC | PWC driver modules
PWC_flags_definition | Pwc flag
PWC_exported_types |
PWC_exported_functions |
PWC_private_functions |
► QSPI | QSPI driver modules
QSPI_flags_definition | Qspi flag
QSPI_exported_types |
QSPI_exported_functions |
QSPI_private_functions |
► SCFG | SCFG driver modules
SCFG_exported_types |
SCFG_exported_functions |
SCFG_private_functions |
► SDIO | SDIO driver modules
SDIO_interrupts_definition | Sdio interrupt
SDIO_flags_definition | Sdio flag
SDIO_exported_types |
SDIO_exported_functions |
SDIO_private_functions |
► SPI | SPI driver modules
SPI_I2S_flags_definition | Spi i2s flag
SPI_I2S_interrupts_definition | Spi i2s interrupt
SPI_exported_types |
SPI_exported_functions |
SPI_private_functions |
► TMR | TMR driver modules
TMR_flags_definition | Tmr flag
TMR_interrupt_select_type_definition | Tmr interrupt select type
TMR_exported_types |
TMR_exported_functions |
TMR_private_functions |
► USART | USART driver modules
USART_flags_definition | Usart flag
USART_interrupts_definition | Usart interrupt
USART_exported_types |
USART_exported_functions |
USART_private_functions |
► USB | USB driver modules
USB_global_interrupts_definition | Usb global interrupt mask
USB_global_interrupt_flags_definition | Usb global interrupt flag
USB_global_setting_definition | Usb global setting
USB_host_config_definition |
USB_device_config_definition |
USB_exported_enum_types |
USB_exported_types |
USB_exported_functions |
USB_private_functions |
► WDT | WDT driver modules
WDT_flags_definition | Wdt flag
WDT_exported_types |
WDT_exported_functions |
WDT_private_functions |
► WWDT | WWDT driver modules
WWDT_enable_bit_definition | Wwdt enable bit
WWDT_exported_types |
WWDT_exported_functions |
WWDT_private_functions |
► XMC | XMC driver modules
XMC_exported_types |
XMC_exported_functions |
XMC_private_functions |
► AT32F435_437_middlewares_i2c_application_library |
I2C_library_event_check_flag |
I2C_library_transmission_mode |
I2C_library_status_code |
I2C_library_handler |
I2C_library_exported_functions |
► AT32F435_437_middlewares_usb_drivers |
► USB_drivers_core | Usb global drivers core
USB_core_exported_types |
USB_core_private_functions |
► USB_standard |
USB_standard_define |
► AT32F435_437_middlewares_usbd_drivers |
► USBD_drivers_core | Usb device drivers core
USBD_core_exported_types |
USBD_core_private_functions |
► USBD_drivers_interrupt | Usb device interrupt
USBD_int_private_functions |
► USBD_drivers_standard_request | Usb device standard_request
USBD_sdr_exported_functions |
USBD_sdr_private_functions |
► USBD_drivers_int |
USBD_interrupt_exported_types |
► AT32F435_437_middlewares_usbh_drivers |
► USBH_drivers_core | Usb host drivers core
USBH_core_exported_types |
USBH_core_private_functions |
► USBH_drivers_control | Usb host drivers control
USBH_ctrl_exported_types |
USBH_ctrl_private_functions |
► USBH_drivers_interrupt | Usb host interrupt
USBH_int_private_functions |
► USBH_drivers_int |
USBH_interrupt_exported_types |
► AT32F435_437_middlewares_usbd_class |
► USB_audio_class | Usb device class audio demo
USB_audio_class_private_functions |
USB_audio_class_definition |
USB_device_audio_config_definition |
► USB_audio_desc | Usb device audio descriptor
USB_audio_desc_private_functions |
USB_audio_desc_definition |
► USB_audio_hid_class | Usb device class audio hid demo
USB_device_audio_hid_config_definition |
USB_audio_hid_class_private_functions |
USB_audio_hid_class_definition |
► USB_audio_hid_desc | Usb device audio hid descriptor
USB_audio_hid_desc_private_functions |
USB_audio_hid_desc_definition |
► USB_cdc_class | Usb device class cdc demo
USB_cdc_class_private_functions |
USB_cdc_class_definition |
► USB_cdc_class_exported_types |
USB_msc_bot_scsi_definition |
USB_cdc_msc_class_exported_functions |
USB_cdc_class_exported_functions |
► USB_cdc_desc | Usb device cdc descriptor
USB_cdc_desc_private_functions |
USB_cdc_desc_definition |
► USB_cdc_keyboard_class | Usb device class composite cdc and keyboard
USB_cdc_keyboard_class_private_functions |
USB_cdc_keyboard_class_definition |
► USB_cdc_class_exported_types |
USB_msc_bot_scsi_definition |
USB_cdc_msc_class_exported_functions |
USB_cdc_keyboar_class_exported_functions |
► USB_cdc_keyboard_desc | Usb device cdc keyboard descriptor
USB_cdc_keyboard_desc_private_functions |
USB_cdc_keyboard_desc_definition |
► USB_cdc_msc_class | Usb device class cdc msc demo
USB_cdc_class_private_functions |
USB_cdc_class_definition |
► USB_cdc_class_exported_types |
USB_msc_bot_scsi_definition |
USB_cdc_msc_class_exported_functions |
► USB_cdc_msc_desc | Usb device cdc msc descriptor
USB_cdc_msc_desc_private_functions |
USB_cdc_desc_definition |
► USB_msc_bot_scsi | Usb device class mass storage demo
USB_msc_bot_functions |
USB_msc_bot_scsi_definition |
► USB_custom_hid_class | Usb device custom hid demo
USB_custom_hid_class_private_functions |
USB_custom_hid_class_endpoint_definition |
USB_custom_hid_class_request_code_definition |
USB_custom_hid_class_exported_functions |
► USB_custom_hid_desc | Usb device custom_hid descriptor
USB_custom_hid_desc_private_functions |
USB_custom_hid_desc_definition |
► USB_hid_iap_class | Usb device class hid iap demo
USB_hid_iap_class_private_functions |
USB_hid_iap_class_definition |
► USB_hid_iap_desc | Usb device hid_iap descriptor
USB_hid_iap_desc_private_functions |
USB_hid_iap_desc_definition |
► USB_keyboard_class | Usb device keyboard demo
USB_keyboard_class_private_functions |
USB_keyboard_class_endpoint_definition |
USB_hid_class_exported_functions |
► USB_keyboard_desc | Usb device keyboard descriptor
USB_keyboard_desc_private_functions |
USB_keyboard_desc_definition |
► USB_mouse_class | Usb device mouse demo
USB_mouse_class_private_functions |
USB_mouse_class_endpoint_definition |
USB_mouse_class_request_code_definition |
USB_hid_class_exported_functions |
► USB_mouse_desc | Usb device mouse descriptor
USB_mouse_desc_private_functions |
USB_mouse_desc_definition |
► USB_msc_class | Usb device class msc demo
USB_msc_class_private_functions |
USB_msc_class_definition |
► USB_msc_desc | Usb device msc descriptor
USB_msc_desc_private_functions |
USB_msc_desc_definition |
► USB_printer_class | Usb device class printer demo
USB_printer_class_private_functions |
USB_printer_class_definition |
► USB_printer_desc | Usb device printer descriptor
USB_printer_desc_private_functions |
USB_printer_desc_definition |
► AT32F435_437_middlewares_usbh_class |
► USBH_hid_class | Usb host class hid demo
USBH_hid_class_private_functions |
USBH_hid_class_definition |
► USBH_hid_class_keyboard | Usb host class hid keyboard
USBH_hid_class_keyboard_private_functions |
USBH_hid_class_keyboard_definition |
► USBH_hid_class_mouse | Usb host class hid mouse
USBH_hid_class_mouse_private_functions |
USBH_hid_class_mouse_definition |
► USBH_msc_bot_scsi_class | Usb host class msc bot scsi
USBH_msc_bot_scsi_class_private_functions |
USBH_msc_bot_scsi_class_definition |
► USBH_msc_class | Usb host class msc demo
USBH_msc_class_private_functions |
USBH_msc_class_definition |
► AT32F435_437_board |
► BOARD | Onboard periph driver
BOARD_pins_definition |
BOARD_exported_functions |
► AT32F435_periph_examples |
USB_device_vcp_loopback |
ACC_calibration |
ADC_combine_mode_ordinary_shift_twoslave_dma3 |
ADC_combine_mode_ordinary_shift_twoslave_dma4 |
ADC_combine_mode_ordinary_smlt_oneslave_dma2 |
ADC_combine_mode_ordinary_smlt_oneslave_edma |
ADC_combine_mode_ordinary_smlt_twoslave_dma1 |
ADC_combine_mode_ordinary_smlt_twoslave_dma5 |
ADC_combine_mode_preempt_interltrig_twoslave |
ADC_conversion_abort |
ADC_current_vref_value_check |
ADC_edma_double_buffer |
ADC_exint_trigger_partitioned |
ADC_internal_temperature_sensor |
ADC_ordinary_preempt_oversampling |
ADC_software_trigger_repeat |
ADC_tmr_trigger_automatic_preempted |
ADC_use_polling_get_conversion_data |
ADC_vbat_monitor |
ADC_voltage_monitoring |
CAN_communication_mode |
CAN_filter |
CAN_loopback_mode |
CORTEX_m4_bit_band |
System_clock_configuration |
CORTEX_m4_cmsis_dsp |
► CORTEX_m4_fpu |
JULIA_fpu_functions |
CORTEX_m4_systick_interrupt |
CRC_calculation |
CRM_clock_failure_detection |
CRM_pll_parameter_calculate |
CRM_sysclk_switch |
DAC_double_mode_dma_sinewave |
DAC_double_mode_dma_squarewave |
DAC_one_dac_dma_escalator |
DAC_one_dac_noisewave |
DAC_two_dac_trianglewave |
DEBUG_tmr |
DMA_data_to_gpio |
DMAMUX_genertor_exint |
DMAMUX_synchronization_exint |
DMA_flash_to_sram |
► DVP_ov2640_capture |
LCD_device_type |
ADDRESS_of_data_and_command |
LCD_reset_line |
XMC_lcd_exported_functions |
► DVP_ov5640_capture |
LCD_device_type |
ADDRESS_of_data_and_command |
LCD_reset_line |
XMC_lcd_exported_functions |
Ov5640_library_peripheral_info |
Ov5640_library_exported_functions |
EDMA_continuous_mode |
EDMA_dmamux_genertor_exint |
EDMA_dmamux_synchronization_exint |
EDMA_flash_to_sram |
EDMA_i2s_halfduplex_edma_doublebuffer |
EDMA_link_list_mode |
EDMA_two_dimension_mode |
ERTC_bpr_domain |
ERTC_calendar |
ERTC_lick_calibration |
ERTC_tamper |
ERTC_time_stamp |
ERTC_wakeup_timer |
EXINT_exint_config |
EXINT_exint_software_trigger |
FLASH_fap_enable |
► FLASH_write_read |
FLASH_write_read_functions |
GPIO_io_toggle |
GPIO_led_toggle |
_GPIO_swjtag_mux |
GPIO_swjtag_mux |
I2C_communication_dma |
I2C_communication_int |
I2C_communication_poll |
I2C_communication_smbus |
I2C_eeprom |
I2S_fullduplex_dma |
I2S_halfduplex_dma |
I2S_halfduplex_interrupt |
I2S_spii2s_switch_halfduplex_polling |
IRTMR_output |
PWC_deepsleep_ertc_alarm |
PWC_deepsleep_ertc_tamper |
PWC_deepsleep_ertc_wakeup |
PWC_ldo_set |
PWC_power_voltage_monitor |
PWC_sleep_tmr2 |
PWC_sleep_usart1 |
_PWC_standby_ertc_alarm |
PWC_standby_ertc_alarm |
PWC_standby_wakeup_pin |
QSPI_command_port_using_dma |
QSPI_command_port_using_dma_and_pem |
QSPI_command_port_using_dma_in_qpi_mode |
QSPI_command_port_using_interrupt |
QSPI_command_port_using_polling |
QSPI_command_port_using_rdsr_sw |
QSPI_xip_port_write_read |
SCFG_mem_map_sel |
► SD_mmc_card |
SDIO_instance_definition |
SDIO_exported_types |
SDIO_command_index_definition |
SDIO_paremeters_definition |
SDIO_response_definition |
SDIO_command_class_definition |
SDIO_cmd8_definition |
SDIO_mmc_extend_definition |
SDIO_interrupt_flags_definition |
SDIO_exported_functions |
SD_mmc_card |
► SDIO_fatfs |
SDIO_instance_definition |
SDIO_exported_types |
SDIO_command_index_definition |
SDIO_paremeters_definition |
SDIO_response_definition |
SDIO_command_class_definition |
SDIO_cmd8_definition |
SDIO_mmc_extend_definition |
SDIO_interrupt_flags_definition |
SDIO_exported_functions |
SPI_crc_transfer_polling |
SPI_fullduplex_polling |
SPI_halfduplex_interrupt |
SPI_halfduplex_transceiver_switch |
SPI_only_receive_mode_polling |
SPI_ti_fullduplex_dma |
SPI_use_jtagpin_hardwarecs_dma |
► SPI_w25q_flash |
SPI_flash_cs_pin_definition |
SPI_flash_id_definition |
SPI_flash_operation_definition |
SPI_flash_exported_functions |
SRAM_extend_sram |
TMR_6_steps |
TMR_7_pwm_output |
TMR_cascade_synchro |
TMR_complementary_signals |
TMR_dma |
TMR_dma_burst |
TMR_encoder_tmr2 |
TMR_external_clock |
TMR_hall_xor_tmr2 |
TMR_hang_mode |
TMR_input_capture |
TMR_oc_high |
TMR_oc_low |
TMR_oc_toggle_tmr3 |
TMR_oc_toggle_tmr9 |
TMR_one_cycle |
TMR_parallel_synchro |
TMR_pwm_input |
TMR_pwm_input_dma |
TMR_pwm_output_simulate |
TMR_pwm_output_tmr10 |
TMR_pwm_output_tmr3 |
TMR_timer_base |
TMR_tmr1_synchro |
TMR_tmr2_32bit |
USART_half_duplex |
USART_hw_flow_control |
USART_idle_detection |
USART_interrupt |
USART_irda |
USART_polling |
USART_printf |
USART_receiver_mute |
_USART_rs485 |
USART_smartcard |
USART_synchronous |
USART_transfer_by_dma_interrupt |
USART_transfer_by_dma_polling |
USART_tx_rx_swap |
► USB_device_audio |
USB_device_audio_codec_reg_definition |
USB_device_audio_codec_pin_definition |
USB_device_audio_codec_exported_functions |
► USB_device_audio_hid |
USB_device_audio_hid_codec_reg_definition |
USB_device_audio_hid_codec_pin_definition |
USB_device_audio_hid_codec_exported_functions |
USB_device_composite_vcp_keyboard |
USB_device_msc |
USB_device_composite_vcp_msc |
_USB_device_cdc_msc |
USB_device_custom_hid |
USB_device_keyboard |
USB_device_mouse |
USB_device_otg1_host_otg2_device_demo |
USB_device_printer |
USB_device_two_otg_device_demo |
_USB_device_virtaul_comport |
USB_device_virtaul_comport |
► USB_device_virtual_msc_iap |
USB_device_virtual_msc_iap_definition |
USB_host_hid |
USB_host_msc |
USB_host_two_otg_host_demo |
WDT_wdt_reset |
WDT_WDT_standby |
WWDT_wwdt_reset |
► XMC_lcd_8bit |
ADDRESS_of_data_and_command |
LCD_reset_line |
XMC_lcd_exported_functions |
► XMC_lcd_touch_16bit |
TOUCH_device_type |
TOUCH_exported_functions |
LCD_device_type |
ADDRESS_of_data_and_command |
LCD_reset_line |
XMC_lcd_exported_functions |
► XMC_nand_ecc |
NAND_id_define |
NAND_address_define |
NAND_area_define |
XMC_nand_memory_command |
XMC_nand_status |
XMC_nand_parameters |
XMC_nand_address_computation |
XMC_nand_ecc_functions |
► XMC_nand |
NAND_id_define |
NAND_address_define |
NAND_area_define |
XMC_nand_memory_command |
XMC_nand_status |
XMC_nand_parameters |
XMC_nand_address_computation |
XMC_nand_functions |
XMC_nor_flash |
XMC_psram |
XMC_sdram_basic |
XMC_sdram_dma |
XMC_sram |
► AT32F435_periph_template |
Library_configuration |
System_clock_configuration |
LED_toggle |
► AT32F437_periph_examples |
USB_device_vcp_loopback |
ACC_calibration |
ADC_combine_mode_ordinary_shift_twoslave_dma3 |
ADC_combine_mode_ordinary_shift_twoslave_dma4 |
ADC_combine_mode_ordinary_smlt_oneslave_dma2 |
ADC_combine_mode_ordinary_smlt_oneslave_edma |
ADC_combine_mode_ordinary_smlt_twoslave_dma1 |
ADC_combine_mode_ordinary_smlt_twoslave_dma5 |
ADC_combine_mode_preempt_interltrig_twoslave |
ADC_conversion_abort |
ADC_current_vref_value_check |
ADC_edma_double_buffer |
ADC_exint_trigger_partitioned |
ADC_internal_temperature_sensor |
ADC_ordinary_preempt_oversampling |
ADC_software_trigger_repeat |
ADC_tmr_trigger_automatic_preempted |
ADC_use_polling_get_conversion_data |
ADC_vbat_monitor |
ADC_voltage_monitoring |
CAN_communication_mode |
CAN_filter |
CAN_loopback_mode |
CORTEX_m4_bit_band |
System_clock_configuration |
CORTEX_m4_cmsis_dsp |
► CORTEX_m4_fpu |
JULIA_fpu_functions |
CORTEX_m4_systick_interrupt |
CRC_calculation |
CRM_clock_failure_detection |
CRM_pll_parameter_calculate |
CRM_sysclk_switch |
DAC_double_mode_dma_sinewave |
DAC_double_mode_dma_squarewave |
DAC_one_dac_dma_escalator |
DAC_one_dac_noisewave |
DAC_two_dac_trianglewave |
DEBUG_tmr |
DMA_data_to_gpio |
DMAMUX_genertor_exint |
DMAMUX_synchronization_exint |
DMA_flash_to_sram |
► DVP_ov2640_capture |
LCD_device_type |
ADDRESS_of_data_and_command |
LCD_reset_line |
XMC_lcd_exported_functions |
► DVP_ov5640_capture |
LCD_device_type |
ADDRESS_of_data_and_command |
LCD_reset_line |
XMC_lcd_exported_functions |
Ov5640_library_peripheral_info |
Ov5640_library_exported_functions |
EDMA_continuous_mode |
EDMA_dmamux_genertor_exint |
EDMA_dmamux_synchronization_exint |
EDMA_flash_to_sram |
EDMA_i2s_halfduplex_edma_doublebuffer |
EDMA_link_list_mode |
EDMA_two_dimension_mode |
► EMAC_dns_client |
Network_configuration_prototype |
Network_configuration |
► EMAC_http_server |
Network_configuration_prototype |
Filesystem |
Network_configuration |
► EMAC_iperf |
Iperf_prototype |
Network_configuration_prototype |
Network_configuration |
► EMAC_mqtt_client |
Network_configuration_prototype |
Network_configuration |
► EMAC_tcp_client |
TCP_instance_definition |
TCP_client_prototype |
Network_configuration_prototype |
Network_configuration |
► EMAC_tcp_server |
TCP_server_definition |
TCP_server_prototype |
Network_configuration_prototype |
Network_configuration |
► EMAC_telnet |
TELENT_instance_definition |
TELNET_prototype |
Network_configuration_prototype |
Network_configuration |
► EMAC_wake_on_lan |
Network_configuration_prototype |
Network_configuration |
ERTC_bpr_domain |
ERTC_calendar |
ERTC_lick_calibration |
ERTC_tamper |
ERTC_time_stamp |
ERTC_wakeup_timer |
EXINT_exint_config |
EXINT_exint_software_trigger |
FLASH_fap_enable |
► FLASH_write_read |
FLASH_write_read_functions |
GPIO_io_toggle |
GPIO_led_toggle |
_GPIO_swjtag_mux |
GPIO_swjtag_mux |
I2C_communication_dma |
I2C_communication_int |
I2C_communication_poll |
I2C_communication_smbus |
I2C_eeprom |
I2S_fullduplex_dma |
I2S_halfduplex_dma |
I2S_halfduplex_interrupt |
I2S_spii2s_switch_halfduplex_polling |
IRTMR_output |
PWC_deepsleep_ertc_alarm |
PWC_deepsleep_ertc_tamper |
PWC_deepsleep_ertc_wakeup |
PWC_ldo_set |
PWC_power_voltage_monitor |
PWC_sleep_tmr2 |
PWC_sleep_usart1 |
_PWC_standby_ertc_alarm |
PWC_standby_ertc_alarm |
PWC_standby_wakeup_pin |
QSPI_command_port_using_dma |
QSPI_command_port_using_dma_and_pem |
QSPI_command_port_using_dma_in_qpi_mode |
QSPI_command_port_using_interrupt |
QSPI_command_port_using_polling |
QSPI_command_port_using_rdsr_sw |
QSPI_xip_port_write_read |
SCFG_mem_map_sel |
► SD_mmc_card |
SDIO_instance_definition |
SDIO_exported_types |
SDIO_command_index_definition |
SDIO_paremeters_definition |
SDIO_response_definition |
SDIO_command_class_definition |
SDIO_cmd8_definition |
SDIO_mmc_extend_definition |
SDIO_interrupt_flags_definition |
SDIO_exported_functions |
SD_mmc_card |
► SDIO_fatfs |
SDIO_instance_definition |
SDIO_exported_types |
SDIO_command_index_definition |
SDIO_paremeters_definition |
SDIO_response_definition |
SDIO_command_class_definition |
SDIO_cmd8_definition |
SDIO_mmc_extend_definition |
SDIO_interrupt_flags_definition |
SDIO_exported_functions |
SPI_crc_transfer_polling |
SPI_fullduplex_polling |
SPI_halfduplex_interrupt |
SPI_halfduplex_transceiver_switch |
SPI_only_receive_mode_polling |
SPI_ti_fullduplex_dma |
SPI_use_jtagpin_hardwarecs_dma |
► SPI_w25q_flash |
SPI_flash_cs_pin_definition |
SPI_flash_id_definition |
SPI_flash_operation_definition |
SPI_flash_exported_functions |
SRAM_extend_sram |
TMR_6_steps |
TMR_7_pwm_output |
TMR_cascade_synchro |
TMR_complementary_signals |
TMR_dma |
TMR_dma_burst |
TMR_encoder_tmr2 |
TMR_external_clock |
TMR_hall_xor_tmr2 |
TMR_hang_mode |
TMR_input_capture |
TMR_oc_high |
TMR_oc_low |
TMR_oc_toggle_tmr3 |
TMR_oc_toggle_tmr9 |
TMR_one_cycle |
TMR_parallel_synchro |
TMR_pwm_input |
TMR_pwm_input_dma |
TMR_pwm_output_simulate |
TMR_pwm_output_tmr10 |
TMR_pwm_output_tmr3 |
TMR_timer_base |
TMR_tmr1_synchro |
TMR_tmr2_32bit |
USART_half_duplex |
USART_hw_flow_control |
USART_idle_detection |
USART_interrupt |
USART_irda |
USART_polling |
USART_printf |
USART_receiver_mute |
_USART_rs485 |
USART_smartcard |
USART_synchronous |
USART_transfer_by_dma_interrupt |
USART_transfer_by_dma_polling |
USART_tx_rx_swap |
► USB_device_audio |
USB_device_audio_codec_reg_definition |
USB_device_audio_codec_pin_definition |
USB_device_audio_codec_exported_functions |
► USB_device_audio_hid |
USB_device_audio_hid_codec_reg_definition |
USB_device_audio_hid_codec_pin_definition |
USB_device_audio_hid_codec_exported_functions |
USB_device_composite_vcp_keyboard |
USB_device_msc |
USB_device_composite_vcp_msc |
_USB_device_cdc_msc |
USB_device_custom_hid |
USB_device_keyboard |
USB_device_mouse |
USB_device_otg1_host_otg2_device_demo |
USB_device_printer |
USB_device_two_otg_device_demo |
_USB_device_virtaul_comport |
USB_device_virtaul_comport |
► USB_device_virtual_msc_iap |
USB_device_virtual_msc_iap_definition |
USB_host_hid |
USB_host_msc |
USB_host_two_otg_host_demo |
WDT_wdt_reset |
WDT_WDT_standby |
WWDT_wwdt_reset |
► XMC_lcd_8bit |
ADDRESS_of_data_and_command |
LCD_reset_line |
XMC_lcd_exported_functions |
► XMC_lcd_touch_16bit |
TOUCH_device_type |
TOUCH_exported_functions |
LCD_device_type |
ADDRESS_of_data_and_command |
LCD_reset_line |
XMC_lcd_exported_functions |
► XMC_nand_ecc |
NAND_id_define |
NAND_address_define |
NAND_area_define |
XMC_nand_memory_command |
XMC_nand_status |
XMC_nand_parameters |
XMC_nand_address_computation |
XMC_nand_ecc_functions |
► XMC_nand |
NAND_id_define |
NAND_address_define |
NAND_area_define |
XMC_nand_memory_command |
XMC_nand_status |
XMC_nand_parameters |
XMC_nand_address_computation |
XMC_nand_functions |
XMC_nor_flash |
XMC_psram |
XMC_sdram_basic |
XMC_sdram_dma |
XMC_sram |
_USB_device_hid_app_led3 |
_USB_device_hid_iap |
► AT32F437_periph_template |
Library_configuration |
System_clock_configuration |
LED_toggle |
► AT32F435_437_periph_template |
Library_configuration |
► UTILITIES_examples |
FreeRTOS_demo |
► GEN_random_number_demo |
ERTC_asseed_definition |
GEN_random_number_demo_exported_functions |
► Bootloader |
Bootloader_address_definition |
Bootloader_exported_functions |
Bootloader_flag_definition |
Bootloader_exported_types |
Bootloader_definition |
QSPI_flash_algorithm_for_iar |
Qspi_algorithm_for_keil |
QSPI_flash_algorithm_for_keil |
SLIB_project_l0 |
SLIB_project_l1 |
► IAP_app_led3_toggle |
IAP_app_led3_address_definition |
IAP_app_led3_flag_definition |
IAP_app_led3_exported_functions |
IAP_bootloader |
► IAP_app_led4_toggle |
IAP_app_led3_address_definition |
IAP_app_led3_flag_definition |
IAP_app_led3_exported_functions |
USB_IAP_app_led3_toggle |
USB_IAP_app_led4_toggle |
USB_IAP_bootloader |
► EMAC_IAP_app_led3_toggle |
App_led3_definition |
App_led3_exported_functions |
► EMAC_IAP_bootloader |
Bootloader_definition |
EMAC_IAP_bootloader_exported_functions |
Bootloader_exported_functions |


AT32F435/437 Firmwary Library: CMSIS

Modules
CMSIS

Modules

AT32F435_437
AT32F435_437_system

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: AT32F435_437

Modules
AT32F435_437
CMSIS

Modules

Library_configuration_section
Configuration_section_for_cmsis
Exported_types
Exported_macro
Peripheral_memory_map

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: Library_configuration_section

Macros
Library_configuration_section
CMSIS » AT32F435_437

Macros

#define | __AT32F435_437_LIBRARY_VERSION_MAJOR (0x02)
at32f435_437 standard peripheral library version number More...
#define | __AT32F435_437_LIBRARY_VERSION_MIDDLE (0x00)
#define | __AT32F435_437_LIBRARY_VERSION_MINOR (0x09)
#define | __AT32F435_437_LIBRARY_VERSION_RC (0x00)
#define | __AT32F435_437_LIBRARY_VERSION

Detailed Description

Macro Definition Documentation

◆ __AT32F435_437_LIBRARY_VERSION

#define __AT32F435_437_LIBRARY_VERSION
Value:
((__AT32F435_437_LIBRARY_VERSION_MAJOR << 24) | \
(__AT32F435_437_LIBRARY_VERSION_MIDDLE << 16) | \
(__AT32F435_437_LIBRARY_VERSION_MINOR << 8) | \
(__AT32F435_437_LIBRARY_VERSION_RC))
__AT32F435_437_LIBRARY_VERSION_MAJOR
#define __AT32F435_437_LIBRARY_VERSION_MAJOR
at32f435_437 standard peripheral library version number
Definition: at32f435_437.h:101
__AT32F435_437_LIBRARY_VERSION_MINOR
#define __AT32F435_437_LIBRARY_VERSION_MINOR
Definition: at32f435_437.h:103
__AT32F435_437_LIBRARY_VERSION_MIDDLE
#define __AT32F435_437_LIBRARY_VERSION_MIDDLE
Definition: at32f435_437.h:102
__AT32F435_437_LIBRARY_VERSION_RC
#define __AT32F435_437_LIBRARY_VERSION_RC
Definition: at32f435_437.h:104

Definition at line 105 of file at32f435_437.h.

◆ __AT32F435_437_LIBRARY_VERSION_MAJOR

#define __AT32F435_437_LIBRARY_VERSION_MAJOR (0x02)

at32f435_437 standard peripheral library version number

tip: to avoid modifying this file each time you need to switch between these devices, you can define the device in your toolchain compiler preprocessor. [31:24] major version

Definition at line 101 of file at32f435_437.h.

◆ __AT32F435_437_LIBRARY_VERSION_MIDDLE

#define __AT32F435_437_LIBRARY_VERSION_MIDDLE (0x00)

[23:16] middle version

Definition at line 102 of file at32f435_437.h.

◆ __AT32F435_437_LIBRARY_VERSION_MINOR

#define __AT32F435_437_LIBRARY_VERSION_MINOR (0x09)

[15:8] minor version

Definition at line 103 of file at32f435_437.h.

◆ __AT32F435_437_LIBRARY_VERSION_RC

#define __AT32F435_437_LIBRARY_VERSION_RC (0x00)

[7:0] release candidate

Definition at line 104 of file at32f435_437.h.


AT32F435/437 Firmwary Library: Configuration_section_for_cmsis

Macros | Typedefs | Enumerations
Configuration_section_for_cmsis
CMSIS » AT32F435_437

Macros

#define | __CM4_REV 0x0001U
configuration of the cortex-m4 processor and core peripherals More...
#define | __MPU_PRESENT 1
#define | __NVIC_PRIO_BITS 4
#define | __Vendor_SysTickConfig 0
#define | __FPU_PRESENT 1U

Typedefs

typedef enum IRQn IRQn_Type
at32f435_437 interrupt number definition, according to the selected device in library_configuration_section More...

Enumerations

enum IRQn {
Reset_IRQn = -15 , NonMaskableInt_IRQn = -14 , HardFault_IRQn = -13 , MemoryManagement_IRQn = -12 ,
BusFault_IRQn = -11 , UsageFault_IRQn = -10 , SVCall_IRQn = -5 , DebugMonitor_IRQn = -4 ,
PendSV_IRQn = -2 , SysTick_IRQn = -1 , WWDT_IRQn = 0 , PVM_IRQn = 1 ,
TAMP_STAMP_IRQn = 2 , ERTC_WKUP_IRQn = 3 , FLASH_IRQn = 4 , CRM_IRQn = 5 ,
EXINT0_IRQn = 6 , EXINT1_IRQn = 7 , EXINT2_IRQn = 8 , EXINT3_IRQn = 9 ,
EXINT4_IRQn = 10 , EDMA_Stream1_IRQn = 11 , EDMA_Stream2_IRQn = 12 , EDMA_Stream3_IRQn = 13 ,
EDMA_Stream4_IRQn = 14 , EDMA_Stream5_IRQn = 15 , EDMA_Stream6_IRQn = 16 , EDMA_Stream7_IRQn = 17 ,
ADC1_2_3_IRQn = 18 , CAN1_TX_IRQn = 19 , CAN1_RX0_IRQn = 20 , CAN1_RX1_IRQn = 21 ,
CAN1_SE_IRQn = 22 , EXINT9_5_IRQn = 23 , TMR1_BRK_TMR9_IRQn = 24 , TMR1_OVF_TMR10_IRQn = 25 ,
TMR1_TRG_HALL_TMR11_IRQn = 26 , TMR1_CH_IRQn = 27 , TMR2_GLOBAL_IRQn = 28 , TMR3_GLOBAL_IRQn = 29 ,
TMR4_GLOBAL_IRQn = 30 , I2C1_EVT_IRQn = 31 , I2C1_ERR_IRQn = 32 , I2C2_EVT_IRQn = 33 ,
I2C2_ERR_IRQn = 34 , SPI1_IRQn = 35 , SPI2_I2S2EXT_IRQn = 36 , USART1_IRQn = 37 ,
USART2_IRQn = 38 , USART3_IRQn = 39 , EXINT15_10_IRQn = 40 , ERTCAlarm_IRQn = 41 ,
OTGFS1_WKUP_IRQn = 42 , TMR8_BRK_TMR12_IRQn = 43 , TMR8_OVF_TMR13_IRQn = 44 , TMR8_TRG_HALL_TMR14_IRQn = 45 ,
TMR8_CH_IRQn = 46 , EDMA_Stream8_IRQn = 47 , XMC_IRQn = 48 , SDIO1_IRQn = 49 ,
TMR5_GLOBAL_IRQn = 50 , SPI3_I2S3EXT_IRQn = 51 , UART4_IRQn = 52 , UART5_IRQn = 53 ,
TMR6_DAC_GLOBAL_IRQn = 54 , TMR7_GLOBAL_IRQn = 55 , DMA1_Channel1_IRQn = 56 , DMA1_Channel2_IRQn = 57 ,
DMA1_Channel3_IRQn = 58 , DMA1_Channel4_IRQn = 59 , DMA1_Channel5_IRQn = 60 , CAN2_TX_IRQn = 63 ,
CAN2_RX0_IRQn = 64 , CAN2_RX1_IRQn = 65 , CAN2_SE_IRQn = 66 , OTGFS1_IRQn = 67 ,
DMA1_Channel6_IRQn = 68 , DMA1_Channel7_IRQn = 69 , USART6_IRQn = 71 , I2C3_EVT_IRQn = 72 ,
I2C3_ERR_IRQn = 73 , OTGFS2_WKUP_IRQn = 76 , OTGFS2_IRQn = 77 , DVP_IRQn = 78 ,
FPU_IRQn = 81 , UART7_IRQn = 82 , UART8_IRQn = 83 , SPI4_IRQn = 84 ,
QSPI2_IRQn = 91 , QSPI1_IRQn = 92 , DMAMUX_IRQn = 94 , SDIO2_IRQn = 102 ,
ACC_IRQn = 103 , TMR20_BRK_IRQn = 104 , TMR20_OVF_IRQn = 105 , TMR20_TRG_HALL_IRQn = 106 ,
TMR20_CH_IRQn = 107 , DMA2_Channel1_IRQn = 108 , DMA2_Channel2_IRQn = 109 , DMA2_Channel3_IRQn = 110 ,
DMA2_Channel4_IRQn = 111 , DMA2_Channel5_IRQn = 112 , DMA2_Channel6_IRQn = 113 , DMA2_Channel7_IRQn = 114
}
at32f435_437 interrupt number definition, according to the selected device in library_configuration_section More...

Detailed Description

Macro Definition Documentation

◆ __CM4_REV

#define __CM4_REV 0x0001U

configuration of the cortex-m4 processor and core peripherals

core revision r0p1

Definition at line 121 of file at32f435_437.h.

◆ __FPU_PRESENT

#define __FPU_PRESENT 1U

fpu present

Definition at line 125 of file at32f435_437.h.

◆ __MPU_PRESENT

#define __MPU_PRESENT 1

mpu present

Definition at line 122 of file at32f435_437.h.

◆ __NVIC_PRIO_BITS

#define __NVIC_PRIO_BITS 4

at32 uses 4 bits for the priority levels

Definition at line 123 of file at32f435_437.h.

◆ __Vendor_SysTickConfig

#define __Vendor_SysTickConfig 0

set to 1 if different systick config is used

Definition at line 124 of file at32f435_437.h.

Typedef Documentation

◆ IRQn_Type

typedef enum IRQn IRQn_Type

at32f435_437 interrupt number definition, according to the selected device in library_configuration_section

Enumeration Type Documentation

◆ IRQn

enum IRQn

at32f435_437 interrupt number definition, according to the selected device in library_configuration_section

Enumerator
Reset_IRQn | 1 reset vector, invoked on power up and warm reset
NonMaskableInt_IRQn | 2 non maskable interrupt
HardFault_IRQn | 3 hard fault, all classes of fault
MemoryManagement_IRQn | 4 cortex-m4 memory management interrupt
BusFault_IRQn | 5 cortex-m4 bus fault interrupt
UsageFault_IRQn | 6 cortex-m4 usage fault interrupt
SVCall_IRQn | 11 cortex-m4 sv call interrupt
DebugMonitor_IRQn | 12 cortex-m4 debug monitor interrupt
PendSV_IRQn | 14 cortex-m4 pend sv interrupt
SysTick_IRQn | 15 cortex-m4 system tick interrupt
WWDT_IRQn | window watchdog timer interrupt
PVM_IRQn | pvm through exint line detection interrupt
TAMP_STAMP_IRQn | tamper and timestamp interrupts through the exint line
ERTC_WKUP_IRQn | ertc wakeup through the exint line
FLASH_IRQn | flash global interrupt
CRM_IRQn | crm global interrupt
EXINT0_IRQn | exint line0 interrupt
EXINT1_IRQn | exint line1 interrupt
EXINT2_IRQn | exint line2 interrupt
EXINT3_IRQn | exint line3 interrupt
EXINT4_IRQn | exint line4 interrupt
EDMA_Stream1_IRQn | edma stream 1 global interrupt
EDMA_Stream2_IRQn | edma stream 2 global interrupt
EDMA_Stream3_IRQn | edma stream 3 global interrupt
EDMA_Stream4_IRQn | edma stream 4 global interrupt
EDMA_Stream5_IRQn | edma stream 5 global interrupt
EDMA_Stream6_IRQn | edma stream 6 global interrupt
EDMA_Stream7_IRQn | edma stream 7 global interrupt
ADC1_2_3_IRQn | adc1 adc2 and adc3 global interrupt
CAN1_TX_IRQn | can1 tx interrupts
CAN1_RX0_IRQn | can1 rx0 interrupts
CAN1_RX1_IRQn | can1 rx1 interrupt
CAN1_SE_IRQn | can1 se interrupt
EXINT9_5_IRQn | external line[9:5] interrupts
TMR1_BRK_TMR9_IRQn | tmr1 brake interrupt
TMR1_OVF_TMR10_IRQn | tmr1 overflow interrupt
TMR1_TRG_HALL_TMR11_IRQn | tmr1 trigger and hall interrupt
TMR1_CH_IRQn | tmr1 channel interrupt
TMR2_GLOBAL_IRQn | tmr2 global interrupt
TMR3_GLOBAL_IRQn | tmr3 global interrupt
TMR4_GLOBAL_IRQn | tmr4 global interrupt
I2C1_EVT_IRQn | i2c1 event interrupt
I2C1_ERR_IRQn | i2c1 error interrupt
I2C2_EVT_IRQn | i2c2 event interrupt
I2C2_ERR_IRQn | i2c2 error interrupt
SPI1_IRQn | spi1 global interrupt
SPI2_I2S2EXT_IRQn | spi2 global interrupt
USART1_IRQn | usart1 global interrupt
USART2_IRQn | usart2 global interrupt
USART3_IRQn | usart3 global interrupt
EXINT15_10_IRQn | external line[15:10] interrupts
ERTCAlarm_IRQn | ertc alarm through exint line interrupt
OTGFS1_WKUP_IRQn | otgfs1 wakeup from suspend through exint line interrupt
TMR8_BRK_TMR12_IRQn | tmr8 brake interrupt
TMR8_OVF_TMR13_IRQn | tmr8 overflow interrupt
TMR8_TRG_HALL_TMR14_IRQn | tmr8 trigger and hall interrupt
TMR8_CH_IRQn | tmr8 channel interrupt
EDMA_Stream8_IRQn | edma stream 8 global interrupt
XMC_IRQn | xmc global interrupt
SDIO1_IRQn | sdio global interrupt
TMR5_GLOBAL_IRQn | tmr5 global interrupt
SPI3_I2S3EXT_IRQn | spi3 global interrupt
UART4_IRQn | uart4 global interrupt
UART5_IRQn | uart5 global interrupt
TMR6_DAC_GLOBAL_IRQn | tmr6 and dac global interrupt
TMR7_GLOBAL_IRQn | tmr7 global interrupt
DMA1_Channel1_IRQn | dma1 channel 0 global interrupt
DMA1_Channel2_IRQn | dma1 channel 1 global interrupt
DMA1_Channel3_IRQn | dma1 channel 2 global interrupt
DMA1_Channel4_IRQn | dma1 channel 3 global interrupt
DMA1_Channel5_IRQn | dma1 channel 4 global interrupt
CAN2_TX_IRQn | can2 tx interrupt
CAN2_RX0_IRQn | can2 rx0 interrupt
CAN2_RX1_IRQn | can2 rx1 interrupt
CAN2_SE_IRQn | can2 se interrupt
OTGFS1_IRQn | otgfs1 interrupt
DMA1_Channel6_IRQn | dma1 channel 5 global interrupt
DMA1_Channel7_IRQn | dma1 channel 6 global interrupt
USART6_IRQn | usart6 interrupt
I2C3_EVT_IRQn | i2c3 event interrupt
I2C3_ERR_IRQn | i2c3 error interrupt
OTGFS2_WKUP_IRQn | otgfs2 wakeup from suspend through exint line interrupt
OTGFS2_IRQn | otgfs2 interrupt
DVP_IRQn | dvp interrupt
FPU_IRQn | fpu interrupt
UART7_IRQn | uart7 interrupt
UART8_IRQn | uart8 interrupt
SPI4_IRQn | spi4 global interrupt
QSPI2_IRQn | qspi2 global interrupt
QSPI1_IRQn | qspi1 global interrupt
DMAMUX_IRQn | dmamux global interrupt
SDIO2_IRQn | sdio2 global interrupt
ACC_IRQn | acc interrupt
TMR20_BRK_IRQn | tmr20 brake interrupt
TMR20_OVF_IRQn | tmr20 overflow interrupt
TMR20_TRG_HALL_IRQn | tmr20 trigger and hall interrupt
TMR20_CH_IRQn | tmr20 channel interrupt
DMA2_Channel1_IRQn | dma2 channel 1 global interrupt
DMA2_Channel2_IRQn | dma2 channel 2 global interrupt
DMA2_Channel3_IRQn | dma2 channel 3 global interrupt
DMA2_Channel4_IRQn | dma2 channel 4 global interrupt
DMA2_Channel5_IRQn | dma2 channel 5 global interrupt
DMA2_Channel6_IRQn | dma2 channel 6 global interrupt
DMA2_Channel7_IRQn | dma2 channel 7 global interrupt

Definition at line 131 of file at32f435_437.h.


AT32F435/437 Firmwary Library: Exported_types

Typedefs | Enumerations
Exported_types
CMSIS » AT32F435_437

Typedefs

typedef int32_t | INT32
typedef int16_t | INT16
typedef int8_t | INT8
typedef uint32_t | UINT32
typedef uint16_t | UINT16
typedef uint8_t | UINT8
typedef int32_t | s32
typedef int16_t | s16
typedef int8_t | s8
typedef const int32_t | sc32
typedef const int16_t | sc16
typedef const int8_t | sc8
typedef __IO int32_t | vs32
typedef __IO int16_t | vs16
typedef __IO int8_t | vs8
typedef __I int32_t | vsc32
typedef __I int16_t | vsc16
typedef __I int8_t | vsc8
typedef uint32_t | u32
typedef uint16_t | u16
typedef uint8_t | u8
typedef const uint32_t | uc32
typedef const uint16_t | uc16
typedef const uint8_t | uc8
typedef __IO uint32_t | vu32
typedef __IO uint16_t | vu16
typedef __IO uint8_t | vu8
typedef __I uint32_t | vuc32
typedef __I uint16_t | vuc16
typedef __I uint8_t | vuc8

Enumerations

enum | flag_status { RESET = 0 , SET = !RESET }
enum | confirm_state { FALSE = 0 , TRUE = !FALSE }
enum | error_status { ERROR = 0 , SUCCESS = !ERROR }

Detailed Description

Typedef Documentation

◆ INT16

typedef int16_t INT16

Definition at line 340 of file at32f435_437.h.

◆ INT32

typedef int32_t INT32

Definition at line 339 of file at32f435_437.h.

◆ INT8

typedef int8_t INT8

Definition at line 341 of file at32f435_437.h.

◆ s16

typedef int16_t s16

Definition at line 347 of file at32f435_437.h.

◆ s32

typedef int32_t s32

Definition at line 346 of file at32f435_437.h.

◆ s8

typedef int8_t s8

Definition at line 348 of file at32f435_437.h.

◆ sc16

typedef const int16_t sc16

read only

Definition at line 351 of file at32f435_437.h.

◆ sc32

typedef const int32_t sc32

read only

Definition at line 350 of file at32f435_437.h.

◆ sc8

typedef const int8_t sc8

read only

Definition at line 352 of file at32f435_437.h.

◆ u16

typedef uint16_t u16

Definition at line 363 of file at32f435_437.h.

◆ u32

typedef uint32_t u32

Definition at line 362 of file at32f435_437.h.

◆ u8

typedef uint8_t u8

Definition at line 364 of file at32f435_437.h.

◆ uc16

typedef const uint16_t uc16

read only

Definition at line 367 of file at32f435_437.h.

◆ uc32

typedef const uint32_t uc32

read only

Definition at line 366 of file at32f435_437.h.

◆ uc8

typedef const uint8_t uc8

read only

Definition at line 368 of file at32f435_437.h.

◆ UINT16

typedef uint16_t UINT16

Definition at line 343 of file at32f435_437.h.

◆ UINT32

typedef uint32_t UINT32

Definition at line 342 of file at32f435_437.h.

◆ UINT8

typedef uint8_t UINT8

Definition at line 344 of file at32f435_437.h.

◆ vs16

typedef __IO int16_t vs16

Definition at line 355 of file at32f435_437.h.

◆ vs32

typedef __IO int32_t vs32

Definition at line 354 of file at32f435_437.h.

◆ vs8

typedef __IO int8_t vs8

Definition at line 356 of file at32f435_437.h.

◆ vsc16

typedef __I int16_t vsc16

read only

Definition at line 359 of file at32f435_437.h.

◆ vsc32

typedef __I int32_t vsc32

read only

Definition at line 358 of file at32f435_437.h.

◆ vsc8

typedef __I int8_t vsc8

read only

Definition at line 360 of file at32f435_437.h.

◆ vu16

typedef __IO uint16_t vu16

Definition at line 371 of file at32f435_437.h.

◆ vu32

typedef __IO uint32_t vu32

Definition at line 370 of file at32f435_437.h.

◆ vu8

typedef __IO uint8_t vu8

Definition at line 372 of file at32f435_437.h.

◆ vuc16

typedef __I uint16_t vuc16

read only

Definition at line 375 of file at32f435_437.h.

◆ vuc32

typedef __I uint32_t vuc32

read only

Definition at line 374 of file at32f435_437.h.

◆ vuc8

typedef __I uint8_t vuc8

read only

Definition at line 376 of file at32f435_437.h.

Enumeration Type Documentation

◆ confirm_state

enum confirm_state
Enumerator
FALSE
TRUE

Definition at line 379 of file at32f435_437.h.

◆ error_status

enum error_status
Enumerator
ERROR
SUCCESS

Definition at line 380 of file at32f435_437.h.

◆ flag_status

enum flag_status
Enumerator
RESET
SET

Definition at line 378 of file at32f435_437.h.


AT32F435/437 Firmwary Library: Exported_macro

Macros
Exported_macro
CMSIS » AT32F435_437

Macros

#define | REG8(addr) *(volatile uint8_t *)(addr)
#define | REG16(addr) *(volatile uint16_t *)(addr)
#define | REG32(addr) *(volatile uint32_t *)(addr)
#define | MAKE_VALUE(reg_offset, bit_num) (((reg_offset) << 16) | (bit_num & 0x1f))
#define | PERIPH_REG(periph_base, value) REG32((periph_base + (value >> 16)))
#define | PERIPH_REG_BIT(value) (0x1u << (value & 0x1f))

Detailed Description

Macro Definition Documentation

◆ MAKE_VALUE

#define MAKE_VALUE | ( | reg_offset,
 |  | bit_num
 | ) | (((reg_offset) << 16) | (bit_num & 0x1f))

Definition at line 394 of file at32f435_437.h.

◆ PERIPH_REG

#define PERIPH_REG | ( | periph_base,
 |  | value
 | ) | REG32((periph_base + (value >> 16)))

Definition at line 396 of file at32f435_437.h.

◆ PERIPH_REG_BIT

#define PERIPH_REG_BIT ( value ) (0x1u << (value & 0x1f))

Definition at line 397 of file at32f435_437.h.

◆ REG16

#define REG16 ( addr ) *(volatile uint16_t *)(addr)

Definition at line 391 of file at32f435_437.h.

◆ REG32

#define REG32 ( addr ) *(volatile uint32_t *)(addr)

Definition at line 392 of file at32f435_437.h.

◆ REG8

#define REG8 ( addr ) *(volatile uint8_t *)(addr)

Definition at line 390 of file at32f435_437.h.


AT32F435/437 Firmwary Library: Peripheral_memory_map

Macros
Peripheral_memory_map
CMSIS » AT32F435_437

Macros

#define | XMC_SDRAM_MEM_BASE ((uint32_t)0xC0000000)
#define | QSPI2_MEM_BASE ((uint32_t)0xB0000000)
#define | XMC_CARD_MEM_BASE ((uint32_t)0xA8000000)
#define | QSPI2_REG_BASE ((uint32_t)0xA0002000)
#define | QSPI1_REG_BASE ((uint32_t)0xA0001000)
#define | XMC_REG_BASE ((uint32_t)0xA0000000)
#define | XMC_BANK1_REG_BASE (XMC_REG_BASE + 0x0000)
#define | XMC_BANK2_REG_BASE (XMC_REG_BASE + 0x0060)
#define | XMC_BANK3_REG_BASE (XMC_REG_BASE + 0x0080)
#define | XMC_BANK4_REG_BASE (XMC_REG_BASE + 0x00A0)
#define | XMC_SDRAM_REG_BASE (XMC_REG_BASE + 0x0140)
#define | QSPI1_MEM_BASE ((uint32_t)0x90000000)
#define | XMC_MEM_BASE ((uint32_t)0x60000000)
#define | PERIPH_BASE ((uint32_t)0x40000000)
#define | SRAM_BB_BASE ((uint32_t)0x22000000)
#define | PERIPH_BB_BASE ((uint32_t)0x42000000)
#define | SRAM_BASE ((uint32_t)0x20000000)
#define | USD_BASE ((uint32_t)0x1FFFC000)
#define | FLASH_BASE ((uint32_t)0x08000000)
#define | DEBUG_BASE ((uint32_t)0xE0042000)
#define | APB1PERIPH_BASE (PERIPH_BASE)
#define | APB2PERIPH_BASE (PERIPH_BASE + 0x10000)
#define | AHBPERIPH1_BASE (PERIPH_BASE + 0x20000)
#define | AHBPERIPH2_BASE (PERIPH_BASE + 0x10000000)
#define | UART8_BASE (APB1PERIPH_BASE + 0x7C00)
#define | UART7_BASE (APB1PERIPH_BASE + 0x7800)
#define | DAC_BASE (APB1PERIPH_BASE + 0x7400)
#define | PWC_BASE (APB1PERIPH_BASE + 0x7000)
#define | CAN2_BASE (APB1PERIPH_BASE + 0x6800)
#define | CAN1_BASE (APB1PERIPH_BASE + 0x6400)
#define | I2C3_BASE (APB1PERIPH_BASE + 0x5C00)
#define | I2C2_BASE (APB1PERIPH_BASE + 0x5800)
#define | I2C1_BASE (APB1PERIPH_BASE + 0x5400)
#define | UART5_BASE (APB1PERIPH_BASE + 0x5000)
#define | UART4_BASE (APB1PERIPH_BASE + 0x4C00)
#define | USART3_BASE (APB1PERIPH_BASE + 0x4800)
#define | USART2_BASE (APB1PERIPH_BASE + 0x4400)
#define | SPI3_BASE (APB1PERIPH_BASE + 0x3C00)
#define | SPI2_BASE (APB1PERIPH_BASE + 0x3800)
#define | WDT_BASE (APB1PERIPH_BASE + 0x3000)
#define | WWDT_BASE (APB1PERIPH_BASE + 0x2C00)
#define | ERTC_BASE (APB1PERIPH_BASE + 0x2800)
#define | TMR14_BASE (APB1PERIPH_BASE + 0x2000)
#define | TMR13_BASE (APB1PERIPH_BASE + 0x1C00)
#define | TMR12_BASE (APB1PERIPH_BASE + 0x1800)
#define | TMR7_BASE (APB1PERIPH_BASE + 0x1400)
#define | TMR6_BASE (APB1PERIPH_BASE + 0x1000)
#define | TMR5_BASE (APB1PERIPH_BASE + 0x0C00)
#define | TMR4_BASE (APB1PERIPH_BASE + 0x0800)
#define | TMR3_BASE (APB1PERIPH_BASE + 0x0400)
#define | TMR2_BASE (APB1PERIPH_BASE + 0x0000)
#define | I2S2EXT_BASE (APB2PERIPH_BASE + 0x7800)
#define | I2S3EXT_BASE (APB2PERIPH_BASE + 0x7C00)
#define | ACC_BASE (APB2PERIPH_BASE + 0x7400)
#define | TMR20_BASE (APB2PERIPH_BASE + 0x4C00)
#define | TMR11_BASE (APB2PERIPH_BASE + 0x4800)
#define | TMR10_BASE (APB2PERIPH_BASE + 0x4400)
#define | TMR9_BASE (APB2PERIPH_BASE + 0x4000)
#define | EXINT_BASE (APB2PERIPH_BASE + 0x3C00)
#define | SCFG_BASE (APB2PERIPH_BASE + 0x3800)
#define | SPI4_BASE (APB2PERIPH_BASE + 0x3400)
#define | SPI1_BASE (APB2PERIPH_BASE + 0x3000)
#define | ADC1_BASE (APB2PERIPH_BASE + 0x2000)
#define | ADC2_BASE (APB2PERIPH_BASE + 0x2100)
#define | ADC3_BASE (APB2PERIPH_BASE + 0x2200)
#define | ADCCOM_BASE (APB2PERIPH_BASE + 0x2300)
#define | USART6_BASE (APB2PERIPH_BASE + 0x1400)
#define | USART1_BASE (APB2PERIPH_BASE + 0x1000)
#define | TMR8_BASE (APB2PERIPH_BASE + 0x0400)
#define | TMR1_BASE (APB2PERIPH_BASE + 0x0000)
#define | OTGFS2_BASE (AHBPERIPH1_BASE + 0x20000)
#define | SDIO1_BASE (AHBPERIPH1_BASE + 0xC400)
#define | GPIOH_BASE (AHBPERIPH1_BASE + 0x1C00)
#define | GPIOG_BASE (AHBPERIPH1_BASE + 0x1800)
#define | GPIOF_BASE (AHBPERIPH1_BASE + 0x1400)
#define | GPIOE_BASE (AHBPERIPH1_BASE + 0x1000)
#define | GPIOD_BASE (AHBPERIPH1_BASE + 0x0C00)
#define | GPIOC_BASE (AHBPERIPH1_BASE + 0x0800)
#define | GPIOB_BASE (AHBPERIPH1_BASE + 0x0400)
#define | GPIOA_BASE (AHBPERIPH1_BASE + 0x0000)
#define | DMA1_BASE (AHBPERIPH1_BASE + 0x6400)
#define | DMA1_CHANNEL1_BASE (DMA1_BASE + 0x0008)
#define | DMA1_CHANNEL2_BASE (DMA1_BASE + 0x001C)
#define | DMA1_CHANNEL3_BASE (DMA1_BASE + 0x0030)
#define | DMA1_CHANNEL4_BASE (DMA1_BASE + 0x0044)
#define | DMA1_CHANNEL5_BASE (DMA1_BASE + 0x0058)
#define | DMA1_CHANNEL6_BASE (DMA1_BASE + 0x006C)
#define | DMA1_CHANNEL7_BASE (DMA1_BASE + 0x0080)
#define | DMA1MUX_BASE (DMA1_BASE + 0x0104)
#define | DMA1MUX_CHANNEL1_BASE (DMA1MUX_BASE)
#define | DMA1MUX_CHANNEL2_BASE (DMA1MUX_BASE + 0x0004)
#define | DMA1MUX_CHANNEL3_BASE (DMA1MUX_BASE + 0x0008)
#define | DMA1MUX_CHANNEL4_BASE (DMA1MUX_BASE + 0x000C)
#define | DMA1MUX_CHANNEL5_BASE (DMA1MUX_BASE + 0x0010)
#define | DMA1MUX_CHANNEL6_BASE (DMA1MUX_BASE + 0x0014)
#define | DMA1MUX_CHANNEL7_BASE (DMA1MUX_BASE + 0x0018)
#define | DMA1MUX_GENERATOR1_BASE (DMA1_BASE + 0x0120)
#define | DMA1MUX_GENERATOR2_BASE (DMA1_BASE + 0x0124)
#define | DMA1MUX_GENERATOR3_BASE (DMA1_BASE + 0x0128)
#define | DMA1MUX_GENERATOR4_BASE (DMA1_BASE + 0x012C)
#define | DMA2_BASE (AHBPERIPH1_BASE + 0x6600)
#define | DMA2_CHANNEL1_BASE (DMA2_BASE + 0x0008)
#define | DMA2_CHANNEL2_BASE (DMA2_BASE + 0x001C)
#define | DMA2_CHANNEL3_BASE (DMA2_BASE + 0x0030)
#define | DMA2_CHANNEL4_BASE (DMA2_BASE + 0x0044)
#define | DMA2_CHANNEL5_BASE (DMA2_BASE + 0x0058)
#define | DMA2_CHANNEL6_BASE (DMA2_BASE + 0x006C)
#define | DMA2_CHANNEL7_BASE (DMA2_BASE + 0x0080)
#define | DMA2MUX_BASE (DMA2_BASE + 0x0104)
#define | DMA2MUX_CHANNEL1_BASE (DMA2MUX_BASE)
#define | DMA2MUX_CHANNEL2_BASE (DMA2MUX_BASE + 0x0004)
#define | DMA2MUX_CHANNEL3_BASE (DMA2MUX_BASE + 0x0008)
#define | DMA2MUX_CHANNEL4_BASE (DMA2MUX_BASE + 0x000C)
#define | DMA2MUX_CHANNEL5_BASE (DMA2MUX_BASE + 0x0010)
#define | DMA2MUX_CHANNEL6_BASE (DMA2MUX_BASE + 0x0014)
#define | DMA2MUX_CHANNEL7_BASE (DMA2MUX_BASE + 0x0018)
#define | DMA2MUX_GENERATOR1_BASE (DMA2_BASE + 0x0120)
#define | DMA2MUX_GENERATOR2_BASE (DMA2_BASE + 0x0124)
#define | DMA2MUX_GENERATOR3_BASE (DMA2_BASE + 0x0128)
#define | DMA2MUX_GENERATOR4_BASE (DMA2_BASE + 0x012C)
#define | EDMA_BASE (AHBPERIPH1_BASE + 0x6000)
#define | EDMA_STREAM1_BASE (EDMA_BASE + 0x0010)
#define | EDMA_STREAM2_BASE (EDMA_BASE + 0x0028)
#define | EDMA_STREAM3_BASE (EDMA_BASE + 0x0040)
#define | EDMA_STREAM4_BASE (EDMA_BASE + 0x0058)
#define | EDMA_STREAM5_BASE (EDMA_BASE + 0x0070)
#define | EDMA_STREAM6_BASE (EDMA_BASE + 0x0088)
#define | EDMA_STREAM7_BASE (EDMA_BASE + 0x00A0)
#define | EDMA_STREAM8_BASE (EDMA_BASE + 0x00B8)
#define | EDMA_2D_BASE (EDMA_BASE + 0x00F4)
#define | EDMA_STREAM1_2D_BASE (EDMA_2D_BASE + 0x0004)
#define | EDMA_STREAM2_2D_BASE (EDMA_2D_BASE + 0x000C)
#define | EDMA_STREAM3_2D_BASE (EDMA_2D_BASE + 0x0014)
#define | EDMA_STREAM4_2D_BASE (EDMA_2D_BASE + 0x001C)
#define | EDMA_STREAM5_2D_BASE (EDMA_2D_BASE + 0x0024)
#define | EDMA_STREAM6_2D_BASE (EDMA_2D_BASE + 0x002C)
#define | EDMA_STREAM7_2D_BASE (EDMA_2D_BASE + 0x0034)
#define | EDMA_STREAM8_2D_BASE (EDMA_2D_BASE + 0x003C)
#define | EDMA_LL_BASE (EDMA_BASE + 0x00D0)
#define | EDMA_STREAM1_LL_BASE (EDMA_LL_BASE + 0x0004)
#define | EDMA_STREAM2_LL_BASE (EDMA_LL_BASE + 0x0008)
#define | EDMA_STREAM3_LL_BASE (EDMA_LL_BASE + 0x000C)
#define | EDMA_STREAM4_LL_BASE (EDMA_LL_BASE + 0x0010)
#define | EDMA_STREAM5_LL_BASE (EDMA_LL_BASE + 0x0014)
#define | EDMA_STREAM6_LL_BASE (EDMA_LL_BASE + 0x0018)
#define | EDMA_STREAM7_LL_BASE (EDMA_LL_BASE + 0x001C)
#define | EDMA_STREAM8_LL_BASE (EDMA_LL_BASE + 0x0020)
#define | EDMAMUX_BASE (EDMA_BASE + 0x0140)
#define | EDMAMUX_CHANNEL1_BASE (EDMAMUX_BASE)
#define | EDMAMUX_CHANNEL2_BASE (EDMAMUX_BASE + 0x0004)
#define | EDMAMUX_CHANNEL3_BASE (EDMAMUX_BASE + 0x0008)
#define | EDMAMUX_CHANNEL4_BASE (EDMAMUX_BASE + 0x000C)
#define | EDMAMUX_CHANNEL5_BASE (EDMAMUX_BASE + 0x0010)
#define | EDMAMUX_CHANNEL6_BASE (EDMAMUX_BASE + 0x0014)
#define | EDMAMUX_CHANNEL7_BASE (EDMAMUX_BASE + 0x0018)
#define | EDMAMUX_CHANNEL8_BASE (EDMAMUX_BASE + 0x001C)
#define | EDMAMUX_GENERATOR1_BASE (EDMA_BASE + 0x0160)
#define | EDMAMUX_GENERATOR2_BASE (EDMA_BASE + 0x0164)
#define | EDMAMUX_GENERATOR3_BASE (EDMA_BASE + 0x0168)
#define | EDMAMUX_GENERATOR4_BASE (EDMA_BASE + 0x016C)
#define | FLASH_REG_BASE (AHBPERIPH1_BASE + 0x3C00)
#define | CRM_BASE (AHBPERIPH1_BASE + 0x3800)
#define | CRC_BASE (AHBPERIPH1_BASE + 0x3000)
#define | SDIO2_BASE (AHBPERIPH2_BASE + 0x61000)
#define | DVP_BASE (AHBPERIPH2_BASE + 0x50000)
#define | OTGFS1_BASE (AHBPERIPH2_BASE + 0x00000)

Detailed Description

Macro Definition Documentation

◆ ACC_BASE

#define ACC_BASE (APB2PERIPH_BASE + 0x7400)

Definition at line 466 of file at32f435_437.h.

◆ ADC1_BASE

#define ADC1_BASE (APB2PERIPH_BASE + 0x2000)

Definition at line 475 of file at32f435_437.h.

◆ ADC2_BASE

#define ADC2_BASE (APB2PERIPH_BASE + 0x2100)

Definition at line 476 of file at32f435_437.h.

◆ ADC3_BASE

#define ADC3_BASE (APB2PERIPH_BASE + 0x2200)

Definition at line 477 of file at32f435_437.h.

◆ ADCCOM_BASE

#define ADCCOM_BASE (APB2PERIPH_BASE + 0x2300)

Definition at line 478 of file at32f435_437.h.

◆ AHBPERIPH1_BASE

#define AHBPERIPH1_BASE (PERIPH_BASE + 0x20000)

Definition at line 431 of file at32f435_437.h.

◆ AHBPERIPH2_BASE

#define AHBPERIPH2_BASE (PERIPH_BASE + 0x10000000)

Definition at line 432 of file at32f435_437.h.

◆ APB1PERIPH_BASE

#define APB1PERIPH_BASE (PERIPH_BASE)

Definition at line 429 of file at32f435_437.h.

◆ APB2PERIPH_BASE

#define APB2PERIPH_BASE (PERIPH_BASE + 0x10000)

Definition at line 430 of file at32f435_437.h.

◆ CAN1_BASE

#define CAN1_BASE (APB1PERIPH_BASE + 0x6400)

Definition at line 441 of file at32f435_437.h.

◆ CAN2_BASE

#define CAN2_BASE (APB1PERIPH_BASE + 0x6800)

Definition at line 440 of file at32f435_437.h.

◆ CRC_BASE

#define CRC_BASE (AHBPERIPH1_BASE + 0x3000)

Definition at line 588 of file at32f435_437.h.

◆ CRM_BASE

#define CRM_BASE (AHBPERIPH1_BASE + 0x3800)

Definition at line 587 of file at32f435_437.h.

◆ DAC_BASE

#define DAC_BASE (APB1PERIPH_BASE + 0x7400)

Definition at line 438 of file at32f435_437.h.

◆ DEBUG_BASE

#define DEBUG_BASE ((uint32_t)0xE0042000)

Definition at line 427 of file at32f435_437.h.

◆ DMA1_BASE

#define DMA1_BASE (AHBPERIPH1_BASE + 0x6400)

Definition at line 495 of file at32f435_437.h.

◆ DMA1_CHANNEL1_BASE

#define DMA1_CHANNEL1_BASE (DMA1_BASE + 0x0008)

Definition at line 496 of file at32f435_437.h.

◆ DMA1_CHANNEL2_BASE

#define DMA1_CHANNEL2_BASE (DMA1_BASE + 0x001C)

Definition at line 497 of file at32f435_437.h.

◆ DMA1_CHANNEL3_BASE

#define DMA1_CHANNEL3_BASE (DMA1_BASE + 0x0030)

Definition at line 498 of file at32f435_437.h.

◆ DMA1_CHANNEL4_BASE

#define DMA1_CHANNEL4_BASE (DMA1_BASE + 0x0044)

Definition at line 499 of file at32f435_437.h.

◆ DMA1_CHANNEL5_BASE

#define DMA1_CHANNEL5_BASE (DMA1_BASE + 0x0058)

Definition at line 500 of file at32f435_437.h.

◆ DMA1_CHANNEL6_BASE

#define DMA1_CHANNEL6_BASE (DMA1_BASE + 0x006C)

Definition at line 501 of file at32f435_437.h.

◆ DMA1_CHANNEL7_BASE

#define DMA1_CHANNEL7_BASE (DMA1_BASE + 0x0080)

Definition at line 502 of file at32f435_437.h.

◆ DMA1MUX_BASE

#define DMA1MUX_BASE (DMA1_BASE + 0x0104)

Definition at line 504 of file at32f435_437.h.

◆ DMA1MUX_CHANNEL1_BASE

#define DMA1MUX_CHANNEL1_BASE (DMA1MUX_BASE)

Definition at line 505 of file at32f435_437.h.

◆ DMA1MUX_CHANNEL2_BASE

#define DMA1MUX_CHANNEL2_BASE (DMA1MUX_BASE + 0x0004)

Definition at line 506 of file at32f435_437.h.

◆ DMA1MUX_CHANNEL3_BASE

#define DMA1MUX_CHANNEL3_BASE (DMA1MUX_BASE + 0x0008)

Definition at line 507 of file at32f435_437.h.

◆ DMA1MUX_CHANNEL4_BASE

#define DMA1MUX_CHANNEL4_BASE (DMA1MUX_BASE + 0x000C)

Definition at line 508 of file at32f435_437.h.

◆ DMA1MUX_CHANNEL5_BASE

#define DMA1MUX_CHANNEL5_BASE (DMA1MUX_BASE + 0x0010)

Definition at line 509 of file at32f435_437.h.

◆ DMA1MUX_CHANNEL6_BASE

#define DMA1MUX_CHANNEL6_BASE (DMA1MUX_BASE + 0x0014)

Definition at line 510 of file at32f435_437.h.

◆ DMA1MUX_CHANNEL7_BASE

#define DMA1MUX_CHANNEL7_BASE (DMA1MUX_BASE + 0x0018)

Definition at line 511 of file at32f435_437.h.

◆ DMA1MUX_GENERATOR1_BASE

#define DMA1MUX_GENERATOR1_BASE (DMA1_BASE + 0x0120)

Definition at line 513 of file at32f435_437.h.

◆ DMA1MUX_GENERATOR2_BASE

#define DMA1MUX_GENERATOR2_BASE (DMA1_BASE + 0x0124)

Definition at line 514 of file at32f435_437.h.

◆ DMA1MUX_GENERATOR3_BASE

#define DMA1MUX_GENERATOR3_BASE (DMA1_BASE + 0x0128)

Definition at line 515 of file at32f435_437.h.

◆ DMA1MUX_GENERATOR4_BASE

#define DMA1MUX_GENERATOR4_BASE (DMA1_BASE + 0x012C)

Definition at line 516 of file at32f435_437.h.

◆ DMA2_BASE

#define DMA2_BASE (AHBPERIPH1_BASE + 0x6600)

Definition at line 518 of file at32f435_437.h.

◆ DMA2_CHANNEL1_BASE

#define DMA2_CHANNEL1_BASE (DMA2_BASE + 0x0008)

Definition at line 519 of file at32f435_437.h.

◆ DMA2_CHANNEL2_BASE

#define DMA2_CHANNEL2_BASE (DMA2_BASE + 0x001C)

Definition at line 520 of file at32f435_437.h.

◆ DMA2_CHANNEL3_BASE

#define DMA2_CHANNEL3_BASE (DMA2_BASE + 0x0030)

Definition at line 521 of file at32f435_437.h.

◆ DMA2_CHANNEL4_BASE

#define DMA2_CHANNEL4_BASE (DMA2_BASE + 0x0044)

Definition at line 522 of file at32f435_437.h.

◆ DMA2_CHANNEL5_BASE

#define DMA2_CHANNEL5_BASE (DMA2_BASE + 0x0058)

Definition at line 523 of file at32f435_437.h.

◆ DMA2_CHANNEL6_BASE

#define DMA2_CHANNEL6_BASE (DMA2_BASE + 0x006C)

Definition at line 524 of file at32f435_437.h.

◆ DMA2_CHANNEL7_BASE

#define DMA2_CHANNEL7_BASE (DMA2_BASE + 0x0080)

Definition at line 525 of file at32f435_437.h.

◆ DMA2MUX_BASE

#define DMA2MUX_BASE (DMA2_BASE + 0x0104)

Definition at line 527 of file at32f435_437.h.

◆ DMA2MUX_CHANNEL1_BASE

#define DMA2MUX_CHANNEL1_BASE (DMA2MUX_BASE)

Definition at line 528 of file at32f435_437.h.

◆ DMA2MUX_CHANNEL2_BASE

#define DMA2MUX_CHANNEL2_BASE (DMA2MUX_BASE + 0x0004)

Definition at line 529 of file at32f435_437.h.

◆ DMA2MUX_CHANNEL3_BASE

#define DMA2MUX_CHANNEL3_BASE (DMA2MUX_BASE + 0x0008)

Definition at line 530 of file at32f435_437.h.

◆ DMA2MUX_CHANNEL4_BASE

#define DMA2MUX_CHANNEL4_BASE (DMA2MUX_BASE + 0x000C)

Definition at line 531 of file at32f435_437.h.

◆ DMA2MUX_CHANNEL5_BASE

#define DMA2MUX_CHANNEL5_BASE (DMA2MUX_BASE + 0x0010)

Definition at line 532 of file at32f435_437.h.

◆ DMA2MUX_CHANNEL6_BASE

#define DMA2MUX_CHANNEL6_BASE (DMA2MUX_BASE + 0x0014)

Definition at line 533 of file at32f435_437.h.

◆ DMA2MUX_CHANNEL7_BASE

#define DMA2MUX_CHANNEL7_BASE (DMA2MUX_BASE + 0x0018)

Definition at line 534 of file at32f435_437.h.

◆ DMA2MUX_GENERATOR1_BASE

#define DMA2MUX_GENERATOR1_BASE (DMA2_BASE + 0x0120)

Definition at line 536 of file at32f435_437.h.

◆ DMA2MUX_GENERATOR2_BASE

#define DMA2MUX_GENERATOR2_BASE (DMA2_BASE + 0x0124)

Definition at line 537 of file at32f435_437.h.

◆ DMA2MUX_GENERATOR3_BASE

#define DMA2MUX_GENERATOR3_BASE (DMA2_BASE + 0x0128)

Definition at line 538 of file at32f435_437.h.

◆ DMA2MUX_GENERATOR4_BASE

#define DMA2MUX_GENERATOR4_BASE (DMA2_BASE + 0x012C)

Definition at line 539 of file at32f435_437.h.

◆ DVP_BASE

#define DVP_BASE (AHBPERIPH2_BASE + 0x50000)

Definition at line 590 of file at32f435_437.h.

◆ EDMA_2D_BASE

#define EDMA_2D_BASE (EDMA_BASE + 0x00F4)

Definition at line 551 of file at32f435_437.h.

◆ EDMA_BASE

#define EDMA_BASE (AHBPERIPH1_BASE + 0x6000)

Definition at line 541 of file at32f435_437.h.

◆ EDMA_LL_BASE

#define EDMA_LL_BASE (EDMA_BASE + 0x00D0)

Definition at line 561 of file at32f435_437.h.

◆ EDMA_STREAM1_2D_BASE

#define EDMA_STREAM1_2D_BASE (EDMA_2D_BASE + 0x0004)

Definition at line 552 of file at32f435_437.h.

◆ EDMA_STREAM1_BASE

#define EDMA_STREAM1_BASE (EDMA_BASE + 0x0010)

Definition at line 542 of file at32f435_437.h.

◆ EDMA_STREAM1_LL_BASE

#define EDMA_STREAM1_LL_BASE (EDMA_LL_BASE + 0x0004)

Definition at line 562 of file at32f435_437.h.

◆ EDMA_STREAM2_2D_BASE

#define EDMA_STREAM2_2D_BASE (EDMA_2D_BASE + 0x000C)

Definition at line 553 of file at32f435_437.h.

◆ EDMA_STREAM2_BASE

#define EDMA_STREAM2_BASE (EDMA_BASE + 0x0028)

Definition at line 543 of file at32f435_437.h.

◆ EDMA_STREAM2_LL_BASE

#define EDMA_STREAM2_LL_BASE (EDMA_LL_BASE + 0x0008)

Definition at line 563 of file at32f435_437.h.

◆ EDMA_STREAM3_2D_BASE

#define EDMA_STREAM3_2D_BASE (EDMA_2D_BASE + 0x0014)

Definition at line 554 of file at32f435_437.h.

◆ EDMA_STREAM3_BASE

#define EDMA_STREAM3_BASE (EDMA_BASE + 0x0040)

Definition at line 544 of file at32f435_437.h.

◆ EDMA_STREAM3_LL_BASE

#define EDMA_STREAM3_LL_BASE (EDMA_LL_BASE + 0x000C)

Definition at line 564 of file at32f435_437.h.

◆ EDMA_STREAM4_2D_BASE

#define EDMA_STREAM4_2D_BASE (EDMA_2D_BASE + 0x001C)

Definition at line 555 of file at32f435_437.h.

◆ EDMA_STREAM4_BASE

#define EDMA_STREAM4_BASE (EDMA_BASE + 0x0058)

Definition at line 545 of file at32f435_437.h.

◆ EDMA_STREAM4_LL_BASE

#define EDMA_STREAM4_LL_BASE (EDMA_LL_BASE + 0x0010)

Definition at line 565 of file at32f435_437.h.

◆ EDMA_STREAM5_2D_BASE

#define EDMA_STREAM5_2D_BASE (EDMA_2D_BASE + 0x0024)

Definition at line 556 of file at32f435_437.h.

◆ EDMA_STREAM5_BASE

#define EDMA_STREAM5_BASE (EDMA_BASE + 0x0070)

Definition at line 546 of file at32f435_437.h.

◆ EDMA_STREAM5_LL_BASE

#define EDMA_STREAM5_LL_BASE (EDMA_LL_BASE + 0x0014)

Definition at line 566 of file at32f435_437.h.

◆ EDMA_STREAM6_2D_BASE

#define EDMA_STREAM6_2D_BASE (EDMA_2D_BASE + 0x002C)

Definition at line 557 of file at32f435_437.h.

◆ EDMA_STREAM6_BASE

#define EDMA_STREAM6_BASE (EDMA_BASE + 0x0088)

Definition at line 547 of file at32f435_437.h.

◆ EDMA_STREAM6_LL_BASE

#define EDMA_STREAM6_LL_BASE (EDMA_LL_BASE + 0x0018)

Definition at line 567 of file at32f435_437.h.

◆ EDMA_STREAM7_2D_BASE

#define EDMA_STREAM7_2D_BASE (EDMA_2D_BASE + 0x0034)

Definition at line 558 of file at32f435_437.h.

◆ EDMA_STREAM7_BASE

#define EDMA_STREAM7_BASE (EDMA_BASE + 0x00A0)

Definition at line 548 of file at32f435_437.h.

◆ EDMA_STREAM7_LL_BASE

#define EDMA_STREAM7_LL_BASE (EDMA_LL_BASE + 0x001C)

Definition at line 568 of file at32f435_437.h.

◆ EDMA_STREAM8_2D_BASE

#define EDMA_STREAM8_2D_BASE (EDMA_2D_BASE + 0x003C)

Definition at line 559 of file at32f435_437.h.

◆ EDMA_STREAM8_BASE

#define EDMA_STREAM8_BASE (EDMA_BASE + 0x00B8)

Definition at line 549 of file at32f435_437.h.

◆ EDMA_STREAM8_LL_BASE

#define EDMA_STREAM8_LL_BASE (EDMA_LL_BASE + 0x0020)

Definition at line 569 of file at32f435_437.h.

◆ EDMAMUX_BASE

#define EDMAMUX_BASE (EDMA_BASE + 0x0140)

Definition at line 571 of file at32f435_437.h.

◆ EDMAMUX_CHANNEL1_BASE

#define EDMAMUX_CHANNEL1_BASE (EDMAMUX_BASE)

Definition at line 572 of file at32f435_437.h.

◆ EDMAMUX_CHANNEL2_BASE

#define EDMAMUX_CHANNEL2_BASE (EDMAMUX_BASE + 0x0004)

Definition at line 573 of file at32f435_437.h.

◆ EDMAMUX_CHANNEL3_BASE

#define EDMAMUX_CHANNEL3_BASE (EDMAMUX_BASE + 0x0008)

Definition at line 574 of file at32f435_437.h.

◆ EDMAMUX_CHANNEL4_BASE

#define EDMAMUX_CHANNEL4_BASE (EDMAMUX_BASE + 0x000C)

Definition at line 575 of file at32f435_437.h.

◆ EDMAMUX_CHANNEL5_BASE

#define EDMAMUX_CHANNEL5_BASE (EDMAMUX_BASE + 0x0010)

Definition at line 576 of file at32f435_437.h.

◆ EDMAMUX_CHANNEL6_BASE

#define EDMAMUX_CHANNEL6_BASE (EDMAMUX_BASE + 0x0014)

Definition at line 577 of file at32f435_437.h.

◆ EDMAMUX_CHANNEL7_BASE

#define EDMAMUX_CHANNEL7_BASE (EDMAMUX_BASE + 0x0018)

Definition at line 578 of file at32f435_437.h.

◆ EDMAMUX_CHANNEL8_BASE

#define EDMAMUX_CHANNEL8_BASE (EDMAMUX_BASE + 0x001C)

Definition at line 579 of file at32f435_437.h.

◆ EDMAMUX_GENERATOR1_BASE

#define EDMAMUX_GENERATOR1_BASE (EDMA_BASE + 0x0160)

Definition at line 581 of file at32f435_437.h.

◆ EDMAMUX_GENERATOR2_BASE

#define EDMAMUX_GENERATOR2_BASE (EDMA_BASE + 0x0164)

Definition at line 582 of file at32f435_437.h.

◆ EDMAMUX_GENERATOR3_BASE

#define EDMAMUX_GENERATOR3_BASE (EDMA_BASE + 0x0168)

Definition at line 583 of file at32f435_437.h.

◆ EDMAMUX_GENERATOR4_BASE

#define EDMAMUX_GENERATOR4_BASE (EDMA_BASE + 0x016C)

Definition at line 584 of file at32f435_437.h.

◆ ERTC_BASE

#define ERTC_BASE (APB1PERIPH_BASE + 0x2800)

Definition at line 453 of file at32f435_437.h.

◆ EXINT_BASE

#define EXINT_BASE (APB2PERIPH_BASE + 0x3C00)

Definition at line 471 of file at32f435_437.h.

◆ FLASH_BASE

#define FLASH_BASE ((uint32_t)0x08000000)

Definition at line 425 of file at32f435_437.h.

◆ FLASH_REG_BASE

#define FLASH_REG_BASE (AHBPERIPH1_BASE + 0x3C00)

Definition at line 586 of file at32f435_437.h.

◆ GPIOA_BASE

#define GPIOA_BASE (AHBPERIPH1_BASE + 0x0000)

Definition at line 493 of file at32f435_437.h.

◆ GPIOB_BASE

#define GPIOB_BASE (AHBPERIPH1_BASE + 0x0400)

Definition at line 492 of file at32f435_437.h.

◆ GPIOC_BASE

#define GPIOC_BASE (AHBPERIPH1_BASE + 0x0800)

Definition at line 491 of file at32f435_437.h.

◆ GPIOD_BASE

#define GPIOD_BASE (AHBPERIPH1_BASE + 0x0C00)

Definition at line 490 of file at32f435_437.h.

◆ GPIOE_BASE

#define GPIOE_BASE (AHBPERIPH1_BASE + 0x1000)

Definition at line 489 of file at32f435_437.h.

◆ GPIOF_BASE

#define GPIOF_BASE (AHBPERIPH1_BASE + 0x1400)

Definition at line 488 of file at32f435_437.h.

◆ GPIOG_BASE

#define GPIOG_BASE (AHBPERIPH1_BASE + 0x1800)

Definition at line 487 of file at32f435_437.h.

◆ GPIOH_BASE

#define GPIOH_BASE (AHBPERIPH1_BASE + 0x1C00)

Definition at line 486 of file at32f435_437.h.

◆ I2C1_BASE

#define I2C1_BASE (APB1PERIPH_BASE + 0x5400)

Definition at line 444 of file at32f435_437.h.

◆ I2C2_BASE

#define I2C2_BASE (APB1PERIPH_BASE + 0x5800)

Definition at line 443 of file at32f435_437.h.

◆ I2C3_BASE

#define I2C3_BASE (APB1PERIPH_BASE + 0x5C00)

Definition at line 442 of file at32f435_437.h.

◆ I2S2EXT_BASE

#define I2S2EXT_BASE (APB2PERIPH_BASE + 0x7800)

Definition at line 464 of file at32f435_437.h.

◆ I2S3EXT_BASE

#define I2S3EXT_BASE (APB2PERIPH_BASE + 0x7C00)

Definition at line 465 of file at32f435_437.h.

◆ OTGFS1_BASE

#define OTGFS1_BASE (AHBPERIPH2_BASE + 0x00000)

Definition at line 591 of file at32f435_437.h.

◆ OTGFS2_BASE

#define OTGFS2_BASE (AHBPERIPH1_BASE + 0x20000)

Definition at line 484 of file at32f435_437.h.

◆ PERIPH_BASE

#define PERIPH_BASE ((uint32_t)0x40000000)

Definition at line 420 of file at32f435_437.h.

◆ PERIPH_BB_BASE

#define PERIPH_BB_BASE ((uint32_t)0x42000000)

Definition at line 422 of file at32f435_437.h.

◆ PWC_BASE

#define PWC_BASE (APB1PERIPH_BASE + 0x7000)

Definition at line 439 of file at32f435_437.h.

◆ QSPI1_MEM_BASE

#define QSPI1_MEM_BASE ((uint32_t)0x90000000)

Definition at line 418 of file at32f435_437.h.

◆ QSPI1_REG_BASE

#define QSPI1_REG_BASE ((uint32_t)0xA0001000)

Definition at line 411 of file at32f435_437.h.

◆ QSPI2_MEM_BASE

#define QSPI2_MEM_BASE ((uint32_t)0xB0000000)

Definition at line 408 of file at32f435_437.h.

◆ QSPI2_REG_BASE

#define QSPI2_REG_BASE ((uint32_t)0xA0002000)

Definition at line 410 of file at32f435_437.h.

◆ SCFG_BASE

#define SCFG_BASE (APB2PERIPH_BASE + 0x3800)

Definition at line 472 of file at32f435_437.h.

◆ SDIO1_BASE

#define SDIO1_BASE (AHBPERIPH1_BASE + 0xC400)

Definition at line 485 of file at32f435_437.h.

◆ SDIO2_BASE

#define SDIO2_BASE (AHBPERIPH2_BASE + 0x61000)

Definition at line 589 of file at32f435_437.h.

◆ SPI1_BASE

#define SPI1_BASE (APB2PERIPH_BASE + 0x3000)

Definition at line 474 of file at32f435_437.h.

◆ SPI2_BASE

#define SPI2_BASE (APB1PERIPH_BASE + 0x3800)

Definition at line 450 of file at32f435_437.h.

◆ SPI3_BASE

#define SPI3_BASE (APB1PERIPH_BASE + 0x3C00)

Definition at line 449 of file at32f435_437.h.

◆ SPI4_BASE

#define SPI4_BASE (APB2PERIPH_BASE + 0x3400)

Definition at line 473 of file at32f435_437.h.

◆ SRAM_BASE

#define SRAM_BASE ((uint32_t)0x20000000)

Definition at line 423 of file at32f435_437.h.

◆ SRAM_BB_BASE

#define SRAM_BB_BASE ((uint32_t)0x22000000)

Definition at line 421 of file at32f435_437.h.

◆ TMR10_BASE

#define TMR10_BASE (APB2PERIPH_BASE + 0x4400)

Definition at line 469 of file at32f435_437.h.

◆ TMR11_BASE

#define TMR11_BASE (APB2PERIPH_BASE + 0x4800)

Definition at line 468 of file at32f435_437.h.

◆ TMR12_BASE

#define TMR12_BASE (APB1PERIPH_BASE + 0x1800)

Definition at line 456 of file at32f435_437.h.

◆ TMR13_BASE

#define TMR13_BASE (APB1PERIPH_BASE + 0x1C00)

Definition at line 455 of file at32f435_437.h.

◆ TMR14_BASE

#define TMR14_BASE (APB1PERIPH_BASE + 0x2000)

Definition at line 454 of file at32f435_437.h.

◆ TMR1_BASE

#define TMR1_BASE (APB2PERIPH_BASE + 0x0000)

Definition at line 482 of file at32f435_437.h.

◆ TMR20_BASE

#define TMR20_BASE (APB2PERIPH_BASE + 0x4C00)

Definition at line 467 of file at32f435_437.h.

◆ TMR2_BASE

#define TMR2_BASE (APB1PERIPH_BASE + 0x0000)

Definition at line 462 of file at32f435_437.h.

◆ TMR3_BASE

#define TMR3_BASE (APB1PERIPH_BASE + 0x0400)

Definition at line 461 of file at32f435_437.h.

◆ TMR4_BASE

#define TMR4_BASE (APB1PERIPH_BASE + 0x0800)

Definition at line 460 of file at32f435_437.h.

◆ TMR5_BASE

#define TMR5_BASE (APB1PERIPH_BASE + 0x0C00)

Definition at line 459 of file at32f435_437.h.

◆ TMR6_BASE

#define TMR6_BASE (APB1PERIPH_BASE + 0x1000)

Definition at line 458 of file at32f435_437.h.

◆ TMR7_BASE

#define TMR7_BASE (APB1PERIPH_BASE + 0x1400)

Definition at line 457 of file at32f435_437.h.

◆ TMR8_BASE

#define TMR8_BASE (APB2PERIPH_BASE + 0x0400)

Definition at line 481 of file at32f435_437.h.

◆ TMR9_BASE

#define TMR9_BASE (APB2PERIPH_BASE + 0x4000)

Definition at line 470 of file at32f435_437.h.

◆ UART4_BASE

#define UART4_BASE (APB1PERIPH_BASE + 0x4C00)

Definition at line 446 of file at32f435_437.h.

◆ UART5_BASE

#define UART5_BASE (APB1PERIPH_BASE + 0x5000)

Definition at line 445 of file at32f435_437.h.

◆ UART7_BASE

#define UART7_BASE (APB1PERIPH_BASE + 0x7800)

Definition at line 437 of file at32f435_437.h.

◆ UART8_BASE

#define UART8_BASE (APB1PERIPH_BASE + 0x7C00)

Definition at line 436 of file at32f435_437.h.

◆ USART1_BASE

#define USART1_BASE (APB2PERIPH_BASE + 0x1000)

Definition at line 480 of file at32f435_437.h.

◆ USART2_BASE

#define USART2_BASE (APB1PERIPH_BASE + 0x4400)

Definition at line 448 of file at32f435_437.h.

◆ USART3_BASE

#define USART3_BASE (APB1PERIPH_BASE + 0x4800)

Definition at line 447 of file at32f435_437.h.

◆ USART6_BASE

#define USART6_BASE (APB2PERIPH_BASE + 0x1400)

Definition at line 479 of file at32f435_437.h.

◆ USD_BASE

#define USD_BASE ((uint32_t)0x1FFFC000)

Definition at line 424 of file at32f435_437.h.

◆ WDT_BASE

#define WDT_BASE (APB1PERIPH_BASE + 0x3000)

Definition at line 451 of file at32f435_437.h.

◆ WWDT_BASE

#define WWDT_BASE (APB1PERIPH_BASE + 0x2C00)

Definition at line 452 of file at32f435_437.h.

◆ XMC_BANK1_REG_BASE

#define XMC_BANK1_REG_BASE (XMC_REG_BASE + 0x0000)

Definition at line 413 of file at32f435_437.h.

◆ XMC_BANK2_REG_BASE

#define XMC_BANK2_REG_BASE (XMC_REG_BASE + 0x0060)

Definition at line 414 of file at32f435_437.h.

◆ XMC_BANK3_REG_BASE

#define XMC_BANK3_REG_BASE (XMC_REG_BASE + 0x0080)

Definition at line 415 of file at32f435_437.h.

◆ XMC_BANK4_REG_BASE

#define XMC_BANK4_REG_BASE (XMC_REG_BASE + 0x00A0)

Definition at line 416 of file at32f435_437.h.

◆ XMC_CARD_MEM_BASE

#define XMC_CARD_MEM_BASE ((uint32_t)0xA8000000)

Definition at line 409 of file at32f435_437.h.

◆ XMC_MEM_BASE

#define XMC_MEM_BASE ((uint32_t)0x60000000)

Definition at line 419 of file at32f435_437.h.

◆ XMC_REG_BASE

#define XMC_REG_BASE ((uint32_t)0xA0000000)

Definition at line 412 of file at32f435_437.h.

◆ XMC_SDRAM_MEM_BASE

#define XMC_SDRAM_MEM_BASE ((uint32_t)0xC0000000)

Definition at line 407 of file at32f435_437.h.

◆ XMC_SDRAM_REG_BASE

#define XMC_SDRAM_REG_BASE (XMC_REG_BASE + 0x0140)

Definition at line 417 of file at32f435_437.h.


AT32F435/437 Firmwary Library: AT32F435_437_system

Modules | Macros
AT32F435_437_system
CMSIS

Modules

AT32F435_437_system_exported_variables
AT32F435_437_system_exported_functions
AT32F435_437_system_private_defines
AT32F435_437_system_private_variables
AT32F435_437_system_private_functions

Macros

#define SystemCoreClock system_core_clock

Detailed Description

Macro Definition Documentation

◆ SystemCoreClock

#define SystemCoreClock system_core_clock

Definition at line 42 of file system_at32f435_437.h.


AT32F435/437 Firmwary Library: AT32F435_437_system_exported_variables

Variables
AT32F435_437_system_exported_variables
CMSIS » AT32F435_437_system

Variables

unsigned int system_core_clock

Detailed Description

Variable Documentation

◆ system_core_clock

unsigned int system_core_clock
extern

system clock frequency (core clock)

value of the high speed internal clock in hz system clock frequency (core clock)

Definition at line 48 of file system_at32f435_437.c.

Referenced by delay_init(), DMA1_Channel2_IRQHandler(), emac_delay(), mclk_tmr1_init(), sd_init(), sd_power_on(), system_core_clock_update(), tmr1_config(), TMR3_GLOBAL_IRQHandler(), and usb_clock48m_select().


AT32F435/437 Firmwary Library: AT32F435_437_system_exported_functions

Functions
AT32F435_437_system_exported_functions
CMSIS » AT32F435_437_system

Functions

void | SystemInit (void)
setup the microcontroller system initialize the flash interface. More...
void | system_core_clock_update (void)
update system_core_clock variable according to clock register values. the system_core_clock variable contains the core clock (hclk), it can be used by the user application to setup the systick timer or configure other parameters. More...

Detailed Description

Function Documentation

◆ system_core_clock_update()

void system_core_clock_update ( void )

update system_core_clock variable according to clock register values. the system_core_clock variable contains the core clock (hclk), it can be used by the user application to setup the systick timer or configure other parameters.

Parameters
none
Return values
none

< value of the high speed internal clock in hz

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

< value of the high speed internal clock in hz

Definition at line 114 of file system_at32f435_437.c.

Referenced by sclk_288m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_200mhz().

◆ SystemInit()

void SystemInit ( void )

setup the microcontroller system initialize the flash interface.

Note
this function should be used only after reset.
Parameters
none
Return values
none

< vector table base offset field. this value must be a multiple of 0x200.

Definition at line 64 of file system_at32f435_437.c.


AT32F435/437 Firmwary Library: AT32F435_437_system_private_defines

Macros
AT32F435_437_system_private_defines
CMSIS » AT32F435_437_system

Macros

#define VECT_TAB_OFFSET 0x0

Detailed Description

Macro Definition Documentation

◆ VECT_TAB_OFFSET

#define VECT_TAB_OFFSET 0x0

vector table base offset field. this value must be a multiple of 0x200.

Definition at line 40 of file system_at32f435_437.c.


AT32F435/437 Firmwary Library: AT32F435_437_system_private_variables

Variables
AT32F435_437_system_private_variables
CMSIS » AT32F435_437_system

Variables

unsigned int system_core_clock = ((uint32_t)8000000)

Detailed Description

Variable Documentation

◆ system_core_clock

unsigned int system_core_clock = ((uint32_t)8000000)

value of the high speed internal clock in hz system clock frequency (core clock)

Definition at line 48 of file system_at32f435_437.c.

Referenced by delay_init(), DMA1_Channel2_IRQHandler(), emac_delay(), mclk_tmr1_init(), sd_init(), sd_power_on(), system_core_clock_update(), tmr1_config(), TMR3_GLOBAL_IRQHandler(), and usb_clock48m_select().


AT32F435/437 Firmwary Library: AT32F435_437_system_private_functions

Functions
AT32F435_437_system_private_functions
CMSIS » AT32F435_437_system

Functions

void | SystemInit (void)
setup the microcontroller system initialize the flash interface. More...
void | system_core_clock_update (void)
update system_core_clock variable according to clock register values. the system_core_clock variable contains the core clock (hclk), it can be used by the user application to setup the systick timer or configure other parameters. More...

Detailed Description

Function Documentation

◆ system_core_clock_update()

void system_core_clock_update ( void )

update system_core_clock variable according to clock register values. the system_core_clock variable contains the core clock (hclk), it can be used by the user application to setup the systick timer or configure other parameters.

Parameters
none
Return values
none

< value of the high speed internal clock in hz

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

< value of the high speed internal clock in hz

Definition at line 114 of file system_at32f435_437.c.

Referenced by sclk_288m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_200mhz().

◆ SystemInit()

void SystemInit ( void )

setup the microcontroller system initialize the flash interface.

Note
this function should be used only after reset.
Parameters
none
Return values
none

< vector table base offset field. this value must be a multiple of 0x200.

Definition at line 64 of file system_at32f435_437.c.


AT32F435/437 Firmwary Library: AT32F435_437_periph_driver

Modules | Macros
AT32F435_437_periph_driver

Modules

ERTC_exported_types
ERTC_exported_functions
ACC
ACC driver modules.
ADC
ADC driver modules.
CAN
CAN driver modules.
CRC
CRC driver modules.
CRM
CRM driver modules.
DAC
DAC driver modules.
DEBUG
DEBUG driver modules.
DMA
DMA driver modules.
DVP
DVP driver modules.
EDMA
EDMA driver modules.
EMAC
EMAC driver modules.
ERTC
ERTC driver modules.
EXINT
EXINT driver modules.
FLASH
FLASH driver modules.
GPIO
GPIO driver modules.
I2C
I2C driver modules.
MISC
MISC driver modules.
PWC
PWC driver modules.
QSPI
QSPI driver modules.
SCFG
SCFG driver modules.
SDIO
SDIO driver modules.
SPI
SPI driver modules.
TMR
TMR driver modules.
USART
USART driver modules.
USB
USB driver modules.
WDT
WDT driver modules.
WWDT
WWDT driver modules.
XMC
XMC driver modules.

Macros

#define ERTC ((ertc_type *) ERTC_BASE)

Detailed Description

Macro Definition Documentation

◆ ERTC

#define ERTC ((ertc_type *) ERTC_BASE)

Definition at line 1130 of file at32f435_437_ertc.h.


AT32F435/437 Firmwary Library: ERTC_exported_types

Data Structures | Enumerations
ERTC_exported_types
AT32F435_437_periph_driver

Data Structures

struct | ertc_time_type
ertc time More...
struct | ertc_alarm_value_type
ertc alarm More...
union | ertc_reg_time_type
ertc time reg union More...
union | ertc_reg_date_type
ertc date reg union More...
union | ertc_reg_alarm_type
ertc alarm reg union More...
union | ertc_reg_scal_type
ertc scal reg union More...
union | ertc_reg_tadj_type
ertc tadj reg union More...
union | ertc_reg_tstm_type
ertc tstm reg union More...
union | ertc_reg_tsdt_type
ertc tsdt register, offset:0x34 More...
struct | ertc_type
type define ertc register all More...

Enumerations

enum | ertc_hour_mode_set_type { ERTC_HOUR_MODE_24 = 0x00 , ERTC_HOUR_MODE_12 = 0x01 }
ertc hour mode More...
enum | ertc_am_pm_type { ERTC_24H = 0x00 , ERTC_AM = 0x00 , ERTC_PM = 0x01 }
ertc 12-hour format am/pm More...
enum | ertc_week_date_select_type { ERTC_SLECT_DATE = 0x00 , ERTC_SLECT_WEEK = 0x01 }
ertc week or date select More...
enum | ertc_alarm_type { ERTC_ALA = 0x00 , ERTC_ALB = 0x01 }
ertc alarm x select More...
enum ertc_alarm_sbs_mask_type {
ERTC_ALARM_SBS_MASK_ALL = 0x00 , ERTC_ALARM_SBS_MASK_14_1 = 0x01 , ERTC_ALARM_SBS_MASK_14_2 = 0x02 , ERTC_ALARM_SBS_MASK_14_3 = 0x03 ,
ERTC_ALARM_SBS_MASK_14_4 = 0x04 , ERTC_ALARM_SBS_MASK_14_5 = 0x05 , ERTC_ALARM_SBS_MASK_14_6 = 0x06 , ERTC_ALARM_SBS_MASK_14_7 = 0x07 ,
ERTC_ALARM_SBS_MASK_14_8 = 0x08 , ERTC_ALARM_SBS_MASK_14_9 = 0x09 , ERTC_ALARM_SBS_MASK_14_10 = 0x0A , ERTC_ALARM_SBS_MASK_14_11 = 0x0B ,
ERTC_ALARM_SBS_MASK_14_12 = 0x0C , ERTC_ALARM_SBS_MASK_14_13 = 0x0D , ERTC_ALARM_SBS_MASK_14 = 0x0E , ERTC_ALARM_SBS_MASK_NONE = 0x0F
}
ertc alarm sub second mask More...
enum ertc_wakeup_clock_type {
ERTC_WAT_CLK_ERTCCLK_DIV16 = 0x00 , ERTC_WAT_CLK_ERTCCLK_DIV8 = 0x01 , ERTC_WAT_CLK_ERTCCLK_DIV4 = 0x02 , ERTC_WAT_CLK_ERTCCLK_DIV2 = 0x03 ,
ERTC_WAT_CLK_CK_B_16BITS = 0x04 , ERTC_WAT_CLK_CK_B_17BITS = 0x06
}
ertc wakeup timer clock select More...
enum | ertc_smooth_cal_period_type { ERTC_SMOOTH_CAL_PERIOD_32 = 0x00 , ERTC_SMOOTH_CAL_PERIOD_16 = 0x01 , ERTC_SMOOTH_CAL_PERIOD_8 = 0x02 }
ertc smooth calibration period More...
enum | ertc_smooth_cal_clk_add_type { ERTC_SMOOTH_CAL_CLK_ADD_0 = 0x00 , ERTC_SMOOTH_CAL_CLK_ADD_512 = 0x01 }
ertc smooth calibration clock add mode More...
enum | ertc_cal_direction_type { ERTC_CAL_DIR_POSITIVE = 0x00 , ERTC_CAL_DIR_NEGATIVE = 0x01 }
ertc calibration direction mode More...
enum | ertc_cal_output_select_type { ERTC_CAL_OUTPUT_512HZ = 0x00 , ERTC_CAL_OUTPUT_1HZ = 0x01 }
ertc calibration output mode More...
enum | ertc_time_adjust_type { ERTC_TIME_ADD_NONE = 0x00 , ERTC_TIME_ADD_1S = 0x01 }
time adjust add mode More...
enum | ertc_dst_operation_type { ERTC_DST_ADD_1H = 0x00 , ERTC_DST_DEC_1H = 0x01 }
ertc daylight saving time hour adjustment mode More...
enum | ertc_dst_save_type { ERTC_DST_SAVE_0 = 0x00 , ERTC_DST_SAVE_1 = 0x01 }
ertc daylight saving time store operation mode More...
enum | ertc_output_source_type { ERTC_OUTPUT_DISABLE = 0x00 , ERTC_OUTPUT_ALARM_A = 0x01 , ERTC_OUTPUT_ALARM_B = 0x02 , ERTC_OUTPUT_WAKEUP = 0x03 }
output source More...
enum | ertc_output_polarity_type { ERTC_OUTPUT_POLARITY_HIGH = 0x00 , ERTC_OUTPUT_POLARITY_LOW = 0x01 }
output polarity More...
enum | ertc_output_type { ERTC_OUTPUT_TYPE_OPEN_DRAIN = 0x00 , ERTC_OUTPUT_TYPE_PUSH_PULL = 0x01 }
output type More...
enum | ertc_pin_select_type { ERTC_PIN_PC13 = 0x00 , ERTC_PIN_PA0 = 0x01 }
timestamp/ tamper detection pin selection More...
enum | ertc_timestamp_valid_edge_type { ERTC_TIMESTAMP_EDGE_RISING = 0x00 , ERTC_TIMESTAMP_EDGE_FALLING = 0x01 }
ertc timestamp valid edge More...
enum | ertc_tamper_select_type { ERTC_TAMPER_1 = 0x00 , ERTC_TAMPER_2 = 0x01 }
ertc tamper x select More...
enum | ertc_tamper_precharge_type { ERTC_TAMPER_PR_1_ERTCCLK = 0x00 , ERTC_TAMPER_PR_2_ERTCCLK = 0x01 , ERTC_TAMPER_PR_4_ERTCCLK = 0x02 , ERTC_TAMPER_PR_8_ERTCCLK = 0x03 }
tamper detection pre-charge time More...
enum | ertc_tamper_filter_type { ERTC_TAMPER_FILTER_DISABLE = 0x00 , ERTC_TAMPER_FILTER_2 = 0x01 , ERTC_TAMPER_FILTER_4 = 0x02 , ERTC_TAMPER_FILTER_8 = 0x03 }
ertc tamper filter More...
enum ertc_tamper_detect_freq_type {
ERTC_TAMPER_FREQ_DIV_32768 = 0x00 , ERTC_TAMPER_FREQ_DIV_16384 = 0x01 , ERTC_TAMPER_FREQ_DIV_8192 = 0x02 , ERTC_TAMPER_FREQ_DIV_4096 = 0x03 ,
ERTC_TAMPER_FREQ_DIV_2048 = 0x04 , ERTC_TAMPER_FREQ_DIV_1024 = 0x05 , ERTC_TAMPER_FREQ_DIV_512 = 0x06 , ERTC_TAMPER_FREQ_DIV_256 = 0x07
}
ertc tamper detection frequency More...
enum | ertc_tamper_valid_edge_type { ERTC_TAMPER_EDGE_RISING = 0x00 , ERTC_TAMPER_EDGE_FALLING = 0x01 , ERTC_TAMPER_EDGE_LOW = 0x00 , ERTC_TAMPER_EDGE_HIGH = 0x01 }
ertc tamper valid edge More...
enum ertc_dt_type {
ERTC_DT1 = 0 , ERTC_DT2 = 1 , ERTC_DT3 = 2 , ERTC_DT4 = 3 ,
ERTC_DT5 = 4 , ERTC_DT6 = 5 , ERTC_DT7 = 6 , ERTC_DT8 = 7 ,
ERTC_DT9 = 8 , ERTC_DT10 = 9 , ERTC_DT11 = 10 , ERTC_DT12 = 11 ,
ERTC_DT13 = 12 , ERTC_DT14 = 13 , ERTC_DT15 = 14 , ERTC_DT16 = 15 ,
ERTC_DT17 = 16 , ERTC_DT18 = 17 , ERTC_DT19 = 18 , ERTC_DT20 = 19
}
ertc bpr register More...

Detailed Description

Enumeration Type Documentation

◆ ertc_alarm_sbs_mask_type

enum ertc_alarm_sbs_mask_type

ertc alarm sub second mask

Enumerator
ERTC_ALARM_SBS_MASK_ALL | do not match the sub-second
ERTC_ALARM_SBS_MASK_14_1 | only compare bit [0]
ERTC_ALARM_SBS_MASK_14_2 | only compare bit [1:0]
ERTC_ALARM_SBS_MASK_14_3 | only compare bit [2:0]
ERTC_ALARM_SBS_MASK_14_4 | only compare bit [3:0]
ERTC_ALARM_SBS_MASK_14_5 | only compare bit [4:0]
ERTC_ALARM_SBS_MASK_14_6 | only compare bit [5:0]
ERTC_ALARM_SBS_MASK_14_7 | only compare bit [6:0]
ERTC_ALARM_SBS_MASK_14_8 | only compare bit [7:0]
ERTC_ALARM_SBS_MASK_14_9 | only compare bit [8:0]
ERTC_ALARM_SBS_MASK_14_10 | only compare bit [9:0]
ERTC_ALARM_SBS_MASK_14_11 | only compare bit [10:0]
ERTC_ALARM_SBS_MASK_14_12 | only compare bit [11:0]
ERTC_ALARM_SBS_MASK_14_13 | only compare bit [12:0]
ERTC_ALARM_SBS_MASK_14 | only compare bit [13:0]
ERTC_ALARM_SBS_MASK_NONE | compare bit [14:0]

Definition at line 151 of file at32f435_437_ertc.h.

◆ ertc_alarm_type

enum ertc_alarm_type

ertc alarm x select

Enumerator
ERTC_ALA | select alarm a
ERTC_ALB | select alarm b

Definition at line 142 of file at32f435_437_ertc.h.

◆ ertc_am_pm_type

enum ertc_am_pm_type

ertc 12-hour format am/pm

Enumerator
ERTC_24H | 24-hour format
ERTC_AM | 12-hour format, ante meridiem
ERTC_PM | 12-hour format, meridiem

Definition at line 123 of file at32f435_437_ertc.h.

◆ ertc_cal_direction_type

enum ertc_cal_direction_type

ertc calibration direction mode

Enumerator
ERTC_CAL_DIR_POSITIVE | positive calibration
ERTC_CAL_DIR_NEGATIVE | negative calibration

Definition at line 206 of file at32f435_437_ertc.h.

◆ ertc_cal_output_select_type

enum ertc_cal_output_select_type

ertc calibration output mode

Enumerator
ERTC_CAL_OUTPUT_512HZ | output 512 hz
ERTC_CAL_OUTPUT_1HZ | output 1 hz

Definition at line 215 of file at32f435_437_ertc.h.

◆ ertc_dst_operation_type

enum ertc_dst_operation_type

ertc daylight saving time hour adjustment mode

Enumerator
ERTC_DST_ADD_1H | add 1 hour
ERTC_DST_DEC_1H | dec 1 hour

Definition at line 233 of file at32f435_437_ertc.h.

◆ ertc_dst_save_type

enum ertc_dst_save_type

ertc daylight saving time store operation mode

Enumerator
ERTC_DST_SAVE_0 | set the bpr register value to 0
ERTC_DST_SAVE_1 | set the bpr register value to 1

Definition at line 242 of file at32f435_437_ertc.h.

◆ ertc_dt_type

enum ertc_dt_type

ertc bpr register

Enumerator
ERTC_DT1 | bpr data register 0
ERTC_DT2 | bpr data register 1
ERTC_DT3 | bpr data register 2
ERTC_DT4 | bpr data register 3
ERTC_DT5 | bpr data register 4
ERTC_DT6 | bpr data register 5
ERTC_DT7 | bpr data register 6
ERTC_DT8 | bpr data register 7
ERTC_DT9 | bpr data register 8
ERTC_DT10 | bpr data register 9
ERTC_DT11 | bpr data register 10
ERTC_DT12 | bpr data register 11
ERTC_DT13 | bpr data register 12
ERTC_DT14 | bpr data register 13
ERTC_DT15 | bpr data register 14
ERTC_DT16 | bpr data register 15
ERTC_DT17 | bpr data register 16
ERTC_DT18 | bpr data register 17
ERTC_DT19 | bpr data register 18
ERTC_DT20 | bpr data register 19

Definition at line 355 of file at32f435_437_ertc.h.

◆ ertc_hour_mode_set_type

enum ertc_hour_mode_set_type

ertc hour mode

Enumerator
ERTC_HOUR_MODE_24 | 24-hour format
ERTC_HOUR_MODE_12 | 12-hour format

Definition at line 114 of file at32f435_437_ertc.h.

◆ ertc_output_polarity_type

enum ertc_output_polarity_type

output polarity

Enumerator
ERTC_OUTPUT_POLARITY_HIGH | when the event occurs, the output is high
ERTC_OUTPUT_POLARITY_LOW | when the event occurs, the output is low

Definition at line 262 of file at32f435_437_ertc.h.

◆ ertc_output_source_type

enum ertc_output_source_type

output source

Enumerator
ERTC_OUTPUT_DISABLE | diable output
ERTC_OUTPUT_ALARM_A | output alarm a event
ERTC_OUTPUT_ALARM_B | output alarm b event
ERTC_OUTPUT_WAKEUP | output wakeup event

Definition at line 251 of file at32f435_437_ertc.h.

◆ ertc_output_type

enum ertc_output_type

output type

Enumerator
ERTC_OUTPUT_TYPE_OPEN_DRAIN | open drain output
ERTC_OUTPUT_TYPE_PUSH_PULL | push pull output

Definition at line 271 of file at32f435_437_ertc.h.

◆ ertc_pin_select_type

enum ertc_pin_select_type

timestamp/ tamper detection pin selection

Enumerator
ERTC_PIN_PC13 | pc13 is used as timestamp detection pin
ERTC_PIN_PA0 | pa0 is used as timestamp detection pin

Definition at line 280 of file at32f435_437_ertc.h.

◆ ertc_smooth_cal_clk_add_type

enum ertc_smooth_cal_clk_add_type

ertc smooth calibration clock add mode

Enumerator
ERTC_SMOOTH_CAL_CLK_ADD_0 | do not increase clock
ERTC_SMOOTH_CAL_CLK_ADD_512 | add 512 clocks

Definition at line 197 of file at32f435_437_ertc.h.

◆ ertc_smooth_cal_period_type

enum ertc_smooth_cal_period_type

ertc smooth calibration period

Enumerator
ERTC_SMOOTH_CAL_PERIOD_32 | 32 second calibration period
ERTC_SMOOTH_CAL_PERIOD_16 | 16 second calibration period
ERTC_SMOOTH_CAL_PERIOD_8 | 8 second calibration period

Definition at line 187 of file at32f435_437_ertc.h.

◆ ertc_tamper_detect_freq_type

enum ertc_tamper_detect_freq_type

ertc tamper detection frequency

Enumerator
ERTC_TAMPER_FREQ_DIV_32768 | ERTC_CLK / 32768
ERTC_TAMPER_FREQ_DIV_16384 | ERTC_CLK / 16384
ERTC_TAMPER_FREQ_DIV_8192 | ERTC_CLK / 8192
ERTC_TAMPER_FREQ_DIV_4096 | ERTC_CLK / 4096
ERTC_TAMPER_FREQ_DIV_2048 | ERTC_CLK / 2048
ERTC_TAMPER_FREQ_DIV_1024 | ERTC_CLK / 1024
ERTC_TAMPER_FREQ_DIV_512 | ERTC_CLK / 512
ERTC_TAMPER_FREQ_DIV_256 | ERTC_CLK / 256

Definition at line 329 of file at32f435_437_ertc.h.

◆ ertc_tamper_filter_type

enum ertc_tamper_filter_type

ertc tamper filter

Enumerator
ERTC_TAMPER_FILTER_DISABLE | disable filter function
ERTC_TAMPER_FILTER_2 | 2 consecutive samples arw valid, effective tamper event
ERTC_TAMPER_FILTER_4 | 4 consecutive samples arw valid, effective tamper event
ERTC_TAMPER_FILTER_8 | 8 consecutive samples arw valid, effective tamper event

Definition at line 318 of file at32f435_437_ertc.h.

◆ ertc_tamper_precharge_type

enum ertc_tamper_precharge_type

tamper detection pre-charge time

Enumerator
ERTC_TAMPER_PR_1_ERTCCLK | pre-charge time is 1 ERTC_CLK
ERTC_TAMPER_PR_2_ERTCCLK | pre-charge time is 2 ERTC_CLK
ERTC_TAMPER_PR_4_ERTCCLK | pre-charge time is 4 ERTC_CLK
ERTC_TAMPER_PR_8_ERTCCLK | pre-charge time is 8 ERTC_CLK

Definition at line 307 of file at32f435_437_ertc.h.

◆ ertc_tamper_select_type

enum ertc_tamper_select_type

ertc tamper x select

Enumerator
ERTC_TAMPER_1 | tamper 1
ERTC_TAMPER_2 | tamper 2

Definition at line 298 of file at32f435_437_ertc.h.

◆ ertc_tamper_valid_edge_type

enum ertc_tamper_valid_edge_type

ertc tamper valid edge

Enumerator
ERTC_TAMPER_EDGE_RISING | rising gedge
ERTC_TAMPER_EDGE_FALLING | falling gedge
ERTC_TAMPER_EDGE_LOW | low level
ERTC_TAMPER_EDGE_HIGH | high level

Definition at line 344 of file at32f435_437_ertc.h.

◆ ertc_time_adjust_type

enum ertc_time_adjust_type

time adjust add mode

Enumerator
ERTC_TIME_ADD_NONE | none operation
ERTC_TIME_ADD_1S | add 1 second

Definition at line 224 of file at32f435_437_ertc.h.

◆ ertc_timestamp_valid_edge_type

enum ertc_timestamp_valid_edge_type

ertc timestamp valid edge

Enumerator
ERTC_TIMESTAMP_EDGE_RISING | rising edge trigger
ERTC_TIMESTAMP_EDGE_FALLING | falling edge trigger

Definition at line 289 of file at32f435_437_ertc.h.

◆ ertc_wakeup_clock_type

enum ertc_wakeup_clock_type

ertc wakeup timer clock select

Enumerator
ERTC_WAT_CLK_ERTCCLK_DIV16 | the wake up timer clock is ERTC_CLK / 16
ERTC_WAT_CLK_ERTCCLK_DIV8 | the wake up timer clock is ERTC_CLK / 8
ERTC_WAT_CLK_ERTCCLK_DIV4 | the wake up timer clock is ERTC_CLK / 4
ERTC_WAT_CLK_ERTCCLK_DIV2 | the wake up timer clock is ERTC_CLK / 2
ERTC_WAT_CLK_CK_B_16BITS | the wake up timer clock is CK_B, wakeup counter = ERTC_WAT
ERTC_WAT_CLK_CK_B_17BITS | the wake up timer clock is CK_B, wakeup counter = ERTC_WAT + 65535

Definition at line 174 of file at32f435_437_ertc.h.

◆ ertc_week_date_select_type

enum ertc_week_date_select_type

ertc week or date select

Enumerator
ERTC_SLECT_DATE | slect date mode
ERTC_SLECT_WEEK | slect week mode

Definition at line 133 of file at32f435_437_ertc.h.


AT32F435/437 Firmwary Library: ertc_time_type Struct Reference

Data Fields
ertc_time_type Struct Reference
AT32F435_437_periph_driver » ERTC_exported_types

ertc time More...

#include <at32f435_437_ertc.h>

Data Fields

uint8_t | year
uint8_t | month
uint8_t | day
uint8_t | hour
uint8_t | min
uint8_t | sec
uint8_t | week
ertc_am_pm_type ampm

Detailed Description

ertc time

Definition at line 382 of file at32f435_437_ertc.h.

Field Documentation

◆ ampm

ertc_am_pm_type ertc_time_type::ampm

ante meridiem / post meridiem

Definition at line 391 of file at32f435_437_ertc.h.

Referenced by ertc_alarm_value_set(), ertc_calendar_get(), and ertc_timestamp_get().

◆ day

uint8_t ertc_time_type::day

date

Definition at line 386 of file at32f435_437_ertc.h.

Referenced by ertc_alarm_value_set(), ertc_calendar_get(), ertc_time_show(), ertc_timestamp_get(), ertc_timestamp_show(), and main().

◆ hour

uint8_t ertc_time_type::hour

hour

Definition at line 387 of file at32f435_437_ertc.h.

Referenced by ertc_alarm_value_set(), ertc_calendar_get(), ertc_time_show(), ertc_timestamp_get(), ertc_timestamp_show(), and main().

◆ min

uint8_t ertc_time_type::min

minute

Definition at line 388 of file at32f435_437_ertc.h.

Referenced by ertc_alarm_value_set(), ertc_calendar_get(), ertc_time_show(), ertc_timestamp_get(), ertc_timestamp_show(), and main().

◆ month

uint8_t ertc_time_type::month

month

Definition at line 385 of file at32f435_437_ertc.h.

Referenced by ertc_calendar_get(), ertc_time_show(), ertc_timestamp_get(), ertc_timestamp_show(), and main().

◆ sec

uint8_t ertc_time_type::sec

second

Definition at line 389 of file at32f435_437_ertc.h.

Referenced by ertc_alarm_value_set(), ertc_calendar_get(), ertc_time_show(), ertc_timestamp_get(), ertc_timestamp_show(), and main().

◆ week

uint8_t ertc_time_type::week

week

Definition at line 390 of file at32f435_437_ertc.h.

Referenced by ertc_calendar_get(), and ertc_timestamp_get().

◆ year

uint8_t ertc_time_type::year

year

Definition at line 384 of file at32f435_437_ertc.h.

Referenced by ertc_calendar_get(), ertc_time_show(), ertc_timestamp_get(), and main().

The documentation for this struct was generated from the following file:
  • at32f435_437_ertc.h


AT32F435/437 Firmwary Library: ertc_alarm_value_type Struct Reference

Data Fields
ertc_alarm_value_type Struct Reference
AT32F435_437_periph_driver » ERTC_exported_types

ertc alarm More...

#include <at32f435_437_ertc.h>

Data Fields

uint8_t | day
uint8_t | hour
uint8_t | min
uint8_t | sec
ertc_am_pm_type ampm
uint32_t | mask
uint8_t | week_date_sel
uint8_t | week

Detailed Description

ertc alarm

Definition at line 397 of file at32f435_437_ertc.h.

Field Documentation

◆ ampm

ertc_am_pm_type ertc_alarm_value_type::ampm

ante meridiem / post meridiem

Definition at line 403 of file at32f435_437_ertc.h.

Referenced by ertc_alarm_get().

◆ day

uint8_t ertc_alarm_value_type::day

date

Definition at line 399 of file at32f435_437_ertc.h.

Referenced by ertc_alarm_get().

◆ hour

uint8_t ertc_alarm_value_type::hour

hour

Definition at line 400 of file at32f435_437_ertc.h.

Referenced by ertc_alarm_get(), and ertc_alarm_show().

◆ mask

uint32_t ertc_alarm_value_type::mask

alarm mask

Definition at line 404 of file at32f435_437_ertc.h.

Referenced by ertc_alarm_get().

◆ min

uint8_t ertc_alarm_value_type::min

minute

Definition at line 401 of file at32f435_437_ertc.h.

Referenced by ertc_alarm_get(), and ertc_alarm_show().

◆ sec

uint8_t ertc_alarm_value_type::sec

second

Definition at line 402 of file at32f435_437_ertc.h.

Referenced by ertc_alarm_get(), and ertc_alarm_show().

◆ week

uint8_t ertc_alarm_value_type::week

week

Definition at line 406 of file at32f435_437_ertc.h.

Referenced by ertc_alarm_get().

◆ week_date_sel

uint8_t ertc_alarm_value_type::week_date_sel

week or date mode

Definition at line 405 of file at32f435_437_ertc.h.

Referenced by ertc_alarm_get().

The documentation for this struct was generated from the following file:
  • at32f435_437_ertc.h


AT32F435/437 Firmwary Library: ertc_reg_time_type Union Reference

Data Fields
ertc_reg_time_type Union Reference
AT32F435_437_periph_driver » ERTC_exported_types

ertc time reg union More...

#include <at32f435_437_ertc.h>

Data Fields

__IO uint32_t time
struct {
__IO uint32_t s: 7
__IO uint32_t reserved1: 1
__IO uint32_t m: 7
__IO uint32_t reserved2: 1
__IO uint32_t h: 6
__IO uint32_t ampm: 1
__IO uint32_t reserved3: 9
} time_bit

Detailed Description

ertc time reg union

Definition at line 412 of file at32f435_437_ertc.h.

Field Documentation

◆ ampm

__IO uint32_t ertc_reg_time_type::ampm

Definition at line 422 of file at32f435_437_ertc.h.

Referenced by ertc_calendar_get(), and ertc_time_set().

◆ h

__IO uint32_t ertc_reg_time_type::h

Definition at line 421 of file at32f435_437_ertc.h.

Referenced by ertc_calendar_get(), and ertc_time_set().

◆ m

__IO uint32_t ertc_reg_time_type::m

Definition at line 419 of file at32f435_437_ertc.h.

Referenced by ertc_calendar_get(), and ertc_time_set().

◆ reserved1

__IO uint32_t ertc_reg_time_type::reserved1

Definition at line 418 of file at32f435_437_ertc.h.

◆ reserved2

__IO uint32_t ertc_reg_time_type::reserved2

Definition at line 420 of file at32f435_437_ertc.h.

◆ reserved3

__IO uint32_t ertc_reg_time_type::reserved3

Definition at line 423 of file at32f435_437_ertc.h.

◆ s

__IO uint32_t ertc_reg_time_type::s

Definition at line 417 of file at32f435_437_ertc.h.

Referenced by ertc_calendar_get(), and ertc_time_set().

◆ time

__IO uint32_t ertc_reg_time_type::time

Definition at line 414 of file at32f435_437_ertc.h.

Referenced by ertc_calendar_get(), and ertc_time_set().

◆

struct { ... } ertc_reg_time_type::time_bit

Referenced by ertc_calendar_get(), and ertc_time_set().

The documentation for this union was generated from the following file:
  • at32f435_437_ertc.h


AT32F435/437 Firmwary Library: ertc_reg_date_type Union Reference

Data Fields
ertc_reg_date_type Union Reference
AT32F435_437_periph_driver » ERTC_exported_types

ertc date reg union More...

#include <at32f435_437_ertc.h>

Data Fields

__IO uint32_t date
struct {
__IO uint32_t d:6
__IO uint32_t reserved1:2
__IO uint32_t m:5
__IO uint32_t wk:3
__IO uint32_t y:8
__IO uint32_t reserved2:8
} date_bit

Detailed Description

ertc date reg union

Definition at line 430 of file at32f435_437_ertc.h.

Field Documentation

◆ d

__IO uint32_t ertc_reg_date_type::d

Definition at line 435 of file at32f435_437_ertc.h.

Referenced by ertc_calendar_get(), and ertc_date_set().

◆ date

__IO uint32_t ertc_reg_date_type::date

Definition at line 432 of file at32f435_437_ertc.h.

Referenced by ertc_calendar_get(), and ertc_date_set().

◆

struct { ... } ertc_reg_date_type::date_bit

Referenced by ertc_calendar_get(), and ertc_date_set().

◆ m

__IO uint32_t ertc_reg_date_type::m

Definition at line 437 of file at32f435_437_ertc.h.

Referenced by ertc_calendar_get(), and ertc_date_set().

◆ reserved1

__IO uint32_t ertc_reg_date_type::reserved1

Definition at line 436 of file at32f435_437_ertc.h.

◆ reserved2

__IO uint32_t ertc_reg_date_type::reserved2

Definition at line 440 of file at32f435_437_ertc.h.

◆ wk

__IO uint32_t ertc_reg_date_type::wk

Definition at line 438 of file at32f435_437_ertc.h.

Referenced by ertc_calendar_get(), and ertc_date_set().

◆ y

__IO uint32_t ertc_reg_date_type::y

Definition at line 439 of file at32f435_437_ertc.h.

Referenced by ertc_calendar_get(), and ertc_date_set().

The documentation for this union was generated from the following file:
  • at32f435_437_ertc.h


AT32F435/437 Firmwary Library: ertc_reg_alarm_type Union Reference

Data Fields
ertc_reg_alarm_type Union Reference
AT32F435_437_periph_driver » ERTC_exported_types

ertc alarm reg union More...

#include <at32f435_437_ertc.h>

Data Fields

__IO uint32_t ala
struct {
__IO uint32_t s:7
__IO uint32_t mask1:1
__IO uint32_t m:7
__IO uint32_t mask2:1
__IO uint32_t h:6
__IO uint32_t ampm:1
__IO uint32_t mask3:1
__IO uint32_t d:6
__IO uint32_t wksel:1
__IO uint32_t mask4:1
} ala_bit

Detailed Description

ertc alarm reg union

Definition at line 447 of file at32f435_437_ertc.h.

Field Documentation

◆ ala

__IO uint32_t ertc_reg_alarm_type::ala

Definition at line 449 of file at32f435_437_ertc.h.

Referenced by ertc_alarm_get(), and ertc_alarm_set().

◆

struct { ... } ertc_reg_alarm_type::ala_bit

Referenced by ertc_alarm_get(), and ertc_alarm_set().

◆ ampm

__IO uint32_t ertc_reg_alarm_type::ampm

Definition at line 457 of file at32f435_437_ertc.h.

Referenced by ertc_alarm_get(), and ertc_alarm_set().

◆ d

__IO uint32_t ertc_reg_alarm_type::d

Definition at line 459 of file at32f435_437_ertc.h.

Referenced by ertc_alarm_get(), and ertc_alarm_set().

◆ h

__IO uint32_t ertc_reg_alarm_type::h

Definition at line 456 of file at32f435_437_ertc.h.

Referenced by ertc_alarm_get(), and ertc_alarm_set().

◆ m

__IO uint32_t ertc_reg_alarm_type::m

Definition at line 454 of file at32f435_437_ertc.h.

Referenced by ertc_alarm_get(), and ertc_alarm_set().

◆ mask1

__IO uint32_t ertc_reg_alarm_type::mask1

Definition at line 453 of file at32f435_437_ertc.h.

◆ mask2

__IO uint32_t ertc_reg_alarm_type::mask2

Definition at line 455 of file at32f435_437_ertc.h.

◆ mask3

__IO uint32_t ertc_reg_alarm_type::mask3

Definition at line 458 of file at32f435_437_ertc.h.

◆ mask4

__IO uint32_t ertc_reg_alarm_type::mask4

Definition at line 461 of file at32f435_437_ertc.h.

◆ s

__IO uint32_t ertc_reg_alarm_type::s

Definition at line 452 of file at32f435_437_ertc.h.

Referenced by ertc_alarm_get(), and ertc_alarm_set().

◆ wksel

__IO uint32_t ertc_reg_alarm_type::wksel

Definition at line 460 of file at32f435_437_ertc.h.

Referenced by ertc_alarm_get().

The documentation for this union was generated from the following file:
  • at32f435_437_ertc.h


AT32F435/437 Firmwary Library: ertc_reg_scal_type Union Reference

Data Fields
ertc_reg_scal_type Union Reference
AT32F435_437_periph_driver » ERTC_exported_types

ertc scal reg union More...

#include <at32f435_437_ertc.h>

Data Fields

__IO uint32_t scal
struct {
__IO uint32_t dec:9
__IO uint32_t reserved1:4
__IO uint32_t cal16:1
__IO uint32_t cal8:1
__IO uint32_t add:1
__IO uint32_t reserved2:16
} scal_bit

Detailed Description

ertc scal reg union

Definition at line 468 of file at32f435_437_ertc.h.

Field Documentation

◆ add

__IO uint32_t ertc_reg_scal_type::add

Definition at line 477 of file at32f435_437_ertc.h.

Referenced by ertc_smooth_calibration_config().

◆ cal16

__IO uint32_t ertc_reg_scal_type::cal16

Definition at line 475 of file at32f435_437_ertc.h.

Referenced by ertc_smooth_calibration_config().

◆ cal8

__IO uint32_t ertc_reg_scal_type::cal8

Definition at line 476 of file at32f435_437_ertc.h.

Referenced by ertc_smooth_calibration_config().

◆ dec

__IO uint32_t ertc_reg_scal_type::dec

Definition at line 473 of file at32f435_437_ertc.h.

Referenced by ertc_smooth_calibration_config().

◆ reserved1

__IO uint32_t ertc_reg_scal_type::reserved1

Definition at line 474 of file at32f435_437_ertc.h.

◆ reserved2

__IO uint32_t ertc_reg_scal_type::reserved2

Definition at line 478 of file at32f435_437_ertc.h.

◆ scal

__IO uint32_t ertc_reg_scal_type::scal

Definition at line 470 of file at32f435_437_ertc.h.

Referenced by ertc_smooth_calibration_config().

◆

struct { ... } ertc_reg_scal_type::scal_bit

Referenced by ertc_smooth_calibration_config().

The documentation for this union was generated from the following file:
  • at32f435_437_ertc.h


AT32F435/437 Firmwary Library: ertc_reg_tadj_type Union Reference

Data Fields
ertc_reg_tadj_type Union Reference
AT32F435_437_periph_driver » ERTC_exported_types

ertc tadj reg union More...

#include <at32f435_437_ertc.h>

Data Fields

__IO uint32_t tadj
struct {
__IO uint32_t decsbs:15
__IO uint32_t reserved1:16
__IO uint32_t add1s:1
} tadj_bit

Detailed Description

ertc tadj reg union

Definition at line 485 of file at32f435_437_ertc.h.

Field Documentation

◆ add1s

__IO uint32_t ertc_reg_tadj_type::add1s

Definition at line 492 of file at32f435_437_ertc.h.

Referenced by ertc_time_adjust().

◆ decsbs

__IO uint32_t ertc_reg_tadj_type::decsbs

Definition at line 490 of file at32f435_437_ertc.h.

Referenced by ertc_time_adjust().

◆ reserved1

__IO uint32_t ertc_reg_tadj_type::reserved1

Definition at line 491 of file at32f435_437_ertc.h.

◆ tadj

__IO uint32_t ertc_reg_tadj_type::tadj

Definition at line 487 of file at32f435_437_ertc.h.

Referenced by ertc_time_adjust().

◆

struct { ... } ertc_reg_tadj_type::tadj_bit

Referenced by ertc_time_adjust().

The documentation for this union was generated from the following file:
  • at32f435_437_ertc.h


AT32F435/437 Firmwary Library: ertc_reg_tstm_type Union Reference

Data Fields
ertc_reg_tstm_type Union Reference
AT32F435_437_periph_driver » ERTC_exported_types

ertc tstm reg union More...

#include <at32f435_437_ertc.h>

Data Fields

__IO uint32_t tstm
struct {
__IO uint32_t s:7
__IO uint32_t reserved1:1
__IO uint32_t m:7
__IO uint32_t reserved2:1
__IO uint32_t h:6
__IO uint32_t ampm:1
__IO uint32_t reserved3:9
} tstm_bit

Detailed Description

ertc tstm reg union

Definition at line 499 of file at32f435_437_ertc.h.

Field Documentation

◆ ampm

__IO uint32_t ertc_reg_tstm_type::ampm

Definition at line 509 of file at32f435_437_ertc.h.

Referenced by ertc_timestamp_get().

◆ h

__IO uint32_t ertc_reg_tstm_type::h

Definition at line 508 of file at32f435_437_ertc.h.

Referenced by ertc_timestamp_get().

◆ m

__IO uint32_t ertc_reg_tstm_type::m

Definition at line 506 of file at32f435_437_ertc.h.

Referenced by ertc_timestamp_get().

◆ reserved1

__IO uint32_t ertc_reg_tstm_type::reserved1

Definition at line 505 of file at32f435_437_ertc.h.

◆ reserved2

__IO uint32_t ertc_reg_tstm_type::reserved2

Definition at line 507 of file at32f435_437_ertc.h.

◆ reserved3

__IO uint32_t ertc_reg_tstm_type::reserved3

Definition at line 510 of file at32f435_437_ertc.h.

◆ s

__IO uint32_t ertc_reg_tstm_type::s

Definition at line 504 of file at32f435_437_ertc.h.

Referenced by ertc_timestamp_get().

◆ tstm

__IO uint32_t ertc_reg_tstm_type::tstm

Definition at line 501 of file at32f435_437_ertc.h.

Referenced by ertc_timestamp_get().

◆

struct { ... } ertc_reg_tstm_type::tstm_bit

Referenced by ertc_timestamp_get().

The documentation for this union was generated from the following file:
  • at32f435_437_ertc.h


AT32F435/437 Firmwary Library: ertc_reg_tsdt_type Union Reference

Data Fields
ertc_reg_tsdt_type Union Reference
AT32F435_437_periph_driver » ERTC_exported_types

ertc tsdt register, offset:0x34 More...

#include <at32f435_437_ertc.h>

Data Fields

__IO uint32_t tsdt
struct {
__IO uint32_t d:6
__IO uint32_t reserved1:2
__IO uint32_t m:5
__IO uint32_t wk:3
__IO uint32_t reserved2:16
} tsdt_bit

Detailed Description

ertc tsdt register, offset:0x34

Definition at line 517 of file at32f435_437_ertc.h.

Field Documentation

◆ d

__IO uint32_t ertc_reg_tsdt_type::d

Definition at line 522 of file at32f435_437_ertc.h.

Referenced by ertc_timestamp_get().

◆ m

__IO uint32_t ertc_reg_tsdt_type::m

Definition at line 524 of file at32f435_437_ertc.h.

Referenced by ertc_timestamp_get().

◆ reserved1

__IO uint32_t ertc_reg_tsdt_type::reserved1

Definition at line 523 of file at32f435_437_ertc.h.

◆ reserved2

__IO uint32_t ertc_reg_tsdt_type::reserved2

Definition at line 526 of file at32f435_437_ertc.h.

◆ tsdt

__IO uint32_t ertc_reg_tsdt_type::tsdt

Definition at line 519 of file at32f435_437_ertc.h.

Referenced by ertc_timestamp_get().

◆

struct { ... } ertc_reg_tsdt_type::tsdt_bit

Referenced by ertc_timestamp_get().

◆ wk

__IO uint32_t ertc_reg_tsdt_type::wk

Definition at line 525 of file at32f435_437_ertc.h.

Referenced by ertc_timestamp_get().

The documentation for this union was generated from the following file:
  • at32f435_437_ertc.h


AT32F435/437 Firmwary Library: ertc_type Struct Reference

Data Fields
ertc_type Struct Reference
AT32F435_437_periph_driver » ERTC_exported_types

type define ertc register all More...

#include <at32f435_437_ertc.h>

Data Fields

union {
__IO uint32_t time
struct {
__IO uint32_t s: 7
__IO uint32_t reserved1: 1
__IO uint32_t m: 7
__IO uint32_t reserved2: 1
__IO uint32_t h: 6
__IO uint32_t ampm: 1
__IO uint32_t reserved3: 9
} time_bit
};
ertc time register, offset:0x00 More...
union {
__IO uint32_t date
struct {
__IO uint32_t d:6
__IO uint32_t reserved1:2
__IO uint32_t m:5
__IO uint32_t wk:3
__IO uint32_t y:8
__IO uint32_t reserved2:8
} date_bit
};
ertc date register, offset:0x04 More...
union {
__IO uint32_t ctrl
struct {
__IO uint32_t watclk:3
__IO uint32_t tsedg:1
__IO uint32_t rcden:1
__IO uint32_t dren:1
__IO uint32_t hm:1
__IO uint32_t ccalen:1
__IO uint32_t alaen:1
__IO uint32_t alben:1
__IO uint32_t waten:1
__IO uint32_t tsen:1
__IO uint32_t alaien:1
__IO uint32_t albien:1
__IO uint32_t watien:1
__IO uint32_t tsien:1
__IO uint32_t add1h:1
__IO uint32_t dec1h:1
__IO uint32_t bpr:1
__IO uint32_t calosel:1
__IO uint32_t outp:1
__IO uint32_t outsel:2
__IO uint32_t caloen:1
__IO uint32_t reserved1:8
} ctrl_bit
};
ertc ctrl register, offset:0x08 More...
union {
__IO uint32_t sts
struct {
__IO uint32_t alawf:1
__IO uint32_t albwf:1
__IO uint32_t watwf:1
__IO uint32_t tadjf:1
__IO uint32_t initf:1
__IO uint32_t updf:1
__IO uint32_t imf:1
__IO uint32_t imen:1
__IO uint32_t alaf:1
__IO uint32_t albf:1
__IO uint32_t watf:1
__IO uint32_t tsf:1
__IO uint32_t tsof:1
__IO uint32_t tp1f:1
__IO uint32_t tp2f:1
__IO uint32_t reserved1:1
__IO uint32_t calupdf:1
__IO uint32_t reserved2:15
} sts_bit
};
ertc sts register, offset:0x0C More...
union {
__IO uint32_t div
struct {
__IO uint32_t divb:15
__IO uint32_t reserved1:1
__IO uint32_t diva:7
__IO uint32_t reserved2:9
} div_bit
};
ertc div register, offset:0x10 More...
union {
__IO uint32_t wat
struct {
__IO uint32_t val:16
__IO uint32_t reserved1:16
} wat_bit
};
ertc wat register, offset:0x14 More...
union {
__IO uint32_t ccal
struct {
__IO uint32_t calval:5
__IO uint32_t reserved1:2
__IO uint32_t caldir:1
__IO uint32_t reserved2:24
} ccal_bit
};
ertc ccal register, offset:0x18 More...
union {
__IO uint32_t ala
struct {
__IO uint32_t s:7
__IO uint32_t mask1:1
__IO uint32_t m:7
__IO uint32_t mask2:1
__IO uint32_t h:6
__IO uint32_t ampm:1
__IO uint32_t mask3:1
__IO uint32_t d:6
__IO uint32_t wksel:1
__IO uint32_t mask4:1
} ala_bit
};
ertc ala register, offset:0x1C More...
union {
__IO uint32_t alb
struct {
__IO uint32_t s:7
__IO uint32_t mask1:1
__IO uint32_t m:7
__IO uint32_t mask2:1
__IO uint32_t h:6
__IO uint32_t ampm:1
__IO uint32_t mask3:1
__IO uint32_t d:6
__IO uint32_t wksel:1
__IO uint32_t mask4:1
} alb_bit
};
ertc alb register, offset:0x20 More...
union {
__IO uint32_t wp
struct {
__IO uint32_t cmd:8
__IO uint32_t reserved1:24
} wp_bit
};
ertc wp register, offset:0x24 More...
union {
__IO uint32_t sbs
struct {
__IO uint32_t sbs:16
__IO uint32_t reserved1:16
} sbs_bit
};
ertc sbs register, offset:0x28 More...
union {
__IO uint32_t tadj
struct {
__IO uint32_t decsbs:15
__IO uint32_t reserved1:16
__IO uint32_t add1s:1
} tadj_bit
};
ertc tadj register, offset:0x2C More...
union {
__IO uint32_t tstm
struct {
__IO uint32_t s:7
__IO uint32_t reserved1:1
__IO uint32_t m:7
__IO uint32_t reserved2:1
__IO uint32_t h:6
__IO uint32_t ampm:1
__IO uint32_t reserved3:9
} tstm_bit
};
ertc tstm register, offset:0x30 More...
union {
__IO uint32_t tsdt
struct {
__IO uint32_t d:6
__IO uint32_t reserved1:2
__IO uint32_t m:5
__IO uint32_t wk:3
__IO uint32_t reserved2:16
} tsdt_bit
};
ertc tsdt register, offset:0x34 More...
union {
__IO uint32_t tssbs
struct {
__IO uint32_t sbs:16
__IO uint32_t reserved1:16
} tssbs_bit
};
ertc tssbs register, offset:0x38 More...
union {
__IO uint32_t scal
struct {
__IO uint32_t dec:9
__IO uint32_t reserved1:4
__IO uint32_t cal16:1
__IO uint32_t cal8:1
__IO uint32_t add:1
__IO uint32_t reserved2:16
} scal_bit
};
ertc scal register, offset:0x3C More...
union {
__IO uint32_t tamp
struct {
__IO uint32_t tp1en:1
__IO uint32_t tp1edg:1
__IO uint32_t tpien:1
__IO uint32_t tp2en:1
__IO uint32_t tp2edg:1
__IO uint32_t reserved1:2
__IO uint32_t tptsen:1
__IO uint32_t tpfreq:3
__IO uint32_t tpflt:2
__IO uint32_t tppr:2
__IO uint32_t tppu:1
__IO uint32_t tp1pin:1
__IO uint32_t tspin:1
__IO uint32_t outtype:1
__IO uint32_t reserved2:13
} tamp_bit
};
ertc tamp register, offset:0x40 More...
union {
__IO uint32_t alasbs
struct {
__IO uint32_t sbs:15
__IO uint32_t reserved1:9
__IO uint32_t sbsmsk:4
__IO uint32_t reserved2:4
} alasbs_bit
};
ertc alasbs register, offset:0x44 More...
union {
__IO uint32_t albsbs
struct {
__IO uint32_t sbs:15
__IO uint32_t reserved1:9
__IO uint32_t sbsmsk:4
__IO uint32_t reserved2:4
} albsbs_bit
};
ertc albsbs register, offset:0x48 More...
union {
__IO uint32_t dt1
struct {
__IO uint32_t dt:32
} dt1_bit
};
ertc dt1 register, offset:0x50 More...
union {
__IO uint32_t dt2
struct {
__IO uint32_t dt:32
} dt2_bit
};
ertc dt2 register, offset:0x54 More...
union {
__IO uint32_t dt3
struct {
__IO uint32_t dt:32
} dt3_bit
};
ertc dt3 register, offset:0x58 More...
union {
__IO uint32_t dt4
struct {
__IO uint32_t dt:32
} dt4_bit
};
ertc dt4 register, offset:0x5C More...
union {
__IO uint32_t dt5
struct {
__IO uint32_t dt:32
} dt5_bit
};
ertc dt5 register, offset:0x60 More...
union {
__IO uint32_t dt6
struct {
__IO uint32_t dt:32
} dt6_bit
};
ertc dt6 register, offset:0x64 More...
union {
__IO uint32_t dt7
struct {
__IO uint32_t dt:32
} dt7_bit
};
ertc dt7 register, offset:0x68 More...
union {
__IO uint32_t dt8
struct {
__IO uint32_t dt:32
} dt8_bit
};
ertc dt8 register, offset:0x6C More...
union {
__IO uint32_t dt9
struct {
__IO uint32_t dt:32
} dt9_bit
};
ertc dt9 register, offset:0x70 More...
union {
__IO uint32_t dt10
struct {
__IO uint32_t dt:32
} dt10_bit
};
ertc dt10 register, offset:0x74 More...
union {
__IO uint32_t dt11
struct {
__IO uint32_t dt:32
} dt11_bit
};
ertc dt11 register, offset:0x78 More...
union {
__IO uint32_t dt12
struct {
__IO uint32_t dt:32
} dt12_bit
};
ertc dt12 register, offset:0x7C More...
union {
__IO uint32_t dt13
struct {
__IO uint32_t dt:32
} dt13_bit
};
ertc dt13 register, offset:0x80 More...
union {
__IO uint32_t dt14
struct {
__IO uint32_t dt:32
} dt14_bit
};
ertc dt14 register, offset:0x84 More...
union {
__IO uint32_t dt15
struct {
__IO uint32_t dt:32
} dt15_bit
};
ertc dt15 register, offset:0x88 More...
union {
__IO uint32_t dt16
struct {
__IO uint32_t dt:32
} dt16_bit
};
ertc dt16 register, offset:0x8C More...
union {
__IO uint32_t dt17
struct {
__IO uint32_t dt:32
} dt17_bit
};
ertc dt17 register, offset:0x90 More...
union {
__IO uint32_t dt18
struct {
__IO uint32_t dt:32
} dt18_bit
};
ertc dt18 register, offset:0x94 More...
union {
__IO uint32_t dt19
struct {
__IO uint32_t dt:32
} dt19_bit
};
ertc dt19 register, offset:0x98 More...
union {
__IO uint32_t dt20
struct {
__IO uint32_t dt:32
} dt20_bit
};
ertc dt20 register, offset:0x9C More...

Detailed Description

type define ertc register all

Definition at line 533 of file at32f435_437_ertc.h.

Field Documentation

◆

union { ... } ertc_type::@614

ertc time register, offset:0x00

◆

union { ... } ertc_type::@616

ertc date register, offset:0x04

◆

union { ... } ertc_type::@618

ertc ctrl register, offset:0x08

◆

union { ... } ertc_type::@620

ertc sts register, offset:0x0C

◆

union { ... } ertc_type::@622

ertc div register, offset:0x10

◆

union { ... } ertc_type::@624

ertc wat register, offset:0x14

◆

union { ... } ertc_type::@626

ertc ccal register, offset:0x18

◆

union { ... } ertc_type::@628

ertc ala register, offset:0x1C

◆

union { ... } ertc_type::@630

ertc alb register, offset:0x20

◆

union { ... } ertc_type::@632

ertc wp register, offset:0x24

◆

union { ... } ertc_type::@634

ertc sbs register, offset:0x28

◆

union { ... } ertc_type::@636

ertc tadj register, offset:0x2C

◆

union { ... } ertc_type::@638

ertc tstm register, offset:0x30

◆

union { ... } ertc_type::@640

ertc tsdt register, offset:0x34

◆

union { ... } ertc_type::@642

ertc tssbs register, offset:0x38

◆

union { ... } ertc_type::@644

ertc scal register, offset:0x3C

◆

union { ... } ertc_type::@646

ertc tamp register, offset:0x40

◆

union { ... } ertc_type::@648

ertc alasbs register, offset:0x44

◆

union { ... } ertc_type::@650

ertc albsbs register, offset:0x48

◆

union { ... } ertc_type::@652

ertc dt1 register, offset:0x50

◆

union { ... } ertc_type::@654

ertc dt2 register, offset:0x54

◆

union { ... } ertc_type::@656

ertc dt3 register, offset:0x58

◆

union { ... } ertc_type::@658

ertc dt4 register, offset:0x5C

◆

union { ... } ertc_type::@660

ertc dt5 register, offset:0x60

◆

union { ... } ertc_type::@662

ertc dt6 register, offset:0x64

◆

union { ... } ertc_type::@664

ertc dt7 register, offset:0x68

◆

union { ... } ertc_type::@666

ertc dt8 register, offset:0x6C

◆

union { ... } ertc_type::@668

ertc dt9 register, offset:0x70

◆

union { ... } ertc_type::@670

ertc dt10 register, offset:0x74

◆

union { ... } ertc_type::@672

ertc dt11 register, offset:0x78

◆

union { ... } ertc_type::@674

ertc dt12 register, offset:0x7C

◆

union { ... } ertc_type::@676

ertc dt13 register, offset:0x80

◆

union { ... } ertc_type::@678

ertc dt14 register, offset:0x84

◆

union { ... } ertc_type::@680

ertc dt15 register, offset:0x88

◆

union { ... } ertc_type::@682

ertc dt16 register, offset:0x8C

◆

union { ... } ertc_type::@684

ertc dt17 register, offset:0x90

◆

union { ... } ertc_type::@686

ertc dt18 register, offset:0x94

◆

union { ... } ertc_type::@688

ertc dt19 register, offset:0x98

◆

union { ... } ertc_type::@690

ertc dt20 register, offset:0x9C

◆ add

__IO uint32_t ertc_type::add

Definition at line 817 of file at32f435_437_ertc.h.

◆ add1h

__IO uint32_t ertc_type::add1h

Definition at line 593 of file at32f435_437_ertc.h.

◆ add1s

__IO uint32_t ertc_type::add1s

Definition at line 754 of file at32f435_437_ertc.h.

◆ ala

__IO uint32_t ertc_type::ala

Definition at line 681 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::ala_bit

◆ alaen

__IO uint32_t ertc_type::alaen

Definition at line 585 of file at32f435_437_ertc.h.

◆ alaf

__IO uint32_t ertc_type::alaf

Definition at line 620 of file at32f435_437_ertc.h.

◆ alaien

__IO uint32_t ertc_type::alaien

Definition at line 589 of file at32f435_437_ertc.h.

◆ alasbs

__IO uint32_t ertc_type::alasbs

Definition at line 853 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::alasbs_bit

◆ alawf

__IO uint32_t ertc_type::alawf

Definition at line 612 of file at32f435_437_ertc.h.

◆ alb

__IO uint32_t ertc_type::alb

Definition at line 702 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::alb_bit

◆ alben

__IO uint32_t ertc_type::alben

Definition at line 586 of file at32f435_437_ertc.h.

◆ albf

__IO uint32_t ertc_type::albf

Definition at line 621 of file at32f435_437_ertc.h.

◆ albien

__IO uint32_t ertc_type::albien

Definition at line 590 of file at32f435_437_ertc.h.

◆ albsbs

__IO uint32_t ertc_type::albsbs

Definition at line 868 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::albsbs_bit

◆ albwf

__IO uint32_t ertc_type::albwf

Definition at line 613 of file at32f435_437_ertc.h.

◆ ampm

__IO uint32_t ertc_type::ampm

Definition at line 549 of file at32f435_437_ertc.h.

◆ bpr

__IO uint32_t ertc_type::bpr

Definition at line 595 of file at32f435_437_ertc.h.

◆ cal16

__IO uint32_t ertc_type::cal16

Definition at line 815 of file at32f435_437_ertc.h.

◆ cal8

__IO uint32_t ertc_type::cal8

Definition at line 816 of file at32f435_437_ertc.h.

◆ caldir

__IO uint32_t ertc_type::caldir

Definition at line 671 of file at32f435_437_ertc.h.

◆ caloen

__IO uint32_t ertc_type::caloen

Definition at line 599 of file at32f435_437_ertc.h.

◆ calosel

__IO uint32_t ertc_type::calosel

Definition at line 596 of file at32f435_437_ertc.h.

◆ calupdf

__IO uint32_t ertc_type::calupdf

Definition at line 628 of file at32f435_437_ertc.h.

◆ calval

__IO uint32_t ertc_type::calval

Definition at line 669 of file at32f435_437_ertc.h.

◆ ccal

__IO uint32_t ertc_type::ccal

Definition at line 666 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::ccal_bit

◆ ccalen

__IO uint32_t ertc_type::ccalen

Definition at line 584 of file at32f435_437_ertc.h.

◆ cmd

__IO uint32_t ertc_type::cmd

Definition at line 726 of file at32f435_437_ertc.h.

◆ ctrl

__IO uint32_t ertc_type::ctrl

Definition at line 576 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::ctrl_bit

◆ d

__IO uint32_t ertc_type::d

Definition at line 562 of file at32f435_437_ertc.h.

◆ date

__IO uint32_t ertc_type::date

Definition at line 559 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::date_bit

◆ dec

__IO uint32_t ertc_type::dec

Definition at line 813 of file at32f435_437_ertc.h.

◆ dec1h

__IO uint32_t ertc_type::dec1h

Definition at line 594 of file at32f435_437_ertc.h.

◆ decsbs

__IO uint32_t ertc_type::decsbs

Definition at line 752 of file at32f435_437_ertc.h.

◆ div

__IO uint32_t ertc_type::div

Definition at line 638 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::div_bit

◆ diva

__IO uint32_t ertc_type::diva

Definition at line 643 of file at32f435_437_ertc.h.

◆ divb

__IO uint32_t ertc_type::divb

Definition at line 641 of file at32f435_437_ertc.h.

◆ dren

__IO uint32_t ertc_type::dren

Definition at line 582 of file at32f435_437_ertc.h.

◆ dt

__IO uint32_t ertc_type::dt

Definition at line 891 of file at32f435_437_ertc.h.

◆ dt1

__IO uint32_t ertc_type::dt1

Definition at line 888 of file at32f435_437_ertc.h.

◆ dt10

__IO uint32_t ertc_type::dt10

Definition at line 996 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::dt10_bit

◆ dt11

__IO uint32_t ertc_type::dt11

Definition at line 1008 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::dt11_bit

◆ dt12

__IO uint32_t ertc_type::dt12

Definition at line 1020 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::dt12_bit

◆ dt13

__IO uint32_t ertc_type::dt13

Definition at line 1032 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::dt13_bit

◆ dt14

__IO uint32_t ertc_type::dt14

Definition at line 1044 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::dt14_bit

◆ dt15

__IO uint32_t ertc_type::dt15

Definition at line 1056 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::dt15_bit

◆ dt16

__IO uint32_t ertc_type::dt16

Definition at line 1068 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::dt16_bit

◆ dt17

__IO uint32_t ertc_type::dt17

Definition at line 1080 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::dt17_bit

◆ dt18

__IO uint32_t ertc_type::dt18

Definition at line 1092 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::dt18_bit

◆ dt19

__IO uint32_t ertc_type::dt19

Definition at line 1104 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::dt19_bit

◆

struct { ... } ertc_type::dt1_bit

◆ dt2

__IO uint32_t ertc_type::dt2

Definition at line 900 of file at32f435_437_ertc.h.

◆ dt20

__IO uint32_t ertc_type::dt20

Definition at line 1116 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::dt20_bit

◆

struct { ... } ertc_type::dt2_bit

◆ dt3

__IO uint32_t ertc_type::dt3

Definition at line 912 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::dt3_bit

◆ dt4

__IO uint32_t ertc_type::dt4

Definition at line 924 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::dt4_bit

◆ dt5

__IO uint32_t ertc_type::dt5

Definition at line 936 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::dt5_bit

◆ dt6

__IO uint32_t ertc_type::dt6

Definition at line 948 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::dt6_bit

◆ dt7

__IO uint32_t ertc_type::dt7

Definition at line 960 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::dt7_bit

◆ dt8

__IO uint32_t ertc_type::dt8

Definition at line 972 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::dt8_bit

◆ dt9

__IO uint32_t ertc_type::dt9

Definition at line 984 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::dt9_bit

◆ h

__IO uint32_t ertc_type::h

Definition at line 548 of file at32f435_437_ertc.h.

◆ hm

__IO uint32_t ertc_type::hm

Definition at line 583 of file at32f435_437_ertc.h.

◆ imen

__IO uint32_t ertc_type::imen

Definition at line 619 of file at32f435_437_ertc.h.

◆ imf

__IO uint32_t ertc_type::imf

Definition at line 618 of file at32f435_437_ertc.h.

◆ initf

__IO uint32_t ertc_type::initf

Definition at line 616 of file at32f435_437_ertc.h.

◆ m

__IO uint32_t ertc_type::m

Definition at line 546 of file at32f435_437_ertc.h.

◆ mask1

__IO uint32_t ertc_type::mask1

Definition at line 685 of file at32f435_437_ertc.h.

◆ mask2

__IO uint32_t ertc_type::mask2

Definition at line 687 of file at32f435_437_ertc.h.

◆ mask3

__IO uint32_t ertc_type::mask3

Definition at line 690 of file at32f435_437_ertc.h.

◆ mask4

__IO uint32_t ertc_type::mask4

Definition at line 693 of file at32f435_437_ertc.h.

◆ outp

__IO uint32_t ertc_type::outp

Definition at line 597 of file at32f435_437_ertc.h.

◆ outsel

__IO uint32_t ertc_type::outsel

Definition at line 598 of file at32f435_437_ertc.h.

◆ outtype

__IO uint32_t ertc_type::outtype

Definition at line 843 of file at32f435_437_ertc.h.

◆ rcden

__IO uint32_t ertc_type::rcden

Definition at line 581 of file at32f435_437_ertc.h.

◆ reserved1

__IO uint32_t ertc_type::reserved1

reserved register, offset:0x4c

Definition at line 545 of file at32f435_437_ertc.h.

◆ reserved2

__IO uint32_t ertc_type::reserved2

Definition at line 547 of file at32f435_437_ertc.h.

◆ reserved3

__IO uint32_t ertc_type::reserved3

Definition at line 550 of file at32f435_437_ertc.h.

◆ s

__IO uint32_t ertc_type::s

Definition at line 544 of file at32f435_437_ertc.h.

◆ sbs

__IO uint32_t ertc_type::sbs

Definition at line 736 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::sbs_bit

◆ sbsmsk

__IO uint32_t ertc_type::sbsmsk

Definition at line 858 of file at32f435_437_ertc.h.

◆ scal

__IO uint32_t ertc_type::scal

Definition at line 810 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::scal_bit

◆ sts

__IO uint32_t ertc_type::sts

Definition at line 609 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::sts_bit

◆ tadj

__IO uint32_t ertc_type::tadj

Definition at line 749 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::tadj_bit

◆ tadjf

__IO uint32_t ertc_type::tadjf

Definition at line 615 of file at32f435_437_ertc.h.

◆ tamp

__IO uint32_t ertc_type::tamp

Definition at line 827 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::tamp_bit

◆ time

__IO uint32_t ertc_type::time

Definition at line 541 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::time_bit

◆ tp1edg

__IO uint32_t ertc_type::tp1edg

Definition at line 831 of file at32f435_437_ertc.h.

◆ tp1en

__IO uint32_t ertc_type::tp1en

Definition at line 830 of file at32f435_437_ertc.h.

◆ tp1f

__IO uint32_t ertc_type::tp1f

Definition at line 625 of file at32f435_437_ertc.h.

◆ tp1pin

__IO uint32_t ertc_type::tp1pin

Definition at line 841 of file at32f435_437_ertc.h.

◆ tp2edg

__IO uint32_t ertc_type::tp2edg

Definition at line 834 of file at32f435_437_ertc.h.

◆ tp2en

__IO uint32_t ertc_type::tp2en

Definition at line 833 of file at32f435_437_ertc.h.

◆ tp2f

__IO uint32_t ertc_type::tp2f

Definition at line 626 of file at32f435_437_ertc.h.

◆ tpflt

__IO uint32_t ertc_type::tpflt

Definition at line 838 of file at32f435_437_ertc.h.

◆ tpfreq

__IO uint32_t ertc_type::tpfreq

Definition at line 837 of file at32f435_437_ertc.h.

◆ tpien

__IO uint32_t ertc_type::tpien

Definition at line 832 of file at32f435_437_ertc.h.

◆ tppr

__IO uint32_t ertc_type::tppr

Definition at line 839 of file at32f435_437_ertc.h.

◆ tppu

__IO uint32_t ertc_type::tppu

Definition at line 840 of file at32f435_437_ertc.h.

◆ tptsen

__IO uint32_t ertc_type::tptsen

Definition at line 836 of file at32f435_437_ertc.h.

◆ tsdt

__IO uint32_t ertc_type::tsdt

Definition at line 781 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::tsdt_bit

◆ tsedg

__IO uint32_t ertc_type::tsedg

Definition at line 580 of file at32f435_437_ertc.h.

◆ tsen

__IO uint32_t ertc_type::tsen

Definition at line 588 of file at32f435_437_ertc.h.

◆ tsf

__IO uint32_t ertc_type::tsf

Definition at line 623 of file at32f435_437_ertc.h.

◆ tsien

__IO uint32_t ertc_type::tsien

Definition at line 592 of file at32f435_437_ertc.h.

◆ tsof

__IO uint32_t ertc_type::tsof

Definition at line 624 of file at32f435_437_ertc.h.

◆ tspin

__IO uint32_t ertc_type::tspin

Definition at line 842 of file at32f435_437_ertc.h.

◆ tssbs

__IO uint32_t ertc_type::tssbs

Definition at line 797 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::tssbs_bit

◆ tstm

__IO uint32_t ertc_type::tstm

Definition at line 763 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::tstm_bit

◆ updf

__IO uint32_t ertc_type::updf

Definition at line 617 of file at32f435_437_ertc.h.

◆ val

__IO uint32_t ertc_type::val

Definition at line 656 of file at32f435_437_ertc.h.

◆ wat

__IO uint32_t ertc_type::wat

Definition at line 653 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::wat_bit

◆ watclk

__IO uint32_t ertc_type::watclk

Definition at line 579 of file at32f435_437_ertc.h.

◆ waten

__IO uint32_t ertc_type::waten

Definition at line 587 of file at32f435_437_ertc.h.

◆ watf

__IO uint32_t ertc_type::watf

Definition at line 622 of file at32f435_437_ertc.h.

◆ watien

__IO uint32_t ertc_type::watien

Definition at line 591 of file at32f435_437_ertc.h.

◆ watwf

__IO uint32_t ertc_type::watwf

Definition at line 614 of file at32f435_437_ertc.h.

◆ wk

__IO uint32_t ertc_type::wk

Definition at line 565 of file at32f435_437_ertc.h.

◆ wksel

__IO uint32_t ertc_type::wksel

Definition at line 692 of file at32f435_437_ertc.h.

◆ wp

__IO uint32_t ertc_type::wp

Definition at line 723 of file at32f435_437_ertc.h.

◆

struct { ... } ertc_type::wp_bit

◆ y

__IO uint32_t ertc_type::y

Definition at line 566 of file at32f435_437_ertc.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_ertc.h


AT32F435/437 Firmwary Library: ERTC_exported_functions

Functions
ERTC_exported_functions
AT32F435_437_periph_driver

Functions

uint8_t | ertc_num_to_bcd (uint8_t num)
number conversion to bcd code. More...
uint8_t | ertc_bcd_to_num (uint8_t bcd)
bcd code conversion to number. More...
void | ertc_write_protect_enable (void)
enable write protection. More...
void | ertc_write_protect_disable (void)
disable write protection. More...
error_status | ertc_wait_update (void)
ertc wait register update finish. More...
error_status | ertc_wait_flag (uint32_t flag, flag_status status)
ertc wait flag status. More...
error_status | ertc_init_mode_enter (void)
ertc enter init mode. More...
void | ertc_init_mode_exit (void)
ertc exit init mode. More...
error_status | ertc_reset (void)
ertc reset all register. More...
error_status | ertc_divider_set (uint16_t div_a, uint16_t div_b)
ertc division set. More...
error_status | ertc_hour_mode_set (ertc_hour_mode_set_type mode)
ertc hour mode set. More...
error_status | ertc_date_set (uint8_t year, uint8_t month, uint8_t date, uint8_t week)
set date. More...
error_status | ertc_time_set (uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
set time. More...
void | ertc_calendar_get (ertc_time_type *time)
get calendar More...
uint32_t | ertc_sub_second_get (void)
get current sub second. More...
void | ertc_alarm_mask_set (ertc_alarm_type alarm_x, uint32_t mask)
set which bits are irrelevant to the alarm match. More...
void | ertc_alarm_week_date_select (ertc_alarm_type alarm_x, ertc_week_date_select_type wk)
alarm week or date mode select. More...
void | ertc_alarm_set (ertc_alarm_type alarm_x, uint8_t week_date, uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
set alarm. More...
void | ertc_alarm_sub_second_set (ertc_alarm_type alarm_x, uint32_t value, ertc_alarm_sbs_mask_type mask)
set alarm sub second. More...
error_status | ertc_alarm_enable (ertc_alarm_type alarm_x, confirm_state new_state)
enable or disable alarm clock. More...
void | ertc_alarm_get (ertc_alarm_type alarm_x, ertc_alarm_value_type *alarm)
get alarm value. More...
uint32_t | ertc_alarm_sub_second_get (ertc_alarm_type alarm_x)
get alarm sub second. More...
void | ertc_wakeup_clock_set (ertc_wakeup_clock_type clock)
set wakeup timer clock. More...
void | ertc_wakeup_counter_set (uint32_t counter)
set wakeup counter. More...
uint16_t | ertc_wakeup_counter_get (void)
get wakeup counter. More...
error_status | ertc_wakeup_enable (confirm_state new_state)
enable or disable wakeup timer. More...
error_status | ertc_smooth_calibration_config (ertc_smooth_cal_period_type period, ertc_smooth_cal_clk_add_type clk_add, uint32_t clk_dec)
config the smooth calibration. More...
error_status | ertc_coarse_calibration_set (ertc_cal_direction_type dir, uint32_t value)
set the coarse digital calibration. More...
error_status | ertc_coarse_calibration_enable (confirm_state new_state)
enable or disable coarse calibration. More...
void | ertc_cal_output_select (ertc_cal_output_select_type output)
calibration output source select. More...
void | ertc_cal_output_enable (confirm_state new_state)
enable or disable calibration output. More...
error_status | ertc_time_adjust (ertc_time_adjust_type add1s, uint32_t decsbs)
adjust the time. More...
void | ertc_daylight_set (ertc_dst_operation_type operation, ertc_dst_save_type save)
config the daylight saving time. More...
uint8_t | ertc_daylight_bpr_get (void)
get the bpr value. More...
error_status | ertc_refer_clock_detect_enable (confirm_state new_state)
enable or disable refer clock detect. More...
void | ertc_direct_read_enable (confirm_state new_state)
enable or disable direct read mode. More...
void | ertc_output_set (ertc_output_source_type source, ertc_output_polarity_type polarity, ertc_output_type type)
set the output mode. More...
void | ertc_timestamp_pin_select (ertc_pin_select_type pin)
timestamp detection pin selection. More...
void | ertc_timestamp_valid_edge_set (ertc_timestamp_valid_edge_type edge)
set the timestamp valid edge. More...
void | ertc_timestamp_enable (confirm_state new_state)
enable or disable timestamp. More...
void | ertc_timestamp_get (ertc_time_type *time)
get the timestamp. More...
uint32_t | ertc_timestamp_sub_second_get (void)
get the timestamp sub second. More...
void | ertc_tamper_1_pin_select (ertc_pin_select_type pin)
tamper 1 detection pin selection. More...
void | ertc_tamper_pull_up_enable (confirm_state new_state)
enable or disable tamper pin pull up. More...
void | ertc_tamper_precharge_set (ertc_tamper_precharge_type precharge)
set the tamper pin pre-charge time. More...
void | ertc_tamper_filter_set (ertc_tamper_filter_type filter)
set the tamper filter time. More...
void | ertc_tamper_detect_freq_set (ertc_tamper_detect_freq_type freq)
set the tamper detection frequency. More...
void | ertc_tamper_valid_edge_set (ertc_tamper_select_type tamper_x, ertc_tamper_valid_edge_type trigger)
set the tamper trigger. More...
void | ertc_tamper_timestamp_enable (confirm_state new_state)
enable or disable trigger timestamp when tamper event occurs. More...
void | ertc_tamper_enable (ertc_tamper_select_type tamper_x, confirm_state new_state)
enable or disable tamper. More...
void | ertc_interrupt_enable (uint32_t source, confirm_state new_state)
enable or disable interrupt. More...
flag_status | ertc_interrupt_get (uint32_t source)
get interrupt status More...
flag_status | ertc_flag_get (uint32_t flag)
get flag status. More...
void | ertc_flag_clear (uint32_t flag)
clear flag status More...
void | ertc_bpr_data_write (ertc_dt_type dt, uint32_t data)
write data to the bpr register. More...
uint32_t | ertc_bpr_data_read (ertc_dt_type dt)
read data from bpr register. More...

Detailed Description

Function Documentation

◆ ertc_alarm_enable()

error_status ertc_alarm_enable | ( | ertc_alarm_type | alarm_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable alarm clock.

Parameters
alarm_x select the alarm. this parameter can be one of the following values:
  • ERTC_ALA: alarm a.
  • ERTC_ALB: alarm b.
new_state (TRUE or FALSE).
Return values
error_status (ERROR or SUCCESS).

< ertc alarm a register allows write flag

< ertc alarm b register allows write flag

Definition at line 629 of file at32f435_437_ertc.c.

Referenced by ertc_alarm_config(), ertc_alarm_value_set(), and ertc_config().

◆ ertc_alarm_get()

void ertc_alarm_get | ( | ertc_alarm_type | alarm_x,
 |  | ertc_alarm_value_type * | alarm
 | ) |  |

get alarm value.

Parameters
alarm_x select the alarm. this parameter can be one of the following values:
  • ERTC_ALA: alarm a.
  • ERTC_ALB: alarm b.
alarm alarm para.
Return values
none.

< ertc alarm don't match all

Definition at line 674 of file at32f435_437_ertc.c.

Referenced by ertc_alarm_show().

◆ ertc_alarm_mask_set()

void ertc_alarm_mask_set | ( | ertc_alarm_type | alarm_x,
 |  | uint32_t | mask
 | ) |  |

set which bits are irrelevant to the alarm match.

Parameters
alarm_x select the alarm. this parameter can be one of the following values:
  • ERTC_ALA: alarm a.
  • ERTC_ALB: alarm b.
mask select which bits are irrelevant to the alarm match. this parameter can be one of the following values:
  • ERTC_ALARM_MASK_NONE: match all.
  • ERTC_ALARM_MASK_SEC: don't match seconds.
  • ERTC_ALARM_MASK_MIN: don't match minute.
  • ERTC_ALARM_MASK_HOUR: don't match hour.
  • ERTC_ALARM_MASK_DATE_WEEK: don't match date or week.
  • ERTC_ALARM_MASK_ALL: don't match all.
alarm alarm para.
Return values
none.

< ertc alarm don't match all

< ertc alarm don't match all

Definition at line 458 of file at32f435_437_ertc.c.

Referenced by ertc_alarm_config(), and ertc_config().

◆ ertc_alarm_set()

void ertc_alarm_set | ( | ertc_alarm_type | alarm_x,
 |  | uint8_t | week_date,
 |  | uint8_t | hour,
 |  | uint8_t | min,
 |  | uint8_t | sec,
 |  | ertc_am_pm_type | ampm
 | ) |  |

set alarm.

Parameters
alarm_x select the alarm. this parameter can be one of the following values:
  • ERTC_ALA: alarm a.
  • ERTC_ALB: alarm b.
week_day week or date.
  • week: 1~7.
  • date: 1~31.
hour | hour (0~23).
min | minute (0~59).
sec | second (0~59).
ampm hour mode. this parameter can be one of the following values:
  • ERTC_24H: 24-hour format.
  • ERTC_AM: 12-hour format, ante meridiem.
  • ERTC_PM: 12-hour format, post meridiem.
alarm | alarm para.
Return values
none.

Definition at line 538 of file at32f435_437_ertc.c.

Referenced by ertc_alarm_config(), ertc_alarm_value_set(), and ertc_config().

◆ ertc_alarm_sub_second_get()

uint32_t ertc_alarm_sub_second_get ( ertc_alarm_type alarm_x )

get alarm sub second.

Parameters
alarm_x select the alarm. this parameter can be one of the following values:
  • ERTC_ALA: alarm a.
  • ERTC_ALB: alarm b.
Return values
sub second.

Definition at line 707 of file at32f435_437_ertc.c.

◆ ertc_alarm_sub_second_set()

void ertc_alarm_sub_second_set | ( | ertc_alarm_type | alarm_x,
 |  | uint32_t | value,
 |  | ertc_alarm_sbs_mask_type | mask
 | ) |  |

set alarm sub second.

Parameters
alarm_x select the alarm. this parameter can be one of the following values:
  • ERTC_ALA: alarm a.
  • ERTC_ALB: alarm b.
value sub second value.
mask sub second mask. this parameter can be one of the following values:
  • ERTC_ALARM_SBS_MASK_ALL: do not match the sub-second.
  • ERTC_ALARM_SBS_MASK_14_1: only compare bit [0].
  • ERTC_ALARM_SBS_MASK_14_2: only compare bit [1:0].
  • ERTC_ALARM_SBS_MASK_14_3: only compare bit [2:0].
  • ERTC_ALARM_SBS_MASK_14_4: only compare bit [3:0].
  • ERTC_ALARM_SBS_MASK_14_5: only compare bit [4:0].
  • ERTC_ALARM_SBS_MASK_14_6: only compare bit [5:0].
  • ERTC_ALARM_SBS_MASK_14_7: only compare bit [6:0].
  • ERTC_ALARM_SBS_MASK_14_8: only compare bit [7:0].
  • ERTC_ALARM_SBS_MASK_14_9: only compare bit [8:0].
  • ERTC_ALARM_SBS_MASK_14_10: only compare bit [9:0].
  • ERTC_ALARM_SBS_MASK_14_11: only compare bit [10:0].
  • ERTC_ALARM_SBS_MASK_14_12: only compare bit [11:0].
  • ERTC_ALARM_SBS_MASK_14_13: only compare bit [12:0].
  • ERTC_ALARM_SBS_MASK_14: only compare bit [13:0].
  • ERTC_ALARM_SBS_MASK_NONE: compare bit [14:0].
Return values
none.

Definition at line 600 of file at32f435_437_ertc.c.

◆ ertc_alarm_week_date_select()

void ertc_alarm_week_date_select | ( | ertc_alarm_type | alarm_x,
 |  | ertc_week_date_select_type | wk
 | ) |  |

alarm week or date mode select.

Parameters
alarm_x select the alarm. this parameter can be one of the following values:
  • ERTC_ALA: alarm a.
  • ERTC_ALB: alarm b.
wk week or date mode select. this parameter can be one of the following values:
  • ERTC_SLECT_DATE: slect date mode.
  • ERTC_SLECT_WEEK: slect week mode.
Return values
none.

Definition at line 500 of file at32f435_437_ertc.c.

Referenced by ertc_alarm_config(), and ertc_config().

◆ ertc_bcd_to_num()

uint8_t ertc_bcd_to_num ( uint8_t bcd )

bcd code conversion to number.

Parameters
bcd bcd code(0~99).
Return values
number.

Definition at line 66 of file at32f435_437_ertc.c.

Referenced by ertc_alarm_get(), ertc_calendar_get(), and ertc_timestamp_get().

◆ ertc_bpr_data_read()

uint32_t ertc_bpr_data_read ( ertc_dt_type dt )

read data from bpr register.

Parameters
dt data register this parameter can be one of the following values:
  • ERTC_DT1
  • ERTC_DT2
  • ...
  • ERTC_DT19
  • ERTC_DT20
Return values
data value.

Definition at line 1550 of file at32f435_437_ertc.c.

Referenced by bpr_reg_check(), is_bpr_reg_reset(), main(), and randnum_test().

◆ ertc_bpr_data_write()

void ertc_bpr_data_write | ( | ertc_dt_type | dt,
 |  | uint32_t | data
 | ) |  |

write data to the bpr register.

Parameters
dt data register this parameter can be one of the following values:
  • ERTC_DT1
  • ERTC_DT2
  • ...
  • ERTC_DT19
  • ERTC_DT20
data data to be write.
Return values
none.

Definition at line 1524 of file at32f435_437_ertc.c.

Referenced by bpr_reg_write(), and ertc_config().

◆ ertc_cal_output_enable()

void ertc_cal_output_enable ( confirm_state new_state )

enable or disable calibration output.

Parameters
new_state (TRUE or FALSE).
Return values
none.

Definition at line 931 of file at32f435_437_ertc.c.

◆ ertc_cal_output_select()

void ertc_cal_output_select ( ertc_cal_output_select_type output )

calibration output source select.

Parameters
output output source. this parameter can be one of the following values:
  • ERTC_CAL_OUTPUT_512HZ: output 512 hz.
  • ERTC_CAL_OUTPUT_1HZ: output 1 hz.
Return values
none.

Definition at line 915 of file at32f435_437_ertc.c.

◆ ertc_calendar_get()

void ertc_calendar_get ( ertc_time_type * time )

get calendar

Parameters
time ertc time.
Return values
none.

Definition at line 404 of file at32f435_437_ertc.c.

Referenced by ertc_alarm_value_set(), ertc_time_show(), main(), and randnum_test().

◆ ertc_coarse_calibration_enable()

error_status ertc_coarse_calibration_enable ( confirm_state new_state )

enable or disable coarse calibration.

Parameters
new_state (TRUE or FALSE).
Return values
error_status (ERROR or SUCCESS).

Definition at line 885 of file at32f435_437_ertc.c.

◆ ertc_coarse_calibration_set()

error_status ertc_coarse_calibration_set | ( | ertc_cal_direction_type | dir,
 |  | uint32_t | value
 | ) |  |

set the coarse digital calibration.

Parameters
dir calibration direction. this parameter can be one of the following values:
  • ERTC_CAL_DIR_POSITIVE: positive calibration.
  • ERTC_CAL_DIR_NEGATIVE: negative calibration.
value calibration value(0~31).
Return values
error_status (ERROR or SUCCESS).

Definition at line 856 of file at32f435_437_ertc.c.

◆ ertc_date_set()

error_status ertc_date_set | ( | uint8_t | year,
 |  | uint8_t | month,
 |  | uint8_t | date,
 |  | uint8_t | week
 | ) |  |

set date.

Parameters
year | year (0~99).
month | month (1~12).
date | date (1~31).
week | week (1~7).
Return values
error_status (ERROR or SUCCESS).

Definition at line 314 of file at32f435_437_ertc.c.

Referenced by ertc_config().

◆ ertc_daylight_bpr_get()

uint8_t ertc_daylight_bpr_get ( void )

get the bpr value.

Parameters
none.
Return values
bpr value.

Definition at line 1026 of file at32f435_437_ertc.c.

◆ ertc_daylight_set()

void ertc_daylight_set | ( | ertc_dst_operation_type | operation,
 |  | ertc_dst_save_type | save
 | ) |  |

config the daylight saving time.

Parameters
operation time adjust. this parameter can be one of the following values:
  • ERTC_DST_ADD_1H: add 1 hour.
  • ERTC_DST_DEC_1H: dec 1 hour.
save operation save. this parameter can be one of the following values:
  • ERTC_DST_SAVE_0: set the bpr register value to 0.
  • ERTC_DST_SAVE_1: set the bpr register value to 1.
Return values
none.

Definition at line 1001 of file at32f435_437_ertc.c.

◆ ertc_direct_read_enable()

void ertc_direct_read_enable ( confirm_state new_state )

enable or disable direct read mode.

Parameters
new_state (TRUE or FALSE).
Return values
none.

Definition at line 1064 of file at32f435_437_ertc.c.

◆ ertc_divider_set()

error_status ertc_divider_set | ( | uint16_t | div_a,
 |  | uint16_t | div_b
 | ) |  |

ertc division set.

Parameters
div_a | division a (0~0x7F).
div_b | division b (0~0x7FFF).
Return values
error_status (ERROR or SUCCESS).

Definition at line 251 of file at32f435_437_ertc.c.

Referenced by ertc_config(), and main().

◆ ertc_flag_clear()

void ertc_flag_clear ( uint32_t flag )

clear flag status

Parameters
flag specifies the flag to clear. this parameter can be any combination of the following values:
  • ERTC_ALAWF_FLAG: alarm a register allows write flag.
  • ERTC_ALBWF_FLAG: alarm b register allows write flag.
  • ERTC_WATWF_FLAG: wakeup timer register allows write flag.
  • ERTC_TADJF_FLAG: time adjustment flag.
  • ERTC_INITF_FLAG: calendar initialization flag.
  • ERTC_UPDF_FLAG: calendar update flag.
  • ERTC_IMF_FLAG: enter initialization mode flag.
  • ERTC_ALAF_FLAG: alarm clock a flag.
  • ERTC_ALBF_FLAG: alarm clock b flag.
  • ERTC_WATF_FLAG: wakeup timer flag.
  • ERTC_TSF_FLAG: timestamp flag.
  • ERTC_TSOF_FLAG: timestamp overflow flag.
  • ERTC_TP1F_FLAG: tamper detection 1 flag.
  • ERTC_TP2F_FLAG: tamper detection 2 flag.
  • ERTC_CALUPDF_FLAG: calibration value update completed flag.
Return values
none

Definition at line 1507 of file at32f435_437_ertc.c.

Referenced by ertc_config(), ertc_tamper_config(), ERTC_WKUP_IRQHandler(), ERTCAlarm_IRQHandler(), main(), and TAMP_STAMP_IRQHandler().

◆ ertc_flag_get()

flag_status ertc_flag_get ( uint32_t flag )

get flag status.

Parameters
flag specifies the flag to check. this parameter can be one of the following values:
  • ERTC_ALAWF_FLAG: alarm a register allows write flag.
  • ERTC_ALBWF_FLAG: alarm b register allows write flag.
  • ERTC_WATWF_FLAG: wakeup timer register allows write flag.
  • ERTC_TADJF_FLAG: time adjustment flag.
  • ERTC_INITF_FLAG: calendar initialization flag.
  • ERTC_UPDF_FLAG: calendar update flag.
  • ERTC_IMF_FLAG: enter initialization mode flag.
  • ERTC_ALAF_FLAG: alarm clock a flag.
  • ERTC_ALBF_FLAG: alarm clock b flag.
  • ERTC_WATF_FLAG: wakeup timer flag.
  • ERTC_TSF_FLAG: timestamp flag.
  • ERTC_TSOF_FLAG: timestamp overflow flag.
  • ERTC_TP1F_FLAG: tamper detection 1 flag.
  • ERTC_TP2F_FLAG: tamper detection 2 flag.
  • ERTC_CALUPDF_FLAG: calibration value update completed flag.
Return values
the new state of flag (SET or RESET).

Definition at line 1474 of file at32f435_437_ertc.c.

Referenced by ertc_wait_flag(), ERTC_WKUP_IRQHandler(), ERTCAlarm_IRQHandler(), and TAMP_STAMP_IRQHandler().

◆ ertc_hour_mode_set()

error_status ertc_hour_mode_set ( ertc_hour_mode_set_type mode )

ertc hour mode set.

Parameters
mode hour mode. this parameter can be one of the following values:
  • ERTC_HOUR_MODE_24: 24-hour format.
  • ERTC_HOUR_MODE_12: 12-hour format.
Return values
error_status (ERROR or SUCCESS).

Definition at line 283 of file at32f435_437_ertc.c.

Referenced by ertc_config().

◆ ertc_init_mode_enter()

error_status ertc_init_mode_enter ( void )

ertc enter init mode.

Parameters
none.
Return values
error_status (ERROR or SUCCESS).

Definition at line 163 of file at32f435_437_ertc.c.

Referenced by ertc_coarse_calibration_enable(), ertc_coarse_calibration_set(), ertc_date_set(), ertc_divider_set(), ertc_hour_mode_set(), ertc_refer_clock_detect_enable(), ertc_reset(), and ertc_time_set().

◆ ertc_init_mode_exit()

void ertc_init_mode_exit ( void )

ertc exit init mode.

Parameters
none.
Return values
none.

Definition at line 197 of file at32f435_437_ertc.c.

Referenced by ertc_coarse_calibration_enable(), ertc_coarse_calibration_set(), ertc_date_set(), ertc_divider_set(), ertc_hour_mode_set(), ertc_refer_clock_detect_enable(), and ertc_time_set().

◆ ertc_interrupt_enable()

void ertc_interrupt_enable | ( | uint32_t | source,
 |  | confirm_state | new_state
 | ) |  |

enable or disable interrupt.

Parameters
source interrupts sources this parameter can be any combination of the following values:
  • ERTC_TP_INT: tamper interrupt.
  • ERTC_ALA_INT: alarm a interrupt.
  • ERTC_ALB_INT: alarm b interrupt.
  • ERTC_WAT_INT: wakeup timer interrupt.
  • ERTC_TS_INT: timestamp interrupt.
new_state (TRUE or FALSE).
Return values
none.

< ertc tamper interrupt

< ertc tamper interrupt

< ertc tamper interrupt

< ertc tamper interrupt

Definition at line 1386 of file at32f435_437_ertc.c.

Referenced by ertc_alarm_config(), ertc_config(), ertc_tamper_config(), ertc_timestamp_config(), ertc_wakeup_timer_config(), and wakeup_timer_config().

◆ ertc_interrupt_get()

flag_status ertc_interrupt_get ( uint32_t source )

get interrupt status

Parameters
source this parameter can be one of the following values:
  • ERTC_TP_INT: tamper interrupt.
  • ERTC_ALA_INT: alarm a interrupt.
  • ERTC_ALB_INT: alarm b interrupt.
  • ERTC_WAT_INT: wakeup timer interrupt.
  • ERTC_TS_INT: timestamp interrupt.
Return values
flag_status (SET or RESET)

< ertc tamper interrupt

< ertc tamper interrupt

Definition at line 1429 of file at32f435_437_ertc.c.

◆ ertc_num_to_bcd()

uint8_t ertc_num_to_bcd ( uint8_t num )

number conversion to bcd code.

Parameters
num number(0~99)
Return values
bcd code.

Definition at line 51 of file at32f435_437_ertc.c.

Referenced by ertc_alarm_set(), ertc_date_set(), and ertc_time_set().

◆ ertc_output_set()

void ertc_output_set | ( | ertc_output_source_type | source,
 |  | ertc_output_polarity_type | polarity,
 |  | ertc_output_type | type
 | ) |  |

set the output mode.

Parameters
source output source. this parameter can be one of the following values:
  • ERTC_OUTPUT_DISABLE: diable output.
  • ERTC_OUTPUT_ALARM_A: output alarm a event.
  • ERTC_OUTPUT_ALARM_B: output alarm b event.
  • ERTC_OUTPUT_WAKEUP: output wakeup event.
polarity output polarity. this parameter can be one of the following values:
  • ERTC_OUTPUT_POLARITY_HIGH: when the event occurs, the output is high.
  • ERTC_OUTPUT_POLARITY_LOW: when the event occurs, the output is low.
type output type. this parameter can be one of the following values:
  • ERTC_OUTPUT_TYPE_OPEN_DRAIN: open drain output.
  • ERTC_OUTPUT_TYPE_PUSH_PULL: push pull output.
Return values
none.

Definition at line 1093 of file at32f435_437_ertc.c.

◆ ertc_refer_clock_detect_enable()

error_status ertc_refer_clock_detect_enable ( confirm_state new_state )

enable or disable refer clock detect.

Parameters
new_state (TRUE or FALSE).
Return values
error_status (ERROR or SUCCESS).

Definition at line 1036 of file at32f435_437_ertc.c.

◆ ertc_reset()

error_status ertc_reset ( void )

ertc reset all register.

Parameters
none.
Return values
error_status (ERROR or SUCCESS).

Definition at line 207 of file at32f435_437_ertc.c.

Referenced by ertc_config().

◆ ertc_smooth_calibration_config()

error_status ertc_smooth_calibration_config | ( | ertc_smooth_cal_period_type | period,
 |  | ertc_smooth_cal_clk_add_type | clk_add,
 |  | uint32_t | clk_dec
 | ) |  |

config the smooth calibration.

Parameters
period calibration period. this parameter can be one of the following values:
  • ERTC_SMOOTH_CAL_PERIOD_32: 32 second calibration period.
  • ERTC_SMOOTH_CAL_PERIOD_16: 16 second calibration period.
  • ERTC_SMOOTH_CAL_PERIOD_8: 8 second calibration period.
clk_add add clock. this parameter can be one of the following values:
  • ERTC_SMOOTH_CAL_CLK_ADD_0: do not increase clock.
  • ERTC_SMOOTH_CAL_CLK_ADD_512: add 512 clocks.
clk_dec decrease clock(0~511).
Return values
error_status (ERROR or SUCCESS).

< ertc calibration value update completed flag

Definition at line 808 of file at32f435_437_ertc.c.

◆ ertc_sub_second_get()

uint32_t ertc_sub_second_get ( void )

get current sub second.

Parameters
none.
Return values
sub second.

Definition at line 430 of file at32f435_437_ertc.c.

◆ ertc_tamper_1_pin_select()

void ertc_tamper_1_pin_select ( ertc_pin_select_type pin )

tamper 1 detection pin selection.

Parameters
pin data register this parameter can be one of the following values:
  • ERTC_PIN_PC13: pc13 is used as tamper 1 detection pin.
  • ERTC_PIN_PA0: pa0 is used as tamper 1 detection pin.
Return values
data value.

Definition at line 1204 of file at32f435_437_ertc.c.

◆ ertc_tamper_detect_freq_set()

void ertc_tamper_detect_freq_set ( ertc_tamper_detect_freq_type freq )

set the tamper detection frequency.

Parameters
freq tamper detection frequency. this parameter can be one of the following values:
  • ERTC_TAMPER_FREQ_DIV_32768: ERTC_CLK / 32768.
  • ERTC_TAMPER_FREQ_DIV_16384: ERTC_CLK / 16384.
  • ERTC_TAMPER_FREQ_DIV_8192: ERTC_CLK / 8192.
  • ERTC_TAMPER_FREQ_DIV_4096: ERTC_CLK / 4096.
  • ERTC_TAMPER_FREQ_DIV_2048: ERTC_CLK / 2048.
  • ERTC_TAMPER_FREQ_DIV_1024: ERTC_CLK / 1024.
  • ERTC_TAMPER_FREQ_DIV_512: ERTC_CLK / 512.
  • ERTC_TAMPER_FREQ_DIV_256: ERTC_CLK / 256.
Return values
none.

Definition at line 1287 of file at32f435_437_ertc.c.

◆ ertc_tamper_enable()

void ertc_tamper_enable | ( | ertc_tamper_select_type | tamper_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tamper.

Parameters
tamper_x select the tamper. this parameter can be one of the following values:
  • ERTC_TAMPER_1: tamper 1.
  • ERTC_TAMPER_2: tamper 2.
new_state (TRUE or FALSE).
Return values
none.

Definition at line 1356 of file at32f435_437_ertc.c.

Referenced by ertc_tamper_config().

◆ ertc_tamper_filter_set()

void ertc_tamper_filter_set ( ertc_tamper_filter_type filter )

set the tamper filter time.

Parameters
filter tamper filter. this parameter can be one of the following values:
  • ERTC_TAMPER_FILTER_DISABLE: disable filter function.
  • ERTC_TAMPER_FILTER_2: 2 consecutive samples arw valid, effective tamper event.
  • ERTC_TAMPER_FILTER_4: 4 consecutive samples arw valid, effective tamper event.
  • ERTC_TAMPER_FILTER_8: 8 consecutive samples arw valid, effective tamper event.
Return values
none.

Definition at line 1262 of file at32f435_437_ertc.c.

◆ ertc_tamper_precharge_set()

void ertc_tamper_precharge_set ( ertc_tamper_precharge_type precharge )

set the tamper pin pre-charge time.

Parameters
precharge tamper detection pre-charge time this parameter can be one of the following values:
  • ERTC_TAMPER_PR_1_ERTCCLK: pre-charge time is 1 ERTC_CLK.
  • ERTC_TAMPER_PR_2_ERTCCLK: pre-charge time is 2 ERTC_CLK.
  • ERTC_TAMPER_PR_4_ERTCCLK: pre-charge time is 4 ERTC_CLK.
  • ERTC_TAMPER_PR_8_ERTCCLK: pre-charge time is 8 ERTC_CLK.
Return values
none.

Definition at line 1241 of file at32f435_437_ertc.c.

◆ ertc_tamper_pull_up_enable()

void ertc_tamper_pull_up_enable ( confirm_state new_state )

enable or disable tamper pin pull up.

Parameters
new_state (TRUE or FALSE).
Return values
none.

Definition at line 1220 of file at32f435_437_ertc.c.

◆ ertc_tamper_timestamp_enable()

void ertc_tamper_timestamp_enable ( confirm_state new_state )

enable or disable trigger timestamp when tamper event occurs.

Parameters
new_state (TRUE or FALSE).
Return values
none.

Definition at line 1336 of file at32f435_437_ertc.c.

◆ ertc_tamper_valid_edge_set()

void ertc_tamper_valid_edge_set | ( | ertc_tamper_select_type | tamper_x,
 |  | ertc_tamper_valid_edge_type | trigger
 | ) |  |

set the tamper trigger.

Parameters
tamper_x select the tamper. this parameter can be one of the following values:
  • ERTC_TAMPER_1: tamper 1.
  • ERTC_TAMPER_2: tamper 2.
trigger tamper valid edge. this parameter can be one of the following values:
  • ERTC_TAMPER_EDGE_RISING: rising gedge.
  • ERTC_TAMPER_EDGE_FALLING: falling gedge.
  • ERTC_TAMPER_EDGE_LOW: low level.
  • ERTC_TAMPER_EDGE_HIGH: high level.
alarm alarm para.
Return values
none.

Definition at line 1313 of file at32f435_437_ertc.c.

Referenced by ertc_tamper_config().

◆ ertc_time_adjust()

error_status ertc_time_adjust | ( | ertc_time_adjust_type | add1s,
 |  | uint32_t | decsbs
 | ) |  |

adjust the time.

Parameters
add1s second operation. this parameter can be one of the following values:
  • ERTC_TIME_ADD_NONE: none operation.
  • ERTC_TIME_ADD_1S: add 1 second.
decsbs decrease sub second(0~0x7FFF).
Return values
error_status (ERROR or SUCCESS).

< ertc time adjustment flag

Definition at line 951 of file at32f435_437_ertc.c.

◆ ertc_time_set()

error_status ertc_time_set | ( | uint8_t | hour,
 |  | uint8_t | min,
 |  | uint8_t | sec,
 |  | ertc_am_pm_type | ampm
 | ) |  |

set time.

Parameters
hour | hour (0~23).
min | minute (0~59).
sec | second (0~59).
ampm hour mode. this parameter can be one of the following values:
  • ERTC_24H: 24-hour format.
  • ERTC_AM: 12-hour format, ante meridiem.
  • ERTC_PM: 12-hour format, post meridiem.
Return values
error_status (ERROR or SUCCESS).

Definition at line 363 of file at32f435_437_ertc.c.

Referenced by ertc_config().

◆ ertc_timestamp_enable()

void ertc_timestamp_enable ( confirm_state new_state )

enable or disable timestamp.

Parameters
new_state (TRUE or FALSE).
Return values
none.

Definition at line 1151 of file at32f435_437_ertc.c.

Referenced by ertc_timestamp_config().

◆ ertc_timestamp_get()

void ertc_timestamp_get ( ertc_time_type * time )

get the timestamp.

Parameters
time | time.
date | date.
Return values
none.

Definition at line 1168 of file at32f435_437_ertc.c.

Referenced by ertc_timestamp_show().

◆ ertc_timestamp_pin_select()

void ertc_timestamp_pin_select ( ertc_pin_select_type pin )

timestamp detection pin selection.

Parameters
pin data register this parameter can be one of the following values:
  • ERTC_PIN_PC13: pc13 is used as timestamp detection pin.
  • ERTC_PIN_PA0: pa0 is used as timestamp detection pin.
Return values
data value.

Definition at line 1116 of file at32f435_437_ertc.c.

◆ ertc_timestamp_sub_second_get()

uint32_t ertc_timestamp_sub_second_get ( void )

get the timestamp sub second.

Parameters
none.
Return values
timestamp sub second.

Definition at line 1191 of file at32f435_437_ertc.c.

◆ ertc_timestamp_valid_edge_set()

void ertc_timestamp_valid_edge_set ( ertc_timestamp_valid_edge_type edge )

set the timestamp valid edge.

Parameters
edge calibration period. this parameter can be one of the following values:
  • ERTC_TIMESTAMP_EDGE_RISING : rising edge trigger.
  • ERTC_TIMESTAMP_EDGE_FALLING: falling edge trigger.
Return values
none.

Definition at line 1135 of file at32f435_437_ertc.c.

Referenced by ertc_timestamp_config().

◆ ertc_wait_flag()

error_status ertc_wait_flag | ( | uint32_t | flag,
 |  | flag_status | status
 | ) |  |

ertc wait flag status.

Parameters
flag flag to wait. this parameter can be one of the following values:
  • ERTC_ALAWF_FLAG: alarm a register allows write flag.
  • ERTC_ALBWF_FLAG: alarm b register allows write flag.
  • ERTC_WATWF_FLAG: wakeup timer register allows write flag.
  • ERTC_TADJF_FLAG: time adjustment flag.
  • ERTC_CALUPDF_FLAG: calibration value update completed flag.
status status to wait. this parameter can be one of the following values:
  • SET.
  • RESET.
Return values
error_status (ERROR or SUCCESS).

Definition at line 138 of file at32f435_437_ertc.c.

Referenced by ertc_alarm_enable(), ertc_smooth_calibration_config(), ertc_time_adjust(), and ertc_wakeup_enable().

◆ ertc_wait_update()

error_status ertc_wait_update ( void )

ertc wait register update finish.

Parameters
none.
Return values
error_status (ERROR or SUCCESS).

< ertc calendar update flag

Definition at line 97 of file at32f435_437_ertc.c.

Referenced by ertc_config(), ertc_date_set(), ertc_reset(), ertc_time_adjust(), ertc_time_set(), and main().

◆ ertc_wakeup_clock_set()

void ertc_wakeup_clock_set ( ertc_wakeup_clock_type clock )

set wakeup timer clock.

Parameters
clock wakeup timer clock source. this parameter can be one of the following values:
  • ERTC_WAT_CLK_ERTCCLK_DIV16: ERTC_CLK / 16.
  • ERTC_WAT_CLK_ERTCCLK_DIV8: ERTC_CLK / 8.
  • ERTC_WAT_CLK_ERTCCLK_DIV4: ERTC_CLK / 4.
  • ERTC_WAT_CLK_ERTCCLK_DIV2: ERTC_CLK / 2.
  • ERTC_WAT_CLK_CK_B_16BITS: CK_B, wakeup counter = ERTC_WAT
  • ERTC_WAT_CLK_CK_B_17BITS: CK_B, wakeup counter = ERTC_WAT + 65535.
Return values
none.

Definition at line 731 of file at32f435_437_ertc.c.

Referenced by ertc_wakeup_timer_config(), and wakeup_timer_config().

◆ ertc_wakeup_counter_get()

uint16_t ertc_wakeup_counter_get ( void )

get wakeup counter.

Parameters
none.
Return values
wakeup counter.

Definition at line 763 of file at32f435_437_ertc.c.

◆ ertc_wakeup_counter_set()

void ertc_wakeup_counter_set ( uint32_t counter )

set wakeup counter.

Parameters
counter wakeup counter(0~65535).
Return values
none.

Definition at line 747 of file at32f435_437_ertc.c.

Referenced by ertc_wakeup_timer_config(), and wakeup_timer_config().

◆ ertc_wakeup_enable()

error_status ertc_wakeup_enable ( confirm_state new_state )

enable or disable wakeup timer.

Parameters
new_state (TRUE or FALSE).
Return values
error_status (ERROR or SUCCESS).

< ertc wakeup timer register allows write flag

Definition at line 773 of file at32f435_437_ertc.c.

Referenced by ertc_wakeup_timer_config(), and wakeup_timer_config().

◆ ertc_write_protect_disable()

void ertc_write_protect_disable ( void )

disable write protection.

Parameters
none.
Return values
none

Definition at line 86 of file at32f435_437_ertc.c.

Referenced by ertc_alarm_enable(), ertc_alarm_mask_set(), ertc_alarm_set(), ertc_alarm_sub_second_set(), ertc_alarm_week_date_select(), ertc_bpr_data_write(), ertc_cal_output_enable(), ertc_cal_output_select(), ertc_coarse_calibration_enable(), ertc_coarse_calibration_set(), ertc_date_set(), ertc_daylight_set(), ertc_direct_read_enable(), ertc_divider_set(), ertc_hour_mode_set(), ertc_init_mode_enter(), ertc_interrupt_enable(), ertc_output_set(), ertc_refer_clock_detect_enable(), ertc_reset(), ertc_smooth_calibration_config(), ertc_tamper_1_pin_select(), ertc_tamper_detect_freq_set(), ertc_tamper_enable(), ertc_tamper_filter_set(), ertc_tamper_precharge_set(), ertc_tamper_pull_up_enable(), ertc_tamper_timestamp_enable(), ertc_tamper_valid_edge_set(), ertc_time_adjust(), ertc_time_set(), ertc_timestamp_enable(), ertc_timestamp_pin_select(), ertc_timestamp_valid_edge_set(), ertc_wait_update(), ertc_wakeup_clock_set(), ertc_wakeup_counter_set(), and ertc_wakeup_enable().

◆ ertc_write_protect_enable()

void ertc_write_protect_enable ( void )

enable write protection.

Parameters
none.
Return values
none

Definition at line 76 of file at32f435_437_ertc.c.

Referenced by ertc_alarm_enable(), ertc_alarm_mask_set(), ertc_alarm_set(), ertc_alarm_sub_second_set(), ertc_alarm_week_date_select(), ertc_bpr_data_write(), ertc_cal_output_enable(), ertc_cal_output_select(), ertc_coarse_calibration_enable(), ertc_coarse_calibration_set(), ertc_date_set(), ertc_daylight_set(), ertc_direct_read_enable(), ertc_divider_set(), ertc_hour_mode_set(), ertc_init_mode_enter(), ertc_interrupt_enable(), ertc_output_set(), ertc_refer_clock_detect_enable(), ertc_reset(), ertc_smooth_calibration_config(), ertc_tamper_1_pin_select(), ertc_tamper_detect_freq_set(), ertc_tamper_enable(), ertc_tamper_filter_set(), ertc_tamper_precharge_set(), ertc_tamper_pull_up_enable(), ertc_tamper_timestamp_enable(), ertc_tamper_valid_edge_set(), ertc_time_adjust(), ertc_time_set(), ertc_timestamp_enable(), ertc_timestamp_pin_select(), ertc_timestamp_valid_edge_set(), ertc_wait_flag(), ertc_wait_update(), ertc_wakeup_clock_set(), ertc_wakeup_counter_set(), and ertc_wakeup_enable().


AT32F435/437 Firmwary Library: ACC

Modules | Macros
ACC
AT32F435_437_periph_driver

ACC driver modules. More...

Modules

ACC_exported_constants
ACC_exported_types
ACC_exported_functions
ACC_private_functions

Macros

#define ACC ((acc_type *) ACC_BASE)

Detailed Description

ACC driver modules.

Macro Definition Documentation

◆ ACC

#define ACC ((acc_type *) ACC_BASE)

Definition at line 168 of file at32f435_437_acc.h.


AT32F435/437 Firmwary Library: ACC_exported_constants

Macros
ACC_exported_constants
AT32F435_437_periph_driver » ACC

Macros

#define | ACC_CAL_HICKCAL ((uint16_t)0x0000)
#define | ACC_CAL_HICKTRIM ((uint16_t)0x0002)
#define | ACC_RSLOST_FLAG ((uint16_t)0x0002)
#define | ACC_CALRDY_FLAG ((uint16_t)0x0001)
#define | ACC_CALRDYIEN_INT ((uint16_t)0x0020)
#define | ACC_EIEN_INT ((uint16_t)0x0010)
#define | ACC_SOF_OTG1 ((uint16_t)0x0000)
#define | ACC_SOF_OTG2 ((uint16_t)0x0004)

Detailed Description

Macro Definition Documentation

◆ ACC_CAL_HICKCAL

#define ACC_CAL_HICKCAL ((uint16_t)0x0000)

acc hick calibration

Definition at line 51 of file at32f435_437_acc.h.

◆ ACC_CAL_HICKTRIM

#define ACC_CAL_HICKTRIM ((uint16_t)0x0002)

acc hick trim

Definition at line 52 of file at32f435_437_acc.h.

◆ ACC_CALRDY_FLAG

#define ACC_CALRDY_FLAG ((uint16_t)0x0001)

acc internal high-speed clock calibration ready error flag

Definition at line 55 of file at32f435_437_acc.h.

◆ ACC_CALRDYIEN_INT

#define ACC_CALRDYIEN_INT ((uint16_t)0x0020)

acc internal high-speed clock calibration ready interrupt enable

Definition at line 57 of file at32f435_437_acc.h.

◆ ACC_EIEN_INT

#define ACC_EIEN_INT ((uint16_t)0x0010)

acc reference signal lost interrupt enable

Definition at line 58 of file at32f435_437_acc.h.

◆ ACC_RSLOST_FLAG

#define ACC_RSLOST_FLAG ((uint16_t)0x0002)

acc reference signal lost error flag

Definition at line 54 of file at32f435_437_acc.h.

◆ ACC_SOF_OTG1

#define ACC_SOF_OTG1 ((uint16_t)0x0000)

acc sof signal select: otg1

Definition at line 60 of file at32f435_437_acc.h.

◆ ACC_SOF_OTG2

#define ACC_SOF_OTG2 ((uint16_t)0x0004)

acc sof signal select: otg2

Definition at line 61 of file at32f435_437_acc.h.


AT32F435/437 Firmwary Library: ACC_exported_types

Data Structures
ACC_exported_types
AT32F435_437_periph_driver » ACC

Data Structures

struct acc_type
type define acc register all More...

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: acc_type Struct Reference

Data Fields
acc_type Struct Reference
AT32F435_437_periph_driver » ACC » ACC_exported_types

type define acc register all More...

#include <at32f435_437_acc.h>

Data Fields

union {
__IO uint32_t sts
struct {
__IO uint32_t calrdy: 1
__IO uint32_t rslost: 1
__IO uint32_t reserved1: 30
} sts_bit
};
acc sts register, offset:0x00 More...
union {
__IO uint32_t ctrl1
struct {
__IO uint32_t calon: 1
__IO uint32_t entrim: 1
__IO uint32_t reserved1: 2
__IO uint32_t eien: 1
__IO uint32_t calrdyien: 1
__IO uint32_t reserved2: 2
__IO uint32_t step: 4
__IO uint32_t reserved3: 20
} ctrl1_bit
};
acc ctrl1 register, offset:0x04 More...
union {
__IO uint32_t ctrl2
struct {
__IO uint32_t hickcal: 8
__IO uint32_t hicktrim: 6
__IO uint32_t reserved1: 18
} ctrl2_bit
};
acc ctrl2 register, offset:0x08 More...
union {
__IO uint32_t c1
struct {
__IO uint32_t c1: 16
__IO uint32_t reserved1: 16
} c1_bit
};
acc acc_c1 register, offset:0x0C More...
union {
__IO uint32_t c2
struct {
__IO uint32_t c2: 16
__IO uint32_t reserved1: 16
} c2_bit
};
acc acc_c2 register, offset:0x10 More...
union {
__IO uint32_t c3
struct {
__IO uint32_t c3: 16
__IO uint32_t reserved1: 16
} c3_bit
};
acc acc_c3 register, offset:0x14 More...

Detailed Description

type define acc register all

Definition at line 74 of file at32f435_437_acc.h.

Field Documentation

◆

union { ... } acc_type::@1

acc sts register, offset:0x00

◆

union { ... } acc_type::@11

acc acc_c3 register, offset:0x14

◆

union { ... } acc_type::@3

acc ctrl1 register, offset:0x04

◆

union { ... } acc_type::@5

acc ctrl2 register, offset:0x08

◆

union { ... } acc_type::@7

acc acc_c1 register, offset:0x0C

◆

union { ... } acc_type::@9

acc acc_c2 register, offset:0x10

◆ c1

__IO uint32_t acc_type::c1

Definition at line 129 of file at32f435_437_acc.h.

◆

struct { ... } acc_type::c1_bit

◆ c2

__IO uint32_t acc_type::c2

Definition at line 142 of file at32f435_437_acc.h.

◆

struct { ... } acc_type::c2_bit

◆ c3

__IO uint32_t acc_type::c3

Definition at line 155 of file at32f435_437_acc.h.

◆

struct { ... } acc_type::c3_bit

◆ calon

__IO uint32_t acc_type::calon

Definition at line 99 of file at32f435_437_acc.h.

◆ calrdy

__IO uint32_t acc_type::calrdy

Definition at line 85 of file at32f435_437_acc.h.

◆ calrdyien

__IO uint32_t acc_type::calrdyien

Definition at line 103 of file at32f435_437_acc.h.

◆ ctrl1

__IO uint32_t acc_type::ctrl1

Definition at line 96 of file at32f435_437_acc.h.

◆

struct { ... } acc_type::ctrl1_bit

◆ ctrl2

__IO uint32_t acc_type::ctrl2

Definition at line 115 of file at32f435_437_acc.h.

◆

struct { ... } acc_type::ctrl2_bit

◆ eien

__IO uint32_t acc_type::eien

Definition at line 102 of file at32f435_437_acc.h.

◆ entrim

__IO uint32_t acc_type::entrim

Definition at line 100 of file at32f435_437_acc.h.

◆ hickcal

__IO uint32_t acc_type::hickcal

Definition at line 118 of file at32f435_437_acc.h.

◆ hicktrim

__IO uint32_t acc_type::hicktrim

Definition at line 119 of file at32f435_437_acc.h.

◆ reserved1

__IO uint32_t acc_type::reserved1

Definition at line 87 of file at32f435_437_acc.h.

◆ reserved2

__IO uint32_t acc_type::reserved2

Definition at line 104 of file at32f435_437_acc.h.

◆ reserved3

__IO uint32_t acc_type::reserved3

Definition at line 106 of file at32f435_437_acc.h.

◆ rslost

__IO uint32_t acc_type::rslost

Definition at line 86 of file at32f435_437_acc.h.

◆ step

__IO uint32_t acc_type::step

Definition at line 105 of file at32f435_437_acc.h.

◆ sts

__IO uint32_t acc_type::sts

Definition at line 82 of file at32f435_437_acc.h.

◆

struct { ... } acc_type::sts_bit
The documentation for this struct was generated from the following file:
  • at32f435_437_acc.h


AT32F435/437 Firmwary Library: ACC_exported_functions

Functions
ACC_exported_functions
AT32F435_437_periph_driver » ACC

Functions

void | acc_calibration_mode_enable (uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode. More...
void | acc_step_set (uint8_t step_value)
store calibration step data in acc's ctrl1 register. More...
void | acc_sof_select (uint16_t sof_sel)
select sof sourse for acc in acc's ctrl1 register. More...
void | acc_interrupt_enable (uint16_t acc_int, confirm_state new_state)
enable or disable the specified acc interrupts. More...
uint8_t | acc_hicktrim_get (void)
return the current acc hicktrim value. More...
uint8_t | acc_hickcal_get (void)
return the current acc hickcal value. More...
void | acc_write_c1 (uint16_t acc_c1_value)
wtire the value to acc c1 register. More...
void | acc_write_c2 (uint16_t acc_c2_value)
wtire the value to acc c2 register. More...
void | acc_write_c3 (uint16_t acc_c3_value)
wtire the value to acc c3 register. More...
uint16_t | acc_read_c1 (void)
return the current acc c1 value. More...
uint16_t | acc_read_c2 (void)
return the current acc c2 value. More...
uint16_t | acc_read_c3 (void)
return the current acc c3 value. More...
flag_status | acc_flag_get (uint16_t acc_flag)
check whether the specified acc flag is set or not. More...
void | acc_flag_clear (uint16_t acc_flag)
clear the specified acc flag is set or not. More...

Detailed Description

Function Documentation

◆ acc_calibration_mode_enable()

void acc_calibration_mode_enable | ( | uint16_t | acc_trim,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the acc calibration mode.

Parameters
acc_trim specifies the acc calibration type. this parameter can be one of the following values:
  • ACC_CAL_HICKCAL
  • ACC_CAL_HICKTRIM
new_state specifies the acc calibration to be enabled or disabled.(TRUE or FALSE)
Return values
none

< acc hick calibration

Definition at line 53 of file at32f435_437_acc.c.

Referenced by main(), and usb_clock48m_select().

◆ acc_flag_clear()

void acc_flag_clear ( uint16_t acc_flag )

clear the specified acc flag is set or not.

Parameters
acc_flag specifies the flag to check. this parameter can be any combination of the following values:
  • ACC_RSLOST_FLAG
  • ACC_CALRDY_FLAG
Return values
none

Definition at line 214 of file at32f435_437_acc.c.

Referenced by ACC_IRQHandler().

◆ acc_flag_get()

flag_status acc_flag_get ( uint16_t acc_flag )

check whether the specified acc flag is set or not.

Parameters
acc_flag specifies the flag to check. this parameter can be one of the following values:
  • ACC_RSLOST_FLAG
  • ACC_CALRDY_FLAG
Return values
flag_status (SET or RESET)

< acc internal high-speed clock calibration ready error flag

Definition at line 198 of file at32f435_437_acc.c.

Referenced by ACC_IRQHandler().

◆ acc_hickcal_get()

uint8_t acc_hickcal_get ( void )

return the current acc hickcal value.

Parameters
none
Return values
8-bit hicktrim value.

Definition at line 125 of file at32f435_437_acc.c.

◆ acc_hicktrim_get()

uint8_t acc_hicktrim_get ( void )

return the current acc hicktrim value.

Parameters
none
Return values
8-bit hicktrim value.

Definition at line 115 of file at32f435_437_acc.c.

◆ acc_interrupt_enable()

void acc_interrupt_enable | ( | uint16_t | acc_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified acc interrupts.

Parameters
acc_int specifies the acc interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • ACC_CALRDYIEN_INT
  • ACC_EIEN_INT
new_state (TRUE or FALSE)
Return values
none

< acc internal high-speed clock calibration ready interrupt enable

Definition at line 98 of file at32f435_437_acc.c.

Referenced by main().

◆ acc_read_c1()

uint16_t acc_read_c1 ( void )

return the current acc c1 value.

Parameters
none
Return values
16-bit c1 value.

Definition at line 165 of file at32f435_437_acc.c.

◆ acc_read_c2()

uint16_t acc_read_c2 ( void )

return the current acc c2 value.

Parameters
none
Return values
16-bit c2 value.

Definition at line 175 of file at32f435_437_acc.c.

◆ acc_read_c3()

uint16_t acc_read_c3 ( void )

return the current acc c3 value.

Parameters
none
Return values
16-bit c3 value.

Definition at line 185 of file at32f435_437_acc.c.

◆ acc_sof_select()

void acc_sof_select ( uint16_t sof_sel )

select sof sourse for acc in acc's ctrl1 register.

Parameters
sof_sel value to be stored in the acc's ctrl1 register this parameter can be one of the following values:
  • ACC_SOF_OTG1
  • ACC_SOF_OTG2
Return values
none

Definition at line 84 of file at32f435_437_acc.c.

Referenced by main(), and usb_clock48m_select().

◆ acc_step_set()

void acc_step_set ( uint8_t step_value )

store calibration step data in acc's ctrl1 register.

Parameters
step_value value to be stored in the acc's ctrl1 register
Return values
none

Definition at line 71 of file at32f435_437_acc.c.

◆ acc_write_c1()

void acc_write_c1 ( uint16_t acc_c1_value )

wtire the value to acc c1 register.

Parameters
acc_c1_value
Return values
none.

Definition at line 135 of file at32f435_437_acc.c.

Referenced by main(), and usb_clock48m_select().

◆ acc_write_c2()

void acc_write_c2 ( uint16_t acc_c2_value )

wtire the value to acc c2 register.

Parameters
acc_c2_value
Return values
none.

Definition at line 145 of file at32f435_437_acc.c.

Referenced by main(), and usb_clock48m_select().

◆ acc_write_c3()

void acc_write_c3 ( uint16_t acc_c3_value )

wtire the value to acc c3 register.

Parameters
acc_c3_value
Return values
none.

Definition at line 155 of file at32f435_437_acc.c.

Referenced by main(), and usb_clock48m_select().


AT32F435/437 Firmwary Library: ACC_private_functions

Functions
ACC_private_functions
AT32F435_437_periph_driver » ACC

Functions

void | acc_calibration_mode_enable (uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode. More...
void | acc_step_set (uint8_t step_value)
store calibration step data in acc's ctrl1 register. More...
void | acc_sof_select (uint16_t sof_sel)
select sof sourse for acc in acc's ctrl1 register. More...
void | acc_interrupt_enable (uint16_t acc_int, confirm_state new_state)
enable or disable the specified acc interrupts. More...
uint8_t | acc_hicktrim_get (void)
return the current acc hicktrim value. More...
uint8_t | acc_hickcal_get (void)
return the current acc hickcal value. More...
void | acc_write_c1 (uint16_t acc_c1_value)
wtire the value to acc c1 register. More...
void | acc_write_c2 (uint16_t acc_c2_value)
wtire the value to acc c2 register. More...
void | acc_write_c3 (uint16_t acc_c3_value)
wtire the value to acc c3 register. More...
uint16_t | acc_read_c1 (void)
return the current acc c1 value. More...
uint16_t | acc_read_c2 (void)
return the current acc c2 value. More...
uint16_t | acc_read_c3 (void)
return the current acc c3 value. More...
flag_status | acc_flag_get (uint16_t acc_flag)
check whether the specified acc flag is set or not. More...
void | acc_flag_clear (uint16_t acc_flag)
clear the specified acc flag is set or not. More...

Detailed Description

Function Documentation

◆ acc_calibration_mode_enable()

void acc_calibration_mode_enable | ( | uint16_t | acc_trim,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the acc calibration mode.

Parameters
acc_trim specifies the acc calibration type. this parameter can be one of the following values:
  • ACC_CAL_HICKCAL
  • ACC_CAL_HICKTRIM
new_state specifies the acc calibration to be enabled or disabled.(TRUE or FALSE)
Return values
none

< acc hick calibration

Definition at line 53 of file at32f435_437_acc.c.

Referenced by main(), and usb_clock48m_select().

◆ acc_flag_clear()

void acc_flag_clear ( uint16_t acc_flag )

clear the specified acc flag is set or not.

Parameters
acc_flag specifies the flag to check. this parameter can be any combination of the following values:
  • ACC_RSLOST_FLAG
  • ACC_CALRDY_FLAG
Return values
none

Definition at line 214 of file at32f435_437_acc.c.

Referenced by ACC_IRQHandler().

◆ acc_flag_get()

flag_status acc_flag_get ( uint16_t acc_flag )

check whether the specified acc flag is set or not.

Parameters
acc_flag specifies the flag to check. this parameter can be one of the following values:
  • ACC_RSLOST_FLAG
  • ACC_CALRDY_FLAG
Return values
flag_status (SET or RESET)

< acc internal high-speed clock calibration ready error flag

Definition at line 198 of file at32f435_437_acc.c.

Referenced by ACC_IRQHandler().

◆ acc_hickcal_get()

uint8_t acc_hickcal_get ( void )

return the current acc hickcal value.

Parameters
none
Return values
8-bit hicktrim value.

Definition at line 125 of file at32f435_437_acc.c.

◆ acc_hicktrim_get()

uint8_t acc_hicktrim_get ( void )

return the current acc hicktrim value.

Parameters
none
Return values
8-bit hicktrim value.

Definition at line 115 of file at32f435_437_acc.c.

◆ acc_interrupt_enable()

void acc_interrupt_enable | ( | uint16_t | acc_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified acc interrupts.

Parameters
acc_int specifies the acc interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • ACC_CALRDYIEN_INT
  • ACC_EIEN_INT
new_state (TRUE or FALSE)
Return values
none

< acc internal high-speed clock calibration ready interrupt enable

Definition at line 98 of file at32f435_437_acc.c.

Referenced by main().

◆ acc_read_c1()

uint16_t acc_read_c1 ( void )

return the current acc c1 value.

Parameters
none
Return values
16-bit c1 value.

Definition at line 165 of file at32f435_437_acc.c.

◆ acc_read_c2()

uint16_t acc_read_c2 ( void )

return the current acc c2 value.

Parameters
none
Return values
16-bit c2 value.

Definition at line 175 of file at32f435_437_acc.c.

◆ acc_read_c3()

uint16_t acc_read_c3 ( void )

return the current acc c3 value.

Parameters
none
Return values
16-bit c3 value.

Definition at line 185 of file at32f435_437_acc.c.

◆ acc_sof_select()

void acc_sof_select ( uint16_t sof_sel )

select sof sourse for acc in acc's ctrl1 register.

Parameters
sof_sel value to be stored in the acc's ctrl1 register this parameter can be one of the following values:
  • ACC_SOF_OTG1
  • ACC_SOF_OTG2
Return values
none

Definition at line 84 of file at32f435_437_acc.c.

Referenced by main(), and usb_clock48m_select().

◆ acc_step_set()

void acc_step_set ( uint8_t step_value )

store calibration step data in acc's ctrl1 register.

Parameters
step_value value to be stored in the acc's ctrl1 register
Return values
none

Definition at line 71 of file at32f435_437_acc.c.

◆ acc_write_c1()

void acc_write_c1 ( uint16_t acc_c1_value )

wtire the value to acc c1 register.

Parameters
acc_c1_value
Return values
none.

Definition at line 135 of file at32f435_437_acc.c.

Referenced by main(), and usb_clock48m_select().

◆ acc_write_c2()

void acc_write_c2 ( uint16_t acc_c2_value )

wtire the value to acc c2 register.

Parameters
acc_c2_value
Return values
none.

Definition at line 145 of file at32f435_437_acc.c.

Referenced by main(), and usb_clock48m_select().

◆ acc_write_c3()

void acc_write_c3 ( uint16_t acc_c3_value )

wtire the value to acc c3 register.

Parameters
acc_c3_value
Return values
none.

Definition at line 155 of file at32f435_437_acc.c.

Referenced by main(), and usb_clock48m_select().


AT32F435/437 Firmwary Library: ADC

Modules | Macros
ADC
AT32F435_437_periph_driver

ADC driver modules. More...

Modules

ADC_interrupts_definition
adc interrupt
ADC_flags_definition
adc flag
ADC_exported_types
ADC_exported_functions
ADC_private_functions

Macros

#define | ADC1 ((adc_type *) ADC1_BASE)
#define | ADC2 ((adc_type *) ADC2_BASE)
#define | ADC3 ((adc_type *) ADC3_BASE)
#define | ADCCOM ((adccom_type *) ADCCOM_BASE)

Detailed Description

ADC driver modules.

Macro Definition Documentation

◆ ADC1

#define ADC1 ((adc_type *) ADC1_BASE)

Definition at line 866 of file at32f435_437_adc.h.

◆ ADC2

#define ADC2 ((adc_type *) ADC2_BASE)

Definition at line 867 of file at32f435_437_adc.h.

◆ ADC3

#define ADC3 ((adc_type *) ADC3_BASE)

Definition at line 868 of file at32f435_437_adc.h.

◆ ADCCOM

#define ADCCOM ((adccom_type *) ADCCOM_BASE)

Definition at line 869 of file at32f435_437_adc.h.


AT32F435/437 Firmwary Library: ADC_interrupts_definition

Macros
ADC_interrupts_definition
AT32F435_437_periph_driver » ADC

adc interrupt More...

Macros

#define | ADC_OCCE_INT ((uint32_t)0x00000020)
#define | ADC_VMOR_INT ((uint32_t)0x00000040)
#define | ADC_PCCE_INT ((uint32_t)0x00000080)
#define | ADC_OCCO_INT ((uint32_t)0x04000000)

Detailed Description

adc interrupt

Macro Definition Documentation

◆ ADC_OCCE_INT

#define ADC_OCCE_INT ((uint32_t)0x00000020)

ordinary channels conversion end interrupt

Definition at line 53 of file at32f435_437_adc.h.

◆ ADC_OCCO_INT

#define ADC_OCCO_INT ((uint32_t)0x04000000)

ordinary channel conversion overflow interrupt

Definition at line 56 of file at32f435_437_adc.h.

◆ ADC_PCCE_INT

#define ADC_PCCE_INT ((uint32_t)0x00000080)

preempt channels conversion end interrupt

Definition at line 55 of file at32f435_437_adc.h.

◆ ADC_VMOR_INT

#define ADC_VMOR_INT ((uint32_t)0x00000040)

voltage monitoring out of range interrupt

Definition at line 54 of file at32f435_437_adc.h.


AT32F435/437 Firmwary Library: ADC_flags_definition

Macros
ADC_flags_definition
AT32F435_437_periph_driver » ADC

adc flag More...

Macros

#define | ADC_VMOR_FLAG ((uint8_t)0x01)
#define | ADC_OCCE_FLAG ((uint8_t)0x02)
#define | ADC_PCCE_FLAG ((uint8_t)0x04)
#define | ADC_PCCS_FLAG ((uint8_t)0x08)
#define | ADC_OCCS_FLAG ((uint8_t)0x10)
#define | ADC_OCCO_FLAG ((uint8_t)0x20)
#define | ADC_RDY_FLAG ((uint8_t)0x40)

Detailed Description

adc flag

Macro Definition Documentation

◆ ADC_OCCE_FLAG

#define ADC_OCCE_FLAG ((uint8_t)0x02)

ordinary channels conversion end flag

Definition at line 68 of file at32f435_437_adc.h.

◆ ADC_OCCO_FLAG

#define ADC_OCCO_FLAG ((uint8_t)0x20)

ordinary channel conversion overflow flag

Definition at line 72 of file at32f435_437_adc.h.

◆ ADC_OCCS_FLAG

#define ADC_OCCS_FLAG ((uint8_t)0x10)

ordinary channel conversion start flag

Definition at line 71 of file at32f435_437_adc.h.

◆ ADC_PCCE_FLAG

#define ADC_PCCE_FLAG ((uint8_t)0x04)

preempt channels conversion end flag

Definition at line 69 of file at32f435_437_adc.h.

◆ ADC_PCCS_FLAG

#define ADC_PCCS_FLAG ((uint8_t)0x08)

preempt channel conversion start flag

Definition at line 70 of file at32f435_437_adc.h.

◆ ADC_RDY_FLAG

#define ADC_RDY_FLAG ((uint8_t)0x40)

adc ready to conversion flag

Definition at line 73 of file at32f435_437_adc.h.

◆ ADC_VMOR_FLAG

#define ADC_VMOR_FLAG ((uint8_t)0x01)

voltage monitoring out of range flag

Definition at line 67 of file at32f435_437_adc.h.


AT32F435/437 Firmwary Library: ADC_exported_types

Data Structures | Enumerations
ADC_exported_types
AT32F435_437_periph_driver » ADC

Data Structures

struct | adc_common_config_type
adc common config type More...
struct | adc_base_config_type
adc base config type More...
struct | adc_type
type define adc register all More...
struct | adccom_type
type define adc register all More...

Enumerations

enum adc_div_type {
ADC_HCLK_DIV_2 = 0x00 , ADC_HCLK_DIV_3 = 0x01 , ADC_HCLK_DIV_4 = 0x02 , ADC_HCLK_DIV_5 = 0x03 ,
ADC_HCLK_DIV_6 = 0x04 , ADC_HCLK_DIV_7 = 0x05 , ADC_HCLK_DIV_8 = 0x06 , ADC_HCLK_DIV_9 = 0x07 ,
ADC_HCLK_DIV_10 = 0x08 , ADC_HCLK_DIV_11 = 0x09 , ADC_HCLK_DIV_12 = 0x0A , ADC_HCLK_DIV_13 = 0x0B ,
ADC_HCLK_DIV_14 = 0x0C , ADC_HCLK_DIV_15 = 0x0D , ADC_HCLK_DIV_16 = 0x0E , ADC_HCLK_DIV_17 = 0x0F
}
adc division type More...
enum adc_combine_mode_type {
ADC_INDEPENDENT_MODE = 0x00 , ADC_ORDINARY_SMLT_PREEMPT_SMLT_ONESLAVE_MODE = 0x01 , ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_ONESLAVE_MODE = 0x02 , ADC_PREEMPT_SMLT_ONLY_ONESLAVE_MODE = 0x05 ,
ADC_ORDINARY_SMLT_ONLY_ONESLAVE_MODE = 0x06 , ADC_ORDINARY_SHIFT_ONLY_ONESLAVE_MODE = 0x07 , ADC_PREEMPT_INTERLTRIG_ONLY_ONESLAVE_MODE = 0x09 , ADC_ORDINARY_SMLT_PREEMPT_SMLT_TWOSLAVE_MODE = 0x11 ,
ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_TWOSLAVE_MODE = 0x12 , ADC_PREEMPT_SMLT_ONLY_TWOSLAVE_MODE = 0x15 , ADC_ORDINARY_SMLT_ONLY_TWOSLAVE_MODE = 0x16 , ADC_ORDINARY_SHIFT_ONLY_TWOSLAVE_MODE = 0x17 ,
ADC_PREEMPT_INTERLTRIG_ONLY_TWOSLAVE_MODE = 0x19
}
adc combine mode type More...
enum adc_common_dma_mode_type {
ADC_COMMON_DMAMODE_DISABLE = 0x00 , ADC_COMMON_DMAMODE_1 = 0x01 , ADC_COMMON_DMAMODE_2 = 0x02 , ADC_COMMON_DMAMODE_3 = 0x03 ,
ADC_COMMON_DMAMODE_4 = 0x04 , ADC_COMMON_DMAMODE_5 = 0x05
}
adc common dma mode type More...
enum adc_sampling_interval_type {
ADC_SAMPLING_INTERVAL_5CYCLES = 0x00 , ADC_SAMPLING_INTERVAL_6CYCLES = 0x01 , ADC_SAMPLING_INTERVAL_7CYCLES = 0x02 , ADC_SAMPLING_INTERVAL_8CYCLES = 0x03 ,
ADC_SAMPLING_INTERVAL_9CYCLES = 0x04 , ADC_SAMPLING_INTERVAL_10CYCLES = 0x05 , ADC_SAMPLING_INTERVAL_11CYCLES = 0x06 , ADC_SAMPLING_INTERVAL_12CYCLES = 0x07 ,
ADC_SAMPLING_INTERVAL_13CYCLES = 0x08 , ADC_SAMPLING_INTERVAL_14CYCLES = 0x09 , ADC_SAMPLING_INTERVAL_15CYCLES = 0x0A , ADC_SAMPLING_INTERVAL_16CYCLES = 0x0B ,
ADC_SAMPLING_INTERVAL_17CYCLES = 0x0C , ADC_SAMPLING_INTERVAL_18CYCLES = 0x0D , ADC_SAMPLING_INTERVAL_19CYCLES = 0x0E , ADC_SAMPLING_INTERVAL_20CYCLES = 0x0F
}
adc common sampling interval type More...
enum | adc_resolution_type { ADC_RESOLUTION_12B = 0x00 , ADC_RESOLUTION_10B = 0x01 , ADC_RESOLUTION_8B = 0x02 , ADC_RESOLUTION_6B = 0x03 }
adc conversion resolution type More...
enum | adc_data_align_type { ADC_RIGHT_ALIGNMENT = 0x00 , ADC_LEFT_ALIGNMENT = 0x01 }
adc data align type More...
enum adc_channel_select_type {
ADC_CHANNEL_0 = 0x00 , ADC_CHANNEL_1 = 0x01 , ADC_CHANNEL_2 = 0x02 , ADC_CHANNEL_3 = 0x03 ,
ADC_CHANNEL_4 = 0x04 , ADC_CHANNEL_5 = 0x05 , ADC_CHANNEL_6 = 0x06 , ADC_CHANNEL_7 = 0x07 ,
ADC_CHANNEL_8 = 0x08 , ADC_CHANNEL_9 = 0x09 , ADC_CHANNEL_10 = 0x0A , ADC_CHANNEL_11 = 0x0B ,
ADC_CHANNEL_12 = 0x0C , ADC_CHANNEL_13 = 0x0D , ADC_CHANNEL_14 = 0x0E , ADC_CHANNEL_15 = 0x0F ,
ADC_CHANNEL_16 = 0x10 , ADC_CHANNEL_17 = 0x11 , ADC_CHANNEL_18 = 0x12
}
adc channel select type More...
enum adc_sampletime_select_type {
ADC_SAMPLETIME_2_5 = 0x00 , ADC_SAMPLETIME_6_5 = 0x01 , ADC_SAMPLETIME_12_5 = 0x02 , ADC_SAMPLETIME_24_5 = 0x03 ,
ADC_SAMPLETIME_47_5 = 0x04 , ADC_SAMPLETIME_92_5 = 0x05 , ADC_SAMPLETIME_247_5 = 0x06 , ADC_SAMPLETIME_640_5 = 0x07
}
adc sampletime select type More...
enum adc_ordinary_trig_select_type {
ADC_ORDINARY_TRIG_TMR1CH1 = 0x00 , ADC_ORDINARY_TRIG_TMR1CH2 = 0x01 , ADC_ORDINARY_TRIG_TMR1CH3 = 0x02 , ADC_ORDINARY_TRIG_TMR2CH2 = 0x03 ,
ADC_ORDINARY_TRIG_TMR2CH3 = 0x04 , ADC_ORDINARY_TRIG_TMR2CH4 = 0x05 , ADC_ORDINARY_TRIG_TMR2TRGOUT = 0x06 , ADC_ORDINARY_TRIG_TMR3CH1 = 0x07 ,
ADC_ORDINARY_TRIG_TMR3TRGOUT = 0x08 , ADC_ORDINARY_TRIG_TMR4CH4 = 0x09 , ADC_ORDINARY_TRIG_TMR5CH1 = 0x0A , ADC_ORDINARY_TRIG_TMR5CH2 = 0x0B ,
ADC_ORDINARY_TRIG_TMR5CH3 = 0x0C , ADC_ORDINARY_TRIG_TMR8CH1 = 0x0D , ADC_ORDINARY_TRIG_TMR8TRGOUT = 0x0E , ADC_ORDINARY_TRIG_EXINT11 = 0x0F ,
ADC_ORDINARY_TRIG_TMR20TRGOUT = 0x10 , ADC_ORDINARY_TRIG_TMR20TRGOUT2 = 0x11 , ADC_ORDINARY_TRIG_TMR20CH1 = 0x12 , ADC_ORDINARY_TRIG_TMR20CH2 = 0x13 ,
ADC_ORDINARY_TRIG_TMR20CH3 = 0x14 , ADC_ORDINARY_TRIG_TMR8TRGOUT2 = 0x15 , ADC_ORDINARY_TRIG_TMR1TRGOUT2 = 0x16 , ADC_ORDINARY_TRIG_TMR4TRGOUT = 0x17 ,
ADC_ORDINARY_TRIG_TMR6TRGOUT = 0x18 , ADC_ORDINARY_TRIG_TMR3CH4 = 0x19 , ADC_ORDINARY_TRIG_TMR4CH1 = 0x1A , ADC_ORDINARY_TRIG_TMR1TRGOUT = 0x1B ,
ADC_ORDINARY_TRIG_TMR2CH1 = 0x1C , ADC_ORDINARY_TRIG_TMR7TRGOUT = 0x1E
}
adc ordinary group trigger event select type More...
enum | adc_ordinary_trig_edge_type { ADC_ORDINARY_TRIG_EDGE_NONE = 0x00 , ADC_ORDINARY_TRIG_EDGE_RISING = 0x01 , ADC_ORDINARY_TRIG_EDGE_FALLING = 0x02 , ADC_ORDINARY_TRIG_EDGE_RISING_FALLING = 0x03 }
adc ordinary channel conversion's external_trigger_edge type More...
enum adc_preempt_trig_select_type {
ADC_PREEMPT_TRIG_TMR1CH4 = 0x00 , ADC_PREEMPT_TRIG_TMR1TRGOUT = 0x01 , ADC_PREEMPT_TRIG_TMR2CH1 = 0x02 , ADC_PREEMPT_TRIG_TMR2TRGOUT = 0x03 ,
ADC_PREEMPT_TRIG_TMR3CH2 = 0x04 , ADC_PREEMPT_TRIG_TMR3CH4 = 0x05 , ADC_PREEMPT_TRIG_TMR4CH1 = 0x06 , ADC_PREEMPT_TRIG_TMR4CH2 = 0x07 ,
ADC_PREEMPT_TRIG_TMR4CH3 = 0x08 , ADC_PREEMPT_TRIG_TMR4TRGOUT = 0x09 , ADC_PREEMPT_TRIG_TMR5CH4 = 0x0A , ADC_PREEMPT_TRIG_TMR5TRGOUT = 0x0B ,
ADC_PREEMPT_TRIG_TMR8CH2 = 0x0C , ADC_PREEMPT_TRIG_TMR8CH3 = 0x0D , ADC_PREEMPT_TRIG_TMR8CH4 = 0x0E , ADC_PREEMPT_TRIG_EXINT15 = 0x0F ,
ADC_PREEMPT_TRIG_TMR20TRGOUT = 0x10 , ADC_PREEMPT_TRIG_TMR20TRGOUT2 = 0x11 , ADC_PREEMPT_TRIG_TMR20CH4 = 0x12 , ADC_PREEMPT_TRIG_TMR1TRGOUT2 = 0x13 ,
ADC_PREEMPT_TRIG_TMR8TRGOUT = 0x14 , ADC_PREEMPT_TRIG_TMR8TRGOUT2 = 0x15 , ADC_PREEMPT_TRIG_TMR3CH3 = 0x16 , ADC_PREEMPT_TRIG_TMR3TRGOUT = 0x17 ,
ADC_PREEMPT_TRIG_TMR3CH1 = 0x18 , ADC_PREEMPT_TRIG_TMR6TRGOUT = 0x19 , ADC_PREEMPT_TRIG_TMR4CH4 = 0x1A , ADC_PREEMPT_TRIG_TMR1CH3 = 0x1B ,
ADC_PREEMPT_TRIG_TMR20CH2 = 0x1C , ADC_PREEMPT_TRIG_TMR7TRGOUT = 0x1E
}
adc preempt group external trigger event select type More...
enum | adc_preempt_trig_edge_type { ADC_PREEMPT_TRIG_EDGE_NONE = 0x00 , ADC_PREEMPT_TRIG_EDGE_RISING = 0x01 , ADC_PREEMPT_TRIG_EDGE_FALLING = 0x02 , ADC_PREEMPT_TRIG_EDGE_RISING_FALLING = 0x03 }
adc preempt channel conversion's external_trigger_edge type More...
enum | adc_preempt_channel_type { ADC_PREEMPT_CHANNEL_1 = 0x00 , ADC_PREEMPT_CHANNEL_2 = 0x01 , ADC_PREEMPT_CHANNEL_3 = 0x02 , ADC_PREEMPT_CHANNEL_4 = 0x03 }
adc preempt channel type More...
enum adc_voltage_monitoring_type {
ADC_VMONITOR_SINGLE_ORDINARY = 0x00800200 , ADC_VMONITOR_SINGLE_PREEMPT = 0x00400200 , ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT = 0x00C00200 , ADC_VMONITOR_ALL_ORDINARY = 0x00800000 ,
ADC_VMONITOR_ALL_PREEMPT = 0x00400000 , ADC_VMONITOR_ALL_ORDINARY_PREEMPT = 0x00C00000 , ADC_VMONITOR_NONE = 0x00000000
}
adc voltage_monitoring type More...
enum adc_oversample_ratio_type {
ADC_OVERSAMPLE_RATIO_2 = 0x00 , ADC_OVERSAMPLE_RATIO_4 = 0x01 , ADC_OVERSAMPLE_RATIO_8 = 0x02 , ADC_OVERSAMPLE_RATIO_16 = 0x03 ,
ADC_OVERSAMPLE_RATIO_32 = 0x04 , ADC_OVERSAMPLE_RATIO_64 = 0x05 , ADC_OVERSAMPLE_RATIO_128 = 0x06 , ADC_OVERSAMPLE_RATIO_256 = 0x07
}
adc oversample ratio type More...
enum adc_oversample_shift_type {
ADC_OVERSAMPLE_SHIFT_0 = 0x00 , ADC_OVERSAMPLE_SHIFT_1 = 0x01 , ADC_OVERSAMPLE_SHIFT_2 = 0x02 , ADC_OVERSAMPLE_SHIFT_3 = 0x03 ,
ADC_OVERSAMPLE_SHIFT_4 = 0x04 , ADC_OVERSAMPLE_SHIFT_5 = 0x05 , ADC_OVERSAMPLE_SHIFT_6 = 0x06 , ADC_OVERSAMPLE_SHIFT_7 = 0x07 ,
ADC_OVERSAMPLE_SHIFT_8 = 0x08
}
adc oversample shift type More...
enum | adc_ordinary_oversample_restart_type { ADC_OVERSAMPLE_CONTINUE = 0x00 , ADC_OVERSAMPLE_RESTART = 0x01 }
adc ordinary oversample recover type More...

Detailed Description

Enumeration Type Documentation

◆ adc_channel_select_type

enum adc_channel_select_type

adc channel select type

Enumerator
ADC_CHANNEL_0 | adc channel 0
ADC_CHANNEL_1 | adc channel 1
ADC_CHANNEL_2 | adc channel 2
ADC_CHANNEL_3 | adc channel 3
ADC_CHANNEL_4 | adc channel 4
ADC_CHANNEL_5 | adc channel 5
ADC_CHANNEL_6 | adc channel 6
ADC_CHANNEL_7 | adc channel 7
ADC_CHANNEL_8 | adc channel 8
ADC_CHANNEL_9 | adc channel 9
ADC_CHANNEL_10 | adc channel 10
ADC_CHANNEL_11 | adc channel 11
ADC_CHANNEL_12 | adc channel 12
ADC_CHANNEL_13 | adc channel 13
ADC_CHANNEL_14 | adc channel 14
ADC_CHANNEL_15 | adc channel 15
ADC_CHANNEL_16 | adc channel 16
ADC_CHANNEL_17 | adc channel 17
ADC_CHANNEL_18 | adc channel 18

Definition at line 185 of file at32f435_437_adc.h.

◆ adc_combine_mode_type

enum adc_combine_mode_type

adc combine mode type

Enumerator
ADC_INDEPENDENT_MODE | independent mode
ADC_ORDINARY_SMLT_PREEMPT_SMLT_ONESLAVE_MODE | single slaver combined ordinary simultaneous + preempt simultaneous mode
ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_ONESLAVE_MODE | single slaver combined ordinary simultaneous + preempt interleaved trigger mode
ADC_PREEMPT_SMLT_ONLY_ONESLAVE_MODE | single slaver preempt simultaneous mode only
ADC_ORDINARY_SMLT_ONLY_ONESLAVE_MODE | single slaver ordinary simultaneous mode only
ADC_ORDINARY_SHIFT_ONLY_ONESLAVE_MODE | single slaver ordinary shifting mode only
ADC_PREEMPT_INTERLTRIG_ONLY_ONESLAVE_MODE | single slaver preempt interleaved trigger mode only
ADC_ORDINARY_SMLT_PREEMPT_SMLT_TWOSLAVE_MODE | double slaver combined ordinary simultaneous + preempt simultaneous mode
ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_TWOSLAVE_MODE | double slaver combined ordinary simultaneous + preempt interleaved trigger mode
ADC_PREEMPT_SMLT_ONLY_TWOSLAVE_MODE | double slaver preempt simultaneous mode only
ADC_ORDINARY_SMLT_ONLY_TWOSLAVE_MODE | double slaver ordinary simultaneous mode only
ADC_ORDINARY_SHIFT_ONLY_TWOSLAVE_MODE | double slaver ordinary shifting mode only
ADC_PREEMPT_INTERLTRIG_ONLY_TWOSLAVE_MODE | double slaver preempt interleaved trigger mode only

Definition at line 109 of file at32f435_437_adc.h.

◆ adc_common_dma_mode_type

enum adc_common_dma_mode_type

adc common dma mode type

Enumerator
ADC_COMMON_DMAMODE_DISABLE | dma mode disabled
ADC_COMMON_DMAMODE_1 | dma mode1: each dma request trans a half-word data(reference manual account the rule of data package)
ADC_COMMON_DMAMODE_2 | dma mode2: each dma request trans two half-word data(reference manual account the rule of data package)
ADC_COMMON_DMAMODE_3 | dma mode3: each dma request trans two bytes data(reference manual account the rule of data package)
ADC_COMMON_DMAMODE_4 | dma mode4: each dma request trans three bytes data(reference manual account the rule of data package)
ADC_COMMON_DMAMODE_5 | dma mode5: odd dma request trans two half-word data,even dma request trans a half-word data(reference manual account the rule of data package)

Definition at line 129 of file at32f435_437_adc.h.

◆ adc_data_align_type

enum adc_data_align_type

adc data align type

Enumerator
ADC_RIGHT_ALIGNMENT | data right alignment
ADC_LEFT_ALIGNMENT | data left alignment

Definition at line 176 of file at32f435_437_adc.h.

◆ adc_div_type

enum adc_div_type

adc division type

Enumerator
ADC_HCLK_DIV_2 | adcclk is hclk/2
ADC_HCLK_DIV_3 | adcclk is hclk/3
ADC_HCLK_DIV_4 | adcclk is hclk/4
ADC_HCLK_DIV_5 | adcclk is hclk/5
ADC_HCLK_DIV_6 | adcclk is hclk/6
ADC_HCLK_DIV_7 | adcclk is hclk/7
ADC_HCLK_DIV_8 | adcclk is hclk/8
ADC_HCLK_DIV_9 | adcclk is hclk/9
ADC_HCLK_DIV_10 | adcclk is hclk/10
ADC_HCLK_DIV_11 | adcclk is hclk/11
ADC_HCLK_DIV_12 | adcclk is hclk/12
ADC_HCLK_DIV_13 | adcclk is hclk/13
ADC_HCLK_DIV_14 | adcclk is hclk/14
ADC_HCLK_DIV_15 | adcclk is hclk/15
ADC_HCLK_DIV_16 | adcclk is hclk/16
ADC_HCLK_DIV_17 | adcclk is hclk/17

Definition at line 86 of file at32f435_437_adc.h.

◆ adc_ordinary_oversample_restart_type

enum adc_ordinary_oversample_restart_type

adc ordinary oversample recover type

Enumerator
ADC_OVERSAMPLE_CONTINUE | continue mode:when preempt triggered,oversampling is temporary stopped and continued after preempt sequence
ADC_OVERSAMPLE_RESTART | restart mode:when preempt triggered,oversampling is aborted and resumed from start after preempt sequence

Definition at line 378 of file at32f435_437_adc.h.

◆ adc_ordinary_trig_edge_type

enum adc_ordinary_trig_edge_type

adc ordinary channel conversion's external_trigger_edge type

Enumerator
ADC_ORDINARY_TRIG_EDGE_NONE | ordinary channels trigger detection disabled
ADC_ORDINARY_TRIG_EDGE_RISING | ordinary channels trigger detection on the rising edge
ADC_ORDINARY_TRIG_EDGE_FALLING | ordinary channels trigger detection on the falling edge
ADC_ORDINARY_TRIG_EDGE_RISING_FALLING | ordinary channels trigger detection on both the rising and falling edges

Definition at line 263 of file at32f435_437_adc.h.

◆ adc_ordinary_trig_select_type

enum adc_ordinary_trig_select_type

adc ordinary group trigger event select type

Enumerator
ADC_ORDINARY_TRIG_TMR1CH1 | timer1 ch1 event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR1CH2 | timer1 ch2 event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR1CH3 | timer1 ch3 event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR2CH2 | timer2 ch2 event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR2CH3 | timer2 ch3 event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR2CH4 | timer2 ch4 event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR2TRGOUT | timer2 trgout event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR3CH1 | timer3 ch1 event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR3TRGOUT | timer3 trgout event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR4CH4 | timer4 ch4 event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR5CH1 | timer5 ch1 event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR5CH2 | timer5 ch2 event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR5CH3 | timer5 ch3 event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR8CH1 | timer8 ch1 event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR8TRGOUT | timer8 trgout event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_EXINT11 | exint line11 event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR20TRGOUT | timer20 trgout event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR20TRGOUT2 | timer20 trgout2 event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR20CH1 | timer20 ch1 event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR20CH2 | timer20 ch2 event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR20CH3 | timer20 ch3 event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR8TRGOUT2 | timer8 trgout2 event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR1TRGOUT2 | timer1 trgout2 event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR4TRGOUT | timer4 trgout event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR6TRGOUT | timer6 trgout event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR3CH4 | timer3 ch4 event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR4CH1 | timer4 ch1 event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR1TRGOUT | timer1 trgout event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR2CH1 | timer2 ch1 event as trigger source of ordinary sequence
ADC_ORDINARY_TRIG_TMR7TRGOUT | timer7 trgout event as trigger source of ordinary sequence

Definition at line 226 of file at32f435_437_adc.h.

◆ adc_oversample_ratio_type

enum adc_oversample_ratio_type

adc oversample ratio type

Enumerator
ADC_OVERSAMPLE_RATIO_2 | adc oversample ratio 2
ADC_OVERSAMPLE_RATIO_4 | adc oversample ratio 4
ADC_OVERSAMPLE_RATIO_8 | adc oversample ratio 8
ADC_OVERSAMPLE_RATIO_16 | adc oversample ratio 16
ADC_OVERSAMPLE_RATIO_32 | adc oversample ratio 32
ADC_OVERSAMPLE_RATIO_64 | adc oversample ratio 64
ADC_OVERSAMPLE_RATIO_128 | adc oversample ratio 128
ADC_OVERSAMPLE_RATIO_256 | adc oversample ratio 256

Definition at line 347 of file at32f435_437_adc.h.

◆ adc_oversample_shift_type

enum adc_oversample_shift_type

adc oversample shift type

Enumerator
ADC_OVERSAMPLE_SHIFT_0 | adc oversample shift 0
ADC_OVERSAMPLE_SHIFT_1 | adc oversample shift 1
ADC_OVERSAMPLE_SHIFT_2 | adc oversample shift 2
ADC_OVERSAMPLE_SHIFT_3 | adc oversample shift 3
ADC_OVERSAMPLE_SHIFT_4 | adc oversample shift 4
ADC_OVERSAMPLE_SHIFT_5 | adc oversample shift 5
ADC_OVERSAMPLE_SHIFT_6 | adc oversample shift 6
ADC_OVERSAMPLE_SHIFT_7 | adc oversample shift 7
ADC_OVERSAMPLE_SHIFT_8 | adc oversample shift 8

Definition at line 362 of file at32f435_437_adc.h.

◆ adc_preempt_channel_type

enum adc_preempt_channel_type

adc preempt channel type

Enumerator
ADC_PREEMPT_CHANNEL_1 | adc preempt channel 1
ADC_PREEMPT_CHANNEL_2 | adc preempt channel 2
ADC_PREEMPT_CHANNEL_3 | adc preempt channel 3
ADC_PREEMPT_CHANNEL_4 | adc preempt channel 4

Definition at line 322 of file at32f435_437_adc.h.

◆ adc_preempt_trig_edge_type

enum adc_preempt_trig_edge_type

adc preempt channel conversion's external_trigger_edge type

Enumerator
ADC_PREEMPT_TRIG_EDGE_NONE | preempt channels trigger detection disabled
ADC_PREEMPT_TRIG_EDGE_RISING | preempt channels trigger detection on the rising edge
ADC_PREEMPT_TRIG_EDGE_FALLING | preempt channels trigger detection on the falling edge
ADC_PREEMPT_TRIG_EDGE_RISING_FALLING | preempt channels trigger detection on both the rising and falling edges

Definition at line 311 of file at32f435_437_adc.h.

◆ adc_preempt_trig_select_type

enum adc_preempt_trig_select_type

adc preempt group external trigger event select type

Enumerator
ADC_PREEMPT_TRIG_TMR1CH4 | timer1 ch4 event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR1TRGOUT | timer1 trgout event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR2CH1 | timer2 ch1 event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR2TRGOUT | timer2 trgout event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR3CH2 | timer3 ch2 event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR3CH4 | timer3 ch4 event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR4CH1 | timer4 ch1 event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR4CH2 | timer4 ch2 event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR4CH3 | timer4 ch3 event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR4TRGOUT | timer4 trgout event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR5CH4 | timer5 ch4 event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR5TRGOUT | timer5 trgout event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR8CH2 | timer8 ch2 event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR8CH3 | timer8 ch3 event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR8CH4 | timer8 ch4 event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_EXINT15 | exint line15 event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR20TRGOUT | timer20 trgout event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR20TRGOUT2 | timer20 trgout2 event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR20CH4 | timer20 ch4 event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR1TRGOUT2 | timer1 trgout2 event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR8TRGOUT | timer8 trgout event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR8TRGOUT2 | timer8 trgout2 event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR3CH3 | timer3 ch3 event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR3TRGOUT | timer3 trgout event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR3CH1 | timer3 ch1 event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR6TRGOUT | timer6 trgout event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR4CH4 | timer4 ch4 event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR1CH3 | timer1 ch3 event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR20CH2 | timer20 ch2 event as trigger source of preempt sequence
ADC_PREEMPT_TRIG_TMR7TRGOUT | timer7 trgout event as trigger source of preempt sequence

Definition at line 274 of file at32f435_437_adc.h.

◆ adc_resolution_type

enum adc_resolution_type

adc conversion resolution type

Enumerator
ADC_RESOLUTION_12B | conversion resolution 12 bit
ADC_RESOLUTION_10B | conversion resolution 10 bit
ADC_RESOLUTION_8B | conversion resolution 8 bit
ADC_RESOLUTION_6B | conversion resolution 6 bit

Definition at line 165 of file at32f435_437_adc.h.

◆ adc_sampletime_select_type

enum adc_sampletime_select_type

adc sampletime select type

Enumerator
ADC_SAMPLETIME_2_5 | adc sample time 2.5 cycle
ADC_SAMPLETIME_6_5 | adc sample time 6.5 cycle
ADC_SAMPLETIME_12_5 | adc sample time 12.5 cycle
ADC_SAMPLETIME_24_5 | adc sample time 24.5 cycle
ADC_SAMPLETIME_47_5 | adc sample time 47.5 cycle
ADC_SAMPLETIME_92_5 | adc sample time 92.5 cycle
ADC_SAMPLETIME_247_5 | adc sample time 247.5 cycle
ADC_SAMPLETIME_640_5 | adc sample time 640.5 cycle

Definition at line 211 of file at32f435_437_adc.h.

◆ adc_sampling_interval_type

enum adc_sampling_interval_type

adc common sampling interval type

Enumerator
ADC_SAMPLING_INTERVAL_5CYCLES | ordinary shifting mode adjacent adc sampling interval 5 adcclk
ADC_SAMPLING_INTERVAL_6CYCLES | ordinary shifting mode adjacent adc sampling interval 6 adcclk
ADC_SAMPLING_INTERVAL_7CYCLES | ordinary shifting mode adjacent adc sampling interval 7 adcclk
ADC_SAMPLING_INTERVAL_8CYCLES | ordinary shifting mode adjacent adc sampling interval 8 adcclk
ADC_SAMPLING_INTERVAL_9CYCLES | ordinary shifting mode adjacent adc sampling interval 9 adcclk
ADC_SAMPLING_INTERVAL_10CYCLES | ordinary shifting mode adjacent adc sampling interval 10 adcclk
ADC_SAMPLING_INTERVAL_11CYCLES | ordinary shifting mode adjacent adc sampling interval 11 adcclk
ADC_SAMPLING_INTERVAL_12CYCLES | ordinary shifting mode adjacent adc sampling interval 12 adcclk
ADC_SAMPLING_INTERVAL_13CYCLES | ordinary shifting mode adjacent adc sampling interval 13 adcclk
ADC_SAMPLING_INTERVAL_14CYCLES | ordinary shifting mode adjacent adc sampling interval 14 adcclk
ADC_SAMPLING_INTERVAL_15CYCLES | ordinary shifting mode adjacent adc sampling interval 15 adcclk
ADC_SAMPLING_INTERVAL_16CYCLES | ordinary shifting mode adjacent adc sampling interval 16 adcclk
ADC_SAMPLING_INTERVAL_17CYCLES | ordinary shifting mode adjacent adc sampling interval 17 adcclk
ADC_SAMPLING_INTERVAL_18CYCLES | ordinary shifting mode adjacent adc sampling interval 18 adcclk
ADC_SAMPLING_INTERVAL_19CYCLES | ordinary shifting mode adjacent adc sampling interval 19 adcclk
ADC_SAMPLING_INTERVAL_20CYCLES | ordinary shifting mode adjacent adc sampling interval 20 adcclk

Definition at line 142 of file at32f435_437_adc.h.

◆ adc_voltage_monitoring_type

enum adc_voltage_monitoring_type

adc voltage_monitoring type

Enumerator
ADC_VMONITOR_SINGLE_ORDINARY | voltage_monitoring on a single ordinary channel
ADC_VMONITOR_SINGLE_PREEMPT | voltage_monitoring on a single preempt channel
ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT | voltage_monitoring on a single ordinary or preempt channel
ADC_VMONITOR_ALL_ORDINARY | voltage_monitoring on all ordinary channel
ADC_VMONITOR_ALL_PREEMPT | voltage_monitoring on all preempt channel
ADC_VMONITOR_ALL_ORDINARY_PREEMPT | voltage_monitoring on all ordinary and preempt channel
ADC_VMONITOR_NONE | no channel guarded by the voltage_monitoring

Definition at line 333 of file at32f435_437_adc.h.


AT32F435/437 Firmwary Library: adc_common_config_type Struct Reference

Data Fields
adc_common_config_type Struct Reference
AT32F435_437_periph_driver » ADC » ADC_exported_types

adc common config type More...

#include <at32f435_437_adc.h>

Data Fields

adc_combine_mode_type combine_mode
adc_div_type div
adc_common_dma_mode_type common_dma_mode
confirm_state common_dma_request_repeat_state
adc_sampling_interval_type sampling_interval
confirm_state tempervintrv_state
confirm_state vbat_state

Detailed Description

adc common config type

Definition at line 387 of file at32f435_437_adc.h.

Field Documentation

◆ combine_mode

adc_combine_mode_type adc_common_config_type::combine_mode

adc combine mode select

Definition at line 389 of file at32f435_437_adc.h.

Referenced by adc_common_config(), adc_common_default_para_init(), adc_config(), and adc_configuration().

◆ common_dma_mode

adc_common_dma_mode_type adc_common_config_type::common_dma_mode

adc common dma mode select

Definition at line 391 of file at32f435_437_adc.h.

Referenced by adc_common_config(), adc_common_default_para_init(), adc_config(), and adc_configuration().

◆ common_dma_request_repeat_state

confirm_state adc_common_config_type::common_dma_request_repeat_state

adc common dma repeat state

Definition at line 392 of file at32f435_437_adc.h.

Referenced by adc_common_config(), adc_common_default_para_init(), adc_config(), and adc_configuration().

◆ div

adc_div_type adc_common_config_type::div

adc division select

Definition at line 390 of file at32f435_437_adc.h.

Referenced by adc_common_config(), adc_common_default_para_init(), adc_config(), and adc_configuration().

◆ sampling_interval

adc_sampling_interval_type adc_common_config_type::sampling_interval

ordinary shifting mode adjacent adc sampling interval select

Definition at line 393 of file at32f435_437_adc.h.

Referenced by adc_common_config(), adc_common_default_para_init(), adc_config(), and adc_configuration().

◆ tempervintrv_state

confirm_state adc_common_config_type::tempervintrv_state

adc temperature sensor and vintrv state

Definition at line 394 of file at32f435_437_adc.h.

Referenced by adc_common_config(), adc_common_default_para_init(), adc_config(), and adc_configuration().

◆ vbat_state

confirm_state adc_common_config_type::vbat_state

adc voltage battery state

Definition at line 395 of file at32f435_437_adc.h.

Referenced by adc_common_config(), adc_common_default_para_init(), adc_config(), and adc_configuration().

The documentation for this struct was generated from the following file:
  • at32f435_437_adc.h


AT32F435/437 Firmwary Library: adc_base_config_type Struct Reference

Data Fields
adc_base_config_type Struct Reference
AT32F435_437_periph_driver » ADC » ADC_exported_types

adc base config type More...

#include <at32f435_437_adc.h>

Data Fields

confirm_state sequence_mode
confirm_state repeat_mode
adc_data_align_type data_align
uint8_t ordinary_channel_length

Detailed Description

adc base config type

Definition at line 401 of file at32f435_437_adc.h.

Field Documentation

◆ data_align

adc_data_align_type adc_base_config_type::data_align

adc data alignment

Definition at line 405 of file at32f435_437_adc.h.

Referenced by adc_base_config(), adc_base_default_para_init(), adc_config(), and adc_configuration().

◆ ordinary_channel_length

uint8_t adc_base_config_type::ordinary_channel_length

adc ordinary channel sequence length

Definition at line 406 of file at32f435_437_adc.h.

Referenced by adc_base_config(), adc_base_default_para_init(), adc_config(), and adc_configuration().

◆ repeat_mode

confirm_state adc_base_config_type::repeat_mode

adc repeat mode

Definition at line 404 of file at32f435_437_adc.h.

Referenced by adc_base_config(), adc_base_default_para_init(), adc_config(), and adc_configuration().

◆ sequence_mode

confirm_state adc_base_config_type::sequence_mode

adc sequence mode

Definition at line 403 of file at32f435_437_adc.h.

Referenced by adc_base_config(), adc_base_default_para_init(), adc_config(), and adc_configuration().

The documentation for this struct was generated from the following file:
  • at32f435_437_adc.h


AT32F435/437 Firmwary Library: adc_type Struct Reference

Data Fields
adc_type Struct Reference
AT32F435_437_periph_driver » ADC » ADC_exported_types

type define adc register all More...

#include <at32f435_437_adc.h>

Data Fields

union {
__IO uint32_t sts
struct {
__IO uint32_t vmor: 1
__IO uint32_t occe: 1
__IO uint32_t pcce: 1
__IO uint32_t pccs: 1
__IO uint32_t occs: 1
__IO uint32_t occo: 1
__IO uint32_t rdy: 1
__IO uint32_t reserved1: 25
} sts_bit
};
adc sts register, offset:0x00 More...
union {
__IO uint32_t ctrl1
struct {
__IO uint32_t vmcsel: 5
__IO uint32_t occeien: 1
__IO uint32_t vmorien: 1
__IO uint32_t pcceien: 1
__IO uint32_t sqen: 1
__IO uint32_t vmsgen: 1
__IO uint32_t pcautoen: 1
__IO uint32_t ocpen: 1
__IO uint32_t pcpen: 1
__IO uint32_t ocpcnt: 3
__IO uint32_t reserved1: 6
__IO uint32_t pcvmen: 1
__IO uint32_t ocvmen: 1
__IO uint32_t crsel: 2
__IO uint32_t occoien: 1
__IO uint32_t reserved2: 5
} ctrl1_bit
};
adc ctrl1 register, offset:0x04 More...
union {
__IO uint32_t ctrl2
struct {
__IO uint32_t adcen: 1
__IO uint32_t rpen: 1
__IO uint32_t adcal: 1
__IO uint32_t adcalinit: 1
__IO uint32_t adabrt: 1
__IO uint32_t reserved1: 3
__IO uint32_t ocdmaen: 1
__IO uint32_t ocdrcen: 1
__IO uint32_t eocsfen: 1
__IO uint32_t dtalign: 1
__IO uint32_t reserved2: 4
__IO uint32_t pctesel_l: 4
__IO uint32_t pcete: 2
__IO uint32_t pcswtrg: 1
__IO uint32_t pctesel_h: 1
__IO uint32_t octesel_l: 4
__IO uint32_t ocete: 2
__IO uint32_t ocswtrg: 1
__IO uint32_t octesel_h: 1
} ctrl2_bit
};
adc ctrl2 register, offset:0x08 More...
union {
__IO uint32_t spt1
struct {
__IO uint32_t cspt10: 3
__IO uint32_t cspt11: 3
__IO uint32_t cspt12: 3
__IO uint32_t cspt13: 3
__IO uint32_t cspt14: 3
__IO uint32_t cspt15: 3
__IO uint32_t cspt16: 3
__IO uint32_t cspt17: 3
__IO uint32_t cspt18: 3
__IO uint32_t reserved1: 5
} spt1_bit
};
adc spt1 register, offset:0x0C More...
union {
__IO uint32_t spt2
struct {
__IO uint32_t cspt0: 3
__IO uint32_t cspt1: 3
__IO uint32_t cspt2: 3
__IO uint32_t cspt3: 3
__IO uint32_t cspt4: 3
__IO uint32_t cspt5: 3
__IO uint32_t cspt6: 3
__IO uint32_t cspt7: 3
__IO uint32_t cspt8: 3
__IO uint32_t cspt9: 3
__IO uint32_t reserved1: 2
} spt2_bit
};
adc spt2 register, offset:0x10 More...
union {
__IO uint32_t pcdto1
struct {
__IO uint32_t pcdto1: 12
__IO uint32_t reserved1: 20
} pcdto1_bit
};
adc pcdto1 register, offset:0x14 More...
union {
__IO uint32_t pcdto2
struct {
__IO uint32_t pcdto2: 12
__IO uint32_t reserved1: 20
} pcdto2_bit
};
adc pcdto2 register, offset:0x18 More...
union {
__IO uint32_t pcdto3
struct {
__IO uint32_t pcdto3: 12
__IO uint32_t reserved1: 20
} pcdto3_bit
};
adc pcdto3 register, offset:0x1C More...
union {
__IO uint32_t pcdto4
struct {
__IO uint32_t pcdto4: 12
__IO uint32_t reserved1: 20
} pcdto4_bit
};
adc pcdto4 register, offset:0x20 More...
union {
__IO uint32_t vmhb
struct {
__IO uint32_t vmhb: 12
__IO uint32_t reserved1: 20
} vmhb_bit
};
adc vmhb register, offset:0x24 More...
union {
__IO uint32_t vmlb
struct {
__IO uint32_t vmlb: 12
__IO uint32_t reserved1: 20
} vmlb_bit
};
adc vmlb register, offset:0x28 More...
union {
__IO uint32_t osq1
struct {
__IO uint32_t osn13: 5
__IO uint32_t osn14: 5
__IO uint32_t osn15: 5
__IO uint32_t osn16: 5
__IO uint32_t oclen: 4
__IO uint32_t reserved1: 8
} osq1_bit
};
adc osq1 register, offset:0x2C More...
union {
__IO uint32_t osq2
struct {
__IO uint32_t osn7: 5
__IO uint32_t osn8: 5
__IO uint32_t osn9: 5
__IO uint32_t osn10: 5
__IO uint32_t osn11: 5
__IO uint32_t osn12: 5
__IO uint32_t reserved1: 2
} osq2_bit
};
adc osq2 register, offset:0x30 More...
union {
__IO uint32_t osq3
struct {
__IO uint32_t osn1: 5
__IO uint32_t osn2: 5
__IO uint32_t osn3: 5
__IO uint32_t osn4: 5
__IO uint32_t osn5: 5
__IO uint32_t osn6: 5
__IO uint32_t reserved1: 2
} osq3_bit
};
adc osq3 register, offset:0x34 More...
union {
__IO uint32_t psq
struct {
__IO uint32_t psn1: 5
__IO uint32_t psn2: 5
__IO uint32_t psn3: 5
__IO uint32_t psn4: 5
__IO uint32_t pclen: 2
__IO uint32_t reserved1: 10
} psq_bit
};
adc psq register, offset:0x38 More...
union {
__IO uint32_t pdt1
struct {
__IO uint32_t pdt1: 16
__IO uint32_t reserved1: 16
} pdt1_bit
};
adc pdt1 register, offset:0x3C More...
union {
__IO uint32_t pdt2
struct {
__IO uint32_t pdt2: 16
__IO uint32_t reserved1: 16
} pdt2_bit
};
adc pdt2 register, offset:0x40 More...
union {
__IO uint32_t pdt3
struct {
__IO uint32_t pdt3: 16
__IO uint32_t reserved1: 16
} pdt3_bit
};
adc pdt3 register, offset:0x44 More...
union {
__IO uint32_t pdt4
struct {
__IO uint32_t pdt4: 16
__IO uint32_t reserved1: 16
} pdt4_bit
};
adc pdt4 register, offset:0x48 More...
union {
__IO uint32_t odt
struct {
__IO uint32_t odt: 16
__IO uint32_t reserved1: 16
} odt_bit
};
adc odt register, offset:0x4C More...
union {
__IO uint32_t ovsp
struct {
__IO uint32_t oosen: 1
__IO uint32_t posen: 1
__IO uint32_t osrsel: 3
__IO uint32_t osssel: 4
__IO uint32_t oostren: 1
__IO uint32_t oosrsel: 1
__IO uint32_t reserved1: 21
} ovsp_bit
};
adc ovsp register, offset:0x80 More...
union {
__IO uint32_t calval
struct {
__IO uint32_t calval: 7
__IO uint32_t reserved1: 25
} calval_bit
};
adc calval register, offset:0xB4 More...

Detailed Description

type define adc register all

Definition at line 412 of file at32f435_437_adc.h.

Field Documentation

◆

union { ... } adc_type::@19

adc sts register, offset:0x00

◆

union { ... } adc_type::@21

adc ctrl1 register, offset:0x04

◆

union { ... } adc_type::@23

adc ctrl2 register, offset:0x08

◆

union { ... } adc_type::@25

adc spt1 register, offset:0x0C

◆

union { ... } adc_type::@27

adc spt2 register, offset:0x10

◆

union { ... } adc_type::@29

adc pcdto1 register, offset:0x14

◆

union { ... } adc_type::@31

adc pcdto2 register, offset:0x18

◆

union { ... } adc_type::@33

adc pcdto3 register, offset:0x1C

◆

union { ... } adc_type::@35

adc pcdto4 register, offset:0x20

◆

union { ... } adc_type::@37

adc vmhb register, offset:0x24

◆

union { ... } adc_type::@39

adc vmlb register, offset:0x28

◆

union { ... } adc_type::@41

adc osq1 register, offset:0x2C

◆

union { ... } adc_type::@43

adc osq2 register, offset:0x30

◆

union { ... } adc_type::@45

adc osq3 register, offset:0x34

◆

union { ... } adc_type::@47

adc psq register, offset:0x38

◆

union { ... } adc_type::@49

adc pdt1 register, offset:0x3C

◆

union { ... } adc_type::@51

adc pdt2 register, offset:0x40

◆

union { ... } adc_type::@53

adc pdt3 register, offset:0x44

◆

union { ... } adc_type::@55

adc pdt4 register, offset:0x48

◆

union { ... } adc_type::@57

adc odt register, offset:0x4C

◆

union { ... } adc_type::@59

adc ovsp register, offset:0x80

◆

union { ... } adc_type::@61

adc calval register, offset:0xB4

◆ adabrt

__IO uint32_t adc_type::adabrt

Definition at line 473 of file at32f435_437_adc.h.

Referenced by adc_conversion_stop(), and adc_conversion_stop_status_get().

◆ adcal

__IO uint32_t adc_type::adcal

Definition at line 471 of file at32f435_437_adc.h.

Referenced by adc_calibration_start(), and adc_calibration_status_get().

◆ adcalinit

__IO uint32_t adc_type::adcalinit

Definition at line 472 of file at32f435_437_adc.h.

Referenced by adc_calibration_init(), and adc_calibration_init_status_get().

◆ adcen

__IO uint32_t adc_type::adcen

Definition at line 469 of file at32f435_437_adc.h.

Referenced by adc_enable().

◆ calval

__IO uint32_t adc_type::calval

Definition at line 774 of file at32f435_437_adc.h.

Referenced by adc_calibration_value_set().

◆

struct { ... } adc_type::calval_bit

◆ crsel

__IO uint32_t adc_type::crsel

Definition at line 455 of file at32f435_437_adc.h.

Referenced by adc_resolution_set().

◆ cspt0

__IO uint32_t adc_type::cspt0

Definition at line 520 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt1

__IO uint32_t adc_type::cspt1

Definition at line 521 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt10

__IO uint32_t adc_type::cspt10

Definition at line 499 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt11

__IO uint32_t adc_type::cspt11

Definition at line 500 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt12

__IO uint32_t adc_type::cspt12

Definition at line 501 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt13

__IO uint32_t adc_type::cspt13

Definition at line 502 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt14

__IO uint32_t adc_type::cspt14

Definition at line 503 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt15

__IO uint32_t adc_type::cspt15

Definition at line 504 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt16

__IO uint32_t adc_type::cspt16

Definition at line 505 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt17

__IO uint32_t adc_type::cspt17

Definition at line 506 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt18

__IO uint32_t adc_type::cspt18

Definition at line 507 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt2

__IO uint32_t adc_type::cspt2

Definition at line 522 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt3

__IO uint32_t adc_type::cspt3

Definition at line 523 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt4

__IO uint32_t adc_type::cspt4

Definition at line 524 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt5

__IO uint32_t adc_type::cspt5

Definition at line 525 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt6

__IO uint32_t adc_type::cspt6

Definition at line 526 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt7

__IO uint32_t adc_type::cspt7

Definition at line 527 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt8

__IO uint32_t adc_type::cspt8

Definition at line 528 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt9

__IO uint32_t adc_type::cspt9

Definition at line 529 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ ctrl1

__IO uint32_t adc_type::ctrl1

Definition at line 439 of file at32f435_437_adc.h.

Referenced by adc_interrupt_enable(), and adc_voltage_monitor_enable().

◆

struct { ... } adc_type::ctrl1_bit

Referenced by adc_base_config(), adc_ordinary_part_count_set(), adc_ordinary_part_mode_enable(), adc_preempt_auto_mode_enable(), adc_preempt_part_mode_enable(), adc_resolution_set(), adc_voltage_monitor_enable(), and adc_voltage_monitor_single_channel_select().

◆ ctrl2

__IO uint32_t adc_type::ctrl2

Definition at line 466 of file at32f435_437_adc.h.

◆

struct { ... } adc_type::ctrl2_bit

Referenced by adc_base_config(), adc_calibration_init(), adc_calibration_init_status_get(), adc_calibration_start(), adc_calibration_status_get(), adc_conversion_stop(), adc_conversion_stop_status_get(), adc_dma_mode_enable(), adc_dma_request_repeat_enable(), adc_enable(), adc_occe_each_conversion_enable(), adc_ordinary_conversion_trigger_set(), adc_ordinary_software_trigger_enable(), adc_ordinary_software_trigger_status_get(), adc_preempt_conversion_trigger_set(), adc_preempt_software_trigger_enable(), and adc_preempt_software_trigger_status_get().

◆ dtalign

__IO uint32_t adc_type::dtalign

Definition at line 478 of file at32f435_437_adc.h.

Referenced by adc_base_config().

◆ eocsfen

__IO uint32_t adc_type::eocsfen

Definition at line 477 of file at32f435_437_adc.h.

Referenced by adc_occe_each_conversion_enable().

◆ occe

__IO uint32_t adc_type::occe

Definition at line 424 of file at32f435_437_adc.h.

◆ occeien

__IO uint32_t adc_type::occeien

Definition at line 443 of file at32f435_437_adc.h.

◆ occo

__IO uint32_t adc_type::occo

Definition at line 428 of file at32f435_437_adc.h.

◆ occoien

__IO uint32_t adc_type::occoien

Definition at line 456 of file at32f435_437_adc.h.

◆ occs

__IO uint32_t adc_type::occs

Definition at line 427 of file at32f435_437_adc.h.

◆ ocdmaen

__IO uint32_t adc_type::ocdmaen

Definition at line 475 of file at32f435_437_adc.h.

Referenced by adc_dma_mode_enable().

◆ ocdrcen

__IO uint32_t adc_type::ocdrcen

Definition at line 476 of file at32f435_437_adc.h.

Referenced by adc_dma_request_repeat_enable().

◆ ocete

__IO uint32_t adc_type::ocete

Definition at line 485 of file at32f435_437_adc.h.

Referenced by adc_ordinary_conversion_trigger_set().

◆ oclen

__IO uint32_t adc_type::oclen

Definition at line 624 of file at32f435_437_adc.h.

Referenced by adc_base_config().

◆ ocpcnt

__IO uint32_t adc_type::ocpcnt

Definition at line 451 of file at32f435_437_adc.h.

Referenced by adc_ordinary_part_count_set().

◆ ocpen

__IO uint32_t adc_type::ocpen

Definition at line 449 of file at32f435_437_adc.h.

Referenced by adc_ordinary_part_mode_enable().

◆ ocswtrg

__IO uint32_t adc_type::ocswtrg

Definition at line 486 of file at32f435_437_adc.h.

Referenced by adc_ordinary_software_trigger_enable(), and adc_ordinary_software_trigger_status_get().

◆ octesel_h

__IO uint32_t adc_type::octesel_h

Definition at line 487 of file at32f435_437_adc.h.

Referenced by adc_ordinary_conversion_trigger_set().

◆ octesel_l

__IO uint32_t adc_type::octesel_l

Definition at line 484 of file at32f435_437_adc.h.

Referenced by adc_ordinary_conversion_trigger_set().

◆ ocvmen

__IO uint32_t adc_type::ocvmen

Definition at line 454 of file at32f435_437_adc.h.

Referenced by adc_voltage_monitor_enable().

◆ odt

__IO uint32_t adc_type::odt

Definition at line 739 of file at32f435_437_adc.h.

Referenced by adc_ordinary_conversion_data_get().

◆

struct { ... } adc_type::odt_bit

Referenced by adc_ordinary_conversion_data_get().

◆ oosen

__IO uint32_t adc_type::oosen

Definition at line 757 of file at32f435_437_adc.h.

Referenced by adc_ordinary_oversample_enable().

◆ oosrsel

__IO uint32_t adc_type::oosrsel

Definition at line 762 of file at32f435_437_adc.h.

Referenced by adc_ordinary_oversample_restart_set().

◆ oostren

__IO uint32_t adc_type::oostren

Definition at line 761 of file at32f435_437_adc.h.

Referenced by adc_ordinary_oversample_trig_enable().

◆ osn1

__IO uint32_t adc_type::osn1

Definition at line 655 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn10

__IO uint32_t adc_type::osn10

Definition at line 640 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn11

__IO uint32_t adc_type::osn11

Definition at line 641 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn12

__IO uint32_t adc_type::osn12

Definition at line 642 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn13

__IO uint32_t adc_type::osn13

Definition at line 620 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn14

__IO uint32_t adc_type::osn14

Definition at line 621 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn15

__IO uint32_t adc_type::osn15

Definition at line 622 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn16

__IO uint32_t adc_type::osn16

Definition at line 623 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn2

__IO uint32_t adc_type::osn2

Definition at line 656 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn3

__IO uint32_t adc_type::osn3

Definition at line 657 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn4

__IO uint32_t adc_type::osn4

Definition at line 658 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn5

__IO uint32_t adc_type::osn5

Definition at line 659 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn6

__IO uint32_t adc_type::osn6

Definition at line 660 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn7

__IO uint32_t adc_type::osn7

Definition at line 637 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn8

__IO uint32_t adc_type::osn8

Definition at line 638 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn9

__IO uint32_t adc_type::osn9

Definition at line 639 of file at32f435_437_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osq1

__IO uint32_t adc_type::osq1

Definition at line 617 of file at32f435_437_adc.h.

◆

struct { ... } adc_type::osq1_bit

Referenced by adc_base_config(), and adc_ordinary_channel_set().

◆ osq2

__IO uint32_t adc_type::osq2

Definition at line 634 of file at32f435_437_adc.h.

◆

struct { ... } adc_type::osq2_bit

Referenced by adc_ordinary_channel_set().

◆ osq3

__IO uint32_t adc_type::osq3

Definition at line 652 of file at32f435_437_adc.h.

◆

struct { ... } adc_type::osq3_bit

Referenced by adc_ordinary_channel_set().

◆ osrsel

__IO uint32_t adc_type::osrsel

Definition at line 759 of file at32f435_437_adc.h.

Referenced by adc_oversample_ratio_shift_set().

◆ osssel

__IO uint32_t adc_type::osssel

Definition at line 760 of file at32f435_437_adc.h.

Referenced by adc_oversample_ratio_shift_set().

◆ ovsp

__IO uint32_t adc_type::ovsp

Definition at line 754 of file at32f435_437_adc.h.

◆

struct { ... } adc_type::ovsp_bit

Referenced by adc_ordinary_oversample_enable(), adc_ordinary_oversample_restart_set(), adc_ordinary_oversample_trig_enable(), adc_oversample_ratio_shift_set(), and adc_preempt_oversample_enable().

◆ pcautoen

__IO uint32_t adc_type::pcautoen

Definition at line 448 of file at32f435_437_adc.h.

Referenced by adc_preempt_auto_mode_enable().

◆ pcce

__IO uint32_t adc_type::pcce

Definition at line 425 of file at32f435_437_adc.h.

◆ pcceien

__IO uint32_t adc_type::pcceien

Definition at line 445 of file at32f435_437_adc.h.

◆ pccs

__IO uint32_t adc_type::pccs

Definition at line 426 of file at32f435_437_adc.h.

◆ pcdto1

__IO uint32_t adc_type::pcdto1

Definition at line 539 of file at32f435_437_adc.h.

Referenced by adc_preempt_offset_value_set().

◆

struct { ... } adc_type::pcdto1_bit

Referenced by adc_preempt_offset_value_set().

◆ pcdto2

__IO uint32_t adc_type::pcdto2

Definition at line 552 of file at32f435_437_adc.h.

Referenced by adc_preempt_offset_value_set().

◆

struct { ... } adc_type::pcdto2_bit

Referenced by adc_preempt_offset_value_set().

◆ pcdto3

__IO uint32_t adc_type::pcdto3

Definition at line 565 of file at32f435_437_adc.h.

Referenced by adc_preempt_offset_value_set().

◆

struct { ... } adc_type::pcdto3_bit

Referenced by adc_preempt_offset_value_set().

◆ pcdto4

__IO uint32_t adc_type::pcdto4

Definition at line 578 of file at32f435_437_adc.h.

Referenced by adc_preempt_offset_value_set().

◆

struct { ... } adc_type::pcdto4_bit

Referenced by adc_preempt_offset_value_set().

◆ pcete

__IO uint32_t adc_type::pcete

Definition at line 481 of file at32f435_437_adc.h.

Referenced by adc_preempt_conversion_trigger_set().

◆ pclen

__IO uint32_t adc_type::pclen

Definition at line 677 of file at32f435_437_adc.h.

Referenced by adc_preempt_channel_length_set(), and adc_preempt_channel_set().

◆ pcpen

__IO uint32_t adc_type::pcpen

Definition at line 450 of file at32f435_437_adc.h.

Referenced by adc_preempt_part_mode_enable().

◆ pcswtrg

__IO uint32_t adc_type::pcswtrg

Definition at line 482 of file at32f435_437_adc.h.

Referenced by adc_preempt_software_trigger_enable(), and adc_preempt_software_trigger_status_get().

◆ pctesel_h

__IO uint32_t adc_type::pctesel_h

Definition at line 483 of file at32f435_437_adc.h.

Referenced by adc_preempt_conversion_trigger_set().

◆ pctesel_l

__IO uint32_t adc_type::pctesel_l

Definition at line 480 of file at32f435_437_adc.h.

Referenced by adc_preempt_conversion_trigger_set().

◆ pcvmen

__IO uint32_t adc_type::pcvmen

Definition at line 453 of file at32f435_437_adc.h.

Referenced by adc_voltage_monitor_enable().

◆ pdt1

__IO uint32_t adc_type::pdt1

Definition at line 687 of file at32f435_437_adc.h.

Referenced by adc_preempt_conversion_data_get().

◆

struct { ... } adc_type::pdt1_bit

Referenced by adc_preempt_conversion_data_get().

◆ pdt2

__IO uint32_t adc_type::pdt2

Definition at line 700 of file at32f435_437_adc.h.

Referenced by adc_preempt_conversion_data_get().

◆

struct { ... } adc_type::pdt2_bit

Referenced by adc_preempt_conversion_data_get().

◆ pdt3

__IO uint32_t adc_type::pdt3

Definition at line 713 of file at32f435_437_adc.h.

Referenced by adc_preempt_conversion_data_get().

◆

struct { ... } adc_type::pdt3_bit

Referenced by adc_preempt_conversion_data_get().

◆ pdt4

__IO uint32_t adc_type::pdt4

Definition at line 726 of file at32f435_437_adc.h.

Referenced by adc_preempt_conversion_data_get().

◆

struct { ... } adc_type::pdt4_bit

Referenced by adc_preempt_conversion_data_get().

◆ posen

__IO uint32_t adc_type::posen

Definition at line 758 of file at32f435_437_adc.h.

Referenced by adc_preempt_oversample_enable().

◆ psn1

__IO uint32_t adc_type::psn1

Definition at line 673 of file at32f435_437_adc.h.

Referenced by adc_preempt_channel_set().

◆ psn2

__IO uint32_t adc_type::psn2

Definition at line 674 of file at32f435_437_adc.h.

Referenced by adc_preempt_channel_set().

◆ psn3

__IO uint32_t adc_type::psn3

Definition at line 675 of file at32f435_437_adc.h.

Referenced by adc_preempt_channel_set().

◆ psn4

__IO uint32_t adc_type::psn4

Definition at line 676 of file at32f435_437_adc.h.

Referenced by adc_preempt_channel_set().

◆ psq

__IO uint32_t adc_type::psq

Definition at line 670 of file at32f435_437_adc.h.

◆

struct { ... } adc_type::psq_bit

Referenced by adc_preempt_channel_length_set(), and adc_preempt_channel_set().

◆ rdy

__IO uint32_t adc_type::rdy

Definition at line 429 of file at32f435_437_adc.h.

◆ reserved1

__IO uint32_t adc_type::reserved1

Definition at line 430 of file at32f435_437_adc.h.

◆ reserved2

__IO uint32_t adc_type::reserved2

Definition at line 457 of file at32f435_437_adc.h.

◆ rpen

__IO uint32_t adc_type::rpen

Definition at line 470 of file at32f435_437_adc.h.

Referenced by adc_base_config().

◆ spt1

__IO uint32_t adc_type::spt1

Definition at line 496 of file at32f435_437_adc.h.

◆

struct { ... } adc_type::spt1_bit

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ spt2

__IO uint32_t adc_type::spt2

Definition at line 517 of file at32f435_437_adc.h.

◆

struct { ... } adc_type::spt2_bit

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ sqen

__IO uint32_t adc_type::sqen

Definition at line 446 of file at32f435_437_adc.h.

Referenced by adc_base_config().

◆ sts

__IO uint32_t adc_type::sts

Definition at line 420 of file at32f435_437_adc.h.

Referenced by adc_flag_clear(), and adc_flag_get().

◆

struct { ... } adc_type::sts_bit

◆ vmcsel

__IO uint32_t adc_type::vmcsel

Definition at line 442 of file at32f435_437_adc.h.

Referenced by adc_voltage_monitor_single_channel_select().

◆ vmhb

__IO uint32_t adc_type::vmhb

Definition at line 591 of file at32f435_437_adc.h.

Referenced by adc_voltage_monitor_threshold_value_set().

◆

struct { ... } adc_type::vmhb_bit

Referenced by adc_voltage_monitor_threshold_value_set().

◆ vmlb

__IO uint32_t adc_type::vmlb

Definition at line 604 of file at32f435_437_adc.h.

Referenced by adc_voltage_monitor_threshold_value_set().

◆

struct { ... } adc_type::vmlb_bit

Referenced by adc_voltage_monitor_threshold_value_set().

◆ vmor

__IO uint32_t adc_type::vmor

Definition at line 423 of file at32f435_437_adc.h.

◆ vmorien

__IO uint32_t adc_type::vmorien

Definition at line 444 of file at32f435_437_adc.h.

◆ vmsgen

__IO uint32_t adc_type::vmsgen

Definition at line 447 of file at32f435_437_adc.h.

Referenced by adc_voltage_monitor_enable().

The documentation for this struct was generated from the following file:
  • at32f435_437_adc.h


AT32F435/437 Firmwary Library: adccom_type Struct Reference

Data Fields
adccom_type Struct Reference
AT32F435_437_periph_driver » ADC » ADC_exported_types

type define adc register all More...

#include <at32f435_437_adc.h>

Data Fields

union {
__IO uint32_t csts
struct {
__IO uint32_t vmor1: 1
__IO uint32_t occe1: 1
__IO uint32_t pcce1: 1
__IO uint32_t pccs1: 1
__IO uint32_t occs1: 1
__IO uint32_t occo1: 1
__IO uint32_t rdy1: 1
__IO uint32_t reserved1: 1
__IO uint32_t vmor2: 1
__IO uint32_t occe2: 1
__IO uint32_t pcce2: 1
__IO uint32_t pccs2: 1
__IO uint32_t occs2: 1
__IO uint32_t occo2: 1
__IO uint32_t rdy2: 1
__IO uint32_t reserved2: 1
__IO uint32_t vmor3: 1
__IO uint32_t occe3: 1
__IO uint32_t pcce3: 1
__IO uint32_t pccs3: 1
__IO uint32_t occs3: 1
__IO uint32_t occo3: 1
__IO uint32_t rdy3: 1
__IO uint32_t reserved3: 9
} csts_bit
};
adc csts register, offset:0x00 More...
union {
__IO uint32_t cctrl
struct {
__IO uint32_t mssel: 5
__IO uint32_t reserved1: 3
__IO uint32_t asisel: 4
__IO uint32_t reserved2: 1
__IO uint32_t msdrcen: 1
__IO uint32_t msdmasel_l: 2
__IO uint32_t adcdiv: 4
__IO uint32_t reserved3: 2
__IO uint32_t vbaten: 1
__IO uint32_t itsrven: 1
__IO uint32_t reserved4: 4
__IO uint32_t msdmasel_h: 1
__IO uint32_t reserved5: 3
} cctrl_bit
};
adc cctrl register, offset:0x04 More...
union {
__IO uint32_t codt
struct {
__IO uint32_t codtl: 16
__IO uint32_t codth: 16
} codt_bit
};
adc codt register, offset:0x08 More...

Detailed Description

type define adc register all

Definition at line 786 of file at32f435_437_adc.h.

Field Documentation

◆

union { ... } adccom_type::@85

adc csts register, offset:0x00

◆

union { ... } adccom_type::@87

adc cctrl register, offset:0x04

◆

union { ... } adccom_type::@89

adc codt register, offset:0x08

◆ adcdiv

__IO uint32_t adccom_type::adcdiv

Definition at line 838 of file at32f435_437_adc.h.

◆ asisel

__IO uint32_t adccom_type::asisel

Definition at line 834 of file at32f435_437_adc.h.

◆ cctrl

__IO uint32_t adccom_type::cctrl

Definition at line 829 of file at32f435_437_adc.h.

◆

struct { ... } adccom_type::cctrl_bit

◆ codt

__IO uint32_t adccom_type::codt

Definition at line 853 of file at32f435_437_adc.h.

◆

struct { ... } adccom_type::codt_bit

◆ codth

__IO uint32_t adccom_type::codth

Definition at line 857 of file at32f435_437_adc.h.

◆ codtl

__IO uint32_t adccom_type::codtl

Definition at line 856 of file at32f435_437_adc.h.

◆ csts

__IO uint32_t adccom_type::csts

Definition at line 794 of file at32f435_437_adc.h.

◆

struct { ... } adccom_type::csts_bit

◆ itsrven

__IO uint32_t adccom_type::itsrven

Definition at line 841 of file at32f435_437_adc.h.

◆ msdmasel_h

__IO uint32_t adccom_type::msdmasel_h

Definition at line 843 of file at32f435_437_adc.h.

◆ msdmasel_l

__IO uint32_t adccom_type::msdmasel_l

Definition at line 837 of file at32f435_437_adc.h.

◆ msdrcen

__IO uint32_t adccom_type::msdrcen

Definition at line 836 of file at32f435_437_adc.h.

◆ mssel

__IO uint32_t adccom_type::mssel

Definition at line 832 of file at32f435_437_adc.h.

◆ occe1

__IO uint32_t adccom_type::occe1

Definition at line 798 of file at32f435_437_adc.h.

◆ occe2

__IO uint32_t adccom_type::occe2

Definition at line 806 of file at32f435_437_adc.h.

◆ occe3

__IO uint32_t adccom_type::occe3

Definition at line 814 of file at32f435_437_adc.h.

◆ occo1

__IO uint32_t adccom_type::occo1

Definition at line 802 of file at32f435_437_adc.h.

◆ occo2

__IO uint32_t adccom_type::occo2

Definition at line 810 of file at32f435_437_adc.h.

◆ occo3

__IO uint32_t adccom_type::occo3

Definition at line 818 of file at32f435_437_adc.h.

◆ occs1

__IO uint32_t adccom_type::occs1

Definition at line 801 of file at32f435_437_adc.h.

◆ occs2

__IO uint32_t adccom_type::occs2

Definition at line 809 of file at32f435_437_adc.h.

◆ occs3

__IO uint32_t adccom_type::occs3

Definition at line 817 of file at32f435_437_adc.h.

◆ pcce1

__IO uint32_t adccom_type::pcce1

Definition at line 799 of file at32f435_437_adc.h.

◆ pcce2

__IO uint32_t adccom_type::pcce2

Definition at line 807 of file at32f435_437_adc.h.

◆ pcce3

__IO uint32_t adccom_type::pcce3

Definition at line 815 of file at32f435_437_adc.h.

◆ pccs1

__IO uint32_t adccom_type::pccs1

Definition at line 800 of file at32f435_437_adc.h.

◆ pccs2

__IO uint32_t adccom_type::pccs2

Definition at line 808 of file at32f435_437_adc.h.

◆ pccs3

__IO uint32_t adccom_type::pccs3

Definition at line 816 of file at32f435_437_adc.h.

◆ rdy1

__IO uint32_t adccom_type::rdy1

Definition at line 803 of file at32f435_437_adc.h.

◆ rdy2

__IO uint32_t adccom_type::rdy2

Definition at line 811 of file at32f435_437_adc.h.

◆ rdy3

__IO uint32_t adccom_type::rdy3

Definition at line 819 of file at32f435_437_adc.h.

◆ reserved1

__IO uint32_t adccom_type::reserved1

Definition at line 804 of file at32f435_437_adc.h.

◆ reserved2

__IO uint32_t adccom_type::reserved2

Definition at line 812 of file at32f435_437_adc.h.

◆ reserved3

__IO uint32_t adccom_type::reserved3

Definition at line 820 of file at32f435_437_adc.h.

◆ reserved4

__IO uint32_t adccom_type::reserved4

Definition at line 842 of file at32f435_437_adc.h.

◆ reserved5

__IO uint32_t adccom_type::reserved5

Definition at line 844 of file at32f435_437_adc.h.

◆ vbaten

__IO uint32_t adccom_type::vbaten

Definition at line 840 of file at32f435_437_adc.h.

◆ vmor1

__IO uint32_t adccom_type::vmor1

Definition at line 797 of file at32f435_437_adc.h.

◆ vmor2

__IO uint32_t adccom_type::vmor2

Definition at line 805 of file at32f435_437_adc.h.

◆ vmor3

__IO uint32_t adccom_type::vmor3

Definition at line 813 of file at32f435_437_adc.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_adc.h


AT32F435/437 Firmwary Library: ADC_exported_functions

Functions
ADC_exported_functions
AT32F435_437_periph_driver » ADC

Functions

void | adc_reset (void)
deinitialize the adc peripheral registers to their default reset values. More...
void | adc_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral. More...
void | adc_base_default_para_init (adc_base_config_type *adc_base_struct)
adc base default para init. More...
void | adc_base_config (adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters. More...
void | adc_common_default_para_init (adc_common_config_type *adc_common_struct)
adc common default para init. More...
void | adc_common_config (adc_common_config_type *adc_common_struct)
adc common default para init. More...
void | adc_resolution_set (adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral. More...
void | adc_voltage_battery_enable (confirm_state new_state)
enable or disable the adc voltage battery. More...
void | adc_dma_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer. More...
void | adc_dma_request_repeat_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat. More...
void | adc_interrupt_enable (adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts. More...
void | adc_calibration_value_set (adc_type *adc_x, uint8_t adc_calibration_value)
set calibration value of the specified adc peripheral. More...
void | adc_calibration_init (adc_type *adc_x)
initialize calibration register of the specified adc peripheral. More...
flag_status | adc_calibration_init_status_get (adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral. More...
void | adc_calibration_start (adc_type *adc_x)
start calibration process of the specified adc peripheral. More...
flag_status | adc_calibration_status_get (adc_type *adc_x)
get calibration status of the specified adc peripheral. More...
void | adc_voltage_monitor_enable (adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring)
enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified adc peripheral. More...
void | adc_voltage_monitor_threshold_value_set (adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold)
set voltage monitoring's high and low thresholds value of the specified adc peripheral. More...
void | adc_voltage_monitor_single_channel_select (adc_type *adc_x, adc_channel_select_type adc_channel)
select the voltage monitoring's channel of the specified adc peripheral. More...
void | adc_ordinary_channel_set (adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc peripheral. More...
void | adc_preempt_channel_length_set (adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral. More...
void | adc_preempt_channel_set (adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc peripheral. More...
void | adc_ordinary_conversion_trigger_set (adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc peripheral. More...
void | adc_preempt_conversion_trigger_set (adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, adc_preempt_trig_edge_type adc_preempt_trig_edge)
enable or disable the preempt channel's external trigger and set external trigger event of the specified adc peripheral. More...
void | adc_preempt_offset_value_set (adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel, uint16_t adc_offset_value)
set preempt channel's conversion value offset of the specified adc peripheral. More...
void | adc_ordinary_part_count_set (adc_type *adc_x, uint8_t adc_channel_count)
set partitioned mode channel count of the specified adc peripheral. More...
void | adc_ordinary_part_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on ordinary channel of the specified adc peripheral. More...
void | adc_preempt_part_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on preempt channel of the specified adc peripheral. More...
void | adc_preempt_auto_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable automatic preempt group conversion of the specified adc peripheral. More...
void | adc_conversion_stop (adc_type *adc_x)
stop the ongoing conversion of the specified adc peripheral. More...
flag_status | adc_conversion_stop_status_get (adc_type *adc_x)
get stop conversion's status of the specified adc peripheral. More...
void | adc_occe_each_conversion_enable (adc_type *adc_x, confirm_state new_state)
enable or disable each ordinary channel conversion set occe flag of the specified adc peripheral. More...
void | adc_ordinary_software_trigger_enable (adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral. More...
flag_status | adc_ordinary_software_trigger_status_get (adc_type *adc_x)
get ordinary software start conversion status of the specified adc peripheral. More...
void | adc_preempt_software_trigger_enable (adc_type *adc_x, confirm_state new_state)
enable or disable preempt software start conversion of the specified adc peripheral. More...
flag_status | adc_preempt_software_trigger_status_get (adc_type *adc_x)
get preempt software start conversion status of the specified adc peripheral. More...
uint16_t | adc_ordinary_conversion_data_get (adc_type *adc_x)
return the last conversion data for ordinary channel of the specified adc peripheral. More...
uint32_t | adc_combine_ordinary_conversion_data_get (void)
return the last ordinary conversion data of combine adc. More...
uint16_t | adc_preempt_conversion_data_get (adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral. More...
flag_status | adc_flag_get (adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral. More...
void | adc_flag_clear (adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral. More...
void | adc_ordinary_oversample_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the ordinary oversampling of the specified adc peripheral. More...
void | adc_preempt_oversample_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the preempt oversampling of the specified adc peripheral. More...
void | adc_oversample_ratio_shift_set (adc_type *adc_x, adc_oversample_ratio_type adc_oversample_ratio, adc_oversample_shift_type adc_oversample_shift)
config the oversampling ratio and shift of the specified adc peripheral. More...
void | adc_ordinary_oversample_trig_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the ordinary oversampling trigger mode of the specified adc peripheral. More...
void | adc_ordinary_oversample_restart_set (adc_type *adc_x, adc_ordinary_oversample_restart_type adc_ordinary_oversample_restart)
set ordinary oversample restart mode of the specified adc peripheral. More...

Detailed Description

Function Documentation

◆ adc_base_config()

void adc_base_config | ( | adc_type * | adc_x,
 |  | adc_base_config_type * | adc_base_struct
 | ) |  |

initialize the adc peripheral according to the specified parameters.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
sequence_mode | set the state of adc sequence mode. this parameter can be:TRUE or FALSE
repeat_mode | set the state of adc repeat conversion mode. this parameter can be:TRUE or FALSE
data_align set the state of adc data alignment. this parameter can be one of the following values:
  • ADC_RIGHT_ALIGNMENT
  • ADC_LEFT_ALIGNMENT
ordinary_channel_length configure the adc ordinary channel sequence length. this parameter can be:
  • (0x1~0xf)
Return values
none

Definition at line 110 of file at32f435_437_adc.c.

Referenced by adc_config(), and adc_configuration().

◆ adc_base_default_para_init()

void adc_base_default_para_init ( adc_base_config_type * adc_base_struct )

adc base default para init.

Parameters
sequence_mode | set the state of adc sequence mode. this parameter can be:TRUE or FALSE
repeat_mode | set the state of adc repeat conversion mode. this parameter can be:TRUE or FALSE
data_align set the state of adc data alignment. this parameter can be one of the following values:
  • ADC_RIGHT_ALIGNMENT
  • ADC_LEFT_ALIGNMENT
ordinary_channel_length configure the adc ordinary channel sequence length. this parameter can be:
  • (0x1~0xf)
Return values
none

Definition at line 84 of file at32f435_437_adc.c.

Referenced by adc_config(), and adc_configuration().

◆ adc_calibration_init()

void adc_calibration_init ( adc_type * adc_x )

initialize calibration register of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
Return values
none

Definition at line 328 of file at32f435_437_adc.c.

Referenced by adc_config(), and adc_configuration().

◆ adc_calibration_init_status_get()

flag_status adc_calibration_init_status_get ( adc_type * adc_x )

get calibration register's initialize status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
Return values
the new state of reset calibration register status(SET or RESET).

Definition at line 340 of file at32f435_437_adc.c.

Referenced by adc_config(), and adc_configuration().

◆ adc_calibration_start()

void adc_calibration_start ( adc_type * adc_x )

start calibration process of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
Return values
none

Definition at line 359 of file at32f435_437_adc.c.

Referenced by adc_config(), and adc_configuration().

◆ adc_calibration_status_get()

flag_status adc_calibration_status_get ( adc_type * adc_x )

get calibration status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
Return values
the new state of calibration status(SET or RESET).

Definition at line 371 of file at32f435_437_adc.c.

Referenced by adc_config(), and adc_configuration().

◆ adc_calibration_value_set()

void adc_calibration_value_set | ( | adc_type * | adc_x,
 |  | uint8_t | adc_calibration_value
 | ) |  |

set calibration value of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_calibration_value calibration value of adc. this parameter can be:
  • (0x00~0x7F)
Return values
none

Definition at line 316 of file at32f435_437_adc.c.

◆ adc_combine_ordinary_conversion_data_get()

uint32_t adc_combine_ordinary_conversion_data_get ( void )

return the last ordinary conversion data of combine adc.

Return values
the last conversion data for ordinary channel.

Definition at line 1018 of file at32f435_437_adc.c.

◆ adc_common_config()

void adc_common_config ( adc_common_config_type * adc_common_struct )

adc common default para init.

Parameters
combine_mode configure the adc combine_mode mode. this parameter can be one of the following values:
  • ADC_INDEPENDENT_MODE - ADC_ORDINARY_SMLT_PREEMPT_SMLT_ONESLAVE_MODE - ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_ONESLAVE_MODE
  • ADC_PREEMPT_SMLT_ONLY_ONESLAVE_MODE - ADC_ORDINARY_SMLT_ONLY_ONESLAVE_MODE - ADC_ORDINARY_SHIFT_ONLY_ONESLAVE_MODE
  • ADC_PREEMPT_INTERLTRIG_ONLY_ONESLAVE_MODE - ADC_ORDINARY_SMLT_PREEMPT_SMLT_TWOSLAVE_MODE - ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_TWOSLAVE_MODE
  • ADC_PREEMPT_SMLT_ONLY_TWOSLAVE_MODE - ADC_ORDINARY_SMLT_ONLY_TWOSLAVE_MODE - ADC_ORDINARY_SHIFT_ONLY_TWOSLAVE_MODE
  • ADC_PREEMPT_INTERLTRIG_ONLY_TWOSLAVE_MODE
div configure the adc division. this parameter can be one of the following values:
  • ADC_HCLK_DIV_2 - ADC_HCLK_DIV_3 - ADC_HCLK_DIV_4 - ADC_HCLK_DIV_5
  • ADC_HCLK_DIV_6 - ADC_HCLK_DIV_7 - ADC_HCLK_DIV_8 - ADC_HCLK_DIV_9
  • ADC_HCLK_DIV_10 - ADC_HCLK_DIV_11 - ADC_HCLK_DIV_12 - ADC_HCLK_DIV_13
  • ADC_HCLK_DIV_14 - ADC_HCLK_DIV_15 - ADC_HCLK_DIV_16 - ADC_HCLK_DIV_17
common_dma_mode configure the adc common dma mode. this parameter can be one of the following values:
  • ADC_COMMON_DMAMODE_DISABLE
  • ADC_COMMON_DMAMODE_1 <mode 1 can be used: all ordinary simultaneous mode,all ordinary shifting mode>
  • ADC_COMMON_DMAMODE_2 <mode 2 can be used: one slaver ordinary simultaneous mode,all ordinary shifting mode>
  • ADC_COMMON_DMAMODE_3 <mode 3 can be used: one slaver ordinary simultaneous mode in 6/8 bit resolution,ordinary shifting mode in 6/8 bit resolution>
  • ADC_COMMON_DMAMODE_4 <mode 4 can be used: two slaver ordinary simultaneous mode in 6/8 bit resolution,two slave ordinary shifting mode in 6/8 bit resolution>
  • ADC_COMMON_DMAMODE_5 <mode 5 can be used: all two slaver ordinary simultaneous mode,all two slave ordinary shifting mode>
common_dma_request_repeat_state | set the adc common dma request repeat state. this parameter can be:TRUE or FALSE
sampling_interval configure the ordinary shifting mode adjacent adc sampling interval. this parameter can be one of the following values:
  • ADC_SAMPLING_INTERVAL_5CYCLES - ADC_SAMPLING_INTERVAL_6CYCLES - ADC_SAMPLING_INTERVAL_7CYCLES - ADC_SAMPLING_INTERVAL_8CYCLES
  • ADC_SAMPLING_INTERVAL_9CYCLES - ADC_SAMPLING_INTERVAL_10CYCLES - ADC_SAMPLING_INTERVAL_11CYCLES - ADC_SAMPLING_INTERVAL_12CYCLES
  • ADC_SAMPLING_INTERVAL_13CYCLES - ADC_SAMPLING_INTERVAL_14CYCLES - ADC_SAMPLING_INTERVAL_15CYCLES - ADC_SAMPLING_INTERVAL_16CYCLES
  • ADC_SAMPLING_INTERVAL_17CYCLES - ADC_SAMPLING_INTERVAL_18CYCLES - ADC_SAMPLING_INTERVAL_19CYCLES - ADC_SAMPLING_INTERVAL_20CYCLES
tempervintrv_state | set the adc temperature sensor and vintrv state. this parameter can be:TRUE or FALSE
vbat_state | set the adc voltage battery state. this parameter can be:TRUE or FALSE
Return values
none

Definition at line 203 of file at32f435_437_adc.c.

Referenced by adc_config(), and adc_configuration().

◆ adc_common_default_para_init()

void adc_common_default_para_init ( adc_common_config_type * adc_common_struct )

adc common default para init.

Parameters
combine_mode configure the adc combine_mode mode. this parameter can be one of the following values:
  • ADC_INDEPENDENT_MODE - ADC_ORDINARY_SMLT_PREEMPT_SMLT_ONESLAVE_MODE - ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_ONESLAVE_MODE
  • ADC_PREEMPT_SMLT_ONLY_ONESLAVE_MODE - ADC_ORDINARY_SMLT_ONLY_ONESLAVE_MODE - ADC_ORDINARY_SHIFT_ONLY_ONESLAVE_MODE
  • ADC_PREEMPT_INTERLTRIG_ONLY_ONESLAVE_MODE - ADC_ORDINARY_SMLT_PREEMPT_SMLT_TWOSLAVE_MODE - ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_TWOSLAVE_MODE
  • ADC_PREEMPT_SMLT_ONLY_TWOSLAVE_MODE - ADC_ORDINARY_SMLT_ONLY_TWOSLAVE_MODE - ADC_ORDINARY_SHIFT_ONLY_TWOSLAVE_MODE
  • ADC_PREEMPT_INTERLTRIG_ONLY_TWOSLAVE_MODE
div configure the adc division. this parameter can be one of the following values:
  • ADC_HCLK_DIV_2 - ADC_HCLK_DIV_3 - ADC_HCLK_DIV_4 - ADC_HCLK_DIV_5
  • ADC_HCLK_DIV_6 - ADC_HCLK_DIV_7 - ADC_HCLK_DIV_8 - ADC_HCLK_DIV_9
  • ADC_HCLK_DIV_10 - ADC_HCLK_DIV_11 - ADC_HCLK_DIV_12 - ADC_HCLK_DIV_13
  • ADC_HCLK_DIV_14 - ADC_HCLK_DIV_15 - ADC_HCLK_DIV_16 - ADC_HCLK_DIV_17
common_dma_mode configure the adc common dma mode. this parameter can be one of the following values:
  • ADC_COMMON_DMAMODE_DISABLE
  • ADC_COMMON_DMAMODE_1 <mode 1 can be used: all ordinary simultaneous mode,all ordinary shifting mode>
  • ADC_COMMON_DMAMODE_2 <mode 2 can be used: one slaver ordinary simultaneous mode,all ordinary shifting mode>
  • ADC_COMMON_DMAMODE_3 <mode 3 can be used: one slaver ordinary simultaneous mode in 6/8 bit resolution,ordinary shifting mode in 6/8 bit resolution>
  • ADC_COMMON_DMAMODE_4 <mode 4 can be used: two slaver ordinary simultaneous mode in 6/8 bit resolution,two slave ordinary shifting mode in 6/8 bit resolution>
  • ADC_COMMON_DMAMODE_5 <mode 5 can be used: all two slaver ordinary simultaneous mode,all two slave ordinary shifting mode>
common_dma_request_repeat_state | set the adc common dma request repeat state. this parameter can be:TRUE or FALSE
sampling_interval configure the ordinary shifting mode adjacent adc sampling interval. this parameter can be one of the following values:
  • ADC_SAMPLING_INTERVAL_5CYCLES - ADC_SAMPLING_INTERVAL_6CYCLES - ADC_SAMPLING_INTERVAL_7CYCLES - ADC_SAMPLING_INTERVAL_8CYCLES
  • ADC_SAMPLING_INTERVAL_9CYCLES - ADC_SAMPLING_INTERVAL_10CYCLES - ADC_SAMPLING_INTERVAL_11CYCLES - ADC_SAMPLING_INTERVAL_12CYCLES
  • ADC_SAMPLING_INTERVAL_13CYCLES - ADC_SAMPLING_INTERVAL_14CYCLES - ADC_SAMPLING_INTERVAL_15CYCLES - ADC_SAMPLING_INTERVAL_16CYCLES
  • ADC_SAMPLING_INTERVAL_17CYCLES - ADC_SAMPLING_INTERVAL_18CYCLES - ADC_SAMPLING_INTERVAL_19CYCLES - ADC_SAMPLING_INTERVAL_20CYCLES
tempervintrv_state | set the adc temperature sensor and vintrv state. this parameter can be:TRUE or FALSE
vbat_state | set the adc voltage battery state. this parameter can be:TRUE or FALSE
Return values
none

Definition at line 155 of file at32f435_437_adc.c.

Referenced by adc_config(), and adc_configuration().

◆ adc_conversion_stop()

void adc_conversion_stop ( adc_type * adc_x )

stop the ongoing conversion of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
Return values
none

Definition at line 898 of file at32f435_437_adc.c.

Referenced by main().

◆ adc_conversion_stop_status_get()

flag_status adc_conversion_stop_status_get ( adc_type * adc_x )

get stop conversion's status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
Return values
the new state of stop conversion's status(SET or RESET).

Definition at line 910 of file at32f435_437_adc.c.

Referenced by main().

◆ adc_dma_mode_enable()

void adc_dma_mode_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the adc dma transfer.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
new_state new state of the adc dma transfer. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 260 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_dma_request_repeat_enable()

void adc_dma_request_repeat_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the adc dma request repeat.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
new_state the adc dma request repeat state. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 274 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_enable()

void adc_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
new_state new state of a/d converter. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 64 of file at32f435_437_adc.c.

Referenced by adc_config(), and adc_configuration().

◆ adc_flag_clear()

void adc_flag_clear | ( | adc_type * | adc_x,
 |  | uint32_t | adc_flag
 | ) |  |

clear flag of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2, ADC3.
adc_flag select the adc flag. this parameter can be any combination of the following values:
  • ADC_VMOR_FLAG
  • ADC_OCCE_FLAG(also can clear by reading the adc_x->odt)
  • ADC_PCCE_FLAG
  • ADC_PCCS_FLAG
  • ADC_OCCS_FLAG
  • ADC_OCCO_FLAG
  • note:"ADC_RDY_FLAG" cannot be choose!rdy bit is readonly bit,it means the adc is ready to accept conversion request
Return values
none

Definition at line 1106 of file at32f435_437_adc.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc_flag_get()

flag_status adc_flag_get | ( | adc_type * | adc_x,
 |  | uint8_t | adc_flag
 | ) |  |

get flag of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_flag select the adc flag. this parameter can be one of the following values:
  • ADC_VMOR_FLAG
  • ADC_OCCE_FLAG
  • ADC_PCCE_FLAG
  • ADC_PCCS_FLAG(no interrupt associated)
  • ADC_OCCS_FLAG(no interrupt associated)
  • ADC_OCCO_FLAG
  • ADC_RDY_FLAG(no interrupt associated)
Return values
the new state of adc flag status(SET or RESET).

Definition at line 1075 of file at32f435_437_adc.c.

Referenced by ADC1_2_3_IRQHandler(), adc_config(), adc_configuration(), and main().

◆ adc_interrupt_enable()

void adc_interrupt_enable | ( | adc_type * | adc_x,
 |  | uint32_t | adc_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified adc interrupts.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_int specifies the adc interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • ADC_OCCE_INT
  • ADC_VMOR_INT
  • ADC_PCCE_INT
  • ADC_OCCO_INT
new_state new state of the specified adc interrupts. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 294 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_occe_each_conversion_enable()

void adc_occe_each_conversion_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable each ordinary channel conversion set occe flag of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
new_state new state of each ordinary channel conversion set occe flag. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 931 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_ordinary_channel_set()

void adc_ordinary_channel_set | ( | adc_type * | adc_x,
 |  | adc_channel_select_type | adc_channel,
 |  | uint8_t | adc_sequence,
 |  | adc_sampletime_select_type | adc_sampletime
 | ) |  |

set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_channel select the channel. this parameter can be one of the following values:
  • ADC_CHANNEL_0 - ADC_CHANNEL_1 - ADC_CHANNEL_2 - ADC_CHANNEL_3
  • ADC_CHANNEL_4 - ADC_CHANNEL_5 - ADC_CHANNEL_6 - ADC_CHANNEL_7
  • ADC_CHANNEL_8 - ADC_CHANNEL_9 - ADC_CHANNEL_10 - ADC_CHANNEL_11
  • ADC_CHANNEL_12 - ADC_CHANNEL_13 - ADC_CHANNEL_14 - ADC_CHANNEL_15
  • ADC_CHANNEL_16 - ADC_CHANNEL_17 - ADC_CHANNEL_18
adc_sequence set rank in the ordinary group sequencer. this parameter must be:
  • between 1 to 16
adc_sampletime set the sampletime of adc channel. this parameter can be one of the following values:
  • ADC_SAMPLETIME_2_5
  • ADC_SAMPLETIME_6_5
  • ADC_SAMPLETIME_12_5
  • ADC_SAMPLETIME_24_5
  • ADC_SAMPLETIME_47_5
  • ADC_SAMPLETIME_92_5
  • ADC_SAMPLETIME_247_5
  • ADC_SAMPLETIME_640_5
Return values
none

Definition at line 472 of file at32f435_437_adc.c.

Referenced by adc_config(), and adc_configuration().

◆ adc_ordinary_conversion_data_get()

uint16_t adc_ordinary_conversion_data_get ( adc_type * adc_x )

return the last conversion data for ordinary channel of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
Return values
the last conversion data for ordinary channel.

Definition at line 1009 of file at32f435_437_adc.c.

Referenced by http_recv(), and main().

◆ adc_ordinary_conversion_trigger_set()

void adc_ordinary_conversion_trigger_set | ( | adc_type * | adc_x,
 |  | adc_ordinary_trig_select_type | adc_ordinary_trig,
 |  | adc_ordinary_trig_edge_type | adc_ordinary_trig_edge
 | ) |  |

set the ordinary channel's external trigger edge and set external trigger event of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_ordinary_trig select the external trigger event. this parameter can be one of the following values:
  • ADC_ORDINARY_TRIG_TMR1CH1 - ADC_ORDINARY_TRIG_TMR1CH2 - ADC_ORDINARY_TRIG_TMR1CH3 - ADC_ORDINARY_TRIG_TMR2CH2
  • ADC_ORDINARY_TRIG_TMR2CH3 - ADC_ORDINARY_TRIG_TMR2CH4 - ADC_ORDINARY_TRIG_TMR2TRGOUT - ADC_ORDINARY_TRIG_TMR3CH1
  • ADC_ORDINARY_TRIG_TMR3TRGOUT - ADC_ORDINARY_TRIG_TMR4CH4 - ADC_ORDINARY_TRIG_TMR5CH1 - ADC_ORDINARY_TRIG_TMR5CH2
  • ADC_ORDINARY_TRIG_TMR5CH3 - ADC_ORDINARY_TRIG_TMR8CH1 - ADC_ORDINARY_TRIG_TMR8TRGOUT - ADC_ORDINARY_TRIG_EXINT11
  • ADC_ORDINARY_TRIG_TMR20TRGOUT - ADC_ORDINARY_TRIG_TMR20TRGOUT2 - ADC_ORDINARY_TRIG_TMR20CH1 - ADC_ORDINARY_TRIG_TMR20CH2
  • ADC_ORDINARY_TRIG_TMR20CH3 - ADC_ORDINARY_TRIG_TMR8TRGOUT2 - ADC_ORDINARY_TRIG_TMR1TRGOUT2 - ADC_ORDINARY_TRIG_TMR4TRGOUT
  • ADC_ORDINARY_TRIG_TMR6TRGOUT - ADC_ORDINARY_TRIG_TMR3CH4 - ADC_ORDINARY_TRIG_TMR4CH1 - ADC_ORDINARY_TRIG_TMR1TRGOUT
  • ADC_ORDINARY_TRIG_TMR2CH1 - ADC_ORDINARY_TRIG_TMR7TRGOUT
adc_ordinary_trig_edge ordinary channel conversion's external_trigger_edge. this parameter can be one of the following values:
  • ADC_ORDINARY_TRIG_EDGE_NONE
  • ADC_ORDINARY_TRIG_EDGE_RISING
  • ADC_ORDINARY_TRIG_EDGE_FALLING
  • ADC_ORDINARY_TRIG_EDGE_RISING_FALLING
Return values
none

Definition at line 742 of file at32f435_437_adc.c.

Referenced by adc_config(), and adc_configuration().

◆ adc_ordinary_oversample_enable()

void adc_ordinary_oversample_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the ordinary oversampling of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
new_state new state of ordinary oversampling. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 1120 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_ordinary_oversample_restart_set()

void adc_ordinary_oversample_restart_set | ( | adc_type * | adc_x,
 |  | adc_ordinary_oversample_restart_type | adc_ordinary_oversample_restart
 | ) |  |

set ordinary oversample restart mode of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_or_oversample_restart ordinary oversample restart mode. this parameter can be one of the following values:
  • ADC_OVERSAMPLE_CONTINUE
  • ADC_OVERSAMPLE_RESTART
Return values
none

Definition at line 1198 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_ordinary_oversample_trig_enable()

void adc_ordinary_oversample_trig_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the ordinary oversampling trigger mode of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
new_state new state of ordinary oversampling trigger mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 1182 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_ordinary_part_count_set()

void adc_ordinary_part_count_set | ( | adc_type * | adc_x,
 |  | uint8_t | adc_channel_count
 | ) |  |

set partitioned mode channel count of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_channel_count configure the adc partitioned mode channel count. this parameter can be:
  • (0x1~0x8)
Return values
none

Definition at line 843 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_ordinary_part_mode_enable()

void adc_ordinary_part_mode_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the partitioned mode on ordinary channel of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
new_state new state of ordinary channel's partitioned mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 858 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_ordinary_software_trigger_enable()

void adc_ordinary_software_trigger_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable ordinary software start conversion of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
new_state new state of ordinary software start conversion. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 945 of file at32f435_437_adc.c.

Referenced by adc_configuration(), and main().

◆ adc_ordinary_software_trigger_status_get()

flag_status adc_ordinary_software_trigger_status_get ( adc_type * adc_x )

get ordinary software start conversion status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
Return values
the new state of ordinary software start conversion status(SET or RESET).

Definition at line 957 of file at32f435_437_adc.c.

◆ adc_oversample_ratio_shift_set()

void adc_oversample_ratio_shift_set | ( | adc_type * | adc_x,
 |  | adc_oversample_ratio_type | adc_oversample_ratio,
 |  | adc_oversample_shift_type | adc_oversample_shift
 | ) |  |

config the oversampling ratio and shift of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_oversample_ratio set the oversample ratio. this parameter can be one of the following values:
  • ADC_OVERSAMPLE_RATIO_2
  • ADC_OVERSAMPLE_RATIO_4
  • ADC_OVERSAMPLE_RATIO_8
  • ADC_OVERSAMPLE_RATIO_16
  • ADC_OVERSAMPLE_RATIO_32
  • ADC_OVERSAMPLE_RATIO_64
  • ADC_OVERSAMPLE_RATIO_128
  • ADC_OVERSAMPLE_RATIO_256
adc_oversample_shift set the oversample shift. this parameter can be one of the following values:
  • ADC_OVERSAMPLE_SHIFT_0
  • ADC_OVERSAMPLE_SHIFT_1
  • ADC_OVERSAMPLE_SHIFT_2
  • ADC_OVERSAMPLE_SHIFT_3
  • ADC_OVERSAMPLE_SHIFT_4
  • ADC_OVERSAMPLE_SHIFT_5
  • ADC_OVERSAMPLE_SHIFT_6
  • ADC_OVERSAMPLE_SHIFT_7
  • ADC_OVERSAMPLE_SHIFT_8
Return values
none

Definition at line 1167 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_preempt_auto_mode_enable()

void adc_preempt_auto_mode_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable automatic preempt group conversion of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
new_state new state of automatic preempt group conversion. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 886 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_preempt_channel_length_set()

void adc_preempt_channel_length_set | ( | adc_type * | adc_x,
 |  | uint8_t | adc_channel_lenght
 | ) |  |

set preempt channel lenghth of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_channel_lenght set the adc preempt channel lenghth. this parameter can be:
  • (0x1~0x4)
Return values
none

Definition at line 601 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_preempt_channel_set()

void adc_preempt_channel_set | ( | adc_type * | adc_x,
 |  | adc_channel_select_type | adc_channel,
 |  | uint8_t | adc_sequence,
 |  | adc_sampletime_select_type | adc_sampletime
 | ) |  |

configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_channel select the channel. this parameter can be one of the following values:
  • ADC_CHANNEL_0 - ADC_CHANNEL_1 - ADC_CHANNEL_2 - ADC_CHANNEL_3
  • ADC_CHANNEL_4 - ADC_CHANNEL_5 - ADC_CHANNEL_6 - ADC_CHANNEL_7
  • ADC_CHANNEL_8 - ADC_CHANNEL_9 - ADC_CHANNEL_10 - ADC_CHANNEL_11
  • ADC_CHANNEL_12 - ADC_CHANNEL_13 - ADC_CHANNEL_14 - ADC_CHANNEL_15
  • ADC_CHANNEL_16 - ADC_CHANNEL_17 - ADC_CHANNEL_18
adc_sequence set rank in the preempt group sequencer. this parameter must be:
  • between 1 to 4
adc_sampletime config the sampletime of adc channel. this parameter can be one of the following values:
  • ADC_SAMPLETIME_2_5
  • ADC_SAMPLETIME_6_5
  • ADC_SAMPLETIME_12_5
  • ADC_SAMPLETIME_24_5
  • ADC_SAMPLETIME_47_5
  • ADC_SAMPLETIME_92_5
  • ADC_SAMPLETIME_247_5
  • ADC_SAMPLETIME_640_5
Return values
none

Definition at line 633 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_preempt_conversion_data_get()

uint16_t adc_preempt_conversion_data_get | ( | adc_type * | adc_x,
 |  | adc_preempt_channel_type | adc_preempt_channel
 | ) |  |

return the conversion data for selection preempt channel of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_preempt_channel select the preempt channel. this parameter can be one of the following values:
  • ADC_PREEMPT_CHANNEL_1
  • ADC_PREEMPT_CHANNEL_2
  • ADC_PREEMPT_CHANNEL_3
  • ADC_PREEMPT_CHANNEL_4
Return values
the conversion data for selection preempt channel.

Definition at line 1036 of file at32f435_437_adc.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc_preempt_conversion_trigger_set()

void adc_preempt_conversion_trigger_set | ( | adc_type * | adc_x,
 |  | adc_preempt_trig_select_type | adc_preempt_trig,
 |  | adc_preempt_trig_edge_type | adc_preempt_trig_edge
 | ) |  |

enable or disable the preempt channel's external trigger and set external trigger event of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_preempt_trig select the external trigger event. this parameter can be one of the following values:
  • ADC_PREEMPT_TRIG_TMR1CH4 - ADC_PREEMPT_TRIG_TMR1TRGOUT - ADC_PREEMPT_TRIG_TMR2CH1 - ADC_PREEMPT_TRIG_TMR2TRGOUT
  • ADC_PREEMPT_TRIG_TMR3CH2 - ADC_PREEMPT_TRIG_TMR3CH4 - ADC_PREEMPT_TRIG_TMR4CH1 - ADC_PREEMPT_TRIG_TMR4CH2
  • ADC_PREEMPT_TRIG_TMR4CH3 - ADC_PREEMPT_TRIG_TMR4TRGOUT - ADC_PREEMPT_TRIG_TMR5CH4 - ADC_PREEMPT_TRIG_TMR5TRGOUT
  • ADC_PREEMPT_TRIG_TMR8CH2 - ADC_PREEMPT_TRIG_TMR8CH3 - ADC_PREEMPT_TRIG_TMR8CH4 - ADC_PREEMPT_TRIG_EXINT15
  • ADC_PREEMPT_TRIG_TMR20TRGOUT - ADC_PREEMPT_TRIG_TMR20TRGOUT2 - ADC_PREEMPT_TRIG_TMR20CH4 - ADC_PREEMPT_TRIG_TMR1TRGOUT2
  • ADC_PREEMPT_TRIG_TMR8TRGOUT - ADC_PREEMPT_TRIG_TMR8TRGOUT2 - ADC_PREEMPT_TRIG_TMR3CH3 - ADC_PREEMPT_TRIG_TMR3TRGOUT
  • ADC_PREEMPT_TRIG_TMR3CH1 - ADC_PREEMPT_TRIG_TMR6TRGOUT - ADC_PREEMPT_TRIG_TMR4CH4 - ADC_PREEMPT_TRIG_TMR1CH3
  • ADC_PREEMPT_TRIG_TMR20CH2 - ADC_PREEMPT_TRIG_TMR7TRGOUT
adc_preempt_trig_edge preempt channel conversion's external_trigger_edge. this parameter can be one of the following values:
  • ADC_PREEMPT_TRIG_EDGE_NONE
  • ADC_PREEMPT_TRIG_EDGE_RISING
  • ADC_PREEMPT_TRIG_EDGE_FALLING
  • ADC_PREEMPT_TRIG_EDGE_RISING_FALLING
Return values
none

Definition at line 781 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_preempt_offset_value_set()

void adc_preempt_offset_value_set | ( | adc_type * | adc_x,
 |  | adc_preempt_channel_type | adc_preempt_channel,
 |  | uint16_t | adc_offset_value
 | ) |  |

set preempt channel's conversion value offset of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_preempt_channel select the preempt channel. this parameter can be one of the following values:
  • ADC_PREEMPT_CHANNEL_1
  • ADC_PREEMPT_CHANNEL_2
  • ADC_PREEMPT_CHANNEL_3
  • ADC_PREEMPT_CHANNEL_4
adc_offset_value set the adc preempt channel's conversion value offset. this parameter can be:
  • (0x000~0xFFF)
Return values
none

Definition at line 812 of file at32f435_437_adc.c.

◆ adc_preempt_oversample_enable()

void adc_preempt_oversample_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the preempt oversampling of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
new_state new state of preempt oversampling. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 1134 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_preempt_part_mode_enable()

void adc_preempt_part_mode_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the partitioned mode on preempt channel of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
new_state new state of preempt channel's partitioned mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 872 of file at32f435_437_adc.c.

◆ adc_preempt_software_trigger_enable()

void adc_preempt_software_trigger_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable preempt software start conversion of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
new_state new state of preempt software start conversion. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 978 of file at32f435_437_adc.c.

Referenced by main().

◆ adc_preempt_software_trigger_status_get()

flag_status adc_preempt_software_trigger_status_get ( adc_type * adc_x )

get preempt software start conversion status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
Return values
the new state of preempt software start conversion status(SET or RESET).

Definition at line 990 of file at32f435_437_adc.c.

◆ adc_reset()

void adc_reset ( void )

deinitialize the adc peripheral registers to their default reset values.

Parameters
none
Return values
none

Definition at line 49 of file at32f435_437_adc.c.

◆ adc_resolution_set()

void adc_resolution_set | ( | adc_type * | adc_x,
 |  | adc_resolution_type | resolution
 | ) |  |

set resolution of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
resolution set the conversion resolution. this parameter can be one of the following values:
  • ADC_RESOLUTION_12B
  • ADC_RESOLUTION_10B
  • ADC_RESOLUTION_8B
  • ADC_RESOLUTION_6B
Return values
none

Definition at line 235 of file at32f435_437_adc.c.

Referenced by adc_config(), and adc_configuration().

◆ adc_voltage_battery_enable()

void adc_voltage_battery_enable ( confirm_state new_state )

enable or disable the adc voltage battery.

Parameters
new_state new state of the adc voltage battery. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 246 of file at32f435_437_adc.c.

Referenced by main().

◆ adc_voltage_monitor_enable()

void adc_voltage_monitor_enable | ( | adc_type * | adc_x,
 |  | adc_voltage_monitoring_type | adc_voltage_monitoring
 | ) |  |

enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_voltage_monitoring choose the adc_voltage_monitoring config. this parameter can be one of the following values:
  • ADC_VMONITOR_SINGLE_ORDINARY
  • ADC_VMONITOR_SINGLE_PREEMPT
  • ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT
  • ADC_VMONITOR_ALL_ORDINARY
  • ADC_VMONITOR_ALL_PREEMPT
  • ADC_VMONITOR_ALL_ORDINARY_PREEMPT
  • ADC_VMONITOR_NONE
Return values
none

Definition at line 399 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_voltage_monitor_single_channel_select()

void adc_voltage_monitor_single_channel_select | ( | adc_type * | adc_x,
 |  | adc_channel_select_type | adc_channel
 | ) |  |

select the voltage monitoring's channel of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_channel select the channel. this parameter can be one of the following values:
  • ADC_CHANNEL_0 - ADC_CHANNEL_1 - ADC_CHANNEL_2 - ADC_CHANNEL_3
  • ADC_CHANNEL_4 - ADC_CHANNEL_5 - ADC_CHANNEL_6 - ADC_CHANNEL_7
  • ADC_CHANNEL_8 - ADC_CHANNEL_9 - ADC_CHANNEL_10 - ADC_CHANNEL_11
  • ADC_CHANNEL_12 - ADC_CHANNEL_13 - ADC_CHANNEL_14 - ADC_CHANNEL_15
  • ADC_CHANNEL_16 - ADC_CHANNEL_17 - ADC_CHANNEL_18
Return values
none

Definition at line 440 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_voltage_monitor_threshold_value_set()

void adc_voltage_monitor_threshold_value_set | ( | adc_type * | adc_x,
 |  | uint16_t | adc_high_threshold,
 |  | uint16_t | adc_low_threshold
 | ) |  |

set voltage monitoring's high and low thresholds value of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_high_threshold voltage monitoring's high thresholds value. this parameter can be:
  • (0x000~0xFFF)
adc_low_threshold voltage monitoring's low thresholds value. this parameter can be:
  • (0x000~0xFFF)
Return values
none

Definition at line 420 of file at32f435_437_adc.c.

Referenced by adc_config().


AT32F435/437 Firmwary Library: ADC_private_functions

Functions
ADC_private_functions
AT32F435_437_periph_driver » ADC

Functions

void | adc_reset (void)
deinitialize the adc peripheral registers to their default reset values. More...
void | adc_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral. More...
void | adc_base_default_para_init (adc_base_config_type *adc_base_struct)
adc base default para init. More...
void | adc_base_config (adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters. More...
void | adc_common_default_para_init (adc_common_config_type *adc_common_struct)
adc common default para init. More...
void | adc_common_config (adc_common_config_type *adc_common_struct)
adc common default para init. More...
void | adc_resolution_set (adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral. More...
void | adc_voltage_battery_enable (confirm_state new_state)
enable or disable the adc voltage battery. More...
void | adc_dma_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer. More...
void | adc_dma_request_repeat_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat. More...
void | adc_interrupt_enable (adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts. More...
void | adc_calibration_value_set (adc_type *adc_x, uint8_t adc_calibration_value)
set calibration value of the specified adc peripheral. More...
void | adc_calibration_init (adc_type *adc_x)
initialize calibration register of the specified adc peripheral. More...
flag_status | adc_calibration_init_status_get (adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral. More...
void | adc_calibration_start (adc_type *adc_x)
start calibration process of the specified adc peripheral. More...
flag_status | adc_calibration_status_get (adc_type *adc_x)
get calibration status of the specified adc peripheral. More...
void | adc_voltage_monitor_enable (adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring)
enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified adc peripheral. More...
void | adc_voltage_monitor_threshold_value_set (adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold)
set voltage monitoring's high and low thresholds value of the specified adc peripheral. More...
void | adc_voltage_monitor_single_channel_select (adc_type *adc_x, adc_channel_select_type adc_channel)
select the voltage monitoring's channel of the specified adc peripheral. More...
void | adc_ordinary_channel_set (adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc peripheral. More...
void | adc_preempt_channel_length_set (adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral. More...
void | adc_preempt_channel_set (adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc peripheral. More...
void | adc_ordinary_conversion_trigger_set (adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc peripheral. More...
void | adc_preempt_conversion_trigger_set (adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, adc_preempt_trig_edge_type adc_preempt_trig_edge)
enable or disable the preempt channel's external trigger and set external trigger event of the specified adc peripheral. More...
void | adc_preempt_offset_value_set (adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel, uint16_t adc_offset_value)
set preempt channel's conversion value offset of the specified adc peripheral. More...
void | adc_ordinary_part_count_set (adc_type *adc_x, uint8_t adc_channel_count)
set partitioned mode channel count of the specified adc peripheral. More...
void | adc_ordinary_part_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on ordinary channel of the specified adc peripheral. More...
void | adc_preempt_part_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on preempt channel of the specified adc peripheral. More...
void | adc_preempt_auto_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable automatic preempt group conversion of the specified adc peripheral. More...
void | adc_conversion_stop (adc_type *adc_x)
stop the ongoing conversion of the specified adc peripheral. More...
flag_status | adc_conversion_stop_status_get (adc_type *adc_x)
get stop conversion's status of the specified adc peripheral. More...
void | adc_occe_each_conversion_enable (adc_type *adc_x, confirm_state new_state)
enable or disable each ordinary channel conversion set occe flag of the specified adc peripheral. More...
void | adc_ordinary_software_trigger_enable (adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral. More...
flag_status | adc_ordinary_software_trigger_status_get (adc_type *adc_x)
get ordinary software start conversion status of the specified adc peripheral. More...
void | adc_preempt_software_trigger_enable (adc_type *adc_x, confirm_state new_state)
enable or disable preempt software start conversion of the specified adc peripheral. More...
flag_status | adc_preempt_software_trigger_status_get (adc_type *adc_x)
get preempt software start conversion status of the specified adc peripheral. More...
uint16_t | adc_ordinary_conversion_data_get (adc_type *adc_x)
return the last conversion data for ordinary channel of the specified adc peripheral. More...
uint32_t | adc_combine_ordinary_conversion_data_get (void)
return the last ordinary conversion data of combine adc. More...
uint16_t | adc_preempt_conversion_data_get (adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral. More...
flag_status | adc_flag_get (adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral. More...
void | adc_flag_clear (adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral. More...
void | adc_ordinary_oversample_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the ordinary oversampling of the specified adc peripheral. More...
void | adc_preempt_oversample_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the preempt oversampling of the specified adc peripheral. More...
void | adc_oversample_ratio_shift_set (adc_type *adc_x, adc_oversample_ratio_type adc_oversample_ratio, adc_oversample_shift_type adc_oversample_shift)
config the oversampling ratio and shift of the specified adc peripheral. More...
void | adc_ordinary_oversample_trig_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the ordinary oversampling trigger mode of the specified adc peripheral. More...
void | adc_ordinary_oversample_restart_set (adc_type *adc_x, adc_ordinary_oversample_restart_type adc_ordinary_oversample_restart)
set ordinary oversample restart mode of the specified adc peripheral. More...

Detailed Description

Function Documentation

◆ adc_base_config()

void adc_base_config | ( | adc_type * | adc_x,
 |  | adc_base_config_type * | adc_base_struct
 | ) |  |

initialize the adc peripheral according to the specified parameters.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
sequence_mode | set the state of adc sequence mode. this parameter can be:TRUE or FALSE
repeat_mode | set the state of adc repeat conversion mode. this parameter can be:TRUE or FALSE
data_align set the state of adc data alignment. this parameter can be one of the following values:
  • ADC_RIGHT_ALIGNMENT
  • ADC_LEFT_ALIGNMENT
ordinary_channel_length configure the adc ordinary channel sequence length. this parameter can be:
  • (0x1~0xf)
Return values
none

Definition at line 110 of file at32f435_437_adc.c.

Referenced by adc_config(), and adc_configuration().

◆ adc_base_default_para_init()

void adc_base_default_para_init ( adc_base_config_type * adc_base_struct )

adc base default para init.

Parameters
sequence_mode | set the state of adc sequence mode. this parameter can be:TRUE or FALSE
repeat_mode | set the state of adc repeat conversion mode. this parameter can be:TRUE or FALSE
data_align set the state of adc data alignment. this parameter can be one of the following values:
  • ADC_RIGHT_ALIGNMENT
  • ADC_LEFT_ALIGNMENT
ordinary_channel_length configure the adc ordinary channel sequence length. this parameter can be:
  • (0x1~0xf)
Return values
none

Definition at line 84 of file at32f435_437_adc.c.

Referenced by adc_config(), and adc_configuration().

◆ adc_calibration_init()

void adc_calibration_init ( adc_type * adc_x )

initialize calibration register of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
Return values
none

Definition at line 328 of file at32f435_437_adc.c.

Referenced by adc_config(), and adc_configuration().

◆ adc_calibration_init_status_get()

flag_status adc_calibration_init_status_get ( adc_type * adc_x )

get calibration register's initialize status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
Return values
the new state of reset calibration register status(SET or RESET).

Definition at line 340 of file at32f435_437_adc.c.

Referenced by adc_config(), and adc_configuration().

◆ adc_calibration_start()

void adc_calibration_start ( adc_type * adc_x )

start calibration process of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
Return values
none

Definition at line 359 of file at32f435_437_adc.c.

Referenced by adc_config(), and adc_configuration().

◆ adc_calibration_status_get()

flag_status adc_calibration_status_get ( adc_type * adc_x )

get calibration status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
Return values
the new state of calibration status(SET or RESET).

Definition at line 371 of file at32f435_437_adc.c.

Referenced by adc_config(), and adc_configuration().

◆ adc_calibration_value_set()

void adc_calibration_value_set | ( | adc_type * | adc_x,
 |  | uint8_t | adc_calibration_value
 | ) |  |

set calibration value of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_calibration_value calibration value of adc. this parameter can be:
  • (0x00~0x7F)
Return values
none

Definition at line 316 of file at32f435_437_adc.c.

◆ adc_combine_ordinary_conversion_data_get()

uint32_t adc_combine_ordinary_conversion_data_get ( void )

return the last ordinary conversion data of combine adc.

Return values
the last conversion data for ordinary channel.

Definition at line 1018 of file at32f435_437_adc.c.

◆ adc_common_config()

void adc_common_config ( adc_common_config_type * adc_common_struct )

adc common default para init.

Parameters
combine_mode configure the adc combine_mode mode. this parameter can be one of the following values:
  • ADC_INDEPENDENT_MODE - ADC_ORDINARY_SMLT_PREEMPT_SMLT_ONESLAVE_MODE - ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_ONESLAVE_MODE
  • ADC_PREEMPT_SMLT_ONLY_ONESLAVE_MODE - ADC_ORDINARY_SMLT_ONLY_ONESLAVE_MODE - ADC_ORDINARY_SHIFT_ONLY_ONESLAVE_MODE
  • ADC_PREEMPT_INTERLTRIG_ONLY_ONESLAVE_MODE - ADC_ORDINARY_SMLT_PREEMPT_SMLT_TWOSLAVE_MODE - ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_TWOSLAVE_MODE
  • ADC_PREEMPT_SMLT_ONLY_TWOSLAVE_MODE - ADC_ORDINARY_SMLT_ONLY_TWOSLAVE_MODE - ADC_ORDINARY_SHIFT_ONLY_TWOSLAVE_MODE
  • ADC_PREEMPT_INTERLTRIG_ONLY_TWOSLAVE_MODE
div configure the adc division. this parameter can be one of the following values:
  • ADC_HCLK_DIV_2 - ADC_HCLK_DIV_3 - ADC_HCLK_DIV_4 - ADC_HCLK_DIV_5
  • ADC_HCLK_DIV_6 - ADC_HCLK_DIV_7 - ADC_HCLK_DIV_8 - ADC_HCLK_DIV_9
  • ADC_HCLK_DIV_10 - ADC_HCLK_DIV_11 - ADC_HCLK_DIV_12 - ADC_HCLK_DIV_13
  • ADC_HCLK_DIV_14 - ADC_HCLK_DIV_15 - ADC_HCLK_DIV_16 - ADC_HCLK_DIV_17
common_dma_mode configure the adc common dma mode. this parameter can be one of the following values:
  • ADC_COMMON_DMAMODE_DISABLE
  • ADC_COMMON_DMAMODE_1 <mode 1 can be used: all ordinary simultaneous mode,all ordinary shifting mode>
  • ADC_COMMON_DMAMODE_2 <mode 2 can be used: one slaver ordinary simultaneous mode,all ordinary shifting mode>
  • ADC_COMMON_DMAMODE_3 <mode 3 can be used: one slaver ordinary simultaneous mode in 6/8 bit resolution,ordinary shifting mode in 6/8 bit resolution>
  • ADC_COMMON_DMAMODE_4 <mode 4 can be used: two slaver ordinary simultaneous mode in 6/8 bit resolution,two slave ordinary shifting mode in 6/8 bit resolution>
  • ADC_COMMON_DMAMODE_5 <mode 5 can be used: all two slaver ordinary simultaneous mode,all two slave ordinary shifting mode>
common_dma_request_repeat_state | set the adc common dma request repeat state. this parameter can be:TRUE or FALSE
sampling_interval configure the ordinary shifting mode adjacent adc sampling interval. this parameter can be one of the following values:
  • ADC_SAMPLING_INTERVAL_5CYCLES - ADC_SAMPLING_INTERVAL_6CYCLES - ADC_SAMPLING_INTERVAL_7CYCLES - ADC_SAMPLING_INTERVAL_8CYCLES
  • ADC_SAMPLING_INTERVAL_9CYCLES - ADC_SAMPLING_INTERVAL_10CYCLES - ADC_SAMPLING_INTERVAL_11CYCLES - ADC_SAMPLING_INTERVAL_12CYCLES
  • ADC_SAMPLING_INTERVAL_13CYCLES - ADC_SAMPLING_INTERVAL_14CYCLES - ADC_SAMPLING_INTERVAL_15CYCLES - ADC_SAMPLING_INTERVAL_16CYCLES
  • ADC_SAMPLING_INTERVAL_17CYCLES - ADC_SAMPLING_INTERVAL_18CYCLES - ADC_SAMPLING_INTERVAL_19CYCLES - ADC_SAMPLING_INTERVAL_20CYCLES
tempervintrv_state | set the adc temperature sensor and vintrv state. this parameter can be:TRUE or FALSE
vbat_state | set the adc voltage battery state. this parameter can be:TRUE or FALSE
Return values
none

Definition at line 203 of file at32f435_437_adc.c.

Referenced by adc_config(), and adc_configuration().

◆ adc_common_default_para_init()

void adc_common_default_para_init ( adc_common_config_type * adc_common_struct )

adc common default para init.

Parameters
combine_mode configure the adc combine_mode mode. this parameter can be one of the following values:
  • ADC_INDEPENDENT_MODE - ADC_ORDINARY_SMLT_PREEMPT_SMLT_ONESLAVE_MODE - ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_ONESLAVE_MODE
  • ADC_PREEMPT_SMLT_ONLY_ONESLAVE_MODE - ADC_ORDINARY_SMLT_ONLY_ONESLAVE_MODE - ADC_ORDINARY_SHIFT_ONLY_ONESLAVE_MODE
  • ADC_PREEMPT_INTERLTRIG_ONLY_ONESLAVE_MODE - ADC_ORDINARY_SMLT_PREEMPT_SMLT_TWOSLAVE_MODE - ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_TWOSLAVE_MODE
  • ADC_PREEMPT_SMLT_ONLY_TWOSLAVE_MODE - ADC_ORDINARY_SMLT_ONLY_TWOSLAVE_MODE - ADC_ORDINARY_SHIFT_ONLY_TWOSLAVE_MODE
  • ADC_PREEMPT_INTERLTRIG_ONLY_TWOSLAVE_MODE
div configure the adc division. this parameter can be one of the following values:
  • ADC_HCLK_DIV_2 - ADC_HCLK_DIV_3 - ADC_HCLK_DIV_4 - ADC_HCLK_DIV_5
  • ADC_HCLK_DIV_6 - ADC_HCLK_DIV_7 - ADC_HCLK_DIV_8 - ADC_HCLK_DIV_9
  • ADC_HCLK_DIV_10 - ADC_HCLK_DIV_11 - ADC_HCLK_DIV_12 - ADC_HCLK_DIV_13
  • ADC_HCLK_DIV_14 - ADC_HCLK_DIV_15 - ADC_HCLK_DIV_16 - ADC_HCLK_DIV_17
common_dma_mode configure the adc common dma mode. this parameter can be one of the following values:
  • ADC_COMMON_DMAMODE_DISABLE
  • ADC_COMMON_DMAMODE_1 <mode 1 can be used: all ordinary simultaneous mode,all ordinary shifting mode>
  • ADC_COMMON_DMAMODE_2 <mode 2 can be used: one slaver ordinary simultaneous mode,all ordinary shifting mode>
  • ADC_COMMON_DMAMODE_3 <mode 3 can be used: one slaver ordinary simultaneous mode in 6/8 bit resolution,ordinary shifting mode in 6/8 bit resolution>
  • ADC_COMMON_DMAMODE_4 <mode 4 can be used: two slaver ordinary simultaneous mode in 6/8 bit resolution,two slave ordinary shifting mode in 6/8 bit resolution>
  • ADC_COMMON_DMAMODE_5 <mode 5 can be used: all two slaver ordinary simultaneous mode,all two slave ordinary shifting mode>
common_dma_request_repeat_state | set the adc common dma request repeat state. this parameter can be:TRUE or FALSE
sampling_interval configure the ordinary shifting mode adjacent adc sampling interval. this parameter can be one of the following values:
  • ADC_SAMPLING_INTERVAL_5CYCLES - ADC_SAMPLING_INTERVAL_6CYCLES - ADC_SAMPLING_INTERVAL_7CYCLES - ADC_SAMPLING_INTERVAL_8CYCLES
  • ADC_SAMPLING_INTERVAL_9CYCLES - ADC_SAMPLING_INTERVAL_10CYCLES - ADC_SAMPLING_INTERVAL_11CYCLES - ADC_SAMPLING_INTERVAL_12CYCLES
  • ADC_SAMPLING_INTERVAL_13CYCLES - ADC_SAMPLING_INTERVAL_14CYCLES - ADC_SAMPLING_INTERVAL_15CYCLES - ADC_SAMPLING_INTERVAL_16CYCLES
  • ADC_SAMPLING_INTERVAL_17CYCLES - ADC_SAMPLING_INTERVAL_18CYCLES - ADC_SAMPLING_INTERVAL_19CYCLES - ADC_SAMPLING_INTERVAL_20CYCLES
tempervintrv_state | set the adc temperature sensor and vintrv state. this parameter can be:TRUE or FALSE
vbat_state | set the adc voltage battery state. this parameter can be:TRUE or FALSE
Return values
none

Definition at line 155 of file at32f435_437_adc.c.

Referenced by adc_config(), and adc_configuration().

◆ adc_conversion_stop()

void adc_conversion_stop ( adc_type * adc_x )

stop the ongoing conversion of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
Return values
none

Definition at line 898 of file at32f435_437_adc.c.

Referenced by main().

◆ adc_conversion_stop_status_get()

flag_status adc_conversion_stop_status_get ( adc_type * adc_x )

get stop conversion's status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
Return values
the new state of stop conversion's status(SET or RESET).

Definition at line 910 of file at32f435_437_adc.c.

Referenced by main().

◆ adc_dma_mode_enable()

void adc_dma_mode_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the adc dma transfer.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
new_state new state of the adc dma transfer. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 260 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_dma_request_repeat_enable()

void adc_dma_request_repeat_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the adc dma request repeat.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
new_state the adc dma request repeat state. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 274 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_enable()

void adc_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
new_state new state of a/d converter. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 64 of file at32f435_437_adc.c.

Referenced by adc_config(), and adc_configuration().

◆ adc_flag_clear()

void adc_flag_clear | ( | adc_type * | adc_x,
 |  | uint32_t | adc_flag
 | ) |  |

clear flag of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2, ADC3.
adc_flag select the adc flag. this parameter can be any combination of the following values:
  • ADC_VMOR_FLAG
  • ADC_OCCE_FLAG(also can clear by reading the adc_x->odt)
  • ADC_PCCE_FLAG
  • ADC_PCCS_FLAG
  • ADC_OCCS_FLAG
  • ADC_OCCO_FLAG
  • note:"ADC_RDY_FLAG" cannot be choose!rdy bit is readonly bit,it means the adc is ready to accept conversion request
Return values
none

Definition at line 1106 of file at32f435_437_adc.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc_flag_get()

flag_status adc_flag_get | ( | adc_type * | adc_x,
 |  | uint8_t | adc_flag
 | ) |  |

get flag of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_flag select the adc flag. this parameter can be one of the following values:
  • ADC_VMOR_FLAG
  • ADC_OCCE_FLAG
  • ADC_PCCE_FLAG
  • ADC_PCCS_FLAG(no interrupt associated)
  • ADC_OCCS_FLAG(no interrupt associated)
  • ADC_OCCO_FLAG
  • ADC_RDY_FLAG(no interrupt associated)
Return values
the new state of adc flag status(SET or RESET).

Definition at line 1075 of file at32f435_437_adc.c.

Referenced by ADC1_2_3_IRQHandler(), adc_config(), adc_configuration(), and main().

◆ adc_interrupt_enable()

void adc_interrupt_enable | ( | adc_type * | adc_x,
 |  | uint32_t | adc_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified adc interrupts.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_int specifies the adc interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • ADC_OCCE_INT
  • ADC_VMOR_INT
  • ADC_PCCE_INT
  • ADC_OCCO_INT
new_state new state of the specified adc interrupts. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 294 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_occe_each_conversion_enable()

void adc_occe_each_conversion_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable each ordinary channel conversion set occe flag of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
new_state new state of each ordinary channel conversion set occe flag. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 931 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_ordinary_channel_set()

void adc_ordinary_channel_set | ( | adc_type * | adc_x,
 |  | adc_channel_select_type | adc_channel,
 |  | uint8_t | adc_sequence,
 |  | adc_sampletime_select_type | adc_sampletime
 | ) |  |

set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_channel select the channel. this parameter can be one of the following values:
  • ADC_CHANNEL_0 - ADC_CHANNEL_1 - ADC_CHANNEL_2 - ADC_CHANNEL_3
  • ADC_CHANNEL_4 - ADC_CHANNEL_5 - ADC_CHANNEL_6 - ADC_CHANNEL_7
  • ADC_CHANNEL_8 - ADC_CHANNEL_9 - ADC_CHANNEL_10 - ADC_CHANNEL_11
  • ADC_CHANNEL_12 - ADC_CHANNEL_13 - ADC_CHANNEL_14 - ADC_CHANNEL_15
  • ADC_CHANNEL_16 - ADC_CHANNEL_17 - ADC_CHANNEL_18
adc_sequence set rank in the ordinary group sequencer. this parameter must be:
  • between 1 to 16
adc_sampletime set the sampletime of adc channel. this parameter can be one of the following values:
  • ADC_SAMPLETIME_2_5
  • ADC_SAMPLETIME_6_5
  • ADC_SAMPLETIME_12_5
  • ADC_SAMPLETIME_24_5
  • ADC_SAMPLETIME_47_5
  • ADC_SAMPLETIME_92_5
  • ADC_SAMPLETIME_247_5
  • ADC_SAMPLETIME_640_5
Return values
none

Definition at line 472 of file at32f435_437_adc.c.

Referenced by adc_config(), and adc_configuration().

◆ adc_ordinary_conversion_data_get()

uint16_t adc_ordinary_conversion_data_get ( adc_type * adc_x )

return the last conversion data for ordinary channel of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
Return values
the last conversion data for ordinary channel.

Definition at line 1009 of file at32f435_437_adc.c.

Referenced by http_recv(), and main().

◆ adc_ordinary_conversion_trigger_set()

void adc_ordinary_conversion_trigger_set | ( | adc_type * | adc_x,
 |  | adc_ordinary_trig_select_type | adc_ordinary_trig,
 |  | adc_ordinary_trig_edge_type | adc_ordinary_trig_edge
 | ) |  |

set the ordinary channel's external trigger edge and set external trigger event of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_ordinary_trig select the external trigger event. this parameter can be one of the following values:
  • ADC_ORDINARY_TRIG_TMR1CH1 - ADC_ORDINARY_TRIG_TMR1CH2 - ADC_ORDINARY_TRIG_TMR1CH3 - ADC_ORDINARY_TRIG_TMR2CH2
  • ADC_ORDINARY_TRIG_TMR2CH3 - ADC_ORDINARY_TRIG_TMR2CH4 - ADC_ORDINARY_TRIG_TMR2TRGOUT - ADC_ORDINARY_TRIG_TMR3CH1
  • ADC_ORDINARY_TRIG_TMR3TRGOUT - ADC_ORDINARY_TRIG_TMR4CH4 - ADC_ORDINARY_TRIG_TMR5CH1 - ADC_ORDINARY_TRIG_TMR5CH2
  • ADC_ORDINARY_TRIG_TMR5CH3 - ADC_ORDINARY_TRIG_TMR8CH1 - ADC_ORDINARY_TRIG_TMR8TRGOUT - ADC_ORDINARY_TRIG_EXINT11
  • ADC_ORDINARY_TRIG_TMR20TRGOUT - ADC_ORDINARY_TRIG_TMR20TRGOUT2 - ADC_ORDINARY_TRIG_TMR20CH1 - ADC_ORDINARY_TRIG_TMR20CH2
  • ADC_ORDINARY_TRIG_TMR20CH3 - ADC_ORDINARY_TRIG_TMR8TRGOUT2 - ADC_ORDINARY_TRIG_TMR1TRGOUT2 - ADC_ORDINARY_TRIG_TMR4TRGOUT
  • ADC_ORDINARY_TRIG_TMR6TRGOUT - ADC_ORDINARY_TRIG_TMR3CH4 - ADC_ORDINARY_TRIG_TMR4CH1 - ADC_ORDINARY_TRIG_TMR1TRGOUT
  • ADC_ORDINARY_TRIG_TMR2CH1 - ADC_ORDINARY_TRIG_TMR7TRGOUT
adc_ordinary_trig_edge ordinary channel conversion's external_trigger_edge. this parameter can be one of the following values:
  • ADC_ORDINARY_TRIG_EDGE_NONE
  • ADC_ORDINARY_TRIG_EDGE_RISING
  • ADC_ORDINARY_TRIG_EDGE_FALLING
  • ADC_ORDINARY_TRIG_EDGE_RISING_FALLING
Return values
none

Definition at line 742 of file at32f435_437_adc.c.

Referenced by adc_config(), and adc_configuration().

◆ adc_ordinary_oversample_enable()

void adc_ordinary_oversample_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the ordinary oversampling of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
new_state new state of ordinary oversampling. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 1120 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_ordinary_oversample_restart_set()

void adc_ordinary_oversample_restart_set | ( | adc_type * | adc_x,
 |  | adc_ordinary_oversample_restart_type | adc_ordinary_oversample_restart
 | ) |  |

set ordinary oversample restart mode of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_or_oversample_restart ordinary oversample restart mode. this parameter can be one of the following values:
  • ADC_OVERSAMPLE_CONTINUE
  • ADC_OVERSAMPLE_RESTART
Return values
none

Definition at line 1198 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_ordinary_oversample_trig_enable()

void adc_ordinary_oversample_trig_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the ordinary oversampling trigger mode of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
new_state new state of ordinary oversampling trigger mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 1182 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_ordinary_part_count_set()

void adc_ordinary_part_count_set | ( | adc_type * | adc_x,
 |  | uint8_t | adc_channel_count
 | ) |  |

set partitioned mode channel count of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_channel_count configure the adc partitioned mode channel count. this parameter can be:
  • (0x1~0x8)
Return values
none

Definition at line 843 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_ordinary_part_mode_enable()

void adc_ordinary_part_mode_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the partitioned mode on ordinary channel of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
new_state new state of ordinary channel's partitioned mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 858 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_ordinary_software_trigger_enable()

void adc_ordinary_software_trigger_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable ordinary software start conversion of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
new_state new state of ordinary software start conversion. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 945 of file at32f435_437_adc.c.

Referenced by adc_configuration(), and main().

◆ adc_ordinary_software_trigger_status_get()

flag_status adc_ordinary_software_trigger_status_get ( adc_type * adc_x )

get ordinary software start conversion status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
Return values
the new state of ordinary software start conversion status(SET or RESET).

Definition at line 957 of file at32f435_437_adc.c.

◆ adc_oversample_ratio_shift_set()

void adc_oversample_ratio_shift_set | ( | adc_type * | adc_x,
 |  | adc_oversample_ratio_type | adc_oversample_ratio,
 |  | adc_oversample_shift_type | adc_oversample_shift
 | ) |  |

config the oversampling ratio and shift of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_oversample_ratio set the oversample ratio. this parameter can be one of the following values:
  • ADC_OVERSAMPLE_RATIO_2
  • ADC_OVERSAMPLE_RATIO_4
  • ADC_OVERSAMPLE_RATIO_8
  • ADC_OVERSAMPLE_RATIO_16
  • ADC_OVERSAMPLE_RATIO_32
  • ADC_OVERSAMPLE_RATIO_64
  • ADC_OVERSAMPLE_RATIO_128
  • ADC_OVERSAMPLE_RATIO_256
adc_oversample_shift set the oversample shift. this parameter can be one of the following values:
  • ADC_OVERSAMPLE_SHIFT_0
  • ADC_OVERSAMPLE_SHIFT_1
  • ADC_OVERSAMPLE_SHIFT_2
  • ADC_OVERSAMPLE_SHIFT_3
  • ADC_OVERSAMPLE_SHIFT_4
  • ADC_OVERSAMPLE_SHIFT_5
  • ADC_OVERSAMPLE_SHIFT_6
  • ADC_OVERSAMPLE_SHIFT_7
  • ADC_OVERSAMPLE_SHIFT_8
Return values
none

Definition at line 1167 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_preempt_auto_mode_enable()

void adc_preempt_auto_mode_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable automatic preempt group conversion of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
new_state new state of automatic preempt group conversion. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 886 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_preempt_channel_length_set()

void adc_preempt_channel_length_set | ( | adc_type * | adc_x,
 |  | uint8_t | adc_channel_lenght
 | ) |  |

set preempt channel lenghth of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_channel_lenght set the adc preempt channel lenghth. this parameter can be:
  • (0x1~0x4)
Return values
none

Definition at line 601 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_preempt_channel_set()

void adc_preempt_channel_set | ( | adc_type * | adc_x,
 |  | adc_channel_select_type | adc_channel,
 |  | uint8_t | adc_sequence,
 |  | adc_sampletime_select_type | adc_sampletime
 | ) |  |

configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_channel select the channel. this parameter can be one of the following values:
  • ADC_CHANNEL_0 - ADC_CHANNEL_1 - ADC_CHANNEL_2 - ADC_CHANNEL_3
  • ADC_CHANNEL_4 - ADC_CHANNEL_5 - ADC_CHANNEL_6 - ADC_CHANNEL_7
  • ADC_CHANNEL_8 - ADC_CHANNEL_9 - ADC_CHANNEL_10 - ADC_CHANNEL_11
  • ADC_CHANNEL_12 - ADC_CHANNEL_13 - ADC_CHANNEL_14 - ADC_CHANNEL_15
  • ADC_CHANNEL_16 - ADC_CHANNEL_17 - ADC_CHANNEL_18
adc_sequence set rank in the preempt group sequencer. this parameter must be:
  • between 1 to 4
adc_sampletime config the sampletime of adc channel. this parameter can be one of the following values:
  • ADC_SAMPLETIME_2_5
  • ADC_SAMPLETIME_6_5
  • ADC_SAMPLETIME_12_5
  • ADC_SAMPLETIME_24_5
  • ADC_SAMPLETIME_47_5
  • ADC_SAMPLETIME_92_5
  • ADC_SAMPLETIME_247_5
  • ADC_SAMPLETIME_640_5
Return values
none

Definition at line 633 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_preempt_conversion_data_get()

uint16_t adc_preempt_conversion_data_get | ( | adc_type * | adc_x,
 |  | adc_preempt_channel_type | adc_preempt_channel
 | ) |  |

return the conversion data for selection preempt channel of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_preempt_channel select the preempt channel. this parameter can be one of the following values:
  • ADC_PREEMPT_CHANNEL_1
  • ADC_PREEMPT_CHANNEL_2
  • ADC_PREEMPT_CHANNEL_3
  • ADC_PREEMPT_CHANNEL_4
Return values
the conversion data for selection preempt channel.

Definition at line 1036 of file at32f435_437_adc.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc_preempt_conversion_trigger_set()

void adc_preempt_conversion_trigger_set | ( | adc_type * | adc_x,
 |  | adc_preempt_trig_select_type | adc_preempt_trig,
 |  | adc_preempt_trig_edge_type | adc_preempt_trig_edge
 | ) |  |

enable or disable the preempt channel's external trigger and set external trigger event of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_preempt_trig select the external trigger event. this parameter can be one of the following values:
  • ADC_PREEMPT_TRIG_TMR1CH4 - ADC_PREEMPT_TRIG_TMR1TRGOUT - ADC_PREEMPT_TRIG_TMR2CH1 - ADC_PREEMPT_TRIG_TMR2TRGOUT
  • ADC_PREEMPT_TRIG_TMR3CH2 - ADC_PREEMPT_TRIG_TMR3CH4 - ADC_PREEMPT_TRIG_TMR4CH1 - ADC_PREEMPT_TRIG_TMR4CH2
  • ADC_PREEMPT_TRIG_TMR4CH3 - ADC_PREEMPT_TRIG_TMR4TRGOUT - ADC_PREEMPT_TRIG_TMR5CH4 - ADC_PREEMPT_TRIG_TMR5TRGOUT
  • ADC_PREEMPT_TRIG_TMR8CH2 - ADC_PREEMPT_TRIG_TMR8CH3 - ADC_PREEMPT_TRIG_TMR8CH4 - ADC_PREEMPT_TRIG_EXINT15
  • ADC_PREEMPT_TRIG_TMR20TRGOUT - ADC_PREEMPT_TRIG_TMR20TRGOUT2 - ADC_PREEMPT_TRIG_TMR20CH4 - ADC_PREEMPT_TRIG_TMR1TRGOUT2
  • ADC_PREEMPT_TRIG_TMR8TRGOUT - ADC_PREEMPT_TRIG_TMR8TRGOUT2 - ADC_PREEMPT_TRIG_TMR3CH3 - ADC_PREEMPT_TRIG_TMR3TRGOUT
  • ADC_PREEMPT_TRIG_TMR3CH1 - ADC_PREEMPT_TRIG_TMR6TRGOUT - ADC_PREEMPT_TRIG_TMR4CH4 - ADC_PREEMPT_TRIG_TMR1CH3
  • ADC_PREEMPT_TRIG_TMR20CH2 - ADC_PREEMPT_TRIG_TMR7TRGOUT
adc_preempt_trig_edge preempt channel conversion's external_trigger_edge. this parameter can be one of the following values:
  • ADC_PREEMPT_TRIG_EDGE_NONE
  • ADC_PREEMPT_TRIG_EDGE_RISING
  • ADC_PREEMPT_TRIG_EDGE_FALLING
  • ADC_PREEMPT_TRIG_EDGE_RISING_FALLING
Return values
none

Definition at line 781 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_preempt_offset_value_set()

void adc_preempt_offset_value_set | ( | adc_type * | adc_x,
 |  | adc_preempt_channel_type | adc_preempt_channel,
 |  | uint16_t | adc_offset_value
 | ) |  |

set preempt channel's conversion value offset of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_preempt_channel select the preempt channel. this parameter can be one of the following values:
  • ADC_PREEMPT_CHANNEL_1
  • ADC_PREEMPT_CHANNEL_2
  • ADC_PREEMPT_CHANNEL_3
  • ADC_PREEMPT_CHANNEL_4
adc_offset_value set the adc preempt channel's conversion value offset. this parameter can be:
  • (0x000~0xFFF)
Return values
none

Definition at line 812 of file at32f435_437_adc.c.

◆ adc_preempt_oversample_enable()

void adc_preempt_oversample_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the preempt oversampling of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
new_state new state of preempt oversampling. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 1134 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_preempt_part_mode_enable()

void adc_preempt_part_mode_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the partitioned mode on preempt channel of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
new_state new state of preempt channel's partitioned mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 872 of file at32f435_437_adc.c.

◆ adc_preempt_software_trigger_enable()

void adc_preempt_software_trigger_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable preempt software start conversion of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
new_state new state of preempt software start conversion. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 978 of file at32f435_437_adc.c.

Referenced by main().

◆ adc_preempt_software_trigger_status_get()

flag_status adc_preempt_software_trigger_status_get ( adc_type * adc_x )

get preempt software start conversion status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
Return values
the new state of preempt software start conversion status(SET or RESET).

Definition at line 990 of file at32f435_437_adc.c.

◆ adc_reset()

void adc_reset ( void )

deinitialize the adc peripheral registers to their default reset values.

Parameters
none
Return values
none

Definition at line 49 of file at32f435_437_adc.c.

◆ adc_resolution_set()

void adc_resolution_set | ( | adc_type * | adc_x,
 |  | adc_resolution_type | resolution
 | ) |  |

set resolution of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
resolution set the conversion resolution. this parameter can be one of the following values:
  • ADC_RESOLUTION_12B
  • ADC_RESOLUTION_10B
  • ADC_RESOLUTION_8B
  • ADC_RESOLUTION_6B
Return values
none

Definition at line 235 of file at32f435_437_adc.c.

Referenced by adc_config(), and adc_configuration().

◆ adc_voltage_battery_enable()

void adc_voltage_battery_enable ( confirm_state new_state )

enable or disable the adc voltage battery.

Parameters
new_state new state of the adc voltage battery. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 246 of file at32f435_437_adc.c.

Referenced by main().

◆ adc_voltage_monitor_enable()

void adc_voltage_monitor_enable | ( | adc_type * | adc_x,
 |  | adc_voltage_monitoring_type | adc_voltage_monitoring
 | ) |  |

enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_voltage_monitoring choose the adc_voltage_monitoring config. this parameter can be one of the following values:
  • ADC_VMONITOR_SINGLE_ORDINARY
  • ADC_VMONITOR_SINGLE_PREEMPT
  • ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT
  • ADC_VMONITOR_ALL_ORDINARY
  • ADC_VMONITOR_ALL_PREEMPT
  • ADC_VMONITOR_ALL_ORDINARY_PREEMPT
  • ADC_VMONITOR_NONE
Return values
none

Definition at line 399 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_voltage_monitor_single_channel_select()

void adc_voltage_monitor_single_channel_select | ( | adc_type * | adc_x,
 |  | adc_channel_select_type | adc_channel
 | ) |  |

select the voltage monitoring's channel of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_channel select the channel. this parameter can be one of the following values:
  • ADC_CHANNEL_0 - ADC_CHANNEL_1 - ADC_CHANNEL_2 - ADC_CHANNEL_3
  • ADC_CHANNEL_4 - ADC_CHANNEL_5 - ADC_CHANNEL_6 - ADC_CHANNEL_7
  • ADC_CHANNEL_8 - ADC_CHANNEL_9 - ADC_CHANNEL_10 - ADC_CHANNEL_11
  • ADC_CHANNEL_12 - ADC_CHANNEL_13 - ADC_CHANNEL_14 - ADC_CHANNEL_15
  • ADC_CHANNEL_16 - ADC_CHANNEL_17 - ADC_CHANNEL_18
Return values
none

Definition at line 440 of file at32f435_437_adc.c.

Referenced by adc_config().

◆ adc_voltage_monitor_threshold_value_set()

void adc_voltage_monitor_threshold_value_set | ( | adc_type * | adc_x,
 |  | uint16_t | adc_high_threshold,
 |  | uint16_t | adc_low_threshold
 | ) |  |

set voltage monitoring's high and low thresholds value of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values:
  • ADC1, ADC2, ADC3.
adc_high_threshold voltage monitoring's high thresholds value. this parameter can be:
  • (0x000~0xFFF)
adc_low_threshold voltage monitoring's low thresholds value. this parameter can be:
  • (0x000~0xFFF)
Return values
none

Definition at line 420 of file at32f435_437_adc.c.

Referenced by adc_config().


AT32F435/437 Firmwary Library: CAN

Modules | Macros
CAN
AT32F435_437_periph_driver

CAN driver modules. More...

Modules

CAN_timeout_count
CAN_flags_definition
can flag
CAN_interrupts_definition
can interrupt
CAN_exported_types
CAN_exported_functions
CAN_private_functions

Macros

#define | CAN_MSTS_EOIF_VAL ((uint32_t)0x00000004)
can flag clear operation macro definition val More...
#define | CAN_MSTS_QDZIF_VAL ((uint32_t)0x00000008)
#define | CAN_MSTS_EDZIF_VAL ((uint32_t)0x00000010)
#define | CAN_TSTS_TM0TCF_VAL ((uint32_t)0x00000001)
#define | CAN_TSTS_TM1TCF_VAL ((uint32_t)0x00000100)
#define | CAN_TSTS_TM2TCF_VAL ((uint32_t)0x00010000)
#define | CAN_TSTS_TM0CT_VAL ((uint32_t)0x00000080)
#define | CAN_TSTS_TM1CT_VAL ((uint32_t)0x00008000)
#define | CAN_TSTS_TM2CT_VAL ((uint32_t)0x00800000)
#define | CAN_RF0_RF0FF_VAL ((uint32_t)0x00000008)
#define | CAN_RF0_RF0OF_VAL ((uint32_t)0x00000010)
#define | CAN_RF0_RF0R_VAL ((uint32_t)0x00000020)
#define | CAN_RF1_RF1FF_VAL ((uint32_t)0x00000008)
#define | CAN_RF1_RF1OF_VAL ((uint32_t)0x00000010)
#define | CAN_RF1_RF1R_VAL ((uint32_t)0x00000020)
#define | CAN1 ((can_type *) CAN1_BASE)
#define | CAN2 ((can_type *) CAN2_BASE)

Detailed Description

CAN driver modules.

Macro Definition Documentation

◆ CAN1

#define CAN1 ((can_type *) CAN1_BASE)

Definition at line 994 of file at32f435_437_can.h.

◆ CAN2

#define CAN2 ((can_type *) CAN2_BASE)

Definition at line 995 of file at32f435_437_can.h.

◆ CAN_MSTS_EDZIF_VAL

#define CAN_MSTS_EDZIF_VAL ((uint32_t)0x00000010)

edzif bit value, it clear by writing 1

Definition at line 115 of file at32f435_437_can.h.

◆ CAN_MSTS_EOIF_VAL

#define CAN_MSTS_EOIF_VAL ((uint32_t)0x00000004)

can flag clear operation macro definition val

eoif bit value, it clear by writing 1

Definition at line 113 of file at32f435_437_can.h.

◆ CAN_MSTS_QDZIF_VAL

#define CAN_MSTS_QDZIF_VAL ((uint32_t)0x00000008)

qdzif bit value, it clear by writing 1

Definition at line 114 of file at32f435_437_can.h.

◆ CAN_RF0_RF0FF_VAL

#define CAN_RF0_RF0FF_VAL ((uint32_t)0x00000008)

rf0ff bit value, it clear by writing 1

Definition at line 122 of file at32f435_437_can.h.

◆ CAN_RF0_RF0OF_VAL

#define CAN_RF0_RF0OF_VAL ((uint32_t)0x00000010)

rf0of bit value, it clear by writing 1

Definition at line 123 of file at32f435_437_can.h.

◆ CAN_RF0_RF0R_VAL

#define CAN_RF0_RF0R_VAL ((uint32_t)0x00000020)

rf0r bit value, it clear by writing 1

Definition at line 124 of file at32f435_437_can.h.

◆ CAN_RF1_RF1FF_VAL

#define CAN_RF1_RF1FF_VAL ((uint32_t)0x00000008)

rf1ff bit value, it clear by writing 1

Definition at line 125 of file at32f435_437_can.h.

◆ CAN_RF1_RF1OF_VAL

#define CAN_RF1_RF1OF_VAL ((uint32_t)0x00000010)

rf1of bit value, it clear by writing 1

Definition at line 126 of file at32f435_437_can.h.

◆ CAN_RF1_RF1R_VAL

#define CAN_RF1_RF1R_VAL ((uint32_t)0x00000020)

rf1r bit value, it clear by writing 1

Definition at line 127 of file at32f435_437_can.h.

◆ CAN_TSTS_TM0CT_VAL

#define CAN_TSTS_TM0CT_VAL ((uint32_t)0x00000080)

tm0ct bit value, it clear by writing 1

Definition at line 119 of file at32f435_437_can.h.

◆ CAN_TSTS_TM0TCF_VAL

#define CAN_TSTS_TM0TCF_VAL ((uint32_t)0x00000001)

tm0tcf bit value, it clear by writing 1

Definition at line 116 of file at32f435_437_can.h.

◆ CAN_TSTS_TM1CT_VAL

#define CAN_TSTS_TM1CT_VAL ((uint32_t)0x00008000)

tm1ct bit value, it clear by writing 1

Definition at line 120 of file at32f435_437_can.h.

◆ CAN_TSTS_TM1TCF_VAL

#define CAN_TSTS_TM1TCF_VAL ((uint32_t)0x00000100)

tm1tcf bit value, it clear by writing 1

Definition at line 117 of file at32f435_437_can.h.

◆ CAN_TSTS_TM2CT_VAL

#define CAN_TSTS_TM2CT_VAL ((uint32_t)0x00800000)

tm2ct bit value, it clear by writing 1

Definition at line 121 of file at32f435_437_can.h.

◆ CAN_TSTS_TM2TCF_VAL

#define CAN_TSTS_TM2TCF_VAL ((uint32_t)0x00010000)

tm2tcf bit value, it clear by writing 1

Definition at line 118 of file at32f435_437_can.h.


AT32F435/437 Firmwary Library: CAN_timeout_count

Macros
CAN_timeout_count
AT32F435_437_periph_driver » CAN

Macros

#define | FZC_TIMEOUT ((uint32_t)0x0000FFFF)
#define | DZC_TIMEOUT ((uint32_t)0x0000FFFF)

Detailed Description

Macro Definition Documentation

◆ DZC_TIMEOUT

#define DZC_TIMEOUT ((uint32_t)0x0000FFFF)

time out for dzc bit

Definition at line 53 of file at32f435_437_can.h.

◆ FZC_TIMEOUT

#define FZC_TIMEOUT ((uint32_t)0x0000FFFF)

time out for fzc bit

Definition at line 52 of file at32f435_437_can.h.


AT32F435/437 Firmwary Library: CAN_flags_definition

Macros
CAN_flags_definition
AT32F435_437_periph_driver » CAN

can flag More...

Macros

#define | CAN_EAF_FLAG ((uint32_t)0x01)
#define | CAN_EPF_FLAG ((uint32_t)0x02)
#define | CAN_BOF_FLAG ((uint32_t)0x03)
#define | CAN_ETR_FLAG ((uint32_t)0x04)
#define | CAN_EOIF_FLAG ((uint32_t)0x05)
#define | CAN_TM0TCF_FLAG ((uint32_t)0x06)
#define | CAN_TM1TCF_FLAG ((uint32_t)0x07)
#define | CAN_TM2TCF_FLAG ((uint32_t)0x08)
#define | CAN_RF0MN_FLAG ((uint32_t)0x09)
#define | CAN_RF0FF_FLAG ((uint32_t)0x0A)
#define | CAN_RF0OF_FLAG ((uint32_t)0x0B)
#define | CAN_RF1MN_FLAG ((uint32_t)0x0C)
#define | CAN_RF1FF_FLAG ((uint32_t)0x0D)
#define | CAN_RF1OF_FLAG ((uint32_t)0x0E)
#define | CAN_QDZIF_FLAG ((uint32_t)0x0F)
#define | CAN_EDZC_FLAG ((uint32_t)0x10)
#define | CAN_TMEF_FLAG ((uint32_t)0x11)

Detailed Description

can flag

Macro Definition Documentation

◆ CAN_BOF_FLAG

#define CAN_BOF_FLAG ((uint32_t)0x03)

bus-off flag

Definition at line 66 of file at32f435_437_can.h.

◆ CAN_EAF_FLAG

#define CAN_EAF_FLAG ((uint32_t)0x01)

error active flag

Definition at line 64 of file at32f435_437_can.h.

◆ CAN_EDZC_FLAG

#define CAN_EDZC_FLAG ((uint32_t)0x10)

enter doze mode confirm flag

Definition at line 79 of file at32f435_437_can.h.

◆ CAN_EOIF_FLAG

#define CAN_EOIF_FLAG ((uint32_t)0x05)

error occur interrupt flag

Definition at line 68 of file at32f435_437_can.h.

◆ CAN_EPF_FLAG

#define CAN_EPF_FLAG ((uint32_t)0x02)

error passive flag

Definition at line 65 of file at32f435_437_can.h.

◆ CAN_ETR_FLAG

#define CAN_ETR_FLAG ((uint32_t)0x04)

error type record flag

Definition at line 67 of file at32f435_437_can.h.

◆ CAN_QDZIF_FLAG

#define CAN_QDZIF_FLAG ((uint32_t)0x0F)

quit doze mode interrupt flag

Definition at line 78 of file at32f435_437_can.h.

◆ CAN_RF0FF_FLAG

#define CAN_RF0FF_FLAG ((uint32_t)0x0A)

receive fifo 0 full flag

Definition at line 73 of file at32f435_437_can.h.

◆ CAN_RF0MN_FLAG

#define CAN_RF0MN_FLAG ((uint32_t)0x09)

receive fifo 0 message num flag

Definition at line 72 of file at32f435_437_can.h.

◆ CAN_RF0OF_FLAG

#define CAN_RF0OF_FLAG ((uint32_t)0x0B)

receive fifo 0 overflow flag

Definition at line 74 of file at32f435_437_can.h.

◆ CAN_RF1FF_FLAG

#define CAN_RF1FF_FLAG ((uint32_t)0x0D)

receive fifo 1 full flag

Definition at line 76 of file at32f435_437_can.h.

◆ CAN_RF1MN_FLAG

#define CAN_RF1MN_FLAG ((uint32_t)0x0C)

receive fifo 1 message num flag

Definition at line 75 of file at32f435_437_can.h.

◆ CAN_RF1OF_FLAG

#define CAN_RF1OF_FLAG ((uint32_t)0x0E)

receive fifo 1 overflow flag

Definition at line 77 of file at32f435_437_can.h.

◆ CAN_TM0TCF_FLAG

#define CAN_TM0TCF_FLAG ((uint32_t)0x06)

transmit mailbox 0 transmission completed flag

Definition at line 69 of file at32f435_437_can.h.

◆ CAN_TM1TCF_FLAG

#define CAN_TM1TCF_FLAG ((uint32_t)0x07)

transmit mailbox 1 transmission completed flag

Definition at line 70 of file at32f435_437_can.h.

◆ CAN_TM2TCF_FLAG

#define CAN_TM2TCF_FLAG ((uint32_t)0x08)

transmit mailbox 2 transmission completed flag

Definition at line 71 of file at32f435_437_can.h.

◆ CAN_TMEF_FLAG

#define CAN_TMEF_FLAG ((uint32_t)0x11)

transmit mailbox empty flag

Definition at line 80 of file at32f435_437_can.h.


AT32F435/437 Firmwary Library: CAN_interrupts_definition

Macros
CAN_interrupts_definition
AT32F435_437_periph_driver » CAN

can interrupt More...

Macros

#define | CAN_TCIEN_INT ((uint32_t)0x00000001)
#define | CAN_RF0MIEN_INT ((uint32_t)0x00000002)
#define | CAN_RF0FIEN_INT ((uint32_t)0x00000004)
#define | CAN_RF0OIEN_INT ((uint32_t)0x00000008)
#define | CAN_RF1MIEN_INT ((uint32_t)0x00000010)
#define | CAN_RF1FIEN_INT ((uint32_t)0x00000020)
#define | CAN_RF1OIEN_INT ((uint32_t)0x00000040)
#define | CAN_EAIEN_INT ((uint32_t)0x00000100)
#define | CAN_EPIEN_INT ((uint32_t)0x00000200)
#define | CAN_BOIEN_INT ((uint32_t)0x00000400)
#define | CAN_ETRIEN_INT ((uint32_t)0x00000800)
#define | CAN_EOIEN_INT ((uint32_t)0x00008000)
#define | CAN_QDZIEN_INT ((uint32_t)0x00010000)
#define | CAN_EDZIEN_INT ((uint32_t)0x00020000)

Detailed Description

can interrupt

Macro Definition Documentation

◆ CAN_BOIEN_INT

#define CAN_BOIEN_INT ((uint32_t)0x00000400)

bus-off interrupt

Definition at line 100 of file at32f435_437_can.h.

◆ CAN_EAIEN_INT

#define CAN_EAIEN_INT ((uint32_t)0x00000100)

error active interrupt

Definition at line 98 of file at32f435_437_can.h.

◆ CAN_EDZIEN_INT

#define CAN_EDZIEN_INT ((uint32_t)0x00020000)

enter doze mode confirm interrupt

Definition at line 104 of file at32f435_437_can.h.

◆ CAN_EOIEN_INT

#define CAN_EOIEN_INT ((uint32_t)0x00008000)

error occur interrupt

Definition at line 102 of file at32f435_437_can.h.

◆ CAN_EPIEN_INT

#define CAN_EPIEN_INT ((uint32_t)0x00000200)

error passive interrupt

Definition at line 99 of file at32f435_437_can.h.

◆ CAN_ETRIEN_INT

#define CAN_ETRIEN_INT ((uint32_t)0x00000800)

error type record interrupt

Definition at line 101 of file at32f435_437_can.h.

◆ CAN_QDZIEN_INT

#define CAN_QDZIEN_INT ((uint32_t)0x00010000)

quit doze mode interrupt

Definition at line 103 of file at32f435_437_can.h.

◆ CAN_RF0FIEN_INT

#define CAN_RF0FIEN_INT ((uint32_t)0x00000004)

receive fifo 0 full interrupt

Definition at line 93 of file at32f435_437_can.h.

◆ CAN_RF0MIEN_INT

#define CAN_RF0MIEN_INT ((uint32_t)0x00000002)

receive fifo 0 message interrupt

Definition at line 92 of file at32f435_437_can.h.

◆ CAN_RF0OIEN_INT

#define CAN_RF0OIEN_INT ((uint32_t)0x00000008)

receive fifo 0 overflow interrupt

Definition at line 94 of file at32f435_437_can.h.

◆ CAN_RF1FIEN_INT

#define CAN_RF1FIEN_INT ((uint32_t)0x00000020)

receive fifo 1 full interrupt

Definition at line 96 of file at32f435_437_can.h.

◆ CAN_RF1MIEN_INT

#define CAN_RF1MIEN_INT ((uint32_t)0x00000010)

receive fifo 1 message interrupt

Definition at line 95 of file at32f435_437_can.h.

◆ CAN_RF1OIEN_INT

#define CAN_RF1OIEN_INT ((uint32_t)0x00000040)

receive fifo 1 overflow interrupt

Definition at line 97 of file at32f435_437_can.h.

◆ CAN_TCIEN_INT

#define CAN_TCIEN_INT ((uint32_t)0x00000001)

transmission complete interrupt

Definition at line 91 of file at32f435_437_can.h.


AT32F435/437 Firmwary Library: CAN_exported_types

Data Structures | Enumerations
CAN_exported_types
AT32F435_437_periph_driver » CAN

Data Structures

struct | can_base_type
can init structure definition More...
struct | can_baudrate_type
can baudrate structure definition More...
struct | can_filter_init_type
can filter init structure definition More...
struct | can_tx_message_type
can tx message structure definition More...
struct | can_rx_message_type
can rx message structure definition More...
struct | can_tx_mailbox_type
can controller area network tx mailbox More...
struct | can_fifo_mailbox_type
can controller area network fifo mailbox More...
struct | can_filter_register_type
can controller area network filter bit register More...
struct | can_type
type define can register all More...

Enumerations

enum | can_filter_fifo_type { CAN_FILTER_FIFO0 = 0x00 , CAN_FILTER_FIFO1 = 0x01 }
can filter fifo More...
enum | can_filter_mode_type { CAN_FILTER_MODE_ID_MASK = 0x00 , CAN_FILTER_MODE_ID_LIST = 0x01 }
can filter mode More...
enum | can_filter_bit_width_type { CAN_FILTER_16BIT = 0x00 , CAN_FILTER_32BIT = 0x01 }
can filter bit width select More...
enum | can_mode_type { CAN_MODE_COMMUNICATE = 0x00 , CAN_MODE_LOOPBACK = 0x01 , CAN_MODE_LISTENONLY = 0x02 , CAN_MODE_LISTENONLY_LOOPBACK = 0x03 }
can mode More...
enum | can_operating_mode_type { CAN_OPERATINGMODE_FREEZE = 0x00 , CAN_OPERATINGMODE_DOZE = 0x01 , CAN_OPERATINGMODE_COMMUNICATE = 0x02 }
can operating mode More...
enum | can_rsaw_type { CAN_RSAW_1TQ = 0x00 , CAN_RSAW_2TQ = 0x01 , CAN_RSAW_3TQ = 0x02 , CAN_RSAW_4TQ = 0x03 }
can resynchronization adjust width More...
enum can_bts1_type {
CAN_BTS1_1TQ = 0x00 , CAN_BTS1_2TQ = 0x01 , CAN_BTS1_3TQ = 0x02 , CAN_BTS1_4TQ = 0x03 ,
CAN_BTS1_5TQ = 0x04 , CAN_BTS1_6TQ = 0x05 , CAN_BTS1_7TQ = 0x06 , CAN_BTS1_8TQ = 0x07 ,
CAN_BTS1_9TQ = 0x08 , CAN_BTS1_10TQ = 0x09 , CAN_BTS1_11TQ = 0x0A , CAN_BTS1_12TQ = 0x0B ,
CAN_BTS1_13TQ = 0x0C , CAN_BTS1_14TQ = 0x0D , CAN_BTS1_15TQ = 0x0E , CAN_BTS1_16TQ = 0x0F
}
can bit time segment 1 More...
enum can_bts2_type {
CAN_BTS2_1TQ = 0x00 , CAN_BTS2_2TQ = 0x01 , CAN_BTS2_3TQ = 0x02 , CAN_BTS2_4TQ = 0x03 ,
CAN_BTS2_5TQ = 0x04 , CAN_BTS2_6TQ = 0x05 , CAN_BTS2_7TQ = 0x06 , CAN_BTS2_8TQ = 0x07
}
can bit time segment 2 More...
enum | can_identifier_type { CAN_ID_STANDARD = 0x00 , CAN_ID_EXTENDED = 0x01 }
can identifier type More...
enum | can_trans_frame_type { CAN_TFT_DATA = 0x00 , CAN_TFT_REMOTE = 0x01 }
can transmission frame type More...
enum | can_tx_mailbox_num_type { CAN_TX_MAILBOX0 = 0x00 , CAN_TX_MAILBOX1 = 0x01 , CAN_TX_MAILBOX2 = 0x02 }
can tx mailboxes More...
enum | can_rx_fifo_num_type { CAN_RX_FIFO0 = 0x00 , CAN_RX_FIFO1 = 0x01 }
can receive fifo More...
enum | can_transmit_status_type { CAN_TX_STATUS_FAILED = 0x00 , CAN_TX_STATUS_SUCCESSFUL = 0x01 , CAN_TX_STATUS_PENDING = 0x02 , CAN_TX_STATUS_NO_EMPTY = 0x04 }
can transmit status More...
enum | can_enter_doze_status_type { CAN_ENTER_DOZE_FAILED = 0x00 , CAN_ENTER_DOZE_SUCCESSFUL = 0x01 }
can enter doze mode status More...
enum | can_quit_doze_status_type { CAN_QUIT_DOZE_FAILED = 0x00 , CAN_QUIT_DOZE_SUCCESSFUL = 0x01 }
can quit doze mode status More...
enum | can_msg_discarding_rule_type { CAN_DISCARDING_FIRST_RECEIVED = 0x00 , CAN_DISCARDING_LAST_RECEIVED = 0x01 }
can message discarding rule select when overflow More...
enum | can_msg_sending_rule_type { CAN_SENDING_BY_ID = 0x00 , CAN_SENDING_BY_REQUEST = 0x01 }
can multiple message sending sequence rule More...
enum can_error_record_type {
CAN_ERRORRECORD_NOERR = 0x00 , CAN_ERRORRECORD_STUFFERR = 0x01 , CAN_ERRORRECORD_FORMERR = 0x02 , CAN_ERRORRECORD_ACKERR = 0x03 ,
CAN_ERRORRECORD_BITRECESSIVEERR = 0x04 , CAN_ERRORRECORD_BITDOMINANTERR = 0x05 , CAN_ERRORRECORD_CRCERR = 0x06 , CAN_ERRORRECORD_SOFTWARESETERR = 0x07
}
can error type record More...

Detailed Description

Enumeration Type Documentation

◆ can_bts1_type

enum can_bts1_type

can bit time segment 1

Enumerator
CAN_BTS1_1TQ | 1 time quantum
CAN_BTS1_2TQ | 2 time quantum
CAN_BTS1_3TQ | 3 time quantum
CAN_BTS1_4TQ | 4 time quantum
CAN_BTS1_5TQ | 5 time quantum
CAN_BTS1_6TQ | 6 time quantum
CAN_BTS1_7TQ | 7 time quantum
CAN_BTS1_8TQ | 8 time quantum
CAN_BTS1_9TQ | 9 time quantum
CAN_BTS1_10TQ | 10 time quantum
CAN_BTS1_11TQ | 11 time quantum
CAN_BTS1_12TQ | 12 time quantum
CAN_BTS1_13TQ | 13 time quantum
CAN_BTS1_14TQ | 14 time quantum
CAN_BTS1_15TQ | 15 time quantum
CAN_BTS1_16TQ | 16 time quantum

Definition at line 195 of file at32f435_437_can.h.

◆ can_bts2_type

enum can_bts2_type

can bit time segment 2

Enumerator
CAN_BTS2_1TQ | 1 time quantum
CAN_BTS2_2TQ | 2 time quantum
CAN_BTS2_3TQ | 3 time quantum
CAN_BTS2_4TQ | 4 time quantum
CAN_BTS2_5TQ | 5 time quantum
CAN_BTS2_6TQ | 6 time quantum
CAN_BTS2_7TQ | 7 time quantum
CAN_BTS2_8TQ | 8 time quantum

Definition at line 218 of file at32f435_437_can.h.

◆ can_enter_doze_status_type

enum can_enter_doze_status_type

can enter doze mode status

Enumerator
CAN_ENTER_DOZE_FAILED | can enter the doze mode failed
CAN_ENTER_DOZE_SUCCESSFUL | can enter the doze mode successful

Definition at line 281 of file at32f435_437_can.h.

◆ can_error_record_type

enum can_error_record_type

can error type record

Enumerator
CAN_ERRORRECORD_NOERR | no error
CAN_ERRORRECORD_STUFFERR | stuff error
CAN_ERRORRECORD_FORMERR | form error
CAN_ERRORRECORD_ACKERR | acknowledgment error
CAN_ERRORRECORD_BITRECESSIVEERR | bit recessive error
CAN_ERRORRECORD_BITDOMINANTERR | bit dominant error
CAN_ERRORRECORD_CRCERR | crc error
CAN_ERRORRECORD_SOFTWARESETERR | software set error

Definition at line 317 of file at32f435_437_can.h.

◆ can_filter_bit_width_type

enum can_filter_bit_width_type

can filter bit width select

Enumerator
CAN_FILTER_16BIT | two 16-bit filters
CAN_FILTER_32BIT | one 32-bit filter

Definition at line 154 of file at32f435_437_can.h.

◆ can_filter_fifo_type

enum can_filter_fifo_type

can filter fifo

Enumerator
CAN_FILTER_FIFO0 | filter fifo 0 assignment for filter x
CAN_FILTER_FIFO1 | filter fifo 1 assignment for filter x

Definition at line 136 of file at32f435_437_can.h.

◆ can_filter_mode_type

enum can_filter_mode_type

can filter mode

Enumerator
CAN_FILTER_MODE_ID_MASK | identifier mask mode
CAN_FILTER_MODE_ID_LIST | identifier list mode

Definition at line 145 of file at32f435_437_can.h.

◆ can_identifier_type

enum can_identifier_type

can identifier type

Enumerator
CAN_ID_STANDARD | standard Id
CAN_ID_EXTENDED | extended Id

Definition at line 233 of file at32f435_437_can.h.

◆ can_mode_type

enum can_mode_type

can mode

Enumerator
CAN_MODE_COMMUNICATE | communication mode
CAN_MODE_LOOPBACK | loopback mode
CAN_MODE_LISTENONLY | listen-only mode
CAN_MODE_LISTENONLY_LOOPBACK | loopback combined with listen-only mode

Definition at line 163 of file at32f435_437_can.h.

◆ can_msg_discarding_rule_type

enum can_msg_discarding_rule_type

can message discarding rule select when overflow

Enumerator
CAN_DISCARDING_FIRST_RECEIVED | can discarding the first received message
CAN_DISCARDING_LAST_RECEIVED | can discarding the last received message

Definition at line 299 of file at32f435_437_can.h.

◆ can_msg_sending_rule_type

enum can_msg_sending_rule_type

can multiple message sending sequence rule

Enumerator
CAN_SENDING_BY_ID | can sending the minimum id message first
CAN_SENDING_BY_REQUEST | can sending the first request message first

Definition at line 308 of file at32f435_437_can.h.

◆ can_operating_mode_type

enum can_operating_mode_type

can operating mode

Enumerator
CAN_OPERATINGMODE_FREEZE | freeze mode
CAN_OPERATINGMODE_DOZE | doze mode
CAN_OPERATINGMODE_COMMUNICATE | communication mode

Definition at line 174 of file at32f435_437_can.h.

◆ can_quit_doze_status_type

enum can_quit_doze_status_type

can quit doze mode status

Enumerator
CAN_QUIT_DOZE_FAILED | can quit doze mode failed
CAN_QUIT_DOZE_SUCCESSFUL | can quit doze mode successful

Definition at line 290 of file at32f435_437_can.h.

◆ can_rsaw_type

enum can_rsaw_type

can resynchronization adjust width

Enumerator
CAN_RSAW_1TQ | 1 time quantum
CAN_RSAW_2TQ | 2 time quantum
CAN_RSAW_3TQ | 3 time quantum
CAN_RSAW_4TQ | 4 time quantum

Definition at line 184 of file at32f435_437_can.h.

◆ can_rx_fifo_num_type

enum can_rx_fifo_num_type

can receive fifo

Enumerator
CAN_RX_FIFO0 | can fifo 0 used to receive
CAN_RX_FIFO1 | can fifo 1 used to receive

Definition at line 261 of file at32f435_437_can.h.

◆ can_trans_frame_type

enum can_trans_frame_type

can transmission frame type

Enumerator
CAN_TFT_DATA | data frame
CAN_TFT_REMOTE | remote frame

Definition at line 242 of file at32f435_437_can.h.

◆ can_transmit_status_type

enum can_transmit_status_type

can transmit status

Enumerator
CAN_TX_STATUS_FAILED | can transmission failed
CAN_TX_STATUS_SUCCESSFUL | can transmission successful
CAN_TX_STATUS_PENDING | can transmission pending
CAN_TX_STATUS_NO_EMPTY | can transmission no empty mailbox

Definition at line 270 of file at32f435_437_can.h.

◆ can_tx_mailbox_num_type

enum can_tx_mailbox_num_type

can tx mailboxes

Enumerator
CAN_TX_MAILBOX0 | can tx mailbox 0
CAN_TX_MAILBOX1 | can tx mailbox 1
CAN_TX_MAILBOX2 | can tx mailbox 2

Definition at line 251 of file at32f435_437_can.h.


AT32F435/437 Firmwary Library: can_base_type Struct Reference

Data Fields
can_base_type Struct Reference
AT32F435_437_periph_driver » CAN » CAN_exported_types

can init structure definition More...

#include <at32f435_437_can.h>

Data Fields

can_mode_type mode_selection
confirm_state ttc_enable
confirm_state aebo_enable
confirm_state aed_enable
confirm_state prsf_enable
can_msg_discarding_rule_type mdrsel_selection
can_msg_sending_rule_type mmssr_selection

Detailed Description

can init structure definition

Definition at line 332 of file at32f435_437_can.h.

Field Documentation

◆ aebo_enable

confirm_state can_base_type::aebo_enable

automatic exit bus-off enable

Definition at line 338 of file at32f435_437_can.h.

Referenced by can_base_init(), can_configuration(), and can_default_para_init().

◆ aed_enable

confirm_state can_base_type::aed_enable

automatic exit doze mode enable

Definition at line 340 of file at32f435_437_can.h.

Referenced by can_base_init(), can_configuration(), and can_default_para_init().

◆ mdrsel_selection

can_msg_discarding_rule_type can_base_type::mdrsel_selection

message discarding rule select when overflow

Definition at line 344 of file at32f435_437_can.h.

Referenced by can_base_init(), can_configuration(), and can_default_para_init().

◆ mmssr_selection

can_msg_sending_rule_type can_base_type::mmssr_selection

multiple message sending sequence rule

Definition at line 346 of file at32f435_437_can.h.

Referenced by can_base_init(), can_configuration(), and can_default_para_init().

◆ mode_selection

can_mode_type can_base_type::mode_selection

specifies the can mode.

Definition at line 334 of file at32f435_437_can.h.

Referenced by can_base_init(), can_configuration(), and can_default_para_init().

◆ prsf_enable

confirm_state can_base_type::prsf_enable

prohibit retransmission when sending fails enable

Definition at line 342 of file at32f435_437_can.h.

Referenced by can_base_init(), can_configuration(), and can_default_para_init().

◆ ttc_enable

confirm_state can_base_type::ttc_enable

time triggered communication mode enable

Definition at line 336 of file at32f435_437_can.h.

Referenced by can_base_init(), can_configuration(), and can_default_para_init().

The documentation for this struct was generated from the following file:
  • at32f435_437_can.h


AT32F435/437 Firmwary Library: can_baudrate_type Struct Reference

Data Fields
can_baudrate_type Struct Reference
AT32F435_437_periph_driver » CAN » CAN_exported_types

can baudrate structure definition More...

#include <at32f435_437_can.h>

Data Fields

uint16_t baudrate_div
can_rsaw_type rsaw_size
can_bts1_type bts1_size
can_bts2_type bts2_size

Detailed Description

can baudrate structure definition

Definition at line 353 of file at32f435_437_can.h.

Field Documentation

◆ baudrate_div

uint16_t can_baudrate_type::baudrate_div

baudrate division,this parameter can be 0x001~0x1000.

Definition at line 355 of file at32f435_437_can.h.

Referenced by can_baudrate_default_para_init(), can_baudrate_set(), and can_configuration().

◆ bts1_size

can_bts1_type can_baudrate_type::bts1_size

bit time segment 1

Definition at line 359 of file at32f435_437_can.h.

Referenced by can_baudrate_default_para_init(), can_baudrate_set(), and can_configuration().

◆ bts2_size

can_bts2_type can_baudrate_type::bts2_size

bit time segment 2

Definition at line 361 of file at32f435_437_can.h.

Referenced by can_baudrate_default_para_init(), can_baudrate_set(), and can_configuration().

◆ rsaw_size

can_rsaw_type can_baudrate_type::rsaw_size

resynchronization adjust width

Definition at line 357 of file at32f435_437_can.h.

Referenced by can_baudrate_default_para_init(), can_baudrate_set(), and can_configuration().

The documentation for this struct was generated from the following file:
  • at32f435_437_can.h


AT32F435/437 Firmwary Library: can_filter_init_type Struct Reference

Data Fields
can_filter_init_type Struct Reference
AT32F435_437_periph_driver » CAN » CAN_exported_types

can filter init structure definition More...

#include <at32f435_437_can.h>

Data Fields

confirm_state filter_activate_enable
can_filter_mode_type filter_mode
can_filter_fifo_type filter_fifo
uint8_t | filter_number
can_filter_bit_width_type filter_bit
uint16_t | filter_id_high
uint16_t | filter_id_low
uint16_t | filter_mask_high
uint16_t | filter_mask_low

Detailed Description

can filter init structure definition

Definition at line 368 of file at32f435_437_can.h.

Field Documentation

◆ filter_activate_enable

confirm_state can_filter_init_type::filter_activate_enable

enable or disable the filter activate.

Definition at line 370 of file at32f435_437_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

◆ filter_bit

can_filter_bit_width_type can_filter_init_type::filter_bit

config the filter bit width 16bit or 32bit.

Definition at line 378 of file at32f435_437_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

◆ filter_fifo

can_filter_fifo_type can_filter_init_type::filter_fifo

config the fifo which will be assigned to the filter.

Definition at line 374 of file at32f435_437_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

◆ filter_id_high

uint16_t can_filter_init_type::filter_id_high

config the filter identification, for 32-bit configuration it's high 16 bits, for 16-bit configuration it's first.

Definition at line 380 of file at32f435_437_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

◆ filter_id_low

uint16_t can_filter_init_type::filter_id_low

config the filter identification, for 32-bit configuration it's low 16 bits, for 16-bit configuration it's second.

Definition at line 383 of file at32f435_437_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

◆ filter_mask_high

uint16_t can_filter_init_type::filter_mask_high

config the filter mask or identification, according to the filtering mode, for 32-bit configuration it's high 16 bits, for 16-bit configuration it's first.

Definition at line 386 of file at32f435_437_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

◆ filter_mask_low

uint16_t can_filter_init_type::filter_mask_low

config the filter mask or identification, according to the filtering mode, for 32-bit configuration it's low 16 bits, for 16-bit configuration it's second.

Definition at line 389 of file at32f435_437_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

◆ filter_mode

can_filter_mode_type can_filter_init_type::filter_mode

config the filter mode mask or list.

Definition at line 372 of file at32f435_437_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

◆ filter_number

uint8_t can_filter_init_type::filter_number

config the filter number, parameter ranges from 0 to 13.

Definition at line 376 of file at32f435_437_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

The documentation for this struct was generated from the following file:
  • at32f435_437_can.h


AT32F435/437 Firmwary Library: can_tx_message_type Struct Reference

Data Fields
can_tx_message_type Struct Reference
AT32F435_437_periph_driver » CAN » CAN_exported_types

can tx message structure definition More...

#include <at32f435_437_can.h>

Data Fields

uint32_t | standard_id
uint32_t | extended_id
can_identifier_type id_type
can_trans_frame_type frame_type
uint8_t | dlc
uint8_t | data [8]

Detailed Description

can tx message structure definition

Definition at line 396 of file at32f435_437_can.h.

Field Documentation

◆ data

uint8_t can_tx_message_type::data[8]

contains the transmit data. it ranges from 0 to 0xFF.

Definition at line 411 of file at32f435_437_can.h.

Referenced by can_message_transmit(), and can_transmit_data().

◆ dlc

uint8_t can_tx_message_type::dlc

specifies frame data length that will be transmitted. this parameter can be a value between 0 to 8

Definition at line 408 of file at32f435_437_can.h.

Referenced by can_message_transmit(), and can_transmit_data().

◆ extended_id

uint32_t can_tx_message_type::extended_id

specifies the 29 bits extended identifier. this parameter can be a value between 0 to 0x1FFFFFFF.

Definition at line 401 of file at32f435_437_can.h.

Referenced by can_message_transmit(), and can_transmit_data().

◆ frame_type

can_trans_frame_type can_tx_message_type::frame_type

specifies frame type for the transmit message.

Definition at line 406 of file at32f435_437_can.h.

Referenced by can_message_transmit(), and can_transmit_data().

◆ id_type

can_identifier_type can_tx_message_type::id_type

specifies identifier type for the transmit message.

Definition at line 404 of file at32f435_437_can.h.

Referenced by can_message_transmit(), and can_transmit_data().

◆ standard_id

uint32_t can_tx_message_type::standard_id

specifies the 11 bits standard identifier. this parameter can be a value between 0 to 0x7FF.

Definition at line 398 of file at32f435_437_can.h.

Referenced by can_message_transmit(), and can_transmit_data().

The documentation for this struct was generated from the following file:
  • at32f435_437_can.h


AT32F435/437 Firmwary Library: can_rx_message_type Struct Reference

Data Fields
can_rx_message_type Struct Reference
AT32F435_437_periph_driver » CAN » CAN_exported_types

can rx message structure definition More...

#include <at32f435_437_can.h>

Data Fields

uint32_t | standard_id
uint32_t | extended_id
can_identifier_type id_type
can_trans_frame_type frame_type
uint8_t | dlc
uint8_t | data [8]
uint8_t | filter_index

Detailed Description

can rx message structure definition

Definition at line 418 of file at32f435_437_can.h.

Field Documentation

◆ data

uint8_t can_rx_message_type::data[8]

contains the receive data. it ranges from 0 to 0xFF.

Definition at line 433 of file at32f435_437_can.h.

Referenced by can_message_receive().

◆ dlc

uint8_t can_rx_message_type::dlc

specifies the frame data length that will be received. this parameter can be a value between 0 to 8

Definition at line 430 of file at32f435_437_can.h.

Referenced by can_message_receive().

◆ extended_id

uint32_t can_rx_message_type::extended_id

specifies the 29 bits extended identifier. this parameter can be a value between 0 to 0x1FFFFFFF.

Definition at line 423 of file at32f435_437_can.h.

Referenced by CAN1_RX0_IRQHandler(), and can_message_receive().

◆ filter_index

uint8_t can_rx_message_type::filter_index

specifies the message stored in which filter this parameter can be a value between 0 to 0xFF

Definition at line 435 of file at32f435_437_can.h.

Referenced by can_message_receive().

◆ frame_type

can_trans_frame_type can_rx_message_type::frame_type

specifies frame type for the receive message.

Definition at line 428 of file at32f435_437_can.h.

Referenced by can_message_receive().

◆ id_type

can_identifier_type can_rx_message_type::id_type

specifies identifier type for the receive message.

Definition at line 426 of file at32f435_437_can.h.

Referenced by CAN1_RX0_IRQHandler(), and can_message_receive().

◆ standard_id

uint32_t can_rx_message_type::standard_id

specifies the 11 bits standard identifier this parameter can be a value between 0 to 0x7FF.

Definition at line 420 of file at32f435_437_can.h.

Referenced by CAN1_RX0_IRQHandler(), and can_message_receive().

The documentation for this struct was generated from the following file:
  • at32f435_437_can.h


AT32F435/437 Firmwary Library: can_tx_mailbox_type Struct Reference

Data Fields
can_tx_mailbox_type Struct Reference
AT32F435_437_periph_driver » CAN » CAN_exported_types

can controller area network tx mailbox More...

#include <at32f435_437_can.h>

Data Fields

union {
__IO uint32_t tmi
struct {
__IO uint32_t tmsr: 1
__IO uint32_t tmfrsel: 1
__IO uint32_t tmidsel: 1
__IO uint32_t tmeid: 18
__IO uint32_t tmsid: 11
} tmi_bit
};
can tmi register More...
union {
__IO uint32_t tmc
struct {
__IO uint32_t tmdtbl: 4
__IO uint32_t reserved1: 4
__IO uint32_t tmtsten: 1
__IO uint32_t reserved2: 7
__IO uint32_t tmts: 16
} tmc_bit
};
can tmc register More...
union {
__IO uint32_t tmdtl
struct {
__IO uint32_t tmdt0: 8
__IO uint32_t tmdt1: 8
__IO uint32_t tmdt2: 8
__IO uint32_t tmdt3: 8
} tmdtl_bit
};
can tmdtl register More...
union {
__IO uint32_t tmdth
struct {
__IO uint32_t tmdt4: 8
__IO uint32_t tmdt5: 8
__IO uint32_t tmdt6: 8
__IO uint32_t tmdt7: 8
} tmdth_bit
};
can tmdth register More...

Detailed Description

can controller area network tx mailbox

Definition at line 442 of file at32f435_437_can.h.

Field Documentation

◆

union { ... } can_tx_mailbox_type::@100

can tmdth register

◆

union { ... } can_tx_mailbox_type::@94

can tmi register

◆

union { ... } can_tx_mailbox_type::@96

can tmc register

◆

union { ... } can_tx_mailbox_type::@98

can tmdtl register

◆ reserved1

__IO uint32_t can_tx_mailbox_type::reserved1

Definition at line 469 of file at32f435_437_can.h.

◆ reserved2

__IO uint32_t can_tx_mailbox_type::reserved2

Definition at line 471 of file at32f435_437_can.h.

◆ tmc

__IO uint32_t can_tx_mailbox_type::tmc

Definition at line 465 of file at32f435_437_can.h.

◆

struct { ... } can_tx_mailbox_type::tmc_bit

Referenced by can_message_transmit(), and can_ttc_mode_enable().

◆ tmdt0

__IO uint32_t can_tx_mailbox_type::tmdt0

Definition at line 484 of file at32f435_437_can.h.

◆ tmdt1

__IO uint32_t can_tx_mailbox_type::tmdt1

Definition at line 485 of file at32f435_437_can.h.

◆ tmdt2

__IO uint32_t can_tx_mailbox_type::tmdt2

Definition at line 486 of file at32f435_437_can.h.

◆ tmdt3

__IO uint32_t can_tx_mailbox_type::tmdt3

Definition at line 487 of file at32f435_437_can.h.

◆ tmdt4

__IO uint32_t can_tx_mailbox_type::tmdt4

Definition at line 499 of file at32f435_437_can.h.

◆ tmdt5

__IO uint32_t can_tx_mailbox_type::tmdt5

Definition at line 500 of file at32f435_437_can.h.

◆ tmdt6

__IO uint32_t can_tx_mailbox_type::tmdt6

Definition at line 501 of file at32f435_437_can.h.

◆ tmdt7

__IO uint32_t can_tx_mailbox_type::tmdt7

Definition at line 502 of file at32f435_437_can.h.

◆ tmdtbl

__IO uint32_t can_tx_mailbox_type::tmdtbl

Definition at line 468 of file at32f435_437_can.h.

Referenced by can_message_transmit().

◆ tmdth

__IO uint32_t can_tx_mailbox_type::tmdth

Definition at line 496 of file at32f435_437_can.h.

Referenced by can_message_transmit().

◆

struct { ... } can_tx_mailbox_type::tmdth_bit

◆ tmdtl

__IO uint32_t can_tx_mailbox_type::tmdtl

Definition at line 481 of file at32f435_437_can.h.

Referenced by can_message_transmit().

◆

struct { ... } can_tx_mailbox_type::tmdtl_bit

◆ tmeid

__IO uint32_t can_tx_mailbox_type::tmeid

Definition at line 455 of file at32f435_437_can.h.

◆ tmfrsel

__IO uint32_t can_tx_mailbox_type::tmfrsel

Definition at line 453 of file at32f435_437_can.h.

Referenced by can_message_transmit().

◆ tmi

__IO uint32_t can_tx_mailbox_type::tmi

Definition at line 449 of file at32f435_437_can.h.

Referenced by can_message_transmit().

◆

struct { ... } can_tx_mailbox_type::tmi_bit

Referenced by can_message_transmit().

◆ tmidsel

__IO uint32_t can_tx_mailbox_type::tmidsel

Definition at line 454 of file at32f435_437_can.h.

Referenced by can_message_transmit().

◆ tmsid

__IO uint32_t can_tx_mailbox_type::tmsid

Definition at line 456 of file at32f435_437_can.h.

Referenced by can_message_transmit().

◆ tmsr

__IO uint32_t can_tx_mailbox_type::tmsr

Definition at line 452 of file at32f435_437_can.h.

Referenced by can_message_transmit().

◆ tmts

__IO uint32_t can_tx_mailbox_type::tmts

Definition at line 472 of file at32f435_437_can.h.

◆ tmtsten

__IO uint32_t can_tx_mailbox_type::tmtsten

Definition at line 470 of file at32f435_437_can.h.

Referenced by can_ttc_mode_enable().

The documentation for this struct was generated from the following file:
  • at32f435_437_can.h


AT32F435/437 Firmwary Library: can_fifo_mailbox_type Struct Reference

Data Fields
can_fifo_mailbox_type Struct Reference
AT32F435_437_periph_driver » CAN » CAN_exported_types

can controller area network fifo mailbox More...

#include <at32f435_437_can.h>

Data Fields

union {
__IO uint32_t rfi
struct {
__IO uint32_t reserved1: 1
__IO uint32_t rffri: 1
__IO uint32_t rfidi: 1
__IO uint32_t rfeid: 18
__IO uint32_t rfsid: 11
} rfi_bit
};
can rfi register More...
union {
__IO uint32_t rfc
struct {
__IO uint32_t rfdtl: 4
__IO uint32_t reserved1: 4
__IO uint32_t rffmn: 8
__IO uint32_t rfts: 16
} rfc_bit
};
can rfc register More...
union {
__IO uint32_t rfdtl
struct {
__IO uint32_t rfdt0: 8
__IO uint32_t rfdt1: 8
__IO uint32_t rfdt2: 8
__IO uint32_t rfdt3: 8
} rfdtl_bit
};
can rfdtl register More...
union {
__IO uint32_t rfdth
struct {
__IO uint32_t rfdt4: 8
__IO uint32_t rfdt5: 8
__IO uint32_t rfdt6: 8
__IO uint32_t rfdt7: 8
} rfdth_bit
};
can rfdth register More...

Detailed Description

can controller area network fifo mailbox

Definition at line 510 of file at32f435_437_can.h.

Field Documentation

◆

union { ... } can_fifo_mailbox_type::@106

can rfi register

◆

union { ... } can_fifo_mailbox_type::@108

can rfc register

◆

union { ... } can_fifo_mailbox_type::@110

can rfdtl register

◆

union { ... } can_fifo_mailbox_type::@112

can rfdth register

◆ reserved1

__IO uint32_t can_fifo_mailbox_type::reserved1

Definition at line 520 of file at32f435_437_can.h.

◆ rfc

__IO uint32_t can_fifo_mailbox_type::rfc

Definition at line 533 of file at32f435_437_can.h.

◆

struct { ... } can_fifo_mailbox_type::rfc_bit

Referenced by can_message_receive().

◆ rfdt0

__IO uint32_t can_fifo_mailbox_type::rfdt0

Definition at line 551 of file at32f435_437_can.h.

Referenced by can_message_receive().

◆ rfdt1

__IO uint32_t can_fifo_mailbox_type::rfdt1

Definition at line 552 of file at32f435_437_can.h.

Referenced by can_message_receive().

◆ rfdt2

__IO uint32_t can_fifo_mailbox_type::rfdt2

Definition at line 553 of file at32f435_437_can.h.

Referenced by can_message_receive().

◆ rfdt3

__IO uint32_t can_fifo_mailbox_type::rfdt3

Definition at line 554 of file at32f435_437_can.h.

Referenced by can_message_receive().

◆ rfdt4

__IO uint32_t can_fifo_mailbox_type::rfdt4

Definition at line 566 of file at32f435_437_can.h.

Referenced by can_message_receive().

◆ rfdt5

__IO uint32_t can_fifo_mailbox_type::rfdt5

Definition at line 567 of file at32f435_437_can.h.

Referenced by can_message_receive().

◆ rfdt6

__IO uint32_t can_fifo_mailbox_type::rfdt6

Definition at line 568 of file at32f435_437_can.h.

Referenced by can_message_receive().

◆ rfdt7

__IO uint32_t can_fifo_mailbox_type::rfdt7

Definition at line 569 of file at32f435_437_can.h.

Referenced by can_message_receive().

◆ rfdth

__IO uint32_t can_fifo_mailbox_type::rfdth

Definition at line 563 of file at32f435_437_can.h.

◆

struct { ... } can_fifo_mailbox_type::rfdth_bit

Referenced by can_message_receive().

◆ rfdtl

__IO uint32_t can_fifo_mailbox_type::rfdtl

Definition at line 536 of file at32f435_437_can.h.

Referenced by can_message_receive().

◆

struct { ... } can_fifo_mailbox_type::rfdtl_bit

Referenced by can_message_receive().

◆ rfeid

__IO uint32_t can_fifo_mailbox_type::rfeid

Definition at line 523 of file at32f435_437_can.h.

◆ rffmn

__IO uint32_t can_fifo_mailbox_type::rffmn

Definition at line 538 of file at32f435_437_can.h.

Referenced by can_message_receive().

◆ rffri

__IO uint32_t can_fifo_mailbox_type::rffri

Definition at line 521 of file at32f435_437_can.h.

Referenced by can_message_receive().

◆ rfi

__IO uint32_t can_fifo_mailbox_type::rfi

Definition at line 517 of file at32f435_437_can.h.

Referenced by can_message_receive().

◆

struct { ... } can_fifo_mailbox_type::rfi_bit

Referenced by can_message_receive().

◆ rfidi

__IO uint32_t can_fifo_mailbox_type::rfidi

Definition at line 522 of file at32f435_437_can.h.

Referenced by can_message_receive().

◆ rfsid

__IO uint32_t can_fifo_mailbox_type::rfsid

Definition at line 524 of file at32f435_437_can.h.

Referenced by can_message_receive().

◆ rfts

__IO uint32_t can_fifo_mailbox_type::rfts

Definition at line 539 of file at32f435_437_can.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_can.h


AT32F435/437 Firmwary Library: can_filter_register_type Struct Reference

Data Fields
can_filter_register_type Struct Reference
AT32F435_437_periph_driver » CAN » CAN_exported_types

can controller area network filter bit register More...

#include <at32f435_437_can.h>

Data Fields

__IO uint32_t | ffdb1
__IO uint32_t | ffdb2

Detailed Description

can controller area network filter bit register

Definition at line 577 of file at32f435_437_can.h.

Field Documentation

◆ ffdb1

__IO uint32_t can_filter_register_type::ffdb1

Definition at line 579 of file at32f435_437_can.h.

Referenced by can_filter_init().

◆ ffdb2

__IO uint32_t can_filter_register_type::ffdb2

Definition at line 580 of file at32f435_437_can.h.

Referenced by can_filter_init().

The documentation for this struct was generated from the following file:
  • at32f435_437_can.h


AT32F435/437 Firmwary Library: can_type Struct Reference

Data Fields
can_type Struct Reference
AT32F435_437_periph_driver » CAN » CAN_exported_types

type define can register all More...

#include <at32f435_437_can.h>

Data Fields

union {
__IO uint32_t mctrl
struct {
__IO uint32_t fzen: 1
__IO uint32_t dzen: 1
__IO uint32_t mmssr: 1
__IO uint32_t mdrsel: 1
__IO uint32_t prsfen: 1
__IO uint32_t aeden: 1
__IO uint32_t aeboen: 1
__IO uint32_t ttcen: 1
__IO uint32_t reserved1: 7
__IO uint32_t sprst: 1
__IO uint32_t ptd: 1
__IO uint32_t reserved2: 15
} mctrl_bit
};
can mctrl register, offset:0x00 More...
union {
__IO uint32_t msts
struct {
__IO uint32_t fzc: 1
__IO uint32_t dzc: 1
__IO uint32_t eoif: 1
__IO uint32_t qdzif: 1
__IO uint32_t edzif: 1
__IO uint32_t reserved1: 3
__IO uint32_t cuss: 1
__IO uint32_t curs: 1
__IO uint32_t lsamprx: 1
__IO uint32_t realrx: 1
__IO uint32_t reserved2: 20
} msts_bit
};
can msts register, offset:0x04 More...
union {
__IO uint32_t tsts
struct {
__IO uint32_t tm0tcf: 1
__IO uint32_t tm0tsf: 1
__IO uint32_t tm0alf: 1
__IO uint32_t tm0tef: 1
__IO uint32_t reserved1: 3
__IO uint32_t tm0ct: 1
__IO uint32_t tm1tcf: 1
__IO uint32_t tm1tsf: 1
__IO uint32_t tm1alf: 1
__IO uint32_t tm1tef: 1
__IO uint32_t reserved2: 3
__IO uint32_t tm1ct: 1
__IO uint32_t tm2tcf: 1
__IO uint32_t tm2tsf: 1
__IO uint32_t tm2alf: 1
__IO uint32_t tm2tef: 1
__IO uint32_t reserved3: 3
__IO uint32_t tm2ct: 1
__IO uint32_t tmnr: 2
__IO uint32_t tm0ef: 1
__IO uint32_t tm1ef: 1
__IO uint32_t tm2ef: 1
__IO uint32_t tm0lpf: 1
__IO uint32_t tm1lpf: 1
__IO uint32_t tm2lpf: 1
} tsts_bit
};
can tsts register, offset:0x08 More...
union {
__IO uint32_t rf0
struct {
__IO uint32_t rf0mn: 2
__IO uint32_t reserved1: 1
__IO uint32_t rf0ff: 1
__IO uint32_t rf0of: 1
__IO uint32_t rf0r: 1
__IO uint32_t reserved2: 26
} rf0_bit
};
can rf0 register, offset:0x0C More...
union {
__IO uint32_t rf1
struct {
__IO uint32_t rf1mn: 2
__IO uint32_t reserved1: 1
__IO uint32_t rf1ff: 1
__IO uint32_t rf1of: 1
__IO uint32_t rf1r: 1
__IO uint32_t reserved2: 26
} rf1_bit
};
can rf1 register, offset:0x10 More...
union {
__IO uint32_t inten
struct {
__IO uint32_t tcien: 1
__IO uint32_t rf0mien: 1
__IO uint32_t rf0fien: 1
__IO uint32_t rf0oien: 1
__IO uint32_t rf1mien: 1
__IO uint32_t rf1fien: 1
__IO uint32_t rf1oien: 1
__IO uint32_t reserved1: 1
__IO uint32_t eaien: 1
__IO uint32_t epien: 1
__IO uint32_t boien: 1
__IO uint32_t etrien: 1
__IO uint32_t reserved2: 3
__IO uint32_t eoien: 1
__IO uint32_t qdzien: 1
__IO uint32_t edzien: 1
__IO uint32_t reserved3: 14
} inten_bit
};
can inten register, offset:0x14 More...
union {
__IO uint32_t ests
struct {
__IO uint32_t eaf: 1
__IO uint32_t epf: 1
__IO uint32_t bof: 1
__IO uint32_t reserved1: 1
__IO uint32_t etr: 3
__IO uint32_t reserved2: 9
__IO uint32_t tec: 8
__IO uint32_t rec: 8
} ests_bit
};
can ests register, offset:0x18 More...
union {
__IO uint32_t btmg
struct {
__IO uint32_t brdiv: 12
__IO uint32_t reserved1: 4
__IO uint32_t bts1: 4
__IO uint32_t bts2: 3
__IO uint32_t reserved2: 1
__IO uint32_t rsaw: 2
__IO uint32_t reserved3: 4
__IO uint32_t lben: 1
__IO uint32_t loen: 1
} btmg_bit
};
can btmg register, offset:0x1C More...
can_tx_mailbox_type | tx_mailbox [3]
can controller area network tx mailbox register, offset:0x180~0x1AC More...
can_fifo_mailbox_type | fifo_mailbox [2]
can controller area network fifo mailbox register, offset:0x1B0~0x1CC More...
union {
__IO uint32_t fctrl
struct {
__IO uint32_t fcs: 1
__IO uint32_t reserved1: 31
} fctrl_bit
};
can fctrl register, offset:0x200 More...
union {
__IO uint32_t fmcfg
struct {
__IO uint32_t fmsel0: 1
__IO uint32_t fmsel1: 1
__IO uint32_t fmsel2: 1
__IO uint32_t fmsel3: 1
__IO uint32_t fmsel4: 1
__IO uint32_t fmsel5: 1
__IO uint32_t fmsel6: 1
__IO uint32_t fmsel7: 1
__IO uint32_t fmsel8: 1
__IO uint32_t fmsel9: 1
__IO uint32_t fmsel10: 1
__IO uint32_t fmsel11: 1
__IO uint32_t fmsel12: 1
__IO uint32_t fmsel13: 1
__IO uint32_t fmsel14: 1
__IO uint32_t fmsel15: 1
__IO uint32_t fmsel16: 1
__IO uint32_t fmsel17: 1
__IO uint32_t fmsel18: 1
__IO uint32_t fmsel19: 1
__IO uint32_t fmsel20: 1
__IO uint32_t fmsel21: 1
__IO uint32_t fmsel22: 1
__IO uint32_t fmsel23: 1
__IO uint32_t fmsel24: 1
__IO uint32_t fmsel25: 1
__IO uint32_t fmsel26: 1
__IO uint32_t fmsel27: 1
__IO uint32_t reserved1: 4
} fmcfg_bit
};
can fmcfg register, offset:0x204 More...
union {
__IO uint32_t fbwcfg
struct {
__IO uint32_t fbwsel0: 1
__IO uint32_t fbwsel1: 1
__IO uint32_t fbwsel2: 1
__IO uint32_t fbwsel3: 1
__IO uint32_t fbwsel4: 1
__IO uint32_t fbwsel5: 1
__IO uint32_t fbwsel6: 1
__IO uint32_t fbwsel7: 1
__IO uint32_t fbwsel8: 1
__IO uint32_t fbwsel9: 1
__IO uint32_t fbwsel10: 1
__IO uint32_t fbwsel11: 1
__IO uint32_t fbwsel12: 1
__IO uint32_t fbwsel13: 1
__IO uint32_t fbwsel14: 1
__IO uint32_t fbwsel15: 1
__IO uint32_t fbwsel16: 1
__IO uint32_t fbwsel17: 1
__IO uint32_t fbwsel18: 1
__IO uint32_t fbwsel19: 1
__IO uint32_t fbwsel20: 1
__IO uint32_t fbwsel21: 1
__IO uint32_t fbwsel22: 1
__IO uint32_t fbwsel23: 1
__IO uint32_t fbwsel24: 1
__IO uint32_t fbwsel25: 1
__IO uint32_t fbwsel26: 1
__IO uint32_t fbwsel27: 1
__IO uint32_t reserved1: 4
} fbwcfg_bit
};
can fbwcfg register, offset:0x20C More...
__IO uint32_t | reserved4
can reserved register, offset:0x210 More...
union {
__IO uint32_t frf
struct {
__IO uint32_t frfsel0: 1
__IO uint32_t frfsel1: 1
__IO uint32_t frfsel2: 1
__IO uint32_t frfsel3: 1
__IO uint32_t frfsel4: 1
__IO uint32_t frfsel5: 1
__IO uint32_t frfsel6: 1
__IO uint32_t frfsel7: 1
__IO uint32_t frfsel8: 1
__IO uint32_t frfsel9: 1
__IO uint32_t frfsel10: 1
__IO uint32_t frfsel11: 1
__IO uint32_t frfsel12: 1
__IO uint32_t frfsel13: 1
__IO uint32_t frfsel14: 1
__IO uint32_t frfsel15: 1
__IO uint32_t frfsel16: 1
__IO uint32_t frfsel17: 1
__IO uint32_t frfsel18: 1
__IO uint32_t frfsel19: 1
__IO uint32_t frfsel20: 1
__IO uint32_t frfsel21: 1
__IO uint32_t frfsel22: 1
__IO uint32_t frfsel23: 1
__IO uint32_t frfsel24: 1
__IO uint32_t frfsel25: 1
__IO uint32_t frfsel26: 1
__IO uint32_t frfsel27: 1
__IO uint32_t reserved1: 4
} frf_bit
};
can frf register, offset:0x214 More...
__IO uint32_t | reserved5
can reserved register, offset:0x218 More...
union {
__IO uint32_t facfg
struct {
__IO uint32_t faen0: 1
__IO uint32_t faen1: 1
__IO uint32_t faen2: 1
__IO uint32_t faen3: 1
__IO uint32_t faen4: 1
__IO uint32_t faen5: 1
__IO uint32_t faen6: 1
__IO uint32_t faen7: 1
__IO uint32_t faen8: 1
__IO uint32_t faen9: 1
__IO uint32_t faen10: 1
__IO uint32_t faen11: 1
__IO uint32_t faen12: 1
__IO uint32_t faen13: 1
__IO uint32_t faen14: 1
__IO uint32_t faen15: 1
__IO uint32_t faen16: 1
__IO uint32_t faen17: 1
__IO uint32_t faen18: 1
__IO uint32_t faen19: 1
__IO uint32_t faen20: 1
__IO uint32_t faen21: 1
__IO uint32_t faen22: 1
__IO uint32_t faen23: 1
__IO uint32_t faen24: 1
__IO uint32_t faen25: 1
__IO uint32_t faen26: 1
__IO uint32_t faen27: 1
__IO uint32_t reserved1: 4
} facfg_bit
};
can facfg register, offset:0x21C More...
__IO uint32_t | reserved6 [8]
can reserved register, offset:0x220~0x23C More...
can_filter_register_type | ffb [28]
can ffb register, offset:0x240~0x2AC More...

Detailed Description

type define can register all

Definition at line 586 of file at32f435_437_can.h.

Field Documentation

◆

union { ... } can_type::@118

can mctrl register, offset:0x00

◆

union { ... } can_type::@120

can msts register, offset:0x04

◆

union { ... } can_type::@122

can tsts register, offset:0x08

◆

union { ... } can_type::@124

can rf0 register, offset:0x0C

◆

union { ... } can_type::@126

can rf1 register, offset:0x10

◆

union { ... } can_type::@128

can inten register, offset:0x14

◆

union { ... } can_type::@130

can ests register, offset:0x18

◆

union { ... } can_type::@132

can btmg register, offset:0x1C

◆

union { ... } can_type::@134

can fctrl register, offset:0x200

◆

union { ... } can_type::@136

can fmcfg register, offset:0x204

◆

union { ... } can_type::@138

can fbwcfg register, offset:0x20C

◆

union { ... } can_type::@140

can frf register, offset:0x214

◆

union { ... } can_type::@142

can facfg register, offset:0x21C

◆ aeboen

__IO uint32_t can_type::aeboen

Definition at line 603 of file at32f435_437_can.h.

Referenced by can_base_init().

◆ aeden

__IO uint32_t can_type::aeden

Definition at line 602 of file at32f435_437_can.h.

Referenced by can_base_init().

◆ bof

__IO uint32_t can_type::bof

Definition at line 742 of file at32f435_437_can.h.

Referenced by can_flag_get().

◆ boien

__IO uint32_t can_type::boien

Definition at line 722 of file at32f435_437_can.h.

◆ brdiv

__IO uint32_t can_type::brdiv

Definition at line 759 of file at32f435_437_can.h.

Referenced by can_baudrate_set().

◆ btmg

__IO uint32_t can_type::btmg

Definition at line 756 of file at32f435_437_can.h.

◆

struct { ... } can_type::btmg_bit

Referenced by can_base_init(), and can_baudrate_set().

◆ bts1

__IO uint32_t can_type::bts1

Definition at line 761 of file at32f435_437_can.h.

Referenced by can_baudrate_set().

◆ bts2

__IO uint32_t can_type::bts2

Definition at line 762 of file at32f435_437_can.h.

Referenced by can_baudrate_set().

◆ curs

__IO uint32_t can_type::curs

Definition at line 627 of file at32f435_437_can.h.

◆ cuss

__IO uint32_t can_type::cuss

Definition at line 626 of file at32f435_437_can.h.

◆ dzc

__IO uint32_t can_type::dzc

Definition at line 621 of file at32f435_437_can.h.

Referenced by can_doze_mode_enter(), can_doze_mode_exit(), can_flag_get(), and can_operating_mode_set().

◆ dzen

__IO uint32_t can_type::dzen

Definition at line 598 of file at32f435_437_can.h.

Referenced by can_base_init(), can_baudrate_set(), can_doze_mode_enter(), can_doze_mode_exit(), and can_operating_mode_set().

◆ eaf

__IO uint32_t can_type::eaf

Definition at line 740 of file at32f435_437_can.h.

Referenced by can_flag_get().

◆ eaien

__IO uint32_t can_type::eaien

Definition at line 720 of file at32f435_437_can.h.

◆ edzien

__IO uint32_t can_type::edzien

Definition at line 727 of file at32f435_437_can.h.

◆ edzif

__IO uint32_t can_type::edzif

Definition at line 624 of file at32f435_437_can.h.

Referenced by can_flag_get().

◆ eoien

__IO uint32_t can_type::eoien

Definition at line 725 of file at32f435_437_can.h.

◆ eoif

__IO uint32_t can_type::eoif

Definition at line 622 of file at32f435_437_can.h.

Referenced by can_flag_get().

◆ epf

__IO uint32_t can_type::epf

Definition at line 741 of file at32f435_437_can.h.

Referenced by can_flag_get().

◆ epien

__IO uint32_t can_type::epien

Definition at line 721 of file at32f435_437_can.h.

◆ ests

__IO uint32_t can_type::ests

Definition at line 737 of file at32f435_437_can.h.

Referenced by can_flag_clear().

◆

struct { ... } can_type::ests_bit

Referenced by can_error_type_record_get(), can_flag_get(), can_receive_error_counter_get(), and can_transmit_error_counter_get().

◆ etr

__IO uint32_t can_type::etr

Definition at line 744 of file at32f435_437_can.h.

Referenced by can_error_type_record_get(), and can_flag_get().

◆ etrien

__IO uint32_t can_type::etrien

Definition at line 723 of file at32f435_437_can.h.

◆ facfg

__IO uint32_t can_type::facfg

Definition at line 944 of file at32f435_437_can.h.

Referenced by can_filter_init().

◆

struct { ... } can_type::facfg_bit

◆ faen0

__IO uint32_t can_type::faen0

Definition at line 947 of file at32f435_437_can.h.

◆ faen1

__IO uint32_t can_type::faen1

Definition at line 948 of file at32f435_437_can.h.

◆ faen10

__IO uint32_t can_type::faen10

Definition at line 957 of file at32f435_437_can.h.

◆ faen11

__IO uint32_t can_type::faen11

Definition at line 958 of file at32f435_437_can.h.

◆ faen12

__IO uint32_t can_type::faen12

Definition at line 959 of file at32f435_437_can.h.

◆ faen13

__IO uint32_t can_type::faen13

Definition at line 960 of file at32f435_437_can.h.

◆ faen14

__IO uint32_t can_type::faen14

Definition at line 961 of file at32f435_437_can.h.

◆ faen15

__IO uint32_t can_type::faen15

Definition at line 962 of file at32f435_437_can.h.

◆ faen16

__IO uint32_t can_type::faen16

Definition at line 963 of file at32f435_437_can.h.

◆ faen17

__IO uint32_t can_type::faen17

Definition at line 964 of file at32f435_437_can.h.

◆ faen18

__IO uint32_t can_type::faen18

Definition at line 965 of file at32f435_437_can.h.

◆ faen19

__IO uint32_t can_type::faen19

Definition at line 966 of file at32f435_437_can.h.

◆ faen2

__IO uint32_t can_type::faen2

Definition at line 949 of file at32f435_437_can.h.

◆ faen20

__IO uint32_t can_type::faen20

Definition at line 967 of file at32f435_437_can.h.

◆ faen21

__IO uint32_t can_type::faen21

Definition at line 968 of file at32f435_437_can.h.

◆ faen22

__IO uint32_t can_type::faen22

Definition at line 969 of file at32f435_437_can.h.

◆ faen23

__IO uint32_t can_type::faen23

Definition at line 970 of file at32f435_437_can.h.

◆ faen24

__IO uint32_t can_type::faen24

Definition at line 971 of file at32f435_437_can.h.

◆ faen25

__IO uint32_t can_type::faen25

Definition at line 972 of file at32f435_437_can.h.

◆ faen26

__IO uint32_t can_type::faen26

Definition at line 973 of file at32f435_437_can.h.

◆ faen27

__IO uint32_t can_type::faen27

Definition at line 974 of file at32f435_437_can.h.

◆ faen3

__IO uint32_t can_type::faen3

Definition at line 950 of file at32f435_437_can.h.

◆ faen4

__IO uint32_t can_type::faen4

Definition at line 951 of file at32f435_437_can.h.

◆ faen5

__IO uint32_t can_type::faen5

Definition at line 952 of file at32f435_437_can.h.

◆ faen6

__IO uint32_t can_type::faen6

Definition at line 953 of file at32f435_437_can.h.

◆ faen7

__IO uint32_t can_type::faen7

Definition at line 954 of file at32f435_437_can.h.

◆ faen8

__IO uint32_t can_type::faen8

Definition at line 955 of file at32f435_437_can.h.

◆ faen9

__IO uint32_t can_type::faen9

Definition at line 956 of file at32f435_437_can.h.

◆ fbwcfg

__IO uint32_t can_type::fbwcfg

Definition at line 854 of file at32f435_437_can.h.

Referenced by can_filter_init().

◆

struct { ... } can_type::fbwcfg_bit

◆ fbwsel0

__IO uint32_t can_type::fbwsel0

Definition at line 857 of file at32f435_437_can.h.

◆ fbwsel1

__IO uint32_t can_type::fbwsel1

Definition at line 858 of file at32f435_437_can.h.

◆ fbwsel10

__IO uint32_t can_type::fbwsel10

Definition at line 867 of file at32f435_437_can.h.

◆ fbwsel11

__IO uint32_t can_type::fbwsel11

Definition at line 868 of file at32f435_437_can.h.

◆ fbwsel12

__IO uint32_t can_type::fbwsel12

Definition at line 869 of file at32f435_437_can.h.

◆ fbwsel13

__IO uint32_t can_type::fbwsel13

Definition at line 870 of file at32f435_437_can.h.

◆ fbwsel14

__IO uint32_t can_type::fbwsel14

Definition at line 871 of file at32f435_437_can.h.

◆ fbwsel15

__IO uint32_t can_type::fbwsel15

Definition at line 872 of file at32f435_437_can.h.

◆ fbwsel16

__IO uint32_t can_type::fbwsel16

Definition at line 873 of file at32f435_437_can.h.

◆ fbwsel17

__IO uint32_t can_type::fbwsel17

Definition at line 874 of file at32f435_437_can.h.

◆ fbwsel18

__IO uint32_t can_type::fbwsel18

Definition at line 875 of file at32f435_437_can.h.

◆ fbwsel19

__IO uint32_t can_type::fbwsel19

Definition at line 876 of file at32f435_437_can.h.

◆ fbwsel2

__IO uint32_t can_type::fbwsel2

Definition at line 859 of file at32f435_437_can.h.

◆ fbwsel20

__IO uint32_t can_type::fbwsel20

Definition at line 877 of file at32f435_437_can.h.

◆ fbwsel21

__IO uint32_t can_type::fbwsel21

Definition at line 878 of file at32f435_437_can.h.

◆ fbwsel22

__IO uint32_t can_type::fbwsel22

Definition at line 879 of file at32f435_437_can.h.

◆ fbwsel23

__IO uint32_t can_type::fbwsel23

Definition at line 880 of file at32f435_437_can.h.

◆ fbwsel24

__IO uint32_t can_type::fbwsel24

Definition at line 881 of file at32f435_437_can.h.

◆ fbwsel25

__IO uint32_t can_type::fbwsel25

Definition at line 882 of file at32f435_437_can.h.

◆ fbwsel26

__IO uint32_t can_type::fbwsel26

Definition at line 883 of file at32f435_437_can.h.

◆ fbwsel27

__IO uint32_t can_type::fbwsel27

Definition at line 884 of file at32f435_437_can.h.

◆ fbwsel3

__IO uint32_t can_type::fbwsel3

Definition at line 860 of file at32f435_437_can.h.

◆ fbwsel4

__IO uint32_t can_type::fbwsel4

Definition at line 861 of file at32f435_437_can.h.

◆ fbwsel5

__IO uint32_t can_type::fbwsel5

Definition at line 862 of file at32f435_437_can.h.

◆ fbwsel6

__IO uint32_t can_type::fbwsel6

Definition at line 863 of file at32f435_437_can.h.

◆ fbwsel7

__IO uint32_t can_type::fbwsel7

Definition at line 864 of file at32f435_437_can.h.

◆ fbwsel8

__IO uint32_t can_type::fbwsel8

Definition at line 865 of file at32f435_437_can.h.

◆ fbwsel9

__IO uint32_t can_type::fbwsel9

Definition at line 866 of file at32f435_437_can.h.

◆ fcs

__IO uint32_t can_type::fcs

Definition at line 799 of file at32f435_437_can.h.

Referenced by can_filter_init().

◆ fctrl

__IO uint32_t can_type::fctrl

Definition at line 796 of file at32f435_437_can.h.

◆

struct { ... } can_type::fctrl_bit

Referenced by can_filter_init().

◆ ffb

can_filter_register_type can_type::ffb[28]

can ffb register, offset:0x240~0x2AC

Definition at line 987 of file at32f435_437_can.h.

Referenced by can_filter_init().

◆ fifo_mailbox

can_fifo_mailbox_type can_type::fifo_mailbox[2]

can controller area network fifo mailbox register, offset:0x1B0~0x1CC

Definition at line 784 of file at32f435_437_can.h.

Referenced by can_message_receive().

◆ fmcfg

__IO uint32_t can_type::fmcfg

Definition at line 809 of file at32f435_437_can.h.

Referenced by can_filter_init().

◆

struct { ... } can_type::fmcfg_bit

◆ fmsel0

__IO uint32_t can_type::fmsel0

Definition at line 812 of file at32f435_437_can.h.

◆ fmsel1

__IO uint32_t can_type::fmsel1

Definition at line 813 of file at32f435_437_can.h.

◆ fmsel10

__IO uint32_t can_type::fmsel10

Definition at line 822 of file at32f435_437_can.h.

◆ fmsel11

__IO uint32_t can_type::fmsel11

Definition at line 823 of file at32f435_437_can.h.

◆ fmsel12

__IO uint32_t can_type::fmsel12

Definition at line 824 of file at32f435_437_can.h.

◆ fmsel13

__IO uint32_t can_type::fmsel13

Definition at line 825 of file at32f435_437_can.h.

◆ fmsel14

__IO uint32_t can_type::fmsel14

Definition at line 826 of file at32f435_437_can.h.

◆ fmsel15

__IO uint32_t can_type::fmsel15

Definition at line 827 of file at32f435_437_can.h.

◆ fmsel16

__IO uint32_t can_type::fmsel16

Definition at line 828 of file at32f435_437_can.h.

◆ fmsel17

__IO uint32_t can_type::fmsel17

Definition at line 829 of file at32f435_437_can.h.

◆ fmsel18

__IO uint32_t can_type::fmsel18

Definition at line 830 of file at32f435_437_can.h.

◆ fmsel19

__IO uint32_t can_type::fmsel19

Definition at line 831 of file at32f435_437_can.h.

◆ fmsel2

__IO uint32_t can_type::fmsel2

Definition at line 814 of file at32f435_437_can.h.

◆ fmsel20

__IO uint32_t can_type::fmsel20

Definition at line 832 of file at32f435_437_can.h.

◆ fmsel21

__IO uint32_t can_type::fmsel21

Definition at line 833 of file at32f435_437_can.h.

◆ fmsel22

__IO uint32_t can_type::fmsel22

Definition at line 834 of file at32f435_437_can.h.

◆ fmsel23

__IO uint32_t can_type::fmsel23

Definition at line 835 of file at32f435_437_can.h.

◆ fmsel24

__IO uint32_t can_type::fmsel24

Definition at line 836 of file at32f435_437_can.h.

◆ fmsel25

__IO uint32_t can_type::fmsel25

Definition at line 837 of file at32f435_437_can.h.

◆ fmsel26

__IO uint32_t can_type::fmsel26

Definition at line 838 of file at32f435_437_can.h.

◆ fmsel27

__IO uint32_t can_type::fmsel27

Definition at line 839 of file at32f435_437_can.h.

◆ fmsel3

__IO uint32_t can_type::fmsel3

Definition at line 815 of file at32f435_437_can.h.

◆ fmsel4

__IO uint32_t can_type::fmsel4

Definition at line 816 of file at32f435_437_can.h.

◆ fmsel5

__IO uint32_t can_type::fmsel5

Definition at line 817 of file at32f435_437_can.h.

◆ fmsel6

__IO uint32_t can_type::fmsel6

Definition at line 818 of file at32f435_437_can.h.

◆ fmsel7

__IO uint32_t can_type::fmsel7

Definition at line 819 of file at32f435_437_can.h.

◆ fmsel8

__IO uint32_t can_type::fmsel8

Definition at line 820 of file at32f435_437_can.h.

◆ fmsel9

__IO uint32_t can_type::fmsel9

Definition at line 821 of file at32f435_437_can.h.

◆ frf

__IO uint32_t can_type::frf

Definition at line 899 of file at32f435_437_can.h.

Referenced by can_filter_init().

◆

struct { ... } can_type::frf_bit

◆ frfsel0

__IO uint32_t can_type::frfsel0

Definition at line 902 of file at32f435_437_can.h.

◆ frfsel1

__IO uint32_t can_type::frfsel1

Definition at line 903 of file at32f435_437_can.h.

◆ frfsel10

__IO uint32_t can_type::frfsel10

Definition at line 912 of file at32f435_437_can.h.

◆ frfsel11

__IO uint32_t can_type::frfsel11

Definition at line 913 of file at32f435_437_can.h.

◆ frfsel12

__IO uint32_t can_type::frfsel12

Definition at line 914 of file at32f435_437_can.h.

◆ frfsel13

__IO uint32_t can_type::frfsel13

Definition at line 915 of file at32f435_437_can.h.

◆ frfsel14

__IO uint32_t can_type::frfsel14

Definition at line 916 of file at32f435_437_can.h.

◆ frfsel15

__IO uint32_t can_type::frfsel15

Definition at line 917 of file at32f435_437_can.h.

◆ frfsel16

__IO uint32_t can_type::frfsel16

Definition at line 918 of file at32f435_437_can.h.

◆ frfsel17

__IO uint32_t can_type::frfsel17

Definition at line 919 of file at32f435_437_can.h.

◆ frfsel18

__IO uint32_t can_type::frfsel18

Definition at line 920 of file at32f435_437_can.h.

◆ frfsel19

__IO uint32_t can_type::frfsel19

Definition at line 921 of file at32f435_437_can.h.

◆ frfsel2

__IO uint32_t can_type::frfsel2

Definition at line 904 of file at32f435_437_can.h.

◆ frfsel20

__IO uint32_t can_type::frfsel20

Definition at line 922 of file at32f435_437_can.h.

◆ frfsel21

__IO uint32_t can_type::frfsel21

Definition at line 923 of file at32f435_437_can.h.

◆ frfsel22

__IO uint32_t can_type::frfsel22

Definition at line 924 of file at32f435_437_can.h.

◆ frfsel23

__IO uint32_t can_type::frfsel23

Definition at line 925 of file at32f435_437_can.h.

◆ frfsel24

__IO uint32_t can_type::frfsel24

Definition at line 926 of file at32f435_437_can.h.

◆ frfsel25

__IO uint32_t can_type::frfsel25

Definition at line 927 of file at32f435_437_can.h.

◆ frfsel26

__IO uint32_t can_type::frfsel26

Definition at line 928 of file at32f435_437_can.h.

◆ frfsel27

__IO uint32_t can_type::frfsel27

Definition at line 929 of file at32f435_437_can.h.

◆ frfsel3

__IO uint32_t can_type::frfsel3

Definition at line 905 of file at32f435_437_can.h.

◆ frfsel4

__IO uint32_t can_type::frfsel4

Definition at line 906 of file at32f435_437_can.h.

◆ frfsel5

__IO uint32_t can_type::frfsel5

Definition at line 907 of file at32f435_437_can.h.

◆ frfsel6

__IO uint32_t can_type::frfsel6

Definition at line 908 of file at32f435_437_can.h.

◆ frfsel7

__IO uint32_t can_type::frfsel7

Definition at line 909 of file at32f435_437_can.h.

◆ frfsel8

__IO uint32_t can_type::frfsel8

Definition at line 910 of file at32f435_437_can.h.

◆ frfsel9

__IO uint32_t can_type::frfsel9

Definition at line 911 of file at32f435_437_can.h.

◆ fzc

__IO uint32_t can_type::fzc

Definition at line 620 of file at32f435_437_can.h.

Referenced by can_base_init(), can_baudrate_set(), can_doze_mode_enter(), and can_operating_mode_set().

◆ fzen

__IO uint32_t can_type::fzen

Definition at line 597 of file at32f435_437_can.h.

Referenced by can_base_init(), can_baudrate_set(), can_doze_mode_enter(), and can_operating_mode_set().

◆ inten

__IO uint32_t can_type::inten

Definition at line 709 of file at32f435_437_can.h.

Referenced by can_interrupt_enable().

◆

struct { ... } can_type::inten_bit

◆ lben

__IO uint32_t can_type::lben

Definition at line 766 of file at32f435_437_can.h.

Referenced by can_base_init().

◆ loen

__IO uint32_t can_type::loen

Definition at line 767 of file at32f435_437_can.h.

Referenced by can_base_init().

◆ lsamprx

__IO uint32_t can_type::lsamprx

Definition at line 628 of file at32f435_437_can.h.

◆ mctrl

__IO uint32_t can_type::mctrl

Definition at line 594 of file at32f435_437_can.h.

◆

struct { ... } can_type::mctrl_bit

Referenced by can_base_init(), can_baudrate_set(), can_debug_transmission_prohibit(), can_doze_mode_enter(), can_doze_mode_exit(), can_operating_mode_set(), and can_ttc_mode_enable().

◆ mdrsel

__IO uint32_t can_type::mdrsel

Definition at line 600 of file at32f435_437_can.h.

Referenced by can_base_init().

◆ mmssr

__IO uint32_t can_type::mmssr

Definition at line 599 of file at32f435_437_can.h.

Referenced by can_base_init().

◆ msts

__IO uint32_t can_type::msts

Definition at line 617 of file at32f435_437_can.h.

Referenced by can_flag_clear().

◆

struct { ... } can_type::msts_bit

Referenced by can_base_init(), can_baudrate_set(), can_doze_mode_enter(), can_doze_mode_exit(), can_flag_get(), and can_operating_mode_set().

◆ prsfen

__IO uint32_t can_type::prsfen

Definition at line 601 of file at32f435_437_can.h.

Referenced by can_base_init().

◆ ptd

__IO uint32_t can_type::ptd

Definition at line 607 of file at32f435_437_can.h.

Referenced by can_debug_transmission_prohibit().

◆ qdzien

__IO uint32_t can_type::qdzien

Definition at line 726 of file at32f435_437_can.h.

◆ qdzif

__IO uint32_t can_type::qdzif

Definition at line 623 of file at32f435_437_can.h.

Referenced by can_flag_get().

◆ realrx

__IO uint32_t can_type::realrx

Definition at line 629 of file at32f435_437_can.h.

◆ rec

__IO uint32_t can_type::rec

Definition at line 747 of file at32f435_437_can.h.

Referenced by can_receive_error_counter_get().

◆ reserved1

__IO uint32_t can_type::reserved1

can reserved register, offset:0x20~0x17C

Definition at line 605 of file at32f435_437_can.h.

◆ reserved2

__IO uint32_t can_type::reserved2

can reserved register, offset:0x1D0~0x1FC

Definition at line 608 of file at32f435_437_can.h.

◆ reserved3

__IO uint32_t can_type::reserved3

can reserved register, offset:0x208

Definition at line 658 of file at32f435_437_can.h.

◆ reserved4

__IO uint32_t can_type::reserved4

can reserved register, offset:0x210

Definition at line 892 of file at32f435_437_can.h.

◆ reserved5

__IO uint32_t can_type::reserved5

can reserved register, offset:0x218

Definition at line 937 of file at32f435_437_can.h.

◆ reserved6

__IO uint32_t can_type::reserved6[8]

can reserved register, offset:0x220~0x23C

Definition at line 982 of file at32f435_437_can.h.

◆ rf0

__IO uint32_t can_type::rf0

Definition at line 675 of file at32f435_437_can.h.

Referenced by can_flag_clear(), and can_receive_fifo_release().

◆

struct { ... } can_type::rf0_bit

Referenced by can_flag_get(), and can_receive_message_pending_get().

◆ rf0ff

__IO uint32_t can_type::rf0ff

Definition at line 680 of file at32f435_437_can.h.

Referenced by can_flag_get().

◆ rf0fien

__IO uint32_t can_type::rf0fien

Definition at line 714 of file at32f435_437_can.h.

◆ rf0mien

__IO uint32_t can_type::rf0mien

Definition at line 713 of file at32f435_437_can.h.

◆ rf0mn

__IO uint32_t can_type::rf0mn

Definition at line 678 of file at32f435_437_can.h.

Referenced by can_flag_get(), and can_receive_message_pending_get().

◆ rf0of

__IO uint32_t can_type::rf0of

Definition at line 681 of file at32f435_437_can.h.

Referenced by can_flag_get().

◆ rf0oien

__IO uint32_t can_type::rf0oien

Definition at line 715 of file at32f435_437_can.h.

◆ rf0r

__IO uint32_t can_type::rf0r

Definition at line 682 of file at32f435_437_can.h.

◆ rf1

__IO uint32_t can_type::rf1

Definition at line 692 of file at32f435_437_can.h.

Referenced by can_flag_clear(), and can_receive_fifo_release().

◆

struct { ... } can_type::rf1_bit

Referenced by can_flag_get(), and can_receive_message_pending_get().

◆ rf1ff

__IO uint32_t can_type::rf1ff

Definition at line 697 of file at32f435_437_can.h.

Referenced by can_flag_get().

◆ rf1fien

__IO uint32_t can_type::rf1fien

Definition at line 717 of file at32f435_437_can.h.

◆ rf1mien

__IO uint32_t can_type::rf1mien

Definition at line 716 of file at32f435_437_can.h.

◆ rf1mn

__IO uint32_t can_type::rf1mn

Definition at line 695 of file at32f435_437_can.h.

Referenced by can_flag_get(), and can_receive_message_pending_get().

◆ rf1of

__IO uint32_t can_type::rf1of

Definition at line 698 of file at32f435_437_can.h.

Referenced by can_flag_get().

◆ rf1oien

__IO uint32_t can_type::rf1oien

Definition at line 718 of file at32f435_437_can.h.

◆ rf1r

__IO uint32_t can_type::rf1r

Definition at line 699 of file at32f435_437_can.h.

◆ rsaw

__IO uint32_t can_type::rsaw

Definition at line 764 of file at32f435_437_can.h.

Referenced by can_baudrate_set().

◆ sprst

__IO uint32_t can_type::sprst

Definition at line 606 of file at32f435_437_can.h.

◆ tcien

__IO uint32_t can_type::tcien

Definition at line 712 of file at32f435_437_can.h.

◆ tec

__IO uint32_t can_type::tec

Definition at line 746 of file at32f435_437_can.h.

Referenced by can_transmit_error_counter_get().

◆ tm0alf

__IO uint32_t can_type::tm0alf

Definition at line 644 of file at32f435_437_can.h.

◆ tm0ct

__IO uint32_t can_type::tm0ct

Definition at line 647 of file at32f435_437_can.h.

◆ tm0ef

__IO uint32_t can_type::tm0ef

Definition at line 661 of file at32f435_437_can.h.

Referenced by can_flag_get(), and can_message_transmit().

◆ tm0lpf

__IO uint32_t can_type::tm0lpf

Definition at line 664 of file at32f435_437_can.h.

◆ tm0tcf

__IO uint32_t can_type::tm0tcf

Definition at line 642 of file at32f435_437_can.h.

Referenced by can_flag_get(), and can_transmit_status_get().

◆ tm0tef

__IO uint32_t can_type::tm0tef

Definition at line 645 of file at32f435_437_can.h.

◆ tm0tsf

__IO uint32_t can_type::tm0tsf

Definition at line 643 of file at32f435_437_can.h.

Referenced by can_transmit_status_get().

◆ tm1alf

__IO uint32_t can_type::tm1alf

Definition at line 650 of file at32f435_437_can.h.

◆ tm1ct

__IO uint32_t can_type::tm1ct

Definition at line 653 of file at32f435_437_can.h.

◆ tm1ef

__IO uint32_t can_type::tm1ef

Definition at line 662 of file at32f435_437_can.h.

Referenced by can_flag_get(), and can_message_transmit().

◆ tm1lpf

__IO uint32_t can_type::tm1lpf

Definition at line 665 of file at32f435_437_can.h.

◆ tm1tcf

__IO uint32_t can_type::tm1tcf

Definition at line 648 of file at32f435_437_can.h.

Referenced by can_flag_get(), and can_transmit_status_get().

◆ tm1tef

__IO uint32_t can_type::tm1tef

Definition at line 651 of file at32f435_437_can.h.

◆ tm1tsf

__IO uint32_t can_type::tm1tsf

Definition at line 649 of file at32f435_437_can.h.

Referenced by can_transmit_status_get().

◆ tm2alf

__IO uint32_t can_type::tm2alf

Definition at line 656 of file at32f435_437_can.h.

◆ tm2ct

__IO uint32_t can_type::tm2ct

Definition at line 659 of file at32f435_437_can.h.

◆ tm2ef

__IO uint32_t can_type::tm2ef

Definition at line 663 of file at32f435_437_can.h.

Referenced by can_flag_get(), and can_message_transmit().

◆ tm2lpf

__IO uint32_t can_type::tm2lpf

Definition at line 666 of file at32f435_437_can.h.

◆ tm2tcf

__IO uint32_t can_type::tm2tcf

Definition at line 654 of file at32f435_437_can.h.

Referenced by can_flag_get(), and can_transmit_status_get().

◆ tm2tef

__IO uint32_t can_type::tm2tef

Definition at line 657 of file at32f435_437_can.h.

◆ tm2tsf

__IO uint32_t can_type::tm2tsf

Definition at line 655 of file at32f435_437_can.h.

Referenced by can_transmit_status_get().

◆ tmnr

__IO uint32_t can_type::tmnr

Definition at line 660 of file at32f435_437_can.h.

◆ tsts

__IO uint32_t can_type::tsts

Definition at line 639 of file at32f435_437_can.h.

Referenced by can_flag_clear(), and can_transmit_cancel().

◆

struct { ... } can_type::tsts_bit

Referenced by can_flag_get(), can_message_transmit(), and can_transmit_status_get().

◆ ttcen

__IO uint32_t can_type::ttcen

Definition at line 604 of file at32f435_437_can.h.

Referenced by can_base_init(), and can_ttc_mode_enable().

◆ tx_mailbox

can_tx_mailbox_type can_type::tx_mailbox[3]

can controller area network tx mailbox register, offset:0x180~0x1AC

Definition at line 779 of file at32f435_437_can.h.

Referenced by can_message_transmit(), and can_ttc_mode_enable().

The documentation for this struct was generated from the following file:
  • at32f435_437_can.h


AT32F435/437 Firmwary Library: CAN_exported_functions

Functions
CAN_exported_functions
AT32F435_437_periph_driver » CAN

Functions

void | can_reset (can_type *can_x)
deinitialize the can peripheral registers to their default reset values. More...
void | can_baudrate_default_para_init (can_baudrate_type *can_baudrate_struct)
fill each can_baudrate_struct member with its default value. More...
error_status | can_baudrate_set (can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral More...
void | can_default_para_init (can_base_type *can_base_struct)
fill each can_init_struct member with its default value. More...
error_status | can_base_init (can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct. More...
void | can_filter_default_para_init (can_filter_init_type *can_filter_init_struct)
fill each can_filter_init_struct member with its default value. More...
void | can_filter_init (can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct. More...
void | can_debug_transmission_prohibit (can_type *can_x, confirm_state new_state)
enable or disable the debug transmission prohibit of the specified can peripheral. More...
void | can_ttc_mode_enable (can_type *can_x, confirm_state new_state)
enable or disable time trigger operation communication mode of the specified can peripheral. More...
uint8_t | can_message_transmit (can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral. More...
can_transmit_status_type | can_transmit_status_get (can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral. More...
void | can_transmit_cancel (can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
cancel a transmit request of the specified can peripheral. More...
void | can_message_receive (can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral. More...
void | can_receive_fifo_release (can_type *can_x, can_rx_fifo_num_type fifo_number)
release the specified fifo of the specified can peripheral. More...
uint8_t | can_receive_message_pending_get (can_type *can_x, can_rx_fifo_num_type fifo_number)
return the number of pending messages of the specified can peripheral. More...
error_status | can_operating_mode_set (can_type *can_x, can_operating_mode_type can_operating_mode)
set the operation mode of the specified can peripheral. More...
can_enter_doze_status_type | can_doze_mode_enter (can_type *can_x)
enter the low power mode of the specified can peripheral. More...
can_quit_doze_status_type | can_doze_mode_exit (can_type *can_x)
exit the doze mode of the specified can peripheral. More...
can_error_record_type | can_error_type_record_get (can_type *can_x)
return the error type record (etr) of the specified can peripheral. More...
uint8_t | can_receive_error_counter_get (can_type *can_x)
return the receive error counter (rec) of the specified can peripheral. More...
uint8_t | can_transmit_error_counter_get (can_type *can_x)
return the transmit error counter of the specified can peripheral. More...
void | can_interrupt_enable (can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral. More...
flag_status | can_flag_get (can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral. More...
void | can_flag_clear (can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral. More...

Detailed Description

Function Documentation

◆ can_base_init()

error_status can_base_init | ( | can_type * | can_x,
 |  | can_base_type * | can_base_struct
 | ) |  |

initialize the can peripheral according to the specified parameters in the can_init_struct.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_base_struct | pointer to a can_base_struct structure that contains the configuration information for the can peripheral.
Return values
the status of initialization this parameter can be one of the following values: SUCCESS or ERROR

< time out for fzc bit

< time out for fzc bit

Definition at line 194 of file at32f435_437_can.c.

Referenced by can_configuration().

◆ can_baudrate_default_para_init()

void can_baudrate_default_para_init ( can_baudrate_type * can_baudrate_struct )

fill each can_baudrate_struct member with its default value.

Parameters
can_baudrate_struct pointer to a can_baudrate_type structure which will be initialized.
Return values
none.

Definition at line 70 of file at32f435_437_can.c.

◆ can_baudrate_set()

error_status can_baudrate_set | ( | can_type * | can_x,
 |  | can_baudrate_type * | can_baudrate_struct
 | ) |  |

set the baudrate of the can peripheral

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_baudrate_struct | pointer to a can_baudrate_type structure which will be set.
Note
baudrate calculate method is: baudrate = fpclk/(baudrate_div *(3 + bts1_size + bts2_size))
Return values
the result of baudrate set this parameter can be one of the following values: SUCCESS or ERROR

< time out for fzc bit

< time out for fzc bit

Definition at line 99 of file at32f435_437_can.c.

Referenced by can_configuration().

◆ can_debug_transmission_prohibit()

void can_debug_transmission_prohibit | ( | can_type * | can_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the debug transmission prohibit of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
new_state | new state of debug transmission prohibit. this parameter can be: TRUE or FALSE.
Return values
none.

Definition at line 395 of file at32f435_437_can.c.

◆ can_default_para_init()

void can_default_para_init ( can_base_type * can_base_struct )

fill each can_init_struct member with its default value.

Parameters
can_base_struct pointer to a can_base_type structure which will be initialized.
Return values
none.

Definition at line 157 of file at32f435_437_can.c.

Referenced by can_configuration().

◆ can_doze_mode_enter()

can_enter_doze_status_type can_doze_mode_enter ( can_type * can_x )

enter the low power mode of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
status of doze mode enter, the returned value can be:
  • CAN_ENTER_DOZE_SUCCESSFUL <it meaning enter the doze mode succeed>
  • CAN_ENTER_DOZE_FAILED <it meaning enter the doze mode failed>

< time out for fzc bit

Definition at line 801 of file at32f435_437_can.c.

◆ can_doze_mode_exit()

can_quit_doze_status_type can_doze_mode_exit ( can_type * can_x )

exit the doze mode of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
status of doze mode enter, the returned value can be:
  • CAN_QUIT_DOZE_SUCCESSFUL <it meaning exit the doze mode succeed>
  • CAN_QUIT_DOZE_FAILED <it meaning exit the doze mode failed>

< time out for dzc bit

Definition at line 831 of file at32f435_437_can.c.

◆ can_error_type_record_get()

can_error_record_type can_error_type_record_get ( can_type * can_x )

return the error type record (etr) of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
the value of the error code the return can be one of the follow values:
  • CAN_ERRORRECORD_NOERR
  • CAN_ERRORRECORD_STUFFERR,
  • CAN_ERRORRECORD_FORMERR,
  • CAN_ERRORRECORD_ACKERR,
  • CAN_ERRORRECORD_BITRECESSIVEERR,
  • CAN_ERRORRECORD_BITDOMINANTERR,
  • CAN_ERRORRECORD_CRCERR,
  • CAN_ERRORRECORD_SOFTWARESETERR

Definition at line 863 of file at32f435_437_can.c.

◆ can_filter_default_para_init()

void can_filter_default_para_init ( can_filter_init_type * can_filter_init_struct )

fill each can_filter_init_struct member with its default value.

Parameters
can_filter_init_struct pointer to a can_filter_init_type structure which will be initialized.
Return values
none.

Definition at line 269 of file at32f435_437_can.c.

◆ can_filter_init()

void can_filter_init | ( | can_type * | can_x,
 |  | can_filter_init_type * | can_filter_init_struct
 | ) |  |

initialize the can peripheral according to the specified parameters in the can_filter_init_struct.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_filter_init_struct | pointer to a can_filter_init_type structure that contains the configuration information.
Return values
none.

Definition at line 304 of file at32f435_437_can.c.

Referenced by can_configuration().

◆ can_flag_clear()

void can_flag_clear | ( | can_type * | can_x,
 |  | uint32_t | can_flag
 | ) |  |

clear flag of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_flag select the flag. this parameter can be one of the following flags:
  • CAN_EAF_FLAG
  • CAN_EPF_FLAG
  • CAN_BOF_FLAG
  • CAN_ETR_FLAG
  • CAN_EOIF_FLAG
  • CAN_TM0TCF_FLAG
  • CAN_TM1TCF_FLAG
  • CAN_TM2TCF_FLAG
  • CAN_RF0FF_FLAG
  • CAN_RF0OF_FLAG
  • CAN_RF1FF_FLAG
  • CAN_RF1OF_FLAG
  • CAN_QDZIF_FLAG
  • CAN_EDZC_FLAG
  • CAN_TMEF_FLAG note:CAN_RF0MN_FLAG and CAN_RF1MN_FLAG can not clear by this function
Return values
none.

< error active flag

< error passive flag

< bus-off flag

< error occur interrupt flag

< eoif bit value, it clear by writing 1

< error type record flag

< eoif bit value, it clear by writing 1

< transmit mailbox 0 transmission completed flag

< tm0tcf bit value, it clear by writing 1

< transmit mailbox 1 transmission completed flag

< tm1tcf bit value, it clear by writing 1

< transmit mailbox 2 transmission completed flag

< tm2tcf bit value, it clear by writing 1

< receive fifo 0 full flag

< rf0ff bit value, it clear by writing 1

< receive fifo 0 overflow flag

< rf0of bit value, it clear by writing 1

< receive fifo 1 full flag

< rf1ff bit value, it clear by writing 1

< receive fifo 1 overflow flag

< rf1of bit value, it clear by writing 1

< quit doze mode interrupt flag

< qdzif bit value, it clear by writing 1

< enter doze mode confirm flag

< edzif bit value, it clear by writing 1

< transmit mailbox empty flag

< tm0tcf bit value, it clear by writing 1

< tm1tcf bit value, it clear by writing 1

< tm2tcf bit value, it clear by writing 1

Definition at line 1087 of file at32f435_437_can.c.

Referenced by CAN1_SE_IRQHandler().

◆ can_flag_get()

flag_status can_flag_get | ( | can_type * | can_x,
 |  | uint32_t | can_flag
 | ) |  |

get flag of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_flag select the flag. this parameter can be one of the following flags:
  • CAN_EAF_FLAG
  • CAN_EPF_FLAG
  • CAN_BOF_FLAG
  • CAN_ETR_FLAG
  • CAN_EOIF_FLAG
  • CAN_TM0TCF_FLAG
  • CAN_TM1TCF_FLAG
  • CAN_TM2TCF_FLAG
  • CAN_RF0MN_FLAG
  • CAN_RF0FF_FLAG
  • CAN_RF0OF_FLAG
  • CAN_RF1MN_FLAG
  • CAN_RF1FF_FLAG
  • CAN_RF1OF_FLAG
  • CAN_QDZIF_FLAG
  • CAN_EDZC_FLAG
  • CAN_TMEF_FLAG note:the state of CAN_EDZC_FLAG need to check dzc and edzif bit note:the state of CAN_TMEF_FLAG need to check rqc0,rqc1 and rqc2 bit
Return values
status of can_flag, the returned value can be:SET or RESET.

< error active flag

< error passive flag

< bus-off flag

< error type record flag

< error occur interrupt flag

< transmit mailbox 0 transmission completed flag

< transmit mailbox 1 transmission completed flag

< transmit mailbox 2 transmission completed flag

< receive fifo 0 message num flag

< receive fifo 0 full flag

< receive fifo 0 overflow flag

< receive fifo 1 message num flag

< receive fifo 1 full flag

< receive fifo 1 overflow flag

< quit doze mode interrupt flag

< enter doze mode confirm flag

< transmit mailbox empty flag

Definition at line 964 of file at32f435_437_can.c.

Referenced by CAN1_RX0_IRQHandler(), and CAN1_SE_IRQHandler().

◆ can_interrupt_enable()

void can_interrupt_enable | ( | can_type * | can_x,
 |  | uint32_t | can_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the interrupt of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_int specifies the can interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • CAN_TCIEN_INT
  • CAN_RF0MIEN_INT
  • CAN_RF0FIEN_INT
  • CAN_RF0OIEN_INT
  • CAN_RF1MIEN_INT
  • CAN_RF1FIEN_INT
  • CAN_RF1OIEN_INT
  • CAN_EAIEN_INT
  • CAN_EPIEN_INT
  • CAN_BOIEN_INT
  • CAN_ETRIEN_INT
  • CAN_EOIEN_INT
  • CAN_QDZIEN_INT
  • CAN_EDZIEN_INT
new_state | new state of the can interrupts. this parameter can be: TRUE or FALSE.
Return values
none.

Definition at line 924 of file at32f435_437_can.c.

Referenced by can_configuration().

◆ can_message_receive()

void can_message_receive | ( | can_type * | can_x,
 |  | can_rx_fifo_num_type | fifo_number,
 |  | can_rx_message_type * | rx_message_struct
 | ) |  |

receive message of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
fifo_number receive fifo number. this parameter can be one of the following values:
  • CAN_RX_FIFO0
  • CAN_RX_FIFO1
rx_message_struct | pointer to a structure which store the receive message.
Return values
none.

Definition at line 619 of file at32f435_437_can.c.

Referenced by CAN1_RX0_IRQHandler().

◆ can_message_transmit()

uint8_t can_message_transmit | ( | can_type * | can_x,
 |  | can_tx_message_type * | tx_message_struct
 | ) |  |

fill the transmission message and transmit of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
tx_message_struct | pointer to a structure which contains the message to be trans.
Return values
the number of the mailbox that is used for transmission: this parameter can be one of the following values:
  • CAN_TX_MAILBOX0
  • CAN_TX_MAILBOX1
  • CAN_TX_MAILBOX2
  • CAN_TX_STATUS_NO_EMPTY <meanings there is no empty mailbox, message cannot be filled>

Definition at line 440 of file at32f435_437_can.c.

Referenced by can_transmit_data().

◆ can_operating_mode_set()

error_status can_operating_mode_set | ( | can_type * | can_x,
 |  | can_operating_mode_type | can_operating_mode
 | ) |  |

set the operation mode of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_operating_mode can operating mode. this parameter can be one of the following values:
  • CAN_OPERATINGMODE_FREEZE
  • CAN_OPERATINGMODE_DOZE
  • CAN_OPERATINGMODE_COMMUNICATE
Return values
status of operation mode set this parameter can be one of the following values: SUCCESS or ERROR

< time out for fzc bit

Definition at line 723 of file at32f435_437_can.c.

◆ can_receive_error_counter_get()

uint8_t can_receive_error_counter_get ( can_type * can_x )

return the receive error counter (rec) of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
the value of receive error counter.

Definition at line 878 of file at32f435_437_can.c.

◆ can_receive_fifo_release()

void can_receive_fifo_release | ( | can_type * | can_x,
 |  | can_rx_fifo_num_type | fifo_number
 | ) |  |

release the specified fifo of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
fifo_number fifo to be release. this parameter can be one of the following values:
  • CAN_RX_FIFO0
  • CAN_RX_FIFO1
Return values
none.

< rf0r bit value, it clear by writing 1

< rf1r bit value, it clear by writing 1

Definition at line 666 of file at32f435_437_can.c.

Referenced by can_message_receive().

◆ can_receive_message_pending_get()

uint8_t can_receive_message_pending_get | ( | can_type * | can_x,
 |  | can_rx_fifo_num_type | fifo_number
 | ) |  |

return the number of pending messages of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
fifo_number receive fifo number. this parameter can be one of the following values:
  • CAN_RX_FIFO0
  • CAN_RX_FIFO1
Return values
the number of message pending in the receive fifo.

Definition at line 692 of file at32f435_437_can.c.

◆ can_reset()

void can_reset ( can_type * can_x )

deinitialize the can peripheral registers to their default reset values.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
none.

Definition at line 51 of file at32f435_437_can.c.

◆ can_transmit_cancel()

void can_transmit_cancel | ( | can_type * | can_x,
 |  | can_tx_mailbox_num_type | transmit_mailbox
 | ) |  |

cancel a transmit request of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1 or CAN2.
mailbox mailbox number. this parameter can be one of the following values:
  • CAN_TX_MAILBOX0
  • CAN_TX_MAILBOX1
  • CAN_TX_MAILBOX2
Return values
none.

< tm0ct bit value, it clear by writing 1

< tm1ct bit value, it clear by writing 1

< tm2ct bit value, it clear by writing 1

Definition at line 589 of file at32f435_437_can.c.

◆ can_transmit_error_counter_get()

uint8_t can_transmit_error_counter_get ( can_type * can_x )

return the transmit error counter of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
the value of transmit error counter.

Definition at line 892 of file at32f435_437_can.c.

◆ can_transmit_status_get()

can_transmit_status_type can_transmit_status_get | ( | can_type * | can_x,
 |  | can_tx_mailbox_num_type | transmit_mailbox
 | ) |  |

check the transmission state of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1 or CAN2.
transmit_mailbox the number of the mailbox that is used for transmission. this parameter can be one of the following values:
  • CAN_TX_MAILBOX0
  • CAN_TX_MAILBOX1
  • CAN_TX_MAILBOX2
Return values
can transmit status this parameter can be one of the following values:
  • CAN_TX_STATUS_SUCCESSFUL
  • CAN_TX_STATUS_FAILED
  • CAN_TX_STATUS_PENDING

Definition at line 514 of file at32f435_437_can.c.

Referenced by can_transmit_data().

◆ can_ttc_mode_enable()

void can_ttc_mode_enable | ( | can_type * | can_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable time trigger operation communication mode of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1 or CAN2.
new_state | : new state of time trigger operation communication mode. this parameter can be: TRUE or FALSE.
Note
note1: when enabled, transmit mailbox time stamp(tmts[15:0]) value is sent in the last two data bytes of the 8-byte message: tmts[7:0] in data byte 6 and tmts[15:8] in data byte 7
note2: tmdtbl must be programmed as 8 in order time stamp (2 bytes) to be sent over the can bus.
Return values
none

Definition at line 416 of file at32f435_437_can.c.


AT32F435/437 Firmwary Library: CAN_private_functions

Functions
CAN_private_functions
AT32F435_437_periph_driver » CAN

Functions

void | can_reset (can_type *can_x)
deinitialize the can peripheral registers to their default reset values. More...
void | can_baudrate_default_para_init (can_baudrate_type *can_baudrate_struct)
fill each can_baudrate_struct member with its default value. More...
error_status | can_baudrate_set (can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral More...
void | can_default_para_init (can_base_type *can_base_struct)
fill each can_init_struct member with its default value. More...
error_status | can_base_init (can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct. More...
void | can_filter_default_para_init (can_filter_init_type *can_filter_init_struct)
fill each can_filter_init_struct member with its default value. More...
void | can_filter_init (can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct. More...
void | can_debug_transmission_prohibit (can_type *can_x, confirm_state new_state)
enable or disable the debug transmission prohibit of the specified can peripheral. More...
void | can_ttc_mode_enable (can_type *can_x, confirm_state new_state)
enable or disable time trigger operation communication mode of the specified can peripheral. More...
uint8_t | can_message_transmit (can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral. More...
can_transmit_status_type | can_transmit_status_get (can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral. More...
void | can_transmit_cancel (can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
cancel a transmit request of the specified can peripheral. More...
void | can_message_receive (can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral. More...
void | can_receive_fifo_release (can_type *can_x, can_rx_fifo_num_type fifo_number)
release the specified fifo of the specified can peripheral. More...
uint8_t | can_receive_message_pending_get (can_type *can_x, can_rx_fifo_num_type fifo_number)
return the number of pending messages of the specified can peripheral. More...
error_status | can_operating_mode_set (can_type *can_x, can_operating_mode_type can_operating_mode)
set the operation mode of the specified can peripheral. More...
can_enter_doze_status_type | can_doze_mode_enter (can_type *can_x)
enter the low power mode of the specified can peripheral. More...
can_quit_doze_status_type | can_doze_mode_exit (can_type *can_x)
exit the doze mode of the specified can peripheral. More...
can_error_record_type | can_error_type_record_get (can_type *can_x)
return the error type record (etr) of the specified can peripheral. More...
uint8_t | can_receive_error_counter_get (can_type *can_x)
return the receive error counter (rec) of the specified can peripheral. More...
uint8_t | can_transmit_error_counter_get (can_type *can_x)
return the transmit error counter of the specified can peripheral. More...
void | can_interrupt_enable (can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral. More...
flag_status | can_flag_get (can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral. More...
void | can_flag_clear (can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral. More...

Detailed Description

Function Documentation

◆ can_base_init()

error_status can_base_init | ( | can_type * | can_x,
 |  | can_base_type * | can_base_struct
 | ) |  |

initialize the can peripheral according to the specified parameters in the can_init_struct.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_base_struct | pointer to a can_base_struct structure that contains the configuration information for the can peripheral.
Return values
the status of initialization this parameter can be one of the following values: SUCCESS or ERROR

< time out for fzc bit

< time out for fzc bit

Definition at line 194 of file at32f435_437_can.c.

Referenced by can_configuration().

◆ can_baudrate_default_para_init()

void can_baudrate_default_para_init ( can_baudrate_type * can_baudrate_struct )

fill each can_baudrate_struct member with its default value.

Parameters
can_baudrate_struct pointer to a can_baudrate_type structure which will be initialized.
Return values
none.

Definition at line 70 of file at32f435_437_can.c.

◆ can_baudrate_set()

error_status can_baudrate_set | ( | can_type * | can_x,
 |  | can_baudrate_type * | can_baudrate_struct
 | ) |  |

set the baudrate of the can peripheral

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_baudrate_struct | pointer to a can_baudrate_type structure which will be set.
Note
baudrate calculate method is: baudrate = fpclk/(baudrate_div *(3 + bts1_size + bts2_size))
Return values
the result of baudrate set this parameter can be one of the following values: SUCCESS or ERROR

< time out for fzc bit

< time out for fzc bit

Definition at line 99 of file at32f435_437_can.c.

Referenced by can_configuration().

◆ can_debug_transmission_prohibit()

void can_debug_transmission_prohibit | ( | can_type * | can_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the debug transmission prohibit of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
new_state | new state of debug transmission prohibit. this parameter can be: TRUE or FALSE.
Return values
none.

Definition at line 395 of file at32f435_437_can.c.

◆ can_default_para_init()

void can_default_para_init ( can_base_type * can_base_struct )

fill each can_init_struct member with its default value.

Parameters
can_base_struct pointer to a can_base_type structure which will be initialized.
Return values
none.

Definition at line 157 of file at32f435_437_can.c.

Referenced by can_configuration().

◆ can_doze_mode_enter()

can_enter_doze_status_type can_doze_mode_enter ( can_type * can_x )

enter the low power mode of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
status of doze mode enter, the returned value can be:
  • CAN_ENTER_DOZE_SUCCESSFUL <it meaning enter the doze mode succeed>
  • CAN_ENTER_DOZE_FAILED <it meaning enter the doze mode failed>

< time out for fzc bit

Definition at line 801 of file at32f435_437_can.c.

◆ can_doze_mode_exit()

can_quit_doze_status_type can_doze_mode_exit ( can_type * can_x )

exit the doze mode of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
status of doze mode enter, the returned value can be:
  • CAN_QUIT_DOZE_SUCCESSFUL <it meaning exit the doze mode succeed>
  • CAN_QUIT_DOZE_FAILED <it meaning exit the doze mode failed>

< time out for dzc bit

Definition at line 831 of file at32f435_437_can.c.

◆ can_error_type_record_get()

can_error_record_type can_error_type_record_get ( can_type * can_x )

return the error type record (etr) of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
the value of the error code the return can be one of the follow values:
  • CAN_ERRORRECORD_NOERR
  • CAN_ERRORRECORD_STUFFERR,
  • CAN_ERRORRECORD_FORMERR,
  • CAN_ERRORRECORD_ACKERR,
  • CAN_ERRORRECORD_BITRECESSIVEERR,
  • CAN_ERRORRECORD_BITDOMINANTERR,
  • CAN_ERRORRECORD_CRCERR,
  • CAN_ERRORRECORD_SOFTWARESETERR

Definition at line 863 of file at32f435_437_can.c.

◆ can_filter_default_para_init()

void can_filter_default_para_init ( can_filter_init_type * can_filter_init_struct )

fill each can_filter_init_struct member with its default value.

Parameters
can_filter_init_struct pointer to a can_filter_init_type structure which will be initialized.
Return values
none.

Definition at line 269 of file at32f435_437_can.c.

◆ can_filter_init()

void can_filter_init | ( | can_type * | can_x,
 |  | can_filter_init_type * | can_filter_init_struct
 | ) |  |

initialize the can peripheral according to the specified parameters in the can_filter_init_struct.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_filter_init_struct | pointer to a can_filter_init_type structure that contains the configuration information.
Return values
none.

Definition at line 304 of file at32f435_437_can.c.

Referenced by can_configuration().

◆ can_flag_clear()

void can_flag_clear | ( | can_type * | can_x,
 |  | uint32_t | can_flag
 | ) |  |

clear flag of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_flag select the flag. this parameter can be one of the following flags:
  • CAN_EAF_FLAG
  • CAN_EPF_FLAG
  • CAN_BOF_FLAG
  • CAN_ETR_FLAG
  • CAN_EOIF_FLAG
  • CAN_TM0TCF_FLAG
  • CAN_TM1TCF_FLAG
  • CAN_TM2TCF_FLAG
  • CAN_RF0FF_FLAG
  • CAN_RF0OF_FLAG
  • CAN_RF1FF_FLAG
  • CAN_RF1OF_FLAG
  • CAN_QDZIF_FLAG
  • CAN_EDZC_FLAG
  • CAN_TMEF_FLAG note:CAN_RF0MN_FLAG and CAN_RF1MN_FLAG can not clear by this function
Return values
none.

< error active flag

< error passive flag

< bus-off flag

< error occur interrupt flag

< eoif bit value, it clear by writing 1

< error type record flag

< eoif bit value, it clear by writing 1

< transmit mailbox 0 transmission completed flag

< tm0tcf bit value, it clear by writing 1

< transmit mailbox 1 transmission completed flag

< tm1tcf bit value, it clear by writing 1

< transmit mailbox 2 transmission completed flag

< tm2tcf bit value, it clear by writing 1

< receive fifo 0 full flag

< rf0ff bit value, it clear by writing 1

< receive fifo 0 overflow flag

< rf0of bit value, it clear by writing 1

< receive fifo 1 full flag

< rf1ff bit value, it clear by writing 1

< receive fifo 1 overflow flag

< rf1of bit value, it clear by writing 1

< quit doze mode interrupt flag

< qdzif bit value, it clear by writing 1

< enter doze mode confirm flag

< edzif bit value, it clear by writing 1

< transmit mailbox empty flag

< tm0tcf bit value, it clear by writing 1

< tm1tcf bit value, it clear by writing 1

< tm2tcf bit value, it clear by writing 1

Definition at line 1087 of file at32f435_437_can.c.

Referenced by CAN1_SE_IRQHandler().

◆ can_flag_get()

flag_status can_flag_get | ( | can_type * | can_x,
 |  | uint32_t | can_flag
 | ) |  |

get flag of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_flag select the flag. this parameter can be one of the following flags:
  • CAN_EAF_FLAG
  • CAN_EPF_FLAG
  • CAN_BOF_FLAG
  • CAN_ETR_FLAG
  • CAN_EOIF_FLAG
  • CAN_TM0TCF_FLAG
  • CAN_TM1TCF_FLAG
  • CAN_TM2TCF_FLAG
  • CAN_RF0MN_FLAG
  • CAN_RF0FF_FLAG
  • CAN_RF0OF_FLAG
  • CAN_RF1MN_FLAG
  • CAN_RF1FF_FLAG
  • CAN_RF1OF_FLAG
  • CAN_QDZIF_FLAG
  • CAN_EDZC_FLAG
  • CAN_TMEF_FLAG note:the state of CAN_EDZC_FLAG need to check dzc and edzif bit note:the state of CAN_TMEF_FLAG need to check rqc0,rqc1 and rqc2 bit
Return values
status of can_flag, the returned value can be:SET or RESET.

< error active flag

< error passive flag

< bus-off flag

< error type record flag

< error occur interrupt flag

< transmit mailbox 0 transmission completed flag

< transmit mailbox 1 transmission completed flag

< transmit mailbox 2 transmission completed flag

< receive fifo 0 message num flag

< receive fifo 0 full flag

< receive fifo 0 overflow flag

< receive fifo 1 message num flag

< receive fifo 1 full flag

< receive fifo 1 overflow flag

< quit doze mode interrupt flag

< enter doze mode confirm flag

< transmit mailbox empty flag

Definition at line 964 of file at32f435_437_can.c.

Referenced by CAN1_RX0_IRQHandler(), and CAN1_SE_IRQHandler().

◆ can_interrupt_enable()

void can_interrupt_enable | ( | can_type * | can_x,
 |  | uint32_t | can_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the interrupt of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_int specifies the can interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • CAN_TCIEN_INT
  • CAN_RF0MIEN_INT
  • CAN_RF0FIEN_INT
  • CAN_RF0OIEN_INT
  • CAN_RF1MIEN_INT
  • CAN_RF1FIEN_INT
  • CAN_RF1OIEN_INT
  • CAN_EAIEN_INT
  • CAN_EPIEN_INT
  • CAN_BOIEN_INT
  • CAN_ETRIEN_INT
  • CAN_EOIEN_INT
  • CAN_QDZIEN_INT
  • CAN_EDZIEN_INT
new_state | new state of the can interrupts. this parameter can be: TRUE or FALSE.
Return values
none.

Definition at line 924 of file at32f435_437_can.c.

Referenced by can_configuration().

◆ can_message_receive()

void can_message_receive | ( | can_type * | can_x,
 |  | can_rx_fifo_num_type | fifo_number,
 |  | can_rx_message_type * | rx_message_struct
 | ) |  |

receive message of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
fifo_number receive fifo number. this parameter can be one of the following values:
  • CAN_RX_FIFO0
  • CAN_RX_FIFO1
rx_message_struct | pointer to a structure which store the receive message.
Return values
none.

Definition at line 619 of file at32f435_437_can.c.

Referenced by CAN1_RX0_IRQHandler().

◆ can_message_transmit()

uint8_t can_message_transmit | ( | can_type * | can_x,
 |  | can_tx_message_type * | tx_message_struct
 | ) |  |

fill the transmission message and transmit of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
tx_message_struct | pointer to a structure which contains the message to be trans.
Return values
the number of the mailbox that is used for transmission: this parameter can be one of the following values:
  • CAN_TX_MAILBOX0
  • CAN_TX_MAILBOX1
  • CAN_TX_MAILBOX2
  • CAN_TX_STATUS_NO_EMPTY <meanings there is no empty mailbox, message cannot be filled>

Definition at line 440 of file at32f435_437_can.c.

Referenced by can_transmit_data().

◆ can_operating_mode_set()

error_status can_operating_mode_set | ( | can_type * | can_x,
 |  | can_operating_mode_type | can_operating_mode
 | ) |  |

set the operation mode of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_operating_mode can operating mode. this parameter can be one of the following values:
  • CAN_OPERATINGMODE_FREEZE
  • CAN_OPERATINGMODE_DOZE
  • CAN_OPERATINGMODE_COMMUNICATE
Return values
status of operation mode set this parameter can be one of the following values: SUCCESS or ERROR

< time out for fzc bit

Definition at line 723 of file at32f435_437_can.c.

◆ can_receive_error_counter_get()

uint8_t can_receive_error_counter_get ( can_type * can_x )

return the receive error counter (rec) of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
the value of receive error counter.

Definition at line 878 of file at32f435_437_can.c.

◆ can_receive_fifo_release()

void can_receive_fifo_release | ( | can_type * | can_x,
 |  | can_rx_fifo_num_type | fifo_number
 | ) |  |

release the specified fifo of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
fifo_number fifo to be release. this parameter can be one of the following values:
  • CAN_RX_FIFO0
  • CAN_RX_FIFO1
Return values
none.

< rf0r bit value, it clear by writing 1

< rf1r bit value, it clear by writing 1

Definition at line 666 of file at32f435_437_can.c.

Referenced by can_message_receive().

◆ can_receive_message_pending_get()

uint8_t can_receive_message_pending_get | ( | can_type * | can_x,
 |  | can_rx_fifo_num_type | fifo_number
 | ) |  |

return the number of pending messages of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
fifo_number receive fifo number. this parameter can be one of the following values:
  • CAN_RX_FIFO0
  • CAN_RX_FIFO1
Return values
the number of message pending in the receive fifo.

Definition at line 692 of file at32f435_437_can.c.

◆ can_reset()

void can_reset ( can_type * can_x )

deinitialize the can peripheral registers to their default reset values.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
none.

Definition at line 51 of file at32f435_437_can.c.

◆ can_transmit_cancel()

void can_transmit_cancel | ( | can_type * | can_x,
 |  | can_tx_mailbox_num_type | transmit_mailbox
 | ) |  |

cancel a transmit request of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1 or CAN2.
mailbox mailbox number. this parameter can be one of the following values:
  • CAN_TX_MAILBOX0
  • CAN_TX_MAILBOX1
  • CAN_TX_MAILBOX2
Return values
none.

< tm0ct bit value, it clear by writing 1

< tm1ct bit value, it clear by writing 1

< tm2ct bit value, it clear by writing 1

Definition at line 589 of file at32f435_437_can.c.

◆ can_transmit_error_counter_get()

uint8_t can_transmit_error_counter_get ( can_type * can_x )

return the transmit error counter of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
the value of transmit error counter.

Definition at line 892 of file at32f435_437_can.c.

◆ can_transmit_status_get()

can_transmit_status_type can_transmit_status_get | ( | can_type * | can_x,
 |  | can_tx_mailbox_num_type | transmit_mailbox
 | ) |  |

check the transmission state of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1 or CAN2.
transmit_mailbox the number of the mailbox that is used for transmission. this parameter can be one of the following values:
  • CAN_TX_MAILBOX0
  • CAN_TX_MAILBOX1
  • CAN_TX_MAILBOX2
Return values
can transmit status this parameter can be one of the following values:
  • CAN_TX_STATUS_SUCCESSFUL
  • CAN_TX_STATUS_FAILED
  • CAN_TX_STATUS_PENDING

Definition at line 514 of file at32f435_437_can.c.

Referenced by can_transmit_data().

◆ can_ttc_mode_enable()

void can_ttc_mode_enable | ( | can_type * | can_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable time trigger operation communication mode of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1 or CAN2.
new_state | : new state of time trigger operation communication mode. this parameter can be: TRUE or FALSE.
Note
note1: when enabled, transmit mailbox time stamp(tmts[15:0]) value is sent in the last two data bytes of the 8-byte message: tmts[7:0] in data byte 6 and tmts[15:8] in data byte 7
note2: tmdtbl must be programmed as 8 in order time stamp (2 bytes) to be sent over the can bus.
Return values
none

Definition at line 416 of file at32f435_437_can.c.


AT32F435/437 Firmwary Library: CRC

Modules | Macros
CRC
AT32F435_437_periph_driver

CRC driver modules. More...

Modules

CRC_exported_types
CRC_exported_functions
CRC_private_functions

Macros

#define CRC ((crc_type *) CRC_BASE)

Detailed Description

CRC driver modules.

Macro Definition Documentation

◆ CRC

#define CRC ((crc_type *) CRC_BASE)

Definition at line 140 of file at32f435_437_crc.h.


AT32F435/437 Firmwary Library: CRC_exported_types

Data Structures | Enumerations
CRC_exported_types
AT32F435_437_periph_driver » CRC

Data Structures

struct crc_type
type define crc register all More...

Enumerations

enum | crc_reverse_input_type { CRC_REVERSE_INPUT_NO_AFFECTE = 0x00 , CRC_REVERSE_INPUT_BY_BYTE = 0x01 , CRC_REVERSE_INPUT_BY_HALFWORD = 0x02 , CRC_REVERSE_INPUT_BY_WORD = 0x03 }
crc reverse input data More...
enum | crc_reverse_output_type { CRC_REVERSE_OUTPUT_NO_AFFECTE = 0x00 , CRC_REVERSE_OUTPUT_DATA = 0x01 }
crc reverse output data More...

Detailed Description

Enumeration Type Documentation

◆ crc_reverse_input_type

enum crc_reverse_input_type

crc reverse input data

Enumerator
CRC_REVERSE_INPUT_NO_AFFECTE | input data no reverse
CRC_REVERSE_INPUT_BY_BYTE | input data reverse by byte
CRC_REVERSE_INPUT_BY_HALFWORD | input data reverse by half word
CRC_REVERSE_INPUT_BY_WORD | input data reverse by word

Definition at line 54 of file at32f435_437_crc.h.

◆ crc_reverse_output_type

enum crc_reverse_output_type

crc reverse output data

Enumerator
CRC_REVERSE_OUTPUT_NO_AFFECTE | output data no reverse
CRC_REVERSE_OUTPUT_DATA | output data reverse by word

Definition at line 65 of file at32f435_437_crc.h.


AT32F435/437 Firmwary Library: crc_type Struct Reference

Data Fields
crc_type Struct Reference
AT32F435_437_periph_driver » CRC » CRC_exported_types

type define crc register all More...

#include <at32f435_437_crc.h>

Data Fields

union {
__IO uint32_t dt
struct {
__IO uint32_t dt: 32
} dt_bit
};
crc dt register, offset:0x00 More...
union {
__IO uint32_t cdt
struct {
__IO uint32_t cdt: 8
__IO uint32_t reserved1: 24
} cdt_bit
};
crc cdt register, offset:0x04 More...
union {
__IO uint32_t ctrl
struct {
__IO uint32_t rst: 1
__IO uint32_t reserved1: 4
__IO uint32_t revid: 2
__IO uint32_t revod: 1
__IO uint32_t reserved2: 24
} ctrl_bit
};
crc ctrl register, offset:0x08 More...
union {
__IO uint32_t idt
struct {
__IO uint32_t idt: 32
} idt_bit
};
crc idt register, offset:0x10 More...

Detailed Description

type define crc register all

Definition at line 74 of file at32f435_437_crc.h.

Field Documentation

◆

union { ... } crc_type::@157

crc dt register, offset:0x00

◆

union { ... } crc_type::@159

crc cdt register, offset:0x04

◆

union { ... } crc_type::@161

crc ctrl register, offset:0x08

◆

union { ... } crc_type::@163

crc idt register, offset:0x10

◆ cdt

__IO uint32_t crc_type::cdt

Definition at line 93 of file at32f435_437_crc.h.

◆

struct { ... } crc_type::cdt_bit

◆ ctrl

__IO uint32_t crc_type::ctrl

Definition at line 106 of file at32f435_437_crc.h.

◆

struct { ... } crc_type::ctrl_bit

◆ dt

__IO uint32_t crc_type::dt

Definition at line 81 of file at32f435_437_crc.h.

◆

struct { ... } crc_type::dt_bit

◆ idt

__IO uint32_t crc_type::idt

Definition at line 127 of file at32f435_437_crc.h.

◆

struct { ... } crc_type::idt_bit

◆ reserved1

__IO uint32_t crc_type::reserved1

crm reserved1 register, offset:0x0C

Definition at line 97 of file at32f435_437_crc.h.

◆ reserved2

__IO uint32_t crc_type::reserved2

Definition at line 113 of file at32f435_437_crc.h.

◆ revid

__IO uint32_t crc_type::revid

Definition at line 111 of file at32f435_437_crc.h.

◆ revod

__IO uint32_t crc_type::revod

Definition at line 112 of file at32f435_437_crc.h.

◆ rst

__IO uint32_t crc_type::rst

Definition at line 109 of file at32f435_437_crc.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_crc.h


AT32F435/437 Firmwary Library: CRC_exported_functions

Functions
CRC_exported_functions
AT32F435_437_periph_driver » CRC

Functions

void | crc_data_reset (void)
reset the crc data register. More...
uint32_t | crc_one_word_calculate (uint32_t data)
compute the 32-bit crc of a given data word(32-bit). More...
uint32_t | crc_block_calculate (uint32_t *pbuffer, uint32_t length)
compute the 32-bit crc of a given buffer of data word(32-bit). More...
uint32_t | crc_data_get (void)
return the current crc value. More...
void | crc_common_data_set (uint8_t cdt_value)
store a 8-bit data in the common data register. More...
uint8_t | crc_common_date_get (void)
return the 8-bit data stored in the common data register More...
void | crc_init_data_set (uint32_t value)
set the 32-bit initial data of crc More...
void | crc_reverse_input_data_set (crc_reverse_input_type value)
control the reversal of the bit order in the input data More...
void | crc_reverse_output_data_set (crc_reverse_output_type value)
control the reversal of the bit order in the output data More...

Detailed Description

Function Documentation

◆ crc_block_calculate()

uint32_t crc_block_calculate | ( | uint32_t * | pbuffer,
 |  | uint32_t | length
 | ) |  |

compute the 32-bit crc of a given buffer of data word(32-bit).

Parameters
pbuffer | pointer to the buffer containing the data to be computed
length | length of the buffer to be computed
Return values
32-bit crc

Definition at line 72 of file at32f435_437_crc.c.

Referenced by main().

◆ crc_common_data_set()

void crc_common_data_set ( uint8_t cdt_value )

store a 8-bit data in the common data register.

Parameters
cdt_value 8-bit value to be stored in the common data register
Return values
none

Definition at line 99 of file at32f435_437_crc.c.

◆ crc_common_date_get()

uint8_t crc_common_date_get ( void )

return the 8-bit data stored in the common data register

Parameters
none
Return values
8-bit value of the common data register

Definition at line 109 of file at32f435_437_crc.c.

◆ crc_data_get()

uint32_t crc_data_get ( void )

return the current crc value.

Parameters
none
Return values
32-bit crc

Definition at line 89 of file at32f435_437_crc.c.

Referenced by crc_cal().

◆ crc_data_reset()

void crc_data_reset ( void )

reset the crc data register.

Parameters
none
Return values
none

Definition at line 49 of file at32f435_437_crc.c.

Referenced by crc_cal(), flash_crc_check(), and main().

◆ crc_init_data_set()

void crc_init_data_set ( uint32_t value )

set the 32-bit initial data of crc

Parameters
value initial data
Return values
none

Definition at line 119 of file at32f435_437_crc.c.

◆ crc_one_word_calculate()

uint32_t crc_one_word_calculate ( uint32_t data )

compute the 32-bit crc of a given data word(32-bit).

Parameters
data data word(32-bit) to compute its crc
Return values
32-bit crc

Definition at line 60 of file at32f435_437_crc.c.

Referenced by crc_cal(), and flash_crc_check().

◆ crc_reverse_input_data_set()

void crc_reverse_input_data_set ( crc_reverse_input_type value )

control the reversal of the bit order in the input data

Parameters
value this parameter can be one of the following values:
  • CRC_REVERSE_INPUT_NO_AFFECTE
  • CRC_REVERSE_INPUT_BY_BYTE
  • CRC_REVERSE_INPUT_BY_HALFWORD
  • CRC_REVERSE_INPUT_BY_WORD
Return values
none.

Definition at line 134 of file at32f435_437_crc.c.

◆ crc_reverse_output_data_set()

void crc_reverse_output_data_set ( crc_reverse_output_type value )

control the reversal of the bit order in the output data

Parameters
value this parameter can be one of the following values:
  • CRC_REVERSE_OUTPUT_NO_AFFECTE
  • CRC_REVERSE_OUTPUT_DATA
Return values
none.

Definition at line 147 of file at32f435_437_crc.c.


AT32F435/437 Firmwary Library: CRC_private_functions

Functions
CRC_private_functions
AT32F435_437_periph_driver » CRC

Functions

void | crc_data_reset (void)
reset the crc data register. More...
uint32_t | crc_one_word_calculate (uint32_t data)
compute the 32-bit crc of a given data word(32-bit). More...
uint32_t | crc_block_calculate (uint32_t *pbuffer, uint32_t length)
compute the 32-bit crc of a given buffer of data word(32-bit). More...
uint32_t | crc_data_get (void)
return the current crc value. More...
void | crc_common_data_set (uint8_t cdt_value)
store a 8-bit data in the common data register. More...
uint8_t | crc_common_date_get (void)
return the 8-bit data stored in the common data register More...
void | crc_init_data_set (uint32_t value)
set the 32-bit initial data of crc More...
void | crc_reverse_input_data_set (crc_reverse_input_type value)
control the reversal of the bit order in the input data More...
void | crc_reverse_output_data_set (crc_reverse_output_type value)
control the reversal of the bit order in the output data More...

Detailed Description

Function Documentation

◆ crc_block_calculate()

uint32_t crc_block_calculate | ( | uint32_t * | pbuffer,
 |  | uint32_t | length
 | ) |  |

compute the 32-bit crc of a given buffer of data word(32-bit).

Parameters
pbuffer | pointer to the buffer containing the data to be computed
length | length of the buffer to be computed
Return values
32-bit crc

Definition at line 72 of file at32f435_437_crc.c.

Referenced by main().

◆ crc_common_data_set()

void crc_common_data_set ( uint8_t cdt_value )

store a 8-bit data in the common data register.

Parameters
cdt_value 8-bit value to be stored in the common data register
Return values
none

Definition at line 99 of file at32f435_437_crc.c.

◆ crc_common_date_get()

uint8_t crc_common_date_get ( void )

return the 8-bit data stored in the common data register

Parameters
none
Return values
8-bit value of the common data register

Definition at line 109 of file at32f435_437_crc.c.

◆ crc_data_get()

uint32_t crc_data_get ( void )

return the current crc value.

Parameters
none
Return values
32-bit crc

Definition at line 89 of file at32f435_437_crc.c.

Referenced by crc_cal().

◆ crc_data_reset()

void crc_data_reset ( void )

reset the crc data register.

Parameters
none
Return values
none

Definition at line 49 of file at32f435_437_crc.c.

Referenced by crc_cal(), flash_crc_check(), and main().

◆ crc_init_data_set()

void crc_init_data_set ( uint32_t value )

set the 32-bit initial data of crc

Parameters
value initial data
Return values
none

Definition at line 119 of file at32f435_437_crc.c.

◆ crc_one_word_calculate()

uint32_t crc_one_word_calculate ( uint32_t data )

compute the 32-bit crc of a given data word(32-bit).

Parameters
data data word(32-bit) to compute its crc
Return values
32-bit crc

Definition at line 60 of file at32f435_437_crc.c.

Referenced by crc_cal(), and flash_crc_check().

◆ crc_reverse_input_data_set()

void crc_reverse_input_data_set ( crc_reverse_input_type value )

control the reversal of the bit order in the input data

Parameters
value this parameter can be one of the following values:
  • CRC_REVERSE_INPUT_NO_AFFECTE
  • CRC_REVERSE_INPUT_BY_BYTE
  • CRC_REVERSE_INPUT_BY_HALFWORD
  • CRC_REVERSE_INPUT_BY_WORD
Return values
none.

Definition at line 134 of file at32f435_437_crc.c.

◆ crc_reverse_output_data_set()

void crc_reverse_output_data_set ( crc_reverse_output_type value )

control the reversal of the bit order in the output data

Parameters
value this parameter can be one of the following values:
  • CRC_REVERSE_OUTPUT_NO_AFFECTE
  • CRC_REVERSE_OUTPUT_DATA
Return values
none.

Definition at line 147 of file at32f435_437_crc.c.


AT32F435/437 Firmwary Library: CRM

Modules | Macros
CRM
AT32F435_437_periph_driver

CRM driver modules. More...

Modules

CRM_flags_definition
crm flag
CRM_interrupts_definition
crm interrupt
CRM_exported_types
CRM_exported_functions
CRM_private_functions

Macros

#define | CRM_REG(value) PERIPH_REG(CRM_BASE, value)
#define | CRM_REG_BIT(value) PERIPH_REG_BIT(value)
#define | CRM ((crm_type *) CRM_BASE)

Detailed Description

CRM driver modules.

Macro Definition Documentation

◆ CRM

#define CRM ((crm_type *) CRM_BASE)

Definition at line 1506 of file at32f435_437_crm.h.

◆ CRM_REG

#define CRM_REG ( value ) PERIPH_REG(CRM_BASE, value)

Definition at line 47 of file at32f435_437_crm.h.

◆ CRM_REG_BIT

#define CRM_REG_BIT ( value ) PERIPH_REG_BIT(value)

Definition at line 48 of file at32f435_437_crm.h.


AT32F435/437 Firmwary Library: CRM_flags_definition

Macros
CRM_flags_definition
AT32F435_437_periph_driver » CRM

crm flag More...

Macros

#define | CRM_HICK_STABLE_FLAG MAKE_VALUE(0x00, 1)
#define | CRM_HEXT_STABLE_FLAG MAKE_VALUE(0x00, 17)
#define | CRM_PLL_STABLE_FLAG MAKE_VALUE(0x00, 25)
#define | CRM_LEXT_STABLE_FLAG MAKE_VALUE(0x70, 1)
#define | CRM_LICK_STABLE_FLAG MAKE_VALUE(0x74, 1)
#define | CRM_ALL_RESET_FLAG MAKE_VALUE(0x74, 24)
#define | CRM_NRST_RESET_FLAG MAKE_VALUE(0x74, 26)
#define | CRM_POR_RESET_FLAG MAKE_VALUE(0x74, 27)
#define | CRM_SW_RESET_FLAG MAKE_VALUE(0x74, 28)
#define | CRM_WDT_RESET_FLAG MAKE_VALUE(0x74, 29)
#define | CRM_WWDT_RESET_FLAG MAKE_VALUE(0x74, 30)
#define | CRM_LOWPOWER_RESET_FLAG MAKE_VALUE(0x74, 31)
#define | CRM_LICK_READY_INT_FLAG MAKE_VALUE(0x0C, 0)
#define | CRM_LEXT_READY_INT_FLAG MAKE_VALUE(0x0C, 1)
#define | CRM_HICK_READY_INT_FLAG MAKE_VALUE(0x0C, 2)
#define | CRM_HEXT_READY_INT_FLAG MAKE_VALUE(0x0C, 3)
#define | CRM_PLL_READY_INT_FLAG MAKE_VALUE(0x0C, 4)
#define | CRM_CLOCK_FAILURE_INT_FLAG MAKE_VALUE(0x0C, 7)

Detailed Description

crm flag

Macro Definition Documentation

◆ CRM_ALL_RESET_FLAG

#define CRM_ALL_RESET_FLAG MAKE_VALUE(0x74, 24)

all reset flag

Definition at line 60 of file at32f435_437_crm.h.

◆ CRM_CLOCK_FAILURE_INT_FLAG

#define CRM_CLOCK_FAILURE_INT_FLAG MAKE_VALUE(0x0C, 7)

clock failure interrupt ready flag

Definition at line 72 of file at32f435_437_crm.h.

◆ CRM_HEXT_READY_INT_FLAG

#define CRM_HEXT_READY_INT_FLAG MAKE_VALUE(0x0C, 3)

high speed external crystal stable interrupt ready flag

Definition at line 70 of file at32f435_437_crm.h.

◆ CRM_HEXT_STABLE_FLAG

#define CRM_HEXT_STABLE_FLAG MAKE_VALUE(0x00, 17)

high speed external crystal stable flag

Definition at line 56 of file at32f435_437_crm.h.

◆ CRM_HICK_READY_INT_FLAG

#define CRM_HICK_READY_INT_FLAG MAKE_VALUE(0x0C, 2)

high speed internal clock stable interrupt ready flag

Definition at line 69 of file at32f435_437_crm.h.

◆ CRM_HICK_STABLE_FLAG

#define CRM_HICK_STABLE_FLAG MAKE_VALUE(0x00, 1)

high speed internal clock stable flag

Definition at line 55 of file at32f435_437_crm.h.

◆ CRM_LEXT_READY_INT_FLAG

#define CRM_LEXT_READY_INT_FLAG MAKE_VALUE(0x0C, 1)

low speed external crystal stable interrupt ready flag

Definition at line 68 of file at32f435_437_crm.h.

◆ CRM_LEXT_STABLE_FLAG

#define CRM_LEXT_STABLE_FLAG MAKE_VALUE(0x70, 1)

low speed external crystal stable flag

Definition at line 58 of file at32f435_437_crm.h.

◆ CRM_LICK_READY_INT_FLAG

#define CRM_LICK_READY_INT_FLAG MAKE_VALUE(0x0C, 0)

low speed internal clock stable interrupt ready flag

Definition at line 67 of file at32f435_437_crm.h.

◆ CRM_LICK_STABLE_FLAG

#define CRM_LICK_STABLE_FLAG MAKE_VALUE(0x74, 1)

low speed internal clock stable flag

Definition at line 59 of file at32f435_437_crm.h.

◆ CRM_LOWPOWER_RESET_FLAG

#define CRM_LOWPOWER_RESET_FLAG MAKE_VALUE(0x74, 31)

low-power reset flag

Definition at line 66 of file at32f435_437_crm.h.

◆ CRM_NRST_RESET_FLAG

#define CRM_NRST_RESET_FLAG MAKE_VALUE(0x74, 26)

nrst pin reset flag

Definition at line 61 of file at32f435_437_crm.h.

◆ CRM_PLL_READY_INT_FLAG

#define CRM_PLL_READY_INT_FLAG MAKE_VALUE(0x0C, 4)

phase locking loop stable interrupt ready flag

Definition at line 71 of file at32f435_437_crm.h.

◆ CRM_PLL_STABLE_FLAG

#define CRM_PLL_STABLE_FLAG MAKE_VALUE(0x00, 25)

phase locking loop stable flag

Definition at line 57 of file at32f435_437_crm.h.

◆ CRM_POR_RESET_FLAG

#define CRM_POR_RESET_FLAG MAKE_VALUE(0x74, 27)

power on reset flag

Definition at line 62 of file at32f435_437_crm.h.

◆ CRM_SW_RESET_FLAG

#define CRM_SW_RESET_FLAG MAKE_VALUE(0x74, 28)

software reset flag

Definition at line 63 of file at32f435_437_crm.h.

◆ CRM_WDT_RESET_FLAG

#define CRM_WDT_RESET_FLAG MAKE_VALUE(0x74, 29)

watchdog timer reset flag

Definition at line 64 of file at32f435_437_crm.h.

◆ CRM_WWDT_RESET_FLAG

#define CRM_WWDT_RESET_FLAG MAKE_VALUE(0x74, 30)

window watchdog timer reset flag

Definition at line 65 of file at32f435_437_crm.h.


AT32F435/437 Firmwary Library: CRM_interrupts_definition

Macros
CRM_interrupts_definition
AT32F435_437_periph_driver » CRM

crm interrupt More...

Macros

#define | CRM_LICK_STABLE_INT ((uint32_t)0x00000100)
#define | CRM_LEXT_STABLE_INT ((uint32_t)0x00000200)
#define | CRM_HICK_STABLE_INT ((uint32_t)0x00000400)
#define | CRM_HEXT_STABLE_INT ((uint32_t)0x00000800)
#define | CRM_PLL_STABLE_INT ((uint32_t)0x00001000)
#define | CRM_CLOCK_FAILURE_INT ((uint32_t)0x00800000)

Detailed Description

crm interrupt

Macro Definition Documentation

◆ CRM_CLOCK_FAILURE_INT

#define CRM_CLOCK_FAILURE_INT ((uint32_t)0x00800000)

clock failure interrupt

Definition at line 88 of file at32f435_437_crm.h.

◆ CRM_HEXT_STABLE_INT

#define CRM_HEXT_STABLE_INT ((uint32_t)0x00000800)

high speed external crystal stable interrupt

Definition at line 86 of file at32f435_437_crm.h.

◆ CRM_HICK_STABLE_INT

#define CRM_HICK_STABLE_INT ((uint32_t)0x00000400)

high speed internal clock stable interrupt

Definition at line 85 of file at32f435_437_crm.h.

◆ CRM_LEXT_STABLE_INT

#define CRM_LEXT_STABLE_INT ((uint32_t)0x00000200)

low speed external crystal stable interrupt

Definition at line 84 of file at32f435_437_crm.h.

◆ CRM_LICK_STABLE_INT

#define CRM_LICK_STABLE_INT ((uint32_t)0x00000100)

low speed internal clock stable interrupt

Definition at line 83 of file at32f435_437_crm.h.

◆ CRM_PLL_STABLE_INT

#define CRM_PLL_STABLE_INT ((uint32_t)0x00001000)

phase locking loop stable interrupt

Definition at line 87 of file at32f435_437_crm.h.


AT32F435/437 Firmwary Library: CRM_exported_types

Data Structures | Enumerations
CRM_exported_types
AT32F435_437_periph_driver » CRM

Data Structures

struct | crm_clocks_freq_type
crm clocks freqency structure More...
struct | crm_type
type define crm register all More...

Enumerations

enum crm_periph_clock_type {
CRM_GPIOA_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 0 & 0x1f)) , CRM_GPIOB_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 1 & 0x1f)) , CRM_GPIOC_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 2 & 0x1f)) , CRM_GPIOD_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 3 & 0x1f)) ,
CRM_GPIOE_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 4 & 0x1f)) , CRM_GPIOF_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 5 & 0x1f)) , CRM_GPIOG_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 6 & 0x1f)) , CRM_GPIOH_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 7 & 0x1f)) ,
CRM_CRC_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 12 & 0x1f)) , CRM_EDMA_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 21 & 0x1f)) , CRM_DMA1_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 22 & 0x1f)) , CRM_DMA2_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 24 & 0x1f)) ,
CRM_OTGFS2_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 29 & 0x1f)) , CRM_DVP_PERIPH_CLOCK = ((( 0x34 ) << 16) | ( 0 & 0x1f)) , CRM_OTGFS1_PERIPH_CLOCK = ((( 0x34 ) << 16) | ( 7 & 0x1f)) , CRM_SDIO1_PERIPH_CLOCK = ((( 0x34 ) << 16) | ( 15 & 0x1f)) ,
CRM_XMC_PERIPH_CLOCK = ((( 0x38 ) << 16) | ( 0 & 0x1f)) , CRM_QSPI1_PERIPH_CLOCK = ((( 0x38 ) << 16) | ( 1 & 0x1f)) , CRM_QSPI2_PERIPH_CLOCK = ((( 0x38 ) << 16) | ( 14 & 0x1f)) , CRM_SDIO2_PERIPH_CLOCK = ((( 0x38 ) << 16) | ( 15 & 0x1f)) ,
CRM_TMR2_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 0 & 0x1f)) , CRM_TMR3_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 1 & 0x1f)) , CRM_TMR4_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 2 & 0x1f)) , CRM_TMR5_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 3 & 0x1f)) ,
CRM_TMR6_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 4 & 0x1f)) , CRM_TMR7_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 5 & 0x1f)) , CRM_TMR12_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 6 & 0x1f)) , CRM_TMR13_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 7 & 0x1f)) ,
CRM_TMR14_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 8 & 0x1f)) , CRM_WWDT_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 11 & 0x1f)) , CRM_SPI2_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 14 & 0x1f)) , CRM_SPI3_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 15 & 0x1f)) ,
CRM_USART2_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 17 & 0x1f)) , CRM_USART3_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 18 & 0x1f)) , CRM_UART4_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 19 & 0x1f)) , CRM_UART5_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 20 & 0x1f)) ,
CRM_I2C1_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 21 & 0x1f)) , CRM_I2C2_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 22 & 0x1f)) , CRM_I2C3_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 23 & 0x1f)) , CRM_CAN1_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 25 & 0x1f)) ,
CRM_CAN2_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 26 & 0x1f)) , CRM_PWC_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 28 & 0x1f)) , CRM_DAC_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 29 & 0x1f)) , CRM_UART7_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 30 & 0x1f)) ,
CRM_UART8_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 31 & 0x1f)) , CRM_TMR1_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 0 & 0x1f)) , CRM_TMR8_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 1 & 0x1f)) , CRM_USART1_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 4 & 0x1f)) ,
CRM_USART6_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 5 & 0x1f)) , CRM_ADC1_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 8 & 0x1f)) , CRM_ADC2_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 9 & 0x1f)) , CRM_ADC3_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 10 & 0x1f)) ,
CRM_SPI1_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 12 & 0x1f)) , CRM_SPI4_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 13 & 0x1f)) , CRM_SCFG_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 14 & 0x1f)) , CRM_TMR9_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 16 & 0x1f)) ,
CRM_TMR10_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 17 & 0x1f)) , CRM_TMR11_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 18 & 0x1f)) , CRM_TMR20_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 20 & 0x1f)) , CRM_ACC_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 29 & 0x1f))
}
crm periph clock More...
enum crm_periph_reset_type {
CRM_GPIOA_PERIPH_RESET = ((( 0x10 ) << 16) | ( 0 & 0x1f)) , CRM_GPIOB_PERIPH_RESET = ((( 0x10 ) << 16) | ( 1 & 0x1f)) , CRM_GPIOC_PERIPH_RESET = ((( 0x10 ) << 16) | ( 2 & 0x1f)) , CRM_GPIOD_PERIPH_RESET = ((( 0x10 ) << 16) | ( 3 & 0x1f)) ,
CRM_GPIOE_PERIPH_RESET = ((( 0x10 ) << 16) | ( 4 & 0x1f)) , CRM_GPIOF_PERIPH_RESET = ((( 0x10 ) << 16) | ( 5 & 0x1f)) , CRM_GPIOG_PERIPH_RESET = ((( 0x10 ) << 16) | ( 6 & 0x1f)) , CRM_GPIOH_PERIPH_RESET = ((( 0x10 ) << 16) | ( 7 & 0x1f)) ,
CRM_CRC_PERIPH_RESET = ((( 0x10 ) << 16) | ( 12 & 0x1f)) , CRM_EDMA_PERIPH_RESET = ((( 0x10 ) << 16) | ( 21 & 0x1f)) , CRM_DMA1_PERIPH_RESET = ((( 0x10 ) << 16) | ( 22 & 0x1f)) , CRM_DMA2_PERIPH_RESET = ((( 0x10 ) << 16) | ( 24 & 0x1f)) ,
CRM_OTGFS2_PERIPH_RESET = ((( 0x10 ) << 16) | ( 29 & 0x1f)) , CRM_DVP_PERIPH_RESET = ((( 0x14 ) << 16) | ( 0 & 0x1f)) , CRM_OTGFS1_PERIPH_RESET = ((( 0x14 ) << 16) | ( 7 & 0x1f)) , CRM_SDIO1_PERIPH_RESET = ((( 0x14 ) << 16) | ( 15 & 0x1f)) ,
CRM_XMC_PERIPH_RESET = ((( 0x18 ) << 16) | ( 0 & 0x1f)) , CRM_QSPI1_PERIPH_RESET = ((( 0x18 ) << 16) | ( 1 & 0x1f)) , CRM_QSPI2_PERIPH_RESET = ((( 0x18 ) << 16) | ( 14 & 0x1f)) , CRM_SDIO2_PERIPH_RESET = ((( 0x18 ) << 16) | ( 15 & 0x1f)) ,
CRM_TMR2_PERIPH_RESET = ((( 0x20 ) << 16) | ( 0 & 0x1f)) , CRM_TMR3_PERIPH_RESET = ((( 0x20 ) << 16) | ( 1 & 0x1f)) , CRM_TMR4_PERIPH_RESET = ((( 0x20 ) << 16) | ( 2 & 0x1f)) , CRM_TMR5_PERIPH_RESET = ((( 0x20 ) << 16) | ( 3 & 0x1f)) ,
CRM_TMR6_PERIPH_RESET = ((( 0x20 ) << 16) | ( 4 & 0x1f)) , CRM_TMR7_PERIPH_RESET = ((( 0x20 ) << 16) | ( 5 & 0x1f)) , CRM_TMR12_PERIPH_RESET = ((( 0x20 ) << 16) | ( 6 & 0x1f)) , CRM_TMR13_PERIPH_RESET = ((( 0x20 ) << 16) | ( 7 & 0x1f)) ,
CRM_TMR14_PERIPH_RESET = ((( 0x20 ) << 16) | ( 8 & 0x1f)) , CRM_WWDT_PERIPH_RESET = ((( 0x20 ) << 16) | ( 11 & 0x1f)) , CRM_SPI2_PERIPH_RESET = ((( 0x20 ) << 16) | ( 14 & 0x1f)) , CRM_SPI3_PERIPH_RESET = ((( 0x20 ) << 16) | ( 15 & 0x1f)) ,
CRM_USART2_PERIPH_RESET = ((( 0x20 ) << 16) | ( 17 & 0x1f)) , CRM_USART3_PERIPH_RESET = ((( 0x20 ) << 16) | ( 18 & 0x1f)) , CRM_UART4_PERIPH_RESET = ((( 0x20 ) << 16) | ( 19 & 0x1f)) , CRM_UART5_PERIPH_RESET = ((( 0x20 ) << 16) | ( 20 & 0x1f)) ,
CRM_I2C1_PERIPH_RESET = ((( 0x20 ) << 16) | ( 21 & 0x1f)) , CRM_I2C2_PERIPH_RESET = ((( 0x20 ) << 16) | ( 22 & 0x1f)) , CRM_I2C3_PERIPH_RESET = ((( 0x20 ) << 16) | ( 23 & 0x1f)) , CRM_CAN1_PERIPH_RESET = ((( 0x20 ) << 16) | ( 25 & 0x1f)) ,
CRM_CAN2_PERIPH_RESET = ((( 0x20 ) << 16) | ( 26 & 0x1f)) , CRM_PWC_PERIPH_RESET = ((( 0x20 ) << 16) | ( 28 & 0x1f)) , CRM_DAC_PERIPH_RESET = ((( 0x20 ) << 16) | ( 29 & 0x1f)) , CRM_UART7_PERIPH_RESET = ((( 0x20 ) << 16) | ( 30 & 0x1f)) ,
CRM_UART8_PERIPH_RESET = ((( 0x20 ) << 16) | ( 31 & 0x1f)) , CRM_TMR1_PERIPH_RESET = ((( 0x24 ) << 16) | ( 0 & 0x1f)) , CRM_TMR8_PERIPH_RESET = ((( 0x24 ) << 16) | ( 1 & 0x1f)) , CRM_USART1_PERIPH_RESET = ((( 0x24 ) << 16) | ( 4 & 0x1f)) ,
CRM_USART6_PERIPH_RESET = ((( 0x24 ) << 16) | ( 5 & 0x1f)) , CRM_ADC_PERIPH_RESET = ((( 0x24 ) << 16) | ( 8 & 0x1f)) , CRM_SPI1_PERIPH_RESET = ((( 0x24 ) << 16) | ( 12 & 0x1f)) , CRM_SPI4_PERIPH_RESET = ((( 0x24 ) << 16) | ( 13 & 0x1f)) ,
CRM_SCFG_PERIPH_RESET = ((( 0x24 ) << 16) | ( 14 & 0x1f)) , CRM_TMR9_PERIPH_RESET = ((( 0x24 ) << 16) | ( 16 & 0x1f)) , CRM_TMR10_PERIPH_RESET = ((( 0x24 ) << 16) | ( 17 & 0x1f)) , CRM_TMR11_PERIPH_RESET = ((( 0x24 ) << 16) | ( 18 & 0x1f)) ,
CRM_TMR20_PERIPH_RESET = ((( 0x24 ) << 16) | ( 20 & 0x1f)) , CRM_ACC_PERIPH_RESET = ((( 0x24 ) << 16) | ( 29 & 0x1f))
}
crm periph reset More...
enum crm_periph_clock_lowpower_type {
CRM_GPIOA_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 0 & 0x1f)) , CRM_GPIOB_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 1 & 0x1f)) , CRM_GPIOC_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 2 & 0x1f)) , CRM_GPIOD_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 3 & 0x1f)) ,
CRM_GPIOE_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 4 & 0x1f)) , CRM_GPIOF_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 5 & 0x1f)) , CRM_GPIOG_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 6 & 0x1f)) , CRM_GPIOH_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 7 & 0x1f)) ,
CRM_CRC_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 12 & 0x1f)) , CRM_EDMA_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 21 & 0x1f)) , CRM_DMA1_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 22 & 0x1f)) , CRM_DMA2_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 24 & 0x1f)) ,
CRM_EMAC_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 25 & 0x1f)) , CRM_EMACTX_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 26 & 0x1f)) , CRM_EMACRX_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 27 & 0x1f)) , CRM_EMACPTP_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 28 & 0x1f)) ,
CRM_OTGFS2_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 29 & 0x1f)) , CRM_DVP_PERIPH_LOWPOWER = ((( 0x54 ) << 16) | ( 0 & 0x1f)) , CRM_OTGFS1_PERIPH_LOWPOWER = ((( 0x54 ) << 16) | ( 7 & 0x1f)) , CRM_SDIO1_PERIPH_LOWPOWER = ((( 0x54 ) << 16) | ( 15 & 0x1f)) ,
CRM_XMC_PERIPH_LOWPOWER = ((( 0x58 ) << 16) | ( 0 & 0x1f)) , CRM_QSPI1_PERIPH_LOWPOWER = ((( 0x58 ) << 16) | ( 1 & 0x1f)) , CRM_QSPI2_PERIPH_LOWPOWER = ((( 0x58 ) << 16) | ( 14 & 0x1f)) , CRM_SDIO2_PERIPH_LOWPOWER = ((( 0x58 ) << 16) | ( 15 & 0x1f)) ,
CRM_TMR2_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 0 & 0x1f)) , CRM_TMR3_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 1 & 0x1f)) , CRM_TMR4_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 2 & 0x1f)) , CRM_TMR5_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 3 & 0x1f)) ,
CRM_TMR6_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 4 & 0x1f)) , CRM_TMR7_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 5 & 0x1f)) , CRM_TMR12_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 6 & 0x1f)) , CRM_TMR13_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 7 & 0x1f)) ,
CRM_TMR14_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 8 & 0x1f)) , CRM_WWDT_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 11 & 0x1f)) , CRM_SPI2_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 14 & 0x1f)) , CRM_SPI3_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 15 & 0x1f)) ,
CRM_USART2_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 17 & 0x1f)) , CRM_USART3_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 18 & 0x1f)) , CRM_UART4_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 19 & 0x1f)) , CRM_UART5_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 20 & 0x1f)) ,
CRM_I2C1_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 21 & 0x1f)) , CRM_I2C2_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 22 & 0x1f)) , CRM_I2C3_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 23 & 0x1f)) , CRM_CAN1_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 25 & 0x1f)) ,
CRM_CAN2_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 26 & 0x1f)) , CRM_PWC_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 28 & 0x1f)) , CRM_DAC_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 29 & 0x1f)) , CRM_UART7_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 30 & 0x1f)) ,
CRM_UART8_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 31 & 0x1f)) , CRM_TMR1_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 0 & 0x1f)) , CRM_TMR8_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 1 & 0x1f)) , CRM_USART1_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 4 & 0x1f)) ,
CRM_USART6_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 5 & 0x1f)) , CRM_ADC1_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 8 & 0x1f)) , CRM_ADC2_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 9 & 0x1f)) , CRM_ADC3_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 10 & 0x1f)) ,
CRM_SPI1_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 12 & 0x1f)) , CRM_SPI4_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 13 & 0x1f)) , CRM_SCFG_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 14 & 0x1f)) , CRM_TMR9_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 16 & 0x1f)) ,
CRM_TMR10_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 17 & 0x1f)) , CRM_TMR11_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 18 & 0x1f)) , CRM_TMR20_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 20 & 0x1f)) , CRM_ACC_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 29 & 0x1f))
}
crm periph clock in low power mode More...
enum | crm_pll_clock_source_type { CRM_PLL_SOURCE_HICK = 0x00 , CRM_PLL_SOURCE_HEXT = 0x01 }
crm pll clock source More...
enum crm_pll_fr_type {
CRM_PLL_FR_1 = 0x00 , CRM_PLL_FR_2 = 0x01 , CRM_PLL_FR_4 = 0x02 , CRM_PLL_FR_8 = 0x03 ,
CRM_PLL_FR_16 = 0x04 , CRM_PLL_FR_32 = 0x05
}
crm pll fr More...
enum crm_clock_source_type {
CRM_CLOCK_SOURCE_HICK = 0x00 , CRM_CLOCK_SOURCE_HEXT = 0x01 , CRM_CLOCK_SOURCE_PLL = 0x02 , CRM_CLOCK_SOURCE_LEXT = 0x03 ,
CRM_CLOCK_SOURCE_LICK = 0x04
}
crm clock source More...
enum crm_ahb_div_type {
CRM_AHB_DIV_1 = 0x00 , CRM_AHB_DIV_2 = 0x08 , CRM_AHB_DIV_4 = 0x09 , CRM_AHB_DIV_8 = 0x0A ,
CRM_AHB_DIV_16 = 0x0B , CRM_AHB_DIV_64 = 0x0C , CRM_AHB_DIV_128 = 0x0D , CRM_AHB_DIV_256 = 0x0E ,
CRM_AHB_DIV_512 = 0x0F
}
crm ahb division More...
enum crm_apb1_div_type {
CRM_APB1_DIV_1 = 0x00 , CRM_APB1_DIV_2 = 0x04 , CRM_APB1_DIV_4 = 0x05 , CRM_APB1_DIV_8 = 0x06 ,
CRM_APB1_DIV_16 = 0x07
}
crm apb1 division More...
enum crm_apb2_div_type {
CRM_APB2_DIV_1 = 0x00 , CRM_APB2_DIV_2 = 0x04 , CRM_APB2_DIV_4 = 0x05 , CRM_APB2_DIV_8 = 0x06 ,
CRM_APB2_DIV_16 = 0x07
}
crm apb2 division More...
enum crm_usb_div_type {
CRM_USB_DIV_1_5 = 0x00 , CRM_USB_DIV_1 = 0x01 , CRM_USB_DIV_2_5 = 0x02 , CRM_USB_DIV_2 = 0x03 ,
CRM_USB_DIV_3_5 = 0x04 , CRM_USB_DIV_3 = 0x05 , CRM_USB_DIV_4_5 = 0x06 , CRM_USB_DIV_4 = 0x07 ,
CRM_USB_DIV_5_5 = 0x08 , CRM_USB_DIV_5 = 0x09 , CRM_USB_DIV_6_5 = 0x0A , CRM_USB_DIV_6 = 0x0B ,
CRM_USB_DIV_7 = 0x0C
}
crm usb division More...
enum crm_ertc_clock_type {
CRM_ERTC_CLOCK_NOCLK = 0x000 , CRM_ERTC_CLOCK_LEXT = 0x001 , CRM_ERTC_CLOCK_LICK = 0x002 , CRM_ERTC_CLOCK_HEXT_DIV_2 = 0x023 ,
CRM_ERTC_CLOCK_HEXT_DIV_3 = 0x033 , CRM_ERTC_CLOCK_HEXT_DIV_4 = 0x043 , CRM_ERTC_CLOCK_HEXT_DIV_5 = 0x053 , CRM_ERTC_CLOCK_HEXT_DIV_6 = 0x063 ,
CRM_ERTC_CLOCK_HEXT_DIV_7 = 0x073 , CRM_ERTC_CLOCK_HEXT_DIV_8 = 0x083 , CRM_ERTC_CLOCK_HEXT_DIV_9 = 0x093 , CRM_ERTC_CLOCK_HEXT_DIV_10 = 0x0A3 ,
CRM_ERTC_CLOCK_HEXT_DIV_11 = 0x0B3 , CRM_ERTC_CLOCK_HEXT_DIV_12 = 0x0C3 , CRM_ERTC_CLOCK_HEXT_DIV_13 = 0x0D3 , CRM_ERTC_CLOCK_HEXT_DIV_14 = 0x0E3 ,
CRM_ERTC_CLOCK_HEXT_DIV_15 = 0x0F3 , CRM_ERTC_CLOCK_HEXT_DIV_16 = 0x103 , CRM_ERTC_CLOCK_HEXT_DIV_17 = 0x113 , CRM_ERTC_CLOCK_HEXT_DIV_18 = 0x123 ,
CRM_ERTC_CLOCK_HEXT_DIV_19 = 0x133 , CRM_ERTC_CLOCK_HEXT_DIV_20 = 0x143 , CRM_ERTC_CLOCK_HEXT_DIV_21 = 0x153 , CRM_ERTC_CLOCK_HEXT_DIV_22 = 0x163 ,
CRM_ERTC_CLOCK_HEXT_DIV_23 = 0x173 , CRM_ERTC_CLOCK_HEXT_DIV_24 = 0x183 , CRM_ERTC_CLOCK_HEXT_DIV_25 = 0x193 , CRM_ERTC_CLOCK_HEXT_DIV_26 = 0x1A3 ,
CRM_ERTC_CLOCK_HEXT_DIV_27 = 0x1B3 , CRM_ERTC_CLOCK_HEXT_DIV_28 = 0x1C3 , CRM_ERTC_CLOCK_HEXT_DIV_29 = 0x1D3 , CRM_ERTC_CLOCK_HEXT_DIV_30 = 0x1E3 ,
CRM_ERTC_CLOCK_HEXT_DIV_31 = 0x1F3
}
crm ertc clock More...
enum | crm_hick_div_6_type { CRM_HICK48_DIV6 = 0x00 , CRM_HICK48_NODIV = 0x01 }
crm hick 48mhz division More...
enum | crm_sclk_type { CRM_SCLK_HICK = 0x00 , CRM_SCLK_HEXT = 0x01 , CRM_SCLK_PLL = 0x02 }
crm sclk select More...
enum | crm_clkout_index_type { CRM_CLKOUT_INDEX_1 = 0x00 , CRM_CLKOUT_INDEX_2 = 0x01 }
crm clkout index More...
enum | crm_clkout1_select_type { CRM_CLKOUT1_HICK = 0x00 , CRM_CLKOUT1_LEXT = 0x01 , CRM_CLKOUT1_HEXT = 0x02 , CRM_CLKOUT1_PLL = 0x03 }
crm clkout1 select More...
enum crm_clkout2_select_type {
CRM_CLKOUT2_SCLK = 0x00 , CRM_CLKOUT2_HEXT = 0x02 , CRM_CLKOUT2_PLL = 0x03 , CRM_CLKOUT2_USB = 0x10 ,
CRM_CLKOUT2_ADC = 0x11 , CRM_CLKOUT2_HICK = 0x12 , CRM_CLKOUT2_LICK = 0x13 , CRM_CLKOUT2_LEXT = 0x14
}
crm clkout2 select More...
enum crm_clkout_div1_type {
CRM_CLKOUT_DIV1_1 = 0x00 , CRM_CLKOUT_DIV1_2 = 0x04 , CRM_CLKOUT_DIV1_3 = 0x05 , CRM_CLKOUT_DIV1_4 = 0x06 ,
CRM_CLKOUT_DIV1_5 = 0x07
}
crm clkout division1 More...
enum crm_clkout_div2_type {
CRM_CLKOUT_DIV2_1 = 0x00 , CRM_CLKOUT_DIV2_2 = 0x08 , CRM_CLKOUT_DIV2_4 = 0x09 , CRM_CLKOUT_DIV2_8 = 0x0A ,
CRM_CLKOUT_DIV2_16 = 0x0B , CRM_CLKOUT_DIV2_64 = 0x0C , CRM_CLKOUT_DIV2_128 = 0x0D , CRM_CLKOUT_DIV2_256 = 0x0E ,
CRM_CLKOUT_DIV2_512 = 0x0F
}
crm clkout division2 More...
enum | crm_auto_step_mode_type { CRM_AUTO_STEP_MODE_DISABLE = 0x00 , CRM_AUTO_STEP_MODE_ENABLE = 0x03 }
crm auto step mode More...
enum | crm_usb_clock_source_type { CRM_USB_CLOCK_SOURCE_PLL = 0x00 , CRM_USB_CLOCK_SOURCE_HICK = 0x01 }
crm usb 48 mhz clock source select More...
enum | crm_hick_sclk_frequency_type { CRM_HICK_SCLK_8MHZ = 0x00 , CRM_HICK_SCLK_48MHZ = 0x01 }
crm hick as system clock frequency select More...
enum | crm_emac_output_pulse_type { CRM_EMAC_PULSE_125MS = 0x00 , CRM_EMAC_PULSE_1SCLK = 0x01 }
crm emac output pulse width More...

Detailed Description

Enumeration Type Documentation

◆ crm_ahb_div_type

enum crm_ahb_div_type

crm ahb division

Enumerator
CRM_AHB_DIV_1 | sclk div1 to ahbclk
CRM_AHB_DIV_2 | sclk div2 to ahbclk
CRM_AHB_DIV_4 | sclk div4 to ahbclk
CRM_AHB_DIV_8 | sclk div8 to ahbclk
CRM_AHB_DIV_16 | sclk div16 to ahbclk
CRM_AHB_DIV_64 | sclk div64 to ahbclk
CRM_AHB_DIV_128 | sclk div128 to ahbclk
CRM_AHB_DIV_256 | sclk div256 to ahbclk
CRM_AHB_DIV_512 | sclk div512 to ahbclk

Definition at line 569 of file at32f435_437_crm.h.

◆ crm_apb1_div_type

enum crm_apb1_div_type

crm apb1 division

Enumerator
CRM_APB1_DIV_1 | ahbclk div1 to apb1clk
CRM_APB1_DIV_2 | ahbclk div2 to apb1clk
CRM_APB1_DIV_4 | ahbclk div4 to apb1clk
CRM_APB1_DIV_8 | ahbclk div8 to apb1clk
CRM_APB1_DIV_16 | ahbclk div16 to apb1clk

Definition at line 585 of file at32f435_437_crm.h.

◆ crm_apb2_div_type

enum crm_apb2_div_type

crm apb2 division

Enumerator
CRM_APB2_DIV_1 | ahbclk div1 to apb2clk
CRM_APB2_DIV_2 | ahbclk div2 to apb2clk
CRM_APB2_DIV_4 | ahbclk div4 to apb2clk
CRM_APB2_DIV_8 | ahbclk div8 to apb2clk
CRM_APB2_DIV_16 | ahbclk div16 to apb2clk

Definition at line 597 of file at32f435_437_crm.h.

◆ crm_auto_step_mode_type

enum crm_auto_step_mode_type

crm auto step mode

Enumerator
CRM_AUTO_STEP_MODE_DISABLE | disable auto step mode
CRM_AUTO_STEP_MODE_ENABLE | enable auto step mode

Definition at line 751 of file at32f435_437_crm.h.

◆ crm_clkout1_select_type

enum crm_clkout1_select_type

crm clkout1 select

Enumerator
CRM_CLKOUT1_HICK | output high speed internal clock to clkout1 pin
CRM_CLKOUT1_LEXT | output low speed external crystal to clkout1 pin
CRM_CLKOUT1_HEXT | output high speed external crystal to clkout1 pin
CRM_CLKOUT1_PLL | output phase locking loop clock to clkout1 pin

Definition at line 697 of file at32f435_437_crm.h.

◆ crm_clkout2_select_type

enum crm_clkout2_select_type

crm clkout2 select

Enumerator
CRM_CLKOUT2_SCLK | output system clock to clkout2 pin
CRM_CLKOUT2_HEXT | output high speed external crystal to clkout2 pin
CRM_CLKOUT2_PLL | output phase locking loop clock to clkout2 pin
CRM_CLKOUT2_USB | output usbclk to clkout2 pin
CRM_CLKOUT2_ADC | output adcclk to clkout2 pin
CRM_CLKOUT2_HICK | output high speed internal clock to clkout2 pin
CRM_CLKOUT2_LICK | output low speed internal clock to clkout2 pin
CRM_CLKOUT2_LEXT | output low speed external crystal to clkout2 pin

Definition at line 708 of file at32f435_437_crm.h.

◆ crm_clkout_div1_type

enum crm_clkout_div1_type

crm clkout division1

Enumerator
CRM_CLKOUT_DIV1_1 | clkout division1 div1
CRM_CLKOUT_DIV1_2 | clkout division1 div2
CRM_CLKOUT_DIV1_3 | clkout division1 div3
CRM_CLKOUT_DIV1_4 | clkout division1 div4
CRM_CLKOUT_DIV1_5 | clkout division1 div5

Definition at line 723 of file at32f435_437_crm.h.

◆ crm_clkout_div2_type

enum crm_clkout_div2_type

crm clkout division2

Enumerator
CRM_CLKOUT_DIV2_1 | clkout division2 div1
CRM_CLKOUT_DIV2_2 | clkout division2 div2
CRM_CLKOUT_DIV2_4 | clkout division2 div4
CRM_CLKOUT_DIV2_8 | clkout division2 div8
CRM_CLKOUT_DIV2_16 | clkout division2 div16
CRM_CLKOUT_DIV2_64 | clkout division2 div64
CRM_CLKOUT_DIV2_128 | clkout division2 div128
CRM_CLKOUT_DIV2_256 | clkout division2 div256
CRM_CLKOUT_DIV2_512 | clkout division2 div512

Definition at line 735 of file at32f435_437_crm.h.

◆ crm_clkout_index_type

enum crm_clkout_index_type

crm clkout index

Enumerator
CRM_CLKOUT_INDEX_1 | clkout1
CRM_CLKOUT_INDEX_2 | clkout2

Definition at line 688 of file at32f435_437_crm.h.

◆ crm_clock_source_type

enum crm_clock_source_type

crm clock source

Enumerator
CRM_CLOCK_SOURCE_HICK | high speed internal clock
CRM_CLOCK_SOURCE_HEXT | high speed external crystal
CRM_CLOCK_SOURCE_PLL | phase locking loop
CRM_CLOCK_SOURCE_LEXT | low speed external crystal
CRM_CLOCK_SOURCE_LICK | low speed internal clock

Definition at line 557 of file at32f435_437_crm.h.

◆ crm_emac_output_pulse_type

enum crm_emac_output_pulse_type

crm emac output pulse width

Enumerator
CRM_EMAC_PULSE_125MS | emac output pulse width 125ms
CRM_EMAC_PULSE_1SCLK | emac output pulse width 1 system clock

Definition at line 778 of file at32f435_437_crm.h.

◆ crm_ertc_clock_type

enum crm_ertc_clock_type

crm ertc clock

Enumerator
CRM_ERTC_CLOCK_NOCLK | no clock as ertc clock source
CRM_ERTC_CLOCK_LEXT | low speed external crystal as ertc clock source
CRM_ERTC_CLOCK_LICK | low speed internal clock as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_2 | high speed external crystal div2 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_3 | high speed external crystal div3 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_4 | high speed external crystal div4 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_5 | high speed external crystal div5 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_6 | high speed external crystal div6 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_7 | high speed external crystal div7 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_8 | high speed external crystal div8 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_9 | high speed external crystal div9 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_10 | high speed external crystal div10 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_11 | high speed external crystal div11 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_12 | high speed external crystal div12 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_13 | high speed external crystal div13 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_14 | high speed external crystal div14 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_15 | high speed external crystal div15 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_16 | high speed external crystal div16 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_17 | high speed external crystal div17 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_18 | high speed external crystal div18 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_19 | high speed external crystal div19 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_20 | high speed external crystal div20 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_21 | high speed external crystal div21 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_22 | high speed external crystal div22 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_23 | high speed external crystal div23 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_24 | high speed external crystal div24 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_25 | high speed external crystal div25 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_26 | high speed external crystal div26 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_27 | high speed external crystal div27 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_28 | high speed external crystal div28 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_29 | high speed external crystal div29 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_30 | high speed external crystal div30 as ertc clock source
CRM_ERTC_CLOCK_HEXT_DIV_31 | high speed external crystal div31 as ertc clock source

Definition at line 629 of file at32f435_437_crm.h.

◆ crm_hick_div_6_type

enum crm_hick_div_6_type

crm hick 48mhz division

Enumerator
CRM_HICK48_DIV6 | fixed 8 mhz when hick is selected as sclk
CRM_HICK48_NODIV | 8 mhz or 48 mhz depend on hickdiv when hick is selected as sclk

Definition at line 669 of file at32f435_437_crm.h.

◆ crm_hick_sclk_frequency_type

enum crm_hick_sclk_frequency_type

crm hick as system clock frequency select

Enumerator
CRM_HICK_SCLK_8MHZ | fixed 8 mhz when hick is selected as sclk
CRM_HICK_SCLK_48MHZ | 8 mhz or 48 mhz depend on hickdiv when hick is selected as sclk

Definition at line 769 of file at32f435_437_crm.h.

◆ crm_periph_clock_lowpower_type

enum crm_periph_clock_lowpower_type

crm periph clock in low power mode

Enumerator
CRM_GPIOA_PERIPH_LOWPOWER | gpioa sleep mode periph clock
CRM_GPIOB_PERIPH_LOWPOWER | gpiob sleep mode periph clock
CRM_GPIOC_PERIPH_LOWPOWER | gpioc sleep mode periph clock
CRM_GPIOD_PERIPH_LOWPOWER | gpiod sleep mode periph clock
CRM_GPIOE_PERIPH_LOWPOWER | gpioe sleep mode periph clock
CRM_GPIOF_PERIPH_LOWPOWER | gpiof sleep mode periph clock
CRM_GPIOG_PERIPH_LOWPOWER | gpiog sleep mode periph clock
CRM_GPIOH_PERIPH_LOWPOWER | gpioh sleep mode periph clock
CRM_CRC_PERIPH_LOWPOWER | crc sleep mode periph clock
CRM_EDMA_PERIPH_LOWPOWER | edma sleep mode periph clock
CRM_DMA1_PERIPH_LOWPOWER | dma1 sleep mode periph clock
CRM_DMA2_PERIPH_LOWPOWER | dma2 sleep mode periph clock
CRM_EMAC_PERIPH_LOWPOWER | emac sleep mode periph clock
CRM_EMACTX_PERIPH_LOWPOWER | emac tx sleep mode periph clock
CRM_EMACRX_PERIPH_LOWPOWER | emac rx sleep mode periph clock
CRM_EMACPTP_PERIPH_LOWPOWER | emac ptp sleep mode periph clock
CRM_OTGFS2_PERIPH_LOWPOWER | otgfs2 sleep mode periph clock
CRM_DVP_PERIPH_LOWPOWER | dvp sleep mode periph clock
CRM_OTGFS1_PERIPH_LOWPOWER | otgfs1 sleep mode periph clock
CRM_SDIO1_PERIPH_LOWPOWER | sdio1 sleep mode periph clock
CRM_XMC_PERIPH_LOWPOWER | xmc sleep mode periph clock
CRM_QSPI1_PERIPH_LOWPOWER | qspi1 sleep mode periph clock
CRM_QSPI2_PERIPH_LOWPOWER | qspi2 sleep mode periph clock
CRM_SDIO2_PERIPH_LOWPOWER | sdio2 sleep mode periph clock
CRM_TMR2_PERIPH_LOWPOWER | tmr2 sleep mode periph clock
CRM_TMR3_PERIPH_LOWPOWER | tmr3 sleep mode periph clock
CRM_TMR4_PERIPH_LOWPOWER | tmr4 sleep mode periph clock
CRM_TMR5_PERIPH_LOWPOWER | tmr5 sleep mode periph clock
CRM_TMR6_PERIPH_LOWPOWER | tmr6 sleep mode periph clock
CRM_TMR7_PERIPH_LOWPOWER | tmr7 sleep mode periph clock
CRM_TMR12_PERIPH_LOWPOWER | tmr12 sleep mode periph clock
CRM_TMR13_PERIPH_LOWPOWER | tmr13 sleep mode periph clock
CRM_TMR14_PERIPH_LOWPOWER | tmr14 sleep mode periph clock
CRM_WWDT_PERIPH_LOWPOWER | wwdt sleep mode periph clock
CRM_SPI2_PERIPH_LOWPOWER | spi2 sleep mode periph clock
CRM_SPI3_PERIPH_LOWPOWER | spi3 sleep mode periph clock
CRM_USART2_PERIPH_LOWPOWER | usart2 sleep mode periph clock
CRM_USART3_PERIPH_LOWPOWER | usart3 sleep mode periph clock
CRM_UART4_PERIPH_LOWPOWER | uart4 sleep mode periph clock
CRM_UART5_PERIPH_LOWPOWER | uart5 sleep mode periph clock
CRM_I2C1_PERIPH_LOWPOWER | i2c1 sleep mode periph clock
CRM_I2C2_PERIPH_LOWPOWER | i2c2 sleep mode periph clock
CRM_I2C3_PERIPH_LOWPOWER | i2c3 sleep mode periph clock
CRM_CAN1_PERIPH_LOWPOWER | can1 sleep mode periph clock
CRM_CAN2_PERIPH_LOWPOWER | can2 sleep mode periph clock
CRM_PWC_PERIPH_LOWPOWER | pwc sleep mode periph clock
CRM_DAC_PERIPH_LOWPOWER | dac sleep mode periph clock
CRM_UART7_PERIPH_LOWPOWER | uart7 sleep mode periph clock
CRM_UART8_PERIPH_LOWPOWER | uart8 sleep mode periph clock
CRM_TMR1_PERIPH_LOWPOWER | tmr1 sleep mode periph clock
CRM_TMR8_PERIPH_LOWPOWER | tmr8 sleep mode periph clock
CRM_USART1_PERIPH_LOWPOWER | usart1 sleep mode periph clock
CRM_USART6_PERIPH_LOWPOWER | usart6 sleep mode periph clock
CRM_ADC1_PERIPH_LOWPOWER | adc1 sleep mode periph clock
CRM_ADC2_PERIPH_LOWPOWER | adc2 sleep mode periph clock
CRM_ADC3_PERIPH_LOWPOWER | adc3 sleep mode periph clock
CRM_SPI1_PERIPH_LOWPOWER | spi1 sleep mode periph clock
CRM_SPI4_PERIPH_LOWPOWER | spi4 sleep mode periph clock
CRM_SCFG_PERIPH_LOWPOWER | scfg sleep mode periph clock
CRM_TMR9_PERIPH_LOWPOWER | tmr9 sleep mode periph clock
CRM_TMR10_PERIPH_LOWPOWER | tmr10 sleep mode periph clock
CRM_TMR11_PERIPH_LOWPOWER | tmr11 sleep mode periph clock
CRM_TMR20_PERIPH_LOWPOWER | tmr20 sleep mode periph clock
CRM_ACC_PERIPH_LOWPOWER | acc sleep mode periph clock

Definition at line 388 of file at32f435_437_crm.h.

◆ crm_periph_clock_type

enum crm_periph_clock_type

crm periph clock

Enumerator
CRM_GPIOA_PERIPH_CLOCK | gpioa periph clock
CRM_GPIOB_PERIPH_CLOCK | gpiob periph clock
CRM_GPIOC_PERIPH_CLOCK | gpioc periph clock
CRM_GPIOD_PERIPH_CLOCK | gpiod periph clock
CRM_GPIOE_PERIPH_CLOCK | gpioe periph clock
CRM_GPIOF_PERIPH_CLOCK | gpiof periph clock
CRM_GPIOG_PERIPH_CLOCK | gpiog periph clock
CRM_GPIOH_PERIPH_CLOCK | gpioh periph clock
CRM_CRC_PERIPH_CLOCK | crc periph clock
CRM_EDMA_PERIPH_CLOCK | edma periph clock
CRM_DMA1_PERIPH_CLOCK | dma1 periph clock
CRM_DMA2_PERIPH_CLOCK | dma2 periph clock
CRM_OTGFS2_PERIPH_CLOCK | otgfs2 periph clock
CRM_DVP_PERIPH_CLOCK | dvp periph clock
CRM_OTGFS1_PERIPH_CLOCK | otgfs1 periph clock
CRM_SDIO1_PERIPH_CLOCK | sdio1 periph clock
CRM_XMC_PERIPH_CLOCK | xmc periph clock
CRM_QSPI1_PERIPH_CLOCK | qspi1 periph clock
CRM_QSPI2_PERIPH_CLOCK | qspi2 periph clock
CRM_SDIO2_PERIPH_CLOCK | sdio2 periph clock
CRM_TMR2_PERIPH_CLOCK | tmr2 periph clock
CRM_TMR3_PERIPH_CLOCK | tmr3 periph clock
CRM_TMR4_PERIPH_CLOCK | tmr4 periph clock
CRM_TMR5_PERIPH_CLOCK | tmr5 periph clock
CRM_TMR6_PERIPH_CLOCK | tmr6 periph clock
CRM_TMR7_PERIPH_CLOCK | tmr7 periph clock
CRM_TMR12_PERIPH_CLOCK | tmr12 periph clock
CRM_TMR13_PERIPH_CLOCK | tmr13 periph clock
CRM_TMR14_PERIPH_CLOCK | tmr14 periph clock
CRM_WWDT_PERIPH_CLOCK | wwdt periph clock
CRM_SPI2_PERIPH_CLOCK | spi2 periph clock
CRM_SPI3_PERIPH_CLOCK | spi3 periph clock
CRM_USART2_PERIPH_CLOCK | usart2 periph clock
CRM_USART3_PERIPH_CLOCK | usart3 periph clock
CRM_UART4_PERIPH_CLOCK | uart4 periph clock
CRM_UART5_PERIPH_CLOCK | uart5 periph clock
CRM_I2C1_PERIPH_CLOCK | i2c1 periph clock
CRM_I2C2_PERIPH_CLOCK | i2c2 periph clock
CRM_I2C3_PERIPH_CLOCK | i2c3 periph clock
CRM_CAN1_PERIPH_CLOCK | can1 periph clock
CRM_CAN2_PERIPH_CLOCK | can2 periph clock
CRM_PWC_PERIPH_CLOCK | pwc periph clock
CRM_DAC_PERIPH_CLOCK | dac periph clock
CRM_UART7_PERIPH_CLOCK | uart7 periph clock
CRM_UART8_PERIPH_CLOCK | uart8 periph clock
CRM_TMR1_PERIPH_CLOCK | tmr1 periph clock
CRM_TMR8_PERIPH_CLOCK | tmr8 periph clock
CRM_USART1_PERIPH_CLOCK | usart1 periph clock
CRM_USART6_PERIPH_CLOCK | usart6 periph clock
CRM_ADC1_PERIPH_CLOCK | adc1 periph clock
CRM_ADC2_PERIPH_CLOCK | adc2 periph clock
CRM_ADC3_PERIPH_CLOCK | adc3 periph clock
CRM_SPI1_PERIPH_CLOCK | spi1 periph clock
CRM_SPI4_PERIPH_CLOCK | spi4 periph clock
CRM_SCFG_PERIPH_CLOCK | scfg periph clock
CRM_TMR9_PERIPH_CLOCK | tmr9 periph clock
CRM_TMR10_PERIPH_CLOCK | tmr10 periph clock
CRM_TMR11_PERIPH_CLOCK | tmr11 periph clock
CRM_TMR20_PERIPH_CLOCK | tmr20 periph clock
CRM_ACC_PERIPH_CLOCK | acc periph clock

Definition at line 101 of file at32f435_437_crm.h.

◆ crm_periph_reset_type

enum crm_periph_reset_type

crm periph reset

Enumerator
CRM_GPIOA_PERIPH_RESET | gpioa periph reset
CRM_GPIOB_PERIPH_RESET | gpiob periph reset
CRM_GPIOC_PERIPH_RESET | gpioc periph reset
CRM_GPIOD_PERIPH_RESET | gpiod periph reset
CRM_GPIOE_PERIPH_RESET | gpioe periph reset
CRM_GPIOF_PERIPH_RESET | gpiof periph reset
CRM_GPIOG_PERIPH_RESET | gpiog periph reset
CRM_GPIOH_PERIPH_RESET | gpioh periph reset
CRM_CRC_PERIPH_RESET | crc periph reset
CRM_EDMA_PERIPH_RESET | edma periph reset
CRM_DMA1_PERIPH_RESET | dma1 periph reset
CRM_DMA2_PERIPH_RESET | dma2 periph reset
CRM_OTGFS2_PERIPH_RESET | otgfs2 periph reset
CRM_DVP_PERIPH_RESET | dvp periph reset
CRM_OTGFS1_PERIPH_RESET | otgfs1 periph reset
CRM_SDIO1_PERIPH_RESET | sdio1 periph reset
CRM_XMC_PERIPH_RESET | xmc periph reset
CRM_QSPI1_PERIPH_RESET | qspi1 periph reset
CRM_QSPI2_PERIPH_RESET | qspi2 periph reset
CRM_SDIO2_PERIPH_RESET | sdio2 periph reset
CRM_TMR2_PERIPH_RESET | tmr2 periph reset
CRM_TMR3_PERIPH_RESET | tmr3 periph reset
CRM_TMR4_PERIPH_RESET | tmr4 periph reset
CRM_TMR5_PERIPH_RESET | tmr5 periph reset
CRM_TMR6_PERIPH_RESET | tmr6 periph reset
CRM_TMR7_PERIPH_RESET | tmr7 periph reset
CRM_TMR12_PERIPH_RESET | tmr12 periph reset
CRM_TMR13_PERIPH_RESET | tmr13 periph reset
CRM_TMR14_PERIPH_RESET | tmr14 periph reset
CRM_WWDT_PERIPH_RESET | wwdt periph reset
CRM_SPI2_PERIPH_RESET | spi2 periph reset
CRM_SPI3_PERIPH_RESET | spi3 periph reset
CRM_USART2_PERIPH_RESET | usart2 periph reset
CRM_USART3_PERIPH_RESET | usart3 periph reset
CRM_UART4_PERIPH_RESET | uart4 periph reset
CRM_UART5_PERIPH_RESET | uart5 periph reset
CRM_I2C1_PERIPH_RESET | i2c1 periph reset
CRM_I2C2_PERIPH_RESET | i2c2 periph reset
CRM_I2C3_PERIPH_RESET | i2c3 periph reset
CRM_CAN1_PERIPH_RESET | can1 periph reset
CRM_CAN2_PERIPH_RESET | can2 periph reset
CRM_PWC_PERIPH_RESET | pwc periph reset
CRM_DAC_PERIPH_RESET | dac periph reset
CRM_UART7_PERIPH_RESET | uart7 periph reset
CRM_UART8_PERIPH_RESET | uart8 periph reset
CRM_TMR1_PERIPH_RESET | tmr1 periph reset
CRM_TMR8_PERIPH_RESET | tmr8 periph reset
CRM_USART1_PERIPH_RESET | usart1 periph reset
CRM_USART6_PERIPH_RESET | usart6 periph reset
CRM_ADC_PERIPH_RESET | adc periph reset
CRM_SPI1_PERIPH_RESET | spi1 periph reset
CRM_SPI4_PERIPH_RESET | spi4 periph reset
CRM_SCFG_PERIPH_RESET | scfg periph reset
CRM_TMR9_PERIPH_RESET | tmr9 periph reset
CRM_TMR10_PERIPH_RESET | tmr10 periph reset
CRM_TMR11_PERIPH_RESET | tmr11 periph reset
CRM_TMR20_PERIPH_RESET | tmr20 periph reset
CRM_ACC_PERIPH_RESET | acc periph reset

Definition at line 248 of file at32f435_437_crm.h.

◆ crm_pll_clock_source_type

enum crm_pll_clock_source_type

crm pll clock source

Enumerator
CRM_PLL_SOURCE_HICK | high speed internal clock as pll reference clock source
CRM_PLL_SOURCE_HEXT | high speed external crystal as pll reference clock source

Definition at line 535 of file at32f435_437_crm.h.

◆ crm_pll_fr_type

enum crm_pll_fr_type

crm pll fr

Enumerator
CRM_PLL_FR_1 | pll post-division div1
CRM_PLL_FR_2 | pll post-division div2
CRM_PLL_FR_4 | pll post-division div4
CRM_PLL_FR_8 | pll post-division div8
CRM_PLL_FR_16 | pll post-division div16
CRM_PLL_FR_32 | pll post-division div32

Definition at line 544 of file at32f435_437_crm.h.

◆ crm_sclk_type

enum crm_sclk_type

crm sclk select

Enumerator
CRM_SCLK_HICK | select high speed internal clock as sclk
CRM_SCLK_HEXT | select high speed external crystal as sclk
CRM_SCLK_PLL | select phase locking loop clock as sclk

Definition at line 678 of file at32f435_437_crm.h.

◆ crm_usb_clock_source_type

enum crm_usb_clock_source_type

crm usb 48 mhz clock source select

Enumerator
CRM_USB_CLOCK_SOURCE_PLL | select phase locking loop clock as usb clock source
CRM_USB_CLOCK_SOURCE_HICK | select high speed internal clock as usb clock source

Definition at line 760 of file at32f435_437_crm.h.

◆ crm_usb_div_type

enum crm_usb_div_type

crm usb division

Enumerator
CRM_USB_DIV_1_5 | pllclk div1.5 to usbclk
CRM_USB_DIV_1 | pllclk div1 to usbclk
CRM_USB_DIV_2_5 | pllclk div2.5 to usbclk
CRM_USB_DIV_2 | pllclk div2 to usbclk
CRM_USB_DIV_3_5 | pllclk div3.5 to usbclk
CRM_USB_DIV_3 | pllclk div3 to usbclk
CRM_USB_DIV_4_5 | pllclk div4.5 to usbclk
CRM_USB_DIV_4 | pllclk div4 to usbclk
CRM_USB_DIV_5_5 | pllclk div5.5 to usbclk
CRM_USB_DIV_5 | pllclk div5 to usbclk
CRM_USB_DIV_6_5 | pllclk div6.5 to usbclk
CRM_USB_DIV_6 | pllclk div6 to usbclk
CRM_USB_DIV_7 | pllclk div7 to usbclk

Definition at line 609 of file at32f435_437_crm.h.


AT32F435/437 Firmwary Library: crm_clocks_freq_type Struct Reference

Data Fields
crm_clocks_freq_type Struct Reference
AT32F435_437_periph_driver » CRM » CRM_exported_types

crm clocks freqency structure More...

#include <at32f435_437_crm.h>

Data Fields

uint32_t | sclk_freq
uint32_t | ahb_freq
uint32_t | apb2_freq
uint32_t | apb1_freq

Detailed Description

crm clocks freqency structure

Definition at line 787 of file at32f435_437_crm.h.

Field Documentation

◆ ahb_freq

uint32_t crm_clocks_freq_type::ahb_freq

ahb bus clock frequency

Definition at line 790 of file at32f435_437_crm.h.

Referenced by crm_clocks_freq_get(), emac_clock_range_set(), emac_tmr_init(), and tmr_init().

◆ apb1_freq

uint32_t crm_clocks_freq_type::apb1_freq

apb1 bus clock frequency

Definition at line 792 of file at32f435_437_crm.h.

Referenced by crm_clocks_freq_get(), lick_frequency_get(), main(), usart_configuration(), and usart_init().

◆ apb2_freq

uint32_t crm_clocks_freq_type::apb2_freq

apb2 bus clock frequency

Definition at line 791 of file at32f435_437_crm.h.

Referenced by crm_clocks_freq_get(), main(), and usart_init().

◆ sclk_freq

uint32_t crm_clocks_freq_type::sclk_freq

system clock frequency

Definition at line 789 of file at32f435_437_crm.h.

Referenced by crm_clocks_freq_get(), i2s_init(), main(), SysTick_Configuration(), tmr1_config(), tmr2_config(), and TMR3_GLOBAL_IRQHandler().

The documentation for this struct was generated from the following file:
  • at32f435_437_crm.h


AT32F435/437 Firmwary Library: crm_type Struct Reference

Data Fields
crm_type Struct Reference
AT32F435_437_periph_driver » CRM » CRM_exported_types

type define crm register all More...

#include <at32f435_437_crm.h>

Data Fields

union {
__IO uint32_t ctrl
struct {
__IO uint32_t hicken: 1
__IO uint32_t hickstbl: 1
__IO uint32_t hicktrim: 6
__IO uint32_t hickcal: 8
__IO uint32_t hexten: 1
__IO uint32_t hextstbl: 1
__IO uint32_t hextbyps: 1
__IO uint32_t cfden: 1
__IO uint32_t reserved1: 4
__IO uint32_t pllen: 1
__IO uint32_t pllstbl: 1
__IO uint32_t reserved2: 6
} ctrl_bit
};
crm ctrl register, offset:0x00 More...
union {
__IO uint32_t pllcfg
struct {
__IO uint32_t pllms: 4
__IO uint32_t reserved1: 2
__IO uint32_t pllns: 9
__IO uint32_t reserved2: 1
__IO uint32_t pllfr: 3
__IO uint32_t reserved3: 3
__IO uint32_t pllrcs: 1
__IO uint32_t reserved4: 9
} pllcfg_bit
};
crm pllcfg register, offset:0x04 More...
union {
__IO uint32_t cfg
struct {
__IO uint32_t sclksel: 2
__IO uint32_t sclksts: 2
__IO uint32_t ahbdiv: 4
__IO uint32_t reserved1: 2
__IO uint32_t apb1div: 3
__IO uint32_t apb2div: 3
__IO uint32_t ertcdiv: 5
__IO uint32_t clkout1_sel: 2
__IO uint32_t reserved2: 1
__IO uint32_t clkout1div1: 3
__IO uint32_t clkout2div1: 3
__IO uint32_t clkout2_sel1: 2
} cfg_bit
};
crm cfg register, offset:0x08 More...
union {
__IO uint32_t clkint
struct {
__IO uint32_t lickstblf: 1
__IO uint32_t lextstblf: 1
__IO uint32_t hickstblf: 1
__IO uint32_t hextstblf: 1
__IO uint32_t pllstblf: 1
__IO uint32_t reserved1: 2
__IO uint32_t cfdf: 1
__IO uint32_t lickstblien: 1
__IO uint32_t lextstblien: 1
__IO uint32_t hickstblien: 1
__IO uint32_t hextstblien: 1
__IO uint32_t pllstblien: 1
__IO uint32_t reserved2: 3
__IO uint32_t lickstblfc: 1
__IO uint32_t lextstblfc: 1
__IO uint32_t hickstblfc: 1
__IO uint32_t hextstblfc: 1
__IO uint32_t pllstblfc: 1
__IO uint32_t reserved3: 2
__IO uint32_t cfdfc: 1
__IO uint32_t reserved4: 8
} clkint_bit
};
crm clkint register, offset:0x0C More...
union {
__IO uint32_t ahbrst1
struct {
__IO uint32_t gpioarst: 1
__IO uint32_t gpiobrst: 1
__IO uint32_t gpiocrst: 1
__IO uint32_t gpiodrst: 1
__IO uint32_t gpioerst: 1
__IO uint32_t gpiofrst: 1
__IO uint32_t gpiogrst: 1
__IO uint32_t gpiohrst: 1
__IO uint32_t reserved1: 4
__IO uint32_t crcrst: 1
__IO uint32_t reserved2: 8
__IO uint32_t edmarst: 1
__IO uint32_t dma1rst: 1
__IO uint32_t reserved3: 1
__IO uint32_t dma2rst: 1
__IO uint32_t reserved4: 4
__IO uint32_t otgfs2rst: 1
__IO uint32_t reserved5: 2
} ahbrst1_bit
};
crm ahbrst1 register, offset:0x10 More...
union {
__IO uint32_t ahbrst2
struct {
__IO uint32_t dvprst: 1
__IO uint32_t reserved1: 6
__IO uint32_t otgfs1rst: 1
__IO uint32_t reserved2: 7
__IO uint32_t sdio1rst: 1
__IO uint32_t reserved3: 16
} ahbrst2_bit
};
crm ahbrst2 register, offset:0x14 More...
union {
__IO uint32_t ahbrst3
struct {
__IO uint32_t xmcrst: 1
__IO uint32_t qspi1rst: 1
__IO uint32_t reserved1: 12
__IO uint32_t qspi2rst: 1
__IO uint32_t sdio2rst: 1
__IO uint32_t reserved3: 16
} ahbrst3_bit
};
crm ahbrst3 register, offset:0x18 More...
union {
__IO uint32_t apb1rst
struct {
__IO uint32_t tmr2rst: 1
__IO uint32_t tmr3rst: 1
__IO uint32_t tmr4rst: 1
__IO uint32_t tmr5rst: 1
__IO uint32_t tmr6rst: 1
__IO uint32_t tmr7rst: 1
__IO uint32_t tmr12rst: 1
__IO uint32_t tmr13rst: 1
__IO uint32_t adc14rst: 1
__IO uint32_t reserved1: 2
__IO uint32_t wwdtrst: 1
__IO uint32_t reserved2: 2
__IO uint32_t spi2rst: 1
__IO uint32_t spi3rst: 1
__IO uint32_t reserved3: 1
__IO uint32_t usart2rst: 1
__IO uint32_t usart3rst: 1
__IO uint32_t uart4rst: 1
__IO uint32_t uart5rst: 1
__IO uint32_t i2c1rst: 1
__IO uint32_t i2c2rst: 1
__IO uint32_t i2c3rst: 1
__IO uint32_t reserved4: 1
__IO uint32_t can1rst: 1
__IO uint32_t can2rst: 1
__IO uint32_t reserved5: 1
__IO uint32_t pwcrst: 1
__IO uint32_t dacrst: 1
__IO uint32_t uart7rst: 1
__IO uint32_t uart8rst: 1
} apb1rst_bit
};
crm apb1rst register, offset:0x20 More...
union {
__IO uint32_t apb2rst
struct {
__IO uint32_t tmr1rst: 1
__IO uint32_t tmr8rst: 1
__IO uint32_t reserved1: 2
__IO uint32_t usart1rst: 1
__IO uint32_t usart6rst: 1
__IO uint32_t reserved2: 2
__IO uint32_t adcrst: 1
__IO uint32_t reserved3: 3
__IO uint32_t spi1rst: 1
__IO uint32_t spi4rst: 1
__IO uint32_t scfgrst: 1
__IO uint32_t reserved4: 1
__IO uint32_t tmr9rst: 1
__IO uint32_t tmr10rst: 1
__IO uint32_t tmr11rst: 1
__IO uint32_t reserved5: 1
__IO uint32_t tmr20rst: 1
__IO uint32_t reserved6: 8
__IO uint32_t accrst: 1
__IO uint32_t reserved7: 2
} apb2rst_bit
};
crm apb2rst register, offset:0x24 More...
union {
__IO uint32_t ahben1
struct {
__IO uint32_t gpioaen: 1
__IO uint32_t gpioben: 1
__IO uint32_t gpiocen: 1
__IO uint32_t gpioden: 1
__IO uint32_t gpioeen: 1
__IO uint32_t gpiofen: 1
__IO uint32_t gpiogen: 1
__IO uint32_t gpiohen: 1
__IO uint32_t reserved1: 4
__IO uint32_t crcen: 1
__IO uint32_t reserved2: 8
__IO uint32_t edmaen: 1
__IO uint32_t dma1en: 1
__IO uint32_t reserved3: 1
__IO uint32_t dma2en: 1
__IO uint32_t reserved4: 4
__IO uint32_t otgfs2en: 1
__IO uint32_t reserved5: 2
} ahben1_bit
};
crm ahben1 register, offset:0x30 More...
union {
__IO uint32_t ahben2
struct {
__IO uint32_t dvpen: 1
__IO uint32_t reserved1: 6
__IO uint32_t otgfs1en: 1
__IO uint32_t reserved2: 7
__IO uint32_t sdio1en: 1
__IO uint32_t reserved3: 16
} ahben2_bit
};
crm ahben2 register, offset:0x34 More...
union {
__IO uint32_t ahben3
struct {
__IO uint32_t xmcen: 1
__IO uint32_t qspi1en: 1
__IO uint32_t reserved1: 12
__IO uint32_t qspi2en: 1
__IO uint32_t sdio2en: 1
__IO uint32_t reserved3: 16
} ahben3_bit
};
crm ahben3 register, offset:0x38 More...
union {
__IO uint32_t apb1en
struct {
__IO uint32_t tmr2en: 1
__IO uint32_t tmr3en: 1
__IO uint32_t tmr4en: 1
__IO uint32_t tmr5en: 1
__IO uint32_t tmr6en: 1
__IO uint32_t tmr7en: 1
__IO uint32_t tmr12en: 1
__IO uint32_t tmr13en: 1
__IO uint32_t adc14en: 1
__IO uint32_t reserved1: 2
__IO uint32_t wwdten: 1
__IO uint32_t reserved2: 2
__IO uint32_t spi2en: 1
__IO uint32_t spi3en: 1
__IO uint32_t reserved3: 1
__IO uint32_t usart2en: 1
__IO uint32_t usart3en: 1
__IO uint32_t uart4en: 1
__IO uint32_t uart5en: 1
__IO uint32_t i2c1en: 1
__IO uint32_t i2c2en: 1
__IO uint32_t i2c3en: 1
__IO uint32_t reserved4: 1
__IO uint32_t can1en: 1
__IO uint32_t can2en: 1
__IO uint32_t reserved5: 1
__IO uint32_t pwcen: 1
__IO uint32_t dacen: 1
__IO uint32_t uart7en: 1
__IO uint32_t uart8en: 1
} apb1en_bit
};
crm apb1en register, offset:0x40 More...
union {
__IO uint32_t apb2en
struct {
__IO uint32_t tmr1en: 1
__IO uint32_t tmr8en: 1
__IO uint32_t reserved1: 2
__IO uint32_t usart1en: 1
__IO uint32_t usart6en: 1
__IO uint32_t reserved2: 2
__IO uint32_t adcen: 1
__IO uint32_t reserved3: 3
__IO uint32_t spi1en: 1
__IO uint32_t spi4en: 1
__IO uint32_t scfgen: 1
__IO uint32_t reserved4: 1
__IO uint32_t tmr9en: 1
__IO uint32_t tmr10en: 1
__IO uint32_t tmr11en: 1
__IO uint32_t reserved5: 1
__IO uint32_t tmr20en: 1
__IO uint32_t reserved6: 8
__IO uint32_t accen: 1
__IO uint32_t reserved7: 2
} apb2en_bit
};
crm apb2en register, offset:0x44 More...
union {
__IO uint32_t ahblpen1
struct {
__IO uint32_t gpioalpen: 1
__IO uint32_t gpioblpen: 1
__IO uint32_t gpioclpen: 1
__IO uint32_t gpiodlpen: 1
__IO uint32_t gpioelpen: 1
__IO uint32_t gpioflpen: 1
__IO uint32_t gpioglpen: 1
__IO uint32_t gpiohlpen: 1
__IO uint32_t reserved1: 4
__IO uint32_t crclpen: 1
__IO uint32_t reserved2: 8
__IO uint32_t edmalpen: 1
__IO uint32_t dma1lpen: 1
__IO uint32_t reserved3: 1
__IO uint32_t dma2lpen: 1
__IO uint32_t reserved4: 4
__IO uint32_t otgfs2lpen: 1
__IO uint32_t reserved5: 2
} ahblpen1_bit
};
crm ahblpen1 register, offset:0x50 More...
union {
__IO uint32_t ahblpen2
struct {
__IO uint32_t dvplpen: 1
__IO uint32_t reserved1: 6
__IO uint32_t otgfs1lpen: 1
__IO uint32_t reserved2: 7
__IO uint32_t sdio1lpen: 1
__IO uint32_t reserved3: 16
} ahblpen2_bit
};
crm ahblpen2 register, offset:0x54 More...
union {
__IO uint32_t ahblpen3
struct {
__IO uint32_t xmclpen: 1
__IO uint32_t qspi1lpen: 1
__IO uint32_t reserved1: 12
__IO uint32_t qspi2lpen: 1
__IO uint32_t sdio2lpen: 1
__IO uint32_t reserved3: 16
} ahblpen3_bit
};
crm ahblpen3 register, offset:0x58 More...
union {
__IO uint32_t apb1lpen
struct {
__IO uint32_t tmr2lpen: 1
__IO uint32_t tmr3lpen: 1
__IO uint32_t tmr4lpen: 1
__IO uint32_t tmr5lpen: 1
__IO uint32_t tmr6lpen: 1
__IO uint32_t tmr7lpen: 1
__IO uint32_t tmr12lpen: 1
__IO uint32_t tmr13lpen: 1
__IO uint32_t adc14lpen: 1
__IO uint32_t reserved1: 2
__IO uint32_t wwdtlpen: 1
__IO uint32_t reserved2: 2
__IO uint32_t spi2lpen: 1
__IO uint32_t spi3lpen: 1
__IO uint32_t reserved3: 1
__IO uint32_t usart2lpen: 1
__IO uint32_t usart3lpen: 1
__IO uint32_t uart4lpen: 1
__IO uint32_t uart5lpen: 1
__IO uint32_t i2c1lpen: 1
__IO uint32_t i2c2lpen: 1
__IO uint32_t i2c3lpen: 1
__IO uint32_t reserved4: 1
__IO uint32_t can1lpen: 1
__IO uint32_t can2lpen: 1
__IO uint32_t reserved5: 1
__IO uint32_t pwclpen: 1
__IO uint32_t daclpen: 1
__IO uint32_t uart7lpen: 1
__IO uint32_t uart8lpen: 1
} apb1lpen_bit
};
crm apb1lpen register, offset:0x60 More...
union {
__IO uint32_t apb2lpen
struct {
__IO uint32_t tmr1lpen: 1
__IO uint32_t tmr8lpen: 1
__IO uint32_t reserved1: 2
__IO uint32_t usart1lpen: 1
__IO uint32_t usart6lpen: 1
__IO uint32_t reserved2: 2
__IO uint32_t adclpen: 1
__IO uint32_t reserved3: 3
__IO uint32_t spi1lpen: 1
__IO uint32_t spi4lpen: 1
__IO uint32_t scfglpen: 1
__IO uint32_t reserved4: 1
__IO uint32_t tmr9lpen: 1
__IO uint32_t tmr10lpen: 1
__IO uint32_t tmr11lpen: 1
__IO uint32_t reserved5: 1
__IO uint32_t tmr20lpen: 1
__IO uint32_t reserved6: 8
__IO uint32_t acclpen: 1
__IO uint32_t reserved7: 2
} apb2lpen_bit
};
crm apb2lpen register, offset:0x64 More...
union {
__IO uint32_t bpdc
struct {
__IO uint32_t lexten: 1
__IO uint32_t lextstbl: 1
__IO uint32_t lextbyps: 1
__IO uint32_t reserved1: 5
__IO uint32_t ertcsel: 2
__IO uint32_t reserved2: 5
__IO uint32_t ertcen: 1
__IO uint32_t bpdrst: 1
__IO uint32_t reserved3: 15
} bpdc_bit
};
crm bpdc register, offset:0x70 More...
union {
__IO uint32_t ctrlsts
struct {
__IO uint32_t licken: 1
__IO uint32_t lickstbl: 1
__IO uint32_t reserved1: 22
__IO uint32_t rstfc: 1
__IO uint32_t reserved2: 1
__IO uint32_t nrstf: 1
__IO uint32_t porrstf: 1
__IO uint32_t swrstf: 1
__IO uint32_t wdtrstf: 1
__IO uint32_t wwdtrstf: 1
__IO uint32_t lprstf: 1
} ctrlsts_bit
};
crm ctrlsts register, offset:0x74 More...
union {
__IO uint32_t misc1
struct {
__IO uint32_t hickcal_key: 8
__IO uint32_t reserved1: 4
__IO uint32_t hickdiv: 1
__IO uint32_t hick_to_usb: 1
__IO uint32_t hick_to_sclk: 1
__IO uint32_t reserved2: 1
__IO uint32_t clkout2_sel2: 4
__IO uint32_t reserved3: 4
__IO uint32_t clkout1div2: 4
__IO uint32_t clkout2div2: 4
} misc1_bit
};
crm misc1 register, offset:0xA0 More...
union {
__IO uint32_t misc2
struct {
__IO uint32_t reserved1: 4
__IO uint32_t auto_step_en: 2
__IO uint32_t reserved2: 2
__IO uint32_t clk_to_tmr: 1
__IO uint32_t emac_pps_sel: 1
__IO uint32_t reserved3: 2
__IO uint32_t usbdiv: 4
__IO uint32_t reserved4: 16
} misc2_bit
};
crm misc2 register, offset:0xA4 More...

Detailed Description

type define crm register all

Definition at line 798 of file at32f435_437_crm.h.

Field Documentation

◆

union { ... } crm_type::@169

crm ctrl register, offset:0x00

◆

union { ... } crm_type::@171

crm pllcfg register, offset:0x04

◆

union { ... } crm_type::@173

crm cfg register, offset:0x08

◆

union { ... } crm_type::@175

crm clkint register, offset:0x0C

◆

union { ... } crm_type::@177

crm ahbrst1 register, offset:0x10

◆

union { ... } crm_type::@179

crm ahbrst2 register, offset:0x14

◆

union { ... } crm_type::@181

crm ahbrst3 register, offset:0x18

◆

union { ... } crm_type::@183

crm apb1rst register, offset:0x20

◆

union { ... } crm_type::@185

crm apb2rst register, offset:0x24

◆

union { ... } crm_type::@187

crm ahben1 register, offset:0x30

◆

union { ... } crm_type::@189

crm ahben2 register, offset:0x34

◆

union { ... } crm_type::@191

crm ahben3 register, offset:0x38

◆

union { ... } crm_type::@193

crm apb1en register, offset:0x40

◆

union { ... } crm_type::@195

crm apb2en register, offset:0x44

◆

union { ... } crm_type::@197

crm ahblpen1 register, offset:0x50

◆

union { ... } crm_type::@199

crm ahblpen2 register, offset:0x54

◆

union { ... } crm_type::@201

crm ahblpen3 register, offset:0x58

◆

union { ... } crm_type::@203

crm apb1lpen register, offset:0x60

◆

union { ... } crm_type::@205

crm apb2lpen register, offset:0x64

◆

union { ... } crm_type::@207

crm bpdc register, offset:0x70

◆

union { ... } crm_type::@209

crm ctrlsts register, offset:0x74

◆

union { ... } crm_type::@211

crm misc1 register, offset:0xA0

◆

union { ... } crm_type::@213

crm misc2 register, offset:0xA4

◆ accen

__IO uint32_t crm_type::accen

Definition at line 1231 of file at32f435_437_crm.h.

◆ acclpen

__IO uint32_t crm_type::acclpen

Definition at line 1403 of file at32f435_437_crm.h.

◆ accrst

__IO uint32_t crm_type::accrst

Definition at line 1059 of file at32f435_437_crm.h.

◆ adc14en

__IO uint32_t crm_type::adc14en

Definition at line 1180 of file at32f435_437_crm.h.

◆ adc14lpen

__IO uint32_t crm_type::adc14lpen

Definition at line 1352 of file at32f435_437_crm.h.

◆ adc14rst

__IO uint32_t crm_type::adc14rst

Definition at line 1008 of file at32f435_437_crm.h.

◆ adcen

__IO uint32_t crm_type::adcen

Definition at line 1219 of file at32f435_437_crm.h.

◆ adclpen

__IO uint32_t crm_type::adclpen

Definition at line 1391 of file at32f435_437_crm.h.

◆ adcrst

__IO uint32_t crm_type::adcrst

Definition at line 1047 of file at32f435_437_crm.h.

◆ ahbdiv

__IO uint32_t crm_type::ahbdiv

Definition at line 852 of file at32f435_437_crm.h.

◆ ahben1

__IO uint32_t crm_type::ahben1

Definition at line 1074 of file at32f435_437_crm.h.

◆

struct { ... } crm_type::ahben1_bit

◆ ahben2

__IO uint32_t crm_type::ahben2

Definition at line 1130 of file at32f435_437_crm.h.

◆

struct { ... } crm_type::ahben2_bit

◆ ahben3

__IO uint32_t crm_type::ahben3

Definition at line 1147 of file at32f435_437_crm.h.

◆

struct { ... } crm_type::ahben3_bit

◆ ahblpen1

__IO uint32_t crm_type::ahblpen1

Definition at line 1246 of file at32f435_437_crm.h.

◆

struct { ... } crm_type::ahblpen1_bit

◆ ahblpen2

__IO uint32_t crm_type::ahblpen2

Definition at line 1302 of file at32f435_437_crm.h.

◆

struct { ... } crm_type::ahblpen2_bit

◆ ahblpen3

__IO uint32_t crm_type::ahblpen3

Definition at line 1319 of file at32f435_437_crm.h.

◆

struct { ... } crm_type::ahblpen3_bit

◆ ahbrst1

__IO uint32_t crm_type::ahbrst1

Definition at line 902 of file at32f435_437_crm.h.

◆

struct { ... } crm_type::ahbrst1_bit

◆ ahbrst2

__IO uint32_t crm_type::ahbrst2

Definition at line 958 of file at32f435_437_crm.h.

◆

struct { ... } crm_type::ahbrst2_bit

◆ ahbrst3

__IO uint32_t crm_type::ahbrst3

Definition at line 975 of file at32f435_437_crm.h.

◆

struct { ... } crm_type::ahbrst3_bit

◆ apb1div

__IO uint32_t crm_type::apb1div

Definition at line 854 of file at32f435_437_crm.h.

◆ apb1en

__IO uint32_t crm_type::apb1en

Definition at line 1169 of file at32f435_437_crm.h.

◆

struct { ... } crm_type::apb1en_bit

◆ apb1lpen

__IO uint32_t crm_type::apb1lpen

Definition at line 1341 of file at32f435_437_crm.h.

◆

struct { ... } crm_type::apb1lpen_bit

◆ apb1rst

__IO uint32_t crm_type::apb1rst

Definition at line 997 of file at32f435_437_crm.h.

◆

struct { ... } crm_type::apb1rst_bit

◆ apb2div

__IO uint32_t crm_type::apb2div

Definition at line 855 of file at32f435_437_crm.h.

◆ apb2en

__IO uint32_t crm_type::apb2en

Definition at line 1210 of file at32f435_437_crm.h.

◆

struct { ... } crm_type::apb2en_bit

◆ apb2lpen

__IO uint32_t crm_type::apb2lpen

Definition at line 1382 of file at32f435_437_crm.h.

◆

struct { ... } crm_type::apb2lpen_bit

◆ apb2rst

__IO uint32_t crm_type::apb2rst

Definition at line 1038 of file at32f435_437_crm.h.

◆

struct { ... } crm_type::apb2rst_bit

◆ auto_step_en

__IO uint32_t crm_type::auto_step_en

Definition at line 1490 of file at32f435_437_crm.h.

◆ bpdc

__IO uint32_t crm_type::bpdc

Definition at line 1418 of file at32f435_437_crm.h.

◆

struct { ... } crm_type::bpdc_bit

◆ bpdrst

__IO uint32_t crm_type::bpdrst

Definition at line 1428 of file at32f435_437_crm.h.

◆ can1en

__IO uint32_t crm_type::can1en

Definition at line 1195 of file at32f435_437_crm.h.

◆ can1lpen

__IO uint32_t crm_type::can1lpen

Definition at line 1367 of file at32f435_437_crm.h.

◆ can1rst

__IO uint32_t crm_type::can1rst

Definition at line 1023 of file at32f435_437_crm.h.

◆ can2en

__IO uint32_t crm_type::can2en

Definition at line 1196 of file at32f435_437_crm.h.

◆ can2lpen

__IO uint32_t crm_type::can2lpen

Definition at line 1368 of file at32f435_437_crm.h.

◆ can2rst

__IO uint32_t crm_type::can2rst

Definition at line 1024 of file at32f435_437_crm.h.

◆ cfden

__IO uint32_t crm_type::cfden

Definition at line 815 of file at32f435_437_crm.h.

◆ cfdf

__IO uint32_t crm_type::cfdf

Definition at line 879 of file at32f435_437_crm.h.

◆ cfdfc

__IO uint32_t crm_type::cfdfc

Definition at line 892 of file at32f435_437_crm.h.

◆ cfg

__IO uint32_t crm_type::cfg

Definition at line 847 of file at32f435_437_crm.h.

◆

struct { ... } crm_type::cfg_bit

◆ clk_to_tmr

__IO uint32_t crm_type::clk_to_tmr

Definition at line 1492 of file at32f435_437_crm.h.

◆ clkint

__IO uint32_t crm_type::clkint

Definition at line 870 of file at32f435_437_crm.h.

◆

struct { ... } crm_type::clkint_bit

◆ clkout1_sel

__IO uint32_t crm_type::clkout1_sel

Definition at line 857 of file at32f435_437_crm.h.

◆ clkout1div1

__IO uint32_t crm_type::clkout1div1

Definition at line 859 of file at32f435_437_crm.h.

◆ clkout1div2

__IO uint32_t crm_type::clkout1div2

Definition at line 1476 of file at32f435_437_crm.h.

◆ clkout2_sel1

__IO uint32_t crm_type::clkout2_sel1

Definition at line 861 of file at32f435_437_crm.h.

◆ clkout2_sel2

__IO uint32_t crm_type::clkout2_sel2

Definition at line 1474 of file at32f435_437_crm.h.

◆ clkout2div1

__IO uint32_t crm_type::clkout2div1

Definition at line 860 of file at32f435_437_crm.h.

◆ clkout2div2

__IO uint32_t crm_type::clkout2div2

Definition at line 1477 of file at32f435_437_crm.h.

◆ crcen

__IO uint32_t crm_type::crcen

Definition at line 1087 of file at32f435_437_crm.h.

◆ crclpen

__IO uint32_t crm_type::crclpen

Definition at line 1259 of file at32f435_437_crm.h.

◆ crcrst

__IO uint32_t crm_type::crcrst

Definition at line 915 of file at32f435_437_crm.h.

◆ ctrl

__IO uint32_t crm_type::ctrl

Definition at line 805 of file at32f435_437_crm.h.

◆

struct { ... } crm_type::ctrl_bit

◆ ctrlsts

__IO uint32_t crm_type::ctrlsts

Definition at line 1438 of file at32f435_437_crm.h.

◆

struct { ... } crm_type::ctrlsts_bit

◆ dacen

__IO uint32_t crm_type::dacen

Definition at line 1199 of file at32f435_437_crm.h.

◆ daclpen

__IO uint32_t crm_type::daclpen

Definition at line 1371 of file at32f435_437_crm.h.

◆ dacrst

__IO uint32_t crm_type::dacrst

Definition at line 1027 of file at32f435_437_crm.h.

◆ dma1en

__IO uint32_t crm_type::dma1en

Definition at line 1090 of file at32f435_437_crm.h.

◆ dma1lpen

__IO uint32_t crm_type::dma1lpen

Definition at line 1262 of file at32f435_437_crm.h.

◆ dma1rst

__IO uint32_t crm_type::dma1rst

Definition at line 918 of file at32f435_437_crm.h.

◆ dma2en

__IO uint32_t crm_type::dma2en

Definition at line 1092 of file at32f435_437_crm.h.

◆ dma2lpen

__IO uint32_t crm_type::dma2lpen

Definition at line 1264 of file at32f435_437_crm.h.

◆ dma2rst

__IO uint32_t crm_type::dma2rst

Definition at line 920 of file at32f435_437_crm.h.

◆ dvpen

__IO uint32_t crm_type::dvpen

Definition at line 1133 of file at32f435_437_crm.h.

◆ dvplpen

__IO uint32_t crm_type::dvplpen

Definition at line 1305 of file at32f435_437_crm.h.

◆ dvprst

__IO uint32_t crm_type::dvprst

Definition at line 961 of file at32f435_437_crm.h.

◆ edmaen

__IO uint32_t crm_type::edmaen

Definition at line 1089 of file at32f435_437_crm.h.

◆ edmalpen

__IO uint32_t crm_type::edmalpen

Definition at line 1261 of file at32f435_437_crm.h.

◆ edmarst

__IO uint32_t crm_type::edmarst

Definition at line 917 of file at32f435_437_crm.h.

◆ emac_pps_sel

__IO uint32_t crm_type::emac_pps_sel

Definition at line 1493 of file at32f435_437_crm.h.

◆ ertcdiv

__IO uint32_t crm_type::ertcdiv

Definition at line 856 of file at32f435_437_crm.h.

◆ ertcen

__IO uint32_t crm_type::ertcen

Definition at line 1427 of file at32f435_437_crm.h.

◆ ertcsel

__IO uint32_t crm_type::ertcsel

Definition at line 1425 of file at32f435_437_crm.h.

◆ gpioaen

__IO uint32_t crm_type::gpioaen

Definition at line 1078 of file at32f435_437_crm.h.

◆ gpioalpen

__IO uint32_t crm_type::gpioalpen

Definition at line 1250 of file at32f435_437_crm.h.

◆ gpioarst

__IO uint32_t crm_type::gpioarst

Definition at line 906 of file at32f435_437_crm.h.

◆ gpioben

__IO uint32_t crm_type::gpioben

Definition at line 1079 of file at32f435_437_crm.h.

◆ gpioblpen

__IO uint32_t crm_type::gpioblpen

Definition at line 1251 of file at32f435_437_crm.h.

◆ gpiobrst

__IO uint32_t crm_type::gpiobrst

Definition at line 907 of file at32f435_437_crm.h.

◆ gpiocen

__IO uint32_t crm_type::gpiocen

Definition at line 1080 of file at32f435_437_crm.h.

◆ gpioclpen

__IO uint32_t crm_type::gpioclpen

Definition at line 1252 of file at32f435_437_crm.h.

◆ gpiocrst

__IO uint32_t crm_type::gpiocrst

Definition at line 908 of file at32f435_437_crm.h.

◆ gpioden

__IO uint32_t crm_type::gpioden

Definition at line 1081 of file at32f435_437_crm.h.

◆ gpiodlpen

__IO uint32_t crm_type::gpiodlpen

Definition at line 1253 of file at32f435_437_crm.h.

◆ gpiodrst

__IO uint32_t crm_type::gpiodrst

Definition at line 909 of file at32f435_437_crm.h.

◆ gpioeen

__IO uint32_t crm_type::gpioeen

Definition at line 1082 of file at32f435_437_crm.h.

◆ gpioelpen

__IO uint32_t crm_type::gpioelpen

Definition at line 1254 of file at32f435_437_crm.h.

◆ gpioerst

__IO uint32_t crm_type::gpioerst

Definition at line 910 of file at32f435_437_crm.h.

◆ gpiofen

__IO uint32_t crm_type::gpiofen

Definition at line 1083 of file at32f435_437_crm.h.

◆ gpioflpen

__IO uint32_t crm_type::gpioflpen

Definition at line 1255 of file at32f435_437_crm.h.

◆ gpiofrst

__IO uint32_t crm_type::gpiofrst

Definition at line 911 of file at32f435_437_crm.h.

◆ gpiogen

__IO uint32_t crm_type::gpiogen

Definition at line 1084 of file at32f435_437_crm.h.

◆ gpioglpen

__IO uint32_t crm_type::gpioglpen

Definition at line 1256 of file at32f435_437_crm.h.

◆ gpiogrst

__IO uint32_t crm_type::gpiogrst

Definition at line 912 of file at32f435_437_crm.h.

◆ gpiohen

__IO uint32_t crm_type::gpiohen

Definition at line 1085 of file at32f435_437_crm.h.

◆ gpiohlpen

__IO uint32_t crm_type::gpiohlpen

Definition at line 1257 of file at32f435_437_crm.h.

◆ gpiohrst

__IO uint32_t crm_type::gpiohrst

Definition at line 913 of file at32f435_437_crm.h.

◆ hextbyps

__IO uint32_t crm_type::hextbyps

Definition at line 814 of file at32f435_437_crm.h.

◆ hexten

__IO uint32_t crm_type::hexten

Definition at line 812 of file at32f435_437_crm.h.

◆ hextstbl

__IO uint32_t crm_type::hextstbl

Definition at line 813 of file at32f435_437_crm.h.

◆ hextstblf

__IO uint32_t crm_type::hextstblf

Definition at line 876 of file at32f435_437_crm.h.

◆ hextstblfc

__IO uint32_t crm_type::hextstblfc

Definition at line 889 of file at32f435_437_crm.h.

◆ hextstblien

__IO uint32_t crm_type::hextstblien

Definition at line 883 of file at32f435_437_crm.h.

◆ hick_to_sclk

__IO uint32_t crm_type::hick_to_sclk

Definition at line 1472 of file at32f435_437_crm.h.

◆ hick_to_usb

__IO uint32_t crm_type::hick_to_usb

Definition at line 1471 of file at32f435_437_crm.h.

◆ hickcal

__IO uint32_t crm_type::hickcal

Definition at line 811 of file at32f435_437_crm.h.

◆ hickcal_key

__IO uint32_t crm_type::hickcal_key

Definition at line 1468 of file at32f435_437_crm.h.

◆ hickdiv

__IO uint32_t crm_type::hickdiv

Definition at line 1470 of file at32f435_437_crm.h.

◆ hicken

__IO uint32_t crm_type::hicken

Definition at line 808 of file at32f435_437_crm.h.

◆ hickstbl

__IO uint32_t crm_type::hickstbl

Definition at line 809 of file at32f435_437_crm.h.

◆ hickstblf

__IO uint32_t crm_type::hickstblf

Definition at line 875 of file at32f435_437_crm.h.

◆ hickstblfc

__IO uint32_t crm_type::hickstblfc

Definition at line 888 of file at32f435_437_crm.h.

◆ hickstblien

__IO uint32_t crm_type::hickstblien

Definition at line 882 of file at32f435_437_crm.h.

◆ hicktrim

__IO uint32_t crm_type::hicktrim

Definition at line 810 of file at32f435_437_crm.h.

◆ i2c1en

__IO uint32_t crm_type::i2c1en

Definition at line 1191 of file at32f435_437_crm.h.

◆ i2c1lpen

__IO uint32_t crm_type::i2c1lpen

Definition at line 1363 of file at32f435_437_crm.h.

◆ i2c1rst

__IO uint32_t crm_type::i2c1rst

Definition at line 1019 of file at32f435_437_crm.h.

◆ i2c2en

__IO uint32_t crm_type::i2c2en

Definition at line 1192 of file at32f435_437_crm.h.

◆ i2c2lpen

__IO uint32_t crm_type::i2c2lpen

Definition at line 1364 of file at32f435_437_crm.h.

◆ i2c2rst

__IO uint32_t crm_type::i2c2rst

Definition at line 1020 of file at32f435_437_crm.h.

◆ i2c3en

__IO uint32_t crm_type::i2c3en

Definition at line 1193 of file at32f435_437_crm.h.

◆ i2c3lpen

__IO uint32_t crm_type::i2c3lpen

Definition at line 1365 of file at32f435_437_crm.h.

◆ i2c3rst

__IO uint32_t crm_type::i2c3rst

Definition at line 1021 of file at32f435_437_crm.h.

◆ lextbyps

__IO uint32_t crm_type::lextbyps

Definition at line 1423 of file at32f435_437_crm.h.

◆ lexten

__IO uint32_t crm_type::lexten

Definition at line 1421 of file at32f435_437_crm.h.

◆ lextstbl

__IO uint32_t crm_type::lextstbl

Definition at line 1422 of file at32f435_437_crm.h.

◆ lextstblf

__IO uint32_t crm_type::lextstblf

Definition at line 874 of file at32f435_437_crm.h.

◆ lextstblfc

__IO uint32_t crm_type::lextstblfc

Definition at line 887 of file at32f435_437_crm.h.

◆ lextstblien

__IO uint32_t crm_type::lextstblien

Definition at line 881 of file at32f435_437_crm.h.

◆ licken

__IO uint32_t crm_type::licken

Definition at line 1441 of file at32f435_437_crm.h.

◆ lickstbl

__IO uint32_t crm_type::lickstbl

Definition at line 1442 of file at32f435_437_crm.h.

◆ lickstblf

__IO uint32_t crm_type::lickstblf

Definition at line 873 of file at32f435_437_crm.h.

◆ lickstblfc

__IO uint32_t crm_type::lickstblfc

Definition at line 886 of file at32f435_437_crm.h.

◆ lickstblien

__IO uint32_t crm_type::lickstblien

Definition at line 880 of file at32f435_437_crm.h.

◆ lprstf

__IO uint32_t crm_type::lprstf

Definition at line 1451 of file at32f435_437_crm.h.

◆ misc1

__IO uint32_t crm_type::misc1

Definition at line 1465 of file at32f435_437_crm.h.

◆

struct { ... } crm_type::misc1_bit

◆ misc2

__IO uint32_t crm_type::misc2

Definition at line 1486 of file at32f435_437_crm.h.

◆

struct { ... } crm_type::misc2_bit

◆ nrstf

__IO uint32_t crm_type::nrstf

Definition at line 1446 of file at32f435_437_crm.h.

◆ otgfs1en

__IO uint32_t crm_type::otgfs1en

Definition at line 1135 of file at32f435_437_crm.h.

◆ otgfs1lpen

__IO uint32_t crm_type::otgfs1lpen

Definition at line 1307 of file at32f435_437_crm.h.

◆ otgfs1rst

__IO uint32_t crm_type::otgfs1rst

Definition at line 963 of file at32f435_437_crm.h.

◆ otgfs2en

__IO uint32_t crm_type::otgfs2en

Definition at line 1094 of file at32f435_437_crm.h.

◆ otgfs2lpen

__IO uint32_t crm_type::otgfs2lpen

Definition at line 1266 of file at32f435_437_crm.h.

◆ otgfs2rst

__IO uint32_t crm_type::otgfs2rst

Definition at line 922 of file at32f435_437_crm.h.

◆ pllcfg

__IO uint32_t crm_type::pllcfg

Definition at line 828 of file at32f435_437_crm.h.

◆

struct { ... } crm_type::pllcfg_bit

◆ pllen

__IO uint32_t crm_type::pllen

Definition at line 817 of file at32f435_437_crm.h.

◆ pllfr

__IO uint32_t crm_type::pllfr

Definition at line 835 of file at32f435_437_crm.h.

◆ pllms

__IO uint32_t crm_type::pllms

Definition at line 831 of file at32f435_437_crm.h.

◆ pllns

__IO uint32_t crm_type::pllns

Definition at line 833 of file at32f435_437_crm.h.

◆ pllrcs

__IO uint32_t crm_type::pllrcs

Definition at line 837 of file at32f435_437_crm.h.

◆ pllstbl

__IO uint32_t crm_type::pllstbl

Definition at line 818 of file at32f435_437_crm.h.

◆ pllstblf

__IO uint32_t crm_type::pllstblf

Definition at line 877 of file at32f435_437_crm.h.

◆ pllstblfc

__IO uint32_t crm_type::pllstblfc

Definition at line 890 of file at32f435_437_crm.h.

◆ pllstblien

__IO uint32_t crm_type::pllstblien

Definition at line 884 of file at32f435_437_crm.h.

◆ porrstf

__IO uint32_t crm_type::porrstf

Definition at line 1447 of file at32f435_437_crm.h.

◆ pwcen

__IO uint32_t crm_type::pwcen

Definition at line 1198 of file at32f435_437_crm.h.

◆ pwclpen

__IO uint32_t crm_type::pwclpen

Definition at line 1370 of file at32f435_437_crm.h.

◆ pwcrst

__IO uint32_t crm_type::pwcrst

Definition at line 1026 of file at32f435_437_crm.h.

◆ qspi1en

__IO uint32_t crm_type::qspi1en

Definition at line 1151 of file at32f435_437_crm.h.

◆ qspi1lpen

__IO uint32_t crm_type::qspi1lpen

Definition at line 1323 of file at32f435_437_crm.h.

◆ qspi1rst

__IO uint32_t crm_type::qspi1rst

Definition at line 979 of file at32f435_437_crm.h.

◆ qspi2en

__IO uint32_t crm_type::qspi2en

Definition at line 1153 of file at32f435_437_crm.h.

◆ qspi2lpen

__IO uint32_t crm_type::qspi2lpen

Definition at line 1325 of file at32f435_437_crm.h.

◆ qspi2rst

__IO uint32_t crm_type::qspi2rst

Definition at line 981 of file at32f435_437_crm.h.

◆ reserved1

__IO uint32_t crm_type::reserved1

crm reserved1 register, offset:0x1C

Definition at line 816 of file at32f435_437_crm.h.

◆ reserved2

__IO uint32_t crm_type::reserved2

crm reserved2 register, offset:0x28~0x2C

Definition at line 819 of file at32f435_437_crm.h.

◆ reserved3

__IO uint32_t crm_type::reserved3

crm reserved3 register, offset:0x3C

Definition at line 836 of file at32f435_437_crm.h.

◆ reserved4

__IO uint32_t crm_type::reserved4

crm reserved4 register, offset:0x48~0x4C

Definition at line 838 of file at32f435_437_crm.h.

◆ reserved5

__IO uint32_t crm_type::reserved5

crm reserved5 register, offset:0x5C

Definition at line 923 of file at32f435_437_crm.h.

◆ reserved6

__IO uint32_t crm_type::reserved6

crm reserved6 register, offset:0x68~0x6C

Definition at line 1058 of file at32f435_437_crm.h.

◆ reserved7

__IO uint32_t crm_type::reserved7

crm reserved7 register, offset:0x78~0x9C

Definition at line 1060 of file at32f435_437_crm.h.

◆ rstfc

__IO uint32_t crm_type::rstfc

Definition at line 1444 of file at32f435_437_crm.h.

◆ scfgen

__IO uint32_t crm_type::scfgen

Definition at line 1223 of file at32f435_437_crm.h.

◆ scfglpen

__IO uint32_t crm_type::scfglpen

Definition at line 1395 of file at32f435_437_crm.h.

◆ scfgrst

__IO uint32_t crm_type::scfgrst

Definition at line 1051 of file at32f435_437_crm.h.

◆ sclksel

__IO uint32_t crm_type::sclksel

Definition at line 850 of file at32f435_437_crm.h.

◆ sclksts

__IO uint32_t crm_type::sclksts

Definition at line 851 of file at32f435_437_crm.h.

◆ sdio1en

__IO uint32_t crm_type::sdio1en

Definition at line 1137 of file at32f435_437_crm.h.

◆ sdio1lpen

__IO uint32_t crm_type::sdio1lpen

Definition at line 1309 of file at32f435_437_crm.h.

◆ sdio1rst

__IO uint32_t crm_type::sdio1rst

Definition at line 965 of file at32f435_437_crm.h.

◆ sdio2en

__IO uint32_t crm_type::sdio2en

Definition at line 1154 of file at32f435_437_crm.h.

◆ sdio2lpen

__IO uint32_t crm_type::sdio2lpen

Definition at line 1326 of file at32f435_437_crm.h.

◆ sdio2rst

__IO uint32_t crm_type::sdio2rst

Definition at line 982 of file at32f435_437_crm.h.

◆ spi1en

__IO uint32_t crm_type::spi1en

Definition at line 1221 of file at32f435_437_crm.h.

◆ spi1lpen

__IO uint32_t crm_type::spi1lpen

Definition at line 1393 of file at32f435_437_crm.h.

◆ spi1rst

__IO uint32_t crm_type::spi1rst

Definition at line 1049 of file at32f435_437_crm.h.

◆ spi2en

__IO uint32_t crm_type::spi2en

Definition at line 1184 of file at32f435_437_crm.h.

◆ spi2lpen

__IO uint32_t crm_type::spi2lpen

Definition at line 1356 of file at32f435_437_crm.h.

◆ spi2rst

__IO uint32_t crm_type::spi2rst

Definition at line 1012 of file at32f435_437_crm.h.

◆ spi3en

__IO uint32_t crm_type::spi3en

Definition at line 1185 of file at32f435_437_crm.h.

◆ spi3lpen

__IO uint32_t crm_type::spi3lpen

Definition at line 1357 of file at32f435_437_crm.h.

◆ spi3rst

__IO uint32_t crm_type::spi3rst

Definition at line 1013 of file at32f435_437_crm.h.

◆ spi4en

__IO uint32_t crm_type::spi4en

Definition at line 1222 of file at32f435_437_crm.h.

◆ spi4lpen

__IO uint32_t crm_type::spi4lpen

Definition at line 1394 of file at32f435_437_crm.h.

◆ spi4rst

__IO uint32_t crm_type::spi4rst

Definition at line 1050 of file at32f435_437_crm.h.

◆ swrstf

__IO uint32_t crm_type::swrstf

Definition at line 1448 of file at32f435_437_crm.h.

◆ tmr10en

__IO uint32_t crm_type::tmr10en

Definition at line 1226 of file at32f435_437_crm.h.

◆ tmr10lpen

__IO uint32_t crm_type::tmr10lpen

Definition at line 1398 of file at32f435_437_crm.h.

◆ tmr10rst

__IO uint32_t crm_type::tmr10rst

Definition at line 1054 of file at32f435_437_crm.h.

◆ tmr11en

__IO uint32_t crm_type::tmr11en

Definition at line 1227 of file at32f435_437_crm.h.

◆ tmr11lpen

__IO uint32_t crm_type::tmr11lpen

Definition at line 1399 of file at32f435_437_crm.h.

◆ tmr11rst

__IO uint32_t crm_type::tmr11rst

Definition at line 1055 of file at32f435_437_crm.h.

◆ tmr12en

__IO uint32_t crm_type::tmr12en

Definition at line 1178 of file at32f435_437_crm.h.

◆ tmr12lpen

__IO uint32_t crm_type::tmr12lpen

Definition at line 1350 of file at32f435_437_crm.h.

◆ tmr12rst

__IO uint32_t crm_type::tmr12rst

Definition at line 1006 of file at32f435_437_crm.h.

◆ tmr13en

__IO uint32_t crm_type::tmr13en

Definition at line 1179 of file at32f435_437_crm.h.

◆ tmr13lpen

__IO uint32_t crm_type::tmr13lpen

Definition at line 1351 of file at32f435_437_crm.h.

◆ tmr13rst

__IO uint32_t crm_type::tmr13rst

Definition at line 1007 of file at32f435_437_crm.h.

◆ tmr1en

__IO uint32_t crm_type::tmr1en

Definition at line 1213 of file at32f435_437_crm.h.

◆ tmr1lpen

__IO uint32_t crm_type::tmr1lpen

Definition at line 1385 of file at32f435_437_crm.h.

◆ tmr1rst

__IO uint32_t crm_type::tmr1rst

Definition at line 1041 of file at32f435_437_crm.h.

◆ tmr20en

__IO uint32_t crm_type::tmr20en

Definition at line 1229 of file at32f435_437_crm.h.

◆ tmr20lpen

__IO uint32_t crm_type::tmr20lpen

Definition at line 1401 of file at32f435_437_crm.h.

◆ tmr20rst

__IO uint32_t crm_type::tmr20rst

Definition at line 1057 of file at32f435_437_crm.h.

◆ tmr2en

__IO uint32_t crm_type::tmr2en

Definition at line 1172 of file at32f435_437_crm.h.

◆ tmr2lpen

__IO uint32_t crm_type::tmr2lpen

Definition at line 1344 of file at32f435_437_crm.h.

◆ tmr2rst

__IO uint32_t crm_type::tmr2rst

Definition at line 1000 of file at32f435_437_crm.h.

◆ tmr3en

__IO uint32_t crm_type::tmr3en

Definition at line 1173 of file at32f435_437_crm.h.

◆ tmr3lpen

__IO uint32_t crm_type::tmr3lpen

Definition at line 1345 of file at32f435_437_crm.h.

◆ tmr3rst

__IO uint32_t crm_type::tmr3rst

Definition at line 1001 of file at32f435_437_crm.h.

◆ tmr4en

__IO uint32_t crm_type::tmr4en

Definition at line 1174 of file at32f435_437_crm.h.

◆ tmr4lpen

__IO uint32_t crm_type::tmr4lpen

Definition at line 1346 of file at32f435_437_crm.h.

◆ tmr4rst

__IO uint32_t crm_type::tmr4rst

Definition at line 1002 of file at32f435_437_crm.h.

◆ tmr5en

__IO uint32_t crm_type::tmr5en

Definition at line 1175 of file at32f435_437_crm.h.

◆ tmr5lpen

__IO uint32_t crm_type::tmr5lpen

Definition at line 1347 of file at32f435_437_crm.h.

◆ tmr5rst

__IO uint32_t crm_type::tmr5rst

Definition at line 1003 of file at32f435_437_crm.h.

◆ tmr6en

__IO uint32_t crm_type::tmr6en

Definition at line 1176 of file at32f435_437_crm.h.

◆ tmr6lpen

__IO uint32_t crm_type::tmr6lpen

Definition at line 1348 of file at32f435_437_crm.h.

◆ tmr6rst

__IO uint32_t crm_type::tmr6rst

Definition at line 1004 of file at32f435_437_crm.h.

◆ tmr7en

__IO uint32_t crm_type::tmr7en

Definition at line 1177 of file at32f435_437_crm.h.

◆ tmr7lpen

__IO uint32_t crm_type::tmr7lpen

Definition at line 1349 of file at32f435_437_crm.h.

◆ tmr7rst

__IO uint32_t crm_type::tmr7rst

Definition at line 1005 of file at32f435_437_crm.h.

◆ tmr8en

__IO uint32_t crm_type::tmr8en

Definition at line 1214 of file at32f435_437_crm.h.

◆ tmr8lpen

__IO uint32_t crm_type::tmr8lpen

Definition at line 1386 of file at32f435_437_crm.h.

◆ tmr8rst

__IO uint32_t crm_type::tmr8rst

Definition at line 1042 of file at32f435_437_crm.h.

◆ tmr9en

__IO uint32_t crm_type::tmr9en

Definition at line 1225 of file at32f435_437_crm.h.

◆ tmr9lpen

__IO uint32_t crm_type::tmr9lpen

Definition at line 1397 of file at32f435_437_crm.h.

◆ tmr9rst

__IO uint32_t crm_type::tmr9rst

Definition at line 1053 of file at32f435_437_crm.h.

◆ uart4en

__IO uint32_t crm_type::uart4en

Definition at line 1189 of file at32f435_437_crm.h.

◆ uart4lpen

__IO uint32_t crm_type::uart4lpen

Definition at line 1361 of file at32f435_437_crm.h.

◆ uart4rst

__IO uint32_t crm_type::uart4rst

Definition at line 1017 of file at32f435_437_crm.h.

◆ uart5en

__IO uint32_t crm_type::uart5en

Definition at line 1190 of file at32f435_437_crm.h.

◆ uart5lpen

__IO uint32_t crm_type::uart5lpen

Definition at line 1362 of file at32f435_437_crm.h.

◆ uart5rst

__IO uint32_t crm_type::uart5rst

Definition at line 1018 of file at32f435_437_crm.h.

◆ uart7en

__IO uint32_t crm_type::uart7en

Definition at line 1200 of file at32f435_437_crm.h.

◆ uart7lpen

__IO uint32_t crm_type::uart7lpen

Definition at line 1372 of file at32f435_437_crm.h.

◆ uart7rst

__IO uint32_t crm_type::uart7rst

Definition at line 1028 of file at32f435_437_crm.h.

◆ uart8en

__IO uint32_t crm_type::uart8en

Definition at line 1201 of file at32f435_437_crm.h.

◆ uart8lpen

__IO uint32_t crm_type::uart8lpen

Definition at line 1373 of file at32f435_437_crm.h.

◆ uart8rst

__IO uint32_t crm_type::uart8rst

Definition at line 1029 of file at32f435_437_crm.h.

◆ usart1en

__IO uint32_t crm_type::usart1en

Definition at line 1216 of file at32f435_437_crm.h.

◆ usart1lpen

__IO uint32_t crm_type::usart1lpen

Definition at line 1388 of file at32f435_437_crm.h.

◆ usart1rst

__IO uint32_t crm_type::usart1rst

Definition at line 1044 of file at32f435_437_crm.h.

◆ usart2en

__IO uint32_t crm_type::usart2en

Definition at line 1187 of file at32f435_437_crm.h.

◆ usart2lpen

__IO uint32_t crm_type::usart2lpen

Definition at line 1359 of file at32f435_437_crm.h.

◆ usart2rst

__IO uint32_t crm_type::usart2rst

Definition at line 1015 of file at32f435_437_crm.h.

◆ usart3en

__IO uint32_t crm_type::usart3en

Definition at line 1188 of file at32f435_437_crm.h.

◆ usart3lpen

__IO uint32_t crm_type::usart3lpen

Definition at line 1360 of file at32f435_437_crm.h.

◆ usart3rst

__IO uint32_t crm_type::usart3rst

Definition at line 1016 of file at32f435_437_crm.h.

◆ usart6en

__IO uint32_t crm_type::usart6en

Definition at line 1217 of file at32f435_437_crm.h.

◆ usart6lpen

__IO uint32_t crm_type::usart6lpen

Definition at line 1389 of file at32f435_437_crm.h.

◆ usart6rst

__IO uint32_t crm_type::usart6rst

Definition at line 1045 of file at32f435_437_crm.h.

◆ usbdiv

__IO uint32_t crm_type::usbdiv

Definition at line 1495 of file at32f435_437_crm.h.

◆ wdtrstf

__IO uint32_t crm_type::wdtrstf

Definition at line 1449 of file at32f435_437_crm.h.

◆ wwdten

__IO uint32_t crm_type::wwdten

Definition at line 1182 of file at32f435_437_crm.h.

◆ wwdtlpen

__IO uint32_t crm_type::wwdtlpen

Definition at line 1354 of file at32f435_437_crm.h.

◆ wwdtrst

__IO uint32_t crm_type::wwdtrst

Definition at line 1010 of file at32f435_437_crm.h.

◆ wwdtrstf

__IO uint32_t crm_type::wwdtrstf

Definition at line 1450 of file at32f435_437_crm.h.

◆ xmcen

__IO uint32_t crm_type::xmcen

Definition at line 1150 of file at32f435_437_crm.h.

◆ xmclpen

__IO uint32_t crm_type::xmclpen

Definition at line 1322 of file at32f435_437_crm.h.

◆ xmcrst

__IO uint32_t crm_type::xmcrst

Definition at line 978 of file at32f435_437_crm.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_crm.h


AT32F435/437 Firmwary Library: CRM_exported_functions

Functions
CRM_exported_functions
AT32F435_437_periph_driver » CRM

Functions

void | crm_reset (void)
reset the crm register More...
void | crm_lext_bypass (confirm_state new_state)
enable or disable crm low speed external crystal bypass More...
void | crm_hext_bypass (confirm_state new_state)
enable or disable crm high speed external crystal bypass More...
flag_status | crm_flag_get (uint32_t flag)
get crm flag status More...
error_status | crm_hext_stable_wait (void)
wait for hext stable More...
void | crm_hick_clock_trimming_set (uint8_t trim_value)
set the hick trimming value More...
void | crm_hick_clock_calibration_set (uint8_t cali_value)
set the crm calibration value More...
void | crm_periph_clock_enable (crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock More...
void | crm_periph_reset (crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset More...
void | crm_periph_lowpower_mode_enable (crm_periph_clock_lowpower_type value, confirm_state new_state)
enable or disable the peripheral clock in lowpower mode More...
void | crm_clock_source_enable (crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source More...
void | crm_flag_clear (uint32_t flag)
clear the crm reset flags More...
void | crm_ertc_clock_select (crm_ertc_clock_type value)
select ertc clock More...
void | crm_ertc_clock_enable (confirm_state new_state)
enable or disable ertc More...
void | crm_ahb_div_set (crm_ahb_div_type value)
set crm ahb division More...
void | crm_apb1_div_set (crm_apb1_div_type value)
set crm apb1 division More...
void | crm_apb2_div_set (crm_apb2_div_type value)
set crm apb2 division More...
void | crm_usb_clock_div_set (crm_usb_div_type value)
set usb division More...
void | crm_clock_failure_detection_enable (confirm_state new_state)
enable or disable clock failure detection More...
void | crm_battery_powered_domain_reset (confirm_state new_state)
battery powered domain software reset More...
void | crm_auto_step_mode_enable (confirm_state new_state)
auto step clock switch enable More...
void | crm_hick_divider_select (crm_hick_div_6_type value)
config hick divider select More...
void | crm_hick_sclk_frequency_select (crm_hick_sclk_frequency_type value)
hick as system clock frequency select More...
void | crm_usb_clock_source_select (crm_usb_clock_source_type value)
usb 48 mhz clock source select More...
void | crm_clkout_to_tmr10_enable (confirm_state new_state)
enable or disable clkout direct to tmr10 channel 1 More...
void | crm_pll_config (crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n attemtion: 31 <= pll_ns <= 500 1 <= pll_ms <= 15 More...
void | crm_sysclk_switch (crm_sclk_type value)
select system clock source More...
crm_sclk_type | crm_sysclk_switch_status_get (void)
indicate which clock source is used as system clock More...
void | crm_clocks_freq_get (crm_clocks_freq_type *clocks_struct)
get crm clocks freqency More...
void | crm_clock_out1_set (crm_clkout1_select_type clkout)
set crm clkout1 More...
void | crm_clock_out2_set (crm_clkout2_select_type clkout)
set crm clkout2 More...
void | crm_clkout_div_set (crm_clkout_index_type index, crm_clkout_div1_type div1, crm_clkout_div2_type div2)
set crm clkout1 division1 More...
void | crm_emac_output_pulse_set (crm_emac_output_pulse_type width)
set emac output pulse width More...
void | crm_interrupt_enable (uint32_t crm_int, confirm_state new_state)
config crm interrupt More...
error_status | crm_pll_parameter_calculate (crm_pll_clock_source_type pll_rcs, uint32_t target_sclk_freq, uint16_t *ret_ms, uint16_t *ret_ns, uint16_t *ret_fr)
calculate the pll parameters with pll reference clock and target pll output frequency. pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n attemtion: 31 <= pll_ns <= 500 1 <= pll_ms <= 15 More...

Detailed Description

Function Documentation

◆ crm_ahb_div_set()

void crm_ahb_div_set ( crm_ahb_div_type value )

set crm ahb division

Parameters
value this parameter can be one of the following values:
  • CRM_AHB_DIV_1
  • CRM_AHB_DIV_2
  • CRM_AHB_DIV_4
  • CRM_AHB_DIV_8
  • CRM_AHB_DIV_16
  • CRM_AHB_DIV_64
  • CRM_AHB_DIV_128
  • CRM_AHB_DIV_256
  • CRM_AHB_DIV_512
Return values
none

Definition at line 465 of file at32f435_437_crm.c.

Referenced by sclk_288m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_200mhz().

◆ crm_apb1_div_set()

void crm_apb1_div_set ( crm_apb1_div_type value )

set crm apb1 division

Parameters
value this parameter can be one of the following values:
  • CRM_APB1_DIV_1
  • CRM_APB1_DIV_2
  • CRM_APB1_DIV_4
  • CRM_APB1_DIV_8
  • CRM_APB1_DIV_16
Return values
none

Definition at line 481 of file at32f435_437_crm.c.

Referenced by main(), sclk_288m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_200mhz().

◆ crm_apb2_div_set()

void crm_apb2_div_set ( crm_apb2_div_type value )

set crm apb2 division

Parameters
value this parameter can be one of the following values:
  • CRM_APB2_DIV_1
  • CRM_APB2_DIV_2
  • CRM_APB2_DIV_4
  • CRM_APB2_DIV_8
  • CRM_APB2_DIV_16
Return values
none

Definition at line 497 of file at32f435_437_crm.c.

Referenced by sclk_288m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_200mhz().

◆ crm_auto_step_mode_enable()

void crm_auto_step_mode_enable ( confirm_state new_state )

auto step clock switch enable

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 551 of file at32f435_437_crm.c.

Referenced by sclk_288m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_200mhz(), and system_clock_recover().

◆ crm_battery_powered_domain_reset()

void crm_battery_powered_domain_reset ( confirm_state new_state )

battery powered domain software reset

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 541 of file at32f435_437_crm.c.

Referenced by ertc_config().

◆ crm_clkout_div_set()

void crm_clkout_div_set | ( | crm_clkout_index_type | index,
 |  | crm_clkout_div1_type | div1,
 |  | crm_clkout_div2_type | div2
 | ) |  |

set crm clkout1 division1

Parameters
div1 this parameter can be one of the following values:
  • CRM_CLKOUT_INDEX_1
  • CRM_CLKOUT_INDEX_2
div1 this parameter can be one of the following values:
  • CRM_CLKOUT_DIV1_1
  • CRM_CLKOUT_DIV1_2
  • CRM_CLKOUT_DIV1_3
  • CRM_CLKOUT_DIV1_4
  • CRM_CLKOUT_DIV1_5
div2 this parameter can be one of the following values:
  • CRM_CLKOUT_DIV2_1
  • CRM_CLKOUT_DIV2_2
  • CRM_CLKOUT_DIV2_4
  • CRM_CLKOUT_DIV2_8
  • CRM_CLKOUT_DIV2_16
  • CRM_CLKOUT_DIV2_64
  • CRM_CLKOUT_DIV2_128
  • CRM_CLKOUT_DIV2_256
  • CRM_CLKOUT_DIV2_512
Return values
none

Definition at line 831 of file at32f435_437_crm.c.

Referenced by clkout_config(), and emac_layer2_configuration().

◆ crm_clkout_to_tmr10_enable()

void crm_clkout_to_tmr10_enable ( confirm_state new_state )

enable or disable clkout direct to tmr10 channel 1

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 608 of file at32f435_437_crm.c.

◆ crm_clock_failure_detection_enable()

void crm_clock_failure_detection_enable ( confirm_state new_state )

enable or disable clock failure detection

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 531 of file at32f435_437_crm.c.

Referenced by clock_failure_detection_handler(), and main().

◆ crm_clock_out1_set()

void crm_clock_out1_set ( crm_clkout1_select_type clkout )

set crm clkout1

Parameters
clkout this parameter can be one of the following values:
  • CRM_CLKOUT1_HICK
  • CRM_CLKOUT1_LEXT
  • CRM_CLKOUT1_HEXT
  • CRM_CLKOUT1_PLL
Return values
none

Definition at line 773 of file at32f435_437_crm.c.

Referenced by clkout_config(), and emac_layer2_configuration().

◆ crm_clock_out2_set()

void crm_clock_out2_set ( crm_clkout2_select_type clkout )

set crm clkout2

Parameters
clkout this parameter can be one of the following values:
  • CRM_CLKOUT2_SCLK
  • CRM_CLKOUT2_HEXT
  • CRM_CLKOUT2_PLL
  • CRM_CLKOUT2_USB
  • CRM_CLKOUT2_ADC
  • CRM_CLKOUT2_HICK
  • CRM_CLKOUT2_LICK
  • CRM_CLKOUT2_LEXT
Return values
none

Definition at line 792 of file at32f435_437_crm.c.

◆ crm_clock_source_enable()

void crm_clock_source_enable | ( | crm_clock_source_type | source,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the crm clock source

Parameters
source this parameter can be one of the following values:
  • CRM_CLOCK_SOURCE_HICK
  • CRM_CLOCK_SOURCE_HEXT
  • CRM_CLOCK_SOURCE_PLL
  • CRM_CLOCK_SOURCE_LEXT
  • CRM_CLOCK_SOURCE_LICK
new_state (TRUE or FALSE)
Return values
none

Definition at line 314 of file at32f435_437_crm.c.

Referenced by ertc_config(), sclk_288m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_200mhz(), and system_clock_recover().

◆ crm_clocks_freq_get()

void crm_clocks_freq_get ( crm_clocks_freq_type * clocks_struct )

get crm clocks freqency

Parameters
clocks_struct
  • pointer to the crm_clocks_freq_type structure
Return values
none

< value of the high speed internal clock in hz

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

< value of the high speed internal clock in hz

Definition at line 691 of file at32f435_437_crm.c.

Referenced by emac_clock_range_set(), emac_tmr_init(), i2s_init(), lick_frequency_get(), main(), tmr1_config(), tmr2_config(), tmr_init(), usart_configuration(), and usart_init().

◆ crm_emac_output_pulse_set()

void crm_emac_output_pulse_set ( crm_emac_output_pulse_type width )

set emac output pulse width

Parameters
width this parameter can be one of the following values:
  • CRM_EMAC_PULSE_125MS
  • CRM_EMAC_PULSE_1SCLK
Return values
none

Definition at line 853 of file at32f435_437_crm.c.

◆ crm_ertc_clock_enable()

void crm_ertc_clock_enable ( confirm_state new_state )

enable or disable ertc

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 445 of file at32f435_437_crm.c.

Referenced by ertc_config().

◆ crm_ertc_clock_select()

void crm_ertc_clock_select ( crm_ertc_clock_type value )

select ertc clock

Parameters
value this parameter can be one of the following values:
  • CRM_ERTC_CLOCK_NOCLK
  • CRM_ERTC_CLOCK_LEXT
  • CRM_ERTC_CLOCK_LICK
  • CRM_ERTC_CLOCK_HEXT_DIV_2
  • CRM_ERTC_CLOCK_HEXT_DIV_3
  • CRM_ERTC_CLOCK_HEXT_DIV_4
  • CRM_ERTC_CLOCK_HEXT_DIV_5
  • CRM_ERTC_CLOCK_HEXT_DIV_6
  • CRM_ERTC_CLOCK_HEXT_DIV_7
  • CRM_ERTC_CLOCK_HEXT_DIV_8
  • CRM_ERTC_CLOCK_HEXT_DIV_9
  • CRM_ERTC_CLOCK_HEXT_DIV_10
  • CRM_ERTC_CLOCK_HEXT_DIV_11
  • CRM_ERTC_CLOCK_HEXT_DIV_12
  • CRM_ERTC_CLOCK_HEXT_DIV_13
  • CRM_ERTC_CLOCK_HEXT_DIV_14
  • CRM_ERTC_CLOCK_HEXT_DIV_15
  • CRM_ERTC_CLOCK_HEXT_DIV_16
  • CRM_ERTC_CLOCK_HEXT_DIV_17
  • CRM_ERTC_CLOCK_HEXT_DIV_18
  • CRM_ERTC_CLOCK_HEXT_DIV_19
  • CRM_ERTC_CLOCK_HEXT_DIV_20
  • CRM_ERTC_CLOCK_HEXT_DIV_21
  • CRM_ERTC_CLOCK_HEXT_DIV_22
  • CRM_ERTC_CLOCK_HEXT_DIV_23
  • CRM_ERTC_CLOCK_HEXT_DIV_24
  • CRM_ERTC_CLOCK_HEXT_DIV_25
  • CRM_ERTC_CLOCK_HEXT_DIV_26
  • CRM_ERTC_CLOCK_HEXT_DIV_27
  • CRM_ERTC_CLOCK_HEXT_DIV_28
  • CRM_ERTC_CLOCK_HEXT_DIV_29
  • CRM_ERTC_CLOCK_HEXT_DIV_30
  • CRM_ERTC_CLOCK_HEXT_DIV_31
Return values
none

Definition at line 434 of file at32f435_437_crm.c.

Referenced by ertc_config().

◆ crm_flag_clear()

void crm_flag_clear ( uint32_t flag )

clear the crm reset flags

Parameters
flag this parameter can be one of the following values: reset flag:
  • CRM_PIN_RESET_FLAG
  • CRM_POR_RESET_FLAG
  • CRM_SW_RESET_FLAG
  • CRM_WDT_RESET_FLAG
  • CRM_WWDT_RESET_FLAG
  • CRM_LOWPOWER_RESET_FLAG
  • CRM_ALL_RESET_FLAG interrupt flag:
  • CRM_LICK_READY_INT_FLAG
  • CRM_LEXT_READY_INT_FLAG
  • CRM_HICK_READY_INT_FLAG
  • CRM_HEXT_READY_INT_FLAG
  • CRM_PLL_READY_INT_FLAG
  • CRM_CLOCK_FAILURE_INT_FLAG
Return values
none

< nrst pin reset flag

< power on reset flag

< software reset flag

< watchdog timer reset flag

< window watchdog timer reset flag

< low-power reset flag

< all reset flag

< low speed internal clock stable interrupt ready flag

< low speed external crystal stable interrupt ready flag

< high speed internal clock stable interrupt ready flag

< high speed external crystal stable interrupt ready flag

< phase locking loop stable interrupt ready flag

< clock failure interrupt ready flag

Definition at line 358 of file at32f435_437_crm.c.

Referenced by clock_failure_detection_handler(), and main().

◆ crm_flag_get()

flag_status crm_flag_get ( uint32_t flag )

get crm flag status

Parameters
flag this parameter can be one of the following values:
  • CRM_HICK_STABLE_FLAG
  • CRM_HEXT_STABLE_FLAG
  • CRM_PLL_STABLE_FLAG
  • CRM_LEXT_STABLE_FLAG
  • CRM_LICK_STABLE_FLAG
  • CRM_PIN_RESET_FLAG
  • CRM_POR_RESET_FLAG
  • CRM_SW_RESET_FLAG
  • CRM_WDT_RESET_FLAG
  • CRM_WWDT_RESET_FLAG
  • CRM_LOWPOWER_RESET_FLAG interrupt flag:
  • CRM_LICK_READY_INT_FLAG
  • CRM_LEXT_READY_INT_FLAG
  • CRM_HICK_READY_INT_FLAG
  • CRM_HEXT_READY_INT_FLAG
  • CRM_PLL_READY_INT_FLAG
  • CRM_CLOCK_FAILURE_INT_FLAG
Return values
flag_status (SET or RESET)

Definition at line 124 of file at32f435_437_crm.c.

Referenced by clock_failure_detection_handler(), crm_hext_stable_wait(), ertc_config(), main(), sclk_288m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_200mhz(), and system_clock_recover().

◆ crm_hext_bypass()

void crm_hext_bypass ( confirm_state new_state )

enable or disable crm high speed external crystal bypass

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 95 of file at32f435_437_crm.c.

◆ crm_hext_stable_wait()

error_status crm_hext_stable_wait ( void )

wait for hext stable

Parameters
none
Return values
error_status (ERROR or SUCCESS)

< high speed external crystal stable flag

< time out for hext start up

< high speed external crystal stable flag

Definition at line 143 of file at32f435_437_crm.c.

Referenced by sclk_96m_hext_config(), system_clock_config(), system_clock_config_200mhz(), and system_clock_recover().

◆ crm_hick_clock_calibration_set()

void crm_hick_clock_calibration_set ( uint8_t cali_value )

set the crm calibration value

Parameters
cali_value (0x00~0xFF)
Return values
none

Definition at line 180 of file at32f435_437_crm.c.

◆ crm_hick_clock_trimming_set()

void crm_hick_clock_trimming_set ( uint8_t trim_value )

set the hick trimming value

Parameters
trim_value (0x00~0x3F)
Return values
none

Definition at line 170 of file at32f435_437_crm.c.

◆ crm_hick_divider_select()

void crm_hick_divider_select ( crm_hick_div_6_type value )

config hick divider select

Parameters
value this parameter can be one of the following values:
  • CRM_HICK48_DIV6
  • CRM_HICK48_NODIV
Return values
none

Definition at line 567 of file at32f435_437_crm.c.

Referenced by crm_hick_sclk_frequency_select().

◆ crm_hick_sclk_frequency_select()

void crm_hick_sclk_frequency_select ( crm_hick_sclk_frequency_type value )

hick as system clock frequency select

Parameters
value this parameter can be one of the following values:
  • CRM_HICK_SCLK_8MHZ
  • CRM_HICK_SCLK_48MHZ
Return values
none

Definition at line 580 of file at32f435_437_crm.c.

Referenced by crm_usb_clock_source_select().

◆ crm_interrupt_enable()

void crm_interrupt_enable | ( | uint32_t | crm_int,
 |  | confirm_state | new_state
 | ) |  |

config crm interrupt

Parameters
int this parameter can be any combination of the following values:
  • CRM_LICK_STABLE_INT
  • CRM_LEXT_STABLE_INT
  • CRM_HICK_STABLE_INT
  • CRM_HEXT_STABLE_INT
  • CRM_PLL_STABLE_INT
new_state (TRUE or FALSE)
Return values
none

Definition at line 870 of file at32f435_437_crm.c.

◆ crm_lext_bypass()

void crm_lext_bypass ( confirm_state new_state )

enable or disable crm low speed external crystal bypass

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 85 of file at32f435_437_crm.c.

◆ crm_periph_clock_enable()

void crm_periph_clock_enable | ( | crm_periph_clock_type | value,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the peripheral clock

Parameters
value this parameter can be one of the following values:
  • CRM_GPIOA_PERIPH_CLOCK - CRM_GPIOB_PERIPH_CLOCK - CRM_GPIOC_PERIPH_CLOCK - CRM_GPIOD_PERIPH_CLOCK
  • CRM_GPIOE_PERIPH_CLOCK - CRM_GPIOF_PERIPH_CLOCK - CRM_GPIOG_PERIPH_CLOCK - CRM_GPIOH_PERIPH_CLOCK
  • CRM_CRC_PERIPH_CLOCK - CRM_EDMA_PERIPH_CLOCK - CRM_DMA1_PERIPH_CLOCK - CRM_DMA2_PERIPH_CLOCK
  • CRM_EMAC_PERIPH_CLOCK - CRM_EMACTX_PERIPH_CLOCK - CRM_EMACRX_PERIPH_CLOCK - CRM_EMACPTP_PERIPH_CLOCK
  • CRM_OTGFS2_PERIPH_CLOCK - CRM_DVP_PERIPH_CLOCK - CRM_OTGFS1_PERIPH_CLOCK - CRM_SDIO1_PERIPH_CLOCK
  • CRM_XMC_PERIPH_CLOCK - CRM_QSPI1_PERIPH_CLOCK - CRM_QSPI2_PERIPH_CLOCK - CRM_SDIO2_PERIPH_CLOCK
  • CRM_TMR2_PERIPH_CLOCK - CRM_TMR3_PERIPH_CLOCK - CRM_TMR4_PERIPH_CLOCK - CRM_TMR5_PERIPH_CLOCK
  • CRM_TMR6_PERIPH_CLOCK - CRM_TMR7_PERIPH_CLOCK - CRM_TMR12_PERIPH_CLOCK - CRM_TMR13_PERIPH_CLOCK
  • CRM_TMR14_PERIPH_CLOCK - CRM_WWDT_PERIPH_CLOCK - CRM_SPI2_PERIPH_CLOCK - CRM_SPI3_PERIPH_CLOCK
  • CRM_USART2_PERIPH_CLOCK - CRM_USART3_PERIPH_CLOCK - CRM_UART4_PERIPH_CLOCK - CRM_UART5_PERIPH_CLOCK
  • CRM_I2C1_PERIPH_CLOCK - CRM_I2C2_PERIPH_CLOCK - CRM_I2C3_PERIPH_CLOCK - CRM_CAN1_PERIPH_CLOCK
  • CRM_CAN2_PERIPH_CLOCK - CRM_PWC_PERIPH_CLOCK - CRM_DAC_PERIPH_CLOCK - CRM_UART7_PERIPH_CLOCK
  • CRM_UART8_PERIPH_CLOCK - CRM_TMR1_PERIPH_CLOCK - CRM_TMR8_PERIPH_CLOCK - CRM_USART1_PERIPH_CLOCK
  • CRM_USART6_PERIPH_CLOCK - CRM_ADC1_PERIPH_CLOCK - CRM_ADC2_PERIPH_CLOCK - CRM_ADC3_PERIPH_CLOCK
  • CRM_SPI1_PERIPH_CLOCK - CRM_SPI4_PERIPH_CLOCK - CRM_SCFG_PERIPH_CLOCK - CRM_TMR9_PERIPH_CLOCK
  • CRM_TMR10_PERIPH_CLOCK - CRM_TMR11_PERIPH_CLOCK - CRM_TMR20_PERIPH_CLOCK - CRM_ACC_PERIPH_CLOCK
new_state (TRUE or FALSE)
Return values
none

Definition at line 215 of file at32f435_437_crm.c.

Referenced by adc_config(), adc_configuration(), app_load(), at32_button_init(), at32_led_init(), button_exint_init(), can_configuration(), can_gpio_config(), clkout_config(), codec_i2s_init(), crc_cal(), crm_configuration(), dma_config(), dma_configuration(), dvp_dma_init(), dvp_io_init(), edma_config(), emac_layer2_configuration(), emac_pins_configuration(), emac_system_init(), emac_tmr_init(), emac_wake_on_lan_init(), ertc_config(), exint_config(), exint_line0_config(), exint_line4_config(), flash_crc_check(), gpio_config(), i2c_lowlevel_init(), i2s_config(), jump_to_app(), lick_frequency_get(), main(), mclk_tmr1_init(), nand_init(), nor_init(), ov2640_init(), ov5640_init(), psram_init(), qspi_config(), reset_phy(), rs485_config(), sclk_288m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), sd_dma_config(), sd_init(), sdram_copy_to_sram_dma(), sdram_init(), spi_config(), spiflash_init(), sram_copy_to_sdram_dma(), sram_init(), swj_dp_config(), system_clock_config(), system_clock_config_200mhz(), tmr1_config(), tmr2_config(), TMR3_GLOBAL_IRQHandler(), tmr_init(), touch_pin_init(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), usart_spi_configuration(), usb_clock48m_select(), usb_gpio_config(), usb_usart_config(), and xmc_init().

◆ crm_periph_lowpower_mode_enable()

void crm_periph_lowpower_mode_enable | ( | crm_periph_clock_lowpower_type | value,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the peripheral clock in lowpower mode

Parameters
value this parameter can be one of the following values:
  • CRM_GPIOA_PERIPH_LOWPOWER - CRM_GPIOB_PERIPH_LOWPOWER - CRM_GPIOC_PERIPH_LOWPOWER - CRM_GPIOD_PERIPH_LOWPOWER
  • CRM_GPIOE_PERIPH_LOWPOWER - CRM_GPIOF_PERIPH_LOWPOWER - CRM_GPIOG_PERIPH_LOWPOWER - CRM_GPIOH_PERIPH_LOWPOWER
  • CRM_CRC_PERIPH_LOWPOWER - CRM_EDMA_PERIPH_LOWPOWER - CRM_DMA1_PERIPH_LOWPOWER - CRM_DMA2_PERIPH_LOWPOWER
  • CRM_EMAC_PERIPH_LOWPOWER - CRM_EMACTX_PERIPH_LOWPOWER - CRM_EMACRX_PERIPH_LOWPOWER - CRM_EMACPTP_PERIPH_LOWPOWER
  • CRM_OTGFS2_PERIPH_LOWPOWER - CRM_DVP_PERIPH_LOWPOWER - CRM_OTGFS1_PERIPH_LOWPOWER - CRM_SDIO1_PERIPH_LOWPOWER
  • CRM_XMC_PERIPH_LOWPOWER - CRM_QSPI1_PERIPH_LOWPOWER - CRM_QSPI2_PERIPH_LOWPOWER - CRM_SDIO2_PERIPH_LOWPOWER
  • CRM_TMR2_PERIPH_LOWPOWER - CRM_TMR3_PERIPH_LOWPOWER - CRM_TMR4_PERIPH_LOWPOWER - CRM_TMR5_PERIPH_LOWPOWER
  • CRM_TMR6_PERIPH_LOWPOWER - CRM_TMR7_PERIPH_LOWPOWER - CRM_TMR12_PERIPH_LOWPOWER - CRM_TMR13_PERIPH_LOWPOWER
  • CRM_TMR14_PERIPH_LOWPOWER - CRM_WWDT_PERIPH_LOWPOWER - CRM_SPI2_PERIPH_LOWPOWER - CRM_SPI3_PERIPH_LOWPOWER
  • CRM_USART2_PERIPH_LOWPOWER - CRM_USART3_PERIPH_LOWPOWER - CRM_UART4_PERIPH_LOWPOWER - CRM_UART5_PERIPH_LOWPOWER
  • CRM_I2C1_PERIPH_LOWPOWER - CRM_I2C2_PERIPH_LOWPOWER - CRM_I2C3_PERIPH_LOWPOWER - CRM_CAN1_PERIPH_LOWPOWER
  • CRM_CAN2_PERIPH_LOWPOWER - CRM_PWC_PERIPH_LOWPOWER - CRM_DAC_PERIPH_LOWPOWER - CRM_UART7_PERIPH_LOWPOWER
  • CRM_UART8_PERIPH_LOWPOWER - CRM_TMR1_PERIPH_LOWPOWER - CRM_TMR8_PERIPH_LOWPOWER - CRM_USART1_PERIPH_LOWPOWER
  • CRM_USART6_PERIPH_LOWPOWER - CRM_ADC1_PERIPH_LOWPOWER - CRM_ADC2_PERIPH_LOWPOWER - CRM_ADC3_PERIPH_LOWPOWER
  • CRM_SPI1_PERIPH_LOWPOWER - CRM_SPI4_PERIPH_LOWPOWER - CRM_SCFG_PERIPH_LOWPOWER - CRM_TMR9_PERIPH_LOWPOWER
  • CRM_TMR10_PERIPH_LOWPOWER - CRM_TMR11_PERIPH_LOWPOWER - CRM_TMR20_PERIPH_LOWPOWER - CRM_ACC_PERIPH_LOWPOWER
new_state (TRUE or FALSE)
Return values
none

Definition at line 288 of file at32f435_437_crm.c.

◆ crm_periph_reset()

void crm_periph_reset | ( | crm_periph_reset_type | value,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the peripheral reset

Parameters
value this parameter can be one of the following values:
  • CRM_GPIOA_PERIPH_RESET - CRM_GPIOB_PERIPH_RESET - CRM_GPIOC_PERIPH_RESET - CRM_GPIOD_PERIPH_RESET
  • CRM_GPIOE_PERIPH_RESET - CRM_GPIOF_PERIPH_RESET - CRM_GPIOG_PERIPH_RESET - CRM_GPIOH_PERIPH_RESET
  • CRM_CRC_PERIPH_RESET - CRM_EDMA_PERIPH_RESET - CRM_DMA1_PERIPH_RESET - CRM_DMA2_PERIPH_RESET
  • CRM_EMAC_PERIPH_RESET - CRM_OTGFS2_PERIPH_RESET - CRM_DVP_PERIPH_RESET - CRM_OTGFS1_PERIPH_RESET
  • CRM_SDIO1_PERIPH_RESET - CRM_XMC_PERIPH_RESET - CRM_QSPI1_PERIPH_RESET - CRM_QSPI2_PERIPH_RESET
  • CRM_SDIO2_PERIPH_RESET - CRM_TMR2_PERIPH_RESET - CRM_TMR3_PERIPH_RESET - CRM_TMR4_PERIPH_RESET
  • CRM_TMR5_PERIPH_RESET - CRM_TMR6_PERIPH_RESET - CRM_TMR7_PERIPH_RESET - CRM_TMR12_PERIPH_RESET
  • CRM_TMR13_PERIPH_RESET - CRM_TMR14_PERIPH_RESET - CRM_WWDT_PERIPH_RESET - CRM_SPI2_PERIPH_RESET
  • CRM_SPI3_PERIPH_RESET - CRM_USART2_PERIPH_RESET - CRM_USART3_PERIPH_RESET - CRM_UART4_PERIPH_RESET
  • CRM_UART5_PERIPH_RESET - CRM_I2C1_PERIPH_RESET - CRM_I2C2_PERIPH_RESET - CRM_I2C3_PERIPH_RESET
  • CRM_CAN1_PERIPH_RESET - CRM_CAN2_PERIPH_RESET - CRM_PWC_PERIPH_RESET - CRM_DAC_PERIPH_RESET
  • CRM_UART7_PERIPH_RESET - CRM_UART8_PERIPH_RESET - CRM_TMR1_PERIPH_RESET - CRM_TMR8_PERIPH_RESET
  • CRM_USART1_PERIPH_RESET - CRM_USART6_PERIPH_RESET - CRM_ADC_PERIPH_RESET - CRM_SPI1_PERIPH_RESET
  • CRM_SPI4_PERIPH_RESET - CRM_SCFG_PERIPH_RESET - CRM_TMR9_PERIPH_RESET - CRM_TMR10_PERIPH_RESET
  • CRM_TMR11_PERIPH_RESET - CRM_TMR20_PERIPH_RESET - CRM_ACC_PERIPH_RESET
new_state (TRUE or FALSE)
Return values
none

Definition at line 251 of file at32f435_437_crm.c.

Referenced by adc_reset(), can_reset(), dac_reset(), dvp_reset(), emac_reset(), gpio_reset(), i2c_reset(), jump_to_app(), pwc_reset(), scfg_reset(), spi_i2s_reset(), tmr_reset(), usart_reset(), and wwdt_reset().

◆ crm_pll_config()

void crm_pll_config | ( | crm_pll_clock_source_type | clock_source,
 |  | uint16_t | pll_ns,
 |  | uint16_t | pll_ms,
 |  | crm_pll_fr_type | pll_fr
 | ) |  |

config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n attemtion: 31 <= pll_ns <= 500 1 <= pll_ms <= 15

 pll_rcs_freq

2mhz <= -------------------— <= 16mhz pll_ms

pll_rcs_freq * pll_ns 500mhz <= -----------------------------— <= 1000mhz pll_ms

Parameters
clock_source this parameter can be one of the following values:
  • CRM_PLL_SOURCE_HICK
  • CRM_PLL_SOURCE_HEXT
pll_ns | (31~500)
pll_ms | (1~15)
pll_fr this parameter can be one of the following values:
  • CRM_PLL_FR_1
  • CRM_PLL_FR_2
  • CRM_PLL_FR_4
  • CRM_PLL_FR_8
  • CRM_PLL_FR_16
  • CRM_PLL_FR_32
Return values
none

Definition at line 645 of file at32f435_437_crm.c.

Referenced by sclk_288m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_200mhz().

◆ crm_pll_parameter_calculate()

error_status crm_pll_parameter_calculate | ( | crm_pll_clock_source_type | pll_rcs,
 |  | uint32_t | target_sclk_freq,
 |  | uint16_t * | ret_ms,
 |  | uint16_t * | ret_ns,
 |  | uint16_t * | ret_fr
 | ) |  |

calculate the pll parameters with pll reference clock and target pll output frequency. pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n attemtion: 31 <= pll_ns <= 500 1 <= pll_ms <= 15

 pll_rcs_freq

2mhz <= -------------------— <= 16mhz pll_ms

pll_rcs_freq * pll_ns 500mhz <= -----------------------------— <= 1000mhz pll_ms

Parameters
pll_rcs this parameter can be one of the following values:
  • CRM_PLL_SOURCE_HICK
  • CRM_PLL_SOURCE_HEXT
target_sclk_freq | target pll output frequency, such as 200 mhz (target_sclk_freq: 200000000)
ret_ms | pointer to ms value, return the pll_ms of pll parameters
ret_ns | pointer to ns value, return the pll_ns of pll parameters
ret_fr | pointer to fr value, return the pll_fr of pll parameters
Return values
error_status (SUCCESS or ERROR)

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

Definition at line 904 of file at32f435_437_crm.c.

Referenced by system_clock_config_200mhz().

◆ crm_reset()

void crm_reset ( void )

reset the crm register

Parameters
none
Return values
none

Definition at line 49 of file at32f435_437_crm.c.

Referenced by app_update_handle(), sclk_288m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_200mhz().

◆ crm_sysclk_switch()

void crm_sysclk_switch ( crm_sclk_type value )

select system clock source

Parameters
value this parameter can be one of the following values:
  • CRM_SCLK_HICK
  • CRM_SCLK_HEXT
  • CRM_SCLK_PLL
Return values
none

Definition at line 666 of file at32f435_437_crm.c.

Referenced by main(), sclk_288m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_200mhz(), and system_clock_recover().

◆ crm_sysclk_switch_status_get()

crm_sclk_type crm_sysclk_switch_status_get ( void )

indicate which clock source is used as system clock

Parameters
none
Return values
crm_sclk this return can be one of the following values:
  • CRM_SCLK_HICK
  • CRM_SCLK_HEXT
  • CRM_SCLK_PLL

Definition at line 680 of file at32f435_437_crm.c.

Referenced by crm_clocks_freq_get(), main(), sclk_288m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_200mhz(), system_clock_recover(), and system_core_clock_update().

◆ crm_usb_clock_div_set()

void crm_usb_clock_div_set ( crm_usb_div_type value )

set usb division

Parameters
value this parameter can be one of the following values:
  • CRM_USB_DIV_1_5
  • CRM_USB_DIV_1
  • CRM_USB_DIV_2_5
  • CRM_USB_DIV_2
  • CRM_USB_DIV_3_5
  • CRM_USB_DIV_3
  • CRM_USB_DIV_4_5
  • CRM_USB_DIV_4
  • CRM_USB_DIV_5_5
  • CRM_USB_DIV_5
  • CRM_USB_DIV_6_5
  • CRM_USB_DIV_6
  • CRM_USB_DIV_7
Return values
none

Definition at line 521 of file at32f435_437_crm.c.

Referenced by usb_clock48m_select().

◆ crm_usb_clock_source_select()

void crm_usb_clock_source_select ( crm_usb_clock_source_type value )

usb 48 mhz clock source select

Parameters
value this parameter can be one of the following values:
  • CRM_USB_CLOCK_SOURCE_PLL
  • CRM_USB_CLOCK_SOURCE_HICK
Return values
none

Definition at line 594 of file at32f435_437_crm.c.

Referenced by usb_clock48m_select().


AT32F435/437 Firmwary Library: CRM_private_functions

Functions
CRM_private_functions
AT32F435_437_periph_driver » CRM

Functions

void | crm_reset (void)
reset the crm register More...
void | crm_lext_bypass (confirm_state new_state)
enable or disable crm low speed external crystal bypass More...
void | crm_hext_bypass (confirm_state new_state)
enable or disable crm high speed external crystal bypass More...
flag_status | crm_flag_get (uint32_t flag)
get crm flag status More...
error_status | crm_hext_stable_wait (void)
wait for hext stable More...
void | crm_hick_clock_trimming_set (uint8_t trim_value)
set the hick trimming value More...
void | crm_hick_clock_calibration_set (uint8_t cali_value)
set the crm calibration value More...
void | crm_periph_clock_enable (crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock More...
void | crm_periph_reset (crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset More...
void | crm_periph_lowpower_mode_enable (crm_periph_clock_lowpower_type value, confirm_state new_state)
enable or disable the peripheral clock in lowpower mode More...
void | crm_clock_source_enable (crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source More...
void | crm_flag_clear (uint32_t flag)
clear the crm reset flags More...
void | crm_ertc_clock_select (crm_ertc_clock_type value)
select ertc clock More...
void | crm_ertc_clock_enable (confirm_state new_state)
enable or disable ertc More...
void | crm_ahb_div_set (crm_ahb_div_type value)
set crm ahb division More...
void | crm_apb1_div_set (crm_apb1_div_type value)
set crm apb1 division More...
void | crm_apb2_div_set (crm_apb2_div_type value)
set crm apb2 division More...
void | crm_usb_clock_div_set (crm_usb_div_type value)
set usb division More...
void | crm_clock_failure_detection_enable (confirm_state new_state)
enable or disable clock failure detection More...
void | crm_battery_powered_domain_reset (confirm_state new_state)
battery powered domain software reset More...
void | crm_auto_step_mode_enable (confirm_state new_state)
auto step clock switch enable More...
void | crm_hick_divider_select (crm_hick_div_6_type value)
config hick divider select More...
void | crm_hick_sclk_frequency_select (crm_hick_sclk_frequency_type value)
hick as system clock frequency select More...
void | crm_usb_clock_source_select (crm_usb_clock_source_type value)
usb 48 mhz clock source select More...
void | crm_clkout_to_tmr10_enable (confirm_state new_state)
enable or disable clkout direct to tmr10 channel 1 More...
void | crm_pll_config (crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n attemtion: 31 <= pll_ns <= 500 1 <= pll_ms <= 15 More...
void | crm_sysclk_switch (crm_sclk_type value)
select system clock source More...
crm_sclk_type | crm_sysclk_switch_status_get (void)
indicate which clock source is used as system clock More...
void | crm_clocks_freq_get (crm_clocks_freq_type *clocks_struct)
get crm clocks freqency More...
void | crm_clock_out1_set (crm_clkout1_select_type clkout)
set crm clkout1 More...
void | crm_clock_out2_set (crm_clkout2_select_type clkout)
set crm clkout2 More...
void | crm_clkout_div_set (crm_clkout_index_type index, crm_clkout_div1_type div1, crm_clkout_div2_type div2)
set crm clkout1 division1 More...
void | crm_emac_output_pulse_set (crm_emac_output_pulse_type width)
set emac output pulse width More...
void | crm_interrupt_enable (uint32_t crm_int, confirm_state new_state)
config crm interrupt More...
error_status | crm_pll_parameter_calculate (crm_pll_clock_source_type pll_rcs, uint32_t target_sclk_freq, uint16_t *ret_ms, uint16_t *ret_ns, uint16_t *ret_fr)
calculate the pll parameters with pll reference clock and target pll output frequency. pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n attemtion: 31 <= pll_ns <= 500 1 <= pll_ms <= 15 More...

Detailed Description

Function Documentation

◆ crm_ahb_div_set()

void crm_ahb_div_set ( crm_ahb_div_type value )

set crm ahb division

Parameters
value this parameter can be one of the following values:
  • CRM_AHB_DIV_1
  • CRM_AHB_DIV_2
  • CRM_AHB_DIV_4
  • CRM_AHB_DIV_8
  • CRM_AHB_DIV_16
  • CRM_AHB_DIV_64
  • CRM_AHB_DIV_128
  • CRM_AHB_DIV_256
  • CRM_AHB_DIV_512
Return values
none

Definition at line 465 of file at32f435_437_crm.c.

Referenced by sclk_288m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_200mhz().

◆ crm_apb1_div_set()

void crm_apb1_div_set ( crm_apb1_div_type value )

set crm apb1 division

Parameters
value this parameter can be one of the following values:
  • CRM_APB1_DIV_1
  • CRM_APB1_DIV_2
  • CRM_APB1_DIV_4
  • CRM_APB1_DIV_8
  • CRM_APB1_DIV_16
Return values
none

Definition at line 481 of file at32f435_437_crm.c.

Referenced by main(), sclk_288m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_200mhz().

◆ crm_apb2_div_set()

void crm_apb2_div_set ( crm_apb2_div_type value )

set crm apb2 division

Parameters
value this parameter can be one of the following values:
  • CRM_APB2_DIV_1
  • CRM_APB2_DIV_2
  • CRM_APB2_DIV_4
  • CRM_APB2_DIV_8
  • CRM_APB2_DIV_16
Return values
none

Definition at line 497 of file at32f435_437_crm.c.

Referenced by sclk_288m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_200mhz().

◆ crm_auto_step_mode_enable()

void crm_auto_step_mode_enable ( confirm_state new_state )

auto step clock switch enable

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 551 of file at32f435_437_crm.c.

Referenced by sclk_288m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_200mhz(), and system_clock_recover().

◆ crm_battery_powered_domain_reset()

void crm_battery_powered_domain_reset ( confirm_state new_state )

battery powered domain software reset

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 541 of file at32f435_437_crm.c.

Referenced by ertc_config().

◆ crm_clkout_div_set()

void crm_clkout_div_set | ( | crm_clkout_index_type | index,
 |  | crm_clkout_div1_type | div1,
 |  | crm_clkout_div2_type | div2
 | ) |  |

set crm clkout1 division1

Parameters
div1 this parameter can be one of the following values:
  • CRM_CLKOUT_INDEX_1
  • CRM_CLKOUT_INDEX_2
div1 this parameter can be one of the following values:
  • CRM_CLKOUT_DIV1_1
  • CRM_CLKOUT_DIV1_2
  • CRM_CLKOUT_DIV1_3
  • CRM_CLKOUT_DIV1_4
  • CRM_CLKOUT_DIV1_5
div2 this parameter can be one of the following values:
  • CRM_CLKOUT_DIV2_1
  • CRM_CLKOUT_DIV2_2
  • CRM_CLKOUT_DIV2_4
  • CRM_CLKOUT_DIV2_8
  • CRM_CLKOUT_DIV2_16
  • CRM_CLKOUT_DIV2_64
  • CRM_CLKOUT_DIV2_128
  • CRM_CLKOUT_DIV2_256
  • CRM_CLKOUT_DIV2_512
Return values
none

Definition at line 831 of file at32f435_437_crm.c.

Referenced by clkout_config(), and emac_layer2_configuration().

◆ crm_clkout_to_tmr10_enable()

void crm_clkout_to_tmr10_enable ( confirm_state new_state )

enable or disable clkout direct to tmr10 channel 1

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 608 of file at32f435_437_crm.c.

◆ crm_clock_failure_detection_enable()

void crm_clock_failure_detection_enable ( confirm_state new_state )

enable or disable clock failure detection

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 531 of file at32f435_437_crm.c.

Referenced by clock_failure_detection_handler(), and main().

◆ crm_clock_out1_set()

void crm_clock_out1_set ( crm_clkout1_select_type clkout )

set crm clkout1

Parameters
clkout this parameter can be one of the following values:
  • CRM_CLKOUT1_HICK
  • CRM_CLKOUT1_LEXT
  • CRM_CLKOUT1_HEXT
  • CRM_CLKOUT1_PLL
Return values
none

Definition at line 773 of file at32f435_437_crm.c.

Referenced by clkout_config(), and emac_layer2_configuration().

◆ crm_clock_out2_set()

void crm_clock_out2_set ( crm_clkout2_select_type clkout )

set crm clkout2

Parameters
clkout this parameter can be one of the following values:
  • CRM_CLKOUT2_SCLK
  • CRM_CLKOUT2_HEXT
  • CRM_CLKOUT2_PLL
  • CRM_CLKOUT2_USB
  • CRM_CLKOUT2_ADC
  • CRM_CLKOUT2_HICK
  • CRM_CLKOUT2_LICK
  • CRM_CLKOUT2_LEXT
Return values
none

Definition at line 792 of file at32f435_437_crm.c.

◆ crm_clock_source_enable()

void crm_clock_source_enable | ( | crm_clock_source_type | source,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the crm clock source

Parameters
source this parameter can be one of the following values:
  • CRM_CLOCK_SOURCE_HICK
  • CRM_CLOCK_SOURCE_HEXT
  • CRM_CLOCK_SOURCE_PLL
  • CRM_CLOCK_SOURCE_LEXT
  • CRM_CLOCK_SOURCE_LICK
new_state (TRUE or FALSE)
Return values
none

Definition at line 314 of file at32f435_437_crm.c.

Referenced by ertc_config(), sclk_288m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_200mhz(), and system_clock_recover().

◆ crm_clocks_freq_get()

void crm_clocks_freq_get ( crm_clocks_freq_type * clocks_struct )

get crm clocks freqency

Parameters
clocks_struct
  • pointer to the crm_clocks_freq_type structure
Return values
none

< value of the high speed internal clock in hz

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

< value of the high speed internal clock in hz

Definition at line 691 of file at32f435_437_crm.c.

Referenced by emac_clock_range_set(), emac_tmr_init(), i2s_init(), lick_frequency_get(), main(), tmr1_config(), tmr2_config(), tmr_init(), usart_configuration(), and usart_init().

◆ crm_emac_output_pulse_set()

void crm_emac_output_pulse_set ( crm_emac_output_pulse_type width )

set emac output pulse width

Parameters
width this parameter can be one of the following values:
  • CRM_EMAC_PULSE_125MS
  • CRM_EMAC_PULSE_1SCLK
Return values
none

Definition at line 853 of file at32f435_437_crm.c.

◆ crm_ertc_clock_enable()

void crm_ertc_clock_enable ( confirm_state new_state )

enable or disable ertc

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 445 of file at32f435_437_crm.c.

Referenced by ertc_config().

◆ crm_ertc_clock_select()

void crm_ertc_clock_select ( crm_ertc_clock_type value )

select ertc clock

Parameters
value this parameter can be one of the following values:
  • CRM_ERTC_CLOCK_NOCLK
  • CRM_ERTC_CLOCK_LEXT
  • CRM_ERTC_CLOCK_LICK
  • CRM_ERTC_CLOCK_HEXT_DIV_2
  • CRM_ERTC_CLOCK_HEXT_DIV_3
  • CRM_ERTC_CLOCK_HEXT_DIV_4
  • CRM_ERTC_CLOCK_HEXT_DIV_5
  • CRM_ERTC_CLOCK_HEXT_DIV_6
  • CRM_ERTC_CLOCK_HEXT_DIV_7
  • CRM_ERTC_CLOCK_HEXT_DIV_8
  • CRM_ERTC_CLOCK_HEXT_DIV_9
  • CRM_ERTC_CLOCK_HEXT_DIV_10
  • CRM_ERTC_CLOCK_HEXT_DIV_11
  • CRM_ERTC_CLOCK_HEXT_DIV_12
  • CRM_ERTC_CLOCK_HEXT_DIV_13
  • CRM_ERTC_CLOCK_HEXT_DIV_14
  • CRM_ERTC_CLOCK_HEXT_DIV_15
  • CRM_ERTC_CLOCK_HEXT_DIV_16
  • CRM_ERTC_CLOCK_HEXT_DIV_17
  • CRM_ERTC_CLOCK_HEXT_DIV_18
  • CRM_ERTC_CLOCK_HEXT_DIV_19
  • CRM_ERTC_CLOCK_HEXT_DIV_20
  • CRM_ERTC_CLOCK_HEXT_DIV_21
  • CRM_ERTC_CLOCK_HEXT_DIV_22
  • CRM_ERTC_CLOCK_HEXT_DIV_23
  • CRM_ERTC_CLOCK_HEXT_DIV_24
  • CRM_ERTC_CLOCK_HEXT_DIV_25
  • CRM_ERTC_CLOCK_HEXT_DIV_26
  • CRM_ERTC_CLOCK_HEXT_DIV_27
  • CRM_ERTC_CLOCK_HEXT_DIV_28
  • CRM_ERTC_CLOCK_HEXT_DIV_29
  • CRM_ERTC_CLOCK_HEXT_DIV_30
  • CRM_ERTC_CLOCK_HEXT_DIV_31
Return values
none

Definition at line 434 of file at32f435_437_crm.c.

Referenced by ertc_config().

◆ crm_flag_clear()

void crm_flag_clear ( uint32_t flag )

clear the crm reset flags

Parameters
flag this parameter can be one of the following values: reset flag:
  • CRM_PIN_RESET_FLAG
  • CRM_POR_RESET_FLAG
  • CRM_SW_RESET_FLAG
  • CRM_WDT_RESET_FLAG
  • CRM_WWDT_RESET_FLAG
  • CRM_LOWPOWER_RESET_FLAG
  • CRM_ALL_RESET_FLAG interrupt flag:
  • CRM_LICK_READY_INT_FLAG
  • CRM_LEXT_READY_INT_FLAG
  • CRM_HICK_READY_INT_FLAG
  • CRM_HEXT_READY_INT_FLAG
  • CRM_PLL_READY_INT_FLAG
  • CRM_CLOCK_FAILURE_INT_FLAG
Return values
none

< nrst pin reset flag

< power on reset flag

< software reset flag

< watchdog timer reset flag

< window watchdog timer reset flag

< low-power reset flag

< all reset flag

< low speed internal clock stable interrupt ready flag

< low speed external crystal stable interrupt ready flag

< high speed internal clock stable interrupt ready flag

< high speed external crystal stable interrupt ready flag

< phase locking loop stable interrupt ready flag

< clock failure interrupt ready flag

Definition at line 358 of file at32f435_437_crm.c.

Referenced by clock_failure_detection_handler(), and main().

◆ crm_flag_get()

flag_status crm_flag_get ( uint32_t flag )

get crm flag status

Parameters
flag this parameter can be one of the following values:
  • CRM_HICK_STABLE_FLAG
  • CRM_HEXT_STABLE_FLAG
  • CRM_PLL_STABLE_FLAG
  • CRM_LEXT_STABLE_FLAG
  • CRM_LICK_STABLE_FLAG
  • CRM_PIN_RESET_FLAG
  • CRM_POR_RESET_FLAG
  • CRM_SW_RESET_FLAG
  • CRM_WDT_RESET_FLAG
  • CRM_WWDT_RESET_FLAG
  • CRM_LOWPOWER_RESET_FLAG interrupt flag:
  • CRM_LICK_READY_INT_FLAG
  • CRM_LEXT_READY_INT_FLAG
  • CRM_HICK_READY_INT_FLAG
  • CRM_HEXT_READY_INT_FLAG
  • CRM_PLL_READY_INT_FLAG
  • CRM_CLOCK_FAILURE_INT_FLAG
Return values
flag_status (SET or RESET)

Definition at line 124 of file at32f435_437_crm.c.

Referenced by clock_failure_detection_handler(), crm_hext_stable_wait(), ertc_config(), main(), sclk_288m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_200mhz(), and system_clock_recover().

◆ crm_hext_bypass()

void crm_hext_bypass ( confirm_state new_state )

enable or disable crm high speed external crystal bypass

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 95 of file at32f435_437_crm.c.

◆ crm_hext_stable_wait()

error_status crm_hext_stable_wait ( void )

wait for hext stable

Parameters
none
Return values
error_status (ERROR or SUCCESS)

< high speed external crystal stable flag

< time out for hext start up

< high speed external crystal stable flag

Definition at line 143 of file at32f435_437_crm.c.

Referenced by sclk_96m_hext_config(), system_clock_config(), system_clock_config_200mhz(), and system_clock_recover().

◆ crm_hick_clock_calibration_set()

void crm_hick_clock_calibration_set ( uint8_t cali_value )

set the crm calibration value

Parameters
cali_value (0x00~0xFF)
Return values
none

Definition at line 180 of file at32f435_437_crm.c.

◆ crm_hick_clock_trimming_set()

void crm_hick_clock_trimming_set ( uint8_t trim_value )

set the hick trimming value

Parameters
trim_value (0x00~0x3F)
Return values
none

Definition at line 170 of file at32f435_437_crm.c.

◆ crm_hick_divider_select()

void crm_hick_divider_select ( crm_hick_div_6_type value )

config hick divider select

Parameters
value this parameter can be one of the following values:
  • CRM_HICK48_DIV6
  • CRM_HICK48_NODIV
Return values
none

Definition at line 567 of file at32f435_437_crm.c.

Referenced by crm_hick_sclk_frequency_select().

◆ crm_hick_sclk_frequency_select()

void crm_hick_sclk_frequency_select ( crm_hick_sclk_frequency_type value )

hick as system clock frequency select

Parameters
value this parameter can be one of the following values:
  • CRM_HICK_SCLK_8MHZ
  • CRM_HICK_SCLK_48MHZ
Return values
none

Definition at line 580 of file at32f435_437_crm.c.

Referenced by crm_usb_clock_source_select().

◆ crm_interrupt_enable()

void crm_interrupt_enable | ( | uint32_t | crm_int,
 |  | confirm_state | new_state
 | ) |  |

config crm interrupt

Parameters
int this parameter can be any combination of the following values:
  • CRM_LICK_STABLE_INT
  • CRM_LEXT_STABLE_INT
  • CRM_HICK_STABLE_INT
  • CRM_HEXT_STABLE_INT
  • CRM_PLL_STABLE_INT
new_state (TRUE or FALSE)
Return values
none

Definition at line 870 of file at32f435_437_crm.c.

◆ crm_lext_bypass()

void crm_lext_bypass ( confirm_state new_state )

enable or disable crm low speed external crystal bypass

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 85 of file at32f435_437_crm.c.

◆ crm_periph_clock_enable()

void crm_periph_clock_enable | ( | crm_periph_clock_type | value,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the peripheral clock

Parameters
value this parameter can be one of the following values:
  • CRM_GPIOA_PERIPH_CLOCK - CRM_GPIOB_PERIPH_CLOCK - CRM_GPIOC_PERIPH_CLOCK - CRM_GPIOD_PERIPH_CLOCK
  • CRM_GPIOE_PERIPH_CLOCK - CRM_GPIOF_PERIPH_CLOCK - CRM_GPIOG_PERIPH_CLOCK - CRM_GPIOH_PERIPH_CLOCK
  • CRM_CRC_PERIPH_CLOCK - CRM_EDMA_PERIPH_CLOCK - CRM_DMA1_PERIPH_CLOCK - CRM_DMA2_PERIPH_CLOCK
  • CRM_EMAC_PERIPH_CLOCK - CRM_EMACTX_PERIPH_CLOCK - CRM_EMACRX_PERIPH_CLOCK - CRM_EMACPTP_PERIPH_CLOCK
  • CRM_OTGFS2_PERIPH_CLOCK - CRM_DVP_PERIPH_CLOCK - CRM_OTGFS1_PERIPH_CLOCK - CRM_SDIO1_PERIPH_CLOCK
  • CRM_XMC_PERIPH_CLOCK - CRM_QSPI1_PERIPH_CLOCK - CRM_QSPI2_PERIPH_CLOCK - CRM_SDIO2_PERIPH_CLOCK
  • CRM_TMR2_PERIPH_CLOCK - CRM_TMR3_PERIPH_CLOCK - CRM_TMR4_PERIPH_CLOCK - CRM_TMR5_PERIPH_CLOCK
  • CRM_TMR6_PERIPH_CLOCK - CRM_TMR7_PERIPH_CLOCK - CRM_TMR12_PERIPH_CLOCK - CRM_TMR13_PERIPH_CLOCK
  • CRM_TMR14_PERIPH_CLOCK - CRM_WWDT_PERIPH_CLOCK - CRM_SPI2_PERIPH_CLOCK - CRM_SPI3_PERIPH_CLOCK
  • CRM_USART2_PERIPH_CLOCK - CRM_USART3_PERIPH_CLOCK - CRM_UART4_PERIPH_CLOCK - CRM_UART5_PERIPH_CLOCK
  • CRM_I2C1_PERIPH_CLOCK - CRM_I2C2_PERIPH_CLOCK - CRM_I2C3_PERIPH_CLOCK - CRM_CAN1_PERIPH_CLOCK
  • CRM_CAN2_PERIPH_CLOCK - CRM_PWC_PERIPH_CLOCK - CRM_DAC_PERIPH_CLOCK - CRM_UART7_PERIPH_CLOCK
  • CRM_UART8_PERIPH_CLOCK - CRM_TMR1_PERIPH_CLOCK - CRM_TMR8_PERIPH_CLOCK - CRM_USART1_PERIPH_CLOCK
  • CRM_USART6_PERIPH_CLOCK - CRM_ADC1_PERIPH_CLOCK - CRM_ADC2_PERIPH_CLOCK - CRM_ADC3_PERIPH_CLOCK
  • CRM_SPI1_PERIPH_CLOCK - CRM_SPI4_PERIPH_CLOCK - CRM_SCFG_PERIPH_CLOCK - CRM_TMR9_PERIPH_CLOCK
  • CRM_TMR10_PERIPH_CLOCK - CRM_TMR11_PERIPH_CLOCK - CRM_TMR20_PERIPH_CLOCK - CRM_ACC_PERIPH_CLOCK
new_state (TRUE or FALSE)
Return values
none

Definition at line 215 of file at32f435_437_crm.c.

Referenced by adc_config(), adc_configuration(), app_load(), at32_button_init(), at32_led_init(), button_exint_init(), can_configuration(), can_gpio_config(), clkout_config(), codec_i2s_init(), crc_cal(), crm_configuration(), dma_config(), dma_configuration(), dvp_dma_init(), dvp_io_init(), edma_config(), emac_layer2_configuration(), emac_pins_configuration(), emac_system_init(), emac_tmr_init(), emac_wake_on_lan_init(), ertc_config(), exint_config(), exint_line0_config(), exint_line4_config(), flash_crc_check(), gpio_config(), i2c_lowlevel_init(), i2s_config(), jump_to_app(), lick_frequency_get(), main(), mclk_tmr1_init(), nand_init(), nor_init(), ov2640_init(), ov5640_init(), psram_init(), qspi_config(), reset_phy(), rs485_config(), sclk_288m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), sd_dma_config(), sd_init(), sdram_copy_to_sram_dma(), sdram_init(), spi_config(), spiflash_init(), sram_copy_to_sdram_dma(), sram_init(), swj_dp_config(), system_clock_config(), system_clock_config_200mhz(), tmr1_config(), tmr2_config(), TMR3_GLOBAL_IRQHandler(), tmr_init(), touch_pin_init(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), usart_spi_configuration(), usb_clock48m_select(), usb_gpio_config(), usb_usart_config(), and xmc_init().

◆ crm_periph_lowpower_mode_enable()

void crm_periph_lowpower_mode_enable | ( | crm_periph_clock_lowpower_type | value,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the peripheral clock in lowpower mode

Parameters
value this parameter can be one of the following values:
  • CRM_GPIOA_PERIPH_LOWPOWER - CRM_GPIOB_PERIPH_LOWPOWER - CRM_GPIOC_PERIPH_LOWPOWER - CRM_GPIOD_PERIPH_LOWPOWER
  • CRM_GPIOE_PERIPH_LOWPOWER - CRM_GPIOF_PERIPH_LOWPOWER - CRM_GPIOG_PERIPH_LOWPOWER - CRM_GPIOH_PERIPH_LOWPOWER
  • CRM_CRC_PERIPH_LOWPOWER - CRM_EDMA_PERIPH_LOWPOWER - CRM_DMA1_PERIPH_LOWPOWER - CRM_DMA2_PERIPH_LOWPOWER
  • CRM_EMAC_PERIPH_LOWPOWER - CRM_EMACTX_PERIPH_LOWPOWER - CRM_EMACRX_PERIPH_LOWPOWER - CRM_EMACPTP_PERIPH_LOWPOWER
  • CRM_OTGFS2_PERIPH_LOWPOWER - CRM_DVP_PERIPH_LOWPOWER - CRM_OTGFS1_PERIPH_LOWPOWER - CRM_SDIO1_PERIPH_LOWPOWER
  • CRM_XMC_PERIPH_LOWPOWER - CRM_QSPI1_PERIPH_LOWPOWER - CRM_QSPI2_PERIPH_LOWPOWER - CRM_SDIO2_PERIPH_LOWPOWER
  • CRM_TMR2_PERIPH_LOWPOWER - CRM_TMR3_PERIPH_LOWPOWER - CRM_TMR4_PERIPH_LOWPOWER - CRM_TMR5_PERIPH_LOWPOWER
  • CRM_TMR6_PERIPH_LOWPOWER - CRM_TMR7_PERIPH_LOWPOWER - CRM_TMR12_PERIPH_LOWPOWER - CRM_TMR13_PERIPH_LOWPOWER
  • CRM_TMR14_PERIPH_LOWPOWER - CRM_WWDT_PERIPH_LOWPOWER - CRM_SPI2_PERIPH_LOWPOWER - CRM_SPI3_PERIPH_LOWPOWER
  • CRM_USART2_PERIPH_LOWPOWER - CRM_USART3_PERIPH_LOWPOWER - CRM_UART4_PERIPH_LOWPOWER - CRM_UART5_PERIPH_LOWPOWER
  • CRM_I2C1_PERIPH_LOWPOWER - CRM_I2C2_PERIPH_LOWPOWER - CRM_I2C3_PERIPH_LOWPOWER - CRM_CAN1_PERIPH_LOWPOWER
  • CRM_CAN2_PERIPH_LOWPOWER - CRM_PWC_PERIPH_LOWPOWER - CRM_DAC_PERIPH_LOWPOWER - CRM_UART7_PERIPH_LOWPOWER
  • CRM_UART8_PERIPH_LOWPOWER - CRM_TMR1_PERIPH_LOWPOWER - CRM_TMR8_PERIPH_LOWPOWER - CRM_USART1_PERIPH_LOWPOWER
  • CRM_USART6_PERIPH_LOWPOWER - CRM_ADC1_PERIPH_LOWPOWER - CRM_ADC2_PERIPH_LOWPOWER - CRM_ADC3_PERIPH_LOWPOWER
  • CRM_SPI1_PERIPH_LOWPOWER - CRM_SPI4_PERIPH_LOWPOWER - CRM_SCFG_PERIPH_LOWPOWER - CRM_TMR9_PERIPH_LOWPOWER
  • CRM_TMR10_PERIPH_LOWPOWER - CRM_TMR11_PERIPH_LOWPOWER - CRM_TMR20_PERIPH_LOWPOWER - CRM_ACC_PERIPH_LOWPOWER
new_state (TRUE or FALSE)
Return values
none

Definition at line 288 of file at32f435_437_crm.c.

◆ crm_periph_reset()

void crm_periph_reset | ( | crm_periph_reset_type | value,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the peripheral reset

Parameters
value this parameter can be one of the following values:
  • CRM_GPIOA_PERIPH_RESET - CRM_GPIOB_PERIPH_RESET - CRM_GPIOC_PERIPH_RESET - CRM_GPIOD_PERIPH_RESET
  • CRM_GPIOE_PERIPH_RESET - CRM_GPIOF_PERIPH_RESET - CRM_GPIOG_PERIPH_RESET - CRM_GPIOH_PERIPH_RESET
  • CRM_CRC_PERIPH_RESET - CRM_EDMA_PERIPH_RESET - CRM_DMA1_PERIPH_RESET - CRM_DMA2_PERIPH_RESET
  • CRM_EMAC_PERIPH_RESET - CRM_OTGFS2_PERIPH_RESET - CRM_DVP_PERIPH_RESET - CRM_OTGFS1_PERIPH_RESET
  • CRM_SDIO1_PERIPH_RESET - CRM_XMC_PERIPH_RESET - CRM_QSPI1_PERIPH_RESET - CRM_QSPI2_PERIPH_RESET
  • CRM_SDIO2_PERIPH_RESET - CRM_TMR2_PERIPH_RESET - CRM_TMR3_PERIPH_RESET - CRM_TMR4_PERIPH_RESET
  • CRM_TMR5_PERIPH_RESET - CRM_TMR6_PERIPH_RESET - CRM_TMR7_PERIPH_RESET - CRM_TMR12_PERIPH_RESET
  • CRM_TMR13_PERIPH_RESET - CRM_TMR14_PERIPH_RESET - CRM_WWDT_PERIPH_RESET - CRM_SPI2_PERIPH_RESET
  • CRM_SPI3_PERIPH_RESET - CRM_USART2_PERIPH_RESET - CRM_USART3_PERIPH_RESET - CRM_UART4_PERIPH_RESET
  • CRM_UART5_PERIPH_RESET - CRM_I2C1_PERIPH_RESET - CRM_I2C2_PERIPH_RESET - CRM_I2C3_PERIPH_RESET
  • CRM_CAN1_PERIPH_RESET - CRM_CAN2_PERIPH_RESET - CRM_PWC_PERIPH_RESET - CRM_DAC_PERIPH_RESET
  • CRM_UART7_PERIPH_RESET - CRM_UART8_PERIPH_RESET - CRM_TMR1_PERIPH_RESET - CRM_TMR8_PERIPH_RESET
  • CRM_USART1_PERIPH_RESET - CRM_USART6_PERIPH_RESET - CRM_ADC_PERIPH_RESET - CRM_SPI1_PERIPH_RESET
  • CRM_SPI4_PERIPH_RESET - CRM_SCFG_PERIPH_RESET - CRM_TMR9_PERIPH_RESET - CRM_TMR10_PERIPH_RESET
  • CRM_TMR11_PERIPH_RESET - CRM_TMR20_PERIPH_RESET - CRM_ACC_PERIPH_RESET
new_state (TRUE or FALSE)
Return values
none

Definition at line 251 of file at32f435_437_crm.c.

Referenced by adc_reset(), can_reset(), dac_reset(), dvp_reset(), emac_reset(), gpio_reset(), i2c_reset(), jump_to_app(), pwc_reset(), scfg_reset(), spi_i2s_reset(), tmr_reset(), usart_reset(), and wwdt_reset().

◆ crm_pll_config()

void crm_pll_config | ( | crm_pll_clock_source_type | clock_source,
 |  | uint16_t | pll_ns,
 |  | uint16_t | pll_ms,
 |  | crm_pll_fr_type | pll_fr
 | ) |  |

config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n attemtion: 31 <= pll_ns <= 500 1 <= pll_ms <= 15

 pll_rcs_freq

2mhz <= -------------------— <= 16mhz pll_ms

pll_rcs_freq * pll_ns 500mhz <= -----------------------------— <= 1000mhz pll_ms

Parameters
clock_source this parameter can be one of the following values:
  • CRM_PLL_SOURCE_HICK
  • CRM_PLL_SOURCE_HEXT
pll_ns | (31~500)
pll_ms | (1~15)
pll_fr this parameter can be one of the following values:
  • CRM_PLL_FR_1
  • CRM_PLL_FR_2
  • CRM_PLL_FR_4
  • CRM_PLL_FR_8
  • CRM_PLL_FR_16
  • CRM_PLL_FR_32
Return values
none

Definition at line 645 of file at32f435_437_crm.c.

Referenced by sclk_288m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_200mhz().

◆ crm_pll_parameter_calculate()

error_status crm_pll_parameter_calculate | ( | crm_pll_clock_source_type | pll_rcs,
 |  | uint32_t | target_sclk_freq,
 |  | uint16_t * | ret_ms,
 |  | uint16_t * | ret_ns,
 |  | uint16_t * | ret_fr
 | ) |  |

calculate the pll parameters with pll reference clock and target pll output frequency. pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n attemtion: 31 <= pll_ns <= 500 1 <= pll_ms <= 15

 pll_rcs_freq

2mhz <= -------------------— <= 16mhz pll_ms

pll_rcs_freq * pll_ns 500mhz <= -----------------------------— <= 1000mhz pll_ms

Parameters
pll_rcs this parameter can be one of the following values:
  • CRM_PLL_SOURCE_HICK
  • CRM_PLL_SOURCE_HEXT
target_sclk_freq | target pll output frequency, such as 200 mhz (target_sclk_freq: 200000000)
ret_ms | pointer to ms value, return the pll_ms of pll parameters
ret_ns | pointer to ns value, return the pll_ns of pll parameters
ret_fr | pointer to fr value, return the pll_fr of pll parameters
Return values
error_status (SUCCESS or ERROR)

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

Definition at line 904 of file at32f435_437_crm.c.

Referenced by system_clock_config_200mhz().

◆ crm_reset()

void crm_reset ( void )

reset the crm register

Parameters
none
Return values
none

Definition at line 49 of file at32f435_437_crm.c.

Referenced by app_update_handle(), sclk_288m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_200mhz().

◆ crm_sysclk_switch()

void crm_sysclk_switch ( crm_sclk_type value )

select system clock source

Parameters
value this parameter can be one of the following values:
  • CRM_SCLK_HICK
  • CRM_SCLK_HEXT
  • CRM_SCLK_PLL
Return values
none

Definition at line 666 of file at32f435_437_crm.c.

Referenced by main(), sclk_288m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_200mhz(), and system_clock_recover().

◆ crm_sysclk_switch_status_get()

crm_sclk_type crm_sysclk_switch_status_get ( void )

indicate which clock source is used as system clock

Parameters
none
Return values
crm_sclk this return can be one of the following values:
  • CRM_SCLK_HICK
  • CRM_SCLK_HEXT
  • CRM_SCLK_PLL

Definition at line 680 of file at32f435_437_crm.c.

Referenced by crm_clocks_freq_get(), main(), sclk_288m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_200mhz(), system_clock_recover(), and system_core_clock_update().

◆ crm_usb_clock_div_set()

void crm_usb_clock_div_set ( crm_usb_div_type value )

set usb division

Parameters
value this parameter can be one of the following values:
  • CRM_USB_DIV_1_5
  • CRM_USB_DIV_1
  • CRM_USB_DIV_2_5
  • CRM_USB_DIV_2
  • CRM_USB_DIV_3_5
  • CRM_USB_DIV_3
  • CRM_USB_DIV_4_5
  • CRM_USB_DIV_4
  • CRM_USB_DIV_5_5
  • CRM_USB_DIV_5
  • CRM_USB_DIV_6_5
  • CRM_USB_DIV_6
  • CRM_USB_DIV_7
Return values
none

Definition at line 521 of file at32f435_437_crm.c.

Referenced by usb_clock48m_select().

◆ crm_usb_clock_source_select()

void crm_usb_clock_source_select ( crm_usb_clock_source_type value )

usb 48 mhz clock source select

Parameters
value this parameter can be one of the following values:
  • CRM_USB_CLOCK_SOURCE_PLL
  • CRM_USB_CLOCK_SOURCE_HICK
Return values
none

Definition at line 594 of file at32f435_437_crm.c.

Referenced by usb_clock48m_select().


AT32F435/437 Firmwary Library: DAC

Modules | Macros
DAC
AT32F435_437_periph_driver

DAC driver modules. More...

Modules

DAC_exported_types
DAC_exported_functions
DAC_private_functions

Macros

#define | DAC1_D1DMAUDRF ((uint32_t)(0x00002000))
#define | DAC2_D2DMAUDRF ((uint32_t)(0x20000000))
#define | DAC ((dac_type *) DAC_BASE)

Detailed Description

DAC driver modules.

Macro Definition Documentation

◆ DAC

#define DAC ((dac_type *) DAC_BASE)

Definition at line 354 of file at32f435_437_dac.h.

◆ DAC1_D1DMAUDRF

#define DAC1_D1DMAUDRF ((uint32_t)(0x00002000))

Definition at line 47 of file at32f435_437_dac.h.

◆ DAC2_D2DMAUDRF

#define DAC2_D2DMAUDRF ((uint32_t)(0x20000000))

Definition at line 48 of file at32f435_437_dac.h.


AT32F435/437 Firmwary Library: DAC_exported_types

Data Structures | Enumerations
DAC_exported_types
AT32F435_437_periph_driver » DAC

Data Structures

struct dac_type
type define dac register all More...

Enumerations

enum | dac_select_type { DAC1_SELECT = 0x01 , DAC2_SELECT = 0x02 }
dac select type More...
enum dac_trigger_type {
DAC_TMR6_TRGOUT_EVENT = 0x00 , DAC_TMR8_TRGOUT_EVENT = 0x01 , DAC_TMR7_TRGOUT_EVENT = 0x02 , DAC_TMR5_TRGOUT_EVENT = 0x03 ,
DAC_TMR2_TRGOUT_EVENT = 0x04 , DAC_TMR4_TRGOUT_EVENT = 0x05 , DAC_EXTERNAL_INTERRUPT_LINE_9 = 0x06 , DAC_SOFTWARE_TRIGGER = 0x07
}
dac trigger type More...
enum | dac_wave_type { DAC_WAVE_GENERATE_NONE = 0x00 , DAC_WAVE_GENERATE_NOISE = 0x01 , DAC_WAVE_GENERATE_TRIANGLE = 0x02 }
dac wave type More...
enum dac_mask_amplitude_type {
DAC_LSFR_BIT0_AMPLITUDE_1 = 0x00 , DAC_LSFR_BIT10_AMPLITUDE_3 = 0x01 , DAC_LSFR_BIT20_AMPLITUDE_7 = 0x02 , DAC_LSFR_BIT30_AMPLITUDE_15 = 0x03 ,
DAC_LSFR_BIT40_AMPLITUDE_31 = 0x04 , DAC_LSFR_BIT50_AMPLITUDE_63 = 0x05 , DAC_LSFR_BIT60_AMPLITUDE_127 = 0x06 , DAC_LSFR_BIT70_AMPLITUDE_255 = 0x07 ,
DAC_LSFR_BIT80_AMPLITUDE_511 = 0x08 , DAC_LSFR_BIT90_AMPLITUDE_1023 = 0x09 , DAC_LSFR_BITA0_AMPLITUDE_2047 = 0x0A , DAC_LSFR_BITB0_AMPLITUDE_4095 = 0x0B
}
dac mask amplitude type More...
enum | dac1_aligned_data_type { DAC1_12BIT_RIGHT = 0x40007408 , DAC1_12BIT_LEFT = 0x4000740C , DAC1_8BIT_RIGHT = 0x40007410 }
dac1 aligned data type More...
enum | dac2_aligned_data_type { DAC2_12BIT_RIGHT = 0x40007414 , DAC2_12BIT_LEFT = 0x40007418 , DAC2_8BIT_RIGHT = 0x4000741C }
dac2 aligned data type More...
enum | dac_dual_data_type { DAC_DUAL_12BIT_RIGHT = 0x40007420 , DAC_DUAL_12BIT_LEFT = 0x40007424 , DAC_DUAL_8BIT_RIGHT = 0x40007428 }
dac dual data type More...

Detailed Description

Enumeration Type Documentation

◆ dac1_aligned_data_type

enum dac1_aligned_data_type

dac1 aligned data type

Enumerator
DAC1_12BIT_RIGHT | dac1 12-bit data right-aligned
DAC1_12BIT_LEFT | dac1 12-bit data left-aligned
DAC1_8BIT_RIGHT | dac1 8-bit data right-aligned

Definition at line 110 of file at32f435_437_dac.h.

◆ dac2_aligned_data_type

enum dac2_aligned_data_type

dac2 aligned data type

Enumerator
DAC2_12BIT_RIGHT | dac2 12-bit data right-aligned
DAC2_12BIT_LEFT | dac2 12-bit data left-aligned
DAC2_8BIT_RIGHT | dac2 8-bit data right-aligned

Definition at line 120 of file at32f435_437_dac.h.

◆ dac_dual_data_type

enum dac_dual_data_type

dac dual data type

Enumerator
DAC_DUAL_12BIT_RIGHT | double dac 12-bit data right-aligned
DAC_DUAL_12BIT_LEFT | double dac 12-bit data left-aligned
DAC_DUAL_8BIT_RIGHT | double dac 8-bit data right-aligned

Definition at line 130 of file at32f435_437_dac.h.

◆ dac_mask_amplitude_type

enum dac_mask_amplitude_type

dac mask amplitude type

Enumerator
DAC_LSFR_BIT0_AMPLITUDE_1 | unmask bit0/ triangle amplitude equal to 1
DAC_LSFR_BIT10_AMPLITUDE_3 | unmask bit[1:0]/ triangle amplitude equal to 3
DAC_LSFR_BIT20_AMPLITUDE_7 | unmask bit[2:0]/ triangle amplitude equal to 7
DAC_LSFR_BIT30_AMPLITUDE_15 | unmask bit[3:0]/ triangle amplitude equal to 15
DAC_LSFR_BIT40_AMPLITUDE_31 | unmask bit[4:0]/ triangle amplitude equal to 31
DAC_LSFR_BIT50_AMPLITUDE_63 | unmask bit[5:0]/ triangle amplitude equal to 63
DAC_LSFR_BIT60_AMPLITUDE_127 | unmask bit[6:0]/ triangle amplitude equal to 127
DAC_LSFR_BIT70_AMPLITUDE_255 | unmask bit[7:0]/ triangle amplitude equal to 255
DAC_LSFR_BIT80_AMPLITUDE_511 | unmask bit[8:0]/ triangle amplitude equal to 511
DAC_LSFR_BIT90_AMPLITUDE_1023 | unmask bit[9:0]/ triangle amplitude equal to 1023
DAC_LSFR_BITA0_AMPLITUDE_2047 | unmask bit[10:0]/ triangle amplitude equal to 2047
DAC_LSFR_BITB0_AMPLITUDE_4095 | unmask bit[11:0]/ triangle amplitude equal to 4095

Definition at line 91 of file at32f435_437_dac.h.

◆ dac_select_type

enum dac_select_type

dac select type

Enumerator
DAC1_SELECT | dac1 select
DAC2_SELECT | dac2 select

Definition at line 57 of file at32f435_437_dac.h.

◆ dac_trigger_type

enum dac_trigger_type

dac trigger type

Enumerator
DAC_TMR6_TRGOUT_EVENT | dac trigger selection:timer6 trgout event
DAC_TMR8_TRGOUT_EVENT | dac trigger selection:timer8 trgout event
DAC_TMR7_TRGOUT_EVENT | dac trigger selection:timer7 trgout event
DAC_TMR5_TRGOUT_EVENT | dac trigger selection:timer5 trgout event
DAC_TMR2_TRGOUT_EVENT | dac trigger selection:timer2 trgout event
DAC_TMR4_TRGOUT_EVENT | dac trigger selection:timer4 trgout event
DAC_EXTERNAL_INTERRUPT_LINE_9 | dac trigger selection:external line9
DAC_SOFTWARE_TRIGGER | dac trigger selection:software trigger

Definition at line 66 of file at32f435_437_dac.h.

◆ dac_wave_type

enum dac_wave_type

dac wave type

Enumerator
DAC_WAVE_GENERATE_NONE | dac wave generation disabled
DAC_WAVE_GENERATE_NOISE | dac noise wave generation enabled
DAC_WAVE_GENERATE_TRIANGLE | dac triangle wave generation enabled

Definition at line 81 of file at32f435_437_dac.h.


AT32F435/437 Firmwary Library: dac_type Struct Reference

Data Fields
dac_type Struct Reference
AT32F435_437_periph_driver » DAC » DAC_exported_types

type define dac register all More...

#include <at32f435_437_dac.h>

Data Fields

union {
__IO uint32_t ctrl
struct {
__IO uint32_t d1en: 1
__IO uint32_t d1obdis: 1
__IO uint32_t d1trgen: 1
__IO uint32_t d1trgsel: 3
__IO uint32_t d1nm: 2
__IO uint32_t d1nbsel: 4
__IO uint32_t d1dmaen: 1
__IO uint32_t d1dmaudrien: 1
__IO uint32_t reserved1: 2
__IO uint32_t d2en: 1
__IO uint32_t d2obdis: 1
__IO uint32_t d2trgen: 1
__IO uint32_t d2trgsel: 3
__IO uint32_t d2nm: 2
__IO uint32_t d2nbsel: 4
__IO uint32_t d2dmaen: 1
__IO uint32_t d2dmaudrien: 1
__IO uint32_t reserved2: 2
} ctrl_bit
};
dac ctrl register, offset:0x00 More...
union {
__IO uint32_t swtrg
struct {
__IO uint32_t d1swtrg: 1
__IO uint32_t d2swtrg: 1
__IO uint32_t reserved1: 30
} swtrg_bit
};
dac swtrg register, offset:0x04 More...
union {
__IO uint32_t d1dth12r
struct {
__IO uint32_t d1dt12r: 12
__IO uint32_t reserved1: 20
} d1dth12r_bit
};
dac d1dth12r register, offset:0x08 More...
union {
__IO uint32_t d1dth12l
struct {
__IO uint32_t d1dt12l: 12
__IO uint32_t reserved1: 20
} d1dth12l_bit
};
dac d1dth12l register, offset:0x0C More...
union {
__IO uint32_t d1dth8r
struct {
__IO uint32_t d1dt8r: 8
__IO uint32_t reserved1: 24
} d1dth8r_bit
};
dac d1dth8r register, offset:0x10 More...
union {
__IO uint32_t d2dth12r
struct {
__IO uint32_t d2dt12r: 12
__IO uint32_t reserved1: 20
} d2dth12r_bit
};
dac d2dth12r register, offset:0x14 More...
union {
__IO uint32_t d2dth12l
struct {
__IO uint32_t d2dt12l: 12
__IO uint32_t reserved1: 20
} d2dth12l_bit
};
dac d2dth12l register, offset:0x18 More...
union {
__IO uint32_t d2dth8r
struct {
__IO uint32_t d2dt8r: 8
__IO uint32_t reserved1: 24
} d2dth8r_bit
};
dac d2dth8r register, offset:0x1C More...
union {
__IO uint32_t ddth12r
struct {
__IO uint32_t dd1dt12r: 12
__IO uint32_t reserved1: 4
__IO uint32_t dd2dt12r: 12
__IO uint32_t reserved2: 4
} ddth12r_bit
};
dac ddth12r register, offset:0x20 More...
union {
__IO uint32_t ddth12l
struct {
__IO uint32_t reserved1: 4
__IO uint32_t dd1dt12l: 12
__IO uint32_t reserved2: 4
__IO uint32_t dd2dt12l: 12
} ddth12l_bit
};
dac ddth12l register, offset:0x24 More...
union {
__IO uint32_t ddth8r
struct {
__IO uint32_t dd1dt8r: 8
__IO uint32_t dd2dt8r: 8
__IO uint32_t reserved1: 16
} ddth8r_bit
};
dac ddth8r register, offset:0x28 More...
union {
__IO uint32_t d1odt
struct {
__IO uint32_t d1odt: 12
__IO uint32_t reserved1: 20
} d1odt_bit
};
dac d1odt register, offset:0x2c More...
union {
__IO uint32_t d2odt
struct {
__IO uint32_t d2odt: 12
__IO uint32_t reserved1: 20
} d2odt_bit
};
dac d2odt register, offset:0x30 More...
union {
__IO uint32_t sts
struct {
__IO uint32_t reserved1: 13
__IO uint32_t d1dmaudrf: 1
__IO uint32_t reserved2: 15
__IO uint32_t d2dmaudrf: 1
__IO uint32_t reserved3: 2
} sts_bit
};
dac sr register, offset:0x34 More...

Detailed Description

type define dac register all

Definition at line 140 of file at32f435_437_dac.h.

Field Documentation

◆

union { ... } dac_type::@238

dac ctrl register, offset:0x00

◆

union { ... } dac_type::@240

dac swtrg register, offset:0x04

◆

union { ... } dac_type::@242

dac d1dth12r register, offset:0x08

◆

union { ... } dac_type::@244

dac d1dth12l register, offset:0x0C

◆

union { ... } dac_type::@246

dac d1dth8r register, offset:0x10

◆

union { ... } dac_type::@248

dac d2dth12r register, offset:0x14

◆

union { ... } dac_type::@250

dac d2dth12l register, offset:0x18

◆

union { ... } dac_type::@252

dac d2dth8r register, offset:0x1C

◆

union { ... } dac_type::@254

dac ddth12r register, offset:0x20

◆

union { ... } dac_type::@256

dac ddth12l register, offset:0x24

◆

union { ... } dac_type::@258

dac ddth8r register, offset:0x28

◆

union { ... } dac_type::@260

dac d1odt register, offset:0x2c

◆

union { ... } dac_type::@262

dac d2odt register, offset:0x30

◆

union { ... } dac_type::@264

dac sr register, offset:0x34

◆ ctrl

__IO uint32_t dac_type::ctrl

Definition at line 147 of file at32f435_437_dac.h.

◆

struct { ... } dac_type::ctrl_bit

◆ d1dmaen

__IO uint32_t dac_type::d1dmaen

Definition at line 156 of file at32f435_437_dac.h.

◆ d1dmaudrf

__IO uint32_t dac_type::d1dmaudrf

Definition at line 342 of file at32f435_437_dac.h.

◆ d1dmaudrien

__IO uint32_t dac_type::d1dmaudrien

Definition at line 157 of file at32f435_437_dac.h.

◆ d1dt12l

__IO uint32_t dac_type::d1dt12l

Definition at line 206 of file at32f435_437_dac.h.

◆ d1dt12r

__IO uint32_t dac_type::d1dt12r

Definition at line 193 of file at32f435_437_dac.h.

◆ d1dt8r

__IO uint32_t dac_type::d1dt8r

Definition at line 219 of file at32f435_437_dac.h.

◆ d1dth12l

__IO uint32_t dac_type::d1dth12l

Definition at line 203 of file at32f435_437_dac.h.

◆

struct { ... } dac_type::d1dth12l_bit

◆ d1dth12r

__IO uint32_t dac_type::d1dth12r

Definition at line 190 of file at32f435_437_dac.h.

◆

struct { ... } dac_type::d1dth12r_bit

◆ d1dth8r

__IO uint32_t dac_type::d1dth8r

Definition at line 216 of file at32f435_437_dac.h.

◆

struct { ... } dac_type::d1dth8r_bit

◆ d1en

__IO uint32_t dac_type::d1en

Definition at line 150 of file at32f435_437_dac.h.

◆ d1nbsel

__IO uint32_t dac_type::d1nbsel

Definition at line 155 of file at32f435_437_dac.h.

◆ d1nm

__IO uint32_t dac_type::d1nm

Definition at line 154 of file at32f435_437_dac.h.

◆ d1obdis

__IO uint32_t dac_type::d1obdis

Definition at line 151 of file at32f435_437_dac.h.

◆ d1odt

__IO uint32_t dac_type::d1odt

Definition at line 312 of file at32f435_437_dac.h.

◆

struct { ... } dac_type::d1odt_bit

◆ d1swtrg

__IO uint32_t dac_type::d1swtrg

Definition at line 179 of file at32f435_437_dac.h.

◆ d1trgen

__IO uint32_t dac_type::d1trgen

Definition at line 152 of file at32f435_437_dac.h.

◆ d1trgsel

__IO uint32_t dac_type::d1trgsel

Definition at line 153 of file at32f435_437_dac.h.

◆ d2dmaen

__IO uint32_t dac_type::d2dmaen

Definition at line 165 of file at32f435_437_dac.h.

◆ d2dmaudrf

__IO uint32_t dac_type::d2dmaudrf

Definition at line 344 of file at32f435_437_dac.h.

◆ d2dmaudrien

__IO uint32_t dac_type::d2dmaudrien

Definition at line 166 of file at32f435_437_dac.h.

◆ d2dt12l

__IO uint32_t dac_type::d2dt12l

Definition at line 245 of file at32f435_437_dac.h.

◆ d2dt12r

__IO uint32_t dac_type::d2dt12r

Definition at line 232 of file at32f435_437_dac.h.

◆ d2dt8r

__IO uint32_t dac_type::d2dt8r

Definition at line 258 of file at32f435_437_dac.h.

◆ d2dth12l

__IO uint32_t dac_type::d2dth12l

Definition at line 242 of file at32f435_437_dac.h.

◆

struct { ... } dac_type::d2dth12l_bit

◆ d2dth12r

__IO uint32_t dac_type::d2dth12r

Definition at line 229 of file at32f435_437_dac.h.

◆

struct { ... } dac_type::d2dth12r_bit

◆ d2dth8r

__IO uint32_t dac_type::d2dth8r

Definition at line 255 of file at32f435_437_dac.h.

◆

struct { ... } dac_type::d2dth8r_bit

◆ d2en

__IO uint32_t dac_type::d2en

Definition at line 159 of file at32f435_437_dac.h.

◆ d2nbsel

__IO uint32_t dac_type::d2nbsel

Definition at line 164 of file at32f435_437_dac.h.

◆ d2nm

__IO uint32_t dac_type::d2nm

Definition at line 163 of file at32f435_437_dac.h.

◆ d2obdis

__IO uint32_t dac_type::d2obdis

Definition at line 160 of file at32f435_437_dac.h.

◆ d2odt

__IO uint32_t dac_type::d2odt

Definition at line 325 of file at32f435_437_dac.h.

◆

struct { ... } dac_type::d2odt_bit

◆ d2swtrg

__IO uint32_t dac_type::d2swtrg

Definition at line 180 of file at32f435_437_dac.h.

◆ d2trgen

__IO uint32_t dac_type::d2trgen

Definition at line 161 of file at32f435_437_dac.h.

◆ d2trgsel

__IO uint32_t dac_type::d2trgsel

Definition at line 162 of file at32f435_437_dac.h.

◆ dd1dt12l

__IO uint32_t dac_type::dd1dt12l

Definition at line 287 of file at32f435_437_dac.h.

◆ dd1dt12r

__IO uint32_t dac_type::dd1dt12r

Definition at line 271 of file at32f435_437_dac.h.

◆ dd1dt8r

__IO uint32_t dac_type::dd1dt8r

Definition at line 301 of file at32f435_437_dac.h.

◆ dd2dt12l

__IO uint32_t dac_type::dd2dt12l

Definition at line 289 of file at32f435_437_dac.h.

◆ dd2dt12r

__IO uint32_t dac_type::dd2dt12r

Definition at line 273 of file at32f435_437_dac.h.

◆ dd2dt8r

__IO uint32_t dac_type::dd2dt8r

Definition at line 302 of file at32f435_437_dac.h.

◆ ddth12l

__IO uint32_t dac_type::ddth12l

Definition at line 283 of file at32f435_437_dac.h.

◆

struct { ... } dac_type::ddth12l_bit

◆ ddth12r

__IO uint32_t dac_type::ddth12r

Definition at line 268 of file at32f435_437_dac.h.

◆

struct { ... } dac_type::ddth12r_bit

◆ ddth8r

__IO uint32_t dac_type::ddth8r

Definition at line 298 of file at32f435_437_dac.h.

◆

struct { ... } dac_type::ddth8r_bit

◆ reserved1

__IO uint32_t dac_type::reserved1

Definition at line 158 of file at32f435_437_dac.h.

◆ reserved2

__IO uint32_t dac_type::reserved2

Definition at line 167 of file at32f435_437_dac.h.

◆ reserved3

__IO uint32_t dac_type::reserved3

Definition at line 345 of file at32f435_437_dac.h.

◆ sts

__IO uint32_t dac_type::sts

Definition at line 338 of file at32f435_437_dac.h.

◆

struct { ... } dac_type::sts_bit

◆ swtrg

__IO uint32_t dac_type::swtrg

Definition at line 176 of file at32f435_437_dac.h.

◆

struct { ... } dac_type::swtrg_bit
The documentation for this struct was generated from the following file:
  • at32f435_437_dac.h


AT32F435/437 Firmwary Library: DAC_exported_functions

Functions
DAC_exported_functions
AT32F435_437_periph_driver » DAC

Functions

void | dac_reset (void)
dac reset More...
void | dac_enable (dac_select_type dac_select, confirm_state new_state)
enable or disable dac More...
void | dac_output_buffer_enable (dac_select_type dac_select, confirm_state new_state)
enable or disable dac output buffer More...
void | dac_trigger_enable (dac_select_type dac_select, confirm_state new_state)
enable or disable dac trigger More...
void | dac_trigger_select (dac_select_type dac_select, dac_trigger_type dac_trigger_source)
select dac trigger More...
void | dac_software_trigger_generate (dac_select_type dac_select)
generate dac software trigger More...
void | dac_dual_software_trigger_generate (void)
generate dac dual software trigger synchronously More...
void | dac_wave_generate (dac_select_type dac_select, dac_wave_type dac_wave)
generate dac wave More...
void | dac_mask_amplitude_select (dac_select_type dac_select, dac_mask_amplitude_type dac_mask_amplitude)
select dac mask amplitude More...
void | dac_dma_enable (dac_select_type dac_select, confirm_state new_state)
enable or disable dac dma More...
uint16_t | dac_data_output_get (dac_select_type dac_select)
get dac data output More...
void | dac_1_data_set (dac1_aligned_data_type dac1_aligned, uint16_t dac1_data)
set dac1 data More...
void | dac_2_data_set (dac2_aligned_data_type dac2_aligned, uint16_t dac2_data)
set dac2 data More...
void | dac_dual_data_set (dac_dual_data_type dac_dual, uint16_t data1, uint16_t data2)
set dac dual data More...
void | dac_udr_enable (dac_select_type dac_select, confirm_state new_state)
enable/disable dac dma udr interrupt More...
flag_status | dac_udr_flag_get (dac_select_type dac_select)
get flag of the dac udr flag. More...
void | dac_udr_flag_clear (dac_select_type dac_select)
clear the dac udr flag. More...

Detailed Description

Function Documentation

◆ dac_1_data_set()

void dac_1_data_set | ( | dac1_aligned_data_type | dac1_aligned,
 |  | uint16_t | dac1_data
 | ) |  |

set dac1 data

Parameters
dac1_aligned | this parameter can be one of the following values: DAC1_12BIT_RIGHT DAC1_12BIT_LEFT DAC1_8BIT_RIGHT
dac1_data | :indecate from selected data holding register
Return values
none

Definition at line 318 of file at32f435_437_dac.c.

◆ dac_2_data_set()

void dac_2_data_set | ( | dac2_aligned_data_type | dac2_aligned,
 |  | uint16_t | dac2_data
 | ) |  |

set dac2 data

Parameters
dac2_aligned | this parameter can be one of the following values: DAC2_12BIT_RIGHT DAC2_12BIT_LEFT DAC2_8BIT_RIGHT
dac2_data | :indecate from selected data holding register
Return values
none

Definition at line 333 of file at32f435_437_dac.c.

◆ dac_data_output_get()

uint16_t dac_data_output_get ( dac_select_type dac_select )

get dac data output

Parameters
dac_select this parameter can be one of the following values:
  • DAC1_SELECT
  • DAC2_SELECT
Return values
dac channel data output

Definition at line 291 of file at32f435_437_dac.c.

◆ dac_dma_enable()

void dac_dma_enable | ( | dac_select_type | dac_select,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dac dma

Parameters
dac_select this parameter can be one of the following values:
  • DAC1_SELECT
  • DAC2_SELECT
new_state (TRUE or FALSE)
Return values
none

Definition at line 268 of file at32f435_437_dac.c.

Referenced by main().

◆ dac_dual_data_set()

void dac_dual_data_set | ( | dac_dual_data_type | dac_dual,
 |  | uint16_t | data1,
 |  | uint16_t | data2
 | ) |  |

set dac dual data

Parameters
dac_dual | this parameter can be one of the following values: DAC_DUAL_12BIT_RIGHT DAC_DUAL_12BIT_LEFT DAC_DUAL_8BIT_RIGHT
data1 | :dac1 channel indecate from selected data holding register
data2 | :dac1 channel indecate from selected data holding register
Return values
none

Definition at line 349 of file at32f435_437_dac.c.

Referenced by main().

◆ dac_dual_software_trigger_generate()

void dac_dual_software_trigger_generate ( void )

generate dac dual software trigger synchronously

Parameters
none
Return values
none

Definition at line 189 of file at32f435_437_dac.c.

◆ dac_enable()

void dac_enable | ( | dac_select_type | dac_select,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dac

Parameters
dac_select this parameter can be one of the following values:
  • DAC1_SELECT
  • DAC2_SELECT
new_state (TRUE or FALSE)
Return values
none

Definition at line 64 of file at32f435_437_dac.c.

Referenced by main().

◆ dac_mask_amplitude_select()

void dac_mask_amplitude_select | ( | dac_select_type | dac_select,
 |  | dac_mask_amplitude_type | dac_mask_amplitude
 | ) |  |

select dac mask amplitude

Parameters
dac_select this parameter can be one of the following values:
  • DAC1_SELECT
  • DAC2_SELECT
dac_mask_amplitude this parameter can be one of the following values:
  • DAC_LSFR_BIT0_AMPLITUDE_1
  • DAC_LSFR_BIT10_AMPLITUDE_3
  • DAC_LSFR_BIT20_AMPLITUDE_7
  • DAC_LSFR_BIT30_AMPLITUDE_15
  • DAC_LSFR_BIT40_AMPLITUDE_31
  • DAC_LSFR_BIT50_AMPLITUDE_63
  • DAC_LSFR_BIT60_AMPLITUDE_127
  • DAC_LSFR_BIT70_AMPLITUDE_255
  • DAC_LSFR_BIT80_AMPLITUDE_511
  • DAC_LSFR_BIT90_AMPLITUDE_1023
  • DAC_LSFR_BITA0_AMPLITUDE_2047
  • DAC_LSFR_BITB0_AMPLITUDE_4095
Return values
none

Definition at line 244 of file at32f435_437_dac.c.

Referenced by main().

◆ dac_output_buffer_enable()

void dac_output_buffer_enable | ( | dac_select_type | dac_select,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dac output buffer

Parameters
dac_select this parameter can be one of the following values:
  • DAC1_SELECT
  • DAC2_SELECT
new_state (TRUE or FALSE)
Return values
none

Definition at line 88 of file at32f435_437_dac.c.

Referenced by main().

◆ dac_reset()

void dac_reset ( void )

dac reset

Parameters
none
Return values
none

Definition at line 49 of file at32f435_437_dac.c.

◆ dac_software_trigger_generate()

void dac_software_trigger_generate ( dac_select_type dac_select )

generate dac software trigger

Parameters
dac_select this parameter can be one of the following values:
  • DAC1_SELECT
  • DAC2_SELECT
Return values
none

Definition at line 169 of file at32f435_437_dac.c.

Referenced by main().

◆ dac_trigger_enable()

void dac_trigger_enable | ( | dac_select_type | dac_select,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dac trigger

Parameters
dac_select this parameter can be one of the following values:
  • DAC1_SELECT
  • DAC2_SELECT
new_state (TRUE or FALSE)
Return values
none

Definition at line 113 of file at32f435_437_dac.c.

Referenced by main().

◆ dac_trigger_select()

void dac_trigger_select | ( | dac_select_type | dac_select,
 |  | dac_trigger_type | dac_trigger_source
 | ) |  |

select dac trigger

Parameters
dac_select this parameter can be one of the following values:
  • DAC1_SELECT
  • DAC2_SELECT
dac_trigger_source this parameter can be one of the following values:
  • DAC_TMR6_TRGOUT_EVENT
  • DAC_TMR8_TRGOUT_EVENT
  • DAC_TMR7_TRGOUT_EVENT
  • DAC_TMR5_TRGOUT_EVENT
  • DAC_TMR2_TRGOUT_EVENT
  • DAC_TMR4_TRGOUT_EVENT
  • DAC_EXTERNAL_INTERRUPT_LINE_9
  • DAC_SOFTWARE_TRIGGER
Return values
none

Definition at line 146 of file at32f435_437_dac.c.

Referenced by main().

◆ dac_udr_enable()

void dac_udr_enable | ( | dac_select_type | dac_select,
 |  | confirm_state | new_state
 | ) |  |

enable/disable dac dma udr interrupt

Parameters
dac_select this parameter can be one of the following values:
  • DAC1_SELECT
  • DAC2_SELECT
new_state (TRUE or FALSE)
Return values
none

Definition at line 376 of file at32f435_437_dac.c.

◆ dac_udr_flag_clear()

void dac_udr_flag_clear ( dac_select_type dac_select )

clear the dac udr flag.

Parameters
dac_select this parameter can be one of the following values:
  • DAC1_SELECT
  • DAC2_SELECT
Return values
none

Definition at line 427 of file at32f435_437_dac.c.

◆ dac_udr_flag_get()

flag_status dac_udr_flag_get ( dac_select_type dac_select )

get flag of the dac udr flag.

Parameters
dac_select this parameter can be one of the following values:
  • DAC1_SELECT
  • DAC2_SELECT
Return values
the new state of dac udr flag status(SET or RESET).

Definition at line 399 of file at32f435_437_dac.c.

◆ dac_wave_generate()

void dac_wave_generate | ( | dac_select_type | dac_select,
 |  | dac_wave_type | dac_wave
 | ) |  |

generate dac wave

Parameters
dac_select this parameter can be one of the following values:
  • DAC1_SELECT
  • DAC2_SELECT
dac_wave this parameter can be one of the following values:
  • DAC_WAVE_GENERATE_NONE
  • DAC_WAVE_GENERATE_NOISE
  • DAC_WAVE_GENERATE_TRIANGLE
Return values
none

Definition at line 207 of file at32f435_437_dac.c.

Referenced by main().


AT32F435/437 Firmwary Library: DAC_private_functions

Functions
DAC_private_functions
AT32F435_437_periph_driver » DAC

Functions

void | dac_reset (void)
dac reset More...
void | dac_enable (dac_select_type dac_select, confirm_state new_state)
enable or disable dac More...
void | dac_output_buffer_enable (dac_select_type dac_select, confirm_state new_state)
enable or disable dac output buffer More...
void | dac_trigger_enable (dac_select_type dac_select, confirm_state new_state)
enable or disable dac trigger More...
void | dac_trigger_select (dac_select_type dac_select, dac_trigger_type dac_trigger_source)
select dac trigger More...
void | dac_software_trigger_generate (dac_select_type dac_select)
generate dac software trigger More...
void | dac_dual_software_trigger_generate (void)
generate dac dual software trigger synchronously More...
void | dac_wave_generate (dac_select_type dac_select, dac_wave_type dac_wave)
generate dac wave More...
void | dac_mask_amplitude_select (dac_select_type dac_select, dac_mask_amplitude_type dac_mask_amplitude)
select dac mask amplitude More...
void | dac_dma_enable (dac_select_type dac_select, confirm_state new_state)
enable or disable dac dma More...
uint16_t | dac_data_output_get (dac_select_type dac_select)
get dac data output More...
void | dac_1_data_set (dac1_aligned_data_type dac1_aligned, uint16_t dac1_data)
set dac1 data More...
void | dac_2_data_set (dac2_aligned_data_type dac2_aligned, uint16_t dac2_data)
set dac2 data More...
void | dac_dual_data_set (dac_dual_data_type dac_dual, uint16_t data1, uint16_t data2)
set dac dual data More...
void | dac_udr_enable (dac_select_type dac_select, confirm_state new_state)
enable/disable dac dma udr interrupt More...
flag_status | dac_udr_flag_get (dac_select_type dac_select)
get flag of the dac udr flag. More...
void | dac_udr_flag_clear (dac_select_type dac_select)
clear the dac udr flag. More...

Detailed Description

Function Documentation

◆ dac_1_data_set()

void dac_1_data_set | ( | dac1_aligned_data_type | dac1_aligned,
 |  | uint16_t | dac1_data
 | ) |  |

set dac1 data

Parameters
dac1_aligned | this parameter can be one of the following values: DAC1_12BIT_RIGHT DAC1_12BIT_LEFT DAC1_8BIT_RIGHT
dac1_data | :indecate from selected data holding register
Return values
none

Definition at line 318 of file at32f435_437_dac.c.

◆ dac_2_data_set()

void dac_2_data_set | ( | dac2_aligned_data_type | dac2_aligned,
 |  | uint16_t | dac2_data
 | ) |  |

set dac2 data

Parameters
dac2_aligned | this parameter can be one of the following values: DAC2_12BIT_RIGHT DAC2_12BIT_LEFT DAC2_8BIT_RIGHT
dac2_data | :indecate from selected data holding register
Return values
none

Definition at line 333 of file at32f435_437_dac.c.

◆ dac_data_output_get()

uint16_t dac_data_output_get ( dac_select_type dac_select )

get dac data output

Parameters
dac_select this parameter can be one of the following values:
  • DAC1_SELECT
  • DAC2_SELECT
Return values
dac channel data output

Definition at line 291 of file at32f435_437_dac.c.

◆ dac_dma_enable()

void dac_dma_enable | ( | dac_select_type | dac_select,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dac dma

Parameters
dac_select this parameter can be one of the following values:
  • DAC1_SELECT
  • DAC2_SELECT
new_state (TRUE or FALSE)
Return values
none

Definition at line 268 of file at32f435_437_dac.c.

Referenced by main().

◆ dac_dual_data_set()

void dac_dual_data_set | ( | dac_dual_data_type | dac_dual,
 |  | uint16_t | data1,
 |  | uint16_t | data2
 | ) |  |

set dac dual data

Parameters
dac_dual | this parameter can be one of the following values: DAC_DUAL_12BIT_RIGHT DAC_DUAL_12BIT_LEFT DAC_DUAL_8BIT_RIGHT
data1 | :dac1 channel indecate from selected data holding register
data2 | :dac1 channel indecate from selected data holding register
Return values
none

Definition at line 349 of file at32f435_437_dac.c.

Referenced by main().

◆ dac_dual_software_trigger_generate()

void dac_dual_software_trigger_generate ( void )

generate dac dual software trigger synchronously

Parameters
none
Return values
none

Definition at line 189 of file at32f435_437_dac.c.

◆ dac_enable()

void dac_enable | ( | dac_select_type | dac_select,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dac

Parameters
dac_select this parameter can be one of the following values:
  • DAC1_SELECT
  • DAC2_SELECT
new_state (TRUE or FALSE)
Return values
none

Definition at line 64 of file at32f435_437_dac.c.

Referenced by main().

◆ dac_mask_amplitude_select()

void dac_mask_amplitude_select | ( | dac_select_type | dac_select,
 |  | dac_mask_amplitude_type | dac_mask_amplitude
 | ) |  |

select dac mask amplitude

Parameters
dac_select this parameter can be one of the following values:
  • DAC1_SELECT
  • DAC2_SELECT
dac_mask_amplitude this parameter can be one of the following values:
  • DAC_LSFR_BIT0_AMPLITUDE_1
  • DAC_LSFR_BIT10_AMPLITUDE_3
  • DAC_LSFR_BIT20_AMPLITUDE_7
  • DAC_LSFR_BIT30_AMPLITUDE_15
  • DAC_LSFR_BIT40_AMPLITUDE_31
  • DAC_LSFR_BIT50_AMPLITUDE_63
  • DAC_LSFR_BIT60_AMPLITUDE_127
  • DAC_LSFR_BIT70_AMPLITUDE_255
  • DAC_LSFR_BIT80_AMPLITUDE_511
  • DAC_LSFR_BIT90_AMPLITUDE_1023
  • DAC_LSFR_BITA0_AMPLITUDE_2047
  • DAC_LSFR_BITB0_AMPLITUDE_4095
Return values
none

Definition at line 244 of file at32f435_437_dac.c.

Referenced by main().

◆ dac_output_buffer_enable()

void dac_output_buffer_enable | ( | dac_select_type | dac_select,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dac output buffer

Parameters
dac_select this parameter can be one of the following values:
  • DAC1_SELECT
  • DAC2_SELECT
new_state (TRUE or FALSE)
Return values
none

Definition at line 88 of file at32f435_437_dac.c.

Referenced by main().

◆ dac_reset()

void dac_reset ( void )

dac reset

Parameters
none
Return values
none

Definition at line 49 of file at32f435_437_dac.c.

◆ dac_software_trigger_generate()

void dac_software_trigger_generate ( dac_select_type dac_select )

generate dac software trigger

Parameters
dac_select this parameter can be one of the following values:
  • DAC1_SELECT
  • DAC2_SELECT
Return values
none

Definition at line 169 of file at32f435_437_dac.c.

Referenced by main().

◆ dac_trigger_enable()

void dac_trigger_enable | ( | dac_select_type | dac_select,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dac trigger

Parameters
dac_select this parameter can be one of the following values:
  • DAC1_SELECT
  • DAC2_SELECT
new_state (TRUE or FALSE)
Return values
none

Definition at line 113 of file at32f435_437_dac.c.

Referenced by main().

◆ dac_trigger_select()

void dac_trigger_select | ( | dac_select_type | dac_select,
 |  | dac_trigger_type | dac_trigger_source
 | ) |  |

select dac trigger

Parameters
dac_select this parameter can be one of the following values:
  • DAC1_SELECT
  • DAC2_SELECT
dac_trigger_source this parameter can be one of the following values:
  • DAC_TMR6_TRGOUT_EVENT
  • DAC_TMR8_TRGOUT_EVENT
  • DAC_TMR7_TRGOUT_EVENT
  • DAC_TMR5_TRGOUT_EVENT
  • DAC_TMR2_TRGOUT_EVENT
  • DAC_TMR4_TRGOUT_EVENT
  • DAC_EXTERNAL_INTERRUPT_LINE_9
  • DAC_SOFTWARE_TRIGGER
Return values
none

Definition at line 146 of file at32f435_437_dac.c.

Referenced by main().

◆ dac_udr_enable()

void dac_udr_enable | ( | dac_select_type | dac_select,
 |  | confirm_state | new_state
 | ) |  |

enable/disable dac dma udr interrupt

Parameters
dac_select this parameter can be one of the following values:
  • DAC1_SELECT
  • DAC2_SELECT
new_state (TRUE or FALSE)
Return values
none

Definition at line 376 of file at32f435_437_dac.c.

◆ dac_udr_flag_clear()

void dac_udr_flag_clear ( dac_select_type dac_select )

clear the dac udr flag.

Parameters
dac_select this parameter can be one of the following values:
  • DAC1_SELECT
  • DAC2_SELECT
Return values
none

Definition at line 427 of file at32f435_437_dac.c.

◆ dac_udr_flag_get()

flag_status dac_udr_flag_get ( dac_select_type dac_select )

get flag of the dac udr flag.

Parameters
dac_select this parameter can be one of the following values:
  • DAC1_SELECT
  • DAC2_SELECT
Return values
the new state of dac udr flag status(SET or RESET).

Definition at line 399 of file at32f435_437_dac.c.

◆ dac_wave_generate()

void dac_wave_generate | ( | dac_select_type | dac_select,
 |  | dac_wave_type | dac_wave
 | ) |  |

generate dac wave

Parameters
dac_select this parameter can be one of the following values:
  • DAC1_SELECT
  • DAC2_SELECT
dac_wave this parameter can be one of the following values:
  • DAC_WAVE_GENERATE_NONE
  • DAC_WAVE_GENERATE_NOISE
  • DAC_WAVE_GENERATE_TRIANGLE
Return values
none

Definition at line 207 of file at32f435_437_dac.c.

Referenced by main().


AT32F435/437 Firmwary Library: DEBUG

Modules | Macros
DEBUG
AT32F435_437_periph_driver

DEBUG driver modules. More...

Modules

DEBUG_mode_definition
DEBUG_exported_types
DEBUG_exported_functions
DEBUG_private_functions

Macros

#define DEBUGMCU ((debug_type *) DEBUG_BASE)

Detailed Description

DEBUG driver modules.

Macro Definition Documentation

◆ DEBUGMCU

#define DEBUGMCU ((debug_type *) DEBUG_BASE)

Definition at line 181 of file at32f435_437_debug.h.


AT32F435/437 Firmwary Library: DEBUG_mode_definition

Macros
DEBUG_mode_definition
AT32F435_437_periph_driver » DEBUG

Macros

#define | DEBUG_SLEEP 0x00000001
#define | DEBUG_DEEPSLEEP 0x00000002
#define | DEBUG_STANDBY 0x00000004
#define | DEBUG_TMR2_PAUSE 0x00000001
#define | DEBUG_TMR3_PAUSE 0x00000002
#define | DEBUG_TMR4_PAUSE 0x00000004
#define | DEBUG_TMR5_PAUSE 0x00000008
#define | DEBUG_TMR6_PAUSE 0x00000010
#define | DEBUG_TMR7_PAUSE 0x00000020
#define | DEBUG_TMR12_PAUSE 0x00000040
#define | DEBUG_TMR13_PAUSE 0x00000080
#define | DEBUG_TMR14_PAUSE 0x00000100
#define | DEBUG_ERTC_PAUSE 0x00000400
#define | DEBUG_WWDT_PAUSE 0x00000800
#define | DEBUG_WDT_PAUSE 0x00001000
#define | DEBUG_ERTC_512_PAUSE 0x00008000
#define | DEBUG_I2C1_SMBUS_TIMEOUT 0x01000000
#define | DEBUG_I2C2_SMBUS_TIMEOUT 0x08000000
#define | DEBUG_I2C3_SMBUS_TIMEOUT 0x10000000
#define | DEBUG_CAN1_PAUSE 0x02000000
#define | DEBUG_CAN2_PAUSE 0x04000000
#define | DEBUG_TMR1_PAUSE 0x00000001
#define | DEBUG_TMR8_PAUSE 0x00000002
#define | DEBUG_TMR20_PAUSE 0x00000040
#define | DEBUG_TMR9_PAUSE 0x00010000
#define | DEBUG_TMR10_PAUSE 0x00020000
#define | DEBUG_TMR11_PAUSE 0x00040000

Detailed Description

Macro Definition Documentation

◆ DEBUG_CAN1_PAUSE

#define DEBUG_CAN1_PAUSE 0x02000000

debug can1 pause

Definition at line 73 of file at32f435_437_debug.h.

◆ DEBUG_CAN2_PAUSE

#define DEBUG_CAN2_PAUSE 0x04000000

debug can2 pause

Definition at line 74 of file at32f435_437_debug.h.

◆ DEBUG_DEEPSLEEP

#define DEBUG_DEEPSLEEP 0x00000002

debug deepsleep mode

Definition at line 53 of file at32f435_437_debug.h.

◆ DEBUG_ERTC_512_PAUSE

#define DEBUG_ERTC_512_PAUSE 0x00008000

debug ertc_512 pause

Definition at line 69 of file at32f435_437_debug.h.

◆ DEBUG_ERTC_PAUSE

#define DEBUG_ERTC_PAUSE 0x00000400

debug ertc pause

Definition at line 66 of file at32f435_437_debug.h.

◆ DEBUG_I2C1_SMBUS_TIMEOUT

#define DEBUG_I2C1_SMBUS_TIMEOUT 0x01000000

debug i2c1 smbus timeout

Definition at line 70 of file at32f435_437_debug.h.

◆ DEBUG_I2C2_SMBUS_TIMEOUT

#define DEBUG_I2C2_SMBUS_TIMEOUT 0x08000000

debug i2c2 smbus timeout

Definition at line 71 of file at32f435_437_debug.h.

◆ DEBUG_I2C3_SMBUS_TIMEOUT

#define DEBUG_I2C3_SMBUS_TIMEOUT 0x10000000

debug i2c3 smbus timeout

Definition at line 72 of file at32f435_437_debug.h.

◆ DEBUG_SLEEP

#define DEBUG_SLEEP 0x00000001

debug sleep mode

Definition at line 52 of file at32f435_437_debug.h.

◆ DEBUG_STANDBY

#define DEBUG_STANDBY 0x00000004

debug standby mode

Definition at line 54 of file at32f435_437_debug.h.

◆ DEBUG_TMR10_PAUSE

#define DEBUG_TMR10_PAUSE 0x00020000

debug timer10 pause

Definition at line 81 of file at32f435_437_debug.h.

◆ DEBUG_TMR11_PAUSE

#define DEBUG_TMR11_PAUSE 0x00040000

debug timer11 pause

Definition at line 82 of file at32f435_437_debug.h.

◆ DEBUG_TMR12_PAUSE

#define DEBUG_TMR12_PAUSE 0x00000040

debug timer12 pause

Definition at line 63 of file at32f435_437_debug.h.

◆ DEBUG_TMR13_PAUSE

#define DEBUG_TMR13_PAUSE 0x00000080

debug timer13 pause

Definition at line 64 of file at32f435_437_debug.h.

◆ DEBUG_TMR14_PAUSE

#define DEBUG_TMR14_PAUSE 0x00000100

debug timer14 pause

Definition at line 65 of file at32f435_437_debug.h.

◆ DEBUG_TMR1_PAUSE

#define DEBUG_TMR1_PAUSE 0x00000001

debug timer1 pause

Definition at line 77 of file at32f435_437_debug.h.

◆ DEBUG_TMR20_PAUSE

#define DEBUG_TMR20_PAUSE 0x00000040

debug timer20 pause

Definition at line 79 of file at32f435_437_debug.h.

◆ DEBUG_TMR2_PAUSE

#define DEBUG_TMR2_PAUSE 0x00000001

debug timer2 pause

Definition at line 57 of file at32f435_437_debug.h.

◆ DEBUG_TMR3_PAUSE

#define DEBUG_TMR3_PAUSE 0x00000002

debug timer3 pause

Definition at line 58 of file at32f435_437_debug.h.

◆ DEBUG_TMR4_PAUSE

#define DEBUG_TMR4_PAUSE 0x00000004

debug timer4 pause

Definition at line 59 of file at32f435_437_debug.h.

◆ DEBUG_TMR5_PAUSE

#define DEBUG_TMR5_PAUSE 0x00000008

debug timer5 pause

Definition at line 60 of file at32f435_437_debug.h.

◆ DEBUG_TMR6_PAUSE

#define DEBUG_TMR6_PAUSE 0x00000010

debug timer6 pause

Definition at line 61 of file at32f435_437_debug.h.

◆ DEBUG_TMR7_PAUSE

#define DEBUG_TMR7_PAUSE 0x00000020

debug timer7 pause

Definition at line 62 of file at32f435_437_debug.h.

◆ DEBUG_TMR8_PAUSE

#define DEBUG_TMR8_PAUSE 0x00000002

debug timer8 pause

Definition at line 78 of file at32f435_437_debug.h.

◆ DEBUG_TMR9_PAUSE

#define DEBUG_TMR9_PAUSE 0x00010000

debug timer9 pause

Definition at line 80 of file at32f435_437_debug.h.

◆ DEBUG_WDT_PAUSE

#define DEBUG_WDT_PAUSE 0x00001000

debug watchdog timer pause

Definition at line 68 of file at32f435_437_debug.h.

◆ DEBUG_WWDT_PAUSE

#define DEBUG_WWDT_PAUSE 0x00000800

debug window watchdog timer pause

Definition at line 67 of file at32f435_437_debug.h.


AT32F435/437 Firmwary Library: DEBUG_exported_types

Data Structures
DEBUG_exported_types
AT32F435_437_periph_driver » DEBUG

Data Structures

struct debug_type
type define debug register all More...

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: debug_type Struct Reference

Data Fields
debug_type Struct Reference
AT32F435_437_periph_driver » DEBUG » DEBUG_exported_types

type define debug register all More...

#include <at32f435_437_debug.h>

Data Fields

union {
__IO uint32_t pid
struct {
__IO uint32_t pid: 32
} idcode_bit
};
debug idcode register, offset:0x00 More...
union {
__IO uint32_t ctrl
struct {
__IO uint32_t sleep_debug: 1
__IO uint32_t deepsleep_debug: 1
__IO uint32_t standby_debug: 1
__IO uint32_t reserved1: 29
} ctrl_bit
};
debug ctrl register, offset:0x04 More...
union {
__IO uint32_t apb1_frz
struct {
__IO uint32_t tmr2_pause: 1
__IO uint32_t tmr3_pause: 1
__IO uint32_t tmr4_pause: 1
__IO uint32_t tmr5_pause: 1
__IO uint32_t tmr6_pause: 1
__IO uint32_t tmr7_pause: 1
__IO uint32_t tmr12_pause: 1
__IO uint32_t tmr13_pause: 1
__IO uint32_t tmr14_pause: 1
__IO uint32_t reserved1: 1
__IO uint32_t ertc_pause: 1
__IO uint32_t wwdt_pause: 1
__IO uint32_t wdt_pause: 1
__IO uint32_t reserved2: 2
__IO uint32_t ertc_512_pause: 1
__IO uint32_t reserved3: 8
__IO uint32_t i2c1_smbus_timeout: 1
__IO uint32_t can1_pause: 1
__IO uint32_t can2_pause: 1
__IO uint32_t i2c2_smbus_timeout: 1
__IO uint32_t i2c3_smbus_timeout: 1
__IO uint32_t reserved4: 3
} apb1_frz_bit
};
debug apb1 frz register, offset:0x08 More...
union {
__IO uint32_t apb2_frz
struct {
__IO uint32_t tmr1_pause: 1
__IO uint32_t tmr8_pause: 1
__IO uint32_t reserved1: 4
__IO uint32_t tmr20_pause: 1
__IO uint32_t reserved2: 9
__IO uint32_t tmr9_pause: 1
__IO uint32_t tmr10_pause: 1
__IO uint32_t tmr11_pause: 1
__IO uint32_t reserved3: 13
} apb2_frz_bit
};
debug apb2 frz register, offset:0x0c More...

Detailed Description

type define debug register all

Definition at line 95 of file at32f435_437_debug.h.

Field Documentation

◆

union { ... } debug_type::@280

debug idcode register, offset:0x00

◆

union { ... } debug_type::@282

debug ctrl register, offset:0x04

◆

union { ... } debug_type::@284

debug apb1 frz register, offset:0x08

◆

union { ... } debug_type::@286

debug apb2 frz register, offset:0x0c

◆ apb1_frz

__IO uint32_t debug_type::apb1_frz

Definition at line 128 of file at32f435_437_debug.h.

◆

struct { ... } debug_type::apb1_frz_bit

◆ apb2_frz

__IO uint32_t debug_type::apb2_frz

Definition at line 160 of file at32f435_437_debug.h.

◆

struct { ... } debug_type::apb2_frz_bit

◆ can1_pause

__IO uint32_t debug_type::can1_pause

Definition at line 148 of file at32f435_437_debug.h.

◆ can2_pause

__IO uint32_t debug_type::can2_pause

Definition at line 149 of file at32f435_437_debug.h.

◆ ctrl

__IO uint32_t debug_type::ctrl

Definition at line 114 of file at32f435_437_debug.h.

◆

struct { ... } debug_type::ctrl_bit

◆ deepsleep_debug

__IO uint32_t debug_type::deepsleep_debug

Definition at line 118 of file at32f435_437_debug.h.

◆ ertc_512_pause

__IO uint32_t debug_type::ertc_512_pause

Definition at line 145 of file at32f435_437_debug.h.

◆ ertc_pause

__IO uint32_t debug_type::ertc_pause

Definition at line 141 of file at32f435_437_debug.h.

◆ i2c1_smbus_timeout

__IO uint32_t debug_type::i2c1_smbus_timeout

Definition at line 147 of file at32f435_437_debug.h.

◆ i2c2_smbus_timeout

__IO uint32_t debug_type::i2c2_smbus_timeout

Definition at line 150 of file at32f435_437_debug.h.

◆ i2c3_smbus_timeout

__IO uint32_t debug_type::i2c3_smbus_timeout

Definition at line 151 of file at32f435_437_debug.h.

◆

struct { ... } debug_type::idcode_bit

◆ pid

__IO uint32_t debug_type::pid

Definition at line 102 of file at32f435_437_debug.h.

◆ reserved1

__IO uint32_t debug_type::reserved1

Definition at line 120 of file at32f435_437_debug.h.

◆ reserved2

__IO uint32_t debug_type::reserved2

Definition at line 144 of file at32f435_437_debug.h.

◆ reserved3

__IO uint32_t debug_type::reserved3

Definition at line 146 of file at32f435_437_debug.h.

◆ reserved4

__IO uint32_t debug_type::reserved4

Definition at line 152 of file at32f435_437_debug.h.

◆ sleep_debug

__IO uint32_t debug_type::sleep_debug

Definition at line 117 of file at32f435_437_debug.h.

◆ standby_debug

__IO uint32_t debug_type::standby_debug

Definition at line 119 of file at32f435_437_debug.h.

◆ tmr10_pause

__IO uint32_t debug_type::tmr10_pause

Definition at line 169 of file at32f435_437_debug.h.

◆ tmr11_pause

__IO uint32_t debug_type::tmr11_pause

Definition at line 170 of file at32f435_437_debug.h.

◆ tmr12_pause

__IO uint32_t debug_type::tmr12_pause

Definition at line 137 of file at32f435_437_debug.h.

◆ tmr13_pause

__IO uint32_t debug_type::tmr13_pause

Definition at line 138 of file at32f435_437_debug.h.

◆ tmr14_pause

__IO uint32_t debug_type::tmr14_pause

Definition at line 139 of file at32f435_437_debug.h.

◆ tmr1_pause

__IO uint32_t debug_type::tmr1_pause

Definition at line 163 of file at32f435_437_debug.h.

◆ tmr20_pause

__IO uint32_t debug_type::tmr20_pause

Definition at line 166 of file at32f435_437_debug.h.

◆ tmr2_pause

__IO uint32_t debug_type::tmr2_pause

Definition at line 131 of file at32f435_437_debug.h.

◆ tmr3_pause

__IO uint32_t debug_type::tmr3_pause

Definition at line 132 of file at32f435_437_debug.h.

◆ tmr4_pause

__IO uint32_t debug_type::tmr4_pause

Definition at line 133 of file at32f435_437_debug.h.

◆ tmr5_pause

__IO uint32_t debug_type::tmr5_pause

Definition at line 134 of file at32f435_437_debug.h.

◆ tmr6_pause

__IO uint32_t debug_type::tmr6_pause

Definition at line 135 of file at32f435_437_debug.h.

◆ tmr7_pause

__IO uint32_t debug_type::tmr7_pause

Definition at line 136 of file at32f435_437_debug.h.

◆ tmr8_pause

__IO uint32_t debug_type::tmr8_pause

Definition at line 164 of file at32f435_437_debug.h.

◆ tmr9_pause

__IO uint32_t debug_type::tmr9_pause

Definition at line 168 of file at32f435_437_debug.h.

◆ wdt_pause

__IO uint32_t debug_type::wdt_pause

Definition at line 143 of file at32f435_437_debug.h.

◆ wwdt_pause

__IO uint32_t debug_type::wwdt_pause

Definition at line 142 of file at32f435_437_debug.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_debug.h


AT32F435/437 Firmwary Library: DEBUG_exported_functions

Functions
DEBUG_exported_functions
AT32F435_437_periph_driver » DEBUG

Functions

uint32_t | debug_device_id_get (void)
get debug device id More...
void | debug_low_power_mode_set (uint32_t low_power_mode, confirm_state new_state)
set periph debug mode More...
void | debug_apb1_periph_mode_set (uint32_t apb1_periph, confirm_state new_state)
set apb1 periph debug mode More...
void | debug_apb2_periph_mode_set (uint32_t apb2_periph, confirm_state new_state)
set apb2 periph debug mode More...

Detailed Description

Function Documentation

◆ debug_apb1_periph_mode_set()

void debug_apb1_periph_mode_set | ( | uint32_t | apb1_periph,
 |  | confirm_state | new_state
 | ) |  |

set apb1 periph debug mode

Parameters
periph_debug_mode this parameter can be any combination of the following values:
  • DEBUG_TMR2_PAUSE - DEBUG_TMR3_PAUSE
  • DEBUG_TMR4_PAUSE - DEBUG_TMR5_PAUSE
  • DEBUG_TMR6_PAUSE - DEBUG_TMR7_PAUSE
  • DEBUG_TMR12_PAUSE - DEBUG_TMR13_PAUSE
  • DEBUG_TMR14_PAUSE - DEBUG_ERTC_PAUSE
  • DEBUG_WWDT_PAUSE - DEBUG_WDT_PAUSE
  • DEBUG_ERTC_512_PAUSE - DEBUG_I2C1_SMBUS_TIMEOUT
  • DEBUG_I2C2_SMBUS_TIMEOUT - DEBUG_I2C3_SMBUS_TIMEOUT
  • DEBUG_CAN1_PAUSE - DEBUG_CAN2_PAUSE
new_state (TRUE or FALSE)
Return values
none

Definition at line 90 of file at32f435_437_debug.c.

◆ debug_apb2_periph_mode_set()

void debug_apb2_periph_mode_set | ( | uint32_t | apb2_periph,
 |  | confirm_state | new_state
 | ) |  |

set apb2 periph debug mode

Parameters
periph_debug_mode this parameter can be any combination of the following values:
  • DEBUG_TMR1_PAUSE - DEBUG_TMR8_PAUSE
  • DEBUG_TMR20_PAUSE - DEBUG_TMR9_PAUSE
  • DEBUG_TMR10_PAUSE - DEBUG_TMR11_PAUSE
new_state (TRUE or FALSE)
Return values
none

Definition at line 111 of file at32f435_437_debug.c.

Referenced by main().

◆ debug_device_id_get()

uint32_t debug_device_id_get ( void )

get debug device id

Parameters
none
Return values
the debug device id

Definition at line 49 of file at32f435_437_debug.c.

◆ debug_low_power_mode_set()

void debug_low_power_mode_set | ( | uint32_t | low_power_mode,
 |  | confirm_state | new_state
 | ) |  |

set periph debug mode

Parameters
periph_debug_mode this parameter can be one of the following values:
  • DEBUG_SLEEP
  • DEBUG_DEEPSLEEP
  • DEBUG_STANDBY
new_state (TRUE or FALSE)
Return values
none

Definition at line 63 of file at32f435_437_debug.c.


AT32F435/437 Firmwary Library: DEBUG_private_functions

Functions
DEBUG_private_functions
AT32F435_437_periph_driver » DEBUG

Functions

uint32_t | debug_device_id_get (void)
get debug device id More...
void | debug_low_power_mode_set (uint32_t low_power_mode, confirm_state new_state)
set periph debug mode More...
void | debug_apb1_periph_mode_set (uint32_t apb1_periph, confirm_state new_state)
set apb1 periph debug mode More...
void | debug_apb2_periph_mode_set (uint32_t apb2_periph, confirm_state new_state)
set apb2 periph debug mode More...

Detailed Description

Function Documentation

◆ debug_apb1_periph_mode_set()

void debug_apb1_periph_mode_set | ( | uint32_t | apb1_periph,
 |  | confirm_state | new_state
 | ) |  |

set apb1 periph debug mode

Parameters
periph_debug_mode this parameter can be any combination of the following values:
  • DEBUG_TMR2_PAUSE - DEBUG_TMR3_PAUSE
  • DEBUG_TMR4_PAUSE - DEBUG_TMR5_PAUSE
  • DEBUG_TMR6_PAUSE - DEBUG_TMR7_PAUSE
  • DEBUG_TMR12_PAUSE - DEBUG_TMR13_PAUSE
  • DEBUG_TMR14_PAUSE - DEBUG_ERTC_PAUSE
  • DEBUG_WWDT_PAUSE - DEBUG_WDT_PAUSE
  • DEBUG_ERTC_512_PAUSE - DEBUG_I2C1_SMBUS_TIMEOUT
  • DEBUG_I2C2_SMBUS_TIMEOUT - DEBUG_I2C3_SMBUS_TIMEOUT
  • DEBUG_CAN1_PAUSE - DEBUG_CAN2_PAUSE
new_state (TRUE or FALSE)
Return values
none

Definition at line 90 of file at32f435_437_debug.c.

◆ debug_apb2_periph_mode_set()

void debug_apb2_periph_mode_set | ( | uint32_t | apb2_periph,
 |  | confirm_state | new_state
 | ) |  |

set apb2 periph debug mode

Parameters
periph_debug_mode this parameter can be any combination of the following values:
  • DEBUG_TMR1_PAUSE - DEBUG_TMR8_PAUSE
  • DEBUG_TMR20_PAUSE - DEBUG_TMR9_PAUSE
  • DEBUG_TMR10_PAUSE - DEBUG_TMR11_PAUSE
new_state (TRUE or FALSE)
Return values
none

Definition at line 111 of file at32f435_437_debug.c.

Referenced by main().

◆ debug_device_id_get()

uint32_t debug_device_id_get ( void )

get debug device id

Parameters
none
Return values
the debug device id

Definition at line 49 of file at32f435_437_debug.c.

◆ debug_low_power_mode_set()

void debug_low_power_mode_set | ( | uint32_t | low_power_mode,
 |  | confirm_state | new_state
 | ) |  |

set periph debug mode

Parameters
periph_debug_mode this parameter can be one of the following values:
  • DEBUG_SLEEP
  • DEBUG_DEEPSLEEP
  • DEBUG_STANDBY
new_state (TRUE or FALSE)
Return values
none

Definition at line 63 of file at32f435_437_debug.c.


AT32F435/437 Firmwary Library: DMA

Modules | Macros
DMA
AT32F435_437_periph_driver

DMA driver modules. More...

Modules

DMA_interrupts_definition
dma interrupt
DMA_flags_definition
edma flag
DMA_exported_types
DMA_exported_functions
DMA_private_functions

Macros

#define | DMA1 ((dma_type *) DMA1_BASE)
#define | DMA1_CHANNEL1 ((dma_channel_type *) DMA1_CHANNEL1_BASE)
#define | DMA1_CHANNEL2 ((dma_channel_type *) DMA1_CHANNEL2_BASE)
#define | DMA1_CHANNEL3 ((dma_channel_type *) DMA1_CHANNEL3_BASE)
#define | DMA1_CHANNEL4 ((dma_channel_type *) DMA1_CHANNEL4_BASE)
#define | DMA1_CHANNEL5 ((dma_channel_type *) DMA1_CHANNEL5_BASE)
#define | DMA1_CHANNEL6 ((dma_channel_type *) DMA1_CHANNEL6_BASE)
#define | DMA1_CHANNEL7 ((dma_channel_type *) DMA1_CHANNEL7_BASE)
#define | DMA1MUX_CHANNEL1 ((dmamux_channel_type *) DMA1MUX_CHANNEL1_BASE)
#define | DMA1MUX_CHANNEL2 ((dmamux_channel_type *) DMA1MUX_CHANNEL2_BASE)
#define | DMA1MUX_CHANNEL3 ((dmamux_channel_type *) DMA1MUX_CHANNEL3_BASE)
#define | DMA1MUX_CHANNEL4 ((dmamux_channel_type *) DMA1MUX_CHANNEL4_BASE)
#define | DMA1MUX_CHANNEL5 ((dmamux_channel_type *) DMA1MUX_CHANNEL5_BASE)
#define | DMA1MUX_CHANNEL6 ((dmamux_channel_type *) DMA1MUX_CHANNEL6_BASE)
#define | DMA1MUX_CHANNEL7 ((dmamux_channel_type *) DMA1MUX_CHANNEL7_BASE)
#define | DMA1MUX_GENERATOR1 ((dmamux_generator_type *) DMA1MUX_GENERATOR1_BASE)
#define | DMA1MUX_GENERATOR2 ((dmamux_generator_type *) DMA1MUX_GENERATOR2_BASE)
#define | DMA1MUX_GENERATOR3 ((dmamux_generator_type *) DMA1MUX_GENERATOR3_BASE)
#define | DMA1MUX_GENERATOR4 ((dmamux_generator_type *) DMA1MUX_GENERATOR4_BASE)
#define | DMA2 ((dma_type *) DMA2_BASE)
#define | DMA2_CHANNEL1 ((dma_channel_type *) DMA2_CHANNEL1_BASE)
#define | DMA2_CHANNEL2 ((dma_channel_type *) DMA2_CHANNEL2_BASE)
#define | DMA2_CHANNEL3 ((dma_channel_type *) DMA2_CHANNEL3_BASE)
#define | DMA2_CHANNEL4 ((dma_channel_type *) DMA2_CHANNEL4_BASE)
#define | DMA2_CHANNEL5 ((dma_channel_type *) DMA2_CHANNEL5_BASE)
#define | DMA2_CHANNEL6 ((dma_channel_type *) DMA2_CHANNEL6_BASE)
#define | DMA2_CHANNEL7 ((dma_channel_type *) DMA2_CHANNEL7_BASE)
#define | DMA2MUX_CHANNEL1 ((dmamux_channel_type *) DMA2MUX_CHANNEL1_BASE)
#define | DMA2MUX_CHANNEL2 ((dmamux_channel_type *) DMA2MUX_CHANNEL2_BASE)
#define | DMA2MUX_CHANNEL3 ((dmamux_channel_type *) DMA2MUX_CHANNEL3_BASE)
#define | DMA2MUX_CHANNEL4 ((dmamux_channel_type *) DMA2MUX_CHANNEL4_BASE)
#define | DMA2MUX_CHANNEL5 ((dmamux_channel_type *) DMA2MUX_CHANNEL5_BASE)
#define | DMA2MUX_CHANNEL6 ((dmamux_channel_type *) DMA2MUX_CHANNEL6_BASE)
#define | DMA2MUX_CHANNEL7 ((dmamux_channel_type *) DMA2MUX_CHANNEL7_BASE)
#define | DMA2MUX_GENERATOR1 ((dmamux_generator_type *) DMA2MUX_GENERATOR1_BASE)
#define | DMA2MUX_GENERATOR2 ((dmamux_generator_type *) DMA2MUX_GENERATOR2_BASE)
#define | DMA2MUX_GENERATOR3 ((dmamux_generator_type *) DMA2MUX_GENERATOR3_BASE)
#define | DMA2MUX_GENERATOR4 ((dmamux_generator_type *) DMA2MUX_GENERATOR4_BASE)

Detailed Description

DMA driver modules.

Macro Definition Documentation

◆ DMA1

#define DMA1 ((dma_type *) DMA1_BASE)

Definition at line 695 of file at32f435_437_dma.h.

◆ DMA1_CHANNEL1

#define DMA1_CHANNEL1 ((dma_channel_type *) DMA1_CHANNEL1_BASE)

Definition at line 696 of file at32f435_437_dma.h.

◆ DMA1_CHANNEL2

#define DMA1_CHANNEL2 ((dma_channel_type *) DMA1_CHANNEL2_BASE)

Definition at line 697 of file at32f435_437_dma.h.

◆ DMA1_CHANNEL3

#define DMA1_CHANNEL3 ((dma_channel_type *) DMA1_CHANNEL3_BASE)

Definition at line 698 of file at32f435_437_dma.h.

◆ DMA1_CHANNEL4

#define DMA1_CHANNEL4 ((dma_channel_type *) DMA1_CHANNEL4_BASE)

Definition at line 699 of file at32f435_437_dma.h.

◆ DMA1_CHANNEL5

#define DMA1_CHANNEL5 ((dma_channel_type *) DMA1_CHANNEL5_BASE)

Definition at line 700 of file at32f435_437_dma.h.

◆ DMA1_CHANNEL6

#define DMA1_CHANNEL6 ((dma_channel_type *) DMA1_CHANNEL6_BASE)

Definition at line 701 of file at32f435_437_dma.h.

◆ DMA1_CHANNEL7

#define DMA1_CHANNEL7 ((dma_channel_type *) DMA1_CHANNEL7_BASE)

Definition at line 702 of file at32f435_437_dma.h.

◆ DMA1MUX_CHANNEL1

#define DMA1MUX_CHANNEL1 ((dmamux_channel_type *) DMA1MUX_CHANNEL1_BASE)

Definition at line 704 of file at32f435_437_dma.h.

◆ DMA1MUX_CHANNEL2

#define DMA1MUX_CHANNEL2 ((dmamux_channel_type *) DMA1MUX_CHANNEL2_BASE)

Definition at line 705 of file at32f435_437_dma.h.

◆ DMA1MUX_CHANNEL3

#define DMA1MUX_CHANNEL3 ((dmamux_channel_type *) DMA1MUX_CHANNEL3_BASE)

Definition at line 706 of file at32f435_437_dma.h.

◆ DMA1MUX_CHANNEL4

#define DMA1MUX_CHANNEL4 ((dmamux_channel_type *) DMA1MUX_CHANNEL4_BASE)

Definition at line 707 of file at32f435_437_dma.h.

◆ DMA1MUX_CHANNEL5

#define DMA1MUX_CHANNEL5 ((dmamux_channel_type *) DMA1MUX_CHANNEL5_BASE)

Definition at line 708 of file at32f435_437_dma.h.

◆ DMA1MUX_CHANNEL6

#define DMA1MUX_CHANNEL6 ((dmamux_channel_type *) DMA1MUX_CHANNEL6_BASE)

Definition at line 709 of file at32f435_437_dma.h.

◆ DMA1MUX_CHANNEL7

#define DMA1MUX_CHANNEL7 ((dmamux_channel_type *) DMA1MUX_CHANNEL7_BASE)

Definition at line 710 of file at32f435_437_dma.h.

◆ DMA1MUX_GENERATOR1

#define DMA1MUX_GENERATOR1 ((dmamux_generator_type *) DMA1MUX_GENERATOR1_BASE)

Definition at line 712 of file at32f435_437_dma.h.

◆ DMA1MUX_GENERATOR2

#define DMA1MUX_GENERATOR2 ((dmamux_generator_type *) DMA1MUX_GENERATOR2_BASE)

Definition at line 713 of file at32f435_437_dma.h.

◆ DMA1MUX_GENERATOR3

#define DMA1MUX_GENERATOR3 ((dmamux_generator_type *) DMA1MUX_GENERATOR3_BASE)

Definition at line 714 of file at32f435_437_dma.h.

◆ DMA1MUX_GENERATOR4

#define DMA1MUX_GENERATOR4 ((dmamux_generator_type *) DMA1MUX_GENERATOR4_BASE)

Definition at line 715 of file at32f435_437_dma.h.

◆ DMA2

#define DMA2 ((dma_type *) DMA2_BASE)

Definition at line 717 of file at32f435_437_dma.h.

◆ DMA2_CHANNEL1

#define DMA2_CHANNEL1 ((dma_channel_type *) DMA2_CHANNEL1_BASE)

Definition at line 718 of file at32f435_437_dma.h.

◆ DMA2_CHANNEL2

#define DMA2_CHANNEL2 ((dma_channel_type *) DMA2_CHANNEL2_BASE)

Definition at line 719 of file at32f435_437_dma.h.

◆ DMA2_CHANNEL3

#define DMA2_CHANNEL3 ((dma_channel_type *) DMA2_CHANNEL3_BASE)

Definition at line 720 of file at32f435_437_dma.h.

◆ DMA2_CHANNEL4

#define DMA2_CHANNEL4 ((dma_channel_type *) DMA2_CHANNEL4_BASE)

Definition at line 721 of file at32f435_437_dma.h.

◆ DMA2_CHANNEL5

#define DMA2_CHANNEL5 ((dma_channel_type *) DMA2_CHANNEL5_BASE)

Definition at line 722 of file at32f435_437_dma.h.

◆ DMA2_CHANNEL6

#define DMA2_CHANNEL6 ((dma_channel_type *) DMA2_CHANNEL6_BASE)

Definition at line 723 of file at32f435_437_dma.h.

◆ DMA2_CHANNEL7

#define DMA2_CHANNEL7 ((dma_channel_type *) DMA2_CHANNEL7_BASE)

Definition at line 724 of file at32f435_437_dma.h.

◆ DMA2MUX_CHANNEL1

#define DMA2MUX_CHANNEL1 ((dmamux_channel_type *) DMA2MUX_CHANNEL1_BASE)

Definition at line 726 of file at32f435_437_dma.h.

◆ DMA2MUX_CHANNEL2

#define DMA2MUX_CHANNEL2 ((dmamux_channel_type *) DMA2MUX_CHANNEL2_BASE)

Definition at line 727 of file at32f435_437_dma.h.

◆ DMA2MUX_CHANNEL3

#define DMA2MUX_CHANNEL3 ((dmamux_channel_type *) DMA2MUX_CHANNEL3_BASE)

Definition at line 728 of file at32f435_437_dma.h.

◆ DMA2MUX_CHANNEL4

#define DMA2MUX_CHANNEL4 ((dmamux_channel_type *) DMA2MUX_CHANNEL4_BASE)

Definition at line 729 of file at32f435_437_dma.h.

◆ DMA2MUX_CHANNEL5

#define DMA2MUX_CHANNEL5 ((dmamux_channel_type *) DMA2MUX_CHANNEL5_BASE)

Definition at line 730 of file at32f435_437_dma.h.

◆ DMA2MUX_CHANNEL6

#define DMA2MUX_CHANNEL6 ((dmamux_channel_type *) DMA2MUX_CHANNEL6_BASE)

Definition at line 731 of file at32f435_437_dma.h.

◆ DMA2MUX_CHANNEL7

#define DMA2MUX_CHANNEL7 ((dmamux_channel_type *) DMA2MUX_CHANNEL7_BASE)

Definition at line 732 of file at32f435_437_dma.h.

◆ DMA2MUX_GENERATOR1

#define DMA2MUX_GENERATOR1 ((dmamux_generator_type *) DMA2MUX_GENERATOR1_BASE)

Definition at line 734 of file at32f435_437_dma.h.

◆ DMA2MUX_GENERATOR2

#define DMA2MUX_GENERATOR2 ((dmamux_generator_type *) DMA2MUX_GENERATOR2_BASE)

Definition at line 735 of file at32f435_437_dma.h.

◆ DMA2MUX_GENERATOR3

#define DMA2MUX_GENERATOR3 ((dmamux_generator_type *) DMA2MUX_GENERATOR3_BASE)

Definition at line 736 of file at32f435_437_dma.h.

◆ DMA2MUX_GENERATOR4

#define DMA2MUX_GENERATOR4 ((dmamux_generator_type *) DMA2MUX_GENERATOR4_BASE)

Definition at line 737 of file at32f435_437_dma.h.


AT32F435/437 Firmwary Library: DMA_interrupts_definition

Macros
DMA_interrupts_definition
AT32F435_437_periph_driver » DMA

dma interrupt More...

Macros

#define | DMA_FDT_INT ((uint32_t)0x00000002)
#define | DMA_HDT_INT ((uint32_t)0x00000004)
#define | DMA_DTERR_INT ((uint32_t)0x00000008)

Detailed Description

dma interrupt

Macro Definition Documentation

◆ DMA_DTERR_INT

#define DMA_DTERR_INT ((uint32_t)0x00000008)

dma errorr interrupt

Definition at line 54 of file at32f435_437_dma.h.

◆ DMA_FDT_INT

#define DMA_FDT_INT ((uint32_t)0x00000002)

dma full data transfer interrupt

Definition at line 52 of file at32f435_437_dma.h.

◆ DMA_HDT_INT

#define DMA_HDT_INT ((uint32_t)0x00000004)

dma half data transfer interrupt

Definition at line 53 of file at32f435_437_dma.h.


AT32F435/437 Firmwary Library: DMA_flags_definition

Macros
DMA_flags_definition
AT32F435_437_periph_driver » DMA

edma flag More...

Macros

#define | DMA1_GL1_FLAG ((uint32_t)0x00000001)
#define | DMA1_FDT1_FLAG ((uint32_t)0x00000002)
#define | DMA1_HDT1_FLAG ((uint32_t)0x00000004)
#define | DMA1_DTERR1_FLAG ((uint32_t)0x00000008)
#define | DMA1_GL2_FLAG ((uint32_t)0x00000010)
#define | DMA1_FDT2_FLAG ((uint32_t)0x00000020)
#define | DMA1_HDT2_FLAG ((uint32_t)0x00000040)
#define | DMA1_DTERR2_FLAG ((uint32_t)0x00000080)
#define | DMA1_GL3_FLAG ((uint32_t)0x00000100)
#define | DMA1_FDT3_FLAG ((uint32_t)0x00000200)
#define | DMA1_HDT3_FLAG ((uint32_t)0x00000400)
#define | DMA1_DTERR3_FLAG ((uint32_t)0x00000800)
#define | DMA1_GL4_FLAG ((uint32_t)0x00001000)
#define | DMA1_FDT4_FLAG ((uint32_t)0x00002000)
#define | DMA1_HDT4_FLAG ((uint32_t)0x00004000)
#define | DMA1_DTERR4_FLAG ((uint32_t)0x00008000)
#define | DMA1_GL5_FLAG ((uint32_t)0x00010000)
#define | DMA1_FDT5_FLAG ((uint32_t)0x00020000)
#define | DMA1_HDT5_FLAG ((uint32_t)0x00040000)
#define | DMA1_DTERR5_FLAG ((uint32_t)0x00080000)
#define | DMA1_GL6_FLAG ((uint32_t)0x00100000)
#define | DMA1_FDT6_FLAG ((uint32_t)0x00200000)
#define | DMA1_HDT6_FLAG ((uint32_t)0x00400000)
#define | DMA1_DTERR6_FLAG ((uint32_t)0x00800000)
#define | DMA1_GL7_FLAG ((uint32_t)0x01000000)
#define | DMA1_FDT7_FLAG ((uint32_t)0x02000000)
#define | DMA1_HDT7_FLAG ((uint32_t)0x04000000)
#define | DMA1_DTERR7_FLAG ((uint32_t)0x08000000)
#define | DMA2_GL1_FLAG ((uint32_t)0x10000001)
#define | DMA2_FDT1_FLAG ((uint32_t)0x10000002)
#define | DMA2_HDT1_FLAG ((uint32_t)0x10000004)
#define | DMA2_DTERR1_FLAG ((uint32_t)0x10000008)
#define | DMA2_GL2_FLAG ((uint32_t)0x10000010)
#define | DMA2_FDT2_FLAG ((uint32_t)0x10000020)
#define | DMA2_HDT2_FLAG ((uint32_t)0x10000040)
#define | DMA2_DTERR2_FLAG ((uint32_t)0x10000080)
#define | DMA2_GL3_FLAG ((uint32_t)0x10000100)
#define | DMA2_FDT3_FLAG ((uint32_t)0x10000200)
#define | DMA2_HDT3_FLAG ((uint32_t)0x10000400)
#define | DMA2_DTERR3_FLAG ((uint32_t)0x10000800)
#define | DMA2_GL4_FLAG ((uint32_t)0x10001000)
#define | DMA2_FDT4_FLAG ((uint32_t)0x10002000)
#define | DMA2_HDT4_FLAG ((uint32_t)0x10004000)
#define | DMA2_DTERR4_FLAG ((uint32_t)0x10008000)
#define | DMA2_GL5_FLAG ((uint32_t)0x10010000)
#define | DMA2_FDT5_FLAG ((uint32_t)0x10020000)
#define | DMA2_HDT5_FLAG ((uint32_t)0x10040000)
#define | DMA2_DTERR5_FLAG ((uint32_t)0x10080000)
#define | DMA2_GL6_FLAG ((uint32_t)0x10100000)
#define | DMA2_FDT6_FLAG ((uint32_t)0x10200000)
#define | DMA2_HDT6_FLAG ((uint32_t)0x10400000)
#define | DMA2_DTERR6_FLAG ((uint32_t)0x10800000)
#define | DMA2_GL7_FLAG ((uint32_t)0x11000000)
#define | DMA2_FDT7_FLAG ((uint32_t)0x12000000)
#define | DMA2_HDT7_FLAG ((uint32_t)0x14000000)
#define | DMA2_DTERR7_FLAG ((uint32_t)0x18000000)
#define | DMAMUX_SYNC_OV1_FLAG ((uint32_t)0x00000001)
dmamux flag More...
#define | DMAMUX_SYNC_OV2_FLAG ((uint32_t)0x00000002)
#define | DMAMUX_SYNC_OV3_FLAG ((uint32_t)0x00000004)
#define | DMAMUX_SYNC_OV4_FLAG ((uint32_t)0x00000008)
#define | DMAMUX_SYNC_OV5_FLAG ((uint32_t)0x00000010)
#define | DMAMUX_SYNC_OV6_FLAG ((uint32_t)0x00000020)
#define | DMAMUX_SYNC_OV7_FLAG ((uint32_t)0x00000040)
#define | DMAMUX_GEN_TRIG_OV1_FLAG ((uint32_t)0x00000001)
#define | DMAMUX_GEN_TRIG_OV2_FLAG ((uint32_t)0x00000002)
#define | DMAMUX_GEN_TRIG_OV3_FLAG ((uint32_t)0x00000004)
#define | DMAMUX_GEN_TRIG_OV4_FLAG ((uint32_t)0x00000008)

Detailed Description

edma flag

Macro Definition Documentation

◆ DMA1_DTERR1_FLAG

#define DMA1_DTERR1_FLAG ((uint32_t)0x00000008)

dma1 channel1 error flag

Definition at line 68 of file at32f435_437_dma.h.

◆ DMA1_DTERR2_FLAG

#define DMA1_DTERR2_FLAG ((uint32_t)0x00000080)

dma1 channel2 error flag

Definition at line 72 of file at32f435_437_dma.h.

◆ DMA1_DTERR3_FLAG

#define DMA1_DTERR3_FLAG ((uint32_t)0x00000800)

dma1 channel3 error flag

Definition at line 76 of file at32f435_437_dma.h.

◆ DMA1_DTERR4_FLAG

#define DMA1_DTERR4_FLAG ((uint32_t)0x00008000)

dma1 channel4 error flag

Definition at line 80 of file at32f435_437_dma.h.

◆ DMA1_DTERR5_FLAG

#define DMA1_DTERR5_FLAG ((uint32_t)0x00080000)

dma1 channel5 error flag

Definition at line 84 of file at32f435_437_dma.h.

◆ DMA1_DTERR6_FLAG

#define DMA1_DTERR6_FLAG ((uint32_t)0x00800000)

dma1 channel6 error flag

Definition at line 88 of file at32f435_437_dma.h.

◆ DMA1_DTERR7_FLAG

#define DMA1_DTERR7_FLAG ((uint32_t)0x08000000)

dma1 channel7 error flag

Definition at line 92 of file at32f435_437_dma.h.

◆ DMA1_FDT1_FLAG

#define DMA1_FDT1_FLAG ((uint32_t)0x00000002)

dma1 channel1 full data transfer flag

Definition at line 66 of file at32f435_437_dma.h.

◆ DMA1_FDT2_FLAG

#define DMA1_FDT2_FLAG ((uint32_t)0x00000020)

dma1 channel2 full data transfer flag

Definition at line 70 of file at32f435_437_dma.h.

◆ DMA1_FDT3_FLAG

#define DMA1_FDT3_FLAG ((uint32_t)0x00000200)

dma1 channel3 full data transfer flag

Definition at line 74 of file at32f435_437_dma.h.

◆ DMA1_FDT4_FLAG

#define DMA1_FDT4_FLAG ((uint32_t)0x00002000)

dma1 channel4 full data transfer flag

Definition at line 78 of file at32f435_437_dma.h.

◆ DMA1_FDT5_FLAG

#define DMA1_FDT5_FLAG ((uint32_t)0x00020000)

dma1 channel5 full data transfer flag

Definition at line 82 of file at32f435_437_dma.h.

◆ DMA1_FDT6_FLAG

#define DMA1_FDT6_FLAG ((uint32_t)0x00200000)

dma1 channel6 full data transfer flag

Definition at line 86 of file at32f435_437_dma.h.

◆ DMA1_FDT7_FLAG

#define DMA1_FDT7_FLAG ((uint32_t)0x02000000)

dma1 channel7 full data transfer flag

Definition at line 90 of file at32f435_437_dma.h.

◆ DMA1_GL1_FLAG

#define DMA1_GL1_FLAG ((uint32_t)0x00000001)

dma1 channel1 global flag

Definition at line 65 of file at32f435_437_dma.h.

◆ DMA1_GL2_FLAG

#define DMA1_GL2_FLAG ((uint32_t)0x00000010)

dma1 channel2 global flag

Definition at line 69 of file at32f435_437_dma.h.

◆ DMA1_GL3_FLAG

#define DMA1_GL3_FLAG ((uint32_t)0x00000100)

dma1 channel3 global flag

Definition at line 73 of file at32f435_437_dma.h.

◆ DMA1_GL4_FLAG

#define DMA1_GL4_FLAG ((uint32_t)0x00001000)

dma1 channel4 global flag

Definition at line 77 of file at32f435_437_dma.h.

◆ DMA1_GL5_FLAG

#define DMA1_GL5_FLAG ((uint32_t)0x00010000)

dma1 channel5 global flag

Definition at line 81 of file at32f435_437_dma.h.

◆ DMA1_GL6_FLAG

#define DMA1_GL6_FLAG ((uint32_t)0x00100000)

dma1 channel6 global flag

Definition at line 85 of file at32f435_437_dma.h.

◆ DMA1_GL7_FLAG

#define DMA1_GL7_FLAG ((uint32_t)0x01000000)

dma1 channel7 global flag

Definition at line 89 of file at32f435_437_dma.h.

◆ DMA1_HDT1_FLAG

#define DMA1_HDT1_FLAG ((uint32_t)0x00000004)

dma1 channel1 half data transfer flag

Definition at line 67 of file at32f435_437_dma.h.

◆ DMA1_HDT2_FLAG

#define DMA1_HDT2_FLAG ((uint32_t)0x00000040)

dma1 channel2 half data transfer flag

Definition at line 71 of file at32f435_437_dma.h.

◆ DMA1_HDT3_FLAG

#define DMA1_HDT3_FLAG ((uint32_t)0x00000400)

dma1 channel3 half data transfer flag

Definition at line 75 of file at32f435_437_dma.h.

◆ DMA1_HDT4_FLAG

#define DMA1_HDT4_FLAG ((uint32_t)0x00004000)

dma1 channel4 half data transfer flag

Definition at line 79 of file at32f435_437_dma.h.

◆ DMA1_HDT5_FLAG

#define DMA1_HDT5_FLAG ((uint32_t)0x00040000)

dma1 channel5 half data transfer flag

Definition at line 83 of file at32f435_437_dma.h.

◆ DMA1_HDT6_FLAG

#define DMA1_HDT6_FLAG ((uint32_t)0x00400000)

dma1 channel6 half data transfer flag

Definition at line 87 of file at32f435_437_dma.h.

◆ DMA1_HDT7_FLAG

#define DMA1_HDT7_FLAG ((uint32_t)0x04000000)

dma1 channel7 half data transfer flag

Definition at line 91 of file at32f435_437_dma.h.

◆ DMA2_DTERR1_FLAG

#define DMA2_DTERR1_FLAG ((uint32_t)0x10000008)

dma2 channel1 error flag

Definition at line 97 of file at32f435_437_dma.h.

◆ DMA2_DTERR2_FLAG

#define DMA2_DTERR2_FLAG ((uint32_t)0x10000080)

dma2 channel2 error flag

Definition at line 101 of file at32f435_437_dma.h.

◆ DMA2_DTERR3_FLAG

#define DMA2_DTERR3_FLAG ((uint32_t)0x10000800)

dma2 channel3 error flag

Definition at line 105 of file at32f435_437_dma.h.

◆ DMA2_DTERR4_FLAG

#define DMA2_DTERR4_FLAG ((uint32_t)0x10008000)

dma2 channel4 error flag

Definition at line 109 of file at32f435_437_dma.h.

◆ DMA2_DTERR5_FLAG

#define DMA2_DTERR5_FLAG ((uint32_t)0x10080000)

dma2 channel5 error flag

Definition at line 113 of file at32f435_437_dma.h.

◆ DMA2_DTERR6_FLAG

#define DMA2_DTERR6_FLAG ((uint32_t)0x10800000)

dma2 channel6 error flag

Definition at line 117 of file at32f435_437_dma.h.

◆ DMA2_DTERR7_FLAG

#define DMA2_DTERR7_FLAG ((uint32_t)0x18000000)

dma2 channel7 error flag

Definition at line 121 of file at32f435_437_dma.h.

◆ DMA2_FDT1_FLAG

#define DMA2_FDT1_FLAG ((uint32_t)0x10000002)

dma2 channel1 full data transfer flag

Definition at line 95 of file at32f435_437_dma.h.

◆ DMA2_FDT2_FLAG

#define DMA2_FDT2_FLAG ((uint32_t)0x10000020)

dma2 channel2 full data transfer flag

Definition at line 99 of file at32f435_437_dma.h.

◆ DMA2_FDT3_FLAG

#define DMA2_FDT3_FLAG ((uint32_t)0x10000200)

dma2 channel3 full data transfer flag

Definition at line 103 of file at32f435_437_dma.h.

◆ DMA2_FDT4_FLAG

#define DMA2_FDT4_FLAG ((uint32_t)0x10002000)

dma2 channel4 full data transfer flag

Definition at line 107 of file at32f435_437_dma.h.

◆ DMA2_FDT5_FLAG

#define DMA2_FDT5_FLAG ((uint32_t)0x10020000)

dma2 channel5 full data transfer flag

Definition at line 111 of file at32f435_437_dma.h.

◆ DMA2_FDT6_FLAG

#define DMA2_FDT6_FLAG ((uint32_t)0x10200000)

dma2 channel6 full data transfer flag

Definition at line 115 of file at32f435_437_dma.h.

◆ DMA2_FDT7_FLAG

#define DMA2_FDT7_FLAG ((uint32_t)0x12000000)

dma2 channel7 full data transfer flag

Definition at line 119 of file at32f435_437_dma.h.

◆ DMA2_GL1_FLAG

#define DMA2_GL1_FLAG ((uint32_t)0x10000001)

dma2 channel1 global flag

Definition at line 94 of file at32f435_437_dma.h.

◆ DMA2_GL2_FLAG

#define DMA2_GL2_FLAG ((uint32_t)0x10000010)

dma2 channel2 global flag

Definition at line 98 of file at32f435_437_dma.h.

◆ DMA2_GL3_FLAG

#define DMA2_GL3_FLAG ((uint32_t)0x10000100)

dma2 channel3 global flag

Definition at line 102 of file at32f435_437_dma.h.

◆ DMA2_GL4_FLAG

#define DMA2_GL4_FLAG ((uint32_t)0x10001000)

dma2 channel4 global flag

Definition at line 106 of file at32f435_437_dma.h.

◆ DMA2_GL5_FLAG

#define DMA2_GL5_FLAG ((uint32_t)0x10010000)

dma2 channel5 global flag

Definition at line 110 of file at32f435_437_dma.h.

◆ DMA2_GL6_FLAG

#define DMA2_GL6_FLAG ((uint32_t)0x10100000)

dma2 channel6 global flag

Definition at line 114 of file at32f435_437_dma.h.

◆ DMA2_GL7_FLAG

#define DMA2_GL7_FLAG ((uint32_t)0x11000000)

dma2 channel7 global flag

Definition at line 118 of file at32f435_437_dma.h.

◆ DMA2_HDT1_FLAG

#define DMA2_HDT1_FLAG ((uint32_t)0x10000004)

dma2 channel1 half data transfer flag

Definition at line 96 of file at32f435_437_dma.h.

◆ DMA2_HDT2_FLAG

#define DMA2_HDT2_FLAG ((uint32_t)0x10000040)

dma2 channel2 half data transfer flag

Definition at line 100 of file at32f435_437_dma.h.

◆ DMA2_HDT3_FLAG

#define DMA2_HDT3_FLAG ((uint32_t)0x10000400)

dma2 channel3 half data transfer flag

Definition at line 104 of file at32f435_437_dma.h.

◆ DMA2_HDT4_FLAG

#define DMA2_HDT4_FLAG ((uint32_t)0x10004000)

dma2 channel4 half data transfer flag

Definition at line 108 of file at32f435_437_dma.h.

◆ DMA2_HDT5_FLAG

#define DMA2_HDT5_FLAG ((uint32_t)0x10040000)

dma2 channel5 half data transfer flag

Definition at line 112 of file at32f435_437_dma.h.

◆ DMA2_HDT6_FLAG

#define DMA2_HDT6_FLAG ((uint32_t)0x10400000)

dma2 channel6 half data transfer flag

Definition at line 116 of file at32f435_437_dma.h.

◆ DMA2_HDT7_FLAG

#define DMA2_HDT7_FLAG ((uint32_t)0x14000000)

dma2 channel7 half data transfer flag

Definition at line 120 of file at32f435_437_dma.h.

◆ DMAMUX_GEN_TRIG_OV1_FLAG

#define DMAMUX_GEN_TRIG_OV1_FLAG ((uint32_t)0x00000001)

dmamux generator channel1 overrun event flag

Definition at line 134 of file at32f435_437_dma.h.

◆ DMAMUX_GEN_TRIG_OV2_FLAG

#define DMAMUX_GEN_TRIG_OV2_FLAG ((uint32_t)0x00000002)

dmamux generator channel2 overrun event flag

Definition at line 135 of file at32f435_437_dma.h.

◆ DMAMUX_GEN_TRIG_OV3_FLAG

#define DMAMUX_GEN_TRIG_OV3_FLAG ((uint32_t)0x00000004)

dmamux generator channel3 overrun event flag

Definition at line 136 of file at32f435_437_dma.h.

◆ DMAMUX_GEN_TRIG_OV4_FLAG

#define DMAMUX_GEN_TRIG_OV4_FLAG ((uint32_t)0x00000008)

dmamux generator channel4 overrun event flag

Definition at line 137 of file at32f435_437_dma.h.

◆ DMAMUX_SYNC_OV1_FLAG

#define DMAMUX_SYNC_OV1_FLAG ((uint32_t)0x00000001)

dmamux flag

dmamux channel1 synchronization overrun event flag

Definition at line 126 of file at32f435_437_dma.h.

◆ DMAMUX_SYNC_OV2_FLAG

#define DMAMUX_SYNC_OV2_FLAG ((uint32_t)0x00000002)

dmamux channel2 synchronization overrun event flag

Definition at line 127 of file at32f435_437_dma.h.

◆ DMAMUX_SYNC_OV3_FLAG

#define DMAMUX_SYNC_OV3_FLAG ((uint32_t)0x00000004)

dmamux channel3 synchronization overrun event flag

Definition at line 128 of file at32f435_437_dma.h.

◆ DMAMUX_SYNC_OV4_FLAG

#define DMAMUX_SYNC_OV4_FLAG ((uint32_t)0x00000008)

dmamux channel4 synchronization overrun event flag

Definition at line 129 of file at32f435_437_dma.h.

◆ DMAMUX_SYNC_OV5_FLAG

#define DMAMUX_SYNC_OV5_FLAG ((uint32_t)0x00000010)

dmamux channel5 synchronization overrun event flag

Definition at line 130 of file at32f435_437_dma.h.

◆ DMAMUX_SYNC_OV6_FLAG

#define DMAMUX_SYNC_OV6_FLAG ((uint32_t)0x00000020)

dmamux channel6 synchronization overrun event flag

Definition at line 131 of file at32f435_437_dma.h.

◆ DMAMUX_SYNC_OV7_FLAG

#define DMAMUX_SYNC_OV7_FLAG ((uint32_t)0x00000040)

dmamux channel7 synchronization overrun event flag

Definition at line 132 of file at32f435_437_dma.h.


AT32F435/437 Firmwary Library: DMA_exported_types

Data Structures | Enumerations
DMA_exported_types
AT32F435_437_periph_driver » DMA

Data Structures

struct | dma_init_type
dma init type More...
struct | dmamux_sync_init_type
dmamux sync init type More...
struct | dmamux_gen_init_type
dmamux generator init type More...
struct | dma_type
type define dma1 register More...
struct | dma_channel_type
type define dma channel register all More...
struct | dmamux_channel_type
type define dmamux muxsctrl register More...
struct | dmamux_generator_type
type define dmamux request generator register all More...

Enumerations

enum | dma_dir_type { DMA_DIR_PERIPHERAL_TO_MEMORY = 0x0000 , DMA_DIR_MEMORY_TO_PERIPHERAL = 0x0010 , DMA_DIR_MEMORY_TO_MEMORY = 0x4000 }
dma direction type More...
enum | dma_peripheral_data_size_type { DMA_PERIPHERAL_DATA_WIDTH_BYTE = 0x00 , DMA_PERIPHERAL_DATA_WIDTH_HALFWORD = 0x01 , DMA_PERIPHERAL_DATA_WIDTH_WORD = 0x02 }
dma peripheral data size type More...
enum | dma_memory_data_size_type { DMA_MEMORY_DATA_WIDTH_BYTE = 0x00 , DMA_MEMORY_DATA_WIDTH_HALFWORD = 0x01 , DMA_MEMORY_DATA_WIDTH_WORD = 0x02 }
dma memory data size type More...
enum | dma_priority_level_type { DMA_PRIORITY_LOW = 0x00 , DMA_PRIORITY_MEDIUM = 0x01 , DMA_PRIORITY_HIGH = 0x02 , DMA_PRIORITY_VERY_HIGH = 0x03 }
dma priority level type More...
enum dmamux_requst_id_sel_type {
DMAMUX_DMAREQ_ID_REQ_G1 = 0x01 , DMAMUX_DMAREQ_ID_REQ_G2 = 0x02 , DMAMUX_DMAREQ_ID_REQ_G3 = 0x03 , DMAMUX_DMAREQ_ID_REQ_G4 = 0x04 ,
DMAMUX_DMAREQ_ID_ADC1 = 0x05 , DMAMUX_DMAREQ_ID_ADC2 = 0x24 , DMAMUX_DMAREQ_ID_ADC3 = 0x25 , DMAMUX_DMAREQ_ID_DAC1 = 0x06 ,
DMAMUX_DMAREQ_ID_DAC2 = 0x29 , DMAMUX_DMAREQ_ID_TMR6_OVERFLOW = 0x08 , DMAMUX_DMAREQ_ID_TMR7_OVERFLOW = 0x09 , DMAMUX_DMAREQ_ID_SPI1_RX = 0x0A ,
DMAMUX_DMAREQ_ID_SPI1_TX = 0x0B , DMAMUX_DMAREQ_ID_SPI2_RX = 0x0C , DMAMUX_DMAREQ_ID_SPI2_TX = 0x0D , DMAMUX_DMAREQ_ID_SPI3_RX = 0x0E ,
DMAMUX_DMAREQ_ID_SPI3_TX = 0x0F , DMAMUX_DMAREQ_ID_SPI4_RX = 0x6A , DMAMUX_DMAREQ_ID_SPI4_TX = 0x6B , DMAMUX_DMAREQ_ID_I2S2_EXT_RX = 0x6E ,
DMAMUX_DMAREQ_ID_I2S2_EXT_TX = 0x6F , DMAMUX_DMAREQ_ID_I2S3_EXT_RX = 0x70 , DMAMUX_DMAREQ_ID_I2S3_EXT_TX = 0x71 , DMAMUX_DMAREQ_ID_I2C1_RX = 0x10 ,
DMAMUX_DMAREQ_ID_I2C1_TX = 0x11 , DMAMUX_DMAREQ_ID_I2C2_RX = 0x12 , DMAMUX_DMAREQ_ID_I2C2_TX = 0x13 , DMAMUX_DMAREQ_ID_I2C3_RX = 0x14 ,
DMAMUX_DMAREQ_ID_I2C3_TX = 0x15 , DMAMUX_DMAREQ_ID_USART1_RX = 0x18 , DMAMUX_DMAREQ_ID_USART1_TX = 0x19 , DMAMUX_DMAREQ_ID_USART2_RX = 0x1A ,
DMAMUX_DMAREQ_ID_USART2_TX = 0x1B , DMAMUX_DMAREQ_ID_USART3_RX = 0x1C , DMAMUX_DMAREQ_ID_USART3_TX = 0x1D , DMAMUX_DMAREQ_ID_UART4_RX = 0x1E ,
DMAMUX_DMAREQ_ID_UART4_TX = 0x1F , DMAMUX_DMAREQ_ID_UART5_RX = 0x20 , DMAMUX_DMAREQ_ID_UART5_TX = 0x21 , DMAMUX_DMAREQ_ID_USART6_RX = 0x72 ,
DMAMUX_DMAREQ_ID_USART6_TX = 0x73 , DMAMUX_DMAREQ_ID_UART7_RX = 0x74 , DMAMUX_DMAREQ_ID_UART7_TX = 0x75 , DMAMUX_DMAREQ_ID_UART8_RX = 0x76 ,
DMAMUX_DMAREQ_ID_UART8_TX = 0x77 , DMAMUX_DMAREQ_ID_SDIO1 = 0x27 , DMAMUX_DMAREQ_ID_SDIO2 = 0x67 , DMAMUX_DMAREQ_ID_QSPI1 = 0x28 ,
DMAMUX_DMAREQ_ID_QSPI2 = 0x68 , DMAMUX_DMAREQ_ID_TMR1_CH1 = 0x2A , DMAMUX_DMAREQ_ID_TMR1_CH2 = 0x2B , DMAMUX_DMAREQ_ID_TMR1_CH3 = 0x2C ,
DMAMUX_DMAREQ_ID_TMR1_CH4 = 0x2D , DMAMUX_DMAREQ_ID_TMR1_OVERFLOW = 0x2E , DMAMUX_DMAREQ_ID_TMR1_TRIG = 0x2F , DMAMUX_DMAREQ_ID_TMR1_HALL = 0x30 ,
DMAMUX_DMAREQ_ID_TMR8_CH1 = 0x31 , DMAMUX_DMAREQ_ID_TMR8_CH2 = 0x32 , DMAMUX_DMAREQ_ID_TMR8_CH3 = 0x33 , DMAMUX_DMAREQ_ID_TMR8_CH4 = 0x34 ,
DMAMUX_DMAREQ_ID_TMR8_OVERFLOW = 0x35 , DMAMUX_DMAREQ_ID_TMR8_TRIG = 0x36 , DMAMUX_DMAREQ_ID_TMR8_HALL = 0x37 , DMAMUX_DMAREQ_ID_TMR2_CH1 = 0x38 ,
DMAMUX_DMAREQ_ID_TMR2_CH2 = 0x39 , DMAMUX_DMAREQ_ID_TMR2_CH3 = 0x3A , DMAMUX_DMAREQ_ID_TMR2_CH4 = 0x3B , DMAMUX_DMAREQ_ID_TMR2_OVERFLOW = 0x3C ,
DMAMUX_DMAREQ_ID_TMR2_TRIG = 0x7E , DMAMUX_DMAREQ_ID_TMR3_CH1 = 0x3D , DMAMUX_DMAREQ_ID_TMR3_CH2 = 0x3E , DMAMUX_DMAREQ_ID_TMR3_CH3 = 0x3F ,
DMAMUX_DMAREQ_ID_TMR3_CH4 = 0x40 , DMAMUX_DMAREQ_ID_TMR3_OVERFLOW = 0x41 , DMAMUX_DMAREQ_ID_TMR3_TRIG = 0x42 , DMAMUX_DMAREQ_ID_TMR4_CH1 = 0x43 ,
DMAMUX_DMAREQ_ID_TMR4_CH2 = 0x44 , DMAMUX_DMAREQ_ID_TMR4_CH3 = 0x45 , DMAMUX_DMAREQ_ID_TMR4_CH4 = 0x46 , DMAMUX_DMAREQ_ID_TMR4_OVERFLOW = 0x47 ,
DMAMUX_DMAREQ_ID_TMR4_TRIG = 0x7F , DMAMUX_DMAREQ_ID_TMR5_CH1 = 0x48 , DMAMUX_DMAREQ_ID_TMR5_CH2 = 0x49 , DMAMUX_DMAREQ_ID_TMR5_CH3 = 0x4A ,
DMAMUX_DMAREQ_ID_TMR5_CH4 = 0x4B , DMAMUX_DMAREQ_ID_TMR5_OVERFLOW = 0x4C , DMAMUX_DMAREQ_ID_TMR5_TRIG = 0x4D , DMAMUX_DMAREQ_ID_TMR20_CH1 = 0x56 ,
DMAMUX_DMAREQ_ID_TMR20_CH2 = 0x57 , DMAMUX_DMAREQ_ID_TMR20_CH3 = 0x58 , DMAMUX_DMAREQ_ID_TMR20_CH4 = 0x59 , DMAMUX_DMAREQ_ID_TMR20_OVERFLOW = 0x5A ,
DMAMUX_DMAREQ_ID_TMR20_TRIG = 0x5D , DMAMUX_DMAREQ_ID_TMR20_HALL = 0x5E , DMAMUX_DMAREQ_ID_DVP = 0x69
}
dmamux request type More...
enum dmamux_sync_id_sel_type {
DMAMUX_SYNC_ID_EXINT0 = 0x00 , DMAMUX_SYNC_ID_EXINT1 = 0x01 , DMAMUX_SYNC_ID_EXINT2 = 0x02 , DMAMUX_SYNC_ID_EXINT3 = 0x03 ,
DMAMUX_SYNC_ID_EXINT4 = 0x04 , DMAMUX_SYNC_ID_EXINT5 = 0x05 , DMAMUX_SYNC_ID_EXINT6 = 0x06 , DMAMUX_SYNC_ID_EXINT7 = 0x07 ,
DMAMUX_SYNC_ID_EXINT8 = 0x08 , DMAMUX_SYNC_ID_EXINT9 = 0x09 , DMAMUX_SYNC_ID_EXINT10 = 0x0A , DMAMUX_SYNC_ID_EXINT11 = 0x0B ,
DMAMUX_SYNC_ID_EXINT12 = 0x0C , DMAMUX_SYNC_ID_EXINT13 = 0x0D , DMAMUX_SYNC_ID_EXINT14 = 0x0E , DMAMUX_SYNC_ID_EXINT15 = 0x0F ,
DMAMUX_SYNC_ID_DMAMUX_CH1_EVT = 0x10 , DMAMUX_SYNC_ID_DMAMUX_CH2_EVT = 0x11 , DMAMUX_SYNC_ID_DMAMUX_CH3_EVT = 0x12 , DMAMUX_SYNC_ID_DMAMUX_CH4_EVT = 0x13 ,
DMAMUX_SYNC_ID_DMAMUX_CH5_EVT = 0x14 , DMAMUX_SYNC_ID_DMAMUX_CH6_EVT = 0x15 , DMAMUX_SYNC_ID_DMAMUX_CH7_EVT = 0x16
}
dmamux sync id type More...
enum | dmamux_sync_pol_type { DMAMUX_SYNC_POLARITY_DISABLE = 0x00 , DMAMUX_SYNC_POLARITY_RISING = 0x01 , DMAMUX_SYNC_POLARITY_FALLING = 0x02 , DMAMUX_SYNC_POLARITY_RISING_FALLING = 0x03 }
dmamux sync polarity type More...
enum dmamux_gen_id_sel_type {
DMAMUX_GEN_ID_EXINT0 = 0x00 , DMAMUX_GEN_ID_EXINT1 = 0x01 , DMAMUX_GEN_ID_EXINT2 = 0x02 , DMAMUX_GEN_ID_EXINT3 = 0x03 ,
DMAMUX_GEN_ID_EXINT4 = 0x04 , DMAMUX_GEN_ID_EXINT5 = 0x05 , DMAMUX_GEN_ID_EXINT6 = 0x06 , DMAMUX_GEN_ID_EXINT7 = 0x07 ,
DMAMUX_GEN_ID_EXINT8 = 0x08 , DMAMUX_GEN_ID_EXINT9 = 0x09 , DMAMUX_GEN_ID_EXINT10 = 0x0A , DMAMUX_GEN_ID_EXINT11 = 0x0B ,
DMAMUX_GEN_ID_EXINT12 = 0x0C , DMAMUX_GEN_ID_EXINT13 = 0x0D , DMAMUX_GEN_ID_EXINT14 = 0x0E , DMAMUX_GEN_ID_EXINT15 = 0x0F ,
DMAMUX_GEN_ID_DMAMUX_CH1_EVT = 0x10 , DMAMUX_GEN_ID_DMAMUX_CH2_EVT = 0x11 , DMAMUX_GEN_ID_DMAMUX_CH3_EVT = 0x12 , DMAMUX_GEN_ID_DMAMUX_CH4_EVT = 0x13 ,
DMAMUX_GEN_ID_DMAMUX_CH5_EVT = 0x14 , DMAMUX_GEN_ID_DMAMUX_CH6_EVT = 0x15 , DMAMUX_GEN_ID_DMAMUX_CH7_EVT = 0x16
}
dmamux generator id type More...
enum | dmamux_gen_pol_type { DMAMUX_GEN_POLARITY_DISABLE = 0x00 , DMAMUX_GEN_POLARITY_RISING = 0x01 , DMAMUX_GEN_POLARITY_FALLING = 0x02 , DMAMUX_GEN_POLARITY_RISING_FALLING = 0x03 }
dmamux generator polarity type More...

Detailed Description

Enumeration Type Documentation

◆ dma_dir_type

enum dma_dir_type

dma direction type

Enumerator
DMA_DIR_PERIPHERAL_TO_MEMORY | dma data transfer direction: peripheral to memory
DMA_DIR_MEMORY_TO_PERIPHERAL | dma data transfer direction: memory to peripheral
DMA_DIR_MEMORY_TO_MEMORY | dma data transfer direction: memory to memory

Definition at line 150 of file at32f435_437_dma.h.

◆ dma_memory_data_size_type

enum dma_memory_data_size_type

dma memory data size type

Enumerator
DMA_MEMORY_DATA_WIDTH_BYTE | dma memory databus width 8bit
DMA_MEMORY_DATA_WIDTH_HALFWORD | dma memory databus width 16bit
DMA_MEMORY_DATA_WIDTH_WORD | dma memory databus width 32bit

Definition at line 170 of file at32f435_437_dma.h.

◆ dma_peripheral_data_size_type

enum dma_peripheral_data_size_type

dma peripheral data size type

Enumerator
DMA_PERIPHERAL_DATA_WIDTH_BYTE | dma peripheral databus width 8bit
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD | dma peripheral databus width 16bit
DMA_PERIPHERAL_DATA_WIDTH_WORD | dma peripheral databus width 32bit

Definition at line 160 of file at32f435_437_dma.h.

◆ dma_priority_level_type

enum dma_priority_level_type

dma priority level type

Enumerator
DMA_PRIORITY_LOW | dma channel priority: low
DMA_PRIORITY_MEDIUM | dma channel priority: medium
DMA_PRIORITY_HIGH | dma channel priority: high
DMA_PRIORITY_VERY_HIGH | dma channel priority: very high

Definition at line 180 of file at32f435_437_dma.h.

◆ dmamux_gen_id_sel_type

enum dmamux_gen_id_sel_type

dmamux generator id type

Enumerator
DMAMUX_GEN_ID_EXINT0 | dmamux generator channel inputs resources: exint line0
DMAMUX_GEN_ID_EXINT1 | dmamux generator channel inputs resources: exint line1
DMAMUX_GEN_ID_EXINT2 | dmamux generator channel inputs resources: exint line2
DMAMUX_GEN_ID_EXINT3 | dmamux generator channel inputs resources: exint line3
DMAMUX_GEN_ID_EXINT4 | dmamux generator channel inputs resources: exint line4
DMAMUX_GEN_ID_EXINT5 | dmamux generator channel inputs resources: exint line5
DMAMUX_GEN_ID_EXINT6 | dmamux generator channel inputs resources: exint line6
DMAMUX_GEN_ID_EXINT7 | dmamux generator channel inputs resources: exint line7
DMAMUX_GEN_ID_EXINT8 | dmamux generator channel inputs resources: exint line8
DMAMUX_GEN_ID_EXINT9 | dmamux generator channel inputs resources: exint line9
DMAMUX_GEN_ID_EXINT10 | dmamux generator channel inputs resources: exint line10
DMAMUX_GEN_ID_EXINT11 | dmamux generator channel inputs resources: exint line11
DMAMUX_GEN_ID_EXINT12 | dmamux generator channel inputs resources: exint line12
DMAMUX_GEN_ID_EXINT13 | dmamux generator channel inputs resources: exint line13
DMAMUX_GEN_ID_EXINT14 | dmamux generator channel inputs resources: exint line14
DMAMUX_GEN_ID_EXINT15 | dmamux generator channel inputs resources: exint line15
DMAMUX_GEN_ID_DMAMUX_CH1_EVT | dmamux generator channel inputs resources: dmamux channel1 event
DMAMUX_GEN_ID_DMAMUX_CH2_EVT | dmamux generator channel inputs resources: dmamux channel2 event
DMAMUX_GEN_ID_DMAMUX_CH3_EVT | dmamux generator channel inputs resources: dmamux channel3 event
DMAMUX_GEN_ID_DMAMUX_CH4_EVT | dmamux generator channel inputs resources: dmamux channel4 event
DMAMUX_GEN_ID_DMAMUX_CH5_EVT | dmamux generator channel inputs resources: dmamux channel5 event
DMAMUX_GEN_ID_DMAMUX_CH6_EVT | dmamux generator channel inputs resources: dmamux channel6 event
DMAMUX_GEN_ID_DMAMUX_CH7_EVT | dmamux generator channel inputs resources: dmamux channel7 event

Definition at line 334 of file at32f435_437_dma.h.

◆ dmamux_gen_pol_type

enum dmamux_gen_pol_type

dmamux generator polarity type

Enumerator
DMAMUX_GEN_POLARITY_DISABLE | dmamux generator channel inputs resources polarity default value
DMAMUX_GEN_POLARITY_RISING | dmamux generator channel inputs resources polarity: rising
DMAMUX_GEN_POLARITY_FALLING | dmamux generator channel inputs resources polarity: falling
DMAMUX_GEN_POLARITY_RISING_FALLING | dmamux generator channel inputs resources polarity: rising_falling

Definition at line 364 of file at32f435_437_dma.h.

◆ dmamux_requst_id_sel_type

enum dmamux_requst_id_sel_type

dmamux request type

Enumerator
DMAMUX_DMAREQ_ID_REQ_G1 | dmamux channel dma request inputs resources: generator channel1
DMAMUX_DMAREQ_ID_REQ_G2 | dmamux channel dma request inputs resources: generator channel2
DMAMUX_DMAREQ_ID_REQ_G3 | dmamux channel dma request inputs resources: generator channel3
DMAMUX_DMAREQ_ID_REQ_G4 | dmamux channel dma request inputs resources: generator channel4
DMAMUX_DMAREQ_ID_ADC1 | dmamux channel dma request inputs resources: adc1
DMAMUX_DMAREQ_ID_ADC2 | dmamux channel dma request inputs resources: adc2
DMAMUX_DMAREQ_ID_ADC3 | dmamux channel dma request inputs resources: adc3
DMAMUX_DMAREQ_ID_DAC1 | dmamux channel dma request inputs resources: dac1
DMAMUX_DMAREQ_ID_DAC2 | dmamux channel dma request inputs resources: dac2
DMAMUX_DMAREQ_ID_TMR6_OVERFLOW | dmamux channel dma request inputs resources: timer6 overflow
DMAMUX_DMAREQ_ID_TMR7_OVERFLOW | dmamux channel dma request inputs resources: timer7 overflow
DMAMUX_DMAREQ_ID_SPI1_RX | dmamux channel dma request inputs resources: spi1 rx
DMAMUX_DMAREQ_ID_SPI1_TX | dmamux channel dma request inputs resources: spi1 tx
DMAMUX_DMAREQ_ID_SPI2_RX | dmamux channel dma request inputs resources: spi2 rx
DMAMUX_DMAREQ_ID_SPI2_TX | dmamux channel dma request inputs resources: spi2 tx
DMAMUX_DMAREQ_ID_SPI3_RX | dmamux channel dma request inputs resources: spi3 rx
DMAMUX_DMAREQ_ID_SPI3_TX | dmamux channel dma request inputs resources: spi3 tx
DMAMUX_DMAREQ_ID_SPI4_RX | dmamux channel dma request inputs resources: spi4 rx
DMAMUX_DMAREQ_ID_SPI4_TX | dmamux channel dma request inputs resources: spi4 tx
DMAMUX_DMAREQ_ID_I2S2_EXT_RX | dmamux channel dma request inputs resources: i2s2_ext_rx
DMAMUX_DMAREQ_ID_I2S2_EXT_TX | dmamux channel dma request inputs resources: i2s2_ext_tx
DMAMUX_DMAREQ_ID_I2S3_EXT_RX | dmamux channel dma request inputs resources: i2s3_ext_rx
DMAMUX_DMAREQ_ID_I2S3_EXT_TX | dmamux channel dma request inputs resources: i2s3_ext_tx
DMAMUX_DMAREQ_ID_I2C1_RX | dmamux channel dma request inputs resources: i2c1_rx
DMAMUX_DMAREQ_ID_I2C1_TX | dmamux channel dma request inputs resources: i2c1_tx
DMAMUX_DMAREQ_ID_I2C2_RX | dmamux channel dma request inputs resources: i2c2_rx
DMAMUX_DMAREQ_ID_I2C2_TX | dmamux channel dma request inputs resources: i2c2_tx
DMAMUX_DMAREQ_ID_I2C3_RX | dmamux channel dma request inputs resources: i2c3_rx
DMAMUX_DMAREQ_ID_I2C3_TX | dmamux channel dma request inputs resources: i2c3_tx
DMAMUX_DMAREQ_ID_USART1_RX | dmamux channel dma request inputs resources: usart1_rx
DMAMUX_DMAREQ_ID_USART1_TX | dmamux channel dma request inputs resources: usart1_tx
DMAMUX_DMAREQ_ID_USART2_RX | dmamux channel dma request inputs resources: usart2_rx
DMAMUX_DMAREQ_ID_USART2_TX | dmamux channel dma request inputs resources: usart2_tx
DMAMUX_DMAREQ_ID_USART3_RX | dmamux channel dma request inputs resources: usart3_rx
DMAMUX_DMAREQ_ID_USART3_TX | dmamux channel dma request inputs resources: usart3_tx
DMAMUX_DMAREQ_ID_UART4_RX | dmamux channel dma request inputs resources: uart4_rx
DMAMUX_DMAREQ_ID_UART4_TX | dmamux channel dma request inputs resources: uart4_tx
DMAMUX_DMAREQ_ID_UART5_RX | dmamux channel dma request inputs resources: uart5_rx
DMAMUX_DMAREQ_ID_UART5_TX | dmamux channel dma request inputs resources: uart5_tx
DMAMUX_DMAREQ_ID_USART6_RX | dmamux channel dma request inputs resources: usart6_rx
DMAMUX_DMAREQ_ID_USART6_TX | dmamux channel dma request inputs resources: usart6_tx
DMAMUX_DMAREQ_ID_UART7_RX | dmamux channel dma request inputs resources: uart7_rx
DMAMUX_DMAREQ_ID_UART7_TX | dmamux channel dma request inputs resources: uart7_tx
DMAMUX_DMAREQ_ID_UART8_RX | dmamux channel dma request inputs resources: uart8_rx
DMAMUX_DMAREQ_ID_UART8_TX | dmamux channel dma request inputs resources: uart8_tx
DMAMUX_DMAREQ_ID_SDIO1 | dmamux channel dma request inputs resources: sdio1
DMAMUX_DMAREQ_ID_SDIO2 | dmamux channel dma request inputs resources: sdio2
DMAMUX_DMAREQ_ID_QSPI1 | dmamux channel dma request inputs resources: qspi1
DMAMUX_DMAREQ_ID_QSPI2 | dmamux channel dma request inputs resources: qspi2
DMAMUX_DMAREQ_ID_TMR1_CH1 | dmamux channel dma request inputs resources: timer1 ch1
DMAMUX_DMAREQ_ID_TMR1_CH2 | dmamux channel dma request inputs resources: timer1 ch2
DMAMUX_DMAREQ_ID_TMR1_CH3 | dmamux channel dma request inputs resources: timer1 ch3
DMAMUX_DMAREQ_ID_TMR1_CH4 | dmamux channel dma request inputs resources: timer1 ch4
DMAMUX_DMAREQ_ID_TMR1_OVERFLOW | dmamux channel dma request inputs resources: timer1 overflow
DMAMUX_DMAREQ_ID_TMR1_TRIG | dmamux channel dma request inputs resources: timer1 trigger
DMAMUX_DMAREQ_ID_TMR1_HALL | dmamux channel dma request inputs resources: timer1 hall
DMAMUX_DMAREQ_ID_TMR8_CH1 | dmamux channel dma request inputs resources: timer8 ch1
DMAMUX_DMAREQ_ID_TMR8_CH2 | dmamux channel dma request inputs resources: timer8 ch2
DMAMUX_DMAREQ_ID_TMR8_CH3 | dmamux channel dma request inputs resources: timer8 ch3
DMAMUX_DMAREQ_ID_TMR8_CH4 | dmamux channel dma request inputs resources: timer8 ch4
DMAMUX_DMAREQ_ID_TMR8_OVERFLOW | dmamux channel dma request inputs resources: timer8 overflow
DMAMUX_DMAREQ_ID_TMR8_TRIG | dmamux channel dma request inputs resources: timer8 trigger
DMAMUX_DMAREQ_ID_TMR8_HALL | dmamux channel dma request inputs resources: timer8 hall
DMAMUX_DMAREQ_ID_TMR2_CH1 | dmamux channel dma request inputs resources: timer2 ch1
DMAMUX_DMAREQ_ID_TMR2_CH2 | dmamux channel dma request inputs resources: timer2 ch2
DMAMUX_DMAREQ_ID_TMR2_CH3 | dmamux channel dma request inputs resources: timer2 ch3
DMAMUX_DMAREQ_ID_TMR2_CH4 | dmamux channel dma request inputs resources: timer2 ch4
DMAMUX_DMAREQ_ID_TMR2_OVERFLOW | dmamux channel dma request inputs resources: timer2 overflow
DMAMUX_DMAREQ_ID_TMR2_TRIG | dmamux channel dma request inputs resources: timer2 trigger
DMAMUX_DMAREQ_ID_TMR3_CH1 | dmamux channel dma request inputs resources: timer3 ch1
DMAMUX_DMAREQ_ID_TMR3_CH2 | dmamux channel dma request inputs resources: timer3 ch2
DMAMUX_DMAREQ_ID_TMR3_CH3 | dmamux channel dma request inputs resources: timer3 ch3
DMAMUX_DMAREQ_ID_TMR3_CH4 | dmamux channel dma request inputs resources: timer3 ch4
DMAMUX_DMAREQ_ID_TMR3_OVERFLOW | dmamux channel dma request inputs resources: timer3 overflow
DMAMUX_DMAREQ_ID_TMR3_TRIG | dmamux channel dma request inputs resources: timer3 trigger
DMAMUX_DMAREQ_ID_TMR4_CH1 | dmamux channel dma request inputs resources: timer4 ch1
DMAMUX_DMAREQ_ID_TMR4_CH2 | dmamux channel dma request inputs resources: timer4 ch2
DMAMUX_DMAREQ_ID_TMR4_CH3 | dmamux channel dma request inputs resources: timer4 ch3
DMAMUX_DMAREQ_ID_TMR4_CH4 | dmamux channel dma request inputs resources: timer4 ch4
DMAMUX_DMAREQ_ID_TMR4_OVERFLOW | dmamux channel dma request inputs resources: timer4 overflow
DMAMUX_DMAREQ_ID_TMR4_TRIG | dmamux channel dma request inputs resources: timer4 trigger
DMAMUX_DMAREQ_ID_TMR5_CH1 | dmamux channel dma request inputs resources: timer5 ch1
DMAMUX_DMAREQ_ID_TMR5_CH2 | dmamux channel dma request inputs resources: timer5 ch2
DMAMUX_DMAREQ_ID_TMR5_CH3 | dmamux channel dma request inputs resources: timer5 ch3
DMAMUX_DMAREQ_ID_TMR5_CH4 | dmamux channel dma request inputs resources: timer5 ch4
DMAMUX_DMAREQ_ID_TMR5_OVERFLOW | dmamux channel dma request inputs resources: timer5 overflow
DMAMUX_DMAREQ_ID_TMR5_TRIG | dmamux channel dma request inputs resources: timer5 trigger
DMAMUX_DMAREQ_ID_TMR20_CH1 | dmamux channel dma request inputs resources: timer20 ch1
DMAMUX_DMAREQ_ID_TMR20_CH2 | dmamux channel dma request inputs resources: timer20 ch2
DMAMUX_DMAREQ_ID_TMR20_CH3 | dmamux channel dma request inputs resources: timer20 ch3
DMAMUX_DMAREQ_ID_TMR20_CH4 | dmamux channel dma request inputs resources: timer20 ch4
DMAMUX_DMAREQ_ID_TMR20_OVERFLOW | dmamux channel dma request inputs resources: timer20 overflow
DMAMUX_DMAREQ_ID_TMR20_TRIG | dmamux channel dma request inputs resources: timer20 trigger
DMAMUX_DMAREQ_ID_TMR20_HALL | dmamux channel dma request inputs resources: timer20 hall
DMAMUX_DMAREQ_ID_DVP | dmamux channel dma request inputs resources: dvp

Definition at line 191 of file at32f435_437_dma.h.

◆ dmamux_sync_id_sel_type

enum dmamux_sync_id_sel_type

dmamux sync id type

Enumerator
DMAMUX_SYNC_ID_EXINT0 | dmamux channel synchronization inputs resources: exint line0
DMAMUX_SYNC_ID_EXINT1 | dmamux channel synchronization inputs resources: exint line1
DMAMUX_SYNC_ID_EXINT2 | dmamux channel synchronization inputs resources: exint line2
DMAMUX_SYNC_ID_EXINT3 | dmamux channel synchronization inputs resources: exint line3
DMAMUX_SYNC_ID_EXINT4 | dmamux channel synchronization inputs resources: exint line4
DMAMUX_SYNC_ID_EXINT5 | dmamux channel synchronization inputs resources: exint line5
DMAMUX_SYNC_ID_EXINT6 | dmamux channel synchronization inputs resources: exint line6
DMAMUX_SYNC_ID_EXINT7 | dmamux channel synchronization inputs resources: exint line7
DMAMUX_SYNC_ID_EXINT8 | dmamux channel synchronization inputs resources: exint line8
DMAMUX_SYNC_ID_EXINT9 | dmamux channel synchronization inputs resources: exint line9
DMAMUX_SYNC_ID_EXINT10 | dmamux channel synchronization inputs resources: exint line10
DMAMUX_SYNC_ID_EXINT11 | dmamux channel synchronization inputs resources: exint line11
DMAMUX_SYNC_ID_EXINT12 | dmamux channel synchronization inputs resources: exint line12
DMAMUX_SYNC_ID_EXINT13 | dmamux channel synchronization inputs resources: exint line13
DMAMUX_SYNC_ID_EXINT14 | dmamux channel synchronization inputs resources: exint line14
DMAMUX_SYNC_ID_EXINT15 | dmamux channel synchronization inputs resources: exint line15
DMAMUX_SYNC_ID_DMAMUX_CH1_EVT | dmamux channel synchronization inputs resources: dmamux channel1 event
DMAMUX_SYNC_ID_DMAMUX_CH2_EVT | dmamux channel synchronization inputs resources: dmamux channel2 event
DMAMUX_SYNC_ID_DMAMUX_CH3_EVT | dmamux channel synchronization inputs resources: dmamux channel3 event
DMAMUX_SYNC_ID_DMAMUX_CH4_EVT | dmamux channel synchronization inputs resources: dmamux channel4 event
DMAMUX_SYNC_ID_DMAMUX_CH5_EVT | dmamux channel synchronization inputs resources: dmamux channel5 event
DMAMUX_SYNC_ID_DMAMUX_CH6_EVT | dmamux channel synchronization inputs resources: dmamux channel6 event
DMAMUX_SYNC_ID_DMAMUX_CH7_EVT | dmamux channel synchronization inputs resources: dmamux channel7 event

Definition at line 293 of file at32f435_437_dma.h.

◆ dmamux_sync_pol_type

enum dmamux_sync_pol_type

dmamux sync polarity type

Enumerator
DMAMUX_SYNC_POLARITY_DISABLE | dmamux channel synchronization inputs resources polarity default value
DMAMUX_SYNC_POLARITY_RISING | dmamux channel synchronization inputs resources polarity: rising
DMAMUX_SYNC_POLARITY_FALLING | dmamux channel synchronization inputs resources polarity: falling
DMAMUX_SYNC_POLARITY_RISING_FALLING | dmamux channel synchronization inputs resources polarity: rising_falling

Definition at line 323 of file at32f435_437_dma.h.


AT32F435/437 Firmwary Library: dma_init_type Struct Reference

Data Fields
dma_init_type Struct Reference
AT32F435_437_periph_driver » DMA » DMA_exported_types

dma init type More...

#include <at32f435_437_dma.h>

Data Fields

uint32_t | peripheral_base_addr
uint32_t | memory_base_addr
dma_dir_type direction
uint16_t | buffer_size
confirm_state peripheral_inc_enable
confirm_state memory_inc_enable
dma_peripheral_data_size_type peripheral_data_width
dma_memory_data_size_type memory_data_width
confirm_state loop_mode_enable
dma_priority_level_type priority

Detailed Description

dma init type

Definition at line 375 of file at32f435_437_dma.h.

Field Documentation

◆ buffer_size

uint16_t dma_init_type::buffer_size

counter to transfer (0~0xFFFF)

Definition at line 380 of file at32f435_437_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_dma_config(), i2c_lowlevel_init(), i2s_config(), main(), qspi_dma_set(), sd_dma_config(), sdram_copy_to_sram_dma(), spi_bytes_read(), spi_bytes_write(), spi_config(), and sram_copy_to_sdram_dma().

◆ direction

dma_dir_type dma_init_type::direction

dma transmit direction, peripheral as source or as destnation

Definition at line 379 of file at32f435_437_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_dma_config(), i2c_lowlevel_init(), i2c_master_irq_handler_dma(), i2s_config(), main(), qspi_dma_set(), sd_dma_config(), sdram_copy_to_sram_dma(), spi_bytes_read(), spi_bytes_write(), spi_config(), and sram_copy_to_sdram_dma().

◆ loop_mode_enable

confirm_state dma_init_type::loop_mode_enable

when loop mode enable, buffer size will reload if count to 0

Definition at line 385 of file at32f435_437_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_lowlevel_init(), i2s_config(), main(), qspi_dma_set(), sd_dma_config(), sdram_copy_to_sram_dma(), spi_bytes_read(), spi_bytes_write(), spi_config(), and sram_copy_to_sdram_dma().

◆ memory_base_addr

uint32_t dma_init_type::memory_base_addr

base addrress for memory

Definition at line 378 of file at32f435_437_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_dma_config(), i2c_lowlevel_init(), i2s_config(), main(), qspi_dma_set(), sd_dma_config(), sdram_copy_to_sram_dma(), spi_bytes_read(), spi_bytes_write(), spi_config(), and sram_copy_to_sdram_dma().

◆ memory_data_width

dma_memory_data_size_type dma_init_type::memory_data_width

memory data width for transmit

Definition at line 384 of file at32f435_437_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_lowlevel_init(), i2s_config(), main(), qspi_dma_set(), sd_dma_config(), sdram_copy_to_sram_dma(), spi_bytes_read(), spi_bytes_write(), spi_config(), and sram_copy_to_sdram_dma().

◆ memory_inc_enable

confirm_state dma_init_type::memory_inc_enable

memory address increment after one transmit

Definition at line 382 of file at32f435_437_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_lowlevel_init(), i2s_config(), main(), qspi_dma_set(), sd_dma_config(), sdram_copy_to_sram_dma(), spi_bytes_read(), spi_bytes_write(), spi_config(), and sram_copy_to_sdram_dma().

◆ peripheral_base_addr

uint32_t dma_init_type::peripheral_base_addr

base addrress for peripheral

Definition at line 377 of file at32f435_437_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_dma_config(), i2c_lowlevel_init(), i2s_config(), main(), qspi_dma_set(), sd_dma_config(), sdram_copy_to_sram_dma(), spi_bytes_read(), spi_bytes_write(), spi_config(), and sram_copy_to_sdram_dma().

◆ peripheral_data_width

dma_peripheral_data_size_type dma_init_type::peripheral_data_width

peripheral data width for transmit

Definition at line 383 of file at32f435_437_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_lowlevel_init(), i2s_config(), main(), qspi_dma_set(), sd_dma_config(), sdram_copy_to_sram_dma(), spi_bytes_read(), spi_bytes_write(), spi_config(), and sram_copy_to_sdram_dma().

◆ peripheral_inc_enable

confirm_state dma_init_type::peripheral_inc_enable

periphera address increment after one transmit

Definition at line 381 of file at32f435_437_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_lowlevel_init(), i2s_config(), main(), qspi_dma_set(), sd_dma_config(), sdram_copy_to_sram_dma(), spi_bytes_read(), spi_bytes_write(), spi_config(), and sram_copy_to_sdram_dma().

◆ priority

dma_priority_level_type dma_init_type::priority

dma priority can choose from very high,high,dedium or low

Definition at line 386 of file at32f435_437_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_lowlevel_init(), i2s_config(), main(), qspi_dma_set(), sd_dma_config(), sdram_copy_to_sram_dma(), spi_bytes_read(), spi_bytes_write(), spi_config(), and sram_copy_to_sdram_dma().

The documentation for this struct was generated from the following file:
  • at32f435_437_dma.h


AT32F435/437 Firmwary Library: dmamux_sync_init_type Struct Reference

Data Fields
dmamux_sync_init_type Struct Reference
AT32F435_437_periph_driver » DMA » DMA_exported_types

dmamux sync init type More...

#include <at32f435_437_dma.h>

Data Fields

dmamux_sync_id_sel_type sync_signal_sel
uint32_t | sync_polarity
uint32_t | sync_request_number
confirm_state sync_event_enable
confirm_state sync_enable

Detailed Description

dmamux sync init type

Definition at line 392 of file at32f435_437_dma.h.

Field Documentation

◆ sync_enable

confirm_state dmamux_sync_init_type::sync_enable

dma dmamux synchronization enable

Definition at line 398 of file at32f435_437_dma.h.

Referenced by dmamux_sync_config(), dmamux_sync_default_para_init(), and main().

◆ sync_event_enable

confirm_state dmamux_sync_init_type::sync_event_enable

dma dmamux event generation disabled

Definition at line 397 of file at32f435_437_dma.h.

Referenced by dmamux_sync_config(), dmamux_sync_default_para_init(), and main().

◆ sync_polarity

uint32_t dmamux_sync_init_type::sync_polarity

dma dmamux synchronization polarity

Definition at line 395 of file at32f435_437_dma.h.

Referenced by dmamux_sync_config(), dmamux_sync_default_para_init(), and main().

◆ sync_request_number

uint32_t dmamux_sync_init_type::sync_request_number

dma dmamux number of dma requests before an output event is generated

Definition at line 396 of file at32f435_437_dma.h.

Referenced by dmamux_sync_config(), dmamux_sync_default_para_init(), and main().

◆ sync_signal_sel

dmamux_sync_id_sel_type dmamux_sync_init_type::sync_signal_sel

dma dmamux synchronization input select

Definition at line 394 of file at32f435_437_dma.h.

Referenced by dmamux_sync_config(), dmamux_sync_default_para_init(), and main().

The documentation for this struct was generated from the following file:
  • at32f435_437_dma.h


AT32F435/437 Firmwary Library: dmamux_gen_init_type Struct Reference

Data Fields
dmamux_gen_init_type Struct Reference
AT32F435_437_periph_driver » DMA » DMA_exported_types

dmamux generator init type More...

#include <at32f435_437_dma.h>

Data Fields

dmamux_gen_id_sel_type gen_signal_sel
dmamux_gen_pol_type gen_polarity
uint32_t gen_request_number
confirm_state gen_enable

Detailed Description

dmamux generator init type

Definition at line 404 of file at32f435_437_dma.h.

Field Documentation

◆ gen_enable

confirm_state dmamux_gen_init_type::gen_enable

dma dmamux generator enable

Definition at line 409 of file at32f435_437_dma.h.

Referenced by dmamux_generator_config(), dmamux_generator_default_para_init(), and main().

◆ gen_polarity

dmamux_gen_pol_type dmamux_gen_init_type::gen_polarity

dma dmamux generator trigger polarity

Definition at line 407 of file at32f435_437_dma.h.

Referenced by dmamux_generator_config(), dmamux_generator_default_para_init(), and main().

◆ gen_request_number

uint32_t dmamux_gen_init_type::gen_request_number

dma dmamux the number of dma requests to be generated after a trigger event

Definition at line 408 of file at32f435_437_dma.h.

Referenced by dmamux_generator_config(), dmamux_generator_default_para_init(), and main().

◆ gen_signal_sel

dmamux_gen_id_sel_type dmamux_gen_init_type::gen_signal_sel

dma dmamux generator dma request trigger input select

Definition at line 406 of file at32f435_437_dma.h.

Referenced by dmamux_generator_config(), dmamux_generator_default_para_init(), and main().

The documentation for this struct was generated from the following file:
  • at32f435_437_dma.h


AT32F435/437 Firmwary Library: dma_type Struct Reference

Data Fields
dma_type Struct Reference
AT32F435_437_periph_driver » DMA » DMA_exported_types

type define dma1 register More...

#include <at32f435_437_dma.h>

Data Fields

union {
__IO uint32_t sts
struct {
__IO uint32_t gf1: 1
__IO uint32_t fdtf1: 1
__IO uint32_t hdtf1: 1
__IO uint32_t dterrf1: 1
__IO uint32_t gf2: 1
__IO uint32_t fdtf2: 1
__IO uint32_t hdtf2: 1
__IO uint32_t dterrf2: 1
__IO uint32_t gf3: 1
__IO uint32_t fdtf3: 1
__IO uint32_t hdtf3: 1
__IO uint32_t dterrf3: 1
__IO uint32_t gf4: 1
__IO uint32_t fdtf4: 1
__IO uint32_t hdtf4: 1
__IO uint32_t dterrf4: 1
__IO uint32_t gf5: 1
__IO uint32_t fdtf5: 1
__IO uint32_t hdtf5: 1
__IO uint32_t dterrf5: 1
__IO uint32_t gf6: 1
__IO uint32_t fdtf6: 1
__IO uint32_t hdtf6: 1
__IO uint32_t dterrf6: 1
__IO uint32_t gf7: 1
__IO uint32_t fdtf7: 1
__IO uint32_t hdtf7: 1
__IO uint32_t dterrf7: 1
__IO uint32_t reserved1: 4
} sts_bit
};
dma sts register, offset:0x00 More...
union {
__IO uint32_t clr
struct {
__IO uint32_t gfc1: 1
__IO uint32_t fdtfc1: 1
__IO uint32_t hdtfc1: 1
__IO uint32_t dterrfc1: 1
__IO uint32_t gfc2: 1
__IO uint32_t fdtfc2: 1
__IO uint32_t hdtfc2: 1
__IO uint32_t dterrfc2: 1
__IO uint32_t gfc3: 1
__IO uint32_t fdtfc3: 1
__IO uint32_t hdtfc3: 1
__IO uint32_t dterrfc3: 1
__IO uint32_t gfc4: 1
__IO uint32_t fdtfc4: 1
__IO uint32_t hdtfc4: 1
__IO uint32_t dterrfc4: 1
__IO uint32_t gfc5: 1
__IO uint32_t fdtfc5: 1
__IO uint32_t hdtfc5: 1
__IO uint32_t dterrfc5: 1
__IO uint32_t gfc6: 1
__IO uint32_t fdtfc6: 1
__IO uint32_t hdtfc6: 1
__IO uint32_t dterrfc6: 1
__IO uint32_t gfc7: 1
__IO uint32_t fdtfc7: 1
__IO uint32_t hdtfc7: 1
__IO uint32_t dterrfc7: 1
__IO uint32_t reserved1: 4
} clr_bit
};
dma clr register, offset:0x04 More...
union {
__IO uint32_t muxsel
struct {
__IO uint32_t tblsel: 1
__IO uint32_t reserved1: 31
} muxsel_bit
};
dmamux sel register, offset:0x100 More...
__IO uint32_t reserved2 [11]
reserved, offset:0x104~0x12C More...
union {
__IO uint32_t muxsyncsts
struct {
__IO uint32_t syncovf: 7
__IO uint32_t reserved1: 25
} muxsyncsts_bit
};
dmamux syncsts register, offset:0x130 More...
union {
__IO uint32_t muxsyncclr
struct {
__IO uint32_t syncovfc: 7
__IO uint32_t reserved1: 25
} muxsyncclr_bit
};
dmamux syncclr register, offset:0x134 More...
union {
__IO uint32_t muxgsts
struct {
__IO uint32_t trgovf: 4
__IO uint32_t reserved1: 28
} muxgsts_bit
};
dmamux request generator status register, offset:0x138 More...
union {
__IO uint32_t muxgclr
struct {
__IO uint32_t trgovfc: 4
__IO uint32_t reserved1: 28
} muxgclr_bit
};
dmamux request generator status clear register, offset:0x13C More...

Detailed Description

type define dma1 register

Definition at line 415 of file at32f435_437_dma.h.

Field Documentation

◆

union { ... } dma_type::@292

dma sts register, offset:0x00

◆

union { ... } dma_type::@294

dma clr register, offset:0x04

◆

union { ... } dma_type::@296

dmamux sel register, offset:0x100

◆

union { ... } dma_type::@298

dmamux syncsts register, offset:0x130

◆

union { ... } dma_type::@300

dmamux syncclr register, offset:0x134

◆

union { ... } dma_type::@302

dmamux request generator status register, offset:0x138

◆

union { ... } dma_type::@304

dmamux request generator status clear register, offset:0x13C

◆ clr

__IO uint32_t dma_type::clr

Definition at line 462 of file at32f435_437_dma.h.

◆

struct { ... } dma_type::clr_bit

◆ dterrf1

__IO uint32_t dma_type::dterrf1

Definition at line 428 of file at32f435_437_dma.h.

◆ dterrf2

__IO uint32_t dma_type::dterrf2

Definition at line 432 of file at32f435_437_dma.h.

◆ dterrf3

__IO uint32_t dma_type::dterrf3

Definition at line 436 of file at32f435_437_dma.h.

◆ dterrf4

__IO uint32_t dma_type::dterrf4

Definition at line 440 of file at32f435_437_dma.h.

◆ dterrf5

__IO uint32_t dma_type::dterrf5

Definition at line 444 of file at32f435_437_dma.h.

◆ dterrf6

__IO uint32_t dma_type::dterrf6

Definition at line 448 of file at32f435_437_dma.h.

◆ dterrf7

__IO uint32_t dma_type::dterrf7

Definition at line 452 of file at32f435_437_dma.h.

◆ dterrfc1

__IO uint32_t dma_type::dterrfc1

Definition at line 468 of file at32f435_437_dma.h.

◆ dterrfc2

__IO uint32_t dma_type::dterrfc2

Definition at line 472 of file at32f435_437_dma.h.

◆ dterrfc3

__IO uint32_t dma_type::dterrfc3

Definition at line 476 of file at32f435_437_dma.h.

◆ dterrfc4

__IO uint32_t dma_type::dterrfc4

Definition at line 480 of file at32f435_437_dma.h.

◆ dterrfc5

__IO uint32_t dma_type::dterrfc5

Definition at line 484 of file at32f435_437_dma.h.

◆ dterrfc6

__IO uint32_t dma_type::dterrfc6

Definition at line 488 of file at32f435_437_dma.h.

◆ dterrfc7

__IO uint32_t dma_type::dterrfc7

Definition at line 492 of file at32f435_437_dma.h.

◆ fdtf1

__IO uint32_t dma_type::fdtf1

Definition at line 426 of file at32f435_437_dma.h.

◆ fdtf2

__IO uint32_t dma_type::fdtf2

Definition at line 430 of file at32f435_437_dma.h.

◆ fdtf3

__IO uint32_t dma_type::fdtf3

Definition at line 434 of file at32f435_437_dma.h.

◆ fdtf4

__IO uint32_t dma_type::fdtf4

Definition at line 438 of file at32f435_437_dma.h.

◆ fdtf5

__IO uint32_t dma_type::fdtf5

Definition at line 442 of file at32f435_437_dma.h.

◆ fdtf6

__IO uint32_t dma_type::fdtf6

Definition at line 446 of file at32f435_437_dma.h.

◆ fdtf7

__IO uint32_t dma_type::fdtf7

Definition at line 450 of file at32f435_437_dma.h.

◆ fdtfc1

__IO uint32_t dma_type::fdtfc1

Definition at line 466 of file at32f435_437_dma.h.

◆ fdtfc2

__IO uint32_t dma_type::fdtfc2

Definition at line 470 of file at32f435_437_dma.h.

◆ fdtfc3

__IO uint32_t dma_type::fdtfc3

Definition at line 474 of file at32f435_437_dma.h.

◆ fdtfc4

__IO uint32_t dma_type::fdtfc4

Definition at line 478 of file at32f435_437_dma.h.

◆ fdtfc5

__IO uint32_t dma_type::fdtfc5

Definition at line 482 of file at32f435_437_dma.h.

◆ fdtfc6

__IO uint32_t dma_type::fdtfc6

Definition at line 486 of file at32f435_437_dma.h.

◆ fdtfc7

__IO uint32_t dma_type::fdtfc7

Definition at line 490 of file at32f435_437_dma.h.

◆ gf1

__IO uint32_t dma_type::gf1

Definition at line 425 of file at32f435_437_dma.h.

◆ gf2

__IO uint32_t dma_type::gf2

Definition at line 429 of file at32f435_437_dma.h.

◆ gf3

__IO uint32_t dma_type::gf3

Definition at line 433 of file at32f435_437_dma.h.

◆ gf4

__IO uint32_t dma_type::gf4

Definition at line 437 of file at32f435_437_dma.h.

◆ gf5

__IO uint32_t dma_type::gf5

Definition at line 441 of file at32f435_437_dma.h.

◆ gf6

__IO uint32_t dma_type::gf6

Definition at line 445 of file at32f435_437_dma.h.

◆ gf7

__IO uint32_t dma_type::gf7

Definition at line 449 of file at32f435_437_dma.h.

◆ gfc1

__IO uint32_t dma_type::gfc1

Definition at line 465 of file at32f435_437_dma.h.

◆ gfc2

__IO uint32_t dma_type::gfc2

Definition at line 469 of file at32f435_437_dma.h.

◆ gfc3

__IO uint32_t dma_type::gfc3

Definition at line 473 of file at32f435_437_dma.h.

◆ gfc4

__IO uint32_t dma_type::gfc4

Definition at line 477 of file at32f435_437_dma.h.

◆ gfc5

__IO uint32_t dma_type::gfc5

Definition at line 481 of file at32f435_437_dma.h.

◆ gfc6

__IO uint32_t dma_type::gfc6

Definition at line 485 of file at32f435_437_dma.h.

◆ gfc7

__IO uint32_t dma_type::gfc7

Definition at line 489 of file at32f435_437_dma.h.

◆ hdtf1

__IO uint32_t dma_type::hdtf1

Definition at line 427 of file at32f435_437_dma.h.

◆ hdtf2

__IO uint32_t dma_type::hdtf2

Definition at line 431 of file at32f435_437_dma.h.

◆ hdtf3

__IO uint32_t dma_type::hdtf3

Definition at line 435 of file at32f435_437_dma.h.

◆ hdtf4

__IO uint32_t dma_type::hdtf4

Definition at line 439 of file at32f435_437_dma.h.

◆ hdtf5

__IO uint32_t dma_type::hdtf5

Definition at line 443 of file at32f435_437_dma.h.

◆ hdtf6

__IO uint32_t dma_type::hdtf6

Definition at line 447 of file at32f435_437_dma.h.

◆ hdtf7

__IO uint32_t dma_type::hdtf7

Definition at line 451 of file at32f435_437_dma.h.

◆ hdtfc1

__IO uint32_t dma_type::hdtfc1

Definition at line 467 of file at32f435_437_dma.h.

◆ hdtfc2

__IO uint32_t dma_type::hdtfc2

Definition at line 471 of file at32f435_437_dma.h.

◆ hdtfc3

__IO uint32_t dma_type::hdtfc3

Definition at line 475 of file at32f435_437_dma.h.

◆ hdtfc4

__IO uint32_t dma_type::hdtfc4

Definition at line 479 of file at32f435_437_dma.h.

◆ hdtfc5

__IO uint32_t dma_type::hdtfc5

Definition at line 483 of file at32f435_437_dma.h.

◆ hdtfc6

__IO uint32_t dma_type::hdtfc6

Definition at line 487 of file at32f435_437_dma.h.

◆ hdtfc7

__IO uint32_t dma_type::hdtfc7

Definition at line 491 of file at32f435_437_dma.h.

◆ muxgclr

__IO uint32_t dma_type::muxgclr

Definition at line 563 of file at32f435_437_dma.h.

Referenced by dmamux_generator_flag_clear().

◆

struct { ... } dma_type::muxgclr_bit

◆ muxgsts

__IO uint32_t dma_type::muxgsts

Definition at line 551 of file at32f435_437_dma.h.

Referenced by dmamux_generator_flag_get().

◆

struct { ... } dma_type::muxgsts_bit

◆ muxsel

__IO uint32_t dma_type::muxsel

Definition at line 507 of file at32f435_437_dma.h.

◆

struct { ... } dma_type::muxsel_bit

Referenced by dma_flexible_config(), and dmamux_enable().

◆ muxsyncclr

__IO uint32_t dma_type::muxsyncclr

Definition at line 538 of file at32f435_437_dma.h.

Referenced by dmamux_sync_flag_clear().

◆

struct { ... } dma_type::muxsyncclr_bit

◆ muxsyncsts

__IO uint32_t dma_type::muxsyncsts

Definition at line 525 of file at32f435_437_dma.h.

Referenced by dmamux_sync_flag_get().

◆

struct { ... } dma_type::muxsyncsts_bit

◆ reserved1

__IO uint32_t dma_type::reserved1

reserved, offset:0x08~0xFC

Definition at line 453 of file at32f435_437_dma.h.

◆ reserved2

__IO uint32_t dma_type::reserved2[11]

reserved, offset:0x104~0x12C

Definition at line 518 of file at32f435_437_dma.h.

◆ sts

__IO uint32_t dma_type::sts

Definition at line 422 of file at32f435_437_dma.h.

◆

struct { ... } dma_type::sts_bit

◆ syncovf

__IO uint32_t dma_type::syncovf

Definition at line 528 of file at32f435_437_dma.h.

◆ syncovfc

__IO uint32_t dma_type::syncovfc

Definition at line 541 of file at32f435_437_dma.h.

◆ tblsel

__IO uint32_t dma_type::tblsel

Definition at line 510 of file at32f435_437_dma.h.

Referenced by dma_flexible_config(), and dmamux_enable().

◆ trgovf

__IO uint32_t dma_type::trgovf

Definition at line 554 of file at32f435_437_dma.h.

◆ trgovfc

__IO uint32_t dma_type::trgovfc

Definition at line 566 of file at32f435_437_dma.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_dma.h


AT32F435/437 Firmwary Library: dma_channel_type Struct Reference

Data Fields
dma_channel_type Struct Reference
AT32F435_437_periph_driver » DMA » DMA_exported_types

type define dma channel register all More...

#include <at32f435_437_dma.h>

Data Fields

union {
__IO uint32_t ctrl
struct {
__IO uint32_t chen: 1
__IO uint32_t fdtien: 1
__IO uint32_t hdtien: 1
__IO uint32_t dterrien: 1
__IO uint32_t dtd: 1
__IO uint32_t lm: 1
__IO uint32_t pincm: 1
__IO uint32_t mincm: 1
__IO uint32_t pwidth: 2
__IO uint32_t mwidth: 2
__IO uint32_t chpl: 2
__IO uint32_t m2m: 1
__IO uint32_t reserved1: 17
} ctrl_bit
};
dma ch ctrl0 register, offset:0x08+20*(x-1) x=1...7 More...
union {
__IO uint32_t dtcnt
struct {
__IO uint32_t cnt: 16
__IO uint32_t reserved1: 16
} dtcnt_bit
};
dma tcnt register, offset:0x0C+20*(x-1) x=1...7 More...
union {
__IO uint32_t paddr
struct {
__IO uint32_t paddr: 32
} paddr_bit
};
dma cpba register, offset:0x10+20*(x-1) x=1...7 More...
union {
__IO uint32_t maddr
struct {
__IO uint32_t maddr: 32
} maddr_bit
};
dma cmba register, offset:0x14+20*(x-1) x=1...7 More...

Detailed Description

type define dma channel register all

Definition at line 575 of file at32f435_437_dma.h.

Field Documentation

◆

union { ... } dma_channel_type::@313

dma ch ctrl0 register, offset:0x08+20*(x-1) x=1...7

◆

union { ... } dma_channel_type::@315

dma tcnt register, offset:0x0C+20*(x-1) x=1...7

◆

union { ... } dma_channel_type::@317

dma cpba register, offset:0x10+20*(x-1) x=1...7

◆

union { ... } dma_channel_type::@319

dma cmba register, offset:0x14+20*(x-1) x=1...7

◆ chen

__IO uint32_t dma_channel_type::chen

Definition at line 585 of file at32f435_437_dma.h.

Referenced by dma_channel_enable(), and dma_reset().

◆ chpl

__IO uint32_t dma_channel_type::chpl

Definition at line 595 of file at32f435_437_dma.h.

Referenced by dma_init().

◆ cnt

__IO uint32_t dma_channel_type::cnt

Definition at line 609 of file at32f435_437_dma.h.

Referenced by dma_init().

◆ ctrl

__IO uint32_t dma_channel_type::ctrl

Definition at line 582 of file at32f435_437_dma.h.

Referenced by dma_init(), dma_interrupt_enable(), and dma_reset().

◆

struct { ... } dma_channel_type::ctrl_bit

Referenced by dma_channel_enable(), dma_init(), and dma_reset().

◆ dtcnt

__IO uint32_t dma_channel_type::dtcnt

Definition at line 606 of file at32f435_437_dma.h.

Referenced by dma_data_number_get(), dma_data_number_set(), and dma_reset().

◆

struct { ... } dma_channel_type::dtcnt_bit

Referenced by dma_init().

◆ dtd

__IO uint32_t dma_channel_type::dtd

Definition at line 589 of file at32f435_437_dma.h.

◆ dterrien

__IO uint32_t dma_channel_type::dterrien

Definition at line 588 of file at32f435_437_dma.h.

◆ fdtien

__IO uint32_t dma_channel_type::fdtien

Definition at line 586 of file at32f435_437_dma.h.

◆ hdtien

__IO uint32_t dma_channel_type::hdtien

Definition at line 587 of file at32f435_437_dma.h.

◆ lm

__IO uint32_t dma_channel_type::lm

Definition at line 590 of file at32f435_437_dma.h.

Referenced by dma_init().

◆ m2m

__IO uint32_t dma_channel_type::m2m

Definition at line 596 of file at32f435_437_dma.h.

◆ maddr

__IO uint32_t dma_channel_type::maddr

Definition at line 631 of file at32f435_437_dma.h.

Referenced by dma_init(), and dma_reset().

◆

struct { ... } dma_channel_type::maddr_bit

◆ mincm

__IO uint32_t dma_channel_type::mincm

Definition at line 592 of file at32f435_437_dma.h.

Referenced by dma_init().

◆ mwidth

__IO uint32_t dma_channel_type::mwidth

Definition at line 594 of file at32f435_437_dma.h.

Referenced by dma_init().

◆ paddr

__IO uint32_t dma_channel_type::paddr

Definition at line 619 of file at32f435_437_dma.h.

Referenced by dma_init(), and dma_reset().

◆

struct { ... } dma_channel_type::paddr_bit

◆ pincm

__IO uint32_t dma_channel_type::pincm

Definition at line 591 of file at32f435_437_dma.h.

Referenced by dma_init().

◆ pwidth

__IO uint32_t dma_channel_type::pwidth

Definition at line 593 of file at32f435_437_dma.h.

Referenced by dma_init().

◆ reserved1

__IO uint32_t dma_channel_type::reserved1

Definition at line 597 of file at32f435_437_dma.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_dma.h


AT32F435/437 Firmwary Library: dmamux_channel_type Struct Reference

Data Fields
dmamux_channel_type Struct Reference
AT32F435_437_periph_driver » DMA » DMA_exported_types

type define dmamux muxsctrl register More...

#include <at32f435_437_dma.h>

Data Fields

union {
__IO uint32_t muxctrl
struct {
__IO uint32_t reqsel: 7
__IO uint32_t reserved1: 1
__IO uint32_t syncovien: 1
__IO uint32_t evtgen: 1
__IO uint32_t reserved2: 6
__IO uint32_t syncen: 1
__IO uint32_t syncpol: 2
__IO uint32_t reqcnt: 5
__IO uint32_t syncsel: 5
__IO uint32_t reserved3: 3
} muxctrl_bit
};
dma muxsctrl register More...

Detailed Description

type define dmamux muxsctrl register

Definition at line 642 of file at32f435_437_dma.h.

Field Documentation

◆

union { ... } dmamux_channel_type::@325

dma muxsctrl register

◆ evtgen

__IO uint32_t dmamux_channel_type::evtgen

Definition at line 655 of file at32f435_437_dma.h.

Referenced by dmamux_sync_config().

◆ muxctrl

__IO uint32_t dmamux_channel_type::muxctrl

Definition at line 649 of file at32f435_437_dma.h.

◆

struct { ... } dmamux_channel_type::muxctrl_bit

Referenced by dma_flexible_config(), dmamux_init(), dmamux_sync_config(), and dmamux_sync_interrupt_enable().

◆ reqcnt

__IO uint32_t dmamux_channel_type::reqcnt

Definition at line 659 of file at32f435_437_dma.h.

Referenced by dmamux_sync_config().

◆ reqsel

__IO uint32_t dmamux_channel_type::reqsel

Definition at line 652 of file at32f435_437_dma.h.

Referenced by dma_flexible_config(), and dmamux_init().

◆ reserved1

__IO uint32_t dmamux_channel_type::reserved1

Definition at line 653 of file at32f435_437_dma.h.

◆ reserved2

__IO uint32_t dmamux_channel_type::reserved2

Definition at line 656 of file at32f435_437_dma.h.

◆ reserved3

__IO uint32_t dmamux_channel_type::reserved3

Definition at line 661 of file at32f435_437_dma.h.

◆ syncen

__IO uint32_t dmamux_channel_type::syncen

Definition at line 657 of file at32f435_437_dma.h.

Referenced by dmamux_sync_config().

◆ syncovien

__IO uint32_t dmamux_channel_type::syncovien

Definition at line 654 of file at32f435_437_dma.h.

Referenced by dmamux_sync_interrupt_enable().

◆ syncpol

__IO uint32_t dmamux_channel_type::syncpol

Definition at line 658 of file at32f435_437_dma.h.

Referenced by dmamux_sync_config().

◆ syncsel

__IO uint32_t dmamux_channel_type::syncsel

Definition at line 660 of file at32f435_437_dma.h.

Referenced by dmamux_sync_config().

The documentation for this struct was generated from the following file:
  • at32f435_437_dma.h


AT32F435/437 Firmwary Library: dmamux_generator_type Struct Reference

Data Fields
dmamux_generator_type Struct Reference
AT32F435_437_periph_driver » DMA » DMA_exported_types

type define dmamux request generator register all More...

#include <at32f435_437_dma.h>

Data Fields

union {
__IO uint32_t gctrl
struct {
__IO uint32_t sigsel: 5
__IO uint32_t reserved1: 3
__IO uint32_t trgovien: 1
__IO uint32_t reserved2: 7
__IO uint32_t gen: 1
__IO uint32_t gpol: 2
__IO uint32_t greqcnt: 5
__IO uint32_t reserved3: 8
} gctrl_bit
};
dmamux request generator register, offset:0x120+4*(x-1) x=1...4 More...

Detailed Description

type define dmamux request generator register all

Definition at line 669 of file at32f435_437_dma.h.

Field Documentation

◆

union { ... } dmamux_generator_type::@328

dmamux request generator register, offset:0x120+4*(x-1) x=1...4

◆ gctrl

__IO uint32_t dmamux_generator_type::gctrl

Definition at line 676 of file at32f435_437_dma.h.

◆

struct { ... } dmamux_generator_type::gctrl_bit

Referenced by dmamux_generator_config(), and dmamux_generator_interrupt_enable().

◆ gen

__IO uint32_t dmamux_generator_type::gen

Definition at line 683 of file at32f435_437_dma.h.

Referenced by dmamux_generator_config().

◆ gpol

__IO uint32_t dmamux_generator_type::gpol

Definition at line 684 of file at32f435_437_dma.h.

Referenced by dmamux_generator_config().

◆ greqcnt

__IO uint32_t dmamux_generator_type::greqcnt

Definition at line 685 of file at32f435_437_dma.h.

Referenced by dmamux_generator_config().

◆ reserved1

__IO uint32_t dmamux_generator_type::reserved1

Definition at line 680 of file at32f435_437_dma.h.

◆ reserved2

__IO uint32_t dmamux_generator_type::reserved2

Definition at line 682 of file at32f435_437_dma.h.

◆ reserved3

__IO uint32_t dmamux_generator_type::reserved3

Definition at line 686 of file at32f435_437_dma.h.

◆ sigsel

__IO uint32_t dmamux_generator_type::sigsel

Definition at line 679 of file at32f435_437_dma.h.

Referenced by dmamux_generator_config().

◆ trgovien

__IO uint32_t dmamux_generator_type::trgovien

Definition at line 681 of file at32f435_437_dma.h.

Referenced by dmamux_generator_interrupt_enable().

The documentation for this struct was generated from the following file:
  • at32f435_437_dma.h


AT32F435/437 Firmwary Library: DMA_exported_functions

Functions
DMA_exported_functions
AT32F435_437_periph_driver » DMA

Functions

void | dma_reset (dma_channel_type *dmax_channely)
reset dmax channely register. More...
void | dma_data_number_set (dma_channel_type *dmax_channely, uint16_t data_number)
set the number of data to be transferred. More...
uint16_t | dma_data_number_get (dma_channel_type *dmax_channely)
get the number of data to be transferred. More...
void | dma_interrupt_enable (dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt. More...
void | dma_channel_enable (dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel. More...
flag_status | dma_flag_get (uint32_t dmax_flag)
dma flag get. More...
void | dma_flag_clear (uint32_t dmax_flag)
dma flag clear. More...
void | dma_default_para_init (dma_init_type *dma_init_struct)
dma init config with its default value. More...
void | dma_init (dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init. More...
void | dma_flexible_config (dma_type *dma_x, dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init. More...
void | dmamux_enable (dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux. More...
void | dmamux_init (dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init. More...
void | dmamux_sync_default_para_init (dmamux_sync_init_type *dmamux_sync_init_struct)
dmamux sync init struct config with its default value. More...
void | dmamux_sync_config (dmamux_channel_type *dmamux_channelx, dmamux_sync_init_type *dmamux_sync_init_struct)
dmamux synchronization config. More...
void | dmamux_generator_default_para_init (dmamux_gen_init_type *dmamux_gen_init_struct)
dmamux request generator init struct config with its default value. More...
void | dmamux_generator_config (dmamux_generator_type *dmamux_gen_x, dmamux_gen_init_type *dmamux_gen_init_struct)
dmamux request generator init. More...
void | dmamux_sync_interrupt_enable (dmamux_channel_type *dmamux_channelx, confirm_state new_state)
enable or disable the dmamux sync interrupts. More...
void | dmamux_generator_interrupt_enable (dmamux_generator_type *dmamux_gen_x, confirm_state new_state)
enable or disable the dmamux request generator interrupts. More...
flag_status | dmamux_sync_flag_get (dma_type *dma_x, uint32_t flag)
dmamux sync flag get. More...
void | dmamux_sync_flag_clear (dma_type *dma_x, uint32_t flag)
dmamux sync flag clear. More...
flag_status | dmamux_generator_flag_get (dma_type *dma_x, uint32_t flag)
dmamux request generator flag get. More...
void | dmamux_generator_flag_clear (dma_type *dma_x, uint32_t flag)
dmamux request generator flag clear. More...

Detailed Description

Function Documentation

◆ dma_channel_enable()

void dma_channel_enable | ( | dma_channel_type * | dmax_channely,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dma channel.

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
new_state (TRUE or FALSE).
Return values
none.

Definition at line 197 of file at32f435_437_dma.c.

Referenced by codec_i2s_init(), codec_i2s_reset(), DMA1_Channel1_IRQHandler(), DMA1_Channel2_IRQHandler(), DMA1_Channel3_IRQHandler(), DMA1_Channel4_IRQHandler(), dma_config(), dma_configuration(), i2c_dma_config(), i2c_dma_tx_rx_irq_handler(), i2s_config(), main(), qspi_dma_set(), sd_dma_config(), sdram_copy_to_sram_dma(), spi_bytes_read(), spi_bytes_write(), and sram_copy_to_sdram_dma().

◆ dma_data_number_get()

uint16_t dma_data_number_get ( dma_channel_type * dmax_channely )

get the number of data to be transferred.

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
Return values
the number value.

Definition at line 133 of file at32f435_437_dma.c.

◆ dma_data_number_set()

void dma_data_number_set | ( | dma_channel_type * | dmax_channely,
 |  | uint16_t | data_number
 | ) |  |

set the number of data to be transferred.

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
data_number the number of data to be transferred (0x0000~0xFFFF).
Return values
none.

Definition at line 108 of file at32f435_437_dma.c.

◆ dma_default_para_init()

void dma_default_para_init ( dma_init_type * dma_init_struct )

dma init config with its default value.

Parameters
dma_init_struct pointer to a dma_init_type structure which will be initialized.
Return values
none.

Definition at line 281 of file at32f435_437_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2s_config(), main(), qspi_dma_set(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ dma_flag_clear()

void dma_flag_clear ( uint32_t dmax_flag )

dma flag clear.

Parameters
dma_flag this parameter can be one of the following values:
  • DMA1_GL1_FLAG - DMA1_FDT1_FLAG - DMA1_HDT1_FLAG - DMA1_DTERR1_FLAG
  • DMA1_GL2_FLAG - DMA1_FDT2_FLAG - DMA1_HDT2_FLAG - DMA1_DTERR2_FLAG
  • DMA1_GL3_FLAG - DMA1_FDT3_FLAG - DMA1_HDT3_FLAG - DMA1_DTERR3_FLAG
  • DMA1_GL4_FLAG - DMA1_FDT4_FLAG - DMA1_HDT4_FLAG - DMA1_DTERR4_FLAG
  • DMA1_GL5_FLAG - DMA1_FDT5_FLAG - DMA1_HDT5_FLAG - DMA1_DTERR5_FLAG
  • DMA1_GL6_FLAG - DMA1_FDT6_FLAG - DMA1_HDT6_FLAG - DMA1_DTERR6_FLAG
  • DMA1_GL7_FLAG - DMA1_FDT7_FLAG - DMA1_HDT7_FLAG - DMA1_DTERR7_FLAG
  • DMA2_GL1_FLAG - DMA2_FDT1_FLAG - DMA2_HDT1_FLAG - DMA2_DTERR1_FLAG
  • DMA2_GL2_FLAG - DMA2_FDT2_FLAG - DMA2_HDT2_FLAG - DMA2_DTERR2_FLAG
  • DMA2_GL3_FLAG - DMA2_FDT3_FLAG - DMA2_HDT3_FLAG - DMA2_DTERR3_FLAG
  • DMA2_GL4_FLAG - DMA2_FDT4_FLAG - DMA2_HDT4_FLAG - DMA2_DTERR4_FLAG
  • DMA2_GL5_FLAG - DMA2_FDT5_FLAG - DMA2_HDT5_FLAG - DMA2_DTERR5_FLAG
  • DMA2_GL6_FLAG - DMA2_FDT6_FLAG - DMA2_HDT6_FLAG - DMA2_DTERR6_FLAG
  • DMA2_GL7_FLAG - DMA2_FDT7_FLAG - DMA2_HDT7_FLAG - DMA2_DTERR7_FLAG
Return values
none.

Definition at line 264 of file at32f435_437_dma.c.

Referenced by DMA1_Channel1_IRQHandler(), DMA1_Channel2_IRQHandler(), DMA1_Channel3_IRQHandler(), DMA1_Channel4_IRQHandler(), DMA2_Channel1_IRQHandler(), DMA2_Channel4_IRQHandler(), i2c_dma_tx_rx_irq_handler(), main(), qspi_data_once_write(), qspi_data_read(), qspi_read_data_using_pem(), spi_bytes_read(), and spi_bytes_write().

◆ dma_flag_get()

flag_status dma_flag_get ( uint32_t dmax_flag )

dma flag get.

Parameters
dma_flag
  • DMA1_GL1_FLAG - DMA1_FDT1_FLAG - DMA1_HDT1_FLAG - DMA1_DTERR1_FLAG
  • DMA1_GL2_FLAG - DMA1_FDT2_FLAG - DMA1_HDT2_FLAG - DMA1_DTERR2_FLAG
  • DMA1_GL3_FLAG - DMA1_FDT3_FLAG - DMA1_HDT3_FLAG - DMA1_DTERR3_FLAG
  • DMA1_GL4_FLAG - DMA1_FDT4_FLAG - DMA1_HDT4_FLAG - DMA1_DTERR4_FLAG
  • DMA1_GL5_FLAG - DMA1_FDT5_FLAG - DMA1_HDT5_FLAG - DMA1_DTERR5_FLAG
  • DMA1_GL6_FLAG - DMA1_FDT6_FLAG - DMA1_HDT6_FLAG - DMA1_DTERR6_FLAG
  • DMA1_GL7_FLAG - DMA1_FDT7_FLAG - DMA1_HDT7_FLAG - DMA1_DTERR7_FLAG
  • DMA2_GL1_FLAG - DMA2_FDT1_FLAG - DMA2_HDT1_FLAG - DMA2_DTERR1_FLAG
  • DMA2_GL2_FLAG - DMA2_FDT2_FLAG - DMA2_HDT2_FLAG - DMA2_DTERR2_FLAG
  • DMA2_GL3_FLAG - DMA2_FDT3_FLAG - DMA2_HDT3_FLAG - DMA2_DTERR3_FLAG
  • DMA2_GL4_FLAG - DMA2_FDT4_FLAG - DMA2_HDT4_FLAG - DMA2_DTERR4_FLAG
  • DMA2_GL5_FLAG - DMA2_FDT5_FLAG - DMA2_HDT5_FLAG - DMA2_DTERR5_FLAG
  • DMA2_GL6_FLAG - DMA2_FDT6_FLAG - DMA2_HDT6_FLAG - DMA2_DTERR6_FLAG
  • DMA2_GL7_FLAG - DMA2_FDT7_FLAG - DMA2_HDT7_FLAG - DMA2_DTERR7_FLAG
Return values
state of dma flag.

Definition at line 221 of file at32f435_437_dma.c.

Referenced by DMA1_Channel1_IRQHandler(), DMA1_Channel2_IRQHandler(), DMA1_Channel3_IRQHandler(), DMA1_Channel4_IRQHandler(), DMA2_Channel1_IRQHandler(), DMA2_Channel4_IRQHandler(), i2c_dma_tx_rx_irq_handler(), main(), qspi_data_once_write(), qspi_data_read(), qspi_read_data_using_pem(), sdram_copy_to_sram_dma(), spi_bytes_read(), spi_bytes_write(), and sram_copy_to_sdram_dma().

◆ dma_flexible_config()

void dma_flexible_config | ( | dma_type * | dma_x,
 |  | dmamux_channel_type * | dmamux_channelx,
 |  | dmamux_requst_id_sel_type | dmamux_req_sel
 | ) |  |

dmamux init.

Parameters
dma_x pointer to a dma_type structure, can be DMA1 or DMA2.
dmamux_channelx this parameter can be one of the following values:
  • DMA1MUX_CHANNEL1
  • DMA1MUX_CHANNEL2
  • DMA1MUX_CHANNEL3
  • DMA1MUX_CHANNEL4
  • DMA1MUX_CHANNEL5
  • DMA1MUX_CHANNEL6
  • DMA1MUX_CHANNEL7
  • DMA2MUX_CHANNEL1
  • DMA2MUX_CHANNEL2
  • DMA2MUX_CHANNEL3
  • DMA2MUX_CHANNEL4
  • DMA2MUX_CHANNEL5
  • DMA2MUX_CHANNEL6
  • DMA2MUX_CHANNEL7
dmamux_req_sel this parameter can be one of the following values:
  • DMAMUX_DMAREQ_ID_REQ_G1 - DMAMUX_DMAREQ_ID_REQ_G2 - DMAMUX_DMAREQ_ID_REQ_G3 - DMAMUX_DMAREQ_ID_REQ_G4
  • DMAMUX_DMAREQ_ID_ADC1 - DMAMUX_DMAREQ_ID_ADC2 - DMAMUX_DMAREQ_ID_ADC3 - DMAMUX_DMAREQ_ID_DAC1
  • DMAMUX_DMAREQ_ID_DAC2 - DMAMUX_DMAREQ_ID_TMR6_OVERFLOW- DMAMUX_DMAREQ_ID_TMR7_OVERFLOW- DMAMUX_DMAREQ_ID_SPI1_RX
  • DMAMUX_DMAREQ_ID_SPI1_TX - DMAMUX_DMAREQ_ID_SPI2_RX - DMAMUX_DMAREQ_ID_SPI2_TX - DMAMUX_DMAREQ_ID_SPI3_RX
  • DMAMUX_DMAREQ_ID_SPI3_TX - DMAMUX_DMAREQ_ID_SPI4_RX - DMAMUX_DMAREQ_ID_SPI4_TX - DMAMUX_DMAREQ_ID_I2S2_EXT_RX
  • DMAMUX_DMAREQ_ID_I2S2_EXT_TX - DMAMUX_DMAREQ_ID_I2S3_EXT_RX - DMAMUX_DMAREQ_ID_I2S3_EXT_TX - DMAMUX_DMAREQ_ID_I2C1_RX
  • DMAMUX_DMAREQ_ID_I2C1_TX - DMAMUX_DMAREQ_ID_I2C2_RX - DMAMUX_DMAREQ_ID_I2C2_TX - DMAMUX_DMAREQ_ID_I2C3_RX
  • DMAMUX_DMAREQ_ID_I2C3_TX - DMAMUX_DMAREQ_ID_USART1_RX - DMAMUX_DMAREQ_ID_USART1_TX - DMAMUX_DMAREQ_ID_USART2_RX
  • DMAMUX_DMAREQ_ID_USART2_TX - DMAMUX_DMAREQ_ID_USART3_RX - DMAMUX_DMAREQ_ID_USART3_TX - DMAMUX_DMAREQ_ID_UART4_RX
  • DMAMUX_DMAREQ_ID_UART4_TX - DMAMUX_DMAREQ_ID_UART5_RX - DMAMUX_DMAREQ_ID_UART5_TX - DMAMUX_DMAREQ_ID_USART6_RX
  • DMAMUX_DMAREQ_ID_USART6_TX - DMAMUX_DMAREQ_ID_UART7_RX - DMAMUX_DMAREQ_ID_UART7_TX - DMAMUX_DMAREQ_ID_UART8_RX
  • DMAMUX_DMAREQ_ID_UART8_TX - DMAMUX_DMAREQ_ID_SDIO1 - DMAMUX_DMAREQ_ID_SDIO2 - DMAMUX_DMAREQ_ID_QSPI1
  • DMAMUX_DMAREQ_ID_QSPI2 - DMAMUX_DMAREQ_ID_TMR1_CH1 - DMAMUX_DMAREQ_ID_TMR1_CH2 - DMAMUX_DMAREQ_ID_TMR1_CH3
  • DMAMUX_DMAREQ_ID_TMR1_CH4 - DMAMUX_DMAREQ_ID_TMR1_OVERFLOW- DMAMUX_DMAREQ_ID_TMR1_TRIG - DMAMUX_DMAREQ_ID_TMR1_COM
  • DMAMUX_DMAREQ_ID_TMR8_CH1 - DMAMUX_DMAREQ_ID_TMR8_CH2 - DMAMUX_DMAREQ_ID_TMR8_CH3 - DMAMUX_DMAREQ_ID_TMR8_CH4
  • DMAMUX_DMAREQ_ID_TMR8_UP - DMAMUX_DMAREQ_ID_TMR8_TRIG - DMAMUX_DMAREQ_ID_TMR8_COM - DMAMUX_DMAREQ_ID_TMR2_CH1
  • DMAMUX_DMAREQ_ID_TMR2_CH2 - DMAMUX_DMAREQ_ID_TMR2_CH3 - DMAMUX_DMAREQ_ID_TMR2_CH4 - DMAMUX_DMAREQ_ID_TMR2_OVERFLOW
  • DMAMUX_DMAREQ_ID_TMR2_TRIG - DMAMUX_DMAREQ_ID_TMR3_CH1 - DMAMUX_DMAREQ_ID_TMR3_CH2 - DMAMUX_DMAREQ_ID_TMR3_CH3
  • DMAMUX_DMAREQ_ID_TMR3_CH4 - DMAMUX_DMAREQ_ID_TMR3_OVERFLOW- DMAMUX_DMAREQ_ID_TMR3_TRIG - DMAMUX_DMAREQ_ID_TMR4_CH1
  • DMAMUX_DMAREQ_ID_TMR4_CH2 - DMAMUX_DMAREQ_ID_TMR4_CH3 - DMAMUX_DMAREQ_ID_TMR4_CH4 - DMAMUX_DMAREQ_ID_TMR4_OVERFLOW
  • DMAMUX_DMAREQ_ID_TMR4_TRIG - DMAMUX_DMAREQ_ID_TMR5_CH1 - DMAMUX_DMAREQ_ID_TMR5_CH2 - DMAMUX_DMAREQ_ID_TMR5_CH3
  • DMAMUX_DMAREQ_ID_TMR5_CH4 - DMAMUX_DMAREQ_ID_TMR5_OVERFLOW- DMAMUX_DMAREQ_ID_TMR5_TRIG - DMAMUX_DMAREQ_ID_TMR20_CH1
  • DMAMUX_DMAREQ_ID_TMR20_CH2 - DMAMUX_DMAREQ_ID_TMR20_CH3 - DMAMUX_DMAREQ_ID_TMR20_CH4 - DMAMUX_DMAREQ_ID_TMR20_OVERFLOW
  • DMAMUX_DMAREQ_ID_TMR20_TRIG - DMAMUX_DMAREQ_ID_TMR20_HALL - DMAMUX_DMAREQ_ID_DVP
Return values
none.

Definition at line 379 of file at32f435_437_dma.c.

◆ dma_init()

void dma_init | ( | dma_channel_type * | dmax_channely,
 |  | dma_init_type * | dma_init_struct
 | ) |  |

dma init.

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
dma_init_struct pointer to a dma_init_type structure.
Return values
none.

Definition at line 316 of file at32f435_437_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_dma_config(), i2c_lowlevel_init(), i2s_config(), main(), qspi_dma_set(), sd_dma_config(), sdram_copy_to_sram_dma(), spi_bytes_read(), spi_bytes_write(), spi_config(), and sram_copy_to_sdram_dma().

◆ dma_interrupt_enable()

void dma_interrupt_enable | ( | dma_channel_type * | dmax_channely,
 |  | uint32_t | dma_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dma interrupt.

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
dma_int this parameter can be any combination of the following values:
  • DMA_FDT_INT
  • DMA_HDT_INT
  • DMA_DTERR_INT
new_state (TRUE or FALSE)
Return values
none.

Definition at line 164 of file at32f435_437_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_dma_config(), i2c_dma_tx_rx_irq_handler(), and main().

◆ dma_reset()

void dma_reset ( dma_channel_type * dmax_channely )

reset dmax channely register.

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
Return values
none.

Definition at line 64 of file at32f435_437_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_lowlevel_init(), i2s_config(), main(), qspi_dma_set(), sd_dma_config(), sdram_copy_to_sram_dma(), spi_bytes_read(), spi_bytes_write(), spi_config(), and sram_copy_to_sdram_dma().

◆ dmamux_enable()

void dmamux_enable | ( | dma_type * | dma_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the dmamux.

Parameters
dma_x | pointer to a dma_type structure, can be DMA1 or DMA2.
new_state | (TRUE or FALSE) .
Return values
none.

Definition at line 391 of file at32f435_437_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_lowlevel_init(), i2s_config(), main(), qspi_dma_set(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ dmamux_generator_config()

void dmamux_generator_config | ( | dmamux_generator_type * | dmamux_gen_x,
 |  | dmamux_gen_init_type * | dmamux_gen_init_struct
 | ) |  |

dmamux request generator init.

Parameters
dmamux_gen_x : this parameter can be one of the following values:
  • DMA1MUX_GENERATOR1
  • DMA1MUX_GENERATOR2
  • DMA1MUX_GENERATOR3
  • DMA1MUX_GENERATOR4
  • DMA2MUX_GENERATOR1
  • DMA2MUX_GENERATOR2
  • DMA2MUX_GENERATOR3
  • DMA2MUX_GENERATOR4
dmamux_gen_init_struct pointer to a dmamux_gen_init_type structure which will be initialized.
Return values
none.

Definition at line 519 of file at32f435_437_dma.c.

Referenced by main().

◆ dmamux_generator_default_para_init()

void dmamux_generator_default_para_init ( dmamux_gen_init_type * dmamux_gen_init_struct )

dmamux request generator init struct config with its default value.

Parameters
dmamux_gen_init_struct pointer to a dmamux_gen_init_type structure which will be initialized.
Return values
none.

Definition at line 496 of file at32f435_437_dma.c.

Referenced by main().

◆ dmamux_generator_flag_clear()

void dmamux_generator_flag_clear | ( | dma_type * | dma_x,
 |  | uint32_t | flag
 | ) |  |

dmamux request generator flag clear.

Parameters
dma_x : pointer to a dma_type structure, can be DMA1 or DMA2.
flag this parameter can be any combination of the following values:
  • DMAMUX_GEN_TRIG_OV1_FLAG
  • DMAMUX_GEN_TRIG_OV2_FLAG
  • DMAMUX_GEN_TRIG_OV3_FLAG
  • DMAMUX_GEN_TRIG_OV4_FLAG
Return values
none.

Definition at line 666 of file at32f435_437_dma.c.

◆ dmamux_generator_flag_get()

flag_status dmamux_generator_flag_get | ( | dma_type * | dma_x,
 |  | uint32_t | flag
 | ) |  |

dmamux request generator flag get.

Parameters
dma_x : pointer to a dma_type structure, can be DMA1 or DMA2.
flag this parameter can be any combination of the following values:
  • DMAMUX_GEN_TRIG_OV1_FLAG
  • DMAMUX_GEN_TRIG_OV2_FLAG
  • DMAMUX_GEN_TRIG_OV3_FLAG
  • DMAMUX_GEN_TRIG_OV4_FLAG
Return values
state of dmamux sync flag.

Definition at line 643 of file at32f435_437_dma.c.

◆ dmamux_generator_interrupt_enable()

void dmamux_generator_interrupt_enable | ( | dmamux_generator_type * | dmamux_gen_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the dmamux request generator interrupts.

Parameters
dmamux_gen_x : pointer to a dmamux_generator_type structure. this parameter can be one of the following values:
  • DMA1MUX_GENERATOR1
  • DMA1MUX_GENERATOR2
  • DMA1MUX_GENERATOR3
  • DMA1MUX_GENERATOR4
  • DMA2MUX_GENERATOR1
  • DMA2MUX_GENERATOR2
  • DMA2MUX_GENERATOR3
  • DMA2MUX_GENERATOR4
new_state (TRUE or FALSE).
Return values
none.

Definition at line 575 of file at32f435_437_dma.c.

◆ dmamux_init()

void dmamux_init | ( | dmamux_channel_type * | dmamux_channelx,
 |  | dmamux_requst_id_sel_type | dmamux_req_sel
 | ) |  |

dmamux init.

Parameters
dmamux_channelx this parameter can be one of the following values:
  • DMA1MUX_CHANNEL1
  • DMA1MUX_CHANNEL2
  • DMA1MUX_CHANNEL3
  • DMA1MUX_CHANNEL4
  • DMA1MUX_CHANNEL5
  • DMA1MUX_CHANNEL6
  • DMA1MUX_CHANNEL7
  • DMA2MUX_CHANNEL1
  • DMA2MUX_CHANNEL2
  • DMA2MUX_CHANNEL3
  • DMA2MUX_CHANNEL4
  • DMA2MUX_CHANNEL5
  • DMA2MUX_CHANNEL6
  • DMA2MUX_CHANNEL7
dmamux_req_sel this parameter can be one of the following values:
  • DMAMUX_DMAREQ_ID_REQ_G1 - DMAMUX_DMAREQ_ID_REQ_G2 - DMAMUX_DMAREQ_ID_REQ_G3 - DMAMUX_DMAREQ_ID_REQ_G4
  • DMAMUX_DMAREQ_ID_ADC1 - DMAMUX_DMAREQ_ID_ADC2 - DMAMUX_DMAREQ_ID_ADC3 - DMAMUX_DMAREQ_ID_DAC1
  • DMAMUX_DMAREQ_ID_DAC2 - DMAMUX_DMAREQ_ID_TMR6_OVERFLOW- DMAMUX_DMAREQ_ID_TMR7_OVERFLOW- DMAMUX_DMAREQ_ID_SPI1_RX
  • DMAMUX_DMAREQ_ID_SPI1_TX - DMAMUX_DMAREQ_ID_SPI2_RX - DMAMUX_DMAREQ_ID_SPI2_TX - DMAMUX_DMAREQ_ID_SPI3_RX
  • DMAMUX_DMAREQ_ID_SPI3_TX - DMAMUX_DMAREQ_ID_SPI4_RX - DMAMUX_DMAREQ_ID_SPI4_TX - DMAMUX_DMAREQ_ID_I2S2_EXT_RX
  • DMAMUX_DMAREQ_ID_I2S2_EXT_TX - DMAMUX_DMAREQ_ID_I2S3_EXT_RX - DMAMUX_DMAREQ_ID_I2S3_EXT_TX - DMAMUX_DMAREQ_ID_I2C1_RX
  • DMAMUX_DMAREQ_ID_I2C1_TX - DMAMUX_DMAREQ_ID_I2C2_RX - DMAMUX_DMAREQ_ID_I2C2_TX - DMAMUX_DMAREQ_ID_I2C3_RX
  • DMAMUX_DMAREQ_ID_I2C3_TX - DMAMUX_DMAREQ_ID_USART1_RX - DMAMUX_DMAREQ_ID_USART1_TX - DMAMUX_DMAREQ_ID_USART2_RX
  • DMAMUX_DMAREQ_ID_USART2_TX - DMAMUX_DMAREQ_ID_USART3_RX - DMAMUX_DMAREQ_ID_USART3_TX - DMAMUX_DMAREQ_ID_UART4_RX
  • DMAMUX_DMAREQ_ID_UART4_TX - DMAMUX_DMAREQ_ID_UART5_RX - DMAMUX_DMAREQ_ID_UART5_TX - DMAMUX_DMAREQ_ID_USART6_RX
  • DMAMUX_DMAREQ_ID_USART6_TX - DMAMUX_DMAREQ_ID_UART7_RX - DMAMUX_DMAREQ_ID_UART7_TX - DMAMUX_DMAREQ_ID_UART8_RX
  • DMAMUX_DMAREQ_ID_UART8_TX - DMAMUX_DMAREQ_ID_SDIO1 - DMAMUX_DMAREQ_ID_SDIO2 - DMAMUX_DMAREQ_ID_QSPI1
  • DMAMUX_DMAREQ_ID_QSPI2 - DMAMUX_DMAREQ_ID_TMR1_CH1 - DMAMUX_DMAREQ_ID_TMR1_CH2 - DMAMUX_DMAREQ_ID_TMR1_CH3
  • DMAMUX_DMAREQ_ID_TMR1_CH4 - DMAMUX_DMAREQ_ID_TMR1_OVERFLOW- DMAMUX_DMAREQ_ID_TMR1_TRIG - DMAMUX_DMAREQ_ID_TMR1_COM
  • DMAMUX_DMAREQ_ID_TMR8_CH1 - DMAMUX_DMAREQ_ID_TMR8_CH2 - DMAMUX_DMAREQ_ID_TMR8_CH3 - DMAMUX_DMAREQ_ID_TMR8_CH4
  • DMAMUX_DMAREQ_ID_TMR8_UP - DMAMUX_DMAREQ_ID_TMR8_TRIG - DMAMUX_DMAREQ_ID_TMR8_COM - DMAMUX_DMAREQ_ID_TMR2_CH1
  • DMAMUX_DMAREQ_ID_TMR2_CH2 - DMAMUX_DMAREQ_ID_TMR2_CH3 - DMAMUX_DMAREQ_ID_TMR2_CH4 - DMAMUX_DMAREQ_ID_TMR2_OVERFLOW
  • DMAMUX_DMAREQ_ID_TMR2_TRIG - DMAMUX_DMAREQ_ID_TMR3_CH1 - DMAMUX_DMAREQ_ID_TMR3_CH2 - DMAMUX_DMAREQ_ID_TMR3_CH3
  • DMAMUX_DMAREQ_ID_TMR3_CH4 - DMAMUX_DMAREQ_ID_TMR3_OVERFLOW- DMAMUX_DMAREQ_ID_TMR3_TRIG - DMAMUX_DMAREQ_ID_TMR4_CH1
  • DMAMUX_DMAREQ_ID_TMR4_CH2 - DMAMUX_DMAREQ_ID_TMR4_CH3 - DMAMUX_DMAREQ_ID_TMR4_CH4 - DMAMUX_DMAREQ_ID_TMR4_OVERFLOW
  • DMAMUX_DMAREQ_ID_TMR4_TRIG - DMAMUX_DMAREQ_ID_TMR5_CH1 - DMAMUX_DMAREQ_ID_TMR5_CH2 - DMAMUX_DMAREQ_ID_TMR5_CH3
  • DMAMUX_DMAREQ_ID_TMR5_CH4 - DMAMUX_DMAREQ_ID_TMR5_OVERFLOW- DMAMUX_DMAREQ_ID_TMR5_TRIG - DMAMUX_DMAREQ_ID_TMR20_CH1
  • DMAMUX_DMAREQ_ID_TMR20_CH2 - DMAMUX_DMAREQ_ID_TMR20_CH3 - DMAMUX_DMAREQ_ID_TMR20_CH4 - DMAMUX_DMAREQ_ID_TMR20_OVERFLOW
  • DMAMUX_DMAREQ_ID_TMR20_TRIG - DMAMUX_DMAREQ_ID_TMR20_HALL - DMAMUX_DMAREQ_ID_DVP
Return values
none.

Definition at line 442 of file at32f435_437_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_lowlevel_init(), i2s_config(), main(), qspi_dma_set(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ dmamux_sync_config()

void dmamux_sync_config | ( | dmamux_channel_type * | dmamux_channelx,
 |  | dmamux_sync_init_type * | dmamux_sync_init_struct
 | ) |  |

dmamux synchronization config.

Parameters
dmamux_channelx this parameter can be one of the following values:
  • DMA1MUX_CHANNEL1
  • DMA1MUX_CHANNEL2
  • DMA1MUX_CHANNEL3
  • DMA1MUX_CHANNEL4
  • DMA1MUX_CHANNEL5
  • DMA1MUX_CHANNEL6
  • DMA1MUX_CHANNEL7
  • DMA2MUX_CHANNEL1
  • DMA2MUX_CHANNEL2
  • DMA2MUX_CHANNEL3
  • DMA2MUX_CHANNEL4
  • DMA2MUX_CHANNEL5
  • DMA2MUX_CHANNEL6
  • DMA2MUX_CHANNEL7
dmamux_sync_init_struct ointer to a dmamux_sync_init_type structure.
Return values
none.

Definition at line 482 of file at32f435_437_dma.c.

Referenced by main().

◆ dmamux_sync_default_para_init()

void dmamux_sync_default_para_init ( dmamux_sync_init_type * dmamux_sync_init_struct )

dmamux sync init struct config with its default value.

Parameters
dmamux_sync_init_struct pointer to a dmamux_sync_init_type structure which will be initialized.
Return values
none.

Definition at line 452 of file at32f435_437_dma.c.

Referenced by main().

◆ dmamux_sync_flag_clear()

void dmamux_sync_flag_clear | ( | dma_type * | dma_x,
 |  | uint32_t | flag
 | ) |  |

dmamux sync flag clear.

Parameters
dma_x : pointer to a dma_type structure, can be DMA1 or DMA2.
flag this parameter can be any combination of the following values:
  • DMAMUX_SYNC_OV1_FLAG
  • DMAMUX_SYNC_OV2_FLAG
  • DMAMUX_SYNC_OV3_FLAG
  • DMAMUX_SYNC_OV4_FLAG
  • DMAMUX_SYNC_OV5_FLAG
  • DMAMUX_SYNC_OV6_FLAG
  • DMAMUX_SYNC_OV7_FLAG
Return values
none.

Definition at line 627 of file at32f435_437_dma.c.

◆ dmamux_sync_flag_get()

flag_status dmamux_sync_flag_get | ( | dma_type * | dma_x,
 |  | uint32_t | flag
 | ) |  |

dmamux sync flag get.

Parameters
dma_x : pointer to a dma_type structure, can be DMA1 or DMA2.
flag this parameter can be any combination of the following values:
  • DMAMUX_SYNC_OV1_FLAG
  • DMAMUX_SYNC_OV2_FLAG
  • DMAMUX_SYNC_OV3_FLAG
  • DMAMUX_SYNC_OV4_FLAG
  • DMAMUX_SYNC_OV5_FLAG
  • DMAMUX_SYNC_OV6_FLAG
  • DMAMUX_SYNC_OV7_FLAG
Return values
state of dmamux sync flag.

Definition at line 601 of file at32f435_437_dma.c.

◆ dmamux_sync_interrupt_enable()

void dmamux_sync_interrupt_enable | ( | dmamux_channel_type * | dmamux_channelx,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the dmamux sync interrupts.

Parameters
dmamux_channelx this parameter can be one of the following values:
  • DMA1MUX_CHANNEL1
  • DMA1MUX_CHANNEL2
  • DMA1MUX_CHANNEL3
  • DMA1MUX_CHANNEL4
  • DMA1MUX_CHANNEL5
  • DMA1MUX_CHANNEL6
  • DMA1MUX_CHANNEL7
  • DMA2MUX_CHANNEL1
  • DMA2MUX_CHANNEL2
  • DMA2MUX_CHANNEL3
  • DMA2MUX_CHANNEL4
  • DMA2MUX_CHANNEL5
  • DMA2MUX_CHANNEL6
  • DMA2MUX_CHANNEL7
new_state (TRUE or FALSE).
Return values
none.

Definition at line 548 of file at32f435_437_dma.c.


AT32F435/437 Firmwary Library: DMA_private_functions

Functions
DMA_private_functions
AT32F435_437_periph_driver » DMA

Functions

void | dma_reset (dma_channel_type *dmax_channely)
reset dmax channely register. More...
void | dma_data_number_set (dma_channel_type *dmax_channely, uint16_t data_number)
set the number of data to be transferred. More...
uint16_t | dma_data_number_get (dma_channel_type *dmax_channely)
get the number of data to be transferred. More...
void | dma_interrupt_enable (dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt. More...
void | dma_channel_enable (dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel. More...
flag_status | dma_flag_get (uint32_t dmax_flag)
dma flag get. More...
void | dma_flag_clear (uint32_t dmax_flag)
dma flag clear. More...
void | dma_default_para_init (dma_init_type *dma_init_struct)
dma init config with its default value. More...
void | dma_init (dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init. More...
void | dma_flexible_config (dma_type *dma_x, dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init. More...
void | dmamux_enable (dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux. More...
void | dmamux_init (dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init. More...
void | dmamux_sync_default_para_init (dmamux_sync_init_type *dmamux_sync_init_struct)
dmamux sync init struct config with its default value. More...
void | dmamux_sync_config (dmamux_channel_type *dmamux_channelx, dmamux_sync_init_type *dmamux_sync_init_struct)
dmamux synchronization config. More...
void | dmamux_generator_default_para_init (dmamux_gen_init_type *dmamux_gen_init_struct)
dmamux request generator init struct config with its default value. More...
void | dmamux_generator_config (dmamux_generator_type *dmamux_gen_x, dmamux_gen_init_type *dmamux_gen_init_struct)
dmamux request generator init. More...
void | dmamux_sync_interrupt_enable (dmamux_channel_type *dmamux_channelx, confirm_state new_state)
enable or disable the dmamux sync interrupts. More...
void | dmamux_generator_interrupt_enable (dmamux_generator_type *dmamux_gen_x, confirm_state new_state)
enable or disable the dmamux request generator interrupts. More...
flag_status | dmamux_sync_flag_get (dma_type *dma_x, uint32_t flag)
dmamux sync flag get. More...
void | dmamux_sync_flag_clear (dma_type *dma_x, uint32_t flag)
dmamux sync flag clear. More...
flag_status | dmamux_generator_flag_get (dma_type *dma_x, uint32_t flag)
dmamux request generator flag get. More...
void | dmamux_generator_flag_clear (dma_type *dma_x, uint32_t flag)
dmamux request generator flag clear. More...

Detailed Description

Function Documentation

◆ dma_channel_enable()

void dma_channel_enable | ( | dma_channel_type * | dmax_channely,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dma channel.

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
new_state (TRUE or FALSE).
Return values
none.

Definition at line 197 of file at32f435_437_dma.c.

Referenced by codec_i2s_init(), codec_i2s_reset(), DMA1_Channel1_IRQHandler(), DMA1_Channel2_IRQHandler(), DMA1_Channel3_IRQHandler(), DMA1_Channel4_IRQHandler(), dma_config(), dma_configuration(), i2c_dma_config(), i2c_dma_tx_rx_irq_handler(), i2s_config(), main(), qspi_dma_set(), sd_dma_config(), sdram_copy_to_sram_dma(), spi_bytes_read(), spi_bytes_write(), and sram_copy_to_sdram_dma().

◆ dma_data_number_get()

uint16_t dma_data_number_get ( dma_channel_type * dmax_channely )

get the number of data to be transferred.

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
Return values
the number value.

Definition at line 133 of file at32f435_437_dma.c.

◆ dma_data_number_set()

void dma_data_number_set | ( | dma_channel_type * | dmax_channely,
 |  | uint16_t | data_number
 | ) |  |

set the number of data to be transferred.

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
data_number the number of data to be transferred (0x0000~0xFFFF).
Return values
none.

Definition at line 108 of file at32f435_437_dma.c.

◆ dma_default_para_init()

void dma_default_para_init ( dma_init_type * dma_init_struct )

dma init config with its default value.

Parameters
dma_init_struct pointer to a dma_init_type structure which will be initialized.
Return values
none.

Definition at line 281 of file at32f435_437_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2s_config(), main(), qspi_dma_set(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ dma_flag_clear()

void dma_flag_clear ( uint32_t dmax_flag )

dma flag clear.

Parameters
dma_flag this parameter can be one of the following values:
  • DMA1_GL1_FLAG - DMA1_FDT1_FLAG - DMA1_HDT1_FLAG - DMA1_DTERR1_FLAG
  • DMA1_GL2_FLAG - DMA1_FDT2_FLAG - DMA1_HDT2_FLAG - DMA1_DTERR2_FLAG
  • DMA1_GL3_FLAG - DMA1_FDT3_FLAG - DMA1_HDT3_FLAG - DMA1_DTERR3_FLAG
  • DMA1_GL4_FLAG - DMA1_FDT4_FLAG - DMA1_HDT4_FLAG - DMA1_DTERR4_FLAG
  • DMA1_GL5_FLAG - DMA1_FDT5_FLAG - DMA1_HDT5_FLAG - DMA1_DTERR5_FLAG
  • DMA1_GL6_FLAG - DMA1_FDT6_FLAG - DMA1_HDT6_FLAG - DMA1_DTERR6_FLAG
  • DMA1_GL7_FLAG - DMA1_FDT7_FLAG - DMA1_HDT7_FLAG - DMA1_DTERR7_FLAG
  • DMA2_GL1_FLAG - DMA2_FDT1_FLAG - DMA2_HDT1_FLAG - DMA2_DTERR1_FLAG
  • DMA2_GL2_FLAG - DMA2_FDT2_FLAG - DMA2_HDT2_FLAG - DMA2_DTERR2_FLAG
  • DMA2_GL3_FLAG - DMA2_FDT3_FLAG - DMA2_HDT3_FLAG - DMA2_DTERR3_FLAG
  • DMA2_GL4_FLAG - DMA2_FDT4_FLAG - DMA2_HDT4_FLAG - DMA2_DTERR4_FLAG
  • DMA2_GL5_FLAG - DMA2_FDT5_FLAG - DMA2_HDT5_FLAG - DMA2_DTERR5_FLAG
  • DMA2_GL6_FLAG - DMA2_FDT6_FLAG - DMA2_HDT6_FLAG - DMA2_DTERR6_FLAG
  • DMA2_GL7_FLAG - DMA2_FDT7_FLAG - DMA2_HDT7_FLAG - DMA2_DTERR7_FLAG
Return values
none.

Definition at line 264 of file at32f435_437_dma.c.

Referenced by DMA1_Channel1_IRQHandler(), DMA1_Channel2_IRQHandler(), DMA1_Channel3_IRQHandler(), DMA1_Channel4_IRQHandler(), DMA2_Channel1_IRQHandler(), DMA2_Channel4_IRQHandler(), i2c_dma_tx_rx_irq_handler(), main(), qspi_data_once_write(), qspi_data_read(), qspi_read_data_using_pem(), spi_bytes_read(), and spi_bytes_write().

◆ dma_flag_get()

flag_status dma_flag_get ( uint32_t dmax_flag )

dma flag get.

Parameters
dma_flag
  • DMA1_GL1_FLAG - DMA1_FDT1_FLAG - DMA1_HDT1_FLAG - DMA1_DTERR1_FLAG
  • DMA1_GL2_FLAG - DMA1_FDT2_FLAG - DMA1_HDT2_FLAG - DMA1_DTERR2_FLAG
  • DMA1_GL3_FLAG - DMA1_FDT3_FLAG - DMA1_HDT3_FLAG - DMA1_DTERR3_FLAG
  • DMA1_GL4_FLAG - DMA1_FDT4_FLAG - DMA1_HDT4_FLAG - DMA1_DTERR4_FLAG
  • DMA1_GL5_FLAG - DMA1_FDT5_FLAG - DMA1_HDT5_FLAG - DMA1_DTERR5_FLAG
  • DMA1_GL6_FLAG - DMA1_FDT6_FLAG - DMA1_HDT6_FLAG - DMA1_DTERR6_FLAG
  • DMA1_GL7_FLAG - DMA1_FDT7_FLAG - DMA1_HDT7_FLAG - DMA1_DTERR7_FLAG
  • DMA2_GL1_FLAG - DMA2_FDT1_FLAG - DMA2_HDT1_FLAG - DMA2_DTERR1_FLAG
  • DMA2_GL2_FLAG - DMA2_FDT2_FLAG - DMA2_HDT2_FLAG - DMA2_DTERR2_FLAG
  • DMA2_GL3_FLAG - DMA2_FDT3_FLAG - DMA2_HDT3_FLAG - DMA2_DTERR3_FLAG
  • DMA2_GL4_FLAG - DMA2_FDT4_FLAG - DMA2_HDT4_FLAG - DMA2_DTERR4_FLAG
  • DMA2_GL5_FLAG - DMA2_FDT5_FLAG - DMA2_HDT5_FLAG - DMA2_DTERR5_FLAG
  • DMA2_GL6_FLAG - DMA2_FDT6_FLAG - DMA2_HDT6_FLAG - DMA2_DTERR6_FLAG
  • DMA2_GL7_FLAG - DMA2_FDT7_FLAG - DMA2_HDT7_FLAG - DMA2_DTERR7_FLAG
Return values
state of dma flag.

Definition at line 221 of file at32f435_437_dma.c.

Referenced by DMA1_Channel1_IRQHandler(), DMA1_Channel2_IRQHandler(), DMA1_Channel3_IRQHandler(), DMA1_Channel4_IRQHandler(), DMA2_Channel1_IRQHandler(), DMA2_Channel4_IRQHandler(), i2c_dma_tx_rx_irq_handler(), main(), qspi_data_once_write(), qspi_data_read(), qspi_read_data_using_pem(), sdram_copy_to_sram_dma(), spi_bytes_read(), spi_bytes_write(), and sram_copy_to_sdram_dma().

◆ dma_flexible_config()

void dma_flexible_config | ( | dma_type * | dma_x,
 |  | dmamux_channel_type * | dmamux_channelx,
 |  | dmamux_requst_id_sel_type | dmamux_req_sel
 | ) |  |

dmamux init.

Parameters
dma_x pointer to a dma_type structure, can be DMA1 or DMA2.
dmamux_channelx this parameter can be one of the following values:
  • DMA1MUX_CHANNEL1
  • DMA1MUX_CHANNEL2
  • DMA1MUX_CHANNEL3
  • DMA1MUX_CHANNEL4
  • DMA1MUX_CHANNEL5
  • DMA1MUX_CHANNEL6
  • DMA1MUX_CHANNEL7
  • DMA2MUX_CHANNEL1
  • DMA2MUX_CHANNEL2
  • DMA2MUX_CHANNEL3
  • DMA2MUX_CHANNEL4
  • DMA2MUX_CHANNEL5
  • DMA2MUX_CHANNEL6
  • DMA2MUX_CHANNEL7
dmamux_req_sel this parameter can be one of the following values:
  • DMAMUX_DMAREQ_ID_REQ_G1 - DMAMUX_DMAREQ_ID_REQ_G2 - DMAMUX_DMAREQ_ID_REQ_G3 - DMAMUX_DMAREQ_ID_REQ_G4
  • DMAMUX_DMAREQ_ID_ADC1 - DMAMUX_DMAREQ_ID_ADC2 - DMAMUX_DMAREQ_ID_ADC3 - DMAMUX_DMAREQ_ID_DAC1
  • DMAMUX_DMAREQ_ID_DAC2 - DMAMUX_DMAREQ_ID_TMR6_OVERFLOW- DMAMUX_DMAREQ_ID_TMR7_OVERFLOW- DMAMUX_DMAREQ_ID_SPI1_RX
  • DMAMUX_DMAREQ_ID_SPI1_TX - DMAMUX_DMAREQ_ID_SPI2_RX - DMAMUX_DMAREQ_ID_SPI2_TX - DMAMUX_DMAREQ_ID_SPI3_RX
  • DMAMUX_DMAREQ_ID_SPI3_TX - DMAMUX_DMAREQ_ID_SPI4_RX - DMAMUX_DMAREQ_ID_SPI4_TX - DMAMUX_DMAREQ_ID_I2S2_EXT_RX
  • DMAMUX_DMAREQ_ID_I2S2_EXT_TX - DMAMUX_DMAREQ_ID_I2S3_EXT_RX - DMAMUX_DMAREQ_ID_I2S3_EXT_TX - DMAMUX_DMAREQ_ID_I2C1_RX
  • DMAMUX_DMAREQ_ID_I2C1_TX - DMAMUX_DMAREQ_ID_I2C2_RX - DMAMUX_DMAREQ_ID_I2C2_TX - DMAMUX_DMAREQ_ID_I2C3_RX
  • DMAMUX_DMAREQ_ID_I2C3_TX - DMAMUX_DMAREQ_ID_USART1_RX - DMAMUX_DMAREQ_ID_USART1_TX - DMAMUX_DMAREQ_ID_USART2_RX
  • DMAMUX_DMAREQ_ID_USART2_TX - DMAMUX_DMAREQ_ID_USART3_RX - DMAMUX_DMAREQ_ID_USART3_TX - DMAMUX_DMAREQ_ID_UART4_RX
  • DMAMUX_DMAREQ_ID_UART4_TX - DMAMUX_DMAREQ_ID_UART5_RX - DMAMUX_DMAREQ_ID_UART5_TX - DMAMUX_DMAREQ_ID_USART6_RX
  • DMAMUX_DMAREQ_ID_USART6_TX - DMAMUX_DMAREQ_ID_UART7_RX - DMAMUX_DMAREQ_ID_UART7_TX - DMAMUX_DMAREQ_ID_UART8_RX
  • DMAMUX_DMAREQ_ID_UART8_TX - DMAMUX_DMAREQ_ID_SDIO1 - DMAMUX_DMAREQ_ID_SDIO2 - DMAMUX_DMAREQ_ID_QSPI1
  • DMAMUX_DMAREQ_ID_QSPI2 - DMAMUX_DMAREQ_ID_TMR1_CH1 - DMAMUX_DMAREQ_ID_TMR1_CH2 - DMAMUX_DMAREQ_ID_TMR1_CH3
  • DMAMUX_DMAREQ_ID_TMR1_CH4 - DMAMUX_DMAREQ_ID_TMR1_OVERFLOW- DMAMUX_DMAREQ_ID_TMR1_TRIG - DMAMUX_DMAREQ_ID_TMR1_COM
  • DMAMUX_DMAREQ_ID_TMR8_CH1 - DMAMUX_DMAREQ_ID_TMR8_CH2 - DMAMUX_DMAREQ_ID_TMR8_CH3 - DMAMUX_DMAREQ_ID_TMR8_CH4
  • DMAMUX_DMAREQ_ID_TMR8_UP - DMAMUX_DMAREQ_ID_TMR8_TRIG - DMAMUX_DMAREQ_ID_TMR8_COM - DMAMUX_DMAREQ_ID_TMR2_CH1
  • DMAMUX_DMAREQ_ID_TMR2_CH2 - DMAMUX_DMAREQ_ID_TMR2_CH3 - DMAMUX_DMAREQ_ID_TMR2_CH4 - DMAMUX_DMAREQ_ID_TMR2_OVERFLOW
  • DMAMUX_DMAREQ_ID_TMR2_TRIG - DMAMUX_DMAREQ_ID_TMR3_CH1 - DMAMUX_DMAREQ_ID_TMR3_CH2 - DMAMUX_DMAREQ_ID_TMR3_CH3
  • DMAMUX_DMAREQ_ID_TMR3_CH4 - DMAMUX_DMAREQ_ID_TMR3_OVERFLOW- DMAMUX_DMAREQ_ID_TMR3_TRIG - DMAMUX_DMAREQ_ID_TMR4_CH1
  • DMAMUX_DMAREQ_ID_TMR4_CH2 - DMAMUX_DMAREQ_ID_TMR4_CH3 - DMAMUX_DMAREQ_ID_TMR4_CH4 - DMAMUX_DMAREQ_ID_TMR4_OVERFLOW
  • DMAMUX_DMAREQ_ID_TMR4_TRIG - DMAMUX_DMAREQ_ID_TMR5_CH1 - DMAMUX_DMAREQ_ID_TMR5_CH2 - DMAMUX_DMAREQ_ID_TMR5_CH3
  • DMAMUX_DMAREQ_ID_TMR5_CH4 - DMAMUX_DMAREQ_ID_TMR5_OVERFLOW- DMAMUX_DMAREQ_ID_TMR5_TRIG - DMAMUX_DMAREQ_ID_TMR20_CH1
  • DMAMUX_DMAREQ_ID_TMR20_CH2 - DMAMUX_DMAREQ_ID_TMR20_CH3 - DMAMUX_DMAREQ_ID_TMR20_CH4 - DMAMUX_DMAREQ_ID_TMR20_OVERFLOW
  • DMAMUX_DMAREQ_ID_TMR20_TRIG - DMAMUX_DMAREQ_ID_TMR20_HALL - DMAMUX_DMAREQ_ID_DVP
Return values
none.

Definition at line 379 of file at32f435_437_dma.c.

◆ dma_init()

void dma_init | ( | dma_channel_type * | dmax_channely,
 |  | dma_init_type * | dma_init_struct
 | ) |  |

dma init.

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
dma_init_struct pointer to a dma_init_type structure.
Return values
none.

Definition at line 316 of file at32f435_437_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_dma_config(), i2c_lowlevel_init(), i2s_config(), main(), qspi_dma_set(), sd_dma_config(), sdram_copy_to_sram_dma(), spi_bytes_read(), spi_bytes_write(), spi_config(), and sram_copy_to_sdram_dma().

◆ dma_interrupt_enable()

void dma_interrupt_enable | ( | dma_channel_type * | dmax_channely,
 |  | uint32_t | dma_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dma interrupt.

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
dma_int this parameter can be any combination of the following values:
  • DMA_FDT_INT
  • DMA_HDT_INT
  • DMA_DTERR_INT
new_state (TRUE or FALSE)
Return values
none.

Definition at line 164 of file at32f435_437_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_dma_config(), i2c_dma_tx_rx_irq_handler(), and main().

◆ dma_reset()

void dma_reset ( dma_channel_type * dmax_channely )

reset dmax channely register.

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
Return values
none.

Definition at line 64 of file at32f435_437_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_lowlevel_init(), i2s_config(), main(), qspi_dma_set(), sd_dma_config(), sdram_copy_to_sram_dma(), spi_bytes_read(), spi_bytes_write(), spi_config(), and sram_copy_to_sdram_dma().

◆ dmamux_enable()

void dmamux_enable | ( | dma_type * | dma_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the dmamux.

Parameters
dma_x | pointer to a dma_type structure, can be DMA1 or DMA2.
new_state | (TRUE or FALSE) .
Return values
none.

Definition at line 391 of file at32f435_437_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_lowlevel_init(), i2s_config(), main(), qspi_dma_set(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ dmamux_generator_config()

void dmamux_generator_config | ( | dmamux_generator_type * | dmamux_gen_x,
 |  | dmamux_gen_init_type * | dmamux_gen_init_struct
 | ) |  |

dmamux request generator init.

Parameters
dmamux_gen_x : this parameter can be one of the following values:
  • DMA1MUX_GENERATOR1
  • DMA1MUX_GENERATOR2
  • DMA1MUX_GENERATOR3
  • DMA1MUX_GENERATOR4
  • DMA2MUX_GENERATOR1
  • DMA2MUX_GENERATOR2
  • DMA2MUX_GENERATOR3
  • DMA2MUX_GENERATOR4
dmamux_gen_init_struct pointer to a dmamux_gen_init_type structure which will be initialized.
Return values
none.

Definition at line 519 of file at32f435_437_dma.c.

Referenced by main().

◆ dmamux_generator_default_para_init()

void dmamux_generator_default_para_init ( dmamux_gen_init_type * dmamux_gen_init_struct )

dmamux request generator init struct config with its default value.

Parameters
dmamux_gen_init_struct pointer to a dmamux_gen_init_type structure which will be initialized.
Return values
none.

Definition at line 496 of file at32f435_437_dma.c.

Referenced by main().

◆ dmamux_generator_flag_clear()

void dmamux_generator_flag_clear | ( | dma_type * | dma_x,
 |  | uint32_t | flag
 | ) |  |

dmamux request generator flag clear.

Parameters
dma_x : pointer to a dma_type structure, can be DMA1 or DMA2.
flag this parameter can be any combination of the following values:
  • DMAMUX_GEN_TRIG_OV1_FLAG
  • DMAMUX_GEN_TRIG_OV2_FLAG
  • DMAMUX_GEN_TRIG_OV3_FLAG
  • DMAMUX_GEN_TRIG_OV4_FLAG
Return values
none.

Definition at line 666 of file at32f435_437_dma.c.

◆ dmamux_generator_flag_get()

flag_status dmamux_generator_flag_get | ( | dma_type * | dma_x,
 |  | uint32_t | flag
 | ) |  |

dmamux request generator flag get.

Parameters
dma_x : pointer to a dma_type structure, can be DMA1 or DMA2.
flag this parameter can be any combination of the following values:
  • DMAMUX_GEN_TRIG_OV1_FLAG
  • DMAMUX_GEN_TRIG_OV2_FLAG
  • DMAMUX_GEN_TRIG_OV3_FLAG
  • DMAMUX_GEN_TRIG_OV4_FLAG
Return values
state of dmamux sync flag.

Definition at line 643 of file at32f435_437_dma.c.

◆ dmamux_generator_interrupt_enable()

void dmamux_generator_interrupt_enable | ( | dmamux_generator_type * | dmamux_gen_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the dmamux request generator interrupts.

Parameters
dmamux_gen_x : pointer to a dmamux_generator_type structure. this parameter can be one of the following values:
  • DMA1MUX_GENERATOR1
  • DMA1MUX_GENERATOR2
  • DMA1MUX_GENERATOR3
  • DMA1MUX_GENERATOR4
  • DMA2MUX_GENERATOR1
  • DMA2MUX_GENERATOR2
  • DMA2MUX_GENERATOR3
  • DMA2MUX_GENERATOR4
new_state (TRUE or FALSE).
Return values
none.

Definition at line 575 of file at32f435_437_dma.c.

◆ dmamux_init()

void dmamux_init | ( | dmamux_channel_type * | dmamux_channelx,
 |  | dmamux_requst_id_sel_type | dmamux_req_sel
 | ) |  |

dmamux init.

Parameters
dmamux_channelx this parameter can be one of the following values:
  • DMA1MUX_CHANNEL1
  • DMA1MUX_CHANNEL2
  • DMA1MUX_CHANNEL3
  • DMA1MUX_CHANNEL4
  • DMA1MUX_CHANNEL5
  • DMA1MUX_CHANNEL6
  • DMA1MUX_CHANNEL7
  • DMA2MUX_CHANNEL1
  • DMA2MUX_CHANNEL2
  • DMA2MUX_CHANNEL3
  • DMA2MUX_CHANNEL4
  • DMA2MUX_CHANNEL5
  • DMA2MUX_CHANNEL6
  • DMA2MUX_CHANNEL7
dmamux_req_sel this parameter can be one of the following values:
  • DMAMUX_DMAREQ_ID_REQ_G1 - DMAMUX_DMAREQ_ID_REQ_G2 - DMAMUX_DMAREQ_ID_REQ_G3 - DMAMUX_DMAREQ_ID_REQ_G4
  • DMAMUX_DMAREQ_ID_ADC1 - DMAMUX_DMAREQ_ID_ADC2 - DMAMUX_DMAREQ_ID_ADC3 - DMAMUX_DMAREQ_ID_DAC1
  • DMAMUX_DMAREQ_ID_DAC2 - DMAMUX_DMAREQ_ID_TMR6_OVERFLOW- DMAMUX_DMAREQ_ID_TMR7_OVERFLOW- DMAMUX_DMAREQ_ID_SPI1_RX
  • DMAMUX_DMAREQ_ID_SPI1_TX - DMAMUX_DMAREQ_ID_SPI2_RX - DMAMUX_DMAREQ_ID_SPI2_TX - DMAMUX_DMAREQ_ID_SPI3_RX
  • DMAMUX_DMAREQ_ID_SPI3_TX - DMAMUX_DMAREQ_ID_SPI4_RX - DMAMUX_DMAREQ_ID_SPI4_TX - DMAMUX_DMAREQ_ID_I2S2_EXT_RX
  • DMAMUX_DMAREQ_ID_I2S2_EXT_TX - DMAMUX_DMAREQ_ID_I2S3_EXT_RX - DMAMUX_DMAREQ_ID_I2S3_EXT_TX - DMAMUX_DMAREQ_ID_I2C1_RX
  • DMAMUX_DMAREQ_ID_I2C1_TX - DMAMUX_DMAREQ_ID_I2C2_RX - DMAMUX_DMAREQ_ID_I2C2_TX - DMAMUX_DMAREQ_ID_I2C3_RX
  • DMAMUX_DMAREQ_ID_I2C3_TX - DMAMUX_DMAREQ_ID_USART1_RX - DMAMUX_DMAREQ_ID_USART1_TX - DMAMUX_DMAREQ_ID_USART2_RX
  • DMAMUX_DMAREQ_ID_USART2_TX - DMAMUX_DMAREQ_ID_USART3_RX - DMAMUX_DMAREQ_ID_USART3_TX - DMAMUX_DMAREQ_ID_UART4_RX
  • DMAMUX_DMAREQ_ID_UART4_TX - DMAMUX_DMAREQ_ID_UART5_RX - DMAMUX_DMAREQ_ID_UART5_TX - DMAMUX_DMAREQ_ID_USART6_RX
  • DMAMUX_DMAREQ_ID_USART6_TX - DMAMUX_DMAREQ_ID_UART7_RX - DMAMUX_DMAREQ_ID_UART7_TX - DMAMUX_DMAREQ_ID_UART8_RX
  • DMAMUX_DMAREQ_ID_UART8_TX - DMAMUX_DMAREQ_ID_SDIO1 - DMAMUX_DMAREQ_ID_SDIO2 - DMAMUX_DMAREQ_ID_QSPI1
  • DMAMUX_DMAREQ_ID_QSPI2 - DMAMUX_DMAREQ_ID_TMR1_CH1 - DMAMUX_DMAREQ_ID_TMR1_CH2 - DMAMUX_DMAREQ_ID_TMR1_CH3
  • DMAMUX_DMAREQ_ID_TMR1_CH4 - DMAMUX_DMAREQ_ID_TMR1_OVERFLOW- DMAMUX_DMAREQ_ID_TMR1_TRIG - DMAMUX_DMAREQ_ID_TMR1_COM
  • DMAMUX_DMAREQ_ID_TMR8_CH1 - DMAMUX_DMAREQ_ID_TMR8_CH2 - DMAMUX_DMAREQ_ID_TMR8_CH3 - DMAMUX_DMAREQ_ID_TMR8_CH4
  • DMAMUX_DMAREQ_ID_TMR8_UP - DMAMUX_DMAREQ_ID_TMR8_TRIG - DMAMUX_DMAREQ_ID_TMR8_COM - DMAMUX_DMAREQ_ID_TMR2_CH1
  • DMAMUX_DMAREQ_ID_TMR2_CH2 - DMAMUX_DMAREQ_ID_TMR2_CH3 - DMAMUX_DMAREQ_ID_TMR2_CH4 - DMAMUX_DMAREQ_ID_TMR2_OVERFLOW
  • DMAMUX_DMAREQ_ID_TMR2_TRIG - DMAMUX_DMAREQ_ID_TMR3_CH1 - DMAMUX_DMAREQ_ID_TMR3_CH2 - DMAMUX_DMAREQ_ID_TMR3_CH3
  • DMAMUX_DMAREQ_ID_TMR3_CH4 - DMAMUX_DMAREQ_ID_TMR3_OVERFLOW- DMAMUX_DMAREQ_ID_TMR3_TRIG - DMAMUX_DMAREQ_ID_TMR4_CH1
  • DMAMUX_DMAREQ_ID_TMR4_CH2 - DMAMUX_DMAREQ_ID_TMR4_CH3 - DMAMUX_DMAREQ_ID_TMR4_CH4 - DMAMUX_DMAREQ_ID_TMR4_OVERFLOW
  • DMAMUX_DMAREQ_ID_TMR4_TRIG - DMAMUX_DMAREQ_ID_TMR5_CH1 - DMAMUX_DMAREQ_ID_TMR5_CH2 - DMAMUX_DMAREQ_ID_TMR5_CH3
  • DMAMUX_DMAREQ_ID_TMR5_CH4 - DMAMUX_DMAREQ_ID_TMR5_OVERFLOW- DMAMUX_DMAREQ_ID_TMR5_TRIG - DMAMUX_DMAREQ_ID_TMR20_CH1
  • DMAMUX_DMAREQ_ID_TMR20_CH2 - DMAMUX_DMAREQ_ID_TMR20_CH3 - DMAMUX_DMAREQ_ID_TMR20_CH4 - DMAMUX_DMAREQ_ID_TMR20_OVERFLOW
  • DMAMUX_DMAREQ_ID_TMR20_TRIG - DMAMUX_DMAREQ_ID_TMR20_HALL - DMAMUX_DMAREQ_ID_DVP
Return values
none.

Definition at line 442 of file at32f435_437_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_lowlevel_init(), i2s_config(), main(), qspi_dma_set(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ dmamux_sync_config()

void dmamux_sync_config | ( | dmamux_channel_type * | dmamux_channelx,
 |  | dmamux_sync_init_type * | dmamux_sync_init_struct
 | ) |  |

dmamux synchronization config.

Parameters
dmamux_channelx this parameter can be one of the following values:
  • DMA1MUX_CHANNEL1
  • DMA1MUX_CHANNEL2
  • DMA1MUX_CHANNEL3
  • DMA1MUX_CHANNEL4
  • DMA1MUX_CHANNEL5
  • DMA1MUX_CHANNEL6
  • DMA1MUX_CHANNEL7
  • DMA2MUX_CHANNEL1
  • DMA2MUX_CHANNEL2
  • DMA2MUX_CHANNEL3
  • DMA2MUX_CHANNEL4
  • DMA2MUX_CHANNEL5
  • DMA2MUX_CHANNEL6
  • DMA2MUX_CHANNEL7
dmamux_sync_init_struct ointer to a dmamux_sync_init_type structure.
Return values
none.

Definition at line 482 of file at32f435_437_dma.c.

Referenced by main().

◆ dmamux_sync_default_para_init()

void dmamux_sync_default_para_init ( dmamux_sync_init_type * dmamux_sync_init_struct )

dmamux sync init struct config with its default value.

Parameters
dmamux_sync_init_struct pointer to a dmamux_sync_init_type structure which will be initialized.
Return values
none.

Definition at line 452 of file at32f435_437_dma.c.

Referenced by main().

◆ dmamux_sync_flag_clear()

void dmamux_sync_flag_clear | ( | dma_type * | dma_x,
 |  | uint32_t | flag
 | ) |  |

dmamux sync flag clear.

Parameters
dma_x : pointer to a dma_type structure, can be DMA1 or DMA2.
flag this parameter can be any combination of the following values:
  • DMAMUX_SYNC_OV1_FLAG
  • DMAMUX_SYNC_OV2_FLAG
  • DMAMUX_SYNC_OV3_FLAG
  • DMAMUX_SYNC_OV4_FLAG
  • DMAMUX_SYNC_OV5_FLAG
  • DMAMUX_SYNC_OV6_FLAG
  • DMAMUX_SYNC_OV7_FLAG
Return values
none.

Definition at line 627 of file at32f435_437_dma.c.

◆ dmamux_sync_flag_get()

flag_status dmamux_sync_flag_get | ( | dma_type * | dma_x,
 |  | uint32_t | flag
 | ) |  |

dmamux sync flag get.

Parameters
dma_x : pointer to a dma_type structure, can be DMA1 or DMA2.
flag this parameter can be any combination of the following values:
  • DMAMUX_SYNC_OV1_FLAG
  • DMAMUX_SYNC_OV2_FLAG
  • DMAMUX_SYNC_OV3_FLAG
  • DMAMUX_SYNC_OV4_FLAG
  • DMAMUX_SYNC_OV5_FLAG
  • DMAMUX_SYNC_OV6_FLAG
  • DMAMUX_SYNC_OV7_FLAG
Return values
state of dmamux sync flag.

Definition at line 601 of file at32f435_437_dma.c.

◆ dmamux_sync_interrupt_enable()

void dmamux_sync_interrupt_enable | ( | dmamux_channel_type * | dmamux_channelx,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the dmamux sync interrupts.

Parameters
dmamux_channelx this parameter can be one of the following values:
  • DMA1MUX_CHANNEL1
  • DMA1MUX_CHANNEL2
  • DMA1MUX_CHANNEL3
  • DMA1MUX_CHANNEL4
  • DMA1MUX_CHANNEL5
  • DMA1MUX_CHANNEL6
  • DMA1MUX_CHANNEL7
  • DMA2MUX_CHANNEL1
  • DMA2MUX_CHANNEL2
  • DMA2MUX_CHANNEL3
  • DMA2MUX_CHANNEL4
  • DMA2MUX_CHANNEL5
  • DMA2MUX_CHANNEL6
  • DMA2MUX_CHANNEL7
new_state (TRUE or FALSE).
Return values
none.

Definition at line 548 of file at32f435_437_dma.c.


AT32F435/437 Firmwary Library: DVP

Modules | Macros
DVP
AT32F435_437_periph_driver

DVP driver modules. More...

Modules

DVP_event_flags_definition
dvp event flag
DVP_interrupt_flags_definition
dvp interrupt flag
DVP_interrupts_definition
dvp interrupt
DVP_exported_types
DVP_exported_functions
DVP_private_functions

Macros

#define DVP ((dvp_type *) DVP_BASE)

Detailed Description

DVP driver modules.

Macro Definition Documentation

◆ DVP

#define DVP ((dvp_type *) DVP_BASE)

Definition at line 569 of file at32f435_437_dvp.h.


AT32F435/437 Firmwary Library: DVP_event_flags_definition

Macros
DVP_event_flags_definition
AT32F435_437_periph_driver » DVP

dvp event flag More...

Macros

#define | DVP_CFD_EVT_FLAG ((uint32_t)0x00000001)
#define | DVP_OVR_EVT_FLAG ((uint32_t)0x00000002)
#define | DVP_ESE_EVT_FLAG ((uint32_t)0x00000004)
#define | DVP_VS_EVT_FLAG ((uint32_t)0x00000008)
#define | DVP_HS_EVT_FLAG ((uint32_t)0x00000010)

Detailed Description

dvp event flag

Macro Definition Documentation

◆ DVP_CFD_EVT_FLAG

#define DVP_CFD_EVT_FLAG ((uint32_t)0x00000001)

capture frame done event status flag

Definition at line 52 of file at32f435_437_dvp.h.

◆ DVP_ESE_EVT_FLAG

#define DVP_ESE_EVT_FLAG ((uint32_t)0x00000004)

embedded synchronization error event status flag

Definition at line 54 of file at32f435_437_dvp.h.

◆ DVP_HS_EVT_FLAG

#define DVP_HS_EVT_FLAG ((uint32_t)0x00000010)

horizontal synchonization event status flag

Definition at line 56 of file at32f435_437_dvp.h.

◆ DVP_OVR_EVT_FLAG

#define DVP_OVR_EVT_FLAG ((uint32_t)0x00000002)

data fifo overrun event status flag

Definition at line 53 of file at32f435_437_dvp.h.

◆ DVP_VS_EVT_FLAG

#define DVP_VS_EVT_FLAG ((uint32_t)0x00000008)

vertical synchonization event status flag

Definition at line 55 of file at32f435_437_dvp.h.


AT32F435/437 Firmwary Library: DVP_interrupt_flags_definition

Macros
DVP_interrupt_flags_definition
AT32F435_437_periph_driver » DVP

dvp interrupt flag More...

Macros

#define | DVP_CFD_INT_FLAG ((uint32_t)0x80000001)
#define | DVP_OVR_INT_FLAG ((uint32_t)0x80000002)
#define | DVP_ESE_INT_FLAG ((uint32_t)0x80000004)
#define | DVP_VS_INT_FLAG ((uint32_t)0x80000008)
#define | DVP_HS_INT_FLAG ((uint32_t)0x80000010)

Detailed Description

dvp interrupt flag

Macro Definition Documentation

◆ DVP_CFD_INT_FLAG

#define DVP_CFD_INT_FLAG ((uint32_t)0x80000001)

capture frame done interrupt status flag

Definition at line 67 of file at32f435_437_dvp.h.

◆ DVP_ESE_INT_FLAG

#define DVP_ESE_INT_FLAG ((uint32_t)0x80000004)

embedded synchronization error interrupt status flag

Definition at line 69 of file at32f435_437_dvp.h.

◆ DVP_HS_INT_FLAG

#define DVP_HS_INT_FLAG ((uint32_t)0x80000010)

horizontal synchonization interrupt status flag

Definition at line 71 of file at32f435_437_dvp.h.

◆ DVP_OVR_INT_FLAG

#define DVP_OVR_INT_FLAG ((uint32_t)0x80000002)

data fifo overrun interrupt status flag

Definition at line 68 of file at32f435_437_dvp.h.

◆ DVP_VS_INT_FLAG

#define DVP_VS_INT_FLAG ((uint32_t)0x80000008)

vertical synchonization interrupt status flag

Definition at line 70 of file at32f435_437_dvp.h.


AT32F435/437 Firmwary Library: DVP_interrupts_definition

Macros
DVP_interrupts_definition
AT32F435_437_periph_driver » DVP

dvp interrupt More...

Macros

#define | DVP_CFD_INT ((uint32_t)0x00000001)
#define | DVP_OVR_INT ((uint32_t)0x00000002)
#define | DVP_ESE_INT ((uint32_t)0x00000004)
#define | DVP_VS_INT ((uint32_t)0x00000008)
#define | DVP_HS_INT ((uint32_t)0x00000010)

Detailed Description

dvp interrupt

Macro Definition Documentation

◆ DVP_CFD_INT

#define DVP_CFD_INT ((uint32_t)0x00000001)

capture frame done interrupt

Definition at line 82 of file at32f435_437_dvp.h.

◆ DVP_ESE_INT

#define DVP_ESE_INT ((uint32_t)0x00000004)

embedded synchronization error interrupt

Definition at line 84 of file at32f435_437_dvp.h.

◆ DVP_HS_INT

#define DVP_HS_INT ((uint32_t)0x00000010)

horizontal synchonization interrupt

Definition at line 86 of file at32f435_437_dvp.h.

◆ DVP_OVR_INT

#define DVP_OVR_INT ((uint32_t)0x00000002)

data fifo overrun interrupt

Definition at line 83 of file at32f435_437_dvp.h.

◆ DVP_VS_INT

#define DVP_VS_INT ((uint32_t)0x00000008)

vertical synchonization interrupt

Definition at line 85 of file at32f435_437_dvp.h.


AT32F435/437 Firmwary Library: DVP_exported_types

Data Structures | Enumerations
DVP_exported_types
AT32F435_437_periph_driver » DVP

Data Structures

struct dvp_type

Enumerations

enum | dvp_cfm_type { DVP_CAP_FUNC_MODE_CONTINUOUS = 0x00 , DVP_CAP_FUNC_MODE_SINGLE = 0x01 }
dvp cfm type More...
enum | dvp_sm_type { DVP_SYNC_MODE_HARDWARE = 0x00 , DVP_SYNC_MODE_EMBEDDED = 0x01 }
dvp sm type More...
enum | dvp_ckp_type { DVP_CLK_POLARITY_RISING = 0x00 , DVP_CLK_POLARITY_FALLING = 0x01 }
dvp ckp type More...
enum | dvp_hsp_type { DVP_HSYNC_POLARITY_HIGH = 0x00 , DVP_HSYNC_POLARITY_LOW = 0x01 }
dvp hsp type More...
enum | dvp_vsp_type { DVP_VSYNC_POLARITY_LOW = 0x00 , DVP_VSYNC_POLARITY_HIGH = 0x01 }
dvp vsp type More...
enum | dvp_bfrc_type { DVP_BFRC_ALL = 0x00 , DVP_BFRC_HALF = 0x01 , DVP_BFRC_QUARTER = 0x02 }
dvp bfrc type More...
enum | dvp_pdl_type { DVP_PIXEL_DATA_LENGTH_8 = 0x00 , DVP_PIXEL_DATA_LENGTH_10 = 0x01 , DVP_PIXEL_DATA_LENGTH_12 = 0x02 , DVP_PIXEL_DATA_LENGTH_14 = 0x03 }
dvp pdl type More...
enum | dvp_pcdc_type { DVP_PCDC_ALL = 0x00 , DVP_PCDC_ONE_IN_TWO = 0x01 , DVP_PCDC_ONE_IN_FOUR = 0x02 , DVP_PCDC_TWO_IN_FOUR = 0x03 }
dvp pcdc type More...
enum | dvp_pcds_type { DVP_PCDS_CAP_FIRST = 0x00 , DVP_PCDS_DROP_FIRST = 0x01 }
dvp pcds type More...
enum | dvp_lcdc_type { DVP_LCDC_ALL = 0x00 , DVP_LCDC_ONE_IN_TWO = 0x01 }
dvp lcdc type More...
enum | dvp_lcds_type { DVP_LCDS_CAP_FIRST = 0x00 , DVP_LCDS_DROP_FIRST = 0x01 }
dvp lcds type More...
enum | dvp_status_basic_type { DVP_STATUS_HSYN = 0x00 , DVP_STATUS_VSYN = 0x01 , DVP_STATUS_OFNE = 0x02 }
dvp status basic type More...
enum | dvp_pcdes_type { DVP_PCDES_CAP_FIRST = 0x00 , DVP_PCDES_DROP_FIRST = 0x01 }
dvp pcdes type More...
enum dvp_efdf_type {
DVP_EFDF_BYPASS = 0x00 , DVP_EFDF_YUV422_UYVY = 0x04 , DVP_EFDF_YUV422_YUYV = 0x05 , DVP_EFDF_RGB565_555 = 0x06 ,
DVP_EFDF_Y8 = 0x07
}
dvp efdf type More...
enum | dvp_idus_type { DVP_IDUS_MSB = 0x00 , DVP_IDUS_LSB = 0x01 }
dvp idus type More...
enum | dvp_dmabt_type { DVP_DMABT_SINGLE = 0x00 , DVP_DMABT_BURST = 0x01 }
dvp dmabt type More...
enum | dvp_hseid_type { DVP_HSEID_LINE_END = 0x00 , DVP_HSEID_LINE_START = 0x01 }
dvp hseid type More...
enum | dvp_vseid_type { DVP_VSEID_FRAME_END = 0x00 , DVP_VSEID_FRMAE_START = 0x01 }
dvp vseid type More...
enum | dvp_idun_type { DVP_IDUN_0 = 0x00 , DVP_IDUN_2 = 0x01 , DVP_IDUN_4 = 0x02 , DVP_IDUN_6 = 0x03 }
dvp idun type More...

Detailed Description

Enumeration Type Documentation

◆ dvp_bfrc_type

enum dvp_bfrc_type

dvp bfrc type

Enumerator
DVP_BFRC_ALL
DVP_BFRC_HALF
DVP_BFRC_QUARTER

Definition at line 144 of file at32f435_437_dvp.h.

◆ dvp_cfm_type

enum dvp_cfm_type

dvp cfm type

Enumerator
DVP_CAP_FUNC_MODE_CONTINUOUS
DVP_CAP_FUNC_MODE_SINGLE

Definition at line 99 of file at32f435_437_dvp.h.

◆ dvp_ckp_type

enum dvp_ckp_type

dvp ckp type

Enumerator
DVP_CLK_POLARITY_RISING
DVP_CLK_POLARITY_FALLING

Definition at line 117 of file at32f435_437_dvp.h.

◆ dvp_dmabt_type

enum dvp_dmabt_type

dvp dmabt type

Enumerator
DVP_DMABT_SINGLE
DVP_DMABT_BURST

Definition at line 243 of file at32f435_437_dvp.h.

◆ dvp_efdf_type

enum dvp_efdf_type

dvp efdf type

Enumerator
DVP_EFDF_BYPASS
DVP_EFDF_YUV422_UYVY
DVP_EFDF_YUV422_YUYV
DVP_EFDF_RGB565_555
DVP_EFDF_Y8

Definition at line 222 of file at32f435_437_dvp.h.

◆ dvp_hseid_type

enum dvp_hseid_type

dvp hseid type

Enumerator
DVP_HSEID_LINE_END
DVP_HSEID_LINE_START

Definition at line 252 of file at32f435_437_dvp.h.

◆ dvp_hsp_type

enum dvp_hsp_type

dvp hsp type

Enumerator
DVP_HSYNC_POLARITY_HIGH
DVP_HSYNC_POLARITY_LOW

Definition at line 126 of file at32f435_437_dvp.h.

◆ dvp_idun_type

enum dvp_idun_type

dvp idun type

Enumerator
DVP_IDUN_0
DVP_IDUN_2
DVP_IDUN_4
DVP_IDUN_6

Definition at line 269 of file at32f435_437_dvp.h.

◆ dvp_idus_type

enum dvp_idus_type

dvp idus type

Enumerator
DVP_IDUS_MSB
DVP_IDUS_LSB

Definition at line 234 of file at32f435_437_dvp.h.

◆ dvp_lcdc_type

enum dvp_lcdc_type

dvp lcdc type

Enumerator
DVP_LCDC_ALL
DVP_LCDC_ONE_IN_TWO

Definition at line 185 of file at32f435_437_dvp.h.

◆ dvp_lcds_type

enum dvp_lcds_type

dvp lcds type

Enumerator
DVP_LCDS_CAP_FIRST
DVP_LCDS_DROP_FIRST

Definition at line 194 of file at32f435_437_dvp.h.

◆ dvp_pcdc_type

enum dvp_pcdc_type

dvp pcdc type

Enumerator
DVP_PCDC_ALL
DVP_PCDC_ONE_IN_TWO
DVP_PCDC_ONE_IN_FOUR
DVP_PCDC_TWO_IN_FOUR

Definition at line 165 of file at32f435_437_dvp.h.

◆ dvp_pcdes_type

enum dvp_pcdes_type

dvp pcdes type

Enumerator
DVP_PCDES_CAP_FIRST
DVP_PCDES_DROP_FIRST

Definition at line 213 of file at32f435_437_dvp.h.

◆ dvp_pcds_type

enum dvp_pcds_type

dvp pcds type

Enumerator
DVP_PCDS_CAP_FIRST
DVP_PCDS_DROP_FIRST

Definition at line 176 of file at32f435_437_dvp.h.

◆ dvp_pdl_type

enum dvp_pdl_type

dvp pdl type

Enumerator
DVP_PIXEL_DATA_LENGTH_8
DVP_PIXEL_DATA_LENGTH_10
DVP_PIXEL_DATA_LENGTH_12
DVP_PIXEL_DATA_LENGTH_14

Definition at line 154 of file at32f435_437_dvp.h.

◆ dvp_sm_type

enum dvp_sm_type

dvp sm type

Enumerator
DVP_SYNC_MODE_HARDWARE
DVP_SYNC_MODE_EMBEDDED

Definition at line 108 of file at32f435_437_dvp.h.

◆ dvp_status_basic_type

enum dvp_status_basic_type

dvp status basic type

Enumerator
DVP_STATUS_HSYN
DVP_STATUS_VSYN
DVP_STATUS_OFNE

Definition at line 203 of file at32f435_437_dvp.h.

◆ dvp_vseid_type

enum dvp_vseid_type

dvp vseid type

Enumerator
DVP_VSEID_FRAME_END
DVP_VSEID_FRMAE_START

Definition at line 261 of file at32f435_437_dvp.h.

◆ dvp_vsp_type

enum dvp_vsp_type

dvp vsp type

Enumerator
DVP_VSYNC_POLARITY_LOW
DVP_VSYNC_POLARITY_HIGH

Definition at line 135 of file at32f435_437_dvp.h.


AT32F435/437 Firmwary Library: dvp_type Struct Reference

Data Fields
dvp_type Struct Reference
AT32F435_437_periph_driver » DVP » DVP_exported_types

#include <at32f435_437_dvp.h>

Data Fields

union {
__IO uint32_t ctrl
struct {
__IO uint32_t cap: 1
__IO uint32_t cfm: 1
__IO uint32_t crp: 1
__IO uint32_t jpeg: 1
__IO uint32_t sm: 1
__IO uint32_t ckp: 1
__IO uint32_t hsp: 1
__IO uint32_t vsp: 1
__IO uint32_t bfrc: 2
__IO uint32_t pdl: 2
__IO uint32_t reserved1: 2
__IO uint32_t ena: 1
__IO uint32_t reserved2: 1
__IO uint32_t pcdc: 2
__IO uint32_t pcds: 1
__IO uint32_t lcdc: 1
__IO uint32_t lcds: 1
__IO uint32_t: 11
} ctrl_bit
};
dvp ctrl register, offset:0x00 More...
union {
__IO uint32_t sts
struct {
__IO uint32_t hsyn: 1
__IO uint32_t vsyn: 1
__IO uint32_t ofne: 1
__IO uint32_t reserved1: 29
} sts_bit
};
dvp sts register, offset:0x04 More...
union {
__IO uint32_t ests
struct {
__IO uint32_t cfdes: 1
__IO uint32_t ovres: 1
__IO uint32_t esees: 1
__IO uint32_t vses: 1
__IO uint32_t hses: 1
__IO uint32_t reserved1: 27
} ests_bit
};
dvp ests register, offset:0x08 More...
union {
__IO uint32_t ier
struct {
__IO uint32_t cfdie: 1
__IO uint32_t ovrie: 1
__IO uint32_t eseie: 1
__IO uint32_t vsie: 1
__IO uint32_t hsie: 1
__IO uint32_t reserved1: 27
} ier_bit
};
dvp ier register, offset:0x0C More...
union {
__IO uint32_t ists
struct {
__IO uint32_t cfdis: 1
__IO uint32_t ovris: 1
__IO uint32_t eseis: 1
__IO uint32_t vsis: 1
__IO uint32_t hsis: 1
__IO uint32_t reserved1: 27
} ists_bit
};
dvp ists register, offset:0x10 More...
union {
__IO uint32_t iclr
struct {
__IO uint32_t cfdic: 1
__IO uint32_t ovric: 1
__IO uint32_t eseic: 1
__IO uint32_t vsic: 1
__IO uint32_t hsic: 1
__IO uint32_t reserved1: 27
} iclr_bit
};
dvp iclr register, offset:0x14 More...
union {
__IO uint32_t scr
struct {
__IO uint32_t fmsc: 8
__IO uint32_t lnsc: 8
__IO uint32_t lnec: 8
__IO uint32_t fmec: 8
} scr_bit
};
dvp scr register, offset:0x18 More...
union {
__IO uint32_t sur
struct {
__IO uint32_t fmsu: 8
__IO uint32_t lnsu: 8
__IO uint32_t lneu: 8
__IO uint32_t fmeu: 8
} sur_bit
};
dvp sur register, offset:0x1C More...
union {
__IO uint32_t cwst
struct {
__IO uint32_t chstr: 14
__IO uint32_t reserved1: 2
__IO uint32_t cvstr: 13
__IO uint32_t reserved2: 3
} cwst_bit
};
dvp cwst register, offset:0x20 More...
union {
__IO uint32_t cwsz
struct {
__IO uint32_t chnum: 14
__IO uint32_t reserved1: 2
__IO uint32_t cvnum: 14
__IO uint32_t reserved2: 2
} cwsz_bit
};
dvp cwsz register, offset:0x24 More...
union {
__IO uint32_t dt
struct {
__IO uint32_t dr0: 8
__IO uint32_t dr1: 8
__IO uint32_t dr2: 8
__IO uint32_t dr3: 8
} dt_bit
};
dvp dt register, offset:0x28 More...
union {
__IO uint32_t actrl
struct {
__IO uint32_t eisre: 1
__IO uint32_t efrce: 1
__IO uint32_t mibe: 1
__IO uint32_t pcdes: 1
__IO uint32_t efdf: 3
__IO uint32_t reserved1: 1
__IO uint32_t idun: 2
__IO uint32_t idus: 1
__IO uint32_t reserved2: 1
__IO uint32_t dmabt: 1
__IO uint32_t reserved3: 1
__IO uint32_t reserved4: 1
__IO uint32_t reserved5: 1
__IO uint32_t hseid: 1
__IO uint32_t vseid: 1
__IO uint32_t reserved6: 1
__IO uint32_t reserved7: 2
__IO uint32_t reserved8: 11
} actrl_bit
};
dvp actrl register, offset:0x40 More...
union {
__IO uint32_t hscf
struct {
__IO uint32_t hsrss: 13
__IO uint32_t reserved1: 3
__IO uint32_t hsrts: 13
__IO uint32_t reserved2: 3
} hscf_bit
};
dvp hscf register, offset:0x48 More...
union {
__IO uint32_t vscf
struct {
__IO uint32_t vsrss: 13
__IO uint32_t reserved1: 3
__IO uint32_t vsrts: 13
__IO uint32_t reserved2: 3
} vscf_bit
};
dvp vscf register, offset:0x4C More...
union {
__IO uint32_t frf
struct {
__IO uint32_t efrcsf: 5
__IO uint32_t reserved1: 3
__IO uint32_t efrctf: 5
__IO uint32_t reserved2: 19
} frf_bit
};
dvp frf register, offset:0x50 More...
union {
__IO uint32_t bth
struct {
__IO uint32_t mibthd: 8
__IO uint32_t reserved1: 24
} bth_bit
};
dvp bth register, offset:0x54 More...

Detailed Description

Definition at line 277 of file at32f435_437_dvp.h.

Field Documentation

◆

union { ... } dvp_type::@331

dvp ctrl register, offset:0x00

◆

union { ... } dvp_type::@333

dvp sts register, offset:0x04

◆

union { ... } dvp_type::@335

dvp ests register, offset:0x08

◆

union { ... } dvp_type::@337

dvp ier register, offset:0x0C

◆

union { ... } dvp_type::@339

dvp ists register, offset:0x10

◆

union { ... } dvp_type::@341

dvp iclr register, offset:0x14

◆

union { ... } dvp_type::@343

dvp scr register, offset:0x18

◆

union { ... } dvp_type::@345

dvp sur register, offset:0x1C

◆

union { ... } dvp_type::@347

dvp cwst register, offset:0x20

◆

union { ... } dvp_type::@349

dvp cwsz register, offset:0x24

◆

union { ... } dvp_type::@351

dvp dt register, offset:0x28

◆

union { ... } dvp_type::@353

dvp actrl register, offset:0x40

◆

union { ... } dvp_type::@355

dvp hscf register, offset:0x48

◆

union { ... } dvp_type::@357

dvp vscf register, offset:0x4C

◆

union { ... } dvp_type::@359

dvp frf register, offset:0x50

◆

union { ... } dvp_type::@361

dvp bth register, offset:0x54

◆ actrl

__IO uint32_t dvp_type::actrl

Definition at line 476 of file at32f435_437_dvp.h.

◆

struct { ... } dvp_type::actrl_bit

◆ bfrc

__IO uint32_t dvp_type::bfrc

Definition at line 295 of file at32f435_437_dvp.h.

◆ bth

__IO uint32_t dvp_type::bth

Definition at line 555 of file at32f435_437_dvp.h.

◆

struct { ... } dvp_type::bth_bit

◆ cap

__IO uint32_t dvp_type::cap

Definition at line 287 of file at32f435_437_dvp.h.

◆ cfdes

__IO uint32_t dvp_type::cfdes

Definition at line 331 of file at32f435_437_dvp.h.

◆ cfdic

__IO uint32_t dvp_type::cfdic

Definition at line 382 of file at32f435_437_dvp.h.

◆ cfdie

__IO uint32_t dvp_type::cfdie

Definition at line 348 of file at32f435_437_dvp.h.

◆ cfdis

__IO uint32_t dvp_type::cfdis

Definition at line 365 of file at32f435_437_dvp.h.

◆ cfm

__IO uint32_t dvp_type::cfm

Definition at line 288 of file at32f435_437_dvp.h.

◆ chnum

__IO uint32_t dvp_type::chnum

Definition at line 444 of file at32f435_437_dvp.h.

◆ chstr

__IO uint32_t dvp_type::chstr

Definition at line 429 of file at32f435_437_dvp.h.

◆ ckp

__IO uint32_t dvp_type::ckp

Definition at line 292 of file at32f435_437_dvp.h.

◆ crp

__IO uint32_t dvp_type::crp

Definition at line 289 of file at32f435_437_dvp.h.

◆ ctrl

__IO uint32_t dvp_type::ctrl

Definition at line 284 of file at32f435_437_dvp.h.

◆

struct { ... } dvp_type::ctrl_bit

◆ cvnum

__IO uint32_t dvp_type::cvnum

Definition at line 446 of file at32f435_437_dvp.h.

◆ cvstr

__IO uint32_t dvp_type::cvstr

Definition at line 431 of file at32f435_437_dvp.h.

◆ cwst

__IO uint32_t dvp_type::cwst

Definition at line 426 of file at32f435_437_dvp.h.

◆

struct { ... } dvp_type::cwst_bit

◆ cwsz

__IO uint32_t dvp_type::cwsz

Definition at line 441 of file at32f435_437_dvp.h.

◆

struct { ... } dvp_type::cwsz_bit

◆ dmabt

__IO uint32_t dvp_type::dmabt

Definition at line 488 of file at32f435_437_dvp.h.

◆ dr0

__IO uint32_t dvp_type::dr0

Definition at line 459 of file at32f435_437_dvp.h.

◆ dr1

__IO uint32_t dvp_type::dr1

Definition at line 460 of file at32f435_437_dvp.h.

◆ dr2

__IO uint32_t dvp_type::dr2

Definition at line 461 of file at32f435_437_dvp.h.

◆ dr3

__IO uint32_t dvp_type::dr3

Definition at line 462 of file at32f435_437_dvp.h.

◆ dt

__IO uint32_t dvp_type::dt

Definition at line 456 of file at32f435_437_dvp.h.

◆

struct { ... } dvp_type::dt_bit

◆ efdf

__IO uint32_t dvp_type::efdf

Definition at line 483 of file at32f435_437_dvp.h.

◆ efrce

__IO uint32_t dvp_type::efrce

Definition at line 480 of file at32f435_437_dvp.h.

◆ efrcsf

__IO uint32_t dvp_type::efrcsf

Definition at line 543 of file at32f435_437_dvp.h.

◆ efrctf

__IO uint32_t dvp_type::efrctf

Definition at line 545 of file at32f435_437_dvp.h.

◆ eisre

__IO uint32_t dvp_type::eisre

Definition at line 479 of file at32f435_437_dvp.h.

◆ ena

__IO uint32_t dvp_type::ena

Definition at line 298 of file at32f435_437_dvp.h.

◆ esees

__IO uint32_t dvp_type::esees

Definition at line 333 of file at32f435_437_dvp.h.

◆ eseic

__IO uint32_t dvp_type::eseic

Definition at line 384 of file at32f435_437_dvp.h.

◆ eseie

__IO uint32_t dvp_type::eseie

Definition at line 350 of file at32f435_437_dvp.h.

◆ eseis

__IO uint32_t dvp_type::eseis

Definition at line 367 of file at32f435_437_dvp.h.

◆ ests

__IO uint32_t dvp_type::ests

Definition at line 328 of file at32f435_437_dvp.h.

◆

struct { ... } dvp_type::ests_bit

◆ fmec

__IO uint32_t dvp_type::fmec

Definition at line 402 of file at32f435_437_dvp.h.

◆ fmeu

__IO uint32_t dvp_type::fmeu

Definition at line 417 of file at32f435_437_dvp.h.

◆ fmsc

__IO uint32_t dvp_type::fmsc

Definition at line 399 of file at32f435_437_dvp.h.

◆ fmsu

__IO uint32_t dvp_type::fmsu

Definition at line 414 of file at32f435_437_dvp.h.

◆ frf

__IO uint32_t dvp_type::frf

Definition at line 540 of file at32f435_437_dvp.h.

◆

struct { ... } dvp_type::frf_bit

◆ hscf

__IO uint32_t dvp_type::hscf

Definition at line 510 of file at32f435_437_dvp.h.

◆

struct { ... } dvp_type::hscf_bit

◆ hseid

__IO uint32_t dvp_type::hseid

Definition at line 492 of file at32f435_437_dvp.h.

◆ hses

__IO uint32_t dvp_type::hses

Definition at line 335 of file at32f435_437_dvp.h.

◆ hsic

__IO uint32_t dvp_type::hsic

Definition at line 386 of file at32f435_437_dvp.h.

◆ hsie

__IO uint32_t dvp_type::hsie

Definition at line 352 of file at32f435_437_dvp.h.

◆ hsis

__IO uint32_t dvp_type::hsis

Definition at line 369 of file at32f435_437_dvp.h.

◆ hsp

__IO uint32_t dvp_type::hsp

Definition at line 293 of file at32f435_437_dvp.h.

◆ hsrss

__IO uint32_t dvp_type::hsrss

Definition at line 513 of file at32f435_437_dvp.h.

◆ hsrts

__IO uint32_t dvp_type::hsrts

Definition at line 515 of file at32f435_437_dvp.h.

◆ hsyn

__IO uint32_t dvp_type::hsyn

Definition at line 316 of file at32f435_437_dvp.h.

◆ iclr

__IO uint32_t dvp_type::iclr

Definition at line 379 of file at32f435_437_dvp.h.

◆

struct { ... } dvp_type::iclr_bit

◆ idun

__IO uint32_t dvp_type::idun

Definition at line 485 of file at32f435_437_dvp.h.

◆ idus

__IO uint32_t dvp_type::idus

Definition at line 486 of file at32f435_437_dvp.h.

◆ ier

__IO uint32_t dvp_type::ier

Definition at line 345 of file at32f435_437_dvp.h.

◆

struct { ... } dvp_type::ier_bit

◆ ists

__IO uint32_t dvp_type::ists

Definition at line 362 of file at32f435_437_dvp.h.

◆

struct { ... } dvp_type::ists_bit

◆ jpeg

__IO uint32_t dvp_type::jpeg

Definition at line 290 of file at32f435_437_dvp.h.

◆ lcdc

__IO uint32_t dvp_type::lcdc

Definition at line 302 of file at32f435_437_dvp.h.

◆ lcds

__IO uint32_t dvp_type::lcds

Definition at line 303 of file at32f435_437_dvp.h.

◆ lnec

__IO uint32_t dvp_type::lnec

Definition at line 401 of file at32f435_437_dvp.h.

◆ lneu

__IO uint32_t dvp_type::lneu

Definition at line 416 of file at32f435_437_dvp.h.

◆ lnsc

__IO uint32_t dvp_type::lnsc

Definition at line 400 of file at32f435_437_dvp.h.

◆ lnsu

__IO uint32_t dvp_type::lnsu

Definition at line 415 of file at32f435_437_dvp.h.

◆ mibe

__IO uint32_t dvp_type::mibe

Definition at line 481 of file at32f435_437_dvp.h.

◆ mibthd

__IO uint32_t dvp_type::mibthd

Definition at line 558 of file at32f435_437_dvp.h.

◆ ofne

__IO uint32_t dvp_type::ofne

Definition at line 318 of file at32f435_437_dvp.h.

◆ ovres

__IO uint32_t dvp_type::ovres

Definition at line 332 of file at32f435_437_dvp.h.

◆ ovric

__IO uint32_t dvp_type::ovric

Definition at line 383 of file at32f435_437_dvp.h.

◆ ovrie

__IO uint32_t dvp_type::ovrie

Definition at line 349 of file at32f435_437_dvp.h.

◆ ovris

__IO uint32_t dvp_type::ovris

Definition at line 366 of file at32f435_437_dvp.h.

◆ pcdc

__IO uint32_t dvp_type::pcdc

Definition at line 300 of file at32f435_437_dvp.h.

◆ pcdes

__IO uint32_t dvp_type::pcdes

Definition at line 482 of file at32f435_437_dvp.h.

◆ pcds

__IO uint32_t dvp_type::pcds

Definition at line 301 of file at32f435_437_dvp.h.

◆ pdl

__IO uint32_t dvp_type::pdl

Definition at line 296 of file at32f435_437_dvp.h.

◆ reserved1

__IO uint32_t dvp_type::reserved1

dvp reserved1 register, offset:0x2C-0x3C

Definition at line 297 of file at32f435_437_dvp.h.

◆ reserved2

__IO uint32_t dvp_type::reserved2

dvp reserved2 register, offset:0x44

Definition at line 299 of file at32f435_437_dvp.h.

◆ reserved3

__IO uint32_t dvp_type::reserved3

Definition at line 489 of file at32f435_437_dvp.h.

◆ reserved4

__IO uint32_t dvp_type::reserved4

Definition at line 490 of file at32f435_437_dvp.h.

◆ reserved5

__IO uint32_t dvp_type::reserved5

Definition at line 491 of file at32f435_437_dvp.h.

◆ reserved6

__IO uint32_t dvp_type::reserved6

Definition at line 494 of file at32f435_437_dvp.h.

◆ reserved7

__IO uint32_t dvp_type::reserved7

Definition at line 495 of file at32f435_437_dvp.h.

◆ reserved8

__IO uint32_t dvp_type::reserved8

Definition at line 496 of file at32f435_437_dvp.h.

◆ scr

__IO uint32_t dvp_type::scr

Definition at line 396 of file at32f435_437_dvp.h.

◆

struct { ... } dvp_type::scr_bit

◆ sm

__IO uint32_t dvp_type::sm

Definition at line 291 of file at32f435_437_dvp.h.

◆ sts

__IO uint32_t dvp_type::sts

Definition at line 313 of file at32f435_437_dvp.h.

◆

struct { ... } dvp_type::sts_bit

◆ sur

__IO uint32_t dvp_type::sur

Definition at line 411 of file at32f435_437_dvp.h.

◆

struct { ... } dvp_type::sur_bit

◆ uint32_t

__IO dvp_type::uint32_t

Definition at line 304 of file at32f435_437_dvp.h.

◆ vscf

__IO uint32_t dvp_type::vscf

Definition at line 525 of file at32f435_437_dvp.h.

◆

struct { ... } dvp_type::vscf_bit

◆ vseid

__IO uint32_t dvp_type::vseid

Definition at line 493 of file at32f435_437_dvp.h.

◆ vses

__IO uint32_t dvp_type::vses

Definition at line 334 of file at32f435_437_dvp.h.

◆ vsic

__IO uint32_t dvp_type::vsic

Definition at line 385 of file at32f435_437_dvp.h.

◆ vsie

__IO uint32_t dvp_type::vsie

Definition at line 351 of file at32f435_437_dvp.h.

◆ vsis

__IO uint32_t dvp_type::vsis

Definition at line 368 of file at32f435_437_dvp.h.

◆ vsp

__IO uint32_t dvp_type::vsp

Definition at line 294 of file at32f435_437_dvp.h.

◆ vsrss

__IO uint32_t dvp_type::vsrss

Definition at line 528 of file at32f435_437_dvp.h.

◆ vsrts

__IO uint32_t dvp_type::vsrts

Definition at line 530 of file at32f435_437_dvp.h.

◆ vsyn

__IO uint32_t dvp_type::vsyn

Definition at line 317 of file at32f435_437_dvp.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_dvp.h


AT32F435/437 Firmwary Library: DVP_exported_functions

Functions
DVP_exported_functions
AT32F435_437_periph_driver » DVP

Functions

void | dvp_reset (void)
reset the dvp register More...
void | dvp_capture_enable (confirm_state new_state)
enable or disable dvp capture More...
void | dvp_capture_mode_set (dvp_cfm_type cap_mode)
set dvp capture mode More...
void | dvp_window_crop_enable (confirm_state new_state)
set dvp cropping window enable More...
void | dvp_window_crop_set (uint16_t crop_x, uint16_t crop_y, uint16_t crop_w, uint16_t crop_h, uint8_t bytes)
set dvp cropping window configuration More...
void | dvp_jpeg_enable (confirm_state new_state)
enable or disable dvp jpeg More...
void | dvp_sync_mode_set (dvp_sm_type sync_mode)
set dvp synchronization mode More...
void | dvp_sync_code_set (uint8_t fmsc, uint8_t fmec, uint8_t lnsc, uint8_t lnec)
set dvp synchronization code configuration More...
void | dvp_sync_unmask_set (uint8_t fmsu, uint8_t fmeu, uint8_t lnsu, uint8_t lneu)
set dvp synchronization unmask configuration More...
void | dvp_pclk_polarity_set (dvp_ckp_type eage)
set dvp pixel clock polarity More...
void | dvp_hsync_polarity_set (dvp_hsp_type hsync_pol)
set dvp horizontal synchronization polarity More...
void | dvp_vsync_polarity_set (dvp_vsp_type vsync_pol)
set dvp vertical synchronization polarity More...
void | dvp_basic_frame_rate_control_set (dvp_bfrc_type dvp_bfrc)
config dvp basic frame rate control More...
void | dvp_pixel_data_length_set (dvp_pdl_type dvp_pdl)
config dvp pixel data length More...
void | dvp_enable (confirm_state new_state)
enable or disable dvp function More...
void | dvp_zoomout_select (dvp_pcdes_type dvp_pcdes)
set dvp zoomout select More...
void | dvp_zoomout_set (dvp_pcdc_type dvp_pcdc, dvp_pcds_type dvp_pcds, dvp_lcdc_type dvp_lcdc, dvp_lcds_type dvp_lcds)
set dvp zoomout configuration More...
flag_status | dvp_basic_status_get (dvp_status_basic_type dvp_status_basic)
get dvp basic status More...
void | dvp_interrupt_enable (uint32_t dvp_int, confirm_state new_state)
enable or disable dvp interrupt More...
flag_status | dvp_flag_get (uint32_t flag)
get dvp event/interrupt flag status More...
void | dvp_flag_clear (uint32_t flag)
clear dvp's pending flags More...
void | dvp_enhanced_scaling_resize_enable (confirm_state new_state)
set dvp enhanced image scaling resize enable More...
void | dvp_enhanced_scaling_resize_set (uint16_t src_w, uint16_t des_w, uint16_t src_h, uint16_t des_h)
set dvp enhanced image scaling resize configuration More...
void | dvp_enhanced_framerate_set (uint16_t efrcsf, uint16_t efrctf, confirm_state new_state)
set enhanced frame rate control configuration More...
void | dvp_monochrome_image_binarization_set (uint8_t mibthd, confirm_state new_state)
set dvp monochrome image binarization configuration More...
void | dvp_enhanced_data_format_set (dvp_efdf_type dvp_efdf)
set dvp enhanced function data format configuration More...
void | dvp_input_data_unused_set (dvp_idus_type dvp_idus, dvp_idun_type dvp_idun)
set dvp input data un-used condition/number configuration More...
void | dvp_dma_burst_set (dvp_dmabt_type dvp_dmabt)
set dvp dma burst transfer configuration More...
void | dvp_sync_event_interrupt_set (dvp_hseid_type dvp_hseid, dvp_vseid_type dvp_vseid)
set dvp hsync/vsync event interrupt strategy configuration More...

Detailed Description

Function Documentation

◆ dvp_basic_frame_rate_control_set()

void dvp_basic_frame_rate_control_set ( dvp_bfrc_type dvp_bfrc )

config dvp basic frame rate control

Note
this function only work in continuous fire mode(ctrl_bit.cfm = 0)
Parameters
dvp_bfrc this parameter can be one of the following values:
  • DVP_BFRC_ALL
  • DVP_BFRC_HALF
  • DVP_BFRC_QUARTER
Return values
none

Definition at line 202 of file at32f435_437_dvp.c.

◆ dvp_basic_status_get()

flag_status dvp_basic_status_get ( dvp_status_basic_type dvp_status_basic )

get dvp basic status

Parameters
dvp_status_basic_type this parameter can be one of the following values:
  • DVP_STATUS_HSYN
  • DVP_STATUS_VSYN
  • DVP_STATUS_OFNE
Return values
flag_status (SET or RESET)

Definition at line 284 of file at32f435_437_dvp.c.

◆ dvp_capture_enable()

void dvp_capture_enable ( confirm_state new_state )

enable or disable dvp capture

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 60 of file at32f435_437_dvp.c.

Referenced by dvp_start(), and dvp_stop().

◆ dvp_capture_mode_set()

void dvp_capture_mode_set ( dvp_cfm_type cap_mode )

set dvp capture mode

Parameters
cap_mode this parameter can be one of the following values:
  • DVP_CAP_FUNC_MODE_CONTINUOUS
  • DVP_CAP_FUNC_MODE_SINGLE
Return values
none

Definition at line 73 of file at32f435_437_dvp.c.

Referenced by dvp_config().

◆ dvp_dma_burst_set()

void dvp_dma_burst_set ( dvp_dmabt_type dvp_dmabt )

set dvp dma burst transfer configuration

Parameters
dvp_dmabt dma burst transfer configuration this parameter can be one of the following values:
  • DVP_DMABT_SINGLE
  • DVP_DMABT_BURST
Return values
none

Definition at line 493 of file at32f435_437_dvp.c.

◆ dvp_enable()

void dvp_enable ( confirm_state new_state )

enable or disable dvp function

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 227 of file at32f435_437_dvp.c.

Referenced by dvp_config().

◆ dvp_enhanced_data_format_set()

void dvp_enhanced_data_format_set ( dvp_efdf_type dvp_efdf )

set dvp enhanced function data format configuration

Parameters
dvp_efdf enhanced function data format this parameter can be one of the following values:
  • DVP_EFDF_BYPASS
  • DVP_EFDF_YUV422_UYVY
  • DVP_EFDF_YUV422_YUYV
  • DVP_EFDF_RGB565_555
  • DVP_EFDF_Y8
Return values
none

Definition at line 460 of file at32f435_437_dvp.c.

◆ dvp_enhanced_framerate_set()

void dvp_enhanced_framerate_set | ( | uint16_t | efrcsf,
 |  | uint16_t | efrctf,
 |  | confirm_state | new_state
 | ) |  |

set enhanced frame rate control configuration

Parameters
efrcsf(0x00~0x1F) | original frame rate contorl factor
efrctf(0x00~0x1F) | enhanced frame rate contorl factor
new_state | (TRUE or FALSE)
Return values
none

Definition at line 427 of file at32f435_437_dvp.c.

◆ dvp_enhanced_scaling_resize_enable()

void dvp_enhanced_scaling_resize_enable ( confirm_state new_state )

set dvp enhanced image scaling resize enable

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 399 of file at32f435_437_dvp.c.

◆ dvp_enhanced_scaling_resize_set()

void dvp_enhanced_scaling_resize_set | ( | uint16_t | src_w,
 |  | uint16_t | des_w,
 |  | uint16_t | src_h,
 |  | uint16_t | des_h
 | ) |  |

set dvp enhanced image scaling resize configuration

Parameters
src_w(0x0001~0x1FFF) | horizontal scaling resize source size (source image width)
des_w(0x0001~0x1FFF) | horizontal scaling resize target size (target image width)
src_h(0x0001~0x1FFF) | vertical scaling resize source size (source image height)
des_h(0x0001~0x1FFF) | vertical scaling resize target size (target image height)
Return values
none

Definition at line 411 of file at32f435_437_dvp.c.

◆ dvp_flag_clear()

void dvp_flag_clear ( uint32_t flag )

clear dvp's pending flags

Parameters
flag this parameter can be one of the following values: event flag:
  • DVP_CFD_EVT_FLAG
  • DVP_OVR_EVT_FLAG
  • DVP_ESE_EVT_FLAG
  • DVP_VS_EVT_FLAG
  • DVP_HS_EVT_FLAG interrupt flag:
  • DVP_CFD_INT_FLAG
  • DVP_OVR_INT_FLAG
  • DVP_ESE_INT_FLAG
  • DVP_VS_INT_FLAG
  • DVP_HS_INT_FLAG
Return values
none

Definition at line 388 of file at32f435_437_dvp.c.

Referenced by dvp_int_handler().

◆ dvp_flag_get()

flag_status dvp_flag_get ( uint32_t flag )

get dvp event/interrupt flag status

Parameters
flag this parameter can be one of the following values: event flag:
  • DVP_CFD_EVT_FLAG
  • DVP_OVR_EVT_FLAG
  • DVP_ESE_EVT_FLAG
  • DVP_VS_EVT_FLAG
  • DVP_HS_EVT_FLAG interrupt flag:
  • DVP_CFD_INT_FLAG
  • DVP_OVR_INT_FLAG
  • DVP_ESE_INT_FLAG
  • DVP_VS_INT_FLAG
  • DVP_HS_INT_FLAG
Return values
flag_status (SET or RESET)

Definition at line 342 of file at32f435_437_dvp.c.

Referenced by dvp_int_handler().

◆ dvp_hsync_polarity_set()

void dvp_hsync_polarity_set ( dvp_hsp_type hsync_pol )

set dvp horizontal synchronization polarity

Parameters
hsync_pol this parameter can be one of the following values:
  • DVP_HSYNC_POLARITY_HIGH
  • DVP_HSYNC_POLARITY_LOW
Return values
none

Definition at line 174 of file at32f435_437_dvp.c.

Referenced by dvp_config().

◆ dvp_input_data_unused_set()

void dvp_input_data_unused_set | ( | dvp_idus_type | dvp_idus,
 |  | dvp_idun_type | dvp_idun
 | ) |  |

set dvp input data un-used condition/number configuration

Parameters
dvp_idus input data un-used condition this parameter can be one of the following values:
  • DVP_IDUS_MSB
  • DVP_IDUS_LSB
dvp_idun input data un-used number this parameter can be one of the following values:
  • DVP_IDUN_0
  • DVP_IDUN_2
  • DVP_IDUN_4
  • DVP_IDUN_6
Return values
none

Definition at line 479 of file at32f435_437_dvp.c.

◆ dvp_interrupt_enable()

void dvp_interrupt_enable | ( | uint32_t | dvp_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dvp interrupt

Parameters
dvp_int this parameter can be any combination of the following values:
  • DVP_CFD_INT
  • DVP_OVR_INT
  • DVP_ESE_INT
  • DVP_VS_INT
  • DVP_HS_INT
new_state (TRUE or FALSE)
Return values
none

Definition at line 312 of file at32f435_437_dvp.c.

Referenced by dvp_config().

◆ dvp_jpeg_enable()

void dvp_jpeg_enable ( confirm_state new_state )

enable or disable dvp jpeg

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 109 of file at32f435_437_dvp.c.

◆ dvp_monochrome_image_binarization_set()

void dvp_monochrome_image_binarization_set | ( | uint8_t | mibthd,
 |  | confirm_state | new_state
 | ) |  |

set dvp monochrome image binarization configuration

Parameters
mibthd(0x00~0xFF) | monochrome image binarization threshold
new_state | (TRUE or FALSE)
Return values
none

Definition at line 443 of file at32f435_437_dvp.c.

◆ dvp_pclk_polarity_set()

void dvp_pclk_polarity_set ( dvp_ckp_type edge )

set dvp pixel clock polarity

Parameters
edge this parameter can be one of the following values:
  • DVP_CLK_POLARITY_RISING
  • DVP_CLK_POLARITY_FALLING
Return values
none

Definition at line 161 of file at32f435_437_dvp.c.

Referenced by dvp_config().

◆ dvp_pixel_data_length_set()

void dvp_pixel_data_length_set ( dvp_pdl_type dvp_pdl )

config dvp pixel data length

Parameters
dvp_pdl this parameter can be one of the following values:
  • DVP_PIXEL_DATA_LENGTH_8
  • DVP_PIXEL_DATA_LENGTH_10
  • DVP_PIXEL_DATA_LENGTH_12
  • DVP_PIXEL_DATA_LENGTH_14
Return values
none

Definition at line 217 of file at32f435_437_dvp.c.

Referenced by dvp_config().

◆ dvp_reset()

void dvp_reset ( void )

reset the dvp register

Parameters
none
Return values
none

Definition at line 49 of file at32f435_437_dvp.c.

◆ dvp_sync_code_set()

void dvp_sync_code_set | ( | uint8_t | fmsc,
 |  | uint8_t | fmec,
 |  | uint8_t | lnsc,
 |  | uint8_t | lnec
 | ) |  |

set dvp synchronization code configuration

Parameters
fmsc(0x00~0xFF) | frame start code
fmec(0x00~0xFF) | frame end code
lnsc(0x00~0xFF) | line start code
lnec(0x00~0xFF) | line end code
Return values
none

Definition at line 135 of file at32f435_437_dvp.c.

Referenced by dvp_config().

◆ dvp_sync_event_interrupt_set()

void dvp_sync_event_interrupt_set | ( | dvp_hseid_type | dvp_hseid,
 |  | dvp_vseid_type | dvp_vseid
 | ) |  |

set dvp hsync/vsync event interrupt strategy configuration

Parameters
dvp_hseid hsync event interrupt strategy this parameter can be one of the following values:
  • DVP_HSEID_LINE_END
  • DVP_HSEID_LINE_START
dvp_vseid vsync event interrupt strategy this parameter can be one of the following values:
  • DVP_VSEID_FRAME_END
  • DVP_VSEID_FRMAE_START
Return values
none

Definition at line 510 of file at32f435_437_dvp.c.

◆ dvp_sync_mode_set()

void dvp_sync_mode_set ( dvp_sm_type sync_mode )

set dvp synchronization mode

Parameters
sync_mode this parameter can be one of the following values:
  • DVP_SYNC_MODE_HARDWARE
  • DVP_SYNC_MODE_EMBEDDED
Return values
none

Definition at line 122 of file at32f435_437_dvp.c.

Referenced by dvp_config().

◆ dvp_sync_unmask_set()

void dvp_sync_unmask_set | ( | uint8_t | fmsu,
 |  | uint8_t | fmeu,
 |  | uint8_t | lnsu,
 |  | uint8_t | lneu
 | ) |  |

set dvp synchronization unmask configuration

Parameters
fmsu(0x00~0xFF) | frame start unmask
fmeu(0x00~0xFF) | frame end unmask
lnsu(0x00~0xFF) | line start unmask
lneu(0x00~0xFF) | line end unmask
Return values
none

Definition at line 148 of file at32f435_437_dvp.c.

◆ dvp_vsync_polarity_set()

void dvp_vsync_polarity_set ( dvp_vsp_type vsync_pol )

set dvp vertical synchronization polarity

Parameters
vsync_pol this parameter can be one of the following values:
  • DVP_VSYNC_POLARITY_LOW
  • DVP_VSYNC_POLARITY_HIGH
Return values
none

Definition at line 187 of file at32f435_437_dvp.c.

Referenced by dvp_config().

◆ dvp_window_crop_enable()

void dvp_window_crop_enable ( confirm_state new_state )

set dvp cropping window enable

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 83 of file at32f435_437_dvp.c.

◆ dvp_window_crop_set()

void dvp_window_crop_set | ( | uint16_t | crop_x,
 |  | uint16_t | crop_y,
 |  | uint16_t | crop_w,
 |  | uint16_t | crop_h,
 |  | uint8_t | bytes
 | ) |  |

set dvp cropping window configuration

Parameters
crop_x | cropping window horizontal start pixel
crop_y | cropping window vertical start line
crop_w | cropping window horizontal pixel number
crop_h | cropping window vertical line number
bytes | the number of bytes corresponding to one pixel eg. y8:bytes = 1, rgb565:bytes = 2
Return values
none

Definition at line 98 of file at32f435_437_dvp.c.

◆ dvp_zoomout_select()

void dvp_zoomout_select ( dvp_pcdes_type dvp_pcdes )

set dvp zoomout select

Parameters
dvp_pcdes pixel capture/drop selection extension (Only work when pcdc = 2) this parameter can be one of the following values:
  • DVP_PCDES_CAP_FIRST
  • DVP_PCDES_DROP_FIRST
Return values
none

Definition at line 240 of file at32f435_437_dvp.c.

Referenced by dvp_config().

◆ dvp_zoomout_set()

void dvp_zoomout_set | ( | dvp_pcdc_type | dvp_pcdc,
 |  | dvp_pcds_type | dvp_pcds,
 |  | dvp_lcdc_type | dvp_lcdc,
 |  | dvp_lcds_type | dvp_lcds
 | ) |  |

set dvp zoomout configuration

Parameters
dvp_pcdc basic pixel capture/drop control this parameter can be one of the following values:
  • DVP_PCDC_ALL
  • DVP_PCDC_ONE_IN_TWO
  • DVP_PCDC_ONE_IN_FOUR
  • DVP_PCDC_TWO_IN_FOUR
dvp_pcds pixel capture/drop selection this parameter can be one of the following values:
  • DVP_PCDS_CAP_FIRST
  • DVP_PCDS_DROP_FIRST
dvp_lcdc line capture/drop control this parameter can be one of the following values:
  • DVP_LCDC_ALL
  • DVP_LCDC_ONE_IN_TWO
dvp_lcds line capture/drop selection this parameter can be one of the following values:
  • DVP_LCDS_CAP_FIRST
  • DVP_LCDS_DROP_FIRST
Return values
none

Definition at line 267 of file at32f435_437_dvp.c.

Referenced by dvp_config().


AT32F435/437 Firmwary Library: DVP_private_functions

Functions
DVP_private_functions
AT32F435_437_periph_driver » DVP

Functions

void | dvp_reset (void)
reset the dvp register More...
void | dvp_capture_enable (confirm_state new_state)
enable or disable dvp capture More...
void | dvp_capture_mode_set (dvp_cfm_type cap_mode)
set dvp capture mode More...
void | dvp_window_crop_enable (confirm_state new_state)
set dvp cropping window enable More...
void | dvp_window_crop_set (uint16_t crop_x, uint16_t crop_y, uint16_t crop_w, uint16_t crop_h, uint8_t bytes)
set dvp cropping window configuration More...
void | dvp_jpeg_enable (confirm_state new_state)
enable or disable dvp jpeg More...
void | dvp_sync_mode_set (dvp_sm_type sync_mode)
set dvp synchronization mode More...
void | dvp_sync_code_set (uint8_t fmsc, uint8_t fmec, uint8_t lnsc, uint8_t lnec)
set dvp synchronization code configuration More...
void | dvp_sync_unmask_set (uint8_t fmsu, uint8_t fmeu, uint8_t lnsu, uint8_t lneu)
set dvp synchronization unmask configuration More...
void | dvp_pclk_polarity_set (dvp_ckp_type edge)
set dvp pixel clock polarity More...
void | dvp_hsync_polarity_set (dvp_hsp_type hsync_pol)
set dvp horizontal synchronization polarity More...
void | dvp_vsync_polarity_set (dvp_vsp_type vsync_pol)
set dvp vertical synchronization polarity More...
void | dvp_basic_frame_rate_control_set (dvp_bfrc_type dvp_bfrc)
config dvp basic frame rate control More...
void | dvp_pixel_data_length_set (dvp_pdl_type dvp_pdl)
config dvp pixel data length More...
void | dvp_enable (confirm_state new_state)
enable or disable dvp function More...
void | dvp_zoomout_select (dvp_pcdes_type dvp_pcdes)
set dvp zoomout select More...
void | dvp_zoomout_set (dvp_pcdc_type dvp_pcdc, dvp_pcds_type dvp_pcds, dvp_lcdc_type dvp_lcdc, dvp_lcds_type dvp_lcds)
set dvp zoomout configuration More...
flag_status | dvp_basic_status_get (dvp_status_basic_type dvp_status_basic)
get dvp basic status More...
void | dvp_interrupt_enable (uint32_t dvp_int, confirm_state new_state)
enable or disable dvp interrupt More...
flag_status | dvp_flag_get (uint32_t flag)
get dvp event/interrupt flag status More...
void | dvp_flag_clear (uint32_t flag)
clear dvp's pending flags More...
void | dvp_enhanced_scaling_resize_enable (confirm_state new_state)
set dvp enhanced image scaling resize enable More...
void | dvp_enhanced_scaling_resize_set (uint16_t src_w, uint16_t des_w, uint16_t src_h, uint16_t des_h)
set dvp enhanced image scaling resize configuration More...
void | dvp_enhanced_framerate_set (uint16_t efrcsf, uint16_t efrctf, confirm_state new_state)
set enhanced frame rate control configuration More...
void | dvp_monochrome_image_binarization_set (uint8_t mibthd, confirm_state new_state)
set dvp monochrome image binarization configuration More...
void | dvp_enhanced_data_format_set (dvp_efdf_type dvp_efdf)
set dvp enhanced function data format configuration More...
void | dvp_input_data_unused_set (dvp_idus_type dvp_idus, dvp_idun_type dvp_idun)
set dvp input data un-used condition/number configuration More...
void | dvp_dma_burst_set (dvp_dmabt_type dvp_dmabt)
set dvp dma burst transfer configuration More...
void | dvp_sync_event_interrupt_set (dvp_hseid_type dvp_hseid, dvp_vseid_type dvp_vseid)
set dvp hsync/vsync event interrupt strategy configuration More...

Detailed Description

Function Documentation

◆ dvp_basic_frame_rate_control_set()

void dvp_basic_frame_rate_control_set ( dvp_bfrc_type dvp_bfrc )

config dvp basic frame rate control

Note
this function only work in continuous fire mode(ctrl_bit.cfm = 0)
Parameters
dvp_bfrc this parameter can be one of the following values:
  • DVP_BFRC_ALL
  • DVP_BFRC_HALF
  • DVP_BFRC_QUARTER
Return values
none

Definition at line 202 of file at32f435_437_dvp.c.

◆ dvp_basic_status_get()

flag_status dvp_basic_status_get ( dvp_status_basic_type dvp_status_basic )

get dvp basic status

Parameters
dvp_status_basic_type this parameter can be one of the following values:
  • DVP_STATUS_HSYN
  • DVP_STATUS_VSYN
  • DVP_STATUS_OFNE
Return values
flag_status (SET or RESET)

Definition at line 284 of file at32f435_437_dvp.c.

◆ dvp_capture_enable()

void dvp_capture_enable ( confirm_state new_state )

enable or disable dvp capture

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 60 of file at32f435_437_dvp.c.

Referenced by dvp_start(), and dvp_stop().

◆ dvp_capture_mode_set()

void dvp_capture_mode_set ( dvp_cfm_type cap_mode )

set dvp capture mode

Parameters
cap_mode this parameter can be one of the following values:
  • DVP_CAP_FUNC_MODE_CONTINUOUS
  • DVP_CAP_FUNC_MODE_SINGLE
Return values
none

Definition at line 73 of file at32f435_437_dvp.c.

Referenced by dvp_config().

◆ dvp_dma_burst_set()

void dvp_dma_burst_set ( dvp_dmabt_type dvp_dmabt )

set dvp dma burst transfer configuration

Parameters
dvp_dmabt dma burst transfer configuration this parameter can be one of the following values:
  • DVP_DMABT_SINGLE
  • DVP_DMABT_BURST
Return values
none

Definition at line 493 of file at32f435_437_dvp.c.

◆ dvp_enable()

void dvp_enable ( confirm_state new_state )

enable or disable dvp function

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 227 of file at32f435_437_dvp.c.

Referenced by dvp_config().

◆ dvp_enhanced_data_format_set()

void dvp_enhanced_data_format_set ( dvp_efdf_type dvp_efdf )

set dvp enhanced function data format configuration

Parameters
dvp_efdf enhanced function data format this parameter can be one of the following values:
  • DVP_EFDF_BYPASS
  • DVP_EFDF_YUV422_UYVY
  • DVP_EFDF_YUV422_YUYV
  • DVP_EFDF_RGB565_555
  • DVP_EFDF_Y8
Return values
none

Definition at line 460 of file at32f435_437_dvp.c.

◆ dvp_enhanced_framerate_set()

void dvp_enhanced_framerate_set | ( | uint16_t | efrcsf,
 |  | uint16_t | efrctf,
 |  | confirm_state | new_state
 | ) |  |

set enhanced frame rate control configuration

Parameters
efrcsf(0x00~0x1F) | original frame rate contorl factor
efrctf(0x00~0x1F) | enhanced frame rate contorl factor
new_state | (TRUE or FALSE)
Return values
none

Definition at line 427 of file at32f435_437_dvp.c.

◆ dvp_enhanced_scaling_resize_enable()

void dvp_enhanced_scaling_resize_enable ( confirm_state new_state )

set dvp enhanced image scaling resize enable

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 399 of file at32f435_437_dvp.c.

◆ dvp_enhanced_scaling_resize_set()

void dvp_enhanced_scaling_resize_set | ( | uint16_t | src_w,
 |  | uint16_t | des_w,
 |  | uint16_t | src_h,
 |  | uint16_t | des_h
 | ) |  |

set dvp enhanced image scaling resize configuration

Parameters
src_w(0x0001~0x1FFF) | horizontal scaling resize source size (source image width)
des_w(0x0001~0x1FFF) | horizontal scaling resize target size (target image width)
src_h(0x0001~0x1FFF) | vertical scaling resize source size (source image height)
des_h(0x0001~0x1FFF) | vertical scaling resize target size (target image height)
Return values
none

Definition at line 411 of file at32f435_437_dvp.c.

◆ dvp_flag_clear()

void dvp_flag_clear ( uint32_t flag )

clear dvp's pending flags

Parameters
flag this parameter can be one of the following values: event flag:
  • DVP_CFD_EVT_FLAG
  • DVP_OVR_EVT_FLAG
  • DVP_ESE_EVT_FLAG
  • DVP_VS_EVT_FLAG
  • DVP_HS_EVT_FLAG interrupt flag:
  • DVP_CFD_INT_FLAG
  • DVP_OVR_INT_FLAG
  • DVP_ESE_INT_FLAG
  • DVP_VS_INT_FLAG
  • DVP_HS_INT_FLAG
Return values
none

Definition at line 388 of file at32f435_437_dvp.c.

Referenced by dvp_int_handler().

◆ dvp_flag_get()

flag_status dvp_flag_get ( uint32_t flag )

get dvp event/interrupt flag status

Parameters
flag this parameter can be one of the following values: event flag:
  • DVP_CFD_EVT_FLAG
  • DVP_OVR_EVT_FLAG
  • DVP_ESE_EVT_FLAG
  • DVP_VS_EVT_FLAG
  • DVP_HS_EVT_FLAG interrupt flag:
  • DVP_CFD_INT_FLAG
  • DVP_OVR_INT_FLAG
  • DVP_ESE_INT_FLAG
  • DVP_VS_INT_FLAG
  • DVP_HS_INT_FLAG
Return values
flag_status (SET or RESET)

Definition at line 342 of file at32f435_437_dvp.c.

Referenced by dvp_int_handler().

◆ dvp_hsync_polarity_set()

void dvp_hsync_polarity_set ( dvp_hsp_type hsync_pol )

set dvp horizontal synchronization polarity

Parameters
hsync_pol this parameter can be one of the following values:
  • DVP_HSYNC_POLARITY_HIGH
  • DVP_HSYNC_POLARITY_LOW
Return values
none

Definition at line 174 of file at32f435_437_dvp.c.

Referenced by dvp_config().

◆ dvp_input_data_unused_set()

void dvp_input_data_unused_set | ( | dvp_idus_type | dvp_idus,
 |  | dvp_idun_type | dvp_idun
 | ) |  |

set dvp input data un-used condition/number configuration

Parameters
dvp_idus input data un-used condition this parameter can be one of the following values:
  • DVP_IDUS_MSB
  • DVP_IDUS_LSB
dvp_idun input data un-used number this parameter can be one of the following values:
  • DVP_IDUN_0
  • DVP_IDUN_2
  • DVP_IDUN_4
  • DVP_IDUN_6
Return values
none

Definition at line 479 of file at32f435_437_dvp.c.

◆ dvp_interrupt_enable()

void dvp_interrupt_enable | ( | uint32_t | dvp_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dvp interrupt

Parameters
dvp_int this parameter can be any combination of the following values:
  • DVP_CFD_INT
  • DVP_OVR_INT
  • DVP_ESE_INT
  • DVP_VS_INT
  • DVP_HS_INT
new_state (TRUE or FALSE)
Return values
none

Definition at line 312 of file at32f435_437_dvp.c.

Referenced by dvp_config().

◆ dvp_jpeg_enable()

void dvp_jpeg_enable ( confirm_state new_state )

enable or disable dvp jpeg

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 109 of file at32f435_437_dvp.c.

◆ dvp_monochrome_image_binarization_set()

void dvp_monochrome_image_binarization_set | ( | uint8_t | mibthd,
 |  | confirm_state | new_state
 | ) |  |

set dvp monochrome image binarization configuration

Parameters
mibthd(0x00~0xFF) | monochrome image binarization threshold
new_state | (TRUE or FALSE)
Return values
none

Definition at line 443 of file at32f435_437_dvp.c.

◆ dvp_pclk_polarity_set()

void dvp_pclk_polarity_set ( dvp_ckp_type edge )

set dvp pixel clock polarity

Parameters
edge this parameter can be one of the following values:
  • DVP_CLK_POLARITY_RISING
  • DVP_CLK_POLARITY_FALLING
Return values
none

Definition at line 161 of file at32f435_437_dvp.c.

Referenced by dvp_config().

◆ dvp_pixel_data_length_set()

void dvp_pixel_data_length_set ( dvp_pdl_type dvp_pdl )

config dvp pixel data length

Parameters
dvp_pdl this parameter can be one of the following values:
  • DVP_PIXEL_DATA_LENGTH_8
  • DVP_PIXEL_DATA_LENGTH_10
  • DVP_PIXEL_DATA_LENGTH_12
  • DVP_PIXEL_DATA_LENGTH_14
Return values
none

Definition at line 217 of file at32f435_437_dvp.c.

Referenced by dvp_config().

◆ dvp_reset()

void dvp_reset ( void )

reset the dvp register

Parameters
none
Return values
none

Definition at line 49 of file at32f435_437_dvp.c.

◆ dvp_sync_code_set()

void dvp_sync_code_set | ( | uint8_t | fmsc,
 |  | uint8_t | fmec,
 |  | uint8_t | lnsc,
 |  | uint8_t | lnec
 | ) |  |

set dvp synchronization code configuration

Parameters
fmsc(0x00~0xFF) | frame start code
fmec(0x00~0xFF) | frame end code
lnsc(0x00~0xFF) | line start code
lnec(0x00~0xFF) | line end code
Return values
none

Definition at line 135 of file at32f435_437_dvp.c.

Referenced by dvp_config().

◆ dvp_sync_event_interrupt_set()

void dvp_sync_event_interrupt_set | ( | dvp_hseid_type | dvp_hseid,
 |  | dvp_vseid_type | dvp_vseid
 | ) |  |

set dvp hsync/vsync event interrupt strategy configuration

Parameters
dvp_hseid hsync event interrupt strategy this parameter can be one of the following values:
  • DVP_HSEID_LINE_END
  • DVP_HSEID_LINE_START
dvp_vseid vsync event interrupt strategy this parameter can be one of the following values:
  • DVP_VSEID_FRAME_END
  • DVP_VSEID_FRMAE_START
Return values
none

Definition at line 510 of file at32f435_437_dvp.c.

◆ dvp_sync_mode_set()

void dvp_sync_mode_set ( dvp_sm_type sync_mode )

set dvp synchronization mode

Parameters
sync_mode this parameter can be one of the following values:
  • DVP_SYNC_MODE_HARDWARE
  • DVP_SYNC_MODE_EMBEDDED
Return values
none

Definition at line 122 of file at32f435_437_dvp.c.

Referenced by dvp_config().

◆ dvp_sync_unmask_set()

void dvp_sync_unmask_set | ( | uint8_t | fmsu,
 |  | uint8_t | fmeu,
 |  | uint8_t | lnsu,
 |  | uint8_t | lneu
 | ) |  |

set dvp synchronization unmask configuration

Parameters
fmsu(0x00~0xFF) | frame start unmask
fmeu(0x00~0xFF) | frame end unmask
lnsu(0x00~0xFF) | line start unmask
lneu(0x00~0xFF) | line end unmask
Return values
none

Definition at line 148 of file at32f435_437_dvp.c.

◆ dvp_vsync_polarity_set()

void dvp_vsync_polarity_set ( dvp_vsp_type vsync_pol )

set dvp vertical synchronization polarity

Parameters
vsync_pol this parameter can be one of the following values:
  • DVP_VSYNC_POLARITY_LOW
  • DVP_VSYNC_POLARITY_HIGH
Return values
none

Definition at line 187 of file at32f435_437_dvp.c.

Referenced by dvp_config().

◆ dvp_window_crop_enable()

void dvp_window_crop_enable ( confirm_state new_state )

set dvp cropping window enable

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 83 of file at32f435_437_dvp.c.

◆ dvp_window_crop_set()

void dvp_window_crop_set | ( | uint16_t | crop_x,
 |  | uint16_t | crop_y,
 |  | uint16_t | crop_w,
 |  | uint16_t | crop_h,
 |  | uint8_t | bytes
 | ) |  |

set dvp cropping window configuration

Parameters
crop_x | cropping window horizontal start pixel
crop_y | cropping window vertical start line
crop_w | cropping window horizontal pixel number
crop_h | cropping window vertical line number
bytes | the number of bytes corresponding to one pixel eg. y8:bytes = 1, rgb565:bytes = 2
Return values
none

Definition at line 98 of file at32f435_437_dvp.c.

◆ dvp_zoomout_select()

void dvp_zoomout_select ( dvp_pcdes_type dvp_pcdes )

set dvp zoomout select

Parameters
dvp_pcdes pixel capture/drop selection extension (Only work when pcdc = 2) this parameter can be one of the following values:
  • DVP_PCDES_CAP_FIRST
  • DVP_PCDES_DROP_FIRST
Return values
none

Definition at line 240 of file at32f435_437_dvp.c.

Referenced by dvp_config().

◆ dvp_zoomout_set()

void dvp_zoomout_set | ( | dvp_pcdc_type | dvp_pcdc,
 |  | dvp_pcds_type | dvp_pcds,
 |  | dvp_lcdc_type | dvp_lcdc,
 |  | dvp_lcds_type | dvp_lcds
 | ) |  |

set dvp zoomout configuration

Parameters
dvp_pcdc basic pixel capture/drop control this parameter can be one of the following values:
  • DVP_PCDC_ALL
  • DVP_PCDC_ONE_IN_TWO
  • DVP_PCDC_ONE_IN_FOUR
  • DVP_PCDC_TWO_IN_FOUR
dvp_pcds pixel capture/drop selection this parameter can be one of the following values:
  • DVP_PCDS_CAP_FIRST
  • DVP_PCDS_DROP_FIRST
dvp_lcdc line capture/drop control this parameter can be one of the following values:
  • DVP_LCDC_ALL
  • DVP_LCDC_ONE_IN_TWO
dvp_lcds line capture/drop selection this parameter can be one of the following values:
  • DVP_LCDS_CAP_FIRST
  • DVP_LCDS_DROP_FIRST
Return values
none

Definition at line 267 of file at32f435_437_dvp.c.

Referenced by dvp_config().


AT32F435/437 Firmwary Library: EDMA

Modules | Macros
EDMA
AT32F435_437_periph_driver

EDMA driver modules. More...

Modules

EDMA_interrupts_definition
edma interrupt
EDMA_flags_definition
edma flag
EDMA_exported_types
EDMA_exported_functions
EDMA_private_functions

Macros

#define | EDMA ((edma_type *) EDMA_BASE)
#define | EDMA_STREAM1 ((edma_stream_type *) EDMA_STREAM1_BASE)
#define | EDMA_STREAM2 ((edma_stream_type *) EDMA_STREAM2_BASE)
#define | EDMA_STREAM3 ((edma_stream_type *) EDMA_STREAM3_BASE)
#define | EDMA_STREAM4 ((edma_stream_type *) EDMA_STREAM4_BASE)
#define | EDMA_STREAM5 ((edma_stream_type *) EDMA_STREAM5_BASE)
#define | EDMA_STREAM6 ((edma_stream_type *) EDMA_STREAM6_BASE)
#define | EDMA_STREAM7 ((edma_stream_type *) EDMA_STREAM7_BASE)
#define | EDMA_STREAM8 ((edma_stream_type *) EDMA_STREAM8_BASE)
#define | EDMA_STREAM1_2D ((edma_stream_2d_type *) EDMA_STREAM1_2D_BASE)
#define | EDMA_STREAM2_2D ((edma_stream_2d_type *) EDMA_STREAM2_2D_BASE)
#define | EDMA_STREAM3_2D ((edma_stream_2d_type *) EDMA_STREAM3_2D_BASE)
#define | EDMA_STREAM4_2D ((edma_stream_2d_type *) EDMA_STREAM4_2D_BASE)
#define | EDMA_STREAM5_2D ((edma_stream_2d_type *) EDMA_STREAM5_2D_BASE)
#define | EDMA_STREAM6_2D ((edma_stream_2d_type *) EDMA_STREAM6_2D_BASE)
#define | EDMA_STREAM7_2D ((edma_stream_2d_type *) EDMA_STREAM7_2D_BASE)
#define | EDMA_STREAM8_2D ((edma_stream_2d_type *) EDMA_STREAM8_2D_BASE)
#define | EDMA_STREAM1_LL ((edma_stream_link_list_type *) EDMA_STREAM1_LL_BASE)
#define | EDMA_STREAM2_LL ((edma_stream_link_list_type *) EDMA_STREAM2_LL_BASE)
#define | EDMA_STREAM3_LL ((edma_stream_link_list_type *) EDMA_STREAM3_LL_BASE)
#define | EDMA_STREAM4_LL ((edma_stream_link_list_type *) EDMA_STREAM4_LL_BASE)
#define | EDMA_STREAM5_LL ((edma_stream_link_list_type *) EDMA_STREAM5_LL_BASE)
#define | EDMA_STREAM6_LL ((edma_stream_link_list_type *) EDMA_STREAM6_LL_BASE)
#define | EDMA_STREAM7_LL ((edma_stream_link_list_type *) EDMA_STREAM7_LL_BASE)
#define | EDMA_STREAM8_LL ((edma_stream_link_list_type *) EDMA_STREAM8_LL_BASE)
#define | EDMAMUX_CHANNEL1 ((edmamux_channel_type *) EDMAMUX_CHANNEL1_BASE)
#define | EDMAMUX_CHANNEL2 ((edmamux_channel_type *) EDMAMUX_CHANNEL2_BASE)
#define | EDMAMUX_CHANNEL3 ((edmamux_channel_type *) EDMAMUX_CHANNEL3_BASE)
#define | EDMAMUX_CHANNEL4 ((edmamux_channel_type *) EDMAMUX_CHANNEL4_BASE)
#define | EDMAMUX_CHANNEL5 ((edmamux_channel_type *) EDMAMUX_CHANNEL5_BASE)
#define | EDMAMUX_CHANNEL6 ((edmamux_channel_type *) EDMAMUX_CHANNEL6_BASE)
#define | EDMAMUX_CHANNEL7 ((edmamux_channel_type *) EDMAMUX_CHANNEL7_BASE)
#define | EDMAMUX_CHANNEL8 ((edmamux_channel_type *) EDMAMUX_CHANNEL8_BASE)
#define | EDMAMUX_GENERATOR1 ((edmamux_generator_type *) EDMAMUX_GENERATOR1_BASE)
#define | EDMAMUX_GENERATOR2 ((edmamux_generator_type *) EDMAMUX_GENERATOR2_BASE)
#define | EDMAMUX_GENERATOR3 ((edmamux_generator_type *) EDMAMUX_GENERATOR3_BASE)
#define | EDMAMUX_GENERATOR4 ((edmamux_generator_type *) EDMAMUX_GENERATOR4_BASE)

Detailed Description

EDMA driver modules.

Macro Definition Documentation

◆ EDMA

#define EDMA ((edma_type *) EDMA_BASE)

Definition at line 961 of file at32f435_437_edma.h.

◆ EDMA_STREAM1

#define EDMA_STREAM1 ((edma_stream_type *) EDMA_STREAM1_BASE)

Definition at line 962 of file at32f435_437_edma.h.

◆ EDMA_STREAM1_2D

#define EDMA_STREAM1_2D ((edma_stream_2d_type *) EDMA_STREAM1_2D_BASE)

Definition at line 971 of file at32f435_437_edma.h.

◆ EDMA_STREAM1_LL

#define EDMA_STREAM1_LL ((edma_stream_link_list_type *) EDMA_STREAM1_LL_BASE)

Definition at line 980 of file at32f435_437_edma.h.

◆ EDMA_STREAM2

#define EDMA_STREAM2 ((edma_stream_type *) EDMA_STREAM2_BASE)

Definition at line 963 of file at32f435_437_edma.h.

◆ EDMA_STREAM2_2D

#define EDMA_STREAM2_2D ((edma_stream_2d_type *) EDMA_STREAM2_2D_BASE)

Definition at line 972 of file at32f435_437_edma.h.

◆ EDMA_STREAM2_LL

#define EDMA_STREAM2_LL ((edma_stream_link_list_type *) EDMA_STREAM2_LL_BASE)

Definition at line 981 of file at32f435_437_edma.h.

◆ EDMA_STREAM3

#define EDMA_STREAM3 ((edma_stream_type *) EDMA_STREAM3_BASE)

Definition at line 964 of file at32f435_437_edma.h.

◆ EDMA_STREAM3_2D

#define EDMA_STREAM3_2D ((edma_stream_2d_type *) EDMA_STREAM3_2D_BASE)

Definition at line 973 of file at32f435_437_edma.h.

◆ EDMA_STREAM3_LL

#define EDMA_STREAM3_LL ((edma_stream_link_list_type *) EDMA_STREAM3_LL_BASE)

Definition at line 982 of file at32f435_437_edma.h.

◆ EDMA_STREAM4

#define EDMA_STREAM4 ((edma_stream_type *) EDMA_STREAM4_BASE)

Definition at line 965 of file at32f435_437_edma.h.

◆ EDMA_STREAM4_2D

#define EDMA_STREAM4_2D ((edma_stream_2d_type *) EDMA_STREAM4_2D_BASE)

Definition at line 974 of file at32f435_437_edma.h.

◆ EDMA_STREAM4_LL

#define EDMA_STREAM4_LL ((edma_stream_link_list_type *) EDMA_STREAM4_LL_BASE)

Definition at line 983 of file at32f435_437_edma.h.

◆ EDMA_STREAM5

#define EDMA_STREAM5 ((edma_stream_type *) EDMA_STREAM5_BASE)

Definition at line 966 of file at32f435_437_edma.h.

◆ EDMA_STREAM5_2D

#define EDMA_STREAM5_2D ((edma_stream_2d_type *) EDMA_STREAM5_2D_BASE)

Definition at line 975 of file at32f435_437_edma.h.

◆ EDMA_STREAM5_LL

#define EDMA_STREAM5_LL ((edma_stream_link_list_type *) EDMA_STREAM5_LL_BASE)

Definition at line 984 of file at32f435_437_edma.h.

◆ EDMA_STREAM6

#define EDMA_STREAM6 ((edma_stream_type *) EDMA_STREAM6_BASE)

Definition at line 967 of file at32f435_437_edma.h.

◆ EDMA_STREAM6_2D

#define EDMA_STREAM6_2D ((edma_stream_2d_type *) EDMA_STREAM6_2D_BASE)

Definition at line 976 of file at32f435_437_edma.h.

◆ EDMA_STREAM6_LL

#define EDMA_STREAM6_LL ((edma_stream_link_list_type *) EDMA_STREAM6_LL_BASE)

Definition at line 985 of file at32f435_437_edma.h.

◆ EDMA_STREAM7

#define EDMA_STREAM7 ((edma_stream_type *) EDMA_STREAM7_BASE)

Definition at line 968 of file at32f435_437_edma.h.

◆ EDMA_STREAM7_2D

#define EDMA_STREAM7_2D ((edma_stream_2d_type *) EDMA_STREAM7_2D_BASE)

Definition at line 977 of file at32f435_437_edma.h.

◆ EDMA_STREAM7_LL

#define EDMA_STREAM7_LL ((edma_stream_link_list_type *) EDMA_STREAM7_LL_BASE)

Definition at line 986 of file at32f435_437_edma.h.

◆ EDMA_STREAM8

#define EDMA_STREAM8 ((edma_stream_type *) EDMA_STREAM8_BASE)

Definition at line 969 of file at32f435_437_edma.h.

◆ EDMA_STREAM8_2D

#define EDMA_STREAM8_2D ((edma_stream_2d_type *) EDMA_STREAM8_2D_BASE)

Definition at line 978 of file at32f435_437_edma.h.

◆ EDMA_STREAM8_LL

#define EDMA_STREAM8_LL ((edma_stream_link_list_type *) EDMA_STREAM8_LL_BASE)

Definition at line 987 of file at32f435_437_edma.h.

◆ EDMAMUX_CHANNEL1

#define EDMAMUX_CHANNEL1 ((edmamux_channel_type *) EDMAMUX_CHANNEL1_BASE)

Definition at line 989 of file at32f435_437_edma.h.

◆ EDMAMUX_CHANNEL2

#define EDMAMUX_CHANNEL2 ((edmamux_channel_type *) EDMAMUX_CHANNEL2_BASE)

Definition at line 990 of file at32f435_437_edma.h.

◆ EDMAMUX_CHANNEL3

#define EDMAMUX_CHANNEL3 ((edmamux_channel_type *) EDMAMUX_CHANNEL3_BASE)

Definition at line 991 of file at32f435_437_edma.h.

◆ EDMAMUX_CHANNEL4

#define EDMAMUX_CHANNEL4 ((edmamux_channel_type *) EDMAMUX_CHANNEL4_BASE)

Definition at line 992 of file at32f435_437_edma.h.

◆ EDMAMUX_CHANNEL5

#define EDMAMUX_CHANNEL5 ((edmamux_channel_type *) EDMAMUX_CHANNEL5_BASE)

Definition at line 993 of file at32f435_437_edma.h.

◆ EDMAMUX_CHANNEL6

#define EDMAMUX_CHANNEL6 ((edmamux_channel_type *) EDMAMUX_CHANNEL6_BASE)

Definition at line 994 of file at32f435_437_edma.h.

◆ EDMAMUX_CHANNEL7

#define EDMAMUX_CHANNEL7 ((edmamux_channel_type *) EDMAMUX_CHANNEL7_BASE)

Definition at line 995 of file at32f435_437_edma.h.

◆ EDMAMUX_CHANNEL8

#define EDMAMUX_CHANNEL8 ((edmamux_channel_type *) EDMAMUX_CHANNEL8_BASE)

Definition at line 996 of file at32f435_437_edma.h.

◆ EDMAMUX_GENERATOR1

#define EDMAMUX_GENERATOR1 ((edmamux_generator_type *) EDMAMUX_GENERATOR1_BASE)

Definition at line 998 of file at32f435_437_edma.h.

◆ EDMAMUX_GENERATOR2

#define EDMAMUX_GENERATOR2 ((edmamux_generator_type *) EDMAMUX_GENERATOR2_BASE)

Definition at line 999 of file at32f435_437_edma.h.

◆ EDMAMUX_GENERATOR3

#define EDMAMUX_GENERATOR3 ((edmamux_generator_type *) EDMAMUX_GENERATOR3_BASE)

Definition at line 1000 of file at32f435_437_edma.h.

◆ EDMAMUX_GENERATOR4

#define EDMAMUX_GENERATOR4 ((edmamux_generator_type *) EDMAMUX_GENERATOR4_BASE)

Definition at line 1001 of file at32f435_437_edma.h.


AT32F435/437 Firmwary Library: EDMA_interrupts_definition

Macros
EDMA_interrupts_definition
AT32F435_437_periph_driver » EDMA

edma interrupt More...

Macros

#define | EDMA_DMERR_INT ((uint32_t)0x00000002) /* edma direct mode error intterrupt */
#define | EDMA_DTERR_INT ((uint32_t)0x00000004) /* edma data transfer error intterrupt */
#define | EDMA_HDT_INT ((uint32_t)0x00000008) /* edma half data transfer intterrupt */
#define | EDMA_FDT_INT ((uint32_t)0x00000010) /* edma full data transfer intterrupt */
#define | EDMA_FERR_INT ((uint32_t)0x00000080) /* edma fifo error interrupt */

Detailed Description

edma interrupt

Macro Definition Documentation

◆ EDMA_DMERR_INT

#define EDMA_DMERR_INT ((uint32_t)0x00000002) /* edma direct mode error intterrupt */

Definition at line 52 of file at32f435_437_edma.h.

◆ EDMA_DTERR_INT

#define EDMA_DTERR_INT ((uint32_t)0x00000004) /* edma data transfer error intterrupt */

Definition at line 53 of file at32f435_437_edma.h.

◆ EDMA_FDT_INT

#define EDMA_FDT_INT ((uint32_t)0x00000010) /* edma full data transfer intterrupt */

Definition at line 55 of file at32f435_437_edma.h.

◆ EDMA_FERR_INT

#define EDMA_FERR_INT ((uint32_t)0x00000080) /* edma fifo error interrupt */

Definition at line 56 of file at32f435_437_edma.h.

◆ EDMA_HDT_INT

#define EDMA_HDT_INT ((uint32_t)0x00000008) /* edma half data transfer intterrupt */

Definition at line 54 of file at32f435_437_edma.h.


AT32F435/437 Firmwary Library: EDMA_flags_definition

Macros
EDMA_flags_definition
AT32F435_437_periph_driver » EDMA

edma flag More...

Macros

#define | EDMA_FERR1_FLAG ((uint32_t)0x10000001) /* edma stream1 fifo error flag */
#define | EDMA_DMERR1_FLAG ((uint32_t)0x10000004) /* edma stream1 direct mode error flag */
#define | EDMA_DTERR1_FLAG ((uint32_t)0x10000008) /* edma stream1 data transfer error flag */
#define | EDMA_HDT1_FLAG ((uint32_t)0x10000010) /* edma stream1 half data transfer flag */
#define | EDMA_FDT1_FLAG ((uint32_t)0x10000020) /* edma stream1 full data transfer flag */
#define | EDMA_FERR2_FLAG ((uint32_t)0x10000040) /* edma stream2 fifo error flag */
#define | EDMA_DMERR2_FLAG ((uint32_t)0x10000100) /* edma stream2 direct mode error flag */
#define | EDMA_DTERR2_FLAG ((uint32_t)0x10000200) /* edma stream2 data transfer error flag */
#define | EDMA_HDT2_FLAG ((uint32_t)0x10000400) /* edma stream2 half data transfer flag */
#define | EDMA_FDT2_FLAG ((uint32_t)0x10000800) /* edma stream2 full data transfer flag */
#define | EDMA_FERR3_FLAG ((uint32_t)0x10010000) /* edma stream3 fifo error flag */
#define | EDMA_DMERR3_FLAG ((uint32_t)0x10040000) /* edma stream3 direct mode error flag */
#define | EDMA_DTERR3_FLAG ((uint32_t)0x10080000) /* edma stream3 data transfer error flag */
#define | EDMA_HDT3_FLAG ((uint32_t)0x10100000) /* edma stream3 half data transfer flag */
#define | EDMA_FDT3_FLAG ((uint32_t)0x10200000) /* edma stream3 full data transfer flag */
#define | EDMA_FERR4_FLAG ((uint32_t)0x10400000) /* edma stream4 fifo error flag */
#define | EDMA_DMERR4_FLAG ((uint32_t)0x11000000) /* edma stream4 direct mode error flag */
#define | EDMA_DTERR4_FLAG ((uint32_t)0x12000000) /* edma stream4 data transfer error flag */
#define | EDMA_HDT4_FLAG ((uint32_t)0x14000000) /* edma stream4 half data transfer flag */
#define | EDMA_FDT4_FLAG ((uint32_t)0x18000000) /* edma stream4 full data transfer flag */
#define | EDMA_FERR5_FLAG ((uint32_t)0x20000001) /* edma stream5 fifo error flag */
#define | EDMA_DMERR5_FLAG ((uint32_t)0x20000004) /* edma stream5 direct mode error flag */
#define | EDMA_DTERR5_FLAG ((uint32_t)0x20000008) /* edma stream5 data transfer error flag */
#define | EDMA_HDT5_FLAG ((uint32_t)0x20000010) /* edma stream5 half data transfer flag */
#define | EDMA_FDT5_FLAG ((uint32_t)0x20000020) /* edma stream5 full data transfer flag */
#define | EDMA_FERR6_FLAG ((uint32_t)0x20000040) /* edma stream6 fifo error flag */
#define | EDMA_DMERR6_FLAG ((uint32_t)0x20000100) /* edma stream6 direct mode error flag */
#define | EDMA_DTERR6_FLAG ((uint32_t)0x20000200) /* edma stream6 data transfer error flag */
#define | EDMA_HDT6_FLAG ((uint32_t)0x20000400) /* edma stream6 half data transfer flag */
#define | EDMA_FDT6_FLAG ((uint32_t)0x20000800) /* edma stream6 full data transfer flag */
#define | EDMA_FERR7_FLAG ((uint32_t)0x20010000) /* edma stream7 fifo error flag */
#define | EDMA_DMERR7_FLAG ((uint32_t)0x20040000) /* edma stream7 direct mode error flag */
#define | EDMA_DTERR7_FLAG ((uint32_t)0x20080000) /* edma stream7 data transfer error flag */
#define | EDMA_HDT7_FLAG ((uint32_t)0x20100000) /* edma stream7 half data transfer flag */
#define | EDMA_FDT7_FLAG ((uint32_t)0x20200000) /* edma stream7 full data transfer flag */
#define | EDMA_FERR8_FLAG ((uint32_t)0x20400000) /* edma stream8 fifo error flag */
#define | EDMA_DMERR8_FLAG ((uint32_t)0x21000000) /* edma stream8 direct mode error flag */
#define | EDMA_DTERR8_FLAG ((uint32_t)0x22000000) /* edma stream8 data transfer error flag */
#define | EDMA_HDT8_FLAG ((uint32_t)0x24000000) /* edma stream8 half data transfer flag */
#define | EDMA_FDT8_FLAG ((uint32_t)0x28000000) /* edma stream8 full data transfer flag */
#define | EDMA_STREAM1_INT_MASK (uint32_t)(0x0000003D)
masks define More...
#define | EDMA_STREAM2_INT_MASK (uint32_t)(EDMA_STREAM1_INT_MASK << 6)
#define | EDMA_STREAM3_INT_MASK (uint32_t)(EDMA_STREAM1_INT_MASK << 16)
#define | EDMA_STREAM4_INT_MASK (uint32_t)(EDMA_STREAM1_INT_MASK << 22)
#define | EDMA_STREAM5_INT_MASK (uint32_t)(EDMA_STREAM1_INT_MASK)
#define | EDMA_STREAM6_INT_MASK (uint32_t)(EDMA_STREAM2_INT_MASK)
#define | EDMA_STREAM7_INT_MASK (uint32_t)(EDMA_STREAM3_INT_MASK)
#define | EDMA_STREAM8_INT_MASK (uint32_t)(EDMA_STREAM4_INT_MASK)
#define | EDMAMUX_SYNC_OV1_FLAG ((uint32_t)0x00000001)
edmamux flag More...
#define | EDMAMUX_SYNC_OV2_FLAG ((uint32_t)0x00000002)
#define | EDMAMUX_SYNC_OV3_FLAG ((uint32_t)0x00000004)
#define | EDMAMUX_SYNC_OV4_FLAG ((uint32_t)0x00000008)
#define | EDMAMUX_SYNC_OV5_FLAG ((uint32_t)0x00000010)
#define | EDMAMUX_SYNC_OV6_FLAG ((uint32_t)0x00000020)
#define | EDMAMUX_SYNC_OV7_FLAG ((uint32_t)0x00000040)
#define | EDMAMUX_SYNC_OV8_FLAG ((uint32_t)0x00000080)
#define | EDMAMUX_GEN_TRIG_OV1_FLAG ((uint32_t)0x00000001)
#define | EDMAMUX_GEN_TRIG_OV2_FLAG ((uint32_t)0x00000002)
#define | EDMAMUX_GEN_TRIG_OV3_FLAG ((uint32_t)0x00000004)
#define | EDMAMUX_GEN_TRIG_OV4_FLAG ((uint32_t)0x00000008)

Detailed Description

edma flag

Macro Definition Documentation

◆ EDMA_DMERR1_FLAG

#define EDMA_DMERR1_FLAG ((uint32_t)0x10000004) /* edma stream1 direct mode error flag */

Definition at line 68 of file at32f435_437_edma.h.

◆ EDMA_DMERR2_FLAG

#define EDMA_DMERR2_FLAG ((uint32_t)0x10000100) /* edma stream2 direct mode error flag */

Definition at line 73 of file at32f435_437_edma.h.

◆ EDMA_DMERR3_FLAG

#define EDMA_DMERR3_FLAG ((uint32_t)0x10040000) /* edma stream3 direct mode error flag */

Definition at line 78 of file at32f435_437_edma.h.

◆ EDMA_DMERR4_FLAG

#define EDMA_DMERR4_FLAG ((uint32_t)0x11000000) /* edma stream4 direct mode error flag */

Definition at line 83 of file at32f435_437_edma.h.

◆ EDMA_DMERR5_FLAG

#define EDMA_DMERR5_FLAG ((uint32_t)0x20000004) /* edma stream5 direct mode error flag */

Definition at line 88 of file at32f435_437_edma.h.

◆ EDMA_DMERR6_FLAG

#define EDMA_DMERR6_FLAG ((uint32_t)0x20000100) /* edma stream6 direct mode error flag */

Definition at line 93 of file at32f435_437_edma.h.

◆ EDMA_DMERR7_FLAG

#define EDMA_DMERR7_FLAG ((uint32_t)0x20040000) /* edma stream7 direct mode error flag */

Definition at line 98 of file at32f435_437_edma.h.

◆ EDMA_DMERR8_FLAG

#define EDMA_DMERR8_FLAG ((uint32_t)0x21000000) /* edma stream8 direct mode error flag */

Definition at line 103 of file at32f435_437_edma.h.

◆ EDMA_DTERR1_FLAG

#define EDMA_DTERR1_FLAG ((uint32_t)0x10000008) /* edma stream1 data transfer error flag */

Definition at line 69 of file at32f435_437_edma.h.

◆ EDMA_DTERR2_FLAG

#define EDMA_DTERR2_FLAG ((uint32_t)0x10000200) /* edma stream2 data transfer error flag */

Definition at line 74 of file at32f435_437_edma.h.

◆ EDMA_DTERR3_FLAG

#define EDMA_DTERR3_FLAG ((uint32_t)0x10080000) /* edma stream3 data transfer error flag */

Definition at line 79 of file at32f435_437_edma.h.

◆ EDMA_DTERR4_FLAG

#define EDMA_DTERR4_FLAG ((uint32_t)0x12000000) /* edma stream4 data transfer error flag */

Definition at line 84 of file at32f435_437_edma.h.

◆ EDMA_DTERR5_FLAG

#define EDMA_DTERR5_FLAG ((uint32_t)0x20000008) /* edma stream5 data transfer error flag */

Definition at line 89 of file at32f435_437_edma.h.

◆ EDMA_DTERR6_FLAG

#define EDMA_DTERR6_FLAG ((uint32_t)0x20000200) /* edma stream6 data transfer error flag */

Definition at line 94 of file at32f435_437_edma.h.

◆ EDMA_DTERR7_FLAG

#define EDMA_DTERR7_FLAG ((uint32_t)0x20080000) /* edma stream7 data transfer error flag */

Definition at line 99 of file at32f435_437_edma.h.

◆ EDMA_DTERR8_FLAG

#define EDMA_DTERR8_FLAG ((uint32_t)0x22000000) /* edma stream8 data transfer error flag */

Definition at line 104 of file at32f435_437_edma.h.

◆ EDMA_FDT1_FLAG

#define EDMA_FDT1_FLAG ((uint32_t)0x10000020) /* edma stream1 full data transfer flag */

Definition at line 71 of file at32f435_437_edma.h.

◆ EDMA_FDT2_FLAG

#define EDMA_FDT2_FLAG ((uint32_t)0x10000800) /* edma stream2 full data transfer flag */

Definition at line 76 of file at32f435_437_edma.h.

◆ EDMA_FDT3_FLAG

#define EDMA_FDT3_FLAG ((uint32_t)0x10200000) /* edma stream3 full data transfer flag */

Definition at line 81 of file at32f435_437_edma.h.

◆ EDMA_FDT4_FLAG

#define EDMA_FDT4_FLAG ((uint32_t)0x18000000) /* edma stream4 full data transfer flag */

Definition at line 86 of file at32f435_437_edma.h.

◆ EDMA_FDT5_FLAG

#define EDMA_FDT5_FLAG ((uint32_t)0x20000020) /* edma stream5 full data transfer flag */

Definition at line 91 of file at32f435_437_edma.h.

◆ EDMA_FDT6_FLAG

#define EDMA_FDT6_FLAG ((uint32_t)0x20000800) /* edma stream6 full data transfer flag */

Definition at line 96 of file at32f435_437_edma.h.

◆ EDMA_FDT7_FLAG

#define EDMA_FDT7_FLAG ((uint32_t)0x20200000) /* edma stream7 full data transfer flag */

Definition at line 101 of file at32f435_437_edma.h.

◆ EDMA_FDT8_FLAG

#define EDMA_FDT8_FLAG ((uint32_t)0x28000000) /* edma stream8 full data transfer flag */

Definition at line 106 of file at32f435_437_edma.h.

◆ EDMA_FERR1_FLAG

#define EDMA_FERR1_FLAG ((uint32_t)0x10000001) /* edma stream1 fifo error flag */

Definition at line 67 of file at32f435_437_edma.h.

◆ EDMA_FERR2_FLAG

#define EDMA_FERR2_FLAG ((uint32_t)0x10000040) /* edma stream2 fifo error flag */

Definition at line 72 of file at32f435_437_edma.h.

◆ EDMA_FERR3_FLAG

#define EDMA_FERR3_FLAG ((uint32_t)0x10010000) /* edma stream3 fifo error flag */

Definition at line 77 of file at32f435_437_edma.h.

◆ EDMA_FERR4_FLAG

#define EDMA_FERR4_FLAG ((uint32_t)0x10400000) /* edma stream4 fifo error flag */

Definition at line 82 of file at32f435_437_edma.h.

◆ EDMA_FERR5_FLAG

#define EDMA_FERR5_FLAG ((uint32_t)0x20000001) /* edma stream5 fifo error flag */

Definition at line 87 of file at32f435_437_edma.h.

◆ EDMA_FERR6_FLAG

#define EDMA_FERR6_FLAG ((uint32_t)0x20000040) /* edma stream6 fifo error flag */

Definition at line 92 of file at32f435_437_edma.h.

◆ EDMA_FERR7_FLAG

#define EDMA_FERR7_FLAG ((uint32_t)0x20010000) /* edma stream7 fifo error flag */

Definition at line 97 of file at32f435_437_edma.h.

◆ EDMA_FERR8_FLAG

#define EDMA_FERR8_FLAG ((uint32_t)0x20400000) /* edma stream8 fifo error flag */

Definition at line 102 of file at32f435_437_edma.h.

◆ EDMA_HDT1_FLAG

#define EDMA_HDT1_FLAG ((uint32_t)0x10000010) /* edma stream1 half data transfer flag */

Definition at line 70 of file at32f435_437_edma.h.

◆ EDMA_HDT2_FLAG

#define EDMA_HDT2_FLAG ((uint32_t)0x10000400) /* edma stream2 half data transfer flag */

Definition at line 75 of file at32f435_437_edma.h.

◆ EDMA_HDT3_FLAG

#define EDMA_HDT3_FLAG ((uint32_t)0x10100000) /* edma stream3 half data transfer flag */

Definition at line 80 of file at32f435_437_edma.h.

◆ EDMA_HDT4_FLAG

#define EDMA_HDT4_FLAG ((uint32_t)0x14000000) /* edma stream4 half data transfer flag */

Definition at line 85 of file at32f435_437_edma.h.

◆ EDMA_HDT5_FLAG

#define EDMA_HDT5_FLAG ((uint32_t)0x20000010) /* edma stream5 half data transfer flag */

Definition at line 90 of file at32f435_437_edma.h.

◆ EDMA_HDT6_FLAG

#define EDMA_HDT6_FLAG ((uint32_t)0x20000400) /* edma stream6 half data transfer flag */

Definition at line 95 of file at32f435_437_edma.h.

◆ EDMA_HDT7_FLAG

#define EDMA_HDT7_FLAG ((uint32_t)0x20100000) /* edma stream7 half data transfer flag */

Definition at line 100 of file at32f435_437_edma.h.

◆ EDMA_HDT8_FLAG

#define EDMA_HDT8_FLAG ((uint32_t)0x24000000) /* edma stream8 half data transfer flag */

Definition at line 105 of file at32f435_437_edma.h.

◆ EDMA_STREAM1_INT_MASK

#define EDMA_STREAM1_INT_MASK (uint32_t)(0x0000003D)

masks define

edma stream1 interrupt mask

Definition at line 111 of file at32f435_437_edma.h.

◆ EDMA_STREAM2_INT_MASK

#define EDMA_STREAM2_INT_MASK (uint32_t)(EDMA_STREAM1_INT_MASK << 6)

edma stream2 interrupt mask

Definition at line 112 of file at32f435_437_edma.h.

◆ EDMA_STREAM3_INT_MASK

#define EDMA_STREAM3_INT_MASK (uint32_t)(EDMA_STREAM1_INT_MASK << 16)

edma stream3 interrupt mask

Definition at line 113 of file at32f435_437_edma.h.

◆ EDMA_STREAM4_INT_MASK

#define EDMA_STREAM4_INT_MASK (uint32_t)(EDMA_STREAM1_INT_MASK << 22)

edma stream4 interrupt mask

Definition at line 114 of file at32f435_437_edma.h.

◆ EDMA_STREAM5_INT_MASK

#define EDMA_STREAM5_INT_MASK (uint32_t)(EDMA_STREAM1_INT_MASK)

edma stream5 interrupt mask

Definition at line 115 of file at32f435_437_edma.h.

◆ EDMA_STREAM6_INT_MASK

#define EDMA_STREAM6_INT_MASK (uint32_t)(EDMA_STREAM2_INT_MASK)

edma stream6 interrupt mask

Definition at line 116 of file at32f435_437_edma.h.

◆ EDMA_STREAM7_INT_MASK

#define EDMA_STREAM7_INT_MASK (uint32_t)(EDMA_STREAM3_INT_MASK)

edma stream7 interrupt mask

Definition at line 117 of file at32f435_437_edma.h.

◆ EDMA_STREAM8_INT_MASK

#define EDMA_STREAM8_INT_MASK (uint32_t)(EDMA_STREAM4_INT_MASK)

edma stream8 interrupt mask

Definition at line 118 of file at32f435_437_edma.h.

◆ EDMAMUX_GEN_TRIG_OV1_FLAG

#define EDMAMUX_GEN_TRIG_OV1_FLAG ((uint32_t)0x00000001)

edmamux generator channel1 overrun event flag

Definition at line 132 of file at32f435_437_edma.h.

◆ EDMAMUX_GEN_TRIG_OV2_FLAG

#define EDMAMUX_GEN_TRIG_OV2_FLAG ((uint32_t)0x00000002)

edmamux generator channel2 overrun event flag

Definition at line 133 of file at32f435_437_edma.h.

◆ EDMAMUX_GEN_TRIG_OV3_FLAG

#define EDMAMUX_GEN_TRIG_OV3_FLAG ((uint32_t)0x00000004)

edmamux generator channel3 overrun event flag

Definition at line 134 of file at32f435_437_edma.h.

◆ EDMAMUX_GEN_TRIG_OV4_FLAG

#define EDMAMUX_GEN_TRIG_OV4_FLAG ((uint32_t)0x00000008)

edmamux generator channel4 overrun event flag

Definition at line 135 of file at32f435_437_edma.h.

◆ EDMAMUX_SYNC_OV1_FLAG

#define EDMAMUX_SYNC_OV1_FLAG ((uint32_t)0x00000001)

edmamux flag

edmamux stream1 synchronization overrun event flag

Definition at line 123 of file at32f435_437_edma.h.

◆ EDMAMUX_SYNC_OV2_FLAG

#define EDMAMUX_SYNC_OV2_FLAG ((uint32_t)0x00000002)

edmamux stream2 synchronization overrun event flag

Definition at line 124 of file at32f435_437_edma.h.

◆ EDMAMUX_SYNC_OV3_FLAG

#define EDMAMUX_SYNC_OV3_FLAG ((uint32_t)0x00000004)

edmamux stream3 synchronization overrun event flag

Definition at line 125 of file at32f435_437_edma.h.

◆ EDMAMUX_SYNC_OV4_FLAG

#define EDMAMUX_SYNC_OV4_FLAG ((uint32_t)0x00000008)

edmamux stream4 synchronization overrun event flag

Definition at line 126 of file at32f435_437_edma.h.

◆ EDMAMUX_SYNC_OV5_FLAG

#define EDMAMUX_SYNC_OV5_FLAG ((uint32_t)0x00000010)

edmamux stream5 synchronization overrun event flag

Definition at line 127 of file at32f435_437_edma.h.

◆ EDMAMUX_SYNC_OV6_FLAG

#define EDMAMUX_SYNC_OV6_FLAG ((uint32_t)0x00000020)

edmamux stream6 synchronization overrun event flag

Definition at line 128 of file at32f435_437_edma.h.

◆ EDMAMUX_SYNC_OV7_FLAG

#define EDMAMUX_SYNC_OV7_FLAG ((uint32_t)0x00000040)

edmamux stream7 synchronization overrun event flag

Definition at line 129 of file at32f435_437_edma.h.

◆ EDMAMUX_SYNC_OV8_FLAG

#define EDMAMUX_SYNC_OV8_FLAG ((uint32_t)0x00000080)

edmamux stream8 synchronization overrun event flag

Definition at line 130 of file at32f435_437_edma.h.


AT32F435/437 Firmwary Library: EDMA_exported_types

Data Structures | Enumerations
EDMA_exported_types
AT32F435_437_periph_driver » EDMA

Data Structures

struct | edma_init_type
edma init type More...
struct | edmamux_sync_init_type
edmamux sync init type More...
struct | edmamux_gen_init_type
edmamux generator init type More...
struct | edma_type
type define edma register all More...
struct | edma_stream_type
type define edma stream register all More...
struct | edma_stream_link_list_type
type define edma stream link list pointer register More...
struct | edma_stream_2d_type
type define edma 2d register all More...
struct | edmamux_channel_type
type define edmamux muxsctrl register More...
struct | edmamux_generator_type
type define edmamux request generator register all More...

Enumerations

enum | edma_memory_type { EDMA_MEMORY_0 = 0x00 , EDMA_MEMORY_1 = 0x01 }
edma memory targets define More...
enum | edma_dir_type { EDMA_DIR_PERIPHERAL_TO_MEMORY = 0x00 , EDMA_DIR_MEMORY_TO_PERIPHERAL = 0x01 , EDMA_DIR_MEMORY_TO_MEMORY = 0x02 }
edma direction type More...
enum | edma_peripheral_data_size_type { EDMA_PERIPHERAL_DATA_WIDTH_BYTE = 0x00 , EDMA_PERIPHERAL_DATA_WIDTH_HALFWORD = 0x01 , EDMA_PERIPHERAL_DATA_WIDTH_WORD = 0x02 }
edma peripheral data size type More...
enum | edma_memory_data_size_type { EDMA_MEMORY_DATA_WIDTH_BYTE = 0x00 , EDMA_MEMORY_DATA_WIDTH_HALFWORD = 0x01 , EDMA_MEMORY_DATA_WIDTH_WORD = 0x02 }
edma memory data size type More...
enum | edma_priority_level_type { EDMA_PRIORITY_LOW = 0x00 , EDMA_PRIORITY_MEDIUM = 0x01 , EDMA_PRIORITY_HIGH = 0x02 , EDMA_PRIORITY_VERY_HIGH = 0x03 }
edma priority level type More...
enum | edma_fifo_threshold_type { EDMA_FIFO_THRESHOLD_1QUARTER = 0x00 , EDMA_FIFO_THRESHOLD_HALF = 0x01 , EDMA_FIFO_THRESHOLD_3QUARTER = 0x02 , EDMA_FIFO_THRESHOLD_FULL = 0x03 }
edma fifo threshold level type More...
enum edma_fifo_stutas_type {
EDMA_FIFO_STATUS_LESS_1QUARTER = 0x00 , EDMA_FIFO_STATUS_1QUARTER = 0x01 , EDMA_FIFO_STATUS_HALF = 0x02 , EDMA_FIFO_STATUS_3QUARTER = 0x03 ,
EDMA_FIFO_STATUS_EMPTY = 0x04 , EDMA_FIFO_STATUS_FULL = 0x05
}
edma fifo stutas level type More...
enum | edma_memory_burst_type { EDMA_MEMORY_SINGLE = 0x00 , EDMA_MEMORY_BURST_4 = 0x01 , EDMA_MEMORY_BURST_8 = 0x02 , EDMA_MEMORY_BURST_16 = 0x03 }
edma memory continuous mode type More...
enum | edma_peripheral_burst_type { EDMA_PERIPHERAL_SINGLE = 0x00 , EDMA_PERIPHERAL_BURST_4 = 0x01 , EDMA_PERIPHERAL_BURST_8 = 0x02 , EDMA_PERIPHERAL_BURST_16 = 0x03 }
edma peripheral continuous mode type More...
enum | edma_peripheral_inc_offset_type { EDMA_PERIPHERAL_INC_PSIZE = 0x00 , EDMA_PERIPHERAL_INC_4_BYTE = 0x01 }
edma peripheral increment offset size type More...
enum edmamux_requst_id_sel_type {
EDMAMUX_DMAREQ_ID_REQ_G1 = 0x01 , EDMAMUX_DMAREQ_ID_REQ_G2 = 0x02 , EDMAMUX_DMAREQ_ID_REQ_G3 = 0x03 , EDMAMUX_DMAREQ_ID_REQ_G4 = 0x04 ,
EDMAMUX_DMAREQ_ID_ADC1 = 0x05 , EDMAMUX_DMAREQ_ID_ADC2 = 0x24 , EDMAMUX_DMAREQ_ID_ADC3 = 0x25 , EDMAMUX_DMAREQ_ID_DAC1 = 0x06 ,
EDMAMUX_DMAREQ_ID_DAC2 = 0x29 , EDMAMUX_DMAREQ_ID_TMR6_OVERFLOW = 0x08 , EDMAMUX_DMAREQ_ID_TMR7_OVERFLOW = 0x09 , EDMAMUX_DMAREQ_ID_SPI1_RX = 0x0A ,
EDMAMUX_DMAREQ_ID_SPI1_TX = 0x0B , EDMAMUX_DMAREQ_ID_SPI2_RX = 0x0C , EDMAMUX_DMAREQ_ID_SPI2_TX = 0x0D , EDMAMUX_DMAREQ_ID_SPI3_RX = 0x0E ,
EDMAMUX_DMAREQ_ID_SPI3_TX = 0x0F , EDMAMUX_DMAREQ_ID_SPI4_RX = 0x6A , EDMAMUX_DMAREQ_ID_SPI4_TX = 0x6B , EDMAMUX_DMAREQ_ID_I2S2_EXT_RX = 0x6E ,
EDMAMUX_DMAREQ_ID_I2S2_EXT_TX = 0x6F , EDMAMUX_DMAREQ_ID_I2S3_EXT_RX = 0x70 , EDMAMUX_DMAREQ_ID_I2S3_EXT_TX = 0x71 , EDMAMUX_DMAREQ_ID_I2C1_RX = 0x10 ,
EDMAMUX_DMAREQ_ID_I2C1_TX = 0x11 , EDMAMUX_DMAREQ_ID_I2C2_RX = 0x12 , EDMAMUX_DMAREQ_ID_I2C2_TX = 0x13 , EDMAMUX_DMAREQ_ID_I2C3_RX = 0x14 ,
EDMAMUX_DMAREQ_ID_I2C3_TX = 0x15 , EDMAMUX_DMAREQ_ID_USART1_RX = 0x18 , EDMAMUX_DMAREQ_ID_USART1_TX = 0x19 , EDMAMUX_DMAREQ_ID_USART2_RX = 0x1A ,
EDMAMUX_DMAREQ_ID_USART2_TX = 0x1B , EDMAMUX_DMAREQ_ID_USART3_RX = 0x1C , EDMAMUX_DMAREQ_ID_USART3_TX = 0x1D , EDMAMUX_DMAREQ_ID_UART4_RX = 0x1E ,
EDMAMUX_DMAREQ_ID_UART4_TX = 0x1F , EDMAMUX_DMAREQ_ID_UART5_RX = 0x20 , EDMAMUX_DMAREQ_ID_UART5_TX = 0x21 , EDMAMUX_DMAREQ_ID_USART6_RX = 0x72 ,
EDMAMUX_DMAREQ_ID_USART6_TX = 0x73 , EDMAMUX_DMAREQ_ID_UART7_RX = 0x74 , EDMAMUX_DMAREQ_ID_UART7_TX = 0x75 , EDMAMUX_DMAREQ_ID_UART8_RX = 0x76 ,
EDMAMUX_DMAREQ_ID_UART8_TX = 0x77 , EDMAMUX_DMAREQ_ID_SDIO1 = 0x27 , EDMAMUX_DMAREQ_ID_SDIO2 = 0x67 , EDMAMUX_DMAREQ_ID_QSPI1 = 0x28 ,
EDMAMUX_DMAREQ_ID_QSPI2 = 0x68 , EDMAMUX_DMAREQ_ID_TMR1_CH1 = 0x2A , EDMAMUX_DMAREQ_ID_TMR1_CH2 = 0x2B , EDMAMUX_DMAREQ_ID_TMR1_CH3 = 0x2C ,
EDMAMUX_DMAREQ_ID_TMR1_CH4 = 0x2D , EDMAMUX_DMAREQ_ID_TMR1_OVERFLOW = 0x2E , EDMAMUX_DMAREQ_ID_TMR1_TRIG = 0x2F , EDMAMUX_DMAREQ_ID_TMR1_HALL = 0x30 ,
EDMAMUX_DMAREQ_ID_TMR8_CH1 = 0x31 , EDMAMUX_DMAREQ_ID_TMR8_CH2 = 0x32 , EDMAMUX_DMAREQ_ID_TMR8_CH3 = 0x33 , EDMAMUX_DMAREQ_ID_TMR8_CH4 = 0x34 ,
EDMAMUX_DMAREQ_ID_TMR8_OVERFLOW = 0x35 , EDMAMUX_DMAREQ_ID_TMR8_TRIG = 0x36 , EDMAMUX_DMAREQ_ID_TMR8_HALL = 0x37 , EDMAMUX_DMAREQ_ID_TMR2_CH1 = 0x38 ,
EDMAMUX_DMAREQ_ID_TMR2_CH2 = 0x39 , EDMAMUX_DMAREQ_ID_TMR2_CH3 = 0x3A , EDMAMUX_DMAREQ_ID_TMR2_CH4 = 0x3B , EDMAMUX_DMAREQ_ID_TMR2_OVERFLOW = 0x3C ,
EDMAMUX_DMAREQ_ID_TMR2_TRIG = 0x7E , EDMAMUX_DMAREQ_ID_TMR3_CH1 = 0x3D , EDMAMUX_DMAREQ_ID_TMR3_CH2 = 0x3E , EDMAMUX_DMAREQ_ID_TMR3_CH3 = 0x3F ,
EDMAMUX_DMAREQ_ID_TMR3_CH4 = 0x40 , EDMAMUX_DMAREQ_ID_TMR3_OVERFLOW = 0x41 , EDMAMUX_DMAREQ_ID_TMR3_TRIG = 0x42 , EDMAMUX_DMAREQ_ID_TMR4_CH1 = 0x43 ,
EDMAMUX_DMAREQ_ID_TMR4_CH2 = 0x44 , EDMAMUX_DMAREQ_ID_TMR4_CH3 = 0x45 , EDMAMUX_DMAREQ_ID_TMR4_CH4 = 0x46 , EDMAMUX_DMAREQ_ID_TMR4_OVERFLOW = 0x47 ,
EDMAMUX_DMAREQ_ID_TMR4_TRIG = 0x7F , EDMAMUX_DMAREQ_ID_TMR5_CH1 = 0x48 , EDMAMUX_DMAREQ_ID_TMR5_CH2 = 0x49 , EDMAMUX_DMAREQ_ID_TMR5_CH3 = 0x4A ,
EDMAMUX_DMAREQ_ID_TMR5_CH4 = 0x4B , EDMAMUX_DMAREQ_ID_TMR5_OVERFLOW = 0x4C , EDMAMUX_DMAREQ_ID_TMR5_TRIG = 0x4D , EDMAMUX_DMAREQ_ID_TMR20_CH1 = 0x56 ,
EDMAMUX_DMAREQ_ID_TMR20_CH2 = 0x57 , EDMAMUX_DMAREQ_ID_TMR20_CH3 = 0x58 , EDMAMUX_DMAREQ_ID_TMR20_CH4 = 0x59 , EDMAMUX_DMAREQ_ID_TMR20_OVERFLOW = 0x5A ,
EDMAMUX_DMAREQ_ID_TMR20_TRIG = 0x5D , EDMAMUX_DMAREQ_ID_TMR20_HALL = 0x5E , EDMAMUX_DMAREQ_ID_DVP = 0x69
}
edmamux request id select type More...
enum edmamux_sync_id_sel_type {
EDMAMUX_SYNC_ID_EXINT0 = 0x00 , EDMAMUX_SYNC_ID_EXINT1 = 0x01 , EDMAMUX_SYNC_ID_EXINT2 = 0x02 , EDMAMUX_SYNC_ID_EXINT3 = 0x03 ,
EDMAMUX_SYNC_ID_EXINT4 = 0x04 , EDMAMUX_SYNC_ID_EXINT5 = 0x05 , EDMAMUX_SYNC_ID_EXINT6 = 0x06 , EDMAMUX_SYNC_ID_EXINT7 = 0x07 ,
EDMAMUX_SYNC_ID_EXINT8 = 0x08 , EDMAMUX_SYNC_ID_EXINT9 = 0x09 , EDMAMUX_SYNC_ID_EXINT10 = 0x0A , EDMAMUX_SYNC_ID_EXINT11 = 0x0B ,
EDMAMUX_SYNC_ID_EXINT12 = 0x0C , EDMAMUX_SYNC_ID_EXINT13 = 0x0D , EDMAMUX_SYNC_ID_EXINT14 = 0x0E , EDMAMUX_SYNC_ID_EXINT15 = 0x0F ,
EDMAMUX_SYNC_ID_DMAMUX_CH1_EVT = 0x10 , EDMAMUX_SYNC_ID_DMAMUX_CH2_EVT = 0x11 , EDMAMUX_SYNC_ID_DMAMUX_CH3_EVT = 0x12 , EDMAMUX_SYNC_ID_DMAMUX_CH4_EVT = 0x13 ,
EDMAMUX_SYNC_ID_DMAMUX_CH5_EVT = 0x14 , EDMAMUX_SYNC_ID_DMAMUX_CH6_EVT = 0x15 , EDMAMUX_SYNC_ID_DMAMUX_CH7_EVT = 0x16 , EDMAMUX_SYNC_ID_DMAMUX_CH8_EVT = 0x17
}
dmamux sync id select type More...
enum | edmamux_sync_pol_type { EDMAMUX_SYNC_POLARITY_DISABLE = 0x00 , EDMAMUX_SYNC_POLARITY_RISING = 0x01 , EDMAMUX_SYNC_POLARITY_FALLING = 0x02 , EDMAMUX_SYNC_POLARITY_RISING_FALLING = 0x03 }
dmamux sync polarity type More...
enum edmamux_gen_id_sel_type {
EDMAMUX_GEN_ID_EXINT0 = 0x00 , EDMAMUX_GEN_ID_EXINT1 = 0x01 , EDMAMUX_GEN_ID_EXINT2 = 0x02 , EDMAMUX_GEN_ID_EXINT3 = 0x03 ,
EDMAMUX_GEN_ID_EXINT4 = 0x04 , EDMAMUX_GEN_ID_EXINT5 = 0x05 , EDMAMUX_GEN_ID_EXINT6 = 0x06 , EDMAMUX_GEN_ID_EXINT7 = 0x07 ,
EDMAMUX_GEN_ID_EXINT8 = 0x08 , EDMAMUX_GEN_ID_EXINT9 = 0x09 , EDMAMUX_GEN_ID_EXINT10 = 0x0A , EDMAMUX_GEN_ID_EXINT11 = 0x0B ,
EDMAMUX_GEN_ID_EXINT12 = 0x0C , EDMAMUX_GEN_ID_EXINT13 = 0x0D , EDMAMUX_GEN_ID_EXINT14 = 0x0E , EDMAMUX_GEN_ID_EXINT15 = 0x0F ,
EDMAMUX_GEN_ID_DMAMUX_CH1_EVT = 0x10 , EDMAMUX_GEN_ID_DMAMUX_CH2_EVT = 0x11 , EDMAMUX_GEN_ID_DMAMUX_CH3_EVT = 0x12 , EDMAMUX_GEN_ID_DMAMUX_CH4_EVT = 0x13 ,
EDMAMUX_GEN_ID_DMAMUX_CH5_EVT = 0x14 , EDMAMUX_GEN_ID_DMAMUX_CH6_EVT = 0x15 , EDMAMUX_GEN_ID_DMAMUX_CH7_EVT = 0x16 , EDMAMUX_GEN_ID_DMAMUX_CH8_EVT = 0x17
}
dmamux generator id select type More...
enum | edmamux_gen_pol_type { EDMAMUX_GEN_POLARITY_DISABLE = 0x00 , EDMAMUX_GEN_POLARITY_RISING = 0x01 , EDMAMUX_GEN_POLARITY_FALLING = 0x02 , EDMAMUX_GEN_POLARITY_RISING_FALLING = 0x03 }
dmamux generator polarity type More...

Detailed Description

Enumeration Type Documentation

◆ edma_dir_type

enum edma_dir_type

edma direction type

Enumerator
EDMA_DIR_PERIPHERAL_TO_MEMORY | data transfer direction: peripheral to memory
EDMA_DIR_MEMORY_TO_PERIPHERAL | data transfer direction: memory to peripheral
EDMA_DIR_MEMORY_TO_MEMORY | data transfer direction: memory to memory

Definition at line 157 of file at32f435_437_edma.h.

◆ edma_fifo_stutas_type

enum edma_fifo_stutas_type

edma fifo stutas level type

Enumerator
EDMA_FIFO_STATUS_LESS_1QUARTER | fifo stutas level: less 1quarter full
EDMA_FIFO_STATUS_1QUARTER | fifo stutas level: 1quarter full
EDMA_FIFO_STATUS_HALF | fifo stutas level: half full
EDMA_FIFO_STATUS_3QUARTER | fifo stutas level: 3quarter full
EDMA_FIFO_STATUS_EMPTY | fifo stutas level: empty
EDMA_FIFO_STATUS_FULL | fifo stutas level: full

Definition at line 209 of file at32f435_437_edma.h.

◆ edma_fifo_threshold_type

enum edma_fifo_threshold_type

edma fifo threshold level type

Enumerator
EDMA_FIFO_THRESHOLD_1QUARTER | fifo threshold level: 1quarter full
EDMA_FIFO_THRESHOLD_HALF | fifo threshold level: half full
EDMA_FIFO_THRESHOLD_3QUARTER | fifo threshold level: 13quarter full
EDMA_FIFO_THRESHOLD_FULL | fifo threshold level: full

Definition at line 198 of file at32f435_437_edma.h.

◆ edma_memory_burst_type

enum edma_memory_burst_type

edma memory continuous mode type

Enumerator
EDMA_MEMORY_SINGLE | memory single transfer
EDMA_MEMORY_BURST_4 | memory burst transfer 4 beats
EDMA_MEMORY_BURST_8 | memory burst transfer 8 beats
EDMA_MEMORY_BURST_16 | memory burst transfer 16 beats

Definition at line 222 of file at32f435_437_edma.h.

◆ edma_memory_data_size_type

enum edma_memory_data_size_type

edma memory data size type

Enumerator
EDMA_MEMORY_DATA_WIDTH_BYTE | memory data bus width is 8bit
EDMA_MEMORY_DATA_WIDTH_HALFWORD | memory data bus width is 16bit
EDMA_MEMORY_DATA_WIDTH_WORD | memory data bus width is 32bit

Definition at line 177 of file at32f435_437_edma.h.

◆ edma_memory_type

enum edma_memory_type

edma memory targets define

Enumerator
EDMA_MEMORY_0 | current target is memory 0
EDMA_MEMORY_1 | current target is memory 1

Definition at line 148 of file at32f435_437_edma.h.

◆ edma_peripheral_burst_type

enum edma_peripheral_burst_type

edma peripheral continuous mode type

Enumerator
EDMA_PERIPHERAL_SINGLE | peripheral single transfer
EDMA_PERIPHERAL_BURST_4 | peripheral burst transfer 4 beats
EDMA_PERIPHERAL_BURST_8 | peripheral burst transfer 8 beats
EDMA_PERIPHERAL_BURST_16 | peripheral burst transfer 16 beats

Definition at line 233 of file at32f435_437_edma.h.

◆ edma_peripheral_data_size_type

enum edma_peripheral_data_size_type

edma peripheral data size type

Enumerator
EDMA_PERIPHERAL_DATA_WIDTH_BYTE | peripheral data bus width is 8bit
EDMA_PERIPHERAL_DATA_WIDTH_HALFWORD | peripheral data bus width is 16bit
EDMA_PERIPHERAL_DATA_WIDTH_WORD | peripheral data bus width is 32bit

Definition at line 167 of file at32f435_437_edma.h.

◆ edma_peripheral_inc_offset_type

enum edma_peripheral_inc_offset_type

edma peripheral increment offset size type

Enumerator
EDMA_PERIPHERAL_INC_PSIZE | peripheral offset is related to psize
EDMA_PERIPHERAL_INC_4_BYTE | peripheral offset is 4 byte

Definition at line 244 of file at32f435_437_edma.h.

◆ edma_priority_level_type

enum edma_priority_level_type

edma priority level type

Enumerator
EDMA_PRIORITY_LOW | stream priority: low
EDMA_PRIORITY_MEDIUM | stream priority: medium
EDMA_PRIORITY_HIGH | stream priority: high
EDMA_PRIORITY_VERY_HIGH | stream priority: very high

Definition at line 187 of file at32f435_437_edma.h.

◆ edmamux_gen_id_sel_type

enum edmamux_gen_id_sel_type

dmamux generator id select type

Enumerator
EDMAMUX_GEN_ID_EXINT0 | edmamux generator channel inputs resources: exint line0
EDMAMUX_GEN_ID_EXINT1 | edmamux generator channel inputs resources: exint line1
EDMAMUX_GEN_ID_EXINT2 | edmamux generator channel inputs resources: exint line2
EDMAMUX_GEN_ID_EXINT3 | edmamux generator channel inputs resources: exint line3
EDMAMUX_GEN_ID_EXINT4 | edmamux generator channel inputs resources: exint line4
EDMAMUX_GEN_ID_EXINT5 | edmamux generator channel inputs resources: exint line5
EDMAMUX_GEN_ID_EXINT6 | edmamux generator channel inputs resources: exint line6
EDMAMUX_GEN_ID_EXINT7 | edmamux generator channel inputs resources: exint line7
EDMAMUX_GEN_ID_EXINT8 | edmamux generator channel inputs resources: exint line8
EDMAMUX_GEN_ID_EXINT9 | edmamux generator channel inputs resources: exint line9
EDMAMUX_GEN_ID_EXINT10 | edmamux generator channel inputs resources: exint line10
EDMAMUX_GEN_ID_EXINT11 | edmamux generator channel inputs resources: exint line11
EDMAMUX_GEN_ID_EXINT12 | edmamux generator channel inputs resources: exint line12
EDMAMUX_GEN_ID_EXINT13 | edmamux generator channel inputs resources: exint line13
EDMAMUX_GEN_ID_EXINT14 | edmamux generator channel inputs resources: exint line14
EDMAMUX_GEN_ID_EXINT15 | edmamux generator channel inputs resources: exint line15
EDMAMUX_GEN_ID_DMAMUX_CH1_EVT | edmamux generator channel inputs resources: dmamux channel1 event
EDMAMUX_GEN_ID_DMAMUX_CH2_EVT | edmamux generator channel inputs resources: dmamux channel2 event
EDMAMUX_GEN_ID_DMAMUX_CH3_EVT | edmamux generator channel inputs resources: dmamux channel3 event
EDMAMUX_GEN_ID_DMAMUX_CH4_EVT | edmamux generator channel inputs resources: dmamux channel4 event
EDMAMUX_GEN_ID_DMAMUX_CH5_EVT | edmamux generator channel inputs resources: dmamux channel5 event
EDMAMUX_GEN_ID_DMAMUX_CH6_EVT | edmamux generator channel inputs resources: dmamux channel6 event
EDMAMUX_GEN_ID_DMAMUX_CH7_EVT | edmamux generator channel inputs resources: dmamux channel7 event
EDMAMUX_GEN_ID_DMAMUX_CH8_EVT | edmamux generator channel inputs resources: dmamux channel8 event

Definition at line 397 of file at32f435_437_edma.h.

◆ edmamux_gen_pol_type

enum edmamux_gen_pol_type

dmamux generator polarity type

Enumerator
EDMAMUX_GEN_POLARITY_DISABLE | edmamux generator channel inputs resources polarity default value
EDMAMUX_GEN_POLARITY_RISING | edmamux generator channel inputs resources polarity: rising
EDMAMUX_GEN_POLARITY_FALLING | edmamux generator channel inputs resources polarity: falling
EDMAMUX_GEN_POLARITY_RISING_FALLING | edmamux generator channel inputs resources polarity: rising_falling

Definition at line 428 of file at32f435_437_edma.h.

◆ edmamux_requst_id_sel_type

enum edmamux_requst_id_sel_type

edmamux request id select type

Enumerator
EDMAMUX_DMAREQ_ID_REQ_G1 | edmamux channel request inputs resources: generator channel1
EDMAMUX_DMAREQ_ID_REQ_G2 | edmamux channel request inputs resources: generator channel2
EDMAMUX_DMAREQ_ID_REQ_G3 | edmamux channel request inputs resources: generator channel3
EDMAMUX_DMAREQ_ID_REQ_G4 | edmamux channel request inputs resources: generator channel4
EDMAMUX_DMAREQ_ID_ADC1 | edmamux channel request inputs resources: adc1
EDMAMUX_DMAREQ_ID_ADC2 | edmamux channel request inputs resources: adc2
EDMAMUX_DMAREQ_ID_ADC3 | edmamux channel request inputs resources: adc3
EDMAMUX_DMAREQ_ID_DAC1 | edmamux channel request inputs resources: dac1
EDMAMUX_DMAREQ_ID_DAC2 | edmamux channel request inputs resources: dac2
EDMAMUX_DMAREQ_ID_TMR6_OVERFLOW | edmamux channel request inputs resources: timer6 overflow
EDMAMUX_DMAREQ_ID_TMR7_OVERFLOW | edmamux channel request inputs resources: timer7 overflow
EDMAMUX_DMAREQ_ID_SPI1_RX | edmamux channel request inputs resources: spi1 rx
EDMAMUX_DMAREQ_ID_SPI1_TX | edmamux channel request inputs resources: spi1 tx
EDMAMUX_DMAREQ_ID_SPI2_RX | edmamux channel request inputs resources: spi2 rx
EDMAMUX_DMAREQ_ID_SPI2_TX | edmamux channel request inputs resources: spi2 tx
EDMAMUX_DMAREQ_ID_SPI3_RX | edmamux channel request inputs resources: spi3 rx
EDMAMUX_DMAREQ_ID_SPI3_TX | edmamux channel request inputs resources: spi3 tx
EDMAMUX_DMAREQ_ID_SPI4_RX | edmamux channel request inputs resources: spi4 rx
EDMAMUX_DMAREQ_ID_SPI4_TX | edmamux channel request inputs resources: spi4 tx
EDMAMUX_DMAREQ_ID_I2S2_EXT_RX | edmamux channel request inputs resources: i2s2_ext_rx
EDMAMUX_DMAREQ_ID_I2S2_EXT_TX | edmamux channel request inputs resources: i2s2_ext_tx
EDMAMUX_DMAREQ_ID_I2S3_EXT_RX | edmamux channel request inputs resources: i2s3_ext_rx
EDMAMUX_DMAREQ_ID_I2S3_EXT_TX | edmamux channel request inputs resources: i2s3_ext_tx
EDMAMUX_DMAREQ_ID_I2C1_RX | edmamux channel request inputs resources: i2c1_rx
EDMAMUX_DMAREQ_ID_I2C1_TX | edmamux channel request inputs resources: i2c1_tx
EDMAMUX_DMAREQ_ID_I2C2_RX | edmamux channel request inputs resources: i2c2_rx
EDMAMUX_DMAREQ_ID_I2C2_TX | edmamux channel request inputs resources: i2c2_tx
EDMAMUX_DMAREQ_ID_I2C3_RX | edmamux channel request inputs resources: i2c3_rx
EDMAMUX_DMAREQ_ID_I2C3_TX | edmamux channel request inputs resources: i2c3_tx
EDMAMUX_DMAREQ_ID_USART1_RX | edmamux channel request inputs resources: usart1_rx
EDMAMUX_DMAREQ_ID_USART1_TX | edmamux channel request inputs resources: usart1_tx
EDMAMUX_DMAREQ_ID_USART2_RX | edmamux channel request inputs resources: usart2_rx
EDMAMUX_DMAREQ_ID_USART2_TX | edmamux channel request inputs resources: usart2_tx
EDMAMUX_DMAREQ_ID_USART3_RX | edmamux channel request inputs resources: usart3_rx
EDMAMUX_DMAREQ_ID_USART3_TX | edmamux channel request inputs resources: usart3_tx
EDMAMUX_DMAREQ_ID_UART4_RX | edmamux channel request inputs resources: uart4_rx
EDMAMUX_DMAREQ_ID_UART4_TX | edmamux channel request inputs resources: uart4_tx
EDMAMUX_DMAREQ_ID_UART5_RX | edmamux channel request inputs resources: uart5_rx
EDMAMUX_DMAREQ_ID_UART5_TX | edmamux channel request inputs resources: uart5_tx
EDMAMUX_DMAREQ_ID_USART6_RX | edmamux channel request inputs resources: usart6_rx
EDMAMUX_DMAREQ_ID_USART6_TX | edmamux channel request inputs resources: usart6_tx
EDMAMUX_DMAREQ_ID_UART7_RX | edmamux channel request inputs resources: uart7_rx
EDMAMUX_DMAREQ_ID_UART7_TX | edmamux channel request inputs resources: uart7_tx
EDMAMUX_DMAREQ_ID_UART8_RX | edmamux channel request inputs resources: uart8_rx
EDMAMUX_DMAREQ_ID_UART8_TX | edmamux channel request inputs resources: uart8_tx
EDMAMUX_DMAREQ_ID_SDIO1 | edmamux channel request inputs resources: sdio1
EDMAMUX_DMAREQ_ID_SDIO2 | edmamux channel request inputs resources: sdio2
EDMAMUX_DMAREQ_ID_QSPI1 | edmamux channel request inputs resources: qspi1
EDMAMUX_DMAREQ_ID_QSPI2 | edmamux channel request inputs resources: qspi2
EDMAMUX_DMAREQ_ID_TMR1_CH1 | edmamux channel request inputs resources: timer1 ch1
EDMAMUX_DMAREQ_ID_TMR1_CH2 | edmamux channel request inputs resources: timer1 ch2
EDMAMUX_DMAREQ_ID_TMR1_CH3 | edmamux channel request inputs resources: timer1 ch3
EDMAMUX_DMAREQ_ID_TMR1_CH4 | edmamux channel request inputs resources: timer1 ch4
EDMAMUX_DMAREQ_ID_TMR1_OVERFLOW | edmamux channel request inputs resources: timer1 overflow
EDMAMUX_DMAREQ_ID_TMR1_TRIG | edmamux channel request inputs resources: timer1 trigger
EDMAMUX_DMAREQ_ID_TMR1_HALL | edmamux channel request inputs resources: timer1 hall
EDMAMUX_DMAREQ_ID_TMR8_CH1 | edmamux channel request inputs resources: timer8 ch1
EDMAMUX_DMAREQ_ID_TMR8_CH2 | edmamux channel request inputs resources: timer8 ch2
EDMAMUX_DMAREQ_ID_TMR8_CH3 | edmamux channel request inputs resources: timer8 ch3
EDMAMUX_DMAREQ_ID_TMR8_CH4 | edmamux channel request inputs resources: timer8 ch4
EDMAMUX_DMAREQ_ID_TMR8_OVERFLOW | edmamux channel request inputs resources: timer8 overflow
EDMAMUX_DMAREQ_ID_TMR8_TRIG | edmamux channel request inputs resources: timer8 trigger
EDMAMUX_DMAREQ_ID_TMR8_HALL | edmamux channel request inputs resources: timer8 hall
EDMAMUX_DMAREQ_ID_TMR2_CH1 | edmamux channel request inputs resources: timer2 ch1
EDMAMUX_DMAREQ_ID_TMR2_CH2 | edmamux channel request inputs resources: timer2 ch2
EDMAMUX_DMAREQ_ID_TMR2_CH3 | edmamux channel request inputs resources: timer2 ch3
EDMAMUX_DMAREQ_ID_TMR2_CH4 | edmamux channel request inputs resources: timer2 ch4
EDMAMUX_DMAREQ_ID_TMR2_OVERFLOW | edmamux channel request inputs resources: timer2 overflow
EDMAMUX_DMAREQ_ID_TMR2_TRIG | edmamux channel request inputs resources: timer2 trigger
EDMAMUX_DMAREQ_ID_TMR3_CH1 | edmamux channel request inputs resources: timer3 ch1
EDMAMUX_DMAREQ_ID_TMR3_CH2 | edmamux channel request inputs resources: timer3 ch2
EDMAMUX_DMAREQ_ID_TMR3_CH3 | edmamux channel request inputs resources: timer3 ch3
EDMAMUX_DMAREQ_ID_TMR3_CH4 | edmamux channel request inputs resources: timer3 ch4
EDMAMUX_DMAREQ_ID_TMR3_OVERFLOW | edmamux channel request inputs resources: timer3 overflow
EDMAMUX_DMAREQ_ID_TMR3_TRIG | edmamux channel request inputs resources: timer3 trigger
EDMAMUX_DMAREQ_ID_TMR4_CH1 | edmamux channel request inputs resources: timer4 ch1
EDMAMUX_DMAREQ_ID_TMR4_CH2 | edmamux channel request inputs resources: timer4 ch2
EDMAMUX_DMAREQ_ID_TMR4_CH3 | edmamux channel request inputs resources: timer4 ch3
EDMAMUX_DMAREQ_ID_TMR4_CH4 | edmamux channel request inputs resources: timer4 ch4
EDMAMUX_DMAREQ_ID_TMR4_OVERFLOW | edmamux channel request inputs resources: timer4 overflow
EDMAMUX_DMAREQ_ID_TMR4_TRIG | edmamux channel request inputs resources: timer4 trigger
EDMAMUX_DMAREQ_ID_TMR5_CH1 | edmamux channel request inputs resources: timer5 ch1
EDMAMUX_DMAREQ_ID_TMR5_CH2 | edmamux channel request inputs resources: timer5 ch2
EDMAMUX_DMAREQ_ID_TMR5_CH3 | edmamux channel request inputs resources: timer5 ch3
EDMAMUX_DMAREQ_ID_TMR5_CH4 | edmamux channel request inputs resources: timer5 ch4
EDMAMUX_DMAREQ_ID_TMR5_OVERFLOW | edmamux channel request inputs resources: timer5 overflow
EDMAMUX_DMAREQ_ID_TMR5_TRIG | edmamux channel request inputs resources: timer5 trigger
EDMAMUX_DMAREQ_ID_TMR20_CH1 | edmamux channel request inputs resources: timer20 ch1
EDMAMUX_DMAREQ_ID_TMR20_CH2 | edmamux channel request inputs resources: timer20 ch2
EDMAMUX_DMAREQ_ID_TMR20_CH3 | edmamux channel request inputs resources: timer20 ch3
EDMAMUX_DMAREQ_ID_TMR20_CH4 | edmamux channel request inputs resources: timer20 ch4
EDMAMUX_DMAREQ_ID_TMR20_OVERFLOW | edmamux channel request inputs resources: timer20 overflow
EDMAMUX_DMAREQ_ID_TMR20_TRIG | edmamux channel request inputs resources: timer20 trigger
EDMAMUX_DMAREQ_ID_TMR20_HALL | edmamux channel request inputs resources: timer20 hall
EDMAMUX_DMAREQ_ID_DVP | edmamux channel request inputs resources: dvp

Definition at line 253 of file at32f435_437_edma.h.

◆ edmamux_sync_id_sel_type

enum edmamux_sync_id_sel_type

dmamux sync id select type

Enumerator
EDMAMUX_SYNC_ID_EXINT0 | edmamux channel synchronization inputs resources: exint line0
EDMAMUX_SYNC_ID_EXINT1 | edmamux channel synchronization inputs resources: exint line1
EDMAMUX_SYNC_ID_EXINT2 | edmamux channel synchronization inputs resources: exint line2
EDMAMUX_SYNC_ID_EXINT3 | edmamux channel synchronization inputs resources: exint line3
EDMAMUX_SYNC_ID_EXINT4 | edmamux channel synchronization inputs resources: exint line4
EDMAMUX_SYNC_ID_EXINT5 | edmamux channel synchronization inputs resources: exint line5
EDMAMUX_SYNC_ID_EXINT6 | edmamux channel synchronization inputs resources: exint line6
EDMAMUX_SYNC_ID_EXINT7 | edmamux channel synchronization inputs resources: exint line7
EDMAMUX_SYNC_ID_EXINT8 | edmamux channel synchronization inputs resources: exint line8
EDMAMUX_SYNC_ID_EXINT9 | edmamux channel synchronization inputs resources: exint line9
EDMAMUX_SYNC_ID_EXINT10 | edmamux channel synchronization inputs resources: exint line10
EDMAMUX_SYNC_ID_EXINT11 | edmamux channel synchronization inputs resources: exint line11
EDMAMUX_SYNC_ID_EXINT12 | edmamux channel synchronization inputs resources: exint line12
EDMAMUX_SYNC_ID_EXINT13 | edmamux channel synchronization inputs resources: exint line13
EDMAMUX_SYNC_ID_EXINT14 | edmamux channel synchronization inputs resources: exint line14
EDMAMUX_SYNC_ID_EXINT15 | edmamux channel synchronization inputs resources: exint line15
EDMAMUX_SYNC_ID_DMAMUX_CH1_EVT | edmamux channel synchronization inputs resources: dmamux channel1 event
EDMAMUX_SYNC_ID_DMAMUX_CH2_EVT | edmamux channel synchronization inputs resources: dmamux channel2 event
EDMAMUX_SYNC_ID_DMAMUX_CH3_EVT | edmamux channel synchronization inputs resources: dmamux channel3 event
EDMAMUX_SYNC_ID_DMAMUX_CH4_EVT | edmamux channel synchronization inputs resources: dmamux channel4 event
EDMAMUX_SYNC_ID_DMAMUX_CH5_EVT | edmamux channel synchronization inputs resources: dmamux channel5 event
EDMAMUX_SYNC_ID_DMAMUX_CH6_EVT | edmamux channel synchronization inputs resources: dmamux channel6 event
EDMAMUX_SYNC_ID_DMAMUX_CH7_EVT | edmamux channel synchronization inputs resources: dmamux channel7 event
EDMAMUX_SYNC_ID_DMAMUX_CH8_EVT | edmamux channel synchronization inputs resources: dmamux channel8 event

Definition at line 355 of file at32f435_437_edma.h.

◆ edmamux_sync_pol_type

enum edmamux_sync_pol_type

dmamux sync polarity type

Enumerator
EDMAMUX_SYNC_POLARITY_DISABLE | edmamux channel synchronization inputs resources polarity default value
EDMAMUX_SYNC_POLARITY_RISING | edmamux channel synchronization inputs resources polarity: rising
EDMAMUX_SYNC_POLARITY_FALLING | edmamux channel synchronization inputs resources polarity: falling
EDMAMUX_SYNC_POLARITY_RISING_FALLING | edmamux channel synchronization inputs resources polarity: rising_falling

Definition at line 386 of file at32f435_437_edma.h.


AT32F435/437 Firmwary Library: edma_init_type Struct Reference

Data Fields
edma_init_type Struct Reference
AT32F435_437_periph_driver » EDMA » EDMA_exported_types

edma init type More...

#include <at32f435_437_edma.h>

Data Fields

uint32_t | peripheral_base_addr
uint32_t | memory0_base_addr
edma_dir_type direction
uint16_t | buffer_size
confirm_state peripheral_inc_enable
confirm_state memory_inc_enable
edma_peripheral_data_size_type peripheral_data_width
edma_memory_data_size_type memory_data_width
confirm_state loop_mode_enable
edma_priority_level_type priority
confirm_state fifo_mode_enable
edma_fifo_threshold_type fifo_threshold
edma_memory_burst_type memory_burst_mode
edma_peripheral_burst_type peripheral_burst_mode

Detailed Description

edma init type

Definition at line 439 of file at32f435_437_edma.h.

Field Documentation

◆ buffer_size

uint16_t edma_init_type::buffer_size

counter to transfer (0~0xFFFF)

Definition at line 444 of file at32f435_437_edma.h.

Referenced by dvp_dma_init(), edma_config(), edma_default_para_init(), edma_init(), i2s_config(), and main().

◆ direction

edma_dir_type edma_init_type::direction

edma transmit direction, peripheral as source or as destnation

Definition at line 443 of file at32f435_437_edma.h.

Referenced by dvp_dma_init(), edma_config(), edma_default_para_init(), edma_init(), i2s_config(), and main().

◆ fifo_mode_enable

confirm_state edma_init_type::fifo_mode_enable

edma fifo mode enable

Definition at line 451 of file at32f435_437_edma.h.

Referenced by dvp_dma_init(), edma_config(), edma_default_para_init(), edma_init(), i2s_config(), and main().

◆ fifo_threshold

edma_fifo_threshold_type edma_init_type::fifo_threshold

edma fifo threshold vaule

Definition at line 452 of file at32f435_437_edma.h.

Referenced by dvp_dma_init(), edma_config(), edma_default_para_init(), edma_init(), i2s_config(), and main().

◆ loop_mode_enable

confirm_state edma_init_type::loop_mode_enable

when loop mode enable, buffer size will reload if count to 0

Definition at line 449 of file at32f435_437_edma.h.

Referenced by dvp_dma_init(), edma_config(), edma_default_para_init(), edma_init(), i2s_config(), and main().

◆ memory0_base_addr

uint32_t edma_init_type::memory0_base_addr

base addrress for memory 0

Definition at line 442 of file at32f435_437_edma.h.

Referenced by dvp_dma_init(), edma_config(), edma_default_para_init(), edma_init(), i2s_config(), and main().

◆ memory_burst_mode

edma_memory_burst_type edma_init_type::memory_burst_mode

edma memory burst transfer

Definition at line 453 of file at32f435_437_edma.h.

Referenced by dvp_dma_init(), edma_config(), edma_default_para_init(), edma_init(), i2s_config(), and main().

◆ memory_data_width

edma_memory_data_size_type edma_init_type::memory_data_width

memory data width for transmit

Definition at line 448 of file at32f435_437_edma.h.

Referenced by dvp_dma_init(), edma_config(), edma_default_para_init(), edma_init(), i2s_config(), and main().

◆ memory_inc_enable

confirm_state edma_init_type::memory_inc_enable

memory address increment after one transmit

Definition at line 446 of file at32f435_437_edma.h.

Referenced by dvp_dma_init(), edma_config(), edma_default_para_init(), edma_init(), i2s_config(), and main().

◆ peripheral_base_addr

uint32_t edma_init_type::peripheral_base_addr

base addrress for peripheral

Definition at line 441 of file at32f435_437_edma.h.

Referenced by dvp_dma_init(), edma_config(), edma_default_para_init(), edma_init(), i2s_config(), and main().

◆ peripheral_burst_mode

edma_peripheral_burst_type edma_init_type::peripheral_burst_mode

edma peripheral burst transfer

Definition at line 454 of file at32f435_437_edma.h.

Referenced by dvp_dma_init(), edma_config(), edma_default_para_init(), edma_init(), i2s_config(), and main().

◆ peripheral_data_width

edma_peripheral_data_size_type edma_init_type::peripheral_data_width

peripheral data width for transmit

Definition at line 447 of file at32f435_437_edma.h.

Referenced by dvp_dma_init(), edma_config(), edma_default_para_init(), edma_init(), i2s_config(), and main().

◆ peripheral_inc_enable

confirm_state edma_init_type::peripheral_inc_enable

periphera address increment after one transmit

Definition at line 445 of file at32f435_437_edma.h.

Referenced by dvp_dma_init(), edma_config(), edma_default_para_init(), edma_init(), i2s_config(), and main().

◆ priority

edma_priority_level_type edma_init_type::priority

edma priority can choose from very high, high, dedium or low

Definition at line 450 of file at32f435_437_edma.h.

Referenced by dvp_dma_init(), edma_config(), edma_default_para_init(), edma_init(), i2s_config(), and main().

The documentation for this struct was generated from the following file:
  • at32f435_437_edma.h


AT32F435/437 Firmwary Library: edmamux_sync_init_type Struct Reference

Data Fields
edmamux_sync_init_type Struct Reference
AT32F435_437_periph_driver » EDMA » EDMA_exported_types

edmamux sync init type More...

#include <at32f435_437_edma.h>

Data Fields

edmamux_sync_id_sel_type sync_signal_sel
edmamux_sync_pol_type sync_polarity
uint32_t sync_request_number
confirm_state sync_event_enable
confirm_state sync_enable

Detailed Description

edmamux sync init type

Definition at line 460 of file at32f435_437_edma.h.

Field Documentation

◆ sync_enable

confirm_state edmamux_sync_init_type::sync_enable

edma dmamux synchronization enable

Definition at line 466 of file at32f435_437_edma.h.

Referenced by edmamux_sync_config(), edmamux_sync_default_para_init(), and main().

◆ sync_event_enable

confirm_state edmamux_sync_init_type::sync_event_enable

edma dmamux event generation disabled

Definition at line 465 of file at32f435_437_edma.h.

Referenced by edmamux_sync_config(), edmamux_sync_default_para_init(), and main().

◆ sync_polarity

edmamux_sync_pol_type edmamux_sync_init_type::sync_polarity

edma dmamux synchronization polarity

Definition at line 463 of file at32f435_437_edma.h.

Referenced by edmamux_sync_config(), edmamux_sync_default_para_init(), and main().

◆ sync_request_number

uint32_t edmamux_sync_init_type::sync_request_number

edma dmamux number of dma requests before an output event is generated

Definition at line 464 of file at32f435_437_edma.h.

Referenced by edmamux_sync_config(), edmamux_sync_default_para_init(), and main().

◆ sync_signal_sel

edmamux_sync_id_sel_type edmamux_sync_init_type::sync_signal_sel

edma dmamux synchronization input select

Definition at line 462 of file at32f435_437_edma.h.

Referenced by edmamux_sync_config(), edmamux_sync_default_para_init(), and main().

The documentation for this struct was generated from the following file:
  • at32f435_437_edma.h


AT32F435/437 Firmwary Library: edmamux_gen_init_type Struct Reference

Data Fields
edmamux_gen_init_type Struct Reference
AT32F435_437_periph_driver » EDMA » EDMA_exported_types

edmamux generator init type More...

#include <at32f435_437_edma.h>

Data Fields

edmamux_gen_id_sel_type gen_signal_sel
edmamux_gen_pol_type gen_polarity
uint32_t gen_request_number
confirm_state gen_enable

Detailed Description

edmamux generator init type

Definition at line 472 of file at32f435_437_edma.h.

Field Documentation

◆ gen_enable

confirm_state edmamux_gen_init_type::gen_enable

edma dmamux generator enable

Definition at line 477 of file at32f435_437_edma.h.

Referenced by edmamux_generator_config(), edmamux_generator_default_para_init(), and main().

◆ gen_polarity

edmamux_gen_pol_type edmamux_gen_init_type::gen_polarity

edma dmamux generator trigger polarity

Definition at line 475 of file at32f435_437_edma.h.

Referenced by edmamux_generator_config(), edmamux_generator_default_para_init(), and main().

◆ gen_request_number

uint32_t edmamux_gen_init_type::gen_request_number

edma dmamux the number of dma requests to be generated after a trigger event

Definition at line 476 of file at32f435_437_edma.h.

Referenced by edmamux_generator_config(), edmamux_generator_default_para_init(), and main().

◆ gen_signal_sel

edmamux_gen_id_sel_type edmamux_gen_init_type::gen_signal_sel

edma dmamux generator dma request trigger input select

Definition at line 474 of file at32f435_437_edma.h.

Referenced by edmamux_generator_config(), edmamux_generator_default_para_init(), and main().

The documentation for this struct was generated from the following file:
  • at32f435_437_edma.h


AT32F435/437 Firmwary Library: edma_type Struct Reference

Data Fields
edma_type Struct Reference
AT32F435_437_periph_driver » EDMA » EDMA_exported_types

type define edma register all More...

#include <at32f435_437_edma.h>

Data Fields

union {
__IO uint32_t sts1
struct {
__IO uint32_t ferrf1: 1
__IO uint32_t reserved1: 1
__IO uint32_t dmerrf1: 1
__IO uint32_t dterrf1: 1
__IO uint32_t hdtf1: 1
__IO uint32_t fdtf1: 1
__IO uint32_t ferrf2: 1
__IO uint32_t reserved2: 1
__IO uint32_t dmerrf2: 1
__IO uint32_t dterrf2: 1
__IO uint32_t hdtf2: 1
__IO uint32_t fdtf2: 1
__IO uint32_t reserved3: 4
__IO uint32_t ferrf3: 1
__IO uint32_t reserved4: 1
__IO uint32_t dmerrf3: 1
__IO uint32_t dterrf3: 1
__IO uint32_t hdtf3: 1
__IO uint32_t fdtf3: 1
__IO uint32_t ferrf4: 1
__IO uint32_t reserved5: 1
__IO uint32_t dmerrf4: 1
__IO uint32_t dterrf4: 1
__IO uint32_t hdtf4: 1
__IO uint32_t fdtf4: 1
__IO uint32_t reserved6: 4
} sts1_bit
};
edma sts1 register, offset:0x00 More...
union {
__IO uint32_t sts2
struct {
__IO uint32_t ferrf5: 1
__IO uint32_t reserved1: 1
__IO uint32_t dmerrf5: 1
__IO uint32_t dterrf5: 1
__IO uint32_t hdtf5: 1
__IO uint32_t fdtf5: 1
__IO uint32_t ferrf6: 1
__IO uint32_t reserved2: 1
__IO uint32_t dmerrf6: 1
__IO uint32_t dterrf6: 1
__IO uint32_t hdtf6: 1
__IO uint32_t fdtf6: 1
__IO uint32_t reserved3: 4
__IO uint32_t ferrf7: 1
__IO uint32_t reserved4: 1
__IO uint32_t dmerrf7: 1
__IO uint32_t dterrf7: 1
__IO uint32_t hdtf7: 1
__IO uint32_t fdtf7: 1
__IO uint32_t ferrf8: 1
__IO uint32_t reserved5: 1
__IO uint32_t dmerrf8: 1
__IO uint32_t dterrf8: 1
__IO uint32_t hdtf8: 1
__IO uint32_t fdtf8: 1
__IO uint32_t reserved6: 4
} sts2_bit
};
edma sts2 register, offset:0x04 More...
union {
__IO uint32_t clr1
struct {
__IO uint32_t ferrfc1: 1
__IO uint32_t reserved1: 1
__IO uint32_t dmerrfc1: 1
__IO uint32_t dterrfc1: 1
__IO uint32_t hdtfc1: 1
__IO uint32_t fdtfc1: 1
__IO uint32_t ferrfc2: 1
__IO uint32_t reserved2: 1
__IO uint32_t dmerrfc2: 1
__IO uint32_t dterrfc2: 1
__IO uint32_t hdtfc2: 1
__IO uint32_t fdtfc2: 1
__IO uint32_t reserved3: 4
__IO uint32_t ferrfc3: 1
__IO uint32_t reserved4: 1
__IO uint32_t dmerrfc3: 1
__IO uint32_t dterrfc3: 1
__IO uint32_t hdtfc3: 1
__IO uint32_t fdtfc3: 1
__IO uint32_t ferrfc4: 1
__IO uint32_t reserved5: 1
__IO uint32_t dmerrfc4: 1
__IO uint32_t dterrfc4: 1
__IO uint32_t hdtfc4: 1
__IO uint32_t fdtfc4: 1
__IO uint32_t reserved6: 4
} clr1_bit
};
edma clr1 register, offset:0x08 More...
union {
__IO uint32_t clr2
struct {
__IO uint32_t ferrfc5: 1
__IO uint32_t reserved1: 1
__IO uint32_t dmerrfc5: 1
__IO uint32_t dterrfc5: 1
__IO uint32_t hdtfc5: 1
__IO uint32_t fdtfc5: 1
__IO uint32_t ferrfc6: 1
__IO uint32_t reserved2: 1
__IO uint32_t dmerrfc6: 1
__IO uint32_t dterrfc6: 1
__IO uint32_t hdtfc6: 1
__IO uint32_t fdtfc6: 1
__IO uint32_t reserved3: 4
__IO uint32_t ferrfc7: 1
__IO uint32_t reserved4: 1
__IO uint32_t dmerrfc7: 1
__IO uint32_t dterrfc7: 1
__IO uint32_t hdtfc7: 1
__IO uint32_t fdtfc7: 1
__IO uint32_t ferrfc8: 1
__IO uint32_t reserved5: 1
__IO uint32_t dmerrfc8: 1
__IO uint32_t dterrfc8: 1
__IO uint32_t hdtfc8: 1
__IO uint32_t fdtfc8: 1
__IO uint32_t reserved6: 4
} clr2_bit
};
edma clr2 register, offset:0x0C More...
union {
__IO uint32_t llctrl
struct {
__IO uint32_t s1llen: 1
__IO uint32_t s2llen: 1
__IO uint32_t s3llen: 1
__IO uint32_t s4llen: 1
__IO uint32_t s5llen: 1
__IO uint32_t s6llen: 1
__IO uint32_t s7llen: 1
__IO uint32_t s8llen: 1
__IO uint32_t reserved1: 24
} llctrl_bit
};
edma link list ctrl register, offset:0xD0 More...
union {
__IO uint32_t s2dctrl
struct {
__IO uint32_t s12den: 1
__IO uint32_t s22den: 1
__IO uint32_t s32den: 1
__IO uint32_t s42den: 1
__IO uint32_t s52den: 1
__IO uint32_t s62den: 1
__IO uint32_t s72den: 1
__IO uint32_t s82den: 1
__IO uint32_t reserved1: 24
} s2dctrl_bit
};
edma 2d ctrl register, offset:0xF4 More...
union {
__IO uint32_t muxsel
struct {
__IO uint32_t tblsel: 1
__IO uint32_t reserved1: 31
} muxsel_bit
};
edmamux sel register, offset:0x13C More...
union {
__IO uint32_t muxsyncsts
struct {
__IO uint32_t syncovf: 8
__IO uint32_t reserved1: 24
} muxsyncsts_bit
};
edmamux syncsts register, offset:0x170 More...
union {
__IO uint32_t muxsyncclr
struct {
__IO uint32_t syncovfc: 8
__IO uint32_t reserved1: 24
} muxsyncclr_bit
};
edmamux syncclr register, offset:0x174 More...
union {
__IO uint32_t muxgsts
struct {
__IO uint32_t trgovf: 4
__IO uint32_t reserved1: 28
} muxgsts_bit
};
edmamux request generator status register, offset:0x178 More...
union {
__IO uint32_t muxgclr
struct {
__IO uint32_t trgovfc: 4
__IO uint32_t reserved1: 28
} muxgclr_bit
};
edmamux request generator status clear register, offset:0x17C More...

Detailed Description

type define edma register all

Definition at line 483 of file at32f435_437_edma.h.

Field Documentation

◆

union { ... } edma_type::@379

edma sts1 register, offset:0x00

◆

union { ... } edma_type::@381

edma sts2 register, offset:0x04

◆

union { ... } edma_type::@383

edma clr1 register, offset:0x08

◆

union { ... } edma_type::@385

edma clr2 register, offset:0x0C

◆

union { ... } edma_type::@387

edma link list ctrl register, offset:0xD0

◆

union { ... } edma_type::@389

edma 2d ctrl register, offset:0xF4

◆

union { ... } edma_type::@391

edmamux sel register, offset:0x13C

◆

union { ... } edma_type::@393

edmamux syncsts register, offset:0x170

◆

union { ... } edma_type::@395

edmamux syncclr register, offset:0x174

◆

union { ... } edma_type::@397

edmamux request generator status register, offset:0x178

◆

union { ... } edma_type::@399

edmamux request generator status clear register, offset:0x17C

◆ clr1

__IO uint32_t edma_type::clr1

Definition at line 562 of file at32f435_437_edma.h.

◆

struct { ... } edma_type::clr1_bit

◆ clr2

__IO uint32_t edma_type::clr2

Definition at line 598 of file at32f435_437_edma.h.

◆

struct { ... } edma_type::clr2_bit

◆ dmerrf1

__IO uint32_t edma_type::dmerrf1

Definition at line 495 of file at32f435_437_edma.h.

◆ dmerrf2

__IO uint32_t edma_type::dmerrf2

Definition at line 501 of file at32f435_437_edma.h.

◆ dmerrf3

__IO uint32_t edma_type::dmerrf3

Definition at line 508 of file at32f435_437_edma.h.

◆ dmerrf4

__IO uint32_t edma_type::dmerrf4

Definition at line 514 of file at32f435_437_edma.h.

◆ dmerrf5

__IO uint32_t edma_type::dmerrf5

Definition at line 531 of file at32f435_437_edma.h.

◆ dmerrf6

__IO uint32_t edma_type::dmerrf6

Definition at line 537 of file at32f435_437_edma.h.

◆ dmerrf7

__IO uint32_t edma_type::dmerrf7

Definition at line 544 of file at32f435_437_edma.h.

◆ dmerrf8

__IO uint32_t edma_type::dmerrf8

Definition at line 550 of file at32f435_437_edma.h.

◆ dmerrfc1

__IO uint32_t edma_type::dmerrfc1

Definition at line 567 of file at32f435_437_edma.h.

◆ dmerrfc2

__IO uint32_t edma_type::dmerrfc2

Definition at line 573 of file at32f435_437_edma.h.

◆ dmerrfc3

__IO uint32_t edma_type::dmerrfc3

Definition at line 580 of file at32f435_437_edma.h.

◆ dmerrfc4

__IO uint32_t edma_type::dmerrfc4

Definition at line 586 of file at32f435_437_edma.h.

◆ dmerrfc5

__IO uint32_t edma_type::dmerrfc5

Definition at line 603 of file at32f435_437_edma.h.

◆ dmerrfc6

__IO uint32_t edma_type::dmerrfc6

Definition at line 609 of file at32f435_437_edma.h.

◆ dmerrfc7

__IO uint32_t edma_type::dmerrfc7

Definition at line 616 of file at32f435_437_edma.h.

◆ dmerrfc8

__IO uint32_t edma_type::dmerrfc8

Definition at line 622 of file at32f435_437_edma.h.

◆ dterrf1

__IO uint32_t edma_type::dterrf1

Definition at line 496 of file at32f435_437_edma.h.

◆ dterrf2

__IO uint32_t edma_type::dterrf2

Definition at line 502 of file at32f435_437_edma.h.

◆ dterrf3

__IO uint32_t edma_type::dterrf3

Definition at line 509 of file at32f435_437_edma.h.

◆ dterrf4

__IO uint32_t edma_type::dterrf4

Definition at line 515 of file at32f435_437_edma.h.

◆ dterrf5

__IO uint32_t edma_type::dterrf5

Definition at line 532 of file at32f435_437_edma.h.

◆ dterrf6

__IO uint32_t edma_type::dterrf6

Definition at line 538 of file at32f435_437_edma.h.

◆ dterrf7

__IO uint32_t edma_type::dterrf7

Definition at line 545 of file at32f435_437_edma.h.

◆ dterrf8

__IO uint32_t edma_type::dterrf8

Definition at line 551 of file at32f435_437_edma.h.

◆ dterrfc1

__IO uint32_t edma_type::dterrfc1

Definition at line 568 of file at32f435_437_edma.h.

◆ dterrfc2

__IO uint32_t edma_type::dterrfc2

Definition at line 574 of file at32f435_437_edma.h.

◆ dterrfc3

__IO uint32_t edma_type::dterrfc3

Definition at line 581 of file at32f435_437_edma.h.

◆ dterrfc4

__IO uint32_t edma_type::dterrfc4

Definition at line 587 of file at32f435_437_edma.h.

◆ dterrfc5

__IO uint32_t edma_type::dterrfc5

Definition at line 604 of file at32f435_437_edma.h.

◆ dterrfc6

__IO uint32_t edma_type::dterrfc6

Definition at line 610 of file at32f435_437_edma.h.

◆ dterrfc7

__IO uint32_t edma_type::dterrfc7

Definition at line 617 of file at32f435_437_edma.h.

◆ dterrfc8

__IO uint32_t edma_type::dterrfc8

Definition at line 623 of file at32f435_437_edma.h.

◆ fdtf1

__IO uint32_t edma_type::fdtf1

Definition at line 498 of file at32f435_437_edma.h.

◆ fdtf2

__IO uint32_t edma_type::fdtf2

Definition at line 504 of file at32f435_437_edma.h.

◆ fdtf3

__IO uint32_t edma_type::fdtf3

Definition at line 511 of file at32f435_437_edma.h.

◆ fdtf4

__IO uint32_t edma_type::fdtf4

Definition at line 517 of file at32f435_437_edma.h.

◆ fdtf5

__IO uint32_t edma_type::fdtf5

Definition at line 534 of file at32f435_437_edma.h.

◆ fdtf6

__IO uint32_t edma_type::fdtf6

Definition at line 540 of file at32f435_437_edma.h.

◆ fdtf7

__IO uint32_t edma_type::fdtf7

Definition at line 547 of file at32f435_437_edma.h.

◆ fdtf8

__IO uint32_t edma_type::fdtf8

Definition at line 553 of file at32f435_437_edma.h.

◆ fdtfc1

__IO uint32_t edma_type::fdtfc1

Definition at line 570 of file at32f435_437_edma.h.

◆ fdtfc2

__IO uint32_t edma_type::fdtfc2

Definition at line 576 of file at32f435_437_edma.h.

◆ fdtfc3

__IO uint32_t edma_type::fdtfc3

Definition at line 583 of file at32f435_437_edma.h.

◆ fdtfc4

__IO uint32_t edma_type::fdtfc4

Definition at line 589 of file at32f435_437_edma.h.

◆ fdtfc5

__IO uint32_t edma_type::fdtfc5

Definition at line 606 of file at32f435_437_edma.h.

◆ fdtfc6

__IO uint32_t edma_type::fdtfc6

Definition at line 612 of file at32f435_437_edma.h.

◆ fdtfc7

__IO uint32_t edma_type::fdtfc7

Definition at line 619 of file at32f435_437_edma.h.

◆ fdtfc8

__IO uint32_t edma_type::fdtfc8

Definition at line 625 of file at32f435_437_edma.h.

◆ ferrf1

__IO uint32_t edma_type::ferrf1

Definition at line 493 of file at32f435_437_edma.h.

◆ ferrf2

__IO uint32_t edma_type::ferrf2

Definition at line 499 of file at32f435_437_edma.h.

◆ ferrf3

__IO uint32_t edma_type::ferrf3

Definition at line 506 of file at32f435_437_edma.h.

◆ ferrf4

__IO uint32_t edma_type::ferrf4

Definition at line 512 of file at32f435_437_edma.h.

◆ ferrf5

__IO uint32_t edma_type::ferrf5

Definition at line 529 of file at32f435_437_edma.h.

◆ ferrf6

__IO uint32_t edma_type::ferrf6

Definition at line 535 of file at32f435_437_edma.h.

◆ ferrf7

__IO uint32_t edma_type::ferrf7

Definition at line 542 of file at32f435_437_edma.h.

◆ ferrf8

__IO uint32_t edma_type::ferrf8

Definition at line 548 of file at32f435_437_edma.h.

◆ ferrfc1

__IO uint32_t edma_type::ferrfc1

Definition at line 565 of file at32f435_437_edma.h.

◆ ferrfc2

__IO uint32_t edma_type::ferrfc2

Definition at line 571 of file at32f435_437_edma.h.

◆ ferrfc3

__IO uint32_t edma_type::ferrfc3

Definition at line 578 of file at32f435_437_edma.h.

◆ ferrfc4

__IO uint32_t edma_type::ferrfc4

Definition at line 584 of file at32f435_437_edma.h.

◆ ferrfc5

__IO uint32_t edma_type::ferrfc5

Definition at line 601 of file at32f435_437_edma.h.

◆ ferrfc6

__IO uint32_t edma_type::ferrfc6

Definition at line 607 of file at32f435_437_edma.h.

◆ ferrfc7

__IO uint32_t edma_type::ferrfc7

Definition at line 614 of file at32f435_437_edma.h.

◆ ferrfc8

__IO uint32_t edma_type::ferrfc8

Definition at line 620 of file at32f435_437_edma.h.

◆ hdtf1

__IO uint32_t edma_type::hdtf1

Definition at line 497 of file at32f435_437_edma.h.

◆ hdtf2

__IO uint32_t edma_type::hdtf2

Definition at line 503 of file at32f435_437_edma.h.

◆ hdtf3

__IO uint32_t edma_type::hdtf3

Definition at line 510 of file at32f435_437_edma.h.

◆ hdtf4

__IO uint32_t edma_type::hdtf4

Definition at line 516 of file at32f435_437_edma.h.

◆ hdtf5

__IO uint32_t edma_type::hdtf5

Definition at line 533 of file at32f435_437_edma.h.

◆ hdtf6

__IO uint32_t edma_type::hdtf6

Definition at line 539 of file at32f435_437_edma.h.

◆ hdtf7

__IO uint32_t edma_type::hdtf7

Definition at line 546 of file at32f435_437_edma.h.

◆ hdtf8

__IO uint32_t edma_type::hdtf8

Definition at line 552 of file at32f435_437_edma.h.

◆ hdtfc1

__IO uint32_t edma_type::hdtfc1

Definition at line 569 of file at32f435_437_edma.h.

◆ hdtfc2

__IO uint32_t edma_type::hdtfc2

Definition at line 575 of file at32f435_437_edma.h.

◆ hdtfc3

__IO uint32_t edma_type::hdtfc3

Definition at line 582 of file at32f435_437_edma.h.

◆ hdtfc4

__IO uint32_t edma_type::hdtfc4

Definition at line 588 of file at32f435_437_edma.h.

◆ hdtfc5

__IO uint32_t edma_type::hdtfc5

Definition at line 605 of file at32f435_437_edma.h.

◆ hdtfc6

__IO uint32_t edma_type::hdtfc6

Definition at line 611 of file at32f435_437_edma.h.

◆ hdtfc7

__IO uint32_t edma_type::hdtfc7

Definition at line 618 of file at32f435_437_edma.h.

◆ hdtfc8

__IO uint32_t edma_type::hdtfc8

Definition at line 624 of file at32f435_437_edma.h.

◆ llctrl

__IO uint32_t edma_type::llctrl

Definition at line 640 of file at32f435_437_edma.h.

◆

struct { ... } edma_type::llctrl_bit

◆ muxgclr

__IO uint32_t edma_type::muxgclr

Definition at line 747 of file at32f435_437_edma.h.

◆

struct { ... } edma_type::muxgclr_bit

◆ muxgsts

__IO uint32_t edma_type::muxgsts

Definition at line 734 of file at32f435_437_edma.h.

◆

struct { ... } edma_type::muxgsts_bit

◆ muxsel

__IO uint32_t edma_type::muxsel

Definition at line 690 of file at32f435_437_edma.h.

◆

struct { ... } edma_type::muxsel_bit

◆ muxsyncclr

__IO uint32_t edma_type::muxsyncclr

Definition at line 721 of file at32f435_437_edma.h.

◆

struct { ... } edma_type::muxsyncclr_bit

◆ muxsyncsts

__IO uint32_t edma_type::muxsyncsts

Definition at line 708 of file at32f435_437_edma.h.

◆

struct { ... } edma_type::muxsyncsts_bit

◆ reserved1

__IO uint32_t edma_type::reserved1

reserved, offset:0x10~0xCC

Definition at line 494 of file at32f435_437_edma.h.

◆ reserved2

__IO uint32_t edma_type::reserved2

reserved, offset:0xD4~0xF0

Definition at line 500 of file at32f435_437_edma.h.

◆ reserved3

__IO uint32_t edma_type::reserved3

reserved, offset:0xF8~0x138

Definition at line 505 of file at32f435_437_edma.h.

◆ reserved4

__IO uint32_t edma_type::reserved4

reserved, offset:0x140~0x16C

Definition at line 507 of file at32f435_437_edma.h.

◆ reserved5

__IO uint32_t edma_type::reserved5

Definition at line 513 of file at32f435_437_edma.h.

◆ reserved6

__IO uint32_t edma_type::reserved6

Definition at line 518 of file at32f435_437_edma.h.

◆ s12den

__IO uint32_t edma_type::s12den

Definition at line 668 of file at32f435_437_edma.h.

◆ s1llen

__IO uint32_t edma_type::s1llen

Definition at line 643 of file at32f435_437_edma.h.

◆ s22den

__IO uint32_t edma_type::s22den

Definition at line 669 of file at32f435_437_edma.h.

◆ s2dctrl

__IO uint32_t edma_type::s2dctrl

Definition at line 665 of file at32f435_437_edma.h.

◆

struct { ... } edma_type::s2dctrl_bit

◆ s2llen

__IO uint32_t edma_type::s2llen

Definition at line 644 of file at32f435_437_edma.h.

◆ s32den

__IO uint32_t edma_type::s32den

Definition at line 670 of file at32f435_437_edma.h.

◆ s3llen

__IO uint32_t edma_type::s3llen

Definition at line 645 of file at32f435_437_edma.h.

◆ s42den

__IO uint32_t edma_type::s42den

Definition at line 671 of file at32f435_437_edma.h.

◆ s4llen

__IO uint32_t edma_type::s4llen

Definition at line 646 of file at32f435_437_edma.h.

◆ s52den

__IO uint32_t edma_type::s52den

Definition at line 672 of file at32f435_437_edma.h.

◆ s5llen

__IO uint32_t edma_type::s5llen

Definition at line 647 of file at32f435_437_edma.h.

◆ s62den

__IO uint32_t edma_type::s62den

Definition at line 673 of file at32f435_437_edma.h.

◆ s6llen

__IO uint32_t edma_type::s6llen

Definition at line 648 of file at32f435_437_edma.h.

◆ s72den

__IO uint32_t edma_type::s72den

Definition at line 674 of file at32f435_437_edma.h.

◆ s7llen

__IO uint32_t edma_type::s7llen

Definition at line 649 of file at32f435_437_edma.h.

◆ s82den

__IO uint32_t edma_type::s82den

Definition at line 675 of file at32f435_437_edma.h.

◆ s8llen

__IO uint32_t edma_type::s8llen

Definition at line 650 of file at32f435_437_edma.h.

◆ sts1

__IO uint32_t edma_type::sts1

Definition at line 490 of file at32f435_437_edma.h.

◆

struct { ... } edma_type::sts1_bit

◆ sts2

__IO uint32_t edma_type::sts2

Definition at line 526 of file at32f435_437_edma.h.

◆

struct { ... } edma_type::sts2_bit

◆ syncovf

__IO uint32_t edma_type::syncovf

Definition at line 711 of file at32f435_437_edma.h.

◆ syncovfc

__IO uint32_t edma_type::syncovfc

Definition at line 724 of file at32f435_437_edma.h.

◆ tblsel

__IO uint32_t edma_type::tblsel

Definition at line 693 of file at32f435_437_edma.h.

◆ trgovf

__IO uint32_t edma_type::trgovf

Definition at line 737 of file at32f435_437_edma.h.

◆ trgovfc

__IO uint32_t edma_type::trgovfc

Definition at line 750 of file at32f435_437_edma.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_edma.h


AT32F435/437 Firmwary Library: edma_stream_type Struct Reference

Data Fields
edma_stream_type Struct Reference
AT32F435_437_periph_driver » EDMA » EDMA_exported_types

type define edma stream register all More...

#include <at32f435_437_edma.h>

Data Fields

union {
__IO uint32_t ctrl
struct {
__IO uint32_t sen: 1
__IO uint32_t dmerrien: 1
__IO uint32_t dterrien: 1
__IO uint32_t hdtien: 1
__IO uint32_t fdtien: 1
__IO uint32_t pfctrl: 1
__IO uint32_t dtd: 2
__IO uint32_t lm: 1
__IO uint32_t pincm: 1
__IO uint32_t mincm: 1
__IO uint32_t pwidth: 2
__IO uint32_t mwidth: 2
__IO uint32_t pincos: 1
__IO uint32_t spl: 2
__IO uint32_t dmm: 1
__IO uint32_t cm: 1
__IO uint32_t reserved1: 1
__IO uint32_t pct: 2
__IO uint32_t mct: 2
__IO uint32_t reserved2: 3
__IO uint32_t reserved3: 4
} ctrl_bit
};
edma sxctrl register, offset:0x10+0x18*n n=1...8 More...
union {
__IO uint32_t dtcnt
struct {
__IO uint32_t cnt: 16
__IO uint32_t reserved1: 16
} dtcnt_bit
};
edma dtcnt register, offset:0x14+0x18*n n=1...8 More...
union {
__IO uint32_t paddr
struct {
__IO uint32_t paddr: 32
} paddr_bit
};
edma paddr register, offset:0x18+0x18*n n=1...8 More...
union {
__IO uint32_t m0addr
struct {
__IO uint32_t m0addr: 32
} m0addr_bit
};
edma m0adr register, offset:0x1C+0x18*n n=1...8 More...
union {
__IO uint32_t m1addr
struct {
__IO uint32_t m1addr: 32
} m1addr_bit
};
edma m1adr register, offset:0x20+0x18*n n=1...8 More...
union {
__IO uint32_t fctrl
struct {
__IO uint32_t fthsel: 2
__IO uint32_t fen: 1
__IO uint32_t fsts: 3
__IO uint32_t reserved1: 1
__IO uint32_t ferrien: 1
__IO uint32_t reserved2: 24
} fctrl_bit
};
edma fctrl register, offset:0x24+0x18*n n=1...8 More...

Detailed Description

type define edma stream register all

Definition at line 760 of file at32f435_437_edma.h.

Field Documentation

◆

union { ... } edma_stream_type::@412

edma sxctrl register, offset:0x10+0x18*n n=1...8

◆

union { ... } edma_stream_type::@414

edma dtcnt register, offset:0x14+0x18*n n=1...8

◆

union { ... } edma_stream_type::@416

edma paddr register, offset:0x18+0x18*n n=1...8

◆

union { ... } edma_stream_type::@418

edma m0adr register, offset:0x1C+0x18*n n=1...8

◆

union { ... } edma_stream_type::@420

edma m1adr register, offset:0x20+0x18*n n=1...8

◆

union { ... } edma_stream_type::@422

edma fctrl register, offset:0x24+0x18*n n=1...8

◆ cm

__IO uint32_t edma_stream_type::cm

Definition at line 785 of file at32f435_437_edma.h.

Referenced by edma_double_buffer_mode_init(), and edma_memory_target_get().

◆ cnt

__IO uint32_t edma_stream_type::cnt

Definition at line 801 of file at32f435_437_edma.h.

◆ ctrl

__IO uint32_t edma_stream_type::ctrl

Definition at line 767 of file at32f435_437_edma.h.

Referenced by edma_interrupt_enable(), and edma_reset().

◆

struct { ... } edma_stream_type::ctrl_bit

Referenced by edma_double_buffer_mode_enable(), edma_double_buffer_mode_init(), edma_flow_controller_enable(), edma_init(), edma_memory_target_get(), edma_peripheral_inc_offset_set(), edma_reset(), edma_stream_enable(), and edma_stream_status_get().

◆ dmerrien

__IO uint32_t edma_stream_type::dmerrien

Definition at line 771 of file at32f435_437_edma.h.

◆ dmm

__IO uint32_t edma_stream_type::dmm

Definition at line 784 of file at32f435_437_edma.h.

Referenced by edma_double_buffer_mode_enable().

◆ dtcnt

__IO uint32_t edma_stream_type::dtcnt

Definition at line 798 of file at32f435_437_edma.h.

Referenced by edma_data_number_get(), edma_data_number_set(), edma_init(), and edma_reset().

◆

struct { ... } edma_stream_type::dtcnt_bit

◆ dtd

__IO uint32_t edma_stream_type::dtd

Definition at line 776 of file at32f435_437_edma.h.

Referenced by edma_init().

◆ dterrien

__IO uint32_t edma_stream_type::dterrien

Definition at line 772 of file at32f435_437_edma.h.

◆ fctrl

__IO uint32_t edma_stream_type::fctrl

Definition at line 843 of file at32f435_437_edma.h.

Referenced by edma_interrupt_enable(), and edma_reset().

◆

struct { ... } edma_stream_type::fctrl_bit

Referenced by edma_fifo_status_get(), and edma_init().

◆ fdtien

__IO uint32_t edma_stream_type::fdtien

Definition at line 774 of file at32f435_437_edma.h.

◆ fen

__IO uint32_t edma_stream_type::fen

Definition at line 847 of file at32f435_437_edma.h.

Referenced by edma_init().

◆ ferrien

__IO uint32_t edma_stream_type::ferrien

Definition at line 850 of file at32f435_437_edma.h.

◆ fsts

__IO uint32_t edma_stream_type::fsts

Definition at line 848 of file at32f435_437_edma.h.

Referenced by edma_fifo_status_get().

◆ fthsel

__IO uint32_t edma_stream_type::fthsel

Definition at line 846 of file at32f435_437_edma.h.

Referenced by edma_init().

◆ hdtien

__IO uint32_t edma_stream_type::hdtien

Definition at line 773 of file at32f435_437_edma.h.

◆ lm

__IO uint32_t edma_stream_type::lm

Definition at line 777 of file at32f435_437_edma.h.

Referenced by edma_init().

◆ m0addr

__IO uint32_t edma_stream_type::m0addr

Definition at line 821 of file at32f435_437_edma.h.

Referenced by edma_init(), edma_memory_addr_set(), and edma_reset().

◆

struct { ... } edma_stream_type::m0addr_bit

◆ m1addr

__IO uint32_t edma_stream_type::m1addr

Definition at line 832 of file at32f435_437_edma.h.

Referenced by edma_double_buffer_mode_init(), edma_memory_addr_set(), and edma_reset().

◆

struct { ... } edma_stream_type::m1addr_bit

◆ mct

__IO uint32_t edma_stream_type::mct

Definition at line 788 of file at32f435_437_edma.h.

Referenced by edma_init().

◆ mincm

__IO uint32_t edma_stream_type::mincm

Definition at line 779 of file at32f435_437_edma.h.

Referenced by edma_init().

◆ mwidth

__IO uint32_t edma_stream_type::mwidth

Definition at line 781 of file at32f435_437_edma.h.

Referenced by edma_init().

◆ paddr

__IO uint32_t edma_stream_type::paddr

Definition at line 810 of file at32f435_437_edma.h.

Referenced by edma_init(), and edma_reset().

◆

struct { ... } edma_stream_type::paddr_bit

◆ pct

__IO uint32_t edma_stream_type::pct

Definition at line 787 of file at32f435_437_edma.h.

Referenced by edma_init().

◆ pfctrl

__IO uint32_t edma_stream_type::pfctrl

Definition at line 775 of file at32f435_437_edma.h.

Referenced by edma_flow_controller_enable().

◆ pincm

__IO uint32_t edma_stream_type::pincm

Definition at line 778 of file at32f435_437_edma.h.

Referenced by edma_init().

◆ pincos

__IO uint32_t edma_stream_type::pincos

Definition at line 782 of file at32f435_437_edma.h.

Referenced by edma_peripheral_inc_offset_set().

◆ pwidth

__IO uint32_t edma_stream_type::pwidth

Definition at line 780 of file at32f435_437_edma.h.

Referenced by edma_init().

◆ reserved1

__IO uint32_t edma_stream_type::reserved1

Definition at line 786 of file at32f435_437_edma.h.

◆ reserved2

__IO uint32_t edma_stream_type::reserved2

Definition at line 789 of file at32f435_437_edma.h.

◆ reserved3

__IO uint32_t edma_stream_type::reserved3

Definition at line 790 of file at32f435_437_edma.h.

◆ sen

__IO uint32_t edma_stream_type::sen

Definition at line 770 of file at32f435_437_edma.h.

Referenced by edma_reset(), edma_stream_enable(), and edma_stream_status_get().

◆ spl

__IO uint32_t edma_stream_type::spl

Definition at line 783 of file at32f435_437_edma.h.

Referenced by edma_init().

The documentation for this struct was generated from the following file:
  • at32f435_437_edma.h


AT32F435/437 Firmwary Library: edma_stream_link_list_type Struct Reference

Data Fields
edma_stream_link_list_type Struct Reference
AT32F435_437_periph_driver » EDMA » EDMA_exported_types

type define edma stream link list pointer register More...

#include <at32f435_437_edma.h>

Data Fields

union {
__IO uint32_t llp
struct {
__IO uint32_t llp: 32
} llp_bit
};
edma stream link list pointer register More...

Detailed Description

type define edma stream link list pointer register

Definition at line 859 of file at32f435_437_edma.h.

Field Documentation

◆

union { ... } edma_stream_link_list_type::@430

edma stream link list pointer register

◆ llp

__IO uint32_t edma_stream_link_list_type::llp

Definition at line 866 of file at32f435_437_edma.h.

Referenced by edma_link_list_init().

◆

struct { ... } edma_stream_link_list_type::llp_bit
The documentation for this struct was generated from the following file:
  • at32f435_437_edma.h


AT32F435/437 Firmwary Library: edma_stream_2d_type Struct Reference

Data Fields
edma_stream_2d_type Struct Reference
AT32F435_437_periph_driver » EDMA » EDMA_exported_types

type define edma 2d register all More...

#include <at32f435_437_edma.h>

Data Fields

union {
__IO uint32_t s2dcnt
struct {
__IO uint32_t xcnt: 16
__IO uint32_t ycnt: 16
} s2dcnt_bit
};
edma s2dcnt register, offset:0x00 More...
union {
__IO uint32_t stride
struct {
__IO uint32_t srcstd: 16
__IO uint32_t dststd: 16
} stride_bit
};
edma stride register, offset:0x04 More...

Detailed Description

type define edma 2d register all

Definition at line 877 of file at32f435_437_edma.h.

Field Documentation

◆

union { ... } edma_stream_2d_type::@433

edma s2dcnt register, offset:0x00

◆

union { ... } edma_stream_2d_type::@435

edma stride register, offset:0x04

◆ dststd

__IO uint32_t edma_stream_2d_type::dststd

Definition at line 900 of file at32f435_437_edma.h.

◆ s2dcnt

__IO uint32_t edma_stream_2d_type::s2dcnt

Definition at line 884 of file at32f435_437_edma.h.

Referenced by edma_2d_init().

◆

struct { ... } edma_stream_2d_type::s2dcnt_bit

◆ srcstd

__IO uint32_t edma_stream_2d_type::srcstd

Definition at line 899 of file at32f435_437_edma.h.

◆ stride

__IO uint32_t edma_stream_2d_type::stride

Definition at line 896 of file at32f435_437_edma.h.

Referenced by edma_2d_init().

◆

struct { ... } edma_stream_2d_type::stride_bit

◆ xcnt

__IO uint32_t edma_stream_2d_type::xcnt

Definition at line 887 of file at32f435_437_edma.h.

◆ ycnt

__IO uint32_t edma_stream_2d_type::ycnt

Definition at line 888 of file at32f435_437_edma.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_edma.h


AT32F435/437 Firmwary Library: edmamux_channel_type Struct Reference

Data Fields
edmamux_channel_type Struct Reference
AT32F435_437_periph_driver » EDMA » EDMA_exported_types

type define edmamux muxsctrl register More...

#include <at32f435_437_edma.h>

Data Fields

union {
__IO uint32_t muxctrl
struct {
__IO uint32_t reqsel: 7
__IO uint32_t reserved1: 1
__IO uint32_t syncovien: 1
__IO uint32_t evtgen: 1
__IO uint32_t reserved2: 6
__IO uint32_t syncen: 1
__IO uint32_t syncpol: 2
__IO uint32_t reqcnt: 5
__IO uint32_t syncsel: 5
__IO uint32_t reserved3: 3
} muxctrl_bit
};
edma muxsctrl register More...

Detailed Description

type define edmamux muxsctrl register

Definition at line 908 of file at32f435_437_edma.h.

Field Documentation

◆

union { ... } edmamux_channel_type::@439

edma muxsctrl register

◆ evtgen

__IO uint32_t edmamux_channel_type::evtgen

Definition at line 921 of file at32f435_437_edma.h.

Referenced by edmamux_sync_config().

◆ muxctrl

__IO uint32_t edmamux_channel_type::muxctrl

Definition at line 915 of file at32f435_437_edma.h.

◆

struct { ... } edmamux_channel_type::muxctrl_bit

Referenced by edmamux_init(), edmamux_sync_config(), and edmamux_sync_interrupt_enable().

◆ reqcnt

__IO uint32_t edmamux_channel_type::reqcnt

Definition at line 925 of file at32f435_437_edma.h.

Referenced by edmamux_sync_config().

◆ reqsel

__IO uint32_t edmamux_channel_type::reqsel

Definition at line 918 of file at32f435_437_edma.h.

Referenced by edmamux_init().

◆ reserved1

__IO uint32_t edmamux_channel_type::reserved1

Definition at line 919 of file at32f435_437_edma.h.

◆ reserved2

__IO uint32_t edmamux_channel_type::reserved2

Definition at line 922 of file at32f435_437_edma.h.

◆ reserved3

__IO uint32_t edmamux_channel_type::reserved3

Definition at line 927 of file at32f435_437_edma.h.

◆ syncen

__IO uint32_t edmamux_channel_type::syncen

Definition at line 923 of file at32f435_437_edma.h.

Referenced by edmamux_sync_config().

◆ syncovien

__IO uint32_t edmamux_channel_type::syncovien

Definition at line 920 of file at32f435_437_edma.h.

Referenced by edmamux_sync_interrupt_enable().

◆ syncpol

__IO uint32_t edmamux_channel_type::syncpol

Definition at line 924 of file at32f435_437_edma.h.

Referenced by edmamux_sync_config().

◆ syncsel

__IO uint32_t edmamux_channel_type::syncsel

Definition at line 926 of file at32f435_437_edma.h.

Referenced by edmamux_sync_config().

The documentation for this struct was generated from the following file:
  • at32f435_437_edma.h


AT32F435/437 Firmwary Library: edmamux_generator_type Struct Reference

Data Fields
edmamux_generator_type Struct Reference
AT32F435_437_periph_driver » EDMA » EDMA_exported_types

type define edmamux request generator register all More...

#include <at32f435_437_edma.h>

Data Fields

union {
__IO uint32_t gctrl
struct {
__IO uint32_t sigsel: 5
__IO uint32_t reserved1: 3
__IO uint32_t trgovien: 1
__IO uint32_t reserved2: 7
__IO uint32_t gen: 1
__IO uint32_t gpol: 2
__IO uint32_t greqcnt: 5
__IO uint32_t reserved3: 8
} gctrl_bit
};
edmamux request generator register, offset:0x160+n*4 n=1...8 More...

Detailed Description

type define edmamux request generator register all

Definition at line 935 of file at32f435_437_edma.h.

Field Documentation

◆

union { ... } edmamux_generator_type::@442

edmamux request generator register, offset:0x160+n*4 n=1...8

◆ gctrl

__IO uint32_t edmamux_generator_type::gctrl

Definition at line 942 of file at32f435_437_edma.h.

◆

struct { ... } edmamux_generator_type::gctrl_bit

Referenced by edmamux_generator_config(), and edmamux_generator_interrupt_enable().

◆ gen

__IO uint32_t edmamux_generator_type::gen

Definition at line 949 of file at32f435_437_edma.h.

Referenced by edmamux_generator_config().

◆ gpol

__IO uint32_t edmamux_generator_type::gpol

Definition at line 950 of file at32f435_437_edma.h.

Referenced by edmamux_generator_config().

◆ greqcnt

__IO uint32_t edmamux_generator_type::greqcnt

Definition at line 951 of file at32f435_437_edma.h.

Referenced by edmamux_generator_config().

◆ reserved1

__IO uint32_t edmamux_generator_type::reserved1

Definition at line 946 of file at32f435_437_edma.h.

◆ reserved2

__IO uint32_t edmamux_generator_type::reserved2

Definition at line 948 of file at32f435_437_edma.h.

◆ reserved3

__IO uint32_t edmamux_generator_type::reserved3

Definition at line 952 of file at32f435_437_edma.h.

◆ sigsel

__IO uint32_t edmamux_generator_type::sigsel

Definition at line 945 of file at32f435_437_edma.h.

Referenced by edmamux_generator_config().

◆ trgovien

__IO uint32_t edmamux_generator_type::trgovien

Definition at line 947 of file at32f435_437_edma.h.

Referenced by edmamux_generator_interrupt_enable().

The documentation for this struct was generated from the following file:
  • at32f435_437_edma.h


AT32F435/437 Firmwary Library: EDMA_exported_functions

Functions
EDMA_exported_functions
AT32F435_437_periph_driver » EDMA

Functions

void | edma_reset (edma_stream_type *edma_streamx)
reset edma_streamx channely register. More...
void | edma_init (edma_stream_type *edma_streamx, edma_init_type *edma_init_struct)
edma init. More...
void | edma_default_para_init (edma_init_type *edma_init_struct)
edma init struct config with its default value. More...
void | edma_stream_enable (edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx. More...
void | edma_interrupt_enable (edma_stream_type *edma_streamx, uint32_t edma_int, confirm_state new_state)
enable or disable the edma streamx interrupts. More...
void | edma_peripheral_inc_offset_set (edma_stream_type *edma_streamx, edma_peripheral_inc_offset_type offset)
config the edma peripheral increment offset size mode. More...
void | edma_flow_controller_enable (edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx flow controller. More...
void | edma_data_number_set (edma_stream_type *edma_streamx, uint16_t data_number)
set the number of data to be transferred. More...
uint16_t | edma_data_number_get (edma_stream_type *edma_streamx)
get the number of data to be transferred. More...
void | edma_double_buffer_mode_init (edma_stream_type *edma_streamx, uint32_t memory1_addr, edma_memory_type current_memory)
config the the double buffer mode. More...
void | edma_double_buffer_mode_enable (edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the double memory mode. More...
void | edma_memory_addr_set (edma_stream_type *edma_streamx, uint32_t memory_addr, uint32_t memory_target)
config the memory address in double buffer mode. More...
edma_memory_type | edma_memory_target_get (edma_stream_type *edma_streamx)
get the current memory target. More...
flag_status | edma_stream_status_get (edma_stream_type *edma_streamx)
get the enable status of edma streamx. More...
uint8_t | edma_fifo_status_get (edma_stream_type *edma_streamx)
get the fifo level status. More...
flag_status | edma_flag_get (uint32_t edma_flag)
get the edma flag. More...
void | edma_flag_clear (uint32_t edma_flag)
clear the edma flag. More...
void | edma_2d_init (edma_stream_2d_type *edma_streamx_2d, int16_t src_stride, int16_t dst_stride, uint16_t xcnt, uint16_t ycnt)
initialize the edma 2d mode. More...
void | edma_2d_enable (edma_stream_2d_type *edma_streamx_2d, confirm_state new_state)
enable or disable the edma 2d mode. More...
void | edma_link_list_init (edma_stream_link_list_type *edma_streamx_ll, uint32_t pointer)
initialize the edma link list. More...
void | edma_link_list_enable (edma_stream_link_list_type *edma_streamx_ll, confirm_state new_state)
enable or disable the edma stream link list mode. More...
void | edmamux_enable (confirm_state new_state)
enable or disable the edma edmamux. More...
void | edmamux_init (edmamux_channel_type *edmamux_channelx, edmamux_requst_id_sel_type edmamux_req_id)
edmamux init. More...
void | edmamux_sync_default_para_init (edmamux_sync_init_type *edmamux_sync_init_struct)
edmamux sync init struct config with its default value. More...
void | edmamux_sync_config (edmamux_channel_type *edmamux_channelx, edmamux_sync_init_type *edmamux_sync_init_struct)
edmamux synchronization config. More...
void | edmamux_generator_default_para_init (edmamux_gen_init_type *edmamux_gen_init_struct)
edmamux request generator init struct config with its default value. More...
void | edmamux_generator_config (edmamux_generator_type *edmamux_gen_x, edmamux_gen_init_type *edmamux_gen_init_struct)
edmamux request generator init. More...
void | edmamux_sync_interrupt_enable (edmamux_channel_type *edmamux_channelx, confirm_state new_state)
enable or disable the edmamux sync interrupts. More...
void | edmamux_generator_interrupt_enable (edmamux_generator_type *edmamux_gen_x, confirm_state new_state)
enable or disable the edmamux request generator interrupts. More...
flag_status | edmamux_sync_flag_get (uint32_t flag)
edmamux sync flag get. More...
void | edmamux_sync_flag_clear (uint32_t flag)
edmamux sync flag clear. More...
flag_status | edmamux_generator_flag_get (uint32_t flag)
edmamux request generator flag get. More...
void | edmamux_generator_flag_clear (uint32_t flag)
edmamux request generator flag clear. More...

Detailed Description

Function Documentation

◆ edma_2d_enable()

void edma_2d_enable | ( | edma_stream_2d_type * | edma_streamx_2d,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the edma 2d mode.

Parameters
edma_streamx_2d this parameter can be one of the following values:
  • EDMA_STREAM1_2D
  • EDMA_STREAM2_2D
  • EDMA_STREAM3_2D
  • EDMA_STREAM4_2D
  • EDMA_STREAM5_2D
  • EDMA_STREAM6_2D
  • EDMA_STREAM7_2D
  • EDMA_STREAM8_2D
new_state (TRUE or FALSE).
Return values
none.

Definition at line 601 of file at32f435_437_edma.c.

Referenced by main().

◆ edma_2d_init()

void edma_2d_init | ( | edma_stream_2d_type * | edma_streamx_2d,
 |  | int16_t | src_stride,
 |  | int16_t | dst_stride,
 |  | uint16_t | xcnt,
 |  | uint16_t | ycnt
 | ) |  |

initialize the edma 2d mode.

Parameters
edma_streamx_2d this parameter can be one of the following values:
  • EDMA_STREAM1_2D
  • EDMA_STREAM2_2D
  • EDMA_STREAM3_2D
  • EDMA_STREAM4_2D
  • EDMA_STREAM5_2D
  • EDMA_STREAM6_2D
  • EDMA_STREAM7_2D
  • EDMA_STREAM8_2D
src_stride | source stride(-32768 ~ 32767).
dst_stride | destination stride(-32768 ~ 32767).
xcnt | x dimension transfer count(0x0000~ 0xFFFF).
ycnt | y dimension transfer count(0x0000~ 0xFFFF).
Return values
none.

Definition at line 579 of file at32f435_437_edma.c.

Referenced by main().

◆ edma_data_number_get()

uint16_t edma_data_number_get ( edma_stream_type * edma_streamx )

get the number of data to be transferred.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
Return values
the number value.

Definition at line 330 of file at32f435_437_edma.c.

◆ edma_data_number_set()

void edma_data_number_set | ( | edma_stream_type * | edma_streamx,
 |  | uint16_t | data_number
 | ) |  |

set the number of data to be transferred.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
data_number the number of data to be transferred (0x0000~0xFFFF).
Return values
none.

Definition at line 310 of file at32f435_437_edma.c.

◆ edma_default_para_init()

void edma_default_para_init ( edma_init_type * edma_init_struct )

edma init struct config with its default value.

Parameters
edma_init_struct pointer to a edma_init_type structure which will be initialized.
Return values
none.

Definition at line 165 of file at32f435_437_edma.c.

Referenced by edma_config(), i2s_config(), and main().

◆ edma_double_buffer_mode_enable()

void edma_double_buffer_mode_enable | ( | edma_stream_type * | edma_streamx,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the double memory mode.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
new_state (TRUE or FALSE).
Return values
none.

Definition at line 383 of file at32f435_437_edma.c.

Referenced by dvp_dma_init(), edma_config(), and i2s_config().

◆ edma_double_buffer_mode_init()

void edma_double_buffer_mode_init | ( | edma_stream_type * | edma_streamx,
 |  | uint32_t | memory1_addr,
 |  | edma_memory_type | current_memory
 | ) |  |

config the the double buffer mode.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
memory1_addr the address of the second buffer.
current_memory specifies the target area of the first transfer. this parameter can be one of the following values:
  • EDMA_MEMORY_0
  • EDMA_MEMORY_1
Return values
none.

Definition at line 354 of file at32f435_437_edma.c.

Referenced by dvp_dma_init(), edma_config(), and i2s_config().

◆ edma_fifo_status_get()

uint8_t edma_fifo_status_get ( edma_stream_type * edma_streamx )

get the fifo level status.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
Return values
the fifo filling state.
  • EDMA_FIFO_STATUS_LESS_1QUARTER: (0) < fifo level < (1/4).
  • EDMA_FIFO_STATUS_1QUARTER: (1/4) <= fifo level < (1/2) .
  • EDMA_FIFO_STATUS_HALF: (1/2) <= fifo level < (3/4).
  • EDMA_FIFO_STATUS_3QUARTER: (3/4) <= fifo level < (1).
  • EDMA_FIFO_STATUS_EMPTY: fifo is empty.
  • EDMA_FIFO_STATUS_FULL: fifo is full.

Definition at line 493 of file at32f435_437_edma.c.

◆ edma_flag_clear()

void edma_flag_clear ( uint32_t edma_flag )

clear the edma flag.

Parameters
edma_flag this parameter can be one of the following values:
  • EDMA_FERR1_FLAG - EDMA_DMERR1_FLAG - EDMA_DTERR1_FLAG - EDMA_HDT1_FLAG - EDMA_FDT1_FLAG
  • EDMA_FERR2_FLAG - EDMA_DMERR2_FLAG - EDMA_DTERR2_FLAG - EDMA_HDT2_FLAG - EDMA_FDT2_FLAG
  • EDMA_FERR3_FLAG - EDMA_DMERR3_FLAG - EDMA_DTERR3_FLAG - EDMA_HDT3_FLAG - EDMA_FDT3_FLAG
  • EDMA_FERR4_FLAG - EDMA_DMERR4_FLAG - EDMA_DTERR4_FLAG - EDMA_HDT4_FLAG - EDMA_FDT4_FLAG
  • EDMA_FERR5_FLAG - EDMA_DMERR5_FLAG - EDMA_DTERR5_FLAG - EDMA_HDT5_FLAG - EDMA_FDT5_FLAG
  • EDMA_FERR6_FLAG - EDMA_DMERR6_FLAG - EDMA_DTERR6_FLAG - EDMA_HDT6_FLAG - EDMA_FDT6_FLAG
  • EDMA_FERR7_FLAG - EDMA_DMERR7_FLAG - EDMA_DTERR7_FLAG - EDMA_HDT7_FLAG - EDMA_FDT7_FLAG
  • EDMA_FERR8_FLAG - EDMA_DMERR8_FLAG - EDMA_DTERR8_FLAG - EDMA_HDT8_FLAG - EDMA_FDT8_FLAG
Return values
none.

Definition at line 549 of file at32f435_437_edma.c.

Referenced by EDMA_Stream1_IRQHandler(), and EDMA_Stream4_IRQHandler().

◆ edma_flag_get()

flag_status edma_flag_get ( uint32_t edma_flag )

get the edma flag.

Parameters
edma_flag this parameter can be one of the following values:
  • EDMA_FERR1_FLAG - EDMA_DMERR1_FLAG - EDMA_DTERR1_FLAG - EDMA_HDT1_FLAG - EDMA_FDT1_FLAG
  • EDMA_FERR2_FLAG - EDMA_DMERR2_FLAG - EDMA_DTERR2_FLAG - EDMA_HDT2_FLAG - EDMA_FDT2_FLAG
  • EDMA_FERR3_FLAG - EDMA_DMERR3_FLAG - EDMA_DTERR3_FLAG - EDMA_HDT3_FLAG - EDMA_FDT3_FLAG
  • EDMA_FERR4_FLAG - EDMA_DMERR4_FLAG - EDMA_DTERR4_FLAG - EDMA_HDT4_FLAG - EDMA_FDT4_FLAG
  • EDMA_FERR5_FLAG - EDMA_DMERR5_FLAG - EDMA_DTERR5_FLAG - EDMA_HDT5_FLAG - EDMA_FDT5_FLAG
  • EDMA_FERR6_FLAG - EDMA_DMERR6_FLAG - EDMA_DTERR6_FLAG - EDMA_HDT6_FLAG - EDMA_FDT6_FLAG
  • EDMA_FERR7_FLAG - EDMA_DMERR7_FLAG - EDMA_DTERR7_FLAG - EDMA_HDT7_FLAG - EDMA_FDT7_FLAG
  • EDMA_FERR8_FLAG - EDMA_DMERR8_FLAG - EDMA_DTERR8_FLAG - EDMA_HDT8_FLAG - EDMA_FDT8_FLAG
Return values
the new state of edma flag (SET or RESET).

Definition at line 512 of file at32f435_437_edma.c.

Referenced by EDMA_Stream1_IRQHandler(), and EDMA_Stream4_IRQHandler().

◆ edma_flow_controller_enable()

void edma_flow_controller_enable | ( | edma_stream_type * | edma_streamx,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the edma streamx flow controller.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
new_state (TRUE or FALSE).
Return values
none.

Definition at line 290 of file at32f435_437_edma.c.

◆ edma_init()

void edma_init | ( | edma_stream_type * | edma_streamx,
 |  | edma_init_type * | edma_init_struct
 | ) |  |

edma init.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
edma_init_struct pointer to a edma_init_type structure.
Return values
none.

Definition at line 115 of file at32f435_437_edma.c.

Referenced by dvp_dma_init(), edma_config(), i2s_config(), and main().

◆ edma_interrupt_enable()

void edma_interrupt_enable | ( | edma_stream_type * | edma_streamx,
 |  | uint32_t | edma_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the edma streamx interrupts.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
edma_int this parameter can be one of the following values:
  • EDMA_FDT_INT
  • EDMA_HDT_INT
  • EDMA_DTERR_INT
  • EDMA_DMERR_INT
  • EDMA_FERR_INT
new_state (TRUE or FALSE).
Return values
none.

Definition at line 225 of file at32f435_437_edma.c.

Referenced by dvp_dma_init(), edma_config(), i2s_config(), and main().

◆ edma_link_list_enable()

void edma_link_list_enable | ( | edma_stream_link_list_type * | edma_streamx_ll,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the edma stream link list mode.

Parameters
edma_streamx_ll this parameter can be any combination of the following values:
  • EDMA_STREAM1_LL
  • EDMA_STREAM2_LL
  • EDMA_STREAM3_LL
  • EDMA_STREAM4_LL
  • EDMA_STREAM5_LL
  • EDMA_STREAM6_LL
  • EDMA_STREAM7_LL
  • EDMA_STREAM8_LL
new_state (TRUE or FALSE).
Return values
none.

Definition at line 652 of file at32f435_437_edma.c.

Referenced by main().

◆ edma_link_list_init()

void edma_link_list_init | ( | edma_stream_link_list_type * | edma_streamx_ll,
 |  | uint32_t | pointer
 | ) |  |

initialize the edma link list.

Parameters
edma_streamx_ll this parameter can be one of the following values:
  • EDMA_STREAM1_LL
  • EDMA_STREAM2_LL
  • EDMA_STREAM3_LL
  • EDMA_STREAM4_LL
  • EDMA_STREAM5_LL
  • EDMA_STREAM6_LL
  • EDMA_STREAM7_LL
  • EDMA_STREAM8_LL
pointer link list pointer.
Return values
none.

Definition at line 632 of file at32f435_437_edma.c.

Referenced by main().

◆ edma_memory_addr_set()

void edma_memory_addr_set | ( | edma_stream_type * | edma_streamx,
 |  | uint32_t | memory_addr,
 |  | uint32_t | memory_target
 | ) |  |

config the memory address in double buffer mode.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
memory_addr the address of the buffer.
memory_target indicates the which memory addr register will be config. this parameter can be one of the following values:
  • EDMA_MEMORY_0
  • EDMA_MEMORY_1
Return values
none.

Definition at line 414 of file at32f435_437_edma.c.

◆ edma_memory_target_get()

edma_memory_type edma_memory_target_get ( edma_stream_type * edma_streamx )

get the current memory target.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
Return values
the memory target
  • EDMA_MEMORY_0
  • EDMA_MEMORY_1

Definition at line 442 of file at32f435_437_edma.c.

Referenced by EDMA_Stream1_IRQHandler().

◆ edma_peripheral_inc_offset_set()

void edma_peripheral_inc_offset_set | ( | edma_stream_type * | edma_streamx,
 |  | edma_peripheral_inc_offset_type | offset
 | ) |  |

config the edma peripheral increment offset size mode.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
offset peripheral increment offset size. this parameter can be one of the following values:
  • EDMA_PERIPHERAL_INC_PSIZE
  • EDMA_PERIPHERAL_INC_4_BYTE
Return values
none.

Definition at line 270 of file at32f435_437_edma.c.

◆ edma_reset()

void edma_reset ( edma_stream_type * edma_streamx )

reset edma_streamx channely register.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
Return values
none.

< edma stream1 interrupt mask

< edma stream1 interrupt mask

< edma stream2 interrupt mask

< edma stream1 interrupt mask

< edma stream3 interrupt mask

< edma stream1 interrupt mask

< edma stream4 interrupt mask

< edma stream1 interrupt mask

< edma stream5 interrupt mask

< edma stream1 interrupt mask

< edma stream2 interrupt mask

< edma stream6 interrupt mask

< edma stream1 interrupt mask

< edma stream3 interrupt mask

< edma stream7 interrupt mask

< edma stream1 interrupt mask

< edma stream4 interrupt mask

< edma stream8 interrupt mask

Definition at line 58 of file at32f435_437_edma.c.

Referenced by dvp_dma_init(), and edma_config().

◆ edma_stream_enable()

void edma_stream_enable | ( | edma_stream_type * | edma_streamx,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the edma streamx.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
new_state (TRUE or FALSE).
Return values
none.

Definition at line 198 of file at32f435_437_edma.c.

Referenced by dvp_start(), dvp_stop(), edma_config(), EDMA_Stream1_IRQHandler(), i2s_config(), and main().

◆ edma_stream_status_get()

flag_status edma_stream_status_get ( edma_stream_type * edma_streamx )

get the enable status of edma streamx.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
Return values
current state of the edma streamx (SET or RESET).

Definition at line 461 of file at32f435_437_edma.c.

◆ edmamux_enable()

void edmamux_enable ( confirm_state new_state )

enable or disable the edma edmamux.

Parameters
new_state (TRUE or FALSE).
Return values
none.

Definition at line 673 of file at32f435_437_edma.c.

Referenced by dvp_dma_init(), edma_config(), i2s_config(), and main().

◆ edmamux_generator_config()

void edmamux_generator_config | ( | edmamux_generator_type * | edmamux_gen_x,
 |  | edmamux_gen_init_type * | edmamux_gen_init_struct
 | ) |  |

edmamux request generator init.

Parameters
edmamux_gen_init_struct pointer to a edmamux_gen_init_type structure which will be initialized.
Return values
none.

Definition at line 779 of file at32f435_437_edma.c.

Referenced by main().

◆ edmamux_generator_default_para_init()

void edmamux_generator_default_para_init ( edmamux_gen_init_type * edmamux_gen_init_struct )

edmamux request generator init struct config with its default value.

Parameters
edmamux_gen_init_struct pointer to a edmamux_gen_init_type structure which will be initialized.
Return values
none.

Definition at line 766 of file at32f435_437_edma.c.

Referenced by main().

◆ edmamux_generator_flag_clear()

void edmamux_generator_flag_clear ( uint32_t flag )

edmamux request generator flag clear.

Parameters
flag this parameter can be any combination of the following values:
  • EDMAMUX_GEN_TRIG_OV1_FLAG
  • EDMAMUX_GEN_TRIG_OV2_FLAG
  • EDMAMUX_GEN_TRIG_OV3_FLAG
  • EDMAMUX_GEN_TRIG_OV4_FLAG
Return values
none.

Definition at line 914 of file at32f435_437_edma.c.

◆ edmamux_generator_flag_get()

flag_status edmamux_generator_flag_get ( uint32_t flag )

edmamux request generator flag get.

Parameters
flag this parameter can be any combination of the following values:
  • EDMAMUX_GEN_TRIG_OV1_FLAG
  • EDMAMUX_GEN_TRIG_OV2_FLAG
  • EDMAMUX_GEN_TRIG_OV3_FLAG
  • EDMAMUX_GEN_TRIG_OV4_FLAG
Return values
state of edmamux sync flag.

Definition at line 892 of file at32f435_437_edma.c.

◆ edmamux_generator_interrupt_enable()

void edmamux_generator_interrupt_enable | ( | edmamux_generator_type * | edmamux_gen_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the edmamux request generator interrupts.

Parameters
edmamux_gen_x pointer to a edmamux_generator_type structure. this parameter can be one of the following values:
  • EDMAMUX_GENERATOR1
  • EDMAMUX_GENERATOR2
  • EDMAMUX_GENERATOR3
  • EDMAMUX_GENERATOR4
new_state (TRUE or FALSE).
Return values
none.

Definition at line 825 of file at32f435_437_edma.c.

◆ edmamux_init()

void edmamux_init | ( | edmamux_channel_type * | edmamux_channelx,
 |  | edmamux_requst_id_sel_type | edmamux_req_id
 | ) |  |

edmamux init.

Parameters
edmamux_channelx this parameter can be one of the following values:
  • EDMAMUX_CHANNEL1
  • EDMAMUX_CHANNEL2
  • EDMAMUX_CHANNEL3
  • EDMAMUX_CHANNEL4
  • EDMAMUX_CHANNEL5
  • EDMAMUX_CHANNEL6
  • EDMAMUX_CHANNEL7
  • EDMAMUX_CHANNEL8
edmamux_req_id this parameter can be one of the following values:
  • EDMAMUX_DMAREQ_ID_REQ_G1 - EDMAMUX_DMAREQ_ID_REQ_G2 - EDMAMUX_DMAREQ_ID_REQ_G3 - EDMAMUX_DMAREQ_ID_REQ_G4
  • EDMAMUX_DMAREQ_ID_ADC1 - EDMAMUX_DMAREQ_ID_ADC2 - EDMAMUX_DMAREQ_ID_ADC3 - EDMAMUX_DMAREQ_ID_DAC1
  • EDMAMUX_DMAREQ_ID_DAC2 - EDMAMUX_DMAREQ_ID_TMR6_OVERFLOW- EDMAMUX_DMAREQ_ID_TMR7_OVERFLOW- EDMAMUX_DMAREQ_ID_SPI1_RX
  • EDMAMUX_DMAREQ_ID_SPI1_TX - EDMAMUX_DMAREQ_ID_SPI2_RX - EDMAMUX_DMAREQ_ID_SPI2_TX - EDMAMUX_DMAREQ_ID_SPI3_RX
  • EDMAMUX_DMAREQ_ID_SPI3_TX - EDMAMUX_DMAREQ_ID_SPI4_RX - EDMAMUX_DMAREQ_ID_SPI4_TX - EDMAMUX_DMAREQ_ID_I2S2_EXT_RX
  • EDMAMUX_DMAREQ_ID_I2S2_EXT_TX - EDMAMUX_DMAREQ_ID_I2S3_EXT_RX - EDMAMUX_DMAREQ_ID_I2S3_EXT_TX - EDMAMUX_DMAREQ_ID_I2C1_RX
  • EDMAMUX_DMAREQ_ID_I2C1_TX - EDMAMUX_DMAREQ_ID_I2C2_RX - EDMAMUX_DMAREQ_ID_I2C2_TX - EDMAMUX_DMAREQ_ID_I2C3_RX
  • EDMAMUX_DMAREQ_ID_I2C3_TX - EDMAMUX_DMAREQ_ID_USART1_RX - EDMAMUX_DMAREQ_ID_USART1_TX - EDMAMUX_DMAREQ_ID_USART2_RX
  • EDMAMUX_DMAREQ_ID_USART2_TX - EDMAMUX_DMAREQ_ID_USART3_RX - EDMAMUX_DMAREQ_ID_USART3_TX - EDMAMUX_DMAREQ_ID_UART4_RX
  • EDMAMUX_DMAREQ_ID_UART4_TX - EDMAMUX_DMAREQ_ID_UART5_RX - EDMAMUX_DMAREQ_ID_UART5_TX - EDMAMUX_DMAREQ_ID_USART6_RX
  • EDMAMUX_DMAREQ_ID_USART6_TX - EDMAMUX_DMAREQ_ID_UART7_RX - EDMAMUX_DMAREQ_ID_UART7_TX - EDMAMUX_DMAREQ_ID_UART8_RX
  • EDMAMUX_DMAREQ_ID_UART8_TX - EDMAMUX_DMAREQ_ID_SDIO1 - EDMAMUX_DMAREQ_ID_SDIO2 - EDMAMUX_DMAREQ_ID_QSPI1
  • EDMAMUX_DMAREQ_ID_QSPI2 - EDMAMUX_DMAREQ_ID_TMR1_CH1 - EDMAMUX_DMAREQ_ID_TMR1_CH2 - EDMAMUX_DMAREQ_ID_TMR1_CH3
  • EDMAMUX_DMAREQ_ID_TMR1_CH4 - EDMAMUX_DMAREQ_ID_TMR1_OVERFLOW- EDMAMUX_DMAREQ_ID_TMR1_TRIG - EDMAMUX_DMAREQ_ID_TMR1_COM
  • EDMAMUX_DMAREQ_ID_TMR8_CH1 - EDMAMUX_DMAREQ_ID_TMR8_CH2 - EDMAMUX_DMAREQ_ID_TMR8_CH3 - EDMAMUX_DMAREQ_ID_TMR8_CH4
  • EDMAMUX_DMAREQ_ID_TMR8_UP - EDMAMUX_DMAREQ_ID_TMR8_TRIG - EDMAMUX_DMAREQ_ID_TMR8_COM - EDMAMUX_DMAREQ_ID_TMR2_CH1
  • EDMAMUX_DMAREQ_ID_TMR2_CH2 - EDMAMUX_DMAREQ_ID_TMR2_CH3 - EDMAMUX_DMAREQ_ID_TMR2_CH4 - EDMAMUX_DMAREQ_ID_TMR2_OVERFLOW
  • EDMAMUX_DMAREQ_ID_TMR2_TRIG - EDMAMUX_DMAREQ_ID_TMR3_CH1 - EDMAMUX_DMAREQ_ID_TMR3_CH2 - EDMAMUX_DMAREQ_ID_TMR3_CH3
  • EDMAMUX_DMAREQ_ID_TMR3_CH4 - EDMAMUX_DMAREQ_ID_TMR3_OVERFLOW- EDMAMUX_DMAREQ_ID_TMR3_TRIG - EDMAMUX_DMAREQ_ID_TMR4_CH1
  • EDMAMUX_DMAREQ_ID_TMR4_CH2 - EDMAMUX_DMAREQ_ID_TMR4_CH3 - EDMAMUX_DMAREQ_ID_TMR4_CH4 - EDMAMUX_DMAREQ_ID_TMR4_OVERFLOW
  • EDMAMUX_DMAREQ_ID_TMR4_TRIG - EDMAMUX_DMAREQ_ID_TMR5_CH1 - EDMAMUX_DMAREQ_ID_TMR5_CH2 - EDMAMUX_DMAREQ_ID_TMR5_CH3
  • EDMAMUX_DMAREQ_ID_TMR5_CH4 - EDMAMUX_DMAREQ_ID_TMR5_OVERFLOW- EDMAMUX_DMAREQ_ID_TMR5_TRIG - EDMAMUX_DMAREQ_ID_TMR20_CH1
  • EDMAMUX_DMAREQ_ID_TMR20_CH2 - EDMAMUX_DMAREQ_ID_TMR20_CH3 - EDMAMUX_DMAREQ_ID_TMR20_CH4 - EDMAMUX_DMAREQ_ID_TMR20_OVERFLOW
  • EDMAMUX_DMAREQ_ID_TMR20_TRIG - EDMAMUX_DMAREQ_ID_TMR20_HALL - EDMAMUX_DMAREQ_ID_DVP
Return values
none.

Definition at line 718 of file at32f435_437_edma.c.

Referenced by dvp_dma_init(), edma_config(), i2s_config(), and main().

◆ edmamux_sync_config()

void edmamux_sync_config | ( | edmamux_channel_type * | edmamux_channelx,
 |  | edmamux_sync_init_type * | edmamux_sync_init_struct
 | ) |  |

edmamux synchronization config.

Parameters
edmamux_channelx this parameter can be one of the following values:
  • EDMAMUX_CHANNEL1
  • EDMAMUX_CHANNEL2
  • EDMAMUX_CHANNEL3
  • EDMAMUX_CHANNEL4
  • EDMAMUX_CHANNEL5
  • EDMAMUX_CHANNEL6
  • EDMAMUX_CHANNEL7
  • EDMAMUX_CHANNEL8
edmamux_sync_init_struct ointer to a edmamux_sync_init_type structure.
Return values
none.

Definition at line 752 of file at32f435_437_edma.c.

Referenced by main().

◆ edmamux_sync_default_para_init()

void edmamux_sync_default_para_init ( edmamux_sync_init_type * edmamux_sync_init_struct )

edmamux sync init struct config with its default value.

Parameters
edmamux_sync_init_struct pointer to a edmamux_sync_init_type structure which will be initialized.
Return values
none.

Definition at line 728 of file at32f435_437_edma.c.

Referenced by main().

◆ edmamux_sync_flag_clear()

void edmamux_sync_flag_clear ( uint32_t flag )

edmamux sync flag clear.

Parameters
flag this parameter can be any combination of the following values:
  • EDMAMUX_SYNC_OV1_FLAG
  • EDMAMUX_SYNC_OV2_FLAG
  • EDMAMUX_SYNC_OV3_FLAG
  • EDMAMUX_SYNC_OV4_FLAG
  • EDMAMUX_SYNC_OV5_FLAG
  • EDMAMUX_SYNC_OV6_FLAG
  • EDMAMUX_SYNC_OV7_FLAG
  • EDMAMUX_SYNC_OV8_FLAG
Return values
none.

Definition at line 877 of file at32f435_437_edma.c.

◆ edmamux_sync_flag_get()

flag_status edmamux_sync_flag_get ( uint32_t flag )

edmamux sync flag get.

Parameters
flag this parameter can be any combination of the following values:
  • EDMAMUX_SYNC_OV1_FLAG
  • EDMAMUX_SYNC_OV2_FLAG
  • EDMAMUX_SYNC_OV3_FLAG
  • EDMAMUX_SYNC_OV4_FLAG
  • EDMAMUX_SYNC_OV5_FLAG
  • EDMAMUX_SYNC_OV6_FLAG
  • EDMAMUX_SYNC_OV7_FLAG
  • EDMAMUX_SYNC_OV8_FLAG
Return values
state of edmamux sync flag.

Definition at line 851 of file at32f435_437_edma.c.

◆ edmamux_sync_interrupt_enable()

void edmamux_sync_interrupt_enable | ( | edmamux_channel_type * | edmamux_channelx,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the edmamux sync interrupts.

Parameters
edmamux_channelx this parameter can be one of the following values:
  • EDMAMUX_CHANNEL1
  • EDMAMUX_CHANNEL2
  • EDMAMUX_CHANNEL3
  • EDMAMUX_CHANNEL4
  • EDMAMUX_CHANNEL5
  • EDMAMUX_CHANNEL6
  • EDMAMUX_CHANNEL7
  • EDMAMUX_CHANNEL8
new_state (TRUE or FALSE).
Return values
none.

Definition at line 802 of file at32f435_437_edma.c.


AT32F435/437 Firmwary Library: EDMA_private_functions

Functions
EDMA_private_functions
AT32F435_437_periph_driver » EDMA

Functions

void | edma_reset (edma_stream_type *edma_streamx)
reset edma_streamx channely register. More...
void | edma_init (edma_stream_type *edma_streamx, edma_init_type *edma_init_struct)
edma init. More...
void | edma_default_para_init (edma_init_type *edma_init_struct)
edma init struct config with its default value. More...
void | edma_stream_enable (edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx. More...
void | edma_interrupt_enable (edma_stream_type *edma_streamx, uint32_t edma_int, confirm_state new_state)
enable or disable the edma streamx interrupts. More...
void | edma_peripheral_inc_offset_set (edma_stream_type *edma_streamx, edma_peripheral_inc_offset_type offset)
config the edma peripheral increment offset size mode. More...
void | edma_flow_controller_enable (edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx flow controller. More...
void | edma_data_number_set (edma_stream_type *edma_streamx, uint16_t data_number)
set the number of data to be transferred. More...
uint16_t | edma_data_number_get (edma_stream_type *edma_streamx)
get the number of data to be transferred. More...
void | edma_double_buffer_mode_init (edma_stream_type *edma_streamx, uint32_t memory1_addr, edma_memory_type current_memory)
config the the double buffer mode. More...
void | edma_double_buffer_mode_enable (edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the double memory mode. More...
void | edma_memory_addr_set (edma_stream_type *edma_streamx, uint32_t memory_addr, uint32_t memory_target)
config the memory address in double buffer mode. More...
edma_memory_type | edma_memory_target_get (edma_stream_type *edma_streamx)
get the current memory target. More...
flag_status | edma_stream_status_get (edma_stream_type *edma_streamx)
get the enable status of edma streamx. More...
uint8_t | edma_fifo_status_get (edma_stream_type *edma_streamx)
get the fifo level status. More...
flag_status | edma_flag_get (uint32_t edma_flag)
get the edma flag. More...
void | edma_flag_clear (uint32_t edma_flag)
clear the edma flag. More...
void | edma_2d_init (edma_stream_2d_type *edma_streamx_2d, int16_t src_stride, int16_t dst_stride, uint16_t xcnt, uint16_t ycnt)
initialize the edma 2d mode. More...
void | edma_2d_enable (edma_stream_2d_type *edma_streamx_2d, confirm_state new_state)
enable or disable the edma 2d mode. More...
void | edma_link_list_init (edma_stream_link_list_type *edma_streamx_ll, uint32_t pointer)
initialize the edma link list. More...
void | edma_link_list_enable (edma_stream_link_list_type *edma_streamx_ll, confirm_state new_state)
enable or disable the edma stream link list mode. More...
void | edmamux_enable (confirm_state new_state)
enable or disable the edma edmamux. More...
void | edmamux_init (edmamux_channel_type *edmamux_channelx, edmamux_requst_id_sel_type edmamux_req_id)
edmamux init. More...
void | edmamux_sync_default_para_init (edmamux_sync_init_type *edmamux_sync_init_struct)
edmamux sync init struct config with its default value. More...
void | edmamux_sync_config (edmamux_channel_type *edmamux_channelx, edmamux_sync_init_type *edmamux_sync_init_struct)
edmamux synchronization config. More...
void | edmamux_generator_default_para_init (edmamux_gen_init_type *edmamux_gen_init_struct)
edmamux request generator init struct config with its default value. More...
void | edmamux_generator_config (edmamux_generator_type *edmamux_gen_x, edmamux_gen_init_type *edmamux_gen_init_struct)
edmamux request generator init. More...
void | edmamux_sync_interrupt_enable (edmamux_channel_type *edmamux_channelx, confirm_state new_state)
enable or disable the edmamux sync interrupts. More...
void | edmamux_generator_interrupt_enable (edmamux_generator_type *edmamux_gen_x, confirm_state new_state)
enable or disable the edmamux request generator interrupts. More...
flag_status | edmamux_sync_flag_get (uint32_t flag)
edmamux sync flag get. More...
void | edmamux_sync_flag_clear (uint32_t flag)
edmamux sync flag clear. More...
flag_status | edmamux_generator_flag_get (uint32_t flag)
edmamux request generator flag get. More...
void | edmamux_generator_flag_clear (uint32_t flag)
edmamux request generator flag clear. More...

Detailed Description

Function Documentation

◆ edma_2d_enable()

void edma_2d_enable | ( | edma_stream_2d_type * | edma_streamx_2d,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the edma 2d mode.

Parameters
edma_streamx_2d this parameter can be one of the following values:
  • EDMA_STREAM1_2D
  • EDMA_STREAM2_2D
  • EDMA_STREAM3_2D
  • EDMA_STREAM4_2D
  • EDMA_STREAM5_2D
  • EDMA_STREAM6_2D
  • EDMA_STREAM7_2D
  • EDMA_STREAM8_2D
new_state (TRUE or FALSE).
Return values
none.

Definition at line 601 of file at32f435_437_edma.c.

Referenced by main().

◆ edma_2d_init()

void edma_2d_init | ( | edma_stream_2d_type * | edma_streamx_2d,
 |  | int16_t | src_stride,
 |  | int16_t | dst_stride,
 |  | uint16_t | xcnt,
 |  | uint16_t | ycnt
 | ) |  |

initialize the edma 2d mode.

Parameters
edma_streamx_2d this parameter can be one of the following values:
  • EDMA_STREAM1_2D
  • EDMA_STREAM2_2D
  • EDMA_STREAM3_2D
  • EDMA_STREAM4_2D
  • EDMA_STREAM5_2D
  • EDMA_STREAM6_2D
  • EDMA_STREAM7_2D
  • EDMA_STREAM8_2D
src_stride | source stride(-32768 ~ 32767).
dst_stride | destination stride(-32768 ~ 32767).
xcnt | x dimension transfer count(0x0000~ 0xFFFF).
ycnt | y dimension transfer count(0x0000~ 0xFFFF).
Return values
none.

Definition at line 579 of file at32f435_437_edma.c.

Referenced by main().

◆ edma_data_number_get()

uint16_t edma_data_number_get ( edma_stream_type * edma_streamx )

get the number of data to be transferred.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
Return values
the number value.

Definition at line 330 of file at32f435_437_edma.c.

◆ edma_data_number_set()

void edma_data_number_set | ( | edma_stream_type * | edma_streamx,
 |  | uint16_t | data_number
 | ) |  |

set the number of data to be transferred.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
data_number the number of data to be transferred (0x0000~0xFFFF).
Return values
none.

Definition at line 310 of file at32f435_437_edma.c.

◆ edma_default_para_init()

void edma_default_para_init ( edma_init_type * edma_init_struct )

edma init struct config with its default value.

Parameters
edma_init_struct pointer to a edma_init_type structure which will be initialized.
Return values
none.

Definition at line 165 of file at32f435_437_edma.c.

Referenced by edma_config(), i2s_config(), and main().

◆ edma_double_buffer_mode_enable()

void edma_double_buffer_mode_enable | ( | edma_stream_type * | edma_streamx,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the double memory mode.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
new_state (TRUE or FALSE).
Return values
none.

Definition at line 383 of file at32f435_437_edma.c.

Referenced by dvp_dma_init(), edma_config(), and i2s_config().

◆ edma_double_buffer_mode_init()

void edma_double_buffer_mode_init | ( | edma_stream_type * | edma_streamx,
 |  | uint32_t | memory1_addr,
 |  | edma_memory_type | current_memory
 | ) |  |

config the the double buffer mode.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
memory1_addr the address of the second buffer.
current_memory specifies the target area of the first transfer. this parameter can be one of the following values:
  • EDMA_MEMORY_0
  • EDMA_MEMORY_1
Return values
none.

Definition at line 354 of file at32f435_437_edma.c.

Referenced by dvp_dma_init(), edma_config(), and i2s_config().

◆ edma_fifo_status_get()

uint8_t edma_fifo_status_get ( edma_stream_type * edma_streamx )

get the fifo level status.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
Return values
the fifo filling state.
  • EDMA_FIFO_STATUS_LESS_1QUARTER: (0) < fifo level < (1/4).
  • EDMA_FIFO_STATUS_1QUARTER: (1/4) <= fifo level < (1/2) .
  • EDMA_FIFO_STATUS_HALF: (1/2) <= fifo level < (3/4).
  • EDMA_FIFO_STATUS_3QUARTER: (3/4) <= fifo level < (1).
  • EDMA_FIFO_STATUS_EMPTY: fifo is empty.
  • EDMA_FIFO_STATUS_FULL: fifo is full.

Definition at line 493 of file at32f435_437_edma.c.

◆ edma_flag_clear()

void edma_flag_clear ( uint32_t edma_flag )

clear the edma flag.

Parameters
edma_flag this parameter can be one of the following values:
  • EDMA_FERR1_FLAG - EDMA_DMERR1_FLAG - EDMA_DTERR1_FLAG - EDMA_HDT1_FLAG - EDMA_FDT1_FLAG
  • EDMA_FERR2_FLAG - EDMA_DMERR2_FLAG - EDMA_DTERR2_FLAG - EDMA_HDT2_FLAG - EDMA_FDT2_FLAG
  • EDMA_FERR3_FLAG - EDMA_DMERR3_FLAG - EDMA_DTERR3_FLAG - EDMA_HDT3_FLAG - EDMA_FDT3_FLAG
  • EDMA_FERR4_FLAG - EDMA_DMERR4_FLAG - EDMA_DTERR4_FLAG - EDMA_HDT4_FLAG - EDMA_FDT4_FLAG
  • EDMA_FERR5_FLAG - EDMA_DMERR5_FLAG - EDMA_DTERR5_FLAG - EDMA_HDT5_FLAG - EDMA_FDT5_FLAG
  • EDMA_FERR6_FLAG - EDMA_DMERR6_FLAG - EDMA_DTERR6_FLAG - EDMA_HDT6_FLAG - EDMA_FDT6_FLAG
  • EDMA_FERR7_FLAG - EDMA_DMERR7_FLAG - EDMA_DTERR7_FLAG - EDMA_HDT7_FLAG - EDMA_FDT7_FLAG
  • EDMA_FERR8_FLAG - EDMA_DMERR8_FLAG - EDMA_DTERR8_FLAG - EDMA_HDT8_FLAG - EDMA_FDT8_FLAG
Return values
none.

Definition at line 549 of file at32f435_437_edma.c.

Referenced by EDMA_Stream1_IRQHandler(), and EDMA_Stream4_IRQHandler().

◆ edma_flag_get()

flag_status edma_flag_get ( uint32_t edma_flag )

get the edma flag.

Parameters
edma_flag this parameter can be one of the following values:
  • EDMA_FERR1_FLAG - EDMA_DMERR1_FLAG - EDMA_DTERR1_FLAG - EDMA_HDT1_FLAG - EDMA_FDT1_FLAG
  • EDMA_FERR2_FLAG - EDMA_DMERR2_FLAG - EDMA_DTERR2_FLAG - EDMA_HDT2_FLAG - EDMA_FDT2_FLAG
  • EDMA_FERR3_FLAG - EDMA_DMERR3_FLAG - EDMA_DTERR3_FLAG - EDMA_HDT3_FLAG - EDMA_FDT3_FLAG
  • EDMA_FERR4_FLAG - EDMA_DMERR4_FLAG - EDMA_DTERR4_FLAG - EDMA_HDT4_FLAG - EDMA_FDT4_FLAG
  • EDMA_FERR5_FLAG - EDMA_DMERR5_FLAG - EDMA_DTERR5_FLAG - EDMA_HDT5_FLAG - EDMA_FDT5_FLAG
  • EDMA_FERR6_FLAG - EDMA_DMERR6_FLAG - EDMA_DTERR6_FLAG - EDMA_HDT6_FLAG - EDMA_FDT6_FLAG
  • EDMA_FERR7_FLAG - EDMA_DMERR7_FLAG - EDMA_DTERR7_FLAG - EDMA_HDT7_FLAG - EDMA_FDT7_FLAG
  • EDMA_FERR8_FLAG - EDMA_DMERR8_FLAG - EDMA_DTERR8_FLAG - EDMA_HDT8_FLAG - EDMA_FDT8_FLAG
Return values
the new state of edma flag (SET or RESET).

Definition at line 512 of file at32f435_437_edma.c.

Referenced by EDMA_Stream1_IRQHandler(), and EDMA_Stream4_IRQHandler().

◆ edma_flow_controller_enable()

void edma_flow_controller_enable | ( | edma_stream_type * | edma_streamx,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the edma streamx flow controller.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
new_state (TRUE or FALSE).
Return values
none.

Definition at line 290 of file at32f435_437_edma.c.

◆ edma_init()

void edma_init | ( | edma_stream_type * | edma_streamx,
 |  | edma_init_type * | edma_init_struct
 | ) |  |

edma init.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
edma_init_struct pointer to a edma_init_type structure.
Return values
none.

Definition at line 115 of file at32f435_437_edma.c.

Referenced by dvp_dma_init(), edma_config(), i2s_config(), and main().

◆ edma_interrupt_enable()

void edma_interrupt_enable | ( | edma_stream_type * | edma_streamx,
 |  | uint32_t | edma_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the edma streamx interrupts.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
edma_int this parameter can be one of the following values:
  • EDMA_FDT_INT
  • EDMA_HDT_INT
  • EDMA_DTERR_INT
  • EDMA_DMERR_INT
  • EDMA_FERR_INT
new_state (TRUE or FALSE).
Return values
none.

Definition at line 225 of file at32f435_437_edma.c.

Referenced by dvp_dma_init(), edma_config(), i2s_config(), and main().

◆ edma_link_list_enable()

void edma_link_list_enable | ( | edma_stream_link_list_type * | edma_streamx_ll,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the edma stream link list mode.

Parameters
edma_streamx_ll this parameter can be any combination of the following values:
  • EDMA_STREAM1_LL
  • EDMA_STREAM2_LL
  • EDMA_STREAM3_LL
  • EDMA_STREAM4_LL
  • EDMA_STREAM5_LL
  • EDMA_STREAM6_LL
  • EDMA_STREAM7_LL
  • EDMA_STREAM8_LL
new_state (TRUE or FALSE).
Return values
none.

Definition at line 652 of file at32f435_437_edma.c.

Referenced by main().

◆ edma_link_list_init()

void edma_link_list_init | ( | edma_stream_link_list_type * | edma_streamx_ll,
 |  | uint32_t | pointer
 | ) |  |

initialize the edma link list.

Parameters
edma_streamx_ll this parameter can be one of the following values:
  • EDMA_STREAM1_LL
  • EDMA_STREAM2_LL
  • EDMA_STREAM3_LL
  • EDMA_STREAM4_LL
  • EDMA_STREAM5_LL
  • EDMA_STREAM6_LL
  • EDMA_STREAM7_LL
  • EDMA_STREAM8_LL
pointer link list pointer.
Return values
none.

Definition at line 632 of file at32f435_437_edma.c.

Referenced by main().

◆ edma_memory_addr_set()

void edma_memory_addr_set | ( | edma_stream_type * | edma_streamx,
 |  | uint32_t | memory_addr,
 |  | uint32_t | memory_target
 | ) |  |

config the memory address in double buffer mode.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
memory_addr the address of the buffer.
memory_target indicates the which memory addr register will be config. this parameter can be one of the following values:
  • EDMA_MEMORY_0
  • EDMA_MEMORY_1
Return values
none.

Definition at line 414 of file at32f435_437_edma.c.

◆ edma_memory_target_get()

edma_memory_type edma_memory_target_get ( edma_stream_type * edma_streamx )

get the current memory target.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
Return values
the memory target
  • EDMA_MEMORY_0
  • EDMA_MEMORY_1

Definition at line 442 of file at32f435_437_edma.c.

Referenced by EDMA_Stream1_IRQHandler().

◆ edma_peripheral_inc_offset_set()

void edma_peripheral_inc_offset_set | ( | edma_stream_type * | edma_streamx,
 |  | edma_peripheral_inc_offset_type | offset
 | ) |  |

config the edma peripheral increment offset size mode.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
offset peripheral increment offset size. this parameter can be one of the following values:
  • EDMA_PERIPHERAL_INC_PSIZE
  • EDMA_PERIPHERAL_INC_4_BYTE
Return values
none.

Definition at line 270 of file at32f435_437_edma.c.

◆ edma_reset()

void edma_reset ( edma_stream_type * edma_streamx )

reset edma_streamx channely register.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
Return values
none.

< edma stream1 interrupt mask

< edma stream1 interrupt mask

< edma stream2 interrupt mask

< edma stream1 interrupt mask

< edma stream3 interrupt mask

< edma stream1 interrupt mask

< edma stream4 interrupt mask

< edma stream1 interrupt mask

< edma stream5 interrupt mask

< edma stream1 interrupt mask

< edma stream2 interrupt mask

< edma stream6 interrupt mask

< edma stream1 interrupt mask

< edma stream3 interrupt mask

< edma stream7 interrupt mask

< edma stream1 interrupt mask

< edma stream4 interrupt mask

< edma stream8 interrupt mask

Definition at line 58 of file at32f435_437_edma.c.

Referenced by dvp_dma_init(), and edma_config().

◆ edma_stream_enable()

void edma_stream_enable | ( | edma_stream_type * | edma_streamx,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the edma streamx.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
new_state (TRUE or FALSE).
Return values
none.

Definition at line 198 of file at32f435_437_edma.c.

Referenced by dvp_start(), dvp_stop(), edma_config(), EDMA_Stream1_IRQHandler(), i2s_config(), and main().

◆ edma_stream_status_get()

flag_status edma_stream_status_get ( edma_stream_type * edma_streamx )

get the enable status of edma streamx.

Parameters
edma_streamx this parameter can be one of the following values:
  • EDMA_STREAM1
  • EDMA_STREAM2
  • EDMA_STREAM3
  • EDMA_STREAM4
  • EDMA_STREAM5
  • EDMA_STREAM6
  • EDMA_STREAM7
  • EDMA_STREAM8
Return values
current state of the edma streamx (SET or RESET).

Definition at line 461 of file at32f435_437_edma.c.

◆ edmamux_enable()

void edmamux_enable ( confirm_state new_state )

enable or disable the edma edmamux.

Parameters
new_state (TRUE or FALSE).
Return values
none.

Definition at line 673 of file at32f435_437_edma.c.

Referenced by dvp_dma_init(), edma_config(), i2s_config(), and main().

◆ edmamux_generator_config()

void edmamux_generator_config | ( | edmamux_generator_type * | edmamux_gen_x,
 |  | edmamux_gen_init_type * | edmamux_gen_init_struct
 | ) |  |

edmamux request generator init.

Parameters
edmamux_gen_init_struct pointer to a edmamux_gen_init_type structure which will be initialized.
Return values
none.

Definition at line 779 of file at32f435_437_edma.c.

Referenced by main().

◆ edmamux_generator_default_para_init()

void edmamux_generator_default_para_init ( edmamux_gen_init_type * edmamux_gen_init_struct )

edmamux request generator init struct config with its default value.

Parameters
edmamux_gen_init_struct pointer to a edmamux_gen_init_type structure which will be initialized.
Return values
none.

Definition at line 766 of file at32f435_437_edma.c.

Referenced by main().

◆ edmamux_generator_flag_clear()

void edmamux_generator_flag_clear ( uint32_t flag )

edmamux request generator flag clear.

Parameters
flag this parameter can be any combination of the following values:
  • EDMAMUX_GEN_TRIG_OV1_FLAG
  • EDMAMUX_GEN_TRIG_OV2_FLAG
  • EDMAMUX_GEN_TRIG_OV3_FLAG
  • EDMAMUX_GEN_TRIG_OV4_FLAG
Return values
none.

Definition at line 914 of file at32f435_437_edma.c.

◆ edmamux_generator_flag_get()

flag_status edmamux_generator_flag_get ( uint32_t flag )

edmamux request generator flag get.

Parameters
flag this parameter can be any combination of the following values:
  • EDMAMUX_GEN_TRIG_OV1_FLAG
  • EDMAMUX_GEN_TRIG_OV2_FLAG
  • EDMAMUX_GEN_TRIG_OV3_FLAG
  • EDMAMUX_GEN_TRIG_OV4_FLAG
Return values
state of edmamux sync flag.

Definition at line 892 of file at32f435_437_edma.c.

◆ edmamux_generator_interrupt_enable()

void edmamux_generator_interrupt_enable | ( | edmamux_generator_type * | edmamux_gen_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the edmamux request generator interrupts.

Parameters
edmamux_gen_x pointer to a edmamux_generator_type structure. this parameter can be one of the following values:
  • EDMAMUX_GENERATOR1
  • EDMAMUX_GENERATOR2
  • EDMAMUX_GENERATOR3
  • EDMAMUX_GENERATOR4
new_state (TRUE or FALSE).
Return values
none.

Definition at line 825 of file at32f435_437_edma.c.

◆ edmamux_init()

void edmamux_init | ( | edmamux_channel_type * | edmamux_channelx,
 |  | edmamux_requst_id_sel_type | edmamux_req_id
 | ) |  |

edmamux init.

Parameters
edmamux_channelx this parameter can be one of the following values:
  • EDMAMUX_CHANNEL1
  • EDMAMUX_CHANNEL2
  • EDMAMUX_CHANNEL3
  • EDMAMUX_CHANNEL4
  • EDMAMUX_CHANNEL5
  • EDMAMUX_CHANNEL6
  • EDMAMUX_CHANNEL7
  • EDMAMUX_CHANNEL8
edmamux_req_id this parameter can be one of the following values:
  • EDMAMUX_DMAREQ_ID_REQ_G1 - EDMAMUX_DMAREQ_ID_REQ_G2 - EDMAMUX_DMAREQ_ID_REQ_G3 - EDMAMUX_DMAREQ_ID_REQ_G4
  • EDMAMUX_DMAREQ_ID_ADC1 - EDMAMUX_DMAREQ_ID_ADC2 - EDMAMUX_DMAREQ_ID_ADC3 - EDMAMUX_DMAREQ_ID_DAC1
  • EDMAMUX_DMAREQ_ID_DAC2 - EDMAMUX_DMAREQ_ID_TMR6_OVERFLOW- EDMAMUX_DMAREQ_ID_TMR7_OVERFLOW- EDMAMUX_DMAREQ_ID_SPI1_RX
  • EDMAMUX_DMAREQ_ID_SPI1_TX - EDMAMUX_DMAREQ_ID_SPI2_RX - EDMAMUX_DMAREQ_ID_SPI2_TX - EDMAMUX_DMAREQ_ID_SPI3_RX
  • EDMAMUX_DMAREQ_ID_SPI3_TX - EDMAMUX_DMAREQ_ID_SPI4_RX - EDMAMUX_DMAREQ_ID_SPI4_TX - EDMAMUX_DMAREQ_ID_I2S2_EXT_RX
  • EDMAMUX_DMAREQ_ID_I2S2_EXT_TX - EDMAMUX_DMAREQ_ID_I2S3_EXT_RX - EDMAMUX_DMAREQ_ID_I2S3_EXT_TX - EDMAMUX_DMAREQ_ID_I2C1_RX
  • EDMAMUX_DMAREQ_ID_I2C1_TX - EDMAMUX_DMAREQ_ID_I2C2_RX - EDMAMUX_DMAREQ_ID_I2C2_TX - EDMAMUX_DMAREQ_ID_I2C3_RX
  • EDMAMUX_DMAREQ_ID_I2C3_TX - EDMAMUX_DMAREQ_ID_USART1_RX - EDMAMUX_DMAREQ_ID_USART1_TX - EDMAMUX_DMAREQ_ID_USART2_RX
  • EDMAMUX_DMAREQ_ID_USART2_TX - EDMAMUX_DMAREQ_ID_USART3_RX - EDMAMUX_DMAREQ_ID_USART3_TX - EDMAMUX_DMAREQ_ID_UART4_RX
  • EDMAMUX_DMAREQ_ID_UART4_TX - EDMAMUX_DMAREQ_ID_UART5_RX - EDMAMUX_DMAREQ_ID_UART5_TX - EDMAMUX_DMAREQ_ID_USART6_RX
  • EDMAMUX_DMAREQ_ID_USART6_TX - EDMAMUX_DMAREQ_ID_UART7_RX - EDMAMUX_DMAREQ_ID_UART7_TX - EDMAMUX_DMAREQ_ID_UART8_RX
  • EDMAMUX_DMAREQ_ID_UART8_TX - EDMAMUX_DMAREQ_ID_SDIO1 - EDMAMUX_DMAREQ_ID_SDIO2 - EDMAMUX_DMAREQ_ID_QSPI1
  • EDMAMUX_DMAREQ_ID_QSPI2 - EDMAMUX_DMAREQ_ID_TMR1_CH1 - EDMAMUX_DMAREQ_ID_TMR1_CH2 - EDMAMUX_DMAREQ_ID_TMR1_CH3
  • EDMAMUX_DMAREQ_ID_TMR1_CH4 - EDMAMUX_DMAREQ_ID_TMR1_OVERFLOW- EDMAMUX_DMAREQ_ID_TMR1_TRIG - EDMAMUX_DMAREQ_ID_TMR1_COM
  • EDMAMUX_DMAREQ_ID_TMR8_CH1 - EDMAMUX_DMAREQ_ID_TMR8_CH2 - EDMAMUX_DMAREQ_ID_TMR8_CH3 - EDMAMUX_DMAREQ_ID_TMR8_CH4
  • EDMAMUX_DMAREQ_ID_TMR8_UP - EDMAMUX_DMAREQ_ID_TMR8_TRIG - EDMAMUX_DMAREQ_ID_TMR8_COM - EDMAMUX_DMAREQ_ID_TMR2_CH1
  • EDMAMUX_DMAREQ_ID_TMR2_CH2 - EDMAMUX_DMAREQ_ID_TMR2_CH3 - EDMAMUX_DMAREQ_ID_TMR2_CH4 - EDMAMUX_DMAREQ_ID_TMR2_OVERFLOW
  • EDMAMUX_DMAREQ_ID_TMR2_TRIG - EDMAMUX_DMAREQ_ID_TMR3_CH1 - EDMAMUX_DMAREQ_ID_TMR3_CH2 - EDMAMUX_DMAREQ_ID_TMR3_CH3
  • EDMAMUX_DMAREQ_ID_TMR3_CH4 - EDMAMUX_DMAREQ_ID_TMR3_OVERFLOW- EDMAMUX_DMAREQ_ID_TMR3_TRIG - EDMAMUX_DMAREQ_ID_TMR4_CH1
  • EDMAMUX_DMAREQ_ID_TMR4_CH2 - EDMAMUX_DMAREQ_ID_TMR4_CH3 - EDMAMUX_DMAREQ_ID_TMR4_CH4 - EDMAMUX_DMAREQ_ID_TMR4_OVERFLOW
  • EDMAMUX_DMAREQ_ID_TMR4_TRIG - EDMAMUX_DMAREQ_ID_TMR5_CH1 - EDMAMUX_DMAREQ_ID_TMR5_CH2 - EDMAMUX_DMAREQ_ID_TMR5_CH3
  • EDMAMUX_DMAREQ_ID_TMR5_CH4 - EDMAMUX_DMAREQ_ID_TMR5_OVERFLOW- EDMAMUX_DMAREQ_ID_TMR5_TRIG - EDMAMUX_DMAREQ_ID_TMR20_CH1
  • EDMAMUX_DMAREQ_ID_TMR20_CH2 - EDMAMUX_DMAREQ_ID_TMR20_CH3 - EDMAMUX_DMAREQ_ID_TMR20_CH4 - EDMAMUX_DMAREQ_ID_TMR20_OVERFLOW
  • EDMAMUX_DMAREQ_ID_TMR20_TRIG - EDMAMUX_DMAREQ_ID_TMR20_HALL - EDMAMUX_DMAREQ_ID_DVP
Return values
none.

Definition at line 718 of file at32f435_437_edma.c.

Referenced by dvp_dma_init(), edma_config(), i2s_config(), and main().

◆ edmamux_sync_config()

void edmamux_sync_config | ( | edmamux_channel_type * | edmamux_channelx,
 |  | edmamux_sync_init_type * | edmamux_sync_init_struct
 | ) |  |

edmamux synchronization config.

Parameters
edmamux_channelx this parameter can be one of the following values:
  • EDMAMUX_CHANNEL1
  • EDMAMUX_CHANNEL2
  • EDMAMUX_CHANNEL3
  • EDMAMUX_CHANNEL4
  • EDMAMUX_CHANNEL5
  • EDMAMUX_CHANNEL6
  • EDMAMUX_CHANNEL7
  • EDMAMUX_CHANNEL8
edmamux_sync_init_struct ointer to a edmamux_sync_init_type structure.
Return values
none.

Definition at line 752 of file at32f435_437_edma.c.

Referenced by main().

◆ edmamux_sync_default_para_init()

void edmamux_sync_default_para_init ( edmamux_sync_init_type * edmamux_sync_init_struct )

edmamux sync init struct config with its default value.

Parameters
edmamux_sync_init_struct pointer to a edmamux_sync_init_type structure which will be initialized.
Return values
none.

Definition at line 728 of file at32f435_437_edma.c.

Referenced by main().

◆ edmamux_sync_flag_clear()

void edmamux_sync_flag_clear ( uint32_t flag )

edmamux sync flag clear.

Parameters
flag this parameter can be any combination of the following values:
  • EDMAMUX_SYNC_OV1_FLAG
  • EDMAMUX_SYNC_OV2_FLAG
  • EDMAMUX_SYNC_OV3_FLAG
  • EDMAMUX_SYNC_OV4_FLAG
  • EDMAMUX_SYNC_OV5_FLAG
  • EDMAMUX_SYNC_OV6_FLAG
  • EDMAMUX_SYNC_OV7_FLAG
  • EDMAMUX_SYNC_OV8_FLAG
Return values
none.

Definition at line 877 of file at32f435_437_edma.c.

◆ edmamux_sync_flag_get()

flag_status edmamux_sync_flag_get ( uint32_t flag )

edmamux sync flag get.

Parameters
flag this parameter can be any combination of the following values:
  • EDMAMUX_SYNC_OV1_FLAG
  • EDMAMUX_SYNC_OV2_FLAG
  • EDMAMUX_SYNC_OV3_FLAG
  • EDMAMUX_SYNC_OV4_FLAG
  • EDMAMUX_SYNC_OV5_FLAG
  • EDMAMUX_SYNC_OV6_FLAG
  • EDMAMUX_SYNC_OV7_FLAG
  • EDMAMUX_SYNC_OV8_FLAG
Return values
state of edmamux sync flag.

Definition at line 851 of file at32f435_437_edma.c.

◆ edmamux_sync_interrupt_enable()

void edmamux_sync_interrupt_enable | ( | edmamux_channel_type * | edmamux_channelx,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the edmamux sync interrupts.

Parameters
edmamux_channelx this parameter can be one of the following values:
  • EDMAMUX_CHANNEL1
  • EDMAMUX_CHANNEL2
  • EDMAMUX_CHANNEL3
  • EDMAMUX_CHANNEL4
  • EDMAMUX_CHANNEL5
  • EDMAMUX_CHANNEL6
  • EDMAMUX_CHANNEL7
  • EDMAMUX_CHANNEL8
new_state (TRUE or FALSE).
Return values
none.

Definition at line 802 of file at32f435_437_edma.c.


AT32F435/437 Firmwary Library: EMAC

Modules | Macros
EMAC
AT32F435_437_periph_driver

EMAC driver modules. More...

Modules

EMAC_smi_clock_border_definition
emac smi clock border
EMAC_interrupts_definition
emac interrupts
EMAC_mmc_flags_definition
emac mmc flags
EMAC_packet_definition
emac packet
EMAC_dma_descriptor_tdes0_definition
tdes0 definition
EMAC_dma_descriptor_tdes1_definition
tdes1 descriptor
EMAC_dma_descriptor_tdes2_definition
tdes2 descriptor
EMAC_dma_descriptor_tdes3_definition
tdes3 descriptor
EMAC_dma_descriptor_rdes0_definition
rdes0 descriptor
EMAC_dma_descriptor_rdes1_definition
rdes1 descriptor
EMAC_dma_descriptor_rdes2_definition
rdes2 descriptor
EMAC_dma_descriptor_rdes3_definition
rdes3 descriptor
EMAC_exported_types
EMAC_exported_functions
EMAC_private_functions

Macros

#define | PHY_TIMEOUT (0x000FFFFF)
#define | EMAC_DMA_TI_FLAG ((uint32_t)0x00000001)
emac dma flag More...
#define | EMAC_DMA_TPS_FLAG ((uint32_t)0x00000002)
#define | EMAC_DMA_TBU_FLAG ((uint32_t)0x00000004)
#define | EMAC_DMA_TJT_FLAG ((uint32_t)0x00000008)
#define | EMAC_DMA_OVF_FLAG ((uint32_t)0x00000010)
#define | EMAC_DMA_UNF_FLAG ((uint32_t)0x00000020)
#define | EMAC_DMA_RI_FLAG ((uint32_t)0x00000040)
#define | EMAC_DMA_RBU_FLAG ((uint32_t)0x00000080)
#define | EMAC_DMA_RPS_FLAG ((uint32_t)0x00000100)
#define | EMAC_DMA_RWT_FLAG ((uint32_t)0x00000200)
#define | EMAC_DMA_ETI_FLAG ((uint32_t)0x00000400)
#define | EMAC_DMA_FBEI_FLAG ((uint32_t)0x00002000)
#define | EMAC_DMA_ERI_FLAG ((uint32_t)0x00004000)
#define | EMAC_DMA_AIS_FLAG ((uint32_t)0x00008000)
#define | EMAC_DMA_NIS_FLAG ((uint32_t)0x00010000)
#define | EMAC ((emac_type *) EMAC_BASE)
#define | EMAC_MMC ((emac_mmc_type *) EMAC_MMC_BASE)
#define | EMAC_PTP ((emac_ptp_type *) EMAC_PTP_BASE)
#define | EMAC_DMA ((emac_dma_type *) EMAC_DMA_BASE)

Detailed Description

EMAC driver modules.

Macro Definition Documentation

◆ EMAC

#define EMAC ((emac_type *) EMAC_BASE)

Definition at line 1558 of file at32f435_437_emac.h.

◆ EMAC_DMA

#define EMAC_DMA ((emac_dma_type *) EMAC_DMA_BASE)

Definition at line 1561 of file at32f435_437_emac.h.

◆ EMAC_DMA_AIS_FLAG

#define EMAC_DMA_AIS_FLAG ((uint32_t)0x00008000)

emac dma abnormal interrupt summary

Definition at line 271 of file at32f435_437_emac.h.

◆ EMAC_DMA_ERI_FLAG

#define EMAC_DMA_ERI_FLAG ((uint32_t)0x00004000)

emac dma early receive interrupt

Definition at line 270 of file at32f435_437_emac.h.

◆ EMAC_DMA_ETI_FLAG

#define EMAC_DMA_ETI_FLAG ((uint32_t)0x00000400)

emac dma early transmit interrupt

Definition at line 268 of file at32f435_437_emac.h.

◆ EMAC_DMA_FBEI_FLAG

#define EMAC_DMA_FBEI_FLAG ((uint32_t)0x00002000)

emac dma fatal bus error interrupt

Definition at line 269 of file at32f435_437_emac.h.

◆ EMAC_DMA_NIS_FLAG

#define EMAC_DMA_NIS_FLAG ((uint32_t)0x00010000)

emac dma normal interrupt summary

Definition at line 272 of file at32f435_437_emac.h.

◆ EMAC_DMA_OVF_FLAG

#define EMAC_DMA_OVF_FLAG ((uint32_t)0x00000010)

emac dma receive overflow

Definition at line 262 of file at32f435_437_emac.h.

◆ EMAC_DMA_RBU_FLAG

#define EMAC_DMA_RBU_FLAG ((uint32_t)0x00000080)

emac dma receive buffer unavailable

Definition at line 265 of file at32f435_437_emac.h.

◆ EMAC_DMA_RI_FLAG

#define EMAC_DMA_RI_FLAG ((uint32_t)0x00000040)

emac dma receive interrupt

Definition at line 264 of file at32f435_437_emac.h.

◆ EMAC_DMA_RPS_FLAG

#define EMAC_DMA_RPS_FLAG ((uint32_t)0x00000100)

emac dma receive process stopped

Definition at line 266 of file at32f435_437_emac.h.

◆ EMAC_DMA_RWT_FLAG

#define EMAC_DMA_RWT_FLAG ((uint32_t)0x00000200)

emac dma receive watchdog timeout

Definition at line 267 of file at32f435_437_emac.h.

◆ EMAC_DMA_TBU_FLAG

#define EMAC_DMA_TBU_FLAG ((uint32_t)0x00000004)

emac dma transmit buffer unavailable

Definition at line 260 of file at32f435_437_emac.h.

◆ EMAC_DMA_TI_FLAG

#define EMAC_DMA_TI_FLAG ((uint32_t)0x00000001)

emac dma flag

emac dma transmit interrupt

Definition at line 258 of file at32f435_437_emac.h.

◆ EMAC_DMA_TJT_FLAG

#define EMAC_DMA_TJT_FLAG ((uint32_t)0x00000008)

emac dma transmit jabber timeout

Definition at line 261 of file at32f435_437_emac.h.

◆ EMAC_DMA_TPS_FLAG

#define EMAC_DMA_TPS_FLAG ((uint32_t)0x00000002)

emac dma transmit process stopped

Definition at line 259 of file at32f435_437_emac.h.

◆ EMAC_DMA_UNF_FLAG

#define EMAC_DMA_UNF_FLAG ((uint32_t)0x00000020)

emac dma transmit underflow

Definition at line 263 of file at32f435_437_emac.h.

◆ EMAC_MMC

#define EMAC_MMC ((emac_mmc_type *) EMAC_MMC_BASE)

Definition at line 1559 of file at32f435_437_emac.h.

◆ EMAC_PTP

#define EMAC_PTP ((emac_ptp_type *) EMAC_PTP_BASE)

Definition at line 1560 of file at32f435_437_emac.h.

◆ PHY_TIMEOUT

#define PHY_TIMEOUT (0x000FFFFF)

timeout for phy response

Definition at line 47 of file at32f435_437_emac.h.


AT32F435/437 Firmwary Library: EMAC_smi_clock_border_definition

Macros
EMAC_smi_clock_border_definition
AT32F435_437_periph_driver » EMAC

emac smi clock border More...

Macros

#define | EMAC_HCLK_BORDER_20MHZ (20000000)
#define | EMAC_HCLK_BORDER_35MHZ (35000000)
#define | EMAC_HCLK_BORDER_60MHZ (60000000)
#define | EMAC_HCLK_BORDER_100MHZ (100000000)
#define | EMAC_HCLK_BORDER_150MHZ (150000000)
#define | EMAC_HCLK_BORDER_250MHZ (250000000)
#define | EMAC_HCLK_BORDER_288MHZ (288000000)

Detailed Description

emac smi clock border

Macro Definition Documentation

◆ EMAC_HCLK_BORDER_100MHZ

#define EMAC_HCLK_BORDER_100MHZ (100000000)

hclk boarder of 100 mhz

Definition at line 57 of file at32f435_437_emac.h.

◆ EMAC_HCLK_BORDER_150MHZ

#define EMAC_HCLK_BORDER_150MHZ (150000000)

hclk boarder of 150 mhz

Definition at line 58 of file at32f435_437_emac.h.

◆ EMAC_HCLK_BORDER_20MHZ

#define EMAC_HCLK_BORDER_20MHZ (20000000)

hclk boarder of 20 mhz

Definition at line 54 of file at32f435_437_emac.h.

◆ EMAC_HCLK_BORDER_250MHZ

#define EMAC_HCLK_BORDER_250MHZ (250000000)

hclk boarder of 250 mhz

Definition at line 59 of file at32f435_437_emac.h.

◆ EMAC_HCLK_BORDER_288MHZ

#define EMAC_HCLK_BORDER_288MHZ (288000000)

hclk boarder of 288 mhz

Definition at line 60 of file at32f435_437_emac.h.

◆ EMAC_HCLK_BORDER_35MHZ

#define EMAC_HCLK_BORDER_35MHZ (35000000)

hclk boarder of 35 mhz

Definition at line 55 of file at32f435_437_emac.h.

◆ EMAC_HCLK_BORDER_60MHZ

#define EMAC_HCLK_BORDER_60MHZ (60000000)

hclk boarder of 60 mhz

Definition at line 56 of file at32f435_437_emac.h.


AT32F435/437 Firmwary Library: EMAC_interrupts_definition

Macros
EMAC_interrupts_definition
AT32F435_437_periph_driver » EMAC

emac interrupts More...

Macros

#define | EMAC_PMT_FLAG ((uint32_t)0x00000008)
#define | EMAC_MMC_FLAG ((uint32_t)0x00000010)
#define | EMAC_MMCR_FLAG ((uint32_t)0x00000020)
#define | EMAC_MMCT_FLAG ((uint32_t)0x00000040)
#define | EMAC_TST_FLAG ((uint32_t)0x00000200)

Detailed Description

emac interrupts

Macro Definition Documentation

◆ EMAC_MMC_FLAG

#define EMAC_MMC_FLAG ((uint32_t)0x00000010)

interrupt bit of mmc

Definition at line 72 of file at32f435_437_emac.h.

◆ EMAC_MMCR_FLAG

#define EMAC_MMCR_FLAG ((uint32_t)0x00000020)

interrupt bit of mmcr

Definition at line 73 of file at32f435_437_emac.h.

◆ EMAC_MMCT_FLAG

#define EMAC_MMCT_FLAG ((uint32_t)0x00000040)

interrupt bit of mmct

Definition at line 74 of file at32f435_437_emac.h.

◆ EMAC_PMT_FLAG

#define EMAC_PMT_FLAG ((uint32_t)0x00000008)

interrupt bit of pmt

Definition at line 71 of file at32f435_437_emac.h.

◆ EMAC_TST_FLAG

#define EMAC_TST_FLAG ((uint32_t)0x00000200)

interrupt bit of tst

Definition at line 75 of file at32f435_437_emac.h.


AT32F435/437 Firmwary Library: EMAC_mmc_flags_definition

Macros
EMAC_mmc_flags_definition
AT32F435_437_periph_driver » EMAC

emac mmc flags More...

Macros

#define | MMC_RX_CRC_ERROR ((uint32_t)0x00000020)
#define | MMC_RX_ALIGN_ERROR ((uint32_t)0x00000040)
#define | MMC_RX_GOOD_UNICAST ((uint32_t)0x00020000)
#define | MMC_TX_SINGLE_COL ((uint32_t)0x00004000)
#define | MMC_TX_MULTIPLE_COL ((uint32_t)0x00008000)
#define | MMC_TX_GOOD_FRAMES ((uint32_t)0x00200000)

Detailed Description

emac mmc flags

Macro Definition Documentation

◆ MMC_RX_ALIGN_ERROR

#define MMC_RX_ALIGN_ERROR ((uint32_t)0x00000040)

mmc error flag of rx alignment

Definition at line 87 of file at32f435_437_emac.h.

◆ MMC_RX_CRC_ERROR

#define MMC_RX_CRC_ERROR ((uint32_t)0x00000020)

mmc error flag of rx crc

Definition at line 86 of file at32f435_437_emac.h.

◆ MMC_RX_GOOD_UNICAST

#define MMC_RX_GOOD_UNICAST ((uint32_t)0x00020000)

mmc error flag of rx unicast good frames

Definition at line 88 of file at32f435_437_emac.h.

◆ MMC_TX_GOOD_FRAMES

#define MMC_TX_GOOD_FRAMES ((uint32_t)0x00200000)

mmc error flag of tx good frames

Definition at line 91 of file at32f435_437_emac.h.

◆ MMC_TX_MULTIPLE_COL

#define MMC_TX_MULTIPLE_COL ((uint32_t)0x00008000)

mmc error flag of tx multiple collision

Definition at line 90 of file at32f435_437_emac.h.

◆ MMC_TX_SINGLE_COL

#define MMC_TX_SINGLE_COL ((uint32_t)0x00004000)

mmc error flag of tx single collision

Definition at line 89 of file at32f435_437_emac.h.


AT32F435/437 Firmwary Library: EMAC_packet_definition

Macros
EMAC_packet_definition
AT32F435_437_periph_driver » EMAC

emac packet More...

Macros

#define | EMAC_MAX_PACKET_LENGTH 1520
#define | EMAC_HEADER 14
#define | EMAC_CRC 4
#define | EMAC_EXTRA 2
#define | VLAN_TAG 4
#define | EMAC_MIN_PAYLOAD 46
#define | EMAC_MAX_PAYLOAD 1500
#define | JUMBO_FRAME_PAYLOAD 9000
#define | EMAC_DMARXDESC_FRAME_LENGTHSHIFT 16

Detailed Description

emac packet

Macro Definition Documentation

◆ EMAC_CRC

#define EMAC_CRC 4

ethernet crc

Definition at line 104 of file at32f435_437_emac.h.

◆ EMAC_DMARXDESC_FRAME_LENGTHSHIFT

#define EMAC_DMARXDESC_FRAME_LENGTHSHIFT 16

Definition at line 110 of file at32f435_437_emac.h.

◆ EMAC_EXTRA

#define EMAC_EXTRA 2

extra bytes in some cases

Definition at line 105 of file at32f435_437_emac.h.

◆ EMAC_HEADER

#define EMAC_HEADER 14

6 byte dest addr, 6 byte src addr, 2 byte length/ept_type

Definition at line 103 of file at32f435_437_emac.h.

◆ EMAC_MAX_PACKET_LENGTH

#define EMAC_MAX_PACKET_LENGTH 1520

emac_header + emac_extra + emac_max_payload + emac_crc

Definition at line 102 of file at32f435_437_emac.h.

◆ EMAC_MAX_PAYLOAD

#define EMAC_MAX_PAYLOAD 1500

maximum ethernet payload size

Definition at line 108 of file at32f435_437_emac.h.

◆ EMAC_MIN_PAYLOAD

#define EMAC_MIN_PAYLOAD 46

minimum ethernet payload size

Definition at line 107 of file at32f435_437_emac.h.

◆ JUMBO_FRAME_PAYLOAD

#define JUMBO_FRAME_PAYLOAD 9000

jumbo frame payload size

Definition at line 109 of file at32f435_437_emac.h.

◆ VLAN_TAG

#define VLAN_TAG 4

optional 802.1q vlan tag

Definition at line 106 of file at32f435_437_emac.h.


AT32F435/437 Firmwary Library: EMAC_dma_descriptor_tdes0_definition

Macros
EMAC_dma_descriptor_tdes0_definition
AT32F435_437_periph_driver » EMAC

tdes0 definition More...

Macros

#define | EMAC_DMATXDESC_OWN ((uint32_t)0x80000000)
#define | EMAC_DMATXDESC_IC ((uint32_t)0x40000000)
#define | EMAC_DMATXDESC_LS ((uint32_t)0x20000000)
#define | EMAC_DMATXDESC_FS ((uint32_t)0x10000000)
#define | EMAC_DMATXDESC_DC ((uint32_t)0x08000000)
#define | EMAC_DMATXDESC_DP ((uint32_t)0x04000000)
#define | EMAC_DMATXDESC_TTSE ((uint32_t)0x02000000)
#define | EMAC_DMATXDESC_CIC ((uint32_t)0x00C00000)
#define | EMAC_DMATXDESC_CIC_BYPASS ((uint32_t)0x00000000)
#define | EMAC_DMATXDESC_CIC_IPV4HEADER ((uint32_t)0x00400000)
#define | EMAC_DMATXDESC_CIC_TUI_SEG ((uint32_t)0x00800000)
#define | EMAC_DMATXDESC_CIC_TUI_FULL ((uint32_t)0x00C00000)
#define | EMAC_DMATXDESC_TER ((uint32_t)0x00200000)
#define | EMAC_DMATXDESC_TCH ((uint32_t)0x00100000)
#define | EMAC_DMATXDESC_TTSS ((uint32_t)0x00020000)
#define | EMAC_DMATXDESC_IHE ((uint32_t)0x00010000)
#define | EMAC_DMATXDESC_ES ((uint32_t)0x00008000)
#define | EMAC_DMATXDESC_JT ((uint32_t)0x00004000)
#define | EMAC_DMATXDESC_FF ((uint32_t)0x00002000)
#define | EMAC_DMATXDESC_PCE ((uint32_t)0x00001000)
#define | EMAC_DMATXDESC_LCA ((uint32_t)0x00000800)
#define | EMAC_DMATXDESC_NC ((uint32_t)0x00000400)
#define | EMAC_DMATXDESC_LCO ((uint32_t)0x00000200)
#define | EMAC_DMATXDESC_EC ((uint32_t)0x00000100)
#define | EMAC_DMATXDESC_VF ((uint32_t)0x00000080)
#define | EMAC_DMATXDESC_CC ((uint32_t)0x00000078)
#define | EMAC_DMATXDESC_ED ((uint32_t)0x00000004)
#define | EMAC_DMATXDESC_UF ((uint32_t)0x00000002)
#define | EMAC_DMATXDESC_DB ((uint32_t)0x00000001)

Detailed Description

tdes0 definition

Macro Definition Documentation

◆ EMAC_DMATXDESC_CC

#define EMAC_DMATXDESC_CC ((uint32_t)0x00000078)

collision count

Definition at line 146 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_CIC

#define EMAC_DMATXDESC_CIC ((uint32_t)0x00C00000)

checksum insertion control: 4 cases

Definition at line 128 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_CIC_BYPASS

#define EMAC_DMATXDESC_CIC_BYPASS ((uint32_t)0x00000000)

do nothing: checksum engine is bypassed

Definition at line 129 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_CIC_IPV4HEADER

#define EMAC_DMATXDESC_CIC_IPV4HEADER ((uint32_t)0x00400000)

ipv4 header checksum insertion

Definition at line 130 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_CIC_TUI_FULL

#define EMAC_DMATXDESC_CIC_TUI_FULL ((uint32_t)0x00C00000)

tcp/udp/icmp checksum insertion fully calculated

Definition at line 132 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_CIC_TUI_SEG

#define EMAC_DMATXDESC_CIC_TUI_SEG ((uint32_t)0x00800000)

tcp/udp/icmp checksum insertion calculated over segment only

Definition at line 131 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_DB

#define EMAC_DMATXDESC_DB ((uint32_t)0x00000001)

deferred bit

Definition at line 149 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_DC

#define EMAC_DMATXDESC_DC ((uint32_t)0x08000000)

disable crc

Definition at line 125 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_DP

#define EMAC_DMATXDESC_DP ((uint32_t)0x04000000)

disable padding

Definition at line 126 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_EC

#define EMAC_DMATXDESC_EC ((uint32_t)0x00000100)

excessive collision: transmission aborted after 16 collisions

Definition at line 144 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_ED

#define EMAC_DMATXDESC_ED ((uint32_t)0x00000004)

excessive deferral

Definition at line 147 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_ES

#define EMAC_DMATXDESC_ES ((uint32_t)0x00008000)

error summary: or of the following bits: ue || ED || EC || LCO || NC || LCA || FF || JT

Definition at line 137 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_FF

#define EMAC_DMATXDESC_FF ((uint32_t)0x00002000)

frame flushed: dma/mtl flushed the frame due to SW flush

Definition at line 139 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_FS

#define EMAC_DMATXDESC_FS ((uint32_t)0x10000000)

first segment

Definition at line 124 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_IC

#define EMAC_DMATXDESC_IC ((uint32_t)0x40000000)

interrupt on completion

Definition at line 122 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_IHE

#define EMAC_DMATXDESC_IHE ((uint32_t)0x00010000)

ip header error

Definition at line 136 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_JT

#define EMAC_DMATXDESC_JT ((uint32_t)0x00004000)

jabber timeout

Definition at line 138 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_LCA

#define EMAC_DMATXDESC_LCA ((uint32_t)0x00000800)

loss of carrier: carrier lost during tramsmission

Definition at line 141 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_LCO

#define EMAC_DMATXDESC_LCO ((uint32_t)0x00000200)

late collision: transmission aborted due to collision

Definition at line 143 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_LS

#define EMAC_DMATXDESC_LS ((uint32_t)0x20000000)

last segment

Definition at line 123 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_NC

#define EMAC_DMATXDESC_NC ((uint32_t)0x00000400)

no carrier: no carrier signal from the tranceiver

Definition at line 142 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_OWN

#define EMAC_DMATXDESC_OWN ((uint32_t)0x80000000)

own bit: descriptor is owned by dma engine

Definition at line 121 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_PCE

#define EMAC_DMATXDESC_PCE ((uint32_t)0x00001000)

payload checksum error

Definition at line 140 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_TCH

#define EMAC_DMATXDESC_TCH ((uint32_t)0x00100000)

second address chained

Definition at line 134 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_TER

#define EMAC_DMATXDESC_TER ((uint32_t)0x00200000)

transmit end of ring

Definition at line 133 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_TTSE

#define EMAC_DMATXDESC_TTSE ((uint32_t)0x02000000)

transmit time stamp enable

Definition at line 127 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_TTSS

#define EMAC_DMATXDESC_TTSS ((uint32_t)0x00020000)

tx time stamp status

Definition at line 135 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_UF

#define EMAC_DMATXDESC_UF ((uint32_t)0x00000002)

underflow error: late data arrival from the memory

Definition at line 148 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_VF

#define EMAC_DMATXDESC_VF ((uint32_t)0x00000080)

vlan frame

Definition at line 145 of file at32f435_437_emac.h.


AT32F435/437 Firmwary Library: EMAC_dma_descriptor_tdes1_definition

Macros
EMAC_dma_descriptor_tdes1_definition
AT32F435_437_periph_driver » EMAC

tdes1 descriptor More...

Macros

#define | EMAC_DMATXDESC_TBS2 ((uint32_t)0x1FFF0000)
#define | EMAC_DMATXDESC_TBS1 ((uint32_t)0x00001FFF)

Detailed Description

tdes1 descriptor

Macro Definition Documentation

◆ EMAC_DMATXDESC_TBS1

#define EMAC_DMATXDESC_TBS1 ((uint32_t)0x00001FFF)

transmit buffer1 size

Definition at line 161 of file at32f435_437_emac.h.

◆ EMAC_DMATXDESC_TBS2

#define EMAC_DMATXDESC_TBS2 ((uint32_t)0x1FFF0000)

transmit buffer2 size

Definition at line 160 of file at32f435_437_emac.h.


AT32F435/437 Firmwary Library: EMAC_dma_descriptor_tdes2_definition

Macros
EMAC_dma_descriptor_tdes2_definition
AT32F435_437_periph_driver » EMAC

tdes2 descriptor More...

Macros

#define EMAC_DMATXDESC_B1AP ((uint32_t)0xFFFFFFFF)

Detailed Description

tdes2 descriptor

Macro Definition Documentation

◆ EMAC_DMATXDESC_B1AP

#define EMAC_DMATXDESC_B1AP ((uint32_t)0xFFFFFFFF)

buffer1 address pointer

Definition at line 172 of file at32f435_437_emac.h.


AT32F435/437 Firmwary Library: EMAC_dma_descriptor_tdes3_definition

Macros
EMAC_dma_descriptor_tdes3_definition
AT32F435_437_periph_driver » EMAC

tdes3 descriptor More...

Macros

#define EMAC_DMATxDesc_B2AP ((uint32_t)0xFFFFFFFF)

Detailed Description

tdes3 descriptor

Macro Definition Documentation

◆ EMAC_DMATxDesc_B2AP

#define EMAC_DMATxDesc_B2AP ((uint32_t)0xFFFFFFFF)

buffer2 address pointer

Definition at line 183 of file at32f435_437_emac.h.


AT32F435/437 Firmwary Library: EMAC_dma_descriptor_rdes0_definition

Macros
EMAC_dma_descriptor_rdes0_definition
AT32F435_437_periph_driver » EMAC

rdes0 descriptor More...

Macros

#define | EMAC_DMARXDESC_OWN ((uint32_t)0x80000000)
#define | EMAC_DMARXDESC_AFM ((uint32_t)0x40000000)
#define | EMAC_DMARXDESC_FL ((uint32_t)0x3FFF0000)
#define | EMAC_DMARXDESC_ES ((uint32_t)0x00008000)
#define | EMAC_DMARXDESC_DE ((uint32_t)0x00004000)
#define | EMAC_DMARXDESC_SAF ((uint32_t)0x00002000)
#define | EMAC_DMARXDESC_LE ((uint32_t)0x00001000)
#define | EMAC_DMARXDESC_OE ((uint32_t)0x00000800)
#define | EMAC_DMARXDESC_VLAN ((uint32_t)0x00000400)
#define | EMAC_DMARXDESC_FS ((uint32_t)0x00000200)
#define | EMAC_DMARXDESC_LS ((uint32_t)0x00000100)
#define | EMAC_DMARXDESC_IPV4HCE ((uint32_t)0x00000080)
#define | EMAC_DMARXDESC_LC ((uint32_t)0x00000040)
#define | EMAC_DMARXDESC_FT ((uint32_t)0x00000020)
#define | EMAC_DMARXDESC_RWT ((uint32_t)0x00000010)
#define | EMAC_DMARXDESC_RE ((uint32_t)0x00000008)
#define | EMAC_DMARXDESC_DBE ((uint32_t)0x00000004)
#define | EMAC_DMARXDESC_CE ((uint32_t)0x00000002)
#define | EMAC_DMARXDESC_MAMPCE ((uint32_t)0x00000001)

Detailed Description

rdes0 descriptor

Macro Definition Documentation

◆ EMAC_DMARXDESC_AFM

#define EMAC_DMARXDESC_AFM ((uint32_t)0x40000000)

da filter fail for the rx frame

Definition at line 195 of file at32f435_437_emac.h.

◆ EMAC_DMARXDESC_CE

#define EMAC_DMARXDESC_CE ((uint32_t)0x00000002)

crc error

Definition at line 211 of file at32f435_437_emac.h.

◆ EMAC_DMARXDESC_DBE

#define EMAC_DMARXDESC_DBE ((uint32_t)0x00000004)

dribble bit error: frame contains non int multiple of 8 bits

Definition at line 210 of file at32f435_437_emac.h.

◆ EMAC_DMARXDESC_DE

#define EMAC_DMARXDESC_DE ((uint32_t)0x00004000)

desciptor error: no more descriptors for receive frame

Definition at line 198 of file at32f435_437_emac.h.

◆ EMAC_DMARXDESC_ES

#define EMAC_DMARXDESC_ES ((uint32_t)0x00008000)

error summary: or of the following bits: de || OE || IPC || LC || RWT || RE || CE

Definition at line 197 of file at32f435_437_emac.h.

◆ EMAC_DMARXDESC_FL

#define EMAC_DMARXDESC_FL ((uint32_t)0x3FFF0000)

receive descriptor frame length

Definition at line 196 of file at32f435_437_emac.h.

◆ EMAC_DMARXDESC_FS

#define EMAC_DMARXDESC_FS ((uint32_t)0x00000200)

first descriptor of the frame

Definition at line 203 of file at32f435_437_emac.h.

◆ EMAC_DMARXDESC_FT

#define EMAC_DMARXDESC_FT ((uint32_t)0x00000020)

frame ept_type - ethernet, otherwise 802.3

Definition at line 207 of file at32f435_437_emac.h.

◆ EMAC_DMARXDESC_IPV4HCE

#define EMAC_DMARXDESC_IPV4HCE ((uint32_t)0x00000080)

ipc checksum error: rx ipv4 header checksum error

Definition at line 205 of file at32f435_437_emac.h.

◆ EMAC_DMARXDESC_LC

#define EMAC_DMARXDESC_LC ((uint32_t)0x00000040)

late collision occurred during reception

Definition at line 206 of file at32f435_437_emac.h.

◆ EMAC_DMARXDESC_LE

#define EMAC_DMARXDESC_LE ((uint32_t)0x00001000)

frame size not matching with length field

Definition at line 200 of file at32f435_437_emac.h.

◆ EMAC_DMARXDESC_LS

#define EMAC_DMARXDESC_LS ((uint32_t)0x00000100)

last descriptor of the frame

Definition at line 204 of file at32f435_437_emac.h.

◆ EMAC_DMARXDESC_MAMPCE

#define EMAC_DMARXDESC_MAMPCE ((uint32_t)0x00000001)

rx mac address/payload checksum error: rx mac address matched/ Rx Payload Checksum Error

Definition at line 212 of file at32f435_437_emac.h.

◆ EMAC_DMARXDESC_OE

#define EMAC_DMARXDESC_OE ((uint32_t)0x00000800)

overflow error: frame was damaged due to buffer overflow

Definition at line 201 of file at32f435_437_emac.h.

◆ EMAC_DMARXDESC_OWN

#define EMAC_DMARXDESC_OWN ((uint32_t)0x80000000)

own bit: descriptor is owned by dma engine

Definition at line 194 of file at32f435_437_emac.h.

◆ EMAC_DMARXDESC_RE

#define EMAC_DMARXDESC_RE ((uint32_t)0x00000008)

receive error: error reported by mii interface

Definition at line 209 of file at32f435_437_emac.h.

◆ EMAC_DMARXDESC_RWT

#define EMAC_DMARXDESC_RWT ((uint32_t)0x00000010)

receive watchdog timeout: watchdog timer expired during reception

Definition at line 208 of file at32f435_437_emac.h.

◆ EMAC_DMARXDESC_SAF

#define EMAC_DMARXDESC_SAF ((uint32_t)0x00002000)

sa filter fail for the received frame

Definition at line 199 of file at32f435_437_emac.h.

◆ EMAC_DMARXDESC_VLAN

#define EMAC_DMARXDESC_VLAN ((uint32_t)0x00000400)

vlan tag: received frame is a vlan frame

Definition at line 202 of file at32f435_437_emac.h.


AT32F435/437 Firmwary Library: EMAC_dma_descriptor_rdes1_definition

Macros
EMAC_dma_descriptor_rdes1_definition
AT32F435_437_periph_driver » EMAC

rdes1 descriptor More...

Macros

#define | EMAC_DMARXDESC_DIC ((uint32_t)0x80000000)
#define | EMAC_DMARXDESC_RBS2 ((uint32_t)0x1FFF0000)
#define | EMAC_DMARXDESC_RER ((uint32_t)0x00008000)
#define | EMAC_DMARXDESC_RCH ((uint32_t)0x00004000)
#define | EMAC_DMARXDESC_RBS1 ((uint32_t)0x00001FFF)

Detailed Description

rdes1 descriptor

Macro Definition Documentation

◆ EMAC_DMARXDESC_DIC

#define EMAC_DMARXDESC_DIC ((uint32_t)0x80000000)

disable interrupt on completion

Definition at line 223 of file at32f435_437_emac.h.

◆ EMAC_DMARXDESC_RBS1

#define EMAC_DMARXDESC_RBS1 ((uint32_t)0x00001FFF)

receive buffer1 size

Definition at line 227 of file at32f435_437_emac.h.

◆ EMAC_DMARXDESC_RBS2

#define EMAC_DMARXDESC_RBS2 ((uint32_t)0x1FFF0000)

receive buffer2 size

Definition at line 224 of file at32f435_437_emac.h.

◆ EMAC_DMARXDESC_RCH

#define EMAC_DMARXDESC_RCH ((uint32_t)0x00004000)

second address chained

Definition at line 226 of file at32f435_437_emac.h.

◆ EMAC_DMARXDESC_RER

#define EMAC_DMARXDESC_RER ((uint32_t)0x00008000)

receive end of ring

Definition at line 225 of file at32f435_437_emac.h.


AT32F435/437 Firmwary Library: EMAC_dma_descriptor_rdes2_definition

Macros
EMAC_dma_descriptor_rdes2_definition
AT32F435_437_periph_driver » EMAC

rdes2 descriptor More...

Macros

#define EMAC_DMARXDESC_B1AP ((uint32_t)0xFFFFFFFF)

Detailed Description

rdes2 descriptor

Macro Definition Documentation

◆ EMAC_DMARXDESC_B1AP

#define EMAC_DMARXDESC_B1AP ((uint32_t)0xFFFFFFFF)

buffer1 address pointer

Definition at line 238 of file at32f435_437_emac.h.


AT32F435/437 Firmwary Library: EMAC_dma_descriptor_rdes3_definition

Macros
EMAC_dma_descriptor_rdes3_definition
AT32F435_437_periph_driver » EMAC

rdes3 descriptor More...

Macros

#define EMAC_DMARXDESC_B2AP ((uint32_t)0xFFFFFFFF)

Detailed Description

rdes3 descriptor

Macro Definition Documentation

◆ EMAC_DMARXDESC_B2AP

#define EMAC_DMARXDESC_B2AP ((uint32_t)0xFFFFFFFF)

buffer2 address pointer

Definition at line 249 of file at32f435_437_emac.h.


AT32F435/437 Firmwary Library: EMAC_exported_types

Data Structures | Enumerations
EMAC_exported_types
AT32F435_437_periph_driver » EMAC

Data Structures

struct | emac_control_config_type
ethernet mac control config type More...
struct | emac_dma_config_type
ethernet mac dma config type More...
struct | emac_dma_desc_type
dma desciptors data structure definition More...
struct | emac_type
type define emac mac register all More...
struct | emac_mmc_type
type define emac mmc register all More...
struct | emac_ptp_type
type define emac ptp register all More...
struct | emac_dma_type
type define emac ptp register all More...

Enumerations

enum | emac_auto_negotiation_type { EMAC_AUTO_NEGOTIATION_OFF = 0x00 , EMAC_AUTO_NEGOTIATION_ON = 0x01 }
emac auto negotiation type More...
enum | emac_bol_type { EMAC_BACKOFF_LIMIT_0 = 0x00 , EMAC_BACKOFF_LIMIT_1 = 0x01 , EMAC_BACKOFF_LIMIT_2 = 0x02 , EMAC_BACKOFF_LIMIT_3 = 0x03 }
emac back_off limit type More...
enum | emac_duplex_type { EMAC_HALF_DUPLEX = 0x00 , EMAC_FULL_DUPLEX = 0x01 }
emac duplex type More...
enum | emac_speed_type { EMAC_SPEED_10MBPS = 0x00 , EMAC_SPEED_100MBPS = 0x01 }
emac speed type More...
enum emac_intergrame_gap_type {
EMAC_INTERFRAME_GAP_96BIT = 0x00 , EMAC_INTERFRAME_GAP_88BIT = 0x01 , EMAC_INTERFRAME_GAP_80BIT = 0x02 , EMAC_INTERFRAME_GAP_72BIT = 0x03 ,
EMAC_INTERFRAME_GAP_64BIT = 0x04 , EMAC_INTERFRAME_GAP_56BIT = 0x05 , EMAC_INTERFRAME_GAP_48BIT = 0x06 , EMAC_INTERFRAME_GAP_40BIT = 0x07
}
emac interframe gap type More...
enum emac_clock_range_type {
EMAC_CLOCK_RANGE_60_TO_100 = 0x00 , EMAC_CLOCK_RANGE_100_TO_150 = 0x01 , EMAC_CLOCK_RANGE_20_TO_35 = 0x02 , EMAC_CLOCK_RANGE_35_TO_60 = 0x03 ,
EMAC_CLOCK_RANGE_150_TO_250 = 0x04 , EMAC_CLOCK_RANGE_250_TO_288 = 0x05
}
mdc clock range type More...
enum | emac_control_frames_filter_type { EMAC_CONTROL_FRAME_PASSING_NO = 0x00 , EMAC_CONTROL_FRAME_PASSING_ALL = 0x02 , EMAC_CONTROL_FRAME_PASSING_MATCH = 0x03 }
emac control frames filter type More...
enum | emac_pause_slot_threshold_type { EMAC_PAUSE_4_SLOT_TIME = 0x00 , EMAC_PAUSE_28_SLOT_TIME = 0x01 , EMAC_PAUSE_144_SLOT_TIME = 0x02 , EMAC_PAUSE_256_SLOT_TIME = 0x03 }
pause threshold type More...
enum | emac_interrupt_mask_type { EMAC_INTERRUPT_PMT_MASK = 0x00 , EMAC_INTERRUPT_TST_MASK = 0x01 }
interrupt mask type More...
enum | emac_address_type { EMAC_ADDRESS_FILTER_1 = 0x01 , EMAC_ADDRESS_FILTER_2 = 0x02 , EMAC_ADDRESS_FILTER_3 = 0x03 }
mac address type More...
enum | emac_address_filter_type { EMAC_DESTINATION_FILTER = 0x00 , EMAC_SOURCE_FILTER = 0x01 }
address filter type More...
enum emac_address_mask_type {
EMAC_ADDRESS_MASK_8L0 = 0x01 , EMAC_ADDRESS_MASK_15L8 = 0x02 , EMAC_ADDRESS_MASK_23L16 = 0x04 , EMAC_ADDRESS_MASK_31L24 = 0x08 ,
EMAC_ADDRESS_MASK_7H0 = 0x10 , EMAC_ADDRESS_MASK_15H8 = 0x20
}
address mask type More...
enum | emac_dma_rx_tx_ratio_type { EMAC_DMA_1_RX_1_TX = 0x00 , EMAC_DMA_2_RX_1_TX = 0x01 , EMAC_DMA_3_RX_1_TX = 0x02 , EMAC_DMA_4_RX_1_TX = 0x03 }
rx tx priority ratio type More...
enum emac_dma_pbl_type {
EMAC_DMA_PBL_1 = 0x01 , EMAC_DMA_PBL_2 = 0x02 , EMAC_DMA_PBL_4 = 0x04 , EMAC_DMA_PBL_8 = 0x08 ,
EMAC_DMA_PBL_16 = 0x10 , EMAC_DMA_PBL_32 = 0x20
}
programmable burst length More...
enum | emac_dma_tx_rx_type { EMAC_DMA_TRANSMIT = 0x00 , EMAC_DMA_RECEIVE = 0x01 }
dma tx rx type More...
enum emac_dma_receive_process_status_type {
EMAC_DMA_RX_RESET_STOP_COMMAND = 0x00 , EMAC_DMA_RX_FETCH_DESCRIPTOR = 0x01 , EMAC_DMA_RX_WAITING_PACKET = 0x03 , EMAC_DMA_RX_DESCRIPTOR_UNAVAILABLE = 0x04 ,
EMAC_DMA_RX_CLOSE_DESCRIPTOR = 0x05 , EMAC_DMA_RX_FIFO_TO_HOST = 0x07
}
dma receive process status type More...
enum emac_dma_transmit_process_status_type {
EMAC_DMA_TX_RESET_STOP_COMMAND = 0x00 , EMAC_DMA_TX_FETCH_DESCRIPTOR = 0x01 , EMAC_DMA_TX_WAITING_FOR_STATUS = 0x02 , EMAC_DMA_TX_HOST_TO_FIFO = 0x03 ,
EMAC_DMA_TX_DESCRIPTOR_UNAVAILABLE = 0x06 , EMAC_DMA_TX_CLOSE_DESCRIPTOR = 0x07
}
dma transmit process status type More...
enum emac_dma_operations_type {
EMAC_DMA_OPS_START_STOP_RECEIVE = 0x00 , EMAC_DMA_OPS_SECOND_FRAME = 0x01 , EMAC_DMA_OPS_FORWARD_UNDERSIZED = 0x02 , EMAC_DMA_OPS_FORWARD_ERROR = 0x03 ,
EMAC_DMA_OPS_START_STOP_TRANSMIT = 0x04 , EMAC_DMA_OPS_FLUSH_TRANSMIT_FIFO = 0x05 , EMAC_DMA_OPS_TRANSMIT_STORE_FORWARD = 0x06 , EMAC_DMA_OPS_RECEIVE_FLUSH_DISABLE = 0x07 ,
EMAC_DMA_OPS_RECEIVE_STORE_FORWARD = 0x08 , EMAC_DMA_OPS_DROP_ERROR_DISABLE = 0x09
}
dma operations type More...
enum | emac_dma_receive_threshold_type { EMAC_DMA_RX_THRESHOLD_64_BYTES = 0x00 , EMAC_DMA_RX_THRESHOLD_32_BYTES = 0x01 , EMAC_DMA_RX_THRESHOLD_96_BYTES = 0x02 , EMAC_DMA_RX_THRESHOLD_128_BYTES = 0x03 }
receive threshold control type More...
enum emac_dma_transmit_threshold_type {
EMAC_DMA_TX_THRESHOLD_64_BYTES = 0x00 , EMAC_DMA_TX_THRESHOLD_128_BYTES = 0x01 , EMAC_DMA_TX_THRESHOLD_192_BYTES = 0x02 , EMAC_DMA_TX_THRESHOLD_256_BYTES = 0x03 ,
EMAC_DMA_TX_THRESHOLD_40_BYTES = 0x04 , EMAC_DMA_TX_THRESHOLD_32_BYTES = 0x05 , EMAC_DMA_TX_THRESHOLD_24_BYTES = 0x06 , EMAC_DMA_TX_THRESHOLD_16_BYTES = 0x07
}
transmit threshold control type More...
enum emac_dma_interrupt_type {
EMAC_DMA_INTERRUPT_TX = 0x00 , EMAC_DMA_INTERRUPT_TX_STOP = 0x01 , EMAC_DMA_INTERRUPT_TX_UNAVAILABLE = 0x02 , EMAC_DMA_INTERRUPT_TX_JABBER = 0x03 ,
EMAC_DMA_INTERRUPT_RX_OVERFLOW = 0x04 , EMAC_DMA_INTERRUPT_TX_UNDERFLOW = 0x05 , EMAC_DMA_INTERRUPT_RX = 0x06 , EMAC_DMA_INTERRUPT_RX_UNAVAILABLE = 0x07 ,
EMAC_DMA_INTERRUPT_RX_STOP = 0x08 , EMAC_DMA_INTERRUPT_RX_TIMEOUT = 0x09 , EMAC_DMA_INTERRUPT_TX_EARLY = 0x0A , EMAC_DMA_INTERRUPT_FATAL_BUS_ERROR = 0x0B ,
EMAC_DMA_INTERRUPT_RX_EARLY = 0x0C , EMAC_DMA_INTERRUPT_ABNORMAL_SUMMARY = 0x0D , EMAC_DMA_INTERRUPT_NORMAL_SUMMARY = 0x0E
}
dma interrupt type More...
enum | emac_dma_transfer_address_type { EMAC_DMA_TX_DESCRIPTOR = 0x00 , EMAC_DMA_RX_DESCRIPTOR = 0x01 , EMAC_DMA_TX_BUFFER = 0x02 , EMAC_DMA_RX_BUFFER = 0x03 }
dma tansfer address type More...
enum | emac_ptp_clock_node_type { EMAC_PTP_NORMAL_CLOCK = 0x00 , EMAC_PTP_BOUNDARY_CLOCK = 0x01 , EMAC_PTP_END_TO_END_CLOCK = 0x02 , EMAC_PTP_PEER_TO_PEER_CLOCK = 0x03 }
clock node type More...
enum | emac_ptp_timestamp_status_type { EMAC_PTP_SECOND_OVERFLOW = 0x00 , EMAC_PTP_TARGET_TIME_REACH = 0x01 }
time stamp status type More...
enum emac_ptp_pps_control_type {
EMAC_PTP_PPS_1HZ = 0x00 , EMAC_PTP_PPS_2HZ = 0x01 , EMAC_PTP_PPS_4HZ = 0x02 , EMAC_PTP_PPS_8HZ = 0x03 ,
EMAC_PTP_PPS_16HZ = 0x04 , EMAC_PTP_PPS_32HZ = 0x05 , EMAC_PTP_PPS_64HZ = 0x06 , EMAC_PTP_PPS_128HZ = 0x07 ,
EMAC_PTP_PPS_256HZ = 0x08 , EMAC_PTP_PPS_512HZ = 0x09 , EMAC_PTP_PPS_1024HZ = 0x0A , EMAC_PTP_PPS_2048HZ = 0x0B ,
EMAC_PTP_PPS_4096HZ = 0x0C , EMAC_PTP_PPS_8192HZ = 0x0D , EMAC_PTP_PPS_16384HZ = 0x0E , EMAC_PTP_PPS_32768HZ = 0x0F
}
pps control type More...

Detailed Description

Enumeration Type Documentation

◆ emac_address_filter_type

enum emac_address_filter_type

address filter type

Enumerator
EMAC_DESTINATION_FILTER | destination mac address filter
EMAC_SOURCE_FILTER | source mac address filter

Definition at line 387 of file at32f435_437_emac.h.

◆ emac_address_mask_type

enum emac_address_mask_type

address mask type

Enumerator
EMAC_ADDRESS_MASK_8L0 | byte 0 of mac address low register
EMAC_ADDRESS_MASK_15L8 | byte 1 of mac address low register
EMAC_ADDRESS_MASK_23L16 | byte 2 of mac address low register
EMAC_ADDRESS_MASK_31L24 | byte 3 of mac address low register
EMAC_ADDRESS_MASK_7H0 | byte 0 of mac address high register
EMAC_ADDRESS_MASK_15H8 | byte 1 of mac address high register

Definition at line 396 of file at32f435_437_emac.h.

◆ emac_address_type

enum emac_address_type

mac address type

Enumerator
EMAC_ADDRESS_FILTER_1 | mac address 1 filter
EMAC_ADDRESS_FILTER_2 | mac address 2 filter
EMAC_ADDRESS_FILTER_3 | mac address 3 filter

Definition at line 377 of file at32f435_437_emac.h.

◆ emac_auto_negotiation_type

enum emac_auto_negotiation_type

emac auto negotiation type

Enumerator
EMAC_AUTO_NEGOTIATION_OFF | disable auto negotiation
EMAC_AUTO_NEGOTIATION_ON | enable auto negotiation

Definition at line 281 of file at32f435_437_emac.h.

◆ emac_bol_type

enum emac_bol_type

emac back_off limit type

Enumerator
EMAC_BACKOFF_LIMIT_0 | retransmission clock gap numbers betwenn n and 10
EMAC_BACKOFF_LIMIT_1 | retransmission clock gap numbers betwenn n and 8
EMAC_BACKOFF_LIMIT_2 | retransmission clock gap numbers betwenn n and 4
EMAC_BACKOFF_LIMIT_3 | retransmission clock gap numbers betwenn n and 1

Definition at line 290 of file at32f435_437_emac.h.

◆ emac_clock_range_type

enum emac_clock_range_type

mdc clock range type

Enumerator
EMAC_CLOCK_RANGE_60_TO_100 | mdc is hclk/42
EMAC_CLOCK_RANGE_100_TO_150 | mdc is hclk/62
EMAC_CLOCK_RANGE_20_TO_35 | mdc is hclk/16
EMAC_CLOCK_RANGE_35_TO_60 | mdc is hclk/26
EMAC_CLOCK_RANGE_150_TO_250 | mdc is hclk/102
EMAC_CLOCK_RANGE_250_TO_288 | mdc is hclk/102

Definition at line 334 of file at32f435_437_emac.h.

◆ emac_control_frames_filter_type

enum emac_control_frames_filter_type

emac control frames filter type

Enumerator
EMAC_CONTROL_FRAME_PASSING_NO | don't pass any control frame to application
EMAC_CONTROL_FRAME_PASSING_ALL | pass all control frames to application
EMAC_CONTROL_FRAME_PASSING_MATCH | only pass filtered control frames to application

Definition at line 347 of file at32f435_437_emac.h.

◆ emac_dma_interrupt_type

enum emac_dma_interrupt_type

dma interrupt type

Enumerator
EMAC_DMA_INTERRUPT_TX | transmit interrupt
EMAC_DMA_INTERRUPT_TX_STOP | transmit process stopped interrupt
EMAC_DMA_INTERRUPT_TX_UNAVAILABLE | transmit buffer unavailable interrupt
EMAC_DMA_INTERRUPT_TX_JABBER | transmit jabber timeout interrupt
EMAC_DMA_INTERRUPT_RX_OVERFLOW | receive overflow interrupt
EMAC_DMA_INTERRUPT_TX_UNDERFLOW | transmit underflow interrupt
EMAC_DMA_INTERRUPT_RX | receive interrupt
EMAC_DMA_INTERRUPT_RX_UNAVAILABLE | receive buffer unavailable interrupt
EMAC_DMA_INTERRUPT_RX_STOP | receive process stopped interrupt
EMAC_DMA_INTERRUPT_RX_TIMEOUT | receive watchdog timeout interrupt
EMAC_DMA_INTERRUPT_TX_EARLY | early transmit interrupt
EMAC_DMA_INTERRUPT_FATAL_BUS_ERROR | fatal bus error interrupt
EMAC_DMA_INTERRUPT_RX_EARLY | early receive interrupt
EMAC_DMA_INTERRUPT_ABNORMAL_SUMMARY | abnormal interrupt summary
EMAC_DMA_INTERRUPT_NORMAL_SUMMARY | normal interrupt summary

Definition at line 511 of file at32f435_437_emac.h.

◆ emac_dma_operations_type

enum emac_dma_operations_type

dma operations type

Enumerator
EMAC_DMA_OPS_START_STOP_RECEIVE | start/stop receive
EMAC_DMA_OPS_SECOND_FRAME | operate on second frame
EMAC_DMA_OPS_FORWARD_UNDERSIZED | forward undersized good frames
EMAC_DMA_OPS_FORWARD_ERROR | forward error frames
EMAC_DMA_OPS_START_STOP_TRANSMIT | start/stop transmission
EMAC_DMA_OPS_FLUSH_TRANSMIT_FIFO | flush transmit fifo
EMAC_DMA_OPS_TRANSMIT_STORE_FORWARD | transmit store and forward
EMAC_DMA_OPS_RECEIVE_FLUSH_DISABLE | disable flushing of received frames
EMAC_DMA_OPS_RECEIVE_STORE_FORWARD | receive store and forward
EMAC_DMA_OPS_DROP_ERROR_DISABLE | disbale dropping of tcp/ip checksum error frames

Definition at line 468 of file at32f435_437_emac.h.

◆ emac_dma_pbl_type

enum emac_dma_pbl_type

programmable burst length

Enumerator
EMAC_DMA_PBL_1 | maximum 1 time of beats to be transferred in one dma transaction
EMAC_DMA_PBL_2 | maximum 2 times of beats to be transferred in one dma transaction
EMAC_DMA_PBL_4 | maximum 4 times of beats to be transferred in one dma transaction
EMAC_DMA_PBL_8 | maximum 8 times of beats to be transferred in one dma transaction
EMAC_DMA_PBL_16 | maximum 16 times of beats to be transferred in one dma transaction
EMAC_DMA_PBL_32 | maximum 32 times of beats to be transferred in one dma transaction

Definition at line 420 of file at32f435_437_emac.h.

◆ emac_dma_receive_process_status_type

enum emac_dma_receive_process_status_type

dma receive process status type

Enumerator
EMAC_DMA_RX_RESET_STOP_COMMAND | receive reset or stop command
EMAC_DMA_RX_FETCH_DESCRIPTOR | rx dma is fetching descriptor
EMAC_DMA_RX_WAITING_PACKET | rx dma is waiting for packets
EMAC_DMA_RX_DESCRIPTOR_UNAVAILABLE | rx dma descriptor is unavailable
EMAC_DMA_RX_CLOSE_DESCRIPTOR | rx dma is closing descriptor
EMAC_DMA_RX_FIFO_TO_HOST | rx dma is transferring data from fifo to host

Definition at line 442 of file at32f435_437_emac.h.

◆ emac_dma_receive_threshold_type

enum emac_dma_receive_threshold_type

receive threshold control type

Enumerator
EMAC_DMA_RX_THRESHOLD_64_BYTES | receive starts when the frame size within the receiv fifo is larger than 64 bytes
EMAC_DMA_RX_THRESHOLD_32_BYTES | receive starts when the frame size within the receiv fifo is larger than 32 bytes
EMAC_DMA_RX_THRESHOLD_96_BYTES | receive starts when the frame size within the receiv fifo is larger than 96 bytes
EMAC_DMA_RX_THRESHOLD_128_BYTES | receive starts when the frame size within the receiv fifo is larger than 128 bytes

Definition at line 485 of file at32f435_437_emac.h.

◆ emac_dma_rx_tx_ratio_type

enum emac_dma_rx_tx_ratio_type

rx tx priority ratio type

Enumerator
EMAC_DMA_1_RX_1_TX | rx/tx ratio is 1:1
EMAC_DMA_2_RX_1_TX | rx/tx ratio is 2:1
EMAC_DMA_3_RX_1_TX | rx/tx ratio is 3:1
EMAC_DMA_4_RX_1_TX | rx/tx ratio is 4:1

Definition at line 409 of file at32f435_437_emac.h.

◆ emac_dma_transfer_address_type

enum emac_dma_transfer_address_type

dma tansfer address type

Enumerator
EMAC_DMA_TX_DESCRIPTOR | transmit descriptor address
EMAC_DMA_RX_DESCRIPTOR | receive descriptor address
EMAC_DMA_TX_BUFFER | transmit buffer address
EMAC_DMA_RX_BUFFER | receive buffer address

Definition at line 533 of file at32f435_437_emac.h.

◆ emac_dma_transmit_process_status_type

enum emac_dma_transmit_process_status_type

dma transmit process status type

Enumerator
EMAC_DMA_TX_RESET_STOP_COMMAND | receive reset or stop command
EMAC_DMA_TX_FETCH_DESCRIPTOR | tx dma is fetching descriptor
EMAC_DMA_TX_WAITING_FOR_STATUS | tx dma is waiting for status message
EMAC_DMA_TX_HOST_TO_FIFO | tx dma is reading data from host and forward data to fifo
EMAC_DMA_TX_DESCRIPTOR_UNAVAILABLE | tx dma is unavailable or fifo underflow
EMAC_DMA_TX_CLOSE_DESCRIPTOR | tx dma is closing descriptor

Definition at line 455 of file at32f435_437_emac.h.

◆ emac_dma_transmit_threshold_type

enum emac_dma_transmit_threshold_type

transmit threshold control type

Enumerator
EMAC_DMA_TX_THRESHOLD_64_BYTES | transmission starts when the frame size within the transmit FIFO is larger than 64 bytes
EMAC_DMA_TX_THRESHOLD_128_BYTES | transmission starts when the frame size within the transmit FIFO is larger than 128 bytes
EMAC_DMA_TX_THRESHOLD_192_BYTES | transmission starts when the frame size within the transmit FIFO is larger than 192 bytes
EMAC_DMA_TX_THRESHOLD_256_BYTES | transmission starts when the frame size within the transmit FIFO is larger than 256 bytes
EMAC_DMA_TX_THRESHOLD_40_BYTES | transmission starts when the frame size within the transmit FIFO is larger than 40 bytes
EMAC_DMA_TX_THRESHOLD_32_BYTES | transmission starts when the frame size within the transmit FIFO is larger than 32 bytes
EMAC_DMA_TX_THRESHOLD_24_BYTES | transmission starts when the frame size within the transmit FIFO is larger than 24 bytes
EMAC_DMA_TX_THRESHOLD_16_BYTES | transmission starts when the frame size within the transmit FIFO is larger than 16 bytes

Definition at line 496 of file at32f435_437_emac.h.

◆ emac_dma_tx_rx_type

enum emac_dma_tx_rx_type

dma tx rx type

Enumerator
EMAC_DMA_TRANSMIT | transmit dma
EMAC_DMA_RECEIVE | receive dma

Definition at line 433 of file at32f435_437_emac.h.

◆ emac_duplex_type

enum emac_duplex_type

emac duplex type

Enumerator
EMAC_HALF_DUPLEX | half duplex
EMAC_FULL_DUPLEX | full duplex

Definition at line 301 of file at32f435_437_emac.h.

◆ emac_intergrame_gap_type

enum emac_intergrame_gap_type

emac interframe gap type

Enumerator
EMAC_INTERFRAME_GAP_96BIT | 96-bit numbers between two frames
EMAC_INTERFRAME_GAP_88BIT | 88-bit numbers between two frames
EMAC_INTERFRAME_GAP_80BIT | 80-bit numbers between two frames
EMAC_INTERFRAME_GAP_72BIT | 72-bit numbers between two frames
EMAC_INTERFRAME_GAP_64BIT | 64-bit numbers between two frames
EMAC_INTERFRAME_GAP_56BIT | 56-bit numbers between two frames
EMAC_INTERFRAME_GAP_48BIT | 48-bit numbers between two frames
EMAC_INTERFRAME_GAP_40BIT | 40-bit numbers between two frames

Definition at line 319 of file at32f435_437_emac.h.

◆ emac_interrupt_mask_type

enum emac_interrupt_mask_type

interrupt mask type

Enumerator
EMAC_INTERRUPT_PMT_MASK | mask pmt interrupt
EMAC_INTERRUPT_TST_MASK | mask tst interrupt

Definition at line 368 of file at32f435_437_emac.h.

◆ emac_pause_slot_threshold_type

enum emac_pause_slot_threshold_type

pause threshold type

Enumerator
EMAC_PAUSE_4_SLOT_TIME | pause time is 4 slot time
EMAC_PAUSE_28_SLOT_TIME | pause time is 28 slot time
EMAC_PAUSE_144_SLOT_TIME | pause time is 144 slot time
EMAC_PAUSE_256_SLOT_TIME | pause time is 256 slot time

Definition at line 357 of file at32f435_437_emac.h.

◆ emac_ptp_clock_node_type

enum emac_ptp_clock_node_type

clock node type

Enumerator
EMAC_PTP_NORMAL_CLOCK | normal clock node
EMAC_PTP_BOUNDARY_CLOCK | boundary clock node
EMAC_PTP_END_TO_END_CLOCK | end to end transparent clock node
EMAC_PTP_PEER_TO_PEER_CLOCK | peer to peer transparent clock node

Definition at line 544 of file at32f435_437_emac.h.

◆ emac_ptp_pps_control_type

enum emac_ptp_pps_control_type

pps control type

Enumerator
EMAC_PTP_PPS_1HZ | pps frequency is 1 hz
EMAC_PTP_PPS_2HZ | pps frequency is 2 hz
EMAC_PTP_PPS_4HZ | pps frequency is 4 hz
EMAC_PTP_PPS_8HZ | pps frequency is 8 hz
EMAC_PTP_PPS_16HZ | pps frequency is 16 hz
EMAC_PTP_PPS_32HZ | pps frequency is 32 hz
EMAC_PTP_PPS_64HZ | pps frequency is 64 hz
EMAC_PTP_PPS_128HZ | pps frequency is 128 hz
EMAC_PTP_PPS_256HZ | pps frequency is 256 hz
EMAC_PTP_PPS_512HZ | pps frequency is 512 hz
EMAC_PTP_PPS_1024HZ | pps frequency is 1024 hz
EMAC_PTP_PPS_2048HZ | pps frequency is 2048 hz
EMAC_PTP_PPS_4096HZ | pps frequency is 4096 hz
EMAC_PTP_PPS_8192HZ | pps frequency is 8192 hz
EMAC_PTP_PPS_16384HZ | pps frequency is 16384 hz
EMAC_PTP_PPS_32768HZ | pps frequency is 32768 hz

Definition at line 564 of file at32f435_437_emac.h.

◆ emac_ptp_timestamp_status_type

enum emac_ptp_timestamp_status_type

time stamp status type

Enumerator
EMAC_PTP_SECOND_OVERFLOW | time stamp second overflow
EMAC_PTP_TARGET_TIME_REACH | time stamp target time reached

Definition at line 555 of file at32f435_437_emac.h.

◆ emac_speed_type

enum emac_speed_type

emac speed type

Enumerator
EMAC_SPEED_10MBPS | 10 mbps
EMAC_SPEED_100MBPS | 100 mbps

Definition at line 310 of file at32f435_437_emac.h.


AT32F435/437 Firmwary Library: emac_control_config_type Struct Reference

Data Fields
emac_control_config_type Struct Reference
AT32F435_437_periph_driver » EMAC » EMAC_exported_types

ethernet mac control config type More...

#include <at32f435_437_emac.h>

Data Fields

emac_auto_negotiation_type auto_nego
confirm_state deferral_check
emac_bol_type back_off_limit
confirm_state auto_pad_crc_strip
confirm_state retry_disable
confirm_state ipv4_checksum_offload
emac_duplex_type duplex_mode
confirm_state loopback_mode
confirm_state receive_own_disable
emac_speed_type fast_ethernet_speed
confirm_state carrier_sense_disable
emac_intergrame_gap_type interframe_gap
confirm_state jabber_disable
confirm_state watchdog_disable

Detailed Description

ethernet mac control config type

Definition at line 587 of file at32f435_437_emac.h.

Field Documentation

◆ auto_nego

emac_auto_negotiation_type emac_control_config_type::auto_nego

auto negotiatin enable

Definition at line 589 of file at32f435_437_emac.h.

Referenced by emac_control_para_init(), emac_layer2_configuration(), emac_phy_init(), and ethernetif_update_config().

◆ auto_pad_crc_strip

confirm_state emac_control_config_type::auto_pad_crc_strip

automtic pad/crc stripping enable

Definition at line 592 of file at32f435_437_emac.h.

Referenced by emac_control_config(), and emac_control_para_init().

◆ back_off_limit

emac_bol_type emac_control_config_type::back_off_limit

back-off limit setting

Definition at line 591 of file at32f435_437_emac.h.

Referenced by emac_control_config(), and emac_control_para_init().

◆ carrier_sense_disable

confirm_state emac_control_config_type::carrier_sense_disable

carrier sense disable

Definition at line 599 of file at32f435_437_emac.h.

Referenced by emac_control_config(), and emac_control_para_init().

◆ deferral_check

confirm_state emac_control_config_type::deferral_check

deferral check enable

Definition at line 590 of file at32f435_437_emac.h.

Referenced by emac_control_config(), and emac_control_para_init().

◆ duplex_mode

emac_duplex_type emac_control_config_type::duplex_mode

duplex mode enable

Definition at line 595 of file at32f435_437_emac.h.

Referenced by emac_control_para_init(), emac_phy_init(), and ethernetif_update_config().

◆ fast_ethernet_speed

emac_speed_type emac_control_config_type::fast_ethernet_speed

fast ethernet speed enable

Definition at line 598 of file at32f435_437_emac.h.

Referenced by emac_control_para_init(), emac_phy_init(), and ethernetif_update_config().

◆ interframe_gap

emac_intergrame_gap_type emac_control_config_type::interframe_gap

set interframe gap

Definition at line 600 of file at32f435_437_emac.h.

Referenced by emac_control_config(), and emac_control_para_init().

◆ ipv4_checksum_offload

confirm_state emac_control_config_type::ipv4_checksum_offload

ipv4 checksum offload enable

Definition at line 594 of file at32f435_437_emac.h.

Referenced by emac_control_config(), and emac_control_para_init().

◆ jabber_disable

confirm_state emac_control_config_type::jabber_disable

jabber disbale

Definition at line 601 of file at32f435_437_emac.h.

Referenced by emac_control_config(), and emac_control_para_init().

◆ loopback_mode

confirm_state emac_control_config_type::loopback_mode

loopback mode enable

Definition at line 596 of file at32f435_437_emac.h.

Referenced by emac_control_config(), and emac_control_para_init().

◆ receive_own_disable

confirm_state emac_control_config_type::receive_own_disable

receive own disbale

Definition at line 597 of file at32f435_437_emac.h.

Referenced by emac_control_config(), and emac_control_para_init().

◆ retry_disable

confirm_state emac_control_config_type::retry_disable

retry disable

Definition at line 593 of file at32f435_437_emac.h.

Referenced by emac_control_config(), and emac_control_para_init().

◆ watchdog_disable

confirm_state emac_control_config_type::watchdog_disable

watchdog disable

Definition at line 602 of file at32f435_437_emac.h.

Referenced by emac_control_config(), and emac_control_para_init().

The documentation for this struct was generated from the following file:
  • at32f435_437_emac.h


AT32F435/437 Firmwary Library: emac_dma_config_type Struct Reference

Data Fields
emac_dma_config_type Struct Reference
AT32F435_437_periph_driver » EMAC » EMAC_exported_types

ethernet mac dma config type More...

#include <at32f435_437_emac.h>

Data Fields

confirm_state aab_enable
confirm_state usp_enable
emac_dma_pbl_type rx_dma_pal
confirm_state fb_enable
emac_dma_pbl_type tx_dma_pal
uint8_t desc_skip_length
confirm_state da_enable
emac_dma_rx_tx_ratio_type priority_ratio
confirm_state dt_disable
confirm_state rsf_enable
confirm_state flush_rx_disable
confirm_state tsf_enable
emac_dma_transmit_threshold_type tx_threshold
confirm_state fef_enable
confirm_state fugf_enable
emac_dma_receive_threshold_type rx_threshold
confirm_state osf_enable

Detailed Description

ethernet mac dma config type

Definition at line 608 of file at32f435_437_emac.h.

Field Documentation

◆ aab_enable

confirm_state emac_dma_config_type::aab_enable

address-aligned beats enable

Definition at line 610 of file at32f435_437_emac.h.

Referenced by emac_dma_config(), emac_dma_para_init(), and emac_layer2_configuration().

◆ da_enable

confirm_state emac_dma_config_type::da_enable

dma arbitration enable

Definition at line 616 of file at32f435_437_emac.h.

Referenced by emac_dma_config(), and emac_dma_para_init().

◆ desc_skip_length

uint8_t emac_dma_config_type::desc_skip_length

descriptor skip length

Definition at line 615 of file at32f435_437_emac.h.

Referenced by emac_dma_config(), and emac_dma_para_init().

◆ dt_disable

confirm_state emac_dma_config_type::dt_disable

disable dropping of tcp/ip checksum error frames

Definition at line 618 of file at32f435_437_emac.h.

Referenced by emac_dma_config(), and emac_dma_para_init().

◆ fb_enable

confirm_state emac_dma_config_type::fb_enable

separate PBL enable

Definition at line 613 of file at32f435_437_emac.h.

Referenced by emac_dma_config(), emac_dma_para_init(), and emac_layer2_configuration().

◆ fef_enable

confirm_state emac_dma_config_type::fef_enable

enable forward error frames

Definition at line 623 of file at32f435_437_emac.h.

Referenced by emac_dma_config(), and emac_dma_para_init().

◆ flush_rx_disable

confirm_state emac_dma_config_type::flush_rx_disable

disable flushing of received frames

Definition at line 620 of file at32f435_437_emac.h.

Referenced by emac_dma_config(), emac_dma_para_init(), and emac_layer2_configuration().

◆ fugf_enable

confirm_state emac_dma_config_type::fugf_enable

enable forward undersized good frames

Definition at line 624 of file at32f435_437_emac.h.

Referenced by emac_dma_config(), and emac_dma_para_init().

◆ osf_enable

confirm_state emac_dma_config_type::osf_enable

enable operating on second frames

Definition at line 626 of file at32f435_437_emac.h.

Referenced by emac_dma_config(), emac_dma_para_init(), and emac_layer2_configuration().

◆ priority_ratio

emac_dma_rx_tx_ratio_type emac_dma_config_type::priority_ratio

priority ratio

Definition at line 617 of file at32f435_437_emac.h.

Referenced by emac_dma_config(), emac_dma_para_init(), and emac_layer2_configuration().

◆ rsf_enable

confirm_state emac_dma_config_type::rsf_enable

enable receiving store or forward

Definition at line 619 of file at32f435_437_emac.h.

Referenced by emac_dma_config(), emac_dma_para_init(), and emac_layer2_configuration().

◆ rx_dma_pal

emac_dma_pbl_type emac_dma_config_type::rx_dma_pal

rx dma pbl

Definition at line 612 of file at32f435_437_emac.h.

Referenced by emac_dma_config(), emac_dma_para_init(), and emac_layer2_configuration().

◆ rx_threshold

emac_dma_receive_threshold_type emac_dma_config_type::rx_threshold

receive threshold control

Definition at line 625 of file at32f435_437_emac.h.

Referenced by emac_dma_config(), and emac_dma_para_init().

◆ tsf_enable

confirm_state emac_dma_config_type::tsf_enable

enable transmitting store or forward

Definition at line 621 of file at32f435_437_emac.h.

Referenced by emac_dma_config(), emac_dma_para_init(), and emac_layer2_configuration().

◆ tx_dma_pal

emac_dma_pbl_type emac_dma_config_type::tx_dma_pal

tx dma pbl

Definition at line 614 of file at32f435_437_emac.h.

Referenced by emac_dma_config(), emac_dma_para_init(), and emac_layer2_configuration().

◆ tx_threshold

emac_dma_transmit_threshold_type emac_dma_config_type::tx_threshold

transmit threshold control

Definition at line 622 of file at32f435_437_emac.h.

Referenced by emac_dma_config(), and emac_dma_para_init().

◆ usp_enable

confirm_state emac_dma_config_type::usp_enable

separate PBL enable

Definition at line 611 of file at32f435_437_emac.h.

Referenced by emac_dma_config(), emac_dma_para_init(), and emac_layer2_configuration().

The documentation for this struct was generated from the following file:
  • at32f435_437_emac.h


AT32F435/437 Firmwary Library: emac_dma_desc_type Struct Reference

Data Fields
emac_dma_desc_type Struct Reference
AT32F435_437_periph_driver » EMAC » EMAC_exported_types

dma desciptors data structure definition More...

#include <at32f435_437_emac.h>

Data Fields

uint32_t | status
uint32_t | controlsize
uint32_t | buf1addr
uint32_t | buf2nextdescaddr

Detailed Description

dma desciptors data structure definition

Definition at line 632 of file at32f435_437_emac.h.

Field Documentation

◆ buf1addr

uint32_t emac_dma_desc_type::buf1addr

buffer1 address pointer

Definition at line 635 of file at32f435_437_emac.h.

Referenced by emac_dma_descriptor_list_address_set().

◆ buf2nextdescaddr

uint32_t emac_dma_desc_type::buf2nextdescaddr

buffer2 or next descriptor address pointer

Definition at line 636 of file at32f435_437_emac.h.

Referenced by emac_dma_descriptor_list_address_set().

◆ controlsize

uint32_t emac_dma_desc_type::controlsize

control and buffer1, buffer2 lengths

Definition at line 634 of file at32f435_437_emac.h.

Referenced by emac_dma_descriptor_list_address_set(), and emac_dma_rx_desc_interrupt_config().

◆ status

uint32_t emac_dma_desc_type::status

status

Definition at line 633 of file at32f435_437_emac.h.

Referenced by emac_dma_descriptor_list_address_set(), emac_dmarxdesc_frame_length_get(), and emac_received_packet_size_get().

The documentation for this struct was generated from the following file:
  • at32f435_437_emac.h


AT32F435/437 Firmwary Library: emac_type Struct Reference

Data Fields
emac_type Struct Reference
AT32F435_437_periph_driver » EMAC » EMAC_exported_types

type define emac mac register all More...

#include <at32f435_437_emac.h>

Data Fields

union {
__IO uint32_t ctrl
struct {
__IO uint32_t reserved1: 2
__IO uint32_t re: 1
__IO uint32_t te: 1
__IO uint32_t dc: 1
__IO uint32_t bl: 2
__IO uint32_t acs: 1
__IO uint32_t reserved2: 1
__IO uint32_t dr: 1
__IO uint32_t ipc: 1
__IO uint32_t dm: 1
__IO uint32_t lm: 1
__IO uint32_t dro: 1
__IO uint32_t fes: 1
__IO uint32_t reserved3: 1
__IO uint32_t dcs: 1
__IO uint32_t ifg: 3
__IO uint32_t reserved4: 2
__IO uint32_t jd: 1
__IO uint32_t wd: 1
__IO uint32_t reserved5: 8
} ctrl_bit
};
emac mac ctrl register, offset:0x00 More...
union {
__IO uint32_t frmf
struct {
__IO uint32_t pr: 1
__IO uint32_t huc: 1
__IO uint32_t hmc: 1
__IO uint32_t daif: 1
__IO uint32_t pmc: 1
__IO uint32_t dbf: 1
__IO uint32_t pcf: 2
__IO uint32_t saif: 1
__IO uint32_t saf: 1
__IO uint32_t hpf: 1
__IO uint32_t reserved1: 20
__IO uint32_t ra: 1
} frmf_bit
};
emac mac frmf register, offset:0x04 More...
union {
__IO uint32_t hth
struct {
__IO uint32_t hth: 32
} hth_bit
};
emac mac hth register, offset:0x08 More...
union {
__IO uint32_t htl
struct {
__IO uint32_t htl: 32
} htl_bit
};
emac mac htl register, offset:0x0c More...
union {
__IO uint32_t miiaddr
struct {
__IO uint32_t mb: 1
__IO uint32_t mw: 1
__IO uint32_t cr: 4
__IO uint32_t mii: 5
__IO uint32_t pa: 5
__IO uint32_t reserved1: 16
} miiaddr_bit
};
emac mac miiaddr register, offset:0x10 More...
union {
__IO uint32_t miidt
struct {
__IO uint32_t md: 16
__IO uint32_t reserved1: 16
} miidt_bit
};
emac mac miidt register, offset:0x14 More...
union {
__IO uint32_t fctrl
struct {
__IO uint32_t fcbbpa: 1
__IO uint32_t etf: 1
__IO uint32_t erf: 1
__IO uint32_t dup: 1
__IO uint32_t plt: 2
__IO uint32_t reserved1: 1
__IO uint32_t dzqp: 1
__IO uint32_t reserved2: 8
__IO uint32_t pt: 16
} fctrl_bit
};
emac mac fctrl register, offset:0x18 More...
union {
__IO uint32_t vlt
struct {
__IO uint32_t vti: 16
__IO uint32_t etv: 1
__IO uint32_t reserved1: 15
} vlt_bit
};
emac mac vlt register, offset:0x1C More...
__IO uint32_t rwff
emac mac rwff register, offset:0x28 More...
union {
__IO uint32_t pmtctrlsts
struct {
__IO uint32_t pd: 1
__IO uint32_t emp: 1
__IO uint32_t erwf: 1
__IO uint32_t reserved1: 2
__IO uint32_t rmp: 1
__IO uint32_t rrwf: 1
__IO uint32_t reserved2: 2
__IO uint32_t guc: 1
__IO uint32_t reserved3: 21
__IO uint32_t rwffpr: 1
} pmtctrlsts_bit
};
emac mac pmtctrlsts register, offset:0x2C More...
union {
__IO uint32_t ists
struct {
__IO uint32_t reserved1: 3
__IO uint32_t pis: 1
__IO uint32_t mis: 1
__IO uint32_t mris: 1
__IO uint32_t mtis: 1
__IO uint32_t reserved2: 2
__IO uint32_t tis: 1
__IO uint32_t reserved3: 22
} ists_bit
};
emac mac ists register, offset:0x38 More...
union {
__IO uint32_t imr
struct {
__IO uint32_t reserved1: 3
__IO uint32_t pim: 1
__IO uint32_t reserved2: 5
__IO uint32_t tim: 1
__IO uint32_t reserved3: 22
} imr_bit
};
emac mac imr register, offset:0x3C More...
union {
__IO uint32_t a0h
struct {
__IO uint32_t ma0h: 16
__IO uint32_t reserved1: 15
__IO uint32_t ae: 1
} a0h_bit
};
emac mac a0h register, offset:0x40 More...
union {
__IO uint32_t a0l
struct {
__IO uint32_t ma0l: 32
} a0l_bit
};
emac mac a0l register, offset:0x44 More...
union {
__IO uint32_t a1h
struct {
__IO uint32_t ma1h: 16
__IO uint32_t reserved1: 8
__IO uint32_t mbc: 6
__IO uint32_t sa: 1
__IO uint32_t ae: 1
} a1h_bit
};
emac mac a1h register, offset:0x48 More...
union {
__IO uint32_t a1l
struct {
__IO uint32_t ma1l: 32
} a1l_bit
};
emac mac a1l register, offset:0x4C More...
union {
__IO uint32_t a2h
struct {
__IO uint32_t ma2h: 16
__IO uint32_t reserved1: 8
__IO uint32_t mbc: 6
__IO uint32_t sa: 1
__IO uint32_t ae: 1
} a2h_bit
};
emac mac a2h register, offset:0x50 More...
union {
__IO uint32_t a2l
struct {
__IO uint32_t ma2l: 32
} a2l_bit
};
emac mac a2l register, offset:0x54 More...
union {
__IO uint32_t a3h
struct {
__IO uint32_t ma3h: 16
__IO uint32_t reserved1: 8
__IO uint32_t mbc: 6
__IO uint32_t sa: 1
__IO uint32_t ae: 1
} a3h_bit
};
emac mac a3h register, offset:0x58 More...
union {
__IO uint32_t a3l
struct {
__IO uint32_t ma3l: 32
} a3l_bit
};
emac mac a3l register, offset:0x5C More...

Detailed Description

type define emac mac register all

Definition at line 642 of file at32f435_437_emac.h.

Field Documentation

◆

union { ... } emac_type::@445

emac mac ctrl register, offset:0x00

◆

union { ... } emac_type::@447

emac mac frmf register, offset:0x04

◆

union { ... } emac_type::@449

emac mac hth register, offset:0x08

◆

union { ... } emac_type::@451

emac mac htl register, offset:0x0c

◆

union { ... } emac_type::@453

emac mac miiaddr register, offset:0x10

◆

union { ... } emac_type::@455

emac mac miidt register, offset:0x14

◆

union { ... } emac_type::@457

emac mac fctrl register, offset:0x18

◆

union { ... } emac_type::@459

emac mac vlt register, offset:0x1C

◆

union { ... } emac_type::@461

emac mac pmtctrlsts register, offset:0x2C

◆

union { ... } emac_type::@463

emac mac ists register, offset:0x38

◆

union { ... } emac_type::@465

emac mac imr register, offset:0x3C

◆

union { ... } emac_type::@467

emac mac a0h register, offset:0x40

◆

union { ... } emac_type::@469

emac mac a0l register, offset:0x44

◆

union { ... } emac_type::@471

emac mac a1h register, offset:0x48

◆

union { ... } emac_type::@473

emac mac a1l register, offset:0x4C

◆

union { ... } emac_type::@475

emac mac a2h register, offset:0x50

◆

union { ... } emac_type::@477

emac mac a2l register, offset:0x54

◆

union { ... } emac_type::@479

emac mac a3h register, offset:0x58

◆

union { ... } emac_type::@481

emac mac a3l register, offset:0x5C

◆ a0h

__IO uint32_t emac_type::a0h

Definition at line 862 of file at32f435_437_emac.h.

◆

struct { ... } emac_type::a0h_bit

◆ a0l

__IO uint32_t emac_type::a0l

Definition at line 876 of file at32f435_437_emac.h.

◆

struct { ... } emac_type::a0l_bit

◆ a1h

__IO uint32_t emac_type::a1h

Definition at line 888 of file at32f435_437_emac.h.

◆

struct { ... } emac_type::a1h_bit

◆ a1l

__IO uint32_t emac_type::a1l

Definition at line 904 of file at32f435_437_emac.h.

◆

struct { ... } emac_type::a1l_bit

◆ a2h

__IO uint32_t emac_type::a2h

Definition at line 916 of file at32f435_437_emac.h.

◆

struct { ... } emac_type::a2h_bit

◆ a2l

__IO uint32_t emac_type::a2l

Definition at line 932 of file at32f435_437_emac.h.

◆

struct { ... } emac_type::a2l_bit

◆ a3h

__IO uint32_t emac_type::a3h

Definition at line 944 of file at32f435_437_emac.h.

◆

struct { ... } emac_type::a3h_bit

◆ a3l

__IO uint32_t emac_type::a3l

Definition at line 960 of file at32f435_437_emac.h.

◆

struct { ... } emac_type::a3l_bit

◆ acs

__IO uint32_t emac_type::acs

Definition at line 657 of file at32f435_437_emac.h.

◆ ae

__IO uint32_t emac_type::ae

Definition at line 867 of file at32f435_437_emac.h.

◆ bl

__IO uint32_t emac_type::bl

Definition at line 656 of file at32f435_437_emac.h.

◆ cr

__IO uint32_t emac_type::cr

Definition at line 732 of file at32f435_437_emac.h.

◆ ctrl

__IO uint32_t emac_type::ctrl

Definition at line 649 of file at32f435_437_emac.h.

◆

struct { ... } emac_type::ctrl_bit

◆ daif

__IO uint32_t emac_type::daif

Definition at line 686 of file at32f435_437_emac.h.

◆ dbf

__IO uint32_t emac_type::dbf

Definition at line 688 of file at32f435_437_emac.h.

◆ dc

__IO uint32_t emac_type::dc

Definition at line 655 of file at32f435_437_emac.h.

◆ dcs

__IO uint32_t emac_type::dcs

Definition at line 666 of file at32f435_437_emac.h.

◆ dm

__IO uint32_t emac_type::dm

Definition at line 661 of file at32f435_437_emac.h.

◆ dr

__IO uint32_t emac_type::dr

Definition at line 659 of file at32f435_437_emac.h.

◆ dro

__IO uint32_t emac_type::dro

Definition at line 663 of file at32f435_437_emac.h.

◆ dup

__IO uint32_t emac_type::dup

Definition at line 763 of file at32f435_437_emac.h.

◆ dzqp

__IO uint32_t emac_type::dzqp

Definition at line 766 of file at32f435_437_emac.h.

◆ emp

__IO uint32_t emac_type::emp

Definition at line 805 of file at32f435_437_emac.h.

◆ erf

__IO uint32_t emac_type::erf

Definition at line 762 of file at32f435_437_emac.h.

◆ erwf

__IO uint32_t emac_type::erwf

Definition at line 806 of file at32f435_437_emac.h.

◆ etf

__IO uint32_t emac_type::etf

Definition at line 761 of file at32f435_437_emac.h.

◆ etv

__IO uint32_t emac_type::etv

Definition at line 781 of file at32f435_437_emac.h.

◆ fcbbpa

__IO uint32_t emac_type::fcbbpa

Definition at line 760 of file at32f435_437_emac.h.

◆ fctrl

__IO uint32_t emac_type::fctrl

Definition at line 757 of file at32f435_437_emac.h.

◆

struct { ... } emac_type::fctrl_bit

◆ fes

__IO uint32_t emac_type::fes

Definition at line 664 of file at32f435_437_emac.h.

◆ frmf

__IO uint32_t emac_type::frmf

Definition at line 680 of file at32f435_437_emac.h.

◆

struct { ... } emac_type::frmf_bit

◆ guc

__IO uint32_t emac_type::guc

Definition at line 811 of file at32f435_437_emac.h.

◆ hmc

__IO uint32_t emac_type::hmc

Definition at line 685 of file at32f435_437_emac.h.

◆ hpf

__IO uint32_t emac_type::hpf

Definition at line 692 of file at32f435_437_emac.h.

◆ hth

__IO uint32_t emac_type::hth

Definition at line 703 of file at32f435_437_emac.h.

◆

struct { ... } emac_type::hth_bit

◆ htl

__IO uint32_t emac_type::htl

Definition at line 715 of file at32f435_437_emac.h.

◆

struct { ... } emac_type::htl_bit

◆ huc

__IO uint32_t emac_type::huc

Definition at line 684 of file at32f435_437_emac.h.

◆ ifg

__IO uint32_t emac_type::ifg

Definition at line 667 of file at32f435_437_emac.h.

◆ imr

__IO uint32_t emac_type::imr

Definition at line 846 of file at32f435_437_emac.h.

◆

struct { ... } emac_type::imr_bit

◆ ipc

__IO uint32_t emac_type::ipc

Definition at line 660 of file at32f435_437_emac.h.

◆ ists

__IO uint32_t emac_type::ists

Definition at line 827 of file at32f435_437_emac.h.

◆

struct { ... } emac_type::ists_bit

◆ jd

__IO uint32_t emac_type::jd

Definition at line 669 of file at32f435_437_emac.h.

◆ lm

__IO uint32_t emac_type::lm

Definition at line 662 of file at32f435_437_emac.h.

◆ ma0h

__IO uint32_t emac_type::ma0h

Definition at line 865 of file at32f435_437_emac.h.

◆ ma0l

__IO uint32_t emac_type::ma0l

Definition at line 879 of file at32f435_437_emac.h.

◆ ma1h

__IO uint32_t emac_type::ma1h

Definition at line 891 of file at32f435_437_emac.h.

◆ ma1l

__IO uint32_t emac_type::ma1l

Definition at line 907 of file at32f435_437_emac.h.

◆ ma2h

__IO uint32_t emac_type::ma2h

Definition at line 919 of file at32f435_437_emac.h.

◆ ma2l

__IO uint32_t emac_type::ma2l

Definition at line 935 of file at32f435_437_emac.h.

◆ ma3h

__IO uint32_t emac_type::ma3h

Definition at line 947 of file at32f435_437_emac.h.

◆ ma3l

__IO uint32_t emac_type::ma3l

Definition at line 963 of file at32f435_437_emac.h.

◆ mb

__IO uint32_t emac_type::mb

Definition at line 730 of file at32f435_437_emac.h.

◆ mbc

__IO uint32_t emac_type::mbc

Definition at line 893 of file at32f435_437_emac.h.

◆ md

__IO uint32_t emac_type::md

Definition at line 747 of file at32f435_437_emac.h.

◆ mii

__IO uint32_t emac_type::mii

Definition at line 733 of file at32f435_437_emac.h.

◆ miiaddr

__IO uint32_t emac_type::miiaddr

Definition at line 727 of file at32f435_437_emac.h.

◆

struct { ... } emac_type::miiaddr_bit

◆ miidt

__IO uint32_t emac_type::miidt

Definition at line 744 of file at32f435_437_emac.h.

◆

struct { ... } emac_type::miidt_bit

◆ mis

__IO uint32_t emac_type::mis

Definition at line 832 of file at32f435_437_emac.h.

◆ mris

__IO uint32_t emac_type::mris

Definition at line 833 of file at32f435_437_emac.h.

◆ mtis

__IO uint32_t emac_type::mtis

Definition at line 834 of file at32f435_437_emac.h.

◆ mw

__IO uint32_t emac_type::mw

Definition at line 731 of file at32f435_437_emac.h.

◆ pa

__IO uint32_t emac_type::pa

Definition at line 734 of file at32f435_437_emac.h.

◆ pcf

__IO uint32_t emac_type::pcf

Definition at line 689 of file at32f435_437_emac.h.

◆ pd

__IO uint32_t emac_type::pd

Definition at line 804 of file at32f435_437_emac.h.

◆ pim

__IO uint32_t emac_type::pim

Definition at line 850 of file at32f435_437_emac.h.

◆ pis

__IO uint32_t emac_type::pis

Definition at line 831 of file at32f435_437_emac.h.

◆ plt

__IO uint32_t emac_type::plt

Definition at line 764 of file at32f435_437_emac.h.

◆ pmc

__IO uint32_t emac_type::pmc

Definition at line 687 of file at32f435_437_emac.h.

◆ pmtctrlsts

__IO uint32_t emac_type::pmtctrlsts

Definition at line 801 of file at32f435_437_emac.h.

◆

struct { ... } emac_type::pmtctrlsts_bit

◆ pr

__IO uint32_t emac_type::pr

Definition at line 683 of file at32f435_437_emac.h.

◆ pt

__IO uint32_t emac_type::pt

Definition at line 768 of file at32f435_437_emac.h.

◆ ra

__IO uint32_t emac_type::ra

Definition at line 694 of file at32f435_437_emac.h.

◆ re

__IO uint32_t emac_type::re

Definition at line 653 of file at32f435_437_emac.h.

◆ reserved1

__IO uint32_t emac_type::reserved1

emac mac reserved1 register, offset:0x20~0x24

Definition at line 652 of file at32f435_437_emac.h.

◆ reserved2

__IO uint32_t emac_type::reserved2

emac mac reserved2 register, offset:0x30~0x34

Definition at line 658 of file at32f435_437_emac.h.

◆ reserved3

__IO uint32_t emac_type::reserved3

Definition at line 665 of file at32f435_437_emac.h.

◆ reserved4

__IO uint32_t emac_type::reserved4

Definition at line 668 of file at32f435_437_emac.h.

◆ reserved5

__IO uint32_t emac_type::reserved5

Definition at line 671 of file at32f435_437_emac.h.

◆ rmp

__IO uint32_t emac_type::rmp

Definition at line 808 of file at32f435_437_emac.h.

◆ rrwf

__IO uint32_t emac_type::rrwf

Definition at line 809 of file at32f435_437_emac.h.

◆ rwff

__IO uint32_t emac_type::rwff

emac mac rwff register, offset:0x28

Definition at line 794 of file at32f435_437_emac.h.

◆ rwffpr

__IO uint32_t emac_type::rwffpr

Definition at line 813 of file at32f435_437_emac.h.

◆ sa

__IO uint32_t emac_type::sa

Definition at line 894 of file at32f435_437_emac.h.

◆ saf

__IO uint32_t emac_type::saf

Definition at line 691 of file at32f435_437_emac.h.

◆ saif

__IO uint32_t emac_type::saif

Definition at line 690 of file at32f435_437_emac.h.

◆ te

__IO uint32_t emac_type::te

Definition at line 654 of file at32f435_437_emac.h.

◆ tim

__IO uint32_t emac_type::tim

Definition at line 852 of file at32f435_437_emac.h.

◆ tis

__IO uint32_t emac_type::tis

Definition at line 836 of file at32f435_437_emac.h.

◆ vlt

__IO uint32_t emac_type::vlt

Definition at line 777 of file at32f435_437_emac.h.

◆

struct { ... } emac_type::vlt_bit

◆ vti

__IO uint32_t emac_type::vti

Definition at line 780 of file at32f435_437_emac.h.

◆ wd

__IO uint32_t emac_type::wd

Definition at line 670 of file at32f435_437_emac.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_emac.h


AT32F435/437 Firmwary Library: emac_mmc_type Struct Reference

Data Fields
emac_mmc_type Struct Reference
AT32F435_437_periph_driver » EMAC » EMAC_exported_types

type define emac mmc register all More...

#include <at32f435_437_emac.h>

Data Fields

union {
__IO uint32_t ctrl
struct {
__IO uint32_t rc: 1
__IO uint32_t scr: 1
__IO uint32_t rr: 1
__IO uint32_t fmc: 1
__IO uint32_t reserved1: 28
} ctrl_bit
};
emac mmc ctrl register, offset:0x0100 More...
union {
__IO uint32_t ri
struct {
__IO uint32_t reserved1: 5
__IO uint32_t rfce: 1
__IO uint32_t rfae: 1
__IO uint32_t reserved2: 10
__IO uint32_t rguf: 1
__IO uint32_t reserved3: 14
} ri_bit
};
emac mmc ri register, offset:0x0104 More...
union {
__IO uint32_t ti
struct {
__IO uint32_t reserved1: 14
__IO uint32_t tscgfci: 1
__IO uint32_t tgfmsc: 1
__IO uint32_t reserved2: 5
__IO uint32_t tgf: 1
__IO uint32_t reserved3: 10
} ti_bit
};
emac mmc ti register, offset:0x0108 More...
union {
__IO uint32_t rim
struct {
__IO uint32_t reserved1: 5
__IO uint32_t rcefcim: 1
__IO uint32_t raefacim: 1
__IO uint32_t reserved2: 10
__IO uint32_t rugfcim: 1
__IO uint32_t reserved3: 14
} rim_bit
};
emac mmc rim register, offset:0x010C More...
union {
__IO uint32_t tim
struct {
__IO uint32_t reserved1: 14
__IO uint32_t tscgfcim: 1
__IO uint32_t tmcgfcim: 1
__IO uint32_t reserved2: 5
__IO uint32_t tgfcim: 1
__IO uint32_t reserved3: 10
} tim_bit
};
emac mmc tim register, offset:0x0110 More...
union {
__IO uint32_t tfscc
struct {
__IO uint32_t tgfscc: 32
} tfscc_bit
};
emac mmc tfscc register, offset:0x014C More...
union {
__IO uint32_t tfmscc
struct {
__IO uint32_t tgfmscc: 32
} tfmscc_bit
};
emac mmc tfmscc register, offset:0x0150 More...
union {
__IO uint32_t tfcnt
struct {
__IO uint32_t tgfc: 32
} tfcnt_bit
};
emac mmc tfcnt register, offset:0x0168 More...
union {
__IO uint32_t rfcecnt
struct {
__IO uint32_t rfcec: 32
} rfcecnt_bit
};
emac mmc rfcecnt register, offset:0x0194 More...
union {
__IO uint32_t rfaecnt
struct {
__IO uint32_t rfaec: 32
} rfaecnt_bit
};
emac mmc rfaecnt register, offset:0x0198 More...
__IO uint32_t reserved4 [10]
emac mmc reserved4 register, offset:0x019C~0x01C0 More...
union {
__IO uint32_t rgufcnt
struct {
__IO uint32_t rgufc: 32
} rgufcnt_bit
};
emac mmc rgufcnt register, offset:0x01C4 More...

Detailed Description

type define emac mmc register all

Definition at line 971 of file at32f435_437_emac.h.

Field Documentation

◆

union { ... } emac_mmc_type::@502

emac mmc ctrl register, offset:0x0100

◆

union { ... } emac_mmc_type::@504

emac mmc ri register, offset:0x0104

◆

union { ... } emac_mmc_type::@506

emac mmc ti register, offset:0x0108

◆

union { ... } emac_mmc_type::@508

emac mmc rim register, offset:0x010C

◆

union { ... } emac_mmc_type::@510

emac mmc tim register, offset:0x0110

◆

union { ... } emac_mmc_type::@512

emac mmc tfscc register, offset:0x014C

◆

union { ... } emac_mmc_type::@514

emac mmc tfmscc register, offset:0x0150

◆

union { ... } emac_mmc_type::@516

emac mmc tfcnt register, offset:0x0168

◆

union { ... } emac_mmc_type::@518

emac mmc rfcecnt register, offset:0x0194

◆

union { ... } emac_mmc_type::@520

emac mmc rfaecnt register, offset:0x0198

◆

union { ... } emac_mmc_type::@522

emac mmc rgufcnt register, offset:0x01C4

◆ ctrl

__IO uint32_t emac_mmc_type::ctrl

Definition at line 978 of file at32f435_437_emac.h.

◆

struct { ... } emac_mmc_type::ctrl_bit

◆ fmc

__IO uint32_t emac_mmc_type::fmc

Definition at line 984 of file at32f435_437_emac.h.

◆ raefacim

__IO uint32_t emac_mmc_type::raefacim

Definition at line 1033 of file at32f435_437_emac.h.

◆ rc

__IO uint32_t emac_mmc_type::rc

Definition at line 981 of file at32f435_437_emac.h.

◆ rcefcim

__IO uint32_t emac_mmc_type::rcefcim

Definition at line 1032 of file at32f435_437_emac.h.

◆ reserved1

__IO uint32_t emac_mmc_type::reserved1

emac mmc reserved1 register, offset:0x0114~0x0148

Definition at line 985 of file at32f435_437_emac.h.

◆ reserved2

__IO uint32_t emac_mmc_type::reserved2

emac mmc reserved2 register, offset:0x0154~0x0164

Definition at line 1000 of file at32f435_437_emac.h.

◆ reserved3

__IO uint32_t emac_mmc_type::reserved3

emac mmc reserved3 register, offset:0x016C~0x0190

Definition at line 1002 of file at32f435_437_emac.h.

◆ reserved4

__IO uint32_t emac_mmc_type::reserved4[10]

emac mmc reserved4 register, offset:0x019C~0x01C0

Definition at line 1135 of file at32f435_437_emac.h.

◆ rfae

__IO uint32_t emac_mmc_type::rfae

Definition at line 999 of file at32f435_437_emac.h.

◆ rfaec

__IO uint32_t emac_mmc_type::rfaec

Definition at line 1128 of file at32f435_437_emac.h.

◆ rfaecnt

__IO uint32_t emac_mmc_type::rfaecnt

Definition at line 1125 of file at32f435_437_emac.h.

◆

struct { ... } emac_mmc_type::rfaecnt_bit

◆ rfce

__IO uint32_t emac_mmc_type::rfce

Definition at line 998 of file at32f435_437_emac.h.

◆ rfcec

__IO uint32_t emac_mmc_type::rfcec

Definition at line 1116 of file at32f435_437_emac.h.

◆ rfcecnt

__IO uint32_t emac_mmc_type::rfcecnt

Definition at line 1113 of file at32f435_437_emac.h.

◆

struct { ... } emac_mmc_type::rfcecnt_bit

◆ rguf

__IO uint32_t emac_mmc_type::rguf

Definition at line 1001 of file at32f435_437_emac.h.

◆ rgufc

__IO uint32_t emac_mmc_type::rgufc

Definition at line 1145 of file at32f435_437_emac.h.

◆ rgufcnt

__IO uint32_t emac_mmc_type::rgufcnt

Definition at line 1142 of file at32f435_437_emac.h.

◆

struct { ... } emac_mmc_type::rgufcnt_bit

◆ ri

__IO uint32_t emac_mmc_type::ri

Definition at line 994 of file at32f435_437_emac.h.

◆

struct { ... } emac_mmc_type::ri_bit

◆ rim

__IO uint32_t emac_mmc_type::rim

Definition at line 1028 of file at32f435_437_emac.h.

◆

struct { ... } emac_mmc_type::rim_bit

◆ rr

__IO uint32_t emac_mmc_type::rr

Definition at line 983 of file at32f435_437_emac.h.

◆ rugfcim

__IO uint32_t emac_mmc_type::rugfcim

Definition at line 1035 of file at32f435_437_emac.h.

◆ scr

__IO uint32_t emac_mmc_type::scr

Definition at line 982 of file at32f435_437_emac.h.

◆ tfcnt

__IO uint32_t emac_mmc_type::tfcnt

Definition at line 1096 of file at32f435_437_emac.h.

◆

struct { ... } emac_mmc_type::tfcnt_bit

◆ tfmscc

__IO uint32_t emac_mmc_type::tfmscc

Definition at line 1079 of file at32f435_437_emac.h.

◆

struct { ... } emac_mmc_type::tfmscc_bit

◆ tfscc

__IO uint32_t emac_mmc_type::tfscc

Definition at line 1067 of file at32f435_437_emac.h.

◆

struct { ... } emac_mmc_type::tfscc_bit

◆ tgf

__IO uint32_t emac_mmc_type::tgf

Definition at line 1018 of file at32f435_437_emac.h.

◆ tgfc

__IO uint32_t emac_mmc_type::tgfc

Definition at line 1099 of file at32f435_437_emac.h.

◆ tgfcim

__IO uint32_t emac_mmc_type::tgfcim

Definition at line 1052 of file at32f435_437_emac.h.

◆ tgfmsc

__IO uint32_t emac_mmc_type::tgfmsc

Definition at line 1016 of file at32f435_437_emac.h.

◆ tgfmscc

__IO uint32_t emac_mmc_type::tgfmscc

Definition at line 1082 of file at32f435_437_emac.h.

◆ tgfscc

__IO uint32_t emac_mmc_type::tgfscc

Definition at line 1070 of file at32f435_437_emac.h.

◆ ti

__IO uint32_t emac_mmc_type::ti

Definition at line 1011 of file at32f435_437_emac.h.

◆

struct { ... } emac_mmc_type::ti_bit

◆ tim

__IO uint32_t emac_mmc_type::tim

Definition at line 1045 of file at32f435_437_emac.h.

◆

struct { ... } emac_mmc_type::tim_bit

◆ tmcgfcim

__IO uint32_t emac_mmc_type::tmcgfcim

Definition at line 1050 of file at32f435_437_emac.h.

◆ tscgfci

__IO uint32_t emac_mmc_type::tscgfci

Definition at line 1015 of file at32f435_437_emac.h.

◆ tscgfcim

__IO uint32_t emac_mmc_type::tscgfcim

Definition at line 1049 of file at32f435_437_emac.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_emac.h


AT32F435/437 Firmwary Library: emac_ptp_type Struct Reference

Data Fields
emac_ptp_type Struct Reference
AT32F435_437_periph_driver » EMAC » EMAC_exported_types

type define emac ptp register all More...

#include <at32f435_437_emac.h>

Data Fields

union {
__IO uint32_t tsctrl
struct {
__IO uint32_t te: 1
__IO uint32_t tfcu: 1
__IO uint32_t ti: 1
__IO uint32_t tu: 1
__IO uint32_t tite: 1
__IO uint32_t aru: 1
__IO uint32_t reserved1: 2
__IO uint32_t etaf: 1
__IO uint32_t tdbrc: 1
__IO uint32_t eppv2f: 1
__IO uint32_t eppef: 1
__IO uint32_t eppfsip6u: 1
__IO uint32_t eppfsip4u: 1
__IO uint32_t etsfem: 1
__IO uint32_t esfmrtm: 1
__IO uint32_t sppfts: 2
__IO uint32_t emafpff: 1
__IO uint32_t reserved2: 13
} tsctrl_bit
};
emac ptp tsctrl register, offset:0x0700 More...
union {
__IO uint32_t ssinc
struct {
__IO uint32_t ssiv: 8
__IO uint32_t reserved1: 24
} ssinc_bit
};
emac ptp ssinc register, offset:0x0704 More...
union {
__IO uint32_t tsh
struct {
__IO uint32_t ts: 32
} tsh_bit
};
emac ptp tsh register, offset:0x0708 More...
union {
__IO uint32_t tsl
struct {
__IO uint32_t tss: 31
__IO uint32_t ast: 1
} tsl_bit
};
emac ptp tsl register, offset:0x070C More...
union {
__IO uint32_t tshud
struct {
__IO uint32_t ts: 32
} tshud_bit
};
emac ptp tshud register, offset:0x0710 More...
union {
__IO uint32_t tslud
struct {
__IO uint32_t tss: 31
__IO uint32_t ast: 1
} tslud_bit
};
emac ptp tslud register, offset:0x0714 More...
union {
__IO uint32_t tsad
struct {
__IO uint32_t tar: 32
} tsad_bit
};
emac ptp tsad register, offset:0x0718 More...
union {
__IO uint32_t tth
struct {
__IO uint32_t ttsr: 32
} tth_bit
};
emac ptp tth register, offset:0x071C More...
union {
__IO uint32_t ttl
struct {
__IO uint32_t ttlr: 32
} ttl_bit
};
emac ptp ttl register, offset:0x0720 More...
union {
__IO uint32_t tssr
struct {
__IO uint32_t tso: 1
__IO uint32_t tttr: 1
__IO uint32_t reserved1: 30
} tssr_bit
};
emac ptp tssr register, offset:0x0728 More...
union {
__IO uint32_t ppscr
struct {
__IO uint32_t pofc: 4
__IO uint32_t reserved1: 28
} ppscr_bit
};
emac ptp ppscr register, offset:0x072C More...

Detailed Description

type define emac ptp register all

Definition at line 1153 of file at32f435_437_emac.h.

Field Documentation

◆

union { ... } emac_ptp_type::@535

emac ptp tsctrl register, offset:0x0700

◆

union { ... } emac_ptp_type::@537

emac ptp ssinc register, offset:0x0704

◆

union { ... } emac_ptp_type::@539

emac ptp tsh register, offset:0x0708

◆

union { ... } emac_ptp_type::@541

emac ptp tsl register, offset:0x070C

◆

union { ... } emac_ptp_type::@543

emac ptp tshud register, offset:0x0710

◆

union { ... } emac_ptp_type::@545

emac ptp tslud register, offset:0x0714

◆

union { ... } emac_ptp_type::@547

emac ptp tsad register, offset:0x0718

◆

union { ... } emac_ptp_type::@549

emac ptp tth register, offset:0x071C

◆

union { ... } emac_ptp_type::@551

emac ptp ttl register, offset:0x0720

◆

union { ... } emac_ptp_type::@553

emac ptp tssr register, offset:0x0728

◆

union { ... } emac_ptp_type::@555

emac ptp ppscr register, offset:0x072C

◆ aru

__IO uint32_t emac_ptp_type::aru

Definition at line 1168 of file at32f435_437_emac.h.

◆ ast

__IO uint32_t emac_ptp_type::ast

Definition at line 1218 of file at32f435_437_emac.h.

◆ emafpff

__IO uint32_t emac_ptp_type::emafpff

Definition at line 1179 of file at32f435_437_emac.h.

◆ eppef

__IO uint32_t emac_ptp_type::eppef

Definition at line 1173 of file at32f435_437_emac.h.

◆ eppfsip4u

__IO uint32_t emac_ptp_type::eppfsip4u

Definition at line 1175 of file at32f435_437_emac.h.

◆ eppfsip6u

__IO uint32_t emac_ptp_type::eppfsip6u

Definition at line 1174 of file at32f435_437_emac.h.

◆ eppv2f

__IO uint32_t emac_ptp_type::eppv2f

Definition at line 1172 of file at32f435_437_emac.h.

◆ esfmrtm

__IO uint32_t emac_ptp_type::esfmrtm

Definition at line 1177 of file at32f435_437_emac.h.

◆ etaf

__IO uint32_t emac_ptp_type::etaf

Definition at line 1170 of file at32f435_437_emac.h.

◆ etsfem

__IO uint32_t emac_ptp_type::etsfem

Definition at line 1176 of file at32f435_437_emac.h.

◆ pofc

__IO uint32_t emac_ptp_type::pofc

Definition at line 1310 of file at32f435_437_emac.h.

◆ ppscr

__IO uint32_t emac_ptp_type::ppscr

Definition at line 1307 of file at32f435_437_emac.h.

◆

struct { ... } emac_ptp_type::ppscr_bit

◆ reserved1

__IO uint32_t emac_ptp_type::reserved1

emac ptp reserved register, offset:0x0724

Definition at line 1169 of file at32f435_437_emac.h.

◆ reserved2

__IO uint32_t emac_ptp_type::reserved2

Definition at line 1180 of file at32f435_437_emac.h.

◆ sppfts

__IO uint32_t emac_ptp_type::sppfts

Definition at line 1178 of file at32f435_437_emac.h.

◆ ssinc

__IO uint32_t emac_ptp_type::ssinc

Definition at line 1189 of file at32f435_437_emac.h.

◆

struct { ... } emac_ptp_type::ssinc_bit

◆ ssiv

__IO uint32_t emac_ptp_type::ssiv

Definition at line 1192 of file at32f435_437_emac.h.

◆ tar

__IO uint32_t emac_ptp_type::tar

Definition at line 1255 of file at32f435_437_emac.h.

◆ tdbrc

__IO uint32_t emac_ptp_type::tdbrc

Definition at line 1171 of file at32f435_437_emac.h.

◆ te

__IO uint32_t emac_ptp_type::te

Definition at line 1163 of file at32f435_437_emac.h.

◆ tfcu

__IO uint32_t emac_ptp_type::tfcu

Definition at line 1164 of file at32f435_437_emac.h.

◆ ti

__IO uint32_t emac_ptp_type::ti

Definition at line 1165 of file at32f435_437_emac.h.

◆ tite

__IO uint32_t emac_ptp_type::tite

Definition at line 1167 of file at32f435_437_emac.h.

◆ ts

__IO uint32_t emac_ptp_type::ts

Definition at line 1205 of file at32f435_437_emac.h.

◆ tsad

__IO uint32_t emac_ptp_type::tsad

Definition at line 1252 of file at32f435_437_emac.h.

◆

struct { ... } emac_ptp_type::tsad_bit

◆ tsctrl

__IO uint32_t emac_ptp_type::tsctrl

Definition at line 1160 of file at32f435_437_emac.h.

◆

struct { ... } emac_ptp_type::tsctrl_bit

◆ tsh

__IO uint32_t emac_ptp_type::tsh

Definition at line 1202 of file at32f435_437_emac.h.

◆

struct { ... } emac_ptp_type::tsh_bit

◆ tshud

__IO uint32_t emac_ptp_type::tshud

Definition at line 1227 of file at32f435_437_emac.h.

◆

struct { ... } emac_ptp_type::tshud_bit

◆ tsl

__IO uint32_t emac_ptp_type::tsl

Definition at line 1214 of file at32f435_437_emac.h.

◆

struct { ... } emac_ptp_type::tsl_bit

◆ tslud

__IO uint32_t emac_ptp_type::tslud

Definition at line 1239 of file at32f435_437_emac.h.

◆

struct { ... } emac_ptp_type::tslud_bit

◆ tso

__IO uint32_t emac_ptp_type::tso

Definition at line 1296 of file at32f435_437_emac.h.

◆ tss

__IO uint32_t emac_ptp_type::tss

Definition at line 1217 of file at32f435_437_emac.h.

◆ tssr

__IO uint32_t emac_ptp_type::tssr

Definition at line 1293 of file at32f435_437_emac.h.

◆

struct { ... } emac_ptp_type::tssr_bit

◆ tth

__IO uint32_t emac_ptp_type::tth

Definition at line 1264 of file at32f435_437_emac.h.

◆

struct { ... } emac_ptp_type::tth_bit

◆ ttl

__IO uint32_t emac_ptp_type::ttl

Definition at line 1276 of file at32f435_437_emac.h.

◆

struct { ... } emac_ptp_type::ttl_bit

◆ ttlr

__IO uint32_t emac_ptp_type::ttlr

Definition at line 1279 of file at32f435_437_emac.h.

◆ ttsr

__IO uint32_t emac_ptp_type::ttsr

Definition at line 1267 of file at32f435_437_emac.h.

◆ tttr

__IO uint32_t emac_ptp_type::tttr

Definition at line 1297 of file at32f435_437_emac.h.

◆ tu

__IO uint32_t emac_ptp_type::tu

Definition at line 1166 of file at32f435_437_emac.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_emac.h


AT32F435/437 Firmwary Library: emac_dma_type Struct Reference

Data Fields
emac_dma_type Struct Reference
AT32F435_437_periph_driver » EMAC » EMAC_exported_types

type define emac ptp register all More...

#include <at32f435_437_emac.h>

Data Fields

union {
__IO uint32_t bm
struct {
__IO uint32_t swr: 1
__IO uint32_t da: 1
__IO uint32_t dsl: 5
__IO uint32_t reserved1: 1
__IO uint32_t pbl: 6
__IO uint32_t pr: 2
__IO uint32_t fb: 1
__IO uint32_t rdp: 6
__IO uint32_t usp: 1
__IO uint32_t pblx8: 1
__IO uint32_t aab: 1
__IO uint32_t reserved2: 6
} bm_bit
};
emac dma bm register, offset:0x1000 More...
union {
__IO uint32_t tpd
struct {
__IO uint32_t tpd: 32
} tpd_bit
};
emac dma tpd register, offset:0x1004 More...
union {
__IO uint32_t rpd
struct {
__IO uint32_t rpd: 32
} rpd_bit
};
emac dma rpd register, offset:0x1008 More...
union {
__IO uint32_t rdladdr
struct {
__IO uint32_t srl: 32
} rdladdr_bit
};
emac dma rdladdr register, offset:0x100c More...
union {
__IO uint32_t tdladdr
struct {
__IO uint32_t stl: 32
} tdladdr_bit
};
emac dma tdladdr register, offset:0x1010 More...
union {
__IO uint32_t sts
struct {
__IO uint32_t ti: 1
__IO uint32_t tps: 1
__IO uint32_t tbu: 1
__IO uint32_t tjt: 1
__IO uint32_t ovf: 1
__IO uint32_t unf: 1
__IO uint32_t ri: 1
__IO uint32_t rbu: 1
__IO uint32_t rps: 1
__IO uint32_t rwt: 1
__IO uint32_t eti: 1
__IO uint32_t reserved1: 2
__IO uint32_t fbei: 1
__IO uint32_t eri: 1
__IO uint32_t ais: 1
__IO uint32_t nis: 1
__IO uint32_t rs: 3
__IO uint32_t ts: 3
__IO uint32_t eb: 3
__IO uint32_t reserved2: 1
__IO uint32_t mmi: 1
__IO uint32_t mpi: 1
__IO uint32_t tti: 1
__IO uint32_t reserved3: 2
} sts_bit
};
emac dma sts register, offset:0x1014 More...
union {
__IO uint32_t opm
struct {
__IO uint32_t reserved1: 1
__IO uint32_t ssr: 1
__IO uint32_t osf: 1
__IO uint32_t rtc: 2
__IO uint32_t reserved2: 1
__IO uint32_t fugf: 1
__IO uint32_t fef: 1
__IO uint32_t reserved3: 5
__IO uint32_t sstc: 1
__IO uint32_t ttc: 3
__IO uint32_t reserved4: 3
__IO uint32_t ftf: 1
__IO uint32_t tsf: 1
__IO uint32_t reserved5: 2
__IO uint32_t dfrf: 1
__IO uint32_t rsf: 1
__IO uint32_t dt: 1
__IO uint32_t reserved6: 5
} opm_bit
};
emac dma opm register, offset:0x1018 More...
union {
__IO uint32_t ie
struct {
__IO uint32_t tie: 1
__IO uint32_t tse: 1
__IO uint32_t tue: 1
__IO uint32_t tje: 1
__IO uint32_t ove: 1
__IO uint32_t une: 1
__IO uint32_t rie: 1
__IO uint32_t rbue: 1
__IO uint32_t rse: 1
__IO uint32_t rwte: 1
__IO uint32_t eie: 1
__IO uint32_t reserved1: 2
__IO uint32_t fbee: 1
__IO uint32_t ere: 1
__IO uint32_t aie: 1
__IO uint32_t nie: 1
__IO uint32_t reserved2: 15
} ie_bit
};
emac dma ie register, offset:0x101C More...
union {
__IO uint32_t mfbocnt
struct {
__IO uint32_t mfc: 16
__IO uint32_t obmfc: 1
__IO uint32_t ofc: 11
__IO uint32_t obfoc: 1
__IO uint32_t reserved1: 3
} mfbocnt_bit
};
emac dma mfbocnt register, offset:0x1020 More...
union {
__IO uint32_t ctd
struct {
__IO uint32_t htdap: 32
} ctd_bit
};
emac ctd register, offset:0x1048 More...
union {
__IO uint32_t crd
struct {
__IO uint32_t hrdap: 32
} crd_bit
};
emac crd register, offset:0x104C More...
union {
__IO uint32_t ctbaddr
struct {
__IO uint32_t htbap: 32
} ctbaddr_bit
};
emac ctbaddr register, offset:0x1050 More...
union {
__IO uint32_t crbaddr
struct {
__IO uint32_t hrbap: 32
} crbaddr_bit
};
emac crbaddr register, offset:0x1054 More...

Detailed Description

type define emac ptp register all

Definition at line 1319 of file at32f435_437_emac.h.

Field Documentation

◆

union { ... } emac_dma_type::@568

emac dma bm register, offset:0x1000

◆

union { ... } emac_dma_type::@570

emac dma tpd register, offset:0x1004

◆

union { ... } emac_dma_type::@572

emac dma rpd register, offset:0x1008

◆

union { ... } emac_dma_type::@574

emac dma rdladdr register, offset:0x100c

◆

union { ... } emac_dma_type::@576

emac dma tdladdr register, offset:0x1010

◆

union { ... } emac_dma_type::@578

emac dma sts register, offset:0x1014

◆

union { ... } emac_dma_type::@580

emac dma opm register, offset:0x1018

◆

union { ... } emac_dma_type::@582

emac dma ie register, offset:0x101C

◆

union { ... } emac_dma_type::@584

emac dma mfbocnt register, offset:0x1020

◆

union { ... } emac_dma_type::@586

emac ctd register, offset:0x1048

◆

union { ... } emac_dma_type::@588

emac crd register, offset:0x104C

◆

union { ... } emac_dma_type::@590

emac ctbaddr register, offset:0x1050

◆

union { ... } emac_dma_type::@592

emac crbaddr register, offset:0x1054

◆ aab

__IO uint32_t emac_dma_type::aab

Definition at line 1339 of file at32f435_437_emac.h.

◆ aie

__IO uint32_t emac_dma_type::aie

Definition at line 1478 of file at32f435_437_emac.h.

◆ ais

__IO uint32_t emac_dma_type::ais

Definition at line 1414 of file at32f435_437_emac.h.

◆ bm

__IO uint32_t emac_dma_type::bm

Definition at line 1326 of file at32f435_437_emac.h.

◆

struct { ... } emac_dma_type::bm_bit

◆ crbaddr

__IO uint32_t emac_dma_type::crbaddr

Definition at line 1546 of file at32f435_437_emac.h.

◆

struct { ... } emac_dma_type::crbaddr_bit

◆ crd

__IO uint32_t emac_dma_type::crd

Definition at line 1522 of file at32f435_437_emac.h.

◆

struct { ... } emac_dma_type::crd_bit

◆ ctbaddr

__IO uint32_t emac_dma_type::ctbaddr

Definition at line 1534 of file at32f435_437_emac.h.

◆

struct { ... } emac_dma_type::ctbaddr_bit

◆ ctd

__IO uint32_t emac_dma_type::ctd

Definition at line 1510 of file at32f435_437_emac.h.

◆

struct { ... } emac_dma_type::ctd_bit

◆ da

__IO uint32_t emac_dma_type::da

Definition at line 1330 of file at32f435_437_emac.h.

◆ dfrf

__IO uint32_t emac_dma_type::dfrf

Definition at line 1449 of file at32f435_437_emac.h.

◆ dsl

__IO uint32_t emac_dma_type::dsl

Definition at line 1331 of file at32f435_437_emac.h.

◆ dt

__IO uint32_t emac_dma_type::dt

Definition at line 1451 of file at32f435_437_emac.h.

◆ eb

__IO uint32_t emac_dma_type::eb

Definition at line 1418 of file at32f435_437_emac.h.

◆ eie

__IO uint32_t emac_dma_type::eie

Definition at line 1474 of file at32f435_437_emac.h.

◆ ere

__IO uint32_t emac_dma_type::ere

Definition at line 1477 of file at32f435_437_emac.h.

◆ eri

__IO uint32_t emac_dma_type::eri

Definition at line 1413 of file at32f435_437_emac.h.

◆ eti

__IO uint32_t emac_dma_type::eti

Definition at line 1410 of file at32f435_437_emac.h.

◆ fb

__IO uint32_t emac_dma_type::fb

Definition at line 1335 of file at32f435_437_emac.h.

◆ fbee

__IO uint32_t emac_dma_type::fbee

Definition at line 1476 of file at32f435_437_emac.h.

◆ fbei

__IO uint32_t emac_dma_type::fbei

Definition at line 1412 of file at32f435_437_emac.h.

◆ fef

__IO uint32_t emac_dma_type::fef

Definition at line 1441 of file at32f435_437_emac.h.

◆ ftf

__IO uint32_t emac_dma_type::ftf

Definition at line 1446 of file at32f435_437_emac.h.

◆ fugf

__IO uint32_t emac_dma_type::fugf

Definition at line 1440 of file at32f435_437_emac.h.

◆ hrbap

__IO uint32_t emac_dma_type::hrbap

Definition at line 1549 of file at32f435_437_emac.h.

◆ hrdap

__IO uint32_t emac_dma_type::hrdap

Definition at line 1525 of file at32f435_437_emac.h.

◆ htbap

__IO uint32_t emac_dma_type::htbap

Definition at line 1537 of file at32f435_437_emac.h.

◆ htdap

__IO uint32_t emac_dma_type::htdap

Definition at line 1513 of file at32f435_437_emac.h.

◆ ie

__IO uint32_t emac_dma_type::ie

Definition at line 1461 of file at32f435_437_emac.h.

◆

struct { ... } emac_dma_type::ie_bit

◆ mfbocnt

__IO uint32_t emac_dma_type::mfbocnt

Definition at line 1489 of file at32f435_437_emac.h.

◆

struct { ... } emac_dma_type::mfbocnt_bit

◆ mfc

__IO uint32_t emac_dma_type::mfc

Definition at line 1492 of file at32f435_437_emac.h.

◆ mmi

__IO uint32_t emac_dma_type::mmi

Definition at line 1420 of file at32f435_437_emac.h.

◆ mpi

__IO uint32_t emac_dma_type::mpi

Definition at line 1421 of file at32f435_437_emac.h.

◆ nie

__IO uint32_t emac_dma_type::nie

Definition at line 1479 of file at32f435_437_emac.h.

◆ nis

__IO uint32_t emac_dma_type::nis

Definition at line 1415 of file at32f435_437_emac.h.

◆ obfoc

__IO uint32_t emac_dma_type::obfoc

Definition at line 1495 of file at32f435_437_emac.h.

◆ obmfc

__IO uint32_t emac_dma_type::obmfc

Definition at line 1493 of file at32f435_437_emac.h.

◆ ofc

__IO uint32_t emac_dma_type::ofc

Definition at line 1494 of file at32f435_437_emac.h.

◆ opm

__IO uint32_t emac_dma_type::opm

Definition at line 1432 of file at32f435_437_emac.h.

◆

struct { ... } emac_dma_type::opm_bit

◆ osf

__IO uint32_t emac_dma_type::osf

Definition at line 1437 of file at32f435_437_emac.h.

◆ ove

__IO uint32_t emac_dma_type::ove

Definition at line 1468 of file at32f435_437_emac.h.

◆ ovf

__IO uint32_t emac_dma_type::ovf

Definition at line 1404 of file at32f435_437_emac.h.

◆ pbl

__IO uint32_t emac_dma_type::pbl

Definition at line 1333 of file at32f435_437_emac.h.

◆ pblx8

__IO uint32_t emac_dma_type::pblx8

Definition at line 1338 of file at32f435_437_emac.h.

◆ pr

__IO uint32_t emac_dma_type::pr

Definition at line 1334 of file at32f435_437_emac.h.

◆ rbu

__IO uint32_t emac_dma_type::rbu

Definition at line 1407 of file at32f435_437_emac.h.

◆ rbue

__IO uint32_t emac_dma_type::rbue

Definition at line 1471 of file at32f435_437_emac.h.

◆ rdladdr

__IO uint32_t emac_dma_type::rdladdr

Definition at line 1373 of file at32f435_437_emac.h.

◆

struct { ... } emac_dma_type::rdladdr_bit

◆ rdp

__IO uint32_t emac_dma_type::rdp

Definition at line 1336 of file at32f435_437_emac.h.

◆ reserved1

__IO uint32_t emac_dma_type::reserved1

emac dma reserved1 register, offset:0x1024~0x1044

Definition at line 1332 of file at32f435_437_emac.h.

◆ reserved2

__IO uint32_t emac_dma_type::reserved2

Definition at line 1340 of file at32f435_437_emac.h.

◆ reserved3

__IO uint32_t emac_dma_type::reserved3

Definition at line 1423 of file at32f435_437_emac.h.

◆ reserved4

__IO uint32_t emac_dma_type::reserved4

Definition at line 1445 of file at32f435_437_emac.h.

◆ reserved5

__IO uint32_t emac_dma_type::reserved5

Definition at line 1448 of file at32f435_437_emac.h.

◆ reserved6

__IO uint32_t emac_dma_type::reserved6

Definition at line 1452 of file at32f435_437_emac.h.

◆ ri

__IO uint32_t emac_dma_type::ri

Definition at line 1406 of file at32f435_437_emac.h.

◆ rie

__IO uint32_t emac_dma_type::rie

Definition at line 1470 of file at32f435_437_emac.h.

◆ rpd

__IO uint32_t emac_dma_type::rpd

Definition at line 1361 of file at32f435_437_emac.h.

◆

struct { ... } emac_dma_type::rpd_bit

◆ rps

__IO uint32_t emac_dma_type::rps

Definition at line 1408 of file at32f435_437_emac.h.

◆ rs

__IO uint32_t emac_dma_type::rs

Definition at line 1416 of file at32f435_437_emac.h.

◆ rse

__IO uint32_t emac_dma_type::rse

Definition at line 1472 of file at32f435_437_emac.h.

◆ rsf

__IO uint32_t emac_dma_type::rsf

Definition at line 1450 of file at32f435_437_emac.h.

◆ rtc

__IO uint32_t emac_dma_type::rtc

Definition at line 1438 of file at32f435_437_emac.h.

◆ rwt

__IO uint32_t emac_dma_type::rwt

Definition at line 1409 of file at32f435_437_emac.h.

◆ rwte

__IO uint32_t emac_dma_type::rwte

Definition at line 1473 of file at32f435_437_emac.h.

◆ srl

__IO uint32_t emac_dma_type::srl

Definition at line 1376 of file at32f435_437_emac.h.

◆ ssr

__IO uint32_t emac_dma_type::ssr

Definition at line 1436 of file at32f435_437_emac.h.

◆ sstc

__IO uint32_t emac_dma_type::sstc

Definition at line 1443 of file at32f435_437_emac.h.

◆ stl

__IO uint32_t emac_dma_type::stl

Definition at line 1388 of file at32f435_437_emac.h.

◆ sts

__IO uint32_t emac_dma_type::sts

Definition at line 1397 of file at32f435_437_emac.h.

◆

struct { ... } emac_dma_type::sts_bit

◆ swr

__IO uint32_t emac_dma_type::swr

Definition at line 1329 of file at32f435_437_emac.h.

◆ tbu

__IO uint32_t emac_dma_type::tbu

Definition at line 1402 of file at32f435_437_emac.h.

◆ tdladdr

__IO uint32_t emac_dma_type::tdladdr

Definition at line 1385 of file at32f435_437_emac.h.

◆

struct { ... } emac_dma_type::tdladdr_bit

◆ ti

__IO uint32_t emac_dma_type::ti

Definition at line 1400 of file at32f435_437_emac.h.

◆ tie

__IO uint32_t emac_dma_type::tie

Definition at line 1464 of file at32f435_437_emac.h.

◆ tje

__IO uint32_t emac_dma_type::tje

Definition at line 1467 of file at32f435_437_emac.h.

◆ tjt

__IO uint32_t emac_dma_type::tjt

Definition at line 1403 of file at32f435_437_emac.h.

◆ tpd

__IO uint32_t emac_dma_type::tpd

Definition at line 1349 of file at32f435_437_emac.h.

◆

struct { ... } emac_dma_type::tpd_bit

◆ tps

__IO uint32_t emac_dma_type::tps

Definition at line 1401 of file at32f435_437_emac.h.

◆ ts

__IO uint32_t emac_dma_type::ts

Definition at line 1417 of file at32f435_437_emac.h.

◆ tse

__IO uint32_t emac_dma_type::tse

Definition at line 1465 of file at32f435_437_emac.h.

◆ tsf

__IO uint32_t emac_dma_type::tsf

Definition at line 1447 of file at32f435_437_emac.h.

◆ ttc

__IO uint32_t emac_dma_type::ttc

Definition at line 1444 of file at32f435_437_emac.h.

◆ tti

__IO uint32_t emac_dma_type::tti

Definition at line 1422 of file at32f435_437_emac.h.

◆ tue

__IO uint32_t emac_dma_type::tue

Definition at line 1466 of file at32f435_437_emac.h.

◆ une

__IO uint32_t emac_dma_type::une

Definition at line 1469 of file at32f435_437_emac.h.

◆ unf

__IO uint32_t emac_dma_type::unf

Definition at line 1405 of file at32f435_437_emac.h.

◆ usp

__IO uint32_t emac_dma_type::usp

Definition at line 1337 of file at32f435_437_emac.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_emac.h


AT32F435/437 Firmwary Library: EMAC_exported_functions

Functions
EMAC_exported_functions
AT32F435_437_periph_driver » EMAC

Functions

void | emac_reset (void)
deinitialize the emac peripheral registers to their default reset values. More...
void | emac_clock_range_set (void)
according to hclk to set mdc clock frequency. More...
void | emac_dma_software_reset_set (void)
reset emac dma More...
flag_status | emac_dma_software_reset_get (void)
get emac dma reset status More...
void | emac_start (void)
enable emac and dma reception/transmission More...
void | emac_stop (void)
stop emac and dma reception/transmission More...
error_status | emac_phy_register_write (uint8_t address, uint8_t reg, uint16_t data)
write phy data. More...
error_status | emac_phy_register_read (uint8_t address, uint8_t reg, uint16_t *data)
read phy data More...
void | emac_control_para_init (emac_control_config_type *control_para)
initialize emac control structure More...
void | emac_control_config (emac_control_config_type *control_struct)
configure emac control setting. More...
void | emac_receiver_enable (confirm_state new_state)
emac receiver enable. More...
void | emac_trasmitter_enable (confirm_state new_state)
emac transmitter enable. More...
void | emac_deferral_check_set (confirm_state new_state)
emac defferal check enable, only avalible in half-duplex mode. More...
void | emac_backoff_limit_set (emac_bol_type slot_time)
emac back-off limit, only avalible in half-duplex mode. More...
void | emac_auto_pad_crc_stripping_set (confirm_state new_state)
set mac automatic pad/CRC stripping. More...
void | emac_retry_disable (confirm_state new_state)
transmittion retry disable. More...
void | emac_ipv4_checksum_offload_set (confirm_state new_state)
set ipv4 checksum offload. More...
void | emac_loopback_mode_enable (confirm_state new_state)
enable loopback mode. More...
void | emac_receive_own_disable (confirm_state new_state)
receive own disable. More...
void | emac_carrier_sense_disable (confirm_state new_state)
carrier sense disbale. More...
void | emac_interframe_gap_set (emac_intergrame_gap_type number)
set minimum interframe gap between frames during transmission. More...
void | emac_jabber_disable (confirm_state new_state)
jabber disable. More...
void | emac_watchdog_disable (confirm_state new_state)
watchdog disable. More...
void | emac_fast_speed_set (emac_speed_type speed)
set mac fast emac speed. More...
void | emac_duplex_mode_set (emac_duplex_type duplex_mode)
set duplex mode. More...
void | emac_promiscuous_mode_set (confirm_state new_state)
set mac promiscuous mode. More...
void | emac_hash_unicast_set (confirm_state new_state)
hash unicast. More...
void | emac_hash_multicast_set (confirm_state new_state)
hash multicast. More...
void | emac_dstaddr_inverse_filter_set (confirm_state new_state)
destination address inverse filtering. More...
void | emac_pass_all_multicasting_set (confirm_state new_state)
pass all multicasting frames. More...
void | emac_broadcast_frames_disable (confirm_state new_state)
broadcast frames disable. More...
void | emac_pass_control_frames_set (emac_control_frames_filter_type condition)
set mac how to pass control frames. More...
void | emac_srcaddr_inverse_filter_set (confirm_state new_state)
source address inverse filtering. More...
void | emac_srcaddr_filter_set (confirm_state new_state)
source address filtering. More...
void | emac_hash_perfect_filter_set (confirm_state new_state)
mac uses hash or perfect filter. More...
void | emac_receive_all_set (confirm_state new_state)
mac receives all frames. More...
void | emac_hash_table_high32bits_set (uint32_t high32bits)
hash table high 32-bit. More...
void | emac_hash_table_low32bits_set (uint32_t low32bits)
hash table low 32-bit. More...
flag_status | emac_mii_busy_get (void)
mii busy status. More...
void | emac_mii_write (confirm_state new_state)
tell phy that will be written. More...
void | emac_fcb_bpa_set (confirm_state new_state)
set flow control busy in full-duplex mode, back pressure activate in half-duplex mode. More...
void | emac_transmit_flow_control_enable (confirm_state new_state)
set transmit flow control. More...
void | emac_receive_flow_control_enable (confirm_state new_state)
set receive flow control. More...
void | emac_unicast_pause_frame_detect (confirm_state new_state)
set unicast pause frame detect. More...
void | emac_pause_low_threshold_set (emac_pause_slot_threshold_type pasue_threshold)
set pause low threshold. More...
void | emac_zero_quanta_pause_disable (confirm_state new_state)
set zero-quanta pause disable. More...
void | emac_pause_time_set (uint16_t pause_time)
set pause time. More...
void | emac_vlan_tag_identifier_set (uint16_t identifier)
identify coming vlan frame field with setting value. More...
void | emac_vlan_tag_comparison_set (confirm_state new_state)
set 12-bit vlan identifier. More...
void | emac_wakeup_frame_set (uint32_t value)
set wakeup frame. More...
uint32_t | emac_wakeup_frame_get (void)
get wakeup frame. More...
void | emac_power_down_set (confirm_state new_state)
all frame will be droppped except wakeup frame or magic packet. More...
void | emac_magic_packet_enable (confirm_state new_state)
magic packet enable More...
void | emac_wakeup_frame_enable (confirm_state new_state)
wakeup frame enable More...
flag_status | emac_received_magic_packet_get (void)
received magic packet More...
flag_status | emac_received_wakeup_frame_get (void)
received wakeup frame. More...
void | emac_global_unicast_set (confirm_state new_state)
set unicast frame that passes DAF as wakeup frame. More...
void | emac_wakeup_frame_filter_reset (confirm_state new_state)
reset wakeup frame filter resgister More...
flag_status | emac_interrupt_status_read (uint32_t flag)
read interrupt status More...
void | emac_interrupt_mask_set (emac_interrupt_mask_type mask_type, confirm_state new_state)
set interrupt mask More...
void | emac_local_address_set (uint8_t *address)
set local mac address More...
void | emac_address_filter_set (emac_address_type mac, emac_address_filter_type filter, emac_address_mask_type mask_bit, confirm_state new_state)
set mac filter address More...
uint32_t | emac_received_packet_size_get (void)
get the size of received the received packet. More...
uint32_t | emac_dmarxdesc_frame_length_get (emac_dma_desc_type *dma_rx_desc)
get the specified dma rx descsriptor frame length. More...
void | emac_dma_descriptor_list_address_set (emac_dma_tx_rx_type transfer_type, emac_dma_desc_type *dma_desc_tab, uint8_t *buff, uint32_t buffer_count)
set transmit/receive descriptor list address More...
uint32_t | emac_dma_descriptor_list_address_get (emac_dma_tx_rx_type transfer_type)
get transmit/receive descriptor list address More...
void | emac_dma_rx_desc_interrupt_config (emac_dma_desc_type *dma_rx_desc, confirm_state new_state)
enable or disable the specified dma rx descriptor receive interrupt More...
void | emac_dma_para_init (emac_dma_config_type *control_para)
init emac dma parameters More...
void | emac_dma_config (emac_dma_config_type *control_para)
configure emac dma More...
void | emac_dma_arbitation_set (emac_dma_rx_tx_ratio_type ratio, confirm_state new_state)
set rx tx priority More...
void | emac_dma_descriptor_skip_length_set (uint8_t length)
set descriptor skip mength More...
void | emac_dma_separate_pbl_set (emac_dma_pbl_type tx_length, emac_dma_pbl_type rx_length, confirm_state new_state)
set programmable burst length More...
void | emac_dma_eight_pbl_mode_set (confirm_state new_state)
set 8 times programmable burst length More...
void | emac_dma_address_aligned_beats_set (confirm_state new_state)
set address-aligned beats More...
void | emac_dma_poll_demand_set (emac_dma_tx_rx_type transfer_type, uint32_t value)
set transmit/receive poll demand More...
uint32_t | emac_dma_poll_demand_get (emac_dma_tx_rx_type transfer_type)
get transmit poll demand More...
emac_dma_receive_process_status_type | emac_dma_receive_status_get (void)
get receive dma process status More...
emac_dma_transmit_process_status_type | emac_dma_transmit_status_get (void)
get transmit dma process status More...
void | emac_dma_operations_set (emac_dma_operations_type ops, confirm_state new_state)
set dma operations More...
void | emac_dma_receive_threshold_set (emac_dma_receive_threshold_type value)
set receive dma threshold More...
void | emac_dma_transmit_threshold_set (emac_dma_transmit_threshold_type value)
set transmit dma threshold More...
void | emac_dma_interrupt_enable (emac_dma_interrupt_type it, confirm_state new_state)
enable dma interrupt More...
uint16_t | emac_dma_controller_missing_frame_get (void)
get missed frames by the controller More...
uint8_t | emac_dma_missing_overflow_bit_get (void)
get overflow bit for missed frame counter More...
uint16_t | emac_dma_application_missing_frame_get (void)
get missed frames by the application More...
uint8_t | emac_dma_fifo_overflow_bit_get (void)
get overflow bit for FIFO overflow counter More...
uint32_t | emac_dma_tansfer_address_get (emac_dma_transfer_address_type transfer_type)
get overflow bit for FIFO overflow counter More...
void | emac_mmc_counter_reset (void)
reset all counter More...
void | emac_mmc_rollover_stop (confirm_state new_state)
counter stop counting from zero when it reaches maximum More...
void | emac_mmc_reset_on_read_enable (confirm_state new_state)
enable reset on read More...
void | emac_mmc_counter_freeze (confirm_state new_state)
freeze mmc counter More...
flag_status | emac_mmc_received_status_get (uint32_t flag)
interupt status of received frames More...
flag_status | emac_mmc_transmit_status_get (uint32_t flag)
interupt status of transmit frames More...
void | emac_mmc_received_interrupt_mask_set (uint32_t flag, confirm_state new_state)
mask received mmc interrupt More...
void | emac_mmc_transmit_interrupt_mask_set (uint32_t flag, confirm_state new_state)
mask transmit mmc interrupt More...
uint32_t | emac_mmc_transmit_good_frames_get (uint32_t flag)
get good frame numbers as single collision occurs. More...
uint32_t | emac_mmc_received_error_frames_get (uint32_t flag)
get good frame numbers as single collision occurs. More...
void | emac_ptp_timestamp_enable (confirm_state new_state)
enable timestamp. More...
void | emac_ptp_timestamp_fine_update_enable (confirm_state new_state)
enable timestamp fine update. More...
void | emac_ptp_timestamp_system_time_init (confirm_state new_state)
initialize timestamp time system. More...
void | emac_ptp_timestamp_system_time_update (confirm_state new_state)
update timestamp time system. More...
void | emac_ptp_interrupt_trigger_enable (confirm_state new_state)
enable timestamp interrupt trigger. More...
void | emac_ptp_addend_register_update (confirm_state new_state)
update timestamp addend register. More...
void | emac_ptp_snapshot_received_frames_enable (confirm_state new_state)
enable timestamp snapshot for all received frames. More...
void | emac_ptp_subsecond_rollover_enable (confirm_state new_state)
enable digital rollover. More...
void | emac_ptp_psv2_enable (confirm_state new_state)
enable packet snooping for version 2. More...
void | emac_ptp_snapshot_emac_frames_enable (confirm_state new_state)
enable snapshot over emac. More...
void | emac_ptp_snapshot_ipv6_frames_enable (confirm_state new_state)
enable snapshot for ipv6 frames. More...
void | emac_ptp_snapshot_ipv4_frames_enable (confirm_state new_state)
enable snapshot for ipv4 frames. More...
void | emac_ptp_snapshot_event_message_enable (confirm_state new_state)
enable snapshot for event message. More...
void | emac_ptp_snapshot_master_event_enable (confirm_state new_state)
enable snapshot for message relevant to master More...
void | emac_ptp_clock_node_set (emac_ptp_clock_node_type node)
set clock node type More...
void | emac_ptp_mac_address_filter_enable (confirm_state new_state)
enable ptp frame filtering mac address More...
void | emac_ptp_subsecond_increment_set (uint8_t value)
set subsecond increment value More...
uint32_t | emac_ptp_system_second_get (void)
get system time second More...
uint32_t | emac_ptp_system_subsecond_get (void)
get system time subsecond More...
confirm_state | emac_ptp_system_time_sign_get (void)
get system time sign More...
void | emac_ptp_system_second_set (uint32_t second)
set system time second More...
void | emac_ptp_system_subsecond_set (uint32_t subsecond)
set system time subsecond More...
void | emac_ptp_system_time_sign_set (confirm_state sign)
set system time sign More...
void | emac_ptp_timestamp_addend_set (uint32_t value)
set time stamp addend More...
void | emac_ptp_target_second_set (uint32_t value)
set target time stamp high More...
void | emac_ptp_target_nanosecond_set (uint32_t value)
set target time stamp low More...
confirm_state emac_ptp_timestamp_status_get (emac_ptp_timestamp_status_type status)
set target time stamp low More...
void | emac_ptp_pps_frequency_set (emac_ptp_pps_control_type freq)
set pps frequency More...
flag_status | emac_dma_flag_get (uint32_t dma_flag)
check whether the specified emac dma flag is set or not. More...
void | emac_dma_flag_clear (uint32_t dma_flag)
clear the emac dma flag. More...

Detailed Description

Function Documentation

◆ emac_address_filter_set()

void emac_address_filter_set | ( | emac_address_type | mac,
 |  | emac_address_filter_type | filter,
 |  | emac_address_mask_type | mask_bit,
 |  | confirm_state | new_state
 | ) |  |

set mac filter address

Parameters
mac select which mac you want to set this parameter can be one of the following values:
  • EMAC_ADDRESS_FILTER_1
  • EMAC_ADDRESS_FILTER_2
  • EMAC_ADDRESS_FILTER_3
Return values
none

Definition at line 895 of file at32f435_437_emac.c.

◆ emac_auto_pad_crc_stripping_set()

void emac_auto_pad_crc_stripping_set ( confirm_state new_state )

set mac automatic pad/CRC stripping.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 348 of file at32f435_437_emac.c.

Referenced by emac_control_config().

◆ emac_backoff_limit_set()

void emac_backoff_limit_set ( emac_bol_type slot_time )

emac back-off limit, only avalible in half-duplex mode.

Parameters
slot_time waiting time of retransmission after collision this parameter can be one of the following values:
  • EMAC_BACKOFF_LIMIT_0
  • EMAC_BACKOFF_LIMIT_1
  • EMAC_BACKOFF_LIMIT_2
  • EMAC_BACKOFF_LIMIT_3
Return values
none

Definition at line 338 of file at32f435_437_emac.c.

Referenced by emac_control_config().

◆ emac_broadcast_frames_disable()

void emac_broadcast_frames_disable ( confirm_state new_state )

broadcast frames disable.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 523 of file at32f435_437_emac.c.

◆ emac_carrier_sense_disable()

void emac_carrier_sense_disable ( confirm_state new_state )

carrier sense disbale.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 398 of file at32f435_437_emac.c.

Referenced by emac_control_config().

◆ emac_clock_range_set()

void emac_clock_range_set ( void )

according to hclk to set mdc clock frequency.

Parameters
none
Return values
none

< hclk boarder of 20 mhz

< hclk boarder of 35 mhz

< hclk boarder of 35 mhz

< hclk boarder of 60 mhz

< hclk boarder of 60 mhz

< hclk boarder of 100 mhz

< hclk boarder of 100 mhz

< hclk boarder of 150 mhz

< hclk boarder of 150 mhz

< hclk boarder of 250 mhz

< hclk boarder of 250 mhz

< hclk boarder of 288 mhz

Definition at line 93 of file at32f435_437_emac.c.

Referenced by emac_phy_init().

◆ emac_control_config()

void emac_control_config ( emac_control_config_type * control_struct )

configure emac control setting.

Parameters
control_struct control setting of mac control register.
Return values
none

Definition at line 136 of file at32f435_437_emac.c.

Referenced by emac_phy_init().

◆ emac_control_para_init()

void emac_control_para_init ( emac_control_config_type * control_para )

initialize emac control structure

Parameters
emac_control_config_type
Return values
none

Definition at line 70 of file at32f435_437_emac.c.

Referenced by emac_layer2_configuration().

◆ emac_deferral_check_set()

void emac_deferral_check_set ( confirm_state new_state )

emac defferal check enable, only avalible in half-duplex mode.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 323 of file at32f435_437_emac.c.

Referenced by emac_control_config().

◆ emac_dma_address_aligned_beats_set()

void emac_dma_address_aligned_beats_set ( confirm_state new_state )

set address-aligned beats

Parameters
new_state TRUE or FALSE
Return values
none

Definition at line 1199 of file at32f435_437_emac.c.

◆ emac_dma_application_missing_frame_get()

uint16_t emac_dma_application_missing_frame_get ( void )

get missed frames by the application

Parameters
none
Return values
missed frames by the application

Definition at line 1606 of file at32f435_437_emac.c.

◆ emac_dma_arbitation_set()

void emac_dma_arbitation_set | ( | emac_dma_rx_tx_ratio_type | ratio,
 |  | confirm_state | new_state
 | ) |  |

set rx tx priority

Parameters
ratio rx tx priority ratio this parameter can be one of the following values:
  • EMAC_DMA_1_RX_1_TX
  • EMAC_DMA_2_RX_1_TX
  • EMAC_DMA_3_RX_1_TX
  • EMAC_DMA_4_RX_1_TX
new_state TRUE or FALSE
Return values
none

Definition at line 1132 of file at32f435_437_emac.c.

◆ emac_dma_config()

void emac_dma_config ( emac_dma_config_type * control_para )

configure emac dma

Parameters
emac_dma_config_type
Return values
none

Definition at line 1099 of file at32f435_437_emac.c.

Referenced by emac_layer2_configuration().

◆ emac_dma_controller_missing_frame_get()

uint16_t emac_dma_controller_missing_frame_get ( void )

get missed frames by the controller

Parameters
none
Return values
missed frames by the controller

Definition at line 1584 of file at32f435_437_emac.c.

◆ emac_dma_descriptor_list_address_get()

uint32_t emac_dma_descriptor_list_address_get ( emac_dma_tx_rx_type transfer_type )

get transmit/receive descriptor list address

Parameters
transfer_type it will be transmit or receive this parameter can be one of the following values:
  • EMAC_DMA_TRANSMIT
  • EMAC_DMA_RECEIVE
Return values
transmit/receive descriptor list address

Definition at line 1023 of file at32f435_437_emac.c.

◆ emac_dma_descriptor_list_address_set()

void emac_dma_descriptor_list_address_set | ( | emac_dma_tx_rx_type | transfer_type,
 |  | emac_dma_desc_type * | dma_desc_tab,
 |  | uint8_t * | buff,
 |  | uint32_t | buffer_count
 | ) |  |

set transmit/receive descriptor list address

Parameters
transfer_type it will be transmit or receive this parameter can be one of the following values:
  • EMAC_DMA_TRANSMIT
  • EMAC_DMA_RECEIVE
dma_desc_tab | pointer on the first tx desc list
buff | pointer on the first tx/rx buffer list
buffer_count | number of the used Tx desc in the list
Return values
none

< second address chained

< emac_header + emac_extra + emac_max_payload + emac_crc

< own bit: descriptor is owned by dma engine

< second address chained

< emac_header + emac_extra + emac_max_payload + emac_crc

< emac_header + emac_extra + emac_max_payload + emac_crc

Definition at line 934 of file at32f435_437_emac.c.

◆ emac_dma_descriptor_skip_length_set()

void emac_dma_descriptor_skip_length_set ( uint8_t length )

set descriptor skip mength

Parameters
length descriptor skip length
Return values
none

Definition at line 1147 of file at32f435_437_emac.c.

◆ emac_dma_eight_pbl_mode_set()

void emac_dma_eight_pbl_mode_set ( confirm_state new_state )

set 8 times programmable burst length

Parameters
new_state TRUE or FALSE
Return values
none

Definition at line 1189 of file at32f435_437_emac.c.

◆ emac_dma_fifo_overflow_bit_get()

uint8_t emac_dma_fifo_overflow_bit_get ( void )

get overflow bit for FIFO overflow counter

Parameters
none
Return values
overflow bit for FIFO overflow counter

Definition at line 1617 of file at32f435_437_emac.c.

◆ emac_dma_flag_clear()

void emac_dma_flag_clear ( uint32_t dma_flag )

clear the emac dma flag.

Parameters
dma_flag specifies the emac dma flags to clear. this parameter can be any combination of the following values:
  • EMAC_DMA_TI_FLAG
  • EMAC_DMA_TPS_FLAG
  • EMAC_DMA_TBU_FLAG
  • EMAC_DMA_TJT_FLAG
  • EMAC_DMA_OVF_FLAG
  • EMAC_DMA_UNF_FLAG
  • EMAC_DMA_RI_FLAG
  • EMAC_DMA_RBU_FLAG
  • EMAC_DMA_RPS_FLAG
  • EMAC_DMA_RWT_FLAG
  • EMAC_DMA_ETI_FLAG
  • EMAC_DMA_FBEI_FLAG
  • EMAC_DMA_ERI_FLAG
  • EMAC_DMA_AIS_FLAG
  • EMAC_DMA_NIS_FLAG
Return values
none

Definition at line 2290 of file at32f435_437_emac.c.

Referenced by EMAC_IRQHandler().

◆ emac_dma_flag_get()

flag_status emac_dma_flag_get ( uint32_t dma_flag )

check whether the specified emac dma flag is set or not.

Parameters
dma_flag specifies the emac dma flag to check. this parameter can be one of emac dma flag status:
  • EMAC_DMA_TI_FLAG
  • EMAC_DMA_TPS_FLAG
  • EMAC_DMA_TBU_FLAG
  • EMAC_DMA_TJT_FLAG
  • EMAC_DMA_OVF_FLAG
  • EMAC_DMA_UNF_FLAG
  • EMAC_DMA_RI_FLAG
  • EMAC_DMA_RBU_FLAG
  • EMAC_DMA_RPS_FLAG
  • EMAC_DMA_RWT_FLAG
  • EMAC_DMA_ETI_FLAG
  • EMAC_DMA_FBEI_FLAG
  • EMAC_DMA_ERI_FLAG
  • EMAC_DMA_AIS_FLAG
  • EMAC_DMA_NIS_FLAG
Return values
the new state of dma_flag (SET or RESET).

Definition at line 2259 of file at32f435_437_emac.c.

◆ emac_dma_interrupt_enable()

void emac_dma_interrupt_enable | ( | emac_dma_interrupt_type | it,
 |  | confirm_state | new_state
 | ) |  |

enable dma interrupt

Parameters
it interrupt type this parameter can be one of the following values:
  • EMAC_DMA_INTERRUPT_TX
  • EMAC_DMA_INTERRUPT_TX_STOP
  • EMAC_DMA_INTERRUPT_TX_UNAVAILABLE
  • EMAC_DMA_INTERRUPT_TX_JABBER
  • EMAC_DMA_INTERRUPT_RX_OVERFLOW
  • EMAC_DMA_INTERRUPT_TX_UNDERFLOW
  • EMAC_DMA_INTERRUPT_RX
  • EMAC_DMA_INTERRUPT_RX_UNAVAILABLE
  • EMAC_DMA_INTERRUPT_RX_STOP
  • EMAC_DMA_INTERRUPT_RX_TIMEOUT
  • EMAC_DMA_INTERRUPT_TX_EARLY
  • EMAC_DMA_INTERRUPT_FATAL_BUS_ERROR
  • EMAC_DMA_INTERRUPT_RX_EARLY
  • EMAC_DMA_INTERRUPT_ABNORMAL_SUMMARY
  • EMAC_DMA_INTERRUPT_NORMAL_SUMMARY
new_state TRUE or FALSE
Return values
none

Definition at line 1497 of file at32f435_437_emac.c.

Referenced by emac_layer2_configuration().

◆ emac_dma_missing_overflow_bit_get()

uint8_t emac_dma_missing_overflow_bit_get ( void )

get overflow bit for missed frame counter

Parameters
none
Return values
overflow bit for missed frame counter

Definition at line 1595 of file at32f435_437_emac.c.

◆ emac_dma_operations_set()

void emac_dma_operations_set | ( | emac_dma_operations_type | ops,
 |  | confirm_state | new_state
 | ) |  |

set dma operations

Parameters
ops operations of dma this parameter can be one of the following values:
  • EMAC_DMA_OPS_START_STOP_RECEIVE
  • EMAC_DMA_OPS_SECOND_FRAME
  • EMAC_DMA_OPS_FORWARD_UNDERSIZED
  • EMAC_DMA_OPS_FORWARD_ERROR
  • EMAC_DMA_OPS_START_STOP_TRANSMIT
  • EMAC_DMA_OPS_FLUSH_TRANSMIT_FIFO
  • EMAC_DMA_OPS_TRANSMIT_STORE_FORWARD
  • EMAC_DMA_OPS_RECEIVE_FLUSH_DISABLE
  • EMAC_DMA_OPS_RECEIVE_STORE_FORWARD
  • EMAC_DMA_OPS_DROP_ERROR_DISABLE
new_state TRUE or FALSE
Return values
none

Definition at line 1371 of file at32f435_437_emac.c.

Referenced by emac_start(), emac_stop(), emac_wake_on_lan_init(), and EMAC_WKUP_IRQHandler().

◆ emac_dma_para_init()

void emac_dma_para_init ( emac_dma_config_type * control_para )

init emac dma parameters

Parameters
emac_dma_config_type
Return values
none

Definition at line 1073 of file at32f435_437_emac.c.

Referenced by emac_layer2_configuration().

◆ emac_dma_poll_demand_get()

uint32_t emac_dma_poll_demand_get ( emac_dma_tx_rx_type transfer_type )

get transmit poll demand

Parameters
transfer_type it will be transmit or receive this parameter can be one of the following values:
  • EMAC_DMA_TRANSMIT
  • EMAC_DMA_RECEIVE
Return values
current transmit descriptor

Definition at line 1238 of file at32f435_437_emac.c.

◆ emac_dma_poll_demand_set()

void emac_dma_poll_demand_set | ( | emac_dma_tx_rx_type | transfer_type,
 |  | uint32_t | value
 | ) |  |

set transmit/receive poll demand

Parameters
transfer_type it will be transmit or receive this parameter can be one of the following values:
  • EMAC_DMA_TRANSMIT
  • EMAC_DMA_RECEIVE
value it can be any number
Return values
none

Definition at line 1213 of file at32f435_437_emac.c.

◆ emac_dma_receive_status_get()

emac_dma_receive_process_status_type emac_dma_receive_status_get ( void )

get receive dma process status

Parameters
none
Return values
every situation it describe in RM this parameter can be one of the following values:
  • EMAC_DMA_RX_RESET_STOP_COMMAND
  • EMAC_DMA_RX_FETCH_DESCRIPTOR
  • EMAC_DMA_RX_WAITING_PACKET
  • EMAC_DMA_RX_DESCRIPTOR_UNAVAILABLE
  • EMAC_DMA_RX_CLOSE_DESCRIPTOR
  • EMAC_DMA_RX_FIFO_TO_HOST

Definition at line 1266 of file at32f435_437_emac.c.

◆ emac_dma_receive_threshold_set()

void emac_dma_receive_threshold_set ( emac_dma_receive_threshold_type value )

set receive dma threshold

Parameters
value receive threshold this parameter can be one of the following values:
  • EMAC_DMA_RX_THRESHOLD_64_BYTES
  • EMAC_DMA_RX_THRESHOLD_32_BYTES
  • EMAC_DMA_RX_THRESHOLD_96_BYTES
  • EMAC_DMA_RX_THRESHOLD_128_BYTES
Return values
none

Definition at line 1451 of file at32f435_437_emac.c.

◆ emac_dma_rx_desc_interrupt_config()

void emac_dma_rx_desc_interrupt_config | ( | emac_dma_desc_type * | dma_rx_desc,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified dma rx descriptor receive interrupt

Parameters
dma_rx_desc pointer on a rx desc.
new_state new state of the specified dma rx descriptor interrupt. this parameter can be one of the following values:
  • TRUE
  • FALSE.
Return values
none

< disable interrupt on completion

< disable interrupt on completion

Definition at line 1001 of file at32f435_437_emac.c.

◆ emac_dma_separate_pbl_set()

void emac_dma_separate_pbl_set | ( | emac_dma_pbl_type | tx_length,
 |  | emac_dma_pbl_type | rx_length,
 |  | confirm_state | new_state
 | ) |  |

set programmable burst length

Parameters
tx_length tx programmable burst length this parameter can be one of the following values:
  • EMAC_DMA_PBL_1
  • EMAC_DMA_PBL_2
  • EMAC_DMA_PBL_4
  • EMAC_DMA_PBL_8
  • EMAC_DMA_PBL_16
  • EMAC_DMA_PBL_32
rx_length rx programmable burst length this parameter can be one of the following values:
  • EMAC_DMA_PBL_1
  • EMAC_DMA_PBL_2
  • EMAC_DMA_PBL_4
  • EMAC_DMA_PBL_8
  • EMAC_DMA_PBL_16
  • EMAC_DMA_PBL_32
new_state TRUE or FALSE
Return values
none

Definition at line 1173 of file at32f435_437_emac.c.

◆ emac_dma_software_reset_get()

flag_status emac_dma_software_reset_get ( void )

get emac dma reset status

Parameters
none
Return values
TRUE of FALSE

Definition at line 166 of file at32f435_437_emac.c.

Referenced by emac_layer2_configuration().

◆ emac_dma_software_reset_set()

void emac_dma_software_reset_set ( void )

reset emac dma

Parameters
none
Return values
none

Definition at line 156 of file at32f435_437_emac.c.

Referenced by emac_layer2_configuration().

◆ emac_dma_tansfer_address_get()

uint32_t emac_dma_tansfer_address_get ( emac_dma_transfer_address_type transfer_type )

get overflow bit for FIFO overflow counter

Parameters
transfer type: receive/transmit type this parameter can be one of the following values:
  • EMAC_DMA_TX_DESCRIPTOR
  • EMAC_DMA_RX_DESCRIPTOR
  • EMAC_DMA_TX_BUFFER
  • EMAC_DMA_RX_BUFFER
Return values
memory address

Definition at line 1633 of file at32f435_437_emac.c.

◆ emac_dma_transmit_status_get()

emac_dma_transmit_process_status_type emac_dma_transmit_status_get ( void )

get transmit dma process status

Parameters
none
Return values
every situation it describe in RM this parameter can be one of the following values:
  • EMAC_DMA_TX_RESET_STOP_COMMAND
  • EMAC_DMA_TX_FETCH_DESCRIPTOR
  • EMAC_DMA_TX_WAITING_FOR_STATUS
  • EMAC_DMA_TX_HOST_TO_FIFO
  • EMAC_DMA_TX_DESCRIPTOR_UNAVAILABLE
  • EMAC_DMA_TX_CLOSE_DESCRIPTOR

Definition at line 1316 of file at32f435_437_emac.c.

◆ emac_dma_transmit_threshold_set()

void emac_dma_transmit_threshold_set ( emac_dma_transmit_threshold_type value )

set transmit dma threshold

Parameters
value transmit threshold this parameter can be one of the following values:
  • EMAC_DMA_TX_THRESHOLD_64_BYTES
  • EMAC_DMA_TX_THRESHOLD_128_BYTES
  • EMAC_DMA_TX_THRESHOLD_192_BYTES
  • EMAC_DMA_TX_THRESHOLD_256_BYTES
  • EMAC_DMA_TX_THRESHOLD_40_BYTES
  • EMAC_DMA_TX_THRESHOLD_32_BYTES
  • EMAC_DMA_TX_THRESHOLD_24_BYTES
  • EMAC_DMA_TX_THRESHOLD_16_BYTES
Return values
none

Definition at line 1470 of file at32f435_437_emac.c.

◆ emac_dmarxdesc_frame_length_get()

uint32_t emac_dmarxdesc_frame_length_get ( emac_dma_desc_type * dma_rx_desc )

get the specified dma rx descsriptor frame length.

Parameters
dma_rx_desc pointer on a dma rx descriptor
Return values
the rx descriptor received frame length.

< receive descriptor frame length

Definition at line 1063 of file at32f435_437_emac.c.

Referenced by emac_received_packet_size_get().

◆ emac_dstaddr_inverse_filter_set()

void emac_dstaddr_inverse_filter_set ( confirm_state new_state )

destination address inverse filtering.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 503 of file at32f435_437_emac.c.

◆ emac_duplex_mode_set()

void emac_duplex_mode_set ( emac_duplex_type duplex_mode )

set duplex mode.

Parameters
duplex_mode communication mode this parameter can be one of the following values:
  • EMAC_HALF_DUPLEX
  • EMAC_FULL_DUPLEX
Return values
none

Definition at line 463 of file at32f435_437_emac.c.

Referenced by emac_speed_config().

◆ emac_fast_speed_set()

void emac_fast_speed_set ( emac_speed_type speed )

set mac fast emac speed.

Parameters
speed mac bandwidth this parameter can be one of the following values:
  • EMAC_SPEED_10MBPS
  • EMAC_SPEED_100MBPS
Return values
none

Definition at line 450 of file at32f435_437_emac.c.

Referenced by emac_speed_config().

◆ emac_fcb_bpa_set()

void emac_fcb_bpa_set ( confirm_state new_state )

set flow control busy in full-duplex mode, back pressure activate in half-duplex mode.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 632 of file at32f435_437_emac.c.

◆ emac_global_unicast_set()

void emac_global_unicast_set ( confirm_state new_state )

set unicast frame that passes DAF as wakeup frame.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 811 of file at32f435_437_emac.c.

◆ emac_hash_multicast_set()

void emac_hash_multicast_set ( confirm_state new_state )

hash multicast.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 493 of file at32f435_437_emac.c.

◆ emac_hash_perfect_filter_set()

void emac_hash_perfect_filter_set ( confirm_state new_state )

mac uses hash or perfect filter.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 567 of file at32f435_437_emac.c.

◆ emac_hash_table_high32bits_set()

void emac_hash_table_high32bits_set ( uint32_t high32bits )

hash table high 32-bit.

Parameters
high32bits the highest 32-bit of hash table.
Return values
none

Definition at line 587 of file at32f435_437_emac.c.

◆ emac_hash_table_low32bits_set()

void emac_hash_table_low32bits_set ( uint32_t low32bits )

hash table low 32-bit.

Parameters
low32bits the lowest 32-bit of hash table.
Return values
none

Definition at line 597 of file at32f435_437_emac.c.

◆ emac_hash_unicast_set()

void emac_hash_unicast_set ( confirm_state new_state )

hash unicast.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 483 of file at32f435_437_emac.c.

◆ emac_interframe_gap_set()

void emac_interframe_gap_set ( emac_intergrame_gap_type number )

set minimum interframe gap between frames during transmission.

Parameters
number interframe gap number. this parameter can be one of the following values:
  • EMAC_FRAME_GAP_96BIT
  • EMAC_FRAME_GAP_88BIT
  • EMAC_FRAME_GAP_80BIT
  • EMAC_FRAME_GAP_72BIT
  • EMAC_FRAME_GAP_64BIT
  • EMAC_FRAME_GAP_56BIT
  • EMAC_FRAME_GAP_48BIT
  • EMAC_FRAME_GAP_40BIT
Return values
none

Definition at line 417 of file at32f435_437_emac.c.

Referenced by emac_control_config().

◆ emac_interrupt_mask_set()

void emac_interrupt_mask_set | ( | emac_interrupt_mask_type | mask_type,
 |  | confirm_state | new_state
 | ) |  |

set interrupt mask

Parameters
mask_type mask the interrupt signal this parameter can be one of the following values:
  • EMAC_INTERRUPT_PMT_MASK
  • EMAC_INTERRUPT_TST_MASK
new_state TRUE or FALSE.
Return values
none

Definition at line 858 of file at32f435_437_emac.c.

◆ emac_interrupt_status_read()

flag_status emac_interrupt_status_read ( uint32_t flag )

read interrupt status

Parameters
flag specifies the flag to check. this parameter can be one of the following values:
  • EMAC_PMT_FLAG
  • EMAC_MMC_FLAG
  • EMAC_MMCR_FLAG
  • EMAC_MMCT_FLAG
  • EMAC_TST_FLAG
Return values
the new state of usart_flag (SET or RESET).

Definition at line 837 of file at32f435_437_emac.c.

◆ emac_ipv4_checksum_offload_set()

void emac_ipv4_checksum_offload_set ( confirm_state new_state )

set ipv4 checksum offload.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 368 of file at32f435_437_emac.c.

Referenced by emac_control_config().

◆ emac_jabber_disable()

void emac_jabber_disable ( confirm_state new_state )

jabber disable.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 427 of file at32f435_437_emac.c.

Referenced by emac_control_config().

◆ emac_local_address_set()

void emac_local_address_set ( uint8_t * address )

set local mac address

Parameters
address local address for mac0
Return values
none

Definition at line 880 of file at32f435_437_emac.c.

◆ emac_loopback_mode_enable()

void emac_loopback_mode_enable ( confirm_state new_state )

enable loopback mode.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 378 of file at32f435_437_emac.c.

Referenced by emac_control_config().

◆ emac_magic_packet_enable()

void emac_magic_packet_enable ( confirm_state new_state )

magic packet enable

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 757 of file at32f435_437_emac.c.

Referenced by emac_wake_on_lan_init().

◆ emac_mii_busy_get()

flag_status emac_mii_busy_get ( void )

mii busy status.

Parameters
none
Return values
SET or RESET

Definition at line 607 of file at32f435_437_emac.c.

◆ emac_mii_write()

void emac_mii_write ( confirm_state new_state )

tell phy that will be written.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 622 of file at32f435_437_emac.c.

◆ emac_mmc_counter_freeze()

void emac_mmc_counter_freeze ( confirm_state new_state )

freeze mmc counter

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1698 of file at32f435_437_emac.c.

◆ emac_mmc_counter_reset()

void emac_mmc_counter_reset ( void )

reset all counter

Parameters
none
Return values
none

Definition at line 1668 of file at32f435_437_emac.c.

◆ emac_mmc_received_error_frames_get()

uint32_t emac_mmc_received_error_frames_get ( uint32_t flag )

get good frame numbers as single collision occurs.

Parameters
flag specifies the flag to check. this parameter can be one of the following values:
  • MMC_RX_CRC_ERROR
  • MMC_RX_ALIGN_ERROR
  • MMC_RX_GOOD_UNICAST
Return values
good frames

< mmc error flag of rx unicast good frames

< mmc error flag of rx crc

< mmc error flag of rx alignment

< mmc error flag of rx unicast good frames

Definition at line 1852 of file at32f435_437_emac.c.

◆ emac_mmc_received_interrupt_mask_set()

void emac_mmc_received_interrupt_mask_set | ( | uint32_t | flag,
 |  | confirm_state | new_state
 | ) |  |

mask received mmc interrupt

Parameters
flag specifies the flag to check. this parameter can be one of the following values:
  • MMC_RX_CRC_ERROR
  • MMC_RX_ALIGN_ERROR
  • MMC_RX_GOOD_UNICAST
new_state TRUE or FALSE.
Return values
none

< mmc error flag of rx crc

< mmc error flag of rx alignment

< mmc error flag of rx unicast good frames

Definition at line 1755 of file at32f435_437_emac.c.

◆ emac_mmc_received_status_get()

flag_status emac_mmc_received_status_get ( uint32_t flag )

interupt status of received frames

Parameters
flag specifies the flag to check. this parameter can be one of the following values:
  • MMC_RX_CRC_ERROR
  • MMC_RX_ALIGN_ERROR
  • MMC_RX_GOOD_UNICAST
Return values
the new state of usart_flag (SET or RESET).

Definition at line 1712 of file at32f435_437_emac.c.

◆ emac_mmc_reset_on_read_enable()

void emac_mmc_reset_on_read_enable ( confirm_state new_state )

enable reset on read

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1688 of file at32f435_437_emac.c.

◆ emac_mmc_rollover_stop()

void emac_mmc_rollover_stop ( confirm_state new_state )

counter stop counting from zero when it reaches maximum

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1678 of file at32f435_437_emac.c.

◆ emac_mmc_transmit_good_frames_get()

uint32_t emac_mmc_transmit_good_frames_get ( uint32_t flag )

get good frame numbers as single collision occurs.

Parameters
flag specifies the flag to check. this parameter can be one of the following values:
  • MMC_TX_SINGLE_COL
  • MMC_TX_MULTIPLE_COL
  • MMC_TX_GOOD_FRAMES
Return values
good frames

< mmc error flag of tx good frames

< mmc error flag of tx single collision

< mmc error flag of tx multiple collision

< mmc error flag of tx good frames

Definition at line 1818 of file at32f435_437_emac.c.

◆ emac_mmc_transmit_interrupt_mask_set()

void emac_mmc_transmit_interrupt_mask_set | ( | uint32_t | flag,
 |  | confirm_state | new_state
 | ) |  |

mask transmit mmc interrupt

Parameters
transmit_type transmit type. this parameter can be one of the following values:
  • MMC_TX_SINGLE_COL
  • MMC_TX_MULTIPLE_COL
  • MMC_TX_GOOD_FRAMES
new_state TRUE or FALSE.
Return values
none

< mmc error flag of tx single collision

< mmc error flag of tx multiple collision

< mmc error flag of tx good frames

Definition at line 1787 of file at32f435_437_emac.c.

◆ emac_mmc_transmit_status_get()

flag_status emac_mmc_transmit_status_get ( uint32_t flag )

interupt status of transmit frames

Parameters
transmit_type transmit type. this parameter can be one of the following values:
  • MMC_TX_SINGLE_COL
  • MMC_TX_MULTIPLE_COL
  • MMC_TX_GOOD_FRAMES
Return values
the new state of usart_flag (SET or RESET).

Definition at line 1733 of file at32f435_437_emac.c.

◆ emac_pass_all_multicasting_set()

void emac_pass_all_multicasting_set ( confirm_state new_state )

pass all multicasting frames.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 513 of file at32f435_437_emac.c.

◆ emac_pass_control_frames_set()

void emac_pass_control_frames_set ( emac_control_frames_filter_type condition )

set mac how to pass control frames.

Parameters
condition set what control frame can pass filter. this parameter can be one of the following values:
  • EMAC_CONTROL_FRAME_PASSING_NO
  • EMAC_CONTROL_FRAME_PASSING_ALL
  • EMAC_CONTROL_FRAME_PASSING_MATCH
Return values
none

Definition at line 537 of file at32f435_437_emac.c.

◆ emac_pause_low_threshold_set()

void emac_pause_low_threshold_set ( emac_pause_slot_threshold_type pasue_threshold )

set pause low threshold.

Parameters
pasue_threshold pause slot time. this parameter can be one of the following values:
  • EMAC_PAUSE_4_SLOT_TIME
  • EMAC_PAUSE_28_SLOT_TIME
  • EMAC_PAUSE_144_SLOT_TIME
  • EMAC_PAUSE_256_SLOT_TIME
Return values
none

Definition at line 677 of file at32f435_437_emac.c.

◆ emac_pause_time_set()

void emac_pause_time_set ( uint16_t pause_time )

set pause time.

Parameters
pause_time time slots to pause transmit frame.
Return values
none

Definition at line 697 of file at32f435_437_emac.c.

◆ emac_phy_register_read()

error_status emac_phy_register_read | ( | uint8_t | address,
 |  | uint8_t | reg,
 |  | uint16_t * | data
 | ) |  |

read phy data

Parameters
address | phy address.
reg | register of phy.
data | value that is read from phy.
Return values
SUCCESS or ERROR

< timeout for phy response

< timeout for phy response

Definition at line 262 of file at32f435_437_emac.c.

Referenced by emac_phy_register_reset(), emac_speed_config(), and link_update().

◆ emac_phy_register_write()

error_status emac_phy_register_write | ( | uint8_t | address,
 |  | uint8_t | reg,
 |  | uint16_t | data
 | ) |  |

write phy data.

Parameters
address | phy address.
reg | register of phy.
data | value that wants to write to phy.
Return values
SUCCESS or ERROR

< timeout for phy response

< timeout for phy response

Definition at line 232 of file at32f435_437_emac.c.

Referenced by emac_phy_register_reset(), and emac_speed_config().

◆ emac_power_down_set()

void emac_power_down_set ( confirm_state new_state )

all frame will be droppped except wakeup frame or magic packet.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 747 of file at32f435_437_emac.c.

Referenced by emac_wake_on_lan_init(), and EMAC_WKUP_IRQHandler().

◆ emac_promiscuous_mode_set()

void emac_promiscuous_mode_set ( confirm_state new_state )

set mac promiscuous mode.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 473 of file at32f435_437_emac.c.

◆ emac_ptp_addend_register_update()

void emac_ptp_addend_register_update ( confirm_state new_state )

update timestamp addend register.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1932 of file at32f435_437_emac.c.

◆ emac_ptp_clock_node_set()

void emac_ptp_clock_node_set ( emac_ptp_clock_node_type node )

set clock node type

Parameters
node select ptp packets for taking snapshot this parameter can be one of the following values:
  • EMAC_PTP_NORMAL_CLOCK
  • EMAC_PTP_BOUNDARY_CLOCK
  • EMAC_PTP_END_TO_END_CLOCK
  • EMAC_PTP_PEER_TO_PEER_CLOCK
Return values
none

Definition at line 2027 of file at32f435_437_emac.c.

◆ emac_ptp_interrupt_trigger_enable()

void emac_ptp_interrupt_trigger_enable ( confirm_state new_state )

enable timestamp interrupt trigger.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1922 of file at32f435_437_emac.c.

◆ emac_ptp_mac_address_filter_enable()

void emac_ptp_mac_address_filter_enable ( confirm_state new_state )

enable ptp frame filtering mac address

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 2037 of file at32f435_437_emac.c.

◆ emac_ptp_pps_frequency_set()

void emac_ptp_pps_frequency_set ( emac_ptp_pps_control_type freq )

set pps frequency

Parameters
freq pps frequency this parameter can be one of the following values:
  • EMAC_PTP_PPS_1HZ
  • EMAC_PTP_PPS_2HZ
  • EMAC_PTP_PPS_4HZ
  • EMAC_PTP_PPS_8HZ
  • EMAC_PTP_PPS_16HZ
  • EMAC_PTP_PPS_32HZ
  • EMAC_PTP_PPS_64HZ
  • EMAC_PTP_PPS_128HZ
  • EMAC_PTP_PPS_256HZ
  • EMAC_PTP_PPS_512HZ
  • EMAC_PTP_PPS_1024HZ
  • EMAC_PTP_PPS_2048HZ
  • EMAC_PTP_PPS_4096HZ
  • EMAC_PTP_PPS_8192HZ
  • EMAC_PTP_PPS_16384HZ
  • EMAC_PTP_PPS_32768HZ
Return values
none

Definition at line 2218 of file at32f435_437_emac.c.

◆ emac_ptp_psv2_enable()

void emac_ptp_psv2_enable ( confirm_state new_state )

enable packet snooping for version 2.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1962 of file at32f435_437_emac.c.

◆ emac_ptp_snapshot_emac_frames_enable()

void emac_ptp_snapshot_emac_frames_enable ( confirm_state new_state )

enable snapshot over emac.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1972 of file at32f435_437_emac.c.

◆ emac_ptp_snapshot_event_message_enable()

void emac_ptp_snapshot_event_message_enable ( confirm_state new_state )

enable snapshot for event message.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 2002 of file at32f435_437_emac.c.

◆ emac_ptp_snapshot_ipv4_frames_enable()

void emac_ptp_snapshot_ipv4_frames_enable ( confirm_state new_state )

enable snapshot for ipv4 frames.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1992 of file at32f435_437_emac.c.

◆ emac_ptp_snapshot_ipv6_frames_enable()

void emac_ptp_snapshot_ipv6_frames_enable ( confirm_state new_state )

enable snapshot for ipv6 frames.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1982 of file at32f435_437_emac.c.

◆ emac_ptp_snapshot_master_event_enable()

void emac_ptp_snapshot_master_event_enable ( confirm_state new_state )

enable snapshot for message relevant to master

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 2012 of file at32f435_437_emac.c.

◆ emac_ptp_snapshot_received_frames_enable()

void emac_ptp_snapshot_received_frames_enable ( confirm_state new_state )

enable timestamp snapshot for all received frames.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1942 of file at32f435_437_emac.c.

◆ emac_ptp_subsecond_increment_set()

void emac_ptp_subsecond_increment_set ( uint8_t value )

set subsecond increment value

Parameters
value add to subsecond value for every update
Return values
none

Definition at line 2047 of file at32f435_437_emac.c.

◆ emac_ptp_subsecond_rollover_enable()

void emac_ptp_subsecond_rollover_enable ( confirm_state new_state )

enable digital rollover.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1952 of file at32f435_437_emac.c.

◆ emac_ptp_system_second_get()

uint32_t emac_ptp_system_second_get ( void )

get system time second

Parameters
none
Return values
system time second

Definition at line 2057 of file at32f435_437_emac.c.

◆ emac_ptp_system_second_set()

void emac_ptp_system_second_set ( uint32_t second )

set system time second

Parameters
second system time second
Return values
none

Definition at line 2096 of file at32f435_437_emac.c.

◆ emac_ptp_system_subsecond_get()

uint32_t emac_ptp_system_subsecond_get ( void )

get system time subsecond

Parameters
none
Return values
system time subsecond

Definition at line 2068 of file at32f435_437_emac.c.

◆ emac_ptp_system_subsecond_set()

void emac_ptp_system_subsecond_set ( uint32_t subsecond )

set system time subsecond

Parameters
subsecond system time subsecond
Return values
none

Definition at line 2106 of file at32f435_437_emac.c.

◆ emac_ptp_system_time_sign_get()

confirm_state emac_ptp_system_time_sign_get ( void )

get system time sign

Parameters
none
Return values
TRUE or FALSE

Definition at line 2079 of file at32f435_437_emac.c.

◆ emac_ptp_system_time_sign_set()

void emac_ptp_system_time_sign_set ( confirm_state sign )

set system time sign

Parameters
sign TRUE or FALSE.
Return values
none

Definition at line 2116 of file at32f435_437_emac.c.

◆ emac_ptp_target_nanosecond_set()

void emac_ptp_target_nanosecond_set ( uint32_t value )

set target time stamp low

Parameters
value to set target time nanosecond
Return values
none

Definition at line 2153 of file at32f435_437_emac.c.

◆ emac_ptp_target_second_set()

void emac_ptp_target_second_set ( uint32_t value )

set target time stamp high

Parameters
value to set target time second
Return values
none

Definition at line 2143 of file at32f435_437_emac.c.

◆ emac_ptp_timestamp_addend_set()

void emac_ptp_timestamp_addend_set ( uint32_t value )

set time stamp addend

Parameters
value to achieve time synchronization
Return values
none

Definition at line 2133 of file at32f435_437_emac.c.

◆ emac_ptp_timestamp_enable()

void emac_ptp_timestamp_enable ( confirm_state new_state )

enable timestamp.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1882 of file at32f435_437_emac.c.

◆ emac_ptp_timestamp_fine_update_enable()

void emac_ptp_timestamp_fine_update_enable ( confirm_state new_state )

enable timestamp fine update.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1892 of file at32f435_437_emac.c.

◆ emac_ptp_timestamp_status_get()

confirm_state emac_ptp_timestamp_status_get ( emac_ptp_timestamp_status_type status )

set target time stamp low

Parameters
status type of status this parameter can be one of the following values:
  • EMAC_PTP_SECOND_OVERFLOW
  • EMAC_PTP_TARGET_TIME_REACH
Return values
TRUE or FALSE

Definition at line 2166 of file at32f435_437_emac.c.

◆ emac_ptp_timestamp_system_time_init()

void emac_ptp_timestamp_system_time_init ( confirm_state new_state )

initialize timestamp time system.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1902 of file at32f435_437_emac.c.

◆ emac_ptp_timestamp_system_time_update()

void emac_ptp_timestamp_system_time_update ( confirm_state new_state )

update timestamp time system.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1912 of file at32f435_437_emac.c.

◆ emac_receive_all_set()

void emac_receive_all_set ( confirm_state new_state )

mac receives all frames.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 577 of file at32f435_437_emac.c.

◆ emac_receive_flow_control_enable()

void emac_receive_flow_control_enable ( confirm_state new_state )

set receive flow control.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 652 of file at32f435_437_emac.c.

◆ emac_receive_own_disable()

void emac_receive_own_disable ( confirm_state new_state )

receive own disable.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 388 of file at32f435_437_emac.c.

Referenced by emac_control_config().

◆ emac_received_magic_packet_get()

flag_status emac_received_magic_packet_get ( void )

received magic packet

Parameters
none
Return values
the new state of usart_flag (SET or RESET).

Definition at line 777 of file at32f435_437_emac.c.

◆ emac_received_packet_size_get()

uint32_t emac_received_packet_size_get ( void )

get the size of received the received packet.

Parameters
none
Return values
received packet size

< own bit: descriptor is owned by dma engine

< error summary: or of the following bits: ue || ED || EC || LCO || NC || LCA || FF || JT

< last descriptor of the frame

< first descriptor of the frame

Definition at line 1044 of file at32f435_437_emac.c.

Referenced by EMAC_IRQHandler().

◆ emac_received_wakeup_frame_get()

flag_status emac_received_wakeup_frame_get ( void )

received wakeup frame.

Parameters
none
Return values
the new state of usart_flag (SET or RESET).

Definition at line 794 of file at32f435_437_emac.c.

◆ emac_receiver_enable()

void emac_receiver_enable ( confirm_state new_state )

emac receiver enable.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 291 of file at32f435_437_emac.c.

Referenced by emac_start(), emac_stop(), and emac_wake_on_lan_init().

◆ emac_reset()

void emac_reset ( void )

deinitialize the emac peripheral registers to their default reset values.

Parameters
none
Return values
none

Definition at line 59 of file at32f435_437_emac.c.

Referenced by emac_layer2_configuration().

◆ emac_retry_disable()

void emac_retry_disable ( confirm_state new_state )

transmittion retry disable.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 358 of file at32f435_437_emac.c.

Referenced by emac_control_config().

◆ emac_srcaddr_filter_set()

void emac_srcaddr_filter_set ( confirm_state new_state )

source address filtering.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 557 of file at32f435_437_emac.c.

◆ emac_srcaddr_inverse_filter_set()

void emac_srcaddr_inverse_filter_set ( confirm_state new_state )

source address inverse filtering.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 547 of file at32f435_437_emac.c.

◆ emac_start()

void emac_start ( void )

enable emac and dma reception/transmission

Parameters
none
Return values
none

Definition at line 183 of file at32f435_437_emac.c.

Referenced by ethernetif_update_config().

◆ emac_stop()

void emac_stop ( void )

stop emac and dma reception/transmission

Parameters
none
Return values
none

Definition at line 206 of file at32f435_437_emac.c.

Referenced by ethernetif_update_config().

◆ emac_transmit_flow_control_enable()

void emac_transmit_flow_control_enable ( confirm_state new_state )

set transmit flow control.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 642 of file at32f435_437_emac.c.

◆ emac_trasmitter_enable()

void emac_trasmitter_enable ( confirm_state new_state )

emac transmitter enable.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 307 of file at32f435_437_emac.c.

Referenced by emac_start(), emac_stop(), emac_wake_on_lan_init(), and EMAC_WKUP_IRQHandler().

◆ emac_unicast_pause_frame_detect()

void emac_unicast_pause_frame_detect ( confirm_state new_state )

set unicast pause frame detect.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 662 of file at32f435_437_emac.c.

◆ emac_vlan_tag_comparison_set()

void emac_vlan_tag_comparison_set ( confirm_state new_state )

set 12-bit vlan identifier.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 717 of file at32f435_437_emac.c.

◆ emac_vlan_tag_identifier_set()

void emac_vlan_tag_identifier_set ( uint16_t identifier )

identify coming vlan frame field with setting value.

Parameters
identifier it will be compared with coming frame.
Return values
none

Definition at line 707 of file at32f435_437_emac.c.

◆ emac_wakeup_frame_enable()

void emac_wakeup_frame_enable ( confirm_state new_state )

wakeup frame enable

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 767 of file at32f435_437_emac.c.

◆ emac_wakeup_frame_filter_reset()

void emac_wakeup_frame_filter_reset ( confirm_state new_state )

reset wakeup frame filter resgister

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 821 of file at32f435_437_emac.c.

◆ emac_wakeup_frame_get()

uint32_t emac_wakeup_frame_get ( void )

get wakeup frame.

Parameters
none
Return values
get value from eight non transparent registers.

Definition at line 737 of file at32f435_437_emac.c.

◆ emac_wakeup_frame_set()

void emac_wakeup_frame_set ( uint32_t value )

set wakeup frame.

Parameters
value it will be written to eight non transparent registers.
Return values
none

Definition at line 727 of file at32f435_437_emac.c.

◆ emac_watchdog_disable()

void emac_watchdog_disable ( confirm_state new_state )

watchdog disable.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 437 of file at32f435_437_emac.c.

Referenced by emac_control_config().

◆ emac_zero_quanta_pause_disable()

void emac_zero_quanta_pause_disable ( confirm_state new_state )

set zero-quanta pause disable.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 687 of file at32f435_437_emac.c.


AT32F435/437 Firmwary Library: EMAC_private_functions

Functions | Variables
EMAC_private_functions
AT32F435_437_periph_driver » EMAC

Functions

static void | emac_delay (uint32_t delay)
this is delay function base on system clock. More...
void | emac_reset (void)
deinitialize the emac peripheral registers to their default reset values. More...
void | emac_control_para_init (emac_control_config_type *control_para)
initialize emac control structure More...
void | emac_clock_range_set (void)
according to hclk to set mdc clock frequency. More...
void | emac_control_config (emac_control_config_type *control_struct)
configure emac control setting. More...
void | emac_dma_software_reset_set (void)
reset emac dma More...
flag_status | emac_dma_software_reset_get (void)
get emac dma reset status More...
void | emac_start (void)
enable emac and dma reception/transmission More...
void | emac_stop (void)
stop emac and dma reception/transmission More...
error_status | emac_phy_register_write (uint8_t address, uint8_t reg, uint16_t data)
write phy data. More...
error_status | emac_phy_register_read (uint8_t address, uint8_t reg, uint16_t *data)
read phy data More...
void | emac_receiver_enable (confirm_state new_state)
emac receiver enable. More...
void | emac_trasmitter_enable (confirm_state new_state)
emac transmitter enable. More...
void | emac_deferral_check_set (confirm_state new_state)
emac defferal check enable, only avalible in half-duplex mode. More...
void | emac_backoff_limit_set (emac_bol_type slot_time)
emac back-off limit, only avalible in half-duplex mode. More...
void | emac_auto_pad_crc_stripping_set (confirm_state new_state)
set mac automatic pad/CRC stripping. More...
void | emac_retry_disable (confirm_state new_state)
transmittion retry disable. More...
void | emac_ipv4_checksum_offload_set (confirm_state new_state)
set ipv4 checksum offload. More...
void | emac_loopback_mode_enable (confirm_state new_state)
enable loopback mode. More...
void | emac_receive_own_disable (confirm_state new_state)
receive own disable. More...
void | emac_carrier_sense_disable (confirm_state new_state)
carrier sense disbale. More...
void | emac_interframe_gap_set (emac_intergrame_gap_type number)
set minimum interframe gap between frames during transmission. More...
void | emac_jabber_disable (confirm_state new_state)
jabber disable. More...
void | emac_watchdog_disable (confirm_state new_state)
watchdog disable. More...
void | emac_fast_speed_set (emac_speed_type speed)
set mac fast emac speed. More...
void | emac_duplex_mode_set (emac_duplex_type duplex_mode)
set duplex mode. More...
void | emac_promiscuous_mode_set (confirm_state new_state)
set mac promiscuous mode. More...
void | emac_hash_unicast_set (confirm_state new_state)
hash unicast. More...
void | emac_hash_multicast_set (confirm_state new_state)
hash multicast. More...
void | emac_dstaddr_inverse_filter_set (confirm_state new_state)
destination address inverse filtering. More...
void | emac_pass_all_multicasting_set (confirm_state new_state)
pass all multicasting frames. More...
void | emac_broadcast_frames_disable (confirm_state new_state)
broadcast frames disable. More...
void | emac_pass_control_frames_set (emac_control_frames_filter_type condition)
set mac how to pass control frames. More...
void | emac_srcaddr_inverse_filter_set (confirm_state new_state)
source address inverse filtering. More...
void | emac_srcaddr_filter_set (confirm_state new_state)
source address filtering. More...
void | emac_hash_perfect_filter_set (confirm_state new_state)
mac uses hash or perfect filter. More...
void | emac_receive_all_set (confirm_state new_state)
mac receives all frames. More...
void | emac_hash_table_high32bits_set (uint32_t high32bits)
hash table high 32-bit. More...
void | emac_hash_table_low32bits_set (uint32_t low32bits)
hash table low 32-bit. More...
flag_status | emac_mii_busy_get (void)
mii busy status. More...
void | emac_mii_write (confirm_state new_state)
tell phy that will be written. More...
void | emac_fcb_bpa_set (confirm_state new_state)
set flow control busy in full-duplex mode, back pressure activate in half-duplex mode. More...
void | emac_transmit_flow_control_enable (confirm_state new_state)
set transmit flow control. More...
void | emac_receive_flow_control_enable (confirm_state new_state)
set receive flow control. More...
void | emac_unicast_pause_frame_detect (confirm_state new_state)
set unicast pause frame detect. More...
void | emac_pause_low_threshold_set (emac_pause_slot_threshold_type pasue_threshold)
set pause low threshold. More...
void | emac_zero_quanta_pause_disable (confirm_state new_state)
set zero-quanta pause disable. More...
void | emac_pause_time_set (uint16_t pause_time)
set pause time. More...
void | emac_vlan_tag_identifier_set (uint16_t identifier)
identify coming vlan frame field with setting value. More...
void | emac_vlan_tag_comparison_set (confirm_state new_state)
set 12-bit vlan identifier. More...
void | emac_wakeup_frame_set (uint32_t value)
set wakeup frame. More...
uint32_t | emac_wakeup_frame_get (void)
get wakeup frame. More...
void | emac_power_down_set (confirm_state new_state)
all frame will be droppped except wakeup frame or magic packet. More...
void | emac_magic_packet_enable (confirm_state new_state)
magic packet enable More...
void | emac_wakeup_frame_enable (confirm_state new_state)
wakeup frame enable More...
flag_status | emac_received_magic_packet_get (void)
received magic packet More...
flag_status | emac_received_wakeup_frame_get (void)
received wakeup frame. More...
void | emac_global_unicast_set (confirm_state new_state)
set unicast frame that passes DAF as wakeup frame. More...
void | emac_wakeup_frame_filter_reset (confirm_state new_state)
reset wakeup frame filter resgister More...
flag_status | emac_interrupt_status_read (uint32_t flag)
read interrupt status More...
void | emac_interrupt_mask_set (emac_interrupt_mask_type mask_type, confirm_state new_state)
set interrupt mask More...
void | emac_local_address_set (uint8_t *address)
set local mac address More...
void | emac_address_filter_set (emac_address_type mac, emac_address_filter_type filter, emac_address_mask_type mask_bit, confirm_state new_state)
set mac filter address More...
void | emac_dma_descriptor_list_address_set (emac_dma_tx_rx_type transfer_type, emac_dma_desc_type *dma_desc_tab, uint8_t *buff, uint32_t buffer_count)
set transmit/receive descriptor list address More...
void | emac_dma_rx_desc_interrupt_config (emac_dma_desc_type *dma_rx_desc, confirm_state new_state)
enable or disable the specified dma rx descriptor receive interrupt More...
uint32_t | emac_dma_descriptor_list_address_get (emac_dma_tx_rx_type transfer_type)
get transmit/receive descriptor list address More...
uint32_t | emac_received_packet_size_get (void)
get the size of received the received packet. More...
uint32_t | emac_dmarxdesc_frame_length_get (emac_dma_desc_type *dma_rx_desc)
get the specified dma rx descsriptor frame length. More...
void | emac_dma_para_init (emac_dma_config_type *control_para)
init emac dma parameters More...
void | emac_dma_config (emac_dma_config_type *control_para)
configure emac dma More...
void | emac_dma_arbitation_set (emac_dma_rx_tx_ratio_type ratio, confirm_state new_state)
set rx tx priority More...
void | emac_dma_descriptor_skip_length_set (uint8_t length)
set descriptor skip mength More...
void | emac_dma_separate_pbl_set (emac_dma_pbl_type tx_length, emac_dma_pbl_type rx_length, confirm_state new_state)
set programmable burst length More...
void | emac_dma_eight_pbl_mode_set (confirm_state new_state)
set 8 times programmable burst length More...
void | emac_dma_address_aligned_beats_set (confirm_state new_state)
set address-aligned beats More...
void | emac_dma_poll_demand_set (emac_dma_tx_rx_type transfer_type, uint32_t value)
set transmit/receive poll demand More...
uint32_t | emac_dma_poll_demand_get (emac_dma_tx_rx_type transfer_type)
get transmit poll demand More...
emac_dma_receive_process_status_type | emac_dma_receive_status_get (void)
get receive dma process status More...
emac_dma_transmit_process_status_type | emac_dma_transmit_status_get (void)
get transmit dma process status More...
void | emac_dma_operations_set (emac_dma_operations_type ops, confirm_state new_state)
set dma operations More...
void | emac_dma_receive_threshold_set (emac_dma_receive_threshold_type value)
set receive dma threshold More...
void | emac_dma_transmit_threshold_set (emac_dma_transmit_threshold_type value)
set transmit dma threshold More...
void | emac_dma_interrupt_enable (emac_dma_interrupt_type it, confirm_state new_state)
enable dma interrupt More...
uint16_t | emac_dma_controller_missing_frame_get (void)
get missed frames by the controller More...
uint8_t | emac_dma_missing_overflow_bit_get (void)
get overflow bit for missed frame counter More...
uint16_t | emac_dma_application_missing_frame_get (void)
get missed frames by the application More...
uint8_t | emac_dma_fifo_overflow_bit_get (void)
get overflow bit for FIFO overflow counter More...
uint32_t | emac_dma_tansfer_address_get (emac_dma_transfer_address_type transfer_type)
get overflow bit for FIFO overflow counter More...
void | emac_mmc_counter_reset (void)
reset all counter More...
void | emac_mmc_rollover_stop (confirm_state new_state)
counter stop counting from zero when it reaches maximum More...
void | emac_mmc_reset_on_read_enable (confirm_state new_state)
enable reset on read More...
void | emac_mmc_counter_freeze (confirm_state new_state)
freeze mmc counter More...
flag_status | emac_mmc_received_status_get (uint32_t flag)
interupt status of received frames More...
flag_status | emac_mmc_transmit_status_get (uint32_t flag)
interupt status of transmit frames More...
void | emac_mmc_received_interrupt_mask_set (uint32_t flag, confirm_state new_state)
mask received mmc interrupt More...
void | emac_mmc_transmit_interrupt_mask_set (uint32_t flag, confirm_state new_state)
mask transmit mmc interrupt More...
uint32_t | emac_mmc_transmit_good_frames_get (uint32_t flag)
get good frame numbers as single collision occurs. More...
uint32_t | emac_mmc_received_error_frames_get (uint32_t flag)
get good frame numbers as single collision occurs. More...
void | emac_ptp_timestamp_enable (confirm_state new_state)
enable timestamp. More...
void | emac_ptp_timestamp_fine_update_enable (confirm_state new_state)
enable timestamp fine update. More...
void | emac_ptp_timestamp_system_time_init (confirm_state new_state)
initialize timestamp time system. More...
void | emac_ptp_timestamp_system_time_update (confirm_state new_state)
update timestamp time system. More...
void | emac_ptp_interrupt_trigger_enable (confirm_state new_state)
enable timestamp interrupt trigger. More...
void | emac_ptp_addend_register_update (confirm_state new_state)
update timestamp addend register. More...
void | emac_ptp_snapshot_received_frames_enable (confirm_state new_state)
enable timestamp snapshot for all received frames. More...
void | emac_ptp_subsecond_rollover_enable (confirm_state new_state)
enable digital rollover. More...
void | emac_ptp_psv2_enable (confirm_state new_state)
enable packet snooping for version 2. More...
void | emac_ptp_snapshot_emac_frames_enable (confirm_state new_state)
enable snapshot over emac. More...
void | emac_ptp_snapshot_ipv6_frames_enable (confirm_state new_state)
enable snapshot for ipv6 frames. More...
void | emac_ptp_snapshot_ipv4_frames_enable (confirm_state new_state)
enable snapshot for ipv4 frames. More...
void | emac_ptp_snapshot_event_message_enable (confirm_state new_state)
enable snapshot for event message. More...
void | emac_ptp_snapshot_master_event_enable (confirm_state new_state)
enable snapshot for message relevant to master More...
void | emac_ptp_clock_node_set (emac_ptp_clock_node_type node)
set clock node type More...
void | emac_ptp_mac_address_filter_enable (confirm_state new_state)
enable ptp frame filtering mac address More...
void | emac_ptp_subsecond_increment_set (uint8_t value)
set subsecond increment value More...
uint32_t | emac_ptp_system_second_get (void)
get system time second More...
uint32_t | emac_ptp_system_subsecond_get (void)
get system time subsecond More...
confirm_state | emac_ptp_system_time_sign_get (void)
get system time sign More...
void | emac_ptp_system_second_set (uint32_t second)
set system time second More...
void | emac_ptp_system_subsecond_set (uint32_t subsecond)
set system time subsecond More...
void | emac_ptp_system_time_sign_set (confirm_state sign)
set system time sign More...
void | emac_ptp_timestamp_addend_set (uint32_t value)
set time stamp addend More...
void | emac_ptp_target_second_set (uint32_t value)
set target time stamp high More...
void | emac_ptp_target_nanosecond_set (uint32_t value)
set target time stamp low More...
confirm_state emac_ptp_timestamp_status_get (emac_ptp_timestamp_status_type status)
set target time stamp low More...
void | emac_ptp_pps_frequency_set (emac_ptp_pps_control_type freq)
set pps frequency More...
flag_status | emac_dma_flag_get (uint32_t dma_flag)
check whether the specified emac dma flag is set or not. More...
void | emac_dma_flag_clear (uint32_t dma_flag)
clear the emac dma flag. More...

Variables

emac_dma_desc_type * dma_tx_desc_to_set
global pointers on tx and rx descriptor used to track transmit and receive descriptors More...
emac_dma_desc_type * dma_rx_desc_to_get

Detailed Description

Function Documentation

◆ emac_address_filter_set()

void emac_address_filter_set | ( | emac_address_type | mac,
 |  | emac_address_filter_type | filter,
 |  | emac_address_mask_type | mask_bit,
 |  | confirm_state | new_state
 | ) |  |

set mac filter address

Parameters
mac select which mac you want to set this parameter can be one of the following values:
  • EMAC_ADDRESS_FILTER_1
  • EMAC_ADDRESS_FILTER_2
  • EMAC_ADDRESS_FILTER_3
Return values
none

Definition at line 895 of file at32f435_437_emac.c.

◆ emac_auto_pad_crc_stripping_set()

void emac_auto_pad_crc_stripping_set ( confirm_state new_state )

set mac automatic pad/CRC stripping.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 348 of file at32f435_437_emac.c.

Referenced by emac_control_config().

◆ emac_backoff_limit_set()

void emac_backoff_limit_set ( emac_bol_type slot_time )

emac back-off limit, only avalible in half-duplex mode.

Parameters
slot_time waiting time of retransmission after collision this parameter can be one of the following values:
  • EMAC_BACKOFF_LIMIT_0
  • EMAC_BACKOFF_LIMIT_1
  • EMAC_BACKOFF_LIMIT_2
  • EMAC_BACKOFF_LIMIT_3
Return values
none

Definition at line 338 of file at32f435_437_emac.c.

Referenced by emac_control_config().

◆ emac_broadcast_frames_disable()

void emac_broadcast_frames_disable ( confirm_state new_state )

broadcast frames disable.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 523 of file at32f435_437_emac.c.

◆ emac_carrier_sense_disable()

void emac_carrier_sense_disable ( confirm_state new_state )

carrier sense disbale.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 398 of file at32f435_437_emac.c.

Referenced by emac_control_config().

◆ emac_clock_range_set()

void emac_clock_range_set ( void )

according to hclk to set mdc clock frequency.

Parameters
none
Return values
none

< hclk boarder of 20 mhz

< hclk boarder of 35 mhz

< hclk boarder of 35 mhz

< hclk boarder of 60 mhz

< hclk boarder of 60 mhz

< hclk boarder of 100 mhz

< hclk boarder of 100 mhz

< hclk boarder of 150 mhz

< hclk boarder of 150 mhz

< hclk boarder of 250 mhz

< hclk boarder of 250 mhz

< hclk boarder of 288 mhz

Definition at line 93 of file at32f435_437_emac.c.

Referenced by emac_phy_init().

◆ emac_control_config()

void emac_control_config ( emac_control_config_type * control_struct )

configure emac control setting.

Parameters
control_struct control setting of mac control register.
Return values
none

Definition at line 136 of file at32f435_437_emac.c.

Referenced by emac_phy_init().

◆ emac_control_para_init()

void emac_control_para_init ( emac_control_config_type * control_para )

initialize emac control structure

Parameters
emac_control_config_type
Return values
none

Definition at line 70 of file at32f435_437_emac.c.

Referenced by emac_layer2_configuration().

◆ emac_deferral_check_set()

void emac_deferral_check_set ( confirm_state new_state )

emac defferal check enable, only avalible in half-duplex mode.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 323 of file at32f435_437_emac.c.

Referenced by emac_control_config().

◆ emac_delay()

static void emac_delay ( uint32_t delay )
static

this is delay function base on system clock.

Parameters
delay delay time
Return values
none

Definition at line 2228 of file at32f435_437_emac.c.

Referenced by emac_dma_operations_set(), emac_receiver_enable(), and emac_trasmitter_enable().

◆ emac_dma_address_aligned_beats_set()

void emac_dma_address_aligned_beats_set ( confirm_state new_state )

set address-aligned beats

Parameters
new_state TRUE or FALSE
Return values
none

Definition at line 1199 of file at32f435_437_emac.c.

◆ emac_dma_application_missing_frame_get()

uint16_t emac_dma_application_missing_frame_get ( void )

get missed frames by the application

Parameters
none
Return values
missed frames by the application

Definition at line 1606 of file at32f435_437_emac.c.

◆ emac_dma_arbitation_set()

void emac_dma_arbitation_set | ( | emac_dma_rx_tx_ratio_type | ratio,
 |  | confirm_state | new_state
 | ) |  |

set rx tx priority

Parameters
ratio rx tx priority ratio this parameter can be one of the following values:
  • EMAC_DMA_1_RX_1_TX
  • EMAC_DMA_2_RX_1_TX
  • EMAC_DMA_3_RX_1_TX
  • EMAC_DMA_4_RX_1_TX
new_state TRUE or FALSE
Return values
none

Definition at line 1132 of file at32f435_437_emac.c.

◆ emac_dma_config()

void emac_dma_config ( emac_dma_config_type * control_para )

configure emac dma

Parameters
emac_dma_config_type
Return values
none

Definition at line 1099 of file at32f435_437_emac.c.

Referenced by emac_layer2_configuration().

◆ emac_dma_controller_missing_frame_get()

uint16_t emac_dma_controller_missing_frame_get ( void )

get missed frames by the controller

Parameters
none
Return values
missed frames by the controller

Definition at line 1584 of file at32f435_437_emac.c.

◆ emac_dma_descriptor_list_address_get()

uint32_t emac_dma_descriptor_list_address_get ( emac_dma_tx_rx_type transfer_type )

get transmit/receive descriptor list address

Parameters
transfer_type it will be transmit or receive this parameter can be one of the following values:
  • EMAC_DMA_TRANSMIT
  • EMAC_DMA_RECEIVE
Return values
transmit/receive descriptor list address

Definition at line 1023 of file at32f435_437_emac.c.

◆ emac_dma_descriptor_list_address_set()

void emac_dma_descriptor_list_address_set | ( | emac_dma_tx_rx_type | transfer_type,
 |  | emac_dma_desc_type * | dma_desc_tab,
 |  | uint8_t * | buff,
 |  | uint32_t | buffer_count
 | ) |  |

set transmit/receive descriptor list address

Parameters
transfer_type it will be transmit or receive this parameter can be one of the following values:
  • EMAC_DMA_TRANSMIT
  • EMAC_DMA_RECEIVE
dma_desc_tab | pointer on the first tx desc list
buff | pointer on the first tx/rx buffer list
buffer_count | number of the used Tx desc in the list
Return values
none

< second address chained

< emac_header + emac_extra + emac_max_payload + emac_crc

< own bit: descriptor is owned by dma engine

< second address chained

< emac_header + emac_extra + emac_max_payload + emac_crc

< emac_header + emac_extra + emac_max_payload + emac_crc

Definition at line 934 of file at32f435_437_emac.c.

◆ emac_dma_descriptor_skip_length_set()

void emac_dma_descriptor_skip_length_set ( uint8_t length )

set descriptor skip mength

Parameters
length descriptor skip length
Return values
none

Definition at line 1147 of file at32f435_437_emac.c.

◆ emac_dma_eight_pbl_mode_set()

void emac_dma_eight_pbl_mode_set ( confirm_state new_state )

set 8 times programmable burst length

Parameters
new_state TRUE or FALSE
Return values
none

Definition at line 1189 of file at32f435_437_emac.c.

◆ emac_dma_fifo_overflow_bit_get()

uint8_t emac_dma_fifo_overflow_bit_get ( void )

get overflow bit for FIFO overflow counter

Parameters
none
Return values
overflow bit for FIFO overflow counter

Definition at line 1617 of file at32f435_437_emac.c.

◆ emac_dma_flag_clear()

void emac_dma_flag_clear ( uint32_t dma_flag )

clear the emac dma flag.

Parameters
dma_flag specifies the emac dma flags to clear. this parameter can be any combination of the following values:
  • EMAC_DMA_TI_FLAG
  • EMAC_DMA_TPS_FLAG
  • EMAC_DMA_TBU_FLAG
  • EMAC_DMA_TJT_FLAG
  • EMAC_DMA_OVF_FLAG
  • EMAC_DMA_UNF_FLAG
  • EMAC_DMA_RI_FLAG
  • EMAC_DMA_RBU_FLAG
  • EMAC_DMA_RPS_FLAG
  • EMAC_DMA_RWT_FLAG
  • EMAC_DMA_ETI_FLAG
  • EMAC_DMA_FBEI_FLAG
  • EMAC_DMA_ERI_FLAG
  • EMAC_DMA_AIS_FLAG
  • EMAC_DMA_NIS_FLAG
Return values
none

Definition at line 2290 of file at32f435_437_emac.c.

Referenced by EMAC_IRQHandler().

◆ emac_dma_flag_get()

flag_status emac_dma_flag_get ( uint32_t dma_flag )

check whether the specified emac dma flag is set or not.

Parameters
dma_flag specifies the emac dma flag to check. this parameter can be one of emac dma flag status:
  • EMAC_DMA_TI_FLAG
  • EMAC_DMA_TPS_FLAG
  • EMAC_DMA_TBU_FLAG
  • EMAC_DMA_TJT_FLAG
  • EMAC_DMA_OVF_FLAG
  • EMAC_DMA_UNF_FLAG
  • EMAC_DMA_RI_FLAG
  • EMAC_DMA_RBU_FLAG
  • EMAC_DMA_RPS_FLAG
  • EMAC_DMA_RWT_FLAG
  • EMAC_DMA_ETI_FLAG
  • EMAC_DMA_FBEI_FLAG
  • EMAC_DMA_ERI_FLAG
  • EMAC_DMA_AIS_FLAG
  • EMAC_DMA_NIS_FLAG
Return values
the new state of dma_flag (SET or RESET).

Definition at line 2259 of file at32f435_437_emac.c.

◆ emac_dma_interrupt_enable()

void emac_dma_interrupt_enable | ( | emac_dma_interrupt_type | it,
 |  | confirm_state | new_state
 | ) |  |

enable dma interrupt

Parameters
it interrupt type this parameter can be one of the following values:
  • EMAC_DMA_INTERRUPT_TX
  • EMAC_DMA_INTERRUPT_TX_STOP
  • EMAC_DMA_INTERRUPT_TX_UNAVAILABLE
  • EMAC_DMA_INTERRUPT_TX_JABBER
  • EMAC_DMA_INTERRUPT_RX_OVERFLOW
  • EMAC_DMA_INTERRUPT_TX_UNDERFLOW
  • EMAC_DMA_INTERRUPT_RX
  • EMAC_DMA_INTERRUPT_RX_UNAVAILABLE
  • EMAC_DMA_INTERRUPT_RX_STOP
  • EMAC_DMA_INTERRUPT_RX_TIMEOUT
  • EMAC_DMA_INTERRUPT_TX_EARLY
  • EMAC_DMA_INTERRUPT_FATAL_BUS_ERROR
  • EMAC_DMA_INTERRUPT_RX_EARLY
  • EMAC_DMA_INTERRUPT_ABNORMAL_SUMMARY
  • EMAC_DMA_INTERRUPT_NORMAL_SUMMARY
new_state TRUE or FALSE
Return values
none

Definition at line 1497 of file at32f435_437_emac.c.

Referenced by emac_layer2_configuration().

◆ emac_dma_missing_overflow_bit_get()

uint8_t emac_dma_missing_overflow_bit_get ( void )

get overflow bit for missed frame counter

Parameters
none
Return values
overflow bit for missed frame counter

Definition at line 1595 of file at32f435_437_emac.c.

◆ emac_dma_operations_set()

void emac_dma_operations_set | ( | emac_dma_operations_type | ops,
 |  | confirm_state | new_state
 | ) |  |

set dma operations

Parameters
ops operations of dma this parameter can be one of the following values:
  • EMAC_DMA_OPS_START_STOP_RECEIVE
  • EMAC_DMA_OPS_SECOND_FRAME
  • EMAC_DMA_OPS_FORWARD_UNDERSIZED
  • EMAC_DMA_OPS_FORWARD_ERROR
  • EMAC_DMA_OPS_START_STOP_TRANSMIT
  • EMAC_DMA_OPS_FLUSH_TRANSMIT_FIFO
  • EMAC_DMA_OPS_TRANSMIT_STORE_FORWARD
  • EMAC_DMA_OPS_RECEIVE_FLUSH_DISABLE
  • EMAC_DMA_OPS_RECEIVE_STORE_FORWARD
  • EMAC_DMA_OPS_DROP_ERROR_DISABLE
new_state TRUE or FALSE
Return values
none

Definition at line 1371 of file at32f435_437_emac.c.

Referenced by emac_start(), emac_stop(), emac_wake_on_lan_init(), and EMAC_WKUP_IRQHandler().

◆ emac_dma_para_init()

void emac_dma_para_init ( emac_dma_config_type * control_para )

init emac dma parameters

Parameters
emac_dma_config_type
Return values
none

Definition at line 1073 of file at32f435_437_emac.c.

Referenced by emac_layer2_configuration().

◆ emac_dma_poll_demand_get()

uint32_t emac_dma_poll_demand_get ( emac_dma_tx_rx_type transfer_type )

get transmit poll demand

Parameters
transfer_type it will be transmit or receive this parameter can be one of the following values:
  • EMAC_DMA_TRANSMIT
  • EMAC_DMA_RECEIVE
Return values
current transmit descriptor

Definition at line 1238 of file at32f435_437_emac.c.

◆ emac_dma_poll_demand_set()

void emac_dma_poll_demand_set | ( | emac_dma_tx_rx_type | transfer_type,
 |  | uint32_t | value
 | ) |  |

set transmit/receive poll demand

Parameters
transfer_type it will be transmit or receive this parameter can be one of the following values:
  • EMAC_DMA_TRANSMIT
  • EMAC_DMA_RECEIVE
value it can be any number
Return values
none

Definition at line 1213 of file at32f435_437_emac.c.

◆ emac_dma_receive_status_get()

emac_dma_receive_process_status_type emac_dma_receive_status_get ( void )

get receive dma process status

Parameters
none
Return values
every situation it describe in RM this parameter can be one of the following values:
  • EMAC_DMA_RX_RESET_STOP_COMMAND
  • EMAC_DMA_RX_FETCH_DESCRIPTOR
  • EMAC_DMA_RX_WAITING_PACKET
  • EMAC_DMA_RX_DESCRIPTOR_UNAVAILABLE
  • EMAC_DMA_RX_CLOSE_DESCRIPTOR
  • EMAC_DMA_RX_FIFO_TO_HOST

Definition at line 1266 of file at32f435_437_emac.c.

◆ emac_dma_receive_threshold_set()

void emac_dma_receive_threshold_set ( emac_dma_receive_threshold_type value )

set receive dma threshold

Parameters
value receive threshold this parameter can be one of the following values:
  • EMAC_DMA_RX_THRESHOLD_64_BYTES
  • EMAC_DMA_RX_THRESHOLD_32_BYTES
  • EMAC_DMA_RX_THRESHOLD_96_BYTES
  • EMAC_DMA_RX_THRESHOLD_128_BYTES
Return values
none

Definition at line 1451 of file at32f435_437_emac.c.

◆ emac_dma_rx_desc_interrupt_config()

void emac_dma_rx_desc_interrupt_config | ( | emac_dma_desc_type * | dma_rx_desc,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified dma rx descriptor receive interrupt

Parameters
dma_rx_desc pointer on a rx desc.
new_state new state of the specified dma rx descriptor interrupt. this parameter can be one of the following values:
  • TRUE
  • FALSE.
Return values
none

< disable interrupt on completion

< disable interrupt on completion

Definition at line 1001 of file at32f435_437_emac.c.

◆ emac_dma_separate_pbl_set()

void emac_dma_separate_pbl_set | ( | emac_dma_pbl_type | tx_length,
 |  | emac_dma_pbl_type | rx_length,
 |  | confirm_state | new_state
 | ) |  |

set programmable burst length

Parameters
tx_length tx programmable burst length this parameter can be one of the following values:
  • EMAC_DMA_PBL_1
  • EMAC_DMA_PBL_2
  • EMAC_DMA_PBL_4
  • EMAC_DMA_PBL_8
  • EMAC_DMA_PBL_16
  • EMAC_DMA_PBL_32
rx_length rx programmable burst length this parameter can be one of the following values:
  • EMAC_DMA_PBL_1
  • EMAC_DMA_PBL_2
  • EMAC_DMA_PBL_4
  • EMAC_DMA_PBL_8
  • EMAC_DMA_PBL_16
  • EMAC_DMA_PBL_32
new_state TRUE or FALSE
Return values
none

Definition at line 1173 of file at32f435_437_emac.c.

◆ emac_dma_software_reset_get()

flag_status emac_dma_software_reset_get ( void )

get emac dma reset status

Parameters
none
Return values
TRUE of FALSE

Definition at line 166 of file at32f435_437_emac.c.

Referenced by emac_layer2_configuration().

◆ emac_dma_software_reset_set()

void emac_dma_software_reset_set ( void )

reset emac dma

Parameters
none
Return values
none

Definition at line 156 of file at32f435_437_emac.c.

Referenced by emac_layer2_configuration().

◆ emac_dma_tansfer_address_get()

uint32_t emac_dma_tansfer_address_get ( emac_dma_transfer_address_type transfer_type )

get overflow bit for FIFO overflow counter

Parameters
transfer type: receive/transmit type this parameter can be one of the following values:
  • EMAC_DMA_TX_DESCRIPTOR
  • EMAC_DMA_RX_DESCRIPTOR
  • EMAC_DMA_TX_BUFFER
  • EMAC_DMA_RX_BUFFER
Return values
memory address

Definition at line 1633 of file at32f435_437_emac.c.

◆ emac_dma_transmit_status_get()

emac_dma_transmit_process_status_type emac_dma_transmit_status_get ( void )

get transmit dma process status

Parameters
none
Return values
every situation it describe in RM this parameter can be one of the following values:
  • EMAC_DMA_TX_RESET_STOP_COMMAND
  • EMAC_DMA_TX_FETCH_DESCRIPTOR
  • EMAC_DMA_TX_WAITING_FOR_STATUS
  • EMAC_DMA_TX_HOST_TO_FIFO
  • EMAC_DMA_TX_DESCRIPTOR_UNAVAILABLE
  • EMAC_DMA_TX_CLOSE_DESCRIPTOR

Definition at line 1316 of file at32f435_437_emac.c.

◆ emac_dma_transmit_threshold_set()

void emac_dma_transmit_threshold_set ( emac_dma_transmit_threshold_type value )

set transmit dma threshold

Parameters
value transmit threshold this parameter can be one of the following values:
  • EMAC_DMA_TX_THRESHOLD_64_BYTES
  • EMAC_DMA_TX_THRESHOLD_128_BYTES
  • EMAC_DMA_TX_THRESHOLD_192_BYTES
  • EMAC_DMA_TX_THRESHOLD_256_BYTES
  • EMAC_DMA_TX_THRESHOLD_40_BYTES
  • EMAC_DMA_TX_THRESHOLD_32_BYTES
  • EMAC_DMA_TX_THRESHOLD_24_BYTES
  • EMAC_DMA_TX_THRESHOLD_16_BYTES
Return values
none

Definition at line 1470 of file at32f435_437_emac.c.

◆ emac_dmarxdesc_frame_length_get()

uint32_t emac_dmarxdesc_frame_length_get ( emac_dma_desc_type * dma_rx_desc )

get the specified dma rx descsriptor frame length.

Parameters
dma_rx_desc pointer on a dma rx descriptor
Return values
the rx descriptor received frame length.

< receive descriptor frame length

Definition at line 1063 of file at32f435_437_emac.c.

Referenced by emac_received_packet_size_get().

◆ emac_dstaddr_inverse_filter_set()

void emac_dstaddr_inverse_filter_set ( confirm_state new_state )

destination address inverse filtering.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 503 of file at32f435_437_emac.c.

◆ emac_duplex_mode_set()

void emac_duplex_mode_set ( emac_duplex_type duplex_mode )

set duplex mode.

Parameters
duplex_mode communication mode this parameter can be one of the following values:
  • EMAC_HALF_DUPLEX
  • EMAC_FULL_DUPLEX
Return values
none

Definition at line 463 of file at32f435_437_emac.c.

Referenced by emac_speed_config().

◆ emac_fast_speed_set()

void emac_fast_speed_set ( emac_speed_type speed )

set mac fast emac speed.

Parameters
speed mac bandwidth this parameter can be one of the following values:
  • EMAC_SPEED_10MBPS
  • EMAC_SPEED_100MBPS
Return values
none

Definition at line 450 of file at32f435_437_emac.c.

Referenced by emac_speed_config().

◆ emac_fcb_bpa_set()

void emac_fcb_bpa_set ( confirm_state new_state )

set flow control busy in full-duplex mode, back pressure activate in half-duplex mode.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 632 of file at32f435_437_emac.c.

◆ emac_global_unicast_set()

void emac_global_unicast_set ( confirm_state new_state )

set unicast frame that passes DAF as wakeup frame.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 811 of file at32f435_437_emac.c.

◆ emac_hash_multicast_set()

void emac_hash_multicast_set ( confirm_state new_state )

hash multicast.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 493 of file at32f435_437_emac.c.

◆ emac_hash_perfect_filter_set()

void emac_hash_perfect_filter_set ( confirm_state new_state )

mac uses hash or perfect filter.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 567 of file at32f435_437_emac.c.

◆ emac_hash_table_high32bits_set()

void emac_hash_table_high32bits_set ( uint32_t high32bits )

hash table high 32-bit.

Parameters
high32bits the highest 32-bit of hash table.
Return values
none

Definition at line 587 of file at32f435_437_emac.c.

◆ emac_hash_table_low32bits_set()

void emac_hash_table_low32bits_set ( uint32_t low32bits )

hash table low 32-bit.

Parameters
low32bits the lowest 32-bit of hash table.
Return values
none

Definition at line 597 of file at32f435_437_emac.c.

◆ emac_hash_unicast_set()

void emac_hash_unicast_set ( confirm_state new_state )

hash unicast.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 483 of file at32f435_437_emac.c.

◆ emac_interframe_gap_set()

void emac_interframe_gap_set ( emac_intergrame_gap_type number )

set minimum interframe gap between frames during transmission.

Parameters
number interframe gap number. this parameter can be one of the following values:
  • EMAC_FRAME_GAP_96BIT
  • EMAC_FRAME_GAP_88BIT
  • EMAC_FRAME_GAP_80BIT
  • EMAC_FRAME_GAP_72BIT
  • EMAC_FRAME_GAP_64BIT
  • EMAC_FRAME_GAP_56BIT
  • EMAC_FRAME_GAP_48BIT
  • EMAC_FRAME_GAP_40BIT
Return values
none

Definition at line 417 of file at32f435_437_emac.c.

Referenced by emac_control_config().

◆ emac_interrupt_mask_set()

void emac_interrupt_mask_set | ( | emac_interrupt_mask_type | mask_type,
 |  | confirm_state | new_state
 | ) |  |

set interrupt mask

Parameters
mask_type mask the interrupt signal this parameter can be one of the following values:
  • EMAC_INTERRUPT_PMT_MASK
  • EMAC_INTERRUPT_TST_MASK
new_state TRUE or FALSE.
Return values
none

Definition at line 858 of file at32f435_437_emac.c.

◆ emac_interrupt_status_read()

flag_status emac_interrupt_status_read ( uint32_t flag )

read interrupt status

Parameters
flag specifies the flag to check. this parameter can be one of the following values:
  • EMAC_PMT_FLAG
  • EMAC_MMC_FLAG
  • EMAC_MMCR_FLAG
  • EMAC_MMCT_FLAG
  • EMAC_TST_FLAG
Return values
the new state of usart_flag (SET or RESET).

Definition at line 837 of file at32f435_437_emac.c.

◆ emac_ipv4_checksum_offload_set()

void emac_ipv4_checksum_offload_set ( confirm_state new_state )

set ipv4 checksum offload.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 368 of file at32f435_437_emac.c.

Referenced by emac_control_config().

◆ emac_jabber_disable()

void emac_jabber_disable ( confirm_state new_state )

jabber disable.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 427 of file at32f435_437_emac.c.

Referenced by emac_control_config().

◆ emac_local_address_set()

void emac_local_address_set ( uint8_t * address )

set local mac address

Parameters
address local address for mac0
Return values
none

Definition at line 880 of file at32f435_437_emac.c.

◆ emac_loopback_mode_enable()

void emac_loopback_mode_enable ( confirm_state new_state )

enable loopback mode.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 378 of file at32f435_437_emac.c.

Referenced by emac_control_config().

◆ emac_magic_packet_enable()

void emac_magic_packet_enable ( confirm_state new_state )

magic packet enable

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 757 of file at32f435_437_emac.c.

Referenced by emac_wake_on_lan_init().

◆ emac_mii_busy_get()

flag_status emac_mii_busy_get ( void )

mii busy status.

Parameters
none
Return values
SET or RESET

Definition at line 607 of file at32f435_437_emac.c.

◆ emac_mii_write()

void emac_mii_write ( confirm_state new_state )

tell phy that will be written.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 622 of file at32f435_437_emac.c.

◆ emac_mmc_counter_freeze()

void emac_mmc_counter_freeze ( confirm_state new_state )

freeze mmc counter

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1698 of file at32f435_437_emac.c.

◆ emac_mmc_counter_reset()

void emac_mmc_counter_reset ( void )

reset all counter

Parameters
none
Return values
none

Definition at line 1668 of file at32f435_437_emac.c.

◆ emac_mmc_received_error_frames_get()

uint32_t emac_mmc_received_error_frames_get ( uint32_t flag )

get good frame numbers as single collision occurs.

Parameters
flag specifies the flag to check. this parameter can be one of the following values:
  • MMC_RX_CRC_ERROR
  • MMC_RX_ALIGN_ERROR
  • MMC_RX_GOOD_UNICAST
Return values
good frames

< mmc error flag of rx unicast good frames

< mmc error flag of rx crc

< mmc error flag of rx alignment

< mmc error flag of rx unicast good frames

Definition at line 1852 of file at32f435_437_emac.c.

◆ emac_mmc_received_interrupt_mask_set()

void emac_mmc_received_interrupt_mask_set | ( | uint32_t | flag,
 |  | confirm_state | new_state
 | ) |  |

mask received mmc interrupt

Parameters
flag specifies the flag to check. this parameter can be one of the following values:
  • MMC_RX_CRC_ERROR
  • MMC_RX_ALIGN_ERROR
  • MMC_RX_GOOD_UNICAST
new_state TRUE or FALSE.
Return values
none

< mmc error flag of rx crc

< mmc error flag of rx alignment

< mmc error flag of rx unicast good frames

Definition at line 1755 of file at32f435_437_emac.c.

◆ emac_mmc_received_status_get()

flag_status emac_mmc_received_status_get ( uint32_t flag )

interupt status of received frames

Parameters
flag specifies the flag to check. this parameter can be one of the following values:
  • MMC_RX_CRC_ERROR
  • MMC_RX_ALIGN_ERROR
  • MMC_RX_GOOD_UNICAST
Return values
the new state of usart_flag (SET or RESET).

Definition at line 1712 of file at32f435_437_emac.c.

◆ emac_mmc_reset_on_read_enable()

void emac_mmc_reset_on_read_enable ( confirm_state new_state )

enable reset on read

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1688 of file at32f435_437_emac.c.

◆ emac_mmc_rollover_stop()

void emac_mmc_rollover_stop ( confirm_state new_state )

counter stop counting from zero when it reaches maximum

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1678 of file at32f435_437_emac.c.

◆ emac_mmc_transmit_good_frames_get()

uint32_t emac_mmc_transmit_good_frames_get ( uint32_t flag )

get good frame numbers as single collision occurs.

Parameters
flag specifies the flag to check. this parameter can be one of the following values:
  • MMC_TX_SINGLE_COL
  • MMC_TX_MULTIPLE_COL
  • MMC_TX_GOOD_FRAMES
Return values
good frames

< mmc error flag of tx good frames

< mmc error flag of tx single collision

< mmc error flag of tx multiple collision

< mmc error flag of tx good frames

Definition at line 1818 of file at32f435_437_emac.c.

◆ emac_mmc_transmit_interrupt_mask_set()

void emac_mmc_transmit_interrupt_mask_set | ( | uint32_t | flag,
 |  | confirm_state | new_state
 | ) |  |

mask transmit mmc interrupt

Parameters
transmit_type transmit type. this parameter can be one of the following values:
  • MMC_TX_SINGLE_COL
  • MMC_TX_MULTIPLE_COL
  • MMC_TX_GOOD_FRAMES
new_state TRUE or FALSE.
Return values
none

< mmc error flag of tx single collision

< mmc error flag of tx multiple collision

< mmc error flag of tx good frames

Definition at line 1787 of file at32f435_437_emac.c.

◆ emac_mmc_transmit_status_get()

flag_status emac_mmc_transmit_status_get ( uint32_t flag )

interupt status of transmit frames

Parameters
transmit_type transmit type. this parameter can be one of the following values:
  • MMC_TX_SINGLE_COL
  • MMC_TX_MULTIPLE_COL
  • MMC_TX_GOOD_FRAMES
Return values
the new state of usart_flag (SET or RESET).

Definition at line 1733 of file at32f435_437_emac.c.

◆ emac_pass_all_multicasting_set()

void emac_pass_all_multicasting_set ( confirm_state new_state )

pass all multicasting frames.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 513 of file at32f435_437_emac.c.

◆ emac_pass_control_frames_set()

void emac_pass_control_frames_set ( emac_control_frames_filter_type condition )

set mac how to pass control frames.

Parameters
condition set what control frame can pass filter. this parameter can be one of the following values:
  • EMAC_CONTROL_FRAME_PASSING_NO
  • EMAC_CONTROL_FRAME_PASSING_ALL
  • EMAC_CONTROL_FRAME_PASSING_MATCH
Return values
none

Definition at line 537 of file at32f435_437_emac.c.

◆ emac_pause_low_threshold_set()

void emac_pause_low_threshold_set ( emac_pause_slot_threshold_type pasue_threshold )

set pause low threshold.

Parameters
pasue_threshold pause slot time. this parameter can be one of the following values:
  • EMAC_PAUSE_4_SLOT_TIME
  • EMAC_PAUSE_28_SLOT_TIME
  • EMAC_PAUSE_144_SLOT_TIME
  • EMAC_PAUSE_256_SLOT_TIME
Return values
none

Definition at line 677 of file at32f435_437_emac.c.

◆ emac_pause_time_set()

void emac_pause_time_set ( uint16_t pause_time )

set pause time.

Parameters
pause_time time slots to pause transmit frame.
Return values
none

Definition at line 697 of file at32f435_437_emac.c.

◆ emac_phy_register_read()

error_status emac_phy_register_read | ( | uint8_t | address,
 |  | uint8_t | reg,
 |  | uint16_t * | data
 | ) |  |

read phy data

Parameters
address | phy address.
reg | register of phy.
data | value that is read from phy.
Return values
SUCCESS or ERROR

< timeout for phy response

< timeout for phy response

Definition at line 262 of file at32f435_437_emac.c.

Referenced by emac_phy_register_reset(), emac_speed_config(), and link_update().

◆ emac_phy_register_write()

error_status emac_phy_register_write | ( | uint8_t | address,
 |  | uint8_t | reg,
 |  | uint16_t | data
 | ) |  |

write phy data.

Parameters
address | phy address.
reg | register of phy.
data | value that wants to write to phy.
Return values
SUCCESS or ERROR

< timeout for phy response

< timeout for phy response

Definition at line 232 of file at32f435_437_emac.c.

Referenced by emac_phy_register_reset(), and emac_speed_config().

◆ emac_power_down_set()

void emac_power_down_set ( confirm_state new_state )

all frame will be droppped except wakeup frame or magic packet.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 747 of file at32f435_437_emac.c.

Referenced by emac_wake_on_lan_init(), and EMAC_WKUP_IRQHandler().

◆ emac_promiscuous_mode_set()

void emac_promiscuous_mode_set ( confirm_state new_state )

set mac promiscuous mode.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 473 of file at32f435_437_emac.c.

◆ emac_ptp_addend_register_update()

void emac_ptp_addend_register_update ( confirm_state new_state )

update timestamp addend register.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1932 of file at32f435_437_emac.c.

◆ emac_ptp_clock_node_set()

void emac_ptp_clock_node_set ( emac_ptp_clock_node_type node )

set clock node type

Parameters
node select ptp packets for taking snapshot this parameter can be one of the following values:
  • EMAC_PTP_NORMAL_CLOCK
  • EMAC_PTP_BOUNDARY_CLOCK
  • EMAC_PTP_END_TO_END_CLOCK
  • EMAC_PTP_PEER_TO_PEER_CLOCK
Return values
none

Definition at line 2027 of file at32f435_437_emac.c.

◆ emac_ptp_interrupt_trigger_enable()

void emac_ptp_interrupt_trigger_enable ( confirm_state new_state )

enable timestamp interrupt trigger.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1922 of file at32f435_437_emac.c.

◆ emac_ptp_mac_address_filter_enable()

void emac_ptp_mac_address_filter_enable ( confirm_state new_state )

enable ptp frame filtering mac address

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 2037 of file at32f435_437_emac.c.

◆ emac_ptp_pps_frequency_set()

void emac_ptp_pps_frequency_set ( emac_ptp_pps_control_type freq )

set pps frequency

Parameters
freq pps frequency this parameter can be one of the following values:
  • EMAC_PTP_PPS_1HZ
  • EMAC_PTP_PPS_2HZ
  • EMAC_PTP_PPS_4HZ
  • EMAC_PTP_PPS_8HZ
  • EMAC_PTP_PPS_16HZ
  • EMAC_PTP_PPS_32HZ
  • EMAC_PTP_PPS_64HZ
  • EMAC_PTP_PPS_128HZ
  • EMAC_PTP_PPS_256HZ
  • EMAC_PTP_PPS_512HZ
  • EMAC_PTP_PPS_1024HZ
  • EMAC_PTP_PPS_2048HZ
  • EMAC_PTP_PPS_4096HZ
  • EMAC_PTP_PPS_8192HZ
  • EMAC_PTP_PPS_16384HZ
  • EMAC_PTP_PPS_32768HZ
Return values
none

Definition at line 2218 of file at32f435_437_emac.c.

◆ emac_ptp_psv2_enable()

void emac_ptp_psv2_enable ( confirm_state new_state )

enable packet snooping for version 2.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1962 of file at32f435_437_emac.c.

◆ emac_ptp_snapshot_emac_frames_enable()

void emac_ptp_snapshot_emac_frames_enable ( confirm_state new_state )

enable snapshot over emac.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1972 of file at32f435_437_emac.c.

◆ emac_ptp_snapshot_event_message_enable()

void emac_ptp_snapshot_event_message_enable ( confirm_state new_state )

enable snapshot for event message.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 2002 of file at32f435_437_emac.c.

◆ emac_ptp_snapshot_ipv4_frames_enable()

void emac_ptp_snapshot_ipv4_frames_enable ( confirm_state new_state )

enable snapshot for ipv4 frames.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1992 of file at32f435_437_emac.c.

◆ emac_ptp_snapshot_ipv6_frames_enable()

void emac_ptp_snapshot_ipv6_frames_enable ( confirm_state new_state )

enable snapshot for ipv6 frames.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1982 of file at32f435_437_emac.c.

◆ emac_ptp_snapshot_master_event_enable()

void emac_ptp_snapshot_master_event_enable ( confirm_state new_state )

enable snapshot for message relevant to master

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 2012 of file at32f435_437_emac.c.

◆ emac_ptp_snapshot_received_frames_enable()

void emac_ptp_snapshot_received_frames_enable ( confirm_state new_state )

enable timestamp snapshot for all received frames.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1942 of file at32f435_437_emac.c.

◆ emac_ptp_subsecond_increment_set()

void emac_ptp_subsecond_increment_set ( uint8_t value )

set subsecond increment value

Parameters
value add to subsecond value for every update
Return values
none

Definition at line 2047 of file at32f435_437_emac.c.

◆ emac_ptp_subsecond_rollover_enable()

void emac_ptp_subsecond_rollover_enable ( confirm_state new_state )

enable digital rollover.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1952 of file at32f435_437_emac.c.

◆ emac_ptp_system_second_get()

uint32_t emac_ptp_system_second_get ( void )

get system time second

Parameters
none
Return values
system time second

Definition at line 2057 of file at32f435_437_emac.c.

◆ emac_ptp_system_second_set()

void emac_ptp_system_second_set ( uint32_t second )

set system time second

Parameters
second system time second
Return values
none

Definition at line 2096 of file at32f435_437_emac.c.

◆ emac_ptp_system_subsecond_get()

uint32_t emac_ptp_system_subsecond_get ( void )

get system time subsecond

Parameters
none
Return values
system time subsecond

Definition at line 2068 of file at32f435_437_emac.c.

◆ emac_ptp_system_subsecond_set()

void emac_ptp_system_subsecond_set ( uint32_t subsecond )

set system time subsecond

Parameters
subsecond system time subsecond
Return values
none

Definition at line 2106 of file at32f435_437_emac.c.

◆ emac_ptp_system_time_sign_get()

confirm_state emac_ptp_system_time_sign_get ( void )

get system time sign

Parameters
none
Return values
TRUE or FALSE

Definition at line 2079 of file at32f435_437_emac.c.

◆ emac_ptp_system_time_sign_set()

void emac_ptp_system_time_sign_set ( confirm_state sign )

set system time sign

Parameters
sign TRUE or FALSE.
Return values
none

Definition at line 2116 of file at32f435_437_emac.c.

◆ emac_ptp_target_nanosecond_set()

void emac_ptp_target_nanosecond_set ( uint32_t value )

set target time stamp low

Parameters
value to set target time nanosecond
Return values
none

Definition at line 2153 of file at32f435_437_emac.c.

◆ emac_ptp_target_second_set()

void emac_ptp_target_second_set ( uint32_t value )

set target time stamp high

Parameters
value to set target time second
Return values
none

Definition at line 2143 of file at32f435_437_emac.c.

◆ emac_ptp_timestamp_addend_set()

void emac_ptp_timestamp_addend_set ( uint32_t value )

set time stamp addend

Parameters
value to achieve time synchronization
Return values
none

Definition at line 2133 of file at32f435_437_emac.c.

◆ emac_ptp_timestamp_enable()

void emac_ptp_timestamp_enable ( confirm_state new_state )

enable timestamp.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1882 of file at32f435_437_emac.c.

◆ emac_ptp_timestamp_fine_update_enable()

void emac_ptp_timestamp_fine_update_enable ( confirm_state new_state )

enable timestamp fine update.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1892 of file at32f435_437_emac.c.

◆ emac_ptp_timestamp_status_get()

confirm_state emac_ptp_timestamp_status_get ( emac_ptp_timestamp_status_type status )

set target time stamp low

Parameters
status type of status this parameter can be one of the following values:
  • EMAC_PTP_SECOND_OVERFLOW
  • EMAC_PTP_TARGET_TIME_REACH
Return values
TRUE or FALSE

Definition at line 2166 of file at32f435_437_emac.c.

◆ emac_ptp_timestamp_system_time_init()

void emac_ptp_timestamp_system_time_init ( confirm_state new_state )

initialize timestamp time system.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1902 of file at32f435_437_emac.c.

◆ emac_ptp_timestamp_system_time_update()

void emac_ptp_timestamp_system_time_update ( confirm_state new_state )

update timestamp time system.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 1912 of file at32f435_437_emac.c.

◆ emac_receive_all_set()

void emac_receive_all_set ( confirm_state new_state )

mac receives all frames.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 577 of file at32f435_437_emac.c.

◆ emac_receive_flow_control_enable()

void emac_receive_flow_control_enable ( confirm_state new_state )

set receive flow control.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 652 of file at32f435_437_emac.c.

◆ emac_receive_own_disable()

void emac_receive_own_disable ( confirm_state new_state )

receive own disable.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 388 of file at32f435_437_emac.c.

Referenced by emac_control_config().

◆ emac_received_magic_packet_get()

flag_status emac_received_magic_packet_get ( void )

received magic packet

Parameters
none
Return values
the new state of usart_flag (SET or RESET).

Definition at line 777 of file at32f435_437_emac.c.

◆ emac_received_packet_size_get()

uint32_t emac_received_packet_size_get ( void )

get the size of received the received packet.

Parameters
none
Return values
received packet size

< own bit: descriptor is owned by dma engine

< error summary: or of the following bits: ue || ED || EC || LCO || NC || LCA || FF || JT

< last descriptor of the frame

< first descriptor of the frame

Definition at line 1044 of file at32f435_437_emac.c.

Referenced by EMAC_IRQHandler().

◆ emac_received_wakeup_frame_get()

flag_status emac_received_wakeup_frame_get ( void )

received wakeup frame.

Parameters
none
Return values
the new state of usart_flag (SET or RESET).

Definition at line 794 of file at32f435_437_emac.c.

◆ emac_receiver_enable()

void emac_receiver_enable ( confirm_state new_state )

emac receiver enable.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 291 of file at32f435_437_emac.c.

Referenced by emac_start(), emac_stop(), and emac_wake_on_lan_init().

◆ emac_reset()

void emac_reset ( void )

deinitialize the emac peripheral registers to their default reset values.

Parameters
none
Return values
none

Definition at line 59 of file at32f435_437_emac.c.

Referenced by emac_layer2_configuration().

◆ emac_retry_disable()

void emac_retry_disable ( confirm_state new_state )

transmittion retry disable.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 358 of file at32f435_437_emac.c.

Referenced by emac_control_config().

◆ emac_srcaddr_filter_set()

void emac_srcaddr_filter_set ( confirm_state new_state )

source address filtering.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 557 of file at32f435_437_emac.c.

◆ emac_srcaddr_inverse_filter_set()

void emac_srcaddr_inverse_filter_set ( confirm_state new_state )

source address inverse filtering.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 547 of file at32f435_437_emac.c.

◆ emac_start()

void emac_start ( void )

enable emac and dma reception/transmission

Parameters
none
Return values
none

Definition at line 183 of file at32f435_437_emac.c.

Referenced by ethernetif_update_config().

◆ emac_stop()

void emac_stop ( void )

stop emac and dma reception/transmission

Parameters
none
Return values
none

Definition at line 206 of file at32f435_437_emac.c.

Referenced by ethernetif_update_config().

◆ emac_transmit_flow_control_enable()

void emac_transmit_flow_control_enable ( confirm_state new_state )

set transmit flow control.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 642 of file at32f435_437_emac.c.

◆ emac_trasmitter_enable()

void emac_trasmitter_enable ( confirm_state new_state )

emac transmitter enable.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 307 of file at32f435_437_emac.c.

Referenced by emac_start(), emac_stop(), emac_wake_on_lan_init(), and EMAC_WKUP_IRQHandler().

◆ emac_unicast_pause_frame_detect()

void emac_unicast_pause_frame_detect ( confirm_state new_state )

set unicast pause frame detect.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 662 of file at32f435_437_emac.c.

◆ emac_vlan_tag_comparison_set()

void emac_vlan_tag_comparison_set ( confirm_state new_state )

set 12-bit vlan identifier.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 717 of file at32f435_437_emac.c.

◆ emac_vlan_tag_identifier_set()

void emac_vlan_tag_identifier_set ( uint16_t identifier )

identify coming vlan frame field with setting value.

Parameters
identifier it will be compared with coming frame.
Return values
none

Definition at line 707 of file at32f435_437_emac.c.

◆ emac_wakeup_frame_enable()

void emac_wakeup_frame_enable ( confirm_state new_state )

wakeup frame enable

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 767 of file at32f435_437_emac.c.

◆ emac_wakeup_frame_filter_reset()

void emac_wakeup_frame_filter_reset ( confirm_state new_state )

reset wakeup frame filter resgister

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 821 of file at32f435_437_emac.c.

◆ emac_wakeup_frame_get()

uint32_t emac_wakeup_frame_get ( void )

get wakeup frame.

Parameters
none
Return values
get value from eight non transparent registers.

Definition at line 737 of file at32f435_437_emac.c.

◆ emac_wakeup_frame_set()

void emac_wakeup_frame_set ( uint32_t value )

set wakeup frame.

Parameters
value it will be written to eight non transparent registers.
Return values
none

Definition at line 727 of file at32f435_437_emac.c.

◆ emac_watchdog_disable()

void emac_watchdog_disable ( confirm_state new_state )

watchdog disable.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 437 of file at32f435_437_emac.c.

Referenced by emac_control_config().

◆ emac_zero_quanta_pause_disable()

void emac_zero_quanta_pause_disable ( confirm_state new_state )

set zero-quanta pause disable.

Parameters
new_state TRUE or FALSE.
Return values
none

Definition at line 687 of file at32f435_437_emac.c.

Variable Documentation

◆ dma_rx_desc_to_get

emac_dma_desc_type* dma_rx_desc_to_get

Definition at line 49 of file at32f435_437_emac.c.

Referenced by emac_dma_descriptor_list_address_set(), and emac_received_packet_size_get().

◆ dma_tx_desc_to_set

emac_dma_desc_type* dma_tx_desc_to_set

global pointers on tx and rx descriptor used to track transmit and receive descriptors

Definition at line 48 of file at32f435_437_emac.c.

Referenced by emac_dma_descriptor_list_address_set().


AT32F435/437 Firmwary Library: ERTC

Modules | Macros
ERTC
AT32F435_437_periph_driver

ERTC driver modules. More...

Modules

ERTC_interrupts_definition
ertc interrupt
ERTC_flags_definition
ertc flag
ERTC_private_functions

Macros

#define | ERTC_WAT_CLK_CK_A_16BITS ERTC_WAT_CLK_CK_B_16BITS
compatible with older versions More...
#define | ERTC_WAT_CLK_CK_A_17BITS ERTC_WAT_CLK_CK_B_17BITS

Detailed Description

ERTC driver modules.

Macro Definition Documentation

◆ ERTC_WAT_CLK_CK_A_16BITS

#define ERTC_WAT_CLK_CK_A_16BITS ERTC_WAT_CLK_CK_B_16BITS

compatible with older versions

Definition at line 100 of file at32f435_437_ertc.h.

◆ ERTC_WAT_CLK_CK_A_17BITS

#define ERTC_WAT_CLK_CK_A_17BITS ERTC_WAT_CLK_CK_B_17BITS

Definition at line 101 of file at32f435_437_ertc.h.


AT32F435/437 Firmwary Library: ERTC_interrupts_definition

Macros
ERTC_interrupts_definition
AT32F435_437_periph_driver » ERTC

ertc interrupt More...

Macros

#define | ERTC_TP_INT ((uint32_t)0x00000004)
#define | ERTC_ALA_INT ((uint32_t)0x00001000)
#define | ERTC_ALB_INT ((uint32_t)0x00002000)
#define | ERTC_WAT_INT ((uint32_t)0x00004000)
#define | ERTC_TS_INT ((uint32_t)0x00008000)

Detailed Description

ertc interrupt

Macro Definition Documentation

◆ ERTC_ALA_INT

#define ERTC_ALA_INT ((uint32_t)0x00001000)

ertc alarm a interrupt

Definition at line 53 of file at32f435_437_ertc.h.

◆ ERTC_ALB_INT

#define ERTC_ALB_INT ((uint32_t)0x00002000)

ertc alarm b interrupt

Definition at line 54 of file at32f435_437_ertc.h.

◆ ERTC_TP_INT

#define ERTC_TP_INT ((uint32_t)0x00000004)

ertc tamper interrupt

Definition at line 52 of file at32f435_437_ertc.h.

◆ ERTC_TS_INT

#define ERTC_TS_INT ((uint32_t)0x00008000)

ertc timestamp interrupt

Definition at line 56 of file at32f435_437_ertc.h.

◆ ERTC_WAT_INT

#define ERTC_WAT_INT ((uint32_t)0x00004000)

ertc wakeup timer interrupt

Definition at line 55 of file at32f435_437_ertc.h.


AT32F435/437 Firmwary Library: ERTC_flags_definition

Macros
ERTC_flags_definition
AT32F435_437_periph_driver » ERTC

ertc flag More...

Macros

#define | ERTC_ALAWF_FLAG ((uint32_t)0x00000001)
#define | ERTC_ALBWF_FLAG ((uint32_t)0x00000002)
#define | ERTC_WATWF_FLAG ((uint32_t)0x00000004)
#define | ERTC_TADJF_FLAG ((uint32_t)0x00000008)
#define | ERTC_INITF_FLAG ((uint32_t)0x00000010)
#define | ERTC_UPDF_FLAG ((uint32_t)0x00000020)
#define | ERTC_IMF_FLAG ((uint32_t)0x00000040)
#define | ERTC_ALAF_FLAG ((uint32_t)0x00000100)
#define | ERTC_ALBF_FLAG ((uint32_t)0x00000200)
#define | ERTC_WATF_FLAG ((uint32_t)0x00000400)
#define | ERTC_TSF_FLAG ((uint32_t)0x00000800)
#define | ERTC_TSOF_FLAG ((uint32_t)0x00001000)
#define | ERTC_TP1F_FLAG ((uint32_t)0x00002000)
#define | ERTC_TP2F_FLAG ((uint32_t)0x00004000)
#define | ERTC_CALUPDF_FLAG ((uint32_t)0x00010000)
#define | ERTC_ALARM_MASK_NONE ((uint32_t)0x00000000)
ertc alarm mask More...
#define | ERTC_ALARM_MASK_SEC ((uint32_t)0x00000080)
#define | ERTC_ALARM_MASK_MIN ((uint32_t)0x00008000)
#define | ERTC_ALARM_MASK_HOUR ((uint32_t)0x00800000)
#define | ERTC_ALARM_MASK_DATE_WEEK ((uint32_t)0x80000000)
#define | ERTC_ALARM_MASK_ALL ((uint32_t)0x80808080)

Detailed Description

ertc flag

Macro Definition Documentation

◆ ERTC_ALAF_FLAG

#define ERTC_ALAF_FLAG ((uint32_t)0x00000100)

ertc alarm clock a flag

Definition at line 74 of file at32f435_437_ertc.h.

◆ ERTC_ALARM_MASK_ALL

#define ERTC_ALARM_MASK_ALL ((uint32_t)0x80808080)

ertc alarm don't match all

Definition at line 91 of file at32f435_437_ertc.h.

◆ ERTC_ALARM_MASK_DATE_WEEK

#define ERTC_ALARM_MASK_DATE_WEEK ((uint32_t)0x80000000)

ertc alarm don't match date or week

Definition at line 90 of file at32f435_437_ertc.h.

◆ ERTC_ALARM_MASK_HOUR

#define ERTC_ALARM_MASK_HOUR ((uint32_t)0x00800000)

ertc alarm don't match hour

Definition at line 89 of file at32f435_437_ertc.h.

◆ ERTC_ALARM_MASK_MIN

#define ERTC_ALARM_MASK_MIN ((uint32_t)0x00008000)

ertc alarm don't match minute

Definition at line 88 of file at32f435_437_ertc.h.

◆ ERTC_ALARM_MASK_NONE

#define ERTC_ALARM_MASK_NONE ((uint32_t)0x00000000)

ertc alarm mask

ertc alarm match all

Definition at line 86 of file at32f435_437_ertc.h.

◆ ERTC_ALARM_MASK_SEC

#define ERTC_ALARM_MASK_SEC ((uint32_t)0x00000080)

ertc alarm don't match seconds

Definition at line 87 of file at32f435_437_ertc.h.

◆ ERTC_ALAWF_FLAG

#define ERTC_ALAWF_FLAG ((uint32_t)0x00000001)

ertc alarm a register allows write flag

Definition at line 67 of file at32f435_437_ertc.h.

◆ ERTC_ALBF_FLAG

#define ERTC_ALBF_FLAG ((uint32_t)0x00000200)

ertc alarm clock b flag

Definition at line 75 of file at32f435_437_ertc.h.

◆ ERTC_ALBWF_FLAG

#define ERTC_ALBWF_FLAG ((uint32_t)0x00000002)

ertc alarm b register allows write flag

Definition at line 68 of file at32f435_437_ertc.h.

◆ ERTC_CALUPDF_FLAG

#define ERTC_CALUPDF_FLAG ((uint32_t)0x00010000)

ertc calibration value update completed flag

Definition at line 81 of file at32f435_437_ertc.h.

◆ ERTC_IMF_FLAG

#define ERTC_IMF_FLAG ((uint32_t)0x00000040)

ertc enter initialization mode flag

Definition at line 73 of file at32f435_437_ertc.h.

◆ ERTC_INITF_FLAG

#define ERTC_INITF_FLAG ((uint32_t)0x00000010)

ertc calendar initialization flag

Definition at line 71 of file at32f435_437_ertc.h.

◆ ERTC_TADJF_FLAG

#define ERTC_TADJF_FLAG ((uint32_t)0x00000008)

ertc time adjustment flag

Definition at line 70 of file at32f435_437_ertc.h.

◆ ERTC_TP1F_FLAG

#define ERTC_TP1F_FLAG ((uint32_t)0x00002000)

ertc tamper detection 1 flag

Definition at line 79 of file at32f435_437_ertc.h.

◆ ERTC_TP2F_FLAG

#define ERTC_TP2F_FLAG ((uint32_t)0x00004000)

ertc tamper detection 2 flag

Definition at line 80 of file at32f435_437_ertc.h.

◆ ERTC_TSF_FLAG

#define ERTC_TSF_FLAG ((uint32_t)0x00000800)

ertc timestamp flag

Definition at line 77 of file at32f435_437_ertc.h.

◆ ERTC_TSOF_FLAG

#define ERTC_TSOF_FLAG ((uint32_t)0x00001000)

ertc timestamp overflow flag

Definition at line 78 of file at32f435_437_ertc.h.

◆ ERTC_UPDF_FLAG

#define ERTC_UPDF_FLAG ((uint32_t)0x00000020)

ertc calendar update flag

Definition at line 72 of file at32f435_437_ertc.h.

◆ ERTC_WATF_FLAG

#define ERTC_WATF_FLAG ((uint32_t)0x00000400)

ertc wakeup timer flag

Definition at line 76 of file at32f435_437_ertc.h.

◆ ERTC_WATWF_FLAG

#define ERTC_WATWF_FLAG ((uint32_t)0x00000004)

ertc wakeup timer register allows write flag

Definition at line 69 of file at32f435_437_ertc.h.


AT32F435/437 Firmwary Library: ERTC_private_functions

Macros | Functions
ERTC_private_functions
AT32F435_437_periph_driver » ERTC

Macros

#define ERTC_TIMEOUT ((uint32_t) 0x00360000)

Functions

uint8_t | ertc_num_to_bcd (uint8_t num)
number conversion to bcd code. More...
uint8_t | ertc_bcd_to_num (uint8_t bcd)
bcd code conversion to number. More...
void | ertc_write_protect_enable (void)
enable write protection. More...
void | ertc_write_protect_disable (void)
disable write protection. More...
error_status | ertc_wait_update (void)
ertc wait register update finish. More...
error_status | ertc_wait_flag (uint32_t flag, flag_status status)
ertc wait flag status. More...
error_status | ertc_init_mode_enter (void)
ertc enter init mode. More...
void | ertc_init_mode_exit (void)
ertc exit init mode. More...
error_status | ertc_reset (void)
ertc reset all register. More...
error_status | ertc_divider_set (uint16_t div_a, uint16_t div_b)
ertc division set. More...
error_status | ertc_hour_mode_set (ertc_hour_mode_set_type mode)
ertc hour mode set. More...
error_status | ertc_date_set (uint8_t year, uint8_t month, uint8_t date, uint8_t week)
set date. More...
error_status | ertc_time_set (uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
set time. More...
void | ertc_calendar_get (ertc_time_type *time)
get calendar More...
uint32_t | ertc_sub_second_get (void)
get current sub second. More...
void | ertc_alarm_mask_set (ertc_alarm_type alarm_x, uint32_t mask)
set which bits are irrelevant to the alarm match. More...
void | ertc_alarm_week_date_select (ertc_alarm_type alarm_x, ertc_week_date_select_type wk)
alarm week or date mode select. More...
void | ertc_alarm_set (ertc_alarm_type alarm_x, uint8_t week_date, uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
set alarm. More...
void | ertc_alarm_sub_second_set (ertc_alarm_type alarm_x, uint32_t value, ertc_alarm_sbs_mask_type mask)
set alarm sub second. More...
error_status | ertc_alarm_enable (ertc_alarm_type alarm_x, confirm_state new_state)
enable or disable alarm clock. More...
void | ertc_alarm_get (ertc_alarm_type alarm_x, ertc_alarm_value_type *alarm)
get alarm value. More...
uint32_t | ertc_alarm_sub_second_get (ertc_alarm_type alarm_x)
get alarm sub second. More...
void | ertc_wakeup_clock_set (ertc_wakeup_clock_type clock)
set wakeup timer clock. More...
void | ertc_wakeup_counter_set (uint32_t counter)
set wakeup counter. More...
uint16_t | ertc_wakeup_counter_get (void)
get wakeup counter. More...
error_status | ertc_wakeup_enable (confirm_state new_state)
enable or disable wakeup timer. More...
error_status | ertc_smooth_calibration_config (ertc_smooth_cal_period_type period, ertc_smooth_cal_clk_add_type clk_add, uint32_t clk_dec)
config the smooth calibration. More...
error_status | ertc_coarse_calibration_set (ertc_cal_direction_type dir, uint32_t value)
set the coarse digital calibration. More...
error_status | ertc_coarse_calibration_enable (confirm_state new_state)
enable or disable coarse calibration. More...
void | ertc_cal_output_select (ertc_cal_output_select_type output)
calibration output source select. More...
void | ertc_cal_output_enable (confirm_state new_state)
enable or disable calibration output. More...
error_status | ertc_time_adjust (ertc_time_adjust_type add1s, uint32_t decsbs)
adjust the time. More...
void | ertc_daylight_set (ertc_dst_operation_type operation, ertc_dst_save_type save)
config the daylight saving time. More...
uint8_t | ertc_daylight_bpr_get (void)
get the bpr value. More...
error_status | ertc_refer_clock_detect_enable (confirm_state new_state)
enable or disable refer clock detect. More...
void | ertc_direct_read_enable (confirm_state new_state)
enable or disable direct read mode. More...
void | ertc_output_set (ertc_output_source_type source, ertc_output_polarity_type polarity, ertc_output_type type)
set the output mode. More...
void | ertc_timestamp_pin_select (ertc_pin_select_type pin)
timestamp detection pin selection. More...
void | ertc_timestamp_valid_edge_set (ertc_timestamp_valid_edge_type edge)
set the timestamp valid edge. More...
void | ertc_timestamp_enable (confirm_state new_state)
enable or disable timestamp. More...
void | ertc_timestamp_get (ertc_time_type *time)
get the timestamp. More...
uint32_t | ertc_timestamp_sub_second_get (void)
get the timestamp sub second. More...
void | ertc_tamper_1_pin_select (ertc_pin_select_type pin)
tamper 1 detection pin selection. More...
void | ertc_tamper_pull_up_enable (confirm_state new_state)
enable or disable tamper pin pull up. More...
void | ertc_tamper_precharge_set (ertc_tamper_precharge_type precharge)
set the tamper pin pre-charge time. More...
void | ertc_tamper_filter_set (ertc_tamper_filter_type filter)
set the tamper filter time. More...
void | ertc_tamper_detect_freq_set (ertc_tamper_detect_freq_type freq)
set the tamper detection frequency. More...
void | ertc_tamper_valid_edge_set (ertc_tamper_select_type tamper_x, ertc_tamper_valid_edge_type trigger)
set the tamper trigger. More...
void | ertc_tamper_timestamp_enable (confirm_state new_state)
enable or disable trigger timestamp when tamper event occurs. More...
void | ertc_tamper_enable (ertc_tamper_select_type tamper_x, confirm_state new_state)
enable or disable tamper. More...
void | ertc_interrupt_enable (uint32_t source, confirm_state new_state)
enable or disable interrupt. More...
flag_status | ertc_interrupt_get (uint32_t source)
get interrupt status More...
flag_status | ertc_flag_get (uint32_t flag)
get flag status. More...
void | ertc_flag_clear (uint32_t flag)
clear flag status More...
void | ertc_bpr_data_write (ertc_dt_type dt, uint32_t data)
write data to the bpr register. More...
uint32_t | ertc_bpr_data_read (ertc_dt_type dt)
read data from bpr register. More...

Detailed Description

Macro Definition Documentation

◆ ERTC_TIMEOUT

#define ERTC_TIMEOUT ((uint32_t) 0x00360000)

Definition at line 44 of file at32f435_437_ertc.c.

Function Documentation

◆ ertc_alarm_enable()

error_status ertc_alarm_enable | ( | ertc_alarm_type | alarm_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable alarm clock.

Parameters
alarm_x select the alarm. this parameter can be one of the following values:
  • ERTC_ALA: alarm a.
  • ERTC_ALB: alarm b.
new_state (TRUE or FALSE).
Return values
error_status (ERROR or SUCCESS).

< ertc alarm a register allows write flag

< ertc alarm b register allows write flag

Definition at line 629 of file at32f435_437_ertc.c.

Referenced by ertc_alarm_config(), ertc_alarm_value_set(), and ertc_config().

◆ ertc_alarm_get()

void ertc_alarm_get | ( | ertc_alarm_type | alarm_x,
 |  | ertc_alarm_value_type * | alarm
 | ) |  |

get alarm value.

Parameters
alarm_x select the alarm. this parameter can be one of the following values:
  • ERTC_ALA: alarm a.
  • ERTC_ALB: alarm b.
alarm alarm para.
Return values
none.

< ertc alarm don't match all

Definition at line 674 of file at32f435_437_ertc.c.

Referenced by ertc_alarm_show().

◆ ertc_alarm_mask_set()

void ertc_alarm_mask_set | ( | ertc_alarm_type | alarm_x,
 |  | uint32_t | mask
 | ) |  |

set which bits are irrelevant to the alarm match.

Parameters
alarm_x select the alarm. this parameter can be one of the following values:
  • ERTC_ALA: alarm a.
  • ERTC_ALB: alarm b.
mask select which bits are irrelevant to the alarm match. this parameter can be one of the following values:
  • ERTC_ALARM_MASK_NONE: match all.
  • ERTC_ALARM_MASK_SEC: don't match seconds.
  • ERTC_ALARM_MASK_MIN: don't match minute.
  • ERTC_ALARM_MASK_HOUR: don't match hour.
  • ERTC_ALARM_MASK_DATE_WEEK: don't match date or week.
  • ERTC_ALARM_MASK_ALL: don't match all.
alarm alarm para.
Return values
none.

< ertc alarm don't match all

< ertc alarm don't match all

Definition at line 458 of file at32f435_437_ertc.c.

Referenced by ertc_alarm_config(), and ertc_config().

◆ ertc_alarm_set()

void ertc_alarm_set | ( | ertc_alarm_type | alarm_x,
 |  | uint8_t | week_date,
 |  | uint8_t | hour,
 |  | uint8_t | min,
 |  | uint8_t | sec,
 |  | ertc_am_pm_type | ampm
 | ) |  |

set alarm.

Parameters
alarm_x select the alarm. this parameter can be one of the following values:
  • ERTC_ALA: alarm a.
  • ERTC_ALB: alarm b.
week_day week or date.
  • week: 1~7.
  • date: 1~31.
hour | hour (0~23).
min | minute (0~59).
sec | second (0~59).
ampm hour mode. this parameter can be one of the following values:
  • ERTC_24H: 24-hour format.
  • ERTC_AM: 12-hour format, ante meridiem.
  • ERTC_PM: 12-hour format, post meridiem.
alarm | alarm para.
Return values
none.

Definition at line 538 of file at32f435_437_ertc.c.

Referenced by ertc_alarm_config(), ertc_alarm_value_set(), and ertc_config().

◆ ertc_alarm_sub_second_get()

uint32_t ertc_alarm_sub_second_get ( ertc_alarm_type alarm_x )

get alarm sub second.

Parameters
alarm_x select the alarm. this parameter can be one of the following values:
  • ERTC_ALA: alarm a.
  • ERTC_ALB: alarm b.
Return values
sub second.

Definition at line 707 of file at32f435_437_ertc.c.

◆ ertc_alarm_sub_second_set()

void ertc_alarm_sub_second_set | ( | ertc_alarm_type | alarm_x,
 |  | uint32_t | value,
 |  | ertc_alarm_sbs_mask_type | mask
 | ) |  |

set alarm sub second.

Parameters
alarm_x select the alarm. this parameter can be one of the following values:
  • ERTC_ALA: alarm a.
  • ERTC_ALB: alarm b.
value sub second value.
mask sub second mask. this parameter can be one of the following values:
  • ERTC_ALARM_SBS_MASK_ALL: do not match the sub-second.
  • ERTC_ALARM_SBS_MASK_14_1: only compare bit [0].
  • ERTC_ALARM_SBS_MASK_14_2: only compare bit [1:0].
  • ERTC_ALARM_SBS_MASK_14_3: only compare bit [2:0].
  • ERTC_ALARM_SBS_MASK_14_4: only compare bit [3:0].
  • ERTC_ALARM_SBS_MASK_14_5: only compare bit [4:0].
  • ERTC_ALARM_SBS_MASK_14_6: only compare bit [5:0].
  • ERTC_ALARM_SBS_MASK_14_7: only compare bit [6:0].
  • ERTC_ALARM_SBS_MASK_14_8: only compare bit [7:0].
  • ERTC_ALARM_SBS_MASK_14_9: only compare bit [8:0].
  • ERTC_ALARM_SBS_MASK_14_10: only compare bit [9:0].
  • ERTC_ALARM_SBS_MASK_14_11: only compare bit [10:0].
  • ERTC_ALARM_SBS_MASK_14_12: only compare bit [11:0].
  • ERTC_ALARM_SBS_MASK_14_13: only compare bit [12:0].
  • ERTC_ALARM_SBS_MASK_14: only compare bit [13:0].
  • ERTC_ALARM_SBS_MASK_NONE: compare bit [14:0].
Return values
none.

Definition at line 600 of file at32f435_437_ertc.c.

◆ ertc_alarm_week_date_select()

void ertc_alarm_week_date_select | ( | ertc_alarm_type | alarm_x,
 |  | ertc_week_date_select_type | wk
 | ) |  |

alarm week or date mode select.

Parameters
alarm_x select the alarm. this parameter can be one of the following values:
  • ERTC_ALA: alarm a.
  • ERTC_ALB: alarm b.
wk week or date mode select. this parameter can be one of the following values:
  • ERTC_SLECT_DATE: slect date mode.
  • ERTC_SLECT_WEEK: slect week mode.
Return values
none.

Definition at line 500 of file at32f435_437_ertc.c.

Referenced by ertc_alarm_config(), and ertc_config().

◆ ertc_bcd_to_num()

uint8_t ertc_bcd_to_num ( uint8_t bcd )

bcd code conversion to number.

Parameters
bcd bcd code(0~99).
Return values
number.

Definition at line 66 of file at32f435_437_ertc.c.

Referenced by ertc_alarm_get(), ertc_calendar_get(), and ertc_timestamp_get().

◆ ertc_bpr_data_read()

uint32_t ertc_bpr_data_read ( ertc_dt_type dt )

read data from bpr register.

Parameters
dt data register this parameter can be one of the following values:
  • ERTC_DT1
  • ERTC_DT2
  • ...
  • ERTC_DT19
  • ERTC_DT20
Return values
data value.

Definition at line 1550 of file at32f435_437_ertc.c.

Referenced by bpr_reg_check(), is_bpr_reg_reset(), main(), and randnum_test().

◆ ertc_bpr_data_write()

void ertc_bpr_data_write | ( | ertc_dt_type | dt,
 |  | uint32_t | data
 | ) |  |

write data to the bpr register.

Parameters
dt data register this parameter can be one of the following values:
  • ERTC_DT1
  • ERTC_DT2
  • ...
  • ERTC_DT19
  • ERTC_DT20
data data to be write.
Return values
none.

Definition at line 1524 of file at32f435_437_ertc.c.

Referenced by bpr_reg_write(), and ertc_config().

◆ ertc_cal_output_enable()

void ertc_cal_output_enable ( confirm_state new_state )

enable or disable calibration output.

Parameters
new_state (TRUE or FALSE).
Return values
none.

Definition at line 931 of file at32f435_437_ertc.c.

◆ ertc_cal_output_select()

void ertc_cal_output_select ( ertc_cal_output_select_type output )

calibration output source select.

Parameters
output output source. this parameter can be one of the following values:
  • ERTC_CAL_OUTPUT_512HZ: output 512 hz.
  • ERTC_CAL_OUTPUT_1HZ: output 1 hz.
Return values
none.

Definition at line 915 of file at32f435_437_ertc.c.

◆ ertc_calendar_get()

void ertc_calendar_get ( ertc_time_type * time )

get calendar

Parameters
time ertc time.
Return values
none.

Definition at line 404 of file at32f435_437_ertc.c.

Referenced by ertc_alarm_value_set(), ertc_time_show(), main(), and randnum_test().

◆ ertc_coarse_calibration_enable()

error_status ertc_coarse_calibration_enable ( confirm_state new_state )

enable or disable coarse calibration.

Parameters
new_state (TRUE or FALSE).
Return values
error_status (ERROR or SUCCESS).

Definition at line 885 of file at32f435_437_ertc.c.

◆ ertc_coarse_calibration_set()

error_status ertc_coarse_calibration_set | ( | ertc_cal_direction_type | dir,
 |  | uint32_t | value
 | ) |  |

set the coarse digital calibration.

Parameters
dir calibration direction. this parameter can be one of the following values:
  • ERTC_CAL_DIR_POSITIVE: positive calibration.
  • ERTC_CAL_DIR_NEGATIVE: negative calibration.
value calibration value(0~31).
Return values
error_status (ERROR or SUCCESS).

Definition at line 856 of file at32f435_437_ertc.c.

◆ ertc_date_set()

error_status ertc_date_set | ( | uint8_t | year,
 |  | uint8_t | month,
 |  | uint8_t | date,
 |  | uint8_t | week
 | ) |  |

set date.

Parameters
year | year (0~99).
month | month (1~12).
date | date (1~31).
week | week (1~7).
Return values
error_status (ERROR or SUCCESS).

Definition at line 314 of file at32f435_437_ertc.c.

Referenced by ertc_config().

◆ ertc_daylight_bpr_get()

uint8_t ertc_daylight_bpr_get ( void )

get the bpr value.

Parameters
none.
Return values
bpr value.

Definition at line 1026 of file at32f435_437_ertc.c.

◆ ertc_daylight_set()

void ertc_daylight_set | ( | ertc_dst_operation_type | operation,
 |  | ertc_dst_save_type | save
 | ) |  |

config the daylight saving time.

Parameters
operation time adjust. this parameter can be one of the following values:
  • ERTC_DST_ADD_1H: add 1 hour.
  • ERTC_DST_DEC_1H: dec 1 hour.
save operation save. this parameter can be one of the following values:
  • ERTC_DST_SAVE_0: set the bpr register value to 0.
  • ERTC_DST_SAVE_1: set the bpr register value to 1.
Return values
none.

Definition at line 1001 of file at32f435_437_ertc.c.

◆ ertc_direct_read_enable()

void ertc_direct_read_enable ( confirm_state new_state )

enable or disable direct read mode.

Parameters
new_state (TRUE or FALSE).
Return values
none.

Definition at line 1064 of file at32f435_437_ertc.c.

◆ ertc_divider_set()

error_status ertc_divider_set | ( | uint16_t | div_a,
 |  | uint16_t | div_b
 | ) |  |

ertc division set.

Parameters
div_a | division a (0~0x7F).
div_b | division b (0~0x7FFF).
Return values
error_status (ERROR or SUCCESS).

Definition at line 251 of file at32f435_437_ertc.c.

Referenced by ertc_config(), and main().

◆ ertc_flag_clear()

void ertc_flag_clear ( uint32_t flag )

clear flag status

Parameters
flag specifies the flag to clear. this parameter can be any combination of the following values:
  • ERTC_ALAWF_FLAG: alarm a register allows write flag.
  • ERTC_ALBWF_FLAG: alarm b register allows write flag.
  • ERTC_WATWF_FLAG: wakeup timer register allows write flag.
  • ERTC_TADJF_FLAG: time adjustment flag.
  • ERTC_INITF_FLAG: calendar initialization flag.
  • ERTC_UPDF_FLAG: calendar update flag.
  • ERTC_IMF_FLAG: enter initialization mode flag.
  • ERTC_ALAF_FLAG: alarm clock a flag.
  • ERTC_ALBF_FLAG: alarm clock b flag.
  • ERTC_WATF_FLAG: wakeup timer flag.
  • ERTC_TSF_FLAG: timestamp flag.
  • ERTC_TSOF_FLAG: timestamp overflow flag.
  • ERTC_TP1F_FLAG: tamper detection 1 flag.
  • ERTC_TP2F_FLAG: tamper detection 2 flag.
  • ERTC_CALUPDF_FLAG: calibration value update completed flag.
Return values
none

Definition at line 1507 of file at32f435_437_ertc.c.

Referenced by ertc_config(), ertc_tamper_config(), ERTC_WKUP_IRQHandler(), ERTCAlarm_IRQHandler(), main(), and TAMP_STAMP_IRQHandler().

◆ ertc_flag_get()

flag_status ertc_flag_get ( uint32_t flag )

get flag status.

Parameters
flag specifies the flag to check. this parameter can be one of the following values:
  • ERTC_ALAWF_FLAG: alarm a register allows write flag.
  • ERTC_ALBWF_FLAG: alarm b register allows write flag.
  • ERTC_WATWF_FLAG: wakeup timer register allows write flag.
  • ERTC_TADJF_FLAG: time adjustment flag.
  • ERTC_INITF_FLAG: calendar initialization flag.
  • ERTC_UPDF_FLAG: calendar update flag.
  • ERTC_IMF_FLAG: enter initialization mode flag.
  • ERTC_ALAF_FLAG: alarm clock a flag.
  • ERTC_ALBF_FLAG: alarm clock b flag.
  • ERTC_WATF_FLAG: wakeup timer flag.
  • ERTC_TSF_FLAG: timestamp flag.
  • ERTC_TSOF_FLAG: timestamp overflow flag.
  • ERTC_TP1F_FLAG: tamper detection 1 flag.
  • ERTC_TP2F_FLAG: tamper detection 2 flag.
  • ERTC_CALUPDF_FLAG: calibration value update completed flag.
Return values
the new state of flag (SET or RESET).

Definition at line 1474 of file at32f435_437_ertc.c.

Referenced by ertc_wait_flag(), ERTC_WKUP_IRQHandler(), ERTCAlarm_IRQHandler(), and TAMP_STAMP_IRQHandler().

◆ ertc_hour_mode_set()

error_status ertc_hour_mode_set ( ertc_hour_mode_set_type mode )

ertc hour mode set.

Parameters
mode hour mode. this parameter can be one of the following values:
  • ERTC_HOUR_MODE_24: 24-hour format.
  • ERTC_HOUR_MODE_12: 12-hour format.
Return values
error_status (ERROR or SUCCESS).

Definition at line 283 of file at32f435_437_ertc.c.

Referenced by ertc_config().

◆ ertc_init_mode_enter()

error_status ertc_init_mode_enter ( void )

ertc enter init mode.

Parameters
none.
Return values
error_status (ERROR or SUCCESS).

Definition at line 163 of file at32f435_437_ertc.c.

Referenced by ertc_coarse_calibration_enable(), ertc_coarse_calibration_set(), ertc_date_set(), ertc_divider_set(), ertc_hour_mode_set(), ertc_refer_clock_detect_enable(), ertc_reset(), and ertc_time_set().

◆ ertc_init_mode_exit()

void ertc_init_mode_exit ( void )

ertc exit init mode.

Parameters
none.
Return values
none.

Definition at line 197 of file at32f435_437_ertc.c.

Referenced by ertc_coarse_calibration_enable(), ertc_coarse_calibration_set(), ertc_date_set(), ertc_divider_set(), ertc_hour_mode_set(), ertc_refer_clock_detect_enable(), and ertc_time_set().

◆ ertc_interrupt_enable()

void ertc_interrupt_enable | ( | uint32_t | source,
 |  | confirm_state | new_state
 | ) |  |

enable or disable interrupt.

Parameters
source interrupts sources this parameter can be any combination of the following values:
  • ERTC_TP_INT: tamper interrupt.
  • ERTC_ALA_INT: alarm a interrupt.
  • ERTC_ALB_INT: alarm b interrupt.
  • ERTC_WAT_INT: wakeup timer interrupt.
  • ERTC_TS_INT: timestamp interrupt.
new_state (TRUE or FALSE).
Return values
none.

< ertc tamper interrupt

< ertc tamper interrupt

< ertc tamper interrupt

< ertc tamper interrupt

Definition at line 1386 of file at32f435_437_ertc.c.

Referenced by ertc_alarm_config(), ertc_config(), ertc_tamper_config(), ertc_timestamp_config(), ertc_wakeup_timer_config(), and wakeup_timer_config().

◆ ertc_interrupt_get()

flag_status ertc_interrupt_get ( uint32_t source )

get interrupt status

Parameters
source this parameter can be one of the following values:
  • ERTC_TP_INT: tamper interrupt.
  • ERTC_ALA_INT: alarm a interrupt.
  • ERTC_ALB_INT: alarm b interrupt.
  • ERTC_WAT_INT: wakeup timer interrupt.
  • ERTC_TS_INT: timestamp interrupt.
Return values
flag_status (SET or RESET)

< ertc tamper interrupt

< ertc tamper interrupt

Definition at line 1429 of file at32f435_437_ertc.c.

◆ ertc_num_to_bcd()

uint8_t ertc_num_to_bcd ( uint8_t num )

number conversion to bcd code.

Parameters
num number(0~99)
Return values
bcd code.

Definition at line 51 of file at32f435_437_ertc.c.

Referenced by ertc_alarm_set(), ertc_date_set(), and ertc_time_set().

◆ ertc_output_set()

void ertc_output_set | ( | ertc_output_source_type | source,
 |  | ertc_output_polarity_type | polarity,
 |  | ertc_output_type | type
 | ) |  |

set the output mode.

Parameters
source output source. this parameter can be one of the following values:
  • ERTC_OUTPUT_DISABLE: diable output.
  • ERTC_OUTPUT_ALARM_A: output alarm a event.
  • ERTC_OUTPUT_ALARM_B: output alarm b event.
  • ERTC_OUTPUT_WAKEUP: output wakeup event.
polarity output polarity. this parameter can be one of the following values:
  • ERTC_OUTPUT_POLARITY_HIGH: when the event occurs, the output is high.
  • ERTC_OUTPUT_POLARITY_LOW: when the event occurs, the output is low.
type output type. this parameter can be one of the following values:
  • ERTC_OUTPUT_TYPE_OPEN_DRAIN: open drain output.
  • ERTC_OUTPUT_TYPE_PUSH_PULL: push pull output.
Return values
none.

Definition at line 1093 of file at32f435_437_ertc.c.

◆ ertc_refer_clock_detect_enable()

error_status ertc_refer_clock_detect_enable ( confirm_state new_state )

enable or disable refer clock detect.

Parameters
new_state (TRUE or FALSE).
Return values
error_status (ERROR or SUCCESS).

Definition at line 1036 of file at32f435_437_ertc.c.

◆ ertc_reset()

error_status ertc_reset ( void )

ertc reset all register.

Parameters
none.
Return values
error_status (ERROR or SUCCESS).

Definition at line 207 of file at32f435_437_ertc.c.

Referenced by ertc_config().

◆ ertc_smooth_calibration_config()

error_status ertc_smooth_calibration_config | ( | ertc_smooth_cal_period_type | period,
 |  | ertc_smooth_cal_clk_add_type | clk_add,
 |  | uint32_t | clk_dec
 | ) |  |

config the smooth calibration.

Parameters
period calibration period. this parameter can be one of the following values:
  • ERTC_SMOOTH_CAL_PERIOD_32: 32 second calibration period.
  • ERTC_SMOOTH_CAL_PERIOD_16: 16 second calibration period.
  • ERTC_SMOOTH_CAL_PERIOD_8: 8 second calibration period.
clk_add add clock. this parameter can be one of the following values:
  • ERTC_SMOOTH_CAL_CLK_ADD_0: do not increase clock.
  • ERTC_SMOOTH_CAL_CLK_ADD_512: add 512 clocks.
clk_dec decrease clock(0~511).
Return values
error_status (ERROR or SUCCESS).

< ertc calibration value update completed flag

Definition at line 808 of file at32f435_437_ertc.c.

◆ ertc_sub_second_get()

uint32_t ertc_sub_second_get ( void )

get current sub second.

Parameters
none.
Return values
sub second.

Definition at line 430 of file at32f435_437_ertc.c.

◆ ertc_tamper_1_pin_select()

void ertc_tamper_1_pin_select ( ertc_pin_select_type pin )

tamper 1 detection pin selection.

Parameters
pin data register this parameter can be one of the following values:
  • ERTC_PIN_PC13: pc13 is used as tamper 1 detection pin.
  • ERTC_PIN_PA0: pa0 is used as tamper 1 detection pin.
Return values
data value.

Definition at line 1204 of file at32f435_437_ertc.c.

◆ ertc_tamper_detect_freq_set()

void ertc_tamper_detect_freq_set ( ertc_tamper_detect_freq_type freq )

set the tamper detection frequency.

Parameters
freq tamper detection frequency. this parameter can be one of the following values:
  • ERTC_TAMPER_FREQ_DIV_32768: ERTC_CLK / 32768.
  • ERTC_TAMPER_FREQ_DIV_16384: ERTC_CLK / 16384.
  • ERTC_TAMPER_FREQ_DIV_8192: ERTC_CLK / 8192.
  • ERTC_TAMPER_FREQ_DIV_4096: ERTC_CLK / 4096.
  • ERTC_TAMPER_FREQ_DIV_2048: ERTC_CLK / 2048.
  • ERTC_TAMPER_FREQ_DIV_1024: ERTC_CLK / 1024.
  • ERTC_TAMPER_FREQ_DIV_512: ERTC_CLK / 512.
  • ERTC_TAMPER_FREQ_DIV_256: ERTC_CLK / 256.
Return values
none.

Definition at line 1287 of file at32f435_437_ertc.c.

◆ ertc_tamper_enable()

void ertc_tamper_enable | ( | ertc_tamper_select_type | tamper_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tamper.

Parameters
tamper_x select the tamper. this parameter can be one of the following values:
  • ERTC_TAMPER_1: tamper 1.
  • ERTC_TAMPER_2: tamper 2.
new_state (TRUE or FALSE).
Return values
none.

Definition at line 1356 of file at32f435_437_ertc.c.

Referenced by ertc_tamper_config().

◆ ertc_tamper_filter_set()

void ertc_tamper_filter_set ( ertc_tamper_filter_type filter )

set the tamper filter time.

Parameters
filter tamper filter. this parameter can be one of the following values:
  • ERTC_TAMPER_FILTER_DISABLE: disable filter function.
  • ERTC_TAMPER_FILTER_2: 2 consecutive samples arw valid, effective tamper event.
  • ERTC_TAMPER_FILTER_4: 4 consecutive samples arw valid, effective tamper event.
  • ERTC_TAMPER_FILTER_8: 8 consecutive samples arw valid, effective tamper event.
Return values
none.

Definition at line 1262 of file at32f435_437_ertc.c.

◆ ertc_tamper_precharge_set()

void ertc_tamper_precharge_set ( ertc_tamper_precharge_type precharge )

set the tamper pin pre-charge time.

Parameters
precharge tamper detection pre-charge time this parameter can be one of the following values:
  • ERTC_TAMPER_PR_1_ERTCCLK: pre-charge time is 1 ERTC_CLK.
  • ERTC_TAMPER_PR_2_ERTCCLK: pre-charge time is 2 ERTC_CLK.
  • ERTC_TAMPER_PR_4_ERTCCLK: pre-charge time is 4 ERTC_CLK.
  • ERTC_TAMPER_PR_8_ERTCCLK: pre-charge time is 8 ERTC_CLK.
Return values
none.

Definition at line 1241 of file at32f435_437_ertc.c.

◆ ertc_tamper_pull_up_enable()

void ertc_tamper_pull_up_enable ( confirm_state new_state )

enable or disable tamper pin pull up.

Parameters
new_state (TRUE or FALSE).
Return values
none.

Definition at line 1220 of file at32f435_437_ertc.c.

◆ ertc_tamper_timestamp_enable()

void ertc_tamper_timestamp_enable ( confirm_state new_state )

enable or disable trigger timestamp when tamper event occurs.

Parameters
new_state (TRUE or FALSE).
Return values
none.

Definition at line 1336 of file at32f435_437_ertc.c.

◆ ertc_tamper_valid_edge_set()

void ertc_tamper_valid_edge_set | ( | ertc_tamper_select_type | tamper_x,
 |  | ertc_tamper_valid_edge_type | trigger
 | ) |  |

set the tamper trigger.

Parameters
tamper_x select the tamper. this parameter can be one of the following values:
  • ERTC_TAMPER_1: tamper 1.
  • ERTC_TAMPER_2: tamper 2.
trigger tamper valid edge. this parameter can be one of the following values:
  • ERTC_TAMPER_EDGE_RISING: rising gedge.
  • ERTC_TAMPER_EDGE_FALLING: falling gedge.
  • ERTC_TAMPER_EDGE_LOW: low level.
  • ERTC_TAMPER_EDGE_HIGH: high level.
alarm alarm para.
Return values
none.

Definition at line 1313 of file at32f435_437_ertc.c.

Referenced by ertc_tamper_config().

◆ ertc_time_adjust()

error_status ertc_time_adjust | ( | ertc_time_adjust_type | add1s,
 |  | uint32_t | decsbs
 | ) |  |

adjust the time.

Parameters
add1s second operation. this parameter can be one of the following values:
  • ERTC_TIME_ADD_NONE: none operation.
  • ERTC_TIME_ADD_1S: add 1 second.
decsbs decrease sub second(0~0x7FFF).
Return values
error_status (ERROR or SUCCESS).

< ertc time adjustment flag

Definition at line 951 of file at32f435_437_ertc.c.

◆ ertc_time_set()

error_status ertc_time_set | ( | uint8_t | hour,
 |  | uint8_t | min,
 |  | uint8_t | sec,
 |  | ertc_am_pm_type | ampm
 | ) |  |

set time.

Parameters
hour | hour (0~23).
min | minute (0~59).
sec | second (0~59).
ampm hour mode. this parameter can be one of the following values:
  • ERTC_24H: 24-hour format.
  • ERTC_AM: 12-hour format, ante meridiem.
  • ERTC_PM: 12-hour format, post meridiem.
Return values
error_status (ERROR or SUCCESS).

Definition at line 363 of file at32f435_437_ertc.c.

Referenced by ertc_config().

◆ ertc_timestamp_enable()

void ertc_timestamp_enable ( confirm_state new_state )

enable or disable timestamp.

Parameters
new_state (TRUE or FALSE).
Return values
none.

Definition at line 1151 of file at32f435_437_ertc.c.

Referenced by ertc_timestamp_config().

◆ ertc_timestamp_get()

void ertc_timestamp_get ( ertc_time_type * time )

get the timestamp.

Parameters
time | time.
date | date.
Return values
none.

Definition at line 1168 of file at32f435_437_ertc.c.

Referenced by ertc_timestamp_show().

◆ ertc_timestamp_pin_select()

void ertc_timestamp_pin_select ( ertc_pin_select_type pin )

timestamp detection pin selection.

Parameters
pin data register this parameter can be one of the following values:
  • ERTC_PIN_PC13: pc13 is used as timestamp detection pin.
  • ERTC_PIN_PA0: pa0 is used as timestamp detection pin.
Return values
data value.

Definition at line 1116 of file at32f435_437_ertc.c.

◆ ertc_timestamp_sub_second_get()

uint32_t ertc_timestamp_sub_second_get ( void )

get the timestamp sub second.

Parameters
none.
Return values
timestamp sub second.

Definition at line 1191 of file at32f435_437_ertc.c.

◆ ertc_timestamp_valid_edge_set()

void ertc_timestamp_valid_edge_set ( ertc_timestamp_valid_edge_type edge )

set the timestamp valid edge.

Parameters
edge calibration period. this parameter can be one of the following values:
  • ERTC_TIMESTAMP_EDGE_RISING : rising edge trigger.
  • ERTC_TIMESTAMP_EDGE_FALLING: falling edge trigger.
Return values
none.

Definition at line 1135 of file at32f435_437_ertc.c.

Referenced by ertc_timestamp_config().

◆ ertc_wait_flag()

error_status ertc_wait_flag | ( | uint32_t | flag,
 |  | flag_status | status
 | ) |  |

ertc wait flag status.

Parameters
flag flag to wait. this parameter can be one of the following values:
  • ERTC_ALAWF_FLAG: alarm a register allows write flag.
  • ERTC_ALBWF_FLAG: alarm b register allows write flag.
  • ERTC_WATWF_FLAG: wakeup timer register allows write flag.
  • ERTC_TADJF_FLAG: time adjustment flag.
  • ERTC_CALUPDF_FLAG: calibration value update completed flag.
status status to wait. this parameter can be one of the following values:
  • SET.
  • RESET.
Return values
error_status (ERROR or SUCCESS).

Definition at line 138 of file at32f435_437_ertc.c.

Referenced by ertc_alarm_enable(), ertc_smooth_calibration_config(), ertc_time_adjust(), and ertc_wakeup_enable().

◆ ertc_wait_update()

error_status ertc_wait_update ( void )

ertc wait register update finish.

Parameters
none.
Return values
error_status (ERROR or SUCCESS).

< ertc calendar update flag

Definition at line 97 of file at32f435_437_ertc.c.

Referenced by ertc_config(), ertc_date_set(), ertc_reset(), ertc_time_adjust(), ertc_time_set(), and main().

◆ ertc_wakeup_clock_set()

void ertc_wakeup_clock_set ( ertc_wakeup_clock_type clock )

set wakeup timer clock.

Parameters
clock wakeup timer clock source. this parameter can be one of the following values:
  • ERTC_WAT_CLK_ERTCCLK_DIV16: ERTC_CLK / 16.
  • ERTC_WAT_CLK_ERTCCLK_DIV8: ERTC_CLK / 8.
  • ERTC_WAT_CLK_ERTCCLK_DIV4: ERTC_CLK / 4.
  • ERTC_WAT_CLK_ERTCCLK_DIV2: ERTC_CLK / 2.
  • ERTC_WAT_CLK_CK_B_16BITS: CK_B, wakeup counter = ERTC_WAT
  • ERTC_WAT_CLK_CK_B_17BITS: CK_B, wakeup counter = ERTC_WAT + 65535.
Return values
none.

Definition at line 731 of file at32f435_437_ertc.c.

Referenced by ertc_wakeup_timer_config(), and wakeup_timer_config().

◆ ertc_wakeup_counter_get()

uint16_t ertc_wakeup_counter_get ( void )

get wakeup counter.

Parameters
none.
Return values
wakeup counter.

Definition at line 763 of file at32f435_437_ertc.c.

◆ ertc_wakeup_counter_set()

void ertc_wakeup_counter_set ( uint32_t counter )

set wakeup counter.

Parameters
counter wakeup counter(0~65535).
Return values
none.

Definition at line 747 of file at32f435_437_ertc.c.

Referenced by ertc_wakeup_timer_config(), and wakeup_timer_config().

◆ ertc_wakeup_enable()

error_status ertc_wakeup_enable ( confirm_state new_state )

enable or disable wakeup timer.

Parameters
new_state (TRUE or FALSE).
Return values
error_status (ERROR or SUCCESS).

< ertc wakeup timer register allows write flag

Definition at line 773 of file at32f435_437_ertc.c.

Referenced by ertc_wakeup_timer_config(), and wakeup_timer_config().

◆ ertc_write_protect_disable()

void ertc_write_protect_disable ( void )

disable write protection.

Parameters
none.
Return values
none

Definition at line 86 of file at32f435_437_ertc.c.

Referenced by ertc_alarm_enable(), ertc_alarm_mask_set(), ertc_alarm_set(), ertc_alarm_sub_second_set(), ertc_alarm_week_date_select(), ertc_bpr_data_write(), ertc_cal_output_enable(), ertc_cal_output_select(), ertc_coarse_calibration_enable(), ertc_coarse_calibration_set(), ertc_date_set(), ertc_daylight_set(), ertc_direct_read_enable(), ertc_divider_set(), ertc_hour_mode_set(), ertc_init_mode_enter(), ertc_interrupt_enable(), ertc_output_set(), ertc_refer_clock_detect_enable(), ertc_reset(), ertc_smooth_calibration_config(), ertc_tamper_1_pin_select(), ertc_tamper_detect_freq_set(), ertc_tamper_enable(), ertc_tamper_filter_set(), ertc_tamper_precharge_set(), ertc_tamper_pull_up_enable(), ertc_tamper_timestamp_enable(), ertc_tamper_valid_edge_set(), ertc_time_adjust(), ertc_time_set(), ertc_timestamp_enable(), ertc_timestamp_pin_select(), ertc_timestamp_valid_edge_set(), ertc_wait_update(), ertc_wakeup_clock_set(), ertc_wakeup_counter_set(), and ertc_wakeup_enable().

◆ ertc_write_protect_enable()

void ertc_write_protect_enable ( void )

enable write protection.

Parameters
none.
Return values
none

Definition at line 76 of file at32f435_437_ertc.c.

Referenced by ertc_alarm_enable(), ertc_alarm_mask_set(), ertc_alarm_set(), ertc_alarm_sub_second_set(), ertc_alarm_week_date_select(), ertc_bpr_data_write(), ertc_cal_output_enable(), ertc_cal_output_select(), ertc_coarse_calibration_enable(), ertc_coarse_calibration_set(), ertc_date_set(), ertc_daylight_set(), ertc_direct_read_enable(), ertc_divider_set(), ertc_hour_mode_set(), ertc_init_mode_enter(), ertc_interrupt_enable(), ertc_output_set(), ertc_refer_clock_detect_enable(), ertc_reset(), ertc_smooth_calibration_config(), ertc_tamper_1_pin_select(), ertc_tamper_detect_freq_set(), ertc_tamper_enable(), ertc_tamper_filter_set(), ertc_tamper_precharge_set(), ertc_tamper_pull_up_enable(), ertc_tamper_timestamp_enable(), ertc_tamper_valid_edge_set(), ertc_time_adjust(), ertc_time_set(), ertc_timestamp_enable(), ertc_timestamp_pin_select(), ertc_timestamp_valid_edge_set(), ertc_wait_flag(), ertc_wait_update(), ertc_wakeup_clock_set(), ertc_wakeup_counter_set(), and ertc_wakeup_enable().


AT32F435/437 Firmwary Library: EXINT

Modules | Macros
EXINT
AT32F435_437_periph_driver

EXINT driver modules. More...

Modules

EXINT_lines
EXINT_exported_types
EXINT_exported_functions
EXINT_private_functions

Macros

#define EXINT ((exint_type *) EXINT_BASE)

Detailed Description

EXINT driver modules.

Macro Definition Documentation

◆ EXINT

#define EXINT ((exint_type *) EXINT_BASE)

Definition at line 203 of file at32f435_437_exint.h.


AT32F435/437 Firmwary Library: EXINT_lines

Macros
EXINT_lines
AT32F435_437_periph_driver » EXINT

Macros

#define | EXINT_LINE_NONE ((uint32_t)0x000000)
#define | EXINT_LINE_0 ((uint32_t)0x000001)
#define | EXINT_LINE_1 ((uint32_t)0x000002)
#define | EXINT_LINE_2 ((uint32_t)0x000004)
#define | EXINT_LINE_3 ((uint32_t)0x000008)
#define | EXINT_LINE_4 ((uint32_t)0x000010)
#define | EXINT_LINE_5 ((uint32_t)0x000020)
#define | EXINT_LINE_6 ((uint32_t)0x000040)
#define | EXINT_LINE_7 ((uint32_t)0x000080)
#define | EXINT_LINE_8 ((uint32_t)0x000100)
#define | EXINT_LINE_9 ((uint32_t)0x000200)
#define | EXINT_LINE_10 ((uint32_t)0x000400)
#define | EXINT_LINE_11 ((uint32_t)0x000800)
#define | EXINT_LINE_12 ((uint32_t)0x001000)
#define | EXINT_LINE_13 ((uint32_t)0x002000)
#define | EXINT_LINE_14 ((uint32_t)0x004000)
#define | EXINT_LINE_15 ((uint32_t)0x008000)
#define | EXINT_LINE_16 ((uint32_t)0x010000)
#define | EXINT_LINE_17 ((uint32_t)0x020000)
#define | EXINT_LINE_18 ((uint32_t)0x040000)
#define | EXINT_LINE_19 ((uint32_t)0x080000)
#define | EXINT_LINE_20 ((uint32_t)0x100000)
#define | EXINT_LINE_21 ((uint32_t)0x200000)
#define | EXINT_LINE_22 ((uint32_t)0x400000)

Detailed Description

Macro Definition Documentation

◆ EXINT_LINE_0

#define EXINT_LINE_0 ((uint32_t)0x000001)

external interrupt line 0

Definition at line 52 of file at32f435_437_exint.h.

◆ EXINT_LINE_1

#define EXINT_LINE_1 ((uint32_t)0x000002)

external interrupt line 1

Definition at line 53 of file at32f435_437_exint.h.

◆ EXINT_LINE_10

#define EXINT_LINE_10 ((uint32_t)0x000400)

external interrupt line 10

Definition at line 62 of file at32f435_437_exint.h.

◆ EXINT_LINE_11

#define EXINT_LINE_11 ((uint32_t)0x000800)

external interrupt line 11

Definition at line 63 of file at32f435_437_exint.h.

◆ EXINT_LINE_12

#define EXINT_LINE_12 ((uint32_t)0x001000)

external interrupt line 12

Definition at line 64 of file at32f435_437_exint.h.

◆ EXINT_LINE_13

#define EXINT_LINE_13 ((uint32_t)0x002000)

external interrupt line 13

Definition at line 65 of file at32f435_437_exint.h.

◆ EXINT_LINE_14

#define EXINT_LINE_14 ((uint32_t)0x004000)

external interrupt line 14

Definition at line 66 of file at32f435_437_exint.h.

◆ EXINT_LINE_15

#define EXINT_LINE_15 ((uint32_t)0x008000)

external interrupt line 15

Definition at line 67 of file at32f435_437_exint.h.

◆ EXINT_LINE_16

#define EXINT_LINE_16 ((uint32_t)0x010000)

external interrupt line 16

Definition at line 68 of file at32f435_437_exint.h.

◆ EXINT_LINE_17

#define EXINT_LINE_17 ((uint32_t)0x020000)

external interrupt line 17

Definition at line 69 of file at32f435_437_exint.h.

◆ EXINT_LINE_18

#define EXINT_LINE_18 ((uint32_t)0x040000)

external interrupt line 18

Definition at line 70 of file at32f435_437_exint.h.

◆ EXINT_LINE_19

#define EXINT_LINE_19 ((uint32_t)0x080000)

external interrupt line 19

Definition at line 71 of file at32f435_437_exint.h.

◆ EXINT_LINE_2

#define EXINT_LINE_2 ((uint32_t)0x000004)

external interrupt line 2

Definition at line 54 of file at32f435_437_exint.h.

◆ EXINT_LINE_20

#define EXINT_LINE_20 ((uint32_t)0x100000)

external interrupt line 20

Definition at line 72 of file at32f435_437_exint.h.

◆ EXINT_LINE_21

#define EXINT_LINE_21 ((uint32_t)0x200000)

external interrupt line 21

Definition at line 73 of file at32f435_437_exint.h.

◆ EXINT_LINE_22

#define EXINT_LINE_22 ((uint32_t)0x400000)

external interrupt line 22

Definition at line 74 of file at32f435_437_exint.h.

◆ EXINT_LINE_3

#define EXINT_LINE_3 ((uint32_t)0x000008)

external interrupt line 3

Definition at line 55 of file at32f435_437_exint.h.

◆ EXINT_LINE_4

#define EXINT_LINE_4 ((uint32_t)0x000010)

external interrupt line 4

Definition at line 56 of file at32f435_437_exint.h.

◆ EXINT_LINE_5

#define EXINT_LINE_5 ((uint32_t)0x000020)

external interrupt line 5

Definition at line 57 of file at32f435_437_exint.h.

◆ EXINT_LINE_6

#define EXINT_LINE_6 ((uint32_t)0x000040)

external interrupt line 6

Definition at line 58 of file at32f435_437_exint.h.

◆ EXINT_LINE_7

#define EXINT_LINE_7 ((uint32_t)0x000080)

external interrupt line 7

Definition at line 59 of file at32f435_437_exint.h.

◆ EXINT_LINE_8

#define EXINT_LINE_8 ((uint32_t)0x000100)

external interrupt line 8

Definition at line 60 of file at32f435_437_exint.h.

◆ EXINT_LINE_9

#define EXINT_LINE_9 ((uint32_t)0x000200)

external interrupt line 9

Definition at line 61 of file at32f435_437_exint.h.

◆ EXINT_LINE_NONE

#define EXINT_LINE_NONE ((uint32_t)0x000000)

Definition at line 51 of file at32f435_437_exint.h.


AT32F435/437 Firmwary Library: EXINT_exported_types

Data Structures | Enumerations
EXINT_exported_types
AT32F435_437_periph_driver » EXINT

Data Structures

struct | exint_init_type
exint init type More...
struct | exint_type
type define exint register all More...

Enumerations

enum | exint_line_mode_type { EXINT_LINE_INTERRUPUT = 0x00 , EXINT_LINE_EVENT = 0x01 }
exint line mode type More...
enum | exint_polarity_config_type { EXINT_TRIGGER_RISING_EDGE = 0x00 , EXINT_TRIGGER_FALLING_EDGE = 0x01 , EXINT_TRIGGER_BOTH_EDGE = 0x02 }
exint polarity configuration type More...

Detailed Description

Enumeration Type Documentation

◆ exint_line_mode_type

enum exint_line_mode_type

exint line mode type

Enumerator
EXINT_LINE_INTERRUPUT | external interrupt line interrupt mode
EXINT_LINE_EVENT | external interrupt line event mode

Definition at line 87 of file at32f435_437_exint.h.

◆ exint_polarity_config_type

enum exint_polarity_config_type

exint polarity configuration type

Enumerator
EXINT_TRIGGER_RISING_EDGE | external interrupt line rising trigger mode
EXINT_TRIGGER_FALLING_EDGE | external interrupt line falling trigger mode
EXINT_TRIGGER_BOTH_EDGE | external interrupt line both rising and falling trigger mode

Definition at line 96 of file at32f435_437_exint.h.


AT32F435/437 Firmwary Library: exint_init_type Struct Reference

Data Fields
exint_init_type Struct Reference
AT32F435_437_periph_driver » EXINT » EXINT_exported_types

exint init type More...

#include <at32f435_437_exint.h>

Data Fields

exint_line_mode_type line_mode
uint32_t line_select
exint_polarity_config_type line_polarity
confirm_state line_enable

Detailed Description

exint init type

Definition at line 106 of file at32f435_437_exint.h.

Field Documentation

◆ line_enable

confirm_state exint_init_type::line_enable

enable or disable exint

Definition at line 111 of file at32f435_437_exint.h.

Referenced by button_exint_init(), emac_wake_on_lan_init(), ertc_alarm_config(), ertc_tamper_config(), ertc_timestamp_config(), ertc_wakeup_timer_config(), exint_config(), exint_default_para_init(), exint_init(), exint_line0_config(), exint_line4_config(), main(), pvm_exint_config(), usart_configuration(), and wakeup_timer_config().

◆ line_mode

exint_line_mode_type exint_init_type::line_mode

choose mode event or interrupt mode

Definition at line 108 of file at32f435_437_exint.h.

Referenced by button_exint_init(), emac_wake_on_lan_init(), ertc_alarm_config(), ertc_tamper_config(), ertc_timestamp_config(), ertc_wakeup_timer_config(), exint_config(), exint_default_para_init(), exint_init(), exint_line0_config(), exint_line4_config(), main(), pvm_exint_config(), usart_configuration(), and wakeup_timer_config().

◆ line_polarity

exint_polarity_config_type exint_init_type::line_polarity

select the tregger polarity, with rising edge, falling edge or both edge

Definition at line 110 of file at32f435_437_exint.h.

Referenced by button_exint_init(), emac_wake_on_lan_init(), ertc_alarm_config(), ertc_tamper_config(), ertc_timestamp_config(), ertc_wakeup_timer_config(), exint_config(), exint_default_para_init(), exint_init(), exint_line0_config(), exint_line4_config(), main(), pvm_exint_config(), usart_configuration(), and wakeup_timer_config().

◆ line_select

uint32_t exint_init_type::line_select

select the exint line, availiable for single line or multiple lines

Definition at line 109 of file at32f435_437_exint.h.

Referenced by button_exint_init(), emac_wake_on_lan_init(), ertc_alarm_config(), ertc_tamper_config(), ertc_timestamp_config(), ertc_wakeup_timer_config(), exint_config(), exint_default_para_init(), exint_init(), exint_line0_config(), exint_line4_config(), main(), pvm_exint_config(), usart_configuration(), and wakeup_timer_config().

The documentation for this struct was generated from the following file:
  • at32f435_437_exint.h


AT32F435/437 Firmwary Library: exint_type Struct Reference

Data Fields
exint_type Struct Reference
AT32F435_437_periph_driver » EXINT » EXINT_exported_types

type define exint register all More...

#include <at32f435_437_exint.h>

Data Fields

union {
__IO uint32_t inten
struct {
__IO uint32_t intenx: 23
__IO uint32_t reserved1: 9
} inten_bit
};
exint inten register, offset:0x00 More...
union {
__IO uint32_t evten
struct {
__IO uint32_t evtenx: 23
__IO uint32_t reserved1: 9
} evten_bit
};
exint evten register, offset:0x04 More...
union {
__IO uint32_t polcfg1
struct {
__IO uint32_t rpx: 23
__IO uint32_t reserved1: 9
} polcfg1_bit
};
exint polcfg1 register, offset:0x08 More...
union {
__IO uint32_t polcfg2
struct {
__IO uint32_t fpx: 23
__IO uint32_t reserved1: 9
} polcfg2_bit
};
exint polcfg2 register, offset:0x0C More...
union {
__IO uint32_t swtrg
struct {
__IO uint32_t swtx: 23
__IO uint32_t reserved1: 9
} swtrg_bit
};
exint swtrg register, offset:0x10 More...
union {
__IO uint32_t intsts
struct {
__IO uint32_t linex: 23
__IO uint32_t reserved1: 9
} intsts_bit
};
exint intsts register, offset:0x14 More...

Detailed Description

type define exint register all

Definition at line 117 of file at32f435_437_exint.h.

Field Documentation

◆

union { ... } exint_type::@731

exint inten register, offset:0x00

◆

union { ... } exint_type::@733

exint evten register, offset:0x04

◆

union { ... } exint_type::@735

exint polcfg1 register, offset:0x08

◆

union { ... } exint_type::@737

exint polcfg2 register, offset:0x0C

◆

union { ... } exint_type::@739

exint swtrg register, offset:0x10

◆

union { ... } exint_type::@741

exint intsts register, offset:0x14

◆ evten

__IO uint32_t exint_type::evten

Definition at line 138 of file at32f435_437_exint.h.

◆

struct { ... } exint_type::evten_bit

◆ evtenx

__IO uint32_t exint_type::evtenx

Definition at line 141 of file at32f435_437_exint.h.

◆ fpx

__IO uint32_t exint_type::fpx

Definition at line 167 of file at32f435_437_exint.h.

◆ inten

__IO uint32_t exint_type::inten

Definition at line 125 of file at32f435_437_exint.h.

◆

struct { ... } exint_type::inten_bit

◆ intenx

__IO uint32_t exint_type::intenx

Definition at line 128 of file at32f435_437_exint.h.

◆ intsts

__IO uint32_t exint_type::intsts

Definition at line 190 of file at32f435_437_exint.h.

◆

struct { ... } exint_type::intsts_bit

◆ linex

__IO uint32_t exint_type::linex

Definition at line 193 of file at32f435_437_exint.h.

◆ polcfg1

__IO uint32_t exint_type::polcfg1

Definition at line 151 of file at32f435_437_exint.h.

◆

struct { ... } exint_type::polcfg1_bit

◆ polcfg2

__IO uint32_t exint_type::polcfg2

Definition at line 164 of file at32f435_437_exint.h.

◆

struct { ... } exint_type::polcfg2_bit

◆ reserved1

__IO uint32_t exint_type::reserved1

Definition at line 129 of file at32f435_437_exint.h.

◆ rpx

__IO uint32_t exint_type::rpx

Definition at line 154 of file at32f435_437_exint.h.

◆ swtrg

__IO uint32_t exint_type::swtrg

Definition at line 177 of file at32f435_437_exint.h.

◆

struct { ... } exint_type::swtrg_bit

◆ swtx

__IO uint32_t exint_type::swtx

Definition at line 180 of file at32f435_437_exint.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_exint.h


AT32F435/437 Firmwary Library: EXINT_exported_functions

Functions
EXINT_exported_functions
AT32F435_437_periph_driver » EXINT

Functions

void | exint_reset (void)
exint reset More...
void | exint_default_para_init (exint_init_type *exint_struct)
exint default para init More...
void | exint_init (exint_init_type *exint_struct)
exint init More...
void | exint_flag_clear (uint32_t exint_line)
clear exint flag More...
flag_status | exint_flag_get (uint32_t exint_line)
get exint flag More...
void | exint_software_interrupt_event_generate (uint32_t exint_line)
generate exint software interrupt event More...
void | exint_interrupt_enable (uint32_t exint_line, confirm_state new_state)
enable or disable exint interrupt More...
void | exint_event_enable (uint32_t exint_line, confirm_state new_state)
enable or disable exint event More...

Detailed Description

Function Documentation

◆ exint_default_para_init()

void exint_default_para_init ( exint_init_type * exint_struct )

exint default para init

Parameters
exint_struct
  • to the structure of exint_init_type
Return values
none

Definition at line 64 of file at32f435_437_exint.c.

Referenced by button_exint_init(), ertc_tamper_config(), ertc_timestamp_config(), exint_config(), exint_line0_config(), exint_line4_config(), main(), usart_configuration(), and wakeup_timer_config().

◆ exint_event_enable()

void exint_event_enable | ( | uint32_t | exint_line,
 |  | confirm_state | new_state
 | ) |  |

enable or disable exint event

Parameters
exint_line this parameter can be any combination of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_21
  • EXINT_LINE_22
new_state new state of exint event. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 212 of file at32f435_437_exint.c.

◆ exint_flag_clear()

void exint_flag_clear ( uint32_t exint_line )

clear exint flag

Parameters
exint_line this parameter can be any combination of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_21
  • EXINT_LINE_22
Return values
none

Definition at line 126 of file at32f435_437_exint.c.

Referenced by button_isr(), emac_wake_on_lan_init(), EMAC_WKUP_IRQHandler(), ERTC_WKUP_IRQHandler(), ERTCAlarm_IRQHandler(), EXINT0_IRQHandler(), EXINT1_IRQHandler(), EXINT4_IRQHandler(), EXINT9_5_IRQHandler(), exint_line4_config(), main(), PVM_IRQHandler(), TAMP_STAMP_IRQHandler(), and usart_configuration().

◆ exint_flag_get()

flag_status exint_flag_get ( uint32_t exint_line )

get exint flag

Parameters
exint_line this parameter can be one of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_21
  • EXINT_LINE_22
Return values
the new state of exint flag(SET or RESET).

Definition at line 142 of file at32f435_437_exint.c.

Referenced by EXINT0_IRQHandler(), EXINT1_IRQHandler(), EXINT4_IRQHandler(), and PVM_IRQHandler().

◆ exint_init()

void exint_init ( exint_init_type * exint_struct )

exint init

Parameters
exint_struct
  • to the structure of exint_init_type
Return values
none

Definition at line 78 of file at32f435_437_exint.c.

Referenced by button_exint_init(), emac_wake_on_lan_init(), ertc_alarm_config(), ertc_tamper_config(), ertc_timestamp_config(), ertc_wakeup_timer_config(), exint_config(), exint_line0_config(), exint_line4_config(), main(), pvm_exint_config(), usart_configuration(), and wakeup_timer_config().

◆ exint_interrupt_enable()

void exint_interrupt_enable | ( | uint32_t | exint_line,
 |  | confirm_state | new_state
 | ) |  |

enable or disable exint interrupt

Parameters
exint_line this parameter can be any combination of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_21
  • EXINT_LINE_22
new_state new state of exint interrupt. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 187 of file at32f435_437_exint.c.

◆ exint_reset()

void exint_reset ( void )

exint reset

Parameters
none
Return values
none

Definition at line 49 of file at32f435_437_exint.c.

◆ exint_software_interrupt_event_generate()

void exint_software_interrupt_event_generate ( uint32_t exint_line )

generate exint software interrupt event

Parameters
exint_line this parameter can be one of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_21
  • EXINT_LINE_22
Return values
none

Definition at line 169 of file at32f435_437_exint.c.

Referenced by TMR1_OVF_TMR10_IRQHandler().


AT32F435/437 Firmwary Library: EXINT_private_functions

Functions
EXINT_private_functions
AT32F435_437_periph_driver » EXINT

Functions

void | exint_reset (void)
exint reset More...
void | exint_default_para_init (exint_init_type *exint_struct)
exint default para init More...
void | exint_init (exint_init_type *exint_struct)
exint init More...
void | exint_flag_clear (uint32_t exint_line)
clear exint flag More...
flag_status | exint_flag_get (uint32_t exint_line)
get exint flag More...
void | exint_software_interrupt_event_generate (uint32_t exint_line)
generate exint software interrupt event More...
void | exint_interrupt_enable (uint32_t exint_line, confirm_state new_state)
enable or disable exint interrupt More...
void | exint_event_enable (uint32_t exint_line, confirm_state new_state)
enable or disable exint event More...

Detailed Description

Function Documentation

◆ exint_default_para_init()

void exint_default_para_init ( exint_init_type * exint_struct )

exint default para init

Parameters
exint_struct
  • to the structure of exint_init_type
Return values
none

Definition at line 64 of file at32f435_437_exint.c.

Referenced by button_exint_init(), ertc_tamper_config(), ertc_timestamp_config(), exint_config(), exint_line0_config(), exint_line4_config(), main(), usart_configuration(), and wakeup_timer_config().

◆ exint_event_enable()

void exint_event_enable | ( | uint32_t | exint_line,
 |  | confirm_state | new_state
 | ) |  |

enable or disable exint event

Parameters
exint_line this parameter can be any combination of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_21
  • EXINT_LINE_22
new_state new state of exint event. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 212 of file at32f435_437_exint.c.

◆ exint_flag_clear()

void exint_flag_clear ( uint32_t exint_line )

clear exint flag

Parameters
exint_line this parameter can be any combination of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_21
  • EXINT_LINE_22
Return values
none

Definition at line 126 of file at32f435_437_exint.c.

Referenced by button_isr(), emac_wake_on_lan_init(), EMAC_WKUP_IRQHandler(), ERTC_WKUP_IRQHandler(), ERTCAlarm_IRQHandler(), EXINT0_IRQHandler(), EXINT1_IRQHandler(), EXINT4_IRQHandler(), EXINT9_5_IRQHandler(), exint_line4_config(), main(), PVM_IRQHandler(), TAMP_STAMP_IRQHandler(), and usart_configuration().

◆ exint_flag_get()

flag_status exint_flag_get ( uint32_t exint_line )

get exint flag

Parameters
exint_line this parameter can be one of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_21
  • EXINT_LINE_22
Return values
the new state of exint flag(SET or RESET).

Definition at line 142 of file at32f435_437_exint.c.

Referenced by EXINT0_IRQHandler(), EXINT1_IRQHandler(), EXINT4_IRQHandler(), and PVM_IRQHandler().

◆ exint_init()

void exint_init ( exint_init_type * exint_struct )

exint init

Parameters
exint_struct
  • to the structure of exint_init_type
Return values
none

Definition at line 78 of file at32f435_437_exint.c.

Referenced by button_exint_init(), emac_wake_on_lan_init(), ertc_alarm_config(), ertc_tamper_config(), ertc_timestamp_config(), ertc_wakeup_timer_config(), exint_config(), exint_line0_config(), exint_line4_config(), main(), pvm_exint_config(), usart_configuration(), and wakeup_timer_config().

◆ exint_interrupt_enable()

void exint_interrupt_enable | ( | uint32_t | exint_line,
 |  | confirm_state | new_state
 | ) |  |

enable or disable exint interrupt

Parameters
exint_line this parameter can be any combination of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_21
  • EXINT_LINE_22
new_state new state of exint interrupt. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 187 of file at32f435_437_exint.c.

◆ exint_reset()

void exint_reset ( void )

exint reset

Parameters
none
Return values
none

Definition at line 49 of file at32f435_437_exint.c.

◆ exint_software_interrupt_event_generate()

void exint_software_interrupt_event_generate ( uint32_t exint_line )

generate exint software interrupt event

Parameters
exint_line this parameter can be one of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_21
  • EXINT_LINE_22
Return values
none

Definition at line 169 of file at32f435_437_exint.c.

Referenced by TMR1_OVF_TMR10_IRQHandler().


AT32F435/437 Firmwary Library: FLASH

Modules | Macros
FLASH
AT32F435_437_periph_driver

FLASH driver modules. More...

Modules

FLASH_exported_constants
FLASH_exported_types
FLASH_exported_functions
FLASH_private_functions

Macros

#define | FLASH ((flash_type *) FLASH_REG_BASE)
#define | USD ((usd_type *) USD_BASE)

Detailed Description

FLASH driver modules.

Macro Definition Documentation

◆ FLASH

#define FLASH ((flash_type *) FLASH_REG_BASE)

Definition at line 658 of file at32f435_437_flash.h.

◆ USD

#define USD ((usd_type *) USD_BASE)

Definition at line 659 of file at32f435_437_flash.h.


AT32F435/437 Firmwary Library: FLASH_exported_constants

Macros
FLASH_exported_constants
AT32F435_437_periph_driver » FLASH

Macros

#define | FLASH_UNLOCK_KEY1 ((uint32_t)0x45670123)
flash unlock keys More...
#define | FLASH_UNLOCK_KEY2 ((uint32_t)0xCDEF89AB)
#define | FAP_RELIEVE_KEY ((uint16_t)0x00A5)
#define | SLIB_UNLOCK_KEY ((uint32_t)0xA35F6D24)
#define | FLASH_BANK1_START_ADDR ((uint32_t)0x08000000)
flash bank address More...
#define | FLASH_BANK1_END_ADDR ((uint32_t)0x0807FFFF)
#define | FLASH_BANK2_START_ADDR ((uint32_t)0x08080000)
#define | FLASH_BANK2_END_ADDR ((uint32_t)0x080FFFFF)
#define | FLASH_OBF_FLAG FLASH_BANK1_OBF_FLAG
flash flag More...
#define | FLASH_ODF_FLAG FLASH_BANK1_ODF_FLAG
#define | FLASH_PRGMERR_FLAG FLASH_BANK1_PRGMERR_FLAG
#define | FLASH_EPPERR_FLAG FLASH_BANK1_EPPERR_FLAG
#define | FLASH_BANK1_OBF_FLAG ((uint32_t)0x00000001)
#define | FLASH_BANK1_ODF_FLAG ((uint32_t)0x00000020)
#define | FLASH_BANK1_PRGMERR_FLAG ((uint32_t)0x00000004)
#define | FLASH_BANK1_EPPERR_FLAG ((uint32_t)0x00000010)
#define | FLASH_BANK2_OBF_FLAG ((uint32_t)0x10000001)
#define | FLASH_BANK2_ODF_FLAG ((uint32_t)0x10000020)
#define | FLASH_BANK2_PRGMERR_FLAG ((uint32_t)0x10000004)
#define | FLASH_BANK2_EPPERR_FLAG ((uint32_t)0x10000010)
#define | FLASH_USDERR_FLAG ((uint32_t)0x40000001)
#define | FLASH_ERR_INT FLASH_BANK1_ERR_INT
flash interrupts More...
#define | FLASH_ODF_INT FLASH_BANK1_ODF_INT
#define | FLASH_BANK1_ERR_INT ((uint32_t)0x00000001)
#define | FLASH_BANK1_ODF_INT ((uint32_t)0x00000002)
#define | FLASH_BANK2_ERR_INT ((uint32_t)0x00000004)
#define | FLASH_BANK2_ODF_INT ((uint32_t)0x00000008)
#define | FLASH_SLIB_START_SECTOR ((uint32_t)0x0000FFFF)
flash slib mask More...
#define | FLASH_SLIB_INST_START_SECTOR ((uint32_t)0x0000FFFF)
#define | FLASH_SLIB_END_SECTOR ((uint32_t)0xFFFF0000)
#define | USD_WDT_ATO_DISABLE ((uint16_t)0x0001)
user system data wdt_ato More...
#define | USD_WDT_ATO_ENABLE ((uint16_t)0x0000)
#define | USD_DEPSLP_NO_RST ((uint16_t)0x0002)
user system data depslp_rst More...
#define | USD_DEPSLP_RST ((uint16_t)0x0000)
#define | USD_STDBY_NO_RST ((uint16_t)0x0004)
user system data stdby_rst More...
#define | USD_STDBY_RST ((uint16_t)0x0000)
#define | FLASH_BOOT_FROM_BANK1 ((uint16_t)0x0008)
user system data btopt More...
#define | FLASH_BOOT_FROM_BANK2 ((uint16_t)0x0000)
#define | USD_WDT_DEPSLP_CONTINUE ((uint16_t)0x0020)
user system data wdt_depslp More...
#define | USD_WDT_DEPSLP_STOP ((uint16_t)0x0000)
#define | USD_WDT_STDBY_CONTINUE ((uint16_t)0x0040)
user system data wdt_stdby More...
#define | USD_WDT_STDBY_STOP ((uint16_t)0x0000)
#define | ERASE_TIMEOUT ((uint32_t)0x80000000)
flash timeout definition More...
#define | PROGRAMMING_TIMEOUT ((uint32_t)0x00100000)
#define | OPERATION_TIMEOUT ((uint32_t)0x10000000)
#define | flash_clock_divider_set(div) (FLASH->divr_bit.fdiv = div)
set the flash clock divider definition More...

Detailed Description

Macro Definition Documentation

◆ ERASE_TIMEOUT

#define ERASE_TIMEOUT ((uint32_t)0x80000000)

flash timeout definition

internal flash erase operation timeout

Definition at line 149 of file at32f435_437_flash.h.

◆ FAP_RELIEVE_KEY

#define FAP_RELIEVE_KEY ((uint16_t)0x00A5)

flash fap relieve key val

Definition at line 56 of file at32f435_437_flash.h.

◆ FLASH_BANK1_END_ADDR

#define FLASH_BANK1_END_ADDR ((uint32_t)0x0807FFFF)

flash end address of bank1

Definition at line 71 of file at32f435_437_flash.h.

◆ FLASH_BANK1_EPPERR_FLAG

#define FLASH_BANK1_EPPERR_FLAG ((uint32_t)0x00000010)

flash bank1 erase/program protection error flag

Definition at line 86 of file at32f435_437_flash.h.

◆ FLASH_BANK1_ERR_INT

#define FLASH_BANK1_ERR_INT ((uint32_t)0x00000001)

flash bank1 error interrupt

Definition at line 98 of file at32f435_437_flash.h.

◆ FLASH_BANK1_OBF_FLAG

#define FLASH_BANK1_OBF_FLAG ((uint32_t)0x00000001)

flash bank1 operate busy flag

Definition at line 83 of file at32f435_437_flash.h.

◆ FLASH_BANK1_ODF_FLAG

#define FLASH_BANK1_ODF_FLAG ((uint32_t)0x00000020)

flash bank1 operate done flag

Definition at line 84 of file at32f435_437_flash.h.

◆ FLASH_BANK1_ODF_INT

#define FLASH_BANK1_ODF_INT ((uint32_t)0x00000002)

flash bank1 operate done interrupt

Definition at line 99 of file at32f435_437_flash.h.

◆ FLASH_BANK1_PRGMERR_FLAG

#define FLASH_BANK1_PRGMERR_FLAG ((uint32_t)0x00000004)

flash bank1 program error flag

Definition at line 85 of file at32f435_437_flash.h.

◆ FLASH_BANK1_START_ADDR

#define FLASH_BANK1_START_ADDR ((uint32_t)0x08000000)

flash bank address

flash start address of bank1

Definition at line 70 of file at32f435_437_flash.h.

◆ FLASH_BANK2_END_ADDR

#define FLASH_BANK2_END_ADDR ((uint32_t)0x080FFFFF)

flash end address of bank2

Definition at line 73 of file at32f435_437_flash.h.

◆ FLASH_BANK2_EPPERR_FLAG

#define FLASH_BANK2_EPPERR_FLAG ((uint32_t)0x10000010)

flash bank2 erase/program protection error flag

Definition at line 90 of file at32f435_437_flash.h.

◆ FLASH_BANK2_ERR_INT

#define FLASH_BANK2_ERR_INT ((uint32_t)0x00000004)

flash bank2 error interrupt

Definition at line 100 of file at32f435_437_flash.h.

◆ FLASH_BANK2_OBF_FLAG

#define FLASH_BANK2_OBF_FLAG ((uint32_t)0x10000001)

flash bank2 operate busy flag

Definition at line 87 of file at32f435_437_flash.h.

◆ FLASH_BANK2_ODF_FLAG

#define FLASH_BANK2_ODF_FLAG ((uint32_t)0x10000020)

flash bank2 operate done flag

Definition at line 88 of file at32f435_437_flash.h.

◆ FLASH_BANK2_ODF_INT

#define FLASH_BANK2_ODF_INT ((uint32_t)0x00000008)

flash bank2 operate done interrupt

Definition at line 101 of file at32f435_437_flash.h.

◆ FLASH_BANK2_PRGMERR_FLAG

#define FLASH_BANK2_PRGMERR_FLAG ((uint32_t)0x10000004)

flash bank2 program error flag

Definition at line 89 of file at32f435_437_flash.h.

◆ FLASH_BANK2_START_ADDR

#define FLASH_BANK2_START_ADDR ((uint32_t)0x08080000)

flash start address of bank2

Definition at line 72 of file at32f435_437_flash.h.

◆ FLASH_BOOT_FROM_BANK1

#define FLASH_BOOT_FROM_BANK1 ((uint16_t)0x0008)

user system data btopt

boot from bank1

Definition at line 131 of file at32f435_437_flash.h.

◆ FLASH_BOOT_FROM_BANK2

#define FLASH_BOOT_FROM_BANK2 ((uint16_t)0x0000)

boot from bank 2 or bank 1,depending on the activation of the bank

Definition at line 132 of file at32f435_437_flash.h.

◆ flash_clock_divider_set

#define flash_clock_divider_set ( div ) (FLASH->divr_bit.fdiv = div)

set the flash clock divider definition

Parameters
div the flash clock divider. this parameter can be one of the following values:
  • FLASH_CLOCK_DIV_2
  • FLASH_CLOCK_DIV_3
  • FLASH_CLOCK_DIV_4

Definition at line 161 of file at32f435_437_flash.h.

◆ FLASH_EPPERR_FLAG

#define FLASH_EPPERR_FLAG FLASH_BANK1_EPPERR_FLAG

flash erase/program protection error flag

Definition at line 82 of file at32f435_437_flash.h.

◆ FLASH_ERR_INT

#define FLASH_ERR_INT FLASH_BANK1_ERR_INT

flash interrupts

flash error interrupt

Definition at line 96 of file at32f435_437_flash.h.

◆ FLASH_OBF_FLAG

#define FLASH_OBF_FLAG FLASH_BANK1_OBF_FLAG

flash flag

flash operate busy flag

Definition at line 79 of file at32f435_437_flash.h.

◆ FLASH_ODF_FLAG

#define FLASH_ODF_FLAG FLASH_BANK1_ODF_FLAG

flash operate done flag

Definition at line 80 of file at32f435_437_flash.h.

◆ FLASH_ODF_INT

#define FLASH_ODF_INT FLASH_BANK1_ODF_INT

flash operate done interrupt

Definition at line 97 of file at32f435_437_flash.h.

◆ FLASH_PRGMERR_FLAG

#define FLASH_PRGMERR_FLAG FLASH_BANK1_PRGMERR_FLAG

flash program error flag

Definition at line 81 of file at32f435_437_flash.h.

◆ FLASH_SLIB_END_SECTOR

#define FLASH_SLIB_END_SECTOR ((uint32_t)0xFFFF0000)

flash slib end sector

Definition at line 108 of file at32f435_437_flash.h.

◆ FLASH_SLIB_INST_START_SECTOR

#define FLASH_SLIB_INST_START_SECTOR ((uint32_t)0x0000FFFF)

flash slib i-bus area start sector

Definition at line 107 of file at32f435_437_flash.h.

◆ FLASH_SLIB_START_SECTOR

#define FLASH_SLIB_START_SECTOR ((uint32_t)0x0000FFFF)

flash slib mask

flash slib start sector

Definition at line 106 of file at32f435_437_flash.h.

◆ FLASH_UNLOCK_KEY1

#define FLASH_UNLOCK_KEY1 ((uint32_t)0x45670123)

flash unlock keys

flash operation unlock order key1

Definition at line 54 of file at32f435_437_flash.h.

◆ FLASH_UNLOCK_KEY2

#define FLASH_UNLOCK_KEY2 ((uint32_t)0xCDEF89AB)

flash operation unlock order key2

Definition at line 55 of file at32f435_437_flash.h.

◆ FLASH_USDERR_FLAG

#define FLASH_USDERR_FLAG ((uint32_t)0x40000001)

flash user system data error flag

Definition at line 91 of file at32f435_437_flash.h.

◆ OPERATION_TIMEOUT

#define OPERATION_TIMEOUT ((uint32_t)0x10000000)

flash common operation timeout

Definition at line 151 of file at32f435_437_flash.h.

◆ PROGRAMMING_TIMEOUT

#define PROGRAMMING_TIMEOUT ((uint32_t)0x00100000)

internal flash program operation timeout

Definition at line 150 of file at32f435_437_flash.h.

◆ SLIB_UNLOCK_KEY

#define SLIB_UNLOCK_KEY ((uint32_t)0xA35F6D24)

flash slib operation unlock order key

Definition at line 57 of file at32f435_437_flash.h.

◆ USD_DEPSLP_NO_RST

#define USD_DEPSLP_NO_RST ((uint16_t)0x0002)

user system data depslp_rst

no reset generated when entering in deepsleep

Definition at line 119 of file at32f435_437_flash.h.

◆ USD_DEPSLP_RST

#define USD_DEPSLP_RST ((uint16_t)0x0000)

reset generated when entering in deepsleep

Definition at line 120 of file at32f435_437_flash.h.

◆ USD_STDBY_NO_RST

#define USD_STDBY_NO_RST ((uint16_t)0x0004)

user system data stdby_rst

no reset generated when entering in standby

Definition at line 125 of file at32f435_437_flash.h.

◆ USD_STDBY_RST

#define USD_STDBY_RST ((uint16_t)0x0000)

reset generated when entering in standby

Definition at line 126 of file at32f435_437_flash.h.

◆ USD_WDT_ATO_DISABLE

#define USD_WDT_ATO_DISABLE ((uint16_t)0x0001)

user system data wdt_ato

wdt auto start disabled

Definition at line 113 of file at32f435_437_flash.h.

◆ USD_WDT_ATO_ENABLE

#define USD_WDT_ATO_ENABLE ((uint16_t)0x0000)

wdt auto start enabled

Definition at line 114 of file at32f435_437_flash.h.

◆ USD_WDT_DEPSLP_CONTINUE

#define USD_WDT_DEPSLP_CONTINUE ((uint16_t)0x0020)

user system data wdt_depslp

wdt continue count when entering in deepsleep

Definition at line 137 of file at32f435_437_flash.h.

◆ USD_WDT_DEPSLP_STOP

#define USD_WDT_DEPSLP_STOP ((uint16_t)0x0000)

wdt stop count when entering in deepsleep

Definition at line 138 of file at32f435_437_flash.h.

◆ USD_WDT_STDBY_CONTINUE

#define USD_WDT_STDBY_CONTINUE ((uint16_t)0x0040)

user system data wdt_stdby

wdt continue count when entering in standby

Definition at line 143 of file at32f435_437_flash.h.

◆ USD_WDT_STDBY_STOP

#define USD_WDT_STDBY_STOP ((uint16_t)0x0000)

wdt stop count when entering in standby

Definition at line 144 of file at32f435_437_flash.h.


AT32F435/437 Firmwary Library: FLASH_exported_types

Data Structures | Enumerations
FLASH_exported_types
AT32F435_437_periph_driver » FLASH

Data Structures

struct | flash_type
type define flash register all More...
struct | usd_type
user system data More...

Enumerations

enum flash_usd_eopb0_type {
FLASH_EOPB0_SRAM_512K = 0x00 , FLASH_EOPB0_SRAM_448K = 0x01 , FLASH_EOPB0_SRAM_384K = 0x02 , FLASH_EOPB0_SRAM_320K = 0x03 ,
FLASH_EOPB0_SRAM_256K = 0x04 , FLASH_EOPB0_SRAM_192K = 0x05 , FLASH_EOPB0_SRAM_128K = 0x06
}
flash usd eopb0 type More...
enum flash_clock_divider_type { FLASH_CLOCK_DIV_2 = 0x00 , FLASH_CLOCK_DIV_3 = 0x01 , FLASH_CLOCK_DIV_4 = 0x02 }
flash clock divider type More...
enum flash_status_type {
FLASH_OPERATE_BUSY = 0x00 , FLASH_PROGRAM_ERROR = 0x01 , FLASH_EPP_ERROR = 0x02 , FLASH_OPERATE_DONE = 0x03 ,
FLASH_OPERATE_TIMEOUT = 0x04
}
flash status type More...

Detailed Description

Enumeration Type Documentation

◆ flash_clock_divider_type

enum flash_clock_divider_type

flash clock divider type

Enumerator
FLASH_CLOCK_DIV_2 | flash clock divide by 2
FLASH_CLOCK_DIV_3 | flash clock divide by 3
FLASH_CLOCK_DIV_4 | flash clock divide by 4

Definition at line 188 of file at32f435_437_flash.h.

◆ flash_status_type

enum flash_status_type

flash status type

Enumerator
FLASH_OPERATE_BUSY | flash status is operate busy
FLASH_PROGRAM_ERROR | flash status is program error
FLASH_EPP_ERROR | flash status is epp error
FLASH_OPERATE_DONE | flash status is operate done
FLASH_OPERATE_TIMEOUT | flash status is operate timeout

Definition at line 198 of file at32f435_437_flash.h.

◆ flash_usd_eopb0_type

enum flash_usd_eopb0_type

flash usd eopb0 type

Enumerator
FLASH_EOPB0_SRAM_512K | sram 512k, flash zw area 128k
FLASH_EOPB0_SRAM_448K | sram 448k, flash zw area 192k
FLASH_EOPB0_SRAM_384K | sram 384k, flash zw area 256k
FLASH_EOPB0_SRAM_320K | sram 320k, flash zw area 320k
FLASH_EOPB0_SRAM_256K | sram 256k, flash zw area 384k
FLASH_EOPB0_SRAM_192K | sram 192k, flash zw area 448k
FLASH_EOPB0_SRAM_128K | sram 128k, flash zw area 512k

Definition at line 174 of file at32f435_437_flash.h.


AT32F435/437 Firmwary Library: flash_type Struct Reference

Data Fields
flash_type Struct Reference
AT32F435_437_periph_driver » FLASH » FLASH_exported_types

type define flash register all More...

#include <at32f435_437_flash.h>

Data Fields

union {
__IO uint32_t psr
struct {
__IO uint32_t reserved1: 12
__IO uint32_t nzw_bst: 1
__IO uint32_t nzw_bst_sts: 1
__IO uint32_t reserved2: 18
} psr_bit
};
flash psr register, offset:0x00 More...
union {
__IO uint32_t unlock
struct {
__IO uint32_t ukval: 32
} unlock_bit
};
flash unlock register, offset:0x04 More...
union {
__IO uint32_t usd_unlock
struct {
__IO uint32_t usd_ukval: 32
} usd_unlock_bit
};
flash usd unlock register, offset:0x08 More...
union {
__IO uint32_t sts
struct {
__IO uint32_t obf: 1
__IO uint32_t reserved1: 1
__IO uint32_t prgmerr: 1
__IO uint32_t reserved2: 1
__IO uint32_t epperr: 1
__IO uint32_t odf: 1
__IO uint32_t reserved3: 26
} sts_bit
};
flash sts register, offset:0x0C More...
union {
__IO uint32_t ctrl
struct {
__IO uint32_t fprgm: 1
__IO uint32_t secers: 1
__IO uint32_t bankers: 1
__IO uint32_t blkers: 1
__IO uint32_t usdprgm: 1
__IO uint32_t usders: 1
__IO uint32_t erstr: 1
__IO uint32_t oplk: 1
__IO uint32_t reserved1: 1
__IO uint32_t usdulks: 1
__IO uint32_t errie: 1
__IO uint32_t reserved2: 1
__IO uint32_t odfie: 1
__IO uint32_t reserved3: 19
} ctrl_bit
};
flash ctrl register, offset:0x10 More...
union {
__IO uint32_t addr
struct {
__IO uint32_t fa: 32
} addr_bit
};
flash addr register, offset:0x14 More...
union {
__IO uint32_t usd
struct {
__IO uint32_t usderr: 1
__IO uint32_t fap: 1
__IO uint32_t wdt_ato_en: 1
__IO uint32_t depslp_rst: 1
__IO uint32_t stdby_rst: 1
__IO uint32_t btopt: 1
__IO uint32_t reserved1: 1
__IO uint32_t wdt_depslp: 1
__IO uint32_t wdt_stdby: 1
__IO uint32_t reserved2: 1
__IO uint32_t user_d0: 8
__IO uint32_t user_d1: 8
__IO uint32_t reserved3: 6
} usd_bit
};
flash usd register, offset:0x1C More...
union {
__IO uint32_t epps0
struct {
__IO uint32_t epps: 32
} epps0_bit
};
flash epps0 register, offset:0x20 More...
union {
__IO uint32_t epps1
struct {
__IO uint32_t epps: 32
} epps1_bit
};
flash epps1 register, offset:0x2C More...
union {
__IO uint32_t unlock2
struct {
__IO uint32_t ukval: 32
} unlock2_bit
};
flash unlock2 register, offset:0x44 More...
__IO uint32_t | reserved4
flash reserved4 register, offset:0x48 More...
union {
__IO uint32_t sts2
struct {
__IO uint32_t obf: 1
__IO uint32_t reserved1: 1
__IO uint32_t prgmerr: 1
__IO uint32_t reserved2: 1
__IO uint32_t epperr: 1
__IO uint32_t odf: 1
__IO uint32_t reserved3: 26
} sts2_bit
};
flash sts2 register, offset:0x4C More...
union {
__IO uint32_t ctrl2
struct {
__IO uint32_t fprgm: 1
__IO uint32_t secers: 1
__IO uint32_t bankers: 1
__IO uint32_t blkers: 1
__IO uint32_t reserved1: 2
__IO uint32_t erstr: 1
__IO uint32_t oplk: 1
__IO uint32_t reserved2: 2
__IO uint32_t errie: 1
__IO uint32_t reserved3: 1
__IO uint32_t odfie: 1
__IO uint32_t reserved4: 19
} ctrl2_bit
};
flash ctrl2 register, offset:0x50 More...
union {
__IO uint32_t addr2
struct {
__IO uint32_t fa: 32
} addr2_bit
};
flash addr2 register, offset:0x54 More...
union {
__IO uint32_t contr
struct {
__IO uint32_t reserved1: 31
__IO uint32_t fcontr_en: 1
} contr_bit
};
flash contr register, offset:0x58 More...
__IO uint32_t | reserved5
flash reserved5 register, offset:0x5C More...
union {
__IO uint32_t divr
struct {
__IO uint32_t fdiv: 2
__IO uint32_t reserved1: 2
__IO uint32_t fdiv_sts: 2
__IO uint32_t reserved2: 26
} divr_bit
};
flash divr register, offset:0x60 More...
__IO uint32_t | reserved6 [25]
flash reserved6 register, offset:0xC4~0x64 More...
union {
__IO uint32_t slib_sts2
struct {
__IO uint32_t slib_inst_ss: 16
__IO uint32_t reserved1: 16
} slib_sts2_bit
};
flash slib_sts2 register, offset:0xC8 More...
union {
__IO uint32_t slib_sts0
struct {
__IO uint32_t reserved1: 3
__IO uint32_t slib_enf: 1
__IO uint32_t reserved2: 28
} slib_sts0_bit
};
flash slib_sts0 register, offset:0xCC More...
union {
__IO uint32_t slib_sts1
struct {
__IO uint32_t slib_ss: 16
__IO uint32_t slib_es: 16
} slib_sts1_bit
};
flash slib_sts1 register, offset:0xD0 More...
union {
__IO uint32_t slib_pwd_clr
struct {
__IO uint32_t slib_pclr_val: 32
} slib_pwd_clr_bit
};
flash slib_pwd_clr register, offset:0xD4 More...
union {
__IO uint32_t slib_misc_sts
struct {
__IO uint32_t slib_pwd_err: 1
__IO uint32_t slib_pwd_ok: 1
__IO uint32_t slib_ulkf: 1
__IO uint32_t reserved1: 13
__IO uint32_t slib_rcnt: 9
__IO uint32_t reserved2: 7
} slib_misc_sts_bit
};
flash slib_misc_sts register, offset:0xD8 More...
union {
__IO uint32_t slib_set_pwd
struct {
__IO uint32_t slib_pset_val: 32
} slib_set_pwd_bit
};
flash slib_set_pwd register, offset:0xDC More...
union {
__IO uint32_t slib_set_range0
struct {
__IO uint32_t slib_ss_set: 16
__IO uint32_t slib_es_set: 16
} slib_set_range0_bit
};
flash slib_set_range0 register, offset:0xE0 More...
union {
__IO uint32_t slib_set_range1
struct {
__IO uint32_t slib_iss_set: 16
__IO uint32_t reserved1: 15
__IO uint32_t set_slib_strt: 1
} slib_set_range1_bit
};
flash slib_set_range1 register, offset:0xE4 More...
__IO uint32_t | reserved7 [2]
flash reserved7 register, offset:0xEC~0xE8 More...
union {
__IO uint32_t slib_unlock
struct {
__IO uint32_t slib_ukval: 32
} slib_unlock_bit
};
flash slib_unlock register, offset:0xF0 More...
union {
__IO uint32_t crc_ctrl
struct {
__IO uint32_t crc_ss: 12
__IO uint32_t crc_sn: 12
__IO uint32_t reserved1: 7
__IO uint32_t crc_strt: 1
} crc_ctrl_bit
};
flash crc_ctrl register, offset:0xF4 More...
union {
__IO uint32_t crc_chkr
struct {
__IO uint32_t crc_chkr: 32
} crc_chkr_bit
};
flash crc_chkr register, offset:0xF8 More...

Detailed Description

type define flash register all

Definition at line 210 of file at32f435_437_flash.h.

Field Documentation

◆

union { ... } flash_type::@749

flash psr register, offset:0x00

◆

union { ... } flash_type::@751

flash unlock register, offset:0x04

◆

union { ... } flash_type::@753

flash usd unlock register, offset:0x08

◆

union { ... } flash_type::@755

flash sts register, offset:0x0C

◆

union { ... } flash_type::@757

flash ctrl register, offset:0x10

◆

union { ... } flash_type::@759

flash addr register, offset:0x14

◆

union { ... } flash_type::@761

flash usd register, offset:0x1C

◆

union { ... } flash_type::@763

flash epps0 register, offset:0x20

◆

union { ... } flash_type::@765

flash epps1 register, offset:0x2C

◆

union { ... } flash_type::@767

flash unlock2 register, offset:0x44

◆

union { ... } flash_type::@769

flash sts2 register, offset:0x4C

◆

union { ... } flash_type::@771

flash ctrl2 register, offset:0x50

◆

union { ... } flash_type::@773

flash addr2 register, offset:0x54

◆

union { ... } flash_type::@775

flash contr register, offset:0x58

◆

union { ... } flash_type::@777

flash divr register, offset:0x60

◆

union { ... } flash_type::@779

flash slib_sts2 register, offset:0xC8

◆

union { ... } flash_type::@781

flash slib_sts0 register, offset:0xCC

◆

union { ... } flash_type::@783

flash slib_sts1 register, offset:0xD0

◆

union { ... } flash_type::@785

flash slib_pwd_clr register, offset:0xD4

◆

union { ... } flash_type::@787

flash slib_misc_sts register, offset:0xD8

◆

union { ... } flash_type::@789

flash slib_set_pwd register, offset:0xDC

◆

union { ... } flash_type::@791

flash slib_set_range0 register, offset:0xE0

◆

union { ... } flash_type::@793

flash slib_set_range1 register, offset:0xE4

◆

union { ... } flash_type::@795

flash slib_unlock register, offset:0xF0

◆

union { ... } flash_type::@797

flash crc_ctrl register, offset:0xF4

◆

union { ... } flash_type::@799

flash crc_chkr register, offset:0xF8

◆ addr

__IO uint32_t flash_type::addr

Definition at line 299 of file at32f435_437_flash.h.

◆ addr2

__IO uint32_t flash_type::addr2

Definition at line 432 of file at32f435_437_flash.h.

◆

struct { ... } flash_type::addr2_bit

◆

struct { ... } flash_type::addr_bit

◆ bankers

__IO uint32_t flash_type::bankers

Definition at line 279 of file at32f435_437_flash.h.

◆ blkers

__IO uint32_t flash_type::blkers

Definition at line 280 of file at32f435_437_flash.h.

◆ btopt

__IO uint32_t flash_type::btopt

Definition at line 324 of file at32f435_437_flash.h.

◆ contr

__IO uint32_t flash_type::contr

Definition at line 444 of file at32f435_437_flash.h.

◆

struct { ... } flash_type::contr_bit

◆ crc_chkr

__IO uint32_t flash_type::crc_chkr

Definition at line 622 of file at32f435_437_flash.h.

◆

struct { ... } flash_type::crc_chkr_bit

◆ crc_ctrl

__IO uint32_t flash_type::crc_ctrl

Definition at line 607 of file at32f435_437_flash.h.

◆

struct { ... } flash_type::crc_ctrl_bit

◆ crc_sn

__IO uint32_t flash_type::crc_sn

Definition at line 611 of file at32f435_437_flash.h.

◆ crc_ss

__IO uint32_t flash_type::crc_ss

Definition at line 610 of file at32f435_437_flash.h.

◆ crc_strt

__IO uint32_t flash_type::crc_strt

Definition at line 613 of file at32f435_437_flash.h.

◆ ctrl

__IO uint32_t flash_type::ctrl

Definition at line 274 of file at32f435_437_flash.h.

◆ ctrl2

__IO uint32_t flash_type::ctrl2

Definition at line 409 of file at32f435_437_flash.h.

◆

struct { ... } flash_type::ctrl2_bit

◆

struct { ... } flash_type::ctrl_bit

◆ depslp_rst

__IO uint32_t flash_type::depslp_rst

Definition at line 322 of file at32f435_437_flash.h.

◆ divr

__IO uint32_t flash_type::divr

Definition at line 462 of file at32f435_437_flash.h.

◆

struct { ... } flash_type::divr_bit

◆ epperr

__IO uint32_t flash_type::epperr

Definition at line 263 of file at32f435_437_flash.h.

◆ epps

__IO uint32_t flash_type::epps

Definition at line 343 of file at32f435_437_flash.h.

◆ epps0

__IO uint32_t flash_type::epps0

Definition at line 340 of file at32f435_437_flash.h.

◆

struct { ... } flash_type::epps0_bit

◆ epps1

__IO uint32_t flash_type::epps1

Definition at line 357 of file at32f435_437_flash.h.

◆

struct { ... } flash_type::epps1_bit

◆ errie

__IO uint32_t flash_type::errie

Definition at line 287 of file at32f435_437_flash.h.

◆ erstr

__IO uint32_t flash_type::erstr

Definition at line 283 of file at32f435_437_flash.h.

◆ fa

__IO uint32_t flash_type::fa

Definition at line 302 of file at32f435_437_flash.h.

◆ fap

__IO uint32_t flash_type::fap

Definition at line 320 of file at32f435_437_flash.h.

◆ fcontr_en

__IO uint32_t flash_type::fcontr_en

Definition at line 448 of file at32f435_437_flash.h.

◆ fdiv

__IO uint32_t flash_type::fdiv

Definition at line 465 of file at32f435_437_flash.h.

◆ fdiv_sts

__IO uint32_t flash_type::fdiv_sts

Definition at line 467 of file at32f435_437_flash.h.

◆ fprgm

__IO uint32_t flash_type::fprgm

Definition at line 277 of file at32f435_437_flash.h.

◆ nzw_bst

__IO uint32_t flash_type::nzw_bst

Definition at line 221 of file at32f435_437_flash.h.

◆ nzw_bst_sts

__IO uint32_t flash_type::nzw_bst_sts

Definition at line 222 of file at32f435_437_flash.h.

◆ obf

__IO uint32_t flash_type::obf

Definition at line 259 of file at32f435_437_flash.h.

◆ odf

__IO uint32_t flash_type::odf

Definition at line 264 of file at32f435_437_flash.h.

◆ odfie

__IO uint32_t flash_type::odfie

Definition at line 289 of file at32f435_437_flash.h.

◆ oplk

__IO uint32_t flash_type::oplk

Definition at line 284 of file at32f435_437_flash.h.

◆ prgmerr

__IO uint32_t flash_type::prgmerr

Definition at line 261 of file at32f435_437_flash.h.

◆ psr

__IO uint32_t flash_type::psr

Definition at line 217 of file at32f435_437_flash.h.

◆

struct { ... } flash_type::psr_bit

◆ reserved1

__IO uint32_t flash_type::reserved1

flash reserved1 register, offset:0x18

Definition at line 220 of file at32f435_437_flash.h.

◆ reserved2

__IO uint32_t flash_type::reserved2

flash reserved2 register, offset:0x28~0x24

Definition at line 223 of file at32f435_437_flash.h.

◆ reserved3

__IO uint32_t flash_type::reserved3

flash reserved3 register, offset:0x40~0x30

Definition at line 265 of file at32f435_437_flash.h.

◆ reserved4

__IO uint32_t flash_type::reserved4

flash reserved4 register, offset:0x48

Definition at line 384 of file at32f435_437_flash.h.

◆ reserved5

__IO uint32_t flash_type::reserved5

flash reserved5 register, offset:0x5C

Definition at line 455 of file at32f435_437_flash.h.

◆ reserved6

__IO uint32_t flash_type::reserved6[25]

flash reserved6 register, offset:0xC4~0x64

Definition at line 475 of file at32f435_437_flash.h.

◆ reserved7

__IO uint32_t flash_type::reserved7[2]

flash reserved7 register, offset:0xEC~0xE8

Definition at line 588 of file at32f435_437_flash.h.

◆ secers

__IO uint32_t flash_type::secers

Definition at line 278 of file at32f435_437_flash.h.

◆ set_slib_strt

__IO uint32_t flash_type::set_slib_strt

Definition at line 581 of file at32f435_437_flash.h.

◆ slib_enf

__IO uint32_t flash_type::slib_enf

Definition at line 499 of file at32f435_437_flash.h.

◆ slib_es

__IO uint32_t flash_type::slib_es

Definition at line 513 of file at32f435_437_flash.h.

◆ slib_es_set

__IO uint32_t flash_type::slib_es_set

Definition at line 567 of file at32f435_437_flash.h.

◆ slib_inst_ss

__IO uint32_t flash_type::slib_inst_ss

Definition at line 485 of file at32f435_437_flash.h.

◆ slib_iss_set

__IO uint32_t flash_type::slib_iss_set

Definition at line 579 of file at32f435_437_flash.h.

◆ slib_misc_sts

__IO uint32_t flash_type::slib_misc_sts

Definition at line 534 of file at32f435_437_flash.h.

◆

struct { ... } flash_type::slib_misc_sts_bit

◆ slib_pclr_val

__IO uint32_t flash_type::slib_pclr_val

Definition at line 525 of file at32f435_437_flash.h.

◆ slib_pset_val

__IO uint32_t flash_type::slib_pset_val

Definition at line 554 of file at32f435_437_flash.h.

◆ slib_pwd_clr

__IO uint32_t flash_type::slib_pwd_clr

Definition at line 522 of file at32f435_437_flash.h.

◆

struct { ... } flash_type::slib_pwd_clr_bit

◆ slib_pwd_err

__IO uint32_t flash_type::slib_pwd_err

Definition at line 537 of file at32f435_437_flash.h.

◆ slib_pwd_ok

__IO uint32_t flash_type::slib_pwd_ok

Definition at line 538 of file at32f435_437_flash.h.

◆ slib_rcnt

__IO uint32_t flash_type::slib_rcnt

Definition at line 541 of file at32f435_437_flash.h.

◆ slib_set_pwd

__IO uint32_t flash_type::slib_set_pwd

Definition at line 551 of file at32f435_437_flash.h.

◆

struct { ... } flash_type::slib_set_pwd_bit

◆ slib_set_range0

__IO uint32_t flash_type::slib_set_range0

Definition at line 563 of file at32f435_437_flash.h.

◆

struct { ... } flash_type::slib_set_range0_bit

◆ slib_set_range1

__IO uint32_t flash_type::slib_set_range1

Definition at line 576 of file at32f435_437_flash.h.

◆

struct { ... } flash_type::slib_set_range1_bit

◆ slib_ss

__IO uint32_t flash_type::slib_ss

Definition at line 512 of file at32f435_437_flash.h.

◆ slib_ss_set

__IO uint32_t flash_type::slib_ss_set

Definition at line 566 of file at32f435_437_flash.h.

◆ slib_sts0

__IO uint32_t flash_type::slib_sts0

Definition at line 495 of file at32f435_437_flash.h.

◆

struct { ... } flash_type::slib_sts0_bit

◆ slib_sts1

__IO uint32_t flash_type::slib_sts1

Definition at line 509 of file at32f435_437_flash.h.

◆

struct { ... } flash_type::slib_sts1_bit

◆ slib_sts2

__IO uint32_t flash_type::slib_sts2

Definition at line 482 of file at32f435_437_flash.h.

◆

struct { ... } flash_type::slib_sts2_bit

◆ slib_ukval

__IO uint32_t flash_type::slib_ukval

Definition at line 598 of file at32f435_437_flash.h.

◆ slib_ulkf

__IO uint32_t flash_type::slib_ulkf

Definition at line 539 of file at32f435_437_flash.h.

◆ slib_unlock

__IO uint32_t flash_type::slib_unlock

Definition at line 595 of file at32f435_437_flash.h.

◆

struct { ... } flash_type::slib_unlock_bit

◆ stdby_rst

__IO uint32_t flash_type::stdby_rst

Definition at line 323 of file at32f435_437_flash.h.

◆ sts

__IO uint32_t flash_type::sts

Definition at line 256 of file at32f435_437_flash.h.

◆ sts2

__IO uint32_t flash_type::sts2

Definition at line 391 of file at32f435_437_flash.h.

◆

struct { ... } flash_type::sts2_bit

◆

struct { ... } flash_type::sts_bit

◆ ukval

__IO uint32_t flash_type::ukval

Definition at line 235 of file at32f435_437_flash.h.

◆ unlock

__IO uint32_t flash_type::unlock

Definition at line 232 of file at32f435_437_flash.h.

◆ unlock2

__IO uint32_t flash_type::unlock2

Definition at line 374 of file at32f435_437_flash.h.

◆

struct { ... } flash_type::unlock2_bit

◆

struct { ... } flash_type::unlock_bit

◆ usd

__IO uint32_t flash_type::usd

Definition at line 316 of file at32f435_437_flash.h.

◆

struct { ... } flash_type::usd_bit

◆ usd_ukval

__IO uint32_t flash_type::usd_ukval

Definition at line 247 of file at32f435_437_flash.h.

◆ usd_unlock

__IO uint32_t flash_type::usd_unlock

Definition at line 244 of file at32f435_437_flash.h.

◆

struct { ... } flash_type::usd_unlock_bit

◆ usderr

__IO uint32_t flash_type::usderr

Definition at line 319 of file at32f435_437_flash.h.

◆ usders

__IO uint32_t flash_type::usders

Definition at line 282 of file at32f435_437_flash.h.

◆ usdprgm

__IO uint32_t flash_type::usdprgm

Definition at line 281 of file at32f435_437_flash.h.

◆ usdulks

__IO uint32_t flash_type::usdulks

Definition at line 286 of file at32f435_437_flash.h.

◆ user_d0

__IO uint32_t flash_type::user_d0

Definition at line 329 of file at32f435_437_flash.h.

◆ user_d1

__IO uint32_t flash_type::user_d1

Definition at line 330 of file at32f435_437_flash.h.

◆ wdt_ato_en

__IO uint32_t flash_type::wdt_ato_en

Definition at line 321 of file at32f435_437_flash.h.

◆ wdt_depslp

__IO uint32_t flash_type::wdt_depslp

Definition at line 326 of file at32f435_437_flash.h.

◆ wdt_stdby

__IO uint32_t flash_type::wdt_stdby

Definition at line 327 of file at32f435_437_flash.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_flash.h


AT32F435/437 Firmwary Library: usd_type Struct Reference

Data Fields
usd_type Struct Reference
AT32F435_437_periph_driver » FLASH » FLASH_exported_types

user system data More...

#include <at32f435_437_flash.h>

Data Fields

__IO uint16_t | fap
__IO uint16_t | ssb
__IO uint16_t | data0
__IO uint16_t | data1
__IO uint16_t | epp0
__IO uint16_t | epp1
__IO uint16_t | epp2
__IO uint16_t | epp3
__IO uint16_t | eopb0
__IO uint16_t | reserved1
__IO uint16_t | epp4
__IO uint16_t | epp5
__IO uint16_t | epp6
__IO uint16_t | epp7
__IO uint16_t | reserved2 [12]
__IO uint16_t | qspikey [8]

Detailed Description

user system data

Definition at line 634 of file at32f435_437_flash.h.

Field Documentation

◆ data0

__IO uint16_t usd_type::data0

Definition at line 638 of file at32f435_437_flash.h.

◆ data1

__IO uint16_t usd_type::data1

Definition at line 639 of file at32f435_437_flash.h.

◆ eopb0

__IO uint16_t usd_type::eopb0

Definition at line 644 of file at32f435_437_flash.h.

◆ epp0

__IO uint16_t usd_type::epp0

Definition at line 640 of file at32f435_437_flash.h.

◆ epp1

__IO uint16_t usd_type::epp1

Definition at line 641 of file at32f435_437_flash.h.

◆ epp2

__IO uint16_t usd_type::epp2

Definition at line 642 of file at32f435_437_flash.h.

◆ epp3

__IO uint16_t usd_type::epp3

Definition at line 643 of file at32f435_437_flash.h.

◆ epp4

__IO uint16_t usd_type::epp4

Definition at line 646 of file at32f435_437_flash.h.

◆ epp5

__IO uint16_t usd_type::epp5

Definition at line 647 of file at32f435_437_flash.h.

◆ epp6

__IO uint16_t usd_type::epp6

Definition at line 648 of file at32f435_437_flash.h.

◆ epp7

__IO uint16_t usd_type::epp7

Definition at line 649 of file at32f435_437_flash.h.

◆ fap

__IO uint16_t usd_type::fap

Definition at line 636 of file at32f435_437_flash.h.

◆ qspikey

__IO uint16_t usd_type::qspikey[8]

Definition at line 651 of file at32f435_437_flash.h.

◆ reserved1

__IO uint16_t usd_type::reserved1

Definition at line 645 of file at32f435_437_flash.h.

◆ reserved2

__IO uint16_t usd_type::reserved2[12]

Definition at line 650 of file at32f435_437_flash.h.

◆ ssb

__IO uint16_t usd_type::ssb

Definition at line 637 of file at32f435_437_flash.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_flash.h


AT32F435/437 Firmwary Library: FLASH_exported_functions

Functions
FLASH_exported_functions
AT32F435_437_periph_driver » FLASH

Functions

flag_status | flash_flag_get (uint32_t flash_flag)
check whether the specified flash flag is set or not. More...
void | flash_flag_clear (uint32_t flash_flag)
clear the flash flag. More...
flash_status_type | flash_operation_status_get (void)
return the flash operation status. More...
flash_status_type | flash_bank1_operation_status_get (void)
return the flash bank1 operation status. More...
flash_status_type | flash_bank2_operation_status_get (void)
return the flash bank2 operation status. More...
flash_status_type | flash_operation_wait_for (uint32_t time_out)
wait for flash operation complete or timeout. More...
flash_status_type | flash_bank1_operation_wait_for (uint32_t time_out)
wait for flash bank1 operation complete or timeout. More...
flash_status_type | flash_bank2_operation_wait_for (uint32_t time_out)
wait for flash bank2 operation complete or timeout. More...
void | flash_unlock (void)
unlock the flash controller. More...
void | flash_bank1_unlock (void)
unlock the flash bank1 controller. More...
void | flash_bank2_unlock (void)
unlock the flash bank2 controller. More...
void | flash_lock (void)
lock the flash controller. More...
void | flash_bank1_lock (void)
lock the flash bank1 controller. More...
void | flash_bank2_lock (void)
lock the flash bank2 controller. More...
flash_status_type | flash_sector_erase (uint32_t sector_address)
erase a specified flash sector. More...
flash_status_type | flash_block_erase (uint32_t block_address)
erase a specified flash block. More...
flash_status_type | flash_internal_all_erase (void)
erase flash all internal sectors. More...
flash_status_type | flash_bank1_erase (void)
erase flash bank1 sectors. More...
flash_status_type | flash_bank2_erase (void)
erase flash bank2 sectors. More...
flash_status_type | flash_user_system_data_erase (void)
erase the flash user system data. More...
flash_status_type | flash_eopb0_config (flash_usd_eopb0_type data)
config the extend sram byte eopb0 in user system data. More...
flash_status_type | flash_word_program (uint32_t address, uint32_t data)
program a word at a specified address. More...
flash_status_type | flash_halfword_program (uint32_t address, uint16_t data)
program a halfword at a specified address. More...
flash_status_type | flash_byte_program (uint32_t address, uint8_t data)
program a byte at a specified address. More...
flash_status_type | flash_user_system_data_program (uint32_t address, uint8_t data)
program a halfword at a specified user system data address. More...
flash_status_type | flash_epp_set (uint32_t *sector_bits)
config erase/program protection for the desired sectors. More...
void | flash_epp_status_get (uint32_t *sector_bits)
return the flash erase/program protection status. More...
flash_status_type | flash_fap_enable (confirm_state new_state)
enable or disable the flash access protection. More...
flag_status | flash_fap_status_get (void)
check the flash access protection status. More...
flash_status_type | flash_ssb_set (uint8_t usd_ssb)
program the flash system setting byte in usd: wdt_ato_en / depslp_rst / stdby_rst / btopt. More...
uint8_t | flash_ssb_status_get (void)
return the flash system setting byte status. More...
void | flash_interrupt_enable (uint32_t flash_int, confirm_state new_state)
enable or disable the specified flash interrupts. More...
flash_status_type | flash_slib_enable (uint32_t pwd, uint16_t start_sector, uint16_t inst_start_sector, uint16_t end_sector)
enable security library function. More...
error_status | flash_slib_disable (uint32_t pwd)
disable slib when slib enabled. More...
uint32_t | flash_slib_remaining_count_get (void)
get remaining count of slib(range: 256~0). More...
flag_status | flash_slib_state_get (void)
get the slib state. More...
uint16_t | flash_slib_start_sector_get (void)
get the start sector of slib. More...
uint16_t | flash_slib_inststart_sector_get (void)
get the instruction start sector of slib. More...
uint16_t | flash_slib_end_sector_get (void)
get the end sector of slib. More...
uint32_t | flash_crc_calibrate (uint32_t start_sector, uint32_t sector_cnt)
flash crc calibration in main block. More...
void | flash_nzw_boost_enable (confirm_state new_state)
flash non-zero wait area boost enable. More...
void | flash_continue_read_enable (confirm_state new_state)
flash continue read enable. More...

Detailed Description

Function Documentation

◆ flash_bank1_erase()

flash_status_type flash_bank1_erase ( void )

erase flash bank1 sectors.

Parameters
none
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< internal flash erase operation timeout

Definition at line 468 of file at32f435_437_flash.c.

◆ flash_bank1_lock()

void flash_bank1_lock ( void )

lock the flash bank1 controller.

Parameters
none
Return values
none

Definition at line 336 of file at32f435_437_flash.c.

◆ flash_bank1_operation_status_get()

flash_status_type flash_bank1_operation_status_get ( void )

return the flash bank1 operation status.

Parameters
none
Return values
status the returned value can be: FLASH_OPERATE_BUSY, FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR or FLASH_OPERATE_DONE.

Definition at line 158 of file at32f435_437_flash.c.

Referenced by flash_bank1_operation_wait_for().

◆ flash_bank1_operation_wait_for()

flash_status_type flash_bank1_operation_wait_for ( uint32_t time_out )

wait for flash bank1 operation complete or timeout.

Parameters
time_out flash operation timeout
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

Definition at line 241 of file at32f435_437_flash.c.

Referenced by flash_bank1_erase(), flash_block_erase(), flash_byte_program(), flash_halfword_program(), flash_internal_all_erase(), flash_sector_erase(), and flash_word_program().

◆ flash_bank1_unlock()

void flash_bank1_unlock ( void )

unlock the flash bank1 controller.

Parameters
none
Return values
none

< flash operation unlock order key1

< flash operation unlock order key2

Definition at line 303 of file at32f435_437_flash.c.

◆ flash_bank2_erase()

flash_status_type flash_bank2_erase ( void )

erase flash bank2 sectors.

Parameters
none
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< internal flash erase operation timeout

Definition at line 491 of file at32f435_437_flash.c.

◆ flash_bank2_lock()

void flash_bank2_lock ( void )

lock the flash bank2 controller.

Parameters
none
Return values
none

Definition at line 346 of file at32f435_437_flash.c.

◆ flash_bank2_operation_status_get()

flash_status_type flash_bank2_operation_status_get ( void )

return the flash bank2 operation status.

Parameters
none
Return values
status the returned value can be: FLASH_OPERATE_BUSY, FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR or FLASH_OPERATE_DONE.

Definition at line 187 of file at32f435_437_flash.c.

Referenced by flash_bank2_operation_wait_for().

◆ flash_bank2_operation_wait_for()

flash_status_type flash_bank2_operation_wait_for ( uint32_t time_out )

wait for flash bank2 operation complete or timeout.

Parameters
time_out flash operation timeout
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

Definition at line 266 of file at32f435_437_flash.c.

Referenced by flash_bank2_erase(), flash_block_erase(), flash_byte_program(), flash_halfword_program(), flash_internal_all_erase(), flash_sector_erase(), and flash_word_program().

◆ flash_bank2_unlock()

void flash_bank2_unlock ( void )

unlock the flash bank2 controller.

Parameters
none
Return values
none

< flash operation unlock order key1

< flash operation unlock order key2

Definition at line 314 of file at32f435_437_flash.c.

◆ flash_block_erase()

flash_status_type flash_block_erase ( uint32_t block_address )

erase a specified flash block.

Parameters
block_address the block address to be erased.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash start address of bank1

< flash end address of bank1

< internal flash erase operation timeout

< flash start address of bank2

< flash end address of bank2

< internal flash erase operation timeout

Definition at line 395 of file at32f435_437_flash.c.

◆ flash_byte_program()

flash_status_type flash_byte_program | ( | uint32_t | address,
 |  | uint8_t | data
 | ) |  |

program a byte at a specified address.

Note
this function cannot be used to program spim.
Parameters
address | specifies the address to be programmed.
data | specifies the data to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash start address of bank1

< flash end address of bank1

< internal flash program operation timeout

< flash start address of bank2

< flash end address of bank2

< internal flash program operation timeout

Definition at line 679 of file at32f435_437_flash.c.

Referenced by flash_write_data(), and msc_disk_write().

◆ flash_continue_read_enable()

void flash_continue_read_enable ( confirm_state new_state )

flash continue read enable.

Parameters
new_state new state of the flash continue read enable operation. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 1141 of file at32f435_437_flash.c.

◆ flash_crc_calibrate()

uint32_t flash_crc_calibrate | ( | uint32_t | start_sector,
 |  | uint32_t | sector_cnt
 | ) |  |

flash crc calibration in main block.

Parameters
start_sector crc calibration start sector number sector_cnt: crc calibration sector count
Return values
uint32 crc calibration result

< flash common operation timeout

Definition at line 1115 of file at32f435_437_flash.c.

◆ flash_eopb0_config()

flash_status_type flash_eopb0_config ( flash_usd_eopb0_type data )

config the extend sram byte eopb0 in user system data.

Note
the 256kb and below capacity mcu only support FLASH_EOPB0_SRAM_384K, FLASH_EOPB0_SRAM_448K or FLASH_EOPB0_SRAM_512K.
Parameters
data the eopb0 value. this parameter can be one of the following values:
  • FLASH_EOPB0_SRAM_512K
  • FLASH_EOPB0_SRAM_448K
  • FLASH_EOPB0_SRAM_384K
  • FLASH_EOPB0_SRAM_320K
  • FLASH_EOPB0_SRAM_256K
  • FLASH_EOPB0_SRAM_192K
  • FLASH_EOPB0_SRAM_128K
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash program operation timeout

Definition at line 576 of file at32f435_437_flash.c.

Referenced by extend_sram().

◆ flash_epp_set()

flash_status_type flash_epp_set ( uint32_t * sector_bits )

config erase/program protection for the desired sectors.

Parameters
sector_bits the pointer of the address of the sectors to be erase/program protected. general bit 0~31 every bit is used to protect the 4KB bytes, bit 62~32 every bit is used to protect the 128KB bytes
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash program operation timeout

< internal flash program operation timeout

< internal flash program operation timeout

< internal flash program operation timeout

< internal flash program operation timeout

< internal flash program operation timeout

< internal flash program operation timeout

< internal flash program operation timeout

Definition at line 751 of file at32f435_437_flash.c.

◆ flash_epp_status_get()

void flash_epp_status_get ( uint32_t * sector_bits )

return the flash erase/program protection status.

Parameters
sector_bits pointer to get the epps register.
Return values
none

Definition at line 832 of file at32f435_437_flash.c.

◆ flash_fap_enable()

flash_status_type flash_fap_enable ( confirm_state new_state )

enable or disable the flash access protection.

Note
if the user has already programmed the other user system data before calling this function, must re-program them since this function erase all user system data.
Parameters
new_state new state of the flash access protection. this parameter can be: TRUE or FALSE.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash erase operation timeout

< internal flash erase operation timeout

< flash fap relieve key val

< internal flash erase operation timeout

Definition at line 848 of file at32f435_437_flash.c.

Referenced by main().

◆ flash_fap_status_get()

flag_status flash_fap_status_get ( void )

check the flash access protection status.

Parameters
none
Return values
flash access protection status(SET or RESET)

Definition at line 895 of file at32f435_437_flash.c.

Referenced by flash_user_system_data_erase(), and main().

◆ flash_flag_clear()

void flash_flag_clear ( uint32_t flash_flag )

clear the flash flag.

Parameters
flash_flag specifies the flash flags to clear. this parameter can be any combination of the following values:
  • FLASH_ODF_FLAG
  • FLASH_PRGMERR_FLAG
  • FLASH_EPPERR_FLAG
  • FLASH_BANK1_ODF_FLAG
  • FLASH_BANK1_PRGMERR_FLAG
  • FLASH_BANK1_EPPERR_FLAG
  • FLASH_BANK2_ODF_FLAG
  • FLASH_BANK2_PRGMERR_FLAG
  • FLASH_BANK2_EPPERR_FLAG
Return values
none

Definition at line 105 of file at32f435_437_flash.c.

Referenced by FLASH_IRQHandler(), flash_write(), and main().

◆ flash_flag_get()

flag_status flash_flag_get ( uint32_t flash_flag )

check whether the specified flash flag is set or not.

Parameters
flash_flag specifies the flash flag to check. this parameter can be one of flash flag status:
  • FLASH_OBF_FLAG
  • FLASH_ODF_FLAG
  • FLASH_PRGMERR_FLAG
  • FLASH_EPPERR_FLAG
  • FLASH_BANK1_OBF_FLAG
  • FLASH_BANK1_ODF_FLAG
  • FLASH_BANK1_PRGMERR_FLAG
  • FLASH_BANK1_EPPERR_FLAG
  • FLASH_BANK2_OBF_FLAG
  • FLASH_BANK2_ODF_FLAG
  • FLASH_BANK2_PRGMERR_FLAG
  • FLASH_BANK2_EPPERR_FLAG
  • FLASH_USDERR_FLAG
Return values
the new state of flash_flag (SET or RESET).

Definition at line 63 of file at32f435_437_flash.c.

Referenced by FLASH_IRQHandler().

◆ flash_halfword_program()

flash_status_type flash_halfword_program | ( | uint32_t | address,
 |  | uint16_t | data
 | ) |  |

program a halfword at a specified address.

Parameters
address | specifies the address to be programmed, halfword alignment is recommended.
data | specifies the data to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash start address of bank1

< flash end address of bank1

< internal flash program operation timeout

< flash start address of bank2

< flash end address of bank2

< internal flash program operation timeout

Definition at line 643 of file at32f435_437_flash.c.

Referenced by flash_2kb_write(), and flash_write_nocheck().

◆ flash_internal_all_erase()

flash_status_type flash_internal_all_erase ( void )

erase flash all internal sectors.

Parameters
none
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< internal flash erase operation timeout

< internal flash erase operation timeout

Definition at line 433 of file at32f435_437_flash.c.

◆ flash_interrupt_enable()

void flash_interrupt_enable | ( | uint32_t | flash_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified flash interrupts.

Parameters
flash_int specifies the flash interrupt sources to be enabled or disabled. this parameter can be any combination of the following values:
  • FLASH_ERR_INT
  • FLASH_ODF_INT
  • FLASH_BANK1_ERR_INT
  • FLASH_BANK1_ODF_INT
  • FLASH_BANK2_ERR_INT
  • FLASH_BANK2_ODF_INT
new_state new state of the specified flash interrupts. this parameter can be: TRUE or FALSE.
Return values
none

< flash bank1 error interrupt

< flash bank1 operate done interrupt

< flash bank2 error interrupt

< flash bank2 operate done interrupt

Definition at line 980 of file at32f435_437_flash.c.

Referenced by config_flash_interrupt().

◆ flash_lock()

void flash_lock ( void )

lock the flash controller.

Parameters
none
Return values
none

Definition at line 325 of file at32f435_437_flash.c.

Referenced by config_flash_interrupt(), flash_2kb_write(), flash_fat16_clear_upgrade_flag(), flash_fat16_set_upgrade_flag(), flash_write(), flash_write_data(), iap_clear_upgrade_flag(), iap_command_handle(), iap_data_write(), iap_erase_sector(), iap_init(), iap_set_upgrade_flag(), and msc_disk_write().

◆ flash_nzw_boost_enable()

void flash_nzw_boost_enable ( confirm_state new_state )

flash non-zero wait area boost enable.

Parameters
new_state new state of the flash non-zero wait area boost operation. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 1130 of file at32f435_437_flash.c.

◆ flash_operation_status_get()

flash_status_type flash_operation_status_get ( void )

return the flash operation status.

Parameters
none
Return values
status the returned value can be: FLASH_OPERATE_BUSY, FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR or FLASH_OPERATE_DONE.

Definition at line 129 of file at32f435_437_flash.c.

Referenced by flash_operation_wait_for().

◆ flash_operation_wait_for()

flash_status_type flash_operation_wait_for ( uint32_t time_out )

wait for flash operation complete or timeout.

Parameters
time_out flash operation timeout
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

Definition at line 216 of file at32f435_437_flash.c.

Referenced by flash_crc_calibrate(), flash_eopb0_config(), flash_epp_set(), flash_fap_enable(), flash_slib_disable(), flash_slib_enable(), flash_ssb_set(), flash_user_system_data_erase(), flash_user_system_data_program(), flash_write(), and main().

◆ flash_sector_erase()

flash_status_type flash_sector_erase ( uint32_t sector_address )

erase a specified flash sector.

Parameters
sector_address the sector address to be erased.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash start address of bank1

< flash end address of bank1

< internal flash erase operation timeout

< flash start address of bank2

< flash end address of bank2

< internal flash erase operation timeout

Definition at line 357 of file at32f435_437_flash.c.

Referenced by flash_2kb_write(), flash_fat16_clear_upgrade_flag(), flash_write(), flash_write_data(), iap_clear_upgrade_flag(), iap_command_handle(), iap_erase_sector(), iap_init(), main(), msc_disk_write(), and slib_enable().

◆ flash_slib_disable()

error_status flash_slib_disable ( uint32_t pwd )

disable slib when slib enabled.

Parameters
pwd slib password
Return values
success or error

< internal flash erase operation timeout

Definition at line 1039 of file at32f435_437_flash.c.

◆ flash_slib_enable()

flash_status_type flash_slib_enable | ( | uint32_t | pwd,
 |  | uint16_t | start_sector,
 |  | uint16_t | inst_start_sector,
 |  | uint16_t | end_sector
 | ) |  |

enable security library function.

Parameters
pwd slib password start_sector: security library start sector inst_start_sector: security library i-bus area start sector end_sector: security library end sector
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash slib operation unlock order key

< internal flash program operation timeout

< flash slib end sector

< flash slib start sector

< internal flash program operation timeout

< flash slib i-bus area start sector

< internal flash program operation timeout

Definition at line 1001 of file at32f435_437_flash.c.

Referenced by slib_enable().

◆ flash_slib_end_sector_get()

uint16_t flash_slib_end_sector_get ( void )

get the end sector of slib.

Parameters
none
Return values
uint16_t

Definition at line 1104 of file at32f435_437_flash.c.

◆ flash_slib_inststart_sector_get()

uint16_t flash_slib_inststart_sector_get ( void )

get the instruction start sector of slib.

Parameters
none
Return values
uint16_t

Definition at line 1094 of file at32f435_437_flash.c.

◆ flash_slib_remaining_count_get()

uint32_t flash_slib_remaining_count_get ( void )

get remaining count of slib(range: 256~0).

Parameters
none
Return values
uint32_t

Definition at line 1061 of file at32f435_437_flash.c.

◆ flash_slib_start_sector_get()

uint16_t flash_slib_start_sector_get ( void )

get the start sector of slib.

Parameters
none
Return values
uint16_t

Definition at line 1084 of file at32f435_437_flash.c.

◆ flash_slib_state_get()

flag_status flash_slib_state_get ( void )

get the slib state.

Parameters
none
Return values
SET or RESET

Definition at line 1071 of file at32f435_437_flash.c.

Referenced by main().

◆ flash_ssb_set()

flash_status_type flash_ssb_set ( uint8_t usd_ssb )

program the flash system setting byte in usd: wdt_ato_en / depslp_rst / stdby_rst / btopt.

Parameters
usd_ssb the system setting byte
Note
this parameter usd_ssb must contain a combination of all the following 6 types of data type 1: wdt_ato_en, select the wdt auto start this data can be one of the following values:
  • USD_WDT_ATO_DISABLE: disable wdt auto start
  • USD_WDT_ATO_ENABLE: enable wdt auto start type 2: depslp_rst, reset event when entering deepsleep mode. this data can be one of the following values:
  • USD_DEPSLP_NO_RST: no reset generated when entering in deepsleep
  • USD_DEPSLP_RST: reset generated when entering in deepsleep type 3: stdby_rst, reset event when entering standby mode. this data can be one of the following values:
  • USD_STDBY_NO_RST: no reset generated when entering in standby
  • USD_STDBY_RST: reset generated when entering in standby type 4: btopt, at startup,if boot pins are set in boot from user flash position,selected the device boot from bank1/bank2. this data can be one of the following values:
  • FLASH_BOOT_FROM_BANK1:boot from bank1
  • FLASH_BOOT_FROM_BANK2:boot from bank 2 or bank 1 type 5: wdt_depslp, wdt stop/continue count when entering in deepsleep. this data can be one of the following values:
  • USD_WDT_DEPSLP_CONTINUE: wdt continue count
  • USD_WDT_DEPSLP_STOP: wdt stop count type 6: wdt_stdby, wdt stop/continue count when entering in standby. this data can be one of the following values:
  • USD_WDT_STDBY_CONTINUE: wdt continue count
  • USD_WDT_STDBY_STOP: wdt stop count
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash program operation timeout

Definition at line 931 of file at32f435_437_flash.c.

◆ flash_ssb_status_get()

uint8_t flash_ssb_status_get ( void )

return the flash system setting byte status.

Parameters
none
Return values
values from flash_usd register: wdt_ato_en(bit0), depslp_rst(bit1), stdby_rst(bit2) and btopt(bit3).

Definition at line 960 of file at32f435_437_flash.c.

◆ flash_unlock()

void flash_unlock ( void )

unlock the flash controller.

Parameters
none
Return values
none

< flash operation unlock order key1

< flash operation unlock order key2

< flash operation unlock order key1

< flash operation unlock order key2

Definition at line 290 of file at32f435_437_flash.c.

Referenced by config_flash_interrupt(), extend_sram(), flash_2kb_write(), flash_fat16_clear_upgrade_flag(), flash_fat16_set_upgrade_flag(), flash_write(), flash_write_data(), iap_clear_upgrade_flag(), iap_command_handle(), iap_data_write(), iap_erase_sector(), iap_init(), iap_set_upgrade_flag(), main(), msc_disk_write(), and slib_enable().

◆ flash_user_system_data_erase()

flash_status_type flash_user_system_data_erase ( void )

erase the flash user system data.

Note
this functions erase all user system data except the fap byte. the eopb0 byte value change to 0xFF, sram size maybe change too.
Parameters
none
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash fap relieve key val

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash erase operation timeout

< flash fap relieve key val

< internal flash program operation timeout

Definition at line 516 of file at32f435_437_flash.c.

Referenced by extend_sram().

◆ flash_user_system_data_program()

flash_status_type flash_user_system_data_program | ( | uint32_t | address,
 |  | uint8_t | data
 | ) |  |

program a halfword at a specified user system data address.

Parameters
address | specifies the address to be programmed.
data | specifies the data to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash program operation timeout

Definition at line 713 of file at32f435_437_flash.c.

◆ flash_word_program()

flash_status_type flash_word_program | ( | uint32_t | address,
 |  | uint32_t | data
 | ) |  |

program a word at a specified address.

Parameters
address | specifies the address to be programmed, word alignment is recommended.
data | specifies the data to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash start address of bank1

< flash end address of bank1

< internal flash program operation timeout

< flash start address of bank2

< flash end address of bank2

< internal flash program operation timeout

Definition at line 608 of file at32f435_437_flash.c.

Referenced by flash_fat16_set_upgrade_flag(), flash_if_write(), iap_command_handle(), iap_data_write(), iap_set_upgrade_flag(), and slib_enable().


AT32F435/437 Firmwary Library: FLASH_private_functions

Functions
FLASH_private_functions
AT32F435_437_periph_driver » FLASH

Functions

flag_status | flash_flag_get (uint32_t flash_flag)
check whether the specified flash flag is set or not. More...
void | flash_flag_clear (uint32_t flash_flag)
clear the flash flag. More...
flash_status_type | flash_operation_status_get (void)
return the flash operation status. More...
flash_status_type | flash_bank1_operation_status_get (void)
return the flash bank1 operation status. More...
flash_status_type | flash_bank2_operation_status_get (void)
return the flash bank2 operation status. More...
flash_status_type | flash_operation_wait_for (uint32_t time_out)
wait for flash operation complete or timeout. More...
flash_status_type | flash_bank1_operation_wait_for (uint32_t time_out)
wait for flash bank1 operation complete or timeout. More...
flash_status_type | flash_bank2_operation_wait_for (uint32_t time_out)
wait for flash bank2 operation complete or timeout. More...
void | flash_unlock (void)
unlock the flash controller. More...
void | flash_bank1_unlock (void)
unlock the flash bank1 controller. More...
void | flash_bank2_unlock (void)
unlock the flash bank2 controller. More...
void | flash_lock (void)
lock the flash controller. More...
void | flash_bank1_lock (void)
lock the flash bank1 controller. More...
void | flash_bank2_lock (void)
lock the flash bank2 controller. More...
flash_status_type | flash_sector_erase (uint32_t sector_address)
erase a specified flash sector. More...
flash_status_type | flash_block_erase (uint32_t block_address)
erase a specified flash block. More...
flash_status_type | flash_internal_all_erase (void)
erase flash all internal sectors. More...
flash_status_type | flash_bank1_erase (void)
erase flash bank1 sectors. More...
flash_status_type | flash_bank2_erase (void)
erase flash bank2 sectors. More...
flash_status_type | flash_user_system_data_erase (void)
erase the flash user system data. More...
flash_status_type | flash_eopb0_config (flash_usd_eopb0_type data)
config the extend sram byte eopb0 in user system data. More...
flash_status_type | flash_word_program (uint32_t address, uint32_t data)
program a word at a specified address. More...
flash_status_type | flash_halfword_program (uint32_t address, uint16_t data)
program a halfword at a specified address. More...
flash_status_type | flash_byte_program (uint32_t address, uint8_t data)
program a byte at a specified address. More...
flash_status_type | flash_user_system_data_program (uint32_t address, uint8_t data)
program a halfword at a specified user system data address. More...
flash_status_type | flash_epp_set (uint32_t *sector_bits)
config erase/program protection for the desired sectors. More...
void | flash_epp_status_get (uint32_t *sector_bits)
return the flash erase/program protection status. More...
flash_status_type | flash_fap_enable (confirm_state new_state)
enable or disable the flash access protection. More...
flag_status | flash_fap_status_get (void)
check the flash access protection status. More...
flash_status_type | flash_ssb_set (uint8_t usd_ssb)
program the flash system setting byte in usd: wdt_ato_en / depslp_rst / stdby_rst / btopt. More...
uint8_t | flash_ssb_status_get (void)
return the flash system setting byte status. More...
void | flash_interrupt_enable (uint32_t flash_int, confirm_state new_state)
enable or disable the specified flash interrupts. More...
flash_status_type | flash_slib_enable (uint32_t pwd, uint16_t start_sector, uint16_t inst_start_sector, uint16_t end_sector)
enable security library function. More...
error_status | flash_slib_disable (uint32_t pwd)
disable slib when slib enabled. More...
uint32_t | flash_slib_remaining_count_get (void)
get remaining count of slib(range: 256~0). More...
flag_status | flash_slib_state_get (void)
get the slib state. More...
uint16_t | flash_slib_start_sector_get (void)
get the start sector of slib. More...
uint16_t | flash_slib_inststart_sector_get (void)
get the instruction start sector of slib. More...
uint16_t | flash_slib_end_sector_get (void)
get the end sector of slib. More...
uint32_t | flash_crc_calibrate (uint32_t start_sector, uint32_t sector_cnt)
flash crc calibration in main block. More...
void | flash_nzw_boost_enable (confirm_state new_state)
flash non-zero wait area boost enable. More...
void | flash_continue_read_enable (confirm_state new_state)
flash continue read enable. More...

Detailed Description

Function Documentation

◆ flash_bank1_erase()

flash_status_type flash_bank1_erase ( void )

erase flash bank1 sectors.

Parameters
none
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< internal flash erase operation timeout

Definition at line 468 of file at32f435_437_flash.c.

◆ flash_bank1_lock()

void flash_bank1_lock ( void )

lock the flash bank1 controller.

Parameters
none
Return values
none

Definition at line 336 of file at32f435_437_flash.c.

◆ flash_bank1_operation_status_get()

flash_status_type flash_bank1_operation_status_get ( void )

return the flash bank1 operation status.

Parameters
none
Return values
status the returned value can be: FLASH_OPERATE_BUSY, FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR or FLASH_OPERATE_DONE.

Definition at line 158 of file at32f435_437_flash.c.

Referenced by flash_bank1_operation_wait_for().

◆ flash_bank1_operation_wait_for()

flash_status_type flash_bank1_operation_wait_for ( uint32_t time_out )

wait for flash bank1 operation complete or timeout.

Parameters
time_out flash operation timeout
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

Definition at line 241 of file at32f435_437_flash.c.

Referenced by flash_bank1_erase(), flash_block_erase(), flash_byte_program(), flash_halfword_program(), flash_internal_all_erase(), flash_sector_erase(), and flash_word_program().

◆ flash_bank1_unlock()

void flash_bank1_unlock ( void )

unlock the flash bank1 controller.

Parameters
none
Return values
none

< flash operation unlock order key1

< flash operation unlock order key2

Definition at line 303 of file at32f435_437_flash.c.

◆ flash_bank2_erase()

flash_status_type flash_bank2_erase ( void )

erase flash bank2 sectors.

Parameters
none
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< internal flash erase operation timeout

Definition at line 491 of file at32f435_437_flash.c.

◆ flash_bank2_lock()

void flash_bank2_lock ( void )

lock the flash bank2 controller.

Parameters
none
Return values
none

Definition at line 346 of file at32f435_437_flash.c.

◆ flash_bank2_operation_status_get()

flash_status_type flash_bank2_operation_status_get ( void )

return the flash bank2 operation status.

Parameters
none
Return values
status the returned value can be: FLASH_OPERATE_BUSY, FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR or FLASH_OPERATE_DONE.

Definition at line 187 of file at32f435_437_flash.c.

Referenced by flash_bank2_operation_wait_for().

◆ flash_bank2_operation_wait_for()

flash_status_type flash_bank2_operation_wait_for ( uint32_t time_out )

wait for flash bank2 operation complete or timeout.

Parameters
time_out flash operation timeout
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

Definition at line 266 of file at32f435_437_flash.c.

Referenced by flash_bank2_erase(), flash_block_erase(), flash_byte_program(), flash_halfword_program(), flash_internal_all_erase(), flash_sector_erase(), and flash_word_program().

◆ flash_bank2_unlock()

void flash_bank2_unlock ( void )

unlock the flash bank2 controller.

Parameters
none
Return values
none

< flash operation unlock order key1

< flash operation unlock order key2

Definition at line 314 of file at32f435_437_flash.c.

◆ flash_block_erase()

flash_status_type flash_block_erase ( uint32_t block_address )

erase a specified flash block.

Parameters
block_address the block address to be erased.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash start address of bank1

< flash end address of bank1

< internal flash erase operation timeout

< flash start address of bank2

< flash end address of bank2

< internal flash erase operation timeout

Definition at line 395 of file at32f435_437_flash.c.

◆ flash_byte_program()

flash_status_type flash_byte_program | ( | uint32_t | address,
 |  | uint8_t | data
 | ) |  |

program a byte at a specified address.

Note
this function cannot be used to program spim.
Parameters
address | specifies the address to be programmed.
data | specifies the data to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash start address of bank1

< flash end address of bank1

< internal flash program operation timeout

< flash start address of bank2

< flash end address of bank2

< internal flash program operation timeout

Definition at line 679 of file at32f435_437_flash.c.

Referenced by flash_write_data(), and msc_disk_write().

◆ flash_continue_read_enable()

void flash_continue_read_enable ( confirm_state new_state )

flash continue read enable.

Parameters
new_state new state of the flash continue read enable operation. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 1141 of file at32f435_437_flash.c.

◆ flash_crc_calibrate()

uint32_t flash_crc_calibrate | ( | uint32_t | start_sector,
 |  | uint32_t | sector_cnt
 | ) |  |

flash crc calibration in main block.

Parameters
start_sector crc calibration start sector number sector_cnt: crc calibration sector count
Return values
uint32 crc calibration result

< flash common operation timeout

Definition at line 1115 of file at32f435_437_flash.c.

◆ flash_eopb0_config()

flash_status_type flash_eopb0_config ( flash_usd_eopb0_type data )

config the extend sram byte eopb0 in user system data.

Note
the 256kb and below capacity mcu only support FLASH_EOPB0_SRAM_384K, FLASH_EOPB0_SRAM_448K or FLASH_EOPB0_SRAM_512K.
Parameters
data the eopb0 value. this parameter can be one of the following values:
  • FLASH_EOPB0_SRAM_512K
  • FLASH_EOPB0_SRAM_448K
  • FLASH_EOPB0_SRAM_384K
  • FLASH_EOPB0_SRAM_320K
  • FLASH_EOPB0_SRAM_256K
  • FLASH_EOPB0_SRAM_192K
  • FLASH_EOPB0_SRAM_128K
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash program operation timeout

Definition at line 576 of file at32f435_437_flash.c.

Referenced by extend_sram().

◆ flash_epp_set()

flash_status_type flash_epp_set ( uint32_t * sector_bits )

config erase/program protection for the desired sectors.

Parameters
sector_bits the pointer of the address of the sectors to be erase/program protected. general bit 0~31 every bit is used to protect the 4KB bytes, bit 62~32 every bit is used to protect the 128KB bytes
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash program operation timeout

< internal flash program operation timeout

< internal flash program operation timeout

< internal flash program operation timeout

< internal flash program operation timeout

< internal flash program operation timeout

< internal flash program operation timeout

< internal flash program operation timeout

Definition at line 751 of file at32f435_437_flash.c.

◆ flash_epp_status_get()

void flash_epp_status_get ( uint32_t * sector_bits )

return the flash erase/program protection status.

Parameters
sector_bits pointer to get the epps register.
Return values
none

Definition at line 832 of file at32f435_437_flash.c.

◆ flash_fap_enable()

flash_status_type flash_fap_enable ( confirm_state new_state )

enable or disable the flash access protection.

Note
if the user has already programmed the other user system data before calling this function, must re-program them since this function erase all user system data.
Parameters
new_state new state of the flash access protection. this parameter can be: TRUE or FALSE.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash erase operation timeout

< internal flash erase operation timeout

< flash fap relieve key val

< internal flash erase operation timeout

Definition at line 848 of file at32f435_437_flash.c.

Referenced by main().

◆ flash_fap_status_get()

flag_status flash_fap_status_get ( void )

check the flash access protection status.

Parameters
none
Return values
flash access protection status(SET or RESET)

Definition at line 895 of file at32f435_437_flash.c.

Referenced by flash_user_system_data_erase(), and main().

◆ flash_flag_clear()

void flash_flag_clear ( uint32_t flash_flag )

clear the flash flag.

Parameters
flash_flag specifies the flash flags to clear. this parameter can be any combination of the following values:
  • FLASH_ODF_FLAG
  • FLASH_PRGMERR_FLAG
  • FLASH_EPPERR_FLAG
  • FLASH_BANK1_ODF_FLAG
  • FLASH_BANK1_PRGMERR_FLAG
  • FLASH_BANK1_EPPERR_FLAG
  • FLASH_BANK2_ODF_FLAG
  • FLASH_BANK2_PRGMERR_FLAG
  • FLASH_BANK2_EPPERR_FLAG
Return values
none

Definition at line 105 of file at32f435_437_flash.c.

Referenced by FLASH_IRQHandler(), flash_write(), and main().

◆ flash_flag_get()

flag_status flash_flag_get ( uint32_t flash_flag )

check whether the specified flash flag is set or not.

Parameters
flash_flag specifies the flash flag to check. this parameter can be one of flash flag status:
  • FLASH_OBF_FLAG
  • FLASH_ODF_FLAG
  • FLASH_PRGMERR_FLAG
  • FLASH_EPPERR_FLAG
  • FLASH_BANK1_OBF_FLAG
  • FLASH_BANK1_ODF_FLAG
  • FLASH_BANK1_PRGMERR_FLAG
  • FLASH_BANK1_EPPERR_FLAG
  • FLASH_BANK2_OBF_FLAG
  • FLASH_BANK2_ODF_FLAG
  • FLASH_BANK2_PRGMERR_FLAG
  • FLASH_BANK2_EPPERR_FLAG
  • FLASH_USDERR_FLAG
Return values
the new state of flash_flag (SET or RESET).

Definition at line 63 of file at32f435_437_flash.c.

Referenced by FLASH_IRQHandler().

◆ flash_halfword_program()

flash_status_type flash_halfword_program | ( | uint32_t | address,
 |  | uint16_t | data
 | ) |  |

program a halfword at a specified address.

Parameters
address | specifies the address to be programmed, halfword alignment is recommended.
data | specifies the data to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash start address of bank1

< flash end address of bank1

< internal flash program operation timeout

< flash start address of bank2

< flash end address of bank2

< internal flash program operation timeout

Definition at line 643 of file at32f435_437_flash.c.

Referenced by flash_2kb_write(), and flash_write_nocheck().

◆ flash_internal_all_erase()

flash_status_type flash_internal_all_erase ( void )

erase flash all internal sectors.

Parameters
none
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< internal flash erase operation timeout

< internal flash erase operation timeout

Definition at line 433 of file at32f435_437_flash.c.

◆ flash_interrupt_enable()

void flash_interrupt_enable | ( | uint32_t | flash_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified flash interrupts.

Parameters
flash_int specifies the flash interrupt sources to be enabled or disabled. this parameter can be any combination of the following values:
  • FLASH_ERR_INT
  • FLASH_ODF_INT
  • FLASH_BANK1_ERR_INT
  • FLASH_BANK1_ODF_INT
  • FLASH_BANK2_ERR_INT
  • FLASH_BANK2_ODF_INT
new_state new state of the specified flash interrupts. this parameter can be: TRUE or FALSE.
Return values
none

< flash bank1 error interrupt

< flash bank1 operate done interrupt

< flash bank2 error interrupt

< flash bank2 operate done interrupt

Definition at line 980 of file at32f435_437_flash.c.

Referenced by config_flash_interrupt().

◆ flash_lock()

void flash_lock ( void )

lock the flash controller.

Parameters
none
Return values
none

Definition at line 325 of file at32f435_437_flash.c.

Referenced by config_flash_interrupt(), flash_2kb_write(), flash_fat16_clear_upgrade_flag(), flash_fat16_set_upgrade_flag(), flash_write(), flash_write_data(), iap_clear_upgrade_flag(), iap_command_handle(), iap_data_write(), iap_erase_sector(), iap_init(), iap_set_upgrade_flag(), and msc_disk_write().

◆ flash_nzw_boost_enable()

void flash_nzw_boost_enable ( confirm_state new_state )

flash non-zero wait area boost enable.

Parameters
new_state new state of the flash non-zero wait area boost operation. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 1130 of file at32f435_437_flash.c.

◆ flash_operation_status_get()

flash_status_type flash_operation_status_get ( void )

return the flash operation status.

Parameters
none
Return values
status the returned value can be: FLASH_OPERATE_BUSY, FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR or FLASH_OPERATE_DONE.

Definition at line 129 of file at32f435_437_flash.c.

Referenced by flash_operation_wait_for().

◆ flash_operation_wait_for()

flash_status_type flash_operation_wait_for ( uint32_t time_out )

wait for flash operation complete or timeout.

Parameters
time_out flash operation timeout
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

Definition at line 216 of file at32f435_437_flash.c.

Referenced by flash_crc_calibrate(), flash_eopb0_config(), flash_epp_set(), flash_fap_enable(), flash_slib_disable(), flash_slib_enable(), flash_ssb_set(), flash_user_system_data_erase(), flash_user_system_data_program(), flash_write(), and main().

◆ flash_sector_erase()

flash_status_type flash_sector_erase ( uint32_t sector_address )

erase a specified flash sector.

Parameters
sector_address the sector address to be erased.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash start address of bank1

< flash end address of bank1

< internal flash erase operation timeout

< flash start address of bank2

< flash end address of bank2

< internal flash erase operation timeout

Definition at line 357 of file at32f435_437_flash.c.

Referenced by flash_2kb_write(), flash_fat16_clear_upgrade_flag(), flash_write(), flash_write_data(), iap_clear_upgrade_flag(), iap_command_handle(), iap_erase_sector(), iap_init(), main(), msc_disk_write(), and slib_enable().

◆ flash_slib_disable()

error_status flash_slib_disable ( uint32_t pwd )

disable slib when slib enabled.

Parameters
pwd slib password
Return values
success or error

< internal flash erase operation timeout

Definition at line 1039 of file at32f435_437_flash.c.

◆ flash_slib_enable()

flash_status_type flash_slib_enable | ( | uint32_t | pwd,
 |  | uint16_t | start_sector,
 |  | uint16_t | inst_start_sector,
 |  | uint16_t | end_sector
 | ) |  |

enable security library function.

Parameters
pwd slib password start_sector: security library start sector inst_start_sector: security library i-bus area start sector end_sector: security library end sector
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash slib operation unlock order key

< internal flash program operation timeout

< flash slib end sector

< flash slib start sector

< internal flash program operation timeout

< flash slib i-bus area start sector

< internal flash program operation timeout

Definition at line 1001 of file at32f435_437_flash.c.

Referenced by slib_enable().

◆ flash_slib_end_sector_get()

uint16_t flash_slib_end_sector_get ( void )

get the end sector of slib.

Parameters
none
Return values
uint16_t

Definition at line 1104 of file at32f435_437_flash.c.

◆ flash_slib_inststart_sector_get()

uint16_t flash_slib_inststart_sector_get ( void )

get the instruction start sector of slib.

Parameters
none
Return values
uint16_t

Definition at line 1094 of file at32f435_437_flash.c.

◆ flash_slib_remaining_count_get()

uint32_t flash_slib_remaining_count_get ( void )

get remaining count of slib(range: 256~0).

Parameters
none
Return values
uint32_t

Definition at line 1061 of file at32f435_437_flash.c.

◆ flash_slib_start_sector_get()

uint16_t flash_slib_start_sector_get ( void )

get the start sector of slib.

Parameters
none
Return values
uint16_t

Definition at line 1084 of file at32f435_437_flash.c.

◆ flash_slib_state_get()

flag_status flash_slib_state_get ( void )

get the slib state.

Parameters
none
Return values
SET or RESET

Definition at line 1071 of file at32f435_437_flash.c.

Referenced by main().

◆ flash_ssb_set()

flash_status_type flash_ssb_set ( uint8_t usd_ssb )

program the flash system setting byte in usd: wdt_ato_en / depslp_rst / stdby_rst / btopt.

Parameters
usd_ssb the system setting byte
Note
this parameter usd_ssb must contain a combination of all the following 6 types of data type 1: wdt_ato_en, select the wdt auto start this data can be one of the following values:
  • USD_WDT_ATO_DISABLE: disable wdt auto start
  • USD_WDT_ATO_ENABLE: enable wdt auto start type 2: depslp_rst, reset event when entering deepsleep mode. this data can be one of the following values:
  • USD_DEPSLP_NO_RST: no reset generated when entering in deepsleep
  • USD_DEPSLP_RST: reset generated when entering in deepsleep type 3: stdby_rst, reset event when entering standby mode. this data can be one of the following values:
  • USD_STDBY_NO_RST: no reset generated when entering in standby
  • USD_STDBY_RST: reset generated when entering in standby type 4: btopt, at startup,if boot pins are set in boot from user flash position,selected the device boot from bank1/bank2. this data can be one of the following values:
  • FLASH_BOOT_FROM_BANK1:boot from bank1
  • FLASH_BOOT_FROM_BANK2:boot from bank 2 or bank 1 type 5: wdt_depslp, wdt stop/continue count when entering in deepsleep. this data can be one of the following values:
  • USD_WDT_DEPSLP_CONTINUE: wdt continue count
  • USD_WDT_DEPSLP_STOP: wdt stop count type 6: wdt_stdby, wdt stop/continue count when entering in standby. this data can be one of the following values:
  • USD_WDT_STDBY_CONTINUE: wdt continue count
  • USD_WDT_STDBY_STOP: wdt stop count
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash program operation timeout

Definition at line 931 of file at32f435_437_flash.c.

◆ flash_ssb_status_get()

uint8_t flash_ssb_status_get ( void )

return the flash system setting byte status.

Parameters
none
Return values
values from flash_usd register: wdt_ato_en(bit0), depslp_rst(bit1), stdby_rst(bit2) and btopt(bit3).

Definition at line 960 of file at32f435_437_flash.c.

◆ flash_unlock()

void flash_unlock ( void )

unlock the flash controller.

Parameters
none
Return values
none

< flash operation unlock order key1

< flash operation unlock order key2

< flash operation unlock order key1

< flash operation unlock order key2

Definition at line 290 of file at32f435_437_flash.c.

Referenced by config_flash_interrupt(), extend_sram(), flash_2kb_write(), flash_fat16_clear_upgrade_flag(), flash_fat16_set_upgrade_flag(), flash_write(), flash_write_data(), iap_clear_upgrade_flag(), iap_command_handle(), iap_data_write(), iap_erase_sector(), iap_init(), iap_set_upgrade_flag(), main(), msc_disk_write(), and slib_enable().

◆ flash_user_system_data_erase()

flash_status_type flash_user_system_data_erase ( void )

erase the flash user system data.

Note
this functions erase all user system data except the fap byte. the eopb0 byte value change to 0xFF, sram size maybe change too.
Parameters
none
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash fap relieve key val

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash erase operation timeout

< flash fap relieve key val

< internal flash program operation timeout

Definition at line 516 of file at32f435_437_flash.c.

Referenced by extend_sram().

◆ flash_user_system_data_program()

flash_status_type flash_user_system_data_program | ( | uint32_t | address,
 |  | uint8_t | data
 | ) |  |

program a halfword at a specified user system data address.

Parameters
address | specifies the address to be programmed.
data | specifies the data to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash program operation timeout

Definition at line 713 of file at32f435_437_flash.c.

◆ flash_word_program()

flash_status_type flash_word_program | ( | uint32_t | address,
 |  | uint32_t | data
 | ) |  |

program a word at a specified address.

Parameters
address | specifies the address to be programmed, word alignment is recommended.
data | specifies the data to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash start address of bank1

< flash end address of bank1

< internal flash program operation timeout

< flash start address of bank2

< flash end address of bank2

< internal flash program operation timeout

Definition at line 608 of file at32f435_437_flash.c.

Referenced by flash_fat16_set_upgrade_flag(), flash_if_write(), iap_command_handle(), iap_data_write(), iap_set_upgrade_flag(), and slib_enable().


AT32F435/437 Firmwary Library: GPIO

Modules | Macros
GPIO
AT32F435_437_periph_driver

GPIO driver modules. More...

Modules

GPIO_pins_number_definition
GPIO_exported_types
GPIO_exported_functions
GPIO_private_functions

Macros

#define | GPIOA ((gpio_type *) GPIOA_BASE)
#define | GPIOB ((gpio_type *) GPIOB_BASE)
#define | GPIOC ((gpio_type *) GPIOC_BASE)
#define | GPIOD ((gpio_type *) GPIOD_BASE)
#define | GPIOE ((gpio_type *) GPIOE_BASE)
#define | GPIOF ((gpio_type *) GPIOF_BASE)
#define | GPIOG ((gpio_type *) GPIOG_BASE)
#define | GPIOH ((gpio_type *) GPIOH_BASE)

Detailed Description

GPIO driver modules.

Macro Definition Documentation

◆ GPIOA

#define GPIOA ((gpio_type *) GPIOA_BASE)

Definition at line 521 of file at32f435_437_gpio.h.

◆ GPIOB

#define GPIOB ((gpio_type *) GPIOB_BASE)

Definition at line 522 of file at32f435_437_gpio.h.

◆ GPIOC

#define GPIOC ((gpio_type *) GPIOC_BASE)

Definition at line 523 of file at32f435_437_gpio.h.

◆ GPIOD

#define GPIOD ((gpio_type *) GPIOD_BASE)

Definition at line 524 of file at32f435_437_gpio.h.

◆ GPIOE

#define GPIOE ((gpio_type *) GPIOE_BASE)

Definition at line 525 of file at32f435_437_gpio.h.

◆ GPIOF

#define GPIOF ((gpio_type *) GPIOF_BASE)

Definition at line 526 of file at32f435_437_gpio.h.

◆ GPIOG

#define GPIOG ((gpio_type *) GPIOG_BASE)

Definition at line 527 of file at32f435_437_gpio.h.

◆ GPIOH

#define GPIOH ((gpio_type *) GPIOH_BASE)

Definition at line 528 of file at32f435_437_gpio.h.


AT32F435/437 Firmwary Library: GPIO_pins_number_definition

Macros
GPIO_pins_number_definition
AT32F435_437_periph_driver » GPIO

Macros

#define | GPIO_PINS_0 0x0001
#define | GPIO_PINS_1 0x0002
#define | GPIO_PINS_2 0x0004
#define | GPIO_PINS_3 0x0008
#define | GPIO_PINS_4 0x0010
#define | GPIO_PINS_5 0x0020
#define | GPIO_PINS_6 0x0040
#define | GPIO_PINS_7 0x0080
#define | GPIO_PINS_8 0x0100
#define | GPIO_PINS_9 0x0200
#define | GPIO_PINS_10 0x0400
#define | GPIO_PINS_11 0x0800
#define | GPIO_PINS_12 0x1000
#define | GPIO_PINS_13 0x2000
#define | GPIO_PINS_14 0x4000
#define | GPIO_PINS_15 0x8000
#define | GPIO_PINS_ALL 0xFFFF

Detailed Description

Macro Definition Documentation

◆ GPIO_PINS_0

#define GPIO_PINS_0 0x0001

gpio pins number 0

Definition at line 51 of file at32f435_437_gpio.h.

◆ GPIO_PINS_1

#define GPIO_PINS_1 0x0002

gpio pins number 1

Definition at line 52 of file at32f435_437_gpio.h.

◆ GPIO_PINS_10

#define GPIO_PINS_10 0x0400

gpio pins number 10

Definition at line 61 of file at32f435_437_gpio.h.

◆ GPIO_PINS_11

#define GPIO_PINS_11 0x0800

gpio pins number 11

Definition at line 62 of file at32f435_437_gpio.h.

◆ GPIO_PINS_12

#define GPIO_PINS_12 0x1000

gpio pins number 12

Definition at line 63 of file at32f435_437_gpio.h.

◆ GPIO_PINS_13

#define GPIO_PINS_13 0x2000

gpio pins number 13

Definition at line 64 of file at32f435_437_gpio.h.

◆ GPIO_PINS_14

#define GPIO_PINS_14 0x4000

gpio pins number 14

Definition at line 65 of file at32f435_437_gpio.h.

◆ GPIO_PINS_15

#define GPIO_PINS_15 0x8000

gpio pins number 15

Definition at line 66 of file at32f435_437_gpio.h.

◆ GPIO_PINS_2

#define GPIO_PINS_2 0x0004

gpio pins number 2

Definition at line 53 of file at32f435_437_gpio.h.

◆ GPIO_PINS_3

#define GPIO_PINS_3 0x0008

gpio pins number 3

Definition at line 54 of file at32f435_437_gpio.h.

◆ GPIO_PINS_4

#define GPIO_PINS_4 0x0010

gpio pins number 4

Definition at line 55 of file at32f435_437_gpio.h.

◆ GPIO_PINS_5

#define GPIO_PINS_5 0x0020

gpio pins number 5

Definition at line 56 of file at32f435_437_gpio.h.

◆ GPIO_PINS_6

#define GPIO_PINS_6 0x0040

gpio pins number 6

Definition at line 57 of file at32f435_437_gpio.h.

◆ GPIO_PINS_7

#define GPIO_PINS_7 0x0080

gpio pins number 7

Definition at line 58 of file at32f435_437_gpio.h.

◆ GPIO_PINS_8

#define GPIO_PINS_8 0x0100

gpio pins number 8

Definition at line 59 of file at32f435_437_gpio.h.

◆ GPIO_PINS_9

#define GPIO_PINS_9 0x0200

gpio pins number 9

Definition at line 60 of file at32f435_437_gpio.h.

◆ GPIO_PINS_ALL

#define GPIO_PINS_ALL 0xFFFF

gpio all pins

Definition at line 67 of file at32f435_437_gpio.h.


AT32F435/437 Firmwary Library: GPIO_exported_types

Data Structures | Enumerations
GPIO_exported_types
AT32F435_437_periph_driver » GPIO

Data Structures

struct | gpio_init_type
gpio init type More...
struct | gpio_type
type define gpio register all More...

Enumerations

enum | gpio_mode_type { GPIO_MODE_INPUT = 0x00 , GPIO_MODE_OUTPUT = 0x01 , GPIO_MODE_MUX = 0x02 , GPIO_MODE_ANALOG = 0x03 }
gpio mode select More...
enum | gpio_drive_type { GPIO_DRIVE_STRENGTH_STRONGER = 0x01 , GPIO_DRIVE_STRENGTH_MODERATE = 0x02 }
gpio output drive strength select More...
enum | gpio_output_type { GPIO_OUTPUT_PUSH_PULL = 0x00 , GPIO_OUTPUT_OPEN_DRAIN = 0x01 }
gpio output type More...
enum | gpio_pull_type { GPIO_PULL_NONE = 0x00 , GPIO_PULL_UP = 0x01 , GPIO_PULL_DOWN = 0x02 }
gpio pull type More...
enum gpio_pins_source_type {
GPIO_PINS_SOURCE0 = 0x00 , GPIO_PINS_SOURCE1 = 0x01 , GPIO_PINS_SOURCE2 = 0x02 , GPIO_PINS_SOURCE3 = 0x03 ,
GPIO_PINS_SOURCE4 = 0x04 , GPIO_PINS_SOURCE5 = 0x05 , GPIO_PINS_SOURCE6 = 0x06 , GPIO_PINS_SOURCE7 = 0x07 ,
GPIO_PINS_SOURCE8 = 0x08 , GPIO_PINS_SOURCE9 = 0x09 , GPIO_PINS_SOURCE10 = 0x0A , GPIO_PINS_SOURCE11 = 0x0B ,
GPIO_PINS_SOURCE12 = 0x0C , GPIO_PINS_SOURCE13 = 0x0D , GPIO_PINS_SOURCE14 = 0x0E , GPIO_PINS_SOURCE15 = 0x0F
}
gpio pins source type More...
enum gpio_mux_sel_type {
GPIO_MUX_0 = 0x00 , GPIO_MUX_1 = 0x01 , GPIO_MUX_2 = 0x02 , GPIO_MUX_3 = 0x03 ,
GPIO_MUX_4 = 0x04 , GPIO_MUX_5 = 0x05 , GPIO_MUX_6 = 0x06 , GPIO_MUX_7 = 0x07 ,
GPIO_MUX_8 = 0x08 , GPIO_MUX_9 = 0x09 , GPIO_MUX_10 = 0x0A , GPIO_MUX_11 = 0x0B ,
GPIO_MUX_12 = 0x0C , GPIO_MUX_13 = 0x0D , GPIO_MUX_14 = 0x0E , GPIO_MUX_15 = 0x0F
}
gpio muxing function selection type More...

Detailed Description

Enumeration Type Documentation

◆ gpio_drive_type

enum gpio_drive_type

gpio output drive strength select

Enumerator
GPIO_DRIVE_STRENGTH_STRONGER | stronger sourcing/sinking strength
GPIO_DRIVE_STRENGTH_MODERATE | moderate sourcing/sinking strength

Definition at line 91 of file at32f435_437_gpio.h.

◆ gpio_mode_type

enum gpio_mode_type

gpio mode select

Enumerator
GPIO_MODE_INPUT | gpio input mode
GPIO_MODE_OUTPUT | gpio output mode
GPIO_MODE_MUX | gpio mux function mode
GPIO_MODE_ANALOG | gpio analog in/out mode

Definition at line 80 of file at32f435_437_gpio.h.

◆ gpio_mux_sel_type

enum gpio_mux_sel_type

gpio muxing function selection type

Enumerator
GPIO_MUX_0 | gpio muxing function selection 0
GPIO_MUX_1 | gpio muxing function selection 1
GPIO_MUX_2 | gpio muxing function selection 2
GPIO_MUX_3 | gpio muxing function selection 3
GPIO_MUX_4 | gpio muxing function selection 4
GPIO_MUX_5 | gpio muxing function selection 5
GPIO_MUX_6 | gpio muxing function selection 6
GPIO_MUX_7 | gpio muxing function selection 7
GPIO_MUX_8 | gpio muxing function selection 8
GPIO_MUX_9 | gpio muxing function selection 9
GPIO_MUX_10 | gpio muxing function selection 10
GPIO_MUX_11 | gpio muxing function selection 11
GPIO_MUX_12 | gpio muxing function selection 12
GPIO_MUX_13 | gpio muxing function selection 13
GPIO_MUX_14 | gpio muxing function selection 14
GPIO_MUX_15 | gpio muxing function selection 15

Definition at line 154 of file at32f435_437_gpio.h.

◆ gpio_output_type

enum gpio_output_type

gpio output type

Enumerator
GPIO_OUTPUT_PUSH_PULL | output push-pull
GPIO_OUTPUT_OPEN_DRAIN | output open-drain

Definition at line 100 of file at32f435_437_gpio.h.

◆ gpio_pins_source_type

enum gpio_pins_source_type

gpio pins source type

Enumerator
GPIO_PINS_SOURCE0 | gpio pins source number 0
GPIO_PINS_SOURCE1 | gpio pins source number 1
GPIO_PINS_SOURCE2 | gpio pins source number 2
GPIO_PINS_SOURCE3 | gpio pins source number 3
GPIO_PINS_SOURCE4 | gpio pins source number 4
GPIO_PINS_SOURCE5 | gpio pins source number 5
GPIO_PINS_SOURCE6 | gpio pins source number 6
GPIO_PINS_SOURCE7 | gpio pins source number 7
GPIO_PINS_SOURCE8 | gpio pins source number 8
GPIO_PINS_SOURCE9 | gpio pins source number 9
GPIO_PINS_SOURCE10 | gpio pins source number 10
GPIO_PINS_SOURCE11 | gpio pins source number 11
GPIO_PINS_SOURCE12 | gpio pins source number 12
GPIO_PINS_SOURCE13 | gpio pins source number 13
GPIO_PINS_SOURCE14 | gpio pins source number 14
GPIO_PINS_SOURCE15 | gpio pins source number 15

Definition at line 131 of file at32f435_437_gpio.h.

◆ gpio_pull_type

enum gpio_pull_type

gpio pull type

Enumerator
GPIO_PULL_NONE | floating for input, no pull for output
GPIO_PULL_UP | pull-up
GPIO_PULL_DOWN | pull-down

Definition at line 109 of file at32f435_437_gpio.h.


AT32F435/437 Firmwary Library: gpio_init_type Struct Reference

Data Fields
gpio_init_type Struct Reference
AT32F435_437_periph_driver » GPIO » GPIO_exported_types

gpio init type More...

#include <at32f435_437_gpio.h>

Data Fields

uint32_t gpio_pins
gpio_output_type gpio_out_type
gpio_pull_type gpio_pull
gpio_mode_type gpio_mode
gpio_drive_type gpio_drive_strength

Detailed Description

gpio init type

Definition at line 119 of file at32f435_437_gpio.h.

Field Documentation

◆ gpio_drive_strength

gpio_drive_type gpio_init_type::gpio_drive_strength

drive strength selection

Definition at line 125 of file at32f435_437_gpio.h.

Referenced by at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), dvp_io_init(), emac_pins_configuration(), exint_config(), gpio_config(), gpio_configuration(), gpio_default_para_init(), gpio_init(), i2c_lowlevel_init(), main(), mclk_tmr1_init(), nand_init(), nor_init(), ov2640_init(), ov5640_init(), psram_init(), qspi_config(), reset_phy(), rs485_config(), sd_init(), sdram_init(), spiflash_init(), sram_init(), swj_dp_config(), tmr1_config(), touch_pin_init(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), usart_spi_configuration(), usb_gpio_config(), and xmc_init().

◆ gpio_mode

gpio_mode_type gpio_init_type::gpio_mode

mode selection

Definition at line 124 of file at32f435_437_gpio.h.

Referenced by adc_configuration(), at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), dvp_io_init(), emac_pins_configuration(), exint_config(), gpio_config(), gpio_configuration(), gpio_default_para_init(), gpio_init(), i2c_lowlevel_init(), main(), mclk_tmr1_init(), nand_init(), nor_init(), ov2640_init(), ov5640_init(), psram_init(), qspi_config(), reset_phy(), rs485_config(), sd_init(), sdram_init(), spiflash_init(), sram_init(), swj_dp_config(), tmr1_config(), touch_pin_init(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), usart_spi_configuration(), usb_gpio_config(), and xmc_init().

◆ gpio_out_type

gpio_output_type gpio_init_type::gpio_out_type

output type selection

Definition at line 122 of file at32f435_437_gpio.h.

Referenced by at32_button_init(), at32_led_init(), can_gpio_config(), codec_i2s_init(), dvp_io_init(), emac_pins_configuration(), gpio_config(), gpio_configuration(), gpio_default_para_init(), gpio_init(), i2c_lowlevel_init(), main(), nand_init(), nor_init(), ov2640_init(), ov5640_init(), psram_init(), qspi_config(), reset_phy(), rs485_config(), sd_init(), sdram_init(), spiflash_init(), sram_init(), swj_dp_config(), tmr1_config(), touch_pin_init(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), usart_spi_configuration(), usb_gpio_config(), and xmc_init().

◆ gpio_pins

uint32_t gpio_init_type::gpio_pins

pins number selection

Definition at line 121 of file at32f435_437_gpio.h.

Referenced by adc_configuration(), at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), dvp_io_init(), emac_pins_configuration(), exint_config(), gpio_config(), gpio_configuration(), gpio_default_para_init(), gpio_init(), i2c_lowlevel_init(), main(), mclk_tmr1_init(), nand_init(), nor_init(), ov2640_init(), ov5640_init(), psram_init(), qspi_config(), reset_phy(), rs485_config(), sd_init(), sdram_init(), spiflash_init(), sram_init(), swj_dp_config(), tmr1_config(), touch_pin_init(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), usart_spi_configuration(), usb_gpio_config(), and xmc_init().

◆ gpio_pull

gpio_pull_type gpio_init_type::gpio_pull

pull type selection

Definition at line 123 of file at32f435_437_gpio.h.

Referenced by at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), dvp_io_init(), emac_pins_configuration(), exint_config(), gpio_config(), gpio_configuration(), gpio_default_para_init(), gpio_init(), i2c_lowlevel_init(), main(), nand_init(), nor_init(), ov2640_init(), ov5640_init(), psram_init(), qspi_config(), reset_phy(), rs485_config(), sd_init(), sdram_init(), spiflash_init(), sram_init(), swj_dp_config(), tmr1_config(), touch_pin_init(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), usart_spi_configuration(), usb_gpio_config(), and xmc_init().

The documentation for this struct was generated from the following file:
  • at32f435_437_gpio.h


AT32F435/437 Firmwary Library: gpio_type Struct Reference

Data Fields
gpio_type Struct Reference
AT32F435_437_periph_driver » GPIO » GPIO_exported_types

type define gpio register all More...

#include <at32f435_437_gpio.h>

Data Fields

union {
__IO uint32_t cfgr
struct {
__IO uint32_t iomc0: 2
__IO uint32_t iomc1: 2
__IO uint32_t iomc2: 2
__IO uint32_t iomc3: 2
__IO uint32_t iomc4: 2
__IO uint32_t iomc5: 2
__IO uint32_t iomc6: 2
__IO uint32_t iomc7: 2
__IO uint32_t iomc8: 2
__IO uint32_t iomc9: 2
__IO uint32_t iomc10: 2
__IO uint32_t iomc11: 2
__IO uint32_t iomc12: 2
__IO uint32_t iomc13: 2
__IO uint32_t iomc14: 2
__IO uint32_t iomc15: 2
} cfgr_bit
};
gpio mode register, offset:0x00 More...
union {
__IO uint32_t omode
struct {
__IO uint32_t om0: 1
__IO uint32_t om1: 1
__IO uint32_t om2: 1
__IO uint32_t om3: 1
__IO uint32_t om4: 1
__IO uint32_t om5: 1
__IO uint32_t om6: 1
__IO uint32_t om7: 1
__IO uint32_t om8: 1
__IO uint32_t om9: 1
__IO uint32_t om10: 1
__IO uint32_t om11: 1
__IO uint32_t om12: 1
__IO uint32_t om13: 1
__IO uint32_t om14: 1
__IO uint32_t om15: 1
__IO uint32_t reserved1: 16
} omode_bit
};
gpio output type register, offset:0x04 More...
union {
__IO uint32_t odrvr
struct {
__IO uint32_t odrv0: 2
__IO uint32_t odrv1: 2
__IO uint32_t odrv2: 2
__IO uint32_t odrv3: 2
__IO uint32_t odrv4: 2
__IO uint32_t odrv5: 2
__IO uint32_t odrv6: 2
__IO uint32_t odrv7: 2
__IO uint32_t odrv8: 2
__IO uint32_t odrv9: 2
__IO uint32_t odrv10: 2
__IO uint32_t odrv11: 2
__IO uint32_t odrv12: 2
__IO uint32_t odrv13: 2
__IO uint32_t odrv14: 2
__IO uint32_t odrv15: 2
} odrvr_bit
};
gpio output driver register, offset:0x08 More...
union {
__IO uint32_t pull
struct {
__IO uint32_t pull0: 2
__IO uint32_t pull1: 2
__IO uint32_t pull2: 2
__IO uint32_t pull3: 2
__IO uint32_t pull4: 2
__IO uint32_t pull5: 2
__IO uint32_t pull6: 2
__IO uint32_t pull7: 2
__IO uint32_t pull8: 2
__IO uint32_t pull9: 2
__IO uint32_t pull10: 2
__IO uint32_t pull11: 2
__IO uint32_t pull12: 2
__IO uint32_t pull13: 2
__IO uint32_t pull14: 2
__IO uint32_t pull15: 2
} pull_bit
};
gpio pull up/down register, offset:0x0C More...
union {
__IO uint32_t idt
struct {
__IO uint32_t idt0: 1
__IO uint32_t idt1: 1
__IO uint32_t idt2: 1
__IO uint32_t idt3: 1
__IO uint32_t idt4: 1
__IO uint32_t idt5: 1
__IO uint32_t idt6: 1
__IO uint32_t idt7: 1
__IO uint32_t idt8: 1
__IO uint32_t idt9: 1
__IO uint32_t idt10: 1
__IO uint32_t idt11: 1
__IO uint32_t idt12: 1
__IO uint32_t idt13: 1
__IO uint32_t idt14: 1
__IO uint32_t idt15: 1
__IO uint32_t reserved1: 16
} idt_bit
};
gpio input data register, offset:0x10 More...
union {
__IO uint32_t odt
struct {
__IO uint32_t odt0: 1
__IO uint32_t odt1: 1
__IO uint32_t odt2: 1
__IO uint32_t odt3: 1
__IO uint32_t odt4: 1
__IO uint32_t odt5: 1
__IO uint32_t odt6: 1
__IO uint32_t odt7: 1
__IO uint32_t odt8: 1
__IO uint32_t odt9: 1
__IO uint32_t odt10: 1
__IO uint32_t odt11: 1
__IO uint32_t odt12: 1
__IO uint32_t odt13: 1
__IO uint32_t odt14: 1
__IO uint32_t odt15: 1
__IO uint32_t reserved1: 16
} odt_bit
};
gpio output data register, offset:0x14 More...
union {
__IO uint32_t scr
struct {
__IO uint32_t iosb0: 1
__IO uint32_t iosb1: 1
__IO uint32_t iosb2: 1
__IO uint32_t iosb3: 1
__IO uint32_t iosb4: 1
__IO uint32_t iosb5: 1
__IO uint32_t iosb6: 1
__IO uint32_t iosb7: 1
__IO uint32_t iosb8: 1
__IO uint32_t iosb9: 1
__IO uint32_t iosb10: 1
__IO uint32_t iosb11: 1
__IO uint32_t iosb12: 1
__IO uint32_t iosb13: 1
__IO uint32_t iosb14: 1
__IO uint32_t iosb15: 1
__IO uint32_t iocb0: 1
__IO uint32_t iocb1: 1
__IO uint32_t iocb2: 1
__IO uint32_t iocb3: 1
__IO uint32_t iocb4: 1
__IO uint32_t iocb5: 1
__IO uint32_t iocb6: 1
__IO uint32_t iocb7: 1
__IO uint32_t iocb8: 1
__IO uint32_t iocb9: 1
__IO uint32_t iocb10: 1
__IO uint32_t iocb11: 1
__IO uint32_t iocb12: 1
__IO uint32_t iocb13: 1
__IO uint32_t iocb14: 1
__IO uint32_t iocb15: 1
} scr_bit
};
gpio scr register, offset:0x18 More...
union {
__IO uint32_t wpr
struct {
__IO uint32_t wpen0: 1
__IO uint32_t wpen1: 1
__IO uint32_t wpen2: 1
__IO uint32_t wpen3: 1
__IO uint32_t wpen4: 1
__IO uint32_t wpen5: 1
__IO uint32_t wpen6: 1
__IO uint32_t wpen7: 1
__IO uint32_t wpen8: 1
__IO uint32_t wpen9: 1
__IO uint32_t wpen10: 1
__IO uint32_t wpen11: 1
__IO uint32_t wpen12: 1
__IO uint32_t wpen13: 1
__IO uint32_t wpen14: 1
__IO uint32_t wpen15: 1
__IO uint32_t wpseq: 1
__IO uint32_t reserved1: 15
} wpr_bit
};
gpio wpen register, offset:0x1C More...
union {
__IO uint32_t muxl
struct {
__IO uint32_t muxl0: 4
__IO uint32_t muxl1: 4
__IO uint32_t muxl2: 4
__IO uint32_t muxl3: 4
__IO uint32_t muxl4: 4
__IO uint32_t muxl5: 4
__IO uint32_t muxl6: 4
__IO uint32_t muxl7: 4
} muxl_bit
};
gpio muxl register, offset:0x20 More...
union {
__IO uint32_t muxh
struct {
__IO uint32_t muxh8: 4
__IO uint32_t muxh9: 4
__IO uint32_t muxh10: 4
__IO uint32_t muxh11: 4
__IO uint32_t muxh12: 4
__IO uint32_t muxh13: 4
__IO uint32_t muxh14: 4
__IO uint32_t muxh15: 4
} muxh_bit
};
gpio muxh register, offset:0x24 More...
union {
__IO uint32_t clr
struct {
__IO uint32_t iocb0: 1
__IO uint32_t iocb1: 1
__IO uint32_t iocb2: 1
__IO uint32_t iocb3: 1
__IO uint32_t iocb4: 1
__IO uint32_t iocb5: 1
__IO uint32_t iocb6: 1
__IO uint32_t iocb7: 1
__IO uint32_t iocb8: 1
__IO uint32_t iocb9: 1
__IO uint32_t iocb10: 1
__IO uint32_t iocb11: 1
__IO uint32_t iocb12: 1
__IO uint32_t iocb13: 1
__IO uint32_t iocb14: 1
__IO uint32_t iocb15: 1
__IO uint32_t reserved1: 16
} clr_bit
};
gpio clr register, offset:0x28 More...
union {
__IO uint32_t hdrv
struct {
__IO uint32_t hdrv0: 1
__IO uint32_t hdrv1: 1
__IO uint32_t hdrv2: 1
__IO uint32_t hdrv3: 1
__IO uint32_t hdrv4: 1
__IO uint32_t hdrv5: 1
__IO uint32_t hdrv6: 1
__IO uint32_t hdrv7: 1
__IO uint32_t hdrv8: 1
__IO uint32_t hdrv9: 1
__IO uint32_t hdrv10: 1
__IO uint32_t hdrv11: 1
__IO uint32_t hdrv12: 1
__IO uint32_t hdrv13: 1
__IO uint32_t hdrv14: 1
__IO uint32_t hdrv15: 1
__IO uint32_t reserved1: 16
} hdrv_bit
};
gpio hdrv register, offset:0x3C More...

Detailed Description

type define gpio register all

Definition at line 177 of file at32f435_437_gpio.h.

Field Documentation

◆

union { ... } gpio_type::@827

gpio mode register, offset:0x00

◆

union { ... } gpio_type::@829

gpio output type register, offset:0x04

◆

union { ... } gpio_type::@831

gpio output driver register, offset:0x08

◆

union { ... } gpio_type::@833

gpio pull up/down register, offset:0x0C

◆

union { ... } gpio_type::@835

gpio input data register, offset:0x10

◆

union { ... } gpio_type::@837

gpio output data register, offset:0x14

◆

union { ... } gpio_type::@839

gpio scr register, offset:0x18

◆

union { ... } gpio_type::@841

gpio wpen register, offset:0x1C

◆

union { ... } gpio_type::@843

gpio muxl register, offset:0x20

◆

union { ... } gpio_type::@845

gpio muxh register, offset:0x24

◆

union { ... } gpio_type::@847

gpio clr register, offset:0x28

◆

union { ... } gpio_type::@849

gpio hdrv register, offset:0x3C

◆ cfgr

__IO uint32_t gpio_type::cfgr

Definition at line 184 of file at32f435_437_gpio.h.

Referenced by gpio_init().

◆

struct { ... } gpio_type::cfgr_bit

◆ clr

__IO uint32_t gpio_type::clr

Definition at line 459 of file at32f435_437_gpio.h.

Referenced by at32_led_on(), gpio_bits_reset(), and gpio_bits_write().

◆

struct { ... } gpio_type::clr_bit

◆ hdrv

__IO uint32_t gpio_type::hdrv

Definition at line 492 of file at32f435_437_gpio.h.

Referenced by gpio_pins_huge_driven_config().

◆ hdrv0

__IO uint32_t gpio_type::hdrv0

Definition at line 495 of file at32f435_437_gpio.h.

◆ hdrv1

__IO uint32_t gpio_type::hdrv1

Definition at line 496 of file at32f435_437_gpio.h.

◆ hdrv10

__IO uint32_t gpio_type::hdrv10

Definition at line 505 of file at32f435_437_gpio.h.

◆ hdrv11

__IO uint32_t gpio_type::hdrv11

Definition at line 506 of file at32f435_437_gpio.h.

◆ hdrv12

__IO uint32_t gpio_type::hdrv12

Definition at line 507 of file at32f435_437_gpio.h.

◆ hdrv13

__IO uint32_t gpio_type::hdrv13

Definition at line 508 of file at32f435_437_gpio.h.

◆ hdrv14

__IO uint32_t gpio_type::hdrv14

Definition at line 509 of file at32f435_437_gpio.h.

◆ hdrv15

__IO uint32_t gpio_type::hdrv15

Definition at line 510 of file at32f435_437_gpio.h.

◆ hdrv2

__IO uint32_t gpio_type::hdrv2

Definition at line 497 of file at32f435_437_gpio.h.

◆ hdrv3

__IO uint32_t gpio_type::hdrv3

Definition at line 498 of file at32f435_437_gpio.h.

◆ hdrv4

__IO uint32_t gpio_type::hdrv4

Definition at line 499 of file at32f435_437_gpio.h.

◆ hdrv5

__IO uint32_t gpio_type::hdrv5

Definition at line 500 of file at32f435_437_gpio.h.

◆ hdrv6

__IO uint32_t gpio_type::hdrv6

Definition at line 501 of file at32f435_437_gpio.h.

◆ hdrv7

__IO uint32_t gpio_type::hdrv7

Definition at line 502 of file at32f435_437_gpio.h.

◆ hdrv8

__IO uint32_t gpio_type::hdrv8

Definition at line 503 of file at32f435_437_gpio.h.

◆ hdrv9

__IO uint32_t gpio_type::hdrv9

Definition at line 504 of file at32f435_437_gpio.h.

◆

struct { ... } gpio_type::hdrv_bit

◆ idt

__IO uint32_t gpio_type::idt

Definition at line 293 of file at32f435_437_gpio.h.

Referenced by gpio_input_data_bit_read(), and gpio_input_data_read().

◆ idt0

__IO uint32_t gpio_type::idt0

Definition at line 296 of file at32f435_437_gpio.h.

◆ idt1

__IO uint32_t gpio_type::idt1

Definition at line 297 of file at32f435_437_gpio.h.

◆ idt10

__IO uint32_t gpio_type::idt10

Definition at line 306 of file at32f435_437_gpio.h.

◆ idt11

__IO uint32_t gpio_type::idt11

Definition at line 307 of file at32f435_437_gpio.h.

◆ idt12

__IO uint32_t gpio_type::idt12

Definition at line 308 of file at32f435_437_gpio.h.

◆ idt13

__IO uint32_t gpio_type::idt13

Definition at line 309 of file at32f435_437_gpio.h.

◆ idt14

__IO uint32_t gpio_type::idt14

Definition at line 310 of file at32f435_437_gpio.h.

◆ idt15

__IO uint32_t gpio_type::idt15

Definition at line 311 of file at32f435_437_gpio.h.

◆ idt2

__IO uint32_t gpio_type::idt2

Definition at line 298 of file at32f435_437_gpio.h.

◆ idt3

__IO uint32_t gpio_type::idt3

Definition at line 299 of file at32f435_437_gpio.h.

◆ idt4

__IO uint32_t gpio_type::idt4

Definition at line 300 of file at32f435_437_gpio.h.

◆ idt5

__IO uint32_t gpio_type::idt5

Definition at line 301 of file at32f435_437_gpio.h.

◆ idt6

__IO uint32_t gpio_type::idt6

Definition at line 302 of file at32f435_437_gpio.h.

◆ idt7

__IO uint32_t gpio_type::idt7

Definition at line 303 of file at32f435_437_gpio.h.

◆ idt8

__IO uint32_t gpio_type::idt8

Definition at line 304 of file at32f435_437_gpio.h.

◆ idt9

__IO uint32_t gpio_type::idt9

Definition at line 305 of file at32f435_437_gpio.h.

◆

struct { ... } gpio_type::idt_bit

◆ iocb0

__IO uint32_t gpio_type::iocb0

Definition at line 368 of file at32f435_437_gpio.h.

◆ iocb1

__IO uint32_t gpio_type::iocb1

Definition at line 369 of file at32f435_437_gpio.h.

◆ iocb10

__IO uint32_t gpio_type::iocb10

Definition at line 378 of file at32f435_437_gpio.h.

◆ iocb11

__IO uint32_t gpio_type::iocb11

Definition at line 379 of file at32f435_437_gpio.h.

◆ iocb12

__IO uint32_t gpio_type::iocb12

Definition at line 380 of file at32f435_437_gpio.h.

◆ iocb13

__IO uint32_t gpio_type::iocb13

Definition at line 381 of file at32f435_437_gpio.h.

◆ iocb14

__IO uint32_t gpio_type::iocb14

Definition at line 382 of file at32f435_437_gpio.h.

◆ iocb15

__IO uint32_t gpio_type::iocb15

Definition at line 383 of file at32f435_437_gpio.h.

◆ iocb2

__IO uint32_t gpio_type::iocb2

Definition at line 370 of file at32f435_437_gpio.h.

◆ iocb3

__IO uint32_t gpio_type::iocb3

Definition at line 371 of file at32f435_437_gpio.h.

◆ iocb4

__IO uint32_t gpio_type::iocb4

Definition at line 372 of file at32f435_437_gpio.h.

◆ iocb5

__IO uint32_t gpio_type::iocb5

Definition at line 373 of file at32f435_437_gpio.h.

◆ iocb6

__IO uint32_t gpio_type::iocb6

Definition at line 374 of file at32f435_437_gpio.h.

◆ iocb7

__IO uint32_t gpio_type::iocb7

Definition at line 375 of file at32f435_437_gpio.h.

◆ iocb8

__IO uint32_t gpio_type::iocb8

Definition at line 376 of file at32f435_437_gpio.h.

◆ iocb9

__IO uint32_t gpio_type::iocb9

Definition at line 377 of file at32f435_437_gpio.h.

◆ iomc0

__IO uint32_t gpio_type::iomc0

Definition at line 187 of file at32f435_437_gpio.h.

◆ iomc1

__IO uint32_t gpio_type::iomc1

Definition at line 188 of file at32f435_437_gpio.h.

◆ iomc10

__IO uint32_t gpio_type::iomc10

Definition at line 197 of file at32f435_437_gpio.h.

◆ iomc11

__IO uint32_t gpio_type::iomc11

Definition at line 198 of file at32f435_437_gpio.h.

◆ iomc12

__IO uint32_t gpio_type::iomc12

Definition at line 199 of file at32f435_437_gpio.h.

◆ iomc13

__IO uint32_t gpio_type::iomc13

Definition at line 200 of file at32f435_437_gpio.h.

◆ iomc14

__IO uint32_t gpio_type::iomc14

Definition at line 201 of file at32f435_437_gpio.h.

◆ iomc15

__IO uint32_t gpio_type::iomc15

Definition at line 202 of file at32f435_437_gpio.h.

◆ iomc2

__IO uint32_t gpio_type::iomc2

Definition at line 189 of file at32f435_437_gpio.h.

◆ iomc3

__IO uint32_t gpio_type::iomc3

Definition at line 190 of file at32f435_437_gpio.h.

◆ iomc4

__IO uint32_t gpio_type::iomc4

Definition at line 191 of file at32f435_437_gpio.h.

◆ iomc5

__IO uint32_t gpio_type::iomc5

Definition at line 192 of file at32f435_437_gpio.h.

◆ iomc6

__IO uint32_t gpio_type::iomc6

Definition at line 193 of file at32f435_437_gpio.h.

◆ iomc7

__IO uint32_t gpio_type::iomc7

Definition at line 194 of file at32f435_437_gpio.h.

◆ iomc8

__IO uint32_t gpio_type::iomc8

Definition at line 195 of file at32f435_437_gpio.h.

◆ iomc9

__IO uint32_t gpio_type::iomc9

Definition at line 196 of file at32f435_437_gpio.h.

◆ iosb0

__IO uint32_t gpio_type::iosb0

Definition at line 352 of file at32f435_437_gpio.h.

◆ iosb1

__IO uint32_t gpio_type::iosb1

Definition at line 353 of file at32f435_437_gpio.h.

◆ iosb10

__IO uint32_t gpio_type::iosb10

Definition at line 362 of file at32f435_437_gpio.h.

◆ iosb11

__IO uint32_t gpio_type::iosb11

Definition at line 363 of file at32f435_437_gpio.h.

◆ iosb12

__IO uint32_t gpio_type::iosb12

Definition at line 364 of file at32f435_437_gpio.h.

◆ iosb13

__IO uint32_t gpio_type::iosb13

Definition at line 365 of file at32f435_437_gpio.h.

◆ iosb14

__IO uint32_t gpio_type::iosb14

Definition at line 366 of file at32f435_437_gpio.h.

◆ iosb15

__IO uint32_t gpio_type::iosb15

Definition at line 367 of file at32f435_437_gpio.h.

◆ iosb2

__IO uint32_t gpio_type::iosb2

Definition at line 354 of file at32f435_437_gpio.h.

◆ iosb3

__IO uint32_t gpio_type::iosb3

Definition at line 355 of file at32f435_437_gpio.h.

◆ iosb4

__IO uint32_t gpio_type::iosb4

Definition at line 356 of file at32f435_437_gpio.h.

◆ iosb5

__IO uint32_t gpio_type::iosb5

Definition at line 357 of file at32f435_437_gpio.h.

◆ iosb6

__IO uint32_t gpio_type::iosb6

Definition at line 358 of file at32f435_437_gpio.h.

◆ iosb7

__IO uint32_t gpio_type::iosb7

Definition at line 359 of file at32f435_437_gpio.h.

◆ iosb8

__IO uint32_t gpio_type::iosb8

Definition at line 360 of file at32f435_437_gpio.h.

◆ iosb9

__IO uint32_t gpio_type::iosb9

Definition at line 361 of file at32f435_437_gpio.h.

◆ muxh

__IO uint32_t gpio_type::muxh

Definition at line 440 of file at32f435_437_gpio.h.

Referenced by gpio_pin_mux_config().

◆ muxh10

__IO uint32_t gpio_type::muxh10

Definition at line 445 of file at32f435_437_gpio.h.

◆ muxh11

__IO uint32_t gpio_type::muxh11

Definition at line 446 of file at32f435_437_gpio.h.

◆ muxh12

__IO uint32_t gpio_type::muxh12

Definition at line 447 of file at32f435_437_gpio.h.

◆ muxh13

__IO uint32_t gpio_type::muxh13

Definition at line 448 of file at32f435_437_gpio.h.

◆ muxh14

__IO uint32_t gpio_type::muxh14

Definition at line 449 of file at32f435_437_gpio.h.

◆ muxh15

__IO uint32_t gpio_type::muxh15

Definition at line 450 of file at32f435_437_gpio.h.

◆ muxh8

__IO uint32_t gpio_type::muxh8

Definition at line 443 of file at32f435_437_gpio.h.

◆ muxh9

__IO uint32_t gpio_type::muxh9

Definition at line 444 of file at32f435_437_gpio.h.

◆

struct { ... } gpio_type::muxh_bit

◆ muxl

__IO uint32_t gpio_type::muxl

Definition at line 421 of file at32f435_437_gpio.h.

Referenced by gpio_pin_mux_config().

◆ muxl0

__IO uint32_t gpio_type::muxl0

Definition at line 424 of file at32f435_437_gpio.h.

◆ muxl1

__IO uint32_t gpio_type::muxl1

Definition at line 425 of file at32f435_437_gpio.h.

◆ muxl2

__IO uint32_t gpio_type::muxl2

Definition at line 426 of file at32f435_437_gpio.h.

◆ muxl3

__IO uint32_t gpio_type::muxl3

Definition at line 427 of file at32f435_437_gpio.h.

◆ muxl4

__IO uint32_t gpio_type::muxl4

Definition at line 428 of file at32f435_437_gpio.h.

◆ muxl5

__IO uint32_t gpio_type::muxl5

Definition at line 429 of file at32f435_437_gpio.h.

◆ muxl6

__IO uint32_t gpio_type::muxl6

Definition at line 430 of file at32f435_437_gpio.h.

◆ muxl7

__IO uint32_t gpio_type::muxl7

Definition at line 431 of file at32f435_437_gpio.h.

◆

struct { ... } gpio_type::muxl_bit

◆ odrv0

__IO uint32_t gpio_type::odrv0

Definition at line 242 of file at32f435_437_gpio.h.

◆ odrv1

__IO uint32_t gpio_type::odrv1

Definition at line 243 of file at32f435_437_gpio.h.

◆ odrv10

__IO uint32_t gpio_type::odrv10

Definition at line 252 of file at32f435_437_gpio.h.

◆ odrv11

__IO uint32_t gpio_type::odrv11

Definition at line 253 of file at32f435_437_gpio.h.

◆ odrv12

__IO uint32_t gpio_type::odrv12

Definition at line 254 of file at32f435_437_gpio.h.

◆ odrv13

__IO uint32_t gpio_type::odrv13

Definition at line 255 of file at32f435_437_gpio.h.

◆ odrv14

__IO uint32_t gpio_type::odrv14

Definition at line 256 of file at32f435_437_gpio.h.

◆ odrv15

__IO uint32_t gpio_type::odrv15

Definition at line 257 of file at32f435_437_gpio.h.

◆ odrv2

__IO uint32_t gpio_type::odrv2

Definition at line 244 of file at32f435_437_gpio.h.

◆ odrv3

__IO uint32_t gpio_type::odrv3

Definition at line 245 of file at32f435_437_gpio.h.

◆ odrv4

__IO uint32_t gpio_type::odrv4

Definition at line 246 of file at32f435_437_gpio.h.

◆ odrv5

__IO uint32_t gpio_type::odrv5

Definition at line 247 of file at32f435_437_gpio.h.

◆ odrv6

__IO uint32_t gpio_type::odrv6

Definition at line 248 of file at32f435_437_gpio.h.

◆ odrv7

__IO uint32_t gpio_type::odrv7

Definition at line 249 of file at32f435_437_gpio.h.

◆ odrv8

__IO uint32_t gpio_type::odrv8

Definition at line 250 of file at32f435_437_gpio.h.

◆ odrv9

__IO uint32_t gpio_type::odrv9

Definition at line 251 of file at32f435_437_gpio.h.

◆ odrvr

__IO uint32_t gpio_type::odrvr

Definition at line 239 of file at32f435_437_gpio.h.

Referenced by gpio_init().

◆

struct { ... } gpio_type::odrvr_bit

◆ odt

__IO uint32_t gpio_type::odt

Definition at line 321 of file at32f435_437_gpio.h.

Referenced by at32_led_toggle(), gpio_output_data_bit_read(), gpio_output_data_read(), gpio_pins_toggle(), and gpio_port_write().

◆ odt0

__IO uint32_t gpio_type::odt0

Definition at line 324 of file at32f435_437_gpio.h.

◆ odt1

__IO uint32_t gpio_type::odt1

Definition at line 325 of file at32f435_437_gpio.h.

◆ odt10

__IO uint32_t gpio_type::odt10

Definition at line 334 of file at32f435_437_gpio.h.

◆ odt11

__IO uint32_t gpio_type::odt11

Definition at line 335 of file at32f435_437_gpio.h.

◆ odt12

__IO uint32_t gpio_type::odt12

Definition at line 336 of file at32f435_437_gpio.h.

◆ odt13

__IO uint32_t gpio_type::odt13

Definition at line 337 of file at32f435_437_gpio.h.

◆ odt14

__IO uint32_t gpio_type::odt14

Definition at line 338 of file at32f435_437_gpio.h.

◆ odt15

__IO uint32_t gpio_type::odt15

Definition at line 339 of file at32f435_437_gpio.h.

◆ odt2

__IO uint32_t gpio_type::odt2

Definition at line 326 of file at32f435_437_gpio.h.

◆ odt3

__IO uint32_t gpio_type::odt3

Definition at line 327 of file at32f435_437_gpio.h.

◆ odt4

__IO uint32_t gpio_type::odt4

Definition at line 328 of file at32f435_437_gpio.h.

◆ odt5

__IO uint32_t gpio_type::odt5

Definition at line 329 of file at32f435_437_gpio.h.

◆ odt6

__IO uint32_t gpio_type::odt6

Definition at line 330 of file at32f435_437_gpio.h.

◆ odt7

__IO uint32_t gpio_type::odt7

Definition at line 331 of file at32f435_437_gpio.h.

◆ odt8

__IO uint32_t gpio_type::odt8

Definition at line 332 of file at32f435_437_gpio.h.

◆ odt9

__IO uint32_t gpio_type::odt9

Definition at line 333 of file at32f435_437_gpio.h.

◆

struct { ... } gpio_type::odt_bit

◆ om0

__IO uint32_t gpio_type::om0

Definition at line 214 of file at32f435_437_gpio.h.

◆ om1

__IO uint32_t gpio_type::om1

Definition at line 215 of file at32f435_437_gpio.h.

◆ om10

__IO uint32_t gpio_type::om10

Definition at line 224 of file at32f435_437_gpio.h.

◆ om11

__IO uint32_t gpio_type::om11

Definition at line 225 of file at32f435_437_gpio.h.

◆ om12

__IO uint32_t gpio_type::om12

Definition at line 226 of file at32f435_437_gpio.h.

◆ om13

__IO uint32_t gpio_type::om13

Definition at line 227 of file at32f435_437_gpio.h.

◆ om14

__IO uint32_t gpio_type::om14

Definition at line 228 of file at32f435_437_gpio.h.

◆ om15

__IO uint32_t gpio_type::om15

Definition at line 229 of file at32f435_437_gpio.h.

◆ om2

__IO uint32_t gpio_type::om2

Definition at line 216 of file at32f435_437_gpio.h.

◆ om3

__IO uint32_t gpio_type::om3

Definition at line 217 of file at32f435_437_gpio.h.

◆ om4

__IO uint32_t gpio_type::om4

Definition at line 218 of file at32f435_437_gpio.h.

◆ om5

__IO uint32_t gpio_type::om5

Definition at line 219 of file at32f435_437_gpio.h.

◆ om6

__IO uint32_t gpio_type::om6

Definition at line 220 of file at32f435_437_gpio.h.

◆ om7

__IO uint32_t gpio_type::om7

Definition at line 221 of file at32f435_437_gpio.h.

◆ om8

__IO uint32_t gpio_type::om8

Definition at line 222 of file at32f435_437_gpio.h.

◆ om9

__IO uint32_t gpio_type::om9

Definition at line 223 of file at32f435_437_gpio.h.

◆ omode

__IO uint32_t gpio_type::omode

Definition at line 211 of file at32f435_437_gpio.h.

Referenced by gpio_init().

◆

struct { ... } gpio_type::omode_bit

◆ pull

__IO uint32_t gpio_type::pull

Definition at line 266 of file at32f435_437_gpio.h.

Referenced by gpio_init().

◆ pull0

__IO uint32_t gpio_type::pull0

Definition at line 269 of file at32f435_437_gpio.h.

◆ pull1

__IO uint32_t gpio_type::pull1

Definition at line 270 of file at32f435_437_gpio.h.

◆ pull10

__IO uint32_t gpio_type::pull10

Definition at line 279 of file at32f435_437_gpio.h.

◆ pull11

__IO uint32_t gpio_type::pull11

Definition at line 280 of file at32f435_437_gpio.h.

◆ pull12

__IO uint32_t gpio_type::pull12

Definition at line 281 of file at32f435_437_gpio.h.

◆ pull13

__IO uint32_t gpio_type::pull13

Definition at line 282 of file at32f435_437_gpio.h.

◆ pull14

__IO uint32_t gpio_type::pull14

Definition at line 283 of file at32f435_437_gpio.h.

◆ pull15

__IO uint32_t gpio_type::pull15

Definition at line 284 of file at32f435_437_gpio.h.

◆ pull2

__IO uint32_t gpio_type::pull2

Definition at line 271 of file at32f435_437_gpio.h.

◆ pull3

__IO uint32_t gpio_type::pull3

Definition at line 272 of file at32f435_437_gpio.h.

◆ pull4

__IO uint32_t gpio_type::pull4

Definition at line 273 of file at32f435_437_gpio.h.

◆ pull5

__IO uint32_t gpio_type::pull5

Definition at line 274 of file at32f435_437_gpio.h.

◆ pull6

__IO uint32_t gpio_type::pull6

Definition at line 275 of file at32f435_437_gpio.h.

◆ pull7

__IO uint32_t gpio_type::pull7

Definition at line 276 of file at32f435_437_gpio.h.

◆ pull8

__IO uint32_t gpio_type::pull8

Definition at line 277 of file at32f435_437_gpio.h.

◆ pull9

__IO uint32_t gpio_type::pull9

Definition at line 278 of file at32f435_437_gpio.h.

◆

struct { ... } gpio_type::pull_bit

◆ reserved1

__IO uint32_t gpio_type::reserved1

gpio reserved1 register, offset:0x2C~0x38

Definition at line 230 of file at32f435_437_gpio.h.

◆ scr

__IO uint32_t gpio_type::scr

Definition at line 349 of file at32f435_437_gpio.h.

Referenced by at32_led_off(), gpio_bits_set(), and gpio_bits_write().

◆

struct { ... } gpio_type::scr_bit

◆ wpen0

__IO uint32_t gpio_type::wpen0

Definition at line 395 of file at32f435_437_gpio.h.

◆ wpen1

__IO uint32_t gpio_type::wpen1

Definition at line 396 of file at32f435_437_gpio.h.

◆ wpen10

__IO uint32_t gpio_type::wpen10

Definition at line 405 of file at32f435_437_gpio.h.

◆ wpen11

__IO uint32_t gpio_type::wpen11

Definition at line 406 of file at32f435_437_gpio.h.

◆ wpen12

__IO uint32_t gpio_type::wpen12

Definition at line 407 of file at32f435_437_gpio.h.

◆ wpen13

__IO uint32_t gpio_type::wpen13

Definition at line 408 of file at32f435_437_gpio.h.

◆ wpen14

__IO uint32_t gpio_type::wpen14

Definition at line 409 of file at32f435_437_gpio.h.

◆ wpen15

__IO uint32_t gpio_type::wpen15

Definition at line 410 of file at32f435_437_gpio.h.

◆ wpen2

__IO uint32_t gpio_type::wpen2

Definition at line 397 of file at32f435_437_gpio.h.

◆ wpen3

__IO uint32_t gpio_type::wpen3

Definition at line 398 of file at32f435_437_gpio.h.

◆ wpen4

__IO uint32_t gpio_type::wpen4

Definition at line 399 of file at32f435_437_gpio.h.

◆ wpen5

__IO uint32_t gpio_type::wpen5

Definition at line 400 of file at32f435_437_gpio.h.

◆ wpen6

__IO uint32_t gpio_type::wpen6

Definition at line 401 of file at32f435_437_gpio.h.

◆ wpen7

__IO uint32_t gpio_type::wpen7

Definition at line 402 of file at32f435_437_gpio.h.

◆ wpen8

__IO uint32_t gpio_type::wpen8

Definition at line 403 of file at32f435_437_gpio.h.

◆ wpen9

__IO uint32_t gpio_type::wpen9

Definition at line 404 of file at32f435_437_gpio.h.

◆ wpr

__IO uint32_t gpio_type::wpr

Definition at line 392 of file at32f435_437_gpio.h.

Referenced by gpio_pin_wp_config().

◆

struct { ... } gpio_type::wpr_bit

◆ wpseq

__IO uint32_t gpio_type::wpseq

Definition at line 411 of file at32f435_437_gpio.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_gpio.h


AT32F435/437 Firmwary Library: GPIO_exported_functions

Functions
GPIO_exported_functions
AT32F435_437_periph_driver » GPIO

Functions

void | gpio_reset (gpio_type *gpio_x)
reset the gpio register More...
void | gpio_init (gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral. More...
void | gpio_default_para_init (gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value. More...
flag_status | gpio_input_data_bit_read (gpio_type *gpio_x, uint16_t pins)
read the specified input port pin. More...
uint16_t | gpio_input_data_read (gpio_type *gpio_x)
read the specified gpio input data port. More...
flag_status | gpio_output_data_bit_read (gpio_type *gpio_x, uint16_t pins)
read the specified output port pin. More...
uint16_t | gpio_output_data_read (gpio_type *gpio_x)
read the specified gpio ouput data port. More...
void | gpio_bits_set (gpio_type *gpio_x, uint16_t pins)
set the selected data port bits. More...
void | gpio_bits_reset (gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits. More...
void | gpio_bits_write (gpio_type *gpio_x, uint16_t pins, confirm_state bit_state)
set or clear the selected data port bit. More...
void | gpio_port_write (gpio_type *gpio_x, uint16_t port_value)
write data to the specified gpio data port. More...
void | gpio_pin_wp_config (gpio_type *gpio_x, uint16_t pins)
write protect gpio pins configuration registers. More...
void | gpio_pins_huge_driven_config (gpio_type *gpio_x, uint16_t pins, confirm_state new_state)
enable or disable gpio pins huge driven. More...
void | gpio_pin_mux_config (gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function. More...

Detailed Description

Function Documentation

◆ gpio_bits_reset()

void gpio_bits_reset | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

clear the selected data port bits.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
pins gpio pin number parameter can be any combination of gpio_pin_x, gpio_pin_x as following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
Return values
none

Definition at line 308 of file at32f435_437_gpio.c.

Referenced by EXINT9_5_IRQHandler(), main(), reset_phy(), TMR2_GLOBAL_IRQHandler(), and usbh_user_active_vbus().

◆ gpio_bits_set()

void gpio_bits_set | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

set the selected data port bits.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
pins gpio pin number parameter can be any combination of gpio_pin_x, gpio_pin_x as following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
Return values
none

Definition at line 277 of file at32f435_437_gpio.c.

Referenced by EXINT9_5_IRQHandler(), main(), reset_phy(), touch_pin_init(), usart_configuration(), usb_gpio_config(), and usbh_user_active_vbus().

◆ gpio_bits_write()

void gpio_bits_write | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins,
 |  | confirm_state | bit_state
 | ) |  |

set or clear the selected data port bit.

Parameters
gpio_x | to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
pins gpio pin number parameter can be any combination of gpio_pin_x, gpio_pin_x as following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
bit_state | specifies the value to be written to the selected bit (TRUE or FALSE).
Return values
none

Definition at line 340 of file at32f435_437_gpio.c.

◆ gpio_default_para_init()

void gpio_default_para_init ( gpio_init_type * gpio_init_struct )

fill each gpio_init_type member with its default value.

Parameters
gpio_init_struct : pointer to a gpio_init_type structure which will be initialized.
Return values
none

< gpio all pins

Definition at line 135 of file at32f435_437_gpio.c.

Referenced by adc_configuration(), at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), exint_config(), gpio_config(), gpio_configuration(), i2c_lowlevel_init(), mclk_tmr1_init(), nand_init(), ov2640_init(), ov5640_init(), qspi_config(), rs485_config(), swj_dp_config(), tmr1_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_gpio_config().

◆ gpio_init()

void gpio_init | ( | gpio_type * | gpio_x,
 |  | gpio_init_type * | gpio_init_struct
 | ) |  |

initialize the gpio peripheral.

Parameters
gpio_x | to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
gpio_init_struct | pointer to gpio init structure.
Return values
none

Definition at line 103 of file at32f435_437_gpio.c.

Referenced by adc_configuration(), at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), dvp_io_init(), emac_pins_configuration(), exint_config(), gpio_config(), gpio_configuration(), i2c_lowlevel_init(), main(), mclk_tmr1_init(), nand_init(), nor_init(), ov2640_init(), ov5640_init(), psram_init(), qspi_config(), reset_phy(), rs485_config(), sd_init(), sdram_init(), spiflash_init(), sram_init(), swj_dp_config(), tmr1_config(), touch_pin_init(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), usart_spi_configuration(), usb_gpio_config(), and xmc_init().

◆ gpio_input_data_bit_read()

flag_status gpio_input_data_bit_read | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

read the specified input port pin.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
pins gpio pin number this parameter can be one of the following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
Return values
flag_status (SET or RESET)

Definition at line 170 of file at32f435_437_gpio.c.

Referenced by at32_button_state(), button_isr(), gpio_config(), nor_getstatus(), and touch_scan().

◆ gpio_input_data_read()

uint16_t gpio_input_data_read ( gpio_type * gpio_x )

read the specified gpio input data port.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
Return values
gpio input data port value.

Definition at line 193 of file at32f435_437_gpio.c.

◆ gpio_output_data_bit_read()

flag_status gpio_output_data_bit_read | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

read the specified output port pin.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
pins gpio pin number this parameter can be one of the following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
Return values
flag_status (SET or RESET)

Definition at line 223 of file at32f435_437_gpio.c.

◆ gpio_output_data_read()

uint16_t gpio_output_data_read ( gpio_type * gpio_x )

read the specified gpio ouput data port.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
Return values
gpio input data port value.

Definition at line 246 of file at32f435_437_gpio.c.

◆ gpio_pin_mux_config()

void gpio_pin_mux_config | ( | gpio_type * | gpio_x,
 |  | gpio_pins_source_type | gpio_pin_source,
 |  | gpio_mux_sel_type | gpio_mux
 | ) |  |

configure the pin's muxing function.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
gpio_pin_source specifies the pin for the muxing function. this parameter can be one of the following values:
  • GPIO_PINS_SOURCE0
  • GPIO_PINS_SOURCE1
  • GPIO_PINS_SOURCE2
  • GPIO_PINS_SOURCE3
  • GPIO_PINS_SOURCE4
  • GPIO_PINS_SOURCE5
  • GPIO_PINS_SOURCE6
  • GPIO_PINS_SOURCE7
  • GPIO_PINS_SOURCE8
  • GPIO_PINS_SOURCE9
  • GPIO_PINS_SOURCE10
  • GPIO_PINS_SOURCE11
  • GPIO_PINS_SOURCE12
  • GPIO_PINS_SOURCE13
  • GPIO_PINS_SOURCE14
  • GPIO_PINS_SOURCE15
gpio_mux select the pin to used as muxing function. this parameter can be one of the following values:
  • GPIO_MUX_0
  • GPIO_MUX_1
  • GPIO_MUX_2
  • GPIO_MUX_3
  • GPIO_MUX_4
  • GPIO_MUX_5
  • GPIO_MUX_6
  • GPIO_MUX_7
  • GPIO_MUX_8
  • GPIO_MUX_9
  • GPIO_MUX_10
  • GPIO_MUX_11
  • GPIO_MUX_12
  • GPIO_MUX_13
  • GPIO_MUX_14
  • GPIO_MUX_15
Return values
none

Definition at line 491 of file at32f435_437_gpio.c.

Referenced by can_gpio_config(), codec_i2s_init(), dvp_io_init(), emac_pins_configuration(), gpio_config(), gpio_configuration(), i2c_lowlevel_init(), main(), mclk_tmr1_init(), nand_init(), nor_init(), psram_init(), qspi_config(), reset_phy(), rs485_config(), sd_init(), sdram_init(), spiflash_init(), sram_init(), swj_dp_config(), tmr1_config(), touch_pin_init(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), usart_spi_configuration(), usb_gpio_config(), and xmc_init().

◆ gpio_pin_wp_config()

void gpio_pin_wp_config | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

write protect gpio pins configuration registers.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
pins gpio pin number this parameter can be any combination of the following:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
Return values
none

Definition at line 391 of file at32f435_437_gpio.c.

◆ gpio_pins_huge_driven_config()

void gpio_pins_huge_driven_config | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins,
 |  | confirm_state | new_state
 | ) |  |

enable or disable gpio pins huge driven.

Parameters
gpio_x | to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
pins gpio pin number parameter can be any combination of gpio_pin_x, gpio_pin_x as following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
new_state | new state of the slew rate. this parameter can be: true or false.
Return values
none

Definition at line 436 of file at32f435_437_gpio.c.

◆ gpio_port_write()

void gpio_port_write | ( | gpio_type * | gpio_x,
 |  | uint16_t | port_value
 | ) |  |

write data to the specified gpio data port.

Parameters
gpio_x | to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
port_value | specifies the value to be written to the port output data register.
Return values
none

Definition at line 360 of file at32f435_437_gpio.c.

◆ gpio_reset()

void gpio_reset ( gpio_type * gpio_x )

reset the gpio register

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
Return values
none

Definition at line 51 of file at32f435_437_gpio.c.


AT32F435/437 Firmwary Library: GPIO_private_functions

Functions
GPIO_private_functions
AT32F435_437_periph_driver » GPIO

Functions

void | gpio_reset (gpio_type *gpio_x)
reset the gpio register More...
void | gpio_init (gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral. More...
void | gpio_default_para_init (gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value. More...
flag_status | gpio_input_data_bit_read (gpio_type *gpio_x, uint16_t pins)
read the specified input port pin. More...
uint16_t | gpio_input_data_read (gpio_type *gpio_x)
read the specified gpio input data port. More...
flag_status | gpio_output_data_bit_read (gpio_type *gpio_x, uint16_t pins)
read the specified output port pin. More...
uint16_t | gpio_output_data_read (gpio_type *gpio_x)
read the specified gpio ouput data port. More...
void | gpio_bits_set (gpio_type *gpio_x, uint16_t pins)
set the selected data port bits. More...
void | gpio_bits_reset (gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits. More...
void | gpio_bits_write (gpio_type *gpio_x, uint16_t pins, confirm_state bit_state)
set or clear the selected data port bit. More...
void | gpio_port_write (gpio_type *gpio_x, uint16_t port_value)
write data to the specified gpio data port. More...
void | gpio_pin_wp_config (gpio_type *gpio_x, uint16_t pins)
write protect gpio pins configuration registers. More...
void | gpio_pins_huge_driven_config (gpio_type *gpio_x, uint16_t pins, confirm_state new_state)
enable or disable gpio pins huge driven. More...
void | gpio_pin_mux_config (gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function. More...

Detailed Description

Function Documentation

◆ gpio_bits_reset()

void gpio_bits_reset | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

clear the selected data port bits.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
pins gpio pin number parameter can be any combination of gpio_pin_x, gpio_pin_x as following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
Return values
none

Definition at line 308 of file at32f435_437_gpio.c.

Referenced by EXINT9_5_IRQHandler(), main(), reset_phy(), TMR2_GLOBAL_IRQHandler(), and usbh_user_active_vbus().

◆ gpio_bits_set()

void gpio_bits_set | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

set the selected data port bits.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
pins gpio pin number parameter can be any combination of gpio_pin_x, gpio_pin_x as following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
Return values
none

Definition at line 277 of file at32f435_437_gpio.c.

Referenced by EXINT9_5_IRQHandler(), main(), reset_phy(), touch_pin_init(), usart_configuration(), usb_gpio_config(), and usbh_user_active_vbus().

◆ gpio_bits_write()

void gpio_bits_write | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins,
 |  | confirm_state | bit_state
 | ) |  |

set or clear the selected data port bit.

Parameters
gpio_x | to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
pins gpio pin number parameter can be any combination of gpio_pin_x, gpio_pin_x as following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
bit_state | specifies the value to be written to the selected bit (TRUE or FALSE).
Return values
none

Definition at line 340 of file at32f435_437_gpio.c.

◆ gpio_default_para_init()

void gpio_default_para_init ( gpio_init_type * gpio_init_struct )

fill each gpio_init_type member with its default value.

Parameters
gpio_init_struct : pointer to a gpio_init_type structure which will be initialized.
Return values
none

< gpio all pins

Definition at line 135 of file at32f435_437_gpio.c.

Referenced by adc_configuration(), at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), exint_config(), gpio_config(), gpio_configuration(), i2c_lowlevel_init(), mclk_tmr1_init(), nand_init(), ov2640_init(), ov5640_init(), qspi_config(), rs485_config(), swj_dp_config(), tmr1_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_gpio_config().

◆ gpio_init()

void gpio_init | ( | gpio_type * | gpio_x,
 |  | gpio_init_type * | gpio_init_struct
 | ) |  |

initialize the gpio peripheral.

Parameters
gpio_x | to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
gpio_init_struct | pointer to gpio init structure.
Return values
none

Definition at line 103 of file at32f435_437_gpio.c.

Referenced by adc_configuration(), at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), dvp_io_init(), emac_pins_configuration(), exint_config(), gpio_config(), gpio_configuration(), i2c_lowlevel_init(), main(), mclk_tmr1_init(), nand_init(), nor_init(), ov2640_init(), ov5640_init(), psram_init(), qspi_config(), reset_phy(), rs485_config(), sd_init(), sdram_init(), spiflash_init(), sram_init(), swj_dp_config(), tmr1_config(), touch_pin_init(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), usart_spi_configuration(), usb_gpio_config(), and xmc_init().

◆ gpio_input_data_bit_read()

flag_status gpio_input_data_bit_read | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

read the specified input port pin.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
pins gpio pin number this parameter can be one of the following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
Return values
flag_status (SET or RESET)

Definition at line 170 of file at32f435_437_gpio.c.

Referenced by at32_button_state(), button_isr(), gpio_config(), nor_getstatus(), and touch_scan().

◆ gpio_input_data_read()

uint16_t gpio_input_data_read ( gpio_type * gpio_x )

read the specified gpio input data port.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
Return values
gpio input data port value.

Definition at line 193 of file at32f435_437_gpio.c.

◆ gpio_output_data_bit_read()

flag_status gpio_output_data_bit_read | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

read the specified output port pin.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
pins gpio pin number this parameter can be one of the following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
Return values
flag_status (SET or RESET)

Definition at line 223 of file at32f435_437_gpio.c.

◆ gpio_output_data_read()

uint16_t gpio_output_data_read ( gpio_type * gpio_x )

read the specified gpio ouput data port.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
Return values
gpio input data port value.

Definition at line 246 of file at32f435_437_gpio.c.

◆ gpio_pin_mux_config()

void gpio_pin_mux_config | ( | gpio_type * | gpio_x,
 |  | gpio_pins_source_type | gpio_pin_source,
 |  | gpio_mux_sel_type | gpio_mux
 | ) |  |

configure the pin's muxing function.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
gpio_pin_source specifies the pin for the muxing function. this parameter can be one of the following values:
  • GPIO_PINS_SOURCE0
  • GPIO_PINS_SOURCE1
  • GPIO_PINS_SOURCE2
  • GPIO_PINS_SOURCE3
  • GPIO_PINS_SOURCE4
  • GPIO_PINS_SOURCE5
  • GPIO_PINS_SOURCE6
  • GPIO_PINS_SOURCE7
  • GPIO_PINS_SOURCE8
  • GPIO_PINS_SOURCE9
  • GPIO_PINS_SOURCE10
  • GPIO_PINS_SOURCE11
  • GPIO_PINS_SOURCE12
  • GPIO_PINS_SOURCE13
  • GPIO_PINS_SOURCE14
  • GPIO_PINS_SOURCE15
gpio_mux select the pin to used as muxing function. this parameter can be one of the following values:
  • GPIO_MUX_0
  • GPIO_MUX_1
  • GPIO_MUX_2
  • GPIO_MUX_3
  • GPIO_MUX_4
  • GPIO_MUX_5
  • GPIO_MUX_6
  • GPIO_MUX_7
  • GPIO_MUX_8
  • GPIO_MUX_9
  • GPIO_MUX_10
  • GPIO_MUX_11
  • GPIO_MUX_12
  • GPIO_MUX_13
  • GPIO_MUX_14
  • GPIO_MUX_15
Return values
none

Definition at line 491 of file at32f435_437_gpio.c.

Referenced by can_gpio_config(), codec_i2s_init(), dvp_io_init(), emac_pins_configuration(), gpio_config(), gpio_configuration(), i2c_lowlevel_init(), main(), mclk_tmr1_init(), nand_init(), nor_init(), psram_init(), qspi_config(), reset_phy(), rs485_config(), sd_init(), sdram_init(), spiflash_init(), sram_init(), swj_dp_config(), tmr1_config(), touch_pin_init(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), usart_spi_configuration(), usb_gpio_config(), and xmc_init().

◆ gpio_pin_wp_config()

void gpio_pin_wp_config | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

write protect gpio pins configuration registers.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
pins gpio pin number this parameter can be any combination of the following:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
Return values
none

Definition at line 391 of file at32f435_437_gpio.c.

◆ gpio_pins_huge_driven_config()

void gpio_pins_huge_driven_config | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins,
 |  | confirm_state | new_state
 | ) |  |

enable or disable gpio pins huge driven.

Parameters
gpio_x | to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
pins gpio pin number parameter can be any combination of gpio_pin_x, gpio_pin_x as following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
new_state | new state of the slew rate. this parameter can be: true or false.
Return values
none

Definition at line 436 of file at32f435_437_gpio.c.

◆ gpio_port_write()

void gpio_port_write | ( | gpio_type * | gpio_x,
 |  | uint16_t | port_value
 | ) |  |

write data to the specified gpio data port.

Parameters
gpio_x | to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
port_value | specifies the value to be written to the port output data register.
Return values
none

Definition at line 360 of file at32f435_437_gpio.c.

◆ gpio_reset()

void gpio_reset ( gpio_type * gpio_x )

reset the gpio register

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOE, GPIOF, GPIOG, GPIOH.
Return values
none

Definition at line 51 of file at32f435_437_gpio.c.


AT32F435/437 Firmwary Library: I2C

Modules | Macros
I2C
AT32F435_437_periph_driver

I2C driver modules. More...

Modules

I2C_interrupts_definition
i2c interrupt
I2C_flags_definition
i2c flag
I2C_exported_types
I2C_exported_functions
I2C_private_functions

Macros

#define | MAX_TRANSFER_CNT 255
maximum number of single transfers More...
#define | I2C1 ((i2c_type *) I2C1_BASE)
#define | I2C2 ((i2c_type *) I2C2_BASE)
#define | I2C3 ((i2c_type *) I2C3_BASE)

Detailed Description

I2C driver modules.

Macro Definition Documentation

◆ I2C1

#define I2C1 ((i2c_type *) I2C1_BASE)

Definition at line 414 of file at32f435_437_i2c.h.

◆ I2C2

#define I2C2 ((i2c_type *) I2C2_BASE)

Definition at line 415 of file at32f435_437_i2c.h.

◆ I2C3

#define I2C3 ((i2c_type *) I2C3_BASE)

Definition at line 416 of file at32f435_437_i2c.h.

◆ MAX_TRANSFER_CNT

#define MAX_TRANSFER_CNT 255

maximum number of single transfers

maximum number of single transfers

Definition at line 50 of file at32f435_437_i2c.h.


AT32F435/437 Firmwary Library: I2C_interrupts_definition

Macros
I2C_interrupts_definition
AT32F435_437_periph_driver » I2C

i2c interrupt More...

Macros

#define | I2C_TD_INT ((uint32_t)0x00000002)
#define | I2C_RD_INT ((uint32_t)0x00000004)
#define | I2C_ADDR_INT ((uint32_t)0x00000008)
#define | I2C_ACKFIAL_INT ((uint32_t)0x00000010)
#define | I2C_STOP_INT ((uint32_t)0x00000020)
#define | I2C_TDC_INT ((uint32_t)0x00000040)
#define | I2C_ERR_INT ((uint32_t)0x00000080)

Detailed Description

i2c interrupt

Macro Definition Documentation

◆ I2C_ACKFIAL_INT

#define I2C_ACKFIAL_INT ((uint32_t)0x00000010)

i2c ack fail interrupt

Definition at line 60 of file at32f435_437_i2c.h.

◆ I2C_ADDR_INT

#define I2C_ADDR_INT ((uint32_t)0x00000008)

i2c address match interrupt

Definition at line 59 of file at32f435_437_i2c.h.

◆ I2C_ERR_INT

#define I2C_ERR_INT ((uint32_t)0x00000080)

i2c bus error interrupt

Definition at line 63 of file at32f435_437_i2c.h.

◆ I2C_RD_INT

#define I2C_RD_INT ((uint32_t)0x00000004)

i2c receive data interrupt

Definition at line 58 of file at32f435_437_i2c.h.

◆ I2C_STOP_INT

#define I2C_STOP_INT ((uint32_t)0x00000020)

i2c stop detect interrupt

Definition at line 61 of file at32f435_437_i2c.h.

◆ I2C_TD_INT

#define I2C_TD_INT ((uint32_t)0x00000002)

i2c transmit data interrupt

Definition at line 57 of file at32f435_437_i2c.h.

◆ I2C_TDC_INT

#define I2C_TDC_INT ((uint32_t)0x00000040)

i2c transmit data complete interrupt

Definition at line 62 of file at32f435_437_i2c.h.


AT32F435/437 Firmwary Library: I2C_flags_definition

Macros
I2C_flags_definition
AT32F435_437_periph_driver » I2C

i2c flag More...

Macros

#define | I2C_TDBE_FLAG ((uint32_t)0x00000001)
#define | I2C_TDIS_FLAG ((uint32_t)0x00000002)
#define | I2C_RDBF_FLAG ((uint32_t)0x00000004)
#define | I2C_ADDRF_FLAG ((uint32_t)0x00000008)
#define | I2C_ACKFAIL_FLAG ((uint32_t)0x00000010)
#define | I2C_STOPF_FLAG ((uint32_t)0x00000020)
#define | I2C_TDC_FLAG ((uint32_t)0x00000040)
#define | I2C_TCRLD_FLAG ((uint32_t)0x00000080)
#define | I2C_BUSERR_FLAG ((uint32_t)0x00000100)
#define | I2C_ARLOST_FLAG ((uint32_t)0x00000200)
#define | I2C_OUF_FLAG ((uint32_t)0x00000400)
#define | I2C_PECERR_FLAG ((uint32_t)0x00000800)
#define | I2C_TMOUT_FLAG ((uint32_t)0x00001000)
#define | I2C_ALERTF_FLAG ((uint32_t)0x00002000)
#define | I2C_BUSYF_FLAG ((uint32_t)0x00008000)
#define | I2C_SDIR_FLAG ((uint32_t)0x00010000)

Detailed Description

i2c flag

Macro Definition Documentation

◆ I2C_ACKFAIL_FLAG

#define I2C_ACKFAIL_FLAG ((uint32_t)0x00000010)

i2c acknowledge failure flag

Definition at line 78 of file at32f435_437_i2c.h.

◆ I2C_ADDRF_FLAG

#define I2C_ADDRF_FLAG ((uint32_t)0x00000008)

i2c 0~7 bit address match flag

Definition at line 77 of file at32f435_437_i2c.h.

◆ I2C_ALERTF_FLAG

#define I2C_ALERTF_FLAG ((uint32_t)0x00002000)

i2c smbus alert flag

Definition at line 87 of file at32f435_437_i2c.h.

◆ I2C_ARLOST_FLAG

#define I2C_ARLOST_FLAG ((uint32_t)0x00000200)

i2c arbitration lost flag

Definition at line 83 of file at32f435_437_i2c.h.

◆ I2C_BUSERR_FLAG

#define I2C_BUSERR_FLAG ((uint32_t)0x00000100)

i2c bus error flag

Definition at line 82 of file at32f435_437_i2c.h.

◆ I2C_BUSYF_FLAG

#define I2C_BUSYF_FLAG ((uint32_t)0x00008000)

i2c bus busy flag transmission mode

Definition at line 88 of file at32f435_437_i2c.h.

◆ I2C_OUF_FLAG

#define I2C_OUF_FLAG ((uint32_t)0x00000400)

i2c overflow or underflow flag

Definition at line 84 of file at32f435_437_i2c.h.

◆ I2C_PECERR_FLAG

#define I2C_PECERR_FLAG ((uint32_t)0x00000800)

i2c pec receive error flag

Definition at line 85 of file at32f435_437_i2c.h.

◆ I2C_RDBF_FLAG

#define I2C_RDBF_FLAG ((uint32_t)0x00000004)

i2c receive data buffer full flag

Definition at line 76 of file at32f435_437_i2c.h.

◆ I2C_SDIR_FLAG

#define I2C_SDIR_FLAG ((uint32_t)0x00010000)

i2c slave data transmit direction

Definition at line 89 of file at32f435_437_i2c.h.

◆ I2C_STOPF_FLAG

#define I2C_STOPF_FLAG ((uint32_t)0x00000020)

i2c stop condition generation complete flag

Definition at line 79 of file at32f435_437_i2c.h.

◆ I2C_TCRLD_FLAG

#define I2C_TCRLD_FLAG ((uint32_t)0x00000080)

i2c transmission is complete, waiting to load data

Definition at line 81 of file at32f435_437_i2c.h.

◆ I2C_TDBE_FLAG

#define I2C_TDBE_FLAG ((uint32_t)0x00000001)

i2c transmit data buffer empty flag

Definition at line 74 of file at32f435_437_i2c.h.

◆ I2C_TDC_FLAG

#define I2C_TDC_FLAG ((uint32_t)0x00000040)

i2c transmit data complete flag

Definition at line 80 of file at32f435_437_i2c.h.

◆ I2C_TDIS_FLAG

#define I2C_TDIS_FLAG ((uint32_t)0x00000002)

i2c send interrupt status

Definition at line 75 of file at32f435_437_i2c.h.

◆ I2C_TMOUT_FLAG

#define I2C_TMOUT_FLAG ((uint32_t)0x00001000)

i2c smbus timeout flag

Definition at line 86 of file at32f435_437_i2c.h.


AT32F435/437 Firmwary Library: I2C_exported_types

Data Structures | Enumerations
I2C_exported_types
AT32F435_437_periph_driver » I2C

Data Structures

struct i2c_type
type define i2c register all More...

Enumerations

enum | i2c_smbus_mode_type { I2C_SMBUS_MODE_DEVICE = 0x00 , I2C_SMBUS_MODE_HOST = 0x01 }
i2c smbus mode set More...
enum | i2c_address_mode_type { I2C_ADDRESS_MODE_7BIT = 0x00 , I2C_ADDRESS_MODE_10BIT = 0x01 }
i2c address mode More...
enum | i2c_transfer_dir_type { I2C_DIR_TRANSMIT = 0x00 , I2C_DIR_RECEIVE = 0x01 }
i2c transfer direction More...
enum | i2c_dma_request_type { I2C_DMA_REQUEST_TX = 0x00 , I2C_DMA_REQUEST_RX = 0x01 }
i2c dma requests direction More...
enum | i2c_smbus_alert_set_type { I2C_SMBUS_ALERT_HIGH = 0x00 , I2C_SMBUS_ALERT_LOW = 0x01 }
i2c smbus alert pin set More...
enum | i2c_timeout_detcet_type { I2C_TIMEOUT_DETCET_LOW = 0x00 , I2C_TIMEOUT_DETCET_HIGH = 0x01 }
i2c clock timeout detection mode More...
enum i2c_addr2_mask_type {
I2C_ADDR2_NOMASK = 0x00 , I2C_ADDR2_MASK01 = 0x01 , I2C_ADDR2_MASK02 = 0x02 , I2C_ADDR2_MASK03 = 0x03 ,
I2C_ADDR2_MASK04 = 0x04 , I2C_ADDR2_MASK05 = 0x05 , I2C_ADDR2_MASK06 = 0x06 , I2C_ADDR2_MASK07 = 0x07
}
i2c own address2 mask More...
enum | i2c_reload_stop_mode_type { I2C_AUTO_STOP_MODE = 0x02000000 , I2C_SOFT_STOP_MODE = 0x00000000 , I2C_RELOAD_MODE = 0x01000000 }
i2c reload end mode More...
enum | i2c_start_mode_type { I2C_WITHOUT_START = 0x00000000 , I2C_GEN_START_READ = 0x00002400 , I2C_GEN_START_WRITE = 0x00002000 }
i2c start mode More...

Detailed Description

Enumeration Type Documentation

◆ i2c_addr2_mask_type

enum i2c_addr2_mask_type

i2c own address2 mask

Enumerator
I2C_ADDR2_NOMASK | compare bit [7:1]
I2C_ADDR2_MASK01 | only compare bit [7:2]
I2C_ADDR2_MASK02 | only compare bit [7:2]
I2C_ADDR2_MASK03 | only compare bit [7:3]
I2C_ADDR2_MASK04 | only compare bit [7:4]
I2C_ADDR2_MASK05 | only compare bit [7:5]
I2C_ADDR2_MASK06 | only compare bit [7:6]
I2C_ADDR2_MASK07 | only compare bit [7]

Definition at line 156 of file at32f435_437_i2c.h.

◆ i2c_address_mode_type

enum i2c_address_mode_type

i2c address mode

Enumerator
I2C_ADDRESS_MODE_7BIT | 7bit address mode
I2C_ADDRESS_MODE_10BIT | 10bit address mode

Definition at line 111 of file at32f435_437_i2c.h.

◆ i2c_dma_request_type

enum i2c_dma_request_type

i2c dma requests direction

Enumerator
I2C_DMA_REQUEST_TX | dma transmit request
I2C_DMA_REQUEST_RX | dma receive request

Definition at line 129 of file at32f435_437_i2c.h.

◆ i2c_reload_stop_mode_type

enum i2c_reload_stop_mode_type

i2c reload end mode

Enumerator
I2C_AUTO_STOP_MODE | auto generate stop mode
I2C_SOFT_STOP_MODE | soft generate stop mode
I2C_RELOAD_MODE | reload mode

Definition at line 171 of file at32f435_437_i2c.h.

◆ i2c_smbus_alert_set_type

enum i2c_smbus_alert_set_type

i2c smbus alert pin set

Enumerator
I2C_SMBUS_ALERT_HIGH | smbus alert pin set high
I2C_SMBUS_ALERT_LOW | smbus alert pin set low

Definition at line 138 of file at32f435_437_i2c.h.

◆ i2c_smbus_mode_type

enum i2c_smbus_mode_type

i2c smbus mode set

Enumerator
I2C_SMBUS_MODE_DEVICE | smbus device mode
I2C_SMBUS_MODE_HOST | smbus host mode

Definition at line 102 of file at32f435_437_i2c.h.

◆ i2c_start_mode_type

enum i2c_start_mode_type

i2c start mode

Enumerator
I2C_WITHOUT_START | transfer data without start condition
I2C_GEN_START_READ | read data and generate start
I2C_GEN_START_WRITE | send data and generate start

Definition at line 181 of file at32f435_437_i2c.h.

◆ i2c_timeout_detcet_type

enum i2c_timeout_detcet_type

i2c clock timeout detection mode

Enumerator
I2C_TIMEOUT_DETCET_LOW | detect low level timeout
I2C_TIMEOUT_DETCET_HIGH | detect high level timeout

Definition at line 147 of file at32f435_437_i2c.h.

◆ i2c_transfer_dir_type

enum i2c_transfer_dir_type

i2c transfer direction

Enumerator
I2C_DIR_TRANSMIT | master request a write transfer
I2C_DIR_RECEIVE | master request a read transfer

Definition at line 120 of file at32f435_437_i2c.h.


AT32F435/437 Firmwary Library: i2c_type Struct Reference

Data Fields
i2c_type Struct Reference
AT32F435_437_periph_driver » I2C » I2C_exported_types

type define i2c register all More...

#include <at32f435_437_i2c.h>

Data Fields

union {
__IO uint32_t ctrl1
struct {
__IO uint32_t i2cen: 1
__IO uint32_t tdien: 1
__IO uint32_t rdien: 1
__IO uint32_t addrien: 1
__IO uint32_t ackfailien: 1
__IO uint32_t stopien: 1
__IO uint32_t tdcien: 1
__IO uint32_t errien: 1
__IO uint32_t dflt: 4
__IO uint32_t reserved1: 2
__IO uint32_t dmaten: 1
__IO uint32_t dmaren: 1
__IO uint32_t sctrl: 1
__IO uint32_t stretch: 1
__IO uint32_t reserved2: 1
__IO uint32_t gcaen: 1
__IO uint32_t haddren: 1
__IO uint32_t devaddren: 1
__IO uint32_t smbalert: 1
__IO uint32_t pecen: 1
__IO uint32_t reserved3: 8
} ctrl1_bit
};
i2c ctrl1 register, offset:0x00 More...
union {
__IO uint32_t ctrl2
struct {
__IO uint32_t saddr: 10
__IO uint32_t dir: 1
__IO uint32_t addr10: 1
__IO uint32_t readh10: 1
__IO uint32_t genstart: 1
__IO uint32_t genstop: 1
__IO uint32_t nacken: 1
__IO uint32_t cnt: 8
__IO uint32_t rlden: 1
__IO uint32_t astopen: 1
__IO uint32_t pecten: 1
__IO uint32_t reserved1: 5
} ctrl2_bit
};
i2c ctrl2 register, offset:0x04 More...
union {
__IO uint32_t oaddr1
struct {
__IO uint32_t addr1: 10
__IO uint32_t addr1mode: 1
__IO uint32_t reserved1: 4
__IO uint32_t addr1en: 1
__IO uint32_t reserved2: 16
} oaddr1_bit
};
i2c oaddr1 register, offset:0x08 More...
union {
__IO uint32_t oaddr2
struct {
__IO uint32_t reserved1: 1
__IO uint32_t addr2: 7
__IO uint32_t addr2mask: 3
__IO uint32_t reserved2: 4
__IO uint32_t addr2en: 1
__IO uint32_t reserved3: 16
} oaddr2_bit
};
i2c oaddr2 register, offset:0x0c More...
union {
__IO uint32_t clkctrl
struct {
__IO uint32_t scll: 8
__IO uint32_t sclh: 8
__IO uint32_t sdad: 4
__IO uint32_t scld: 4
__IO uint32_t divh: 4
__IO uint32_t divl: 4
} clkctrl_bit
};
i2c clkctrl register, offset:0x10 More...
union {
__IO uint32_t timeout
struct {
__IO uint32_t totime: 12
__IO uint32_t tomode: 1
__IO uint32_t reserved1: 2
__IO uint32_t toen: 1
__IO uint32_t exttime: 12
__IO uint32_t reserved2: 3
__IO uint32_t exten: 1
} timeout_bit
};
i2c timeout register, offset:0x14 More...
union {
__IO uint32_t sts
struct {
__IO uint32_t tdbe: 1
__IO uint32_t tdis: 1
__IO uint32_t rdbf: 1
__IO uint32_t addrf: 1
__IO uint32_t ackfail: 1
__IO uint32_t stopf: 1
__IO uint32_t tdc: 1
__IO uint32_t tcrld: 1
__IO uint32_t buserr: 1
__IO uint32_t arlost: 1
__IO uint32_t ouf: 1
__IO uint32_t pecerr: 1
__IO uint32_t tmout: 1
__IO uint32_t alertf: 1
__IO uint32_t reserved1: 1
__IO uint32_t busyf: 1
__IO uint32_t sdir: 1
__IO uint32_t addr: 7
__IO uint32_t reserved2: 8
} sts_bit
};
i2c sts register, offset:0x18 More...
union {
__IO uint32_t clr
struct {
__IO uint32_t reserved1: 3
__IO uint32_t addrc: 1
__IO uint32_t ackfailc: 1
__IO uint32_t stopc: 1
__IO uint32_t reserved2: 2
__IO uint32_t buserrc: 1
__IO uint32_t arlostc: 1
__IO uint32_t oufc: 1
__IO uint32_t pecerrc: 1
__IO uint32_t tmoutc: 1
__IO uint32_t alertc: 1
__IO uint32_t reserved3: 18
} clr_bit
};
i2c clr register, offset:0x1c More...
union {
__IO uint32_t pec
struct {
__IO uint32_t pecval: 8
__IO uint32_t reserved1: 24
} pec_bit
};
i2c pec register, offset:0x20 More...
union {
__IO uint32_t rxdt
struct {
__IO uint32_t dt: 8
__IO uint32_t reserved1: 24
} rxdt_bit
};
i2c rxdt register, offset:0x20 More...
union {
__IO uint32_t txdt
struct {
__IO uint32_t dt: 8
__IO uint32_t reserved1: 24
} txdt_bit
};
i2c txdt register, offset:0x20 More...

Detailed Description

type define i2c register all

Definition at line 191 of file at32f435_437_i2c.h.

Field Documentation

◆

union { ... } i2c_type::@863

i2c ctrl1 register, offset:0x00

◆

union { ... } i2c_type::@865

i2c ctrl2 register, offset:0x04

◆

union { ... } i2c_type::@867

i2c oaddr1 register, offset:0x08

◆

union { ... } i2c_type::@869

i2c oaddr2 register, offset:0x0c

◆

union { ... } i2c_type::@871

i2c clkctrl register, offset:0x10

◆

union { ... } i2c_type::@873

i2c timeout register, offset:0x14

◆

union { ... } i2c_type::@875

i2c sts register, offset:0x18

◆

union { ... } i2c_type::@877

i2c clr register, offset:0x1c

◆

union { ... } i2c_type::@879

i2c pec register, offset:0x20

◆

union { ... } i2c_type::@881

i2c rxdt register, offset:0x20

◆

union { ... } i2c_type::@883

i2c txdt register, offset:0x20

◆ ackfail

__IO uint32_t i2c_type::ackfail

Definition at line 328 of file at32f435_437_i2c.h.

◆ ackfailc

__IO uint32_t i2c_type::ackfailc

Definition at line 356 of file at32f435_437_i2c.h.

◆ ackfailien

__IO uint32_t i2c_type::ackfailien

Definition at line 205 of file at32f435_437_i2c.h.

◆ addr

__IO uint32_t i2c_type::addr

Definition at line 341 of file at32f435_437_i2c.h.

Referenced by i2c_matched_addr_get().

◆ addr1

__IO uint32_t i2c_type::addr1

Definition at line 256 of file at32f435_437_i2c.h.

Referenced by i2c_own_address1_set().

◆ addr10

__IO uint32_t i2c_type::addr10

Definition at line 235 of file at32f435_437_i2c.h.

Referenced by i2c_addr10_mode_enable(), i2c_slave_transmit(), and i2c_smbus_slave_transmit().

◆ addr1en

__IO uint32_t i2c_type::addr1en

Definition at line 259 of file at32f435_437_i2c.h.

Referenced by i2c_own_address1_set().

◆ addr1mode

__IO uint32_t i2c_type::addr1mode

Definition at line 257 of file at32f435_437_i2c.h.

Referenced by i2c_own_address1_set().

◆ addr2

__IO uint32_t i2c_type::addr2

Definition at line 273 of file at32f435_437_i2c.h.

Referenced by i2c_own_address2_set().

◆ addr2en

__IO uint32_t i2c_type::addr2en

Definition at line 276 of file at32f435_437_i2c.h.

Referenced by i2c_own_address2_enable().

◆ addr2mask

__IO uint32_t i2c_type::addr2mask

Definition at line 274 of file at32f435_437_i2c.h.

Referenced by i2c_own_address2_set().

◆ addrc

__IO uint32_t i2c_type::addrc

Definition at line 355 of file at32f435_437_i2c.h.

◆ addrf

__IO uint32_t i2c_type::addrf

Definition at line 327 of file at32f435_437_i2c.h.

◆ addrien

__IO uint32_t i2c_type::addrien

Definition at line 204 of file at32f435_437_i2c.h.

◆ alertc

__IO uint32_t i2c_type::alertc

Definition at line 364 of file at32f435_437_i2c.h.

◆ alertf

__IO uint32_t i2c_type::alertf

Definition at line 337 of file at32f435_437_i2c.h.

◆ arlost

__IO uint32_t i2c_type::arlost

Definition at line 333 of file at32f435_437_i2c.h.

◆ arlostc

__IO uint32_t i2c_type::arlostc

Definition at line 360 of file at32f435_437_i2c.h.

◆ astopen

__IO uint32_t i2c_type::astopen

Definition at line 242 of file at32f435_437_i2c.h.

Referenced by i2c_auto_stop_enable(), and i2c_master_irq_handler_int().

◆ buserr

__IO uint32_t i2c_type::buserr

Definition at line 332 of file at32f435_437_i2c.h.

◆ buserrc

__IO uint32_t i2c_type::buserrc

Definition at line 359 of file at32f435_437_i2c.h.

◆ busyf

__IO uint32_t i2c_type::busyf

Definition at line 339 of file at32f435_437_i2c.h.

◆ clkctrl

__IO uint32_t i2c_type::clkctrl

Definition at line 286 of file at32f435_437_i2c.h.

Referenced by i2c_init().

◆

struct { ... } i2c_type::clkctrl_bit

◆ clr

__IO uint32_t i2c_type::clr

Definition at line 351 of file at32f435_437_i2c.h.

Referenced by i2c_flag_clear().

◆

struct { ... } i2c_type::clr_bit

◆ cnt

__IO uint32_t i2c_type::cnt

Definition at line 240 of file at32f435_437_i2c.h.

Referenced by i2c_cnt_set(), and i2c_reset_ctrl2_register().

◆ ctrl1

__IO uint32_t i2c_type::ctrl1

Definition at line 198 of file at32f435_437_i2c.h.

Referenced by i2c_interrupt_enable(), and i2c_interrupt_get().

◆

struct { ... } i2c_type::ctrl1_bit

Referenced by i2c_clock_stretch_enable(), i2c_dma_enable(), i2c_enable(), i2c_general_call_enable(), i2c_init(), i2c_pec_calculate_enable(), i2c_slave_data_ctrl_enable(), i2c_smbus_alert_set(), and i2c_smbus_enable().

◆ ctrl2

__IO uint32_t i2c_type::ctrl2

Definition at line 230 of file at32f435_437_i2c.h.

Referenced by i2c_transmit_set().

◆

struct { ... } i2c_type::ctrl2_bit

Referenced by i2c_ack_enable(), i2c_addr10_header_enable(), i2c_addr10_mode_enable(), i2c_auto_stop_enable(), i2c_cnt_set(), i2c_master_irq_handler_int(), i2c_pec_transmit_enable(), i2c_reload_enable(), i2c_reset_ctrl2_register(), i2c_slave_transmit(), i2c_smbus_slave_transmit(), i2c_start_generate(), i2c_stop_generate(), i2c_transfer_addr_get(), i2c_transfer_addr_set(), and i2c_transfer_dir_set().

◆ devaddren

__IO uint32_t i2c_type::devaddren

Definition at line 218 of file at32f435_437_i2c.h.

Referenced by i2c_smbus_enable().

◆ dflt

__IO uint32_t i2c_type::dflt

Definition at line 209 of file at32f435_437_i2c.h.

Referenced by i2c_init().

◆ dir

__IO uint32_t i2c_type::dir

Definition at line 234 of file at32f435_437_i2c.h.

Referenced by i2c_reset_ctrl2_register(), and i2c_transfer_dir_set().

◆ divh

__IO uint32_t i2c_type::divh

Definition at line 293 of file at32f435_437_i2c.h.

◆ divl

__IO uint32_t i2c_type::divl

Definition at line 294 of file at32f435_437_i2c.h.

◆ dmaren

__IO uint32_t i2c_type::dmaren

Definition at line 212 of file at32f435_437_i2c.h.

Referenced by i2c_dma_enable().

◆ dmaten

__IO uint32_t i2c_type::dmaten

Definition at line 211 of file at32f435_437_i2c.h.

Referenced by i2c_dma_enable().

◆ dt

__IO uint32_t i2c_type::dt

Definition at line 390 of file at32f435_437_i2c.h.

◆ errien

__IO uint32_t i2c_type::errien

Definition at line 208 of file at32f435_437_i2c.h.

◆ exten

__IO uint32_t i2c_type::exten

Definition at line 312 of file at32f435_437_i2c.h.

Referenced by i2c_ext_timeout_enable().

◆ exttime

__IO uint32_t i2c_type::exttime

Definition at line 310 of file at32f435_437_i2c.h.

Referenced by i2c_ext_timeout_set().

◆ gcaen

__IO uint32_t i2c_type::gcaen

Definition at line 216 of file at32f435_437_i2c.h.

Referenced by i2c_general_call_enable().

◆ genstart

__IO uint32_t i2c_type::genstart

Definition at line 237 of file at32f435_437_i2c.h.

Referenced by i2c_start_generate().

◆ genstop

__IO uint32_t i2c_type::genstop

Definition at line 238 of file at32f435_437_i2c.h.

Referenced by i2c_stop_generate().

◆ haddren

__IO uint32_t i2c_type::haddren

Definition at line 217 of file at32f435_437_i2c.h.

Referenced by i2c_smbus_enable().

◆ i2cen

__IO uint32_t i2c_type::i2cen

Definition at line 201 of file at32f435_437_i2c.h.

Referenced by i2c_enable(), and i2c_init().

◆ nacken

__IO uint32_t i2c_type::nacken

Definition at line 239 of file at32f435_437_i2c.h.

Referenced by i2c_ack_enable().

◆ oaddr1

__IO uint32_t i2c_type::oaddr1

Definition at line 253 of file at32f435_437_i2c.h.

◆

struct { ... } i2c_type::oaddr1_bit

Referenced by i2c_own_address1_set().

◆ oaddr2

__IO uint32_t i2c_type::oaddr2

Definition at line 269 of file at32f435_437_i2c.h.

◆

struct { ... } i2c_type::oaddr2_bit

Referenced by i2c_own_address2_enable(), and i2c_own_address2_set().

◆ ouf

__IO uint32_t i2c_type::ouf

Definition at line 334 of file at32f435_437_i2c.h.

◆ oufc

__IO uint32_t i2c_type::oufc

Definition at line 361 of file at32f435_437_i2c.h.

◆ pec

__IO uint32_t i2c_type::pec

Definition at line 374 of file at32f435_437_i2c.h.

◆

struct { ... } i2c_type::pec_bit

Referenced by i2c_pec_value_get().

◆ pecen

__IO uint32_t i2c_type::pecen

Definition at line 220 of file at32f435_437_i2c.h.

Referenced by i2c_pec_calculate_enable().

◆ pecerr

__IO uint32_t i2c_type::pecerr

Definition at line 335 of file at32f435_437_i2c.h.

◆ pecerrc

__IO uint32_t i2c_type::pecerrc

Definition at line 362 of file at32f435_437_i2c.h.

◆ pecten

__IO uint32_t i2c_type::pecten

Definition at line 243 of file at32f435_437_i2c.h.

Referenced by i2c_pec_transmit_enable().

◆ pecval

__IO uint32_t i2c_type::pecval

Definition at line 377 of file at32f435_437_i2c.h.

Referenced by i2c_pec_value_get().

◆ rdbf

__IO uint32_t i2c_type::rdbf

Definition at line 326 of file at32f435_437_i2c.h.

◆ rdien

__IO uint32_t i2c_type::rdien

Definition at line 203 of file at32f435_437_i2c.h.

◆ readh10

__IO uint32_t i2c_type::readh10

Definition at line 236 of file at32f435_437_i2c.h.

Referenced by i2c_addr10_header_enable(), and i2c_reset_ctrl2_register().

◆ reserved1

__IO uint32_t i2c_type::reserved1

Definition at line 210 of file at32f435_437_i2c.h.

◆ reserved2

__IO uint32_t i2c_type::reserved2

Definition at line 215 of file at32f435_437_i2c.h.

◆ reserved3

__IO uint32_t i2c_type::reserved3

Definition at line 221 of file at32f435_437_i2c.h.

◆ rlden

__IO uint32_t i2c_type::rlden

Definition at line 241 of file at32f435_437_i2c.h.

Referenced by i2c_reload_enable(), and i2c_reset_ctrl2_register().

◆ rxdt

__IO uint32_t i2c_type::rxdt

Definition at line 387 of file at32f435_437_i2c.h.

Referenced by i2c_data_receive(), and i2c_dma_config().

◆

struct { ... } i2c_type::rxdt_bit

◆ saddr

__IO uint32_t i2c_type::saddr

Definition at line 233 of file at32f435_437_i2c.h.

Referenced by i2c_reset_ctrl2_register(), i2c_transfer_addr_get(), and i2c_transfer_addr_set().

◆ scld

__IO uint32_t i2c_type::scld

Definition at line 292 of file at32f435_437_i2c.h.

◆ sclh

__IO uint32_t i2c_type::sclh

Definition at line 290 of file at32f435_437_i2c.h.

◆ scll

__IO uint32_t i2c_type::scll

Definition at line 289 of file at32f435_437_i2c.h.

◆ sctrl

__IO uint32_t i2c_type::sctrl

Definition at line 213 of file at32f435_437_i2c.h.

Referenced by i2c_slave_data_ctrl_enable().

◆ sdad

__IO uint32_t i2c_type::sdad

Definition at line 291 of file at32f435_437_i2c.h.

◆ sdir

__IO uint32_t i2c_type::sdir

Definition at line 340 of file at32f435_437_i2c.h.

Referenced by i2c_transfer_dir_get().

◆ smbalert

__IO uint32_t i2c_type::smbalert

Definition at line 219 of file at32f435_437_i2c.h.

Referenced by i2c_smbus_alert_set().

◆ stopc

__IO uint32_t i2c_type::stopc

Definition at line 357 of file at32f435_437_i2c.h.

◆ stopf

__IO uint32_t i2c_type::stopf

Definition at line 329 of file at32f435_437_i2c.h.

◆ stopien

__IO uint32_t i2c_type::stopien

Definition at line 206 of file at32f435_437_i2c.h.

◆ stretch

__IO uint32_t i2c_type::stretch

Definition at line 214 of file at32f435_437_i2c.h.

Referenced by i2c_clock_stretch_enable().

◆ sts

__IO uint32_t i2c_type::sts

Definition at line 321 of file at32f435_437_i2c.h.

Referenced by i2c_flag_get().

◆

struct { ... } i2c_type::sts_bit

Referenced by i2c_matched_addr_get(), i2c_refresh_txdt_register(), and i2c_transfer_dir_get().

◆ tcrld

__IO uint32_t i2c_type::tcrld

Definition at line 331 of file at32f435_437_i2c.h.

◆ tdbe

__IO uint32_t i2c_type::tdbe

Definition at line 324 of file at32f435_437_i2c.h.

Referenced by i2c_refresh_txdt_register().

◆ tdc

__IO uint32_t i2c_type::tdc

Definition at line 330 of file at32f435_437_i2c.h.

◆ tdcien

__IO uint32_t i2c_type::tdcien

Definition at line 207 of file at32f435_437_i2c.h.

◆ tdien

__IO uint32_t i2c_type::tdien

Definition at line 202 of file at32f435_437_i2c.h.

◆ tdis

__IO uint32_t i2c_type::tdis

Definition at line 325 of file at32f435_437_i2c.h.

◆ timeout

__IO uint32_t i2c_type::timeout

Definition at line 303 of file at32f435_437_i2c.h.

◆

struct { ... } i2c_type::timeout_bit

Referenced by i2c_ext_timeout_enable(), i2c_ext_timeout_set(), i2c_timeout_detcet_set(), i2c_timeout_enable(), and i2c_timeout_set().

◆ tmout

__IO uint32_t i2c_type::tmout

Definition at line 336 of file at32f435_437_i2c.h.

◆ tmoutc

__IO uint32_t i2c_type::tmoutc

Definition at line 363 of file at32f435_437_i2c.h.

◆ toen

__IO uint32_t i2c_type::toen

Definition at line 309 of file at32f435_437_i2c.h.

Referenced by i2c_timeout_enable().

◆ tomode

__IO uint32_t i2c_type::tomode

Definition at line 307 of file at32f435_437_i2c.h.

Referenced by i2c_timeout_detcet_set().

◆ totime

__IO uint32_t i2c_type::totime

Definition at line 306 of file at32f435_437_i2c.h.

Referenced by i2c_timeout_set().

◆ txdt

__IO uint32_t i2c_type::txdt

Definition at line 400 of file at32f435_437_i2c.h.

Referenced by i2c_data_send(), i2c_dma_config(), i2c_lowlevel_init(), i2c_refresh_txdt_register(), and i2c_slave_irq_handler_int().

◆

struct { ... } i2c_type::txdt_bit
The documentation for this struct was generated from the following file:
  • at32f435_437_i2c.h


AT32F435/437 Firmwary Library: I2C_exported_functions

Functions
I2C_exported_functions
AT32F435_437_periph_driver » I2C

Functions

void | i2c_reset (i2c_type *i2c_x)
reset the i2c register More...
void | i2c_init (i2c_type *i2c_x, uint8_t dfilters, uint32_t clk)
init i2c digit filters and clock control register. More...
void | i2c_own_address1_set (i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config i2c own address 1. More...
void | i2c_own_address2_set (i2c_type *i2c_x, uint8_t address, i2c_addr2_mask_type mask)
config i2c own address 2 and mask. More...
void | i2c_own_address2_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable own address 2. More...
void | i2c_smbus_enable (i2c_type *i2c_x, i2c_smbus_mode_type mode, confirm_state new_state)
enable or disable smbus mode. More...
void | i2c_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable peripheral. More...
void | i2c_clock_stretch_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable clock stretch. More...
void | i2c_ack_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable ack. More...
void | i2c_addr10_mode_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable 10-bit address mode (master transfer). More...
void | i2c_transfer_addr_set (i2c_type *i2c_x, uint16_t address)
config the slave address to be transmitted. More...
uint16_t | i2c_transfer_addr_get (i2c_type *i2c_x)
get the slave address to be transmitted. More...
void | i2c_transfer_dir_set (i2c_type *i2c_x, i2c_transfer_dir_type i2c_direction)
config the master transfer direction. More...
i2c_transfer_dir_type | i2c_transfer_dir_get (i2c_type *i2c_x)
slave get the i2c transfer direction. More...
uint8_t | i2c_matched_addr_get (i2c_type *i2c_x)
get the i2c slave matched address. More...
void | i2c_auto_stop_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable auto send stop mode. More...
void | i2c_reload_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable cnt reload mode. More...
void | i2c_cnt_set (i2c_type *i2c_x, uint8_t cnt)
config the transfer cnt . More...
void | i2c_addr10_header_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable read 10-bit header, this mode only used in 10-bit address mode read. More...
void | i2c_general_call_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable general call mode. More...
void | i2c_smbus_alert_set (i2c_type *i2c_x, i2c_smbus_alert_set_type level)
drives the smbus alert pin high or low. More...
void | i2c_slave_data_ctrl_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable slave data control. More...
void | i2c_pec_calculate_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable pec calculate. More...
void | i2c_pec_transmit_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable pec transfer. More...
uint8_t | i2c_pec_value_get (i2c_type *i2c_x)
get the i2c pec value. More...
void | i2c_timeout_set (i2c_type *i2c_x, uint16_t timeout)
config the i2c bus timeout. More...
void | i2c_timeout_detcet_set (i2c_type *i2c_x, i2c_timeout_detcet_type mode)
config the bus timeout detcet level. More...
void | i2c_timeout_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable bus timeout. More...
void | i2c_ext_timeout_set (i2c_type *i2c_x, uint16_t timeout)
config the i2c extend bus timeout. More...
void | i2c_ext_timeout_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable extend bus timeout. More...
void | i2c_interrupt_enable (i2c_type *i2c_x, uint32_t source, confirm_state new_state)
enable or disable interrupts. More...
flag_status | i2c_interrupt_get (i2c_type *i2c_x, uint16_t source)
get interrupt status More...
void | i2c_dma_enable (i2c_type *i2c_x, i2c_dma_request_type dma_req, confirm_state new_state)
enable or disable dma requests. More...
void | i2c_transmit_set (i2c_type *i2c_x, uint16_t address, uint8_t cnt, i2c_reload_stop_mode_type rld_stop, i2c_start_mode_type start)
config data transfer. More...
void | i2c_start_generate (i2c_type *i2c_x)
generate start condition. More...
void | i2c_stop_generate (i2c_type *i2c_x)
generate stop condition. More...
void | i2c_data_send (i2c_type *i2c_x, uint8_t data)
send a byte through the i2c periph. More...
uint8_t | i2c_data_receive (i2c_type *i2c_x)
receive a byte through the i2c periph. More...
flag_status | i2c_flag_get (i2c_type *i2c_x, uint32_t flag)
get flag status. More...
void | i2c_flag_clear (i2c_type *i2c_x, uint32_t flag)
clear flag status More...

Detailed Description

Function Documentation

◆ i2c_ack_enable()

void i2c_ack_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable ack.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none.

Definition at line 214 of file at32f435_437_i2c.c.

Referenced by i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), i2c_smbus_slave_receive(), and i2c_smbus_slave_transmit().

◆ i2c_addr10_header_enable()

void i2c_addr10_header_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable read 10-bit header, this mode only used in 10-bit address mode read.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 354 of file at32f435_437_i2c.c.

◆ i2c_addr10_mode_enable()

void i2c_addr10_mode_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable 10-bit address mode (master transfer).

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 227 of file at32f435_437_i2c.c.

◆ i2c_auto_stop_enable()

void i2c_auto_stop_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable auto send stop mode.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 314 of file at32f435_437_i2c.c.

◆ i2c_clock_stretch_enable()

void i2c_clock_stretch_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable clock stretch.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 201 of file at32f435_437_i2c.c.

◆ i2c_cnt_set()

void i2c_cnt_set | ( | i2c_type * | i2c_x,
 |  | uint8_t | cnt
 | ) |  |

config the transfer cnt .

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
cnt | transfer cnt.
Return values
none

Definition at line 340 of file at32f435_437_i2c.c.

Referenced by i2c_smbus_slave_receive(), and i2c_smbus_slave_transmit().

◆ i2c_data_receive()

uint8_t i2c_data_receive ( i2c_type * i2c_x )

receive a byte through the i2c periph.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
Return values
the value of the received data.

Definition at line 671 of file at32f435_437_i2c.c.

Referenced by i2c_master_irq_handler_int(), i2c_master_receive(), i2c_memory_read(), i2c_slave_irq_handler_dma(), i2c_slave_irq_handler_int(), i2c_slave_receive(), i2c_smbus_master_receive(), and i2c_smbus_slave_receive().

◆ i2c_data_send()

void i2c_data_send | ( | i2c_type * | i2c_x,
 |  | uint8_t | data
 | ) |  |

send a byte through the i2c periph.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
data | byte to be transmitted.
Return values
none

Definition at line 659 of file at32f435_437_i2c.c.

Referenced by i2c_master_irq_handler_int(), i2c_master_transmit(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_transmit(), i2c_smbus_master_transmit(), and i2c_smbus_slave_transmit().

◆ i2c_dma_enable()

void i2c_dma_enable | ( | i2c_type * | i2c_x,
 |  | i2c_dma_request_type | dma_req,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dma requests.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
dma_req dma transfer request. this parameter can be one of the following values:
  • I2C_DMA_REQUEST_TX: dma transmit request.
  • I2C_DMA_REQUEST_RX: dma receive request.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 576 of file at32f435_437_i2c.c.

Referenced by i2c_dma_tx_rx_irq_handler(), i2c_master_irq_handler_dma(), i2c_master_receive_dma(), i2c_master_transmit_dma(), i2c_memory_read_dma(), i2c_memory_write_dma(), i2c_slave_receive_dma(), and i2c_slave_transmit_dma().

◆ i2c_enable()

void i2c_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable peripheral.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 188 of file at32f435_437_i2c.c.

Referenced by i2c_config().

◆ i2c_ext_timeout_enable()

void i2c_ext_timeout_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable extend bus timeout.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 502 of file at32f435_437_i2c.c.

◆ i2c_ext_timeout_set()

void i2c_ext_timeout_set | ( | i2c_type * | i2c_x,
 |  | uint16_t | timeout
 | ) |  |

config the i2c extend bus timeout.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
timeout | extend timeout (0x0000~0x0FFF).
Return values
none

Definition at line 489 of file at32f435_437_i2c.c.

◆ i2c_flag_clear()

void i2c_flag_clear | ( | i2c_type * | i2c_x,
 |  | uint32_t | flag
 | ) |  |

clear flag status

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
flag specifies the flag to clear. this parameter can be any combination of the following values:
  • I2C_ADDRF_FLAG: 0~7 bit address match flag.
  • I2C_ACKFAIL_FLAG: acknowledge failure flag.
  • I2C_STOPF_FLAG: stop condition generation complete flag.
  • I2C_BUSERR_FLAG: bus error flag.
  • I2C_ARLOST_FLAG: arbitration lost flag.
  • I2C_OUF_FLAG: overflow or underflow flag.
  • I2C_PECERR_FLAG: pec receive error flag.
  • I2C_TMOUT_FLAG: smbus timeout flag.
  • I2C_ALERTF_FLAG: smbus alert flag.
Return values
none

Definition at line 731 of file at32f435_437_i2c.c.

Referenced by i2c_err_irq_handler(), i2c_master_irq_handler_dma(), i2c_master_irq_handler_int(), i2c_master_receive(), i2c_master_transmit(), i2c_memory_read(), i2c_memory_write(), i2c_slave_irq_handler_dma(), i2c_slave_irq_handler_int(), i2c_slave_receive(), i2c_slave_transmit(), i2c_smbus_master_receive(), i2c_smbus_master_transmit(), i2c_smbus_slave_receive(), i2c_smbus_slave_transmit(), and i2c_wait_flag().

◆ i2c_flag_get()

flag_status i2c_flag_get | ( | i2c_type * | i2c_x,
 |  | uint32_t | flag
 | ) |  |

get flag status.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
flag specifies the flag to check. this parameter can be one of the following values:
  • I2C_TDBE_FLAG: transmit data buffer empty flag.
  • I2C_TDIS_FLAG: send interrupt status.
  • I2C_RDBF_FLAG: receive data buffer full flag.
  • I2C_ADDRF_FLAG: 0~7 bit address match flag.
  • I2C_ACKFAIL_FLAG: acknowledge failure flag.
  • I2C_STOPF_FLAG: stop condition generation complete flag.
  • I2C_TDC_FLAG: transmit data complete flag.
  • I2C_TCRLD_FLAG: transmission is complete, waiting to load data.
  • I2C_BUSERR_FLAG: bus error flag.
  • I2C_ARLOST_FLAG: arbitration lost flag.
  • I2C_OUF_FLAG: overflow or underflow flag.
  • I2C_PECERR_FLAG: pec receive error flag.
  • I2C_TMOUT_FLAG: smbus timeout flag.
  • I2C_ALERTF_FLAG: smbus alert flag.
  • I2C_BUSYF_FLAG: bus busy flag transmission mode.
  • I2C_SDIR_FLAG: slave data transmit direction.
Return values
the new state of flag (SET or RESET).

Definition at line 701 of file at32f435_437_i2c.c.

Referenced by i2c_err_irq_handler(), i2c_master_irq_handler_dma(), i2c_master_irq_handler_int(), i2c_refresh_txdt_register(), i2c_slave_irq_handler_dma(), i2c_slave_irq_handler_int(), i2c_slave_receive(), i2c_smbus_slave_receive(), and i2c_wait_flag().

◆ i2c_general_call_enable()

void i2c_general_call_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable general call mode.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 367 of file at32f435_437_i2c.c.

◆ i2c_init()

void i2c_init | ( | i2c_type * | i2c_x,
 |  | uint8_t | dfilters,
 |  | uint32_t | clk
 | ) |  |

init i2c digit filters and clock control register.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
dfilters | number of digit filters (0x00~0x0F).
clk | i2c clock control register (0x00000000~0xFFFFFFFF).
Return values
none

Definition at line 79 of file at32f435_437_i2c.c.

Referenced by i2c_lowlevel_init().

◆ i2c_interrupt_enable()

void i2c_interrupt_enable | ( | i2c_type * | i2c_x,
 |  | uint32_t | source,
 |  | confirm_state | new_state
 | ) |  |

enable or disable interrupts.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
i2c_int interrupts sources. this parameter can be one of the following values:
  • I2C_TD_INT: transmit data interrupt.
  • I2C_RD_INT: receive data interrupt.
  • I2C_ADDR_INT: address match interrupt.
  • I2C_ACKFIAL_INT: ack fail interrupt.
  • I2C_STOP_INT: stop detect interrupt.
  • I2C_TDC_INT: transmit data complete interrupt.
  • I2C_ERR_INT: bus error interrupt.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 524 of file at32f435_437_i2c.c.

Referenced by i2c_dma_tx_rx_irq_handler(), i2c_err_irq_handler(), i2c_master_irq_handler_dma(), i2c_master_irq_handler_int(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_irq_handler_dma(), i2c_slave_irq_handler_int(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit_dma(), and i2c_slave_transmit_int().

◆ i2c_interrupt_get()

flag_status i2c_interrupt_get | ( | i2c_type * | i2c_x,
 |  | uint16_t | source
 | ) |  |

get interrupt status

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
source this parameter can be one of the following values:
  • I2C_TD_INT: transmit data interrupt.
  • I2C_RD_INT: receive data interrupt.
  • I2C_ADDR_INT: address match interrupt.
  • I2C_ACKFIAL_INT: ack fail interrupt.
  • I2C_STOP_INT: stop detect interrupt.
  • I2C_TDC_INT: transmit data complete interrupt.
  • I2C_ERR_INT: bus error interrupt.
Return values
flag_status (SET or RESET)

Definition at line 552 of file at32f435_437_i2c.c.

◆ i2c_matched_addr_get()

uint8_t i2c_matched_addr_get ( i2c_type * i2c_x )

get the i2c slave matched address.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
Return values
slave matched address.

Definition at line 301 of file at32f435_437_i2c.c.

◆ i2c_own_address1_set()

void i2c_own_address1_set | ( | i2c_type * | i2c_x,
 |  | i2c_address_mode_type | mode,
 |  | uint16_t | address
 | ) |  |

config i2c own address 1.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
mode i2c address mode. this parameter can be one of the following values:
  • I2C_ADDRESS_MODE_7BIT: 7bit address.
  • I2C_ADDRESS_MODE_10BIT: 10bit address.
address | own address 1, such as 0xB0.
Return values
none

Definition at line 103 of file at32f435_437_i2c.c.

Referenced by i2c_lowlevel_init().

◆ i2c_own_address2_enable()

void i2c_own_address2_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable own address 2.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 148 of file at32f435_437_i2c.c.

◆ i2c_own_address2_set()

void i2c_own_address2_set | ( | i2c_type * | i2c_x,
 |  | uint8_t | address,
 |  | i2c_addr2_mask_type | mask
 | ) |  |

config i2c own address 2 and mask.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
address | own address 1, such as 0xC0.
mask own address 2 mask. this parameter can be one of the following values:
  • I2C_ADDR2_NOMASK: compare bit [7:1].
  • I2C_ADDR2_MASK01: only compare bit [7:2].
  • I2C_ADDR2_MASK02: only compare bit [7:2].
  • I2C_ADDR2_MASK03: only compare bit [7:3].
  • I2C_ADDR2_MASK04: only compare bit [7:4].
  • I2C_ADDR2_MASK05: only compare bit [7:5].
  • I2C_ADDR2_MASK06: only compare bit [7:6].
  • I2C_ADDR2_MASK07: only compare bit [7].
Return values
none

Definition at line 133 of file at32f435_437_i2c.c.

◆ i2c_pec_calculate_enable()

void i2c_pec_calculate_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable pec calculate.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 409 of file at32f435_437_i2c.c.

Referenced by i2c_smbus_master_receive(), i2c_smbus_master_transmit(), i2c_smbus_slave_receive(), and i2c_smbus_slave_transmit().

◆ i2c_pec_transmit_enable()

void i2c_pec_transmit_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable pec transfer.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 422 of file at32f435_437_i2c.c.

Referenced by i2c_smbus_master_receive(), i2c_smbus_master_transmit(), i2c_smbus_slave_receive(), and i2c_smbus_slave_transmit().

◆ i2c_pec_value_get()

uint8_t i2c_pec_value_get ( i2c_type * i2c_x )

get the i2c pec value.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
Return values
the value of the pec.

Definition at line 434 of file at32f435_437_i2c.c.

◆ i2c_reload_enable()

void i2c_reload_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable cnt reload mode.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 327 of file at32f435_437_i2c.c.

◆ i2c_reset()

void i2c_reset ( i2c_type * i2c_x )

reset the i2c register

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
Return values
none

Definition at line 51 of file at32f435_437_i2c.c.

Referenced by i2c_config().

◆ i2c_slave_data_ctrl_enable()

void i2c_slave_data_ctrl_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable slave data control.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 396 of file at32f435_437_i2c.c.

Referenced by i2c_smbus_slave_receive(), and i2c_smbus_slave_transmit().

◆ i2c_smbus_alert_set()

void i2c_smbus_alert_set | ( | i2c_type * | i2c_x,
 |  | i2c_smbus_alert_set_type | level
 | ) |  |

drives the smbus alert pin high or low.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
level this parameter can be one of the following values:
  • I2C_SMBUS_ALERT_LOW: smbus alert set low.
  • I2C_SMBUS_ALERT_HIGH: smbus alert set high.
Return values
none

Definition at line 383 of file at32f435_437_i2c.c.

◆ i2c_smbus_enable()

void i2c_smbus_enable | ( | i2c_type * | i2c_x,
 |  | i2c_smbus_mode_type | mode,
 |  | confirm_state | new_state
 | ) |  |

enable or disable smbus mode.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
mode smbus device mode. this parameter can be one of the following values:
  • I2C_SMBUS_MODE_DEVICE: smbus device.
  • I2C_SMBUS_MODE_HOST: smbus host.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 165 of file at32f435_437_i2c.c.

◆ i2c_start_generate()

void i2c_start_generate ( i2c_type * i2c_x )

generate start condition.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
Return values
none

Definition at line 634 of file at32f435_437_i2c.c.

◆ i2c_stop_generate()

void i2c_stop_generate ( i2c_type * i2c_x )

generate stop condition.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
Return values
none

Definition at line 646 of file at32f435_437_i2c.c.

Referenced by i2c_master_irq_handler_int().

◆ i2c_timeout_detcet_set()

void i2c_timeout_detcet_set | ( | i2c_type * | i2c_x,
 |  | i2c_timeout_detcet_type | mode
 | ) |  |

config the bus timeout detcet level.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
level this parameter can be one of the following values:
  • I2C_TIMEOUT_DETCET_HIGH: detect high level timeout.
  • I2C_TIMEOUT_DETCET_LOW: detect low level timeout.
Return values
none

Definition at line 463 of file at32f435_437_i2c.c.

◆ i2c_timeout_enable()

void i2c_timeout_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable bus timeout.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 476 of file at32f435_437_i2c.c.

◆ i2c_timeout_set()

void i2c_timeout_set | ( | i2c_type * | i2c_x,
 |  | uint16_t | timeout
 | ) |  |

config the i2c bus timeout.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
timeout | timeout (0x0000~0x0FFF).
Return values
none

Definition at line 447 of file at32f435_437_i2c.c.

◆ i2c_transfer_addr_get()

uint16_t i2c_transfer_addr_get ( i2c_type * i2c_x )

get the slave address to be transmitted.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
Return values
slave address

Definition at line 252 of file at32f435_437_i2c.c.

Referenced by i2c_master_irq_handler_dma(), and i2c_master_irq_handler_int().

◆ i2c_transfer_addr_set()

void i2c_transfer_addr_set | ( | i2c_type * | i2c_x,
 |  | uint16_t | address
 | ) |  |

config the slave address to be transmitted.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
address | slave address.
Return values
none

Definition at line 240 of file at32f435_437_i2c.c.

◆ i2c_transfer_dir_get()

i2c_transfer_dir_type i2c_transfer_dir_get ( i2c_type * i2c_x )

slave get the i2c transfer direction.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
Return values
the value of the slave direction
  • I2C_DIR_TRANSMIT: master request a write transfer, slave enters receiver mode.
  • I2C_DIR_RECEIVE: master request a read transfer, slave enters transmitter mode.

Definition at line 282 of file at32f435_437_i2c.c.

◆ i2c_transfer_dir_set()

void i2c_transfer_dir_set | ( | i2c_type * | i2c_x,
 |  | i2c_transfer_dir_type | i2c_direction
 | ) |  |

config the master transfer direction.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
i2c_direction transfer request direction. this parameter can be one of the following values:
  • I2C_DIR_TRANSMIT: master request a write transfer.
  • I2C_DIR_RECEIVE: master request a read transfer.
Return values
none

Definition at line 268 of file at32f435_437_i2c.c.

◆ i2c_transmit_set()

void i2c_transmit_set | ( | i2c_type * | i2c_x,
 |  | uint16_t | address,
 |  | uint8_t | cnt,
 |  | i2c_reload_stop_mode_type | rld_stop,
 |  | i2c_start_mode_type | start
 | ) |  |

config data transfer.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
address | slave address.
cnt | transfer conuter(0~255)
rld_stop config reload and gen stop condition mode. this parameter can be one of the following values:
  • I2C_AUTO_STOP_MODE: auto generate stop mode.
  • I2C_SOFT_STOP_MODE: soft generate stop mode.
  • I2C_RELOAD_MODE: reload mode.
start config gen start condition mode. this parameter can be one of the following values:
  • I2C_WITHOUT_START: transfer data without start condition.
  • I2C_GEN_START_READ: read data and generate start.
  • I2C_GEN_START_WRITE: send data and generate start.
Return values
none

Definition at line 607 of file at32f435_437_i2c.c.

Referenced by i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write_dma(), i2c_start_transfer(), and i2c_start_transfer_dma().


AT32F435/437 Firmwary Library: I2C_private_functions

Functions
I2C_private_functions
AT32F435_437_periph_driver » I2C

Functions

void | i2c_reset (i2c_type *i2c_x)
reset the i2c register More...
void | i2c_init (i2c_type *i2c_x, uint8_t dfilters, uint32_t clk)
init i2c digit filters and clock control register. More...
void | i2c_own_address1_set (i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config i2c own address 1. More...
void | i2c_own_address2_set (i2c_type *i2c_x, uint8_t address, i2c_addr2_mask_type mask)
config i2c own address 2 and mask. More...
void | i2c_own_address2_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable own address 2. More...
void | i2c_smbus_enable (i2c_type *i2c_x, i2c_smbus_mode_type mode, confirm_state new_state)
enable or disable smbus mode. More...
void | i2c_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable peripheral. More...
void | i2c_clock_stretch_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable clock stretch. More...
void | i2c_ack_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable ack. More...
void | i2c_addr10_mode_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable 10-bit address mode (master transfer). More...
void | i2c_transfer_addr_set (i2c_type *i2c_x, uint16_t address)
config the slave address to be transmitted. More...
uint16_t | i2c_transfer_addr_get (i2c_type *i2c_x)
get the slave address to be transmitted. More...
void | i2c_transfer_dir_set (i2c_type *i2c_x, i2c_transfer_dir_type i2c_direction)
config the master transfer direction. More...
i2c_transfer_dir_type | i2c_transfer_dir_get (i2c_type *i2c_x)
slave get the i2c transfer direction. More...
uint8_t | i2c_matched_addr_get (i2c_type *i2c_x)
get the i2c slave matched address. More...
void | i2c_auto_stop_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable auto send stop mode. More...
void | i2c_reload_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable cnt reload mode. More...
void | i2c_cnt_set (i2c_type *i2c_x, uint8_t cnt)
config the transfer cnt . More...
void | i2c_addr10_header_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable read 10-bit header, this mode only used in 10-bit address mode read. More...
void | i2c_general_call_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable general call mode. More...
void | i2c_smbus_alert_set (i2c_type *i2c_x, i2c_smbus_alert_set_type level)
drives the smbus alert pin high or low. More...
void | i2c_slave_data_ctrl_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable slave data control. More...
void | i2c_pec_calculate_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable pec calculate. More...
void | i2c_pec_transmit_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable pec transfer. More...
uint8_t | i2c_pec_value_get (i2c_type *i2c_x)
get the i2c pec value. More...
void | i2c_timeout_set (i2c_type *i2c_x, uint16_t timeout)
config the i2c bus timeout. More...
void | i2c_timeout_detcet_set (i2c_type *i2c_x, i2c_timeout_detcet_type mode)
config the bus timeout detcet level. More...
void | i2c_timeout_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable bus timeout. More...
void | i2c_ext_timeout_set (i2c_type *i2c_x, uint16_t timeout)
config the i2c extend bus timeout. More...
void | i2c_ext_timeout_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable extend bus timeout. More...
void | i2c_interrupt_enable (i2c_type *i2c_x, uint32_t source, confirm_state new_state)
enable or disable interrupts. More...
flag_status | i2c_interrupt_get (i2c_type *i2c_x, uint16_t source)
get interrupt status More...
void | i2c_dma_enable (i2c_type *i2c_x, i2c_dma_request_type dma_req, confirm_state new_state)
enable or disable dma requests. More...
void | i2c_transmit_set (i2c_type *i2c_x, uint16_t address, uint8_t cnt, i2c_reload_stop_mode_type rld_stop, i2c_start_mode_type start)
config data transfer. More...
void | i2c_start_generate (i2c_type *i2c_x)
generate start condition. More...
void | i2c_stop_generate (i2c_type *i2c_x)
generate stop condition. More...
void | i2c_data_send (i2c_type *i2c_x, uint8_t data)
send a byte through the i2c periph. More...
uint8_t | i2c_data_receive (i2c_type *i2c_x)
receive a byte through the i2c periph. More...
flag_status | i2c_flag_get (i2c_type *i2c_x, uint32_t flag)
get flag status. More...
void | i2c_flag_clear (i2c_type *i2c_x, uint32_t flag)
clear flag status More...

Detailed Description

Function Documentation

◆ i2c_ack_enable()

void i2c_ack_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable ack.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none.

Definition at line 214 of file at32f435_437_i2c.c.

Referenced by i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), i2c_smbus_slave_receive(), and i2c_smbus_slave_transmit().

◆ i2c_addr10_header_enable()

void i2c_addr10_header_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable read 10-bit header, this mode only used in 10-bit address mode read.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 354 of file at32f435_437_i2c.c.

◆ i2c_addr10_mode_enable()

void i2c_addr10_mode_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable 10-bit address mode (master transfer).

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 227 of file at32f435_437_i2c.c.

◆ i2c_auto_stop_enable()

void i2c_auto_stop_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable auto send stop mode.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 314 of file at32f435_437_i2c.c.

◆ i2c_clock_stretch_enable()

void i2c_clock_stretch_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable clock stretch.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 201 of file at32f435_437_i2c.c.

◆ i2c_cnt_set()

void i2c_cnt_set | ( | i2c_type * | i2c_x,
 |  | uint8_t | cnt
 | ) |  |

config the transfer cnt .

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
cnt | transfer cnt.
Return values
none

Definition at line 340 of file at32f435_437_i2c.c.

Referenced by i2c_smbus_slave_receive(), and i2c_smbus_slave_transmit().

◆ i2c_data_receive()

uint8_t i2c_data_receive ( i2c_type * i2c_x )

receive a byte through the i2c periph.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
Return values
the value of the received data.

Definition at line 671 of file at32f435_437_i2c.c.

Referenced by i2c_master_irq_handler_int(), i2c_master_receive(), i2c_memory_read(), i2c_slave_irq_handler_dma(), i2c_slave_irq_handler_int(), i2c_slave_receive(), i2c_smbus_master_receive(), and i2c_smbus_slave_receive().

◆ i2c_data_send()

void i2c_data_send | ( | i2c_type * | i2c_x,
 |  | uint8_t | data
 | ) |  |

send a byte through the i2c periph.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
data | byte to be transmitted.
Return values
none

Definition at line 659 of file at32f435_437_i2c.c.

Referenced by i2c_master_irq_handler_int(), i2c_master_transmit(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_transmit(), i2c_smbus_master_transmit(), and i2c_smbus_slave_transmit().

◆ i2c_dma_enable()

void i2c_dma_enable | ( | i2c_type * | i2c_x,
 |  | i2c_dma_request_type | dma_req,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dma requests.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
dma_req dma transfer request. this parameter can be one of the following values:
  • I2C_DMA_REQUEST_TX: dma transmit request.
  • I2C_DMA_REQUEST_RX: dma receive request.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 576 of file at32f435_437_i2c.c.

Referenced by i2c_dma_tx_rx_irq_handler(), i2c_master_irq_handler_dma(), i2c_master_receive_dma(), i2c_master_transmit_dma(), i2c_memory_read_dma(), i2c_memory_write_dma(), i2c_slave_receive_dma(), and i2c_slave_transmit_dma().

◆ i2c_enable()

void i2c_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable peripheral.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 188 of file at32f435_437_i2c.c.

Referenced by i2c_config().

◆ i2c_ext_timeout_enable()

void i2c_ext_timeout_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable extend bus timeout.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 502 of file at32f435_437_i2c.c.

◆ i2c_ext_timeout_set()

void i2c_ext_timeout_set | ( | i2c_type * | i2c_x,
 |  | uint16_t | timeout
 | ) |  |

config the i2c extend bus timeout.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
timeout | extend timeout (0x0000~0x0FFF).
Return values
none

Definition at line 489 of file at32f435_437_i2c.c.

◆ i2c_flag_clear()

void i2c_flag_clear | ( | i2c_type * | i2c_x,
 |  | uint32_t | flag
 | ) |  |

clear flag status

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
flag specifies the flag to clear. this parameter can be any combination of the following values:
  • I2C_ADDRF_FLAG: 0~7 bit address match flag.
  • I2C_ACKFAIL_FLAG: acknowledge failure flag.
  • I2C_STOPF_FLAG: stop condition generation complete flag.
  • I2C_BUSERR_FLAG: bus error flag.
  • I2C_ARLOST_FLAG: arbitration lost flag.
  • I2C_OUF_FLAG: overflow or underflow flag.
  • I2C_PECERR_FLAG: pec receive error flag.
  • I2C_TMOUT_FLAG: smbus timeout flag.
  • I2C_ALERTF_FLAG: smbus alert flag.
Return values
none

Definition at line 731 of file at32f435_437_i2c.c.

Referenced by i2c_err_irq_handler(), i2c_master_irq_handler_dma(), i2c_master_irq_handler_int(), i2c_master_receive(), i2c_master_transmit(), i2c_memory_read(), i2c_memory_write(), i2c_slave_irq_handler_dma(), i2c_slave_irq_handler_int(), i2c_slave_receive(), i2c_slave_transmit(), i2c_smbus_master_receive(), i2c_smbus_master_transmit(), i2c_smbus_slave_receive(), i2c_smbus_slave_transmit(), and i2c_wait_flag().

◆ i2c_flag_get()

flag_status i2c_flag_get | ( | i2c_type * | i2c_x,
 |  | uint32_t | flag
 | ) |  |

get flag status.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
flag specifies the flag to check. this parameter can be one of the following values:
  • I2C_TDBE_FLAG: transmit data buffer empty flag.
  • I2C_TDIS_FLAG: send interrupt status.
  • I2C_RDBF_FLAG: receive data buffer full flag.
  • I2C_ADDRF_FLAG: 0~7 bit address match flag.
  • I2C_ACKFAIL_FLAG: acknowledge failure flag.
  • I2C_STOPF_FLAG: stop condition generation complete flag.
  • I2C_TDC_FLAG: transmit data complete flag.
  • I2C_TCRLD_FLAG: transmission is complete, waiting to load data.
  • I2C_BUSERR_FLAG: bus error flag.
  • I2C_ARLOST_FLAG: arbitration lost flag.
  • I2C_OUF_FLAG: overflow or underflow flag.
  • I2C_PECERR_FLAG: pec receive error flag.
  • I2C_TMOUT_FLAG: smbus timeout flag.
  • I2C_ALERTF_FLAG: smbus alert flag.
  • I2C_BUSYF_FLAG: bus busy flag transmission mode.
  • I2C_SDIR_FLAG: slave data transmit direction.
Return values
the new state of flag (SET or RESET).

Definition at line 701 of file at32f435_437_i2c.c.

Referenced by i2c_err_irq_handler(), i2c_master_irq_handler_dma(), i2c_master_irq_handler_int(), i2c_refresh_txdt_register(), i2c_slave_irq_handler_dma(), i2c_slave_irq_handler_int(), i2c_slave_receive(), i2c_smbus_slave_receive(), and i2c_wait_flag().

◆ i2c_general_call_enable()

void i2c_general_call_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable general call mode.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 367 of file at32f435_437_i2c.c.

◆ i2c_init()

void i2c_init | ( | i2c_type * | i2c_x,
 |  | uint8_t | dfilters,
 |  | uint32_t | clk
 | ) |  |

init i2c digit filters and clock control register.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
dfilters | number of digit filters (0x00~0x0F).
clk | i2c clock control register (0x00000000~0xFFFFFFFF).
Return values
none

Definition at line 79 of file at32f435_437_i2c.c.

Referenced by i2c_lowlevel_init().

◆ i2c_interrupt_enable()

void i2c_interrupt_enable | ( | i2c_type * | i2c_x,
 |  | uint32_t | source,
 |  | confirm_state | new_state
 | ) |  |

enable or disable interrupts.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
i2c_int interrupts sources. this parameter can be one of the following values:
  • I2C_TD_INT: transmit data interrupt.
  • I2C_RD_INT: receive data interrupt.
  • I2C_ADDR_INT: address match interrupt.
  • I2C_ACKFIAL_INT: ack fail interrupt.
  • I2C_STOP_INT: stop detect interrupt.
  • I2C_TDC_INT: transmit data complete interrupt.
  • I2C_ERR_INT: bus error interrupt.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 524 of file at32f435_437_i2c.c.

Referenced by i2c_dma_tx_rx_irq_handler(), i2c_err_irq_handler(), i2c_master_irq_handler_dma(), i2c_master_irq_handler_int(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_irq_handler_dma(), i2c_slave_irq_handler_int(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit_dma(), and i2c_slave_transmit_int().

◆ i2c_interrupt_get()

flag_status i2c_interrupt_get | ( | i2c_type * | i2c_x,
 |  | uint16_t | source
 | ) |  |

get interrupt status

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
source this parameter can be one of the following values:
  • I2C_TD_INT: transmit data interrupt.
  • I2C_RD_INT: receive data interrupt.
  • I2C_ADDR_INT: address match interrupt.
  • I2C_ACKFIAL_INT: ack fail interrupt.
  • I2C_STOP_INT: stop detect interrupt.
  • I2C_TDC_INT: transmit data complete interrupt.
  • I2C_ERR_INT: bus error interrupt.
Return values
flag_status (SET or RESET)

Definition at line 552 of file at32f435_437_i2c.c.

◆ i2c_matched_addr_get()

uint8_t i2c_matched_addr_get ( i2c_type * i2c_x )

get the i2c slave matched address.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
Return values
slave matched address.

Definition at line 301 of file at32f435_437_i2c.c.

◆ i2c_own_address1_set()

void i2c_own_address1_set | ( | i2c_type * | i2c_x,
 |  | i2c_address_mode_type | mode,
 |  | uint16_t | address
 | ) |  |

config i2c own address 1.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
mode i2c address mode. this parameter can be one of the following values:
  • I2C_ADDRESS_MODE_7BIT: 7bit address.
  • I2C_ADDRESS_MODE_10BIT: 10bit address.
address | own address 1, such as 0xB0.
Return values
none

Definition at line 103 of file at32f435_437_i2c.c.

Referenced by i2c_lowlevel_init().

◆ i2c_own_address2_enable()

void i2c_own_address2_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable own address 2.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 148 of file at32f435_437_i2c.c.

◆ i2c_own_address2_set()

void i2c_own_address2_set | ( | i2c_type * | i2c_x,
 |  | uint8_t | address,
 |  | i2c_addr2_mask_type | mask
 | ) |  |

config i2c own address 2 and mask.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
address | own address 1, such as 0xC0.
mask own address 2 mask. this parameter can be one of the following values:
  • I2C_ADDR2_NOMASK: compare bit [7:1].
  • I2C_ADDR2_MASK01: only compare bit [7:2].
  • I2C_ADDR2_MASK02: only compare bit [7:2].
  • I2C_ADDR2_MASK03: only compare bit [7:3].
  • I2C_ADDR2_MASK04: only compare bit [7:4].
  • I2C_ADDR2_MASK05: only compare bit [7:5].
  • I2C_ADDR2_MASK06: only compare bit [7:6].
  • I2C_ADDR2_MASK07: only compare bit [7].
Return values
none

Definition at line 133 of file at32f435_437_i2c.c.

◆ i2c_pec_calculate_enable()

void i2c_pec_calculate_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable pec calculate.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 409 of file at32f435_437_i2c.c.

Referenced by i2c_smbus_master_receive(), i2c_smbus_master_transmit(), i2c_smbus_slave_receive(), and i2c_smbus_slave_transmit().

◆ i2c_pec_transmit_enable()

void i2c_pec_transmit_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable pec transfer.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 422 of file at32f435_437_i2c.c.

Referenced by i2c_smbus_master_receive(), i2c_smbus_master_transmit(), i2c_smbus_slave_receive(), and i2c_smbus_slave_transmit().

◆ i2c_pec_value_get()

uint8_t i2c_pec_value_get ( i2c_type * i2c_x )

get the i2c pec value.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
Return values
the value of the pec.

Definition at line 434 of file at32f435_437_i2c.c.

◆ i2c_reload_enable()

void i2c_reload_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable cnt reload mode.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 327 of file at32f435_437_i2c.c.

◆ i2c_reset()

void i2c_reset ( i2c_type * i2c_x )

reset the i2c register

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
Return values
none

Definition at line 51 of file at32f435_437_i2c.c.

Referenced by i2c_config().

◆ i2c_slave_data_ctrl_enable()

void i2c_slave_data_ctrl_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable slave data control.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 396 of file at32f435_437_i2c.c.

Referenced by i2c_smbus_slave_receive(), and i2c_smbus_slave_transmit().

◆ i2c_smbus_alert_set()

void i2c_smbus_alert_set | ( | i2c_type * | i2c_x,
 |  | i2c_smbus_alert_set_type | level
 | ) |  |

drives the smbus alert pin high or low.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
level this parameter can be one of the following values:
  • I2C_SMBUS_ALERT_LOW: smbus alert set low.
  • I2C_SMBUS_ALERT_HIGH: smbus alert set high.
Return values
none

Definition at line 383 of file at32f435_437_i2c.c.

◆ i2c_smbus_enable()

void i2c_smbus_enable | ( | i2c_type * | i2c_x,
 |  | i2c_smbus_mode_type | mode,
 |  | confirm_state | new_state
 | ) |  |

enable or disable smbus mode.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
mode smbus device mode. this parameter can be one of the following values:
  • I2C_SMBUS_MODE_DEVICE: smbus device.
  • I2C_SMBUS_MODE_HOST: smbus host.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 165 of file at32f435_437_i2c.c.

◆ i2c_start_generate()

void i2c_start_generate ( i2c_type * i2c_x )

generate start condition.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
Return values
none

Definition at line 634 of file at32f435_437_i2c.c.

◆ i2c_stop_generate()

void i2c_stop_generate ( i2c_type * i2c_x )

generate stop condition.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
Return values
none

Definition at line 646 of file at32f435_437_i2c.c.

Referenced by i2c_master_irq_handler_int().

◆ i2c_timeout_detcet_set()

void i2c_timeout_detcet_set | ( | i2c_type * | i2c_x,
 |  | i2c_timeout_detcet_type | mode
 | ) |  |

config the bus timeout detcet level.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
level this parameter can be one of the following values:
  • I2C_TIMEOUT_DETCET_HIGH: detect high level timeout.
  • I2C_TIMEOUT_DETCET_LOW: detect low level timeout.
Return values
none

Definition at line 463 of file at32f435_437_i2c.c.

◆ i2c_timeout_enable()

void i2c_timeout_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable bus timeout.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
new_state | (TRUE or FALSE).
Return values
none

Definition at line 476 of file at32f435_437_i2c.c.

◆ i2c_timeout_set()

void i2c_timeout_set | ( | i2c_type * | i2c_x,
 |  | uint16_t | timeout
 | ) |  |

config the i2c bus timeout.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
timeout | timeout (0x0000~0x0FFF).
Return values
none

Definition at line 447 of file at32f435_437_i2c.c.

◆ i2c_transfer_addr_get()

uint16_t i2c_transfer_addr_get ( i2c_type * i2c_x )

get the slave address to be transmitted.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
Return values
slave address

Definition at line 252 of file at32f435_437_i2c.c.

Referenced by i2c_master_irq_handler_dma(), and i2c_master_irq_handler_int().

◆ i2c_transfer_addr_set()

void i2c_transfer_addr_set | ( | i2c_type * | i2c_x,
 |  | uint16_t | address
 | ) |  |

config the slave address to be transmitted.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
address | slave address.
Return values
none

Definition at line 240 of file at32f435_437_i2c.c.

◆ i2c_transfer_dir_get()

i2c_transfer_dir_type i2c_transfer_dir_get ( i2c_type * i2c_x )

slave get the i2c transfer direction.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
Return values
the value of the slave direction
  • I2C_DIR_TRANSMIT: master request a write transfer, slave enters receiver mode.
  • I2C_DIR_RECEIVE: master request a read transfer, slave enters transmitter mode.

Definition at line 282 of file at32f435_437_i2c.c.

◆ i2c_transfer_dir_set()

void i2c_transfer_dir_set | ( | i2c_type * | i2c_x,
 |  | i2c_transfer_dir_type | i2c_direction
 | ) |  |

config the master transfer direction.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
i2c_direction transfer request direction. this parameter can be one of the following values:
  • I2C_DIR_TRANSMIT: master request a write transfer.
  • I2C_DIR_RECEIVE: master request a read transfer.
Return values
none

Definition at line 268 of file at32f435_437_i2c.c.

◆ i2c_transmit_set()

void i2c_transmit_set | ( | i2c_type * | i2c_x,
 |  | uint16_t | address,
 |  | uint8_t | cnt,
 |  | i2c_reload_stop_mode_type | rld_stop,
 |  | i2c_start_mode_type | start
 | ) |  |

config data transfer.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2, I2C3.
address | slave address.
cnt | transfer conuter(0~255)
rld_stop config reload and gen stop condition mode. this parameter can be one of the following values:
  • I2C_AUTO_STOP_MODE: auto generate stop mode.
  • I2C_SOFT_STOP_MODE: soft generate stop mode.
  • I2C_RELOAD_MODE: reload mode.
start config gen start condition mode. this parameter can be one of the following values:
  • I2C_WITHOUT_START: transfer data without start condition.
  • I2C_GEN_START_READ: read data and generate start.
  • I2C_GEN_START_WRITE: send data and generate start.
Return values
none

Definition at line 607 of file at32f435_437_i2c.c.

Referenced by i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write_dma(), i2c_start_transfer(), and i2c_start_transfer_dma().


AT32F435/437 Firmwary Library: MISC

Modules
MISC
AT32F435_437_periph_driver

MISC driver modules. More...

Modules

MISC_vector_table_base_address
MISC_exported_types
MISC_exported_functions
MISC_private_functions

Detailed Description

MISC driver modules.


AT32F435/437 Firmwary Library: MISC_vector_table_base_address

Macros
MISC_vector_table_base_address
AT32F435_437_periph_driver » MISC

Macros

#define | NVIC_VECTTAB_RAM ((uint32_t)0x20000000)
#define | NVIC_VECTTAB_FLASH ((uint32_t)0x08000000)

Detailed Description

Macro Definition Documentation

◆ NVIC_VECTTAB_FLASH

#define NVIC_VECTTAB_FLASH ((uint32_t)0x08000000)

nvic vector table based flash address

Definition at line 52 of file at32f435_437_misc.h.

◆ NVIC_VECTTAB_RAM

#define NVIC_VECTTAB_RAM ((uint32_t)0x20000000)

nvic vector table based ram address

Definition at line 51 of file at32f435_437_misc.h.


AT32F435/437 Firmwary Library: MISC_exported_types

Enumerations
MISC_exported_types
AT32F435_437_periph_driver » MISC

Enumerations

enum nvic_priority_group_type {
NVIC_PRIORITY_GROUP_0 = ((uint32_t)0x7) , NVIC_PRIORITY_GROUP_1 = ((uint32_t)0x6) , NVIC_PRIORITY_GROUP_2 = ((uint32_t)0x5) , NVIC_PRIORITY_GROUP_3 = ((uint32_t)0x4) ,
NVIC_PRIORITY_GROUP_4 = ((uint32_t)0x3)
}
nvic interrupt priority group More...
enum | nvic_lowpower_mode_type { NVIC_LP_SLEEPONEXIT = 0x02 , NVIC_LP_SLEEPDEEP = 0x04 , NVIC_LP_SEVONPEND = 0x10 }
nvic low power mode More...
enum | systick_clock_source_type { SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8 = ((uint32_t)0x00000000) , SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV = ((uint32_t)0x00000004) }
systick clock source More...

Detailed Description

Enumeration Type Documentation

◆ nvic_lowpower_mode_type

enum nvic_lowpower_mode_type

nvic low power mode

Enumerator
NVIC_LP_SLEEPONEXIT | enable sleep-on-exit feature
NVIC_LP_SLEEPDEEP | enable sleep-deep output signal when entering sleep mode
NVIC_LP_SEVONPEND | send event on pending

Definition at line 77 of file at32f435_437_misc.h.

◆ nvic_priority_group_type

enum nvic_priority_group_type

nvic interrupt priority group

Enumerator
NVIC_PRIORITY_GROUP_0 | 0 bits for preemption priority, 4 bits for subpriority
NVIC_PRIORITY_GROUP_1 | 1 bits for preemption priority, 3 bits for subpriority
NVIC_PRIORITY_GROUP_2 | 2 bits for preemption priority, 2 bits for subpriority
NVIC_PRIORITY_GROUP_3 | 3 bits for preemption priority, 1 bits for subpriority
NVIC_PRIORITY_GROUP_4 | 4 bits for preemption priority, 0 bits for subpriority

Definition at line 65 of file at32f435_437_misc.h.

◆ systick_clock_source_type

enum systick_clock_source_type

systick clock source

Enumerator
SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8 | systick clock source from core clock div8
SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV | systick clock source from core clock

Definition at line 87 of file at32f435_437_misc.h.


AT32F435/437 Firmwary Library: MISC_exported_functions

Functions
MISC_exported_functions
AT32F435_437_periph_driver » MISC

Functions

void | nvic_system_reset (void)
system reset More...
void | nvic_irq_enable (IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq More...
void | nvic_irq_disable (IRQn_Type irqn)
disable nvic irq number More...
void | nvic_priority_group_config (nvic_priority_group_type priority_group)
config nvic priority group More...
void | nvic_vector_table_set (uint32_t base, uint32_t offset)
set the vector table location and offset. More...
void | nvic_lowpower_mode_config (nvic_lowpower_mode_type lp_mode, confirm_state new_state)
config nvic lowpower mode More...
void | systick_clock_source_config (systick_clock_source_type source)
config systick clock source More...

Detailed Description

Function Documentation

◆ nvic_irq_disable()

void nvic_irq_disable ( IRQn_Type irqn )

disable nvic irq number

Parameters
irqn (IRQn_Type number)
Return values
none

Definition at line 81 of file at32f435_437_misc.c.

Referenced by app_load(), and jump_to_app().

◆ nvic_irq_enable()

void nvic_irq_enable | ( | IRQn_Type | irqn,
 |  | uint32_t | preempt_priority,
 |  | uint32_t | sub_priority
 | ) |  |

enable nvic irq

Parameters
irqn | (IRQn_Type number)
preempt_priority | preemptive priority value (starting from 0)
sub_priority | subpriority value (starting from 0)
Return values
none

Definition at line 64 of file at32f435_437_misc.c.

Referenced by adc_config(), button_exint_init(), can_configuration(), codec_i2s_init(), config_flash_interrupt(), dma_config(), dma_configuration(), dvp_config(), dvp_dma_init(), edma_config(), emac_nvic_configuration(), emac_tmr_init(), emac_wake_on_lan_init(), ertc_alarm_config(), ertc_tamper_config(), ertc_timestamp_config(), ertc_wakeup_timer_config(), exint_line0_config(), exint_line4_config(), i2c_lowlevel_init(), i2s_config(), lick_frequency_get(), main(), nvic_configuration(), rs485_config(), spi_config(), tmr1_config(), tmr2_config(), tmr_init(), uart_init(), usart1_config(), usart_configuration(), usb_usart_config(), and wakeup_timer_config().

◆ nvic_lowpower_mode_config()

void nvic_lowpower_mode_config | ( | nvic_lowpower_mode_type | lp_mode,
 |  | confirm_state | new_state
 | ) |  |

config nvic lowpower mode

Parameters
lp_mode this parameter can be one of the following values:
  • NVIC_LP_SEVONPEND
  • NVIC_LP_SLEEPDEEP
  • NVIC_LP_SLEEPONEXIT
new_state (new state of lp condition. ENABLE or DISABLE)
Return values
none

Definition at line 127 of file at32f435_437_misc.c.

◆ nvic_priority_group_config()

void nvic_priority_group_config ( nvic_priority_group_type priority_group )

config nvic priority group

Parameters
priority_group this parameter can be one of the following values:
  • NVIC_PRIORITY_GROUP_0
  • NVIC_PRIORITY_GROUP_1
  • NVIC_PRIORITY_GROUP_2
  • NVIC_PRIORITY_GROUP_3
  • NVIC_PRIORITY_GROUP_4
Return values
none

Definition at line 97 of file at32f435_437_misc.c.

Referenced by button_exint_init(), config_flash_interrupt(), dma_configuration(), emac_tmr_init(), emac_wake_on_lan_init(), exint_line0_config(), main(), nvic_configuration(), and usart_configuration().

◆ nvic_system_reset()

void nvic_system_reset ( void )

system reset

Parameters
none
Return values
none

Definition at line 52 of file at32f435_437_misc.c.

Referenced by app_loop(), extend_sram(), iap_command_handle(), and main().

◆ nvic_vector_table_set()

void nvic_vector_table_set | ( | uint32_t | base,
 |  | uint32_t | offset
 | ) |  |

set the vector table location and offset.

Parameters
base this parameter can be one of the following values:
  • NVIC_VECTTAB_RAM
  • NVIC_VECTTAB_FLASH
offset (vector table base offset field. this value must be a multiple of 0x200)
Return values
none

Definition at line 112 of file at32f435_437_misc.c.

Referenced by main().

◆ systick_clock_source_config()

void systick_clock_source_config ( systick_clock_source_type source )

config systick clock source

Parameters
source this parameter can be one of the following values:
  • SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8
  • SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
Return values
none

Definition at line 147 of file at32f435_437_misc.c.

Referenced by delay_init(), and main().


AT32F435/437 Firmwary Library: MISC_private_functions

Macros | Functions
MISC_private_functions
AT32F435_437_periph_driver » MISC

Macros

#define AIRCR_VECTKEY_MASK ((uint32_t)0x05FA0000)

Functions

void | nvic_system_reset (void)
system reset More...
void | nvic_irq_enable (IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq More...
void | nvic_irq_disable (IRQn_Type irqn)
disable nvic irq number More...
void | nvic_priority_group_config (nvic_priority_group_type priority_group)
config nvic priority group More...
void | nvic_vector_table_set (uint32_t base, uint32_t offset)
set the vector table location and offset. More...
void | nvic_lowpower_mode_config (nvic_lowpower_mode_type lp_mode, confirm_state new_state)
config nvic lowpower mode More...
void | systick_clock_source_config (systick_clock_source_type source)
config systick clock source More...

Detailed Description

Macro Definition Documentation

◆ AIRCR_VECTKEY_MASK

#define AIRCR_VECTKEY_MASK ((uint32_t)0x05FA0000)

Definition at line 45 of file at32f435_437_misc.c.

Function Documentation

◆ nvic_irq_disable()

void nvic_irq_disable ( IRQn_Type irqn )

disable nvic irq number

Parameters
irqn (IRQn_Type number)
Return values
none

Definition at line 81 of file at32f435_437_misc.c.

Referenced by app_load(), and jump_to_app().

◆ nvic_irq_enable()

void nvic_irq_enable | ( | IRQn_Type | irqn,
 |  | uint32_t | preempt_priority,
 |  | uint32_t | sub_priority
 | ) |  |

enable nvic irq

Parameters
irqn | (IRQn_Type number)
preempt_priority | preemptive priority value (starting from 0)
sub_priority | subpriority value (starting from 0)
Return values
none

Definition at line 64 of file at32f435_437_misc.c.

Referenced by adc_config(), button_exint_init(), can_configuration(), codec_i2s_init(), config_flash_interrupt(), dma_config(), dma_configuration(), dvp_config(), dvp_dma_init(), edma_config(), emac_nvic_configuration(), emac_tmr_init(), emac_wake_on_lan_init(), ertc_alarm_config(), ertc_tamper_config(), ertc_timestamp_config(), ertc_wakeup_timer_config(), exint_line0_config(), exint_line4_config(), i2c_lowlevel_init(), i2s_config(), lick_frequency_get(), main(), nvic_configuration(), rs485_config(), spi_config(), tmr1_config(), tmr2_config(), tmr_init(), uart_init(), usart1_config(), usart_configuration(), usb_usart_config(), and wakeup_timer_config().

◆ nvic_lowpower_mode_config()

void nvic_lowpower_mode_config | ( | nvic_lowpower_mode_type | lp_mode,
 |  | confirm_state | new_state
 | ) |  |

config nvic lowpower mode

Parameters
lp_mode this parameter can be one of the following values:
  • NVIC_LP_SEVONPEND
  • NVIC_LP_SLEEPDEEP
  • NVIC_LP_SLEEPONEXIT
new_state (new state of lp condition. ENABLE or DISABLE)
Return values
none

Definition at line 127 of file at32f435_437_misc.c.

◆ nvic_priority_group_config()

void nvic_priority_group_config ( nvic_priority_group_type priority_group )

config nvic priority group

Parameters
priority_group this parameter can be one of the following values:
  • NVIC_PRIORITY_GROUP_0
  • NVIC_PRIORITY_GROUP_1
  • NVIC_PRIORITY_GROUP_2
  • NVIC_PRIORITY_GROUP_3
  • NVIC_PRIORITY_GROUP_4
Return values
none

Definition at line 97 of file at32f435_437_misc.c.

Referenced by button_exint_init(), config_flash_interrupt(), dma_configuration(), emac_tmr_init(), emac_wake_on_lan_init(), exint_line0_config(), main(), nvic_configuration(), and usart_configuration().

◆ nvic_system_reset()

void nvic_system_reset ( void )

system reset

Parameters
none
Return values
none

Definition at line 52 of file at32f435_437_misc.c.

Referenced by app_loop(), extend_sram(), iap_command_handle(), and main().

◆ nvic_vector_table_set()

void nvic_vector_table_set | ( | uint32_t | base,
 |  | uint32_t | offset
 | ) |  |

set the vector table location and offset.

Parameters
base this parameter can be one of the following values:
  • NVIC_VECTTAB_RAM
  • NVIC_VECTTAB_FLASH
offset (vector table base offset field. this value must be a multiple of 0x200)
Return values
none

Definition at line 112 of file at32f435_437_misc.c.

Referenced by main().

◆ systick_clock_source_config()

void systick_clock_source_config ( systick_clock_source_type source )

config systick clock source

Parameters
source this parameter can be one of the following values:
  • SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8
  • SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
Return values
none

Definition at line 147 of file at32f435_437_misc.c.

Referenced by delay_init(), and main().


AT32F435/437 Firmwary Library: PWC

Modules | Macros
PWC
AT32F435_437_periph_driver

PWC driver modules. More...

Modules

PWC_flags_definition
pwc flag
PWC_exported_types
PWC_exported_functions
PWC_private_functions

Macros

#define | PWC_WAKEUP_PIN_1 ((uint32_t)0x00000100)
pwc wakeup pin num definition More...
#define | PWC_WAKEUP_PIN_2 ((uint32_t)0x00000200)
#define | pwc_ldo_output_voltage_set(val) (PWC->ldoov_bit.ldoovsel = val)
select ldo output voltage. More...
#define | PWC ((pwc_type *) PWC_BASE)

Detailed Description

PWC driver modules.

Macro Definition Documentation

◆ PWC

#define PWC ((pwc_type *) PWC_BASE)

Definition at line 196 of file at32f435_437_pwc.h.

◆ pwc_ldo_output_voltage_set

#define pwc_ldo_output_voltage_set ( val ) (PWC->ldoov_bit.ldoovsel = val)

select ldo output voltage.

Parameters
val set the ldo output voltage. this parameter can be one of the following values:
  • PWC_LDO_OUTPUT_1V2
  • PWC_LDO_OUTPUT_1V3
  • PWC_LDO_OUTPUT_1V1
  • PWC_LDO_OUTPUT_1V0

Definition at line 75 of file at32f435_437_pwc.h.

◆ PWC_WAKEUP_PIN_1

#define PWC_WAKEUP_PIN_1 ((uint32_t)0x00000100)

pwc wakeup pin num definition

standby wake-up pin1

Definition at line 63 of file at32f435_437_pwc.h.

◆ PWC_WAKEUP_PIN_2

#define PWC_WAKEUP_PIN_2 ((uint32_t)0x00000200)

standby wake-up pin2

Definition at line 64 of file at32f435_437_pwc.h.


AT32F435/437 Firmwary Library: PWC_flags_definition

Macros
PWC_flags_definition
AT32F435_437_periph_driver » PWC

pwc flag More...

Macros

#define | PWC_WAKEUP_FLAG ((uint32_t)0x00000001)
#define | PWC_STANDBY_FLAG ((uint32_t)0x00000002)
#define | PWC_PVM_OUTPUT_FLAG ((uint32_t)0x00000004)

Detailed Description

pwc flag

Macro Definition Documentation

◆ PWC_PVM_OUTPUT_FLAG

#define PWC_PVM_OUTPUT_FLAG ((uint32_t)0x00000004)

pvm output flag

Definition at line 54 of file at32f435_437_pwc.h.

◆ PWC_STANDBY_FLAG

#define PWC_STANDBY_FLAG ((uint32_t)0x00000002)

standby flag

Definition at line 53 of file at32f435_437_pwc.h.

◆ PWC_WAKEUP_FLAG

#define PWC_WAKEUP_FLAG ((uint32_t)0x00000001)

wakeup flag

Definition at line 52 of file at32f435_437_pwc.h.


AT32F435/437 Firmwary Library: PWC_exported_types

Data Structures | Enumerations
PWC_exported_types
AT32F435_437_periph_driver » PWC

Data Structures

struct pwc_type
type define pwc register all More...

Enumerations

enum pwc_pvm_voltage_type {
PWC_PVM_VOLTAGE_2V3 = 0x01 , PWC_PVM_VOLTAGE_2V4 = 0x02 , PWC_PVM_VOLTAGE_2V5 = 0x03 , PWC_PVM_VOLTAGE_2V6 = 0x04 ,
PWC_PVM_VOLTAGE_2V7 = 0x05 , PWC_PVM_VOLTAGE_2V8 = 0x06 , PWC_PVM_VOLTAGE_2V9 = 0x07
}
pwc pvm voltage type More...
enum | pwc_ldo_output_voltage_type { PWC_LDO_OUTPUT_1V2 = 0x00 , PWC_LDO_OUTPUT_1V3 = 0x01 , PWC_LDO_OUTPUT_1V1 = 0x04 , PWC_LDO_OUTPUT_1V0 = 0x05 }
pwc ldo output voltage type More...
enum | pwc_sleep_enter_type { PWC_SLEEP_ENTER_WFI = 0x00 , PWC_SLEEP_ENTER_WFE = 0x01 }
pwc sleep enter type More...
enum | pwc_deep_sleep_enter_type { PWC_DEEP_SLEEP_ENTER_WFI = 0x00 , PWC_DEEP_SLEEP_ENTER_WFE = 0x01 }
pwc deep sleep enter type More...
enum | pwc_regulator_type { PWC_REGULATOR_ON = 0x00 , PWC_REGULATOR_LOW_POWER = 0x01 }
pwc regulator type More...

Detailed Description

Enumeration Type Documentation

◆ pwc_deep_sleep_enter_type

enum pwc_deep_sleep_enter_type

pwc deep sleep enter type

Enumerator
PWC_DEEP_SLEEP_ENTER_WFI | use wfi enter deepsleep mode
PWC_DEEP_SLEEP_ENTER_WFE | use wfe enter deepsleep mode

Definition at line 118 of file at32f435_437_pwc.h.

◆ pwc_ldo_output_voltage_type

enum pwc_ldo_output_voltage_type

pwc ldo output voltage type

Enumerator
PWC_LDO_OUTPUT_1V2 | ldo output voltage is 1.2v
PWC_LDO_OUTPUT_1V3 | ldo output voltage is 1.3v
PWC_LDO_OUTPUT_1V1 | ldo output voltage is 1.1v
PWC_LDO_OUTPUT_1V0 | ldo output voltage is 1.0v

Definition at line 98 of file at32f435_437_pwc.h.

◆ pwc_pvm_voltage_type

enum pwc_pvm_voltage_type

pwc pvm voltage type

Enumerator
PWC_PVM_VOLTAGE_2V3 | power voltage monitoring boundary 2.3v
PWC_PVM_VOLTAGE_2V4 | power voltage monitoring boundary 2.4v
PWC_PVM_VOLTAGE_2V5 | power voltage monitoring boundary 2.5v
PWC_PVM_VOLTAGE_2V6 | power voltage monitoring boundary 2.6v
PWC_PVM_VOLTAGE_2V7 | power voltage monitoring boundary 2.7v
PWC_PVM_VOLTAGE_2V8 | power voltage monitoring boundary 2.8v
PWC_PVM_VOLTAGE_2V9 | power voltage monitoring boundary 2.9v

Definition at line 84 of file at32f435_437_pwc.h.

◆ pwc_regulator_type

enum pwc_regulator_type

pwc regulator type

Enumerator
PWC_REGULATOR_ON | voltage regulator state on when deepsleep mode
PWC_REGULATOR_LOW_POWER | voltage regulator state low power when deepsleep mode

Definition at line 127 of file at32f435_437_pwc.h.

◆ pwc_sleep_enter_type

enum pwc_sleep_enter_type

pwc sleep enter type

Enumerator
PWC_SLEEP_ENTER_WFI | use wfi enter sleep mode
PWC_SLEEP_ENTER_WFE | use wfe enter sleep mode

Definition at line 109 of file at32f435_437_pwc.h.


AT32F435/437 Firmwary Library: pwc_type Struct Reference

Data Fields
pwc_type Struct Reference
AT32F435_437_periph_driver » PWC » PWC_exported_types

type define pwc register all More...

#include <at32f435_437_pwc.h>

Data Fields

union {
__IO uint32_t ctrl
struct {
__IO uint32_t vrsel: 1
__IO uint32_t lpsel: 1
__IO uint32_t clswef: 1
__IO uint32_t clsef: 1
__IO uint32_t pvmen: 1
__IO uint32_t pvmsel: 3
__IO uint32_t bpwen: 1
__IO uint32_t reserved1: 23
} ctrl_bit
};
pwc ctrl register, offset:0x00 More...
union {
__IO uint32_t ctrlsts
struct {
__IO uint32_t swef: 1
__IO uint32_t sef: 1
__IO uint32_t pvmof: 1
__IO uint32_t reserved1: 5
__IO uint32_t swpen1: 1
__IO uint32_t swpen2: 1
__IO uint32_t reserved2: 22
} ctrlsts_bit
};
pwc ctrlsts register, offset:0x04 More...
union {
__IO uint32_t ldoov
struct {
__IO uint32_t ldoovsel: 3
__IO uint32_t reserved1: 29
} ldoov_bit
};
pwc ldoov register, offset:0x10 More...

Detailed Description

type define pwc register all

Definition at line 136 of file at32f435_437_pwc.h.

Field Documentation

◆

union { ... } pwc_type::@896

pwc ctrl register, offset:0x00

◆

union { ... } pwc_type::@898

pwc ctrlsts register, offset:0x04

◆

union { ... } pwc_type::@900

pwc ldoov register, offset:0x10

◆ bpwen

__IO uint32_t pwc_type::bpwen

Definition at line 152 of file at32f435_437_pwc.h.

◆ clsef

__IO uint32_t pwc_type::clsef

Definition at line 149 of file at32f435_437_pwc.h.

◆ clswef

__IO uint32_t pwc_type::clswef

Definition at line 148 of file at32f435_437_pwc.h.

◆ ctrl

__IO uint32_t pwc_type::ctrl

Definition at line 143 of file at32f435_437_pwc.h.

◆

struct { ... } pwc_type::ctrl_bit

◆ ctrlsts

__IO uint32_t pwc_type::ctrlsts

Definition at line 162 of file at32f435_437_pwc.h.

◆

struct { ... } pwc_type::ctrlsts_bit

◆ ldoov

__IO uint32_t pwc_type::ldoov

Definition at line 182 of file at32f435_437_pwc.h.

◆

struct { ... } pwc_type::ldoov_bit

◆ ldoovsel

__IO uint32_t pwc_type::ldoovsel

Definition at line 185 of file at32f435_437_pwc.h.

◆ lpsel

__IO uint32_t pwc_type::lpsel

Definition at line 147 of file at32f435_437_pwc.h.

◆ pvmen

__IO uint32_t pwc_type::pvmen

Definition at line 150 of file at32f435_437_pwc.h.

◆ pvmof

__IO uint32_t pwc_type::pvmof

Definition at line 167 of file at32f435_437_pwc.h.

◆ pvmsel

__IO uint32_t pwc_type::pvmsel

Definition at line 151 of file at32f435_437_pwc.h.

◆ reserved1

__IO uint32_t pwc_type::reserved1

Definition at line 153 of file at32f435_437_pwc.h.

◆ reserved2

__IO uint32_t pwc_type::reserved2

Definition at line 171 of file at32f435_437_pwc.h.

◆ sef

__IO uint32_t pwc_type::sef

Definition at line 166 of file at32f435_437_pwc.h.

◆ swef

__IO uint32_t pwc_type::swef

Definition at line 165 of file at32f435_437_pwc.h.

◆ swpen1

__IO uint32_t pwc_type::swpen1

Definition at line 169 of file at32f435_437_pwc.h.

◆ swpen2

__IO uint32_t pwc_type::swpen2

Definition at line 170 of file at32f435_437_pwc.h.

◆ vrsel

__IO uint32_t pwc_type::vrsel

Definition at line 146 of file at32f435_437_pwc.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_pwc.h


AT32F435/437 Firmwary Library: PWC_exported_functions

Functions
PWC_exported_functions
AT32F435_437_periph_driver » PWC

Functions

void | pwc_reset (void)
deinitialize the pwc peripheral registers to their default reset values. More...
void | pwc_battery_powered_domain_access (confirm_state new_state)
enable or disable access to the battery powered domain. More...
void | pwc_pvm_level_select (pwc_pvm_voltage_type pvm_voltage)
select the voltage threshold detected by the power voltage detector. More...
void | pwc_power_voltage_monitor_enable (confirm_state new_state)
enable or disable pwc power voltage monitor (pvm) More...
void | pwc_wakeup_pin_enable (uint32_t pin_num, confirm_state new_state)
enable or disable pwc standby wakeup pin More...
void | pwc_flag_clear (uint32_t pwc_flag)
clear flag of pwc More...
flag_status | pwc_flag_get (uint32_t pwc_flag)
get flag of pwc More...
void | pwc_sleep_mode_enter (pwc_sleep_enter_type pwc_sleep_enter)
enter pwc sleep mode More...
void | pwc_deep_sleep_mode_enter (pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode More...
void | pwc_voltage_regulate_set (pwc_regulator_type pwc_regulator)
regulate low power consumption in the deep sleep mode More...
void | pwc_standby_mode_enter (void)
enter pwc standby mode More...

Detailed Description

Function Documentation

◆ pwc_battery_powered_domain_access()

void pwc_battery_powered_domain_access ( confirm_state new_state )

enable or disable access to the battery powered domain.

Parameters
new_state new state of battery powered domain access. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 61 of file at32f435_437_pwc.c.

Referenced by ertc_config(), and main().

◆ pwc_deep_sleep_mode_enter()

void pwc_deep_sleep_mode_enter ( pwc_deep_sleep_enter_type pwc_deep_sleep_enter )

enter pwc deep-sleep mode

Parameters
pwc_deep_sleep_enter choose the instruction to enter deep sleep mode. this parameter can be one of the following values:
  • PWC_DEEP_SLEEP_ENTER_WFI
  • PWC_DEEP_SLEEP_ENTER_WFE
Return values
none

Definition at line 190 of file at32f435_437_pwc.c.

Referenced by emac_wake_on_lan_init(), and main().

◆ pwc_flag_clear()

void pwc_flag_clear ( uint32_t pwc_flag )

clear flag of pwc

Parameters
pwc_flag select the pwc flag. this parameter can be any combination of the following values:
  • PWC_WAKEUP_FLAG
  • PWC_STANDBY_FLAG
  • note:"PWC_PVM_OUTPUT_FLAG" cannot be choose!this bit is readonly bit,it means the voltage monitoring output state
Return values
none

< standby flag

< wakeup flag

Definition at line 128 of file at32f435_437_pwc.c.

Referenced by main().

◆ pwc_flag_get()

flag_status pwc_flag_get ( uint32_t pwc_flag )

get flag of pwc

Parameters
pwc_flag select the pwc flag. this parameter can be one of the following values:
  • PWC_WAKEUP_FLAG
  • PWC_STANDBY_FLAG
  • PWC_PVM_OUTPUT_FLAG
Return values
state of select flag(SET or RESET).

Definition at line 145 of file at32f435_437_pwc.c.

Referenced by main().

◆ pwc_power_voltage_monitor_enable()

void pwc_power_voltage_monitor_enable ( confirm_state new_state )

enable or disable pwc power voltage monitor (pvm)

Parameters
new_state new state of pvm. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 90 of file at32f435_437_pwc.c.

Referenced by main().

◆ pwc_pvm_level_select()

void pwc_pvm_level_select ( pwc_pvm_voltage_type pvm_voltage )

select the voltage threshold detected by the power voltage detector.

Parameters
pvm_voltage select pwc pvm voltage this parameter can be one of the following values:
  • PWC_PVM_VOLTAGE_2V3
  • PWC_PVM_VOLTAGE_2V4
  • PWC_PVM_VOLTAGE_2V5
  • PWC_PVM_VOLTAGE_2V6
  • PWC_PVM_VOLTAGE_2V7
  • PWC_PVM_VOLTAGE_2V8
  • PWC_PVM_VOLTAGE_2V9
Return values
none

Definition at line 79 of file at32f435_437_pwc.c.

Referenced by main().

◆ pwc_reset()

void pwc_reset ( void )

deinitialize the pwc peripheral registers to their default reset values.

Parameters
none
Return values
none

Definition at line 49 of file at32f435_437_pwc.c.

◆ pwc_sleep_mode_enter()

void pwc_sleep_mode_enter ( pwc_sleep_enter_type pwc_sleep_enter )

enter pwc sleep mode

Parameters
sleep_mode_enter choose the instruction to enter sleep mode. this parameter can be one of the following values:
  • PWC_SLEEP_ENTER_WFI
  • PWC_SLEEP_ENTER_WFE
Return values
none

Definition at line 167 of file at32f435_437_pwc.c.

Referenced by main().

◆ pwc_standby_mode_enter()

void pwc_standby_mode_enter ( void )

enter pwc standby mode

Parameters
none
Return values
none

Definition at line 224 of file at32f435_437_pwc.c.

Referenced by main().

◆ pwc_voltage_regulate_set()

void pwc_voltage_regulate_set ( pwc_regulator_type pwc_regulator )

regulate low power consumption in the deep sleep mode

Parameters
pwc_regulator set the regulator state. this parameter can be one of the following values:
  • PWC_REGULATOR_ON
  • PWC_REGULATOR_LOW_POWER
Return values
none

Definition at line 214 of file at32f435_437_pwc.c.

Referenced by emac_wake_on_lan_init(), and main().

◆ pwc_wakeup_pin_enable()

void pwc_wakeup_pin_enable | ( | uint32_t | pin_num,
 |  | confirm_state | new_state
 | ) |  |

enable or disable pwc standby wakeup pin

Parameters
pin_num choose the wakeup pin. this parameter can be be any combination of the following values:
  • PWC_WAKEUP_PIN_1
  • PWC_WAKEUP_PIN_2
new_state new state of the standby wakeup pin. this parameter can be one of the following values:
  • TRUE <wakeup pin is used for wake up cpu from standby mode>
  • FALSE <wakeup pin is used for general purpose I/O>
Return values
none

Definition at line 107 of file at32f435_437_pwc.c.

Referenced by main().


AT32F435/437 Firmwary Library: PWC_private_functions

Functions
PWC_private_functions
AT32F435_437_periph_driver » PWC

Functions

void | pwc_reset (void)
deinitialize the pwc peripheral registers to their default reset values. More...
void | pwc_battery_powered_domain_access (confirm_state new_state)
enable or disable access to the battery powered domain. More...
void | pwc_pvm_level_select (pwc_pvm_voltage_type pvm_voltage)
select the voltage threshold detected by the power voltage detector. More...
void | pwc_power_voltage_monitor_enable (confirm_state new_state)
enable or disable pwc power voltage monitor (pvm) More...
void | pwc_wakeup_pin_enable (uint32_t pin_num, confirm_state new_state)
enable or disable pwc standby wakeup pin More...
void | pwc_flag_clear (uint32_t pwc_flag)
clear flag of pwc More...
flag_status | pwc_flag_get (uint32_t pwc_flag)
get flag of pwc More...
void | pwc_sleep_mode_enter (pwc_sleep_enter_type pwc_sleep_enter)
enter pwc sleep mode More...
void | pwc_deep_sleep_mode_enter (pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode More...
void | pwc_voltage_regulate_set (pwc_regulator_type pwc_regulator)
regulate low power consumption in the deep sleep mode More...
void | pwc_standby_mode_enter (void)
enter pwc standby mode More...

Detailed Description

Function Documentation

◆ pwc_battery_powered_domain_access()

void pwc_battery_powered_domain_access ( confirm_state new_state )

enable or disable access to the battery powered domain.

Parameters
new_state new state of battery powered domain access. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 61 of file at32f435_437_pwc.c.

Referenced by ertc_config(), and main().

◆ pwc_deep_sleep_mode_enter()

void pwc_deep_sleep_mode_enter ( pwc_deep_sleep_enter_type pwc_deep_sleep_enter )

enter pwc deep-sleep mode

Parameters
pwc_deep_sleep_enter choose the instruction to enter deep sleep mode. this parameter can be one of the following values:
  • PWC_DEEP_SLEEP_ENTER_WFI
  • PWC_DEEP_SLEEP_ENTER_WFE
Return values
none

Definition at line 190 of file at32f435_437_pwc.c.

Referenced by emac_wake_on_lan_init(), and main().

◆ pwc_flag_clear()

void pwc_flag_clear ( uint32_t pwc_flag )

clear flag of pwc

Parameters
pwc_flag select the pwc flag. this parameter can be any combination of the following values:
  • PWC_WAKEUP_FLAG
  • PWC_STANDBY_FLAG
  • note:"PWC_PVM_OUTPUT_FLAG" cannot be choose!this bit is readonly bit,it means the voltage monitoring output state
Return values
none

< standby flag

< wakeup flag

Definition at line 128 of file at32f435_437_pwc.c.

Referenced by main().

◆ pwc_flag_get()

flag_status pwc_flag_get ( uint32_t pwc_flag )

get flag of pwc

Parameters
pwc_flag select the pwc flag. this parameter can be one of the following values:
  • PWC_WAKEUP_FLAG
  • PWC_STANDBY_FLAG
  • PWC_PVM_OUTPUT_FLAG
Return values
state of select flag(SET or RESET).

Definition at line 145 of file at32f435_437_pwc.c.

Referenced by main().

◆ pwc_power_voltage_monitor_enable()

void pwc_power_voltage_monitor_enable ( confirm_state new_state )

enable or disable pwc power voltage monitor (pvm)

Parameters
new_state new state of pvm. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 90 of file at32f435_437_pwc.c.

Referenced by main().

◆ pwc_pvm_level_select()

void pwc_pvm_level_select ( pwc_pvm_voltage_type pvm_voltage )

select the voltage threshold detected by the power voltage detector.

Parameters
pvm_voltage select pwc pvm voltage this parameter can be one of the following values:
  • PWC_PVM_VOLTAGE_2V3
  • PWC_PVM_VOLTAGE_2V4
  • PWC_PVM_VOLTAGE_2V5
  • PWC_PVM_VOLTAGE_2V6
  • PWC_PVM_VOLTAGE_2V7
  • PWC_PVM_VOLTAGE_2V8
  • PWC_PVM_VOLTAGE_2V9
Return values
none

Definition at line 79 of file at32f435_437_pwc.c.

Referenced by main().

◆ pwc_reset()

void pwc_reset ( void )

deinitialize the pwc peripheral registers to their default reset values.

Parameters
none
Return values
none

Definition at line 49 of file at32f435_437_pwc.c.

◆ pwc_sleep_mode_enter()

void pwc_sleep_mode_enter ( pwc_sleep_enter_type pwc_sleep_enter )

enter pwc sleep mode

Parameters
sleep_mode_enter choose the instruction to enter sleep mode. this parameter can be one of the following values:
  • PWC_SLEEP_ENTER_WFI
  • PWC_SLEEP_ENTER_WFE
Return values
none

Definition at line 167 of file at32f435_437_pwc.c.

Referenced by main().

◆ pwc_standby_mode_enter()

void pwc_standby_mode_enter ( void )

enter pwc standby mode

Parameters
none
Return values
none

Definition at line 224 of file at32f435_437_pwc.c.

Referenced by main().

◆ pwc_voltage_regulate_set()

void pwc_voltage_regulate_set ( pwc_regulator_type pwc_regulator )

regulate low power consumption in the deep sleep mode

Parameters
pwc_regulator set the regulator state. this parameter can be one of the following values:
  • PWC_REGULATOR_ON
  • PWC_REGULATOR_LOW_POWER
Return values
none

Definition at line 214 of file at32f435_437_pwc.c.

Referenced by emac_wake_on_lan_init(), and main().

◆ pwc_wakeup_pin_enable()

void pwc_wakeup_pin_enable | ( | uint32_t | pin_num,
 |  | confirm_state | new_state
 | ) |  |

enable or disable pwc standby wakeup pin

Parameters
pin_num choose the wakeup pin. this parameter can be be any combination of the following values:
  • PWC_WAKEUP_PIN_1
  • PWC_WAKEUP_PIN_2
new_state new state of the standby wakeup pin. this parameter can be one of the following values:
  • TRUE <wakeup pin is used for wake up cpu from standby mode>
  • FALSE <wakeup pin is used for general purpose I/O>
Return values
none

Definition at line 107 of file at32f435_437_pwc.c.

Referenced by main().


AT32F435/437 Firmwary Library: QSPI

Modules | Macros
QSPI
AT32F435_437_periph_driver

QSPI driver modules. More...

Modules

QSPI_flags_definition
qspi flag
QSPI_exported_types
QSPI_exported_functions
QSPI_private_functions

Macros

#define | QSPI1 ((qspi_type*)QSPI1_REG_BASE)
#define | QSPI2 ((qspi_type*)QSPI2_REG_BASE)

Detailed Description

QSPI driver modules.

Macro Definition Documentation

◆ QSPI1

#define QSPI1 ((qspi_type*)QSPI1_REG_BASE)

Definition at line 512 of file at32f435_437_qspi.h.

◆ QSPI2

#define QSPI2 ((qspi_type*)QSPI2_REG_BASE)

Definition at line 513 of file at32f435_437_qspi.h.


AT32F435/437 Firmwary Library: QSPI_flags_definition

Macros
QSPI_flags_definition
AT32F435_437_periph_driver » QSPI

qspi flag More...

Macros

#define | QSPI_CMDSTS_FLAG ((uint32_t)0x00000001)
#define | QSPI_RXFIFORDY_FLAG ((uint32_t)0x00000002)
#define | QSPI_TXFIFORDY_FLAG ((uint32_t)0x00000004)

Detailed Description

qspi flag

Macro Definition Documentation

◆ QSPI_CMDSTS_FLAG

#define QSPI_CMDSTS_FLAG ((uint32_t)0x00000001)

qspi command complete status flag

Definition at line 52 of file at32f435_437_qspi.h.

◆ QSPI_RXFIFORDY_FLAG

#define QSPI_RXFIFORDY_FLAG ((uint32_t)0x00000002)

qspi rxfifo ready status flag

Definition at line 53 of file at32f435_437_qspi.h.

◆ QSPI_TXFIFORDY_FLAG

#define QSPI_TXFIFORDY_FLAG ((uint32_t)0x00000004)

qspi txfifo ready status flag

Definition at line 54 of file at32f435_437_qspi.h.


AT32F435/437 Firmwary Library: QSPI_exported_types

Data Structures | Enumerations
QSPI_exported_types
AT32F435_437_periph_driver » QSPI

Data Structures

struct | qspi_cmd_type
qspi cmd type More...
struct | qspi_xip_type
qspi xip type More...
struct | qspi_type
type define qspi register all More...

Enumerations

enum | qspi_xip_read_sel_type { QSPI_XIPR_SEL_MODED = 0x00 , QSPI_XIPR_SEL_MODET = 0x01 }
qspi xip read access mode type More...
enum | qspi_xip_write_sel_type { QSPI_XIPW_SEL_MODED = 0x00 , QSPI_XIPW_SEL_MODET = 0x01 }
qspi xip write access mode type More...
enum qspi_busy_pos_type {
QSPI_BUSY_OFFSET_0 = 0x00 , QSPI_BUSY_OFFSET_1 = 0x01 , QSPI_BUSY_OFFSET_2 = 0x02 , QSPI_BUSY_OFFSET_3 = 0x03 ,
QSPI_BUSY_OFFSET_4 = 0x04 , QSPI_BUSY_OFFSET_5 = 0x05 , QSPI_BUSY_OFFSET_6 = 0x06 , QSPI_BUSY_OFFSET_7 = 0x07
}
qspi busy bit offset position in status register type More...
enum | qspi_read_status_conf_type { QSPI_RSTSC_HW_AUTO = 0x00 , QSPI_RSTSC_SW_ONCE = 0x01 }
qspi read status configure type More...
enum qspi_operate_mode_type {
QSPI_OPERATE_MODE_111 = 0x00 , QSPI_OPERATE_MODE_112 = 0x01 , QSPI_OPERATE_MODE_114 = 0x02 , QSPI_OPERATE_MODE_122 = 0x03 ,
QSPI_OPERATE_MODE_144 = 0x04 , QSPI_OPERATE_MODE_222 = 0x05 , QSPI_OPERATE_MODE_444 = 0x06
}
qspi operate mode type More...
enum qspi_clk_div_type {
QSPI_CLK_DIV_2 = 0x00 , QSPI_CLK_DIV_4 = 0x01 , QSPI_CLK_DIV_6 = 0x02 , QSPI_CLK_DIV_8 = 0x03 ,
QSPI_CLK_DIV_3 = 0x04 , QSPI_CLK_DIV_5 = 0x05 , QSPI_CLK_DIV_10 = 0x06 , QSPI_CLK_DIV_12 = 0x07
}
qspi clock division type More...
enum qspi_cmd_adrlen_type {
QSPI_CMD_ADRLEN_0_BYTE = 0x00 , QSPI_CMD_ADRLEN_1_BYTE = 0x01 , QSPI_CMD_ADRLEN_2_BYTE = 0x02 , QSPI_CMD_ADRLEN_3_BYTE = 0x03 ,
QSPI_CMD_ADRLEN_4_BYTE = 0x04
}
qspi command port address length type More...
enum | qspi_cmd_inslen_type { QSPI_CMD_INSLEN_0_BYTE = 0x00 , QSPI_CMD_INSLEN_1_BYTE = 0x01 , QSPI_CMD_INSLEN_2_BYTE = 0x02 }
qspi command port instruction length type More...
enum | qspi_xip_addrlen_type { QSPI_XIP_ADDRLEN_3_BYTE = 0x00 , QSPI_XIP_ADDRLEN_4_BYTE = 0x01 }
qspi xip r/w address length type More...
enum | qspi_clk_mode_type { QSPI_SCK_MODE_0 = 0x00 , QSPI_SCK_MODE_3 = 0x01 }
qspi sckout mode type More...
enum | qspi_dma_fifo_thod_type { QSPI_DMA_FIFO_THOD_WORD08 = 0x00 , QSPI_DMA_FIFO_THOD_WORD16 = 0x01 , QSPI_DMA_FIFO_THOD_WORD32 = 0x02 }
qspi dma tx/rx fifo threshold type More...

Detailed Description

Enumeration Type Documentation

◆ qspi_busy_pos_type

enum qspi_busy_pos_type

qspi busy bit offset position in status register type

Enumerator
QSPI_BUSY_OFFSET_0 | qspi busy bit offset position 0
QSPI_BUSY_OFFSET_1 | qspi busy bit offset position 1
QSPI_BUSY_OFFSET_2 | qspi busy bit offset position 2
QSPI_BUSY_OFFSET_3 | qspi busy bit offset position 3
QSPI_BUSY_OFFSET_4 | qspi busy bit offset position 4
QSPI_BUSY_OFFSET_5 | qspi busy bit offset position 5
QSPI_BUSY_OFFSET_6 | qspi busy bit offset position 6
QSPI_BUSY_OFFSET_7 | qspi busy bit offset position 7

Definition at line 85 of file at32f435_437_qspi.h.

◆ qspi_clk_div_type

enum qspi_clk_div_type

qspi clock division type

Enumerator
QSPI_CLK_DIV_2 | qspi clk divide by 2
QSPI_CLK_DIV_4 | qspi clk divide by 4
QSPI_CLK_DIV_6 | qspi clk divide by 6
QSPI_CLK_DIV_8 | qspi clk divide by 8
QSPI_CLK_DIV_3 | qspi clk divide by 3
QSPI_CLK_DIV_5 | qspi clk divide by 5
QSPI_CLK_DIV_10 | qspi clk divide by 10
QSPI_CLK_DIV_12 | qspi clk divide by 12

Definition at line 123 of file at32f435_437_qspi.h.

◆ qspi_clk_mode_type

enum qspi_clk_mode_type

qspi sckout mode type

Enumerator
QSPI_SCK_MODE_0 | qspi sck mode 0
QSPI_SCK_MODE_3 | qspi sck mode 3

Definition at line 169 of file at32f435_437_qspi.h.

◆ qspi_cmd_adrlen_type

enum qspi_cmd_adrlen_type

qspi command port address length type

Enumerator
QSPI_CMD_ADRLEN_0_BYTE | qspi no address
QSPI_CMD_ADRLEN_1_BYTE | qspi address length 1 byte
QSPI_CMD_ADRLEN_2_BYTE | qspi address length 2 byte
QSPI_CMD_ADRLEN_3_BYTE | qspi address length 3 byte
QSPI_CMD_ADRLEN_4_BYTE | qspi address length 4 byte

Definition at line 138 of file at32f435_437_qspi.h.

◆ qspi_cmd_inslen_type

enum qspi_cmd_inslen_type

qspi command port instruction length type

Enumerator
QSPI_CMD_INSLEN_0_BYTE | qspi no instruction code
QSPI_CMD_INSLEN_1_BYTE | qspi instruction code 1 byte
QSPI_CMD_INSLEN_2_BYTE | qspi instruction code 2 byte(repeat)

Definition at line 150 of file at32f435_437_qspi.h.

◆ qspi_dma_fifo_thod_type

enum qspi_dma_fifo_thod_type

qspi dma tx/rx fifo threshold type

Enumerator
QSPI_DMA_FIFO_THOD_WORD08 | qspi dma fifo threshold 8 words
QSPI_DMA_FIFO_THOD_WORD16 | qspi dma fifo threshold 16 words
QSPI_DMA_FIFO_THOD_WORD32 | qspi dma fifo threshold 32 words

Definition at line 178 of file at32f435_437_qspi.h.

◆ qspi_operate_mode_type

enum qspi_operate_mode_type

qspi operate mode type

Enumerator
QSPI_OPERATE_MODE_111 | qspi serial mode
QSPI_OPERATE_MODE_112 | qspi dual mode
QSPI_OPERATE_MODE_114 | qspi quad mode
QSPI_OPERATE_MODE_122 | qspi dual i/o mode
QSPI_OPERATE_MODE_144 | qspi quad i/o mode
QSPI_OPERATE_MODE_222 | qspi instruction 2-bit mode
QSPI_OPERATE_MODE_444 | qspi instruction 4-bit mode(qpi)

Definition at line 109 of file at32f435_437_qspi.h.

◆ qspi_read_status_conf_type

enum qspi_read_status_conf_type

qspi read status configure type

Enumerator
QSPI_RSTSC_HW_AUTO | qspi read status by hardware
QSPI_RSTSC_SW_ONCE | qspi read status by software

Definition at line 100 of file at32f435_437_qspi.h.

◆ qspi_xip_addrlen_type

enum qspi_xip_addrlen_type

qspi xip r/w address length type

Enumerator
QSPI_XIP_ADDRLEN_3_BYTE | qspi xip address length 3 byte
QSPI_XIP_ADDRLEN_4_BYTE | qspi xip address length 4 byte

Definition at line 160 of file at32f435_437_qspi.h.

◆ qspi_xip_read_sel_type

enum qspi_xip_read_sel_type

qspi xip read access mode type

Enumerator
QSPI_XIPR_SEL_MODED | qspi xip read select mode d
QSPI_XIPR_SEL_MODET | qspi xip read select mode t

Definition at line 67 of file at32f435_437_qspi.h.

◆ qspi_xip_write_sel_type

enum qspi_xip_write_sel_type

qspi xip write access mode type

Enumerator
QSPI_XIPW_SEL_MODED | qspi xip write select mode d
QSPI_XIPW_SEL_MODET | qspi xip write select mode t

Definition at line 76 of file at32f435_437_qspi.h.


AT32F435/437 Firmwary Library: qspi_cmd_type Struct Reference

Data Fields
qspi_cmd_type Struct Reference
AT32F435_437_periph_driver » QSPI » QSPI_exported_types

qspi cmd type More...

#include <at32f435_437_qspi.h>

Data Fields

confirm_state pe_mode_enable
uint8_t | pe_mode_operate_code
uint8_t | instruction_code
qspi_cmd_inslen_type instruction_length
uint32_t | address_code
qspi_cmd_adrlen_type address_length
uint32_t | data_counter
uint8_t | second_dummy_cycle_num
qspi_operate_mode_type operation_mode
qspi_read_status_conf_type read_status_config
confirm_state read_status_enable
confirm_state write_data_enable

Detailed Description

qspi cmd type

Definition at line 188 of file at32f435_437_qspi.h.

Field Documentation

◆ address_code

uint32_t qspi_cmd_type::address_code

address code

Definition at line 194 of file at32f435_437_qspi.h.

Referenced by cmd_rst_ly68l6400_config(), cmd_rsten_ly68l6400_config(), esmt32m_cmd_erase_config(), esmt32m_cmd_qpien_config(), esmt32m_cmd_rdsr_config(), esmt32m_cmd_read_config(), esmt32m_cmd_read_pem_begin_config(), esmt32m_cmd_read_pem_end_config(), esmt32m_cmd_read_pem_keep_config(), esmt32m_cmd_rst_config(), esmt32m_cmd_rsten_config(), esmt32m_cmd_rstqpi_config(), esmt32m_cmd_wren_config(), esmt32m_cmd_write_config(), and qspi_cmd_operation_kick().

◆ address_length

qspi_cmd_adrlen_type qspi_cmd_type::address_length

address legnth

Definition at line 195 of file at32f435_437_qspi.h.

Referenced by cmd_rst_ly68l6400_config(), cmd_rsten_ly68l6400_config(), esmt32m_cmd_erase_config(), esmt32m_cmd_qpien_config(), esmt32m_cmd_rdsr_config(), esmt32m_cmd_read_config(), esmt32m_cmd_read_pem_begin_config(), esmt32m_cmd_read_pem_end_config(), esmt32m_cmd_read_pem_keep_config(), esmt32m_cmd_rst_config(), esmt32m_cmd_rsten_config(), esmt32m_cmd_rstqpi_config(), esmt32m_cmd_wren_config(), esmt32m_cmd_write_config(), and qspi_cmd_operation_kick().

◆ data_counter

uint32_t qspi_cmd_type::data_counter

read/write data counter

Definition at line 196 of file at32f435_437_qspi.h.

Referenced by cmd_rst_ly68l6400_config(), cmd_rsten_ly68l6400_config(), esmt32m_cmd_erase_config(), esmt32m_cmd_qpien_config(), esmt32m_cmd_rdsr_config(), esmt32m_cmd_read_config(), esmt32m_cmd_read_pem_begin_config(), esmt32m_cmd_read_pem_end_config(), esmt32m_cmd_read_pem_keep_config(), esmt32m_cmd_rst_config(), esmt32m_cmd_rsten_config(), esmt32m_cmd_rstqpi_config(), esmt32m_cmd_wren_config(), esmt32m_cmd_write_config(), and qspi_cmd_operation_kick().

◆ instruction_code

uint8_t qspi_cmd_type::instruction_code

instruction code

Definition at line 192 of file at32f435_437_qspi.h.

Referenced by cmd_rst_ly68l6400_config(), cmd_rsten_ly68l6400_config(), esmt32m_cmd_erase_config(), esmt32m_cmd_qpien_config(), esmt32m_cmd_rdsr_config(), esmt32m_cmd_read_config(), esmt32m_cmd_read_pem_begin_config(), esmt32m_cmd_read_pem_end_config(), esmt32m_cmd_read_pem_keep_config(), esmt32m_cmd_rst_config(), esmt32m_cmd_rsten_config(), esmt32m_cmd_rstqpi_config(), esmt32m_cmd_wren_config(), esmt32m_cmd_write_config(), and qspi_cmd_operation_kick().

◆ instruction_length

qspi_cmd_inslen_type qspi_cmd_type::instruction_length

instruction code length

Definition at line 193 of file at32f435_437_qspi.h.

Referenced by cmd_rst_ly68l6400_config(), cmd_rsten_ly68l6400_config(), esmt32m_cmd_erase_config(), esmt32m_cmd_qpien_config(), esmt32m_cmd_rdsr_config(), esmt32m_cmd_read_config(), esmt32m_cmd_read_pem_begin_config(), esmt32m_cmd_read_pem_end_config(), esmt32m_cmd_read_pem_keep_config(), esmt32m_cmd_rst_config(), esmt32m_cmd_rsten_config(), esmt32m_cmd_rstqpi_config(), esmt32m_cmd_wren_config(), esmt32m_cmd_write_config(), and qspi_cmd_operation_kick().

◆ operation_mode

qspi_operate_mode_type qspi_cmd_type::operation_mode

operation mode

Definition at line 198 of file at32f435_437_qspi.h.

Referenced by cmd_rst_ly68l6400_config(), cmd_rsten_ly68l6400_config(), esmt32m_cmd_erase_config(), esmt32m_cmd_qpien_config(), esmt32m_cmd_rdsr_config(), esmt32m_cmd_read_config(), esmt32m_cmd_read_pem_begin_config(), esmt32m_cmd_read_pem_end_config(), esmt32m_cmd_read_pem_keep_config(), esmt32m_cmd_rst_config(), esmt32m_cmd_rsten_config(), esmt32m_cmd_rstqpi_config(), esmt32m_cmd_wren_config(), esmt32m_cmd_write_config(), and qspi_cmd_operation_kick().

◆ pe_mode_enable

confirm_state qspi_cmd_type::pe_mode_enable

perfornance enhance mode enable

Definition at line 190 of file at32f435_437_qspi.h.

Referenced by cmd_rst_ly68l6400_config(), cmd_rsten_ly68l6400_config(), esmt32m_cmd_erase_config(), esmt32m_cmd_qpien_config(), esmt32m_cmd_rdsr_config(), esmt32m_cmd_read_config(), esmt32m_cmd_read_pem_begin_config(), esmt32m_cmd_read_pem_end_config(), esmt32m_cmd_read_pem_keep_config(), esmt32m_cmd_rst_config(), esmt32m_cmd_rsten_config(), esmt32m_cmd_rstqpi_config(), esmt32m_cmd_wren_config(), esmt32m_cmd_write_config(), and qspi_cmd_operation_kick().

◆ pe_mode_operate_code

uint8_t qspi_cmd_type::pe_mode_operate_code

performance enhance mode operate code

Definition at line 191 of file at32f435_437_qspi.h.

Referenced by cmd_rst_ly68l6400_config(), cmd_rsten_ly68l6400_config(), esmt32m_cmd_erase_config(), esmt32m_cmd_qpien_config(), esmt32m_cmd_rdsr_config(), esmt32m_cmd_read_config(), esmt32m_cmd_read_pem_begin_config(), esmt32m_cmd_read_pem_end_config(), esmt32m_cmd_read_pem_keep_config(), esmt32m_cmd_rst_config(), esmt32m_cmd_rsten_config(), esmt32m_cmd_rstqpi_config(), esmt32m_cmd_wren_config(), esmt32m_cmd_write_config(), and qspi_cmd_operation_kick().

◆ read_status_config

qspi_read_status_conf_type qspi_cmd_type::read_status_config

config to read status

Definition at line 199 of file at32f435_437_qspi.h.

Referenced by cmd_rst_ly68l6400_config(), cmd_rsten_ly68l6400_config(), esmt32m_cmd_erase_config(), esmt32m_cmd_qpien_config(), esmt32m_cmd_rdsr_config(), esmt32m_cmd_read_config(), esmt32m_cmd_read_pem_begin_config(), esmt32m_cmd_read_pem_end_config(), esmt32m_cmd_read_pem_keep_config(), esmt32m_cmd_rst_config(), esmt32m_cmd_rsten_config(), esmt32m_cmd_rstqpi_config(), esmt32m_cmd_wren_config(), esmt32m_cmd_write_config(), and qspi_cmd_operation_kick().

◆ read_status_enable

confirm_state qspi_cmd_type::read_status_enable

config to read status

Definition at line 200 of file at32f435_437_qspi.h.

Referenced by cmd_rst_ly68l6400_config(), cmd_rsten_ly68l6400_config(), esmt32m_cmd_erase_config(), esmt32m_cmd_qpien_config(), esmt32m_cmd_rdsr_config(), esmt32m_cmd_read_config(), esmt32m_cmd_read_pem_begin_config(), esmt32m_cmd_read_pem_end_config(), esmt32m_cmd_read_pem_keep_config(), esmt32m_cmd_rst_config(), esmt32m_cmd_rsten_config(), esmt32m_cmd_rstqpi_config(), esmt32m_cmd_wren_config(), esmt32m_cmd_write_config(), and qspi_cmd_operation_kick().

◆ second_dummy_cycle_num

uint8_t qspi_cmd_type::second_dummy_cycle_num

number of second dummy state cycle 0~32

Definition at line 197 of file at32f435_437_qspi.h.

Referenced by cmd_rst_ly68l6400_config(), cmd_rsten_ly68l6400_config(), esmt32m_cmd_erase_config(), esmt32m_cmd_qpien_config(), esmt32m_cmd_rdsr_config(), esmt32m_cmd_read_config(), esmt32m_cmd_read_pem_begin_config(), esmt32m_cmd_read_pem_end_config(), esmt32m_cmd_read_pem_keep_config(), esmt32m_cmd_rst_config(), esmt32m_cmd_rsten_config(), esmt32m_cmd_rstqpi_config(), esmt32m_cmd_wren_config(), esmt32m_cmd_write_config(), and qspi_cmd_operation_kick().

◆ write_data_enable

confirm_state qspi_cmd_type::write_data_enable

enable to write data

Definition at line 201 of file at32f435_437_qspi.h.

Referenced by cmd_rst_ly68l6400_config(), cmd_rsten_ly68l6400_config(), esmt32m_cmd_erase_config(), esmt32m_cmd_qpien_config(), esmt32m_cmd_rdsr_config(), esmt32m_cmd_read_config(), esmt32m_cmd_read_pem_begin_config(), esmt32m_cmd_read_pem_end_config(), esmt32m_cmd_read_pem_keep_config(), esmt32m_cmd_rst_config(), esmt32m_cmd_rsten_config(), esmt32m_cmd_rstqpi_config(), esmt32m_cmd_wren_config(), esmt32m_cmd_write_config(), and qspi_cmd_operation_kick().

The documentation for this struct was generated from the following file:
  • at32f435_437_qspi.h


AT32F435/437 Firmwary Library: qspi_xip_type Struct Reference

Data Fields
qspi_xip_type Struct Reference
AT32F435_437_periph_driver » QSPI » QSPI_exported_types

qspi xip type More...

#include <at32f435_437_qspi.h>

Data Fields

uint8_t | read_instruction_code
qspi_xip_addrlen_type read_address_length
qspi_operate_mode_type read_operation_mode
uint8_t | read_second_dummy_cycle_num
uint8_t | write_instruction_code
qspi_xip_addrlen_type write_address_length
qspi_operate_mode_type write_operation_mode
uint8_t | write_second_dummy_cycle_num
qspi_xip_write_sel_type write_select_mode
uint8_t | write_time_counter
uint8_t | write_data_counter
qspi_xip_read_sel_type read_select_mode
uint8_t | read_time_counter
uint8_t | read_data_counter

Detailed Description

qspi xip type

Definition at line 207 of file at32f435_437_qspi.h.

Field Documentation

◆ read_address_length

qspi_xip_addrlen_type qspi_xip_type::read_address_length

read address legnth

Definition at line 210 of file at32f435_437_qspi.h.

Referenced by custom_xip_enable_config(), qspi_xip_init(), and xip_init_ly68l6400_config().

◆ read_data_counter

uint8_t qspi_xip_type::read_data_counter

read count for mode d

Definition at line 222 of file at32f435_437_qspi.h.

Referenced by custom_xip_enable_config(), qspi_xip_init(), and xip_init_ly68l6400_config().

◆ read_instruction_code

uint8_t qspi_xip_type::read_instruction_code

read instruction code

Definition at line 209 of file at32f435_437_qspi.h.

Referenced by custom_xip_enable_config(), qspi_xip_init(), and xip_init_ly68l6400_config().

◆ read_operation_mode

qspi_operate_mode_type qspi_xip_type::read_operation_mode

read operation mode

Definition at line 211 of file at32f435_437_qspi.h.

Referenced by custom_xip_enable_config(), qspi_xip_init(), and xip_init_ly68l6400_config().

◆ read_second_dummy_cycle_num

uint8_t qspi_xip_type::read_second_dummy_cycle_num

read number of second dummy state cycle 0~32

Definition at line 212 of file at32f435_437_qspi.h.

Referenced by custom_xip_enable_config(), qspi_xip_init(), and xip_init_ly68l6400_config().

◆ read_select_mode

qspi_xip_read_sel_type qspi_xip_type::read_select_mode

read mode d or mode t selection

Definition at line 220 of file at32f435_437_qspi.h.

Referenced by custom_xip_enable_config(), qspi_xip_init(), and xip_init_ly68l6400_config().

◆ read_time_counter

uint8_t qspi_xip_type::read_time_counter

read count for mode t

Definition at line 221 of file at32f435_437_qspi.h.

Referenced by custom_xip_enable_config(), qspi_xip_init(), and xip_init_ly68l6400_config().

◆ write_address_length

qspi_xip_addrlen_type qspi_xip_type::write_address_length

write address legnth

Definition at line 214 of file at32f435_437_qspi.h.

Referenced by custom_xip_enable_config(), qspi_xip_init(), and xip_init_ly68l6400_config().

◆ write_data_counter

uint8_t qspi_xip_type::write_data_counter

write count for mode d

Definition at line 219 of file at32f435_437_qspi.h.

Referenced by custom_xip_enable_config(), qspi_xip_init(), and xip_init_ly68l6400_config().

◆ write_instruction_code

uint8_t qspi_xip_type::write_instruction_code

write instruction code

Definition at line 213 of file at32f435_437_qspi.h.

Referenced by custom_xip_enable_config(), qspi_xip_init(), and xip_init_ly68l6400_config().

◆ write_operation_mode

qspi_operate_mode_type qspi_xip_type::write_operation_mode

write operation mode

Definition at line 215 of file at32f435_437_qspi.h.

Referenced by custom_xip_enable_config(), qspi_xip_init(), and xip_init_ly68l6400_config().

◆ write_second_dummy_cycle_num

uint8_t qspi_xip_type::write_second_dummy_cycle_num

write number of second dummy state cycle 0~32

Definition at line 216 of file at32f435_437_qspi.h.

Referenced by custom_xip_enable_config(), qspi_xip_init(), and xip_init_ly68l6400_config().

◆ write_select_mode

qspi_xip_write_sel_type qspi_xip_type::write_select_mode

write mode d or mode t selection

Definition at line 217 of file at32f435_437_qspi.h.

Referenced by custom_xip_enable_config(), qspi_xip_init(), and xip_init_ly68l6400_config().

◆ write_time_counter

uint8_t qspi_xip_type::write_time_counter

write count for mode t

Definition at line 218 of file at32f435_437_qspi.h.

Referenced by custom_xip_enable_config(), qspi_xip_init(), and xip_init_ly68l6400_config().

The documentation for this struct was generated from the following file:
  • at32f435_437_qspi.h


AT32F435/437 Firmwary Library: qspi_type Struct Reference

Data Fields
qspi_type Struct Reference
AT32F435_437_periph_driver » QSPI » QSPI_exported_types

type define qspi register all More...

#include <at32f435_437_qspi.h>

Data Fields

union {
__IO uint32_t cmd_w0
struct {
__IO uint32_t spiadr: 32
} cmd_w0_bit
};
qspi cmd_w0 register, offset:0x00 More...
union {
__IO uint32_t cmd_w1
struct {
__IO uint32_t adrlen: 3
__IO uint32_t reserved1: 13
__IO uint32_t dum2: 8
__IO uint32_t inslen: 2
__IO uint32_t reserved2: 2
__IO uint32_t pemen: 1
__IO uint32_t reserved3: 3
} cmd_w1_bit
};
qspi cmd_w1 register, offset:0x04 More...
union {
__IO uint32_t cmd_w2
struct {
__IO uint32_t dcnt: 32
} cmd_w2_bit
};
qspi cmd_w2 register, offset:0x08 More...
union {
__IO uint32_t cmd_w3
struct {
__IO uint32_t reserved1: 1
__IO uint32_t wen: 1
__IO uint32_t rstsen: 1
__IO uint32_t rstsc: 1
__IO uint32_t reserved2: 1
__IO uint32_t opmode: 3
__IO uint32_t reserved3: 8
__IO uint32_t pemopc: 8
__IO uint32_t insc: 8
} cmd_w3_bit
};
qspi cmd_w3 register, offset:0x0C More...
union {
__IO uint32_t ctrl
struct {
__IO uint32_t clkdiv: 3
__IO uint32_t reserved1: 1
__IO uint32_t sckmode: 1
__IO uint32_t reserved2: 2
__IO uint32_t xipidle: 1
__IO uint32_t abort: 1
__IO uint32_t reserved3: 7
__IO uint32_t busy: 3
__IO uint32_t xiprcmdf: 1
__IO uint32_t xipsel: 1
__IO uint32_t keyen: 1
__IO uint32_t reserved4: 10
} ctrl_bit
};
qspi ctrl register, offset:0x10 More...
union {
__IO uint32_t actr
struct {
__IO uint32_t csdly: 4
__IO uint32_t reserved1: 28
} actr_bit
};
qspi actr register, offset:0x14 More...
union {
__IO uint32_t fifosts
struct {
__IO uint32_t txfifordy: 1
__IO uint32_t rxfifordy: 1
__IO uint32_t reserved1: 30
} fifosts_bit
};
qspi fifosts register, offset:0x18 More...
union {
__IO uint32_t ctrl2
struct {
__IO uint32_t dmaen: 1
__IO uint32_t cmdie: 1
__IO uint32_t reserved1: 6
__IO uint32_t txfifo_thod: 2
__IO uint32_t reserved2: 2
__IO uint32_t rxfifo_thod: 2
__IO uint32_t reserved3: 18
} ctrl2_bit
};
qspi ctrl2 register, offset:0x20 More...
union {
__IO uint32_t cmdsts
struct {
__IO uint32_t cmdsts: 1
__IO uint32_t reserved1: 31
} cmdsts_bit
};
qspi cmdsts register, offset:0x24 More...
union {
__IO uint32_t rsts
struct {
__IO uint32_t spists: 8
__IO uint32_t reserved1: 24
} rsts_bit
};
qspi rsts register, offset:0x28 More...
union {
__IO uint32_t fsize
struct {
__IO uint32_t spifsize: 32
} fsize_bit
};
qspi fsize register, offset:0x2C More...
union {
__IO uint32_t xip_cmd_w0
struct {
__IO uint32_t xipr_dum2: 8
__IO uint32_t xipr_opmode: 3
__IO uint32_t xipr_adrlen: 1
__IO uint32_t xipr_insc: 8
__IO uint32_t reserved1: 12
} xip_cmd_w0_bit
};
qspi xip_cmd_w0 register, offset:0x30 More...
union {
__IO uint32_t xip_cmd_w1
struct {
__IO uint32_t xipr_dum2: 8
__IO uint32_t xipr_opmode: 3
__IO uint32_t xipr_adrlen: 1
__IO uint32_t xipr_insc: 8
__IO uint32_t reserved1: 12
} xip_cmd_w1_bit
};
qspi xip_cmd_w1 register, offset:0x34 More...
union {
__IO uint32_t xip_cmd_w2
struct {
__IO uint32_t xipr_dcnt: 6
__IO uint32_t reserved1: 2
__IO uint32_t xipr_tcnt: 7
__IO uint32_t xipr_sel: 1
__IO uint32_t xipw_dcnt: 6
__IO uint32_t reserved2: 2
__IO uint32_t xipw_tcnt: 7
__IO uint32_t xipw_sel: 1
} xip_cmd_w2_bit
};
qspi xip_cmd_w2 register, offset:0x38 More...
union {
__IO uint32_t xip_cmd_w3
struct {
__IO uint32_t bypassc: 1
__IO uint32_t reserved1: 2
__IO uint32_t csts: 1
__IO uint32_t reserved2: 28
} xip_cmd_w3_bit
};
qspi xip_cmd_w3 register, offset:0x3C More...
union {
__IO uint32_t rev
struct {
__IO uint32_t rev: 32
} rev_bit
};
qspi rev register, offset:0x50 More...
union {
__IO uint8_t dt_u8
__IO uint16_t dt_u16
__IO uint32_t dt
struct {
__IO uint32_t dt: 32
} dt_bit
};
qspi dt register, offset:0x100 More...

Detailed Description

type define qspi register all

Definition at line 228 of file at32f435_437_qspi.h.

Field Documentation

◆

union { ... } qspi_type::@905

qspi cmd_w0 register, offset:0x00

◆

union { ... } qspi_type::@907

qspi cmd_w1 register, offset:0x04

◆

union { ... } qspi_type::@909

qspi cmd_w2 register, offset:0x08

◆

union { ... } qspi_type::@911

qspi cmd_w3 register, offset:0x0C

◆

union { ... } qspi_type::@913

qspi ctrl register, offset:0x10

◆

union { ... } qspi_type::@915

qspi actr register, offset:0x14

◆

union { ... } qspi_type::@917

qspi fifosts register, offset:0x18

◆

union { ... } qspi_type::@919

qspi ctrl2 register, offset:0x20

◆

union { ... } qspi_type::@921

qspi cmdsts register, offset:0x24

◆

union { ... } qspi_type::@923

qspi rsts register, offset:0x28

◆

union { ... } qspi_type::@925

qspi fsize register, offset:0x2C

◆

union { ... } qspi_type::@927

qspi xip_cmd_w0 register, offset:0x30

◆

union { ... } qspi_type::@929

qspi xip_cmd_w1 register, offset:0x34

◆

union { ... } qspi_type::@931

qspi xip_cmd_w2 register, offset:0x38

◆

union { ... } qspi_type::@933

qspi xip_cmd_w3 register, offset:0x3C

◆

union { ... } qspi_type::@935

qspi rev register, offset:0x50

◆

union { ... } qspi_type::@937

qspi dt register, offset:0x100

◆ abort

__IO uint32_t qspi_type::abort

Definition at line 306 of file at32f435_437_qspi.h.

Referenced by qspi_xip_enable().

◆ actr

__IO uint32_t qspi_type::actr

Definition at line 321 of file at32f435_437_qspi.h.

◆

struct { ... } qspi_type::actr_bit

◆ adrlen

__IO uint32_t qspi_type::adrlen

Definition at line 251 of file at32f435_437_qspi.h.

◆ busy

__IO uint32_t qspi_type::busy

Definition at line 308 of file at32f435_437_qspi.h.

Referenced by qspi_busy_config().

◆ bypassc

__IO uint32_t qspi_type::bypassc

Definition at line 463 of file at32f435_437_qspi.h.

Referenced by qspi_xip_cache_bypass_set().

◆ clkdiv

__IO uint32_t qspi_type::clkdiv

Definition at line 301 of file at32f435_437_qspi.h.

Referenced by qspi_clk_division_set().

◆ cmd_w0

__IO uint32_t qspi_type::cmd_w0

Definition at line 235 of file at32f435_437_qspi.h.

Referenced by qspi_cmd_operation_kick().

◆

struct { ... } qspi_type::cmd_w0_bit

◆ cmd_w1

__IO uint32_t qspi_type::cmd_w1

Definition at line 248 of file at32f435_437_qspi.h.

Referenced by qspi_cmd_operation_kick().

◆

struct { ... } qspi_type::cmd_w1_bit

◆ cmd_w2

__IO uint32_t qspi_type::cmd_w2

Definition at line 266 of file at32f435_437_qspi.h.

Referenced by qspi_cmd_operation_kick().

◆

struct { ... } qspi_type::cmd_w2_bit

◆ cmd_w3

__IO uint32_t qspi_type::cmd_w3

Definition at line 278 of file at32f435_437_qspi.h.

Referenced by qspi_cmd_operation_kick().

◆

struct { ... } qspi_type::cmd_w3_bit

◆ cmdie

__IO uint32_t qspi_type::cmdie

Definition at line 357 of file at32f435_437_qspi.h.

Referenced by qspi_interrupt_enable().

◆ cmdsts

__IO uint32_t qspi_type::cmdsts

Definition at line 371 of file at32f435_437_qspi.h.

Referenced by qspi_flag_clear(), and qspi_flag_get().

◆

struct { ... } qspi_type::cmdsts_bit

Referenced by qspi_flag_get().

◆ csdly

__IO uint32_t qspi_type::csdly

Definition at line 324 of file at32f435_437_qspi.h.

◆ csts

__IO uint32_t qspi_type::csts

Definition at line 465 of file at32f435_437_qspi.h.

Referenced by qspi_xip_enable().

◆ ctrl

__IO uint32_t qspi_type::ctrl

Definition at line 298 of file at32f435_437_qspi.h.

◆ ctrl2

__IO uint32_t qspi_type::ctrl2

Definition at line 353 of file at32f435_437_qspi.h.

◆

struct { ... } qspi_type::ctrl2_bit

Referenced by qspi_dma_enable(), qspi_dma_rx_threshold_set(), qspi_dma_tx_threshold_set(), and qspi_interrupt_enable().

◆

struct { ... } qspi_type::ctrl_bit

Referenced by qspi_busy_config(), qspi_clk_division_set(), qspi_encryption_enable(), qspi_sck_mode_set(), and qspi_xip_enable().

◆ dcnt

__IO uint32_t qspi_type::dcnt

Definition at line 269 of file at32f435_437_qspi.h.

◆ dmaen

__IO uint32_t qspi_type::dmaen

Definition at line 356 of file at32f435_437_qspi.h.

Referenced by qspi_dma_enable().

◆ dt

__IO uint32_t qspi_type::dt

Definition at line 499 of file at32f435_437_qspi.h.

Referenced by qspi_word_read(), and qspi_word_write().

◆

struct { ... } qspi_type::dt_bit

◆ dt_u16

__IO uint16_t qspi_type::dt_u16

Definition at line 498 of file at32f435_437_qspi.h.

Referenced by qspi_half_word_read(), and qspi_half_word_write().

◆ dt_u8

__IO uint8_t qspi_type::dt_u8

Definition at line 497 of file at32f435_437_qspi.h.

Referenced by qspi_byte_read(), and qspi_byte_write().

◆ dum2

__IO uint32_t qspi_type::dum2

Definition at line 253 of file at32f435_437_qspi.h.

◆ fifosts

__IO uint32_t qspi_type::fifosts

Definition at line 334 of file at32f435_437_qspi.h.

◆

struct { ... } qspi_type::fifosts_bit

Referenced by qspi_flag_get(), and qspi_xip_enable().

◆ fsize

__IO uint32_t qspi_type::fsize

Definition at line 397 of file at32f435_437_qspi.h.

◆

struct { ... } qspi_type::fsize_bit

◆ insc

__IO uint32_t qspi_type::insc

Definition at line 289 of file at32f435_437_qspi.h.

◆ inslen

__IO uint32_t qspi_type::inslen

Definition at line 254 of file at32f435_437_qspi.h.

◆ keyen

__IO uint32_t qspi_type::keyen

Definition at line 311 of file at32f435_437_qspi.h.

Referenced by qspi_encryption_enable().

◆ opmode

__IO uint32_t qspi_type::opmode

Definition at line 286 of file at32f435_437_qspi.h.

◆ pemen

__IO uint32_t qspi_type::pemen

Definition at line 256 of file at32f435_437_qspi.h.

◆ pemopc

__IO uint32_t qspi_type::pemopc

Definition at line 288 of file at32f435_437_qspi.h.

◆ reserved1

__IO uint32_t qspi_type::reserved1

qspi reserved register, offset:0x1C

Definition at line 252 of file at32f435_437_qspi.h.

◆ reserved2

__IO uint32_t qspi_type::reserved2

qspi reserved register, offset:0x40~4C

Definition at line 255 of file at32f435_437_qspi.h.

◆ reserved3

__IO uint32_t qspi_type::reserved3

qspi reserved register, offset:0x54~FC

Definition at line 257 of file at32f435_437_qspi.h.

◆ reserved4

__IO uint32_t qspi_type::reserved4

Definition at line 312 of file at32f435_437_qspi.h.

◆ rev

__IO uint32_t qspi_type::rev

Definition at line 480 of file at32f435_437_qspi.h.

◆

struct { ... } qspi_type::rev_bit

◆ rsts

__IO uint32_t qspi_type::rsts

Definition at line 384 of file at32f435_437_qspi.h.

◆

struct { ... } qspi_type::rsts_bit

◆ rstsc

__IO uint32_t qspi_type::rstsc

Definition at line 284 of file at32f435_437_qspi.h.

◆ rstsen

__IO uint32_t qspi_type::rstsen

Definition at line 283 of file at32f435_437_qspi.h.

◆ rxfifo_thod

__IO uint32_t qspi_type::rxfifo_thod

Definition at line 361 of file at32f435_437_qspi.h.

Referenced by qspi_dma_rx_threshold_set().

◆ rxfifordy

__IO uint32_t qspi_type::rxfifordy

Definition at line 338 of file at32f435_437_qspi.h.

Referenced by qspi_flag_get().

◆ sckmode

__IO uint32_t qspi_type::sckmode

Definition at line 303 of file at32f435_437_qspi.h.

Referenced by qspi_sck_mode_set().

◆ spiadr

__IO uint32_t qspi_type::spiadr

Definition at line 239 of file at32f435_437_qspi.h.

◆ spifsize

__IO uint32_t qspi_type::spifsize

Definition at line 400 of file at32f435_437_qspi.h.

◆ spists

__IO uint32_t qspi_type::spists

Definition at line 387 of file at32f435_437_qspi.h.

◆ txfifo_thod

__IO uint32_t qspi_type::txfifo_thod

Definition at line 359 of file at32f435_437_qspi.h.

Referenced by qspi_dma_tx_threshold_set().

◆ txfifordy

__IO uint32_t qspi_type::txfifordy

Definition at line 337 of file at32f435_437_qspi.h.

Referenced by qspi_flag_get(), and qspi_xip_enable().

◆ wen

__IO uint32_t qspi_type::wen

Definition at line 282 of file at32f435_437_qspi.h.

◆ xip_cmd_w0

__IO uint32_t qspi_type::xip_cmd_w0

Definition at line 409 of file at32f435_437_qspi.h.

Referenced by qspi_xip_init().

◆

struct { ... } qspi_type::xip_cmd_w0_bit

◆ xip_cmd_w1

__IO uint32_t qspi_type::xip_cmd_w1

Definition at line 425 of file at32f435_437_qspi.h.

Referenced by qspi_xip_init().

◆

struct { ... } qspi_type::xip_cmd_w1_bit

◆ xip_cmd_w2

__IO uint32_t qspi_type::xip_cmd_w2

Definition at line 441 of file at32f435_437_qspi.h.

Referenced by qspi_xip_init().

◆

struct { ... } qspi_type::xip_cmd_w2_bit

◆ xip_cmd_w3

__IO uint32_t qspi_type::xip_cmd_w3

Definition at line 460 of file at32f435_437_qspi.h.

◆

struct { ... } qspi_type::xip_cmd_w3_bit

Referenced by qspi_xip_cache_bypass_set(), and qspi_xip_enable().

◆ xipidle

__IO uint32_t qspi_type::xipidle

Definition at line 305 of file at32f435_437_qspi.h.

◆ xipr_adrlen

__IO uint32_t qspi_type::xipr_adrlen

Definition at line 414 of file at32f435_437_qspi.h.

◆ xipr_dcnt

__IO uint32_t qspi_type::xipr_dcnt

Definition at line 444 of file at32f435_437_qspi.h.

◆ xipr_dum2

__IO uint32_t qspi_type::xipr_dum2

Definition at line 412 of file at32f435_437_qspi.h.

◆ xipr_insc

__IO uint32_t qspi_type::xipr_insc

Definition at line 415 of file at32f435_437_qspi.h.

◆ xipr_opmode

__IO uint32_t qspi_type::xipr_opmode

Definition at line 413 of file at32f435_437_qspi.h.

◆ xipr_sel

__IO uint32_t qspi_type::xipr_sel

Definition at line 447 of file at32f435_437_qspi.h.

◆ xipr_tcnt

__IO uint32_t qspi_type::xipr_tcnt

Definition at line 446 of file at32f435_437_qspi.h.

◆ xiprcmdf

__IO uint32_t qspi_type::xiprcmdf

Definition at line 309 of file at32f435_437_qspi.h.

Referenced by qspi_xip_enable().

◆ xipsel

__IO uint32_t qspi_type::xipsel

Definition at line 310 of file at32f435_437_qspi.h.

Referenced by qspi_xip_enable().

◆ xipw_dcnt

__IO uint32_t qspi_type::xipw_dcnt

Definition at line 448 of file at32f435_437_qspi.h.

◆ xipw_sel

__IO uint32_t qspi_type::xipw_sel

Definition at line 451 of file at32f435_437_qspi.h.

◆ xipw_tcnt

__IO uint32_t qspi_type::xipw_tcnt

Definition at line 450 of file at32f435_437_qspi.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_qspi.h


AT32F435/437 Firmwary Library: QSPI_exported_functions

Functions
QSPI_exported_functions
AT32F435_437_periph_driver » QSPI

Functions

void | qspi_encryption_enable (qspi_type *qspi_x, confirm_state new_state)
enable/disable encryption for qspi. More...
void | qspi_sck_mode_set (qspi_type *qspi_x, qspi_clk_mode_type new_mode)
set qspi sck mode. More...
void | qspi_clk_division_set (qspi_type *qspi_x, qspi_clk_div_type new_clkdiv)
set qspi clock division More...
void | qspi_xip_cache_bypass_set (qspi_type *qspi_x, confirm_state new_state)
enable/disable cache in xip mode More...
void | qspi_interrupt_enable (qspi_type *qspi_x, confirm_state new_state)
enable/disable interrupt when command is completed More...
flag_status | qspi_flag_get (qspi_type *qspi_x, uint32_t flag)
get status flags. More...
void | qspi_flag_clear (qspi_type *qspi_x, uint32_t flag)
clear flags More...
void | qspi_dma_rx_threshold_set (qspi_type *qspi_x, qspi_dma_fifo_thod_type new_threshold)
set dma threshold for dma rx More...
void | qspi_dma_tx_threshold_set (qspi_type *qspi_x, qspi_dma_fifo_thod_type new_threshold)
set dma threshold for dma tx More...
void | qspi_dma_enable (qspi_type *qspi_x, confirm_state new_state)
enable/disable dma transfer More...
void | qspi_busy_config (qspi_type *qspi_x, qspi_busy_pos_type busy_pos)
set wip position in status register of flash More...
void | qspi_xip_enable (qspi_type *qspi_x, confirm_state new_state)
enable xip mode or command-port mode. More...
void | qspi_cmd_operation_kick (qspi_type *qspi_x, qspi_cmd_type *qspi_cmd_struct)
set command-port and qspi_x will start to work More...
void | qspi_xip_init (qspi_type *qspi_x, qspi_xip_type *xip_init_struct)
initial xip mode for qspi_x More...
uint8_t | qspi_byte_read (qspi_type *qspi_x)
read one byte from qspi device in command mode More...
uint16_t | qspi_half_word_read (qspi_type *qspi_x)
read one half-word from qspi device in command mode More...
uint32_t | qspi_word_read (qspi_type *qspi_x)
read one word from qspi device in command mode More...
void | qspi_word_write (qspi_type *qspi_x, uint32_t value)
write one word to qspi device in command mode More...
void | qspi_half_word_write (qspi_type *qspi_x, uint16_t value)
write one half-word to qspi device in command mode More...
void | qspi_byte_write (qspi_type *qspi_x, uint8_t value)
write one byte to qspi device in command mode More...

Detailed Description

Function Documentation

◆ qspi_busy_config()

void qspi_busy_config | ( | qspi_type * | qspi_x,
 |  | qspi_busy_pos_type | busy_pos
 | ) |  |

set wip position in status register of flash

Note
the function must be configured only when qspi in command-port mode!!!
Parameters
qspi_x select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
busy_pos value to set this parameter can be one of the following values:
  • QSPI_BUSY_OFFSET_0
  • QSPI_BUSY_OFFSET_1
  • QSPI_BUSY_OFFSET_2
  • QSPI_BUSY_OFFSET_3
  • QSPI_BUSY_OFFSET_4
  • QSPI_BUSY_OFFSET_5
  • QSPI_BUSY_OFFSET_6
  • QSPI_BUSY_OFFSET_7
Return values
none

Definition at line 241 of file at32f435_437_qspi.c.

Referenced by main().

◆ qspi_byte_read()

uint8_t qspi_byte_read ( qspi_type * qspi_x )

read one byte from qspi device in command mode

Parameters
qspi_x select the qspi peripheral.
Return values
8-bit data.

Definition at line 359 of file at32f435_437_qspi.c.

Referenced by qspi_data_read().

◆ qspi_byte_write()

void qspi_byte_write | ( | qspi_type * | qspi_x,
 |  | uint8_t | value
 | ) |  |

write one byte to qspi device in command mode

Parameters
qspi_x | select the qspi peripheral.
value | 8-bit data.
Return values
none.

Definition at line 390 of file at32f435_437_qspi.c.

Referenced by qspi_data_write().

◆ qspi_clk_division_set()

void qspi_clk_division_set | ( | qspi_type * | qspi_x,
 |  | qspi_clk_div_type | new_clkdiv
 | ) |  |

set qspi clock division

Note
the function must be configured only when qspi in command-port mode!!!
Parameters
qspi_x select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
new_clkdiv new division value this parameter can be one of the following values:
  • QSPI_CLK_DIV_2
  • QSPI_CLK_DIV_4
  • QSPI_CLK_DIV_6
  • QSPI_CLK_DIV_8
  • QSPI_CLK_DIV_3
  • QSPI_CLK_DIV_5
  • QSPI_CLK_DIV_10
  • QSPI_CLK_DIV_12
Return values
none

Definition at line 93 of file at32f435_437_qspi.c.

Referenced by main().

◆ qspi_cmd_operation_kick()

void qspi_cmd_operation_kick | ( | qspi_type * | qspi_x,
 |  | qspi_cmd_type * | qspi_cmd_struct
 | ) |  |

set command-port and qspi_x will start to work

Parameters
qspi_x | select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
qspi_cmd_struct | pointer to qspi cmd structure
Return values
none

Definition at line 292 of file at32f435_437_qspi.c.

Referenced by esmt32m_cmd_send(), qspi_busy_check(), qspi_cmd_ly68l6400_send(), qspi_data_once_write(), qspi_data_read(), qspi_data_write(), qspi_erase(), qspi_read_data_using_pem(), and qspi_write_enable().

◆ qspi_dma_enable()

void qspi_dma_enable | ( | qspi_type * | qspi_x,
 |  | confirm_state | new_state
 | ) |  |

enable/disable dma transfer

Note
the function must be configured only when qspi in command-port mode!!!
Parameters
qspi_x | select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 218 of file at32f435_437_qspi.c.

Referenced by qspi_data_once_write(), qspi_data_read(), and qspi_read_data_using_pem().

◆ qspi_dma_rx_threshold_set()

void qspi_dma_rx_threshold_set | ( | qspi_type * | qspi_x,
 |  | qspi_dma_fifo_thod_type | new_threshold
 | ) |  |

set dma threshold for dma rx

Note
the function must be configured only when qspi in command-port mode!!!
Parameters
qspi_x select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
new_threshold value to set this parameter can be one of the following values:
  • QSPI_DMA_FIFO_THOD_WORD08
  • QSPI_DMA_FIFO_THOD_WORD16
  • QSPI_DMA_FIFO_THOD_WORD32
Return values
none

Definition at line 186 of file at32f435_437_qspi.c.

Referenced by qspi_data_read(), and qspi_read_data_using_pem().

◆ qspi_dma_tx_threshold_set()

void qspi_dma_tx_threshold_set | ( | qspi_type * | qspi_x,
 |  | qspi_dma_fifo_thod_type | new_threshold
 | ) |  |

set dma threshold for dma tx

Note
the function must be configured only when qspi in command-port mode!!!
Parameters
qspi_x select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
new_threshold value to set this parameter can be one of the following values:
  • QSPI_DMA_FIFO_THOD_WORD08
  • QSPI_DMA_FIFO_THOD_WORD16
  • QSPI_DMA_FIFO_THOD_WORD32
Return values
none

Definition at line 204 of file at32f435_437_qspi.c.

Referenced by qspi_data_once_write().

◆ qspi_encryption_enable()

void qspi_encryption_enable | ( | qspi_type * | qspi_x,
 |  | confirm_state | new_state
 | ) |  |

enable/disable encryption for qspi.

Note
the function must be configured only when qspi in command-port mode!!!
Parameters
qspi_x | select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 53 of file at32f435_437_qspi.c.

◆ qspi_flag_clear()

void qspi_flag_clear | ( | qspi_type * | qspi_x,
 |  | uint32_t | flag
 | ) |  |

clear flags

Parameters
qspi_x select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
flag flags to be clear this parameter can be one of the following values:
  • QSPI_CMDSTS_FLAG
Return values
none

< qspi command complete status flag

Definition at line 168 of file at32f435_437_qspi.c.

Referenced by esmt32m_cmd_send(), QSPI1_IRQHandler(), qspi_busy_check(), qspi_cmd_ly68l6400_send(), qspi_data_once_write(), qspi_data_read(), qspi_data_write(), qspi_erase(), qspi_read_data_using_pem(), and qspi_write_enable().

◆ qspi_flag_get()

flag_status qspi_flag_get | ( | qspi_type * | qspi_x,
 |  | uint32_t | flag
 | ) |  |

get status flags.

Parameters
qspi_x select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
flag specifies the flag to check. this parameter can be one of the following values:
  • QSPI_RXFIFORDY_FLAG
  • QSPI_TXFIFORDY_FLAG
  • QSPI_CMDSTS_FLAG
Return values
the new state of usart_flag (SET or RESET).

< qspi rxfifo ready status flag

< qspi txfifo ready status flag

< qspi command complete status flag

Definition at line 138 of file at32f435_437_qspi.c.

Referenced by esmt32m_cmd_send(), QSPI1_IRQHandler(), qspi_busy_check(), qspi_cmd_ly68l6400_send(), qspi_data_once_write(), qspi_data_read(), qspi_data_write(), qspi_erase(), qspi_read_data_using_pem(), and qspi_write_enable().

◆ qspi_half_word_read()

uint16_t qspi_half_word_read ( qspi_type * qspi_x )

read one half-word from qspi device in command mode

Parameters
qspi_x select the qspi peripheral.
Return values
16-bit data.

Definition at line 369 of file at32f435_437_qspi.c.

◆ qspi_half_word_write()

void qspi_half_word_write | ( | qspi_type * | qspi_x,
 |  | uint16_t | value
 | ) |  |

write one half-word to qspi device in command mode

Parameters
qspi_x | select the qspi peripheral.
value | 16-bit data.
Return values
none.

Definition at line 401 of file at32f435_437_qspi.c.

◆ qspi_interrupt_enable()

void qspi_interrupt_enable | ( | qspi_type * | qspi_x,
 |  | confirm_state | new_state
 | ) |  |

enable/disable interrupt when command is completed

Note
the function must be configured only when qspi in command-port mode!!!
Parameters
qspi_x | select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 121 of file at32f435_437_qspi.c.

Referenced by main().

◆ qspi_sck_mode_set()

void qspi_sck_mode_set | ( | qspi_type * | qspi_x,
 |  | qspi_clk_mode_type | new_mode
 | ) |  |

set qspi sck mode.

Note
the function must be configured only when qspi in command-port mode!!!
Parameters
qspi_x select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
new_mode new state to be set this parameter can be one of the following values:
  • QSPI_SCK_MODE_0
  • QSPI_SCK_MODE_3
Return values
none

Definition at line 70 of file at32f435_437_qspi.c.

Referenced by main().

◆ qspi_word_read()

uint32_t qspi_word_read ( qspi_type * qspi_x )

read one word from qspi device in command mode

Parameters
qspi_x select the qspi peripheral.
Return values
32-bit data.

Definition at line 379 of file at32f435_437_qspi.c.

◆ qspi_word_write()

void qspi_word_write | ( | qspi_type * | qspi_x,
 |  | uint32_t | value
 | ) |  |

write one word to qspi device in command mode

Parameters
qspi_x | select the qspi peripheral.
value | 32-bit data.
Return values
none.

Definition at line 412 of file at32f435_437_qspi.c.

◆ qspi_xip_cache_bypass_set()

void qspi_xip_cache_bypass_set | ( | qspi_type * | qspi_x,
 |  | confirm_state | new_state
 | ) |  |

enable/disable cache in xip mode

Note
the function must be configured only when qspi in command-port mode!!!
Parameters
qspi_x | select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 107 of file at32f435_437_qspi.c.

Referenced by qspi_xip_init_ly68l6400().

◆ qspi_xip_enable()

void qspi_xip_enable | ( | qspi_type * | qspi_x,
 |  | confirm_state | new_state
 | ) |  |

enable xip mode or command-port mode.

Parameters
qspi_x | select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 254 of file at32f435_437_qspi.c.

Referenced by main(), and qspi_xip_init_ly68l6400().

◆ qspi_xip_init()

void qspi_xip_init | ( | qspi_type * | qspi_x,
 |  | qspi_xip_type * | xip_init_struct
 | ) |  |

initial xip mode for qspi_x

Parameters
qspi_x | select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
xip_init_struct | pointer to xip init structure.
Return values
none.

Definition at line 327 of file at32f435_437_qspi.c.

Referenced by qspi_xip_init_ly68l6400().


AT32F435/437 Firmwary Library: QSPI_private_functions

Functions
QSPI_private_functions
AT32F435_437_periph_driver » QSPI

Functions

void | qspi_encryption_enable (qspi_type *qspi_x, confirm_state new_state)
enable/disable encryption for qspi. More...
void | qspi_sck_mode_set (qspi_type *qspi_x, qspi_clk_mode_type new_mode)
set qspi sck mode. More...
void | qspi_clk_division_set (qspi_type *qspi_x, qspi_clk_div_type new_clkdiv)
set qspi clock division More...
void | qspi_xip_cache_bypass_set (qspi_type *qspi_x, confirm_state new_state)
enable/disable cache in xip mode More...
void | qspi_interrupt_enable (qspi_type *qspi_x, confirm_state new_state)
enable/disable interrupt when command is completed More...
flag_status | qspi_flag_get (qspi_type *qspi_x, uint32_t flag)
get status flags. More...
void | qspi_flag_clear (qspi_type *qspi_x, uint32_t flag)
clear flags More...
void | qspi_dma_rx_threshold_set (qspi_type *qspi_x, qspi_dma_fifo_thod_type new_threshold)
set dma threshold for dma rx More...
void | qspi_dma_tx_threshold_set (qspi_type *qspi_x, qspi_dma_fifo_thod_type new_threshold)
set dma threshold for dma tx More...
void | qspi_dma_enable (qspi_type *qspi_x, confirm_state new_state)
enable/disable dma transfer More...
void | qspi_busy_config (qspi_type *qspi_x, qspi_busy_pos_type busy_pos)
set wip position in status register of flash More...
void | qspi_xip_enable (qspi_type *qspi_x, confirm_state new_state)
enable xip mode or command-port mode. More...
void | qspi_cmd_operation_kick (qspi_type *qspi_x, qspi_cmd_type *qspi_cmd_struct)
set command-port and qspi_x will start to work More...
void | qspi_xip_init (qspi_type *qspi_x, qspi_xip_type *xip_init_struct)
initial xip mode for qspi_x More...
uint8_t | qspi_byte_read (qspi_type *qspi_x)
read one byte from qspi device in command mode More...
uint16_t | qspi_half_word_read (qspi_type *qspi_x)
read one half-word from qspi device in command mode More...
uint32_t | qspi_word_read (qspi_type *qspi_x)
read one word from qspi device in command mode More...
void | qspi_byte_write (qspi_type *qspi_x, uint8_t value)
write one byte to qspi device in command mode More...
void | qspi_half_word_write (qspi_type *qspi_x, uint16_t value)
write one half-word to qspi device in command mode More...
void | qspi_word_write (qspi_type *qspi_x, uint32_t value)
write one word to qspi device in command mode More...

Detailed Description

Function Documentation

◆ qspi_busy_config()

void qspi_busy_config | ( | qspi_type * | qspi_x,
 |  | qspi_busy_pos_type | busy_pos
 | ) |  |

set wip position in status register of flash

Note
the function must be configured only when qspi in command-port mode!!!
Parameters
qspi_x select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
busy_pos value to set this parameter can be one of the following values:
  • QSPI_BUSY_OFFSET_0
  • QSPI_BUSY_OFFSET_1
  • QSPI_BUSY_OFFSET_2
  • QSPI_BUSY_OFFSET_3
  • QSPI_BUSY_OFFSET_4
  • QSPI_BUSY_OFFSET_5
  • QSPI_BUSY_OFFSET_6
  • QSPI_BUSY_OFFSET_7
Return values
none

Definition at line 241 of file at32f435_437_qspi.c.

Referenced by main().

◆ qspi_byte_read()

uint8_t qspi_byte_read ( qspi_type * qspi_x )

read one byte from qspi device in command mode

Parameters
qspi_x select the qspi peripheral.
Return values
8-bit data.

Definition at line 359 of file at32f435_437_qspi.c.

Referenced by qspi_data_read().

◆ qspi_byte_write()

void qspi_byte_write | ( | qspi_type * | qspi_x,
 |  | uint8_t | value
 | ) |  |

write one byte to qspi device in command mode

Parameters
qspi_x | select the qspi peripheral.
value | 8-bit data.
Return values
none.

Definition at line 390 of file at32f435_437_qspi.c.

Referenced by qspi_data_write().

◆ qspi_clk_division_set()

void qspi_clk_division_set | ( | qspi_type * | qspi_x,
 |  | qspi_clk_div_type | new_clkdiv
 | ) |  |

set qspi clock division

Note
the function must be configured only when qspi in command-port mode!!!
Parameters
qspi_x select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
new_clkdiv new division value this parameter can be one of the following values:
  • QSPI_CLK_DIV_2
  • QSPI_CLK_DIV_4
  • QSPI_CLK_DIV_6
  • QSPI_CLK_DIV_8
  • QSPI_CLK_DIV_3
  • QSPI_CLK_DIV_5
  • QSPI_CLK_DIV_10
  • QSPI_CLK_DIV_12
Return values
none

Definition at line 93 of file at32f435_437_qspi.c.

Referenced by main().

◆ qspi_cmd_operation_kick()

void qspi_cmd_operation_kick | ( | qspi_type * | qspi_x,
 |  | qspi_cmd_type * | qspi_cmd_struct
 | ) |  |

set command-port and qspi_x will start to work

Parameters
qspi_x | select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
qspi_cmd_struct | pointer to qspi cmd structure
Return values
none

Definition at line 292 of file at32f435_437_qspi.c.

Referenced by esmt32m_cmd_send(), qspi_busy_check(), qspi_cmd_ly68l6400_send(), qspi_data_once_write(), qspi_data_read(), qspi_data_write(), qspi_erase(), qspi_read_data_using_pem(), and qspi_write_enable().

◆ qspi_dma_enable()

void qspi_dma_enable | ( | qspi_type * | qspi_x,
 |  | confirm_state | new_state
 | ) |  |

enable/disable dma transfer

Note
the function must be configured only when qspi in command-port mode!!!
Parameters
qspi_x | select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 218 of file at32f435_437_qspi.c.

Referenced by qspi_data_once_write(), qspi_data_read(), and qspi_read_data_using_pem().

◆ qspi_dma_rx_threshold_set()

void qspi_dma_rx_threshold_set | ( | qspi_type * | qspi_x,
 |  | qspi_dma_fifo_thod_type | new_threshold
 | ) |  |

set dma threshold for dma rx

Note
the function must be configured only when qspi in command-port mode!!!
Parameters
qspi_x select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
new_threshold value to set this parameter can be one of the following values:
  • QSPI_DMA_FIFO_THOD_WORD08
  • QSPI_DMA_FIFO_THOD_WORD16
  • QSPI_DMA_FIFO_THOD_WORD32
Return values
none

Definition at line 186 of file at32f435_437_qspi.c.

Referenced by qspi_data_read(), and qspi_read_data_using_pem().

◆ qspi_dma_tx_threshold_set()

void qspi_dma_tx_threshold_set | ( | qspi_type * | qspi_x,
 |  | qspi_dma_fifo_thod_type | new_threshold
 | ) |  |

set dma threshold for dma tx

Note
the function must be configured only when qspi in command-port mode!!!
Parameters
qspi_x select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
new_threshold value to set this parameter can be one of the following values:
  • QSPI_DMA_FIFO_THOD_WORD08
  • QSPI_DMA_FIFO_THOD_WORD16
  • QSPI_DMA_FIFO_THOD_WORD32
Return values
none

Definition at line 204 of file at32f435_437_qspi.c.

Referenced by qspi_data_once_write().

◆ qspi_encryption_enable()

void qspi_encryption_enable | ( | qspi_type * | qspi_x,
 |  | confirm_state | new_state
 | ) |  |

enable/disable encryption for qspi.

Note
the function must be configured only when qspi in command-port mode!!!
Parameters
qspi_x | select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 53 of file at32f435_437_qspi.c.

◆ qspi_flag_clear()

void qspi_flag_clear | ( | qspi_type * | qspi_x,
 |  | uint32_t | flag
 | ) |  |

clear flags

Parameters
qspi_x select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
flag flags to be clear this parameter can be one of the following values:
  • QSPI_CMDSTS_FLAG
Return values
none

< qspi command complete status flag

Definition at line 168 of file at32f435_437_qspi.c.

Referenced by esmt32m_cmd_send(), QSPI1_IRQHandler(), qspi_busy_check(), qspi_cmd_ly68l6400_send(), qspi_data_once_write(), qspi_data_read(), qspi_data_write(), qspi_erase(), qspi_read_data_using_pem(), and qspi_write_enable().

◆ qspi_flag_get()

flag_status qspi_flag_get | ( | qspi_type * | qspi_x,
 |  | uint32_t | flag
 | ) |  |

get status flags.

Parameters
qspi_x select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
flag specifies the flag to check. this parameter can be one of the following values:
  • QSPI_RXFIFORDY_FLAG
  • QSPI_TXFIFORDY_FLAG
  • QSPI_CMDSTS_FLAG
Return values
the new state of usart_flag (SET or RESET).

< qspi rxfifo ready status flag

< qspi txfifo ready status flag

< qspi command complete status flag

Definition at line 138 of file at32f435_437_qspi.c.

Referenced by esmt32m_cmd_send(), QSPI1_IRQHandler(), qspi_busy_check(), qspi_cmd_ly68l6400_send(), qspi_data_once_write(), qspi_data_read(), qspi_data_write(), qspi_erase(), qspi_read_data_using_pem(), and qspi_write_enable().

◆ qspi_half_word_read()

uint16_t qspi_half_word_read ( qspi_type * qspi_x )

read one half-word from qspi device in command mode

Parameters
qspi_x select the qspi peripheral.
Return values
16-bit data.

Definition at line 369 of file at32f435_437_qspi.c.

◆ qspi_half_word_write()

void qspi_half_word_write | ( | qspi_type * | qspi_x,
 |  | uint16_t | value
 | ) |  |

write one half-word to qspi device in command mode

Parameters
qspi_x | select the qspi peripheral.
value | 16-bit data.
Return values
none.

Definition at line 401 of file at32f435_437_qspi.c.

◆ qspi_interrupt_enable()

void qspi_interrupt_enable | ( | qspi_type * | qspi_x,
 |  | confirm_state | new_state
 | ) |  |

enable/disable interrupt when command is completed

Note
the function must be configured only when qspi in command-port mode!!!
Parameters
qspi_x | select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 121 of file at32f435_437_qspi.c.

Referenced by main().

◆ qspi_sck_mode_set()

void qspi_sck_mode_set | ( | qspi_type * | qspi_x,
 |  | qspi_clk_mode_type | new_mode
 | ) |  |

set qspi sck mode.

Note
the function must be configured only when qspi in command-port mode!!!
Parameters
qspi_x select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
new_mode new state to be set this parameter can be one of the following values:
  • QSPI_SCK_MODE_0
  • QSPI_SCK_MODE_3
Return values
none

Definition at line 70 of file at32f435_437_qspi.c.

Referenced by main().

◆ qspi_word_read()

uint32_t qspi_word_read ( qspi_type * qspi_x )

read one word from qspi device in command mode

Parameters
qspi_x select the qspi peripheral.
Return values
32-bit data.

Definition at line 379 of file at32f435_437_qspi.c.

◆ qspi_word_write()

void qspi_word_write | ( | qspi_type * | qspi_x,
 |  | uint32_t | value
 | ) |  |

write one word to qspi device in command mode

Parameters
qspi_x | select the qspi peripheral.
value | 32-bit data.
Return values
none.

Definition at line 412 of file at32f435_437_qspi.c.

◆ qspi_xip_cache_bypass_set()

void qspi_xip_cache_bypass_set | ( | qspi_type * | qspi_x,
 |  | confirm_state | new_state
 | ) |  |

enable/disable cache in xip mode

Note
the function must be configured only when qspi in command-port mode!!!
Parameters
qspi_x | select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 107 of file at32f435_437_qspi.c.

Referenced by qspi_xip_init_ly68l6400().

◆ qspi_xip_enable()

void qspi_xip_enable | ( | qspi_type * | qspi_x,
 |  | confirm_state | new_state
 | ) |  |

enable xip mode or command-port mode.

Parameters
qspi_x | select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 254 of file at32f435_437_qspi.c.

Referenced by main(), and qspi_xip_init_ly68l6400().

◆ qspi_xip_init()

void qspi_xip_init | ( | qspi_type * | qspi_x,
 |  | qspi_xip_type * | xip_init_struct
 | ) |  |

initial xip mode for qspi_x

Parameters
qspi_x | select the qspi peripheral. this parameter can be one of the following values: QSPI1,QSPI2.
xip_init_struct | pointer to xip init structure.
Return values
none.

Definition at line 327 of file at32f435_437_qspi.c.

Referenced by qspi_xip_init_ly68l6400().


AT32F435/437 Firmwary Library: SCFG

Modules | Macros
SCFG
AT32F435_437_periph_driver

SCFG driver modules. More...

Modules

SCFG_exported_types
SCFG_exported_functions
SCFG_private_functions

Macros

#define | SCFG_REG(value) PERIPH_REG(SCFG_BASE, value)
#define | SCFG_REG_BIT(value) PERIPH_REG_BIT(value)
#define | SCFG ((scfg_type *) SCFG_BASE)

Detailed Description

SCFG driver modules.

Macro Definition Documentation

◆ SCFG

#define SCFG ((scfg_type *) SCFG_BASE)

Definition at line 293 of file at32f435_437_scfg.h.

◆ SCFG_REG

#define SCFG_REG ( value ) PERIPH_REG(SCFG_BASE, value)

Definition at line 47 of file at32f435_437_scfg.h.

◆ SCFG_REG_BIT

#define SCFG_REG_BIT ( value ) PERIPH_REG_BIT(value)

Definition at line 48 of file at32f435_437_scfg.h.


AT32F435/437 Firmwary Library: SCFG_exported_types

Data Structures | Enumerations
SCFG_exported_types
AT32F435_437_periph_driver » SCFG

Data Structures

struct scfg_type
type define system config register all More...

Enumerations

enum | scfg_xmc_swap_type { SCFG_XMC_SWAP_NONE = 0x00 , SCFG_XMC_SWAP_MODE1 = 0x01 , SCFG_XMC_SWAP_MODE2 = 0x02 , SCFG_XMC_SWAP_MODE3 = 0x03 }
scfg xmc addres mapping swap type More...
enum | scfg_ir_source_type { SCFG_IR_SOURCE_TMR10 = 0x00 , SCFG_IR_SOURCE_USART1 = 0x01 , SCFG_IR_SOURCE_USART2 = 0x02 }
scfg infrared modulation signal source selecting type More...
enum | scfg_ir_polarity_type { SCFG_IR_POLARITY_NO_AFFECTE = 0x00 , SCFG_IR_POLARITY_REVERSE = 0x01 }
scfg infrared output polarity selecting type More...
enum scfg_mem_map_type {
SCFG_MEM_MAP_MAIN_MEMORY = 0x00 , SCFG_MEM_MAP_BOOT_MEMORY = 0x01 , SCFG_MEM_MAP_XMC_BANK1 = 0x02 , SCFG_MEM_MAP_INTERNAL_SRAM = 0x03 ,
SCFG_MEM_MAP_XMC_SDRAM_BANK1 = 0x04
}
scfg memory address mapping selecting type More...
enum scfg_pins_source_type {
SCFG_PINS_SOURCE0 = 0x00 , SCFG_PINS_SOURCE1 = 0x01 , SCFG_PINS_SOURCE2 = 0x02 , SCFG_PINS_SOURCE3 = 0x03 ,
SCFG_PINS_SOURCE4 = 0x04 , SCFG_PINS_SOURCE5 = 0x05 , SCFG_PINS_SOURCE6 = 0x06 , SCFG_PINS_SOURCE7 = 0x07 ,
SCFG_PINS_SOURCE8 = 0x08 , SCFG_PINS_SOURCE9 = 0x09 , SCFG_PINS_SOURCE10 = 0x0A , SCFG_PINS_SOURCE11 = 0x0B ,
SCFG_PINS_SOURCE12 = 0x0C , SCFG_PINS_SOURCE13 = 0x0D , SCFG_PINS_SOURCE14 = 0x0E , SCFG_PINS_SOURCE15 = 0x0F
}
scfg pin source type More...
enum scfg_port_source_type {
SCFG_PORT_SOURCE_GPIOA = 0x00 , SCFG_PORT_SOURCE_GPIOB = 0x01 , SCFG_PORT_SOURCE_GPIOC = 0x02 , SCFG_PORT_SOURCE_GPIOD = 0x03 ,
SCFG_PORT_SOURCE_GPIOE = 0x04 , SCFG_PORT_SOURCE_GPIOF = 0x05 , SCFG_PORT_SOURCE_GPIOG = 0x06 , SCFG_PORT_SOURCE_GPIOH = 0x07
}
gpio port source type More...
enum | scfg_emac_interface_type { SCFG_EMAC_SELECT_MII = 0x00 , SCFG_EMAC_SELECT_RMII = 0x01 }
scfg emac interface selecting type More...
enum scfg_ultra_driven_pins_type {
SCFG_ULTRA_DRIVEN_PB3 = ((( 0x2C ) << 16) | ( 0 & 0x1f)) , SCFG_ULTRA_DRIVEN_PB9 = ((( 0x2C ) << 16) | ( 1 & 0x1f)) , SCFG_ULTRA_DRIVEN_PB10 = ((( 0x2C ) << 16) | ( 2 & 0x1f)) , SCFG_ULTRA_DRIVEN_PD12 = ((( 0x2C ) << 16) | ( 5 & 0x1f)) ,
SCFG_ULTRA_DRIVEN_PD13 = ((( 0x2C ) << 16) | ( 6 & 0x1f)) , SCFG_ULTRA_DRIVEN_PD14 = ((( 0x2C ) << 16) | ( 7 & 0x1f)) , SCFG_ULTRA_DRIVEN_PD15 = ((( 0x2C ) << 16) | ( 8 & 0x1f)) , SCFG_ULTRA_DRIVEN_PF14 = ((( 0x2C ) << 16) | ( 9 & 0x1f)) ,
SCFG_ULTRA_DRIVEN_PF15 = ((( 0x2C ) << 16) | ( 10 & 0x1f))
}
scfg ultra high sourcing/sinking strength pins type More...

Detailed Description

Enumeration Type Documentation

◆ scfg_emac_interface_type

enum scfg_emac_interface_type

scfg emac interface selecting type

Enumerator
SCFG_EMAC_SELECT_MII
SCFG_EMAC_SELECT_RMII

Definition at line 137 of file at32f435_437_scfg.h.

◆ scfg_ir_polarity_type

enum scfg_ir_polarity_type

scfg infrared output polarity selecting type

Enumerator
SCFG_IR_POLARITY_NO_AFFECTE
SCFG_IR_POLARITY_REVERSE

Definition at line 78 of file at32f435_437_scfg.h.

◆ scfg_ir_source_type

enum scfg_ir_source_type

scfg infrared modulation signal source selecting type

Enumerator
SCFG_IR_SOURCE_TMR10
SCFG_IR_SOURCE_USART1
SCFG_IR_SOURCE_USART2

Definition at line 68 of file at32f435_437_scfg.h.

◆ scfg_mem_map_type

enum scfg_mem_map_type

scfg memory address mapping selecting type

Enumerator
SCFG_MEM_MAP_MAIN_MEMORY
SCFG_MEM_MAP_BOOT_MEMORY
SCFG_MEM_MAP_XMC_BANK1
SCFG_MEM_MAP_INTERNAL_SRAM
SCFG_MEM_MAP_XMC_SDRAM_BANK1

Definition at line 87 of file at32f435_437_scfg.h.

◆ scfg_pins_source_type

enum scfg_pins_source_type

scfg pin source type

Enumerator
SCFG_PINS_SOURCE0
SCFG_PINS_SOURCE1
SCFG_PINS_SOURCE2
SCFG_PINS_SOURCE3
SCFG_PINS_SOURCE4
SCFG_PINS_SOURCE5
SCFG_PINS_SOURCE6
SCFG_PINS_SOURCE7
SCFG_PINS_SOURCE8
SCFG_PINS_SOURCE9
SCFG_PINS_SOURCE10
SCFG_PINS_SOURCE11
SCFG_PINS_SOURCE12
SCFG_PINS_SOURCE13
SCFG_PINS_SOURCE14
SCFG_PINS_SOURCE15

Definition at line 99 of file at32f435_437_scfg.h.

◆ scfg_port_source_type

enum scfg_port_source_type

gpio port source type

Enumerator
SCFG_PORT_SOURCE_GPIOA
SCFG_PORT_SOURCE_GPIOB
SCFG_PORT_SOURCE_GPIOC
SCFG_PORT_SOURCE_GPIOD
SCFG_PORT_SOURCE_GPIOE
SCFG_PORT_SOURCE_GPIOF
SCFG_PORT_SOURCE_GPIOG
SCFG_PORT_SOURCE_GPIOH

Definition at line 122 of file at32f435_437_scfg.h.

◆ scfg_ultra_driven_pins_type

enum scfg_ultra_driven_pins_type

scfg ultra high sourcing/sinking strength pins type

Enumerator
SCFG_ULTRA_DRIVEN_PB3
SCFG_ULTRA_DRIVEN_PB9
SCFG_ULTRA_DRIVEN_PB10
SCFG_ULTRA_DRIVEN_PD12
SCFG_ULTRA_DRIVEN_PD13
SCFG_ULTRA_DRIVEN_PD14
SCFG_ULTRA_DRIVEN_PD15
SCFG_ULTRA_DRIVEN_PF14
SCFG_ULTRA_DRIVEN_PF15

Definition at line 146 of file at32f435_437_scfg.h.

◆ scfg_xmc_swap_type

enum scfg_xmc_swap_type

scfg xmc addres mapping swap type

Enumerator
SCFG_XMC_SWAP_NONE
SCFG_XMC_SWAP_MODE1
SCFG_XMC_SWAP_MODE2
SCFG_XMC_SWAP_MODE3

Definition at line 57 of file at32f435_437_scfg.h.


AT32F435/437 Firmwary Library: scfg_type Struct Reference

Data Fields
scfg_type Struct Reference
AT32F435_437_periph_driver » SCFG » SCFG_exported_types

type define system config register all More...

#include <at32f435_437_scfg.h>

Data Fields

union {
__IO uint32_t cfg1
struct {
__IO uint32_t mem_map_sel: 3
__IO uint32_t reserved1: 2
__IO uint32_t ir_pol: 1
__IO uint32_t ir_src_sel: 2
__IO uint32_t reserved2: 2
__IO uint32_t swap_xmc: 2
__IO uint32_t reserved3: 20
} cfg1_bit
};
scfg cfg1 register, offset:0x00 More...
union {
__IO uint32_t cfg2
struct {
__IO uint32_t reserved1: 23
__IO uint32_t mii_rmii_sel: 1
__IO uint32_t reserved2: 8
} cfg2_bit
};
scfg cfg2 register, offset:0x04 More...
union {
__IO uint32_t exintc1
struct {
__IO uint32_t exint0: 4
__IO uint32_t exint1: 4
__IO uint32_t exint2: 4
__IO uint32_t exint3: 4
__IO uint32_t reserved1: 16
} exintc1_bit
};
scfg exintc1 register, offset:0x08 More...
union {
__IO uint32_t exintc2
struct {
__IO uint32_t exint4: 4
__IO uint32_t exint5: 4
__IO uint32_t exint6: 4
__IO uint32_t exint7: 4
__IO uint32_t reserved1: 16
} exintc2_bit
};
scfg exintc2 register, offset:0x0C More...
union {
__IO uint32_t exintc3
struct {
__IO uint32_t exint8: 4
__IO uint32_t exint9: 4
__IO uint32_t exint10: 4
__IO uint32_t exint11: 4
__IO uint32_t reserved1: 16
} exintc3_bit
};
scfg exintc3 register, offset:0x10 More...
union {
__IO uint32_t exintc4
struct {
__IO uint32_t exint12: 4
__IO uint32_t exint13: 4
__IO uint32_t exint14: 4
__IO uint32_t exint15: 4
__IO uint32_t reserved1: 16
} exintc4_bit
};
scfg exintc4 register, offset:0x14 More...
union {
__IO uint32_t uhdrv
struct {
__IO uint32_t pb3_uh: 1
__IO uint32_t pb9_uh: 1
__IO uint32_t pb10_uh: 1
__IO uint32_t reserved1: 2
__IO uint32_t pd12_uh: 1
__IO uint32_t pd13_uh: 1
__IO uint32_t pd14_uh: 1
__IO uint32_t pd15_uh: 1
__IO uint32_t pf14_uh: 1
__IO uint32_t pf15_uh: 1
__IO uint32_t reserved2: 21
} uhdrv_bit
};
scfg uhdrv register, offset:0x2C More...

Detailed Description

type define system config register all

Definition at line 162 of file at32f435_437_scfg.h.

Field Documentation

◆

union { ... } scfg_type::@956

scfg cfg1 register, offset:0x00

◆

union { ... } scfg_type::@958

scfg cfg2 register, offset:0x04

◆

union { ... } scfg_type::@960

scfg exintc1 register, offset:0x08

◆

union { ... } scfg_type::@962

scfg exintc2 register, offset:0x0C

◆

union { ... } scfg_type::@964

scfg exintc3 register, offset:0x10

◆

union { ... } scfg_type::@966

scfg exintc4 register, offset:0x14

◆

union { ... } scfg_type::@968

scfg uhdrv register, offset:0x2C

◆ cfg1

__IO uint32_t scfg_type::cfg1

Definition at line 169 of file at32f435_437_scfg.h.

◆

struct { ... } scfg_type::cfg1_bit

◆ cfg2

__IO uint32_t scfg_type::cfg2

Definition at line 187 of file at32f435_437_scfg.h.

◆

struct { ... } scfg_type::cfg2_bit

◆ exint0

__IO uint32_t scfg_type::exint0

Definition at line 204 of file at32f435_437_scfg.h.

◆ exint1

__IO uint32_t scfg_type::exint1

Definition at line 205 of file at32f435_437_scfg.h.

◆ exint10

__IO uint32_t scfg_type::exint10

Definition at line 238 of file at32f435_437_scfg.h.

◆ exint11

__IO uint32_t scfg_type::exint11

Definition at line 239 of file at32f435_437_scfg.h.

◆ exint12

__IO uint32_t scfg_type::exint12

Definition at line 252 of file at32f435_437_scfg.h.

◆ exint13

__IO uint32_t scfg_type::exint13

Definition at line 253 of file at32f435_437_scfg.h.

◆ exint14

__IO uint32_t scfg_type::exint14

Definition at line 254 of file at32f435_437_scfg.h.

◆ exint15

__IO uint32_t scfg_type::exint15

Definition at line 255 of file at32f435_437_scfg.h.

◆ exint2

__IO uint32_t scfg_type::exint2

Definition at line 206 of file at32f435_437_scfg.h.

◆ exint3

__IO uint32_t scfg_type::exint3

Definition at line 207 of file at32f435_437_scfg.h.

◆ exint4

__IO uint32_t scfg_type::exint4

Definition at line 220 of file at32f435_437_scfg.h.

◆ exint5

__IO uint32_t scfg_type::exint5

Definition at line 221 of file at32f435_437_scfg.h.

◆ exint6

__IO uint32_t scfg_type::exint6

Definition at line 222 of file at32f435_437_scfg.h.

◆ exint7

__IO uint32_t scfg_type::exint7

Definition at line 223 of file at32f435_437_scfg.h.

◆ exint8

__IO uint32_t scfg_type::exint8

Definition at line 236 of file at32f435_437_scfg.h.

◆ exint9

__IO uint32_t scfg_type::exint9

Definition at line 237 of file at32f435_437_scfg.h.

◆ exintc1

__IO uint32_t scfg_type::exintc1

Definition at line 201 of file at32f435_437_scfg.h.

◆

struct { ... } scfg_type::exintc1_bit

◆ exintc2

__IO uint32_t scfg_type::exintc2

Definition at line 217 of file at32f435_437_scfg.h.

◆

struct { ... } scfg_type::exintc2_bit

◆ exintc3

__IO uint32_t scfg_type::exintc3

Definition at line 233 of file at32f435_437_scfg.h.

◆

struct { ... } scfg_type::exintc3_bit

◆ exintc4

__IO uint32_t scfg_type::exintc4

Definition at line 249 of file at32f435_437_scfg.h.

◆

struct { ... } scfg_type::exintc4_bit

◆ ir_pol

__IO uint32_t scfg_type::ir_pol

Definition at line 174 of file at32f435_437_scfg.h.

◆ ir_src_sel

__IO uint32_t scfg_type::ir_src_sel

Definition at line 175 of file at32f435_437_scfg.h.

◆ mem_map_sel

__IO uint32_t scfg_type::mem_map_sel

Definition at line 172 of file at32f435_437_scfg.h.

◆ mii_rmii_sel

__IO uint32_t scfg_type::mii_rmii_sel

Definition at line 191 of file at32f435_437_scfg.h.

◆ pb10_uh

__IO uint32_t scfg_type::pb10_uh

Definition at line 275 of file at32f435_437_scfg.h.

◆ pb3_uh

__IO uint32_t scfg_type::pb3_uh

Definition at line 273 of file at32f435_437_scfg.h.

◆ pb9_uh

__IO uint32_t scfg_type::pb9_uh

Definition at line 274 of file at32f435_437_scfg.h.

◆ pd12_uh

__IO uint32_t scfg_type::pd12_uh

Definition at line 277 of file at32f435_437_scfg.h.

◆ pd13_uh

__IO uint32_t scfg_type::pd13_uh

Definition at line 278 of file at32f435_437_scfg.h.

◆ pd14_uh

__IO uint32_t scfg_type::pd14_uh

Definition at line 279 of file at32f435_437_scfg.h.

◆ pd15_uh

__IO uint32_t scfg_type::pd15_uh

Definition at line 280 of file at32f435_437_scfg.h.

◆ pf14_uh

__IO uint32_t scfg_type::pf14_uh

Definition at line 281 of file at32f435_437_scfg.h.

◆ pf15_uh

__IO uint32_t scfg_type::pf15_uh

Definition at line 282 of file at32f435_437_scfg.h.

◆ reserved1

__IO uint32_t scfg_type::reserved1

crm reserved1 register, offset:0x18~0x28

Definition at line 173 of file at32f435_437_scfg.h.

◆ reserved2

__IO uint32_t scfg_type::reserved2

Definition at line 176 of file at32f435_437_scfg.h.

◆ reserved3

__IO uint32_t scfg_type::reserved3

Definition at line 178 of file at32f435_437_scfg.h.

◆ swap_xmc

__IO uint32_t scfg_type::swap_xmc

Definition at line 177 of file at32f435_437_scfg.h.

◆ uhdrv

__IO uint32_t scfg_type::uhdrv

Definition at line 270 of file at32f435_437_scfg.h.

◆

struct { ... } scfg_type::uhdrv_bit
The documentation for this struct was generated from the following file:
  • at32f435_437_scfg.h


AT32F435/437 Firmwary Library: SCFG_exported_functions

Functions
SCFG_exported_functions
AT32F435_437_periph_driver » SCFG

Functions

void | scfg_reset (void)
scfg reset More...
void | scfg_xmc_mapping_swap_set (scfg_xmc_swap_type xmc_swap)
scfg xmc address mapping swap set More...
void | scfg_infrared_config (scfg_ir_source_type source, scfg_ir_polarity_type polarity)
scfg infrared config More...
void | scfg_mem_map_set (scfg_mem_map_type mem_map)
scfg memory address mapping set More...
void | scfg_emac_interface_set (scfg_emac_interface_type mode)
scfg emac interface set More...
void | scfg_exint_line_config (scfg_port_source_type port_source, scfg_pins_source_type pin_source)
select the gpio pin used as exint line. More...
void | scfg_pins_ultra_driven_enable (scfg_ultra_driven_pins_type value, confirm_state new_state)
enable or disable gpio pins ultra driven. More...

Detailed Description

Function Documentation

◆ scfg_emac_interface_set()

void scfg_emac_interface_set ( scfg_emac_interface_type mode )

scfg emac interface set

Parameters
mode this parameter can be one of the following values:
  • SCFG_EMAC_SELECT_MII
  • SCFG_EMAC_SELECT_RMII
Return values
none

Definition at line 113 of file at32f435_437_scfg.c.

Referenced by emac_layer2_configuration().

◆ scfg_exint_line_config()

void scfg_exint_line_config | ( | scfg_port_source_type | port_source,
 |  | scfg_pins_source_type | pin_source
 | ) |  |

select the gpio pin used as exint line.

Parameters
port_source select the gpio port to be used as source for exint lines. this parameter can be one of the following values:
  • SCFG_PORT_SOURCE_GPIOA
  • SCFG_PORT_SOURCE_GPIOB
  • SCFG_PORT_SOURCE_GPIOC
  • SCFG_PORT_SOURCE_GPIOD
  • SCFG_PORT_SOURCE_GPIOE
  • SCFG_PORT_SOURCE_GPIOF
  • SCFG_PORT_SOURCE_GPIOG
  • SCFG_PORT_SOURCE_GPIOH
pin_source specifies the exint line to be configured. this parameter can be one of the following values:
  • SCFG_PINS_SOURCE0
  • SCFG_PINS_SOURCE1
  • SCFG_PINS_SOURCE2
  • SCFG_PINS_SOURCE3
  • SCFG_PINS_SOURCE4
  • SCFG_PINS_SOURCE5
  • SCFG_PINS_SOURCE6
  • SCFG_PINS_SOURCE7
  • SCFG_PINS_SOURCE8
  • SCFG_PINS_SOURCE9
  • SCFG_PINS_SOURCE10
  • SCFG_PINS_SOURCE11
  • SCFG_PINS_SOURCE12
  • SCFG_PINS_SOURCE13
  • SCFG_PINS_SOURCE14
  • SCFG_PINS_SOURCE15
Return values
none

Definition at line 152 of file at32f435_437_scfg.c.

Referenced by button_exint_init(), exint_config(), exint_line0_config(), main(), and usart_configuration().

◆ scfg_infrared_config()

void scfg_infrared_config | ( | scfg_ir_source_type | source,
 |  | scfg_ir_polarity_type | polarity
 | ) |  |

scfg infrared config

Parameters
source this parameter can be one of the following values:
  • SCFG_IR_SOURCE_TMR10
  • SCFG_IR_SOURCE_USART1
  • SCFG_IR_SOURCE_USART2
polarity this parameter can be one of the following values:
  • SCFG_IR_POLARITY_NO_AFFECTE
  • SCFG_IR_POLARITY_REVERSE
Return values
none

Definition at line 83 of file at32f435_437_scfg.c.

Referenced by main().

◆ scfg_mem_map_set()

void scfg_mem_map_set ( scfg_mem_map_type mem_map )

scfg memory address mapping set

Parameters
mem_map this parameter can be one of the following values:
  • SCFG_MEM_MAP_MAIN_MEMORY
  • SCFG_MEM_MAP_BOOT_MEMORY
  • SCFG_MEM_MAP_XMC_BANK1
  • SCFG_MEM_MAP_INTERNAL_SRAM
  • SCFG_MEM_MAP_XMC_SDRAM_BANK1
Return values
none

Definition at line 100 of file at32f435_437_scfg.c.

Referenced by main().

◆ scfg_pins_ultra_driven_enable()

void scfg_pins_ultra_driven_enable | ( | scfg_ultra_driven_pins_type | value,
 |  | confirm_state | new_state
 | ) |  |

enable or disable gpio pins ultra driven.

Parameters
value this parameter can be one of the following values:
  • SCFG_ULTRA_DRIVEN_PB3
  • SCFG_ULTRA_DRIVEN_PB9
  • SCFG_ULTRA_DRIVEN_PB10
  • SCFG_ULTRA_DRIVEN_PD12
  • SCFG_ULTRA_DRIVEN_PD13
  • SCFG_ULTRA_DRIVEN_PD14
  • SCFG_ULTRA_DRIVEN_PD15
  • SCFG_ULTRA_DRIVEN_PF14
  • SCFG_ULTRA_DRIVEN_PF15
new_state (TRUE or FALSE)
Return values
none

Definition at line 196 of file at32f435_437_scfg.c.

◆ scfg_reset()

void scfg_reset ( void )

scfg reset

Parameters
none
Return values
none

Definition at line 49 of file at32f435_437_scfg.c.

◆ scfg_xmc_mapping_swap_set()

void scfg_xmc_mapping_swap_set ( scfg_xmc_swap_type xmc_swap )

scfg xmc address mapping swap set

Parameters
xmc_swap this parameter can be one of the following values:
  • SCFG_XMC_SWAP_NONE
  • SCFG_XMC_SWAP_MODE1
  • SCFG_XMC_SWAP_MODE2
  • SCFG_XMC_SWAP_MODE3
Return values
none

Definition at line 65 of file at32f435_437_scfg.c.


AT32F435/437 Firmwary Library: SCFG_private_functions

Functions
SCFG_private_functions
AT32F435_437_periph_driver » SCFG

Functions

void | scfg_reset (void)
scfg reset More...
void | scfg_xmc_mapping_swap_set (scfg_xmc_swap_type xmc_swap)
scfg xmc address mapping swap set More...
void | scfg_infrared_config (scfg_ir_source_type source, scfg_ir_polarity_type polarity)
scfg infrared config More...
void | scfg_mem_map_set (scfg_mem_map_type mem_map)
scfg memory address mapping set More...
void | scfg_emac_interface_set (scfg_emac_interface_type mode)
scfg emac interface set More...
void | scfg_exint_line_config (scfg_port_source_type port_source, scfg_pins_source_type pin_source)
select the gpio pin used as exint line. More...
void | scfg_pins_ultra_driven_enable (scfg_ultra_driven_pins_type value, confirm_state new_state)
enable or disable gpio pins ultra driven. More...

Detailed Description

Function Documentation

◆ scfg_emac_interface_set()

void scfg_emac_interface_set ( scfg_emac_interface_type mode )

scfg emac interface set

Parameters
mode this parameter can be one of the following values:
  • SCFG_EMAC_SELECT_MII
  • SCFG_EMAC_SELECT_RMII
Return values
none

Definition at line 113 of file at32f435_437_scfg.c.

Referenced by emac_layer2_configuration().

◆ scfg_exint_line_config()

void scfg_exint_line_config | ( | scfg_port_source_type | port_source,
 |  | scfg_pins_source_type | pin_source
 | ) |  |

select the gpio pin used as exint line.

Parameters
port_source select the gpio port to be used as source for exint lines. this parameter can be one of the following values:
  • SCFG_PORT_SOURCE_GPIOA
  • SCFG_PORT_SOURCE_GPIOB
  • SCFG_PORT_SOURCE_GPIOC
  • SCFG_PORT_SOURCE_GPIOD
  • SCFG_PORT_SOURCE_GPIOE
  • SCFG_PORT_SOURCE_GPIOF
  • SCFG_PORT_SOURCE_GPIOG
  • SCFG_PORT_SOURCE_GPIOH
pin_source specifies the exint line to be configured. this parameter can be one of the following values:
  • SCFG_PINS_SOURCE0
  • SCFG_PINS_SOURCE1
  • SCFG_PINS_SOURCE2
  • SCFG_PINS_SOURCE3
  • SCFG_PINS_SOURCE4
  • SCFG_PINS_SOURCE5
  • SCFG_PINS_SOURCE6
  • SCFG_PINS_SOURCE7
  • SCFG_PINS_SOURCE8
  • SCFG_PINS_SOURCE9
  • SCFG_PINS_SOURCE10
  • SCFG_PINS_SOURCE11
  • SCFG_PINS_SOURCE12
  • SCFG_PINS_SOURCE13
  • SCFG_PINS_SOURCE14
  • SCFG_PINS_SOURCE15
Return values
none

Definition at line 152 of file at32f435_437_scfg.c.

Referenced by button_exint_init(), exint_config(), exint_line0_config(), main(), and usart_configuration().

◆ scfg_infrared_config()

void scfg_infrared_config | ( | scfg_ir_source_type | source,
 |  | scfg_ir_polarity_type | polarity
 | ) |  |

scfg infrared config

Parameters
source this parameter can be one of the following values:
  • SCFG_IR_SOURCE_TMR10
  • SCFG_IR_SOURCE_USART1
  • SCFG_IR_SOURCE_USART2
polarity this parameter can be one of the following values:
  • SCFG_IR_POLARITY_NO_AFFECTE
  • SCFG_IR_POLARITY_REVERSE
Return values
none

Definition at line 83 of file at32f435_437_scfg.c.

Referenced by main().

◆ scfg_mem_map_set()

void scfg_mem_map_set ( scfg_mem_map_type mem_map )

scfg memory address mapping set

Parameters
mem_map this parameter can be one of the following values:
  • SCFG_MEM_MAP_MAIN_MEMORY
  • SCFG_MEM_MAP_BOOT_MEMORY
  • SCFG_MEM_MAP_XMC_BANK1
  • SCFG_MEM_MAP_INTERNAL_SRAM
  • SCFG_MEM_MAP_XMC_SDRAM_BANK1
Return values
none

Definition at line 100 of file at32f435_437_scfg.c.

Referenced by main().

◆ scfg_pins_ultra_driven_enable()

void scfg_pins_ultra_driven_enable | ( | scfg_ultra_driven_pins_type | value,
 |  | confirm_state | new_state
 | ) |  |

enable or disable gpio pins ultra driven.

Parameters
value this parameter can be one of the following values:
  • SCFG_ULTRA_DRIVEN_PB3
  • SCFG_ULTRA_DRIVEN_PB9
  • SCFG_ULTRA_DRIVEN_PB10
  • SCFG_ULTRA_DRIVEN_PD12
  • SCFG_ULTRA_DRIVEN_PD13
  • SCFG_ULTRA_DRIVEN_PD14
  • SCFG_ULTRA_DRIVEN_PD15
  • SCFG_ULTRA_DRIVEN_PF14
  • SCFG_ULTRA_DRIVEN_PF15
new_state (TRUE or FALSE)
Return values
none

Definition at line 196 of file at32f435_437_scfg.c.

◆ scfg_reset()

void scfg_reset ( void )

scfg reset

Parameters
none
Return values
none

Definition at line 49 of file at32f435_437_scfg.c.

◆ scfg_xmc_mapping_swap_set()

void scfg_xmc_mapping_swap_set ( scfg_xmc_swap_type xmc_swap )

scfg xmc address mapping swap set

Parameters
xmc_swap this parameter can be one of the following values:
  • SCFG_XMC_SWAP_NONE
  • SCFG_XMC_SWAP_MODE1
  • SCFG_XMC_SWAP_MODE2
  • SCFG_XMC_SWAP_MODE3
Return values
none

Definition at line 65 of file at32f435_437_scfg.c.


AT32F435/437 Firmwary Library: SDIO

Modules | Macros
SDIO
AT32F435_437_periph_driver

SDIO driver modules. More...

Modules

SDIO_interrupts_definition
sdio interrupt
SDIO_flags_definition
sdio flag
SDIO_exported_types
SDIO_exported_functions
SDIO_private_functions

Macros

#define | SDIO1 ((sdio_type *) SDIO1_BASE)
#define | SDIO2 ((sdio_type *) SDIO2_BASE)

Detailed Description

SDIO driver modules.

Macro Definition Documentation

◆ SDIO1

#define SDIO1 ((sdio_type *) SDIO1_BASE)

Definition at line 572 of file at32f435_437_sdio.h.

◆ SDIO2

#define SDIO2 ((sdio_type *) SDIO2_BASE)

Definition at line 573 of file at32f435_437_sdio.h.


AT32F435/437 Firmwary Library: SDIO_interrupts_definition

Macros
SDIO_interrupts_definition
AT32F435_437_periph_driver » SDIO

sdio interrupt More...

Macros

#define | SDIO_CMDFAIL_INT ((uint32_t)0x00000001)
#define | SDIO_DTFAIL_INT ((uint32_t)0x00000002)
#define | SDIO_CMDTIMEOUT_INT ((uint32_t)0x00000004)
#define | SDIO_DTTIMEOUT_INT ((uint32_t)0x00000008)
#define | SDIO_TXERRU_INT ((uint32_t)0x00000010)
#define | SDIO_RXERRO_INT ((uint32_t)0x00000020)
#define | SDIO_CMDRSPCMPL_INT ((uint32_t)0x00000040)
#define | SDIO_CMDCMPL_INT ((uint32_t)0x00000080)
#define | SDIO_DTCMP_INT ((uint32_t)0x00000100)
#define | SDIO_SBITERR_INT ((uint32_t)0x00000200)
#define | SDIO_DTBLKCMPL_INT ((uint32_t)0x00000400)
#define | SDIO_DOCMD_INT ((uint32_t)0x00000800)
#define | SDIO_DOTX_INT ((uint32_t)0x00001000)
#define | SDIO_DORX_INT ((uint32_t)0x00002000)
#define | SDIO_TXBUFH_INT ((uint32_t)0x00004000)
#define | SDIO_RXBUFH_INT ((uint32_t)0x00008000)
#define | SDIO_TXBUFF_INT ((uint32_t)0x00010000)
#define | SDIO_RXBUFF_INT ((uint32_t)0x00020000)
#define | SDIO_TXBUFE_INT ((uint32_t)0x00040000)
#define | SDIO_RXBUFE_INT ((uint32_t)0x00080000)
#define | SDIO_TXBUF_INT ((uint32_t)0x00100000)
#define | SDIO_RXBUF_INT ((uint32_t)0x00200000)
#define | SDIO_SDIOIF_INT ((uint32_t)0x00400000)

Detailed Description

sdio interrupt

Macro Definition Documentation

◆ SDIO_CMDCMPL_INT

#define SDIO_CMDCMPL_INT ((uint32_t)0x00000080)

command sent interrupt

Definition at line 59 of file at32f435_437_sdio.h.

◆ SDIO_CMDFAIL_INT

#define SDIO_CMDFAIL_INT ((uint32_t)0x00000001)

command response received check failed interrupt

Definition at line 52 of file at32f435_437_sdio.h.

◆ SDIO_CMDRSPCMPL_INT

#define SDIO_CMDRSPCMPL_INT ((uint32_t)0x00000040)

command response received interrupt

Definition at line 58 of file at32f435_437_sdio.h.

◆ SDIO_CMDTIMEOUT_INT

#define SDIO_CMDTIMEOUT_INT ((uint32_t)0x00000004)

command response timerout interrupt

Definition at line 54 of file at32f435_437_sdio.h.

◆ SDIO_DOCMD_INT

#define SDIO_DOCMD_INT ((uint32_t)0x00000800)

command transfer in progress interrupt

Definition at line 63 of file at32f435_437_sdio.h.

◆ SDIO_DORX_INT

#define SDIO_DORX_INT ((uint32_t)0x00002000)

data receive in progress interrupt

Definition at line 65 of file at32f435_437_sdio.h.

◆ SDIO_DOTX_INT

#define SDIO_DOTX_INT ((uint32_t)0x00001000)

data transmit in progress interrupt

Definition at line 64 of file at32f435_437_sdio.h.

◆ SDIO_DTBLKCMPL_INT

#define SDIO_DTBLKCMPL_INT ((uint32_t)0x00000400)

data block sent/received interrupt

Definition at line 62 of file at32f435_437_sdio.h.

◆ SDIO_DTCMP_INT

#define SDIO_DTCMP_INT ((uint32_t)0x00000100)

data sent interrupt

Definition at line 60 of file at32f435_437_sdio.h.

◆ SDIO_DTFAIL_INT

#define SDIO_DTFAIL_INT ((uint32_t)0x00000002)

data block sent/received check failed interrupt

Definition at line 53 of file at32f435_437_sdio.h.

◆ SDIO_DTTIMEOUT_INT

#define SDIO_DTTIMEOUT_INT ((uint32_t)0x00000008)

data timeout interrupt

Definition at line 55 of file at32f435_437_sdio.h.

◆ SDIO_RXBUF_INT

#define SDIO_RXBUF_INT ((uint32_t)0x00200000)

data available in receive interrupt

Definition at line 73 of file at32f435_437_sdio.h.

◆ SDIO_RXBUFE_INT

#define SDIO_RXBUFE_INT ((uint32_t)0x00080000)

receive buf empty interrupt

Definition at line 71 of file at32f435_437_sdio.h.

◆ SDIO_RXBUFF_INT

#define SDIO_RXBUFF_INT ((uint32_t)0x00020000)

receive buf full interrupt

Definition at line 69 of file at32f435_437_sdio.h.

◆ SDIO_RXBUFH_INT

#define SDIO_RXBUFH_INT ((uint32_t)0x00008000)

receive buf half full interrupt

Definition at line 67 of file at32f435_437_sdio.h.

◆ SDIO_RXERRO_INT

#define SDIO_RXERRO_INT ((uint32_t)0x00000020)

received overrun error interrupt

Definition at line 57 of file at32f435_437_sdio.h.

◆ SDIO_SBITERR_INT

#define SDIO_SBITERR_INT ((uint32_t)0x00000200)

start bit not detected on data bus interrupt

Definition at line 61 of file at32f435_437_sdio.h.

◆ SDIO_SDIOIF_INT

#define SDIO_SDIOIF_INT ((uint32_t)0x00400000)

sdio interface received interrupt

Definition at line 74 of file at32f435_437_sdio.h.

◆ SDIO_TXBUF_INT

#define SDIO_TXBUF_INT ((uint32_t)0x00100000)

data available in transmit interrupt

Definition at line 72 of file at32f435_437_sdio.h.

◆ SDIO_TXBUFE_INT

#define SDIO_TXBUFE_INT ((uint32_t)0x00040000)

transmit buf empty interrupt

Definition at line 70 of file at32f435_437_sdio.h.

◆ SDIO_TXBUFF_INT

#define SDIO_TXBUFF_INT ((uint32_t)0x00010000)

transmit buf full interrupt

Definition at line 68 of file at32f435_437_sdio.h.

◆ SDIO_TXBUFH_INT

#define SDIO_TXBUFH_INT ((uint32_t)0x00004000)

transmit buf half empty interrupt

Definition at line 66 of file at32f435_437_sdio.h.

◆ SDIO_TXERRU_INT

#define SDIO_TXERRU_INT ((uint32_t)0x00000010)

transmit underrun error interrupt

Definition at line 56 of file at32f435_437_sdio.h.


AT32F435/437 Firmwary Library: SDIO_flags_definition

Macros
SDIO_flags_definition
AT32F435_437_periph_driver » SDIO

sdio flag More...

Macros

#define | SDIO_CMDFAIL_FLAG ((uint32_t)0x00000001)
#define | SDIO_DTFAIL_FLAG ((uint32_t)0x00000002)
#define | SDIO_CMDTIMEOUT_FLAG ((uint32_t)0x00000004)
#define | SDIO_DTTIMEOUT_FLAG ((uint32_t)0x00000008)
#define | SDIO_TXERRU_FLAG ((uint32_t)0x00000010)
#define | SDIO_RXERRO_FLAG ((uint32_t)0x00000020)
#define | SDIO_CMDRSPCMPL_FLAG ((uint32_t)0x00000040)
#define | SDIO_CMDCMPL_FLAG ((uint32_t)0x00000080)
#define | SDIO_DTCMPL_FLAG ((uint32_t)0x00000100)
#define | SDIO_SBITERR_FLAG ((uint32_t)0x00000200)
#define | SDIO_DTBLKCMPL_FLAG ((uint32_t)0x00000400)
#define | SDIO_DOCMD_FLAG ((uint32_t)0x00000800)
#define | SDIO_DOTX_FLAG ((uint32_t)0x00001000)
#define | SDIO_DORX_FLAG ((uint32_t)0x00002000)
#define | SDIO_TXBUFH_FLAG ((uint32_t)0x00004000)
#define | SDIO_RXBUFH_FLAG ((uint32_t)0x00008000)
#define | SDIO_TXBUFF_FLAG ((uint32_t)0x00010000)
#define | SDIO_RXBUFF_FLAG ((uint32_t)0x00020000)
#define | SDIO_TXBUFE_FLAG ((uint32_t)0x00040000)
#define | SDIO_RXBUFE_FLAG ((uint32_t)0x00080000)
#define | SDIO_TXBUF_FLAG ((uint32_t)0x00100000)
#define | SDIO_RXBUF_FLAG ((uint32_t)0x00200000)
#define | SDIO_SDIOIF_FLAG ((uint32_t)0x00400000)

Detailed Description

sdio flag

Macro Definition Documentation

◆ SDIO_CMDCMPL_FLAG

#define SDIO_CMDCMPL_FLAG ((uint32_t)0x00000080)

command sent flag

Definition at line 92 of file at32f435_437_sdio.h.

◆ SDIO_CMDFAIL_FLAG

#define SDIO_CMDFAIL_FLAG ((uint32_t)0x00000001)

command response received check failed flag

Definition at line 85 of file at32f435_437_sdio.h.

◆ SDIO_CMDRSPCMPL_FLAG

#define SDIO_CMDRSPCMPL_FLAG ((uint32_t)0x00000040)

command response received flag

Definition at line 91 of file at32f435_437_sdio.h.

◆ SDIO_CMDTIMEOUT_FLAG

#define SDIO_CMDTIMEOUT_FLAG ((uint32_t)0x00000004)

command response timerout flag

Definition at line 87 of file at32f435_437_sdio.h.

◆ SDIO_DOCMD_FLAG

#define SDIO_DOCMD_FLAG ((uint32_t)0x00000800)

command transfer in progress flag

Definition at line 96 of file at32f435_437_sdio.h.

◆ SDIO_DORX_FLAG

#define SDIO_DORX_FLAG ((uint32_t)0x00002000)

data receive in progress flag

Definition at line 98 of file at32f435_437_sdio.h.

◆ SDIO_DOTX_FLAG

#define SDIO_DOTX_FLAG ((uint32_t)0x00001000)

data transmit in progress flag

Definition at line 97 of file at32f435_437_sdio.h.

◆ SDIO_DTBLKCMPL_FLAG

#define SDIO_DTBLKCMPL_FLAG ((uint32_t)0x00000400)

data block sent/received flag

Definition at line 95 of file at32f435_437_sdio.h.

◆ SDIO_DTCMPL_FLAG

#define SDIO_DTCMPL_FLAG ((uint32_t)0x00000100)

data sent flag

Definition at line 93 of file at32f435_437_sdio.h.

◆ SDIO_DTFAIL_FLAG

#define SDIO_DTFAIL_FLAG ((uint32_t)0x00000002)

data block sent/received check failed flag

Definition at line 86 of file at32f435_437_sdio.h.

◆ SDIO_DTTIMEOUT_FLAG

#define SDIO_DTTIMEOUT_FLAG ((uint32_t)0x00000008)

data timeout flag

Definition at line 88 of file at32f435_437_sdio.h.

◆ SDIO_RXBUF_FLAG

#define SDIO_RXBUF_FLAG ((uint32_t)0x00200000)

data available in receive flag

Definition at line 106 of file at32f435_437_sdio.h.

◆ SDIO_RXBUFE_FLAG

#define SDIO_RXBUFE_FLAG ((uint32_t)0x00080000)

receive buf empty flag

Definition at line 104 of file at32f435_437_sdio.h.

◆ SDIO_RXBUFF_FLAG

#define SDIO_RXBUFF_FLAG ((uint32_t)0x00020000)

receive buf full flag

Definition at line 102 of file at32f435_437_sdio.h.

◆ SDIO_RXBUFH_FLAG

#define SDIO_RXBUFH_FLAG ((uint32_t)0x00008000)

receive buf half full flag

Definition at line 100 of file at32f435_437_sdio.h.

◆ SDIO_RXERRO_FLAG

#define SDIO_RXERRO_FLAG ((uint32_t)0x00000020)

received overrun error flag

Definition at line 90 of file at32f435_437_sdio.h.

◆ SDIO_SBITERR_FLAG

#define SDIO_SBITERR_FLAG ((uint32_t)0x00000200)

start bit not detected on data bus flag

Definition at line 94 of file at32f435_437_sdio.h.

◆ SDIO_SDIOIF_FLAG

#define SDIO_SDIOIF_FLAG ((uint32_t)0x00400000)

sdio interface received flag

Definition at line 107 of file at32f435_437_sdio.h.

◆ SDIO_TXBUF_FLAG

#define SDIO_TXBUF_FLAG ((uint32_t)0x00100000)

data available in transmit flag

Definition at line 105 of file at32f435_437_sdio.h.

◆ SDIO_TXBUFE_FLAG

#define SDIO_TXBUFE_FLAG ((uint32_t)0x00040000)

transmit buf empty flag

Definition at line 103 of file at32f435_437_sdio.h.

◆ SDIO_TXBUFF_FLAG

#define SDIO_TXBUFF_FLAG ((uint32_t)0x00010000)

transmit buf full flag

Definition at line 101 of file at32f435_437_sdio.h.

◆ SDIO_TXBUFH_FLAG

#define SDIO_TXBUFH_FLAG ((uint32_t)0x00004000)

transmit buf half empty flag

Definition at line 99 of file at32f435_437_sdio.h.

◆ SDIO_TXERRU_FLAG

#define SDIO_TXERRU_FLAG ((uint32_t)0x00000010)

transmit underrun error flag

Definition at line 89 of file at32f435_437_sdio.h.


AT32F435/437 Firmwary Library: SDIO_exported_types

Data Structures | Enumerations | Variables
SDIO_exported_types
AT32F435_437_periph_driver » SDIO | AT32F435_periph_examples | AT32F437_periph_examples » SD_mmc_card | AT32F435_periph_examples | AT32F437_periph_examples » SDIO_fatfs

Data Structures

struct | sdio_command_struct_type
sdio command structure More...
struct | sdio_data_struct_type
sdio data structure More...
struct | sdio_type
type define sdio register all More...
struct | sd_csd_struct_type
struct | sd_cid_struct_type
struct | sd_scr_struct_type
struct | sd_card_info_struct_type

Enumerations

enum | sdio_power_state_type { SDIO_POWER_OFF = 0x00 , SDIO_POWER_ON = 0x03 }
sdio power state More...
enum | sdio_edge_phase_type { SDIO_CLOCK_EDGE_RISING = 0x00 , SDIO_CLOCK_EDGE_FALLING = 0x01 }
sdio edge phase More...
enum | sdio_bus_width_type { SDIO_BUS_WIDTH_D1 = 0x00 , SDIO_BUS_WIDTH_D4 = 0x01 , SDIO_BUS_WIDTH_D8 = 0x02 }
sdio bus width More...
enum | sdio_reponse_type { SDIO_RESPONSE_NO = 0x00 , SDIO_RESPONSE_SHORT = 0x01 , SDIO_RESPONSE_LONG = 0x03 }
sdio response type More...
enum | sdio_wait_type { SDIO_WAIT_FOR_NO = 0x00 , SDIO_WAIT_FOR_INT = 0x01 , SDIO_WAIT_FOR_PEND = 0x02 }
sdio wait type More...
enum | sdio_rsp_index_type { SDIO_RSP1_INDEX = 0x00 , SDIO_RSP2_INDEX = 0x01 , SDIO_RSP3_INDEX = 0x02 , SDIO_RSP4_INDEX = 0x03 }
sdio response register index More...
enum sdio_block_size_type {
SDIO_DATA_BLOCK_SIZE_1B = 0x00 , SDIO_DATA_BLOCK_SIZE_2B = 0x01 , SDIO_DATA_BLOCK_SIZE_4B = 0x02 , SDIO_DATA_BLOCK_SIZE_8B = 0x03 ,
SDIO_DATA_BLOCK_SIZE_16B = 0x04 , SDIO_DATA_BLOCK_SIZE_32B = 0x05 , SDIO_DATA_BLOCK_SIZE_64B = 0x06 , SDIO_DATA_BLOCK_SIZE_128B = 0x07 ,
SDIO_DATA_BLOCK_SIZE_256B = 0x08 , SDIO_DATA_BLOCK_SIZE_512B = 0x09 , SDIO_DATA_BLOCK_SIZE_1024B = 0x0A , SDIO_DATA_BLOCK_SIZE_2048B = 0x0B ,
SDIO_DATA_BLOCK_SIZE_4096B = 0x0C , SDIO_DATA_BLOCK_SIZE_8192B = 0x0D , SDIO_DATA_BLOCK_SIZE_16384B = 0x0E
}
sdio data block size More...
enum | sdio_transfer_mode_type { SDIO_DATA_BLOCK_TRANSFER = 0x00 , SDIO_DATA_STREAM_TRANSFER = 0x01 }
sdio data transfer mode More...
enum | sdio_transfer_direction_type { SDIO_DATA_TRANSFER_TO_CARD = 0x00 , SDIO_DATA_TRANSFER_TO_CONTROLLER = 0x01 }
sdio data transfer direction More...
enum | sdio_read_wait_mode_type { SDIO_READ_WAIT_CONTROLLED_BY_D2 = 0x00 , SDIO_READ_WAIT_CONTROLLED_BY_CK = 0x01 }
sdio read wait mode More...
enum sd_data_transfer_mode_type {
SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 , SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 ,
SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 , SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1
}
enum sd_error_status_type {
SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 , SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 ,
SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 , SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 ,
SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 , SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 ,
SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 , SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 ,
SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 , SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 ,
SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 , SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 ,
SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 , SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 ,
SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 , SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 ,
SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR , SD_NOT_CONFIGURED , SD_REQ_PENDING ,
SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER , SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW ,
SD_ERROR , SD_OK = 0 , SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 ,
SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 , SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 ,
SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 , SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 ,
SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 , SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 ,
SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 , SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 ,
SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 , SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 ,
SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 , SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 ,
SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 , SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 ,
SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 , SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR ,
SD_NOT_CONFIGURED , SD_REQ_PENDING , SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER ,
SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW , SD_ERROR , SD_OK = 0 ,
SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 , SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 ,
SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 , SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 ,
SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 , SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 ,
SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 , SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 ,
SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 , SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 ,
SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 , SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 ,
SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 , SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 ,
SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 , SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 ,
SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR , SD_NOT_CONFIGURED , SD_REQ_PENDING ,
SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER , SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW ,
SD_ERROR , SD_OK = 0 , SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 ,
SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 , SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 ,
SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 , SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 ,
SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 , SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 ,
SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 , SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 ,
SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 , SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 ,
SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 , SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 ,
SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 , SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 ,
SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 , SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR ,
SD_NOT_CONFIGURED , SD_REQ_PENDING , SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER ,
SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW , SD_ERROR , SD_OK = 0
}
enum sd_card_state_type {
SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) ,
SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) ,
SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) ,
SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) ,
SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) ,
SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) ,
SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) ,
SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) ,
SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF)
}
enum sd_memory_card_type {
SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 ,
SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 ,
SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 ,
SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 ,
SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 ,
SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 ,
SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 ,
SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 ,
SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8
}
enum sd_data_transfer_mode_type {
SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 , SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 ,
SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 , SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1
}
enum sd_error_status_type {
SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 , SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 ,
SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 , SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 ,
SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 , SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 ,
SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 , SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 ,
SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 , SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 ,
SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 , SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 ,
SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 , SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 ,
SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 , SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 ,
SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR , SD_NOT_CONFIGURED , SD_REQ_PENDING ,
SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER , SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW ,
SD_ERROR , SD_OK = 0 , SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 ,
SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 , SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 ,
SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 , SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 ,
SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 , SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 ,
SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 , SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 ,
SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 , SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 ,
SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 , SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 ,
SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 , SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 ,
SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 , SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR ,
SD_NOT_CONFIGURED , SD_REQ_PENDING , SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER ,
SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW , SD_ERROR , SD_OK = 0 ,
SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 , SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 ,
SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 , SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 ,
SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 , SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 ,
SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 , SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 ,
SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 , SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 ,
SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 , SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 ,
SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 , SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 ,
SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 , SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 ,
SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR , SD_NOT_CONFIGURED , SD_REQ_PENDING ,
SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER , SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW ,
SD_ERROR , SD_OK = 0 , SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 ,
SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 , SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 ,
SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 , SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 ,
SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 , SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 ,
SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 , SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 ,
SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 , SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 ,
SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 , SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 ,
SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 , SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 ,
SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 , SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR ,
SD_NOT_CONFIGURED , SD_REQ_PENDING , SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER ,
SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW , SD_ERROR , SD_OK = 0
}
enum sd_card_state_type {
SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) ,
SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) ,
SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) ,
SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) ,
SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) ,
SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) ,
SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) ,
SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) ,
SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF)
}
enum sd_memory_card_type {
SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 ,
SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 ,
SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 ,
SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 ,
SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 ,
SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 ,
SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 ,
SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 ,
SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8
}
enum sd_data_transfer_mode_type {
SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 , SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 ,
SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 , SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1
}
enum sd_error_status_type {
SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 , SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 ,
SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 , SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 ,
SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 , SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 ,
SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 , SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 ,
SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 , SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 ,
SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 , SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 ,
SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 , SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 ,
SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 , SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 ,
SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR , SD_NOT_CONFIGURED , SD_REQ_PENDING ,
SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER , SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW ,
SD_ERROR , SD_OK = 0 , SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 ,
SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 , SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 ,
SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 , SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 ,
SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 , SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 ,
SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 , SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 ,
SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 , SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 ,
SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 , SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 ,
SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 , SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 ,
SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 , SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR ,
SD_NOT_CONFIGURED , SD_REQ_PENDING , SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER ,
SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW , SD_ERROR , SD_OK = 0 ,
SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 , SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 ,
SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 , SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 ,
SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 , SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 ,
SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 , SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 ,
SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 , SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 ,
SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 , SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 ,
SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 , SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 ,
SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 , SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 ,
SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR , SD_NOT_CONFIGURED , SD_REQ_PENDING ,
SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER , SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW ,
SD_ERROR , SD_OK = 0 , SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 ,
SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 , SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 ,
SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 , SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 ,
SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 , SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 ,
SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 , SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 ,
SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 , SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 ,
SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 , SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 ,
SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 , SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 ,
SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 , SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR ,
SD_NOT_CONFIGURED , SD_REQ_PENDING , SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER ,
SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW , SD_ERROR , SD_OK = 0
}
enum sd_card_state_type {
SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) ,
SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) ,
SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) ,
SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) ,
SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) ,
SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) ,
SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) ,
SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) ,
SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF)
}
enum sd_memory_card_type {
SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 ,
SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 ,
SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 ,
SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 ,
SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 ,
SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 ,
SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 ,
SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 ,
SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8
}
enum sd_data_transfer_mode_type {
SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 , SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 ,
SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 , SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1
}
enum sd_error_status_type {
SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 , SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 ,
SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 , SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 ,
SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 , SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 ,
SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 , SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 ,
SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 , SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 ,
SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 , SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 ,
SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 , SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 ,
SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 , SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 ,
SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR , SD_NOT_CONFIGURED , SD_REQ_PENDING ,
SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER , SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW ,
SD_ERROR , SD_OK = 0 , SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 ,
SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 , SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 ,
SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 , SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 ,
SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 , SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 ,
SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 , SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 ,
SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 , SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 ,
SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 , SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 ,
SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 , SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 ,
SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 , SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR ,
SD_NOT_CONFIGURED , SD_REQ_PENDING , SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER ,
SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW , SD_ERROR , SD_OK = 0 ,
SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 , SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 ,
SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 , SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 ,
SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 , SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 ,
SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 , SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 ,
SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 , SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 ,
SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 , SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 ,
SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 , SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 ,
SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 , SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 ,
SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR , SD_NOT_CONFIGURED , SD_REQ_PENDING ,
SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER , SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW ,
SD_ERROR , SD_OK = 0 , SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 ,
SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 , SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 ,
SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 , SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 ,
SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 , SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 ,
SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 , SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 ,
SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 , SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 ,
SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 , SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 ,
SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 , SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 ,
SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 , SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR ,
SD_NOT_CONFIGURED , SD_REQ_PENDING , SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER ,
SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW , SD_ERROR , SD_OK = 0
}
enum sd_card_state_type {
SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) ,
SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) ,
SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) ,
SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) ,
SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) ,
SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) ,
SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) ,
SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) ,
SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF)
}
enum sd_memory_card_type {
SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 ,
SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 ,
SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 ,
SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 ,
SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 ,
SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 ,
SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 ,
SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 ,
SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8
}

Variables

sd_card_info_struct_type sd_card_info
sd_card_info_struct_type sd_card_info
sd_card_info_struct_type sd_card_info
sd_card_info_struct_type sd_card_info

Detailed Description

Enumeration Type Documentation

◆ sd_card_state_type [1/4]

enum sd_card_state_type

sd card status

Enumerator
SD_CARD_READY
SD_CARD_IDENTIFICATION
SD_CARD_STANDBY
SD_CARD_TRANSFER
SD_CARD_SENDING
SD_CARD_RECEIVING
SD_CARD_PROGRAMMING
SD_CARD_DISCONNECTED
SD_CARD_ERROR
SD_CARD_READY
SD_CARD_IDENTIFICATION
SD_CARD_STANDBY
SD_CARD_TRANSFER
SD_CARD_SENDING
SD_CARD_RECEIVING
SD_CARD_PROGRAMMING
SD_CARD_DISCONNECTED
SD_CARD_ERROR
SD_CARD_READY
SD_CARD_IDENTIFICATION
SD_CARD_STANDBY
SD_CARD_TRANSFER
SD_CARD_SENDING
SD_CARD_RECEIVING
SD_CARD_PROGRAMMING
SD_CARD_DISCONNECTED
SD_CARD_ERROR
SD_CARD_READY
SD_CARD_IDENTIFICATION
SD_CARD_STANDBY
SD_CARD_TRANSFER
SD_CARD_SENDING
SD_CARD_RECEIVING
SD_CARD_PROGRAMMING
SD_CARD_DISCONNECTED
SD_CARD_ERROR

Definition at line 187 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ sd_card_state_type [2/4]

enum sd_card_state_type

sd card status

Enumerator
SD_CARD_READY
SD_CARD_IDENTIFICATION
SD_CARD_STANDBY
SD_CARD_TRANSFER
SD_CARD_SENDING
SD_CARD_RECEIVING
SD_CARD_PROGRAMMING
SD_CARD_DISCONNECTED
SD_CARD_ERROR
SD_CARD_READY
SD_CARD_IDENTIFICATION
SD_CARD_STANDBY
SD_CARD_TRANSFER
SD_CARD_SENDING
SD_CARD_RECEIVING
SD_CARD_PROGRAMMING
SD_CARD_DISCONNECTED
SD_CARD_ERROR
SD_CARD_READY
SD_CARD_IDENTIFICATION
SD_CARD_STANDBY
SD_CARD_TRANSFER
SD_CARD_SENDING
SD_CARD_RECEIVING
SD_CARD_PROGRAMMING
SD_CARD_DISCONNECTED
SD_CARD_ERROR
SD_CARD_READY
SD_CARD_IDENTIFICATION
SD_CARD_STANDBY
SD_CARD_TRANSFER
SD_CARD_SENDING
SD_CARD_RECEIVING
SD_CARD_PROGRAMMING
SD_CARD_DISCONNECTED
SD_CARD_ERROR

Definition at line 187 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ sd_card_state_type [3/4]

enum sd_card_state_type

sd card status

Enumerator
SD_CARD_READY
SD_CARD_IDENTIFICATION
SD_CARD_STANDBY
SD_CARD_TRANSFER
SD_CARD_SENDING
SD_CARD_RECEIVING
SD_CARD_PROGRAMMING
SD_CARD_DISCONNECTED
SD_CARD_ERROR
SD_CARD_READY
SD_CARD_IDENTIFICATION
SD_CARD_STANDBY
SD_CARD_TRANSFER
SD_CARD_SENDING
SD_CARD_RECEIVING
SD_CARD_PROGRAMMING
SD_CARD_DISCONNECTED
SD_CARD_ERROR
SD_CARD_READY
SD_CARD_IDENTIFICATION
SD_CARD_STANDBY
SD_CARD_TRANSFER
SD_CARD_SENDING
SD_CARD_RECEIVING
SD_CARD_PROGRAMMING
SD_CARD_DISCONNECTED
SD_CARD_ERROR
SD_CARD_READY
SD_CARD_IDENTIFICATION
SD_CARD_STANDBY
SD_CARD_TRANSFER
SD_CARD_SENDING
SD_CARD_RECEIVING
SD_CARD_PROGRAMMING
SD_CARD_DISCONNECTED
SD_CARD_ERROR

Definition at line 187 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ sd_card_state_type [4/4]

enum sd_card_state_type

sd card status

Enumerator
SD_CARD_READY
SD_CARD_IDENTIFICATION
SD_CARD_STANDBY
SD_CARD_TRANSFER
SD_CARD_SENDING
SD_CARD_RECEIVING
SD_CARD_PROGRAMMING
SD_CARD_DISCONNECTED
SD_CARD_ERROR
SD_CARD_READY
SD_CARD_IDENTIFICATION
SD_CARD_STANDBY
SD_CARD_TRANSFER
SD_CARD_SENDING
SD_CARD_RECEIVING
SD_CARD_PROGRAMMING
SD_CARD_DISCONNECTED
SD_CARD_ERROR
SD_CARD_READY
SD_CARD_IDENTIFICATION
SD_CARD_STANDBY
SD_CARD_TRANSFER
SD_CARD_SENDING
SD_CARD_RECEIVING
SD_CARD_PROGRAMMING
SD_CARD_DISCONNECTED
SD_CARD_ERROR
SD_CARD_READY
SD_CARD_IDENTIFICATION
SD_CARD_STANDBY
SD_CARD_TRANSFER
SD_CARD_SENDING
SD_CARD_RECEIVING
SD_CARD_PROGRAMMING
SD_CARD_DISCONNECTED
SD_CARD_ERROR

Definition at line 187 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ sd_data_transfer_mode_type [1/4]

enum sd_data_transfer_mode_type

sdio data transfer mode

Enumerator
SD_TRANSFER_POLLING_MODE
SD_TRANSFER_DMA_MODE
SD_TRANSFER_POLLING_MODE
SD_TRANSFER_DMA_MODE
SD_TRANSFER_POLLING_MODE
SD_TRANSFER_DMA_MODE
SD_TRANSFER_POLLING_MODE
SD_TRANSFER_DMA_MODE

Definition at line 65 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ sd_data_transfer_mode_type [2/4]

enum sd_data_transfer_mode_type

sdio data transfer mode

Enumerator
SD_TRANSFER_POLLING_MODE
SD_TRANSFER_DMA_MODE
SD_TRANSFER_POLLING_MODE
SD_TRANSFER_DMA_MODE
SD_TRANSFER_POLLING_MODE
SD_TRANSFER_DMA_MODE
SD_TRANSFER_POLLING_MODE
SD_TRANSFER_DMA_MODE

Definition at line 65 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ sd_data_transfer_mode_type [3/4]

enum sd_data_transfer_mode_type

sdio data transfer mode

Enumerator
SD_TRANSFER_POLLING_MODE
SD_TRANSFER_DMA_MODE
SD_TRANSFER_POLLING_MODE
SD_TRANSFER_DMA_MODE
SD_TRANSFER_POLLING_MODE
SD_TRANSFER_DMA_MODE
SD_TRANSFER_POLLING_MODE
SD_TRANSFER_DMA_MODE

Definition at line 65 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ sd_data_transfer_mode_type [4/4]

enum sd_data_transfer_mode_type

sdio data transfer mode

Enumerator
SD_TRANSFER_POLLING_MODE
SD_TRANSFER_DMA_MODE
SD_TRANSFER_POLLING_MODE
SD_TRANSFER_DMA_MODE
SD_TRANSFER_POLLING_MODE
SD_TRANSFER_DMA_MODE
SD_TRANSFER_POLLING_MODE
SD_TRANSFER_DMA_MODE

Definition at line 65 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ sd_error_status_type [1/4]

enum sd_error_status_type

sdio error defines

Enumerator
SD_CMD_FAIL | command response received (but crc check error)
SD_DATA_FAIL | data bock sent/received (crc check error)
SD_CMD_RSP_TIMEOUT | command response timeout
SD_DATA_TIMEOUT | data time out
SD_TX_UNDERRUN | transmit fifo under-run
SD_RX_OVERRUN | receive fifo over-run
SD_START_BIT_ERR | start bit not detected on all data signals in wide bus mode
SD_CMD_OUT_OF_RANGE | cmd's argument was out of range.
SD_ADDR_MISALIGNED | misaligned address
SD_BLK_LEN_ERR | transferred block length is not allowed for the card or the number of transferred bytes does not match the block length
SD_ERASE_SEQ_ERR | an error in the sequence of erase command occurs.
SD_INVALID_ERASE_PARAM | an invalid selection for erase groups
SD_WR_PROTECT_VIOLATION | attempt to program a write protect block
SD_LOCK_UNLOCK_ERROR | sequence or password error has been detected in unlock command or if there was an attempt to access a locked card
SD_CMD_CRC_ERROR | crc check of the previous command error
SD_ILLEGAL_CMD | command is not legal for the card state
SD_CARD_ECC_ERROR | card internal ecc was applied but error to correct the data
SD_CARD_CONTROLLER_ERR | internal card controller error
SD_GENERAL_UNKNOWN_ERROR | general or unknown error
SD_STREAM_RD_UNDERRUN | the card could not sustain data transfer in stream read operation.
SD_STREAM_WR_OVERRUN | the card could not sustain data programming in stream mode
SD_CID_CSD_OVERWRITE | cid/csd overwrite error
SD_WP_ERASE_SKIP | only partial address space was erased
SD_CARD_ECC_DISABLED | command has been executed without using internal ecc
SD_ERASE_RESET | erase sequence was cleared before executing because an out of erase sequence command was received
SD_AKE_SEQ_ERROR | error in sequence of authentication.
SD_INVALID_VOLTRANGE | invalid voltage range
SD_ADDR_OUT_OF_RANGE | address out of range
SD_SWITCH_ERROR | switch error
SD_SDIO_DISABLED | sdio disabled
SD_SDIO_FUNC_BUSY | function busy
SD_SDIO_FUNC_ERROR | function error
SD_SDIO_UNKNOWN_FUNC | unknown function
SD_INTERNAL_ERROR | internal error
SD_NOT_CONFIGURED | sdio doesn't configuration
SD_REQ_PENDING | request pending
SD_REQ_NOT_APPLICABLE | request isn't applicable
SD_INVALID_PARAMETER | invalid parameter
SD_UNSUPPORTED_FEATURE | unsupported feature
SD_UNSUPPORTED_HW | unsupported hardware
SD_ERROR | error
SD_OK | pass
SD_CMD_FAIL | command response received (but crc check error)
SD_DATA_FAIL | data bock sent/received (crc check error)
SD_CMD_RSP_TIMEOUT | command response timeout
SD_DATA_TIMEOUT | data time out
SD_TX_UNDERRUN | transmit fifo under-run
SD_RX_OVERRUN | receive fifo over-run
SD_START_BIT_ERR | start bit not detected on all data signals in wide bus mode
SD_CMD_OUT_OF_RANGE | cmd's argument was out of range.
SD_ADDR_MISALIGNED | misaligned address
SD_BLK_LEN_ERR | transferred block length is not allowed for the card or the number of transferred bytes does not match the block length
SD_ERASE_SEQ_ERR | an error in the sequence of erase command occurs.
SD_INVALID_ERASE_PARAM | an invalid selection for erase groups
SD_WR_PROTECT_VIOLATION | attempt to program a write protect block
SD_LOCK_UNLOCK_ERROR | sequence or password error has been detected in unlock command or if there was an attempt to access a locked card
SD_CMD_CRC_ERROR | crc check of the previous command error
SD_ILLEGAL_CMD | command is not legal for the card state
SD_CARD_ECC_ERROR | card internal ecc was applied but error to correct the data
SD_CARD_CONTROLLER_ERR | internal card controller error
SD_GENERAL_UNKNOWN_ERROR | general or unknown error
SD_STREAM_RD_UNDERRUN | the card could not sustain data transfer in stream read operation.
SD_STREAM_WR_OVERRUN | the card could not sustain data programming in stream mode
SD_CID_CSD_OVERWRITE | cid/csd overwrite error
SD_WP_ERASE_SKIP | only partial address space was erased
SD_CARD_ECC_DISABLED | command has been executed without using internal ecc
SD_ERASE_RESET | erase sequence was cleared before executing because an out of erase sequence command was received
SD_AKE_SEQ_ERROR | error in sequence of authentication.
SD_INVALID_VOLTRANGE | invalid voltage range
SD_ADDR_OUT_OF_RANGE | address out of range
SD_SWITCH_ERROR | switch error
SD_SDIO_DISABLED | sdio disabled
SD_SDIO_FUNC_BUSY | function busy
SD_SDIO_FUNC_ERROR | function error
SD_SDIO_UNKNOWN_FUNC | unknown function
SD_INTERNAL_ERROR | internal error
SD_NOT_CONFIGURED | sdio doesn't configuration
SD_REQ_PENDING | request pending
SD_REQ_NOT_APPLICABLE | request isn't applicable
SD_INVALID_PARAMETER | invalid parameter
SD_UNSUPPORTED_FEATURE | unsupported feature
SD_UNSUPPORTED_HW | unsupported hardware
SD_ERROR | error
SD_OK | pass
SD_CMD_FAIL | command response received (but crc check error)
SD_DATA_FAIL | data bock sent/received (crc check error)
SD_CMD_RSP_TIMEOUT | command response timeout
SD_DATA_TIMEOUT | data time out
SD_TX_UNDERRUN | transmit fifo under-run
SD_RX_OVERRUN | receive fifo over-run
SD_START_BIT_ERR | start bit not detected on all data signals in wide bus mode
SD_CMD_OUT_OF_RANGE | cmd's argument was out of range.
SD_ADDR_MISALIGNED | misaligned address
SD_BLK_LEN_ERR | transferred block length is not allowed for the card or the number of transferred bytes does not match the block length
SD_ERASE_SEQ_ERR | an error in the sequence of erase command occurs.
SD_INVALID_ERASE_PARAM | an invalid selection for erase groups
SD_WR_PROTECT_VIOLATION | attempt to program a write protect block
SD_LOCK_UNLOCK_ERROR | sequence or password error has been detected in unlock command or if there was an attempt to access a locked card
SD_CMD_CRC_ERROR | crc check of the previous command error
SD_ILLEGAL_CMD | command is not legal for the card state
SD_CARD_ECC_ERROR | card internal ecc was applied but error to correct the data
SD_CARD_CONTROLLER_ERR | internal card controller error
SD_GENERAL_UNKNOWN_ERROR | general or unknown error
SD_STREAM_RD_UNDERRUN | the card could not sustain data transfer in stream read operation.
SD_STREAM_WR_OVERRUN | the card could not sustain data programming in stream mode
SD_CID_CSD_OVERWRITE | cid/csd overwrite error
SD_WP_ERASE_SKIP | only partial address space was erased
SD_CARD_ECC_DISABLED | command has been executed without using internal ecc
SD_ERASE_RESET | erase sequence was cleared before executing because an out of erase sequence command was received
SD_AKE_SEQ_ERROR | error in sequence of authentication.
SD_INVALID_VOLTRANGE | invalid voltage range
SD_ADDR_OUT_OF_RANGE | address out of range
SD_SWITCH_ERROR | switch error
SD_SDIO_DISABLED | sdio disabled
SD_SDIO_FUNC_BUSY | function busy
SD_SDIO_FUNC_ERROR | function error
SD_SDIO_UNKNOWN_FUNC | unknown function
SD_INTERNAL_ERROR | internal error
SD_NOT_CONFIGURED | sdio doesn't configuration
SD_REQ_PENDING | request pending
SD_REQ_NOT_APPLICABLE | request isn't applicable
SD_INVALID_PARAMETER | invalid parameter
SD_UNSUPPORTED_FEATURE | unsupported feature
SD_UNSUPPORTED_HW | unsupported hardware
SD_ERROR | error
SD_OK | pass
SD_CMD_FAIL | command response received (but crc check error)
SD_DATA_FAIL | data bock sent/received (crc check error)
SD_CMD_RSP_TIMEOUT | command response timeout
SD_DATA_TIMEOUT | data time out
SD_TX_UNDERRUN | transmit fifo under-run
SD_RX_OVERRUN | receive fifo over-run
SD_START_BIT_ERR | start bit not detected on all data signals in wide bus mode
SD_CMD_OUT_OF_RANGE | cmd's argument was out of range.
SD_ADDR_MISALIGNED | misaligned address
SD_BLK_LEN_ERR | transferred block length is not allowed for the card or the number of transferred bytes does not match the block length
SD_ERASE_SEQ_ERR | an error in the sequence of erase command occurs.
SD_INVALID_ERASE_PARAM | an invalid selection for erase groups
SD_WR_PROTECT_VIOLATION | attempt to program a write protect block
SD_LOCK_UNLOCK_ERROR | sequence or password error has been detected in unlock command or if there was an attempt to access a locked card
SD_CMD_CRC_ERROR | crc check of the previous command error
SD_ILLEGAL_CMD | command is not legal for the card state
SD_CARD_ECC_ERROR | card internal ecc was applied but error to correct the data
SD_CARD_CONTROLLER_ERR | internal card controller error
SD_GENERAL_UNKNOWN_ERROR | general or unknown error
SD_STREAM_RD_UNDERRUN | the card could not sustain data transfer in stream read operation.
SD_STREAM_WR_OVERRUN | the card could not sustain data programming in stream mode
SD_CID_CSD_OVERWRITE | cid/csd overwrite error
SD_WP_ERASE_SKIP | only partial address space was erased
SD_CARD_ECC_DISABLED | command has been executed without using internal ecc
SD_ERASE_RESET | erase sequence was cleared before executing because an out of erase sequence command was received
SD_AKE_SEQ_ERROR | error in sequence of authentication.
SD_INVALID_VOLTRANGE | invalid voltage range
SD_ADDR_OUT_OF_RANGE | address out of range
SD_SWITCH_ERROR | switch error
SD_SDIO_DISABLED | sdio disabled
SD_SDIO_FUNC_BUSY | function busy
SD_SDIO_FUNC_ERROR | function error
SD_SDIO_UNKNOWN_FUNC | unknown function
SD_INTERNAL_ERROR | internal error
SD_NOT_CONFIGURED | sdio doesn't configuration
SD_REQ_PENDING | request pending
SD_REQ_NOT_APPLICABLE | request isn't applicable
SD_INVALID_PARAMETER | invalid parameter
SD_UNSUPPORTED_FEATURE | unsupported feature
SD_UNSUPPORTED_HW | unsupported hardware
SD_ERROR | error
SD_OK | pass

Definition at line 74 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ sd_error_status_type [2/4]

enum sd_error_status_type

sdio error defines

Enumerator
SD_CMD_FAIL | command response received (but crc check error)
SD_DATA_FAIL | data bock sent/received (crc check error)
SD_CMD_RSP_TIMEOUT | command response timeout
SD_DATA_TIMEOUT | data time out
SD_TX_UNDERRUN | transmit fifo under-run
SD_RX_OVERRUN | receive fifo over-run
SD_START_BIT_ERR | start bit not detected on all data signals in wide bus mode
SD_CMD_OUT_OF_RANGE | cmd's argument was out of range.
SD_ADDR_MISALIGNED | misaligned address
SD_BLK_LEN_ERR | transferred block length is not allowed for the card or the number of transferred bytes does not match the block length
SD_ERASE_SEQ_ERR | an error in the sequence of erase command occurs.
SD_INVALID_ERASE_PARAM | an invalid selection for erase groups
SD_WR_PROTECT_VIOLATION | attempt to program a write protect block
SD_LOCK_UNLOCK_ERROR | sequence or password error has been detected in unlock command or if there was an attempt to access a locked card
SD_CMD_CRC_ERROR | crc check of the previous command error
SD_ILLEGAL_CMD | command is not legal for the card state
SD_CARD_ECC_ERROR | card internal ecc was applied but error to correct the data
SD_CARD_CONTROLLER_ERR | internal card controller error
SD_GENERAL_UNKNOWN_ERROR | general or unknown error
SD_STREAM_RD_UNDERRUN | the card could not sustain data transfer in stream read operation.
SD_STREAM_WR_OVERRUN | the card could not sustain data programming in stream mode
SD_CID_CSD_OVERWRITE | cid/csd overwrite error
SD_WP_ERASE_SKIP | only partial address space was erased
SD_CARD_ECC_DISABLED | command has been executed without using internal ecc
SD_ERASE_RESET | erase sequence was cleared before executing because an out of erase sequence command was received
SD_AKE_SEQ_ERROR | error in sequence of authentication.
SD_INVALID_VOLTRANGE | invalid voltage range
SD_ADDR_OUT_OF_RANGE | address out of range
SD_SWITCH_ERROR | switch error
SD_SDIO_DISABLED | sdio disabled
SD_SDIO_FUNC_BUSY | function busy
SD_SDIO_FUNC_ERROR | function error
SD_SDIO_UNKNOWN_FUNC | unknown function
SD_INTERNAL_ERROR | internal error
SD_NOT_CONFIGURED | sdio doesn't configuration
SD_REQ_PENDING | request pending
SD_REQ_NOT_APPLICABLE | request isn't applicable
SD_INVALID_PARAMETER | invalid parameter
SD_UNSUPPORTED_FEATURE | unsupported feature
SD_UNSUPPORTED_HW | unsupported hardware
SD_ERROR | error
SD_OK | pass
SD_CMD_FAIL | command response received (but crc check error)
SD_DATA_FAIL | data bock sent/received (crc check error)
SD_CMD_RSP_TIMEOUT | command response timeout
SD_DATA_TIMEOUT | data time out
SD_TX_UNDERRUN | transmit fifo under-run
SD_RX_OVERRUN | receive fifo over-run
SD_START_BIT_ERR | start bit not detected on all data signals in wide bus mode
SD_CMD_OUT_OF_RANGE | cmd's argument was out of range.
SD_ADDR_MISALIGNED | misaligned address
SD_BLK_LEN_ERR | transferred block length is not allowed for the card or the number of transferred bytes does not match the block length
SD_ERASE_SEQ_ERR | an error in the sequence of erase command occurs.
SD_INVALID_ERASE_PARAM | an invalid selection for erase groups
SD_WR_PROTECT_VIOLATION | attempt to program a write protect block
SD_LOCK_UNLOCK_ERROR | sequence or password error has been detected in unlock command or if there was an attempt to access a locked card
SD_CMD_CRC_ERROR | crc check of the previous command error
SD_ILLEGAL_CMD | command is not legal for the card state
SD_CARD_ECC_ERROR | card internal ecc was applied but error to correct the data
SD_CARD_CONTROLLER_ERR | internal card controller error
SD_GENERAL_UNKNOWN_ERROR | general or unknown error
SD_STREAM_RD_UNDERRUN | the card could not sustain data transfer in stream read operation.
SD_STREAM_WR_OVERRUN | the card could not sustain data programming in stream mode
SD_CID_CSD_OVERWRITE | cid/csd overwrite error
SD_WP_ERASE_SKIP | only partial address space was erased
SD_CARD_ECC_DISABLED | command has been executed without using internal ecc
SD_ERASE_RESET | erase sequence was cleared before executing because an out of erase sequence command was received
SD_AKE_SEQ_ERROR | error in sequence of authentication.
SD_INVALID_VOLTRANGE | invalid voltage range
SD_ADDR_OUT_OF_RANGE | address out of range
SD_SWITCH_ERROR | switch error
SD_SDIO_DISABLED | sdio disabled
SD_SDIO_FUNC_BUSY | function busy
SD_SDIO_FUNC_ERROR | function error
SD_SDIO_UNKNOWN_FUNC | unknown function
SD_INTERNAL_ERROR | internal error
SD_NOT_CONFIGURED | sdio doesn't configuration
SD_REQ_PENDING | request pending
SD_REQ_NOT_APPLICABLE | request isn't applicable
SD_INVALID_PARAMETER | invalid parameter
SD_UNSUPPORTED_FEATURE | unsupported feature
SD_UNSUPPORTED_HW | unsupported hardware
SD_ERROR | error
SD_OK | pass
SD_CMD_FAIL | command response received (but crc check error)
SD_DATA_FAIL | data bock sent/received (crc check error)
SD_CMD_RSP_TIMEOUT | command response timeout
SD_DATA_TIMEOUT | data time out
SD_TX_UNDERRUN | transmit fifo under-run
SD_RX_OVERRUN | receive fifo over-run
SD_START_BIT_ERR | start bit not detected on all data signals in wide bus mode
SD_CMD_OUT_OF_RANGE | cmd's argument was out of range.
SD_ADDR_MISALIGNED | misaligned address
SD_BLK_LEN_ERR | transferred block length is not allowed for the card or the number of transferred bytes does not match the block length
SD_ERASE_SEQ_ERR | an error in the sequence of erase command occurs.
SD_INVALID_ERASE_PARAM | an invalid selection for erase groups
SD_WR_PROTECT_VIOLATION | attempt to program a write protect block
SD_LOCK_UNLOCK_ERROR | sequence or password error has been detected in unlock command or if there was an attempt to access a locked card
SD_CMD_CRC_ERROR | crc check of the previous command error
SD_ILLEGAL_CMD | command is not legal for the card state
SD_CARD_ECC_ERROR | card internal ecc was applied but error to correct the data
SD_CARD_CONTROLLER_ERR | internal card controller error
SD_GENERAL_UNKNOWN_ERROR | general or unknown error
SD_STREAM_RD_UNDERRUN | the card could not sustain data transfer in stream read operation.
SD_STREAM_WR_OVERRUN | the card could not sustain data programming in stream mode
SD_CID_CSD_OVERWRITE | cid/csd overwrite error
SD_WP_ERASE_SKIP | only partial address space was erased
SD_CARD_ECC_DISABLED | command has been executed without using internal ecc
SD_ERASE_RESET | erase sequence was cleared before executing because an out of erase sequence command was received
SD_AKE_SEQ_ERROR | error in sequence of authentication.
SD_INVALID_VOLTRANGE | invalid voltage range
SD_ADDR_OUT_OF_RANGE | address out of range
SD_SWITCH_ERROR | switch error
SD_SDIO_DISABLED | sdio disabled
SD_SDIO_FUNC_BUSY | function busy
SD_SDIO_FUNC_ERROR | function error
SD_SDIO_UNKNOWN_FUNC | unknown function
SD_INTERNAL_ERROR | internal error
SD_NOT_CONFIGURED | sdio doesn't configuration
SD_REQ_PENDING | request pending
SD_REQ_NOT_APPLICABLE | request isn't applicable
SD_INVALID_PARAMETER | invalid parameter
SD_UNSUPPORTED_FEATURE | unsupported feature
SD_UNSUPPORTED_HW | unsupported hardware
SD_ERROR | error
SD_OK | pass
SD_CMD_FAIL | command response received (but crc check error)
SD_DATA_FAIL | data bock sent/received (crc check error)
SD_CMD_RSP_TIMEOUT | command response timeout
SD_DATA_TIMEOUT | data time out
SD_TX_UNDERRUN | transmit fifo under-run
SD_RX_OVERRUN | receive fifo over-run
SD_START_BIT_ERR | start bit not detected on all data signals in wide bus mode
SD_CMD_OUT_OF_RANGE | cmd's argument was out of range.
SD_ADDR_MISALIGNED | misaligned address
SD_BLK_LEN_ERR | transferred block length is not allowed for the card or the number of transferred bytes does not match the block length
SD_ERASE_SEQ_ERR | an error in the sequence of erase command occurs.
SD_INVALID_ERASE_PARAM | an invalid selection for erase groups
SD_WR_PROTECT_VIOLATION | attempt to program a write protect block
SD_LOCK_UNLOCK_ERROR | sequence or password error has been detected in unlock command or if there was an attempt to access a locked card
SD_CMD_CRC_ERROR | crc check of the previous command error
SD_ILLEGAL_CMD | command is not legal for the card state
SD_CARD_ECC_ERROR | card internal ecc was applied but error to correct the data
SD_CARD_CONTROLLER_ERR | internal card controller error
SD_GENERAL_UNKNOWN_ERROR | general or unknown error
SD_STREAM_RD_UNDERRUN | the card could not sustain data transfer in stream read operation.
SD_STREAM_WR_OVERRUN | the card could not sustain data programming in stream mode
SD_CID_CSD_OVERWRITE | cid/csd overwrite error
SD_WP_ERASE_SKIP | only partial address space was erased
SD_CARD_ECC_DISABLED | command has been executed without using internal ecc
SD_ERASE_RESET | erase sequence was cleared before executing because an out of erase sequence command was received
SD_AKE_SEQ_ERROR | error in sequence of authentication.
SD_INVALID_VOLTRANGE | invalid voltage range
SD_ADDR_OUT_OF_RANGE | address out of range
SD_SWITCH_ERROR | switch error
SD_SDIO_DISABLED | sdio disabled
SD_SDIO_FUNC_BUSY | function busy
SD_SDIO_FUNC_ERROR | function error
SD_SDIO_UNKNOWN_FUNC | unknown function
SD_INTERNAL_ERROR | internal error
SD_NOT_CONFIGURED | sdio doesn't configuration
SD_REQ_PENDING | request pending
SD_REQ_NOT_APPLICABLE | request isn't applicable
SD_INVALID_PARAMETER | invalid parameter
SD_UNSUPPORTED_FEATURE | unsupported feature
SD_UNSUPPORTED_HW | unsupported hardware
SD_ERROR | error
SD_OK | pass

Definition at line 74 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ sd_error_status_type [3/4]

enum sd_error_status_type

sdio error defines

Enumerator
SD_CMD_FAIL | command response received (but crc check error)
SD_DATA_FAIL | data bock sent/received (crc check error)
SD_CMD_RSP_TIMEOUT | command response timeout
SD_DATA_TIMEOUT | data time out
SD_TX_UNDERRUN | transmit fifo under-run
SD_RX_OVERRUN | receive fifo over-run
SD_START_BIT_ERR | start bit not detected on all data signals in wide bus mode
SD_CMD_OUT_OF_RANGE | cmd's argument was out of range.
SD_ADDR_MISALIGNED | misaligned address
SD_BLK_LEN_ERR | transferred block length is not allowed for the card or the number of transferred bytes does not match the block length
SD_ERASE_SEQ_ERR | an error in the sequence of erase command occurs.
SD_INVALID_ERASE_PARAM | an invalid selection for erase groups
SD_WR_PROTECT_VIOLATION | attempt to program a write protect block
SD_LOCK_UNLOCK_ERROR | sequence or password error has been detected in unlock command or if there was an attempt to access a locked card
SD_CMD_CRC_ERROR | crc check of the previous command error
SD_ILLEGAL_CMD | command is not legal for the card state
SD_CARD_ECC_ERROR | card internal ecc was applied but error to correct the data
SD_CARD_CONTROLLER_ERR | internal card controller error
SD_GENERAL_UNKNOWN_ERROR | general or unknown error
SD_STREAM_RD_UNDERRUN | the card could not sustain data transfer in stream read operation.
SD_STREAM_WR_OVERRUN | the card could not sustain data programming in stream mode
SD_CID_CSD_OVERWRITE | cid/csd overwrite error
SD_WP_ERASE_SKIP | only partial address space was erased
SD_CARD_ECC_DISABLED | command has been executed without using internal ecc
SD_ERASE_RESET | erase sequence was cleared before executing because an out of erase sequence command was received
SD_AKE_SEQ_ERROR | error in sequence of authentication.
SD_INVALID_VOLTRANGE | invalid voltage range
SD_ADDR_OUT_OF_RANGE | address out of range
SD_SWITCH_ERROR | switch error
SD_SDIO_DISABLED | sdio disabled
SD_SDIO_FUNC_BUSY | function busy
SD_SDIO_FUNC_ERROR | function error
SD_SDIO_UNKNOWN_FUNC | unknown function
SD_INTERNAL_ERROR | internal error
SD_NOT_CONFIGURED | sdio doesn't configuration
SD_REQ_PENDING | request pending
SD_REQ_NOT_APPLICABLE | request isn't applicable
SD_INVALID_PARAMETER | invalid parameter
SD_UNSUPPORTED_FEATURE | unsupported feature
SD_UNSUPPORTED_HW | unsupported hardware
SD_ERROR | error
SD_OK | pass
SD_CMD_FAIL | command response received (but crc check error)
SD_DATA_FAIL | data bock sent/received (crc check error)
SD_CMD_RSP_TIMEOUT | command response timeout
SD_DATA_TIMEOUT | data time out
SD_TX_UNDERRUN | transmit fifo under-run
SD_RX_OVERRUN | receive fifo over-run
SD_START_BIT_ERR | start bit not detected on all data signals in wide bus mode
SD_CMD_OUT_OF_RANGE | cmd's argument was out of range.
SD_ADDR_MISALIGNED | misaligned address
SD_BLK_LEN_ERR | transferred block length is not allowed for the card or the number of transferred bytes does not match the block length
SD_ERASE_SEQ_ERR | an error in the sequence of erase command occurs.
SD_INVALID_ERASE_PARAM | an invalid selection for erase groups
SD_WR_PROTECT_VIOLATION | attempt to program a write protect block
SD_LOCK_UNLOCK_ERROR | sequence or password error has been detected in unlock command or if there was an attempt to access a locked card
SD_CMD_CRC_ERROR | crc check of the previous command error
SD_ILLEGAL_CMD | command is not legal for the card state
SD_CARD_ECC_ERROR | card internal ecc was applied but error to correct the data
SD_CARD_CONTROLLER_ERR | internal card controller error
SD_GENERAL_UNKNOWN_ERROR | general or unknown error
SD_STREAM_RD_UNDERRUN | the card could not sustain data transfer in stream read operation.
SD_STREAM_WR_OVERRUN | the card could not sustain data programming in stream mode
SD_CID_CSD_OVERWRITE | cid/csd overwrite error
SD_WP_ERASE_SKIP | only partial address space was erased
SD_CARD_ECC_DISABLED | command has been executed without using internal ecc
SD_ERASE_RESET | erase sequence was cleared before executing because an out of erase sequence command was received
SD_AKE_SEQ_ERROR | error in sequence of authentication.
SD_INVALID_VOLTRANGE | invalid voltage range
SD_ADDR_OUT_OF_RANGE | address out of range
SD_SWITCH_ERROR | switch error
SD_SDIO_DISABLED | sdio disabled
SD_SDIO_FUNC_BUSY | function busy
SD_SDIO_FUNC_ERROR | function error
SD_SDIO_UNKNOWN_FUNC | unknown function
SD_INTERNAL_ERROR | internal error
SD_NOT_CONFIGURED | sdio doesn't configuration
SD_REQ_PENDING | request pending
SD_REQ_NOT_APPLICABLE | request isn't applicable
SD_INVALID_PARAMETER | invalid parameter
SD_UNSUPPORTED_FEATURE | unsupported feature
SD_UNSUPPORTED_HW | unsupported hardware
SD_ERROR | error
SD_OK | pass
SD_CMD_FAIL | command response received (but crc check error)
SD_DATA_FAIL | data bock sent/received (crc check error)
SD_CMD_RSP_TIMEOUT | command response timeout
SD_DATA_TIMEOUT | data time out
SD_TX_UNDERRUN | transmit fifo under-run
SD_RX_OVERRUN | receive fifo over-run
SD_START_BIT_ERR | start bit not detected on all data signals in wide bus mode
SD_CMD_OUT_OF_RANGE | cmd's argument was out of range.
SD_ADDR_MISALIGNED | misaligned address
SD_BLK_LEN_ERR | transferred block length is not allowed for the card or the number of transferred bytes does not match the block length
SD_ERASE_SEQ_ERR | an error in the sequence of erase command occurs.
SD_INVALID_ERASE_PARAM | an invalid selection for erase groups
SD_WR_PROTECT_VIOLATION | attempt to program a write protect block
SD_LOCK_UNLOCK_ERROR | sequence or password error has been detected in unlock command or if there was an attempt to access a locked card
SD_CMD_CRC_ERROR | crc check of the previous command error
SD_ILLEGAL_CMD | command is not legal for the card state
SD_CARD_ECC_ERROR | card internal ecc was applied but error to correct the data
SD_CARD_CONTROLLER_ERR | internal card controller error
SD_GENERAL_UNKNOWN_ERROR | general or unknown error
SD_STREAM_RD_UNDERRUN | the card could not sustain data transfer in stream read operation.
SD_STREAM_WR_OVERRUN | the card could not sustain data programming in stream mode
SD_CID_CSD_OVERWRITE | cid/csd overwrite error
SD_WP_ERASE_SKIP | only partial address space was erased
SD_CARD_ECC_DISABLED | command has been executed without using internal ecc
SD_ERASE_RESET | erase sequence was cleared before executing because an out of erase sequence command was received
SD_AKE_SEQ_ERROR | error in sequence of authentication.
SD_INVALID_VOLTRANGE | invalid voltage range
SD_ADDR_OUT_OF_RANGE | address out of range
SD_SWITCH_ERROR | switch error
SD_SDIO_DISABLED | sdio disabled
SD_SDIO_FUNC_BUSY | function busy
SD_SDIO_FUNC_ERROR | function error
SD_SDIO_UNKNOWN_FUNC | unknown function
SD_INTERNAL_ERROR | internal error
SD_NOT_CONFIGURED | sdio doesn't configuration
SD_REQ_PENDING | request pending
SD_REQ_NOT_APPLICABLE | request isn't applicable
SD_INVALID_PARAMETER | invalid parameter
SD_UNSUPPORTED_FEATURE | unsupported feature
SD_UNSUPPORTED_HW | unsupported hardware
SD_ERROR | error
SD_OK | pass
SD_CMD_FAIL | command response received (but crc check error)
SD_DATA_FAIL | data bock sent/received (crc check error)
SD_CMD_RSP_TIMEOUT | command response timeout
SD_DATA_TIMEOUT | data time out
SD_TX_UNDERRUN | transmit fifo under-run
SD_RX_OVERRUN | receive fifo over-run
SD_START_BIT_ERR | start bit not detected on all data signals in wide bus mode
SD_CMD_OUT_OF_RANGE | cmd's argument was out of range.
SD_ADDR_MISALIGNED | misaligned address
SD_BLK_LEN_ERR | transferred block length is not allowed for the card or the number of transferred bytes does not match the block length
SD_ERASE_SEQ_ERR | an error in the sequence of erase command occurs.
SD_INVALID_ERASE_PARAM | an invalid selection for erase groups
SD_WR_PROTECT_VIOLATION | attempt to program a write protect block
SD_LOCK_UNLOCK_ERROR | sequence or password error has been detected in unlock command or if there was an attempt to access a locked card
SD_CMD_CRC_ERROR | crc check of the previous command error
SD_ILLEGAL_CMD | command is not legal for the card state
SD_CARD_ECC_ERROR | card internal ecc was applied but error to correct the data
SD_CARD_CONTROLLER_ERR | internal card controller error
SD_GENERAL_UNKNOWN_ERROR | general or unknown error
SD_STREAM_RD_UNDERRUN | the card could not sustain data transfer in stream read operation.
SD_STREAM_WR_OVERRUN | the card could not sustain data programming in stream mode
SD_CID_CSD_OVERWRITE | cid/csd overwrite error
SD_WP_ERASE_SKIP | only partial address space was erased
SD_CARD_ECC_DISABLED | command has been executed without using internal ecc
SD_ERASE_RESET | erase sequence was cleared before executing because an out of erase sequence command was received
SD_AKE_SEQ_ERROR | error in sequence of authentication.
SD_INVALID_VOLTRANGE | invalid voltage range
SD_ADDR_OUT_OF_RANGE | address out of range
SD_SWITCH_ERROR | switch error
SD_SDIO_DISABLED | sdio disabled
SD_SDIO_FUNC_BUSY | function busy
SD_SDIO_FUNC_ERROR | function error
SD_SDIO_UNKNOWN_FUNC | unknown function
SD_INTERNAL_ERROR | internal error
SD_NOT_CONFIGURED | sdio doesn't configuration
SD_REQ_PENDING | request pending
SD_REQ_NOT_APPLICABLE | request isn't applicable
SD_INVALID_PARAMETER | invalid parameter
SD_UNSUPPORTED_FEATURE | unsupported feature
SD_UNSUPPORTED_HW | unsupported hardware
SD_ERROR | error
SD_OK | pass

Definition at line 74 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ sd_error_status_type [4/4]

enum sd_error_status_type

sdio error defines

Enumerator
SD_CMD_FAIL | command response received (but crc check error)
SD_DATA_FAIL | data bock sent/received (crc check error)
SD_CMD_RSP_TIMEOUT | command response timeout
SD_DATA_TIMEOUT | data time out
SD_TX_UNDERRUN | transmit fifo under-run
SD_RX_OVERRUN | receive fifo over-run
SD_START_BIT_ERR | start bit not detected on all data signals in wide bus mode
SD_CMD_OUT_OF_RANGE | cmd's argument was out of range.
SD_ADDR_MISALIGNED | misaligned address
SD_BLK_LEN_ERR | transferred block length is not allowed for the card or the number of transferred bytes does not match the block length
SD_ERASE_SEQ_ERR | an error in the sequence of erase command occurs.
SD_INVALID_ERASE_PARAM | an invalid selection for erase groups
SD_WR_PROTECT_VIOLATION | attempt to program a write protect block
SD_LOCK_UNLOCK_ERROR | sequence or password error has been detected in unlock command or if there was an attempt to access a locked card
SD_CMD_CRC_ERROR | crc check of the previous command error
SD_ILLEGAL_CMD | command is not legal for the card state
SD_CARD_ECC_ERROR | card internal ecc was applied but error to correct the data
SD_CARD_CONTROLLER_ERR | internal card controller error
SD_GENERAL_UNKNOWN_ERROR | general or unknown error
SD_STREAM_RD_UNDERRUN | the card could not sustain data transfer in stream read operation.
SD_STREAM_WR_OVERRUN | the card could not sustain data programming in stream mode
SD_CID_CSD_OVERWRITE | cid/csd overwrite error
SD_WP_ERASE_SKIP | only partial address space was erased
SD_CARD_ECC_DISABLED | command has been executed without using internal ecc
SD_ERASE_RESET | erase sequence was cleared before executing because an out of erase sequence command was received
SD_AKE_SEQ_ERROR | error in sequence of authentication.
SD_INVALID_VOLTRANGE | invalid voltage range
SD_ADDR_OUT_OF_RANGE | address out of range
SD_SWITCH_ERROR | switch error
SD_SDIO_DISABLED | sdio disabled
SD_SDIO_FUNC_BUSY | function busy
SD_SDIO_FUNC_ERROR | function error
SD_SDIO_UNKNOWN_FUNC | unknown function
SD_INTERNAL_ERROR | internal error
SD_NOT_CONFIGURED | sdio doesn't configuration
SD_REQ_PENDING | request pending
SD_REQ_NOT_APPLICABLE | request isn't applicable
SD_INVALID_PARAMETER | invalid parameter
SD_UNSUPPORTED_FEATURE | unsupported feature
SD_UNSUPPORTED_HW | unsupported hardware
SD_ERROR | error
SD_OK | pass
SD_CMD_FAIL | command response received (but crc check error)
SD_DATA_FAIL | data bock sent/received (crc check error)
SD_CMD_RSP_TIMEOUT | command response timeout
SD_DATA_TIMEOUT | data time out
SD_TX_UNDERRUN | transmit fifo under-run
SD_RX_OVERRUN | receive fifo over-run
SD_START_BIT_ERR | start bit not detected on all data signals in wide bus mode
SD_CMD_OUT_OF_RANGE | cmd's argument was out of range.
SD_ADDR_MISALIGNED | misaligned address
SD_BLK_LEN_ERR | transferred block length is not allowed for the card or the number of transferred bytes does not match the block length
SD_ERASE_SEQ_ERR | an error in the sequence of erase command occurs.
SD_INVALID_ERASE_PARAM | an invalid selection for erase groups
SD_WR_PROTECT_VIOLATION | attempt to program a write protect block
SD_LOCK_UNLOCK_ERROR | sequence or password error has been detected in unlock command or if there was an attempt to access a locked card
SD_CMD_CRC_ERROR | crc check of the previous command error
SD_ILLEGAL_CMD | command is not legal for the card state
SD_CARD_ECC_ERROR | card internal ecc was applied but error to correct the data
SD_CARD_CONTROLLER_ERR | internal card controller error
SD_GENERAL_UNKNOWN_ERROR | general or unknown error
SD_STREAM_RD_UNDERRUN | the card could not sustain data transfer in stream read operation.
SD_STREAM_WR_OVERRUN | the card could not sustain data programming in stream mode
SD_CID_CSD_OVERWRITE | cid/csd overwrite error
SD_WP_ERASE_SKIP | only partial address space was erased
SD_CARD_ECC_DISABLED | command has been executed without using internal ecc
SD_ERASE_RESET | erase sequence was cleared before executing because an out of erase sequence command was received
SD_AKE_SEQ_ERROR | error in sequence of authentication.
SD_INVALID_VOLTRANGE | invalid voltage range
SD_ADDR_OUT_OF_RANGE | address out of range
SD_SWITCH_ERROR | switch error
SD_SDIO_DISABLED | sdio disabled
SD_SDIO_FUNC_BUSY | function busy
SD_SDIO_FUNC_ERROR | function error
SD_SDIO_UNKNOWN_FUNC | unknown function
SD_INTERNAL_ERROR | internal error
SD_NOT_CONFIGURED | sdio doesn't configuration
SD_REQ_PENDING | request pending
SD_REQ_NOT_APPLICABLE | request isn't applicable
SD_INVALID_PARAMETER | invalid parameter
SD_UNSUPPORTED_FEATURE | unsupported feature
SD_UNSUPPORTED_HW | unsupported hardware
SD_ERROR | error
SD_OK | pass
SD_CMD_FAIL | command response received (but crc check error)
SD_DATA_FAIL | data bock sent/received (crc check error)
SD_CMD_RSP_TIMEOUT | command response timeout
SD_DATA_TIMEOUT | data time out
SD_TX_UNDERRUN | transmit fifo under-run
SD_RX_OVERRUN | receive fifo over-run
SD_START_BIT_ERR | start bit not detected on all data signals in wide bus mode
SD_CMD_OUT_OF_RANGE | cmd's argument was out of range.
SD_ADDR_MISALIGNED | misaligned address
SD_BLK_LEN_ERR | transferred block length is not allowed for the card or the number of transferred bytes does not match the block length
SD_ERASE_SEQ_ERR | an error in the sequence of erase command occurs.
SD_INVALID_ERASE_PARAM | an invalid selection for erase groups
SD_WR_PROTECT_VIOLATION | attempt to program a write protect block
SD_LOCK_UNLOCK_ERROR | sequence or password error has been detected in unlock command or if there was an attempt to access a locked card
SD_CMD_CRC_ERROR | crc check of the previous command error
SD_ILLEGAL_CMD | command is not legal for the card state
SD_CARD_ECC_ERROR | card internal ecc was applied but error to correct the data
SD_CARD_CONTROLLER_ERR | internal card controller error
SD_GENERAL_UNKNOWN_ERROR | general or unknown error
SD_STREAM_RD_UNDERRUN | the card could not sustain data transfer in stream read operation.
SD_STREAM_WR_OVERRUN | the card could not sustain data programming in stream mode
SD_CID_CSD_OVERWRITE | cid/csd overwrite error
SD_WP_ERASE_SKIP | only partial address space was erased
SD_CARD_ECC_DISABLED | command has been executed without using internal ecc
SD_ERASE_RESET | erase sequence was cleared before executing because an out of erase sequence command was received
SD_AKE_SEQ_ERROR | error in sequence of authentication.
SD_INVALID_VOLTRANGE | invalid voltage range
SD_ADDR_OUT_OF_RANGE | address out of range
SD_SWITCH_ERROR | switch error
SD_SDIO_DISABLED | sdio disabled
SD_SDIO_FUNC_BUSY | function busy
SD_SDIO_FUNC_ERROR | function error
SD_SDIO_UNKNOWN_FUNC | unknown function
SD_INTERNAL_ERROR | internal error
SD_NOT_CONFIGURED | sdio doesn't configuration
SD_REQ_PENDING | request pending
SD_REQ_NOT_APPLICABLE | request isn't applicable
SD_INVALID_PARAMETER | invalid parameter
SD_UNSUPPORTED_FEATURE | unsupported feature
SD_UNSUPPORTED_HW | unsupported hardware
SD_ERROR | error
SD_OK | pass
SD_CMD_FAIL | command response received (but crc check error)
SD_DATA_FAIL | data bock sent/received (crc check error)
SD_CMD_RSP_TIMEOUT | command response timeout
SD_DATA_TIMEOUT | data time out
SD_TX_UNDERRUN | transmit fifo under-run
SD_RX_OVERRUN | receive fifo over-run
SD_START_BIT_ERR | start bit not detected on all data signals in wide bus mode
SD_CMD_OUT_OF_RANGE | cmd's argument was out of range.
SD_ADDR_MISALIGNED | misaligned address
SD_BLK_LEN_ERR | transferred block length is not allowed for the card or the number of transferred bytes does not match the block length
SD_ERASE_SEQ_ERR | an error in the sequence of erase command occurs.
SD_INVALID_ERASE_PARAM | an invalid selection for erase groups
SD_WR_PROTECT_VIOLATION | attempt to program a write protect block
SD_LOCK_UNLOCK_ERROR | sequence or password error has been detected in unlock command or if there was an attempt to access a locked card
SD_CMD_CRC_ERROR | crc check of the previous command error
SD_ILLEGAL_CMD | command is not legal for the card state
SD_CARD_ECC_ERROR | card internal ecc was applied but error to correct the data
SD_CARD_CONTROLLER_ERR | internal card controller error
SD_GENERAL_UNKNOWN_ERROR | general or unknown error
SD_STREAM_RD_UNDERRUN | the card could not sustain data transfer in stream read operation.
SD_STREAM_WR_OVERRUN | the card could not sustain data programming in stream mode
SD_CID_CSD_OVERWRITE | cid/csd overwrite error
SD_WP_ERASE_SKIP | only partial address space was erased
SD_CARD_ECC_DISABLED | command has been executed without using internal ecc
SD_ERASE_RESET | erase sequence was cleared before executing because an out of erase sequence command was received
SD_AKE_SEQ_ERROR | error in sequence of authentication.
SD_INVALID_VOLTRANGE | invalid voltage range
SD_ADDR_OUT_OF_RANGE | address out of range
SD_SWITCH_ERROR | switch error
SD_SDIO_DISABLED | sdio disabled
SD_SDIO_FUNC_BUSY | function busy
SD_SDIO_FUNC_ERROR | function error
SD_SDIO_UNKNOWN_FUNC | unknown function
SD_INTERNAL_ERROR | internal error
SD_NOT_CONFIGURED | sdio doesn't configuration
SD_REQ_PENDING | request pending
SD_REQ_NOT_APPLICABLE | request isn't applicable
SD_INVALID_PARAMETER | invalid parameter
SD_UNSUPPORTED_FEATURE | unsupported feature
SD_UNSUPPORTED_HW | unsupported hardware
SD_ERROR | error
SD_OK | pass

Definition at line 74 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ sd_memory_card_type [1/4]

enum sd_memory_card_type

supported sd memory cards

Enumerator
SDIO_STD_CAPACITY_SD_CARD_V1_1
SDIO_STD_CAPACITY_SD_CARD_V2_0
SDIO_HIGH_CAPACITY_SD_CARD
SDIO_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_CARD
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
SDIO_HIGH_CAPACITY_MMC_CARD
SDIO_SDIO_CARD
SDIO_STD_CAPACITY_SD_CARD_V1_1
SDIO_STD_CAPACITY_SD_CARD_V2_0
SDIO_HIGH_CAPACITY_SD_CARD
SDIO_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_CARD
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
SDIO_HIGH_CAPACITY_MMC_CARD
SDIO_SDIO_CARD
SDIO_STD_CAPACITY_SD_CARD_V1_1
SDIO_STD_CAPACITY_SD_CARD_V2_0
SDIO_HIGH_CAPACITY_SD_CARD
SDIO_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_CARD
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
SDIO_HIGH_CAPACITY_MMC_CARD
SDIO_SDIO_CARD
SDIO_STD_CAPACITY_SD_CARD_V1_1
SDIO_STD_CAPACITY_SD_CARD_V2_0
SDIO_HIGH_CAPACITY_SD_CARD
SDIO_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_CARD
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
SDIO_HIGH_CAPACITY_MMC_CARD
SDIO_SDIO_CARD

Definition at line 203 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ sd_memory_card_type [2/4]

enum sd_memory_card_type

supported sd memory cards

Enumerator
SDIO_STD_CAPACITY_SD_CARD_V1_1
SDIO_STD_CAPACITY_SD_CARD_V2_0
SDIO_HIGH_CAPACITY_SD_CARD
SDIO_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_CARD
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
SDIO_HIGH_CAPACITY_MMC_CARD
SDIO_SDIO_CARD
SDIO_STD_CAPACITY_SD_CARD_V1_1
SDIO_STD_CAPACITY_SD_CARD_V2_0
SDIO_HIGH_CAPACITY_SD_CARD
SDIO_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_CARD
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
SDIO_HIGH_CAPACITY_MMC_CARD
SDIO_SDIO_CARD
SDIO_STD_CAPACITY_SD_CARD_V1_1
SDIO_STD_CAPACITY_SD_CARD_V2_0
SDIO_HIGH_CAPACITY_SD_CARD
SDIO_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_CARD
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
SDIO_HIGH_CAPACITY_MMC_CARD
SDIO_SDIO_CARD
SDIO_STD_CAPACITY_SD_CARD_V1_1
SDIO_STD_CAPACITY_SD_CARD_V2_0
SDIO_HIGH_CAPACITY_SD_CARD
SDIO_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_CARD
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
SDIO_HIGH_CAPACITY_MMC_CARD
SDIO_SDIO_CARD

Definition at line 203 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ sd_memory_card_type [3/4]

enum sd_memory_card_type

supported sd memory cards

Enumerator
SDIO_STD_CAPACITY_SD_CARD_V1_1
SDIO_STD_CAPACITY_SD_CARD_V2_0
SDIO_HIGH_CAPACITY_SD_CARD
SDIO_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_CARD
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
SDIO_HIGH_CAPACITY_MMC_CARD
SDIO_SDIO_CARD
SDIO_STD_CAPACITY_SD_CARD_V1_1
SDIO_STD_CAPACITY_SD_CARD_V2_0
SDIO_HIGH_CAPACITY_SD_CARD
SDIO_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_CARD
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
SDIO_HIGH_CAPACITY_MMC_CARD
SDIO_SDIO_CARD
SDIO_STD_CAPACITY_SD_CARD_V1_1
SDIO_STD_CAPACITY_SD_CARD_V2_0
SDIO_HIGH_CAPACITY_SD_CARD
SDIO_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_CARD
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
SDIO_HIGH_CAPACITY_MMC_CARD
SDIO_SDIO_CARD
SDIO_STD_CAPACITY_SD_CARD_V1_1
SDIO_STD_CAPACITY_SD_CARD_V2_0
SDIO_HIGH_CAPACITY_SD_CARD
SDIO_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_CARD
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
SDIO_HIGH_CAPACITY_MMC_CARD
SDIO_SDIO_CARD

Definition at line 203 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ sd_memory_card_type [4/4]

enum sd_memory_card_type

supported sd memory cards

Enumerator
SDIO_STD_CAPACITY_SD_CARD_V1_1
SDIO_STD_CAPACITY_SD_CARD_V2_0
SDIO_HIGH_CAPACITY_SD_CARD
SDIO_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_CARD
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
SDIO_HIGH_CAPACITY_MMC_CARD
SDIO_SDIO_CARD
SDIO_STD_CAPACITY_SD_CARD_V1_1
SDIO_STD_CAPACITY_SD_CARD_V2_0
SDIO_HIGH_CAPACITY_SD_CARD
SDIO_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_CARD
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
SDIO_HIGH_CAPACITY_MMC_CARD
SDIO_SDIO_CARD
SDIO_STD_CAPACITY_SD_CARD_V1_1
SDIO_STD_CAPACITY_SD_CARD_V2_0
SDIO_HIGH_CAPACITY_SD_CARD
SDIO_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_CARD
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
SDIO_HIGH_CAPACITY_MMC_CARD
SDIO_SDIO_CARD
SDIO_STD_CAPACITY_SD_CARD_V1_1
SDIO_STD_CAPACITY_SD_CARD_V2_0
SDIO_HIGH_CAPACITY_SD_CARD
SDIO_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_CARD
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
SDIO_HIGH_CAPACITY_MMC_CARD
SDIO_SDIO_CARD

Definition at line 203 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ sdio_block_size_type

enum sdio_block_size_type

sdio data block size

Enumerator
SDIO_DATA_BLOCK_SIZE_1B | data block size 1 byte
SDIO_DATA_BLOCK_SIZE_2B | data block size 2 bytes
SDIO_DATA_BLOCK_SIZE_4B | data block size 4 bytes
SDIO_DATA_BLOCK_SIZE_8B | data block size 8 bytes
SDIO_DATA_BLOCK_SIZE_16B | data block size 16 bytes
SDIO_DATA_BLOCK_SIZE_32B | data block size 32 bytes
SDIO_DATA_BLOCK_SIZE_64B | data block size 64 bytes
SDIO_DATA_BLOCK_SIZE_128B | data block size 128 bytes
SDIO_DATA_BLOCK_SIZE_256B | data block size 256 bytes
SDIO_DATA_BLOCK_SIZE_512B | data block size 512 bytes
SDIO_DATA_BLOCK_SIZE_1024B | data block size 1024 bytes
SDIO_DATA_BLOCK_SIZE_2048B | data block size 2048 bytes
SDIO_DATA_BLOCK_SIZE_4096B | data block size 4096 bytes
SDIO_DATA_BLOCK_SIZE_8192B | data block size 8192 bytes
SDIO_DATA_BLOCK_SIZE_16384B | data block size 16384 bytes

Definition at line 179 of file at32f435_437_sdio.h.

◆ sdio_bus_width_type

enum sdio_bus_width_type

sdio bus width

Enumerator
SDIO_BUS_WIDTH_D1 | sdio wide bus select 1-bit
SDIO_BUS_WIDTH_D4 | sdio wide bus select 4-bit
SDIO_BUS_WIDTH_D8 | sdio wide bus select 8-bit

Definition at line 138 of file at32f435_437_sdio.h.

◆ sdio_edge_phase_type

enum sdio_edge_phase_type

sdio edge phase

Enumerator
SDIO_CLOCK_EDGE_RISING | sdio bus clock generated on the rising edge of the master clock
SDIO_CLOCK_EDGE_FALLING | sdio bus clock generated on the falling edge of the master clock

Definition at line 129 of file at32f435_437_sdio.h.

◆ sdio_power_state_type

enum sdio_power_state_type

sdio power state

Enumerator
SDIO_POWER_OFF | power-off, clock to card is stopped
SDIO_POWER_ON | power-on, the card is clocked

Definition at line 120 of file at32f435_437_sdio.h.

◆ sdio_read_wait_mode_type

enum sdio_read_wait_mode_type

sdio read wait mode

Enumerator
SDIO_READ_WAIT_CONTROLLED_BY_D2 | the sdio read wait on data2 line
SDIO_READ_WAIT_CONTROLLED_BY_CK | the sdio read wait on clock line

Definition at line 219 of file at32f435_437_sdio.h.

◆ sdio_reponse_type

enum sdio_reponse_type

sdio response type

Enumerator
SDIO_RESPONSE_NO | no response
SDIO_RESPONSE_SHORT | short response
SDIO_RESPONSE_LONG | long response

Definition at line 148 of file at32f435_437_sdio.h.

◆ sdio_rsp_index_type

enum sdio_rsp_index_type

sdio response register index

Enumerator
SDIO_RSP1_INDEX | response index 1, corresponding to sdio_rsp register 1
SDIO_RSP2_INDEX | response index 2, corresponding to sdio_rsp register 2
SDIO_RSP3_INDEX | response index 3, corresponding to sdio_rsp register 3
SDIO_RSP4_INDEX | response index 4, corresponding to sdio_rsp register 4

Definition at line 168 of file at32f435_437_sdio.h.

◆ sdio_transfer_direction_type

enum sdio_transfer_direction_type

sdio data transfer direction

Enumerator
SDIO_DATA_TRANSFER_TO_CARD | the sdio controller write
SDIO_DATA_TRANSFER_TO_CONTROLLER | the sdio controller read

Definition at line 210 of file at32f435_437_sdio.h.

◆ sdio_transfer_mode_type

enum sdio_transfer_mode_type

sdio data transfer mode

Enumerator
SDIO_DATA_BLOCK_TRANSFER | the sdio block transfer mode
SDIO_DATA_STREAM_TRANSFER | the sdio stream transfer mode

Definition at line 201 of file at32f435_437_sdio.h.

◆ sdio_wait_type

enum sdio_wait_type

sdio wait type

Enumerator
SDIO_WAIT_FOR_NO | no wait
SDIO_WAIT_FOR_INT | wait interrupt request
SDIO_WAIT_FOR_PEND | wait end of transfer

Definition at line 158 of file at32f435_437_sdio.h.

Variable Documentation

◆ sd_card_info [1/4]

sd_card_info_struct_type sd_card_info
extern

Definition at line 48 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by disk_ioctl(), main(), and show_card_info().

◆ sd_card_info [2/4]

sd_card_info_struct_type sd_card_info
extern

Definition at line 48 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

◆ sd_card_info [3/4]

sd_card_info_struct_type sd_card_info
extern

Definition at line 48 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

◆ sd_card_info [4/4]

sd_card_info_struct_type sd_card_info
extern

Definition at line 48 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by scr_find(), sd_bus_wide_enable(), sd_init(), and speed_change().


AT32F435/437 Firmwary Library: sdio_command_struct_type Struct Reference

Data Fields
sdio_command_struct_type Struct Reference
AT32F435_437_periph_driver » SDIO | AT32F435_periph_examples | AT32F437_periph_examples » SD_mmc_card | AT32F435_periph_examples | AT32F437_periph_examples » SDIO_fatfs » SDIO_exported_types

sdio command structure More...

#include <at32f435_437_sdio.h>

Data Fields

uint32_t | argument
uint8_t | cmd_index
sdio_reponse_type rsp_type
sdio_wait_type wait_type

Detailed Description

sdio command structure

Definition at line 228 of file at32f435_437_sdio.h.

Field Documentation

◆ argument

uint32_t sdio_command_struct_type::argument

the sdio command argument is sent to a card as part of command message

Definition at line 230 of file at32f435_437_sdio.h.

Referenced by check_card_programming(), mmc_stream_read(), mmc_stream_write(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), sdio_command_config(), and sdio_command_data_send().

◆ cmd_index

uint8_t sdio_command_struct_type::cmd_index

the sdio command index

Definition at line 231 of file at32f435_437_sdio.h.

Referenced by check_card_programming(), mmc_stream_read(), mmc_stream_write(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), sdio_command_config(), and sdio_command_data_send().

◆ rsp_type

sdio_reponse_type sdio_command_struct_type::rsp_type

the sdio response type

Definition at line 232 of file at32f435_437_sdio.h.

Referenced by check_card_programming(), mmc_stream_read(), mmc_stream_write(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), sdio_command_config(), and sdio_command_data_send().

◆ wait_type

sdio_wait_type sdio_command_struct_type::wait_type

the sdio wait for interrupt request is enabled or disable

Definition at line 233 of file at32f435_437_sdio.h.

Referenced by check_card_programming(), mmc_stream_read(), mmc_stream_write(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), sdio_command_config(), and sdio_command_data_send().

The documentation for this struct was generated from the following file:
  • at32f435_437_sdio.h


AT32F435/437 Firmwary Library: sdio_data_struct_type Struct Reference

Data Fields
sdio_data_struct_type Struct Reference
AT32F435_437_periph_driver » SDIO | AT32F435_periph_examples | AT32F437_periph_examples » SD_mmc_card | AT32F435_periph_examples | AT32F437_periph_examples » SDIO_fatfs » SDIO_exported_types

sdio data structure More...

#include <at32f435_437_sdio.h>

Data Fields

uint32_t | timeout
uint32_t | data_length
sdio_block_size_type block_size
sdio_transfer_mode_type transfer_mode
sdio_transfer_direction_type transfer_direction

Detailed Description

sdio data structure

Definition at line 239 of file at32f435_437_sdio.h.

Field Documentation

◆ block_size

sdio_block_size_type sdio_data_struct_type::block_size

the sdio data block size of block transfer mode

Definition at line 243 of file at32f435_437_sdio.h.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_switch(), and sdio_data_config().

◆ data_length

uint32_t sdio_data_struct_type::data_length

the sdio data length

Definition at line 242 of file at32f435_437_sdio.h.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_switch(), sdio_command_data_send(), and sdio_data_config().

◆ timeout

uint32_t sdio_data_struct_type::timeout

the sdio data timeout period in car bus clock periods

Definition at line 241 of file at32f435_437_sdio.h.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_switch(), and sdio_data_config().

◆ transfer_direction

sdio_transfer_direction_type sdio_data_struct_type::transfer_direction

the sdio data transfer direction

Definition at line 245 of file at32f435_437_sdio.h.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_switch(), sdio_command_data_send(), and sdio_data_config().

◆ transfer_mode

sdio_transfer_mode_type sdio_data_struct_type::transfer_mode

the sdio transfer mode, block or stream

Definition at line 244 of file at32f435_437_sdio.h.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_switch(), and sdio_data_config().

The documentation for this struct was generated from the following file:
  • at32f435_437_sdio.h


AT32F435/437 Firmwary Library: sdio_type Struct Reference

Data Fields
sdio_type Struct Reference
AT32F435_437_periph_driver » SDIO | AT32F435_periph_examples | AT32F437_periph_examples » SD_mmc_card | AT32F435_periph_examples | AT32F437_periph_examples » SDIO_fatfs » SDIO_exported_types

type define sdio register all More...

#include <at32f435_437_sdio.h>

Data Fields

union {
__IO uint32_t pwrctrl
struct {
__IO uint32_t ps: 2
__IO uint32_t reserved1: 30
} pwrctrl_bit
};
sdio pwrctrl register, offset:0x00 More...
union {
__IO uint32_t clkctrl
struct {
__IO uint32_t clkdiv_l: 8
__IO uint32_t clkoen: 1
__IO uint32_t pwrsven: 1
__IO uint32_t bypsen: 1
__IO uint32_t busws: 2
__IO uint32_t clkegs: 1
__IO uint32_t hfcen: 1
__IO uint32_t clkdiv_h: 2
__IO uint32_t reserved1: 15
} clkctrl_bit
};
sdio clkctrl register, offset:0x04 More...
union {
__IO uint32_t argu
struct {
__IO uint32_t argu: 32
} argu_bit
};
sdio argu register, offset:0x08 More...
union {
__IO uint32_t cmdctrl
struct {
__IO uint32_t cmdidx: 6
__IO uint32_t rspwt: 2
__IO uint32_t intwt: 1
__IO uint32_t pndwt: 1
__IO uint32_t ccsmen: 1
__IO uint32_t iosusp: 1
__IO uint32_t reserved1: 20
} cmdctrl_bit
};
sdio cmdctrl register, offset:0x0C More...
union {
__IO uint32_t rspcmd
struct {
__IO uint32_t rspcmd: 6
__IO uint32_t reserved1: 26
} rspcmd_bit
};
sdio rspcmd register, offset:0x10 More...
union {
__IO uint32_t rsp1
struct {
__IO uint32_t cardsts1: 32
} rsp1_bit
};
sdio rsp1 register, offset:0x14 More...
union {
__IO uint32_t rsp2
struct {
__IO uint32_t cardsts2: 32
} rsp2_bit
};
sdio rsp2 register, offset:0x18 More...
union {
__IO uint32_t rsp3
struct {
__IO uint32_t cardsts3: 32
} rsp3_bit
};
sdio rsp3 register, offset:0x1C More...
union {
__IO uint32_t rsp4
struct {
__IO uint32_t cardsts4: 32
} rsp4_bit
};
sdio rsp4 register, offset:0x20 More...
union {
__IO uint32_t dttmr
struct {
__IO uint32_t timeout: 32
} dttmr_bit
};
sdio dttmr register, offset:0x24 More...
union {
__IO uint32_t dtlen
struct {
__IO uint32_t dtlen: 25
__IO uint32_t reserved1: 7
} dtlen_bit
};
sdio dtlen register, offset:0x28 More...
union {
__IO uint32_t dtctrl
struct {
__IO uint32_t tfren: 1
__IO uint32_t tfrdir: 1
__IO uint32_t tfrmode: 1
__IO uint32_t dmaen: 1
__IO uint32_t blksize: 4
__IO uint32_t rdwtstart: 1
__IO uint32_t rdwtstop: 1
__IO uint32_t rdwtmode: 1
__IO uint32_t ioen: 1
__IO uint32_t reserved1: 20
} dtctrl_bit
};
sdio dtctrl register, offset:0x2C More...
union {
__IO uint32_t dtcnt
struct {
__IO uint32_t cnt: 25
__IO uint32_t reserved1: 7
} dtcnt_bit
};
sdio dtcnt register, offset:0x30 More...
union {
__IO uint32_t sts
struct {
__IO uint32_t cmdfail: 1
__IO uint32_t dtfail: 1
__IO uint32_t cmdtimeout: 1
__IO uint32_t dttimeout: 1
__IO uint32_t txerru: 1
__IO uint32_t rxerro: 1
__IO uint32_t cmdrspcmpl: 1
__IO uint32_t cmdcmpl: 1
__IO uint32_t dtcmpl: 1
__IO uint32_t sbiterr: 1
__IO uint32_t dtblkcmpl: 1
__IO uint32_t docmd: 1
__IO uint32_t dotx: 1
__IO uint32_t dorx: 1
__IO uint32_t txbufh: 1
__IO uint32_t rxbufh: 1
__IO uint32_t txbuff: 1
__IO uint32_t rxbuff: 1
__IO uint32_t txbufe: 1
__IO uint32_t rxbufe: 1
__IO uint32_t txbuf: 1
__IO uint32_t rxbuf: 1
__IO uint32_t ioif: 1
__IO uint32_t reserved1: 9
} sts_bit
};
sdio sts register, offset:0x34 More...
union {
__IO uint32_t intclr
struct {
__IO uint32_t cmdfail: 1
__IO uint32_t dtfail: 1
__IO uint32_t cmdtimeout: 1
__IO uint32_t dttimeout: 1
__IO uint32_t txerru: 1
__IO uint32_t rxerro: 1
__IO uint32_t cmdrspcmpl: 1
__IO uint32_t cmdcmpl: 1
__IO uint32_t dtcmpl: 1
__IO uint32_t sbiterr: 1
__IO uint32_t dtblkcmpl: 1
__IO uint32_t reserved1: 11
__IO uint32_t ioif: 1
__IO uint32_t reserved2: 9
} intclr_bit
};
sdio intclr register, offset:0x38 More...
union {
__IO uint32_t inten
struct {
__IO uint32_t cmdfailien: 1
__IO uint32_t dtfailien: 1
__IO uint32_t cmdtimeoutien: 1
__IO uint32_t dttimeoutien: 1
__IO uint32_t txerruien: 1
__IO uint32_t rxerroien: 1
__IO uint32_t cmdrspcmplien: 1
__IO uint32_t cmdcmplien: 1
__IO uint32_t dtcmplien: 1
__IO uint32_t sbiterrien: 1
__IO uint32_t dtblkcmplien: 1
__IO uint32_t docmdien: 1
__IO uint32_t dotxien: 1
__IO uint32_t dorxien: 1
__IO uint32_t txbufhien: 1
__IO uint32_t rxbufhien: 1
__IO uint32_t txbuffien: 1
__IO uint32_t rxbuffien: 1
__IO uint32_t txbufeien: 1
__IO uint32_t rxbufeien: 1
__IO uint32_t txbufien: 1
__IO uint32_t rxbufien: 1
__IO uint32_t ioifien: 1
__IO uint32_t reserved1: 9
} inten_bit
};
sdio inten register, offset:0x3C More...
union {
__IO uint32_t bufcnt
struct {
__IO uint32_t cnt: 24
__IO uint32_t reserved1: 8
} bufcnt_bit
};
sdio bufcnt register, offset:0x48 More...
union {
__IO uint32_t buf
struct {
__IO uint32_t dt: 32
} buf_bit
};
sdio buf register, offset:0x80 More...

Detailed Description

type define sdio register all

Definition at line 251 of file at32f435_437_sdio.h.

Field Documentation

◆

union { ... } sdio_type::@1001

sdio dtcnt register, offset:0x30

◆

union { ... } sdio_type::@1003

sdio sts register, offset:0x34

◆

union { ... } sdio_type::@1005

sdio intclr register, offset:0x38

◆

union { ... } sdio_type::@1007

sdio inten register, offset:0x3C

◆

union { ... } sdio_type::@1009

sdio bufcnt register, offset:0x48

◆

union { ... } sdio_type::@1011

sdio buf register, offset:0x80

◆

union { ... } sdio_type::@977

sdio pwrctrl register, offset:0x00

◆

union { ... } sdio_type::@979

sdio clkctrl register, offset:0x04

◆

union { ... } sdio_type::@981

sdio argu register, offset:0x08

◆

union { ... } sdio_type::@983

sdio cmdctrl register, offset:0x0C

◆

union { ... } sdio_type::@985

sdio rspcmd register, offset:0x10

◆

union { ... } sdio_type::@987

sdio rsp1 register, offset:0x14

◆

union { ... } sdio_type::@989

sdio rsp2 register, offset:0x18

◆

union { ... } sdio_type::@991

sdio rsp3 register, offset:0x1C

◆

union { ... } sdio_type::@993

sdio rsp4 register, offset:0x20

◆

union { ... } sdio_type::@995

sdio dttmr register, offset:0x24

◆

union { ... } sdio_type::@997

sdio dtlen register, offset:0x28

◆

union { ... } sdio_type::@999

sdio dtctrl register, offset:0x2C

◆ argu

__IO uint32_t sdio_type::argu

Definition at line 291 of file at32f435_437_sdio.h.

Referenced by sdio_command_config(), and sdio_reset().

◆

struct { ... } sdio_type::argu_bit

◆ blksize

__IO uint32_t sdio_type::blksize

Definition at line 414 of file at32f435_437_sdio.h.

Referenced by sdio_data_config().

◆ buf

__IO uint32_t sdio_type::buf

Definition at line 559 of file at32f435_437_sdio.h.

Referenced by sdio_data_read(), and sdio_data_write().

◆

struct { ... } sdio_type::buf_bit

◆ bufcnt

__IO uint32_t sdio_type::bufcnt

Definition at line 541 of file at32f435_437_sdio.h.

Referenced by sdio_buffer_counter_get().

◆

struct { ... } sdio_type::bufcnt_bit

◆ busws

__IO uint32_t sdio_type::busws

Definition at line 278 of file at32f435_437_sdio.h.

Referenced by sdio_bus_width_config().

◆ bypsen

__IO uint32_t sdio_type::bypsen

Definition at line 277 of file at32f435_437_sdio.h.

Referenced by sdio_clock_bypass().

◆ cardsts1

__IO uint32_t sdio_type::cardsts1

Definition at line 337 of file at32f435_437_sdio.h.

◆ cardsts2

__IO uint32_t sdio_type::cardsts2

Definition at line 349 of file at32f435_437_sdio.h.

◆ cardsts3

__IO uint32_t sdio_type::cardsts3

Definition at line 361 of file at32f435_437_sdio.h.

◆ cardsts4

__IO uint32_t sdio_type::cardsts4

Definition at line 373 of file at32f435_437_sdio.h.

◆ ccsmen

__IO uint32_t sdio_type::ccsmen

Definition at line 310 of file at32f435_437_sdio.h.

Referenced by sdio_command_config(), and sdio_command_state_machine_enable().

◆ clkctrl

__IO uint32_t sdio_type::clkctrl

Definition at line 271 of file at32f435_437_sdio.h.

Referenced by sdio_reset().

◆

struct { ... } sdio_type::clkctrl_bit

Referenced by sdio_bus_width_config(), sdio_clock_bypass(), sdio_clock_config(), sdio_clock_enable(), sdio_flow_control_enable(), and sdio_power_saving_mode_enable().

◆ clkdiv_h

__IO uint32_t sdio_type::clkdiv_h

Definition at line 281 of file at32f435_437_sdio.h.

Referenced by sdio_clock_config().

◆ clkdiv_l

__IO uint32_t sdio_type::clkdiv_l

Definition at line 274 of file at32f435_437_sdio.h.

Referenced by sdio_clock_config().

◆ clkegs

__IO uint32_t sdio_type::clkegs

Definition at line 279 of file at32f435_437_sdio.h.

Referenced by sdio_clock_config().

◆ clkoen

__IO uint32_t sdio_type::clkoen

Definition at line 275 of file at32f435_437_sdio.h.

Referenced by sdio_clock_enable().

◆ cmdcmpl

__IO uint32_t sdio_type::cmdcmpl

Definition at line 451 of file at32f435_437_sdio.h.

◆ cmdcmplien

__IO uint32_t sdio_type::cmdcmplien

Definition at line 511 of file at32f435_437_sdio.h.

◆ cmdctrl

__IO uint32_t sdio_type::cmdctrl

Definition at line 303 of file at32f435_437_sdio.h.

Referenced by sdio_reset().

◆

struct { ... } sdio_type::cmdctrl_bit

Referenced by sdio_command_config(), sdio_command_state_machine_enable(), and sdio_io_suspend_command_set().

◆ cmdfail

__IO uint32_t sdio_type::cmdfail

Definition at line 444 of file at32f435_437_sdio.h.

◆ cmdfailien

__IO uint32_t sdio_type::cmdfailien

Definition at line 504 of file at32f435_437_sdio.h.

◆ cmdidx

__IO uint32_t sdio_type::cmdidx

Definition at line 306 of file at32f435_437_sdio.h.

Referenced by sdio_command_config().

◆ cmdrspcmpl

__IO uint32_t sdio_type::cmdrspcmpl

Definition at line 450 of file at32f435_437_sdio.h.

◆ cmdrspcmplien

__IO uint32_t sdio_type::cmdrspcmplien

Definition at line 510 of file at32f435_437_sdio.h.

◆ cmdtimeout

__IO uint32_t sdio_type::cmdtimeout

Definition at line 446 of file at32f435_437_sdio.h.

◆ cmdtimeoutien

__IO uint32_t sdio_type::cmdtimeoutien

Definition at line 506 of file at32f435_437_sdio.h.

◆ cnt

__IO uint32_t sdio_type::cnt

Definition at line 431 of file at32f435_437_sdio.h.

◆ dmaen

__IO uint32_t sdio_type::dmaen

Definition at line 413 of file at32f435_437_sdio.h.

Referenced by sdio_dma_enable().

◆ docmd

__IO uint32_t sdio_type::docmd

Definition at line 455 of file at32f435_437_sdio.h.

◆ docmdien

__IO uint32_t sdio_type::docmdien

Definition at line 515 of file at32f435_437_sdio.h.

◆ dorx

__IO uint32_t sdio_type::dorx

Definition at line 457 of file at32f435_437_sdio.h.

◆ dorxien

__IO uint32_t sdio_type::dorxien

Definition at line 517 of file at32f435_437_sdio.h.

◆ dotx

__IO uint32_t sdio_type::dotx

Definition at line 456 of file at32f435_437_sdio.h.

◆ dotxien

__IO uint32_t sdio_type::dotxien

Definition at line 516 of file at32f435_437_sdio.h.

◆ dt

__IO uint32_t sdio_type::dt

Definition at line 562 of file at32f435_437_sdio.h.

◆ dtblkcmpl

__IO uint32_t sdio_type::dtblkcmpl

Definition at line 454 of file at32f435_437_sdio.h.

◆ dtblkcmplien

__IO uint32_t sdio_type::dtblkcmplien

Definition at line 514 of file at32f435_437_sdio.h.

◆ dtcmpl

__IO uint32_t sdio_type::dtcmpl

Definition at line 452 of file at32f435_437_sdio.h.

◆ dtcmplien

__IO uint32_t sdio_type::dtcmplien

Definition at line 512 of file at32f435_437_sdio.h.

◆ dtcnt

__IO uint32_t sdio_type::dtcnt

Definition at line 428 of file at32f435_437_sdio.h.

Referenced by sdio_data_counter_get().

◆

struct { ... } sdio_type::dtcnt_bit

◆ dtctrl

__IO uint32_t sdio_type::dtctrl

Definition at line 407 of file at32f435_437_sdio.h.

Referenced by sdio_reset().

◆

struct { ... } sdio_type::dtctrl_bit

Referenced by sdio_data_config(), sdio_data_state_machine_enable(), sdio_dma_enable(), sdio_io_function_enable(), sdio_read_wait_mode_set(), sdio_read_wait_start(), and sdio_read_wait_stop().

◆ dtfail

__IO uint32_t sdio_type::dtfail

Definition at line 445 of file at32f435_437_sdio.h.

◆ dtfailien

__IO uint32_t sdio_type::dtfailien

Definition at line 505 of file at32f435_437_sdio.h.

◆ dtlen

__IO uint32_t sdio_type::dtlen

Definition at line 394 of file at32f435_437_sdio.h.

Referenced by sdio_data_config(), and sdio_reset().

◆

struct { ... } sdio_type::dtlen_bit

Referenced by sdio_data_config().

◆ dttimeout

__IO uint32_t sdio_type::dttimeout

Definition at line 447 of file at32f435_437_sdio.h.

◆ dttimeoutien

__IO uint32_t sdio_type::dttimeoutien

Definition at line 507 of file at32f435_437_sdio.h.

◆ dttmr

__IO uint32_t sdio_type::dttmr

Definition at line 382 of file at32f435_437_sdio.h.

Referenced by sdio_reset().

◆

struct { ... } sdio_type::dttmr_bit

Referenced by sdio_data_config().

◆ hfcen

__IO uint32_t sdio_type::hfcen

Definition at line 280 of file at32f435_437_sdio.h.

Referenced by sdio_flow_control_enable().

◆ intclr

__IO uint32_t sdio_type::intclr

Definition at line 476 of file at32f435_437_sdio.h.

Referenced by sdio_flag_clear(), and sdio_reset().

◆

struct { ... } sdio_type::intclr_bit

◆ inten

__IO uint32_t sdio_type::inten

Definition at line 501 of file at32f435_437_sdio.h.

Referenced by sdio_interrupt_enable(), and sdio_reset().

◆

struct { ... } sdio_type::inten_bit

◆ intwt

__IO uint32_t sdio_type::intwt

Definition at line 308 of file at32f435_437_sdio.h.

Referenced by sdio_command_config().

◆ ioen

__IO uint32_t sdio_type::ioen

Definition at line 418 of file at32f435_437_sdio.h.

Referenced by sdio_io_function_enable().

◆ ioif

__IO uint32_t sdio_type::ioif

Definition at line 466 of file at32f435_437_sdio.h.

◆ ioifien

__IO uint32_t sdio_type::ioifien

Definition at line 526 of file at32f435_437_sdio.h.

◆ iosusp

__IO uint32_t sdio_type::iosusp

Definition at line 311 of file at32f435_437_sdio.h.

Referenced by sdio_io_suspend_command_set().

◆ pndwt

__IO uint32_t sdio_type::pndwt

Definition at line 309 of file at32f435_437_sdio.h.

Referenced by sdio_command_config().

◆ ps

__IO uint32_t sdio_type::ps

Definition at line 261 of file at32f435_437_sdio.h.

Referenced by sdio_power_set(), and sdio_power_status_get().

◆ pwrctrl

__IO uint32_t sdio_type::pwrctrl

Definition at line 258 of file at32f435_437_sdio.h.

Referenced by sdio_reset().

◆

struct { ... } sdio_type::pwrctrl_bit

Referenced by sdio_power_set(), and sdio_power_status_get().

◆ pwrsven

__IO uint32_t sdio_type::pwrsven

Definition at line 276 of file at32f435_437_sdio.h.

Referenced by sdio_power_saving_mode_enable().

◆ rdwtmode

__IO uint32_t sdio_type::rdwtmode

Definition at line 417 of file at32f435_437_sdio.h.

Referenced by sdio_read_wait_mode_set().

◆ rdwtstart

__IO uint32_t sdio_type::rdwtstart

Definition at line 415 of file at32f435_437_sdio.h.

Referenced by sdio_read_wait_start().

◆ rdwtstop

__IO uint32_t sdio_type::rdwtstop

Definition at line 416 of file at32f435_437_sdio.h.

Referenced by sdio_read_wait_stop().

◆ reserved1

__IO uint32_t sdio_type::reserved1

sdio reserved1 register, offset:0x40~0x44

Definition at line 262 of file at32f435_437_sdio.h.

◆ reserved2

__IO uint32_t sdio_type::reserved2

sdio reserved2 register, offset:0x4C~0x7C

Definition at line 492 of file at32f435_437_sdio.h.

◆ rsp1

__IO uint32_t sdio_type::rsp1

Definition at line 334 of file at32f435_437_sdio.h.

Referenced by sdio_response_get().

◆

struct { ... } sdio_type::rsp1_bit

◆ rsp2

__IO uint32_t sdio_type::rsp2

Definition at line 346 of file at32f435_437_sdio.h.

Referenced by sdio_response_get().

◆

struct { ... } sdio_type::rsp2_bit

◆ rsp3

__IO uint32_t sdio_type::rsp3

Definition at line 358 of file at32f435_437_sdio.h.

Referenced by sdio_response_get().

◆

struct { ... } sdio_type::rsp3_bit

◆ rsp4

__IO uint32_t sdio_type::rsp4

Definition at line 370 of file at32f435_437_sdio.h.

Referenced by sdio_response_get().

◆

struct { ... } sdio_type::rsp4_bit

◆ rspcmd

__IO uint32_t sdio_type::rspcmd

Definition at line 321 of file at32f435_437_sdio.h.

Referenced by sdio_command_response_get().

◆

struct { ... } sdio_type::rspcmd_bit

Referenced by sdio_command_response_get().

◆ rspwt

__IO uint32_t sdio_type::rspwt

Definition at line 307 of file at32f435_437_sdio.h.

Referenced by sdio_command_config().

◆ rxbuf

__IO uint32_t sdio_type::rxbuf

Definition at line 465 of file at32f435_437_sdio.h.

◆ rxbufe

__IO uint32_t sdio_type::rxbufe

Definition at line 463 of file at32f435_437_sdio.h.

◆ rxbufeien

__IO uint32_t sdio_type::rxbufeien

Definition at line 523 of file at32f435_437_sdio.h.

◆ rxbuff

__IO uint32_t sdio_type::rxbuff

Definition at line 461 of file at32f435_437_sdio.h.

◆ rxbuffien

__IO uint32_t sdio_type::rxbuffien

Definition at line 521 of file at32f435_437_sdio.h.

◆ rxbufh

__IO uint32_t sdio_type::rxbufh

Definition at line 459 of file at32f435_437_sdio.h.

◆ rxbufhien

__IO uint32_t sdio_type::rxbufhien

Definition at line 519 of file at32f435_437_sdio.h.

◆ rxbufien

__IO uint32_t sdio_type::rxbufien

Definition at line 525 of file at32f435_437_sdio.h.

◆ rxerro

__IO uint32_t sdio_type::rxerro

Definition at line 449 of file at32f435_437_sdio.h.

◆ rxerroien

__IO uint32_t sdio_type::rxerroien

Definition at line 509 of file at32f435_437_sdio.h.

◆ sbiterr

__IO uint32_t sdio_type::sbiterr

Definition at line 453 of file at32f435_437_sdio.h.

◆ sbiterrien

__IO uint32_t sdio_type::sbiterrien

Definition at line 513 of file at32f435_437_sdio.h.

◆ sts

__IO uint32_t sdio_type::sts

Definition at line 441 of file at32f435_437_sdio.h.

Referenced by sdio_flag_get().

◆

struct { ... } sdio_type::sts_bit

◆ tfrdir

__IO uint32_t sdio_type::tfrdir

Definition at line 411 of file at32f435_437_sdio.h.

Referenced by sdio_data_config().

◆ tfren

__IO uint32_t sdio_type::tfren

Definition at line 410 of file at32f435_437_sdio.h.

Referenced by sdio_data_config(), and sdio_data_state_machine_enable().

◆ tfrmode

__IO uint32_t sdio_type::tfrmode

Definition at line 412 of file at32f435_437_sdio.h.

Referenced by sdio_data_config().

◆ timeout

__IO uint32_t sdio_type::timeout

Definition at line 385 of file at32f435_437_sdio.h.

Referenced by sdio_data_config().

◆ txbuf

__IO uint32_t sdio_type::txbuf

Definition at line 464 of file at32f435_437_sdio.h.

◆ txbufe

__IO uint32_t sdio_type::txbufe

Definition at line 462 of file at32f435_437_sdio.h.

◆ txbufeien

__IO uint32_t sdio_type::txbufeien

Definition at line 522 of file at32f435_437_sdio.h.

◆ txbuff

__IO uint32_t sdio_type::txbuff

Definition at line 460 of file at32f435_437_sdio.h.

◆ txbuffien

__IO uint32_t sdio_type::txbuffien

Definition at line 520 of file at32f435_437_sdio.h.

◆ txbufh

__IO uint32_t sdio_type::txbufh

Definition at line 458 of file at32f435_437_sdio.h.

◆ txbufhien

__IO uint32_t sdio_type::txbufhien

Definition at line 518 of file at32f435_437_sdio.h.

◆ txbufien

__IO uint32_t sdio_type::txbufien

Definition at line 524 of file at32f435_437_sdio.h.

◆ txerru

__IO uint32_t sdio_type::txerru

Definition at line 448 of file at32f435_437_sdio.h.

◆ txerruien

__IO uint32_t sdio_type::txerruien

Definition at line 508 of file at32f435_437_sdio.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_sdio.h


AT32F435/437 Firmwary Library: sd_csd_struct_type Struct Reference

Data Fields
sd_csd_struct_type Struct Reference
AT32F435_437_periph_driver » SDIO | AT32F435_periph_examples | AT32F437_periph_examples » SD_mmc_card | AT32F435_periph_examples | AT32F437_periph_examples » SDIO_fatfs » SDIO_exported_types

#include <at32_sdio.h>

Data Fields

uint8_t | csd_struct
uint8_t | spec_version
uint8_t | reserved1
uint8_t | taac
uint8_t | nsac
uint8_t | max_bus_clk_freq
uint16_t | card_cmd_classes
uint8_t | max_read_blk_length
uint8_t | part_blk_read
uint8_t | write_blk_misalign
uint8_t | read_blk_misalign
uint8_t | dsr_implemented
uint8_t | reserved2
uint32_t | device_size
uint8_t | max_read_current_vdd_min
uint8_t | max_read_current_vdd_max
uint8_t | max_write_current_vdd_min
uint8_t | max_write_current_vdd_max
uint8_t | device_size_mult
uint8_t | erase_group_size
uint8_t | erase_group_size_mult
uint8_t | write_protect_group_size
uint8_t | write_protect_group_enable
uint8_t | manufacturer_default_ecc
uint8_t | write_speed_factor
uint8_t | max_write_blk_length
uint8_t | part_blk_write
uint8_t | reserved3
uint8_t | content_protect_app
uint8_t | file_format_group
uint8_t | copy_flag
uint8_t | permanent_write_protect
uint8_t | temp_write_protect
uint8_t | file_formart
uint8_t | ecc_code
uint8_t | csd_crc
uint8_t | reserved4

Detailed Description

card specific data: csd register

Definition at line 126 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Field Documentation

◆ card_cmd_classes

uint16_t sd_csd_struct_type::card_cmd_classes

card command classes

Definition at line 134 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ content_protect_app

uint8_t sd_csd_struct_type::content_protect_app

content protection application

Definition at line 156 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ copy_flag

uint8_t sd_csd_struct_type::copy_flag

copy flag (otp)

Definition at line 158 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ csd_crc

uint8_t sd_csd_struct_type::csd_crc

csd crc

Definition at line 163 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ csd_struct

uint8_t sd_csd_struct_type::csd_struct

csd structure

Definition at line 128 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ device_size

uint32_t sd_csd_struct_type::device_size

device size

Definition at line 141 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get(), and show_card_info().

◆ device_size_mult

uint8_t sd_csd_struct_type::device_size_mult

device size multiplier

Definition at line 146 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ dsr_implemented

uint8_t sd_csd_struct_type::dsr_implemented

dsr implemented

Definition at line 139 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ ecc_code

uint8_t sd_csd_struct_type::ecc_code

ecc code

Definition at line 162 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ erase_group_size

uint8_t sd_csd_struct_type::erase_group_size

erase group size

Definition at line 147 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ erase_group_size_mult

uint8_t sd_csd_struct_type::erase_group_size_mult

erase group size multiplier

Definition at line 148 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ file_formart

uint8_t sd_csd_struct_type::file_formart

file format

Definition at line 161 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ file_format_group

uint8_t sd_csd_struct_type::file_format_group

file format group

Definition at line 157 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ manufacturer_default_ecc

uint8_t sd_csd_struct_type::manufacturer_default_ecc

manufacturer default ecc

Definition at line 151 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ max_bus_clk_freq

uint8_t sd_csd_struct_type::max_bus_clk_freq

max. bus clock frequency

Definition at line 133 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ max_read_blk_length

uint8_t sd_csd_struct_type::max_read_blk_length

max. read data block length

Definition at line 135 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ max_read_current_vdd_max

uint8_t sd_csd_struct_type::max_read_current_vdd_max

max. read current @ vdd max

Definition at line 143 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ max_read_current_vdd_min

uint8_t sd_csd_struct_type::max_read_current_vdd_min

max. read current @ vdd min

Definition at line 142 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ max_write_blk_length

uint8_t sd_csd_struct_type::max_write_blk_length

max. write data block length

Definition at line 153 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ max_write_current_vdd_max

uint8_t sd_csd_struct_type::max_write_current_vdd_max

max. write current @ vdd max

Definition at line 145 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ max_write_current_vdd_min

uint8_t sd_csd_struct_type::max_write_current_vdd_min

max. write current @ vdd min

Definition at line 144 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ nsac

uint8_t sd_csd_struct_type::nsac

data read access-time 2 in clk cycles

Definition at line 132 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ part_blk_read

uint8_t sd_csd_struct_type::part_blk_read

partial blocks for read allowed

Definition at line 136 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ part_blk_write

uint8_t sd_csd_struct_type::part_blk_write

partial blocks for write allowed

Definition at line 154 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ permanent_write_protect

uint8_t sd_csd_struct_type::permanent_write_protect

permanent write protection

Definition at line 159 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ read_blk_misalign

uint8_t sd_csd_struct_type::read_blk_misalign

read block misalignment

Definition at line 138 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ reserved1

uint8_t sd_csd_struct_type::reserved1

reserved

Definition at line 130 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ reserved2

uint8_t sd_csd_struct_type::reserved2

reserved

Definition at line 140 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ reserved3

uint8_t sd_csd_struct_type::reserved3

reserded

Definition at line 155 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ reserved4

uint8_t sd_csd_struct_type::reserved4

always

Definition at line 164 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ spec_version

uint8_t sd_csd_struct_type::spec_version

system specification version

Definition at line 129 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get(), and sd_init().

◆ taac

uint8_t sd_csd_struct_type::taac

data read access-time 1

Definition at line 131 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ temp_write_protect

uint8_t sd_csd_struct_type::temp_write_protect

temporary write protection

Definition at line 160 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ write_blk_misalign

uint8_t sd_csd_struct_type::write_blk_misalign

write block misalignment

Definition at line 137 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ write_protect_group_enable

uint8_t sd_csd_struct_type::write_protect_group_enable

write protect group enable

Definition at line 150 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ write_protect_group_size

uint8_t sd_csd_struct_type::write_protect_group_size

write protect group size

Definition at line 149 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ write_speed_factor

uint8_t sd_csd_struct_type::write_speed_factor

write speed factor

Definition at line 152 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

The documentation for this struct was generated from the following files:
  • at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h
  • at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h
  • at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h


AT32F435/437 Firmwary Library: sd_cid_struct_type Struct Reference

Data Fields
sd_cid_struct_type Struct Reference
AT32F435_437_periph_driver » SDIO | AT32F435_periph_examples | AT32F437_periph_examples » SD_mmc_card | AT32F435_periph_examples | AT32F437_periph_examples » SDIO_fatfs » SDIO_exported_types

#include <at32_sdio.h>

Data Fields

uint8_t | manufacturer_id
uint16_t | oem_app_id
uint32_t | product_name1
uint8_t | product_name2
uint8_t | product_reversion
uint32_t | product_sn
uint8_t | reserved1
uint16_t | manufact_date
uint8_t | cid_crc
uint8_t | reserved2

Detailed Description

card identification data: cid register

Definition at line 170 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Field Documentation

◆ cid_crc

uint8_t sd_cid_struct_type::cid_crc

cid crc

Definition at line 180 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ manufact_date

uint16_t sd_cid_struct_type::manufact_date

manufacturing date

Definition at line 179 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ manufacturer_id

uint8_t sd_cid_struct_type::manufacturer_id

manufacturer id

Definition at line 172 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get(), and show_card_info().

◆ oem_app_id

uint16_t sd_cid_struct_type::oem_app_id

oem/application id

Definition at line 173 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ product_name1

uint32_t sd_cid_struct_type::product_name1

product name part1

Definition at line 174 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ product_name2

uint8_t sd_cid_struct_type::product_name2

product name part2

Definition at line 175 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ product_reversion

uint8_t sd_cid_struct_type::product_reversion

product revision

Definition at line 176 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ product_sn

uint32_t sd_cid_struct_type::product_sn

product serial number

Definition at line 177 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ reserved1

uint8_t sd_cid_struct_type::reserved1

reserved1

Definition at line 178 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ reserved2

uint8_t sd_cid_struct_type::reserved2

always 1

Definition at line 181 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

The documentation for this struct was generated from the following files:
  • at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h
  • at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h
  • at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h


AT32F435/437 Firmwary Library: sd_scr_struct_type Struct Reference

Data Fields
sd_scr_struct_type Struct Reference
AT32F435_437_periph_driver » SDIO | AT32F435_periph_examples | AT32F437_periph_examples » SD_mmc_card | AT32F435_periph_examples | AT32F437_periph_examples » SDIO_fatfs » SDIO_exported_types

#include <at32_sdio.h>

Data Fields

uint32_t | sd_spec:4
uint32_t | scr_structure:4
uint32_t | sd_bus_width:4
uint32_t | sd_security:3
uint32_t | data_stat_after_erase:1
uint32_t | reserved1:7
uint32_t | sd_spec3:1
uint32_t | cmd20_support:1
uint32_t | cmd23_support:1
uint32_t | reserverd2:6
uint32_t | reserverd3

Detailed Description

sd card scr information

Definition at line 219 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Field Documentation

◆ cmd20_support

uint32_t sd_scr_struct_type::cmd20_support

Definition at line 228 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ cmd23_support

uint32_t sd_scr_struct_type::cmd23_support

Definition at line 229 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ data_stat_after_erase

uint32_t sd_scr_struct_type::data_stat_after_erase

Definition at line 225 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ reserved1

uint32_t sd_scr_struct_type::reserved1

Definition at line 226 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ reserverd2

uint32_t sd_scr_struct_type::reserverd2

Definition at line 230 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ reserverd3

uint32_t sd_scr_struct_type::reserverd3

Definition at line 231 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ scr_structure

uint32_t sd_scr_struct_type::scr_structure

Definition at line 222 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ sd_bus_width

uint32_t sd_scr_struct_type::sd_bus_width

Definition at line 223 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_bus_wide_enable().

◆ sd_security

uint32_t sd_scr_struct_type::sd_security

Definition at line 224 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ sd_spec

uint32_t sd_scr_struct_type::sd_spec

Definition at line 221 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by speed_change().

◆ sd_spec3

uint32_t sd_scr_struct_type::sd_spec3

Definition at line 227 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

The documentation for this struct was generated from the following files:
  • at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h
  • at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h
  • at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h


AT32F435/437 Firmwary Library: sd_card_info_struct_type Struct Reference

Data Fields
sd_card_info_struct_type Struct Reference
AT32F435_437_periph_driver » SDIO | AT32F435_periph_examples | AT32F437_periph_examples » SD_mmc_card | AT32F435_periph_examples | AT32F437_periph_examples » SDIO_fatfs » SDIO_exported_types

#include <at32_sdio.h>

Data Fields

sd_csd_struct_type sd_csd_reg
sd_cid_struct_type sd_cid_reg
sd_scr_struct_type sd_scr_reg
long long | card_capacity
uint32_t | card_blk_size
uint16_t | rca
uint8_t | card_type

Detailed Description

sd card information

Definition at line 237 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Field Documentation

◆ card_blk_size

uint32_t sd_card_info_struct_type::card_blk_size

Definition at line 243 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by disk_ioctl(), sd_card_info_get(), and show_card_info().

◆ card_capacity

long long sd_card_info_struct_type::card_capacity

Definition at line 242 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by disk_ioctl(), sd_card_info_get(), and show_card_info().

◆ card_type

uint8_t sd_card_info_struct_type::card_type

Definition at line 245 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by main(), sd_card_info_get(), sd_init(), and show_card_info().

◆ rca

uint16_t sd_card_info_struct_type::rca

Definition at line 244 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by scr_find(), sd_bus_wide_enable(), sd_card_info_get(), sd_init(), and show_card_info().

◆ sd_cid_reg

sd_cid_struct_type sd_card_info_struct_type::sd_cid_reg

Definition at line 240 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get(), and show_card_info().

◆ sd_csd_reg

sd_csd_struct_type sd_card_info_struct_type::sd_csd_reg

Definition at line 239 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get(), sd_init(), and show_card_info().

◆ sd_scr_reg

sd_scr_struct_type sd_card_info_struct_type::sd_scr_reg

Definition at line 241 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

Referenced by scr_find(), sd_bus_wide_enable(), and speed_change().

The documentation for this struct was generated from the following files:
  • at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h
  • at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h
  • at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h


AT32F435/437 Firmwary Library: SDIO_exported_functions

Functions
SDIO_exported_functions
AT32F435_437_periph_driver » SDIO | AT32F435_periph_examples | AT32F437_periph_examples » SD_mmc_card | AT32F435_periph_examples | AT32F437_periph_examples » SDIO_fatfs

Functions

void | sdio_reset (sdio_type *sdio_x)
reset the sdio register More...
void | sdio_power_set (sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller More...
sdio_power_state_type | sdio_power_status_get (sdio_type *sdio_x)
get power status. More...
void | sdio_clock_config (sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock More...
void | sdio_bus_width_config (sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width More...
void | sdio_clock_bypass (sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss More...
void | sdio_power_saving_mode_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle. More...
void | sdio_flow_control_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control. More...
void | sdio_clock_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output. More...
void | sdio_dma_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable dma. More...
void | sdio_interrupt_enable (sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt. More...
flag_status | sdio_flag_get (sdio_type *sdio_x, uint32_t flag)
get sdio flag. More...
void | sdio_flag_clear (sdio_type *sdio_x, uint32_t flag)
clear sdio flag. More...
void | sdio_command_config (sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command. More...
void | sdio_command_state_machine_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM). More...
uint8_t | sdio_command_response_get (sdio_type *sdio_x)
get command index of last command for which response received. More...
uint32_t | sdio_response_get (sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command. More...
void | sdio_data_config (sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data. More...
void | sdio_data_state_machine_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM). More...
uint32_t | sdio_data_counter_get (sdio_type *sdio_x)
get the number of remaining data bytes to be transferred. More...
uint32_t | sdio_data_read (sdio_type *sdio_x)
read a word data from sdio fifo. More...
uint32_t | sdio_buffer_counter_get (sdio_type *sdio_x)
get the number of words left to be written to or read from fifo.. More...
void | sdio_data_write (sdio_type *sdio_x, uint32_t data)
write one word data to fifo. More...
void | sdio_read_wait_mode_set (sdio_type *sdio_x, sdio_read_wait_mode_type mode)
set the read wait mode. More...
void | sdio_read_wait_start (sdio_type *sdio_x, confirm_state new_state)
enable or disable to start sd i/o read wait operation. More...
void | sdio_read_wait_stop (sdio_type *sdio_x, confirm_state new_state)
enable or disable to stop sd i/o read wait operation. More...
void | sdio_io_function_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable the sd i/o function. More...
void | sdio_io_suspend_command_set (sdio_type *sdio_x, confirm_state new_state)
enable or disable sd i/o suspend command sending. More...
sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clkdiv)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...

Detailed Description

Function Documentation

◆ mmc_stream_read()

sd_error_status_type mmc_stream_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint32_t | len
 | ) |  |

read mmc card data stream.

Parameters
buf | buffer of saving data from mmc card
addr | start address of data from mmc card
len | data size
Return values
sd_error_status_type sd card error code.

Definition at line 1653 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_stream_test().

◆ mmc_stream_write()

sd_error_status_type mmc_stream_write | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint32_t | len
 | ) |  |

write mmc card data stream.

Parameters
buf | data that writing to mmc card
addr | start address mmc card
len | data size
Return values
sd_error_status_type sd card error code.

Definition at line 1700 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_stream_test().

◆ sd_block_read()

sd_error_status_type sd_block_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size
 | ) |  |

allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that will contain the received data
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
Return values
sd_error_status_type sd card error code.

Definition at line 1188 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_read_disk(), and sd_single_block_test().

◆ sd_block_write()

sd_error_status_type sd_block_write | ( | const uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size
 | ) |  |

allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that contain the data to be transferred.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
Return values
sd_error_status_type sd card error code.

Definition at line 1367 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_single_block_test(), and sd_write_disk().

◆ sd_blocks_erase()

sd_error_status_type sd_blocks_erase | ( | long long | addr,
 |  | uint32_t | nblks
 | ) |  |

erase continuous data block

Parameters
addr | starting address
nblks | amount of erasing data block
Return values
sd_error_status_type sd card error code.

Definition at line 1030 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

◆ sd_card_info_get()

sd_error_status_type sd_card_info_get ( sd_card_info_struct_type * card_info )

returns information about specific card.

Parameters
card_info pointer to a sd_card_info_struct_type structure that contains all sd card information.
Return values
sd_error_status_type sd card error code.

Definition at line 532 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_card_init()

sd_error_status_type sd_card_init ( void )

intialises all cards or single card as the case may be card(s) come into standby state.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 417 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_deselect_select()

sd_error_status_type sd_deselect_select ( uint32_t addr )

selects od deselects the corresponding card.

Parameters
addr address of the card to be selected.
Return values
sd_error_status_type sd card error code.

Definition at line 807 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_device_mode_set()

sd_error_status_type sd_device_mode_set ( uint32_t mode )

set sdio work mode.

Parameters
mode parameter as following values:
  • SD_TRANSFER_POLLING_MODE: dma mode.
  • SD_TRANSFER_POLLING_MODE: polling mode.
Return values
sd_error_status_type sd card error code.

Definition at line 786 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_dma_config()

void sd_dma_config | ( | uint32_t * | mbuf,
 |  | uint32_t | buf_size,
 |  | dma_dir_type | dir
 | ) |  |

set dma configuation for sdio

Parameters
mbuf | buffer address
buf_size | transmission data size
dir | dma direction, it is DMA_DIR_MEMORY_TO_PERIPHERAL(writing data) or DMA_DIR_PERIPHERAL_TO_MEMORY(read data)
Return values
none

Definition at line 2706 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sdio_command_data_send().

◆ sd_init()

sd_error_status_type sd_init ( void )

initializes the sd card and put it into standby state (ready for data transfer).

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 72 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by disk_initialize(), main(), and sdio_command_data_send().

◆ sd_irq_service()

sd_error_status_type sd_irq_service ( void )

allows to process all the interrupts that are high.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 1789 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by SDIO1_IRQHandler(), and SDIO2_IRQHandler().

◆ sd_mult_blocks_read()

sd_error_status_type sd_mult_blocks_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size,
 |  | uint32_t | nblks
 | ) |  |

allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that will contain the received data.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
nblks | number of blocks to be read.
Return values
sd_error_status_type sd card error code.

Definition at line 1277 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_multiple_blocks_test(), and sd_read_disk().

◆ sd_mult_blocks_write()

sd_error_status_type sd_mult_blocks_write | ( | const uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size,
 |  | uint32_t | nblks
 | ) |  |

allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only.

Parameters
buf | pointer to the buffer that contain the data to be transferred.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
nblks | number of blocks to be written.
Return values
sd_error_status_type sd card error code.

Definition at line 1489 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_multiple_blocks_test(), and sd_write_disk().

◆ sd_power_off()

sd_error_status_type sd_power_off ( void )

turns the sdio output signals off.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 403 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

◆ sd_power_on()

sd_error_status_type sd_power_on ( void )

enquires cards about their operating voltage and configures clock controls.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 203 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_state_get()

sd_card_state_type sd_state_get ( void )

returns information about sd card.

Parameters
none.
Return values
sd_card_state_type sd card state code.

Definition at line 2489 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

◆ sd_status_send()

sd_error_status_type sd_status_send ( uint32_t * p_card_status )

read current card status.

Parameters
p_card_status card status.
Return values
sd_error_status_type sd card error code.

Definition at line 2452 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_switch(), sd_block_write(), sd_mult_blocks_write(), and sd_state_get().

◆ sd_wide_bus_operation_config()

sd_error_status_type sd_wide_bus_operation_config ( sdio_bus_width_type mode )

enable wide bus opeartion for the requeseted card if supported by card.

Parameters
mode specifies the sd card wide bus mode. this parameter can be one of the following values:
  • SDIO_BUS_WIDTH_D8: 8-bit data transfer (only for mmc)
  • SDIO_BUS_WIDTH_D4: 4-bit data transfer
  • SDIO_BUS_WIDTH_D1: 1-bit data transfer
Return values
sd_error_status_type sd card error code.

Definition at line 743 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_stream_test(), sd_init(), sd_multiple_blocks_test(), and sd_single_block_test().

◆ sdio_buffer_counter_get()

uint32_t sdio_buffer_counter_get ( sdio_type * sdio_x )

get the number of words left to be written to or read from fifo..

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
Return values
uint32_t number of words

Definition at line 477 of file at32f435_437_sdio.c.

◆ sdio_bus_width_config()

void sdio_bus_width_config | ( | sdio_type * | sdio_x,
 |  | sdio_bus_width_type | width
 | ) |  |

config sdio bus width

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
width this parameter can be one of the following values:
  • SDIO_BUS_WIDTH_D1
  • SDIO_BUS_WIDTH_D4
  • SDIO_BUS_WIDTH_D8
Return values
none

Definition at line 128 of file at32f435_437_sdio.c.

Referenced by sd_power_on(), and sd_wide_bus_operation_config().

◆ sdio_clock_bypass()

void sdio_clock_bypass | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable clock divider bypss

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 141 of file at32f435_437_sdio.c.

Referenced by sd_power_on().

◆ sdio_clock_config()

void sdio_clock_config | ( | sdio_type * | sdio_x,
 |  | uint16_t | clk_div,
 |  | sdio_edge_phase_type | clk_edg
 | ) |  |

config sdio clock

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
clk_div | sdio clock divide factor(frequency = sdio_clk / [clk_psc + 2]).
clk_edg this parameter can be one of the following values:
  • SDIO_CLOCK_EDGE_RISING
  • SDIO_CLOCK_EDGE_FALLING
Return values
none

Definition at line 104 of file at32f435_437_sdio.c.

Referenced by sd_power_on().

◆ sdio_clock_enable()

void sdio_clock_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable sdio_ck output.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 181 of file at32f435_437_sdio.c.

Referenced by sd_power_on().

◆ sdio_clock_set()

void sdio_clock_set ( uint32_t clk_div )

set sdio clock devision factor.

Parameters
clkdiv sdio_ck = ahbclk / (clkdiv+2)
Return values
none

Definition at line 188 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sdio_command_config()

void sdio_command_config | ( | sdio_type * | sdio_x,
 |  | sdio_command_struct_type * | command_struct
 | ) |  |

config sdio command.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
command_struct | : pointer to a sdio_command_struct_type structure that contains the configuration information for the sdio command.
Return values
none

Definition at line 329 of file at32f435_437_sdio.c.

Referenced by check_card_programming(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), and sdio_command_data_send().

◆ sdio_command_response_get()

uint8_t sdio_command_response_get ( sdio_type * sdio_x )

get command index of last command for which response received.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
new_state | (TRUE or FALSE)
Return values
uint8_t command index

Definition at line 365 of file at32f435_437_sdio.c.

Referenced by check_card_programming(), command_rsp1_error(), command_rsp4_error(), command_rsp5_error(), and command_rsp6_error().

◆ sdio_command_state_machine_enable()

void sdio_command_state_machine_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable command path state machine(CPSM).

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 352 of file at32f435_437_sdio.c.

Referenced by check_card_programming(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), and sdio_command_data_send().

◆ sdio_data_config()

void sdio_data_config | ( | sdio_type * | sdio_x,
 |  | sdio_data_struct_type * | data_struct
 | ) |  |

config sdio data.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
data_struct | : pointer to a sdio_data_struct_type structure that contains the configuration information for the sdio data.
Return values
none

Definition at line 416 of file at32f435_437_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sdio_command_data_send().

◆ sdio_data_counter_get()

uint32_t sdio_data_counter_get ( sdio_type * sdio_x )

get the number of remaining data bytes to be transferred.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
Return values
uint32_t number of bytes

Definition at line 453 of file at32f435_437_sdio.c.

◆ sdio_data_read()

uint32_t sdio_data_read ( sdio_type * sdio_x )

read a word data from sdio fifo.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
Return values
uint32_t data received

Definition at line 465 of file at32f435_437_sdio.c.

Referenced by scr_find(), and sdio_command_data_send().

◆ sdio_data_state_machine_enable()

void sdio_data_state_machine_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable data path state machine(DPSM).

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 441 of file at32f435_437_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sdio_command_data_send().

◆ sdio_data_write()

void sdio_data_write | ( | sdio_type * | sdio_x,
 |  | uint32_t | data
 | ) |  |

write one word data to fifo.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
data | data to be transferred.
Return values
none

Definition at line 490 of file at32f435_437_sdio.c.

Referenced by sdio_command_data_send().

◆ sdio_dma_enable()

void sdio_dma_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dma.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 194 of file at32f435_437_sdio.c.

Referenced by sdio_command_data_send().

◆ sdio_flag_clear()

void sdio_flag_clear | ( | sdio_type * | sdio_x,
 |  | uint32_t | flag
 | ) |  |

clear sdio flag.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
int_opt this parameter can be any combination of the following values:
  • SDIO_CMDFAIL_FLAG
  • SDIO_DTFAIL_FLAG
  • SDIO_CMDTIMEOUT_FLAG
  • SDIO_DTTIMEOUT_FLAG
  • SDIO_TXERRU_FLAG
  • SDIO_RXERRO_FLAG
  • SDIO_CMDRSPCMPL_FLAG
  • SDIO_CMDCMPL_FLAG
  • SDIO_DTCMPL_FLAG
  • SDIO_SBITERR_FLAG
  • SDIO_DTBLKCMPL_FLAG
  • SDIO_SDIOIF_FLAG
Return values
none

Definition at line 315 of file at32f435_437_sdio.c.

Referenced by check_card_programming(), command_error(), command_rsp1_error(), command_rsp2_error(), command_rsp3_error(), command_rsp4_error(), command_rsp5_error(), command_rsp6_error(), command_rsp7_error(), mmc_stream_write(), scr_find(), sd_block_write(), sd_irq_service(), sd_mult_blocks_write(), and sdio_command_data_send().

◆ sdio_flag_get()

flag_status sdio_flag_get | ( | sdio_type * | sdio_x,
 |  | uint32_t | flag
 | ) |  |

get sdio flag.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
flag this parameter can be one of the following values:
  • SDIO_CMDFAIL_FLAG
  • SDIO_DTFAIL_FLAG
  • SDIO_CMDTIMEOUT_FLAG
  • SDIO_DTTIMEOUT_FLAG
  • SDIO_TXERRU_FLAG
  • SDIO_RXERRO_FLAG
  • SDIO_CMDRSPCMPL_FLAG
  • SDIO_CMDCMPL_FLAG
  • SDIO_DTCMPL_FLAG
  • SDIO_SBITERR_FLAG
  • SDIO_DTBLKCMPL_FLAG
  • SDIO_DOCMD_FLAG
  • SDIO_DOTX_FLAG
  • SDIO_DORX_FLAG
  • SDIO_TXBUFH_FLAG
  • SDIO_RXBUFH_FLAG
  • SDIO_TXBUFF_FLAG
  • SDIO_RXBUFF_FLAG
  • SDIO_TXBUFE_FLAG
  • SDIO_RXBUFE_FLAG
  • SDIO_TXBUF_FLAG
  • SDIO_RXBUF_FLAG
  • SDIO_SDIOIF_FLAG
Return values
flag_status (SET or RESET)

Definition at line 278 of file at32f435_437_sdio.c.

Referenced by check_card_programming(), command_error(), command_rsp1_error(), command_rsp2_error(), command_rsp3_error(), command_rsp4_error(), command_rsp5_error(), command_rsp6_error(), scr_find(), sd_irq_service(), and sdio_command_data_send().

◆ sdio_flow_control_enable()

void sdio_flow_control_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable hardware flow control.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 168 of file at32f435_437_sdio.c.

Referenced by sd_power_on().

◆ sdio_interrupt_enable()

void sdio_interrupt_enable | ( | sdio_type * | sdio_x,
 |  | uint32_t | int_opt,
 |  | confirm_state | new_state
 | ) |  |

config corresponding interrupt.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
int_opt this parameter can be one of the following values:
  • SDIO_CMDFAIL_INT
  • SDIO_DTFAIL_INT
  • SDIO_CMDTIMEOUT_INT
  • SDIO_DTTIMEOUT_INT
  • SDIO_TXERRU_INT
  • SDIO_RXERRO_INT
  • SDIO_CMDRSPCMPL_INT
  • SDIO_CMDCMPL_INT
  • SDIO_DTCMP_INT
  • SDIO_SBITERR_INT
  • SDIO_DTBLKCMPL_INT
  • SDIO_DOCMD_INT
  • SDIO_DOTX_INT
  • SDIO_DORX_INT
  • SDIO_TXBUFH_INT
  • SDIO_RXBUFH_INT
  • SDIO_TXBUFF_INT
  • SDIO_RXBUFF_INT
  • SDIO_TXBUFE_INT
  • SDIO_RXBUFE_INT
  • SDIO_TXBUF_INT
  • SDIO_RXBUF_INT
  • SDIO_SDIOIF_INT
new_state | (TRUE or FALSE)
Return values
none

Definition at line 232 of file at32f435_437_sdio.c.

Referenced by sd_irq_service().

◆ sdio_io_function_enable()

void sdio_io_function_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the sd i/o function.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 545 of file at32f435_437_sdio.c.

◆ sdio_io_suspend_command_set()

void sdio_io_suspend_command_set | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable sd i/o suspend command sending.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 558 of file at32f435_437_sdio.c.

◆ sdio_power_saving_mode_enable()

void sdio_power_saving_mode_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable power saving mode, config sdio_ck clock output when the bus is idle.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 155 of file at32f435_437_sdio.c.

Referenced by sd_power_on().

◆ sdio_power_set()

void sdio_power_set | ( | sdio_type * | sdio_x,
 |  | sdio_power_state_type | power_state
 | ) |  |

set the power status of the controller

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
power_state this parameter can be one of the following values:
  • SDIO_POWER_OFF
  • SDIO_POWER_ON
Return values
none

Definition at line 75 of file at32f435_437_sdio.c.

Referenced by sd_power_off(), and sd_power_on().

◆ sdio_power_status_get()

sdio_power_state_type sdio_power_status_get ( sdio_type * sdio_x )

get power status.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
Return values
sdio_power_state_type (SDIO_POWER_ON or SDIO_POWER_OFF)

Definition at line 87 of file at32f435_437_sdio.c.

Referenced by sd_card_init().

◆ sdio_read_wait_mode_set()

void sdio_read_wait_mode_set | ( | sdio_type * | sdio_x,
 |  | sdio_read_wait_mode_type | mode
 | ) |  |

set the read wait mode.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
mode this parameter can be one of the following values:
  • SDIO_READ_WAIT_CONTROLLED_BY_D2
  • SDIO_READ_WAIT_CONTROLLED_BY_CK
Return values
none

Definition at line 506 of file at32f435_437_sdio.c.

◆ sdio_read_wait_start()

void sdio_read_wait_start | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable to start sd i/o read wait operation.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 519 of file at32f435_437_sdio.c.

◆ sdio_read_wait_stop()

void sdio_read_wait_stop | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable to stop sd i/o read wait operation.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 532 of file at32f435_437_sdio.c.

◆ sdio_reset()

void sdio_reset ( sdio_type * sdio_x )

reset the sdio register

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
Return values
none

Definition at line 51 of file at32f435_437_sdio.c.

Referenced by sd_init().

◆ sdio_response_get()

uint32_t sdio_response_get | ( | sdio_type * | sdio_x,
 |  | sdio_rsp_index_type | reg_index
 | ) |  |

get response received from the card for the last command.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
reg_index this parameter can be one of the following values:
  • SDIO_RSP1_INDEX
  • SDIO_RSP2_INDEX
  • SDIO_RSP3_INDEX
  • SDIO_RSP4_INDEX
Return values
uint32_t response register value

Definition at line 383 of file at32f435_437_sdio.c.

Referenced by check_card_programming(), command_rsp1_error(), command_rsp5_error(), command_rsp6_error(), mmc_stream_read(), mmc_stream_write(), mmc_switch(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), and sd_status_send().


AT32F435/437 Firmwary Library: SDIO_private_functions

Functions
SDIO_private_functions
AT32F435_437_periph_driver » SDIO

Functions

void | sdio_reset (sdio_type *sdio_x)
reset the sdio register More...
void | sdio_power_set (sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller More...
sdio_power_state_type | sdio_power_status_get (sdio_type *sdio_x)
get power status. More...
void | sdio_clock_config (sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock More...
void | sdio_bus_width_config (sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width More...
void | sdio_clock_bypass (sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss More...
void | sdio_power_saving_mode_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle. More...
void | sdio_flow_control_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control. More...
void | sdio_clock_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output. More...
void | sdio_dma_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable dma. More...
void | sdio_interrupt_enable (sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt. More...
flag_status | sdio_flag_get (sdio_type *sdio_x, uint32_t flag)
get sdio flag. More...
void | sdio_flag_clear (sdio_type *sdio_x, uint32_t flag)
clear sdio flag. More...
void | sdio_command_config (sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command. More...
void | sdio_command_state_machine_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM). More...
uint8_t | sdio_command_response_get (sdio_type *sdio_x)
get command index of last command for which response received. More...
uint32_t | sdio_response_get (sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command. More...
void | sdio_data_config (sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data. More...
void | sdio_data_state_machine_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM). More...
uint32_t | sdio_data_counter_get (sdio_type *sdio_x)
get the number of remaining data bytes to be transferred. More...
uint32_t | sdio_data_read (sdio_type *sdio_x)
read a word data from sdio fifo. More...
uint32_t | sdio_buffer_counter_get (sdio_type *sdio_x)
get the number of words left to be written to or read from fifo.. More...
void | sdio_data_write (sdio_type *sdio_x, uint32_t data)
write one word data to fifo. More...
void | sdio_read_wait_mode_set (sdio_type *sdio_x, sdio_read_wait_mode_type mode)
set the read wait mode. More...
void | sdio_read_wait_start (sdio_type *sdio_x, confirm_state new_state)
enable or disable to start sd i/o read wait operation. More...
void | sdio_read_wait_stop (sdio_type *sdio_x, confirm_state new_state)
enable or disable to stop sd i/o read wait operation. More...
void | sdio_io_function_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable the sd i/o function. More...
void | sdio_io_suspend_command_set (sdio_type *sdio_x, confirm_state new_state)
enable or disable sd i/o suspend command sending. More...

Detailed Description

Function Documentation

◆ sdio_buffer_counter_get()

uint32_t sdio_buffer_counter_get ( sdio_type * sdio_x )

get the number of words left to be written to or read from fifo..

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
Return values
uint32_t number of words

Definition at line 477 of file at32f435_437_sdio.c.

◆ sdio_bus_width_config()

void sdio_bus_width_config | ( | sdio_type * | sdio_x,
 |  | sdio_bus_width_type | width
 | ) |  |

config sdio bus width

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
width this parameter can be one of the following values:
  • SDIO_BUS_WIDTH_D1
  • SDIO_BUS_WIDTH_D4
  • SDIO_BUS_WIDTH_D8
Return values
none

Definition at line 128 of file at32f435_437_sdio.c.

Referenced by sd_power_on(), and sd_wide_bus_operation_config().

◆ sdio_clock_bypass()

void sdio_clock_bypass | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable clock divider bypss

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 141 of file at32f435_437_sdio.c.

Referenced by sd_power_on().

◆ sdio_clock_config()

void sdio_clock_config | ( | sdio_type * | sdio_x,
 |  | uint16_t | clk_div,
 |  | sdio_edge_phase_type | clk_edg
 | ) |  |

config sdio clock

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
clk_div | sdio clock divide factor(frequency = sdio_clk / [clk_psc + 2]).
clk_edg this parameter can be one of the following values:
  • SDIO_CLOCK_EDGE_RISING
  • SDIO_CLOCK_EDGE_FALLING
Return values
none

Definition at line 104 of file at32f435_437_sdio.c.

Referenced by sd_power_on().

◆ sdio_clock_enable()

void sdio_clock_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable sdio_ck output.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 181 of file at32f435_437_sdio.c.

Referenced by sd_power_on().

◆ sdio_command_config()

void sdio_command_config | ( | sdio_type * | sdio_x,
 |  | sdio_command_struct_type * | command_struct
 | ) |  |

config sdio command.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
command_struct | : pointer to a sdio_command_struct_type structure that contains the configuration information for the sdio command.
Return values
none

Definition at line 329 of file at32f435_437_sdio.c.

Referenced by check_card_programming(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), and sdio_command_data_send().

◆ sdio_command_response_get()

uint8_t sdio_command_response_get ( sdio_type * sdio_x )

get command index of last command for which response received.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
new_state | (TRUE or FALSE)
Return values
uint8_t command index

Definition at line 365 of file at32f435_437_sdio.c.

Referenced by check_card_programming(), command_rsp1_error(), command_rsp4_error(), command_rsp5_error(), and command_rsp6_error().

◆ sdio_command_state_machine_enable()

void sdio_command_state_machine_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable command path state machine(CPSM).

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 352 of file at32f435_437_sdio.c.

Referenced by check_card_programming(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), and sdio_command_data_send().

◆ sdio_data_config()

void sdio_data_config | ( | sdio_type * | sdio_x,
 |  | sdio_data_struct_type * | data_struct
 | ) |  |

config sdio data.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
data_struct | : pointer to a sdio_data_struct_type structure that contains the configuration information for the sdio data.
Return values
none

Definition at line 416 of file at32f435_437_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sdio_command_data_send().

◆ sdio_data_counter_get()

uint32_t sdio_data_counter_get ( sdio_type * sdio_x )

get the number of remaining data bytes to be transferred.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
Return values
uint32_t number of bytes

Definition at line 453 of file at32f435_437_sdio.c.

◆ sdio_data_read()

uint32_t sdio_data_read ( sdio_type * sdio_x )

read a word data from sdio fifo.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
Return values
uint32_t data received

Definition at line 465 of file at32f435_437_sdio.c.

Referenced by scr_find(), and sdio_command_data_send().

◆ sdio_data_state_machine_enable()

void sdio_data_state_machine_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable data path state machine(DPSM).

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 441 of file at32f435_437_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sdio_command_data_send().

◆ sdio_data_write()

void sdio_data_write | ( | sdio_type * | sdio_x,
 |  | uint32_t | data
 | ) |  |

write one word data to fifo.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
data | data to be transferred.
Return values
none

Definition at line 490 of file at32f435_437_sdio.c.

Referenced by sdio_command_data_send().

◆ sdio_dma_enable()

void sdio_dma_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dma.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 194 of file at32f435_437_sdio.c.

Referenced by sdio_command_data_send().

◆ sdio_flag_clear()

void sdio_flag_clear | ( | sdio_type * | sdio_x,
 |  | uint32_t | flag
 | ) |  |

clear sdio flag.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
int_opt this parameter can be any combination of the following values:
  • SDIO_CMDFAIL_FLAG
  • SDIO_DTFAIL_FLAG
  • SDIO_CMDTIMEOUT_FLAG
  • SDIO_DTTIMEOUT_FLAG
  • SDIO_TXERRU_FLAG
  • SDIO_RXERRO_FLAG
  • SDIO_CMDRSPCMPL_FLAG
  • SDIO_CMDCMPL_FLAG
  • SDIO_DTCMPL_FLAG
  • SDIO_SBITERR_FLAG
  • SDIO_DTBLKCMPL_FLAG
  • SDIO_SDIOIF_FLAG
Return values
none

Definition at line 315 of file at32f435_437_sdio.c.

Referenced by check_card_programming(), command_error(), command_rsp1_error(), command_rsp2_error(), command_rsp3_error(), command_rsp4_error(), command_rsp5_error(), command_rsp6_error(), command_rsp7_error(), mmc_stream_write(), scr_find(), sd_block_write(), sd_irq_service(), sd_mult_blocks_write(), and sdio_command_data_send().

◆ sdio_flag_get()

flag_status sdio_flag_get | ( | sdio_type * | sdio_x,
 |  | uint32_t | flag
 | ) |  |

get sdio flag.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
flag this parameter can be one of the following values:
  • SDIO_CMDFAIL_FLAG
  • SDIO_DTFAIL_FLAG
  • SDIO_CMDTIMEOUT_FLAG
  • SDIO_DTTIMEOUT_FLAG
  • SDIO_TXERRU_FLAG
  • SDIO_RXERRO_FLAG
  • SDIO_CMDRSPCMPL_FLAG
  • SDIO_CMDCMPL_FLAG
  • SDIO_DTCMPL_FLAG
  • SDIO_SBITERR_FLAG
  • SDIO_DTBLKCMPL_FLAG
  • SDIO_DOCMD_FLAG
  • SDIO_DOTX_FLAG
  • SDIO_DORX_FLAG
  • SDIO_TXBUFH_FLAG
  • SDIO_RXBUFH_FLAG
  • SDIO_TXBUFF_FLAG
  • SDIO_RXBUFF_FLAG
  • SDIO_TXBUFE_FLAG
  • SDIO_RXBUFE_FLAG
  • SDIO_TXBUF_FLAG
  • SDIO_RXBUF_FLAG
  • SDIO_SDIOIF_FLAG
Return values
flag_status (SET or RESET)

Definition at line 278 of file at32f435_437_sdio.c.

Referenced by check_card_programming(), command_error(), command_rsp1_error(), command_rsp2_error(), command_rsp3_error(), command_rsp4_error(), command_rsp5_error(), command_rsp6_error(), scr_find(), sd_irq_service(), and sdio_command_data_send().

◆ sdio_flow_control_enable()

void sdio_flow_control_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable hardware flow control.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 168 of file at32f435_437_sdio.c.

Referenced by sd_power_on().

◆ sdio_interrupt_enable()

void sdio_interrupt_enable | ( | sdio_type * | sdio_x,
 |  | uint32_t | int_opt,
 |  | confirm_state | new_state
 | ) |  |

config corresponding interrupt.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
int_opt this parameter can be one of the following values:
  • SDIO_CMDFAIL_INT
  • SDIO_DTFAIL_INT
  • SDIO_CMDTIMEOUT_INT
  • SDIO_DTTIMEOUT_INT
  • SDIO_TXERRU_INT
  • SDIO_RXERRO_INT
  • SDIO_CMDRSPCMPL_INT
  • SDIO_CMDCMPL_INT
  • SDIO_DTCMP_INT
  • SDIO_SBITERR_INT
  • SDIO_DTBLKCMPL_INT
  • SDIO_DOCMD_INT
  • SDIO_DOTX_INT
  • SDIO_DORX_INT
  • SDIO_TXBUFH_INT
  • SDIO_RXBUFH_INT
  • SDIO_TXBUFF_INT
  • SDIO_RXBUFF_INT
  • SDIO_TXBUFE_INT
  • SDIO_RXBUFE_INT
  • SDIO_TXBUF_INT
  • SDIO_RXBUF_INT
  • SDIO_SDIOIF_INT
new_state | (TRUE or FALSE)
Return values
none

Definition at line 232 of file at32f435_437_sdio.c.

Referenced by sd_irq_service().

◆ sdio_io_function_enable()

void sdio_io_function_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the sd i/o function.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 545 of file at32f435_437_sdio.c.

◆ sdio_io_suspend_command_set()

void sdio_io_suspend_command_set | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable sd i/o suspend command sending.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 558 of file at32f435_437_sdio.c.

◆ sdio_power_saving_mode_enable()

void sdio_power_saving_mode_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable power saving mode, config sdio_ck clock output when the bus is idle.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 155 of file at32f435_437_sdio.c.

Referenced by sd_power_on().

◆ sdio_power_set()

void sdio_power_set | ( | sdio_type * | sdio_x,
 |  | sdio_power_state_type | power_state
 | ) |  |

set the power status of the controller

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
power_state this parameter can be one of the following values:
  • SDIO_POWER_OFF
  • SDIO_POWER_ON
Return values
none

Definition at line 75 of file at32f435_437_sdio.c.

Referenced by sd_power_off(), and sd_power_on().

◆ sdio_power_status_get()

sdio_power_state_type sdio_power_status_get ( sdio_type * sdio_x )

get power status.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
Return values
sdio_power_state_type (SDIO_POWER_ON or SDIO_POWER_OFF)

Definition at line 87 of file at32f435_437_sdio.c.

Referenced by sd_card_init().

◆ sdio_read_wait_mode_set()

void sdio_read_wait_mode_set | ( | sdio_type * | sdio_x,
 |  | sdio_read_wait_mode_type | mode
 | ) |  |

set the read wait mode.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
mode this parameter can be one of the following values:
  • SDIO_READ_WAIT_CONTROLLED_BY_D2
  • SDIO_READ_WAIT_CONTROLLED_BY_CK
Return values
none

Definition at line 506 of file at32f435_437_sdio.c.

◆ sdio_read_wait_start()

void sdio_read_wait_start | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable to start sd i/o read wait operation.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 519 of file at32f435_437_sdio.c.

◆ sdio_read_wait_stop()

void sdio_read_wait_stop | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable to stop sd i/o read wait operation.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 532 of file at32f435_437_sdio.c.

◆ sdio_reset()

void sdio_reset ( sdio_type * sdio_x )

reset the sdio register

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
Return values
none

Definition at line 51 of file at32f435_437_sdio.c.

Referenced by sd_init().

◆ sdio_response_get()

uint32_t sdio_response_get | ( | sdio_type * | sdio_x,
 |  | sdio_rsp_index_type | reg_index
 | ) |  |

get response received from the card for the last command.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1, SDIO2.
reg_index this parameter can be one of the following values:
  • SDIO_RSP1_INDEX
  • SDIO_RSP2_INDEX
  • SDIO_RSP3_INDEX
  • SDIO_RSP4_INDEX
Return values
uint32_t response register value

Definition at line 383 of file at32f435_437_sdio.c.

Referenced by check_card_programming(), command_rsp1_error(), command_rsp5_error(), command_rsp6_error(), mmc_stream_read(), mmc_stream_write(), mmc_switch(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), and sd_status_send().


AT32F435/437 Firmwary Library: SPI

Modules | Macros
SPI
AT32F435_437_periph_driver

SPI driver modules. More...

Modules

SPI_I2S_flags_definition
spi i2s flag
SPI_I2S_interrupts_definition
spi i2s interrupt
SPI_exported_types
SPI_exported_functions
SPI_private_functions

Macros

#define | SPI1 ((spi_type *) SPI1_BASE)
#define | SPI2 ((spi_type *) SPI2_BASE)
#define | SPI3 ((spi_type *) SPI3_BASE)
#define | SPI4 ((spi_type *) SPI4_BASE)
#define | I2S2EXT ((spi_type *) I2S2EXT_BASE)
#define | I2S3EXT ((spi_type *) I2S3EXT_BASE)

Detailed Description

SPI driver modules.

Macro Definition Documentation

◆ I2S2EXT

#define I2S2EXT ((spi_type *) I2S2EXT_BASE)

Definition at line 457 of file at32f435_437_spi.h.

◆ I2S3EXT

#define I2S3EXT ((spi_type *) I2S3EXT_BASE)

Definition at line 458 of file at32f435_437_spi.h.

◆ SPI1

#define SPI1 ((spi_type *) SPI1_BASE)

Definition at line 453 of file at32f435_437_spi.h.

◆ SPI2

#define SPI2 ((spi_type *) SPI2_BASE)

Definition at line 454 of file at32f435_437_spi.h.

◆ SPI3

#define SPI3 ((spi_type *) SPI3_BASE)

Definition at line 455 of file at32f435_437_spi.h.

◆ SPI4

#define SPI4 ((spi_type *) SPI4_BASE)

Definition at line 456 of file at32f435_437_spi.h.


AT32F435/437 Firmwary Library: SPI_I2S_flags_definition

Macros
SPI_I2S_flags_definition
AT32F435_437_periph_driver » SPI

spi i2s flag More...

Macros

#define | SPI_I2S_RDBF_FLAG 0x0001
#define | SPI_I2S_TDBE_FLAG 0x0002
#define | I2S_ACS_FLAG 0x0004
#define | I2S_TUERR_FLAG 0x0008
#define | SPI_CCERR_FLAG 0x0010
#define | SPI_MMERR_FLAG 0x0020
#define | SPI_I2S_ROERR_FLAG 0x0040
#define | SPI_I2S_BF_FLAG 0x0080
#define | SPI_CSPAS_FLAG 0x0100

Detailed Description

spi i2s flag

Macro Definition Documentation

◆ I2S_ACS_FLAG

#define I2S_ACS_FLAG 0x0004

i2s audio channel state flag

Definition at line 55 of file at32f435_437_spi.h.

◆ I2S_TUERR_FLAG

#define I2S_TUERR_FLAG 0x0008

i2s transmitter underload error flag

Definition at line 56 of file at32f435_437_spi.h.

◆ SPI_CCERR_FLAG

#define SPI_CCERR_FLAG 0x0010

spi crc calculation error flag

Definition at line 57 of file at32f435_437_spi.h.

◆ SPI_CSPAS_FLAG

#define SPI_CSPAS_FLAG 0x0100

spi cs pulse abnormal setting fiag

Definition at line 61 of file at32f435_437_spi.h.

◆ SPI_I2S_BF_FLAG

#define SPI_I2S_BF_FLAG 0x0080

spi or i2s busy flag

Definition at line 60 of file at32f435_437_spi.h.

◆ SPI_I2S_RDBF_FLAG

#define SPI_I2S_RDBF_FLAG 0x0001

spi or i2s receive data buffer full flag

Definition at line 53 of file at32f435_437_spi.h.

◆ SPI_I2S_ROERR_FLAG

#define SPI_I2S_ROERR_FLAG 0x0040

spi or i2s receiver overflow error flag

Definition at line 59 of file at32f435_437_spi.h.

◆ SPI_I2S_TDBE_FLAG

#define SPI_I2S_TDBE_FLAG 0x0002

spi or i2s transmit data buffer empty flag

Definition at line 54 of file at32f435_437_spi.h.

◆ SPI_MMERR_FLAG

#define SPI_MMERR_FLAG 0x0020

spi master mode error flag

Definition at line 58 of file at32f435_437_spi.h.


AT32F435/437 Firmwary Library: SPI_I2S_interrupts_definition

Macros
SPI_I2S_interrupts_definition
AT32F435_437_periph_driver » SPI

spi i2s interrupt More...

Macros

#define | SPI_I2S_ERROR_INT 0x0020
#define | SPI_I2S_RDBF_INT 0x0040
#define | SPI_I2S_TDBE_INT 0x0080

Detailed Description

spi i2s interrupt

Macro Definition Documentation

◆ SPI_I2S_ERROR_INT

#define SPI_I2S_ERROR_INT 0x0020

error interrupt

Definition at line 73 of file at32f435_437_spi.h.

◆ SPI_I2S_RDBF_INT

#define SPI_I2S_RDBF_INT 0x0040

receive data buffer full interrupt

Definition at line 74 of file at32f435_437_spi.h.

◆ SPI_I2S_TDBE_INT

#define SPI_I2S_TDBE_INT 0x0080

transmit data buffer empty interrupt

Definition at line 75 of file at32f435_437_spi.h.


AT32F435/437 Firmwary Library: SPI_exported_types

Data Structures | Enumerations
SPI_exported_types
AT32F435_437_periph_driver » SPI

Data Structures

struct | spi_init_type
spi init type More...
struct | i2s_init_type
i2s init type More...
struct | spi_type
type define spi register all More...

Enumerations

enum | spi_frame_bit_num_type { SPI_FRAME_8BIT = 0x00 , SPI_FRAME_16BIT = 0x01 }
spi frame bit num type More...
enum | spi_master_slave_mode_type { SPI_MODE_SLAVE = 0x00 , SPI_MODE_MASTER = 0x01 }
spi master/slave mode type More...
enum | spi_clock_polarity_type { SPI_CLOCK_POLARITY_LOW = 0x00 , SPI_CLOCK_POLARITY_HIGH = 0x01 }
spi clock polarity (clkpol) type More...
enum | spi_clock_phase_type { SPI_CLOCK_PHASE_1EDGE = 0x00 , SPI_CLOCK_PHASE_2EDGE = 0x01 }
spi clock phase (clkpha) type More...
enum | spi_cs_mode_type { SPI_CS_HARDWARE_MODE = 0x00 , SPI_CS_SOFTWARE_MODE = 0x01 }
spi cs mode type More...
enum spi_mclk_freq_div_type {
SPI_MCLK_DIV_2 = 0x00 , SPI_MCLK_DIV_3 = 0x0A , SPI_MCLK_DIV_4 = 0x01 , SPI_MCLK_DIV_8 = 0x02 ,
SPI_MCLK_DIV_16 = 0x03 , SPI_MCLK_DIV_32 = 0x04 , SPI_MCLK_DIV_64 = 0x05 , SPI_MCLK_DIV_128 = 0x06 ,
SPI_MCLK_DIV_256 = 0x07 , SPI_MCLK_DIV_512 = 0x08 , SPI_MCLK_DIV_1024 = 0x09
}
spi master clock frequency division type More...
enum | spi_first_bit_type { SPI_FIRST_BIT_MSB = 0x00 , SPI_FIRST_BIT_LSB = 0x01 }
spi transmit first bit (lsb/msb) type More...
enum | spi_transmission_mode_type { SPI_TRANSMIT_FULL_DUPLEX = 0x00 , SPI_TRANSMIT_SIMPLEX_RX = 0x01 , SPI_TRANSMIT_HALF_DUPLEX_RX = 0x02 , SPI_TRANSMIT_HALF_DUPLEX_TX = 0x03 }
spi transmission mode type More...
enum | spi_crc_direction_type { SPI_CRC_RX = 0x0014 , SPI_CRC_TX = 0x0018 }
spi crc direction type More...
enum | spi_half_duplex_direction_type { SPI_HALF_DUPLEX_DIRECTION_RX = 0x00 , SPI_HALF_DUPLEX_DIRECTION_TX = 0x01 }
spi single line bidirectional direction type More...
enum | spi_software_cs_level_type { SPI_SWCS_INTERNAL_LEVEL_LOW = 0x00 , SPI_SWCS_INTERNAL_LEVEL_HIGHT = 0x01 }
spi software cs internal level type More...
enum i2s_audio_protocol_type {
I2S_AUDIO_PROTOCOL_PHILLIPS = 0x00 , I2S_AUDIO_PROTOCOL_MSB = 0x01 , I2S_AUDIO_PROTOCOL_LSB = 0x02 , I2S_AUDIO_PROTOCOL_PCM_SHORT = 0x03 ,
I2S_AUDIO_PROTOCOL_PCM_LONG = 0x04
}
i2s audio protocol type More...
enum i2s_audio_sampling_freq_type {
I2S_AUDIO_FREQUENCY_DEFAULT = 2 , I2S_AUDIO_FREQUENCY_8K = 8000 , I2S_AUDIO_FREQUENCY_11_025K = 11025 , I2S_AUDIO_FREQUENCY_16K = 16000 ,
I2S_AUDIO_FREQUENCY_22_05K = 22050 , I2S_AUDIO_FREQUENCY_32K = 32000 , I2S_AUDIO_FREQUENCY_44_1K = 44100 , I2S_AUDIO_FREQUENCY_48K = 48000 ,
I2S_AUDIO_FREQUENCY_96K = 96000 , I2S_AUDIO_FREQUENCY_192K = 192000
}
i2s audio frequency type More...
enum | i2s_data_channel_format_type { I2S_DATA_16BIT_CHANNEL_16BIT = 0x01 , I2S_DATA_16BIT_CHANNEL_32BIT = 0x02 , I2S_DATA_24BIT_CHANNEL_32BIT = 0x03 , I2S_DATA_32BIT_CHANNEL_32BIT = 0x04 }
i2s data bit num and channel bit num type More...
enum | i2s_operation_mode_type { I2S_MODE_SLAVE_TX = 0x00 , I2S_MODE_SLAVE_RX = 0x01 , I2S_MODE_MASTER_TX = 0x02 , I2S_MODE_MASTER_RX = 0x03 }
i2s operation mode type More...
enum | i2s_clock_polarity_type { I2S_CLOCK_POLARITY_LOW = 0x00 , I2S_CLOCK_POLARITY_HIGH = 0x01 }
i2s clock polarity type More...

Detailed Description

Enumeration Type Documentation

◆ i2s_audio_protocol_type

enum i2s_audio_protocol_type

i2s audio protocol type

Enumerator
I2S_AUDIO_PROTOCOL_PHILLIPS | i2s philip standard
I2S_AUDIO_PROTOCOL_MSB | msb-justified standard
I2S_AUDIO_PROTOCOL_LSB | lsb-justified standard
I2S_AUDIO_PROTOCOL_PCM_SHORT | pcm standard-short frame
I2S_AUDIO_PROTOCOL_PCM_LONG | pcm standard-long frame

Definition at line 198 of file at32f435_437_spi.h.

◆ i2s_audio_sampling_freq_type

enum i2s_audio_sampling_freq_type

i2s audio frequency type

Enumerator
I2S_AUDIO_FREQUENCY_DEFAULT | i2s audio sampling frequency default
I2S_AUDIO_FREQUENCY_8K | i2s audio sampling frequency 8k
I2S_AUDIO_FREQUENCY_11_025K | i2s audio sampling frequency 11.025k
I2S_AUDIO_FREQUENCY_16K | i2s audio sampling frequency 16k
I2S_AUDIO_FREQUENCY_22_05K | i2s audio sampling frequency 22.05k
I2S_AUDIO_FREQUENCY_32K | i2s audio sampling frequency 32k
I2S_AUDIO_FREQUENCY_44_1K | i2s audio sampling frequency 44.1k
I2S_AUDIO_FREQUENCY_48K | i2s audio sampling frequency 48k
I2S_AUDIO_FREQUENCY_96K | i2s audio sampling frequency 96k
I2S_AUDIO_FREQUENCY_192K | i2s audio sampling frequency 192k

Definition at line 210 of file at32f435_437_spi.h.

◆ i2s_clock_polarity_type

enum i2s_clock_polarity_type

i2s clock polarity type

Enumerator
I2S_CLOCK_POLARITY_LOW | i2s clock steady state is low level
I2S_CLOCK_POLARITY_HIGH | i2s clock steady state is high level

Definition at line 249 of file at32f435_437_spi.h.

◆ i2s_data_channel_format_type

enum i2s_data_channel_format_type

i2s data bit num and channel bit num type

Enumerator
I2S_DATA_16BIT_CHANNEL_16BIT | 16-bit data packed in 16-bit channel frame
I2S_DATA_16BIT_CHANNEL_32BIT | 16-bit data packed in 32-bit channel frame
I2S_DATA_24BIT_CHANNEL_32BIT | 24-bit data packed in 32-bit channel frame
I2S_DATA_32BIT_CHANNEL_32BIT | 32-bit data packed in 32-bit channel frame

Definition at line 227 of file at32f435_437_spi.h.

◆ i2s_operation_mode_type

enum i2s_operation_mode_type

i2s operation mode type

Enumerator
I2S_MODE_SLAVE_TX | slave transmission mode
I2S_MODE_SLAVE_RX | slave reception mode
I2S_MODE_MASTER_TX | master transmission mode
I2S_MODE_MASTER_RX | master reception mode

Definition at line 238 of file at32f435_437_spi.h.

◆ spi_clock_phase_type

enum spi_clock_phase_type

spi clock phase (clkpha) type

Enumerator
SPI_CLOCK_PHASE_1EDGE | data capture start from the first clock edge
SPI_CLOCK_PHASE_2EDGE | data capture start from the second clock edge

Definition at line 115 of file at32f435_437_spi.h.

◆ spi_clock_polarity_type

enum spi_clock_polarity_type

spi clock polarity (clkpol) type

Enumerator
SPI_CLOCK_POLARITY_LOW | sck keeps low at idle state
SPI_CLOCK_POLARITY_HIGH | sck keeps high at idle state

Definition at line 106 of file at32f435_437_spi.h.

◆ spi_crc_direction_type

enum spi_crc_direction_type

spi crc direction type

Enumerator
SPI_CRC_RX | crc direction is rx
SPI_CRC_TX | crc direction is tx

Definition at line 171 of file at32f435_437_spi.h.

◆ spi_cs_mode_type

enum spi_cs_mode_type

spi cs mode type

Enumerator
SPI_CS_HARDWARE_MODE | cs is hardware mode
SPI_CS_SOFTWARE_MODE | cs is software mode

Definition at line 124 of file at32f435_437_spi.h.

◆ spi_first_bit_type

enum spi_first_bit_type

spi transmit first bit (lsb/msb) type

Enumerator
SPI_FIRST_BIT_MSB | the frame format is msb first
SPI_FIRST_BIT_LSB | the frame format is lsb first

Definition at line 151 of file at32f435_437_spi.h.

◆ spi_frame_bit_num_type

enum spi_frame_bit_num_type

spi frame bit num type

Enumerator
SPI_FRAME_8BIT | 8-bit data frame format
SPI_FRAME_16BIT | 16-bit data frame format

Definition at line 88 of file at32f435_437_spi.h.

◆ spi_half_duplex_direction_type

enum spi_half_duplex_direction_type

spi single line bidirectional direction type

Enumerator
SPI_HALF_DUPLEX_DIRECTION_RX | single line bidirectional half duplex mode direction: receive(slbtd = 0)
SPI_HALF_DUPLEX_DIRECTION_TX | single line bidirectional half duplex mode direction: transmit(slbtd = 1)

Definition at line 180 of file at32f435_437_spi.h.

◆ spi_master_slave_mode_type

enum spi_master_slave_mode_type

spi master/slave mode type

Enumerator
SPI_MODE_SLAVE | select as slave mode
SPI_MODE_MASTER | select as master mode

Definition at line 97 of file at32f435_437_spi.h.

◆ spi_mclk_freq_div_type

enum spi_mclk_freq_div_type

spi master clock frequency division type

Enumerator
SPI_MCLK_DIV_2 | master clock frequency division 2
SPI_MCLK_DIV_3 | master clock frequency division 3
SPI_MCLK_DIV_4 | master clock frequency division 4
SPI_MCLK_DIV_8 | master clock frequency division 8
SPI_MCLK_DIV_16 | master clock frequency division 16
SPI_MCLK_DIV_32 | master clock frequency division 32
SPI_MCLK_DIV_64 | master clock frequency division 64
SPI_MCLK_DIV_128 | master clock frequency division 128
SPI_MCLK_DIV_256 | master clock frequency division 256
SPI_MCLK_DIV_512 | master clock frequency division 512
SPI_MCLK_DIV_1024 | master clock frequency division 1024

Definition at line 133 of file at32f435_437_spi.h.

◆ spi_software_cs_level_type

enum spi_software_cs_level_type

spi software cs internal level type

Enumerator
SPI_SWCS_INTERNAL_LEVEL_LOW | internal level low
SPI_SWCS_INTERNAL_LEVEL_HIGHT | internal level high

Definition at line 189 of file at32f435_437_spi.h.

◆ spi_transmission_mode_type

enum spi_transmission_mode_type

spi transmission mode type

Enumerator
SPI_TRANSMIT_FULL_DUPLEX | dual line unidirectional full-duplex mode(slben = 0 and ora = 0)
SPI_TRANSMIT_SIMPLEX_RX | dual line unidirectional simplex receive-only mode(slben = 0 and ora = 1)
SPI_TRANSMIT_HALF_DUPLEX_RX | single line bidirectional half duplex mode-receiving(slben = 1 and slbtd = 0)
SPI_TRANSMIT_HALF_DUPLEX_TX | single line bidirectional half duplex mode-transmitting(slben = 1 and slbtd = 1)

Definition at line 160 of file at32f435_437_spi.h.


AT32F435/437 Firmwary Library: spi_init_type Struct Reference

Data Fields
spi_init_type Struct Reference
AT32F435_437_periph_driver » SPI » SPI_exported_types

spi init type More...

#include <at32f435_437_spi.h>

Data Fields

spi_transmission_mode_type transmission_mode
spi_master_slave_mode_type master_slave_mode
spi_mclk_freq_div_type mclk_freq_division
spi_first_bit_type first_bit_transmission
spi_frame_bit_num_type frame_bit_num
spi_clock_polarity_type clock_polarity
spi_clock_phase_type clock_phase
spi_cs_mode_type cs_mode_selection

Detailed Description

spi init type

Definition at line 258 of file at32f435_437_spi.h.

Field Documentation

◆ clock_phase

spi_clock_phase_type spi_init_type::clock_phase

clock phase selection

Definition at line 266 of file at32f435_437_spi.h.

Referenced by spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), touch_pin_init(), and usart_spi_configuration().

◆ clock_polarity

spi_clock_polarity_type spi_init_type::clock_polarity

clock polarity selection

Definition at line 265 of file at32f435_437_spi.h.

Referenced by spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), touch_pin_init(), and usart_spi_configuration().

◆ cs_mode_selection

spi_cs_mode_type spi_init_type::cs_mode_selection

hardware or software cs mode selection

Definition at line 267 of file at32f435_437_spi.h.

Referenced by spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), touch_pin_init(), and usart_spi_configuration().

◆ first_bit_transmission

spi_first_bit_type spi_init_type::first_bit_transmission

transmit lsb or msb selection

Definition at line 263 of file at32f435_437_spi.h.

Referenced by spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), touch_pin_init(), and usart_spi_configuration().

◆ frame_bit_num

spi_frame_bit_num_type spi_init_type::frame_bit_num

frame bit num 8 or 16 bit selection

Definition at line 264 of file at32f435_437_spi.h.

Referenced by spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), touch_pin_init(), and usart_spi_configuration().

◆ master_slave_mode

spi_master_slave_mode_type spi_init_type::master_slave_mode

master or slave mode selection

Definition at line 261 of file at32f435_437_spi.h.

Referenced by main(), spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), touch_pin_init(), and usart_spi_configuration().

◆ mclk_freq_division

spi_mclk_freq_div_type spi_init_type::mclk_freq_division

master clock frequency division selection

Definition at line 262 of file at32f435_437_spi.h.

Referenced by spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), and touch_pin_init().

◆ transmission_mode

spi_transmission_mode_type spi_init_type::transmission_mode

transmission mode selection

Definition at line 260 of file at32f435_437_spi.h.

Referenced by main(), spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), touch_pin_init(), and usart_spi_configuration().

The documentation for this struct was generated from the following file:
  • at32f435_437_spi.h


AT32F435/437 Firmwary Library: i2s_init_type Struct Reference

Data Fields
i2s_init_type Struct Reference
AT32F435_437_periph_driver » SPI » SPI_exported_types

i2s init type More...

#include <at32f435_437_spi.h>

Data Fields

i2s_operation_mode_type operation_mode
i2s_audio_protocol_type audio_protocol
i2s_audio_sampling_freq_type audio_sampling_freq
i2s_data_channel_format_type data_channel_format
i2s_clock_polarity_type clock_polarity
confirm_state mclk_output_enable

Detailed Description

i2s init type

Definition at line 273 of file at32f435_437_spi.h.

Field Documentation

◆ audio_protocol

i2s_audio_protocol_type i2s_init_type::audio_protocol

audio protocol selection

Definition at line 276 of file at32f435_437_spi.h.

Referenced by codec_i2s_init(), i2s_config(), i2s_default_para_init(), and i2s_init().

◆ audio_sampling_freq

i2s_audio_sampling_freq_type i2s_init_type::audio_sampling_freq

audio frequency selection

Definition at line 277 of file at32f435_437_spi.h.

Referenced by codec_i2s_init(), i2s_config(), i2s_default_para_init(), and i2s_init().

◆ clock_polarity

i2s_clock_polarity_type i2s_init_type::clock_polarity

clock polarity selection

Definition at line 279 of file at32f435_437_spi.h.

Referenced by codec_i2s_init(), i2s_config(), i2s_default_para_init(), and i2s_init().

◆ data_channel_format

i2s_data_channel_format_type i2s_init_type::data_channel_format

data bit num and channel bit num selection

Definition at line 278 of file at32f435_437_spi.h.

Referenced by codec_i2s_init(), i2s_config(), i2s_default_para_init(), and i2s_init().

◆ mclk_output_enable

confirm_state i2s_init_type::mclk_output_enable

mclk_output selection

Definition at line 280 of file at32f435_437_spi.h.

Referenced by codec_i2s_init(), i2s_config(), i2s_default_para_init(), and i2s_init().

◆ operation_mode

i2s_operation_mode_type i2s_init_type::operation_mode

operation mode selection

Definition at line 275 of file at32f435_437_spi.h.

Referenced by codec_i2s_init(), i2s_config(), i2s_default_para_init(), and i2s_init().

The documentation for this struct was generated from the following file:
  • at32f435_437_spi.h


AT32F435/437 Firmwary Library: spi_type Struct Reference

Data Fields
spi_type Struct Reference
AT32F435_437_periph_driver » SPI » SPI_exported_types

type define spi register all More...

#include <at32f435_437_spi.h>

Data Fields

union {
__IO uint32_t ctrl1
struct {
__IO uint32_t clkpha: 1
__IO uint32_t clkpol: 1
__IO uint32_t msten: 1
__IO uint32_t mdiv_l: 3
__IO uint32_t spien: 1
__IO uint32_t ltf: 1
__IO uint32_t swcsil: 1
__IO uint32_t swcsen: 1
__IO uint32_t ora: 1
__IO uint32_t fbn: 1
__IO uint32_t ntc: 1
__IO uint32_t ccen: 1
__IO uint32_t slbtd: 1
__IO uint32_t slben: 1
__IO uint32_t reserved1: 16
} ctrl1_bit
};
spi ctrl1 register, offset:0x00 More...
union {
__IO uint32_t ctrl2
struct {
__IO uint32_t dmaren: 1
__IO uint32_t dmaten: 1
__IO uint32_t hwcsoe: 1
__IO uint32_t reserved1: 1
__IO uint32_t tien: 1
__IO uint32_t errie: 1
__IO uint32_t rdbfie: 1
__IO uint32_t tdbeie: 1
__IO uint32_t mdiv_h: 1
__IO uint32_t mdiv3en: 1
__IO uint32_t reserved2: 22
} ctrl2_bit
};
spi ctrl2 register, offset:0x04 More...
union {
__IO uint32_t sts
struct {
__IO uint32_t rdbf: 1
__IO uint32_t tdbe: 1
__IO uint32_t acs: 1
__IO uint32_t tuerr: 1
__IO uint32_t ccerr: 1
__IO uint32_t mmerr: 1
__IO uint32_t roerr: 1
__IO uint32_t bf: 1
__IO uint32_t cspas: 1
__IO uint32_t reserved1: 23
} sts_bit
};
spi sts register, offset:0x08 More...
union {
__IO uint32_t dt
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt_bit
};
spi dt register, offset:0x0C More...
union {
__IO uint32_t cpoly
struct {
__IO uint32_t cpoly: 16
__IO uint32_t reserved1: 16
} cpoly_bit
};
spi cpoly register, offset:0x10 More...
union {
__IO uint32_t rcrc
struct {
__IO uint32_t rcrc: 16
__IO uint32_t reserved1: 16
} rcrc_bit
};
spi rcrc register, offset:0x14 More...
union {
__IO uint32_t tcrc
struct {
__IO uint32_t tcrc: 16
__IO uint32_t reserved1: 16
} tcrc_bit
};
spi tcrc register, offset:0x18 More...
union {
__IO uint32_t i2sctrl
struct {
__IO uint32_t i2scbn: 1
__IO uint32_t i2sdbn: 2
__IO uint32_t i2sclkpol: 1
__IO uint32_t stdsel: 2
__IO uint32_t reserved1: 1
__IO uint32_t pcmfssel: 1
__IO uint32_t opersel: 2
__IO uint32_t i2sen: 1
__IO uint32_t i2smsel: 1
__IO uint32_t reserved2: 20
} i2sctrl_bit
};
spi i2sctrl register, offset:0x1C More...
union {
__IO uint32_t i2sclk
struct {
__IO uint32_t i2sdiv_l: 8
__IO uint32_t i2sodd: 1
__IO uint32_t i2smclkoe: 1
__IO uint32_t i2sdiv_h: 2
__IO uint32_t reserved1: 20
} i2sclk_bit
};
spi i2sclk register, offset:0x20 More...

Detailed Description

type define spi register all

Definition at line 286 of file at32f435_437_spi.h.

Field Documentation

◆

union { ... } spi_type::@1031

spi ctrl1 register, offset:0x00

◆

union { ... } spi_type::@1033

spi ctrl2 register, offset:0x04

◆

union { ... } spi_type::@1035

spi sts register, offset:0x08

◆

union { ... } spi_type::@1037

spi dt register, offset:0x0C

◆

union { ... } spi_type::@1039

spi cpoly register, offset:0x10

◆

union { ... } spi_type::@1041

spi rcrc register, offset:0x14

◆

union { ... } spi_type::@1043

spi tcrc register, offset:0x18

◆

union { ... } spi_type::@1045

spi i2sctrl register, offset:0x1C

◆

union { ... } spi_type::@1047

spi i2sclk register, offset:0x20

◆ acs

__IO uint32_t spi_type::acs

Definition at line 347 of file at32f435_437_spi.h.

◆ bf

__IO uint32_t spi_type::bf

Definition at line 352 of file at32f435_437_spi.h.

◆ ccen

__IO uint32_t spi_type::ccen

Definition at line 308 of file at32f435_437_spi.h.

Referenced by spi_crc_enable().

◆ ccerr

__IO uint32_t spi_type::ccerr

Definition at line 349 of file at32f435_437_spi.h.

◆ clkpha

__IO uint32_t spi_type::clkpha

Definition at line 297 of file at32f435_437_spi.h.

Referenced by spi_init().

◆ clkpol

__IO uint32_t spi_type::clkpol

Definition at line 298 of file at32f435_437_spi.h.

Referenced by spi_init().

◆ cpoly

__IO uint32_t spi_type::cpoly

Definition at line 376 of file at32f435_437_spi.h.

Referenced by spi_crc_polynomial_get(), and spi_crc_polynomial_set().

◆

struct { ... } spi_type::cpoly_bit

Referenced by spi_crc_polynomial_get(), and spi_crc_polynomial_set().

◆ cspas

__IO uint32_t spi_type::cspas

Definition at line 353 of file at32f435_437_spi.h.

◆ ctrl1

__IO uint32_t spi_type::ctrl1

Definition at line 294 of file at32f435_437_spi.h.

Referenced by spi_i2s_flag_clear().

◆

struct { ... } spi_type::ctrl1_bit

Referenced by spi_crc_enable(), spi_crc_next_transmit(), spi_enable(), spi_frame_bit_num_set(), spi_half_duplex_direction_set(), spi_init(), and spi_software_cs_internal_level_set().

◆ ctrl2

__IO uint32_t spi_type::ctrl2

Definition at line 320 of file at32f435_437_spi.h.

Referenced by spi_i2s_interrupt_enable().

◆

struct { ... } spi_type::ctrl2_bit

Referenced by spi_hardware_cs_output_enable(), spi_i2s_dma_receiver_enable(), spi_i2s_dma_transmitter_enable(), spi_init(), and spi_ti_mode_enable().

◆ dmaren

__IO uint32_t spi_type::dmaren

Definition at line 323 of file at32f435_437_spi.h.

Referenced by spi_i2s_dma_receiver_enable().

◆ dmaten

__IO uint32_t spi_type::dmaten

Definition at line 324 of file at32f435_437_spi.h.

Referenced by spi_i2s_dma_transmitter_enable().

◆ dt

__IO uint32_t spi_type::dt

Definition at line 363 of file at32f435_437_spi.h.

Referenced by spi_i2s_data_receive(), spi_i2s_data_transmit(), and spi_i2s_flag_clear().

◆

struct { ... } spi_type::dt_bit

◆ errie

__IO uint32_t spi_type::errie

Definition at line 328 of file at32f435_437_spi.h.

◆ fbn

__IO uint32_t spi_type::fbn

Definition at line 306 of file at32f435_437_spi.h.

Referenced by spi_frame_bit_num_set(), and spi_init().

◆ hwcsoe

__IO uint32_t spi_type::hwcsoe

Definition at line 325 of file at32f435_437_spi.h.

Referenced by spi_hardware_cs_output_enable().

◆ i2scbn

__IO uint32_t spi_type::i2scbn

Definition at line 418 of file at32f435_437_spi.h.

Referenced by i2s_init().

◆ i2sclk

__IO uint32_t spi_type::i2sclk

Definition at line 436 of file at32f435_437_spi.h.

◆

struct { ... } spi_type::i2sclk_bit

Referenced by i2s_init().

◆ i2sclkpol

__IO uint32_t spi_type::i2sclkpol

Definition at line 420 of file at32f435_437_spi.h.

Referenced by i2s_init().

◆ i2sctrl

__IO uint32_t spi_type::i2sctrl

Definition at line 415 of file at32f435_437_spi.h.

◆

struct { ... } spi_type::i2sctrl_bit

Referenced by i2s_enable(), i2s_init(), and spi_init().

◆ i2sdbn

__IO uint32_t spi_type::i2sdbn

Definition at line 419 of file at32f435_437_spi.h.

Referenced by i2s_init().

◆ i2sdiv_h

__IO uint32_t spi_type::i2sdiv_h

Definition at line 442 of file at32f435_437_spi.h.

Referenced by i2s_init().

◆ i2sdiv_l

__IO uint32_t spi_type::i2sdiv_l

Definition at line 439 of file at32f435_437_spi.h.

Referenced by i2s_init().

◆ i2sen

__IO uint32_t spi_type::i2sen

Definition at line 425 of file at32f435_437_spi.h.

Referenced by i2s_enable().

◆ i2smclkoe

__IO uint32_t spi_type::i2smclkoe

Definition at line 441 of file at32f435_437_spi.h.

Referenced by i2s_init().

◆ i2smsel

__IO uint32_t spi_type::i2smsel

Definition at line 426 of file at32f435_437_spi.h.

Referenced by i2s_init(), and spi_init().

◆ i2sodd

__IO uint32_t spi_type::i2sodd

Definition at line 440 of file at32f435_437_spi.h.

Referenced by i2s_init().

◆ ltf

__IO uint32_t spi_type::ltf

Definition at line 302 of file at32f435_437_spi.h.

Referenced by spi_init().

◆ mdiv3en

__IO uint32_t spi_type::mdiv3en

Definition at line 332 of file at32f435_437_spi.h.

Referenced by spi_init().

◆ mdiv_h

__IO uint32_t spi_type::mdiv_h

Definition at line 331 of file at32f435_437_spi.h.

Referenced by spi_init().

◆ mdiv_l

__IO uint32_t spi_type::mdiv_l

Definition at line 300 of file at32f435_437_spi.h.

Referenced by spi_init().

◆ mmerr

__IO uint32_t spi_type::mmerr

Definition at line 350 of file at32f435_437_spi.h.

◆ msten

__IO uint32_t spi_type::msten

Definition at line 299 of file at32f435_437_spi.h.

Referenced by spi_init().

◆ ntc

__IO uint32_t spi_type::ntc

Definition at line 307 of file at32f435_437_spi.h.

Referenced by spi_crc_next_transmit().

◆ opersel

__IO uint32_t spi_type::opersel

Definition at line 424 of file at32f435_437_spi.h.

Referenced by i2s_init().

◆ ora

__IO uint32_t spi_type::ora

Definition at line 305 of file at32f435_437_spi.h.

Referenced by spi_init().

◆ pcmfssel

__IO uint32_t spi_type::pcmfssel

Definition at line 423 of file at32f435_437_spi.h.

Referenced by i2s_init().

◆ rcrc

__IO uint32_t spi_type::rcrc

Definition at line 389 of file at32f435_437_spi.h.

Referenced by spi_crc_value_get().

◆

struct { ... } spi_type::rcrc_bit

Referenced by spi_crc_value_get().

◆ rdbf

__IO uint32_t spi_type::rdbf

Definition at line 345 of file at32f435_437_spi.h.

◆ rdbfie

__IO uint32_t spi_type::rdbfie

Definition at line 329 of file at32f435_437_spi.h.

◆ reserved1

__IO uint32_t spi_type::reserved1

Definition at line 311 of file at32f435_437_spi.h.

◆ reserved2

__IO uint32_t spi_type::reserved2

Definition at line 333 of file at32f435_437_spi.h.

◆ roerr

__IO uint32_t spi_type::roerr

Definition at line 351 of file at32f435_437_spi.h.

◆ slben

__IO uint32_t spi_type::slben

Definition at line 310 of file at32f435_437_spi.h.

Referenced by spi_init().

◆ slbtd

__IO uint32_t spi_type::slbtd

Definition at line 309 of file at32f435_437_spi.h.

Referenced by spi_half_duplex_direction_set(), and spi_init().

◆ spien

__IO uint32_t spi_type::spien

Definition at line 301 of file at32f435_437_spi.h.

Referenced by spi_enable().

◆ stdsel

__IO uint32_t spi_type::stdsel

Definition at line 421 of file at32f435_437_spi.h.

Referenced by i2s_init().

◆ sts

__IO uint32_t spi_type::sts

Definition at line 342 of file at32f435_437_spi.h.

Referenced by spi_i2s_flag_clear(), and spi_i2s_flag_get().

◆

struct { ... } spi_type::sts_bit

◆ swcsen

__IO uint32_t spi_type::swcsen

Definition at line 304 of file at32f435_437_spi.h.

Referenced by spi_init().

◆ swcsil

__IO uint32_t spi_type::swcsil

Definition at line 303 of file at32f435_437_spi.h.

Referenced by spi_init(), and spi_software_cs_internal_level_set().

◆ tcrc

__IO uint32_t spi_type::tcrc

Definition at line 402 of file at32f435_437_spi.h.

Referenced by spi_crc_value_get().

◆

struct { ... } spi_type::tcrc_bit

Referenced by spi_crc_value_get().

◆ tdbe

__IO uint32_t spi_type::tdbe

Definition at line 346 of file at32f435_437_spi.h.

◆ tdbeie

__IO uint32_t spi_type::tdbeie

Definition at line 330 of file at32f435_437_spi.h.

◆ tien

__IO uint32_t spi_type::tien

Definition at line 327 of file at32f435_437_spi.h.

Referenced by spi_ti_mode_enable().

◆ tuerr

__IO uint32_t spi_type::tuerr

Definition at line 348 of file at32f435_437_spi.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_spi.h


AT32F435/437 Firmwary Library: SPI_exported_functions

Functions
SPI_exported_functions
AT32F435_437_periph_driver » SPI

Functions

void | spi_i2s_reset (spi_type *spi_x)
spi reset by crm reset register More...
void | spi_default_para_init (spi_init_type *spi_init_struct)
spi init config with its default value. More...
void | spi_init (spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value. More...
void | spi_ti_mode_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the ti mode for the spi peripheral. More...
void | spi_crc_next_transmit (spi_type *spi_x)
spi next transmit crc for the spi peripheral. More...
void | spi_crc_polynomial_set (spi_type *spi_x, uint16_t crc_poly)
set the crc polynomial value for the spi peripheral. More...
uint16_t | spi_crc_polynomial_get (spi_type *spi_x)
return the crc polynomial register value for the spi peripheral. More...
void | spi_crc_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the hardware crc calculation for the spi peripheral. More...
uint16_t | spi_crc_value_get (spi_type *spi_x, spi_crc_direction_type crc_direction)
return the transmit or the receive crc value for the spi peripheral. More...
void | spi_hardware_cs_output_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the hardware cs output for the spi peripheral. More...
void | spi_software_cs_internal_level_set (spi_type *spi_x, spi_software_cs_level_type level)
set the software cs internal level for the spi peripheral. More...
void | spi_frame_bit_num_set (spi_type *spi_x, spi_frame_bit_num_type bit_num)
set the data frame bit num for the spi peripheral. More...
void | spi_half_duplex_direction_set (spi_type *spi_x, spi_half_duplex_direction_type direction)
set the data transmission direction in single line bidirectiona half duplex mode of the spi peripheral. More...
void | spi_enable (spi_type *spi_x, confirm_state new_state)
enable or disable spi. More...
void | i2s_default_para_init (i2s_init_type *i2s_init_struct)
i2s init config with its default value. More...
void | i2s_init (spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value. More...
void | i2s_enable (spi_type *spi_x, confirm_state new_state)
enable or disable i2s. More...
void | spi_i2s_interrupt_enable (spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts. More...
void | spi_i2s_dma_transmitter_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode. More...
void | spi_i2s_dma_receiver_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode. More...
void | spi_i2s_data_transmit (spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit More...
uint16_t | spi_i2s_data_receive (spi_type *spi_x)
spi/i2s data receive More...
flag_status | spi_i2s_flag_get (spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral. More...
void | spi_i2s_flag_clear (spi_type *spi_x, uint32_t spi_i2s_flag)
clear flag of the specified spi/i2s peripheral. More...

Detailed Description

Function Documentation

◆ i2s_default_para_init()

void i2s_default_para_init ( i2s_init_type * i2s_init_struct )

i2s init config with its default value.

Parameters
i2s_init_struct : pointer to a i2s_init_type structure which will be initialized.
Return values
none

Definition at line 332 of file at32f435_437_spi.c.

Referenced by codec_i2s_init(), and i2s_config().

◆ i2s_enable()

void i2s_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable i2s.

Parameters
spi_x | select the i2s peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4 , I2S2EXT, I2S3EXT
new_state | new state of i2s. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 479 of file at32f435_437_spi.c.

Referenced by codec_i2s_init(), codec_i2s_reset(), i2s_config(), and main().

◆ i2s_init()

void i2s_init | ( | spi_type * | spi_x,
 |  | i2s_init_type * | i2s_init_struct
 | ) |  |

i2s init config with its setting value.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4 , I2S2EXT, I2S3EXT
i2s_init_struct | : pointer to a i2s_init_type structure which will be initialized.
Return values
none

Definition at line 350 of file at32f435_437_spi.c.

Referenced by codec_i2s_init(), and i2s_config().

◆ spi_crc_enable()

void spi_crc_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the hardware crc calculation for the spi peripheral.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
new_state | new state of crc calculation. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 225 of file at32f435_437_spi.c.

Referenced by spi_config().

◆ spi_crc_next_transmit()

void spi_crc_next_transmit ( spi_type * spi_x )

spi next transmit crc for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
Return values
none

Definition at line 186 of file at32f435_437_spi.c.

Referenced by main().

◆ spi_crc_polynomial_get()

uint16_t spi_crc_polynomial_get ( spi_type * spi_x )

return the crc polynomial register value for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
Return values
the select crc polynomial register value

Definition at line 211 of file at32f435_437_spi.c.

◆ spi_crc_polynomial_set()

void spi_crc_polynomial_set | ( | spi_type * | spi_x,
 |  | uint16_t | crc_poly
 | ) |  |

set the crc polynomial value for the spi peripheral.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
crc_poly | crc polynomial value.
Return values
none

Definition at line 199 of file at32f435_437_spi.c.

Referenced by spi_config().

◆ spi_crc_value_get()

uint16_t spi_crc_value_get | ( | spi_type * | spi_x,
 |  | spi_crc_direction_type | crc_direction
 | ) |  |

return the transmit or the receive crc value for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
crc_direction select transmit or receive crc value to be read
  • SPI_CRC_RX
  • SPI_CRC_TX
Return values
the select crc register value

Definition at line 240 of file at32f435_437_spi.c.

◆ spi_default_para_init()

void spi_default_para_init ( spi_init_type * spi_init_struct )

spi init config with its default value.

Parameters
spi_init_struct : pointer to a spi_init_type structure which will be initialized.
Return values
none

Definition at line 81 of file at32f435_437_spi.c.

Referenced by spi_config(), spiflash_init(), touch_pin_init(), and usart_spi_configuration().

◆ spi_enable()

void spi_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable spi.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
new_state | new state of spi. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 321 of file at32f435_437_spi.c.

Referenced by main(), SPI3_I2S3EXT_IRQHandler(), spi_config(), spiflash_init(), touch_pin_init(), and usart_spi_configuration().

◆ spi_frame_bit_num_set()

void spi_frame_bit_num_set | ( | spi_type * | spi_x,
 |  | spi_frame_bit_num_type | bit_num
 | ) |  |

set the data frame bit num for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
bit_num set the data frame size
  • SPI_FRAME_8BIT
  • SPI_FRAME_16BIT
Return values
none

Definition at line 291 of file at32f435_437_spi.c.

◆ spi_half_duplex_direction_set()

void spi_half_duplex_direction_set | ( | spi_type * | spi_x,
 |  | spi_half_duplex_direction_type | direction
 | ) |  |

set the data transmission direction in single line bidirectiona half duplex mode of the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
direction data transfer direction this parameter can be one of the following values:
  • SPI_HALF_DUPLEX_DIRECTION_RX
  • SPI_HALF_DUPLEX_DIRECTION_TX
Return values
none

Definition at line 307 of file at32f435_437_spi.c.

◆ spi_hardware_cs_output_enable()

void spi_hardware_cs_output_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the hardware cs output for the spi peripheral.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
new_state | new state of spi master cs output. this parameter can be: TRUE or FALSE. note:the bit only use in spi master mode
Return values
none

Definition at line 258 of file at32f435_437_spi.c.

Referenced by spi_config().

◆ spi_i2s_data_receive()

uint16_t spi_i2s_data_receive ( spi_type * spi_x )

spi/i2s data receive

Parameters
spi_x select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4 , I2S2EXT, I2S3EXT
Return values
the received data value

Definition at line 560 of file at32f435_437_spi.c.

Referenced by main(), SPI2_I2S2EXT_IRQHandler(), SPI3_I2S3EXT_IRQHandler(), spi_byte_write(), spi_bytes_read(), spi_bytes_write(), and touch_read_1byte().

◆ spi_i2s_data_transmit()

void spi_i2s_data_transmit | ( | spi_type * | spi_x,
 |  | uint16_t | tx_data
 | ) |  |

spi/i2s data transmit

Parameters
spi_x select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4 , I2S2EXT, I2S3EXT
tx_data the data to be transmit. this parameter can be:
  • (0x0000~0xFFFF)
Return values
none

Definition at line 548 of file at32f435_437_spi.c.

Referenced by main(), SPI2_I2S2EXT_IRQHandler(), SPI3_I2S3EXT_IRQHandler(), spi_byte_write(), spi_bytes_read(), spi_bytes_write(), touch_read_1byte(), and touch_write_1byte().

◆ spi_i2s_dma_receiver_enable()

void spi_i2s_dma_receiver_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the spi/i2s dma receiver mode.

Parameters
spi_x | select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4 , I2S2EXT, I2S3EXT
new_state | new state of the dma request. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 533 of file at32f435_437_spi.c.

Referenced by codec_i2s_init(), i2s_config(), spi_byte_write(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ spi_i2s_dma_transmitter_enable()

void spi_i2s_dma_transmitter_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the spi/i2s dma transmitter mode.

Parameters
spi_x | select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4 , I2S2EXT, I2S3EXT
new_state | new state of the dma request. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 519 of file at32f435_437_spi.c.

Referenced by codec_i2s_init(), i2s_config(), spi_byte_write(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ spi_i2s_flag_clear()

void spi_i2s_flag_clear | ( | spi_type * | spi_x,
 |  | uint32_t | spi_i2s_flag
 | ) |  |

clear flag of the specified spi/i2s peripheral.

Parameters
spi_x select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4 , I2S2EXT, I2S3EXT
spi_i2s_flag select the spi/i2s flag this parameter can be one of the following values:
  • SPI_CCERR_FLAG
  • SPI_I2S_RDBF_FLAG
  • I2S_TUERR_FLAG
  • SPI_MMERR_FLAG
  • SPI_I2S_ROERR_FLAG
  • SPI_CSPAS_FLAG
Note
SPI_I2S_TDBE_FLAG this flag is cleared when the tx buffer already contain data to be transmit. I2S_ACS_FLAG this flag cann't cleared by software,the flag indicate the channel side(not use in pcm standard mode). SPI_I2S_BF_FLAG this flag cann't cleared by software, it's set and cleared by hardware.
Return values
none

< spi crc calculation error flag

< spi crc calculation error flag

< spi or i2s receive data buffer full flag

< i2s transmitter underload error flag

< spi cs pulse abnormal setting fiag

< spi master mode error flag

< spi or i2s receiver overflow error flag

Definition at line 616 of file at32f435_437_spi.c.

Referenced by main().

◆ spi_i2s_flag_get()

flag_status spi_i2s_flag_get | ( | spi_type * | spi_x,
 |  | uint32_t | spi_i2s_flag
 | ) |  |

get flag of the specified spi/i2s peripheral.

Parameters
spi_x select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4 , I2S2EXT, I2S3EXT
spi_i2s_flag select the spi/i2s flag this parameter can be one of the following values:
  • SPI_I2S_RDBF_FLAG
  • SPI_I2S_TDBE_FLAG
  • I2S_ACS_FLAG (this flag only use in i2s mode)
  • I2S_TUERR_FLAG (this flag only use in i2s mode)
  • SPI_CCERR_FLAG (this flag only use in spi mode)
  • SPI_MMERR_FLAG (this flag only use in spi mode)
  • SPI_I2S_ROERR_FLAG
  • SPI_I2S_BF_FLAG
  • SPI_CSPAS_FLAG
Return values
the new state of spi/i2s flag

Definition at line 583 of file at32f435_437_spi.c.

Referenced by main(), SPI2_I2S2EXT_IRQHandler(), SPI3_I2S3EXT_IRQHandler(), spi_byte_write(), spi_bytes_read(), spi_bytes_write(), touch_read_1byte(), and touch_write_1byte().

◆ spi_i2s_interrupt_enable()

void spi_i2s_interrupt_enable | ( | spi_type * | spi_x,
 |  | uint32_t | spi_i2s_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified spi/i2s interrupts.

Parameters
spi_x | select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4 , I2S2EXT, I2S3EXT
spi_i2s_int specifies the spi/i2s interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • SPI_I2S_ERROR_INT
  • SPI_I2S_RDBF_INT
  • SPI_I2S_TDBE_INT
new_state | new state of the specified spi/i2s interrupts. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 498 of file at32f435_437_spi.c.

Referenced by i2s_config(), main(), SPI2_I2S2EXT_IRQHandler(), SPI3_I2S3EXT_IRQHandler(), and spi_config().

◆ spi_i2s_reset()

void spi_i2s_reset ( spi_type * spi_x )

spi reset by crm reset register

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
Return values
none

Definition at line 51 of file at32f435_437_spi.c.

Referenced by codec_i2s_init(), i2s_config(), and spi_config().

◆ spi_init()

void spi_init | ( | spi_type * | spi_x,
 |  | spi_init_type * | spi_init_struct
 | ) |  |

spi init config with its setting value.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
spi_init_struct | : pointer to a spi_init_type structure which will be initialized.
Return values
none

Definition at line 101 of file at32f435_437_spi.c.

Referenced by main(), spi_config(), spiflash_init(), touch_pin_init(), and usart_spi_configuration().

◆ spi_software_cs_internal_level_set()

void spi_software_cs_internal_level_set | ( | spi_type * | spi_x,
 |  | spi_software_cs_level_type | level
 | ) |  |

set the software cs internal level for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
level set the state of spi cs level. this parameter can be one of the following values:
  • SPI_SWCS_INTERNAL_LEVEL_LOW
  • SPI_SWCS_INTERNAL_LEVEL_HIGHT note:the bit only use when swcsen bit is set. note:when use this bit,io operation on the cs pin are invalid.
Return values
none

Definition at line 276 of file at32f435_437_spi.c.

◆ spi_ti_mode_enable()

void spi_ti_mode_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the ti mode for the spi peripheral.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
new_state | new state of ti mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 174 of file at32f435_437_spi.c.

Referenced by spi_config().


AT32F435/437 Firmwary Library: SPI_private_functions

Functions
SPI_private_functions
AT32F435_437_periph_driver » SPI

Functions

void | spi_i2s_reset (spi_type *spi_x)
spi reset by crm reset register More...
void | spi_default_para_init (spi_init_type *spi_init_struct)
spi init config with its default value. More...
void | spi_init (spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value. More...
void | spi_ti_mode_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the ti mode for the spi peripheral. More...
void | spi_crc_next_transmit (spi_type *spi_x)
spi next transmit crc for the spi peripheral. More...
void | spi_crc_polynomial_set (spi_type *spi_x, uint16_t crc_poly)
set the crc polynomial value for the spi peripheral. More...
uint16_t | spi_crc_polynomial_get (spi_type *spi_x)
return the crc polynomial register value for the spi peripheral. More...
void | spi_crc_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the hardware crc calculation for the spi peripheral. More...
uint16_t | spi_crc_value_get (spi_type *spi_x, spi_crc_direction_type crc_direction)
return the transmit or the receive crc value for the spi peripheral. More...
void | spi_hardware_cs_output_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the hardware cs output for the spi peripheral. More...
void | spi_software_cs_internal_level_set (spi_type *spi_x, spi_software_cs_level_type level)
set the software cs internal level for the spi peripheral. More...
void | spi_frame_bit_num_set (spi_type *spi_x, spi_frame_bit_num_type bit_num)
set the data frame bit num for the spi peripheral. More...
void | spi_half_duplex_direction_set (spi_type *spi_x, spi_half_duplex_direction_type direction)
set the data transmission direction in single line bidirectiona half duplex mode of the spi peripheral. More...
void | spi_enable (spi_type *spi_x, confirm_state new_state)
enable or disable spi. More...
void | i2s_default_para_init (i2s_init_type *i2s_init_struct)
i2s init config with its default value. More...
void | i2s_init (spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value. More...
void | i2s_enable (spi_type *spi_x, confirm_state new_state)
enable or disable i2s. More...
void | spi_i2s_interrupt_enable (spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts. More...
void | spi_i2s_dma_transmitter_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode. More...
void | spi_i2s_dma_receiver_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode. More...
void | spi_i2s_data_transmit (spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit More...
uint16_t | spi_i2s_data_receive (spi_type *spi_x)
spi/i2s data receive More...
flag_status | spi_i2s_flag_get (spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral. More...
void | spi_i2s_flag_clear (spi_type *spi_x, uint32_t spi_i2s_flag)
clear flag of the specified spi/i2s peripheral. More...

Detailed Description

Function Documentation

◆ i2s_default_para_init()

void i2s_default_para_init ( i2s_init_type * i2s_init_struct )

i2s init config with its default value.

Parameters
i2s_init_struct : pointer to a i2s_init_type structure which will be initialized.
Return values
none

Definition at line 332 of file at32f435_437_spi.c.

Referenced by codec_i2s_init(), and i2s_config().

◆ i2s_enable()

void i2s_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable i2s.

Parameters
spi_x | select the i2s peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4 , I2S2EXT, I2S3EXT
new_state | new state of i2s. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 479 of file at32f435_437_spi.c.

Referenced by codec_i2s_init(), codec_i2s_reset(), i2s_config(), and main().

◆ i2s_init()

void i2s_init | ( | spi_type * | spi_x,
 |  | i2s_init_type * | i2s_init_struct
 | ) |  |

i2s init config with its setting value.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4 , I2S2EXT, I2S3EXT
i2s_init_struct | : pointer to a i2s_init_type structure which will be initialized.
Return values
none

Definition at line 350 of file at32f435_437_spi.c.

Referenced by codec_i2s_init(), and i2s_config().

◆ spi_crc_enable()

void spi_crc_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the hardware crc calculation for the spi peripheral.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
new_state | new state of crc calculation. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 225 of file at32f435_437_spi.c.

Referenced by spi_config().

◆ spi_crc_next_transmit()

void spi_crc_next_transmit ( spi_type * spi_x )

spi next transmit crc for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
Return values
none

Definition at line 186 of file at32f435_437_spi.c.

Referenced by main().

◆ spi_crc_polynomial_get()

uint16_t spi_crc_polynomial_get ( spi_type * spi_x )

return the crc polynomial register value for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
Return values
the select crc polynomial register value

Definition at line 211 of file at32f435_437_spi.c.

◆ spi_crc_polynomial_set()

void spi_crc_polynomial_set | ( | spi_type * | spi_x,
 |  | uint16_t | crc_poly
 | ) |  |

set the crc polynomial value for the spi peripheral.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
crc_poly | crc polynomial value.
Return values
none

Definition at line 199 of file at32f435_437_spi.c.

Referenced by spi_config().

◆ spi_crc_value_get()

uint16_t spi_crc_value_get | ( | spi_type * | spi_x,
 |  | spi_crc_direction_type | crc_direction
 | ) |  |

return the transmit or the receive crc value for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
crc_direction select transmit or receive crc value to be read
  • SPI_CRC_RX
  • SPI_CRC_TX
Return values
the select crc register value

Definition at line 240 of file at32f435_437_spi.c.

◆ spi_default_para_init()

void spi_default_para_init ( spi_init_type * spi_init_struct )

spi init config with its default value.

Parameters
spi_init_struct : pointer to a spi_init_type structure which will be initialized.
Return values
none

Definition at line 81 of file at32f435_437_spi.c.

Referenced by spi_config(), spiflash_init(), touch_pin_init(), and usart_spi_configuration().

◆ spi_enable()

void spi_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable spi.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
new_state | new state of spi. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 321 of file at32f435_437_spi.c.

Referenced by main(), SPI3_I2S3EXT_IRQHandler(), spi_config(), spiflash_init(), touch_pin_init(), and usart_spi_configuration().

◆ spi_frame_bit_num_set()

void spi_frame_bit_num_set | ( | spi_type * | spi_x,
 |  | spi_frame_bit_num_type | bit_num
 | ) |  |

set the data frame bit num for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
bit_num set the data frame size
  • SPI_FRAME_8BIT
  • SPI_FRAME_16BIT
Return values
none

Definition at line 291 of file at32f435_437_spi.c.

◆ spi_half_duplex_direction_set()

void spi_half_duplex_direction_set | ( | spi_type * | spi_x,
 |  | spi_half_duplex_direction_type | direction
 | ) |  |

set the data transmission direction in single line bidirectiona half duplex mode of the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
direction data transfer direction this parameter can be one of the following values:
  • SPI_HALF_DUPLEX_DIRECTION_RX
  • SPI_HALF_DUPLEX_DIRECTION_TX
Return values
none

Definition at line 307 of file at32f435_437_spi.c.

◆ spi_hardware_cs_output_enable()

void spi_hardware_cs_output_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the hardware cs output for the spi peripheral.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
new_state | new state of spi master cs output. this parameter can be: TRUE or FALSE. note:the bit only use in spi master mode
Return values
none

Definition at line 258 of file at32f435_437_spi.c.

Referenced by spi_config().

◆ spi_i2s_data_receive()

uint16_t spi_i2s_data_receive ( spi_type * spi_x )

spi/i2s data receive

Parameters
spi_x select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4 , I2S2EXT, I2S3EXT
Return values
the received data value

Definition at line 560 of file at32f435_437_spi.c.

Referenced by main(), SPI2_I2S2EXT_IRQHandler(), SPI3_I2S3EXT_IRQHandler(), spi_byte_write(), spi_bytes_read(), spi_bytes_write(), and touch_read_1byte().

◆ spi_i2s_data_transmit()

void spi_i2s_data_transmit | ( | spi_type * | spi_x,
 |  | uint16_t | tx_data
 | ) |  |

spi/i2s data transmit

Parameters
spi_x select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4 , I2S2EXT, I2S3EXT
tx_data the data to be transmit. this parameter can be:
  • (0x0000~0xFFFF)
Return values
none

Definition at line 548 of file at32f435_437_spi.c.

Referenced by main(), SPI2_I2S2EXT_IRQHandler(), SPI3_I2S3EXT_IRQHandler(), spi_byte_write(), spi_bytes_read(), spi_bytes_write(), touch_read_1byte(), and touch_write_1byte().

◆ spi_i2s_dma_receiver_enable()

void spi_i2s_dma_receiver_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the spi/i2s dma receiver mode.

Parameters
spi_x | select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4 , I2S2EXT, I2S3EXT
new_state | new state of the dma request. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 533 of file at32f435_437_spi.c.

Referenced by codec_i2s_init(), i2s_config(), spi_byte_write(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ spi_i2s_dma_transmitter_enable()

void spi_i2s_dma_transmitter_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the spi/i2s dma transmitter mode.

Parameters
spi_x | select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4 , I2S2EXT, I2S3EXT
new_state | new state of the dma request. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 519 of file at32f435_437_spi.c.

Referenced by codec_i2s_init(), i2s_config(), spi_byte_write(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ spi_i2s_flag_clear()

void spi_i2s_flag_clear | ( | spi_type * | spi_x,
 |  | uint32_t | spi_i2s_flag
 | ) |  |

clear flag of the specified spi/i2s peripheral.

Parameters
spi_x select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4 , I2S2EXT, I2S3EXT
spi_i2s_flag select the spi/i2s flag this parameter can be one of the following values:
  • SPI_CCERR_FLAG
  • SPI_I2S_RDBF_FLAG
  • I2S_TUERR_FLAG
  • SPI_MMERR_FLAG
  • SPI_I2S_ROERR_FLAG
  • SPI_CSPAS_FLAG
Note
SPI_I2S_TDBE_FLAG this flag is cleared when the tx buffer already contain data to be transmit. I2S_ACS_FLAG this flag cann't cleared by software,the flag indicate the channel side(not use in pcm standard mode). SPI_I2S_BF_FLAG this flag cann't cleared by software, it's set and cleared by hardware.
Return values
none

< spi crc calculation error flag

< spi crc calculation error flag

< spi or i2s receive data buffer full flag

< i2s transmitter underload error flag

< spi cs pulse abnormal setting fiag

< spi master mode error flag

< spi or i2s receiver overflow error flag

Definition at line 616 of file at32f435_437_spi.c.

Referenced by main().

◆ spi_i2s_flag_get()

flag_status spi_i2s_flag_get | ( | spi_type * | spi_x,
 |  | uint32_t | spi_i2s_flag
 | ) |  |

get flag of the specified spi/i2s peripheral.

Parameters
spi_x select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4 , I2S2EXT, I2S3EXT
spi_i2s_flag select the spi/i2s flag this parameter can be one of the following values:
  • SPI_I2S_RDBF_FLAG
  • SPI_I2S_TDBE_FLAG
  • I2S_ACS_FLAG (this flag only use in i2s mode)
  • I2S_TUERR_FLAG (this flag only use in i2s mode)
  • SPI_CCERR_FLAG (this flag only use in spi mode)
  • SPI_MMERR_FLAG (this flag only use in spi mode)
  • SPI_I2S_ROERR_FLAG
  • SPI_I2S_BF_FLAG
  • SPI_CSPAS_FLAG
Return values
the new state of spi/i2s flag

Definition at line 583 of file at32f435_437_spi.c.

Referenced by main(), SPI2_I2S2EXT_IRQHandler(), SPI3_I2S3EXT_IRQHandler(), spi_byte_write(), spi_bytes_read(), spi_bytes_write(), touch_read_1byte(), and touch_write_1byte().

◆ spi_i2s_interrupt_enable()

void spi_i2s_interrupt_enable | ( | spi_type * | spi_x,
 |  | uint32_t | spi_i2s_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified spi/i2s interrupts.

Parameters
spi_x | select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4 , I2S2EXT, I2S3EXT
spi_i2s_int specifies the spi/i2s interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • SPI_I2S_ERROR_INT
  • SPI_I2S_RDBF_INT
  • SPI_I2S_TDBE_INT
new_state | new state of the specified spi/i2s interrupts. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 498 of file at32f435_437_spi.c.

Referenced by i2s_config(), main(), SPI2_I2S2EXT_IRQHandler(), SPI3_I2S3EXT_IRQHandler(), and spi_config().

◆ spi_i2s_reset()

void spi_i2s_reset ( spi_type * spi_x )

spi reset by crm reset register

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
Return values
none

Definition at line 51 of file at32f435_437_spi.c.

Referenced by codec_i2s_init(), i2s_config(), and spi_config().

◆ spi_init()

void spi_init | ( | spi_type * | spi_x,
 |  | spi_init_type * | spi_init_struct
 | ) |  |

spi init config with its setting value.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
spi_init_struct | : pointer to a spi_init_type structure which will be initialized.
Return values
none

Definition at line 101 of file at32f435_437_spi.c.

Referenced by main(), spi_config(), spiflash_init(), touch_pin_init(), and usart_spi_configuration().

◆ spi_software_cs_internal_level_set()

void spi_software_cs_internal_level_set | ( | spi_type * | spi_x,
 |  | spi_software_cs_level_type | level
 | ) |  |

set the software cs internal level for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
level set the state of spi cs level. this parameter can be one of the following values:
  • SPI_SWCS_INTERNAL_LEVEL_LOW
  • SPI_SWCS_INTERNAL_LEVEL_HIGHT note:the bit only use when swcsen bit is set. note:when use this bit,io operation on the cs pin are invalid.
Return values
none

Definition at line 276 of file at32f435_437_spi.c.

◆ spi_ti_mode_enable()

void spi_ti_mode_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the ti mode for the spi peripheral.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2, SPI3 ,SPI4
new_state | new state of ti mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 174 of file at32f435_437_spi.c.

Referenced by spi_config().


AT32F435/437 Firmwary Library: TMR

Modules | Macros
TMR
AT32F435_437_periph_driver

TMR driver modules. More...

Modules

TMR_flags_definition
tmr flag
TMR_interrupt_select_type_definition
tmr interrupt select type
TMR_exported_types
TMR_exported_functions
TMR_private_functions

Macros

#define | TMR1 ((tmr_type *) TMR1_BASE)
#define | TMR2 ((tmr_type *) TMR2_BASE)
#define | TMR3 ((tmr_type *) TMR3_BASE)
#define | TMR4 ((tmr_type *) TMR4_BASE)
#define | TMR5 ((tmr_type *) TMR5_BASE)
#define | TMR6 ((tmr_type *) TMR6_BASE)
#define | TMR7 ((tmr_type *) TMR7_BASE)
#define | TMR8 ((tmr_type *) TMR8_BASE)
#define | TMR9 ((tmr_type *) TMR9_BASE)
#define | TMR10 ((tmr_type *) TMR10_BASE)
#define | TMR11 ((tmr_type *) TMR11_BASE)
#define | TMR12 ((tmr_type *) TMR12_BASE)
#define | TMR13 ((tmr_type *) TMR13_BASE)
#define | TMR14 ((tmr_type *) TMR14_BASE)
#define | TMR20 ((tmr_type *) TMR20_BASE)

Detailed Description

TMR driver modules.

Macro Definition Documentation

◆ TMR1

#define TMR1 ((tmr_type *) TMR1_BASE)

Definition at line 895 of file at32f435_437_tmr.h.

◆ TMR10

#define TMR10 ((tmr_type *) TMR10_BASE)

Definition at line 904 of file at32f435_437_tmr.h.

◆ TMR11

#define TMR11 ((tmr_type *) TMR11_BASE)

Definition at line 905 of file at32f435_437_tmr.h.

◆ TMR12

#define TMR12 ((tmr_type *) TMR12_BASE)

Definition at line 906 of file at32f435_437_tmr.h.

◆ TMR13

#define TMR13 ((tmr_type *) TMR13_BASE)

Definition at line 907 of file at32f435_437_tmr.h.

◆ TMR14

#define TMR14 ((tmr_type *) TMR14_BASE)

Definition at line 908 of file at32f435_437_tmr.h.

◆ TMR2

#define TMR2 ((tmr_type *) TMR2_BASE)

Definition at line 896 of file at32f435_437_tmr.h.

◆ TMR20

#define TMR20 ((tmr_type *) TMR20_BASE)

Definition at line 909 of file at32f435_437_tmr.h.

◆ TMR3

#define TMR3 ((tmr_type *) TMR3_BASE)

Definition at line 897 of file at32f435_437_tmr.h.

◆ TMR4

#define TMR4 ((tmr_type *) TMR4_BASE)

Definition at line 898 of file at32f435_437_tmr.h.

◆ TMR5

#define TMR5 ((tmr_type *) TMR5_BASE)

Definition at line 899 of file at32f435_437_tmr.h.

◆ TMR6

#define TMR6 ((tmr_type *) TMR6_BASE)

Definition at line 900 of file at32f435_437_tmr.h.

◆ TMR7

#define TMR7 ((tmr_type *) TMR7_BASE)

Definition at line 901 of file at32f435_437_tmr.h.

◆ TMR8

#define TMR8 ((tmr_type *) TMR8_BASE)

Definition at line 902 of file at32f435_437_tmr.h.

◆ TMR9

#define TMR9 ((tmr_type *) TMR9_BASE)

Definition at line 903 of file at32f435_437_tmr.h.


AT32F435/437 Firmwary Library: TMR_flags_definition

Macros
TMR_flags_definition
AT32F435_437_periph_driver » TMR

tmr flag More...

Macros

#define | TMR_OVF_FLAG ((uint32_t)0x000001)
#define | TMR_C1_FLAG ((uint32_t)0x000002)
#define | TMR_C2_FLAG ((uint32_t)0x000004)
#define | TMR_C3_FLAG ((uint32_t)0x000008)
#define | TMR_C4_FLAG ((uint32_t)0x000010)
#define | TMR_C5_FLAG ((uint32_t)0x010000)
#define | TMR_HALL_FLAG ((uint32_t)0x000020)
#define | TMR_TRIGGER_FLAG ((uint32_t)0x000040)
#define | TMR_BRK_FLAG ((uint32_t)0x000080)
#define | TMR_C1_RECAPTURE_FLAG ((uint32_t)0x000200)
#define | TMR_C2_RECAPTURE_FLAG ((uint32_t)0x000400)
#define | TMR_C3_RECAPTURE_FLAG ((uint32_t)0x000800)
#define | TMR_C4_RECAPTURE_FLAG ((uint32_t)0x001000)

Detailed Description

tmr flag

Macro Definition Documentation

◆ TMR_BRK_FLAG

#define TMR_BRK_FLAG ((uint32_t)0x000080)

tmr flag brake

Definition at line 60 of file at32f435_437_tmr.h.

◆ TMR_C1_FLAG

#define TMR_C1_FLAG ((uint32_t)0x000002)

tmr flag channel 1

Definition at line 53 of file at32f435_437_tmr.h.

◆ TMR_C1_RECAPTURE_FLAG

#define TMR_C1_RECAPTURE_FLAG ((uint32_t)0x000200)

tmr flag channel 1 recapture

Definition at line 61 of file at32f435_437_tmr.h.

◆ TMR_C2_FLAG

#define TMR_C2_FLAG ((uint32_t)0x000004)

tmr flag channel 2

Definition at line 54 of file at32f435_437_tmr.h.

◆ TMR_C2_RECAPTURE_FLAG

#define TMR_C2_RECAPTURE_FLAG ((uint32_t)0x000400)

tmr flag channel 2 recapture

Definition at line 62 of file at32f435_437_tmr.h.

◆ TMR_C3_FLAG

#define TMR_C3_FLAG ((uint32_t)0x000008)

tmr flag channel 3

Definition at line 55 of file at32f435_437_tmr.h.

◆ TMR_C3_RECAPTURE_FLAG

#define TMR_C3_RECAPTURE_FLAG ((uint32_t)0x000800)

tmr flag channel 3 recapture

Definition at line 63 of file at32f435_437_tmr.h.

◆ TMR_C4_FLAG

#define TMR_C4_FLAG ((uint32_t)0x000010)

tmr flag channel 4

Definition at line 56 of file at32f435_437_tmr.h.

◆ TMR_C4_RECAPTURE_FLAG

#define TMR_C4_RECAPTURE_FLAG ((uint32_t)0x001000)

tmr flag channel 4 recapture

Definition at line 64 of file at32f435_437_tmr.h.

◆ TMR_C5_FLAG

#define TMR_C5_FLAG ((uint32_t)0x010000)

tmr flag channel 5

Definition at line 57 of file at32f435_437_tmr.h.

◆ TMR_HALL_FLAG

#define TMR_HALL_FLAG ((uint32_t)0x000020)

tmr flag hall

Definition at line 58 of file at32f435_437_tmr.h.

◆ TMR_OVF_FLAG

#define TMR_OVF_FLAG ((uint32_t)0x000001)

tmr flag overflow

Definition at line 52 of file at32f435_437_tmr.h.

◆ TMR_TRIGGER_FLAG

#define TMR_TRIGGER_FLAG ((uint32_t)0x000040)

tmr flag trigger

Definition at line 59 of file at32f435_437_tmr.h.


AT32F435/437 Firmwary Library: TMR_interrupt_select_type_definition

Macros
TMR_interrupt_select_type_definition
AT32F435_437_periph_driver » TMR

tmr interrupt select type More...

Macros

#define | TMR_OVF_INT ((uint32_t)0x000001)
#define | TMR_C1_INT ((uint32_t)0x000002)
#define | TMR_C2_INT ((uint32_t)0x000004)
#define | TMR_C3_INT ((uint32_t)0x000008)
#define | TMR_C4_INT ((uint32_t)0x000010)
#define | TMR_HALL_INT ((uint32_t)0x000020)
#define | TMR_TRIGGER_INT ((uint32_t)0x000040)
#define | TMR_BRK_INT ((uint32_t)0x000080)

Detailed Description

tmr interrupt select type

Macro Definition Documentation

◆ TMR_BRK_INT

#define TMR_BRK_INT ((uint32_t)0x000080)

tmr interrupt brake

Definition at line 82 of file at32f435_437_tmr.h.

◆ TMR_C1_INT

#define TMR_C1_INT ((uint32_t)0x000002)

tmr interrupt channel 1

Definition at line 76 of file at32f435_437_tmr.h.

◆ TMR_C2_INT

#define TMR_C2_INT ((uint32_t)0x000004)

tmr interrupt channel 2

Definition at line 77 of file at32f435_437_tmr.h.

◆ TMR_C3_INT

#define TMR_C3_INT ((uint32_t)0x000008)

tmr interrupt channel 3

Definition at line 78 of file at32f435_437_tmr.h.

◆ TMR_C4_INT

#define TMR_C4_INT ((uint32_t)0x000010)

tmr interrupt channel 4

Definition at line 79 of file at32f435_437_tmr.h.

◆ TMR_HALL_INT

#define TMR_HALL_INT ((uint32_t)0x000020)

tmr interrupt hall

Definition at line 80 of file at32f435_437_tmr.h.

◆ TMR_OVF_INT

#define TMR_OVF_INT ((uint32_t)0x000001)

tmr interrupt overflow

Definition at line 75 of file at32f435_437_tmr.h.

◆ TMR_TRIGGER_INT

#define TMR_TRIGGER_INT ((uint32_t)0x000040)

tmr interrupt trigger

Definition at line 81 of file at32f435_437_tmr.h.


AT32F435/437 Firmwary Library: TMR_exported_types

Data Structures | Enumerations
TMR_exported_types
AT32F435_437_periph_driver » TMR

Data Structures

struct | tmr_output_config_type
tmr output config type More...
struct | tmr_input_config_type
tmr input capture config type More...
struct | tmr_brkdt_config_type
tmr brkdt config type More...
struct | tmr_type
type define tmr register all More...

Enumerations

enum | tmr_clock_division_type { TMR_CLOCK_DIV1 = 0x00 , TMR_CLOCK_DIV2 = 0x01 , TMR_CLOCK_DIV4 = 0x02 }
tmr clock division type More...
enum tmr_count_mode_type {
TMR_COUNT_UP = 0x00 , TMR_COUNT_DOWN = 0x01 , TMR_COUNT_TWO_WAY_1 = 0x02 , TMR_COUNT_TWO_WAY_2 = 0x04 ,
TMR_COUNT_TWO_WAY_3 = 0x06
}
tmr counter mode type More...
enum tmr_primary_select_type {
TMR_PRIMARY_SEL_RESET = 0x00 , TMR_PRIMARY_SEL_ENABLE = 0x01 , TMR_PRIMARY_SEL_OVERFLOW = 0x02 , TMR_PRIMARY_SEL_COMPARE = 0x03 ,
TMR_PRIMARY_SEL_C1ORAW = 0x04 , TMR_PRIMARY_SEL_C2ORAW = 0x05 , TMR_PRIMARY_SEL_C3ORAW = 0x06 , TMR_PRIMARY_SEL_C4ORAW = 0x07
}
tmr primary mode select type More...
enum sub_tmr_input_sel_type {
TMR_SUB_INPUT_SEL_IS0 = 0x00 , TMR_SUB_INPUT_SEL_IS1 = 0x01 , TMR_SUB_INPUT_SEL_IS2 = 0x02 , TMR_SUB_INPUT_SEL_IS3 = 0x03 ,
TMR_SUB_INPUT_SEL_C1INC = 0x04 , TMR_SUB_INPUT_SEL_C1DF1 = 0x05 , TMR_SUB_INPUT_SEL_C2DF2 = 0x06 , TMR_SUB_INPUT_SEL_EXTIN = 0x07
}
tmr subordinate mode input select type More...
enum tmr_sub_mode_select_type {
TMR_SUB_MODE_DIABLE = 0x00 , TMR_SUB_ENCODER_MODE_A = 0x01 , TMR_SUB_ENCODER_MODE_B = 0x02 , TMR_SUB_ENCODER_MODE_C = 0x03 ,
TMR_SUB_RESET_MODE = 0x04 , TMR_SUB_HANG_MODE = 0x05 , TMR_SUB_TRIGGER_MODE = 0x06 , TMR_SUB_EXTERNAL_CLOCK_MODE_A = 0x07
}
tmr subordinate mode select type More...
enum | tmr_encoder_mode_type { TMR_ENCODER_MODE_A = TMR_SUB_ENCODER_MODE_A , TMR_ENCODER_MODE_B = TMR_SUB_ENCODER_MODE_B , TMR_ENCODER_MODE_C = TMR_SUB_ENCODER_MODE_C }
tmr encoder mode type More...
enum tmr_output_control_mode_type {
TMR_OUTPUT_CONTROL_OFF = 0x00 , TMR_OUTPUT_CONTROL_HIGH = 0x01 , TMR_OUTPUT_CONTROL_LOW = 0x02 , TMR_OUTPUT_CONTROL_SWITCH = 0x03 ,
TMR_OUTPUT_CONTROL_FORCE_LOW = 0x04 , TMR_OUTPUT_CONTROL_FORCE_HIGH = 0x05 , TMR_OUTPUT_CONTROL_PWM_MODE_A = 0x06 , TMR_OUTPUT_CONTROL_PWM_MODE_B = 0x07
}
tmr output control mode type More...
enum | tmr_force_output_type { TMR_FORCE_OUTPUT_HIGH = TMR_OUTPUT_CONTROL_FORCE_HIGH , TMR_FORCE_OUTPUT_LOW = TMR_OUTPUT_CONTROL_FORCE_LOW }
tmr force output type More...
enum | tmr_output_polarity_type { TMR_OUTPUT_ACTIVE_HIGH = 0x00 , TMR_OUTPUT_ACTIVE_LOW = 0x01 }
tmr output channel polarity type More...
enum | tmr_input_polarity_type { TMR_INPUT_RISING_EDGE = 0x00 , TMR_INPUT_FALLING_EDGE = 0x01 , TMR_INPUT_BOTH_EDGE = 0x03 }
tmr input channel polarity type More...
enum tmr_channel_select_type {
TMR_SELECT_CHANNEL_1 = 0x00 , TMR_SELECT_CHANNEL_1C = 0x01 , TMR_SELECT_CHANNEL_2 = 0x02 , TMR_SELECT_CHANNEL_2C = 0x03 ,
TMR_SELECT_CHANNEL_3 = 0x04 , TMR_SELECT_CHANNEL_3C = 0x05 , TMR_SELECT_CHANNEL_4 = 0x06 , TMR_SELECT_CHANNEL_5 = 0x07
}
tmr channel select type More...
enum | tmr_channel1_input_connected_type { TMR_CHANEL1_CONNECTED_C1IRAW = 0x00 , TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR = 0x01 }
tmr channel1 input connected type More...
enum | tmr_input_direction_mapped_type { TMR_CC_CHANNEL_MAPPED_DIRECT = 0x01 , TMR_CC_CHANNEL_MAPPED_INDIRECT = 0x02 , TMR_CC_CHANNEL_MAPPED_STI = 0x03 }
tmr input channel mapped type channel direction More...
enum | tmr_channel_input_divider_type { TMR_CHANNEL_INPUT_DIV_1 = 0x00 , TMR_CHANNEL_INPUT_DIV_2 = 0x01 , TMR_CHANNEL_INPUT_DIV_4 = 0x02 , TMR_CHANNEL_INPUT_DIV_8 = 0x03 }
tmr input divider type More...
enum | tmr_dma_request_source_type { TMR_DMA_REQUEST_BY_CHANNEL = 0x00 , TMR_DMA_REQUEST_BY_OVERFLOW = 0x01 }
tmr dma request source select type More...
enum tmr_dma_request_type {
TMR_OVERFLOW_DMA_REQUEST = 0x00000100 , TMR_C1_DMA_REQUEST = 0x00000200 , TMR_C2_DMA_REQUEST = 0x00000400 , TMR_C3_DMA_REQUEST = 0x00000800 ,
TMR_C4_DMA_REQUEST = 0x00001000 , TMR_HALL_DMA_REQUEST = 0x00002000 , TMR_TRIGGER_DMA_REQUEST = 0x00004000
}
tmr dma request type More...
enum tmr_event_trigger_type {
TMR_OVERFLOW_SWTRIG = 0x00000001 , TMR_C1_SWTRIG = 0x00000002 , TMR_C2_SWTRIG = 0x00000004 , TMR_C3_SWTRIG = 0x00000008 ,
TMR_C4_SWTRIG = 0x00000010 , TMR_HALL_SWTRIG = 0x00000020 , TMR_TRIGGER_SWTRIG = 0x00000040 , TMR_BRK_SWTRIG = 0x00000080
}
tmr event triggered by software type More...
enum | tmr_polarity_active_type { TMR_POLARITY_ACTIVE_HIGH = 0x00 , TMR_POLARITY_ACTIVE_LOW = 0x01 , TMR_POLARITY_ACTIVE_BOTH = 0x02 }
tmr polarity active type More...
enum | tmr_external_signal_divider_type { TMR_ES_FREQUENCY_DIV_1 = 0x00 , TMR_ES_FREQUENCY_DIV_2 = 0x01 , TMR_ES_FREQUENCY_DIV_4 = 0x02 , TMR_ES_FREQUENCY_DIV_8 = 0x03 }
tmr external signal divider type More...
enum | tmr_external_signal_polarity_type { TMR_ES_POLARITY_NON_INVERTED = 0x00 , TMR_ES_POLARITY_INVERTED = 0x01 }
tmr external signal polarity type More...
enum tmr_dma_transfer_length_type {
TMR_DMA_TRANSFER_1BYTE = 0x00 , TMR_DMA_TRANSFER_2BYTES = 0x01 , TMR_DMA_TRANSFER_3BYTES = 0x02 , TMR_DMA_TRANSFER_4BYTES = 0x03 ,
TMR_DMA_TRANSFER_5BYTES = 0x04 , TMR_DMA_TRANSFER_6BYTES = 0x05 , TMR_DMA_TRANSFER_7BYTES = 0x06 , TMR_DMA_TRANSFER_8BYTES = 0x07 ,
TMR_DMA_TRANSFER_9BYTES = 0x08 , TMR_DMA_TRANSFER_10BYTES = 0x09 , TMR_DMA_TRANSFER_11BYTES = 0x0A , TMR_DMA_TRANSFER_12BYTES = 0x0B ,
TMR_DMA_TRANSFER_13BYTES = 0x0C , TMR_DMA_TRANSFER_14BYTES = 0x0D , TMR_DMA_TRANSFER_15BYTES = 0x0E , TMR_DMA_TRANSFER_16BYTES = 0x0F ,
TMR_DMA_TRANSFER_17BYTES = 0x10 , TMR_DMA_TRANSFER_18BYTES = 0x11
}
tmr dma transfer length type More...
enum tmr_dma_address_type {
TMR_CTRL1_ADDRESS = 0x0000 , TMR_CTRL2_ADDRESS = 0x0001 , TMR_STCTRL_ADDRESS = 0x0002 , TMR_IDEN_ADDRESS = 0x0003 ,
TMR_ISTS_ADDRESS = 0x0004 , TMR_SWEVT_ADDRESS = 0x0005 , TMR_CM1_ADDRESS = 0x0006 , TMR_CM2_ADDRESS = 0x0007 ,
TMR_CCTRL_ADDRESS = 0x0008 , TMR_CVAL_ADDRESS = 0x0009 , TMR_DIV_ADDRESS = 0x000A , TMR_PR_ADDRESS = 0x000B ,
TMR_RPR_ADDRESS = 0x000C , TMR_C1DT_ADDRESS = 0x000D , TMR_C2DT_ADDRESS = 0x000E , TMR_C3DT_ADDRESS = 0x000F ,
TMR_C4DT_ADDRESS = 0x0010 , TMR_BRK_ADDRESS = 0x0011 , TMR_DMACTRL_ADDRESS = 0x0012
}
tmr dma base address type More...
enum | tmr_brk_polarity_type { TMR_BRK_INPUT_ACTIVE_LOW = 0x00 , TMR_BRK_INPUT_ACTIVE_HIGH = 0x01 }
tmr brk polarity type More...
enum | tmr_wp_level_type { TMR_WP_OFF = 0x00 , TMR_WP_LEVEL_3 = 0x01 , TMR_WP_LEVEL_2 = 0x02 , TMR_WP_LEVEL_1 = 0x03 }
tmr write protect level type More...
enum | tmr_input_remap_type { TMR2_TMR8TRGOUT_TMR5_GPIO = 0x00 , TMR2_PTP_TMR5_LICK = 0x01 , TMR2_OTG1FS_TMR5_LEXT = 0x02 , TMR2_OTG2FS_TMR5_ERTC = 0x03 }
tmr input remap type More...

Detailed Description

Enumeration Type Documentation

◆ sub_tmr_input_sel_type

enum sub_tmr_input_sel_type

tmr subordinate mode input select type

Enumerator
TMR_SUB_INPUT_SEL_IS0 | subordinate mode input select is0
TMR_SUB_INPUT_SEL_IS1 | subordinate mode input select is1
TMR_SUB_INPUT_SEL_IS2 | subordinate mode input select is2
TMR_SUB_INPUT_SEL_IS3 | subordinate mode input select is3
TMR_SUB_INPUT_SEL_C1INC | subordinate mode input select c1inc
TMR_SUB_INPUT_SEL_C1DF1 | subordinate mode input select c1df1
TMR_SUB_INPUT_SEL_C2DF2 | subordinate mode input select c2df2
TMR_SUB_INPUT_SEL_EXTIN | subordinate mode input select extin

Definition at line 132 of file at32f435_437_tmr.h.

◆ tmr_brk_polarity_type

enum tmr_brk_polarity_type

tmr brk polarity type

Enumerator
TMR_BRK_INPUT_ACTIVE_LOW | tmr brk input channel active low
TMR_BRK_INPUT_ACTIVE_HIGH | tmr brk input channel active high

Definition at line 379 of file at32f435_437_tmr.h.

◆ tmr_channel1_input_connected_type

enum tmr_channel1_input_connected_type

tmr channel1 input connected type

Enumerator
TMR_CHANEL1_CONNECTED_C1IRAW | channel1 pins is only connected to C1IRAW input
TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR | channel1/2/3 pins are connected to C1IRAW input after xored

Definition at line 230 of file at32f435_437_tmr.h.

◆ tmr_channel_input_divider_type

enum tmr_channel_input_divider_type

tmr input divider type

Enumerator
TMR_CHANNEL_INPUT_DIV_1 | tmr channel input divider 1
TMR_CHANNEL_INPUT_DIV_2 | tmr channel input divider 2
TMR_CHANNEL_INPUT_DIV_4 | tmr channel input divider 4
TMR_CHANNEL_INPUT_DIV_8 | tmr channel input divider 8

Definition at line 249 of file at32f435_437_tmr.h.

◆ tmr_channel_select_type

enum tmr_channel_select_type

tmr channel select type

Enumerator
TMR_SELECT_CHANNEL_1 | tmr channel select channel 1
TMR_SELECT_CHANNEL_1C | tmr channel select channel 1 complementary
TMR_SELECT_CHANNEL_2 | tmr channel select channel 2
TMR_SELECT_CHANNEL_2C | tmr channel select channel 2 complementary
TMR_SELECT_CHANNEL_3 | tmr channel select channel 3
TMR_SELECT_CHANNEL_3C | tmr channel select channel 3 complementary
TMR_SELECT_CHANNEL_4 | tmr channel select channel 4
TMR_SELECT_CHANNEL_5 | tmr channel select channel 5

Definition at line 215 of file at32f435_437_tmr.h.

◆ tmr_clock_division_type

enum tmr_clock_division_type

tmr clock division type

Enumerator
TMR_CLOCK_DIV1 | tmr clock division 1
TMR_CLOCK_DIV2 | tmr clock division 2
TMR_CLOCK_DIV4 | tmr clock division 4

Definition at line 95 of file at32f435_437_tmr.h.

◆ tmr_count_mode_type

enum tmr_count_mode_type

tmr counter mode type

Enumerator
TMR_COUNT_UP | tmr counter mode up
TMR_COUNT_DOWN | tmr counter mode down
TMR_COUNT_TWO_WAY_1 | tmr counter mode two way 1
TMR_COUNT_TWO_WAY_2 | tmr counter mode two way 2
TMR_COUNT_TWO_WAY_3 | tmr counter mode two way 3

Definition at line 105 of file at32f435_437_tmr.h.

◆ tmr_dma_address_type

enum tmr_dma_address_type

tmr dma base address type

Enumerator
TMR_CTRL1_ADDRESS | tmr dma base address ctrl1
TMR_CTRL2_ADDRESS | tmr dma base address ctrl2
TMR_STCTRL_ADDRESS | tmr dma base address stctrl
TMR_IDEN_ADDRESS | tmr dma base address iden
TMR_ISTS_ADDRESS | tmr dma base address ists
TMR_SWEVT_ADDRESS | tmr dma base address swevt
TMR_CM1_ADDRESS | tmr dma base address cm1
TMR_CM2_ADDRESS | tmr dma base address cm2
TMR_CCTRL_ADDRESS | tmr dma base address cctrl
TMR_CVAL_ADDRESS | tmr dma base address cval
TMR_DIV_ADDRESS | tmr dma base address div
TMR_PR_ADDRESS | tmr dma base address pr
TMR_RPR_ADDRESS | tmr dma base address rpr
TMR_C1DT_ADDRESS | tmr dma base address c1dt
TMR_C2DT_ADDRESS | tmr dma base address c2dt
TMR_C3DT_ADDRESS | tmr dma base address c3dt
TMR_C4DT_ADDRESS | tmr dma base address c4dt
TMR_BRK_ADDRESS | tmr dma base address brake
TMR_DMACTRL_ADDRESS | tmr dma base address dmactrl

Definition at line 353 of file at32f435_437_tmr.h.

◆ tmr_dma_request_source_type

enum tmr_dma_request_source_type

tmr dma request source select type

Enumerator
TMR_DMA_REQUEST_BY_CHANNEL | tmr dma request source select channel
TMR_DMA_REQUEST_BY_OVERFLOW | tmr dma request source select overflow

Definition at line 260 of file at32f435_437_tmr.h.

◆ tmr_dma_request_type

enum tmr_dma_request_type

tmr dma request type

Enumerator
TMR_OVERFLOW_DMA_REQUEST | tmr dma request select overflow
TMR_C1_DMA_REQUEST | tmr dma request select channel 1
TMR_C2_DMA_REQUEST | tmr dma request select channel 2
TMR_C3_DMA_REQUEST | tmr dma request select channel 3
TMR_C4_DMA_REQUEST | tmr dma request select channel 4
TMR_HALL_DMA_REQUEST | tmr dma request select hall
TMR_TRIGGER_DMA_REQUEST | tmr dma request select trigger

Definition at line 269 of file at32f435_437_tmr.h.

◆ tmr_dma_transfer_length_type

enum tmr_dma_transfer_length_type

tmr dma transfer length type

Enumerator
TMR_DMA_TRANSFER_1BYTE | tmr dma transfer length 1 byte
TMR_DMA_TRANSFER_2BYTES | tmr dma transfer length 2 bytes
TMR_DMA_TRANSFER_3BYTES | tmr dma transfer length 3 bytes
TMR_DMA_TRANSFER_4BYTES | tmr dma transfer length 4 bytes
TMR_DMA_TRANSFER_5BYTES | tmr dma transfer length 5 bytes
TMR_DMA_TRANSFER_6BYTES | tmr dma transfer length 6 bytes
TMR_DMA_TRANSFER_7BYTES | tmr dma transfer length 7 bytes
TMR_DMA_TRANSFER_8BYTES | tmr dma transfer length 8 bytes
TMR_DMA_TRANSFER_9BYTES | tmr dma transfer length 9 bytes
TMR_DMA_TRANSFER_10BYTES | tmr dma transfer length 10 bytes
TMR_DMA_TRANSFER_11BYTES | tmr dma transfer length 11 bytes
TMR_DMA_TRANSFER_12BYTES | tmr dma transfer length 12 bytes
TMR_DMA_TRANSFER_13BYTES | tmr dma transfer length 13 bytes
TMR_DMA_TRANSFER_14BYTES | tmr dma transfer length 14 bytes
TMR_DMA_TRANSFER_15BYTES | tmr dma transfer length 15 bytes
TMR_DMA_TRANSFER_16BYTES | tmr dma transfer length 16 bytes
TMR_DMA_TRANSFER_17BYTES | tmr dma transfer length 17 bytes
TMR_DMA_TRANSFER_18BYTES | tmr dma transfer length 18 bytes

Definition at line 328 of file at32f435_437_tmr.h.

◆ tmr_encoder_mode_type

enum tmr_encoder_mode_type

tmr encoder mode type

Enumerator
TMR_ENCODER_MODE_A | tmr encoder mode a
TMR_ENCODER_MODE_B | tmr encoder mode b
TMR_ENCODER_MODE_C | tmr encoder mode c

Definition at line 162 of file at32f435_437_tmr.h.

◆ tmr_event_trigger_type

enum tmr_event_trigger_type

tmr event triggered by software type

Enumerator
TMR_OVERFLOW_SWTRIG | tmr event triggered by software of overflow
TMR_C1_SWTRIG | tmr event triggered by software of channel 1
TMR_C2_SWTRIG | tmr event triggered by software of channel 2
TMR_C3_SWTRIG | tmr event triggered by software of channel 3
TMR_C4_SWTRIG | tmr event triggered by software of channel 4
TMR_HALL_SWTRIG | tmr event triggered by software of hall
TMR_TRIGGER_SWTRIG | tmr event triggered by software of trigger
TMR_BRK_SWTRIG | tmr event triggered by software of brake

Definition at line 283 of file at32f435_437_tmr.h.

◆ tmr_external_signal_divider_type

enum tmr_external_signal_divider_type

tmr external signal divider type

Enumerator
TMR_ES_FREQUENCY_DIV_1 | tmr external signal frequency divider 1
TMR_ES_FREQUENCY_DIV_2 | tmr external signal frequency divider 2
TMR_ES_FREQUENCY_DIV_4 | tmr external signal frequency divider 4
TMR_ES_FREQUENCY_DIV_8 | tmr external signal frequency divider 8

Definition at line 308 of file at32f435_437_tmr.h.

◆ tmr_external_signal_polarity_type

enum tmr_external_signal_polarity_type

tmr external signal polarity type

Enumerator
TMR_ES_POLARITY_NON_INVERTED | tmr external signal polarity non-inerted
TMR_ES_POLARITY_INVERTED | tmr external signal polarity inerted

Definition at line 319 of file at32f435_437_tmr.h.

◆ tmr_force_output_type

enum tmr_force_output_type

tmr force output type

Enumerator
TMR_FORCE_OUTPUT_HIGH | tmr force output high
TMR_FORCE_OUTPUT_LOW | tmr force output low

Definition at line 187 of file at32f435_437_tmr.h.

◆ tmr_input_direction_mapped_type

enum tmr_input_direction_mapped_type

tmr input channel mapped type channel direction

Enumerator
TMR_CC_CHANNEL_MAPPED_DIRECT | channel is configured as input, mapped direct
TMR_CC_CHANNEL_MAPPED_INDIRECT | channel is configured as input, mapped indirect
TMR_CC_CHANNEL_MAPPED_STI | channel is configured as input, mapped trc

Definition at line 239 of file at32f435_437_tmr.h.

◆ tmr_input_polarity_type

enum tmr_input_polarity_type

tmr input channel polarity type

Enumerator
TMR_INPUT_RISING_EDGE | tmr input channel polarity rising
TMR_INPUT_FALLING_EDGE | tmr input channel polarity falling
TMR_INPUT_BOTH_EDGE | tmr input channel polarity both edge

Definition at line 205 of file at32f435_437_tmr.h.

◆ tmr_input_remap_type

enum tmr_input_remap_type

tmr input remap type

Enumerator
TMR2_TMR8TRGOUT_TMR5_GPIO | tmr2 input remap to tmr8_trgout or tmr5 remap to gpio
TMR2_PTP_TMR5_LICK | tmr2 input remap to ptp or tmr5 remap to lick
TMR2_OTG1FS_TMR5_LEXT | tmr2 input remap to otg1fs or tmr5 remap to lext
TMR2_OTG2FS_TMR5_ERTC | tmr2 input remap to otg2fs or tmr5 remap to ertc

Definition at line 399 of file at32f435_437_tmr.h.

◆ tmr_output_control_mode_type

enum tmr_output_control_mode_type

tmr output control mode type

Enumerator
TMR_OUTPUT_CONTROL_OFF | tmr output control mode off
TMR_OUTPUT_CONTROL_HIGH | tmr output control mode high
TMR_OUTPUT_CONTROL_LOW | tmr output control mode low
TMR_OUTPUT_CONTROL_SWITCH | tmr output control mode switch
TMR_OUTPUT_CONTROL_FORCE_LOW | tmr output control mode force low
TMR_OUTPUT_CONTROL_FORCE_HIGH | tmr output control mode force high
TMR_OUTPUT_CONTROL_PWM_MODE_A | tmr output control mode pwm a
TMR_OUTPUT_CONTROL_PWM_MODE_B | tmr output control mode pwm b

Definition at line 172 of file at32f435_437_tmr.h.

◆ tmr_output_polarity_type

enum tmr_output_polarity_type

tmr output channel polarity type

Enumerator
TMR_OUTPUT_ACTIVE_HIGH | tmr output channel polarity high
TMR_OUTPUT_ACTIVE_LOW | tmr output channel polarity low

Definition at line 196 of file at32f435_437_tmr.h.

◆ tmr_polarity_active_type

enum tmr_polarity_active_type

tmr polarity active type

Enumerator
TMR_POLARITY_ACTIVE_HIGH | tmr polarity active high
TMR_POLARITY_ACTIVE_LOW | tmr polarity active low
TMR_POLARITY_ACTIVE_BOTH | tmr polarity active both high ande low

Definition at line 298 of file at32f435_437_tmr.h.

◆ tmr_primary_select_type

enum tmr_primary_select_type

tmr primary mode select type

Enumerator
TMR_PRIMARY_SEL_RESET | tmr primary mode select reset
TMR_PRIMARY_SEL_ENABLE | tmr primary mode select enable
TMR_PRIMARY_SEL_OVERFLOW | tmr primary mode select overflow
TMR_PRIMARY_SEL_COMPARE | tmr primary mode select compare
TMR_PRIMARY_SEL_C1ORAW | tmr primary mode select c1oraw
TMR_PRIMARY_SEL_C2ORAW | tmr primary mode select c2oraw
TMR_PRIMARY_SEL_C3ORAW | tmr primary mode select c3oraw
TMR_PRIMARY_SEL_C4ORAW | tmr primary mode select c4oraw

Definition at line 117 of file at32f435_437_tmr.h.

◆ tmr_sub_mode_select_type

enum tmr_sub_mode_select_type

tmr subordinate mode select type

Enumerator
TMR_SUB_MODE_DIABLE | subordinate mode disable
TMR_SUB_ENCODER_MODE_A | subordinate mode select encoder mode a
TMR_SUB_ENCODER_MODE_B | subordinate mode select encoder mode b
TMR_SUB_ENCODER_MODE_C | subordinate mode select encoder mode c
TMR_SUB_RESET_MODE | subordinate mode select reset
TMR_SUB_HANG_MODE | subordinate mode select hang
TMR_SUB_TRIGGER_MODE | subordinate mode select trigger
TMR_SUB_EXTERNAL_CLOCK_MODE_A | subordinate mode external clock mode a

Definition at line 147 of file at32f435_437_tmr.h.

◆ tmr_wp_level_type

enum tmr_wp_level_type

tmr write protect level type

Enumerator
TMR_WP_OFF | tmr write protect off
TMR_WP_LEVEL_3 | tmr write protect level 3
TMR_WP_LEVEL_2 | tmr write protect level 2
TMR_WP_LEVEL_1 | tmr write protect level 1

Definition at line 388 of file at32f435_437_tmr.h.


AT32F435/437 Firmwary Library: tmr_output_config_type Struct Reference

Data Fields
tmr_output_config_type Struct Reference
AT32F435_437_periph_driver » TMR » TMR_exported_types

tmr output config type More...

#include <at32f435_437_tmr.h>

Data Fields

tmr_output_control_mode_type oc_mode
confirm_state oc_idle_state
confirm_state occ_idle_state
tmr_output_polarity_type oc_polarity
tmr_output_polarity_type occ_polarity
confirm_state oc_output_state
confirm_state occ_output_state

Detailed Description

tmr output config type

Definition at line 410 of file at32f435_437_tmr.h.

Field Documentation

◆ oc_idle_state

confirm_state tmr_output_config_type::oc_idle_state

output channel idle state

Definition at line 413 of file at32f435_437_tmr.h.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), tmr_output_channel_config(), and tmr_output_default_para_init().

◆ oc_mode

tmr_output_control_mode_type tmr_output_config_type::oc_mode

output channel mode

Definition at line 412 of file at32f435_437_tmr.h.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), tmr_output_channel_config(), and tmr_output_default_para_init().

◆ oc_output_state

confirm_state tmr_output_config_type::oc_output_state

output channel enable

Definition at line 417 of file at32f435_437_tmr.h.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), tmr_output_channel_config(), and tmr_output_default_para_init().

◆ oc_polarity

tmr_output_polarity_type tmr_output_config_type::oc_polarity

output channel polarity

Definition at line 415 of file at32f435_437_tmr.h.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), tmr_output_channel_config(), and tmr_output_default_para_init().

◆ occ_idle_state

confirm_state tmr_output_config_type::occ_idle_state

output channel complementary idle state

Definition at line 414 of file at32f435_437_tmr.h.

Referenced by main(), tmr_output_channel_config(), and tmr_output_default_para_init().

◆ occ_output_state

confirm_state tmr_output_config_type::occ_output_state

output channel complementary enable

Definition at line 418 of file at32f435_437_tmr.h.

Referenced by main(), tmr_output_channel_config(), and tmr_output_default_para_init().

◆ occ_polarity

tmr_output_polarity_type tmr_output_config_type::occ_polarity

output channel complementary polarity

Definition at line 416 of file at32f435_437_tmr.h.

Referenced by main(), tmr_output_channel_config(), and tmr_output_default_para_init().

The documentation for this struct was generated from the following file:
  • at32f435_437_tmr.h


AT32F435/437 Firmwary Library: tmr_input_config_type Struct Reference

Data Fields
tmr_input_config_type Struct Reference
AT32F435_437_periph_driver » TMR » TMR_exported_types

tmr input capture config type More...

#include <at32f435_437_tmr.h>

Data Fields

tmr_channel_select_type input_channel_select
tmr_input_polarity_type input_polarity_select
tmr_input_direction_mapped_type input_mapped_select
uint8_t input_filter_value

Detailed Description

tmr input capture config type

Definition at line 424 of file at32f435_437_tmr.h.

Field Documentation

◆ input_channel_select

tmr_channel_select_type tmr_input_config_type::input_channel_select

tmr input channel select

Definition at line 426 of file at32f435_437_tmr.h.

Referenced by lick_frequency_get(), main(), tmr_input_channel_init(), tmr_input_default_para_init(), and tmr_pwm_input_config().

◆ input_filter_value

uint8_t tmr_input_config_type::input_filter_value

tmr channel filter value

Definition at line 429 of file at32f435_437_tmr.h.

Referenced by lick_frequency_get(), main(), tmr_input_channel_init(), tmr_input_default_para_init(), and tmr_pwm_input_config().

◆ input_mapped_select

tmr_input_direction_mapped_type tmr_input_config_type::input_mapped_select

tmr channel mapped direct or indirect

Definition at line 428 of file at32f435_437_tmr.h.

Referenced by lick_frequency_get(), main(), tmr_input_channel_init(), tmr_input_default_para_init(), and tmr_pwm_input_config().

◆ input_polarity_select

tmr_input_polarity_type tmr_input_config_type::input_polarity_select

tmr input polarity select

Definition at line 427 of file at32f435_437_tmr.h.

Referenced by lick_frequency_get(), main(), tmr_input_channel_init(), tmr_input_default_para_init(), and tmr_pwm_input_config().

The documentation for this struct was generated from the following file:
  • at32f435_437_tmr.h


AT32F435/437 Firmwary Library: tmr_brkdt_config_type Struct Reference

Data Fields
tmr_brkdt_config_type Struct Reference
AT32F435_437_periph_driver » TMR » TMR_exported_types

tmr brkdt config type More...

#include <at32f435_437_tmr.h>

Data Fields

uint8_t deadtime
tmr_brk_polarity_type brk_polarity
tmr_wp_level_type wp_level
confirm_state auto_output_enable
confirm_state fcsoen_state
confirm_state fcsodis_state
confirm_state brk_enable

Detailed Description

tmr brkdt config type

Definition at line 435 of file at32f435_437_tmr.h.

Field Documentation

◆ auto_output_enable

confirm_state tmr_brkdt_config_type::auto_output_enable

automatic output enable

Definition at line 440 of file at32f435_437_tmr.h.

Referenced by main(), tmr_brkdt_config(), and tmr_brkdt_default_para_init().

◆ brk_enable

confirm_state tmr_brkdt_config_type::brk_enable

tmr brk enale

Definition at line 443 of file at32f435_437_tmr.h.

Referenced by main(), tmr_brkdt_config(), and tmr_brkdt_default_para_init().

◆ brk_polarity

tmr_brk_polarity_type tmr_brkdt_config_type::brk_polarity

tmr brake polarity

Definition at line 438 of file at32f435_437_tmr.h.

Referenced by main(), tmr_brkdt_config(), and tmr_brkdt_default_para_init().

◆ deadtime

uint8_t tmr_brkdt_config_type::deadtime

dead-time generator setup

Definition at line 437 of file at32f435_437_tmr.h.

Referenced by main(), tmr_brkdt_config(), and tmr_brkdt_default_para_init().

◆ fcsodis_state

confirm_state tmr_brkdt_config_type::fcsodis_state

frozen channel status when output disable

Definition at line 442 of file at32f435_437_tmr.h.

Referenced by main(), tmr_brkdt_config(), and tmr_brkdt_default_para_init().

◆ fcsoen_state

confirm_state tmr_brkdt_config_type::fcsoen_state

frozen channel status when output enable

Definition at line 441 of file at32f435_437_tmr.h.

Referenced by main(), tmr_brkdt_config(), and tmr_brkdt_default_para_init().

◆ wp_level

tmr_wp_level_type tmr_brkdt_config_type::wp_level

write protect configuration

Definition at line 439 of file at32f435_437_tmr.h.

Referenced by main(), tmr_brkdt_config(), and tmr_brkdt_default_para_init().

The documentation for this struct was generated from the following file:
  • at32f435_437_tmr.h


AT32F435/437 Firmwary Library: tmr_type Struct Reference

Data Fields
tmr_type Struct Reference
AT32F435_437_periph_driver » TMR » TMR_exported_types

type define tmr register all More...

#include <at32f435_437_tmr.h>

Data Fields

union {
__IO uint32_t ctrl1
struct {
__IO uint32_t tmren: 1
__IO uint32_t ovfen: 1
__IO uint32_t ovfs: 1
__IO uint32_t ocmen: 1
__IO uint32_t cnt_dir: 3
__IO uint32_t prben: 1
__IO uint32_t clkdiv: 2
__IO uint32_t pmen: 1
__IO uint32_t reserved1: 21
} ctrl1_bit
};
tmr ctrl1 register, offset:0x00 More...
union {
__IO uint32_t ctrl2
struct {
__IO uint32_t cbctrl: 1
__IO uint32_t reserved1: 1
__IO uint32_t ccfs: 1
__IO uint32_t drs: 1
__IO uint32_t ptos: 3
__IO uint32_t c1insel: 1
__IO uint32_t c1ios: 1
__IO uint32_t c1cios: 1
__IO uint32_t c2ios: 1
__IO uint32_t c2cios: 1
__IO uint32_t c3ios: 1
__IO uint32_t c3cios: 1
__IO uint32_t c4ios: 1
__IO uint32_t reserved2: 16
__IO uint32_t trgout2en: 1
} ctrl2_bit
};
tmr ctrl2 register, offset:0x04 More...
union {
__IO uint32_t stctrl
struct {
__IO uint32_t smsel: 3
__IO uint32_t reserved1: 1
__IO uint32_t stis: 3
__IO uint32_t sts: 1
__IO uint32_t esf: 4
__IO uint32_t esdiv: 2
__IO uint32_t ecmben: 1
__IO uint32_t esp: 1
__IO uint32_t reserved2: 16
} stctrl_bit
};
tmr smc register, offset:0x08 More...
union {
__IO uint32_t iden
struct {
__IO uint32_t ovfien: 1
__IO uint32_t c1ien: 1
__IO uint32_t c2ien: 1
__IO uint32_t c3ien: 1
__IO uint32_t c4ien: 1
__IO uint32_t hallien: 1
__IO uint32_t tien: 1
__IO uint32_t brkie: 1
__IO uint32_t ovfden: 1
__IO uint32_t c1den: 1
__IO uint32_t c2den: 1
__IO uint32_t c3den: 1
__IO uint32_t c4den: 1
__IO uint32_t hallde: 1
__IO uint32_t tden: 1
__IO uint32_t reserved1: 17
} iden_bit
};
tmr die register, offset:0x0C More...
union {
__IO uint32_t ists
struct {
__IO uint32_t ovfif: 1
__IO uint32_t c1if: 1
__IO uint32_t c2if: 1
__IO uint32_t c3if: 1
__IO uint32_t c4if: 1
__IO uint32_t hallif: 1
__IO uint32_t trgif: 1
__IO uint32_t brkif: 1
__IO uint32_t reserved1: 1
__IO uint32_t c1rf: 1
__IO uint32_t c2rf: 1
__IO uint32_t c3rf: 1
__IO uint32_t c4rf: 1
__IO uint32_t reserved2: 19
} ists_bit
};
tmr ists register, offset:0x10 More...
union {
__IO uint32_t swevt
struct {
__IO uint32_t ovfswtr: 1
__IO uint32_t c1swtr: 1
__IO uint32_t c2swtr: 1
__IO uint32_t c3swtr: 1
__IO uint32_t c4swtr: 1
__IO uint32_t hallswtr: 1
__IO uint32_t trgswtr: 1
__IO uint32_t brkswtr: 1
__IO uint32_t reserved: 24
} swevt_bit
};
tmr eveg register, offset:0x14 More...
union {
__IO uint32_t cm1
struct {
__IO uint32_t c1c: 2
__IO uint32_t c1oien: 1
__IO uint32_t c1oben: 1
__IO uint32_t c1octrl: 3
__IO uint32_t c1osen: 1
__IO uint32_t c2c: 2
__IO uint32_t c2oien: 1
__IO uint32_t c2oben: 1
__IO uint32_t c2octrl: 3
__IO uint32_t c2osen: 1
__IO uint32_t reserved1: 16
} cm1_output_bit
channel mode More...
struct {
__IO uint32_t c1c: 2
__IO uint32_t c1idiv: 2
__IO uint32_t c1df: 4
__IO uint32_t c2c: 2
__IO uint32_t c2idiv: 2
__IO uint32_t c2df: 4
__IO uint32_t reserved1: 16
} cm1_input_bit
input capture mode More...
};
tmr ccm1 register, offset:0x18 More...
union {
__IO uint32_t cm2
struct {
__IO uint32_t c3c: 2
__IO uint32_t c3oien: 1
__IO uint32_t c3oben: 1
__IO uint32_t c3octrl: 3
__IO uint32_t c3osen: 1
__IO uint32_t c4c: 2
__IO uint32_t c4oien: 1
__IO uint32_t c4oben: 1
__IO uint32_t c4octrl: 3
__IO uint32_t c4osen: 1
__IO uint32_t reserved1: 16
} cm2_output_bit
channel mode More...
struct {
__IO uint32_t c3c: 2
__IO uint32_t c3idiv: 2
__IO uint32_t c3df: 4
__IO uint32_t c4c: 2
__IO uint32_t c4idiv: 2
__IO uint32_t c4df: 4
__IO uint32_t reserved1: 16
} cm2_input_bit
input capture mode More...
};
tmr ccm2 register, offset:0x1C More...
union {
uint32_t cctrl
struct {
__IO uint32_t c1en: 1
__IO uint32_t c1p: 1
__IO uint32_t c1cen: 1
__IO uint32_t c1cp: 1
__IO uint32_t c2en: 1
__IO uint32_t c2p: 1
__IO uint32_t c2cen: 1
__IO uint32_t c2cp: 1
__IO uint32_t c3en: 1
__IO uint32_t c3p: 1
__IO uint32_t c3cen: 1
__IO uint32_t c3cp: 1
__IO uint32_t c4en: 1
__IO uint32_t c4p: 1
__IO uint32_t reserved1: 18
} cctrl_bit
};
tmr cce register, offset:0x20 More...
union {
__IO uint32_t cval
struct {
__IO uint32_t cval: 32
} cval_bit
};
tmr cnt register, offset:0x24 More...
union {
__IO uint32_t div
struct {
__IO uint32_t div: 16
__IO uint32_t reserved1: 16
} div_bit
};
tmr div, offset:0x28 More...
union {
__IO uint32_t pr
struct {
__IO uint32_t pr: 32
} pr_bit
};
tmr pr register, offset:0x2C More...
union {
__IO uint32_t rpr
struct {
__IO uint32_t rpr: 16
__IO uint32_t reserved1: 16
} rpr_bit
};
tmr rpr register, offset:0x30 More...
union {
uint32_t c1dt
struct {
__IO uint32_t c1dt: 32
} c1dt_bit
};
tmr c1dt register, offset:0x34 More...
union {
uint32_t c2dt
struct {
__IO uint32_t c2dt: 32
} c2dt_bit
};
tmr c2dt register, offset:0x38 More...
union {
__IO uint32_t c3dt
struct {
__IO uint32_t c3dt: 32
} c3dt_bit
};
tmr c3dt register, offset:0x3C More...
union {
__IO uint32_t c4dt
struct {
__IO uint32_t c4dt: 32
} c4dt_bit
};
tmr c4dt register, offset:0x40 More...
union {
__IO uint32_t brk
struct {
__IO uint32_t dtc: 8
__IO uint32_t wpc: 2
__IO uint32_t fcsodis: 1
__IO uint32_t fcsoen: 1
__IO uint32_t brken: 1
__IO uint32_t brkv: 1
__IO uint32_t aoen: 1
__IO uint32_t oen: 1
__IO uint32_t reserved1: 16
} brk_bit
};
tmr brk register, offset:0x44 More...
union {
__IO uint32_t dmactrl
struct {
__IO uint32_t addr: 5
__IO uint32_t reserved1: 3
__IO uint32_t dtb: 5
__IO uint32_t reserved2: 19
} dmactrl_bit
};
tmr dmactrl register, offset:0x48 More...
union {
__IO uint32_t dmadt
struct {
__IO uint32_t dmadt: 16
__IO uint32_t reserved1: 16
} dmadt_bit
};
tmr dmadt register, offset:0x4C More...
union {
__IO uint32_t rmp
struct {
__IO uint32_t reserved1: 6
__IO uint32_t tmr5_ch4_irmp: 2
__IO uint32_t reserved2: 2
__IO uint32_t tmr2_ch1_irmp: 2
__IO uint32_t reserved3: 20
} rmp_bit
};
tmr rmp register, offset:0x50 More...
union {
__IO uint32_t cm3
struct {
__IO uint32_t reserved1: 2
__IO uint32_t c5oien: 1
__IO uint32_t c5oben: 1
__IO uint32_t c5octrl: 3
__IO uint32_t c5osen: 1
__IO uint32_t reserved2: 24
} cm3_output_bit
};
tmr cm3 register, offset:0x70 More...
union {
__IO uint32_t c5dt
struct {
__IO uint32_t c5dt: 32
} c5dt_bit
};
tmr c5dt register, offset:0x74 More...

Detailed Description

type define tmr register all

Definition at line 449 of file at32f435_437_tmr.h.

Field Documentation

◆

union { ... } tmr_type::@1058

tmr ctrl1 register, offset:0x00

◆

union { ... } tmr_type::@1060

tmr ctrl2 register, offset:0x04

◆

union { ... } tmr_type::@1062

tmr smc register, offset:0x08

◆

union { ... } tmr_type::@1064

tmr die register, offset:0x0C

◆

union { ... } tmr_type::@1066

tmr ists register, offset:0x10

◆

union { ... } tmr_type::@1068

tmr eveg register, offset:0x14

◆

union { ... } tmr_type::@1070

tmr ccm1 register, offset:0x18

◆

union { ... } tmr_type::@1072

tmr ccm2 register, offset:0x1C

◆

union { ... } tmr_type::@1074

tmr cce register, offset:0x20

◆

union { ... } tmr_type::@1076

tmr cnt register, offset:0x24

◆

union { ... } tmr_type::@1078

tmr div, offset:0x28

◆

union { ... } tmr_type::@1080

tmr pr register, offset:0x2C

◆

union { ... } tmr_type::@1082

tmr rpr register, offset:0x30

◆

union { ... } tmr_type::@1084

tmr c1dt register, offset:0x34

◆

union { ... } tmr_type::@1086

tmr c2dt register, offset:0x38

◆

union { ... } tmr_type::@1088

tmr c3dt register, offset:0x3C

◆

union { ... } tmr_type::@1090

tmr c4dt register, offset:0x40

◆

union { ... } tmr_type::@1092

tmr brk register, offset:0x44

◆

union { ... } tmr_type::@1094

tmr dmactrl register, offset:0x48

◆

union { ... } tmr_type::@1096

tmr dmadt register, offset:0x4C

◆

union { ... } tmr_type::@1098

tmr rmp register, offset:0x50

◆

union { ... } tmr_type::@1100

tmr cm3 register, offset:0x70

◆

union { ... } tmr_type::@1102

tmr c5dt register, offset:0x74

◆ addr

__IO uint32_t tmr_type::addr

Definition at line 820 of file at32f435_437_tmr.h.

Referenced by tmr_dma_control_config().

◆ aoen

__IO uint32_t tmr_type::aoen

Definition at line 807 of file at32f435_437_tmr.h.

Referenced by tmr_brkdt_config().

◆ brk

__IO uint32_t tmr_type::brk

Definition at line 798 of file at32f435_437_tmr.h.

◆

struct { ... } tmr_type::brk_bit

Referenced by tmr_brkdt_config(), and tmr_output_enable().

◆ brken

__IO uint32_t tmr_type::brken

Definition at line 805 of file at32f435_437_tmr.h.

Referenced by tmr_brkdt_config().

◆ brkie

__IO uint32_t tmr_type::brkie

Definition at line 532 of file at32f435_437_tmr.h.

◆ brkif

__IO uint32_t tmr_type::brkif

Definition at line 559 of file at32f435_437_tmr.h.

◆ brkswtr

__IO uint32_t tmr_type::brkswtr

Definition at line 584 of file at32f435_437_tmr.h.

◆ brkv

__IO uint32_t tmr_type::brkv

Definition at line 806 of file at32f435_437_tmr.h.

Referenced by tmr_brkdt_config().

◆ c1c

__IO uint32_t tmr_type::c1c

Definition at line 601 of file at32f435_437_tmr.h.

Referenced by tmr_encoder_mode_config(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆ c1cen

__IO uint32_t tmr_type::c1cen

Definition at line 679 of file at32f435_437_tmr.h.

Referenced by tmr_channel_enable().

◆ c1cios

__IO uint32_t tmr_type::c1cios

Definition at line 486 of file at32f435_437_tmr.h.

◆ c1cp

__IO uint32_t tmr_type::c1cp

Definition at line 680 of file at32f435_437_tmr.h.

Referenced by tmr_encoder_mode_config(), tmr_input_channel_init(), and tmr_output_channel_polarity_set().

◆ c1den

__IO uint32_t tmr_type::c1den

Definition at line 534 of file at32f435_437_tmr.h.

◆ c1df

__IO uint32_t tmr_type::c1df

Definition at line 621 of file at32f435_437_tmr.h.

Referenced by tmr_input_channel_filter_set(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆ c1dt [1/2]

uint32_t tmr_type::c1dt

Definition at line 750 of file at32f435_437_tmr.h.

Referenced by tmr_channel_value_get(), and tmr_channel_value_set().

◆ c1dt [2/2]

__IO uint32_t tmr_type::c1dt

Definition at line 753 of file at32f435_437_tmr.h.

◆

struct { ... } tmr_type::c1dt_bit

◆ c1en

__IO uint32_t tmr_type::c1en

Definition at line 677 of file at32f435_437_tmr.h.

Referenced by tmr_channel_enable(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆ c1idiv

__IO uint32_t tmr_type::c1idiv

Definition at line 620 of file at32f435_437_tmr.h.

Referenced by tmr_input_channel_divider_set(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆ c1ien

__IO uint32_t tmr_type::c1ien

Definition at line 526 of file at32f435_437_tmr.h.

◆ c1if

__IO uint32_t tmr_type::c1if

Definition at line 553 of file at32f435_437_tmr.h.

◆ c1insel

__IO uint32_t tmr_type::c1insel

Definition at line 484 of file at32f435_437_tmr.h.

Referenced by tmr_channel1_input_select().

◆ c1ios

__IO uint32_t tmr_type::c1ios

Definition at line 485 of file at32f435_437_tmr.h.

◆ c1oben

__IO uint32_t tmr_type::c1oben

Definition at line 603 of file at32f435_437_tmr.h.

Referenced by tmr_output_channel_buffer_enable().

◆ c1octrl

__IO uint32_t tmr_type::c1octrl

Definition at line 604 of file at32f435_437_tmr.h.

Referenced by tmr_force_output_set(), tmr_output_channel_config(), and tmr_output_channel_mode_select().

◆ c1oien

__IO uint32_t tmr_type::c1oien

Definition at line 602 of file at32f435_437_tmr.h.

Referenced by tmr_output_channel_immediately_set().

◆ c1osen

__IO uint32_t tmr_type::c1osen

Definition at line 605 of file at32f435_437_tmr.h.

Referenced by tmr_output_channel_switch_set().

◆ c1p

__IO uint32_t tmr_type::c1p

Definition at line 678 of file at32f435_437_tmr.h.

Referenced by tmr_encoder_mode_config(), tmr_input_channel_init(), tmr_output_channel_polarity_set(), and tmr_pwm_input_config().

◆ c1rf

__IO uint32_t tmr_type::c1rf

Definition at line 561 of file at32f435_437_tmr.h.

◆ c1swtr

__IO uint32_t tmr_type::c1swtr

Definition at line 578 of file at32f435_437_tmr.h.

◆ c2c

__IO uint32_t tmr_type::c2c

Definition at line 606 of file at32f435_437_tmr.h.

Referenced by tmr_encoder_mode_config(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆ c2cen

__IO uint32_t tmr_type::c2cen

Definition at line 683 of file at32f435_437_tmr.h.

Referenced by tmr_channel_enable().

◆ c2cios

__IO uint32_t tmr_type::c2cios

Definition at line 488 of file at32f435_437_tmr.h.

◆ c2cp

__IO uint32_t tmr_type::c2cp

Definition at line 684 of file at32f435_437_tmr.h.

Referenced by tmr_encoder_mode_config(), tmr_input_channel_init(), and tmr_output_channel_polarity_set().

◆ c2den

__IO uint32_t tmr_type::c2den

Definition at line 535 of file at32f435_437_tmr.h.

◆ c2df

__IO uint32_t tmr_type::c2df

Definition at line 624 of file at32f435_437_tmr.h.

Referenced by tmr_input_channel_filter_set(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆ c2dt [1/2]

uint32_t tmr_type::c2dt

Definition at line 762 of file at32f435_437_tmr.h.

Referenced by tmr_channel_value_get(), and tmr_channel_value_set().

◆ c2dt [2/2]

__IO uint32_t tmr_type::c2dt

Definition at line 765 of file at32f435_437_tmr.h.

◆

struct { ... } tmr_type::c2dt_bit

◆ c2en

__IO uint32_t tmr_type::c2en

Definition at line 681 of file at32f435_437_tmr.h.

Referenced by tmr_channel_enable(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆ c2idiv

__IO uint32_t tmr_type::c2idiv

Definition at line 623 of file at32f435_437_tmr.h.

Referenced by tmr_input_channel_divider_set(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆ c2ien

__IO uint32_t tmr_type::c2ien

Definition at line 527 of file at32f435_437_tmr.h.

◆ c2if

__IO uint32_t tmr_type::c2if

Definition at line 554 of file at32f435_437_tmr.h.

◆ c2ios

__IO uint32_t tmr_type::c2ios

Definition at line 487 of file at32f435_437_tmr.h.

◆ c2oben

__IO uint32_t tmr_type::c2oben

Definition at line 608 of file at32f435_437_tmr.h.

Referenced by tmr_output_channel_buffer_enable().

◆ c2octrl

__IO uint32_t tmr_type::c2octrl

Definition at line 609 of file at32f435_437_tmr.h.

Referenced by tmr_force_output_set(), tmr_output_channel_config(), and tmr_output_channel_mode_select().

◆ c2oien

__IO uint32_t tmr_type::c2oien

Definition at line 607 of file at32f435_437_tmr.h.

Referenced by tmr_output_channel_immediately_set().

◆ c2osen

__IO uint32_t tmr_type::c2osen

Definition at line 610 of file at32f435_437_tmr.h.

Referenced by tmr_output_channel_switch_set().

◆ c2p

__IO uint32_t tmr_type::c2p

Definition at line 682 of file at32f435_437_tmr.h.

Referenced by tmr_encoder_mode_config(), tmr_input_channel_init(), tmr_output_channel_polarity_set(), and tmr_pwm_input_config().

◆ c2rf

__IO uint32_t tmr_type::c2rf

Definition at line 562 of file at32f435_437_tmr.h.

◆ c2swtr

__IO uint32_t tmr_type::c2swtr

Definition at line 579 of file at32f435_437_tmr.h.

◆ c3c

__IO uint32_t tmr_type::c3c

Definition at line 641 of file at32f435_437_tmr.h.

Referenced by tmr_input_channel_init().

◆ c3cen

__IO uint32_t tmr_type::c3cen

Definition at line 687 of file at32f435_437_tmr.h.

Referenced by tmr_channel_enable().

◆ c3cios

__IO uint32_t tmr_type::c3cios

Definition at line 490 of file at32f435_437_tmr.h.

◆ c3cp

__IO uint32_t tmr_type::c3cp

Definition at line 688 of file at32f435_437_tmr.h.

Referenced by tmr_input_channel_init(), and tmr_output_channel_polarity_set().

◆ c3den

__IO uint32_t tmr_type::c3den

Definition at line 536 of file at32f435_437_tmr.h.

◆ c3df

__IO uint32_t tmr_type::c3df

Definition at line 661 of file at32f435_437_tmr.h.

Referenced by tmr_input_channel_filter_set(), and tmr_input_channel_init().

◆ c3dt

__IO uint32_t tmr_type::c3dt

Definition at line 774 of file at32f435_437_tmr.h.

Referenced by tmr_channel_value_get(), and tmr_channel_value_set().

◆

struct { ... } tmr_type::c3dt_bit

◆ c3en

__IO uint32_t tmr_type::c3en

Definition at line 685 of file at32f435_437_tmr.h.

Referenced by tmr_channel_enable(), and tmr_input_channel_init().

◆ c3idiv

__IO uint32_t tmr_type::c3idiv

Definition at line 660 of file at32f435_437_tmr.h.

Referenced by tmr_input_channel_divider_set(), and tmr_input_channel_init().

◆ c3ien

__IO uint32_t tmr_type::c3ien

Definition at line 528 of file at32f435_437_tmr.h.

◆ c3if

__IO uint32_t tmr_type::c3if

Definition at line 555 of file at32f435_437_tmr.h.

◆ c3ios

__IO uint32_t tmr_type::c3ios

Definition at line 489 of file at32f435_437_tmr.h.

◆ c3oben

__IO uint32_t tmr_type::c3oben

Definition at line 643 of file at32f435_437_tmr.h.

Referenced by tmr_output_channel_buffer_enable().

◆ c3octrl

__IO uint32_t tmr_type::c3octrl

Definition at line 644 of file at32f435_437_tmr.h.

Referenced by tmr_force_output_set(), tmr_output_channel_config(), and tmr_output_channel_mode_select().

◆ c3oien

__IO uint32_t tmr_type::c3oien

Definition at line 642 of file at32f435_437_tmr.h.

Referenced by tmr_output_channel_immediately_set().

◆ c3osen

__IO uint32_t tmr_type::c3osen

Definition at line 645 of file at32f435_437_tmr.h.

Referenced by tmr_output_channel_switch_set().

◆ c3p

__IO uint32_t tmr_type::c3p

Definition at line 686 of file at32f435_437_tmr.h.

Referenced by tmr_input_channel_init(), and tmr_output_channel_polarity_set().

◆ c3rf

__IO uint32_t tmr_type::c3rf

Definition at line 563 of file at32f435_437_tmr.h.

◆ c3swtr

__IO uint32_t tmr_type::c3swtr

Definition at line 580 of file at32f435_437_tmr.h.

◆ c4c

__IO uint32_t tmr_type::c4c

Definition at line 646 of file at32f435_437_tmr.h.

Referenced by tmr_input_channel_init().

◆ c4den

__IO uint32_t tmr_type::c4den

Definition at line 537 of file at32f435_437_tmr.h.

◆ c4df

__IO uint32_t tmr_type::c4df

Definition at line 664 of file at32f435_437_tmr.h.

Referenced by tmr_input_channel_filter_set(), and tmr_input_channel_init().

◆ c4dt

__IO uint32_t tmr_type::c4dt

Definition at line 786 of file at32f435_437_tmr.h.

Referenced by tmr_channel_value_get(), and tmr_channel_value_set().

◆

struct { ... } tmr_type::c4dt_bit

◆ c4en

__IO uint32_t tmr_type::c4en

Definition at line 689 of file at32f435_437_tmr.h.

Referenced by tmr_channel_enable(), and tmr_input_channel_init().

◆ c4idiv

__IO uint32_t tmr_type::c4idiv

Definition at line 663 of file at32f435_437_tmr.h.

Referenced by tmr_input_channel_divider_set(), and tmr_input_channel_init().

◆ c4ien

__IO uint32_t tmr_type::c4ien

Definition at line 529 of file at32f435_437_tmr.h.

◆ c4if

__IO uint32_t tmr_type::c4if

Definition at line 556 of file at32f435_437_tmr.h.

◆ c4ios

__IO uint32_t tmr_type::c4ios

Definition at line 491 of file at32f435_437_tmr.h.

◆ c4oben

__IO uint32_t tmr_type::c4oben

Definition at line 648 of file at32f435_437_tmr.h.

Referenced by tmr_output_channel_buffer_enable().

◆ c4octrl

__IO uint32_t tmr_type::c4octrl

Definition at line 649 of file at32f435_437_tmr.h.

Referenced by tmr_force_output_set(), tmr_output_channel_config(), and tmr_output_channel_mode_select().

◆ c4oien

__IO uint32_t tmr_type::c4oien

Definition at line 647 of file at32f435_437_tmr.h.

Referenced by tmr_output_channel_immediately_set().

◆ c4osen

__IO uint32_t tmr_type::c4osen

Definition at line 650 of file at32f435_437_tmr.h.

Referenced by tmr_output_channel_switch_set().

◆ c4p

__IO uint32_t tmr_type::c4p

Definition at line 690 of file at32f435_437_tmr.h.

Referenced by tmr_input_channel_init(), and tmr_output_channel_polarity_set().

◆ c4rf

__IO uint32_t tmr_type::c4rf

Definition at line 564 of file at32f435_437_tmr.h.

◆ c4swtr

__IO uint32_t tmr_type::c4swtr

Definition at line 581 of file at32f435_437_tmr.h.

◆ c5dt

__IO uint32_t tmr_type::c5dt

Definition at line 883 of file at32f435_437_tmr.h.

Referenced by tmr_channel_value_get(), and tmr_channel_value_set().

◆

struct { ... } tmr_type::c5dt_bit

◆ c5oben

__IO uint32_t tmr_type::c5oben

Definition at line 871 of file at32f435_437_tmr.h.

Referenced by tmr_output_channel_buffer_enable().

◆ c5octrl

__IO uint32_t tmr_type::c5octrl

Definition at line 872 of file at32f435_437_tmr.h.

Referenced by tmr_force_output_set(), tmr_output_channel_config(), and tmr_output_channel_mode_select().

◆ c5oien

__IO uint32_t tmr_type::c5oien

Definition at line 870 of file at32f435_437_tmr.h.

Referenced by tmr_output_channel_immediately_set().

◆ c5osen

__IO uint32_t tmr_type::c5osen

Definition at line 873 of file at32f435_437_tmr.h.

Referenced by tmr_output_channel_switch_set().

◆ cbctrl

__IO uint32_t tmr_type::cbctrl

Definition at line 479 of file at32f435_437_tmr.h.

Referenced by tmr_channel_buffer_enable().

◆ ccfs

__IO uint32_t tmr_type::ccfs

Definition at line 481 of file at32f435_437_tmr.h.

Referenced by tmr_hall_select().

◆ cctrl

uint32_t tmr_type::cctrl

Definition at line 674 of file at32f435_437_tmr.h.

Referenced by tmr_output_channel_config().

◆

struct { ... } tmr_type::cctrl_bit

Referenced by tmr_channel_enable(), tmr_encoder_mode_config(), tmr_input_channel_init(), tmr_output_channel_polarity_set(), and tmr_pwm_input_config().

◆ clkdiv

__IO uint32_t tmr_type::clkdiv

Definition at line 465 of file at32f435_437_tmr.h.

Referenced by tmr_clock_source_div_set().

◆ cm1

__IO uint32_t tmr_type::cm1

Definition at line 594 of file at32f435_437_tmr.h.

◆

struct { ... } tmr_type::cm1_input_bit

input capture mode

Referenced by tmr_encoder_mode_config(), tmr_input_channel_divider_set(), tmr_input_channel_filter_set(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆

struct { ... } tmr_type::cm1_output_bit

channel mode

Referenced by tmr_force_output_set(), tmr_output_channel_buffer_enable(), tmr_output_channel_config(), tmr_output_channel_immediately_set(), tmr_output_channel_mode_select(), and tmr_output_channel_switch_set().

◆ cm2

__IO uint32_t tmr_type::cm2

Definition at line 634 of file at32f435_437_tmr.h.

◆

struct { ... } tmr_type::cm2_input_bit

input capture mode

Referenced by tmr_input_channel_divider_set(), tmr_input_channel_filter_set(), and tmr_input_channel_init().

◆

struct { ... } tmr_type::cm2_output_bit

channel mode

Referenced by tmr_force_output_set(), tmr_output_channel_buffer_enable(), tmr_output_channel_config(), tmr_output_channel_immediately_set(), tmr_output_channel_mode_select(), and tmr_output_channel_switch_set().

◆ cm3

__IO uint32_t tmr_type::cm3

Definition at line 866 of file at32f435_437_tmr.h.

◆

struct { ... } tmr_type::cm3_output_bit

Referenced by tmr_force_output_set(), tmr_output_channel_buffer_enable(), tmr_output_channel_config(), tmr_output_channel_immediately_set(), tmr_output_channel_mode_select(), and tmr_output_channel_switch_set().

◆ cnt_dir

__IO uint32_t tmr_type::cnt_dir

Definition at line 463 of file at32f435_437_tmr.h.

Referenced by tmr_cnt_dir_set().

◆ ctrl1

__IO uint32_t tmr_type::ctrl1

Definition at line 456 of file at32f435_437_tmr.h.

◆

struct { ... } tmr_type::ctrl1_bit

Referenced by tmr_32_bit_function_enable(), tmr_clock_source_div_set(), tmr_cnt_dir_set(), tmr_counter_enable(), tmr_one_cycle_mode_enable(), tmr_overflow_event_disable(), tmr_overflow_request_source_set(), and tmr_period_buffer_enable().

◆ ctrl2

__IO uint32_t tmr_type::ctrl2

Definition at line 476 of file at32f435_437_tmr.h.

Referenced by tmr_output_channel_config().

◆

struct { ... } tmr_type::ctrl2_bit

Referenced by tmr_channel1_input_select(), tmr_channel_buffer_enable(), tmr_channel_dma_select(), tmr_hall_select(), tmr_primary_mode_select(), and tmr_trgout2_enable().

◆ cval

__IO uint32_t tmr_type::cval

Definition at line 700 of file at32f435_437_tmr.h.

Referenced by tmr_counter_value_get(), and tmr_counter_value_set().

◆

struct { ... } tmr_type::cval_bit

◆ div

__IO uint32_t tmr_type::div

Definition at line 712 of file at32f435_437_tmr.h.

Referenced by tmr_base_init(), tmr_div_value_get(), and tmr_div_value_set().

◆

struct { ... } tmr_type::div_bit

◆ dmactrl

__IO uint32_t tmr_type::dmactrl

Definition at line 817 of file at32f435_437_tmr.h.

◆

struct { ... } tmr_type::dmactrl_bit

Referenced by tmr_dma_control_config().

◆ dmadt

__IO uint32_t tmr_type::dmadt

Definition at line 832 of file at32f435_437_tmr.h.

◆

struct { ... } tmr_type::dmadt_bit

◆ drs

__IO uint32_t tmr_type::drs

Definition at line 482 of file at32f435_437_tmr.h.

Referenced by tmr_channel_dma_select().

◆ dtb

__IO uint32_t tmr_type::dtb

Definition at line 822 of file at32f435_437_tmr.h.

Referenced by tmr_dma_control_config().

◆ dtc

__IO uint32_t tmr_type::dtc

Definition at line 801 of file at32f435_437_tmr.h.

Referenced by tmr_brkdt_config().

◆ ecmben

__IO uint32_t tmr_type::ecmben

Definition at line 511 of file at32f435_437_tmr.h.

Referenced by tmr_external_clock_mode2_config().

◆ esdiv

__IO uint32_t tmr_type::esdiv

Definition at line 510 of file at32f435_437_tmr.h.

Referenced by tmr_external_clock_config().

◆ esf

__IO uint32_t tmr_type::esf

Definition at line 509 of file at32f435_437_tmr.h.

Referenced by tmr_external_clock_config().

◆ esp

__IO uint32_t tmr_type::esp

Definition at line 512 of file at32f435_437_tmr.h.

Referenced by tmr_external_clock_config().

◆ fcsodis

__IO uint32_t tmr_type::fcsodis

Definition at line 803 of file at32f435_437_tmr.h.

Referenced by tmr_brkdt_config().

◆ fcsoen

__IO uint32_t tmr_type::fcsoen

Definition at line 804 of file at32f435_437_tmr.h.

Referenced by tmr_brkdt_config().

◆ hallde

__IO uint32_t tmr_type::hallde

Definition at line 538 of file at32f435_437_tmr.h.

◆ hallien

__IO uint32_t tmr_type::hallien

Definition at line 530 of file at32f435_437_tmr.h.

◆ hallif

__IO uint32_t tmr_type::hallif

Definition at line 557 of file at32f435_437_tmr.h.

◆ hallswtr

__IO uint32_t tmr_type::hallswtr

Definition at line 582 of file at32f435_437_tmr.h.

◆ iden

__IO uint32_t tmr_type::iden

Definition at line 522 of file at32f435_437_tmr.h.

Referenced by tmr_dma_request_enable(), and tmr_interrupt_enable().

◆

struct { ... } tmr_type::iden_bit

◆ ists

__IO uint32_t tmr_type::ists

Definition at line 549 of file at32f435_437_tmr.h.

Referenced by tmr_flag_clear(), and tmr_flag_get().

◆

struct { ... } tmr_type::ists_bit

◆ ocmen

__IO uint32_t tmr_type::ocmen

Definition at line 462 of file at32f435_437_tmr.h.

Referenced by tmr_one_cycle_mode_enable().

◆ oen

__IO uint32_t tmr_type::oen

Definition at line 808 of file at32f435_437_tmr.h.

Referenced by tmr_output_enable().

◆ ovfden

__IO uint32_t tmr_type::ovfden

Definition at line 533 of file at32f435_437_tmr.h.

◆ ovfen

__IO uint32_t tmr_type::ovfen

Definition at line 460 of file at32f435_437_tmr.h.

Referenced by tmr_overflow_event_disable().

◆ ovfien

__IO uint32_t tmr_type::ovfien

Definition at line 525 of file at32f435_437_tmr.h.

◆ ovfif

__IO uint32_t tmr_type::ovfif

Definition at line 552 of file at32f435_437_tmr.h.

◆ ovfs

__IO uint32_t tmr_type::ovfs

Definition at line 461 of file at32f435_437_tmr.h.

Referenced by tmr_overflow_request_source_set().

◆ ovfswtr

__IO uint32_t tmr_type::ovfswtr

Definition at line 577 of file at32f435_437_tmr.h.

Referenced by tmr_base_init().

◆ pmen

__IO uint32_t tmr_type::pmen

Definition at line 466 of file at32f435_437_tmr.h.

Referenced by tmr_32_bit_function_enable().

◆ pr

__IO uint32_t tmr_type::pr

Definition at line 725 of file at32f435_437_tmr.h.

Referenced by tmr_base_init(), tmr_period_value_get(), and tmr_period_value_set().

◆

struct { ... } tmr_type::pr_bit

◆ prben

__IO uint32_t tmr_type::prben

Definition at line 464 of file at32f435_437_tmr.h.

Referenced by tmr_period_buffer_enable().

◆ ptos

__IO uint32_t tmr_type::ptos

Definition at line 483 of file at32f435_437_tmr.h.

Referenced by tmr_primary_mode_select().

◆ reserved

__IO uint32_t tmr_type::reserved

Definition at line 585 of file at32f435_437_tmr.h.

◆ reserved1

__IO uint32_t tmr_type::reserved1

tmr reserved0 register, offset:0x54-0x6C

Definition at line 467 of file at32f435_437_tmr.h.

◆ reserved2

__IO uint32_t tmr_type::reserved2

Definition at line 492 of file at32f435_437_tmr.h.

◆ reserved3

__IO uint32_t tmr_type::reserved3

Definition at line 852 of file at32f435_437_tmr.h.

◆ rmp

__IO uint32_t tmr_type::rmp

Definition at line 845 of file at32f435_437_tmr.h.

◆

struct { ... } tmr_type::rmp_bit

Referenced by tmr_iremap_config().

◆ rpr

__IO uint32_t tmr_type::rpr

Definition at line 737 of file at32f435_437_tmr.h.

Referenced by tmr_repetition_counter_set().

◆

struct { ... } tmr_type::rpr_bit

Referenced by tmr_repetition_counter_set().

◆ smsel

__IO uint32_t tmr_type::smsel

Definition at line 505 of file at32f435_437_tmr.h.

Referenced by tmr_encoder_mode_config(), tmr_external_clock_mode1_config(), tmr_internal_clock_set(), and tmr_sub_mode_select().

◆ stctrl

__IO uint32_t tmr_type::stctrl

Definition at line 502 of file at32f435_437_tmr.h.

◆

struct { ... } tmr_type::stctrl_bit

Referenced by tmr_encoder_mode_config(), tmr_external_clock_config(), tmr_external_clock_mode1_config(), tmr_external_clock_mode2_config(), tmr_internal_clock_set(), tmr_sub_mode_select(), tmr_sub_sync_mode_set(), and tmr_trigger_input_select().

◆ stis

__IO uint32_t tmr_type::stis

Definition at line 507 of file at32f435_437_tmr.h.

Referenced by tmr_external_clock_mode1_config(), and tmr_trigger_input_select().

◆ sts

__IO uint32_t tmr_type::sts

Definition at line 508 of file at32f435_437_tmr.h.

Referenced by tmr_sub_sync_mode_set().

◆ swevt

__IO uint32_t tmr_type::swevt

Definition at line 574 of file at32f435_437_tmr.h.

Referenced by tmr_event_sw_trigger().

◆

struct { ... } tmr_type::swevt_bit

Referenced by tmr_base_init().

◆ tden

__IO uint32_t tmr_type::tden

Definition at line 539 of file at32f435_437_tmr.h.

◆ tien

__IO uint32_t tmr_type::tien

Definition at line 531 of file at32f435_437_tmr.h.

◆ tmr2_ch1_irmp

__IO uint32_t tmr_type::tmr2_ch1_irmp

Definition at line 851 of file at32f435_437_tmr.h.

Referenced by tmr_iremap_config().

◆ tmr5_ch4_irmp

__IO uint32_t tmr_type::tmr5_ch4_irmp

Definition at line 849 of file at32f435_437_tmr.h.

Referenced by tmr_iremap_config().

◆ tmren

__IO uint32_t tmr_type::tmren

Definition at line 459 of file at32f435_437_tmr.h.

Referenced by tmr_counter_enable().

◆ trgif

__IO uint32_t tmr_type::trgif

Definition at line 558 of file at32f435_437_tmr.h.

◆ trgout2en

__IO uint32_t tmr_type::trgout2en

Definition at line 493 of file at32f435_437_tmr.h.

Referenced by tmr_trgout2_enable().

◆ trgswtr

__IO uint32_t tmr_type::trgswtr

Definition at line 583 of file at32f435_437_tmr.h.

◆ wpc

__IO uint32_t tmr_type::wpc

Definition at line 802 of file at32f435_437_tmr.h.

Referenced by tmr_brkdt_config().

The documentation for this struct was generated from the following file:
  • at32f435_437_tmr.h


AT32F435/437 Firmwary Library: TMR_exported_functions

Functions
TMR_exported_functions
AT32F435_437_periph_driver » TMR

Functions

void | tmr_reset (tmr_type *tmr_x)
tmr reset by crm reset register More...
void | tmr_counter_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter More...
void | tmr_output_default_para_init (tmr_output_config_type *tmr_output_struct)
init tmr output default para More...
void | tmr_input_default_para_init (tmr_input_config_type *tmr_input_struct)
init tmr input default para More...
void | tmr_brkdt_default_para_init (tmr_brkdt_config_type *tmr_brkdt_struct)
init tmr brkdt default para More...
void | tmr_base_init (tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base More...
void | tmr_clock_source_div_set (tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division More...
void | tmr_cnt_dir_set (tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction More...
void | tmr_repetition_counter_set (tmr_type *tmr_x, uint8_t tmr_rpr_value)
set the repetition counter register(rpr) value More...
void | tmr_counter_value_set (tmr_type *tmr_x, uint32_t tmr_cnt_value)
set tmr counter value More...
uint32_t | tmr_counter_value_get (tmr_type *tmr_x)
get tmr counter value More...
void | tmr_div_value_set (tmr_type *tmr_x, uint32_t tmr_div_value)
set tmr div value More...
uint32_t | tmr_div_value_get (tmr_type *tmr_x)
get tmr div value More...
void | tmr_output_channel_config (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel More...
void | tmr_output_channel_mode_select (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_control_mode_type oc_mode)
select tmr output channel mode More...
void | tmr_period_value_set (tmr_type *tmr_x, uint32_t tmr_pr_value)
set tmr period value More...
uint32_t | tmr_period_value_get (tmr_type *tmr_x)
get tmr period value More...
void | tmr_channel_value_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value More...
uint32_t | tmr_channel_value_get (tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value More...
void | tmr_period_buffer_enable (tmr_type *tmr_x, confirm_state new_state)
set tmr period buffer More...
void | tmr_output_channel_buffer_enable (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel buffer More...
void | tmr_output_channel_immediately_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel immediately More...
void | tmr_output_channel_switch_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel switch More...
void | tmr_one_cycle_mode_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr one cycle mode More...
void | tmr_32_bit_function_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode) More...
void | tmr_overflow_request_source_set (tmr_type *tmr_x, confirm_state new_state)
select tmr the overflow event sources More...
void | tmr_overflow_event_disable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr overflow event generation More...
void | tmr_input_channel_init (tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel More...
void | tmr_channel_enable (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable More...
void | tmr_input_channel_filter_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint16_t filter_value)
set tmr input channel filter More...
void | tmr_pwm_input_config (tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
config tmr pwm input More...
void | tmr_channel1_input_select (tmr_type *tmr_x, tmr_channel1_input_connected_type ch1_connect)
select tmr channel1 input More...
void | tmr_input_channel_divider_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_channel_input_divider_type divider_factor)
set tmr input channel divider More...
void | tmr_primary_mode_select (tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode More...
void | tmr_sub_mode_select (tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode More...
void | tmr_channel_dma_select (tmr_type *tmr_x, tmr_dma_request_source_type cc_dma_select)
select tmr channel dma More...
void | tmr_hall_select (tmr_type *tmr_x, confirm_state new_state)
select tmr hall More...
void | tmr_channel_buffer_enable (tmr_type *tmr_x, confirm_state new_state)
select tmr channel buffer More...
void | tmr_trgout2_enable (tmr_type *tmr_x, confirm_state new_state)
select tmr trgout2 More...
void | tmr_trigger_input_select (tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger More...
void | tmr_sub_sync_mode_set (tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode More...
void | tmr_dma_request_enable (tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request More...
void | tmr_interrupt_enable (tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt More...
flag_status | tmr_flag_get (tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag More...
void | tmr_flag_clear (tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag More...
void | tmr_event_sw_trigger (tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event More...
void | tmr_output_enable (tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable More...
void | tmr_internal_clock_set (tmr_type *tmr_x)
set tmr select internal clock More...
void | tmr_output_channel_polarity_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_polarity_active_type oc_polarity)
set tmr output channel polarity More...
void | tmr_external_clock_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock More...
void | tmr_external_clock_mode1_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode1 More...
void | tmr_external_clock_mode2_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode2 More...
void | tmr_encoder_mode_config (tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type ic1_polarity, tmr_input_polarity_type ic2_polarity)
config tmr encoder mode More...
void | tmr_force_output_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_force_output_type force_output)
set tmr force output More...
void | tmr_dma_control_config (tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, tmr_dma_address_type dma_base_address)
config tmr dma control More...
void | tmr_brkdt_config (tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
config tmr break mode and dead-time More...
void | tmr_iremap_config (tmr_type *tmr_x, tmr_input_remap_type input_remap)
set tmr2/tmr5 input channel remap More...

Detailed Description

Function Documentation

◆ tmr_32_bit_function_enable()

void tmr_32_bit_function_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr 32 bit function(plus mode)

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR2, TMR5
new_state | (TRUE or FALSE)
Return values
none

Definition at line 819 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_base_init()

void tmr_base_init | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_pr,
 |  | uint32_t | tmr_div
 | ) |  |

init tmr base

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_pr | (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
tmr_div | (timer div value:0x0000~0xFFFF)
Return values
none

Definition at line 205 of file at32f435_437_tmr.c.

Referenced by emac_tmr_init(), main(), mclk_tmr1_init(), tmr1_config(), tmr2_config(), and tmr_init().

◆ tmr_brkdt_config()

void tmr_brkdt_config | ( | tmr_type * | tmr_x,
 |  | tmr_brkdt_config_type * | brkdt_struct
 | ) |  |

config tmr break mode and dead-time

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8, TMR20
brkdt_struct
  • to the structure of tmr_brkdt_config_type
Return values
none

Definition at line 1801 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_brkdt_default_para_init()

void tmr_brkdt_default_para_init ( tmr_brkdt_config_type * tmr_brkdt_struct )

init tmr brkdt default para

Parameters
tmr_brkdt_struct
  • to the structure of tmr_brkdt_config_type
Return values
none

Definition at line 183 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_channel1_input_select()

void tmr_channel1_input_select | ( | tmr_type * | tmr_x,
 |  | tmr_channel1_input_connected_type | ch1_connect
 | ) |  |

select tmr channel1 input

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR20
ch1_connect this parameter can be one of the following values:
  • TMR_CHANEL1_CONNECTED_C1IRAW
  • TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR
Return values
none

Definition at line 1150 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_channel_buffer_enable()

void tmr_channel_buffer_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

select tmr channel buffer

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8, TMR20
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1287 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_channel_dma_select()

void tmr_channel_dma_select | ( | tmr_type * | tmr_x,
 |  | tmr_dma_request_source_type | cc_dma_select
 | ) |  |

select tmr channel dma

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR12, TMR20
cc_dma_select this parameter can be one of the following values:
  • TMR_DMA_REQUEST_BY_CHANNEL
  • TMR_DMA_REQUEST_BY_OVERFLOW
Return values
none

Definition at line 1261 of file at32f435_437_tmr.c.

◆ tmr_channel_enable()

void tmr_channel_enable | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | confirm_state | new_state
 | ) |  |

tmr channel enable

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_1C
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_2C
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_3C
  • TMR_SELECT_CHANNEL_4
new_state | (TRUE or FALSE)
Return values
none

Definition at line 940 of file at32f435_437_tmr.c.

Referenced by tmr1_config(), and TMR1_TRG_HALL_TMR11_IRQHandler().

◆ tmr_channel_value_get()

uint32_t tmr_channel_value_get | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel
 | ) |  |

get tmr channel value

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
  • TMR_SELECT_CHANNEL_5
Return values
tmr channel value

Definition at line 593 of file at32f435_437_tmr.c.

Referenced by TMR1_BRK_TMR9_IRQHandler(), TMR2_GLOBAL_IRQHandler(), TMR3_GLOBAL_IRQHandler(), and TMR5_GLOBAL_IRQHandler().

◆ tmr_channel_value_set()

void tmr_channel_value_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | uint32_t | tmr_channel_value
 | ) |  |

set tmr channel value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
  • TMR_SELECT_CHANNEL_5
tmr_channel_value | (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
Return values
none

Definition at line 543 of file at32f435_437_tmr.c.

Referenced by main(), mclk_tmr1_init(), TMR1_BRK_TMR9_IRQHandler(), tmr1_config(), TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ tmr_clock_source_div_set()

void tmr_clock_source_div_set | ( | tmr_type * | tmr_x,
 |  | tmr_clock_division_type | tmr_clock_div
 | ) |  |

set tmr clock source division

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_clock_div this parameter can be one of the following values:
  • TMR_CLOCK_DIV1
  • TMR_CLOCK_DIV2
  • TMR_CLOCK_DIV4
Return values
none

Definition at line 230 of file at32f435_437_tmr.c.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), and tmr2_config().

◆ tmr_cnt_dir_set()

void tmr_cnt_dir_set | ( | tmr_type * | tmr_x,
 |  | tmr_count_mode_type | tmr_cnt_dir
 | ) |  |

set tmr counter count direction

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_cnt_dir this parameter can be one of the following values:
  • TMR_COUNT_UP
  • TMR_COUNT_DOWN
  • TMR_COUNT_TWO_WAY_1
  • TMR_COUNT_TWO_WAY_2
  • TMR_COUNT_TWO_WAY_3
Return values
none

Definition at line 251 of file at32f435_437_tmr.c.

Referenced by emac_tmr_init(), main(), mclk_tmr1_init(), tmr1_config(), tmr2_config(), and tmr_init().

◆ tmr_counter_enable()

void tmr_counter_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr counter

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
new_state | (TRUE or FALSE)
Return values
none

Definition at line 140 of file at32f435_437_tmr.c.

Referenced by emac_tmr_init(), lick_frequency_get(), main(), mclk_tmr1_init(), tmr2_config(), and tmr_init().

◆ tmr_counter_value_get()

uint32_t tmr_counter_value_get ( tmr_type * tmr_x )

get tmr counter value

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
Return values
tmr counter value

Definition at line 299 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_counter_value_set()

void tmr_counter_value_set | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_cnt_value
 | ) |  |

set tmr counter value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_cnt_value | (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
Return values
none

Definition at line 285 of file at32f435_437_tmr.c.

◆ tmr_div_value_get()

uint32_t tmr_div_value_get ( tmr_type * tmr_x )

get tmr div value

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
Return values
tmr div value

Definition at line 328 of file at32f435_437_tmr.c.

◆ tmr_div_value_set()

void tmr_div_value_set | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_div_value
 | ) |  |

set tmr div value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_div_value | (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
Return values
none

Definition at line 314 of file at32f435_437_tmr.c.

Referenced by lick_frequency_get().

◆ tmr_dma_control_config()

void tmr_dma_control_config | ( | tmr_type * | tmr_x,
 |  | tmr_dma_transfer_length_type | dma_length,
 |  | tmr_dma_address_type | dma_base_address
 | ) |  |

config tmr dma control

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR20
dma_length this parameter can be one of the following values:
  • TMR_DMA_TRANSFER_1BYTE
  • TMR_DMA_TRANSFER_2BYTES
  • TMR_DMA_TRANSFER_3BYTES ...
  • TMR_DMA_TRANSFER_17BYTES
  • TMR_DMA_TRANSFER_18BYTES
dma_base_address this parameter can be one of the following values:
  • TMR_CTRL1_ADDRESS
  • TMR_CTRL2_ADDRESS
  • TMR_STCTRL_ADDRESS
  • TMR_IDEN_ADDRESS
  • TMR_ISTS_ADDRESS
  • TMR_SWEVT_ADDRESS
  • TMR_CM1_ADDRESS
  • TMR_CM2_ADDRESS
  • TMR_CCTRL_ADDRESS
  • TMR_CVAL_ADDRESS
  • TMR_DIV_ADDRESS
  • TMR_PR_ADDRESS
  • TMR_RPR_ADDRESS
  • TMR_C1DT_ADDRESS
  • TMR_C2DT_ADDRESS
  • TMR_C3DT_ADDRESS
  • TMR_C4DT_ADDRESS
  • TMR_BRK_ADDRESS
  • TMR_DMACTRL_ADDRESS
Return values
none

Definition at line 1785 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_dma_request_enable()

void tmr_dma_request_enable | ( | tmr_type * | tmr_x,
 |  | tmr_dma_request_type | dma_request,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr dma request

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
dma_request this parameter can be one of the following values:
  • TMR_OVERFLOW_DMA_REQUEST
  • TMR_C1_DMA_REQUEST
  • TMR_C2_DMA_REQUEST
  • TMR_C3_DMA_REQUEST
  • TMR_C4_DMA_REQUEST
  • TMR_HALL_DMA_REQUEST
  • TMR_TRIGGER_DMA_REQUEST
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1358 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_encoder_mode_config()

void tmr_encoder_mode_config | ( | tmr_type * | tmr_x,
 |  | tmr_encoder_mode_type | encoder_mode,
 |  | tmr_input_polarity_type | ic1_polarity,
 |  | tmr_input_polarity_type | ic2_polarity
 | ) |  |

config tmr encoder mode

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR20
encoder_mode this parameter can be one of the following values:
  • TMR_ENCODER_MODE_A
  • TMR_ENCODER_MODE_B
  • TMR_ENCODER_MODE_C
ic1_polarity this parameter can be one of the following values:
  • TMR_INPUT_RISING_EDGE
  • TMR_INPUT_FALLING_EDGE
  • TMR_INPUT_BOTH_EDGE
ic2_polarity this parameter can be one of the following values:
  • TMR_INPUT_RISING_EDGE
  • TMR_INPUT_FALLING_EDGE
  • TMR_INPUT_BOTH_EDGE
Return values
none

Definition at line 1678 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_event_sw_trigger()

void tmr_event_sw_trigger | ( | tmr_type * | tmr_x,
 |  | tmr_event_trigger_type | tmr_event
 | ) |  |

generate tmr event

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_event this parameter can be one of the following values:
  • TMR_OVERFLOW_SWTRIG
  • TMR_C1_SWTRIG
  • TMR_C2_SWTRIG
  • TMR_C3_SWTRIG
  • TMR_C4_SWTRIG
  • TMR_HALL_SWTRIG
  • TMR_TRIGGER_SWTRIG
  • TMR_BRK_SWTRIG
Return values
none

Definition at line 1486 of file at32f435_437_tmr.c.

Referenced by lick_frequency_get(), and SysTick_Handler().

◆ tmr_external_clock_config()

void tmr_external_clock_config | ( | tmr_type * | tmr_x,
 |  | tmr_external_signal_divider_type | es_divide,
 |  | tmr_external_signal_polarity_type | es_polarity,
 |  | uint16_t | es_filter
 | ) |  |

config tmr external clock

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR20
es_divide this parameter can be one of the following values:
  • TMR_ES_FREQUENCY_DIV_1
  • TMR_ES_FREQUENCY_DIV_2
  • TMR_ES_FREQUENCY_DIV_4
  • TMR_ES_FREQUENCY_DIV_8
es_polarity this parameter can be one of the following values:
  • TMR_ES_POLARITY_NON_INVERTED
  • TMR_ES_POLARITY_INVERTED
es_filter | (0x0~0xf)
Return values
none

Definition at line 1597 of file at32f435_437_tmr.c.

Referenced by tmr_external_clock_mode1_config(), and tmr_external_clock_mode2_config().

◆ tmr_external_clock_mode1_config()

void tmr_external_clock_mode1_config | ( | tmr_type * | tmr_x,
 |  | tmr_external_signal_divider_type | es_divide,
 |  | tmr_external_signal_polarity_type | es_polarity,
 |  | uint16_t | es_filter
 | ) |  |

config tmr external clock mode1

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR12, TMR20
es_divide this parameter can be one of the following values:
  • TMR_ES_FREQUENCY_DIV_1
  • TMR_ES_FREQUENCY_DIV_2
  • TMR_ES_FREQUENCY_DIV_4
  • TMR_ES_FREQUENCY_DIV_8
es_polarity this parameter can be one of the following values:
  • TMR_ES_POLARITY_NON_INVERTED
  • TMR_ES_POLARITY_INVERTED
es_filter | (0x0~0xf)
Return values
none

Definition at line 1623 of file at32f435_437_tmr.c.

◆ tmr_external_clock_mode2_config()

void tmr_external_clock_mode2_config | ( | tmr_type * | tmr_x,
 |  | tmr_external_signal_divider_type | es_divide,
 |  | tmr_external_signal_polarity_type | es_polarity,
 |  | uint16_t | es_filter
 | ) |  |

config tmr external clock mode2

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR20
es_divide this parameter can be one of the following values:
  • TMR_ES_FREQUENCY_DIV_1
  • TMR_ES_FREQUENCY_DIV_2
  • TMR_ES_FREQUENCY_DIV_4
  • TMR_ES_FREQUENCY_DIV_8
es_polarity this parameter can be one of the following values:
  • TMR_ES_POLARITY_NON_INVERTED
  • TMR_ES_POLARITY_INVERTED
es_filter | (0x0~0xf)
Return values
none

Definition at line 1649 of file at32f435_437_tmr.c.

◆ tmr_flag_clear()

void tmr_flag_clear | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_flag
 | ) |  |

clear tmr flag

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_flag this parameter can be any combination of the following values:
  • TMR_OVF_FLAG
  • TMR_C1_FLAG
  • TMR_C2_FLAG
  • TMR_C3_FLAG
  • TMR_C4_FLAG
  • TMR_C5_FLAG
  • TMR_HALL_FLAG
  • TMR_TRIGGER_FLAG
  • TMR_BRK_FLAG
  • TMR_C1_RECAPTURE_FLAG
  • TMR_C2_RECAPTURE_FLAG
  • TMR_C3_RECAPTURE_FLAG
  • TMR_C4_RECAPTURE_FLAG
Return values
none

Definition at line 1463 of file at32f435_437_tmr.c.

Referenced by TMR1_BRK_TMR9_IRQHandler(), TMR1_OVF_TMR10_IRQHandler(), TMR1_TRG_HALL_TMR11_IRQHandler(), TMR2_GLOBAL_IRQHandler(), TMR3_GLOBAL_IRQHandler(), TMR5_GLOBAL_IRQHandler(), and TMR6_DAC_GLOBAL_IRQHandler().

◆ tmr_flag_get()

flag_status tmr_flag_get | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_flag
 | ) |  |

get tmr flag

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_flag this parameter can be one of the following values:
  • TMR_OVF_FLAG
  • TMR_C1_FLAG
  • TMR_C2_FLAG
  • TMR_C3_FLAG
  • TMR_C4_FLAG
  • TMR_C5_FLAG
  • TMR_HALL_FLAG
  • TMR_TRIGGER_FLAG
  • TMR_BRK_FLAG
  • TMR_C1_RECAPTURE_FLAG
  • TMR_C2_RECAPTURE_FLAG
  • TMR_C3_RECAPTURE_FLAG
  • TMR_C4_RECAPTURE_FLAG
Return values
state of tmr flag

Definition at line 1424 of file at32f435_437_tmr.c.

Referenced by TMR1_BRK_TMR9_IRQHandler(), TMR1_OVF_TMR10_IRQHandler(), TMR2_GLOBAL_IRQHandler(), TMR3_GLOBAL_IRQHandler(), TMR5_GLOBAL_IRQHandler(), and TMR6_DAC_GLOBAL_IRQHandler().

◆ tmr_force_output_set()

void tmr_force_output_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_force_output_type | force_output
 | ) |  |

set tmr force output

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
  • TMR_SELECT_CHANNEL_5
force_output this parameter can be one of the following values:
  • TMR_FORCE_OUTPUT_HIGH
  • TMR_FORCE_OUTPUT_LOW
Return values
none

Definition at line 1715 of file at32f435_437_tmr.c.

◆ tmr_hall_select()

void tmr_hall_select | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

select tmr hall

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8, TMR20
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1274 of file at32f435_437_tmr.c.

◆ tmr_input_channel_divider_set()

void tmr_input_channel_divider_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_channel_input_divider_type | divider_factor
 | ) |  |

set tmr input channel divider

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
divider_factor this parameter can be one of the following values:
  • TMR_CHANNEL_INPUT_DIV_1
  • TMR_CHANNEL_INPUT_DIV_2
  • TMR_CHANNEL_INPUT_DIV_4
  • TMR_CHANNEL_INPUT_DIV_8
Return values
none

Definition at line 1175 of file at32f435_437_tmr.c.

Referenced by lick_frequency_get().

◆ tmr_input_channel_filter_set()

void tmr_input_channel_filter_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | uint16_t | filter_value
 | ) |  |

set tmr input channel filter

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
filter_value | (0x0~0xf)
Return values
none

Definition at line 996 of file at32f435_437_tmr.c.

◆ tmr_input_channel_init()

void tmr_input_channel_init | ( | tmr_type * | tmr_x,
 |  | tmr_input_config_type * | input_struct,
 |  | tmr_channel_input_divider_type | divider_factor
 | ) |  |

init tmr input channel

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
input_struct
  • to the structure of tmr_input_config_type
divider_factor this parameter can be one of the following values:
  • TMR_CHANNEL_INPUT_DIV_1
  • TMR_CHANNEL_INPUT_DIV_2
  • TMR_CHANNEL_INPUT_DIV_4
  • TMR_CHANNEL_INPUT_DIV_8
Return values
none

Definition at line 872 of file at32f435_437_tmr.c.

Referenced by lick_frequency_get(), and main().

◆ tmr_input_default_para_init()

void tmr_input_default_para_init ( tmr_input_config_type * tmr_input_struct )

init tmr input default para

Parameters
tmr_input_struct
  • to the structure of tmr_input_config_type
Return values
none

Definition at line 169 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_internal_clock_set()

void tmr_internal_clock_set ( tmr_type * tmr_x )

set tmr select internal clock

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR12, TMR20
Return values
none

Definition at line 1511 of file at32f435_437_tmr.c.

◆ tmr_interrupt_enable()

void tmr_interrupt_enable | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_interrupt,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr interrupt

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_interrupt this parameter can be one of the following values:
  • TMR_OVF_INT
  • TMR_C1_INT
  • TMR_C2_INT
  • TMR_C3_INT
  • TMR_C4_INT
  • TMR_HALL_INT
  • TMR_TRIGGER_INT
  • TMR_BRK_INT
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1389 of file at32f435_437_tmr.c.

Referenced by emac_tmr_init(), lick_frequency_get(), main(), tmr1_config(), tmr2_config(), and tmr_init().

◆ tmr_iremap_config()

void tmr_iremap_config | ( | tmr_type * | tmr_x,
 |  | tmr_input_remap_type | input_remap
 | ) |  |

set tmr2/tmr5 input channel remap

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR2, TMR5
input_remap
  • TMR2_TMR8TRGOUT_TMR5_GPIO
  • TMR2_PTP_TMR5_LICK
  • TMR2_OTG1FS_TMR5_LEXT
  • TMR2_OTG2FS_TMR5_ERTC
Return values
none

Definition at line 1824 of file at32f435_437_tmr.c.

Referenced by lick_frequency_get().

◆ tmr_one_cycle_mode_enable()

void tmr_one_cycle_mode_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr one cycle mode

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR12, TMR20
new_state | (TRUE or FALSE)
Return values
none

Definition at line 805 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_output_channel_buffer_enable()

void tmr_output_channel_buffer_enable | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | confirm_state | new_state
 | ) |  |

set tmr output channel buffer

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
  • TMR_SELECT_CHANNEL_5
new_state | (TRUE or FALSE)
Return values
none

Definition at line 660 of file at32f435_437_tmr.c.

Referenced by main(), and mclk_tmr1_init().

◆ tmr_output_channel_config()

void tmr_output_channel_config | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_output_config_type * | tmr_output_struct
 | ) |  |

config tmr output channel

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
  • TMR_SELECT_CHANNEL_5
tmr_output_struct
  • to the structure of tmr_output_config_type
Return values
none

Definition at line 350 of file at32f435_437_tmr.c.

Referenced by main(), mclk_tmr1_init(), and tmr1_config().

◆ tmr_output_channel_immediately_set()

void tmr_output_channel_immediately_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | confirm_state | new_state
 | ) |  |

set tmr output channel immediately

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
  • TMR_SELECT_CHANNEL_5
new_state | (TRUE or FALSE)
Return values
none

Definition at line 711 of file at32f435_437_tmr.c.

◆ tmr_output_channel_mode_select()

void tmr_output_channel_mode_select | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_output_control_mode_type | oc_mode
 | ) |  |

select tmr output channel mode

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
  • TMR_SELECT_CHANNEL_5
oc_mode this parameter can be one of the following values:
  • TMR_OUTPUT_CONTROL_OFF
  • TMR_OUTPUT_CONTROL_HIGH
  • TMR_OUTPUT_CONTROL_LOW
  • TMR_OUTPUT_CONTROL_SWITCH
  • TMR_OUTPUT_CONTROL_FORCE_HIGH
  • TMR_OUTPUT_CONTROL_FORCE_LOW
  • TMR_OUTPUT_CONTROL_PWM_MODE_A
  • TMR_OUTPUT_CONTROL_PWM_MODE_B
Return values
none

Definition at line 461 of file at32f435_437_tmr.c.

Referenced by TMR1_TRG_HALL_TMR11_IRQHandler().

◆ tmr_output_channel_polarity_set()

void tmr_output_channel_polarity_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_polarity_active_type | oc_polarity
 | ) |  |

set tmr output channel polarity

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
  • TMR_SELECT_CHANNEL_1C
  • TMR_SELECT_CHANNEL_2C
  • TMR_SELECT_CHANNEL_3C
oc_polarity this parameter can be one of the following values:
  • TMR_POLARITY_ACTIVE_HIGH
  • TMR_POLARITY_ACTIVE_LOW
Return values
none

Definition at line 1537 of file at32f435_437_tmr.c.

◆ tmr_output_channel_switch_set()

void tmr_output_channel_switch_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | confirm_state | new_state
 | ) |  |

set tmr output channel switch

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
  • TMR_SELECT_CHANNEL_5
new_state | (TRUE or FALSE)
Return values
none

Definition at line 762 of file at32f435_437_tmr.c.

◆ tmr_output_default_para_init()

void tmr_output_default_para_init ( tmr_output_config_type * tmr_output_struct )

init tmr output default para

Parameters
tmr_output_struct
  • to the structure of tmr_output_config_type
Return values
none

Definition at line 152 of file at32f435_437_tmr.c.

Referenced by main(), mclk_tmr1_init(), and tmr1_config().

◆ tmr_output_enable()

void tmr_output_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

tmr output enable(oen),this function is important for advtm output enable

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8, TMR20
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1499 of file at32f435_437_tmr.c.

Referenced by main(), mclk_tmr1_init(), and tmr1_config().

◆ tmr_overflow_event_disable()

void tmr_overflow_event_disable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr overflow event generation

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
new_state | (TRUE or FALSE)
Return values
none

Definition at line 851 of file at32f435_437_tmr.c.

◆ tmr_overflow_request_source_set()

void tmr_overflow_request_source_set | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

select tmr the overflow event sources

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
new_state | (TRUE or FALSE)
Return values
none

Definition at line 837 of file at32f435_437_tmr.c.

◆ tmr_period_buffer_enable()

void tmr_period_buffer_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

set tmr period buffer

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
new_state | (TRUE or FALSE)
Return values
none

Definition at line 638 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_period_value_get()

uint32_t tmr_period_value_get ( tmr_type * tmr_x )

get tmr period value

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
Return values
timer period register value of counter (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)

Definition at line 521 of file at32f435_437_tmr.c.

◆ tmr_period_value_set()

void tmr_period_value_set | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_pr_value
 | ) |  |

set tmr period value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_pr_value | timer period register value of counter (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
Return values
none

Definition at line 505 of file at32f435_437_tmr.c.

◆ tmr_primary_mode_select()

void tmr_primary_mode_select | ( | tmr_type * | tmr_x,
 |  | tmr_primary_select_type | primary_mode
 | ) |  |

select tmr primary mode

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR20
primary_mode this parameter can be one of the following values:
  • TMR_PRIMARY_SEL_RESET
  • TMR_PRIMARY_SEL_ENABLE
  • TMR_PRIMARY_SEL_OVERFLOW
  • TMR_PRIMARY_SEL_COMPARE
  • TMR_PRIMARY_SEL_C1ORAW
  • TMR_PRIMARY_SEL_C2ORAW
  • TMR_PRIMARY_SEL_C3ORAW
  • TMR_PRIMARY_SEL_C4ORAW
Return values
none

Definition at line 1222 of file at32f435_437_tmr.c.

Referenced by main(), and tmr1_config().

◆ tmr_pwm_input_config()

void tmr_pwm_input_config | ( | tmr_type * | tmr_x,
 |  | tmr_input_config_type * | input_struct,
 |  | tmr_channel_input_divider_type | divider_factor
 | ) |  |

config tmr pwm input

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
input_struct
  • to the structure of tmr_input_config_type
divider_factor this parameter can be one of the following values:
  • TMR_CHANNEL_INPUT_DIV_1
  • TMR_CHANNEL_INPUT_DIV_2
  • TMR_CHANNEL_INPUT_DIV_4
  • TMR_CHANNEL_INPUT_DIV_8
Return values
none

Definition at line 1042 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_repetition_counter_set()

void tmr_repetition_counter_set | ( | tmr_type * | tmr_x,
 |  | uint8_t | tmr_rpr_value
 | ) |  |

set the repetition counter register(rpr) value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8, TMR20
tmr_rpr_value | (0x0000~0xFFFF)
Return values
none

Definition at line 265 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_reset()

void tmr_reset ( tmr_type * tmr_x )

tmr reset by crm reset register

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
Return values
none

Definition at line 52 of file at32f435_437_tmr.c.

Referenced by lick_frequency_get().

◆ tmr_sub_mode_select()

void tmr_sub_mode_select | ( | tmr_type * | tmr_x,
 |  | tmr_sub_mode_select_type | sub_mode
 | ) |  |

select tmr subordinate mode

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR12, TMR20
sub_mode this parameter can be one of the following values:
  • TMR_SUB_MODE_DIABLE
  • TMR_SUB_ENCODER_MODE_A
  • TMR_SUB_ENCODER_MODE_B
  • TMR_SUB_ENCODER_MODE_C
  • TMR_SUB_RESET_MODE
  • TMR_SUB_HANG_MODE
  • TMR_SUB_TRIGGER_MODE
  • TMR_SUB_EXTERNAL_CLOCK_MODE_A
Return values
none

Definition at line 1245 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_sub_sync_mode_set()

void tmr_sub_sync_mode_set | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

set tmr subordinate synchronization mode

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR12, TMR20
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1335 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_trgout2_enable()

void tmr_trgout2_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

select tmr trgout2

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8, TMR20
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1300 of file at32f435_437_tmr.c.

Referenced by tmr1_config().

◆ tmr_trigger_input_select()

void tmr_trigger_input_select | ( | tmr_type * | tmr_x,
 |  | sub_tmr_input_sel_type | trigger_select
 | ) |  |

select tmr sub-trigger

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR12, TMR20
trigger_select this parameter can be one of the following values:
  • TMR_SUB_INPUT_SEL_IS0
  • TMR_SUB_INPUT_SEL_IS1
  • TMR_SUB_INPUT_SEL_IS2
  • TMR_SUB_INPUT_SEL_IS3
  • TMR_SUB_INPUT_SEL_C1INC
  • TMR_SUB_INPUT_SEL_C1DF1
  • TMR_SUB_INPUT_SEL_C2DF2
  • TMR_SUB_INPUT_SEL_EXTIN
Return values
none

Definition at line 1322 of file at32f435_437_tmr.c.

Referenced by main().


AT32F435/437 Firmwary Library: TMR_private_functions

Functions
TMR_private_functions
AT32F435_437_periph_driver » TMR

Functions

void | tmr_reset (tmr_type *tmr_x)
tmr reset by crm reset register More...
void | tmr_counter_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter More...
void | tmr_output_default_para_init (tmr_output_config_type *tmr_output_struct)
init tmr output default para More...
void | tmr_input_default_para_init (tmr_input_config_type *tmr_input_struct)
init tmr input default para More...
void | tmr_brkdt_default_para_init (tmr_brkdt_config_type *tmr_brkdt_struct)
init tmr brkdt default para More...
void | tmr_base_init (tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base More...
void | tmr_clock_source_div_set (tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division More...
void | tmr_cnt_dir_set (tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction More...
void | tmr_repetition_counter_set (tmr_type *tmr_x, uint8_t tmr_rpr_value)
set the repetition counter register(rpr) value More...
void | tmr_counter_value_set (tmr_type *tmr_x, uint32_t tmr_cnt_value)
set tmr counter value More...
uint32_t | tmr_counter_value_get (tmr_type *tmr_x)
get tmr counter value More...
void | tmr_div_value_set (tmr_type *tmr_x, uint32_t tmr_div_value)
set tmr div value More...
uint32_t | tmr_div_value_get (tmr_type *tmr_x)
get tmr div value More...
void | tmr_output_channel_config (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel More...
void | tmr_output_channel_mode_select (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_control_mode_type oc_mode)
select tmr output channel mode More...
void | tmr_period_value_set (tmr_type *tmr_x, uint32_t tmr_pr_value)
set tmr period value More...
uint32_t | tmr_period_value_get (tmr_type *tmr_x)
get tmr period value More...
void | tmr_channel_value_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value More...
uint32_t | tmr_channel_value_get (tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value More...
void | tmr_period_buffer_enable (tmr_type *tmr_x, confirm_state new_state)
set tmr period buffer More...
void | tmr_output_channel_buffer_enable (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel buffer More...
void | tmr_output_channel_immediately_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel immediately More...
void | tmr_output_channel_switch_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel switch More...
void | tmr_one_cycle_mode_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr one cycle mode More...
void | tmr_32_bit_function_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode) More...
void | tmr_overflow_request_source_set (tmr_type *tmr_x, confirm_state new_state)
select tmr the overflow event sources More...
void | tmr_overflow_event_disable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr overflow event generation More...
void | tmr_input_channel_init (tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel More...
void | tmr_channel_enable (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable More...
void | tmr_input_channel_filter_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint16_t filter_value)
set tmr input channel filter More...
void | tmr_pwm_input_config (tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
config tmr pwm input More...
void | tmr_channel1_input_select (tmr_type *tmr_x, tmr_channel1_input_connected_type ch1_connect)
select tmr channel1 input More...
void | tmr_input_channel_divider_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_channel_input_divider_type divider_factor)
set tmr input channel divider More...
void | tmr_primary_mode_select (tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode More...
void | tmr_sub_mode_select (tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode More...
void | tmr_channel_dma_select (tmr_type *tmr_x, tmr_dma_request_source_type cc_dma_select)
select tmr channel dma More...
void | tmr_hall_select (tmr_type *tmr_x, confirm_state new_state)
select tmr hall More...
void | tmr_channel_buffer_enable (tmr_type *tmr_x, confirm_state new_state)
select tmr channel buffer More...
void | tmr_trgout2_enable (tmr_type *tmr_x, confirm_state new_state)
select tmr trgout2 More...
void | tmr_trigger_input_select (tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger More...
void | tmr_sub_sync_mode_set (tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode More...
void | tmr_dma_request_enable (tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request More...
void | tmr_interrupt_enable (tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt More...
flag_status | tmr_flag_get (tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag More...
void | tmr_flag_clear (tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag More...
void | tmr_event_sw_trigger (tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event More...
void | tmr_output_enable (tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable More...
void | tmr_internal_clock_set (tmr_type *tmr_x)
set tmr select internal clock More...
void | tmr_output_channel_polarity_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_polarity_active_type oc_polarity)
set tmr output channel polarity More...
void | tmr_external_clock_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock More...
void | tmr_external_clock_mode1_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode1 More...
void | tmr_external_clock_mode2_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode2 More...
void | tmr_encoder_mode_config (tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type ic1_polarity, tmr_input_polarity_type ic2_polarity)
config tmr encoder mode More...
void | tmr_force_output_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_force_output_type force_output)
set tmr force output More...
void | tmr_dma_control_config (tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, tmr_dma_address_type dma_base_address)
config tmr dma control More...
void | tmr_brkdt_config (tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
config tmr break mode and dead-time More...
void | tmr_iremap_config (tmr_type *tmr_x, tmr_input_remap_type input_remap)
set tmr2/tmr5 input channel remap More...

Detailed Description

Function Documentation

◆ tmr_32_bit_function_enable()

void tmr_32_bit_function_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr 32 bit function(plus mode)

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR2, TMR5
new_state | (TRUE or FALSE)
Return values
none

Definition at line 819 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_base_init()

void tmr_base_init | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_pr,
 |  | uint32_t | tmr_div
 | ) |  |

init tmr base

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_pr | (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
tmr_div | (timer div value:0x0000~0xFFFF)
Return values
none

Definition at line 205 of file at32f435_437_tmr.c.

Referenced by emac_tmr_init(), main(), mclk_tmr1_init(), tmr1_config(), tmr2_config(), and tmr_init().

◆ tmr_brkdt_config()

void tmr_brkdt_config | ( | tmr_type * | tmr_x,
 |  | tmr_brkdt_config_type * | brkdt_struct
 | ) |  |

config tmr break mode and dead-time

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8, TMR20
brkdt_struct
  • to the structure of tmr_brkdt_config_type
Return values
none

Definition at line 1801 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_brkdt_default_para_init()

void tmr_brkdt_default_para_init ( tmr_brkdt_config_type * tmr_brkdt_struct )

init tmr brkdt default para

Parameters
tmr_brkdt_struct
  • to the structure of tmr_brkdt_config_type
Return values
none

Definition at line 183 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_channel1_input_select()

void tmr_channel1_input_select | ( | tmr_type * | tmr_x,
 |  | tmr_channel1_input_connected_type | ch1_connect
 | ) |  |

select tmr channel1 input

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR20
ch1_connect this parameter can be one of the following values:
  • TMR_CHANEL1_CONNECTED_C1IRAW
  • TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR
Return values
none

Definition at line 1150 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_channel_buffer_enable()

void tmr_channel_buffer_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

select tmr channel buffer

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8, TMR20
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1287 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_channel_dma_select()

void tmr_channel_dma_select | ( | tmr_type * | tmr_x,
 |  | tmr_dma_request_source_type | cc_dma_select
 | ) |  |

select tmr channel dma

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR12, TMR20
cc_dma_select this parameter can be one of the following values:
  • TMR_DMA_REQUEST_BY_CHANNEL
  • TMR_DMA_REQUEST_BY_OVERFLOW
Return values
none

Definition at line 1261 of file at32f435_437_tmr.c.

◆ tmr_channel_enable()

void tmr_channel_enable | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | confirm_state | new_state
 | ) |  |

tmr channel enable

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_1C
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_2C
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_3C
  • TMR_SELECT_CHANNEL_4
new_state | (TRUE or FALSE)
Return values
none

Definition at line 940 of file at32f435_437_tmr.c.

Referenced by tmr1_config(), and TMR1_TRG_HALL_TMR11_IRQHandler().

◆ tmr_channel_value_get()

uint32_t tmr_channel_value_get | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel
 | ) |  |

get tmr channel value

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
  • TMR_SELECT_CHANNEL_5
Return values
tmr channel value

Definition at line 593 of file at32f435_437_tmr.c.

Referenced by TMR1_BRK_TMR9_IRQHandler(), TMR2_GLOBAL_IRQHandler(), TMR3_GLOBAL_IRQHandler(), and TMR5_GLOBAL_IRQHandler().

◆ tmr_channel_value_set()

void tmr_channel_value_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | uint32_t | tmr_channel_value
 | ) |  |

set tmr channel value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
  • TMR_SELECT_CHANNEL_5
tmr_channel_value | (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
Return values
none

Definition at line 543 of file at32f435_437_tmr.c.

Referenced by main(), mclk_tmr1_init(), TMR1_BRK_TMR9_IRQHandler(), tmr1_config(), TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ tmr_clock_source_div_set()

void tmr_clock_source_div_set | ( | tmr_type * | tmr_x,
 |  | tmr_clock_division_type | tmr_clock_div
 | ) |  |

set tmr clock source division

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_clock_div this parameter can be one of the following values:
  • TMR_CLOCK_DIV1
  • TMR_CLOCK_DIV2
  • TMR_CLOCK_DIV4
Return values
none

Definition at line 230 of file at32f435_437_tmr.c.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), and tmr2_config().

◆ tmr_cnt_dir_set()

void tmr_cnt_dir_set | ( | tmr_type * | tmr_x,
 |  | tmr_count_mode_type | tmr_cnt_dir
 | ) |  |

set tmr counter count direction

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_cnt_dir this parameter can be one of the following values:
  • TMR_COUNT_UP
  • TMR_COUNT_DOWN
  • TMR_COUNT_TWO_WAY_1
  • TMR_COUNT_TWO_WAY_2
  • TMR_COUNT_TWO_WAY_3
Return values
none

Definition at line 251 of file at32f435_437_tmr.c.

Referenced by emac_tmr_init(), main(), mclk_tmr1_init(), tmr1_config(), tmr2_config(), and tmr_init().

◆ tmr_counter_enable()

void tmr_counter_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr counter

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
new_state | (TRUE or FALSE)
Return values
none

Definition at line 140 of file at32f435_437_tmr.c.

Referenced by emac_tmr_init(), lick_frequency_get(), main(), mclk_tmr1_init(), tmr2_config(), and tmr_init().

◆ tmr_counter_value_get()

uint32_t tmr_counter_value_get ( tmr_type * tmr_x )

get tmr counter value

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
Return values
tmr counter value

Definition at line 299 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_counter_value_set()

void tmr_counter_value_set | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_cnt_value
 | ) |  |

set tmr counter value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_cnt_value | (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
Return values
none

Definition at line 285 of file at32f435_437_tmr.c.

◆ tmr_div_value_get()

uint32_t tmr_div_value_get ( tmr_type * tmr_x )

get tmr div value

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
Return values
tmr div value

Definition at line 328 of file at32f435_437_tmr.c.

◆ tmr_div_value_set()

void tmr_div_value_set | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_div_value
 | ) |  |

set tmr div value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_div_value | (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
Return values
none

Definition at line 314 of file at32f435_437_tmr.c.

Referenced by lick_frequency_get().

◆ tmr_dma_control_config()

void tmr_dma_control_config | ( | tmr_type * | tmr_x,
 |  | tmr_dma_transfer_length_type | dma_length,
 |  | tmr_dma_address_type | dma_base_address
 | ) |  |

config tmr dma control

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR20
dma_length this parameter can be one of the following values:
  • TMR_DMA_TRANSFER_1BYTE
  • TMR_DMA_TRANSFER_2BYTES
  • TMR_DMA_TRANSFER_3BYTES ...
  • TMR_DMA_TRANSFER_17BYTES
  • TMR_DMA_TRANSFER_18BYTES
dma_base_address this parameter can be one of the following values:
  • TMR_CTRL1_ADDRESS
  • TMR_CTRL2_ADDRESS
  • TMR_STCTRL_ADDRESS
  • TMR_IDEN_ADDRESS
  • TMR_ISTS_ADDRESS
  • TMR_SWEVT_ADDRESS
  • TMR_CM1_ADDRESS
  • TMR_CM2_ADDRESS
  • TMR_CCTRL_ADDRESS
  • TMR_CVAL_ADDRESS
  • TMR_DIV_ADDRESS
  • TMR_PR_ADDRESS
  • TMR_RPR_ADDRESS
  • TMR_C1DT_ADDRESS
  • TMR_C2DT_ADDRESS
  • TMR_C3DT_ADDRESS
  • TMR_C4DT_ADDRESS
  • TMR_BRK_ADDRESS
  • TMR_DMACTRL_ADDRESS
Return values
none

Definition at line 1785 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_dma_request_enable()

void tmr_dma_request_enable | ( | tmr_type * | tmr_x,
 |  | tmr_dma_request_type | dma_request,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr dma request

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
dma_request this parameter can be one of the following values:
  • TMR_OVERFLOW_DMA_REQUEST
  • TMR_C1_DMA_REQUEST
  • TMR_C2_DMA_REQUEST
  • TMR_C3_DMA_REQUEST
  • TMR_C4_DMA_REQUEST
  • TMR_HALL_DMA_REQUEST
  • TMR_TRIGGER_DMA_REQUEST
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1358 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_encoder_mode_config()

void tmr_encoder_mode_config | ( | tmr_type * | tmr_x,
 |  | tmr_encoder_mode_type | encoder_mode,
 |  | tmr_input_polarity_type | ic1_polarity,
 |  | tmr_input_polarity_type | ic2_polarity
 | ) |  |

config tmr encoder mode

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR20
encoder_mode this parameter can be one of the following values:
  • TMR_ENCODER_MODE_A
  • TMR_ENCODER_MODE_B
  • TMR_ENCODER_MODE_C
ic1_polarity this parameter can be one of the following values:
  • TMR_INPUT_RISING_EDGE
  • TMR_INPUT_FALLING_EDGE
  • TMR_INPUT_BOTH_EDGE
ic2_polarity this parameter can be one of the following values:
  • TMR_INPUT_RISING_EDGE
  • TMR_INPUT_FALLING_EDGE
  • TMR_INPUT_BOTH_EDGE
Return values
none

Definition at line 1678 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_event_sw_trigger()

void tmr_event_sw_trigger | ( | tmr_type * | tmr_x,
 |  | tmr_event_trigger_type | tmr_event
 | ) |  |

generate tmr event

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_event this parameter can be one of the following values:
  • TMR_OVERFLOW_SWTRIG
  • TMR_C1_SWTRIG
  • TMR_C2_SWTRIG
  • TMR_C3_SWTRIG
  • TMR_C4_SWTRIG
  • TMR_HALL_SWTRIG
  • TMR_TRIGGER_SWTRIG
  • TMR_BRK_SWTRIG
Return values
none

Definition at line 1486 of file at32f435_437_tmr.c.

Referenced by lick_frequency_get(), and SysTick_Handler().

◆ tmr_external_clock_config()

void tmr_external_clock_config | ( | tmr_type * | tmr_x,
 |  | tmr_external_signal_divider_type | es_divide,
 |  | tmr_external_signal_polarity_type | es_polarity,
 |  | uint16_t | es_filter
 | ) |  |

config tmr external clock

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR20
es_divide this parameter can be one of the following values:
  • TMR_ES_FREQUENCY_DIV_1
  • TMR_ES_FREQUENCY_DIV_2
  • TMR_ES_FREQUENCY_DIV_4
  • TMR_ES_FREQUENCY_DIV_8
es_polarity this parameter can be one of the following values:
  • TMR_ES_POLARITY_NON_INVERTED
  • TMR_ES_POLARITY_INVERTED
es_filter | (0x0~0xf)
Return values
none

Definition at line 1597 of file at32f435_437_tmr.c.

Referenced by tmr_external_clock_mode1_config(), and tmr_external_clock_mode2_config().

◆ tmr_external_clock_mode1_config()

void tmr_external_clock_mode1_config | ( | tmr_type * | tmr_x,
 |  | tmr_external_signal_divider_type | es_divide,
 |  | tmr_external_signal_polarity_type | es_polarity,
 |  | uint16_t | es_filter
 | ) |  |

config tmr external clock mode1

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR12, TMR20
es_divide this parameter can be one of the following values:
  • TMR_ES_FREQUENCY_DIV_1
  • TMR_ES_FREQUENCY_DIV_2
  • TMR_ES_FREQUENCY_DIV_4
  • TMR_ES_FREQUENCY_DIV_8
es_polarity this parameter can be one of the following values:
  • TMR_ES_POLARITY_NON_INVERTED
  • TMR_ES_POLARITY_INVERTED
es_filter | (0x0~0xf)
Return values
none

Definition at line 1623 of file at32f435_437_tmr.c.

◆ tmr_external_clock_mode2_config()

void tmr_external_clock_mode2_config | ( | tmr_type * | tmr_x,
 |  | tmr_external_signal_divider_type | es_divide,
 |  | tmr_external_signal_polarity_type | es_polarity,
 |  | uint16_t | es_filter
 | ) |  |

config tmr external clock mode2

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR20
es_divide this parameter can be one of the following values:
  • TMR_ES_FREQUENCY_DIV_1
  • TMR_ES_FREQUENCY_DIV_2
  • TMR_ES_FREQUENCY_DIV_4
  • TMR_ES_FREQUENCY_DIV_8
es_polarity this parameter can be one of the following values:
  • TMR_ES_POLARITY_NON_INVERTED
  • TMR_ES_POLARITY_INVERTED
es_filter | (0x0~0xf)
Return values
none

Definition at line 1649 of file at32f435_437_tmr.c.

◆ tmr_flag_clear()

void tmr_flag_clear | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_flag
 | ) |  |

clear tmr flag

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_flag this parameter can be any combination of the following values:
  • TMR_OVF_FLAG
  • TMR_C1_FLAG
  • TMR_C2_FLAG
  • TMR_C3_FLAG
  • TMR_C4_FLAG
  • TMR_C5_FLAG
  • TMR_HALL_FLAG
  • TMR_TRIGGER_FLAG
  • TMR_BRK_FLAG
  • TMR_C1_RECAPTURE_FLAG
  • TMR_C2_RECAPTURE_FLAG
  • TMR_C3_RECAPTURE_FLAG
  • TMR_C4_RECAPTURE_FLAG
Return values
none

Definition at line 1463 of file at32f435_437_tmr.c.

Referenced by TMR1_BRK_TMR9_IRQHandler(), TMR1_OVF_TMR10_IRQHandler(), TMR1_TRG_HALL_TMR11_IRQHandler(), TMR2_GLOBAL_IRQHandler(), TMR3_GLOBAL_IRQHandler(), TMR5_GLOBAL_IRQHandler(), and TMR6_DAC_GLOBAL_IRQHandler().

◆ tmr_flag_get()

flag_status tmr_flag_get | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_flag
 | ) |  |

get tmr flag

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_flag this parameter can be one of the following values:
  • TMR_OVF_FLAG
  • TMR_C1_FLAG
  • TMR_C2_FLAG
  • TMR_C3_FLAG
  • TMR_C4_FLAG
  • TMR_C5_FLAG
  • TMR_HALL_FLAG
  • TMR_TRIGGER_FLAG
  • TMR_BRK_FLAG
  • TMR_C1_RECAPTURE_FLAG
  • TMR_C2_RECAPTURE_FLAG
  • TMR_C3_RECAPTURE_FLAG
  • TMR_C4_RECAPTURE_FLAG
Return values
state of tmr flag

Definition at line 1424 of file at32f435_437_tmr.c.

Referenced by TMR1_BRK_TMR9_IRQHandler(), TMR1_OVF_TMR10_IRQHandler(), TMR2_GLOBAL_IRQHandler(), TMR3_GLOBAL_IRQHandler(), TMR5_GLOBAL_IRQHandler(), and TMR6_DAC_GLOBAL_IRQHandler().

◆ tmr_force_output_set()

void tmr_force_output_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_force_output_type | force_output
 | ) |  |

set tmr force output

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
  • TMR_SELECT_CHANNEL_5
force_output this parameter can be one of the following values:
  • TMR_FORCE_OUTPUT_HIGH
  • TMR_FORCE_OUTPUT_LOW
Return values
none

Definition at line 1715 of file at32f435_437_tmr.c.

◆ tmr_hall_select()

void tmr_hall_select | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

select tmr hall

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8, TMR20
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1274 of file at32f435_437_tmr.c.

◆ tmr_input_channel_divider_set()

void tmr_input_channel_divider_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_channel_input_divider_type | divider_factor
 | ) |  |

set tmr input channel divider

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
divider_factor this parameter can be one of the following values:
  • TMR_CHANNEL_INPUT_DIV_1
  • TMR_CHANNEL_INPUT_DIV_2
  • TMR_CHANNEL_INPUT_DIV_4
  • TMR_CHANNEL_INPUT_DIV_8
Return values
none

Definition at line 1175 of file at32f435_437_tmr.c.

Referenced by lick_frequency_get().

◆ tmr_input_channel_filter_set()

void tmr_input_channel_filter_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | uint16_t | filter_value
 | ) |  |

set tmr input channel filter

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
filter_value | (0x0~0xf)
Return values
none

Definition at line 996 of file at32f435_437_tmr.c.

◆ tmr_input_channel_init()

void tmr_input_channel_init | ( | tmr_type * | tmr_x,
 |  | tmr_input_config_type * | input_struct,
 |  | tmr_channel_input_divider_type | divider_factor
 | ) |  |

init tmr input channel

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
input_struct
  • to the structure of tmr_input_config_type
divider_factor this parameter can be one of the following values:
  • TMR_CHANNEL_INPUT_DIV_1
  • TMR_CHANNEL_INPUT_DIV_2
  • TMR_CHANNEL_INPUT_DIV_4
  • TMR_CHANNEL_INPUT_DIV_8
Return values
none

Definition at line 872 of file at32f435_437_tmr.c.

Referenced by lick_frequency_get(), and main().

◆ tmr_input_default_para_init()

void tmr_input_default_para_init ( tmr_input_config_type * tmr_input_struct )

init tmr input default para

Parameters
tmr_input_struct
  • to the structure of tmr_input_config_type
Return values
none

Definition at line 169 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_internal_clock_set()

void tmr_internal_clock_set ( tmr_type * tmr_x )

set tmr select internal clock

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR12, TMR20
Return values
none

Definition at line 1511 of file at32f435_437_tmr.c.

◆ tmr_interrupt_enable()

void tmr_interrupt_enable | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_interrupt,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr interrupt

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_interrupt this parameter can be one of the following values:
  • TMR_OVF_INT
  • TMR_C1_INT
  • TMR_C2_INT
  • TMR_C3_INT
  • TMR_C4_INT
  • TMR_HALL_INT
  • TMR_TRIGGER_INT
  • TMR_BRK_INT
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1389 of file at32f435_437_tmr.c.

Referenced by emac_tmr_init(), lick_frequency_get(), main(), tmr1_config(), tmr2_config(), and tmr_init().

◆ tmr_iremap_config()

void tmr_iremap_config | ( | tmr_type * | tmr_x,
 |  | tmr_input_remap_type | input_remap
 | ) |  |

set tmr2/tmr5 input channel remap

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR2, TMR5
input_remap
  • TMR2_TMR8TRGOUT_TMR5_GPIO
  • TMR2_PTP_TMR5_LICK
  • TMR2_OTG1FS_TMR5_LEXT
  • TMR2_OTG2FS_TMR5_ERTC
Return values
none

Definition at line 1824 of file at32f435_437_tmr.c.

Referenced by lick_frequency_get().

◆ tmr_one_cycle_mode_enable()

void tmr_one_cycle_mode_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr one cycle mode

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR12, TMR20
new_state | (TRUE or FALSE)
Return values
none

Definition at line 805 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_output_channel_buffer_enable()

void tmr_output_channel_buffer_enable | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | confirm_state | new_state
 | ) |  |

set tmr output channel buffer

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
  • TMR_SELECT_CHANNEL_5
new_state | (TRUE or FALSE)
Return values
none

Definition at line 660 of file at32f435_437_tmr.c.

Referenced by main(), and mclk_tmr1_init().

◆ tmr_output_channel_config()

void tmr_output_channel_config | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_output_config_type * | tmr_output_struct
 | ) |  |

config tmr output channel

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
  • TMR_SELECT_CHANNEL_5
tmr_output_struct
  • to the structure of tmr_output_config_type
Return values
none

Definition at line 350 of file at32f435_437_tmr.c.

Referenced by main(), mclk_tmr1_init(), and tmr1_config().

◆ tmr_output_channel_immediately_set()

void tmr_output_channel_immediately_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | confirm_state | new_state
 | ) |  |

set tmr output channel immediately

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
  • TMR_SELECT_CHANNEL_5
new_state | (TRUE or FALSE)
Return values
none

Definition at line 711 of file at32f435_437_tmr.c.

◆ tmr_output_channel_mode_select()

void tmr_output_channel_mode_select | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_output_control_mode_type | oc_mode
 | ) |  |

select tmr output channel mode

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
  • TMR_SELECT_CHANNEL_5
oc_mode this parameter can be one of the following values:
  • TMR_OUTPUT_CONTROL_OFF
  • TMR_OUTPUT_CONTROL_HIGH
  • TMR_OUTPUT_CONTROL_LOW
  • TMR_OUTPUT_CONTROL_SWITCH
  • TMR_OUTPUT_CONTROL_FORCE_HIGH
  • TMR_OUTPUT_CONTROL_FORCE_LOW
  • TMR_OUTPUT_CONTROL_PWM_MODE_A
  • TMR_OUTPUT_CONTROL_PWM_MODE_B
Return values
none

Definition at line 461 of file at32f435_437_tmr.c.

Referenced by TMR1_TRG_HALL_TMR11_IRQHandler().

◆ tmr_output_channel_polarity_set()

void tmr_output_channel_polarity_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_polarity_active_type | oc_polarity
 | ) |  |

set tmr output channel polarity

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
  • TMR_SELECT_CHANNEL_1C
  • TMR_SELECT_CHANNEL_2C
  • TMR_SELECT_CHANNEL_3C
oc_polarity this parameter can be one of the following values:
  • TMR_POLARITY_ACTIVE_HIGH
  • TMR_POLARITY_ACTIVE_LOW
Return values
none

Definition at line 1537 of file at32f435_437_tmr.c.

◆ tmr_output_channel_switch_set()

void tmr_output_channel_switch_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | confirm_state | new_state
 | ) |  |

set tmr output channel switch

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
  • TMR_SELECT_CHANNEL_5
new_state | (TRUE or FALSE)
Return values
none

Definition at line 762 of file at32f435_437_tmr.c.

◆ tmr_output_default_para_init()

void tmr_output_default_para_init ( tmr_output_config_type * tmr_output_struct )

init tmr output default para

Parameters
tmr_output_struct
  • to the structure of tmr_output_config_type
Return values
none

Definition at line 152 of file at32f435_437_tmr.c.

Referenced by main(), mclk_tmr1_init(), and tmr1_config().

◆ tmr_output_enable()

void tmr_output_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

tmr output enable(oen),this function is important for advtm output enable

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8, TMR20
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1499 of file at32f435_437_tmr.c.

Referenced by main(), mclk_tmr1_init(), and tmr1_config().

◆ tmr_overflow_event_disable()

void tmr_overflow_event_disable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr overflow event generation

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
new_state | (TRUE or FALSE)
Return values
none

Definition at line 851 of file at32f435_437_tmr.c.

◆ tmr_overflow_request_source_set()

void tmr_overflow_request_source_set | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

select tmr the overflow event sources

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
new_state | (TRUE or FALSE)
Return values
none

Definition at line 837 of file at32f435_437_tmr.c.

◆ tmr_period_buffer_enable()

void tmr_period_buffer_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

set tmr period buffer

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
new_state | (TRUE or FALSE)
Return values
none

Definition at line 638 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_period_value_get()

uint32_t tmr_period_value_get ( tmr_type * tmr_x )

get tmr period value

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
Return values
timer period register value of counter (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)

Definition at line 521 of file at32f435_437_tmr.c.

◆ tmr_period_value_set()

void tmr_period_value_set | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_pr_value
 | ) |  |

set tmr period value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
tmr_pr_value | timer period register value of counter (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
Return values
none

Definition at line 505 of file at32f435_437_tmr.c.

◆ tmr_primary_mode_select()

void tmr_primary_mode_select | ( | tmr_type * | tmr_x,
 |  | tmr_primary_select_type | primary_mode
 | ) |  |

select tmr primary mode

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR20
primary_mode this parameter can be one of the following values:
  • TMR_PRIMARY_SEL_RESET
  • TMR_PRIMARY_SEL_ENABLE
  • TMR_PRIMARY_SEL_OVERFLOW
  • TMR_PRIMARY_SEL_COMPARE
  • TMR_PRIMARY_SEL_C1ORAW
  • TMR_PRIMARY_SEL_C2ORAW
  • TMR_PRIMARY_SEL_C3ORAW
  • TMR_PRIMARY_SEL_C4ORAW
Return values
none

Definition at line 1222 of file at32f435_437_tmr.c.

Referenced by main(), and tmr1_config().

◆ tmr_pwm_input_config()

void tmr_pwm_input_config | ( | tmr_type * | tmr_x,
 |  | tmr_input_config_type * | input_struct,
 |  | tmr_channel_input_divider_type | divider_factor
 | ) |  |

config tmr pwm input

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
input_struct
  • to the structure of tmr_input_config_type
divider_factor this parameter can be one of the following values:
  • TMR_CHANNEL_INPUT_DIV_1
  • TMR_CHANNEL_INPUT_DIV_2
  • TMR_CHANNEL_INPUT_DIV_4
  • TMR_CHANNEL_INPUT_DIV_8
Return values
none

Definition at line 1042 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_repetition_counter_set()

void tmr_repetition_counter_set | ( | tmr_type * | tmr_x,
 |  | uint8_t | tmr_rpr_value
 | ) |  |

set the repetition counter register(rpr) value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8, TMR20
tmr_rpr_value | (0x0000~0xFFFF)
Return values
none

Definition at line 265 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_reset()

void tmr_reset ( tmr_type * tmr_x )

tmr reset by crm reset register

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR6, TMR7, TMR8, TMR9, TMR10, TMR11, TMR12, TMR13, TMR14, TMR20
Return values
none

Definition at line 52 of file at32f435_437_tmr.c.

Referenced by lick_frequency_get().

◆ tmr_sub_mode_select()

void tmr_sub_mode_select | ( | tmr_type * | tmr_x,
 |  | tmr_sub_mode_select_type | sub_mode
 | ) |  |

select tmr subordinate mode

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR12, TMR20
sub_mode this parameter can be one of the following values:
  • TMR_SUB_MODE_DIABLE
  • TMR_SUB_ENCODER_MODE_A
  • TMR_SUB_ENCODER_MODE_B
  • TMR_SUB_ENCODER_MODE_C
  • TMR_SUB_RESET_MODE
  • TMR_SUB_HANG_MODE
  • TMR_SUB_TRIGGER_MODE
  • TMR_SUB_EXTERNAL_CLOCK_MODE_A
Return values
none

Definition at line 1245 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_sub_sync_mode_set()

void tmr_sub_sync_mode_set | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

set tmr subordinate synchronization mode

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR12, TMR20
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1335 of file at32f435_437_tmr.c.

Referenced by main().

◆ tmr_trgout2_enable()

void tmr_trgout2_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

select tmr trgout2

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8, TMR20
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1300 of file at32f435_437_tmr.c.

Referenced by tmr1_config().

◆ tmr_trigger_input_select()

void tmr_trigger_input_select | ( | tmr_type * | tmr_x,
 |  | sub_tmr_input_sel_type | trigger_select
 | ) |  |

select tmr sub-trigger

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR12, TMR20
trigger_select this parameter can be one of the following values:
  • TMR_SUB_INPUT_SEL_IS0
  • TMR_SUB_INPUT_SEL_IS1
  • TMR_SUB_INPUT_SEL_IS2
  • TMR_SUB_INPUT_SEL_IS3
  • TMR_SUB_INPUT_SEL_C1INC
  • TMR_SUB_INPUT_SEL_C1DF1
  • TMR_SUB_INPUT_SEL_C2DF2
  • TMR_SUB_INPUT_SEL_EXTIN
Return values
none

Definition at line 1322 of file at32f435_437_tmr.c.

Referenced by main().


AT32F435/437 Firmwary Library: USART

Modules | Macros
USART
AT32F435_437_periph_driver

USART driver modules. More...

Modules

USART_flags_definition
usart flag
USART_interrupts_definition
usart interrupt
USART_exported_types
USART_exported_functions
USART_private_functions

Macros

#define | USART1 ((usart_type *) USART1_BASE)
#define | USART2 ((usart_type *) USART2_BASE)
#define | USART3 ((usart_type *) USART3_BASE)
#define | UART4 ((usart_type *) UART4_BASE)
#define | UART5 ((usart_type *) UART5_BASE)
#define | USART6 ((usart_type *) USART6_BASE)
#define | UART7 ((usart_type *) UART7_BASE)
#define | UART8 ((usart_type *) UART8_BASE)

Detailed Description

USART driver modules.

Macro Definition Documentation

◆ UART4

#define UART4 ((usart_type *) UART4_BASE)

Definition at line 351 of file at32f435_437_usart.h.

◆ UART5

#define UART5 ((usart_type *) UART5_BASE)

Definition at line 352 of file at32f435_437_usart.h.

◆ UART7

#define UART7 ((usart_type *) UART7_BASE)

Definition at line 354 of file at32f435_437_usart.h.

◆ UART8

#define UART8 ((usart_type *) UART8_BASE)

Definition at line 355 of file at32f435_437_usart.h.

◆ USART1

#define USART1 ((usart_type *) USART1_BASE)

Definition at line 348 of file at32f435_437_usart.h.

◆ USART2

#define USART2 ((usart_type *) USART2_BASE)

Definition at line 349 of file at32f435_437_usart.h.

◆ USART3

#define USART3 ((usart_type *) USART3_BASE)

Definition at line 350 of file at32f435_437_usart.h.

◆ USART6

#define USART6 ((usart_type *) USART6_BASE)

Definition at line 353 of file at32f435_437_usart.h.


AT32F435/437 Firmwary Library: USART_flags_definition

Macros
USART_flags_definition
AT32F435_437_periph_driver » USART

usart flag More...

Macros

#define | USART_PERR_FLAG ((uint32_t)0x00000001)
#define | USART_FERR_FLAG ((uint32_t)0x00000002)
#define | USART_NERR_FLAG ((uint32_t)0x00000004)
#define | USART_ROERR_FLAG ((uint32_t)0x00000008)
#define | USART_IDLEF_FLAG ((uint32_t)0x00000010)
#define | USART_RDBF_FLAG ((uint32_t)0x00000020)
#define | USART_TDC_FLAG ((uint32_t)0x00000040)
#define | USART_TDBE_FLAG ((uint32_t)0x00000080)
#define | USART_BFF_FLAG ((uint32_t)0x00000100)
#define | USART_CTSCF_FLAG ((uint32_t)0x00000200)

Detailed Description

usart flag

Macro Definition Documentation

◆ USART_BFF_FLAG

#define USART_BFF_FLAG ((uint32_t)0x00000100)

usart break frame flag

Definition at line 60 of file at32f435_437_usart.h.

◆ USART_CTSCF_FLAG

#define USART_CTSCF_FLAG ((uint32_t)0x00000200)

usart cts change flag

Definition at line 61 of file at32f435_437_usart.h.

◆ USART_FERR_FLAG

#define USART_FERR_FLAG ((uint32_t)0x00000002)

usart framing error flag

Definition at line 53 of file at32f435_437_usart.h.

◆ USART_IDLEF_FLAG

#define USART_IDLEF_FLAG ((uint32_t)0x00000010)

usart idle flag

Definition at line 56 of file at32f435_437_usart.h.

◆ USART_NERR_FLAG

#define USART_NERR_FLAG ((uint32_t)0x00000004)

usart noise error flag

Definition at line 54 of file at32f435_437_usart.h.

◆ USART_PERR_FLAG

#define USART_PERR_FLAG ((uint32_t)0x00000001)

usart parity error flag

Definition at line 52 of file at32f435_437_usart.h.

◆ USART_RDBF_FLAG

#define USART_RDBF_FLAG ((uint32_t)0x00000020)

usart receive data buffer full flag

Definition at line 57 of file at32f435_437_usart.h.

◆ USART_ROERR_FLAG

#define USART_ROERR_FLAG ((uint32_t)0x00000008)

usart receiver overflow error flag

Definition at line 55 of file at32f435_437_usart.h.

◆ USART_TDBE_FLAG

#define USART_TDBE_FLAG ((uint32_t)0x00000080)

usart transmit data buffer empty flag

Definition at line 59 of file at32f435_437_usart.h.

◆ USART_TDC_FLAG

#define USART_TDC_FLAG ((uint32_t)0x00000040)

usart transmit data complete flag

Definition at line 58 of file at32f435_437_usart.h.


AT32F435/437 Firmwary Library: USART_interrupts_definition

Macros
USART_interrupts_definition
AT32F435_437_periph_driver » USART

usart interrupt More...

Macros

#define | USART_IDLE_INT MAKE_VALUE(0x0C,0x04)
#define | USART_RDBF_INT MAKE_VALUE(0x0C,0x05)
#define | USART_TDC_INT MAKE_VALUE(0x0C,0x06)
#define | USART_TDBE_INT MAKE_VALUE(0x0C,0x07)
#define | USART_PERR_INT MAKE_VALUE(0x0C,0x08)
#define | USART_BF_INT MAKE_VALUE(0x10,0x06)
#define | USART_ERR_INT MAKE_VALUE(0x14,0x00)
#define | USART_CTSCF_INT MAKE_VALUE(0x14,0x0A)

Detailed Description

usart interrupt

Macro Definition Documentation

◆ USART_BF_INT

#define USART_BF_INT MAKE_VALUE(0x10,0x06)

usart break frame interrupt

Definition at line 77 of file at32f435_437_usart.h.

◆ USART_CTSCF_INT

#define USART_CTSCF_INT MAKE_VALUE(0x14,0x0A)

usart cts change interrupt

Definition at line 79 of file at32f435_437_usart.h.

◆ USART_ERR_INT

#define USART_ERR_INT MAKE_VALUE(0x14,0x00)

usart error interrupt

Definition at line 78 of file at32f435_437_usart.h.

◆ USART_IDLE_INT

#define USART_IDLE_INT MAKE_VALUE(0x0C,0x04)

usart idle interrupt

Definition at line 72 of file at32f435_437_usart.h.

◆ USART_PERR_INT

#define USART_PERR_INT MAKE_VALUE(0x0C,0x08)

usart parity error interrupt

Definition at line 76 of file at32f435_437_usart.h.

◆ USART_RDBF_INT

#define USART_RDBF_INT MAKE_VALUE(0x0C,0x05)

usart receive data buffer full interrupt

Definition at line 73 of file at32f435_437_usart.h.

◆ USART_TDBE_INT

#define USART_TDBE_INT MAKE_VALUE(0x0C,0x07)

usart transmit data buffer empty interrupt

Definition at line 75 of file at32f435_437_usart.h.

◆ USART_TDC_INT

#define USART_TDC_INT MAKE_VALUE(0x0C,0x06)

usart transmit data complete interrupt

Definition at line 74 of file at32f435_437_usart.h.


AT32F435/437 Firmwary Library: USART_exported_types

Data Structures | Enumerations
USART_exported_types
AT32F435_437_periph_driver » USART

Data Structures

struct usart_type
type define usart register all More...

Enumerations

enum | usart_parity_selection_type { USART_PARITY_NONE = 0x00 , USART_PARITY_EVEN = 0x01 , USART_PARITY_ODD = 0x02 }
usart parity selection type More...
enum | usart_wakeup_mode_type { USART_WAKEUP_BY_IDLE_FRAME = 0x00 , USART_WAKEUP_BY_MATCHING_ID = 0x01 }
usart wakeup mode type More...
enum | usart_data_bit_num_type { USART_DATA_7BITS = 0x00 , USART_DATA_8BITS = 0x01 , USART_DATA_9BITS = 0x02 }
usart data bit num type More...
enum | usart_break_bit_num_type { USART_BREAK_10BITS = 0x00 , USART_BREAK_11BITS = 0x01 }
usart break frame bit num type More...
enum | usart_clock_phase_type { USART_CLOCK_PHASE_1EDGE = 0x00 , USART_CLOCK_PHASE_2EDGE = 0x01 }
usart phase of the clock type More...
enum | usart_clock_polarity_type { USART_CLOCK_POLARITY_LOW = 0x00 , USART_CLOCK_POLARITY_HIGH = 0x01 }
usart polarity of the clock type More...
enum | usart_lbcp_type { USART_CLOCK_LAST_BIT_NONE = 0x00 , USART_CLOCK_LAST_BIT_OUTPUT = 0x01 }
usart last bit clock pulse type More...
enum | usart_stop_bit_num_type { USART_STOP_1_BIT = 0x00 , USART_STOP_0_5_BIT = 0x01 , USART_STOP_2_BIT = 0x02 , USART_STOP_1_5_BIT = 0x03 }
usart stop bit num type More...
enum | usart_hardware_flow_control_type { USART_HARDWARE_FLOW_NONE = 0x00 , USART_HARDWARE_FLOW_RTS = 0x01 , USART_HARDWARE_FLOW_CTS = 0x02 , USART_HARDWARE_FLOW_RTS_CTS = 0x03 }
usart hardware flow control type More...
enum | usart_identification_bit_num_type { USART_ID_FIXED_4_BIT = 0x00 , USART_ID_RELATED_DATA_BIT = 0x01 }
usart identification bit num type More...
enum | usart_de_polarity_type { USART_DE_POLARITY_HIGH = 0x00 , USART_DE_POLARITY_LOW = 0x01 }
usart de polarity type More...

Detailed Description

Enumeration Type Documentation

◆ usart_break_bit_num_type

enum usart_break_bit_num_type

usart break frame bit num type

Enumerator
USART_BREAK_10BITS | usart lin mode berak frame detection 10 bits
USART_BREAK_11BITS | usart lin mode berak frame detection 11 bits

Definition at line 121 of file at32f435_437_usart.h.

◆ usart_clock_phase_type

enum usart_clock_phase_type

usart phase of the clock type

Enumerator
USART_CLOCK_PHASE_1EDGE | usart data capture is done on the clock leading edge
USART_CLOCK_PHASE_2EDGE | usart data capture is done on the clock trailing edge

Definition at line 130 of file at32f435_437_usart.h.

◆ usart_clock_polarity_type

enum usart_clock_polarity_type

usart polarity of the clock type

Enumerator
USART_CLOCK_POLARITY_LOW | usart clock stay low level outside transmission window
USART_CLOCK_POLARITY_HIGH | usart clock stay high level outside transmission window

Definition at line 139 of file at32f435_437_usart.h.

◆ usart_data_bit_num_type

enum usart_data_bit_num_type

usart data bit num type

Enumerator
USART_DATA_7BITS | usart data size is 7 bits
USART_DATA_8BITS | usart data size is 8 bits
USART_DATA_9BITS | usart data size is 9 bits

Definition at line 111 of file at32f435_437_usart.h.

◆ usart_de_polarity_type

enum usart_de_polarity_type

usart de polarity type

Enumerator
USART_DE_POLARITY_HIGH | usart de polarity high
USART_DE_POLARITY_LOW | usart de polarity low

Definition at line 188 of file at32f435_437_usart.h.

◆ usart_hardware_flow_control_type

enum usart_hardware_flow_control_type

usart hardware flow control type

Enumerator
USART_HARDWARE_FLOW_NONE | usart without hardware flow
USART_HARDWARE_FLOW_RTS | usart hardware flow only rts
USART_HARDWARE_FLOW_CTS | usart hardware flow only cts
USART_HARDWARE_FLOW_RTS_CTS | usart hardware flow both rts and cts

Definition at line 168 of file at32f435_437_usart.h.

◆ usart_identification_bit_num_type

enum usart_identification_bit_num_type

usart identification bit num type

Enumerator
USART_ID_FIXED_4_BIT | usart id bit num fixed 4 bits
USART_ID_RELATED_DATA_BIT | usart id bit num related data bits

Definition at line 179 of file at32f435_437_usart.h.

◆ usart_lbcp_type

enum usart_lbcp_type

usart last bit clock pulse type

Enumerator
USART_CLOCK_LAST_BIT_NONE | usart clock pulse of the last data bit is not outputted
USART_CLOCK_LAST_BIT_OUTPUT | usart clock pulse of the last data bit is outputted

Definition at line 148 of file at32f435_437_usart.h.

◆ usart_parity_selection_type

enum usart_parity_selection_type

usart parity selection type

Enumerator
USART_PARITY_NONE | usart no parity
USART_PARITY_EVEN | usart even parity
USART_PARITY_ODD | usart odd parity

Definition at line 92 of file at32f435_437_usart.h.

◆ usart_stop_bit_num_type

enum usart_stop_bit_num_type

usart stop bit num type

Enumerator
USART_STOP_1_BIT | usart stop bits num is 1
USART_STOP_0_5_BIT | usart stop bits num is 0.5
USART_STOP_2_BIT | usart stop bits num is 2
USART_STOP_1_5_BIT | usart stop bits num is 1.5

Definition at line 157 of file at32f435_437_usart.h.

◆ usart_wakeup_mode_type

enum usart_wakeup_mode_type

usart wakeup mode type

Enumerator
USART_WAKEUP_BY_IDLE_FRAME | usart wakeup by idle frame
USART_WAKEUP_BY_MATCHING_ID | usart wakeup by matching id

Definition at line 102 of file at32f435_437_usart.h.


AT32F435/437 Firmwary Library: usart_type Struct Reference

Data Fields
usart_type Struct Reference
AT32F435_437_periph_driver » USART » USART_exported_types

type define usart register all More...

#include <at32f435_437_usart.h>

Data Fields

union {
__IO uint32_t sts
struct {
__IO uint32_t perr: 1
__IO uint32_t ferr: 1
__IO uint32_t nerr: 1
__IO uint32_t roerr: 1
__IO uint32_t idlef: 1
__IO uint32_t rdbf: 1
__IO uint32_t tdc: 1
__IO uint32_t tdbe: 1
__IO uint32_t bff: 1
__IO uint32_t ctscf: 1
__IO uint32_t reserved1: 22
} sts_bit
};
usart sts register, offset:0x00 More...
union {
__IO uint32_t dt
struct {
__IO uint32_t dt: 9
__IO uint32_t reserved1: 23
} dt_bit
};
usart dt register, offset:0x04 More...
union {
__IO uint32_t baudr
struct {
__IO uint32_t div: 16
__IO uint32_t reserved1: 16
} baudr_bit
};
usart baudr register, offset:0x08 More...
union {
__IO uint32_t ctrl1
struct {
__IO uint32_t sbf: 1
__IO uint32_t rm: 1
__IO uint32_t ren: 1
__IO uint32_t ten: 1
__IO uint32_t idleien: 1
__IO uint32_t rdbfien: 1
__IO uint32_t tdcien: 1
__IO uint32_t tdbeien: 1
__IO uint32_t perrien: 1
__IO uint32_t psel: 1
__IO uint32_t pen: 1
__IO uint32_t wum: 1
__IO uint32_t dbn_l: 1
__IO uint32_t uen: 1
__IO uint32_t reserved1: 2
__IO uint32_t tcdt: 5
__IO uint32_t tsdt: 5
__IO uint32_t reserved2: 2
__IO uint32_t dbn_h: 1
__IO uint32_t reserved3: 3
} ctrl1_bit
};
usart ctrl1 register, offset:0x0C More...
union {
__IO uint32_t ctrl2
struct {
__IO uint32_t id_l: 4
__IO uint32_t idbn: 1
__IO uint32_t bfbn: 1
__IO uint32_t bfien: 1
__IO uint32_t reserved1: 1
__IO uint32_t lbcp: 1
__IO uint32_t clkpha: 1
__IO uint32_t clkpol: 1
__IO uint32_t clken: 1
__IO uint32_t stopbn: 2
__IO uint32_t linen: 1
__IO uint32_t trpswap: 1
__IO uint32_t reserved2: 12
__IO uint32_t id_h: 4
} ctrl2_bit
};
usart ctrl2 register, offset:0x10 More...
union {
__IO uint32_t ctrl3
struct {
__IO uint32_t errien: 1
__IO uint32_t irdaen: 1
__IO uint32_t irdalp: 1
__IO uint32_t slben: 1
__IO uint32_t scnacken: 1
__IO uint32_t scmen: 1
__IO uint32_t dmaren: 1
__IO uint32_t dmaten: 1
__IO uint32_t rtsen: 1
__IO uint32_t ctsen: 1
__IO uint32_t ctscfien: 1
__IO uint32_t reserved1: 3
__IO uint32_t rs485en: 1
__IO uint32_t dep: 1
__IO uint32_t reserved2: 16
} ctrl3_bit
};
usart ctrl3 register, offset:0x14 More...
union {
__IO uint32_t gdiv
struct {
__IO uint32_t isdiv: 8
__IO uint32_t scgt: 8
__IO uint32_t reserved1: 16
} gdiv_bit
};
usart gdiv register, offset:0x18 More...

Detailed Description

type define usart register all

Definition at line 197 of file at32f435_437_usart.h.

Field Documentation

◆

union { ... } usart_type::@1129

usart sts register, offset:0x00

◆

union { ... } usart_type::@1131

usart dt register, offset:0x04

◆

union { ... } usart_type::@1133

usart baudr register, offset:0x08

◆

union { ... } usart_type::@1135

usart ctrl1 register, offset:0x0C

◆

union { ... } usart_type::@1137

usart ctrl2 register, offset:0x10

◆

union { ... } usart_type::@1139

usart ctrl3 register, offset:0x14

◆

union { ... } usart_type::@1141

usart gdiv register, offset:0x18

◆ baudr

__IO uint32_t usart_type::baudr

Definition at line 239 of file at32f435_437_usart.h.

◆

struct { ... } usart_type::baudr_bit

Referenced by usart_init().

◆ bfbn

__IO uint32_t usart_type::bfbn

Definition at line 288 of file at32f435_437_usart.h.

Referenced by usart_break_bit_num_set().

◆ bff

__IO uint32_t usart_type::bff

Definition at line 215 of file at32f435_437_usart.h.

◆ bfien

__IO uint32_t usart_type::bfien

Definition at line 289 of file at32f435_437_usart.h.

◆ clken

__IO uint32_t usart_type::clken

Definition at line 294 of file at32f435_437_usart.h.

Referenced by usart_clock_enable().

◆ clkpha

__IO uint32_t usart_type::clkpha

Definition at line 292 of file at32f435_437_usart.h.

Referenced by usart_clock_config().

◆ clkpol

__IO uint32_t usart_type::clkpol

Definition at line 293 of file at32f435_437_usart.h.

Referenced by usart_clock_config().

◆ ctrl1

__IO uint32_t usart_type::ctrl1

Definition at line 252 of file at32f435_437_usart.h.

◆

struct { ... } usart_type::ctrl1_bit

Referenced by usart_break_send(), usart_enable(), usart_init(), usart_parity_selection_config(), usart_receiver_enable(), usart_receiver_mute_enable(), usart_rs485_delay_time_config(), usart_transmitter_enable(), and usart_wakeup_mode_set().

◆ ctrl2

__IO uint32_t usart_type::ctrl2

Definition at line 283 of file at32f435_437_usart.h.

◆

struct { ... } usart_type::ctrl2_bit

Referenced by usart_break_bit_num_set(), usart_clock_config(), usart_clock_enable(), usart_id_bit_num_set(), usart_init(), usart_lin_mode_enable(), usart_transmit_receive_pin_swap(), and usart_wakeup_id_set().

◆ ctrl3

__IO uint32_t usart_type::ctrl3

Definition at line 308 of file at32f435_437_usart.h.

◆

struct { ... } usart_type::ctrl3_bit

Referenced by usart_de_polarity_set(), usart_dma_receiver_enable(), usart_dma_transmitter_enable(), usart_hardware_flow_control_set(), usart_irda_low_power_enable(), usart_irda_mode_enable(), usart_rs485_mode_enable(), usart_single_line_halfduplex_select(), usart_smartcard_mode_enable(), and usart_smartcard_nack_set().

◆ ctscf

__IO uint32_t usart_type::ctscf

Definition at line 216 of file at32f435_437_usart.h.

◆ ctscfien

__IO uint32_t usart_type::ctscfien

Definition at line 321 of file at32f435_437_usart.h.

◆ ctsen

__IO uint32_t usart_type::ctsen

Definition at line 320 of file at32f435_437_usart.h.

Referenced by usart_hardware_flow_control_set().

◆ dbn_h

__IO uint32_t usart_type::dbn_h

Definition at line 273 of file at32f435_437_usart.h.

Referenced by usart_init().

◆ dbn_l

__IO uint32_t usart_type::dbn_l

Definition at line 267 of file at32f435_437_usart.h.

Referenced by usart_init().

◆ dep

__IO uint32_t usart_type::dep

Definition at line 324 of file at32f435_437_usart.h.

Referenced by usart_de_polarity_set().

◆ div

__IO uint32_t usart_type::div

Definition at line 242 of file at32f435_437_usart.h.

Referenced by usart_init().

◆ dmaren

__IO uint32_t usart_type::dmaren

Definition at line 317 of file at32f435_437_usart.h.

Referenced by usart_dma_receiver_enable().

◆ dmaten

__IO uint32_t usart_type::dmaten

Definition at line 318 of file at32f435_437_usart.h.

Referenced by usart_dma_transmitter_enable().

◆ dt

__IO uint32_t usart_type::dt

Definition at line 226 of file at32f435_437_usart.h.

Referenced by usart_data_receive(), usart_data_transmit(), and usart_flag_clear().

◆

struct { ... } usart_type::dt_bit

◆ errien

__IO uint32_t usart_type::errien

Definition at line 311 of file at32f435_437_usart.h.

◆ ferr

__IO uint32_t usart_type::ferr

Definition at line 208 of file at32f435_437_usart.h.

◆ gdiv

__IO uint32_t usart_type::gdiv

Definition at line 334 of file at32f435_437_usart.h.

◆

struct { ... } usart_type::gdiv_bit

Referenced by usart_irda_smartcard_division_set(), and usart_smartcard_guard_time_set().

◆ id_h

__IO uint32_t usart_type::id_h

Definition at line 299 of file at32f435_437_usart.h.

Referenced by usart_wakeup_id_set().

◆ id_l

__IO uint32_t usart_type::id_l

Definition at line 286 of file at32f435_437_usart.h.

Referenced by usart_wakeup_id_set().

◆ idbn

__IO uint32_t usart_type::idbn

Definition at line 287 of file at32f435_437_usart.h.

Referenced by usart_id_bit_num_set(), and usart_wakeup_id_set().

◆ idlef

__IO uint32_t usart_type::idlef

Definition at line 211 of file at32f435_437_usart.h.

◆ idleien

__IO uint32_t usart_type::idleien

Definition at line 259 of file at32f435_437_usart.h.

◆ irdaen

__IO uint32_t usart_type::irdaen

Definition at line 312 of file at32f435_437_usart.h.

Referenced by usart_irda_mode_enable().

◆ irdalp

__IO uint32_t usart_type::irdalp

Definition at line 313 of file at32f435_437_usart.h.

Referenced by usart_irda_low_power_enable().

◆ isdiv

__IO uint32_t usart_type::isdiv

Definition at line 337 of file at32f435_437_usart.h.

Referenced by usart_irda_smartcard_division_set().

◆ lbcp

__IO uint32_t usart_type::lbcp

Definition at line 291 of file at32f435_437_usart.h.

Referenced by usart_clock_config().

◆ linen

__IO uint32_t usart_type::linen

Definition at line 296 of file at32f435_437_usart.h.

Referenced by usart_lin_mode_enable().

◆ nerr

__IO uint32_t usart_type::nerr

Definition at line 209 of file at32f435_437_usart.h.

◆ pen

__IO uint32_t usart_type::pen

Definition at line 265 of file at32f435_437_usart.h.

Referenced by usart_parity_selection_config().

◆ perr

__IO uint32_t usart_type::perr

Definition at line 207 of file at32f435_437_usart.h.

◆ perrien

__IO uint32_t usart_type::perrien

Definition at line 263 of file at32f435_437_usart.h.

◆ psel

__IO uint32_t usart_type::psel

Definition at line 264 of file at32f435_437_usart.h.

Referenced by usart_parity_selection_config().

◆ rdbf

__IO uint32_t usart_type::rdbf

Definition at line 212 of file at32f435_437_usart.h.

◆ rdbfien

__IO uint32_t usart_type::rdbfien

Definition at line 260 of file at32f435_437_usart.h.

◆ ren

__IO uint32_t usart_type::ren

Definition at line 257 of file at32f435_437_usart.h.

Referenced by usart_receiver_enable().

◆ reserved1

__IO uint32_t usart_type::reserved1

Definition at line 217 of file at32f435_437_usart.h.

◆ reserved2

__IO uint32_t usart_type::reserved2

Definition at line 272 of file at32f435_437_usart.h.

◆ reserved3

__IO uint32_t usart_type::reserved3

Definition at line 274 of file at32f435_437_usart.h.

◆ rm

__IO uint32_t usart_type::rm

Definition at line 256 of file at32f435_437_usart.h.

Referenced by usart_receiver_mute_enable().

◆ roerr

__IO uint32_t usart_type::roerr

Definition at line 210 of file at32f435_437_usart.h.

◆ rs485en

__IO uint32_t usart_type::rs485en

Definition at line 323 of file at32f435_437_usart.h.

Referenced by usart_rs485_mode_enable().

◆ rtsen

__IO uint32_t usart_type::rtsen

Definition at line 319 of file at32f435_437_usart.h.

Referenced by usart_hardware_flow_control_set().

◆ sbf

__IO uint32_t usart_type::sbf

Definition at line 255 of file at32f435_437_usart.h.

Referenced by usart_break_send().

◆ scgt

__IO uint32_t usart_type::scgt

Definition at line 338 of file at32f435_437_usart.h.

Referenced by usart_smartcard_guard_time_set().

◆ scmen

__IO uint32_t usart_type::scmen

Definition at line 316 of file at32f435_437_usart.h.

Referenced by usart_smartcard_mode_enable().

◆ scnacken

__IO uint32_t usart_type::scnacken

Definition at line 315 of file at32f435_437_usart.h.

Referenced by usart_smartcard_nack_set().

◆ slben

__IO uint32_t usart_type::slben

Definition at line 314 of file at32f435_437_usart.h.

Referenced by usart_single_line_halfduplex_select().

◆ stopbn

__IO uint32_t usart_type::stopbn

Definition at line 295 of file at32f435_437_usart.h.

Referenced by usart_init().

◆ sts

__IO uint32_t usart_type::sts

Definition at line 204 of file at32f435_437_usart.h.

Referenced by usart_flag_clear(), and usart_flag_get().

◆

struct { ... } usart_type::sts_bit

◆ tcdt

__IO uint32_t usart_type::tcdt

Definition at line 270 of file at32f435_437_usart.h.

Referenced by usart_rs485_delay_time_config().

◆ tdbe

__IO uint32_t usart_type::tdbe

Definition at line 214 of file at32f435_437_usart.h.

◆ tdbeien

__IO uint32_t usart_type::tdbeien

Definition at line 262 of file at32f435_437_usart.h.

◆ tdc

__IO uint32_t usart_type::tdc

Definition at line 213 of file at32f435_437_usart.h.

◆ tdcien

__IO uint32_t usart_type::tdcien

Definition at line 261 of file at32f435_437_usart.h.

◆ ten

__IO uint32_t usart_type::ten

Definition at line 258 of file at32f435_437_usart.h.

Referenced by usart_transmitter_enable().

◆ trpswap

__IO uint32_t usart_type::trpswap

Definition at line 297 of file at32f435_437_usart.h.

Referenced by usart_transmit_receive_pin_swap().

◆ tsdt

__IO uint32_t usart_type::tsdt

Definition at line 271 of file at32f435_437_usart.h.

Referenced by usart_rs485_delay_time_config().

◆ uen

__IO uint32_t usart_type::uen

Definition at line 268 of file at32f435_437_usart.h.

Referenced by usart_enable().

◆ wum

__IO uint32_t usart_type::wum

Definition at line 266 of file at32f435_437_usart.h.

Referenced by usart_wakeup_mode_set().

The documentation for this struct was generated from the following file:
  • at32f435_437_usart.h


AT32F435/437 Firmwary Library: USART_exported_functions

Functions
USART_exported_functions
AT32F435_437_periph_driver » USART

Functions

void | usart_reset (usart_type *usart_x)
deinitialize the usart peripheral registers to their default reset values. More...
void | usart_init (usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters. More...
void | usart_parity_selection_config (usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config. More...
void | usart_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral. More...
void | usart_transmitter_enable (usart_type *usart_x, confirm_state new_state)
usart transmitter enable. More...
void | usart_receiver_enable (usart_type *usart_x, confirm_state new_state)
usart receiver enable. More...
void | usart_clock_config (usart_type *usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
usart clock config. More...
void | usart_clock_enable (usart_type *usart_x, confirm_state new_state)
usart enable the ck pin. More...
void | usart_interrupt_enable (usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts. More...
void | usart_dma_transmitter_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface. More...
void | usart_dma_receiver_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma receiver interface. More...
void | usart_wakeup_id_set (usart_type *usart_x, uint8_t usart_id)
set the wakeup id of the usart. More...
void | usart_wakeup_mode_set (usart_type *usart_x, usart_wakeup_mode_type wakeup_mode)
select the usart wakeup method in multi-processor communication. More...
void | usart_receiver_mute_enable (usart_type *usart_x, confirm_state new_state)
config the usart in mute mode in multi-processor communication. More...
void | usart_break_bit_num_set (usart_type *usart_x, usart_break_bit_num_type break_bit)
set the usart break frame bit num. More...
void | usart_lin_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart lin mode. More...
void | usart_data_transmit (usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral. More...
uint16_t | usart_data_receive (usart_type *usart_x)
return the most recent received data by the usart peripheral. More...
void | usart_break_send (usart_type *usart_x)
transmit break characters. More...
void | usart_smartcard_guard_time_set (usart_type *usart_x, uint8_t guard_time_val)
config the specified usart smartcard guard time. More...
void | usart_irda_smartcard_division_set (usart_type *usart_x, uint8_t div_val)
config the irda/smartcard division. More...
void | usart_smartcard_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart smart card mode. More...
void | usart_smartcard_nack_set (usart_type *usart_x, confirm_state new_state)
enable or disable nack transmission in smartcard mode. More...
void | usart_single_line_halfduplex_select (usart_type *usart_x, confirm_state new_state)
enable or disable the usart single line bidirectional half-duplex communication. More...
void | usart_irda_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's irda interface. More...
void | usart_irda_low_power_enable (usart_type *usart_x, confirm_state new_state)
configure the usart's irda low power. More...
void | usart_hardware_flow_control_set (usart_type *usart_x, usart_hardware_flow_control_type flow_state)
configure the usart's hardware flow control. More...
flag_status | usart_flag_get (usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not. More...
void | usart_flag_clear (usart_type *usart_x, uint32_t flag)
clear the usart's pending flags. More...
void | usart_rs485_delay_time_config (usart_type *usart_x, uint8_t start_delay_time, uint8_t complete_delay_time)
configure the usart's rs485 transmit delay time. More...
void | usart_transmit_receive_pin_swap (usart_type *usart_x, confirm_state new_state)
swap the usart's transmit receive pin. More...
void | usart_id_bit_num_set (usart_type *usart_x, usart_identification_bit_num_type id_bit_num)
set the usart's identification bit num. More...
void | usart_de_polarity_set (usart_type *usart_x, usart_de_polarity_type de_polarity)
set the usart's de polarity. More...
void | usart_rs485_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's rs485 mode. More...

Detailed Description

Function Documentation

◆ usart_break_bit_num_set()

void usart_break_bit_num_set | ( | usart_type * | usart_x,
 |  | usart_break_bit_num_type | break_bit
 | ) |  |

set the usart break frame bit num.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
break_bit specifies the break bit num. this parameter can be one of the following values:
  • USART_BREAK_10BITS
  • USART_BREAK_11BITS
Return values
none

Definition at line 386 of file at32f435_437_usart.c.

◆ usart_break_send()

void usart_break_send ( usart_type * usart_x )

transmit break characters.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
Return values
none

Definition at line 437 of file at32f435_437_usart.c.

◆ usart_clock_config()

void usart_clock_config | ( | usart_type * | usart_x,
 |  | usart_clock_polarity_type | clk_pol,
 |  | usart_clock_phase_type | clk_pha,
 |  | usart_lbcp_type | clk_lb
 | ) |  |

usart clock config.

Note
clock config are not available for UART4, UART5, UART7 and UART8.
Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3 or USART6.
clk_pol polarity of the clock output on the ck pin. this parameter can be one of the following values:
  • USART_CLOCK_POLARITY_LOW
  • USART_CLOCK_POLARITY_HIGH
clk_pha phase of the clock output on the ck pin. this parameter can be one of the following values:
  • USART_CLOCK_PHASE_1EDGE
  • USART_CLOCK_PHASE_2EDGE
clk_lb whether the clock pulse of the last data bit transmitted (MSB) is outputted on the ck pin. this parameter can be one of the following values:
  • USART_CLOCK_LAST_BIT_NONE
  • USART_CLOCK_LAST_BIT_OUTPUT
Return values
none

Definition at line 247 of file at32f435_437_usart.c.

Referenced by usart_configuration(), and usart_spi_configuration().

◆ usart_clock_enable()

void usart_clock_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

usart enable the ck pin.

Note
clock enable are not available for UART4, UART5, UART7 and UART8.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3 or USART6.
new_state | TRUE or FALSE
Return values
none

Definition at line 263 of file at32f435_437_usart.c.

Referenced by usart_configuration(), and usart_spi_configuration().

◆ usart_data_receive()

uint16_t usart_data_receive ( usart_type * usart_x )

return the most recent received data by the usart peripheral.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
Return values
the received data.

Definition at line 425 of file at32f435_437_usart.c.

Referenced by main(), SC_USART_IRQHandler(), USART1_IRQHandler(), USART2_IRQHandler(), and USART3_IRQHandler().

◆ usart_data_transmit()

void usart_data_transmit | ( | usart_type * | usart_x,
 |  | uint16_t | data
 | ) |  |

transmit single data through the usart peripheral.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
data | the data to transmit.
Return values
none

Definition at line 413 of file at32f435_437_usart.c.

Referenced by back_err(), back_ok(), fputc(), main(), rs485_send_data(), USART2_IRQHandler(), USART3_IRQHandler(), and usart_send_data().

◆ usart_de_polarity_set()

void usart_de_polarity_set | ( | usart_type * | usart_x,
 |  | usart_de_polarity_type | de_polarity
 | ) |  |

set the usart's de polarity.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3
de_polarity | the usart de polarity selection. this parameter can be: USART_DE_POLARITY_HIGH or USART_DE_POLARITY_LOW.
Return values
none

Definition at line 701 of file at32f435_437_usart.c.

Referenced by rs485_config().

◆ usart_dma_receiver_enable()

void usart_dma_receiver_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart's dma receiver interface.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
new_state | new state of the dma request sources. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 318 of file at32f435_437_usart.c.

Referenced by usart_configuration().

◆ usart_dma_transmitter_enable()

void usart_dma_transmitter_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart's dma transmitter interface.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
new_state | new state of the dma request sources. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 304 of file at32f435_437_usart.c.

Referenced by uart_init(), and usart_configuration().

◆ usart_enable()

void usart_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified usart peripheral.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
new_state | new state of the usart peripheral. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 196 of file at32f435_437_usart.c.

Referenced by rs485_config(), swj_dp_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_usart_config().

◆ usart_flag_clear()

void usart_flag_clear | ( | usart_type * | usart_x,
 |  | uint32_t | flag
 | ) |  |

clear the usart's pending flags.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
flag specifies the flag to clear. this parameter can be any combination of the following values:
  • USART_CTSCF_FLAG: (not available for UART4,UART5,USART6,UART7 and UART8).
  • USART_BFF_FLAG:
  • USART_TDC_FLAG:
  • USART_RDBF_FLAG:
  • USART_PERR_FLAG:
  • USART_FERR_FLAG:
  • USART_NERR_FLAG:
  • USART_ROERR_FLAG:
  • USART_IDLEF_FLAG:
Note
  • USART_PERR_FLAG, USART_FERR_FLAG, USART_NERR_FLAG, USART_ROERR_FLAG and USART_IDLEF_FLAG are cleared by software sequence: a read operation to usart sts register (usart_flag_get()) followed by a read operation to usart dt register (usart_data_receive()).
  • USART_RDBF_FLAG can be also cleared by a read to the usart dt register(usart_data_receive()).
  • USART_TDC_FLAG can be also cleared by software sequence: a read operation to usart sts register (usart_flag_get()) followed by a write operation to usart dt register (usart_data_transmit()).
  • USART_TDBE_FLAG is cleared only by a write to the usart dt register(usart_data_transmit()).
Return values
none

< usart parity error flag

< usart framing error flag

< usart noise error flag

< usart receiver overflow error flag

< usart idle flag

Definition at line 636 of file at32f435_437_usart.c.

Referenced by rs485_config().

◆ usart_flag_get()

flag_status usart_flag_get | ( | usart_type * | usart_x,
 |  | uint32_t | flag
 | ) |  |

check whether the specified usart flag is set or not.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
flag specifies the flag to check. this parameter can be one of the following values:
  • USART_CTSCF_FLAG: cts change flag (not available for UART4,UART5,USART6,UART7 and UART8)
  • USART_BFF_FLAG: break frame flag
  • USART_TDBE_FLAG: transmit data buffer empty flag
  • USART_TDC_FLAG: transmit data complete flag
  • USART_RDBF_FLAG: receive data buffer full flag
  • USART_IDLEF_FLAG: idle flag
  • USART_ROERR_FLAG: receiver overflow error flag
  • USART_NERR_FLAG: noise error flag
  • USART_FERR_FLAG: framing error flag
  • USART_PERR_FLAG: parity error flag
Return values
the new state of usart_flag (SET or RESET).

Definition at line 598 of file at32f435_437_usart.c.

Referenced by back_err(), back_ok(), fputc(), main(), rs485_send_data(), SC_USART_IRQHandler(), USART1_IRQHandler(), USART2_IRQHandler(), USART3_IRQHandler(), and usart_send_data().

◆ usart_hardware_flow_control_set()

void usart_hardware_flow_control_set | ( | usart_type * | usart_x,
 |  | usart_hardware_flow_control_type | flow_state
 | ) |  |

configure the usart's hardware flow control.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3
flow_state specifies the hardware flow control. this parameter can be one of the following values:
  • USART_HARDWARE_FLOW_NONE
  • USART_HARDWARE_FLOW_RTS,
  • USART_HARDWARE_FLOW_CTS,
  • USART_HARDWARE_FLOW_RTS_CTS
Return values
none

Definition at line 555 of file at32f435_437_usart.c.

Referenced by usart1_config(), and usart_configuration().

◆ usart_id_bit_num_set()

void usart_id_bit_num_set | ( | usart_type * | usart_x,
 |  | usart_identification_bit_num_type | id_bit_num
 | ) |  |

set the usart's identification bit num.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7,or UART8.
id_bit_num | the usart wakeup identification bit num. this parameter can be: USART_ID_FIXED_4_BIT or USART_ID_RELATED_DATA_BIT.
Return values
none

Definition at line 687 of file at32f435_437_usart.c.

◆ usart_init()

void usart_init | ( | usart_type * | usart_x,
 |  | uint32_t | baud_rate,
 |  | usart_data_bit_num_type | data_bit,
 |  | usart_stop_bit_num_type | stop_bit
 | ) |  |

initialize the usart peripheral according to the specified parameters.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 ,UART5, USART6, UART7 or UART8.
baud_rate | configure the usart communication baud rate.
data_bit data bits transmitted or received in a frame this parameter can be one of the following values:
  • USART_DATA_7BITS
  • USART_DATA_8BITS
  • USART_DATA_9BITS.
stop_bit stop bits transmitted this parameter can be one of the following values:
  • USART_STOP_1_BIT
  • USART_STOP_0_5_BIT.
  • USART_STOP_2_BIT
  • USART_STOP_1_5_BIT.
Return values
none

Definition at line 115 of file at32f435_437_usart.c.

Referenced by rs485_config(), swj_dp_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_usart_config().

◆ usart_interrupt_enable()

void usart_interrupt_enable | ( | usart_type * | usart_x,
 |  | uint32_t | usart_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified usart interrupts.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
usart_int specifies the USART interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • USART_IDLE_INT: idle interrupt
  • USART_RDBF_INT: rdbf interrupt
  • USART_TDC_INT: tdc interrupt
  • USART_TDBE_INT: tdbe interrupt
  • USART_PERR_INT: perr interrupt
  • USART_BF_INT: break frame interrupt
  • USART_ERR_INT: err interrupt
  • USART_CTSCF_INT: ctscf interrupt
new_state | new state of the specified usart interrupts. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 287 of file at32f435_437_usart.c.

Referenced by data_take(), main(), rs485_config(), SC_USART_IRQHandler(), uart_init(), usart1_config(), USART2_IRQHandler(), USART3_IRQHandler(), usart_configuration(), and usb_usart_config().

◆ usart_irda_low_power_enable()

void usart_irda_low_power_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

configure the usart's irda low power.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
new_state | new state of the irda mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 537 of file at32f435_437_usart.c.

◆ usart_irda_mode_enable()

void usart_irda_mode_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart's irda interface.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
new_state | new state of the irda mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 523 of file at32f435_437_usart.c.

Referenced by usart_configuration().

◆ usart_irda_smartcard_division_set()

void usart_irda_smartcard_division_set | ( | usart_type * | usart_x,
 |  | uint8_t | div_val
 | ) |  |

config the irda/smartcard division.

Note
the division are not available for UART4, UART5, UART7 or UART8.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3 or USART6.
div_val | specifies the division.
Return values
none

Definition at line 465 of file at32f435_437_usart.c.

Referenced by usart_configuration().

◆ usart_lin_mode_enable()

void usart_lin_mode_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart lin mode.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
new_state | new state of the usart lin mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 400 of file at32f435_437_usart.c.

◆ usart_parity_selection_config()

void usart_parity_selection_config | ( | usart_type * | usart_x,
 |  | usart_parity_selection_type | parity
 | ) |  |

usart parity selection config.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 ,UART5, USART6, UART7 or UART8.
parity select the none, odd or even parity. this parameter can be one of the following values:
  • USART_PARITY_NONE
  • USART_PARITY_EVEN.
  • USART_PARITY_ODD
Return values
none

Definition at line 168 of file at32f435_437_usart.c.

Referenced by uart_init(), usart1_config(), usart_configuration(), and usb_usart_config().

◆ usart_receiver_enable()

void usart_receiver_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

usart receiver enable.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 ,UART5, USART6, UART7 or UART8.
new_state | TRUE or FALSE.
Return values
none

Definition at line 222 of file at32f435_437_usart.c.

Referenced by rs485_config(), uart_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_usart_config().

◆ usart_receiver_mute_enable()

void usart_receiver_mute_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

config the usart in mute mode in multi-processor communication.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
new_state | new state of the usart mute mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 370 of file at32f435_437_usart.c.

Referenced by usart_configuration().

◆ usart_reset()

void usart_reset ( usart_type * usart_x )

deinitialize the usart peripheral registers to their default reset values.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7,or UART8.
Return values
none

Definition at line 52 of file at32f435_437_usart.c.

◆ usart_rs485_delay_time_config()

void usart_rs485_delay_time_config | ( | usart_type * | usart_x,
 |  | uint8_t | start_delay_time,
 |  | uint8_t | complete_delay_time
 | ) |  |

configure the usart's rs485 transmit delay time.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3
start_delay_time | transmit start delay time.
complete_delay_time | transmit complete delay time.
Return values
none

Definition at line 658 of file at32f435_437_usart.c.

Referenced by rs485_config().

◆ usart_rs485_mode_enable()

void usart_rs485_mode_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart's rs485 mode.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3
new_state | new state of the irda mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 715 of file at32f435_437_usart.c.

Referenced by rs485_config().

◆ usart_single_line_halfduplex_select()

void usart_single_line_halfduplex_select | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart single line bidirectional half-duplex communication.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
new_state | new state of the single line half-duplex select. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 509 of file at32f435_437_usart.c.

Referenced by usart_configuration().

◆ usart_smartcard_guard_time_set()

void usart_smartcard_guard_time_set | ( | usart_type * | usart_x,
 |  | uint8_t | guard_time_val
 | ) |  |

config the specified usart smartcard guard time.

Note
The guard time bits are not available for UART4, UART5, UART7 or UART8.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3 or USART6.
guard_time_val | specifies the guard time (0x00~0xFF).
Return values
none

Definition at line 451 of file at32f435_437_usart.c.

Referenced by usart_configuration().

◆ usart_smartcard_mode_enable()

void usart_smartcard_mode_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart smart card mode.

Note
the smart card mode are not available for UART4, UART5, UART7 or UART8.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3 or USART6.
new_state | new state of the smart card mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 480 of file at32f435_437_usart.c.

Referenced by usart_configuration().

◆ usart_smartcard_nack_set()

void usart_smartcard_nack_set | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable nack transmission in smartcard mode.

Note
the smart card nack are not available for UART4, UART5, UART7 or UART8.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3 or USART6.
new_state | new state of the nack transmission. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 495 of file at32f435_437_usart.c.

Referenced by usart_configuration().

◆ usart_transmit_receive_pin_swap()

void usart_transmit_receive_pin_swap | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

swap the usart's transmit receive pin.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7,or UART8.
new_state | new state of the usart peripheral. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 673 of file at32f435_437_usart.c.

Referenced by usart_configuration().

◆ usart_transmitter_enable()

void usart_transmitter_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

usart transmitter enable.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 ,UART5, USART6, UART7 or UART8.
new_state | TRUE or FALSE.
Return values
none

Definition at line 209 of file at32f435_437_usart.c.

Referenced by rs485_config(), swj_dp_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_usart_config().

◆ usart_wakeup_id_set()

void usart_wakeup_id_set | ( | usart_type * | usart_x,
 |  | uint8_t | usart_id
 | ) |  |

set the wakeup id of the usart.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
usart_id | the matching id(0x0~0xFF).
Return values
none

Definition at line 331 of file at32f435_437_usart.c.

Referenced by usart_configuration().

◆ usart_wakeup_mode_set()

void usart_wakeup_mode_set | ( | usart_type * | usart_x,
 |  | usart_wakeup_mode_type | wakeup_mode
 | ) |  |

select the usart wakeup method in multi-processor communication.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
wakeup_mode determines the way to wake up usart method. this parameter can be one of the following values:
  • USART_WAKEUP_BY_IDLE_FRAME
  • USART_WAKEUP_BY_MATCHING_ID
Return values
none

Definition at line 356 of file at32f435_437_usart.c.

Referenced by usart_configuration().


AT32F435/437 Firmwary Library: USART_private_functions

Functions
USART_private_functions
AT32F435_437_periph_driver » USART

Functions

void | usart_reset (usart_type *usart_x)
deinitialize the usart peripheral registers to their default reset values. More...
void | usart_init (usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters. More...
void | usart_parity_selection_config (usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config. More...
void | usart_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral. More...
void | usart_transmitter_enable (usart_type *usart_x, confirm_state new_state)
usart transmitter enable. More...
void | usart_receiver_enable (usart_type *usart_x, confirm_state new_state)
usart receiver enable. More...
void | usart_clock_config (usart_type *usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
usart clock config. More...
void | usart_clock_enable (usart_type *usart_x, confirm_state new_state)
usart enable the ck pin. More...
void | usart_interrupt_enable (usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts. More...
void | usart_dma_transmitter_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface. More...
void | usart_dma_receiver_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma receiver interface. More...
void | usart_wakeup_id_set (usart_type *usart_x, uint8_t usart_id)
set the wakeup id of the usart. More...
void | usart_wakeup_mode_set (usart_type *usart_x, usart_wakeup_mode_type wakeup_mode)
select the usart wakeup method in multi-processor communication. More...
void | usart_receiver_mute_enable (usart_type *usart_x, confirm_state new_state)
config the usart in mute mode in multi-processor communication. More...
void | usart_break_bit_num_set (usart_type *usart_x, usart_break_bit_num_type break_bit)
set the usart break frame bit num. More...
void | usart_lin_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart lin mode. More...
void | usart_data_transmit (usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral. More...
uint16_t | usart_data_receive (usart_type *usart_x)
return the most recent received data by the usart peripheral. More...
void | usart_break_send (usart_type *usart_x)
transmit break characters. More...
void | usart_smartcard_guard_time_set (usart_type *usart_x, uint8_t guard_time_val)
config the specified usart smartcard guard time. More...
void | usart_irda_smartcard_division_set (usart_type *usart_x, uint8_t div_val)
config the irda/smartcard division. More...
void | usart_smartcard_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart smart card mode. More...
void | usart_smartcard_nack_set (usart_type *usart_x, confirm_state new_state)
enable or disable nack transmission in smartcard mode. More...
void | usart_single_line_halfduplex_select (usart_type *usart_x, confirm_state new_state)
enable or disable the usart single line bidirectional half-duplex communication. More...
void | usart_irda_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's irda interface. More...
void | usart_irda_low_power_enable (usart_type *usart_x, confirm_state new_state)
configure the usart's irda low power. More...
void | usart_hardware_flow_control_set (usart_type *usart_x, usart_hardware_flow_control_type flow_state)
configure the usart's hardware flow control. More...
flag_status | usart_flag_get (usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not. More...
void | usart_flag_clear (usart_type *usart_x, uint32_t flag)
clear the usart's pending flags. More...
void | usart_rs485_delay_time_config (usart_type *usart_x, uint8_t start_delay_time, uint8_t complete_delay_time)
configure the usart's rs485 transmit delay time. More...
void | usart_transmit_receive_pin_swap (usart_type *usart_x, confirm_state new_state)
swap the usart's transmit receive pin. More...
void | usart_id_bit_num_set (usart_type *usart_x, usart_identification_bit_num_type id_bit_num)
set the usart's identification bit num. More...
void | usart_de_polarity_set (usart_type *usart_x, usart_de_polarity_type de_polarity)
set the usart's de polarity. More...
void | usart_rs485_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's rs485 mode. More...

Detailed Description

Function Documentation

◆ usart_break_bit_num_set()

void usart_break_bit_num_set | ( | usart_type * | usart_x,
 |  | usart_break_bit_num_type | break_bit
 | ) |  |

set the usart break frame bit num.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
break_bit specifies the break bit num. this parameter can be one of the following values:
  • USART_BREAK_10BITS
  • USART_BREAK_11BITS
Return values
none

Definition at line 386 of file at32f435_437_usart.c.

◆ usart_break_send()

void usart_break_send ( usart_type * usart_x )

transmit break characters.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
Return values
none

Definition at line 437 of file at32f435_437_usart.c.

◆ usart_clock_config()

void usart_clock_config | ( | usart_type * | usart_x,
 |  | usart_clock_polarity_type | clk_pol,
 |  | usart_clock_phase_type | clk_pha,
 |  | usart_lbcp_type | clk_lb
 | ) |  |

usart clock config.

Note
clock config are not available for UART4, UART5, UART7 and UART8.
Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3 or USART6.
clk_pol polarity of the clock output on the ck pin. this parameter can be one of the following values:
  • USART_CLOCK_POLARITY_LOW
  • USART_CLOCK_POLARITY_HIGH
clk_pha phase of the clock output on the ck pin. this parameter can be one of the following values:
  • USART_CLOCK_PHASE_1EDGE
  • USART_CLOCK_PHASE_2EDGE
clk_lb whether the clock pulse of the last data bit transmitted (MSB) is outputted on the ck pin. this parameter can be one of the following values:
  • USART_CLOCK_LAST_BIT_NONE
  • USART_CLOCK_LAST_BIT_OUTPUT
Return values
none

Definition at line 247 of file at32f435_437_usart.c.

Referenced by usart_configuration(), and usart_spi_configuration().

◆ usart_clock_enable()

void usart_clock_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

usart enable the ck pin.

Note
clock enable are not available for UART4, UART5, UART7 and UART8.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3 or USART6.
new_state | TRUE or FALSE
Return values
none

Definition at line 263 of file at32f435_437_usart.c.

Referenced by usart_configuration(), and usart_spi_configuration().

◆ usart_data_receive()

uint16_t usart_data_receive ( usart_type * usart_x )

return the most recent received data by the usart peripheral.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
Return values
the received data.

Definition at line 425 of file at32f435_437_usart.c.

Referenced by main(), SC_USART_IRQHandler(), USART1_IRQHandler(), USART2_IRQHandler(), and USART3_IRQHandler().

◆ usart_data_transmit()

void usart_data_transmit | ( | usart_type * | usart_x,
 |  | uint16_t | data
 | ) |  |

transmit single data through the usart peripheral.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
data | the data to transmit.
Return values
none

Definition at line 413 of file at32f435_437_usart.c.

Referenced by back_err(), back_ok(), fputc(), main(), rs485_send_data(), USART2_IRQHandler(), USART3_IRQHandler(), and usart_send_data().

◆ usart_de_polarity_set()

void usart_de_polarity_set | ( | usart_type * | usart_x,
 |  | usart_de_polarity_type | de_polarity
 | ) |  |

set the usart's de polarity.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3
de_polarity | the usart de polarity selection. this parameter can be: USART_DE_POLARITY_HIGH or USART_DE_POLARITY_LOW.
Return values
none

Definition at line 701 of file at32f435_437_usart.c.

Referenced by rs485_config().

◆ usart_dma_receiver_enable()

void usart_dma_receiver_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart's dma receiver interface.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
new_state | new state of the dma request sources. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 318 of file at32f435_437_usart.c.

Referenced by usart_configuration().

◆ usart_dma_transmitter_enable()

void usart_dma_transmitter_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart's dma transmitter interface.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
new_state | new state of the dma request sources. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 304 of file at32f435_437_usart.c.

Referenced by uart_init(), and usart_configuration().

◆ usart_enable()

void usart_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified usart peripheral.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
new_state | new state of the usart peripheral. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 196 of file at32f435_437_usart.c.

Referenced by rs485_config(), swj_dp_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_usart_config().

◆ usart_flag_clear()

void usart_flag_clear | ( | usart_type * | usart_x,
 |  | uint32_t | flag
 | ) |  |

clear the usart's pending flags.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
flag specifies the flag to clear. this parameter can be any combination of the following values:
  • USART_CTSCF_FLAG: (not available for UART4,UART5,USART6,UART7 and UART8).
  • USART_BFF_FLAG:
  • USART_TDC_FLAG:
  • USART_RDBF_FLAG:
  • USART_PERR_FLAG:
  • USART_FERR_FLAG:
  • USART_NERR_FLAG:
  • USART_ROERR_FLAG:
  • USART_IDLEF_FLAG:
Note
  • USART_PERR_FLAG, USART_FERR_FLAG, USART_NERR_FLAG, USART_ROERR_FLAG and USART_IDLEF_FLAG are cleared by software sequence: a read operation to usart sts register (usart_flag_get()) followed by a read operation to usart dt register (usart_data_receive()).
  • USART_RDBF_FLAG can be also cleared by a read to the usart dt register(usart_data_receive()).
  • USART_TDC_FLAG can be also cleared by software sequence: a read operation to usart sts register (usart_flag_get()) followed by a write operation to usart dt register (usart_data_transmit()).
  • USART_TDBE_FLAG is cleared only by a write to the usart dt register(usart_data_transmit()).
Return values
none

< usart parity error flag

< usart framing error flag

< usart noise error flag

< usart receiver overflow error flag

< usart idle flag

Definition at line 636 of file at32f435_437_usart.c.

Referenced by rs485_config().

◆ usart_flag_get()

flag_status usart_flag_get | ( | usart_type * | usart_x,
 |  | uint32_t | flag
 | ) |  |

check whether the specified usart flag is set or not.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
flag specifies the flag to check. this parameter can be one of the following values:
  • USART_CTSCF_FLAG: cts change flag (not available for UART4,UART5,USART6,UART7 and UART8)
  • USART_BFF_FLAG: break frame flag
  • USART_TDBE_FLAG: transmit data buffer empty flag
  • USART_TDC_FLAG: transmit data complete flag
  • USART_RDBF_FLAG: receive data buffer full flag
  • USART_IDLEF_FLAG: idle flag
  • USART_ROERR_FLAG: receiver overflow error flag
  • USART_NERR_FLAG: noise error flag
  • USART_FERR_FLAG: framing error flag
  • USART_PERR_FLAG: parity error flag
Return values
the new state of usart_flag (SET or RESET).

Definition at line 598 of file at32f435_437_usart.c.

Referenced by back_err(), back_ok(), fputc(), main(), rs485_send_data(), SC_USART_IRQHandler(), USART1_IRQHandler(), USART2_IRQHandler(), USART3_IRQHandler(), and usart_send_data().

◆ usart_hardware_flow_control_set()

void usart_hardware_flow_control_set | ( | usart_type * | usart_x,
 |  | usart_hardware_flow_control_type | flow_state
 | ) |  |

configure the usart's hardware flow control.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3
flow_state specifies the hardware flow control. this parameter can be one of the following values:
  • USART_HARDWARE_FLOW_NONE
  • USART_HARDWARE_FLOW_RTS,
  • USART_HARDWARE_FLOW_CTS,
  • USART_HARDWARE_FLOW_RTS_CTS
Return values
none

Definition at line 555 of file at32f435_437_usart.c.

Referenced by usart1_config(), and usart_configuration().

◆ usart_id_bit_num_set()

void usart_id_bit_num_set | ( | usart_type * | usart_x,
 |  | usart_identification_bit_num_type | id_bit_num
 | ) |  |

set the usart's identification bit num.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7,or UART8.
id_bit_num | the usart wakeup identification bit num. this parameter can be: USART_ID_FIXED_4_BIT or USART_ID_RELATED_DATA_BIT.
Return values
none

Definition at line 687 of file at32f435_437_usart.c.

◆ usart_init()

void usart_init | ( | usart_type * | usart_x,
 |  | uint32_t | baud_rate,
 |  | usart_data_bit_num_type | data_bit,
 |  | usart_stop_bit_num_type | stop_bit
 | ) |  |

initialize the usart peripheral according to the specified parameters.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 ,UART5, USART6, UART7 or UART8.
baud_rate | configure the usart communication baud rate.
data_bit data bits transmitted or received in a frame this parameter can be one of the following values:
  • USART_DATA_7BITS
  • USART_DATA_8BITS
  • USART_DATA_9BITS.
stop_bit stop bits transmitted this parameter can be one of the following values:
  • USART_STOP_1_BIT
  • USART_STOP_0_5_BIT.
  • USART_STOP_2_BIT
  • USART_STOP_1_5_BIT.
Return values
none

Definition at line 115 of file at32f435_437_usart.c.

Referenced by rs485_config(), swj_dp_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_usart_config().

◆ usart_interrupt_enable()

void usart_interrupt_enable | ( | usart_type * | usart_x,
 |  | uint32_t | usart_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified usart interrupts.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
usart_int specifies the USART interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • USART_IDLE_INT: idle interrupt
  • USART_RDBF_INT: rdbf interrupt
  • USART_TDC_INT: tdc interrupt
  • USART_TDBE_INT: tdbe interrupt
  • USART_PERR_INT: perr interrupt
  • USART_BF_INT: break frame interrupt
  • USART_ERR_INT: err interrupt
  • USART_CTSCF_INT: ctscf interrupt
new_state | new state of the specified usart interrupts. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 287 of file at32f435_437_usart.c.

Referenced by data_take(), main(), rs485_config(), SC_USART_IRQHandler(), uart_init(), usart1_config(), USART2_IRQHandler(), USART3_IRQHandler(), usart_configuration(), and usb_usart_config().

◆ usart_irda_low_power_enable()

void usart_irda_low_power_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

configure the usart's irda low power.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
new_state | new state of the irda mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 537 of file at32f435_437_usart.c.

◆ usart_irda_mode_enable()

void usart_irda_mode_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart's irda interface.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
new_state | new state of the irda mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 523 of file at32f435_437_usart.c.

Referenced by usart_configuration().

◆ usart_irda_smartcard_division_set()

void usart_irda_smartcard_division_set | ( | usart_type * | usart_x,
 |  | uint8_t | div_val
 | ) |  |

config the irda/smartcard division.

Note
the division are not available for UART4, UART5, UART7 or UART8.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3 or USART6.
div_val | specifies the division.
Return values
none

Definition at line 465 of file at32f435_437_usart.c.

Referenced by usart_configuration().

◆ usart_lin_mode_enable()

void usart_lin_mode_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart lin mode.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
new_state | new state of the usart lin mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 400 of file at32f435_437_usart.c.

◆ usart_parity_selection_config()

void usart_parity_selection_config | ( | usart_type * | usart_x,
 |  | usart_parity_selection_type | parity
 | ) |  |

usart parity selection config.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 ,UART5, USART6, UART7 or UART8.
parity select the none, odd or even parity. this parameter can be one of the following values:
  • USART_PARITY_NONE
  • USART_PARITY_EVEN.
  • USART_PARITY_ODD
Return values
none

Definition at line 168 of file at32f435_437_usart.c.

Referenced by uart_init(), usart1_config(), usart_configuration(), and usb_usart_config().

◆ usart_receiver_enable()

void usart_receiver_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

usart receiver enable.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 ,UART5, USART6, UART7 or UART8.
new_state | TRUE or FALSE.
Return values
none

Definition at line 222 of file at32f435_437_usart.c.

Referenced by rs485_config(), uart_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_usart_config().

◆ usart_receiver_mute_enable()

void usart_receiver_mute_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

config the usart in mute mode in multi-processor communication.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
new_state | new state of the usart mute mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 370 of file at32f435_437_usart.c.

Referenced by usart_configuration().

◆ usart_reset()

void usart_reset ( usart_type * usart_x )

deinitialize the usart peripheral registers to their default reset values.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7,or UART8.
Return values
none

Definition at line 52 of file at32f435_437_usart.c.

◆ usart_rs485_delay_time_config()

void usart_rs485_delay_time_config | ( | usart_type * | usart_x,
 |  | uint8_t | start_delay_time,
 |  | uint8_t | complete_delay_time
 | ) |  |

configure the usart's rs485 transmit delay time.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3
start_delay_time | transmit start delay time.
complete_delay_time | transmit complete delay time.
Return values
none

Definition at line 658 of file at32f435_437_usart.c.

Referenced by rs485_config().

◆ usart_rs485_mode_enable()

void usart_rs485_mode_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart's rs485 mode.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3
new_state | new state of the irda mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 715 of file at32f435_437_usart.c.

Referenced by rs485_config().

◆ usart_single_line_halfduplex_select()

void usart_single_line_halfduplex_select | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart single line bidirectional half-duplex communication.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
new_state | new state of the single line half-duplex select. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 509 of file at32f435_437_usart.c.

Referenced by usart_configuration().

◆ usart_smartcard_guard_time_set()

void usart_smartcard_guard_time_set | ( | usart_type * | usart_x,
 |  | uint8_t | guard_time_val
 | ) |  |

config the specified usart smartcard guard time.

Note
The guard time bits are not available for UART4, UART5, UART7 or UART8.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3 or USART6.
guard_time_val | specifies the guard time (0x00~0xFF).
Return values
none

Definition at line 451 of file at32f435_437_usart.c.

Referenced by usart_configuration().

◆ usart_smartcard_mode_enable()

void usart_smartcard_mode_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart smart card mode.

Note
the smart card mode are not available for UART4, UART5, UART7 or UART8.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3 or USART6.
new_state | new state of the smart card mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 480 of file at32f435_437_usart.c.

Referenced by usart_configuration().

◆ usart_smartcard_nack_set()

void usart_smartcard_nack_set | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable nack transmission in smartcard mode.

Note
the smart card nack are not available for UART4, UART5, UART7 or UART8.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3 or USART6.
new_state | new state of the nack transmission. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 495 of file at32f435_437_usart.c.

Referenced by usart_configuration().

◆ usart_transmit_receive_pin_swap()

void usart_transmit_receive_pin_swap | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

swap the usart's transmit receive pin.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7,or UART8.
new_state | new state of the usart peripheral. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 673 of file at32f435_437_usart.c.

Referenced by usart_configuration().

◆ usart_transmitter_enable()

void usart_transmitter_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

usart transmitter enable.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 ,UART5, USART6, UART7 or UART8.
new_state | TRUE or FALSE.
Return values
none

Definition at line 209 of file at32f435_437_usart.c.

Referenced by rs485_config(), swj_dp_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_usart_config().

◆ usart_wakeup_id_set()

void usart_wakeup_id_set | ( | usart_type * | usart_x,
 |  | uint8_t | usart_id
 | ) |  |

set the wakeup id of the usart.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
usart_id | the matching id(0x0~0xFF).
Return values
none

Definition at line 331 of file at32f435_437_usart.c.

Referenced by usart_configuration().

◆ usart_wakeup_mode_set()

void usart_wakeup_mode_set | ( | usart_type * | usart_x,
 |  | usart_wakeup_mode_type | wakeup_mode
 | ) |  |

select the usart wakeup method in multi-processor communication.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4, UART5, USART6, UART7 or UART8.
wakeup_mode determines the way to wake up usart method. this parameter can be one of the following values:
  • USART_WAKEUP_BY_IDLE_FRAME
  • USART_WAKEUP_BY_MATCHING_ID
Return values
none

Definition at line 356 of file at32f435_437_usart.c.

Referenced by usart_configuration().


AT32F435/437 Firmwary Library: USB

Modules | Macros
USB
AT32F435_437_periph_driver

USB driver modules. More...

Modules

USB_global_interrupts_definition
usb global interrupt mask
USB_global_interrupt_flags_definition
usb global interrupt flag
USB_global_setting_definition
usb global setting
USB_host_config_definition
USB_device_config_definition
USB_exported_enum_types
USB_exported_types
USB_exported_functions
USB_private_functions

Macros

#define | OTG_FIFO_SIZE 320
otg fifo size (word) More...
#define | USB_MAX_DATA_LENGTH 0x200
otg host max buffer length (byte) More...
#define | OTGFS_USB_GLOBAL
#define | OTGFS_USB_DEVICE
#define | OTGFS_USB_HOST

Detailed Description

USB driver modules.

Macro Definition Documentation

◆ OTG_FIFO_SIZE

#define OTG_FIFO_SIZE 320

otg fifo size (word)

otg usb total fifo size

Definition at line 316 of file at32f435_437_usb.h.

◆ OTGFS_USB_DEVICE

#define OTGFS_USB_DEVICE

Definition at line 324 of file at32f435_437_usb.h.

◆ OTGFS_USB_GLOBAL

#define OTGFS_USB_GLOBAL

Definition at line 323 of file at32f435_437_usb.h.

◆ OTGFS_USB_HOST

#define OTGFS_USB_HOST

Definition at line 325 of file at32f435_437_usb.h.

◆ USB_MAX_DATA_LENGTH

#define USB_MAX_DATA_LENGTH 0x200

otg host max buffer length (byte)

usb host maximum buffer size

Definition at line 321 of file at32f435_437_usb.h.


AT32F435/437 Firmwary Library: USB_global_interrupts_definition

Macros
USB_global_interrupts_definition
AT32F435_437_periph_driver » USB

usb global interrupt mask More...

Macros

#define | USB_OTG_MODEMIS_INT ((uint32_t)0x00000002)
#define | USB_OTG_OTGINT_INT ((uint32_t)0x00000004)
#define | USB_OTG_SOF_INT ((uint32_t)0x00000008)
#define | USB_OTG_RXFLVL_INT ((uint32_t)0x00000010)
#define | USB_OTG_NPTXFEMP_INT ((uint32_t)0x00000020)
#define | USB_OTG_GINNAKEFF_INT ((uint32_t)0x00000040)
#define | USB_OTG_GOUTNAKEFF_INT ((uint32_t)0x00000080)
#define | USB_OTG_ERLYSUSP_INT ((uint32_t)0x00000400)
#define | USB_OTG_USBSUSP_INT ((uint32_t)0x00000800)
#define | USB_OTG_USBRST_INT ((uint32_t)0x00001000)
#define | USB_OTG_ENUMDONE_INT ((uint32_t)0x00002000)
#define | USB_OTG_ISOOUTDROP_INT ((uint32_t)0x00004000)
#define | USB_OTG_EOPF_INT ((uint32_t)0x00008000)
#define | USB_OTG_IEPT_INT ((uint32_t)0x00040000)
#define | USB_OTG_OEPT_INT ((uint32_t)0x00080000)
#define | USB_OTG_INCOMISOIN_INT ((uint32_t)0x00100000)
#define | USB_OTG_INCOMPIP_INCOMPISOOUT_INT ((uint32_t)0x00200000)
#define | USB_OTG_PRT_INT ((uint32_t)0x01000000)
#define | USB_OTG_HCH_INT ((uint32_t)0x02000000)
#define | USB_OTG_PTXFEMP_INT ((uint32_t)0x04000000)
#define | USB_OTG_CONIDSCHG_INT ((uint32_t)0x10000000)
#define | USB_OTG_DISCON_INT ((uint32_t)0x20000000)
#define | USB_OTG_WKUP_INT ((uint32_t)0x80000000)

Detailed Description

usb global interrupt mask

Macro Definition Documentation

◆ USB_OTG_CONIDSCHG_INT

#define USB_OTG_CONIDSCHG_INT ((uint32_t)0x10000000)

usb otg connector id status change interrupt

Definition at line 72 of file at32f435_437_usb.h.

◆ USB_OTG_DISCON_INT

#define USB_OTG_DISCON_INT ((uint32_t)0x20000000)

usb otg disconnect detected interrupt

Definition at line 73 of file at32f435_437_usb.h.

◆ USB_OTG_ENUMDONE_INT

#define USB_OTG_ENUMDONE_INT ((uint32_t)0x00002000)

usb otg enumeration done interrupt

Definition at line 62 of file at32f435_437_usb.h.

◆ USB_OTG_EOPF_INT

#define USB_OTG_EOPF_INT ((uint32_t)0x00008000)

usb otg eop interrupt

Definition at line 64 of file at32f435_437_usb.h.

◆ USB_OTG_ERLYSUSP_INT

#define USB_OTG_ERLYSUSP_INT ((uint32_t)0x00000400)

usb otg early suspend interrupt

Definition at line 59 of file at32f435_437_usb.h.

◆ USB_OTG_GINNAKEFF_INT

#define USB_OTG_GINNAKEFF_INT ((uint32_t)0x00000040)

usb otg global non-periodic in nak effective interrupt

Definition at line 57 of file at32f435_437_usb.h.

◆ USB_OTG_GOUTNAKEFF_INT

#define USB_OTG_GOUTNAKEFF_INT ((uint32_t)0x00000080)

usb otg global out nak effective interrupt

Definition at line 58 of file at32f435_437_usb.h.

◆ USB_OTG_HCH_INT

#define USB_OTG_HCH_INT ((uint32_t)0x02000000)

usb otg host channel interrupt

Definition at line 70 of file at32f435_437_usb.h.

◆ USB_OTG_IEPT_INT

#define USB_OTG_IEPT_INT ((uint32_t)0x00040000)

usb otg in endpoint interrupt

Definition at line 65 of file at32f435_437_usb.h.

◆ USB_OTG_INCOMISOIN_INT

#define USB_OTG_INCOMISOIN_INT ((uint32_t)0x00100000)

usb otg incomplete isochronous in transfer interrupt

Definition at line 67 of file at32f435_437_usb.h.

◆ USB_OTG_INCOMPIP_INCOMPISOOUT_INT

#define USB_OTG_INCOMPIP_INCOMPISOOUT_INT ((uint32_t)0x00200000)

usb otg incomplete periodic transfer/isochronous out interrupt

Definition at line 68 of file at32f435_437_usb.h.

◆ USB_OTG_ISOOUTDROP_INT

#define USB_OTG_ISOOUTDROP_INT ((uint32_t)0x00004000)

usb otg isochronous out packet dropped interrut

Definition at line 63 of file at32f435_437_usb.h.

◆ USB_OTG_MODEMIS_INT

#define USB_OTG_MODEMIS_INT ((uint32_t)0x00000002)

usb otg mode mismatch interrupt

Definition at line 52 of file at32f435_437_usb.h.

◆ USB_OTG_NPTXFEMP_INT

#define USB_OTG_NPTXFEMP_INT ((uint32_t)0x00000020)

usb otg non-periodic tx fifo empty interrupt

Definition at line 56 of file at32f435_437_usb.h.

◆ USB_OTG_OEPT_INT

#define USB_OTG_OEPT_INT ((uint32_t)0x00080000)

usb otg out endpoint interrupt

Definition at line 66 of file at32f435_437_usb.h.

◆ USB_OTG_OTGINT_INT

#define USB_OTG_OTGINT_INT ((uint32_t)0x00000004)

usb otg interrupt

Definition at line 53 of file at32f435_437_usb.h.

◆ USB_OTG_PRT_INT

#define USB_OTG_PRT_INT ((uint32_t)0x01000000)

usb otg host port interrupt

Definition at line 69 of file at32f435_437_usb.h.

◆ USB_OTG_PTXFEMP_INT

#define USB_OTG_PTXFEMP_INT ((uint32_t)0x04000000)

usb otg periodic txfifo empty interrupt

Definition at line 71 of file at32f435_437_usb.h.

◆ USB_OTG_RXFLVL_INT

#define USB_OTG_RXFLVL_INT ((uint32_t)0x00000010)

usb otg receive fifo non-empty interrupt

Definition at line 55 of file at32f435_437_usb.h.

◆ USB_OTG_SOF_INT

#define USB_OTG_SOF_INT ((uint32_t)0x00000008)

usb otg sof interrupt

Definition at line 54 of file at32f435_437_usb.h.

◆ USB_OTG_USBRST_INT

#define USB_OTG_USBRST_INT ((uint32_t)0x00001000)

usb otg reset interrupt

Definition at line 61 of file at32f435_437_usb.h.

◆ USB_OTG_USBSUSP_INT

#define USB_OTG_USBSUSP_INT ((uint32_t)0x00000800)

usb otg suspend interrupt

Definition at line 60 of file at32f435_437_usb.h.

◆ USB_OTG_WKUP_INT

#define USB_OTG_WKUP_INT ((uint32_t)0x80000000)

usb otg wakeup interrupt

Definition at line 74 of file at32f435_437_usb.h.


AT32F435/437 Firmwary Library: USB_global_interrupt_flags_definition

Macros
USB_global_interrupt_flags_definition
AT32F435_437_periph_driver » USB

usb global interrupt flag More...

Macros

#define | USB_OTG_CURMODE ((uint32_t)0x00000001)
#define | USB_OTG_MODEMIS_FLAG ((uint32_t)0x00000002)
#define | USB_OTG_OTGINT_FLAG ((uint32_t)0x00000004)
#define | USB_OTG_SOF_FLAG ((uint32_t)0x00000008)
#define | USB_OTG_RXFLVL_FLAG ((uint32_t)0x00000010)
#define | USB_OTG_NPTXFEMP_FLAG ((uint32_t)0x00000020)
#define | USB_OTG_GINNAKEFF_FLAG ((uint32_t)0x00000040)
#define | USB_OTG_GOUTNAKEFF_FLAG ((uint32_t)0x00000080)
#define | USB_OTG_ERLYSUSP_FLAG ((uint32_t)0x00000400)
#define | USB_OTG_USBSUSP_FLAG ((uint32_t)0x00000800)
#define | USB_OTG_USBRST_FLAG ((uint32_t)0x00001000)
#define | USB_OTG_ENUMDONE_FLAG ((uint32_t)0x00002000)
#define | USB_OTG_ISOOUTDROP_FLAG ((uint32_t)0x00004000)
#define | USB_OTG_EOPF_FLAG ((uint32_t)0x00008000)
#define | USB_OTG_IEPT_FLAG ((uint32_t)0x00040000)
#define | USB_OTG_OEPT_FLAG ((uint32_t)0x00080000)
#define | USB_OTG_INCOMISOIN_FLAG ((uint32_t)0x00100000)
#define | USB_OTG_INCOMPIP_INCOMPISOOUT_FLAG ((uint32_t)0x00200000)
#define | USB_OTG_PRT_FLAG ((uint32_t)0x01000000)
#define | USB_OTG_HCH_FLAG ((uint32_t)0x02000000)
#define | USB_OTG_PTXFEMP_FLAG ((uint32_t)0x04000000)
#define | USB_OTG_CONIDSCHG_FLAG ((uint32_t)0x10000000)
#define | USB_OTG_DISCON_FLAG ((uint32_t)0x20000000)
#define | USB_OTG_WKUP_FLAG ((uint32_t)0x80000000)

Detailed Description

usb global interrupt flag

Macro Definition Documentation

◆ USB_OTG_CONIDSCHG_FLAG

#define USB_OTG_CONIDSCHG_FLAG ((uint32_t)0x10000000)

usb otg connector id status change flag

Definition at line 106 of file at32f435_437_usb.h.

◆ USB_OTG_CURMODE

#define USB_OTG_CURMODE ((uint32_t)0x00000001)

usb otg current mode

Definition at line 85 of file at32f435_437_usb.h.

◆ USB_OTG_DISCON_FLAG

#define USB_OTG_DISCON_FLAG ((uint32_t)0x20000000)

usb otg disconnect detected flag

Definition at line 107 of file at32f435_437_usb.h.

◆ USB_OTG_ENUMDONE_FLAG

#define USB_OTG_ENUMDONE_FLAG ((uint32_t)0x00002000)

usb otg enumeration done flag

Definition at line 96 of file at32f435_437_usb.h.

◆ USB_OTG_EOPF_FLAG

#define USB_OTG_EOPF_FLAG ((uint32_t)0x00008000)

usb otg eop flag

Definition at line 98 of file at32f435_437_usb.h.

◆ USB_OTG_ERLYSUSP_FLAG

#define USB_OTG_ERLYSUSP_FLAG ((uint32_t)0x00000400)

usb otg early suspend flag

Definition at line 93 of file at32f435_437_usb.h.

◆ USB_OTG_GINNAKEFF_FLAG

#define USB_OTG_GINNAKEFF_FLAG ((uint32_t)0x00000040)

usb otg global non-periodic in nak effective flag

Definition at line 91 of file at32f435_437_usb.h.

◆ USB_OTG_GOUTNAKEFF_FLAG

#define USB_OTG_GOUTNAKEFF_FLAG ((uint32_t)0x00000080)

usb otg global out nak effective flag

Definition at line 92 of file at32f435_437_usb.h.

◆ USB_OTG_HCH_FLAG

#define USB_OTG_HCH_FLAG ((uint32_t)0x02000000)

usb otg host channel flag

Definition at line 104 of file at32f435_437_usb.h.

◆ USB_OTG_IEPT_FLAG

#define USB_OTG_IEPT_FLAG ((uint32_t)0x00040000)

usb otg in endpoint flag

Definition at line 99 of file at32f435_437_usb.h.

◆ USB_OTG_INCOMISOIN_FLAG

#define USB_OTG_INCOMISOIN_FLAG ((uint32_t)0x00100000)

usb otg incomplete isochronous in transfer flag

Definition at line 101 of file at32f435_437_usb.h.

◆ USB_OTG_INCOMPIP_INCOMPISOOUT_FLAG

#define USB_OTG_INCOMPIP_INCOMPISOOUT_FLAG ((uint32_t)0x00200000)

usb otg incomplete periodic transfer/isochronous out flag

Definition at line 102 of file at32f435_437_usb.h.

◆ USB_OTG_ISOOUTDROP_FLAG

#define USB_OTG_ISOOUTDROP_FLAG ((uint32_t)0x00004000)

usb otg isochronous out packet dropped flag

Definition at line 97 of file at32f435_437_usb.h.

◆ USB_OTG_MODEMIS_FLAG

#define USB_OTG_MODEMIS_FLAG ((uint32_t)0x00000002)

usb otg mode mismatch flag

Definition at line 86 of file at32f435_437_usb.h.

◆ USB_OTG_NPTXFEMP_FLAG

#define USB_OTG_NPTXFEMP_FLAG ((uint32_t)0x00000020)

usb otg non-periodic tx fifo empty flag

Definition at line 90 of file at32f435_437_usb.h.

◆ USB_OTG_OEPT_FLAG

#define USB_OTG_OEPT_FLAG ((uint32_t)0x00080000)

usb otg out endpoint flag

Definition at line 100 of file at32f435_437_usb.h.

◆ USB_OTG_OTGINT_FLAG

#define USB_OTG_OTGINT_FLAG ((uint32_t)0x00000004)

usb otg flag

Definition at line 87 of file at32f435_437_usb.h.

◆ USB_OTG_PRT_FLAG

#define USB_OTG_PRT_FLAG ((uint32_t)0x01000000)

usb otg host port flag

Definition at line 103 of file at32f435_437_usb.h.

◆ USB_OTG_PTXFEMP_FLAG

#define USB_OTG_PTXFEMP_FLAG ((uint32_t)0x04000000)

usb otg periodic txfifo empty flag

Definition at line 105 of file at32f435_437_usb.h.

◆ USB_OTG_RXFLVL_FLAG

#define USB_OTG_RXFLVL_FLAG ((uint32_t)0x00000010)

usb otg receive fifo non-empty flag

Definition at line 89 of file at32f435_437_usb.h.

◆ USB_OTG_SOF_FLAG

#define USB_OTG_SOF_FLAG ((uint32_t)0x00000008)

usb otg sof flag

Definition at line 88 of file at32f435_437_usb.h.

◆ USB_OTG_USBRST_FLAG

#define USB_OTG_USBRST_FLAG ((uint32_t)0x00001000)

usb otg reset flag

Definition at line 95 of file at32f435_437_usb.h.

◆ USB_OTG_USBSUSP_FLAG

#define USB_OTG_USBSUSP_FLAG ((uint32_t)0x00000800)

usb otg suspend flag

Definition at line 94 of file at32f435_437_usb.h.

◆ USB_OTG_WKUP_FLAG

#define USB_OTG_WKUP_FLAG ((uint32_t)0x80000000)

usb otg wakeup flag

Definition at line 108 of file at32f435_437_usb.h.


AT32F435/437 Firmwary Library: USB_global_setting_definition

Macros
USB_global_setting_definition
AT32F435_437_periph_driver » USB

usb global setting More...

Macros

#define | USB_TRDTIM_8 0x9
usb turnaround time More...
#define | USB_TRDTIM_16 0x5
#define | USB_OTG_GRXSTSP_EPTNUM ((uint32_t)0x0000000F)
usb receive status More...
#define | USB_OTG_GRXSTSP_CHNUM ((uint32_t)0x0000000F)
#define | USB_OTG_GRXSTSP_BCNT ((uint32_t)0x00007FF0)
#define | USB_OTG_GRXSTSP_DPID ((uint32_t)0x00018000)
#define | USB_OTG_GRXSTSP_PKTSTS ((uint32_t)0x001E0000)
#define | PKTSTS_IN_DATA_PACKET_RECV 0x2
usb host packet status More...
#define | PKTSTS_IN_TRANSFER_COMPLETE 0x3
#define | PKTSTS_DATA_BIT_ERROR 0x5
#define | PKTSTS_CHANNEL_STOP 0x7
#define | USB_OUT_STS_NAK 0x1
usb device packet status More...
#define | USB_OUT_STS_DATA 0x2
#define | USB_OUT_STS_COMP 0x3
#define | USB_SETUP_STS_COMP 0x4
#define | USB_SETUP_STS_DATA 0x6

Detailed Description

usb global setting

Macro Definition Documentation

◆ PKTSTS_CHANNEL_STOP

#define PKTSTS_CHANNEL_STOP 0x7

usb host channel halted

Definition at line 141 of file at32f435_437_usb.h.

◆ PKTSTS_DATA_BIT_ERROR

#define PKTSTS_DATA_BIT_ERROR 0x5

usb host data toggle error

Definition at line 140 of file at32f435_437_usb.h.

◆ PKTSTS_IN_DATA_PACKET_RECV

#define PKTSTS_IN_DATA_PACKET_RECV 0x2

usb host packet status

usb host in data packet received

Definition at line 138 of file at32f435_437_usb.h.

◆ PKTSTS_IN_TRANSFER_COMPLETE

#define PKTSTS_IN_TRANSFER_COMPLETE 0x3

usb host in transfer completed

Definition at line 139 of file at32f435_437_usb.h.

◆ USB_OTG_GRXSTSP_BCNT

#define USB_OTG_GRXSTSP_BCNT ((uint32_t)0x00007FF0)

usb receive packet byte count

Definition at line 131 of file at32f435_437_usb.h.

◆ USB_OTG_GRXSTSP_CHNUM

#define USB_OTG_GRXSTSP_CHNUM ((uint32_t)0x0000000F)

usb host receive packet channel number

Definition at line 130 of file at32f435_437_usb.h.

◆ USB_OTG_GRXSTSP_DPID

#define USB_OTG_GRXSTSP_DPID ((uint32_t)0x00018000)

usb receive packet pid

Definition at line 132 of file at32f435_437_usb.h.

◆ USB_OTG_GRXSTSP_EPTNUM

#define USB_OTG_GRXSTSP_EPTNUM ((uint32_t)0x0000000F)

usb receive status

usb device receive packet endpoint number

Definition at line 129 of file at32f435_437_usb.h.

◆ USB_OTG_GRXSTSP_PKTSTS

#define USB_OTG_GRXSTSP_PKTSTS ((uint32_t)0x001E0000)

usb receive packet status

Definition at line 133 of file at32f435_437_usb.h.

◆ USB_OUT_STS_COMP

#define USB_OUT_STS_COMP 0x3

usb device out transfer completed

Definition at line 148 of file at32f435_437_usb.h.

◆ USB_OUT_STS_DATA

#define USB_OUT_STS_DATA 0x2

usb device out data packet received

Definition at line 147 of file at32f435_437_usb.h.

◆ USB_OUT_STS_NAK

#define USB_OUT_STS_NAK 0x1

usb device packet status

usb device global out nak

Definition at line 146 of file at32f435_437_usb.h.

◆ USB_SETUP_STS_COMP

#define USB_SETUP_STS_COMP 0x4

usb device setup transcation completed

Definition at line 149 of file at32f435_437_usb.h.

◆ USB_SETUP_STS_DATA

#define USB_SETUP_STS_DATA 0x6

usb device setup data packet received

Definition at line 150 of file at32f435_437_usb.h.

◆ USB_TRDTIM_16

#define USB_TRDTIM_16 0x5

usb turn around time 16

Definition at line 124 of file at32f435_437_usb.h.

◆ USB_TRDTIM_8

#define USB_TRDTIM_8 0x9

usb turnaround time

usb turn around time 8

Definition at line 123 of file at32f435_437_usb.h.


AT32F435/437 Firmwary Library: USB_host_config_definition

Macros
USB_host_config_definition
AT32F435_437_periph_driver » USB

Macros

#define | USB_HCFG_CLK_60M 0
usb host phy clock More...
#define | USB_HCFG_CLK_48M 1
#define | USB_HCFG_CLK_6M 2
#define | USB_OTG_HPRT_PRTCONSTS ((uint32_t)0x00000001)
usb host port status More...
#define | USB_OTG_HPRT_PRTCONDET ((uint32_t)0x00000002)
#define | USB_OTG_HPRT_PRTENA ((uint32_t)0x00000004)
#define | USB_OTG_HPRT_PRTENCHNG ((uint32_t)0x00000008)
#define | USB_OTG_HPRT_PRTOVRCACT ((uint32_t)0x00000010)
#define | USB_OTG_HPRT_PRTOVRCCHNG ((uint32_t)0x00000020)
#define | USB_OTG_HPRT_PRTRES ((uint32_t)0x00000040)
#define | USB_OTG_HPRT_PRTSUSP ((uint32_t)0x00000080)
#define | USB_OTG_HPRT_PRTRST ((uint32_t)0x00000100)
#define | USB_OTG_HPRT_PRTLNSTS ((uint32_t)0x00000C00)
#define | USB_OTG_HPRT_PRTPWR ((uint32_t)0x00001000)
#define | USB_OTG_HPRT_PRTSPD ((uint32_t)0x00060000)
#define | USB_PRTSPD_HIGH_SPEED 0
usb port speed More...
#define | USB_PRTSPD_FULL_SPEED 1
#define | USB_PRTSPD_LOW_SPEED 2
#define | USB_OTG_HCCHAR_MPS ((uint32_t)0x000007FF)
usb host register hcchar bit define More...
#define | USB_OTG_HCCHAR_EPTNUM ((uint32_t)0x00007800)
#define | USB_OTG_HCCHAR_EPTDIR ((uint32_t)0x00008000)
#define | USB_OTG_HCCHAR_LSPDDEV ((uint32_t)0x00020000)
#define | USB_OTG_HCCHAR_EPTYPE ((uint32_t)0x000C0000)
#define | USB_OTG_HCCHAR_MC ((uint32_t)0x00300000)
#define | USB_OTG_HCCHAR_DEVADDR ((uint32_t)0x1FC00000)
#define | USB_OTG_HCCHAR_ODDFRM ((uint32_t)0x20000000)
#define | USB_OTG_HCCHAR_CHDIS ((uint32_t)0x40000000)
#define | USB_OTG_HCCHAR_CHENA ((uint32_t)0x80000000)
#define | USB_OTG_HCTSIZ_XFERSIZE ((uint32_t)0x0007FFFF)
usb host register hctsiz bit define More...
#define | USB_OTG_HCTSIZ_PKTCNT ((uint32_t)0x1FF80000)
#define | USB_OTG_HCTSIZ_PID ((uint32_t)0x60000000)
#define | USB_OTG_HC_XFERCM_INT ((uint32_t)0x00000001)
usb host channel interrupt mask More...
#define | USB_OTG_HC_CHHLTDM_INT ((uint32_t)0x00000002)
#define | USB_OTG_HC_STALLM_INT ((uint32_t)0x00000008)
#define | USB_OTG_HC_NAKM_INT ((uint32_t)0x00000010)
#define | USB_OTG_HC_ACKM_INT ((uint32_t)0x00000020)
#define | USB_OTG_HC_NYETM_INT ((uint32_t)0x00000040)
#define | USB_OTG_HC_XACTERRM_INT ((uint32_t)0x00000080)
#define | USB_OTG_HC_BBLERRM_INT ((uint32_t)0x00000100)
#define | USB_OTG_HC_FRMOVRRUN_INT ((uint32_t)0x00000200)
#define | USB_OTG_HC_DTGLERRM_INT ((uint32_t)0x00000400)
#define | USB_OTG_HC_XFERC_FLAG ((uint32_t)0x00000001)
usb host channel interrupt flag More...
#define | USB_OTG_HC_CHHLTD_FLAG ((uint32_t)0x00000002)
#define | USB_OTG_HC_STALL_FLAG ((uint32_t)0x00000008)
#define | USB_OTG_HC_NAK_FLAG ((uint32_t)0x00000010)
#define | USB_OTG_HC_ACK_FLAG ((uint32_t)0x00000020)
#define | USB_OTG_HC_NYET_FLAG ((uint32_t)0x00000040)
#define | USB_OTG_HC_XACTERR_FLAG ((uint32_t)0x00000080)
#define | USB_OTG_HC_BBLERR_FLAG ((uint32_t)0x00000100)
#define | USB_OTG_HC_FRMOVRRUN_FLAG ((uint32_t)0x00000200)
#define | USB_OTG_HC_DTGLERR_FLAG ((uint32_t)0x00000400)

Detailed Description

Macro Definition Documentation

◆ USB_HCFG_CLK_48M

#define USB_HCFG_CLK_48M 1

usb host phy clock 48mhz

Definition at line 164 of file at32f435_437_usb.h.

◆ USB_HCFG_CLK_60M

#define USB_HCFG_CLK_60M 0

usb host phy clock

usb host phy clock 60mhz

Definition at line 163 of file at32f435_437_usb.h.

◆ USB_HCFG_CLK_6M

#define USB_HCFG_CLK_6M 2

usb host phy clock 6mhz

Definition at line 165 of file at32f435_437_usb.h.

◆ USB_OTG_HC_ACK_FLAG

#define USB_OTG_HC_ACK_FLAG ((uint32_t)0x00000020)

channel ack flag

Definition at line 232 of file at32f435_437_usb.h.

◆ USB_OTG_HC_ACKM_INT

#define USB_OTG_HC_ACKM_INT ((uint32_t)0x00000020)

channel ack interrupt

Definition at line 218 of file at32f435_437_usb.h.

◆ USB_OTG_HC_BBLERR_FLAG

#define USB_OTG_HC_BBLERR_FLAG ((uint32_t)0x00000100)

channel babble error flag

Definition at line 235 of file at32f435_437_usb.h.

◆ USB_OTG_HC_BBLERRM_INT

#define USB_OTG_HC_BBLERRM_INT ((uint32_t)0x00000100)

channel babble error interrupt

Definition at line 221 of file at32f435_437_usb.h.

◆ USB_OTG_HC_CHHLTD_FLAG

#define USB_OTG_HC_CHHLTD_FLAG ((uint32_t)0x00000002)

channel halted flag

Definition at line 229 of file at32f435_437_usb.h.

◆ USB_OTG_HC_CHHLTDM_INT

#define USB_OTG_HC_CHHLTDM_INT ((uint32_t)0x00000002)

channel halted interrupt

Definition at line 215 of file at32f435_437_usb.h.

◆ USB_OTG_HC_DTGLERR_FLAG

#define USB_OTG_HC_DTGLERR_FLAG ((uint32_t)0x00000400)

channel data toggle flag

Definition at line 237 of file at32f435_437_usb.h.

◆ USB_OTG_HC_DTGLERRM_INT

#define USB_OTG_HC_DTGLERRM_INT ((uint32_t)0x00000400)

channel data toggle interrupt

Definition at line 223 of file at32f435_437_usb.h.

◆ USB_OTG_HC_FRMOVRRUN_FLAG

#define USB_OTG_HC_FRMOVRRUN_FLAG ((uint32_t)0x00000200)

channel frame overrun flag

Definition at line 236 of file at32f435_437_usb.h.

◆ USB_OTG_HC_FRMOVRRUN_INT

#define USB_OTG_HC_FRMOVRRUN_INT ((uint32_t)0x00000200)

channel frame overrun interrupt

Definition at line 222 of file at32f435_437_usb.h.

◆ USB_OTG_HC_NAK_FLAG

#define USB_OTG_HC_NAK_FLAG ((uint32_t)0x00000010)

channel nak flag

Definition at line 231 of file at32f435_437_usb.h.

◆ USB_OTG_HC_NAKM_INT

#define USB_OTG_HC_NAKM_INT ((uint32_t)0x00000010)

channel nak interrupt

Definition at line 217 of file at32f435_437_usb.h.

◆ USB_OTG_HC_NYET_FLAG

#define USB_OTG_HC_NYET_FLAG ((uint32_t)0x00000040)

channel nyet flag

Definition at line 233 of file at32f435_437_usb.h.

◆ USB_OTG_HC_NYETM_INT

#define USB_OTG_HC_NYETM_INT ((uint32_t)0x00000040)

channel nyet interrupt

Definition at line 219 of file at32f435_437_usb.h.

◆ USB_OTG_HC_STALL_FLAG

#define USB_OTG_HC_STALL_FLAG ((uint32_t)0x00000008)

channel stall flag

Definition at line 230 of file at32f435_437_usb.h.

◆ USB_OTG_HC_STALLM_INT

#define USB_OTG_HC_STALLM_INT ((uint32_t)0x00000008)

channel stall interrupt

Definition at line 216 of file at32f435_437_usb.h.

◆ USB_OTG_HC_XACTERR_FLAG

#define USB_OTG_HC_XACTERR_FLAG ((uint32_t)0x00000080)

channel transaction error flag

Definition at line 234 of file at32f435_437_usb.h.

◆ USB_OTG_HC_XACTERRM_INT

#define USB_OTG_HC_XACTERRM_INT ((uint32_t)0x00000080)

channel transaction error interrupt

Definition at line 220 of file at32f435_437_usb.h.

◆ USB_OTG_HC_XFERC_FLAG

#define USB_OTG_HC_XFERC_FLAG ((uint32_t)0x00000001)

usb host channel interrupt flag

channel transfer complete flag

Definition at line 228 of file at32f435_437_usb.h.

◆ USB_OTG_HC_XFERCM_INT

#define USB_OTG_HC_XFERCM_INT ((uint32_t)0x00000001)

usb host channel interrupt mask

channel transfer complete interrupt

Definition at line 214 of file at32f435_437_usb.h.

◆ USB_OTG_HCCHAR_CHDIS

#define USB_OTG_HCCHAR_CHDIS ((uint32_t)0x40000000)

channel disable

Definition at line 201 of file at32f435_437_usb.h.

◆ USB_OTG_HCCHAR_CHENA

#define USB_OTG_HCCHAR_CHENA ((uint32_t)0x80000000)

channel enable

Definition at line 202 of file at32f435_437_usb.h.

◆ USB_OTG_HCCHAR_DEVADDR

#define USB_OTG_HCCHAR_DEVADDR ((uint32_t)0x1FC00000)

device address

Definition at line 199 of file at32f435_437_usb.h.

◆ USB_OTG_HCCHAR_EPTDIR

#define USB_OTG_HCCHAR_EPTDIR ((uint32_t)0x00008000)

endpoint direction

Definition at line 195 of file at32f435_437_usb.h.

◆ USB_OTG_HCCHAR_EPTNUM

#define USB_OTG_HCCHAR_EPTNUM ((uint32_t)0x00007800)

endpoint number

Definition at line 194 of file at32f435_437_usb.h.

◆ USB_OTG_HCCHAR_EPTYPE

#define USB_OTG_HCCHAR_EPTYPE ((uint32_t)0x000C0000)

endpoint type

Definition at line 197 of file at32f435_437_usb.h.

◆ USB_OTG_HCCHAR_LSPDDEV

#define USB_OTG_HCCHAR_LSPDDEV ((uint32_t)0x00020000)

low speed device

Definition at line 196 of file at32f435_437_usb.h.

◆ USB_OTG_HCCHAR_MC

#define USB_OTG_HCCHAR_MC ((uint32_t)0x00300000)

multi count

Definition at line 198 of file at32f435_437_usb.h.

◆ USB_OTG_HCCHAR_MPS

#define USB_OTG_HCCHAR_MPS ((uint32_t)0x000007FF)

usb host register hcchar bit define

channel maximum packet size

Definition at line 193 of file at32f435_437_usb.h.

◆ USB_OTG_HCCHAR_ODDFRM

#define USB_OTG_HCCHAR_ODDFRM ((uint32_t)0x20000000)

odd frame

Definition at line 200 of file at32f435_437_usb.h.

◆ USB_OTG_HCTSIZ_PID

#define USB_OTG_HCTSIZ_PID ((uint32_t)0x60000000)

channel pid

Definition at line 209 of file at32f435_437_usb.h.

◆ USB_OTG_HCTSIZ_PKTCNT

#define USB_OTG_HCTSIZ_PKTCNT ((uint32_t)0x1FF80000)

channel packet count

Definition at line 208 of file at32f435_437_usb.h.

◆ USB_OTG_HCTSIZ_XFERSIZE

#define USB_OTG_HCTSIZ_XFERSIZE ((uint32_t)0x0007FFFF)

usb host register hctsiz bit define

channel transfer size

Definition at line 207 of file at32f435_437_usb.h.

◆ USB_OTG_HPRT_PRTCONDET

#define USB_OTG_HPRT_PRTCONDET ((uint32_t)0x00000002)

usb host port connect detected

Definition at line 171 of file at32f435_437_usb.h.

◆ USB_OTG_HPRT_PRTCONSTS

#define USB_OTG_HPRT_PRTCONSTS ((uint32_t)0x00000001)

usb host port status

usb host port connect status

Definition at line 170 of file at32f435_437_usb.h.

◆ USB_OTG_HPRT_PRTENA

#define USB_OTG_HPRT_PRTENA ((uint32_t)0x00000004)

usb host port enable

Definition at line 172 of file at32f435_437_usb.h.

◆ USB_OTG_HPRT_PRTENCHNG

#define USB_OTG_HPRT_PRTENCHNG ((uint32_t)0x00000008)

usb host port enable/disable change

Definition at line 173 of file at32f435_437_usb.h.

◆ USB_OTG_HPRT_PRTLNSTS

#define USB_OTG_HPRT_PRTLNSTS ((uint32_t)0x00000C00)

usb host port line status

Definition at line 179 of file at32f435_437_usb.h.

◆ USB_OTG_HPRT_PRTOVRCACT

#define USB_OTG_HPRT_PRTOVRCACT ((uint32_t)0x00000010)

usb host port overcurrent active

Definition at line 174 of file at32f435_437_usb.h.

◆ USB_OTG_HPRT_PRTOVRCCHNG

#define USB_OTG_HPRT_PRTOVRCCHNG ((uint32_t)0x00000020)

usb host port overcurrent change

Definition at line 175 of file at32f435_437_usb.h.

◆ USB_OTG_HPRT_PRTPWR

#define USB_OTG_HPRT_PRTPWR ((uint32_t)0x00001000)

usb host port power

Definition at line 180 of file at32f435_437_usb.h.

◆ USB_OTG_HPRT_PRTRES

#define USB_OTG_HPRT_PRTRES ((uint32_t)0x00000040)

usb host port resume

Definition at line 176 of file at32f435_437_usb.h.

◆ USB_OTG_HPRT_PRTRST

#define USB_OTG_HPRT_PRTRST ((uint32_t)0x00000100)

usb host port reset

Definition at line 178 of file at32f435_437_usb.h.

◆ USB_OTG_HPRT_PRTSPD

#define USB_OTG_HPRT_PRTSPD ((uint32_t)0x00060000)

usb host port speed

Definition at line 181 of file at32f435_437_usb.h.

◆ USB_OTG_HPRT_PRTSUSP

#define USB_OTG_HPRT_PRTSUSP ((uint32_t)0x00000080)

usb host port suspend

Definition at line 177 of file at32f435_437_usb.h.

◆ USB_PRTSPD_FULL_SPEED

#define USB_PRTSPD_FULL_SPEED 1

usb host port full speed

Definition at line 187 of file at32f435_437_usb.h.

◆ USB_PRTSPD_HIGH_SPEED

#define USB_PRTSPD_HIGH_SPEED 0

usb port speed

usb host port high speed

Definition at line 186 of file at32f435_437_usb.h.

◆ USB_PRTSPD_LOW_SPEED

#define USB_PRTSPD_LOW_SPEED 2

usb host port low speed

Definition at line 188 of file at32f435_437_usb.h.


AT32F435/437 Firmwary Library: USB_device_config_definition

Macros | Enumerations
USB_device_config_definition
AT32F435_437_periph_driver » USB

Macros

#define | USB_DCFG_FULL_SPEED 3
usb device full speed More...
#define | USB_OTG_DCTL_RWKUPSIG ((uint32_t)0x00000001)
usb device ctrl define More...
#define | USB_OTG_DCTL_SFTDISCON ((uint32_t)0x00000002)
#define | USB_OTG_DCTL_GNPINNAKSTS ((uint32_t)0x00000004)
#define | USB_OTG_DCTL_GOUTNAKSTS ((uint32_t)0x00000008)
#define | USB_OTG_DCTL_SGNPINNAK ((uint32_t)0x00000080)
#define | USB_OTG_DCTL_CGNPINNAK ((uint32_t)0x00000100)
#define | USB_OTG_DCTL_SGOUTNAK ((uint32_t)0x00000200)
#define | USB_OTG_DCTL_CGOUTNAK ((uint32_t)0x00000400)
#define | USB_OTG_DCTL_PWROPRGDNE ((uint32_t)0x00000800)
#define | USB_OTG_DIEPINT_XFERC_FLAG ((uint32_t)0x00000001)
usb device in endpoint flag More...
#define | USB_OTG_DIEPINT_EPTDISD_FLAG ((uint32_t)0x00000002)
#define | USB_OTG_DIEPINT_TIMEOUT_FLAG ((uint32_t)0x00000008)
#define | USB_OTG_DIEPINT_INTKNTXFEMP_FLAG ((uint32_t)0x00000010)
#define | USB_OTG_DIEPINT_INEPTNAK_FLAG ((uint32_t)0x00000040)
#define | USB_OTG_DIEPINT_TXFEMP_FLAG ((uint32_t)0x00000080)
#define | USB_OTG_DOEPINT_XFERC_FLAG ((uint32_t)0x00000001)
usb device out endpoint flag More...
#define | USB_OTG_DOEPINT_EPTDISD_FLAG ((uint32_t)0x00000002)
#define | USB_OTG_DOEPINT_SETUP_FLAG ((uint32_t)0x00000008)
#define | USB_OTG_DOEPINT_OUTTEPD_FLAG ((uint32_t)0x00000010)
#define | USB_OTG_DOEPINT_B2BSTUP_FLAG ((uint32_t)0x00000040)
#define | USB_OTG_DTXFSTS_INEPTFSAV ((uint32_t)0x0000FFFF)
usb device in endpoint fifo space mask More...
#define | USB_EPT0_MPS_64 0
endpoint0 maximum packet size More...
#define | USB_EPT0_MPS_32 1
#define | USB_EPT0_MPS_16 2
#define | USB_EPT0_MPS_8 3

Enumerations

enum dcfg_perfrint_type { DCFG_PERFRINT_80 = 0x00 , DCFG_PERFRINT_85 = 0x01 , DCFG_PERFRINT_90 = 0x02 , DCFG_PERFRINT_95 = 0x03 }
usb device periodic frame interval More...

Detailed Description

Macro Definition Documentation

◆ USB_DCFG_FULL_SPEED

#define USB_DCFG_FULL_SPEED 3

usb device full speed

device full speed

Definition at line 262 of file at32f435_437_usb.h.

◆ USB_EPT0_MPS_16

#define USB_EPT0_MPS_16 2

usb device endpoint 0 maximum packet size 16byte

Definition at line 306 of file at32f435_437_usb.h.

◆ USB_EPT0_MPS_32

#define USB_EPT0_MPS_32 1

usb device endpoint 0 maximum packet size 32byte

Definition at line 305 of file at32f435_437_usb.h.

◆ USB_EPT0_MPS_64

#define USB_EPT0_MPS_64 0

endpoint0 maximum packet size

usb device endpoint 0 maximum packet size 64byte

Definition at line 304 of file at32f435_437_usb.h.

◆ USB_EPT0_MPS_8

#define USB_EPT0_MPS_8 3

usb device endpoint 0 maximum packet size 8byte

Definition at line 307 of file at32f435_437_usb.h.

◆ USB_OTG_DCTL_CGNPINNAK

#define USB_OTG_DCTL_CGNPINNAK ((uint32_t)0x00000100)

usb device clear global non-periodic in nak

Definition at line 272 of file at32f435_437_usb.h.

◆ USB_OTG_DCTL_CGOUTNAK

#define USB_OTG_DCTL_CGOUTNAK ((uint32_t)0x00000400)

usb device clear global out nak status

Definition at line 274 of file at32f435_437_usb.h.

◆ USB_OTG_DCTL_GNPINNAKSTS

#define USB_OTG_DCTL_GNPINNAKSTS ((uint32_t)0x00000004)

usb device global non-periodic in nak status

Definition at line 269 of file at32f435_437_usb.h.

◆ USB_OTG_DCTL_GOUTNAKSTS

#define USB_OTG_DCTL_GOUTNAKSTS ((uint32_t)0x00000008)

usb device global out nak status

Definition at line 270 of file at32f435_437_usb.h.

◆ USB_OTG_DCTL_PWROPRGDNE

#define USB_OTG_DCTL_PWROPRGDNE ((uint32_t)0x00000800)

usb device power on programming done

Definition at line 275 of file at32f435_437_usb.h.

◆ USB_OTG_DCTL_RWKUPSIG

#define USB_OTG_DCTL_RWKUPSIG ((uint32_t)0x00000001)

usb device ctrl define

usb device remote wakeup signaling

Definition at line 267 of file at32f435_437_usb.h.

◆ USB_OTG_DCTL_SFTDISCON

#define USB_OTG_DCTL_SFTDISCON ((uint32_t)0x00000002)

usb device soft disconnect

Definition at line 268 of file at32f435_437_usb.h.

◆ USB_OTG_DCTL_SGNPINNAK

#define USB_OTG_DCTL_SGNPINNAK ((uint32_t)0x00000080)

usb device set global non-periodic in nak

Definition at line 271 of file at32f435_437_usb.h.

◆ USB_OTG_DCTL_SGOUTNAK

#define USB_OTG_DCTL_SGOUTNAK ((uint32_t)0x00000200)

usb device set global out nak status

Definition at line 273 of file at32f435_437_usb.h.

◆ USB_OTG_DIEPINT_EPTDISD_FLAG

#define USB_OTG_DIEPINT_EPTDISD_FLAG ((uint32_t)0x00000002)

usb device endpoint disable flag

Definition at line 281 of file at32f435_437_usb.h.

◆ USB_OTG_DIEPINT_INEPTNAK_FLAG

#define USB_OTG_DIEPINT_INEPTNAK_FLAG ((uint32_t)0x00000040)

usb device in endpoint nak effective flag

Definition at line 284 of file at32f435_437_usb.h.

◆ USB_OTG_DIEPINT_INTKNTXFEMP_FLAG

#define USB_OTG_DIEPINT_INTKNTXFEMP_FLAG ((uint32_t)0x00000010)

usb device in token received when tx fifo is empty flag

Definition at line 283 of file at32f435_437_usb.h.

◆ USB_OTG_DIEPINT_TIMEOUT_FLAG

#define USB_OTG_DIEPINT_TIMEOUT_FLAG ((uint32_t)0x00000008)

usb device in timeout

Definition at line 282 of file at32f435_437_usb.h.

◆ USB_OTG_DIEPINT_TXFEMP_FLAG

#define USB_OTG_DIEPINT_TXFEMP_FLAG ((uint32_t)0x00000080)

usb device transmit fifo empty flag

Definition at line 285 of file at32f435_437_usb.h.

◆ USB_OTG_DIEPINT_XFERC_FLAG

#define USB_OTG_DIEPINT_XFERC_FLAG ((uint32_t)0x00000001)

usb device in endpoint flag

usb device in transfer completed flag

Definition at line 280 of file at32f435_437_usb.h.

◆ USB_OTG_DOEPINT_B2BSTUP_FLAG

#define USB_OTG_DOEPINT_B2BSTUP_FLAG ((uint32_t)0x00000040)

back-to-back setup packets received

Definition at line 294 of file at32f435_437_usb.h.

◆ USB_OTG_DOEPINT_EPTDISD_FLAG

#define USB_OTG_DOEPINT_EPTDISD_FLAG ((uint32_t)0x00000002)

usb device endpoint disable flag

Definition at line 291 of file at32f435_437_usb.h.

◆ USB_OTG_DOEPINT_OUTTEPD_FLAG

#define USB_OTG_DOEPINT_OUTTEPD_FLAG ((uint32_t)0x00000010)

usb device out token recevied when endpoint disable flag

Definition at line 293 of file at32f435_437_usb.h.

◆ USB_OTG_DOEPINT_SETUP_FLAG

#define USB_OTG_DOEPINT_SETUP_FLAG ((uint32_t)0x00000008)

usb device setup flag

Definition at line 292 of file at32f435_437_usb.h.

◆ USB_OTG_DOEPINT_XFERC_FLAG

#define USB_OTG_DOEPINT_XFERC_FLAG ((uint32_t)0x00000001)

usb device out endpoint flag

usb device out transfer completed flag

Definition at line 290 of file at32f435_437_usb.h.

◆ USB_OTG_DTXFSTS_INEPTFSAV

#define USB_OTG_DTXFSTS_INEPTFSAV ((uint32_t)0x0000FFFF)

usb device in endpoint fifo space mask

usb device in endpoint tx fifo space avail

Definition at line 299 of file at32f435_437_usb.h.

Enumeration Type Documentation

◆ dcfg_perfrint_type

enum dcfg_perfrint_type

usb device periodic frame interval

Enumerator
DCFG_PERFRINT_80 | periodic frame interval 80%
DCFG_PERFRINT_85 | periodic frame interval 85%
DCFG_PERFRINT_90 | periodic frame interval 90%
DCFG_PERFRINT_95 | periodic frame interval 95%

Definition at line 250 of file at32f435_437_usb.h.


AT32F435/437 Firmwary Library: USB_exported_enum_types

Enumerations
USB_exported_enum_types
AT32F435_437_periph_driver » USB

Enumerations

enum | otg_mode_type { OTG_DEVICE_MODE , OTG_HOST_MODE , OTG_DRD_MODE }
usb mode define(device, host, drd) More...
enum | endpoint_trans_type { EPT_CONTROL_TYPE = 0x00 , EPT_ISO_TYPE = 0x01 , EPT_BULK_TYPE = 0x02 , EPT_INT_TYPE = 0x03 }
endpoint type define More...
enum usb_endpoint_number_type {
USB_EPT0 = 0x00 , USB_EPT1 = 0x01 , USB_EPT2 = 0x02 , USB_EPT3 = 0x03 ,
USB_EPT4 = 0x04 , USB_EPT5 = 0x05 , USB_EPT6 = 0x06 , USB_EPT7 = 0x07
}
usb endpoint number define type More...
enum | endpoint_dir_type { EPT_DIR_IN = 0x00 , EPT_DIR_OUT = 0x01 }
usb endpoint max num define More...
enum | otg_id_type { USB_OTG1_ID , USB_OTG2_ID }
otgfs1 and otgfs2 select type More...
enum | usb_clk48_s { USB_CLK_HICK , USB_CLK_HEXT }
usb clock select More...

Detailed Description

Enumeration Type Documentation

◆ endpoint_dir_type

enum endpoint_dir_type

usb endpoint max num define

usb channel max num define

endpoint trans dir type

Enumerator
EPT_DIR_IN | usb transfer direction in
EPT_DIR_OUT | usb transfer direction out

Definition at line 383 of file at32f435_437_usb.h.

◆ endpoint_trans_type

enum endpoint_trans_type

endpoint type define

Enumerator
EPT_CONTROL_TYPE | usb endpoint type control
EPT_ISO_TYPE | usb endpoint type iso
EPT_BULK_TYPE | usb endpoint type bulk
EPT_INT_TYPE | usb endpoint type interrupt

Definition at line 344 of file at32f435_437_usb.h.

◆ otg_id_type

enum otg_id_type

otgfs1 and otgfs2 select type

Enumerator
USB_OTG1_ID | usb otg 1 id
USB_OTG2_ID | usb otg 2 id

Definition at line 392 of file at32f435_437_usb.h.

◆ otg_mode_type

enum otg_mode_type

usb mode define(device, host, drd)

Enumerator
OTG_DEVICE_MODE | usb device mode
OTG_HOST_MODE | usb host mode
OTG_DRD_MODE | usb drd mode

Definition at line 334 of file at32f435_437_usb.h.

◆ usb_clk48_s

enum usb_clk48_s

usb clock select

Enumerator
USB_CLK_HICK | usb clock use hick
USB_CLK_HEXT | usb clock use hext

Definition at line 401 of file at32f435_437_usb.h.

◆ usb_endpoint_number_type

enum usb_endpoint_number_type

usb endpoint number define type

Enumerator
USB_EPT0 | usb endpoint 0
USB_EPT1 | usb endpoint 1
USB_EPT2 | usb endpoint 2
USB_EPT3 | usb endpoint 3
USB_EPT4 | usb endpoint 4
USB_EPT5 | usb endpoint 5
USB_EPT6 | usb endpoint 6
USB_EPT7 | usb endpoint 7

Definition at line 355 of file at32f435_437_usb.h.


AT32F435/437 Firmwary Library: USB_exported_types

Data Structures
USB_exported_types
AT32F435_437_periph_driver » USB

Data Structures

struct | usb_ept_info
usb endpoint infomation structure definition More...
struct | usb_hch_type
usb host channel infomation structure definition More...
struct | otg_global_type
struct | otg_host_type
struct | otg_hchannel_type
struct | otg_device_type
struct | otg_eptin_type
struct | otg_eptout_type
struct | otg_pcgcctl_type

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: usb_ept_info Struct Reference

Data Fields
usb_ept_info Struct Reference
AT32F435_437_periph_driver » USB » USB_exported_types

usb endpoint infomation structure definition More...

#include <at32f435_437_usb.h>

Data Fields

uint8_t | eptn
uint8_t | ept_address
uint8_t | inout
uint8_t | trans_type
uint16_t | tx_addr
uint16_t | rx_addr
uint32_t | maxpacket
uint8_t | is_double_buffer
uint8_t | stall
uint32_t | status
uint8_t * | trans_buf
uint32_t | total_len
uint32_t | trans_len
uint32_t | last_len
uint32_t | rem0_len
uint32_t | ept0_slen

Detailed Description

usb endpoint infomation structure definition

Definition at line 420 of file at32f435_437_usb.h.

Field Documentation

◆ ept0_slen

uint32_t usb_ept_info::ept0_slen

endpoint 0 transfer sum length

Definition at line 441 of file at32f435_437_usb.h.

Referenced by usbd_core_in_handler(), usbd_ctrl_recv(), and usbd_ctrl_send().

◆ ept_address

uint8_t usb_ept_info::ept_address

endpoint address

Definition at line 423 of file at32f435_437_usb.h.

◆ eptn

uint8_t usb_ept_info::eptn

endpoint register number (0~7)

Definition at line 422 of file at32f435_437_usb.h.

Referenced by usb_ept_clear_stall(), usb_ept_close(), usb_ept_open(), usb_ept_stall(), usbd_ept_recv(), and usbd_ept_send().

◆ inout

uint8_t usb_ept_info::inout

endpoint dir EPT_DIR_IN or EPT_DIR_OUT

Definition at line 424 of file at32f435_437_usb.h.

Referenced by usb_ept_clear_stall(), usb_ept_close(), usb_ept_open(), usb_ept_stall(), and usbd_ept_open().

◆ is_double_buffer

uint8_t usb_ept_info::is_double_buffer

endpoint double buffer flag

Definition at line 430 of file at32f435_437_usb.h.

◆ last_len

uint32_t usb_ept_info::last_len

last transfer length

Definition at line 439 of file at32f435_437_usb.h.

Referenced by usbd_core_in_handler(), and usbd_ept_send().

◆ maxpacket

uint32_t usb_ept_info::maxpacket

endpoint max packet

Definition at line 429 of file at32f435_437_usb.h.

Referenced by usb_ept_open(), usb_write_empty_txfifo(), usbd_core_in_handler(), usbd_core_out_handler(), usbd_ept_open(), usbd_ept_recv(), and usbd_ept_send().

◆ rem0_len

uint32_t usb_ept_info::rem0_len

rem transfer length

Definition at line 440 of file at32f435_437_usb.h.

Referenced by usbd_core_in_handler(), usbd_core_out_handler(), usbd_ctrl_recv(), and usbd_ctrl_send().

◆ rx_addr

uint16_t usb_ept_info::rx_addr

endpoint rx buffer offset address

Definition at line 428 of file at32f435_437_usb.h.

◆ stall

uint8_t usb_ept_info::stall

endpoint is stall state

Definition at line 431 of file at32f435_437_usb.h.

Referenced by usbd_clear_stall(), usbd_endpoint_request(), and usbd_set_stall().

◆ status

uint32_t usb_ept_info::status

Definition at line 432 of file at32f435_437_usb.h.

Referenced by usbd_endpoint_request().

◆ total_len

uint32_t usb_ept_info::total_len

endpoint transmission lengtg

Definition at line 436 of file at32f435_437_usb.h.

Referenced by usb_write_empty_txfifo(), usbd_ept_recv(), and usbd_ept_send().

◆ trans_buf

uint8_t* usb_ept_info::trans_buf

endpoint transmission buffer

Definition at line 435 of file at32f435_437_usb.h.

Referenced by usb_write_empty_txfifo(), usbd_core_in_handler(), usbd_core_out_handler(), usbd_ept_recv(), usbd_ept_send(), and usbd_rxflvl_handler().

◆ trans_len

uint32_t usb_ept_info::trans_len

endpoint transmission length

Definition at line 437 of file at32f435_437_usb.h.

Referenced by usb_write_empty_txfifo(), usbd_ept_recv(), usbd_ept_send(), usbd_get_recv_len(), and usbd_rxflvl_handler().

◆ trans_type

uint8_t usb_ept_info::trans_type

endpoint type: EPT_CONTROL_TYPE, EPT_BULK_TYPE, EPT_INT_TYPE, EPT_ISO_TYPE

Definition at line 425 of file at32f435_437_usb.h.

Referenced by usb_ept_clear_stall(), usb_ept_open(), usbd_ept_open(), usbd_ept_recv(), and usbd_ept_send().

◆ tx_addr

uint16_t usb_ept_info::tx_addr

endpoint tx buffer offset address

Definition at line 427 of file at32f435_437_usb.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_usb.h


AT32F435/437 Firmwary Library: usb_hch_type Struct Reference

Data Fields
usb_hch_type Struct Reference
AT32F435_437_periph_driver » USB » USB_exported_types

usb host channel infomation structure definition More...

#include <at32f435_437_usb.h>

Data Fields

uint8_t | ch_num
uint8_t | address
uint8_t | dir
uint8_t | ept_num
uint8_t | ept_type
uint32_t | maxpacket
uint8_t | data_pid
uint8_t | speed
uint8_t | stall
uint32_t | status
uint32_t | state
uint32_t | urb_sts
uint8_t | toggle_in
uint8_t | toggle_out
uint8_t * | trans_buf
uint32_t | trans_len
uint32_t | trans_count

Detailed Description

usb host channel infomation structure definition

Definition at line 448 of file at32f435_437_usb.h.

Field Documentation

◆ address

uint8_t usb_hch_type::address

device address

Definition at line 451 of file at32f435_437_usb.h.

◆ ch_num

uint8_t usb_hch_type::ch_num

host channel number

Definition at line 450 of file at32f435_437_usb.h.

◆ data_pid

uint8_t usb_hch_type::data_pid

data pid

Definition at line 456 of file at32f435_437_usb.h.

◆ dir

uint8_t usb_hch_type::dir

transmission direction

Definition at line 452 of file at32f435_437_usb.h.

◆ ept_num

uint8_t usb_hch_type::ept_num

device endpoint number

Definition at line 453 of file at32f435_437_usb.h.

◆ ept_type

uint8_t usb_hch_type::ept_type

channel transmission type

Definition at line 454 of file at32f435_437_usb.h.

◆ maxpacket

uint32_t usb_hch_type::maxpacket

support max packet size

Definition at line 455 of file at32f435_437_usb.h.

◆ speed

uint8_t usb_hch_type::speed

usb speed

Definition at line 457 of file at32f435_437_usb.h.

◆ stall

uint8_t usb_hch_type::stall

channel stall flag

Definition at line 458 of file at32f435_437_usb.h.

◆ state

uint32_t usb_hch_type::state

channel state

Definition at line 460 of file at32f435_437_usb.h.

◆ status

uint32_t usb_hch_type::status

channel status

Definition at line 459 of file at32f435_437_usb.h.

◆ toggle_in

uint8_t usb_hch_type::toggle_in

channel in transfer toggle

Definition at line 463 of file at32f435_437_usb.h.

◆ toggle_out

uint8_t usb_hch_type::toggle_out

channel out transfer toggle

Definition at line 464 of file at32f435_437_usb.h.

◆ trans_buf

uint8_t* usb_hch_type::trans_buf

Definition at line 467 of file at32f435_437_usb.h.

◆ trans_count

uint32_t usb_hch_type::trans_count

Definition at line 469 of file at32f435_437_usb.h.

◆ trans_len

uint32_t usb_hch_type::trans_len

Definition at line 468 of file at32f435_437_usb.h.

◆ urb_sts

uint32_t usb_hch_type::urb_sts

usb channel request block state

Definition at line 461 of file at32f435_437_usb.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_usb.h


AT32F435/437 Firmwary Library: otg_global_type Struct Reference

Data Fields
otg_global_type Struct Reference
AT32F435_437_periph_driver » USB » USB_exported_types

#include <at32f435_437_usb.h>

Data Fields

union {
__IO uint32_t gotgctrl
struct {
__IO uint32_t reserved1: 16
__IO uint32_t cidsts: 1
__IO uint32_t reserved2: 4
__IO uint32_t curmod: 1
__IO uint32_t reserved3: 10
} gotgctrl_bit
};
otgfs control and status register, offset:0x00 More...
union {
__IO uint32_t gotgint
struct {
__IO uint32_t reserved1: 2
__IO uint32_t sesenddet: 1
__IO uint32_t reserved2: 29
} gotgint_bit
};
otgfs interrupt register, offset:0x04 More...
union {
__IO uint32_t gahbcfg
struct {
__IO uint32_t glbintmsk: 1
__IO uint32_t reserved1: 6
__IO uint32_t nptxfemplvl: 1
__IO uint32_t ptxfemplvl: 1
__IO uint32_t reserved2: 23
} gahbcfg_bit
};
otgfs gahbcfg configuration register, offset:0x08 More...
union {
__IO uint32_t gusbcfg
struct {
__IO uint32_t toutcal: 3
__IO uint32_t reserved1: 7
__IO uint32_t usbtrdtim: 4
__IO uint32_t reserved2: 15
__IO uint32_t fhstmode: 1
__IO uint32_t fdevmode: 1
__IO uint32_t cotxpkt: 1
} gusbcfg_bit
};
otgfs usb configuration register, offset:0x0C More...
union {
__IO uint32_t grstctl
struct {
__IO uint32_t csftrst: 1
__IO uint32_t piusftrst: 1
__IO uint32_t frmcntrst: 1
__IO uint32_t reserved1: 1
__IO uint32_t rxfflsh: 1
__IO uint32_t txfflsh: 1
__IO uint32_t txfnum: 5
__IO uint32_t reserved2: 20
__IO uint32_t ahbidle: 1
} grstctl_bit
};
otgfs reset register, offset:0x10 More...
union {
__IO uint32_t gintsts
struct {
__IO uint32_t curmode: 1
__IO uint32_t modemis: 1
__IO uint32_t otgint: 1
__IO uint32_t sof: 1
__IO uint32_t rxflvl: 1
__IO uint32_t nptxfemp: 1
__IO uint32_t ginnakeff: 1
__IO uint32_t goutnakeff: 1
__IO uint32_t reserved1: 2
__IO uint32_t erlysusp: 1
__IO uint32_t usbsusp: 1
__IO uint32_t usbrst: 1
__IO uint32_t enumdone: 1
__IO uint32_t isooutdrop: 1
__IO uint32_t eopf: 1
__IO uint32_t reserved2: 2
__IO uint32_t ieptint: 1
__IO uint32_t oeptint: 1
__IO uint32_t incompisoin: 1
__IO uint32_t incompip_incompisoout: 1
__IO uint32_t reserved3: 2
__IO uint32_t prtint: 1
__IO uint32_t hchint: 1
__IO uint32_t ptxfemp: 1
__IO uint32_t reserved4: 1
__IO uint32_t conidschg: 1
__IO uint32_t disconint: 1
__IO uint32_t reserved5: 1
__IO uint32_t wkupint: 1
} gintsts_bit
};
otgfs core interrupt register, offset:0x14 More...
union {
__IO uint32_t gintmsk
struct {
__IO uint32_t reserved1: 1
__IO uint32_t modemismsk: 1
__IO uint32_t otgintmsk: 1
__IO uint32_t sofmsk: 1
__IO uint32_t rxflvlmsk: 1
__IO uint32_t nptxfempmsk: 1
__IO uint32_t ginnakeffmsk: 1
__IO uint32_t goutnakeffmsk: 1
__IO uint32_t reserved2: 2
__IO uint32_t erlysuspmsk: 1
__IO uint32_t usbsuspmsk: 1
__IO uint32_t usbrstmsk: 1
__IO uint32_t enumdonemsk: 1
__IO uint32_t isooutdropmsk: 1
__IO uint32_t eopfmsk: 1
__IO uint32_t reserved3: 2
__IO uint32_t ieptintmsk: 1
__IO uint32_t oeptintmsk: 1
__IO uint32_t incompisoinmsk: 1
__IO uint32_t incompip_incompisooutmsk: 1
__IO uint32_t reserved4: 2
__IO uint32_t prtintmsk: 1
__IO uint32_t hchintmsk: 1
__IO uint32_t ptxfempmsk: 1
__IO uint32_t reserved5: 1
__IO uint32_t conidschgmsk: 1
__IO uint32_t disconintmsk: 1
__IO uint32_t reserved6: 1
__IO uint32_t wkupintmsk: 1
} gintmsk_bit
};
otgfs interrupt mask register, offset:0x18 More...
union {
__IO uint32_t grxstsr
struct {
__IO uint32_t eptnum: 4
__IO uint32_t bcnt: 11
__IO uint32_t dpid: 2
__IO uint32_t pktsts: 4
__IO uint32_t fn: 4
__IO uint32_t reserved1: 7
} grxstsr_bit
};
otgfs rx status debug read register, offset:0x1C More...
union {
__IO uint32_t grxstsp
struct {
__IO uint32_t chnum: 4
__IO uint32_t bcnt: 11
__IO uint32_t dpid: 2
__IO uint32_t pktsts: 4
__IO uint32_t reserved1: 11
} grxstsp_bit
};
otgfs rx status read and pop register, offset:0x20 More...
union {
__IO uint32_t grxfsiz
struct {
__IO uint32_t rxfdep: 16
__IO uint32_t reserved1: 16
} grxfsiz_bit
};
otgfs rx fifo size register, offset:0x24 More...
union {
__IO uint32_t gnptxfsiz_ept0tx
struct {
__IO uint32_t nptxfstaddr: 16
__IO uint32_t nptxfdep: 16
} gnptxfsiz_ept0tx_bit
};
otgfs non-periodic and ept0 tx fifo size register, offset:0x28 More...
union {
__IO uint32_t gnptxsts
struct {
__IO uint32_t nptxfspcavail: 16
__IO uint32_t nptxqspcavail: 8
__IO uint32_t nptxqtop: 7
} gnptxsts_bit
};
otgfs non-periodic tx fifo request queue status register, offset:0x2C More...
union {
__IO uint32_t gccfg
struct {
__IO uint32_t reserved1: 16
__IO uint32_t pwrdown: 1
__IO uint32_t lp_mode: 1
__IO uint32_t reserved2: 2
__IO uint32_t sofouten: 1
__IO uint32_t vbusig: 1
__IO uint32_t reserved3: 10
} gccfg_bit
};
otgfs general core configuration register, offset:0x38 More...
union {
__IO uint32_t guid
struct {
__IO uint32_t userid: 32
} guid_bit
};
otgfs core id register, offset:0x3C More...
union {
__IO uint32_t hptxfsiz
struct {
__IO uint32_t ptxfstaddr: 16
__IO uint32_t ptxfsize: 16
} hptxfsiz_bit
};
otgfs host periodic tx fifo size register, offset:0x100 More...
union {
__IO uint32_t dieptxfn [7]
struct {
__IO uint32_t ineptxfstaddr: 16
__IO uint32_t ineptxfdep: 16
} dieptxfn_bit [7]
};
otgfs host periodic tx fifo size register, offset:0x100 More...

Detailed Description

Definition at line 473 of file at32f435_437_usb.h.

Field Documentation

◆

union { ... } otg_global_type::@1150

otgfs control and status register, offset:0x00

◆

union { ... } otg_global_type::@1152

otgfs interrupt register, offset:0x04

◆

union { ... } otg_global_type::@1154

otgfs gahbcfg configuration register, offset:0x08

◆

union { ... } otg_global_type::@1156

otgfs usb configuration register, offset:0x0C

◆

union { ... } otg_global_type::@1158

otgfs reset register, offset:0x10

◆

union { ... } otg_global_type::@1160

otgfs core interrupt register, offset:0x14

◆

union { ... } otg_global_type::@1162

otgfs interrupt mask register, offset:0x18

◆

union { ... } otg_global_type::@1164

otgfs rx status debug read register, offset:0x1C

◆

union { ... } otg_global_type::@1166

otgfs rx status read and pop register, offset:0x20

◆

union { ... } otg_global_type::@1168

otgfs rx fifo size register, offset:0x24

◆

union { ... } otg_global_type::@1170

otgfs non-periodic and ept0 tx fifo size register, offset:0x28

◆

union { ... } otg_global_type::@1172

otgfs non-periodic tx fifo request queue status register, offset:0x2C

◆

union { ... } otg_global_type::@1174

otgfs general core configuration register, offset:0x38

◆

union { ... } otg_global_type::@1176

otgfs core id register, offset:0x3C

◆

union { ... } otg_global_type::@1178

otgfs host periodic tx fifo size register, offset:0x100

◆

union { ... } otg_global_type::@1180

otgfs host periodic tx fifo size register, offset:0x100

◆ ahbidle

__IO uint32_t otg_global_type::ahbidle

Definition at line 556 of file at32f435_437_usb.h.

Referenced by usb_global_reset().

◆ bcnt

__IO uint32_t otg_global_type::bcnt

Definition at line 649 of file at32f435_437_usb.h.

◆ chnum

__IO uint32_t otg_global_type::chnum

Definition at line 665 of file at32f435_437_usb.h.

◆ cidsts

__IO uint32_t otg_global_type::cidsts

Definition at line 484 of file at32f435_437_usb.h.

◆ conidschg

__IO uint32_t otg_global_type::conidschg

Definition at line 593 of file at32f435_437_usb.h.

◆ conidschgmsk

__IO uint32_t otg_global_type::conidschgmsk

Definition at line 633 of file at32f435_437_usb.h.

◆ cotxpkt

__IO uint32_t otg_global_type::cotxpkt

Definition at line 536 of file at32f435_437_usb.h.

◆ csftrst

__IO uint32_t otg_global_type::csftrst

Definition at line 548 of file at32f435_437_usb.h.

Referenced by usb_global_power_on(), and usb_global_reset().

◆ curmod

__IO uint32_t otg_global_type::curmod

Definition at line 486 of file at32f435_437_usb.h.

◆ curmode

__IO uint32_t otg_global_type::curmode

Definition at line 568 of file at32f435_437_usb.h.

Referenced by usbd_irq_handler(), and usbh_irq_handler().

◆ dieptxfn

__IO uint32_t otg_global_type::dieptxfn[7]

Definition at line 765 of file at32f435_437_usb.h.

Referenced by usb_set_tx_fifo(), and usbd_core_init().

◆

struct { ... } otg_global_type::dieptxfn_bit[7]

Referenced by usb_set_tx_fifo().

◆ disconint

__IO uint32_t otg_global_type::disconint

Definition at line 594 of file at32f435_437_usb.h.

◆ disconintmsk

__IO uint32_t otg_global_type::disconintmsk

Definition at line 634 of file at32f435_437_usb.h.

◆ dpid

__IO uint32_t otg_global_type::dpid

Definition at line 650 of file at32f435_437_usb.h.

◆ enumdone

__IO uint32_t otg_global_type::enumdone

Definition at line 580 of file at32f435_437_usb.h.

◆ enumdonemsk

__IO uint32_t otg_global_type::enumdonemsk

Definition at line 620 of file at32f435_437_usb.h.

◆ eopf

__IO uint32_t otg_global_type::eopf

Definition at line 582 of file at32f435_437_usb.h.

◆ eopfmsk

__IO uint32_t otg_global_type::eopfmsk

Definition at line 622 of file at32f435_437_usb.h.

◆ eptnum

__IO uint32_t otg_global_type::eptnum

Definition at line 648 of file at32f435_437_usb.h.

◆ erlysusp

__IO uint32_t otg_global_type::erlysusp

Definition at line 577 of file at32f435_437_usb.h.

◆ erlysuspmsk

__IO uint32_t otg_global_type::erlysuspmsk

Definition at line 617 of file at32f435_437_usb.h.

◆ fdevmode

__IO uint32_t otg_global_type::fdevmode

Definition at line 535 of file at32f435_437_usb.h.

Referenced by usb_global_set_mode().

◆ fhstmode

__IO uint32_t otg_global_type::fhstmode

Definition at line 534 of file at32f435_437_usb.h.

Referenced by usb_global_set_mode().

◆ fn

__IO uint32_t otg_global_type::fn

Definition at line 652 of file at32f435_437_usb.h.

◆ frmcntrst

__IO uint32_t otg_global_type::frmcntrst

Definition at line 550 of file at32f435_437_usb.h.

◆ gahbcfg

__IO uint32_t otg_global_type::gahbcfg

Definition at line 511 of file at32f435_437_usb.h.

◆

struct { ... } otg_global_type::gahbcfg_bit

Referenced by usb_host_disable(), usb_interrupt_disable(), and usb_interrupt_enable().

◆ gccfg

__IO uint32_t otg_global_type::gccfg

Definition at line 720 of file at32f435_437_usb.h.

◆

struct { ... } otg_global_type::gccfg_bit

Referenced by usb_global_init(), and usb_global_power_on().

◆ ginnakeff

__IO uint32_t otg_global_type::ginnakeff

Definition at line 574 of file at32f435_437_usb.h.

◆ ginnakeffmsk

__IO uint32_t otg_global_type::ginnakeffmsk

Definition at line 614 of file at32f435_437_usb.h.

◆ gintmsk

__IO uint32_t otg_global_type::gintmsk

Definition at line 605 of file at32f435_437_usb.h.

Referenced by usb_global_get_all_interrupt(), usb_global_interrupt_enable(), usbd_core_init(), and usbh_core_init().

◆

struct { ... } otg_global_type::gintmsk_bit

Referenced by usb_hc_enable(), usbh_in_out_request(), and usbh_rx_qlvl_handler().

◆ gintsts

__IO uint32_t otg_global_type::gintsts

Definition at line 565 of file at32f435_437_usb.h.

Referenced by usb_global_clear_interrupt(), usb_global_get_all_interrupt(), usb_host_disable(), usbd_core_init(), and usbh_core_init().

◆

struct { ... } otg_global_type::gintsts_bit

Referenced by usbd_irq_handler(), and usbh_irq_handler().

◆ glbintmsk

__IO uint32_t otg_global_type::glbintmsk

Definition at line 514 of file at32f435_437_usb.h.

Referenced by usb_host_disable(), usb_interrupt_disable(), and usb_interrupt_enable().

◆ gnptxfsiz_ept0tx

__IO uint32_t otg_global_type::gnptxfsiz_ept0tx

Definition at line 691 of file at32f435_437_usb.h.

Referenced by usb_set_tx_fifo().

◆

struct { ... } otg_global_type::gnptxfsiz_ept0tx_bit

Referenced by usb_set_tx_fifo(), and usbh_core_init().

◆ gnptxsts

__IO uint32_t otg_global_type::gnptxsts

Definition at line 704 of file at32f435_437_usb.h.

Referenced by usb_hch_halt().

◆

struct { ... } otg_global_type::gnptxsts_bit

Referenced by usbh_in_out_request().

◆ gotgctrl

__IO uint32_t otg_global_type::gotgctrl

Definition at line 480 of file at32f435_437_usb.h.

◆

struct { ... } otg_global_type::gotgctrl_bit

◆ gotgint

__IO uint32_t otg_global_type::gotgint

Definition at line 496 of file at32f435_437_usb.h.

◆

struct { ... } otg_global_type::gotgint_bit

◆ goutnakeff

__IO uint32_t otg_global_type::goutnakeff

Definition at line 575 of file at32f435_437_usb.h.

◆ goutnakeffmsk

__IO uint32_t otg_global_type::goutnakeffmsk

Definition at line 615 of file at32f435_437_usb.h.

◆ grstctl

__IO uint32_t otg_global_type::grstctl

Definition at line 545 of file at32f435_437_usb.h.

◆

struct { ... } otg_global_type::grstctl_bit

Referenced by usb_flush_rx_fifo(), usb_flush_tx_fifo(), usb_global_power_on(), and usb_global_reset().

◆ grxfsiz

__IO uint32_t otg_global_type::grxfsiz

Definition at line 678 of file at32f435_437_usb.h.

Referenced by usb_set_rx_fifo(), usb_set_tx_fifo(), and usbh_core_init().

◆

struct { ... } otg_global_type::grxfsiz_bit

◆ grxstsp

__IO uint32_t otg_global_type::grxstsp

Definition at line 662 of file at32f435_437_usb.h.

Referenced by usbd_rxflvl_handler(), and usbh_rx_qlvl_handler().

◆

struct { ... } otg_global_type::grxstsp_bit

◆ grxstsr

__IO uint32_t otg_global_type::grxstsr

Definition at line 645 of file at32f435_437_usb.h.

◆

struct { ... } otg_global_type::grxstsr_bit

◆ guid

__IO uint32_t otg_global_type::guid

Definition at line 738 of file at32f435_437_usb.h.

◆

struct { ... } otg_global_type::guid_bit

◆ gusbcfg

__IO uint32_t otg_global_type::gusbcfg

Definition at line 527 of file at32f435_437_usb.h.

◆

struct { ... } otg_global_type::gusbcfg_bit

Referenced by usb_global_set_mode(), and usbd_enumdone_handler().

◆ hchint

__IO uint32_t otg_global_type::hchint

Definition at line 590 of file at32f435_437_usb.h.

◆ hchintmsk

__IO uint32_t otg_global_type::hchintmsk

Definition at line 630 of file at32f435_437_usb.h.

Referenced by usb_hc_enable().

◆ hptxfsiz

__IO uint32_t otg_global_type::hptxfsiz

Definition at line 752 of file at32f435_437_usb.h.

◆

struct { ... } otg_global_type::hptxfsiz_bit

Referenced by usbh_core_init().

◆ ieptint

__IO uint32_t otg_global_type::ieptint

Definition at line 584 of file at32f435_437_usb.h.

◆ ieptintmsk

__IO uint32_t otg_global_type::ieptintmsk

Definition at line 624 of file at32f435_437_usb.h.

◆ incompip_incompisoout

__IO uint32_t otg_global_type::incompip_incompisoout

Definition at line 587 of file at32f435_437_usb.h.

◆ incompip_incompisooutmsk

__IO uint32_t otg_global_type::incompip_incompisooutmsk

Definition at line 627 of file at32f435_437_usb.h.

◆ incompisoin

__IO uint32_t otg_global_type::incompisoin

Definition at line 586 of file at32f435_437_usb.h.

◆ incompisoinmsk

__IO uint32_t otg_global_type::incompisoinmsk

Definition at line 626 of file at32f435_437_usb.h.

◆ ineptxfdep

__IO uint32_t otg_global_type::ineptxfdep

Definition at line 769 of file at32f435_437_usb.h.

Referenced by usb_set_tx_fifo().

◆ ineptxfstaddr

__IO uint32_t otg_global_type::ineptxfstaddr

Definition at line 768 of file at32f435_437_usb.h.

◆ isooutdrop

__IO uint32_t otg_global_type::isooutdrop

Definition at line 581 of file at32f435_437_usb.h.

◆ isooutdropmsk

__IO uint32_t otg_global_type::isooutdropmsk

Definition at line 621 of file at32f435_437_usb.h.

◆ lp_mode

__IO uint32_t otg_global_type::lp_mode

Definition at line 725 of file at32f435_437_usb.h.

◆ modemis

__IO uint32_t otg_global_type::modemis

Definition at line 569 of file at32f435_437_usb.h.

◆ modemismsk

__IO uint32_t otg_global_type::modemismsk

Definition at line 609 of file at32f435_437_usb.h.

◆ nptxfdep

__IO uint32_t otg_global_type::nptxfdep

Definition at line 695 of file at32f435_437_usb.h.

Referenced by usb_set_tx_fifo(), and usbh_core_init().

◆ nptxfemp

__IO uint32_t otg_global_type::nptxfemp

Definition at line 573 of file at32f435_437_usb.h.

◆ nptxfemplvl

__IO uint32_t otg_global_type::nptxfemplvl

Definition at line 516 of file at32f435_437_usb.h.

◆ nptxfempmsk

__IO uint32_t otg_global_type::nptxfempmsk

Definition at line 613 of file at32f435_437_usb.h.

Referenced by usbh_in_out_request().

◆ nptxfspcavail

__IO uint32_t otg_global_type::nptxfspcavail

Definition at line 707 of file at32f435_437_usb.h.

Referenced by usbh_in_out_request().

◆ nptxfstaddr

__IO uint32_t otg_global_type::nptxfstaddr

Definition at line 694 of file at32f435_437_usb.h.

Referenced by usbh_core_init().

◆ nptxqspcavail

__IO uint32_t otg_global_type::nptxqspcavail

Definition at line 708 of file at32f435_437_usb.h.

◆ nptxqtop

__IO uint32_t otg_global_type::nptxqtop

Definition at line 709 of file at32f435_437_usb.h.

◆ oeptint

__IO uint32_t otg_global_type::oeptint

Definition at line 585 of file at32f435_437_usb.h.

◆ oeptintmsk

__IO uint32_t otg_global_type::oeptintmsk

Definition at line 625 of file at32f435_437_usb.h.

◆ otgint

__IO uint32_t otg_global_type::otgint

Definition at line 570 of file at32f435_437_usb.h.

◆ otgintmsk

__IO uint32_t otg_global_type::otgintmsk

Definition at line 610 of file at32f435_437_usb.h.

◆ piusftrst

__IO uint32_t otg_global_type::piusftrst

Definition at line 549 of file at32f435_437_usb.h.

◆ pktsts

__IO uint32_t otg_global_type::pktsts

Definition at line 651 of file at32f435_437_usb.h.

◆ prtint

__IO uint32_t otg_global_type::prtint

Definition at line 589 of file at32f435_437_usb.h.

◆ prtintmsk

__IO uint32_t otg_global_type::prtintmsk

Definition at line 629 of file at32f435_437_usb.h.

◆ ptxfemp

__IO uint32_t otg_global_type::ptxfemp

Definition at line 591 of file at32f435_437_usb.h.

◆ ptxfemplvl

__IO uint32_t otg_global_type::ptxfemplvl

Definition at line 517 of file at32f435_437_usb.h.

◆ ptxfempmsk

__IO uint32_t otg_global_type::ptxfempmsk

Definition at line 631 of file at32f435_437_usb.h.

Referenced by usbh_in_out_request().

◆ ptxfsize

__IO uint32_t otg_global_type::ptxfsize

Definition at line 756 of file at32f435_437_usb.h.

Referenced by usbh_core_init().

◆ ptxfstaddr

__IO uint32_t otg_global_type::ptxfstaddr

Definition at line 755 of file at32f435_437_usb.h.

Referenced by usbh_core_init().

◆ pwrdown

__IO uint32_t otg_global_type::pwrdown

Definition at line 724 of file at32f435_437_usb.h.

Referenced by usb_global_init(), and usb_global_power_on().

◆ reserved1

__IO uint32_t otg_global_type::reserved1

Definition at line 483 of file at32f435_437_usb.h.

◆ reserved2

__IO uint32_t otg_global_type::reserved2

Definition at line 485 of file at32f435_437_usb.h.

◆ reserved3

__IO uint32_t otg_global_type::reserved3

Definition at line 487 of file at32f435_437_usb.h.

◆ reserved4

__IO uint32_t otg_global_type::reserved4

Definition at line 592 of file at32f435_437_usb.h.

◆ reserved5

__IO uint32_t otg_global_type::reserved5

Definition at line 595 of file at32f435_437_usb.h.

◆ reserved6

__IO uint32_t otg_global_type::reserved6

Definition at line 635 of file at32f435_437_usb.h.

◆ rxfdep

__IO uint32_t otg_global_type::rxfdep

Definition at line 681 of file at32f435_437_usb.h.

◆ rxfflsh

__IO uint32_t otg_global_type::rxfflsh

Definition at line 552 of file at32f435_437_usb.h.

Referenced by usb_flush_rx_fifo().

◆ rxflvl

__IO uint32_t otg_global_type::rxflvl

Definition at line 572 of file at32f435_437_usb.h.

◆ rxflvlmsk

__IO uint32_t otg_global_type::rxflvlmsk

Definition at line 612 of file at32f435_437_usb.h.

Referenced by usbh_rx_qlvl_handler().

◆ sesenddet

__IO uint32_t otg_global_type::sesenddet

Definition at line 500 of file at32f435_437_usb.h.

◆ sof

__IO uint32_t otg_global_type::sof

Definition at line 571 of file at32f435_437_usb.h.

◆ sofmsk

__IO uint32_t otg_global_type::sofmsk

Definition at line 611 of file at32f435_437_usb.h.

◆ sofouten

__IO uint32_t otg_global_type::sofouten

Definition at line 727 of file at32f435_437_usb.h.

◆ toutcal

__IO uint32_t otg_global_type::toutcal

Definition at line 530 of file at32f435_437_usb.h.

◆ txfflsh

__IO uint32_t otg_global_type::txfflsh

Definition at line 553 of file at32f435_437_usb.h.

Referenced by usb_flush_tx_fifo().

◆ txfnum

__IO uint32_t otg_global_type::txfnum

Definition at line 554 of file at32f435_437_usb.h.

Referenced by usb_flush_tx_fifo().

◆ usbrst

__IO uint32_t otg_global_type::usbrst

Definition at line 579 of file at32f435_437_usb.h.

◆ usbrstmsk

__IO uint32_t otg_global_type::usbrstmsk

Definition at line 619 of file at32f435_437_usb.h.

◆ usbsusp

__IO uint32_t otg_global_type::usbsusp

Definition at line 578 of file at32f435_437_usb.h.

◆ usbsuspmsk

__IO uint32_t otg_global_type::usbsuspmsk

Definition at line 618 of file at32f435_437_usb.h.

◆ usbtrdtim

__IO uint32_t otg_global_type::usbtrdtim

Definition at line 532 of file at32f435_437_usb.h.

Referenced by usbd_enumdone_handler().

◆ userid

__IO uint32_t otg_global_type::userid

Definition at line 741 of file at32f435_437_usb.h.

◆ vbusig

__IO uint32_t otg_global_type::vbusig

Definition at line 728 of file at32f435_437_usb.h.

◆ wkupint

__IO uint32_t otg_global_type::wkupint

Definition at line 596 of file at32f435_437_usb.h.

◆ wkupintmsk

__IO uint32_t otg_global_type::wkupintmsk

Definition at line 636 of file at32f435_437_usb.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_usb.h


AT32F435/437 Firmwary Library: otg_host_type Struct Reference

Data Fields
otg_host_type Struct Reference
AT32F435_437_periph_driver » USB » USB_exported_types

#include <at32f435_437_usb.h>

Data Fields

union {
__IO uint32_t hcfg
struct {
__IO uint32_t fslspclksel: 2
__IO uint32_t fslssupp: 1
__IO uint32_t reserved1: 29
} hcfg_bit
};
otgfs host mode configuration register, offset:0x400 More...
union {
__IO uint32_t hfir
struct {
__IO uint32_t frint: 16
__IO uint32_t reserved1: 16
} hfir_bit
};
otgfs host frame interval register, offset:0x404 More...
union {
__IO uint32_t hfnum
struct {
__IO uint32_t frnum: 16
__IO uint32_t ftrem: 16
} hfnum_bit
};
otgfs host frame number and time remaining register, offset:0x408 More...
union {
__IO uint32_t hptxsts
struct {
__IO uint32_t ptxfspcavil: 16
__IO uint32_t ptxqspcavil: 8
__IO uint32_t ptxqtop: 8
} hptxsts_bit
};
otgfs host periodic tx fifo request queue register, offset:0x410 More...
union {
__IO uint32_t haint
struct {
__IO uint32_t haint: 16
__IO uint32_t reserved1: 16
} haint_bit
};
otgfs host all channel interrupt register, offset:0x414 More...
union {
__IO uint32_t haintmsk
struct {
__IO uint32_t haintmsk: 16
__IO uint32_t reserved1: 16
} haintmsk_bit
};
otgfs host all channel interrupt mask register, offset:0x418 More...
__IO uint32_t reserved2 [9]
union {
__IO uint32_t hprt
struct {
__IO uint32_t prtconsts: 1
__IO uint32_t prtcondet: 1
__IO uint32_t prtena: 1
__IO uint32_t prtenchng: 1
__IO uint32_t prtovrcact: 1
__IO uint32_t prtovrcchng: 1
__IO uint32_t prtres: 1
__IO uint32_t prtsusp: 1
__IO uint32_t prtrst: 1
__IO uint32_t reserved1: 1
__IO uint32_t prtlnsts: 2
__IO uint32_t prtpwr: 1
__IO uint32_t prttsctl: 4
__IO uint32_t prtspd: 2
__IO uint32_t reserved2: 13
} hprt_bit
};
otgfs host port control and status register, offset:0x440 More...

Detailed Description

Definition at line 775 of file at32f435_437_usb.h.

Field Documentation

◆

union { ... } otg_host_type::@1198

otgfs host mode configuration register, offset:0x400

◆

union { ... } otg_host_type::@1200

otgfs host frame interval register, offset:0x404

◆

union { ... } otg_host_type::@1202

otgfs host frame number and time remaining register, offset:0x408

◆

union { ... } otg_host_type::@1204

otgfs host periodic tx fifo request queue register, offset:0x410

◆

union { ... } otg_host_type::@1206

otgfs host all channel interrupt register, offset:0x414

◆

union { ... } otg_host_type::@1208

otgfs host all channel interrupt mask register, offset:0x418

◆

union { ... } otg_host_type::@1210

otgfs host port control and status register, offset:0x440

◆ frint

__IO uint32_t otg_host_type::frint

Definition at line 799 of file at32f435_437_usb.h.

◆ frnum

__IO uint32_t otg_host_type::frnum

Definition at line 812 of file at32f435_437_usb.h.

◆ fslspclksel

__IO uint32_t otg_host_type::fslspclksel

Definition at line 785 of file at32f435_437_usb.h.

Referenced by usbh_fsls_clksel().

◆ fslssupp

__IO uint32_t otg_host_type::fslssupp

Definition at line 786 of file at32f435_437_usb.h.

Referenced by usbh_core_init().

◆ ftrem

__IO uint32_t otg_host_type::ftrem

Definition at line 813 of file at32f435_437_usb.h.

◆ haint

__IO uint32_t otg_host_type::haint

Definition at line 838 of file at32f435_437_usb.h.

Referenced by usb_hch_read_interrupt(), usb_host_disable(), and usbh_hch_handler().

◆

struct { ... } otg_host_type::haint_bit

◆ haintmsk

__IO uint32_t otg_host_type::haintmsk

Definition at line 851 of file at32f435_437_usb.h.

Referenced by usb_hc_enable().

◆

struct { ... } otg_host_type::haintmsk_bit

◆ hcfg

__IO uint32_t otg_host_type::hcfg

Definition at line 782 of file at32f435_437_usb.h.

◆

struct { ... } otg_host_type::hcfg_bit

Referenced by usbh_core_init(), and usbh_fsls_clksel().

◆ hfir

__IO uint32_t otg_host_type::hfir

Definition at line 796 of file at32f435_437_usb.h.

Referenced by usbh_fsls_clksel().

◆

struct { ... } otg_host_type::hfir_bit

◆ hfnum

__IO uint32_t otg_host_type::hfnum

Definition at line 809 of file at32f435_437_usb.h.

Referenced by usbh_get_frame().

◆

struct { ... } otg_host_type::hfnum_bit

◆ hprt

__IO uint32_t otg_host_type::hprt

Definition at line 866 of file at32f435_437_usb.h.

Referenced by usb_port_power_on(), usbh_enter_suspend(), usbh_port_handler(), usbh_reset_port(), and usbh_resume().

◆

struct { ... } otg_host_type::hprt_bit

◆ hptxsts

__IO uint32_t otg_host_type::hptxsts

Definition at line 824 of file at32f435_437_usb.h.

Referenced by usb_hch_halt().

◆

struct { ... } otg_host_type::hptxsts_bit

◆ prtcondet

__IO uint32_t otg_host_type::prtcondet

Definition at line 870 of file at32f435_437_usb.h.

◆ prtconsts

__IO uint32_t otg_host_type::prtconsts

Definition at line 869 of file at32f435_437_usb.h.

◆ prtena

__IO uint32_t otg_host_type::prtena

Definition at line 871 of file at32f435_437_usb.h.

◆ prtenchng

__IO uint32_t otg_host_type::prtenchng

Definition at line 872 of file at32f435_437_usb.h.

◆ prtlnsts

__IO uint32_t otg_host_type::prtlnsts

Definition at line 879 of file at32f435_437_usb.h.

◆ prtovrcact

__IO uint32_t otg_host_type::prtovrcact

Definition at line 873 of file at32f435_437_usb.h.

◆ prtovrcchng

__IO uint32_t otg_host_type::prtovrcchng

Definition at line 874 of file at32f435_437_usb.h.

◆ prtpwr

__IO uint32_t otg_host_type::prtpwr

Definition at line 880 of file at32f435_437_usb.h.

◆ prtres

__IO uint32_t otg_host_type::prtres

Definition at line 875 of file at32f435_437_usb.h.

◆ prtrst

__IO uint32_t otg_host_type::prtrst

Definition at line 877 of file at32f435_437_usb.h.

◆ prtspd

__IO uint32_t otg_host_type::prtspd

Definition at line 882 of file at32f435_437_usb.h.

◆ prtsusp

__IO uint32_t otg_host_type::prtsusp

Definition at line 876 of file at32f435_437_usb.h.

◆ prttsctl

__IO uint32_t otg_host_type::prttsctl

Definition at line 881 of file at32f435_437_usb.h.

◆ ptxfspcavil

__IO uint32_t otg_host_type::ptxfspcavil

Definition at line 827 of file at32f435_437_usb.h.

◆ ptxqspcavil

__IO uint32_t otg_host_type::ptxqspcavil

Definition at line 828 of file at32f435_437_usb.h.

◆ ptxqtop

__IO uint32_t otg_host_type::ptxqtop

Definition at line 829 of file at32f435_437_usb.h.

◆ reserved1

__IO uint32_t otg_host_type::reserved1

Definition at line 787 of file at32f435_437_usb.h.

◆ reserved2

__IO uint32_t otg_host_type::reserved2

Definition at line 859 of file at32f435_437_usb.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_usb.h


AT32F435/437 Firmwary Library: otg_hchannel_type Struct Reference

Data Fields
otg_hchannel_type Struct Reference
AT32F435_437_periph_driver » USB » USB_exported_types

#include <at32f435_437_usb.h>

Data Fields

union {
__IO uint32_t hcchar
struct {
__IO uint32_t mps: 11
__IO uint32_t eptnum: 4
__IO uint32_t eptdir: 1
__IO uint32_t reserved1: 1
__IO uint32_t lspddev: 1
__IO uint32_t eptype: 2
__IO uint32_t mc: 2
__IO uint32_t devaddr: 7
__IO uint32_t oddfrm: 1
__IO uint32_t chdis: 1
__IO uint32_t chena: 1
} hcchar_bit
};
otgfs host channel x characterisic register, offset:0x500 More...
union {
__IO uint32_t hcsplt
struct {
__IO uint32_t prtaddr: 7
__IO uint32_t hubaddr: 7
__IO uint32_t xactpos: 2
__IO uint32_t compsplt: 1
__IO uint32_t reserved1: 14
__IO uint32_t spltena: 1
} hcsplt_bit
};
otgfs host channel split control register, offset:0x504 More...
union {
__IO uint32_t hcint
struct {
__IO uint32_t xferc: 1
__IO uint32_t chhltd: 1
__IO uint32_t reserved1: 1
__IO uint32_t stall: 1
__IO uint32_t nak: 1
__IO uint32_t ack: 1
__IO uint32_t reserved2: 1
__IO uint32_t xacterr: 1
__IO uint32_t bblerr: 1
__IO uint32_t frmovrun: 1
__IO uint32_t dtglerr: 1
__IO uint32_t reserved3: 21
} hcint_bit
};
otgfs host channel interrupt register, offset:0x508 More...
union {
__IO uint32_t hcintmsk
struct {
__IO uint32_t xfercmsk: 1
__IO uint32_t chhltdmsk: 1
__IO uint32_t reserved1: 1
__IO uint32_t stallmsk: 1
__IO uint32_t nakmsk: 1
__IO uint32_t ackmsk: 1
__IO uint32_t reserved2: 1
__IO uint32_t xacterrmsk: 1
__IO uint32_t bblerrmsk: 1
__IO uint32_t frmovrunmsk: 1
__IO uint32_t dtglerrmsk: 1
__IO uint32_t reserved3: 21
} hcintmsk_bit
};
otgfs host channel interrupt mask register, offset:0x50C More...
union {
__IO uint32_t hctsiz
struct {
__IO uint32_t xfersize: 19
__IO uint32_t pktcnt: 10
__IO uint32_t pid: 2
__IO uint32_t reserved1: 1
} hctsiz_bit
};
otgfs host channel transfer size register, offset:0x510 More...

Detailed Description

Definition at line 889 of file at32f435_437_usb.h.

Field Documentation

◆

union { ... } otg_hchannel_type::@1219

otgfs host channel x characterisic register, offset:0x500

◆

union { ... } otg_hchannel_type::@1221

otgfs host channel split control register, offset:0x504

◆

union { ... } otg_hchannel_type::@1223

otgfs host channel interrupt register, offset:0x508

◆

union { ... } otg_hchannel_type::@1225

otgfs host channel interrupt mask register, offset:0x50C

◆

union { ... } otg_hchannel_type::@1227

otgfs host channel transfer size register, offset:0x510

◆ ack

__IO uint32_t otg_hchannel_type::ack

Definition at line 943 of file at32f435_437_usb.h.

◆ ackmsk

__IO uint32_t otg_hchannel_type::ackmsk

Definition at line 966 of file at32f435_437_usb.h.

◆ bblerr

__IO uint32_t otg_hchannel_type::bblerr

Definition at line 946 of file at32f435_437_usb.h.

◆ bblerrmsk

__IO uint32_t otg_hchannel_type::bblerrmsk

Definition at line 969 of file at32f435_437_usb.h.

Referenced by usb_hc_enable().

◆ chdis

__IO uint32_t otg_hchannel_type::chdis

Definition at line 908 of file at32f435_437_usb.h.

Referenced by usb_hch_halt(), usb_host_disable(), usbh_hch_in_handler(), usbh_hch_out_handler(), and usbh_rx_qlvl_handler().

◆ chena

__IO uint32_t otg_hchannel_type::chena

Definition at line 909 of file at32f435_437_usb.h.

Referenced by usb_hch_halt(), usb_host_disable(), usbh_hch_in_handler(), usbh_hch_out_handler(), and usbh_rx_qlvl_handler().

◆ chhltd

__IO uint32_t otg_hchannel_type::chhltd

Definition at line 939 of file at32f435_437_usb.h.

◆ chhltdmsk

__IO uint32_t otg_hchannel_type::chhltdmsk

Definition at line 962 of file at32f435_437_usb.h.

Referenced by usbh_hch_in_handler(), and usbh_hch_out_handler().

◆ compsplt

__IO uint32_t otg_hchannel_type::compsplt

Definition at line 924 of file at32f435_437_usb.h.

◆ devaddr

__IO uint32_t otg_hchannel_type::devaddr

Definition at line 906 of file at32f435_437_usb.h.

Referenced by usb_hc_enable().

◆ dtglerr

__IO uint32_t otg_hchannel_type::dtglerr

Definition at line 948 of file at32f435_437_usb.h.

◆ dtglerrmsk

__IO uint32_t otg_hchannel_type::dtglerrmsk

Definition at line 971 of file at32f435_437_usb.h.

◆ eptdir

__IO uint32_t otg_hchannel_type::eptdir

Definition at line 901 of file at32f435_437_usb.h.

Referenced by usb_hc_enable(), usb_hch_halt(), and usb_host_disable().

◆ eptnum

__IO uint32_t otg_hchannel_type::eptnum

Definition at line 900 of file at32f435_437_usb.h.

Referenced by usb_hc_enable().

◆ eptype

__IO uint32_t otg_hchannel_type::eptype

Definition at line 904 of file at32f435_437_usb.h.

Referenced by usb_hc_enable(), usb_hch_halt(), and usbh_hch_in_handler().

◆ frmovrun

__IO uint32_t otg_hchannel_type::frmovrun

Definition at line 947 of file at32f435_437_usb.h.

◆ frmovrunmsk

__IO uint32_t otg_hchannel_type::frmovrunmsk

Definition at line 970 of file at32f435_437_usb.h.

◆ hcchar

__IO uint32_t otg_hchannel_type::hcchar

Definition at line 896 of file at32f435_437_usb.h.

Referenced by usbh_in_out_request().

◆

struct { ... } otg_hchannel_type::hcchar_bit

Referenced by usb_hc_enable(), usb_hch_halt(), usb_host_disable(), usbh_hch_in_handler(), usbh_hch_out_handler(), usbh_in_out_request(), and usbh_rx_qlvl_handler().

◆ hcint

__IO uint32_t otg_hchannel_type::hcint

Definition at line 935 of file at32f435_437_usb.h.

Referenced by usbh_hch_in_handler(), and usbh_hch_out_handler().

◆

struct { ... } otg_hchannel_type::hcint_bit

◆ hcintmsk

__IO uint32_t otg_hchannel_type::hcintmsk

Definition at line 958 of file at32f435_437_usb.h.

Referenced by usb_hc_enable(), usbh_hch_in_handler(), and usbh_hch_out_handler().

◆

struct { ... } otg_hchannel_type::hcintmsk_bit

Referenced by usb_hc_enable(), usbh_hch_in_handler(), and usbh_hch_out_handler().

◆ hcsplt

__IO uint32_t otg_hchannel_type::hcsplt

Definition at line 918 of file at32f435_437_usb.h.

◆

struct { ... } otg_hchannel_type::hcsplt_bit

◆ hctsiz

__IO uint32_t otg_hchannel_type::hctsiz

Definition at line 981 of file at32f435_437_usb.h.

Referenced by usbh_in_out_request().

◆

struct { ... } otg_hchannel_type::hctsiz_bit

Referenced by usbh_rx_qlvl_handler().

◆ hubaddr

__IO uint32_t otg_hchannel_type::hubaddr

Definition at line 922 of file at32f435_437_usb.h.

◆ lspddev

__IO uint32_t otg_hchannel_type::lspddev

Definition at line 903 of file at32f435_437_usb.h.

Referenced by usb_hc_enable().

◆ mc

__IO uint32_t otg_hchannel_type::mc

Definition at line 905 of file at32f435_437_usb.h.

◆ mps

__IO uint32_t otg_hchannel_type::mps

Definition at line 899 of file at32f435_437_usb.h.

Referenced by usb_hc_enable().

◆ nak

__IO uint32_t otg_hchannel_type::nak

Definition at line 942 of file at32f435_437_usb.h.

◆ nakmsk

__IO uint32_t otg_hchannel_type::nakmsk

Definition at line 965 of file at32f435_437_usb.h.

◆ oddfrm

__IO uint32_t otg_hchannel_type::oddfrm

Definition at line 907 of file at32f435_437_usb.h.

Referenced by usb_hc_enable(), usbh_hch_in_handler(), and usbh_in_out_request().

◆ pid

__IO uint32_t otg_hchannel_type::pid

Definition at line 986 of file at32f435_437_usb.h.

◆ pktcnt

__IO uint32_t otg_hchannel_type::pktcnt

Definition at line 985 of file at32f435_437_usb.h.

Referenced by usbh_rx_qlvl_handler().

◆ prtaddr

__IO uint32_t otg_hchannel_type::prtaddr

Definition at line 921 of file at32f435_437_usb.h.

◆ reserved1

__IO uint32_t otg_hchannel_type::reserved1

Definition at line 902 of file at32f435_437_usb.h.

◆ reserved2

__IO uint32_t otg_hchannel_type::reserved2

Definition at line 944 of file at32f435_437_usb.h.

◆ reserved3

__IO uint32_t otg_hchannel_type::reserved3

Definition at line 949 of file at32f435_437_usb.h.

◆ spltena

__IO uint32_t otg_hchannel_type::spltena

Definition at line 926 of file at32f435_437_usb.h.

◆ stall

__IO uint32_t otg_hchannel_type::stall

Definition at line 941 of file at32f435_437_usb.h.

◆ stallmsk

__IO uint32_t otg_hchannel_type::stallmsk

Definition at line 964 of file at32f435_437_usb.h.

◆ xacterr

__IO uint32_t otg_hchannel_type::xacterr

Definition at line 945 of file at32f435_437_usb.h.

◆ xacterrmsk

__IO uint32_t otg_hchannel_type::xacterrmsk

Definition at line 968 of file at32f435_437_usb.h.

◆ xactpos

__IO uint32_t otg_hchannel_type::xactpos

Definition at line 923 of file at32f435_437_usb.h.

◆ xferc

__IO uint32_t otg_hchannel_type::xferc

Definition at line 938 of file at32f435_437_usb.h.

◆ xfercmsk

__IO uint32_t otg_hchannel_type::xfercmsk

Definition at line 961 of file at32f435_437_usb.h.

◆ xfersize

__IO uint32_t otg_hchannel_type::xfersize

Definition at line 984 of file at32f435_437_usb.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_usb.h


AT32F435/437 Firmwary Library: otg_device_type Struct Reference

Data Fields
otg_device_type Struct Reference
AT32F435_437_periph_driver » USB » USB_exported_types

#include <at32f435_437_usb.h>

Data Fields

union {
__IO uint32_t dcfg
struct {
__IO uint32_t devspd: 2
__IO uint32_t nzstsouthshk: 1
__IO uint32_t reserved1: 1
__IO uint32_t devaddr: 7
__IO uint32_t perfrint: 2
__IO uint32_t reserved2: 19
} dcfg_bit
};
otgfs device configuration register, offset:0x800 More...
union {
__IO uint32_t dctl
struct {
__IO uint32_t rwkupsig: 1
__IO uint32_t sftdiscon: 1
__IO uint32_t gnpinnaksts: 1
__IO uint32_t goutnaksts: 1
__IO uint32_t tstctl: 3
__IO uint32_t sgnpinak: 1
__IO uint32_t cgnpinak: 1
__IO uint32_t sgoutnak: 1
__IO uint32_t cgoutnak: 1
__IO uint32_t pwroprgdne: 1
__IO uint32_t reserved1: 20
} dctl_bit
};
otgfs device controls register, offset:0x804 More...
union {
__IO uint32_t dsts
struct {
__IO uint32_t suspsts: 1
__IO uint32_t enumspd: 2
__IO uint32_t eticerr: 1
__IO uint32_t reserved1: 4
__IO uint32_t soffn: 14
__IO uint32_t reserved2: 10
} dsts_bit
};
otgfs device status register, offset:0x80C More...
union {
__IO uint32_t diepmsk
struct {
__IO uint32_t xfercmsk: 1
__IO uint32_t eptdismsk: 1
__IO uint32_t reserved1: 1
__IO uint32_t timeoutmsk: 1
__IO uint32_t intkntxfempmsk: 1
__IO uint32_t intkneptmismsk: 1
__IO uint32_t ineptnakmsk: 1
__IO uint32_t reserved2: 1
__IO uint32_t txfifoudrmsk: 1
__IO uint32_t bnainmsk: 1
__IO uint32_t reserved3: 22
} diepmsk_bit
};
otgfs device in endpoint general interrupt mask register, offset:0x810 More...
union {
__IO uint32_t doepmsk
struct {
__IO uint32_t xfercmsk: 1
__IO uint32_t eptdismsk: 1
__IO uint32_t reserved1: 1
__IO uint32_t setupmsk: 1
__IO uint32_t outtepdmsk: 1
__IO uint32_t reserved2: 1
__IO uint32_t b2bsetupmsk: 1
__IO uint32_t reserved3: 1
__IO uint32_t outperrmsk: 1
__IO uint32_t bnaoutmsk: 1
__IO uint32_t reserved4: 22
} doepmsk_bit
};
otgfs device out endpoint general interrupt mask register, offset:0x814 More...
union {
__IO uint32_t daint
struct {
__IO uint32_t ineptint: 16
__IO uint32_t outeptint: 16
} daint_bit
};
otgfs device all endpoint interrupt register, offset:0x818 More...
union {
__IO uint32_t daintmsk
struct {
__IO uint32_t ineptmsk: 16
__IO uint32_t outeptmsk: 16
} daintmsk_bit
};
otgfs device all endpoint interrupt mask register, offset:0x81C More...
union {
__IO uint32_t diepempmsk
struct {
__IO uint32_t ineptxfemsk: 16
__IO uint32_t reserved1: 16
} diepempmsk_bit
};
otgfs device in endpoint fifo empty interrupt mask register, offset:0x834 More...

Detailed Description

Definition at line 995 of file at32f435_437_usb.h.

Field Documentation

◆

union { ... } otg_device_type::@1234

otgfs device configuration register, offset:0x800

◆

union { ... } otg_device_type::@1236

otgfs device controls register, offset:0x804

◆

union { ... } otg_device_type::@1238

otgfs device status register, offset:0x80C

◆

union { ... } otg_device_type::@1240

otgfs device in endpoint general interrupt mask register, offset:0x810

◆

union { ... } otg_device_type::@1242

otgfs device out endpoint general interrupt mask register, offset:0x814

◆

union { ... } otg_device_type::@1244

otgfs device all endpoint interrupt register, offset:0x818

◆

union { ... } otg_device_type::@1246

otgfs device all endpoint interrupt mask register, offset:0x81C

◆

union { ... } otg_device_type::@1248

otgfs device in endpoint fifo empty interrupt mask register, offset:0x834

◆ b2bsetupmsk

__IO uint32_t otg_device_type::b2bsetupmsk

Definition at line 1090 of file at32f435_437_usb.h.

◆ bnainmsk

__IO uint32_t otg_device_type::bnainmsk

Definition at line 1071 of file at32f435_437_usb.h.

◆ bnaoutmsk

__IO uint32_t otg_device_type::bnaoutmsk

Definition at line 1093 of file at32f435_437_usb.h.

◆ cgnpinak

__IO uint32_t otg_device_type::cgnpinak

Definition at line 1028 of file at32f435_437_usb.h.

◆ cgoutnak

__IO uint32_t otg_device_type::cgoutnak

Definition at line 1030 of file at32f435_437_usb.h.

◆ daint

__IO uint32_t otg_device_type::daint

Definition at line 1103 of file at32f435_437_usb.h.

Referenced by usbd_core_init(), and usbd_reset_handler().

◆

struct { ... } otg_device_type::daint_bit

◆ daintmsk

__IO uint32_t otg_device_type::daintmsk

Definition at line 1116 of file at32f435_437_usb.h.

Referenced by usbd_core_init(), and usbd_reset_handler().

◆

struct { ... } otg_device_type::daintmsk_bit

◆ dcfg

__IO uint32_t otg_device_type::dcfg

Definition at line 1002 of file at32f435_437_usb.h.

◆

struct { ... } otg_device_type::dcfg_bit

Referenced by usbd_core_init().

◆ dctl

__IO uint32_t otg_device_type::dctl

Definition at line 1019 of file at32f435_437_usb.h.

◆

struct { ... } otg_device_type::dctl_bit

Referenced by usbd_reset_handler().

◆ devaddr

__IO uint32_t otg_device_type::devaddr

Definition at line 1008 of file at32f435_437_usb.h.

◆ devspd

__IO uint32_t otg_device_type::devspd

Definition at line 1005 of file at32f435_437_usb.h.

Referenced by usbd_core_init().

◆ diepempmsk

__IO uint32_t otg_device_type::diepempmsk

Definition at line 1131 of file at32f435_437_usb.h.

Referenced by usbd_ept_send().

◆

struct { ... } otg_device_type::diepempmsk_bit

◆ diepmsk

__IO uint32_t otg_device_type::diepmsk

Definition at line 1059 of file at32f435_437_usb.h.

Referenced by usbd_core_init().

◆

struct { ... } otg_device_type::diepmsk_bit

Referenced by usbd_core_init(), and usbd_reset_handler().

◆ doepmsk

__IO uint32_t otg_device_type::doepmsk

Definition at line 1081 of file at32f435_437_usb.h.

Referenced by usbd_core_init().

◆

struct { ... } otg_device_type::doepmsk_bit

Referenced by usbd_reset_handler().

◆ dsts

__IO uint32_t otg_device_type::dsts

Definition at line 1041 of file at32f435_437_usb.h.

◆

struct { ... } otg_device_type::dsts_bit

Referenced by usbd_ept_recv(), and usbd_ept_send().

◆ enumspd

__IO uint32_t otg_device_type::enumspd

Definition at line 1045 of file at32f435_437_usb.h.

◆ eptdismsk

__IO uint32_t otg_device_type::eptdismsk

Definition at line 1063 of file at32f435_437_usb.h.

Referenced by usbd_reset_handler().

◆ eticerr

__IO uint32_t otg_device_type::eticerr

Definition at line 1046 of file at32f435_437_usb.h.

◆ gnpinnaksts

__IO uint32_t otg_device_type::gnpinnaksts

Definition at line 1024 of file at32f435_437_usb.h.

◆ goutnaksts

__IO uint32_t otg_device_type::goutnaksts

Definition at line 1025 of file at32f435_437_usb.h.

◆ ineptint

__IO uint32_t otg_device_type::ineptint

Definition at line 1106 of file at32f435_437_usb.h.

◆ ineptmsk

__IO uint32_t otg_device_type::ineptmsk

Definition at line 1119 of file at32f435_437_usb.h.

◆ ineptnakmsk

__IO uint32_t otg_device_type::ineptnakmsk

Definition at line 1068 of file at32f435_437_usb.h.

◆ ineptxfemsk

__IO uint32_t otg_device_type::ineptxfemsk

Definition at line 1134 of file at32f435_437_usb.h.

◆ intkneptmismsk

__IO uint32_t otg_device_type::intkneptmismsk

Definition at line 1067 of file at32f435_437_usb.h.

◆ intkntxfempmsk

__IO uint32_t otg_device_type::intkntxfempmsk

Definition at line 1066 of file at32f435_437_usb.h.

◆ nzstsouthshk

__IO uint32_t otg_device_type::nzstsouthshk

Definition at line 1006 of file at32f435_437_usb.h.

◆ outeptint

__IO uint32_t otg_device_type::outeptint

Definition at line 1107 of file at32f435_437_usb.h.

◆ outeptmsk

__IO uint32_t otg_device_type::outeptmsk

Definition at line 1120 of file at32f435_437_usb.h.

◆ outperrmsk

__IO uint32_t otg_device_type::outperrmsk

Definition at line 1092 of file at32f435_437_usb.h.

◆ outtepdmsk

__IO uint32_t otg_device_type::outtepdmsk

Definition at line 1088 of file at32f435_437_usb.h.

◆ perfrint

__IO uint32_t otg_device_type::perfrint

Definition at line 1009 of file at32f435_437_usb.h.

Referenced by usbd_core_init().

◆ pwroprgdne

__IO uint32_t otg_device_type::pwroprgdne

Definition at line 1031 of file at32f435_437_usb.h.

◆ reserved1

__IO uint32_t otg_device_type::reserved1

Definition at line 1007 of file at32f435_437_usb.h.

◆ reserved2

__IO uint32_t otg_device_type::reserved2

Definition at line 1010 of file at32f435_437_usb.h.

◆ reserved3

__IO uint32_t otg_device_type::reserved3

Definition at line 1072 of file at32f435_437_usb.h.

◆ reserved4

__IO uint32_t otg_device_type::reserved4

Definition at line 1094 of file at32f435_437_usb.h.

◆ rwkupsig

__IO uint32_t otg_device_type::rwkupsig

Definition at line 1022 of file at32f435_437_usb.h.

Referenced by usbd_reset_handler().

◆ setupmsk

__IO uint32_t otg_device_type::setupmsk

Definition at line 1087 of file at32f435_437_usb.h.

Referenced by usbd_reset_handler().

◆ sftdiscon

__IO uint32_t otg_device_type::sftdiscon

Definition at line 1023 of file at32f435_437_usb.h.

◆ sgnpinak

__IO uint32_t otg_device_type::sgnpinak

Definition at line 1027 of file at32f435_437_usb.h.

◆ sgoutnak

__IO uint32_t otg_device_type::sgoutnak

Definition at line 1029 of file at32f435_437_usb.h.

◆ soffn

__IO uint32_t otg_device_type::soffn

Definition at line 1048 of file at32f435_437_usb.h.

Referenced by usbd_ept_recv(), and usbd_ept_send().

◆ suspsts

__IO uint32_t otg_device_type::suspsts

Definition at line 1044 of file at32f435_437_usb.h.

◆ timeoutmsk

__IO uint32_t otg_device_type::timeoutmsk

Definition at line 1065 of file at32f435_437_usb.h.

Referenced by usbd_reset_handler().

◆ tstctl

__IO uint32_t otg_device_type::tstctl

Definition at line 1026 of file at32f435_437_usb.h.

◆ txfifoudrmsk

__IO uint32_t otg_device_type::txfifoudrmsk

Definition at line 1070 of file at32f435_437_usb.h.

Referenced by usbd_core_init().

◆ xfercmsk

__IO uint32_t otg_device_type::xfercmsk

Definition at line 1062 of file at32f435_437_usb.h.

Referenced by usbd_reset_handler().

The documentation for this struct was generated from the following file:
  • at32f435_437_usb.h


AT32F435/437 Firmwary Library: otg_eptin_type Struct Reference

Data Fields
otg_eptin_type Struct Reference
AT32F435_437_periph_driver » USB » USB_exported_types

#include <at32f435_437_usb.h>

Data Fields

union {
__IO uint32_t diepctl
struct {
__IO uint32_t mps: 11
__IO uint32_t reserved1: 4
__IO uint32_t usbacept: 1
__IO uint32_t dpid: 1
__IO uint32_t naksts: 1
__IO uint32_t eptype: 2
__IO uint32_t reserved2: 1
__IO uint32_t stall: 1
__IO uint32_t txfnum: 4
__IO uint32_t cnak: 1
__IO uint32_t snak: 1
__IO uint32_t setd0pid: 1
__IO uint32_t setd1pid: 1
__IO uint32_t eptdis: 1
__IO uint32_t eptena: 1
} diepctl_bit
};
otgfs device out endpoint control register, offset:0x900 More...
union {
__IO uint32_t diepint
struct {
__IO uint32_t xferc: 1
__IO uint32_t epdisd: 1
__IO uint32_t reserved1: 1
__IO uint32_t timeout: 1
__IO uint32_t intkntxfemp: 1
__IO uint32_t reserved2: 1
__IO uint32_t ineptnak: 1
__IO uint32_t txfemp: 1
__IO uint32_t reserved3: 24
} diepint_bit
};
otgfs device in endpoint interrupt register, offset:0x908 More...
union {
__IO uint32_t dieptsiz
struct {
__IO uint32_t xfersize: 19
__IO uint32_t pktcnt: 10
__IO uint32_t mc: 2
__IO uint32_t reserved1: 1
} dieptsiz_bit
};
otgfs device in endpoint transfer size register, offset:0x910 + endpoint number * 0x20 More...
union {
__IO uint32_t dtxfsts
struct {
__IO uint32_t ineptxfsav: 16
__IO uint32_t reserved1: 16
} dtxfsts_bit
};
otgfs device in endpoint tx fifo status register, offset:0x918 + endpoint number * 0x20 More...

Detailed Description

Definition at line 1141 of file at32f435_437_usb.h.

Field Documentation

◆

union { ... } otg_eptin_type::@1258

otgfs device out endpoint control register, offset:0x900

◆

union { ... } otg_eptin_type::@1260

otgfs device in endpoint interrupt register, offset:0x908

◆

union { ... } otg_eptin_type::@1262

otgfs device in endpoint transfer size register, offset:0x910 + endpoint number * 0x20

◆

union { ... } otg_eptin_type::@1264

otgfs device in endpoint tx fifo status register, offset:0x918 + endpoint number * 0x20

◆ cnak

__IO uint32_t otg_eptin_type::cnak

Definition at line 1160 of file at32f435_437_usb.h.

Referenced by usbd_ept_send().

◆ diepctl

__IO uint32_t otg_eptin_type::diepctl

Definition at line 1148 of file at32f435_437_usb.h.

Referenced by usbd_core_init().

◆

struct { ... } otg_eptin_type::diepctl_bit

Referenced by usbd_core_init(), and usbd_ept_send().

◆ diepint

__IO uint32_t otg_eptin_type::diepint

Definition at line 1175 of file at32f435_437_usb.h.

Referenced by usbd_core_init().

◆

struct { ... } otg_eptin_type::diepint_bit

◆ dieptsiz

__IO uint32_t otg_eptin_type::dieptsiz

Definition at line 1196 of file at32f435_437_usb.h.

Referenced by usbd_core_init().

◆

struct { ... } otg_eptin_type::dieptsiz_bit

Referenced by usbd_ept_send().

◆ dpid

__IO uint32_t otg_eptin_type::dpid

Definition at line 1154 of file at32f435_437_usb.h.

◆ dtxfsts

__IO uint32_t otg_eptin_type::dtxfsts

Definition at line 1213 of file at32f435_437_usb.h.

◆

struct { ... } otg_eptin_type::dtxfsts_bit

◆ epdisd

__IO uint32_t otg_eptin_type::epdisd

Definition at line 1179 of file at32f435_437_usb.h.

◆ eptdis

__IO uint32_t otg_eptin_type::eptdis

Definition at line 1164 of file at32f435_437_usb.h.

Referenced by usbd_core_init().

◆ eptena

__IO uint32_t otg_eptin_type::eptena

Definition at line 1165 of file at32f435_437_usb.h.

Referenced by usbd_core_init(), and usbd_ept_send().

◆ eptype

__IO uint32_t otg_eptin_type::eptype

Definition at line 1156 of file at32f435_437_usb.h.

◆ ineptnak

__IO uint32_t otg_eptin_type::ineptnak

Definition at line 1184 of file at32f435_437_usb.h.

◆ ineptxfsav

__IO uint32_t otg_eptin_type::ineptxfsav

Definition at line 1216 of file at32f435_437_usb.h.

◆ intkntxfemp

__IO uint32_t otg_eptin_type::intkntxfemp

Definition at line 1182 of file at32f435_437_usb.h.

◆ mc

__IO uint32_t otg_eptin_type::mc

Definition at line 1201 of file at32f435_437_usb.h.

Referenced by usbd_ept_send().

◆ mps

__IO uint32_t otg_eptin_type::mps

Definition at line 1151 of file at32f435_437_usb.h.

◆ naksts

__IO uint32_t otg_eptin_type::naksts

Definition at line 1155 of file at32f435_437_usb.h.

◆ pktcnt

__IO uint32_t otg_eptin_type::pktcnt

Definition at line 1200 of file at32f435_437_usb.h.

Referenced by usbd_ept_send().

◆ reserved1

__IO uint32_t otg_eptin_type::reserved1

Definition at line 1152 of file at32f435_437_usb.h.

◆ reserved2

__IO uint32_t otg_eptin_type::reserved2

Definition at line 1157 of file at32f435_437_usb.h.

◆ reserved3

__IO uint32_t otg_eptin_type::reserved3

Definition at line 1186 of file at32f435_437_usb.h.

◆ setd0pid

__IO uint32_t otg_eptin_type::setd0pid

Definition at line 1162 of file at32f435_437_usb.h.

Referenced by usbd_ept_send().

◆ setd1pid

__IO uint32_t otg_eptin_type::setd1pid

Definition at line 1163 of file at32f435_437_usb.h.

Referenced by usbd_ept_send().

◆ snak

__IO uint32_t otg_eptin_type::snak

Definition at line 1161 of file at32f435_437_usb.h.

Referenced by usbd_core_init().

◆ stall

__IO uint32_t otg_eptin_type::stall

Definition at line 1158 of file at32f435_437_usb.h.

◆ timeout

__IO uint32_t otg_eptin_type::timeout

Definition at line 1181 of file at32f435_437_usb.h.

◆ txfemp

__IO uint32_t otg_eptin_type::txfemp

Definition at line 1185 of file at32f435_437_usb.h.

◆ txfnum

__IO uint32_t otg_eptin_type::txfnum

Definition at line 1159 of file at32f435_437_usb.h.

◆ usbacept

__IO uint32_t otg_eptin_type::usbacept

Definition at line 1153 of file at32f435_437_usb.h.

◆ xferc

__IO uint32_t otg_eptin_type::xferc

Definition at line 1178 of file at32f435_437_usb.h.

◆ xfersize

__IO uint32_t otg_eptin_type::xfersize

Definition at line 1199 of file at32f435_437_usb.h.

Referenced by usbd_ept_send().

The documentation for this struct was generated from the following file:
  • at32f435_437_usb.h


AT32F435/437 Firmwary Library: otg_eptout_type Struct Reference

Data Fields
otg_eptout_type Struct Reference
AT32F435_437_periph_driver » USB » USB_exported_types

#include <at32f435_437_usb.h>

Data Fields

union {
__IO uint32_t doepctl
struct {
__IO uint32_t mps: 11
__IO uint32_t reserved1: 4
__IO uint32_t usbacept: 1
__IO uint32_t dpid: 1
__IO uint32_t naksts: 1
__IO uint32_t eptype: 2
__IO uint32_t snpm: 1
__IO uint32_t stall: 1
__IO uint32_t reserved2: 4
__IO uint32_t cnak: 1
__IO uint32_t snak: 1
__IO uint32_t setd0pid: 1
__IO uint32_t setd1pid: 1
__IO uint32_t eptdis: 1
__IO uint32_t eptena: 1
} doepctl_bit
};
otgfs device out endpoint control register, offset:0xb00 + endpoint number * 0x20 More...
union {
__IO uint32_t doepint
struct {
__IO uint32_t xferc: 1
__IO uint32_t epdisd: 1
__IO uint32_t reserved1: 1
__IO uint32_t setup: 1
__IO uint32_t outtepd: 1
__IO uint32_t reserved2: 1
__IO uint32_t b2pstup: 1
__IO uint32_t reserved3: 25
} doepint_bit
};
otgfs device out endpoint interrupt register, offset:0xb08 + endpoint number * 0x20 More...
union {
__IO uint32_t doeptsiz
struct {
__IO uint32_t xfersize: 19
__IO uint32_t pktcnt: 10
__IO uint32_t rxdpid_setupcnt: 2
__IO uint32_t reserved1: 1
} doeptsiz_bit
};
otgfs device out endpoint transfer size register, offset:0xb10 + endpoint number * 0x20 More...

Detailed Description

Definition at line 1223 of file at32f435_437_usb.h.

Field Documentation

◆

union { ... } otg_eptout_type::@1270

otgfs device out endpoint control register, offset:0xb00 + endpoint number * 0x20

◆

union { ... } otg_eptout_type::@1272

otgfs device out endpoint interrupt register, offset:0xb08 + endpoint number * 0x20

◆

union { ... } otg_eptout_type::@1274

otgfs device out endpoint transfer size register, offset:0xb10 + endpoint number * 0x20

◆ b2pstup

__IO uint32_t otg_eptout_type::b2pstup

Definition at line 1266 of file at32f435_437_usb.h.

◆ cnak

__IO uint32_t otg_eptout_type::cnak

Definition at line 1242 of file at32f435_437_usb.h.

Referenced by usbd_ept_recv().

◆ doepctl

__IO uint32_t otg_eptout_type::doepctl

Definition at line 1230 of file at32f435_437_usb.h.

Referenced by usbd_core_init().

◆

struct { ... } otg_eptout_type::doepctl_bit

Referenced by usbd_core_init(), and usbd_ept_recv().

◆ doepint

__IO uint32_t otg_eptout_type::doepint

Definition at line 1257 of file at32f435_437_usb.h.

Referenced by usbd_core_init().

◆

struct { ... } otg_eptout_type::doepint_bit

◆ doeptsiz

__IO uint32_t otg_eptout_type::doeptsiz

Definition at line 1277 of file at32f435_437_usb.h.

Referenced by usb_ept0_start(), and usbd_core_init().

◆

struct { ... } otg_eptout_type::doeptsiz_bit

Referenced by usb_ept0_start(), and usbd_ept_recv().

◆ dpid

__IO uint32_t otg_eptout_type::dpid

Definition at line 1236 of file at32f435_437_usb.h.

◆ epdisd

__IO uint32_t otg_eptout_type::epdisd

Definition at line 1261 of file at32f435_437_usb.h.

◆ eptdis

__IO uint32_t otg_eptout_type::eptdis

Definition at line 1246 of file at32f435_437_usb.h.

Referenced by usbd_core_init().

◆ eptena

__IO uint32_t otg_eptout_type::eptena

Definition at line 1247 of file at32f435_437_usb.h.

Referenced by usbd_core_init(), and usbd_ept_recv().

◆ eptype

__IO uint32_t otg_eptout_type::eptype

Definition at line 1238 of file at32f435_437_usb.h.

◆ mps

__IO uint32_t otg_eptout_type::mps

Definition at line 1233 of file at32f435_437_usb.h.

◆ naksts

__IO uint32_t otg_eptout_type::naksts

Definition at line 1237 of file at32f435_437_usb.h.

◆ outtepd

__IO uint32_t otg_eptout_type::outtepd

Definition at line 1264 of file at32f435_437_usb.h.

◆ pktcnt

__IO uint32_t otg_eptout_type::pktcnt

Definition at line 1281 of file at32f435_437_usb.h.

Referenced by usb_ept0_start(), and usbd_ept_recv().

◆ reserved1

__IO uint32_t otg_eptout_type::reserved1

Definition at line 1234 of file at32f435_437_usb.h.

◆ reserved2

__IO uint32_t otg_eptout_type::reserved2

Definition at line 1241 of file at32f435_437_usb.h.

◆ reserved3

__IO uint32_t otg_eptout_type::reserved3

Definition at line 1267 of file at32f435_437_usb.h.

◆ rxdpid_setupcnt

__IO uint32_t otg_eptout_type::rxdpid_setupcnt

Definition at line 1282 of file at32f435_437_usb.h.

Referenced by usb_ept0_start().

◆ setd0pid

__IO uint32_t otg_eptout_type::setd0pid

Definition at line 1244 of file at32f435_437_usb.h.

Referenced by usbd_ept_recv().

◆ setd1pid

__IO uint32_t otg_eptout_type::setd1pid

Definition at line 1245 of file at32f435_437_usb.h.

Referenced by usbd_ept_recv().

◆ setup

__IO uint32_t otg_eptout_type::setup

Definition at line 1263 of file at32f435_437_usb.h.

◆ snak

__IO uint32_t otg_eptout_type::snak

Definition at line 1243 of file at32f435_437_usb.h.

Referenced by usbd_core_init().

◆ snpm

__IO uint32_t otg_eptout_type::snpm

Definition at line 1239 of file at32f435_437_usb.h.

◆ stall

__IO uint32_t otg_eptout_type::stall

Definition at line 1240 of file at32f435_437_usb.h.

◆ usbacept

__IO uint32_t otg_eptout_type::usbacept

Definition at line 1235 of file at32f435_437_usb.h.

◆ xferc

__IO uint32_t otg_eptout_type::xferc

Definition at line 1260 of file at32f435_437_usb.h.

◆ xfersize

__IO uint32_t otg_eptout_type::xfersize

Definition at line 1280 of file at32f435_437_usb.h.

Referenced by usb_ept0_start(), and usbd_ept_recv().

The documentation for this struct was generated from the following file:
  • at32f435_437_usb.h


AT32F435/437 Firmwary Library: otg_pcgcctl_type Struct Reference

Data Fields
otg_pcgcctl_type Struct Reference
AT32F435_437_periph_driver » USB » USB_exported_types

#include <at32f435_437_usb.h>

Data Fields

union {
__IO uint32_t pcgcctl
struct {
__IO uint32_t stoppclk: 1
__IO uint32_t reserved1: 3
__IO uint32_t suspendm: 1
__IO uint32_t reserved2: 27
} pcgcctl_bit
};
otgfs power and clock gating control registers, offset:0xe00 More...

Detailed Description

Definition at line 1288 of file at32f435_437_usb.h.

Field Documentation

◆

union { ... } otg_pcgcctl_type::@1279

otgfs power and clock gating control registers, offset:0xe00

◆ pcgcctl

__IO uint32_t otg_pcgcctl_type::pcgcctl

Definition at line 1295 of file at32f435_437_usb.h.

◆

struct { ... } otg_pcgcctl_type::pcgcctl_bit

◆ reserved1

__IO uint32_t otg_pcgcctl_type::reserved1

Definition at line 1299 of file at32f435_437_usb.h.

◆ reserved2

__IO uint32_t otg_pcgcctl_type::reserved2

Definition at line 1301 of file at32f435_437_usb.h.

◆ stoppclk

__IO uint32_t otg_pcgcctl_type::stoppclk

Definition at line 1298 of file at32f435_437_usb.h.

◆ suspendm

__IO uint32_t otg_pcgcctl_type::suspendm

Definition at line 1300 of file at32f435_437_usb.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_usb.h


AT32F435/437 Firmwary Library: USB_exported_functions

Macros | Typedefs | Functions
USB_exported_functions
AT32F435_437_periph_driver » USB

Macros

#define | OTG_HOST_ADDR_OFFSET 0x400
usb host and device offset address More...
#define | OTG_HOST_CHANNEL_ADDR_OFFSET 0x500
#define | OTG_DEVICE_ADDR_OFFSET 0x800
#define | OTG_DEVICE_EPTIN_ADDR_OFFSET 0x900
#define | OTG_DEVICE_EPTOUT_ADDR_OFFSET 0xB00
#define | OTG_PCGCCTL_ADDR_OFFSET 0xE00
#define | OTG_FIFO_ADDR_OFFSET 0x1000
#define | OTG1_GLOBAL ((otg_global_type *)(OTGFS1_BASE))
usb host and device register define More...
#define | OTG2_GLOBAL ((otg_global_type *)(OTGFS2_BASE))
#define | OTG_PCGCCTL(usbx) ((otg_pcgcctl_type *)((uint32_t)usbx + OTG_PCGCCTL_ADDR_OFFSET))
#define | OTG_DEVICE(usbx) ((otg_device_type *)((uint32_t)usbx + OTG_DEVICE_ADDR_OFFSET))
#define | OTG_HOST(usbx) ((otg_host_type *)((uint32_t)usbx + OTG_HOST_ADDR_OFFSET))
#define | USB_CHL(usbx, n) ((otg_hchannel_type *)((uint32_t)usbx + OTG_HOST_CHANNEL_ADDR_OFFSET + n * 0x20))
#define | USB_INEPT(usbx, eptn) ((otg_eptin_type *)((uint32_t)usbx + OTG_DEVICE_EPTIN_ADDR_OFFSET + eptn * 0x20))
#define | USB_OUTEPT(usbx, eptn) ((otg_eptout_type *)((uint32_t)usbx + OTG_DEVICE_EPTOUT_ADDR_OFFSET + eptn * 0x20))
#define | USB_FIFO(usbx, eptn) *(__IO uint32_t *)((uint32_t)usbx + OTG_FIFO_ADDR_OFFSET + eptn * 0x1000)

Typedefs

typedef otg_global_type usb_reg_type

Functions

error_status | usb_global_reset (otg_global_type *usbx)
usb global core soft reset More...
void | usb_global_init (otg_global_type *usbx)
usb global initialization More...
otg_global_type * | usb_global_select_core (uint8_t usb_id)
usb global select usb core (otg1 or otg2). More...
void | usb_flush_tx_fifo (otg_global_type *usbx, uint32_t fifo_num)
flush tx fifo More...
void | usb_flush_rx_fifo (otg_global_type *usbx)
flush rx fifo More...
void | usb_global_interrupt_enable (otg_global_type *usbx, uint16_t interrupt, confirm_state new_state)
usb interrupt mask enable More...
uint32_t | usb_global_get_all_interrupt (otg_global_type *usbx)
get all global core interrupt flag More...
void | usb_global_clear_interrupt (otg_global_type *usbx, uint32_t flag)
clear the global interrupt flag More...
void | usb_interrupt_enable (otg_global_type *usbx)
usb global interrupt enable More...
void | usb_interrupt_disable (otg_global_type *usbx)
usb global interrupt disable More...
void | usb_set_rx_fifo (otg_global_type *usbx, uint16_t size)
usb set rx fifo size More...
void | usb_set_tx_fifo (otg_global_type *usbx, uint8_t txfifo, uint16_t size)
usb set tx fifo size More...
void | usb_global_set_mode (otg_global_type *usbx, uint32_t mode)
set otg mode(device or host mode) More...
void | usb_global_power_on (otg_global_type *usbx)
disable the transceiver power down mode More...
void | usb_write_packet (otg_global_type *usbx, uint8_t *pusr_buf, uint16_t num, uint16_t nbytes)
write data from user memory to usb buffer More...
void | usb_read_packet (otg_global_type *usbx, uint8_t *pusr_buf, uint16_t num, uint16_t nbytes)
read data from usb buffer to user buffer More...
void | usb_stop_phy_clk (otg_global_type *usbx)
usb stop phy clock More...
void | usb_open_phy_clk (otg_global_type *usbx)
usb open phy clock More...
void | usb_ept_open (otg_global_type *usbx, usb_ept_info *ept_info)
open usb endpoint More...
void | usb_ept_close (otg_global_type *usbx, usb_ept_info *ept_info)
close usb endpoint More...
void | usb_ept_stall (otg_global_type *usbx, usb_ept_info *ept_info)
set endpoint tx or rx status to stall More...
void | usb_ept_clear_stall (otg_global_type *usbx, usb_ept_info *ept_info)
clear endpoint tx or rx status to stall More...
uint32_t | usb_get_all_out_interrupt (otg_global_type *usbx)
get all out endpoint interrupt bits More...
uint32_t | usb_get_all_in_interrupt (otg_global_type *usbx)
get all in endpoint interrupt bits More...
uint32_t | usb_ept_out_interrupt (otg_global_type *usbx, uint32_t eptn)
get out endpoint interrupt flag More...
uint32_t | usb_ept_in_interrupt (otg_global_type *usbx, uint32_t eptn)
get in endpoint interrupt flag More...
void | usb_ept_out_clear (otg_global_type *usbx, uint32_t eptn, uint32_t flag)
clear out endpoint interrupt flag More...
void | usb_ept_in_clear (otg_global_type *usbx, uint32_t eptn, uint32_t flag)
clear in endpoint interrupt flag More...
void | usb_set_address (otg_global_type *usbx, uint8_t address)
set the host assignment address More...
void | usb_ept0_start (otg_global_type *usbx)
enable endpoint 0 out More...
void | usb_ept0_setup (otg_global_type *usbx)
endpoint 0 start setup More...
void | usb_connect (otg_global_type *usbx)
connect usb device by enable pull-up More...
void | usb_disconnect (otg_global_type *usbx)
disconnect usb device by disable pull-up More...
void | usb_remote_wkup_set (otg_global_type *usbx)
usb remote wakeup set More...
void | usb_remote_wkup_clear (otg_global_type *usbx)
usb remote wakeup clear More...
uint8_t | usb_suspend_status_get (otg_global_type *usbx)
usb suspend status get More...
void | usb_port_power_on (otg_global_type *usbx, confirm_state state)
usb port power on More...
uint32_t | usbh_get_frame (otg_global_type *usbx)
get current frame number More...
void | usb_hc_enable (otg_global_type *usbx, uint8_t chn, uint8_t ept_num, uint8_t dev_address, uint8_t type, uint16_t maxpacket, uint8_t speed)
enable one host channel More...
uint32_t | usb_hch_read_interrupt (otg_global_type *usbx)
host read channel interrupt More...
void | usb_host_disable (otg_global_type *usbx)
disable host More...
void | usb_hch_halt (otg_global_type *usbx, uint8_t chn)
halt channel More...
void | usbh_fsls_clksel (otg_global_type *usbx, uint8_t clk)
select full or low speed clock More...

Detailed Description

Macro Definition Documentation

◆ OTG1_GLOBAL

#define OTG1_GLOBAL ((otg_global_type *)(OTGFS1_BASE))

usb host and device register define

usb otg1 global register

Definition at line 1328 of file at32f435_437_usb.h.

◆ OTG2_GLOBAL

#define OTG2_GLOBAL ((otg_global_type *)(OTGFS2_BASE))

usb otg2 global register

Definition at line 1329 of file at32f435_437_usb.h.

◆ OTG_DEVICE

#define OTG_DEVICE ( usbx ) ((otg_device_type *)((uint32_t)usbx + OTG_DEVICE_ADDR_OFFSET))

usb device register

Definition at line 1331 of file at32f435_437_usb.h.

◆ OTG_DEVICE_ADDR_OFFSET

#define OTG_DEVICE_ADDR_OFFSET 0x800

usb device register offset address

Definition at line 1319 of file at32f435_437_usb.h.

◆ OTG_DEVICE_EPTIN_ADDR_OFFSET

#define OTG_DEVICE_EPTIN_ADDR_OFFSET 0x900

usb device endpoint in register offset address

Definition at line 1320 of file at32f435_437_usb.h.

◆ OTG_DEVICE_EPTOUT_ADDR_OFFSET

#define OTG_DEVICE_EPTOUT_ADDR_OFFSET 0xB00

usb device endpoint out register offset address

Definition at line 1321 of file at32f435_437_usb.h.

◆ OTG_FIFO_ADDR_OFFSET

#define OTG_FIFO_ADDR_OFFSET 0x1000

usb fifo offset address

Definition at line 1323 of file at32f435_437_usb.h.

◆ OTG_HOST

#define OTG_HOST ( usbx ) ((otg_host_type *)((uint32_t)usbx + OTG_HOST_ADDR_OFFSET))

usb host register

Definition at line 1332 of file at32f435_437_usb.h.

◆ OTG_HOST_ADDR_OFFSET

#define OTG_HOST_ADDR_OFFSET 0x400

usb host and device offset address

usb host register offset address

Definition at line 1317 of file at32f435_437_usb.h.

◆ OTG_HOST_CHANNEL_ADDR_OFFSET

#define OTG_HOST_CHANNEL_ADDR_OFFSET 0x500

usb host channel register offset address

Definition at line 1318 of file at32f435_437_usb.h.

◆ OTG_PCGCCTL

#define OTG_PCGCCTL ( usbx ) ((otg_pcgcctl_type *)((uint32_t)usbx + OTG_PCGCCTL_ADDR_OFFSET))

usb power and clock control register

Definition at line 1330 of file at32f435_437_usb.h.

◆ OTG_PCGCCTL_ADDR_OFFSET

#define OTG_PCGCCTL_ADDR_OFFSET 0xE00

usb power and clock control register offset address

Definition at line 1322 of file at32f435_437_usb.h.

◆ USB_CHL

#define USB_CHL | ( | usbx,
 |  | n
 | ) | ((otg_hchannel_type *)((uint32_t)usbx + OTG_HOST_CHANNEL_ADDR_OFFSET + n * 0x20))

usb channel n register

Definition at line 1333 of file at32f435_437_usb.h.

◆ USB_FIFO

#define USB_FIFO | ( | usbx,
 |  | eptn
 | ) | *(__IO uint32_t *)((uint32_t)usbx + OTG_FIFO_ADDR_OFFSET + eptn * 0x1000)

usb fifo address

Definition at line 1336 of file at32f435_437_usb.h.

◆ USB_INEPT

#define USB_INEPT | ( | usbx,
 |  | eptn
 | ) | ((otg_eptin_type *)((uint32_t)usbx + OTG_DEVICE_EPTIN_ADDR_OFFSET + eptn * 0x20))

usb device endpoint in register

Definition at line 1334 of file at32f435_437_usb.h.

◆ USB_OUTEPT

#define USB_OUTEPT | ( | usbx,
 |  | eptn
 | ) | ((otg_eptout_type *)((uint32_t)usbx + OTG_DEVICE_EPTOUT_ADDR_OFFSET + eptn * 0x20))

usb device endpoint out register

Definition at line 1335 of file at32f435_437_usb.h.

Typedef Documentation

◆ usb_reg_type

typedef otg_global_type usb_reg_type

Definition at line 1340 of file at32f435_437_usb.h.

Function Documentation

◆ usb_connect()

void usb_connect ( otg_global_type * usbx )

connect usb device by enable pull-up

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

< usb device register offset address

< usb device register

Definition at line 771 of file at32f435_437_usb.c.

Referenced by usbd_connect().

◆ usb_disconnect()

void usb_disconnect ( otg_global_type * usbx )

disconnect usb device by disable pull-up

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

< usb device register offset address

< usb device register

Definition at line 785 of file at32f435_437_usb.c.

Referenced by usbd_disconnect().

◆ usb_ept0_setup()

void usb_ept0_setup ( otg_global_type * usbx )

endpoint 0 start setup

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device register offset address

< usb device register

Definition at line 757 of file at32f435_437_usb.c.

Referenced by usbd_enumdone_handler().

◆ usb_ept0_start()

void usb_ept0_start ( otg_global_type * usbx )

enable endpoint 0 out

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

< usb device endpoint out register offset address

< usb device endpoint out register

Definition at line 739 of file at32f435_437_usb.c.

Referenced by usbd_reset_handler().

◆ usb_ept_clear_stall()

void usb_ept_clear_stall | ( | otg_global_type * | usbx,
 |  | usb_ept_info * | ept_info
 | ) |  |

clear endpoint tx or rx status to stall

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
ept_info endpoint information structure
Return values
none

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device endpoint out register offset address

< usb device endpoint out register

< usb device endpoint out register offset address

< usb device endpoint out register

Definition at line 592 of file at32f435_437_usb.c.

Referenced by usbd_clear_stall().

◆ usb_ept_close()

void usb_ept_close | ( | otg_global_type * | usbx,
 |  | usb_ept_info * | ept_info
 | ) |  |

close usb endpoint

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
ept_info endpoint information structure
Return values
none

< usb device register offset address

< usb device register

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device register offset address

< usb device register

< usb device endpoint out register offset address

< usb device endpoint out register

Definition at line 539 of file at32f435_437_usb.c.

Referenced by usbd_ept_close().

◆ usb_ept_in_clear()

void usb_ept_in_clear | ( | otg_global_type * | usbx,
 |  | uint32_t | eptn,
 |  | uint32_t | flag
 | ) |  |

clear in endpoint interrupt flag

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
eptn endpoint number
Return values
flag interrupt flag this parameter can be any combination of the following values:
  • USB_OTG_DIEPINT_XFERC_FLAG
  • USB_OTG_DIEPINT_EPTDISD_FLAG
  • USB_OTG_DIEPINT_TMROC_FLAG
  • USB_OTG_DIEPINT_INTTXFE_FLAG
  • USB_OTG_DIEPINT_INEPNE_FLAG
  • USB_OTG_DIEPINT_TXFE_FLAG

< usb device endpoint in register offset address

< usb device endpoint in register

Definition at line 711 of file at32f435_437_usb.c.

Referenced by usbd_inept_handler().

◆ usb_ept_in_interrupt()

uint32_t usb_ept_in_interrupt | ( | otg_global_type * | usbx,
 |  | uint32_t | eptn
 | ) |  |

get in endpoint interrupt flag

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
eptn endpoint number
Return values
in endpoint intterupt flags

< usb device register offset address

< usb device register

< usb device register offset address

< usb device register

< usb device endpoint in register offset address

< usb device endpoint in register

Definition at line 665 of file at32f435_437_usb.c.

Referenced by usbd_inept_handler().

◆ usb_ept_open()

void usb_ept_open | ( | otg_global_type * | usbx,
 |  | usb_ept_info * | ept_info
 | ) |  |

open usb endpoint

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
ept_info endpoint information structure
Return values
none

< usb device endpoint 0 maximum packet size 64byte

< usb device endpoint 0 maximum packet size 64byte

< usb device endpoint 0 maximum packet size 32byte

< usb device endpoint 0 maximum packet size 16byte

< usb device endpoint 0 maximum packet size 8byte

< usb device register offset address

< usb device register

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device register offset address

< usb device register

< usb device endpoint out register offset address

< usb device endpoint out register

< usb device endpoint out register offset address

< usb device endpoint out register

< usb device endpoint out register offset address

< usb device endpoint out register

< usb device endpoint out register offset address

< usb device endpoint out register

< usb device endpoint out register offset address

< usb device endpoint out register

Definition at line 473 of file at32f435_437_usb.c.

Referenced by usbd_ept_open().

◆ usb_ept_out_clear()

void usb_ept_out_clear | ( | otg_global_type * | usbx,
 |  | uint32_t | eptn,
 |  | uint32_t | flag
 | ) |  |

clear out endpoint interrupt flag

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
eptn endpoint number
Return values
flag interrupt flag this parameter can be any combination of the following values:
  • USB_OTG_DOEPINT_XFERC_FLAG
  • USB_OTG_DOEPINT_EPTDISD_FLAG
  • USB_OTG_DOEPINT_SETUP_FLAG
  • USB_OTG_DOEPINT_OTEPDIS_FLAG
  • USB_OTG_DOEPINT_B2BSTUP_FLAG

< usb device endpoint out register offset address

< usb device endpoint out register

Definition at line 690 of file at32f435_437_usb.c.

Referenced by usbd_outept_handler().

◆ usb_ept_out_interrupt()

uint32_t usb_ept_out_interrupt | ( | otg_global_type * | usbx,
 |  | uint32_t | eptn
 | ) |  |

get out endpoint interrupt flag

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
eptn endpoint number
Return values
out endpoint interrupt flags

< usb device endpoint out register offset address

< usb device endpoint out register

< usb device register offset address

< usb device register

Definition at line 650 of file at32f435_437_usb.c.

Referenced by usbd_outept_handler().

◆ usb_ept_stall()

void usb_ept_stall | ( | otg_global_type * | usbx,
 |  | usb_ept_info * | ept_info
 | ) |  |

set endpoint tx or rx status to stall

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
ept_info endpoint information structure
Return values
none

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device endpoint out register offset address

< usb device endpoint out register

< usb device endpoint out register offset address

< usb device endpoint out register

< usb device endpoint out register offset address

< usb device endpoint out register

Definition at line 563 of file at32f435_437_usb.c.

Referenced by usbd_set_stall().

◆ usb_flush_rx_fifo()

void usb_flush_rx_fifo ( otg_global_type * usbx )

flush rx fifo

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

Definition at line 150 of file at32f435_437_usb.c.

Referenced by usb_host_disable(), usbd_core_init(), usbh_attached(), and usbh_core_init().

◆ usb_flush_tx_fifo()

void usb_flush_tx_fifo | ( | otg_global_type * | usbx,
 |  | uint32_t | fifo_num
 | ) |  |

flush tx fifo

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
fifo_num tx fifo num,when fifo_num=16,flush all tx fifo parameter as following values: 0-16
Return values
none

Definition at line 124 of file at32f435_437_usb.c.

Referenced by audio_inisoincom_event(), usb_host_disable(), usbd_core_init(), usbd_flush_tx_fifo(), usbd_reset_handler(), usbh_attached(), and usbh_core_init().

◆ usb_get_all_in_interrupt()

uint32_t usb_get_all_in_interrupt ( otg_global_type * usbx )

get all in endpoint interrupt bits

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
in endpoint interrupt bits

< usb device register offset address

< usb device register

< usb device register offset address

< usb device register

Definition at line 634 of file at32f435_437_usb.c.

Referenced by usbd_inept_handler().

◆ usb_get_all_out_interrupt()

uint32_t usb_get_all_out_interrupt ( otg_global_type * usbx )

get all out endpoint interrupt bits

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
out endpoint interrupt bits

< usb device register offset address

< usb device register

< usb device register offset address

< usb device register

Definition at line 620 of file at32f435_437_usb.c.

Referenced by usbd_outept_handler().

◆ usb_global_clear_interrupt()

void usb_global_clear_interrupt | ( | otg_global_type * | usbx,
 |  | uint32_t | flag
 | ) |  |

clear the global interrupt flag

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
flag interrupt flag this parameter can be any combination of the following values:
  • USB_OTG_MODEMIS_FLAG
  • USB_OTG_OTGINT_FLAG
  • USB_OTG_SOF_FLAG
  • USB_OTG_RXFLVL_FLAG
  • USB_OTG_NPTXFEMP_FLAG
  • USB_OTG_GINNAKEFF_FLAG
  • USB_OTG_GOUTNAKEFF_FLAG
  • USB_OTG_ERLYSUSP_FLAG
  • USB_OTG_USBSUSP_FLAG
  • USB_OTG_USBRST_FLAG
  • USB_OTG_ENUMDONE_FLAG
  • USB_OTG_ISOOUTDROP_FLAG
  • USB_OTG_EOPF_FLAG
  • USB_OTG_IEPT_FLAG
  • USB_OTG_OEPT_FLAG
  • USB_OTG_INCOMISOIN_FLAG
  • USB_OTG_INCOMPIP_INCOMPISOOUT_FLAG
  • USB_OTG_PRT_FLAG
  • USB_OTG_HCH_FLAG
  • USB_OTG_PTXFEMP_FLAG
  • USB_OTG_CONIDSCHG_FLAG
  • USB_OTG_DISCON_FLAG
  • USB_OTG_WKUP_FLAG
Return values
none

Definition at line 255 of file at32f435_437_usb.c.

Referenced by usbd_irq_handler(), and usbh_irq_handler().

◆ usb_global_get_all_interrupt()

uint32_t usb_global_get_all_interrupt ( otg_global_type * usbx )

get all global core interrupt flag

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
intterupt flag

Definition at line 216 of file at32f435_437_usb.c.

Referenced by usbd_irq_handler(), and usbh_irq_handler().

◆ usb_global_init()

void usb_global_init ( otg_global_type * usbx )

usb global initialization

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

Definition at line 83 of file at32f435_437_usb.c.

Referenced by usbd_core_init(), and usbh_core_init().

◆ usb_global_interrupt_enable()

void usb_global_interrupt_enable | ( | otg_global_type * | usbx,
 |  | uint16_t | interrupt,
 |  | confirm_state | new_state
 | ) |  |

usb interrupt mask enable

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
interrupt this parameter can be any combination of the following values:
  • USB_OTG_MODEMIS_INT
  • USB_OTG_OTGINT_INT
  • USB_OTG_SOF_INT
  • USB_OTG_RXFLVL_INT
  • USB_OTG_NPTXFEMP_INT
  • USB_OTG_GINNAKEFF_INT
  • USB_OTG_GOUTNAKEFF_INT
  • USB_OTG_ERLYSUSP_INT
  • USB_OTG_USBSUSP_INT
  • USB_OTG_USBRST_INT
  • USB_OTG_ENUMDONE_INT
  • USB_OTG_ISOOUTDROP_INT
  • USB_OTG_IEPT_INT
  • USB_OTG_OEPT_INT
  • USB_OTG_INCOMISOIN_INT
  • USB_OTG_INCOMPIP_INCOMPISOOUT_INT
  • USB_OTG_PRT_INT
  • USB_OTG_HCH_INT
  • USB_OTG_PTXFEMP_INT
  • USB_OTG_CONIDSCHG_INT
  • USB_OTG_DISCON_INT
  • USB_OTG_WKUP_INT
new_state TRUE or FALSE
Return values
none

Definition at line 196 of file at32f435_437_usb.c.

Referenced by usbd_rxflvl_handler().

◆ usb_global_power_on()

void usb_global_power_on ( otg_global_type * usbx )

disable the transceiver power down mode

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

Definition at line 377 of file at32f435_437_usb.c.

◆ usb_global_reset()

error_status usb_global_reset ( otg_global_type * usbx )

usb global core soft reset

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
error status

Definition at line 53 of file at32f435_437_usb.c.

Referenced by usb_global_init().

◆ usb_global_select_core()

otg_global_type * usb_global_select_core ( uint8_t usb_id )

usb global select usb core (otg1 or otg2).

Parameters
usb_id select otg1 or otg2 this parameter can be one of the following values:
  • USB_OTG1_ID
  • USB_OTG2_ID
Return values
usb global register type pointer

< usb otg1 global register

< usb otg2 global register

Definition at line 100 of file at32f435_437_usb.c.

◆ usb_global_set_mode()

void usb_global_set_mode | ( | otg_global_type * | usbx,
 |  | uint32_t | mode
 | ) |  |

set otg mode(device or host mode)

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
mode this parameter can be one of the following values:
  • OTG_DEVICE_MODE
  • OTG_HOST_MODE
  • OTG_DRD_MODE
Return values
none

Definition at line 344 of file at32f435_437_usb.c.

Referenced by usbd_core_init(), and usbh_core_init().

◆ usb_hc_enable()

void usb_hc_enable | ( | otg_global_type * | usbx,
 |  | uint8_t | chn,
 |  | uint8_t | ept_num,
 |  | uint8_t | dev_address,
 |  | uint8_t | type,
 |  | uint16_t | maxpacket,
 |  | uint8_t | speed
 | ) |  |

enable one host channel

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
chn | host channel number
ept_num | devvice endpoint number
dev_address | device address
type channel transfer type this parameter can be one of the following values:
  • EPT_CONTROL_TYPE
  • EPT_BULK_TYPE
  • EPT_INT_TYPE
  • EPT_ISO_TYPE
maxpacket | support max packe size for this channel
speed device speed this parameter can be one of the following values:
  • USB_PRTSPD_FULL_SPEED
  • USB_PRTSPD_LOW_SPEED
Return values
none

< usb host channel register offset address

< usb channel chn register

< usb host register offset address

< usb host register

< channel transfer complete interrupt

< channel stall interrupt

< channel transaction error interrupt

< channel nak interrupt

< channel data toggle interrupt

< channel transfer complete interrupt

< channel stall interrupt

< channel transaction error interrupt

< channel nak interrupt

< channel data toggle interrupt

< channel frame overrun interrupt

< channel transfer complete interrupt

< channel ack interrupt

< channel frame overrun interrupt

< usb host port low speed

Definition at line 896 of file at32f435_437_usb.c.

Referenced by usbh_hc_open().

◆ usb_hch_halt()

void usb_hch_halt | ( | otg_global_type * | usbx,
 |  | uint8_t | chn
 | ) |  |

halt channel

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
chn channel number
Return values
none

< usb host channel register offset address

< usb channel chn register

< usb host register offset address

< usb host register

Definition at line 1012 of file at32f435_437_usb.c.

Referenced by usbh_ch_disable(), usbh_hch_in_handler(), and usbh_hch_out_handler().

◆ usb_hch_read_interrupt()

uint32_t usb_hch_read_interrupt ( otg_global_type * usbx )

host read channel interrupt

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
interrupt flag

< usb host register offset address

< usb host register

Definition at line 954 of file at32f435_437_usb.c.

◆ usb_host_disable()

void usb_host_disable ( otg_global_type * usbx )

disable host

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

< usb host register offset address

< usb host register

< usb host channel register offset address

< usb channel i_index register

< usb host channel register offset address

< usb channel i_index register

Definition at line 968 of file at32f435_437_usb.c.

Referenced by usbh_disconnect_handler().

◆ usb_interrupt_disable()

void usb_interrupt_disable ( otg_global_type * usbx )

usb global interrupt disable

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

Definition at line 280 of file at32f435_437_usb.c.

Referenced by usbd_core_init(), and usbh_core_init().

◆ usb_interrupt_enable()

void usb_interrupt_enable ( otg_global_type * usbx )

usb global interrupt enable

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values: OTG1_GLOBAL , OTG2_GLOBAL
Return values
none

Definition at line 267 of file at32f435_437_usb.c.

Referenced by usbd_core_init(), and usbh_core_init().

◆ usb_open_phy_clk()

void usb_open_phy_clk ( otg_global_type * usbx )

usb open phy clock

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

< usb power and clock control register offset address

< usb power and clock control register

Definition at line 409 of file at32f435_437_usb.c.

Referenced by usbd_core_init(), usbd_remote_wakeup(), usbd_wakeup_handler(), usbh_core_init(), and usbh_resume().

◆ usb_port_power_on()

void usb_port_power_on | ( | otg_global_type * | usbx,
 |  | confirm_state | state
 | ) |  |

usb port power on

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
state state (TRUE or FALSE)
Return values
none

< usb host register offset address

< usb host register

< usb host port enable

< usb host port enable/disable change

< usb host port overcurrent active

< usb host port connect detected

< usb host port power

< usb host port power

Definition at line 842 of file at32f435_437_usb.c.

Referenced by usbh_core_init().

◆ usb_read_packet()

void usb_read_packet | ( | otg_global_type * | usbx,
 |  | uint8_t * | pusr_buf,
 |  | uint16_t | num,
 |  | uint16_t | nbytes
 | ) |  |

read data from usb buffer to user buffer

Parameters
pusr_buf | point to user buffer
offset_addr | endpoint rx offset address
nbytes | number of bytes data write to usb buffer
Return values
none

< usb fifo offset address

< usb fifo address

Definition at line 445 of file at32f435_437_usb.c.

Referenced by usbd_rxflvl_handler(), and usbh_rx_qlvl_handler().

◆ usb_remote_wkup_clear()

void usb_remote_wkup_clear ( otg_global_type * usbx )

usb remote wakeup clear

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

< usb device register offset address

< usb device register

Definition at line 813 of file at32f435_437_usb.c.

Referenced by usbd_remote_wakeup().

◆ usb_remote_wkup_set()

void usb_remote_wkup_set ( otg_global_type * usbx )

usb remote wakeup set

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

< usb device register offset address

< usb device register

Definition at line 800 of file at32f435_437_usb.c.

Referenced by usbd_remote_wakeup().

◆ usb_set_address()

void usb_set_address | ( | otg_global_type * | usbx,
 |  | uint8_t | address
 | ) |  |

set the host assignment address

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
address host assignment address
Return values
none

< usb device register offset address

< usb device register

Definition at line 726 of file at32f435_437_usb.c.

Referenced by usbd_reset_handler(), and usbd_set_device_addr().

◆ usb_set_rx_fifo()

void usb_set_rx_fifo | ( | otg_global_type * | usbx,
 |  | uint16_t | size
 | ) |  |

usb set rx fifo size

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
size rx fifo size
Return values
none

Definition at line 294 of file at32f435_437_usb.c.

Referenced by usbd_fifo_alloc().

◆ usb_set_tx_fifo()

void usb_set_tx_fifo | ( | otg_global_type * | usbx,
 |  | uint8_t | txfifo,
 |  | uint16_t | size
 | ) |  |

usb set tx fifo size

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
txfifo | the fifo number
size | tx fifo size
Return values
none

Definition at line 309 of file at32f435_437_usb.c.

Referenced by usbd_fifo_alloc().

◆ usb_stop_phy_clk()

void usb_stop_phy_clk ( otg_global_type * usbx )

usb stop phy clock

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

< usb power and clock control register offset address

< usb power and clock control register

Definition at line 396 of file at32f435_437_usb.c.

Referenced by usbd_enter_suspend(), and usbh_enter_suspend().

◆ usb_suspend_status_get()

uint8_t usb_suspend_status_get ( otg_global_type * usbx )

usb suspend status get

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
usb suspend status

< usb device register offset address

< usb device register

Definition at line 826 of file at32f435_437_usb.c.

Referenced by usbd_enter_suspend(), and usbd_remote_wakeup().

◆ usb_write_packet()

void usb_write_packet | ( | otg_global_type * | usbx,
 |  | uint8_t * | pusr_buf,
 |  | uint16_t | num,
 |  | uint16_t | nbytes
 | ) |  |

write data from user memory to usb buffer

Parameters
pusr_buf | point to user buffer
offset_addr | endpoint tx offset address
nbytes | number of bytes data write to usb buffer
Return values
none

< usb fifo offset address

< usb fifo address

Definition at line 422 of file at32f435_437_usb.c.

Referenced by usb_write_empty_txfifo(), usbd_ept_send(), and usbh_in_out_request().

◆ usbh_fsls_clksel()

void usbh_fsls_clksel | ( | otg_global_type * | usbx,
 |  | uint8_t | clk
 | ) |  |

select full or low speed clock

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
clk clock frequency
Return values
none

< usb host register offset address

< usb host register

< usb host phy clock 6mhz

Definition at line 1068 of file at32f435_437_usb.c.

Referenced by usbh_core_init(), usbh_disconnect_handler(), and usbh_port_handler().

◆ usbh_get_frame()

uint32_t usbh_get_frame ( otg_global_type * usbx )

get current frame number

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

< usb host register offset address

< usb host register

Definition at line 868 of file at32f435_437_usb.c.

Referenced by uhost_process_handler().


AT32F435/437 Firmwary Library: USB_private_functions

Functions
USB_private_functions
AT32F435_437_periph_driver » USB

Functions

error_status | usb_global_reset (otg_global_type *usbx)
usb global core soft reset More...
void | usb_global_init (otg_global_type *usbx)
usb global initialization More...
otg_global_type * | usb_global_select_core (uint8_t usb_id)
usb global select usb core (otg1 or otg2). More...
void | usb_flush_tx_fifo (otg_global_type *usbx, uint32_t fifo_num)
flush tx fifo More...
void | usb_flush_rx_fifo (otg_global_type *usbx)
flush rx fifo More...
void | usb_global_interrupt_enable (otg_global_type *usbx, uint16_t interrupt, confirm_state new_state)
usb interrupt mask enable More...
uint32_t | usb_global_get_all_interrupt (otg_global_type *usbx)
get all global core interrupt flag More...
void | usb_global_clear_interrupt (otg_global_type *usbx, uint32_t flag)
clear the global interrupt flag More...
void | usb_interrupt_enable (otg_global_type *usbx)
usb global interrupt enable More...
void | usb_interrupt_disable (otg_global_type *usbx)
usb global interrupt disable More...
void | usb_set_rx_fifo (otg_global_type *usbx, uint16_t size)
usb set rx fifo size More...
void | usb_set_tx_fifo (otg_global_type *usbx, uint8_t txfifo, uint16_t size)
usb set tx fifo size More...
void | usb_global_set_mode (otg_global_type *usbx, uint32_t mode)
set otg mode(device or host mode) More...
void | usb_global_power_on (otg_global_type *usbx)
disable the transceiver power down mode More...
void | usb_stop_phy_clk (otg_global_type *usbx)
usb stop phy clock More...
void | usb_open_phy_clk (otg_global_type *usbx)
usb open phy clock More...
void | usb_write_packet (otg_global_type *usbx, uint8_t *pusr_buf, uint16_t num, uint16_t nbytes)
write data from user memory to usb buffer More...
void | usb_read_packet (otg_global_type *usbx, uint8_t *pusr_buf, uint16_t num, uint16_t nbytes)
read data from usb buffer to user buffer More...
void | usb_ept_open (otg_global_type *usbx, usb_ept_info *ept_info)
open usb endpoint More...
void | usb_ept_close (otg_global_type *usbx, usb_ept_info *ept_info)
close usb endpoint More...
void | usb_ept_stall (otg_global_type *usbx, usb_ept_info *ept_info)
set endpoint tx or rx status to stall More...
void | usb_ept_clear_stall (otg_global_type *usbx, usb_ept_info *ept_info)
clear endpoint tx or rx status to stall More...
uint32_t | usb_get_all_out_interrupt (otg_global_type *usbx)
get all out endpoint interrupt bits More...
uint32_t | usb_get_all_in_interrupt (otg_global_type *usbx)
get all in endpoint interrupt bits More...
uint32_t | usb_ept_out_interrupt (otg_global_type *usbx, uint32_t eptn)
get out endpoint interrupt flag More...
uint32_t | usb_ept_in_interrupt (otg_global_type *usbx, uint32_t eptn)
get in endpoint interrupt flag More...
void | usb_ept_out_clear (otg_global_type *usbx, uint32_t eptn, uint32_t flag)
clear out endpoint interrupt flag More...
void | usb_ept_in_clear (otg_global_type *usbx, uint32_t eptn, uint32_t flag)
clear in endpoint interrupt flag More...
void | usb_set_address (otg_global_type *usbx, uint8_t address)
set the host assignment address More...
void | usb_ept0_start (otg_global_type *usbx)
enable endpoint 0 out More...
void | usb_ept0_setup (otg_global_type *usbx)
endpoint 0 start setup More...
void | usb_connect (otg_global_type *usbx)
connect usb device by enable pull-up More...
void | usb_disconnect (otg_global_type *usbx)
disconnect usb device by disable pull-up More...
void | usb_remote_wkup_set (otg_global_type *usbx)
usb remote wakeup set More...
void | usb_remote_wkup_clear (otg_global_type *usbx)
usb remote wakeup clear More...
uint8_t | usb_suspend_status_get (otg_global_type *usbx)
usb suspend status get More...
void | usb_port_power_on (otg_global_type *usbx, confirm_state state)
usb port power on More...
uint32_t | usbh_get_frame (otg_global_type *usbx)
get current frame number More...
void | usb_hc_enable (otg_global_type *usbx, uint8_t chn, uint8_t ept_num, uint8_t dev_address, uint8_t type, uint16_t maxpacket, uint8_t speed)
enable one host channel More...
uint32_t | usb_hch_read_interrupt (otg_global_type *usbx)
host read channel interrupt More...
void | usb_host_disable (otg_global_type *usbx)
disable host More...
void | usb_hch_halt (otg_global_type *usbx, uint8_t chn)
halt channel More...
void | usbh_fsls_clksel (otg_global_type *usbx, uint8_t clk)
select full or low speed clock More...

Detailed Description

Function Documentation

◆ usb_connect()

void usb_connect ( otg_global_type * usbx )

connect usb device by enable pull-up

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

< usb device register offset address

< usb device register

Definition at line 771 of file at32f435_437_usb.c.

Referenced by usbd_connect().

◆ usb_disconnect()

void usb_disconnect ( otg_global_type * usbx )

disconnect usb device by disable pull-up

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

< usb device register offset address

< usb device register

Definition at line 785 of file at32f435_437_usb.c.

Referenced by usbd_disconnect().

◆ usb_ept0_setup()

void usb_ept0_setup ( otg_global_type * usbx )

endpoint 0 start setup

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device register offset address

< usb device register

Definition at line 757 of file at32f435_437_usb.c.

Referenced by usbd_enumdone_handler().

◆ usb_ept0_start()

void usb_ept0_start ( otg_global_type * usbx )

enable endpoint 0 out

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

< usb device endpoint out register offset address

< usb device endpoint out register

Definition at line 739 of file at32f435_437_usb.c.

Referenced by usbd_reset_handler().

◆ usb_ept_clear_stall()

void usb_ept_clear_stall | ( | otg_global_type * | usbx,
 |  | usb_ept_info * | ept_info
 | ) |  |

clear endpoint tx or rx status to stall

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
ept_info endpoint information structure
Return values
none

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device endpoint out register offset address

< usb device endpoint out register

< usb device endpoint out register offset address

< usb device endpoint out register

Definition at line 592 of file at32f435_437_usb.c.

Referenced by usbd_clear_stall().

◆ usb_ept_close()

void usb_ept_close | ( | otg_global_type * | usbx,
 |  | usb_ept_info * | ept_info
 | ) |  |

close usb endpoint

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
ept_info endpoint information structure
Return values
none

< usb device register offset address

< usb device register

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device register offset address

< usb device register

< usb device endpoint out register offset address

< usb device endpoint out register

Definition at line 539 of file at32f435_437_usb.c.

Referenced by usbd_ept_close().

◆ usb_ept_in_clear()

void usb_ept_in_clear | ( | otg_global_type * | usbx,
 |  | uint32_t | eptn,
 |  | uint32_t | flag
 | ) |  |

clear in endpoint interrupt flag

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
eptn endpoint number
Return values
flag interrupt flag this parameter can be any combination of the following values:
  • USB_OTG_DIEPINT_XFERC_FLAG
  • USB_OTG_DIEPINT_EPTDISD_FLAG
  • USB_OTG_DIEPINT_TMROC_FLAG
  • USB_OTG_DIEPINT_INTTXFE_FLAG
  • USB_OTG_DIEPINT_INEPNE_FLAG
  • USB_OTG_DIEPINT_TXFE_FLAG

< usb device endpoint in register offset address

< usb device endpoint in register

Definition at line 711 of file at32f435_437_usb.c.

Referenced by usbd_inept_handler().

◆ usb_ept_in_interrupt()

uint32_t usb_ept_in_interrupt | ( | otg_global_type * | usbx,
 |  | uint32_t | eptn
 | ) |  |

get in endpoint interrupt flag

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
eptn endpoint number
Return values
in endpoint intterupt flags

< usb device register offset address

< usb device register

< usb device register offset address

< usb device register

< usb device endpoint in register offset address

< usb device endpoint in register

Definition at line 665 of file at32f435_437_usb.c.

Referenced by usbd_inept_handler().

◆ usb_ept_open()

void usb_ept_open | ( | otg_global_type * | usbx,
 |  | usb_ept_info * | ept_info
 | ) |  |

open usb endpoint

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
ept_info endpoint information structure
Return values
none

< usb device endpoint 0 maximum packet size 64byte

< usb device endpoint 0 maximum packet size 64byte

< usb device endpoint 0 maximum packet size 32byte

< usb device endpoint 0 maximum packet size 16byte

< usb device endpoint 0 maximum packet size 8byte

< usb device register offset address

< usb device register

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device register offset address

< usb device register

< usb device endpoint out register offset address

< usb device endpoint out register

< usb device endpoint out register offset address

< usb device endpoint out register

< usb device endpoint out register offset address

< usb device endpoint out register

< usb device endpoint out register offset address

< usb device endpoint out register

< usb device endpoint out register offset address

< usb device endpoint out register

Definition at line 473 of file at32f435_437_usb.c.

Referenced by usbd_ept_open().

◆ usb_ept_out_clear()

void usb_ept_out_clear | ( | otg_global_type * | usbx,
 |  | uint32_t | eptn,
 |  | uint32_t | flag
 | ) |  |

clear out endpoint interrupt flag

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
eptn endpoint number
Return values
flag interrupt flag this parameter can be any combination of the following values:
  • USB_OTG_DOEPINT_XFERC_FLAG
  • USB_OTG_DOEPINT_EPTDISD_FLAG
  • USB_OTG_DOEPINT_SETUP_FLAG
  • USB_OTG_DOEPINT_OTEPDIS_FLAG
  • USB_OTG_DOEPINT_B2BSTUP_FLAG

< usb device endpoint out register offset address

< usb device endpoint out register

Definition at line 690 of file at32f435_437_usb.c.

Referenced by usbd_outept_handler().

◆ usb_ept_out_interrupt()

uint32_t usb_ept_out_interrupt | ( | otg_global_type * | usbx,
 |  | uint32_t | eptn
 | ) |  |

get out endpoint interrupt flag

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
eptn endpoint number
Return values
out endpoint interrupt flags

< usb device endpoint out register offset address

< usb device endpoint out register

< usb device register offset address

< usb device register

Definition at line 650 of file at32f435_437_usb.c.

Referenced by usbd_outept_handler().

◆ usb_ept_stall()

void usb_ept_stall | ( | otg_global_type * | usbx,
 |  | usb_ept_info * | ept_info
 | ) |  |

set endpoint tx or rx status to stall

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
ept_info endpoint information structure
Return values
none

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device endpoint in register offset address

< usb device endpoint in register

< usb device endpoint out register offset address

< usb device endpoint out register

< usb device endpoint out register offset address

< usb device endpoint out register

< usb device endpoint out register offset address

< usb device endpoint out register

Definition at line 563 of file at32f435_437_usb.c.

Referenced by usbd_set_stall().

◆ usb_flush_rx_fifo()

void usb_flush_rx_fifo ( otg_global_type * usbx )

flush rx fifo

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

Definition at line 150 of file at32f435_437_usb.c.

Referenced by usb_host_disable(), usbd_core_init(), usbh_attached(), and usbh_core_init().

◆ usb_flush_tx_fifo()

void usb_flush_tx_fifo | ( | otg_global_type * | usbx,
 |  | uint32_t | fifo_num
 | ) |  |

flush tx fifo

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
fifo_num tx fifo num,when fifo_num=16,flush all tx fifo parameter as following values: 0-16
Return values
none

Definition at line 124 of file at32f435_437_usb.c.

Referenced by audio_inisoincom_event(), usb_host_disable(), usbd_core_init(), usbd_flush_tx_fifo(), usbd_reset_handler(), usbh_attached(), and usbh_core_init().

◆ usb_get_all_in_interrupt()

uint32_t usb_get_all_in_interrupt ( otg_global_type * usbx )

get all in endpoint interrupt bits

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
in endpoint interrupt bits

< usb device register offset address

< usb device register

< usb device register offset address

< usb device register

Definition at line 634 of file at32f435_437_usb.c.

Referenced by usbd_inept_handler().

◆ usb_get_all_out_interrupt()

uint32_t usb_get_all_out_interrupt ( otg_global_type * usbx )

get all out endpoint interrupt bits

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
out endpoint interrupt bits

< usb device register offset address

< usb device register

< usb device register offset address

< usb device register

Definition at line 620 of file at32f435_437_usb.c.

Referenced by usbd_outept_handler().

◆ usb_global_clear_interrupt()

void usb_global_clear_interrupt | ( | otg_global_type * | usbx,
 |  | uint32_t | flag
 | ) |  |

clear the global interrupt flag

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
flag interrupt flag this parameter can be any combination of the following values:
  • USB_OTG_MODEMIS_FLAG
  • USB_OTG_OTGINT_FLAG
  • USB_OTG_SOF_FLAG
  • USB_OTG_RXFLVL_FLAG
  • USB_OTG_NPTXFEMP_FLAG
  • USB_OTG_GINNAKEFF_FLAG
  • USB_OTG_GOUTNAKEFF_FLAG
  • USB_OTG_ERLYSUSP_FLAG
  • USB_OTG_USBSUSP_FLAG
  • USB_OTG_USBRST_FLAG
  • USB_OTG_ENUMDONE_FLAG
  • USB_OTG_ISOOUTDROP_FLAG
  • USB_OTG_EOPF_FLAG
  • USB_OTG_IEPT_FLAG
  • USB_OTG_OEPT_FLAG
  • USB_OTG_INCOMISOIN_FLAG
  • USB_OTG_INCOMPIP_INCOMPISOOUT_FLAG
  • USB_OTG_PRT_FLAG
  • USB_OTG_HCH_FLAG
  • USB_OTG_PTXFEMP_FLAG
  • USB_OTG_CONIDSCHG_FLAG
  • USB_OTG_DISCON_FLAG
  • USB_OTG_WKUP_FLAG
Return values
none

Definition at line 255 of file at32f435_437_usb.c.

Referenced by usbd_irq_handler(), and usbh_irq_handler().

◆ usb_global_get_all_interrupt()

uint32_t usb_global_get_all_interrupt ( otg_global_type * usbx )

get all global core interrupt flag

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
intterupt flag

Definition at line 216 of file at32f435_437_usb.c.

Referenced by usbd_irq_handler(), and usbh_irq_handler().

◆ usb_global_init()

void usb_global_init ( otg_global_type * usbx )

usb global initialization

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

Definition at line 83 of file at32f435_437_usb.c.

Referenced by usbd_core_init(), and usbh_core_init().

◆ usb_global_interrupt_enable()

void usb_global_interrupt_enable | ( | otg_global_type * | usbx,
 |  | uint16_t | interrupt,
 |  | confirm_state | new_state
 | ) |  |

usb interrupt mask enable

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
interrupt this parameter can be any combination of the following values:
  • USB_OTG_MODEMIS_INT
  • USB_OTG_OTGINT_INT
  • USB_OTG_SOF_INT
  • USB_OTG_RXFLVL_INT
  • USB_OTG_NPTXFEMP_INT
  • USB_OTG_GINNAKEFF_INT
  • USB_OTG_GOUTNAKEFF_INT
  • USB_OTG_ERLYSUSP_INT
  • USB_OTG_USBSUSP_INT
  • USB_OTG_USBRST_INT
  • USB_OTG_ENUMDONE_INT
  • USB_OTG_ISOOUTDROP_INT
  • USB_OTG_IEPT_INT
  • USB_OTG_OEPT_INT
  • USB_OTG_INCOMISOIN_INT
  • USB_OTG_INCOMPIP_INCOMPISOOUT_INT
  • USB_OTG_PRT_INT
  • USB_OTG_HCH_INT
  • USB_OTG_PTXFEMP_INT
  • USB_OTG_CONIDSCHG_INT
  • USB_OTG_DISCON_INT
  • USB_OTG_WKUP_INT
new_state TRUE or FALSE
Return values
none

Definition at line 196 of file at32f435_437_usb.c.

Referenced by usbd_rxflvl_handler().

◆ usb_global_power_on()

void usb_global_power_on ( otg_global_type * usbx )

disable the transceiver power down mode

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

Definition at line 377 of file at32f435_437_usb.c.

◆ usb_global_reset()

error_status usb_global_reset ( otg_global_type * usbx )

usb global core soft reset

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
error status

Definition at line 53 of file at32f435_437_usb.c.

Referenced by usb_global_init().

◆ usb_global_select_core()

otg_global_type * usb_global_select_core ( uint8_t usb_id )

usb global select usb core (otg1 or otg2).

Parameters
usb_id select otg1 or otg2 this parameter can be one of the following values:
  • USB_OTG1_ID
  • USB_OTG2_ID
Return values
usb global register type pointer

< usb otg1 global register

< usb otg2 global register

Definition at line 100 of file at32f435_437_usb.c.

◆ usb_global_set_mode()

void usb_global_set_mode | ( | otg_global_type * | usbx,
 |  | uint32_t | mode
 | ) |  |

set otg mode(device or host mode)

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
mode this parameter can be one of the following values:
  • OTG_DEVICE_MODE
  • OTG_HOST_MODE
  • OTG_DRD_MODE
Return values
none

Definition at line 344 of file at32f435_437_usb.c.

Referenced by usbd_core_init(), and usbh_core_init().

◆ usb_hc_enable()

void usb_hc_enable | ( | otg_global_type * | usbx,
 |  | uint8_t | chn,
 |  | uint8_t | ept_num,
 |  | uint8_t | dev_address,
 |  | uint8_t | type,
 |  | uint16_t | maxpacket,
 |  | uint8_t | speed
 | ) |  |

enable one host channel

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
chn | host channel number
ept_num | devvice endpoint number
dev_address | device address
type channel transfer type this parameter can be one of the following values:
  • EPT_CONTROL_TYPE
  • EPT_BULK_TYPE
  • EPT_INT_TYPE
  • EPT_ISO_TYPE
maxpacket | support max packe size for this channel
speed device speed this parameter can be one of the following values:
  • USB_PRTSPD_FULL_SPEED
  • USB_PRTSPD_LOW_SPEED
Return values
none

< usb host channel register offset address

< usb channel chn register

< usb host register offset address

< usb host register

< channel transfer complete interrupt

< channel stall interrupt

< channel transaction error interrupt

< channel nak interrupt

< channel data toggle interrupt

< channel transfer complete interrupt

< channel stall interrupt

< channel transaction error interrupt

< channel nak interrupt

< channel data toggle interrupt

< channel frame overrun interrupt

< channel transfer complete interrupt

< channel ack interrupt

< channel frame overrun interrupt

< usb host port low speed

Definition at line 896 of file at32f435_437_usb.c.

Referenced by usbh_hc_open().

◆ usb_hch_halt()

void usb_hch_halt | ( | otg_global_type * | usbx,
 |  | uint8_t | chn
 | ) |  |

halt channel

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
chn channel number
Return values
none

< usb host channel register offset address

< usb channel chn register

< usb host register offset address

< usb host register

Definition at line 1012 of file at32f435_437_usb.c.

Referenced by usbh_ch_disable(), usbh_hch_in_handler(), and usbh_hch_out_handler().

◆ usb_hch_read_interrupt()

uint32_t usb_hch_read_interrupt ( otg_global_type * usbx )

host read channel interrupt

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
interrupt flag

< usb host register offset address

< usb host register

Definition at line 954 of file at32f435_437_usb.c.

◆ usb_host_disable()

void usb_host_disable ( otg_global_type * usbx )

disable host

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

< usb host register offset address

< usb host register

< usb host channel register offset address

< usb channel i_index register

< usb host channel register offset address

< usb channel i_index register

Definition at line 968 of file at32f435_437_usb.c.

Referenced by usbh_disconnect_handler().

◆ usb_interrupt_disable()

void usb_interrupt_disable ( otg_global_type * usbx )

usb global interrupt disable

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

Definition at line 280 of file at32f435_437_usb.c.

Referenced by usbd_core_init(), and usbh_core_init().

◆ usb_interrupt_enable()

void usb_interrupt_enable ( otg_global_type * usbx )

usb global interrupt enable

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values: OTG1_GLOBAL , OTG2_GLOBAL
Return values
none

Definition at line 267 of file at32f435_437_usb.c.

Referenced by usbd_core_init(), and usbh_core_init().

◆ usb_open_phy_clk()

void usb_open_phy_clk ( otg_global_type * usbx )

usb open phy clock

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

< usb power and clock control register offset address

< usb power and clock control register

Definition at line 409 of file at32f435_437_usb.c.

Referenced by usbd_core_init(), usbd_remote_wakeup(), usbd_wakeup_handler(), usbh_core_init(), and usbh_resume().

◆ usb_port_power_on()

void usb_port_power_on | ( | otg_global_type * | usbx,
 |  | confirm_state | state
 | ) |  |

usb port power on

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
state state (TRUE or FALSE)
Return values
none

< usb host register offset address

< usb host register

< usb host port enable

< usb host port enable/disable change

< usb host port overcurrent active

< usb host port connect detected

< usb host port power

< usb host port power

Definition at line 842 of file at32f435_437_usb.c.

Referenced by usbh_core_init().

◆ usb_read_packet()

void usb_read_packet | ( | otg_global_type * | usbx,
 |  | uint8_t * | pusr_buf,
 |  | uint16_t | num,
 |  | uint16_t | nbytes
 | ) |  |

read data from usb buffer to user buffer

Parameters
pusr_buf | point to user buffer
offset_addr | endpoint rx offset address
nbytes | number of bytes data write to usb buffer
Return values
none

< usb fifo offset address

< usb fifo address

Definition at line 445 of file at32f435_437_usb.c.

Referenced by usbd_rxflvl_handler(), and usbh_rx_qlvl_handler().

◆ usb_remote_wkup_clear()

void usb_remote_wkup_clear ( otg_global_type * usbx )

usb remote wakeup clear

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

< usb device register offset address

< usb device register

Definition at line 813 of file at32f435_437_usb.c.

Referenced by usbd_remote_wakeup().

◆ usb_remote_wkup_set()

void usb_remote_wkup_set ( otg_global_type * usbx )

usb remote wakeup set

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

< usb device register offset address

< usb device register

Definition at line 800 of file at32f435_437_usb.c.

Referenced by usbd_remote_wakeup().

◆ usb_set_address()

void usb_set_address | ( | otg_global_type * | usbx,
 |  | uint8_t | address
 | ) |  |

set the host assignment address

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
address host assignment address
Return values
none

< usb device register offset address

< usb device register

Definition at line 726 of file at32f435_437_usb.c.

Referenced by usbd_reset_handler(), and usbd_set_device_addr().

◆ usb_set_rx_fifo()

void usb_set_rx_fifo | ( | otg_global_type * | usbx,
 |  | uint16_t | size
 | ) |  |

usb set rx fifo size

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
size rx fifo size
Return values
none

Definition at line 294 of file at32f435_437_usb.c.

Referenced by usbd_fifo_alloc().

◆ usb_set_tx_fifo()

void usb_set_tx_fifo | ( | otg_global_type * | usbx,
 |  | uint8_t | txfifo,
 |  | uint16_t | size
 | ) |  |

usb set tx fifo size

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
txfifo | the fifo number
size | tx fifo size
Return values
none

Definition at line 309 of file at32f435_437_usb.c.

Referenced by usbd_fifo_alloc().

◆ usb_stop_phy_clk()

void usb_stop_phy_clk ( otg_global_type * usbx )

usb stop phy clock

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

< usb power and clock control register offset address

< usb power and clock control register

Definition at line 396 of file at32f435_437_usb.c.

Referenced by usbd_enter_suspend(), and usbh_enter_suspend().

◆ usb_suspend_status_get()

uint8_t usb_suspend_status_get ( otg_global_type * usbx )

usb suspend status get

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
usb suspend status

< usb device register offset address

< usb device register

Definition at line 826 of file at32f435_437_usb.c.

Referenced by usbd_enter_suspend(), and usbd_remote_wakeup().

◆ usb_write_packet()

void usb_write_packet | ( | otg_global_type * | usbx,
 |  | uint8_t * | pusr_buf,
 |  | uint16_t | num,
 |  | uint16_t | nbytes
 | ) |  |

write data from user memory to usb buffer

Parameters
pusr_buf | point to user buffer
offset_addr | endpoint tx offset address
nbytes | number of bytes data write to usb buffer
Return values
none

< usb fifo offset address

< usb fifo address

Definition at line 422 of file at32f435_437_usb.c.

Referenced by usb_write_empty_txfifo(), usbd_ept_send(), and usbh_in_out_request().

◆ usbh_fsls_clksel()

void usbh_fsls_clksel | ( | otg_global_type * | usbx,
 |  | uint8_t | clk
 | ) |  |

select full or low speed clock

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
clk clock frequency
Return values
none

< usb host register offset address

< usb host register

< usb host phy clock 6mhz

Definition at line 1068 of file at32f435_437_usb.c.

Referenced by usbh_core_init(), usbh_disconnect_handler(), and usbh_port_handler().

◆ usbh_get_frame()

uint32_t usbh_get_frame ( otg_global_type * usbx )

get current frame number

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
Return values
none

< usb host register offset address

< usb host register

Definition at line 868 of file at32f435_437_usb.c.

Referenced by uhost_process_handler().


AT32F435/437 Firmwary Library: WDT

Modules | Macros
WDT
AT32F435_437_periph_driver

WDT driver modules. More...

Modules

WDT_flags_definition
wdt flag
WDT_exported_types
WDT_exported_functions
WDT_private_functions

Macros

#define WDT ((wdt_type *) WDT_BASE)

Detailed Description

WDT driver modules.

Macro Definition Documentation

◆ WDT

#define WDT ((wdt_type *) WDT_BASE)

Definition at line 167 of file at32f435_437_wdt.h.


AT32F435/437 Firmwary Library: WDT_flags_definition

Macros
WDT_flags_definition
AT32F435_437_periph_driver » WDT

wdt flag More...

Macros

#define | WDT_DIVF_UPDATE_FLAG ((uint16_t)0x0001)
#define | WDT_RLDF_UPDATE_FLAG ((uint16_t)0x0002)
#define | WDT_WINF_UPDATE_FLAG ((uint16_t)0x0004)

Detailed Description

wdt flag

Macro Definition Documentation

◆ WDT_DIVF_UPDATE_FLAG

#define WDT_DIVF_UPDATE_FLAG ((uint16_t)0x0001)

wdt division value update complete flag

Definition at line 53 of file at32f435_437_wdt.h.

◆ WDT_RLDF_UPDATE_FLAG

#define WDT_RLDF_UPDATE_FLAG ((uint16_t)0x0002)

wdt reload value update complete flag

Definition at line 54 of file at32f435_437_wdt.h.

◆ WDT_WINF_UPDATE_FLAG

#define WDT_WINF_UPDATE_FLAG ((uint16_t)0x0004)

wdt window value update complete flag

Definition at line 55 of file at32f435_437_wdt.h.


AT32F435/437 Firmwary Library: WDT_exported_types

Data Structures | Enumerations
WDT_exported_types
AT32F435_437_periph_driver » WDT

Data Structures

struct wdt_type
type define wdt register all More...

Enumerations

enum wdt_division_type {
WDT_CLK_DIV_4 = 0x00 , WDT_CLK_DIV_8 = 0x01 , WDT_CLK_DIV_16 = 0x02 , WDT_CLK_DIV_32 = 0x03 ,
WDT_CLK_DIV_64 = 0x04 , WDT_CLK_DIV_128 = 0x05 , WDT_CLK_DIV_256 = 0x06
}
wdt division value type More...
enum wdt_cmd_value_type { WDT_CMD_LOCK = 0x0000 , WDT_CMD_UNLOCK = 0x5555 , WDT_CMD_ENABLE = 0xCCCC , WDT_CMD_RELOAD = 0xAAAA }
wdt cmd value type More...

Detailed Description

Enumeration Type Documentation

◆ wdt_cmd_value_type

enum wdt_cmd_value_type

wdt cmd value type

Enumerator
WDT_CMD_LOCK | disable write protection command
WDT_CMD_UNLOCK | enable write protection command
WDT_CMD_ENABLE | enable wdt command
WDT_CMD_RELOAD | reload command

Definition at line 82 of file at32f435_437_wdt.h.

◆ wdt_division_type

enum wdt_division_type

wdt division value type

Enumerator
WDT_CLK_DIV_4 | wdt clock divider value is 4
WDT_CLK_DIV_8 | wdt clock divider value is 8
WDT_CLK_DIV_16 | wdt clock divider value is 16
WDT_CLK_DIV_32 | wdt clock divider value is 32
WDT_CLK_DIV_64 | wdt clock divider value is 64
WDT_CLK_DIV_128 | wdt clock divider value is 128
WDT_CLK_DIV_256 | wdt clock divider value is 256

Definition at line 68 of file at32f435_437_wdt.h.


AT32F435/437 Firmwary Library: wdt_type Struct Reference

Data Fields
wdt_type Struct Reference
AT32F435_437_periph_driver » WDT » WDT_exported_types

type define wdt register all More...

#include <at32f435_437_wdt.h>

Data Fields

union {
__IO uint32_t cmd
struct {
__IO uint32_t cmd: 16
__IO uint32_t reserved1: 16
} cmd_bit
};
wdt cmd register, offset:0x00 More...
union {
__IO uint32_t div
struct {
__IO uint32_t div: 3
__IO uint32_t reserved1: 29
} div_bit
};
wdt div register, offset:0x04 More...
union {
__IO uint32_t rld
struct {
__IO uint32_t rld: 12
__IO uint32_t reserved1: 20
} rld_bit
};
wdt rld register, offset:0x08 More...
union {
__IO uint32_t sts
struct {
__IO uint32_t divf: 1
__IO uint32_t rldf: 1
__IO uint32_t reserved1: 30
} sts_bit
};
wdt sts register, offset:0x0C More...
union {
__IO uint32_t win
struct {
__IO uint32_t win: 12
__IO uint32_t reserved1: 20
} win_bit
};
wdt win register, offset:0x10 More...

Detailed Description

type define wdt register all

Definition at line 93 of file at32f435_437_wdt.h.

Field Documentation

◆

union { ... } wdt_type::@1282

wdt cmd register, offset:0x00

◆

union { ... } wdt_type::@1284

wdt div register, offset:0x04

◆

union { ... } wdt_type::@1286

wdt rld register, offset:0x08

◆

union { ... } wdt_type::@1288

wdt sts register, offset:0x0C

◆

union { ... } wdt_type::@1290

wdt win register, offset:0x10

◆ cmd

__IO uint32_t wdt_type::cmd

Definition at line 101 of file at32f435_437_wdt.h.

◆

struct { ... } wdt_type::cmd_bit

◆ div

__IO uint32_t wdt_type::div

Definition at line 114 of file at32f435_437_wdt.h.

◆

struct { ... } wdt_type::div_bit

◆ divf

__IO uint32_t wdt_type::divf

Definition at line 143 of file at32f435_437_wdt.h.

◆ reserved1

__IO uint32_t wdt_type::reserved1

Definition at line 105 of file at32f435_437_wdt.h.

◆ rld

__IO uint32_t wdt_type::rld

Definition at line 127 of file at32f435_437_wdt.h.

◆

struct { ... } wdt_type::rld_bit

◆ rldf

__IO uint32_t wdt_type::rldf

Definition at line 144 of file at32f435_437_wdt.h.

◆ sts

__IO uint32_t wdt_type::sts

Definition at line 140 of file at32f435_437_wdt.h.

◆

struct { ... } wdt_type::sts_bit

◆ win

__IO uint32_t wdt_type::win

Definition at line 154 of file at32f435_437_wdt.h.

◆

struct { ... } wdt_type::win_bit
The documentation for this struct was generated from the following file:
  • at32f435_437_wdt.h


AT32F435/437 Firmwary Library: WDT_exported_functions

Functions
WDT_exported_functions
AT32F435_437_periph_driver » WDT

Functions

void | wdt_enable (void)
wdt enable ,the reload value will be sent to the counter More...
void | wdt_counter_reload (void)
reload wdt counter More...
void | wdt_reload_value_set (uint16_t reload_value)
set wdt counter reload value More...
void | wdt_divider_set (wdt_division_type division)
set wdt division divider More...
void | wdt_register_write_enable (confirm_state new_state)
enable or disable wdt cmd register write More...
flag_status | wdt_flag_get (uint16_t wdt_flag)
get wdt flag More...
void | wdt_window_counter_set (uint16_t window_cnt)
wdt window counter value set More...

Detailed Description

Function Documentation

◆ wdt_counter_reload()

void wdt_counter_reload ( void )

reload wdt counter

Parameters
none
Return values
none

Definition at line 59 of file at32f435_437_wdt.c.

Referenced by main().

◆ wdt_divider_set()

void wdt_divider_set ( wdt_division_type division )

set wdt division divider

Parameters
division this parameter can be one of the following values:
  • WDT_CLK_DIV_4
  • WDT_CLK_DIV_8
  • WDT_CLK_DIV_16
  • WDT_CLK_DIV_32
  • WDT_CLK_DIV_64
  • WDT_CLK_DIV_128
  • WDT_CLK_DIV_256
Return values
none

Definition at line 87 of file at32f435_437_wdt.c.

Referenced by main().

◆ wdt_enable()

void wdt_enable ( void )

wdt enable ,the reload value will be sent to the counter

Parameters
none
Return values
none

Definition at line 49 of file at32f435_437_wdt.c.

Referenced by main().

◆ wdt_flag_get()

flag_status wdt_flag_get ( uint16_t wdt_flag )

get wdt flag

Parameters
wdt_flag this parameter can be one of the following values:
  • WDT_DIVF_UPDATE_FLAG: division value update complete flag.
  • WDT_RLDF_UPDATE_FLAG: reload value update complete flag.
  • WDT_WINF_UPDATE_FLAG: window value update complete flag.
Return values
state of wdt flag

Definition at line 118 of file at32f435_437_wdt.c.

◆ wdt_register_write_enable()

void wdt_register_write_enable ( confirm_state new_state )

enable or disable wdt cmd register write

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 97 of file at32f435_437_wdt.c.

Referenced by main().

◆ wdt_reload_value_set()

void wdt_reload_value_set ( uint16_t reload_value )

set wdt counter reload value

Parameters
reload_value (0x0000~0x0FFF)
Return values
none

Definition at line 69 of file at32f435_437_wdt.c.

Referenced by main().

◆ wdt_window_counter_set()

void wdt_window_counter_set ( uint16_t window_cnt )

wdt window counter value set

Parameters
window_cnt (0x0000~0x0FFF)
Return values
none

Definition at line 139 of file at32f435_437_wdt.c.


AT32F435/437 Firmwary Library: WDT_private_functions

Functions
WDT_private_functions
AT32F435_437_periph_driver » WDT

Functions

void | wdt_enable (void)
wdt enable ,the reload value will be sent to the counter More...
void | wdt_counter_reload (void)
reload wdt counter More...
void | wdt_reload_value_set (uint16_t reload_value)
set wdt counter reload value More...
void | wdt_divider_set (wdt_division_type division)
set wdt division divider More...
void | wdt_register_write_enable (confirm_state new_state)
enable or disable wdt cmd register write More...
flag_status | wdt_flag_get (uint16_t wdt_flag)
get wdt flag More...
void | wdt_window_counter_set (uint16_t window_cnt)
wdt window counter value set More...

Detailed Description

Function Documentation

◆ wdt_counter_reload()

void wdt_counter_reload ( void )

reload wdt counter

Parameters
none
Return values
none

Definition at line 59 of file at32f435_437_wdt.c.

Referenced by main().

◆ wdt_divider_set()

void wdt_divider_set ( wdt_division_type division )

set wdt division divider

Parameters
division this parameter can be one of the following values:
  • WDT_CLK_DIV_4
  • WDT_CLK_DIV_8
  • WDT_CLK_DIV_16
  • WDT_CLK_DIV_32
  • WDT_CLK_DIV_64
  • WDT_CLK_DIV_128
  • WDT_CLK_DIV_256
Return values
none

Definition at line 87 of file at32f435_437_wdt.c.

Referenced by main().

◆ wdt_enable()

void wdt_enable ( void )

wdt enable ,the reload value will be sent to the counter

Parameters
none
Return values
none

Definition at line 49 of file at32f435_437_wdt.c.

Referenced by main().

◆ wdt_flag_get()

flag_status wdt_flag_get ( uint16_t wdt_flag )

get wdt flag

Parameters
wdt_flag this parameter can be one of the following values:
  • WDT_DIVF_UPDATE_FLAG: division value update complete flag.
  • WDT_RLDF_UPDATE_FLAG: reload value update complete flag.
  • WDT_WINF_UPDATE_FLAG: window value update complete flag.
Return values
state of wdt flag

Definition at line 118 of file at32f435_437_wdt.c.

◆ wdt_register_write_enable()

void wdt_register_write_enable ( confirm_state new_state )

enable or disable wdt cmd register write

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 97 of file at32f435_437_wdt.c.

Referenced by main().

◆ wdt_reload_value_set()

void wdt_reload_value_set ( uint16_t reload_value )

set wdt counter reload value

Parameters
reload_value (0x0000~0x0FFF)
Return values
none

Definition at line 69 of file at32f435_437_wdt.c.

Referenced by main().

◆ wdt_window_counter_set()

void wdt_window_counter_set ( uint16_t window_cnt )

wdt window counter value set

Parameters
window_cnt (0x0000~0x0FFF)
Return values
none

Definition at line 139 of file at32f435_437_wdt.c.


AT32F435/437 Firmwary Library: WWDT

Modules | Macros
WWDT
AT32F435_437_periph_driver

WWDT driver modules. More...

Modules

WWDT_enable_bit_definition
wwdt enable bit
WWDT_exported_types
WWDT_exported_functions
WWDT_private_functions

Macros

#define WWDT ((wwdt_type *) WWDT_BASE)

Detailed Description

WWDT driver modules.

Macro Definition Documentation

◆ WWDT

#define WWDT ((wwdt_type *) WWDT_BASE)

Definition at line 127 of file at32f435_437_wwdt.h.


AT32F435/437 Firmwary Library: WWDT_enable_bit_definition

Macros
WWDT_enable_bit_definition
AT32F435_437_periph_driver » WWDT

wwdt enable bit More...

Macros

#define WWDT_EN_BIT ((uint32_t)0x00000080)

Detailed Description

wwdt enable bit

Macro Definition Documentation

◆ WWDT_EN_BIT

#define WWDT_EN_BIT ((uint32_t)0x00000080)

wwdt enable bit

Definition at line 52 of file at32f435_437_wwdt.h.


AT32F435/437 Firmwary Library: WWDT_exported_types

Data Structures | Enumerations
WWDT_exported_types
AT32F435_437_periph_driver » WWDT

Data Structures

struct wwdt_type
type define wwdt register all More...

Enumerations

enum wwdt_division_type { WWDT_PCLK1_DIV_4096 = 0x00 , WWDT_PCLK1_DIV_8192 = 0x01 , WWDT_PCLK1_DIV_16384 = 0x02 , WWDT_PCLK1_DIV_32768 = 0x03 }
wwdt division type More...

Detailed Description

Enumeration Type Documentation

◆ wwdt_division_type

enum wwdt_division_type

wwdt division type

Enumerator
WWDT_PCLK1_DIV_4096 | wwdt counter clock = (pclk1/4096)/1)
WWDT_PCLK1_DIV_8192 | wwdt counter clock = (pclk1/4096)/2)
WWDT_PCLK1_DIV_16384 | wwdt counter clock = (pclk1/4096)/4)
WWDT_PCLK1_DIV_32768 | wwdt counter clock = (pclk1/4096)/8)

Definition at line 65 of file at32f435_437_wwdt.h.


AT32F435/437 Firmwary Library: wwdt_type Struct Reference

Data Fields
wwdt_type Struct Reference
AT32F435_437_periph_driver » WWDT » WWDT_exported_types

type define wwdt register all More...

#include <at32f435_437_wwdt.h>

Data Fields

union {
__IO uint32_t ctrl
struct {
__IO uint32_t cnt: 7
__IO uint32_t wwdten: 1
__IO uint32_t reserved1: 24
} ctrl_bit
};
wwdt ctrl register, offset:0x00 More...
union {
__IO uint32_t cfg
struct {
__IO uint32_t win: 7
__IO uint32_t div: 2
__IO uint32_t rldien: 1
__IO uint32_t reserved1: 22
} cfg_bit
};
wwdt cfg register, offset:0x04 More...
union {
__IO uint32_t sts
struct {
__IO uint32_t rldf: 1
__IO uint32_t reserved1: 31
} sts_bit
};
wwdt cfg register, offset:0x08 More...

Detailed Description

type define wwdt register all

Definition at line 76 of file at32f435_437_wwdt.h.

Field Documentation

◆

union { ... } wwdt_type::@1297

wwdt ctrl register, offset:0x00

◆

union { ... } wwdt_type::@1299

wwdt cfg register, offset:0x04

◆

union { ... } wwdt_type::@1301

wwdt cfg register, offset:0x08

◆ cfg

__IO uint32_t wwdt_type::cfg

Definition at line 98 of file at32f435_437_wwdt.h.

◆

struct { ... } wwdt_type::cfg_bit

◆ cnt

__IO uint32_t wwdt_type::cnt

Definition at line 87 of file at32f435_437_wwdt.h.

◆ ctrl

__IO uint32_t wwdt_type::ctrl

Definition at line 84 of file at32f435_437_wwdt.h.

◆

struct { ... } wwdt_type::ctrl_bit

◆ div

__IO uint32_t wwdt_type::div

Definition at line 102 of file at32f435_437_wwdt.h.

◆ reserved1

__IO uint32_t wwdt_type::reserved1

Definition at line 89 of file at32f435_437_wwdt.h.

◆ rldf

__IO uint32_t wwdt_type::rldf

Definition at line 116 of file at32f435_437_wwdt.h.

◆ rldien

__IO uint32_t wwdt_type::rldien

Definition at line 103 of file at32f435_437_wwdt.h.

◆ sts

__IO uint32_t wwdt_type::sts

Definition at line 113 of file at32f435_437_wwdt.h.

◆

struct { ... } wwdt_type::sts_bit

◆ win

__IO uint32_t wwdt_type::win

Definition at line 101 of file at32f435_437_wwdt.h.

◆ wwdten

__IO uint32_t wwdt_type::wwdten

Definition at line 88 of file at32f435_437_wwdt.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_wwdt.h


AT32F435/437 Firmwary Library: WWDT_exported_functions

Functions
WWDT_exported_functions
AT32F435_437_periph_driver » WWDT

Functions

void | wwdt_reset (void)
wwdt reset by crm reset register More...
void | wwdt_divider_set (wwdt_division_type division)
wwdt division set More...
void | wwdt_flag_clear (void)
wwdt reload counter interrupt flag clear More...
void | wwdt_enable (uint8_t wwdt_cnt)
wwdt enable and the counter value load More...
void | wwdt_interrupt_enable (void)
wwdt reload counter interrupt enable More...
flag_status | wwdt_flag_get (void)
wwdt reload counter interrupt flag get More...
void | wwdt_counter_set (uint8_t wwdt_cnt)
wwdt counter value set More...
void | wwdt_window_counter_set (uint8_t window_cnt)
wwdt window counter value set More...

Detailed Description

Function Documentation

◆ wwdt_counter_set()

void wwdt_counter_set ( uint8_t wwdt_cnt )

wwdt counter value set

Parameters
wwdt_cnt (0x40~0x7f)
Return values
none

Definition at line 114 of file at32f435_437_wwdt.c.

Referenced by main().

◆ wwdt_divider_set()

void wwdt_divider_set ( wwdt_division_type division )

wwdt division set

Parameters
division this parameter can be one of the following values:
  • WWDT_PCLK1_DIV_4096 (wwdt counter clock = (pclk1/4096)/1)
  • WWDT_PCLK1_DIV_8192 (wwdt counter clock = (pclk1/4096)/2)
  • WWDT_PCLK1_DIV_16384 (wwdt counter clock = (pclk1/4096)/4)
  • WWDT_PCLK1_DIV_32768 (wwdt counter clock = (pclk1/4096)/8)
Return values
none

Definition at line 64 of file at32f435_437_wwdt.c.

Referenced by main().

◆ wwdt_enable()

void wwdt_enable ( uint8_t wwdt_cnt )

wwdt enable and the counter value load

Parameters
wwdt_cnt (0x40~0x7f)
Return values
none

< wwdt enable bit

Definition at line 84 of file at32f435_437_wwdt.c.

Referenced by main().

◆ wwdt_flag_clear()

void wwdt_flag_clear ( void )

wwdt reload counter interrupt flag clear

Parameters
none
Return values
none

Definition at line 74 of file at32f435_437_wwdt.c.

◆ wwdt_flag_get()

flag_status wwdt_flag_get ( void )

wwdt reload counter interrupt flag get

Parameters
none
Return values
state of reload counter interrupt flag

Definition at line 104 of file at32f435_437_wwdt.c.

◆ wwdt_interrupt_enable()

void wwdt_interrupt_enable ( void )

wwdt reload counter interrupt enable

Parameters
none
Return values
none

Definition at line 94 of file at32f435_437_wwdt.c.

◆ wwdt_reset()

void wwdt_reset ( void )

wwdt reset by crm reset register

Return values
none

Definition at line 48 of file at32f435_437_wwdt.c.

◆ wwdt_window_counter_set()

void wwdt_window_counter_set ( uint8_t window_cnt )

wwdt window counter value set

Parameters
window_cnt (0x40~0x7f)
Return values
none

Definition at line 124 of file at32f435_437_wwdt.c.

Referenced by main().


AT32F435/437 Firmwary Library: WWDT_private_functions

Functions
WWDT_private_functions
AT32F435_437_periph_driver » WWDT

Functions

void | wwdt_reset (void)
wwdt reset by crm reset register More...
void | wwdt_divider_set (wwdt_division_type division)
wwdt division set More...
void | wwdt_flag_clear (void)
wwdt reload counter interrupt flag clear More...
void | wwdt_enable (uint8_t wwdt_cnt)
wwdt enable and the counter value load More...
void | wwdt_interrupt_enable (void)
wwdt reload counter interrupt enable More...
flag_status | wwdt_flag_get (void)
wwdt reload counter interrupt flag get More...
void | wwdt_counter_set (uint8_t wwdt_cnt)
wwdt counter value set More...
void | wwdt_window_counter_set (uint8_t window_cnt)
wwdt window counter value set More...

Detailed Description

Function Documentation

◆ wwdt_counter_set()

void wwdt_counter_set ( uint8_t wwdt_cnt )

wwdt counter value set

Parameters
wwdt_cnt (0x40~0x7f)
Return values
none

Definition at line 114 of file at32f435_437_wwdt.c.

Referenced by main().

◆ wwdt_divider_set()

void wwdt_divider_set ( wwdt_division_type division )

wwdt division set

Parameters
division this parameter can be one of the following values:
  • WWDT_PCLK1_DIV_4096 (wwdt counter clock = (pclk1/4096)/1)
  • WWDT_PCLK1_DIV_8192 (wwdt counter clock = (pclk1/4096)/2)
  • WWDT_PCLK1_DIV_16384 (wwdt counter clock = (pclk1/4096)/4)
  • WWDT_PCLK1_DIV_32768 (wwdt counter clock = (pclk1/4096)/8)
Return values
none

Definition at line 64 of file at32f435_437_wwdt.c.

Referenced by main().

◆ wwdt_enable()

void wwdt_enable ( uint8_t wwdt_cnt )

wwdt enable and the counter value load

Parameters
wwdt_cnt (0x40~0x7f)
Return values
none

< wwdt enable bit

Definition at line 84 of file at32f435_437_wwdt.c.

Referenced by main().

◆ wwdt_flag_clear()

void wwdt_flag_clear ( void )

wwdt reload counter interrupt flag clear

Parameters
none
Return values
none

Definition at line 74 of file at32f435_437_wwdt.c.

◆ wwdt_flag_get()

flag_status wwdt_flag_get ( void )

wwdt reload counter interrupt flag get

Parameters
none
Return values
state of reload counter interrupt flag

Definition at line 104 of file at32f435_437_wwdt.c.

◆ wwdt_interrupt_enable()

void wwdt_interrupt_enable ( void )

wwdt reload counter interrupt enable

Parameters
none
Return values
none

Definition at line 94 of file at32f435_437_wwdt.c.

◆ wwdt_reset()

void wwdt_reset ( void )

wwdt reset by crm reset register

Return values
none

Definition at line 48 of file at32f435_437_wwdt.c.

◆ wwdt_window_counter_set()

void wwdt_window_counter_set ( uint8_t window_cnt )

wwdt window counter value set

Parameters
window_cnt (0x40~0x7f)
Return values
none

Definition at line 124 of file at32f435_437_wwdt.c.

Referenced by main().


AT32F435/437 Firmwary Library: XMC

Modules | Macros
XMC
AT32F435_437_periph_driver

XMC driver modules. More...

Modules

XMC_exported_types
XMC_exported_functions
XMC_private_functions

Macros

#define | XMC_BANK1 ((xmc_bank1_type *) XMC_BANK1_REG_BASE)
#define | XMC_BANK2 ((xmc_bank2_type *) XMC_BANK2_REG_BASE)
#define | XMC_BANK3 ((xmc_bank3_type *) XMC_BANK3_REG_BASE)
#define | XMC_BANK4 ((xmc_bank4_type *) XMC_BANK4_REG_BASE)
#define | XMC_SDRAM ((xmc_sdram_type *) XMC_SDRAM_REG_BASE)

Detailed Description

XMC driver modules.

Macro Definition Documentation

◆ XMC_BANK1

#define XMC_BANK1 ((xmc_bank1_type *) XMC_BANK1_REG_BASE)

Definition at line 1009 of file at32f435_437_xmc.h.

◆ XMC_BANK2

#define XMC_BANK2 ((xmc_bank2_type *) XMC_BANK2_REG_BASE)

Definition at line 1010 of file at32f435_437_xmc.h.

◆ XMC_BANK3

#define XMC_BANK3 ((xmc_bank3_type *) XMC_BANK3_REG_BASE)

Definition at line 1011 of file at32f435_437_xmc.h.

◆ XMC_BANK4

#define XMC_BANK4 ((xmc_bank4_type *) XMC_BANK4_REG_BASE)

Definition at line 1012 of file at32f435_437_xmc.h.

◆ XMC_SDRAM

#define XMC_SDRAM ((xmc_sdram_type *) XMC_SDRAM_REG_BASE)

Definition at line 1013 of file at32f435_437_xmc.h.


AT32F435/437 Firmwary Library: XMC_exported_types

Data Structures | Enumerations
XMC_exported_types
AT32F435_437_periph_driver » XMC

Data Structures

struct | xmc_norsram_timing_init_type
nor/sram banks timing parameters More...
struct | xmc_norsram_init_type
xmc nor/sram init structure definition More...
struct | xmc_nand_pccard_timinginit_type
nand and pccard timing parameters xmc More...
struct | xmc_nand_init_type
xmc nand init structure definition More...
struct | xmc_pccard_init_type
xmc pccard init structure definition More...
struct | xmc_sdram_init_type
xmc sdram init structure definition More...
struct | xmc_sdram_timing_type
xmc sdram timing structure definition More...
struct | xmc_sdram_cmd_type
xmc sdram command structure definition More...
struct | xmc_bank1_ctrl_tmg_reg_type
struct | xmc_bank1_tmgwr_reg_type
struct | xmc_bank1_type
xmc bank1 registers More...
struct | xmc_bank2_type
xmc bank2 registers More...
struct | xmc_bank3_type
xmc bank3 registers More...
struct | xmc_bank4_type
xmc bank4 registers More...
struct | xmc_sdram_type
xmc sdram type More...

Enumerations

enum | xmc_data_addr_mux_type { XMC_DATA_ADDR_MUX_DISABLE = 0x00000000 , XMC_DATA_ADDR_MUX_ENABLE = 0x00000002 }
xmc data address bus multiplexing type More...
enum | xmc_burst_access_mode_type { XMC_BURST_MODE_DISABLE = 0x00000000 , XMC_BURST_MODE_ENABLE = 0x00000100 }
xmc burst access mode type More...
enum | xmc_asyn_wait_type { XMC_ASYN_WAIT_DISABLE = 0x00000000 , XMC_ASYN_WAIT_ENABLE = 0x00008000 }
xmc asynchronous wait type More...
enum | xmc_wrap_mode_type { XMC_WRAPPED_MODE_DISABLE = 0x00000000 , XMC_WRAPPED_MODE_ENABLE = 0x00000400 }
xmc wrapped mode type More...
enum | xmc_write_operation_type { XMC_WRITE_OPERATION_DISABLE = 0x00000000 , XMC_WRITE_OPERATION_ENABLE = 0x00001000 }
xmc write operation type More...
enum | xmc_wait_signal_type { XMC_WAIT_SIGNAL_DISABLE = 0x00000000 , XMC_WAIT_SIGNAL_ENABLE = 0x00002000 }
xmc wait signal type More...
enum | xmc_write_burst_type { XMC_WRITE_BURST_SYN_DISABLE = 0x00000000 , XMC_WRITE_BURST_SYN_ENABLE = 0x00080000 }
xmc write burst type More...
enum | xmc_extended_mode_type { XMC_WRITE_TIMING_DISABLE = 0x00000000 , XMC_WRITE_TIMING_ENABLE = 0x00004000 }
xmc extended mode type More...
enum | xmc_nand_pccard_wait_type { XMC_WAIT_OPERATION_DISABLE = 0x00000000 , XMC_WAIT_OPERATION_ENABLE = 0x00000002 }
xmc pccard wait type More...
enum | xmc_ecc_enable_type { XMC_ECC_OPERATION_DISABLE = 0x00000000 , XMC_ECC_OPERATION_ENABLE = 0x00000040 }
xmc ecc enable type More...
enum | xmc_nor_sram_subbank_type { XMC_BANK1_NOR_SRAM1 = 0x00000000 , XMC_BANK1_NOR_SRAM2 = 0x00000001 , XMC_BANK1_NOR_SRAM3 = 0x00000002 , XMC_BANK1_NOR_SRAM4 = 0x00000003 }
xmc nor/sram subbank type More...
enum | xmc_class_bank_type { XMC_BANK2_NAND = 0x00000000 , XMC_BANK3_NAND = 0x00000001 , XMC_BANK4_PCCARD = 0x00000002 , XMC_BANK5_6_SDRAM = 0x00000003 }
xmc class bank type More...
enum | xmc_memory_type { XMC_DEVICE_SRAM = 0x00000000 , XMC_DEVICE_PSRAM = 0x00000004 , XMC_DEVICE_NOR = 0x00000008 }
xmc memory type More...
enum | xmc_data_width_type { XMC_BUSTYPE_8_BITS = 0x00000000 , XMC_BUSTYPE_16_BITS = 0x00000010 }
xmc data width type More...
enum | xmc_wait_signal_polarity_type { XMC_WAIT_SIGNAL_LEVEL_LOW = 0x00000000 , XMC_WAIT_SIGNAL_LEVEL_HIGH = 0x00000200 }
xmc wait signal polarity type More...
enum | xmc_wait_timing_type { XMC_WAIT_SIGNAL_SYN_BEFORE = 0x00000000 , XMC_WAIT_SIGNAL_SYN_DURING = 0x00000800 }
xmc wait timing type More...
enum | xmc_access_mode_type { XMC_ACCESS_MODE_A = 0x00000000 , XMC_ACCESS_MODE_B = 0x10000000 , XMC_ACCESS_MODE_C = 0x20000000 , XMC_ACCESS_MODE_D = 0x30000000 }
xmc access mode type More...
enum xmc_ecc_pagesize_type {
XMC_ECC_PAGESIZE_256_BYTES = 0x00000000 , XMC_ECC_PAGESIZE_512_BYTES = 0x00020000 , XMC_ECC_PAGESIZE_1024_BYTES = 0x00040000 , XMC_ECC_PAGESIZE_2048_BYTES = 0x00060000 ,
XMC_ECC_PAGESIZE_4096_BYTES = 0x00080000 , XMC_ECC_PAGESIZE_8192_BYTES = 0x000A0000
}
xmc ecc page size type More...
enum | xmc_interrupt_sources_type { XMC_INT_RISING_EDGE = 0x00000008 , XMC_INT_LEVEL = 0x00000010 , XMC_INT_FALLING_EDGE = 0x00000020 , XMC_INT_ERR = 0x00004000 }
xmc interrupt sources type More...
enum xmc_interrupt_flag_type {
XMC_RISINGEDGE_FLAG = 0x00000001 , XMC_LEVEL_FLAG = 0x00000002 , XMC_FALLINGEDGE_FLAG = 0x00000004 , XMC_FEMPT_FLAG = 0x00000040 ,
XMC_ERR_FLAG = 0x00000001 , XMC_BUSY_FLAG = 0x00000020
}
xmc interrupt flag type More...
enum | xmc_sdram_column_type { XMC_COLUMN_8 = 0x00000000 , XMC_COLUMN_9 = 0x00000001 , XMC_COLUMN_10 = 0x00000002 , XMC_COLUMN_11 = 0x00000003 }
xmc sdram number of column address type More...
enum | xmc_sdram_row_type { XMC_ROW_11 = 0x00000000 , XMC_ROW_12 = 0x00000001 , XMC_ROW_13 = 0x00000002 }
xmc sdram number of row address type More...
enum | xmc_sdram_width_type { XMC_MEM_WIDTH_8 = 0x00000000 , XMC_MEM_WIDTH_16 = 0x00000001 }
xmc sdram memory data bus width type More...
enum | xmc_sdram_inbk_type { XMC_INBK_2 = 0x00000000 , XMC_INBK_4 = 0x00000001 }
xmc sdram number of internal banks type More...
enum | xmc_sdram_cas_type { XMC_CAS_1 = 0x00000001 , XMC_CAS_2 = 0x00000002 , XMC_CAS_3 = 0x00000003 }
xmc sdram cas latency type More...
enum | xmc_sdram_clkdiv_type { XMC_NO_CLK = 0x00000000 , XMC_CLKDIV_2 = 0x00000002 , XMC_CLKDIV_3 = 0x00000003 , XMC_CLKDIV_4 = 0x00000001 }
xmc sdram clock div type More...
enum | xmc_sdram_rd_delay_type { XMC_READ_DELAY_0 = 0x00000000 , XMC_READ_DELAY_1 = 0x00000001 , XMC_READ_DELAY_2 = 0x00000002 }
xmc sdram read delay More...
enum | xmc_sdram_bank_type { XMC_SDRAM_BANK1 = 0x00000000 , XMC_SDRAM_BANK2 = 0x00000001 }
xmc sdram bank type More...
enum xmc_sdram_delay_type {
XMC_DELAY_CYCLE_1 = 0x00000000 , XMC_DELAY_CYCLE_2 = 0x00000001 , XMC_DELAY_CYCLE_3 = 0x00000002 , XMC_DELAY_CYCLE_4 = 0x00000003 ,
XMC_DELAY_CYCLE_5 = 0x00000004 , XMC_DELAY_CYCLE_6 = 0x00000005 , XMC_DELAY_CYCLE_7 = 0x00000006 , XMC_DELAY_CYCLE_8 = 0x00000007 ,
XMC_DELAY_CYCLE_9 = 0x00000008 , XMC_DELAY_CYCLE_10 = 0x00000009 , XMC_DELAY_CYCLE_11 = 0x0000000A , XMC_DELAY_CYCLE_12 = 0x0000000B ,
XMC_DELAY_CYCLE_13 = 0x0000000C , XMC_DELAY_CYCLE_14 = 0x0000000D , XMC_DELAY_CYCLE_15 = 0x0000000E , XMC_DELAY_CYCLE_16 = 0x0000000F
}
xmc sdram timing delay cycle type More...
enum xmc_command_type {
XMC_CMD_NORMAL = 0x00000000 , XMC_CMD_CLK = 0x00000001 , XMC_CMD_PRECHARG_ALL = 0x00000002 , XMC_CMD_AUTO_REFRESH = 0x00000003 ,
XMC_CMD_LOAD_MODE = 0x00000004 , XMC_CMD_SELF_REFRESH = 0x00000005 , XMC_CMD_POWER_DOWN = 0x00000006
}
xmc sdram command type More...
enum | xmc_cmd_bank1_2_type { XMC_CMD_BANK1 = 0x00000010 , XMC_CMD_BANK2 = 0x00000008 , XMC_CMD_BANK1_2 = 0x00000018 }
xmc sdram command bank select type More...
enum | xmc_bank_status_type { XMC_STATUS_NORMAL = 0x00000000 , XMC_STATUS_SELF_REFRESH = 0x00000001 , XMC_STATUS_POWER_DOWN = 0x00000002 , XMC_STATUS_MASK = 0x00000003 }
xmc sdram bank status type More...

Detailed Description

Enumeration Type Documentation

◆ xmc_access_mode_type

enum xmc_access_mode_type

xmc access mode type

Enumerator
XMC_ACCESS_MODE_A | xmc access mode A
XMC_ACCESS_MODE_B | xmc access mode B
XMC_ACCESS_MODE_C | xmc access mode C
XMC_ACCESS_MODE_D | xmc access mode D

Definition at line 203 of file at32f435_437_xmc.h.

◆ xmc_asyn_wait_type

enum xmc_asyn_wait_type

xmc asynchronous wait type

Enumerator
XMC_ASYN_WAIT_DISABLE | xmc wait signal during asynchronous transfers disbale
XMC_ASYN_WAIT_ENABLE | xmc wait signal during asynchronous transfers enable

Definition at line 72 of file at32f435_437_xmc.h.

◆ xmc_bank_status_type

enum xmc_bank_status_type

xmc sdram bank status type

Enumerator
XMC_STATUS_NORMAL | xmc sdram status normal
XMC_STATUS_SELF_REFRESH | xmc sdram status self refresh
XMC_STATUS_POWER_DOWN | xmc sdram power down
XMC_STATUS_MASK | xmc sdram mask

Definition at line 380 of file at32f435_437_xmc.h.

◆ xmc_burst_access_mode_type

enum xmc_burst_access_mode_type

xmc burst access mode type

Enumerator
XMC_BURST_MODE_DISABLE | xmc burst mode disable
XMC_BURST_MODE_ENABLE | xmc burst mode enable

Definition at line 63 of file at32f435_437_xmc.h.

◆ xmc_class_bank_type

enum xmc_class_bank_type

xmc class bank type

Enumerator
XMC_BANK2_NAND | xmc nand flash bank2
XMC_BANK3_NAND | xmc nand flash bank3
XMC_BANK4_PCCARD | xmc pc card bank4
XMC_BANK5_6_SDRAM | xmc sdram bank5/6

Definition at line 155 of file at32f435_437_xmc.h.

◆ xmc_cmd_bank1_2_type

enum xmc_cmd_bank1_2_type

xmc sdram command bank select type

Enumerator
XMC_CMD_BANK1 | send xmc sdram command to bank1
XMC_CMD_BANK2 | send xmc sdram command to bank2
XMC_CMD_BANK1_2 | send xmc sdram command to bank1 and bank2

Definition at line 369 of file at32f435_437_xmc.h.

◆ xmc_command_type

enum xmc_command_type

xmc sdram command type

Enumerator
XMC_CMD_NORMAL | xmc sdram command normal
XMC_CMD_CLK | xmc sdram command clock enable
XMC_CMD_PRECHARG_ALL | xmc sdram command precharg all bank
XMC_CMD_AUTO_REFRESH | xmc sdram command auto refresh
XMC_CMD_LOAD_MODE | xmc sdram command load mode register
XMC_CMD_SELF_REFRESH | xmc sdram command self refresh
XMC_CMD_POWER_DOWN | xmc sdram command power down

Definition at line 355 of file at32f435_437_xmc.h.

◆ xmc_data_addr_mux_type

enum xmc_data_addr_mux_type

xmc data address bus multiplexing type

Enumerator
XMC_DATA_ADDR_MUX_DISABLE | xmc address/data multiplexing disable
XMC_DATA_ADDR_MUX_ENABLE | xmc address/data multiplexing enable

Definition at line 54 of file at32f435_437_xmc.h.

◆ xmc_data_width_type

enum xmc_data_width_type

xmc data width type

Enumerator
XMC_BUSTYPE_8_BITS | xmc databuss width 8bits
XMC_BUSTYPE_16_BITS | xmc databuss width 16bits

Definition at line 176 of file at32f435_437_xmc.h.

◆ xmc_ecc_enable_type

enum xmc_ecc_enable_type

xmc ecc enable type

Enumerator
XMC_ECC_OPERATION_DISABLE | xmc ecc module disable
XMC_ECC_OPERATION_ENABLE | xmc ecc module enable

Definition at line 135 of file at32f435_437_xmc.h.

◆ xmc_ecc_pagesize_type

enum xmc_ecc_pagesize_type

xmc ecc page size type

Enumerator
XMC_ECC_PAGESIZE_256_BYTES | xmc ecc page size 256 bytes
XMC_ECC_PAGESIZE_512_BYTES | xmc ecc page size 512 bytes
XMC_ECC_PAGESIZE_1024_BYTES | xmc ecc page size 1024 bytes
XMC_ECC_PAGESIZE_2048_BYTES | xmc ecc page size 2048 bytes
XMC_ECC_PAGESIZE_4096_BYTES | xmc ecc page size 4096 bytes
XMC_ECC_PAGESIZE_8192_BYTES | xmc ecc page size 8192 bytes

Definition at line 214 of file at32f435_437_xmc.h.

◆ xmc_extended_mode_type

enum xmc_extended_mode_type

xmc extended mode type

Enumerator
XMC_WRITE_TIMING_DISABLE | xmc write timing disable
XMC_WRITE_TIMING_ENABLE | xmc write timing enable

Definition at line 117 of file at32f435_437_xmc.h.

◆ xmc_interrupt_flag_type

enum xmc_interrupt_flag_type

xmc interrupt flag type

Enumerator
XMC_RISINGEDGE_FLAG | xmc interrupt rising edge detection flag
XMC_LEVEL_FLAG | xmc interrupt high-level edge detection flag
XMC_FALLINGEDGE_FLAG | xmc interrupt falling edge detection flag
XMC_FEMPT_FLAG | xmc fifo empty flag
XMC_ERR_FLAG | xmc sdram error flag
XMC_BUSY_FLAG | xmc sdram busy flag

Definition at line 238 of file at32f435_437_xmc.h.

◆ xmc_interrupt_sources_type

enum xmc_interrupt_sources_type

xmc interrupt sources type

Enumerator
XMC_INT_RISING_EDGE | xmc rising edge detection interrupt enable
XMC_INT_LEVEL | xmc high-level edge detection interrupt enable
XMC_INT_FALLING_EDGE | xmc falling edge detection interrupt enable
XMC_INT_ERR | xmc sdram error interrupt enable

Definition at line 227 of file at32f435_437_xmc.h.

◆ xmc_memory_type

enum xmc_memory_type

xmc memory type

Enumerator
XMC_DEVICE_SRAM | xmc device choice sram
XMC_DEVICE_PSRAM | xmc device choice psram
XMC_DEVICE_NOR | xmc device choice nor flash

Definition at line 166 of file at32f435_437_xmc.h.

◆ xmc_nand_pccard_wait_type

enum xmc_nand_pccard_wait_type

xmc pccard wait type

Enumerator
XMC_WAIT_OPERATION_DISABLE | xmc wait operation for the pc card/nand flash memory bank disable
XMC_WAIT_OPERATION_ENABLE | xmc wait operation for the pc card/nand flash memory bank enable

Definition at line 126 of file at32f435_437_xmc.h.

◆ xmc_nor_sram_subbank_type

enum xmc_nor_sram_subbank_type

xmc nor/sram subbank type

Enumerator
XMC_BANK1_NOR_SRAM1 | xmc nor/sram subbank1
XMC_BANK1_NOR_SRAM2 | xmc nor/sram subbank2
XMC_BANK1_NOR_SRAM3 | xmc nor/sram subbank3
XMC_BANK1_NOR_SRAM4 | xmc nor/sram subbank4

Definition at line 144 of file at32f435_437_xmc.h.

◆ xmc_sdram_bank_type

enum xmc_sdram_bank_type

xmc sdram bank type

Enumerator
XMC_SDRAM_BANK1 | xmc sdram bank 1
XMC_SDRAM_BANK2 | xmc sdram bank 2

Definition at line 321 of file at32f435_437_xmc.h.

◆ xmc_sdram_cas_type

enum xmc_sdram_cas_type

xmc sdram cas latency type

Enumerator
XMC_CAS_1 | xmc sdram cas 1
XMC_CAS_2 | xmc sdram cas 2
XMC_CAS_3 | xmc sdram cas 3

Definition at line 290 of file at32f435_437_xmc.h.

◆ xmc_sdram_clkdiv_type

enum xmc_sdram_clkdiv_type

xmc sdram clock div type

Enumerator
XMC_NO_CLK | xmc sdram disable clock
XMC_CLKDIV_2 | xmc sdram clock div 2
XMC_CLKDIV_3 | xmc sdram clock div 3
XMC_CLKDIV_4 | xmc sdram clock div 4

Definition at line 300 of file at32f435_437_xmc.h.

◆ xmc_sdram_column_type

enum xmc_sdram_column_type

xmc sdram number of column address type

Enumerator
XMC_COLUMN_8 | xmc sdram column address 8bit
XMC_COLUMN_9 | xmc sdram column address 9bit
XMC_COLUMN_10 | xmc sdram column address 10bit
XMC_COLUMN_11 | xmc sdram column address 11bit

Definition at line 251 of file at32f435_437_xmc.h.

◆ xmc_sdram_delay_type

enum xmc_sdram_delay_type

xmc sdram timing delay cycle type

Enumerator
XMC_DELAY_CYCLE_1 | xmc sdram timming delay 1 cycle
XMC_DELAY_CYCLE_2 | xmc sdram timming delay 2 cycle
XMC_DELAY_CYCLE_3 | xmc sdram timming delay 3 cycle
XMC_DELAY_CYCLE_4 | xmc sdram timming delay 4 cycle
XMC_DELAY_CYCLE_5 | xmc sdram timming delay 5 cycle
XMC_DELAY_CYCLE_6 | xmc sdram timming delay 6 cycle
XMC_DELAY_CYCLE_7 | xmc sdram timming delay 7 cycle
XMC_DELAY_CYCLE_8 | xmc sdram timming delay 8 cycle
XMC_DELAY_CYCLE_9 | xmc sdram timming delay 9 cycle
XMC_DELAY_CYCLE_10 | xmc sdram timming delay 10 cycle
XMC_DELAY_CYCLE_11 | xmc sdram timming delay 11 cycle
XMC_DELAY_CYCLE_12 | xmc sdram timming delay 12 cycle
XMC_DELAY_CYCLE_13 | xmc sdram timming delay 13 cycle
XMC_DELAY_CYCLE_14 | xmc sdram timming delay 14 cycle
XMC_DELAY_CYCLE_15 | xmc sdram timming delay 15 cycle
XMC_DELAY_CYCLE_16 | xmc sdram timming delay 16 cycle

Definition at line 331 of file at32f435_437_xmc.h.

◆ xmc_sdram_inbk_type

enum xmc_sdram_inbk_type

xmc sdram number of internal banks type

Enumerator
XMC_INBK_2 | xmc sdram 2 internal banks
XMC_INBK_4 | xmc sdram 4 internal banks

Definition at line 281 of file at32f435_437_xmc.h.

◆ xmc_sdram_rd_delay_type

enum xmc_sdram_rd_delay_type

xmc sdram read delay

Enumerator
XMC_READ_DELAY_0 | xmc sdram no delay
XMC_READ_DELAY_1 | xmc sdram delay 1 clock
XMC_READ_DELAY_2 | xmc sdram delay 2 clock

Definition at line 311 of file at32f435_437_xmc.h.

◆ xmc_sdram_row_type

enum xmc_sdram_row_type

xmc sdram number of row address type

Enumerator
XMC_ROW_11 | xmc sdram row address 11bit
XMC_ROW_12 | xmc sdram row address 12bit
XMC_ROW_13 | xmc sdram row address 13bit

Definition at line 262 of file at32f435_437_xmc.h.

◆ xmc_sdram_width_type

enum xmc_sdram_width_type

xmc sdram memory data bus width type

Enumerator
XMC_MEM_WIDTH_8 | xmc sdram data bus width 8
XMC_MEM_WIDTH_16 | xmc sdram data bus width 16

Definition at line 272 of file at32f435_437_xmc.h.

◆ xmc_wait_signal_polarity_type

enum xmc_wait_signal_polarity_type

xmc wait signal polarity type

Enumerator
XMC_WAIT_SIGNAL_LEVEL_LOW | xmc nwait active low
XMC_WAIT_SIGNAL_LEVEL_HIGH | xmc nwait active high

Definition at line 185 of file at32f435_437_xmc.h.

◆ xmc_wait_signal_type

enum xmc_wait_signal_type

xmc wait signal type

Enumerator
XMC_WAIT_SIGNAL_DISABLE | xmc nwait signal is disable
XMC_WAIT_SIGNAL_ENABLE | xmc nwait signal is enable

Definition at line 99 of file at32f435_437_xmc.h.

◆ xmc_wait_timing_type

enum xmc_wait_timing_type

xmc wait timing type

Enumerator
XMC_WAIT_SIGNAL_SYN_BEFORE | xmc nwait signal is active one data cycle before wait state
XMC_WAIT_SIGNAL_SYN_DURING | xmc nwait signal is active during wait state

Definition at line 194 of file at32f435_437_xmc.h.

◆ xmc_wrap_mode_type

enum xmc_wrap_mode_type

xmc wrapped mode type

Enumerator
XMC_WRAPPED_MODE_DISABLE | xmc direct wrapped burst is disbale
XMC_WRAPPED_MODE_ENABLE | xmc direct wrapped burst is enable

Definition at line 81 of file at32f435_437_xmc.h.

◆ xmc_write_burst_type

enum xmc_write_burst_type

xmc write burst type

Enumerator
XMC_WRITE_BURST_SYN_DISABLE | xmc write operations are always performed in asynchronous mode
XMC_WRITE_BURST_SYN_ENABLE | xmc write operations are performed in synchronous mode

Definition at line 108 of file at32f435_437_xmc.h.

◆ xmc_write_operation_type

enum xmc_write_operation_type

xmc write operation type

Enumerator
XMC_WRITE_OPERATION_DISABLE | xmc write operations is disable
XMC_WRITE_OPERATION_ENABLE | xmc write operations is enable

Definition at line 90 of file at32f435_437_xmc.h.


AT32F435/437 Firmwary Library: xmc_norsram_timing_init_type Struct Reference

Data Fields
xmc_norsram_timing_init_type Struct Reference
AT32F435_437_periph_driver » XMC » XMC_exported_types

nor/sram banks timing parameters More...

#include <at32f435_437_xmc.h>

Data Fields

xmc_nor_sram_subbank_type subbank
xmc_extended_mode_type write_timing_enable
uint32_t | addr_setup_time
uint32_t | addr_hold_time
uint32_t | data_setup_time
uint32_t | bus_latency_time
uint32_t | clk_psc
uint32_t | data_latency_time
xmc_access_mode_type mode

Detailed Description

nor/sram banks timing parameters

Definition at line 392 of file at32f435_437_xmc.h.

Field Documentation

◆ addr_hold_time

uint32_t xmc_norsram_timing_init_type::addr_hold_time

xmc nor/sram address hold time

Definition at line 397 of file at32f435_437_xmc.h.

Referenced by nor_init(), psram_init(), sram_init(), xmc_init(), xmc_nor_sram_timing_config(), and xmc_norsram_timing_default_para_init().

◆ addr_setup_time

uint32_t xmc_norsram_timing_init_type::addr_setup_time

xmc nor/sram address setup time

Definition at line 396 of file at32f435_437_xmc.h.

Referenced by nor_init(), psram_init(), sram_init(), xmc_init(), xmc_nor_sram_timing_config(), and xmc_norsram_timing_default_para_init().

◆ bus_latency_time

uint32_t xmc_norsram_timing_init_type::bus_latency_time

xmc nor/sram bus latency time

Definition at line 399 of file at32f435_437_xmc.h.

Referenced by nor_init(), psram_init(), sram_init(), xmc_init(), xmc_nor_sram_timing_config(), and xmc_norsram_timing_default_para_init().

◆ clk_psc

uint32_t xmc_norsram_timing_init_type::clk_psc

xmc nor/sram clock prescale

Definition at line 400 of file at32f435_437_xmc.h.

Referenced by nor_init(), psram_init(), sram_init(), xmc_init(), xmc_nor_sram_timing_config(), and xmc_norsram_timing_default_para_init().

◆ data_latency_time

uint32_t xmc_norsram_timing_init_type::data_latency_time

xmc nor/sram data latency time

Definition at line 401 of file at32f435_437_xmc.h.

Referenced by nor_init(), psram_init(), sram_init(), xmc_init(), xmc_nor_sram_timing_config(), and xmc_norsram_timing_default_para_init().

◆ data_setup_time

uint32_t xmc_norsram_timing_init_type::data_setup_time

xmc nor/sram data setup time

Definition at line 398 of file at32f435_437_xmc.h.

Referenced by nor_init(), psram_init(), sram_init(), xmc_init(), xmc_nor_sram_timing_config(), and xmc_norsram_timing_default_para_init().

◆ mode

xmc_access_mode_type xmc_norsram_timing_init_type::mode

xmc nor/sram access mode

Definition at line 402 of file at32f435_437_xmc.h.

Referenced by nor_init(), psram_init(), sram_init(), xmc_init(), xmc_nor_sram_timing_config(), and xmc_norsram_timing_default_para_init().

◆ subbank

xmc_nor_sram_subbank_type xmc_norsram_timing_init_type::subbank

xmc nor/sram subbank

Definition at line 394 of file at32f435_437_xmc.h.

Referenced by nor_init(), psram_init(), sram_init(), xmc_init(), xmc_nor_sram_timing_config(), and xmc_norsram_timing_default_para_init().

◆ write_timing_enable

xmc_extended_mode_type xmc_norsram_timing_init_type::write_timing_enable

xmc nor/sram write timing enable

Definition at line 395 of file at32f435_437_xmc.h.

Referenced by nor_init(), psram_init(), sram_init(), xmc_init(), xmc_nor_sram_timing_config(), and xmc_norsram_timing_default_para_init().

The documentation for this struct was generated from the following file:
  • at32f435_437_xmc.h


AT32F435/437 Firmwary Library: xmc_norsram_init_type Struct Reference

Data Fields
xmc_norsram_init_type Struct Reference
AT32F435_437_periph_driver » XMC » XMC_exported_types

xmc nor/sram init structure definition More...

#include <at32f435_437_xmc.h>

Data Fields

xmc_nor_sram_subbank_type subbank
xmc_data_addr_mux_type data_addr_multiplex
xmc_memory_type device
xmc_data_width_type bus_type
xmc_burst_access_mode_type burst_mode_enable
xmc_asyn_wait_type asynwait_enable
xmc_wait_signal_polarity_type wait_signal_lv
xmc_wrap_mode_type wrapped_mode_enable
xmc_wait_timing_type wait_signal_config
xmc_write_operation_type write_enable
xmc_wait_signal_type wait_signal_enable
xmc_extended_mode_type write_timing_enable
xmc_write_burst_type write_burst_syn

Detailed Description

xmc nor/sram init structure definition

Definition at line 408 of file at32f435_437_xmc.h.

Field Documentation

◆ asynwait_enable

xmc_asyn_wait_type xmc_norsram_init_type::asynwait_enable

xmc nor/sram nwait in asynchronous transfer enable

Definition at line 415 of file at32f435_437_xmc.h.

Referenced by nor_init(), psram_init(), sram_init(), xmc_init(), xmc_nor_sram_init(), and xmc_norsram_default_para_init().

◆ burst_mode_enable

xmc_burst_access_mode_type xmc_norsram_init_type::burst_mode_enable

xmc nor/sram burst mode enable

Definition at line 414 of file at32f435_437_xmc.h.

Referenced by nor_init(), psram_init(), sram_init(), xmc_init(), xmc_nor_sram_init(), and xmc_norsram_default_para_init().

◆ bus_type

xmc_data_width_type xmc_norsram_init_type::bus_type

xmc nor/sram data bus width

Definition at line 413 of file at32f435_437_xmc.h.

Referenced by nor_init(), psram_init(), sram_init(), xmc_init(), xmc_nor_sram_init(), and xmc_norsram_default_para_init().

◆ data_addr_multiplex

xmc_data_addr_mux_type xmc_norsram_init_type::data_addr_multiplex

xmc nor/sram address/data multiplexing enable

Definition at line 411 of file at32f435_437_xmc.h.

Referenced by nor_init(), psram_init(), sram_init(), xmc_init(), xmc_nor_sram_init(), and xmc_norsram_default_para_init().

◆ device

xmc_memory_type xmc_norsram_init_type::device

xmc nor/sram memory device

Definition at line 412 of file at32f435_437_xmc.h.

Referenced by nor_init(), psram_init(), sram_init(), xmc_init(), xmc_nor_sram_init(), and xmc_norsram_default_para_init().

◆ subbank

xmc_nor_sram_subbank_type xmc_norsram_init_type::subbank

xmc nor/sram subbank

Definition at line 410 of file at32f435_437_xmc.h.

Referenced by nor_init(), psram_init(), sram_init(), xmc_init(), xmc_nor_sram_init(), and xmc_norsram_default_para_init().

◆ wait_signal_config

xmc_wait_timing_type xmc_norsram_init_type::wait_signal_config

xmc nor/sram nwait timing configuration

Definition at line 418 of file at32f435_437_xmc.h.

Referenced by nor_init(), psram_init(), sram_init(), xmc_init(), xmc_nor_sram_init(), and xmc_norsram_default_para_init().

◆ wait_signal_enable

xmc_wait_signal_type xmc_norsram_init_type::wait_signal_enable

xmc nor/sram nwait in synchronous transfer enable

Definition at line 420 of file at32f435_437_xmc.h.

Referenced by nor_init(), psram_init(), sram_init(), xmc_init(), xmc_nor_sram_init(), and xmc_norsram_default_para_init().

◆ wait_signal_lv

xmc_wait_signal_polarity_type xmc_norsram_init_type::wait_signal_lv

xmc nor/sram nwait polarity

Definition at line 416 of file at32f435_437_xmc.h.

Referenced by nor_init(), psram_init(), sram_init(), xmc_init(), xmc_nor_sram_init(), and xmc_norsram_default_para_init().

◆ wrapped_mode_enable

xmc_wrap_mode_type xmc_norsram_init_type::wrapped_mode_enable

xmc nor/sram wrapped enable

Definition at line 417 of file at32f435_437_xmc.h.

Referenced by nor_init(), psram_init(), sram_init(), xmc_init(), xmc_nor_sram_init(), and xmc_norsram_default_para_init().

◆ write_burst_syn

xmc_write_burst_type xmc_norsram_init_type::write_burst_syn

xmc nor/sram memory write mode control

Definition at line 422 of file at32f435_437_xmc.h.

Referenced by nor_init(), psram_init(), sram_init(), xmc_init(), xmc_nor_sram_init(), and xmc_norsram_default_para_init().

◆ write_enable

xmc_write_operation_type xmc_norsram_init_type::write_enable

xmc nor/sram write enable

Definition at line 419 of file at32f435_437_xmc.h.

Referenced by nor_init(), psram_init(), sram_init(), xmc_init(), xmc_nor_sram_init(), and xmc_norsram_default_para_init().

◆ write_timing_enable

xmc_extended_mode_type xmc_norsram_init_type::write_timing_enable

xmc nor/sram read-write timing different

Definition at line 421 of file at32f435_437_xmc.h.

Referenced by nor_init(), psram_init(), sram_init(), xmc_init(), xmc_nor_sram_init(), and xmc_norsram_default_para_init().

The documentation for this struct was generated from the following file:
  • at32f435_437_xmc.h


AT32F435/437 Firmwary Library: xmc_nand_pccard_timinginit_type Struct Reference

Data Fields
xmc_nand_pccard_timinginit_type Struct Reference
AT32F435_437_periph_driver » XMC » XMC_exported_types

nand and pccard timing parameters xmc More...

#include <at32f435_437_xmc.h>

Data Fields

xmc_class_bank_type class_bank
uint32_t | mem_setup_time
uint32_t | mem_waite_time
uint32_t | mem_hold_time
uint32_t | mem_hiz_time

Detailed Description

nand and pccard timing parameters xmc

Definition at line 429 of file at32f435_437_xmc.h.

Field Documentation

◆ class_bank

xmc_class_bank_type xmc_nand_pccard_timinginit_type::class_bank

xmc nand/pccard bank

Definition at line 431 of file at32f435_437_xmc.h.

Referenced by nand_init(), xmc_nand_timing_config(), xmc_nand_timing_default_para_init(), and xmc_pccard_timing_default_para_init().

◆ mem_hiz_time

uint32_t xmc_nand_pccard_timinginit_type::mem_hiz_time

xmc nand/pccard memory databus high resistance time

Definition at line 435 of file at32f435_437_xmc.h.

Referenced by nand_init(), xmc_nand_timing_config(), xmc_nand_timing_default_para_init(), xmc_pccard_timing_config(), and xmc_pccard_timing_default_para_init().

◆ mem_hold_time

uint32_t xmc_nand_pccard_timinginit_type::mem_hold_time

xmc nand/pccard memory hold time

Definition at line 434 of file at32f435_437_xmc.h.

Referenced by nand_init(), xmc_nand_timing_config(), xmc_nand_timing_default_para_init(), xmc_pccard_timing_config(), and xmc_pccard_timing_default_para_init().

◆ mem_setup_time

uint32_t xmc_nand_pccard_timinginit_type::mem_setup_time

xmc nand/pccard memory setup time

Definition at line 432 of file at32f435_437_xmc.h.

Referenced by nand_init(), xmc_nand_timing_config(), xmc_nand_timing_default_para_init(), xmc_pccard_timing_config(), and xmc_pccard_timing_default_para_init().

◆ mem_waite_time

uint32_t xmc_nand_pccard_timinginit_type::mem_waite_time

xmc nand/pccard memory wait time

Definition at line 433 of file at32f435_437_xmc.h.

Referenced by nand_init(), xmc_nand_timing_config(), xmc_nand_timing_default_para_init(), xmc_pccard_timing_config(), and xmc_pccard_timing_default_para_init().

The documentation for this struct was generated from the following file:
  • at32f435_437_xmc.h


AT32F435/437 Firmwary Library: xmc_nand_init_type Struct Reference

Data Fields
xmc_nand_init_type Struct Reference
AT32F435_437_periph_driver » XMC » XMC_exported_types

xmc nand init structure definition More...

#include <at32f435_437_xmc.h>

Data Fields

xmc_class_bank_type nand_bank
xmc_nand_pccard_wait_type wait_enable
xmc_data_width_type bus_type
xmc_ecc_enable_type ecc_enable
xmc_ecc_pagesize_type ecc_pagesize
uint32_t | delay_time_cycle
uint32_t | delay_time_ar

Detailed Description

xmc nand init structure definition

Definition at line 442 of file at32f435_437_xmc.h.

Field Documentation

◆ bus_type

xmc_data_width_type xmc_nand_init_type::bus_type

xmc nand bus width

Definition at line 446 of file at32f435_437_xmc.h.

Referenced by nand_init(), xmc_nand_default_para_init(), and xmc_nand_init().

◆ delay_time_ar

uint32_t xmc_nand_init_type::delay_time_ar

xmc nand ale to re delay

Definition at line 450 of file at32f435_437_xmc.h.

Referenced by nand_init(), xmc_nand_default_para_init(), and xmc_nand_init().

◆ delay_time_cycle

uint32_t xmc_nand_init_type::delay_time_cycle

xmc nand cle to re delay

Definition at line 449 of file at32f435_437_xmc.h.

Referenced by nand_init(), xmc_nand_default_para_init(), and xmc_nand_init().

◆ ecc_enable

xmc_ecc_enable_type xmc_nand_init_type::ecc_enable

xmc nand ecc enable

Definition at line 447 of file at32f435_437_xmc.h.

Referenced by nand_init(), xmc_nand_default_para_init(), and xmc_nand_init().

◆ ecc_pagesize

xmc_ecc_pagesize_type xmc_nand_init_type::ecc_pagesize

xmc nand ecc page size

Definition at line 448 of file at32f435_437_xmc.h.

Referenced by nand_init(), xmc_nand_default_para_init(), and xmc_nand_init().

◆ nand_bank

xmc_class_bank_type xmc_nand_init_type::nand_bank

xmc nand bank

Definition at line 444 of file at32f435_437_xmc.h.

Referenced by nand_init(), xmc_nand_default_para_init(), and xmc_nand_init().

◆ wait_enable

xmc_nand_pccard_wait_type xmc_nand_init_type::wait_enable

xmc wait feature enable

Definition at line 445 of file at32f435_437_xmc.h.

Referenced by nand_init(), xmc_nand_default_para_init(), and xmc_nand_init().

The documentation for this struct was generated from the following file:
  • at32f435_437_xmc.h


AT32F435/437 Firmwary Library: xmc_pccard_init_type Struct Reference

Data Fields
xmc_pccard_init_type Struct Reference
AT32F435_437_periph_driver » XMC » XMC_exported_types

xmc pccard init structure definition More...

#include <at32f435_437_xmc.h>

Data Fields

xmc_nand_pccard_wait_type enable_wait
uint32_t | delay_time_cr
uint32_t | delay_time_ar

Detailed Description

xmc pccard init structure definition

Definition at line 457 of file at32f435_437_xmc.h.

Field Documentation

◆ delay_time_ar

uint32_t xmc_pccard_init_type::delay_time_ar

xmc pccard ale to re delay

Definition at line 461 of file at32f435_437_xmc.h.

Referenced by xmc_pccard_default_para_init(), and xmc_pccard_init().

◆ delay_time_cr

uint32_t xmc_pccard_init_type::delay_time_cr

xmc pccard cle to re delay

Definition at line 460 of file at32f435_437_xmc.h.

Referenced by xmc_pccard_default_para_init(), and xmc_pccard_init().

◆ enable_wait

xmc_nand_pccard_wait_type xmc_pccard_init_type::enable_wait

xmc pccard wait feature enable

Definition at line 459 of file at32f435_437_xmc.h.

Referenced by xmc_pccard_default_para_init(), and xmc_pccard_init().

The documentation for this struct was generated from the following file:
  • at32f435_437_xmc.h


AT32F435/437 Firmwary Library: xmc_sdram_init_type Struct Reference

Data Fields
xmc_sdram_init_type Struct Reference
AT32F435_437_periph_driver » XMC » XMC_exported_types

xmc sdram init structure definition More...

#include <at32f435_437_xmc.h>

Data Fields

xmc_sdram_bank_type sdram_bank
xmc_sdram_inbk_type internel_banks
xmc_sdram_clkdiv_type clkdiv
uint8_t | write_protection
uint8_t | burst_read
uint8_t | read_delay
xmc_sdram_column_type column_address
xmc_sdram_row_type row_address
xmc_sdram_cas_type cas
xmc_sdram_width_type width

Detailed Description

xmc sdram init structure definition

Definition at line 468 of file at32f435_437_xmc.h.

Field Documentation

◆ burst_read

uint8_t xmc_sdram_init_type::burst_read

xmc sdram burst read

Definition at line 474 of file at32f435_437_xmc.h.

Referenced by sdram_init(), xmc_sdram_default_para_init(), and xmc_sdram_init().

◆ cas

xmc_sdram_cas_type xmc_sdram_init_type::cas

xmc sdram cas

Definition at line 478 of file at32f435_437_xmc.h.

Referenced by sdram_init(), xmc_sdram_default_para_init(), and xmc_sdram_init().

◆ clkdiv

xmc_sdram_clkdiv_type xmc_sdram_init_type::clkdiv

xmc sdram clock div

Definition at line 472 of file at32f435_437_xmc.h.

Referenced by sdram_init(), xmc_sdram_default_para_init(), and xmc_sdram_init().

◆ column_address

xmc_sdram_column_type xmc_sdram_init_type::column_address

xmc sdram column address

Definition at line 476 of file at32f435_437_xmc.h.

Referenced by sdram_init(), xmc_sdram_default_para_init(), and xmc_sdram_init().

◆ internel_banks

xmc_sdram_inbk_type xmc_sdram_init_type::internel_banks

xmc sdram internal banks

Definition at line 471 of file at32f435_437_xmc.h.

Referenced by sdram_init(), xmc_sdram_default_para_init(), and xmc_sdram_init().

◆ read_delay

uint8_t xmc_sdram_init_type::read_delay

xmc sdram read delay

Definition at line 475 of file at32f435_437_xmc.h.

Referenced by sdram_init(), xmc_sdram_default_para_init(), and xmc_sdram_init().

◆ row_address

xmc_sdram_row_type xmc_sdram_init_type::row_address

xmc sdram row address

Definition at line 477 of file at32f435_437_xmc.h.

Referenced by sdram_init(), xmc_sdram_default_para_init(), and xmc_sdram_init().

◆ sdram_bank

xmc_sdram_bank_type xmc_sdram_init_type::sdram_bank

xmc sdram bank bype

Definition at line 470 of file at32f435_437_xmc.h.

Referenced by sdram_init(), xmc_sdram_default_para_init(), and xmc_sdram_init().

◆ width

xmc_sdram_width_type xmc_sdram_init_type::width

xmc sdram data width

Definition at line 479 of file at32f435_437_xmc.h.

Referenced by sdram_init(), xmc_sdram_default_para_init(), and xmc_sdram_init().

◆ write_protection

uint8_t xmc_sdram_init_type::write_protection

xmc sdram write protection

Definition at line 473 of file at32f435_437_xmc.h.

Referenced by sdram_init(), xmc_sdram_default_para_init(), and xmc_sdram_init().

The documentation for this struct was generated from the following file:
  • at32f435_437_xmc.h


AT32F435/437 Firmwary Library: xmc_sdram_timing_type Struct Reference

Data Fields
xmc_sdram_timing_type Struct Reference
AT32F435_437_periph_driver » XMC » XMC_exported_types

xmc sdram timing structure definition More...

#include <at32f435_437_xmc.h>

Data Fields

xmc_sdram_delay_type tmrd
xmc_sdram_delay_type txsr
xmc_sdram_delay_type tras
xmc_sdram_delay_type trc
xmc_sdram_delay_type twr
xmc_sdram_delay_type trp
xmc_sdram_delay_type trcd

Detailed Description

xmc sdram timing structure definition

Definition at line 486 of file at32f435_437_xmc.h.

Field Documentation

◆ tmrd

xmc_sdram_delay_type xmc_sdram_timing_type::tmrd

mode register program to active delay

Definition at line 488 of file at32f435_437_xmc.h.

Referenced by sdram_init(), xmc_sdram_default_para_init(), and xmc_sdram_init().

◆ tras

xmc_sdram_delay_type xmc_sdram_timing_type::tras

self refresh

Definition at line 490 of file at32f435_437_xmc.h.

Referenced by sdram_init(), xmc_sdram_default_para_init(), and xmc_sdram_init().

◆ trc

xmc_sdram_delay_type xmc_sdram_timing_type::trc

refresh to active delay

Definition at line 491 of file at32f435_437_xmc.h.

Referenced by sdram_init(), xmc_sdram_default_para_init(), and xmc_sdram_init().

◆ trcd

xmc_sdram_delay_type xmc_sdram_timing_type::trcd

row active to read/write delay

Definition at line 494 of file at32f435_437_xmc.h.

Referenced by sdram_init(), xmc_sdram_default_para_init(), and xmc_sdram_init().

◆ trp

xmc_sdram_delay_type xmc_sdram_timing_type::trp

precharge to active delay

Definition at line 493 of file at32f435_437_xmc.h.

Referenced by sdram_init(), xmc_sdram_default_para_init(), and xmc_sdram_init().

◆ twr

xmc_sdram_delay_type xmc_sdram_timing_type::twr

write recovery delay

Definition at line 492 of file at32f435_437_xmc.h.

Referenced by sdram_init(), xmc_sdram_default_para_init(), and xmc_sdram_init().

◆ txsr

xmc_sdram_delay_type xmc_sdram_timing_type::txsr

exit self-refresh to active delay

Definition at line 489 of file at32f435_437_xmc.h.

Referenced by sdram_init(), xmc_sdram_default_para_init(), and xmc_sdram_init().

The documentation for this struct was generated from the following file:
  • at32f435_437_xmc.h


AT32F435/437 Firmwary Library: xmc_sdram_cmd_type Struct Reference

Data Fields
xmc_sdram_cmd_type Struct Reference
AT32F435_437_periph_driver » XMC » XMC_exported_types

xmc sdram command structure definition More...

#include <at32f435_437_xmc.h>

Data Fields

xmc_command_type cmd
xmc_cmd_bank1_2_type cmd_banks
uint32_t | auto_refresh
uint32_t | data

Detailed Description

xmc sdram command structure definition

Definition at line 501 of file at32f435_437_xmc.h.

Field Documentation

◆ auto_refresh

uint32_t xmc_sdram_cmd_type::auto_refresh

auto refresh times

Definition at line 505 of file at32f435_437_xmc.h.

Referenced by sdram_init_sequence(), and xmc_sdram_cmd().

◆ cmd

xmc_command_type xmc_sdram_cmd_type::cmd

sdram command

Definition at line 503 of file at32f435_437_xmc.h.

Referenced by sdram_init_sequence(), and xmc_sdram_cmd().

◆ cmd_banks

xmc_cmd_bank1_2_type xmc_sdram_cmd_type::cmd_banks

which bank send command

Definition at line 504 of file at32f435_437_xmc.h.

Referenced by sdram_init_sequence(), and xmc_sdram_cmd().

◆ data

uint32_t xmc_sdram_cmd_type::data

mode register data

Definition at line 506 of file at32f435_437_xmc.h.

Referenced by sdram_init_sequence(), and xmc_sdram_cmd().

The documentation for this struct was generated from the following file:
  • at32f435_437_xmc.h


AT32F435/437 Firmwary Library: xmc_bank1_ctrl_tmg_reg_type Struct Reference

Data Fields
xmc_bank1_ctrl_tmg_reg_type Struct Reference
AT32F435_437_periph_driver » XMC » XMC_exported_types

#include <at32f435_437_xmc.h>

Data Fields

union {
__IO uint32_t bk1ctrl
struct {
__IO uint32_t en: 1
__IO uint32_t admuxen: 1
__IO uint32_t dev: 2
__IO uint32_t extmdbw: 2
__IO uint32_t noren: 1
__IO uint32_t reserved1: 1
__IO uint32_t syncben: 1
__IO uint32_t nwpol: 1
__IO uint32_t wrapen: 1
__IO uint32_t nwtcfg: 1
__IO uint32_t wen: 1
__IO uint32_t nwsen: 1
__IO uint32_t rwtd: 1
__IO uint32_t nwasen: 1
__IO uint32_t crpgs: 3
__IO uint32_t mwmc: 1
__IO uint32_t reserved2: 12
} bk1ctrl_bit
};
xmc bank1 bk1ctrl register, offset:0x00+0x08*(x-1) x= 1...4 More...
union {
__IO uint32_t bk1tmg
struct {
__IO uint32_t addrst: 4
__IO uint32_t addrht: 4
__IO uint32_t dtst: 8
__IO uint32_t buslat: 4
__IO uint32_t clkpsc: 4
__IO uint32_t dtlat: 4
__IO uint32_t asyncm: 2
__IO uint32_t reserved1: 2
} bk1tmg_bit
};
xmc bank1 bk1tmg register, offset:0x04+0x08*(x-1) x= 1...4 More...

Detailed Description

Definition at line 509 of file at32f435_437_xmc.h.

Field Documentation

◆

union { ... } xmc_bank1_ctrl_tmg_reg_type::@1306

xmc bank1 bk1ctrl register, offset:0x00+0x08*(x-1) x= 1...4

◆

union { ... } xmc_bank1_ctrl_tmg_reg_type::@1308

xmc bank1 bk1tmg register, offset:0x04+0x08*(x-1) x= 1...4

◆ addrht

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::addrht

Definition at line 548 of file at32f435_437_xmc.h.

◆ addrst

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::addrst

Definition at line 547 of file at32f435_437_xmc.h.

◆ admuxen

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::admuxen

Definition at line 520 of file at32f435_437_xmc.h.

◆ asyncm

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::asyncm

Definition at line 553 of file at32f435_437_xmc.h.

◆ bk1ctrl

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::bk1ctrl

Definition at line 516 of file at32f435_437_xmc.h.

◆

struct { ... } xmc_bank1_ctrl_tmg_reg_type::bk1ctrl_bit

◆ bk1tmg

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::bk1tmg

Definition at line 544 of file at32f435_437_xmc.h.

◆

struct { ... } xmc_bank1_ctrl_tmg_reg_type::bk1tmg_bit

◆ buslat

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::buslat

Definition at line 550 of file at32f435_437_xmc.h.

◆ clkpsc

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::clkpsc

Definition at line 551 of file at32f435_437_xmc.h.

◆ crpgs

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::crpgs

Definition at line 533 of file at32f435_437_xmc.h.

◆ dev

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::dev

Definition at line 521 of file at32f435_437_xmc.h.

◆ dtlat

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::dtlat

Definition at line 552 of file at32f435_437_xmc.h.

◆ dtst

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::dtst

Definition at line 549 of file at32f435_437_xmc.h.

◆ en

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::en

Definition at line 519 of file at32f435_437_xmc.h.

◆ extmdbw

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::extmdbw

Definition at line 522 of file at32f435_437_xmc.h.

◆ mwmc

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::mwmc

Definition at line 534 of file at32f435_437_xmc.h.

◆ noren

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::noren

Definition at line 523 of file at32f435_437_xmc.h.

◆ nwasen

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::nwasen

Definition at line 532 of file at32f435_437_xmc.h.

◆ nwpol

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::nwpol

Definition at line 526 of file at32f435_437_xmc.h.

◆ nwsen

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::nwsen

Definition at line 530 of file at32f435_437_xmc.h.

◆ nwtcfg

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::nwtcfg

Definition at line 528 of file at32f435_437_xmc.h.

◆ reserved1

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::reserved1

Definition at line 524 of file at32f435_437_xmc.h.

◆ reserved2

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::reserved2

Definition at line 535 of file at32f435_437_xmc.h.

◆ rwtd

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::rwtd

Definition at line 531 of file at32f435_437_xmc.h.

◆ syncben

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::syncben

Definition at line 525 of file at32f435_437_xmc.h.

◆ wen

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::wen

Definition at line 529 of file at32f435_437_xmc.h.

◆ wrapen

__IO uint32_t xmc_bank1_ctrl_tmg_reg_type::wrapen

Definition at line 527 of file at32f435_437_xmc.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_xmc.h


AT32F435/437 Firmwary Library: xmc_bank1_tmgwr_reg_type Struct Reference

Data Fields
xmc_bank1_tmgwr_reg_type Struct Reference
AT32F435_437_periph_driver » XMC » XMC_exported_types

#include <at32f435_437_xmc.h>

Data Fields

union {
__IO uint32_t bk1tmgwr
struct {
__IO uint32_t addrst: 4
__IO uint32_t addrht: 4
__IO uint32_t dtst: 8
__IO uint32_t buslat: 4
__IO uint32_t reserved1: 8
__IO uint32_t asyncm: 2
__IO uint32_t reserved2: 2
} bk1tmgwr_bit
};
xmc bank1 bk1tmgwr register, offset:0x104+0x08*(x-1) x= 1...4 More...

Detailed Description

Definition at line 560 of file at32f435_437_xmc.h.

Field Documentation

◆

union { ... } xmc_bank1_tmgwr_reg_type::@1312

xmc bank1 bk1tmgwr register, offset:0x104+0x08*(x-1) x= 1...4

◆ addrht

__IO uint32_t xmc_bank1_tmgwr_reg_type::addrht

Definition at line 571 of file at32f435_437_xmc.h.

◆ addrst

__IO uint32_t xmc_bank1_tmgwr_reg_type::addrst

Definition at line 570 of file at32f435_437_xmc.h.

◆ asyncm

__IO uint32_t xmc_bank1_tmgwr_reg_type::asyncm

Definition at line 575 of file at32f435_437_xmc.h.

◆ bk1tmgwr

__IO uint32_t xmc_bank1_tmgwr_reg_type::bk1tmgwr

Definition at line 567 of file at32f435_437_xmc.h.

◆

struct { ... } xmc_bank1_tmgwr_reg_type::bk1tmgwr_bit

◆ buslat

__IO uint32_t xmc_bank1_tmgwr_reg_type::buslat

Definition at line 573 of file at32f435_437_xmc.h.

◆ dtst

__IO uint32_t xmc_bank1_tmgwr_reg_type::dtst

Definition at line 572 of file at32f435_437_xmc.h.

◆ reserved1

__IO uint32_t xmc_bank1_tmgwr_reg_type::reserved1

xmc bank1 reserved register

Definition at line 574 of file at32f435_437_xmc.h.

◆ reserved2

__IO uint32_t xmc_bank1_tmgwr_reg_type::reserved2

Definition at line 576 of file at32f435_437_xmc.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_xmc.h


AT32F435/437 Firmwary Library: xmc_bank1_type Struct Reference

Data Fields
xmc_bank1_type Struct Reference
AT32F435_437_periph_driver » XMC » XMC_exported_types

xmc bank1 registers More...

#include <at32f435_437_xmc.h>

Data Fields

xmc_bank1_ctrl_tmg_reg_type | ctrl_tmg_group [4]
xmc bank1 ctrl and tmg register, offset:0x00~0x1C More...
__IO uint32_t | reserved1 [57]
xmc bank1 reserved register, offset:0x20~0x100 More...
xmc_bank1_tmgwr_reg_type | tmgwr_group [4]
xmc bank1 tmgwr register, offset:0x104~0x11C More...
__IO uint32_t | reserved2 [63]
xmc bank1 reserved register, offset:0x120~0x21C More...
union {
__IO uint32_t ext [4]
struct {
__IO uint32_t buslatw2w: 8
__IO uint32_t buslatr2r: 8
__IO uint32_t reserved1: 16
} ext_bit [4]
};
xmc bank1 ext register, offset:0x220~0x22C More...

Detailed Description

xmc bank1 registers

Definition at line 590 of file at32f435_437_xmc.h.

Field Documentation

◆

union { ... } xmc_bank1_type::@1315

xmc bank1 ext register, offset:0x220~0x22C

◆ buslatr2r

__IO uint32_t xmc_bank1_type::buslatr2r

Definition at line 621 of file at32f435_437_xmc.h.

◆ buslatw2w

__IO uint32_t xmc_bank1_type::buslatw2w

Definition at line 620 of file at32f435_437_xmc.h.

◆ ctrl_tmg_group

xmc_bank1_ctrl_tmg_reg_type xmc_bank1_type::ctrl_tmg_group[4]

xmc bank1 ctrl and tmg register, offset:0x00~0x1C

Definition at line 595 of file at32f435_437_xmc.h.

◆ ext

__IO uint32_t xmc_bank1_type::ext[4]

Definition at line 617 of file at32f435_437_xmc.h.

◆

struct { ... } xmc_bank1_type::ext_bit[4]

◆ reserved1

__IO uint32_t xmc_bank1_type::reserved1

xmc bank1 reserved register, offset:0x20~0x100

Definition at line 600 of file at32f435_437_xmc.h.

◆ reserved2

__IO uint32_t xmc_bank1_type::reserved2[63]

xmc bank1 reserved register, offset:0x120~0x21C

Definition at line 610 of file at32f435_437_xmc.h.

◆ tmgwr_group

xmc_bank1_tmgwr_reg_type xmc_bank1_type::tmgwr_group[4]

xmc bank1 tmgwr register, offset:0x104~0x11C

Definition at line 605 of file at32f435_437_xmc.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_xmc.h


AT32F435/437 Firmwary Library: xmc_bank2_type Struct Reference

Data Fields
xmc_bank2_type Struct Reference
AT32F435_437_periph_driver » XMC » XMC_exported_types

xmc bank2 registers More...

#include <at32f435_437_xmc.h>

Data Fields

union {
__IO uint32_t bk2ctrl
struct {
__IO uint32_t reserved1: 1
__IO uint32_t nwen: 1
__IO uint32_t en: 1
__IO uint32_t dev: 1
__IO uint32_t extmdbw: 2
__IO uint32_t eccen: 1
__IO uint32_t reserved2: 2
__IO uint32_t tcr: 4
__IO uint32_t tar: 4
__IO uint32_t eccpgs: 3
__IO uint32_t reserved3: 12
} bk2ctrl_bit
};
xmc bk2ctrl register, offset:0x60 More...
union {
__IO uint32_t bk2is
struct {
__IO uint32_t res: 1
__IO uint32_t hls: 1
__IO uint32_t fes: 1
__IO uint32_t reien: 1
__IO uint32_t hlien: 1
__IO uint32_t feien: 1
__IO uint32_t fifoe: 1
__IO uint32_t reserved1: 25
} bk2is_bit
};
xmc bk2is register, offset:0x64 More...
union {
__IO uint32_t bk2tmgmem
struct {
__IO uint32_t cmst: 8
__IO uint32_t cmwt: 8
__IO uint32_t cmht: 8
__IO uint32_t cmdhizt: 8
} bk2tmgmem_bit
};
xmc bk2tmgmem register, offset:0x68 More...
union {
__IO uint32_t bk2tmgatt
struct {
__IO uint32_t amst: 8
__IO uint32_t amwt: 8
__IO uint32_t amht: 8
__IO uint32_t amdhizt: 8
} bk2tmgatt_bit
};
xmc bk2tmgatt register, offset:0x6C More...
union {
__IO uint32_t bk2ecc
struct {
__IO uint32_t ecc: 32
} bk2ecc_bit
};
xmc bk2ecc register, offset:0x74 More...

Detailed Description

xmc bank2 registers

Definition at line 631 of file at32f435_437_xmc.h.

Field Documentation

◆

union { ... } xmc_bank2_type::@1318

xmc bk2ctrl register, offset:0x60

◆

union { ... } xmc_bank2_type::@1320

xmc bk2is register, offset:0x64

◆

union { ... } xmc_bank2_type::@1322

xmc bk2tmgmem register, offset:0x68

◆

union { ... } xmc_bank2_type::@1324

xmc bk2tmgatt register, offset:0x6C

◆

union { ... } xmc_bank2_type::@1326

xmc bk2ecc register, offset:0x74

◆ amdhizt

__IO uint32_t xmc_bank2_type::amdhizt

Definition at line 700 of file at32f435_437_xmc.h.

◆ amht

__IO uint32_t xmc_bank2_type::amht

Definition at line 699 of file at32f435_437_xmc.h.

◆ amst

__IO uint32_t xmc_bank2_type::amst

Definition at line 697 of file at32f435_437_xmc.h.

◆ amwt

__IO uint32_t xmc_bank2_type::amwt

Definition at line 698 of file at32f435_437_xmc.h.

◆ bk2ctrl

__IO uint32_t xmc_bank2_type::bk2ctrl

Definition at line 638 of file at32f435_437_xmc.h.

◆

struct { ... } xmc_bank2_type::bk2ctrl_bit

◆ bk2ecc

__IO uint32_t xmc_bank2_type::bk2ecc

Definition at line 714 of file at32f435_437_xmc.h.

◆

struct { ... } xmc_bank2_type::bk2ecc_bit

◆ bk2is

__IO uint32_t xmc_bank2_type::bk2is

Definition at line 660 of file at32f435_437_xmc.h.

◆

struct { ... } xmc_bank2_type::bk2is_bit

◆ bk2tmgatt

__IO uint32_t xmc_bank2_type::bk2tmgatt

Definition at line 694 of file at32f435_437_xmc.h.

◆

struct { ... } xmc_bank2_type::bk2tmgatt_bit

◆ bk2tmgmem

__IO uint32_t xmc_bank2_type::bk2tmgmem

Definition at line 679 of file at32f435_437_xmc.h.

◆

struct { ... } xmc_bank2_type::bk2tmgmem_bit

◆ cmdhizt

__IO uint32_t xmc_bank2_type::cmdhizt

Definition at line 685 of file at32f435_437_xmc.h.

◆ cmht

__IO uint32_t xmc_bank2_type::cmht

Definition at line 684 of file at32f435_437_xmc.h.

◆ cmst

__IO uint32_t xmc_bank2_type::cmst

Definition at line 682 of file at32f435_437_xmc.h.

◆ cmwt

__IO uint32_t xmc_bank2_type::cmwt

Definition at line 683 of file at32f435_437_xmc.h.

◆ dev

__IO uint32_t xmc_bank2_type::dev

Definition at line 644 of file at32f435_437_xmc.h.

◆ ecc

__IO uint32_t xmc_bank2_type::ecc

Definition at line 717 of file at32f435_437_xmc.h.

◆ eccen

__IO uint32_t xmc_bank2_type::eccen

Definition at line 646 of file at32f435_437_xmc.h.

◆ eccpgs

__IO uint32_t xmc_bank2_type::eccpgs

Definition at line 650 of file at32f435_437_xmc.h.

◆ en

__IO uint32_t xmc_bank2_type::en

Definition at line 643 of file at32f435_437_xmc.h.

◆ extmdbw

__IO uint32_t xmc_bank2_type::extmdbw

Definition at line 645 of file at32f435_437_xmc.h.

◆ feien

__IO uint32_t xmc_bank2_type::feien

Definition at line 668 of file at32f435_437_xmc.h.

◆ fes

__IO uint32_t xmc_bank2_type::fes

Definition at line 665 of file at32f435_437_xmc.h.

◆ fifoe

__IO uint32_t xmc_bank2_type::fifoe

Definition at line 669 of file at32f435_437_xmc.h.

◆ hlien

__IO uint32_t xmc_bank2_type::hlien

Definition at line 667 of file at32f435_437_xmc.h.

◆ hls

__IO uint32_t xmc_bank2_type::hls

Definition at line 664 of file at32f435_437_xmc.h.

◆ nwen

__IO uint32_t xmc_bank2_type::nwen

Definition at line 642 of file at32f435_437_xmc.h.

◆ reien

__IO uint32_t xmc_bank2_type::reien

Definition at line 666 of file at32f435_437_xmc.h.

◆ res

__IO uint32_t xmc_bank2_type::res

Definition at line 663 of file at32f435_437_xmc.h.

◆ reserved1

__IO uint32_t xmc_bank2_type::reserved1

xmc reserved register, offset:0x70

Definition at line 641 of file at32f435_437_xmc.h.

◆ reserved2

__IO uint32_t xmc_bank2_type::reserved2

Definition at line 647 of file at32f435_437_xmc.h.

◆ reserved3

__IO uint32_t xmc_bank2_type::reserved3

Definition at line 651 of file at32f435_437_xmc.h.

◆ tar

__IO uint32_t xmc_bank2_type::tar

Definition at line 649 of file at32f435_437_xmc.h.

◆ tcr

__IO uint32_t xmc_bank2_type::tcr

Definition at line 648 of file at32f435_437_xmc.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_xmc.h


AT32F435/437 Firmwary Library: xmc_bank3_type Struct Reference

Data Fields
xmc_bank3_type Struct Reference
AT32F435_437_periph_driver » XMC » XMC_exported_types

xmc bank3 registers More...

#include <at32f435_437_xmc.h>

Data Fields

union {
__IO uint32_t bk3ctrl
struct {
__IO uint32_t reserved1: 1
__IO uint32_t nwen: 1
__IO uint32_t en: 1
__IO uint32_t dev: 1
__IO uint32_t extmdbw: 2
__IO uint32_t eccen: 1
__IO uint32_t reserved2: 2
__IO uint32_t tcr: 4
__IO uint32_t tar: 4
__IO uint32_t eccpgs: 3
__IO uint32_t reserved3: 12
} bk3ctrl_bit
};
xmc bk3ctrl register, offset:0x80 More...
union {
__IO uint32_t bk3is
struct {
__IO uint32_t res: 1
__IO uint32_t hls: 1
__IO uint32_t fes: 1
__IO uint32_t reien: 1
__IO uint32_t hlien: 1
__IO uint32_t feien: 1
__IO uint32_t fifoe: 1
__IO uint32_t reserved1: 25
} bk3is_bit
};
xmc bk3is register, offset:0x84 More...
union {
__IO uint32_t bk3tmgmem
struct {
__IO uint32_t cmst: 8
__IO uint32_t cmwt: 8
__IO uint32_t cmht: 8
__IO uint32_t cmdhizt: 8
} bk3tmgmem_bit
};
xmc bk3tmgmem register, offset:0x88 More...
union {
__IO uint32_t bk3tmgatt
struct {
__IO uint32_t amst: 8
__IO uint32_t amwt: 8
__IO uint32_t amht: 8
__IO uint32_t amdhizt: 8
} bk3tmgatt_bit
};
xmc bk3tmgatt register, offset:0x8C More...
union {
__IO uint32_t bk3ecc
struct {
__IO uint32_t ecc: 32
} bk3ecc_bit
};
xmc bk3ecc register, offset:0x94 More...

Detailed Description

xmc bank3 registers

Definition at line 726 of file at32f435_437_xmc.h.

Field Documentation

◆

union { ... } xmc_bank3_type::@1333

xmc bk3ctrl register, offset:0x80

◆

union { ... } xmc_bank3_type::@1335

xmc bk3is register, offset:0x84

◆

union { ... } xmc_bank3_type::@1337

xmc bk3tmgmem register, offset:0x88

◆

union { ... } xmc_bank3_type::@1339

xmc bk3tmgatt register, offset:0x8C

◆

union { ... } xmc_bank3_type::@1341

xmc bk3ecc register, offset:0x94

◆ amdhizt

__IO uint32_t xmc_bank3_type::amdhizt

Definition at line 795 of file at32f435_437_xmc.h.

◆ amht

__IO uint32_t xmc_bank3_type::amht

Definition at line 794 of file at32f435_437_xmc.h.

◆ amst

__IO uint32_t xmc_bank3_type::amst

Definition at line 792 of file at32f435_437_xmc.h.

◆ amwt

__IO uint32_t xmc_bank3_type::amwt

Definition at line 793 of file at32f435_437_xmc.h.

◆ bk3ctrl

__IO uint32_t xmc_bank3_type::bk3ctrl

Definition at line 733 of file at32f435_437_xmc.h.

◆

struct { ... } xmc_bank3_type::bk3ctrl_bit

◆ bk3ecc

__IO uint32_t xmc_bank3_type::bk3ecc

Definition at line 809 of file at32f435_437_xmc.h.

◆

struct { ... } xmc_bank3_type::bk3ecc_bit

◆ bk3is

__IO uint32_t xmc_bank3_type::bk3is

Definition at line 755 of file at32f435_437_xmc.h.

◆

struct { ... } xmc_bank3_type::bk3is_bit

◆ bk3tmgatt

__IO uint32_t xmc_bank3_type::bk3tmgatt

Definition at line 789 of file at32f435_437_xmc.h.

◆

struct { ... } xmc_bank3_type::bk3tmgatt_bit

◆ bk3tmgmem

__IO uint32_t xmc_bank3_type::bk3tmgmem

Definition at line 774 of file at32f435_437_xmc.h.

◆

struct { ... } xmc_bank3_type::bk3tmgmem_bit

◆ cmdhizt

__IO uint32_t xmc_bank3_type::cmdhizt

Definition at line 780 of file at32f435_437_xmc.h.

◆ cmht

__IO uint32_t xmc_bank3_type::cmht

Definition at line 779 of file at32f435_437_xmc.h.

◆ cmst

__IO uint32_t xmc_bank3_type::cmst

Definition at line 777 of file at32f435_437_xmc.h.

◆ cmwt

__IO uint32_t xmc_bank3_type::cmwt

Definition at line 778 of file at32f435_437_xmc.h.

◆ dev

__IO uint32_t xmc_bank3_type::dev

Definition at line 739 of file at32f435_437_xmc.h.

◆ ecc

__IO uint32_t xmc_bank3_type::ecc

Definition at line 812 of file at32f435_437_xmc.h.

◆ eccen

__IO uint32_t xmc_bank3_type::eccen

Definition at line 741 of file at32f435_437_xmc.h.

◆ eccpgs

__IO uint32_t xmc_bank3_type::eccpgs

Definition at line 745 of file at32f435_437_xmc.h.

◆ en

__IO uint32_t xmc_bank3_type::en

Definition at line 738 of file at32f435_437_xmc.h.

◆ extmdbw

__IO uint32_t xmc_bank3_type::extmdbw

Definition at line 740 of file at32f435_437_xmc.h.

◆ feien

__IO uint32_t xmc_bank3_type::feien

Definition at line 763 of file at32f435_437_xmc.h.

◆ fes

__IO uint32_t xmc_bank3_type::fes

Definition at line 760 of file at32f435_437_xmc.h.

◆ fifoe

__IO uint32_t xmc_bank3_type::fifoe

Definition at line 764 of file at32f435_437_xmc.h.

◆ hlien

__IO uint32_t xmc_bank3_type::hlien

Definition at line 762 of file at32f435_437_xmc.h.

◆ hls

__IO uint32_t xmc_bank3_type::hls

Definition at line 759 of file at32f435_437_xmc.h.

◆ nwen

__IO uint32_t xmc_bank3_type::nwen

Definition at line 737 of file at32f435_437_xmc.h.

◆ reien

__IO uint32_t xmc_bank3_type::reien

Definition at line 761 of file at32f435_437_xmc.h.

◆ res

__IO uint32_t xmc_bank3_type::res

Definition at line 758 of file at32f435_437_xmc.h.

◆ reserved1

__IO uint32_t xmc_bank3_type::reserved1

xmc reserved register, offset:0x90

Definition at line 736 of file at32f435_437_xmc.h.

◆ reserved2

__IO uint32_t xmc_bank3_type::reserved2

Definition at line 742 of file at32f435_437_xmc.h.

◆ reserved3

__IO uint32_t xmc_bank3_type::reserved3

Definition at line 746 of file at32f435_437_xmc.h.

◆ tar

__IO uint32_t xmc_bank3_type::tar

Definition at line 744 of file at32f435_437_xmc.h.

◆ tcr

__IO uint32_t xmc_bank3_type::tcr

Definition at line 743 of file at32f435_437_xmc.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_xmc.h


AT32F435/437 Firmwary Library: xmc_bank4_type Struct Reference

Data Fields
xmc_bank4_type Struct Reference
AT32F435_437_periph_driver » XMC » XMC_exported_types

xmc bank4 registers More...

#include <at32f435_437_xmc.h>

Data Fields

union {
__IO uint32_t bk4ctrl
struct {
__IO uint32_t reserved1: 1
__IO uint32_t nwen: 1
__IO uint32_t en: 1
__IO uint32_t dev: 1
__IO uint32_t extmdbw: 2
__IO uint32_t eccen: 1
__IO uint32_t reserved2: 2
__IO uint32_t tcr: 4
__IO uint32_t tar: 4
__IO uint32_t eccpgs: 3
__IO uint32_t reserved3: 12
} bk4ctrl_bit
};
xmc bk4ctrl register, offset:0xA0 More...
union {
__IO uint32_t bk4is
struct {
__IO uint32_t res: 1
__IO uint32_t hls: 1
__IO uint32_t fes: 1
__IO uint32_t reien: 1
__IO uint32_t hlien: 1
__IO uint32_t feien: 1
__IO uint32_t fifoe: 1
__IO uint32_t reserved1: 25
} bk4is_bit
};
xmc bk4is register, offset:0xA4 More...
union {
__IO uint32_t bk4tmgmem
struct {
__IO uint32_t cmst: 8
__IO uint32_t cmwt: 8
__IO uint32_t cmht: 8
__IO uint32_t cmdhizt: 8
} bk4tmgmem_bit
};
xmc bk4tmgmem register, offset:0xA8 More...
union {
__IO uint32_t bk4tmgatt
struct {
__IO uint32_t amst: 8
__IO uint32_t amwt: 8
__IO uint32_t amht: 8
__IO uint32_t amdhizt: 8
} bk4tmgatt_bit
};
xmc bk4tmgatt register, offset:0xAC More...
union {
__IO uint32_t bk4tmgio
struct {
__IO uint32_t iost: 8
__IO uint32_t iowt: 8
__IO uint32_t ioht: 8
__IO uint32_t iohizt: 8
} bk4tmgio_bit
};
xmc bk4tmgio register, offset:0xB0 More...

Detailed Description

xmc bank4 registers

Definition at line 820 of file at32f435_437_xmc.h.

Field Documentation

◆

union { ... } xmc_bank4_type::@1348

xmc bk4ctrl register, offset:0xA0

◆

union { ... } xmc_bank4_type::@1350

xmc bk4is register, offset:0xA4

◆

union { ... } xmc_bank4_type::@1352

xmc bk4tmgmem register, offset:0xA8

◆

union { ... } xmc_bank4_type::@1354

xmc bk4tmgatt register, offset:0xAC

◆

union { ... } xmc_bank4_type::@1356

xmc bk4tmgio register, offset:0xB0

◆ amdhizt

__IO uint32_t xmc_bank4_type::amdhizt

Definition at line 890 of file at32f435_437_xmc.h.

◆ amht

__IO uint32_t xmc_bank4_type::amht

Definition at line 889 of file at32f435_437_xmc.h.

◆ amst

__IO uint32_t xmc_bank4_type::amst

Definition at line 887 of file at32f435_437_xmc.h.

◆ amwt

__IO uint32_t xmc_bank4_type::amwt

Definition at line 888 of file at32f435_437_xmc.h.

◆ bk4ctrl

__IO uint32_t xmc_bank4_type::bk4ctrl

Definition at line 828 of file at32f435_437_xmc.h.

◆

struct { ... } xmc_bank4_type::bk4ctrl_bit

◆ bk4is

__IO uint32_t xmc_bank4_type::bk4is

Definition at line 850 of file at32f435_437_xmc.h.

◆

struct { ... } xmc_bank4_type::bk4is_bit

◆ bk4tmgatt

__IO uint32_t xmc_bank4_type::bk4tmgatt

Definition at line 884 of file at32f435_437_xmc.h.

◆

struct { ... } xmc_bank4_type::bk4tmgatt_bit

◆ bk4tmgio

__IO uint32_t xmc_bank4_type::bk4tmgio

Definition at line 899 of file at32f435_437_xmc.h.

◆

struct { ... } xmc_bank4_type::bk4tmgio_bit

◆ bk4tmgmem

__IO uint32_t xmc_bank4_type::bk4tmgmem

Definition at line 869 of file at32f435_437_xmc.h.

◆

struct { ... } xmc_bank4_type::bk4tmgmem_bit

◆ cmdhizt

__IO uint32_t xmc_bank4_type::cmdhizt

Definition at line 875 of file at32f435_437_xmc.h.

◆ cmht

__IO uint32_t xmc_bank4_type::cmht

Definition at line 874 of file at32f435_437_xmc.h.

◆ cmst

__IO uint32_t xmc_bank4_type::cmst

Definition at line 872 of file at32f435_437_xmc.h.

◆ cmwt

__IO uint32_t xmc_bank4_type::cmwt

Definition at line 873 of file at32f435_437_xmc.h.

◆ dev

__IO uint32_t xmc_bank4_type::dev

Definition at line 834 of file at32f435_437_xmc.h.

◆ eccen

__IO uint32_t xmc_bank4_type::eccen

Definition at line 836 of file at32f435_437_xmc.h.

◆ eccpgs

__IO uint32_t xmc_bank4_type::eccpgs

Definition at line 840 of file at32f435_437_xmc.h.

◆ en

__IO uint32_t xmc_bank4_type::en

Definition at line 833 of file at32f435_437_xmc.h.

◆ extmdbw

__IO uint32_t xmc_bank4_type::extmdbw

Definition at line 835 of file at32f435_437_xmc.h.

◆ feien

__IO uint32_t xmc_bank4_type::feien

Definition at line 858 of file at32f435_437_xmc.h.

◆ fes

__IO uint32_t xmc_bank4_type::fes

Definition at line 855 of file at32f435_437_xmc.h.

◆ fifoe

__IO uint32_t xmc_bank4_type::fifoe

Definition at line 859 of file at32f435_437_xmc.h.

◆ hlien

__IO uint32_t xmc_bank4_type::hlien

Definition at line 857 of file at32f435_437_xmc.h.

◆ hls

__IO uint32_t xmc_bank4_type::hls

Definition at line 854 of file at32f435_437_xmc.h.

◆ iohizt

__IO uint32_t xmc_bank4_type::iohizt

Definition at line 905 of file at32f435_437_xmc.h.

◆ ioht

__IO uint32_t xmc_bank4_type::ioht

Definition at line 904 of file at32f435_437_xmc.h.

◆ iost

__IO uint32_t xmc_bank4_type::iost

Definition at line 902 of file at32f435_437_xmc.h.

◆ iowt

__IO uint32_t xmc_bank4_type::iowt

Definition at line 903 of file at32f435_437_xmc.h.

◆ nwen

__IO uint32_t xmc_bank4_type::nwen

Definition at line 832 of file at32f435_437_xmc.h.

◆ reien

__IO uint32_t xmc_bank4_type::reien

Definition at line 856 of file at32f435_437_xmc.h.

◆ res

__IO uint32_t xmc_bank4_type::res

Definition at line 853 of file at32f435_437_xmc.h.

◆ reserved1

__IO uint32_t xmc_bank4_type::reserved1

Definition at line 831 of file at32f435_437_xmc.h.

◆ reserved2

__IO uint32_t xmc_bank4_type::reserved2

Definition at line 837 of file at32f435_437_xmc.h.

◆ reserved3

__IO uint32_t xmc_bank4_type::reserved3

Definition at line 841 of file at32f435_437_xmc.h.

◆ tar

__IO uint32_t xmc_bank4_type::tar

Definition at line 839 of file at32f435_437_xmc.h.

◆ tcr

__IO uint32_t xmc_bank4_type::tcr

Definition at line 838 of file at32f435_437_xmc.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_xmc.h


AT32F435/437 Firmwary Library: xmc_sdram_type Struct Reference

Data Fields
xmc_sdram_type Struct Reference
AT32F435_437_periph_driver » XMC » XMC_exported_types

xmc sdram type More...

#include <at32f435_437_xmc.h>

Data Fields

union {
__IO uint32_t ctrl [2]
struct {
__IO uint32_t ca: 2
__IO uint32_t ra: 2
__IO uint32_t db: 2
__IO uint32_t inbk: 1
__IO uint32_t cas: 2
__IO uint32_t wrp: 1
__IO uint32_t clkdiv: 2
__IO uint32_t bstr: 1
__IO uint32_t rd: 2
__IO uint32_t reserved1: 17
} ctrl_bit [2]
};
xmc sdram ctrl register, offset:0x140~0x144 More...
union {
__IO uint32_t tm [2]
struct {
__IO uint32_t tmrd: 4
__IO uint32_t txsr: 4
__IO uint32_t tras: 4
__IO uint32_t trc: 4
__IO uint32_t twr: 4
__IO uint32_t trp: 4
__IO uint32_t trcd: 4
__IO uint32_t reserved1: 4
} tm_bit [2]
};
xmc sdram tm register, offset:0x148~0x14C More...
union {
__IO uint32_t cmd
struct {
__IO uint32_t cmd: 3
__IO uint32_t bk2: 1
__IO uint32_t bk1: 1
__IO uint32_t art: 4
__IO uint32_t mrd: 13
__IO uint32_t reserved1: 10
} cmd_bit
};
xmc sdram cmd register, offset:0x150 More...
union {
__IO uint32_t rcnt
struct {
__IO uint32_t errc: 1
__IO uint32_t rc: 13
__IO uint32_t erien: 1
__IO uint32_t reserved1: 17
} rcnt_bit
};
xmc sdram rcnt register, offset:0x154 More...
union {
__IO uint32_t sts
struct {
__IO uint32_t err: 1
__IO uint32_t bk1sts: 2
__IO uint32_t bk2sts: 2
__IO uint32_t busy: 1
__IO uint32_t reserved1: 26
} sts_bit
};
xmc sdram sts register, offset:0x158 More...

Detailed Description

xmc sdram type

Definition at line 913 of file at32f435_437_xmc.h.

Field Documentation

◆

union { ... } xmc_sdram_type::@1363

xmc sdram ctrl register, offset:0x140~0x144

◆

union { ... } xmc_sdram_type::@1365

xmc sdram tm register, offset:0x148~0x14C

◆

union { ... } xmc_sdram_type::@1367

xmc sdram cmd register, offset:0x150

◆

union { ... } xmc_sdram_type::@1369

xmc sdram rcnt register, offset:0x154

◆

union { ... } xmc_sdram_type::@1371

xmc sdram sts register, offset:0x158

◆ art

__IO uint32_t xmc_sdram_type::art

Definition at line 967 of file at32f435_437_xmc.h.

◆ bk1

__IO uint32_t xmc_sdram_type::bk1

Definition at line 966 of file at32f435_437_xmc.h.

◆ bk1sts

__IO uint32_t xmc_sdram_type::bk1sts

Definition at line 997 of file at32f435_437_xmc.h.

◆ bk2

__IO uint32_t xmc_sdram_type::bk2

Definition at line 965 of file at32f435_437_xmc.h.

◆ bk2sts

__IO uint32_t xmc_sdram_type::bk2sts

Definition at line 998 of file at32f435_437_xmc.h.

◆ bstr

__IO uint32_t xmc_sdram_type::bstr

Definition at line 930 of file at32f435_437_xmc.h.

◆ busy

__IO uint32_t xmc_sdram_type::busy

Definition at line 999 of file at32f435_437_xmc.h.

◆ ca

__IO uint32_t xmc_sdram_type::ca

Definition at line 923 of file at32f435_437_xmc.h.

◆ cas

__IO uint32_t xmc_sdram_type::cas

Definition at line 927 of file at32f435_437_xmc.h.

◆ clkdiv

__IO uint32_t xmc_sdram_type::clkdiv

Definition at line 929 of file at32f435_437_xmc.h.

◆ cmd

__IO uint32_t xmc_sdram_type::cmd

Definition at line 961 of file at32f435_437_xmc.h.

◆

struct { ... } xmc_sdram_type::cmd_bit

◆ ctrl

__IO uint32_t xmc_sdram_type::ctrl[2]

Definition at line 920 of file at32f435_437_xmc.h.

◆

struct { ... } xmc_sdram_type::ctrl_bit[2]

◆ db

__IO uint32_t xmc_sdram_type::db

Definition at line 925 of file at32f435_437_xmc.h.

◆ erien

__IO uint32_t xmc_sdram_type::erien

Definition at line 983 of file at32f435_437_xmc.h.

◆ err

__IO uint32_t xmc_sdram_type::err

Definition at line 996 of file at32f435_437_xmc.h.

◆ errc

__IO uint32_t xmc_sdram_type::errc

Definition at line 981 of file at32f435_437_xmc.h.

◆ inbk

__IO uint32_t xmc_sdram_type::inbk

Definition at line 926 of file at32f435_437_xmc.h.

◆ mrd

__IO uint32_t xmc_sdram_type::mrd

Definition at line 968 of file at32f435_437_xmc.h.

◆ ra

__IO uint32_t xmc_sdram_type::ra

Definition at line 924 of file at32f435_437_xmc.h.

◆ rc

__IO uint32_t xmc_sdram_type::rc

Definition at line 982 of file at32f435_437_xmc.h.

◆ rcnt

__IO uint32_t xmc_sdram_type::rcnt

Definition at line 978 of file at32f435_437_xmc.h.

◆

struct { ... } xmc_sdram_type::rcnt_bit

◆ rd

__IO uint32_t xmc_sdram_type::rd

Definition at line 931 of file at32f435_437_xmc.h.

◆ reserved1

__IO uint32_t xmc_sdram_type::reserved1

Definition at line 932 of file at32f435_437_xmc.h.

◆ sts

__IO uint32_t xmc_sdram_type::sts

Definition at line 993 of file at32f435_437_xmc.h.

◆

struct { ... } xmc_sdram_type::sts_bit

◆ tm

__IO uint32_t xmc_sdram_type::tm[2]

Definition at line 941 of file at32f435_437_xmc.h.

◆

struct { ... } xmc_sdram_type::tm_bit[2]

◆ tmrd

__IO uint32_t xmc_sdram_type::tmrd

Definition at line 944 of file at32f435_437_xmc.h.

◆ tras

__IO uint32_t xmc_sdram_type::tras

Definition at line 946 of file at32f435_437_xmc.h.

◆ trc

__IO uint32_t xmc_sdram_type::trc

Definition at line 947 of file at32f435_437_xmc.h.

◆ trcd

__IO uint32_t xmc_sdram_type::trcd

Definition at line 950 of file at32f435_437_xmc.h.

◆ trp

__IO uint32_t xmc_sdram_type::trp

Definition at line 949 of file at32f435_437_xmc.h.

◆ twr

__IO uint32_t xmc_sdram_type::twr

Definition at line 948 of file at32f435_437_xmc.h.

◆ txsr

__IO uint32_t xmc_sdram_type::txsr

Definition at line 945 of file at32f435_437_xmc.h.

◆ wrp

__IO uint32_t xmc_sdram_type::wrp

Definition at line 928 of file at32f435_437_xmc.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_xmc.h


AT32F435/437 Firmwary Library: XMC_exported_functions

Functions
XMC_exported_functions
AT32F435_437_periph_driver » XMC

Functions

void | xmc_nor_sram_reset (xmc_nor_sram_subbank_type xmc_subbank)
xmc nor or sram registers reset More...
void | xmc_nor_sram_init (xmc_norsram_init_type *xmc_norsram_init_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_norsraminitstruct. More...
void | xmc_nor_sram_timing_config (xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_rw_timing_struct and xmc_w_timing_struct. More...
void | xmc_norsram_default_para_init (xmc_norsram_init_type *xmc_nor_sram_init_struct)
fill each xmc_nor_sram_init_struct member with its default value. More...
void | xmc_norsram_timing_default_para_init (xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
fill each xmc_rw_timing_struct and xmc_w_timing_struct member with its default value. More...
void | xmc_nor_sram_enable (xmc_nor_sram_subbank_type xmc_subbank, confirm_state new_state)
enable or disable the specified nor/sram memory bank. More...
void | xmc_ext_timing_config (xmc_nor_sram_subbank_type xmc_sub_bank, uint16_t w2w_timing, uint16_t r2r_timing)
config the bus turnaround phase. More...
void | xmc_nand_reset (xmc_class_bank_type xmc_bank)
xmc nand flash registers reset More...
void | xmc_nand_init (xmc_nand_init_type *xmc_nand_init_struct)
initialize the xmc nand banks according to the specified parameters in the xmc_nandinitstruct. More...
void | xmc_nand_timing_config (xmc_nand_pccard_timinginit_type *xmc_common_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_attribute_spacetiming_struct)
initialize the xmc nand banks according to the specified parameters in the xmc_nandinitstruct. More...
void | xmc_nand_default_para_init (xmc_nand_init_type *xmc_nand_init_struct)
fill each xmc_nand_init_struct member with its default value. More...
void | xmc_nand_timing_default_para_init (xmc_nand_pccard_timinginit_type *xmc_common_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_attribute_spacetiming_struct)
fill each xmc_common_spacetiming_struct and xmc_attribute_spacetiming_struct member with its default value. More...
void | xmc_nand_enable (xmc_class_bank_type xmc_bank, confirm_state new_state)
enable or disable the specified nand memory bank. More...
void | xmc_nand_ecc_enable (xmc_class_bank_type xmc_bank, confirm_state new_state)
enable or disable the xmc nand ecc feature. More...
uint32_t | xmc_ecc_get (xmc_class_bank_type xmc_bank)
return the error correction code register value. More...
void | xmc_interrupt_enable (xmc_class_bank_type xmc_bank, xmc_interrupt_sources_type xmc_int, confirm_state new_state)
enable or disable the specified xmc interrupts. More...
flag_status | xmc_flag_status_get (xmc_class_bank_type xmc_bank, xmc_interrupt_flag_type xmc_flag)
check whether the specified xmc flag is set or not. More...
void | xmc_flag_clear (xmc_class_bank_type xmc_bank, xmc_interrupt_flag_type xmc_flag)
clear the xmc's pending flags. More...
void | xmc_pccard_reset (void)
xmc pc card registers reset More...
void | xmc_pccard_init (xmc_pccard_init_type *xmc_pccard_init_struct)
initialize the xmc pccard bank according to the specified parameters in the xmc_pccard_init_struct. More...
void | xmc_pccard_timing_config (xmc_nand_pccard_timinginit_type *xmc_common_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_attribute_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_iospace_timing_struct)
initialize the xmc pccard bank according to the specified parameters in the xmc_common_spacetiming_struct/xmc_attribute_spacetiming_struct and xmc_iospace_timing_struct. More...
void | xmc_pccard_default_para_init (xmc_pccard_init_type *xmc_pccard_init_struct)
fill each xmc_pccard_init_struct member with its default value. More...
void | xmc_pccard_timing_default_para_init (xmc_nand_pccard_timinginit_type *xmc_common_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_attribute_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_iospace_timing_struct)
fill each xmc_common_spacetiming_struct/xmc_attribute_spacetiming_struct and xmc_iospace_timing_struct member with its default value. More...
void | xmc_pccard_enable (confirm_state new_state)
enable or disable the pccard memory bank. More...
void | xmc_sdram_reset (xmc_sdram_bank_type xmc_bank)
xmc sdram registers reset More...
void | xmc_sdram_init (xmc_sdram_init_type *xmc_sdram_init_struct, xmc_sdram_timing_type *xmc_sdram_timing_struct)
initialize the xmc sdram banks according to the specified parameters in the xmc_sdram_init_struct and xmc_sdram_timing_struct. More...
void | xmc_sdram_default_para_init (xmc_sdram_init_type *xmc_sdram_init_struct, xmc_sdram_timing_type *xmc_sdram_timing_struct)
fill each xmc_sdram_init_struct member with its default value. More...
void | xmc_sdram_cmd (xmc_sdram_cmd_type *xmc_sdram_cmd_struct)
sdram command confg More...
uint32_t | xmc_sdram_status_get (xmc_sdram_bank_type xmc_bank)
get sdram bank status More...
void | xmc_sdram_refresh_counter_set (uint32_t counter)
set sdram refresh counter More...
void | xmc_sdram_auto_refresh_set (uint32_t number)
set sdram auto refresh number More...

Detailed Description

Function Documentation

◆ xmc_ecc_get()

uint32_t xmc_ecc_get ( xmc_class_bank_type xmc_bank )

return the error correction code register value.

Parameters
xmc_bank specifies the xmc bank to be used this parameter can be one of the following values:
  • XMC_BANK2_NAND
  • XMC_BANK3_NAND
Return values
the error correction code (ecc) value.

Definition at line 429 of file at32f435_437_xmc.c.

Referenced by nand_read_small_page(), and nand_write_small_page().

◆ xmc_ext_timing_config()

void xmc_ext_timing_config | ( | xmc_nor_sram_subbank_type | xmc_sub_bank,
 |  | uint16_t | w2w_timing,
 |  | uint16_t | r2r_timing
 | ) |  |

config the bus turnaround phase.

Parameters
xmc_sub_bank this parameter can be one of the following values:
  • XMC_BANK1_NOR_SRAM1
  • XMC_BANK1_NOR_SRAM2
  • XMC_BANK1_NOR_SRAM3
  • XMC_BANK1_NOR_SRAM4
w2w_timing | :write timing
r2r_timing | :read timing
Return values
none

Definition at line 227 of file at32f435_437_xmc.c.

Referenced by psram_init(), sram_init(), and xmc_init().

◆ xmc_flag_clear()

void xmc_flag_clear | ( | xmc_class_bank_type | xmc_bank,
 |  | xmc_interrupt_flag_type | xmc_flag
 | ) |  |

clear the xmc's pending flags.

Parameters
xmc_bank specifies the xmc bank to be used this parameter can be one of the following values:
  • XMC_BANK2_NAND
  • XMC_BANK3_NAND
  • XMC_BANK4_PCCARD
  • XMC_BANK5_6_SDRAM
xmc_flag specifies the flag to check. this parameter can be any combination of the following values:
  • XMC_RISINGEDGE_FLAG
  • XMC_LEVEL_FLAG
  • XMC_FALLINGEDGE_FLAG
  • XMC_ERR_FLAG
Return values
none

Definition at line 745 of file at32f435_437_xmc.c.

◆ xmc_flag_status_get()

flag_status xmc_flag_status_get | ( | xmc_class_bank_type | xmc_bank,
 |  | xmc_interrupt_flag_type | xmc_flag
 | ) |  |

check whether the specified xmc flag is set or not.

Parameters
xmc_bank specifies the xmc bank to be used this parameter can be one of the following values:
  • XMC_BANK2_NAND
  • XMC_BANK3_NAND
  • XMC_BANK4_PCCARD
  • XMC_BANK5_6_SDRAM
xmc_flag specifies the flag to check. this parameter can be any combination of the following values:
  • XMC_RISINGEDGE_FLAG
  • XMC_LEVEL_FLAG
  • XMC_FALLINGEDGE_FLAG
  • XMC_FEMPT_FLAG
  • XMC_BUSY_FLAG
  • XMC_ERR_FLAG
Return values
none

Definition at line 695 of file at32f435_437_xmc.c.

Referenced by nand_write_small_page(), and sdram_init_sequence().

◆ xmc_interrupt_enable()

void xmc_interrupt_enable | ( | xmc_class_bank_type | xmc_bank,
 |  | xmc_interrupt_sources_type | xmc_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified xmc interrupts.

Parameters
xmc_bank specifies the xmc bank to be used this parameter can be one of the following values:
  • XMC_BANK2_NAND
  • XMC_BANK3_NAND
  • XMC_BANK4_PCCARD
  • XMC_BANK5_6_SDRAM
xmc_int specifies the xmc interrupt sources to be enabled or disabled. this parameter can be any combination of the following values:
  • XMC_INT_RISING_EDGE
  • XMC_INT_LEVEL
  • XMC_INT_FALLING_EDGE
  • XMC_INT_ERR
new_state (TRUE or FALSE)
Return values
none

Definition at line 627 of file at32f435_437_xmc.c.

◆ xmc_nand_default_para_init()

void xmc_nand_default_para_init ( xmc_nand_init_type * xmc_nand_init_struct )

fill each xmc_nand_init_struct member with its default value.

Parameters
xmc_nand_init_struct pointer to a xmc_nand_init_type structure which will be initialized.
Return values
none

Definition at line 340 of file at32f435_437_xmc.c.

Referenced by nand_init().

◆ xmc_nand_ecc_enable()

void xmc_nand_ecc_enable | ( | xmc_class_bank_type | xmc_bank,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the xmc nand ecc feature.

Parameters
xmc_bank specifies the xmc bank to be used this parameter can be one of the following values:
  • XMC_BANK2_NAND
  • XMC_BANK3_NAND
new_state (TRUE or FALSE)
Return values
none

Definition at line 407 of file at32f435_437_xmc.c.

Referenced by main(), nand_read_small_page(), and nand_write_small_page().

◆ xmc_nand_enable()

void xmc_nand_enable | ( | xmc_class_bank_type | xmc_bank,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified nand memory bank.

Parameters
xmc_bank specifies the xmc bank to be used this parameter can be one of the following values:
  • XMC_BANK2_NAND
  • XMC_BANK3_NAND
new_state (TRUE or FALSE)
Return values
none

Definition at line 384 of file at32f435_437_xmc.c.

Referenced by nand_init().

◆ xmc_nand_init()

void xmc_nand_init ( xmc_nand_init_type * xmc_nand_init_struct )

initialize the xmc nand banks according to the specified parameters in the xmc_nandinitstruct.

Parameters
xmc_nand_init_struct : pointer to a xmc_nand_init_type structure that contains the configuration information for the xmc nand specified banks.
Return values
none

Definition at line 269 of file at32f435_437_xmc.c.

Referenced by nand_init().

◆ xmc_nand_reset()

void xmc_nand_reset ( xmc_class_bank_type xmc_bank )

xmc nand flash registers reset

Parameters
xmc_bank this parameter can be one of the following values:
  • XMC_BANK2_NAND
  • XMC_BANK3_NAND
Return values
none

Definition at line 241 of file at32f435_437_xmc.c.

◆ xmc_nand_timing_config()

void xmc_nand_timing_config | ( | xmc_nand_pccard_timinginit_type * | xmc_regular_spacetiming_struct,
 |  | xmc_nand_pccard_timinginit_type * | xmc_special_spacetiming_struct
 | ) |  |

initialize the xmc nand banks according to the specified parameters in the xmc_nandinitstruct.

Parameters
xmc_regular_spacetiming_struct | : pointer to a xmc_nand_pccard_timinginit_type structure that contains the configuration information for the xmc nand specified banks.
xmc_special_spacetiming_struct | : pointer to a xmc_nand_pccard_timinginit_type structure that contains the configuration information for the xmc nand specified banks.
Return values
none

Definition at line 305 of file at32f435_437_xmc.c.

Referenced by nand_init().

◆ xmc_nand_timing_default_para_init()

void xmc_nand_timing_default_para_init | ( | xmc_nand_pccard_timinginit_type * | xmc_regular_spacetiming_struct,
 |  | xmc_nand_pccard_timinginit_type * | xmc_special_spacetiming_struct
 | ) |  |

fill each xmc_common_spacetiming_struct and xmc_attribute_spacetiming_struct member with its default value.

Parameters
xmc_common_spacetiming_struct | pointer to a xmc_nand_pccard_timinginit_type structure which will be initialized.
xmc_special_spacetiming_struct | pointer to a xmc_nand_pccard_timinginit_type structure which will be initialized.
Return values
none

Definition at line 360 of file at32f435_437_xmc.c.

Referenced by nand_init().

◆ xmc_nor_sram_enable()

void xmc_nor_sram_enable | ( | xmc_nor_sram_subbank_type | xmc_subbank,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified nor/sram memory bank.

Parameters
xmc_subbank this parameter can be one of the following values:
  • XMC_BANK1_NOR_SRAM1
  • XMC_BANK1_NOR_SRAM2
  • XMC_BANK1_NOR_SRAM3
  • XMC_BANK1_NOR_SRAM4
new_state (TRUE or FALSE)
Return values
none

Definition at line 210 of file at32f435_437_xmc.c.

Referenced by nor_init(), psram_init(), sram_init(), and xmc_init().

◆ xmc_nor_sram_init()

void xmc_nor_sram_init ( xmc_norsram_init_type * xmc_norsram_init_struct )

initialize the xmc nor/sram banks according to the specified parameters in the xmc_norsraminitstruct.

Parameters
xmc_norsram_init_struct : pointer to a xmc_norsram_init_type structure that contains the configuration information for the xmc nor/sram specified banks.
Return values
none

Definition at line 78 of file at32f435_437_xmc.c.

Referenced by nor_init(), psram_init(), sram_init(), and xmc_init().

◆ xmc_nor_sram_reset()

void xmc_nor_sram_reset ( xmc_nor_sram_subbank_type xmc_subbank )

xmc nor or sram registers reset

Parameters
xmc_subbank this parameter can be one of the following values:
  • XMC_BANK1_NOR_SRAM1
  • XMC_BANK1_NOR_SRAM2
  • XMC_BANK1_NOR_SRAM3
  • XMC_BANK1_NOR_SRAM4
Return values
none

Definition at line 54 of file at32f435_437_xmc.c.

◆ xmc_nor_sram_timing_config()

void xmc_nor_sram_timing_config | ( | xmc_norsram_timing_init_type * | xmc_rw_timing_struct,
 |  | xmc_norsram_timing_init_type * | xmc_w_timing_struct
 | ) |  |

initialize the xmc nor/sram banks according to the specified parameters in the xmc_rw_timing_struct and xmc_w_timing_struct.

Parameters
xmc_rw_timing_struct | : pointer to a xmc_norsram_timing_init_type structure that contains the configuration information for the xmc nor/sram specified banks.
xmc_w_timing_struct | : pointer to a xmc_norsram_timing_init_type structure that contains the configuration information for the xmc nor/sram specified banks.
Return values
none

Definition at line 113 of file at32f435_437_xmc.c.

Referenced by nor_init(), psram_init(), sram_init(), and xmc_init().

◆ xmc_norsram_default_para_init()

void xmc_norsram_default_para_init ( xmc_norsram_init_type * xmc_nor_sram_init_struct )

fill each xmc_nor_sram_init_struct member with its default value.

Parameters
xmc_nor_sram_init_struct pointer to a xmc_norsram_init_type structure which will be initialized.
Return values
none

Definition at line 150 of file at32f435_437_xmc.c.

Referenced by nor_init(), psram_init(), sram_init(), and xmc_init().

◆ xmc_norsram_timing_default_para_init()

void xmc_norsram_timing_default_para_init | ( | xmc_norsram_timing_init_type * | xmc_rw_timing_struct,
 |  | xmc_norsram_timing_init_type * | xmc_w_timing_struct
 | ) |  |

fill each xmc_rw_timing_struct and xmc_w_timing_struct member with its default value.

Parameters
xmc_rw_timing_struct | pointer to a xmc_norsram_timing_init_type structure which will be initialized.
xmc_w_timing_struct | pointer to a xmc_norsram_timing_init_type structure which will be initialized.
Return values
none

Definition at line 176 of file at32f435_437_xmc.c.

Referenced by nor_init(), psram_init(), sram_init(), and xmc_init().

◆ xmc_pccard_default_para_init()

void xmc_pccard_default_para_init ( xmc_pccard_init_type * xmc_pccard_init_struct )

fill each xmc_pccard_init_struct member with its default value.

Parameters
xmc_pccard_init_struct pointer to a xmc_pccardinittype structure which will be initialized.
Return values
none

Definition at line 844 of file at32f435_437_xmc.c.

◆ xmc_pccard_enable()

void xmc_pccard_enable ( confirm_state new_state )

enable or disable the pccard memory bank.

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 891 of file at32f435_437_xmc.c.

◆ xmc_pccard_init()

void xmc_pccard_init ( xmc_pccard_init_type * xmc_pccard_init_struct )

initialize the xmc pccard bank according to the specified parameters in the xmc_pccard_init_struct.

Parameters
xmc_pccard_init_struct : pointer to a xmc_pccard_init_type structure that contains the configuration information for the xmc pccard bank.
Return values
none

Definition at line 792 of file at32f435_437_xmc.c.

◆ xmc_pccard_reset()

void xmc_pccard_reset ( void )

xmc pc card registers reset

Parameters
none
Return values
none

Definition at line 774 of file at32f435_437_xmc.c.

◆ xmc_pccard_timing_config()

void xmc_pccard_timing_config | ( | xmc_nand_pccard_timinginit_type * | xmc_regular_spacetiming_struct,
 |  | xmc_nand_pccard_timinginit_type * | xmc_special_spacetiming_struct,
 |  | xmc_nand_pccard_timinginit_type * | xmc_iospace_timing_struct
 | ) |  |

initialize the xmc pccard bank according to the specified parameters in the xmc_common_spacetiming_struct/xmc_attribute_spacetiming_struct and xmc_iospace_timing_struct.

Parameters
xmc_regular_spacetiming_struct | : pointer to a xmc_pccard_init_type structure that contains the configuration information for the xmc pccard bank.
xmc_special_spacetiming_struct | : pointer to a xmc_pccard_init_type structure that contains the configuration information for the xmc pccard bank.
xmc_iospace_timing_struct | : pointer to a xmc_pccard_init_type structure that contains the configuration information for the xmc pccard bank.
Return values
none

Definition at line 816 of file at32f435_437_xmc.c.

◆ xmc_pccard_timing_default_para_init()

void xmc_pccard_timing_default_para_init | ( | xmc_nand_pccard_timinginit_type * | xmc_regular_spacetiming_struct,
 |  | xmc_nand_pccard_timinginit_type * | xmc_special_spacetiming_struct,
 |  | xmc_nand_pccard_timinginit_type * | xmc_iospace_timing_struct
 | ) |  |

fill each xmc_common_spacetiming_struct/xmc_attribute_spacetiming_struct and xmc_iospace_timing_struct member with its default value.

Parameters
xmc_regular_spacetiming_struct | : pointer to a xmc_pccard_init_type structure that contains the configuration information for the xmc pccard bank.
xmc_special_spacetiming_struct | : pointer to a xmc_pccard_init_type structure that contains the configuration information for the xmc pccard bank.
xmc_iospace_timing_struct | : pointer to a xmc_pccard_init_type structure that contains the configuration information for the xmc pccard bank.
Return values
none

Definition at line 866 of file at32f435_437_xmc.c.

◆ xmc_sdram_auto_refresh_set()

void xmc_sdram_auto_refresh_set ( uint32_t number )

set sdram auto refresh number

Parameters
number xmc sdram auto refresh number
Return values
none

Definition at line 605 of file at32f435_437_xmc.c.

◆ xmc_sdram_cmd()

void xmc_sdram_cmd ( xmc_sdram_cmd_type * xmc_sdram_cmd_struct )

sdram command confg

Parameters
xmc_sdram_cmd_struct pointer to a xmc_sdram_cmd_type structure which will be initialized.
Return values
none

Definition at line 561 of file at32f435_437_xmc.c.

Referenced by sdram_init_sequence().

◆ xmc_sdram_default_para_init()

void xmc_sdram_default_para_init | ( | xmc_sdram_init_type * | xmc_sdram_init_struct,
 |  | xmc_sdram_timing_type * | xmc_sdram_timing_struct
 | ) |  |

fill each xmc_sdram_init_struct member with its default value.

Parameters
xmc_sdram_init_struct | pointer to a xmc_sdram_init_type structure which will be initialized.
xmc_sdram_timing_struct | pointer to a xmc_sdram_timing_type structure which will be initialized.
Return values
none

Definition at line 532 of file at32f435_437_xmc.c.

Referenced by sdram_init().

◆ xmc_sdram_init()

void xmc_sdram_init | ( | xmc_sdram_init_type * | xmc_sdram_init_struct,
 |  | xmc_sdram_timing_type * | xmc_sdram_timing_struct
 | ) |  |

initialize the xmc sdram banks according to the specified parameters in the xmc_sdram_init_struct and xmc_sdram_timing_struct.

Parameters
xmc_sdram_init_struct | : pointer to a xmc_sdram_init_type structure that contains the configuration information for the xmc sdram specified banks.
xmc_sdram_timing_struct | : pointer to a xmc_sdram_timing_type structure that contains the configuration information for the xmc sdram specified banks.
Return values
none

Definition at line 475 of file at32f435_437_xmc.c.

Referenced by sdram_init().

◆ xmc_sdram_refresh_counter_set()

void xmc_sdram_refresh_counter_set ( uint32_t counter )

set sdram refresh counter

Parameters
counter xmc sdram refresh counter
Return values
none

Definition at line 595 of file at32f435_437_xmc.c.

Referenced by sdram_init_sequence().

◆ xmc_sdram_reset()

void xmc_sdram_reset ( xmc_sdram_bank_type xmc_bank )

xmc sdram registers reset

Parameters
xmc_bank this parameter can be one of the following values:
  • XMC_SDRAM_BANK1
  • XMC_SDRAM_BANK2
Return values
none

Definition at line 455 of file at32f435_437_xmc.c.

◆ xmc_sdram_status_get()

uint32_t xmc_sdram_status_get ( xmc_sdram_bank_type xmc_bank )

get sdram bank status

Parameters
xmc_bank specifies the xmc bank to be used this parameter can be one of the following values:
  • XMC_SDRAM_BANK1
  • XMC_SDRAM_BANK1
Return values
the bank status

Definition at line 578 of file at32f435_437_xmc.c.


AT32F435/437 Firmwary Library: XMC_private_functions

Functions
XMC_private_functions
AT32F435_437_periph_driver » XMC

Functions

void | xmc_nor_sram_reset (xmc_nor_sram_subbank_type xmc_subbank)
xmc nor or sram registers reset More...
void | xmc_nor_sram_init (xmc_norsram_init_type *xmc_norsram_init_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_norsraminitstruct. More...
void | xmc_nor_sram_timing_config (xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_rw_timing_struct and xmc_w_timing_struct. More...
void | xmc_norsram_default_para_init (xmc_norsram_init_type *xmc_nor_sram_init_struct)
fill each xmc_nor_sram_init_struct member with its default value. More...
void | xmc_norsram_timing_default_para_init (xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
fill each xmc_rw_timing_struct and xmc_w_timing_struct member with its default value. More...
void | xmc_nor_sram_enable (xmc_nor_sram_subbank_type xmc_subbank, confirm_state new_state)
enable or disable the specified nor/sram memory bank. More...
void | xmc_ext_timing_config (xmc_nor_sram_subbank_type xmc_sub_bank, uint16_t w2w_timing, uint16_t r2r_timing)
config the bus turnaround phase. More...
void | xmc_nand_reset (xmc_class_bank_type xmc_bank)
xmc nand flash registers reset More...
void | xmc_nand_init (xmc_nand_init_type *xmc_nand_init_struct)
initialize the xmc nand banks according to the specified parameters in the xmc_nandinitstruct. More...
void | xmc_nand_timing_config (xmc_nand_pccard_timinginit_type *xmc_regular_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_special_spacetiming_struct)
initialize the xmc nand banks according to the specified parameters in the xmc_nandinitstruct. More...
void | xmc_nand_default_para_init (xmc_nand_init_type *xmc_nand_init_struct)
fill each xmc_nand_init_struct member with its default value. More...
void | xmc_nand_timing_default_para_init (xmc_nand_pccard_timinginit_type *xmc_regular_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_special_spacetiming_struct)
fill each xmc_common_spacetiming_struct and xmc_attribute_spacetiming_struct member with its default value. More...
void | xmc_nand_enable (xmc_class_bank_type xmc_bank, confirm_state new_state)
enable or disable the specified nand memory bank. More...
void | xmc_nand_ecc_enable (xmc_class_bank_type xmc_bank, confirm_state new_state)
enable or disable the xmc nand ecc feature. More...
uint32_t | xmc_ecc_get (xmc_class_bank_type xmc_bank)
return the error correction code register value. More...
void | xmc_sdram_reset (xmc_sdram_bank_type xmc_bank)
xmc sdram registers reset More...
void | xmc_sdram_init (xmc_sdram_init_type *xmc_sdram_init_struct, xmc_sdram_timing_type *xmc_sdram_timing_struct)
initialize the xmc sdram banks according to the specified parameters in the xmc_sdram_init_struct and xmc_sdram_timing_struct. More...
void | xmc_sdram_default_para_init (xmc_sdram_init_type *xmc_sdram_init_struct, xmc_sdram_timing_type *xmc_sdram_timing_struct)
fill each xmc_sdram_init_struct member with its default value. More...
void | xmc_sdram_cmd (xmc_sdram_cmd_type *xmc_sdram_cmd_struct)
sdram command confg More...
uint32_t | xmc_sdram_status_get (xmc_sdram_bank_type xmc_bank)
get sdram bank status More...
void | xmc_sdram_refresh_counter_set (uint32_t counter)
set sdram refresh counter More...
void | xmc_sdram_auto_refresh_set (uint32_t number)
set sdram auto refresh number More...
void | xmc_interrupt_enable (xmc_class_bank_type xmc_bank, xmc_interrupt_sources_type xmc_int, confirm_state new_state)
enable or disable the specified xmc interrupts. More...
flag_status | xmc_flag_status_get (xmc_class_bank_type xmc_bank, xmc_interrupt_flag_type xmc_flag)
check whether the specified xmc flag is set or not. More...
void | xmc_flag_clear (xmc_class_bank_type xmc_bank, xmc_interrupt_flag_type xmc_flag)
clear the xmc's pending flags. More...
void | xmc_pccard_reset (void)
xmc pc card registers reset More...
void | xmc_pccard_init (xmc_pccard_init_type *xmc_pccard_init_struct)
initialize the xmc pccard bank according to the specified parameters in the xmc_pccard_init_struct. More...
void | xmc_pccard_timing_config (xmc_nand_pccard_timinginit_type *xmc_regular_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_special_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_iospace_timing_struct)
initialize the xmc pccard bank according to the specified parameters in the xmc_common_spacetiming_struct/xmc_attribute_spacetiming_struct and xmc_iospace_timing_struct. More...
void | xmc_pccard_default_para_init (xmc_pccard_init_type *xmc_pccard_init_struct)
fill each xmc_pccard_init_struct member with its default value. More...
void | xmc_pccard_timing_default_para_init (xmc_nand_pccard_timinginit_type *xmc_regular_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_special_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_iospace_timing_struct)
fill each xmc_common_spacetiming_struct/xmc_attribute_spacetiming_struct and xmc_iospace_timing_struct member with its default value. More...
void | xmc_pccard_enable (confirm_state new_state)
enable or disable the pccard memory bank. More...

Detailed Description

Function Documentation

◆ xmc_ecc_get()

uint32_t xmc_ecc_get ( xmc_class_bank_type xmc_bank )

return the error correction code register value.

Parameters
xmc_bank specifies the xmc bank to be used this parameter can be one of the following values:
  • XMC_BANK2_NAND
  • XMC_BANK3_NAND
Return values
the error correction code (ecc) value.

Definition at line 429 of file at32f435_437_xmc.c.

Referenced by nand_read_small_page(), and nand_write_small_page().

◆ xmc_ext_timing_config()

void xmc_ext_timing_config | ( | xmc_nor_sram_subbank_type | xmc_sub_bank,
 |  | uint16_t | w2w_timing,
 |  | uint16_t | r2r_timing
 | ) |  |

config the bus turnaround phase.

Parameters
xmc_sub_bank this parameter can be one of the following values:
  • XMC_BANK1_NOR_SRAM1
  • XMC_BANK1_NOR_SRAM2
  • XMC_BANK1_NOR_SRAM3
  • XMC_BANK1_NOR_SRAM4
w2w_timing | :write timing
r2r_timing | :read timing
Return values
none

Definition at line 227 of file at32f435_437_xmc.c.

Referenced by psram_init(), sram_init(), and xmc_init().

◆ xmc_flag_clear()

void xmc_flag_clear | ( | xmc_class_bank_type | xmc_bank,
 |  | xmc_interrupt_flag_type | xmc_flag
 | ) |  |

clear the xmc's pending flags.

Parameters
xmc_bank specifies the xmc bank to be used this parameter can be one of the following values:
  • XMC_BANK2_NAND
  • XMC_BANK3_NAND
  • XMC_BANK4_PCCARD
  • XMC_BANK5_6_SDRAM
xmc_flag specifies the flag to check. this parameter can be any combination of the following values:
  • XMC_RISINGEDGE_FLAG
  • XMC_LEVEL_FLAG
  • XMC_FALLINGEDGE_FLAG
  • XMC_ERR_FLAG
Return values
none

Definition at line 745 of file at32f435_437_xmc.c.

◆ xmc_flag_status_get()

flag_status xmc_flag_status_get | ( | xmc_class_bank_type | xmc_bank,
 |  | xmc_interrupt_flag_type | xmc_flag
 | ) |  |

check whether the specified xmc flag is set or not.

Parameters
xmc_bank specifies the xmc bank to be used this parameter can be one of the following values:
  • XMC_BANK2_NAND
  • XMC_BANK3_NAND
  • XMC_BANK4_PCCARD
  • XMC_BANK5_6_SDRAM
xmc_flag specifies the flag to check. this parameter can be any combination of the following values:
  • XMC_RISINGEDGE_FLAG
  • XMC_LEVEL_FLAG
  • XMC_FALLINGEDGE_FLAG
  • XMC_FEMPT_FLAG
  • XMC_BUSY_FLAG
  • XMC_ERR_FLAG
Return values
none

Definition at line 695 of file at32f435_437_xmc.c.

Referenced by nand_write_small_page(), and sdram_init_sequence().

◆ xmc_interrupt_enable()

void xmc_interrupt_enable | ( | xmc_class_bank_type | xmc_bank,
 |  | xmc_interrupt_sources_type | xmc_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified xmc interrupts.

Parameters
xmc_bank specifies the xmc bank to be used this parameter can be one of the following values:
  • XMC_BANK2_NAND
  • XMC_BANK3_NAND
  • XMC_BANK4_PCCARD
  • XMC_BANK5_6_SDRAM
xmc_int specifies the xmc interrupt sources to be enabled or disabled. this parameter can be any combination of the following values:
  • XMC_INT_RISING_EDGE
  • XMC_INT_LEVEL
  • XMC_INT_FALLING_EDGE
  • XMC_INT_ERR
new_state (TRUE or FALSE)
Return values
none

Definition at line 627 of file at32f435_437_xmc.c.

◆ xmc_nand_default_para_init()

void xmc_nand_default_para_init ( xmc_nand_init_type * xmc_nand_init_struct )

fill each xmc_nand_init_struct member with its default value.

Parameters
xmc_nand_init_struct pointer to a xmc_nand_init_type structure which will be initialized.
Return values
none

Definition at line 340 of file at32f435_437_xmc.c.

Referenced by nand_init().

◆ xmc_nand_ecc_enable()

void xmc_nand_ecc_enable | ( | xmc_class_bank_type | xmc_bank,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the xmc nand ecc feature.

Parameters
xmc_bank specifies the xmc bank to be used this parameter can be one of the following values:
  • XMC_BANK2_NAND
  • XMC_BANK3_NAND
new_state (TRUE or FALSE)
Return values
none

Definition at line 407 of file at32f435_437_xmc.c.

Referenced by main(), nand_read_small_page(), and nand_write_small_page().

◆ xmc_nand_enable()

void xmc_nand_enable | ( | xmc_class_bank_type | xmc_bank,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified nand memory bank.

Parameters
xmc_bank specifies the xmc bank to be used this parameter can be one of the following values:
  • XMC_BANK2_NAND
  • XMC_BANK3_NAND
new_state (TRUE or FALSE)
Return values
none

Definition at line 384 of file at32f435_437_xmc.c.

Referenced by nand_init().

◆ xmc_nand_init()

void xmc_nand_init ( xmc_nand_init_type * xmc_nand_init_struct )

initialize the xmc nand banks according to the specified parameters in the xmc_nandinitstruct.

Parameters
xmc_nand_init_struct : pointer to a xmc_nand_init_type structure that contains the configuration information for the xmc nand specified banks.
Return values
none

Definition at line 269 of file at32f435_437_xmc.c.

Referenced by nand_init().

◆ xmc_nand_reset()

void xmc_nand_reset ( xmc_class_bank_type xmc_bank )

xmc nand flash registers reset

Parameters
xmc_bank this parameter can be one of the following values:
  • XMC_BANK2_NAND
  • XMC_BANK3_NAND
Return values
none

Definition at line 241 of file at32f435_437_xmc.c.

◆ xmc_nand_timing_config()

void xmc_nand_timing_config | ( | xmc_nand_pccard_timinginit_type * | xmc_regular_spacetiming_struct,
 |  | xmc_nand_pccard_timinginit_type * | xmc_special_spacetiming_struct
 | ) |  |

initialize the xmc nand banks according to the specified parameters in the xmc_nandinitstruct.

Parameters
xmc_regular_spacetiming_struct | : pointer to a xmc_nand_pccard_timinginit_type structure that contains the configuration information for the xmc nand specified banks.
xmc_special_spacetiming_struct | : pointer to a xmc_nand_pccard_timinginit_type structure that contains the configuration information for the xmc nand specified banks.
Return values
none

Definition at line 305 of file at32f435_437_xmc.c.

Referenced by nand_init().

◆ xmc_nand_timing_default_para_init()

void xmc_nand_timing_default_para_init | ( | xmc_nand_pccard_timinginit_type * | xmc_regular_spacetiming_struct,
 |  | xmc_nand_pccard_timinginit_type * | xmc_special_spacetiming_struct
 | ) |  |

fill each xmc_common_spacetiming_struct and xmc_attribute_spacetiming_struct member with its default value.

Parameters
xmc_common_spacetiming_struct | pointer to a xmc_nand_pccard_timinginit_type structure which will be initialized.
xmc_special_spacetiming_struct | pointer to a xmc_nand_pccard_timinginit_type structure which will be initialized.
Return values
none

Definition at line 360 of file at32f435_437_xmc.c.

Referenced by nand_init().

◆ xmc_nor_sram_enable()

void xmc_nor_sram_enable | ( | xmc_nor_sram_subbank_type | xmc_subbank,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified nor/sram memory bank.

Parameters
xmc_subbank this parameter can be one of the following values:
  • XMC_BANK1_NOR_SRAM1
  • XMC_BANK1_NOR_SRAM2
  • XMC_BANK1_NOR_SRAM3
  • XMC_BANK1_NOR_SRAM4
new_state (TRUE or FALSE)
Return values
none

Definition at line 210 of file at32f435_437_xmc.c.

Referenced by nor_init(), psram_init(), sram_init(), and xmc_init().

◆ xmc_nor_sram_init()

void xmc_nor_sram_init ( xmc_norsram_init_type * xmc_norsram_init_struct )

initialize the xmc nor/sram banks according to the specified parameters in the xmc_norsraminitstruct.

Parameters
xmc_norsram_init_struct : pointer to a xmc_norsram_init_type structure that contains the configuration information for the xmc nor/sram specified banks.
Return values
none

Definition at line 78 of file at32f435_437_xmc.c.

Referenced by nor_init(), psram_init(), sram_init(), and xmc_init().

◆ xmc_nor_sram_reset()

void xmc_nor_sram_reset ( xmc_nor_sram_subbank_type xmc_subbank )

xmc nor or sram registers reset

Parameters
xmc_subbank this parameter can be one of the following values:
  • XMC_BANK1_NOR_SRAM1
  • XMC_BANK1_NOR_SRAM2
  • XMC_BANK1_NOR_SRAM3
  • XMC_BANK1_NOR_SRAM4
Return values
none

Definition at line 54 of file at32f435_437_xmc.c.

◆ xmc_nor_sram_timing_config()

void xmc_nor_sram_timing_config | ( | xmc_norsram_timing_init_type * | xmc_rw_timing_struct,
 |  | xmc_norsram_timing_init_type * | xmc_w_timing_struct
 | ) |  |

initialize the xmc nor/sram banks according to the specified parameters in the xmc_rw_timing_struct and xmc_w_timing_struct.

Parameters
xmc_rw_timing_struct | : pointer to a xmc_norsram_timing_init_type structure that contains the configuration information for the xmc nor/sram specified banks.
xmc_w_timing_struct | : pointer to a xmc_norsram_timing_init_type structure that contains the configuration information for the xmc nor/sram specified banks.
Return values
none

Definition at line 113 of file at32f435_437_xmc.c.

Referenced by nor_init(), psram_init(), sram_init(), and xmc_init().

◆ xmc_norsram_default_para_init()

void xmc_norsram_default_para_init ( xmc_norsram_init_type * xmc_nor_sram_init_struct )

fill each xmc_nor_sram_init_struct member with its default value.

Parameters
xmc_nor_sram_init_struct pointer to a xmc_norsram_init_type structure which will be initialized.
Return values
none

Definition at line 150 of file at32f435_437_xmc.c.

Referenced by nor_init(), psram_init(), sram_init(), and xmc_init().

◆ xmc_norsram_timing_default_para_init()

void xmc_norsram_timing_default_para_init | ( | xmc_norsram_timing_init_type * | xmc_rw_timing_struct,
 |  | xmc_norsram_timing_init_type * | xmc_w_timing_struct
 | ) |  |

fill each xmc_rw_timing_struct and xmc_w_timing_struct member with its default value.

Parameters
xmc_rw_timing_struct | pointer to a xmc_norsram_timing_init_type structure which will be initialized.
xmc_w_timing_struct | pointer to a xmc_norsram_timing_init_type structure which will be initialized.
Return values
none

Definition at line 176 of file at32f435_437_xmc.c.

Referenced by nor_init(), psram_init(), sram_init(), and xmc_init().

◆ xmc_pccard_default_para_init()

void xmc_pccard_default_para_init ( xmc_pccard_init_type * xmc_pccard_init_struct )

fill each xmc_pccard_init_struct member with its default value.

Parameters
xmc_pccard_init_struct pointer to a xmc_pccardinittype structure which will be initialized.
Return values
none

Definition at line 844 of file at32f435_437_xmc.c.

◆ xmc_pccard_enable()

void xmc_pccard_enable ( confirm_state new_state )

enable or disable the pccard memory bank.

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 891 of file at32f435_437_xmc.c.

◆ xmc_pccard_init()

void xmc_pccard_init ( xmc_pccard_init_type * xmc_pccard_init_struct )

initialize the xmc pccard bank according to the specified parameters in the xmc_pccard_init_struct.

Parameters
xmc_pccard_init_struct : pointer to a xmc_pccard_init_type structure that contains the configuration information for the xmc pccard bank.
Return values
none

Definition at line 792 of file at32f435_437_xmc.c.

◆ xmc_pccard_reset()

void xmc_pccard_reset ( void )

xmc pc card registers reset

Parameters
none
Return values
none

Definition at line 774 of file at32f435_437_xmc.c.

◆ xmc_pccard_timing_config()

void xmc_pccard_timing_config | ( | xmc_nand_pccard_timinginit_type * | xmc_regular_spacetiming_struct,
 |  | xmc_nand_pccard_timinginit_type * | xmc_special_spacetiming_struct,
 |  | xmc_nand_pccard_timinginit_type * | xmc_iospace_timing_struct
 | ) |  |

initialize the xmc pccard bank according to the specified parameters in the xmc_common_spacetiming_struct/xmc_attribute_spacetiming_struct and xmc_iospace_timing_struct.

Parameters
xmc_regular_spacetiming_struct | : pointer to a xmc_pccard_init_type structure that contains the configuration information for the xmc pccard bank.
xmc_special_spacetiming_struct | : pointer to a xmc_pccard_init_type structure that contains the configuration information for the xmc pccard bank.
xmc_iospace_timing_struct | : pointer to a xmc_pccard_init_type structure that contains the configuration information for the xmc pccard bank.
Return values
none

Definition at line 816 of file at32f435_437_xmc.c.

◆ xmc_pccard_timing_default_para_init()

void xmc_pccard_timing_default_para_init | ( | xmc_nand_pccard_timinginit_type * | xmc_regular_spacetiming_struct,
 |  | xmc_nand_pccard_timinginit_type * | xmc_special_spacetiming_struct,
 |  | xmc_nand_pccard_timinginit_type * | xmc_iospace_timing_struct
 | ) |  |

fill each xmc_common_spacetiming_struct/xmc_attribute_spacetiming_struct and xmc_iospace_timing_struct member with its default value.

Parameters
xmc_regular_spacetiming_struct | : pointer to a xmc_pccard_init_type structure that contains the configuration information for the xmc pccard bank.
xmc_special_spacetiming_struct | : pointer to a xmc_pccard_init_type structure that contains the configuration information for the xmc pccard bank.
xmc_iospace_timing_struct | : pointer to a xmc_pccard_init_type structure that contains the configuration information for the xmc pccard bank.
Return values
none

Definition at line 866 of file at32f435_437_xmc.c.

◆ xmc_sdram_auto_refresh_set()

void xmc_sdram_auto_refresh_set ( uint32_t number )

set sdram auto refresh number

Parameters
number xmc sdram auto refresh number
Return values
none

Definition at line 605 of file at32f435_437_xmc.c.

◆ xmc_sdram_cmd()

void xmc_sdram_cmd ( xmc_sdram_cmd_type * xmc_sdram_cmd_struct )

sdram command confg

Parameters
xmc_sdram_cmd_struct pointer to a xmc_sdram_cmd_type structure which will be initialized.
Return values
none

Definition at line 561 of file at32f435_437_xmc.c.

Referenced by sdram_init_sequence().

◆ xmc_sdram_default_para_init()

void xmc_sdram_default_para_init | ( | xmc_sdram_init_type * | xmc_sdram_init_struct,
 |  | xmc_sdram_timing_type * | xmc_sdram_timing_struct
 | ) |  |

fill each xmc_sdram_init_struct member with its default value.

Parameters
xmc_sdram_init_struct | pointer to a xmc_sdram_init_type structure which will be initialized.
xmc_sdram_timing_struct | pointer to a xmc_sdram_timing_type structure which will be initialized.
Return values
none

Definition at line 532 of file at32f435_437_xmc.c.

Referenced by sdram_init().

◆ xmc_sdram_init()

void xmc_sdram_init | ( | xmc_sdram_init_type * | xmc_sdram_init_struct,
 |  | xmc_sdram_timing_type * | xmc_sdram_timing_struct
 | ) |  |

initialize the xmc sdram banks according to the specified parameters in the xmc_sdram_init_struct and xmc_sdram_timing_struct.

Parameters
xmc_sdram_init_struct | : pointer to a xmc_sdram_init_type structure that contains the configuration information for the xmc sdram specified banks.
xmc_sdram_timing_struct | : pointer to a xmc_sdram_timing_type structure that contains the configuration information for the xmc sdram specified banks.
Return values
none

Definition at line 475 of file at32f435_437_xmc.c.

Referenced by sdram_init().

◆ xmc_sdram_refresh_counter_set()

void xmc_sdram_refresh_counter_set ( uint32_t counter )

set sdram refresh counter

Parameters
counter xmc sdram refresh counter
Return values
none

Definition at line 595 of file at32f435_437_xmc.c.

Referenced by sdram_init_sequence().

◆ xmc_sdram_reset()

void xmc_sdram_reset ( xmc_sdram_bank_type xmc_bank )

xmc sdram registers reset

Parameters
xmc_bank this parameter can be one of the following values:
  • XMC_SDRAM_BANK1
  • XMC_SDRAM_BANK2
Return values
none

Definition at line 455 of file at32f435_437_xmc.c.

◆ xmc_sdram_status_get()

uint32_t xmc_sdram_status_get ( xmc_sdram_bank_type xmc_bank )

get sdram bank status

Parameters
xmc_bank specifies the xmc bank to be used this parameter can be one of the following values:
  • XMC_SDRAM_BANK1
  • XMC_SDRAM_BANK1
Return values
the bank status

Definition at line 578 of file at32f435_437_xmc.c.


AT32F435/437 Firmwary Library: AT32F435_437_middlewares_i2c_application_library

Modules
AT32F435_437_middlewares_i2c_application_library

Modules

I2C_library_event_check_flag
I2C_library_transmission_mode
I2C_library_status_code
I2C_library_handler
I2C_library_exported_functions

Detailed Description

< define to prevent recursive inclusion ----------------------------------—


AT32F435/437 Firmwary Library: I2C_library_event_check_flag

Macros
I2C_library_event_check_flag
AT32F435_437_middlewares_i2c_application_library

Macros

#define | I2C_EVENT_CHECK_NONE ((uint32_t)0x00000000)
#define | I2C_EVENT_CHECK_ACKFAIL ((uint32_t)0x00000001)
#define | I2C_EVENT_CHECK_STOP ((uint32_t)0x00000002)

Detailed Description

Macro Definition Documentation

◆ I2C_EVENT_CHECK_ACKFAIL

#define I2C_EVENT_CHECK_ACKFAIL ((uint32_t)0x00000001)

check flag ackfail

Definition at line 48 of file i2c_application.h.

◆ I2C_EVENT_CHECK_NONE

#define I2C_EVENT_CHECK_NONE ((uint32_t)0x00000000)

check flag none

Definition at line 47 of file i2c_application.h.

◆ I2C_EVENT_CHECK_STOP

#define I2C_EVENT_CHECK_STOP ((uint32_t)0x00000002)

check flag stop

Definition at line 49 of file i2c_application.h.


AT32F435/437 Firmwary Library: I2C_library_transmission_mode

Enumerations
I2C_library_transmission_mode
AT32F435_437_middlewares_i2c_application_library

Enumerations

enum i2c_mode_type {
I2C_INT_MA_TX = 0 , I2C_INT_MA_RX , I2C_INT_SLA_TX , I2C_INT_SLA_RX ,
I2C_DMA_MA_TX , I2C_DMA_MA_RX , I2C_DMA_SLA_TX , I2C_DMA_SLA_RX
}

Detailed Description

Enumeration Type Documentation

◆ i2c_mode_type

enum i2c_mode_type
Enumerator
I2C_INT_MA_TX
I2C_INT_MA_RX
I2C_INT_SLA_TX
I2C_INT_SLA_RX
I2C_DMA_MA_TX
I2C_DMA_MA_RX
I2C_DMA_SLA_TX
I2C_DMA_SLA_RX

Definition at line 59 of file i2c_application.h.


AT32F435/437 Firmwary Library: I2C_library_status_code

Enumerations
I2C_library_status_code
AT32F435_437_middlewares_i2c_application_library

Enumerations

enum i2c_status_type {
I2C_OK = 0 , I2C_ERR_STEP_1 , I2C_ERR_STEP_2 , I2C_ERR_STEP_3 ,
I2C_ERR_STEP_4 , I2C_ERR_STEP_5 , I2C_ERR_STEP_6 , I2C_ERR_STEP_7 ,
I2C_ERR_STEP_8 , I2C_ERR_STEP_9 , I2C_ERR_STEP_10 , I2C_ERR_STEP_11 ,
I2C_ERR_STEP_12 , I2C_ERR_TCRLD , I2C_ERR_TDC , I2C_ERR_ADDR ,
I2C_ERR_STOP , I2C_ERR_ACKFAIL , I2C_ERR_TIMEOUT , I2C_ERR_INTERRUPT
}

Detailed Description

Enumeration Type Documentation

◆ i2c_status_type

enum i2c_status_type
Enumerator
I2C_OK | no error
I2C_ERR_STEP_1 | step 1 error
I2C_ERR_STEP_2 | step 2 error
I2C_ERR_STEP_3 | step 3 error
I2C_ERR_STEP_4 | step 4 error
I2C_ERR_STEP_5 | step 5 error
I2C_ERR_STEP_6 | step 6 error
I2C_ERR_STEP_7 | step 7 error
I2C_ERR_STEP_8 | step 8 error
I2C_ERR_STEP_9 | step 9 error
I2C_ERR_STEP_10 | step 10 error
I2C_ERR_STEP_11 | step 11 error
I2C_ERR_STEP_12 | step 12 error
I2C_ERR_TCRLD | tcrld error
I2C_ERR_TDC | tdc error
I2C_ERR_ADDR | addr error
I2C_ERR_STOP | stop error
I2C_ERR_ACKFAIL | ackfail error
I2C_ERR_TIMEOUT | timeout error
I2C_ERR_INTERRUPT | interrupt error

Definition at line 79 of file i2c_application.h.


AT32F435/437 Firmwary Library: I2C_library_handler

Data Structures
I2C_library_handler
AT32F435_437_middlewares_i2c_application_library

Data Structures

struct i2c_handle_type

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: i2c_handle_type Struct Reference

Data Fields
i2c_handle_type Struct Reference
AT32F435_437_middlewares_i2c_application_library » I2C_library_handler

#include <i2c_application.h>

Data Fields

i2c_type * i2cx
uint8_t * | pbuff
__IO uint16_t | psize
__IO uint16_t | pcount
__IO uint32_t | mode
__IO uint32_t | status
__IO i2c_status_type | error_code
dma_channel_type * dma_tx_channel
dma_channel_type * dma_rx_channel
dma_init_type dma_init_struct

Detailed Description

Definition at line 111 of file i2c_application.h.

Field Documentation

◆ dma_init_struct

dma_init_type i2c_handle_type::dma_init_struct

dma init parameters

Definition at line 122 of file i2c_application.h.

Referenced by i2c_dma_config(), i2c_lowlevel_init(), and i2c_master_irq_handler_dma().

◆ dma_rx_channel

dma_channel_type* i2c_handle_type::dma_rx_channel

dma receive channel

Definition at line 121 of file i2c_application.h.

Referenced by i2c_dma_rx_irq_handler(), i2c_lowlevel_init(), i2c_master_receive_dma(), i2c_memory_read_dma(), and i2c_slave_receive_dma().

◆ dma_tx_channel

dma_channel_type* i2c_handle_type::dma_tx_channel

dma transmit channel

Definition at line 120 of file i2c_application.h.

Referenced by i2c_dma_config(), i2c_dma_tx_irq_handler(), i2c_lowlevel_init(), i2c_master_transmit_dma(), i2c_memory_write_dma(), and i2c_slave_transmit_dma().

◆ error_code

__IO i2c_status_type i2c_handle_type::error_code

i2c error code

Definition at line 119 of file i2c_application.h.

Referenced by i2c_err_irq_handler(), i2c_master_irq_handler_dma(), i2c_master_irq_handler_int(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), i2c_smbus_master_receive(), i2c_smbus_master_transmit(), i2c_smbus_slave_receive(), i2c_smbus_slave_transmit(), i2c_wait_end(), and i2c_wait_flag().

◆ i2cx

i2c_type* i2c_handle_type::i2cx

i2c registers base address

Definition at line 113 of file i2c_application.h.

Referenced by audio_codec_init(), i2c_config(), i2c_dma_config(), i2c_dma_tx_rx_irq_handler(), i2c_err_irq_handler(), i2c_lowlevel_init(), i2c_master_irq_handler_dma(), i2c_master_irq_handler_int(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_refresh_txdt_register(), i2c_reset_ctrl2_register(), i2c_slave_irq_handler_dma(), i2c_slave_irq_handler_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), i2c_smbus_master_receive(), i2c_smbus_master_transmit(), i2c_smbus_slave_receive(), i2c_smbus_slave_transmit(), i2c_start_transfer(), i2c_start_transfer_dma(), i2c_wait_flag(), main(), ov2640_i2c_init(), and ov5640_i2c_init().

◆ mode

__IO uint32_t i2c_handle_type::mode

i2c communication mode

Definition at line 117 of file i2c_application.h.

Referenced by i2c_dma_tx_rx_irq_handler(), i2c_evt_irq_handler(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit_dma(), and i2c_slave_transmit_int().

◆ pbuff

uint8_t* i2c_handle_type::pbuff

pointer to i2c transfer buffer

Definition at line 114 of file i2c_application.h.

Referenced by i2c_dma_tx_rx_irq_handler(), i2c_master_irq_handler_int(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_irq_handler_dma(), i2c_slave_irq_handler_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), i2c_smbus_master_receive(), i2c_smbus_master_transmit(), i2c_smbus_slave_receive(), i2c_smbus_slave_transmit(), and i2c_start_transfer_dma().

◆ pcount

__IO uint16_t i2c_handle_type::pcount

i2c transfer counter

Definition at line 116 of file i2c_application.h.

Referenced by i2c_dma_tx_rx_irq_handler(), i2c_master_irq_handler_dma(), i2c_master_irq_handler_int(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_irq_handler_dma(), i2c_slave_irq_handler_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), i2c_smbus_master_receive(), i2c_smbus_master_transmit(), i2c_smbus_slave_receive(), i2c_smbus_slave_transmit(), i2c_start_transfer(), and i2c_start_transfer_dma().

◆ psize

__IO uint16_t i2c_handle_type::psize

i2c transfer size

Definition at line 115 of file i2c_application.h.

Referenced by i2c_dma_tx_rx_irq_handler(), i2c_master_irq_handler_int(), i2c_master_receive(), i2c_master_transmit(), i2c_memory_read(), i2c_memory_write(), i2c_memory_write_int(), i2c_slave_irq_handler_dma(), i2c_slave_irq_handler_int(), i2c_smbus_master_receive(), i2c_smbus_master_transmit(), i2c_start_transfer(), and i2c_start_transfer_dma().

◆ status

__IO uint32_t i2c_handle_type::status

i2c communication status

Definition at line 118 of file i2c_application.h.

Referenced by i2c_master_irq_handler_dma(), i2c_master_irq_handler_int(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_irq_handler_dma(), i2c_slave_irq_handler_int(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), and i2c_wait_end().

The documentation for this struct was generated from the following file:
  • i2c_application.h


AT32F435/437 Firmwary Library: I2C_library_exported_functions

Functions
I2C_library_exported_functions
AT32F435_437_middlewares_i2c_application_library

Functions

void | i2c_config (i2c_handle_type *hi2c)
i2c peripheral initialization. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | i2c_reset_ctrl2_register (i2c_handle_type *hi2c)
reset ctrl2 register. More...
i2c_status_type | i2c_wait_end (i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end. More...
i2c_status_type | i2c_wait_flag (i2c_handle_type *hi2c, uint32_t flag, uint32_t event_check, uint32_t timeout)
wait for the flag to be set or reset, only BUSYF flag is waiting to be reset, and other flags are waiting to be set More...
i2c_status_type | i2c_master_transmit (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode. More...
i2c_status_type | i2c_master_receive (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through polling mode. More...
i2c_status_type | i2c_slave_transmit (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through polling mode. More...
i2c_status_type | i2c_slave_receive (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through polling mode. More...
i2c_status_type | i2c_master_transmit_int (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through interrupt mode. More...
i2c_status_type | i2c_master_receive_int (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through interrupt mode. More...
i2c_status_type | i2c_slave_transmit_int (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through interrupt mode. More...
i2c_status_type | i2c_slave_receive_int (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through interrupt mode. More...
i2c_status_type | i2c_master_transmit_dma (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through dma mode. More...
i2c_status_type | i2c_master_receive_dma (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through dma mode. More...
i2c_status_type | i2c_slave_transmit_dma (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through dma mode. More...
i2c_status_type | i2c_slave_receive_dma (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through dma mode. More...
i2c_status_type | i2c_smbus_master_transmit (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through SMBus mode. More...
i2c_status_type | i2c_smbus_master_receive (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through SMBus mode. More...
i2c_status_type | i2c_smbus_slave_transmit (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through SMBus mode. More...
i2c_status_type | i2c_smbus_slave_receive (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through SMBus mode. More...
i2c_status_type | i2c_memory_write (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through polling mode. More...
i2c_status_type | i2c_memory_write_int (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through interrupt mode. More...
i2c_status_type | i2c_memory_write_dma (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through dma mode. More...
i2c_status_type | i2c_memory_read (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode. More...
i2c_status_type | i2c_memory_read_int (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through interrupt mode. More...
i2c_status_type | i2c_memory_read_dma (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode. More...
void | i2c_evt_irq_handler (i2c_handle_type *hi2c)
interrupt procession function. More...
void | i2c_err_irq_handler (i2c_handle_type *hi2c)
dma reveive complete interrupt function. More...
void | i2c_dma_tx_irq_handler (i2c_handle_type *hi2c)
dma transmission complete interrupt function. More...
void | i2c_dma_rx_irq_handler (i2c_handle_type *hi2c)
dma reveive complete interrupt function. More...

Detailed Description

Function Documentation

◆ i2c_config()

void i2c_config ( i2c_handle_type * hi2c )

i2c peripheral initialization.

Parameters
hi2c the handle points to the operation information.
Return values
none.

Definition at line 113 of file i2c_application.c.

Referenced by audio_codec_init(), main(), ov2640_i2c_init(), and ov5640_i2c_init().

◆ i2c_dma_rx_irq_handler()

void i2c_dma_rx_irq_handler ( i2c_handle_type * hi2c )

dma reveive complete interrupt function.

Parameters
hi2c the handle points to the operation information.
Return values
none.

Definition at line 2130 of file i2c_application.c.

Referenced by DMA1_Channel2_IRQHandler().

◆ i2c_dma_tx_irq_handler()

void i2c_dma_tx_irq_handler ( i2c_handle_type * hi2c )

dma transmission complete interrupt function.

Parameters
hi2c the handle points to the operation information.
Return values
none.

Definition at line 2120 of file i2c_application.c.

Referenced by DMA1_Channel1_IRQHandler().

◆ i2c_err_irq_handler()

void i2c_err_irq_handler ( i2c_handle_type * hi2c )

dma reveive complete interrupt function.

Parameters
hi2c the handle points to the operation information.
Return values
none.

< i2c bus error flag

< i2c bus error flag

< i2c arbitration lost flag

< i2c arbitration lost flag

< i2c overflow or underflow flag

< i2c overflow or underflow flag

< i2c pec receive error flag

< i2c pec receive error flag

< i2c smbus timeout flag

< i2c smbus timeout flag

< i2c smbus alert flag

< i2c smbus alert flag

< i2c bus error interrupt

Definition at line 2174 of file i2c_application.c.

Referenced by I2C1_ERR_IRQHandler(), and I2C2_ERR_IRQHandler().

◆ i2c_evt_irq_handler()

void i2c_evt_irq_handler ( i2c_handle_type * hi2c )

interrupt procession function.

Parameters
hi2c the handle points to the operation information.
Return values
none.

Definition at line 2140 of file i2c_application.c.

Referenced by I2C1_EVT_IRQHandler(), and I2C2_EVT_IRQHandler().

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
none
Return values
none
Parameters
hi2c i2c_handle_type
Return values
none
Parameters
hi2c i2c_handle_type
Return values
none
Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 10

< gpio pins number 11

< gpio pins number 10

< gpio pins number 11

Definition at line 103 of file i2c_application.c.

Referenced by i2c_config().

◆ i2c_master_receive()

i2c_status_type i2c_master_receive | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master receive data through polling mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c receive data buffer full flag

< check flag ackfail

< i2c transmission is complete, waiting to load data

< check flag none

< i2c stop condition generation complete flag

< check flag ackfail

< i2c stop condition generation complete flag

Definition at line 524 of file i2c_application.c.

Referenced by main(), ov2640_reg_read(), and ov5640_reg_read().

◆ i2c_master_receive_dma()

i2c_status_type i2c_master_receive_dma | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master receive data through dma mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c bus error interrupt

< i2c ack fail interrupt

Definition at line 919 of file i2c_application.c.

Referenced by main().

◆ i2c_master_receive_int()

i2c_status_type i2c_master_receive_int | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master receive data through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c bus error interrupt

< i2c transmit data complete interrupt

< i2c stop detect interrupt

< i2c ack fail interrupt

< i2c receive data interrupt

Definition at line 764 of file i2c_application.c.

Referenced by main().

◆ i2c_master_transmit()

i2c_status_type i2c_master_transmit | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master transmits data through polling mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c send interrupt status

< check flag ackfail

< i2c transmission is complete, waiting to load data

< check flag ackfail

< i2c stop condition generation complete flag

< check flag ackfail

< i2c stop condition generation complete flag

Definition at line 375 of file i2c_application.c.

Referenced by audio_codec_init(), audio_codec_loop(), audio_codec_modify_freq(), main(), ov2640_reg_read(), ov2640_reg_write(), ov5640_reg_read(), and ov5640_reg_write().

◆ i2c_master_transmit_dma()

i2c_status_type i2c_master_transmit_dma | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master transmits data through dma mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c bus error interrupt

< i2c ack fail interrupt

Definition at line 835 of file i2c_application.c.

Referenced by main().

◆ i2c_master_transmit_int()

i2c_status_type i2c_master_transmit_int | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master transmits data through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c bus error interrupt

< i2c transmit data complete interrupt

< i2c stop detect interrupt

< i2c ack fail interrupt

< i2c transmit data interrupt

Definition at line 695 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_read()

i2c_status_type i2c_memory_read | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

read data from memory device through polling mode.

Parameters
hi2c | the handle points to the operation information.
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c send interrupt status

< check flag ackfail

< i2c transmit data complete flag

< check flag none

< i2c receive data buffer full flag

< check flag ackfail

< i2c transmission is complete, waiting to load data

< check flag none

< i2c stop condition generation complete flag

< check flag ackfail

< i2c stop condition generation complete flag

Definition at line 1084 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_read_dma()

i2c_status_type i2c_memory_read_dma | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

read data from memory device through polling mode.

Parameters
hi2c | the handle points to the operation information.
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c send interrupt status

< check flag ackfail

< i2c transmit data complete flag

< check flag none

< i2c bus error interrupt

< i2c ack fail interrupt

Definition at line 1331 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_read_int()

i2c_status_type i2c_memory_read_int | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

read data from memory device through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c send interrupt status

< check flag ackfail

< i2c transmit data complete flag

< check flag none

< i2c bus error interrupt

< i2c transmit data complete interrupt

< i2c stop detect interrupt

< i2c ack fail interrupt

< i2c receive data interrupt

Definition at line 1217 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_write()

i2c_status_type i2c_memory_write | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

write data to the memory device through polling mode.

Parameters
hi2c | the handle points to the operation information.
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c send interrupt status

< check flag ackfail

< i2c send interrupt status

< check flag ackfail

< i2c transmission is complete, waiting to load data

< check flag ackfail

< i2c stop condition generation complete flag

< check flag ackfail

< i2c stop condition generation complete flag

Definition at line 1004 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_write_dma()

i2c_status_type i2c_memory_write_dma | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

write data to the memory device through dma mode.

Parameters
hi2c | the handle points to the operation information.
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c send interrupt status

< check flag ackfail

< i2c transmission is complete, waiting to load data

< check flag none

< i2c bus error interrupt

< i2c ack fail interrupt

Definition at line 1271 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_write_int()

i2c_status_type i2c_memory_write_int | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

write data to the memory device through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c send interrupt status

< check flag ackfail

< i2c bus error interrupt

< i2c transmit data complete interrupt

< i2c stop detect interrupt

< i2c ack fail interrupt

< i2c transmit data interrupt

Definition at line 1170 of file i2c_application.c.

Referenced by main().

◆ i2c_reset_ctrl2_register()

void i2c_reset_ctrl2_register ( i2c_handle_type * hi2c )

reset ctrl2 register.

Parameters
hi2c the handle points to the operation information.
Return values
none.

Definition at line 150 of file i2c_application.c.

Referenced by i2c_master_irq_handler_dma(), i2c_master_irq_handler_int(), i2c_master_receive(), i2c_master_transmit(), i2c_memory_read(), i2c_memory_write(), i2c_slave_irq_handler_dma(), i2c_slave_irq_handler_int(), i2c_smbus_master_receive(), i2c_smbus_master_transmit(), i2c_smbus_slave_transmit(), and i2c_wait_flag().

◆ i2c_slave_receive()

i2c_status_type i2c_slave_receive | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave receive data through polling mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< check flag none

< i2c 0~7 bit address match flag

< i2c receive data buffer full flag

< check flag stop

< i2c receive data buffer full flag

< i2c stop condition generation complete flag

< check flag none

< i2c stop condition generation complete flag

< i2c bus busy flag transmission mode

< check flag none

Definition at line 441 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_receive_dma()

i2c_status_type i2c_slave_receive_dma | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave receive data through dma mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c address match interrupt

< i2c stop detect interrupt

< i2c ack fail interrupt

< i2c bus error interrupt

Definition at line 875 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_receive_int()

i2c_status_type i2c_slave_receive_int | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave receive data through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c bus error interrupt

< i2c transmit data complete interrupt

< i2c stop detect interrupt

< i2c ack fail interrupt

< i2c address match interrupt

< i2c receive data interrupt

Definition at line 729 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_transmit()

i2c_status_type i2c_slave_transmit | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave transmits data through polling mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< check flag none

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< check flag none

< i2c 0~7 bit address match flag

< i2c send interrupt status

< check flag ackfail

< i2c acknowledge failure flag

< check flag none

< i2c acknowledge failure flag

< i2c stop condition generation complete flag

< check flag none

< i2c stop condition generation complete flag

< i2c bus busy flag transmission mode

< check flag none

Definition at line 590 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_transmit_dma()

i2c_status_type i2c_slave_transmit_dma | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave transmits data through dma mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c address match interrupt

< i2c stop detect interrupt

< i2c ack fail interrupt

< i2c bus error interrupt

Definition at line 959 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_transmit_int()

i2c_status_type i2c_slave_transmit_int | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave transmits data through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c bus error interrupt

< i2c transmit data complete interrupt

< i2c stop detect interrupt

< i2c ack fail interrupt

< i2c address match interrupt

< i2c transmit data interrupt

Definition at line 798 of file i2c_application.c.

Referenced by main().

◆ i2c_smbus_master_receive()

i2c_status_type i2c_smbus_master_receive | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master receive data through SMBus mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c receive data buffer full flag

< check flag ackfail

< i2c transmission is complete, waiting to load data

< check flag none

< i2c stop condition generation complete flag

< check flag ackfail

< i2c stop condition generation complete flag

Definition at line 1556 of file i2c_application.c.

Referenced by main().

◆ i2c_smbus_master_transmit()

i2c_status_type i2c_smbus_master_transmit | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master transmits data through SMBus mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c send interrupt status

< check flag ackfail

< i2c transmission is complete, waiting to load data

< check flag ackfail

< i2c stop condition generation complete flag

< check flag ackfail

< i2c stop condition generation complete flag

Definition at line 1390 of file i2c_application.c.

Referenced by main().

◆ i2c_smbus_slave_receive()

i2c_status_type i2c_smbus_slave_receive | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave receive data through SMBus mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c 0~7 bit address match flag

< check flag none

< i2c 0~7 bit address match flag

< i2c receive data buffer full flag

< check flag stop

< i2c receive data buffer full flag

< i2c stop condition generation complete flag

< check flag none

< i2c stop condition generation complete flag

< i2c bus busy flag transmission mode

< check flag none

Definition at line 1464 of file i2c_application.c.

Referenced by main().

◆ i2c_smbus_slave_transmit()

i2c_status_type i2c_smbus_slave_transmit | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave transmits data through SMBus mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c 0~7 bit address match flag

< check flag none

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< check flag none

< i2c 0~7 bit address match flag

< i2c send interrupt status

< check flag ackfail

< i2c acknowledge failure flag

< check flag none

< i2c acknowledge failure flag

< i2c stop condition generation complete flag

< check flag none

< i2c stop condition generation complete flag

< i2c bus busy flag transmission mode

< check flag none

Definition at line 1628 of file i2c_application.c.

Referenced by main().

◆ i2c_wait_end()

i2c_status_type i2c_wait_end | ( | i2c_handle_type * | hi2c,
 |  | uint32_t | timeout
 | ) |  |

wait for the transfer to end.

Parameters
hi2c | the handle points to the operation information.
timeout | maximum waiting time.
Return values
i2c status.

Definition at line 165 of file i2c_application.c.

Referenced by main().

◆ i2c_wait_flag()

i2c_status_type i2c_wait_flag | ( | i2c_handle_type * | hi2c,
 |  | uint32_t | flag,
 |  | uint32_t | event_check,
 |  | uint32_t | timeout
 | ) |  |

wait for the flag to be set or reset, only BUSYF flag is waiting to be reset, and other flags are waiting to be set

Parameters
hi2c | the handle points to the operation information.
flag specifies the flag to check. this parameter can be one of the following values:
  • I2C_TDBE_FLAG: transmit data buffer empty flag.
  • I2C_TDIS_FLAG: send interrupt status.
  • I2C_RDBF_FLAG: receive data buffer full flag.
  • I2C_ADDRF_FLAG: 0~7 bit address match flag.
  • I2C_ACKFAIL_FLAG: acknowledge failure flag.
  • I2C_STOPF_FLAG: stop condition generation complete flag.
  • I2C_TDC_FLAG: transmit data complete flag.
  • I2C_TCRLD_FLAG: transmission is complete, waiting to load data.
  • I2C_BUSERR_FLAG: bus error flag.
  • I2C_ARLOST_FLAG: arbitration lost flag.
  • I2C_OUF_FLAG: overflow or underflow flag.
  • I2C_PECERR_FLAG: pec receive error flag.
  • I2C_TMOUT_FLAG: smbus timeout flag.
  • I2C_ALERTF_FLAG: smbus alert flag.
  • I2C_BUSYF_FLAG: bus busy flag transmission mode.
  • I2C_SDIR_FLAG: slave data transmit direction.
event_check check other error flags while waiting for the flag. parameter as following values:
  • I2C_EVENT_CHECK_NONE
  • I2C_EVENT_CHECK_ACKFAIL
  • I2C_EVENT_CHECK_STOP
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag ackfail

< i2c acknowledge failure flag

< i2c acknowledge failure flag

< check flag stop

< i2c stop condition generation complete flag

< i2c stop condition generation complete flag

Definition at line 214 of file i2c_application.c.

Referenced by i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), i2c_smbus_master_receive(), i2c_smbus_master_transmit(), i2c_smbus_slave_receive(), and i2c_smbus_slave_transmit().


AT32F435/437 Firmwary Library: AT32F435_437_middlewares_usb_drivers

Modules
AT32F435_437_middlewares_usb_drivers

Modules

USB_drivers_core
usb global drivers core
USB_standard

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: USB_drivers_core

Modules
USB_drivers_core
AT32F435_437_middlewares_usb_drivers

usb global drivers core More...

Modules

USB_core_exported_types
USB_core_private_functions

Detailed Description

usb global drivers core


AT32F435/437 Firmwary Library: USB_core_exported_types

Data Structures | Enumerations
USB_core_exported_types
AT32F435_437_middlewares_usb_drivers » USB_drivers_core

Data Structures

struct | usb_core_cfg
usb core cofig struct More...
struct | otg_core_type
usb otg core struct type More...

Enumerations

enum usb_speed_type { USB_LOW_SPEED_CORE_ID , USB_FULL_SPEED_CORE_ID , USB_HIGH_SPEED_CORE_ID }
usb core speed select More...

Detailed Description

Enumeration Type Documentation

◆ usb_speed_type

enum usb_speed_type

usb core speed select

Enumerator
USB_LOW_SPEED_CORE_ID | usb low speed core id
USB_FULL_SPEED_CORE_ID | usb full speed core id
USB_HIGH_SPEED_CORE_ID | usb high speed core id

Definition at line 61 of file usb_core.h.


AT32F435/437 Firmwary Library: usb_core_cfg Struct Reference

Data Fields
usb_core_cfg Struct Reference
AT32F435_437_middlewares_usb_drivers » USB_drivers_core » USB_core_exported_types

usb core cofig struct More...

#include <usb_core.h>

Data Fields

uint8_t | speed
uint8_t | dma_en
uint8_t | hc_num
uint8_t | ept_num
uint16_t | max_size
uint16_t | fifo_size
uint8_t | phy_itface
uint8_t | core_id
uint8_t | low_power
uint8_t | sof_out
uint8_t | usb_id
uint8_t | vbusig

Detailed Description

usb core cofig struct

Definition at line 71 of file usb_core.h.

Field Documentation

◆ core_id

uint8_t usb_core_cfg::core_id

the usb otg core id

Definition at line 81 of file usb_core.h.

Referenced by usb_core_config().

◆ dma_en

uint8_t usb_core_cfg::dma_en

dma enable state, not use

Definition at line 74 of file usb_core.h.

◆ ept_num

uint8_t usb_core_cfg::ept_num

the otg device support number of endpoint

Definition at line 76 of file usb_core.h.

Referenced by usb_core_config().

◆ fifo_size

uint16_t usb_core_cfg::fifo_size

the usb otg total file size

Definition at line 79 of file usb_core.h.

Referenced by usb_core_config().

◆ hc_num

uint8_t usb_core_cfg::hc_num

the otg host support number of channel

Definition at line 75 of file usb_core.h.

Referenced by usb_core_config().

◆ low_power

uint8_t usb_core_cfg::low_power

the usb otg low power option

Definition at line 82 of file usb_core.h.

◆ max_size

uint16_t usb_core_cfg::max_size

support max packet size

Definition at line 78 of file usb_core.h.

Referenced by usb_core_config().

◆ phy_itface

uint8_t usb_core_cfg::phy_itface

usb phy select

Definition at line 80 of file usb_core.h.

Referenced by usb_core_config().

◆ sof_out

uint8_t usb_core_cfg::sof_out

the sof signal output

Definition at line 83 of file usb_core.h.

Referenced by usb_core_config().

◆ speed

uint8_t usb_core_cfg::speed

otg speed

Definition at line 73 of file usb_core.h.

Referenced by usb_core_config().

◆ usb_id

uint8_t usb_core_cfg::usb_id

select otgfs1 or otgfs2

Definition at line 84 of file usb_core.h.

◆ vbusig

uint8_t usb_core_cfg::vbusig

vbus ignore

Definition at line 85 of file usb_core.h.

Referenced by usb_core_config().

The documentation for this struct was generated from the following file:
  • usb_core.h


AT32F435/437 Firmwary Library: otg_core_type Struct Reference

Data Fields
otg_core_type Struct Reference
AT32F435_437_middlewares_usb_drivers » USB_drivers_core » USB_core_exported_types

usb otg core struct type More...

#include <usb_core.h>

Data Fields

usb_reg_type * usb_reg
usb_core_cfg cfg

Detailed Description

usb otg core struct type

Definition at line 91 of file usb_core.h.

Field Documentation

◆ cfg

usb_core_cfg otg_core_type::cfg

the usb otg core config type

Definition at line 102 of file usb_core.h.

Referenced by usb_core_config().

◆ usb_reg

usb_reg_type* otg_core_type::usb_reg

the usb otg register type

Definition at line 93 of file usb_core.h.

Referenced by usbd_irq_handler(), and usbh_irq_handler().

The documentation for this struct was generated from the following file:
  • usb_core.h


AT32F435/437 Firmwary Library: USB_core_private_functions

Functions
USB_core_private_functions
AT32F435_437_middlewares_usb_drivers » USB_drivers_core

Functions

usb_sts_type usb_core_config (otg_core_type *otgdev, uint8_t core_id)
usb core config More...

Detailed Description

Function Documentation

◆ usb_core_config()

usb_sts_type usb_core_config | ( | otg_core_type * | otgdev,
 |  | uint8_t | core_id
 | ) |  |

usb core config

Parameters
otgdev | to the structure of otg_core_type
core_id | usb core id number (USB_FULL_SPEED_CORE_ID)
Return values
usb_sts_type

Definition at line 49 of file usb_core.c.


AT32F435/437 Firmwary Library: USB_standard

Modules
USB_standard
AT32F435_437_middlewares_usb_drivers

Modules

USB_standard_define

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: USB_standard_define

Data Structures | Macros | Enumerations
USB_standard_define
AT32F435_437_middlewares_usb_drivers » USB_standard

Data Structures

struct | linecoding_type
usb cdc class set line coding struct More...
struct | usb_setup_type
format of usb setup data More...
struct | usb_device_desc_type
format of standard device descriptor More...
struct | usb_configuration_desc_type
format of standard configuration descriptor More...
struct | usb_interface_desc_type
format of standard interface descriptor More...
struct | usb_endpoint_desc_type
format of standard endpoint descriptor More...
struct | usb_header_desc_type
format of header More...

Macros

#define | USB_REQ_RECIPIENT_DEVICE 0x00
usb request recipient More...
#define | USB_REQ_RECIPIENT_INTERFACE 0x01
#define | USB_REQ_RECIPIENT_ENDPOINT 0x02
#define | USB_REQ_RECIPIENT_OTHER 0x03
#define | USB_REQ_RECIPIENT_MASK 0x1F
#define | USB_REQ_TYPE_STANDARD 0x00
usb request type More...
#define | USB_REQ_TYPE_CLASS 0x20
#define | USB_REQ_TYPE_VENDOR 0x40
#define | USB_REQ_TYPE_RESERVED 0x60
#define | USB_REQ_DIR_HTD 0x00
usb request data transfer direction More...
#define | USB_REQ_DIR_DTH 0x80
#define | USB_STD_REQ_GET_STATUS 0
usb standard device requests codes More...
#define | USB_STD_REQ_CLEAR_FEATURE 1
#define | USB_STD_REQ_SET_FEATURE 3
#define | USB_STD_REQ_SET_ADDRESS 5
#define | USB_STD_REQ_GET_DESCRIPTOR 6
#define | USB_STD_REQ_SET_DESCRIPTOR 7
#define | USB_STD_REQ_GET_CONFIGURATION 8
#define | USB_STD_REQ_SET_CONFIGURATION 9
#define | USB_STD_REQ_GET_INTERFACE 10
#define | USB_STD_REQ_SET_INTERFACE 11
#define | USB_STD_REQ_SYNCH_FRAME 12
#define | USB_DESCIPTOR_TYPE_DEVICE 1
usb standard device type More...
#define | USB_DESCIPTOR_TYPE_CONFIGURATION 2
#define | USB_DESCIPTOR_TYPE_STRING 3
#define | USB_DESCIPTOR_TYPE_INTERFACE 4
#define | USB_DESCIPTOR_TYPE_ENDPOINT 5
#define | USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER 6
#define | USB_DESCIPTOR_TYPE_OTHER_SPEED 7
#define | USB_DESCIPTOR_TYPE_INTERFACE_POWER 8
#define | USB_LANGID_STRING 0
usb standard string type More...
#define | USB_MFC_STRING 1
#define | USB_PRODUCT_STRING 2
#define | USB_SERIAL_STRING 3
#define | USB_CONFIG_STRING 4
#define | USB_INTERFACE_STRING 5
#define | USB_CONF_REMOTE_WAKEUP 2
usb configuration attributes More...
#define | USB_CONF_SELF_POWERED 1
#define | USB_FEATURE_EPT_HALT 0
usb standard feature selectors More...
#define | USB_FEATURE_REMOTE_WAKEUP 1
#define | USB_FEATURE_TEST_MODE 2
#define | USB_EPT0_IDLE 0
endpoint 0 state More...
#define | USB_EPT0_SETUP 1
#define | USB_EPT0_DATA_IN 2
#define | USB_EPT0_DATA_OUT 3
#define | USB_EPT0_STATUS_IN 4
#define | USB_EPT0_STATUS_OUT 5
#define | USB_EPT0_STALL 6
#define | USB_DEVICE_QUALIFIER_DESC_LEN 0x0A
usb descriptor length More...
#define | USB_DEVICE_DESC_LEN 0x12
#define | USB_DEVICE_CFG_DESC_LEN 0x09
#define | USB_DEVICE_IF_DESC_LEN 0x09
#define | USB_DEVICE_EPT_LEN 0x07
#define | USB_DEVICE_OTG_DESC_LEN 0x03
#define | USB_DEVICE_LANGID_STR_DESC_LEN 0x04
#define | USB_DEVICE_OTHER_SPEED_DESC_SIZ_LEN 0x09
#define | USB_CLASS_CODE_AUDIO 0x01
usb class code More...
#define | USB_CLASS_CODE_CDC 0x02
#define | USB_CLASS_CODE_HID 0x03
#define | USB_CLASS_CODE_PRINTER 0x07
#define | USB_CLASS_CODE_MSC 0x08
#define | USB_CLASS_CODE_HUB 0x09
#define | USB_CLASS_CODE_CDCDATA 0x0A
#define | USB_CLASS_CODE_CCID 0x0B
#define | USB_CLASS_CODE_VIDEO 0x0E
#define | USB_CLASS_CODE_VENDOR 0xFF
#define | USB_EPT_DESC_CONTROL 0x00
usb endpoint type More...
#define | USB_EPT_DESC_ISO 0x01
#define | USB_EPT_DESC_BULK 0x02
#define | USB_EPT_DESC_INTERRUPT 0x03
#define | USB_EPT_DESC_NSYNC 0x00
#define | USB_ETP_DESC_ASYNC 0x04
#define | USB_ETP_DESC_ADAPTIVE 0x08
#define | USB_ETP_DESC_SYNC 0x0C
#define | USB_EPT_DESC_DATA_EPT 0x00
#define | USB_EPT_DESC_FD_EPT 0x10
#define | USB_EPT_DESC_FDDATA_EPT 0x20
#define | USBD_CDC_CS_INTERFACE 0x24
usb cdc class descriptor define More...
#define | USBD_CDC_CS_ENDPOINT 0x25
#define | USBD_CDC_SUBTYPE_HEADER 0x00
usb cdc class sub-type define More...
#define | USBD_CDC_SUBTYPE_CMF 0x01
#define | USBD_CDC_SUBTYPE_ACM 0x02
#define | USBD_CDC_SUBTYPE_UFD 0x06
#define | SET_LINE_CODING 0x20
usb cdc class request code define More...
#define | GET_LINE_CODING 0x21
#define | HID_CLASS_DESC_HID 0x21
usb hid class descriptor define More...
#define | HID_CLASS_DESC_REPORT 0x22
#define | HID_CLASS_DESC_PHYSICAL 0x23
#define | HID_REQ_SET_PROTOCOL 0x0B
usb hid class request code define More...
#define | HID_REQ_GET_PROTOCOL 0x03
#define | HID_REQ_SET_IDLE 0x0A
#define | HID_REQ_GET_IDLE 0x02
#define | HID_REQ_SET_REPORT 0x09
#define | HID_REQ_GET_REPORT 0x01
#define | HID_DESCRIPTOR_TYPE 0x21
#define | HID_REPORT_DESC 0x22
#define | USB_MAX_EP0_SIZE 64
endpoint 0 max size More...
#define | SWAPBYTE(addr)
usb swap address More...
#define | MIN(a, b) (uint16_t)(((a) < (b)) ? (a) : (b))
min and max define More...
#define | MAX(a, b) (uint16_t)(((a) > (b)) ? (a) : (b))
#define | LBYTE(x) ((uint8_t)(x & 0x00FF))
low byte and high byte define More...
#define | HBYTE(x) ((uint8_t)((x & 0xFF00) >>8))

Enumerations

enum usbd_conn_state { USB_CONN_STATE_DEFAULT =1 , USB_CONN_STATE_ADDRESSED , USB_CONN_STATE_CONFIGURED , USB_CONN_STATE_SUSPENDED }
usb device connect state More...
enum usb_sts_type {
USB_OK , USB_FAIL , USB_WAIT , USB_NOT_SUPPORT ,
USB_ERROR
}
usb return status More...

Detailed Description

Macro Definition Documentation

◆ GET_LINE_CODING

#define GET_LINE_CODING 0x21

Definition at line 207 of file usb_std.h.

◆ HBYTE

#define HBYTE ( x ) ((uint8_t)((x & 0xFF00) >>8))

high byte define

Definition at line 261 of file usb_std.h.

◆ HID_CLASS_DESC_HID

#define HID_CLASS_DESC_HID 0x21

usb hid class descriptor define

Definition at line 223 of file usb_std.h.

◆ HID_CLASS_DESC_PHYSICAL

#define HID_CLASS_DESC_PHYSICAL 0x23

Definition at line 225 of file usb_std.h.

◆ HID_CLASS_DESC_REPORT

#define HID_CLASS_DESC_REPORT 0x22

Definition at line 224 of file usb_std.h.

◆ HID_DESCRIPTOR_TYPE

#define HID_DESCRIPTOR_TYPE 0x21

Definition at line 236 of file usb_std.h.

◆ HID_REPORT_DESC

#define HID_REPORT_DESC 0x22

Definition at line 237 of file usb_std.h.

◆ HID_REQ_GET_IDLE

#define HID_REQ_GET_IDLE 0x02

Definition at line 233 of file usb_std.h.

◆ HID_REQ_GET_PROTOCOL

#define HID_REQ_GET_PROTOCOL 0x03

Definition at line 231 of file usb_std.h.

◆ HID_REQ_GET_REPORT

#define HID_REQ_GET_REPORT 0x01

Definition at line 235 of file usb_std.h.

◆ HID_REQ_SET_IDLE

#define HID_REQ_SET_IDLE 0x0A

Definition at line 232 of file usb_std.h.

◆ HID_REQ_SET_PROTOCOL

#define HID_REQ_SET_PROTOCOL 0x0B

usb hid class request code define

Definition at line 230 of file usb_std.h.

◆ HID_REQ_SET_REPORT

#define HID_REQ_SET_REPORT 0x09

Definition at line 234 of file usb_std.h.

◆ LBYTE

#define LBYTE ( x ) ((uint8_t)(x & 0x00FF))

low byte and high byte define

low byte define

Definition at line 260 of file usb_std.h.

◆ MAX

#define MAX | ( | a,
 |  | b
 | ) | (uint16_t)(((a) > (b)) ? (a) : (b))

max define

Definition at line 255 of file usb_std.h.

◆ MIN

#define MIN | ( | a,
 |  | b
 | ) | (uint16_t)(((a) < (b)) ? (a) : (b))

min and max define

min define

Definition at line 254 of file usb_std.h.

◆ SET_LINE_CODING

#define SET_LINE_CODING 0x20

usb cdc class request code define

Definition at line 206 of file usb_std.h.

◆ SWAPBYTE

#define SWAPBYTE ( addr )
Value:
(uint16_t)(((uint16_t)(*((uint8_t *)(addr)))) + \
(((uint16_t)(*(((uint8_t *)(addr)) + 1))) << 8))

usb swap address

swap address

Definition at line 249 of file usb_std.h.

◆ USB_CLASS_CODE_AUDIO

#define USB_CLASS_CODE_AUDIO 0x01

usb class code

usb class code audio

Definition at line 161 of file usb_std.h.

◆ USB_CLASS_CODE_CCID

#define USB_CLASS_CODE_CCID 0x0B

usb class code ccid

Definition at line 168 of file usb_std.h.

◆ USB_CLASS_CODE_CDC

#define USB_CLASS_CODE_CDC 0x02

usb class code cdc

Definition at line 162 of file usb_std.h.

◆ USB_CLASS_CODE_CDCDATA

#define USB_CLASS_CODE_CDCDATA 0x0A

usb class code cdc data

Definition at line 167 of file usb_std.h.

◆ USB_CLASS_CODE_HID

#define USB_CLASS_CODE_HID 0x03

usb class code hid

Definition at line 163 of file usb_std.h.

◆ USB_CLASS_CODE_HUB

#define USB_CLASS_CODE_HUB 0x09

usb class code hub

Definition at line 166 of file usb_std.h.

◆ USB_CLASS_CODE_MSC

#define USB_CLASS_CODE_MSC 0x08

usb class code msc

Definition at line 165 of file usb_std.h.

◆ USB_CLASS_CODE_PRINTER

#define USB_CLASS_CODE_PRINTER 0x07

usb class code printer

Definition at line 164 of file usb_std.h.

◆ USB_CLASS_CODE_VENDOR

#define USB_CLASS_CODE_VENDOR 0xFF

usb class code vendor

Definition at line 170 of file usb_std.h.

◆ USB_CLASS_CODE_VIDEO

#define USB_CLASS_CODE_VIDEO 0x0E

usb class code video

Definition at line 169 of file usb_std.h.

◆ USB_CONF_REMOTE_WAKEUP

#define USB_CONF_REMOTE_WAKEUP 2

usb configuration attributes

usb configuration attributes remote wakeup

Definition at line 114 of file usb_std.h.

◆ USB_CONF_SELF_POWERED

#define USB_CONF_SELF_POWERED 1

usb configuration attributes self powered

Definition at line 115 of file usb_std.h.

◆ USB_CONFIG_STRING

#define USB_CONFIG_STRING 4

usb standard string type config

Definition at line 108 of file usb_std.h.

◆ USB_DESCIPTOR_TYPE_CONFIGURATION

#define USB_DESCIPTOR_TYPE_CONFIGURATION 2

usb standard device type configuration

Definition at line 93 of file usb_std.h.

◆ USB_DESCIPTOR_TYPE_DEVICE

#define USB_DESCIPTOR_TYPE_DEVICE 1

usb standard device type

usb standard device type device

Definition at line 92 of file usb_std.h.

◆ USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER

#define USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER 6

usb standard device type qualifier

Definition at line 97 of file usb_std.h.

◆ USB_DESCIPTOR_TYPE_ENDPOINT

#define USB_DESCIPTOR_TYPE_ENDPOINT 5

usb standard device type endpoint

Definition at line 96 of file usb_std.h.

◆ USB_DESCIPTOR_TYPE_INTERFACE

#define USB_DESCIPTOR_TYPE_INTERFACE 4

usb standard device type interface

Definition at line 95 of file usb_std.h.

◆ USB_DESCIPTOR_TYPE_INTERFACE_POWER

#define USB_DESCIPTOR_TYPE_INTERFACE_POWER 8

usb standard device type interface power

Definition at line 99 of file usb_std.h.

◆ USB_DESCIPTOR_TYPE_OTHER_SPEED

#define USB_DESCIPTOR_TYPE_OTHER_SPEED 7

usb standard device type other speed

Definition at line 98 of file usb_std.h.

◆ USB_DESCIPTOR_TYPE_STRING

#define USB_DESCIPTOR_TYPE_STRING 3

usb standard device type string

Definition at line 94 of file usb_std.h.

◆ USB_DEVICE_CFG_DESC_LEN

#define USB_DEVICE_CFG_DESC_LEN 0x09

usb configuration descriptor length

Definition at line 151 of file usb_std.h.

◆ USB_DEVICE_DESC_LEN

#define USB_DEVICE_DESC_LEN 0x12

usb device descriptor length

Definition at line 150 of file usb_std.h.

◆ USB_DEVICE_EPT_LEN

#define USB_DEVICE_EPT_LEN 0x07

usb endpoint descriptor length

Definition at line 153 of file usb_std.h.

◆ USB_DEVICE_IF_DESC_LEN

#define USB_DEVICE_IF_DESC_LEN 0x09

usb interface descriptor length

Definition at line 152 of file usb_std.h.

◆ USB_DEVICE_LANGID_STR_DESC_LEN

#define USB_DEVICE_LANGID_STR_DESC_LEN 0x04

usb lang id string descriptor length

Definition at line 155 of file usb_std.h.

◆ USB_DEVICE_OTG_DESC_LEN

#define USB_DEVICE_OTG_DESC_LEN 0x03

usb otg descriptor length

Definition at line 154 of file usb_std.h.

◆ USB_DEVICE_OTHER_SPEED_DESC_SIZ_LEN

#define USB_DEVICE_OTHER_SPEED_DESC_SIZ_LEN 0x09

usb other speed descriptor length

Definition at line 156 of file usb_std.h.

◆ USB_DEVICE_QUALIFIER_DESC_LEN

#define USB_DEVICE_QUALIFIER_DESC_LEN 0x0A

usb descriptor length

usb qualifier descriptor length

Definition at line 149 of file usb_std.h.

◆ USB_EPT0_DATA_IN

#define USB_EPT0_DATA_IN 2

usb endpoint state data in

Definition at line 140 of file usb_std.h.

◆ USB_EPT0_DATA_OUT

#define USB_EPT0_DATA_OUT 3

usb endpoint state data out

Definition at line 141 of file usb_std.h.

◆ USB_EPT0_IDLE

#define USB_EPT0_IDLE 0

endpoint 0 state

usb endpoint state idle

Definition at line 138 of file usb_std.h.

◆ USB_EPT0_SETUP

#define USB_EPT0_SETUP 1

usb endpoint state setup

Definition at line 139 of file usb_std.h.

◆ USB_EPT0_STALL

#define USB_EPT0_STALL 6

usb endpoint state stall

Definition at line 144 of file usb_std.h.

◆ USB_EPT0_STATUS_IN

#define USB_EPT0_STATUS_IN 4

usb endpoint state status in

Definition at line 142 of file usb_std.h.

◆ USB_EPT0_STATUS_OUT

#define USB_EPT0_STATUS_OUT 5

usb endpoint state status out

Definition at line 143 of file usb_std.h.

◆ USB_EPT_DESC_BULK

#define USB_EPT_DESC_BULK 0x02

usb endpoint description type bulk

Definition at line 177 of file usb_std.h.

◆ USB_EPT_DESC_CONTROL

#define USB_EPT_DESC_CONTROL 0x00

usb endpoint type

usb endpoint description type control

Definition at line 175 of file usb_std.h.

◆ USB_EPT_DESC_DATA_EPT

#define USB_EPT_DESC_DATA_EPT 0x00

usb endpoint description data

Definition at line 185 of file usb_std.h.

◆ USB_EPT_DESC_FD_EPT

#define USB_EPT_DESC_FD_EPT 0x10

usb endpoint description fd

Definition at line 186 of file usb_std.h.

◆ USB_EPT_DESC_FDDATA_EPT

#define USB_EPT_DESC_FDDATA_EPT 0x20

usb endpoint description fddata

Definition at line 187 of file usb_std.h.

◆ USB_EPT_DESC_INTERRUPT

#define USB_EPT_DESC_INTERRUPT 0x03

usb endpoint description type interrupt

Definition at line 178 of file usb_std.h.

◆ USB_EPT_DESC_ISO

#define USB_EPT_DESC_ISO 0x01

usb endpoint description type iso

Definition at line 176 of file usb_std.h.

◆ USB_EPT_DESC_NSYNC

#define USB_EPT_DESC_NSYNC 0x00

usb endpoint description nsync

Definition at line 180 of file usb_std.h.

◆ USB_ETP_DESC_ADAPTIVE

#define USB_ETP_DESC_ADAPTIVE 0x08

usb endpoint description adaptive

Definition at line 182 of file usb_std.h.

◆ USB_ETP_DESC_ASYNC

#define USB_ETP_DESC_ASYNC 0x04

usb endpoint description async

Definition at line 181 of file usb_std.h.

◆ USB_ETP_DESC_SYNC

#define USB_ETP_DESC_SYNC 0x0C

usb endpoint description sync

Definition at line 183 of file usb_std.h.

◆ USB_FEATURE_EPT_HALT

#define USB_FEATURE_EPT_HALT 0

usb standard feature selectors

usb standard feature selectors endpoint halt

Definition at line 120 of file usb_std.h.

◆ USB_FEATURE_REMOTE_WAKEUP

#define USB_FEATURE_REMOTE_WAKEUP 1

usb standard feature selectors remote wakeup

Definition at line 121 of file usb_std.h.

◆ USB_FEATURE_TEST_MODE

#define USB_FEATURE_TEST_MODE 2

usb standard feature selectors test mode

Definition at line 122 of file usb_std.h.

◆ USB_INTERFACE_STRING

#define USB_INTERFACE_STRING 5

usb standard string type interface

Definition at line 109 of file usb_std.h.

◆ USB_LANGID_STRING

#define USB_LANGID_STRING 0

usb standard string type

usb standard string type lang id

Definition at line 104 of file usb_std.h.

◆ USB_MAX_EP0_SIZE

#define USB_MAX_EP0_SIZE 64

endpoint 0 max size

usb endpoint 0 max size

Definition at line 242 of file usb_std.h.

◆ USB_MFC_STRING

#define USB_MFC_STRING 1

usb standard string type mfc

Definition at line 105 of file usb_std.h.

◆ USB_PRODUCT_STRING

#define USB_PRODUCT_STRING 2

usb standard string type product

Definition at line 106 of file usb_std.h.

◆ USB_REQ_DIR_DTH

#define USB_REQ_DIR_DTH 0x80

usb request data transfer direction device to host

Definition at line 72 of file usb_std.h.

◆ USB_REQ_DIR_HTD

#define USB_REQ_DIR_HTD 0x00

usb request data transfer direction

usb request data transfer direction host to device

Definition at line 71 of file usb_std.h.

◆ USB_REQ_RECIPIENT_DEVICE

#define USB_REQ_RECIPIENT_DEVICE 0x00

usb request recipient

usb request recipient device

Definition at line 54 of file usb_std.h.

◆ USB_REQ_RECIPIENT_ENDPOINT

#define USB_REQ_RECIPIENT_ENDPOINT 0x02

usb request recipient endpoint

Definition at line 56 of file usb_std.h.

◆ USB_REQ_RECIPIENT_INTERFACE

#define USB_REQ_RECIPIENT_INTERFACE 0x01

usb request recipient interface

Definition at line 55 of file usb_std.h.

◆ USB_REQ_RECIPIENT_MASK

#define USB_REQ_RECIPIENT_MASK 0x1F

usb request recipient mask

Definition at line 58 of file usb_std.h.

◆ USB_REQ_RECIPIENT_OTHER

#define USB_REQ_RECIPIENT_OTHER 0x03

usb request recipient other

Definition at line 57 of file usb_std.h.

◆ USB_REQ_TYPE_CLASS

#define USB_REQ_TYPE_CLASS 0x20

usb request type class

Definition at line 64 of file usb_std.h.

◆ USB_REQ_TYPE_RESERVED

#define USB_REQ_TYPE_RESERVED 0x60

usb request type reserved

Definition at line 66 of file usb_std.h.

◆ USB_REQ_TYPE_STANDARD

#define USB_REQ_TYPE_STANDARD 0x00

usb request type

usb request type standard

Definition at line 63 of file usb_std.h.

◆ USB_REQ_TYPE_VENDOR

#define USB_REQ_TYPE_VENDOR 0x40

usb request type vendor

Definition at line 65 of file usb_std.h.

◆ USB_SERIAL_STRING

#define USB_SERIAL_STRING 3

usb standard string type serial

Definition at line 107 of file usb_std.h.

◆ USB_STD_REQ_CLEAR_FEATURE

#define USB_STD_REQ_CLEAR_FEATURE 1

usb request code clear feature

Definition at line 78 of file usb_std.h.

◆ USB_STD_REQ_GET_CONFIGURATION

#define USB_STD_REQ_GET_CONFIGURATION 8

usb request code get configuration

Definition at line 83 of file usb_std.h.

◆ USB_STD_REQ_GET_DESCRIPTOR

#define USB_STD_REQ_GET_DESCRIPTOR 6

usb request code get descriptor

Definition at line 81 of file usb_std.h.

◆ USB_STD_REQ_GET_INTERFACE

#define USB_STD_REQ_GET_INTERFACE 10

usb request code get interface

Definition at line 85 of file usb_std.h.

◆ USB_STD_REQ_GET_STATUS

#define USB_STD_REQ_GET_STATUS 0

usb standard device requests codes

usb request code status

Definition at line 77 of file usb_std.h.

◆ USB_STD_REQ_SET_ADDRESS

#define USB_STD_REQ_SET_ADDRESS 5

usb request code address

Definition at line 80 of file usb_std.h.

◆ USB_STD_REQ_SET_CONFIGURATION

#define USB_STD_REQ_SET_CONFIGURATION 9

usb request code set configuration

Definition at line 84 of file usb_std.h.

◆ USB_STD_REQ_SET_DESCRIPTOR

#define USB_STD_REQ_SET_DESCRIPTOR 7

usb request code set descriptor

Definition at line 82 of file usb_std.h.

◆ USB_STD_REQ_SET_FEATURE

#define USB_STD_REQ_SET_FEATURE 3

usb request code feature

Definition at line 79 of file usb_std.h.

◆ USB_STD_REQ_SET_INTERFACE

#define USB_STD_REQ_SET_INTERFACE 11

usb request code set interface

Definition at line 86 of file usb_std.h.

◆ USB_STD_REQ_SYNCH_FRAME

#define USB_STD_REQ_SYNCH_FRAME 12

usb request code synch frame

Definition at line 87 of file usb_std.h.

◆ USBD_CDC_CS_ENDPOINT

#define USBD_CDC_CS_ENDPOINT 0x25

Definition at line 193 of file usb_std.h.

◆ USBD_CDC_CS_INTERFACE

#define USBD_CDC_CS_INTERFACE 0x24

usb cdc class descriptor define

Definition at line 192 of file usb_std.h.

◆ USBD_CDC_SUBTYPE_ACM

#define USBD_CDC_SUBTYPE_ACM 0x02

Definition at line 200 of file usb_std.h.

◆ USBD_CDC_SUBTYPE_CMF

#define USBD_CDC_SUBTYPE_CMF 0x01

Definition at line 199 of file usb_std.h.

◆ USBD_CDC_SUBTYPE_HEADER

#define USBD_CDC_SUBTYPE_HEADER 0x00

usb cdc class sub-type define

Definition at line 198 of file usb_std.h.

◆ USBD_CDC_SUBTYPE_UFD

#define USBD_CDC_SUBTYPE_UFD 0x06

Definition at line 201 of file usb_std.h.

Enumeration Type Documentation

◆ usb_sts_type

enum usb_sts_type

usb return status

Enumerator
USB_OK | usb status ok
USB_FAIL | usb status fail
USB_WAIT | usb status wait
USB_NOT_SUPPORT | usb status not support
USB_ERROR | usb status error

Definition at line 266 of file usb_std.h.

◆ usbd_conn_state

enum usbd_conn_state

usb device connect state

Enumerator
USB_CONN_STATE_DEFAULT | usb device connect state default
USB_CONN_STATE_ADDRESSED | usb device connect state address
USB_CONN_STATE_CONFIGURED | usb device connect state configured
USB_CONN_STATE_SUSPENDED | usb device connect state suspend

Definition at line 127 of file usb_std.h.


AT32F435/437 Firmwary Library: linecoding_type Struct Reference

Data Fields
linecoding_type Struct Reference
AT32F435_437_middlewares_usb_drivers » USB_standard » USB_standard_define

usb cdc class set line coding struct More...

#include <usb_std.h>

Data Fields

uint32_t | bitrate
uint8_t | format
uint8_t | parity
uint8_t | data

Detailed Description

usb cdc class set line coding struct

Definition at line 212 of file usb_std.h.

Field Documentation

◆ bitrate

uint32_t linecoding_type::bitrate

Definition at line 214 of file usb_std.h.

Referenced by cdc_struct_init(), class_init_handler(), usb_usart_config(), and usb_vcp_cmd_process().

◆ data

uint8_t linecoding_type::data

Definition at line 217 of file usb_std.h.

Referenced by cdc_struct_init(), class_init_handler(), usb_usart_config(), and usb_vcp_cmd_process().

◆ format

uint8_t linecoding_type::format

Definition at line 215 of file usb_std.h.

Referenced by cdc_struct_init(), class_init_handler(), usb_usart_config(), and usb_vcp_cmd_process().

◆ parity

uint8_t linecoding_type::parity

Definition at line 216 of file usb_std.h.

Referenced by cdc_struct_init(), class_init_handler(), usb_usart_config(), and usb_vcp_cmd_process().

The documentation for this struct was generated from the following file:
  • usb_std.h


AT32F435/437 Firmwary Library: usb_setup_type Struct Reference

Data Fields
usb_setup_type Struct Reference
AT32F435_437_middlewares_usb_drivers » USB_standard » USB_standard_define

format of usb setup data More...

#include <usb_std.h>

Data Fields

uint8_t | bmRequestType
uint8_t | bRequest
uint16_t | wValue
uint16_t | wIndex
uint16_t | wLength

Detailed Description

format of usb setup data

Definition at line 279 of file usb_std.h.

Field Documentation

◆ bmRequestType

uint8_t usb_setup_type::bmRequestType

characteristics of request

Definition at line 281 of file usb_std.h.

Referenced by audio_req_set_cur(), cdc_class_setup_handler(), class_audio_setup_handler(), class_hid_setup_handler(), class_setup_handler(), keyboard_class_setup_handler(), msc_class_setup_handler(), usbd_device_request(), usbd_endpoint_request(), and usbd_setup_request_parse().

◆ bRequest

uint8_t usb_setup_type::bRequest

specific request

Definition at line 282 of file usb_std.h.

Referenced by cdc_class_setup_handler(), class_audio_setup_handler(), class_hid_setup_handler(), class_setup_handler(), keyboard_class_setup_handler(), msc_class_setup_handler(), usbd_endpoint_request(), and usbd_setup_request_parse().

◆ wIndex

uint16_t usb_setup_type::wIndex

word-sized field that varies according to request typically used to pass an index or offset

Definition at line 284 of file usb_std.h.

Referenced by audio_get_interface(), audio_req_get_cur(), audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), audio_req_set_cur(), audio_set_interface(), class_setup_handler(), msc_class_setup_handler(), usbd_endpoint_request(), usbd_set_address(), usbd_set_configuration(), and usbd_setup_request_parse().

◆ wLength

uint16_t usb_setup_type::wLength

number of bytes to transfer if there is a data stage

Definition at line 286 of file usb_std.h.

Referenced by audio_req_get_cur(), audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), audio_req_set_cur(), cdc_class_setup_handler(), class_audio_setup_handler(), class_hid_setup_handler(), class_setup_handler(), keyboard_class_setup_handler(), usbd_get_configuration(), usbd_interface_request(), usbd_set_address(), usbd_set_configuration(), and usbd_setup_request_parse().

◆ wValue

uint16_t usb_setup_type::wValue

word-sized field that varies according to request

Definition at line 283 of file usb_std.h.

Referenced by audio_req_get_cur(), audio_req_set_cur(), audio_set_interface(), cdc_class_setup_handler(), class_audio_setup_handler(), class_hid_setup_handler(), class_setup_handler(), keyboard_class_setup_handler(), msc_class_setup_handler(), usbd_clear_feature(), usbd_endpoint_request(), usbd_set_address(), usbd_set_configuration(), usbd_set_feature(), and usbd_setup_request_parse().

The documentation for this struct was generated from the following file:
  • usb_std.h


AT32F435/437 Firmwary Library: usb_device_desc_type Struct Reference

Data Fields
usb_device_desc_type Struct Reference
AT32F435_437_middlewares_usb_drivers » USB_standard » USB_standard_define

format of standard device descriptor More...

#include <usb_std.h>

Data Fields

uint8_t | bLength
uint8_t | bDescriptorType
uint16_t | bcdUSB
uint8_t | bDeviceClass
uint8_t | bDeviceSubClass
uint8_t | bDeviceProtocol
uint8_t | bMaxPacketSize0
uint16_t | idVendor
uint16_t | idProduct
uint16_t | bcdDevice
uint8_t | iManufacturer
uint8_t | iProduct
uint8_t | iSerialNumber
uint8_t | bNumConfigurations

Detailed Description

format of standard device descriptor

Definition at line 292 of file usb_std.h.

Field Documentation

◆ bcdDevice

uint16_t usb_device_desc_type::bcdDevice

device release number in binary-coded decimal

Definition at line 303 of file usb_std.h.

◆ bcdUSB

uint16_t usb_device_desc_type::bcdUSB

usb specification release number

Definition at line 296 of file usb_std.h.

◆ bDescriptorType

uint8_t usb_device_desc_type::bDescriptorType

device descriptor type

Definition at line 295 of file usb_std.h.

◆ bDeviceClass

uint8_t usb_device_desc_type::bDeviceClass

class code (assigned by the usb-if)

Definition at line 297 of file usb_std.h.

◆ bDeviceProtocol

uint8_t usb_device_desc_type::bDeviceProtocol

protocol code ((assigned by the usb-if))

Definition at line 299 of file usb_std.h.

◆ bDeviceSubClass

uint8_t usb_device_desc_type::bDeviceSubClass

subclass code (assigned by the usb-if)

Definition at line 298 of file usb_std.h.

◆ bLength

uint8_t usb_device_desc_type::bLength

size of this descriptor in bytes

Definition at line 294 of file usb_std.h.

◆ bMaxPacketSize0

uint8_t usb_device_desc_type::bMaxPacketSize0

maximum packet size for endpoint zero

Definition at line 300 of file usb_std.h.

◆ bNumConfigurations

uint8_t usb_device_desc_type::bNumConfigurations

number of possible configurations

Definition at line 307 of file usb_std.h.

◆ idProduct

uint16_t usb_device_desc_type::idProduct

product id ((assigned by the usb-if))

Definition at line 302 of file usb_std.h.

◆ idVendor

uint16_t usb_device_desc_type::idVendor

verndor id ((assigned by the usb-if))

Definition at line 301 of file usb_std.h.

◆ iManufacturer

uint8_t usb_device_desc_type::iManufacturer

index of string descriptor describing manufacturer

Definition at line 304 of file usb_std.h.

◆ iProduct

uint8_t usb_device_desc_type::iProduct

index of string descriptor describing product

Definition at line 305 of file usb_std.h.

◆ iSerialNumber

uint8_t usb_device_desc_type::iSerialNumber

index of string descriptor describing serial number

Definition at line 306 of file usb_std.h.

The documentation for this struct was generated from the following file:
  • usb_std.h


AT32F435/437 Firmwary Library: usb_configuration_desc_type Struct Reference

Data Fields
usb_configuration_desc_type Struct Reference
AT32F435_437_middlewares_usb_drivers » USB_standard » USB_standard_define

format of standard configuration descriptor More...

#include <usb_std.h>

Data Fields

uint8_t | bLength
uint8_t | bDescriptorType
uint16_t | wTotalLength
uint8_t | bNumInterfaces
uint8_t | bConfigurationValue
uint8_t | iConfiguration
uint8_t | bmAttributes
uint8_t | bMaxPower

Detailed Description

format of standard configuration descriptor

Definition at line 313 of file usb_std.h.

Field Documentation

◆ bConfigurationValue

uint8_t usb_configuration_desc_type::bConfigurationValue

value to use as an argument to the SetConfiguration() request

Definition at line 319 of file usb_std.h.

◆ bDescriptorType

uint8_t usb_configuration_desc_type::bDescriptorType

configuration descriptor type

Definition at line 316 of file usb_std.h.

◆ bLength

uint8_t usb_configuration_desc_type::bLength

size of this descriptor in bytes

Definition at line 315 of file usb_std.h.

◆ bmAttributes

uint8_t usb_configuration_desc_type::bmAttributes

configuration characteristics D7 reserved D6 self-powered D5 remote wakeup D4~D0 reserved

Definition at line 321 of file usb_std.h.

◆ bMaxPower

uint8_t usb_configuration_desc_type::bMaxPower

maximum power consumption of the usb device from the bus

Definition at line 326 of file usb_std.h.

◆ bNumInterfaces

uint8_t usb_configuration_desc_type::bNumInterfaces

number of interfaces supported by this configuration

Definition at line 318 of file usb_std.h.

◆ iConfiguration

uint8_t usb_configuration_desc_type::iConfiguration

index of string descriptor describing this configuration

Definition at line 320 of file usb_std.h.

◆ wTotalLength

uint16_t usb_configuration_desc_type::wTotalLength

total length of data returned for this configuration

Definition at line 317 of file usb_std.h.

The documentation for this struct was generated from the following file:
  • usb_std.h


AT32F435/437 Firmwary Library: usb_interface_desc_type Struct Reference

Data Fields
usb_interface_desc_type Struct Reference
AT32F435_437_middlewares_usb_drivers » USB_standard » USB_standard_define

format of standard interface descriptor More...

#include <usb_std.h>

Data Fields

uint8_t | bLength
uint8_t | bDescriptorType
uint8_t | bInterfaceNumber
uint8_t | bAlternateSetting
uint8_t | bNumEndpoints
uint8_t | bInterfaceClass
uint8_t | bInterfaceSubClass
uint8_t | bInterfaceProtocol
uint8_t | iInterface

Detailed Description

format of standard interface descriptor

Definition at line 334 of file usb_std.h.

Field Documentation

◆ bAlternateSetting

uint8_t usb_interface_desc_type::bAlternateSetting

value used to select this alternate setting for the interface

Definition at line 339 of file usb_std.h.

Referenced by usbh_parse_interface_desc().

◆ bDescriptorType

uint8_t usb_interface_desc_type::bDescriptorType

interface descriptor type

Definition at line 337 of file usb_std.h.

Referenced by usbh_parse_interface_desc().

◆ bInterfaceClass

uint8_t usb_interface_desc_type::bInterfaceClass

class code (assigned by the usb-if)

Definition at line 341 of file usb_std.h.

Referenced by usbh_parse_interface_desc().

◆ bInterfaceNumber

uint8_t usb_interface_desc_type::bInterfaceNumber

number of this interface

Definition at line 338 of file usb_std.h.

Referenced by usbh_parse_interface_desc().

◆ bInterfaceProtocol

uint8_t usb_interface_desc_type::bInterfaceProtocol

protocol code (assigned by the usb-if)

Definition at line 343 of file usb_std.h.

Referenced by usbh_parse_interface_desc().

◆ bInterfaceSubClass

uint8_t usb_interface_desc_type::bInterfaceSubClass

subclass code (assigned by the usb-if)

Definition at line 342 of file usb_std.h.

Referenced by usbh_parse_interface_desc().

◆ bLength

uint8_t usb_interface_desc_type::bLength

size of this descriptor in bytes

Definition at line 336 of file usb_std.h.

Referenced by usbh_parse_interface_desc().

◆ bNumEndpoints

uint8_t usb_interface_desc_type::bNumEndpoints

number of endpoints used by this interface

Definition at line 340 of file usb_std.h.

Referenced by usbh_parse_interface_desc().

◆ iInterface

uint8_t usb_interface_desc_type::iInterface

index of string descriptor describing this interface

Definition at line 344 of file usb_std.h.

Referenced by usbh_parse_interface_desc().

The documentation for this struct was generated from the following file:
  • usb_std.h


AT32F435/437 Firmwary Library: usb_endpoint_desc_type Struct Reference

Data Fields
usb_endpoint_desc_type Struct Reference
AT32F435_437_middlewares_usb_drivers » USB_standard » USB_standard_define

format of standard endpoint descriptor More...

#include <usb_std.h>

Data Fields

uint8_t | bLength
uint8_t | bDescriptorType
uint8_t | bEndpointAddress
uint8_t | bmAttributes
uint16_t | wMaxPacketSize
uint8_t | bInterval

Detailed Description

format of standard endpoint descriptor

Definition at line 350 of file usb_std.h.

Field Documentation

◆ bDescriptorType

uint8_t usb_endpoint_desc_type::bDescriptorType

endpoint descriptor type

Definition at line 353 of file usb_std.h.

Referenced by usbh_parse_endpoint_desc().

◆ bEndpointAddress

uint8_t usb_endpoint_desc_type::bEndpointAddress

the address of the endpoint on the usb device described by this descriptor

Definition at line 354 of file usb_std.h.

Referenced by usbh_parse_endpoint_desc().

◆ bInterval

uint8_t usb_endpoint_desc_type::bInterval

interval for polling endpoint for data transfers

Definition at line 357 of file usb_std.h.

Referenced by usbh_parse_endpoint_desc().

◆ bLength

uint8_t usb_endpoint_desc_type::bLength

size of this descriptor in bytes

Definition at line 352 of file usb_std.h.

Referenced by usbh_parse_endpoint_desc().

◆ bmAttributes

uint8_t usb_endpoint_desc_type::bmAttributes

describes the endpoints attributes when it is configured using bConfiguration value

Definition at line 355 of file usb_std.h.

Referenced by usbh_parse_endpoint_desc().

◆ wMaxPacketSize

uint16_t usb_endpoint_desc_type::wMaxPacketSize

maximum packet size this endpoint

Definition at line 356 of file usb_std.h.

Referenced by usbh_parse_endpoint_desc().

The documentation for this struct was generated from the following file:
  • usb_std.h


AT32F435/437 Firmwary Library: usb_header_desc_type Struct Reference

Data Fields
usb_header_desc_type Struct Reference
AT32F435_437_middlewares_usb_drivers » USB_standard » USB_standard_define

format of header More...

#include <usb_std.h>

Data Fields

uint8_t | bLength
uint8_t | bDescriptorType

Detailed Description

format of header

Definition at line 363 of file usb_std.h.

Field Documentation

◆ bDescriptorType

uint8_t usb_header_desc_type::bDescriptorType

descriptor type

Definition at line 366 of file usb_std.h.

◆ bLength

uint8_t usb_header_desc_type::bLength

size of this descriptor in bytes

Definition at line 365 of file usb_std.h.

Referenced by usbh_get_next_header().

The documentation for this struct was generated from the following file:
  • usb_std.h


AT32F435/437 Firmwary Library: AT32F435_437_middlewares_usbd_drivers

Modules
AT32F435_437_middlewares_usbd_drivers

Modules

USBD_drivers_core
usb device drivers core
USBD_drivers_interrupt
usb device interrupt
USBD_drivers_standard_request
usb device standard_request
USBD_drivers_int

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: USBD_drivers_core

Modules
USBD_drivers_core
AT32F435_437_middlewares_usbd_drivers

usb device drivers core More...

Modules

USBD_core_exported_types
USBD_core_private_functions

Detailed Description

usb device drivers core


AT32F435/437 Firmwary Library: USBD_core_exported_types

USBD_core_exported_types
AT32F435_437_middlewares_usbd_drivers » USBD_drivers_core


AT32F435/437 Firmwary Library: USBD_core_private_functions

Functions
USBD_core_private_functions
AT32F435_437_middlewares_usbd_drivers » USBD_drivers_core

Functions

void | usbd_core_in_handler (usbd_core_type *udev, uint8_t ept_addr)
usb core in transfer complete handler More...
void | usbd_core_out_handler (usbd_core_type *udev, uint8_t ept_addr)
usb core out transfer complete handler More...
void | usbd_core_setup_handler (usbd_core_type *udev, uint8_t ept_num)
usb core setup transfer complete handler More...
void | usbd_ctrl_send (usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data More...
void | usbd_ctrl_recv (usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint recv data More...
void | usbd_ctrl_send_status (usbd_core_type *udev)
usb control endpoint send in status More...
void | usbd_ctrl_recv_status (usbd_core_type *udev)
usb control endpoint send out status More...
void | usbd_clear_stall (usbd_core_type *udev, uint8_t ept_addr)
clear endpoint stall More...
void | usbd_set_stall (usbd_core_type *udev, uint8_t ept_addr)
usb set endpoint to stall status More...
void | usbd_ctrl_unsupport (usbd_core_type *udev)
un-support device request More...
uint32_t | usbd_get_recv_len (usbd_core_type *udev, uint8_t ept_addr)
get endpoint receive data length More...
void | usbd_ept_open (usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint More...
void | usbd_ept_close (usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint More...
void | usbd_connect (usbd_core_type *udev)
usb device connect to host More...
void | usbd_disconnect (usbd_core_type *udev)
usb device disconnect to host More...
void | usbd_set_device_addr (usbd_core_type *udev, uint8_t address)
usb device set device address. More...
void | usb_ept_default_init (usbd_core_type *udev)
usb endpoint structure initialization More...
void | usbd_ept_send (usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint send data More...
void | usbd_ept_recv (usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint receive data More...
usbd_conn_state | usbd_connect_state_get (usbd_core_type *udev)
get usb connect state More...
void | usbd_remote_wakeup (usbd_core_type *udev)
usb device remote wakeup More...
void | usbd_enter_suspend (usbd_core_type *udev)
usb device enter suspend mode More...
void | usbd_flush_tx_fifo (usbd_core_type *udev, uint8_t ept_num)
usb device flush in endpoint fifo More...
void | usbd_fifo_alloc (usbd_core_type *udev)
usb device endpoint fifo alloc More...
usb_sts_type | usbd_core_init (usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *class_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
usb device core initialization More...

Detailed Description

Function Documentation

◆ usb_ept_default_init()

void usb_ept_default_init ( usbd_core_type * udev )

usb endpoint structure initialization

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 400 of file usbd_core.c.

Referenced by usbd_core_init().

◆ usbd_clear_stall()

void usbd_clear_stall | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

clear endpoint stall

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 237 of file usbd_core.c.

Referenced by usbd_endpoint_request().

◆ usbd_connect()

void usbd_connect ( usbd_core_type * udev )

usb device connect to host

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 369 of file usbd_core.c.

Referenced by usb_reset(), and usbd_core_init().

◆ usbd_connect_state_get()

usbd_conn_state usbd_connect_state_get ( usbd_core_type * udev )

get usb connect state

Parameters
udev to the structure of usbd_core_type
Return values
usb connect state

Definition at line 597 of file usbd_core.c.

Referenced by audio_hid_class_send_report(), custom_hid_class_send_report(), main(), usb_iap_class_send_report(), usb_keyboard_class_send_report(), usb_mouse_class_send_report(), and usb_vcpkybrd_class_send_report().

◆ usbd_core_in_handler()

void usbd_core_in_handler | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

usb core in transfer complete handler

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 50 of file usbd_core.c.

Referenced by usbd_inept_handler().

◆ usbd_core_init()

usb_sts_type usbd_core_init | ( | usbd_core_type * | udev,
 |  | usb_reg_type * | usb_reg,
 |  | usbd_class_handler * | class_handler,
 |  | usbd_desc_handler * | desc_handler,
 |  | uint8_t | core_id
 | ) |  |

usb device core initialization

Parameters
udev | to the structure of usbd_core_type
usb_reg | usb otgfs peripheral global register this parameter can be one of the following values: OTG1_GLOBAL , OTG2_GLOBAL
class_handler | usb class handler
desc_handler | device config handler
core_id | usb core id number
Return values
usb_sts_type

Definition at line 744 of file usbd_core.c.

◆ usbd_core_out_handler()

void usbd_core_out_handler | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

usb core out transfer complete handler

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 101 of file usbd_core.c.

Referenced by usbd_outept_handler().

◆ usbd_core_setup_handler()

void usbd_core_setup_handler | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_num
 | ) |  |

usb core setup transfer complete handler

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 141 of file usbd_core.c.

Referenced by usbd_outept_handler().

◆ usbd_ctrl_recv()

void usbd_ctrl_recv | ( | usbd_core_type * | udev,
 |  | uint8_t * | buffer,
 |  | uint16_t | len
 | ) |  |

usb control endpoint recv data

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
buffer | recv data buffer
len | recv data length
Return values
none

Definition at line 196 of file usbd_core.c.

Referenced by audio_req_set_cur(), cdc_class_setup_handler(), class_hid_setup_handler(), class_setup_handler(), and keyboard_class_setup_handler().

◆ usbd_ctrl_recv_status()

void usbd_ctrl_recv_status ( usbd_core_type * udev )

usb control endpoint send out status

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 224 of file usbd_core.c.

Referenced by usbd_core_in_handler().

◆ usbd_ctrl_send()

void usbd_ctrl_send | ( | usbd_core_type * | udev,
 |  | uint8_t * | buffer,
 |  | uint16_t | len
 | ) |  |

usb control endpoint send data

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
buffer | send data buffer
len | send data length
Return values
none

Definition at line 177 of file usbd_core.c.

Referenced by audio_get_interface(), audio_req_get_cur(), audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), cdc_class_setup_handler(), class_audio_setup_handler(), class_hid_setup_handler(), class_setup_handler(), keyboard_class_setup_handler(), msc_class_setup_handler(), usbd_endpoint_request(), usbd_get_configuration(), usbd_get_descriptor(), and usbd_get_status().

◆ usbd_ctrl_send_status()

void usbd_ctrl_send_status ( usbd_core_type * udev )

usb control endpoint send in status

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 212 of file usbd_core.c.

Referenced by class_audio_setup_handler(), class_setup_handler(), msc_class_setup_handler(), usbd_clear_feature(), usbd_core_out_handler(), usbd_endpoint_request(), usbd_interface_request(), usbd_set_address(), usbd_set_configuration(), and usbd_set_feature().

◆ usbd_ctrl_unsupport()

void usbd_ctrl_unsupport ( usbd_core_type * udev )

un-support device request

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 287 of file usbd_core.c.

Referenced by cdc_class_setup_handler(), class_audio_setup_handler(), class_hid_setup_handler(), class_setup_handler(), keyboard_class_setup_handler(), msc_class_setup_handler(), usbd_clear_feature(), usbd_device_request(), usbd_endpoint_request(), usbd_get_configuration(), usbd_get_descriptor(), usbd_get_status(), usbd_interface_request(), usbd_set_address(), and usbd_set_configuration().

◆ usbd_disconnect()

void usbd_disconnect ( usbd_core_type * udev )

usb device disconnect to host

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 379 of file usbd_core.c.

Referenced by usb_reset(), and usbd_core_init().

◆ usbd_enter_suspend()

void usbd_enter_suspend ( usbd_core_type * udev )

usb device enter suspend mode

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 634 of file usbd_core.c.

Referenced by usbd_suspend_handler().

◆ usbd_ept_close()

void usbd_ept_close | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

usb close endpoint

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 346 of file usbd_core.c.

Referenced by class_clear_handler(), class_setup_handler(), and msc_class_setup_handler().

◆ usbd_ept_open()

void usbd_ept_open | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr,
 |  | uint8_t | ept_type,
 |  | uint16_t | maxpacket
 | ) |  |

usb open endpoint

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
ept_type | endpoint type
maxpacket | endpoint support max buffer size
Return values
none

Definition at line 314 of file usbd_core.c.

Referenced by class_init_handler(), class_setup_handler(), msc_class_setup_handler(), and usbd_enumdone_handler().

◆ usbd_ept_recv()

void usbd_ept_recv | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr,
 |  | uint8_t * | buffer,
 |  | uint16_t | len
 | ) |  |

endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
buffer | receive data buffer
len | receive data length
Return values
none

Definition at line 534 of file usbd_core.c.

Referenced by audio_set_interface(), bot_scsi_init(), bot_scsi_reset(), bot_scsi_send_csw(), bot_scsi_stall(), bot_scsi_write10(), class_init_handler(), class_out_handler(), usb_vcp_get_rxdata(), usb_vcpkybrd_vcp_get_rxdata(), usbd_core_in_handler(), usbd_core_out_handler(), usbd_ctrl_recv(), and usbd_ctrl_recv_status().

◆ usbd_ept_send()

void usbd_ept_send | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr,
 |  | uint8_t * | buffer,
 |  | uint16_t | len
 | ) |  |

endpoint send data

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
buffer | send data buffer
len | send data length
Return values
none

Definition at line 434 of file usbd_core.c.

Referenced by audio_hid_class_send_report(), audio_inisoincom_event(), audio_set_interface(), bot_scsi_read10(), bot_scsi_send_csw(), bot_scsi_send_data(), class_in_handler(), class_sof_handler(), custom_hid_class_send_report(), usb_hid_buf_process(), usb_iap_class_send_report(), usb_keyboard_class_send_report(), usb_mouse_class_send_report(), usb_printer_send_data(), usb_vcp_send_data(), usb_vcpkybrd_class_send_report(), usb_vcpkybrd_vcp_send_data(), usbd_core_in_handler(), usbd_ctrl_send(), and usbd_ctrl_send_status().

◆ usbd_fifo_alloc()

void usbd_fifo_alloc ( usbd_core_type * udev )

usb device endpoint fifo alloc

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 661 of file usbd_core.c.

Referenced by usbd_core_init(), and usbd_reset_handler().

◆ usbd_flush_tx_fifo()

void usbd_flush_tx_fifo | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_num
 | ) |  |

usb device flush in endpoint fifo

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none

Definition at line 650 of file usbd_core.c.

Referenced by bot_scsi_init(), bot_scsi_reset(), class_in_handler(), class_setup_handler(), class_sof_handler(), msc_class_setup_handler(), and usb_mouse_class_send_report().

◆ usbd_get_recv_len()

uint32_t usbd_get_recv_len | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

get endpoint receive data length

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
data receive len

Definition at line 300 of file usbd_core.c.

Referenced by bot_cbw_decode(), class_ept0_rx_handler(), and class_out_handler().

◆ usbd_remote_wakeup()

void usbd_remote_wakeup ( usbd_core_type * udev )

usb device remote wakeup

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 607 of file usbd_core.c.

Referenced by main().

◆ usbd_set_device_addr()

void usbd_set_device_addr | ( | usbd_core_type * | udev,
 |  | uint8_t | address
 | ) |  |

usb device set device address.

Parameters
udev | to the structure of usbd_core_type
address | host assignment address
Return values
none

Definition at line 390 of file usbd_core.c.

◆ usbd_set_stall()

void usbd_set_stall | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

usb set endpoint to stall status

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 262 of file usbd_core.c.

Referenced by bot_scsi_clear_feature(), bot_scsi_stall(), usbd_ctrl_unsupport(), and usbd_endpoint_request().


AT32F435/437 Firmwary Library: USBD_drivers_interrupt

Modules
USBD_drivers_interrupt
AT32F435_437_middlewares_usbd_drivers

usb device interrupt More...

Modules

USBD_int_private_functions

Detailed Description

usb device interrupt


AT32F435/437 Firmwary Library: USBD_int_private_functions

Functions
USBD_int_private_functions
AT32F435_437_middlewares_usbd_drivers » USBD_drivers_interrupt

Functions

void | usbd_irq_handler (otg_core_type *otgdev)
usb device interrput request handler. More...
void | usb_write_empty_txfifo (usbd_core_type *udev, uint32_t ept_num)
usb write tx fifo. More...
void | usbd_inept_handler (usbd_core_type *udev)
usb in endpoint handler More...
void | usbd_outept_handler (usbd_core_type *udev)
usb out endpoint handler More...
void | usbd_enumdone_handler (usbd_core_type *udev)
usb enumeration done handler More...
void | usbd_rxflvl_handler (usbd_core_type *udev)
usb rx non-empty handler More...
void | usbd_discon_handler (usbd_core_type *udev)
usb disconnect handler More...
void | usbd_incomisoout_handler (usbd_core_type *udev)
usb incomplete out handler More...
void | usbd_incomisioin_handler (usbd_core_type *udev)
usb incomplete in handler More...
void | usbd_reset_handler (usbd_core_type *udev)
usb device reset interrupt request handler. More...
void | usbd_sof_handler (usbd_core_type *udev)
usb device sof interrupt request handler. More...
void | usbd_suspend_handler (usbd_core_type *udev)
usb device suspend interrupt request handler. More...
void | usbd_wakeup_handler (usbd_core_type *udev)
usb device wakup interrupt request handler. More...

Detailed Description

Function Documentation

◆ usb_write_empty_txfifo()

void usb_write_empty_txfifo | ( | usbd_core_type * | udev,
 |  | uint32_t | ept_num
 | ) |  |

usb write tx fifo.

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none

Definition at line 147 of file usbd_int.c.

Referenced by usbd_inept_handler().

◆ usbd_discon_handler()

void usbd_discon_handler ( usbd_core_type * udev )

usb disconnect handler

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 381 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_enumdone_handler()

void usbd_enumdone_handler ( usbd_core_type * udev )

usb enumeration done handler

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 301 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_incomisioin_handler()

void usbd_incomisioin_handler ( usbd_core_type * udev )

usb incomplete in handler

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 405 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_incomisoout_handler()

void usbd_incomisoout_handler ( usbd_core_type * udev )

usb incomplete out handler

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 394 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_inept_handler()

void usbd_inept_handler ( usbd_core_type * udev )

usb in endpoint handler

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 187 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_irq_handler()

void usbd_irq_handler ( otg_core_type * otgdev )

usb device interrput request handler.

Parameters
otgdev to the structure of otg_core_type
Return values
none

Definition at line 46 of file usbd_int.c.

Referenced by OTG2_IRQ_HANDLER(), and OTG_IRQ_HANDLER().

◆ usbd_outept_handler()

void usbd_outept_handler ( usbd_core_type * udev )

usb out endpoint handler

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 250 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_reset_handler()

void usbd_reset_handler ( usbd_core_type * udev )

usb device reset interrupt request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 416 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_rxflvl_handler()

void usbd_rxflvl_handler ( usbd_core_type * udev )

usb rx non-empty handler

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 328 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_sof_handler()

void usbd_sof_handler ( usbd_core_type * udev )

usb device sof interrupt request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 473 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_suspend_handler()

void usbd_suspend_handler ( usbd_core_type * udev )

usb device suspend interrupt request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 485 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_wakeup_handler()

void usbd_wakeup_handler ( usbd_core_type * udev )

usb device wakup interrupt request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 511 of file usbd_int.c.

Referenced by usbd_irq_handler().


AT32F435/437 Firmwary Library: USBD_drivers_standard_request

Modules
USBD_drivers_standard_request
AT32F435_437_middlewares_usbd_drivers

usb device standard_request More...

Modules

USBD_sdr_exported_functions
USBD_sdr_private_functions

Detailed Description

usb device standard_request


AT32F435/437 Firmwary Library: USBD_sdr_exported_functions

Functions
USBD_sdr_exported_functions
AT32F435_437_middlewares_usbd_drivers » USBD_drivers_standard_request

Functions

void | usbd_setup_request_parse (usb_setup_type *setup, uint8_t *buf)
usb parse standard setup request More...
usb_sts_type | usbd_device_request (usbd_core_type *udev)
standard usb device requests More...
usb_sts_type | usbd_interface_request (usbd_core_type *udev)
standard usb interface requests More...
usb_sts_type | usbd_endpoint_request (usbd_core_type *udev)
standard usb endpoint requests More...

Detailed Description

Function Documentation

◆ usbd_device_request()

usb_sts_type usbd_device_request ( usbd_core_type * udev )

standard usb device requests

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 350 of file usbd_sdr.c.

Referenced by usbd_core_setup_handler().

◆ usbd_endpoint_request()

usb_sts_type usbd_endpoint_request ( usbd_core_type * udev )

standard usb endpoint requests

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 419 of file usbd_sdr.c.

Referenced by usbd_core_setup_handler().

◆ usbd_interface_request()

usb_sts_type usbd_interface_request ( usbd_core_type * udev )

standard usb interface requests

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 394 of file usbd_sdr.c.

Referenced by usbd_core_setup_handler().

◆ usbd_setup_request_parse()

void usbd_setup_request_parse | ( | usb_setup_type * | setup,
 |  | uint8_t * | buf
 | ) |  |

usb parse standard setup request

Parameters
setup | setup structure
buf | setup buffer
Return values
none

Definition at line 55 of file usbd_sdr.c.

Referenced by usbd_core_setup_handler().


AT32F435/437 Firmwary Library: USBD_sdr_private_functions

Functions
USBD_sdr_private_functions
AT32F435_437_middlewares_usbd_drivers » USBD_drivers_standard_request

Functions

static usb_sts_type | usbd_get_descriptor (usbd_core_type *udev)
get usb standard device description request More...
static usb_sts_type | usbd_set_address (usbd_core_type *udev)
this request sets the device address More...
static usb_sts_type | usbd_get_status (usbd_core_type *udev)
get usb status request More...
static usb_sts_type | usbd_clear_feature (usbd_core_type *udev)
clear usb feature request More...
static usb_sts_type | usbd_set_feature (usbd_core_type *udev)
set usb feature request More...
static usb_sts_type | usbd_get_configuration (usbd_core_type *udev)
get usb configuration request More...
static usb_sts_type | usbd_set_configuration (usbd_core_type *udev)
sets the usb device configuration request More...
void | usbd_setup_request_parse (usb_setup_type *setup, uint8_t *buf)
usb parse standard setup request More...
usb_sts_type | usbd_device_request (usbd_core_type *udev)
standard usb device requests More...
usb_sts_type | usbd_interface_request (usbd_core_type *udev)
standard usb interface requests More...
usb_sts_type | usbd_endpoint_request (usbd_core_type *udev)
standard usb endpoint requests More...

Detailed Description

Function Documentation

◆ usbd_clear_feature()

static usb_sts_type usbd_clear_feature ( usbd_core_type * udev )
static

clear usb feature request

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 210 of file usbd_sdr.c.

Referenced by usbd_device_request().

◆ usbd_device_request()

usb_sts_type usbd_device_request ( usbd_core_type * udev )

standard usb device requests

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 350 of file usbd_sdr.c.

Referenced by usbd_core_setup_handler().

◆ usbd_endpoint_request()

usb_sts_type usbd_endpoint_request ( usbd_core_type * udev )

standard usb endpoint requests

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 419 of file usbd_sdr.c.

Referenced by usbd_core_setup_handler().

◆ usbd_get_configuration()

static usb_sts_type usbd_get_configuration ( usbd_core_type * udev )
static

get usb configuration request

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 256 of file usbd_sdr.c.

Referenced by usbd_device_request().

◆ usbd_get_descriptor()

static usb_sts_type usbd_get_descriptor ( usbd_core_type * udev )
static

get usb standard device description request

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 69 of file usbd_sdr.c.

Referenced by usbd_device_request().

◆ usbd_get_status()

static usb_sts_type usbd_get_status ( usbd_core_type * udev )
static

get usb status request

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 185 of file usbd_sdr.c.

Referenced by usbd_device_request().

◆ usbd_interface_request()

usb_sts_type usbd_interface_request ( usbd_core_type * udev )

standard usb interface requests

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 394 of file usbd_sdr.c.

Referenced by usbd_core_setup_handler().

◆ usbd_set_address()

static usb_sts_type usbd_set_address ( usbd_core_type * udev )
static

this request sets the device address

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 139 of file usbd_sdr.c.

Referenced by usbd_device_request().

◆ usbd_set_configuration()

static usb_sts_type usbd_set_configuration ( usbd_core_type * udev )
static

sets the usb device configuration request

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 288 of file usbd_sdr.c.

Referenced by usbd_device_request().

◆ usbd_set_feature()

static usb_sts_type usbd_set_feature ( usbd_core_type * udev )
static

set usb feature request

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 238 of file usbd_sdr.c.

Referenced by usbd_device_request().

◆ usbd_setup_request_parse()

void usbd_setup_request_parse | ( | usb_setup_type * | setup,
 |  | uint8_t * | buf
 | ) |  |

usb parse standard setup request

Parameters
setup | setup structure
buf | setup buffer
Return values
none

Definition at line 55 of file usbd_sdr.c.

Referenced by usbd_core_setup_handler().


AT32F435/437 Firmwary Library: USBD_drivers_int

Modules
USBD_drivers_int
AT32F435_437_middlewares_usbd_drivers

Modules

USBD_interrupt_exported_types

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: USBD_interrupt_exported_types

Functions
USBD_interrupt_exported_types
AT32F435_437_middlewares_usbd_drivers » USBD_drivers_int

Functions

void | usbd_irq_handler (otg_core_type *udev)
usb device interrput request handler. More...
void | usbd_ept_handler (usbd_core_type *udev)
void | usbd_reset_handler (usbd_core_type *udev)
usb device reset interrupt request handler. More...
void | usbd_sof_handler (usbd_core_type *udev)
usb device sof interrupt request handler. More...
void | usbd_suspend_handler (usbd_core_type *udev)
usb device suspend interrupt request handler. More...
void | usbd_wakeup_handler (usbd_core_type *udev)
usb device wakup interrupt request handler. More...
void | usbd_inept_handler (usbd_core_type *udev)
usb in endpoint handler More...
void | usbd_outept_handler (usbd_core_type *udev)
usb out endpoint handler More...
void | usbd_enumdone_handler (usbd_core_type *udev)
usb enumeration done handler More...
void | usbd_rxflvl_handler (usbd_core_type *udev)
usb rx non-empty handler More...
void | usbd_incomisioin_handler (usbd_core_type *udev)
usb incomplete in handler More...
void | usbd_discon_handler (usbd_core_type *udev)
usb disconnect handler More...
void | usbd_incomisoout_handler (usbd_core_type *udev)
usb incomplete out handler More...
void | usb_write_empty_txfifo (usbd_core_type *udev, uint32_t ept_num)
usb write tx fifo. More...

Detailed Description

Function Documentation

◆ usb_write_empty_txfifo()

void usb_write_empty_txfifo | ( | usbd_core_type * | udev,
 |  | uint32_t | ept_num
 | ) |  |

usb write tx fifo.

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none

Definition at line 147 of file usbd_int.c.

Referenced by usbd_inept_handler().

◆ usbd_discon_handler()

void usbd_discon_handler ( usbd_core_type * udev )

usb disconnect handler

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 381 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_enumdone_handler()

void usbd_enumdone_handler ( usbd_core_type * udev )

usb enumeration done handler

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 301 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_ept_handler()

void usbd_ept_handler ( usbd_core_type * udev )

◆ usbd_incomisioin_handler()

void usbd_incomisioin_handler ( usbd_core_type * udev )

usb incomplete in handler

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 405 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_incomisoout_handler()

void usbd_incomisoout_handler ( usbd_core_type * udev )

usb incomplete out handler

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 394 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_inept_handler()

void usbd_inept_handler ( usbd_core_type * udev )

usb in endpoint handler

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 187 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_irq_handler()

void usbd_irq_handler ( otg_core_type * otgdev )

usb device interrput request handler.

Parameters
otgdev to the structure of otg_core_type
Return values
none

Definition at line 46 of file usbd_int.c.

Referenced by OTG2_IRQ_HANDLER(), and OTG_IRQ_HANDLER().

◆ usbd_outept_handler()

void usbd_outept_handler ( usbd_core_type * udev )

usb out endpoint handler

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 250 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_reset_handler()

void usbd_reset_handler ( usbd_core_type * udev )

usb device reset interrupt request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 416 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_rxflvl_handler()

void usbd_rxflvl_handler ( usbd_core_type * udev )

usb rx non-empty handler

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 328 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_sof_handler()

void usbd_sof_handler ( usbd_core_type * udev )

usb device sof interrupt request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 473 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_suspend_handler()

void usbd_suspend_handler ( usbd_core_type * udev )

usb device suspend interrupt request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 485 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_wakeup_handler()

void usbd_wakeup_handler ( usbd_core_type * udev )

usb device wakup interrupt request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 511 of file usbd_int.c.

Referenced by usbd_irq_handler().


AT32F435/437 Firmwary Library: AT32F435_437_middlewares_usbh_drivers

Modules
AT32F435_437_middlewares_usbh_drivers

Modules

USBH_drivers_core
usb host drivers core
USBH_drivers_control
usb host drivers control
USBH_drivers_interrupt
usb host interrupt
USBH_drivers_int

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: USBH_drivers_core

Modules
USBH_drivers_core
AT32F435_437_middlewares_usbh_drivers

usb host drivers core More...

Modules

USBH_core_exported_types
USBH_core_private_functions

Detailed Description

usb host drivers core


AT32F435/437 Firmwary Library: USBH_core_exported_types

USBH_core_exported_types
AT32F435_437_middlewares_usbh_drivers » USBH_drivers_core


AT32F435/437 Firmwary Library: USBH_core_private_functions

Functions
USBH_core_private_functions
AT32F435_437_middlewares_usbh_drivers » USBH_drivers_core

Functions

static void | usbh_attached (usbh_core_type *uhost)
usb host attached More...
static void | usbh_enumeration (usbh_core_type *uhost)
usb host enumeration More...
static void | usbh_class_request (usbh_core_type *uhost)
usb host class request More...
static void | usbh_class (usbh_core_type *uhost)
usb host class handler More...
static void | usbh_suspend (usbh_core_type *uhost)
usb host suspend More...
static void | usbh_wakeup (usbh_core_type *uhost)
usb host wakeup More...
static void | usbh_disconnect (usbh_core_type *uhost)
usb host disconnect More...
void | usbh_free_channel (usbh_core_type *uhost, uint8_t index)
usb host free channel More...
uint16_t | usbh_get_free_channel (usbh_core_type *uhost)
get usb host free channel More...
usb_sts_type | usbh_set_toggle (usbh_core_type *uhost, uint8_t hc_num, uint8_t toggle)
usb host set toggle More...
usb_sts_type | usbh_in_out_request (usbh_core_type *uhost, uint8_t hc_num)
usb host in out request More...
usb_sts_type | usbh_interrupt_recv (usbh_core_type *uhost, uint8_t hc_num, uint8_t *buffer, uint16_t length)
usb host interrupt receive request More...
usb_sts_type | usbh_interrupt_send (usbh_core_type *uhost, uint8_t hc_num, uint8_t *buffer, uint16_t length)
usb host interrupt send request More...
usb_sts_type | usbh_bulk_recv (usbh_core_type *uhost, uint8_t hc_num, uint8_t *buffer, uint16_t length)
usb host bulk receive request More...
usb_sts_type | usbh_bulk_send (usbh_core_type *uhost, uint8_t hc_num, uint8_t *buffer, uint16_t length)
usb host bulk send request More...
usb_sts_type | usbh_isoc_send (usbh_core_type *uhost, uint8_t hc_num, uint8_t *buffer, uint16_t length)
usb host iso send request More...
usb_sts_type | usbh_isoc_recv (usbh_core_type *uhost, uint8_t hc_num, uint8_t *buffer, uint16_t length)
usb host iso receive request More...
usb_sts_type | usbh_cfg_default_init (usbh_core_type *uhost)
usb host cfg default init More...
void | usbh_enter_suspend (usbh_core_type *uhost)
usb host enter suspend More...
void | usbh_resume (usbh_core_type *uhost)
usb host resume More...
usb_sts_type | usbh_core_init (usbh_core_type *uhost, usb_reg_type *usb_reg, usbh_class_handler_type *class_handler, usbh_user_handler_type *user_handler, uint8_t core_id)
usb host core initialize More...
void | usbh_hc_open (usbh_core_type *uhost, uint8_t chn, uint8_t ept_num, uint8_t dev_address, uint8_t type, uint16_t maxpacket, uint8_t speed)
usb host open channel More...
void | usbh_ch_disable (usbh_core_type *uhost, uint8_t chn)
disable host channel More...
uint16_t | usbh_alloc_channel (usbh_core_type *uhost, uint8_t ept_addr)
usb host alloc channel More...
urb_sts_type | usbh_get_urb_status (usbh_core_type *uhost, uint8_t ch_num)
usb host get urb status More...
usb_sts_type | usbh_ctrl_result_check (usbh_core_type *uhost, ctrl_ept0_sts_type next_ctrl_state, uint8_t next_enum_state)
usb wait control setup complete More...
uint8_t | usbh_alloc_address (void)
auto alloc address (1...20) More...
usb_sts_type | usbh_enum_handler (usbh_core_type *uhost)
usb host enumeration handler More...
void | usbh_active_vbus (usbh_core_type *uhost, confirm_state state)
active vbus. More...
void | usbh_reset_port (usbh_core_type *uhost)
reset usb port More...
usb_sts_type | usbh_loop_handler (usbh_core_type *uhost)
usb host enum loop handler More...

Detailed Description

Function Documentation

◆ usbh_active_vbus()

void usbh_active_vbus | ( | usbh_core_type * | uhost,
 |  | confirm_state | state
 | ) |  |

active vbus.

Parameters
uhost | to the structure of usbh_core_type
state | vbus state
Return values
none

Definition at line 939 of file usbh_core.c.

Referenced by usbh_core_init().

◆ usbh_alloc_address()

uint8_t usbh_alloc_address ( void )

auto alloc address (1...20)

Parameters
none
Return values
address (1...20)

Definition at line 756 of file usbh_core.c.

Referenced by usbh_enum_handler().

◆ usbh_alloc_channel()

uint16_t usbh_alloc_channel | ( | usbh_core_type * | uhost,
 |  | uint8_t | ept_addr
 | ) |  |

usb host alloc channel

Parameters
uhost | to the structure of usbh_core_type
ept_addr | endpoint address
Return values
usb_sts_type

Definition at line 694 of file usbh_core.c.

Referenced by uhost_init_handler(), and usbh_attached().

◆ usbh_attached()

static void usbh_attached ( usbh_core_type * uhost )
static

usb host attached

Parameters
uhost to the structure of usbh_core_type
Return values
none

Definition at line 974 of file usbh_core.c.

Referenced by usbh_loop_handler().

◆ usbh_bulk_recv()

usb_sts_type usbh_bulk_recv | ( | usbh_core_type * | uhost,
 |  | uint8_t | hc_num,
 |  | uint8_t * | buffer,
 |  | uint16_t | length
 | ) |  |

usb host bulk receive request

Parameters
uhost | to the structure of usbh_core_type
hc_num | channel number
buffer | receive buffer
length | receive length
Return values
status usb_sts_type status

Definition at line 286 of file usbh_core.c.

Referenced by usb_bot_request().

◆ usbh_bulk_send()

usb_sts_type usbh_bulk_send | ( | usbh_core_type * | uhost,
 |  | uint8_t | hc_num,
 |  | uint8_t * | buffer,
 |  | uint16_t | length
 | ) |  |

usb host bulk send request

Parameters
uhost | to the structure of usbh_core_type
hc_num | channel number
buffer | receive buffer
length | receive length
Return values
status usb_sts_type status

Definition at line 321 of file usbh_core.c.

Referenced by usb_bot_request().

◆ usbh_cfg_default_init()

usb_sts_type usbh_cfg_default_init ( usbh_core_type * uhost )

usb host cfg default init

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 405 of file usbh_core.c.

Referenced by usbh_core_init(), usbh_disconnect(), and usbh_loop_handler().

◆ usbh_ch_disable()

void usbh_ch_disable | ( | usbh_core_type * | uhost,
 |  | uint8_t | chn
 | ) |  |

disable host channel

Parameters
usbx to select the otgfs peripheral. this parameter can be one of the following values:
  • OTG1_GLOBAL
  • OTG2_GLOBAL
chn channel number
Return values
none

Definition at line 683 of file usbh_core.c.

Referenced by uhost_reset_handler().

◆ usbh_class()

static void usbh_class ( usbh_core_type * uhost )
static

usb host class handler

Parameters
uhost to the structure of usbh_core_type
Return values
none

Definition at line 1054 of file usbh_core.c.

Referenced by usbh_loop_handler().

◆ usbh_class_request()

static void usbh_class_request ( usbh_core_type * uhost )
static

usb host class request

Parameters
uhost to the structure of usbh_core_type
Return values
none

Definition at line 1029 of file usbh_core.c.

Referenced by usbh_loop_handler().

◆ usbh_core_init()

usb_sts_type usbh_core_init | ( | usbh_core_type * | uhost,
 |  | usb_reg_type * | usb_reg,
 |  | usbh_class_handler_type * | class_handler,
 |  | usbh_user_handler_type * | user_handler,
 |  | uint8_t | core_id
 | ) |  |

usb host core initialize

Parameters
uhost | to the structure of usbh_core_type
usb_reg | usb otgfs peripheral global register this parameter can be one of the following values: OTG1_GLOBAL , OTG2_GLOBAL
class_handler | usb host class handler type pointer
user_handler | usb host user handler type pointer
core_id | usb core select id
Return values
status usb_sts_type status

Definition at line 501 of file usbh_core.c.

◆ usbh_ctrl_result_check()

usb_sts_type usbh_ctrl_result_check | ( | usbh_core_type * | uhost,
 |  | ctrl_ept0_sts_type | next_ctrl_state,
 |  | uint8_t | next_enum_state
 | ) |  |

usb wait control setup complete

Parameters
uhost | to the structure of usbh_core_type
next_ctrl_state | next ctrl state when setup complete
next_enum_state | next enum state when setup complete
Return values
status usb_sts_type status

Definition at line 724 of file usbh_core.c.

Referenced by usbh_clear_endpoint_feature(), usbh_clear_ept_feature(), usbh_enum_handler(), usbh_hid_get_desc(), usbh_hid_get_report(), usbh_hid_set_idle(), usbh_hid_set_protocol(), usbh_msc_clear_feature(), usbh_msc_get_max_lun(), usbh_suspend(), and usbh_wakeup().

◆ usbh_disconnect()

static void usbh_disconnect ( usbh_core_type * uhost )
static

usb host disconnect

Parameters
uhost to the structure of usbh_core_type
Return values
none

Definition at line 1110 of file usbh_core.c.

Referenced by usbh_loop_handler().

◆ usbh_enter_suspend()

void usbh_enter_suspend ( usbh_core_type * uhost )

usb host enter suspend

Parameters
uhost to the structure of usbh_core_type
Return values
none

Definition at line 443 of file usbh_core.c.

Referenced by usbh_suspend().

◆ usbh_enum_handler()

usb_sts_type usbh_enum_handler ( usbh_core_type * uhost )

usb host enumeration handler

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 770 of file usbh_core.c.

Referenced by usbh_enumeration().

◆ usbh_enumeration()

static void usbh_enumeration ( usbh_core_type * uhost )
static

usb host enumeration

Parameters
uhost to the structure of usbh_core_type
Return values
none

Definition at line 1013 of file usbh_core.c.

Referenced by usbh_loop_handler().

◆ usbh_free_channel()

void usbh_free_channel | ( | usbh_core_type * | uhost,
 |  | uint8_t | index
 | ) |  |

usb host free channel

Parameters
uhost | to the structure of usbh_core_type
index | channle number
Return values
none

Definition at line 57 of file usbh_core.c.

Referenced by uhost_reset_handler(), usbh_cfg_default_init(), usbh_disconnect(), and usbh_disconnect_handler().

◆ usbh_get_free_channel()

uint16_t usbh_get_free_channel ( usbh_core_type * uhost )

get usb host free channel

Parameters
uhost to the structure of usbh_core_type
Return values
channel index

Definition at line 71 of file usbh_core.c.

Referenced by usbh_alloc_channel().

◆ usbh_get_urb_status()

urb_sts_type usbh_get_urb_status | ( | usbh_core_type * | uhost,
 |  | uint8_t | ch_num
 | ) |  |

usb host get urb status

Parameters
uhost | to the structure of usbh_core_type
ch_num | channel number
Return values
urb_sts_type urb status

Definition at line 713 of file usbh_core.c.

Referenced by uhost_process_handler(), and usb_bot_request().

◆ usbh_hc_open()

void usbh_hc_open | ( | usbh_core_type * | uhost,
 |  | uint8_t | chn,
 |  | uint8_t | ept_num,
 |  | uint8_t | dev_address,
 |  | uint8_t | type,
 |  | uint16_t | maxpacket,
 |  | uint8_t | speed
 | ) |  |

usb host open channel

Parameters
uhost | to the structure of usbh_core_type
chn | host channel number
ept_num | devvice endpoint number
dev_address | device address
type channel transfer type this parameter can be one of the following values:
  • EPT_CONTROL_TYPE
  • EPT_BULK_TYPE
  • EPT_INT_TYPE
  • EPT_ISO_TYPE
maxpacket | support max packe size for this channel
speed device speed this parameter can be one of the following values:
  • USB_PRTSPD_FULL_SPEED
  • USB_PRTSPD_LOW_SPEED
ept_addr | endpoint address
Return values
usb_sts_type

Definition at line 638 of file usbh_core.c.

Referenced by uhost_init_handler(), usbh_attached(), and usbh_enum_handler().

◆ usbh_in_out_request()

usb_sts_type usbh_in_out_request | ( | usbh_core_type * | uhost,
 |  | uint8_t | hc_num
 | ) |  |

usb host in out request

Parameters
uhost | to the structure of usbh_core_type
hc_num | channel number
Return values
status usb_sts_type status

Definition at line 115 of file usbh_core.c.

Referenced by usbh_bulk_recv(), usbh_bulk_send(), usbh_ctrl_recv_data(), usbh_ctrl_send_data(), usbh_ctrl_send_setup(), usbh_interrupt_recv(), usbh_interrupt_send(), usbh_isoc_recv(), and usbh_isoc_send().

◆ usbh_interrupt_recv()

usb_sts_type usbh_interrupt_recv | ( | usbh_core_type * | uhost,
 |  | uint8_t | hc_num,
 |  | uint8_t * | buffer,
 |  | uint16_t | length
 | ) |  |

usb host interrupt receive request

Parameters
uhost | to the structure of usbh_core_type
hc_num | channel number
buffer | receive buffer
length | receive length
Return values
status usb_sts_type status

Definition at line 217 of file usbh_core.c.

Referenced by uhost_process_handler().

◆ usbh_interrupt_send()

usb_sts_type usbh_interrupt_send | ( | usbh_core_type * | uhost,
 |  | uint8_t | hc_num,
 |  | uint8_t * | buffer,
 |  | uint16_t | length
 | ) |  |

usb host interrupt send request

Parameters
uhost | to the structure of usbh_core_type
hc_num | channel number
buffer | send buffer
length | send length
Return values
status usb_sts_type status

Definition at line 251 of file usbh_core.c.

◆ usbh_isoc_recv()

usb_sts_type usbh_isoc_recv | ( | usbh_core_type * | uhost,
 |  | uint8_t | hc_num,
 |  | uint8_t * | buffer,
 |  | uint16_t | length
 | ) |  |

usb host iso receive request

Parameters
uhost | to the structure of usbh_core_type
hc_num | channel number
buffer | receive buffer
length | receive length
Return values
status usb_sts_type status

Definition at line 382 of file usbh_core.c.

◆ usbh_isoc_send()

usb_sts_type usbh_isoc_send | ( | usbh_core_type * | uhost,
 |  | uint8_t | hc_num,
 |  | uint8_t * | buffer,
 |  | uint16_t | length
 | ) |  |

usb host iso send request

Parameters
uhost | to the structure of usbh_core_type
hc_num | channel number
buffer | send buffer
length | send length
Return values
status usb_sts_type status

Definition at line 356 of file usbh_core.c.

◆ usbh_loop_handler()

usb_sts_type usbh_loop_handler ( usbh_core_type * uhost )

usb host enum loop handler

Parameters
uhost to the structure of usbh_core_type
Return values
none

Definition at line 1142 of file usbh_core.c.

Referenced by main().

◆ usbh_reset_port()

void usbh_reset_port ( usbh_core_type * uhost )

reset usb port

Parameters
usbx to the structure of otg_global_type
Return values
none

Definition at line 949 of file usbh_core.c.

Referenced by usbh_loop_handler().

◆ usbh_resume()

void usbh_resume ( usbh_core_type * uhost )

usb host resume

Parameters
uhost to the structure of usbh_core_type
Return values
none

Definition at line 464 of file usbh_core.c.

Referenced by usbh_wakeup().

◆ usbh_set_toggle()

usb_sts_type usbh_set_toggle | ( | usbh_core_type * | uhost,
 |  | uint8_t | hc_num,
 |  | uint8_t | toggle
 | ) |  |

usb host set toggle

Parameters
uhost | to the structure of usbh_core_type
hc_num | channel number
toggle | toggle value
Return values
status usb_sts_type status

Definition at line 94 of file usbh_core.c.

Referenced by uhost_init_handler(), and usb_bot_request().

◆ usbh_suspend()

static void usbh_suspend ( usbh_core_type * uhost )
static

usb host suspend

Parameters
uhost to the structure of usbh_core_type
Return values
none

Definition at line 1067 of file usbh_core.c.

Referenced by usbh_loop_handler().

◆ usbh_wakeup()

static void usbh_wakeup ( usbh_core_type * uhost )
static

usb host wakeup

Parameters
uhost to the structure of usbh_core_type
Return values
none

Definition at line 1089 of file usbh_core.c.

Referenced by usbh_loop_handler().


AT32F435/437 Firmwary Library: USBH_drivers_control

Modules
USBH_drivers_control
AT32F435_437_middlewares_usbh_drivers

usb host drivers control More...

Modules

USBH_ctrl_exported_types
USBH_ctrl_private_functions

Detailed Description

usb host drivers control


AT32F435/437 Firmwary Library: USBH_ctrl_exported_types

Functions
USBH_ctrl_exported_types
AT32F435_437_middlewares_usbh_drivers » USBH_drivers_control

Functions

usb_sts_type | usbh_ctrl_send_setup (usbh_core_type *uhost, uint8_t *buffer, uint8_t hc_num)
usb host control send setup packet More...
usb_sts_type | usbh_ctrl_recv_data (usbh_core_type *uhost, uint8_t *buffer, uint8_t length, uint16_t hc_num)
usb host control receive data from device More...
usb_sts_type | usbh_ctrl_send_data (usbh_core_type *uhost, uint8_t *buffer, uint8_t length, uint16_t hc_num)
usb host control send data packet More...
usb_sts_type | usbh_ctrl_setup_handler (usbh_core_type *uhost)
usb host control setup request handler More...
usb_sts_type | usbh_ctrl_setup_wait_handler (usbh_core_type *uhost, uint32_t *timeout)
usb host control setup request wait handler More...
usb_sts_type | usbh_ctrl_data_in_handler (usbh_core_type *uhost)
usb host control data in request handler More...
usb_sts_type | usbh_ctrl_data_in_wait_handler (usbh_core_type *uhost, uint32_t timeout)
usb host control data in wait handler More...
usb_sts_type | usbh_ctrl_data_out_handler (usbh_core_type *uhost)
usb host control data out request handler More...
usb_sts_type | usbh_ctrl_data_out_wait_handler (usbh_core_type *uhost, uint32_t timeout)
usb host control data out wait handler More...
usb_sts_type | usbh_ctrl_status_in_handler (usbh_core_type *uhost)
usb host control status data in handler More...
usb_sts_type | usbh_ctrl_status_in_wait_handler (usbh_core_type *uhost, uint32_t timeout)
usb host control status data in wait handler More...
usb_sts_type | usbh_ctrl_status_out_handler (usbh_core_type *uhost)
usb host control status data out wait handler More...
usb_sts_type | usbh_ctrl_status_out_wait_handler (usbh_core_type *uhost, uint32_t timeout)
usb host control status data out wait handler More...
usb_sts_type | usbh_ctrl_error_handler (usbh_core_type *uhost)
usb host control error handler More...
usb_sts_type | usbh_ctrl_stall_handler (usbh_core_type *uhost)
usb host control stall handler More...
usb_sts_type | usbh_ctrl_complete_handler (usbh_core_type *uhost)
usb host control complete handler More...
usb_sts_type | usbh_ctrl_transfer_loop (usbh_core_type *uhost)
usb host control transfer loop function More...
usb_sts_type | usbh_ctrl_request (usbh_core_type *uhost, uint8_t *buffer, uint16_t length)
usb host control request More...
usb_sts_type | usbh_get_descriptor (usbh_core_type *uhost, uint16_t length, uint8_t req_type, uint16_t wvalue, uint8_t *buffer)
usb host get device descriptor More...
void | usbh_parse_dev_desc (usbh_core_type *uhost, uint8_t *buffer, uint16_t length)
usb host parse device descriptor More...
usb_header_desc_type * | usbh_get_next_header (uint8_t *buf, uint16_t *index_len)
usb host get next header More...
void | usbh_parse_interface_desc (usb_interface_desc_type *intf, uint8_t *buf)
usb host parse interface descriptor More...
void | usbh_parse_endpoint_desc (usb_endpoint_desc_type *ept_desc, uint8_t *buf)
usb host parse endpoint descriptor More...
usb_sts_type | usbh_parse_configure_desc (usbh_core_type *uhost, uint8_t *buffer, uint16_t length)
usb host parse configure descriptor More...
uint8_t | usbh_find_interface (usbh_core_type *uhost, uint8_t class_code, uint8_t sub_class, uint8_t protocol)
usb host find interface More...
void | usbh_parse_string_desc (uint8_t *src, uint8_t *dest, uint16_t length)
usbh parse string descriptor More...
usb_sts_type | usbh_get_device_descriptor (usbh_core_type *uhost, uint16_t length)
usb host get device descriptor More...
usb_sts_type | usbh_get_configure_descriptor (usbh_core_type *uhost, uint16_t length)
usb host get configure descriptor More...
usb_sts_type | usbh_get_sting_descriptor (usbh_core_type *uhost, uint8_t string_id, uint8_t *buffer, uint16_t length)
usb host get string descriptor More...
usb_sts_type | usbh_set_configuration (usbh_core_type *uhost, uint16_t config)
usb host set configurtion More...
usb_sts_type | usbh_set_address (usbh_core_type *uhost, uint8_t address)
usb host set device address More...
usb_sts_type | usbh_set_interface (usbh_core_type *uhost, uint8_t ept_num, uint8_t altsetting)
usb host set interface More...
usb_sts_type | usbh_set_feature (usbh_core_type *uhost, uint8_t feature, uint16_t index)
usb host set feature More...
usb_sts_type | usbh_clear_dev_feature (usbh_core_type *uhost, uint8_t feature, uint16_t index)
usb host clear device feature More...
usb_sts_type | usbh_clear_ept_feature (usbh_core_type *uhost, uint8_t ept_num, uint8_t hc_num)
usb host clear endpoint feature More...

Detailed Description

Function Documentation

◆ usbh_clear_dev_feature()

usb_sts_type usbh_clear_dev_feature | ( | usbh_core_type * | uhost,
 |  | uint8_t | feature,
 |  | uint16_t | index
 | ) |  |

usb host clear device feature

Parameters
uhost | to the structure of usbh_core_type
feature | feature number
index | index number
Return values
status usb_sts_type status

Definition at line 922 of file usbh_ctrl.c.

Referenced by usbh_wakeup().

◆ usbh_clear_ept_feature()

usb_sts_type usbh_clear_ept_feature | ( | usbh_core_type * | uhost,
 |  | uint8_t | ept_num,
 |  | uint8_t | hc_num
 | ) |  |

usb host clear endpoint feature

Parameters
uhost | to the structure of usbh_core_type
ept_num | endpoint number
hc_num | host channel number
Return values
status usb_sts_type status

Definition at line 944 of file usbh_ctrl.c.

Referenced by usb_bot_request().

◆ usbh_ctrl_complete_handler()

usb_sts_type usbh_ctrl_complete_handler ( usbh_core_type * uhost )

usb host control complete handler

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 444 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_data_in_handler()

usb_sts_type usbh_ctrl_data_in_handler ( usbh_core_type * uhost )

usb host control data in request handler

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 190 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_data_in_wait_handler()

usb_sts_type usbh_ctrl_data_in_wait_handler | ( | usbh_core_type * | uhost,
 |  | uint32_t | timeout
 | ) |  |

usb host control data in wait handler

Parameters
uhost | to the structure of usbh_core_type
timeout | wait timeout
Return values
status usb_sts_type status

Definition at line 207 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_data_out_handler()

usb_sts_type usbh_ctrl_data_out_handler ( usbh_core_type * uhost )

usb host control data out request handler

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 244 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_data_out_wait_handler()

usb_sts_type usbh_ctrl_data_out_wait_handler | ( | usbh_core_type * | uhost,
 |  | uint32_t | timeout
 | ) |  |

usb host control data out wait handler

Parameters
uhost | to the structure of usbh_core_type
timeout | wait timeout
Return values
status usb_sts_type status

Definition at line 263 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_error_handler()

usb_sts_type usbh_ctrl_error_handler ( usbh_core_type * uhost )

usb host control error handler

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 411 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_recv_data()

usb_sts_type usbh_ctrl_recv_data | ( | usbh_core_type * | uhost,
 |  | uint8_t * | buffer,
 |  | uint8_t | length,
 |  | uint16_t | hc_num
 | ) |  |

usb host control receive data from device

Parameters
uhost | to the structure of usbh_core_type
buffer | usb control receive data buffer
length | usb control receive data length
hc_num | channel number
Return values
status usb_sts_type status

Definition at line 71 of file usbh_ctrl.c.

Referenced by usbh_ctrl_data_in_handler(), and usbh_ctrl_status_in_handler().

◆ usbh_ctrl_request()

usb_sts_type usbh_ctrl_request | ( | usbh_core_type * | uhost,
 |  | uint8_t * | buffer,
 |  | uint16_t | length
 | ) |  |

usb host control request

Parameters
uhost | to the structure of usbh_core_type
buffer | usb request buffer
length | usb request length
Return values
status usb_sts_type status

Definition at line 530 of file usbh_ctrl.c.

Referenced by usbh_clear_dev_feature(), usbh_clear_endpoint_feature(), usbh_clear_ept_feature(), usbh_get_descriptor(), usbh_hid_set_idle(), usbh_hid_set_protocol(), usbh_msc_clear_feature(), usbh_msc_get_max_lun(), usbh_set_address(), usbh_set_configuration(), usbh_set_feature(), and usbh_set_interface().

◆ usbh_ctrl_send_data()

usb_sts_type usbh_ctrl_send_data | ( | usbh_core_type * | uhost,
 |  | uint8_t * | buffer,
 |  | uint8_t | length,
 |  | uint16_t | hc_num
 | ) |  |

usb host control send data packet

Parameters
uhost | to the structure of usbh_core_type
buffer | usb control send data buffer
length | usb control send data length
hc_num | channel number
Return values
status usb_sts_type status

Definition at line 90 of file usbh_ctrl.c.

Referenced by usbh_ctrl_data_out_handler(), and usbh_ctrl_status_out_handler().

◆ usbh_ctrl_send_setup()

usb_sts_type usbh_ctrl_send_setup | ( | usbh_core_type * | uhost,
 |  | uint8_t * | buffer,
 |  | uint8_t | hc_num
 | ) |  |

usb host control send setup packet

Parameters
uhost | to the structure of usbh_core_type
buffer | usb control setup send buffer
hc_num | channel number
Return values
status usb_sts_type status

Definition at line 53 of file usbh_ctrl.c.

Referenced by usbh_ctrl_setup_handler().

◆ usbh_ctrl_setup_handler()

usb_sts_type usbh_ctrl_setup_handler ( usbh_core_type * uhost )

usb host control setup request handler

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 117 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_setup_wait_handler()

usb_sts_type usbh_ctrl_setup_wait_handler | ( | usbh_core_type * | uhost,
 |  | uint32_t * | timeout
 | ) |  |

usb host control setup request wait handler

Parameters
uhost | to the structure of usbh_core_type
timeout | pointer of wait timeout
Return values
status usb_sts_type status

Definition at line 131 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_stall_handler()

usb_sts_type usbh_ctrl_stall_handler ( usbh_core_type * uhost )

usb host control stall handler

Parameters
uhost to the structure of usbh_core_type
Return values
usb_sts_type

Definition at line 434 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_status_in_handler()

usb_sts_type usbh_ctrl_status_in_handler ( usbh_core_type * uhost )

usb host control status data in handler

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 302 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_status_in_wait_handler()

usb_sts_type usbh_ctrl_status_in_wait_handler | ( | usbh_core_type * | uhost,
 |  | uint32_t | timeout
 | ) |  |

usb host control status data in wait handler

Parameters
uhost | to the structure of usbh_core_type
timeout | wait timeout
Return values
status usb_sts_type status

Definition at line 319 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_status_out_handler()

usb_sts_type usbh_ctrl_status_out_handler ( usbh_core_type * uhost )

usb host control status data out wait handler

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 355 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_status_out_wait_handler()

usb_sts_type usbh_ctrl_status_out_wait_handler | ( | usbh_core_type * | uhost,
 |  | uint32_t | timeout
 | ) |  |

usb host control status data out wait handler

Parameters
uhost | to the structure of usbh_core_type
timeout | wait timeout
Return values
status usb_sts_type status

Definition at line 372 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_transfer_loop()

usb_sts_type usbh_ctrl_transfer_loop ( usbh_core_type * uhost )

usb host control transfer loop function

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 454 of file usbh_ctrl.c.

Referenced by usbh_ctrl_result_check().

◆ usbh_find_interface()

uint8_t usbh_find_interface | ( | usbh_core_type * | uhost,
 |  | uint8_t | class_code,
 |  | uint8_t | sub_class,
 |  | uint8_t | protocol
 | ) |  |

usb host find interface

Parameters
uhost | to the structure of usbh_core_type
class_code | class code
sub_class | subclass code
protocol | prtocol code
Return values
idx interface index

Definition at line 720 of file usbh_ctrl.c.

Referenced by uhost_init_handler().

◆ usbh_get_configure_descriptor()

usb_sts_type usbh_get_configure_descriptor | ( | usbh_core_type * | uhost,
 |  | uint16_t | length
 | ) |  |

usb host get configure descriptor

Parameters
uhost | to the structure of usbh_core_type
length | get device configure length
Return values
status usb_sts_type status

Definition at line 789 of file usbh_ctrl.c.

Referenced by usbh_enum_handler().

◆ usbh_get_descriptor()

usb_sts_type usbh_get_descriptor | ( | usbh_core_type * | uhost,
 |  | uint16_t | length,
 |  | uint8_t | req_type,
 |  | uint16_t | wvalue,
 |  | uint8_t * | buffer
 | ) |  |

usb host get device descriptor

Parameters
uhost | to the structure of usbh_core_type
length | get descriptor request length
req_type | usb request type
wvalue | usb wvalue
buffer | request buffer
Return values
status usb_sts_type status

Definition at line 552 of file usbh_ctrl.c.

Referenced by usbh_get_configure_descriptor(), usbh_get_device_descriptor(), usbh_get_sting_descriptor(), usbh_hid_get_desc(), and usbh_hid_get_report().

◆ usbh_get_device_descriptor()

usb_sts_type usbh_get_device_descriptor | ( | usbh_core_type * | uhost,
 |  | uint16_t | length
 | ) |  |

usb host get device descriptor

Parameters
uhost | to the structure of usbh_core_type
length | get device descriptor length
Return values
status usb_sts_type status

Definition at line 769 of file usbh_ctrl.c.

Referenced by usbh_enum_handler().

◆ usbh_get_next_header()

usb_header_desc_type * usbh_get_next_header | ( | uint8_t * | buf,
 |  | uint16_t * | index_len
 | ) |  |

usb host get next header

Parameters
buffer | usb data buffer
index_len | pointer of index len
Return values
status usb_sts_type status

Definition at line 612 of file usbh_ctrl.c.

Referenced by usbh_parse_configure_desc().

◆ usbh_get_sting_descriptor()

usb_sts_type usbh_get_sting_descriptor | ( | usbh_core_type * | uhost,
 |  | uint8_t | string_id,
 |  | uint8_t * | buffer,
 |  | uint16_t | length
 | ) |  |

usb host get string descriptor

Parameters
uhost | to the structure of usbh_core_type
string_id | string id
buffer | receive data buffer
length | get device string length
Return values
status usb_sts_type status

Definition at line 812 of file usbh_ctrl.c.

Referenced by usbh_enum_handler().

◆ usbh_parse_configure_desc()

usb_sts_type usbh_parse_configure_desc | ( | usbh_core_type * | uhost,
 |  | uint8_t * | buffer,
 |  | uint16_t | length
 | ) |  |

usb host parse configure descriptor

Parameters
uhost | to the structure of usbh_core_type
buffer | configure buffer
length | configure length
Return values
status usb_sts_type status

Definition at line 661 of file usbh_ctrl.c.

Referenced by usbh_enum_handler().

◆ usbh_parse_dev_desc()

void usbh_parse_dev_desc | ( | usbh_core_type * | uhost,
 |  | uint8_t * | buffer,
 |  | uint16_t | length
 | ) |  |

usb host parse device descriptor

Parameters
uhost | to the structure of usbh_core_type
buffer | usb device descriptor buffer
length | usb device descriptor length
Return values
status usb_sts_type status

Definition at line 582 of file usbh_ctrl.c.

Referenced by usbh_enum_handler().

◆ usbh_parse_endpoint_desc()

void usbh_parse_endpoint_desc | ( | usb_endpoint_desc_type * | ept_desc,
 |  | uint8_t * | buf
 | ) |  |

usb host parse endpoint descriptor

Parameters
ept_desc | endpoint type
buf | endpoint description data buffer
Return values
none

Definition at line 644 of file usbh_ctrl.c.

Referenced by usbh_parse_configure_desc().

◆ usbh_parse_interface_desc()

void usbh_parse_interface_desc | ( | usb_interface_desc_type * | intf,
 |  | uint8_t * | buf
 | ) |  |

usb host parse interface descriptor

Parameters
intf | usb interface description type
buf | interface description data buffer
Return values
none

Definition at line 625 of file usbh_ctrl.c.

Referenced by usbh_parse_configure_desc().

◆ usbh_parse_string_desc()

void usbh_parse_string_desc | ( | uint8_t * | src,
 |  | uint8_t * | dest,
 |  | uint16_t | length
 | ) |  |

usbh parse string descriptor

Parameters
src | string source pointer
dest | string destination pointer
length | string length
Return values
none

Definition at line 745 of file usbh_ctrl.c.

Referenced by usbh_enum_handler().

◆ usbh_set_address()

usb_sts_type usbh_set_address | ( | usbh_core_type * | uhost,
 |  | uint8_t | address
 | ) |  |

usb host set device address

Parameters
uhost | to the structure of usbh_core_type
address | device address
Return values
status usb_sts_type status

Definition at line 855 of file usbh_ctrl.c.

Referenced by usbh_enum_handler().

◆ usbh_set_configuration()

usb_sts_type usbh_set_configuration | ( | usbh_core_type * | uhost,
 |  | uint16_t | config
 | ) |  |

usb host set configurtion

Parameters
uhost | to the structure of usbh_core_type
config | usb configuration
Return values
status usb_sts_type status

Definition at line 834 of file usbh_ctrl.c.

Referenced by usbh_enum_handler().

◆ usbh_set_feature()

usb_sts_type usbh_set_feature | ( | usbh_core_type * | uhost,
 |  | uint8_t | feature,
 |  | uint16_t | index
 | ) |  |

usb host set feature

Parameters
uhost | to the structure of usbh_core_type
feature | feature number
index | index number
Return values
status usb_sts_type status

Definition at line 899 of file usbh_ctrl.c.

Referenced by usbh_suspend().

◆ usbh_set_interface()

usb_sts_type usbh_set_interface | ( | usbh_core_type * | uhost,
 |  | uint8_t | ept_num,
 |  | uint8_t | altsetting
 | ) |  |

usb host set interface

Parameters
uhost | to the structure of usbh_core_type
ept_num | endpoint number
altsetting | alter setting
Return values
status usb_sts_type status

Definition at line 877 of file usbh_ctrl.c.


AT32F435/437 Firmwary Library: USBH_ctrl_private_functions

Macros | Functions
USBH_ctrl_private_functions
AT32F435_437_middlewares_usbh_drivers » USBH_drivers_control

Macros

#define CTRL_TIMEOUT 5000

Functions

usb_sts_type | usbh_ctrl_send_setup (usbh_core_type *uhost, uint8_t *buffer, uint8_t hc_num)
usb host control send setup packet More...
usb_sts_type | usbh_ctrl_recv_data (usbh_core_type *uhost, uint8_t *buffer, uint8_t length, uint16_t hc_num)
usb host control receive data from device More...
usb_sts_type | usbh_ctrl_send_data (usbh_core_type *uhost, uint8_t *buffer, uint8_t length, uint16_t hc_num)
usb host control send data packet More...
usb_sts_type | usbh_ctrl_setup_handler (usbh_core_type *uhost)
usb host control setup request handler More...
usb_sts_type | usbh_ctrl_setup_wait_handler (usbh_core_type *uhost, uint32_t *timeout)
usb host control setup request wait handler More...
usb_sts_type | usbh_ctrl_data_in_handler (usbh_core_type *uhost)
usb host control data in request handler More...
usb_sts_type | usbh_ctrl_data_in_wait_handler (usbh_core_type *uhost, uint32_t timeout)
usb host control data in wait handler More...
usb_sts_type | usbh_ctrl_data_out_handler (usbh_core_type *uhost)
usb host control data out request handler More...
usb_sts_type | usbh_ctrl_data_out_wait_handler (usbh_core_type *uhost, uint32_t timeout)
usb host control data out wait handler More...
usb_sts_type | usbh_ctrl_status_in_handler (usbh_core_type *uhost)
usb host control status data in handler More...
usb_sts_type | usbh_ctrl_status_in_wait_handler (usbh_core_type *uhost, uint32_t timeout)
usb host control status data in wait handler More...
usb_sts_type | usbh_ctrl_status_out_handler (usbh_core_type *uhost)
usb host control status data out wait handler More...
usb_sts_type | usbh_ctrl_status_out_wait_handler (usbh_core_type *uhost, uint32_t timeout)
usb host control status data out wait handler More...
usb_sts_type | usbh_ctrl_error_handler (usbh_core_type *uhost)
usb host control error handler More...
usb_sts_type | usbh_ctrl_stall_handler (usbh_core_type *uhost)
usb host control stall handler More...
usb_sts_type | usbh_ctrl_complete_handler (usbh_core_type *uhost)
usb host control complete handler More...
usb_sts_type | usbh_ctrl_transfer_loop (usbh_core_type *uhost)
usb host control transfer loop function More...
usb_sts_type | usbh_ctrl_request (usbh_core_type *uhost, uint8_t *buffer, uint16_t length)
usb host control request More...
usb_sts_type | usbh_get_descriptor (usbh_core_type *uhost, uint16_t length, uint8_t req_type, uint16_t wvalue, uint8_t *buffer)
usb host get device descriptor More...
void | usbh_parse_dev_desc (usbh_core_type *uhost, uint8_t *buffer, uint16_t length)
usb host parse device descriptor More...
usb_header_desc_type * | usbh_get_next_header (uint8_t *buf, uint16_t *index_len)
usb host get next header More...
void | usbh_parse_interface_desc (usb_interface_desc_type *intf, uint8_t *buf)
usb host parse interface descriptor More...
void | usbh_parse_endpoint_desc (usb_endpoint_desc_type *ept_desc, uint8_t *buf)
usb host parse endpoint descriptor More...
usb_sts_type | usbh_parse_configure_desc (usbh_core_type *uhost, uint8_t *buffer, uint16_t length)
usb host parse configure descriptor More...
uint8_t | usbh_find_interface (usbh_core_type *uhost, uint8_t class_code, uint8_t sub_class, uint8_t protocol)
usb host find interface More...
void | usbh_parse_string_desc (uint8_t *src, uint8_t *dest, uint16_t length)
usbh parse string descriptor More...
usb_sts_type | usbh_get_device_descriptor (usbh_core_type *uhost, uint16_t length)
usb host get device descriptor More...
usb_sts_type | usbh_get_configure_descriptor (usbh_core_type *uhost, uint16_t length)
usb host get configure descriptor More...
usb_sts_type | usbh_get_sting_descriptor (usbh_core_type *uhost, uint8_t string_id, uint8_t *buffer, uint16_t length)
usb host get string descriptor More...
usb_sts_type | usbh_set_configuration (usbh_core_type *uhost, uint16_t config)
usb host set configurtion More...
usb_sts_type | usbh_set_address (usbh_core_type *uhost, uint8_t address)
usb host set device address More...
usb_sts_type | usbh_set_interface (usbh_core_type *uhost, uint8_t ept_num, uint8_t altsetting)
usb host set interface More...
usb_sts_type | usbh_set_feature (usbh_core_type *uhost, uint8_t feature, uint16_t index)
usb host set feature More...
usb_sts_type | usbh_clear_dev_feature (usbh_core_type *uhost, uint8_t feature, uint16_t index)
usb host clear device feature More...
usb_sts_type | usbh_clear_ept_feature (usbh_core_type *uhost, uint8_t ept_num, uint8_t hc_num)
usb host clear endpoint feature More...

Detailed Description

Macro Definition Documentation

◆ CTRL_TIMEOUT

#define CTRL_TIMEOUT 5000

Definition at line 44 of file usbh_ctrl.c.

Function Documentation

◆ usbh_clear_dev_feature()

usb_sts_type usbh_clear_dev_feature | ( | usbh_core_type * | uhost,
 |  | uint8_t | feature,
 |  | uint16_t | index
 | ) |  |

usb host clear device feature

Parameters
uhost | to the structure of usbh_core_type
feature | feature number
index | index number
Return values
status usb_sts_type status

Definition at line 922 of file usbh_ctrl.c.

Referenced by usbh_wakeup().

◆ usbh_clear_ept_feature()

usb_sts_type usbh_clear_ept_feature | ( | usbh_core_type * | uhost,
 |  | uint8_t | ept_num,
 |  | uint8_t | hc_num
 | ) |  |

usb host clear endpoint feature

Parameters
uhost | to the structure of usbh_core_type
ept_num | endpoint number
hc_num | host channel number
Return values
status usb_sts_type status

Definition at line 944 of file usbh_ctrl.c.

Referenced by usb_bot_request().

◆ usbh_ctrl_complete_handler()

usb_sts_type usbh_ctrl_complete_handler ( usbh_core_type * uhost )

usb host control complete handler

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 444 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_data_in_handler()

usb_sts_type usbh_ctrl_data_in_handler ( usbh_core_type * uhost )

usb host control data in request handler

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 190 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_data_in_wait_handler()

usb_sts_type usbh_ctrl_data_in_wait_handler | ( | usbh_core_type * | uhost,
 |  | uint32_t | timeout
 | ) |  |

usb host control data in wait handler

Parameters
uhost | to the structure of usbh_core_type
timeout | wait timeout
Return values
status usb_sts_type status

Definition at line 207 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_data_out_handler()

usb_sts_type usbh_ctrl_data_out_handler ( usbh_core_type * uhost )

usb host control data out request handler

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 244 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_data_out_wait_handler()

usb_sts_type usbh_ctrl_data_out_wait_handler | ( | usbh_core_type * | uhost,
 |  | uint32_t | timeout
 | ) |  |

usb host control data out wait handler

Parameters
uhost | to the structure of usbh_core_type
timeout | wait timeout
Return values
status usb_sts_type status

Definition at line 263 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_error_handler()

usb_sts_type usbh_ctrl_error_handler ( usbh_core_type * uhost )

usb host control error handler

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 411 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_recv_data()

usb_sts_type usbh_ctrl_recv_data | ( | usbh_core_type * | uhost,
 |  | uint8_t * | buffer,
 |  | uint8_t | length,
 |  | uint16_t | hc_num
 | ) |  |

usb host control receive data from device

Parameters
uhost | to the structure of usbh_core_type
buffer | usb control receive data buffer
length | usb control receive data length
hc_num | channel number
Return values
status usb_sts_type status

Definition at line 71 of file usbh_ctrl.c.

Referenced by usbh_ctrl_data_in_handler(), and usbh_ctrl_status_in_handler().

◆ usbh_ctrl_request()

usb_sts_type usbh_ctrl_request | ( | usbh_core_type * | uhost,
 |  | uint8_t * | buffer,
 |  | uint16_t | length
 | ) |  |

usb host control request

Parameters
uhost | to the structure of usbh_core_type
buffer | usb request buffer
length | usb request length
Return values
status usb_sts_type status

Definition at line 530 of file usbh_ctrl.c.

Referenced by usbh_clear_dev_feature(), usbh_clear_endpoint_feature(), usbh_clear_ept_feature(), usbh_get_descriptor(), usbh_hid_set_idle(), usbh_hid_set_protocol(), usbh_msc_clear_feature(), usbh_msc_get_max_lun(), usbh_set_address(), usbh_set_configuration(), usbh_set_feature(), and usbh_set_interface().

◆ usbh_ctrl_send_data()

usb_sts_type usbh_ctrl_send_data | ( | usbh_core_type * | uhost,
 |  | uint8_t * | buffer,
 |  | uint8_t | length,
 |  | uint16_t | hc_num
 | ) |  |

usb host control send data packet

Parameters
uhost | to the structure of usbh_core_type
buffer | usb control send data buffer
length | usb control send data length
hc_num | channel number
Return values
status usb_sts_type status

Definition at line 90 of file usbh_ctrl.c.

Referenced by usbh_ctrl_data_out_handler(), and usbh_ctrl_status_out_handler().

◆ usbh_ctrl_send_setup()

usb_sts_type usbh_ctrl_send_setup | ( | usbh_core_type * | uhost,
 |  | uint8_t * | buffer,
 |  | uint8_t | hc_num
 | ) |  |

usb host control send setup packet

Parameters
uhost | to the structure of usbh_core_type
buffer | usb control setup send buffer
hc_num | channel number
Return values
status usb_sts_type status

Definition at line 53 of file usbh_ctrl.c.

Referenced by usbh_ctrl_setup_handler().

◆ usbh_ctrl_setup_handler()

usb_sts_type usbh_ctrl_setup_handler ( usbh_core_type * uhost )

usb host control setup request handler

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 117 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_setup_wait_handler()

usb_sts_type usbh_ctrl_setup_wait_handler | ( | usbh_core_type * | uhost,
 |  | uint32_t * | timeout
 | ) |  |

usb host control setup request wait handler

Parameters
uhost | to the structure of usbh_core_type
timeout | pointer of wait timeout
Return values
status usb_sts_type status

Definition at line 131 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_stall_handler()

usb_sts_type usbh_ctrl_stall_handler ( usbh_core_type * uhost )

usb host control stall handler

Parameters
uhost to the structure of usbh_core_type
Return values
usb_sts_type

Definition at line 434 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_status_in_handler()

usb_sts_type usbh_ctrl_status_in_handler ( usbh_core_type * uhost )

usb host control status data in handler

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 302 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_status_in_wait_handler()

usb_sts_type usbh_ctrl_status_in_wait_handler | ( | usbh_core_type * | uhost,
 |  | uint32_t | timeout
 | ) |  |

usb host control status data in wait handler

Parameters
uhost | to the structure of usbh_core_type
timeout | wait timeout
Return values
status usb_sts_type status

Definition at line 319 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_status_out_handler()

usb_sts_type usbh_ctrl_status_out_handler ( usbh_core_type * uhost )

usb host control status data out wait handler

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 355 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_status_out_wait_handler()

usb_sts_type usbh_ctrl_status_out_wait_handler | ( | usbh_core_type * | uhost,
 |  | uint32_t | timeout
 | ) |  |

usb host control status data out wait handler

Parameters
uhost | to the structure of usbh_core_type
timeout | wait timeout
Return values
status usb_sts_type status

Definition at line 372 of file usbh_ctrl.c.

Referenced by usbh_ctrl_transfer_loop().

◆ usbh_ctrl_transfer_loop()

usb_sts_type usbh_ctrl_transfer_loop ( usbh_core_type * uhost )

usb host control transfer loop function

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 454 of file usbh_ctrl.c.

Referenced by usbh_ctrl_result_check().

◆ usbh_find_interface()

uint8_t usbh_find_interface | ( | usbh_core_type * | uhost,
 |  | uint8_t | class_code,
 |  | uint8_t | sub_class,
 |  | uint8_t | protocol
 | ) |  |

usb host find interface

Parameters
uhost | to the structure of usbh_core_type
class_code | class code
sub_class | subclass code
protocol | prtocol code
Return values
idx interface index

Definition at line 720 of file usbh_ctrl.c.

Referenced by uhost_init_handler().

◆ usbh_get_configure_descriptor()

usb_sts_type usbh_get_configure_descriptor | ( | usbh_core_type * | uhost,
 |  | uint16_t | length
 | ) |  |

usb host get configure descriptor

Parameters
uhost | to the structure of usbh_core_type
length | get device configure length
Return values
status usb_sts_type status

Definition at line 789 of file usbh_ctrl.c.

Referenced by usbh_enum_handler().

◆ usbh_get_descriptor()

usb_sts_type usbh_get_descriptor | ( | usbh_core_type * | uhost,
 |  | uint16_t | length,
 |  | uint8_t | req_type,
 |  | uint16_t | wvalue,
 |  | uint8_t * | buffer
 | ) |  |

usb host get device descriptor

Parameters
uhost | to the structure of usbh_core_type
length | get descriptor request length
req_type | usb request type
wvalue | usb wvalue
buffer | request buffer
Return values
status usb_sts_type status

Definition at line 552 of file usbh_ctrl.c.

Referenced by usbh_get_configure_descriptor(), usbh_get_device_descriptor(), usbh_get_sting_descriptor(), usbh_hid_get_desc(), and usbh_hid_get_report().

◆ usbh_get_device_descriptor()

usb_sts_type usbh_get_device_descriptor | ( | usbh_core_type * | uhost,
 |  | uint16_t | length
 | ) |  |

usb host get device descriptor

Parameters
uhost | to the structure of usbh_core_type
length | get device descriptor length
Return values
status usb_sts_type status

Definition at line 769 of file usbh_ctrl.c.

Referenced by usbh_enum_handler().

◆ usbh_get_next_header()

usb_header_desc_type * usbh_get_next_header | ( | uint8_t * | buf,
 |  | uint16_t * | index_len
 | ) |  |

usb host get next header

Parameters
buffer | usb data buffer
index_len | pointer of index len
Return values
status usb_sts_type status

Definition at line 612 of file usbh_ctrl.c.

Referenced by usbh_parse_configure_desc().

◆ usbh_get_sting_descriptor()

usb_sts_type usbh_get_sting_descriptor | ( | usbh_core_type * | uhost,
 |  | uint8_t | string_id,
 |  | uint8_t * | buffer,
 |  | uint16_t | length
 | ) |  |

usb host get string descriptor

Parameters
uhost | to the structure of usbh_core_type
string_id | string id
buffer | receive data buffer
length | get device string length
Return values
status usb_sts_type status

Definition at line 812 of file usbh_ctrl.c.

Referenced by usbh_enum_handler().

◆ usbh_parse_configure_desc()

usb_sts_type usbh_parse_configure_desc | ( | usbh_core_type * | uhost,
 |  | uint8_t * | buffer,
 |  | uint16_t | length
 | ) |  |

usb host parse configure descriptor

Parameters
uhost | to the structure of usbh_core_type
buffer | configure buffer
length | configure length
Return values
status usb_sts_type status

Definition at line 661 of file usbh_ctrl.c.

Referenced by usbh_enum_handler().

◆ usbh_parse_dev_desc()

void usbh_parse_dev_desc | ( | usbh_core_type * | uhost,
 |  | uint8_t * | buffer,
 |  | uint16_t | length
 | ) |  |

usb host parse device descriptor

Parameters
uhost | to the structure of usbh_core_type
buffer | usb device descriptor buffer
length | usb device descriptor length
Return values
status usb_sts_type status

Definition at line 582 of file usbh_ctrl.c.

Referenced by usbh_enum_handler().

◆ usbh_parse_endpoint_desc()

void usbh_parse_endpoint_desc | ( | usb_endpoint_desc_type * | ept_desc,
 |  | uint8_t * | buf
 | ) |  |

usb host parse endpoint descriptor

Parameters
ept_desc | endpoint type
buf | endpoint description data buffer
Return values
none

Definition at line 644 of file usbh_ctrl.c.

Referenced by usbh_parse_configure_desc().

◆ usbh_parse_interface_desc()

void usbh_parse_interface_desc | ( | usb_interface_desc_type * | intf,
 |  | uint8_t * | buf
 | ) |  |

usb host parse interface descriptor

Parameters
intf | usb interface description type
buf | interface description data buffer
Return values
none

Definition at line 625 of file usbh_ctrl.c.

Referenced by usbh_parse_configure_desc().

◆ usbh_parse_string_desc()

void usbh_parse_string_desc | ( | uint8_t * | src,
 |  | uint8_t * | dest,
 |  | uint16_t | length
 | ) |  |

usbh parse string descriptor

Parameters
src | string source pointer
dest | string destination pointer
length | string length
Return values
none

Definition at line 745 of file usbh_ctrl.c.

Referenced by usbh_enum_handler().

◆ usbh_set_address()

usb_sts_type usbh_set_address | ( | usbh_core_type * | uhost,
 |  | uint8_t | address
 | ) |  |

usb host set device address

Parameters
uhost | to the structure of usbh_core_type
address | device address
Return values
status usb_sts_type status

Definition at line 855 of file usbh_ctrl.c.

Referenced by usbh_enum_handler().

◆ usbh_set_configuration()

usb_sts_type usbh_set_configuration | ( | usbh_core_type * | uhost,
 |  | uint16_t | config
 | ) |  |

usb host set configurtion

Parameters
uhost | to the structure of usbh_core_type
config | usb configuration
Return values
status usb_sts_type status

Definition at line 834 of file usbh_ctrl.c.

Referenced by usbh_enum_handler().

◆ usbh_set_feature()

usb_sts_type usbh_set_feature | ( | usbh_core_type * | uhost,
 |  | uint8_t | feature,
 |  | uint16_t | index
 | ) |  |

usb host set feature

Parameters
uhost | to the structure of usbh_core_type
feature | feature number
index | index number
Return values
status usb_sts_type status

Definition at line 899 of file usbh_ctrl.c.

Referenced by usbh_suspend().

◆ usbh_set_interface()

usb_sts_type usbh_set_interface | ( | usbh_core_type * | uhost,
 |  | uint8_t | ept_num,
 |  | uint8_t | altsetting
 | ) |  |

usb host set interface

Parameters
uhost | to the structure of usbh_core_type
ept_num | endpoint number
altsetting | alter setting
Return values
status usb_sts_type status

Definition at line 877 of file usbh_ctrl.c.


AT32F435/437 Firmwary Library: USBH_drivers_interrupt

Modules
USBH_drivers_interrupt
AT32F435_437_middlewares_usbh_drivers

usb host interrupt More...

Modules

USBH_int_private_functions

Detailed Description

usb host interrupt


AT32F435/437 Firmwary Library: USBH_int_private_functions

Functions
USBH_int_private_functions
AT32F435_437_middlewares_usbh_drivers » USBH_drivers_interrupt

Functions

void | usbh_irq_handler (otg_core_type *otgdev)
usb host interrupt handler More...
void | usbh_wakeup_handler (usbh_core_type *uhost)
usb host wakeup handler More...
void | usbh_sof_handler (usbh_core_type *uhost)
usb host sof handler More...
void | usbh_disconnect_handler (usbh_core_type *uhost)
usb host disconnect handler More...
void | usbh_hch_in_handler (usbh_core_type *uhost, uint8_t chn)
usb host in transfer request handler More...
void | usbh_hch_out_handler (usbh_core_type *uhost, uint8_t chn)
usb host out transfer request handler More...
void | usbh_hch_handler (usbh_core_type *uhost)
usb host channel request handler More...
void | usbh_rx_qlvl_handler (usbh_core_type *uhost)
usb host rx buffer not empty request handler More...
void | usbh_port_handler (usbh_core_type *uhost)
usb host port request handler More...

Detailed Description

Function Documentation

◆ usbh_disconnect_handler()

void usbh_disconnect_handler ( usbh_core_type * uhost )

usb host disconnect handler

Parameters
uhost to the structure of usbh_core_type
Return values
none

Definition at line 133 of file usbh_int.c.

Referenced by usbh_irq_handler().

◆ usbh_hch_handler()

void usbh_hch_handler ( usbh_core_type * uhost )

usb host channel request handler

Parameters
uhost to the structure of usbh_core_type
Return values
none

Definition at line 384 of file usbh_int.c.

Referenced by usbh_irq_handler().

◆ usbh_hch_in_handler()

void usbh_hch_in_handler | ( | usbh_core_type * | uhost,
 |  | uint8_t | chn
 | ) |  |

usb host in transfer request handler

Parameters
uhost | to the structure of usbh_core_type
chn | channel number
Return values
none

Definition at line 158 of file usbh_int.c.

Referenced by usbh_hch_handler().

◆ usbh_hch_out_handler()

void usbh_hch_out_handler | ( | usbh_core_type * | uhost,
 |  | uint8_t | chn
 | ) |  |

usb host out transfer request handler

Parameters
uhost | to the structure of usbh_core_type
chn | channel number
Return values
none

Definition at line 285 of file usbh_int.c.

Referenced by usbh_hch_handler().

◆ usbh_irq_handler()

void usbh_irq_handler ( otg_core_type * otgdev )

usb host interrupt handler

Parameters
otgdev to the structure of otg_core_type
Return values
none

Definition at line 47 of file usbh_int.c.

Referenced by OTG2_IRQ_HANDLER(), and OTG_IRQ_HANDLER().

◆ usbh_port_handler()

void usbh_port_handler ( usbh_core_type * uhost )

usb host port request handler

Parameters
uhost to the structure of usbh_core_type
Return values
none

Definition at line 465 of file usbh_int.c.

Referenced by usbh_irq_handler().

◆ usbh_rx_qlvl_handler()

void usbh_rx_qlvl_handler ( usbh_core_type * uhost )

usb host rx buffer not empty request handler

Parameters
uhost to the structure of usbh_core_type
Return values
none

Definition at line 414 of file usbh_int.c.

Referenced by usbh_irq_handler().

◆ usbh_sof_handler()

void usbh_sof_handler ( usbh_core_type * uhost )

usb host sof handler

Parameters
uhost to the structure of usbh_core_type
Return values
none

Definition at line 123 of file usbh_int.c.

Referenced by usbh_irq_handler().

◆ usbh_wakeup_handler()

void usbh_wakeup_handler ( usbh_core_type * uhost )

usb host wakeup handler

Parameters
uhost to the structure of usbh_core_type
Return values
none

Definition at line 113 of file usbh_int.c.

Referenced by usbh_irq_handler().


AT32F435/437 Firmwary Library: USBH_drivers_int

Modules
USBH_drivers_int
AT32F435_437_middlewares_usbh_drivers

Modules

USBH_interrupt_exported_types

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: USBH_interrupt_exported_types

Functions
USBH_interrupt_exported_types
AT32F435_437_middlewares_usbh_drivers » USBH_drivers_int

Functions

void | usbh_irq_handler (otg_core_type *hdev)
usb host interrupt handler More...
void | usbh_hch_handler (usbh_core_type *uhost)
usb host channel request handler More...
void | usbh_port_handler (usbh_core_type *uhost)
usb host port request handler More...
void | usbh_disconnect_handler (usbh_core_type *uhost)
usb host disconnect handler More...
void | usbh_hch_in_handler (usbh_core_type *uhost, uint8_t chn)
usb host in transfer request handler More...
void | usbh_hch_out_handler (usbh_core_type *uhost, uint8_t chn)
usb host out transfer request handler More...
void | usbh_rx_qlvl_handler (usbh_core_type *uhost)
usb host rx buffer not empty request handler More...
void | usbh_wakeup_handler (usbh_core_type *uhost)
usb host wakeup handler More...
void | usbh_sof_handler (usbh_core_type *uhost)
usb host sof handler More...

Detailed Description

Function Documentation

◆ usbh_disconnect_handler()

void usbh_disconnect_handler ( usbh_core_type * uhost )

usb host disconnect handler

Parameters
uhost to the structure of usbh_core_type
Return values
none

Definition at line 133 of file usbh_int.c.

Referenced by usbh_irq_handler().

◆ usbh_hch_handler()

void usbh_hch_handler ( usbh_core_type * uhost )

usb host channel request handler

Parameters
uhost to the structure of usbh_core_type
Return values
none

Definition at line 384 of file usbh_int.c.

Referenced by usbh_irq_handler().

◆ usbh_hch_in_handler()

void usbh_hch_in_handler | ( | usbh_core_type * | uhost,
 |  | uint8_t | chn
 | ) |  |

usb host in transfer request handler

Parameters
uhost | to the structure of usbh_core_type
chn | channel number
Return values
none

Definition at line 158 of file usbh_int.c.

Referenced by usbh_hch_handler().

◆ usbh_hch_out_handler()

void usbh_hch_out_handler | ( | usbh_core_type * | uhost,
 |  | uint8_t | chn
 | ) |  |

usb host out transfer request handler

Parameters
uhost | to the structure of usbh_core_type
chn | channel number
Return values
none

Definition at line 285 of file usbh_int.c.

Referenced by usbh_hch_handler().

◆ usbh_irq_handler()

void usbh_irq_handler ( otg_core_type * otgdev )

usb host interrupt handler

Parameters
otgdev to the structure of otg_core_type
Return values
none

Definition at line 47 of file usbh_int.c.

Referenced by OTG2_IRQ_HANDLER(), and OTG_IRQ_HANDLER().

◆ usbh_port_handler()

void usbh_port_handler ( usbh_core_type * uhost )

usb host port request handler

Parameters
uhost to the structure of usbh_core_type
Return values
none

Definition at line 465 of file usbh_int.c.

Referenced by usbh_irq_handler().

◆ usbh_rx_qlvl_handler()

void usbh_rx_qlvl_handler ( usbh_core_type * uhost )

usb host rx buffer not empty request handler

Parameters
uhost to the structure of usbh_core_type
Return values
none

Definition at line 414 of file usbh_int.c.

Referenced by usbh_irq_handler().

◆ usbh_sof_handler()

void usbh_sof_handler ( usbh_core_type * uhost )

usb host sof handler

Parameters
uhost to the structure of usbh_core_type
Return values
none

Definition at line 123 of file usbh_int.c.

Referenced by usbh_irq_handler().

◆ usbh_wakeup_handler()

void usbh_wakeup_handler ( usbh_core_type * uhost )

usb host wakeup handler

Parameters
uhost to the structure of usbh_core_type
Return values
none

Definition at line 113 of file usbh_int.c.

Referenced by usbh_irq_handler().


AT32F435/437 Firmwary Library: AT32F435_437_middlewares_usbd_class

Modules | Variables
AT32F435_437_middlewares_usbd_class

Modules

USB_audio_class
usb device class audio demo
USB_audio_desc
usb device audio descriptor
USB_audio_hid_class
usb device class audio hid demo
USB_audio_hid_desc
usb device audio hid descriptor
USB_cdc_class
usb device class cdc demo
USB_cdc_desc
usb device cdc descriptor
USB_cdc_keyboard_class
usb device class composite cdc and keyboard
USB_cdc_keyboard_desc
usb device cdc keyboard descriptor
USB_cdc_msc_class
usb device class cdc msc demo
USB_cdc_msc_desc
usb device cdc msc descriptor
USB_msc_bot_scsi
usb device class mass storage demo
USB_custom_hid_class
usb device custom hid demo
USB_custom_hid_desc
usb device custom_hid descriptor
USB_hid_iap_class
usb device class hid iap demo
USB_hid_iap_desc
usb device hid_iap descriptor
USB_keyboard_class
usb device keyboard demo
USB_keyboard_desc
usb device keyboard descriptor
USB_mouse_class
usb device mouse demo
USB_mouse_desc
usb device mouse descriptor
USB_msc_class
usb device class msc demo
USB_msc_desc
usb device msc descriptor
USB_printer_class
usb device class printer demo
USB_printer_desc
usb device printer descriptor

Variables

uint8_t | cbd_typical_type::opcode
uint8_t | cbd_typical_type::lun
uint32_t | cbd_typical_type::address
uint8_t | cbd_typical_type::reserved1
uint32_t | cbd_typical_type::alloc_length
uint16_t | cbd_typical_type::reserved2
uint8_t | cbd_extended_type::opcode
uint8_t | cbd_extended_type::lun
uint32_t | cbd_extended_type::address
uint8_t | cbd_extended_type::reserved1
uint32_t | cbd_extended_type::alloc_length
uint16_t | cbd_extended_type::reserved2
uint32_t | cbw_type::dCBWSignature
uint32_t | cbw_type::dCBWTage
uint32_t | cbw_type::dCBWDataTransferLength
uint8_t | cbw_type::bmCBWFlags
uint8_t | cbw_type::bCBWLUN
uint8_t | cbw_type::bCBWCBLength
uint8_t | cbw_type::CBWCB [16]
uint32_t | csw_type::dCSWSignature
uint32_t | csw_type::dCSWTag
uint32_t | csw_type::dCSWDataResidue
uint32_t | csw_type::bCSWStatus
uint8_t | sense_type::err_code
uint8_t | sense_type::reserved1
uint8_t | sense_type::sense_key
uint32_t | sense_type::information
uint8_t | sense_type::as_length
uint32_t | sense_type::reserved2
uint8_t | sense_type::asc
uint8_t | sense_type::ascq
uint32_t | sense_type::reserved3
uint8_t | msc_type::msc_state
uint8_t | msc_type::bot_status
uint32_t | msc_type::max_lun
uint32_t | msc_type::blk_nbr [1]
uint32_t | msc_type::blk_size [1]
uint32_t | msc_type::blk_addr
uint32_t | msc_type::blk_len
uint32_t | msc_type::data_len
uint8_t | msc_type::data [4096]
uint32_t | msc_type::alt_setting
cbw_type msc_type::cbw_struct
csw_type msc_type::csw_struct
uint32_t | cdc_msc_struct_type::alt_setting
uint8_t | cdc_msc_struct_type::g_rx_buff [0x40]
uint8_t | cdc_msc_struct_type::g_cmd [0x08]
uint8_t | cdc_msc_struct_type::g_req
uint16_t | cdc_msc_struct_type::g_len
uint16_t | cdc_msc_struct_type::g_rxlen
__IO uint8_t | cdc_msc_struct_type::g_tx_completed
__IO uint8_t | cdc_msc_struct_type::g_rx_completed
linecoding_type cdc_msc_struct_type::linecoding
uint8_t | cdc_msc_struct_type::msc_state
uint8_t | cdc_msc_struct_type::bot_status
uint32_t | cdc_msc_struct_type::max_lun
uint32_t | cdc_msc_struct_type::blk_nbr [1]
uint32_t | cdc_msc_struct_type::blk_size [1]
uint32_t | cdc_msc_struct_type::blk_addr
uint32_t | cdc_msc_struct_type::blk_len
uint32_t | cdc_msc_struct_type::data_len
uint8_t | cdc_msc_struct_type::data [4096]
cbw_type cdc_msc_struct_type::cbw_struct
csw_type cdc_msc_struct_type::csw_struct

Detailed Description

Variable Documentation

◆ address [1/2]

uint32_t cbd_typical_type::address

Definition at line 166 of file cdc_msc_class.h.

◆ address [2/2]

uint32_t cbd_extended_type::address

Definition at line 179 of file cdc_msc_class.h.

◆ alloc_length [1/2]

uint32_t cbd_typical_type::alloc_length

Definition at line 168 of file cdc_msc_class.h.

◆ alloc_length [2/2]

uint32_t cbd_extended_type::alloc_length

Definition at line 181 of file cdc_msc_class.h.

◆ alt_setting [1/2]

uint32_t msc_type::alt_setting

Definition at line 242 of file cdc_msc_class.h.

Referenced by class_setup_handler().

◆ alt_setting [2/2]

uint32_t cdc_msc_struct_type::alt_setting

Definition at line 255 of file cdc_msc_class.h.

Referenced by cdc_class_setup_handler(), cdc_struct_init(), and msc_class_setup_handler().

◆ as_length

uint8_t sense_type::as_length

Definition at line 219 of file cdc_msc_class.h.

◆ asc

uint8_t sense_type::asc

Definition at line 221 of file cdc_msc_class.h.

◆ ascq

uint8_t sense_type::ascq

Definition at line 222 of file cdc_msc_class.h.

◆ bCBWCBLength

uint8_t cbw_type::bCBWCBLength

Definition at line 195 of file cdc_msc_class.h.

Referenced by bot_cbw_decode().

◆ bCBWLUN

uint8_t cbw_type::bCBWLUN

Definition at line 194 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), and bot_scsi_cmd_process().

◆ bCSWStatus

uint32_t csw_type::bCSWStatus

Definition at line 207 of file cdc_msc_class.h.

Referenced by bot_scsi_send_csw(), and bot_scsi_send_data().

◆ blk_addr [1/2]

uint32_t msc_type::blk_addr

Definition at line 236 of file cdc_msc_class.h.

Referenced by bot_scsi_read10(), bot_scsi_verify(), and bot_scsi_write10().

◆ blk_addr [2/2]

uint32_t cdc_msc_struct_type::blk_addr

Definition at line 271 of file cdc_msc_class.h.

Referenced by bot_scsi_read10(), bot_scsi_verify(), and bot_scsi_write10().

◆ blk_len [1/2]

uint32_t msc_type::blk_len

Definition at line 237 of file cdc_msc_class.h.

Referenced by bot_scsi_read10(), bot_scsi_verify(), and bot_scsi_write10().

◆ blk_len [2/2]

uint32_t cdc_msc_struct_type::blk_len

Definition at line 272 of file cdc_msc_class.h.

Referenced by bot_scsi_read10(), bot_scsi_verify(), and bot_scsi_write10().

◆ blk_nbr [1/2]

uint32_t msc_type::blk_nbr

Definition at line 233 of file cdc_msc_class.h.

Referenced by bot_scsi_capacity(), bot_scsi_check_address(), and bot_scsi_format_capacity().

◆ blk_nbr [2/2]

uint32_t cdc_msc_struct_type::blk_nbr[1]

Definition at line 268 of file cdc_msc_class.h.

Referenced by bot_scsi_capacity(), bot_scsi_check_address(), and bot_scsi_format_capacity().

◆ blk_size [1/2]

uint32_t msc_type::blk_size

Definition at line 234 of file cdc_msc_class.h.

Referenced by bot_scsi_capacity(), bot_scsi_format_capacity(), bot_scsi_read10(), and bot_scsi_write10().

◆ blk_size [2/2]

uint32_t cdc_msc_struct_type::blk_size[1]

Definition at line 269 of file cdc_msc_class.h.

Referenced by bot_scsi_capacity(), bot_scsi_format_capacity(), bot_scsi_read10(), and bot_scsi_write10().

◆ bmCBWFlags

uint8_t cbw_type::bmCBWFlags

Definition at line 193 of file cdc_msc_class.h.

Referenced by bot_scsi_read10(), bot_scsi_stall(), and bot_scsi_write10().

◆ bot_status [1/2]

uint8_t msc_type::bot_status

Definition at line 230 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_clear_feature(), bot_scsi_init(), bot_scsi_reset(), and bot_scsi_stall().

◆ bot_status [2/2]

uint8_t cdc_msc_struct_type::bot_status

Definition at line 265 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_clear_feature(), bot_scsi_init(), bot_scsi_reset(), and bot_scsi_stall().

◆ cbw_struct [1/2]

cbw_type msc_type::cbw_struct

Definition at line 244 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_cmd_process(), bot_scsi_init(), bot_scsi_inquiry(), bot_scsi_read10(), bot_scsi_request_sense(), bot_scsi_reset(), bot_scsi_send_csw(), bot_scsi_send_data(), bot_scsi_stall(), bot_scsi_test_unit(), bot_scsi_verify(), and bot_scsi_write10().

◆ cbw_struct [2/2]

cbw_type cdc_msc_struct_type::cbw_struct

Definition at line 277 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_cmd_process(), bot_scsi_init(), bot_scsi_inquiry(), bot_scsi_read10(), bot_scsi_request_sense(), bot_scsi_reset(), bot_scsi_send_csw(), bot_scsi_send_data(), bot_scsi_stall(), bot_scsi_test_unit(), bot_scsi_verify(), and bot_scsi_write10().

◆ CBWCB

uint8_t cbw_type::CBWCB

Definition at line 196 of file cdc_msc_class.h.

Referenced by bot_scsi_cmd_process(), bot_scsi_inquiry(), bot_scsi_read10(), bot_scsi_verify(), and bot_scsi_write10().

◆ csw_struct [1/2]

csw_type msc_type::csw_struct

Definition at line 245 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_init(), bot_scsi_read10(), bot_scsi_send_csw(), bot_scsi_send_data(), and bot_scsi_write10().

◆ csw_struct [2/2]

csw_type cdc_msc_struct_type::csw_struct

Definition at line 278 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_init(), bot_scsi_read10(), bot_scsi_send_csw(), bot_scsi_send_data(), and bot_scsi_write10().

◆ data [1/2]

uint8_t msc_type::data

Definition at line 240 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_capacity(), bot_scsi_format_capacity(), bot_scsi_inquiry(), bot_scsi_mode_sense10(), bot_scsi_mode_sense6(), bot_scsi_read10(), bot_scsi_request_sense(), bot_scsi_write10(), and usbh_cmd_capacity10().

◆ data [2/2]

uint8_t cdc_msc_struct_type::data[4096]

Definition at line 275 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_capacity(), bot_scsi_format_capacity(), bot_scsi_inquiry(), bot_scsi_mode_sense10(), bot_scsi_mode_sense6(), bot_scsi_read10(), bot_scsi_request_sense(), and bot_scsi_write10().

◆ data_len [1/2]

uint32_t msc_type::data_len

Definition at line 239 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_allow_medium_removal(), bot_scsi_capacity(), bot_scsi_format_capacity(), bot_scsi_inquiry(), bot_scsi_mode_sense10(), bot_scsi_mode_sense6(), bot_scsi_read10(), bot_scsi_request_sense(), bot_scsi_start_stop(), bot_scsi_test_unit(), and bot_scsi_verify().

◆ data_len [2/2]

uint32_t cdc_msc_struct_type::data_len

Definition at line 274 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_allow_medium_removal(), bot_scsi_capacity(), bot_scsi_format_capacity(), bot_scsi_inquiry(), bot_scsi_mode_sense10(), bot_scsi_mode_sense6(), bot_scsi_read10(), bot_scsi_request_sense(), bot_scsi_start_stop(), bot_scsi_test_unit(), and bot_scsi_verify().

◆ dCBWDataTransferLength

uint32_t cbw_type::dCBWDataTransferLength

Definition at line 192 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_inquiry(), bot_scsi_read10(), bot_scsi_request_sense(), bot_scsi_send_data(), bot_scsi_stall(), bot_scsi_test_unit(), and bot_scsi_write10().

◆ dCBWSignature

uint32_t cbw_type::dCBWSignature

Definition at line 190 of file cdc_msc_class.h.

Referenced by bot_cbw_decode().

◆ dCBWTage

uint32_t cbw_type::dCBWTage

Definition at line 191 of file cdc_msc_class.h.

Referenced by bot_cbw_decode().

◆ dCSWDataResidue

uint32_t csw_type::dCSWDataResidue

Definition at line 206 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_init(), bot_scsi_read10(), bot_scsi_send_data(), and bot_scsi_write10().

◆ dCSWSignature

uint32_t csw_type::dCSWSignature

Definition at line 204 of file cdc_msc_class.h.

Referenced by bot_scsi_init(), and bot_scsi_send_csw().

◆ dCSWTag

uint32_t csw_type::dCSWTag

Definition at line 205 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), and bot_scsi_init().

◆ err_code

uint8_t sense_type::err_code

Definition at line 215 of file cdc_msc_class.h.

◆ g_cmd

uint8_t cdc_msc_struct_type::g_cmd[0x08]

Definition at line 257 of file cdc_msc_class.h.

Referenced by cdc_class_setup_handler(), and class_ept0_rx_handler().

◆ g_len

uint16_t cdc_msc_struct_type::g_len

Definition at line 259 of file cdc_msc_class.h.

Referenced by cdc_class_setup_handler().

◆ g_req

uint8_t cdc_msc_struct_type::g_req

Definition at line 258 of file cdc_msc_class.h.

Referenced by cdc_class_setup_handler(), and class_ept0_rx_handler().

◆ g_rx_buff

uint8_t cdc_msc_struct_type::g_rx_buff[0x40]

Definition at line 256 of file cdc_msc_class.h.

Referenced by class_init_handler().

◆ g_rx_completed

__IO uint8_t cdc_msc_struct_type::g_rx_completed

Definition at line 260 of file cdc_msc_class.h.

Referenced by cdc_struct_init(), and class_out_handler().

◆ g_rxlen

uint16_t cdc_msc_struct_type::g_rxlen

Definition at line 259 of file cdc_msc_class.h.

Referenced by class_out_handler().

◆ g_tx_completed

__IO uint8_t cdc_msc_struct_type::g_tx_completed

Definition at line 260 of file cdc_msc_class.h.

Referenced by cdc_struct_init(), and class_in_handler().

◆ information

uint32_t sense_type::information

Definition at line 218 of file cdc_msc_class.h.

◆ linecoding

linecoding_type cdc_msc_struct_type::linecoding

Definition at line 261 of file cdc_msc_class.h.

Referenced by cdc_struct_init(), and usb_vcp_cmd_process().

◆ lun [1/2]

uint8_t cbd_typical_type::lun

Definition at line 165 of file cdc_msc_class.h.

◆ lun [2/2]

uint8_t cbd_extended_type::lun

Definition at line 178 of file cdc_msc_class.h.

◆ max_lun [1/2]

uint32_t msc_type::max_lun

Definition at line 231 of file cdc_msc_class.h.

Referenced by bot_scsi_init(), bot_scsi_reset(), class_setup_handler(), and msc_bot_scsi_init().

◆ max_lun [2/2]

uint32_t cdc_msc_struct_type::max_lun

Definition at line 266 of file cdc_msc_class.h.

Referenced by bot_scsi_init(), bot_scsi_reset(), and msc_class_setup_handler().

◆ msc_state [1/2]

uint8_t msc_type::msc_state

Definition at line 229 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_datain_handler(), bot_scsi_dataout_handler(), bot_scsi_init(), bot_scsi_read10(), bot_scsi_reset(), bot_scsi_send_csw(), bot_scsi_send_data(), and bot_scsi_write10().

◆ msc_state [2/2]

uint8_t cdc_msc_struct_type::msc_state

Definition at line 264 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_datain_handler(), bot_scsi_dataout_handler(), bot_scsi_init(), bot_scsi_read10(), bot_scsi_reset(), bot_scsi_send_csw(), bot_scsi_send_data(), and bot_scsi_write10().

◆ opcode [1/2]

uint8_t cbd_typical_type::opcode

Definition at line 164 of file cdc_msc_class.h.

◆ opcode [2/2]

uint8_t cbd_extended_type::opcode

Definition at line 177 of file cdc_msc_class.h.

◆ reserved1 [1/3]

uint8_t cbd_typical_type::reserved1

Definition at line 167 of file cdc_msc_class.h.

◆ reserved1 [2/3]

uint8_t cbd_extended_type::reserved1

Definition at line 180 of file cdc_msc_class.h.

◆ reserved1 [3/3]

uint8_t sense_type::reserved1

Definition at line 216 of file cdc_msc_class.h.

◆ reserved2 [1/3]

uint16_t cbd_typical_type::reserved2

Definition at line 169 of file cdc_msc_class.h.

◆ reserved2 [2/3]

uint16_t cbd_extended_type::reserved2

Definition at line 182 of file cdc_msc_class.h.

◆ reserved2 [3/3]

uint32_t sense_type::reserved2

Definition at line 220 of file cdc_msc_class.h.

◆ reserved3

uint32_t sense_type::reserved3

Definition at line 223 of file cdc_msc_class.h.

◆ sense_key

uint8_t sense_type::sense_key

Definition at line 217 of file cdc_msc_class.h.


AT32F435/437 Firmwary Library: USB_audio_class

Modules
USB_audio_class
AT32F435_437_middlewares_usbd_class

usb device class audio demo More...

Modules

USB_audio_class_private_functions
USB_audio_class_definition
USB_device_audio_config_definition

Detailed Description

usb device class audio demo


AT32F435/437 Firmwary Library: USB_audio_class_private_functions

Functions | Variables
USB_audio_class_private_functions
AT32F435_437_middlewares_usbd_class » USB_audio_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
static void | audio_inisoincom_event (void *udev)
usb audio in iso incom event More...
static void | audio_req_get_cur (void *udev, usb_setup_type *setup)
usb audio request get cur More...
static void | audio_req_set_cur (void *udev, usb_setup_type *setup)
usb audio request set cur More...
static void | audio_req_get_min (void *udev, usb_setup_type *setup)
usb audio request get min More...
static void | audio_req_get_max (void *udev, usb_setup_type *setup)
usb audio request get max More...
static void | audio_req_get_res (void *udev, usb_setup_type *setup)
usb audio request get res More...
static void | audio_get_interface (void *udev, usb_setup_type *setup)
usb audio get interface More...
static void | audio_set_interface (void *udev, usb_setup_type *setup)
usb audio set interface More...

Variables

usb_audio_type | audio_struct = {0, 0, 0, 0, 0, 0x1400, 0, 0, 0, {0x0000, 0x1400, 0x33}, {0x0000, 0x1400, 0x33}, 0, 0}
usbd_class_handler | audio_class_handler

Detailed Description

Function Documentation

◆ audio_get_interface()

static void audio_get_interface | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio get interface

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 657 of file audio_class.c.

Referenced by class_setup_handler().

◆ audio_inisoincom_event()

static void audio_inisoincom_event ( void * udev )
static

usb audio in iso incom event

Parameters
udev usb device core handler type
Return values
none

Definition at line 440 of file audio_class.c.

Referenced by class_event_handler().

◆ audio_req_get_cur()

static void audio_req_get_cur | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request get cur

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 477 of file audio_class.c.

Referenced by class_setup_handler().

◆ audio_req_get_max()

static void audio_req_get_max | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request get max

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 578 of file audio_class.c.

Referenced by class_setup_handler().

◆ audio_req_get_min()

static void audio_req_get_min | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request get min

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 556 of file audio_class.c.

Referenced by class_setup_handler().

◆ audio_req_get_res()

static void audio_req_get_res | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request get res

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 600 of file audio_class.c.

Referenced by class_setup_handler().

◆ audio_req_set_cur()

static void audio_req_set_cur | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request set cur

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 516 of file audio_class.c.

Referenced by class_setup_handler().

◆ audio_set_interface()

static void audio_set_interface | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio set interface

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 622 of file audio_class.c.

Referenced by class_setup_handler().

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 111 of file audio_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device endpoint 0 out status stage complete

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 229 of file audio_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device endpoint 0 in status stage complete

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 215 of file audio_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device event handler

Parameters
udev | usb device core handler type
event | usb device event
Return values
status of usb_sts_type

Definition at line 401 of file audio_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device transmision complete handler

Parameters
udev | usb device core handler type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 300 of file audio_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb custom hid endpoint

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 85 of file audio_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device endpoint receive data

Parameters
udev | usb device core handler type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 331 of file audio_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | usb device core handler type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 136 of file audio_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device sof handler

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 358 of file audio_class.c.

Variable Documentation

◆ audio_class_handler

usbd_class_handler audio_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&audio_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: audio_class.c:358
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: audio_class.c:300
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: audio_class.c:111
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: audio_class.c:136
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: audio_class.c:215
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: audio_class.c:229
audio_struct
usb_audio_type audio_struct
Definition: audio_class.c:63
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: audio_class.c:401
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: audio_class.c:85
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: audio_class.c:331

Definition at line 66 of file audio_class.c.

Referenced by main().

◆ audio_struct

usb_audio_type audio_struct = {0, 0, 0, 0, 0, 0x1400, 0, 0, 0, {0x0000, 0x1400, 0x33}, {0x0000, 0x1400, 0x33}, 0, 0}

Definition at line 63 of file audio_class.c.


AT32F435/437 Firmwary Library: USB_audio_class_definition

Data Structures | Macros | Variables
USB_audio_class_definition
AT32F435_437_middlewares_usbd_class » USB_audio_class

Data Structures

struct usb_audio_type
usb audio control struct More...

Macros

#define | USBD_AUDIO_MIC_IN_EPT 0x81
endpoint define More...
#define | USBD_AUDIO_SPK_OUT_EPT 0x02
#define | USBD_AUDIO_FEEDBACK_EPT 0x83
#define | AUDIO_REMAIN_SIZE 40
endpoint support max size More...
#define | AUDIO_MIC_IN_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_MIC_CHANEL_NUM * (AUDIO_MIC_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
#define | AUDIO_SPK_OUT_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_SPK_CHANEL_NUM * (AUDIO_SPK_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
#define | AUDIO_FEEDBACK_MAXPACKET_SIZE 0x3
#define | FEEDBACK_REFRESH_TIME 0x8
#define | AUDIO_REQ_CONTROL_INTERFACE 0x01
request type define More...
#define | AUDIO_REQ_CONTROL_ENDPOINT 0x02
#define | AUDIO_REQ_CONTROL_MASK 0x03
#define | AUDIO_MUTE_CONTROL 0x01
audio set cur type define More...
#define | AUDIO_VOLUME_CONTROL 0x02
#define | AUDIO_FREQ_SET_CONTROL 0x03
#define | AUDIO_DESCRIPTOR_TYPE 0x21
audio descriptor type More...
#define | AUDIO_DESCRIPTOR_SIZE 0x09

Variables

usbd_class_handler audio_class_handler

Detailed Description

Macro Definition Documentation

◆ AUDIO_DESCRIPTOR_SIZE

#define AUDIO_DESCRIPTOR_SIZE 0x09

Definition at line 84 of file audio_class.h.

◆ AUDIO_DESCRIPTOR_TYPE

#define AUDIO_DESCRIPTOR_TYPE 0x21

audio descriptor type

Definition at line 83 of file audio_class.h.

◆ AUDIO_FEEDBACK_MAXPACKET_SIZE

#define AUDIO_FEEDBACK_MAXPACKET_SIZE 0x3

Definition at line 64 of file audio_class.h.

◆ AUDIO_FREQ_SET_CONTROL

#define AUDIO_FREQ_SET_CONTROL 0x03

Definition at line 78 of file audio_class.h.

◆ AUDIO_MIC_IN_MAXPACKET_SIZE

#define AUDIO_MIC_IN_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_MIC_CHANEL_NUM * (AUDIO_MIC_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)

Definition at line 62 of file audio_class.h.

◆ AUDIO_MUTE_CONTROL

#define AUDIO_MUTE_CONTROL 0x01

audio set cur type define

Definition at line 76 of file audio_class.h.

◆ AUDIO_REMAIN_SIZE

#define AUDIO_REMAIN_SIZE 40

endpoint support max size

Definition at line 61 of file audio_class.h.

◆ AUDIO_REQ_CONTROL_ENDPOINT

#define AUDIO_REQ_CONTROL_ENDPOINT 0x02

Definition at line 70 of file audio_class.h.

◆ AUDIO_REQ_CONTROL_INTERFACE

#define AUDIO_REQ_CONTROL_INTERFACE 0x01

request type define

Definition at line 69 of file audio_class.h.

◆ AUDIO_REQ_CONTROL_MASK

#define AUDIO_REQ_CONTROL_MASK 0x03

Definition at line 71 of file audio_class.h.

◆ AUDIO_SPK_OUT_MAXPACKET_SIZE

#define AUDIO_SPK_OUT_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_SPK_CHANEL_NUM * (AUDIO_SPK_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)

Definition at line 63 of file audio_class.h.

◆ AUDIO_VOLUME_CONTROL

#define AUDIO_VOLUME_CONTROL 0x02

Definition at line 77 of file audio_class.h.

◆ FEEDBACK_REFRESH_TIME

#define FEEDBACK_REFRESH_TIME 0x8

Definition at line 65 of file audio_class.h.

◆ USBD_AUDIO_FEEDBACK_EPT

#define USBD_AUDIO_FEEDBACK_EPT 0x83

Definition at line 56 of file audio_class.h.

◆ USBD_AUDIO_MIC_IN_EPT

#define USBD_AUDIO_MIC_IN_EPT 0x81

endpoint define

Definition at line 54 of file audio_class.h.

◆ USBD_AUDIO_SPK_OUT_EPT

#define USBD_AUDIO_SPK_OUT_EPT 0x02

Definition at line 55 of file audio_class.h.

Variable Documentation

◆ audio_class_handler

usbd_class_handler audio_class_handler
extern

Definition at line 66 of file audio_class.c.

Referenced by main().


AT32F435/437 Firmwary Library: usb_audio_type Struct Reference

Data Fields
usb_audio_type Struct Reference
AT32F435_437_middlewares_usbd_class » USB_audio_class » USB_audio_class_definition

usb audio control struct More...

#include <audio_class.h>

Data Fields

uint8_t | enpd
uint8_t | interface
uint8_t | request_no
uint8_t | spk_mute
uint8_t | mic_mute
uint16_t | spk_volume
uint16_t | mic_volume
uint32_t | spk_freq
uint32_t | mic_freq
uint16_t | spk_volume_limits [3]
uint16_t | mic_volume_limits [3]
uint8_t | audio_cmd
uint32_t | audio_cmd_len
uint32_t | spk_alt_setting
uint32_t | mic_alt_setting
uint8_t | g_audio_cur [64]
uint8_t | audio_spk_data [(48 *2 *(16/8)+40)]
uint8_t | audio_mic_data [(48 *2 *(16/8)+40)]
uint8_t | audio_feed_back [0x3+1]
__IO uint16_t | audio_feedback_state
__IO uint8_t | audio_spk_out_stage

Detailed Description

usb audio control struct

Definition at line 89 of file audio_class.h.

Field Documentation

◆ audio_cmd

uint8_t usb_audio_type::audio_cmd

Definition at line 103 of file audio_class.h.

Referenced by audio_req_set_cur(), and class_ept0_rx_handler().

◆ audio_cmd_len

uint32_t usb_audio_type::audio_cmd_len

Definition at line 104 of file audio_class.h.

Referenced by audio_req_set_cur().

◆ audio_feed_back

uint8_t usb_audio_type::audio_feed_back[0x3+1]

Definition at line 110 of file audio_class.h.

Referenced by audio_inisoincom_event(), and class_sof_handler().

◆ audio_feedback_state

__IO uint16_t usb_audio_type::audio_feedback_state

Definition at line 112 of file audio_class.h.

Referenced by class_in_handler(), and class_sof_handler().

◆ audio_mic_data

uint8_t usb_audio_type::audio_mic_data[(48 * 2 *( 16/8)+ 40)]

Definition at line 109 of file audio_class.h.

Referenced by audio_inisoincom_event(), audio_set_interface(), and class_in_handler().

◆ audio_spk_data

uint8_t usb_audio_type::audio_spk_data[(48 * 2 *( 16/8)+ 40)]

Definition at line 108 of file audio_class.h.

Referenced by audio_set_interface(), class_init_handler(), and class_out_handler().

◆ audio_spk_out_stage

__IO uint8_t usb_audio_type::audio_spk_out_stage

Definition at line 113 of file audio_class.h.

Referenced by class_out_handler(), and class_sof_handler().

◆ enpd

uint8_t usb_audio_type::enpd

Definition at line 91 of file audio_class.h.

Referenced by audio_req_set_cur(), and class_ept0_rx_handler().

◆ g_audio_cur

uint8_t usb_audio_type::g_audio_cur[64]

Definition at line 107 of file audio_class.h.

Referenced by audio_req_get_cur(), audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), audio_req_set_cur(), and class_ept0_rx_handler().

◆ interface

uint8_t usb_audio_type::interface

Definition at line 92 of file audio_class.h.

Referenced by audio_req_set_cur(), and class_ept0_rx_handler().

◆ mic_alt_setting

uint32_t usb_audio_type::mic_alt_setting

Definition at line 106 of file audio_class.h.

Referenced by audio_get_interface(), audio_set_interface(), and class_event_handler().

◆ mic_freq

uint32_t usb_audio_type::mic_freq

Definition at line 99 of file audio_class.h.

Referenced by class_ept0_rx_handler().

◆ mic_mute

uint8_t usb_audio_type::mic_mute

Definition at line 95 of file audio_class.h.

Referenced by audio_req_get_cur(), and class_ept0_rx_handler().

◆ mic_volume

uint16_t usb_audio_type::mic_volume

Definition at line 97 of file audio_class.h.

Referenced by audio_req_get_cur(), and class_ept0_rx_handler().

◆ mic_volume_limits

uint16_t usb_audio_type::mic_volume_limits[3]

Definition at line 101 of file audio_class.h.

Referenced by audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), and class_ept0_rx_handler().

◆ request_no

uint8_t usb_audio_type::request_no

Definition at line 93 of file audio_class.h.

Referenced by audio_req_set_cur(), and class_ept0_rx_handler().

◆ spk_alt_setting

uint32_t usb_audio_type::spk_alt_setting

Definition at line 105 of file audio_class.h.

Referenced by audio_get_interface(), audio_set_interface(), and class_event_handler().

◆ spk_freq

uint32_t usb_audio_type::spk_freq

Definition at line 98 of file audio_class.h.

Referenced by class_ept0_rx_handler().

◆ spk_mute

uint8_t usb_audio_type::spk_mute

Definition at line 94 of file audio_class.h.

Referenced by audio_req_get_cur(), and class_ept0_rx_handler().

◆ spk_volume

uint16_t usb_audio_type::spk_volume

Definition at line 96 of file audio_class.h.

Referenced by audio_req_get_cur(), and class_ept0_rx_handler().

◆ spk_volume_limits

uint16_t usb_audio_type::spk_volume_limits[3]

Definition at line 100 of file audio_class.h.

Referenced by audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), and class_ept0_rx_handler().

The documentation for this struct was generated from the following file:
  • audio_class.h


AT32F435/437 Firmwary Library: USB_device_audio_config_definition

Macros
USB_device_audio_config_definition
AT32F435_437_middlewares_usbd_class » USB_audio_class

Macros

#define | AUDIO_SUPPORT_SPK 1
#define | AUDIO_SUPPORT_MIC 1
#define | AUDIO_SUPPORT_FEEDBACK 1
#define | AUDIO_SUPPORT_FREQ_16K 0
#define | AUDIO_SUPPORT_FREQ_48K 1
#define | AUDIO_SUPPORT_FREQ
#define | AUDIO_FREQ_16K 16000
#define | AUDIO_FREQ_48K 48000
#define | AUDIO_BITW_16 16
#define | AUDIO_MIC_CHANEL_NUM 2
#define | AUDIO_MIC_DEFAULT_BITW AUDIO_BITW_16
#define | AUDIO_SPK_CHANEL_NUM 2
#define | AUDIO_SPK_DEFAULT_BITW AUDIO_BITW_16
#define | AUDIO_SUPPORT_MAX_FREQ 48
#define | AUDIO_DEFAULT_FREQ AUDIO_FREQ_48K
#define | AUDIO_DEFAULT_BITW AUDIO_BITW_16

Detailed Description

Macro Definition Documentation

◆ AUDIO_BITW_16

#define AUDIO_BITW_16 16

Definition at line 61 of file audio/audio_conf.h.

◆ AUDIO_DEFAULT_BITW

#define AUDIO_DEFAULT_BITW AUDIO_BITW_16

Definition at line 72 of file audio/audio_conf.h.

◆ AUDIO_DEFAULT_FREQ

#define AUDIO_DEFAULT_FREQ AUDIO_FREQ_48K

Definition at line 71 of file audio/audio_conf.h.

◆ AUDIO_FREQ_16K

#define AUDIO_FREQ_16K 16000

Definition at line 59 of file audio/audio_conf.h.

◆ AUDIO_FREQ_48K

#define AUDIO_FREQ_48K 48000

Definition at line 60 of file audio/audio_conf.h.

◆ AUDIO_MIC_CHANEL_NUM

#define AUDIO_MIC_CHANEL_NUM 2

Definition at line 63 of file audio/audio_conf.h.

◆ AUDIO_MIC_DEFAULT_BITW

#define AUDIO_MIC_DEFAULT_BITW AUDIO_BITW_16

Definition at line 64 of file audio/audio_conf.h.

◆ AUDIO_SPK_CHANEL_NUM

#define AUDIO_SPK_CHANEL_NUM 2

Definition at line 66 of file audio/audio_conf.h.

◆ AUDIO_SPK_DEFAULT_BITW

#define AUDIO_SPK_DEFAULT_BITW AUDIO_BITW_16

Definition at line 67 of file audio/audio_conf.h.

◆ AUDIO_SUPPORT_FEEDBACK

#define AUDIO_SUPPORT_FEEDBACK 1

Definition at line 49 of file audio/audio_conf.h.

◆ AUDIO_SUPPORT_FREQ

#define AUDIO_SUPPORT_FREQ
Value:
(AUDIO_SUPPORT_FREQ_16K + \
AUDIO_SUPPORT_FREQ_48K \
)
AUDIO_SUPPORT_FREQ_16K
#define AUDIO_SUPPORT_FREQ_16K
Definition: audio/audio_conf.h:51

Definition at line 55 of file audio/audio_conf.h.

◆ AUDIO_SUPPORT_FREQ_16K

#define AUDIO_SUPPORT_FREQ_16K 0

Definition at line 51 of file audio/audio_conf.h.

◆ AUDIO_SUPPORT_FREQ_48K

#define AUDIO_SUPPORT_FREQ_48K 1

Definition at line 52 of file audio/audio_conf.h.

◆ AUDIO_SUPPORT_MAX_FREQ

#define AUDIO_SUPPORT_MAX_FREQ 48

Definition at line 70 of file audio/audio_conf.h.

◆ AUDIO_SUPPORT_MIC

#define AUDIO_SUPPORT_MIC 1

Definition at line 48 of file audio/audio_conf.h.

◆ AUDIO_SUPPORT_SPK

#define AUDIO_SUPPORT_SPK 1

Definition at line 47 of file audio/audio_conf.h.


AT32F435/437 Firmwary Library: USB_audio_desc

Modules
USB_audio_desc
AT32F435_437_middlewares_usbd_class

usb device audio descriptor More...

Modules

USB_audio_desc_private_functions
USB_audio_desc_definition

Detailed Description

usb device audio descriptor


AT32F435/437 Firmwary Library: USB_audio_desc_private_functions

Functions | Variables
USB_audio_desc_private_functions
AT32F435_437_middlewares_usbd_class » USB_audio_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler | audio_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 614 of file audio_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 536 of file audio_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 516 of file audio_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 602 of file audio_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 556 of file audio_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 567 of file audio_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 546 of file audio_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 579 of file audio_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 526 of file audio_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 591 of file audio_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 494 of file audio_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 468 of file audio_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 442 of file audio_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x00,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x5730 ),
HBYTE( 0x5730 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
0x01
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92

usb device standard descriptor

usb string serial

usb string lang id

usb configuration standard descriptor

Definition at line 82 of file audio_desc.c.

◆ audio_desc_handler

usbd_desc_handler audio_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: audio_desc.c:536
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: audio_desc.c:516
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: audio_desc.c:567
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: audio_desc.c:526
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: audio_desc.c:602
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: audio_desc.c:546
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: audio_desc.c:579
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: audio_desc.c:614
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: audio_desc.c:556
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: audio_desc.c:591

device descriptor handler structure

Definition at line 62 of file audio_desc.c.

Referenced by main().

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
( 0x12 + ((0x08 + ( 1 + 1 ) ) + ( 1 + 1 ) * 0x1E) + + (0x31 + ( ( 0 + 1 ) ) * 3) + (0x31 + ( ( 0 + 1 ) ) * 3) + (9 * 1 ) ) ,
g_usbd_configuration
}

Definition at line 414 of file audio_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 407 of file audio_desc.c.

Referenced by get_device_descriptor().

◆ g_usbd_desc_buffer

uint8_t g_usbd_desc_buffer[256]
static

Definition at line 57 of file audio_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 421 of file audio_desc.c.

Referenced by get_device_lang_id().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 428 of file audio_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 434 of file audio_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F435/437 Firmwary Library: USB_audio_desc_definition

Macros | Variables
USB_audio_desc_definition
AT32F435_437_middlewares_usbd_class » USB_audio_desc

Macros

#define | AUDIO_BCD_NUM 0x0100
#define | USBD_AUDIO_VENDOR_ID 0x2E3C
#define | USBD_AUDIO_PRODUCT_ID 0x5730
#define | USBD_AUDIO_SIZ_STRING_LANGID 4
#define | USBD_AUDIO_SIZ_STRING_SERIAL 0x1A
#define | USBD_AUDIO_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_AUDIO_DESC_PRODUCT_STRING "AT32 Audio"
#define | USBD_AUDIO_DESC_CONFIGURATION_STRING "Audio Config"
#define | USBD_AUDIO_DESC_INTERFACE_STRING "Audio Interface"
#define | AUDIO_SUBCLASS_UNDEFINED 0x00
audio interface subclass codes More...
#define | AUDIO_SUBCLASS_AUDIOCONTROL 0x01
#define | AUDIO_SUBCLASS_AUDIOSTREAMING 0x02
#define | AUDIO_SUBCLASS_MIDISTREMING 0x03
#define | AUDIO_CS_INTERFACE 0x24
audio class-specific descriptor types More...
#define | AUDIO_CS_ENDPOINT 0x25
#define | AUDIO_CS_STRING 0x23
#define | AUDIO_CS_CONFIGURATION 0x22
#define | AUDIO_CS_DEVICE 0x21
#define | AUDIO_CS_UNDEFINED 0x20
#define | AUDIO_PROTOCOL_UNDEFINED 0x00
audio interface protocol codes More...
#define | AUDIO_AC_DESCRIPTOR_UNDEFINED 0x00
audio class-specific ac interface descriptor subtypes More...
#define | AUDIO_AC_HEADER 0x01
#define | AUDIO_AC_INPUT_TERMINAL 0x02
#define | AUDIO_AC_OUTPUT_TERMINAL 0x03
#define | AUDIO_AC_MIXER_UNIT 0x04
#define | AUDIO_AC_SELECTOR_UNIT 0x05
#define | AUDIO_AC_FEATURE_UNIT 0x06
#define | AUDIO_AC_PROCESSING_UNIT 0x07
#define | AUDIO_AC_EXTENSION_UNIT 0x08
#define | AUDIO_AS_DESCRIPTOR_UNDEFINED 0x00
audio class-specific as interface descriptor subtypes More...
#define | AUDIO_AS_GENERAL 0x01
#define | AUDIO_AS_FORMAT_TYPE 0x02
#define | AUDIO_AS_FORMAT_SPECIFIC 0x03
#define | AUDIO_REQUEST_CODE_UNDEFINED 0x00
audio class-specific request codes More...
#define | AUDIO_REQ_SET_CUR 0x01
#define | AUDIO_REQ_GET_CUR 0x81
#define | AUDIO_REQ_SET_MIN 0x02
#define | AUDIO_REQ_GET_MIN 0x82
#define | AUDIO_REQ_SET_MAX 0x03
#define | AUDIO_REQ_GET_MAX 0x83
#define | AUDIO_REQ_SET_RES 0x04
#define | AUDIO_REQ_GET_RES 0x84
#define | AUDIO_REQ_SET_MEM 0x05
#define | AUDIO_REQ_GET_MEM 0x85
#define | AUDIO_REQ_GET_STAT 0xFF
#define | AUDIO_FU_CONTROL_UNDEFINED 0x00
audio feature unit control selectors More...
#define | AUDIO_FU_MUTE_CONTROL 0x01
#define | AUDIO_FU_VOLUME_CONTROL 0x02
#define | AUDIO_FU_BASS_CONTROL 0x03
#define | AUDIO_FU_MID_CONTROL 0x04
#define | AUDIO_FU_TREBLE_CONTROL 0x05
#define | AUDIO_TERMINAL_TYPE_UNDEFINED 0x0100
audio terminal type More...
#define | AUDIO_TERMINAL_TYPE_STREAMING 0x0101
#define | AUDIO_TERMINAL_TYPE_VENDOR 0x01FF
#define | AUDIO_INPUT_TERMINAL_UNDEFINED 0x0200
#define | AUDIO_INPUT_TERMINAL_MICROPHONE 0x0201
#define | AUDIO_OUTPUT_TERMINAL_UNDEFINED 0x0300
#define | AUDIO_OUTPUT_TERMINAL_SPEAKER 0x0301
#define | AUDIO_FORMAT_TYPE_I 0x01
audio format type 1 More...
#define | AUDIO_INTERFACE_NUM (AUDIO_SUPPORT_SPK + AUDIO_SUPPORT_MIC)
audio interface config More...
#define | AUDIO_INTERFACE_LEN ((0x08 + AUDIO_INTERFACE_NUM) + AUDIO_INTERFACE_NUM * 0x1E)
#define | AUDIO_MIC_INTERFACE 0x01
#define | AUDIO_SPK_INTERFACE 0x02
#define | AUDIO_INPUT_TERMINAL_SIZE 0x0C
audio interface descriptor size define More...
#define | AUDIO_OUTPUT_TERMINAL_SIZE 0x09
#define | AUDIO_FEATURE_UNIT_SIZE 0x09
#define | AUDIO_MIC_INPUT_TERMINAL_ID 0x01
audio terminal id define More...
#define | AUDIO_MIC_FEATURE_UNIT_ID 0x02
#define | AUDIO_MIC_OUTPUT_TERMINAL_ID 0x03
#define | AUDIO_SPK_INPUT_TERMINAL_ID 0x04
#define | AUDIO_SPK_FEATURE_UNIT_ID 0x05
#define | AUDIO_SPK_OUTPUT_TERMINAL_ID 0x06
#define | AUDIO_MIC_INTERFACE_NUMBER 0x01
audio interface number More...
#define | AUDIO_SPK_INTERFACE_NUMBER 0x02
#define | AT32_AUDIO_FREQ_16K 16000
audio support freq More...
#define | AT32_AUDIO_FREQ_48K 48000
#define | AUDIO_MIC_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
audio microphone freq and channel config More...
#define | AUDIO_MIC_CHR AUDIO_MIC_CHANEL_NUM
#define | AUDIO_MIC_BITW (AUDIO_MIC_DEFAULT_BITW)
#define | AUDIO_SPK_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
audio speaker freq and channel config More...
#define | AUDIO_SPK_CHR AUDIO_SPK_CHANEL_NUM
#define | AUDIO_SPK_BITW (AUDIO_SPK_DEFAULT_BITW)
#define | AUDIO_BINTERVAL_TIME 0x01
#define | USBD_AUDIO_CONFIG_DESC_SIZE
#define | SAMPLE_FREQ(frq) (uint8_t)(frq), (uint8_t)((frq >> 8)), (uint8_t)((frq >> 16))
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

usbd_desc_handler audio_desc_handler
device descriptor handler structure More...

Detailed Description

Macro Definition Documentation

◆ AT32_AUDIO_FREQ_16K

#define AT32_AUDIO_FREQ_16K 16000

audio support freq

Definition at line 188 of file audio_desc.h.

◆ AT32_AUDIO_FREQ_48K

#define AT32_AUDIO_FREQ_48K 48000

Definition at line 189 of file audio_desc.h.

◆ AUDIO_AC_DESCRIPTOR_UNDEFINED

#define AUDIO_AC_DESCRIPTOR_UNDEFINED 0x00

audio class-specific ac interface descriptor subtypes

Definition at line 90 of file audio_desc.h.

◆ AUDIO_AC_EXTENSION_UNIT

#define AUDIO_AC_EXTENSION_UNIT 0x08

Definition at line 98 of file audio_desc.h.

◆ AUDIO_AC_FEATURE_UNIT

#define AUDIO_AC_FEATURE_UNIT 0x06

Definition at line 96 of file audio_desc.h.

◆ AUDIO_AC_HEADER

#define AUDIO_AC_HEADER 0x01

Definition at line 91 of file audio_desc.h.

◆ AUDIO_AC_INPUT_TERMINAL

#define AUDIO_AC_INPUT_TERMINAL 0x02

Definition at line 92 of file audio_desc.h.

◆ AUDIO_AC_MIXER_UNIT

#define AUDIO_AC_MIXER_UNIT 0x04

Definition at line 94 of file audio_desc.h.

◆ AUDIO_AC_OUTPUT_TERMINAL

#define AUDIO_AC_OUTPUT_TERMINAL 0x03

Definition at line 93 of file audio_desc.h.

◆ AUDIO_AC_PROCESSING_UNIT

#define AUDIO_AC_PROCESSING_UNIT 0x07

Definition at line 97 of file audio_desc.h.

◆ AUDIO_AC_SELECTOR_UNIT

#define AUDIO_AC_SELECTOR_UNIT 0x05

Definition at line 95 of file audio_desc.h.

◆ AUDIO_AS_DESCRIPTOR_UNDEFINED

#define AUDIO_AS_DESCRIPTOR_UNDEFINED 0x00

audio class-specific as interface descriptor subtypes

Definition at line 103 of file audio_desc.h.

◆ AUDIO_AS_FORMAT_SPECIFIC

#define AUDIO_AS_FORMAT_SPECIFIC 0x03

Definition at line 106 of file audio_desc.h.

◆ AUDIO_AS_FORMAT_TYPE

#define AUDIO_AS_FORMAT_TYPE 0x02

Definition at line 105 of file audio_desc.h.

◆ AUDIO_AS_GENERAL

#define AUDIO_AS_GENERAL 0x01

Definition at line 104 of file audio_desc.h.

◆ AUDIO_BCD_NUM

#define AUDIO_BCD_NUM 0x0100

Definition at line 51 of file audio_desc.h.

◆ AUDIO_BINTERVAL_TIME

#define AUDIO_BINTERVAL_TIME 0x01

Definition at line 205 of file audio_desc.h.

◆ AUDIO_CS_CONFIGURATION

#define AUDIO_CS_CONFIGURATION 0x22

Definition at line 78 of file audio_desc.h.

◆ AUDIO_CS_DEVICE

#define AUDIO_CS_DEVICE 0x21

Definition at line 79 of file audio_desc.h.

◆ AUDIO_CS_ENDPOINT

#define AUDIO_CS_ENDPOINT 0x25

Definition at line 76 of file audio_desc.h.

◆ AUDIO_CS_INTERFACE

#define AUDIO_CS_INTERFACE 0x24

audio class-specific descriptor types

Definition at line 75 of file audio_desc.h.

◆ AUDIO_CS_STRING

#define AUDIO_CS_STRING 0x23

Definition at line 77 of file audio_desc.h.

◆ AUDIO_CS_UNDEFINED

#define AUDIO_CS_UNDEFINED 0x20

Definition at line 80 of file audio_desc.h.

◆ AUDIO_FEATURE_UNIT_SIZE

#define AUDIO_FEATURE_UNIT_SIZE 0x09

Definition at line 163 of file audio_desc.h.

◆ AUDIO_FORMAT_TYPE_I

#define AUDIO_FORMAT_TYPE_I 0x01

audio format type 1

Definition at line 148 of file audio_desc.h.

◆ AUDIO_FU_BASS_CONTROL

#define AUDIO_FU_BASS_CONTROL 0x03

Definition at line 130 of file audio_desc.h.

◆ AUDIO_FU_CONTROL_UNDEFINED

#define AUDIO_FU_CONTROL_UNDEFINED 0x00

audio feature unit control selectors

Definition at line 127 of file audio_desc.h.

◆ AUDIO_FU_MID_CONTROL

#define AUDIO_FU_MID_CONTROL 0x04

Definition at line 131 of file audio_desc.h.

◆ AUDIO_FU_MUTE_CONTROL

#define AUDIO_FU_MUTE_CONTROL 0x01

Definition at line 128 of file audio_desc.h.

◆ AUDIO_FU_TREBLE_CONTROL

#define AUDIO_FU_TREBLE_CONTROL 0x05

Definition at line 132 of file audio_desc.h.

◆ AUDIO_FU_VOLUME_CONTROL

#define AUDIO_FU_VOLUME_CONTROL 0x02

Definition at line 129 of file audio_desc.h.

◆ AUDIO_INPUT_TERMINAL_MICROPHONE

#define AUDIO_INPUT_TERMINAL_MICROPHONE 0x0201

Definition at line 141 of file audio_desc.h.

◆ AUDIO_INPUT_TERMINAL_SIZE

#define AUDIO_INPUT_TERMINAL_SIZE 0x0C

audio interface descriptor size define

Definition at line 161 of file audio_desc.h.

◆ AUDIO_INPUT_TERMINAL_UNDEFINED

#define AUDIO_INPUT_TERMINAL_UNDEFINED 0x0200

Definition at line 140 of file audio_desc.h.

◆ AUDIO_INTERFACE_LEN

#define AUDIO_INTERFACE_LEN ((0x08 + AUDIO_INTERFACE_NUM) + AUDIO_INTERFACE_NUM * 0x1E)

Definition at line 154 of file audio_desc.h.

◆ AUDIO_INTERFACE_NUM

#define AUDIO_INTERFACE_NUM (AUDIO_SUPPORT_SPK + AUDIO_SUPPORT_MIC)

audio interface config

Definition at line 153 of file audio_desc.h.

◆ AUDIO_MIC_BITW

#define AUDIO_MIC_BITW (AUDIO_MIC_DEFAULT_BITW)

Definition at line 196 of file audio_desc.h.

◆ AUDIO_MIC_CHR

#define AUDIO_MIC_CHR AUDIO_MIC_CHANEL_NUM

Definition at line 195 of file audio_desc.h.

◆ AUDIO_MIC_FEATURE_UNIT_ID

#define AUDIO_MIC_FEATURE_UNIT_ID 0x02

Definition at line 169 of file audio_desc.h.

◆ AUDIO_MIC_FREQ_SIZE

#define AUDIO_MIC_FREQ_SIZE (AUDIO_SUPPORT_FREQ)

audio microphone freq and channel config

Definition at line 194 of file audio_desc.h.

◆ AUDIO_MIC_INPUT_TERMINAL_ID

#define AUDIO_MIC_INPUT_TERMINAL_ID 0x01

audio terminal id define

Definition at line 168 of file audio_desc.h.

◆ AUDIO_MIC_INTERFACE

#define AUDIO_MIC_INTERFACE 0x01

Definition at line 155 of file audio_desc.h.

◆ AUDIO_MIC_INTERFACE_NUMBER

#define AUDIO_MIC_INTERFACE_NUMBER 0x01

audio interface number

Definition at line 178 of file audio_desc.h.

◆ AUDIO_MIC_OUTPUT_TERMINAL_ID

#define AUDIO_MIC_OUTPUT_TERMINAL_ID 0x03

Definition at line 170 of file audio_desc.h.

◆ AUDIO_OUTPUT_TERMINAL_SIZE

#define AUDIO_OUTPUT_TERMINAL_SIZE 0x09

Definition at line 162 of file audio_desc.h.

◆ AUDIO_OUTPUT_TERMINAL_SPEAKER

#define AUDIO_OUTPUT_TERMINAL_SPEAKER 0x0301

Definition at line 143 of file audio_desc.h.

◆ AUDIO_OUTPUT_TERMINAL_UNDEFINED

#define AUDIO_OUTPUT_TERMINAL_UNDEFINED 0x0300

Definition at line 142 of file audio_desc.h.

◆ AUDIO_PROTOCOL_UNDEFINED

#define AUDIO_PROTOCOL_UNDEFINED 0x00

audio interface protocol codes

Definition at line 85 of file audio_desc.h.

◆ AUDIO_REQ_GET_CUR

#define AUDIO_REQ_GET_CUR 0x81

Definition at line 113 of file audio_desc.h.

◆ AUDIO_REQ_GET_MAX

#define AUDIO_REQ_GET_MAX 0x83

Definition at line 117 of file audio_desc.h.

◆ AUDIO_REQ_GET_MEM

#define AUDIO_REQ_GET_MEM 0x85

Definition at line 121 of file audio_desc.h.

◆ AUDIO_REQ_GET_MIN

#define AUDIO_REQ_GET_MIN 0x82

Definition at line 115 of file audio_desc.h.

◆ AUDIO_REQ_GET_RES

#define AUDIO_REQ_GET_RES 0x84

Definition at line 119 of file audio_desc.h.

◆ AUDIO_REQ_GET_STAT

#define AUDIO_REQ_GET_STAT 0xFF

Definition at line 122 of file audio_desc.h.

◆ AUDIO_REQ_SET_CUR

#define AUDIO_REQ_SET_CUR 0x01

Definition at line 112 of file audio_desc.h.

◆ AUDIO_REQ_SET_MAX

#define AUDIO_REQ_SET_MAX 0x03

Definition at line 116 of file audio_desc.h.

◆ AUDIO_REQ_SET_MEM

#define AUDIO_REQ_SET_MEM 0x05

Definition at line 120 of file audio_desc.h.

◆ AUDIO_REQ_SET_MIN

#define AUDIO_REQ_SET_MIN 0x02

Definition at line 114 of file audio_desc.h.

◆ AUDIO_REQ_SET_RES

#define AUDIO_REQ_SET_RES 0x04

Definition at line 118 of file audio_desc.h.

◆ AUDIO_REQUEST_CODE_UNDEFINED

#define AUDIO_REQUEST_CODE_UNDEFINED 0x00

audio class-specific request codes

Definition at line 111 of file audio_desc.h.

◆ AUDIO_SPK_BITW

#define AUDIO_SPK_BITW (AUDIO_SPK_DEFAULT_BITW)

Definition at line 203 of file audio_desc.h.

◆ AUDIO_SPK_CHR

#define AUDIO_SPK_CHR AUDIO_SPK_CHANEL_NUM

Definition at line 202 of file audio_desc.h.

◆ AUDIO_SPK_FEATURE_UNIT_ID

#define AUDIO_SPK_FEATURE_UNIT_ID 0x05

Definition at line 172 of file audio_desc.h.

◆ AUDIO_SPK_FREQ_SIZE

#define AUDIO_SPK_FREQ_SIZE (AUDIO_SUPPORT_FREQ)

audio speaker freq and channel config

Definition at line 201 of file audio_desc.h.

◆ AUDIO_SPK_INPUT_TERMINAL_ID

#define AUDIO_SPK_INPUT_TERMINAL_ID 0x04

Definition at line 171 of file audio_desc.h.

◆ AUDIO_SPK_INTERFACE

#define AUDIO_SPK_INTERFACE 0x02

Definition at line 156 of file audio_desc.h.

◆ AUDIO_SPK_INTERFACE_NUMBER

#define AUDIO_SPK_INTERFACE_NUMBER 0x02

Definition at line 180 of file audio_desc.h.

◆ AUDIO_SPK_OUTPUT_TERMINAL_ID

#define AUDIO_SPK_OUTPUT_TERMINAL_ID 0x06

Definition at line 173 of file audio_desc.h.

◆ AUDIO_SUBCLASS_AUDIOCONTROL

#define AUDIO_SUBCLASS_AUDIOCONTROL 0x01

Definition at line 68 of file audio_desc.h.

◆ AUDIO_SUBCLASS_AUDIOSTREAMING

#define AUDIO_SUBCLASS_AUDIOSTREAMING 0x02

Definition at line 69 of file audio_desc.h.

◆ AUDIO_SUBCLASS_MIDISTREMING

#define AUDIO_SUBCLASS_MIDISTREMING 0x03

Definition at line 70 of file audio_desc.h.

◆ AUDIO_SUBCLASS_UNDEFINED

#define AUDIO_SUBCLASS_UNDEFINED 0x00

audio interface subclass codes

Definition at line 67 of file audio_desc.h.

◆ AUDIO_TERMINAL_TYPE_STREAMING

#define AUDIO_TERMINAL_TYPE_STREAMING 0x0101

Definition at line 138 of file audio_desc.h.

◆ AUDIO_TERMINAL_TYPE_UNDEFINED

#define AUDIO_TERMINAL_TYPE_UNDEFINED 0x0100

audio terminal type

Definition at line 137 of file audio_desc.h.

◆ AUDIO_TERMINAL_TYPE_VENDOR

#define AUDIO_TERMINAL_TYPE_VENDOR 0x01FF

Definition at line 139 of file audio_desc.h.

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

Definition at line 215 of file audio_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 216 of file audio_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 217 of file audio_desc.h.

◆ SAMPLE_FREQ

#define SAMPLE_FREQ ( frq ) (uint8_t)(frq), (uint8_t)((frq >> 8)), (uint8_t)((frq >> 16))

Definition at line 213 of file audio_desc.h.

◆ USBD_AUDIO_CONFIG_DESC_SIZE

#define USBD_AUDIO_CONFIG_DESC_SIZE
Value:
( 0x12 + AUDIO_INTERFACE_LEN + \
+ (0x31 + AUDIO_SPK_FREQ_SIZE * 3) \
+ (0x31 + AUDIO_MIC_FREQ_SIZE * 3) \
+ (9 * AUDIO_SUPPORT_FEEDBACK) \
)
AUDIO_MIC_FREQ_SIZE
#define AUDIO_MIC_FREQ_SIZE
audio microphone freq and channel config
Definition: audio_desc.h:194
AUDIO_SPK_FREQ_SIZE
#define AUDIO_SPK_FREQ_SIZE
audio speaker freq and channel config
Definition: audio_desc.h:201
AUDIO_INTERFACE_LEN
#define AUDIO_INTERFACE_LEN
Definition: audio_desc.h:154
AUDIO_SUPPORT_FEEDBACK
#define AUDIO_SUPPORT_FEEDBACK
Definition: audio/audio_conf.h:49

Definition at line 208 of file audio_desc.h.

◆ USBD_AUDIO_DESC_CONFIGURATION_STRING

#define USBD_AUDIO_DESC_CONFIGURATION_STRING "Audio Config"

Definition at line 61 of file audio_desc.h.

◆ USBD_AUDIO_DESC_INTERFACE_STRING

#define USBD_AUDIO_DESC_INTERFACE_STRING "Audio Interface"

Definition at line 62 of file audio_desc.h.

◆ USBD_AUDIO_DESC_MANUFACTURER_STRING

#define USBD_AUDIO_DESC_MANUFACTURER_STRING "Artery"

Definition at line 59 of file audio_desc.h.

◆ USBD_AUDIO_DESC_PRODUCT_STRING

#define USBD_AUDIO_DESC_PRODUCT_STRING "AT32 Audio"

Definition at line 60 of file audio_desc.h.

◆ USBD_AUDIO_PRODUCT_ID

#define USBD_AUDIO_PRODUCT_ID 0x5730

Definition at line 54 of file audio_desc.h.

◆ USBD_AUDIO_SIZ_STRING_LANGID

#define USBD_AUDIO_SIZ_STRING_LANGID 4

Definition at line 56 of file audio_desc.h.

◆ USBD_AUDIO_SIZ_STRING_SERIAL

#define USBD_AUDIO_SIZ_STRING_SERIAL 0x1A

Definition at line 57 of file audio_desc.h.

◆ USBD_AUDIO_VENDOR_ID

#define USBD_AUDIO_VENDOR_ID 0x2E3C

Definition at line 53 of file audio_desc.h.

Variable Documentation

◆ audio_desc_handler

usbd_desc_handler audio_desc_handler
extern

device descriptor handler structure

Definition at line 62 of file audio_desc.c.

Referenced by main().


AT32F435/437 Firmwary Library: USB_audio_hid_class

Modules
USB_audio_hid_class
AT32F435_437_middlewares_usbd_class

usb device class audio hid demo More...

Modules

USB_device_audio_hid_config_definition
USB_audio_hid_class_private_functions
USB_audio_hid_class_definition

Detailed Description

usb device class audio hid demo


AT32F435/437 Firmwary Library: USB_device_audio_hid_config_definition

Macros
USB_device_audio_hid_config_definition
AT32F435_437_middlewares_usbd_class » USB_audio_hid_class

Macros

#define | AUDIO_SUPPORT_SPK 1
#define | AUDIO_SUPPORT_MIC 1
#define | AUDIO_SUPPORT_FEEDBACK 1
#define | AUDIO_SUPPORT_FREQ_16K 0
#define | AUDIO_SUPPORT_FREQ_48K 1
#define | AUDIO_SUPPORT_FREQ
#define | AUDIO_FREQ_16K 16000
#define | AUDIO_FREQ_48K 48000
#define | AUDIO_BITW_16 16
#define | AUDIO_MIC_CHANEL_NUM 2
#define | AUDIO_MIC_DEFAULT_BITW AUDIO_BITW_16
#define | AUDIO_SPK_CHANEL_NUM 2
#define | AUDIO_SPK_DEFAULT_BITW AUDIO_BITW_16
#define | AUDIO_SUPPORT_MAX_FREQ 48
#define | AUDIO_DEFAULT_FREQ AUDIO_FREQ_48K
#define | AUDIO_DEFAULT_BITW AUDIO_BITW_16

Detailed Description

Macro Definition Documentation

◆ AUDIO_BITW_16

#define AUDIO_BITW_16 16

Definition at line 61 of file audio_hid/audio_conf.h.

◆ AUDIO_DEFAULT_BITW

#define AUDIO_DEFAULT_BITW AUDIO_BITW_16

Definition at line 72 of file audio_hid/audio_conf.h.

◆ AUDIO_DEFAULT_FREQ

#define AUDIO_DEFAULT_FREQ AUDIO_FREQ_48K

Definition at line 71 of file audio_hid/audio_conf.h.

◆ AUDIO_FREQ_16K

#define AUDIO_FREQ_16K 16000

Definition at line 59 of file audio_hid/audio_conf.h.

◆ AUDIO_FREQ_48K

#define AUDIO_FREQ_48K 48000

Definition at line 60 of file audio_hid/audio_conf.h.

◆ AUDIO_MIC_CHANEL_NUM

#define AUDIO_MIC_CHANEL_NUM 2

Definition at line 63 of file audio_hid/audio_conf.h.

◆ AUDIO_MIC_DEFAULT_BITW

#define AUDIO_MIC_DEFAULT_BITW AUDIO_BITW_16

Definition at line 64 of file audio_hid/audio_conf.h.

◆ AUDIO_SPK_CHANEL_NUM

#define AUDIO_SPK_CHANEL_NUM 2

Definition at line 66 of file audio_hid/audio_conf.h.

◆ AUDIO_SPK_DEFAULT_BITW

#define AUDIO_SPK_DEFAULT_BITW AUDIO_BITW_16

Definition at line 67 of file audio_hid/audio_conf.h.

◆ AUDIO_SUPPORT_FEEDBACK

#define AUDIO_SUPPORT_FEEDBACK 1

Definition at line 49 of file audio_hid/audio_conf.h.

◆ AUDIO_SUPPORT_FREQ

#define AUDIO_SUPPORT_FREQ
Value:
(AUDIO_SUPPORT_FREQ_16K + \
AUDIO_SUPPORT_FREQ_48K \
)
AUDIO_SUPPORT_FREQ_16K
#define AUDIO_SUPPORT_FREQ_16K
Definition: audio_hid/audio_conf.h:51

Definition at line 55 of file audio_hid/audio_conf.h.

◆ AUDIO_SUPPORT_FREQ_16K

#define AUDIO_SUPPORT_FREQ_16K 0

Definition at line 51 of file audio_hid/audio_conf.h.

◆ AUDIO_SUPPORT_FREQ_48K

#define AUDIO_SUPPORT_FREQ_48K 1

Definition at line 52 of file audio_hid/audio_conf.h.

◆ AUDIO_SUPPORT_MAX_FREQ

#define AUDIO_SUPPORT_MAX_FREQ 48

Definition at line 70 of file audio_hid/audio_conf.h.

◆ AUDIO_SUPPORT_MIC

#define AUDIO_SUPPORT_MIC 1

Definition at line 48 of file audio_hid/audio_conf.h.

◆ AUDIO_SUPPORT_SPK

#define AUDIO_SUPPORT_SPK 1

Definition at line 47 of file audio_hid/audio_conf.h.


AT32F435/437 Firmwary Library: USB_audio_hid_class_private_functions

Functions | Variables
USB_audio_hid_class_private_functions
AT32F435_437_middlewares_usbd_class » USB_audio_hid_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
static void | audio_inisoincom_event (void *udev)
usb audio in iso incom event More...
static void | audio_req_get_cur (void *udev, usb_setup_type *setup)
usb audio request get cur More...
static void | audio_req_set_cur (void *udev, usb_setup_type *setup)
usb audio request set cur More...
static void | audio_req_get_min (void *udev, usb_setup_type *setup)
usb audio request get min More...
static void | audio_req_get_max (void *udev, usb_setup_type *setup)
usb audio request get max More...
static void | audio_req_get_res (void *udev, usb_setup_type *setup)
usb audio request get res More...
static void | audio_get_interface (void *udev, usb_setup_type *setup)
usb audio get interface More...
static void | audio_set_interface (void *udev, usb_setup_type *setup)
usb audio set interface More...
static void | usb_hid_buf_process (void *udev, uint8_t *report, uint16_t len)
usb device report function More...
static usb_sts_type | class_audio_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_hid_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
usb_sts_type | audio_hid_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

usb_audio_hid_type | audio_hid_struct = {0, 0, 0, 0, 0, 0x1400, 0, 0, 0, {0x0000, 0x1400, 0x33}, {0x0000, 0x1400, 0x33}, 0, 0}
usbd_class_handler | audio_hid_class_handler

Detailed Description

Function Documentation

◆ audio_get_interface()

static void audio_get_interface | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio get interface

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 805 of file audio_hid_class.c.

Referenced by class_audio_setup_handler().

◆ audio_hid_class_send_report()

usb_sts_type audio_hid_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 827 of file audio_hid_class.c.

Referenced by main().

◆ audio_inisoincom_event()

static void audio_inisoincom_event ( void * udev )
static

usb audio in iso incom event

Parameters
udev usb device core handler type
Return values
none

Definition at line 589 of file audio_hid_class.c.

Referenced by class_event_handler().

◆ audio_req_get_cur()

static void audio_req_get_cur | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request get cur

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 626 of file audio_hid_class.c.

Referenced by class_audio_setup_handler().

◆ audio_req_get_max()

static void audio_req_get_max | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request get max

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 727 of file audio_hid_class.c.

Referenced by class_audio_setup_handler().

◆ audio_req_get_min()

static void audio_req_get_min | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request get min

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 705 of file audio_hid_class.c.

Referenced by class_audio_setup_handler().

◆ audio_req_get_res()

static void audio_req_get_res | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request get res

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 749 of file audio_hid_class.c.

Referenced by class_audio_setup_handler().

◆ audio_req_set_cur()

static void audio_req_set_cur | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request set cur

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 665 of file audio_hid_class.c.

Referenced by class_audio_setup_handler().

◆ audio_set_interface()

static void audio_set_interface | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio set interface

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 771 of file audio_hid_class.c.

Referenced by class_audio_setup_handler().

◆ class_audio_setup_handler()

static usb_sts_type class_audio_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | usb device core handler type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 153 of file audio_hid_class.c.

Referenced by class_setup_handler().

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 121 of file audio_hid_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device endpoint 0 out status stage complete

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 352 of file audio_hid_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device endpoint 0 in status stage complete

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 338 of file audio_hid_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device event handler

Parameters
udev | usb device core handler type
event | usb device event
Return values
status of usb_sts_type

Definition at line 550 of file audio_hid_class.c.

◆ class_hid_setup_handler()

static usb_sts_type class_hid_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | usb device core handler type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 233 of file audio_hid_class.c.

Referenced by class_setup_handler().

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device transmision complete handler

Parameters
udev | usb device core handler type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 438 of file audio_hid_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb custom hid endpoint

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 85 of file audio_hid_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device endpoint receive data

Parameters
udev | usb device core handler type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 473 of file audio_hid_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | usb device core handler type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 307 of file audio_hid_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device sof handler

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 507 of file audio_hid_class.c.

◆ usb_hid_buf_process()

static void usb_hid_buf_process | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |
static

usb device report function

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
none

Definition at line 846 of file audio_hid_class.c.

Referenced by class_ept0_rx_handler(), and class_out_handler().

Variable Documentation

◆ audio_hid_class_handler

usbd_class_handler audio_hid_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&audio_hid_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: audio_hid_class.c:507
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: audio_hid_class.c:438
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: audio_hid_class.c:121
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: audio_hid_class.c:307
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: audio_hid_class.c:338
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: audio_hid_class.c:352
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: audio_hid_class.c:550
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: audio_hid_class.c:85
audio_hid_struct
usb_audio_hid_type audio_hid_struct
Definition: audio_hid_class.c:64
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: audio_hid_class.c:473

Definition at line 66 of file audio_hid_class.c.

Referenced by main().

◆ audio_hid_struct

usb_audio_hid_type audio_hid_struct = {0, 0, 0, 0, 0, 0x1400, 0, 0, 0, {0x0000, 0x1400, 0x33}, {0x0000, 0x1400, 0x33}, 0, 0}

Definition at line 64 of file audio_hid_class.c.


AT32F435/437 Firmwary Library: USB_audio_hid_class_definition

Data Structures | Macros | Functions | Variables
USB_audio_hid_class_definition
AT32F435_437_middlewares_usbd_class » USB_audio_hid_class

Data Structures

struct usb_audio_hid_type
usb audio control struct More...

Macros

#define | USBD_AUHID_AUDIO_MIC_IN_EPT 0x81
endpoint define More...
#define | USBD_AUHID_AUDIO_SPK_OUT_EPT 0x02
#define | USBD_AUHID_AUDIO_FEEDBACK_EPT 0x83
#define | USBD_AUHID_HID_IN_EPT 0x82
usb custom hid use endpoint define More...
#define | USBD_AUHID_HID_OUT_EPT 0x01
#define | USBD_AUHID_IN_MAXPACKET_SIZE 0x40
usb custom hid in and out max packet size define More...
#define | USBD_AUHID_OUT_MAXPACKET_SIZE 0x40
#define | AUDIO_REMAIN_SIZE 40
endpoint support max size More...
#define | AUDIO_MIC_IN_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_MIC_CHANEL_NUM * (AUDIO_MIC_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
#define | AUDIO_SPK_OUT_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_SPK_CHANEL_NUM * (AUDIO_SPK_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
#define | AUDIO_FEEDBACK_MAXPACKET_SIZE 0x3
#define | FEEDBACK_REFRESH_TIME 0x8
#define | AUDIO_REQ_CONTROL_INTERFACE 0x01
request type define More...
#define | AUDIO_REQ_CONTROL_ENDPOINT 0x02
#define | AUDIO_REQ_CONTROL_MASK 0x03
#define | AUDIO_MUTE_CONTROL 0x01
audio set cur type define More...
#define | AUDIO_MUTE_CONTROL 0x01
audio set cur type define More...
#define | AUDIO_VOLUME_CONTROL 0x02
#define | AUDIO_VOLUME_CONTROL 0x02
#define | AUDIO_FREQ_SET_CONTROL 0x03
#define | AUDIO_FREQ_SET_CONTROL 0x03
#define | AUDIO_DESCRIPTOR_TYPE 0x21
audio descriptor type More...
#define | AUDIO_DESCRIPTOR_SIZE 0x09

Functions

usb_sts_type audio_hid_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

usbd_class_handler audio_hid_class_handler

Detailed Description

Macro Definition Documentation

◆ AUDIO_DESCRIPTOR_SIZE

#define AUDIO_DESCRIPTOR_SIZE 0x09

Definition at line 107 of file audio_hid_class.h.

◆ AUDIO_DESCRIPTOR_TYPE

#define AUDIO_DESCRIPTOR_TYPE 0x21

audio descriptor type

Definition at line 106 of file audio_hid_class.h.

◆ AUDIO_FEEDBACK_MAXPACKET_SIZE

#define AUDIO_FEEDBACK_MAXPACKET_SIZE 0x3

Definition at line 76 of file audio_hid_class.h.

◆ AUDIO_FREQ_SET_CONTROL [1/2]

#define AUDIO_FREQ_SET_CONTROL 0x03

Definition at line 101 of file audio_hid_class.h.

◆ AUDIO_FREQ_SET_CONTROL [2/2]

#define AUDIO_FREQ_SET_CONTROL 0x03

Definition at line 101 of file audio_hid_class.h.

◆ AUDIO_MIC_IN_MAXPACKET_SIZE

#define AUDIO_MIC_IN_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_MIC_CHANEL_NUM * (AUDIO_MIC_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)

Definition at line 74 of file audio_hid_class.h.

◆ AUDIO_MUTE_CONTROL [1/2]

#define AUDIO_MUTE_CONTROL 0x01

audio set cur type define

audio descriptor type

audio set cur type define

Definition at line 99 of file audio_hid_class.h.

◆ AUDIO_MUTE_CONTROL [2/2]

#define AUDIO_MUTE_CONTROL 0x01

audio set cur type define

audio descriptor type

audio set cur type define

Definition at line 99 of file audio_hid_class.h.

◆ AUDIO_REMAIN_SIZE

#define AUDIO_REMAIN_SIZE 40

endpoint support max size

Definition at line 73 of file audio_hid_class.h.

◆ AUDIO_REQ_CONTROL_ENDPOINT

#define AUDIO_REQ_CONTROL_ENDPOINT 0x02

Definition at line 82 of file audio_hid_class.h.

◆ AUDIO_REQ_CONTROL_INTERFACE

#define AUDIO_REQ_CONTROL_INTERFACE 0x01

request type define

Definition at line 81 of file audio_hid_class.h.

◆ AUDIO_REQ_CONTROL_MASK

#define AUDIO_REQ_CONTROL_MASK 0x03

Definition at line 83 of file audio_hid_class.h.

◆ AUDIO_SPK_OUT_MAXPACKET_SIZE

#define AUDIO_SPK_OUT_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_SPK_CHANEL_NUM * (AUDIO_SPK_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)

Definition at line 75 of file audio_hid_class.h.

◆ AUDIO_VOLUME_CONTROL [1/2]

#define AUDIO_VOLUME_CONTROL 0x02

Definition at line 100 of file audio_hid_class.h.

◆ AUDIO_VOLUME_CONTROL [2/2]

#define AUDIO_VOLUME_CONTROL 0x02

Definition at line 100 of file audio_hid_class.h.

◆ FEEDBACK_REFRESH_TIME

#define FEEDBACK_REFRESH_TIME 0x8

Definition at line 77 of file audio_hid_class.h.

◆ USBD_AUHID_AUDIO_FEEDBACK_EPT

#define USBD_AUHID_AUDIO_FEEDBACK_EPT 0x83

Definition at line 56 of file audio_hid_class.h.

◆ USBD_AUHID_AUDIO_MIC_IN_EPT

#define USBD_AUHID_AUDIO_MIC_IN_EPT 0x81

endpoint define

Definition at line 54 of file audio_hid_class.h.

◆ USBD_AUHID_AUDIO_SPK_OUT_EPT

#define USBD_AUHID_AUDIO_SPK_OUT_EPT 0x02

Definition at line 55 of file audio_hid_class.h.

◆ USBD_AUHID_HID_IN_EPT

#define USBD_AUHID_HID_IN_EPT 0x82

usb custom hid use endpoint define

Definition at line 61 of file audio_hid_class.h.

◆ USBD_AUHID_HID_OUT_EPT

#define USBD_AUHID_HID_OUT_EPT 0x01

Definition at line 62 of file audio_hid_class.h.

◆ USBD_AUHID_IN_MAXPACKET_SIZE

#define USBD_AUHID_IN_MAXPACKET_SIZE 0x40

usb custom hid in and out max packet size define

Definition at line 67 of file audio_hid_class.h.

◆ USBD_AUHID_OUT_MAXPACKET_SIZE

#define USBD_AUHID_OUT_MAXPACKET_SIZE 0x40

Definition at line 68 of file audio_hid_class.h.

Function Documentation

◆ audio_hid_class_send_report()

usb_sts_type audio_hid_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 827 of file audio_hid_class.c.

Referenced by main().

Variable Documentation

◆ audio_hid_class_handler

usbd_class_handler audio_hid_class_handler
extern

Definition at line 66 of file audio_hid_class.c.

Referenced by main().


AT32F435/437 Firmwary Library: usb_audio_hid_type Struct Reference

Data Fields
usb_audio_hid_type Struct Reference
AT32F435_437_middlewares_usbd_class » USB_audio_hid_class » USB_audio_hid_class_definition

usb audio control struct More...

#include <audio_hid_class.h>

Data Fields

uint8_t | enpd
uint8_t | interface
uint8_t | request_no
uint8_t | spk_mute
uint8_t | mic_mute
uint16_t | spk_volume
uint16_t | mic_volume
uint32_t | spk_freq
uint32_t | mic_freq
uint16_t | spk_volume_limits [3]
uint16_t | mic_volume_limits [3]
uint8_t | audio_cmd
uint32_t | audio_cmd_len
uint32_t | spk_alt_setting
uint32_t | mic_alt_setting
uint8_t | g_audio_cur [64]
uint8_t | audio_spk_data [(48 *2 *(16/8)+40)]
uint8_t | audio_mic_data [(48 *2 *(16/8)+40)]
uint8_t | audio_feed_back [0x3+1]
__IO uint16_t | audio_feedback_state
__IO uint8_t | audio_spk_out_stage
uint32_t | hid_protocol
uint32_t | hid_set_idle
uint32_t | alt_setting
uint8_t | hid_state
uint8_t | hid_set_report [64]
uint8_t | g_rxhid_buff [0x40]
uint8_t | g_txhid_buff [0x40]

Detailed Description

usb audio control struct

Definition at line 112 of file audio_hid_class.h.

Field Documentation

◆ alt_setting

uint32_t usb_audio_hid_type::alt_setting

Definition at line 142 of file audio_hid_class.h.

Referenced by class_hid_setup_handler().

◆ audio_cmd

uint8_t usb_audio_hid_type::audio_cmd

Definition at line 127 of file audio_hid_class.h.

Referenced by audio_req_set_cur(), and class_ept0_rx_handler().

◆ audio_cmd_len

uint32_t usb_audio_hid_type::audio_cmd_len

Definition at line 128 of file audio_hid_class.h.

Referenced by audio_req_set_cur().

◆ audio_feed_back

uint8_t usb_audio_hid_type::audio_feed_back[0x3+1]

Definition at line 134 of file audio_hid_class.h.

Referenced by audio_inisoincom_event(), and class_sof_handler().

◆ audio_feedback_state

__IO uint16_t usb_audio_hid_type::audio_feedback_state

Definition at line 135 of file audio_hid_class.h.

Referenced by class_in_handler(), and class_sof_handler().

◆ audio_mic_data

uint8_t usb_audio_hid_type::audio_mic_data[(48 * 2 *( 16/8)+ 40)]

Definition at line 133 of file audio_hid_class.h.

Referenced by audio_inisoincom_event(), audio_set_interface(), and class_in_handler().

◆ audio_spk_data

uint8_t usb_audio_hid_type::audio_spk_data[(48 * 2 *( 16/8)+ 40)]

Definition at line 132 of file audio_hid_class.h.

Referenced by audio_set_interface(), class_init_handler(), and class_out_handler().

◆ audio_spk_out_stage

__IO uint8_t usb_audio_hid_type::audio_spk_out_stage

Definition at line 136 of file audio_hid_class.h.

Referenced by class_out_handler(), and class_sof_handler().

◆ enpd

uint8_t usb_audio_hid_type::enpd

Definition at line 115 of file audio_hid_class.h.

Referenced by audio_req_set_cur(), and class_ept0_rx_handler().

◆ g_audio_cur

uint8_t usb_audio_hid_type::g_audio_cur[64]

Definition at line 131 of file audio_hid_class.h.

Referenced by audio_req_get_cur(), audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), audio_req_set_cur(), and class_ept0_rx_handler().

◆ g_rxhid_buff

uint8_t usb_audio_hid_type::g_rxhid_buff[0x40]

Definition at line 145 of file audio_hid_class.h.

Referenced by class_init_handler(), class_out_handler(), and usb_hid_buf_process().

◆ g_txhid_buff

uint8_t usb_audio_hid_type::g_txhid_buff[0x40]

Definition at line 146 of file audio_hid_class.h.

Referenced by usb_hid_buf_process().

◆ hid_protocol

uint32_t usb_audio_hid_type::hid_protocol

Definition at line 140 of file audio_hid_class.h.

Referenced by class_hid_setup_handler().

◆ hid_set_idle

uint32_t usb_audio_hid_type::hid_set_idle

Definition at line 141 of file audio_hid_class.h.

Referenced by class_hid_setup_handler().

◆ hid_set_report

uint8_t usb_audio_hid_type::hid_set_report[64]

Definition at line 144 of file audio_hid_class.h.

Referenced by class_ept0_rx_handler(), and class_hid_setup_handler().

◆ hid_state

uint8_t usb_audio_hid_type::hid_state

Definition at line 143 of file audio_hid_class.h.

Referenced by class_ept0_rx_handler(), and class_hid_setup_handler().

◆ interface

uint8_t usb_audio_hid_type::interface

Definition at line 116 of file audio_hid_class.h.

Referenced by audio_req_set_cur(), and class_ept0_rx_handler().

◆ mic_alt_setting

uint32_t usb_audio_hid_type::mic_alt_setting

Definition at line 130 of file audio_hid_class.h.

Referenced by audio_get_interface(), audio_set_interface(), and class_event_handler().

◆ mic_freq

uint32_t usb_audio_hid_type::mic_freq

Definition at line 123 of file audio_hid_class.h.

Referenced by class_ept0_rx_handler().

◆ mic_mute

uint8_t usb_audio_hid_type::mic_mute

Definition at line 119 of file audio_hid_class.h.

Referenced by audio_req_get_cur(), and class_ept0_rx_handler().

◆ mic_volume

uint16_t usb_audio_hid_type::mic_volume

Definition at line 121 of file audio_hid_class.h.

Referenced by audio_req_get_cur(), and class_ept0_rx_handler().

◆ mic_volume_limits

uint16_t usb_audio_hid_type::mic_volume_limits[3]

Definition at line 125 of file audio_hid_class.h.

Referenced by audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), and class_ept0_rx_handler().

◆ request_no

uint8_t usb_audio_hid_type::request_no

Definition at line 117 of file audio_hid_class.h.

Referenced by audio_req_set_cur(), and class_ept0_rx_handler().

◆ spk_alt_setting

uint32_t usb_audio_hid_type::spk_alt_setting

Definition at line 129 of file audio_hid_class.h.

Referenced by audio_get_interface(), audio_set_interface(), and class_event_handler().

◆ spk_freq

uint32_t usb_audio_hid_type::spk_freq

Definition at line 122 of file audio_hid_class.h.

Referenced by class_ept0_rx_handler().

◆ spk_mute

uint8_t usb_audio_hid_type::spk_mute

Definition at line 118 of file audio_hid_class.h.

Referenced by audio_req_get_cur(), and class_ept0_rx_handler().

◆ spk_volume

uint16_t usb_audio_hid_type::spk_volume

Definition at line 120 of file audio_hid_class.h.

Referenced by audio_req_get_cur(), and class_ept0_rx_handler().

◆ spk_volume_limits

uint16_t usb_audio_hid_type::spk_volume_limits[3]

Definition at line 124 of file audio_hid_class.h.

Referenced by audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), and class_ept0_rx_handler().

The documentation for this struct was generated from the following file:
  • audio_hid_class.h


AT32F435/437 Firmwary Library: USB_audio_hid_desc

Modules
USB_audio_hid_desc
AT32F435_437_middlewares_usbd_class

usb device audio hid descriptor More...

Modules

USB_audio_hid_desc_private_functions
USB_audio_hid_desc_definition

Detailed Description

usb device audio hid descriptor


AT32F435/437 Firmwary Library: USB_audio_hid_desc_private_functions

Functions | Variables
USB_audio_hid_desc_private_functions
AT32F435_437_middlewares_usbd_class » USB_audio_hid_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler | audio_hid_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 774 of file audio_hid_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 696 of file audio_hid_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 676 of file audio_hid_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 762 of file audio_hid_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 716 of file audio_hid_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 727 of file audio_hid_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 706 of file audio_hid_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 739 of file audio_hid_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 686 of file audio_hid_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 751 of file audio_hid_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 654 of file audio_hid_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 628 of file audio_hid_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 602 of file audio_hid_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x00,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x5555 ),
HBYTE( 0x5555 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
0x01
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92

usb device standard descriptor

usb string serial

usb string lang id

usb hid descriptor

usb hid report descriptor

usb configuration standard descriptor

Definition at line 82 of file audio_hid_desc.c.

◆ audio_hid_desc_handler

usbd_desc_handler audio_hid_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: audio_hid_desc.c:696
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: audio_hid_desc.c:676
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: audio_hid_desc.c:727
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: audio_hid_desc.c:686
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: audio_hid_desc.c:762
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: audio_hid_desc.c:706
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: audio_hid_desc.c:739
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: audio_hid_desc.c:774
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: audio_hid_desc.c:716
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: audio_hid_desc.c:751

device descriptor handler structure

Definition at line 62 of file audio_hid_desc.c.

Referenced by main().

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
( 0x12 + ((0x08 + ( 1 + 1 ) ) + ( 1 + 1 ) * 0x1E) + + (0x31 + ( ( 0 + 1 ) ) * 3) + (0x31 + ( ( 0 + 1 ) ) * 3) + (9 * 1 ) + 32 ) ,
g_usbd_configuration
}

Definition at line 574 of file audio_hid_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 567 of file audio_hid_desc.c.

Referenced by get_device_descriptor().

◆ g_usbd_desc_buffer

uint8_t g_usbd_desc_buffer[256]
static

Definition at line 57 of file audio_hid_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 581 of file audio_hid_desc.c.

Referenced by get_device_lang_id().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 588 of file audio_hid_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 594 of file audio_hid_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F435/437 Firmwary Library: USB_audio_hid_desc_definition

Macros | Variables
USB_audio_hid_desc_definition
AT32F435_437_middlewares_usbd_class » USB_audio_hid_desc

Macros

#define | AUHID_BCD_NUM 0x0100
#define | USBD_AUHID_VENDOR_ID 0x2E3C
#define | USBD_AUHID_PRODUCT_ID 0x5555
#define | USBD_AUHID_SIZ_STRING_LANGID 4
#define | USBD_AUHID_SIZ_STRING_SERIAL 0x1A
#define | USBD_AUHID_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_AUHID_DESC_PRODUCT_STRING "AT32 Audio"
#define | USBD_AUHID_DESC_CONFIGURATION_STRING "Audio Config"
#define | USBD_AUHID_DESC_INTERFACE_STRING "Audio Interface"
#define | AUDIO_SUBCLASS_UNDEFINED 0x00
audio interface subclass codes More...
#define | AUDIO_SUBCLASS_AUDIOCONTROL 0x01
#define | AUDIO_SUBCLASS_AUDIOSTREAMING 0x02
#define | AUDIO_SUBCLASS_MIDISTREMING 0x03
#define | AUDIO_CS_INTERFACE 0x24
audio class-specific descriptor types More...
#define | AUDIO_CS_ENDPOINT 0x25
#define | AUDIO_CS_STRING 0x23
#define | AUDIO_CS_CONFIGURATION 0x22
#define | AUDIO_CS_DEVICE 0x21
#define | AUDIO_CS_UNDEFINED 0x20
#define | AUDIO_PROTOCOL_UNDEFINED 0x00
audio interface protocol codes More...
#define | AUDIO_AC_DESCRIPTOR_UNDEFINED 0x00
audio class-specific ac interface descriptor subtypes More...
#define | AUDIO_AC_HEADER 0x01
#define | AUDIO_AC_INPUT_TERMINAL 0x02
#define | AUDIO_AC_OUTPUT_TERMINAL 0x03
#define | AUDIO_AC_MIXER_UNIT 0x04
#define | AUDIO_AC_SELECTOR_UNIT 0x05
#define | AUDIO_AC_FEATURE_UNIT 0x06
#define | AUDIO_AC_PROCESSING_UNIT 0x07
#define | AUDIO_AC_EXTENSION_UNIT 0x08
#define | AUDIO_AS_DESCRIPTOR_UNDEFINED 0x00
audio class-specific as interface descriptor subtypes More...
#define | AUDIO_AS_GENERAL 0x01
#define | AUDIO_AS_FORMAT_TYPE 0x02
#define | AUDIO_AS_FORMAT_SPECIFIC 0x03
#define | AUDIO_REQUEST_CODE_UNDEFINED 0x00
audio class-specific request codes More...
#define | AUDIO_REQ_SET_CUR 0x01
#define | AUDIO_REQ_GET_CUR 0x81
#define | AUDIO_REQ_SET_MIN 0x02
#define | AUDIO_REQ_GET_MIN 0x82
#define | AUDIO_REQ_SET_MAX 0x03
#define | AUDIO_REQ_GET_MAX 0x83
#define | AUDIO_REQ_SET_RES 0x04
#define | AUDIO_REQ_GET_RES 0x84
#define | AUDIO_REQ_SET_MEM 0x05
#define | AUDIO_REQ_GET_MEM 0x85
#define | AUDIO_REQ_GET_STAT 0xFF
#define | AUDIO_FU_CONTROL_UNDEFINED 0x00
audio feature unit control selectors More...
#define | AUDIO_FU_MUTE_CONTROL 0x01
#define | AUDIO_FU_VOLUME_CONTROL 0x02
#define | AUDIO_FU_BASS_CONTROL 0x03
#define | AUDIO_FU_MID_CONTROL 0x04
#define | AUDIO_FU_TREBLE_CONTROL 0x05
#define | AUDIO_TERMINAL_TYPE_UNDEFINED 0x0100
audio terminal type More...
#define | AUDIO_TERMINAL_TYPE_STREAMING 0x0101
#define | AUDIO_TERMINAL_TYPE_VENDOR 0x01FF
#define | AUDIO_INPUT_TERMINAL_UNDEFINED 0x0200
#define | AUDIO_INPUT_TERMINAL_MICROPHONE 0x0201
#define | AUDIO_OUTPUT_TERMINAL_UNDEFINED 0x0300
#define | AUDIO_OUTPUT_TERMINAL_SPEAKER 0x0301
#define | AUDIO_FORMAT_TYPE_I 0x01
audio format type 1 More...
#define | AUDIO_INTERFACE_NUM (AUDIO_SUPPORT_SPK + AUDIO_SUPPORT_MIC)
audio interface config More...
#define | AUDIO_INTERFACE_LEN ((0x08 + AUDIO_INTERFACE_NUM) + AUDIO_INTERFACE_NUM * 0x1E)
#define | AUDIO_MIC_INTERFACE 0x01
#define | AUDIO_SPK_INTERFACE 0x02
#define | AUDIO_INPUT_TERMINAL_SIZE 0x0C
audio interface descriptor size define More...
#define | AUDIO_OUTPUT_TERMINAL_SIZE 0x09
#define | AUDIO_FEATURE_UNIT_SIZE 0x09
#define | AUDIO_MIC_INPUT_TERMINAL_ID 0x01
audio terminal id define More...
#define | AUDIO_MIC_FEATURE_UNIT_ID 0x02
#define | AUDIO_MIC_OUTPUT_TERMINAL_ID 0x03
#define | AUDIO_SPK_INPUT_TERMINAL_ID 0x04
#define | AUDIO_SPK_FEATURE_UNIT_ID 0x05
#define | AUDIO_SPK_OUTPUT_TERMINAL_ID 0x06
#define | AUDIO_MIC_INTERFACE_NUMBER 0x01
audio interface number More...
#define | AUDIO_SPK_INTERFACE_NUMBER 0x02
#define | HID_INTERFACE_NUMBER 0x03
#define | AT32_AUDIO_FREQ_16K 16000
audio support freq More...
#define | AT32_AUDIO_FREQ_48K 48000
#define | AUDIO_MIC_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
audio microphone freq and channel config More...
#define | AUDIO_MIC_CHR AUDIO_MIC_CHANEL_NUM
#define | AUDIO_MIC_BITW (AUDIO_MIC_DEFAULT_BITW)
#define | AUDIO_SPK_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
audio speaker freq and channel config More...
#define | AUDIO_SPK_CHR AUDIO_SPK_CHANEL_NUM
#define | AUDIO_SPK_BITW (AUDIO_SPK_DEFAULT_BITW)
#define | AUHID_HID_BINTERVAL_TIME 0x01
#define | AUHID_HID_BCD_NUM 0x0110
usb bcd number define More...
#define | HID_CLASS_DESC_HID 0x21
usb hid class descriptor define More...
#define | HID_CLASS_DESC_REPORT 0x22
#define | HID_CLASS_DESC_PHYSICAL 0x23
#define | HID_REPORT_ID_1 0x01
usb hid report id define More...
#define | HID_REPORT_ID_2 0x02
#define | HID_REPORT_ID_3 0x03
#define | HID_REPORT_ID_4 0x04
#define | HID_REPORT_ID_5 0x05
#define | HID_REPORT_ID_6 0xF0
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)
#define | SAMPLE_FREQ(frq) (uint8_t)(frq), (uint8_t)((frq >> 8)), (uint8_t)((frq >> 16))
#define | USBD_AUHID_HID_SIZ_REPORT_DESC 126
#define | USBD_AUHID_HID_DESC_SIZE 32
#define | USBD_AUHID_CONFIG_DESC_SIZE

Variables

uint8_t | g_usbd_audio_hid_report [126]
usb hid report descriptor More...
uint8_t | g_audio_hid_usb_desc [9]
usb hid descriptor More...
usbd_desc_handler | audio_hid_desc_handler
device descriptor handler structure More...

Detailed Description

Macro Definition Documentation

◆ AT32_AUDIO_FREQ_16K

#define AT32_AUDIO_FREQ_16K 16000

audio support freq

Definition at line 188 of file audio_hid_desc.h.

◆ AT32_AUDIO_FREQ_48K

#define AT32_AUDIO_FREQ_48K 48000

Definition at line 189 of file audio_hid_desc.h.

◆ AUDIO_AC_DESCRIPTOR_UNDEFINED

#define AUDIO_AC_DESCRIPTOR_UNDEFINED 0x00

audio class-specific ac interface descriptor subtypes

Definition at line 89 of file audio_hid_desc.h.

◆ AUDIO_AC_EXTENSION_UNIT

#define AUDIO_AC_EXTENSION_UNIT 0x08

Definition at line 97 of file audio_hid_desc.h.

◆ AUDIO_AC_FEATURE_UNIT

#define AUDIO_AC_FEATURE_UNIT 0x06

Definition at line 95 of file audio_hid_desc.h.

◆ AUDIO_AC_HEADER

#define AUDIO_AC_HEADER 0x01

Definition at line 90 of file audio_hid_desc.h.

◆ AUDIO_AC_INPUT_TERMINAL

#define AUDIO_AC_INPUT_TERMINAL 0x02

Definition at line 91 of file audio_hid_desc.h.

◆ AUDIO_AC_MIXER_UNIT

#define AUDIO_AC_MIXER_UNIT 0x04

Definition at line 93 of file audio_hid_desc.h.

◆ AUDIO_AC_OUTPUT_TERMINAL

#define AUDIO_AC_OUTPUT_TERMINAL 0x03

Definition at line 92 of file audio_hid_desc.h.

◆ AUDIO_AC_PROCESSING_UNIT

#define AUDIO_AC_PROCESSING_UNIT 0x07

Definition at line 96 of file audio_hid_desc.h.

◆ AUDIO_AC_SELECTOR_UNIT

#define AUDIO_AC_SELECTOR_UNIT 0x05

Definition at line 94 of file audio_hid_desc.h.

◆ AUDIO_AS_DESCRIPTOR_UNDEFINED

#define AUDIO_AS_DESCRIPTOR_UNDEFINED 0x00

audio class-specific as interface descriptor subtypes

Definition at line 102 of file audio_hid_desc.h.

◆ AUDIO_AS_FORMAT_SPECIFIC

#define AUDIO_AS_FORMAT_SPECIFIC 0x03

Definition at line 105 of file audio_hid_desc.h.

◆ AUDIO_AS_FORMAT_TYPE

#define AUDIO_AS_FORMAT_TYPE 0x02

Definition at line 104 of file audio_hid_desc.h.

◆ AUDIO_AS_GENERAL

#define AUDIO_AS_GENERAL 0x01

Definition at line 103 of file audio_hid_desc.h.

◆ AUDIO_CS_CONFIGURATION

#define AUDIO_CS_CONFIGURATION 0x22

Definition at line 77 of file audio_hid_desc.h.

◆ AUDIO_CS_DEVICE

#define AUDIO_CS_DEVICE 0x21

Definition at line 78 of file audio_hid_desc.h.

◆ AUDIO_CS_ENDPOINT

#define AUDIO_CS_ENDPOINT 0x25

Definition at line 75 of file audio_hid_desc.h.

◆ AUDIO_CS_INTERFACE

#define AUDIO_CS_INTERFACE 0x24

audio class-specific descriptor types

Definition at line 74 of file audio_hid_desc.h.

◆ AUDIO_CS_STRING

#define AUDIO_CS_STRING 0x23

Definition at line 76 of file audio_hid_desc.h.

◆ AUDIO_CS_UNDEFINED

#define AUDIO_CS_UNDEFINED 0x20

Definition at line 79 of file audio_hid_desc.h.

◆ AUDIO_FEATURE_UNIT_SIZE

#define AUDIO_FEATURE_UNIT_SIZE 0x09

Definition at line 162 of file audio_hid_desc.h.

◆ AUDIO_FORMAT_TYPE_I

#define AUDIO_FORMAT_TYPE_I 0x01

audio format type 1

Definition at line 147 of file audio_hid_desc.h.

◆ AUDIO_FU_BASS_CONTROL

#define AUDIO_FU_BASS_CONTROL 0x03

Definition at line 129 of file audio_hid_desc.h.

◆ AUDIO_FU_CONTROL_UNDEFINED

#define AUDIO_FU_CONTROL_UNDEFINED 0x00

audio feature unit control selectors

Definition at line 126 of file audio_hid_desc.h.

◆ AUDIO_FU_MID_CONTROL

#define AUDIO_FU_MID_CONTROL 0x04

Definition at line 130 of file audio_hid_desc.h.

◆ AUDIO_FU_MUTE_CONTROL

#define AUDIO_FU_MUTE_CONTROL 0x01

Definition at line 127 of file audio_hid_desc.h.

◆ AUDIO_FU_TREBLE_CONTROL

#define AUDIO_FU_TREBLE_CONTROL 0x05

Definition at line 131 of file audio_hid_desc.h.

◆ AUDIO_FU_VOLUME_CONTROL

#define AUDIO_FU_VOLUME_CONTROL 0x02

Definition at line 128 of file audio_hid_desc.h.

◆ AUDIO_INPUT_TERMINAL_MICROPHONE

#define AUDIO_INPUT_TERMINAL_MICROPHONE 0x0201

Definition at line 140 of file audio_hid_desc.h.

◆ AUDIO_INPUT_TERMINAL_SIZE

#define AUDIO_INPUT_TERMINAL_SIZE 0x0C

audio interface descriptor size define

Definition at line 160 of file audio_hid_desc.h.

◆ AUDIO_INPUT_TERMINAL_UNDEFINED

#define AUDIO_INPUT_TERMINAL_UNDEFINED 0x0200

Definition at line 139 of file audio_hid_desc.h.

◆ AUDIO_INTERFACE_LEN

#define AUDIO_INTERFACE_LEN ((0x08 + AUDIO_INTERFACE_NUM) + AUDIO_INTERFACE_NUM * 0x1E)

Definition at line 153 of file audio_hid_desc.h.

◆ AUDIO_INTERFACE_NUM

#define AUDIO_INTERFACE_NUM (AUDIO_SUPPORT_SPK + AUDIO_SUPPORT_MIC)

audio interface config

Definition at line 152 of file audio_hid_desc.h.

◆ AUDIO_MIC_BITW

#define AUDIO_MIC_BITW (AUDIO_MIC_DEFAULT_BITW)

Definition at line 196 of file audio_hid_desc.h.

◆ AUDIO_MIC_CHR

#define AUDIO_MIC_CHR AUDIO_MIC_CHANEL_NUM

Definition at line 195 of file audio_hid_desc.h.

◆ AUDIO_MIC_FEATURE_UNIT_ID

#define AUDIO_MIC_FEATURE_UNIT_ID 0x02

Definition at line 168 of file audio_hid_desc.h.

◆ AUDIO_MIC_FREQ_SIZE

#define AUDIO_MIC_FREQ_SIZE (AUDIO_SUPPORT_FREQ)

audio microphone freq and channel config

Definition at line 194 of file audio_hid_desc.h.

◆ AUDIO_MIC_INPUT_TERMINAL_ID

#define AUDIO_MIC_INPUT_TERMINAL_ID 0x01

audio terminal id define

Definition at line 167 of file audio_hid_desc.h.

◆ AUDIO_MIC_INTERFACE

#define AUDIO_MIC_INTERFACE 0x01

Definition at line 154 of file audio_hid_desc.h.

◆ AUDIO_MIC_INTERFACE_NUMBER

#define AUDIO_MIC_INTERFACE_NUMBER 0x01

audio interface number

Definition at line 177 of file audio_hid_desc.h.

◆ AUDIO_MIC_OUTPUT_TERMINAL_ID

#define AUDIO_MIC_OUTPUT_TERMINAL_ID 0x03

Definition at line 169 of file audio_hid_desc.h.

◆ AUDIO_OUTPUT_TERMINAL_SIZE

#define AUDIO_OUTPUT_TERMINAL_SIZE 0x09

Definition at line 161 of file audio_hid_desc.h.

◆ AUDIO_OUTPUT_TERMINAL_SPEAKER

#define AUDIO_OUTPUT_TERMINAL_SPEAKER 0x0301

Definition at line 142 of file audio_hid_desc.h.

◆ AUDIO_OUTPUT_TERMINAL_UNDEFINED

#define AUDIO_OUTPUT_TERMINAL_UNDEFINED 0x0300

Definition at line 141 of file audio_hid_desc.h.

◆ AUDIO_PROTOCOL_UNDEFINED

#define AUDIO_PROTOCOL_UNDEFINED 0x00

audio interface protocol codes

Definition at line 84 of file audio_hid_desc.h.

◆ AUDIO_REQ_GET_CUR

#define AUDIO_REQ_GET_CUR 0x81

Definition at line 112 of file audio_hid_desc.h.

◆ AUDIO_REQ_GET_MAX

#define AUDIO_REQ_GET_MAX 0x83

Definition at line 116 of file audio_hid_desc.h.

◆ AUDIO_REQ_GET_MEM

#define AUDIO_REQ_GET_MEM 0x85

Definition at line 120 of file audio_hid_desc.h.

◆ AUDIO_REQ_GET_MIN

#define AUDIO_REQ_GET_MIN 0x82

Definition at line 114 of file audio_hid_desc.h.

◆ AUDIO_REQ_GET_RES

#define AUDIO_REQ_GET_RES 0x84

Definition at line 118 of file audio_hid_desc.h.

◆ AUDIO_REQ_GET_STAT

#define AUDIO_REQ_GET_STAT 0xFF

Definition at line 121 of file audio_hid_desc.h.

◆ AUDIO_REQ_SET_CUR

#define AUDIO_REQ_SET_CUR 0x01

Definition at line 111 of file audio_hid_desc.h.

◆ AUDIO_REQ_SET_MAX

#define AUDIO_REQ_SET_MAX 0x03

Definition at line 115 of file audio_hid_desc.h.

◆ AUDIO_REQ_SET_MEM

#define AUDIO_REQ_SET_MEM 0x05

Definition at line 119 of file audio_hid_desc.h.

◆ AUDIO_REQ_SET_MIN

#define AUDIO_REQ_SET_MIN 0x02

Definition at line 113 of file audio_hid_desc.h.

◆ AUDIO_REQ_SET_RES

#define AUDIO_REQ_SET_RES 0x04

Definition at line 117 of file audio_hid_desc.h.

◆ AUDIO_REQUEST_CODE_UNDEFINED

#define AUDIO_REQUEST_CODE_UNDEFINED 0x00

audio class-specific request codes

Definition at line 110 of file audio_hid_desc.h.

◆ AUDIO_SPK_BITW

#define AUDIO_SPK_BITW (AUDIO_SPK_DEFAULT_BITW)

Definition at line 203 of file audio_hid_desc.h.

◆ AUDIO_SPK_CHR

#define AUDIO_SPK_CHR AUDIO_SPK_CHANEL_NUM

Definition at line 202 of file audio_hid_desc.h.

◆ AUDIO_SPK_FEATURE_UNIT_ID

#define AUDIO_SPK_FEATURE_UNIT_ID 0x05

Definition at line 171 of file audio_hid_desc.h.

◆ AUDIO_SPK_FREQ_SIZE

#define AUDIO_SPK_FREQ_SIZE (AUDIO_SUPPORT_FREQ)

audio speaker freq and channel config

Definition at line 201 of file audio_hid_desc.h.

◆ AUDIO_SPK_INPUT_TERMINAL_ID

#define AUDIO_SPK_INPUT_TERMINAL_ID 0x04

Definition at line 170 of file audio_hid_desc.h.

◆ AUDIO_SPK_INTERFACE

#define AUDIO_SPK_INTERFACE 0x02

Definition at line 155 of file audio_hid_desc.h.

◆ AUDIO_SPK_INTERFACE_NUMBER

#define AUDIO_SPK_INTERFACE_NUMBER 0x02

Definition at line 179 of file audio_hid_desc.h.

◆ AUDIO_SPK_OUTPUT_TERMINAL_ID

#define AUDIO_SPK_OUTPUT_TERMINAL_ID 0x06

Definition at line 172 of file audio_hid_desc.h.

◆ AUDIO_SUBCLASS_AUDIOCONTROL

#define AUDIO_SUBCLASS_AUDIOCONTROL 0x01

Definition at line 67 of file audio_hid_desc.h.

◆ AUDIO_SUBCLASS_AUDIOSTREAMING

#define AUDIO_SUBCLASS_AUDIOSTREAMING 0x02

Definition at line 68 of file audio_hid_desc.h.

◆ AUDIO_SUBCLASS_MIDISTREMING

#define AUDIO_SUBCLASS_MIDISTREMING 0x03

Definition at line 69 of file audio_hid_desc.h.

◆ AUDIO_SUBCLASS_UNDEFINED

#define AUDIO_SUBCLASS_UNDEFINED 0x00

audio interface subclass codes

Definition at line 66 of file audio_hid_desc.h.

◆ AUDIO_TERMINAL_TYPE_STREAMING

#define AUDIO_TERMINAL_TYPE_STREAMING 0x0101

Definition at line 137 of file audio_hid_desc.h.

◆ AUDIO_TERMINAL_TYPE_UNDEFINED

#define AUDIO_TERMINAL_TYPE_UNDEFINED 0x0100

audio terminal type

Definition at line 136 of file audio_hid_desc.h.

◆ AUDIO_TERMINAL_TYPE_VENDOR

#define AUDIO_TERMINAL_TYPE_VENDOR 0x01FF

Definition at line 138 of file audio_hid_desc.h.

◆ AUHID_BCD_NUM

#define AUHID_BCD_NUM 0x0100

Definition at line 51 of file audio_hid_desc.h.

◆ AUHID_HID_BCD_NUM

#define AUHID_HID_BCD_NUM 0x0110

usb bcd number define

Definition at line 210 of file audio_hid_desc.h.

◆ AUHID_HID_BINTERVAL_TIME

#define AUHID_HID_BINTERVAL_TIME 0x01

Definition at line 205 of file audio_hid_desc.h.

◆ HID_CLASS_DESC_HID

#define HID_CLASS_DESC_HID 0x21

usb hid class descriptor define

Definition at line 215 of file audio_hid_desc.h.

◆ HID_CLASS_DESC_PHYSICAL

#define HID_CLASS_DESC_PHYSICAL 0x23

Definition at line 217 of file audio_hid_desc.h.

◆ HID_CLASS_DESC_REPORT

#define HID_CLASS_DESC_REPORT 0x22

Definition at line 216 of file audio_hid_desc.h.

◆ HID_INTERFACE_NUMBER

#define HID_INTERFACE_NUMBER 0x03

Definition at line 183 of file audio_hid_desc.h.

◆ HID_REPORT_ID_1

#define HID_REPORT_ID_1 0x01

usb hid report id define

Definition at line 222 of file audio_hid_desc.h.

◆ HID_REPORT_ID_2

#define HID_REPORT_ID_2 0x02

Definition at line 223 of file audio_hid_desc.h.

◆ HID_REPORT_ID_3

#define HID_REPORT_ID_3 0x03

Definition at line 224 of file audio_hid_desc.h.

◆ HID_REPORT_ID_4

#define HID_REPORT_ID_4 0x04

Definition at line 225 of file audio_hid_desc.h.

◆ HID_REPORT_ID_5

#define HID_REPORT_ID_5 0x05

Definition at line 226 of file audio_hid_desc.h.

◆ HID_REPORT_ID_6

#define HID_REPORT_ID_6 0xF0

Definition at line 227 of file audio_hid_desc.h.

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

Definition at line 229 of file audio_hid_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 230 of file audio_hid_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 231 of file audio_hid_desc.h.

◆ SAMPLE_FREQ

#define SAMPLE_FREQ ( frq ) (uint8_t)(frq), (uint8_t)((frq >> 8)), (uint8_t)((frq >> 16))

Definition at line 234 of file audio_hid_desc.h.

◆ USBD_AUHID_CONFIG_DESC_SIZE

#define USBD_AUHID_CONFIG_DESC_SIZE
Value:
( 0x12 + AUDIO_INTERFACE_LEN + \
+ (0x31 + AUDIO_SPK_FREQ_SIZE * 3) \
+ (0x31 + AUDIO_MIC_FREQ_SIZE * 3) \
+ (9 * AUDIO_SUPPORT_FEEDBACK) \
+ USBD_AUHID_HID_DESC_SIZE)
AUDIO_MIC_FREQ_SIZE
#define AUDIO_MIC_FREQ_SIZE
audio microphone freq and channel config
Definition: audio_hid_desc.h:194
AUDIO_SPK_FREQ_SIZE
#define AUDIO_SPK_FREQ_SIZE
audio speaker freq and channel config
Definition: audio_hid_desc.h:201
USBD_AUHID_HID_DESC_SIZE
#define USBD_AUHID_HID_DESC_SIZE
Definition: audio_hid_desc.h:237
AUDIO_INTERFACE_LEN
#define AUDIO_INTERFACE_LEN
Definition: audio_hid_desc.h:153
AUDIO_SUPPORT_FEEDBACK
#define AUDIO_SUPPORT_FEEDBACK
Definition: audio/audio_conf.h:49

Definition at line 238 of file audio_hid_desc.h.

◆ USBD_AUHID_DESC_CONFIGURATION_STRING

#define USBD_AUHID_DESC_CONFIGURATION_STRING "Audio Config"

Definition at line 61 of file audio_hid_desc.h.

◆ USBD_AUHID_DESC_INTERFACE_STRING

#define USBD_AUHID_DESC_INTERFACE_STRING "Audio Interface"

Definition at line 62 of file audio_hid_desc.h.

◆ USBD_AUHID_DESC_MANUFACTURER_STRING

#define USBD_AUHID_DESC_MANUFACTURER_STRING "Artery"

Definition at line 59 of file audio_hid_desc.h.

◆ USBD_AUHID_DESC_PRODUCT_STRING

#define USBD_AUHID_DESC_PRODUCT_STRING "AT32 Audio"

Definition at line 60 of file audio_hid_desc.h.

◆ USBD_AUHID_HID_DESC_SIZE

#define USBD_AUHID_HID_DESC_SIZE 32

Definition at line 237 of file audio_hid_desc.h.

◆ USBD_AUHID_HID_SIZ_REPORT_DESC

#define USBD_AUHID_HID_SIZ_REPORT_DESC 126

Definition at line 236 of file audio_hid_desc.h.

◆ USBD_AUHID_PRODUCT_ID

#define USBD_AUHID_PRODUCT_ID 0x5555

Definition at line 54 of file audio_hid_desc.h.

◆ USBD_AUHID_SIZ_STRING_LANGID

#define USBD_AUHID_SIZ_STRING_LANGID 4

Definition at line 56 of file audio_hid_desc.h.

◆ USBD_AUHID_SIZ_STRING_SERIAL

#define USBD_AUHID_SIZ_STRING_SERIAL 0x1A

Definition at line 57 of file audio_hid_desc.h.

◆ USBD_AUHID_VENDOR_ID

#define USBD_AUHID_VENDOR_ID 0x2E3C

Definition at line 53 of file audio_hid_desc.h.

Variable Documentation

◆ audio_hid_desc_handler

usbd_desc_handler audio_hid_desc_handler
extern

device descriptor handler structure

Definition at line 62 of file audio_hid_desc.c.

Referenced by main().

◆ g_audio_hid_usb_desc

ALIGNED_HEAD uint8_t g_audio_hid_usb_desc
extern
Initial value:
=
{
0x09,
0x21 ,
LBYTE( 0x0110 ),
HBYTE( 0x0110 ),
0x00,
0x01,
0x22 ,
LBYTE(sizeof(g_usbd_audio_hid_report)),
HBYTE(sizeof(g_usbd_audio_hid_report)),
}
g_usbd_audio_hid_report
uint8_t g_usbd_audio_hid_report[126]
usb hid report descriptor
Definition: audio_hid_desc.c:427
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260

usb hid descriptor

Definition at line 525 of file audio_hid_desc.c.

Referenced by class_hid_setup_handler().

◆ g_usbd_audio_hid_report

ALIGNED_HEAD uint8_t g_usbd_audio_hid_report
extern

usb hid report descriptor

Definition at line 427 of file audio_hid_desc.c.

Referenced by class_hid_setup_handler().


AT32F435/437 Firmwary Library: USB_cdc_class

Modules
USB_cdc_class
AT32F435_437_middlewares_usbd_class

usb device class cdc demo More...

Modules

USB_cdc_class_private_functions
USB_cdc_class_definition
USB_cdc_class_exported_types
USB_cdc_class_exported_functions

Detailed Description

usb device class cdc demo


AT32F435/437 Firmwary Library: USB_cdc_class_private_functions

Functions | Variables
USB_cdc_class_private_functions
AT32F435_437_middlewares_usbd_class » USB_cdc_class | AT32F435_437_middlewares_usbd_class » USB_cdc_msc_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
static usb_sts_type | cdc_struct_init (cdc_struct_type *pcdc)
usb device cdc init More...
void | usb_usart_config (linecoding_type linecoding)
this function handles usart2 and linecoding config. More...
static void | usb_vcp_cmd_process (void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device function More...
uint16_t | usb_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...
static usb_sts_type | cdc_struct_init (cdc_msc_struct_type *pcdc)
usb device cdc init More...
static usb_sts_type | cdc_class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | msc_class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...

Variables

linecoding_type linecoding
cdc_struct_type cdc_struct
usbd_class_handler | cdc_class_handler
linecoding_type linecoding
cdc_msc_struct_type cdc_msc_struct
usbd_class_handler | cdc_msc_class_handler

Detailed Description

Function Documentation

◆ cdc_class_setup_handler()

static usb_sts_type cdc_class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 193 of file cdc_msc_class.c.

Referenced by class_setup_handler().

◆ cdc_struct_init() [1/2]

static usb_sts_type cdc_struct_init ( cdc_msc_struct_type * pcdc )
static

usb device cdc init

Parameters
pcdc to the structure of cdc_struct
Return values
status of usb_sts_type

Definition at line 462 of file cdc_msc_class.c.

Referenced by class_init_handler().

◆ cdc_struct_init() [2/2]

static usb_sts_type cdc_struct_init ( cdc_struct_type * pcdc )
static

usb device cdc init

Parameters
pcdc to the structure of cdc_struct
Return values
status of usb_sts_type

Definition at line 321 of file cdc_class.c.

Referenced by class_init_handler().

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 116 of file cdc_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device endpoint 0 out status stage complete

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 208 of file cdc_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 194 of file cdc_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 286 of file cdc_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 230 of file cdc_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb custom hid endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 87 of file cdc_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 251 of file cdc_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 139 of file cdc_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 271 of file cdc_class.c.

◆ msc_class_setup_handler()

static usb_sts_type msc_class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

< get max lun

< bulk only mass storage reset

Definition at line 249 of file cdc_msc_class.c.

Referenced by class_setup_handler().

◆ usb_usart_config()

void usb_usart_config ( linecoding_type linecoding )

this function handles usart2 and linecoding config.

Parameters
linecoding linecoding value
Return values
none

< usart receive data buffer full interrupt

< usart receive data buffer full interrupt

< usart receive data buffer full interrupt

Definition at line 241 of file project/at_start_f435/examples/usb_device/virtual_comport/src/main.c.

Referenced by main(), and usb_vcp_cmd_process().

◆ usb_vcp_cmd_process()

static void usb_vcp_cmd_process | ( | void * | udev,
 |  | uint8_t | cmd,
 |  | uint8_t * | buff,
 |  | uint16_t | len
 | ) |  |
static

usb device function

Parameters
udev | to the structure of usbd_core_type
cmd | request number
buff | request buffer
len | buffer length
Return values
none

Definition at line 394 of file cdc_class.c.

Referenced by class_ept0_rx_handler(), and class_setup_handler().

◆ usb_vcp_get_rxdata()

uint16_t usb_vcp_get_rxdata | ( | void * | udev,
 |  | uint8_t * | recv_data
 | ) |  |

usb device class rx data process

Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len
Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len

Definition at line 339 of file cdc_class.c.

Referenced by main().

◆ usb_vcp_send_data()

error_status usb_vcp_send_data | ( | void * | udev,
 |  | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

usb device class send data

Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status
Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status

Definition at line 369 of file cdc_class.c.

Referenced by main().

Variable Documentation

◆ cdc_class_handler

usbd_class_handler cdc_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&cdc_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: cdc_class.c:271
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: cdc_class.c:230
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: cdc_class.c:116
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_class.c:139
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: cdc_class.c:194
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: cdc_class.c:208
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: cdc_class.c:286
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: cdc_class.c:87
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: cdc_class.c:251
cdc_struct
cdc_struct_type cdc_struct
Definition: cdc_class.c:66

Definition at line 69 of file cdc_class.c.

Referenced by main().

◆ cdc_msc_class_handler

usbd_class_handler cdc_msc_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&cdc_msc_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: cdc_msc_class.c:412
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: cdc_msc_class.c:354
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: cdc_msc_class.c:127
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_msc_class.c:156
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: cdc_msc_class.c:318
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: cdc_msc_class.c:332
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: cdc_msc_class.c:427
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: cdc_msc_class.c:90
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: cdc_msc_class.c:383
cdc_msc_struct
cdc_msc_struct_type cdc_msc_struct
Definition: cdc_msc_class.c:69

Definition at line 72 of file cdc_msc_class.c.

Referenced by main().

◆ cdc_msc_struct

cdc_msc_struct_type cdc_msc_struct

Definition at line 69 of file cdc_msc_class.c.

Referenced by msc_class_setup_handler().

◆ cdc_struct

cdc_struct_type cdc_struct

Definition at line 66 of file cdc_class.c.

◆ linecoding [1/2]

linecoding_type linecoding
Initial value:
=
{
115200,
0,
0,
8
}

Definition at line 57 of file cdc_class.c.

Referenced by cdc_struct_init().

◆ linecoding [2/2]

linecoding_type linecoding
Initial value:
=
{
115200,
0,
0,
8
}

Definition at line 60 of file cdc_msc_class.c.

Referenced by cdc_struct_init(), main(), and usb_usart_config().


AT32F435/437 Firmwary Library: USB_cdc_class_definition

Macros
USB_cdc_class_definition
AT32F435_437_middlewares_usbd_class » USB_cdc_class | AT32F435_437_middlewares_usbd_class » USB_cdc_msc_class

Macros

#define | USBD_CDC_INT_EPT 0x82
usb cdc use endpoint define More...
#define | USBD_CDC_BULK_IN_EPT 0x81
#define | USBD_CDC_BULK_OUT_EPT 0x01
#define | USBD_CDC_IN_MAXPACKET_SIZE 0x40
usb cdc in and out max packet size define More...
#define | USBD_CDC_OUT_MAXPACKET_SIZE 0x40
#define | USBD_CDC_CMD_MAXPACKET_SIZE 0x08
#define | USBD_CDC_INT_EPT 0x82
usb cdc use endpoint define More...
#define | USBD_CDC_BULK_IN_EPT 0x83
#define | USBD_CDC_BULK_OUT_EPT 0x02
#define | USBD_MSC_BULK_IN_EPT 0x81
#define | USBD_MSC_BULK_OUT_EPT 0x01
#define | USBD_CDC_MSC_IN_MAXPACKET_SIZE 0x40
usb cdc in and out max packet size define More...
#define | USBD_CDC_MSC_OUT_MAXPACKET_SIZE 0x40
#define | USBD_CDC_CMD_MAXPACKET_SIZE 0x08

Detailed Description

Macro Definition Documentation

◆ USBD_CDC_BULK_IN_EPT [1/2]

#define USBD_CDC_BULK_IN_EPT 0x81

Definition at line 54 of file cdc_class.h.

◆ USBD_CDC_BULK_IN_EPT [2/2]

#define USBD_CDC_BULK_IN_EPT 0x83

Definition at line 54 of file cdc_msc_class.h.

◆ USBD_CDC_BULK_OUT_EPT [1/2]

#define USBD_CDC_BULK_OUT_EPT 0x01

Definition at line 55 of file cdc_class.h.

◆ USBD_CDC_BULK_OUT_EPT [2/2]

#define USBD_CDC_BULK_OUT_EPT 0x02

Definition at line 55 of file cdc_msc_class.h.

◆ USBD_CDC_CMD_MAXPACKET_SIZE [1/2]

#define USBD_CDC_CMD_MAXPACKET_SIZE 0x08

Definition at line 62 of file cdc_class.h.

◆ USBD_CDC_CMD_MAXPACKET_SIZE [2/2]

#define USBD_CDC_CMD_MAXPACKET_SIZE 0x08

Definition at line 66 of file cdc_msc_class.h.

◆ USBD_CDC_IN_MAXPACKET_SIZE

#define USBD_CDC_IN_MAXPACKET_SIZE 0x40

usb cdc in and out max packet size define

Definition at line 60 of file cdc_class.h.

◆ USBD_CDC_INT_EPT [1/2]

#define USBD_CDC_INT_EPT 0x82

usb cdc use endpoint define

Definition at line 53 of file cdc_class.h.

◆ USBD_CDC_INT_EPT [2/2]

#define USBD_CDC_INT_EPT 0x82

usb cdc use endpoint define

Definition at line 53 of file cdc_msc_class.h.

◆ USBD_CDC_MSC_IN_MAXPACKET_SIZE

#define USBD_CDC_MSC_IN_MAXPACKET_SIZE 0x40

usb cdc in and out max packet size define

Definition at line 63 of file cdc_msc_class.h.

◆ USBD_CDC_MSC_OUT_MAXPACKET_SIZE

#define USBD_CDC_MSC_OUT_MAXPACKET_SIZE 0x40

Definition at line 65 of file cdc_msc_class.h.

◆ USBD_CDC_OUT_MAXPACKET_SIZE

#define USBD_CDC_OUT_MAXPACKET_SIZE 0x40

Definition at line 61 of file cdc_class.h.

◆ USBD_MSC_BULK_IN_EPT

#define USBD_MSC_BULK_IN_EPT 0x81

Definition at line 57 of file cdc_msc_class.h.

◆ USBD_MSC_BULK_OUT_EPT

#define USBD_MSC_BULK_OUT_EPT 0x01

Definition at line 58 of file cdc_msc_class.h.


AT32F435/437 Firmwary Library: USB_cdc_class_exported_types

Modules | Data Structures
USB_cdc_class_exported_types
AT32F435_437_middlewares_usbd_class » USB_cdc_class | AT32F435_437_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F435_437_middlewares_usbd_class » USB_cdc_msc_class

Modules

USB_msc_bot_scsi_definition
USB_cdc_msc_class_exported_functions

Data Structures

struct | cdc_struct_type
usb cdc class struct More...
struct | vcp_keyboard_type

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: USB_msc_bot_scsi_definition

Data Structures | Macros | Functions
USB_msc_bot_scsi_definition
AT32F435_437_middlewares_usbd_class » USB_cdc_class | AT32F435_437_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F435_437_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types | AT32F435_437_middlewares_usbd_class » USB_msc_bot_scsi

Data Structures

struct | cbd_typical_type
typical command block description More...
struct | cbd_extended_type
extended command block description More...
struct | cbw_type
command block wrapper More...
struct | csw_type
command block wrapper More...
struct | sense_type
request sense standard data More...
struct | msc_type
struct | cdc_msc_struct_type
usb cdc class struct More...

Macros

#define | MSC_SUPPORT_MAX_LUN 1
#define | MSC_MAX_DATA_BUF_LEN 4096
#define | MSC_CMD_FORMAT_UNIT 0x04
#define | MSC_CMD_INQUIRY 0x12
#define | MSC_CMD_START_STOP 0x1B
#define | MSC_CMD_MODE_SENSE6 0x1A
#define | MSC_CMD_MODE_SENSE10 0x5A
#define | MSC_CMD_ALLOW_MEDIUM_REMOVAL 0x1E
#define | MSC_CMD_READ_10 0x28
#define | MSC_CMD_READ_12 0xA8
#define | MSC_CMD_READ_CAPACITY 0x25
#define | MSC_CMD_READ_FORMAT_CAPACITY 0x23
#define | MSC_CMD_REQUEST_SENSE 0x03
#define | MSC_CMD_TEST_UNIT 0x00
#define | MSC_CMD_VERIFY 0x2F
#define | MSC_CMD_WRITE_10 0x2A
#define | MSC_CMD_WRITE_12 0xAA
#define | MSC_CMD_WRITE_VERIFY 0x2E
#define | MSC_REQ_GET_MAX_LUN 0xFE
#define | MSC_REQ_BO_RESET 0xFF
#define | SET_LINE_CODING 0x20
#define | GET_LINE_CODING 0x21
#define | CBW_CMD_LENGTH 31
#define | CBW_DCBWSIGNATURE 0x43425355
#define | CBW_BMCBWFLAGS_DIR_OUT 0x00
#define | CBW_BMCBWFLAGS_DIR_IN 0x80
#define | CSW_CMD_LENGTH 13
#define | CSW_DCSWSIGNATURE 0x53425355
#define | CSW_BCSWSTATUS_PASS 0x00
#define | CSW_BCSWSTATUS_FAILED 0x01
#define | CSW_BCSWSTATUS_PHASE_ERR 0x02
#define | MSC_STATE_MACHINE_CMD 0x00
#define | MSC_STATE_MACHINE_DATA_IN 0x01
#define | MSC_STATE_MACHINE_DATA_OUT 0x02
#define | MSC_STATE_MACHINE_SEND_DATA 0x03
#define | MSC_STATE_MACHINE_LAST_DATA 0x04
#define | MSC_STATE_MACHINE_STATUS 0x05
#define | MSC_STATE_MACHINE_FAILED 0x06
#define | MSC_STATE_MACHINE_IDLE 0x07
#define | MSC_BOT_STATE_IDLE 0x00
#define | MSC_BOT_STATE_RECOVERY 0x01
#define | MSC_BOT_STATE_ERROR 0x02
#define | REQ_SENSE_STANDARD_DATA_LEN 0x12
#define | SENSE_KEY_NO_SENSE 0x00
#define | SENSE_KEY_RECOVERED_ERROR 0x01
#define | SENSE_KEY_NOT_READY 0x02
#define | SENSE_KEY_MEDIUM_ERROR 0x03
#define | SENSE_KEY_HARDWARE_ERROR 0x04
#define | SENSE_KEY_ILLEGAL_REQUEST 0x05
#define | SENSE_KEY_UNIT_ATTENTION 0x06
#define | SENSE_KEY_DATA_PROTECT 0x07
#define | SENSE_KEY_BLANK_CHECK 0x08
#define | SENSE_KEY_VENDERO_SPECIFIC 0x09
#define | SENSE_KEY_ABORTED_COMMAND 0x0B
#define | SENSE_KEY_VOLUME_OVERFLOW 0x0D
#define | SENSE_KEY_MISCOMPARE 0x0E
#define | INVALID_COMMAND 0x20
#define | INVALID_FIELED_IN_COMMAND 0x24
#define | PARAMETER_LIST_LENGTH_ERROR 0x1A
#define | INVALID_FIELD_IN_PARAMETER_LIST 0x26
#define | ADDRESS_OUT_OF_RANGE 0x21
#define | MEDIUM_NOT_PRESENT 0x3A
#define | MEDIUM_HAVE_CHANGED 0x28
#define | SCSI_INQUIRY_DATA_LENGTH 36
#define | MSC_SUPPORT_MAX_LUN 1
#define | MSC_MAX_DATA_BUF_LEN 4096
#define | MSC_CMD_FORMAT_UNIT 0x04
#define | MSC_CMD_INQUIRY 0x12
#define | MSC_CMD_START_STOP 0x1B
#define | MSC_CMD_MODE_SENSE6 0x1A
#define | MSC_CMD_MODE_SENSE10 0x5A
#define | MSC_CMD_ALLOW_MEDIUM_REMOVAL 0x1E
#define | MSC_CMD_READ_10 0x28
#define | MSC_CMD_READ_12 0xA8
#define | MSC_CMD_READ_CAPACITY 0x25
#define | MSC_CMD_READ_FORMAT_CAPACITY 0x23
#define | MSC_CMD_REQUEST_SENSE 0x03
#define | MSC_CMD_TEST_UNIT 0x00
#define | MSC_CMD_VERIFY 0x2F
#define | MSC_CMD_WRITE_10 0x2A
#define | MSC_CMD_WRITE_12 0xAA
#define | MSC_CMD_WRITE_VERIFY 0x2E
#define | MSC_REQ_GET_MAX_LUN 0xFE
#define | MSC_REQ_BO_RESET 0xFF
#define | SET_LINE_CODING 0x20
#define | GET_LINE_CODING 0x21
#define | CBW_CMD_LENGTH 31
#define | CBW_DCBWSIGNATURE 0x43425355
#define | CBW_BMCBWFLAGS_DIR_OUT 0x00
#define | CBW_BMCBWFLAGS_DIR_IN 0x80
#define | CSW_CMD_LENGTH 13
#define | CSW_DCSWSIGNATURE 0x53425355
#define | CSW_BCSWSTATUS_PASS 0x00
#define | CSW_BCSWSTATUS_FAILED 0x01
#define | CSW_BCSWSTATUS_PHASE_ERR 0x02
#define | MSC_STATE_MACHINE_CMD 0x00
#define | MSC_STATE_MACHINE_DATA_IN 0x01
#define | MSC_STATE_MACHINE_DATA_OUT 0x02
#define | MSC_STATE_MACHINE_SEND_DATA 0x03
#define | MSC_STATE_MACHINE_LAST_DATA 0x04
#define | MSC_STATE_MACHINE_STATUS 0x05
#define | MSC_STATE_MACHINE_FAILED 0x06
#define | MSC_STATE_MACHINE_IDLE 0x07
#define | MSC_BOT_STATE_IDLE 0x00
#define | MSC_BOT_STATE_RECOVERY 0x01
#define | MSC_BOT_STATE_ERROR 0x02
#define | REQ_SENSE_STANDARD_DATA_LEN 0x12
#define | SENSE_KEY_NO_SENSE 0x00
#define | SENSE_KEY_RECOVERED_ERROR 0x01
#define | SENSE_KEY_NOT_READY 0x02
#define | SENSE_KEY_MEDIUM_ERROR 0x03
#define | SENSE_KEY_HARDWARE_ERROR 0x04
#define | SENSE_KEY_ILLEGAL_REQUEST 0x05
#define | SENSE_KEY_UNIT_ATTENTION 0x06
#define | SENSE_KEY_DATA_PROTECT 0x07
#define | SENSE_KEY_BLANK_CHECK 0x08
#define | SENSE_KEY_VENDERO_SPECIFIC 0x09
#define | SENSE_KEY_ABORTED_COMMAND 0x0B
#define | SENSE_KEY_VOLUME_OVERFLOW 0x0D
#define | SENSE_KEY_MISCOMPARE 0x0E
#define | INVALID_COMMAND 0x20
#define | INVALID_FIELED_IN_COMMAND 0x24
#define | PARAMETER_LIST_LENGTH_ERROR 0x1A
#define | INVALID_FIELD_IN_PARAMETER_LIST 0x26
#define | ADDRESS_OUT_OF_RANGE 0x21
#define | MEDIUM_NOT_PRESENT 0x3A
#define | MEDIUM_HAVE_CHANGED 0x28
#define | SCSI_INQUIRY_DATA_LENGTH 36

Functions

void | bot_scsi_init (void *udev)
initialize bulk-only transport and scsi More...
void | bot_scsi_reset (void *udev)
reset bulk-only transport and scsi More...
void | bot_scsi_datain_handler (void *pudev, uint8_t ept_num)
bulk-only transport data in handler More...
void | bot_scsi_dataout_handler (void *pudev, uint8_t ept_num)
bulk-only transport data out handler More...
void | bot_cbw_decode (void *udev)
bulk-only cbw decode More...
void | bot_scsi_send_data (void *udev, uint8_t *buffer, uint32_t len)
send bot data More...
void | bot_scsi_send_csw (void *udev, uint8_t status)
send command status More...
void | bot_scsi_sense_code (void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code More...
usb_sts_type | bot_scsi_check_address (void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address More...
void | bot_scsi_stall (void *udev)
bot endpoint stall More...
usb_sts_type | bot_scsi_cmd_process (void *udev)
bulk-only transport scsi command process More...
usb_sts_type | bot_scsi_test_unit (void *udev, uint8_t lun)
bulk-only transport scsi command test unit More...
usb_sts_type | bot_scsi_inquiry (void *udev, uint8_t lun)
bulk-only transport scsi command inquiry More...
usb_sts_type | bot_scsi_start_stop (void *udev, uint8_t lun)
bulk-only transport scsi command start stop More...
usb_sts_type | bot_scsi_allow_medium_removal (void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal More...
usb_sts_type | bot_scsi_mode_sense6 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6 More...
usb_sts_type | bot_scsi_mode_sense10 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10 More...
usb_sts_type | bot_scsi_read10 (void *udev, uint8_t lun)
bulk-only transport scsi command read10 More...
usb_sts_type | bot_scsi_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command capacity More...
usb_sts_type | bot_scsi_format_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command format capacity More...
usb_sts_type | bot_scsi_request_sense (void *udev, uint8_t lun)
bulk-only transport scsi command request sense More...
usb_sts_type | bot_scsi_verify (void *udev, uint8_t lun)
bulk-only transport scsi command verify More...
usb_sts_type | bot_scsi_write10 (void *udev, uint8_t lun)
bulk-only transport scsi command write10 More...
void | bot_scsi_clear_feature (void *udev, uint8_t ept_num)
clear feature More...

Detailed Description

Macro Definition Documentation

◆ ADDRESS_OUT_OF_RANGE [1/2]

#define ADDRESS_OUT_OF_RANGE 0x21

Definition at line 153 of file cdc_msc_class.h.

◆ ADDRESS_OUT_OF_RANGE [2/2]

#define ADDRESS_OUT_OF_RANGE 0x21

Definition at line 119 of file msc_bot_scsi.h.

◆ CBW_BMCBWFLAGS_DIR_IN [1/2]

#define CBW_BMCBWFLAGS_DIR_IN 0x80

Definition at line 112 of file cdc_msc_class.h.

◆ CBW_BMCBWFLAGS_DIR_IN [2/2]

#define CBW_BMCBWFLAGS_DIR_IN 0x80

Definition at line 78 of file msc_bot_scsi.h.

◆ CBW_BMCBWFLAGS_DIR_OUT [1/2]

#define CBW_BMCBWFLAGS_DIR_OUT 0x00

Definition at line 111 of file cdc_msc_class.h.

◆ CBW_BMCBWFLAGS_DIR_OUT [2/2]

#define CBW_BMCBWFLAGS_DIR_OUT 0x00

Definition at line 77 of file msc_bot_scsi.h.

◆ CBW_CMD_LENGTH [1/2]

#define CBW_CMD_LENGTH 31

Definition at line 109 of file cdc_msc_class.h.

◆ CBW_CMD_LENGTH [2/2]

#define CBW_CMD_LENGTH 31

Definition at line 75 of file msc_bot_scsi.h.

◆ CBW_DCBWSIGNATURE [1/2]

#define CBW_DCBWSIGNATURE 0x43425355

Definition at line 110 of file cdc_msc_class.h.

◆ CBW_DCBWSIGNATURE [2/2]

#define CBW_DCBWSIGNATURE 0x43425355

Definition at line 76 of file msc_bot_scsi.h.

◆ CSW_BCSWSTATUS_FAILED [1/2]

#define CSW_BCSWSTATUS_FAILED 0x01

Definition at line 117 of file cdc_msc_class.h.

◆ CSW_BCSWSTATUS_FAILED [2/2]

#define CSW_BCSWSTATUS_FAILED 0x01

Definition at line 83 of file msc_bot_scsi.h.

◆ CSW_BCSWSTATUS_PASS [1/2]

#define CSW_BCSWSTATUS_PASS 0x00

Definition at line 116 of file cdc_msc_class.h.

◆ CSW_BCSWSTATUS_PASS [2/2]

#define CSW_BCSWSTATUS_PASS 0x00

Definition at line 82 of file msc_bot_scsi.h.

◆ CSW_BCSWSTATUS_PHASE_ERR [1/2]

#define CSW_BCSWSTATUS_PHASE_ERR 0x02

Definition at line 118 of file cdc_msc_class.h.

◆ CSW_BCSWSTATUS_PHASE_ERR [2/2]

#define CSW_BCSWSTATUS_PHASE_ERR 0x02

Definition at line 84 of file msc_bot_scsi.h.

◆ CSW_CMD_LENGTH [1/2]

#define CSW_CMD_LENGTH 13

Definition at line 114 of file cdc_msc_class.h.

◆ CSW_CMD_LENGTH [2/2]

#define CSW_CMD_LENGTH 13

Definition at line 80 of file msc_bot_scsi.h.

◆ CSW_DCSWSIGNATURE [1/2]

#define CSW_DCSWSIGNATURE 0x53425355

Definition at line 115 of file cdc_msc_class.h.

◆ CSW_DCSWSIGNATURE [2/2]

#define CSW_DCSWSIGNATURE 0x53425355

Definition at line 81 of file msc_bot_scsi.h.

◆ GET_LINE_CODING [1/2]

#define GET_LINE_CODING 0x21

Definition at line 107 of file cdc_msc_class.h.

◆ GET_LINE_CODING [2/2]

#define GET_LINE_CODING 0x21

Definition at line 73 of file msc_bot_scsi.h.

◆ INVALID_COMMAND [1/2]

#define INVALID_COMMAND 0x20

Definition at line 149 of file cdc_msc_class.h.

◆ INVALID_COMMAND [2/2]

#define INVALID_COMMAND 0x20

Definition at line 115 of file msc_bot_scsi.h.

◆ INVALID_FIELD_IN_PARAMETER_LIST [1/2]

#define INVALID_FIELD_IN_PARAMETER_LIST 0x26

Definition at line 152 of file cdc_msc_class.h.

◆ INVALID_FIELD_IN_PARAMETER_LIST [2/2]

#define INVALID_FIELD_IN_PARAMETER_LIST 0x26

Definition at line 118 of file msc_bot_scsi.h.

◆ INVALID_FIELED_IN_COMMAND [1/2]

#define INVALID_FIELED_IN_COMMAND 0x24

Definition at line 150 of file cdc_msc_class.h.

◆ INVALID_FIELED_IN_COMMAND [2/2]

#define INVALID_FIELED_IN_COMMAND 0x24

Definition at line 116 of file msc_bot_scsi.h.

◆ MEDIUM_HAVE_CHANGED [1/2]

#define MEDIUM_HAVE_CHANGED 0x28

Definition at line 155 of file cdc_msc_class.h.

◆ MEDIUM_HAVE_CHANGED [2/2]

#define MEDIUM_HAVE_CHANGED 0x28

Definition at line 121 of file msc_bot_scsi.h.

◆ MEDIUM_NOT_PRESENT [1/2]

#define MEDIUM_NOT_PRESENT 0x3A

Definition at line 154 of file cdc_msc_class.h.

◆ MEDIUM_NOT_PRESENT [2/2]

#define MEDIUM_NOT_PRESENT 0x3A

Definition at line 120 of file msc_bot_scsi.h.

◆ MSC_BOT_STATE_ERROR [1/2]

#define MSC_BOT_STATE_ERROR 0x02

Definition at line 131 of file cdc_msc_class.h.

◆ MSC_BOT_STATE_ERROR [2/2]

#define MSC_BOT_STATE_ERROR 0x02

Definition at line 97 of file msc_bot_scsi.h.

◆ MSC_BOT_STATE_IDLE [1/2]

#define MSC_BOT_STATE_IDLE 0x00

Definition at line 129 of file cdc_msc_class.h.

◆ MSC_BOT_STATE_IDLE [2/2]

#define MSC_BOT_STATE_IDLE 0x00

Definition at line 95 of file msc_bot_scsi.h.

◆ MSC_BOT_STATE_RECOVERY [1/2]

#define MSC_BOT_STATE_RECOVERY 0x01

Definition at line 130 of file cdc_msc_class.h.

◆ MSC_BOT_STATE_RECOVERY [2/2]

#define MSC_BOT_STATE_RECOVERY 0x01

Definition at line 96 of file msc_bot_scsi.h.

◆ MSC_CMD_ALLOW_MEDIUM_REMOVAL [1/2]

#define MSC_CMD_ALLOW_MEDIUM_REMOVAL 0x1E

Definition at line 91 of file cdc_msc_class.h.

◆ MSC_CMD_ALLOW_MEDIUM_REMOVAL [2/2]

#define MSC_CMD_ALLOW_MEDIUM_REMOVAL 0x1E

Definition at line 57 of file msc_bot_scsi.h.

◆ MSC_CMD_FORMAT_UNIT [1/2]

#define MSC_CMD_FORMAT_UNIT 0x04

Definition at line 86 of file cdc_msc_class.h.

◆ MSC_CMD_FORMAT_UNIT [2/2]

#define MSC_CMD_FORMAT_UNIT 0x04

Definition at line 52 of file msc_bot_scsi.h.

◆ MSC_CMD_INQUIRY [1/2]

#define MSC_CMD_INQUIRY 0x12

Definition at line 87 of file cdc_msc_class.h.

◆ MSC_CMD_INQUIRY [2/2]

#define MSC_CMD_INQUIRY 0x12

Definition at line 53 of file msc_bot_scsi.h.

◆ MSC_CMD_MODE_SENSE10 [1/2]

#define MSC_CMD_MODE_SENSE10 0x5A

Definition at line 90 of file cdc_msc_class.h.

◆ MSC_CMD_MODE_SENSE10 [2/2]

#define MSC_CMD_MODE_SENSE10 0x5A

Definition at line 56 of file msc_bot_scsi.h.

◆ MSC_CMD_MODE_SENSE6 [1/2]

#define MSC_CMD_MODE_SENSE6 0x1A

Definition at line 89 of file cdc_msc_class.h.

◆ MSC_CMD_MODE_SENSE6 [2/2]

#define MSC_CMD_MODE_SENSE6 0x1A

Definition at line 55 of file msc_bot_scsi.h.

◆ MSC_CMD_READ_10 [1/2]

#define MSC_CMD_READ_10 0x28

Definition at line 92 of file cdc_msc_class.h.

◆ MSC_CMD_READ_10 [2/2]

#define MSC_CMD_READ_10 0x28

Definition at line 58 of file msc_bot_scsi.h.

◆ MSC_CMD_READ_12 [1/2]

#define MSC_CMD_READ_12 0xA8

Definition at line 93 of file cdc_msc_class.h.

◆ MSC_CMD_READ_12 [2/2]

#define MSC_CMD_READ_12 0xA8

Definition at line 59 of file msc_bot_scsi.h.

◆ MSC_CMD_READ_CAPACITY [1/2]

#define MSC_CMD_READ_CAPACITY 0x25

Definition at line 94 of file cdc_msc_class.h.

◆ MSC_CMD_READ_CAPACITY [2/2]

#define MSC_CMD_READ_CAPACITY 0x25

Definition at line 60 of file msc_bot_scsi.h.

◆ MSC_CMD_READ_FORMAT_CAPACITY [1/2]

#define MSC_CMD_READ_FORMAT_CAPACITY 0x23

Definition at line 95 of file cdc_msc_class.h.

◆ MSC_CMD_READ_FORMAT_CAPACITY [2/2]

#define MSC_CMD_READ_FORMAT_CAPACITY 0x23

Definition at line 61 of file msc_bot_scsi.h.

◆ MSC_CMD_REQUEST_SENSE [1/2]

#define MSC_CMD_REQUEST_SENSE 0x03

Definition at line 96 of file cdc_msc_class.h.

◆ MSC_CMD_REQUEST_SENSE [2/2]

#define MSC_CMD_REQUEST_SENSE 0x03

Definition at line 62 of file msc_bot_scsi.h.

◆ MSC_CMD_START_STOP [1/2]

#define MSC_CMD_START_STOP 0x1B

Definition at line 88 of file cdc_msc_class.h.

◆ MSC_CMD_START_STOP [2/2]

#define MSC_CMD_START_STOP 0x1B

Definition at line 54 of file msc_bot_scsi.h.

◆ MSC_CMD_TEST_UNIT [1/2]

#define MSC_CMD_TEST_UNIT 0x00

Definition at line 97 of file cdc_msc_class.h.

◆ MSC_CMD_TEST_UNIT [2/2]

#define MSC_CMD_TEST_UNIT 0x00

Definition at line 63 of file msc_bot_scsi.h.

◆ MSC_CMD_VERIFY [1/2]

#define MSC_CMD_VERIFY 0x2F

Definition at line 98 of file cdc_msc_class.h.

◆ MSC_CMD_VERIFY [2/2]

#define MSC_CMD_VERIFY 0x2F

Definition at line 64 of file msc_bot_scsi.h.

◆ MSC_CMD_WRITE_10 [1/2]

#define MSC_CMD_WRITE_10 0x2A

Definition at line 99 of file cdc_msc_class.h.

◆ MSC_CMD_WRITE_10 [2/2]

#define MSC_CMD_WRITE_10 0x2A

Definition at line 65 of file msc_bot_scsi.h.

◆ MSC_CMD_WRITE_12 [1/2]

#define MSC_CMD_WRITE_12 0xAA

Definition at line 100 of file cdc_msc_class.h.

◆ MSC_CMD_WRITE_12 [2/2]

#define MSC_CMD_WRITE_12 0xAA

Definition at line 66 of file msc_bot_scsi.h.

◆ MSC_CMD_WRITE_VERIFY [1/2]

#define MSC_CMD_WRITE_VERIFY 0x2E

Definition at line 101 of file cdc_msc_class.h.

◆ MSC_CMD_WRITE_VERIFY [2/2]

#define MSC_CMD_WRITE_VERIFY 0x2E

Definition at line 67 of file msc_bot_scsi.h.

◆ MSC_MAX_DATA_BUF_LEN [1/2]

#define MSC_MAX_DATA_BUF_LEN 4096

Definition at line 84 of file cdc_msc_class.h.

◆ MSC_MAX_DATA_BUF_LEN [2/2]

#define MSC_MAX_DATA_BUF_LEN 4096

Definition at line 50 of file msc_bot_scsi.h.

◆ MSC_REQ_BO_RESET [1/2]

#define MSC_REQ_BO_RESET 0xFF

bulk only mass storage reset

Definition at line 104 of file cdc_msc_class.h.

◆ MSC_REQ_BO_RESET [2/2]

#define MSC_REQ_BO_RESET 0xFF

bulk only mass storage reset

Definition at line 70 of file msc_bot_scsi.h.

◆ MSC_REQ_GET_MAX_LUN [1/2]

#define MSC_REQ_GET_MAX_LUN 0xFE

get max lun

Definition at line 103 of file cdc_msc_class.h.

◆ MSC_REQ_GET_MAX_LUN [2/2]

#define MSC_REQ_GET_MAX_LUN 0xFE

get max lun

Definition at line 69 of file msc_bot_scsi.h.

◆ MSC_STATE_MACHINE_CMD [1/2]

#define MSC_STATE_MACHINE_CMD 0x00

Definition at line 120 of file cdc_msc_class.h.

◆ MSC_STATE_MACHINE_CMD [2/2]

#define MSC_STATE_MACHINE_CMD 0x00

Definition at line 86 of file msc_bot_scsi.h.

◆ MSC_STATE_MACHINE_DATA_IN [1/2]

#define MSC_STATE_MACHINE_DATA_IN 0x01

Definition at line 121 of file cdc_msc_class.h.

◆ MSC_STATE_MACHINE_DATA_IN [2/2]

#define MSC_STATE_MACHINE_DATA_IN 0x01

Definition at line 87 of file msc_bot_scsi.h.

◆ MSC_STATE_MACHINE_DATA_OUT [1/2]

#define MSC_STATE_MACHINE_DATA_OUT 0x02

Definition at line 122 of file cdc_msc_class.h.

◆ MSC_STATE_MACHINE_DATA_OUT [2/2]

#define MSC_STATE_MACHINE_DATA_OUT 0x02

Definition at line 88 of file msc_bot_scsi.h.

◆ MSC_STATE_MACHINE_FAILED [1/2]

#define MSC_STATE_MACHINE_FAILED 0x06

Definition at line 126 of file cdc_msc_class.h.

◆ MSC_STATE_MACHINE_FAILED [2/2]

#define MSC_STATE_MACHINE_FAILED 0x06

Definition at line 92 of file msc_bot_scsi.h.

◆ MSC_STATE_MACHINE_IDLE [1/2]

#define MSC_STATE_MACHINE_IDLE 0x07

Definition at line 127 of file cdc_msc_class.h.

◆ MSC_STATE_MACHINE_IDLE [2/2]

#define MSC_STATE_MACHINE_IDLE 0x07

Definition at line 93 of file msc_bot_scsi.h.

◆ MSC_STATE_MACHINE_LAST_DATA [1/2]

#define MSC_STATE_MACHINE_LAST_DATA 0x04

Definition at line 124 of file cdc_msc_class.h.

◆ MSC_STATE_MACHINE_LAST_DATA [2/2]

#define MSC_STATE_MACHINE_LAST_DATA 0x04

Definition at line 90 of file msc_bot_scsi.h.

◆ MSC_STATE_MACHINE_SEND_DATA [1/2]

#define MSC_STATE_MACHINE_SEND_DATA 0x03

Definition at line 123 of file cdc_msc_class.h.

◆ MSC_STATE_MACHINE_SEND_DATA [2/2]

#define MSC_STATE_MACHINE_SEND_DATA 0x03

Definition at line 89 of file msc_bot_scsi.h.

◆ MSC_STATE_MACHINE_STATUS [1/2]

#define MSC_STATE_MACHINE_STATUS 0x05

Definition at line 125 of file cdc_msc_class.h.

◆ MSC_STATE_MACHINE_STATUS [2/2]

#define MSC_STATE_MACHINE_STATUS 0x05

Definition at line 91 of file msc_bot_scsi.h.

◆ MSC_SUPPORT_MAX_LUN [1/2]

#define MSC_SUPPORT_MAX_LUN 1

Definition at line 83 of file cdc_msc_class.h.

◆ MSC_SUPPORT_MAX_LUN [2/2]

#define MSC_SUPPORT_MAX_LUN 1

Definition at line 49 of file msc_bot_scsi.h.

◆ PARAMETER_LIST_LENGTH_ERROR [1/2]

#define PARAMETER_LIST_LENGTH_ERROR 0x1A

Definition at line 151 of file cdc_msc_class.h.

◆ PARAMETER_LIST_LENGTH_ERROR [2/2]

#define PARAMETER_LIST_LENGTH_ERROR 0x1A

Definition at line 117 of file msc_bot_scsi.h.

◆ REQ_SENSE_STANDARD_DATA_LEN [1/2]

#define REQ_SENSE_STANDARD_DATA_LEN 0x12

Definition at line 133 of file cdc_msc_class.h.

◆ REQ_SENSE_STANDARD_DATA_LEN [2/2]

#define REQ_SENSE_STANDARD_DATA_LEN 0x12

Definition at line 99 of file msc_bot_scsi.h.

◆ SCSI_INQUIRY_DATA_LENGTH [1/2]

#define SCSI_INQUIRY_DATA_LENGTH 36

Definition at line 157 of file cdc_msc_class.h.

◆ SCSI_INQUIRY_DATA_LENGTH [2/2]

#define SCSI_INQUIRY_DATA_LENGTH 36

Definition at line 123 of file msc_bot_scsi.h.

◆ SENSE_KEY_ABORTED_COMMAND [1/2]

#define SENSE_KEY_ABORTED_COMMAND 0x0B

Definition at line 144 of file cdc_msc_class.h.

◆ SENSE_KEY_ABORTED_COMMAND [2/2]

#define SENSE_KEY_ABORTED_COMMAND 0x0B

Definition at line 110 of file msc_bot_scsi.h.

◆ SENSE_KEY_BLANK_CHECK [1/2]

#define SENSE_KEY_BLANK_CHECK 0x08

Definition at line 142 of file cdc_msc_class.h.

◆ SENSE_KEY_BLANK_CHECK [2/2]

#define SENSE_KEY_BLANK_CHECK 0x08

Definition at line 108 of file msc_bot_scsi.h.

◆ SENSE_KEY_DATA_PROTECT [1/2]

#define SENSE_KEY_DATA_PROTECT 0x07

Definition at line 141 of file cdc_msc_class.h.

◆ SENSE_KEY_DATA_PROTECT [2/2]

#define SENSE_KEY_DATA_PROTECT 0x07

Definition at line 107 of file msc_bot_scsi.h.

◆ SENSE_KEY_HARDWARE_ERROR [1/2]

#define SENSE_KEY_HARDWARE_ERROR 0x04

Definition at line 138 of file cdc_msc_class.h.

◆ SENSE_KEY_HARDWARE_ERROR [2/2]

#define SENSE_KEY_HARDWARE_ERROR 0x04

Definition at line 104 of file msc_bot_scsi.h.

◆ SENSE_KEY_ILLEGAL_REQUEST [1/2]

#define SENSE_KEY_ILLEGAL_REQUEST 0x05

Definition at line 139 of file cdc_msc_class.h.

◆ SENSE_KEY_ILLEGAL_REQUEST [2/2]

#define SENSE_KEY_ILLEGAL_REQUEST 0x05

Definition at line 105 of file msc_bot_scsi.h.

◆ SENSE_KEY_MEDIUM_ERROR [1/2]

#define SENSE_KEY_MEDIUM_ERROR 0x03

Definition at line 137 of file cdc_msc_class.h.

◆ SENSE_KEY_MEDIUM_ERROR [2/2]

#define SENSE_KEY_MEDIUM_ERROR 0x03

Definition at line 103 of file msc_bot_scsi.h.

◆ SENSE_KEY_MISCOMPARE [1/2]

#define SENSE_KEY_MISCOMPARE 0x0E

Definition at line 146 of file cdc_msc_class.h.

◆ SENSE_KEY_MISCOMPARE [2/2]

#define SENSE_KEY_MISCOMPARE 0x0E

Definition at line 112 of file msc_bot_scsi.h.

◆ SENSE_KEY_NO_SENSE [1/2]

#define SENSE_KEY_NO_SENSE 0x00

Definition at line 134 of file cdc_msc_class.h.

◆ SENSE_KEY_NO_SENSE [2/2]

#define SENSE_KEY_NO_SENSE 0x00

Definition at line 100 of file msc_bot_scsi.h.

◆ SENSE_KEY_NOT_READY [1/2]

#define SENSE_KEY_NOT_READY 0x02

Definition at line 136 of file cdc_msc_class.h.

◆ SENSE_KEY_NOT_READY [2/2]

#define SENSE_KEY_NOT_READY 0x02

Definition at line 102 of file msc_bot_scsi.h.

◆ SENSE_KEY_RECOVERED_ERROR [1/2]

#define SENSE_KEY_RECOVERED_ERROR 0x01

Definition at line 135 of file cdc_msc_class.h.

◆ SENSE_KEY_RECOVERED_ERROR [2/2]

#define SENSE_KEY_RECOVERED_ERROR 0x01

Definition at line 101 of file msc_bot_scsi.h.

◆ SENSE_KEY_UNIT_ATTENTION [1/2]

#define SENSE_KEY_UNIT_ATTENTION 0x06

Definition at line 140 of file cdc_msc_class.h.

◆ SENSE_KEY_UNIT_ATTENTION [2/2]

#define SENSE_KEY_UNIT_ATTENTION 0x06

Definition at line 106 of file msc_bot_scsi.h.

◆ SENSE_KEY_VENDERO_SPECIFIC [1/2]

#define SENSE_KEY_VENDERO_SPECIFIC 0x09

Definition at line 143 of file cdc_msc_class.h.

◆ SENSE_KEY_VENDERO_SPECIFIC [2/2]

#define SENSE_KEY_VENDERO_SPECIFIC 0x09

Definition at line 109 of file msc_bot_scsi.h.

◆ SENSE_KEY_VOLUME_OVERFLOW [1/2]

#define SENSE_KEY_VOLUME_OVERFLOW 0x0D

Definition at line 145 of file cdc_msc_class.h.

◆ SENSE_KEY_VOLUME_OVERFLOW [2/2]

#define SENSE_KEY_VOLUME_OVERFLOW 0x0D

Definition at line 111 of file msc_bot_scsi.h.

◆ SET_LINE_CODING [1/2]

#define SET_LINE_CODING 0x20

Definition at line 106 of file cdc_msc_class.h.

◆ SET_LINE_CODING [2/2]

#define SET_LINE_CODING 0x20

Definition at line 72 of file msc_bot_scsi.h.

Function Documentation

◆ bot_cbw_decode()

void bot_cbw_decode ( void * udev )

bulk-only cbw decode

Parameters
udev to the structure of usbd_core_type
Return values
none
Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 200 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_dataout_handler().

◆ bot_scsi_allow_medium_removal()

usb_sts_type bot_scsi_allow_medium_removal | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command meidum removal

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 427 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_capacity()

usb_sts_type bot_scsi_capacity | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command capacity

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 481 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_check_address()

usb_sts_type bot_scsi_check_address | ( | void * | udev,
 |  | uint8_t | lun,
 |  | uint32_t | blk_offset,
 |  | uint32_t | blk_count
 | ) |  |

check address

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
blk_offset | blk offset address
blk_count | blk number
Return values
usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
blk_offset | blk offset address
blk_count | blk number
Return values
usb_sts_type

Definition at line 307 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_read10(), bot_scsi_verify(), and bot_scsi_write10().

◆ bot_scsi_clear_feature()

void bot_scsi_clear_feature | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |

clear feature

Parameters
udev | to the structure of usbd_core_type
etp_num | endpoint number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
etp_num | endpoint number
Return values
status of usb_sts_type

Definition at line 733 of file composite_cdc_msc/msc_bot_scsi.c.

◆ bot_scsi_cmd_process()

usb_sts_type bot_scsi_cmd_process ( void * udev )

bulk-only transport scsi command process

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type
Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 753 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode(), bot_scsi_datain_handler(), and bot_scsi_dataout_handler().

◆ bot_scsi_datain_handler()

void bot_scsi_datain_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |

bulk-only transport data in handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none
Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none

Definition at line 147 of file composite_cdc_msc/msc_bot_scsi.c.

◆ bot_scsi_dataout_handler()

void bot_scsi_dataout_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |

bulk-only transport data out handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none
Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none

Definition at line 176 of file composite_cdc_msc/msc_bot_scsi.c.

◆ bot_scsi_format_capacity()

usb_sts_type bot_scsi_format_capacity | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command format capacity

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 508 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_init()

void bot_scsi_init ( void * udev )

initialize bulk-only transport and scsi

Parameters
udev to the structure of usbd_core_type
Return values
none
Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 104 of file composite_cdc_msc/msc_bot_scsi.c.

◆ bot_scsi_inquiry()

usb_sts_type bot_scsi_inquiry | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command inquiry

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 372 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_mode_sense10()

usb_sts_type bot_scsi_mode_sense10 | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command mode sense10

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 461 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_mode_sense6()

usb_sts_type bot_scsi_mode_sense6 | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command mode sense6

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 441 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_read10()

usb_sts_type bot_scsi_read10 | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command read10

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 602 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_request_sense()

usb_sts_type bot_scsi_request_sense | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command request sense

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 543 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_reset()

void bot_scsi_reset ( void * udev )

reset bulk-only transport and scsi

Parameters
udev to the structure of usbd_core_type
Return values
none
Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 128 of file composite_cdc_msc/msc_bot_scsi.c.

◆ bot_scsi_send_csw()

void bot_scsi_send_csw | ( | void * | udev,
 |  | uint8_t | status
 | ) |  |

send command status

Parameters
udev | to the structure of usbd_core_type
status | csw status
Return values
none
Parameters
udev | to the structure of usbd_core_type
status | csw status
Return values
none

Definition at line 268 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode(), bot_scsi_clear_feature(), bot_scsi_datain_handler(), bot_scsi_dataout_handler(), and bot_scsi_write10().

◆ bot_scsi_send_data()

void bot_scsi_send_data | ( | void * | udev,
 |  | uint8_t * | buffer,
 |  | uint32_t | len
 | ) |  |

send bot data

Parameters
udev | to the structure of usbd_core_type
buffer | data buffer
len | data len
Return values
none
Parameters
udev | to the structure of usbd_core_type
buffer | data buffer
len | data len
Return values
none

Definition at line 247 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode().

◆ bot_scsi_sense_code()

void bot_scsi_sense_code | ( | void * | udev,
 |  | uint8_t | sense_key,
 |  | uint8_t | asc
 | ) |  |

send scsi sense code

Parameters
udev | to the structure of usbd_core_type
sense_key | sense key
asc | asc
Return values
none
Parameters
udev | to the structure of usbd_core_type
sense_key | sense key
asc | asc
Return values
none

Definition at line 292 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode(), bot_scsi_check_address(), bot_scsi_cmd_process(), bot_scsi_read10(), bot_scsi_test_unit(), bot_scsi_verify(), and bot_scsi_write10().

◆ bot_scsi_stall()

void bot_scsi_stall ( void * udev )

bot endpoint stall

Parameters
udev to the structure of usbd_core_type
Return values
none
Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 324 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode().

◆ bot_scsi_start_stop()

usb_sts_type bot_scsi_start_stop | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command start stop

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 413 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_test_unit()

usb_sts_type bot_scsi_test_unit | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command test unit

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 350 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_verify()

usb_sts_type bot_scsi_verify | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command verify

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 574 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_write10()

usb_sts_type bot_scsi_write10 | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command write10

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 663 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().


AT32F435/437 Firmwary Library: cbd_typical_type Struct Reference

Data Fields
cbd_typical_type Struct Reference
AT32F435_437_middlewares_usbd_class » USB_cdc_class | AT32F435_437_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F435_437_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types | AT32F435_437_middlewares_usbd_class » USB_msc_bot_scsi » USB_msc_bot_scsi_definition

typical command block description More...

#include <cdc_msc_class.h>

Data Fields

uint8_t | opcode
uint8_t | lun
uint32_t | address
uint8_t | reserved1
uint32_t | alloc_length
uint16_t | reserved2

Detailed Description

typical command block description

Definition at line 162 of file cdc_msc_class.h.

The documentation for this struct was generated from the following files:
  • cdc_msc_class.h
  • msc_bot_scsi.h


AT32F435/437 Firmwary Library: cbd_extended_type Struct Reference

Data Fields
cbd_extended_type Struct Reference
AT32F435_437_middlewares_usbd_class » USB_cdc_class | AT32F435_437_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F435_437_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types | AT32F435_437_middlewares_usbd_class » USB_msc_bot_scsi » USB_msc_bot_scsi_definition

extended command block description More...

#include <cdc_msc_class.h>

Data Fields

uint8_t | opcode
uint8_t | lun
uint32_t | address
uint8_t | reserved1
uint32_t | alloc_length
uint16_t | reserved2

Detailed Description

extended command block description

Definition at line 175 of file cdc_msc_class.h.

The documentation for this struct was generated from the following files:
  • cdc_msc_class.h
  • msc_bot_scsi.h


AT32F435/437 Firmwary Library: cbw_type Struct Reference

Data Fields
cbw_type Struct Reference
AT32F435_437_middlewares_usbd_class » USB_cdc_class | AT32F435_437_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F435_437_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types | AT32F435_437_middlewares_usbd_class » USB_msc_bot_scsi » USB_msc_bot_scsi_definition

command block wrapper More...

#include <cdc_msc_class.h>

Data Fields

uint32_t | dCBWSignature
uint32_t | dCBWTage
uint32_t | dCBWDataTransferLength
uint8_t | bmCBWFlags
uint8_t | bCBWLUN
uint8_t | bCBWCBLength
uint8_t | CBWCB [16]

Detailed Description

command block wrapper

Definition at line 188 of file cdc_msc_class.h.

The documentation for this struct was generated from the following files:
  • cdc_msc_class.h
  • msc_bot_scsi.h


AT32F435/437 Firmwary Library: csw_type Struct Reference

Data Fields
csw_type Struct Reference
AT32F435_437_middlewares_usbd_class » USB_cdc_class | AT32F435_437_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F435_437_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types | AT32F435_437_middlewares_usbd_class » USB_msc_bot_scsi » USB_msc_bot_scsi_definition

command block wrapper More...

#include <cdc_msc_class.h>

Data Fields

uint32_t | dCSWSignature
uint32_t | dCSWTag
uint32_t | dCSWDataResidue
uint32_t | bCSWStatus

Detailed Description

command block wrapper

Definition at line 202 of file cdc_msc_class.h.

The documentation for this struct was generated from the following files:
  • cdc_msc_class.h
  • msc_bot_scsi.h


AT32F435/437 Firmwary Library: sense_type Struct Reference

Data Fields
sense_type Struct Reference
AT32F435_437_middlewares_usbd_class » USB_cdc_class | AT32F435_437_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F435_437_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types | AT32F435_437_middlewares_usbd_class » USB_msc_bot_scsi » USB_msc_bot_scsi_definition

request sense standard data More...

#include <cdc_msc_class.h>

Data Fields

uint8_t | err_code
uint8_t | reserved1
uint8_t | sense_key
uint32_t | information
uint8_t | as_length
uint32_t | reserved2
uint8_t | asc
uint8_t | ascq
uint32_t | reserved3

Detailed Description

request sense standard data

Definition at line 213 of file cdc_msc_class.h.

The documentation for this struct was generated from the following files:
  • cdc_msc_class.h
  • msc_bot_scsi.h


AT32F435/437 Firmwary Library: msc_type Struct Reference

Data Fields
msc_type Struct Reference
AT32F435_437_middlewares_usbd_class » USB_cdc_class | AT32F435_437_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F435_437_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types | AT32F435_437_middlewares_usbd_class » USB_msc_bot_scsi » USB_msc_bot_scsi_definition

#include <cdc_msc_class.h>

Data Fields

uint8_t | msc_state
uint8_t | bot_status
uint32_t | max_lun
uint32_t | blk_nbr [1]
uint32_t | blk_size [1]
uint32_t | blk_addr
uint32_t | blk_len
uint32_t | data_len
uint8_t | data [4096]
uint32_t | alt_setting
cbw_type cbw_struct
csw_type csw_struct

Detailed Description

Definition at line 227 of file cdc_msc_class.h.

The documentation for this struct was generated from the following files:
  • cdc_msc_class.h
  • msc_bot_scsi.h


AT32F435/437 Firmwary Library: cdc_msc_struct_type Struct Reference

Data Fields
cdc_msc_struct_type Struct Reference
AT32F435_437_middlewares_usbd_class » USB_cdc_class | AT32F435_437_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F435_437_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types | AT32F435_437_middlewares_usbd_class » USB_msc_bot_scsi » USB_msc_bot_scsi_definition

usb cdc class struct More...

#include <cdc_msc_class.h>

Data Fields

uint32_t | alt_setting
uint8_t | g_rx_buff [0x40]
uint8_t | g_cmd [0x08]
uint8_t | g_req
uint16_t | g_len
uint16_t | g_rxlen
__IO uint8_t | g_tx_completed
__IO uint8_t | g_rx_completed
linecoding_type linecoding
uint8_t | msc_state
uint8_t | bot_status
uint32_t | max_lun
uint32_t | blk_nbr [1]
uint32_t | blk_size [1]
uint32_t | blk_addr
uint32_t | blk_len
uint32_t | data_len
uint8_t | data [4096]
cbw_type cbw_struct
csw_type csw_struct

Detailed Description

usb cdc class struct

Definition at line 252 of file cdc_msc_class.h.

The documentation for this struct was generated from the following file:
  • cdc_msc_class.h


AT32F435/437 Firmwary Library: USB_cdc_msc_class_exported_functions

Functions | Variables
USB_cdc_msc_class_exported_functions
AT32F435_437_middlewares_usbd_class » USB_cdc_class | AT32F435_437_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F435_437_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types

Functions

uint16_t | usb_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

usbd_class_handler cdc_msc_class_handler

Detailed Description

Function Documentation

◆ usb_vcp_get_rxdata()

uint16_t usb_vcp_get_rxdata | ( | void * | udev,
 |  | uint8_t * | recv_data
 | ) |  |

usb device class rx data process

Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len
Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len

Definition at line 339 of file cdc_class.c.

Referenced by main().

◆ usb_vcp_send_data()

error_status usb_vcp_send_data | ( | void * | udev,
 |  | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

usb device class send data

Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status
Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status

Definition at line 369 of file cdc_class.c.

Referenced by main().

Variable Documentation

◆ cdc_msc_class_handler

usbd_class_handler cdc_msc_class_handler
extern

Definition at line 72 of file cdc_msc_class.c.

Referenced by main().


AT32F435/437 Firmwary Library: cdc_struct_type Struct Reference

Data Fields
cdc_struct_type Struct Reference
AT32F435_437_middlewares_usbd_class » USB_cdc_class | AT32F435_437_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F435_437_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types

usb cdc class struct More...

#include <cdc_class.h>

Data Fields

uint32_t | alt_setting
uint8_t | g_rx_buff [0x40]
uint8_t | g_cmd [0x08]
uint8_t | g_req
uint16_t | g_len
uint16_t | g_rxlen
__IO uint8_t | g_tx_completed
__IO uint8_t | g_rx_completed
linecoding_type linecoding

Detailed Description

usb cdc class struct

Definition at line 75 of file cdc_class.h.

Field Documentation

◆ alt_setting

uint32_t cdc_struct_type::alt_setting

Definition at line 77 of file cdc_class.h.

Referenced by cdc_struct_init(), and class_setup_handler().

◆ g_cmd

uint8_t cdc_struct_type::g_cmd[0x08]

Definition at line 79 of file cdc_class.h.

Referenced by class_ept0_rx_handler(), and class_setup_handler().

◆ g_len

uint16_t cdc_struct_type::g_len

Definition at line 81 of file cdc_class.h.

Referenced by class_setup_handler().

◆ g_req

uint8_t cdc_struct_type::g_req

Definition at line 80 of file cdc_class.h.

Referenced by class_ept0_rx_handler(), and class_setup_handler().

◆ g_rx_buff

uint8_t cdc_struct_type::g_rx_buff[0x40]

Definition at line 78 of file cdc_class.h.

Referenced by class_init_handler(), and usb_vcp_get_rxdata().

◆ g_rx_completed

__IO uint8_t cdc_struct_type::g_rx_completed

Definition at line 82 of file cdc_class.h.

Referenced by cdc_struct_init(), class_out_handler(), and usb_vcp_get_rxdata().

◆ g_rxlen

uint16_t cdc_struct_type::g_rxlen

Definition at line 81 of file cdc_class.h.

Referenced by class_out_handler(), and usb_vcp_get_rxdata().

◆ g_tx_completed

__IO uint8_t cdc_struct_type::g_tx_completed

Definition at line 82 of file cdc_class.h.

Referenced by cdc_struct_init(), class_in_handler(), and usb_vcp_send_data().

◆ linecoding

linecoding_type cdc_struct_type::linecoding

Definition at line 83 of file cdc_class.h.

Referenced by cdc_struct_init(), and usb_vcp_cmd_process().

The documentation for this struct was generated from the following file:
  • cdc_class.h


AT32F435/437 Firmwary Library: vcp_keyboard_type Struct Reference

Data Fields
vcp_keyboard_type Struct Reference
AT32F435_437_middlewares_usbd_class » USB_cdc_class | AT32F435_437_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F435_437_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types

#include <cdc_keyboard_class.h>

Data Fields

uint32_t | alt_setting
uint32_t | hid_protocol
uint32_t | hid_set_idle
uint8_t | hid_set_report [64]
uint8_t | g_rx_buff [0x40]
uint8_t | g_cmd [0x08]
uint8_t | g_req
uint8_t | hid_state
uint16_t | g_len
uint16_t | g_rxlen
__IO uint8_t | g_tx_completed
__IO uint8_t | g_rx_completed
__IO uint8_t | g_keyboard_tx_completed
linecoding_type linecoding

Detailed Description

Definition at line 74 of file cdc_keyboard_class.h.

Field Documentation

◆ alt_setting

uint32_t vcp_keyboard_type::alt_setting

Definition at line 76 of file cdc_keyboard_class.h.

Referenced by cdc_class_setup_handler(), and keyboard_class_setup_handler().

◆ g_cmd

uint8_t vcp_keyboard_type::g_cmd[0x08]

Definition at line 82 of file cdc_keyboard_class.h.

Referenced by cdc_class_setup_handler(), and class_ept0_rx_handler().

◆ g_keyboard_tx_completed

__IO uint8_t vcp_keyboard_type::g_keyboard_tx_completed

Definition at line 88 of file cdc_keyboard_class.h.

Referenced by class_in_handler(), class_init_handler(), and keyboard_send_string().

◆ g_len

uint16_t vcp_keyboard_type::g_len

Definition at line 85 of file cdc_keyboard_class.h.

Referenced by cdc_class_setup_handler().

◆ g_req

uint8_t vcp_keyboard_type::g_req

Definition at line 83 of file cdc_keyboard_class.h.

Referenced by cdc_class_setup_handler(), and class_ept0_rx_handler().

◆ g_rx_buff

uint8_t vcp_keyboard_type::g_rx_buff[0x40]

Definition at line 81 of file cdc_keyboard_class.h.

Referenced by class_init_handler(), and usb_vcpkybrd_vcp_get_rxdata().

◆ g_rx_completed

__IO uint8_t vcp_keyboard_type::g_rx_completed

Definition at line 87 of file cdc_keyboard_class.h.

Referenced by class_out_handler(), and usb_vcpkybrd_vcp_get_rxdata().

◆ g_rxlen

uint16_t vcp_keyboard_type::g_rxlen

Definition at line 85 of file cdc_keyboard_class.h.

Referenced by class_out_handler(), and usb_vcpkybrd_vcp_get_rxdata().

◆ g_tx_completed

__IO uint8_t vcp_keyboard_type::g_tx_completed

Definition at line 86 of file cdc_keyboard_class.h.

Referenced by class_in_handler(), class_init_handler(), and usb_vcpkybrd_vcp_send_data().

◆ hid_protocol

uint32_t vcp_keyboard_type::hid_protocol

Definition at line 77 of file cdc_keyboard_class.h.

Referenced by keyboard_class_setup_handler().

◆ hid_set_idle

uint32_t vcp_keyboard_type::hid_set_idle

Definition at line 78 of file cdc_keyboard_class.h.

Referenced by keyboard_class_setup_handler().

◆ hid_set_report

uint8_t vcp_keyboard_type::hid_set_report[64]

Definition at line 80 of file cdc_keyboard_class.h.

Referenced by keyboard_class_setup_handler().

◆ hid_state

uint8_t vcp_keyboard_type::hid_state

Definition at line 84 of file cdc_keyboard_class.h.

Referenced by class_ept0_rx_handler(), and keyboard_class_setup_handler().

◆ linecoding

linecoding_type vcp_keyboard_type::linecoding

Definition at line 90 of file cdc_keyboard_class.h.

Referenced by class_init_handler(), and usb_vcp_cmd_process().

The documentation for this struct was generated from the following file:
  • cdc_keyboard_class.h


AT32F435/437 Firmwary Library: USB_cdc_class_exported_functions

Functions | Variables
USB_cdc_class_exported_functions
AT32F435_437_middlewares_usbd_class » USB_cdc_class

Functions

uint16_t | usb_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

usbd_class_handler cdc_class_handler

Detailed Description

Function Documentation

◆ usb_vcp_get_rxdata()

uint16_t usb_vcp_get_rxdata | ( | void * | udev,
 |  | uint8_t * | recv_data
 | ) |  |

usb device class rx data process

Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len
Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len

Definition at line 339 of file cdc_class.c.

◆ usb_vcp_send_data()

error_status usb_vcp_send_data | ( | void * | udev,
 |  | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

usb device class send data

Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status
Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status

Definition at line 369 of file cdc_class.c.

Variable Documentation

◆ cdc_class_handler

usbd_class_handler cdc_class_handler
extern

Definition at line 69 of file cdc_class.c.

Referenced by main().


AT32F435/437 Firmwary Library: USB_cdc_desc

Modules | Variables
USB_cdc_desc
AT32F435_437_middlewares_usbd_class

usb device cdc descriptor More...

Modules

USB_cdc_desc_private_functions
USB_cdc_desc_definition

Variables

usbd_desc_handler cdc_desc_handler
device descriptor handler structure More...

Detailed Description

usb device cdc descriptor

Variable Documentation

◆ cdc_desc_handler

usbd_desc_handler cdc_desc_handler
extern

device descriptor handler structure

Definition at line 64 of file cdc_desc.c.

Referenced by main().


AT32F435/437 Firmwary Library: USB_cdc_desc_private_functions

Functions | Variables
USB_cdc_desc_private_functions
AT32F435_437_middlewares_usbd_class » USB_cdc_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler | cdc_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 429 of file cdc_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 351 of file cdc_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 331 of file cdc_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 417 of file cdc_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 371 of file cdc_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 382 of file cdc_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 361 of file cdc_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 394 of file cdc_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 341 of file cdc_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 406 of file cdc_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 309 of file cdc_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 283 of file cdc_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 257 of file cdc_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x02,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x5740 ),
HBYTE( 0x5740 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92

usb device standard descriptor

usb string serial

usb string lang id

usb configuration standard descriptor

Definition at line 84 of file cdc_desc.c.

◆ cdc_desc_handler

usbd_desc_handler cdc_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: cdc_desc.c:351
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: cdc_desc.c:331
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: cdc_desc.c:382
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: cdc_desc.c:341
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: cdc_desc.c:417
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: cdc_desc.c:361
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: cdc_desc.c:394
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: cdc_desc.c:429
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: cdc_desc.c:371
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: cdc_desc.c:406

device descriptor handler structure

Definition at line 64 of file cdc_desc.c.

Referenced by main().

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
67 ,
g_usbd_configuration
}

Definition at line 229 of file cdc_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 222 of file cdc_desc.c.

Referenced by get_device_descriptor().

◆ g_usbd_desc_buffer

uint8_t g_usbd_desc_buffer[256]
static

Definition at line 59 of file cdc_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 236 of file cdc_desc.c.

Referenced by get_device_lang_id().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 243 of file cdc_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 249 of file cdc_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F435/437 Firmwary Library: USB_cdc_desc_definition

Macros
USB_cdc_desc_definition
AT32F435_437_middlewares_usbd_class » USB_cdc_desc | AT32F435_437_middlewares_usbd_class » USB_cdc_msc_desc

Macros

#define | CDC_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_CDC_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_CDC_PRODUCT_ID 0x5740
#define | USBD_CDC_CONFIG_DESC_SIZE 67
usb descriptor size define More...
#define | USBD_CDC_SIZ_STRING_LANGID 4
#define | USBD_CDC_SIZ_STRING_SERIAL 0x1A
#define | USBD_CDC_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_CDC_DESC_PRODUCT_STRING "AT32 Virtual Com Port "
#define | USBD_CDC_DESC_CONFIGURATION_STRING "Virtual ComPort Config"
#define | USBD_CDC_DESC_INTERFACE_STRING "Virtual ComPort Interface"
#define | CDC_HID_BINTERVAL_TIME 0xFF
usb endpoint interval define More...
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)
#define | CDC_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_CDC_MSC_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_CDC_MSC_PRODUCT_ID 0x5760
#define | USBD_CDC_MSC_CONFIG_DESC_SIZE 106
usb descriptor size define More...
#define | USBD_CDC_SIZ_STRING_LANGID 4
#define | USBD_CDC_SIZ_STRING_SERIAL 0x1A
#define | USBD_CDC_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_CDC_DESC_PRODUCT_STRING "AT32 Composite VCP and MSC "
#define | USBD_CDC_DESC_CONFIGURATION_STRING "Composite VCP and MSC Config"
#define | USBD_CDC_DESC_INTERFACE_STRING "Composite VCP and MSC Interface"
#define | CDC_HID_BINTERVAL_TIME 0xFF
usb endpoint interval define More...
#define | VCPMSC_MSC_INTERFACE 0x00
usb interface define More...
#define | VCPMSC_CDC_INTERFACE 0x01
#define | VCPMSC_CDC_DATA_INTERFACE 0x02
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Detailed Description

Macro Definition Documentation

◆ CDC_BCD_NUM [1/2]

#define CDC_BCD_NUM 0x0110

usb bcd number define

Definition at line 52 of file cdc_desc.h.

◆ CDC_BCD_NUM [2/2]

#define CDC_BCD_NUM 0x0110

usb bcd number define

Definition at line 52 of file cdc_msc_desc.h.

◆ CDC_HID_BINTERVAL_TIME [1/2]

#define CDC_HID_BINTERVAL_TIME 0xFF

usb endpoint interval define

Definition at line 78 of file cdc_desc.h.

◆ CDC_HID_BINTERVAL_TIME [2/2]

#define CDC_HID_BINTERVAL_TIME 0xFF

usb endpoint interval define

Definition at line 79 of file cdc_msc_desc.h.

◆ MCU_ID1 [1/2]

#define MCU_ID1 (0x1FFFF7E8)

usb mcu id address deine

Definition at line 83 of file cdc_desc.h.

◆ MCU_ID1 [2/2]

#define MCU_ID1 (0x1FFFF7E8)

usb mcu id address deine

Definition at line 92 of file cdc_msc_desc.h.

◆ MCU_ID2 [1/2]

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 84 of file cdc_desc.h.

◆ MCU_ID2 [2/2]

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 93 of file cdc_msc_desc.h.

◆ MCU_ID3 [1/2]

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 85 of file cdc_desc.h.

◆ MCU_ID3 [2/2]

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 94 of file cdc_msc_desc.h.

◆ USBD_CDC_CONFIG_DESC_SIZE

#define USBD_CDC_CONFIG_DESC_SIZE 67

usb descriptor size define

Definition at line 63 of file cdc_desc.h.

◆ USBD_CDC_DESC_CONFIGURATION_STRING [1/2]

#define USBD_CDC_DESC_CONFIGURATION_STRING "Virtual ComPort Config"

Definition at line 72 of file cdc_desc.h.

◆ USBD_CDC_DESC_CONFIGURATION_STRING [2/2]

#define USBD_CDC_DESC_CONFIGURATION_STRING "Composite VCP and MSC Config"

Definition at line 73 of file cdc_msc_desc.h.

◆ USBD_CDC_DESC_INTERFACE_STRING [1/2]

#define USBD_CDC_DESC_INTERFACE_STRING "Virtual ComPort Interface"

Definition at line 73 of file cdc_desc.h.

◆ USBD_CDC_DESC_INTERFACE_STRING [2/2]

#define USBD_CDC_DESC_INTERFACE_STRING "Composite VCP and MSC Interface"

Definition at line 74 of file cdc_msc_desc.h.

◆ USBD_CDC_DESC_MANUFACTURER_STRING [1/2]

#define USBD_CDC_DESC_MANUFACTURER_STRING "Artery"

usb string define(vendor, product configuration, interface)

Definition at line 70 of file cdc_desc.h.

◆ USBD_CDC_DESC_MANUFACTURER_STRING [2/2]

#define USBD_CDC_DESC_MANUFACTURER_STRING "Artery"

usb string define(vendor, product configuration, interface)

Definition at line 71 of file cdc_msc_desc.h.

◆ USBD_CDC_DESC_PRODUCT_STRING [1/2]

#define USBD_CDC_DESC_PRODUCT_STRING "AT32 Virtual Com Port "

Definition at line 71 of file cdc_desc.h.

◆ USBD_CDC_DESC_PRODUCT_STRING [2/2]

#define USBD_CDC_DESC_PRODUCT_STRING "AT32 Composite VCP and MSC "

Definition at line 72 of file cdc_msc_desc.h.

◆ USBD_CDC_MSC_CONFIG_DESC_SIZE

#define USBD_CDC_MSC_CONFIG_DESC_SIZE 106

usb descriptor size define

Definition at line 64 of file cdc_msc_desc.h.

◆ USBD_CDC_MSC_PRODUCT_ID

#define USBD_CDC_MSC_PRODUCT_ID 0x5760

Definition at line 58 of file cdc_msc_desc.h.

◆ USBD_CDC_MSC_VENDOR_ID

#define USBD_CDC_MSC_VENDOR_ID 0x2E3C

usb vendor id and product id define

Definition at line 57 of file cdc_msc_desc.h.

◆ USBD_CDC_PRODUCT_ID

#define USBD_CDC_PRODUCT_ID 0x5740

Definition at line 58 of file cdc_desc.h.

◆ USBD_CDC_SIZ_STRING_LANGID [1/2]

#define USBD_CDC_SIZ_STRING_LANGID 4

Definition at line 64 of file cdc_desc.h.

◆ USBD_CDC_SIZ_STRING_LANGID [2/2]

#define USBD_CDC_SIZ_STRING_LANGID 4

Definition at line 65 of file cdc_msc_desc.h.

◆ USBD_CDC_SIZ_STRING_SERIAL [1/2]

#define USBD_CDC_SIZ_STRING_SERIAL 0x1A

Definition at line 65 of file cdc_desc.h.

◆ USBD_CDC_SIZ_STRING_SERIAL [2/2]

#define USBD_CDC_SIZ_STRING_SERIAL 0x1A

Definition at line 66 of file cdc_msc_desc.h.

◆ USBD_CDC_VENDOR_ID

#define USBD_CDC_VENDOR_ID 0x2E3C

usb vendor id and product id define

Definition at line 57 of file cdc_desc.h.

◆ VCPMSC_CDC_DATA_INTERFACE

#define VCPMSC_CDC_DATA_INTERFACE 0x02

Definition at line 86 of file cdc_msc_desc.h.

◆ VCPMSC_CDC_INTERFACE

#define VCPMSC_CDC_INTERFACE 0x01

Definition at line 85 of file cdc_msc_desc.h.

◆ VCPMSC_MSC_INTERFACE

#define VCPMSC_MSC_INTERFACE 0x00

usb interface define

Definition at line 84 of file cdc_msc_desc.h.


AT32F435/437 Firmwary Library: USB_cdc_keyboard_class

Modules
USB_cdc_keyboard_class
AT32F435_437_middlewares_usbd_class

usb device class composite cdc and keyboard More...

Modules

USB_cdc_keyboard_class_private_functions
USB_cdc_keyboard_class_definition
USB_cdc_class_exported_types
USB_cdc_keyboar_class_exported_functions

Detailed Description

usb device class composite cdc and keyboard


AT32F435/437 Firmwary Library: USB_cdc_keyboard_class_private_functions

Macros | Functions | Variables
USB_cdc_keyboard_class_private_functions
AT32F435_437_middlewares_usbd_class » USB_cdc_keyboard_class

Macros

#define SHIFT 0x80

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
static usb_sts_type | cdc_class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | keyboard_class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static void | usb_vcp_cmd_process (void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device class request function More...
uint16_t | usb_vcpkybrd_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcpkybrd_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...
usb_sts_type | usb_vcpkybrd_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_vcpkybrd_keyboard_send_char (void *udev, uint8_t ascii_code)
usb keyoard send char More...

Variables

vcp_keyboard_type vcp_keyboard_struct
static const unsigned char | _asciimap [128]
linecoding_type linecoding_vcpkybrd
usbd_class_handler | cdc_keyboard_class_handler

Detailed Description

Macro Definition Documentation

◆ SHIFT

#define SHIFT 0x80

Definition at line 59 of file cdc_keyboard_class.c.

Function Documentation

◆ cdc_class_setup_handler()

static usb_sts_type cdc_class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 315 of file cdc_keyboard_class.c.

Referenced by class_setup_handler().

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 260 of file cdc_keyboard_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device class endpoint 0 out status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 459 of file cdc_keyboard_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device class endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 445 of file cdc_keyboard_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device class event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 549 of file cdc_keyboard_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 486 of file cdc_keyboard_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 224 of file cdc_keyboard_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 514 of file cdc_keyboard_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 286 of file cdc_keyboard_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device class sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 534 of file cdc_keyboard_class.c.

◆ keyboard_class_setup_handler()

static usb_sts_type keyboard_class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 371 of file cdc_keyboard_class.c.

Referenced by class_setup_handler().

◆ usb_vcp_cmd_process()

static void usb_vcp_cmd_process | ( | void * | udev,
 |  | uint8_t | cmd,
 |  | uint8_t * | buff,
 |  | uint16_t | len
 | ) |  |
static

usb device class request function

Parameters
udev | to the structure of usbd_core_type
cmd | request number
buff | request buffer
len | buffer length
Return values
none

Definition at line 636 of file cdc_keyboard_class.c.

Referenced by cdc_class_setup_handler(), and class_ept0_rx_handler().

◆ usb_vcpkybrd_class_send_report()

usb_sts_type usb_vcpkybrd_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 671 of file cdc_keyboard_class.c.

Referenced by usb_vcpkybrd_keyboard_send_char().

◆ usb_vcpkybrd_keyboard_send_char()

void usb_vcpkybrd_keyboard_send_char | ( | void * | udev,
 |  | uint8_t | ascii_code
 | ) |  |

usb keyoard send char

Parameters
udev | to the structure of usbd_core_type
op | operation
Return values
none

Definition at line 689 of file cdc_keyboard_class.c.

Referenced by keyboard_send_string().

◆ usb_vcpkybrd_vcp_get_rxdata()

uint16_t usb_vcpkybrd_vcp_get_rxdata | ( | void * | udev,
 |  | uint8_t * | recv_data
 | ) |  |

usb device class rx data process

Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len

Definition at line 580 of file cdc_keyboard_class.c.

Referenced by main().

◆ usb_vcpkybrd_vcp_send_data()

error_status usb_vcpkybrd_vcp_send_data | ( | void * | udev,
 |  | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

usb device class send data

Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status

Definition at line 610 of file cdc_keyboard_class.c.

Referenced by main().

Variable Documentation

◆ _asciimap

const unsigned char _asciimap[128]
static

Definition at line 60 of file cdc_keyboard_class.c.

Referenced by usb_vcpkybrd_keyboard_send_char().

◆ cdc_keyboard_class_handler

usbd_class_handler cdc_keyboard_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&vcp_keyboard_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: cdc_keyboard_class.c:534
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: cdc_keyboard_class.c:486
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: cdc_keyboard_class.c:260
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_keyboard_class.c:286
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: cdc_keyboard_class.c:445
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: cdc_keyboard_class.c:459
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: cdc_keyboard_class.c:549
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: cdc_keyboard_class.c:224
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: cdc_keyboard_class.c:514
vcp_keyboard_struct
vcp_keyboard_type vcp_keyboard_struct
Definition: cdc_keyboard_class.c:57

Definition at line 205 of file cdc_keyboard_class.c.

Referenced by main().

◆ linecoding_vcpkybrd

linecoding_type linecoding_vcpkybrd
Initial value:
=
{
115200,
0x00,
0x00,
0x08
}

Definition at line 193 of file cdc_keyboard_class.c.

Referenced by class_init_handler().

◆ vcp_keyboard_struct

vcp_keyboard_type vcp_keyboard_struct

Definition at line 57 of file cdc_keyboard_class.c.


AT32F435/437 Firmwary Library: USB_cdc_keyboard_class_definition

Macros
USB_cdc_keyboard_class_definition
AT32F435_437_middlewares_usbd_class » USB_cdc_keyboard_class

Macros

#define | USBD_VCPKYBRD_CDC_INT_EPT 0x82
usb use endpoint define More...
#define | USBD_VCPKYBRD_CDC_BULK_IN_EPT 0x81
#define | USBD_VCPKYBRD_CDC_BULK_OUT_EPT 0x01
#define | USBD_VCPKYBRD_HID_IN_EPT 0x83
#define | USBD_VCPKYBRD_IN_MAXPACKET_SIZE 0x40
usb in and out max packet size define More...
#define | USBD_VCPKYBRD_OUT_MAXPACKET_SIZE 0x40
#define | USBD_VCPKYBRD_CMD_MAXPACKET_SIZE 0x08

Detailed Description

Macro Definition Documentation

◆ USBD_VCPKYBRD_CDC_BULK_IN_EPT

#define USBD_VCPKYBRD_CDC_BULK_IN_EPT 0x81

Definition at line 54 of file cdc_keyboard_class.h.

◆ USBD_VCPKYBRD_CDC_BULK_OUT_EPT

#define USBD_VCPKYBRD_CDC_BULK_OUT_EPT 0x01

Definition at line 55 of file cdc_keyboard_class.h.

◆ USBD_VCPKYBRD_CDC_INT_EPT

#define USBD_VCPKYBRD_CDC_INT_EPT 0x82

usb use endpoint define

Definition at line 53 of file cdc_keyboard_class.h.

◆ USBD_VCPKYBRD_CMD_MAXPACKET_SIZE

#define USBD_VCPKYBRD_CMD_MAXPACKET_SIZE 0x08

Definition at line 63 of file cdc_keyboard_class.h.

◆ USBD_VCPKYBRD_HID_IN_EPT

#define USBD_VCPKYBRD_HID_IN_EPT 0x83

Definition at line 56 of file cdc_keyboard_class.h.

◆ USBD_VCPKYBRD_IN_MAXPACKET_SIZE

#define USBD_VCPKYBRD_IN_MAXPACKET_SIZE 0x40

usb in and out max packet size define

Definition at line 61 of file cdc_keyboard_class.h.

◆ USBD_VCPKYBRD_OUT_MAXPACKET_SIZE

#define USBD_VCPKYBRD_OUT_MAXPACKET_SIZE 0x40

Definition at line 62 of file cdc_keyboard_class.h.


AT32F435/437 Firmwary Library: USB_cdc_keyboar_class_exported_functions

Functions | Variables
USB_cdc_keyboar_class_exported_functions
AT32F435_437_middlewares_usbd_class » USB_cdc_keyboard_class

Functions

uint16_t | usb_vcpkybrd_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcpkybrd_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...
usb_sts_type | usb_vcpkybrd_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_vcpkybrd_keyboard_send_char (void *udev, uint8_t ascii_code)
usb keyoard send char More...

Variables

usbd_class_handler cdc_keyboard_class_handler

Detailed Description

Function Documentation

◆ usb_vcpkybrd_class_send_report()

usb_sts_type usb_vcpkybrd_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 671 of file cdc_keyboard_class.c.

Referenced by usb_vcpkybrd_keyboard_send_char().

◆ usb_vcpkybrd_keyboard_send_char()

void usb_vcpkybrd_keyboard_send_char | ( | void * | udev,
 |  | uint8_t | ascii_code
 | ) |  |

usb keyoard send char

Parameters
udev | to the structure of usbd_core_type
op | operation
Return values
none

Definition at line 689 of file cdc_keyboard_class.c.

Referenced by keyboard_send_string().

◆ usb_vcpkybrd_vcp_get_rxdata()

uint16_t usb_vcpkybrd_vcp_get_rxdata | ( | void * | udev,
 |  | uint8_t * | recv_data
 | ) |  |

usb device class rx data process

Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len

Definition at line 580 of file cdc_keyboard_class.c.

Referenced by main().

◆ usb_vcpkybrd_vcp_send_data()

error_status usb_vcpkybrd_vcp_send_data | ( | void * | udev,
 |  | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

usb device class send data

Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status

Definition at line 610 of file cdc_keyboard_class.c.

Referenced by main().

Variable Documentation

◆ cdc_keyboard_class_handler

usbd_class_handler cdc_keyboard_class_handler
extern

Definition at line 205 of file cdc_keyboard_class.c.

Referenced by main().


AT32F435/437 Firmwary Library: USB_cdc_keyboard_desc

Modules | Variables
USB_cdc_keyboard_desc
AT32F435_437_middlewares_usbd_class

usb device cdc keyboard descriptor More...

Modules

USB_cdc_keyboard_desc_private_functions
USB_cdc_keyboard_desc_definition

Variables

usbd_desc_handler cdc_keyboard_desc_handler
device descriptor handler structure More...

Detailed Description

usb device cdc keyboard descriptor

Variable Documentation

◆ cdc_keyboard_desc_handler

usbd_desc_handler cdc_keyboard_desc_handler
extern

device descriptor handler structure

Definition at line 62 of file cdc_keyboard_desc.c.

Referenced by main().


AT32F435/437 Firmwary Library: USB_cdc_keyboard_desc_private_functions

Functions | Variables
USB_cdc_keyboard_desc_private_functions
AT32F435_437_middlewares_usbd_class » USB_cdc_keyboard_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler | cdc_keyboard_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc
uint8_t | g_vcpkybrd_hid_usb_desc [9]
usb hid descriptor More...
uint8_t | g_usbd_vcpkybrd_hid_report [63]
usb hid keyboard report descriptor More...

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 533 of file cdc_keyboard_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 455 of file cdc_keyboard_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 435 of file cdc_keyboard_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 521 of file cdc_keyboard_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 475 of file cdc_keyboard_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 486 of file cdc_keyboard_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 465 of file cdc_keyboard_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 498 of file cdc_keyboard_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 445 of file cdc_keyboard_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 510 of file cdc_keyboard_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 413 of file cdc_keyboard_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 387 of file cdc_keyboard_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 361 of file cdc_keyboard_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0xEF,
0x02,
0x01,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x5750 ),
HBYTE( 0x5750 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92

usb device standard descriptor

usb string serial

usb string lang id

usb hid keyboard report descriptor

usb hid descriptor

usb configuration standard descriptor

Definition at line 82 of file cdc_keyboard_desc.c.

◆ cdc_keyboard_desc_handler

usbd_desc_handler cdc_keyboard_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: cdc_keyboard_desc.c:455
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: cdc_keyboard_desc.c:435
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: cdc_keyboard_desc.c:486
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: cdc_keyboard_desc.c:445
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: cdc_keyboard_desc.c:521
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: cdc_keyboard_desc.c:465
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: cdc_keyboard_desc.c:498
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: cdc_keyboard_desc.c:533
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: cdc_keyboard_desc.c:475
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: cdc_keyboard_desc.c:510

device descriptor handler structure

Definition at line 62 of file cdc_keyboard_desc.c.

Referenced by main().

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
108 ,
g_usbd_configuration
}

Definition at line 333 of file cdc_keyboard_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 326 of file cdc_keyboard_desc.c.

Referenced by get_device_descriptor().

◆ g_usbd_desc_buffer

uint8_t g_usbd_desc_buffer[256]
static

Definition at line 57 of file cdc_keyboard_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

◆ g_usbd_vcpkybrd_hid_report

ALIGNED_HEAD uint8_t g_usbd_vcpkybrd_hid_report
extern

usb hid keyboard report descriptor

Definition at line 263 of file cdc_keyboard_desc.c.

Referenced by keyboard_class_setup_handler().

◆ g_vcpkybrd_hid_usb_desc

ALIGNED_HEAD uint8_t g_vcpkybrd_hid_usb_desc
extern
Initial value:
=
{
0x09,
HID_CLASS_DESC_HID,
LBYTE( 0x0110 ),
HBYTE( 0x0110 ),
0x00,
0x01,
HID_CLASS_DESC_REPORT,
LBYTE(sizeof(g_usbd_vcpkybrd_hid_report)),
HBYTE(sizeof(g_usbd_vcpkybrd_hid_report)),
}
g_usbd_vcpkybrd_hid_report
uint8_t g_usbd_vcpkybrd_hid_report[63]
usb hid keyboard report descriptor
Definition: cdc_keyboard_desc.c:263
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: usb_std.h:223
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: usb_std.h:224

usb hid descriptor

Definition at line 244 of file cdc_keyboard_desc.c.

Referenced by keyboard_class_setup_handler().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 340 of file cdc_keyboard_desc.c.

Referenced by get_device_lang_id().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 347 of file cdc_keyboard_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 353 of file cdc_keyboard_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F435/437 Firmwary Library: USB_cdc_keyboard_desc_definition

Macros
USB_cdc_keyboard_desc_definition
AT32F435_437_middlewares_usbd_class » USB_cdc_keyboard_desc

Macros

#define | VCPKYBRD_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_VCPKYBRD_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_VCPKYBRD_PRODUCT_ID 0x5750
#define | USBD_VCPKYBRD_CONFIG_DESC_SIZE 108
usb descriptor size define More...
#define | USBD_VCPKYBRD_HID_SIZ_REPORT_DESC 63
#define | USBD_VCPKYBRD_SIZ_STRING_LANGID 4
#define | USBD_VCPKYBRD_SIZ_STRING_SERIAL 0x1A
#define | USBD_VCPKYBRD_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_VCPKYBRD_DESC_PRODUCT_STRING "AT32 Composite VCP and Keyboard"
#define | USBD_VCPKYBRD_DESC_CONFIGURATION_STRING "Composite VCP and Keyboard Config"
#define | USBD_VCPKYBRD_DESC_INTERFACE_STRING "Composite VCP and Keyboard Interface"
#define | VCPKYBRD_HID_BINTERVAL_TIME 0x0A
usb endpoint interval define More...
#define | VCPKYBRD_CDC_INTERFACE 0x00
usb interface define More...
#define | VCPKYBRD_CDC_DATA_INTERFACE 0x01
#define | VCPKYBRD_KEYBOARD_INTERFACE 0x02
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Detailed Description

Macro Definition Documentation

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

usb mcu id address deine

Definition at line 93 of file cdc_keyboard_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 94 of file cdc_keyboard_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 95 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_CONFIG_DESC_SIZE

#define USBD_VCPKYBRD_CONFIG_DESC_SIZE 108

usb descriptor size define

Definition at line 65 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_DESC_CONFIGURATION_STRING

#define USBD_VCPKYBRD_DESC_CONFIGURATION_STRING "Composite VCP and Keyboard Config"

Definition at line 75 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_DESC_INTERFACE_STRING

#define USBD_VCPKYBRD_DESC_INTERFACE_STRING "Composite VCP and Keyboard Interface"

Definition at line 76 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_DESC_MANUFACTURER_STRING

#define USBD_VCPKYBRD_DESC_MANUFACTURER_STRING "Artery"

usb string define(vendor, product configuration, interface)

Definition at line 73 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_DESC_PRODUCT_STRING

#define USBD_VCPKYBRD_DESC_PRODUCT_STRING "AT32 Composite VCP and Keyboard"

Definition at line 74 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_HID_SIZ_REPORT_DESC

#define USBD_VCPKYBRD_HID_SIZ_REPORT_DESC 63

Definition at line 66 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_PRODUCT_ID

#define USBD_VCPKYBRD_PRODUCT_ID 0x5750

Definition at line 59 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_SIZ_STRING_LANGID

#define USBD_VCPKYBRD_SIZ_STRING_LANGID 4

Definition at line 67 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_SIZ_STRING_SERIAL

#define USBD_VCPKYBRD_SIZ_STRING_SERIAL 0x1A

Definition at line 68 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_VENDOR_ID

#define USBD_VCPKYBRD_VENDOR_ID 0x2E3C

usb vendor id and product id define

Definition at line 58 of file cdc_keyboard_desc.h.

◆ VCPKYBRD_BCD_NUM

#define VCPKYBRD_BCD_NUM 0x0110

usb bcd number define

Definition at line 53 of file cdc_keyboard_desc.h.

◆ VCPKYBRD_CDC_DATA_INTERFACE

#define VCPKYBRD_CDC_DATA_INTERFACE 0x01

Definition at line 87 of file cdc_keyboard_desc.h.

◆ VCPKYBRD_CDC_INTERFACE

#define VCPKYBRD_CDC_INTERFACE 0x00

usb interface define

Definition at line 86 of file cdc_keyboard_desc.h.

◆ VCPKYBRD_HID_BINTERVAL_TIME

#define VCPKYBRD_HID_BINTERVAL_TIME 0x0A

usb endpoint interval define

Definition at line 81 of file cdc_keyboard_desc.h.

◆ VCPKYBRD_KEYBOARD_INTERFACE

#define VCPKYBRD_KEYBOARD_INTERFACE 0x02

Definition at line 88 of file cdc_keyboard_desc.h.


AT32F435/437 Firmwary Library: USB_cdc_msc_class

Modules
USB_cdc_msc_class
AT32F435_437_middlewares_usbd_class

usb device class cdc msc demo More...

Modules

USB_cdc_class_private_functions
USB_cdc_class_definition
USB_cdc_class_exported_types

Detailed Description

usb device class cdc msc demo


AT32F435/437 Firmwary Library: USB_cdc_msc_desc

Modules | Variables
USB_cdc_msc_desc
AT32F435_437_middlewares_usbd_class

usb device cdc msc descriptor More...

Modules

USB_cdc_msc_desc_private_functions
USB_cdc_desc_definition

Variables

usbd_desc_handler cdc_msc_desc_handler
device descriptor handler structure More...

Detailed Description

usb device cdc msc descriptor

Variable Documentation

◆ cdc_msc_desc_handler

usbd_desc_handler cdc_msc_desc_handler
extern

device descriptor handler structure

Definition at line 66 of file cdc_msc_desc.c.

Referenced by main().


AT32F435/437 Firmwary Library: USB_cdc_msc_desc_private_functions

Macros | Functions | Variables
USB_cdc_msc_desc_private_functions
AT32F435_437_middlewares_usbd_class » USB_cdc_msc_desc

Macros

#define USB_INTERFACE_ASSOCIATION_TYPE 0x0B

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler | cdc_msc_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

Macro Definition Documentation

◆ USB_INTERFACE_ASSOCIATION_TYPE

#define USB_INTERFACE_ASSOCIATION_TYPE 0x0B

Definition at line 45 of file cdc_msc_desc.c.

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 481 of file cdc_msc_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 403 of file cdc_msc_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 383 of file cdc_msc_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 469 of file cdc_msc_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 423 of file cdc_msc_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 434 of file cdc_msc_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 413 of file cdc_msc_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 446 of file cdc_msc_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 393 of file cdc_msc_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 458 of file cdc_msc_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 361 of file cdc_msc_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 335 of file cdc_msc_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 309 of file cdc_msc_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0xEF,
0x02,
0x01,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x5760 ),
HBYTE( 0x5760 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92

usb device standard descriptor

usb string serial

usb string lang id

usb configuration standard descriptor

Definition at line 86 of file cdc_msc_desc.c.

◆ cdc_msc_desc_handler

usbd_desc_handler cdc_msc_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: cdc_msc_desc.c:403
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: cdc_msc_desc.c:383
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: cdc_msc_desc.c:434
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: cdc_msc_desc.c:393
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: cdc_msc_desc.c:469
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: cdc_msc_desc.c:413
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: cdc_msc_desc.c:446
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: cdc_msc_desc.c:481
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: cdc_msc_desc.c:423
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: cdc_msc_desc.c:458

device descriptor handler structure

Definition at line 66 of file cdc_msc_desc.c.

Referenced by main().

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
106 ,
g_usbd_configuration
}

Definition at line 281 of file cdc_msc_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 274 of file cdc_msc_desc.c.

Referenced by get_device_descriptor().

◆ g_usbd_desc_buffer

uint8_t g_usbd_desc_buffer[256]
static

Definition at line 61 of file cdc_msc_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 288 of file cdc_msc_desc.c.

Referenced by get_device_lang_id().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 295 of file cdc_msc_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 301 of file cdc_msc_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F435/437 Firmwary Library: USB_msc_bot_scsi

Modules
USB_msc_bot_scsi
AT32F435_437_middlewares_usbd_class

usb device class mass storage demo More...

Modules

USB_msc_bot_functions
USB_msc_bot_scsi_definition

Detailed Description

usb device class mass storage demo


AT32F435/437 Firmwary Library: USB_msc_bot_functions

Functions | Variables
USB_msc_bot_functions
AT32F435_437_middlewares_usbd_class » USB_msc_bot_scsi

Functions

void | bot_scsi_init (void *udev)
initialize bulk-only transport and scsi More...
void | bot_scsi_reset (void *udev)
reset bulk-only transport and scsi More...
void | bot_scsi_datain_handler (void *udev, uint8_t ept_num)
bulk-only transport data in handler More...
void | bot_scsi_dataout_handler (void *udev, uint8_t ept_num)
bulk-only transport data out handler More...
void | bot_cbw_decode (void *udev)
bulk-only cbw decode More...
void | bot_scsi_send_data (void *udev, uint8_t *buffer, uint32_t len)
send bot data More...
void | bot_scsi_send_csw (void *udev, uint8_t status)
send command status More...
void | bot_scsi_sense_code (void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code More...
usb_sts_type | bot_scsi_check_address (void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address More...
void | bot_scsi_stall (void *udev)
bot endpoint stall More...
usb_sts_type | bot_scsi_test_unit (void *udev, uint8_t lun)
bulk-only transport scsi command test unit More...
usb_sts_type | bot_scsi_inquiry (void *udev, uint8_t lun)
bulk-only transport scsi command inquiry More...
usb_sts_type | bot_scsi_start_stop (void *udev, uint8_t lun)
bulk-only transport scsi command start stop More...
usb_sts_type | bot_scsi_allow_medium_removal (void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal More...
usb_sts_type | bot_scsi_mode_sense6 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6 More...
usb_sts_type | bot_scsi_mode_sense10 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10 More...
usb_sts_type | bot_scsi_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command capacity More...
usb_sts_type | bot_scsi_format_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command format capacity More...
usb_sts_type | bot_scsi_request_sense (void *udev, uint8_t lun)
bulk-only transport scsi command request sense More...
usb_sts_type | bot_scsi_verify (void *udev, uint8_t lun)
bulk-only transport scsi command verify More...
usb_sts_type | bot_scsi_read10 (void *udev, uint8_t lun)
bulk-only transport scsi command read10 More...
usb_sts_type | bot_scsi_write10 (void *udev, uint8_t lun)
bulk-only transport scsi command write10 More...
void | bot_scsi_clear_feature (void *udev, uint8_t ept_num)
clear feature More...
usb_sts_type | bot_scsi_cmd_process (void *udev)
bulk-only transport scsi command process More...

Variables

ALIGNED_HEAD uint8_t page00_inquiry_data[] | ALIGNED_TAIL
ALIGNED_HEAD uint8_t page00_inquiry_data[] | ALIGNED_TAIL

Detailed Description

Function Documentation

◆ bot_cbw_decode()

void bot_cbw_decode ( void * udev )

bulk-only cbw decode

Parameters
udev to the structure of usbd_core_type
Return values
none
Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 200 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_dataout_handler().

◆ bot_scsi_allow_medium_removal()

usb_sts_type bot_scsi_allow_medium_removal | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command meidum removal

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 427 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_capacity()

usb_sts_type bot_scsi_capacity | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command capacity

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 481 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_check_address()

usb_sts_type bot_scsi_check_address | ( | void * | udev,
 |  | uint8_t | lun,
 |  | uint32_t | blk_offset,
 |  | uint32_t | blk_count
 | ) |  |

check address

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
blk_offset | blk offset address
blk_count | blk number
Return values
usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
blk_offset | blk offset address
blk_count | blk number
Return values
usb_sts_type

Definition at line 307 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_read10(), bot_scsi_verify(), and bot_scsi_write10().

◆ bot_scsi_clear_feature()

void bot_scsi_clear_feature | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |

clear feature

Parameters
udev | to the structure of usbd_core_type
etp_num | endpoint number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
etp_num | endpoint number
Return values
status of usb_sts_type

Definition at line 733 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by class_setup_handler(), and msc_class_setup_handler().

◆ bot_scsi_cmd_process()

usb_sts_type bot_scsi_cmd_process ( void * udev )

bulk-only transport scsi command process

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type
Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 753 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode(), bot_scsi_datain_handler(), and bot_scsi_dataout_handler().

◆ bot_scsi_datain_handler()

void bot_scsi_datain_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |

bulk-only transport data in handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none
Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none

Definition at line 147 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by class_in_handler().

◆ bot_scsi_dataout_handler()

void bot_scsi_dataout_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |

bulk-only transport data out handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none
Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none

Definition at line 176 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by class_out_handler().

◆ bot_scsi_format_capacity()

usb_sts_type bot_scsi_format_capacity | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command format capacity

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 508 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_init()

void bot_scsi_init ( void * udev )

initialize bulk-only transport and scsi

Parameters
udev to the structure of usbd_core_type
Return values
none
Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 104 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by class_init_handler().

◆ bot_scsi_inquiry()

usb_sts_type bot_scsi_inquiry | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command inquiry

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 372 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_mode_sense10()

usb_sts_type bot_scsi_mode_sense10 | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command mode sense10

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 461 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_mode_sense6()

usb_sts_type bot_scsi_mode_sense6 | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command mode sense6

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 441 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_read10()

usb_sts_type bot_scsi_read10 | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command read10

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 602 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_request_sense()

usb_sts_type bot_scsi_request_sense | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command request sense

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 543 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_reset()

void bot_scsi_reset ( void * udev )

reset bulk-only transport and scsi

Parameters
udev to the structure of usbd_core_type
Return values
none
Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 128 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by class_setup_handler(), and msc_class_setup_handler().

◆ bot_scsi_send_csw()

void bot_scsi_send_csw | ( | void * | udev,
 |  | uint8_t | status
 | ) |  |

send command status

Parameters
udev | to the structure of usbd_core_type
status | csw status
Return values
none
Parameters
udev | to the structure of usbd_core_type
status | csw status
Return values
none

Definition at line 268 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode(), bot_scsi_clear_feature(), bot_scsi_datain_handler(), bot_scsi_dataout_handler(), and bot_scsi_write10().

◆ bot_scsi_send_data()

void bot_scsi_send_data | ( | void * | udev,
 |  | uint8_t * | buffer,
 |  | uint32_t | len
 | ) |  |

send bot data

Parameters
udev | to the structure of usbd_core_type
buffer | data buffer
len | data len
Return values
none
Parameters
udev | to the structure of usbd_core_type
buffer | data buffer
len | data len
Return values
none

Definition at line 247 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode().

◆ bot_scsi_sense_code()

void bot_scsi_sense_code | ( | void * | udev,
 |  | uint8_t | sense_key,
 |  | uint8_t | asc
 | ) |  |

send scsi sense code

Parameters
udev | to the structure of usbd_core_type
sense_key | sense key
asc | asc
Return values
none
Parameters
udev | to the structure of usbd_core_type
sense_key | sense key
asc | asc
Return values
none

Definition at line 292 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode(), bot_scsi_check_address(), bot_scsi_cmd_process(), bot_scsi_read10(), bot_scsi_test_unit(), bot_scsi_verify(), and bot_scsi_write10().

◆ bot_scsi_stall()

void bot_scsi_stall ( void * udev )

bot endpoint stall

Parameters
udev to the structure of usbd_core_type
Return values
none
Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 324 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode().

◆ bot_scsi_start_stop()

usb_sts_type bot_scsi_start_stop | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command start stop

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 413 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_test_unit()

usb_sts_type bot_scsi_test_unit | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command test unit

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 350 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_verify()

usb_sts_type bot_scsi_verify | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command verify

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 574 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_write10()

usb_sts_type bot_scsi_write10 | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command write10

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 663 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

Variable Documentation

◆ ALIGNED_TAIL [1/2]

ALIGNED_HEAD sense_type sense_data ALIGNED_TAIL
Initial value:
= {
0x00,
0x00,
0x00,
0x00,
0x00,
}

Definition at line 46 of file composite_cdc_msc/msc_bot_scsi.c.

◆ ALIGNED_TAIL [2/2]

ALIGNED_HEAD uint8_t mode_sense10_data [8] ALIGNED_TAIL
Initial value:
= {
0x00,
0x00,
0x00,
0x00,
0x00,
}

Definition at line 46 of file msc/msc_bot_scsi.c.


AT32F435/437 Firmwary Library: USB_custom_hid_class

Modules
USB_custom_hid_class
AT32F435_437_middlewares_usbd_class

usb device custom hid demo More...

Modules

USB_custom_hid_class_private_functions
USB_custom_hid_class_endpoint_definition
USB_custom_hid_class_request_code_definition
USB_custom_hid_class_exported_functions

Detailed Description

usb device custom hid demo


AT32F435/437 Firmwary Library: USB_custom_hid_class_private_functions

Functions | Variables
USB_custom_hid_class_private_functions
AT32F435_437_middlewares_usbd_class » USB_custom_hid_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
static void | usb_hid_buf_process (void *udev, uint8_t *report, uint16_t len)
usb device report function More...
usb_sts_type | custom_hid_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

custom_hid_type custom_hid_struct
usbd_class_handler custom_hid_class_handler

Detailed Description

Function Documentation

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 98 of file custom_hid_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device endpoint 0 out status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 206 of file custom_hid_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 192 of file custom_hid_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 284 of file custom_hid_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 229 of file custom_hid_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb custom hid endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 76 of file custom_hid_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 246 of file custom_hid_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 118 of file custom_hid_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 269 of file custom_hid_class.c.

◆ custom_hid_class_send_report()

usb_sts_type custom_hid_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 316 of file custom_hid_class.c.

Referenced by main().

◆ usb_hid_buf_process()

static void usb_hid_buf_process | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |
static

usb device report function

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
none

Definition at line 334 of file custom_hid_class.c.

Referenced by class_ept0_rx_handler(), and class_out_handler().

Variable Documentation

◆ custom_hid_class_handler

usbd_class_handler custom_hid_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&custom_hid_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: custom_hid_class.c:269
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: custom_hid_class.c:229
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: custom_hid_class.c:98
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: custom_hid_class.c:118
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: custom_hid_class.c:192
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: custom_hid_class.c:206
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: custom_hid_class.c:284
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: custom_hid_class.c:76
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: custom_hid_class.c:246
custom_hid_struct
custom_hid_type custom_hid_struct
Definition: custom_hid_class.c:54

Definition at line 57 of file custom_hid_class.c.

Referenced by main().

◆ custom_hid_struct

custom_hid_type custom_hid_struct

Definition at line 54 of file custom_hid_class.c.


AT32F435/437 Firmwary Library: USB_custom_hid_class_endpoint_definition

Macros
USB_custom_hid_class_endpoint_definition
AT32F435_437_middlewares_usbd_class » USB_custom_hid_class

Macros

#define | USBD_CUSTOM_HID_IN_EPT 0x81
usb custom hid use endpoint define More...
#define | USBD_CUSTOM_HID_OUT_EPT 0x01
#define | USBD_CUSTOM_IN_MAXPACKET_SIZE 0x40
usb custom hid in and out max packet size define More...
#define | USBD_CUSTOM_OUT_MAXPACKET_SIZE 0x40

Detailed Description

Macro Definition Documentation

◆ USBD_CUSTOM_HID_IN_EPT

#define USBD_CUSTOM_HID_IN_EPT 0x81

usb custom hid use endpoint define

Definition at line 53 of file custom_hid_class.h.

◆ USBD_CUSTOM_HID_OUT_EPT

#define USBD_CUSTOM_HID_OUT_EPT 0x01

Definition at line 54 of file custom_hid_class.h.

◆ USBD_CUSTOM_IN_MAXPACKET_SIZE

#define USBD_CUSTOM_IN_MAXPACKET_SIZE 0x40

usb custom hid in and out max packet size define

Definition at line 59 of file custom_hid_class.h.

◆ USBD_CUSTOM_OUT_MAXPACKET_SIZE

#define USBD_CUSTOM_OUT_MAXPACKET_SIZE 0x40

Definition at line 60 of file custom_hid_class.h.


AT32F435/437 Firmwary Library: USB_custom_hid_class_request_code_definition

Data Structures
USB_custom_hid_class_request_code_definition
AT32F435_437_middlewares_usbd_class » USB_custom_hid_class

Data Structures

struct custom_hid_type

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: custom_hid_type Struct Reference

Data Fields
custom_hid_type Struct Reference
AT32F435_437_middlewares_usbd_class » USB_custom_hid_class » USB_custom_hid_class_request_code_definition

#include <custom_hid_class.h>

Data Fields

uint8_t | g_rxhid_buff [0x40]
uint8_t | g_txhid_buff [0x40]
uint32_t | hid_protocol
uint32_t | hid_set_idle
uint32_t | alt_setting
uint8_t | hid_state
uint8_t | hid_set_report [64]

Detailed Description

Definition at line 70 of file custom_hid_class.h.

Field Documentation

◆ alt_setting

uint32_t custom_hid_type::alt_setting

Definition at line 77 of file custom_hid_class.h.

Referenced by class_setup_handler().

◆ g_rxhid_buff

uint8_t custom_hid_type::g_rxhid_buff[0x40]

Definition at line 72 of file custom_hid_class.h.

Referenced by class_init_handler(), class_out_handler(), and usb_hid_buf_process().

◆ g_txhid_buff

uint8_t custom_hid_type::g_txhid_buff[0x40]

Definition at line 73 of file custom_hid_class.h.

Referenced by usb_hid_buf_process().

◆ hid_protocol

uint32_t custom_hid_type::hid_protocol

Definition at line 75 of file custom_hid_class.h.

Referenced by class_setup_handler().

◆ hid_set_idle

uint32_t custom_hid_type::hid_set_idle

Definition at line 76 of file custom_hid_class.h.

Referenced by class_setup_handler().

◆ hid_set_report

uint8_t custom_hid_type::hid_set_report[64]

Definition at line 79 of file custom_hid_class.h.

Referenced by class_ept0_rx_handler(), and class_setup_handler().

◆ hid_state

uint8_t custom_hid_type::hid_state

Definition at line 78 of file custom_hid_class.h.

Referenced by class_ept0_rx_handler(), and class_setup_handler().

The documentation for this struct was generated from the following file:
  • custom_hid_class.h


AT32F435/437 Firmwary Library: USB_custom_hid_class_exported_functions

Functions | Variables
USB_custom_hid_class_exported_functions
AT32F435_437_middlewares_usbd_class » USB_custom_hid_class

Functions

usb_sts_type custom_hid_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

usbd_class_handler custom_hid_class_handler

Detailed Description

Function Documentation

◆ custom_hid_class_send_report()

usb_sts_type custom_hid_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 316 of file custom_hid_class.c.

Referenced by main().

Variable Documentation

◆ custom_hid_class_handler

usbd_class_handler custom_hid_class_handler
extern

Definition at line 57 of file custom_hid_class.c.

Referenced by main().


AT32F435/437 Firmwary Library: USB_custom_hid_desc

Modules | Variables
USB_custom_hid_desc
AT32F435_437_middlewares_usbd_class

usb device custom_hid descriptor More...

Modules

USB_custom_hid_desc_private_functions
USB_custom_hid_desc_definition

Variables

usbd_desc_handler custom_hid_desc_handler
custom hid device descriptor handler structure More...

Detailed Description

usb device custom_hid descriptor

Variable Documentation

◆ custom_hid_desc_handler

usbd_desc_handler custom_hid_desc_handler
extern

custom hid device descriptor handler structure

Definition at line 62 of file custom_hid_desc.c.

Referenced by main().


AT32F435/437 Firmwary Library: USB_custom_hid_desc_private_functions

Functions | Variables
USB_custom_hid_desc_private_functions
AT32F435_437_middlewares_usbd_class » USB_custom_hid_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler | custom_hid_desc_handler
custom hid device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc
uint8_t | g_usbd_custom_hid_report [126]
usb hid report descriptor More...
uint8_t | g_custom_hid_usb_desc [9]
usb hid descriptor More...

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 513 of file custom_hid_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 435 of file custom_hid_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 415 of file custom_hid_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 501 of file custom_hid_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 455 of file custom_hid_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 466 of file custom_hid_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 445 of file custom_hid_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 478 of file custom_hid_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 425 of file custom_hid_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 490 of file custom_hid_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 393 of file custom_hid_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 367 of file custom_hid_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 341 of file custom_hid_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x00,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x5745 ),
HBYTE( 0x5745 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92

usb device standard descriptor

usb string serial

usb string lang id

usb hid descriptor

usb hid report descriptor

usb configuration standard descriptor

Definition at line 82 of file custom_hid_desc.c.

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
41 ,
g_usbd_configuration
}

Definition at line 313 of file custom_hid_desc.c.

Referenced by get_device_configuration().

◆ custom_hid_desc_handler

usbd_desc_handler custom_hid_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: custom_hid_desc.c:435
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: custom_hid_desc.c:415
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: custom_hid_desc.c:466
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: custom_hid_desc.c:425
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: custom_hid_desc.c:501
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: custom_hid_desc.c:445
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: custom_hid_desc.c:478
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: custom_hid_desc.c:513
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: custom_hid_desc.c:455
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: custom_hid_desc.c:490

custom hid device descriptor handler structure

Definition at line 62 of file custom_hid_desc.c.

Referenced by main().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 306 of file custom_hid_desc.c.

Referenced by get_device_descriptor().

◆ g_custom_hid_usb_desc

ALIGNED_HEAD uint8_t g_custom_hid_usb_desc
extern
Initial value:
=
{
0x09,
HID_CLASS_DESC_HID,
LBYTE( 0x0110 ),
HBYTE( 0x0110 ),
0x00,
0x01,
HID_CLASS_DESC_REPORT,
LBYTE(sizeof(g_usbd_custom_hid_report)),
HBYTE(sizeof(g_usbd_custom_hid_report)),
}
g_usbd_custom_hid_report
uint8_t g_usbd_custom_hid_report[126]
usb hid report descriptor
Definition: custom_hid_desc.c:166
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: usb_std.h:223
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: usb_std.h:224

usb hid descriptor

Definition at line 264 of file custom_hid_desc.c.

Referenced by class_setup_handler().

◆ g_usbd_custom_hid_report

ALIGNED_HEAD uint8_t g_usbd_custom_hid_report
extern

usb hid report descriptor

Definition at line 166 of file custom_hid_desc.c.

Referenced by class_setup_handler().

◆ g_usbd_desc_buffer

uint8_t g_usbd_desc_buffer[256]
static

Definition at line 57 of file custom_hid_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 320 of file custom_hid_desc.c.

Referenced by get_device_lang_id().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 327 of file custom_hid_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 333 of file custom_hid_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F435/437 Firmwary Library: USB_custom_hid_desc_definition

Macros
USB_custom_hid_desc_definition
AT32F435_437_middlewares_usbd_class » USB_custom_hid_desc

Macros

#define | CUSHID_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_CUSHID_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_CUSHID_PRODUCT_ID 0x5745
#define | USBD_CUSHID_CONFIG_DESC_SIZE 41
usb descriptor size define More...
#define | USBD_CUSHID_SIZ_REPORT_DESC 126
#define | USBD_CUSHID_SIZ_STRING_LANGID 4
#define | USBD_CUSHID_SIZ_STRING_SERIAL 0x1A
#define | USBD_CUSHID_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_CUSHID_DESC_PRODUCT_STRING "Custom HID"
#define | USBD_CUSHID_DESC_CONFIGURATION_STRING "Custom HID Config"
#define | USBD_CUSHID_DESC_INTERFACE_STRING "Custom HID Interface"
#define | CUSHID_BINTERVAL_TIME 0x0A
#define | HID_REPORT_ID_1 0x01
usb hid report id define More...
#define | HID_REPORT_ID_2 0x02
#define | HID_REPORT_ID_3 0x03
#define | HID_REPORT_ID_4 0x04
#define | HID_REPORT_ID_5 0x05
#define | HID_REPORT_ID_6 0xF0
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Detailed Description

Macro Definition Documentation

◆ CUSHID_BCD_NUM

#define CUSHID_BCD_NUM 0x0110

usb bcd number define

Definition at line 54 of file custom_hid_desc.h.

◆ CUSHID_BINTERVAL_TIME

#define CUSHID_BINTERVAL_TIME 0x0A

Definition at line 78 of file custom_hid_desc.h.

◆ HID_REPORT_ID_1

#define HID_REPORT_ID_1 0x01

usb hid report id define

usb hid report id define

Definition at line 86 of file custom_hid_desc.h.

◆ HID_REPORT_ID_2

#define HID_REPORT_ID_2 0x02

Definition at line 87 of file custom_hid_desc.h.

◆ HID_REPORT_ID_3

#define HID_REPORT_ID_3 0x03

Definition at line 88 of file custom_hid_desc.h.

◆ HID_REPORT_ID_4

#define HID_REPORT_ID_4 0x04

Definition at line 89 of file custom_hid_desc.h.

◆ HID_REPORT_ID_5

#define HID_REPORT_ID_5 0x05

Definition at line 90 of file custom_hid_desc.h.

◆ HID_REPORT_ID_6

#define HID_REPORT_ID_6 0xF0

Definition at line 91 of file custom_hid_desc.h.

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

usb mcu id address deine

Definition at line 96 of file custom_hid_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 97 of file custom_hid_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 98 of file custom_hid_desc.h.

◆ USBD_CUSHID_CONFIG_DESC_SIZE

#define USBD_CUSHID_CONFIG_DESC_SIZE 41

usb descriptor size define

Definition at line 65 of file custom_hid_desc.h.

◆ USBD_CUSHID_DESC_CONFIGURATION_STRING

#define USBD_CUSHID_DESC_CONFIGURATION_STRING "Custom HID Config"

Definition at line 75 of file custom_hid_desc.h.

◆ USBD_CUSHID_DESC_INTERFACE_STRING

#define USBD_CUSHID_DESC_INTERFACE_STRING "Custom HID Interface"

Definition at line 76 of file custom_hid_desc.h.

◆ USBD_CUSHID_DESC_MANUFACTURER_STRING

#define USBD_CUSHID_DESC_MANUFACTURER_STRING "Artery"

usb string define(vendor, product configuration, interface)

Definition at line 73 of file custom_hid_desc.h.

◆ USBD_CUSHID_DESC_PRODUCT_STRING

#define USBD_CUSHID_DESC_PRODUCT_STRING "Custom HID"

Definition at line 74 of file custom_hid_desc.h.

◆ USBD_CUSHID_PRODUCT_ID

#define USBD_CUSHID_PRODUCT_ID 0x5745

Definition at line 60 of file custom_hid_desc.h.

◆ USBD_CUSHID_SIZ_REPORT_DESC

#define USBD_CUSHID_SIZ_REPORT_DESC 126

Definition at line 66 of file custom_hid_desc.h.

◆ USBD_CUSHID_SIZ_STRING_LANGID

#define USBD_CUSHID_SIZ_STRING_LANGID 4

Definition at line 67 of file custom_hid_desc.h.

◆ USBD_CUSHID_SIZ_STRING_SERIAL

#define USBD_CUSHID_SIZ_STRING_SERIAL 0x1A

Definition at line 68 of file custom_hid_desc.h.

◆ USBD_CUSHID_VENDOR_ID

#define USBD_CUSHID_VENDOR_ID 0x2E3C

usb vendor id and product id define

Definition at line 59 of file custom_hid_desc.h.


AT32F435/437 Firmwary Library: USB_hid_iap_class

Modules
USB_hid_iap_class
AT32F435_437_middlewares_usbd_class

usb device class hid iap demo More...

Modules

USB_hid_iap_class_private_functions
USB_hid_iap_class_definition

Detailed Description

usb device class hid iap demo


AT32F435/437 Firmwary Library: USB_hid_iap_class_private_functions

Functions | Variables
USB_hid_iap_class_private_functions
AT32F435_437_middlewares_usbd_class » USB_hid_iap_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
usb_sts_type | usb_iap_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

iap_info_type iap_info
usbd_class_handler hid_iap_class_handler

Detailed Description

Function Documentation

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 98 of file hid_iap_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device endpoint 0 out status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 206 of file hid_iap_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 192 of file hid_iap_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 284 of file hid_iap_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 228 of file hid_iap_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb custom hid endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 76 of file hid_iap_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 246 of file hid_iap_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 118 of file hid_iap_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 269 of file hid_iap_class.c.

◆ usb_iap_class_send_report()

usb_sts_type usb_iap_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 316 of file hid_iap_class.c.

Referenced by usbd_hid_iap_process().

Variable Documentation

◆ hid_iap_class_handler

usbd_class_handler hid_iap_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&iap_info
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: hid_iap_class.c:269
iap_info
iap_info_type iap_info
Definition: hid_iap_class.c:54
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: hid_iap_class.c:228
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: hid_iap_class.c:98
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: hid_iap_class.c:118
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: hid_iap_class.c:192
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: hid_iap_class.c:206
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: hid_iap_class.c:284
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: hid_iap_class.c:76
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: hid_iap_class.c:246

Definition at line 57 of file hid_iap_class.c.

Referenced by main().

◆ iap_info

iap_info_type iap_info

Definition at line 54 of file hid_iap_class.c.

Referenced by app_loop(), iap_address(), iap_clear_upgrade_flag(), iap_crc(), iap_data_write(), iap_erase_sector(), iap_finish(), iap_get(), iap_get_upgrade_flag(), iap_idle(), iap_init(), iap_jump(), iap_loop(), iap_respond(), iap_set_upgrade_flag(), iap_start(), usbd_hid_iap_in_complete(), and usbd_hid_iap_process().


AT32F435/437 Firmwary Library: USB_hid_iap_class_definition

Data Structures | Macros | Enumerations | Functions | Variables
USB_hid_iap_class_definition
AT32F435_437_middlewares_usbd_class » USB_hid_iap_class

Data Structures

struct iap_info_type

Macros

#define | USBD_HIDIAP_IN_EPT 0x81
#define | USBD_HIDIAP_OUT_EPT 0x01
#define | USBD_HIDIAP_IN_MAXPACKET_SIZE 0x40
#define | USBD_HIDIAP_OUT_MAXPACKET_SIZE 0x40
#define | FLASH_SIZE_REG() ((*(uint32_t *)0x1FFFF7E0) & 0xFFFF) /*Get Flash size*/
#define | KB_TO_B(kb) ((kb) << 10)
#define | SECTOR_SIZE_1K 0x400
#define | SECTOR_SIZE_2K 0x800
#define | SECTOR_SIZE_4K 0x1000
#define | IAP_CMD_IDLE 0x5AA0
iap command More...
#define | IAP_CMD_START 0x5AA1
#define | IAP_CMD_ADDR 0x5AA2
#define | IAP_CMD_DATA 0x5AA3
#define | IAP_CMD_FINISH 0x5AA4
#define | IAP_CMD_CRC 0x5AA5
#define | IAP_CMD_JMP 0x5AA6
#define | IAP_CMD_GET 0x5AA7
#define | HID_IAP_BUFFER_LEN 1024
#define | IAP_UPGRADE_COMPLETE_FLAG 0x41544B38
#define | CONVERT_ENDIAN(dwValue)
#define | IAP_ACK 0xFF00
#define | IAP_NACK 0x00FF

Enumerations

enum iap_result_type { IAP_SUCCESS , IAP_WAIT , IAP_FAILED }
enum iap_machine_state_type {
IAP_STS_IDLE , IAP_STS_START , IAP_STS_ADDR , IAP_STS_DATA ,
IAP_STS_FINISH , IAP_STS_CRC , IAP_STS_JMP_WAIT , IAP_STS_JMP
}

Functions

usb_sts_type | usb_iap_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
iap_result_type | usbd_hid_iap_process (void *udev, uint8_t *report, uint16_t len)
usb device iap function More...
void | usbd_hid_iap_in_complete (void *udev)
usb device in transfer complete function More...

Variables

usbd_class_handler hid_iap_class_handler
iap_info_type iap_info

Detailed Description

Macro Definition Documentation

◆ CONVERT_ENDIAN

#define CONVERT_ENDIAN ( dwValue )
Value:
((dwValue >> 24) | ((dwValue >> 8) & 0xFF00) | \
((dwValue << 8) & 0xFF0000) | (dwValue << 24) )

Definition at line 79 of file hid_iap_class.h.

◆ FLASH_SIZE_REG

#define FLASH_SIZE_REG ( ) ((*(uint32_t *)0x1FFFF7E0) & 0xFFFF) /*Get Flash size*/

Definition at line 58 of file hid_iap_class.h.

◆ HID_IAP_BUFFER_LEN

#define HID_IAP_BUFFER_LEN 1024

Definition at line 77 of file hid_iap_class.h.

◆ IAP_ACK

#define IAP_ACK 0xFF00

Definition at line 82 of file hid_iap_class.h.

◆ IAP_CMD_ADDR

#define IAP_CMD_ADDR 0x5AA2

Definition at line 70 of file hid_iap_class.h.

◆ IAP_CMD_CRC

#define IAP_CMD_CRC 0x5AA5

Definition at line 73 of file hid_iap_class.h.

◆ IAP_CMD_DATA

#define IAP_CMD_DATA 0x5AA3

Definition at line 71 of file hid_iap_class.h.

◆ IAP_CMD_FINISH

#define IAP_CMD_FINISH 0x5AA4

Definition at line 72 of file hid_iap_class.h.

◆ IAP_CMD_GET

#define IAP_CMD_GET 0x5AA7

Definition at line 75 of file hid_iap_class.h.

◆ IAP_CMD_IDLE

#define IAP_CMD_IDLE 0x5AA0

iap command

Definition at line 68 of file hid_iap_class.h.

◆ IAP_CMD_JMP

#define IAP_CMD_JMP 0x5AA6

Definition at line 74 of file hid_iap_class.h.

◆ IAP_CMD_START

#define IAP_CMD_START 0x5AA1

Definition at line 69 of file hid_iap_class.h.

◆ IAP_NACK

#define IAP_NACK 0x00FF

Definition at line 83 of file hid_iap_class.h.

◆ IAP_UPGRADE_COMPLETE_FLAG

#define IAP_UPGRADE_COMPLETE_FLAG 0x41544B38

Definition at line 78 of file hid_iap_class.h.

◆ KB_TO_B

#define KB_TO_B ( kb ) ((kb) << 10)

Definition at line 59 of file hid_iap_class.h.

◆ SECTOR_SIZE_1K

#define SECTOR_SIZE_1K 0x400

Definition at line 61 of file hid_iap_class.h.

◆ SECTOR_SIZE_2K

#define SECTOR_SIZE_2K 0x800

Definition at line 62 of file hid_iap_class.h.

◆ SECTOR_SIZE_4K

#define SECTOR_SIZE_4K 0x1000

Definition at line 63 of file hid_iap_class.h.

◆ USBD_HIDIAP_IN_EPT

#define USBD_HIDIAP_IN_EPT 0x81

Definition at line 52 of file hid_iap_class.h.

◆ USBD_HIDIAP_IN_MAXPACKET_SIZE

#define USBD_HIDIAP_IN_MAXPACKET_SIZE 0x40

Definition at line 55 of file hid_iap_class.h.

◆ USBD_HIDIAP_OUT_EPT

#define USBD_HIDIAP_OUT_EPT 0x01

Definition at line 53 of file hid_iap_class.h.

◆ USBD_HIDIAP_OUT_MAXPACKET_SIZE

#define USBD_HIDIAP_OUT_MAXPACKET_SIZE 0x40

Definition at line 56 of file hid_iap_class.h.

Enumeration Type Documentation

◆ iap_machine_state_type

enum iap_machine_state_type
Enumerator
IAP_STS_IDLE
IAP_STS_START
IAP_STS_ADDR
IAP_STS_DATA
IAP_STS_FINISH
IAP_STS_CRC
IAP_STS_JMP_WAIT
IAP_STS_JMP

Definition at line 92 of file hid_iap_class.h.

◆ iap_result_type

enum iap_result_type
Enumerator
IAP_SUCCESS
IAP_WAIT
IAP_FAILED

Definition at line 85 of file hid_iap_class.h.

Function Documentation

◆ usb_iap_class_send_report()

usb_sts_type usb_iap_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 316 of file hid_iap_class.c.

Referenced by usbd_hid_iap_process().

◆ usbd_hid_iap_in_complete()

void usbd_hid_iap_in_complete ( void * udev )

usb device in transfer complete function

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 247 of file app_led3_toggle/src/hid_iap_user.c.

Referenced by class_in_handler().

◆ usbd_hid_iap_process()

iap_result_type usbd_hid_iap_process | ( | void * | udev,
 |  | uint8_t * | pdata,
 |  | uint16_t | len
 | ) |  |

usb device iap function

Parameters
udev | to the structure of usbd_core_type
pdata | data buffer point
len | data length
Return values
iap_result_type

Definition at line 201 of file app_led3_toggle/src/hid_iap_user.c.

Referenced by class_out_handler().

Variable Documentation

◆ hid_iap_class_handler

usbd_class_handler hid_iap_class_handler
extern

Definition at line 57 of file hid_iap_class.c.

Referenced by main().

◆ iap_info

iap_info_type iap_info
extern

Definition at line 54 of file hid_iap_class.c.

Referenced by app_loop(), iap_address(), iap_clear_upgrade_flag(), iap_crc(), iap_data_write(), iap_erase_sector(), iap_finish(), iap_get(), iap_get_upgrade_flag(), iap_idle(), iap_init(), iap_jump(), iap_loop(), iap_respond(), iap_set_upgrade_flag(), iap_start(), usbd_hid_iap_in_complete(), and usbd_hid_iap_process().


AT32F435/437 Firmwary Library: iap_info_type Struct Reference

Data Fields
iap_info_type Struct Reference
AT32F435_437_middlewares_usbd_class » USB_hid_iap_class » USB_hid_iap_class_definition

#include <hid_iap_class.h>

Data Fields

uint8_t | iap_fifo [1024]
uint8_t | iap_rx [0x40]
uint8_t | iap_tx [0x40]
uint32_t | fifo_length
uint32_t | tx_length
uint32_t | app_address
uint32_t | iap_address
uint32_t | flag_address
uint32_t | flash_start_address
uint32_t | flash_end_address
uint32_t | sector_size
uint32_t | flash_size
uint32_t | respond_flag
uint8_t | g_rxhid_buff [0x40]
uint32_t | hid_protocol
uint32_t | hid_set_idle
uint32_t | alt_setting
uint32_t | hid_state
uint8_t | hid_set_report [64]
iap_machine_state_type state

Detailed Description

Definition at line 104 of file hid_iap_class.h.

Field Documentation

◆ alt_setting

uint32_t iap_info_type::alt_setting

Definition at line 129 of file hid_iap_class.h.

Referenced by class_setup_handler().

◆ app_address

uint32_t iap_info_type::app_address

Definition at line 114 of file hid_iap_class.h.

Referenced by iap_get(), iap_init(), and iap_loop().

◆ fifo_length

uint32_t iap_info_type::fifo_length

Definition at line 111 of file hid_iap_class.h.

Referenced by iap_data_write(), and iap_init().

◆ flag_address

uint32_t iap_info_type::flag_address

Definition at line 116 of file hid_iap_class.h.

Referenced by iap_clear_upgrade_flag(), iap_get_upgrade_flag(), iap_init(), and iap_set_upgrade_flag().

◆ flash_end_address

uint32_t iap_info_type::flash_end_address

Definition at line 119 of file hid_iap_class.h.

Referenced by iap_address(), and iap_init().

◆ flash_size

uint32_t iap_info_type::flash_size

Definition at line 122 of file hid_iap_class.h.

Referenced by iap_init().

◆ flash_start_address

uint32_t iap_info_type::flash_start_address

Definition at line 118 of file hid_iap_class.h.

Referenced by iap_init().

◆ g_rxhid_buff

uint8_t iap_info_type::g_rxhid_buff[0x40]

Definition at line 126 of file hid_iap_class.h.

Referenced by class_init_handler(), and class_out_handler().

◆ hid_protocol

uint32_t iap_info_type::hid_protocol

Definition at line 127 of file hid_iap_class.h.

Referenced by class_setup_handler().

◆ hid_set_idle

uint32_t iap_info_type::hid_set_idle

Definition at line 128 of file hid_iap_class.h.

Referenced by class_setup_handler().

◆ hid_set_report

uint8_t iap_info_type::hid_set_report[64]

Definition at line 131 of file hid_iap_class.h.

Referenced by class_setup_handler().

◆ hid_state

uint32_t iap_info_type::hid_state

Definition at line 130 of file hid_iap_class.h.

Referenced by class_ept0_rx_handler(), and class_setup_handler().

◆ iap_address

uint32_t iap_info_type::iap_address

Definition at line 115 of file hid_iap_class.h.

Referenced by iap_address(), iap_data_write(), and iap_init().

◆ iap_fifo

uint8_t iap_info_type::iap_fifo[1024]

Definition at line 107 of file hid_iap_class.h.

Referenced by iap_data_write().

◆ iap_rx

uint8_t iap_info_type::iap_rx[0x40]

Definition at line 108 of file hid_iap_class.h.

◆ iap_tx

uint8_t iap_info_type::iap_tx[0x40]

Definition at line 109 of file hid_iap_class.h.

Referenced by iap_address(), iap_crc(), iap_data_write(), iap_finish(), iap_get(), iap_idle(), iap_jump(), iap_start(), and usbd_hid_iap_process().

◆ respond_flag

uint32_t iap_info_type::respond_flag

Definition at line 124 of file hid_iap_class.h.

Referenced by iap_respond(), and usbd_hid_iap_process().

◆ sector_size

uint32_t iap_info_type::sector_size

Definition at line 121 of file hid_iap_class.h.

Referenced by iap_erase_sector(), and iap_init().

◆ state

iap_machine_state_type iap_info_type::state

Definition at line 133 of file hid_iap_class.h.

Referenced by app_loop(), iap_address(), iap_data_write(), iap_finish(), iap_idle(), iap_jump(), iap_loop(), iap_start(), and usbd_hid_iap_in_complete().

◆ tx_length

uint32_t iap_info_type::tx_length

Definition at line 112 of file hid_iap_class.h.

The documentation for this struct was generated from the following file:
  • hid_iap_class.h


AT32F435/437 Firmwary Library: USB_hid_iap_desc

Modules
USB_hid_iap_desc
AT32F435_437_middlewares_usbd_class

usb device hid_iap descriptor More...

Modules

USB_hid_iap_desc_private_functions
USB_hid_iap_desc_definition

Detailed Description

usb device hid_iap descriptor


AT32F435/437 Firmwary Library: USB_hid_iap_desc_private_functions

Functions | Variables
USB_hid_iap_desc_private_functions
AT32F435_437_middlewares_usbd_class » USB_hid_iap_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler | hid_iap_desc_handler
hid device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 449 of file hid_iap_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 371 of file hid_iap_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 351 of file hid_iap_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 437 of file hid_iap_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 391 of file hid_iap_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 402 of file hid_iap_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 381 of file hid_iap_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 414 of file hid_iap_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 361 of file hid_iap_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 426 of file hid_iap_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 329 of file hid_iap_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 303 of file hid_iap_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 277 of file hid_iap_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x00,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0xAF01 ),
HBYTE( 0xAF01 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92

usb device standard descriptor

usb string serial

usb string lang id

usb hid descriptor

usb hid report descriptor

usb configuration standard descriptor

Definition at line 85 of file hid_iap_desc.c.

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
41 ,
g_usbd_configuration
}

Definition at line 249 of file hid_iap_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 242 of file hid_iap_desc.c.

Referenced by get_device_descriptor().

◆ g_usbd_desc_buffer

uint8_t g_usbd_desc_buffer[256]
static

Definition at line 60 of file hid_iap_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

◆ hid_iap_desc_handler

usbd_desc_handler hid_iap_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: hid_iap_desc.c:371
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: hid_iap_desc.c:351
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: hid_iap_desc.c:402
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: hid_iap_desc.c:361
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: hid_iap_desc.c:437
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: hid_iap_desc.c:381
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: hid_iap_desc.c:414
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: hid_iap_desc.c:449
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: hid_iap_desc.c:391
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: hid_iap_desc.c:426

hid device descriptor handler structure

Definition at line 65 of file hid_iap_desc.c.

Referenced by main().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 256 of file hid_iap_desc.c.

Referenced by get_device_lang_id().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 263 of file hid_iap_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 269 of file hid_iap_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F435/437 Firmwary Library: USB_hid_iap_desc_definition

Macros | Variables
USB_hid_iap_desc_definition
AT32F435_437_middlewares_usbd_class » USB_hid_iap_desc

Macros

#define | HIDIAP_BCD_NUM 0x0110
#define | USBD_HIDIAP_VENDOR_ID 0x2E3C
#define | USBD_HIDIAP_PRODUCT_ID 0xAF01
#define | USBD_HIDIAP_CONFIG_DESC_SIZE 41
#define | USBD_HIDIAP_SIZ_REPORT_DESC 32
#define | USBD_HIDIAP_SIZ_STRING_LANGID 4
#define | USBD_HIDIAP_SIZ_STRING_SERIAL 0x1A
#define | USBD_HIDIAP_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_HIDIAP_DESC_PRODUCT_STRING "HID IAP"
#define | USBD_HIDIAP_DESC_CONFIGURATION_STRING "HID IAP Config"
#define | USBD_HIDIAP_DESC_INTERFACE_STRING "HID IAP Interface"
#define | HIDIAP_BINTERVAL_TIME 0x01
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

uint8_t | g_usbd_hidiap_report [32]
usb hid report descriptor More...
uint8_t | g_hidiap_usb_desc [9]
usb hid descriptor More...
usbd_desc_handler | hid_iap_desc_handler
hid device descriptor handler structure More...

Detailed Description

Macro Definition Documentation

◆ HIDIAP_BCD_NUM

#define HIDIAP_BCD_NUM 0x0110

Definition at line 51 of file hid_iap_desc.h.

◆ HIDIAP_BINTERVAL_TIME

#define HIDIAP_BINTERVAL_TIME 0x01

Definition at line 66 of file hid_iap_desc.h.

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

Definition at line 68 of file hid_iap_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 69 of file hid_iap_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 70 of file hid_iap_desc.h.

◆ USBD_HIDIAP_CONFIG_DESC_SIZE

#define USBD_HIDIAP_CONFIG_DESC_SIZE 41

Definition at line 56 of file hid_iap_desc.h.

◆ USBD_HIDIAP_DESC_CONFIGURATION_STRING

#define USBD_HIDIAP_DESC_CONFIGURATION_STRING "HID IAP Config"

Definition at line 63 of file hid_iap_desc.h.

◆ USBD_HIDIAP_DESC_INTERFACE_STRING

#define USBD_HIDIAP_DESC_INTERFACE_STRING "HID IAP Interface"

Definition at line 64 of file hid_iap_desc.h.

◆ USBD_HIDIAP_DESC_MANUFACTURER_STRING

#define USBD_HIDIAP_DESC_MANUFACTURER_STRING "Artery"

Definition at line 61 of file hid_iap_desc.h.

◆ USBD_HIDIAP_DESC_PRODUCT_STRING

#define USBD_HIDIAP_DESC_PRODUCT_STRING "HID IAP"

Definition at line 62 of file hid_iap_desc.h.

◆ USBD_HIDIAP_PRODUCT_ID

#define USBD_HIDIAP_PRODUCT_ID 0xAF01

Definition at line 54 of file hid_iap_desc.h.

◆ USBD_HIDIAP_SIZ_REPORT_DESC

#define USBD_HIDIAP_SIZ_REPORT_DESC 32

Definition at line 57 of file hid_iap_desc.h.

◆ USBD_HIDIAP_SIZ_STRING_LANGID

#define USBD_HIDIAP_SIZ_STRING_LANGID 4

Definition at line 58 of file hid_iap_desc.h.

◆ USBD_HIDIAP_SIZ_STRING_SERIAL

#define USBD_HIDIAP_SIZ_STRING_SERIAL 0x1A

Definition at line 59 of file hid_iap_desc.h.

◆ USBD_HIDIAP_VENDOR_ID

#define USBD_HIDIAP_VENDOR_ID 0x2E3C

Definition at line 53 of file hid_iap_desc.h.

Variable Documentation

◆ g_hidiap_usb_desc

ALIGNED_HEAD uint8_t g_hidiap_usb_desc
extern
Initial value:
=
{
0x09,
HID_CLASS_DESC_HID,
LBYTE( 0x0110 ),
HBYTE( 0x0110 ),
0x00,
0x01,
HID_CLASS_DESC_REPORT,
LBYTE(sizeof(g_usbd_hidiap_report)),
HBYTE(sizeof(g_usbd_hidiap_report)),
}
g_usbd_hidiap_report
uint8_t g_usbd_hidiap_report[32]
usb hid report descriptor
Definition: hid_iap_desc.c:169
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: usb_std.h:223
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: usb_std.h:224

usb hid descriptor

Definition at line 200 of file hid_iap_desc.c.

Referenced by class_setup_handler().

◆ g_usbd_hidiap_report

ALIGNED_HEAD uint8_t g_usbd_hidiap_report
extern
Initial value:
=
{
0x06, 0xFF, 0x00,
0x09, 0x01,
0xa1, 0x01,
0x15, 0x00,
0x25, 0xFF,
0x75, 0x08,
0x95, 0x40,
0x09, 0x01,
0x81, 0x02,
0x95, 0x40,
0x09, 0x01,
0x91, 0x02,
0x95, 0x01,
0x09, 0x01,
0xB1, 0x02,
0xC0
}

usb hid report descriptor

Definition at line 169 of file hid_iap_desc.c.

Referenced by class_setup_handler().

◆ hid_iap_desc_handler

usbd_desc_handler hid_iap_desc_handler
extern

hid device descriptor handler structure

Definition at line 65 of file hid_iap_desc.c.

Referenced by main().


AT32F435/437 Firmwary Library: USB_keyboard_class

Modules | Data Structures
USB_keyboard_class
AT32F435_437_middlewares_usbd_class

usb device keyboard demo More...

Modules

USB_keyboard_class_private_functions
USB_keyboard_class_endpoint_definition
USB_hid_class_exported_functions

Data Structures

struct keyboard_type

Detailed Description

usb device keyboard demo


AT32F435/437 Firmwary Library: USB_keyboard_class_private_functions

Macros | Functions | Variables
USB_keyboard_class_private_functions
AT32F435_437_middlewares_usbd_class » USB_keyboard_class

Macros

#define SHIFT 0x80

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
usb_sts_type | usb_keyboard_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_hid_keyboard_send_char (void *udev, uint8_t ascii_code)
usb device class report function More...

Variables

keyboard_type keyboard_struct
static const unsigned char | _asciimap [128]
usbd_class_handler | keyboard_class_handler

Detailed Description

Macro Definition Documentation

◆ SHIFT

#define SHIFT 0x80

Definition at line 54 of file keyboard_class.c.

Function Documentation

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 227 of file keyboard_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device class endpoint 0 out status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 332 of file keyboard_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device class endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 318 of file keyboard_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device class event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 401 of file keyboard_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 354 of file keyboard_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 208 of file keyboard_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 374 of file keyboard_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 244 of file keyboard_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device class sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 386 of file keyboard_class.c.

◆ usb_hid_keyboard_send_char()

void usb_hid_keyboard_send_char | ( | void * | udev,
 |  | uint8_t | ascii_code
 | ) |  |

usb device class report function

Parameters
udev | to the structure of usbd_core_type
op | operation
Return values
none

Definition at line 453 of file keyboard_class.c.

Referenced by keyboard_send_string().

◆ usb_keyboard_class_send_report()

usb_sts_type usb_keyboard_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 435 of file keyboard_class.c.

Referenced by usb_hid_keyboard_send_char().

Variable Documentation

◆ _asciimap

const unsigned char _asciimap[128]
static

Definition at line 55 of file keyboard_class.c.

Referenced by usb_hid_keyboard_send_char().

◆ keyboard_class_handler

usbd_class_handler keyboard_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&keyboard_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: keyboard_class.c:386
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: keyboard_class.c:354
keyboard_struct
keyboard_type keyboard_struct
Definition: keyboard_class.c:53
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: keyboard_class.c:227
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: keyboard_class.c:244
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: keyboard_class.c:318
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: keyboard_class.c:332
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: keyboard_class.c:401
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: keyboard_class.c:208
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: keyboard_class.c:374

Definition at line 189 of file keyboard_class.c.

Referenced by main().

◆ keyboard_struct

keyboard_type keyboard_struct

Definition at line 53 of file keyboard_class.c.


AT32F435/437 Firmwary Library: USB_keyboard_class_endpoint_definition

Macros
USB_keyboard_class_endpoint_definition
AT32F435_437_middlewares_usbd_class » USB_keyboard_class

Macros

#define | USBD_KEYBOARD_IN_EPT 0x81
usb hid use endpoint define More...
#define | USBD_KEYBOARD_IN_MAXPACKET_SIZE 0x40
usb hid in and out max packet size define More...
#define | USBD_KEYBOARD_OUT_MAXPACKET_SIZE 0x40

Detailed Description

Macro Definition Documentation

◆ USBD_KEYBOARD_IN_EPT

#define USBD_KEYBOARD_IN_EPT 0x81

usb hid use endpoint define

Definition at line 53 of file keyboard_class.h.

◆ USBD_KEYBOARD_IN_MAXPACKET_SIZE

#define USBD_KEYBOARD_IN_MAXPACKET_SIZE 0x40

usb hid in and out max packet size define

Definition at line 58 of file keyboard_class.h.

◆ USBD_KEYBOARD_OUT_MAXPACKET_SIZE

#define USBD_KEYBOARD_OUT_MAXPACKET_SIZE 0x40

Definition at line 59 of file keyboard_class.h.


AT32F435/437 Firmwary Library: USB_hid_class_exported_functions

Functions | Variables
USB_hid_class_exported_functions
AT32F435_437_middlewares_usbd_class » USB_keyboard_class | AT32F435_437_middlewares_usbd_class » USB_mouse_class

Functions

usb_sts_type | usb_keyboard_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_hid_keyboard_send_char (void *udev, uint8_t ascii_code)
usb device class report function More...
usb_sts_type | usb_mouse_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_hid_mouse_send (void *udev, uint8_t op)
usb device class report function More...

Variables

usbd_class_handler | keyboard_class_handler
usbd_class_handler | mouse_class_handler

Detailed Description

Function Documentation

◆ usb_hid_keyboard_send_char()

void usb_hid_keyboard_send_char | ( | void * | udev,
 |  | uint8_t | ascii_code
 | ) |  |

usb device class report function

Parameters
udev | to the structure of usbd_core_type
op | operation
Return values
none

Definition at line 453 of file keyboard_class.c.

Referenced by keyboard_send_string().

◆ usb_hid_mouse_send()

void usb_hid_mouse_send | ( | void * | udev,
 |  | uint8_t | op
 | ) |  |

usb device class report function

Parameters
udev | to the structure of usbd_core_type
op | operation
Return values
none

Definition at line 314 of file mouse_class.c.

Referenced by main().

◆ usb_keyboard_class_send_report()

usb_sts_type usb_keyboard_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 435 of file keyboard_class.c.

Referenced by usb_hid_keyboard_send_char().

◆ usb_mouse_class_send_report()

usb_sts_type usb_mouse_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 294 of file mouse_class.c.

Referenced by usb_hid_mouse_send().

Variable Documentation

◆ keyboard_class_handler

usbd_class_handler keyboard_class_handler
extern

Definition at line 189 of file keyboard_class.c.

Referenced by main().

◆ mouse_class_handler

usbd_class_handler mouse_class_handler
extern

Definition at line 56 of file mouse_class.c.

Referenced by main().


AT32F435/437 Firmwary Library: keyboard_type Struct Reference

Data Fields
keyboard_type Struct Reference
AT32F435_437_middlewares_usbd_class » USB_keyboard_class

#include <keyboard_class.h>

Data Fields

uint32_t | hid_protocol
uint32_t | hid_set_idle
uint32_t | alt_setting
uint8_t | hid_set_report [64]
uint8_t | keyboard_buf [8]
__IO uint8_t | hid_suspend_flag
__IO uint8_t | g_u8tx_completed
uint8_t | hid_state
uint8_t | temp

Detailed Description

Definition at line 66 of file keyboard_class.h.

Field Documentation

◆ alt_setting

uint32_t keyboard_type::alt_setting

Definition at line 70 of file keyboard_class.h.

Referenced by class_setup_handler().

◆ g_u8tx_completed

__IO uint8_t keyboard_type::g_u8tx_completed

Definition at line 75 of file keyboard_class.h.

Referenced by class_in_handler(), class_init_handler(), and keyboard_send_string().

◆ hid_protocol

uint32_t keyboard_type::hid_protocol

Definition at line 68 of file keyboard_class.h.

Referenced by class_setup_handler().

◆ hid_set_idle

uint32_t keyboard_type::hid_set_idle

Definition at line 69 of file keyboard_class.h.

Referenced by class_setup_handler().

◆ hid_set_report

uint8_t keyboard_type::hid_set_report[64]

Definition at line 71 of file keyboard_class.h.

Referenced by class_setup_handler().

◆ hid_state

uint8_t keyboard_type::hid_state

Definition at line 76 of file keyboard_class.h.

Referenced by class_ept0_rx_handler(), and class_setup_handler().

◆ hid_suspend_flag

__IO uint8_t keyboard_type::hid_suspend_flag

Definition at line 74 of file keyboard_class.h.

Referenced by class_event_handler().

◆ keyboard_buf

uint8_t keyboard_type::keyboard_buf[8]

Definition at line 72 of file keyboard_class.h.

Referenced by usb_hid_keyboard_send_char().

◆ temp

uint8_t keyboard_type::temp

Definition at line 77 of file keyboard_class.h.

Referenced by usb_hid_keyboard_send_char().

The documentation for this struct was generated from the following file:
  • keyboard_class.h


AT32F435/437 Firmwary Library: USB_keyboard_desc

Modules | Variables
USB_keyboard_desc
AT32F435_437_middlewares_usbd_class

usb device keyboard descriptor More...

Modules

USB_keyboard_desc_private_functions
USB_keyboard_desc_definition

Variables

usbd_desc_handler keyboard_desc_handler
keyboard device descriptor handler structure More...

Detailed Description

usb device keyboard descriptor

Variable Documentation

◆ keyboard_desc_handler

usbd_desc_handler keyboard_desc_handler
extern

keyboard device descriptor handler structure

Definition at line 63 of file keyboard_desc.c.

Referenced by main().


AT32F435/437 Firmwary Library: USB_keyboard_desc_private_functions

Functions | Variables
USB_keyboard_desc_private_functions
AT32F435_437_middlewares_usbd_class » USB_keyboard_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler | keyboard_desc_handler
keyboard device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc
uint8_t | g_usbd_keyboard_report [63]
usb mouse report descriptor More...
uint8_t | g_keyboard_usb_desc [9]
usb hid descriptor More...

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 450 of file keyboard_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 372 of file keyboard_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 352 of file keyboard_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 438 of file keyboard_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 392 of file keyboard_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 403 of file keyboard_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 382 of file keyboard_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 415 of file keyboard_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 362 of file keyboard_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 427 of file keyboard_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 330 of file keyboard_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 304 of file keyboard_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 278 of file keyboard_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x00,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x6040 ),
HBYTE( 0x6040 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92

usb device standard descriptor

usb string serial

usb string lang id

usb hid descriptor

usb mouse report descriptor

usb configuration standard descriptor

Definition at line 83 of file keyboard_desc.c.

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
34 ,
g_usbd_configuration
}

Definition at line 250 of file keyboard_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 243 of file keyboard_desc.c.

Referenced by get_device_descriptor().

◆ g_keyboard_usb_desc

ALIGNED_HEAD uint8_t g_keyboard_usb_desc
extern
Initial value:
=
{
0x09,
HID_CLASS_DESC_HID,
LBYTE( 0x0110 ),
HBYTE( 0x0110 ),
0x00,
0x01,
HID_CLASS_DESC_REPORT,
LBYTE(sizeof(g_usbd_keyboard_report)),
HBYTE(sizeof(g_usbd_keyboard_report)),
}
g_usbd_keyboard_report
uint8_t g_usbd_keyboard_report[63]
usb mouse report descriptor
Definition: keyboard_desc.c:159
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: usb_std.h:223
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: usb_std.h:224

usb hid descriptor

Definition at line 201 of file keyboard_desc.c.

Referenced by class_setup_handler().

◆ g_usbd_desc_buffer

uint8_t g_usbd_desc_buffer[256]
static

Definition at line 58 of file keyboard_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

◆ g_usbd_keyboard_report

ALIGNED_HEAD uint8_t g_usbd_keyboard_report
extern

usb mouse report descriptor

Definition at line 159 of file keyboard_desc.c.

Referenced by class_setup_handler().

◆ keyboard_desc_handler

usbd_desc_handler keyboard_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: keyboard_desc.c:372
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: keyboard_desc.c:352
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: keyboard_desc.c:403
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: keyboard_desc.c:362
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: keyboard_desc.c:438
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: keyboard_desc.c:382
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: keyboard_desc.c:415
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: keyboard_desc.c:450
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: keyboard_desc.c:392
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: keyboard_desc.c:427

keyboard device descriptor handler structure

Definition at line 63 of file keyboard_desc.c.

Referenced by main().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 257 of file keyboard_desc.c.

Referenced by get_device_lang_id().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 264 of file keyboard_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 270 of file keyboard_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F435/437 Firmwary Library: USB_keyboard_desc_definition

Macros
USB_keyboard_desc_definition
AT32F435_437_middlewares_usbd_class » USB_keyboard_desc

Macros

#define | KEYBOARD_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_KEYBOARD_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_KEYBOARD_PRODUCT_ID 0x6040
#define | USBD_KEYBOARD_CONFIG_DESC_SIZE 34
usb descriptor size define More...
#define | USBD_KEYBOARD_SIZ_REPORT_DESC 63
#define | USBD_KEYBOARD_SIZ_STRING_LANGID 4
#define | USBD_KEYBOARD_SIZ_STRING_SERIAL 0x1A
#define | USBD_KEYBOARD_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_KEYBOARD_DESC_PRODUCT_STRING "Keyboard"
#define | USBD_KEYBOARD_DESC_CONFIGURATION_STRING "Keyboard Config"
#define | USBD_KEYBOARD_DESC_INTERFACE_STRING "Keyboard Interface"
#define | KEYBOARD_BINTERVAL_TIME 0x0A
usb hid endpoint interval define More...
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Detailed Description

Macro Definition Documentation

◆ KEYBOARD_BCD_NUM

#define KEYBOARD_BCD_NUM 0x0110

usb bcd number define

Definition at line 53 of file keyboard_desc.h.

◆ KEYBOARD_BINTERVAL_TIME

#define KEYBOARD_BINTERVAL_TIME 0x0A

usb hid endpoint interval define

Definition at line 80 of file keyboard_desc.h.

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

usb mcu id address deine

Definition at line 85 of file keyboard_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 86 of file keyboard_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 87 of file keyboard_desc.h.

◆ USBD_KEYBOARD_CONFIG_DESC_SIZE

#define USBD_KEYBOARD_CONFIG_DESC_SIZE 34

usb descriptor size define

Definition at line 64 of file keyboard_desc.h.

◆ USBD_KEYBOARD_DESC_CONFIGURATION_STRING

#define USBD_KEYBOARD_DESC_CONFIGURATION_STRING "Keyboard Config"

Definition at line 74 of file keyboard_desc.h.

◆ USBD_KEYBOARD_DESC_INTERFACE_STRING

#define USBD_KEYBOARD_DESC_INTERFACE_STRING "Keyboard Interface"

Definition at line 75 of file keyboard_desc.h.

◆ USBD_KEYBOARD_DESC_MANUFACTURER_STRING

#define USBD_KEYBOARD_DESC_MANUFACTURER_STRING "Artery"

usb string define(vendor, product configuration, interface)

Definition at line 72 of file keyboard_desc.h.

◆ USBD_KEYBOARD_DESC_PRODUCT_STRING

#define USBD_KEYBOARD_DESC_PRODUCT_STRING "Keyboard"

Definition at line 73 of file keyboard_desc.h.

◆ USBD_KEYBOARD_PRODUCT_ID

#define USBD_KEYBOARD_PRODUCT_ID 0x6040

Definition at line 59 of file keyboard_desc.h.

◆ USBD_KEYBOARD_SIZ_REPORT_DESC

#define USBD_KEYBOARD_SIZ_REPORT_DESC 63

Definition at line 65 of file keyboard_desc.h.

◆ USBD_KEYBOARD_SIZ_STRING_LANGID

#define USBD_KEYBOARD_SIZ_STRING_LANGID 4

Definition at line 66 of file keyboard_desc.h.

◆ USBD_KEYBOARD_SIZ_STRING_SERIAL

#define USBD_KEYBOARD_SIZ_STRING_SERIAL 0x1A

Definition at line 67 of file keyboard_desc.h.

◆ USBD_KEYBOARD_VENDOR_ID

#define USBD_KEYBOARD_VENDOR_ID 0x2E3C

usb vendor id and product id define

Definition at line 58 of file keyboard_desc.h.


AT32F435/437 Firmwary Library: USB_mouse_class

Modules
USB_mouse_class
AT32F435_437_middlewares_usbd_class

usb device mouse demo More...

Modules

USB_mouse_class_private_functions
USB_mouse_class_endpoint_definition
USB_mouse_class_request_code_definition
USB_hid_class_exported_functions

Detailed Description

usb device mouse demo


AT32F435/437 Firmwary Library: USB_mouse_class_private_functions

Functions | Variables
USB_mouse_class_private_functions
AT32F435_437_middlewares_usbd_class » USB_mouse_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
usb_sts_type | usb_mouse_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_hid_mouse_send (void *udev, uint8_t op)
usb device class report function More...

Variables

mouse_type mouse_struct
usbd_class_handler mouse_class_handler

Detailed Description

Function Documentation

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 91 of file mouse_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device class endpoint 0 out status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 194 of file mouse_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device class endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 180 of file mouse_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device class event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 260 of file mouse_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 216 of file mouse_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 75 of file mouse_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 233 of file mouse_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 108 of file mouse_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device class sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 245 of file mouse_class.c.

◆ usb_hid_mouse_send()

void usb_hid_mouse_send | ( | void * | udev,
 |  | uint8_t | op
 | ) |  |

usb device class report function

Parameters
udev | to the structure of usbd_core_type
op | operation
Return values
none

Definition at line 314 of file mouse_class.c.

Referenced by main().

◆ usb_mouse_class_send_report()

usb_sts_type usb_mouse_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 294 of file mouse_class.c.

Referenced by usb_hid_mouse_send().

Variable Documentation

◆ mouse_class_handler

usbd_class_handler mouse_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&mouse_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: mouse_class.c:245
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: mouse_class.c:216
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: mouse_class.c:91
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: mouse_class.c:108
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: mouse_class.c:180
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: mouse_class.c:194
mouse_struct
mouse_type mouse_struct
Definition: mouse_class.c:53
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: mouse_class.c:260
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: mouse_class.c:75
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: mouse_class.c:233

Definition at line 56 of file mouse_class.c.

Referenced by main().

◆ mouse_struct

mouse_type mouse_struct

Definition at line 53 of file mouse_class.c.


AT32F435/437 Firmwary Library: USB_mouse_class_endpoint_definition

Macros
USB_mouse_class_endpoint_definition
AT32F435_437_middlewares_usbd_class » USB_mouse_class

Macros

#define | USBD_MOUSE_IN_EPT 0x81
usb hid use endpoint define More...
#define | USBD_MOUSE_IN_MAXPACKET_SIZE 0x40
usb hid in and out max packet size define More...

Detailed Description

Macro Definition Documentation

◆ USBD_MOUSE_IN_EPT

#define USBD_MOUSE_IN_EPT 0x81

usb hid use endpoint define

Definition at line 53 of file mouse_class.h.

◆ USBD_MOUSE_IN_MAXPACKET_SIZE

#define USBD_MOUSE_IN_MAXPACKET_SIZE 0x40

usb hid in and out max packet size define

Definition at line 58 of file mouse_class.h.


AT32F435/437 Firmwary Library: USB_mouse_class_request_code_definition

Data Structures | Macros
USB_mouse_class_request_code_definition
AT32F435_437_middlewares_usbd_class » USB_mouse_class

Data Structures

struct mouse_type

Macros

#define | MOVE_STEP 20
usb hid mouse operation More...
#define | BUTTON_RELEASE 0
#define | LEFT_BUTTON 1
#define | RIGHT_BUTTON 2
#define | LEFT_MOVE 3
#define | RIGHT_MOVE 4
#define | UP_MOVE 5
#define | DOWN_MOVE 6

Detailed Description

Macro Definition Documentation

◆ BUTTON_RELEASE

#define BUTTON_RELEASE 0

Definition at line 74 of file mouse_class.h.

◆ DOWN_MOVE

#define DOWN_MOVE 6

Definition at line 80 of file mouse_class.h.

◆ LEFT_BUTTON

#define LEFT_BUTTON 1

Definition at line 75 of file mouse_class.h.

◆ LEFT_MOVE

#define LEFT_MOVE 3

Definition at line 77 of file mouse_class.h.

◆ MOVE_STEP

#define MOVE_STEP 20

usb hid mouse operation

Definition at line 72 of file mouse_class.h.

◆ RIGHT_BUTTON

#define RIGHT_BUTTON 2

Definition at line 76 of file mouse_class.h.

◆ RIGHT_MOVE

#define RIGHT_MOVE 4

Definition at line 78 of file mouse_class.h.

◆ UP_MOVE

#define UP_MOVE 5

Definition at line 79 of file mouse_class.h.


AT32F435/437 Firmwary Library: mouse_type Struct Reference

Data Fields
mouse_type Struct Reference
AT32F435_437_middlewares_usbd_class » USB_mouse_class » USB_mouse_class_request_code_definition

#include <mouse_class.h>

Data Fields

uint32_t | hid_protocol
uint32_t | hid_set_idle
uint32_t | alt_setting
uint8_t | hid_set_report [64]
uint8_t | mouse_buffer [4]
uint8_t | hid_state
__IO uint8_t | hid_suspend_flag

Detailed Description

Definition at line 82 of file mouse_class.h.

Field Documentation

◆ alt_setting

uint32_t mouse_type::alt_setting

Definition at line 86 of file mouse_class.h.

Referenced by class_setup_handler().

◆ hid_protocol

uint32_t mouse_type::hid_protocol

Definition at line 84 of file mouse_class.h.

Referenced by class_setup_handler().

◆ hid_set_idle

uint32_t mouse_type::hid_set_idle

Definition at line 85 of file mouse_class.h.

Referenced by class_setup_handler().

◆ hid_set_report

uint8_t mouse_type::hid_set_report[64]

Definition at line 88 of file mouse_class.h.

Referenced by class_setup_handler().

◆ hid_state

uint8_t mouse_type::hid_state

Definition at line 90 of file mouse_class.h.

Referenced by class_ept0_rx_handler(), and class_setup_handler().

◆ hid_suspend_flag

__IO uint8_t mouse_type::hid_suspend_flag

Definition at line 91 of file mouse_class.h.

Referenced by class_event_handler().

◆ mouse_buffer

uint8_t mouse_type::mouse_buffer[4]

Definition at line 89 of file mouse_class.h.

Referenced by usb_hid_mouse_send().

The documentation for this struct was generated from the following file:
  • mouse_class.h


AT32F435/437 Firmwary Library: USB_mouse_desc

Modules | Variables
USB_mouse_desc
AT32F435_437_middlewares_usbd_class

usb device mouse descriptor More...

Modules

USB_mouse_desc_private_functions
USB_mouse_desc_definition

Variables

usbd_desc_handler mouse_desc_handler
mouse device descriptor handler structure More...

Detailed Description

usb device mouse descriptor

Variable Documentation

◆ mouse_desc_handler

usbd_desc_handler mouse_desc_handler
extern

mouse device descriptor handler structure

Definition at line 63 of file mouse_desc.c.

Referenced by main().


AT32F435/437 Firmwary Library: USB_mouse_desc_private_functions

Functions | Variables
USB_mouse_desc_private_functions
AT32F435_437_middlewares_usbd_class » USB_mouse_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler | mouse_desc_handler
mouse device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc
uint8_t | g_usbd_mouse_report [74]
usb mouse report descriptor More...
uint8_t | g_mouse_usb_desc [9]
usb hid descriptor More...

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 464 of file mouse_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 386 of file mouse_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 366 of file mouse_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 452 of file mouse_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 406 of file mouse_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 417 of file mouse_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 396 of file mouse_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 429 of file mouse_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 376 of file mouse_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 441 of file mouse_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 344 of file mouse_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 318 of file mouse_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 292 of file mouse_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x00,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x5710 ),
HBYTE( 0x5710 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92

usb device standard descriptor

usb string serial

usb string lang id

usb hid descriptor

usb mouse report descriptor

usb configuration standard descriptor

Definition at line 83 of file mouse_desc.c.

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
34 ,
g_usbd_configuration
}

Definition at line 264 of file mouse_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 257 of file mouse_desc.c.

Referenced by get_device_descriptor().

◆ g_mouse_usb_desc

ALIGNED_HEAD uint8_t g_mouse_usb_desc
extern
Initial value:
=
{
0x09,
HID_CLASS_DESC_HID,
LBYTE( 0x0110 ),
HBYTE( 0x0110 ),
0x00,
0x01,
HID_CLASS_DESC_REPORT,
LBYTE(sizeof(g_usbd_mouse_report)),
HBYTE(sizeof(g_usbd_mouse_report)),
}
g_usbd_mouse_report
uint8_t g_usbd_mouse_report[74]
usb mouse report descriptor
Definition: mouse_desc.c:159
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: usb_std.h:223
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: usb_std.h:224

usb hid descriptor

Definition at line 215 of file mouse_desc.c.

Referenced by class_setup_handler().

◆ g_usbd_desc_buffer

uint8_t g_usbd_desc_buffer[256]
static

Definition at line 58 of file mouse_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

◆ g_usbd_mouse_report

ALIGNED_HEAD uint8_t g_usbd_mouse_report
extern

usb mouse report descriptor

Definition at line 159 of file mouse_desc.c.

Referenced by class_setup_handler().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 271 of file mouse_desc.c.

Referenced by get_device_lang_id().

◆ mouse_desc_handler

usbd_desc_handler mouse_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: mouse_desc.c:386
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: mouse_desc.c:366
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: mouse_desc.c:417
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: mouse_desc.c:376
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: mouse_desc.c:452
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: mouse_desc.c:396
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: mouse_desc.c:429
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: mouse_desc.c:464
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: mouse_desc.c:406
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: mouse_desc.c:441

mouse device descriptor handler structure

Definition at line 63 of file mouse_desc.c.

Referenced by main().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 278 of file mouse_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 284 of file mouse_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F435/437 Firmwary Library: USB_mouse_desc_definition

Macros
USB_mouse_desc_definition
AT32F435_437_middlewares_usbd_class » USB_mouse_desc

Macros

#define | MOUSE_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_MOUSE_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_MOUSE_PRODUCT_ID 0x5710
#define | USBD_MOUSE_CONFIG_DESC_SIZE 34
usb descriptor size define More...
#define | USBD_MOUSE_SIZ_REPORT_DESC 74
#define | USBD_MOUSE_SIZ_STRING_LANGID 4
#define | USBD_MOUSE_SIZ_STRING_SERIAL 0x1A
#define | USBD_MOUSE_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_MOUSE_DESC_PRODUCT_STRING "Mouse"
#define | USBD_MOUSE_DESC_CONFIGURATION_STRING "Mouse Config"
#define | USBD_MOUSE_DESC_INTERFACE_STRING "Mouse Interface"
#define | MOUSE_BINTERVAL_TIME 0x0A
usb hid endpoint interval define More...
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Detailed Description

Macro Definition Documentation

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

usb mcu id address deine

Definition at line 85 of file mouse_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 86 of file mouse_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 87 of file mouse_desc.h.

◆ MOUSE_BCD_NUM

#define MOUSE_BCD_NUM 0x0110

usb bcd number define

Definition at line 53 of file mouse_desc.h.

◆ MOUSE_BINTERVAL_TIME

#define MOUSE_BINTERVAL_TIME 0x0A

usb hid endpoint interval define

Definition at line 80 of file mouse_desc.h.

◆ USBD_MOUSE_CONFIG_DESC_SIZE

#define USBD_MOUSE_CONFIG_DESC_SIZE 34

usb descriptor size define

Definition at line 64 of file mouse_desc.h.

◆ USBD_MOUSE_DESC_CONFIGURATION_STRING

#define USBD_MOUSE_DESC_CONFIGURATION_STRING "Mouse Config"

Definition at line 74 of file mouse_desc.h.

◆ USBD_MOUSE_DESC_INTERFACE_STRING

#define USBD_MOUSE_DESC_INTERFACE_STRING "Mouse Interface"

Definition at line 75 of file mouse_desc.h.

◆ USBD_MOUSE_DESC_MANUFACTURER_STRING

#define USBD_MOUSE_DESC_MANUFACTURER_STRING "Artery"

usb string define(vendor, product configuration, interface)

Definition at line 72 of file mouse_desc.h.

◆ USBD_MOUSE_DESC_PRODUCT_STRING

#define USBD_MOUSE_DESC_PRODUCT_STRING "Mouse"

Definition at line 73 of file mouse_desc.h.

◆ USBD_MOUSE_PRODUCT_ID

#define USBD_MOUSE_PRODUCT_ID 0x5710

Definition at line 59 of file mouse_desc.h.

◆ USBD_MOUSE_SIZ_REPORT_DESC

#define USBD_MOUSE_SIZ_REPORT_DESC 74

Definition at line 65 of file mouse_desc.h.

◆ USBD_MOUSE_SIZ_STRING_LANGID

#define USBD_MOUSE_SIZ_STRING_LANGID 4

Definition at line 66 of file mouse_desc.h.

◆ USBD_MOUSE_SIZ_STRING_SERIAL

#define USBD_MOUSE_SIZ_STRING_SERIAL 0x1A

Definition at line 67 of file mouse_desc.h.

◆ USBD_MOUSE_VENDOR_ID

#define USBD_MOUSE_VENDOR_ID 0x2E3C

usb vendor id and product id define

Definition at line 58 of file mouse_desc.h.


AT32F435/437 Firmwary Library: USB_msc_class

Modules
USB_msc_class
AT32F435_437_middlewares_usbd_class

usb device class msc demo More...

Modules

USB_msc_class_private_functions
USB_msc_class_definition

Detailed Description

usb device class msc demo


AT32F435/437 Firmwary Library: USB_msc_class_private_functions

Functions | Variables
USB_msc_class_private_functions
AT32F435_437_middlewares_usbd_class » USB_msc_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...

Variables

msc_type msc_struct
usbd_class_handler msc_class_handler

Detailed Description

Function Documentation

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 97 of file msc_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device endpoint 0 out status stage complete

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 200 of file msc_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 186 of file msc_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 258 of file msc_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 215 of file msc_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 76 of file msc_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 230 of file msc_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

< get max lun

< bulk only mass storage reset

Definition at line 117 of file msc_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 243 of file msc_class.c.

Variable Documentation

◆ msc_class_handler

usbd_class_handler msc_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&msc_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: msc_class.c:243
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: msc_class.c:215
msc_struct
msc_type msc_struct
Definition: msc_class.c:54
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: msc_class.c:97
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: msc_class.c:117
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: msc_class.c:186
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: msc_class.c:200
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: msc_class.c:258
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: msc_class.c:76
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: msc_class.c:230

Definition at line 57 of file msc_class.c.

Referenced by main().

◆ msc_struct

msc_type msc_struct

Definition at line 54 of file msc_class.c.

Referenced by msc_bot_scsi_init(), usb_bot_request(), usbh_cmd_capacity10(), and usbh_cmd_inquiry().


AT32F435/437 Firmwary Library: USB_msc_class_definition

Macros | Variables
USB_msc_class_definition
AT32F435_437_middlewares_usbd_class » USB_msc_class

Macros

#define | USBD_MSC_BULK_IN_EPT 0x81
#define | USBD_MSC_BULK_OUT_EPT 0x01
#define | USBD_IN_MAXPACKET_SIZE 0x40
#define | USBD_OUT_MAXPACKET_SIZE 0x40

Variables

usbd_class_handler msc_class_handler

Detailed Description

Macro Definition Documentation

◆ USBD_IN_MAXPACKET_SIZE

#define USBD_IN_MAXPACKET_SIZE 0x40

Definition at line 52 of file msc_class.h.

◆ USBD_MSC_BULK_IN_EPT

#define USBD_MSC_BULK_IN_EPT 0x81

Definition at line 49 of file msc_class.h.

◆ USBD_MSC_BULK_OUT_EPT

#define USBD_MSC_BULK_OUT_EPT 0x01

Definition at line 50 of file msc_class.h.

◆ USBD_OUT_MAXPACKET_SIZE

#define USBD_OUT_MAXPACKET_SIZE 0x40

Definition at line 53 of file msc_class.h.

Variable Documentation

◆ msc_class_handler

usbd_class_handler msc_class_handler
extern

Definition at line 57 of file msc_class.c.

Referenced by main().


AT32F435/437 Firmwary Library: USB_msc_desc

Modules
USB_msc_desc
AT32F435_437_middlewares_usbd_class

usb device msc descriptor More...

Modules

USB_msc_desc_private_functions
USB_msc_desc_definition

Detailed Description

usb device msc descriptor


AT32F435/437 Firmwary Library: USB_msc_desc_private_functions

Functions | Variables
USB_msc_desc_private_functions
AT32F435_437_middlewares_usbd_class » USB_msc_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler | msc_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 387 of file msc_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 309 of file msc_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 289 of file msc_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 375 of file msc_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 329 of file msc_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 340 of file msc_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 319 of file msc_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 352 of file msc_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 299 of file msc_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 364 of file msc_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 267 of file msc_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 241 of file msc_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 215 of file msc_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x00,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x5720 ),
HBYTE( 0x5720 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92

usb device standard descriptor

usb string serial

usb string lang id

usb configuration standard descriptor

Definition at line 84 of file msc_desc.c.

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
32 ,
g_usbd_configuration
}

Definition at line 187 of file msc_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 180 of file msc_desc.c.

Referenced by get_device_descriptor().

◆ g_usbd_desc_buffer

uint8_t g_usbd_desc_buffer[256]
static

Definition at line 59 of file msc_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 194 of file msc_desc.c.

Referenced by get_device_lang_id().

◆ msc_desc_handler

usbd_desc_handler msc_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: msc_desc.c:309
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: msc_desc.c:289
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: msc_desc.c:340
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: msc_desc.c:299
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: msc_desc.c:375
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: msc_desc.c:319
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: msc_desc.c:352
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: msc_desc.c:387
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: msc_desc.c:329
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: msc_desc.c:364

device descriptor handler structure

Definition at line 64 of file msc_desc.c.

Referenced by main().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 201 of file msc_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 207 of file msc_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F435/437 Firmwary Library: USB_msc_desc_definition

Macros | Variables
USB_msc_desc_definition
AT32F435_437_middlewares_usbd_class » USB_msc_desc

Macros

#define | MSC_BCD_NUM 0x0110
#define | USBD_MSC_VENDOR_ID 0x2E3C
#define | USBD_MSC_PRODUCT_ID 0x5720
#define | USBD_MSC_CONFIG_DESC_SIZE 32
#define | USBD_MSC_SIZ_STRING_LANGID 4
#define | USBD_MSC_SIZ_STRING_SERIAL 0x1A
#define | USBD_MSC_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_MSC_DESC_PRODUCT_STRING "AT32 Mass Storage"
#define | USBD_MSC_DESC_CONFIGURATION_STRING "Mass Storage Config"
#define | USBD_MSC_DESC_INTERFACE_STRING "Mass Storage Interface"
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

usbd_desc_handler msc_desc_handler
device descriptor handler structure More...

Detailed Description

Macro Definition Documentation

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

Definition at line 64 of file msc_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 65 of file msc_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 66 of file msc_desc.h.

◆ MSC_BCD_NUM

#define MSC_BCD_NUM 0x0110

Definition at line 50 of file msc_desc.h.

◆ USBD_MSC_CONFIG_DESC_SIZE

#define USBD_MSC_CONFIG_DESC_SIZE 32

Definition at line 55 of file msc_desc.h.

◆ USBD_MSC_DESC_CONFIGURATION_STRING

#define USBD_MSC_DESC_CONFIGURATION_STRING "Mass Storage Config"

Definition at line 61 of file msc_desc.h.

◆ USBD_MSC_DESC_INTERFACE_STRING

#define USBD_MSC_DESC_INTERFACE_STRING "Mass Storage Interface"

Definition at line 62 of file msc_desc.h.

◆ USBD_MSC_DESC_MANUFACTURER_STRING

#define USBD_MSC_DESC_MANUFACTURER_STRING "Artery"

Definition at line 59 of file msc_desc.h.

◆ USBD_MSC_DESC_PRODUCT_STRING

#define USBD_MSC_DESC_PRODUCT_STRING "AT32 Mass Storage"

Definition at line 60 of file msc_desc.h.

◆ USBD_MSC_PRODUCT_ID

#define USBD_MSC_PRODUCT_ID 0x5720

Definition at line 53 of file msc_desc.h.

◆ USBD_MSC_SIZ_STRING_LANGID

#define USBD_MSC_SIZ_STRING_LANGID 4

Definition at line 56 of file msc_desc.h.

◆ USBD_MSC_SIZ_STRING_SERIAL

#define USBD_MSC_SIZ_STRING_SERIAL 0x1A

Definition at line 57 of file msc_desc.h.

◆ USBD_MSC_VENDOR_ID

#define USBD_MSC_VENDOR_ID 0x2E3C

Definition at line 52 of file msc_desc.h.

Variable Documentation

◆ msc_desc_handler

usbd_desc_handler msc_desc_handler
extern

device descriptor handler structure

Definition at line 64 of file msc_desc.c.

Referenced by main().


AT32F435/437 Firmwary Library: USB_printer_class

Modules
USB_printer_class
AT32F435_437_middlewares_usbd_class

usb device class printer demo More...

Modules

USB_printer_class_private_functions
USB_printer_class_definition

Detailed Description

usb device class printer demo


AT32F435/437 Firmwary Library: USB_printer_class_private_functions

Functions | Variables
USB_printer_class_private_functions
AT32F435_437_middlewares_usbd_class » USB_printer_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
error_status | usb_printer_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

static ALIGNED_HEAD uint8_t printer_device_id[24] | ALIGNED_TAIL
printer_type printer_struct
usbd_class_handler | printer_class_handler

Detailed Description

Function Documentation

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 109 of file printer_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device endpoint 0 out status stage complete

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 198 of file printer_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 184 of file printer_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 266 of file printer_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 213 of file printer_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb custom hid endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 83 of file printer_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 234 of file printer_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 129 of file printer_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 251 of file printer_class.c.

◆ usb_printer_send_data()

error_status usb_printer_send_data | ( | void * | udev,
 |  | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

usb device class send data

Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status

Definition at line 303 of file printer_class.c.

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t printer_device_id [ 24 ] ALIGNED_TAIL
static
Initial value:
=
{
0x00, 0x16,
'M', 'F', 'G',':','A','r','t','e', 'r', 'y' ,' ',
'C','M', 'D', ':', 'E', 'S', 'C', 'P', 'O', 'S',' ',
}

Definition at line 53 of file printer_class.c.

◆ printer_class_handler

usbd_class_handler printer_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&printer_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: printer_class.c:251
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: printer_class.c:213
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: printer_class.c:109
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: printer_class.c:129
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: printer_class.c:184
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: printer_class.c:198
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: printer_class.c:266
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: printer_class.c:83
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: printer_class.c:234
printer_struct
printer_type printer_struct
Definition: printer_class.c:61

Definition at line 64 of file printer_class.c.

Referenced by main().

◆ printer_struct

printer_type printer_struct

Definition at line 61 of file printer_class.c.


AT32F435/437 Firmwary Library: USB_printer_class_definition

Data Structures | Macros | Enumerations | Functions | Variables
USB_printer_class_definition
AT32F435_437_middlewares_usbd_class » USB_printer_class

Data Structures

struct printer_type

Macros

#define | USBD_PRINTER_BULK_IN_EPT 0x81
#define | USBD_PRINTER_BULK_OUT_EPT 0x01
#define | USBD_PRINTER_IN_MAXPACKET_SIZE 0x40
#define | USBD_PRINTER_OUT_MAXPACKET_SIZE 0x40
#define | PRINTER_DEVICE_ID_LEN 24

Enumerations

enum printer_req_type { PRINTER_REQ_GET_DEVICE_ID = 0x00 , PRINTER_REQ_GET_PORT_STATUS = 0x01 , PRINTER_REQ_GET_SOFT_RESET = 0x02 }

Functions

uint16_t | usb_printer_get_rxdata (void *udev, uint8_t *recv_data)
error_status | usb_printer_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

usbd_class_handler printer_class_handler

Detailed Description

Macro Definition Documentation

◆ PRINTER_DEVICE_ID_LEN

#define PRINTER_DEVICE_ID_LEN 24

Definition at line 57 of file printer_class.h.

◆ USBD_PRINTER_BULK_IN_EPT

#define USBD_PRINTER_BULK_IN_EPT 0x81

Definition at line 50 of file printer_class.h.

◆ USBD_PRINTER_BULK_OUT_EPT

#define USBD_PRINTER_BULK_OUT_EPT 0x01

Definition at line 51 of file printer_class.h.

◆ USBD_PRINTER_IN_MAXPACKET_SIZE

#define USBD_PRINTER_IN_MAXPACKET_SIZE 0x40

Definition at line 54 of file printer_class.h.

◆ USBD_PRINTER_OUT_MAXPACKET_SIZE

#define USBD_PRINTER_OUT_MAXPACKET_SIZE 0x40

Definition at line 55 of file printer_class.h.

Enumeration Type Documentation

◆ printer_req_type

enum printer_req_type
Enumerator
PRINTER_REQ_GET_DEVICE_ID
PRINTER_REQ_GET_PORT_STATUS
PRINTER_REQ_GET_SOFT_RESET

Definition at line 59 of file printer_class.h.

Function Documentation

◆ usb_printer_get_rxdata()

uint16_t usb_printer_get_rxdata | ( | void * | udev,
 |  | uint8_t * | recv_data
 | ) |  |

◆ usb_printer_send_data()

error_status usb_printer_send_data | ( | void * | udev,
 |  | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

usb device class send data

Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status

Definition at line 303 of file printer_class.c.

Variable Documentation

◆ printer_class_handler

usbd_class_handler printer_class_handler
extern

Definition at line 64 of file printer_class.c.

Referenced by main().


AT32F435/437 Firmwary Library: printer_type Struct Reference

Data Fields
printer_type Struct Reference
AT32F435_437_middlewares_usbd_class » USB_printer_class » USB_printer_class_definition

#include <printer_class.h>

Data Fields

uint32_t | alt_setting
uint32_t | g_printer_port_status
uint8_t | g_rx_buff [0x40]
uint8_t | g_printer_data [0x40]
__IO uint8_t | g_tx_completed
__IO uint8_t | g_rx_completed

Detailed Description

Definition at line 67 of file printer_class.h.

Field Documentation

◆ alt_setting

uint32_t printer_type::alt_setting

Definition at line 69 of file printer_class.h.

Referenced by class_setup_handler().

◆ g_printer_data

uint8_t printer_type::g_printer_data[0x40]

Definition at line 72 of file printer_class.h.

Referenced by class_setup_handler().

◆ g_printer_port_status

uint32_t printer_type::g_printer_port_status

Definition at line 70 of file printer_class.h.

Referenced by class_init_handler(), and class_setup_handler().

◆ g_rx_buff

uint8_t printer_type::g_rx_buff[0x40]

Definition at line 71 of file printer_class.h.

Referenced by class_init_handler().

◆ g_rx_completed

__IO uint8_t printer_type::g_rx_completed

Definition at line 74 of file printer_class.h.

Referenced by class_out_handler().

◆ g_tx_completed

__IO uint8_t printer_type::g_tx_completed

Definition at line 73 of file printer_class.h.

Referenced by class_in_handler(), class_init_handler(), and usb_printer_send_data().

The documentation for this struct was generated from the following file:
  • printer_class.h


AT32F435/437 Firmwary Library: USB_printer_desc

Modules
USB_printer_desc
AT32F435_437_middlewares_usbd_class

usb device printer descriptor More...

Modules

USB_printer_desc_private_functions
USB_printer_desc_definition

Detailed Description

usb device printer descriptor


AT32F435/437 Firmwary Library: USB_printer_desc_private_functions

Functions | Variables
USB_printer_desc_private_functions
AT32F435_437_middlewares_usbd_class » USB_printer_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler | printer_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 387 of file printer_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 309 of file printer_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 289 of file printer_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 375 of file printer_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 329 of file printer_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 340 of file printer_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 319 of file printer_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 352 of file printer_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 299 of file printer_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 364 of file printer_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 267 of file printer_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 241 of file printer_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 215 of file printer_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x00,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x57FF ),
HBYTE( 0x57FF ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92

usb device standard descriptor

usb string serial

usb string lang id

usb configuration standard descriptor

Definition at line 84 of file printer_desc.c.

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
32 ,
g_usbd_configuration
}

Definition at line 187 of file printer_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 180 of file printer_desc.c.

Referenced by get_device_descriptor().

◆ g_usbd_desc_buffer

uint8_t g_usbd_desc_buffer[256]
static

Definition at line 59 of file printer_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 194 of file printer_desc.c.

Referenced by get_device_lang_id().

◆ printer_desc_handler

usbd_desc_handler printer_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: printer_desc.c:309
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: printer_desc.c:289
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: printer_desc.c:340
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: printer_desc.c:299
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: printer_desc.c:375
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: printer_desc.c:319
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: printer_desc.c:352
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: printer_desc.c:387
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: printer_desc.c:329
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: printer_desc.c:364

device descriptor handler structure

Definition at line 64 of file printer_desc.c.

Referenced by main().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 201 of file printer_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 207 of file printer_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F435/437 Firmwary Library: USB_printer_desc_definition

Macros | Variables
USB_printer_desc_definition
AT32F435_437_middlewares_usbd_class » USB_printer_desc

Macros

#define | PRINTER_BCD_NUM 0x0110
#define | USBD_PRINTER_VENDOR_ID 0x2E3C
#define | USBD_PRINTER_PRODUCT_ID 0x57FF
#define | USBD_PRINTER_CONFIG_DESC_SIZE 32
#define | USBD_PRINTER_SIZ_STRING_LANGID 4
#define | USBD_PRINTER_SIZ_STRING_SERIAL 0x1A
#define | USBD_PRINTER_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_PRINTER_DESC_PRODUCT_STRING "AT32 Printer"
#define | USBD_PRINTER_DESC_CONFIGURATION_STRING "Printer Config"
#define | USBD_PRINTER_DESC_INTERFACE_STRING "Printer Interface"
#define | PRINTER_PROTOCOL_UNIDIRECTIONAL 0x01
#define | PRINTER_PROTOCOL_BI_DIRECTIONAL 0x02
#define | PRINTER_PROTOCOL_1284_4 0x03
#define | PRINTER_PROTOCOL_VENDOR_SPECIFIC 0xFF
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

usbd_desc_handler printer_desc_handler
device descriptor handler structure More...

Detailed Description

Macro Definition Documentation

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

Definition at line 70 of file printer_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 71 of file printer_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 72 of file printer_desc.h.

◆ PRINTER_BCD_NUM

#define PRINTER_BCD_NUM 0x0110

Definition at line 50 of file printer_desc.h.

◆ PRINTER_PROTOCOL_1284_4

#define PRINTER_PROTOCOL_1284_4 0x03

Definition at line 66 of file printer_desc.h.

◆ PRINTER_PROTOCOL_BI_DIRECTIONAL

#define PRINTER_PROTOCOL_BI_DIRECTIONAL 0x02

Definition at line 65 of file printer_desc.h.

◆ PRINTER_PROTOCOL_UNIDIRECTIONAL

#define PRINTER_PROTOCOL_UNIDIRECTIONAL 0x01

Definition at line 64 of file printer_desc.h.

◆ PRINTER_PROTOCOL_VENDOR_SPECIFIC

#define PRINTER_PROTOCOL_VENDOR_SPECIFIC 0xFF

Definition at line 67 of file printer_desc.h.

◆ USBD_PRINTER_CONFIG_DESC_SIZE

#define USBD_PRINTER_CONFIG_DESC_SIZE 32

Definition at line 55 of file printer_desc.h.

◆ USBD_PRINTER_DESC_CONFIGURATION_STRING

#define USBD_PRINTER_DESC_CONFIGURATION_STRING "Printer Config"

Definition at line 61 of file printer_desc.h.

◆ USBD_PRINTER_DESC_INTERFACE_STRING

#define USBD_PRINTER_DESC_INTERFACE_STRING "Printer Interface"

Definition at line 62 of file printer_desc.h.

◆ USBD_PRINTER_DESC_MANUFACTURER_STRING

#define USBD_PRINTER_DESC_MANUFACTURER_STRING "Artery"

Definition at line 59 of file printer_desc.h.

◆ USBD_PRINTER_DESC_PRODUCT_STRING

#define USBD_PRINTER_DESC_PRODUCT_STRING "AT32 Printer"

Definition at line 60 of file printer_desc.h.

◆ USBD_PRINTER_PRODUCT_ID

#define USBD_PRINTER_PRODUCT_ID 0x57FF

Definition at line 53 of file printer_desc.h.

◆ USBD_PRINTER_SIZ_STRING_LANGID

#define USBD_PRINTER_SIZ_STRING_LANGID 4

Definition at line 56 of file printer_desc.h.

◆ USBD_PRINTER_SIZ_STRING_SERIAL

#define USBD_PRINTER_SIZ_STRING_SERIAL 0x1A

Definition at line 57 of file printer_desc.h.

◆ USBD_PRINTER_VENDOR_ID

#define USBD_PRINTER_VENDOR_ID 0x2E3C

Definition at line 52 of file printer_desc.h.

Variable Documentation

◆ printer_desc_handler

usbd_desc_handler printer_desc_handler
extern

device descriptor handler structure

Definition at line 64 of file printer_desc.c.

Referenced by main().


AT32F435/437 Firmwary Library: AT32F435_437_middlewares_usbh_class

Modules
AT32F435_437_middlewares_usbh_class

Modules

USBH_hid_class
usb host class hid demo
USBH_hid_class_keyboard
usb host class hid keyboard
USBH_hid_class_mouse
usb host class hid mouse
USBH_msc_bot_scsi_class
usb host class msc bot scsi
USBH_msc_class
usb host class msc demo

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: USBH_hid_class

Modules
USBH_hid_class
AT32F435_437_middlewares_usbh_class

usb host class hid demo More...

Modules

USBH_hid_class_private_functions
USBH_hid_class_definition

Detailed Description

usb host class hid demo


AT32F435/437 Firmwary Library: USBH_hid_class_private_functions

Functions | Variables
USBH_hid_class_private_functions
AT32F435_437_middlewares_usbh_class » USBH_hid_class

Functions

static usb_sts_type | uhost_init_handler (void *uhost)
usb host class init handler More...
static usb_sts_type | uhost_reset_handler (void *uhost)
usb host class reset handler More...
static usb_sts_type | uhost_request_handler (void *uhost)
usb host hid class request handler More...
static usb_sts_type | uhost_process_handler (void *uhost)
usb host hid class process handler More...
usb_sts_type | usbh_hid_get_desc (void *uhost, uint16_t length)
usb host hid class get descriptor More...
usb_sts_type | usbh_hid_get_report (void *uhost, uint16_t length)
usb host hid class get report More...
usb_sts_type | usbh_hid_set_idle (void *uhost, uint8_t id, uint8_t dr)
usb host hid class set idle More...
usb_sts_type | usbh_hid_set_protocol (void *uhost, uint8_t protocol)
usb host hid class set protocol More...
usb_sts_type | usbh_clear_endpoint_feature (usbh_core_type *uhost, uint8_t ept_num, uint8_t hc_num)
usb host clear feature More...

Variables

usbh_hid_type usbh_hid
usbh_class_handler_type uhost_hid_class_handler

Detailed Description

Function Documentation

◆ uhost_init_handler()

static usb_sts_type uhost_init_handler ( void * uhost )
static

usb host class init handler

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 66 of file usbh_hid_class.c.

◆ uhost_process_handler()

static usb_sts_type uhost_process_handler ( void * uhost )
static

usb host hid class process handler

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 389 of file usbh_hid_class.c.

◆ uhost_request_handler()

static usb_sts_type uhost_request_handler ( void * uhost )
static

usb host hid class request handler

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 338 of file usbh_hid_class.c.

◆ uhost_reset_handler()

static usb_sts_type uhost_reset_handler ( void * uhost )
static

usb host class reset handler

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 137 of file usbh_hid_class.c.

◆ usbh_clear_endpoint_feature()

usb_sts_type usbh_clear_endpoint_feature | ( | usbh_core_type * | uhost,
 |  | uint8_t | ept_num,
 |  | uint8_t | hc_num
 | ) |  |

usb host clear feature

Parameters
uhost | to the structure of usbh_core_type
ept_num | endpoint number
hc_num | channel number
Return values
status usb_sts_type status

Definition at line 303 of file usbh_hid_class.c.

Referenced by uhost_process_handler().

◆ usbh_hid_get_desc()

usb_sts_type usbh_hid_get_desc | ( | void * | uhost,
 |  | uint16_t | length
 | ) |  |

usb host hid class get descriptor

Parameters
uhost | to the structure of usbh_core_type
length | descriptor length
Return values
status usb_sts_type status

Definition at line 172 of file usbh_hid_class.c.

Referenced by uhost_request_handler().

◆ usbh_hid_get_report()

usb_sts_type usbh_hid_get_report | ( | void * | uhost,
 |  | uint16_t | length
 | ) |  |

usb host hid class get report

Parameters
uhost | to the structure of usbh_core_type
length | reprot length
Return values
status usb_sts_type status

Definition at line 211 of file usbh_hid_class.c.

Referenced by uhost_request_handler().

◆ usbh_hid_set_idle()

usb_sts_type usbh_hid_set_idle | ( | void * | uhost,
 |  | uint8_t | id,
 |  | uint8_t | dr
 | ) |  |

usb host hid class set idle

Parameters
uhost | to the structure of usbh_core_type
id | id
dr | dr
Return values
status usb_sts_type status

Definition at line 242 of file usbh_hid_class.c.

Referenced by uhost_request_handler().

◆ usbh_hid_set_protocol()

usb_sts_type usbh_hid_set_protocol | ( | void * | uhost,
 |  | uint8_t | protocol
 | ) |  |

usb host hid class set protocol

Parameters
uhost | to the structure of usbh_core_type
protocol | portocol number
Return values
status usb_sts_type status

Definition at line 272 of file usbh_hid_class.c.

Referenced by uhost_request_handler().

Variable Documentation

◆ uhost_hid_class_handler

usbh_class_handler_type uhost_hid_class_handler
Initial value:
=
{
uhost_init_handler,
uhost_reset_handler,
uhost_request_handler,
uhost_process_handler,
&usbh_hid
}
usbh_hid
usbh_hid_type usbh_hid
Definition: usbh_hid_class.c:51
uhost_request_handler
static usb_sts_type uhost_request_handler(void *uhost)
usb host hid class request handler
Definition: usbh_hid_class.c:338
uhost_process_handler
static usb_sts_type uhost_process_handler(void *uhost)
usb host hid class process handler
Definition: usbh_hid_class.c:389
uhost_reset_handler
static usb_sts_type uhost_reset_handler(void *uhost)
usb host class reset handler
Definition: usbh_hid_class.c:137
uhost_init_handler
static usb_sts_type uhost_init_handler(void *uhost)
usb host class init handler
Definition: usbh_hid_class.c:66

Definition at line 52 of file usbh_hid_class.c.

Referenced by main().

◆ usbh_hid

usbh_hid_type usbh_hid

Definition at line 51 of file usbh_hid_class.c.

Referenced by uhost_init_handler().


AT32F435/437 Firmwary Library: USBH_hid_class_definition

Data Structures | Macros | Enumerations | Variables
USBH_hid_class_definition
AT32F435_437_middlewares_usbh_class » USBH_hid_class

Data Structures

struct | usb_hid_desc_type
usb hid descriptor type More...
struct | usbh_hid_type
usb hid struct More...

Macros

#define | USB_HID_NONE_PROTOCOL_CODE 0x00
usb hid protocol code More...
#define | USB_HID_KEYBOARD_PROTOCOL_CODE 0x01
#define | USB_HID_MOUSE_PROTOCOL_CODE 0x02
#define | USB_HID_GET_REPORT 0x01
usb hid request code More...
#define | USB_HID_GET_IDLE 0x02
#define | USB_HID_GET_PROTOCOL 0x03
#define | USB_HID_SET_REPORT 0x09
#define | USB_HID_SET_IDLE 0x0A
#define | USB_HID_SET_PROTOCOL 0x0B

Enumerations

enum usb_hid_ctrl_state_type {
USB_HID_STATE_IDLE , USB_HID_STATE_GET_DESC , USB_HID_STATE_GET_REPORT , USB_HID_STATE_SET_IDLE ,
USB_HID_STATE_SET_PROTOCOL , USB_HID_STATE_COMPLETE
}
usb hid request state More...
enum usb_hid_state_type {
USB_HID_INIT , USB_HID_GET , USB_HID_SEND , USB_HID_POLL ,
USB_HID_BUSY , USB_HID_ERROR
}
usb hid process state More...

Variables

usbh_class_handler_type uhost_hid_class_handler

Detailed Description

Macro Definition Documentation

◆ USB_HID_GET_IDLE

#define USB_HID_GET_IDLE 0x02

Definition at line 60 of file usbh_hid_class.h.

◆ USB_HID_GET_PROTOCOL

#define USB_HID_GET_PROTOCOL 0x03

Definition at line 61 of file usbh_hid_class.h.

◆ USB_HID_GET_REPORT

#define USB_HID_GET_REPORT 0x01

usb hid request code

Definition at line 59 of file usbh_hid_class.h.

◆ USB_HID_KEYBOARD_PROTOCOL_CODE

#define USB_HID_KEYBOARD_PROTOCOL_CODE 0x01

Definition at line 53 of file usbh_hid_class.h.

◆ USB_HID_MOUSE_PROTOCOL_CODE

#define USB_HID_MOUSE_PROTOCOL_CODE 0x02

Definition at line 54 of file usbh_hid_class.h.

◆ USB_HID_NONE_PROTOCOL_CODE

#define USB_HID_NONE_PROTOCOL_CODE 0x00

usb hid protocol code

Definition at line 52 of file usbh_hid_class.h.

◆ USB_HID_SET_IDLE

#define USB_HID_SET_IDLE 0x0A

Definition at line 63 of file usbh_hid_class.h.

◆ USB_HID_SET_PROTOCOL

#define USB_HID_SET_PROTOCOL 0x0B

Definition at line 64 of file usbh_hid_class.h.

◆ USB_HID_SET_REPORT

#define USB_HID_SET_REPORT 0x09

Definition at line 62 of file usbh_hid_class.h.

Enumeration Type Documentation

◆ usb_hid_ctrl_state_type

enum usb_hid_ctrl_state_type

usb hid request state

Enumerator
USB_HID_STATE_IDLE
USB_HID_STATE_GET_DESC
USB_HID_STATE_GET_REPORT
USB_HID_STATE_SET_IDLE
USB_HID_STATE_SET_PROTOCOL
USB_HID_STATE_COMPLETE

Definition at line 69 of file usbh_hid_class.h.

◆ usb_hid_state_type

enum usb_hid_state_type

usb hid process state

Enumerator
USB_HID_INIT
USB_HID_GET
USB_HID_SEND
USB_HID_POLL
USB_HID_BUSY
USB_HID_ERROR

Definition at line 82 of file usbh_hid_class.h.

Variable Documentation

◆ uhost_hid_class_handler

usbh_class_handler_type uhost_hid_class_handler
extern

Definition at line 52 of file usbh_hid_class.c.

Referenced by main().


AT32F435/437 Firmwary Library: usb_hid_desc_type Struct Reference

Data Fields
usb_hid_desc_type Struct Reference
AT32F435_437_middlewares_usbh_class » USBH_hid_class » USBH_hid_class_definition

usb hid descriptor type More...

#include <usbh_hid_class.h>

Data Fields

uint8_t | bLength
uint8_t | bDescriptorType
uint16_t | bcdHID
uint8_t | bCountryCode
uint8_t | bNumDescriptors
uint8_t | bReportDescriptorType
uint16_t | wItemLength

Detailed Description

usb hid descriptor type

Definition at line 95 of file usbh_hid_class.h.

Field Documentation

◆ bcdHID

uint16_t usb_hid_desc_type::bcdHID

Definition at line 99 of file usbh_hid_class.h.

Referenced by usbh_hid_get_desc().

◆ bCountryCode

uint8_t usb_hid_desc_type::bCountryCode

Definition at line 100 of file usbh_hid_class.h.

Referenced by usbh_hid_get_desc().

◆ bDescriptorType

uint8_t usb_hid_desc_type::bDescriptorType

Definition at line 98 of file usbh_hid_class.h.

Referenced by usbh_hid_get_desc().

◆ bLength

uint8_t usb_hid_desc_type::bLength

Definition at line 97 of file usbh_hid_class.h.

Referenced by usbh_hid_get_desc().

◆ bNumDescriptors

uint8_t usb_hid_desc_type::bNumDescriptors

Definition at line 101 of file usbh_hid_class.h.

Referenced by usbh_hid_get_desc().

◆ bReportDescriptorType

uint8_t usb_hid_desc_type::bReportDescriptorType

Definition at line 102 of file usbh_hid_class.h.

Referenced by usbh_hid_get_desc().

◆ wItemLength

uint16_t usb_hid_desc_type::wItemLength

Definition at line 103 of file usbh_hid_class.h.

Referenced by uhost_request_handler(), and usbh_hid_get_desc().

The documentation for this struct was generated from the following file:
  • usbh_hid_class.h


AT32F435/437 Firmwary Library: usbh_hid_type Struct Reference

Data Fields
usbh_hid_type Struct Reference
AT32F435_437_middlewares_usbh_class » USBH_hid_class » USBH_hid_class_definition

usb hid struct More...

#include <usbh_hid_class.h>

Data Fields

uint8_t | chin
uint8_t | eptin
uint16_t | in_maxpacket
uint8_t | in_poll
uint8_t | chout
uint8_t | eptout
uint16_t | out_maxpacket
uint8_t | out_poll
uint8_t | protocol
usb_hid_desc_type hid_desc
usb_hid_ctrl_state_type ctrl_state
usb_hid_state_type state
uint16_t | poll_timer
uint32_t | buffer [16]

Detailed Description

usb hid struct

Definition at line 109 of file usbh_hid_class.h.

Field Documentation

◆ buffer

uint32_t usbh_hid_type::buffer[16]

Definition at line 127 of file usbh_hid_class.h.

Referenced by uhost_process_handler().

◆ chin

uint8_t usbh_hid_type::chin

Definition at line 111 of file usbh_hid_class.h.

Referenced by uhost_init_handler(), uhost_process_handler(), and uhost_reset_handler().

◆ chout

uint8_t usbh_hid_type::chout

Definition at line 116 of file usbh_hid_class.h.

Referenced by uhost_init_handler(), and uhost_reset_handler().

◆ ctrl_state

usb_hid_ctrl_state_type usbh_hid_type::ctrl_state

Definition at line 124 of file usbh_hid_class.h.

Referenced by uhost_init_handler(), and uhost_request_handler().

◆ eptin

uint8_t usbh_hid_type::eptin

Definition at line 112 of file usbh_hid_class.h.

Referenced by uhost_init_handler(), and uhost_process_handler().

◆ eptout

uint8_t usbh_hid_type::eptout

Definition at line 117 of file usbh_hid_class.h.

Referenced by uhost_init_handler().

◆ hid_desc

usb_hid_desc_type usbh_hid_type::hid_desc

Definition at line 123 of file usbh_hid_class.h.

Referenced by uhost_request_handler(), and usbh_hid_get_desc().

◆ in_maxpacket

uint16_t usbh_hid_type::in_maxpacket

Definition at line 113 of file usbh_hid_class.h.

Referenced by uhost_init_handler(), and uhost_process_handler().

◆ in_poll

uint8_t usbh_hid_type::in_poll

Definition at line 114 of file usbh_hid_class.h.

Referenced by uhost_init_handler(), and uhost_process_handler().

◆ out_maxpacket

uint16_t usbh_hid_type::out_maxpacket

Definition at line 118 of file usbh_hid_class.h.

Referenced by uhost_init_handler().

◆ out_poll

uint8_t usbh_hid_type::out_poll

Definition at line 119 of file usbh_hid_class.h.

Referenced by uhost_init_handler().

◆ poll_timer

uint16_t usbh_hid_type::poll_timer

Definition at line 126 of file usbh_hid_class.h.

Referenced by uhost_process_handler().

◆ protocol

uint8_t usbh_hid_type::protocol

Definition at line 120 of file usbh_hid_class.h.

Referenced by uhost_init_handler(), and uhost_process_handler().

◆ state

usb_hid_state_type usbh_hid_type::state

Definition at line 125 of file usbh_hid_class.h.

Referenced by uhost_process_handler(), and uhost_request_handler().

The documentation for this struct was generated from the following file:
  • usbh_hid_class.h


AT32F435/437 Firmwary Library: USBH_hid_class_keyboard

Modules
USBH_hid_class_keyboard
AT32F435_437_middlewares_usbh_class

usb host class hid keyboard More...

Modules

USBH_hid_class_keyboard_private_functions
USBH_hid_class_keyboard_definition

Detailed Description

usb host class hid keyboard


AT32F435/437 Firmwary Library: USBH_hid_class_keyboard_private_functions

Functions | Variables
USBH_hid_class_keyboard_private_functions
AT32F435_437_middlewares_usbh_class » USBH_hid_class_keyboard

Functions

void usbh_hid_keyboard_decode (uint8_t *data)
usb host hid keyboard decode More...

Variables

static const uint8_t | hid_keyboard_codes []
static const int8_t | hid_keyboard_key []
static const int8_t | hid_keyboard_key_shift []

Detailed Description

Function Documentation

◆ usbh_hid_keyboard_decode()

void usbh_hid_keyboard_decode ( uint8_t * data )

usb host hid keyboard decode

Parameters
data keyboard data
Return values
none

Definition at line 145 of file usbh_hid_keyboard.c.

Referenced by uhost_process_handler().

Variable Documentation

◆ hid_keyboard_codes

const uint8_t hid_keyboard_codes[]
static

Definition at line 41 of file usbh_hid_keyboard.c.

Referenced by usbh_hid_keyboard_decode().

◆ hid_keyboard_key

const int8_t hid_keyboard_key[]
static
Initial value:
= {
'\0', '`', '1', '2', '3', '4', '5', '6',
'7', '8', '9', '0', '-', '=', '\0', '\r',
'\t', 'q', 'w', 'e', 'r', 't', 'y', 'u',
'i', 'o', 'p', '[', ']', '\\',
'\0', 'a', 's', 'd', 'f', 'g', 'h', 'j',
'k', 'l', ';', '\'', '\0', '\n',
'\0', '\0', 'z', 'x', 'c', 'v', 'b', 'n',
'm', ',', '.', '/', '\0', '\0',
'\0', '\0', '\0', ' ', '\0', '\0', '\0', '\0',
'\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0',
'\0', '\0', '\0', '\0', '\0', '\r', '\0', '\0',
'\0', '\0', '\0', '\0', '\0', '\0',
'\0', '\0', '7', '4', '1',
'\0', '/', '8', '5', '2',
'0', '*', '9', '6', '3',
'.', '-', '+', '\0', '\n', '\0', '\0', '\0', '\0', '\0', '\0',
'\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0',
'\0', '\0', '\0', '\0'
}

Definition at line 76 of file usbh_hid_keyboard.c.

Referenced by usbh_hid_keyboard_decode().

◆ hid_keyboard_key_shift

const int8_t hid_keyboard_key_shift[]
static
Initial value:
= {
'\0', '~', '!', '@', '#', '$', '%', '^', '&', '*', '(', ')',
'_', '+', '\0', '\0', '\0', 'Q', 'W', 'E', 'R', 'T', 'Y', 'U',
'I', 'O', 'P', '{', '}', '|', '\0', 'A', 'S', 'D', 'F', 'G',
'H', 'J', 'K', 'L', ':', '"', '\0', '\n', '\0', '\0', 'Z', 'X',
'C', 'V', 'B', 'N', 'M', '<', '>', '?', '\0', '\0', '\0', '\0',
'\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0',
'\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0',
'\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0',
'\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0',
'\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0',
'\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0', '\0'
}

Definition at line 97 of file usbh_hid_keyboard.c.

Referenced by usbh_hid_keyboard_decode().


AT32F435/437 Firmwary Library: USBH_hid_class_keyboard_definition

Macros | Functions
USBH_hid_class_keyboard_definition
AT32F435_437_middlewares_usbh_class » USBH_hid_class_keyboard

Macros

#define | KEYBOARD_LEFT_CTRL 0x01
usb keyboard option code More...
#define | KEYBOARD_LEFT_SHIFT 0x02
#define | KEYBOARD_LEFT_ALT 0x04
#define | KEYBOARD_LEFT_GUI 0x08
#define | KEYBOARD_RIGHT_CTRL 0x10
#define | KEYBOARD_RIGHT_SHIFT 0x20
#define | KEYBOARD_RIGHT_ALT 0x40
#define | KEYBOARD_RIGHT_GUI 0x80
#define | KEYBOARD_MAX_NB_PRESSED 6
#define | QWERTY_KEYBOARD

Functions

void usbh_hid_keyboard_decode (uint8_t *data)
usb host hid keyboard decode More...

Detailed Description

Macro Definition Documentation

◆ KEYBOARD_LEFT_ALT

#define KEYBOARD_LEFT_ALT 0x04

Definition at line 53 of file usbh_hid_keyboard.h.

◆ KEYBOARD_LEFT_CTRL

#define KEYBOARD_LEFT_CTRL 0x01

usb keyboard option code

Definition at line 51 of file usbh_hid_keyboard.h.

◆ KEYBOARD_LEFT_GUI

#define KEYBOARD_LEFT_GUI 0x08

Definition at line 54 of file usbh_hid_keyboard.h.

◆ KEYBOARD_LEFT_SHIFT

#define KEYBOARD_LEFT_SHIFT 0x02

Definition at line 52 of file usbh_hid_keyboard.h.

◆ KEYBOARD_MAX_NB_PRESSED

#define KEYBOARD_MAX_NB_PRESSED 6

Definition at line 60 of file usbh_hid_keyboard.h.

◆ KEYBOARD_RIGHT_ALT

#define KEYBOARD_RIGHT_ALT 0x40

Definition at line 57 of file usbh_hid_keyboard.h.

◆ KEYBOARD_RIGHT_CTRL

#define KEYBOARD_RIGHT_CTRL 0x10

Definition at line 55 of file usbh_hid_keyboard.h.

◆ KEYBOARD_RIGHT_GUI

#define KEYBOARD_RIGHT_GUI 0x80

Definition at line 58 of file usbh_hid_keyboard.h.

◆ KEYBOARD_RIGHT_SHIFT

#define KEYBOARD_RIGHT_SHIFT 0x20

Definition at line 56 of file usbh_hid_keyboard.h.

◆ QWERTY_KEYBOARD

#define QWERTY_KEYBOARD

Definition at line 63 of file usbh_hid_keyboard.h.

Function Documentation

◆ usbh_hid_keyboard_decode()

void usbh_hid_keyboard_decode ( uint8_t * data )

usb host hid keyboard decode

Parameters
data keyboard data
Return values
none

Definition at line 145 of file usbh_hid_keyboard.c.

Referenced by uhost_process_handler().


AT32F435/437 Firmwary Library: USBH_hid_class_mouse

Modules
USBH_hid_class_mouse
AT32F435_437_middlewares_usbh_class

usb host class hid mouse More...

Modules

USBH_hid_class_mouse_private_functions
USBH_hid_class_mouse_definition

Detailed Description

usb host class hid mouse


AT32F435/437 Firmwary Library: USBH_hid_class_mouse_private_functions

Functions | Variables
USBH_hid_class_mouse_private_functions
AT32F435_437_middlewares_usbh_class » USBH_hid_class_mouse

Functions

void | usbh_hid_mouse_position (uint8_t x, uint8_t y)
usb host hid position More...
void | usbh_hid_mouse_button_press (uint8_t button)
usb host hid button press More...
void | usbh_hid_mouse_button_release (uint8_t button)
usb host hid button release More...
void | usbh_hid_mouse_process (usb_hid_mouse_type *mouse)
usb host hid mouse process More...
void | usbh_hid_mouse_decode (uint8_t *mouse_data)
usb host hid mouse decode More...

Variables

usb_hid_mouse_type hid_mouse
uint16_t | x_pos = 0
uint16_t | y_pos = 0

Detailed Description

Function Documentation

◆ usbh_hid_mouse_button_press()

void usbh_hid_mouse_button_press ( uint8_t button )

usb host hid button press

Parameters
button button id
Return values
none

Definition at line 84 of file usbh_hid_mouse.c.

Referenced by usbh_hid_mouse_process().

◆ usbh_hid_mouse_button_release()

void usbh_hid_mouse_button_release ( uint8_t button )

usb host hid button release

Parameters
button button id
Return values
none

Definition at line 108 of file usbh_hid_mouse.c.

Referenced by usbh_hid_mouse_process().

◆ usbh_hid_mouse_decode()

void usbh_hid_mouse_decode ( uint8_t * mouse_data )

usb host hid mouse decode

Parameters
mouse_data mouse data
Return values
none

Definition at line 167 of file usbh_hid_mouse.c.

Referenced by uhost_process_handler().

◆ usbh_hid_mouse_position()

void usbh_hid_mouse_position | ( | uint8_t | x,
 |  | uint8_t | y
 | ) |  |

usb host hid position

Parameters
x | x position
y | y position
Return values
none

Definition at line 50 of file usbh_hid_mouse.c.

Referenced by usbh_hid_mouse_process().

◆ usbh_hid_mouse_process()

void usbh_hid_mouse_process ( usb_hid_mouse_type * mouse )

usb host hid mouse process

Parameters
mouse mouse data type
Return values
none

Definition at line 132 of file usbh_hid_mouse.c.

Referenced by usbh_hid_mouse_decode().

Variable Documentation

◆ hid_mouse

usb_hid_mouse_type hid_mouse

Definition at line 41 of file usbh_hid_mouse.c.

Referenced by usbh_hid_mouse_decode().

◆ x_pos

uint16_t x_pos = 0

Definition at line 42 of file usbh_hid_mouse.c.

Referenced by usbh_hid_mouse_position().

◆ y_pos

uint16_t y_pos = 0

Definition at line 42 of file usbh_hid_mouse.c.

Referenced by usbh_hid_mouse_position().


AT32F435/437 Firmwary Library: USBH_hid_class_mouse_definition

Data Structures | Macros | Functions
USBH_hid_class_mouse_definition
AT32F435_437_middlewares_usbh_class » USBH_hid_class_mouse

Data Structures

struct usb_hid_mouse_type
usb hid mouse type More...

Macros

#define | MOUSE_WINDOW_X 100
usb hid mouse x y More...
#define | MOUSE_WINDOW_Y 220
#define | MOUSE_WINDOW_HEIGHT 90
#define | MOUSE_WINDOW_WIDTH 128
#define | MOUSE_BUTTON_LEFT 0x00
usb hid mouse button More...
#define | MOUSE_BUTTON_RIGHT 0x01
#define | MOUSE_BUTTON_MIDDLE 0x02

Functions

void usbh_hid_mouse_decode (uint8_t *mouse_data)
usb host hid mouse decode More...

Detailed Description

Macro Definition Documentation

◆ MOUSE_BUTTON_LEFT

#define MOUSE_BUTTON_LEFT 0x00

usb hid mouse button

Definition at line 59 of file usbh_hid_mouse.h.

◆ MOUSE_BUTTON_MIDDLE

#define MOUSE_BUTTON_MIDDLE 0x02

Definition at line 61 of file usbh_hid_mouse.h.

◆ MOUSE_BUTTON_RIGHT

#define MOUSE_BUTTON_RIGHT 0x01

Definition at line 60 of file usbh_hid_mouse.h.

◆ MOUSE_WINDOW_HEIGHT

#define MOUSE_WINDOW_HEIGHT 90

Definition at line 53 of file usbh_hid_mouse.h.

◆ MOUSE_WINDOW_WIDTH

#define MOUSE_WINDOW_WIDTH 128

Definition at line 54 of file usbh_hid_mouse.h.

◆ MOUSE_WINDOW_X

#define MOUSE_WINDOW_X 100

usb hid mouse x y

Definition at line 51 of file usbh_hid_mouse.h.

◆ MOUSE_WINDOW_Y

#define MOUSE_WINDOW_Y 220

Definition at line 52 of file usbh_hid_mouse.h.

Function Documentation

◆ usbh_hid_mouse_decode()

void usbh_hid_mouse_decode ( uint8_t * mouse_data )

usb host hid mouse decode

Parameters
mouse_data mouse data
Return values
none

Definition at line 167 of file usbh_hid_mouse.c.

Referenced by uhost_process_handler().


AT32F435/437 Firmwary Library: usb_hid_mouse_type Struct Reference

Data Fields
usb_hid_mouse_type Struct Reference
AT32F435_437_middlewares_usbh_class » USBH_hid_class_mouse » USBH_hid_class_mouse_definition

usb hid mouse type More...

#include <usbh_hid_mouse.h>

Data Fields

uint8_t | button
uint8_t | x
uint8_t | y
uint8_t | z

Detailed Description

usb hid mouse type

Definition at line 66 of file usbh_hid_mouse.h.

Field Documentation

◆ button

uint8_t usb_hid_mouse_type::button

Definition at line 68 of file usbh_hid_mouse.h.

Referenced by usbh_hid_mouse_decode(), and usbh_hid_mouse_process().

◆ x

uint8_t usb_hid_mouse_type::x

Definition at line 69 of file usbh_hid_mouse.h.

Referenced by usbh_hid_mouse_decode(), and usbh_hid_mouse_process().

◆ y

uint8_t usb_hid_mouse_type::y

Definition at line 70 of file usbh_hid_mouse.h.

Referenced by usbh_hid_mouse_decode(), and usbh_hid_mouse_process().

◆ z

uint8_t usb_hid_mouse_type::z

Definition at line 71 of file usbh_hid_mouse.h.

Referenced by usbh_hid_mouse_decode().

The documentation for this struct was generated from the following file:
  • usbh_hid_mouse.h


AT32F435/437 Firmwary Library: USBH_msc_bot_scsi_class

Modules
USBH_msc_bot_scsi_class
AT32F435_437_middlewares_usbh_class

usb host class msc bot scsi More...

Modules

USBH_msc_bot_scsi_class_private_functions
USBH_msc_bot_scsi_class_definition

Detailed Description

usb host class msc bot scsi


AT32F435/437 Firmwary Library: USBH_msc_bot_scsi_class_private_functions

Functions
USBH_msc_bot_scsi_class_private_functions
AT32F435_437_middlewares_usbh_class » USBH_msc_bot_scsi_class

Functions

static usb_sts_type | usbh_bot_cbw (msc_bot_cbw_type *cbw, uint32_t data_length, uint8_t cmd_len, uint8_t flag)
usb host bulk-only cbw More...
static usb_sts_type | usbh_cmd_inquiry (msc_bot_trans_type *bot_trans, uint8_t *cmd, uint8_t lun)
usb host msc command inquiry More...
static usb_sts_type | usbh_cmd_capacity10 (msc_bot_trans_type *bot_trans, uint8_t *cmd, uint8_t lun)
usb host msc command capacity10 More...
static usb_sts_type | usbh_cmd_test_unit_ready (msc_bot_trans_type *bot_trans, uint8_t *cmd, uint8_t lun)
usb host msc command test unit ready More...
static usb_sts_type | usbh_cmd_requset_sense (msc_bot_trans_type *bot_trans, uint8_t *cmd, uint8_t lun)
usb host msc command request sense More...
static usb_sts_type | usbh_cmd_write (msc_bot_trans_type *bot_trans, uint8_t *cmd, uint8_t lun, uint32_t data_len, uint32_t address, uint8_t *buffer)
usb host msc command write More...
static usb_sts_type | usbh_cmd_read (msc_bot_trans_type *bot_trans, uint8_t *cmd, uint8_t lun, uint32_t data_len, uint32_t address, uint8_t *buffer)
usb host msc command read More...
usb_sts_type | usbh_check_csw (void *uhost, msc_bot_cbw_type *cbw, msc_bot_csw_type *csw)
usb host csw check More...
usb_sts_type | usb_bot_request (void *uhost, msc_bot_trans_type *bot_trans)
usb host msc bulk-only request More...
usb_sts_type | usbh_msc_bot_scsi_get_inquiry (void *uhost, msc_bot_trans_type *bot_trans, uint8_t lun, msc_scsi_data_inquiry *inquiry)
usb host msc bulk-only get inquiry request More...
usb_sts_type | usbh_msc_bot_scsi_capacity (void *uhost, msc_bot_trans_type *bot_trans, uint8_t lun, msc_scsi_data_capacity *capacity)
usb host msc bulk-only capacity request More...
usb_sts_type | usbh_msc_bot_scsi_test_unit_ready (void *uhost, msc_bot_trans_type *bot_trans, uint8_t lun)
usb host msc bulk-only tet unit ready request More...
usb_sts_type | usbh_msc_bot_scsi_request_sense (void *uhost, msc_bot_trans_type *bot_trans, uint8_t lun)
usb host msc bulk-only request sense request More...
usb_sts_type | usbh_msc_bot_scsi_write (void *uhost, msc_bot_trans_type *bot_trans, uint32_t address, uint8_t *write_data, uint32_t write_len, uint8_t lun)
usb host msc bulk-only write request More...
usb_sts_type | usbh_msc_bot_scsi_read (void *uhost, msc_bot_trans_type *bot_trans, uint32_t address, uint8_t *read_data, uint32_t read_len, uint8_t lun)
usb host msc bulk-only read request More...
usb_sts_type msc_bot_scsi_init (usbh_msc_type *msc_struct)
usb host msc init More...

Detailed Description

Function Documentation

◆ msc_bot_scsi_init()

usb_sts_type msc_bot_scsi_init ( usbh_msc_type * msc_struct )

usb host msc init

Parameters
msc_struct to the structure of usbh_msc_type
Return values
status usb_sts_type status

Definition at line 642 of file usbh_msc_bot_scsi.c.

Referenced by uhost_init_handler().

◆ usb_bot_request()

usb_sts_type usb_bot_request | ( | void * | uhost,
 |  | msc_bot_trans_type * | bot_trans
 | ) |  |

usb host msc bulk-only request

Parameters
uhost | to the structure of usbh_core_type
bot_trans | to the structure of msc_bot_trans_type
Return values
status usb_sts_type status

Definition at line 227 of file usbh_msc_bot_scsi.c.

Referenced by usbh_msc_bot_scsi_capacity(), usbh_msc_bot_scsi_get_inquiry(), usbh_msc_bot_scsi_read(), usbh_msc_bot_scsi_request_sense(), usbh_msc_bot_scsi_test_unit_ready(), and usbh_msc_bot_scsi_write().

◆ usbh_bot_cbw()

static usb_sts_type usbh_bot_cbw | ( | msc_bot_cbw_type * | cbw,
 |  | uint32_t | data_length,
 |  | uint8_t | cmd_len,
 |  | uint8_t | flag
 | ) |  |
static

usb host bulk-only cbw

Parameters
cbw | to the structure of msc_bot_cbw_type
data_length | data length
cmd_len | command len
flag | cbw flag
Return values
status usb_sts_type status

Definition at line 63 of file usbh_msc_bot_scsi.c.

Referenced by usbh_msc_bot_scsi_capacity(), usbh_msc_bot_scsi_get_inquiry(), usbh_msc_bot_scsi_read(), usbh_msc_bot_scsi_request_sense(), usbh_msc_bot_scsi_test_unit_ready(), and usbh_msc_bot_scsi_write().

◆ usbh_check_csw()

usb_sts_type usbh_check_csw | ( | void * | uhost,
 |  | msc_bot_cbw_type * | cbw,
 |  | msc_bot_csw_type * | csw
 | ) |  |

usb host csw check

Parameters
cbw | to the structure of msc_bot_cbw_type
csw | to the structure of msc_bot_csw_type
Return values
status usb_sts_type status

Definition at line 205 of file usbh_msc_bot_scsi.c.

Referenced by usb_bot_request().

◆ usbh_cmd_capacity10()

static usb_sts_type usbh_cmd_capacity10 | ( | msc_bot_trans_type * | bot_trans,
 |  | uint8_t * | cmd,
 |  | uint8_t | lun
 | ) |  |
static

usb host msc command capacity10

Parameters
bot_trans | to the structure of msc_bot_trans_type
cmd | command buffer
lun | logical unit number
Return values
status usb_sts_type status

Definition at line 103 of file usbh_msc_bot_scsi.c.

Referenced by usbh_msc_bot_scsi_capacity().

◆ usbh_cmd_inquiry()

static usb_sts_type usbh_cmd_inquiry | ( | msc_bot_trans_type * | bot_trans,
 |  | uint8_t * | cmd,
 |  | uint8_t | lun
 | ) |  |
static

usb host msc command inquiry

Parameters
bot_trans | to the structure of msc_bot_trans_type
cmd | command buffer
lun | logical unit number
Return values
status usb_sts_type status

Definition at line 85 of file usbh_msc_bot_scsi.c.

Referenced by usbh_msc_bot_scsi_get_inquiry().

◆ usbh_cmd_read()

static usb_sts_type usbh_cmd_read | ( | msc_bot_trans_type * | bot_trans,
 |  | uint8_t * | cmd,
 |  | uint8_t | lun,
 |  | uint32_t | data_len,
 |  | uint32_t | address,
 |  | uint8_t * | buffer
 | ) |  |
static

usb host msc command read

Parameters
bot_trans | to the structure of msc_bot_trans_type
cmd | command buffer
lun | logical unit number
data_len | transfer data length
address | logical block address
buffer | transfer data buffer
Return values
status usb_sts_type status

Definition at line 182 of file usbh_msc_bot_scsi.c.

Referenced by usbh_msc_bot_scsi_read().

◆ usbh_cmd_requset_sense()

static usb_sts_type usbh_cmd_requset_sense | ( | msc_bot_trans_type * | bot_trans,
 |  | uint8_t * | cmd,
 |  | uint8_t | lun
 | ) |  |
static

usb host msc command request sense

Parameters
bot_trans | to the structure of msc_bot_trans_type
cmd | command buffer
lun | logical unit number
Return values
status usb_sts_type status

Definition at line 135 of file usbh_msc_bot_scsi.c.

Referenced by usbh_msc_bot_scsi_request_sense().

◆ usbh_cmd_test_unit_ready()

static usb_sts_type usbh_cmd_test_unit_ready | ( | msc_bot_trans_type * | bot_trans,
 |  | uint8_t * | cmd,
 |  | uint8_t | lun
 | ) |  |
static

usb host msc command test unit ready

Parameters
bot_trans | to the structure of msc_bot_trans_type
cmd | command buffer
lun | logical unit number
Return values
status usb_sts_type status

Definition at line 120 of file usbh_msc_bot_scsi.c.

Referenced by usbh_msc_bot_scsi_test_unit_ready().

◆ usbh_cmd_write()

static usb_sts_type usbh_cmd_write | ( | msc_bot_trans_type * | bot_trans,
 |  | uint8_t * | cmd,
 |  | uint8_t | lun,
 |  | uint32_t | data_len,
 |  | uint32_t | address,
 |  | uint8_t * | buffer
 | ) |  |
static

usb host msc command write

Parameters
bot_trans | to the structure of msc_bot_trans_type
cmd | command buffer
lun | logical unit number
data_len | transfer data length
address | logical block address
buffer | transfer data buffer
Return values
status usb_sts_type status

Definition at line 155 of file usbh_msc_bot_scsi.c.

Referenced by usbh_msc_bot_scsi_write().

◆ usbh_msc_bot_scsi_capacity()

usb_sts_type usbh_msc_bot_scsi_capacity | ( | void * | uhost,
 |  | msc_bot_trans_type * | bot_trans,
 |  | uint8_t | lun,
 |  | msc_scsi_data_capacity * | capacity
 | ) |  |

usb host msc bulk-only capacity request

Parameters
uhost | to the structure of usbh_core_type
bot_trans | to the structure of msc_bot_trans_type
lun | logical unit number
capacity | to the structure of msc_scsi_data_capacity
Return values
status usb_sts_type status

Definition at line 439 of file usbh_msc_bot_scsi.c.

Referenced by uhost_process_handler().

◆ usbh_msc_bot_scsi_get_inquiry()

usb_sts_type usbh_msc_bot_scsi_get_inquiry | ( | void * | uhost,
 |  | msc_bot_trans_type * | bot_trans,
 |  | uint8_t | lun,
 |  | msc_scsi_data_inquiry * | inquiry
 | ) |  |

usb host msc bulk-only get inquiry request

Parameters
uhost | to the structure of usbh_core_type
bot_trans | to the structure of msc_bot_trans_type
lun | logical unit number
inquiry | to the structure of msc_scsi_data_inquiry
Return values
status usb_sts_type status

Definition at line 400 of file usbh_msc_bot_scsi.c.

Referenced by uhost_process_handler().

◆ usbh_msc_bot_scsi_read()

usb_sts_type usbh_msc_bot_scsi_read | ( | void * | uhost,
 |  | msc_bot_trans_type * | bot_trans,
 |  | uint32_t | address,
 |  | uint8_t * | read_data,
 |  | uint32_t | read_len,
 |  | uint8_t | lun
 | ) |  |

usb host msc bulk-only read request

Parameters
uhost | to the structure of usbh_core_type
bot_trans | to the structure of msc_bot_trans_type
address | logical block address
read_data | read data buffer
read_len | read data length
lun | logical unit number
Return values
status usb_sts_type status

Definition at line 604 of file usbh_msc_bot_scsi.c.

Referenced by usbh_msc_rw_handle().

◆ usbh_msc_bot_scsi_request_sense()

usb_sts_type usbh_msc_bot_scsi_request_sense | ( | void * | uhost,
 |  | msc_bot_trans_type * | bot_trans,
 |  | uint8_t | lun
 | ) |  |

usb host msc bulk-only request sense request

Parameters
uhost | to the structure of usbh_core_type
bot_trans | to the structure of msc_bot_trans_type
lun | logical unit number
Return values
status usb_sts_type status

Definition at line 519 of file usbh_msc_bot_scsi.c.

Referenced by uhost_process_handler(), and usbh_msc_rw_handle().

◆ usbh_msc_bot_scsi_test_unit_ready()

usb_sts_type usbh_msc_bot_scsi_test_unit_ready | ( | void * | uhost,
 |  | msc_bot_trans_type * | bot_trans,
 |  | uint8_t | lun
 | ) |  |

usb host msc bulk-only tet unit ready request

Parameters
uhost | to the structure of usbh_core_type
bot_trans | to the structure of msc_bot_trans_type
lun | logical unit number
Return values
status usb_sts_type status

Definition at line 480 of file usbh_msc_bot_scsi.c.

Referenced by uhost_process_handler().

◆ usbh_msc_bot_scsi_write()

usb_sts_type usbh_msc_bot_scsi_write | ( | void * | uhost,
 |  | msc_bot_trans_type * | bot_trans,
 |  | uint32_t | address,
 |  | uint8_t * | write_data,
 |  | uint32_t | write_len,
 |  | uint8_t | lun
 | ) |  |

usb host msc bulk-only write request

Parameters
uhost | to the structure of usbh_core_type
bot_trans | to the structure of msc_bot_trans_type
address | logical block address
write_data | write data buffer
write_len | write data length
lun | logical unit number
Return values
status usb_sts_type status

Definition at line 561 of file usbh_msc_bot_scsi.c.

Referenced by usbh_msc_rw_handle().


AT32F435/437 Firmwary Library: USBH_msc_bot_scsi_class_definition

Data Structures | Macros | Enumerations | Functions
USBH_msc_bot_scsi_class_definition
AT32F435_437_middlewares_usbh_class » USBH_msc_bot_scsi_class

Data Structures

struct | msc_scsi_data_inquiry
usb msc inquiry data type More...
struct | msc_scsi_data_capacity
usb msc capacity data type More...
struct | msc_bot_cbw_type
usb msc bulk-only command block wrapper type More...
struct | msc_bot_csw_type
usb msc bulk-only command status wrapper type More...
struct | msc_bot_trans_type
usb msc bulk-only transfer control type More...
struct | usbh_msc_unit_type
usb msc bank type More...

Macros

#define | MSC_CBW_SIGNATURE 0x43425355
#define | MSC_CSW_SIGNATURE 0x53425355
#define | MSC_CBW_TAG 0x50607080
#define | MSC_CBW_FLAG_IN 0x80
#define | MSC_CBW_FLAG_OUT 0x00
#define | MSC_CBW_LEN 31
#define | MSC_CSW_LEN 13
#define | MSC_CBW_CB_LEN 16
#define | MSC_TEST_UNIT_READY_CMD_LEN 12
#define | MSC_TEST_UNIT_READY_DATA_LEN 0
#define | MSC_INQUIRY_CMD_LEN 12
#define | MSC_INQUIRY_DATA_LEN 36
#define | MSC_CAPACITY10_CMD_LEN 12
#define | MSC_CAPACITY10_DATA_LEN 8
#define | MSC_REQUEST_SENSE_CMD_LEN 12
#define | MSC_REQUEST_SENSE_DATA_LEN 18
#define | MSC_WRITE_CMD_LEN 12
#define | MSC_READ_CMD_LEN 10
#define | MSC_OPCODE_INQUIRY 0x12
#define | MSC_OPCODE_CAPACITY 0x25
#define | MSC_OPCODE_TEST_UNIT_READY 0x00
#define | MSC_OPCODE_REQUEST_SENSE 0x03
#define | MSC_OPCODE_WRITE10 0x2A
#define | MSC_OPCODE_READ10 0x28

Enumerations

enum msc_bot_state_type {
BOT_STATE_IDLE , BOT_STATE_SEND_CBW , BOT_STATE_SEND_CBW_WAIT , BOT_STATE_DATA_IN ,
BOT_STATE_DATA_IN_WAIT , BOT_STATE_DATA_OUT , BOT_STATE_DATA_OUT_WAIT , BOT_STATE_RECV_CSW ,
BOT_STATE_RECV_CSW_WAIT , BOT_STATE_ERROR_IN , BOT_STATE_ERROR_OUT , BOT_STATE_COMPLETE
}
enum | msc_cmd_state_type { CMD_STATE_SEND , CMD_STATE_WAIT }
enum msc_state_type {
USBH_MSC_INIT , USBH_MSC_INQUIRY , USBH_MSC_TEST_UNIT_READY , USBH_MSC_READ_CAPACITY10 ,
USBH_MSC_REQUEST_SENSE , USBH_MSC_READ10 , USBH_MSC_WRITE , USBH_MSC_BUSY ,
USBH_MSC_ERROR , USBH_MSC_IDLE
}
usb msc process state More...
enum | msc_error_type { MSC_OK , MSC_NOT_READY , MSC_ERROR }

Functions

usb_sts_type | usb_bot_request (void *uhost, msc_bot_trans_type *bot_trans)
usb host msc bulk-only request More...
usb_sts_type | usbh_msc_bot_scsi_get_inquiry (void *uhost, msc_bot_trans_type *bot_trans, uint8_t lun, msc_scsi_data_inquiry *inquiry)
usb host msc bulk-only get inquiry request More...
usb_sts_type | usbh_msc_bot_scsi_capacity (void *uhost, msc_bot_trans_type *bot_trans, uint8_t lun, msc_scsi_data_capacity *capacity)
usb host msc bulk-only capacity request More...
usb_sts_type | usbh_msc_bot_scsi_test_unit_ready (void *uhost, msc_bot_trans_type *bot_trans, uint8_t lun)
usb host msc bulk-only tet unit ready request More...
usb_sts_type | usbh_msc_bot_scsi_request_sense (void *uhost, msc_bot_trans_type *bot_trans, uint8_t lun)
usb host msc bulk-only request sense request More...
usb_sts_type | usbh_msc_bot_scsi_write (void *uhost, msc_bot_trans_type *bot_trans, uint32_t address, uint8_t *write_data, uint32_t write_len, uint8_t lun)
usb host msc bulk-only write request More...
usb_sts_type | usbh_msc_bot_scsi_read (void *uhost, msc_bot_trans_type *bot_trans, uint32_t address, uint8_t *read_data, uint32_t read_len, uint8_t lun)
usb host msc bulk-only read request More...

Detailed Description

Macro Definition Documentation

◆ MSC_CAPACITY10_CMD_LEN

#define MSC_CAPACITY10_CMD_LEN 12

Definition at line 62 of file usbh_msc_bot_scsi.h.

◆ MSC_CAPACITY10_DATA_LEN

#define MSC_CAPACITY10_DATA_LEN 8

Definition at line 63 of file usbh_msc_bot_scsi.h.

◆ MSC_CBW_CB_LEN

#define MSC_CBW_CB_LEN 16

Definition at line 57 of file usbh_msc_bot_scsi.h.

◆ MSC_CBW_FLAG_IN

#define MSC_CBW_FLAG_IN 0x80

Definition at line 52 of file usbh_msc_bot_scsi.h.

◆ MSC_CBW_FLAG_OUT

#define MSC_CBW_FLAG_OUT 0x00

Definition at line 53 of file usbh_msc_bot_scsi.h.

◆ MSC_CBW_LEN

#define MSC_CBW_LEN 31

Definition at line 55 of file usbh_msc_bot_scsi.h.

◆ MSC_CBW_SIGNATURE

#define MSC_CBW_SIGNATURE 0x43425355

Definition at line 49 of file usbh_msc_bot_scsi.h.

◆ MSC_CBW_TAG

#define MSC_CBW_TAG 0x50607080

Definition at line 51 of file usbh_msc_bot_scsi.h.

◆ MSC_CSW_LEN

#define MSC_CSW_LEN 13

Definition at line 56 of file usbh_msc_bot_scsi.h.

◆ MSC_CSW_SIGNATURE

#define MSC_CSW_SIGNATURE 0x53425355

Definition at line 50 of file usbh_msc_bot_scsi.h.

◆ MSC_INQUIRY_CMD_LEN

#define MSC_INQUIRY_CMD_LEN 12

Definition at line 60 of file usbh_msc_bot_scsi.h.

◆ MSC_INQUIRY_DATA_LEN

#define MSC_INQUIRY_DATA_LEN 36

Definition at line 61 of file usbh_msc_bot_scsi.h.

◆ MSC_OPCODE_CAPACITY

#define MSC_OPCODE_CAPACITY 0x25

Definition at line 70 of file usbh_msc_bot_scsi.h.

◆ MSC_OPCODE_INQUIRY

#define MSC_OPCODE_INQUIRY 0x12

Definition at line 69 of file usbh_msc_bot_scsi.h.

◆ MSC_OPCODE_READ10

#define MSC_OPCODE_READ10 0x28

Definition at line 74 of file usbh_msc_bot_scsi.h.

◆ MSC_OPCODE_REQUEST_SENSE

#define MSC_OPCODE_REQUEST_SENSE 0x03

Definition at line 72 of file usbh_msc_bot_scsi.h.

◆ MSC_OPCODE_TEST_UNIT_READY

#define MSC_OPCODE_TEST_UNIT_READY 0x00

Definition at line 71 of file usbh_msc_bot_scsi.h.

◆ MSC_OPCODE_WRITE10

#define MSC_OPCODE_WRITE10 0x2A

Definition at line 73 of file usbh_msc_bot_scsi.h.

◆ MSC_READ_CMD_LEN

#define MSC_READ_CMD_LEN 10

Definition at line 67 of file usbh_msc_bot_scsi.h.

◆ MSC_REQUEST_SENSE_CMD_LEN

#define MSC_REQUEST_SENSE_CMD_LEN 12

Definition at line 64 of file usbh_msc_bot_scsi.h.

◆ MSC_REQUEST_SENSE_DATA_LEN

#define MSC_REQUEST_SENSE_DATA_LEN 18

Definition at line 65 of file usbh_msc_bot_scsi.h.

◆ MSC_TEST_UNIT_READY_CMD_LEN

#define MSC_TEST_UNIT_READY_CMD_LEN 12

Definition at line 58 of file usbh_msc_bot_scsi.h.

◆ MSC_TEST_UNIT_READY_DATA_LEN

#define MSC_TEST_UNIT_READY_DATA_LEN 0

Definition at line 59 of file usbh_msc_bot_scsi.h.

◆ MSC_WRITE_CMD_LEN

#define MSC_WRITE_CMD_LEN 12

Definition at line 66 of file usbh_msc_bot_scsi.h.

Enumeration Type Documentation

◆ msc_bot_state_type

enum msc_bot_state_type
Enumerator
BOT_STATE_IDLE
BOT_STATE_SEND_CBW
BOT_STATE_SEND_CBW_WAIT
BOT_STATE_DATA_IN
BOT_STATE_DATA_IN_WAIT
BOT_STATE_DATA_OUT
BOT_STATE_DATA_OUT_WAIT
BOT_STATE_RECV_CSW
BOT_STATE_RECV_CSW_WAIT
BOT_STATE_ERROR_IN
BOT_STATE_ERROR_OUT
BOT_STATE_COMPLETE

Definition at line 76 of file usbh_msc_bot_scsi.h.

◆ msc_cmd_state_type

enum msc_cmd_state_type
Enumerator
CMD_STATE_SEND
CMD_STATE_WAIT

Definition at line 92 of file usbh_msc_bot_scsi.h.

◆ msc_error_type

enum msc_error_type
Enumerator
MSC_OK
MSC_NOT_READY
MSC_ERROR

Definition at line 115 of file usbh_msc_bot_scsi.h.

◆ msc_state_type

enum msc_state_type

usb msc process state

Enumerator
USBH_MSC_INIT
USBH_MSC_INQUIRY
USBH_MSC_TEST_UNIT_READY
USBH_MSC_READ_CAPACITY10
USBH_MSC_REQUEST_SENSE
USBH_MSC_READ10
USBH_MSC_WRITE
USBH_MSC_BUSY
USBH_MSC_ERROR
USBH_MSC_IDLE

Definition at line 101 of file usbh_msc_bot_scsi.h.

Function Documentation

◆ usb_bot_request()

usb_sts_type usb_bot_request | ( | void * | uhost,
 |  | msc_bot_trans_type * | bot_trans
 | ) |  |

usb host msc bulk-only request

Parameters
uhost | to the structure of usbh_core_type
bot_trans | to the structure of msc_bot_trans_type
Return values
status usb_sts_type status

Definition at line 227 of file usbh_msc_bot_scsi.c.

Referenced by usbh_msc_bot_scsi_capacity(), usbh_msc_bot_scsi_get_inquiry(), usbh_msc_bot_scsi_read(), usbh_msc_bot_scsi_request_sense(), usbh_msc_bot_scsi_test_unit_ready(), and usbh_msc_bot_scsi_write().

◆ usbh_msc_bot_scsi_capacity()

usb_sts_type usbh_msc_bot_scsi_capacity | ( | void * | uhost,
 |  | msc_bot_trans_type * | bot_trans,
 |  | uint8_t | lun,
 |  | msc_scsi_data_capacity * | capacity
 | ) |  |

usb host msc bulk-only capacity request

Parameters
uhost | to the structure of usbh_core_type
bot_trans | to the structure of msc_bot_trans_type
lun | logical unit number
capacity | to the structure of msc_scsi_data_capacity
Return values
status usb_sts_type status

Definition at line 439 of file usbh_msc_bot_scsi.c.

Referenced by uhost_process_handler().

◆ usbh_msc_bot_scsi_get_inquiry()

usb_sts_type usbh_msc_bot_scsi_get_inquiry | ( | void * | uhost,
 |  | msc_bot_trans_type * | bot_trans,
 |  | uint8_t | lun,
 |  | msc_scsi_data_inquiry * | inquiry
 | ) |  |

usb host msc bulk-only get inquiry request

Parameters
uhost | to the structure of usbh_core_type
bot_trans | to the structure of msc_bot_trans_type
lun | logical unit number
inquiry | to the structure of msc_scsi_data_inquiry
Return values
status usb_sts_type status

Definition at line 400 of file usbh_msc_bot_scsi.c.

Referenced by uhost_process_handler().

◆ usbh_msc_bot_scsi_read()

usb_sts_type usbh_msc_bot_scsi_read | ( | void * | uhost,
 |  | msc_bot_trans_type * | bot_trans,
 |  | uint32_t | address,
 |  | uint8_t * | read_data,
 |  | uint32_t | read_len,
 |  | uint8_t | lun
 | ) |  |

usb host msc bulk-only read request

Parameters
uhost | to the structure of usbh_core_type
bot_trans | to the structure of msc_bot_trans_type
address | logical block address
read_data | read data buffer
read_len | read data length
lun | logical unit number
Return values
status usb_sts_type status

Definition at line 604 of file usbh_msc_bot_scsi.c.

Referenced by usbh_msc_rw_handle().

◆ usbh_msc_bot_scsi_request_sense()

usb_sts_type usbh_msc_bot_scsi_request_sense | ( | void * | uhost,
 |  | msc_bot_trans_type * | bot_trans,
 |  | uint8_t | lun
 | ) |  |

usb host msc bulk-only request sense request

Parameters
uhost | to the structure of usbh_core_type
bot_trans | to the structure of msc_bot_trans_type
lun | logical unit number
Return values
status usb_sts_type status

Definition at line 519 of file usbh_msc_bot_scsi.c.

Referenced by uhost_process_handler(), and usbh_msc_rw_handle().

◆ usbh_msc_bot_scsi_test_unit_ready()

usb_sts_type usbh_msc_bot_scsi_test_unit_ready | ( | void * | uhost,
 |  | msc_bot_trans_type * | bot_trans,
 |  | uint8_t | lun
 | ) |  |

usb host msc bulk-only tet unit ready request

Parameters
uhost | to the structure of usbh_core_type
bot_trans | to the structure of msc_bot_trans_type
lun | logical unit number
Return values
status usb_sts_type status

Definition at line 480 of file usbh_msc_bot_scsi.c.

Referenced by uhost_process_handler().

◆ usbh_msc_bot_scsi_write()

usb_sts_type usbh_msc_bot_scsi_write | ( | void * | uhost,
 |  | msc_bot_trans_type * | bot_trans,
 |  | uint32_t | address,
 |  | uint8_t * | write_data,
 |  | uint32_t | write_len,
 |  | uint8_t | lun
 | ) |  |

usb host msc bulk-only write request

Parameters
uhost | to the structure of usbh_core_type
bot_trans | to the structure of msc_bot_trans_type
address | logical block address
write_data | write data buffer
write_len | write data length
lun | logical unit number
Return values
status usb_sts_type status

Definition at line 561 of file usbh_msc_bot_scsi.c.

Referenced by usbh_msc_rw_handle().


AT32F435/437 Firmwary Library: msc_scsi_data_inquiry Struct Reference

Data Fields
msc_scsi_data_inquiry Struct Reference
AT32F435_437_middlewares_usbh_class » USBH_msc_bot_scsi_class » USBH_msc_bot_scsi_class_definition

usb msc inquiry data type More...

#include <usbh_msc_bot_scsi.h>

Data Fields

uint8_t | pdev_type
uint8_t | rmb
uint8_t | version
uint8_t | data_format
uint8_t | length
uint8_t | reserved [3]
uint8_t | vendor [8]
uint8_t | product [16]
uint8_t | revision [4]

Detailed Description

usb msc inquiry data type

Definition at line 126 of file usbh_msc_bot_scsi.h.

Field Documentation

◆ data_format

uint8_t msc_scsi_data_inquiry::data_format

Definition at line 131 of file usbh_msc_bot_scsi.h.

◆ length

uint8_t msc_scsi_data_inquiry::length

Definition at line 132 of file usbh_msc_bot_scsi.h.

◆ pdev_type

uint8_t msc_scsi_data_inquiry::pdev_type

Definition at line 128 of file usbh_msc_bot_scsi.h.

◆ product

uint8_t msc_scsi_data_inquiry::product[16]

Definition at line 135 of file usbh_msc_bot_scsi.h.

◆ reserved

uint8_t msc_scsi_data_inquiry::reserved[3]

Definition at line 133 of file usbh_msc_bot_scsi.h.

◆ revision

uint8_t msc_scsi_data_inquiry::revision[4]

Definition at line 136 of file usbh_msc_bot_scsi.h.

◆ rmb

uint8_t msc_scsi_data_inquiry::rmb

Definition at line 129 of file usbh_msc_bot_scsi.h.

◆ vendor

uint8_t msc_scsi_data_inquiry::vendor[8]

Definition at line 134 of file usbh_msc_bot_scsi.h.

◆ version

uint8_t msc_scsi_data_inquiry::version

Definition at line 130 of file usbh_msc_bot_scsi.h.

The documentation for this struct was generated from the following file:
  • usbh_msc_bot_scsi.h


AT32F435/437 Firmwary Library: msc_scsi_data_capacity Struct Reference

Data Fields
msc_scsi_data_capacity Struct Reference
AT32F435_437_middlewares_usbh_class » USBH_msc_bot_scsi_class » USBH_msc_bot_scsi_class_definition

usb msc capacity data type More...

#include <usbh_msc_bot_scsi.h>

Data Fields

uint32_t | blk_nbr
uint32_t | blk_size

Detailed Description

usb msc capacity data type

Definition at line 143 of file usbh_msc_bot_scsi.h.

Field Documentation

◆ blk_nbr

uint32_t msc_scsi_data_capacity::blk_nbr

Definition at line 145 of file usbh_msc_bot_scsi.h.

Referenced by disk_ioctl(), uhost_process_handler(), and usbh_msc_bot_scsi_capacity().

◆ blk_size

uint32_t msc_scsi_data_capacity::blk_size

Definition at line 146 of file usbh_msc_bot_scsi.h.

Referenced by uhost_process_handler(), and usbh_msc_bot_scsi_capacity().

The documentation for this struct was generated from the following file:
  • usbh_msc_bot_scsi.h


AT32F435/437 Firmwary Library: msc_bot_cbw_type Struct Reference

Data Fields
msc_bot_cbw_type Struct Reference
AT32F435_437_middlewares_usbh_class » USBH_msc_bot_scsi_class » USBH_msc_bot_scsi_class_definition

usb msc bulk-only command block wrapper type More...

#include <usbh_msc_bot_scsi.h>

Data Fields

uint32_t | dCBWSignature
uint32_t | dCBWTag
uint32_t | dCBWDataTransferLength
uint8_t | bmCBWFlags
uint8_t | bCBWLUN
uint8_t | bCBWCBLength
uint8_t | CBWCB [16]

Detailed Description

usb msc bulk-only command block wrapper type

Definition at line 152 of file usbh_msc_bot_scsi.h.

Field Documentation

◆ bCBWCBLength

uint8_t msc_bot_cbw_type::bCBWCBLength

Definition at line 159 of file usbh_msc_bot_scsi.h.

Referenced by usbh_bot_cbw().

◆ bCBWLUN

uint8_t msc_bot_cbw_type::bCBWLUN

Definition at line 158 of file usbh_msc_bot_scsi.h.

Referenced by usbh_msc_bot_scsi_capacity(), usbh_msc_bot_scsi_get_inquiry(), usbh_msc_bot_scsi_read(), usbh_msc_bot_scsi_request_sense(), usbh_msc_bot_scsi_test_unit_ready(), and usbh_msc_bot_scsi_write().

◆ bmCBWFlags

uint8_t msc_bot_cbw_type::bmCBWFlags

Definition at line 157 of file usbh_msc_bot_scsi.h.

Referenced by usb_bot_request(), and usbh_bot_cbw().

◆ CBWCB

uint8_t msc_bot_cbw_type::CBWCB[16]

Definition at line 160 of file usbh_msc_bot_scsi.h.

Referenced by usbh_bot_cbw(), usbh_msc_bot_scsi_capacity(), usbh_msc_bot_scsi_get_inquiry(), usbh_msc_bot_scsi_read(), usbh_msc_bot_scsi_request_sense(), usbh_msc_bot_scsi_test_unit_ready(), and usbh_msc_bot_scsi_write().

◆ dCBWDataTransferLength

uint32_t msc_bot_cbw_type::dCBWDataTransferLength

Definition at line 156 of file usbh_msc_bot_scsi.h.

Referenced by usb_bot_request(), and usbh_bot_cbw().

◆ dCBWSignature

uint32_t msc_bot_cbw_type::dCBWSignature

Definition at line 154 of file usbh_msc_bot_scsi.h.

Referenced by usbh_bot_cbw().

◆ dCBWTag

uint32_t msc_bot_cbw_type::dCBWTag

Definition at line 155 of file usbh_msc_bot_scsi.h.

Referenced by usbh_bot_cbw(), and usbh_check_csw().

The documentation for this struct was generated from the following file:
  • usbh_msc_bot_scsi.h


AT32F435/437 Firmwary Library: msc_bot_csw_type Struct Reference

Data Fields
msc_bot_csw_type Struct Reference
AT32F435_437_middlewares_usbh_class » USBH_msc_bot_scsi_class » USBH_msc_bot_scsi_class_definition

usb msc bulk-only command status wrapper type More...

#include <usbh_msc_bot_scsi.h>

Data Fields

uint32_t | dCBWSignature
uint32_t | dCBWTag
uint32_t | dCSWDataResidue
uint8_t | bCSWStatus

Detailed Description

usb msc bulk-only command status wrapper type

Definition at line 166 of file usbh_msc_bot_scsi.h.

Field Documentation

◆ bCSWStatus

uint8_t msc_bot_csw_type::bCSWStatus

Definition at line 171 of file usbh_msc_bot_scsi.h.

Referenced by usbh_check_csw().

◆ dCBWSignature

uint32_t msc_bot_csw_type::dCBWSignature

Definition at line 168 of file usbh_msc_bot_scsi.h.

Referenced by usbh_check_csw().

◆ dCBWTag

uint32_t msc_bot_csw_type::dCBWTag

Definition at line 169 of file usbh_msc_bot_scsi.h.

Referenced by usbh_check_csw().

◆ dCSWDataResidue

uint32_t msc_bot_csw_type::dCSWDataResidue

Definition at line 170 of file usbh_msc_bot_scsi.h.

The documentation for this struct was generated from the following file:
  • usbh_msc_bot_scsi.h


AT32F435/437 Firmwary Library: msc_bot_trans_type Struct Reference

Data Fields
msc_bot_trans_type Struct Reference
AT32F435_437_middlewares_usbh_class » USBH_msc_bot_scsi_class » USBH_msc_bot_scsi_class_definition

usb msc bulk-only transfer control type More...

#include <usbh_msc_bot_scsi.h>

Data Fields

uint8_t | buffer [32]
msc_bot_cbw_type cbw
msc_bot_csw_type csw
msc_cmd_state_type cmd_state
msc_bot_state_type bot_state
uint8_t * | data
void * | msc_struct

Detailed Description

usb msc bulk-only transfer control type

Definition at line 177 of file usbh_msc_bot_scsi.h.

Field Documentation

◆ bot_state

msc_bot_state_type msc_bot_trans_type::bot_state

Definition at line 183 of file usbh_msc_bot_scsi.h.

Referenced by usb_bot_request(), usbh_msc_bot_scsi_capacity(), usbh_msc_bot_scsi_get_inquiry(), usbh_msc_bot_scsi_read(), usbh_msc_bot_scsi_request_sense(), usbh_msc_bot_scsi_test_unit_ready(), and usbh_msc_bot_scsi_write().

◆ buffer

uint8_t msc_bot_trans_type::buffer[32]

Definition at line 179 of file usbh_msc_bot_scsi.h.

Referenced by usbh_cmd_capacity10(), usbh_cmd_requset_sense(), and usbh_msc_bot_scsi_capacity().

◆ cbw

msc_bot_cbw_type msc_bot_trans_type::cbw

Definition at line 180 of file usbh_msc_bot_scsi.h.

Referenced by usb_bot_request(), usbh_msc_bot_scsi_capacity(), usbh_msc_bot_scsi_get_inquiry(), usbh_msc_bot_scsi_read(), usbh_msc_bot_scsi_request_sense(), usbh_msc_bot_scsi_test_unit_ready(), and usbh_msc_bot_scsi_write().

◆ cmd_state

msc_cmd_state_type msc_bot_trans_type::cmd_state

Definition at line 182 of file usbh_msc_bot_scsi.h.

Referenced by usb_bot_request(), usbh_msc_bot_scsi_capacity(), usbh_msc_bot_scsi_get_inquiry(), usbh_msc_bot_scsi_read(), usbh_msc_bot_scsi_request_sense(), usbh_msc_bot_scsi_test_unit_ready(), and usbh_msc_bot_scsi_write().

◆ csw

msc_bot_csw_type msc_bot_trans_type::csw

Definition at line 181 of file usbh_msc_bot_scsi.h.

Referenced by usb_bot_request().

◆ data

uint8_t* msc_bot_trans_type::data

Definition at line 184 of file usbh_msc_bot_scsi.h.

Referenced by usb_bot_request(), usbh_cmd_inquiry(), usbh_cmd_read(), usbh_cmd_requset_sense(), and usbh_cmd_write().

◆ msc_struct

void* msc_bot_trans_type::msc_struct

Definition at line 185 of file usbh_msc_bot_scsi.h.

Referenced by usb_bot_request(), usbh_cmd_capacity10(), usbh_cmd_inquiry(), usbh_msc_read(), and usbh_msc_write().

The documentation for this struct was generated from the following file:
  • usbh_msc_bot_scsi.h


AT32F435/437 Firmwary Library: usbh_msc_unit_type Struct Reference

Data Fields
usbh_msc_unit_type Struct Reference
AT32F435_437_middlewares_usbh_class » USBH_msc_bot_scsi_class » USBH_msc_bot_scsi_class_definition

usb msc bank type More...

#include <usbh_msc_bot_scsi.h>

Data Fields

msc_scsi_data_inquiry inquiry
msc_scsi_data_capacity capacity
msc_state_type state
msc_error_type ready
usb_sts_type pre_state
uint8_t change

Detailed Description

usb msc bank type

Definition at line 191 of file usbh_msc_bot_scsi.h.

Field Documentation

◆ capacity

msc_scsi_data_capacity usbh_msc_unit_type::capacity

Definition at line 194 of file usbh_msc_bot_scsi.h.

Referenced by disk_ioctl(), and uhost_process_handler().

◆ change

uint8_t usbh_msc_unit_type::change

Definition at line 198 of file usbh_msc_bot_scsi.h.

Referenced by uhost_request_handler(), and uhost_reset_handler().

◆ inquiry

msc_scsi_data_inquiry usbh_msc_unit_type::inquiry

Definition at line 193 of file usbh_msc_bot_scsi.h.

Referenced by uhost_process_handler().

◆ pre_state

usb_sts_type usbh_msc_unit_type::pre_state

Definition at line 197 of file usbh_msc_bot_scsi.h.

Referenced by uhost_request_handler(), and uhost_reset_handler().

◆ ready

msc_error_type usbh_msc_unit_type::ready

Definition at line 196 of file usbh_msc_bot_scsi.h.

Referenced by uhost_process_handler(), uhost_reset_handler(), and usbh_msc_is_ready().

◆ state

msc_state_type usbh_msc_unit_type::state

Definition at line 195 of file usbh_msc_bot_scsi.h.

Referenced by uhost_process_handler(), uhost_request_handler(), uhost_reset_handler(), usbh_msc_read(), usbh_msc_rw_handle(), and usbh_msc_write().

The documentation for this struct was generated from the following file:
  • usbh_msc_bot_scsi.h


AT32F435/437 Firmwary Library: USBH_msc_class

Modules
USBH_msc_class
AT32F435_437_middlewares_usbh_class

usb host class msc demo More...

Modules

USBH_msc_class_private_functions
USBH_msc_class_definition

Detailed Description

usb host class msc demo


AT32F435/437 Firmwary Library: USBH_msc_class_private_functions

Functions | Variables
USBH_msc_class_private_functions
AT32F435_437_middlewares_usbh_class » USBH_msc_class

Functions

static usb_sts_type | uhost_init_handler (void *uhost)
usb host class init handler More...
static usb_sts_type | uhost_reset_handler (void *uhost)
usb host class reset handler More...
static usb_sts_type | uhost_request_handler (void *uhost)
usb host hid class request handler More...
static usb_sts_type | uhost_process_handler (void *uhost)
usb host class process handler More...
static usb_sts_type | usbh_msc_get_max_lun (void *uhost, uint8_t *lun)
usb host msc get max lun More...
static usb_sts_type | usbh_msc_clear_feature (void *uhost, uint8_t ept_num)
usb host msc clear feature More...
msc_error_type | usbh_msc_is_ready (void *uhost, uint8_t lun)
usb host msc clear feature More...
usb_sts_type | usbh_msc_rw_handle (void *uhost, uint32_t address, uint32_t len, uint8_t *buffer, uint8_t lun)
usb host msc read and write handle More...
usb_sts_type | usbh_msc_read (void *uhost, uint32_t address, uint32_t len, uint8_t *buffer, uint8_t lun)
usb host msc read More...
usb_sts_type | usbh_msc_write (void *uhost, uint32_t address, uint32_t len, uint8_t *buffer, uint8_t lun)
usb host msc write More...

Variables

usbh_msc_type usbh_msc
usbh_class_handler_type uhost_msc_class_handler

Detailed Description

Function Documentation

◆ uhost_init_handler()

static usb_sts_type uhost_init_handler ( void * uhost )
static

usb host class init handler

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 71 of file usbh_msc_class.c.

◆ uhost_process_handler()

static usb_sts_type uhost_process_handler ( void * uhost )
static

usb host class process handler

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 213 of file usbh_msc_class.c.

◆ uhost_request_handler()

static usb_sts_type uhost_request_handler ( void * uhost )
static

usb host hid class request handler

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 170 of file usbh_msc_class.c.

◆ uhost_reset_handler()

static usb_sts_type uhost_reset_handler ( void * uhost )
static

usb host class reset handler

Parameters
uhost to the structure of usbh_core_type
Return values
status usb_sts_type status

Definition at line 128 of file usbh_msc_class.c.

◆ usbh_msc_clear_feature()

static usb_sts_type usbh_msc_clear_feature | ( | void * | uhost,
 |  | uint8_t | ept_num
 | ) |  |
static

usb host msc clear feature

Parameters
uhost | to the structure of usbh_core_type
ept_num | endpoint number
Return values
status usb_sts_type status

Definition at line 346 of file usbh_msc_class.c.

Referenced by uhost_request_handler().

◆ usbh_msc_get_max_lun()

static usb_sts_type usbh_msc_get_max_lun | ( | void * | uhost,
 |  | uint8_t * | lun
 | ) |  |
static

usb host msc get max lun

Parameters
uhost | to the structure of usbh_core_type
lun | max lun buffer
Return values
status usb_sts_type status

Definition at line 316 of file usbh_msc_class.c.

Referenced by uhost_request_handler().

◆ usbh_msc_is_ready()

msc_error_type usbh_msc_is_ready | ( | void * | uhost,
 |  | uint8_t | lun
 | ) |  |

usb host msc clear feature

Parameters
lun logical unit number
Return values
msc_error_type status

Definition at line 375 of file usbh_msc_class.c.

Referenced by disk_status().

◆ usbh_msc_read()

usb_sts_type usbh_msc_read | ( | void * | uhost,
 |  | uint32_t | address,
 |  | uint32_t | len,
 |  | uint8_t * | buffer,
 |  | uint8_t | lun
 | ) |  |

usb host msc read

Parameters
uhost | to the structure of usbh_core_type
address | logical block address
data_len | transfer data length
buffer | transfer data buffer
lun | logical unit number
Return values
status usb_sts_type status

Definition at line 450 of file usbh_msc_class.c.

Referenced by disk_read().

◆ usbh_msc_rw_handle()

usb_sts_type usbh_msc_rw_handle | ( | void * | uhost,
 |  | uint32_t | address,
 |  | uint32_t | len,
 |  | uint8_t * | buffer,
 |  | uint8_t | lun
 | ) |  |

usb host msc read and write handle

Parameters
uhost | to the structure of usbh_core_type
address | logical block address
data_len | transfer data length
buffer | transfer data buffer
lun | logical unit number
Return values
status usb_sts_type status

Definition at line 392 of file usbh_msc_class.c.

Referenced by usbh_msc_read(), and usbh_msc_write().

◆ usbh_msc_write()

usb_sts_type usbh_msc_write | ( | void * | uhost,
 |  | uint32_t | address,
 |  | uint32_t | len,
 |  | uint8_t * | buffer,
 |  | uint8_t | lun
 | ) |  |

usb host msc write

Parameters
uhost | to the structure of usbh_core_type
address | logical block address
data_len | transfer data length
buffer | transfer data buffer
lun | logical unit number
Return values
status usb_sts_type status

Definition at line 486 of file usbh_msc_class.c.

Referenced by disk_write().

Variable Documentation

◆ uhost_msc_class_handler

usbh_class_handler_type uhost_msc_class_handler
Initial value:
=
{
uhost_init_handler,
uhost_reset_handler,
uhost_request_handler,
uhost_process_handler,
&usbh_msc
}
uhost_request_handler
static usb_sts_type uhost_request_handler(void *uhost)
usb host hid class request handler
Definition: usbh_msc_class.c:170
uhost_process_handler
static usb_sts_type uhost_process_handler(void *uhost)
usb host class process handler
Definition: usbh_msc_class.c:213
uhost_reset_handler
static usb_sts_type uhost_reset_handler(void *uhost)
usb host class reset handler
Definition: usbh_msc_class.c:128
uhost_init_handler
static usb_sts_type uhost_init_handler(void *uhost)
usb host class init handler
Definition: usbh_msc_class.c:71
usbh_msc
usbh_msc_type usbh_msc
Definition: usbh_msc_class.c:53

Definition at line 55 of file usbh_msc_class.c.

Referenced by main().

◆ usbh_msc

usbh_msc_type usbh_msc

Definition at line 53 of file usbh_msc_class.c.

Referenced by msc_bot_scsi_init(), uhost_init_handler(), usbh_msc_read(), and usbh_msc_write().


AT32F435/437 Firmwary Library: USBH_msc_class_definition

Data Structures | Macros | Enumerations | Functions | Variables
USBH_msc_class_definition
AT32F435_437_middlewares_usbh_class » USBH_msc_class

Data Structures

struct usbh_msc_type
usb msc struct More...

Macros

#define | MSC_SUBCLASS_SCSI_TRANS 0x06
usb msc subclass code More...
#define | MSC_PROTOCOL_BBB 0x50
usb msc protocol code More...
#define | MSC_REQ_GET_MAX_LUN 0xFE
usb msc request code More...
#define | MSC_REQ_BOMSR 0xFF
#define | USB_HID_GET_REPORT 0x01
usb hid request code More...
#define | USB_HID_GET_IDLE 0x02
#define | USB_HID_GET_PROTOCOL 0x03
#define | USB_HID_SET_REPORT 0x09
#define | USB_HID_SET_IDLE 0x0A
#define | USB_HID_SET_PROTOCOL 0x0B
#define | USBH_SUPPORT_MAX_LUN 0x2

Enumerations

enum usbh_msc_ctrl_state_type { USBH_MSC_STATE_IDLE , USBH_MSC_STATE_GET_LUN , USBH_MSC_STATE_ERROR , USBH_MSC_STATE_COMPLETE }
usb msc request state More...

Functions

msc_error_type | usbh_msc_is_ready (void *uhost, uint8_t lun)
usb host msc clear feature More...
usb_sts_type | usbh_msc_write (void *uhost, uint32_t address, uint32_t len, uint8_t *buffer, uint8_t lun)
usb host msc write More...
usb_sts_type | usbh_msc_read (void *uhost, uint32_t address, uint32_t len, uint8_t *buffer, uint8_t lun)
usb host msc read More...
usb_sts_type | usbh_msc_rw_handle (void *uhost, uint32_t address, uint32_t len, uint8_t *buffer, uint8_t lun)
usb host msc read and write handle More...
usb_sts_type msc_bot_scsi_init (usbh_msc_type *msc_struct)
usb host msc init More...

Variables

usbh_class_handler_type uhost_msc_class_handler
usbh_msc_type usbh_msc

Detailed Description

Macro Definition Documentation

◆ MSC_PROTOCOL_BBB

#define MSC_PROTOCOL_BBB 0x50

usb msc protocol code

Definition at line 58 of file usbh_msc_class.h.

◆ MSC_REQ_BOMSR

#define MSC_REQ_BOMSR 0xFF

Definition at line 64 of file usbh_msc_class.h.

◆ MSC_REQ_GET_MAX_LUN

#define MSC_REQ_GET_MAX_LUN 0xFE

usb msc request code

Definition at line 63 of file usbh_msc_class.h.

◆ MSC_SUBCLASS_SCSI_TRANS

#define MSC_SUBCLASS_SCSI_TRANS 0x06

usb msc subclass code

Definition at line 53 of file usbh_msc_class.h.

◆ USB_HID_GET_IDLE

#define USB_HID_GET_IDLE 0x02

Definition at line 70 of file usbh_msc_class.h.

◆ USB_HID_GET_PROTOCOL

#define USB_HID_GET_PROTOCOL 0x03

Definition at line 71 of file usbh_msc_class.h.

◆ USB_HID_GET_REPORT

#define USB_HID_GET_REPORT 0x01

usb hid request code

Definition at line 69 of file usbh_msc_class.h.

◆ USB_HID_SET_IDLE

#define USB_HID_SET_IDLE 0x0A

Definition at line 73 of file usbh_msc_class.h.

◆ USB_HID_SET_PROTOCOL

#define USB_HID_SET_PROTOCOL 0x0B

Definition at line 74 of file usbh_msc_class.h.

◆ USB_HID_SET_REPORT

#define USB_HID_SET_REPORT 0x09

Definition at line 72 of file usbh_msc_class.h.

◆ USBH_SUPPORT_MAX_LUN

#define USBH_SUPPORT_MAX_LUN 0x2

Definition at line 77 of file usbh_msc_class.h.

Enumeration Type Documentation

◆ usbh_msc_ctrl_state_type

enum usbh_msc_ctrl_state_type

usb msc request state

Enumerator
USBH_MSC_STATE_IDLE
USBH_MSC_STATE_GET_LUN
USBH_MSC_STATE_ERROR
USBH_MSC_STATE_COMPLETE

Definition at line 82 of file usbh_msc_class.h.

Function Documentation

◆ msc_bot_scsi_init()

usb_sts_type msc_bot_scsi_init ( usbh_msc_type * msc_struct )

usb host msc init

Parameters
msc_struct to the structure of usbh_msc_type
Return values
status usb_sts_type status

Definition at line 642 of file usbh_msc_bot_scsi.c.

Referenced by uhost_init_handler().

◆ usbh_msc_is_ready()

msc_error_type usbh_msc_is_ready | ( | void * | uhost,
 |  | uint8_t | lun
 | ) |  |

usb host msc clear feature

Parameters
lun logical unit number
Return values
msc_error_type status

Definition at line 375 of file usbh_msc_class.c.

Referenced by disk_status().

◆ usbh_msc_read()

usb_sts_type usbh_msc_read | ( | void * | uhost,
 |  | uint32_t | address,
 |  | uint32_t | len,
 |  | uint8_t * | buffer,
 |  | uint8_t | lun
 | ) |  |

usb host msc read

Parameters
uhost | to the structure of usbh_core_type
address | logical block address
data_len | transfer data length
buffer | transfer data buffer
lun | logical unit number
Return values
status usb_sts_type status

Definition at line 450 of file usbh_msc_class.c.

Referenced by disk_read().

◆ usbh_msc_rw_handle()

usb_sts_type usbh_msc_rw_handle | ( | void * | uhost,
 |  | uint32_t | address,
 |  | uint32_t | len,
 |  | uint8_t * | buffer,
 |  | uint8_t | lun
 | ) |  |

usb host msc read and write handle

Parameters
uhost | to the structure of usbh_core_type
address | logical block address
data_len | transfer data length
buffer | transfer data buffer
lun | logical unit number
Return values
status usb_sts_type status

Definition at line 392 of file usbh_msc_class.c.

Referenced by usbh_msc_read(), and usbh_msc_write().

◆ usbh_msc_write()

usb_sts_type usbh_msc_write | ( | void * | uhost,
 |  | uint32_t | address,
 |  | uint32_t | len,
 |  | uint8_t * | buffer,
 |  | uint8_t | lun
 | ) |  |

usb host msc write

Parameters
uhost | to the structure of usbh_core_type
address | logical block address
data_len | transfer data length
buffer | transfer data buffer
lun | logical unit number
Return values
status usb_sts_type status

Definition at line 486 of file usbh_msc_class.c.

Referenced by disk_write().

Variable Documentation

◆ uhost_msc_class_handler

usbh_class_handler_type uhost_msc_class_handler
extern

Definition at line 55 of file usbh_msc_class.c.

Referenced by main().

◆ usbh_msc

usbh_msc_type usbh_msc
extern

Definition at line 53 of file usbh_msc_class.c.

Referenced by msc_bot_scsi_init(), uhost_init_handler(), usbh_msc_read(), and usbh_msc_write().


AT32F435/437 Firmwary Library: usbh_msc_type Struct Reference

Data Fields
usbh_msc_type Struct Reference
AT32F435_437_middlewares_usbh_class » USBH_msc_class » USBH_msc_class_definition

usb msc struct More...

#include <usbh_msc_class.h>

Data Fields

uint8_t | chin
uint8_t | eptin
uint16_t | in_maxpacket
uint8_t | in_poll
uint8_t | chout
uint8_t | eptout
uint16_t | out_maxpacket
uint8_t | out_poll
uint8_t | protocol
uint32_t | max_lun
uint32_t | cur_lun
uint32_t | use_lun
usbh_msc_ctrl_state_type ctrl_state
msc_state_type state
uint8_t | error
msc_bot_trans_type bot_trans
usbh_msc_unit_type | l_unit_n [0x2]
uint16_t | poll_timer
uint8_t | buffer [64]

Detailed Description

usb msc struct

Definition at line 93 of file usbh_msc_class.h.

Field Documentation

◆ bot_trans

msc_bot_trans_type usbh_msc_type::bot_trans

Definition at line 114 of file usbh_msc_class.h.

Referenced by uhost_process_handler(), usbh_msc_read(), usbh_msc_rw_handle(), and usbh_msc_write().

◆ buffer

uint8_t usbh_msc_type::buffer[64]

Definition at line 117 of file usbh_msc_class.h.

◆ chin

uint8_t usbh_msc_type::chin

Definition at line 95 of file usbh_msc_class.h.

Referenced by uhost_init_handler(), and uhost_reset_handler().

◆ chout

uint8_t usbh_msc_type::chout

Definition at line 100 of file usbh_msc_class.h.

Referenced by uhost_init_handler(), and uhost_reset_handler().

◆ ctrl_state

usbh_msc_ctrl_state_type usbh_msc_type::ctrl_state

Definition at line 111 of file usbh_msc_class.h.

Referenced by uhost_request_handler().

◆ cur_lun

uint32_t usbh_msc_type::cur_lun

Definition at line 107 of file usbh_msc_class.h.

Referenced by uhost_process_handler().

◆ eptin

uint8_t usbh_msc_type::eptin

Definition at line 96 of file usbh_msc_class.h.

Referenced by uhost_init_handler().

◆ eptout

uint8_t usbh_msc_type::eptout

Definition at line 101 of file usbh_msc_class.h.

Referenced by uhost_init_handler().

◆ error

uint8_t usbh_msc_type::error

Definition at line 113 of file usbh_msc_class.h.

◆ in_maxpacket

uint16_t usbh_msc_type::in_maxpacket

Definition at line 97 of file usbh_msc_class.h.

Referenced by uhost_init_handler().

◆ in_poll

uint8_t usbh_msc_type::in_poll

Definition at line 98 of file usbh_msc_class.h.

Referenced by uhost_init_handler().

◆ l_unit_n

usbh_msc_unit_type usbh_msc_type::l_unit_n[0x2]

Definition at line 115 of file usbh_msc_class.h.

Referenced by disk_ioctl(), uhost_process_handler(), uhost_request_handler(), uhost_reset_handler(), usbh_msc_is_ready(), usbh_msc_read(), usbh_msc_rw_handle(), and usbh_msc_write().

◆ max_lun

uint32_t usbh_msc_type::max_lun

Definition at line 106 of file usbh_msc_class.h.

Referenced by uhost_process_handler(), uhost_request_handler(), and uhost_reset_handler().

◆ out_maxpacket

uint16_t usbh_msc_type::out_maxpacket

Definition at line 102 of file usbh_msc_class.h.

Referenced by uhost_init_handler().

◆ out_poll

uint8_t usbh_msc_type::out_poll

Definition at line 103 of file usbh_msc_class.h.

Referenced by uhost_init_handler().

◆ poll_timer

uint16_t usbh_msc_type::poll_timer

Definition at line 116 of file usbh_msc_class.h.

◆ protocol

uint8_t usbh_msc_type::protocol

Definition at line 104 of file usbh_msc_class.h.

Referenced by uhost_init_handler().

◆ state

msc_state_type usbh_msc_type::state

Definition at line 112 of file usbh_msc_class.h.

Referenced by uhost_process_handler().

◆ use_lun

uint32_t usbh_msc_type::use_lun

Definition at line 108 of file usbh_msc_class.h.

Referenced by usbh_msc_read(), and usbh_msc_write().

The documentation for this struct was generated from the following file:
  • usbh_msc_class.h


AT32F435/437 Firmwary Library: AT32F435_437_board

Modules
AT32F435_437_board

Modules

BOARD
onboard periph driver

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: BOARD

Modules | Macros | Functions | Variables
BOARD
AT32F435_437_board

onboard periph driver More...

Modules

BOARD_pins_definition
BOARD_exported_functions

Macros

#define | STEP_DELAY_MS 50
#define | PUTCHAR_PROTOTYPE int fputc(int ch, FILE *f)

Functions

int | fputc (int ch, FILE *f)
retargets the c library printf function to the usart. More...
void | uart_print_init (uint32_t baudrate)
initialize uart More...
void | at32_board_init ()
board initialize interface init led and button More...
void | at32_button_init (void)
configure button gpio More...
uint8_t | at32_button_state (void)
returns the selected button state More...
button_type at32_button_press ()
returns which button have press down More...
void | at32_led_init (led_type led)
configure led gpio More...
void | at32_led_on (led_type led)
turns selected led on. More...
void | at32_led_off (led_type led)
turns selected led off. More...
void | at32_led_toggle (led_type led)
turns selected led toggle. More...
void | delay_init ()
initialize delay function More...
void | delay_us (uint32_t nus)
inserts a delay time. More...
void | delay_ms (uint16_t nms)
inserts a delay time. More...
void | delay_sec (uint16_t sec)
inserts a delay time. More...

Variables

gpio_type * | led_gpio_port [3] = {LED2_GPIO, LED3_GPIO, LED4_GPIO}
uint16_t | led_gpio_pin [3] = {LED2_PIN, LED3_PIN, LED4_PIN}
crm_periph_clock_type | led_gpio_crm_clk [3] = {LED2_GPIO_CRM_CLK, LED3_GPIO_CRM_CLK, LED4_GPIO_CRM_CLK}
static __IO uint32_t | fac_us
static __IO uint32_t | fac_ms

Detailed Description

onboard periph driver

Macro Definition Documentation

◆ PUTCHAR_PROTOTYPE

#define PUTCHAR_PROTOTYPE int fputc(int ch, FILE *f)

Definition at line 87 of file at32f435_437_board.c.

◆ STEP_DELAY_MS

#define STEP_DELAY_MS 50

Definition at line 40 of file at32f435_437_board.c.

Function Documentation

◆ at32_board_init()

void at32_board_init ( void )

board initialize interface init led and button

Parameters
none
Return values
none

Definition at line 138 of file at32f435_437_board.c.

Referenced by main().

◆ at32_button_init()

void at32_button_init ( void )

configure button gpio

Parameters
button specifies the button to be configured.
Return values
none

< gpio pins number 0

Definition at line 160 of file at32f435_437_board.c.

Referenced by at32_board_init().

◆ at32_button_press()

button_type at32_button_press ( void )

returns which button have press down

Parameters
none
Return values
the button have press down

Definition at line 194 of file at32f435_437_board.c.

Referenced by main().

◆ at32_button_state()

uint8_t at32_button_state ( void )

returns the selected button state

Parameters
none
Return values
the button gpio pin value

< gpio pins number 0

Definition at line 184 of file at32f435_437_board.c.

Referenced by at32_button_press().

◆ at32_led_init()

void at32_led_init ( led_type led )

configure led gpio

Parameters
led specifies the led to be configured.
Return values
none

Definition at line 218 of file at32f435_437_board.c.

Referenced by at32_board_init(), and main().

◆ at32_led_off()

void at32_led_off ( led_type led )

turns selected led off.

Parameters
led specifies the led to be set off. this parameter can be one of following parameters:
  • LED2
  • LED3
  • LED4
Return values
none

Definition at line 263 of file at32f435_437_board.c.

Referenced by at32_board_init(), EDMA_Stream1_IRQHandler(), ethernetif_set_link(), http_recv(), main(), sd_test_error(), and usb_hid_buf_process().

◆ at32_led_on()

void at32_led_on ( led_type led )

turns selected led on.

Parameters
led specifies the led to be set on. this parameter can be one of following parameters:
  • LED2
  • LED3
  • LED4
Return values
none

Definition at line 246 of file at32f435_437_board.c.

Referenced by DMA2_Channel1_IRQHandler(), DMA2_Channel4_IRQHandler(), EDMA_Stream1_IRQHandler(), EDMA_Stream4_IRQHandler(), ERTC_WKUP_IRQHandler(), ERTCAlarm_IRQHandler(), ethernetif_set_link(), http_recv(), main(), sd_test_error(), USART2_IRQHandler(), and usb_hid_buf_process().

◆ at32_led_toggle()

void at32_led_toggle ( led_type led )

turns selected led toggle.

Parameters
led specifies the led to be set off. this parameter can be one of following parameters:
  • LED2
  • LED3
  • LED4
Return values
none

Definition at line 280 of file at32f435_437_board.c.

Referenced by ACC_IRQHandler(), CAN1_RX0_IRQHandler(), error_handler(), ERTC_WKUP_IRQHandler(), ERTCAlarm_IRQHandler(), EXINT0_IRQHandler(), EXINT1_IRQHandler(), EXINT4_IRQHandler(), led2_task_function(), led3_task_function(), main(), PVM_IRQHandler(), result_error(), systick_handler(), TAMP_STAMP_IRQHandler(), TMR1_OVF_TMR10_IRQHandler(), TMR2_GLOBAL_IRQHandler(), TMR3_GLOBAL_IRQHandler(), and USART1_IRQHandler().

◆ delay_init()

void delay_init ( void )

initialize delay function

Parameters
none
Return values
none

Definition at line 293 of file at32f435_437_board.c.

Referenced by at32_board_init(), main(), sclk_288m_hick_config(), sclk_64m_hick_config(), and sclk_96m_hext_config().

◆ delay_ms()

void delay_ms ( uint16_t nms )

inserts a delay time.

Parameters
nms specifies the delay time length, in milliseconds.
Return values
none

Definition at line 326 of file at32f435_437_board.c.

Referenced by at32_button_press(), button_isr(), delay_sec(), error_handler(), ethernetif_update_config(), EXINT0_IRQHandler(), flash_fat16_loop_status(), FLASH_IRQHandler(), iap_loop(), lcd_display_number(), lcd_init(), main(), nand_read_small_page(), nand_read_spare_area(), ov2640_capture(), ov2640_init(), ov5640_capture(), ov5640_focus_constant(), ov5640_focus_init(), ov5640_focus_single(), ov5640_init(), randnum_test(), reset_phy(), sd_power_on(), sd_test_error(), sdram_init_sequence(), usb_delay_ms(), and usb_reset().

◆ delay_sec()

void delay_sec ( uint16_t sec )

inserts a delay time.

Parameters
sec specifies the delay time, in seconds.
Return values
none

Definition at line 358 of file at32f435_437_board.c.

Referenced by main(), and result_error().

◆ delay_us()

void delay_us ( uint32_t nus )

inserts a delay time.

Parameters
nus specifies the delay time length, in microsecond.
Return values
none

Definition at line 306 of file at32f435_437_board.c.

Referenced by esmt32m_qpi_mode_init(), main(), SCCB_No_Ack(), SCCB_RD_Byte(), SCCB_RD_Reg(), SCCB_Start(), SCCB_Stop(), SCCB_WR_Byte(), SCCB_WR_Reg(), touch_read_ad(), and usb_delay_us().

◆ fputc()

int fputc | ( | int | ch,
 |  | FILE * | f
 | ) |  |

retargets the c library printf function to the usart.

Parameters
none
Return values
none

< usart transmit data buffer empty flag

Definition at line 95 of file at32f435_437_board.c.

◆ uart_print_init()

void uart_print_init ( uint32_t baudrate )

initialize uart

Parameters
baudrate uart baudrate
Return values
none

< gpio pins number 9

Definition at line 107 of file at32f435_437_board.c.

Referenced by main().

Variable Documentation

◆ fac_ms

__IO uint32_t fac_ms
static

Definition at line 49 of file at32f435_437_board.c.

Referenced by delay_init(), and delay_ms().

◆ fac_us

__IO uint32_t fac_us
static

Definition at line 48 of file at32f435_437_board.c.

Referenced by delay_init(), and delay_us().

◆ led_gpio_crm_clk

crm_periph_clock_type led_gpio_crm_clk[3] = {LED2_GPIO_CRM_CLK, LED3_GPIO_CRM_CLK, LED4_GPIO_CRM_CLK}

Definition at line 45 of file at32f435_437_board.c.

Referenced by at32_led_init().

◆ led_gpio_pin

uint16_t led_gpio_pin[3] = {LED2_PIN, LED3_PIN, LED4_PIN}

Definition at line 44 of file at32f435_437_board.c.

Referenced by at32_led_init(), at32_led_off(), at32_led_on(), and at32_led_toggle().

◆ led_gpio_port

gpio_type* led_gpio_port[3] = {LED2_GPIO, LED3_GPIO, LED4_GPIO}

Definition at line 43 of file at32f435_437_board.c.

Referenced by at32_led_init(), at32_led_off(), at32_led_on(), and at32_led_toggle().


AT32F435/437 Firmwary Library: BOARD_pins_definition

Macros | Enumerations
BOARD_pins_definition
AT32F435_437_board » BOARD

Macros

#define | LED_NUM 3
#define | PRINT_UART USART1
#define | PRINT_UART_CRM_CLK CRM_USART1_PERIPH_CLOCK
#define | PRINT_UART_TX_PIN GPIO_PINS_9
#define | PRINT_UART_TX_GPIO GPIOA
#define | PRINT_UART_TX_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
#define | PRINT_UART_TX_PIN_SOURCE GPIO_PINS_SOURCE9
#define | PRINT_UART_TX_PIN_MUX_NUM GPIO_MUX_7
#define | USER_BUTTON_PIN GPIO_PINS_0
#define | USER_BUTTON_PORT GPIOA
#define | USER_BUTTON_CRM_CLK CRM_GPIOA_PERIPH_CLOCK

Enumerations

enum | led_type { LED2 = 0 , LED3 = 1 , LED4 = 2 }
enum | button_type { USER_BUTTON = 0 , NO_BUTTON = 1 }

Detailed Description

Macro Definition Documentation

◆ LED_NUM

#define LED_NUM 3

Definition at line 70 of file at32f435_437_board.h.

◆ PRINT_UART

#define PRINT_UART USART1

Definition at line 87 of file at32f435_437_board.h.

◆ PRINT_UART_CRM_CLK

#define PRINT_UART_CRM_CLK CRM_USART1_PERIPH_CLOCK

Definition at line 88 of file at32f435_437_board.h.

◆ PRINT_UART_TX_GPIO

#define PRINT_UART_TX_GPIO GPIOA

Definition at line 90 of file at32f435_437_board.h.

◆ PRINT_UART_TX_GPIO_CRM_CLK

#define PRINT_UART_TX_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 91 of file at32f435_437_board.h.

◆ PRINT_UART_TX_PIN

#define PRINT_UART_TX_PIN GPIO_PINS_9

Definition at line 89 of file at32f435_437_board.h.

◆ PRINT_UART_TX_PIN_MUX_NUM

#define PRINT_UART_TX_PIN_MUX_NUM GPIO_MUX_7

Definition at line 93 of file at32f435_437_board.h.

◆ PRINT_UART_TX_PIN_SOURCE

#define PRINT_UART_TX_PIN_SOURCE GPIO_PINS_SOURCE9

Definition at line 92 of file at32f435_437_board.h.

◆ USER_BUTTON_CRM_CLK

#define USER_BUTTON_CRM_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 104 of file at32f435_437_board.h.

◆ USER_BUTTON_PIN

#define USER_BUTTON_PIN GPIO_PINS_0

Definition at line 102 of file at32f435_437_board.h.

◆ USER_BUTTON_PORT

#define USER_BUTTON_PORT GPIOA

Definition at line 103 of file at32f435_437_board.h.

Enumeration Type Documentation

◆ button_type

enum button_type
Enumerator
USER_BUTTON
NO_BUTTON

Definition at line 96 of file at32f435_437_board.h.

◆ led_type

enum led_type

this header include define support list:

  1. at-start-f435 v1.x board
  2. at-start-f437 v1.x board if define AT_START_F435_V1, the header file support at-start-f437 v1.x board if define AT_START_F437_V1, the header file support at-start-f437 v1.x board
Enumerator
LED2
LED3
LED4

Definition at line 63 of file at32f435_437_board.h.


AT32F435/437 Firmwary Library: BOARD_exported_functions

Functions
BOARD_exported_functions
AT32F435_437_board » BOARD

Functions

void | at32_board_init (void)
board initialize interface init led and button More...
void | at32_led_init (led_type led)
configure led gpio More...
void | at32_led_on (led_type led)
turns selected led on. More...
void | at32_led_off (led_type led)
turns selected led off. More...
void | at32_led_toggle (led_type led)
turns selected led toggle. More...
void | at32_button_init (void)
configure button gpio More...
button_type | at32_button_press (void)
returns which button have press down More...
uint8_t | at32_button_state (void)
returns the selected button state More...
void | delay_init (void)
initialize delay function More...
void | delay_us (uint32_t nus)
inserts a delay time. More...
void | delay_ms (uint16_t nms)
inserts a delay time. More...
void | delay_sec (uint16_t sec)
inserts a delay time. More...
void | uart_print_init (uint32_t baudrate)
initialize uart More...

Detailed Description

Function Documentation

◆ at32_board_init()

void at32_board_init ( void )

board initialize interface init led and button

Parameters
none
Return values
none

Definition at line 138 of file at32f435_437_board.c.

Referenced by main().

◆ at32_button_init()

void at32_button_init ( void )

configure button gpio

Parameters
button specifies the button to be configured.
Return values
none

< gpio pins number 0

Definition at line 160 of file at32f435_437_board.c.

Referenced by at32_board_init().

◆ at32_button_press()

button_type at32_button_press ( void )

returns which button have press down

Parameters
none
Return values
the button have press down

Definition at line 194 of file at32f435_437_board.c.

Referenced by main().

◆ at32_button_state()

uint8_t at32_button_state ( void )

returns the selected button state

Parameters
none
Return values
the button gpio pin value

< gpio pins number 0

Definition at line 184 of file at32f435_437_board.c.

Referenced by at32_button_press().

◆ at32_led_init()

void at32_led_init ( led_type led )

configure led gpio

Parameters
led specifies the led to be configured.
Return values
none

Definition at line 218 of file at32f435_437_board.c.

Referenced by at32_board_init(), and main().

◆ at32_led_off()

void at32_led_off ( led_type led )

turns selected led off.

Parameters
led specifies the led to be set off. this parameter can be one of following parameters:
  • LED2
  • LED3
  • LED4
Return values
none

Definition at line 263 of file at32f435_437_board.c.

Referenced by at32_board_init(), EDMA_Stream1_IRQHandler(), ethernetif_set_link(), http_recv(), main(), sd_test_error(), and usb_hid_buf_process().

◆ at32_led_on()

void at32_led_on ( led_type led )

turns selected led on.

Parameters
led specifies the led to be set on. this parameter can be one of following parameters:
  • LED2
  • LED3
  • LED4
Return values
none

Definition at line 246 of file at32f435_437_board.c.

Referenced by DMA2_Channel1_IRQHandler(), DMA2_Channel4_IRQHandler(), EDMA_Stream1_IRQHandler(), EDMA_Stream4_IRQHandler(), ERTC_WKUP_IRQHandler(), ERTCAlarm_IRQHandler(), ethernetif_set_link(), http_recv(), main(), sd_test_error(), USART2_IRQHandler(), and usb_hid_buf_process().

◆ at32_led_toggle()

void at32_led_toggle ( led_type led )

turns selected led toggle.

Parameters
led specifies the led to be set off. this parameter can be one of following parameters:
  • LED2
  • LED3
  • LED4
Return values
none

Definition at line 280 of file at32f435_437_board.c.

Referenced by ACC_IRQHandler(), CAN1_RX0_IRQHandler(), error_handler(), ERTC_WKUP_IRQHandler(), ERTCAlarm_IRQHandler(), EXINT0_IRQHandler(), EXINT1_IRQHandler(), EXINT4_IRQHandler(), led2_task_function(), led3_task_function(), main(), PVM_IRQHandler(), result_error(), systick_handler(), TAMP_STAMP_IRQHandler(), TMR1_OVF_TMR10_IRQHandler(), TMR2_GLOBAL_IRQHandler(), TMR3_GLOBAL_IRQHandler(), and USART1_IRQHandler().

◆ delay_init()

void delay_init ( void )

initialize delay function

Parameters
none
Return values
none

Definition at line 293 of file at32f435_437_board.c.

Referenced by at32_board_init(), main(), sclk_288m_hick_config(), sclk_64m_hick_config(), and sclk_96m_hext_config().

◆ delay_ms()

void delay_ms ( uint16_t nms )

inserts a delay time.

Parameters
nms specifies the delay time length, in milliseconds.
Return values
none

Definition at line 326 of file at32f435_437_board.c.

Referenced by at32_button_press(), button_isr(), delay_sec(), error_handler(), ethernetif_update_config(), EXINT0_IRQHandler(), flash_fat16_loop_status(), FLASH_IRQHandler(), iap_loop(), lcd_display_number(), lcd_init(), main(), nand_read_small_page(), nand_read_spare_area(), ov2640_capture(), ov2640_init(), ov5640_capture(), ov5640_focus_constant(), ov5640_focus_init(), ov5640_focus_single(), ov5640_init(), randnum_test(), reset_phy(), sd_power_on(), sd_test_error(), sdram_init_sequence(), usb_delay_ms(), and usb_reset().

◆ delay_sec()

void delay_sec ( uint16_t sec )

inserts a delay time.

Parameters
sec specifies the delay time, in seconds.
Return values
none

Definition at line 358 of file at32f435_437_board.c.

Referenced by main(), and result_error().

◆ delay_us()

void delay_us ( uint32_t nus )

inserts a delay time.

Parameters
nus specifies the delay time length, in microsecond.
Return values
none

Definition at line 306 of file at32f435_437_board.c.

Referenced by esmt32m_qpi_mode_init(), main(), SCCB_No_Ack(), SCCB_RD_Byte(), SCCB_RD_Reg(), SCCB_Start(), SCCB_Stop(), SCCB_WR_Byte(), SCCB_WR_Reg(), touch_read_ad(), and usb_delay_us().

◆ uart_print_init()

void uart_print_init ( uint32_t baudrate )

initialize uart

Parameters
baudrate uart baudrate
Return values
none

< gpio pins number 9

Definition at line 107 of file at32f435_437_board.c.

Referenced by main().


AT32F435/437 Firmwary Library: AT32F435_periph_examples

Modules
AT32F435_periph_examples

Modules

USB_device_vcp_loopback
ACC_calibration
ADC_combine_mode_ordinary_shift_twoslave_dma3
ADC_combine_mode_ordinary_shift_twoslave_dma4
ADC_combine_mode_ordinary_smlt_oneslave_dma2
ADC_combine_mode_ordinary_smlt_oneslave_edma
ADC_combine_mode_ordinary_smlt_twoslave_dma1
ADC_combine_mode_ordinary_smlt_twoslave_dma5
ADC_combine_mode_preempt_interltrig_twoslave
ADC_conversion_abort
ADC_current_vref_value_check
ADC_edma_double_buffer
ADC_exint_trigger_partitioned
ADC_internal_temperature_sensor
ADC_ordinary_preempt_oversampling
ADC_software_trigger_repeat
ADC_tmr_trigger_automatic_preempted
ADC_use_polling_get_conversion_data
ADC_vbat_monitor
ADC_voltage_monitoring
CAN_communication_mode
CAN_filter
CAN_loopback_mode
CORTEX_m4_bit_band
System_clock_configuration
CORTEX_m4_cmsis_dsp
CORTEX_m4_fpu
CORTEX_m4_systick_interrupt
CRC_calculation
CRM_clock_failure_detection
CRM_pll_parameter_calculate
CRM_sysclk_switch
DAC_double_mode_dma_sinewave
DAC_double_mode_dma_squarewave
DAC_one_dac_dma_escalator
DAC_one_dac_noisewave
DAC_two_dac_trianglewave
DEBUG_tmr
DMA_data_to_gpio
DMAMUX_genertor_exint
DMAMUX_synchronization_exint
DMA_flash_to_sram
DVP_ov2640_capture
DVP_ov5640_capture
EDMA_continuous_mode
EDMA_dmamux_genertor_exint
EDMA_dmamux_synchronization_exint
EDMA_flash_to_sram
EDMA_i2s_halfduplex_edma_doublebuffer
EDMA_link_list_mode
EDMA_two_dimension_mode
ERTC_bpr_domain
ERTC_calendar
ERTC_lick_calibration
ERTC_tamper
ERTC_time_stamp
ERTC_wakeup_timer
EXINT_exint_config
EXINT_exint_software_trigger
FLASH_fap_enable
FLASH_write_read
GPIO_io_toggle
GPIO_led_toggle
_GPIO_swjtag_mux
GPIO_swjtag_mux
I2C_communication_dma
I2C_communication_int
I2C_communication_poll
I2C_communication_smbus
I2C_eeprom
I2S_fullduplex_dma
I2S_halfduplex_dma
I2S_halfduplex_interrupt
I2S_spii2s_switch_halfduplex_polling
IRTMR_output
PWC_deepsleep_ertc_alarm
PWC_deepsleep_ertc_tamper
PWC_deepsleep_ertc_wakeup
PWC_ldo_set
PWC_power_voltage_monitor
PWC_sleep_tmr2
PWC_sleep_usart1
_PWC_standby_ertc_alarm
PWC_standby_ertc_alarm
PWC_standby_wakeup_pin
QSPI_command_port_using_dma
QSPI_command_port_using_dma_and_pem
QSPI_command_port_using_dma_in_qpi_mode
QSPI_command_port_using_interrupt
QSPI_command_port_using_polling
QSPI_command_port_using_rdsr_sw
QSPI_xip_port_write_read
SCFG_mem_map_sel
SD_mmc_card
SD_mmc_card
SDIO_fatfs
SPI_crc_transfer_polling
SPI_fullduplex_polling
SPI_halfduplex_interrupt
SPI_halfduplex_transceiver_switch
SPI_only_receive_mode_polling
SPI_ti_fullduplex_dma
SPI_use_jtagpin_hardwarecs_dma
SPI_w25q_flash
SRAM_extend_sram
TMR_6_steps
TMR_7_pwm_output
TMR_cascade_synchro
TMR_complementary_signals
TMR_dma
TMR_dma_burst
TMR_encoder_tmr2
TMR_external_clock
TMR_hall_xor_tmr2
TMR_hang_mode
TMR_input_capture
TMR_oc_high
TMR_oc_low
TMR_oc_toggle_tmr3
TMR_oc_toggle_tmr9
TMR_one_cycle
TMR_parallel_synchro
TMR_pwm_input
TMR_pwm_input_dma
TMR_pwm_output_simulate
TMR_pwm_output_tmr10
TMR_pwm_output_tmr3
TMR_timer_base
TMR_tmr1_synchro
TMR_tmr2_32bit
USART_half_duplex
USART_hw_flow_control
USART_idle_detection
USART_interrupt
USART_irda
USART_polling
USART_printf
USART_receiver_mute
_USART_rs485
USART_smartcard
USART_synchronous
USART_transfer_by_dma_interrupt
USART_transfer_by_dma_polling
USART_tx_rx_swap
USB_device_audio
USB_device_audio_hid
USB_device_composite_vcp_keyboard
USB_device_msc
USB_device_composite_vcp_msc
_USB_device_cdc_msc
USB_device_custom_hid
USB_device_keyboard
USB_device_mouse
USB_device_otg1_host_otg2_device_demo
USB_device_printer
USB_device_two_otg_device_demo
_USB_device_virtaul_comport
USB_device_virtaul_comport
USB_device_virtual_msc_iap
USB_host_hid
USB_host_msc
USB_host_two_otg_host_demo
WDT_wdt_reset
WDT_WDT_standby
WWDT_wwdt_reset
XMC_lcd_8bit
XMC_lcd_touch_16bit
XMC_nand_ecc
XMC_nand
XMC_nor_flash
XMC_psram
XMC_sdram_basic
XMC_sdram_dma
XMC_sram

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: USB_device_vcp_loopback

Macros | Functions | Variables
USB_device_vcp_loopback
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | USB_VIRTUAL_COMPORT
usb low power wakeup handler enable More...
#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | USB_VIRTUAL_COMPORT
usb low power wakeup handler enable More...

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
int | main (void)
main function. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...

Variables

otg_core_type otg_core_struct
uint8_t | usb_buffer [256]
otg_core_type otg_core_struct
uint8_t | usb_buffer [256]

Detailed Description

Macro Definition Documentation

◆ OTG_CLOCK [1/6]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 69 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_CLOCK [2/6]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 69 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_CLOCK [3/6]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 69 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_CLOCK [4/6]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 69 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_CLOCK [5/6]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 69 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_CLOCK [6/6]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 69 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_IRQ [1/6]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 70 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_IRQ [2/6]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 70 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_IRQ [3/6]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 70 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_IRQ [4/6]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 70 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_IRQ [5/6]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 70 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_IRQ [6/6]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 70 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [1/5]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 71 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [2/5]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 71 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [3/5]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 71 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [4/5]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 71 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [5/5]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 71 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_DM [1/6]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 82 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_DM [2/6]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 82 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_DM [3/6]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 82 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_DM [4/6]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 82 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_DM [5/6]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 82 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_DM [6/6]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 82 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [1/6]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 83 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [2/6]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 83 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [3/6]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 83 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [4/6]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 83 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [5/6]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 83 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [6/6]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 83 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_DP [1/6]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 79 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_DP [2/6]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 79 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_DP [3/6]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 79 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_DP [4/6]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 79 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_DP [5/6]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 79 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_DP [6/6]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 79 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [1/6]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 80 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [2/6]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 80 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [3/6]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 80 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [4/6]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 80 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [5/6]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 80 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [6/6]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 80 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_GPIO [1/6]

#define OTG_PIN_GPIO GPIOA

Definition at line 76 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_GPIO [2/6]

#define OTG_PIN_GPIO GPIOA

Definition at line 76 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_GPIO [3/6]

#define OTG_PIN_GPIO GPIOA

Definition at line 76 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_GPIO [4/6]

#define OTG_PIN_GPIO GPIOA

Definition at line 76 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_GPIO [5/6]

#define OTG_PIN_GPIO GPIOA

Definition at line 76 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_GPIO [6/6]

#define OTG_PIN_GPIO GPIOA

Definition at line 76 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [1/6]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 77 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [2/6]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 77 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [3/6]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 77 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [4/6]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 77 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [5/6]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 77 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [6/6]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 77 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_ID [1/6]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 88 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_ID [2/6]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 88 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_ID [3/6]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 88 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_ID [4/6]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 88 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_ID [5/6]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 88 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_ID [6/6]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 88 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [1/6]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 89 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [2/6]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 89 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [3/6]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 89 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [4/6]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 89 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [5/6]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 89 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [6/6]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 89 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_MUX [1/6]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 96 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_MUX [2/6]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 96 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_MUX [3/6]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 96 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_MUX [4/6]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 96 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_MUX [5/6]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 96 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_MUX [6/6]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 96 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_SOF [1/6]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 93 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_SOF [2/6]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 93 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_SOF [3/6]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 93 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_SOF [4/6]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 93 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_SOF [5/6]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 93 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_SOF [6/6]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 93 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [1/6]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 91 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [2/6]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 91 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [3/6]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 91 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [4/6]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 91 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [5/6]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 91 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [6/6]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 91 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [1/6]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 92 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [2/6]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 92 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [3/6]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK

Definition at line 92 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [4/6]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 92 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [5/6]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 92 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [6/6]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK

Definition at line 92 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [1/6]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 94 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [2/6]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 94 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [3/6]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 94 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [4/6]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 94 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [5/6]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 94 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [6/6]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 94 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_VBUS [1/6]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 85 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_VBUS [2/6]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 85 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_VBUS [3/6]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 85 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_VBUS [4/6]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 85 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_VBUS [5/6]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 85 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_VBUS [6/6]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 85 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [1/6]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 86 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [2/6]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 86 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [3/6]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 86 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [4/6]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 86 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [5/6]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 86 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [6/6]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 86 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_USB_ID [1/6]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 62 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_USB_ID [2/6]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 62 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_USB_ID [3/6]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 62 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_USB_ID [4/6]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 62 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_USB_ID [5/6]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 62 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_USB_ID [6/6]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 62 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [1/6]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 74 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [2/6]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 74 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [3/6]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 74 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [4/6]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 74 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [5/6]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 74 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [6/6]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 74 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [1/6]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 73 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [2/6]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 73 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [3/6]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 73 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [4/6]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 73 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [5/6]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 73 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [6/6]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 73 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [1/6]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 72 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [2/6]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 72 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [3/6]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 72 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [4/6]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 72 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [5/6]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 72 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [6/6]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 72 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USB_ID [1/6]

#define USB_ID 0

Definition at line 68 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ USB_ID [2/6]

#define USB_ID 0

Definition at line 68 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USB_ID [3/6]

#define USB_ID 0

Definition at line 68 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USB_ID [4/6]

#define USB_ID 0

Definition at line 68 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ USB_ID [5/6]

#define USB_ID 0

Definition at line 68 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USB_ID [6/6]

#define USB_ID 0

Definition at line 68 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [1/6]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vubs ignor, not use vbus pin

Definition at line 198 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [2/6]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore, not use vbus pin

Definition at line 198 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [3/6]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore, not use vbus pin

Definition at line 198 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [4/6]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vubs ignor, not use vbus pin

Definition at line 198 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [5/6]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore, not use vbus pin

Definition at line 198 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [6/6]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore, not use vbus pin

Definition at line 198 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USB_VIRTUAL_COMPORT [1/2]

#define USB_VIRTUAL_COMPORT

usb low power wakeup handler enable

usb virtual comport

Definition at line 208 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USB_VIRTUAL_COMPORT [2/2]

#define USB_VIRTUAL_COMPORT

usb low power wakeup handler enable

usb virtual comport

Definition at line 208 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [1/6]

#define USBD2_EP0_TX_SIZE 24

Definition at line 151 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [2/6]

#define USBD2_EP0_TX_SIZE 24

Definition at line 151 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [3/6]

#define USBD2_EP0_TX_SIZE 24

Definition at line 151 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [4/6]

#define USBD2_EP0_TX_SIZE 24

Definition at line 151 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [5/6]

#define USBD2_EP0_TX_SIZE 24

Definition at line 151 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [6/6]

#define USBD2_EP0_TX_SIZE 24

Definition at line 151 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [1/6]

#define USBD2_EP1_TX_SIZE 20

Definition at line 152 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [2/6]

#define USBD2_EP1_TX_SIZE 20

Definition at line 152 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [3/6]

#define USBD2_EP1_TX_SIZE 20

Definition at line 152 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [4/6]

#define USBD2_EP1_TX_SIZE 20

Definition at line 152 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [5/6]

#define USBD2_EP1_TX_SIZE 20

Definition at line 152 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [6/6]

#define USBD2_EP1_TX_SIZE 20

Definition at line 152 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [1/6]

#define USBD2_EP2_TX_SIZE 20

Definition at line 153 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [2/6]

#define USBD2_EP2_TX_SIZE 20

Definition at line 153 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [3/6]

#define USBD2_EP2_TX_SIZE 20

Definition at line 153 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [4/6]

#define USBD2_EP2_TX_SIZE 20

Definition at line 153 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [5/6]

#define USBD2_EP2_TX_SIZE 20

Definition at line 153 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [6/6]

#define USBD2_EP2_TX_SIZE 20

Definition at line 153 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [1/6]

#define USBD2_EP3_TX_SIZE 20

Definition at line 154 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [2/6]

#define USBD2_EP3_TX_SIZE 20

Definition at line 154 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [3/6]

#define USBD2_EP3_TX_SIZE 20

Definition at line 154 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [4/6]

#define USBD2_EP3_TX_SIZE 20

Definition at line 154 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [5/6]

#define USBD2_EP3_TX_SIZE 20

Definition at line 154 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [6/6]

#define USBD2_EP3_TX_SIZE 20

Definition at line 154 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [1/6]

#define USBD2_EP4_TX_SIZE 20

Definition at line 155 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [2/6]

#define USBD2_EP4_TX_SIZE 20

Definition at line 155 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [3/6]

#define USBD2_EP4_TX_SIZE 20

Definition at line 155 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [4/6]

#define USBD2_EP4_TX_SIZE 20

Definition at line 155 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [5/6]

#define USBD2_EP4_TX_SIZE 20

Definition at line 155 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [6/6]

#define USBD2_EP4_TX_SIZE 20

Definition at line 155 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [1/6]

#define USBD2_EP5_TX_SIZE 20

Definition at line 156 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [2/6]

#define USBD2_EP5_TX_SIZE 20

Definition at line 156 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [3/6]

#define USBD2_EP5_TX_SIZE 20

Definition at line 156 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [4/6]

#define USBD2_EP5_TX_SIZE 20

Definition at line 156 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [5/6]

#define USBD2_EP5_TX_SIZE 20

Definition at line 156 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [6/6]

#define USBD2_EP5_TX_SIZE 20

Definition at line 156 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [1/6]

#define USBD2_EP6_TX_SIZE 20

Definition at line 157 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [2/6]

#define USBD2_EP6_TX_SIZE 20

Definition at line 157 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [3/6]

#define USBD2_EP6_TX_SIZE 20

Definition at line 157 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [4/6]

#define USBD2_EP6_TX_SIZE 20

Definition at line 157 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [5/6]

#define USBD2_EP6_TX_SIZE 20

Definition at line 157 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [6/6]

#define USBD2_EP6_TX_SIZE 20

Definition at line 157 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [1/6]

#define USBD2_EP7_TX_SIZE 20

Definition at line 158 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [2/6]

#define USBD2_EP7_TX_SIZE 20

Definition at line 158 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [3/6]

#define USBD2_EP7_TX_SIZE 20

Definition at line 158 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [4/6]

#define USBD2_EP7_TX_SIZE 20

Definition at line 158 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [5/6]

#define USBD2_EP7_TX_SIZE 20

Definition at line 158 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [6/6]

#define USBD2_EP7_TX_SIZE 20

Definition at line 158 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD2_RX_SIZE [1/6]

#define USBD2_RX_SIZE 128

Definition at line 150 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ USBD2_RX_SIZE [2/6]

#define USBD2_RX_SIZE 128

Definition at line 150 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD2_RX_SIZE [3/6]

#define USBD2_RX_SIZE 128

Definition at line 150 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD2_RX_SIZE [4/6]

#define USBD2_RX_SIZE 128

Definition at line 150 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ USBD2_RX_SIZE [5/6]

#define USBD2_RX_SIZE 128

Definition at line 150 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD2_RX_SIZE [6/6]

#define USBD2_RX_SIZE 128

Definition at line 150 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [1/6]

#define USBD_EP0_TX_SIZE 24

Definition at line 140 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [2/6]

#define USBD_EP0_TX_SIZE 24

Definition at line 140 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [3/6]

#define USBD_EP0_TX_SIZE 24

Definition at line 140 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [4/6]

#define USBD_EP0_TX_SIZE 24

Definition at line 140 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [5/6]

#define USBD_EP0_TX_SIZE 24

Definition at line 140 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [6/6]

#define USBD_EP0_TX_SIZE 24

Definition at line 140 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [1/6]

#define USBD_EP1_TX_SIZE 20

Definition at line 141 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [2/6]

#define USBD_EP1_TX_SIZE 20

Definition at line 141 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [3/6]

#define USBD_EP1_TX_SIZE 20

Definition at line 141 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [4/6]

#define USBD_EP1_TX_SIZE 20

Definition at line 141 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [5/6]

#define USBD_EP1_TX_SIZE 20

Definition at line 141 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [6/6]

#define USBD_EP1_TX_SIZE 20

Definition at line 141 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [1/6]

#define USBD_EP2_TX_SIZE 20

Definition at line 142 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [2/6]

#define USBD_EP2_TX_SIZE 20

Definition at line 142 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [3/6]

#define USBD_EP2_TX_SIZE 20

Definition at line 142 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [4/6]

#define USBD_EP2_TX_SIZE 20

Definition at line 142 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [5/6]

#define USBD_EP2_TX_SIZE 20

Definition at line 142 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [6/6]

#define USBD_EP2_TX_SIZE 20

Definition at line 142 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [1/6]

#define USBD_EP3_TX_SIZE 20

Definition at line 143 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [2/6]

#define USBD_EP3_TX_SIZE 20

Definition at line 143 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [3/6]

#define USBD_EP3_TX_SIZE 20

Definition at line 143 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [4/6]

#define USBD_EP3_TX_SIZE 20

Definition at line 143 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [5/6]

#define USBD_EP3_TX_SIZE 20

Definition at line 143 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [6/6]

#define USBD_EP3_TX_SIZE 20

Definition at line 143 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [1/6]

#define USBD_EP4_TX_SIZE 20

Definition at line 144 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [2/6]

#define USBD_EP4_TX_SIZE 20

Definition at line 144 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [3/6]

#define USBD_EP4_TX_SIZE 20

Definition at line 144 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [4/6]

#define USBD_EP4_TX_SIZE 20

Definition at line 144 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [5/6]

#define USBD_EP4_TX_SIZE 20

Definition at line 144 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [6/6]

#define USBD_EP4_TX_SIZE 20

Definition at line 144 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [1/6]

#define USBD_EP5_TX_SIZE 20

Definition at line 145 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [2/6]

#define USBD_EP5_TX_SIZE 20

Definition at line 145 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [3/6]

#define USBD_EP5_TX_SIZE 20

Definition at line 145 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [4/6]

#define USBD_EP5_TX_SIZE 20

Definition at line 145 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [5/6]

#define USBD_EP5_TX_SIZE 20

Definition at line 145 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [6/6]

#define USBD_EP5_TX_SIZE 20

Definition at line 145 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [1/6]

#define USBD_EP6_TX_SIZE 20

Definition at line 146 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [2/6]

#define USBD_EP6_TX_SIZE 20

Definition at line 146 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [3/6]

#define USBD_EP6_TX_SIZE 20

Definition at line 146 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [4/6]

#define USBD_EP6_TX_SIZE 20

Definition at line 146 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [5/6]

#define USBD_EP6_TX_SIZE 20

Definition at line 146 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [6/6]

#define USBD_EP6_TX_SIZE 20

Definition at line 146 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [1/6]

#define USBD_EP7_TX_SIZE 20

Definition at line 147 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [2/6]

#define USBD_EP7_TX_SIZE 20

Definition at line 147 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [3/6]

#define USBD_EP7_TX_SIZE 20

Definition at line 147 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [4/6]

#define USBD_EP7_TX_SIZE 20

Definition at line 147 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [5/6]

#define USBD_EP7_TX_SIZE 20

Definition at line 147 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [6/6]

#define USBD_EP7_TX_SIZE 20

Definition at line 147 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD_RX_SIZE [1/6]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 139 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ USBD_RX_SIZE [2/6]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 139 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD_RX_SIZE [3/6]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 139 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USBD_RX_SIZE [4/6]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 139 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ USBD_RX_SIZE [5/6]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 139 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USBD_RX_SIZE [6/6]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 139 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [1/6]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 50 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [2/6]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 50 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [3/6]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 50 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [4/6]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 50 of file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [5/6]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 50 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [6/6]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 50 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c.

◆ OTG_IRQ_HANDLER()

void OTG_IRQ_HANDLER ( void )

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 294 of file project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc sof signal select: otg1

< acc hick trim

< acc sof signal select: otg1

< acc hick trim

Definition at line 127 of file project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c.

Referenced by main().

◆ usb_gpio_config()

void usb_gpio_config ( void )

this function config gpio.

Parameters
none
Return values
none

Definition at line 219 of file project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c.

Referenced by main().

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

Variable Documentation

◆ otg_core_struct [1/2]

otg_core_type otg_core_struct

Definition at line 44 of file project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c.

Referenced by main(), and OTG_IRQ_HANDLER().

◆ otg_core_struct [2/2]

otg_core_type otg_core_struct

Definition at line 44 of file project/at_start_f437/examples/usb_device/vcp_loopback/src/main.c.

◆ usb_buffer [1/2]

uint8_t usb_buffer[256]

Definition at line 45 of file project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c.

Referenced by main().

◆ usb_buffer [2/2]

uint8_t usb_buffer[256]

Definition at line 45 of file project/at_start_f437/examples/usb_device/vcp_loopback/src/main.c.


AT32F435/437 Firmwary Library: ACC_calibration

Macros | Functions | Variables
ACC_calibration
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | ACC_TRIM
#define | ACC_TRIM
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
this function handles otgfs interrupt. More...

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_low_power_wakeup_config (void)
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...
void | ACC_IRQHandler (void)
acc interrupt handler More...
int | main (void)
main function. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

otg_core_type otg_core_struct
uint8_t | usb_buffer [256]
uint32_t | acc_c2_value = 0
otg_core_type otg_core_struct
uint8_t | usb_buffer [256]
uint32_t | acc_c2_value = 0

Detailed Description

Macro Definition Documentation

◆ ACC_TRIM [1/2]

#define ACC_TRIM

Definition at line 53 of file project/at_start_f435/examples/acc/calibration/src/main.c.

◆ ACC_TRIM [2/2]

#define ACC_TRIM

Definition at line 53 of file project/at_start_f437/examples/acc/calibration/src/main.c.

◆ OTG_IRQ_HANDLER

void OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 71 of file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.

Function Documentation

◆ ACC_IRQHandler()

void ACC_IRQHandler ( void )

acc interrupt handler

Parameters
none
Return values
none

< acc internal high-speed clock calibration ready error flag

< acc internal high-speed clock calibration ready error flag

< acc reference signal lost error flag

< acc reference signal lost error flag

< acc internal high-speed clock calibration ready error flag

< acc internal high-speed clock calibration ready error flag

< acc reference signal lost error flag

< acc reference signal lost error flag

Definition at line 144 of file project/at_start_f435/examples/acc/calibration/src/main.c.

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

main program

Parameters
none
Return values
none

< acc internal high-speed clock calibration ready interrupt enable

< acc reference signal lost interrupt enable

< acc sof signal select: otg1

< acc hick trim

< acc internal high-speed clock calibration ready interrupt enable

< acc reference signal lost interrupt enable

< acc sof signal select: otg1

< acc hick trim

Definition at line 167 of file project/at_start_f435/examples/acc/calibration/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c.

◆ OTG_IRQ_HANDLER()

void OTG_IRQ_HANDLER ( void )

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 135 of file project/at_start_f435/examples/acc/calibration/src/main.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c.

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

usb low power wakeup handler enable

Parameters
ms number of millisecond delay
Return values
none

Definition at line 353 of file project/at_start_f435/examples/acc/calibration/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 364 of file project/at_start_f435/examples/acc/calibration/src/main.c.

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

Variable Documentation

◆ acc_c2_value [1/2]

uint32_t acc_c2_value = 0

Definition at line 55 of file project/at_start_f435/examples/acc/calibration/src/main.c.

Referenced by acc_write_c2(), and main().

◆ acc_c2_value [2/2]

uint32_t acc_c2_value = 0

Definition at line 55 of file project/at_start_f437/examples/acc/calibration/src/main.c.

◆ otg_core_struct [1/2]

otg_core_type otg_core_struct

Definition at line 45 of file project/at_start_f435/examples/acc/calibration/src/main.c.

Referenced by main(), and OTG_IRQ_HANDLER().

◆ otg_core_struct [2/2]

otg_core_type otg_core_struct

Definition at line 45 of file project/at_start_f437/examples/acc/calibration/src/main.c.

◆ usb_buffer [1/2]

uint8_t usb_buffer[256]

Definition at line 46 of file project/at_start_f435/examples/acc/calibration/src/main.c.

Referenced by main().

◆ usb_buffer [2/2]

uint8_t usb_buffer[256]

Definition at line 46 of file project/at_start_f437/examples/acc/calibration/src/main.c.


AT32F435/437 Firmwary Library: ADC_combine_mode_ordinary_shift_twoslave_dma3

Functions | Variables
ADC_combine_mode_ordinary_shift_twoslave_dma3
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | tmr1_config (void)
tmr1 configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | dma1_trans_complete_flag
__IO uint32_t | adc1_overflow_flag
__IO uint32_t | adc2_overflow_flag
__IO uint32_t | adc3_overflow_flag
__IO uint16_t | adccom_ordinary_valuetab [6]
__IO uint32_t | dma1_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint32_t | adc2_overflow_flag = 0
__IO uint32_t | adc3_overflow_flag = 0
__IO uint32_t | dma1_trans_complete_flag
__IO uint32_t | adc1_overflow_flag
__IO uint32_t | adc2_overflow_flag
__IO uint32_t | adc3_overflow_flag
__IO uint16_t | adccom_ordinary_valuetab [6]
__IO uint32_t | dma1_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint32_t | adc2_overflow_flag = 0
__IO uint32_t | adc3_overflow_flag = 0

Detailed Description

Function Documentation

◆ ADC1_2_3_IRQHandler()

void ADC1_2_3_IRQHandler ( void )

this function handles adc1_2_3 handler.

Parameters
none
Return values
none

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

Definition at line 159 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c.

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< ordinary channel conversion overflow interrupt

< ordinary channel conversion overflow interrupt

< ordinary channel conversion overflow interrupt

< adc ready to conversion flag

< adc ready to conversion flag

< adc ready to conversion flag

< adc ready to conversion flag

< adc ready to conversion flag

< adc ready to conversion flag

Definition at line 132 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 83 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 118 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1_channel1 handler.

this function handles dma interrupt request.

this function handles dma1 channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 145 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 99 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by main().

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 7

< gpio pins number 0

Definition at line 54 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 57 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 242 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 48 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 127 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 109 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 136 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c.

◆ tmr1_config()

static void tmr1_config ( void )
static

tmr1 configuration.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by main().

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 96 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c.

Variable Documentation

◆ adc1_overflow_flag [1/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc1_overflow_flag [2/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by main().

◆ adc1_overflow_flag [3/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc1_overflow_flag [4/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 40 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc2_overflow_flag [1/4]

__IO uint32_t adc2_overflow_flag
extern

Definition at line 41 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc2_overflow_flag [2/4]

__IO uint32_t adc2_overflow_flag = 0

Definition at line 41 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by main().

◆ adc2_overflow_flag [3/4]

__IO uint32_t adc2_overflow_flag
extern

Definition at line 41 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc2_overflow_flag [4/4]

__IO uint32_t adc2_overflow_flag = 0

Definition at line 41 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc3_overflow_flag [1/4]

__IO uint32_t adc3_overflow_flag
extern

Definition at line 42 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc3_overflow_flag [2/4]

__IO uint32_t adc3_overflow_flag = 0

Definition at line 42 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by main().

◆ adc3_overflow_flag [3/4]

__IO uint32_t adc3_overflow_flag
extern

Definition at line 42 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc3_overflow_flag [4/4]

__IO uint32_t adc3_overflow_flag = 0

Definition at line 42 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adccom_ordinary_valuetab [1/2]

__IO uint16_t adccom_ordinary_valuetab[6]

Definition at line 38 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by dma_config(), and main().

◆ adccom_ordinary_valuetab [2/2]

__IO uint16_t adccom_ordinary_valuetab[6]

Definition at line 38 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by dma_config().

◆ dma1_trans_complete_flag [1/4]

__IO uint32_t dma1_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by DMA1_Channel1_IRQHandler().

◆ dma1_trans_complete_flag [2/4]

__IO uint32_t dma1_trans_complete_flag = 0

Definition at line 39 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by main().

◆ dma1_trans_complete_flag [3/4]

__IO uint32_t dma1_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ dma1_trans_complete_flag [4/4]

__IO uint32_t dma1_trans_complete_flag = 0

Definition at line 39 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.


AT32F435/437 Firmwary Library: ADC_combine_mode_ordinary_shift_twoslave_dma4

Functions | Variables
ADC_combine_mode_ordinary_shift_twoslave_dma4
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | tmr1_config (void)
tmr1 configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | dma1_trans_complete_flag
__IO uint32_t | adc1_overflow_flag
__IO uint32_t | adc2_overflow_flag
__IO uint32_t | adc3_overflow_flag
__IO uint32_t | adccom_ordinary_valuetab [5]
__IO uint32_t | dma1_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint32_t | adc2_overflow_flag = 0
__IO uint32_t | adc3_overflow_flag = 0
__IO uint32_t | dma1_trans_complete_flag
__IO uint32_t | adc1_overflow_flag
__IO uint32_t | adc2_overflow_flag
__IO uint32_t | adc3_overflow_flag
__IO uint32_t | adccom_ordinary_valuetab [5]
__IO uint32_t | dma1_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint32_t | adc2_overflow_flag = 0
__IO uint32_t | adc3_overflow_flag = 0

Detailed Description

Function Documentation

◆ ADC1_2_3_IRQHandler()

void ADC1_2_3_IRQHandler ( void )

this function handles adc1_2_3 handler.

Parameters
none
Return values
none

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

Definition at line 159 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c.

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< ordinary channel conversion overflow interrupt

< ordinary channel conversion overflow interrupt

< ordinary channel conversion overflow interrupt

< adc ready to conversion flag

< adc ready to conversion flag

< adc ready to conversion flag

< adc ready to conversion flag

< adc ready to conversion flag

< adc ready to conversion flag

Definition at line 132 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 83 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 118 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1_channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 145 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 99 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c.

Referenced by main().

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 7

< gpio pins number 0

Definition at line 54 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 57 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 241 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 48 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 127 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 109 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 136 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c.

◆ tmr1_config()

static void tmr1_config ( void )
static

tmr1 configuration.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c.

Referenced by main().

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 96 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c.

Variable Documentation

◆ adc1_overflow_flag [1/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc1_overflow_flag [2/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c.

Referenced by main().

◆ adc1_overflow_flag [3/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc1_overflow_flag [4/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 40 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c.

◆ adc2_overflow_flag [1/4]

__IO uint32_t adc2_overflow_flag
extern

Definition at line 41 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc2_overflow_flag [2/4]

__IO uint32_t adc2_overflow_flag = 0

Definition at line 41 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c.

Referenced by main().

◆ adc2_overflow_flag [3/4]

__IO uint32_t adc2_overflow_flag
extern

Definition at line 41 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc2_overflow_flag [4/4]

__IO uint32_t adc2_overflow_flag = 0

Definition at line 41 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c.

◆ adc3_overflow_flag [1/4]

__IO uint32_t adc3_overflow_flag
extern

Definition at line 42 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc3_overflow_flag [2/4]

__IO uint32_t adc3_overflow_flag = 0

Definition at line 42 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c.

Referenced by main().

◆ adc3_overflow_flag [3/4]

__IO uint32_t adc3_overflow_flag
extern

Definition at line 42 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc3_overflow_flag [4/4]

__IO uint32_t adc3_overflow_flag = 0

Definition at line 42 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c.

◆ adccom_ordinary_valuetab [1/2]

__IO uint32_t adccom_ordinary_valuetab[5]

Definition at line 38 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c.

Referenced by dma_config(), and main().

◆ adccom_ordinary_valuetab [2/2]

__IO uint32_t adccom_ordinary_valuetab[5]

Definition at line 38 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c.

Referenced by dma_config().

◆ dma1_trans_complete_flag [1/4]

__IO uint32_t dma1_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by DMA1_Channel1_IRQHandler().

◆ dma1_trans_complete_flag [2/4]

__IO uint32_t dma1_trans_complete_flag = 0

Definition at line 39 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c.

Referenced by main().

◆ dma1_trans_complete_flag [3/4]

__IO uint32_t dma1_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ dma1_trans_complete_flag [4/4]

__IO uint32_t dma1_trans_complete_flag = 0

Definition at line 39 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c.


AT32F435/437 Firmwary Library: ADC_combine_mode_ordinary_smlt_oneslave_dma2

Functions | Variables
ADC_combine_mode_ordinary_smlt_oneslave_dma2
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | dma1_trans_complete_flag
__IO uint32_t | adc1_overflow_flag
__IO uint32_t | adc2_overflow_flag
__IO uint32_t | adccom_ordinary_valuetab [5][3]
__IO uint32_t | dma1_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint32_t | adc2_overflow_flag = 0
__IO uint32_t | dma1_trans_complete_flag
__IO uint32_t | adc1_overflow_flag
__IO uint32_t | adc2_overflow_flag
__IO uint32_t | adccom_ordinary_valuetab [5][3]
__IO uint32_t | dma1_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint32_t | adc2_overflow_flag = 0

Detailed Description

Function Documentation

◆ ADC1_2_3_IRQHandler()

void ADC1_2_3_IRQHandler ( void )

this function handles adc1_2_3 handler.

Parameters
none
Return values
none

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

Definition at line 158 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c.

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< ordinary channel conversion overflow interrupt

< ordinary channel conversion overflow interrupt

< adc ready to conversion flag

< adc ready to conversion flag

Definition at line 108 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 82 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 117 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1_channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 144 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 75 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c.

Referenced by main().

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

Definition at line 52 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 56 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 198 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 69 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 47 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 126 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 108 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 135 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 95 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c.

Variable Documentation

◆ adc1_overflow_flag [1/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc1_overflow_flag [2/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c.

Referenced by main().

◆ adc1_overflow_flag [3/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc1_overflow_flag [4/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 40 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c.

◆ adc2_overflow_flag [1/4]

__IO uint32_t adc2_overflow_flag
extern

Definition at line 41 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc2_overflow_flag [2/4]

__IO uint32_t adc2_overflow_flag = 0

Definition at line 41 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c.

Referenced by main().

◆ adc2_overflow_flag [3/4]

__IO uint32_t adc2_overflow_flag
extern

Definition at line 41 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc2_overflow_flag [4/4]

__IO uint32_t adc2_overflow_flag = 0

Definition at line 41 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c.

◆ adccom_ordinary_valuetab [1/2]

__IO uint32_t adccom_ordinary_valuetab[5][3]

Definition at line 38 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c.

Referenced by dma_config(), and main().

◆ adccom_ordinary_valuetab [2/2]

__IO uint32_t adccom_ordinary_valuetab[5][3]

Definition at line 38 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c.

Referenced by dma_config().

◆ dma1_trans_complete_flag [1/4]

__IO uint32_t dma1_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by DMA1_Channel1_IRQHandler().

◆ dma1_trans_complete_flag [2/4]

__IO uint32_t dma1_trans_complete_flag = 0

Definition at line 39 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c.

Referenced by main().

◆ dma1_trans_complete_flag [3/4]

__IO uint32_t dma1_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ dma1_trans_complete_flag [4/4]

__IO uint32_t dma1_trans_complete_flag = 0

Definition at line 39 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c.


AT32F435/437 Firmwary Library: ADC_combine_mode_ordinary_smlt_oneslave_edma

Functions | Variables
ADC_combine_mode_ordinary_smlt_oneslave_edma
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | EDMA_Stream1_IRQHandler (void)
this function handles edma_stream1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | edma_config (void)
edma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | edma_trans_complete_flag
__IO uint32_t | adc1_overflow_flag
__IO uint32_t | adc2_overflow_flag
__IO uint32_t | adccom_ordinary_valuetab [5][3]
__IO uint32_t | edma_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint32_t | adc2_overflow_flag = 0
__IO uint32_t | edma_trans_complete_flag
__IO uint32_t | adc1_overflow_flag
__IO uint32_t | adc2_overflow_flag
__IO uint32_t | adccom_ordinary_valuetab [5][3]
__IO uint32_t | edma_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint32_t | adc2_overflow_flag = 0

Detailed Description

Function Documentation

◆ ADC1_2_3_IRQHandler()

void ADC1_2_3_IRQHandler ( void )

this function handles adc1_2_3 handler.

Parameters
none
Return values
none

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

Definition at line 158 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c.

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< ordinary channel conversion overflow interrupt

< ordinary channel conversion overflow interrupt

< adc ready to conversion flag

< adc ready to conversion flag

Definition at line 113 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 82 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 117 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c.

◆ edma_config()

static void edma_config ( void )
static

edma configuration.

Parameters
none
Return values
none

Definition at line 75 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c.

Referenced by main().

◆ EDMA_Stream1_IRQHandler()

void EDMA_Stream1_IRQHandler ( void )

this function handles edma_stream1 handler.

this function handles edma stream1 handler.

Parameters
none
Return values
none

Definition at line 144 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

Definition at line 52 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 56 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 203 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 69 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 47 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 126 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 108 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 135 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 95 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c.

Variable Documentation

◆ adc1_overflow_flag [1/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc1_overflow_flag [2/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c.

Referenced by main().

◆ adc1_overflow_flag [3/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc1_overflow_flag [4/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 40 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c.

◆ adc2_overflow_flag [1/4]

__IO uint32_t adc2_overflow_flag
extern

Definition at line 41 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc2_overflow_flag [2/4]

__IO uint32_t adc2_overflow_flag = 0

Definition at line 41 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c.

Referenced by main().

◆ adc2_overflow_flag [3/4]

__IO uint32_t adc2_overflow_flag
extern

Definition at line 41 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc2_overflow_flag [4/4]

__IO uint32_t adc2_overflow_flag = 0

Definition at line 41 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c.

◆ adccom_ordinary_valuetab [1/2]

__IO uint32_t adccom_ordinary_valuetab[5][3]

Definition at line 38 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c.

Referenced by edma_config(), and main().

◆ adccom_ordinary_valuetab [2/2]

__IO uint32_t adccom_ordinary_valuetab[5][3]

Definition at line 38 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c.

Referenced by edma_config().

◆ edma_trans_complete_flag [1/4]

__IO uint32_t edma_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c.

Referenced by EDMA_Stream1_IRQHandler().

◆ edma_trans_complete_flag [2/4]

__IO uint32_t edma_trans_complete_flag = 0

Definition at line 39 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c.

Referenced by main().

◆ edma_trans_complete_flag [3/4]

__IO uint32_t edma_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c.

◆ edma_trans_complete_flag [4/4]

__IO uint32_t edma_trans_complete_flag = 0

Definition at line 39 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c.


AT32F435/437 Firmwary Library: ADC_combine_mode_ordinary_smlt_twoslave_dma1

Functions | Variables
ADC_combine_mode_ordinary_smlt_twoslave_dma1
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | tmr1_config (void)
tmr1 configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | dma1_trans_complete_flag
__IO uint32_t | adc1_overflow_flag
__IO uint32_t | adc2_overflow_flag
__IO uint32_t | adc3_overflow_flag
__IO uint16_t | adccom_ordinary_valuetab [3][3][3]
__IO uint32_t | dma1_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint32_t | adc2_overflow_flag = 0
__IO uint32_t | adc3_overflow_flag = 0
__IO uint32_t | dma1_trans_complete_flag
__IO uint32_t | adc1_overflow_flag
__IO uint32_t | adc2_overflow_flag
__IO uint32_t | adc3_overflow_flag
__IO uint16_t | adccom_ordinary_valuetab [3][3][3]
__IO uint32_t | dma1_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint32_t | adc2_overflow_flag = 0
__IO uint32_t | adc3_overflow_flag = 0

Detailed Description

Function Documentation

◆ ADC1_2_3_IRQHandler()

void ADC1_2_3_IRQHandler ( void )

this function handles adc1_2_3 handler.

Parameters
none
Return values
none

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

Definition at line 159 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c.

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< ordinary channel conversion overflow interrupt

< ordinary channel conversion overflow interrupt

< ordinary channel conversion overflow interrupt

< adc ready to conversion flag

< adc ready to conversion flag

< adc ready to conversion flag

Definition at line 159 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 83 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 118 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1_channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 145 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 126 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c.

Referenced by main().

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

< gpio pins number 0

< gpio pins number 2

< gpio pins number 3

Definition at line 54 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 57 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 266 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 48 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 127 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 109 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 136 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c.

◆ tmr1_config()

static void tmr1_config ( void )
static

tmr1 configuration.

Parameters
none
Return values
none

< gpio pins number 14

Definition at line 82 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c.

Referenced by main().

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 96 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c.

Variable Documentation

◆ adc1_overflow_flag [1/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc1_overflow_flag [2/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c.

Referenced by main().

◆ adc1_overflow_flag [3/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc1_overflow_flag [4/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 40 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c.

◆ adc2_overflow_flag [1/4]

__IO uint32_t adc2_overflow_flag
extern

Definition at line 41 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc2_overflow_flag [2/4]

__IO uint32_t adc2_overflow_flag = 0

Definition at line 41 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c.

Referenced by main().

◆ adc2_overflow_flag [3/4]

__IO uint32_t adc2_overflow_flag
extern

Definition at line 41 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc2_overflow_flag [4/4]

__IO uint32_t adc2_overflow_flag = 0

Definition at line 41 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c.

◆ adc3_overflow_flag [1/4]

__IO uint32_t adc3_overflow_flag
extern

Definition at line 42 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc3_overflow_flag [2/4]

__IO uint32_t adc3_overflow_flag = 0

Definition at line 42 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c.

Referenced by main().

◆ adc3_overflow_flag [3/4]

__IO uint32_t adc3_overflow_flag
extern

Definition at line 42 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc3_overflow_flag [4/4]

__IO uint32_t adc3_overflow_flag = 0

Definition at line 42 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c.

◆ adccom_ordinary_valuetab [1/2]

__IO uint16_t adccom_ordinary_valuetab[3][3][3]

Definition at line 38 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c.

Referenced by dma_config(), and main().

◆ adccom_ordinary_valuetab [2/2]

__IO uint16_t adccom_ordinary_valuetab[3][3][3]

Definition at line 38 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c.

Referenced by dma_config().

◆ dma1_trans_complete_flag [1/4]

__IO uint32_t dma1_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by DMA1_Channel1_IRQHandler().

◆ dma1_trans_complete_flag [2/4]

__IO uint32_t dma1_trans_complete_flag = 0

Definition at line 39 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c.

Referenced by main().

◆ dma1_trans_complete_flag [3/4]

__IO uint32_t dma1_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ dma1_trans_complete_flag [4/4]

__IO uint32_t dma1_trans_complete_flag = 0

Definition at line 39 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c.


AT32F435/437 Firmwary Library: ADC_combine_mode_ordinary_smlt_twoslave_dma5

Functions | Variables
ADC_combine_mode_ordinary_smlt_twoslave_dma5
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | tmr1_config (void)
tmr1 configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | dma1_trans_complete_flag
__IO uint32_t | adc1_overflow_flag
__IO uint32_t | adc2_overflow_flag
__IO uint32_t | adc3_overflow_flag
__IO uint32_t | adccom_ordinary_valuetab [3][3][2]
__IO uint32_t | dma1_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint32_t | adc2_overflow_flag = 0
__IO uint32_t | adc3_overflow_flag = 0
__IO uint32_t | dma1_trans_complete_flag
__IO uint32_t | adc1_overflow_flag
__IO uint32_t | adc2_overflow_flag
__IO uint32_t | adc3_overflow_flag
__IO uint32_t | adccom_ordinary_valuetab [3][3][2]
__IO uint32_t | dma1_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint32_t | adc2_overflow_flag = 0
__IO uint32_t | adc3_overflow_flag = 0

Detailed Description

Function Documentation

◆ ADC1_2_3_IRQHandler()

void ADC1_2_3_IRQHandler ( void )

this function handles adc1_2_3 handler.

Parameters
none
Return values
none

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

Definition at line 159 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c.

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< ordinary channel conversion overflow interrupt

< ordinary channel conversion overflow interrupt

< ordinary channel conversion overflow interrupt

< adc ready to conversion flag

< adc ready to conversion flag

< adc ready to conversion flag

Definition at line 157 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 83 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 118 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1_channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 145 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 124 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c.

Referenced by main().

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

< gpio pins number 0

< gpio pins number 2

< gpio pins number 3

Definition at line 54 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 57 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 264 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 48 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 127 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 109 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 136 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c.

◆ tmr1_config()

static void tmr1_config ( void )
static

tmr1 configuration.

Parameters
none
Return values
none

< gpio pins number 8

Definition at line 82 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c.

Referenced by main().

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 96 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c.

Variable Documentation

◆ adc1_overflow_flag [1/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc1_overflow_flag [2/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c.

Referenced by main().

◆ adc1_overflow_flag [3/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc1_overflow_flag [4/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 40 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c.

◆ adc2_overflow_flag [1/4]

__IO uint32_t adc2_overflow_flag
extern

Definition at line 41 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc2_overflow_flag [2/4]

__IO uint32_t adc2_overflow_flag = 0

Definition at line 41 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c.

Referenced by main().

◆ adc2_overflow_flag [3/4]

__IO uint32_t adc2_overflow_flag
extern

Definition at line 41 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by main().

◆ adc2_overflow_flag [4/4]

__IO uint32_t adc2_overflow_flag = 0

Definition at line 41 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc3_overflow_flag [1/4]

__IO uint32_t adc3_overflow_flag
extern

Definition at line 42 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc3_overflow_flag [2/4]

__IO uint32_t adc3_overflow_flag = 0

Definition at line 42 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c.

Referenced by main().

◆ adc3_overflow_flag [3/4]

__IO uint32_t adc3_overflow_flag
extern

Definition at line 42 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by main().

◆ adc3_overflow_flag [4/4]

__IO uint32_t adc3_overflow_flag = 0

Definition at line 42 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adccom_ordinary_valuetab [1/2]

__IO uint32_t adccom_ordinary_valuetab[3][3][2]

Definition at line 38 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c.

Referenced by dma_config(), and main().

◆ adccom_ordinary_valuetab [2/2]

__IO uint32_t adccom_ordinary_valuetab[3][3][2]

Definition at line 38 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c.

Referenced by dma_config().

◆ dma1_trans_complete_flag [1/4]

__IO uint32_t dma1_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by DMA1_Channel1_IRQHandler().

◆ dma1_trans_complete_flag [2/4]

__IO uint32_t dma1_trans_complete_flag = 0

Definition at line 39 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c.

Referenced by main().

◆ dma1_trans_complete_flag [3/4]

__IO uint32_t dma1_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by main().

◆ dma1_trans_complete_flag [4/4]

__IO uint32_t dma1_trans_complete_flag = 0

Definition at line 39 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c.

Referenced by DMA1_Channel1_IRQHandler().


AT32F435/437 Firmwary Library: ADC_combine_mode_preempt_interltrig_twoslave

Functions | Variables
ADC_combine_mode_preempt_interltrig_twoslave
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_preempt_valuetab [2][3]
__IO uint16_t | adc2_preempt_valuetab [2][3]
__IO uint16_t | adc3_preempt_valuetab [2][3]
__IO uint16_t | adc1_preempt_conversion_count
__IO uint16_t | adc2_preempt_conversion_count
__IO uint16_t | adc3_preempt_conversion_count
__IO uint16_t | adc1_preempt_valuetab [2][3] = {0}
__IO uint16_t | adc2_preempt_valuetab [2][3] = {0}
__IO uint16_t | adc3_preempt_valuetab [2][3] = {0}
__IO uint16_t | adc1_preempt_conversion_count = 0
__IO uint16_t | adc2_preempt_conversion_count = 0
__IO uint16_t | adc3_preempt_conversion_count = 0
__IO uint16_t | adc1_preempt_valuetab [2][3]
__IO uint16_t | adc2_preempt_valuetab [2][3]
__IO uint16_t | adc3_preempt_valuetab [2][3]
__IO uint16_t | adc1_preempt_conversion_count
__IO uint16_t | adc2_preempt_conversion_count
__IO uint16_t | adc3_preempt_conversion_count
__IO uint16_t | adc1_preempt_valuetab [2][3] = {0}
__IO uint16_t | adc2_preempt_valuetab [2][3] = {0}
__IO uint16_t | adc3_preempt_valuetab [2][3] = {0}
__IO uint16_t | adc1_preempt_conversion_count = 0
__IO uint16_t | adc2_preempt_conversion_count = 0
__IO uint16_t | adc3_preempt_conversion_count = 0

Detailed Description

Function Documentation

◆ ADC1_2_3_IRQHandler()

void ADC1_2_3_IRQHandler ( void )

this function handles adc1_2_3 handler.

Parameters
none
Return values
none

< preempt channels conversion end flag

< preempt channels conversion end flag

< preempt channels conversion end flag

< preempt channels conversion end flag

< preempt channels conversion end flag

< preempt channels conversion end flag

< preempt channels conversion end flag

< preempt channels conversion end flag

< preempt channels conversion end flag

< preempt channels conversion end flag

< preempt channels conversion end flag

< preempt channels conversion end flag

Definition at line 148 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c.

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< preempt channels conversion end interrupt

< preempt channels conversion end interrupt

< preempt channels conversion end interrupt

< adc ready to conversion flag

< adc ready to conversion flag

< adc ready to conversion flag

Definition at line 81 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 86 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

< gpio pins number 0

< gpio pins number 2

< gpio pins number 3

Definition at line 53 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 60 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 201 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 73 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 139 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 99 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c.

Variable Documentation

◆ adc1_preempt_conversion_count [1/4]

__IO uint16_t adc1_preempt_conversion_count
extern

Definition at line 41 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc1_preempt_conversion_count [2/4]

__IO uint16_t adc1_preempt_conversion_count = 0

Definition at line 41 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by main().

◆ adc1_preempt_conversion_count [3/4]

__IO uint16_t adc1_preempt_conversion_count
extern

Definition at line 41 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by main().

◆ adc1_preempt_conversion_count [4/4]

__IO uint16_t adc1_preempt_conversion_count = 0

Definition at line 41 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc1_preempt_valuetab [1/4]

__IO uint16_t adc1_preempt_valuetab[2][3]
extern

Definition at line 38 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc1_preempt_valuetab [2/4]

__IO uint16_t adc1_preempt_valuetab[2][3] = {0}

Definition at line 38 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by main().

◆ adc1_preempt_valuetab [3/4]

__IO uint16_t adc1_preempt_valuetab[2][3]
extern

Definition at line 38 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

◆ adc1_preempt_valuetab [4/4]

__IO uint16_t adc1_preempt_valuetab[2][3] = {0}

Definition at line 38 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

◆ adc2_preempt_conversion_count [1/4]

__IO uint16_t adc2_preempt_conversion_count
extern

Definition at line 42 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc2_preempt_conversion_count [2/4]

__IO uint16_t adc2_preempt_conversion_count = 0

Definition at line 42 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by main().

◆ adc2_preempt_conversion_count [3/4]

__IO uint16_t adc2_preempt_conversion_count
extern

Definition at line 42 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by main().

◆ adc2_preempt_conversion_count [4/4]

__IO uint16_t adc2_preempt_conversion_count = 0

Definition at line 42 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc2_preempt_valuetab [1/4]

__IO uint16_t adc2_preempt_valuetab[2][3]
extern

Definition at line 39 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc2_preempt_valuetab [2/4]

__IO uint16_t adc2_preempt_valuetab[2][3] = {0}

Definition at line 39 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by main().

◆ adc2_preempt_valuetab [3/4]

__IO uint16_t adc2_preempt_valuetab[2][3]
extern

Definition at line 39 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by main().

◆ adc2_preempt_valuetab [4/4]

__IO uint16_t adc2_preempt_valuetab[2][3] = {0}

Definition at line 39 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc3_preempt_conversion_count [1/4]

__IO uint16_t adc3_preempt_conversion_count
extern

Definition at line 43 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc3_preempt_conversion_count [2/4]

__IO uint16_t adc3_preempt_conversion_count = 0

Definition at line 43 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by main().

◆ adc3_preempt_conversion_count [3/4]

__IO uint16_t adc3_preempt_conversion_count
extern

Definition at line 43 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by main().

◆ adc3_preempt_conversion_count [4/4]

__IO uint16_t adc3_preempt_conversion_count = 0

Definition at line 43 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc3_preempt_valuetab [1/4]

__IO uint16_t adc3_preempt_valuetab[2][3]
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc3_preempt_valuetab [2/4]

__IO uint16_t adc3_preempt_valuetab[2][3] = {0}

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by main().

◆ adc3_preempt_valuetab [3/4]

__IO uint16_t adc3_preempt_valuetab[2][3]
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by main().

◆ adc3_preempt_valuetab [4/4]

__IO uint16_t adc3_preempt_valuetab[2][3] = {0}

Definition at line 40 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by ADC1_2_3_IRQHandler().


AT32F435/437 Firmwary Library: ADC_conversion_abort

Functions | Variables
ADC_conversion_abort
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | dma_trans_complete_flag
__IO uint32_t | adc1_overflow_flag
__IO uint16_t | adc1_ordinary_valuetab [10][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint16_t | dma_trans_complete_flag
__IO uint32_t | adc1_overflow_flag
__IO uint16_t | adc1_ordinary_valuetab [10][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0

Detailed Description

Function Documentation

◆ ADC1_2_3_IRQHandler()

void ADC1_2_3_IRQHandler ( void )

this function handles adc1_2_3 handler.

Parameters
none
Return values
none

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

Definition at line 157 of file project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c.

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< ordinary channel conversion overflow interrupt

< adc ready to conversion flag

Definition at line 102 of file project/at_start_f435/examples/adc/conversion_abort/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1_channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 143 of file project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 69 of file project/at_start_f435/examples/adc/conversion_abort/src/main.c.

Referenced by main().

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

Definition at line 51 of file project/at_start_f435/examples/adc/conversion_abort/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 175 of file project/at_start_f435/examples/adc/conversion_abort/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c.

Variable Documentation

◆ adc1_ordinary_valuetab [1/2]

__IO uint16_t adc1_ordinary_valuetab[10][3] = {0}

Definition at line 38 of file project/at_start_f435/examples/adc/conversion_abort/src/main.c.

Referenced by dma_config(), and main().

◆ adc1_ordinary_valuetab [2/2]

__IO uint16_t adc1_ordinary_valuetab[10][3] = {0}

Definition at line 38 of file project/at_start_f437/examples/adc/conversion_abort/src/main.c.

Referenced by dma_config().

◆ adc1_overflow_flag [1/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc1_overflow_flag [2/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 40 of file project/at_start_f435/examples/adc/conversion_abort/src/main.c.

Referenced by main().

◆ adc1_overflow_flag [3/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc1_overflow_flag [4/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 40 of file project/at_start_f437/examples/adc/conversion_abort/src/main.c.

◆ dma_trans_complete_flag [1/4]

__IO uint16_t dma_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/conversion_abort/src/main.c.

Referenced by DMA1_Channel1_IRQHandler().

◆ dma_trans_complete_flag [2/4]

__IO uint16_t dma_trans_complete_flag = 0

Definition at line 39 of file project/at_start_f435/examples/adc/conversion_abort/src/main.c.

Referenced by main().

◆ dma_trans_complete_flag [3/4]

__IO uint16_t dma_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/conversion_abort/src/main.c.

◆ dma_trans_complete_flag [4/4]

__IO uint16_t dma_trans_complete_flag = 0

Definition at line 39 of file project/at_start_f437/examples/adc/conversion_abort/src/main.c.


AT32F435/437 Firmwary Library: ADC_current_vref_value_check

Functions | Variables
ADC_current_vref_value_check
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | adc1_overflow_flag
__IO uint16_t | adc1_ordinary_value = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint32_t | adc1_overflow_flag
__IO uint16_t | adc1_ordinary_value = 0
__IO uint32_t | adc1_overflow_flag = 0

Detailed Description

Function Documentation

◆ ADC1_2_3_IRQHandler()

void ADC1_2_3_IRQHandler ( void )

this function handles adc1_2_3 handler.

Parameters
none
Return values
none

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

Definition at line 143 of file project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c.

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< ordinary channel conversion overflow interrupt

< adc ready to conversion flag

Definition at line 82 of file project/at_start_f435/examples/adc/current_vref_value_check/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 49 of file project/at_start_f435/examples/adc/current_vref_value_check/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 153 of file project/at_start_f435/examples/adc/current_vref_value_check/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c.

Variable Documentation

◆ adc1_ordinary_value [1/2]

__IO uint16_t adc1_ordinary_value = 0

Definition at line 38 of file project/at_start_f435/examples/adc/current_vref_value_check/src/main.c.

Referenced by dma_config(), and main().

◆ adc1_ordinary_value [2/2]

__IO uint16_t adc1_ordinary_value = 0

Definition at line 38 of file project/at_start_f437/examples/adc/current_vref_value_check/src/main.c.

Referenced by dma_config().

◆ adc1_overflow_flag [1/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc1_overflow_flag [2/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 39 of file project/at_start_f435/examples/adc/current_vref_value_check/src/main.c.

Referenced by main().

◆ adc1_overflow_flag [3/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc1_overflow_flag [4/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 39 of file project/at_start_f437/examples/adc/current_vref_value_check/src/main.c.


AT32F435/437 Firmwary Library: ADC_edma_double_buffer

Functions | Variables
ADC_edma_double_buffer
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | EDMA_Stream1_IRQHandler (void)
this function handles edma_stream1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | edma_config (void)
edma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | edma_trans_complete_flag
__IO uint16_t | double_buffer_is_useful
__IO uint32_t | adc1_overflow_flag
__IO uint16_t | adc1_ordinary_valuetab [3] = {0}
__IO uint16_t | double_adc1_ordinary_valuetab [3] = {0}
__IO uint16_t | edma_trans_complete_flag = 0
__IO uint16_t | double_buffer_is_useful = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint16_t | edma_trans_complete_flag
__IO uint16_t | double_buffer_is_useful
__IO uint32_t | adc1_overflow_flag
__IO uint16_t | adc1_ordinary_valuetab [3] = {0}
__IO uint16_t | double_adc1_ordinary_valuetab [3] = {0}
__IO uint16_t | edma_trans_complete_flag = 0
__IO uint16_t | double_buffer_is_useful = 0
__IO uint32_t | adc1_overflow_flag = 0

Detailed Description

Function Documentation

◆ ADC1_2_3_IRQHandler()

void ADC1_2_3_IRQHandler ( void )

this function handles adc1_2_3 handler.

Parameters
none
Return values
none

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

Definition at line 167 of file project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c.

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< ordinary channel conversion overflow interrupt

< adc ready to conversion flag

Definition at line 115 of file project/at_start_f435/examples/adc/edma_double_buffer/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 83 of file project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 118 of file project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c.

◆ edma_config()

static void edma_config ( void )
static

edma configuration.

Parameters
none
Return values
none

Definition at line 71 of file project/at_start_f435/examples/adc/edma_double_buffer/src/main.c.

Referenced by main().

◆ EDMA_Stream1_IRQHandler()

void EDMA_Stream1_IRQHandler ( void )

this function handles edma_stream1 handler.

Parameters
none
Return values
none

Definition at line 145 of file project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

Definition at line 53 of file project/at_start_f435/examples/adc/edma_double_buffer/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 57 of file project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 189 of file project/at_start_f435/examples/adc/edma_double_buffer/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 48 of file project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 127 of file project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 109 of file project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 136 of file project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 96 of file project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c.

Variable Documentation

◆ adc1_ordinary_valuetab [1/2]

__IO uint16_t adc1_ordinary_valuetab[3] = {0}

Definition at line 38 of file project/at_start_f435/examples/adc/edma_double_buffer/src/main.c.

Referenced by edma_config(), and main().

◆ adc1_ordinary_valuetab [2/2]

__IO uint16_t adc1_ordinary_valuetab[3] = {0}

Definition at line 38 of file project/at_start_f437/examples/adc/edma_double_buffer/src/main.c.

Referenced by edma_config().

◆ adc1_overflow_flag [1/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc1_overflow_flag [2/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 42 of file project/at_start_f435/examples/adc/edma_double_buffer/src/main.c.

Referenced by main().

◆ adc1_overflow_flag [3/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc1_overflow_flag [4/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 42 of file project/at_start_f437/examples/adc/edma_double_buffer/src/main.c.

◆ double_adc1_ordinary_valuetab [1/2]

__IO uint16_t double_adc1_ordinary_valuetab[3] = {0}

Definition at line 39 of file project/at_start_f435/examples/adc/edma_double_buffer/src/main.c.

Referenced by edma_config(), and main().

◆ double_adc1_ordinary_valuetab [2/2]

__IO uint16_t double_adc1_ordinary_valuetab[3] = {0}

Definition at line 39 of file project/at_start_f437/examples/adc/edma_double_buffer/src/main.c.

Referenced by edma_config().

◆ double_buffer_is_useful [1/4]

__IO uint16_t double_buffer_is_useful
extern

Definition at line 41 of file project/at_start_f435/examples/adc/edma_double_buffer/src/main.c.

Referenced by EDMA_Stream1_IRQHandler().

◆ double_buffer_is_useful [2/4]

__IO uint16_t double_buffer_is_useful = 0

Definition at line 41 of file project/at_start_f435/examples/adc/edma_double_buffer/src/main.c.

Referenced by main().

◆ double_buffer_is_useful [3/4]

__IO uint16_t double_buffer_is_useful
extern

Definition at line 41 of file project/at_start_f435/examples/adc/edma_double_buffer/src/main.c.

Referenced by main().

◆ double_buffer_is_useful [4/4]

__IO uint16_t double_buffer_is_useful = 0

Definition at line 41 of file project/at_start_f437/examples/adc/edma_double_buffer/src/main.c.

Referenced by EDMA_Stream1_IRQHandler().

◆ edma_trans_complete_flag [1/4]

__IO uint16_t edma_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c.

Referenced by EDMA_Stream1_IRQHandler().

◆ edma_trans_complete_flag [2/4]

__IO uint16_t edma_trans_complete_flag = 0

Definition at line 40 of file project/at_start_f435/examples/adc/edma_double_buffer/src/main.c.

Referenced by main().

◆ edma_trans_complete_flag [3/4]

__IO uint16_t edma_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c.

Referenced by main().

◆ edma_trans_complete_flag [4/4]

__IO uint16_t edma_trans_complete_flag = 0

Definition at line 40 of file project/at_start_f437/examples/adc/edma_double_buffer/src/main.c.

Referenced by EDMA_Stream1_IRQHandler().


AT32F435/437 Firmwary Library: ADC_exint_trigger_partitioned

Functions | Variables
ADC_exint_trigger_partitioned
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | exint_config (void)
exint configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_preempt_valuetab [3][3]
__IO uint16_t | dma_trans_complete_flag
__IO uint16_t | preempt_trigger_count
__IO uint32_t | adc1_overflow_flag
__IO uint16_t | adc1_ordinary_valuetab [3][3] = {0}
__IO uint16_t | adc1_preempt_valuetab [3][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint16_t | preempt_trigger_count = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint16_t | adc1_preempt_valuetab [3][3]
__IO uint16_t | dma_trans_complete_flag
__IO uint16_t | preempt_trigger_count
__IO uint32_t | adc1_overflow_flag
__IO uint16_t | adc1_ordinary_valuetab [3][3] = {0}
__IO uint16_t | adc1_preempt_valuetab [3][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint16_t | preempt_trigger_count = 0
__IO uint32_t | adc1_overflow_flag = 0

Detailed Description

Function Documentation

◆ ADC1_2_3_IRQHandler()

void ADC1_2_3_IRQHandler ( void )

this function handles adc1_2_3 handler.

Parameters
none
Return values
none

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< preempt channels conversion end flag

< preempt channels conversion end flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< preempt channels conversion end flag

< preempt channels conversion end flag

Definition at line 160 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c.

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< ordinary channel conversion overflow interrupt

< preempt channels conversion end interrupt

< adc ready to conversion flag

Definition at line 152 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 84 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 119 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1_channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 146 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 119 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by main().

◆ exint_config()

static void exint_config ( void )
static

exint configuration.

Parameters
none
Return values
none

< gpio pins number 11

< gpio pins number 15

< external interrupt line 11

< external interrupt line 15

Definition at line 77 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by main().

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

Definition at line 54 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 58 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 243 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 71 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 49 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 128 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 110 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 137 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 97 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c.

Variable Documentation

◆ adc1_ordinary_valuetab [1/2]

__IO uint16_t adc1_ordinary_valuetab[3][3] = {0}

Definition at line 38 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by dma_config(), and main().

◆ adc1_ordinary_valuetab [2/2]

__IO uint16_t adc1_ordinary_valuetab[3][3] = {0}

Definition at line 38 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by dma_config().

◆ adc1_overflow_flag [1/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc1_overflow_flag [2/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 42 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by main().

◆ adc1_overflow_flag [3/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc1_overflow_flag [4/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 42 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c.

◆ adc1_preempt_valuetab [1/4]

__IO uint16_t adc1_preempt_valuetab[3][3]
extern

Definition at line 38 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc1_preempt_valuetab [2/4]

__IO uint16_t adc1_preempt_valuetab[3][3] = {0}

Definition at line 39 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by main().

◆ adc1_preempt_valuetab [3/4]

__IO uint16_t adc1_preempt_valuetab[3][3]
extern

Definition at line 38 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

◆ adc1_preempt_valuetab [4/4]

__IO uint16_t adc1_preempt_valuetab[3][3] = {0}

Definition at line 39 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c.

◆ dma_trans_complete_flag [1/4]

__IO uint16_t dma_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/conversion_abort/src/main.c.

Referenced by DMA1_Channel1_IRQHandler().

◆ dma_trans_complete_flag [2/4]

__IO uint16_t dma_trans_complete_flag = 0

Definition at line 40 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by main().

◆ dma_trans_complete_flag [3/4]

__IO uint16_t dma_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/conversion_abort/src/main.c.

◆ dma_trans_complete_flag [4/4]

__IO uint16_t dma_trans_complete_flag = 0

Definition at line 40 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c.

◆ preempt_trigger_count [1/4]

__IO uint16_t preempt_trigger_count
extern

Definition at line 41 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ preempt_trigger_count [2/4]

__IO uint16_t preempt_trigger_count = 0

Definition at line 41 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by main().

◆ preempt_trigger_count [3/4]

__IO uint16_t preempt_trigger_count
extern

Definition at line 41 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by main().

◆ preempt_trigger_count [4/4]

__IO uint16_t preempt_trigger_count = 0

Definition at line 41 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by ADC1_2_3_IRQHandler().


AT32F435/437 Firmwary Library: ADC_internal_temperature_sensor

Functions | Variables
ADC_internal_temperature_sensor
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | adc1_overflow_flag
__IO uint16_t | adc1_ordinary_value = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint32_t | adc1_overflow_flag
__IO uint16_t | adc1_ordinary_value = 0
__IO uint32_t | adc1_overflow_flag = 0

Detailed Description

Function Documentation

◆ ADC1_2_3_IRQHandler()

void ADC1_2_3_IRQHandler ( void )

this function handles adc1_2_3 handler.

Parameters
none
Return values
none

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

Definition at line 143 of file project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c.

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< ordinary channel conversion overflow interrupt

< adc ready to conversion flag

Definition at line 86 of file project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 53 of file project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 157 of file project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c.

Variable Documentation

◆ adc1_ordinary_value [1/2]

__IO uint16_t adc1_ordinary_value = 0

Definition at line 42 of file project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c.

Referenced by dma_config(), and main().

◆ adc1_ordinary_value [2/2]

__IO uint16_t adc1_ordinary_value = 0

Definition at line 42 of file project/at_start_f437/examples/adc/internal_temperature_sensor/src/main.c.

Referenced by dma_config().

◆ adc1_overflow_flag [1/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc1_overflow_flag [2/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 43 of file project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c.

Referenced by main().

◆ adc1_overflow_flag [3/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc1_overflow_flag [4/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 43 of file project/at_start_f437/examples/adc/internal_temperature_sensor/src/main.c.


AT32F435/437 Firmwary Library: ADC_ordinary_preempt_oversampling

Functions | Variables
ADC_ordinary_preempt_oversampling
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_preempt_valuetab [5][3]
__IO uint16_t | dma_trans_complete_flag
__IO uint16_t | preempt_conversion_count
__IO uint32_t | adc1_overflow_flag
__IO uint16_t | adc1_ordinary_valuetab [5][3] = {0}
__IO uint16_t | adc1_preempt_valuetab [5][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint16_t | preempt_conversion_count = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint16_t | adc1_preempt_valuetab [5][3]
__IO uint16_t | dma_trans_complete_flag
__IO uint16_t | preempt_conversion_count
__IO uint32_t | adc1_overflow_flag
__IO uint16_t | adc1_ordinary_valuetab [5][3] = {0}
__IO uint16_t | adc1_preempt_valuetab [5][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint16_t | preempt_conversion_count = 0
__IO uint32_t | adc1_overflow_flag = 0

Detailed Description

Function Documentation

◆ ADC1_2_3_IRQHandler()

void ADC1_2_3_IRQHandler ( void )

this function handles adc1_2_3 handler.

Parameters
none
Return values
none

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< preempt channels conversion end flag

< preempt channels conversion end flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< preempt channels conversion end flag

< preempt channels conversion end flag

Definition at line 160 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c.

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< ordinary channel conversion overflow interrupt

< preempt channels conversion end interrupt

< adc ready to conversion flag

Definition at line 109 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 84 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 119 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1_channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 146 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 76 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c.

Referenced by main().

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

Definition at line 53 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 58 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 212 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 71 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 49 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 128 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 110 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 137 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 97 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c.

Variable Documentation

◆ adc1_ordinary_valuetab [1/2]

__IO uint16_t adc1_ordinary_valuetab[5][3] = {0}

Definition at line 38 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c.

Referenced by dma_config(), and main().

◆ adc1_ordinary_valuetab [2/2]

__IO uint16_t adc1_ordinary_valuetab[5][3] = {0}

Definition at line 38 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/main.c.

Referenced by dma_config().

◆ adc1_overflow_flag [1/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc1_overflow_flag [2/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 42 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c.

Referenced by main().

◆ adc1_overflow_flag [3/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc1_overflow_flag [4/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 42 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/main.c.

◆ adc1_preempt_valuetab [1/4]

__IO uint16_t adc1_preempt_valuetab[5][3]
extern

Definition at line 38 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc1_preempt_valuetab [2/4]

__IO uint16_t adc1_preempt_valuetab[5][3] = {0}

Definition at line 39 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c.

Referenced by main().

◆ adc1_preempt_valuetab [3/4]

__IO uint16_t adc1_preempt_valuetab[5][3]
extern

Definition at line 38 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

◆ adc1_preempt_valuetab [4/4]

__IO uint16_t adc1_preempt_valuetab[5][3] = {0}

Definition at line 39 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/main.c.

◆ dma_trans_complete_flag [1/4]

__IO uint16_t dma_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/conversion_abort/src/main.c.

Referenced by DMA1_Channel1_IRQHandler().

◆ dma_trans_complete_flag [2/4]

__IO uint16_t dma_trans_complete_flag = 0

Definition at line 40 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c.

Referenced by main().

◆ dma_trans_complete_flag [3/4]

__IO uint16_t dma_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/conversion_abort/src/main.c.

◆ dma_trans_complete_flag [4/4]

__IO uint16_t dma_trans_complete_flag = 0

Definition at line 40 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/main.c.

◆ preempt_conversion_count [1/4]

__IO uint16_t preempt_conversion_count
extern

Definition at line 41 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ preempt_conversion_count [2/4]

__IO uint16_t preempt_conversion_count = 0

Definition at line 41 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c.

◆ preempt_conversion_count [3/4]

__IO uint16_t preempt_conversion_count
extern

Definition at line 41 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c.

◆ preempt_conversion_count [4/4]

__IO uint16_t preempt_conversion_count = 0

Definition at line 41 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/main.c.


AT32F435/437 Firmwary Library: ADC_software_trigger_repeat

Functions | Variables
ADC_software_trigger_repeat
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | dma_trans_complete_flag
__IO uint32_t | adc1_overflow_flag
__IO uint16_t | adc1_ordinary_valuetab [10][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint16_t | dma_trans_complete_flag
__IO uint32_t | adc1_overflow_flag
__IO uint16_t | adc1_ordinary_valuetab [10][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint16_t | dma_trans_complete_flag
__IO uint32_t | adc1_overflow_flag
__IO uint16_t | adc1_ordinary_valuetab [10][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint16_t | dma_trans_complete_flag
__IO uint32_t | adc1_overflow_flag
__IO uint16_t | adc1_ordinary_valuetab [10][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0

Detailed Description

Function Documentation

◆ ADC1_2_3_IRQHandler()

void ADC1_2_3_IRQHandler ( void )

this function handles adc1_2_3 handler.

Parameters
none
Return values
none

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

Definition at line 158 of file project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c.

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< ordinary channel conversion overflow interrupt

< adc ready to conversion flag

< adc ready to conversion flag

Definition at line 102 of file project/at_start_f435/examples/adc/resolution_6bit/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 82 of file project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 117 of file project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1_channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 144 of file project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 69 of file project/at_start_f435/examples/adc/resolution_6bit/src/main.c.

Referenced by main().

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

Definition at line 51 of file project/at_start_f435/examples/adc/resolution_6bit/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 56 of file project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 179 of file project/at_start_f435/examples/adc/resolution_6bit/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 69 of file project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 47 of file project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 126 of file project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 108 of file project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 135 of file project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 95 of file project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c.

Variable Documentation

◆ adc1_ordinary_valuetab [1/4]

__IO uint16_t adc1_ordinary_valuetab[10][3] = {0}

Definition at line 38 of file project/at_start_f435/examples/adc/resolution_6bit/src/main.c.

Referenced by dma_config(), and main().

◆ adc1_ordinary_valuetab [2/4]

__IO uint16_t adc1_ordinary_valuetab[10][3] = {0}

Definition at line 38 of file project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c.

Referenced by dma_config().

◆ adc1_ordinary_valuetab [3/4]

__IO uint16_t adc1_ordinary_valuetab[10][3] = {0}

Definition at line 38 of file project/at_start_f437/examples/adc/resolution_6bit/src/main.c.

Referenced by dma_config().

◆ adc1_ordinary_valuetab [4/4]

__IO uint16_t adc1_ordinary_valuetab[10][3] = {0}

Definition at line 38 of file project/at_start_f437/examples/adc/software_trigger_repeat/src/main.c.

Referenced by dma_config().

◆ adc1_overflow_flag [1/8]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc1_overflow_flag [2/8]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 40 of file project/at_start_f435/examples/adc/resolution_6bit/src/main.c.

Referenced by main().

◆ adc1_overflow_flag [3/8]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc1_overflow_flag [4/8]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 40 of file project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c.

◆ adc1_overflow_flag [5/8]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc1_overflow_flag [6/8]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 40 of file project/at_start_f437/examples/adc/resolution_6bit/src/main.c.

◆ adc1_overflow_flag [7/8]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc1_overflow_flag [8/8]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 40 of file project/at_start_f437/examples/adc/software_trigger_repeat/src/main.c.

◆ dma_trans_complete_flag [1/8]

__IO uint16_t dma_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/conversion_abort/src/main.c.

Referenced by DMA1_Channel1_IRQHandler().

◆ dma_trans_complete_flag [2/8]

__IO uint16_t dma_trans_complete_flag = 0

Definition at line 39 of file project/at_start_f435/examples/adc/resolution_6bit/src/main.c.

Referenced by main().

◆ dma_trans_complete_flag [3/8]

__IO uint16_t dma_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/conversion_abort/src/main.c.

◆ dma_trans_complete_flag [4/8]

__IO uint16_t dma_trans_complete_flag = 0

Definition at line 39 of file project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c.

◆ dma_trans_complete_flag [5/8]

__IO uint16_t dma_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/conversion_abort/src/main.c.

◆ dma_trans_complete_flag [6/8]

__IO uint16_t dma_trans_complete_flag = 0

Definition at line 39 of file project/at_start_f437/examples/adc/resolution_6bit/src/main.c.

◆ dma_trans_complete_flag [7/8]

__IO uint16_t dma_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/conversion_abort/src/main.c.

◆ dma_trans_complete_flag [8/8]

__IO uint16_t dma_trans_complete_flag = 0

Definition at line 39 of file project/at_start_f437/examples/adc/software_trigger_repeat/src/main.c.


AT32F435/437 Firmwary Library: ADC_tmr_trigger_automatic_preempted

Functions | Variables
ADC_tmr_trigger_automatic_preempted
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | tmr1_config (void)
tmr1 configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [5][3]
__IO uint16_t | adc1_preempt_valuetab [5][3]
__IO uint16_t | dma_trans_complete_flag
__IO uint16_t | preempt_conversion_count
__IO uint32_t | adc1_overflow_flag
__IO uint16_t | adc1_ordinary_valuetab [5][3] = {0}
__IO uint16_t | adc1_preempt_valuetab [5][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint16_t | preempt_conversion_count = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint16_t | adc1_ordinary_valuetab [5][3]
__IO uint16_t | adc1_preempt_valuetab [5][3]
__IO uint16_t | dma_trans_complete_flag
__IO uint16_t | preempt_conversion_count
__IO uint32_t | adc1_overflow_flag
__IO uint16_t | adc1_ordinary_valuetab [5][3] = {0}
__IO uint16_t | adc1_preempt_valuetab [5][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint16_t | preempt_conversion_count = 0
__IO uint32_t | adc1_overflow_flag = 0

Detailed Description

Function Documentation

◆ ADC1_2_3_IRQHandler()

void ADC1_2_3_IRQHandler ( void )

this function handles adc1_2_3 handler.

Parameters
none
Return values
none

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< preempt channels conversion end flag

< preempt channels conversion end flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< preempt channels conversion end flag

< preempt channels conversion end flag

Definition at line 161 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c.

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< ordinary channel conversion overflow interrupt

< preempt channels conversion end interrupt

< adc ready to conversion flag

Definition at line 152 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 85 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1_channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 147 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 77 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by main().

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

Definition at line 54 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 59 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 240 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 72 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 138 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c.

◆ tmr1_config()

static void tmr1_config ( void )
static

tmr1 configuration.

Parameters
none
Return values
none

< gpio pins number 8

Definition at line 110 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by main().

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 98 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c.

Variable Documentation

◆ adc1_ordinary_valuetab [1/4]

__IO uint16_t adc1_ordinary_valuetab[5][3]
extern

Definition at line 38 of file project/at_start_f435/examples/adc/conversion_abort/src/main.c.

◆ adc1_ordinary_valuetab [2/4]

__IO uint16_t adc1_ordinary_valuetab[5][3] = {0}

Definition at line 38 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by dma_config(), and main().

◆ adc1_ordinary_valuetab [3/4]

__IO uint16_t adc1_ordinary_valuetab[5][3]
extern

Definition at line 38 of file project/at_start_f435/examples/adc/conversion_abort/src/main.c.

Referenced by dma_config(), edma_config(), and main().

◆ adc1_ordinary_valuetab [4/4]

__IO uint16_t adc1_ordinary_valuetab[5][3] = {0}

Definition at line 38 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by dma_config().

◆ adc1_overflow_flag [1/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc1_overflow_flag [2/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 42 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by main().

◆ adc1_overflow_flag [3/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc1_overflow_flag [4/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 42 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

◆ adc1_preempt_valuetab [1/4]

__IO uint16_t adc1_preempt_valuetab[5][3]
extern

Definition at line 38 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc1_preempt_valuetab [2/4]

__IO uint16_t adc1_preempt_valuetab[5][3] = {0}

Definition at line 39 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by main().

◆ adc1_preempt_valuetab [3/4]

__IO uint16_t adc1_preempt_valuetab[5][3]
extern

Definition at line 38 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.

Referenced by main().

◆ adc1_preempt_valuetab [4/4]

__IO uint16_t adc1_preempt_valuetab[5][3] = {0}

Definition at line 39 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ dma_trans_complete_flag [1/4]

__IO uint16_t dma_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/conversion_abort/src/main.c.

Referenced by DMA1_Channel1_IRQHandler().

◆ dma_trans_complete_flag [2/4]

__IO uint16_t dma_trans_complete_flag = 0

Definition at line 40 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by main().

◆ dma_trans_complete_flag [3/4]

__IO uint16_t dma_trans_complete_flag
extern

Definition at line 39 of file project/at_start_f435/examples/adc/conversion_abort/src/main.c.

Referenced by main().

◆ dma_trans_complete_flag [4/4]

__IO uint16_t dma_trans_complete_flag = 0

Definition at line 40 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by DMA1_Channel1_IRQHandler().

◆ preempt_conversion_count [1/4]

__IO uint16_t preempt_conversion_count
extern

Definition at line 41 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ preempt_conversion_count [2/4]

__IO uint16_t preempt_conversion_count = 0

Definition at line 41 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by main().

◆ preempt_conversion_count [3/4]

__IO uint16_t preempt_conversion_count
extern

Definition at line 41 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c.

Referenced by main().

◆ preempt_conversion_count [4/4]

__IO uint16_t preempt_conversion_count = 0

Definition at line 41 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by ADC1_2_3_IRQHandler().


AT32F435/437 Firmwary Library: ADC_use_polling_get_conversion_data

Functions | Variables
ADC_use_polling_get_conversion_data
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | adc1_overflow_flag
__IO uint16_t | adc1_ordinary_valuetab [3] = {0}
__IO uint16_t * | p_adc1_ordinary = adc1_ordinary_valuetab
__IO uint32_t | adc1_overflow_flag = 0
__IO uint32_t | adc1_overflow_flag
__IO uint16_t | adc1_ordinary_valuetab [3] = {0}
__IO uint16_t * | p_adc1_ordinary = adc1_ordinary_valuetab
__IO uint32_t | adc1_overflow_flag = 0

Detailed Description

Function Documentation

◆ ADC1_2_3_IRQHandler()

void ADC1_2_3_IRQHandler ( void )

this function handles adc1_2_3 handler.

Parameters
none
Return values
none

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

Definition at line 143 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c.

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< ordinary channel conversion overflow interrupt

< adc ready to conversion flag

Definition at line 68 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

Definition at line 50 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< ordinary channels conversion end flag

< ordinary channels conversion end flag

Definition at line 144 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c.

Variable Documentation

◆ adc1_ordinary_valuetab [1/2]

__IO uint16_t adc1_ordinary_valuetab[3] = {0}

Definition at line 38 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c.

Referenced by main().

◆ adc1_ordinary_valuetab [2/2]

__IO uint16_t adc1_ordinary_valuetab[3] = {0}

Definition at line 38 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/src/main.c.

◆ adc1_overflow_flag [1/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc1_overflow_flag [2/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 40 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c.

Referenced by main().

◆ adc1_overflow_flag [3/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc1_overflow_flag [4/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 40 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/src/main.c.

◆ p_adc1_ordinary [1/2]

__IO uint16_t* p_adc1_ordinary = adc1_ordinary_valuetab

Definition at line 39 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c.

Referenced by main().

◆ p_adc1_ordinary [2/2]

__IO uint16_t* p_adc1_ordinary = adc1_ordinary_valuetab

Definition at line 39 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/src/main.c.


AT32F435/437 Firmwary Library: ADC_vbat_monitor

Functions | Variables
ADC_vbat_monitor
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | adc1_overflow_flag
__IO uint16_t | adc1_ordinary_value = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint32_t | adc1_overflow_flag
__IO uint16_t | adc1_ordinary_value = 0
__IO uint32_t | adc1_overflow_flag = 0

Detailed Description

Function Documentation

◆ ADC1_2_3_IRQHandler()

void ADC1_2_3_IRQHandler ( void )

this function handles adc1_2_3 handler.

Parameters
none
Return values
none

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

Definition at line 143 of file project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c.

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< ordinary channel conversion overflow interrupt

< adc ready to conversion flag

Definition at line 82 of file project/at_start_f435/examples/adc/vbat_monitor/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 49 of file project/at_start_f435/examples/adc/vbat_monitor/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 153 of file project/at_start_f435/examples/adc/vbat_monitor/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c.

Variable Documentation

◆ adc1_ordinary_value [1/2]

__IO uint16_t adc1_ordinary_value = 0

Definition at line 38 of file project/at_start_f435/examples/adc/vbat_monitor/src/main.c.

Referenced by dma_config(), and main().

◆ adc1_ordinary_value [2/2]

__IO uint16_t adc1_ordinary_value = 0

Definition at line 38 of file project/at_start_f437/examples/adc/vbat_monitor/src/main.c.

Referenced by dma_config().

◆ adc1_overflow_flag [1/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc1_overflow_flag [2/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 39 of file project/at_start_f435/examples/adc/vbat_monitor/src/main.c.

Referenced by main().

◆ adc1_overflow_flag [3/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

◆ adc1_overflow_flag [4/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 39 of file project/at_start_f437/examples/adc/vbat_monitor/src/main.c.


AT32F435/437 Firmwary Library: ADC_voltage_monitoring

Functions | Variables
ADC_voltage_monitoring
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | vmor_flag_index
__IO uint32_t | adc1_overflow_flag
__IO uint16_t | adc1_ordinary_valuetab [3] = {0}
__IO uint32_t | vmor_flag_index = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint32_t | vmor_flag_index
__IO uint32_t | adc1_overflow_flag
__IO uint16_t | adc1_ordinary_valuetab [3] = {0}
__IO uint32_t | vmor_flag_index = 0
__IO uint32_t | adc1_overflow_flag = 0

Detailed Description

Function Documentation

◆ ADC1_2_3_IRQHandler()

void ADC1_2_3_IRQHandler ( void )

this function handles adc1_2_3 handler.

Parameters
none
Return values
none

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< voltage monitoring out of range flag

< voltage monitoring out of range flag

< ordinary channel conversion overflow flag

< ordinary channel conversion overflow flag

< voltage monitoring out of range flag

< voltage monitoring out of range flag

Definition at line 144 of file project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c.

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< ordinary channel conversion overflow interrupt

< voltage monitoring out of range interrupt

< adc ready to conversion flag

Definition at line 102 of file project/at_start_f435/examples/adc/voltage_monitoring/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 82 of file project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 117 of file project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 69 of file project/at_start_f435/examples/adc/voltage_monitoring/src/main.c.

Referenced by main().

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

Definition at line 51 of file project/at_start_f435/examples/adc/voltage_monitoring/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 56 of file project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 183 of file project/at_start_f435/examples/adc/voltage_monitoring/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 69 of file project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 47 of file project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 126 of file project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 108 of file project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 135 of file project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 95 of file project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c.

Variable Documentation

◆ adc1_ordinary_valuetab [1/2]

__IO uint16_t adc1_ordinary_valuetab[3] = {0}

Definition at line 38 of file project/at_start_f435/examples/adc/voltage_monitoring/src/main.c.

Referenced by dma_config(), and main().

◆ adc1_ordinary_valuetab [2/2]

__IO uint16_t adc1_ordinary_valuetab[3] = {0}

Definition at line 38 of file project/at_start_f437/examples/adc/voltage_monitoring/src/main.c.

Referenced by dma_config().

◆ adc1_overflow_flag [1/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ adc1_overflow_flag [2/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 40 of file project/at_start_f435/examples/adc/voltage_monitoring/src/main.c.

Referenced by main().

◆ adc1_overflow_flag [3/4]

__IO uint32_t adc1_overflow_flag
extern

Definition at line 40 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.

Referenced by main().

◆ adc1_overflow_flag [4/4]

__IO uint32_t adc1_overflow_flag = 0

Definition at line 40 of file project/at_start_f437/examples/adc/voltage_monitoring/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ vmor_flag_index [1/4]

__IO uint32_t vmor_flag_index
extern

Definition at line 39 of file project/at_start_f435/examples/adc/voltage_monitoring/src/main.c.

Referenced by ADC1_2_3_IRQHandler().

◆ vmor_flag_index [2/4]

__IO uint32_t vmor_flag_index = 0

Definition at line 39 of file project/at_start_f435/examples/adc/voltage_monitoring/src/main.c.

Referenced by main().

◆ vmor_flag_index [3/4]

__IO uint32_t vmor_flag_index
extern

Definition at line 39 of file project/at_start_f435/examples/adc/voltage_monitoring/src/main.c.

Referenced by main().

◆ vmor_flag_index [4/4]

__IO uint32_t vmor_flag_index = 0

Definition at line 39 of file project/at_start_f437/examples/adc/voltage_monitoring/src/main.c.

Referenced by ADC1_2_3_IRQHandler().


AT32F435/437 Firmwary Library: CAN_communication_mode

Functions
CAN_communication_mode
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | can_gpio_config (void)
can gpio config More...
static void | can_configuration (void)
can configiguration. More...
static void | can_transmit_data (void)
can transmit data More...
void | CAN1_RX0_IRQHandler (void)
can1 interrupt function rx0 More...
void | CAN1_SE_IRQHandler (void)
can1 interrupt function se More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c.

◆ CAN1_RX0_IRQHandler()

void CAN1_RX0_IRQHandler ( void )

can1 interrupt function rx0

Parameters
none
Return values
none

< receive fifo 0 message num flag

< receive fifo 0 message num flag

Definition at line 147 of file project/at_start_f435/examples/can/communication_mode/src/main.c.

◆ CAN1_SE_IRQHandler()

void CAN1_SE_IRQHandler ( void )

can1 interrupt function se

Parameters
none
Return values
none

< error type record flag

< error type record flag

< error type record flag

< error type record flag

Definition at line 165 of file project/at_start_f435/examples/can/communication_mode/src/main.c.

◆ can_configuration()

static void can_configuration ( void )
static

can configiguration.

Parameters
none
Return values
none

< receive fifo 0 message interrupt

< error type record interrupt

< error occur interrupt

Definition at line 68 of file project/at_start_f435/examples/can/communication_mode/src/main.c.

Referenced by main().

◆ can_gpio_config()

static void can_gpio_config ( void )
static

can gpio config

Parameters
none
Return values
none

< gpio pins number 9

< gpio pins number 8

Definition at line 43 of file project/at_start_f435/examples/can/communication_mode/src/main.c.

Referenced by main().

◆ can_transmit_data()

static void can_transmit_data ( void )
static

can transmit data

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f435/examples/can/communication_mode/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 186 of file project/at_start_f435/examples/can/communication_mode/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: CAN_filter

Macros | Functions | Variables
CAN_filter
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | FILTER_EXT_ID1 ((uint32_t)0x18F5F100)
#define | FILTER_EXT_ID2 ((uint32_t)0x18F5F200)
#define | FILTER_EXT_ID3 ((uint32_t)0x18F5F300)
#define | FILTER_STD_ID1 ((uint16_t)0x04F6)
#define | FILTER_STD_ID2 ((uint16_t)0x04F7)
#define | FILTER_STD_ID3 ((uint16_t)0x04F8)
#define | FILTER_EXT_ID1 ((uint32_t)0x18F5F100)
#define | FILTER_EXT_ID2 ((uint32_t)0x18F5F200)
#define | FILTER_EXT_ID3 ((uint32_t)0x18F5F300)
#define | FILTER_STD_ID1 ((uint16_t)0x04F6)
#define | FILTER_STD_ID2 ((uint16_t)0x04F7)
#define | FILTER_STD_ID3 ((uint16_t)0x04F8)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | can_gpio_config (void)
can gpio config More...
static void | can_configuration (void)
can configiguration. More...
static void | can_transmit_data (void)
can transmit data More...
void | CAN1_RX0_IRQHandler (void)
can1 interrupt function rx0 More...
void | CAN1_SE_IRQHandler (void)
can1 interrupt function se More...
int | main (void)
main function. More...

Variables

uint8_t | test_result = 0
uint8_t | test_result = 0

Detailed Description

Macro Definition Documentation

◆ FILTER_EXT_ID1 [1/2]

#define FILTER_EXT_ID1 ((uint32_t)0x18F5F100)

Definition at line 39 of file project/at_start_f435/examples/can/filter/src/main.c.

◆ FILTER_EXT_ID1 [2/2]

#define FILTER_EXT_ID1 ((uint32_t)0x18F5F100)

Definition at line 39 of file project/at_start_f437/examples/can/filter/src/main.c.

◆ FILTER_EXT_ID2 [1/2]

#define FILTER_EXT_ID2 ((uint32_t)0x18F5F200)

Definition at line 40 of file project/at_start_f435/examples/can/filter/src/main.c.

◆ FILTER_EXT_ID2 [2/2]

#define FILTER_EXT_ID2 ((uint32_t)0x18F5F200)

Definition at line 40 of file project/at_start_f437/examples/can/filter/src/main.c.

◆ FILTER_EXT_ID3 [1/2]

#define FILTER_EXT_ID3 ((uint32_t)0x18F5F300)

Definition at line 41 of file project/at_start_f435/examples/can/filter/src/main.c.

◆ FILTER_EXT_ID3 [2/2]

#define FILTER_EXT_ID3 ((uint32_t)0x18F5F300)

Definition at line 41 of file project/at_start_f437/examples/can/filter/src/main.c.

◆ FILTER_STD_ID1 [1/2]

#define FILTER_STD_ID1 ((uint16_t)0x04F6)

Definition at line 44 of file project/at_start_f435/examples/can/filter/src/main.c.

◆ FILTER_STD_ID1 [2/2]

#define FILTER_STD_ID1 ((uint16_t)0x04F6)

Definition at line 44 of file project/at_start_f437/examples/can/filter/src/main.c.

◆ FILTER_STD_ID2 [1/2]

#define FILTER_STD_ID2 ((uint16_t)0x04F7)

Definition at line 45 of file project/at_start_f435/examples/can/filter/src/main.c.

◆ FILTER_STD_ID2 [2/2]

#define FILTER_STD_ID2 ((uint16_t)0x04F7)

Definition at line 45 of file project/at_start_f437/examples/can/filter/src/main.c.

◆ FILTER_STD_ID3 [1/2]

#define FILTER_STD_ID3 ((uint16_t)0x04F8)

Definition at line 46 of file project/at_start_f435/examples/can/filter/src/main.c.

◆ FILTER_STD_ID3 [2/2]

#define FILTER_STD_ID3 ((uint16_t)0x04F8)

Definition at line 46 of file project/at_start_f437/examples/can/filter/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/can/filter/src/at32f435_437_int.c.

◆ CAN1_RX0_IRQHandler()

void CAN1_RX0_IRQHandler ( void )

can1 interrupt function rx0

Parameters
none
Return values
none

< receive fifo 0 message num flag

< receive fifo 0 message num flag

Definition at line 257 of file project/at_start_f435/examples/can/filter/src/main.c.

◆ CAN1_SE_IRQHandler()

void CAN1_SE_IRQHandler ( void )

can1 interrupt function se

Parameters
none
Return values
none

< error type record flag

< error type record flag

< error type record flag

< error type record flag

Definition at line 285 of file project/at_start_f435/examples/can/filter/src/main.c.

◆ can_configuration()

static void can_configuration ( void )
static

can configiguration.

Parameters
none
Return values
none

< receive fifo 0 message interrupt

< error type record interrupt

< error occur interrupt

Definition at line 79 of file project/at_start_f435/examples/can/filter/src/main.c.

Referenced by main().

◆ can_gpio_config()

static void can_gpio_config ( void )
static

can gpio config

Parameters
none
Return values
none

< gpio pins number 9

< gpio pins number 8

Definition at line 54 of file project/at_start_f435/examples/can/filter/src/main.c.

Referenced by main().

◆ can_transmit_data()

static void can_transmit_data ( void )
static

can transmit data

Parameters
none
Return values
none

Definition at line 144 of file project/at_start_f435/examples/can/filter/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/can/filter/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/can/filter/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 306 of file project/at_start_f435/examples/can/filter/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/can/filter/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/can/filter/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/can/filter/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/can/filter/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/can/filter/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/can/filter/src/at32f435_437_int.c.

Variable Documentation

◆ test_result [1/2]

uint8_t test_result = 0

Definition at line 48 of file project/at_start_f435/examples/can/filter/src/main.c.

Referenced by CAN1_RX0_IRQHandler(), and main().

◆ test_result [2/2]

uint8_t test_result = 0

Definition at line 48 of file project/at_start_f437/examples/can/filter/src/main.c.


AT32F435/437 Firmwary Library: CAN_loopback_mode

Functions
CAN_loopback_mode
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | can_gpio_config (void)
can gpio config More...
static void | can_configuration (void)
can configiguration. More...
static void | can_transmit_data (void)
can transmit data More...
void | CAN1_RX0_IRQHandler (void)
can1 interrupt function rx0 More...
void | CAN1_SE_IRQHandler (void)
can1 interrupt function se More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c.

◆ CAN1_RX0_IRQHandler()

void CAN1_RX0_IRQHandler ( void )

can1 interrupt function rx0

Parameters
none
Return values
none

< receive fifo 0 message num flag

< receive fifo 0 message num flag

Definition at line 147 of file project/at_start_f435/examples/can/loopback_mode/src/main.c.

◆ CAN1_SE_IRQHandler()

void CAN1_SE_IRQHandler ( void )

can1 interrupt function se

Parameters
none
Return values
none

< error type record flag

< error type record flag

< error type record flag

< error type record flag

Definition at line 163 of file project/at_start_f435/examples/can/loopback_mode/src/main.c.

◆ can_configuration()

static void can_configuration ( void )
static

can configiguration.

Parameters
none
Return values
none

< receive fifo 0 message interrupt

< error type record interrupt

< error occur interrupt

Definition at line 68 of file project/at_start_f435/examples/can/loopback_mode/src/main.c.

Referenced by main().

◆ can_gpio_config()

static void can_gpio_config ( void )
static

can gpio config

Parameters
none
Return values
none

< gpio pins number 9

< gpio pins number 8

Definition at line 43 of file project/at_start_f435/examples/can/loopback_mode/src/main.c.

Referenced by main().

◆ can_transmit_data()

static void can_transmit_data ( void )
static

can transmit data

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f435/examples/can/loopback_mode/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 185 of file project/at_start_f435/examples/can/loopback_mode/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: CORTEX_m4_bit_band

Macros | Functions | Variables
CORTEX_m4_bit_band
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | RAM_BASE 0x20000000
#define | RAM_BITBAND_BASE 0x22000000
#define | VARIABLES_RESET_BIT(variables_addr, bit_number) (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 0)
#define | VARIABLES_SET_BIT(variables_addr, bit_number) (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 1)
#define | VARIABLES_GET_BIT(variables_addr, bit_number) (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)))
#define | PERIPHERAL_BASE 0x40000000
#define | PERIPHERAL_BITBAND_BASE 0x42000000
#define | PERIPHERAL_RESET_BIT(peripheral_addr, bit_number) (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 0)
#define | PERIPHERAL_SET_BIT(peripheral_addr, bit_number) (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 1)
#define | RAM_BASE 0x20000000
#define | RAM_BITBAND_BASE 0x22000000
#define | VARIABLES_RESET_BIT(variables_addr, bit_number) (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 0)
#define | VARIABLES_SET_BIT(variables_addr, bit_number) (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 1)
#define | VARIABLES_GET_BIT(variables_addr, bit_number) (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)))
#define | PERIPHERAL_BASE 0x40000000
#define | PERIPHERAL_BITBAND_BASE 0x42000000
#define | PERIPHERAL_RESET_BIT(peripheral_addr, bit_number) (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 0)
#define | PERIPHERAL_SET_BIT(peripheral_addr, bit_number) (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 1)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | result_error (void)
led4 flick for error. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | variables
__IO uint32_t | variables_addr = 0
__IO uint32_t | variables_bit_val = 0
__IO uint32_t | variables
__IO uint32_t | variables_addr = 0
__IO uint32_t | variables_bit_val = 0

Detailed Description

Macro Definition Documentation

◆ PERIPHERAL_BASE [1/2]

#define PERIPHERAL_BASE 0x40000000

Definition at line 53 of file project/at_start_f435/examples/cortex_m4/bit_band/src/main.c.

◆ PERIPHERAL_BASE [2/2]

#define PERIPHERAL_BASE 0x40000000

Definition at line 53 of file project/at_start_f437/examples/cortex_m4/bit_band/src/main.c.

◆ PERIPHERAL_BITBAND_BASE [1/2]

#define PERIPHERAL_BITBAND_BASE 0x42000000

Definition at line 54 of file project/at_start_f435/examples/cortex_m4/bit_band/src/main.c.

◆ PERIPHERAL_BITBAND_BASE [2/2]

#define PERIPHERAL_BITBAND_BASE 0x42000000

Definition at line 54 of file project/at_start_f437/examples/cortex_m4/bit_band/src/main.c.

◆ PERIPHERAL_RESET_BIT [1/2]

#define PERIPHERAL_RESET_BIT | ( | peripheral_addr,
 |  | bit_number
 | ) | (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 0)

Definition at line 56 of file project/at_start_f435/examples/cortex_m4/bit_band/src/main.c.

◆ PERIPHERAL_RESET_BIT [2/2]

#define PERIPHERAL_RESET_BIT | ( | peripheral_addr,
 |  | bit_number
 | ) | (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 0)

Definition at line 56 of file project/at_start_f437/examples/cortex_m4/bit_band/src/main.c.

◆ PERIPHERAL_SET_BIT [1/2]

#define PERIPHERAL_SET_BIT | ( | peripheral_addr,
 |  | bit_number
 | ) | (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 1)

Definition at line 59 of file project/at_start_f435/examples/cortex_m4/bit_band/src/main.c.

◆ PERIPHERAL_SET_BIT [2/2]

#define PERIPHERAL_SET_BIT | ( | peripheral_addr,
 |  | bit_number
 | ) | (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 1)

Definition at line 59 of file project/at_start_f437/examples/cortex_m4/bit_band/src/main.c.

◆ RAM_BASE [1/2]

#define RAM_BASE 0x20000000

Definition at line 40 of file project/at_start_f435/examples/cortex_m4/bit_band/src/main.c.

◆ RAM_BASE [2/2]

#define RAM_BASE 0x20000000

Definition at line 40 of file project/at_start_f437/examples/cortex_m4/bit_band/src/main.c.

◆ RAM_BITBAND_BASE [1/2]

#define RAM_BITBAND_BASE 0x22000000

Definition at line 41 of file project/at_start_f435/examples/cortex_m4/bit_band/src/main.c.

◆ RAM_BITBAND_BASE [2/2]

#define RAM_BITBAND_BASE 0x22000000

Definition at line 41 of file project/at_start_f437/examples/cortex_m4/bit_band/src/main.c.

◆ VARIABLES_GET_BIT [1/2]

#define VARIABLES_GET_BIT | ( | variables_addr,
 |  | bit_number
 | ) | (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)))

Definition at line 49 of file project/at_start_f435/examples/cortex_m4/bit_band/src/main.c.

◆ VARIABLES_GET_BIT [2/2]

#define VARIABLES_GET_BIT | ( | variables_addr,
 |  | bit_number
 | ) | (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)))

Definition at line 49 of file project/at_start_f437/examples/cortex_m4/bit_band/src/main.c.

◆ VARIABLES_RESET_BIT [1/2]

#define VARIABLES_RESET_BIT | ( | variables_addr,
 |  | bit_number
 | ) | (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 0)

Definition at line 43 of file project/at_start_f435/examples/cortex_m4/bit_band/src/main.c.

◆ VARIABLES_RESET_BIT [2/2]

#define VARIABLES_RESET_BIT | ( | variables_addr,
 |  | bit_number
 | ) | (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 0)

Definition at line 43 of file project/at_start_f437/examples/cortex_m4/bit_band/src/main.c.

◆ VARIABLES_SET_BIT [1/2]

#define VARIABLES_SET_BIT | ( | variables_addr,
 |  | bit_number
 | ) | (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 1)

Definition at line 46 of file project/at_start_f435/examples/cortex_m4/bit_band/src/main.c.

◆ VARIABLES_SET_BIT [2/2]

#define VARIABLES_SET_BIT | ( | variables_addr,
 |  | bit_number
 | ) | (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 1)

Definition at line 46 of file project/at_start_f437/examples/cortex_m4/bit_band/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 83 of file project/at_start_f435/examples/cortex_m4/bit_band/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c.

◆ result_error()

void result_error ( void )

led4 flick for error.

Parameters
none
Return values
none

Definition at line 69 of file project/at_start_f435/examples/cortex_m4/bit_band/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c.

Variable Documentation

◆ variables [1/2]

__IO uint32_t variables

Definition at line 62 of file project/at_start_f435/examples/cortex_m4/bit_band/src/main.c.

Referenced by main().

◆ variables [2/2]

__IO uint32_t variables

Definition at line 62 of file project/at_start_f437/examples/cortex_m4/bit_band/src/main.c.

◆ variables_addr [1/2]

__IO uint32_t variables_addr = 0

Definition at line 62 of file project/at_start_f435/examples/cortex_m4/bit_band/src/main.c.

Referenced by main().

◆ variables_addr [2/2]

__IO uint32_t variables_addr = 0

Definition at line 62 of file project/at_start_f437/examples/cortex_m4/bit_band/src/main.c.

◆ variables_bit_val [1/2]

__IO uint32_t variables_bit_val = 0

Definition at line 62 of file project/at_start_f435/examples/cortex_m4/bit_band/src/main.c.

◆ variables_bit_val [2/2]

__IO uint32_t variables_bit_val = 0

Definition at line 62 of file project/at_start_f437/examples/cortex_m4/bit_band/src/main.c.


AT32F435/437 Firmwary Library: System_clock_configuration

Functions
System_clock_configuration
AT32F435_periph_examples | AT32F435_periph_template | AT32F437_periph_examples | AT32F437_periph_template

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

< phase locking loop stable flag

< phase locking loop stable flag

< phase locking loop stable flag

Definition at line 57 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: CORTEX_m4_cmsis_dsp

Macros | Functions | Variables
CORTEX_m4_cmsis_dsp
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | USE_STATIC_INIT
#define | TEST_LENGTH_SAMPLES (20*4)
#define | NUMSTUDENTS 20
#define | NUMSUBJECTS 4
#define | USE_STATIC_INIT
#define | TEST_LENGTH_SAMPLES (20*4)
#define | NUMSTUDENTS 20
#define | NUMSUBJECTS 4

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int32_t | main ()
main function. More...

Variables

const float32_t | testMarks_f32 [(20 *4)]
const float32_t | testUnity_f32 [4]
static float32_t | testOutput [(20 *4)]
uint32_t | numStudents = 20
uint32_t | numSubjects = 4
float32_t | max_marks
float32_t | min_marks
float32_t | mean
float32_t | std
float32_t | var
uint32_t | student_num
const float32_t | testMarks_f32 [(20 *4)]
const float32_t | testUnity_f32 [4]
static float32_t | testOutput [(20 *4)]
uint32_t | numStudents = 20
uint32_t | numSubjects = 4
float32_t | max_marks
float32_t | min_marks
float32_t | mean
float32_t | std
float32_t | var
uint32_t | student_num

Detailed Description

Macro Definition Documentation

◆ NUMSTUDENTS [1/2]

#define NUMSTUDENTS 20

Definition at line 83 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ NUMSTUDENTS [2/2]

#define NUMSTUDENTS 20

Definition at line 83 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ NUMSUBJECTS [1/2]

#define NUMSUBJECTS 4

Definition at line 84 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ NUMSUBJECTS [2/2]

#define NUMSUBJECTS 4

Definition at line 84 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ TEST_LENGTH_SAMPLES [1/2]

#define TEST_LENGTH_SAMPLES (20*4)

Definition at line 43 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ TEST_LENGTH_SAMPLES [2/2]

#define TEST_LENGTH_SAMPLES (20*4)

Definition at line 43 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ USE_STATIC_INIT [1/2]

#define USE_STATIC_INIT

Definition at line 39 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ USE_STATIC_INIT [2/2]

#define USE_STATIC_INIT

Definition at line 39 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c.

◆ main()

int32_t main ( void )

main function.

Parameters
none
Return values
none

Definition at line 98 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c.

Variable Documentation

◆ max_marks [1/2]

float32_t max_marks

Definition at line 90 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ max_marks [2/2]

float32_t max_marks

Definition at line 90 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ mean [1/2]

float32_t mean

Definition at line 90 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ mean [2/2]

float32_t mean

Definition at line 90 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ min_marks [1/2]

float32_t min_marks

Definition at line 90 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ min_marks [2/2]

float32_t min_marks

Definition at line 90 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ numStudents [1/2]

uint32_t numStudents = 20

Definition at line 88 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ numStudents [2/2]

uint32_t numStudents = 20

Definition at line 88 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ numSubjects [1/2]

uint32_t numSubjects = 4

Definition at line 89 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ numSubjects [2/2]

uint32_t numSubjects = 4

Definition at line 89 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ std [1/2]

float32_t std

Definition at line 90 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ std [2/2]

float32_t std

Definition at line 90 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ student_num [1/2]

uint32_t student_num

Definition at line 91 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ student_num [2/2]

uint32_t student_num

Definition at line 91 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ testMarks_f32 [1/2]

const float32_t testMarks_f32[(20 *4)]
Initial value:
=
{
42.000000, 37.000000, 81.000000, 28.000000,
83.000000, 72.000000, 36.000000, 38.000000,
32.000000, 51.000000, 63.000000, 64.000000,
97.000000, 82.000000, 95.000000, 90.000000,
66.000000, 51.000000, 54.000000, 42.000000,
67.000000, 56.000000, 45.000000, 57.000000,
67.000000, 69.000000, 35.000000, 52.000000,
29.000000, 81.000000, 58.000000, 47.000000,
38.000000, 76.000000, 100.000000, 29.000000,
33.000000, 47.000000, 29.000000, 50.000000,
34.000000, 41.000000, 61.000000, 46.000000,
52.000000, 50.000000, 48.000000, 36.000000,
47.000000, 55.000000, 44.000000, 40.000000,
100.000000, 94.000000, 84.000000, 37.000000,
32.000000, 71.000000, 47.000000, 77.000000,
31.000000, 50.000000, 49.000000, 35.000000,
63.000000, 67.000000, 40.000000, 31.000000,
29.000000, 68.000000, 61.000000, 38.000000,
31.000000, 28.000000, 28.000000, 76.000000,
55.000000, 33.000000, 29.000000, 39.000000
}

Definition at line 46 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ testMarks_f32 [2/2]

const float32_t testMarks_f32[(20 *4)]
Initial value:
=
{
42.000000, 37.000000, 81.000000, 28.000000,
83.000000, 72.000000, 36.000000, 38.000000,
32.000000, 51.000000, 63.000000, 64.000000,
97.000000, 82.000000, 95.000000, 90.000000,
66.000000, 51.000000, 54.000000, 42.000000,
67.000000, 56.000000, 45.000000, 57.000000,
67.000000, 69.000000, 35.000000, 52.000000,
29.000000, 81.000000, 58.000000, 47.000000,
38.000000, 76.000000, 100.000000, 29.000000,
33.000000, 47.000000, 29.000000, 50.000000,
34.000000, 41.000000, 61.000000, 46.000000,
52.000000, 50.000000, 48.000000, 36.000000,
47.000000, 55.000000, 44.000000, 40.000000,
100.000000, 94.000000, 84.000000, 37.000000,
32.000000, 71.000000, 47.000000, 77.000000,
31.000000, 50.000000, 49.000000, 35.000000,
63.000000, 67.000000, 40.000000, 31.000000,
29.000000, 68.000000, 61.000000, 38.000000,
31.000000, 28.000000, 28.000000, 76.000000,
55.000000, 33.000000, 29.000000, 39.000000
}

Definition at line 46 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ testOutput [1/2]

float32_t testOutput[(20 *4)]
static

Definition at line 79 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ testOutput [2/2]

float32_t testOutput[(20 *4)]
static

Definition at line 79 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ testUnity_f32 [1/2]

const float32_t testUnity_f32[4]
Initial value:
=
{
1.000, 1.000, 1.000, 1.000
}

Definition at line 72 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ testUnity_f32 [2/2]

const float32_t testUnity_f32[4]
Initial value:
=
{
1.000, 1.000, 1.000, 1.000
}

Definition at line 72 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ var [1/2]

float32_t var

Definition at line 90 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ var [2/2]

float32_t var

Definition at line 90 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c.


AT32F435/437 Firmwary Library: CORTEX_m4_fpu

Modules | Macros | Functions | Variables
CORTEX_m4_fpu
AT32F435_periph_examples | AT32F437_periph_examples

Modules

JULIA_fpu_functions

Macros

#define | ITERATION 200
#define | REAL_CONSTANT (0.285f)
#define | IMG_CONSTANT (0.01f)
#define | SCREEN_X_SIZE ((uint16_t)320)
#define | SCREEN_Y_SIZE ((uint16_t)240)
#define | ZOOM ((uint16_t)100)
#define | ITERATION 200
#define | REAL_CONSTANT (0.285f)
#define | IMG_CONSTANT (0.01f)
#define | SCREEN_X_SIZE ((uint16_t)320)
#define | SCREEN_Y_SIZE ((uint16_t)240)
#define | ZOOM ((uint16_t)100)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | generate_julia_fpu (uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable More...
int | main (void)
main function. More...

Variables

uint8_t | buffer [((uint16_t) 320) *((uint16_t) 240)]
uint8_t | buffer [((uint16_t) 320) *((uint16_t) 240)]

Detailed Description

Macro Definition Documentation

◆ IMG_CONSTANT [1/2]

#define IMG_CONSTANT (0.01f)

Definition at line 48 of file at_start_f435/examples/cortex_m4/fpu/inc/julia_fpu.h.

◆ IMG_CONSTANT [2/2]

#define IMG_CONSTANT (0.01f)

Definition at line 48 of file at_start_f437/examples/cortex_m4/fpu/inc/julia_fpu.h.

◆ ITERATION [1/2]

#define ITERATION 200

Definition at line 46 of file at_start_f435/examples/cortex_m4/fpu/inc/julia_fpu.h.

◆ ITERATION [2/2]

#define ITERATION 200

Definition at line 46 of file at_start_f437/examples/cortex_m4/fpu/inc/julia_fpu.h.

◆ REAL_CONSTANT [1/2]

#define REAL_CONSTANT (0.285f)

Definition at line 47 of file at_start_f435/examples/cortex_m4/fpu/inc/julia_fpu.h.

◆ REAL_CONSTANT [2/2]

#define REAL_CONSTANT (0.285f)

Definition at line 47 of file at_start_f437/examples/cortex_m4/fpu/inc/julia_fpu.h.

◆ SCREEN_X_SIZE [1/2]

#define SCREEN_X_SIZE ((uint16_t)320)

Definition at line 39 of file project/at_start_f435/examples/cortex_m4/fpu/src/main.c.

◆ SCREEN_X_SIZE [2/2]

#define SCREEN_X_SIZE ((uint16_t)320)

Definition at line 39 of file project/at_start_f437/examples/cortex_m4/fpu/src/main.c.

◆ SCREEN_Y_SIZE [1/2]

#define SCREEN_Y_SIZE ((uint16_t)240)

Definition at line 40 of file project/at_start_f435/examples/cortex_m4/fpu/src/main.c.

◆ SCREEN_Y_SIZE [2/2]

#define SCREEN_Y_SIZE ((uint16_t)240)

Definition at line 40 of file project/at_start_f437/examples/cortex_m4/fpu/src/main.c.

◆ ZOOM [1/2]

#define ZOOM ((uint16_t)100)

Definition at line 41 of file project/at_start_f435/examples/cortex_m4/fpu/src/main.c.

◆ ZOOM [2/2]

#define ZOOM ((uint16_t)100)

Definition at line 41 of file project/at_start_f437/examples/cortex_m4/fpu/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c.

◆ generate_julia_fpu()

void generate_julia_fpu | ( | uint16_t | size_x,
 |  | uint16_t | size_y,
 |  | uint16_t | offset_x,
 |  | uint16_t | offset_y,
 |  | uint16_t | zoom,
 |  | uint8_t * | buffer
 | ) |  |

julia calculation test with fpu option enable or disable

Parameters
size_x | width in pixel
size_y | height in pixel
offset_x | x offset for starting point
offset_y | y offset for starting point
zoom | iteration zoom ratio
buffer | pointer to output buffer where values are stored
Return values
none

Definition at line 48 of file at_start_f435/examples/cortex_m4/fpu/src/julia_fpu.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f435/examples/cortex_m4/fpu/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c.

Variable Documentation

◆ buffer [1/2]

uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]

Definition at line 43 of file project/at_start_f435/examples/cortex_m4/fpu/src/main.c.

Referenced by audio_codec_mic_get_data(), bot_scsi_send_data(), FlashWrite(), generate_julia_fpu(), main(), memset16_buffer(), sdram_copy_to_sram_dma(), sram_copy_to_sdram_dma(), usbd_ctrl_recv(), usbd_ctrl_send(), usbd_ept_recv(), usbd_ept_send(), usbh_bulk_recv(), usbh_bulk_send(), usbh_cmd_read(), usbh_cmd_write(), usbh_ctrl_recv_data(), usbh_ctrl_request(), usbh_ctrl_send_data(), usbh_ctrl_send_setup(), usbh_get_descriptor(), usbh_interrupt_recv(), usbh_interrupt_send(), usbh_isoc_recv(), usbh_isoc_send(), usbh_msc_read(), usbh_msc_rw_handle(), usbh_msc_write(), usbh_parse_configure_desc(), and usbh_parse_dev_desc().

◆ buffer [2/2]

uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]

Definition at line 43 of file project/at_start_f437/examples/cortex_m4/fpu/src/main.c.


AT32F435/437 Firmwary Library: JULIA_fpu_functions

Functions
JULIA_fpu_functions
AT32F435_periph_examples | AT32F437_periph_examples » CORTEX_m4_fpu

Functions

void generate_julia_fpu (uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable More...

Detailed Description

Function Documentation

◆ generate_julia_fpu()

void generate_julia_fpu | ( | uint16_t | size_x,
 |  | uint16_t | size_y,
 |  | uint16_t | offset_x,
 |  | uint16_t | offset_y,
 |  | uint16_t | zoom,
 |  | uint8_t * | buffer
 | ) |  |

julia calculation test with fpu option enable or disable

Parameters
size_x | width in pixel
size_y | height in pixel
offset_x | x offset for starting point
offset_y | y offset for starting point
zoom | iteration zoom ratio
buffer | pointer to output buffer where values are stored
Return values
none

Definition at line 48 of file at_start_f437/examples/cortex_m4/fpu/src/julia_fpu.c.

Referenced by main().


AT32F435/437 Firmwary Library: CORTEX_m4_systick_interrupt

Macros | Functions
CORTEX_m4_systick_interrupt
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | MS_TICK (system_core_clock / 1000U)
#define | DELAY 200 /* 200 ms ticks */
#define | MS_TICK (system_core_clock / 1000U)
#define | DELAY 200 /* 200 ms ticks */

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | systick_handler (void)
systick interrupt handler. More...
int | main (void)
main function. More...

Detailed Description

Macro Definition Documentation

◆ DELAY [1/2]

#define DELAY 200 /* 200 ms ticks */

Definition at line 38 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/src/main.c.

◆ DELAY [2/2]

#define DELAY 200 /* 200 ms ticks */

Definition at line 38 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/src/main.c.

◆ MS_TICK [1/2]

#define MS_TICK (system_core_clock / 1000U)

Definition at line 37 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/src/main.c.

◆ MS_TICK [2/2]

#define MS_TICK (system_core_clock / 1000U)

Definition at line 37 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 80 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 115 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 54 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 64 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 67 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 45 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 124 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 106 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 133 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c.

◆ systick_handler()

void systick_handler ( void )

systick interrupt handler.

Parameters
none
Return values
none

Definition at line 45 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/src/main.c.

Referenced by SysTick_Handler().

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 93 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: CRC_calculation

Macros | Functions | Variables
CRC_calculation
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | BUFFER_SIZE 120
#define | BUFFER_SIZE 120

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

static const uint32_t | data_buffer [120]
__IO uint32_t | crc_value = 0
static const uint32_t | data_buffer [120]
__IO uint32_t | crc_value = 0

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE [1/2]

#define BUFFER_SIZE 120

Definition at line 38 of file project/at_start_f435/examples/crc/calculation/src/main.c.

◆ BUFFER_SIZE [2/2]

#define BUFFER_SIZE 120

Definition at line 38 of file project/at_start_f437/examples/crc/calculation/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 71 of file project/at_start_f435/examples/crc/calculation/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c.

Variable Documentation

◆ crc_value [1/2]

__IO uint32_t crc_value = 0

Definition at line 64 of file project/at_start_f435/examples/crc/calculation/src/main.c.

Referenced by iap_crc(), and main().

◆ crc_value [2/2]

__IO uint32_t crc_value = 0

Definition at line 64 of file project/at_start_f437/examples/crc/calculation/src/main.c.

◆ data_buffer [1/2]

const uint32_t data_buffer[120]
static
Initial value:
=
{
0xc33dd31c, 0xe37ff35e, 0x129022f3, 0x32d24235, 0x52146277, 0x7256b5ea,
0x4a755a54, 0x6a377a16, 0x0af11ad0, 0x2ab33a92, 0xed0fdd6c, 0xcd4dbdaa,
0xbb3bab1a, 0x6ca67c87, 0x5cc52c22, 0x3c030c60, 0x1c41edae, 0xfd8fcdec,
0xad8b9de8, 0x8dc97c26, 0x5c644c45, 0x3ca22c83, 0x1ce00cc1, 0xef1fff3e,
0x95a88589, 0xf56ee54f, 0xd52cc50d, 0x34e224c3, 0x04817466, 0x64475424,
0x78066827, 0x18c008e1, 0x28a3cb7d, 0xdb5ceb3f, 0xfb1e8bf9, 0x9bd8abbb,
0xdf7caf9b, 0xbfba8fd9, 0x9ff86e17, 0x7e364e55, 0x2e933eb2, 0x0ed11ef0,
0xa35ad3bd, 0xc39cf3ff, 0xe3de2462, 0x34430420, 0x64e674c7, 0x44a45485,
0xad2abd0b, 0x8d689d49, 0x7e976eb6, 0x5ed54ef4, 0x2e321e51, 0x0e70ff9f,
0xefbedfdd, 0xcffcbf1b, 0x9f598f78, 0x918881a9, 0xb1caa1eb, 0xd10cc12d,
0xe16f1080, 0x00a130c2, 0x20e35004, 0x40257046, 0x83b99398, 0xa3fbb3da,
0x00001021, 0x20423063, 0x408450a5, 0x60c670e7, 0x9129a14a, 0xb16bc18c,
0x569546b4, 0xb75ba77a, 0x97198738, 0xf7dfe7fe, 0xc7bc48c4, 0x58e56886,
0x4405a7db, 0xb7fa8799, 0xe75ff77e, 0xc71dd73c, 0x26d336f2, 0x069116b0,
0x76764615, 0x5634d94c, 0xc96df90e, 0xe92f99c8, 0xb98aa9ab, 0x58444865,
0x78a70840, 0x18612802, 0xc9ccd9ed, 0xe98ef9af, 0x89489969, 0xa90ab92b,
0xd1ade1ce, 0xf1ef1231, 0x32732252, 0x52b54294, 0x72f762d6, 0x93398318,
0xa56ab54b, 0x85289509, 0xf5cfc5ac, 0xd58d3653, 0x26721611, 0x063076d7,
0x8d689d49, 0xf7dfe7fe, 0xe98ef9af, 0x063076d7, 0x93398318, 0xb98aa9ab,
0x4ad47ab7, 0x6a961a71, 0x0a503a33, 0x2a12dbfd, 0xfbbfeb9e, 0x9b798b58
}

Definition at line 40 of file project/at_start_f435/examples/crc/calculation/src/main.c.

Referenced by main().

◆ data_buffer [2/2]

const uint32_t data_buffer[120]
static
Initial value:
=
{
0xc33dd31c, 0xe37ff35e, 0x129022f3, 0x32d24235, 0x52146277, 0x7256b5ea,
0x4a755a54, 0x6a377a16, 0x0af11ad0, 0x2ab33a92, 0xed0fdd6c, 0xcd4dbdaa,
0xbb3bab1a, 0x6ca67c87, 0x5cc52c22, 0x3c030c60, 0x1c41edae, 0xfd8fcdec,
0xad8b9de8, 0x8dc97c26, 0x5c644c45, 0x3ca22c83, 0x1ce00cc1, 0xef1fff3e,
0x95a88589, 0xf56ee54f, 0xd52cc50d, 0x34e224c3, 0x04817466, 0x64475424,
0x78066827, 0x18c008e1, 0x28a3cb7d, 0xdb5ceb3f, 0xfb1e8bf9, 0x9bd8abbb,
0xdf7caf9b, 0xbfba8fd9, 0x9ff86e17, 0x7e364e55, 0x2e933eb2, 0x0ed11ef0,
0xa35ad3bd, 0xc39cf3ff, 0xe3de2462, 0x34430420, 0x64e674c7, 0x44a45485,
0xad2abd0b, 0x8d689d49, 0x7e976eb6, 0x5ed54ef4, 0x2e321e51, 0x0e70ff9f,
0xefbedfdd, 0xcffcbf1b, 0x9f598f78, 0x918881a9, 0xb1caa1eb, 0xd10cc12d,
0xe16f1080, 0x00a130c2, 0x20e35004, 0x40257046, 0x83b99398, 0xa3fbb3da,
0x00001021, 0x20423063, 0x408450a5, 0x60c670e7, 0x9129a14a, 0xb16bc18c,
0x569546b4, 0xb75ba77a, 0x97198738, 0xf7dfe7fe, 0xc7bc48c4, 0x58e56886,
0x4405a7db, 0xb7fa8799, 0xe75ff77e, 0xc71dd73c, 0x26d336f2, 0x069116b0,
0x76764615, 0x5634d94c, 0xc96df90e, 0xe92f99c8, 0xb98aa9ab, 0x58444865,
0x78a70840, 0x18612802, 0xc9ccd9ed, 0xe98ef9af, 0x89489969, 0xa90ab92b,
0xd1ade1ce, 0xf1ef1231, 0x32732252, 0x52b54294, 0x72f762d6, 0x93398318,
0xa56ab54b, 0x85289509, 0xf5cfc5ac, 0xd58d3653, 0x26721611, 0x063076d7,
0x8d689d49, 0xf7dfe7fe, 0xe98ef9af, 0x063076d7, 0x93398318, 0xb98aa9ab,
0x4ad47ab7, 0x6a961a71, 0x0a503a33, 0x2a12dbfd, 0xfbbfeb9e, 0x9b798b58
}

Definition at line 40 of file project/at_start_f437/examples/crc/calculation/src/main.c.


AT32F435/437 Firmwary Library: CRM_clock_failure_detection

Functions
CRM_clock_failure_detection
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | clkout_config (void)
clkout configuration. More...
static void | sclk_288m_hick_config (void)
system clock config program More...
void | clock_failure_detection_handler (void)
clock failure detection handler. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c.

◆ clkout_config()

static void clkout_config ( void )
static

clkout configuration.

Parameters
none
Return values
none

< gpio pins number 8

Definition at line 47 of file project/at_start_f435/examples/crm/clock_failure_detection/src/main.c.

Referenced by main(), and sclk_288m_hick_config().

◆ clock_failure_detection_handler()

void clock_failure_detection_handler ( void )

clock failure detection handler.

Parameters
none
Return values
none

< clock failure interrupt ready flag

< clock failure interrupt ready flag

< clock failure interrupt ready flag

< clock failure interrupt ready flag

Definition at line 76 of file project/at_start_f435/examples/crm/clock_failure_detection/src/main.c.

Referenced by NMI_Handler().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 181 of file project/at_start_f435/examples/crm/clock_failure_detection/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 45 of file project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c.

◆ sclk_288m_hick_config()

static void sclk_288m_hick_config ( void )
static

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hick * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hick)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< high speed internal clock stable flag

< phase locking loop stable flag

Definition at line 111 of file project/at_start_f435/examples/crm/clock_failure_detection/src/main.c.

Referenced by clock_failure_detection_handler().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: CRM_pll_parameter_calculate

Functions | Variables
CRM_pll_parameter_calculate
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | clkout_config (void)
clkout configuration. More...
void | system_clock_config_200mhz (void)
system clock config 200mhz More...
int | main (void)
main function. More...

Variables

error_status calculate_status = ERROR
error_status calculate_status = ERROR

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c.

◆ clkout_config()

void clkout_config ( void )

clkout configuration.

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 8

Definition at line 45 of file project/at_start_f435/examples/crm/pll_parameter_calculate/src/main.c.

Referenced by main(), sclk_64m_hick_config(), and sclk_96m_hext_config().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 155 of file project/at_start_f435/examples/crm/pll_parameter_calculate/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c.

◆ system_clock_config_200mhz()

void system_clock_config_200mhz ( void )

system clock config 200mhz

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 200000000
  • ahbdiv = 1
  • ahbclk = 200000000
  • apb2div = 2
  • apb2clk = 100000000
  • apb1div = 2
  • apb1clk = 100000000 pll_ns, pll_ms and pll_fr need calculate
Parameters
none
Return values
none

< phase locking loop stable flag

< phase locking loop stable flag

Definition at line 86 of file project/at_start_f435/examples/crm/pll_parameter_calculate/src/main.c.

Referenced by main().

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c.

Variable Documentation

◆ calculate_status [1/2]

error_status calculate_status = ERROR

Definition at line 38 of file project/at_start_f435/examples/crm/pll_parameter_calculate/src/main.c.

Referenced by main(), and system_clock_config_200mhz().

◆ calculate_status [2/2]

error_status calculate_status = ERROR

Definition at line 38 of file project/at_start_f437/examples/crm/pll_parameter_calculate/src/main.c.


AT32F435/437 Firmwary Library: CRM_sysclk_switch

Functions
CRM_sysclk_switch
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | clkout_config (void)
clkout configuration. More...
static void | sclk_64m_hick_config (void)
config sclk 64 mhz with hick clock source. More...
static void | sclk_96m_hext_config (void)
config sclk 96 mhz with hext clock source. More...
static void | switch_system_clock (void)
sclk switch function. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c.

◆ clkout_config()

static void clkout_config ( void )
static

clkout configuration.

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 8

Definition at line 48 of file project/at_start_f435/examples/crm/sysclk_switch/src/main.c.

Referenced by main(), sclk_64m_hick_config(), and sclk_96m_hext_config().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 268 of file project/at_start_f435/examples/crm/sysclk_switch/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c.

◆ sclk_64m_hick_config()

static void sclk_64m_hick_config ( void )
static

config sclk 64 mhz with hick clock source.

Note
the system clock is configured as follow:
  • system clock = (hick * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hick)
  • hext = 8000000
  • sclk = 64000000
  • ahbdiv = 1
  • ahbclk = 64000000
  • apb2div = 2
  • apb2clk = 32000000
  • apb1div = 2
  • apb1clk = 32000000
  • pll_ns = 64
  • pll_ms = 1
  • pll_fr = 8
Parameters
none
Return values
none

< high speed internal clock stable flag

< phase locking loop stable flag

Definition at line 108 of file project/at_start_f435/examples/crm/sysclk_switch/src/main.c.

Referenced by switch_system_clock().

◆ sclk_96m_hext_config()

static void sclk_96m_hext_config ( void )
static

config sclk 96 mhz with hext clock source.

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 96000000
  • ahbdiv = 1
  • ahbclk = 96000000
  • apb2div = 2
  • apb2clk = 48000000
  • apb1div = 2
  • apb1clk = 48000000
  • pll_ns = 96
  • pll_ms = 1
  • pll_fr = 8
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 195 of file project/at_start_f435/examples/crm/sysclk_switch/src/main.c.

Referenced by switch_system_clock().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c.

◆ switch_system_clock()

static void switch_system_clock ( void )
static

sclk switch function.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f435/examples/crm/sysclk_switch/src/main.c.

Referenced by main().

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: DAC_double_mode_dma_sinewave

Functions | Variables
DAC_double_mode_dma_sinewave
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
dma_init_type dma_init_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
const uint16_t | sine12bit [32]
uint32_t | dualsine12bit [32]
uint32_t | idx = 0
gpio_init_type | gpio_init_struct = {0}
dma_init_type dma_init_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
const uint16_t | sine12bit [32]
uint32_t | dualsine12bit [32]
uint32_t | idx = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 4

< gpio pins number 5

Definition at line 53 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c.

Variable Documentation

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 40 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c.

Referenced by emac_tmr_init(), main(), tmr1_config(), tmr2_config(), and tmr_init().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 40 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/main.c.

◆ dma_init_struct [1/2]

dma_init_type dma_init_struct

Definition at line 39 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2s_config(), main(), qspi_dma_set(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ dma_init_struct [2/2]

dma_init_type dma_init_struct

Definition at line 39 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/main.c.

◆ dualsine12bit [1/2]

uint32_t dualsine12bit[32]

Definition at line 45 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c.

Referenced by main().

◆ dualsine12bit [2/2]

uint32_t dualsine12bit[32]

Definition at line 45 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/main.c.

◆ gpio_init_struct [1/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c.

Referenced by adc_configuration(), at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), emac_pins_configuration(), gpio_config(), gpio_configuration(), gpio_default_para_init(), gpio_init(), main(), mclk_tmr1_init(), nand_init(), nor_init(), psram_init(), qspi_config(), reset_phy(), rs485_config(), sd_init(), sdram_init(), sram_init(), swj_dp_config(), touch_pin_init(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), usart_spi_configuration(), usb_gpio_config(), and xmc_init().

◆ gpio_init_struct [2/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/main.c.

◆ idx [1/2]

uint32_t idx = 0

Definition at line 46 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c.

Referenced by main(), usbd_int_to_unicode(), usbh_find_interface(), usbh_hid_keyboard_decode(), and usbh_hid_mouse_process().

◆ idx [2/2]

uint32_t idx = 0

Definition at line 46 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/main.c.

◆ sine12bit [1/2]

const uint16_t sine12bit[32]
Initial value:
= {2047, 2447, 2831, 3185, 3498, 3750, 3939, 4056,
4095, 4056, 3939, 3750, 3495, 3185, 2831, 2447,
2047, 1647, 1263, 909, 599, 344, 155, 38,
0, 38, 155, 344, 599, 909, 1263, 1647}

Definition at line 41 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c.

Referenced by main().

◆ sine12bit [2/2]

const uint16_t sine12bit[32]
Initial value:
= {2047, 2447, 2831, 3185, 3498, 3750, 3939, 4056,
4095, 4056, 3939, 3750, 3495, 3185, 2831, 2447,
2047, 1647, 1263, 909, 599, 344, 155, 38,
0, 38, 155, 344, 599, 909, 1263, 1647}

Definition at line 41 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/main.c.


AT32F435/437 Firmwary Library: DAC_double_mode_dma_squarewave

Functions | Variables
DAC_double_mode_dma_squarewave
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
dma_init_type dma_init_struct
uint32_t | dualsquare12bit [2] = {(0xfff | (0xfff << 16)), 0}
gpio_init_type | gpio_init_struct = {0}
dma_init_type dma_init_struct
uint32_t | dualsquare12bit [2] = {(0xfff | (0xfff << 16)), 0}

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 4

< gpio pins number 5

Definition at line 48 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c.

Variable Documentation

◆ dma_init_struct [1/2]

dma_init_type dma_init_struct

Definition at line 39 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/main.c.

Referenced by main().

◆ dma_init_struct [2/2]

dma_init_type dma_init_struct

Definition at line 39 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/src/main.c.

◆ dualsquare12bit [1/2]

uint32_t dualsquare12bit[2] = {(0xfff | (0xfff << 16)), 0}

Definition at line 41 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/main.c.

Referenced by main().

◆ dualsquare12bit [2/2]

uint32_t dualsquare12bit[2] = {(0xfff | (0xfff << 16)), 0}

Definition at line 41 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/src/main.c.

◆ gpio_init_struct [1/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/main.c.

Referenced by main().

◆ gpio_init_struct [2/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/src/main.c.


AT32F435/437 Firmwary Library: DAC_one_dac_dma_escalator

Functions | Variables
DAC_one_dac_dma_escalator
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
dma_init_type dma_init_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
const uint8_t | escalator8bit [6] = {0x0, 0x33, 0x66, 0x99, 0xCC, 0xFF}
gpio_init_type | gpio_init_struct = {0}
dma_init_type dma_init_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
const uint8_t | escalator8bit [6] = {0x0, 0x33, 0x66, 0x99, 0xCC, 0xFF}

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 4

Definition at line 48 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c.

Variable Documentation

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 40 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 40 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/src/main.c.

◆ dma_init_struct [1/2]

dma_init_type dma_init_struct

Definition at line 39 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c.

Referenced by main().

◆ dma_init_struct [2/2]

dma_init_type dma_init_struct

Definition at line 39 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/src/main.c.

◆ escalator8bit [1/2]

const uint8_t escalator8bit[6] = {0x0, 0x33, 0x66, 0x99, 0xCC, 0xFF}

Definition at line 41 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c.

Referenced by main().

◆ escalator8bit [2/2]

const uint8_t escalator8bit[6] = {0x0, 0x33, 0x66, 0x99, 0xCC, 0xFF}

Definition at line 41 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/src/main.c.

◆ gpio_init_struct [1/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c.

Referenced by main().

◆ gpio_init_struct [2/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/src/main.c.


AT32F435/437 Firmwary Library: DAC_one_dac_noisewave

Functions | Variables
DAC_one_dac_noisewave
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
gpio_init_type | gpio_init_struct = {0}

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 4

Definition at line 45 of file project/at_start_f435/examples/dac/one_dac_noisewave/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c.

Variable Documentation

◆ gpio_init_struct [1/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f435/examples/dac/one_dac_noisewave/src/main.c.

Referenced by main().

◆ gpio_init_struct [2/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f437/examples/dac/one_dac_noisewave/src/main.c.


AT32F435/437 Firmwary Library: DAC_two_dac_trianglewave

Functions | Variables
DAC_two_dac_trianglewave
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 4

< gpio pins number 5

Definition at line 45 of file project/at_start_f435/examples/dac/two_dac_trianglewave/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c.

Variable Documentation

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f435/examples/dac/two_dac_trianglewave/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f437/examples/dac/two_dac_trianglewave/src/main.c.

◆ gpio_init_struct [1/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f435/examples/dac/two_dac_trianglewave/src/main.c.

Referenced by main().

◆ gpio_init_struct [2/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f437/examples/dac/two_dac_trianglewave/src/main.c.


AT32F435/437 Firmwary Library: DEBUG_tmr

Functions | Variables
DEBUG_tmr
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR1_OVF_TMR10_IRQHandler (void)
this function handles tmr1 overflow handler. More...
int | main (void)
main function. More...

Variables

crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | counter = 0
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | counter = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< debug timer1 pause

< tmr interrupt overflow

< debug timer1 pause

< tmr interrupt overflow

Definition at line 61 of file project/at_start_f435/examples/debug/tmr1/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c.

◆ TMR1_OVF_TMR10_IRQHandler()

void TMR1_OVF_TMR10_IRQHandler ( void )

this function handles tmr1 overflow handler.

tmr1 interrupt handler

this function handles timer1 overflow handler.

Parameters
none
Return values
none

< tmr flag overflow

< tmr flag overflow

< tmr flag overflow

< tmr flag overflow

Definition at line 46 of file project/at_start_f435/examples/debug/tmr1/src/main.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c.

Variable Documentation

◆ counter [1/2]

uint16_t counter = 0

Definition at line 39 of file project/at_start_f435/examples/debug/tmr1/src/main.c.

Referenced by can_receive_error_counter_get(), can_transmit_error_counter_get(), ertc_wakeup_counter_set(), esmt32m_cmd_read_config(), esmt32m_cmd_read_pem_begin_config(), esmt32m_cmd_read_pem_end_config(), esmt32m_cmd_read_pem_keep_config(), esmt32m_cmd_write_config(), main(), and xmc_sdram_refresh_counter_set().

◆ counter [2/2]

uint16_t counter = 0

Definition at line 39 of file project/at_start_f437/examples/debug/tmr1/src/main.c.

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 38 of file project/at_start_f435/examples/debug/tmr1/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 38 of file project/at_start_f437/examples/debug/tmr1/src/main.c.


AT32F435/437 Firmwary Library: DMA_data_to_gpio

Macros | Functions | Variables
DMA_data_to_gpio
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | BUFFER_SIZE 16
#define | BUFFER_SIZE 16

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA2_Channel1_IRQHandler (void)
this function handles dma2 channel1 handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
dma_init_type dma_init_struct
uint16_t | src_buffer [16]
gpio_init_type | gpio_init_struct = {0}
dma_init_type dma_init_struct
uint16_t | src_buffer [16]

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE [1/2]

#define BUFFER_SIZE 16

Definition at line 41 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c.

◆ BUFFER_SIZE [2/2]

#define BUFFER_SIZE 16

Definition at line 41 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c.

◆ DMA2_Channel1_IRQHandler()

void DMA2_Channel1_IRQHandler ( void )

this function handles dma2 channel1 handler.

Parameters
none
Return values
none

< dma2 channel1 full data transfer flag

< dma2 channel1 full data transfer flag

< dma2 channel1 full data transfer flag

< dma2 channel1 full data transfer flag

Definition at line 141 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio all pins

< dma full data transfer interrupt

< gpio all pins

< dma full data transfer interrupt

Definition at line 50 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c.

Variable Documentation

◆ dma_init_struct [1/2]

dma_init_type dma_init_struct

Definition at line 39 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c.

Referenced by main().

◆ dma_init_struct [2/2]

dma_init_type dma_init_struct

Definition at line 39 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/src/main.c.

◆ gpio_init_struct [1/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c.

Referenced by main().

◆ gpio_init_struct [2/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/src/main.c.

◆ src_buffer [1/2]

uint16_t src_buffer[16]
Initial value:
= {0x0001, 0x0002, 0x0003, 0x0004, 0x0005, 0x0006, 0x0007, 0x0008,
0x0009, 0x000a, 0x000b, 0x000c, 0x000d, 0x000e, 0x000f, 0x0010}

Definition at line 42 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c.

Referenced by main().

◆ src_buffer [2/2]

uint16_t src_buffer[16]
Initial value:
= {0x0001, 0x0002, 0x0003, 0x0004, 0x0005, 0x0006, 0x0007, 0x0008,
0x0009, 0x000a, 0x000b, 0x000c, 0x000d, 0x000e, 0x000f, 0x0010}

Definition at line 42 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/src/main.c.


AT32F435/437 Firmwary Library: DMAMUX_genertor_exint

Macros | Functions | Variables
DMAMUX_genertor_exint
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | BUFFER_SIZE 16
#define | BUFFER_SIZE 16

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA2_Channel4_IRQHandler (void)
this function handles DMA2 channel1 handler. More...
void | EXINT1_IRQHandler (void)
exint1 interrupt handler More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
dma_init_type dma_init_struct
dmamux_gen_init_type dmamux_gen_init_struct
exint_init_type exint_init_struct
uint16_t | src_buffer [16]
uint16_t | dst_buffer [16]
gpio_init_type | gpio_init_struct = {0}
dma_init_type dma_init_struct
dmamux_gen_init_type dmamux_gen_init_struct
exint_init_type exint_init_struct
uint16_t | src_buffer [16]
uint16_t | dst_buffer [16]

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE [1/2]

#define BUFFER_SIZE 16

Definition at line 42 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c.

◆ BUFFER_SIZE [2/2]

#define BUFFER_SIZE 16

Definition at line 42 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c.

◆ DMA2_Channel4_IRQHandler()

void DMA2_Channel4_IRQHandler ( void )

this function handles DMA2 channel1 handler.

this function handles dma2 channel4 handler.

Parameters
none
Return values
none

< dma2 channel4 full data transfer flag

< dma2 channel4 full data transfer flag

< dma2 channel4 full data transfer flag

< dma2 channel4 full data transfer flag

Definition at line 141 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c.

◆ EXINT1_IRQHandler()

void EXINT1_IRQHandler ( void )

exint1 interrupt handler

Parameters
none
Return values
none

< external interrupt line 1

< external interrupt line 1

< external interrupt line 1

< external interrupt line 1

Definition at line 53 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 1

< external interrupt line 1

< dma full data transfer interrupt

< gpio pins number 1

< external interrupt line 1

< dma full data transfer interrupt

Definition at line 66 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c.

Variable Documentation

◆ dma_init_struct [1/2]

dma_init_type dma_init_struct

Definition at line 39 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c.

Referenced by main().

◆ dma_init_struct [2/2]

dma_init_type dma_init_struct

Definition at line 39 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/src/main.c.

◆ dmamux_gen_init_struct [1/2]

dmamux_gen_init_type dmamux_gen_init_struct

Definition at line 40 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c.

Referenced by dmamux_generator_config(), dmamux_generator_default_para_init(), and main().

◆ dmamux_gen_init_struct [2/2]

dmamux_gen_init_type dmamux_gen_init_struct

Definition at line 40 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/src/main.c.

◆ dst_buffer [1/2]

uint16_t dst_buffer[16]

Definition at line 46 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c.

Referenced by main().

◆ dst_buffer [2/2]

uint16_t dst_buffer[16]

Definition at line 46 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/src/main.c.

◆ exint_init_struct [1/2]

exint_init_type exint_init_struct

Definition at line 41 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c.

Referenced by button_exint_init(), ertc_alarm_config(), ertc_tamper_config(), ertc_timestamp_config(), ertc_wakeup_timer_config(), exint_config(), exint_line0_config(), exint_line4_config(), main(), pvm_exint_config(), usart_configuration(), and wakeup_timer_config().

◆ exint_init_struct [2/2]

exint_init_type exint_init_struct

Definition at line 41 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/src/main.c.

◆ gpio_init_struct [1/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c.

Referenced by main().

◆ gpio_init_struct [2/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/src/main.c.

◆ src_buffer [1/2]

uint16_t src_buffer[16]
Initial value:
= {0x0001, 0x0002, 0x0003, 0x0004, 0x0005, 0x0006, 0x0007, 0x0008,
0x0009, 0x000a, 0x000b, 0x000c, 0x000d, 0x000e, 0x000f, 0x0010}

Definition at line 43 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c.

Referenced by main().

◆ src_buffer [2/2]

uint16_t src_buffer[16]
Initial value:
= {0x0001, 0x0002, 0x0003, 0x0004, 0x0005, 0x0006, 0x0007, 0x0008,
0x0009, 0x000a, 0x000b, 0x000c, 0x000d, 0x000e, 0x000f, 0x0010}

Definition at line 43 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/src/main.c.


AT32F435/437 Firmwary Library: DMAMUX_synchronization_exint

Macros | Functions | Variables
DMAMUX_synchronization_exint
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | BUFFER_SIZE 16
#define | BUFFER_SIZE 16

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA2_Channel4_IRQHandler (void)
this function handles dma2 channel4 handler. More...
void | EXINT1_IRQHandler (void)
exint1 interrupt handler More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
dma_init_type dma_init_struct
dmamux_sync_init_type dmamux_sync_init_struct
exint_init_type exint_init_struct
uint16_t | src_buffer [16]
uint16_t | dst_buffer [16]
gpio_init_type | gpio_init_struct = {0}
dma_init_type dma_init_struct
dmamux_sync_init_type dmamux_sync_init_struct
exint_init_type exint_init_struct
uint16_t | src_buffer [16]
uint16_t | dst_buffer [16]

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE [1/2]

#define BUFFER_SIZE 16

Definition at line 42 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c.

◆ BUFFER_SIZE [2/2]

#define BUFFER_SIZE 16

Definition at line 42 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c.

◆ DMA2_Channel4_IRQHandler()

void DMA2_Channel4_IRQHandler ( void )

this function handles dma2 channel4 handler.

Parameters
none
Return values
none

< dma2 channel4 full data transfer flag

< dma2 channel4 full data transfer flag

< dma2 channel4 full data transfer flag

< dma2 channel4 full data transfer flag

Definition at line 141 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c.

◆ EXINT1_IRQHandler()

void EXINT1_IRQHandler ( void )

exint1 interrupt handler

Parameters
none
Return values
none

< external interrupt line 1

< external interrupt line 1

< external interrupt line 1

< external interrupt line 1

Definition at line 54 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 1

< external interrupt line 1

< dma full data transfer interrupt

< gpio pins number 1

< external interrupt line 1

< dma full data transfer interrupt

Definition at line 67 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c.

Variable Documentation

◆ dma_init_struct [1/2]

dma_init_type dma_init_struct

Definition at line 39 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c.

Referenced by main().

◆ dma_init_struct [2/2]

dma_init_type dma_init_struct

Definition at line 39 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/main.c.

◆ dmamux_sync_init_struct [1/2]

dmamux_sync_init_type dmamux_sync_init_struct

Definition at line 40 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c.

Referenced by dmamux_sync_config(), dmamux_sync_default_para_init(), and main().

◆ dmamux_sync_init_struct [2/2]

dmamux_sync_init_type dmamux_sync_init_struct

Definition at line 40 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/main.c.

◆ dst_buffer [1/2]

uint16_t dst_buffer[16]

Definition at line 46 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c.

Referenced by main().

◆ dst_buffer [2/2]

uint16_t dst_buffer[16]

Definition at line 46 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/main.c.

◆ exint_init_struct [1/2]

exint_init_type exint_init_struct

Definition at line 41 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c.

Referenced by main().

◆ exint_init_struct [2/2]

exint_init_type exint_init_struct

Definition at line 41 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/main.c.

◆ gpio_init_struct [1/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c.

Referenced by main().

◆ gpio_init_struct [2/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/main.c.

◆ src_buffer [1/2]

uint16_t src_buffer[16]
Initial value:
= {0x0001, 0x0002, 0x0003, 0x0004, 0x0005, 0x0006, 0x0007, 0x0008,
0x0009, 0x000a, 0x000b, 0x000c, 0x000d, 0x000e, 0x000f, 0x0010}

Definition at line 43 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c.

Referenced by main().

◆ src_buffer [2/2]

uint16_t src_buffer[16]
Initial value:
= {0x0001, 0x0002, 0x0003, 0x0004, 0x0005, 0x0006, 0x0007, 0x0008,
0x0009, 0x000a, 0x000b, 0x000c, 0x000d, 0x000e, 0x000f, 0x0010}

Definition at line 43 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/main.c.


AT32F435/437 Firmwary Library: DMA_flash_to_sram

Macros | Functions | Variables
DMA_flash_to_sram
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | BUFFER_SIZE 32
#define | BUFFER_SIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1 channel1 handler. More...
error_status | buffer_compare (const uint32_t *pbuffer, uint32_t *pbuffer1, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

const uint32_t | src_const_buffer [32]
uint32_t | dst_buffer [32]
gpio_init_type | gpio_init_struct = {0}
dma_init_type dma_init_struct
__IO uint32_t | data_counter_end = 0x01
error_status transfer_status = ERROR
const uint32_t | src_const_buffer [32]
uint32_t | dst_buffer [32]
gpio_init_type | gpio_init_struct = {0}
dma_init_type dma_init_struct
__IO uint32_t | data_counter_end = 0x01
error_status transfer_status = ERROR

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE [1/2]

#define BUFFER_SIZE 32

Definition at line 38 of file project/at_start_f435/examples/dma/flash_to_sram/src/main.c.

◆ BUFFER_SIZE [2/2]

#define BUFFER_SIZE 32

Definition at line 38 of file project/at_start_f437/examples/dma/flash_to_sram/src/main.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | const uint32_t * | pbuffer,
 |  | uint32_t * | pbuffer1,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer,pbuffer1 | buffers to be compared.
buffer_length | buffer's length
Return values
SUCCESS pbuffer identical to pbuffer1 ERROR: pbuffer differs from pbuffer1

Definition at line 61 of file project/at_start_f435/examples/dma/flash_to_sram/src/main.c.

Referenced by fatfs_test(), main(), mmc_stream_test(), sd_multiple_blocks_test(), and sd_single_block_test().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1 channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 143 of file project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< dma full data transfer interrupt

< dma full data transfer interrupt

Definition at line 82 of file project/at_start_f435/examples/dma/flash_to_sram/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c.

Variable Documentation

◆ data_counter_end [1/2]

__IO uint32_t data_counter_end = 0x01

Definition at line 51 of file project/at_start_f435/examples/dma/flash_to_sram/src/main.c.

Referenced by main().

◆ data_counter_end [2/2]

__IO uint32_t data_counter_end = 0x01

Definition at line 51 of file project/at_start_f437/examples/dma/flash_to_sram/src/main.c.

◆ dma_init_struct [1/2]

dma_init_type dma_init_struct

Definition at line 50 of file project/at_start_f435/examples/dma/flash_to_sram/src/main.c.

Referenced by main().

◆ dma_init_struct [2/2]

dma_init_type dma_init_struct

Definition at line 50 of file project/at_start_f437/examples/dma/flash_to_sram/src/main.c.

◆ dst_buffer [1/2]

uint32_t dst_buffer[32]

Definition at line 48 of file project/at_start_f435/examples/dma/flash_to_sram/src/main.c.

Referenced by main().

◆ dst_buffer [2/2]

uint32_t dst_buffer[32]

Definition at line 48 of file project/at_start_f437/examples/dma/flash_to_sram/src/main.c.

◆ gpio_init_struct [1/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 49 of file project/at_start_f435/examples/dma/flash_to_sram/src/main.c.

◆ gpio_init_struct [2/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 49 of file project/at_start_f437/examples/dma/flash_to_sram/src/main.c.

◆ src_const_buffer [1/2]

const uint32_t src_const_buffer[32]
Initial value:
= {0x01020304, 0x05060708, 0x090A0B0C, 0x0D0E0F10,
0x11121314, 0x15161718, 0x191A1B1C, 0x1D1E1F20,
0x21222324, 0x25262728, 0x292A2B2C, 0x2D2E2F30,
0x31323334, 0x35363738, 0x393A3B3C, 0x3D3E3F40,
0x41424344, 0x45464748, 0x494A4B4C, 0x4D4E4F50,
0x51525354, 0x55565758, 0x595A5B5C, 0x5D5E5F60,
0x61626364, 0x65666768, 0x696A6B6C, 0x6D6E6F70,
0x71727374, 0x75767778, 0x797A7B7C, 0x7D7E7F80}

Definition at line 40 of file project/at_start_f435/examples/dma/flash_to_sram/src/main.c.

Referenced by main().

◆ src_const_buffer [2/2]

const uint32_t src_const_buffer[32]
Initial value:
= {0x01020304, 0x05060708, 0x090A0B0C, 0x0D0E0F10,
0x11121314, 0x15161718, 0x191A1B1C, 0x1D1E1F20,
0x21222324, 0x25262728, 0x292A2B2C, 0x2D2E2F30,
0x31323334, 0x35363738, 0x393A3B3C, 0x3D3E3F40,
0x41424344, 0x45464748, 0x494A4B4C, 0x4D4E4F50,
0x51525354, 0x55565758, 0x595A5B5C, 0x5D5E5F60,
0x61626364, 0x65666768, 0x696A6B6C, 0x6D6E6F70,
0x71727374, 0x75767778, 0x797A7B7C, 0x7D7E7F80}

Definition at line 40 of file project/at_start_f437/examples/dma/flash_to_sram/src/main.c.

◆ transfer_status [1/2]

error_status transfer_status = ERROR

Definition at line 52 of file project/at_start_f435/examples/dma/flash_to_sram/src/main.c.

Referenced by main().

◆ transfer_status [2/2]

error_status transfer_status = ERROR

Definition at line 52 of file project/at_start_f437/examples/dma/flash_to_sram/src/main.c.


AT32F435/437 Firmwary Library: DVP_ov2640_capture

Modules | Data Structures | Macros | Functions | Variables
DVP_ov2640_capture
AT32F435_periph_examples | AT32F437_periph_examples

Modules

LCD_device_type
ADDRESS_of_data_and_command
LCD_reset_line
XMC_lcd_exported_functions

Data Structures

struct Descriptors_Format_def

Macros

#define | LCD_W 320
#define | LCD_H 240
#define | LCD_BL_HIGH gpio_bits_set(GPIOC,GPIO_PINS_0)
#define | LCD_BL_LOW gpio_bits_reset(GPIOC,GPIO_PINS_0)
#define | WHITE 0xFFFF
#define | BLACK 0x0000
#define | BLUE 0x001F
#define | BRED 0xF81F
#define | GRED 0xFFE0
#define | GBLUE 0x07FF
#define | RED 0xF800
#define | MAGENTA 0xF81F
#define | GREEN 0x07E0
#define | CYAN 0x7FFF
#define | YELLOW 0xFFE0
#define | BROWN 0xBC40
#define | BRRED 0xFC07
#define | GRAY 0x8430
#define | I2C_TIMEOUT 0x2FFFFFF
#define | I2Cx_CLKCTRL 0x30F05292
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_DMA DMA1
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_AF GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_AF GPIO_MUX_4
#define | LCD_W 320
#define | LCD_H 240
#define | LCD_BL_HIGH gpio_bits_set(GPIOC,GPIO_PINS_0)
#define | LCD_BL_LOW gpio_bits_reset(GPIOC,GPIO_PINS_0)
#define | WHITE 0xFFFF
#define | BLACK 0x0000
#define | BLUE 0x001F
#define | BRED 0xF81F
#define | GRED 0xFFE0
#define | GBLUE 0x07FF
#define | RED 0xF800
#define | MAGENTA 0xF81F
#define | GREEN 0x07E0
#define | CYAN 0x7FFF
#define | YELLOW 0xFFE0
#define | BROWN 0xBC40
#define | BRRED 0xFC07
#define | GRAY 0x8430
#define | I2C_TIMEOUT 0x2FFFFFF
#define | I2Cx_CLKCTRL 0x30F05292
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_DMA DMA1
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_AF GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_AF GPIO_MUX_4

Functions

void | jpeg_data_process (void)
void | dvp_config (void)
configure dvp More...
void | dvp_io_init (void)
initialize gpio for dvp More...
void | dvp_dma_init (uint32_t mem0addr, uint32_t mem1addr, uint16_t memsize)
initialize dma for dvp More...
void | dvp_start (void)
start dvp transmission More...
void | dvp_stop (void)
stop dvp transmission More...
void | DVP_IRQHandler (void)
dvp irq handler More...
void | dvp_frame_done (void)
dvp frame transmit done More...
void | EDMA_Stream4_IRQHandler (void)
edma stream4 irq handler More...
error_status | ov2640_reg_write (uint8_t reg, uint8_t data)
write register to ov2640 More...
error_status | ov2640_reg_read (uint8_t reg, uint8_t *data)
read register from ov2640 More...
error_status | ov2640_init (void)
void | ov2640_jpeg_mode (void)
void | ov2640_rgb565_mode (void)
void | ov2640_auto_exposure (u8 level)
void | ov2640_light_mode (u8 mode)
void | ov2640_color_saturation (u8 sat)
void | ov2640_brightness (u8 bright)
void | ov2640_contrast (u8 contrast)
void | ov2640_special_effects (u8 eft)
void | ov2640_color_bar (u8 sw)
void | ov2640_window_set (u16 sx, u16 sy, u16 width, u16 height)
u8 | ov2640_outsize_set (u16 width, u16 height)
u8 | ov2640_imagewin_set (u16 offx, u16 offy, u16 width, u16 height)
u8 | ov2640_imagesize_set (u16 width, u16 height)
void | ov2640_i2c_init (void)
ov2640 i2c initialize More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ov2640_capture (void)
int | main (void)
main function. More...

Variables

edma_init_type edma_init_struct
uint8_t | ov_frame = 0
edma_init_type edma_init_struct
const unsigned char | asc2_1206 [95][12]
const unsigned char | asc2_1608 [95][16]
const unsigned char | asc2_2412 [95][36]
const unsigned char | asc2_3216 [95][128]
lcd_dev_type lcd_dev_struct
lcd_dev_type * lcd_struct
lcd_dev_type lcd_dev_struct
lcd_dev_type * lcd_struct
static uint16_t | LCD_ID
i2c_handle_type hi2cx
i2c_status_type STA
static const u8 | OV2640_AUTOEXPOSURE_LEVEL [5][8]
uint16_t | point_color
edma_init_type edma_init_struct
uint8_t | ov_frame = 0
edma_init_type edma_init_struct
const unsigned char | asc2_1206 [95][12]
const unsigned char | asc2_1608 [95][16]
const unsigned char | asc2_2412 [95][36]
const unsigned char | asc2_3216 [95][128]
lcd_dev_type lcd_dev_struct
lcd_dev_type * lcd_struct
lcd_dev_type lcd_dev_struct
lcd_dev_type * lcd_struct
static uint16_t | LCD_ID
i2c_handle_type hi2cx
i2c_status_type STA
static const u8 | OV2640_AUTOEXPOSURE_LEVEL [5][8]
uint16_t | point_color

Detailed Description

Macro Definition Documentation

◆ BLACK [1/2]

#define BLACK 0x0000

Definition at line 85 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ BLACK [2/2]

#define BLACK 0x0000

Definition at line 85 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ BLUE [1/2]

#define BLUE 0x001F

Definition at line 86 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ BLUE [2/2]

#define BLUE 0x001F

Definition at line 86 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ BRED [1/2]

#define BRED 0xF81F

Definition at line 87 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ BRED [2/2]

#define BRED 0xF81F

Definition at line 87 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ BROWN [1/2]

#define BROWN 0xBC40

Definition at line 95 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ BROWN [2/2]

#define BROWN 0xBC40

Definition at line 95 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ BRRED [1/2]

#define BRRED 0xFC07

Definition at line 96 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ BRRED [2/2]

#define BRRED 0xFC07

Definition at line 96 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ CYAN [1/2]

#define CYAN 0x7FFF

Definition at line 93 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ CYAN [2/2]

#define CYAN 0x7FFF

Definition at line 93 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ GBLUE [1/2]

#define GBLUE 0x07FF

Definition at line 89 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ GBLUE [2/2]

#define GBLUE 0x07FF

Definition at line 89 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ GRAY [1/2]

#define GRAY 0x8430

Definition at line 97 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ GRAY [2/2]

#define GRAY 0x8430

Definition at line 97 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ GRED [1/2]

#define GRED 0xFFE0

Definition at line 88 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ GRED [2/2]

#define GRED 0xFFE0

Definition at line 88 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ GREEN [1/2]

#define GREEN 0x07E0

Definition at line 92 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ GREEN [2/2]

#define GREEN 0x07E0

Definition at line 92 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ I2C_TIMEOUT [1/2]

#define I2C_TIMEOUT 0x2FFFFFF

Definition at line 15 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2C_TIMEOUT [2/2]

#define I2C_TIMEOUT 0x2FFFFFF

Definition at line 15 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_ADDRESS [1/2]

#define I2Cx_ADDRESS 0xA0

Definition at line 18 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_ADDRESS [2/2]

#define I2Cx_ADDRESS 0xA0

Definition at line 18 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_CLK [1/2]

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 21 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_CLK [2/2]

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 21 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_CLKCTRL [1/2]

#define I2Cx_CLKCTRL 0x30F05292

Definition at line 17 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_CLKCTRL [2/2]

#define I2Cx_CLKCTRL 0x30F05292

Definition at line 17 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_DMA [1/2]

#define I2Cx_DMA DMA1

Definition at line 22 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_DMA [2/2]

#define I2Cx_DMA DMA1

Definition at line 22 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_DMA_CLK [1/2]

#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK

Definition at line 23 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_DMA_CLK [2/2]

#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK

Definition at line 23 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_PORT [1/2]

#define I2Cx_PORT I2C1

Definition at line 20 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_PORT [2/2]

#define I2Cx_PORT I2C1

Definition at line 20 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_SCL_GPIO_AF [1/2]

#define I2Cx_SCL_GPIO_AF GPIO_MUX_4

Definition at line 29 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_SCL_GPIO_AF [2/2]

#define I2Cx_SCL_GPIO_AF GPIO_MUX_4

Definition at line 29 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_SCL_GPIO_CLK [1/2]

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 25 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_SCL_GPIO_CLK [2/2]

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 25 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_SCL_GPIO_PIN [1/2]

#define I2Cx_SCL_GPIO_PIN GPIO_PINS_6

Definition at line 26 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_SCL_GPIO_PIN [2/2]

#define I2Cx_SCL_GPIO_PIN GPIO_PINS_6

Definition at line 26 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_SCL_GPIO_PinsSource [1/2]

#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6

Definition at line 27 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_SCL_GPIO_PinsSource [2/2]

#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6

Definition at line 27 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_SCL_GPIO_PORT [1/2]

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 28 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_SCL_GPIO_PORT [2/2]

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 28 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_SDA_GPIO_AF [1/2]

#define I2Cx_SDA_GPIO_AF GPIO_MUX_4

Definition at line 35 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_SDA_GPIO_AF [2/2]

#define I2Cx_SDA_GPIO_AF GPIO_MUX_4

Definition at line 35 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_SDA_GPIO_CLK [1/2]

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 31 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_SDA_GPIO_CLK [2/2]

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 31 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_SDA_GPIO_PIN [1/2]

#define I2Cx_SDA_GPIO_PIN GPIO_PINS_7

Definition at line 32 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_SDA_GPIO_PIN [2/2]

#define I2Cx_SDA_GPIO_PIN GPIO_PINS_7

Definition at line 32 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_SDA_GPIO_PinsSource [1/2]

#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7

Definition at line 33 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_SDA_GPIO_PinsSource [2/2]

#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7

Definition at line 33 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_SDA_GPIO_PORT [1/2]

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 34 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ I2Cx_SDA_GPIO_PORT [2/2]

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 34 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ LCD_BL_HIGH [1/2]

#define LCD_BL_HIGH gpio_bits_set(GPIOC,GPIO_PINS_0)

Definition at line 81 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ LCD_BL_HIGH [2/2]

#define LCD_BL_HIGH gpio_bits_set(GPIOC,GPIO_PINS_0)

Definition at line 81 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ LCD_BL_LOW [1/2]

#define LCD_BL_LOW gpio_bits_reset(GPIOC,GPIO_PINS_0)

Definition at line 82 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ LCD_BL_LOW [2/2]

#define LCD_BL_LOW gpio_bits_reset(GPIOC,GPIO_PINS_0)

Definition at line 82 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ LCD_H [1/2]

#define LCD_H 240

Definition at line 79 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ LCD_H [2/2]

#define LCD_H 240

Definition at line 79 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ LCD_W [1/2]

#define LCD_W 320

Definition at line 78 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ LCD_W [2/2]

#define LCD_W 320

Definition at line 78 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ MAGENTA [1/2]

#define MAGENTA 0xF81F

Definition at line 91 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ MAGENTA [2/2]

#define MAGENTA 0xF81F

Definition at line 91 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ RED [1/2]

#define RED 0xF800

Definition at line 90 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ RED [2/2]

#define RED 0xF800

Definition at line 90 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ WHITE [1/2]

#define WHITE 0xFFFF

Definition at line 84 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ WHITE [2/2]

#define WHITE 0xFFFF

Definition at line 84 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ YELLOW [1/2]

#define YELLOW 0xFFE0

Definition at line 94 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ YELLOW [2/2]

#define YELLOW 0xFFE0

Definition at line 94 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c.

◆ dvp_config()

void dvp_config ( void )

configure dvp

Parameters
none
Return values
none

< capture frame done interrupt

< data fifo overrun interrupt

< embedded synchronization error interrupt

< vertical synchonization interrupt

< horizontal synchonization interrupt

< capture frame done interrupt

< data fifo overrun interrupt

< embedded synchronization error interrupt

< vertical synchonization interrupt

< horizontal synchonization interrupt

Definition at line 60 of file at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c.

Referenced by ov2640_capture(), and ov5640_capture().

◆ dvp_dma_init()

void dvp_dma_init | ( | uint32_t | mem0addr,
 |  | uint32_t | mem1addr,
 |  | uint16_t | memsize
 | ) |  |

initialize dma for dvp

Parameters
mem0addr | memory0 base address
mem1addr | memory1 base address
memsize | memory size
memblen | memory data width
meminc | memory increase
Return values
none

Definition at line 129 of file at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c.

Referenced by ov2640_capture(), and ov5640_capture().

◆ dvp_frame_done()

void dvp_frame_done ( void )

dvp frame transmit done

Parameters
none
Return values
none

Definition at line 205 of file at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c.

Referenced by dvp_int_handler().

◆ dvp_io_init()

void dvp_io_init ( void )

initialize gpio for dvp

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 6

< gpio pins number 9

< gpio pins number 10

< gpio pins number 11

< gpio pins number 12

< gpio pins number 4

< gpio pins number 7

< gpio pins number 9

< gpio pins number 4

< gpio pins number 5

< gpio pins number 4

< gpio pins number 6

< gpio pins number 9

< gpio pins number 10

< gpio pins number 11

< gpio pins number 12

< gpio pins number 4

< gpio pins number 7

< gpio pins number 9

< gpio pins number 4

< gpio pins number 5

Definition at line 85 of file at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c.

Referenced by dvp_config().

◆ DVP_IRQHandler()

void DVP_IRQHandler ( void )

dvp irq handler

Parameters
none
Return values
none

Definition at line 195 of file at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c.

◆ dvp_start()

void dvp_start ( void )

start dvp transmission

Parameters
none
Return values
none

Definition at line 169 of file at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c.

Referenced by ov2640_capture(), and ov5640_capture().

◆ dvp_stop()

void dvp_stop ( void )

stop dvp transmission

Parameters
none
Return values
none

Definition at line 181 of file at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c.

◆ EDMA_Stream4_IRQHandler()

void EDMA_Stream4_IRQHandler ( void )

edma stream4 irq handler

this function handles edma stream4 handler.

Parameters
none
Return values
none

Definition at line 216 of file at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c.

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
hi2c i2c_handle_type
Return values
none

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

Definition at line 465 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ jpeg_data_process()

void jpeg_data_process ( void )

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f435/examples/dvp/ov2640_capture/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c.

◆ ov2640_auto_exposure()

void ov2640_auto_exposure ( u8 level )

Definition at line 195 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ ov2640_brightness()

void ov2640_brightness ( u8 bright )

Definition at line 265 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

Referenced by ov2640_capture().

◆ ov2640_capture()

void ov2640_capture ( void )

Definition at line 85 of file project/at_start_f435/examples/dvp/ov2640_capture/src/main.c.

Referenced by main().

◆ ov2640_color_bar()

void ov2640_color_bar ( u8 sw )

Definition at line 355 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ ov2640_color_saturation()

void ov2640_color_saturation ( u8 sat )

Definition at line 249 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

Referenced by ov2640_capture().

◆ ov2640_contrast()

void ov2640_contrast ( u8 contrast )

Definition at line 280 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

Referenced by ov2640_capture().

◆ ov2640_i2c_init()

void ov2640_i2c_init ( void )

ov2640 i2c initialize

Parameters
none
Return values
none

Definition at line 454 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

Referenced by ov2640_init().

◆ ov2640_imagesize_set()

u8 ov2640_imagesize_set | ( | u16 | width,
 |  | u16 | height
 | ) |  |

Definition at line 434 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ ov2640_imagewin_set()

u8 ov2640_imagewin_set | ( | u16 | offx,
 |  | u16 | offy,
 |  | u16 | width,
 |  | u16 | height
 | ) |  |

Definition at line 409 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ ov2640_init()

error_status ov2640_init ( void )

< gpio pins number 3

< gpio pins number 1

< gpio pins number 3

< gpio pins number 1

< gpio pins number 3

< gpio pins number 3

< gpio pins number 1

< gpio pins number 3

< gpio pins number 1

< gpio pins number 3

Definition at line 84 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

Referenced by main().

◆ ov2640_jpeg_mode()

void ov2640_jpeg_mode ( void )

Definition at line 136 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ ov2640_light_mode()

void ov2640_light_mode ( u8 mode )

Definition at line 210 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

Referenced by ov2640_capture().

◆ ov2640_outsize_set()

u8 ov2640_outsize_set | ( | u16 | width,
 |  | u16 | height
 | ) |  |

Definition at line 389 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

Referenced by ov2640_capture().

◆ ov2640_reg_read()

error_status ov2640_reg_read | ( | uint8_t | reg,
 |  | uint8_t * | data
 | ) |  |

read register from ov2640

Parameters
reg | register read from ov2640
data | data read from ov2640
Return values
error_status SUCCESS, ERROR

Definition at line 66 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

Referenced by ov2640_color_bar(), ov2640_init(), and ov2640_window_set().

◆ ov2640_reg_write()

error_status ov2640_reg_write | ( | uint8_t | reg,
 |  | uint8_t | data
 | ) |  |

write register to ov2640

Parameters
reg | register write to ov2640
data | data write to ov2640
Return values
error_status SUCCESS, ERROR

Definition at line 46 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

Referenced by ov2640_auto_exposure(), ov2640_brightness(), ov2640_color_bar(), ov2640_color_saturation(), ov2640_contrast(), ov2640_imagesize_set(), ov2640_imagewin_set(), ov2640_init(), ov2640_jpeg_mode(), ov2640_light_mode(), ov2640_outsize_set(), ov2640_rgb565_mode(), ov2640_special_effects(), and ov2640_window_set().

◆ ov2640_rgb565_mode()

void ov2640_rgb565_mode ( void )

Definition at line 151 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

Referenced by ov2640_capture().

◆ ov2640_special_effects()

void ov2640_special_effects ( u8 eft )

Definition at line 313 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ ov2640_window_set()

void ov2640_window_set | ( | u16 | sx,
 |  | u16 | sy,
 |  | u16 | width,
 |  | u16 | height
 | ) |  |

Definition at line 365 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c.

Variable Documentation

◆ asc2_1206 [1/2]

const unsigned char asc2_1206[95][12]

Definition at line 38 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h.

Referenced by lcd_char_show().

◆ asc2_1206 [2/2]

const unsigned char asc2_1206[95][12]

Definition at line 38 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/font.h.

◆ asc2_1608 [1/2]

const unsigned char asc2_1608[95][16]

Definition at line 136 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h.

Referenced by lcd_char_show().

◆ asc2_1608 [2/2]

const unsigned char asc2_1608[95][16]

Definition at line 136 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/font.h.

◆ asc2_2412 [1/2]

const unsigned char asc2_2412[95][36]

Definition at line 234 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h.

Referenced by lcd_char_show().

◆ asc2_2412 [2/2]

const unsigned char asc2_2412[95][36]

Definition at line 234 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/font.h.

◆ asc2_3216 [1/2]

const unsigned char asc2_3216[95][128]

Definition at line 332 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h.

Referenced by lcd_char_show().

◆ asc2_3216 [2/2]

const unsigned char asc2_3216[95][128]

Definition at line 332 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/font.h.

◆ edma_init_struct [1/4]

edma_init_type edma_init_struct

Definition at line 40 of file at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c.

Referenced by dvp_dma_init(), edma_config(), edma_default_para_init(), edma_init(), and i2s_config().

◆ edma_init_struct [2/4]

edma_init_type edma_init_struct
extern

Definition at line 40 of file at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c.

◆ edma_init_struct [3/4]

edma_init_type edma_init_struct

Definition at line 40 of file at_start_f437/examples/dvp/ov2640_capture/hardware/dvp/dvp.c.

◆ edma_init_struct [4/4]

edma_init_type edma_init_struct
extern

Definition at line 40 of file at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c.

◆ hi2cx [1/2]

i2c_handle_type hi2cx

Definition at line 37 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

Referenced by ov2640_i2c_init(), ov2640_reg_read(), and ov2640_reg_write().

◆ hi2cx [2/2]

i2c_handle_type hi2cx

Definition at line 37 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ lcd_dev_struct [1/4]

lcd_dev_type lcd_dev_struct
Initial value:
=
{
0,
xmc_init,
lcd_init,
lcd_setblock,
lcd_drawpoint,
lcd_clear,
}
lcd_setblock
void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:332
lcd_init
void lcd_init(void)
configures the lcd. this function must be called before any write/read operation on the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:165
lcd_drawpoint
void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:367
lcd_clear
void lcd_clear(uint16_t color)
this function is clear the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:379
xmc_init
void xmc_init(void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write...
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:57

Definition at line 38 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

Referenced by main().

◆ lcd_dev_struct [2/4]

lcd_dev_type lcd_dev_struct
extern

Definition at line 38 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

◆ lcd_dev_struct [3/4]

lcd_dev_type lcd_dev_struct
Initial value:
=
{
0,
xmc_init,
lcd_init,
lcd_setblock,
lcd_drawpoint,
lcd_clear,
}

Definition at line 38 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

◆ lcd_dev_struct [4/4]

lcd_dev_type lcd_dev_struct
extern

Definition at line 38 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

◆ LCD_ID [1/2]

uint16_t LCD_ID
static

Definition at line 83 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ LCD_ID [2/2]

uint16_t LCD_ID
static

Definition at line 83 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ lcd_struct [1/4]

lcd_dev_type* lcd_struct

Definition at line 48 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

Referenced by dvp_frame_done(), dvp_start(), lcd_clear(), lcd_color_fill(), lcd_drawpoint(), lcd_fill(), lcd_init(), and main().

◆ lcd_struct [2/4]

lcd_dev_type* lcd_struct
extern

Definition at line 48 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

◆ lcd_struct [3/4]

lcd_dev_type* lcd_struct

Definition at line 48 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

◆ lcd_struct [4/4]

lcd_dev_type* lcd_struct
extern

Definition at line 48 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

◆ OV2640_AUTOEXPOSURE_LEVEL [1/2]

const u8 OV2640_AUTOEXPOSURE_LEVEL[5][8]
static

Definition at line 160 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

Referenced by ov2640_auto_exposure().

◆ OV2640_AUTOEXPOSURE_LEVEL [2/2]

const u8 OV2640_AUTOEXPOSURE_LEVEL[5][8]
static

Definition at line 160 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ ov_frame [1/2]

uint8_t ov_frame = 0

Definition at line 41 of file at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c.

Referenced by dvp_frame_done().

◆ ov_frame [2/2]

uint8_t ov_frame = 0

Definition at line 41 of file at_start_f437/examples/dvp/ov2640_capture/hardware/dvp/dvp.c.

◆ point_color [1/2]

uint16_t point_color

Definition at line 42 of file project/at_start_f435/examples/dvp/ov2640_capture/src/main.c.

Referenced by main().

◆ point_color [2/2]

uint16_t point_color

Definition at line 42 of file project/at_start_f437/examples/dvp/ov2640_capture/src/main.c.

◆ STA [1/2]

i2c_status_type STA

Definition at line 38 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

Referenced by ov2640_reg_write().

◆ STA [2/2]

i2c_status_type STA

Definition at line 38 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.


AT32F435/437 Firmwary Library: LCD_device_type

Data Structures
LCD_device_type
AT32F435_periph_examples | AT32F437_periph_examples » DVP_ov2640_capture | AT32F435_periph_examples | AT32F437_periph_examples » DVP_ov5640_capture | AT32F435_periph_examples | AT32F437_periph_examples » XMC_lcd_touch_16bit

Data Structures

struct lcd_dev_type

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: lcd_dev_type Struct Reference

Data Fields
lcd_dev_type Struct Reference
AT32F435_periph_examples | AT32F437_periph_examples » DVP_ov2640_capture | AT32F435_periph_examples | AT32F437_periph_examples » DVP_ov5640_capture | AT32F435_periph_examples | AT32F437_periph_examples » XMC_lcd_touch_16bit » LCD_device_type

#include <xmc_lcd.h>

Data Fields

uint16_t | lcd_id
void(* | xmc_init )(void)
void(* | lcd_init )(void)
void(* | lcd_setblock )(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
void(* | draw_point )(uint16_t x, uint16_t y, uint16_t color)
void(* | lcd_clear )(uint16_t color)

Detailed Description

Definition at line 43 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

Field Documentation

◆ draw_point

void(* lcd_dev_type::draw_point)(uint16_t x, uint16_t y, uint16_t color)

lcd function to drawpoint

Definition at line 49 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ lcd_clear

void(* lcd_dev_type::lcd_clear)(uint16_t color)

lcd function to clear

Definition at line 50 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

Referenced by main().

◆ lcd_id

uint16_t lcd_dev_type::lcd_id

lcd device id define

Definition at line 45 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

Referenced by lcd_init().

◆ lcd_init

void(* lcd_dev_type::lcd_init)(void) ( void )

function for configures the lcd

Definition at line 47 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

Referenced by main().

◆ lcd_setblock

void(* lcd_dev_type::lcd_setblock)(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)

lcd function to set block or set window

Definition at line 48 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

Referenced by dvp_frame_done(), dvp_start(), lcd_clear(), lcd_color_fill(), lcd_drawpoint(), and lcd_fill().

◆ xmc_init

void(* lcd_dev_type::xmc_init)(void) ( void )

function for xmc and gpios init

Definition at line 46 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

Referenced by lcd_init().

The documentation for this struct was generated from the following files:
  • at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h
  • at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h
  • at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h
  • at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h
  • at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h


AT32F435/437 Firmwary Library: ADDRESS_of_data_and_command

Macros
ADDRESS_of_data_and_command
AT32F435_periph_examples | AT32F437_periph_examples » DVP_ov2640_capture | AT32F435_periph_examples | AT32F437_periph_examples » DVP_ov5640_capture | AT32F435_periph_examples | AT32F437_periph_examples » XMC_lcd_8bit | AT32F435_periph_examples | AT32F437_periph_examples » XMC_lcd_touch_16bit

Macros

#define | XMC_LCD_COMMAND (0x6C000000)
#define | XMC_LCD_DATA (0x6C000800)
#define | XMC_LCD_COMMAND (0x6C000000)
#define | XMC_LCD_DATA (0x6C000800)
#define | XMC_LCD_COMMAND 0x60000000
#define | XMC_LCD_DATA 0x60000001
#define | XMC_LCD_COMMAND 0x6C000000
#define | XMC_LCD_DATA 0x6C000800
#define | XMC_LCD_COMMAND (0x6C000000)
#define | XMC_LCD_DATA (0x6C000800)
#define | XMC_LCD_COMMAND (0x6C000000)
#define | XMC_LCD_DATA (0x6C000800)
#define | XMC_LCD_COMMAND 0x60000000
#define | XMC_LCD_DATA 0x60000001
#define | XMC_LCD_COMMAND 0x6C000000
#define | XMC_LCD_DATA 0x6C000800

Detailed Description

Macro Definition Documentation

◆ XMC_LCD_COMMAND [1/8]

#define XMC_LCD_COMMAND (0x6C000000)

Definition at line 65 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ XMC_LCD_COMMAND [2/8]

#define XMC_LCD_COMMAND (0x6C000000)

Definition at line 65 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ XMC_LCD_COMMAND [3/8]

#define XMC_LCD_COMMAND 0x60000000

Definition at line 41 of file at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ XMC_LCD_COMMAND [4/8]

#define XMC_LCD_COMMAND 0x6C000000

Definition at line 65 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ XMC_LCD_COMMAND [5/8]

#define XMC_LCD_COMMAND (0x6C000000)

Definition at line 65 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ XMC_LCD_COMMAND [6/8]

#define XMC_LCD_COMMAND (0x6C000000)

Definition at line 65 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ XMC_LCD_COMMAND [7/8]

#define XMC_LCD_COMMAND 0x60000000

Definition at line 41 of file at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ XMC_LCD_COMMAND [8/8]

#define XMC_LCD_COMMAND 0x6C000000

Definition at line 65 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ XMC_LCD_DATA [1/8]

#define XMC_LCD_DATA (0x6C000800)

Definition at line 66 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ XMC_LCD_DATA [2/8]

#define XMC_LCD_DATA (0x6C000800)

Definition at line 66 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ XMC_LCD_DATA [3/8]

#define XMC_LCD_DATA 0x60000001

Definition at line 42 of file at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ XMC_LCD_DATA [4/8]

#define XMC_LCD_DATA 0x6C000800

Definition at line 66 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ XMC_LCD_DATA [5/8]

#define XMC_LCD_DATA (0x6C000800)

Definition at line 66 of file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.

◆ XMC_LCD_DATA [6/8]

#define XMC_LCD_DATA (0x6C000800)

Definition at line 66 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ XMC_LCD_DATA [7/8]

#define XMC_LCD_DATA 0x60000001

Definition at line 42 of file at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ XMC_LCD_DATA [8/8]

#define XMC_LCD_DATA 0x6C000800

Definition at line 66 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.


AT32F435/437 Firmwary Library: LCD_reset_line

Macros
LCD_reset_line
AT32F435_periph_examples | AT32F437_periph_examples » DVP_ov2640_capture | AT32F435_periph_examples | AT32F437_periph_examples » DVP_ov5640_capture | AT32F435_periph_examples | AT32F437_periph_examples » XMC_lcd_8bit | AT32F435_periph_examples | AT32F437_periph_examples » XMC_lcd_touch_16bit

Macros

#define | LCD_RESET_HIGH gpio_bits_set(GPIOB,GPIO_PINS_9)
#define | LCD_RESET_LOW gpio_bits_reset(GPIOB,GPIO_PINS_9)
#define | LCD_RESET_HIGH gpio_bits_set(GPIOB,GPIO_PINS_9)
#define | LCD_RESET_LOW gpio_bits_reset(GPIOB,GPIO_PINS_9)

Detailed Description

Macro Definition Documentation

◆ LCD_RESET_HIGH [1/2]

#define LCD_RESET_HIGH gpio_bits_set(GPIOB,GPIO_PINS_9)

Definition at line 53 of file at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ LCD_RESET_HIGH [2/2]

#define LCD_RESET_HIGH gpio_bits_set(GPIOB,GPIO_PINS_9)

Definition at line 53 of file at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ LCD_RESET_LOW [1/2]

#define LCD_RESET_LOW gpio_bits_reset(GPIOB,GPIO_PINS_9)

Definition at line 54 of file at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ LCD_RESET_LOW [2/2]

#define LCD_RESET_LOW gpio_bits_reset(GPIOB,GPIO_PINS_9)

Definition at line 54 of file at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h.


AT32F435/437 Firmwary Library: XMC_lcd_exported_functions

Functions
XMC_lcd_exported_functions
AT32F435_periph_examples | AT32F437_periph_examples » DVP_ov2640_capture | AT32F435_periph_examples | AT32F437_periph_examples » DVP_ov5640_capture | AT32F435_periph_examples | AT32F437_periph_examples » XMC_lcd_8bit | AT32F435_periph_examples | AT32F437_periph_examples » XMC_lcd_touch_16bit

Functions

void | xmc_init (void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_init (void)
configures the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_wr_command (uint16_t command)
this function is write command to lcd. More...
void | lcd_wr_data (uint16_t data)
this function is write data to lcd. More...
uint16_t | lcd_rd_data (void)
void | lcd_setblock (uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd. More...
void | lcd_writeonepoint (uint16_t color)
this function is write one point to lcd. More...
void | lcd_drawpoint (uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd. More...
void | lcd_clear (uint16_t color)
this function is clear the lcd. More...
void | lcd_char_show (uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode)
this function is show char to lcd More...
void | lcd_string_show (uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p)
this function is show string to lcd More...
void | lcd_fill (uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color)
this function is fill in lcd with concolorous More...
void | lcd_color_fill (uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color)
this function is fill in lcd with color-pointer More...
void | lcd_wr_command (uint8_t command)
this function is write command to lcd. More...
void | lcd_wr_data (uint8_t data)
this function is write data to lcd. More...
void | lcd_display_number (void)
this function is display number on the lcd. More...

Detailed Description

Function Documentation

◆ lcd_char_show()

void lcd_char_show | ( | uint16_t | x,
 |  | uint16_t | y,
 |  | uint8_t | num,
 |  | uint8_t | size,
 |  | uint8_t | mode
 | ) |  |

this function is show char to lcd

Parameters
x | : row coordinates starting vaule
y | : column coordinates starting vaule
num | : number of char
size | : size of char
mode | : color
Return values
none

Definition at line 400 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

Referenced by lcd_string_show().

◆ lcd_clear()

void lcd_clear ( uint16_t color )

this function is clear the lcd.

Parameters
data : the data to write.
Return values
none

Definition at line 379 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

Referenced by main(), ov2640_capture(), and ov5640_capture().

◆ lcd_color_fill()

void lcd_color_fill | ( | uint16_t | sx,
 |  | uint16_t | sy,
 |  | uint16_t | ex,
 |  | uint16_t | ey,
 |  | uint16_t * | color
 | ) |  |

this function is fill in lcd with color-pointer

Parameters
sx | : row coordinates starting vaule
sy | : column coordinates starting vaule
ex | : row coordinates ending vaule
ey | : column coordinates ending vaule
color | : color-point for fill in lcd
Return values
none

Definition at line 529 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

◆ lcd_display_number()

void lcd_display_number ( void )

this function is display number on the lcd.

Parameters
none
Return values
none

Definition at line 347 of file at_start_f437/examples/xmc/lcd_8bit/src/xmc_lcd.c.

Referenced by main().

◆ lcd_drawpoint()

void lcd_drawpoint | ( | uint16_t | x,
 |  | uint16_t | y,
 |  | uint16_t | color
 | ) |  |

this function is draw point to lcd.

Parameters
data : the data to write.
Return values
None
Parameters
data : the data to write.
Return values
none
Parameters
data : the data to write.
Return values
None
Parameters
data : the data to write.
Return values
none

Definition at line 367 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

Referenced by lcd_char_show(), and touch_scan().

◆ lcd_fill()

void lcd_fill | ( | uint16_t | sx,
 |  | uint16_t | sy,
 |  | uint16_t | ex,
 |  | uint16_t | ey,
 |  | uint16_t | color
 | ) |  |

this function is fill in lcd with concolorous

Parameters
sx | : row coordinates starting vaule
sy | : column coordinates starting vaule
ex | : row coordinates ending vaule
ey | : column coordinates ending vaule
color | : color for fill in lcd
Return values
none

Definition at line 508 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

Referenced by main().

◆ lcd_init()

void lcd_init ( void )

configures the lcd. this function must be called before any write/read operation on the lcd.

Parameters
none
Return values
none

Definition at line 165 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

Referenced by main().

◆ lcd_rd_data()

uint16_t lcd_rd_data ( void )

Definition at line 315 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

Referenced by lcd_init().

◆ lcd_setblock()

void lcd_setblock | ( | uint16_t | xstart,
 |  | uint16_t | ystart,
 |  | uint16_t | xend,
 |  | uint16_t | yend
 | ) |  |

this function is set row&column coordinates for lcd.

Parameters
xstart | : row coordinates starting vaule.
ystart | : column coordinates starting vaule.
xend | : row coordinates ending vaule.
yend | : column coordinates ending vaule.
Return values
none

Definition at line 332 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

Referenced by lcd_clear(), lcd_display_number(), and lcd_drawpoint().

◆ lcd_string_show()

void lcd_string_show | ( | uint16_t | x,
 |  | uint16_t | y,
 |  | uint16_t | width,
 |  | uint16_t | height,
 |  | uint8_t | size,
 |  | uint8_t * | p
 | ) |  |

this function is show string to lcd

Parameters
x | : row coordinates starting vaule
y | : column coordinates starting vaule
width | : width of string
height | : height of string
p | : pointer of string
Return values
none

Definition at line 474 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

Referenced by main(), ov2640_capture(), and ov5640_capture().

◆ lcd_wr_command() [1/2]

void lcd_wr_command ( uint16_t command )

this function is write command to lcd.

Parameters
command : the command to write.
Return values
none

Definition at line 300 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

Referenced by lcd_init(), and lcd_setblock().

◆ lcd_wr_command() [2/2]

void lcd_wr_command ( uint8_t command )

this function is write command to lcd.

Parameters
command : the command to write.
Return values
none

Definition at line 260 of file at_start_f437/examples/xmc/lcd_8bit/src/xmc_lcd.c.

Referenced by lcd_init(), and lcd_setblock().

◆ lcd_wr_data() [1/2]

void lcd_wr_data ( uint16_t data )

this function is write data to lcd.

Parameters
data : the data to write.
Return values
none

Definition at line 310 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

Referenced by lcd_display_number(), lcd_init(), lcd_setblock(), and lcd_writeonepoint().

◆ lcd_wr_data() [2/2]

void lcd_wr_data ( uint8_t data )

this function is write data to lcd.

Parameters
data : the data to write.
Return values
none

Definition at line 270 of file at_start_f437/examples/xmc/lcd_8bit/src/xmc_lcd.c.

Referenced by lcd_display_number(), lcd_init(), lcd_setblock(), and lcd_writeonepoint().

◆ lcd_writeonepoint()

void lcd_writeonepoint ( uint16_t color )

this function is write one point to lcd.

Parameters
data : the data to write.
Return values
none

Definition at line 357 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

Referenced by lcd_clear(), lcd_color_fill(), lcd_drawpoint(), and lcd_fill().

◆ xmc_init()

void xmc_init ( void )

configures the xmc and gpios to interface with the lcd. this function must be called before any write/read operation on the lcd.

Parameters
none
Return values
none

Definition at line 57 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

Referenced by lcd_init().


AT32F435/437 Firmwary Library: Descriptors_Format_def Struct Reference

Data Fields
Descriptors_Format_def Struct Reference
AT32F435_periph_examples | AT32F437_periph_examples » DVP_ov2640_capture | AT32F435_periph_examples | AT32F437_periph_examples » DVP_ov5640_capture

Data Fields

uint32_t | CR_NDT
uint32_t | PA
uint32_t | M0A
uint32_t | LLP

Detailed Description

Definition at line 46 of file at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c.

Field Documentation

◆ CR_NDT

uint32_t Descriptors_Format_def::CR_NDT

Definition at line 48 of file at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c.

◆ LLP

uint32_t Descriptors_Format_def::LLP

Definition at line 51 of file at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c.

◆ M0A

uint32_t Descriptors_Format_def::M0A

Definition at line 50 of file at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c.

◆ PA

uint32_t Descriptors_Format_def::PA

Definition at line 49 of file at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c.

The documentation for this struct was generated from the following files:
  • at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c
  • at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c
  • at_start_f437/examples/dvp/ov2640_capture/hardware/dvp/dvp.c
  • at_start_f437/examples/dvp/ov5640_capture/hardware/dvp/dvp.c


AT32F435/437 Firmwary Library: DVP_ov5640_capture

Modules | Data Structures | Macros | Functions | Variables
DVP_ov5640_capture
AT32F435_periph_examples | AT32F437_periph_examples

Modules

LCD_device_type
ADDRESS_of_data_and_command
LCD_reset_line
XMC_lcd_exported_functions
Ov5640_library_peripheral_info
Ov5640_library_exported_functions

Data Structures

struct Descriptors_Format_def

Macros

#define | LCD_W 320
#define | LCD_H 240
#define | LCD_BL_HIGH gpio_bits_set(GPIOC,GPIO_PINS_0)
#define | LCD_BL_LOW gpio_bits_reset(GPIOC,GPIO_PINS_0)
#define | WHITE 0xFFFF
#define | BLACK 0x0000
#define | BLUE 0x001F
#define | BRED 0xF81F
#define | GRED 0xFFE0
#define | GBLUE 0x07FF
#define | RED 0xF800
#define | MAGENTA 0xF81F
#define | GREEN 0x07E0
#define | CYAN 0x7FFF
#define | YELLOW 0xFFE0
#define | BROWN 0xBC40
#define | BRRED 0xFC07
#define | GRAY 0x8430
#define | I2C_TIMEOUT 0x2FFFFFF
#define | I2Cx_CLKCTRL 0x30F05292
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_DMA DMA1
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_AF GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_AF GPIO_MUX_4
#define | LCD_W 320
#define | LCD_H 240
#define | LCD_BL_HIGH gpio_bits_set(GPIOC,GPIO_PINS_0)
#define | LCD_BL_LOW gpio_bits_reset(GPIOC,GPIO_PINS_0)
#define | WHITE 0xFFFF
#define | BLACK 0x0000
#define | BLUE 0x001F
#define | BRED 0xF81F
#define | GRED 0xFFE0
#define | GBLUE 0x07FF
#define | RED 0xF800
#define | MAGENTA 0xF81F
#define | GREEN 0x07E0
#define | CYAN 0x7FFF
#define | YELLOW 0xFFE0
#define | BROWN 0xBC40
#define | BRRED 0xFC07
#define | GRAY 0x8430
#define | I2C_TIMEOUT 0x2FFFFFF
#define | I2Cx_CLKCTRL 0x30F05292
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_DMA DMA1
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_AF GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_AF GPIO_MUX_4

Functions

void | jpeg_data_process (void)
void | dvp_int_handler (void)
handles dvp interrupt request. More...
void | dvp_config (void)
configure dvp More...
void | dvp_io_init (void)
initialize gpio for dvp More...
void | dvp_dma_init (uint32_t mem0addr, uint32_t mem1addr, uint16_t memsize)
initialize dma for dvp More...
void | dvp_start (void)
start dvp transmission More...
void | dvp_stop (void)
stop dvp transmission More...
void | DVP_IRQHandler (void)
dvp irq handler More...
void | dvp_frame_done (void)
dvp frame transmit done More...
void | EDMA_Stream4_IRQHandler (void)
edma stream4 irq handler More...
void | xmc_init (void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_init (void)
configures the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_wr_command (uint16_t command)
this function is write command to lcd. More...
void | lcd_wr_data (uint16_t data)
this function is write data to lcd. More...
uint16_t | lcd_rd_data (void)
void | lcd_setblock (uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd. More...
void | lcd_writeonepoint (uint16_t color)
this function is write one point to lcd. More...
void | lcd_drawpoint (uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd. More...
void | lcd_clear (uint16_t color)
this function is clear the lcd. More...
void | lcd_char_show (uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode)
this function is show char to lcd More...
void | lcd_string_show (uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p)
this function is show string to lcd More...
void | lcd_fill (uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color)
this function is fill in lcd with concolorous More...
void | lcd_color_fill (uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color)
this function is fill in lcd with color-pointer More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ov5640_capture (void)
int | main (void)
main function. More...

Variables

edma_init_type edma_init_struct
uint8_t | ov_frame = 0
edma_init_type edma_init_struct
const unsigned char | asc2_1206 [95][12]
const unsigned char | asc2_1608 [95][16]
const unsigned char | asc2_2412 [95][36]
const unsigned char | asc2_3216 [95][128]
lcd_dev_type lcd_dev_struct
lcd_dev_type * lcd_struct
lcd_dev_type lcd_dev_struct
lcd_dev_type * lcd_struct
static uint16_t | LCD_ID
i2c_handle_type hi2cx
i2c_status_type STA
const uint8_t | OV5640_EXPOSURE_TBL [7][6]
const uint8_t | OV5640_LIGHTMODE_TBL [5][7]
const uint8_t | OV5640_SATURATION_TBL [7][6]
const uint8_t | OV5640_EFFECTS_TBL [7][3]
const unsigned char | OV5640_AF_Config []
const uint16_t | OV5640_jpeg_reg_tbl [][2]
const uint16_t | ov5640_rgb565_reg_tbl [][2]
const uint16_t | ov5640_uxga_init_reg_tbl [][2]
uint16_t | point_color
edma_init_type edma_init_struct
uint8_t | ov_frame = 0
edma_init_type edma_init_struct
const unsigned char | asc2_1206 [95][12]
const unsigned char | asc2_1608 [95][16]
const unsigned char | asc2_2412 [95][36]
const unsigned char | asc2_3216 [95][128]
lcd_dev_type lcd_dev_struct
lcd_dev_type * lcd_struct
lcd_dev_type lcd_dev_struct
lcd_dev_type * lcd_struct
static uint16_t | LCD_ID
i2c_handle_type hi2cx
i2c_status_type STA
const uint8_t | OV5640_EXPOSURE_TBL [7][6]
const uint8_t | OV5640_LIGHTMODE_TBL [5][7]
const uint8_t | OV5640_SATURATION_TBL [7][6]
const uint8_t | OV5640_EFFECTS_TBL [7][3]
const unsigned char | OV5640_AF_Config []
const uint16_t | OV5640_jpeg_reg_tbl [][2]
const uint16_t | ov5640_rgb565_reg_tbl [][2]
const uint16_t | ov5640_uxga_init_reg_tbl [][2]
uint16_t | point_color

Detailed Description

Macro Definition Documentation

◆ BLACK [1/2]

#define BLACK 0x0000

Definition at line 85 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ BLACK [2/2]

#define BLACK 0x0000

Definition at line 85 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ BLUE [1/2]

#define BLUE 0x001F

Definition at line 86 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ BLUE [2/2]

#define BLUE 0x001F

Definition at line 86 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ BRED [1/2]

#define BRED 0xF81F

Definition at line 87 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ BRED [2/2]

#define BRED 0xF81F

Definition at line 87 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ BROWN [1/2]

#define BROWN 0xBC40

Definition at line 95 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ BROWN [2/2]

#define BROWN 0xBC40

Definition at line 95 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ BRRED [1/2]

#define BRRED 0xFC07

Definition at line 96 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ BRRED [2/2]

#define BRRED 0xFC07

Definition at line 96 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ CYAN [1/2]

#define CYAN 0x7FFF

Definition at line 93 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ CYAN [2/2]

#define CYAN 0x7FFF

Definition at line 93 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ GBLUE [1/2]

#define GBLUE 0x07FF

Definition at line 89 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ GBLUE [2/2]

#define GBLUE 0x07FF

Definition at line 89 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ GRAY [1/2]

#define GRAY 0x8430

Definition at line 97 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ GRAY [2/2]

#define GRAY 0x8430

Definition at line 97 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ GRED [1/2]

#define GRED 0xFFE0

Definition at line 88 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ GRED [2/2]

#define GRED 0xFFE0

Definition at line 88 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ GREEN [1/2]

#define GREEN 0x07E0

Definition at line 92 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ GREEN [2/2]

#define GREEN 0x07E0

Definition at line 92 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ I2C_TIMEOUT [1/2]

#define I2C_TIMEOUT 0x2FFFFFF

Definition at line 42 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2C_TIMEOUT [2/2]

#define I2C_TIMEOUT 0x2FFFFFF

Definition at line 42 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_ADDRESS [1/2]

#define I2Cx_ADDRESS 0xA0

Definition at line 45 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_ADDRESS [2/2]

#define I2Cx_ADDRESS 0xA0

Definition at line 45 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_CLK [1/2]

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 48 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_CLK [2/2]

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 48 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_CLKCTRL [1/2]

#define I2Cx_CLKCTRL 0x30F05292

Definition at line 44 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_CLKCTRL [2/2]

#define I2Cx_CLKCTRL 0x30F05292

Definition at line 44 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_DMA [1/2]

#define I2Cx_DMA DMA1

Definition at line 49 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_DMA [2/2]

#define I2Cx_DMA DMA1

Definition at line 49 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_DMA_CLK [1/2]

#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK

Definition at line 50 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_DMA_CLK [2/2]

#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK

Definition at line 50 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_PORT [1/2]

#define I2Cx_PORT I2C1

Definition at line 47 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_PORT [2/2]

#define I2Cx_PORT I2C1

Definition at line 47 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_SCL_GPIO_AF [1/2]

#define I2Cx_SCL_GPIO_AF GPIO_MUX_4

Definition at line 56 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_SCL_GPIO_AF [2/2]

#define I2Cx_SCL_GPIO_AF GPIO_MUX_4

Definition at line 56 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_SCL_GPIO_CLK [1/2]

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 52 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_SCL_GPIO_CLK [2/2]

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 52 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_SCL_GPIO_PIN [1/2]

#define I2Cx_SCL_GPIO_PIN GPIO_PINS_6

Definition at line 53 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_SCL_GPIO_PIN [2/2]

#define I2Cx_SCL_GPIO_PIN GPIO_PINS_6

Definition at line 53 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_SCL_GPIO_PinsSource [1/2]

#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6

Definition at line 54 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_SCL_GPIO_PinsSource [2/2]

#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6

Definition at line 54 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_SCL_GPIO_PORT [1/2]

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 55 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_SCL_GPIO_PORT [2/2]

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 55 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_SDA_GPIO_AF [1/2]

#define I2Cx_SDA_GPIO_AF GPIO_MUX_4

Definition at line 62 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_SDA_GPIO_AF [2/2]

#define I2Cx_SDA_GPIO_AF GPIO_MUX_4

Definition at line 62 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_SDA_GPIO_CLK [1/2]

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 58 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_SDA_GPIO_CLK [2/2]

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 58 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_SDA_GPIO_PIN [1/2]

#define I2Cx_SDA_GPIO_PIN GPIO_PINS_7

Definition at line 59 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_SDA_GPIO_PIN [2/2]

#define I2Cx_SDA_GPIO_PIN GPIO_PINS_7

Definition at line 59 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_SDA_GPIO_PinsSource [1/2]

#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7

Definition at line 60 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_SDA_GPIO_PinsSource [2/2]

#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7

Definition at line 60 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_SDA_GPIO_PORT [1/2]

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 61 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ I2Cx_SDA_GPIO_PORT [2/2]

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 61 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ LCD_BL_HIGH [1/2]

#define LCD_BL_HIGH gpio_bits_set(GPIOC,GPIO_PINS_0)

Definition at line 81 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ LCD_BL_HIGH [2/2]

#define LCD_BL_HIGH gpio_bits_set(GPIOC,GPIO_PINS_0)

Definition at line 81 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ LCD_BL_LOW [1/2]

#define LCD_BL_LOW gpio_bits_reset(GPIOC,GPIO_PINS_0)

Definition at line 82 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ LCD_BL_LOW [2/2]

#define LCD_BL_LOW gpio_bits_reset(GPIOC,GPIO_PINS_0)

Definition at line 82 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ LCD_H [1/2]

#define LCD_H 240

Definition at line 79 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ LCD_H [2/2]

#define LCD_H 240

Definition at line 79 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ LCD_W [1/2]

#define LCD_W 320

Definition at line 78 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ LCD_W [2/2]

#define LCD_W 320

Definition at line 78 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ MAGENTA [1/2]

#define MAGENTA 0xF81F

Definition at line 91 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ MAGENTA [2/2]

#define MAGENTA 0xF81F

Definition at line 91 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ RED [1/2]

#define RED 0xF800

Definition at line 90 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ RED [2/2]

#define RED 0xF800

Definition at line 90 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ WHITE [1/2]

#define WHITE 0xFFFF

Definition at line 84 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ WHITE [2/2]

#define WHITE 0xFFFF

Definition at line 84 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ YELLOW [1/2]

#define YELLOW 0xFFE0

Definition at line 94 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ YELLOW [2/2]

#define YELLOW 0xFFE0

Definition at line 94 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c.

◆ dvp_config()

void dvp_config ( void )

configure dvp

Parameters
none
Return values
none

< capture frame done interrupt

< data fifo overrun interrupt

< embedded synchronization error interrupt

< vertical synchonization interrupt

< horizontal synchonization interrupt

< capture frame done interrupt

< data fifo overrun interrupt

< embedded synchronization error interrupt

< vertical synchonization interrupt

< horizontal synchonization interrupt

Definition at line 60 of file at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c.

◆ dvp_dma_init()

void dvp_dma_init | ( | uint32_t | mem0addr,
 |  | uint32_t | mem1addr,
 |  | uint16_t | memsize
 | ) |  |

initialize dma for dvp

Parameters
mem0addr | memory0 base address
mem1addr | memory1 base address
memsize | memory size
memblen | memory data width
meminc | memory increase
Return values
none

Definition at line 136 of file at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c.

◆ dvp_frame_done()

void dvp_frame_done ( void )

dvp frame transmit done

Parameters
none
Return values
none

Definition at line 212 of file at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c.

Referenced by dvp_int_handler().

◆ dvp_int_handler()

void dvp_int_handler ( void )

handles dvp interrupt request.

Parameters
none
Return values
none

< embedded synchronization error interrupt status flag

< embedded synchronization error interrupt status flag

< data fifo overrun interrupt status flag

< data fifo overrun interrupt status flag

< horizontal synchonization interrupt status flag

< horizontal synchonization interrupt status flag

< vertical synchonization interrupt status flag

< vertical synchonization interrupt status flag

< capture frame done interrupt status flag

< capture frame done interrupt status flag

< embedded synchronization error interrupt status flag

< embedded synchronization error interrupt status flag

< data fifo overrun interrupt status flag

< data fifo overrun interrupt status flag

< horizontal synchonization interrupt status flag

< horizontal synchonization interrupt status flag

< vertical synchonization interrupt status flag

< vertical synchonization interrupt status flag

< capture frame done interrupt status flag

< capture frame done interrupt status flag

Definition at line 236 of file at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c.

Referenced by DVP_IRQHandler().

◆ dvp_io_init()

void dvp_io_init ( void )

initialize gpio for dvp

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 6

< gpio pins number 9

< gpio pins number 10

< gpio pins number 11

< gpio pins number 12

< gpio pins number 4

< gpio pins number 7

< gpio pins number 9

< gpio pins number 4

< gpio pins number 5

< gpio pins number 4

< gpio pins number 6

< gpio pins number 9

< gpio pins number 10

< gpio pins number 11

< gpio pins number 12

< gpio pins number 4

< gpio pins number 7

< gpio pins number 9

< gpio pins number 4

< gpio pins number 5

Definition at line 92 of file at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c.

Referenced by dvp_config().

◆ DVP_IRQHandler()

void DVP_IRQHandler ( void )

dvp irq handler

Parameters
none
Return values
none

Definition at line 202 of file at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c.

◆ dvp_start()

void dvp_start ( void )

start dvp transmission

Parameters
none
Return values
none

Definition at line 176 of file at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c.

◆ dvp_stop()

void dvp_stop ( void )

stop dvp transmission

Parameters
none
Return values
none

Definition at line 188 of file at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c.

◆ EDMA_Stream4_IRQHandler()

void EDMA_Stream4_IRQHandler ( void )

edma stream4 irq handler

Parameters
none
Return values
none

Definition at line 223 of file at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c.

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
hi2c i2c_handle_type
Return values
none

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

Definition at line 645 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ jpeg_data_process()

void jpeg_data_process ( void )

◆ lcd_char_show()

void lcd_char_show | ( | uint16_t | x,
 |  | uint16_t | y,
 |  | uint8_t | num,
 |  | uint8_t | size,
 |  | uint8_t | mode
 | ) |  |

this function is show char to lcd

Parameters
x | : row coordinates starting vaule
y | : column coordinates starting vaule
num | : number of char
size | : size of char
mode | : color
Return values
none

Definition at line 400 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c.

Referenced by lcd_string_show().

◆ lcd_clear()

void lcd_clear ( uint16_t color )

this function is clear the lcd.

Parameters
data : the data to write.
Return values
none

Definition at line 379 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c.

◆ lcd_color_fill()

void lcd_color_fill | ( | uint16_t | sx,
 |  | uint16_t | sy,
 |  | uint16_t | ex,
 |  | uint16_t | ey,
 |  | uint16_t * | color
 | ) |  |

this function is fill in lcd with color-pointer

Parameters
sx | : row coordinates starting vaule
sy | : column coordinates starting vaule
ex | : row coordinates ending vaule
ey | : column coordinates ending vaule
color | : color-point for fill in lcd
Return values
none

Definition at line 529 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c.

◆ lcd_drawpoint()

void lcd_drawpoint | ( | uint16_t | x,
 |  | uint16_t | y,
 |  | uint16_t | color
 | ) |  |

this function is draw point to lcd.

Parameters
data : the data to write.
Return values
None

Definition at line 367 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c.

Referenced by lcd_char_show().

◆ lcd_fill()

void lcd_fill | ( | uint16_t | sx,
 |  | uint16_t | sy,
 |  | uint16_t | ex,
 |  | uint16_t | ey,
 |  | uint16_t | color
 | ) |  |

this function is fill in lcd with concolorous

Parameters
sx | : row coordinates starting vaule
sy | : column coordinates starting vaule
ex | : row coordinates ending vaule
ey | : column coordinates ending vaule
color | : color for fill in lcd
Return values
none

Definition at line 508 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c.

◆ lcd_init()

void lcd_init ( void )

configures the lcd. this function must be called before any write/read operation on the lcd.

Parameters
none
Return values
none

Definition at line 165 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c.

◆ lcd_rd_data()

uint16_t lcd_rd_data ( void )

Definition at line 315 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c.

Referenced by lcd_init().

◆ lcd_setblock()

void lcd_setblock | ( | uint16_t | xstart,
 |  | uint16_t | ystart,
 |  | uint16_t | xend,
 |  | uint16_t | yend
 | ) |  |

this function is set row&column coordinates for lcd.

Parameters
xstart | : row coordinates starting vaule.
ystart | : column coordinates starting vaule.
xend | : row coordinates ending vaule.
yend | : column coordinates ending vaule.
Return values
none

Definition at line 332 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c.

◆ lcd_string_show()

void lcd_string_show | ( | uint16_t | x,
 |  | uint16_t | y,
 |  | uint16_t | width,
 |  | uint16_t | height,
 |  | uint8_t | size,
 |  | uint8_t * | p
 | ) |  |

this function is show string to lcd

Parameters
x | : row coordinates starting vaule
y | : column coordinates starting vaule
width | : width of string
height | : height of string
p | : pointer of string
Return values
none

Definition at line 474 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c.

◆ lcd_wr_command()

void lcd_wr_command ( uint16_t command )

this function is write command to lcd.

Parameters
command : the command to write.
Return values
none

Definition at line 300 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c.

Referenced by lcd_init(), and lcd_setblock().

◆ lcd_wr_data()

void lcd_wr_data ( uint16_t data )

this function is write data to lcd.

Parameters
data : the data to write.
Return values
none

Definition at line 310 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c.

Referenced by lcd_init(), lcd_setblock(), and lcd_writeonepoint().

◆ lcd_writeonepoint()

void lcd_writeonepoint ( uint16_t color )

this function is write one point to lcd.

Parameters
data : the data to write.
Return values
none

Definition at line 357 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c.

Referenced by lcd_clear(), lcd_color_fill(), lcd_drawpoint(), and lcd_fill().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f435/examples/dvp/ov5640_capture/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c.

◆ ov5640_capture()

void ov5640_capture ( void )

Definition at line 85 of file project/at_start_f435/examples/dvp/ov5640_capture/src/main.c.

Referenced by main().

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c.

◆ xmc_init()

void xmc_init ( void )

configures the xmc and gpios to interface with the lcd. this function must be called before any write/read operation on the lcd.

Parameters
none
Return values
none

Definition at line 57 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c.

Variable Documentation

◆ asc2_1206 [1/2]

const unsigned char asc2_1206[95][12]

Definition at line 38 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/font.h.

◆ asc2_1206 [2/2]

const unsigned char asc2_1206[95][12]

Definition at line 38 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/font.h.

◆ asc2_1608 [1/2]

const unsigned char asc2_1608[95][16]

Definition at line 136 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/font.h.

◆ asc2_1608 [2/2]

const unsigned char asc2_1608[95][16]

Definition at line 136 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/font.h.

◆ asc2_2412 [1/2]

const unsigned char asc2_2412[95][36]

Definition at line 234 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/font.h.

◆ asc2_2412 [2/2]

const unsigned char asc2_2412[95][36]

Definition at line 234 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/font.h.

◆ asc2_3216 [1/2]

const unsigned char asc2_3216[95][128]

Definition at line 332 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/font.h.

◆ asc2_3216 [2/2]

const unsigned char asc2_3216[95][128]

Definition at line 332 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/font.h.

◆ edma_init_struct [1/4]

edma_init_type edma_init_struct

Definition at line 40 of file at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c.

Referenced by dvp_dma_init().

◆ edma_init_struct [2/4]

edma_init_type edma_init_struct
extern

Definition at line 40 of file at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c.

◆ edma_init_struct [3/4]

edma_init_type edma_init_struct

Definition at line 40 of file at_start_f437/examples/dvp/ov5640_capture/hardware/dvp/dvp.c.

◆ edma_init_struct [4/4]

edma_init_type edma_init_struct
extern

Definition at line 40 of file at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c.

Referenced by dvp_dma_init(), edma_config(), edma_default_para_init(), edma_init(), i2s_config(), and main().

◆ hi2cx [1/2]

i2c_handle_type hi2cx

Definition at line 64 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

Referenced by ov5640_i2c_init(), ov5640_reg_read(), and ov5640_reg_write().

◆ hi2cx [2/2]

i2c_handle_type hi2cx

Definition at line 64 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ lcd_dev_struct [1/4]

lcd_dev_type lcd_dev_struct
Initial value:
=
{
0,
xmc_init,
lcd_init,
lcd_setblock,
lcd_drawpoint,
lcd_clear,
}
lcd_setblock
void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd.
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c:332
lcd_init
void lcd_init(void)
configures the lcd. this function must be called before any write/read operation on the lcd.
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c:165
lcd_drawpoint
void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd.
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c:367
lcd_clear
void lcd_clear(uint16_t color)
this function is clear the lcd.
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c:379
xmc_init
void xmc_init(void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write...
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c:57

Definition at line 38 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c.

◆ lcd_dev_struct [2/4]

lcd_dev_type lcd_dev_struct
extern

Definition at line 38 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

◆ lcd_dev_struct [3/4]

lcd_dev_type lcd_dev_struct
Initial value:
=
{
0,
xmc_init,
lcd_init,
lcd_setblock,
lcd_drawpoint,
lcd_clear,
}
lcd_setblock
void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:332
lcd_init
void lcd_init(void)
configures the lcd. this function must be called before any write/read operation on the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:165
lcd_drawpoint
void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:367
lcd_clear
void lcd_clear(uint16_t color)
this function is clear the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:379
xmc_init
void xmc_init(void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write...
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:57

Definition at line 38 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c.

◆ lcd_dev_struct [4/4]

lcd_dev_type lcd_dev_struct
extern

Definition at line 38 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

◆ LCD_ID [1/2]

uint16_t LCD_ID
static

Definition at line 83 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ LCD_ID [2/2]

uint16_t LCD_ID
static

Definition at line 83 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.

◆ lcd_struct [1/4]

lcd_dev_type* lcd_struct

Definition at line 48 of file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c.

Referenced by lcd_clear(), lcd_color_fill(), lcd_drawpoint(), lcd_fill(), and lcd_init().

◆ lcd_struct [2/4]

lcd_dev_type* lcd_struct
extern

Definition at line 48 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

◆ lcd_struct [3/4]

lcd_dev_type* lcd_struct

Definition at line 48 of file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c.

◆ lcd_struct [4/4]

lcd_dev_type* lcd_struct
extern

Definition at line 48 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

◆ OV5640_AF_Config [1/2]

const unsigned char OV5640_AF_Config[]

Definition at line 38 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640af.h.

Referenced by ov5640_focus_init().

◆ OV5640_AF_Config [2/2]

const unsigned char OV5640_AF_Config[]

Definition at line 38 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640af.h.

◆ OV5640_EFFECTS_TBL [1/2]

const uint8_t OV5640_EFFECTS_TBL[7][3]
Initial value:
=
{
0x06, 0x40, 0x10,
0x1E, 0xA0, 0x40,
0x1E, 0x80, 0xC0,
0x1E, 0x80, 0x80,
0x1E, 0x40, 0xA0,
0x40, 0x40, 0x10,
0x1E, 0x60, 0x60,
}

Definition at line 98 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

Referenced by ov5640_special_effects().

◆ OV5640_EFFECTS_TBL [2/2]

const uint8_t OV5640_EFFECTS_TBL[7][3]
Initial value:
=
{
0x06, 0x40, 0x10,
0x1E, 0xA0, 0x40,
0x1E, 0x80, 0xC0,
0x1E, 0x80, 0x80,
0x1E, 0x40, 0xA0,
0x40, 0x40, 0x10,
0x1E, 0x60, 0x60,
}

Definition at line 98 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ OV5640_EXPOSURE_TBL [1/2]

const uint8_t OV5640_EXPOSURE_TBL[7][6]
Initial value:
=
{
0x10, 0x08, 0x10, 0x08, 0x20, 0x10,
0x20, 0x18, 0x41, 0x20, 0x18, 0x10,
0x30, 0x28, 0x61, 0x30, 0x28, 0x10,
0x38, 0x30, 0x61, 0x38, 0x30, 0x10,
0x40, 0x38, 0x71, 0x40, 0x38, 0x10,
0x50, 0x48, 0x90, 0x50, 0x48, 0x20,
0x60, 0x58, 0xa0, 0x60, 0x58, 0x20,
}

Definition at line 67 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

Referenced by ov5640_exposure().

◆ OV5640_EXPOSURE_TBL [2/2]

const uint8_t OV5640_EXPOSURE_TBL[7][6]
Initial value:
=
{
0x10, 0x08, 0x10, 0x08, 0x20, 0x10,
0x20, 0x18, 0x41, 0x20, 0x18, 0x10,
0x30, 0x28, 0x61, 0x30, 0x28, 0x10,
0x38, 0x30, 0x61, 0x38, 0x30, 0x10,
0x40, 0x38, 0x71, 0x40, 0x38, 0x10,
0x50, 0x48, 0x90, 0x50, 0x48, 0x20,
0x60, 0x58, 0xa0, 0x60, 0x58, 0x20,
}

Definition at line 67 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ OV5640_jpeg_reg_tbl [1/2]

const uint16_t OV5640_jpeg_reg_tbl[][2]

Definition at line 39 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h.

Referenced by ov5640_jpeg_mode().

◆ OV5640_jpeg_reg_tbl [2/2]

const uint16_t OV5640_jpeg_reg_tbl[][2]

Definition at line 39 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h.

◆ OV5640_LIGHTMODE_TBL [1/2]

const uint8_t OV5640_LIGHTMODE_TBL[5][7]
Initial value:
=
{
0x04, 0x00, 0x04, 0x00, 0x04, 0x00, 0x00,
0x06, 0x1C, 0x04, 0x00, 0x04, 0xF3, 0x01,
0x05, 0x48, 0x04, 0x00, 0x07, 0xCF, 0x01,
0x06, 0x48, 0x04, 0x00, 0x04, 0xD3, 0x01,
0x04, 0x10, 0x04, 0x00, 0x08, 0x40, 0x01,
}

Definition at line 78 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

Referenced by ov5640_light_mode().

◆ OV5640_LIGHTMODE_TBL [2/2]

const uint8_t OV5640_LIGHTMODE_TBL[5][7]
Initial value:
=
{
0x04, 0x00, 0x04, 0x00, 0x04, 0x00, 0x00,
0x06, 0x1C, 0x04, 0x00, 0x04, 0xF3, 0x01,
0x05, 0x48, 0x04, 0x00, 0x07, 0xCF, 0x01,
0x06, 0x48, 0x04, 0x00, 0x04, 0xD3, 0x01,
0x04, 0x10, 0x04, 0x00, 0x08, 0x40, 0x01,
}

Definition at line 78 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ ov5640_rgb565_reg_tbl [1/2]

const uint16_t ov5640_rgb565_reg_tbl[][2]

Definition at line 89 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h.

Referenced by ov5640_rgb565_mode().

◆ ov5640_rgb565_reg_tbl [2/2]

const uint16_t ov5640_rgb565_reg_tbl[][2]

Definition at line 89 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h.

◆ OV5640_SATURATION_TBL [1/2]

const uint8_t OV5640_SATURATION_TBL[7][6]
Initial value:
=
{
0x0C, 0x30, 0x3D, 0x3E, 0x3D, 0x01,
0x10, 0x3D, 0x4D, 0x4E, 0x4D, 0x01,
0x15, 0x52, 0x66, 0x68, 0x66, 0x02,
0x1A, 0x66, 0x80, 0x82, 0x80, 0x02,
0x1F, 0x7A, 0x9A, 0x9C, 0x9A, 0x02,
0x24, 0x8F, 0xB3, 0xB6, 0xB3, 0x03,
0x2B, 0xAB, 0xD6, 0xDA, 0xD6, 0x04,
}

Definition at line 87 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

Referenced by ov5640_color_saturation().

◆ OV5640_SATURATION_TBL [2/2]

const uint8_t OV5640_SATURATION_TBL[7][6]
Initial value:
=
{
0x0C, 0x30, 0x3D, 0x3E, 0x3D, 0x01,
0x10, 0x3D, 0x4D, 0x4E, 0x4D, 0x01,
0x15, 0x52, 0x66, 0x68, 0x66, 0x02,
0x1A, 0x66, 0x80, 0x82, 0x80, 0x02,
0x1F, 0x7A, 0x9A, 0x9C, 0x9A, 0x02,
0x24, 0x8F, 0xB3, 0xB6, 0xB3, 0x03,
0x2B, 0xAB, 0xD6, 0xDA, 0xD6, 0x04,
}

Definition at line 87 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ ov5640_uxga_init_reg_tbl [1/2]

const uint16_t ov5640_uxga_init_reg_tbl[][2]

Definition at line 154 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h.

Referenced by ov5640_init().

◆ ov5640_uxga_init_reg_tbl [2/2]

const uint16_t ov5640_uxga_init_reg_tbl[][2]

Definition at line 154 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h.

◆ ov_frame [1/2]

uint8_t ov_frame = 0

Definition at line 41 of file at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c.

Referenced by dvp_frame_done().

◆ ov_frame [2/2]

uint8_t ov_frame = 0

Definition at line 41 of file at_start_f437/examples/dvp/ov5640_capture/hardware/dvp/dvp.c.

◆ point_color [1/2]

uint16_t point_color

Definition at line 42 of file project/at_start_f435/examples/dvp/ov5640_capture/src/main.c.

Referenced by main().

◆ point_color [2/2]

uint16_t point_color

Definition at line 42 of file project/at_start_f437/examples/dvp/ov5640_capture/src/main.c.

◆ STA [1/2]

i2c_status_type STA

Definition at line 65 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

Referenced by ov5640_reg_write().

◆ STA [2/2]

i2c_status_type STA

Definition at line 65 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.


AT32F435/437 Firmwary Library: Ov5640_library_peripheral_info

Macros
Ov5640_library_peripheral_info
AT32F435_periph_examples | AT32F437_periph_examples » DVP_ov5640_capture

Macros

#define | LIGHT_SWITCH 0
#define | OV5640_RST_HIGH gpio_bits_set(GPIOC, GPIO_PINS_3);
#define | OV5640_RST_LOW gpio_bits_reset(GPIOC, GPIO_PINS_3);
#define | OV5640_ID ((uint16_t)0x5640)
#define | OV5640_ADDR ((uint16_t)0x0078)
#define | OV5640_CHIPIDH ((uint16_t)0x300A)
#define | OV5640_CHIPIDL ((uint16_t)0x300B)
#define | HARDWARE_MODE
#define | LIGHT_SWITCH 0
#define | OV5640_RST_HIGH gpio_bits_set(GPIOC, GPIO_PINS_3);
#define | OV5640_RST_LOW gpio_bits_reset(GPIOC, GPIO_PINS_3);
#define | OV5640_ID ((uint16_t)0x5640)
#define | OV5640_ADDR ((uint16_t)0x0078)
#define | OV5640_CHIPIDH ((uint16_t)0x300A)
#define | OV5640_CHIPIDL ((uint16_t)0x300B)
#define | HARDWARE_MODE

Detailed Description

Macro Definition Documentation

◆ HARDWARE_MODE [1/2]

#define HARDWARE_MODE

Definition at line 54 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h.

◆ HARDWARE_MODE [2/2]

#define HARDWARE_MODE

Definition at line 54 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h.

◆ LIGHT_SWITCH [1/2]

#define LIGHT_SWITCH 0

Definition at line 44 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h.

◆ LIGHT_SWITCH [2/2]

#define LIGHT_SWITCH 0

Definition at line 44 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h.

◆ OV5640_ADDR [1/2]

#define OV5640_ADDR ((uint16_t)0x0078)

ov5640 address

Definition at line 50 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h.

◆ OV5640_ADDR [2/2]

#define OV5640_ADDR ((uint16_t)0x0078)

ov5640 address

Definition at line 50 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h.

◆ OV5640_CHIPIDH [1/2]

#define OV5640_CHIPIDH ((uint16_t)0x300A)

ov5640 chip id high bits

Definition at line 51 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h.

◆ OV5640_CHIPIDH [2/2]

#define OV5640_CHIPIDH ((uint16_t)0x300A)

ov5640 chip id high bits

Definition at line 51 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h.

◆ OV5640_CHIPIDL [1/2]

#define OV5640_CHIPIDL ((uint16_t)0x300B)

ov5640 chip id low bits

Definition at line 52 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h.

◆ OV5640_CHIPIDL [2/2]

#define OV5640_CHIPIDL ((uint16_t)0x300B)

ov5640 chip id low bits

Definition at line 52 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h.

◆ OV5640_ID [1/2]

#define OV5640_ID ((uint16_t)0x5640)

ov5640 id

Definition at line 49 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h.

◆ OV5640_ID [2/2]

#define OV5640_ID ((uint16_t)0x5640)

ov5640 id

Definition at line 49 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h.

◆ OV5640_RST_HIGH [1/2]

#define OV5640_RST_HIGH gpio_bits_set(GPIOC, GPIO_PINS_3);

Definition at line 46 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h.

◆ OV5640_RST_HIGH [2/2]

#define OV5640_RST_HIGH gpio_bits_set(GPIOC, GPIO_PINS_3);

Definition at line 46 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h.

◆ OV5640_RST_LOW [1/2]

#define OV5640_RST_LOW gpio_bits_reset(GPIOC, GPIO_PINS_3);

Definition at line 47 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h.

◆ OV5640_RST_LOW [2/2]

#define OV5640_RST_LOW gpio_bits_reset(GPIOC, GPIO_PINS_3);

Definition at line 47 of file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h.


AT32F435/437 Firmwary Library: Ov5640_library_exported_functions

Functions
Ov5640_library_exported_functions
AT32F435_periph_examples | AT32F437_periph_examples » DVP_ov5640_capture

Functions

error_status | ov5640_reg_write (uint16_t reg, uint8_t data)
write register to ov5640 More...
error_status | ov5640_reg_read (uint16_t reg, uint8_t *val)
read register from ov5640 More...
error_status | ov5640_init (void)
initialize ov5640 More...
void | ov5640_jpeg_mode (void)
ov5640 jpeg mode configure More...
void | ov5640_rgb565_mode (void)
ov5640 rgb565 mode configure More...
void | ov5640_exposure (uint8_t exposure)
ov5640 exposure configure More...
void | ov5640_light_mode (uint8_t mode)
this function is draw point to lcd More...
void | ov5640_color_saturation (uint8_t sat)
ov5640 color saturation configure More...
void | ov5640_brightness (uint8_t bright)
ov5640 brightness configure More...
void | ov5640_contrast (uint8_t contrast)
ov5640 contrast configure More...
void | ov5640_sharpness (uint8_t sharp)
ov5640 sharpness configure More...
void | ov5640_special_effects (uint8_t eft)
ov5640 special effects configure More...
void | ov5640_flash_ctrl (uint8_t sw)
ov5640 flash control More...
void | ov5640_outsize_set (uint16_t offx, uint16_t offy, uint16_t width, uint16_t height)
ov5640 output size set More...
void | ov5640_imagewin_set (uint16_t offx, uint16_t offy, uint16_t width, uint16_t height)
ov5640 image window set More...
error_status | ov5640_focus_init (void)
initialize ov5640 focus function More...
error_status | ov5640_focus_single (void)
ov5640 focus single More...
error_status | ov5640_focus_constant (void)
ov5640 focus constant More...
void | ov5640_i2c_init (void)
ov5640 i2c initialize More...

Detailed Description

Function Documentation

◆ ov5640_brightness()

void ov5640_brightness ( uint8_t bright )

ov5640 brightness configure

Parameters
bright brightness value
Return values
none

Definition at line 312 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

Referenced by ov5640_capture().

◆ ov5640_color_saturation()

void ov5640_color_saturation ( uint8_t sat )

ov5640 color saturation configure

Parameters
sat color saturation value
Return values
none

Definition at line 288 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

Referenced by ov5640_capture().

◆ ov5640_contrast()

void ov5640_contrast ( uint8_t contrast )

ov5640 contrast configure

Parameters
contrast contrast value
Return values
none

Definition at line 346 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

Referenced by ov5640_capture().

◆ ov5640_exposure()

void ov5640_exposure ( uint8_t exposure )

ov5640 exposure configure

Parameters
exposure exposure value
Return values
none

Definition at line 246 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ ov5640_flash_ctrl()

void ov5640_flash_ctrl ( uint8_t sw )

ov5640 flash control

Parameters
sw switch on / switch off the flash
Return values
none

Definition at line 436 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

Referenced by ov5640_init().

◆ ov5640_focus_constant()

error_status ov5640_focus_constant ( void )

ov5640 focus constant

Parameters
none
Return values
error_status SUCCESS, ERROR

Definition at line 587 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

Referenced by ov5640_capture().

◆ ov5640_focus_init()

error_status ov5640_focus_init ( void )

initialize ov5640 focus function

Parameters
none
Return values
error_status SUCCESS, ERROR

Definition at line 510 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

Referenced by ov5640_capture().

◆ ov5640_focus_single()

error_status ov5640_focus_single ( void )

ov5640 focus single

Parameters
none
Return values
error_status SUCCESS, ERROR

Definition at line 555 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ ov5640_i2c_init()

void ov5640_i2c_init ( void )

ov5640 i2c initialize

Parameters
none
Return values
none

Definition at line 634 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

Referenced by ov5640_init().

◆ ov5640_imagewin_set()

void ov5640_imagewin_set | ( | uint16_t | offx,
 |  | uint16_t | offy,
 |  | uint16_t | width,
 |  | uint16_t | height
 | ) |  |

ov5640 image window set

Parameters
offx | image offset x
offy | image offset y
width | output width
height | output height
Return values
none

Definition at line 485 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ ov5640_init()

error_status ov5640_init ( void )

initialize ov5640

Parameters
none
Return values
error_status SUCCESS, ERROR

< gpio pins number 3

< gpio pins number 3

< gpio pins number 3

< ov5640 chip id high bits

< ov5640 chip id low bits

< ov5640 id

< gpio pins number 3

< gpio pins number 3

< gpio pins number 3

< ov5640 chip id high bits

< ov5640 chip id low bits

< ov5640 id

Definition at line 160 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

Referenced by main().

◆ ov5640_jpeg_mode()

void ov5640_jpeg_mode ( void )

ov5640 jpeg mode configure

Parameters
none
Return values
none

Definition at line 216 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

◆ ov5640_light_mode()

void ov5640_light_mode ( uint8_t mode )

this function is draw point to lcd

Parameters
mode : the light mode. 0:auto 1:sunny 2,office 3,cloudy 4,home
Return values
none

Definition at line 269 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

Referenced by ov5640_capture().

◆ ov5640_outsize_set()

void ov5640_outsize_set | ( | uint16_t | offx,
 |  | uint16_t | offy,
 |  | uint16_t | width,
 |  | uint16_t | height
 | ) |  |

ov5640 output size set

Parameters
offx | image offset x
offy | image offset y
width | output width
height | output height
Return values
none

Definition at line 459 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

Referenced by ov5640_capture().

◆ ov5640_reg_read()

error_status ov5640_reg_read | ( | uint16_t | reg,
 |  | uint8_t * | val
 | ) |  |

read register from ov5640

Parameters
reg | register read from ov5640
data | data read from ov5640
Return values
error_status SUCCESS, ERROR

< ov5640 address

< ov5640 address

< ov5640 address

< ov5640 address

Definition at line 136 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

Referenced by ov5640_capture(), ov5640_focus_constant(), ov5640_focus_init(), ov5640_focus_single(), and ov5640_init().

◆ ov5640_reg_write()

error_status ov5640_reg_write | ( | uint16_t | reg,
 |  | uint8_t | data
 | ) |  |

write register to ov5640

Parameters
reg | register write to ov5640
data | data write to ov5640
Return values
error_status SUCCESS, ERROR

< ov5640 address

< ov5640 address

Definition at line 115 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

Referenced by ov5640_brightness(), ov5640_color_saturation(), ov5640_contrast(), ov5640_exposure(), ov5640_flash_ctrl(), ov5640_focus_constant(), ov5640_focus_init(), ov5640_focus_single(), ov5640_imagewin_set(), ov5640_init(), ov5640_jpeg_mode(), ov5640_light_mode(), ov5640_outsize_set(), ov5640_rgb565_mode(), ov5640_sharpness(), and ov5640_special_effects().

◆ ov5640_rgb565_mode()

void ov5640_rgb565_mode ( void )

ov5640 rgb565 mode configure

Parameters
none
Return values
none

Definition at line 231 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

Referenced by ov5640_capture().

◆ ov5640_sharpness()

void ov5640_sharpness ( uint8_t sharp )

ov5640 sharpness configure

Parameters
sharp sharpness value
Return values
none

Definition at line 393 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.

Referenced by ov5640_capture().

◆ ov5640_special_effects()

void ov5640_special_effects ( uint8_t eft )

ov5640 special effects configure

Parameters
eft special effects value
Return values
none

Definition at line 420 of file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.


AT32F435/437 Firmwary Library: EDMA_continuous_mode

Functions | Variables
EDMA_continuous_mode
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...
void | TMR1_OVF_TMR10_IRQHandler (void)
this function handles timer1 overflow handler. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
edma_init_type edma_init_struct
uint32_t | duty_buffer [4] = {10,10,10,10}
gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
edma_init_type edma_init_struct
uint32_t | duty_buffer [4] = {10,10,10,10}

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 9

< gpio pins number 10

< gpio pins number 11

< tmr interrupt overflow

< gpio pins number 8

< gpio pins number 9

< gpio pins number 10

< gpio pins number 11

< tmr interrupt overflow

Definition at line 49 of file project/at_start_f435/examples/edma/burst_mode/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c.

◆ TMR1_OVF_TMR10_IRQHandler()

void TMR1_OVF_TMR10_IRQHandler ( void )

this function handles timer1 overflow handler.

Parameters
none
Return values
none

< tmr flag overflow

< tmr flag overflow

< tmr flag overflow

< tmr flag overflow

Definition at line 161 of file project/at_start_f435/examples/edma/burst_mode/src/main.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c.

Variable Documentation

◆ duty_buffer [1/2]

uint32_t duty_buffer[4] = {10,10,10,10}

Definition at line 42 of file project/at_start_f435/examples/edma/burst_mode/src/main.c.

Referenced by main(), and TMR1_OVF_TMR10_IRQHandler().

◆ duty_buffer [2/2]

uint32_t duty_buffer[4] = {10,10,10,10}

Definition at line 42 of file project/at_start_f437/examples/edma/burst_mode/src/main.c.

◆ edma_init_struct [1/2]

edma_init_type edma_init_struct

Definition at line 40 of file project/at_start_f435/examples/edma/burst_mode/src/main.c.

Referenced by main().

◆ edma_init_struct [2/2]

edma_init_type edma_init_struct

Definition at line 40 of file project/at_start_f437/examples/edma/burst_mode/src/main.c.

◆ gpio_init_struct [1/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f435/examples/edma/burst_mode/src/main.c.

Referenced by main().

◆ gpio_init_struct [2/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f437/examples/edma/burst_mode/src/main.c.

◆ tmr_output_struct [1/2]

tmr_output_config_type tmr_output_struct

Definition at line 39 of file project/at_start_f435/examples/edma/burst_mode/src/main.c.

Referenced by main(), tmr_output_channel_config(), and tmr_output_default_para_init().

◆ tmr_output_struct [2/2]

tmr_output_config_type tmr_output_struct

Definition at line 39 of file project/at_start_f437/examples/edma/burst_mode/src/main.c.


AT32F435/437 Firmwary Library: EDMA_dmamux_genertor_exint

Macros | Functions | Variables
EDMA_dmamux_genertor_exint
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | BUFFER_SIZE 16
#define | BUFFER_SIZE 16

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | EDMA_Stream4_IRQHandler (void)
this function handles edma stream4 handler. More...
void | EXINT1_IRQHandler (void)
exint1 interrupt handler More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
edma_init_type edma_init_struct
edmamux_gen_init_type dmamux_gen_init_struct
exint_init_type exint_init_struct
uint16_t | src_buffer [16]
uint16_t | dst_buffer [16]
gpio_init_type | gpio_init_struct = {0}
edma_init_type edma_init_struct
edmamux_gen_init_type dmamux_gen_init_struct
exint_init_type exint_init_struct
uint16_t | src_buffer [16]
uint16_t | dst_buffer [16]

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE [1/2]

#define BUFFER_SIZE 16

Definition at line 43 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c.

◆ BUFFER_SIZE [2/2]

#define BUFFER_SIZE 16

Definition at line 43 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c.

◆ EDMA_Stream4_IRQHandler()

void EDMA_Stream4_IRQHandler ( void )

this function handles edma stream4 handler.

Parameters
none
Return values
none

Definition at line 54 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c.

◆ EXINT1_IRQHandler()

void EXINT1_IRQHandler ( void )

exint1 interrupt handler

Parameters
none
Return values
none

< external interrupt line 1

< external interrupt line 1

< external interrupt line 1

< external interrupt line 1

Definition at line 71 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 1

< external interrupt line 1

< gpio pins number 1

< external interrupt line 1

Definition at line 84 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c.

Variable Documentation

◆ dmamux_gen_init_struct [1/2]

edmamux_gen_init_type dmamux_gen_init_struct

Definition at line 40 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c.

Referenced by main().

◆ dmamux_gen_init_struct [2/2]

edmamux_gen_init_type dmamux_gen_init_struct

Definition at line 40 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/src/main.c.

◆ dst_buffer [1/2]

uint16_t dst_buffer[16]

Definition at line 47 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c.

Referenced by main().

◆ dst_buffer [2/2]

uint16_t dst_buffer[16]

Definition at line 47 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/src/main.c.

◆ edma_init_struct [1/2]

edma_init_type edma_init_struct

Definition at line 39 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c.

Referenced by main().

◆ edma_init_struct [2/2]

edma_init_type edma_init_struct

Definition at line 39 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/src/main.c.

◆ exint_init_struct [1/2]

exint_init_type exint_init_struct

Definition at line 41 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c.

Referenced by main().

◆ exint_init_struct [2/2]

exint_init_type exint_init_struct

Definition at line 41 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/src/main.c.

◆ gpio_init_struct [1/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c.

Referenced by main().

◆ gpio_init_struct [2/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/src/main.c.

◆ src_buffer [1/2]

uint16_t src_buffer[16]
Initial value:
= {0x0001, 0x0002, 0x0003, 0x0004, 0x0005, 0x0006, 0x0007, 0x0008,
0x0009, 0x000a, 0x000b, 0x000c, 0x000d, 0x000e, 0x000f, 0x0010}

Definition at line 44 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c.

Referenced by main().

◆ src_buffer [2/2]

uint16_t src_buffer[16]
Initial value:
= {0x0001, 0x0002, 0x0003, 0x0004, 0x0005, 0x0006, 0x0007, 0x0008,
0x0009, 0x000a, 0x000b, 0x000c, 0x000d, 0x000e, 0x000f, 0x0010}

Definition at line 44 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/src/main.c.


AT32F435/437 Firmwary Library: EDMA_dmamux_synchronization_exint

Macros | Functions | Variables
EDMA_dmamux_synchronization_exint
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | BUFFER_SIZE 16
#define | BUFFER_SIZE 16

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | EDMA_Stream4_IRQHandler (void)
this function handles edma stream4 handler. More...
void | EXINT1_IRQHandler (void)
exint1 interrupt handler More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
edma_init_type edma_init_struct
edmamux_sync_init_type edmamux_sync_init_struct
exint_init_type exint_init_struct
uint16_t | src_buffer [16]
uint16_t | dst_buffer [16]
gpio_init_type | gpio_init_struct = {0}
edma_init_type edma_init_struct
edmamux_sync_init_type edmamux_sync_init_struct
exint_init_type exint_init_struct
uint16_t | src_buffer [16]
uint16_t | dst_buffer [16]

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE [1/2]

#define BUFFER_SIZE 16

Definition at line 42 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c.

◆ BUFFER_SIZE [2/2]

#define BUFFER_SIZE 16

Definition at line 42 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c.

◆ EDMA_Stream4_IRQHandler()

void EDMA_Stream4_IRQHandler ( void )

this function handles edma stream4 handler.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c.

◆ EXINT1_IRQHandler()

void EXINT1_IRQHandler ( void )

exint1 interrupt handler

Parameters
none
Return values
none

< external interrupt line 1

< external interrupt line 1

< external interrupt line 1

< external interrupt line 1

Definition at line 70 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 1

< external interrupt line 1

< gpio pins number 1

< external interrupt line 1

Definition at line 84 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c.

Variable Documentation

◆ dst_buffer [1/2]

uint16_t dst_buffer[16]

Definition at line 46 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c.

Referenced by main().

◆ dst_buffer [2/2]

uint16_t dst_buffer[16]

Definition at line 46 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/main.c.

◆ edma_init_struct [1/2]

edma_init_type edma_init_struct

Definition at line 39 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c.

Referenced by main().

◆ edma_init_struct [2/2]

edma_init_type edma_init_struct

Definition at line 39 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/main.c.

◆ edmamux_sync_init_struct [1/2]

edmamux_sync_init_type edmamux_sync_init_struct

Definition at line 40 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c.

Referenced by edmamux_sync_config(), edmamux_sync_default_para_init(), and main().

◆ edmamux_sync_init_struct [2/2]

edmamux_sync_init_type edmamux_sync_init_struct

Definition at line 40 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/main.c.

◆ exint_init_struct [1/2]

exint_init_type exint_init_struct

Definition at line 41 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c.

Referenced by main().

◆ exint_init_struct [2/2]

exint_init_type exint_init_struct

Definition at line 41 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/main.c.

◆ gpio_init_struct [1/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c.

Referenced by main().

◆ gpio_init_struct [2/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/main.c.

◆ src_buffer [1/2]

uint16_t src_buffer[16]
Initial value:
= {0x0001, 0x0002, 0x0003, 0x0004, 0x0005, 0x0006, 0x0007, 0x0008,
0x0009, 0x000a, 0x000b, 0x000c, 0x000d, 0x000e, 0x000f, 0x0010}

Definition at line 43 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c.

Referenced by main().

◆ src_buffer [2/2]

uint16_t src_buffer[16]
Initial value:
= {0x0001, 0x0002, 0x0003, 0x0004, 0x0005, 0x0006, 0x0007, 0x0008,
0x0009, 0x000a, 0x000b, 0x000c, 0x000d, 0x000e, 0x000f, 0x0010}

Definition at line 43 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/main.c.


AT32F435/437 Firmwary Library: EDMA_flash_to_sram

Macros | Functions | Variables
EDMA_flash_to_sram
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | BUFFER_SIZE 32
#define | BUFFER_SIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
error_status | buffer_compare (const uint32_t *pbuffer, uint32_t *pbuffer1, uint16_t buffer_length)
compares two buffers. More...
void | EDMA_Stream1_IRQHandler (void)
this function handles edma stream1 handler. More...
int | main (void)
main function. More...

Variables

const uint32_t | src_const_buffer [32]
uint32_t | dst_buffer [32]
edma_init_type edma_init_struct
__IO uint32_t | data_counter_end = 0x01
error_status transfer_status = ERROR
const uint32_t | src_const_buffer [32]
uint32_t | dst_buffer [32]
edma_init_type edma_init_struct
__IO uint32_t | data_counter_end = 0x01
error_status transfer_status = ERROR

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE [1/2]

#define BUFFER_SIZE 32

Definition at line 38 of file project/at_start_f435/examples/edma/flash_to_sram/src/main.c.

◆ BUFFER_SIZE [2/2]

#define BUFFER_SIZE 32

Definition at line 38 of file project/at_start_f437/examples/edma/flash_to_sram/src/main.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | const uint32_t * | pbuffer,
 |  | uint32_t * | pbuffer1,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer,pbuffer1 | buffers to be compared.
buffer_length | buffer's length
Return values
SUCCESS pbuffer identical to pbuffer1 ERROR: pbuffer differs from pbuffer1

Definition at line 76 of file project/at_start_f435/examples/edma/flash_to_sram/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c.

◆ EDMA_Stream1_IRQHandler()

void EDMA_Stream1_IRQHandler ( void )

this function handles edma stream1 handler.

Parameters
none
Return values
none

Definition at line 60 of file project/at_start_f435/examples/edma/flash_to_sram/src/main.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 97 of file project/at_start_f435/examples/edma/flash_to_sram/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c.

Variable Documentation

◆ data_counter_end [1/2]

__IO uint32_t data_counter_end = 0x01

Definition at line 50 of file project/at_start_f435/examples/edma/flash_to_sram/src/main.c.

Referenced by EDMA_Stream1_IRQHandler(), and main().

◆ data_counter_end [2/2]

__IO uint32_t data_counter_end = 0x01

Definition at line 50 of file project/at_start_f437/examples/edma/flash_to_sram/src/main.c.

◆ dst_buffer [1/2]

uint32_t dst_buffer[32]

Definition at line 48 of file project/at_start_f435/examples/edma/flash_to_sram/src/main.c.

Referenced by main().

◆ dst_buffer [2/2]

uint32_t dst_buffer[32]

Definition at line 48 of file project/at_start_f437/examples/edma/flash_to_sram/src/main.c.

◆ edma_init_struct [1/2]

edma_init_type edma_init_struct

Definition at line 49 of file project/at_start_f435/examples/edma/flash_to_sram/src/main.c.

Referenced by main().

◆ edma_init_struct [2/2]

edma_init_type edma_init_struct

Definition at line 49 of file project/at_start_f437/examples/edma/flash_to_sram/src/main.c.

◆ src_const_buffer [1/2]

const uint32_t src_const_buffer[32]
Initial value:
= {0x01020304, 0x05060708, 0x090A0B0C, 0x0D0E0F10,
0x11121314, 0x15161718, 0x191A1B1C, 0x1D1E1F20,
0x21222324, 0x25262728, 0x292A2B2C, 0x2D2E2F30,
0x31323334, 0x35363738, 0x393A3B3C, 0x3D3E3F40,
0x41424344, 0x45464748, 0x494A4B4C, 0x4D4E4F50,
0x51525354, 0x55565758, 0x595A5B5C, 0x5D5E5F60,
0x61626364, 0x65666768, 0x696A6B6C, 0x6D6E6F70,
0x71727374, 0x75767778, 0x797A7B7C, 0x7D7E7F80}

Definition at line 40 of file project/at_start_f435/examples/edma/flash_to_sram/src/main.c.

Referenced by main().

◆ src_const_buffer [2/2]

const uint32_t src_const_buffer[32]
Initial value:
= {0x01020304, 0x05060708, 0x090A0B0C, 0x0D0E0F10,
0x11121314, 0x15161718, 0x191A1B1C, 0x1D1E1F20,
0x21222324, 0x25262728, 0x292A2B2C, 0x2D2E2F30,
0x31323334, 0x35363738, 0x393A3B3C, 0x3D3E3F40,
0x41424344, 0x45464748, 0x494A4B4C, 0x4D4E4F50,
0x51525354, 0x55565758, 0x595A5B5C, 0x5D5E5F60,
0x61626364, 0x65666768, 0x696A6B6C, 0x6D6E6F70,
0x71727374, 0x75767778, 0x797A7B7C, 0x7D7E7F80}

Definition at line 40 of file project/at_start_f437/examples/edma/flash_to_sram/src/main.c.

◆ transfer_status [1/2]

error_status transfer_status = ERROR

Definition at line 51 of file project/at_start_f435/examples/edma/flash_to_sram/src/main.c.

Referenced by main().

◆ transfer_status [2/2]

error_status transfer_status = ERROR

Definition at line 51 of file project/at_start_f437/examples/edma/flash_to_sram/src/main.c.


AT32F435/437 Firmwary Library: EDMA_i2s_halfduplex_edma_doublebuffer

Functions | Variables
EDMA_i2s_halfduplex_edma_doublebuffer
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | i2s_config (void)
i2s configuration. More...
void | EDMA_Stream1_IRQHandler (void)
this function handles edma stream1 handler. More...
int | main (void)
main function. More...

Variables

uint16_t | i2s3_buffer1_tx [32]
uint16_t | i2s3_buffer2_tx [32]
uint16_t | i2s2_buffer1_rx [32]
uint16_t | i2s2_buffer2_rx [32]
volatile int | transfer_count = 0
uint16_t | i2s3_buffer1_tx [32]
uint16_t | i2s3_buffer2_tx [32]
uint16_t | i2s2_buffer1_rx [32]
uint16_t | i2s2_buffer2_rx [32]
volatile int | transfer_count = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c.

◆ EDMA_Stream1_IRQHandler()

void EDMA_Stream1_IRQHandler ( void )

this function handles edma stream1 handler.

Parameters
none
Return values
none

Definition at line 83 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 10

< gpio pins number 12

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

< gpio pins number 4

Definition at line 211 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c.

◆ i2s_config()

static void i2s_config ( void )
static

i2s configuration.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c.

Referenced by main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 269 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c.

Variable Documentation

◆ i2s2_buffer1_rx [1/2]

uint16_t i2s2_buffer1_rx[32]

Definition at line 50 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c.

Referenced by EDMA_Stream1_IRQHandler(), and i2s_config().

◆ i2s2_buffer1_rx [2/2]

uint16_t i2s2_buffer1_rx[32]

Definition at line 50 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c.

Referenced by i2s_config().

◆ i2s2_buffer2_rx [1/2]

uint16_t i2s2_buffer2_rx[32]

Definition at line 51 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c.

Referenced by EDMA_Stream1_IRQHandler(), and i2s_config().

◆ i2s2_buffer2_rx [2/2]

uint16_t i2s2_buffer2_rx[32]

Definition at line 51 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c.

Referenced by i2s_config().

◆ i2s3_buffer1_tx [1/2]

uint16_t i2s3_buffer1_tx[32]
Initial value:
= {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C,
0x0D0E, 0x0F10, 0x1112, 0x1314, 0x1516, 0x1718,
0x191A, 0x1B1C, 0x1D1E, 0x1F20, 0x2122, 0x2324,
0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C,
0x3D3E, 0x3F40}

Definition at line 38 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c.

Referenced by EDMA_Stream1_IRQHandler(), and i2s_config().

◆ i2s3_buffer1_tx [2/2]

uint16_t i2s3_buffer1_tx[32]
Initial value:
= {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C,
0x0D0E, 0x0F10, 0x1112, 0x1314, 0x1516, 0x1718,
0x191A, 0x1B1C, 0x1D1E, 0x1F20, 0x2122, 0x2324,
0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C,
0x3D3E, 0x3F40}

Definition at line 38 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c.

Referenced by i2s_config().

◆ i2s3_buffer2_tx [1/2]

uint16_t i2s3_buffer2_tx[32]
Initial value:
= {0x4142, 0x4344, 0x4546, 0x4748, 0x494A, 0x4B4C,
0x4D4E, 0x4F50, 0x5152, 0x5354, 0x5556, 0x5758,
0x595A, 0x5B5C, 0x5D5E, 0x5F60, 0x6162, 0x6364,
0x6566, 0x6768, 0x696A, 0x6B6C, 0x6D6E, 0x6F70,
0x7172, 0x7374, 0x7576, 0x7778, 0x797A, 0x7B7C,
0x7D7E, 0x7F80}

Definition at line 44 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c.

Referenced by EDMA_Stream1_IRQHandler(), and i2s_config().

◆ i2s3_buffer2_tx [2/2]

uint16_t i2s3_buffer2_tx[32]
Initial value:
= {0x4142, 0x4344, 0x4546, 0x4748, 0x494A, 0x4B4C,
0x4D4E, 0x4F50, 0x5152, 0x5354, 0x5556, 0x5758,
0x595A, 0x5B5C, 0x5D5E, 0x5F60, 0x6162, 0x6364,
0x6566, 0x6768, 0x696A, 0x6B6C, 0x6D6E, 0x6F70,
0x7172, 0x7374, 0x7576, 0x7778, 0x797A, 0x7B7C,
0x7D7E, 0x7F80}

Definition at line 44 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c.

Referenced by i2s_config().

◆ transfer_count [1/2]

volatile int transfer_count = 0

Definition at line 52 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c.

Referenced by EDMA_Stream1_IRQHandler().

◆ transfer_count [2/2]

volatile int transfer_count = 0

Definition at line 52 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c.


AT32F435/437 Firmwary Library: EDMA_link_list_mode

Data Structures | Macros | Functions | Variables
EDMA_link_list_mode
AT32F435_periph_examples | AT32F437_periph_examples

Data Structures

struct ll_descriptors_type

Macros

#define | LIST_COUNT 3
#define | BUFFER_SIZE 35
#define | LIST_COUNT 3
#define | BUFFER_SIZE 35

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
__ALIGNED (16)
edma link list descriptor init function. More...
int | main (void)
main function. More...
void | EDMA_Stream1_IRQHandler (void)
this function handles edma stream1 handler. More...

Variables

const int8_t | tx_buffer [3][35]
const int8_t | tx_buffer [3][35]

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE [1/2]

#define BUFFER_SIZE 35

Definition at line 39 of file project/at_start_f435/examples/edma/link_list_mode/src/main.c.

◆ BUFFER_SIZE [2/2]

#define BUFFER_SIZE 35

Definition at line 39 of file project/at_start_f437/examples/edma/link_list_mode/src/main.c.

◆ LIST_COUNT [1/2]

#define LIST_COUNT 3

Definition at line 38 of file project/at_start_f435/examples/edma/link_list_mode/src/main.c.

◆ LIST_COUNT [2/2]

#define LIST_COUNT 3

Definition at line 38 of file project/at_start_f437/examples/edma/link_list_mode/src/main.c.

Function Documentation

◆ __ALIGNED()

__ALIGNED ( 16 )

edma link list descriptor init function.

Parameters
none
Return values
none

Definition at line 58 of file project/at_start_f435/examples/edma/link_list_mode/src/main.c.

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c.

◆ EDMA_Stream1_IRQHandler()

void EDMA_Stream1_IRQHandler ( void )

this function handles edma stream1 handler.

Parameters
none
Return values
none

Definition at line 177 of file project/at_start_f435/examples/edma/link_list_mode/src/main.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f435/examples/edma/link_list_mode/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c.

Variable Documentation

◆ tx_buffer [1/2]

const int8_t tx_buffer[3][35]
Initial value:
={
{'T','h','i','s',' ','i','s',' ','E','D','M','A',' '},
{'L','i','n','k',' ','L','i','s','t',' ','M','o','d','e',' ','t','e','s','t','!'},
{'\r','\n','T','h','i','s',' ','t','e','s','t',' ','c','a','s','e',' ','u','s','e',' ','U','s','a','r','t','1','_','T','X','!','\r','\n'}
}

Definition at line 51 of file project/at_start_f435/examples/edma/link_list_mode/src/main.c.

Referenced by __ALIGNED().

◆ tx_buffer [2/2]

const int8_t tx_buffer[3][35]
Initial value:
={
{'T','h','i','s',' ','i','s',' ','E','D','M','A',' '},
{'L','i','n','k',' ','L','i','s','t',' ','M','o','d','e',' ','t','e','s','t','!'},
{'\r','\n','T','h','i','s',' ','t','e','s','t',' ','c','a','s','e',' ','u','s','e',' ','U','s','a','r','t','1','_','T','X','!','\r','\n'}
}

Definition at line 51 of file project/at_start_f437/examples/edma/link_list_mode/src/main.c.


AT32F435/437 Firmwary Library: ll_descriptors_type Struct Reference

Data Fields
ll_descriptors_type Struct Reference
AT32F435_periph_examples | AT32F437_periph_examples » EDMA_link_list_mode

Data Fields

uint32_t | ctrl_dtcnt
uint32_t | paddr
uint32_t | m0addr
uint32_t | llp

Detailed Description

Definition at line 42 of file project/at_start_f435/examples/edma/link_list_mode/src/main.c.

Field Documentation

◆ ctrl_dtcnt

uint32_t ll_descriptors_type::ctrl_dtcnt

Definition at line 44 of file project/at_start_f435/examples/edma/link_list_mode/src/main.c.

◆ llp

uint32_t ll_descriptors_type::llp

Definition at line 47 of file project/at_start_f435/examples/edma/link_list_mode/src/main.c.

◆ m0addr

uint32_t ll_descriptors_type::m0addr

Definition at line 46 of file project/at_start_f435/examples/edma/link_list_mode/src/main.c.

◆ paddr

uint32_t ll_descriptors_type::paddr

Definition at line 45 of file project/at_start_f435/examples/edma/link_list_mode/src/main.c.

The documentation for this struct was generated from the following files:
  • project/at_start_f435/examples/edma/link_list_mode/src/main.c
  • project/at_start_f437/examples/edma/link_list_mode/src/main.c


AT32F435/437 Firmwary Library: EDMA_two_dimension_mode

Macros | Functions | Variables
EDMA_two_dimension_mode
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | BUFFER_SIZE 32
#define | BUFFER_SIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | EDMA_Stream1_IRQHandler (void)
this function handles edma stream1 handler. More...
int | main (void)
main function. More...

Variables

const uint32_t | src_const_buffer [32]
uint32_t | dst_buffer [32]
edma_init_type edma_init_struct
__IO uint32_t | data_counter_end = 0x01
error_status transfer_status = ERROR
uint16_t | counter = 0
const uint32_t | src_const_buffer [32]
uint32_t | dst_buffer [32]
edma_init_type edma_init_struct
__IO uint32_t | data_counter_end = 0x01
error_status transfer_status = ERROR
uint16_t | counter = 0

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE [1/2]

#define BUFFER_SIZE 32

Definition at line 38 of file project/at_start_f435/examples/edma/two_dimension_mode/src/main.c.

◆ BUFFER_SIZE [2/2]

#define BUFFER_SIZE 32

Definition at line 38 of file project/at_start_f437/examples/edma/two_dimension_mode/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c.

◆ EDMA_Stream1_IRQHandler()

void EDMA_Stream1_IRQHandler ( void )

this function handles edma stream1 handler.

Parameters
none
Return values
none

Definition at line 60 of file project/at_start_f435/examples/edma/two_dimension_mode/src/main.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 74 of file project/at_start_f435/examples/edma/two_dimension_mode/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c.

Variable Documentation

◆ counter [1/2]

uint16_t counter = 0

Definition at line 52 of file project/at_start_f435/examples/edma/two_dimension_mode/src/main.c.

Referenced by main().

◆ counter [2/2]

uint16_t counter = 0

Definition at line 52 of file project/at_start_f437/examples/edma/two_dimension_mode/src/main.c.

◆ data_counter_end [1/2]

__IO uint32_t data_counter_end = 0x01

Definition at line 50 of file project/at_start_f435/examples/edma/two_dimension_mode/src/main.c.

Referenced by EDMA_Stream1_IRQHandler(), and main().

◆ data_counter_end [2/2]

__IO uint32_t data_counter_end = 0x01

Definition at line 50 of file project/at_start_f437/examples/edma/two_dimension_mode/src/main.c.

Referenced by DMA1_Channel1_IRQHandler().

◆ dst_buffer [1/2]

uint32_t dst_buffer[32]

Definition at line 48 of file project/at_start_f435/examples/edma/two_dimension_mode/src/main.c.

Referenced by main().

◆ dst_buffer [2/2]

uint32_t dst_buffer[32]

Definition at line 48 of file project/at_start_f437/examples/edma/two_dimension_mode/src/main.c.

◆ edma_init_struct [1/2]

edma_init_type edma_init_struct

Definition at line 49 of file project/at_start_f435/examples/edma/two_dimension_mode/src/main.c.

Referenced by main().

◆ edma_init_struct [2/2]

edma_init_type edma_init_struct

Definition at line 49 of file project/at_start_f437/examples/edma/two_dimension_mode/src/main.c.

◆ src_const_buffer [1/2]

const uint32_t src_const_buffer[32]
Initial value:
= {0x01020304, 0x05060708, 0x090A0B0C, 0x0D0E0F10,
0x11121314, 0x15161718, 0x191A1B1C, 0x1D1E1F20,
0x21222324, 0x25262728, 0x292A2B2C, 0x2D2E2F30,
0x31323334, 0x35363738, 0x393A3B3C, 0x3D3E3F40,
0x41424344, 0x45464748, 0x494A4B4C, 0x4D4E4F50,
0x51525354, 0x55565758, 0x595A5B5C, 0x5D5E5F60,
0x61626364, 0x65666768, 0x696A6B6C, 0x6D6E6F70,
0x71727374, 0x75767778, 0x797A7B7C, 0x7D7E7F80}

Definition at line 40 of file project/at_start_f435/examples/edma/two_dimension_mode/src/main.c.

Referenced by main().

◆ src_const_buffer [2/2]

const uint32_t src_const_buffer[32]
Initial value:
= {0x01020304, 0x05060708, 0x090A0B0C, 0x0D0E0F10,
0x11121314, 0x15161718, 0x191A1B1C, 0x1D1E1F20,
0x21222324, 0x25262728, 0x292A2B2C, 0x2D2E2F30,
0x31323334, 0x35363738, 0x393A3B3C, 0x3D3E3F40,
0x41424344, 0x45464748, 0x494A4B4C, 0x4D4E4F50,
0x51525354, 0x55565758, 0x595A5B5C, 0x5D5E5F60,
0x61626364, 0x65666768, 0x696A6B6C, 0x6D6E6F70,
0x71727374, 0x75767778, 0x797A7B7C, 0x7D7E7F80}

Definition at line 40 of file project/at_start_f437/examples/edma/two_dimension_mode/src/main.c.

◆ transfer_status [1/2]

error_status transfer_status = ERROR

Definition at line 51 of file project/at_start_f435/examples/edma/two_dimension_mode/src/main.c.

◆ transfer_status [2/2]

error_status transfer_status = ERROR

Definition at line 51 of file project/at_start_f437/examples/edma/two_dimension_mode/src/main.c.


AT32F435/437 Firmwary Library: ERTC_bpr_domain

Macros | Functions | Variables
ERTC_bpr_domain
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | ERTC_BPR_DT_NUMBER 20
#define | ERTC_BPR_DT_NUMBER 20

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

ertc_dt_type | bpr_addr_tab [20]
ertc_dt_type | bpr_addr_tab [20]

Detailed Description

Macro Definition Documentation

◆ ERTC_BPR_DT_NUMBER [1/2]

#define ERTC_BPR_DT_NUMBER 20

Definition at line 38 of file project/at_start_f435/examples/ertc/bpr_domain/src/main.c.

◆ ERTC_BPR_DT_NUMBER [2/2]

#define ERTC_BPR_DT_NUMBER 20

Definition at line 38 of file project/at_start_f437/examples/ertc/bpr_domain/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 57 of file project/at_start_f435/examples/ertc/bpr_domain/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c.

Variable Documentation

◆ bpr_addr_tab [1/2]

ertc_dt_type bpr_addr_tab[20]
Initial value:
=
{
ERTC_DT1, ERTC_DT2, ERTC_DT3, ERTC_DT4, ERTC_DT5,
ERTC_DT6, ERTC_DT7, ERTC_DT8, ERTC_DT9, ERTC_DT10,
ERTC_DT11, ERTC_DT12, ERTC_DT13, ERTC_DT14, ERTC_DT15,
ERTC_DT16, ERTC_DT17, ERTC_DT18, ERTC_DT19, ERTC_DT20
}
ERTC_DT11
@ ERTC_DT11
Definition: at32f435_437_ertc.h:367
ERTC_DT13
@ ERTC_DT13
Definition: at32f435_437_ertc.h:369
ERTC_DT2
@ ERTC_DT2
Definition: at32f435_437_ertc.h:358
ERTC_DT1
@ ERTC_DT1
Definition: at32f435_437_ertc.h:357
ERTC_DT15
@ ERTC_DT15
Definition: at32f435_437_ertc.h:371
ERTC_DT18
@ ERTC_DT18
Definition: at32f435_437_ertc.h:374
ERTC_DT19
@ ERTC_DT19
Definition: at32f435_437_ertc.h:375
ERTC_DT6
@ ERTC_DT6
Definition: at32f435_437_ertc.h:362
ERTC_DT7
@ ERTC_DT7
Definition: at32f435_437_ertc.h:363
ERTC_DT20
@ ERTC_DT20
Definition: at32f435_437_ertc.h:376
ERTC_DT17
@ ERTC_DT17
Definition: at32f435_437_ertc.h:373
ERTC_DT3
@ ERTC_DT3
Definition: at32f435_437_ertc.h:359
ERTC_DT4
@ ERTC_DT4
Definition: at32f435_437_ertc.h:360
ERTC_DT8
@ ERTC_DT8
Definition: at32f435_437_ertc.h:364
ERTC_DT5
@ ERTC_DT5
Definition: at32f435_437_ertc.h:361
ERTC_DT10
@ ERTC_DT10
Definition: at32f435_437_ertc.h:366
ERTC_DT9
@ ERTC_DT9
Definition: at32f435_437_ertc.h:365
ERTC_DT16
@ ERTC_DT16
Definition: at32f435_437_ertc.h:372
ERTC_DT12
@ ERTC_DT12
Definition: at32f435_437_ertc.h:368
ERTC_DT14
@ ERTC_DT14
Definition: at32f435_437_ertc.h:370

Definition at line 40 of file project/at_start_f435/examples/ertc/bpr_domain/src/main.c.

Referenced by bpr_reg_check(), and bpr_reg_write().

◆ bpr_addr_tab [2/2]

ertc_dt_type bpr_addr_tab[20]
Initial value:
=
{
ERTC_DT1, ERTC_DT2, ERTC_DT3, ERTC_DT4, ERTC_DT5,
ERTC_DT6, ERTC_DT7, ERTC_DT8, ERTC_DT9, ERTC_DT10,
ERTC_DT11, ERTC_DT12, ERTC_DT13, ERTC_DT14, ERTC_DT15,
ERTC_DT16, ERTC_DT17, ERTC_DT18, ERTC_DT19, ERTC_DT20
}

Definition at line 40 of file project/at_start_f437/examples/ertc/bpr_domain/src/main.c.


AT32F435/437 Firmwary Library: ERTC_calendar

Macros | Functions | Variables
ERTC_calendar
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | ERTC_CLOCK_SOURCE_LEXT /* select lext as the ertc clock */
#define | ERTC_CLOCK_SOURCE_LEXT /* select lext as the ertc clock */

Functions

void | ertc_alarm_show (void)
display the current alarm. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ERTCAlarm_IRQHandler (void)
this function handles ertc alarms interrupt request. More...
void | ertc_config (void)
configure the ertc peripheral by selecting the clock source. More...
int | main (void)
main program More...

Variables

__IO uint16_t | ertc_clk_div_a = 0
__IO uint16_t | ertc_clk_div_b = 0
__IO uint16_t | ertc_clk_div_a = 0
__IO uint16_t | ertc_clk_div_b = 0

Detailed Description

Macro Definition Documentation

◆ ERTC_CLOCK_SOURCE_LEXT [1/2]

#define ERTC_CLOCK_SOURCE_LEXT /* select lext as the ertc clock */

Definition at line 39 of file project/at_start_f435/examples/ertc/calendar/src/main.c.

◆ ERTC_CLOCK_SOURCE_LEXT [2/2]

#define ERTC_CLOCK_SOURCE_LEXT /* select lext as the ertc clock */

Definition at line 39 of file project/at_start_f437/examples/ertc/calendar/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c.

◆ ertc_alarm_show()

void ertc_alarm_show ( void )

display the current alarm.

Parameters
none
Return values
none

Definition at line 247 of file project/at_start_f435/examples/ertc/calendar/src/main.c.

Referenced by ERTCAlarm_IRQHandler(), and main().

◆ ertc_config()

void ertc_config ( void )

configure the ertc peripheral by selecting the clock source.

Parameters
none
Return values
none

< low speed external crystal stable flag

< ertc alarm don't match date or week

< ertc alarm a interrupt

< ertc alarm clock a flag

< low speed external crystal stable flag

< ertc alarm don't match date or week

< ertc alarm a interrupt

< ertc alarm clock a flag

Definition at line 141 of file project/at_start_f435/examples/ertc/calendar/src/main.c.

Referenced by main().

◆ ERTCAlarm_IRQHandler()

void ERTCAlarm_IRQHandler ( void )

this function handles ertc alarms interrupt request.

Parameters
none
Return values
none

< ertc alarm clock a flag

< ertc alarm clock a flag

< external interrupt line 17

< ertc alarm clock a flag

< ertc alarm clock a flag

< external interrupt line 17

Definition at line 143 of file project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c.

◆ main()

int main ( void )

main program

Parameters
none
Return values
none

< ertc alarm clock a flag

< external interrupt line 17

< external interrupt line 17

< ertc alarm clock a flag

< external interrupt line 17

< external interrupt line 17

Definition at line 54 of file project/at_start_f435/examples/ertc/calendar/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c.

Variable Documentation

◆ ertc_clk_div_a [1/2]

__IO uint16_t ertc_clk_div_a = 0

Definition at line 42 of file project/at_start_f435/examples/ertc/calendar/src/main.c.

Referenced by ertc_config().

◆ ertc_clk_div_a [2/2]

__IO uint16_t ertc_clk_div_a = 0

Definition at line 42 of file project/at_start_f437/examples/ertc/calendar/src/main.c.

◆ ertc_clk_div_b [1/2]

__IO uint16_t ertc_clk_div_b = 0

Definition at line 43 of file project/at_start_f435/examples/ertc/calendar/src/main.c.

Referenced by ertc_config().

◆ ertc_clk_div_b [2/2]

__IO uint16_t ertc_clk_div_b = 0

Definition at line 43 of file project/at_start_f437/examples/ertc/calendar/src/main.c.


AT32F435/437 Firmwary Library: ERTC_lick_calibration

Functions | Variables
ERTC_lick_calibration
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR5_GLOBAL_IRQHandler (void)
this function handles tmr5 global interrupt request. More...
void | ertc_config (void)
configures the ertc peripheral by selecting the clock source. More...
uint32_t | lick_frequency_get (void)
configures tmr5 to measure the lick oscillator frequency. More...
int | main (void)
main program More...

Variables

__IO uint32_t | period_value
__IO uint32_t | capture_number
uint16_t | tmp_c4 [2] = {0, 0}
__IO uint32_t | lick_freq = 0
__IO uint32_t | capture_number = 0
__IO uint32_t | period_value = 0
__IO uint32_t | period_value
__IO uint32_t | capture_number
uint16_t | tmp_c4 [2] = {0, 0}
__IO uint32_t | lick_freq = 0
__IO uint32_t | capture_number = 0
__IO uint32_t | period_value = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 83 of file project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 118 of file project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c.

◆ ertc_config()

void ertc_config ( void )

configures the ertc peripheral by selecting the clock source.

Parameters
none
Return values
none

< low speed internal clock stable flag

< low speed internal clock stable flag

Definition at line 105 of file project/at_start_f435/examples/ertc/lick_calibration/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 57 of file project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c.

◆ lick_frequency_get()

uint32_t lick_frequency_get ( void )

configures tmr5 to measure the lick oscillator frequency.

Parameters
none
Return values
lick frequency

< tmr interrupt channel 4

< tmr interrupt channel 4

Definition at line 155 of file project/at_start_f435/examples/ertc/lick_calibration/src/main.c.

Referenced by main().

◆ main()

int main ( void )

main program

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f435/examples/ertc/lick_calibration/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 48 of file project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 127 of file project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 109 of file project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 136 of file project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c.

◆ TMR5_GLOBAL_IRQHandler()

void TMR5_GLOBAL_IRQHandler ( void )

this function handles tmr5 global interrupt request.

Parameters
none
Return values
none

< tmr flag channel 4

< tmr flag channel 4

< tmr flag channel 4

< tmr flag channel 4

Definition at line 145 of file project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 96 of file project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c.

Variable Documentation

◆ capture_number [1/4]

__IO uint32_t capture_number
extern

Definition at line 39 of file project/at_start_f435/examples/ertc/lick_calibration/src/main.c.

Referenced by TMR5_GLOBAL_IRQHandler().

◆ capture_number [2/4]

__IO uint32_t capture_number = 0

Definition at line 39 of file project/at_start_f435/examples/ertc/lick_calibration/src/main.c.

Referenced by lick_frequency_get().

◆ capture_number [3/4]

__IO uint32_t capture_number
extern

Definition at line 39 of file project/at_start_f435/examples/ertc/lick_calibration/src/main.c.

Referenced by lick_frequency_get().

◆ capture_number [4/4]

__IO uint32_t capture_number = 0

Definition at line 39 of file project/at_start_f437/examples/ertc/lick_calibration/src/main.c.

Referenced by TMR5_GLOBAL_IRQHandler().

◆ lick_freq [1/2]

__IO uint32_t lick_freq = 0

Definition at line 38 of file project/at_start_f435/examples/ertc/lick_calibration/src/main.c.

Referenced by main().

◆ lick_freq [2/2]

__IO uint32_t lick_freq = 0

Definition at line 38 of file project/at_start_f437/examples/ertc/lick_calibration/src/main.c.

◆ period_value [1/4]

__IO uint32_t period_value
extern

Definition at line 40 of file project/at_start_f435/examples/ertc/lick_calibration/src/main.c.

Referenced by TMR5_GLOBAL_IRQHandler().

◆ period_value [2/4]

__IO uint32_t period_value = 0

Definition at line 40 of file project/at_start_f435/examples/ertc/lick_calibration/src/main.c.

Referenced by lick_frequency_get().

◆ period_value [3/4]

__IO uint32_t period_value
extern

Definition at line 40 of file project/at_start_f435/examples/ertc/lick_calibration/src/main.c.

Referenced by lick_frequency_get().

◆ period_value [4/4]

__IO uint32_t period_value = 0

Definition at line 40 of file project/at_start_f437/examples/ertc/lick_calibration/src/main.c.

Referenced by TMR5_GLOBAL_IRQHandler().

◆ tmp_c4 [1/2]

uint16_t tmp_c4[2] = {0, 0}

Definition at line 41 of file project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c.

Referenced by TMR5_GLOBAL_IRQHandler().

◆ tmp_c4 [2/2]

uint16_t tmp_c4[2] = {0, 0}

Definition at line 41 of file project/at_start_f437/examples/ertc/lick_calibration/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: ERTC_tamper

Macros | Functions | Variables
ERTC_tamper
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | ERTC_BPR_DT_NUMBER 20
#define | ERTC_BPR_DT_NUMBER 20

Functions

uint32_t | is_bpr_reg_reset (void)
checks if the ertc bpr dtx registers are reset or not. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TAMP_STAMP_IRQHandler (void)
this function handles ertc tamper and time stamp interrupts requests. More...
void | ertc_config (void)
configure the ertc peripheral by selecting the clock source. More...
void | bpr_reg_write (void)
write data to bpr dt register. More...
uint32_t | bpr_reg_check (void)
checks if the bpr dt register values are correct or not. More...
int | main (void)
main program More...

Variables

ertc_dt_type | bpr_addr_tab [20]
ertc_dt_type | bpr_addr_tab [20]

Detailed Description

Macro Definition Documentation

◆ ERTC_BPR_DT_NUMBER [1/2]

#define ERTC_BPR_DT_NUMBER 20

Definition at line 38 of file project/at_start_f435/examples/ertc/tamper/src/main.c.

◆ ERTC_BPR_DT_NUMBER [2/2]

#define ERTC_BPR_DT_NUMBER 20

Definition at line 38 of file project/at_start_f437/examples/ertc/tamper/src/main.c.

Function Documentation

◆ bpr_reg_check()

uint32_t bpr_reg_check ( void )

checks if the bpr dt register values are correct or not.

Parameters
none.
Return values
- TRUE: all bpr dt register values are correct
  • FALSE: number of the bpr register which value is not correct

Definition at line 210 of file project/at_start_f435/examples/ertc/tamper/src/main.c.

Referenced by main().

◆ bpr_reg_write()

void bpr_reg_write ( void )

write data to bpr dt register.

Parameters
none.
Return values
none

Definition at line 192 of file project/at_start_f435/examples/ertc/tamper/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c.

◆ ertc_config()

void ertc_config ( void )

configure the ertc peripheral by selecting the clock source.

Parameters
none
Return values
none

< low speed external crystal stable flag

< low speed external crystal stable flag

Definition at line 102 of file project/at_start_f435/examples/ertc/tamper/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c.

◆ is_bpr_reg_reset()

uint32_t is_bpr_reg_reset ( void )

checks if the ertc bpr dtx registers are reset or not.

Parameters
none
Return values
- 0: all ertc bpr dtx registers are reset
  • value different from 0: number of the first bpr register not reset

Definition at line 232 of file project/at_start_f435/examples/ertc/tamper/src/main.c.

Referenced by TAMP_STAMP_IRQHandler().

◆ main()

int main ( void )

main program

Parameters
none
Return values
none

Definition at line 59 of file project/at_start_f435/examples/ertc/tamper/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c.

◆ TAMP_STAMP_IRQHandler()

void TAMP_STAMP_IRQHandler ( void )

this function handles ertc tamper and time stamp interrupts requests.

this function handles ertc tamper interrupt request.

this function handles external lines 15 to 10 interrupt request.

Parameters
none
Return values
none

< ertc tamper detection 1 flag

< ertc tamper detection 1 flag

< external interrupt line 21

< ertc tamper detection 1 flag

< ertc tamper detection 1 flag

< external interrupt line 21

Definition at line 143 of file project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c.

Variable Documentation

◆ bpr_addr_tab [1/2]

ertc_dt_type bpr_addr_tab[20]
Initial value:
=
{
ERTC_DT1, ERTC_DT2, ERTC_DT3, ERTC_DT4, ERTC_DT5,
ERTC_DT6, ERTC_DT7, ERTC_DT8, ERTC_DT9, ERTC_DT10,
ERTC_DT11, ERTC_DT12, ERTC_DT13, ERTC_DT14, ERTC_DT15,
ERTC_DT16, ERTC_DT17, ERTC_DT18, ERTC_DT19, ERTC_DT20,
}
ERTC_DT11
@ ERTC_DT11
Definition: at32f435_437_ertc.h:367
ERTC_DT13
@ ERTC_DT13
Definition: at32f435_437_ertc.h:369
ERTC_DT2
@ ERTC_DT2
Definition: at32f435_437_ertc.h:358
ERTC_DT1
@ ERTC_DT1
Definition: at32f435_437_ertc.h:357
ERTC_DT15
@ ERTC_DT15
Definition: at32f435_437_ertc.h:371
ERTC_DT18
@ ERTC_DT18
Definition: at32f435_437_ertc.h:374
ERTC_DT19
@ ERTC_DT19
Definition: at32f435_437_ertc.h:375
ERTC_DT6
@ ERTC_DT6
Definition: at32f435_437_ertc.h:362
ERTC_DT7
@ ERTC_DT7
Definition: at32f435_437_ertc.h:363
ERTC_DT20
@ ERTC_DT20
Definition: at32f435_437_ertc.h:376
ERTC_DT17
@ ERTC_DT17
Definition: at32f435_437_ertc.h:373
ERTC_DT3
@ ERTC_DT3
Definition: at32f435_437_ertc.h:359
ERTC_DT4
@ ERTC_DT4
Definition: at32f435_437_ertc.h:360
ERTC_DT8
@ ERTC_DT8
Definition: at32f435_437_ertc.h:364
ERTC_DT5
@ ERTC_DT5
Definition: at32f435_437_ertc.h:361
ERTC_DT10
@ ERTC_DT10
Definition: at32f435_437_ertc.h:366
ERTC_DT9
@ ERTC_DT9
Definition: at32f435_437_ertc.h:365
ERTC_DT16
@ ERTC_DT16
Definition: at32f435_437_ertc.h:372
ERTC_DT12
@ ERTC_DT12
Definition: at32f435_437_ertc.h:368
ERTC_DT14
@ ERTC_DT14
Definition: at32f435_437_ertc.h:370

Definition at line 40 of file project/at_start_f435/examples/ertc/tamper/src/main.c.

Referenced by bpr_reg_check(), bpr_reg_write(), and is_bpr_reg_reset().

◆ bpr_addr_tab [2/2]

ertc_dt_type bpr_addr_tab[20]
Initial value:
=
{
ERTC_DT1, ERTC_DT2, ERTC_DT3, ERTC_DT4, ERTC_DT5,
ERTC_DT6, ERTC_DT7, ERTC_DT8, ERTC_DT9, ERTC_DT10,
ERTC_DT11, ERTC_DT12, ERTC_DT13, ERTC_DT14, ERTC_DT15,
ERTC_DT16, ERTC_DT17, ERTC_DT18, ERTC_DT19, ERTC_DT20,
}

Definition at line 40 of file project/at_start_f437/examples/ertc/tamper/src/main.c.


AT32F435/437 Firmwary Library: ERTC_time_stamp

Functions
ERTC_time_stamp
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | ertc_time_show (void)
display the current date. More...
void | ertc_timestamp_show (void)
display the current timestamp. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TAMP_STAMP_IRQHandler (void)
this function handles external lines 15 to 10 interrupt request. More...
void | ertc_config (void)
configure the ertc peripheral by selecting the clock source. More...
void | ertc_timestamp_config (void)
configure the ertc timestamp. More...
int | main (void)
main program More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 82 of file project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 117 of file project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c.

◆ ertc_config()

void ertc_config ( void )

configure the ertc peripheral by selecting the clock source.

Parameters
none
Return values
none

< low speed external crystal stable flag

< low speed external crystal stable flag

Definition at line 82 of file project/at_start_f435/examples/ertc/time_stamp/src/main.c.

Referenced by main().

◆ ertc_time_show()

void ertc_time_show ( void )

display the current date.

Parameters
none
Return values
none

Definition at line 161 of file project/at_start_f435/examples/ertc/time_stamp/src/main.c.

Referenced by TAMP_STAMP_IRQHandler().

◆ ertc_timestamp_config()

void ertc_timestamp_config ( void )

configure the ertc timestamp.

Parameters
none
Return values
none

< external interrupt line 21

< ertc timestamp interrupt

< external interrupt line 21

< ertc timestamp interrupt

Definition at line 133 of file project/at_start_f435/examples/ertc/time_stamp/src/main.c.

Referenced by main().

◆ ertc_timestamp_show()

void ertc_timestamp_show ( void )

display the current timestamp.

Parameters
none
Return values
none

Definition at line 183 of file project/at_start_f435/examples/ertc/time_stamp/src/main.c.

Referenced by TAMP_STAMP_IRQHandler().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 56 of file project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c.

◆ main()

int main ( void )

main program

Parameters
none
Return values
none

Definition at line 48 of file project/at_start_f435/examples/ertc/time_stamp/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 69 of file project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 47 of file project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 126 of file project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 108 of file project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 135 of file project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c.

◆ TAMP_STAMP_IRQHandler()

void TAMP_STAMP_IRQHandler ( void )

this function handles external lines 15 to 10 interrupt request.

Parameters
none
Return values
none

< ertc timestamp flag

< external interrupt line 21

< ertc timestamp flag

< ertc timestamp flag

< external interrupt line 21

< ertc timestamp flag

Definition at line 144 of file project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 95 of file project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: ERTC_wakeup_timer

Functions
ERTC_wakeup_timer
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | ertc_wakeup_show (void)
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ERTC_WKUP_IRQHandler (void)
this function handles ertc wakeup timer interrupt request. More...
void | ertc_config (void)
configure the ertc peripheral by selecting the clock source. More...
void | wakeup_timer_config (void)
configure the ertc peripheral by selecting the clock source. More...
int | main (void)
main program More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c.

◆ ertc_config()

void ertc_config ( void )

configure the ertc peripheral by selecting the clock source.

Parameters
none
Return values
none

< low speed external crystal stable flag

< low speed external crystal stable flag

Definition at line 92 of file project/at_start_f435/examples/ertc/wakeup_timer/src/main.c.

Referenced by main().

◆ ertc_wakeup_show()

void ertc_wakeup_show ( void )

◆ ERTC_WKUP_IRQHandler()

void ERTC_WKUP_IRQHandler ( void )

this function handles ertc wakeup timer interrupt request.

Parameters
none
Return values
none

< ertc wakeup timer flag

< ertc wakeup timer flag

< external interrupt line 22

< ertc wakeup timer flag

< ertc wakeup timer flag

< external interrupt line 22

Definition at line 143 of file project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c.

◆ main()

int main ( void )

main program

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f435/examples/ertc/wakeup_timer/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c.

◆ wakeup_timer_config()

void wakeup_timer_config ( void )

configure the ertc peripheral by selecting the clock source.

Parameters
none
Return values
none

< ertc wakeup timer interrupt

< external interrupt line 22

< ertc wakeup timer interrupt

< external interrupt line 22

Definition at line 144 of file project/at_start_f435/examples/ertc/wakeup_timer/src/main.c.

Referenced by main().


AT32F435/437 Firmwary Library: EXINT_exint_config

Functions
EXINT_exint_config
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | exint_line0_config (void)
exint line0 config. configure pa0 in interrupt mode More...
void | EXINT0_IRQHandler (void)
exint0 interrupt handler More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c.

◆ EXINT0_IRQHandler()

void EXINT0_IRQHandler ( void )

exint0 interrupt handler

Parameters
none
Return values
none

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

Definition at line 70 of file project/at_start_f435/examples/exint/exint_config/src/main.c.

◆ exint_line0_config()

void exint_line0_config ( void )

exint line0 config. configure pa0 in interrupt mode

Parameters
None
Return values
None

< external interrupt line 0

< external interrupt line 0

Definition at line 45 of file project/at_start_f435/examples/exint/exint_config/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 86 of file project/at_start_f435/examples/exint/exint_config/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: EXINT_exint_software_trigger

Functions
EXINT_exint_software_trigger
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | exint_line4_config (void)
exint line4 config. configure pa0 in interrupt mode More...
static void | tmr1_config (void)
tmr1 configuration. More...
void | TMR1_OVF_TMR10_IRQHandler (void)
tmr1 interrupt handler More...
void | EXINT4_IRQHandler (void)
exint4 interrupt handler More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c.

◆ EXINT4_IRQHandler()

void EXINT4_IRQHandler ( void )

exint4 interrupt handler

Parameters
none
Return values
none

< external interrupt line 4

< external interrupt line 4

< external interrupt line 4

< external interrupt line 4

Definition at line 104 of file project/at_start_f435/examples/exint/exint_software_trigger/src/main.c.

◆ exint_line4_config()

void exint_line4_config ( void )

exint line4 config. configure pa0 in interrupt mode

Parameters
None
Return values
None

< external interrupt line 4

< external interrupt line 4

< external interrupt line 4

< external interrupt line 4

Definition at line 46 of file project/at_start_f435/examples/exint/exint_software_trigger/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 119 of file project/at_start_f435/examples/exint/exint_software_trigger/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c.

◆ tmr1_config()

static void tmr1_config ( void )
static

tmr1 configuration.

Parameters
none
Return values
none

< tmr interrupt overflow

Definition at line 67 of file project/at_start_f435/examples/exint/exint_software_trigger/src/main.c.

Referenced by main().

◆ TMR1_OVF_TMR10_IRQHandler()

void TMR1_OVF_TMR10_IRQHandler ( void )

tmr1 interrupt handler

Parameters
none
Return values
none

< tmr flag overflow

< external interrupt line 4

< tmr flag overflow

< tmr flag overflow

< external interrupt line 4

< tmr flag overflow

Definition at line 89 of file project/at_start_f435/examples/exint/exint_software_trigger/src/main.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: FLASH_fap_enable

Functions
FLASH_fap_enable
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< flash common operation timeout

< flash bank1 program error flag

< flash program error flag

< flash bank1 erase/program protection error flag

< flash erase/program protection error flag

< flash common operation timeout

< flash bank1 program error flag

< flash program error flag

< flash bank1 erase/program protection error flag

< flash erase/program protection error flag

Definition at line 43 of file project/at_start_f435/examples/flash/fap_enable/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: FLASH_write_read

Modules | Macros | Functions | Variables
FLASH_write_read
AT32F435_periph_examples | AT32F437_periph_examples

Modules

FLASH_write_read_functions

Macros

#define | SECTOR_SIZE 4096 /* this parameter depends on the specific model of the chip */
#define | TEST_BUFEER_SIZE 3000
#define | TEST_FLASH_ADDRESS_START (0x08000000 + 1024 * 10)
#define | SECTOR_SIZE 4096 /* this parameter depends on the specific model of the chip */
#define | TEST_BUFEER_SIZE 3000
#define | TEST_FLASH_ADDRESS_START (0x08000000 + 1024 * 10)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | flash_read (uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read)
read data using halfword mode More...
error_status | flash_write_nocheck (uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode without checking More...
error_status | flash_write (uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode with checking More...
error_status | buffer_compare (uint16_t *p_buffer1, uint16_t *p_buffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint16_t | flash_buf [4096/2]
uint16_t | buffer_write [3000]
uint16_t | buffer_read [3000]
uint16_t | flash_buf [4096/2]
uint16_t | buffer_write [3000]
uint16_t | buffer_read [3000]

Detailed Description

Macro Definition Documentation

◆ SECTOR_SIZE [1/2]

#define SECTOR_SIZE 4096 /* this parameter depends on the specific model of the chip */

Definition at line 38 of file project/at_start_f435/examples/flash/flash_write_read/src/flash.c.

◆ SECTOR_SIZE [2/2]

#define SECTOR_SIZE 4096 /* this parameter depends on the specific model of the chip */

Definition at line 38 of file project/at_start_f437/examples/flash/flash_write_read/src/flash.c.

◆ TEST_BUFEER_SIZE [1/2]

#define TEST_BUFEER_SIZE 3000

Definition at line 39 of file project/at_start_f435/examples/flash/flash_write_read/src/main.c.

◆ TEST_BUFEER_SIZE [2/2]

#define TEST_BUFEER_SIZE 3000

Definition at line 39 of file project/at_start_f437/examples/flash/flash_write_read/src/main.c.

◆ TEST_FLASH_ADDRESS_START [1/2]

#define TEST_FLASH_ADDRESS_START (0x08000000 + 1024 * 10)

Definition at line 40 of file project/at_start_f435/examples/flash/flash_write_read/src/main.c.

◆ TEST_FLASH_ADDRESS_START [2/2]

#define TEST_FLASH_ADDRESS_START (0x08000000 + 1024 * 10)

Definition at line 40 of file project/at_start_f437/examples/flash/flash_write_read/src/main.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint16_t * | p_buffer1,
 |  | uint16_t * | p_buffer2,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
p_buffer1,p_buffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
SUCCESS p_buffer1 identical to p_buffer2 ERROR: p_buffer1 differs from p_buffer2

Definition at line 54 of file project/at_start_f435/examples/flash/flash_write_read/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c.

◆ flash_read()

void flash_read | ( | uint32_t | read_addr,
 |  | uint16_t * | p_buffer,
 |  | uint16_t | num_read
 | ) |  |

read data using halfword mode

Parameters
read_addr | the address of reading
p_buffer | the buffer of reading data
num_read | the number of reading data
Return values
none

Definition at line 49 of file project/at_start_f435/examples/flash/flash_write_read/src/flash.c.

Referenced by flash_write(), and main().

◆ flash_write()

error_status flash_write | ( | uint32_t | write_addr,
 |  | uint16_t * | p_buffer,
 |  | uint16_t | num_write
 | ) |  |

write data using halfword mode with checking

Parameters
write_addr | the address of writing
p_buffer | the buffer of writing data
num_write | the number of writing data
Return values
result

Definition at line 87 of file project/at_start_f435/examples/flash/flash_write_read/src/flash.c.

Referenced by main().

◆ flash_write_nocheck()

error_status flash_write_nocheck | ( | uint32_t | write_addr,
 |  | uint16_t * | p_buffer,
 |  | uint16_t | num_write
 | ) |  |

write data using halfword mode without checking

Parameters
write_addr | the address of writing
p_buffer | the buffer of writing data
num_write | the number of writing data
Return values
result

Definition at line 66 of file project/at_start_f435/examples/flash/flash_write_read/src/flash.c.

Referenced by flash_write().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 73 of file project/at_start_f435/examples/flash/flash_write_read/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c.

Variable Documentation

◆ buffer_read [1/2]

uint16_t buffer_read[3000]

Definition at line 43 of file project/at_start_f435/examples/flash/flash_write_read/src/main.c.

Referenced by main().

◆ buffer_read [2/2]

uint16_t buffer_read[3000]

Definition at line 43 of file project/at_start_f437/examples/flash/flash_write_read/src/main.c.

◆ buffer_write [1/2]

uint16_t buffer_write[3000]

Definition at line 42 of file project/at_start_f435/examples/flash/flash_write_read/src/main.c.

Referenced by main().

◆ buffer_write [2/2]

uint16_t buffer_write[3000]

Definition at line 42 of file project/at_start_f437/examples/flash/flash_write_read/src/main.c.

◆ flash_buf [1/2]

uint16_t flash_buf[4096/2]

Definition at line 40 of file project/at_start_f435/examples/flash/flash_write_read/src/flash.c.

Referenced by flash_write().

◆ flash_buf [2/2]

uint16_t flash_buf[4096/2]

Definition at line 40 of file project/at_start_f437/examples/flash/flash_write_read/src/flash.c.

Referenced by flash_write().


AT32F435/437 Firmwary Library: FLASH_write_read_functions

Functions
FLASH_write_read_functions
AT32F435_periph_examples | AT32F437_periph_examples » FLASH_write_read

Functions

void | flash_read (uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read)
read data using halfword mode More...
error_status | flash_write_nocheck (uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode without checking More...
error_status | flash_write (uint32_t write_addr, uint16_t *p_Buffer, uint16_t num_write)
write data using halfword mode with checking More...

Detailed Description

Function Documentation

◆ flash_read()

void flash_read | ( | uint32_t | read_addr,
 |  | uint16_t * | p_buffer,
 |  | uint16_t | num_read
 | ) |  |

read data using halfword mode

Parameters
read_addr | the address of reading
p_buffer | the buffer of reading data
num_read | the number of reading data
Return values
none

Definition at line 49 of file project/at_start_f437/examples/flash/flash_write_read/src/flash.c.

Referenced by flash_write(), and main().

◆ flash_write()

error_status flash_write | ( | uint32_t | write_addr,
 |  | uint16_t * | p_buffer,
 |  | uint16_t | num_write
 | ) |  |

write data using halfword mode with checking

Parameters
write_addr | the address of writing
p_buffer | the buffer of writing data
num_write | the number of writing data
Return values
result

Definition at line 87 of file project/at_start_f437/examples/flash/flash_write_read/src/flash.c.

Referenced by main().

◆ flash_write_nocheck()

error_status flash_write_nocheck | ( | uint32_t | write_addr,
 |  | uint16_t * | p_buffer,
 |  | uint16_t | num_write
 | ) |  |

write data using halfword mode without checking

Parameters
write_addr | the address of writing
p_buffer | the buffer of writing data
num_write | the number of writing data
Return values
result

Definition at line 66 of file project/at_start_f437/examples/flash/flash_write_read/src/flash.c.

Referenced by flash_write().


AT32F435/437 Firmwary Library: GPIO_io_toggle

Functions
GPIO_io_toggle
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | gpio_config (void)
pa.01 gpio configuration. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c.

◆ gpio_config()

static void gpio_config ( void )

pa.01 gpio configuration.

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 1

< gpio pins number 1

Definition at line 44 of file project/at_start_f435/examples/gpio/io_toggle/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

< gpio pins number 1

Definition at line 68 of file project/at_start_f435/examples/gpio/io_toggle/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: GPIO_led_toggle

Functions
GPIO_led_toggle
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f435/examples/gpio/led_toggle/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: _GPIO_swjtag_mux

Functions
_GPIO_swjtag_mux
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: GPIO_swjtag_mux

Functions
GPIO_swjtag_mux
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | swj_dp_config (void)
configure the gpio of swj-dp. More...
void | gpio_pins_toggle (gpio_type *gpio_x, uint16_t gpio_pin)
toggles the specified gpio pin More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ gpio_pins_toggle()

void gpio_pins_toggle | ( | gpio_type * | gpio_x,
 |  | uint16_t | gpio_pin
 | ) |  |

toggles the specified gpio pin

Parameters
gpiox | where x can be (a..g depending on device used) to select the gpio peripheral
gpio_pin | specifies the pins to be toggled.
Return values
none

Definition at line 85 of file project/at_start_f435/examples/gpio/swjtag_mux/src/main.c.

Referenced by main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 13

< usart transmit data buffer empty flag

< gpio pins number 13

< usart transmit data buffer empty flag

Definition at line 95 of file project/at_start_f435/examples/gpio/swjtag_mux/src/main.c.

◆ swj_dp_config()

void swj_dp_config ( void )

configure the gpio of swj-dp.

Parameters
none
Return values
none

< gpio pins number 13

< gpio pins number 14

< gpio pins number 13

< gpio pins number 14

Definition at line 47 of file project/at_start_f435/examples/gpio/swjtag_mux/src/main.c.

Referenced by main().


AT32F435/437 Firmwary Library: I2C_communication_dma

Macros | Functions | Variables
I2C_communication_dma
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | I2Cx_DMA_TX_IRQHandler DMA1_Channel1_IRQHandler
#define | I2Cx_DMA_RX_IRQHandler DMA1_Channel2_IRQHandler
#define | I2Cx_EVT_IRQHandler I2C1_EVT_IRQHandler
#define | I2Cx_ERR_IRQHandler I2C1_ERR_IRQHandler
#define | I2C_TIMEOUT 0xFFFFFFF
#define | I2Cx_CLKCTRL 0x80504C4E
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_DMA DMA1
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_MUX GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_MUX GPIO_MUX_4
#define | I2Cx_DMA_TX_Channel DMA1_CHANNEL1
#define | I2Cx_DMA_TX_DMAMUX_Channel DMA1MUX_CHANNEL1
#define | I2Cx_DMA_TX_DMAREQ DMAMUX_DMAREQ_ID_I2C1_TX
#define | I2Cx_DMA_TX_IRQn DMA1_Channel1_IRQn
#define | I2Cx_DMA_RX_Channel DMA1_CHANNEL2
#define | I2Cx_DMA_RX_DMAMUX_Channel DMA1MUX_CHANNEL2
#define | I2Cx_DMA_RX_DMAREQ DMAMUX_DMAREQ_ID_I2C1_RX
#define | I2Cx_DMA_RX_IRQn DMA1_Channel2_IRQn
#define | I2Cx_EVT_IRQn I2C1_EVT_IRQn
#define | I2Cx_ERR_IRQn I2C1_ERR_IRQn
#define | BUF_SIZE 8
#define | MASTER_BOARD
#define | I2Cx_DMA_TX_IRQHandler DMA1_Channel1_IRQHandler
#define | I2Cx_DMA_RX_IRQHandler DMA1_Channel2_IRQHandler
#define | I2Cx_EVT_IRQHandler I2C1_EVT_IRQHandler
#define | I2Cx_ERR_IRQHandler I2C1_ERR_IRQHandler
#define | I2C_TIMEOUT 0xFFFFFFF
#define | I2Cx_CLKCTRL 0x80504C4E
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_DMA DMA1
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_MUX GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_MUX GPIO_MUX_4
#define | I2Cx_DMA_TX_Channel DMA1_CHANNEL1
#define | I2Cx_DMA_TX_DMAMUX_Channel DMA1MUX_CHANNEL1
#define | I2Cx_DMA_TX_DMAREQ DMAMUX_DMAREQ_ID_I2C1_TX
#define | I2Cx_DMA_TX_IRQn DMA1_Channel1_IRQn
#define | I2Cx_DMA_RX_Channel DMA1_CHANNEL2
#define | I2Cx_DMA_RX_DMAMUX_Channel DMA1MUX_CHANNEL2
#define | I2Cx_DMA_RX_DMAREQ DMAMUX_DMAREQ_ID_I2C1_RX
#define | I2Cx_DMA_RX_IRQn DMA1_Channel2_IRQn
#define | I2Cx_EVT_IRQn I2C1_EVT_IRQn
#define | I2Cx_ERR_IRQn I2C1_ERR_IRQn
#define | BUF_SIZE 8
#define | MASTER_BOARD

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel2_IRQHandler (void)
this function handles dma interrupt request. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma interrupt request. More...
void | I2C1_EVT_IRQHandler (void)
this function handles i2c event interrupt request. More...
void | I2C1_ERR_IRQHandler (void)
this function handles i2c error interrupt request. More...
void | error_handler (uint32_t error_code)
error handler program More...
uint32_t | buffer_compare (uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal. More...
int | main (void)
main function. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...

Variables

i2c_handle_type hi2cx
uint8_t | tx_buf [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | rx_buf [8] = {0}
i2c_handle_type hi2cx
i2c_handle_type hi2cx
uint8_t | tx_buf [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | rx_buf [8] = {0}
i2c_handle_type hi2cx

Detailed Description

Macro Definition Documentation

◆ BUF_SIZE [1/2]

#define BUF_SIZE 8

Definition at line 78 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ BUF_SIZE [2/2]

#define BUF_SIZE 8

Definition at line 78 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2C_TIMEOUT [1/2]

#define I2C_TIMEOUT 0xFFFFFFF

Definition at line 39 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2C_TIMEOUT [2/2]

#define I2C_TIMEOUT 0xFFFFFFF

Definition at line 39 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_ADDRESS [1/2]

#define I2Cx_ADDRESS 0xA0

Definition at line 46 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_ADDRESS [2/2]

#define I2Cx_ADDRESS 0xA0

Definition at line 46 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_CLK [1/2]

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 49 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_CLK [2/2]

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 49 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_CLKCTRL [1/2]

#define I2Cx_CLKCTRL 0x80504C4E

Definition at line 43 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_CLKCTRL [2/2]

#define I2Cx_CLKCTRL 0x80504C4E

Definition at line 43 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA [1/2]

#define I2Cx_DMA DMA1

Definition at line 50 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA [2/2]

#define I2Cx_DMA DMA1

Definition at line 50 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_CLK [1/2]

#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK

Definition at line 51 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_CLK [2/2]

#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK

Definition at line 51 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_RX_Channel [1/2]

#define I2Cx_DMA_RX_Channel DMA1_CHANNEL2

Definition at line 70 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_RX_Channel [2/2]

#define I2Cx_DMA_RX_Channel DMA1_CHANNEL2

Definition at line 70 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_RX_DMAMUX_Channel [1/2]

#define I2Cx_DMA_RX_DMAMUX_Channel DMA1MUX_CHANNEL2

Definition at line 71 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_RX_DMAMUX_Channel [2/2]

#define I2Cx_DMA_RX_DMAMUX_Channel DMA1MUX_CHANNEL2

Definition at line 71 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_RX_DMAREQ [1/2]

#define I2Cx_DMA_RX_DMAREQ DMAMUX_DMAREQ_ID_I2C1_RX

Definition at line 72 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_RX_DMAREQ [2/2]

#define I2Cx_DMA_RX_DMAREQ DMAMUX_DMAREQ_ID_I2C1_RX

Definition at line 72 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_RX_IRQHandler [1/2]

#define I2Cx_DMA_RX_IRQHandler DMA1_Channel2_IRQHandler

Definition at line 42 of file project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c.

◆ I2Cx_DMA_RX_IRQHandler [2/2]

#define I2Cx_DMA_RX_IRQHandler DMA1_Channel2_IRQHandler

Definition at line 42 of file project/at_start_f437/examples/i2c/communication_dma/src/at32f435_437_int.c.

◆ I2Cx_DMA_RX_IRQn [1/2]

#define I2Cx_DMA_RX_IRQn DMA1_Channel2_IRQn

Definition at line 73 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_RX_IRQn [2/2]

#define I2Cx_DMA_RX_IRQn DMA1_Channel2_IRQn

Definition at line 73 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_TX_Channel [1/2]

#define I2Cx_DMA_TX_Channel DMA1_CHANNEL1

Definition at line 65 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_TX_Channel [2/2]

#define I2Cx_DMA_TX_Channel DMA1_CHANNEL1

Definition at line 65 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_TX_DMAMUX_Channel [1/2]

#define I2Cx_DMA_TX_DMAMUX_Channel DMA1MUX_CHANNEL1

Definition at line 66 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_TX_DMAMUX_Channel [2/2]

#define I2Cx_DMA_TX_DMAMUX_Channel DMA1MUX_CHANNEL1

Definition at line 66 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_TX_DMAREQ [1/2]

#define I2Cx_DMA_TX_DMAREQ DMAMUX_DMAREQ_ID_I2C1_TX

Definition at line 67 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_TX_DMAREQ [2/2]

#define I2Cx_DMA_TX_DMAREQ DMAMUX_DMAREQ_ID_I2C1_TX

Definition at line 67 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_TX_IRQHandler [1/2]

#define I2Cx_DMA_TX_IRQHandler DMA1_Channel1_IRQHandler

Definition at line 41 of file project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c.

◆ I2Cx_DMA_TX_IRQHandler [2/2]

#define I2Cx_DMA_TX_IRQHandler DMA1_Channel1_IRQHandler

Definition at line 41 of file project/at_start_f437/examples/i2c/communication_dma/src/at32f435_437_int.c.

◆ I2Cx_DMA_TX_IRQn [1/2]

#define I2Cx_DMA_TX_IRQn DMA1_Channel1_IRQn

Definition at line 68 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_TX_IRQn [2/2]

#define I2Cx_DMA_TX_IRQn DMA1_Channel1_IRQn

Definition at line 68 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_ERR_IRQHandler [1/2]

#define I2Cx_ERR_IRQHandler I2C1_ERR_IRQHandler

Definition at line 44 of file project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c.

◆ I2Cx_ERR_IRQHandler [2/2]

#define I2Cx_ERR_IRQHandler I2C1_ERR_IRQHandler

Definition at line 44 of file project/at_start_f437/examples/i2c/communication_dma/src/at32f435_437_int.c.

◆ I2Cx_ERR_IRQn [1/2]

#define I2Cx_ERR_IRQn I2C1_ERR_IRQn

Definition at line 76 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_ERR_IRQn [2/2]

#define I2Cx_ERR_IRQn I2C1_ERR_IRQn

Definition at line 76 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_EVT_IRQHandler [1/2]

#define I2Cx_EVT_IRQHandler I2C1_EVT_IRQHandler

Definition at line 43 of file project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c.

◆ I2Cx_EVT_IRQHandler [2/2]

#define I2Cx_EVT_IRQHandler I2C1_EVT_IRQHandler

Definition at line 43 of file project/at_start_f437/examples/i2c/communication_dma/src/at32f435_437_int.c.

◆ I2Cx_EVT_IRQn [1/2]

#define I2Cx_EVT_IRQn I2C1_EVT_IRQn

Definition at line 75 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_EVT_IRQn [2/2]

#define I2Cx_EVT_IRQn I2C1_EVT_IRQn

Definition at line 75 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_PORT [1/2]

#define I2Cx_PORT I2C1

Definition at line 48 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_PORT [2/2]

#define I2Cx_PORT I2C1

Definition at line 48 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SCL_GPIO_CLK [1/2]

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 53 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SCL_GPIO_CLK [2/2]

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 53 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SCL_GPIO_MUX [1/2]

#define I2Cx_SCL_GPIO_MUX GPIO_MUX_4

Definition at line 57 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SCL_GPIO_MUX [2/2]

#define I2Cx_SCL_GPIO_MUX GPIO_MUX_4

Definition at line 57 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SCL_GPIO_PIN [1/2]

#define I2Cx_SCL_GPIO_PIN GPIO_PINS_6

Definition at line 54 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SCL_GPIO_PIN [2/2]

#define I2Cx_SCL_GPIO_PIN GPIO_PINS_6

Definition at line 54 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SCL_GPIO_PinsSource [1/2]

#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6

Definition at line 55 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SCL_GPIO_PinsSource [2/2]

#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6

Definition at line 55 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SCL_GPIO_PORT [1/2]

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 56 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SCL_GPIO_PORT [2/2]

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 56 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SDA_GPIO_CLK [1/2]

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 59 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SDA_GPIO_CLK [2/2]

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 59 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SDA_GPIO_MUX [1/2]

#define I2Cx_SDA_GPIO_MUX GPIO_MUX_4

Definition at line 63 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SDA_GPIO_MUX [2/2]

#define I2Cx_SDA_GPIO_MUX GPIO_MUX_4

Definition at line 63 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SDA_GPIO_PIN [1/2]

#define I2Cx_SDA_GPIO_PIN GPIO_PINS_7

Definition at line 60 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SDA_GPIO_PIN [2/2]

#define I2Cx_SDA_GPIO_PIN GPIO_PINS_7

Definition at line 60 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SDA_GPIO_PinsSource [1/2]

#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7

Definition at line 61 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SDA_GPIO_PinsSource [2/2]

#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7

Definition at line 61 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SDA_GPIO_PORT [1/2]

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 62 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SDA_GPIO_PORT [2/2]

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 62 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ MASTER_BOARD [1/2]

#define MASTER_BOARD

Definition at line 79 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ MASTER_BOARD [2/2]

#define MASTER_BOARD

Definition at line 79 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

Function Documentation

◆ buffer_compare()

uint32_t buffer_compare | ( | uint8_t * | buffer1,
 |  | uint8_t * | buffer2,
 |  | uint32_t | len
 | ) |  |

compare whether the valus of buffer 1 and buffer 2 are equal.

Parameters
buffer1 buffer 1 address. buffer2: buffer 2 address.
Return values
0 equal. 1: unequal.

Definition at line 107 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 86 of file project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma interrupt request.

Parameters
none
Return values
none

Definition at line 159 of file project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c.

◆ DMA1_Channel2_IRQHandler()

void DMA1_Channel2_IRQHandler ( void )

this function handles dma interrupt request.

this function handles dma1 channel2 handler.

Parameters
none
Return values
none

< dma1 channel2 full data transfer flag

Definition at line 149 of file project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c.

◆ error_handler()

void error_handler ( uint32_t error_code )

error handler program

Parameters
i2c_status
Return values
none

Definition at line 91 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 60 of file project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c.

◆ I2C1_ERR_IRQHandler()

void I2C1_ERR_IRQHandler ( void )

this function handles i2c error interrupt request.

Parameters
none
Return values
none

Definition at line 179 of file project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c.

◆ I2C1_EVT_IRQHandler()

void I2C1_EVT_IRQHandler ( void )

this function handles i2c event interrupt request.

Parameters
none
Return values
none

Definition at line 169 of file project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c.

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

Definition at line 239 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 127 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 73 of file project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 139 of file project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 99 of file project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c.

Variable Documentation

◆ hi2cx [1/4]

i2c_handle_type hi2cx
extern

Definition at line 37 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

Referenced by DMA1_Channel1_IRQHandler(), DMA1_Channel2_IRQHandler(), I2C1_ERR_IRQHandler(), and I2C1_EVT_IRQHandler().

◆ hi2cx [2/4]

i2c_handle_type hi2cx

Definition at line 84 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

Referenced by main().

◆ hi2cx [3/4]

i2c_handle_type hi2cx
extern

Definition at line 37 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ hi2cx [4/4]

i2c_handle_type hi2cx

Definition at line 84 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ rx_buf [1/2]

uint8_t rx_buf[8] = {0}

Definition at line 82 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

Referenced by main().

◆ rx_buf [2/2]

uint8_t rx_buf[8] = {0}

Definition at line 82 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.

◆ tx_buf [1/2]

uint8_t tx_buf[8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}

Definition at line 81 of file project/at_start_f435/examples/i2c/communication_dma/src/main.c.

Referenced by main().

◆ tx_buf [2/2]

uint8_t tx_buf[8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}

Definition at line 81 of file project/at_start_f437/examples/i2c/communication_dma/src/main.c.


AT32F435/437 Firmwary Library: I2C_communication_int

Macros | Functions | Variables
I2C_communication_int
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | I2Cx_EVT_IRQHandler I2C1_EVT_IRQHandler
#define | I2Cx_ERR_IRQHandler I2C1_ERR_IRQHandler
#define | I2C_TIMEOUT 0xFFFFFFF
#define | I2Cx_CLKCTRL 0x80504C4E
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_MUX GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_MUX GPIO_MUX_4
#define | I2Cx_EVT_IRQn I2C1_EVT_IRQn
#define | I2Cx_ERR_IRQn I2C1_ERR_IRQn
#define | BUF_SIZE 8
#define | MASTER_BOARD
#define | I2Cx_EVT_IRQHandler I2C1_EVT_IRQHandler
#define | I2Cx_ERR_IRQHandler I2C1_ERR_IRQHandler
#define | I2C_TIMEOUT 0xFFFFFFF
#define | I2Cx_CLKCTRL 0x80504C4E
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_MUX GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_MUX GPIO_MUX_4
#define | I2Cx_EVT_IRQn I2C1_EVT_IRQn
#define | I2Cx_ERR_IRQn I2C1_ERR_IRQn
#define | BUF_SIZE 8
#define | MASTER_BOARD

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | I2C1_EVT_IRQHandler (void)
this function handles i2c event interrupt request. More...
void | I2C1_ERR_IRQHandler (void)
this function handles i2c error interrupt request. More...
void | error_handler (uint32_t error_code)
error handler program More...
uint32_t | buffer_compare (uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal. More...
int | main (void)
main function. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...

Variables

i2c_handle_type hi2cx
uint8_t | tx_buf [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | rx_buf [8] = {0}
i2c_handle_type hi2cx
i2c_handle_type hi2cx
uint8_t | tx_buf [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | rx_buf [8] = {0}
i2c_handle_type hi2cx

Detailed Description

Macro Definition Documentation

◆ BUF_SIZE [1/2]

#define BUF_SIZE 8

Definition at line 66 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

◆ BUF_SIZE [2/2]

#define BUF_SIZE 8

Definition at line 66 of file project/at_start_f437/examples/i2c/communication_int/src/main.c.

◆ I2C_TIMEOUT [1/2]

#define I2C_TIMEOUT 0xFFFFFFF

Definition at line 39 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

◆ I2C_TIMEOUT [2/2]

#define I2C_TIMEOUT 0xFFFFFFF

Definition at line 39 of file project/at_start_f437/examples/i2c/communication_int/src/main.c.

◆ I2Cx_ADDRESS [1/2]

#define I2Cx_ADDRESS 0xA0

Definition at line 46 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

◆ I2Cx_ADDRESS [2/2]

#define I2Cx_ADDRESS 0xA0

Definition at line 46 of file project/at_start_f437/examples/i2c/communication_int/src/main.c.

◆ I2Cx_CLK [1/2]

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 49 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

◆ I2Cx_CLK [2/2]

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 49 of file project/at_start_f437/examples/i2c/communication_int/src/main.c.

◆ I2Cx_CLKCTRL [1/2]

#define I2Cx_CLKCTRL 0x80504C4E

Definition at line 43 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

◆ I2Cx_CLKCTRL [2/2]

#define I2Cx_CLKCTRL 0x80504C4E

Definition at line 43 of file project/at_start_f437/examples/i2c/communication_int/src/main.c.

◆ I2Cx_ERR_IRQHandler [1/2]

#define I2Cx_ERR_IRQHandler I2C1_ERR_IRQHandler

Definition at line 42 of file project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c.

◆ I2Cx_ERR_IRQHandler [2/2]

#define I2Cx_ERR_IRQHandler I2C1_ERR_IRQHandler

Definition at line 42 of file project/at_start_f437/examples/i2c/communication_int/src/at32f435_437_int.c.

◆ I2Cx_ERR_IRQn [1/2]

#define I2Cx_ERR_IRQn I2C1_ERR_IRQn

Definition at line 64 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

◆ I2Cx_ERR_IRQn [2/2]

#define I2Cx_ERR_IRQn I2C1_ERR_IRQn

Definition at line 64 of file project/at_start_f437/examples/i2c/communication_int/src/main.c.

◆ I2Cx_EVT_IRQHandler [1/2]

#define I2Cx_EVT_IRQHandler I2C1_EVT_IRQHandler

Definition at line 41 of file project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c.

◆ I2Cx_EVT_IRQHandler [2/2]

#define I2Cx_EVT_IRQHandler I2C1_EVT_IRQHandler

Definition at line 41 of file project/at_start_f437/examples/i2c/communication_int/src/at32f435_437_int.c.

◆ I2Cx_EVT_IRQn [1/2]

#define I2Cx_EVT_IRQn I2C1_EVT_IRQn

Definition at line 63 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

◆ I2Cx_EVT_IRQn [2/2]

#define I2Cx_EVT_IRQn I2C1_EVT_IRQn

Definition at line 63 of file project/at_start_f437/examples/i2c/communication_int/src/main.c.

◆ I2Cx_PORT [1/2]

#define I2Cx_PORT I2C1

Definition at line 48 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

◆ I2Cx_PORT [2/2]

#define I2Cx_PORT I2C1

Definition at line 48 of file project/at_start_f437/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SCL_GPIO_CLK [1/2]

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 51 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SCL_GPIO_CLK [2/2]

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 51 of file project/at_start_f437/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SCL_GPIO_MUX [1/2]

#define I2Cx_SCL_GPIO_MUX GPIO_MUX_4

Definition at line 55 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SCL_GPIO_MUX [2/2]

#define I2Cx_SCL_GPIO_MUX GPIO_MUX_4

Definition at line 55 of file project/at_start_f437/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SCL_GPIO_PIN [1/2]

#define I2Cx_SCL_GPIO_PIN GPIO_PINS_6

Definition at line 52 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SCL_GPIO_PIN [2/2]

#define I2Cx_SCL_GPIO_PIN GPIO_PINS_6

Definition at line 52 of file project/at_start_f437/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SCL_GPIO_PinsSource [1/2]

#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6

Definition at line 53 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SCL_GPIO_PinsSource [2/2]

#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6

Definition at line 53 of file project/at_start_f437/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SCL_GPIO_PORT [1/2]

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 54 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SCL_GPIO_PORT [2/2]

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 54 of file project/at_start_f437/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SDA_GPIO_CLK [1/2]

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 57 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SDA_GPIO_CLK [2/2]

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 57 of file project/at_start_f437/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SDA_GPIO_MUX [1/2]

#define I2Cx_SDA_GPIO_MUX GPIO_MUX_4

Definition at line 61 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SDA_GPIO_MUX [2/2]

#define I2Cx_SDA_GPIO_MUX GPIO_MUX_4

Definition at line 61 of file project/at_start_f437/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SDA_GPIO_PIN [1/2]

#define I2Cx_SDA_GPIO_PIN GPIO_PINS_7

Definition at line 58 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SDA_GPIO_PIN [2/2]

#define I2Cx_SDA_GPIO_PIN GPIO_PINS_7

Definition at line 58 of file project/at_start_f437/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SDA_GPIO_PinsSource [1/2]

#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7

Definition at line 59 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SDA_GPIO_PinsSource [2/2]

#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7

Definition at line 59 of file project/at_start_f437/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SDA_GPIO_PORT [1/2]

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 60 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SDA_GPIO_PORT [2/2]

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 60 of file project/at_start_f437/examples/i2c/communication_int/src/main.c.

◆ MASTER_BOARD [1/2]

#define MASTER_BOARD

Definition at line 67 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

◆ MASTER_BOARD [2/2]

#define MASTER_BOARD

Definition at line 67 of file project/at_start_f437/examples/i2c/communication_int/src/main.c.

Function Documentation

◆ buffer_compare()

uint32_t buffer_compare | ( | uint8_t * | buffer1,
 |  | uint8_t * | buffer2,
 |  | uint32_t | len
 | ) |  |

compare whether the valus of buffer 1 and buffer 2 are equal.

Parameters
buffer1 buffer 1 address. buffer2: buffer 2 address.
Return values
0 equal. 1: unequal.

Definition at line 95 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 84 of file project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 119 of file project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c.

◆ error_handler()

void error_handler ( uint32_t error_code )

error handler program

Parameters
i2c_status
Return values
none

Definition at line 79 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 58 of file project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c.

◆ I2C1_ERR_IRQHandler()

void I2C1_ERR_IRQHandler ( void )

this function handles i2c error interrupt request.

Parameters
none
Return values
none

Definition at line 156 of file project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c.

◆ I2C1_EVT_IRQHandler()

void I2C1_EVT_IRQHandler ( void )

this function handles i2c event interrupt request.

Parameters
none
Return values
none

Definition at line 146 of file project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c.

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

Definition at line 226 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 115 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 71 of file project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 49 of file project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 128 of file project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 110 of file project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 137 of file project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 97 of file project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c.

Variable Documentation

◆ hi2cx [1/4]

i2c_handle_type hi2cx
extern

Definition at line 37 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

Referenced by I2C1_ERR_IRQHandler(), and I2C1_EVT_IRQHandler().

◆ hi2cx [2/4]

i2c_handle_type hi2cx

Definition at line 72 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

Referenced by main().

◆ hi2cx [3/4]

i2c_handle_type hi2cx
extern

Definition at line 37 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

◆ hi2cx [4/4]

i2c_handle_type hi2cx

Definition at line 72 of file project/at_start_f437/examples/i2c/communication_int/src/main.c.

◆ rx_buf [1/2]

uint8_t rx_buf[8] = {0}

Definition at line 70 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

Referenced by main().

◆ rx_buf [2/2]

uint8_t rx_buf[8] = {0}

Definition at line 70 of file project/at_start_f437/examples/i2c/communication_int/src/main.c.

◆ tx_buf [1/2]

uint8_t tx_buf[8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}

Definition at line 69 of file project/at_start_f435/examples/i2c/communication_int/src/main.c.

Referenced by main().

◆ tx_buf [2/2]

uint8_t tx_buf[8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}

Definition at line 69 of file project/at_start_f437/examples/i2c/communication_int/src/main.c.


AT32F435/437 Firmwary Library: I2C_communication_poll

Macros | Functions | Variables
I2C_communication_poll
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | I2C_TIMEOUT 0xFFFFFFF
#define | I2Cx_CLKCTRL 0x80504C4E
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_DMA DMA1
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_MUX GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_MUX GPIO_MUX_4
#define | BUF_SIZE 8
#define | MASTER_BOARD
#define | I2C_TIMEOUT 0xFFFFFFF
#define | I2Cx_CLKCTRL 0x80504C4E
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_DMA DMA1
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_MUX GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_MUX GPIO_MUX_4
#define | BUF_SIZE 8
#define | MASTER_BOARD

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | error_handler (uint32_t error_code)
error handler program More...
uint32_t | buffer_compare (uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal. More...
int | main (void)
main function. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...

Variables

uint8_t | tx_buf [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | rx_buf [8] = {0}
i2c_handle_type hi2cx
uint8_t | tx_buf [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | rx_buf [8] = {0}
i2c_handle_type hi2cx

Detailed Description

Macro Definition Documentation

◆ BUF_SIZE [1/2]

#define BUF_SIZE 8

Definition at line 65 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

◆ BUF_SIZE [2/2]

#define BUF_SIZE 8

Definition at line 65 of file project/at_start_f437/examples/i2c/communication_poll/src/main.c.

◆ I2C_TIMEOUT [1/2]

#define I2C_TIMEOUT 0xFFFFFFF

Definition at line 39 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

◆ I2C_TIMEOUT [2/2]

#define I2C_TIMEOUT 0xFFFFFFF

Definition at line 39 of file project/at_start_f437/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_ADDRESS [1/2]

#define I2Cx_ADDRESS 0xA0

Definition at line 46 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_ADDRESS [2/2]

#define I2Cx_ADDRESS 0xA0

Definition at line 46 of file project/at_start_f437/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_CLK [1/2]

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 49 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_CLK [2/2]

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 49 of file project/at_start_f437/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_CLKCTRL [1/2]

#define I2Cx_CLKCTRL 0x80504C4E

Definition at line 43 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_CLKCTRL [2/2]

#define I2Cx_CLKCTRL 0x80504C4E

Definition at line 43 of file project/at_start_f437/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_DMA [1/2]

#define I2Cx_DMA DMA1

Definition at line 50 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_DMA [2/2]

#define I2Cx_DMA DMA1

Definition at line 50 of file project/at_start_f437/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_DMA_CLK [1/2]

#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK

Definition at line 51 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_DMA_CLK [2/2]

#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK

Definition at line 51 of file project/at_start_f437/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_PORT [1/2]

#define I2Cx_PORT I2C1

Definition at line 48 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_PORT [2/2]

#define I2Cx_PORT I2C1

Definition at line 48 of file project/at_start_f437/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SCL_GPIO_CLK [1/2]

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 53 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SCL_GPIO_CLK [2/2]

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 53 of file project/at_start_f437/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SCL_GPIO_MUX [1/2]

#define I2Cx_SCL_GPIO_MUX GPIO_MUX_4

Definition at line 57 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SCL_GPIO_MUX [2/2]

#define I2Cx_SCL_GPIO_MUX GPIO_MUX_4

Definition at line 57 of file project/at_start_f437/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SCL_GPIO_PIN [1/2]

#define I2Cx_SCL_GPIO_PIN GPIO_PINS_6

Definition at line 54 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SCL_GPIO_PIN [2/2]

#define I2Cx_SCL_GPIO_PIN GPIO_PINS_6

Definition at line 54 of file project/at_start_f437/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SCL_GPIO_PinsSource [1/2]

#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6

Definition at line 55 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SCL_GPIO_PinsSource [2/2]

#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6

Definition at line 55 of file project/at_start_f437/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SCL_GPIO_PORT [1/2]

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 56 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SCL_GPIO_PORT [2/2]

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 56 of file project/at_start_f437/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SDA_GPIO_CLK [1/2]

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 59 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SDA_GPIO_CLK [2/2]

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 59 of file project/at_start_f437/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SDA_GPIO_MUX [1/2]

#define I2Cx_SDA_GPIO_MUX GPIO_MUX_4

Definition at line 63 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SDA_GPIO_MUX [2/2]

#define I2Cx_SDA_GPIO_MUX GPIO_MUX_4

Definition at line 63 of file project/at_start_f437/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SDA_GPIO_PIN [1/2]

#define I2Cx_SDA_GPIO_PIN GPIO_PINS_7

Definition at line 60 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SDA_GPIO_PIN [2/2]

#define I2Cx_SDA_GPIO_PIN GPIO_PINS_7

Definition at line 60 of file project/at_start_f437/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SDA_GPIO_PinsSource [1/2]

#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7

Definition at line 61 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SDA_GPIO_PinsSource [2/2]

#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7

Definition at line 61 of file project/at_start_f437/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SDA_GPIO_PORT [1/2]

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 62 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SDA_GPIO_PORT [2/2]

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 62 of file project/at_start_f437/examples/i2c/communication_poll/src/main.c.

◆ MASTER_BOARD [1/2]

#define MASTER_BOARD

Definition at line 66 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

◆ MASTER_BOARD [2/2]

#define MASTER_BOARD

Definition at line 66 of file project/at_start_f437/examples/i2c/communication_poll/src/main.c.

Function Documentation

◆ buffer_compare()

uint32_t buffer_compare | ( | uint8_t * | buffer1,
 |  | uint8_t * | buffer2,
 |  | uint32_t | len
 | ) |  |

compare whether the valus of buffer 1 and buffer 2 are equal.

Parameters
buffer1 buffer 1 address. buffer2: buffer 2 address.
Return values
0 equal. 1: unequal.

Definition at line 94 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c.

◆ error_handler()

void error_handler ( uint32_t error_code )

error handler program

Parameters
i2c_status
Return values
none

Definition at line 78 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c.

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

Definition at line 200 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c.

Variable Documentation

◆ hi2cx [1/2]

i2c_handle_type hi2cx

Definition at line 71 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

Referenced by main().

◆ hi2cx [2/2]

i2c_handle_type hi2cx

Definition at line 71 of file project/at_start_f437/examples/i2c/communication_poll/src/main.c.

◆ rx_buf [1/2]

uint8_t rx_buf[8] = {0}

Definition at line 69 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

Referenced by main().

◆ rx_buf [2/2]

uint8_t rx_buf[8] = {0}

Definition at line 69 of file project/at_start_f437/examples/i2c/communication_poll/src/main.c.

◆ tx_buf [1/2]

uint8_t tx_buf[8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}

Definition at line 68 of file project/at_start_f435/examples/i2c/communication_poll/src/main.c.

Referenced by main().

◆ tx_buf [2/2]

uint8_t tx_buf[8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}

Definition at line 68 of file project/at_start_f437/examples/i2c/communication_poll/src/main.c.


AT32F435/437 Firmwary Library: I2C_communication_smbus

Macros | Functions | Variables
I2C_communication_smbus
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | I2C_TIMEOUT 0xFFFFFFF
#define | I2Cx_CLKCTRL 0x80504C4E
#define | I2Cx_ADDRESS 0xA2
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_DMA DMA1
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_MUX GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_MUX GPIO_MUX_4
#define | BUF_SIZE 9
#define | MASTER_BOARD
#define | I2C_TIMEOUT 0xFFFFFFF
#define | I2Cx_CLKCTRL 0x80504C4E
#define | I2Cx_ADDRESS 0xA2
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_DMA DMA1
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_MUX GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_MUX GPIO_MUX_4
#define | BUF_SIZE 9
#define | MASTER_BOARD

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | error_handler (uint32_t error_code)
error handler program More...
uint32_t | buffer_compare (uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal. More...
int | main (void)
main function. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...

Variables

uint8_t | tx_buf [9] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08, 0x00}
uint8_t | rx_buf [9] = {0}
i2c_handle_type hi2cx
uint8_t | tx_buf [9] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08, 0x00}
uint8_t | rx_buf [9] = {0}
i2c_handle_type hi2cx

Detailed Description

Macro Definition Documentation

◆ BUF_SIZE [1/2]

#define BUF_SIZE 9

Definition at line 65 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

◆ BUF_SIZE [2/2]

#define BUF_SIZE 9

Definition at line 65 of file project/at_start_f437/examples/i2c/communication_smbus/src/main.c.

◆ I2C_TIMEOUT [1/2]

#define I2C_TIMEOUT 0xFFFFFFF

Definition at line 39 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

◆ I2C_TIMEOUT [2/2]

#define I2C_TIMEOUT 0xFFFFFFF

Definition at line 39 of file project/at_start_f437/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_ADDRESS [1/2]

#define I2Cx_ADDRESS 0xA2

Definition at line 46 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_ADDRESS [2/2]

#define I2Cx_ADDRESS 0xA2

Definition at line 46 of file project/at_start_f437/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_CLK [1/2]

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 49 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_CLK [2/2]

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 49 of file project/at_start_f437/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_CLKCTRL [1/2]

#define I2Cx_CLKCTRL 0x80504C4E

Definition at line 43 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_CLKCTRL [2/2]

#define I2Cx_CLKCTRL 0x80504C4E

Definition at line 43 of file project/at_start_f437/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_DMA [1/2]

#define I2Cx_DMA DMA1

Definition at line 50 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_DMA [2/2]

#define I2Cx_DMA DMA1

Definition at line 50 of file project/at_start_f437/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_DMA_CLK [1/2]

#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK

Definition at line 51 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_DMA_CLK [2/2]

#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK

Definition at line 51 of file project/at_start_f437/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_PORT [1/2]

#define I2Cx_PORT I2C1

Definition at line 48 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_PORT [2/2]

#define I2Cx_PORT I2C1

Definition at line 48 of file project/at_start_f437/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_SCL_GPIO_CLK [1/2]

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 53 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_SCL_GPIO_CLK [2/2]

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 53 of file project/at_start_f437/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_SCL_GPIO_MUX [1/2]

#define I2Cx_SCL_GPIO_MUX GPIO_MUX_4

Definition at line 57 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_SCL_GPIO_MUX [2/2]

#define I2Cx_SCL_GPIO_MUX GPIO_MUX_4

Definition at line 57 of file project/at_start_f437/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_SCL_GPIO_PIN [1/2]

#define I2Cx_SCL_GPIO_PIN GPIO_PINS_6

Definition at line 54 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_SCL_GPIO_PIN [2/2]

#define I2Cx_SCL_GPIO_PIN GPIO_PINS_6

Definition at line 54 of file project/at_start_f437/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_SCL_GPIO_PinsSource [1/2]

#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6

Definition at line 55 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_SCL_GPIO_PinsSource [2/2]

#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6

Definition at line 55 of file project/at_start_f437/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_SCL_GPIO_PORT [1/2]

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 56 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_SCL_GPIO_PORT [2/2]

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 56 of file project/at_start_f437/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_SDA_GPIO_CLK [1/2]

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 59 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_SDA_GPIO_CLK [2/2]

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 59 of file project/at_start_f437/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_SDA_GPIO_MUX [1/2]

#define I2Cx_SDA_GPIO_MUX GPIO_MUX_4

Definition at line 63 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_SDA_GPIO_MUX [2/2]

#define I2Cx_SDA_GPIO_MUX GPIO_MUX_4

Definition at line 63 of file project/at_start_f437/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_SDA_GPIO_PIN [1/2]

#define I2Cx_SDA_GPIO_PIN GPIO_PINS_7

Definition at line 60 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_SDA_GPIO_PIN [2/2]

#define I2Cx_SDA_GPIO_PIN GPIO_PINS_7

Definition at line 60 of file project/at_start_f437/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_SDA_GPIO_PinsSource [1/2]

#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7

Definition at line 61 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_SDA_GPIO_PinsSource [2/2]

#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7

Definition at line 61 of file project/at_start_f437/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_SDA_GPIO_PORT [1/2]

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 62 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

◆ I2Cx_SDA_GPIO_PORT [2/2]

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 62 of file project/at_start_f437/examples/i2c/communication_smbus/src/main.c.

◆ MASTER_BOARD [1/2]

#define MASTER_BOARD

Definition at line 66 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

◆ MASTER_BOARD [2/2]

#define MASTER_BOARD

Definition at line 66 of file project/at_start_f437/examples/i2c/communication_smbus/src/main.c.

Function Documentation

◆ buffer_compare()

uint32_t buffer_compare | ( | uint8_t * | buffer1,
 |  | uint8_t * | buffer2,
 |  | uint32_t | len
 | ) |  |

compare whether the valus of buffer 1 and buffer 2 are equal.

Parameters
buffer1 buffer 1 address. buffer2: buffer 2 address.
Return values
0 equal. 1: unequal.

Definition at line 94 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c.

◆ error_handler()

void error_handler ( uint32_t error_code )

error handler program

Parameters
i2c_status
Return values
none

Definition at line 78 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c.

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

Definition at line 200 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c.

Variable Documentation

◆ hi2cx [1/2]

i2c_handle_type hi2cx

Definition at line 71 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

Referenced by main().

◆ hi2cx [2/2]

i2c_handle_type hi2cx

Definition at line 71 of file project/at_start_f437/examples/i2c/communication_smbus/src/main.c.

◆ rx_buf [1/2]

uint8_t rx_buf[9] = {0}

Definition at line 69 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

Referenced by main().

◆ rx_buf [2/2]

uint8_t rx_buf[9] = {0}

Definition at line 69 of file project/at_start_f437/examples/i2c/communication_smbus/src/main.c.

◆ tx_buf [1/2]

uint8_t tx_buf[9] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08, 0x00}

Definition at line 68 of file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.

Referenced by main().

◆ tx_buf [2/2]

uint8_t tx_buf[9] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08, 0x00}

Definition at line 68 of file project/at_start_f437/examples/i2c/communication_smbus/src/main.c.


AT32F435/437 Firmwary Library: I2C_eeprom

Macros | Functions | Variables
I2C_eeprom
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | I2Cx_DMA_TX_IRQHandler DMA1_Channel1_IRQHandler
#define | I2Cx_DMA_RX_IRQHandler DMA1_Channel2_IRQHandler
#define | I2Cx_EVT_IRQHandler I2C2_EVT_IRQHandler
#define | I2Cx_ERR_IRQHandler I2C2_ERR_IRQHandler
#define | I2C_TIMEOUT 0xFFFFFFF
#define | I2Cx_CLKCTRL 0x80504C4E
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C2
#define | I2Cx_CLK CRM_I2C2_PERIPH_CLOCK
#define | I2Cx_DMA DMA1
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_10
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE10
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_MUX GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_11
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE11
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_MUX GPIO_MUX_4
#define | I2Cx_DMA_TX_Channel DMA1_CHANNEL1
#define | I2Cx_DMA_TX_DMAMUX_Channel DMA1MUX_CHANNEL1
#define | I2Cx_DMA_TX_DMAREQ DMAMUX_DMAREQ_ID_I2C2_TX
#define | I2Cx_DMA_TX_IRQn DMA1_Channel1_IRQn
#define | I2Cx_DMA_RX_Channel DMA1_CHANNEL2
#define | I2Cx_DMA_RX_DMAMUX_Channel DMA1MUX_CHANNEL2
#define | I2Cx_DMA_RX_DMAREQ DMAMUX_DMAREQ_ID_I2C2_RX
#define | I2Cx_DMA_RX_IRQn DMA1_Channel2_IRQn
#define | I2Cx_EVT_IRQn I2C2_EVT_IRQn
#define | I2Cx_ERR_IRQn I2C2_ERR_IRQn
#define | BUF_SIZE 8
#define | I2Cx_DMA_TX_IRQHandler DMA1_Channel1_IRQHandler
#define | I2Cx_DMA_RX_IRQHandler DMA1_Channel2_IRQHandler
#define | I2Cx_EVT_IRQHandler I2C2_EVT_IRQHandler
#define | I2Cx_ERR_IRQHandler I2C2_ERR_IRQHandler
#define | I2C_TIMEOUT 0xFFFFFFF
#define | I2Cx_CLKCTRL 0x80504C4E
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C2
#define | I2Cx_CLK CRM_I2C2_PERIPH_CLOCK
#define | I2Cx_DMA DMA1
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_10
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE10
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_MUX GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_11
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE11
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_MUX GPIO_MUX_4
#define | I2Cx_DMA_TX_Channel DMA1_CHANNEL1
#define | I2Cx_DMA_TX_DMAMUX_Channel DMA1MUX_CHANNEL1
#define | I2Cx_DMA_TX_DMAREQ DMAMUX_DMAREQ_ID_I2C2_TX
#define | I2Cx_DMA_TX_IRQn DMA1_Channel1_IRQn
#define | I2Cx_DMA_RX_Channel DMA1_CHANNEL2
#define | I2Cx_DMA_RX_DMAMUX_Channel DMA1MUX_CHANNEL2
#define | I2Cx_DMA_RX_DMAREQ DMAMUX_DMAREQ_ID_I2C2_RX
#define | I2Cx_DMA_RX_IRQn DMA1_Channel2_IRQn
#define | I2Cx_EVT_IRQn I2C2_EVT_IRQn
#define | I2Cx_ERR_IRQn I2C2_ERR_IRQn
#define | BUF_SIZE 8

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel2_IRQHandler (void)
this function handles dma interrupt request. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma interrupt request. More...
void | I2C2_EVT_IRQHandler (void)
this function handles i2c event interrupt request. More...
void | I2C2_ERR_IRQHandler (void)
this function handles i2c error interrupt request. More...
void | error_handler (uint32_t error_code)
error handler program More...
uint32_t | buffer_compare (uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal. More...
int | main (void)
main function. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...

Variables

i2c_handle_type hi2cx
uint8_t | tx_buf1 [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | tx_buf2 [8] = {0x10, 0x20, 0x30, 0x40, 0x50, 0x60, 0x70, 0x80}
uint8_t | tx_buf3 [8] = {0x11, 0x22, 0x33, 0x44, 0x55, 0x66, 0x77, 0x88}
uint8_t | rx_buf1 [8] = {0}
uint8_t | rx_buf2 [8] = {0}
uint8_t | rx_buf3 [8] = {0}
i2c_handle_type hi2cx
i2c_handle_type hi2cx
uint8_t | tx_buf1 [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | tx_buf2 [8] = {0x10, 0x20, 0x30, 0x40, 0x50, 0x60, 0x70, 0x80}
uint8_t | tx_buf3 [8] = {0x11, 0x22, 0x33, 0x44, 0x55, 0x66, 0x77, 0x88}
uint8_t | rx_buf1 [8] = {0}
uint8_t | rx_buf2 [8] = {0}
uint8_t | rx_buf3 [8] = {0}
i2c_handle_type hi2cx

Detailed Description

Macro Definition Documentation

◆ BUF_SIZE [1/2]

#define BUF_SIZE 8

Definition at line 78 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ BUF_SIZE [2/2]

#define BUF_SIZE 8

Definition at line 78 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2C_TIMEOUT [1/2]

#define I2C_TIMEOUT 0xFFFFFFF

Definition at line 39 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2C_TIMEOUT [2/2]

#define I2C_TIMEOUT 0xFFFFFFF

Definition at line 39 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_ADDRESS [1/2]

#define I2Cx_ADDRESS 0xA0

Definition at line 46 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_ADDRESS [2/2]

#define I2Cx_ADDRESS 0xA0

Definition at line 46 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_CLK [1/2]

#define I2Cx_CLK CRM_I2C2_PERIPH_CLOCK

Definition at line 49 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_CLK [2/2]

#define I2Cx_CLK CRM_I2C2_PERIPH_CLOCK

Definition at line 49 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_CLKCTRL [1/2]

#define I2Cx_CLKCTRL 0x80504C4E

Definition at line 43 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_CLKCTRL [2/2]

#define I2Cx_CLKCTRL 0x80504C4E

Definition at line 43 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA [1/2]

#define I2Cx_DMA DMA1

Definition at line 50 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA [2/2]

#define I2Cx_DMA DMA1

Definition at line 50 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_CLK [1/2]

#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK

Definition at line 51 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_CLK [2/2]

#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK

Definition at line 51 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_RX_Channel [1/2]

#define I2Cx_DMA_RX_Channel DMA1_CHANNEL2

Definition at line 70 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_RX_Channel [2/2]

#define I2Cx_DMA_RX_Channel DMA1_CHANNEL2

Definition at line 70 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_RX_DMAMUX_Channel [1/2]

#define I2Cx_DMA_RX_DMAMUX_Channel DMA1MUX_CHANNEL2

Definition at line 71 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_RX_DMAMUX_Channel [2/2]

#define I2Cx_DMA_RX_DMAMUX_Channel DMA1MUX_CHANNEL2

Definition at line 71 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_RX_DMAREQ [1/2]

#define I2Cx_DMA_RX_DMAREQ DMAMUX_DMAREQ_ID_I2C2_RX

Definition at line 72 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_RX_DMAREQ [2/2]

#define I2Cx_DMA_RX_DMAREQ DMAMUX_DMAREQ_ID_I2C2_RX

Definition at line 72 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_RX_IRQHandler [1/2]

#define I2Cx_DMA_RX_IRQHandler DMA1_Channel2_IRQHandler

Definition at line 42 of file project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c.

◆ I2Cx_DMA_RX_IRQHandler [2/2]

#define I2Cx_DMA_RX_IRQHandler DMA1_Channel2_IRQHandler

Definition at line 42 of file project/at_start_f437/examples/i2c/eeprom/src/at32f435_437_int.c.

◆ I2Cx_DMA_RX_IRQn [1/2]

#define I2Cx_DMA_RX_IRQn DMA1_Channel2_IRQn

Definition at line 73 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_RX_IRQn [2/2]

#define I2Cx_DMA_RX_IRQn DMA1_Channel2_IRQn

Definition at line 73 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_TX_Channel [1/2]

#define I2Cx_DMA_TX_Channel DMA1_CHANNEL1

Definition at line 65 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_TX_Channel [2/2]

#define I2Cx_DMA_TX_Channel DMA1_CHANNEL1

Definition at line 65 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_TX_DMAMUX_Channel [1/2]

#define I2Cx_DMA_TX_DMAMUX_Channel DMA1MUX_CHANNEL1

Definition at line 66 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_TX_DMAMUX_Channel [2/2]

#define I2Cx_DMA_TX_DMAMUX_Channel DMA1MUX_CHANNEL1

Definition at line 66 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_TX_DMAREQ [1/2]

#define I2Cx_DMA_TX_DMAREQ DMAMUX_DMAREQ_ID_I2C2_TX

Definition at line 67 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_TX_DMAREQ [2/2]

#define I2Cx_DMA_TX_DMAREQ DMAMUX_DMAREQ_ID_I2C2_TX

Definition at line 67 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_TX_IRQHandler [1/2]

#define I2Cx_DMA_TX_IRQHandler DMA1_Channel1_IRQHandler

Definition at line 41 of file project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c.

◆ I2Cx_DMA_TX_IRQHandler [2/2]

#define I2Cx_DMA_TX_IRQHandler DMA1_Channel1_IRQHandler

Definition at line 41 of file project/at_start_f437/examples/i2c/eeprom/src/at32f435_437_int.c.

◆ I2Cx_DMA_TX_IRQn [1/2]

#define I2Cx_DMA_TX_IRQn DMA1_Channel1_IRQn

Definition at line 68 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_TX_IRQn [2/2]

#define I2Cx_DMA_TX_IRQn DMA1_Channel1_IRQn

Definition at line 68 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_ERR_IRQHandler [1/2]

#define I2Cx_ERR_IRQHandler I2C2_ERR_IRQHandler

Definition at line 44 of file project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c.

◆ I2Cx_ERR_IRQHandler [2/2]

#define I2Cx_ERR_IRQHandler I2C2_ERR_IRQHandler

Definition at line 44 of file project/at_start_f437/examples/i2c/eeprom/src/at32f435_437_int.c.

◆ I2Cx_ERR_IRQn [1/2]

#define I2Cx_ERR_IRQn I2C2_ERR_IRQn

Definition at line 76 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_ERR_IRQn [2/2]

#define I2Cx_ERR_IRQn I2C2_ERR_IRQn

Definition at line 76 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_EVT_IRQHandler [1/2]

#define I2Cx_EVT_IRQHandler I2C2_EVT_IRQHandler

Definition at line 43 of file project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c.

◆ I2Cx_EVT_IRQHandler [2/2]

#define I2Cx_EVT_IRQHandler I2C2_EVT_IRQHandler

Definition at line 43 of file project/at_start_f437/examples/i2c/eeprom/src/at32f435_437_int.c.

◆ I2Cx_EVT_IRQn [1/2]

#define I2Cx_EVT_IRQn I2C2_EVT_IRQn

Definition at line 75 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_EVT_IRQn [2/2]

#define I2Cx_EVT_IRQn I2C2_EVT_IRQn

Definition at line 75 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_PORT [1/2]

#define I2Cx_PORT I2C2

Definition at line 48 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_PORT [2/2]

#define I2Cx_PORT I2C2

Definition at line 48 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SCL_GPIO_CLK [1/2]

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 53 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SCL_GPIO_CLK [2/2]

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 53 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SCL_GPIO_MUX [1/2]

#define I2Cx_SCL_GPIO_MUX GPIO_MUX_4

Definition at line 57 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SCL_GPIO_MUX [2/2]

#define I2Cx_SCL_GPIO_MUX GPIO_MUX_4

Definition at line 57 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SCL_GPIO_PIN [1/2]

#define I2Cx_SCL_GPIO_PIN GPIO_PINS_10

Definition at line 54 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SCL_GPIO_PIN [2/2]

#define I2Cx_SCL_GPIO_PIN GPIO_PINS_10

Definition at line 54 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SCL_GPIO_PinsSource [1/2]

#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE10

Definition at line 55 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SCL_GPIO_PinsSource [2/2]

#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE10

Definition at line 55 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SCL_GPIO_PORT [1/2]

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 56 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SCL_GPIO_PORT [2/2]

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 56 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SDA_GPIO_CLK [1/2]

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 59 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SDA_GPIO_CLK [2/2]

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 59 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SDA_GPIO_MUX [1/2]

#define I2Cx_SDA_GPIO_MUX GPIO_MUX_4

Definition at line 63 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SDA_GPIO_MUX [2/2]

#define I2Cx_SDA_GPIO_MUX GPIO_MUX_4

Definition at line 63 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SDA_GPIO_PIN [1/2]

#define I2Cx_SDA_GPIO_PIN GPIO_PINS_11

Definition at line 60 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SDA_GPIO_PIN [2/2]

#define I2Cx_SDA_GPIO_PIN GPIO_PINS_11

Definition at line 60 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SDA_GPIO_PinsSource [1/2]

#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE11

Definition at line 61 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SDA_GPIO_PinsSource [2/2]

#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE11

Definition at line 61 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SDA_GPIO_PORT [1/2]

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 62 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SDA_GPIO_PORT [2/2]

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 62 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

Function Documentation

◆ buffer_compare()

uint32_t buffer_compare | ( | uint8_t * | buffer1,
 |  | uint8_t * | buffer2,
 |  | uint32_t | len
 | ) |  |

compare whether the valus of buffer 1 and buffer 2 are equal.

Parameters
buffer1 buffer 1 address. buffer2: buffer 2 address.
Return values
0 equal. 1: unequal.

Definition at line 110 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 86 of file project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma interrupt request.

Parameters
none
Return values
none

Definition at line 158 of file project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c.

◆ DMA1_Channel2_IRQHandler()

void DMA1_Channel2_IRQHandler ( void )

this function handles dma interrupt request.

Parameters
none
Return values
none

Definition at line 148 of file project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c.

◆ error_handler()

void error_handler ( uint32_t error_code )

error handler program

Parameters
i2c_status
Return values
none

Definition at line 94 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 60 of file project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c.

◆ I2C2_ERR_IRQHandler()

void I2C2_ERR_IRQHandler ( void )

this function handles i2c error interrupt request.

Parameters
none
Return values
none

Definition at line 178 of file project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c.

◆ I2C2_EVT_IRQHandler()

void I2C2_EVT_IRQHandler ( void )

this function handles i2c event interrupt request.

Parameters
none
Return values
none

Definition at line 168 of file project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c.

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
none
Return values
none

< gpio pins number 10

< gpio pins number 11

< gpio pins number 10

< gpio pins number 11

Definition at line 240 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 73 of file project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 139 of file project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 99 of file project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c.

Variable Documentation

◆ hi2cx [1/4]

i2c_handle_type hi2cx
extern

Definition at line 37 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

Referenced by DMA1_Channel1_IRQHandler(), DMA1_Channel2_IRQHandler(), I2C2_ERR_IRQHandler(), and I2C2_EVT_IRQHandler().

◆ hi2cx [2/4]

i2c_handle_type hi2cx

Definition at line 87 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ hi2cx [3/4]

i2c_handle_type hi2cx
extern

Definition at line 37 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c.

Referenced by audio_codec_init(), audio_codec_loop(), audio_codec_modify_freq(), main(), ov2640_i2c_init(), ov2640_reg_read(), ov2640_reg_write(), ov5640_i2c_init(), ov5640_reg_read(), and ov5640_reg_write().

◆ hi2cx [4/4]

i2c_handle_type hi2cx

Definition at line 87 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ rx_buf1 [1/2]

uint8_t rx_buf1[8] = {0}

Definition at line 83 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ rx_buf1 [2/2]

uint8_t rx_buf1[8] = {0}

Definition at line 83 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ rx_buf2 [1/2]

uint8_t rx_buf2[8] = {0}

Definition at line 84 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ rx_buf2 [2/2]

uint8_t rx_buf2[8] = {0}

Definition at line 84 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ rx_buf3 [1/2]

uint8_t rx_buf3[8] = {0}

Definition at line 85 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ rx_buf3 [2/2]

uint8_t rx_buf3[8] = {0}

Definition at line 85 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ tx_buf1 [1/2]

uint8_t tx_buf1[8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}

Definition at line 80 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ tx_buf1 [2/2]

uint8_t tx_buf1[8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}

Definition at line 80 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ tx_buf2 [1/2]

uint8_t tx_buf2[8] = {0x10, 0x20, 0x30, 0x40, 0x50, 0x60, 0x70, 0x80}

Definition at line 81 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ tx_buf2 [2/2]

uint8_t tx_buf2[8] = {0x10, 0x20, 0x30, 0x40, 0x50, 0x60, 0x70, 0x80}

Definition at line 81 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.

◆ tx_buf3 [1/2]

uint8_t tx_buf3[8] = {0x11, 0x22, 0x33, 0x44, 0x55, 0x66, 0x77, 0x88}

Definition at line 82 of file project/at_start_f435/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ tx_buf3 [2/2]

uint8_t tx_buf3[8] = {0x11, 0x22, 0x33, 0x44, 0x55, 0x66, 0x77, 0x88}

Definition at line 82 of file project/at_start_f437/examples/i2c/eeprom/src/main.c.


AT32F435/437 Firmwary Library: I2S_fullduplex_dma

Macros | Functions | Variables
I2S_fullduplex_dma
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | TXBUF_SIZE 32
#define | RXBUF_SIZE TXBUF_SIZE
#define | TXBUF_SIZE 32
#define | RXBUF_SIZE TXBUF_SIZE

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | i2s_config (void)
i2s configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

uint16_t | i2s2_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
uint16_t | i2s3_buffer_tx [32]
uint16_t | i2s3_buffer_rx [32]
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR
uint16_t | i2s2_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
uint16_t | i2s3_buffer_tx [32]
uint16_t | i2s3_buffer_rx [32]
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR

Detailed Description

Macro Definition Documentation

◆ RXBUF_SIZE [1/2]

#define RXBUF_SIZE TXBUF_SIZE

Definition at line 39 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c.

◆ RXBUF_SIZE [2/2]

#define RXBUF_SIZE TXBUF_SIZE

Definition at line 39 of file project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c.

◆ TXBUF_SIZE [1/2]

#define TXBUF_SIZE 32

Definition at line 38 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c.

◆ TXBUF_SIZE [2/2]

#define TXBUF_SIZE 32

Definition at line 38 of file project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint16_t * | pbuffer1,
 |  | uint16_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer compare function.

Parameters
none
Return values
the result of compare

Definition at line 57 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 0

< gpio pins number 1

< gpio pins number 2

< gpio pins number 4

< gpio pins number 4

< gpio pins number 10

< gpio pins number 11

< gpio pins number 12

Definition at line 171 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c.

◆ i2s_config()

static void i2s_config ( void )
static

i2s configuration.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c.

Referenced by main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< dma1 channel2 full data transfer flag

< dma1 channel2 full data transfer flag

Definition at line 235 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c.

Variable Documentation

◆ i2s2_buffer_rx [1/2]

uint16_t i2s2_buffer_rx[ 32]

Definition at line 42 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c.

Referenced by i2s_config(), and main().

◆ i2s2_buffer_rx [2/2]

uint16_t i2s2_buffer_rx[ 32]

Definition at line 42 of file project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c.

Referenced by i2s_config().

◆ i2s2_buffer_tx [1/2]

uint16_t i2s2_buffer_tx[32]

Definition at line 41 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c.

Referenced by i2s_config(), main(), and tx_data_fill().

◆ i2s2_buffer_tx [2/2]

uint16_t i2s2_buffer_tx[32]

Definition at line 41 of file project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c.

Referenced by i2s_config().

◆ i2s3_buffer_rx [1/2]

uint16_t i2s3_buffer_rx[ 32]

Definition at line 44 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c.

Referenced by i2s_config(), and main().

◆ i2s3_buffer_rx [2/2]

uint16_t i2s3_buffer_rx[ 32]

Definition at line 44 of file project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c.

Referenced by i2s_config().

◆ i2s3_buffer_tx [1/2]

uint16_t i2s3_buffer_tx[32]

Definition at line 43 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c.

Referenced by i2s_config(), main(), and tx_data_fill().

◆ i2s3_buffer_tx [2/2]

uint16_t i2s3_buffer_tx[32]

Definition at line 43 of file project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c.

Referenced by i2s_config().

◆ transfer_status1 [1/2]

volatile error_status transfer_status1 = ERROR

Definition at line 45 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c.

Referenced by main().

◆ transfer_status1 [2/2]

volatile error_status transfer_status1 = ERROR

Definition at line 45 of file project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c.

◆ transfer_status2 [1/2]

volatile error_status transfer_status2 = ERROR

Definition at line 45 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c.

Referenced by main().

◆ transfer_status2 [2/2]

volatile error_status transfer_status2 = ERROR

Definition at line 45 of file project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c.


AT32F435/437 Firmwary Library: I2S_halfduplex_dma

Functions | Variables
I2S_halfduplex_dma
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | i2s_config (void)
i2s configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function. More...
int | main (void)
main function. More...

Variables

uint16_t | i2s3_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
volatile error_status | transfer_status = ERROR
uint16_t | i2s3_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
volatile error_status | transfer_status = ERROR

Detailed Description

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint16_t * | pbuffer1,
 |  | uint16_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer_compare function.

Parameters
none
Return values
the result of compare

Definition at line 56 of file project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 10

< gpio pins number 12

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

< gpio pins number 4

Definition at line 133 of file project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c.

◆ i2s_config()

static void i2s_config ( void )
static

i2s configuration.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c.

Referenced by main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 191 of file project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c.

Variable Documentation

◆ i2s2_buffer_rx [1/2]

uint16_t i2s2_buffer_rx[32]

Definition at line 44 of file project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c.

Referenced by i2s_config(), and main().

◆ i2s2_buffer_rx [2/2]

uint16_t i2s2_buffer_rx[32]

Definition at line 44 of file project/at_start_f437/examples/i2s/halfduplex_dma/src/main.c.

Referenced by i2s_config().

◆ i2s3_buffer_tx [1/2]

uint16_t i2s3_buffer_tx[32]
Initial value:
= {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C,
0x0D0E, 0x0F10, 0x1112, 0x1314, 0x1516, 0x1718,
0x191A, 0x1B1C, 0x1D1E, 0x1F20, 0x2122, 0x2324,
0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C,
0x3D3E, 0x3F40}

Definition at line 38 of file project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c.

Referenced by i2s_config(), and main().

◆ i2s3_buffer_tx [2/2]

uint16_t i2s3_buffer_tx[32]
Initial value:
= {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C,
0x0D0E, 0x0F10, 0x1112, 0x1314, 0x1516, 0x1718,
0x191A, 0x1B1C, 0x1D1E, 0x1F20, 0x2122, 0x2324,
0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C,
0x3D3E, 0x3F40}

Definition at line 38 of file project/at_start_f437/examples/i2s/halfduplex_dma/src/main.c.

Referenced by i2s_config().

◆ transfer_status [1/2]

volatile error_status transfer_status = ERROR

Definition at line 45 of file project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c.

Referenced by main().

◆ transfer_status [2/2]

volatile error_status transfer_status = ERROR

Definition at line 45 of file project/at_start_f437/examples/i2s/halfduplex_dma/src/main.c.


AT32F435/437 Firmwary Library: I2S_halfduplex_interrupt

Functions | Variables
I2S_halfduplex_interrupt
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | SPI2_I2S2EXT_IRQHandler (void)
This function handles the spi2 interrupt request. More...
void | SPI3_I2S3EXT_IRQHandler (void)
This function handles the spi3 interrupt request. More...
static void | gpio_config (void)
gpio configuration. More...
static void | i2s_config (i2s_data_channel_format_type format, i2s_audio_sampling_freq_type freq)
i2s configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function. More...
error_status | buffer_compare_24bits (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare_24bits function. More...
int | main (void)
main function. More...

Variables

uint16_t | i2s3_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
__IO uint32_t | tx_index
__IO uint32_t | rx_index
uint16_t | i2s3_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
__IO uint32_t | tx_index = 0
__IO uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR
uint16_t | i2s3_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
__IO uint32_t | tx_index
__IO uint32_t | rx_index
uint16_t | i2s3_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
__IO uint32_t | tx_index = 0
__IO uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR

Detailed Description

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint16_t * | pbuffer1,
 |  | uint16_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer_compare function.

Parameters
none
Return values
the result of compare

Definition at line 58 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ buffer_compare_24bits()

error_status buffer_compare_24bits | ( | uint16_t * | pbuffer1,
 |  | uint16_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer_compare_24bits function.

Parameters
none
Return values
the result of compare

Definition at line 78 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 82 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 117 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 15

< gpio pins number 3

< gpio pins number 5

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

< gpio pins number 4

Definition at line 135 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 56 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c.

◆ i2s_config()

static void i2s_config | ( | i2s_data_channel_format_type | format,
 |  | i2s_audio_sampling_freq_type | freq
 | ) |  |
static

i2s configuration.

Parameters
none
Return values
none

< receive data buffer full interrupt

< transmit data buffer empty interrupt

Definition at line 101 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 194 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 69 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 47 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 126 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c.

◆ SPI2_I2S2EXT_IRQHandler()

void SPI2_I2S2EXT_IRQHandler ( void )

This function handles the spi2 interrupt request.

Parameters
None
Return values
None

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

Definition at line 144 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c.

◆ SPI3_I2S3EXT_IRQHandler()

void SPI3_I2S3EXT_IRQHandler ( void )

This function handles the spi3 interrupt request.

Parameters
None
Return values
None

< spi or i2s transmit data buffer empty flag

< transmit data buffer empty interrupt

< spi or i2s transmit data buffer empty flag

< transmit data buffer empty interrupt

Definition at line 157 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 108 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 135 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 95 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c.

Variable Documentation

◆ i2s2_buffer_rx [1/4]

uint16_t i2s2_buffer_rx[32]
extern

Definition at line 42 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c.

Referenced by SPI2_I2S2EXT_IRQHandler().

◆ i2s2_buffer_rx [2/4]

uint16_t i2s2_buffer_rx[32]

Definition at line 44 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ i2s2_buffer_rx [3/4]

uint16_t i2s2_buffer_rx[32]
extern

Definition at line 42 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c.

Referenced by i2s_config(), and main().

◆ i2s2_buffer_rx [4/4]

uint16_t i2s2_buffer_rx[32]

Definition at line 44 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/src/main.c.

◆ i2s3_buffer_tx [1/4]

uint16_t i2s3_buffer_tx[32]
extern

Definition at line 43 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c.

Referenced by SPI3_I2S3EXT_IRQHandler().

◆ i2s3_buffer_tx [2/4]

uint16_t i2s3_buffer_tx[32]
Initial value:
= {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C,
0x0D0E, 0x0F10, 0x1112, 0x1314, 0x1516, 0x1718,
0x191A, 0x1B1C, 0x1D1E, 0x1F20, 0x2122, 0x2324,
0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C,
0x3D3E, 0x3F40}

Definition at line 38 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ i2s3_buffer_tx [3/4]

uint16_t i2s3_buffer_tx[32]
extern

Definition at line 43 of file project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c.

Referenced by i2s_config(), main(), and tx_data_fill().

◆ i2s3_buffer_tx [4/4]

uint16_t i2s3_buffer_tx[32]
Initial value:
= {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C,
0x0D0E, 0x0F10, 0x1112, 0x1314, 0x1516, 0x1718,
0x191A, 0x1B1C, 0x1D1E, 0x1F20, 0x2122, 0x2324,
0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C,
0x3D3E, 0x3F40}

Definition at line 38 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/src/main.c.

◆ rx_index [1/4]

__IO uint32_t rx_index

Definition at line 40 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c.

Referenced by SPI2_I2S2EXT_IRQHandler().

◆ rx_index [2/4]

__IO uint32_t rx_index = 0

Definition at line 45 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ rx_index [3/4]

__IO uint32_t rx_index

Definition at line 40 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c.

◆ rx_index [4/4]

__IO uint32_t rx_index = 0

Definition at line 45 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/src/main.c.

◆ transfer_status1 [1/2]

volatile error_status transfer_status1 = ERROR

Definition at line 46 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ transfer_status1 [2/2]

volatile error_status transfer_status1 = ERROR

Definition at line 46 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/src/main.c.

◆ transfer_status2 [1/2]

volatile error_status transfer_status2 = ERROR

Definition at line 46 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ transfer_status2 [2/2]

volatile error_status transfer_status2 = ERROR

Definition at line 46 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/src/main.c.

◆ tx_index [1/4]

__IO uint32_t tx_index
extern

Definition at line 45 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by SPI3_I2S3EXT_IRQHandler().

◆ tx_index [2/4]

__IO uint32_t tx_index = 0

Definition at line 45 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ tx_index [3/4]

__IO uint32_t tx_index
extern

Definition at line 45 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c.

◆ tx_index [4/4]

__IO uint32_t tx_index = 0

Definition at line 45 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/src/main.c.


AT32F435/437 Firmwary Library: I2S_spii2s_switch_halfduplex_polling

Functions | Variables
I2S_spii2s_switch_halfduplex_polling
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
static void | i2s_config (i2s_operation_mode_type i2s3_mode, i2s_operation_mode_type i2s2_mode)
i2s configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function. More...
int | main (void)
main function. More...

Variables

uint16_t | i2s3_buffer_tx [32]
uint16_t | spi3_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
uint16_t | spi2_buffer_rx [32]
__IO uint32_t | tx_index = 0
__IO uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR
volatile error_status | transfer_status3 = ERROR
uint16_t | i2s3_buffer_tx [32]
uint16_t | spi3_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
uint16_t | spi2_buffer_rx [32]
__IO uint32_t | tx_index = 0
__IO uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR
volatile error_status | transfer_status3 = ERROR

Detailed Description

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint16_t * | pbuffer1,
 |  | uint16_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer_compare function.

Parameters
none
Return values
the result of compare

Definition at line 67 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 15

< gpio pins number 3

< gpio pins number 5

< gpio pins number 0

< gpio pins number 1

< gpio pins number 4

Definition at line 146 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c.

◆ i2s_config()

static void i2s_config | ( | i2s_operation_mode_type | i2s3_mode,
 |  | i2s_operation_mode_type | i2s2_mode
 | ) |  |
static

i2s configuration.

Parameters
none
Return values
none

Definition at line 87 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s transmit data buffer empty flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s transmit data buffer empty flag

Definition at line 198 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c.

◆ spi_config()

static void spi_config ( void )
static

spi configuration.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c.

Variable Documentation

◆ i2s2_buffer_rx [1/2]

uint16_t i2s2_buffer_rx[32]

Definition at line 52 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ i2s2_buffer_rx [2/2]

uint16_t i2s2_buffer_rx[32]

Definition at line 52 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by SPI2_I2S2EXT_IRQHandler().

◆ i2s3_buffer_tx [1/2]

uint16_t i2s3_buffer_tx[32]
Initial value:
= {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C,
0x0D0E, 0x0F10, 0x1112, 0x1314, 0x1516, 0x1718,
0x191A, 0x1B1C, 0x1D1E, 0x1F20, 0x2122, 0x2324,
0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C,
0x3D3E, 0x3F40
}

Definition at line 38 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ i2s3_buffer_tx [2/2]

uint16_t i2s3_buffer_tx[32]
Initial value:
= {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C,
0x0D0E, 0x0F10, 0x1112, 0x1314, 0x1516, 0x1718,
0x191A, 0x1B1C, 0x1D1E, 0x1F20, 0x2122, 0x2324,
0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C,
0x3D3E, 0x3F40
}

Definition at line 38 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by SPI3_I2S3EXT_IRQHandler().

◆ rx_index [1/2]

__IO uint32_t rx_index = 0

Definition at line 54 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ rx_index [2/2]

__IO uint32_t rx_index = 0

Definition at line 54 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

◆ spi2_buffer_rx [1/2]

uint16_t spi2_buffer_rx[32]

Definition at line 53 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ spi2_buffer_rx [2/2]

uint16_t spi2_buffer_rx[32]

Definition at line 53 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

◆ spi3_buffer_tx [1/2]

uint16_t spi3_buffer_tx[32]
Initial value:
= {0x5152, 0x5354, 0x5556, 0x5758, 0x595A, 0x5B5C,
0x5D5E, 0x5F60, 0x6162, 0x6364, 0x6566, 0x6768,
0x696A, 0x6B6C, 0x6D6E, 0x6F70, 0x7172, 0x7374,
0x7576, 0x7778, 0x797A, 0x7B7C, 0x7D7E, 0x7F80,
0x8182, 0x8384, 0x8586, 0x8788, 0x898A, 0x8B8C,
0x8D8E, 0x8F90
}

Definition at line 45 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ spi3_buffer_tx [2/2]

uint16_t spi3_buffer_tx[32]
Initial value:
= {0x5152, 0x5354, 0x5556, 0x5758, 0x595A, 0x5B5C,
0x5D5E, 0x5F60, 0x6162, 0x6364, 0x6566, 0x6768,
0x696A, 0x6B6C, 0x6D6E, 0x6F70, 0x7172, 0x7374,
0x7576, 0x7778, 0x797A, 0x7B7C, 0x7D7E, 0x7F80,
0x8182, 0x8384, 0x8586, 0x8788, 0x898A, 0x8B8C,
0x8D8E, 0x8F90
}

Definition at line 45 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

◆ transfer_status1 [1/2]

volatile error_status transfer_status1 = ERROR

Definition at line 55 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ transfer_status1 [2/2]

volatile error_status transfer_status1 = ERROR

Definition at line 55 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

◆ transfer_status2 [1/2]

volatile error_status transfer_status2 = ERROR

Definition at line 55 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ transfer_status2 [2/2]

volatile error_status transfer_status2 = ERROR

Definition at line 55 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

◆ transfer_status3 [1/2]

volatile error_status transfer_status3 = ERROR

Definition at line 55 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ transfer_status3 [2/2]

volatile error_status transfer_status3 = ERROR

Definition at line 55 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

◆ tx_index [1/2]

__IO uint32_t tx_index = 0

Definition at line 54 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ tx_index [2/2]

__IO uint32_t tx_index = 0

Definition at line 54 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.


AT32F435/437 Firmwary Library: IRTMR_output

Functions | Variables
IRTMR_output
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | ccr1_val = 249
uint16_t | ccr2_val = 24
uint16_t | prescalervalue = 0
tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | ccr1_val = 249
uint16_t | ccr2_val = 24
uint16_t | prescalervalue = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f435/examples/irtmr/irtmr_output/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c.

Variable Documentation

◆ ccr1_val [1/2]

uint16_t ccr1_val = 249

Definition at line 41 of file project/at_start_f435/examples/irtmr/irtmr_output/src/main.c.

Referenced by main().

◆ ccr1_val [2/2]

uint16_t ccr1_val = 249

Definition at line 41 of file project/at_start_f437/examples/irtmr/irtmr_output/src/main.c.

◆ ccr2_val [1/2]

uint16_t ccr2_val = 24

Definition at line 42 of file project/at_start_f435/examples/irtmr/irtmr_output/src/main.c.

Referenced by main().

◆ ccr2_val [2/2]

uint16_t ccr2_val = 24

Definition at line 42 of file project/at_start_f437/examples/irtmr/irtmr_output/src/main.c.

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f435/examples/irtmr/irtmr_output/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f437/examples/irtmr/irtmr_output/src/main.c.

◆ prescalervalue [1/2]

uint16_t prescalervalue = 0

Definition at line 43 of file project/at_start_f435/examples/irtmr/irtmr_output/src/main.c.

Referenced by main().

◆ prescalervalue [2/2]

uint16_t prescalervalue = 0

Definition at line 43 of file project/at_start_f437/examples/irtmr/irtmr_output/src/main.c.

◆ tmr_oc_init_structure [1/2]

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f435/examples/irtmr/irtmr_output/src/main.c.

Referenced by main(), mclk_tmr1_init(), and tmr1_config().

◆ tmr_oc_init_structure [2/2]

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f437/examples/irtmr/irtmr_output/src/main.c.


AT32F435/437 Firmwary Library: PWC_deepsleep_ertc_alarm

Functions
PWC_deepsleep_ertc_alarm
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ERTCAlarm_IRQHandler (void)
this function handles ertc alarms interrupt request. More...
void | ertc_config (void)
ertc configuration. More...
void | ertc_alarm_config (void)
ertc alarm configuration. More...
void | ertc_alarm_value_set (uint32_t alam_index)
ertc alarm value set. More...
void | system_clock_recover (void)
system clock recover. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c.

◆ ertc_alarm_config()

void ertc_alarm_config ( void )

ertc alarm configuration.

Parameters
none
Return values
none

< external interrupt line 17

< ertc alarm don't match date or week

< ertc alarm don't match hour

< ertc alarm don't match minute

< ertc alarm a interrupt

< external interrupt line 17

< ertc alarm don't match date or week

< ertc alarm don't match hour

< ertc alarm don't match minute

< ertc alarm a interrupt

Definition at line 92 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c.

Referenced by main().

◆ ertc_alarm_value_set()

void ertc_alarm_value_set ( uint32_t alam_index )

ertc alarm value set.

Parameters
alam_index : ERTC Alarm Seconds value
Return values
none

Definition at line 123 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c.

Referenced by main().

◆ ertc_config()

void ertc_config ( void )

ertc configuration.

Parameters
none
Return values
none

< low speed external crystal stable flag

< low speed external crystal stable flag

Definition at line 43 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c.

Referenced by main().

◆ ERTCAlarm_IRQHandler()

void ERTCAlarm_IRQHandler ( void )

this function handles ertc alarms interrupt request.

Parameters
none
Return values
none

< ertc alarm clock a flag

< ertc alarm clock a flag

< external interrupt line 17

< ertc alarm clock a flag

< ertc alarm clock a flag

< external interrupt line 17

Definition at line 141 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 170 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c.

◆ system_clock_recover()

void system_clock_recover ( void )

system clock recover.

Parameters
none
Return values
none

< phase locking loop stable flag

< phase locking loop stable flag

Definition at line 141 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c.

Referenced by main().

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: PWC_deepsleep_ertc_tamper

Functions
PWC_deepsleep_ertc_tamper
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TAMP_STAMP_IRQHandler (void)
this function handles ertc tamper interrupt request. More...
void | ertc_config (void)
ertc configuration. More...
void | ertc_tamper_config (void)
ertc tamper configuration. More...
void | system_clock_recover (void)
system clock recover. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c.

◆ ertc_config()

void ertc_config ( void )

ertc configuration.

Parameters
none
Return values
none

< low speed external crystal stable flag

< low speed external crystal stable flag

Definition at line 43 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/main.c.

Referenced by main().

◆ ertc_tamper_config()

void ertc_tamper_config ( void )

ertc tamper configuration.

Parameters
none
Return values
none

< external interrupt line 21

< ertc tamper detection 1 flag

< ertc tamper interrupt

< external interrupt line 21

< ertc tamper detection 1 flag

< ertc tamper interrupt

Definition at line 76 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 140 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c.

◆ system_clock_recover()

void system_clock_recover ( void )

system clock recover.

Parameters
none
Return values
none

< phase locking loop stable flag

< phase locking loop stable flag

Definition at line 111 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/main.c.

Referenced by main().

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c.

◆ TAMP_STAMP_IRQHandler()

void TAMP_STAMP_IRQHandler ( void )

this function handles ertc tamper interrupt request.

Parameters
none
Return values
none

< ertc tamper detection 1 flag

< ertc tamper detection 1 flag

< external interrupt line 21

< ertc tamper detection 1 flag

< ertc tamper detection 1 flag

< external interrupt line 21

Definition at line 141 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: PWC_deepsleep_ertc_wakeup

Functions
PWC_deepsleep_ertc_wakeup
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ERTC_WKUP_IRQHandler (void)
this function handles ertc wakeup timer interrupt request. More...
void | ertc_config (void)
ertc configuration. More...
void | ertc_wakeup_timer_config (void)
ertc wakeup timer configuration. More...
void | system_clock_recover (void)
system clock recover. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c.

◆ ertc_config()

void ertc_config ( void )

ertc configuration.

Parameters
none
Return values
none

< low speed external crystal stable flag

< low speed external crystal stable flag

Definition at line 43 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/main.c.

Referenced by main().

◆ ertc_wakeup_timer_config()

void ertc_wakeup_timer_config ( void )

ertc wakeup timer configuration.

Parameters
none
Return values
none

< external interrupt line 22

< ertc wakeup timer interrupt

< external interrupt line 22

< ertc wakeup timer interrupt

Definition at line 92 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/main.c.

Referenced by main().

◆ ERTC_WKUP_IRQHandler()

void ERTC_WKUP_IRQHandler ( void )

this function handles ertc wakeup timer interrupt request.

Parameters
none
Return values
none

< ertc wakeup timer flag

< ertc wakeup timer flag

< external interrupt line 22

< ertc wakeup timer flag

< ertc wakeup timer flag

< external interrupt line 22

Definition at line 141 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 153 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c.

◆ system_clock_recover()

void system_clock_recover ( void )

system clock recover.

Parameters
none
Return values
none

< phase locking loop stable flag

< phase locking loop stable flag

Definition at line 124 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/main.c.

Referenced by main().

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: PWC_ldo_set

Functions
PWC_ldo_set
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TAMP_STAMP_IRQHandler (void)
this function handles ertc tamper interrupt request. More...
void | ertc_config (void)
ertc configuration. More...
void | ertc_tamper_config (void)
ertc tamper configuration. More...
void | system_clock_recover (void)
system clock recover. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c.

◆ ertc_config()

void ertc_config ( void )

ertc configuration.

Parameters
none
Return values
none

< low speed external crystal stable flag

< low speed external crystal stable flag

Definition at line 43 of file project/at_start_f435/examples/pwc/ldo_set/src/main.c.

Referenced by main().

◆ ertc_tamper_config()

void ertc_tamper_config ( void )

ertc tamper configuration.

Parameters
none
Return values
none

< external interrupt line 21

< ertc tamper detection 1 flag

< ertc tamper interrupt

< external interrupt line 21

< ertc tamper detection 1 flag

< ertc tamper interrupt

Definition at line 76 of file project/at_start_f435/examples/pwc/ldo_set/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 141 of file project/at_start_f435/examples/pwc/ldo_set/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c.

◆ system_clock_recover()

void system_clock_recover ( void )

system clock recover.

Parameters
none
Return values
none

< phase locking loop stable flag

< phase locking loop stable flag

Definition at line 111 of file project/at_start_f435/examples/pwc/ldo_set/src/main.c.

Referenced by main().

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c.

◆ TAMP_STAMP_IRQHandler()

void TAMP_STAMP_IRQHandler ( void )

this function handles ertc tamper interrupt request.

Parameters
none
Return values
none

< ertc tamper detection 1 flag

< ertc tamper detection 1 flag

< external interrupt line 21

< ertc tamper detection 1 flag

< ertc tamper detection 1 flag

< external interrupt line 21

Definition at line 141 of file project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: PWC_power_voltage_monitor

Functions
PWC_power_voltage_monitor
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | PVM_IRQHandler (void)
This function handles the power voltage monitoring output interrupt request. More...
void | pvm_exint_config (void)
power voltage monitor exint configuration. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 60 of file project/at_start_f435/examples/pwc/power_voltage_monitor/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c.

◆ pvm_exint_config()

void pvm_exint_config ( void )

power voltage monitor exint configuration.

Parameters
none
Return values
none

< external interrupt line 16

< external interrupt line 16

Definition at line 43 of file project/at_start_f435/examples/pwc/power_voltage_monitor/src/main.c.

Referenced by main().

◆ PVM_IRQHandler()

void PVM_IRQHandler ( void )

This function handles the power voltage monitoring output interrupt request.

Parameters
None
Return values
None

< external interrupt line 16

< external interrupt line 16

< external interrupt line 16

< external interrupt line 16

Definition at line 141 of file project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: PWC_sleep_tmr2

Functions
PWC_sleep_tmr2
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR2_GLOBAL_IRQHandler (void)
This function handles the power voltage monitoring output interrupt request. More...
void | tmr2_config (void)
tmr2 configuration. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f435/examples/pwc/sleep_tmr2/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c.

◆ tmr2_config()

void tmr2_config ( void )

tmr2 configuration.

Parameters
none
Return values
none

< tmr interrupt overflow

< tmr interrupt overflow

Definition at line 43 of file project/at_start_f435/examples/pwc/sleep_tmr2/src/main.c.

Referenced by main().

◆ TMR2_GLOBAL_IRQHandler()

void TMR2_GLOBAL_IRQHandler ( void )

This function handles the power voltage monitoring output interrupt request.

this function handles tmr2 global interrupt request.

this function handles TMR2 trigger exception.

Parameters
None
Return values
None
Parameters
none
Return values
none

< tmr flag overflow

< tmr flag overflow

< tmr flag overflow

< tmr flag overflow

Definition at line 141 of file project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: PWC_sleep_usart1

Functions | Variables
PWC_sleep_usart1
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | USART1_IRQHandler (void)
this function handles the usatt interrupt request. More...
void | usart1_config (uint32_t baudrate)
usart1 configuration. More...
int | main (void)
main function. More...

Variables

uint16_t | usart1_index = 0
uint16_t | usart1_index = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 80 of file project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 115 of file project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 54 of file project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 88 of file project/at_start_f435/examples/pwc/sleep_usart1/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 67 of file project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 45 of file project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 124 of file project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 106 of file project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 133 of file project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 93 of file project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c.

◆ usart1_config()

void usart1_config ( uint32_t baudrate )

usart1 configuration.

Parameters
none
Return values
none

< gpio pins number 9

< gpio pins number 10

< usart receive data buffer full interrupt

< gpio pins number 9

< gpio pins number 10

< usart receive data buffer full interrupt

Definition at line 43 of file project/at_start_f435/examples/pwc/sleep_usart1/src/main.c.

Referenced by main().

◆ USART1_IRQHandler()

void USART1_IRQHandler ( void )

this function handles the usatt interrupt request.

Parameters
none
Return values
none

< usart receive data buffer full flag

< usart receive data buffer full flag

Definition at line 142 of file project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c.

Variable Documentation

◆ usart1_index [1/2]

uint16_t usart1_index = 0

Definition at line 39 of file project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c.

Referenced by USART1_IRQHandler().

◆ usart1_index [2/2]

uint16_t usart1_index = 0

Definition at line 39 of file project/at_start_f437/examples/pwc/sleep_usart1/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: _PWC_standby_ertc_alarm

Functions
_PWC_standby_ertc_alarm
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: PWC_standby_ertc_alarm

Functions
PWC_standby_ertc_alarm
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | ertc_config (void)
ertc configuration. More...
void | ertc_alarm_config (void)
ertc alarm configuration. More...
void | ertc_alarm_value_set (uint32_t alam_index)
ertc alarm value set. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ ertc_alarm_config()

void ertc_alarm_config ( void )

ertc alarm configuration.

Parameters
none
Return values
none

< ertc alarm don't match date or week

< ertc alarm don't match hour

< ertc alarm don't match minute

< ertc alarm a interrupt

< ertc alarm don't match date or week

< ertc alarm don't match hour

< ertc alarm don't match minute

< ertc alarm a interrupt

Definition at line 92 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/src/main.c.

Referenced by main().

◆ ertc_alarm_value_set()

void ertc_alarm_value_set ( uint32_t alam_index )

ertc alarm value set.

Parameters
alam_index : ERTC Alarm Seconds value
Return values
none

Definition at line 107 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/src/main.c.

Referenced by main().

◆ ertc_config()

void ertc_config ( void )

ertc configuration.

Parameters
none
Return values
none

< low speed external crystal stable flag

< low speed external crystal stable flag

Definition at line 43 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/src/main.c.

Referenced by main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< standby flag

< standby flag

< wakeup flag

< wakeup flag

< standby flag

< standby flag

< wakeup flag

< wakeup flag

Definition at line 125 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/src/main.c.


AT32F435/437 Firmwary Library: PWC_standby_wakeup_pin

Functions
PWC_standby_wakeup_pin
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< standby flag

< standby flag

< wakeup flag

< wakeup flag

< standby wake-up pin1

< standby wake-up pin2

< standby flag

< standby flag

< wakeup flag

< wakeup flag

< standby wake-up pin1

< standby wake-up pin2

Definition at line 43 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: QSPI_command_port_using_dma

Macros | Functions | Variables
QSPI_command_port_using_dma
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | TEST_SIZE 4096
#define | FLASH_PAGE_PROGRAM_SIZE 256
#define | TEST_SIZE 4096
#define | FLASH_PAGE_PROGRAM_SIZE 256

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | qspi_config (void)
qspi config More...
int | main (void)
main function. More...
void | esmt32m_cmd_read_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config More...
void | esmt32m_cmd_write_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config More...
void | esmt32m_cmd_erase_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config More...
void | esmt32m_cmd_wren_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config More...
void | esmt32m_cmd_rdsr_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config More...
void | qspi_dma_set (dma_dir_type dir, uint8_t *buf, uint32_t length)
qspi dma set More...
static void | qspi_data_once_write (uint32_t addr, uint32_t sz, uint8_t *buf)
qspi write data for one time More...

Variables

ALIGNED_HEAD uint8_t wbuf[4096] | ALIGNED_TAIL
qspi_cmd_type esmt32m_cmd_config
ALIGNED_HEAD uint8_t wbuf[4096] | ALIGNED_TAIL
qspi_cmd_type esmt32m_cmd_config

Detailed Description

Macro Definition Documentation

◆ FLASH_PAGE_PROGRAM_SIZE [1/2]

#define FLASH_PAGE_PROGRAM_SIZE 256

Definition at line 37 of file at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c.

◆ FLASH_PAGE_PROGRAM_SIZE [2/2]

#define FLASH_PAGE_PROGRAM_SIZE 256

Definition at line 37 of file at_start_f437/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c.

◆ TEST_SIZE [1/2]

#define TEST_SIZE 4096

Definition at line 43 of file project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c.

◆ TEST_SIZE [2/2]

#define TEST_SIZE 4096

Definition at line 43 of file project/at_start_f437/examples/qspi/command_port_using_dma/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c.

◆ esmt32m_cmd_erase_config()

void esmt32m_cmd_erase_config | ( | qspi_cmd_type * | qspi_cmd_struct,
 |  | uint32_t | addr
 | ) |  |

esmt32m cmd erase config

Parameters
qspi_cmd_struct | the pointer for qspi_cmd_type parameter
addr | erase address
Return values
none

Definition at line 96 of file at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c.

Referenced by qspi_erase().

◆ esmt32m_cmd_rdsr_config()

void esmt32m_cmd_rdsr_config ( qspi_cmd_type * qspi_cmd_struct )

esmt32m cmd rdsr config

Parameters
qspi_cmd_struct the pointer for qspi_cmd_type parameter
Return values
none

Definition at line 138 of file at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c.

Referenced by qspi_busy_check().

◆ esmt32m_cmd_read_config()

void esmt32m_cmd_read_config | ( | qspi_cmd_type * | qspi_cmd_struct,
 |  | uint32_t | addr,
 |  | uint32_t | counter
 | ) |  |

esmt32m cmd read config

Parameters
qspi_cmd_struct | the pointer for qspi_cmd_type parameter
addr | read start address
counter | read data counter
Return values
none

Definition at line 51 of file at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_read().

◆ esmt32m_cmd_wren_config()

void esmt32m_cmd_wren_config ( qspi_cmd_type * qspi_cmd_struct )

esmt32m cmd wren config

Parameters
qspi_cmd_struct the pointer for qspi_cmd_type parameter
Return values
none

Definition at line 117 of file at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c.

Referenced by qspi_write_enable().

◆ esmt32m_cmd_write_config()

void esmt32m_cmd_write_config | ( | qspi_cmd_type * | qspi_cmd_struct,
 |  | uint32_t | addr,
 |  | uint32_t | counter
 | ) |  |

esmt32m cmd write config

Parameters
qspi_cmd_struct | the pointer for qspi_cmd_type parameter
addr | write start address
counter | write data counter
Return values
none

Definition at line 74 of file at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_once_write().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c.

◆ qspi_config()

void qspi_config ( void )

qspi config

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 9

< gpio pins number 7

< gpio pins number 6

< gpio pins number 10

< gpio pins number 6

< gpio pins number 8

< gpio pins number 9

< gpio pins number 7

< gpio pins number 6

< gpio pins number 10

< gpio pins number 6

Definition at line 60 of file project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c.

Referenced by main().

◆ qspi_data_once_write()

static void qspi_data_once_write | ( | uint32_t | addr,
 |  | uint32_t | sz,
 |  | uint8_t * | buf
 | ) |  |
static

qspi write data for one time

Parameters
addr | the address for write
sz | the length for write
buf | the pointer for write data
Return values
none

Definition at line 222 of file at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_write().

◆ qspi_dma_set()

void qspi_dma_set | ( | dma_dir_type | dir,
 |  | uint8_t * | buf,
 |  | uint32_t | length
 | ) |  |

qspi dma set

Parameters
dir | dma transfer direction
buf | the pointer for dma data
length | data length
Return values
none

Definition at line 161 of file at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_once_write(), and qspi_data_read().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c.

Variable Documentation

◆ ALIGNED_TAIL [1/2]

ALIGNED_HEAD uint8_t rbuf [ 4096 ] ALIGNED_TAIL

Definition at line 48 of file project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c.

◆ ALIGNED_TAIL [2/2]

ALIGNED_HEAD uint8_t rbuf [ 4096 ] ALIGNED_TAIL

Definition at line 48 of file project/at_start_f437/examples/qspi/command_port_using_dma/src/main.c.

◆ esmt32m_cmd_config [1/2]

qspi_cmd_type esmt32m_cmd_config

Definition at line 39 of file at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c.

Referenced by qspi_busy_check(), qspi_data_once_write(), qspi_data_read(), qspi_erase(), and qspi_write_enable().

◆ esmt32m_cmd_config [2/2]

qspi_cmd_type esmt32m_cmd_config

Definition at line 39 of file at_start_f437/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_once_write().


AT32F435/437 Firmwary Library: QSPI_command_port_using_dma_and_pem

Macros | Enumerations | Functions | Variables
QSPI_command_port_using_dma_and_pem
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | TEST_SIZE 4096
#define | FLASH_PAGE_PROGRAM_SIZE 256
#define | PEMOPC_SET 0xA5
#define | PEMOPC_RESET 0xFF
#define | TEST_SIZE 4096
#define | FLASH_PAGE_PROGRAM_SIZE 256
#define | PEMOPC_SET 0xA5
#define | PEMOPC_RESET 0xFF

Enumerations

enum pem_step_type {
PEM_STEP_BEGIN , PEM_STEP_KEEP , PEM_STEP_END , PEM_STEP_BEGIN ,
PEM_STEP_KEEP , PEM_STEP_END
}
enum pem_step_type {
PEM_STEP_BEGIN , PEM_STEP_KEEP , PEM_STEP_END , PEM_STEP_BEGIN ,
PEM_STEP_KEEP , PEM_STEP_END
}

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | qspi_data_read (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data More...
void | qspi_data_write (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data More...
void | qspi_erase (uint32_t sec_addr)
qspi erase data More...
void | qspi_config (void)
qspi config More...
int | main (void)
main function. More...
void | qspi_busy_check (void)
qspi check busy More...
void | qspi_write_enable (void)
qspi write enable More...
void | esmt32m_cmd_read_pem_begin_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read pem begin config More...
void | esmt32m_cmd_read_pem_keep_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read pem keep config More...
void | esmt32m_cmd_read_pem_end_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read pem end config More...
void | esmt32m_cmd_write_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config More...
void | esmt32m_cmd_erase_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config More...
void | esmt32m_cmd_wren_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config More...
void | esmt32m_cmd_rdsr_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config More...
void | qspi_dma_set (dma_dir_type dir, uint8_t *buf, uint32_t length)
qspi dma set More...
void | qspi_read_data_using_pem (pem_step_type pem_step, uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data using pem More...
static void | qspi_data_once_write (uint32_t addr, uint32_t sz, uint8_t *buf)
qspi write data for one time More...

Variables

ALIGNED_HEAD uint8_t wbuf[4096] | ALIGNED_TAIL
qspi_cmd_type esmt32m_cmd_config
ALIGNED_HEAD uint8_t wbuf[4096] | ALIGNED_TAIL
qspi_cmd_type esmt32m_cmd_config

Detailed Description

Macro Definition Documentation

◆ FLASH_PAGE_PROGRAM_SIZE [1/2]

#define FLASH_PAGE_PROGRAM_SIZE 256

Definition at line 37 of file at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

◆ FLASH_PAGE_PROGRAM_SIZE [2/2]

#define FLASH_PAGE_PROGRAM_SIZE 256

Definition at line 37 of file at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

◆ PEMOPC_RESET [1/2]

#define PEMOPC_RESET 0xFF

Definition at line 39 of file at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

◆ PEMOPC_RESET [2/2]

#define PEMOPC_RESET 0xFF

Definition at line 39 of file at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

◆ PEMOPC_SET [1/2]

#define PEMOPC_SET 0xA5

Definition at line 38 of file at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

◆ PEMOPC_SET [2/2]

#define PEMOPC_SET 0xA5

Definition at line 38 of file at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

◆ TEST_SIZE [1/2]

#define TEST_SIZE 4096

Definition at line 43 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c.

◆ TEST_SIZE [2/2]

#define TEST_SIZE 4096

Definition at line 43 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/main.c.

Enumeration Type Documentation

◆ pem_step_type [1/2]

enum pem_step_type
Enumerator
PEM_STEP_BEGIN
PEM_STEP_KEEP
PEM_STEP_END
PEM_STEP_BEGIN
PEM_STEP_KEEP
PEM_STEP_END

Definition at line 41 of file at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

◆ pem_step_type [2/2]

enum pem_step_type
Enumerator
PEM_STEP_BEGIN
PEM_STEP_KEEP
PEM_STEP_END
PEM_STEP_BEGIN
PEM_STEP_KEEP
PEM_STEP_END

Definition at line 41 of file at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c.

◆ esmt32m_cmd_erase_config()

void esmt32m_cmd_erase_config | ( | qspi_cmd_type * | qspi_cmd_struct,
 |  | uint32_t | addr
 | ) |  |

esmt32m cmd erase config

Parameters
qspi_cmd_struct | the pointer for qspi_cmd_type parameter
addr | erase address
Return values
none

Definition at line 151 of file at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

Referenced by qspi_erase().

◆ esmt32m_cmd_rdsr_config()

void esmt32m_cmd_rdsr_config ( qspi_cmd_type * qspi_cmd_struct )

esmt32m cmd rdsr config

Parameters
qspi_cmd_struct the pointer for qspi_cmd_type parameter
Return values
none

Definition at line 193 of file at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

Referenced by qspi_busy_check().

◆ esmt32m_cmd_read_pem_begin_config()

void esmt32m_cmd_read_pem_begin_config | ( | qspi_cmd_type * | qspi_cmd_struct,
 |  | uint32_t | addr,
 |  | uint32_t | counter
 | ) |  |

esmt32m cmd read pem begin config

Parameters
qspi_cmd_struct | the pointer for qspi_cmd_type parameter
addr | read start address
counter | read data counter
Return values
none

Definition at line 60 of file at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

Referenced by qspi_read_data_using_pem().

◆ esmt32m_cmd_read_pem_end_config()

void esmt32m_cmd_read_pem_end_config | ( | qspi_cmd_type * | qspi_cmd_struct,
 |  | uint32_t | addr,
 |  | uint32_t | counter
 | ) |  |

esmt32m cmd read pem end config

Parameters
qspi_cmd_struct | the pointer for qspi_cmd_type parameter
addr | read start address
counter | read data counter
Return values
none

Definition at line 106 of file at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

Referenced by qspi_read_data_using_pem().

◆ esmt32m_cmd_read_pem_keep_config()

void esmt32m_cmd_read_pem_keep_config | ( | qspi_cmd_type * | qspi_cmd_struct,
 |  | uint32_t | addr,
 |  | uint32_t | counter
 | ) |  |

esmt32m cmd read pem keep config

Parameters
qspi_cmd_struct | the pointer for qspi_cmd_type parameter
addr | read start address
counter | read data counter
Return values
none

Definition at line 83 of file at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

Referenced by qspi_read_data_using_pem().

◆ esmt32m_cmd_wren_config()

void esmt32m_cmd_wren_config ( qspi_cmd_type * qspi_cmd_struct )

esmt32m cmd wren config

Parameters
qspi_cmd_struct the pointer for qspi_cmd_type parameter
Return values
none

Definition at line 172 of file at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

Referenced by qspi_write_enable().

◆ esmt32m_cmd_write_config()

void esmt32m_cmd_write_config | ( | qspi_cmd_type * | qspi_cmd_struct,
 |  | uint32_t | addr,
 |  | uint32_t | counter
 | ) |  |

esmt32m cmd write config

Parameters
qspi_cmd_struct | the pointer for qspi_cmd_type parameter
addr | write start address
counter | write data counter
Return values
none

Definition at line 129 of file at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_once_write().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c.

◆ qspi_busy_check()

void qspi_busy_check ( void )

qspi check busy

Parameters
none
Return values
none

Definition at line 392 of file at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_once_write(), and qspi_erase().

◆ qspi_config()

void qspi_config ( void )

qspi config

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 9

< gpio pins number 7

< gpio pins number 6

< gpio pins number 10

< gpio pins number 6

< gpio pins number 8

< gpio pins number 9

< gpio pins number 7

< gpio pins number 6

< gpio pins number 10

< gpio pins number 6

Definition at line 60 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c.

Referenced by main().

◆ qspi_data_once_write()

static void qspi_data_once_write | ( | uint32_t | addr,
 |  | uint32_t | sz,
 |  | uint8_t * | buf
 | ) |  |
static

qspi write data for one time

Parameters
addr | the address for write
sz | the length for write
buf | the pointer for write data
Return values
none

Definition at line 314 of file at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_write().

◆ qspi_data_read()

void qspi_data_read | ( | uint32_t | addr,
 |  | uint32_t | total_len,
 |  | uint8_t * | buf
 | ) |  |

qspi read data

Parameters
addr | the address for read
total_len | the length for read
buf | the pointer for read data
Return values
none

Definition at line 288 of file at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

Referenced by main().

◆ qspi_data_write()

void qspi_data_write | ( | uint32_t | addr,
 |  | uint32_t | total_len,
 |  | uint8_t * | buf
 | ) |  |

qspi write data

Parameters
addr | the address for write
total_len | the length for write
buf | the pointer for write data
Return values
none

Definition at line 348 of file at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

Referenced by main().

◆ qspi_dma_set()

void qspi_dma_set | ( | dma_dir_type | dir,
 |  | uint8_t * | buf,
 |  | uint32_t | length
 | ) |  |

qspi dma set

Parameters
dir | dma transfer direction
buf | the pointer for dma data
length | data length
Return values
none

Definition at line 216 of file at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_once_write(), and qspi_read_data_using_pem().

◆ qspi_erase()

void qspi_erase ( uint32_t sec_addr )

qspi erase data

Parameters
sec_addr the sector address for erase
Return values
none

Definition at line 373 of file at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

Referenced by main().

◆ qspi_read_data_using_pem()

void qspi_read_data_using_pem | ( | pem_step_type | pem_step,
 |  | uint32_t | addr,
 |  | uint32_t | total_len,
 |  | uint8_t * | buf
 | ) |  |

qspi read data using pem

Parameters
pem_step | pem step
addr | the address for read
total_len | the length for read
buf | the pointer for read data
Return values
none

Definition at line 248 of file at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_read().

◆ qspi_write_enable()

void qspi_write_enable ( void )

qspi write enable

Parameters
none
Return values
none

Definition at line 407 of file at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_once_write(), and qspi_erase().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c.

Variable Documentation

◆ ALIGNED_TAIL [1/2]

ALIGNED_HEAD uint8_t rbuf [ 4096 ] ALIGNED_TAIL

Definition at line 48 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c.

◆ ALIGNED_TAIL [2/2]

ALIGNED_HEAD uint8_t rbuf [ 4096 ] ALIGNED_TAIL

Definition at line 48 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/main.c.

◆ esmt32m_cmd_config [1/2]

qspi_cmd_type esmt32m_cmd_config

Definition at line 48 of file at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

Referenced by qspi_busy_check(), qspi_data_once_write(), qspi_erase(), qspi_read_data_using_pem(), and qspi_write_enable().

◆ esmt32m_cmd_config [2/2]

qspi_cmd_type esmt32m_cmd_config

Definition at line 48 of file at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_once_write().


AT32F435/437 Firmwary Library: QSPI_command_port_using_dma_in_qpi_mode

Macros | Functions | Variables
QSPI_command_port_using_dma_in_qpi_mode
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | TEST_SIZE 4096
#define | FLASH_PAGE_PROGRAM_SIZE 256
#define | TEST_SIZE 4096
#define | FLASH_PAGE_PROGRAM_SIZE 256

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | qspi_data_read (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data More...
void | qspi_data_write (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data More...
void | qspi_erase (uint32_t sec_addr)
qspi erase data More...
void | esmt32m_qpi_mode_init (void)
switch QSPI to cmd port and setup to qpi mode More...
void | qspi_config (void)
qspi config More...
int | main (void)
main function. More...
void | qspi_busy_check (void)
qspi check busy More...
void | qspi_write_enable (void)
qspi write enable More...
void | esmt32m_cmd_read_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config More...
void | esmt32m_cmd_write_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config More...
void | esmt32m_cmd_erase_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config More...
void | esmt32m_cmd_wren_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config More...
void | esmt32m_cmd_rdsr_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config More...
void | qspi_dma_set (dma_dir_type dir, uint8_t *buf, uint32_t length)
qspi dma set More...
static void | qspi_data_once_write (uint32_t addr, uint32_t sz, uint8_t *buf)
qspi write data for one time More...
void | esmt32m_cmd_qpien_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd qpi enter config More...
void | esmt32m_cmd_rstqpi_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rstqpi config More...
void | esmt32m_cmd_rsten_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rst config More...
void | esmt32m_cmd_rst_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rst config More...
void | esmt32m_cmd_send (qspi_cmd_type *cmd)
esmt32m cmd kick and wait completed More...

Variables

ALIGNED_HEAD uint8_t wbuf[4096] | ALIGNED_TAIL
qspi_cmd_type esmt32m_cmd_config
ALIGNED_HEAD uint8_t wbuf[4096] | ALIGNED_TAIL
qspi_cmd_type esmt32m_cmd_config

Detailed Description

Macro Definition Documentation

◆ FLASH_PAGE_PROGRAM_SIZE [1/2]

#define FLASH_PAGE_PROGRAM_SIZE 256

Definition at line 37 of file at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.

◆ FLASH_PAGE_PROGRAM_SIZE [2/2]

#define FLASH_PAGE_PROGRAM_SIZE 256

Definition at line 37 of file at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.

◆ TEST_SIZE [1/2]

#define TEST_SIZE 4096

Definition at line 44 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c.

◆ TEST_SIZE [2/2]

#define TEST_SIZE 4096

Definition at line 44 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c.

◆ esmt32m_cmd_erase_config()

void esmt32m_cmd_erase_config | ( | qspi_cmd_type * | qspi_cmd_struct,
 |  | uint32_t | addr
 | ) |  |

esmt32m cmd erase config

Parameters
qspi_cmd_struct | the pointer for qspi_cmd_type parameter
addr | erase address
Return values
none

Definition at line 96 of file at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.

Referenced by qspi_erase().

◆ esmt32m_cmd_qpien_config()

void esmt32m_cmd_qpien_config ( qspi_cmd_type * qspi_cmd_struct )

esmt32m cmd qpi enter config

Parameters
qspi_cmd_struct the pointer for qspi_cmd_type parameter
Return values
none

Definition at line 330 of file at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.

Referenced by esmt32m_qpi_mode_init().

◆ esmt32m_cmd_rdsr_config()

void esmt32m_cmd_rdsr_config ( qspi_cmd_type * qspi_cmd_struct )

esmt32m cmd rdsr config

Parameters
qspi_cmd_struct the pointer for qspi_cmd_type parameter
Return values
none

Definition at line 138 of file at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.

Referenced by qspi_busy_check().

◆ esmt32m_cmd_read_config()

void esmt32m_cmd_read_config | ( | qspi_cmd_type * | qspi_cmd_struct,
 |  | uint32_t | addr,
 |  | uint32_t | counter
 | ) |  |

esmt32m cmd read config

Parameters
qspi_cmd_struct | the pointer for qspi_cmd_type parameter
addr | read start address
counter | read data counter
Return values
none

Definition at line 51 of file at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_read().

◆ esmt32m_cmd_rst_config()

void esmt32m_cmd_rst_config ( qspi_cmd_type * qspi_cmd_struct )

esmt32m cmd rst config

Parameters
qspi_cmd_struct the pointer for qspi_cmd_type parameter
Return values
none

Definition at line 393 of file at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.

Referenced by esmt32m_qpi_mode_init().

◆ esmt32m_cmd_rsten_config()

void esmt32m_cmd_rsten_config ( qspi_cmd_type * qspi_cmd_struct )

esmt32m cmd rst config

Parameters
qspi_cmd_struct the pointer for qspi_cmd_type parameter
Return values
none

Definition at line 372 of file at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.

Referenced by esmt32m_qpi_mode_init().

◆ esmt32m_cmd_rstqpi_config()

void esmt32m_cmd_rstqpi_config ( qspi_cmd_type * qspi_cmd_struct )

esmt32m cmd rstqpi config

Parameters
qspi_cmd_struct the pointer for qspi_cmd_type parameter
Return values
none

Definition at line 351 of file at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.

Referenced by esmt32m_qpi_mode_init().

◆ esmt32m_cmd_send()

void esmt32m_cmd_send ( qspi_cmd_type * cmd )

esmt32m cmd kick and wait completed

Parameters
qspi_cmd_struct the pointer for qspi_cmd_type parameter
Return values
none

Definition at line 414 of file at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.

Referenced by esmt32m_qpi_mode_init().

◆ esmt32m_cmd_wren_config()

void esmt32m_cmd_wren_config ( qspi_cmd_type * qspi_cmd_struct )

esmt32m cmd wren config

Parameters
qspi_cmd_struct the pointer for qspi_cmd_type parameter
Return values
none

Definition at line 117 of file at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.

Referenced by qspi_write_enable().

◆ esmt32m_cmd_write_config()

void esmt32m_cmd_write_config | ( | qspi_cmd_type * | qspi_cmd_struct,
 |  | uint32_t | addr,
 |  | uint32_t | counter
 | ) |  |

esmt32m cmd write config

Parameters
qspi_cmd_struct | the pointer for qspi_cmd_type parameter
addr | write start address
counter | write data counter
Return values
none

Definition at line 74 of file at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_once_write().

◆ esmt32m_qpi_mode_init()

void esmt32m_qpi_mode_init ( void )

switch QSPI to cmd port and setup to qpi mode

Parameters
none
Return values
none

Definition at line 427 of file at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 117 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c.

◆ qspi_busy_check()

void qspi_busy_check ( void )

qspi check busy

Parameters
none
Return values
none

Definition at line 300 of file at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_once_write(), and qspi_erase().

◆ qspi_config()

void qspi_config ( void )

qspi config

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 9

< gpio pins number 7

< gpio pins number 6

< gpio pins number 10

< gpio pins number 6

< gpio pins number 8

< gpio pins number 9

< gpio pins number 7

< gpio pins number 6

< gpio pins number 10

< gpio pins number 6

Definition at line 61 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c.

Referenced by main().

◆ qspi_data_once_write()

static void qspi_data_once_write | ( | uint32_t | addr,
 |  | uint32_t | sz,
 |  | uint8_t * | buf
 | ) |  |
static

qspi write data for one time

Parameters
addr | the address for write
sz | the length for write
buf | the pointer for write data
Return values
none

Definition at line 222 of file at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_write().

◆ qspi_data_read()

void qspi_data_read | ( | uint32_t | addr,
 |  | uint32_t | total_len,
 |  | uint8_t * | buf
 | ) |  |

qspi read data

Parameters
addr | the address for read
total_len | the length for read
buf | the pointer for read data
Return values
none

Definition at line 192 of file at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.

Referenced by main().

◆ qspi_data_write()

void qspi_data_write | ( | uint32_t | addr,
 |  | uint32_t | total_len,
 |  | uint8_t * | buf
 | ) |  |

qspi write data

Parameters
addr | the address for write
total_len | the length for write
buf | the pointer for write data
Return values
none

Definition at line 256 of file at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.

Referenced by main().

◆ qspi_dma_set()

void qspi_dma_set | ( | dma_dir_type | dir,
 |  | uint8_t * | buf,
 |  | uint32_t | length
 | ) |  |

qspi dma set

Parameters
dir | dma transfer direction
buf | the pointer for dma data
length | data length
Return values
none

Definition at line 161 of file at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_once_write(), and qspi_data_read().

◆ qspi_erase()

void qspi_erase ( uint32_t sec_addr )

qspi erase data

Parameters
sec_addr the sector address for erase
Return values
none

Definition at line 281 of file at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.

Referenced by main().

◆ qspi_write_enable()

void qspi_write_enable ( void )

qspi write enable

Parameters
none
Return values
none

Definition at line 315 of file at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_once_write(), and qspi_erase().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c.

Variable Documentation

◆ ALIGNED_TAIL [1/2]

ALIGNED_HEAD uint8_t rbuf [ 4096 ] ALIGNED_TAIL

Definition at line 49 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c.

◆ ALIGNED_TAIL [2/2]

ALIGNED_HEAD uint8_t rbuf [ 4096 ] ALIGNED_TAIL

Definition at line 49 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/main.c.

◆ esmt32m_cmd_config [1/2]

qspi_cmd_type esmt32m_cmd_config

Definition at line 39 of file at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.

Referenced by esmt32m_qpi_mode_init(), qspi_busy_check(), qspi_data_once_write(), qspi_data_read(), qspi_erase(), and qspi_write_enable().

◆ esmt32m_cmd_config [2/2]

qspi_cmd_type esmt32m_cmd_config

Definition at line 39 of file at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_once_write().


AT32F435/437 Firmwary Library: QSPI_command_port_using_interrupt

Macros | Functions | Variables
QSPI_command_port_using_interrupt
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | TEST_SIZE 4096
#define | QSPI_FIFO_DEPTH (32*4)
#define | FLASH_PAGE_PROGRAM_SIZE 256
#define | TEST_SIZE 4096
#define | QSPI_FIFO_DEPTH (32*4)
#define | FLASH_PAGE_PROGRAM_SIZE 256

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | qspi_data_read (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data More...
void | qspi_data_write (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data More...
void | qspi_erase (uint32_t sec_addr)
qspi erase data More...
void | qspi_config (void)
qspi config More...
int | main (void)
main function. More...
void | qspi_busy_check (void)
qspi check busy More...
void | qspi_write_enable (void)
qspi write enable More...
void | esmt32m_cmd_read_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config More...
void | esmt32m_cmd_write_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config More...
void | esmt32m_cmd_erase_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config More...
void | esmt32m_cmd_wren_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config More...
void | esmt32m_cmd_rdsr_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config More...
void | qspi_command_set_busy ()
set qspi_state_is_busy More...
void | qspi_command_not_busy ()
reset qspi_state_is_busy More...
flag_status | qspi_command_is_busy (void)
return qspi_state_is_busy More...
void | QSPI1_IRQHandler (void)
this function handles qspi1 handler. More...

Variables

uint8_t | wbuf [4096]
uint8_t | rbuf [4096]
qspi_cmd_type esmt32m_cmd_config
volatile flag_status | qspi_state_is_busy = RESET
uint8_t | wbuf [4096]
uint8_t | rbuf [4096]
qspi_cmd_type esmt32m_cmd_config
volatile flag_status | qspi_state_is_busy = RESET

Detailed Description

Macro Definition Documentation

◆ FLASH_PAGE_PROGRAM_SIZE [1/2]

#define FLASH_PAGE_PROGRAM_SIZE 256

Definition at line 38 of file at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c.

◆ FLASH_PAGE_PROGRAM_SIZE [2/2]

#define FLASH_PAGE_PROGRAM_SIZE 256

Definition at line 38 of file at_start_f437/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c.

◆ QSPI_FIFO_DEPTH [1/2]

#define QSPI_FIFO_DEPTH (32*4)

Definition at line 37 of file at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c.

◆ QSPI_FIFO_DEPTH [2/2]

#define QSPI_FIFO_DEPTH (32*4)

Definition at line 37 of file at_start_f437/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c.

◆ TEST_SIZE [1/2]

#define TEST_SIZE 4096

Definition at line 43 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c.

◆ TEST_SIZE [2/2]

#define TEST_SIZE 4096

Definition at line 43 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c.

◆ esmt32m_cmd_erase_config()

void esmt32m_cmd_erase_config | ( | qspi_cmd_type * | qspi_cmd_struct,
 |  | uint32_t | addr
 | ) |  |

esmt32m cmd erase config

Parameters
qspi_cmd_struct | the pointer for qspi_cmd_type parameter
addr | erase address
Return values
none

Definition at line 98 of file at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c.

Referenced by qspi_erase().

◆ esmt32m_cmd_rdsr_config()

void esmt32m_cmd_rdsr_config ( qspi_cmd_type * qspi_cmd_struct )

esmt32m cmd rdsr config

Parameters
qspi_cmd_struct the pointer for qspi_cmd_type parameter
Return values
none

Definition at line 140 of file at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c.

Referenced by qspi_busy_check().

◆ esmt32m_cmd_read_config()

void esmt32m_cmd_read_config | ( | qspi_cmd_type * | qspi_cmd_struct,
 |  | uint32_t | addr,
 |  | uint32_t | counter
 | ) |  |

esmt32m cmd read config

Parameters
qspi_cmd_struct | the pointer for qspi_cmd_type parameter
addr | read start address
counter | read data counter
Return values
none

Definition at line 53 of file at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_read().

◆ esmt32m_cmd_wren_config()

void esmt32m_cmd_wren_config ( qspi_cmd_type * qspi_cmd_struct )

esmt32m cmd wren config

Parameters
qspi_cmd_struct the pointer for qspi_cmd_type parameter
Return values
none

Definition at line 119 of file at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c.

Referenced by qspi_write_enable().

◆ esmt32m_cmd_write_config()

void esmt32m_cmd_write_config | ( | qspi_cmd_type * | qspi_cmd_struct,
 |  | uint32_t | addr,
 |  | uint32_t | counter
 | ) |  |

esmt32m cmd write config

Parameters
qspi_cmd_struct | the pointer for qspi_cmd_type parameter
addr | write start address
counter | write data counter
Return values
none

Definition at line 76 of file at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_write().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 106 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c.

◆ QSPI1_IRQHandler()

void QSPI1_IRQHandler ( void )

this function handles qspi1 handler.

Parameters
none
Return values
none

Definition at line 191 of file at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c.

◆ qspi_busy_check()

void qspi_busy_check ( void )

qspi check busy

Parameters
none
Return values
none

Definition at line 310 of file at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_write(), and qspi_erase().

◆ qspi_command_is_busy()

flag_status qspi_command_is_busy ( void )

return qspi_state_is_busy

Parameters
none
Return values
the new state of qspi_state_is_busy (SET or RESET).

Definition at line 181 of file at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c.

Referenced by qspi_busy_check(), qspi_data_read(), qspi_data_write(), qspi_erase(), and qspi_write_enable().

◆ qspi_command_not_busy()

void qspi_command_not_busy ( )

reset qspi_state_is_busy

Parameters
none
Return values
none

Definition at line 171 of file at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c.

Referenced by QSPI1_IRQHandler().

◆ qspi_command_set_busy()

void qspi_command_set_busy ( )

set qspi_state_is_busy

Parameters
none
Return values
none

Definition at line 161 of file at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c.

Referenced by qspi_busy_check(), qspi_data_read(), qspi_data_write(), qspi_erase(), and qspi_write_enable().

◆ qspi_config()

void qspi_config ( void )

qspi config

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 9

< gpio pins number 7

< gpio pins number 6

< gpio pins number 10

< gpio pins number 6

< gpio pins number 8

< gpio pins number 9

< gpio pins number 7

< gpio pins number 6

< gpio pins number 10

< gpio pins number 6

Definition at line 52 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c.

Referenced by main().

◆ qspi_data_read()

void qspi_data_read | ( | uint32_t | addr,
 |  | uint32_t | total_len,
 |  | uint8_t * | buf
 | ) |  |

qspi read data

Parameters
addr | the address for read
total_len | the length for read
buf | the pointer for read data
Return values
none

Definition at line 207 of file at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c.

Referenced by main().

◆ qspi_data_write()

void qspi_data_write | ( | uint32_t | addr,
 |  | uint32_t | total_len,
 |  | uint8_t * | buf
 | ) |  |

qspi write data

Parameters
addr | the address for write
total_len | the length for write
buf | the pointer for write data
Return values
none

Definition at line 247 of file at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c.

Referenced by main().

◆ qspi_erase()

void qspi_erase ( uint32_t sec_addr )

qspi erase data

Parameters
sec_addr the sector address for erase
Return values
none

Definition at line 289 of file at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c.

Referenced by main().

◆ qspi_write_enable()

void qspi_write_enable ( void )

qspi write enable

Parameters
none
Return values
none

Definition at line 327 of file at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_write(), and qspi_erase().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c.

Variable Documentation

◆ esmt32m_cmd_config [1/2]

qspi_cmd_type esmt32m_cmd_config

Definition at line 40 of file at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c.

Referenced by qspi_busy_check(), qspi_data_read(), qspi_data_write(), qspi_erase(), and qspi_write_enable().

◆ esmt32m_cmd_config [2/2]

qspi_cmd_type esmt32m_cmd_config

Definition at line 40 of file at_start_f437/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c.

◆ qspi_state_is_busy [1/2]

volatile flag_status qspi_state_is_busy = RESET

Definition at line 41 of file at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c.

Referenced by qspi_command_is_busy(), qspi_command_not_busy(), and qspi_command_set_busy().

◆ qspi_state_is_busy [2/2]

volatile flag_status qspi_state_is_busy = RESET

Definition at line 41 of file at_start_f437/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c.

◆ rbuf [1/2]

ALIGNED_HEAD uint8_t rbuf

Definition at line 45 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c.

Referenced by fatfs_test(), and main().

◆ rbuf [2/2]

uint8_t rbuf[4096]

Definition at line 45 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/src/main.c.

◆ wbuf [1/2]

uint8_t wbuf[4096]

Definition at line 44 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c.

Referenced by fatfs_test(), and main().

◆ wbuf [2/2]

uint8_t wbuf[4096]

Definition at line 44 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/src/main.c.


AT32F435/437 Firmwary Library: QSPI_command_port_using_polling

Macros | Functions | Variables
QSPI_command_port_using_polling
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | TEST_SIZE 4096
#define | QSPI_FIFO_DEPTH (32*4)
#define | FLASH_PAGE_PROGRAM_SIZE 256
#define | TEST_SIZE 4096
#define | QSPI_FIFO_DEPTH (32*4)
#define | FLASH_PAGE_PROGRAM_SIZE 256

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | qspi_data_read (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data More...
void | qspi_data_write (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data More...
void | qspi_erase (uint32_t sec_addr)
qspi erase data More...
void | qspi_config (void)
qspi config More...
int | main (void)
main function. More...
void | qspi_busy_check (void)
qspi check busy More...
void | qspi_write_enable (void)
qspi write enable More...
void | esmt32m_cmd_read_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config More...
void | esmt32m_cmd_write_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config More...
void | esmt32m_cmd_erase_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config More...
void | esmt32m_cmd_wren_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config More...
void | esmt32m_cmd_rdsr_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config More...

Variables

uint8_t | wbuf [4096]
uint8_t | rbuf [4096]
qspi_cmd_type esmt32m_cmd_config
uint8_t | wbuf [4096]
uint8_t | rbuf [4096]
qspi_cmd_type esmt32m_cmd_config

Detailed Description

Macro Definition Documentation

◆ FLASH_PAGE_PROGRAM_SIZE [1/2]

#define FLASH_PAGE_PROGRAM_SIZE 256

Definition at line 38 of file at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c.

◆ FLASH_PAGE_PROGRAM_SIZE [2/2]

#define FLASH_PAGE_PROGRAM_SIZE 256

Definition at line 38 of file at_start_f437/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c.

◆ QSPI_FIFO_DEPTH [1/2]

#define QSPI_FIFO_DEPTH (32*4)

Definition at line 37 of file at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c.

◆ QSPI_FIFO_DEPTH [2/2]

#define QSPI_FIFO_DEPTH (32*4)

Definition at line 37 of file at_start_f437/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c.

◆ TEST_SIZE [1/2]

#define TEST_SIZE 4096

Definition at line 43 of file project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c.

◆ TEST_SIZE [2/2]

#define TEST_SIZE 4096

Definition at line 43 of file project/at_start_f437/examples/qspi/command_port_using_polling/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c.

◆ esmt32m_cmd_erase_config()

void esmt32m_cmd_erase_config | ( | qspi_cmd_type * | qspi_cmd_struct,
 |  | uint32_t | addr
 | ) |  |

esmt32m cmd erase config

Parameters
qspi_cmd_struct | the pointer for qspi_cmd_type parameter
addr | erase address
Return values
none

Definition at line 97 of file at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c.

Referenced by qspi_erase().

◆ esmt32m_cmd_rdsr_config()

void esmt32m_cmd_rdsr_config ( qspi_cmd_type * qspi_cmd_struct )

esmt32m cmd rdsr config

Parameters
qspi_cmd_struct the pointer for qspi_cmd_type parameter
Return values
none

Definition at line 139 of file at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c.

Referenced by qspi_busy_check().

◆ esmt32m_cmd_read_config()

void esmt32m_cmd_read_config | ( | qspi_cmd_type * | qspi_cmd_struct,
 |  | uint32_t | addr,
 |  | uint32_t | counter
 | ) |  |

esmt32m cmd read config

Parameters
qspi_cmd_struct | the pointer for qspi_cmd_type parameter
addr | read start address
counter | read data counter
Return values
none

Definition at line 52 of file at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_read().

◆ esmt32m_cmd_wren_config()

void esmt32m_cmd_wren_config ( qspi_cmd_type * qspi_cmd_struct )

esmt32m cmd wren config

Parameters
qspi_cmd_struct the pointer for qspi_cmd_type parameter
Return values
none

Definition at line 118 of file at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c.

Referenced by qspi_write_enable().

◆ esmt32m_cmd_write_config()

void esmt32m_cmd_write_config | ( | qspi_cmd_type * | qspi_cmd_struct,
 |  | uint32_t | addr,
 |  | uint32_t | counter
 | ) |  |

esmt32m cmd write config

Parameters
qspi_cmd_struct | the pointer for qspi_cmd_type parameter
addr | write start address
counter | write data counter
Return values
none

Definition at line 75 of file at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_write().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 106 of file project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c.

◆ qspi_busy_check()

void qspi_busy_check ( void )

qspi check busy

Parameters
none
Return values
none

Definition at line 259 of file at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_write(), and qspi_erase().

◆ qspi_config()

void qspi_config ( void )

qspi config

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 9

< gpio pins number 7

< gpio pins number 6

< gpio pins number 10

< gpio pins number 6

< gpio pins number 8

< gpio pins number 9

< gpio pins number 7

< gpio pins number 6

< gpio pins number 10

< gpio pins number 6

Definition at line 52 of file project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c.

Referenced by main().

◆ qspi_data_read()

void qspi_data_read | ( | uint32_t | addr,
 |  | uint32_t | total_len,
 |  | uint8_t * | buf
 | ) |  |

qspi read data

Parameters
addr | the address for read
total_len | the length for read
buf | the pointer for read data
Return values
none

Definition at line 162 of file at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c.

Referenced by main().

◆ qspi_data_write()

void qspi_data_write | ( | uint32_t | addr,
 |  | uint32_t | total_len,
 |  | uint8_t * | buf
 | ) |  |

qspi write data

Parameters
addr | the address for write
total_len | the length for write
buf | the pointer for write data
Return values
none

Definition at line 200 of file at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c.

Referenced by main().

◆ qspi_erase()

void qspi_erase ( uint32_t sec_addr )

qspi erase data

Parameters
sec_addr the sector address for erase
Return values
none

Definition at line 240 of file at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c.

Referenced by main().

◆ qspi_write_enable()

void qspi_write_enable ( void )

qspi write enable

Parameters
none
Return values
none

Definition at line 274 of file at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_write(), and qspi_erase().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c.

Variable Documentation

◆ esmt32m_cmd_config [1/2]

qspi_cmd_type esmt32m_cmd_config

Definition at line 40 of file at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c.

Referenced by qspi_busy_check(), qspi_data_read(), qspi_data_write(), qspi_erase(), and qspi_write_enable().

◆ esmt32m_cmd_config [2/2]

qspi_cmd_type esmt32m_cmd_config

Definition at line 40 of file at_start_f437/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c.

◆ rbuf [1/2]

uint8_t rbuf[4096]

Definition at line 45 of file project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c.

Referenced by main().

◆ rbuf [2/2]

uint8_t rbuf[4096]

Definition at line 45 of file project/at_start_f437/examples/qspi/command_port_using_polling/src/main.c.

◆ wbuf [1/2]

uint8_t wbuf[4096]

Definition at line 44 of file project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c.

Referenced by main().

◆ wbuf [2/2]

uint8_t wbuf[4096]

Definition at line 44 of file project/at_start_f437/examples/qspi/command_port_using_polling/src/main.c.


AT32F435/437 Firmwary Library: QSPI_command_port_using_rdsr_sw

Macros | Functions | Variables
QSPI_command_port_using_rdsr_sw
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | TEST_SIZE 4096
#define | QSPI_FIFO_DEPTH (32*4)
#define | FLASH_PAGE_PROGRAM_SIZE 256
#define | TEST_SIZE 4096
#define | QSPI_FIFO_DEPTH (32*4)
#define | FLASH_PAGE_PROGRAM_SIZE 256

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | qspi_data_read (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data More...
void | qspi_data_write (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data More...
void | qspi_erase (uint32_t sec_addr)
qspi erase data More...
void | qspi_config (void)
qspi config More...
int | main (void)
main function. More...
void | qspi_busy_check (void)
qspi check busy More...
void | qspi_write_enable (void)
qspi write enable More...
void | esmt32m_cmd_read_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config More...
void | esmt32m_cmd_write_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config More...
void | esmt32m_cmd_erase_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config More...
void | esmt32m_cmd_wren_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config More...
void | esmt32m_cmd_rdsr_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config More...

Variables

uint8_t | wbuf [4096]
uint8_t | rbuf [4096]
qspi_cmd_type esmt32m_cmd_config
uint8_t | wbuf [4096]
uint8_t | rbuf [4096]
qspi_cmd_type esmt32m_cmd_config

Detailed Description

Macro Definition Documentation

◆ FLASH_PAGE_PROGRAM_SIZE [1/2]

#define FLASH_PAGE_PROGRAM_SIZE 256

Definition at line 38 of file at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c.

◆ FLASH_PAGE_PROGRAM_SIZE [2/2]

#define FLASH_PAGE_PROGRAM_SIZE 256

Definition at line 38 of file at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c.

◆ QSPI_FIFO_DEPTH [1/2]

#define QSPI_FIFO_DEPTH (32*4)

Definition at line 37 of file at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c.

◆ QSPI_FIFO_DEPTH [2/2]

#define QSPI_FIFO_DEPTH (32*4)

Definition at line 37 of file at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c.

◆ TEST_SIZE [1/2]

#define TEST_SIZE 4096

Definition at line 43 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c.

◆ TEST_SIZE [2/2]

#define TEST_SIZE 4096

Definition at line 43 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c.

◆ esmt32m_cmd_erase_config()

void esmt32m_cmd_erase_config | ( | qspi_cmd_type * | qspi_cmd_struct,
 |  | uint32_t | addr
 | ) |  |

esmt32m cmd erase config

Parameters
qspi_cmd_struct | the pointer for qspi_cmd_type parameter
addr | erase address
Return values
none

Definition at line 97 of file at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c.

Referenced by qspi_erase().

◆ esmt32m_cmd_rdsr_config()

void esmt32m_cmd_rdsr_config ( qspi_cmd_type * qspi_cmd_struct )

esmt32m cmd rdsr config

Parameters
qspi_cmd_struct the pointer for qspi_cmd_type parameter
Return values
none

Definition at line 139 of file at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c.

Referenced by qspi_busy_check().

◆ esmt32m_cmd_read_config()

void esmt32m_cmd_read_config | ( | qspi_cmd_type * | qspi_cmd_struct,
 |  | uint32_t | addr,
 |  | uint32_t | counter
 | ) |  |

esmt32m cmd read config

Parameters
qspi_cmd_struct | the pointer for qspi_cmd_type parameter
addr | read start address
counter | read data counter
Return values
none

Definition at line 52 of file at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_read().

◆ esmt32m_cmd_wren_config()

void esmt32m_cmd_wren_config ( qspi_cmd_type * qspi_cmd_struct )

esmt32m cmd wren config

Parameters
qspi_cmd_struct the pointer for qspi_cmd_type parameter
Return values
none

Definition at line 118 of file at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c.

Referenced by qspi_write_enable().

◆ esmt32m_cmd_write_config()

void esmt32m_cmd_write_config | ( | qspi_cmd_type * | qspi_cmd_struct,
 |  | uint32_t | addr,
 |  | uint32_t | counter
 | ) |  |

esmt32m cmd write config

Parameters
qspi_cmd_struct | the pointer for qspi_cmd_type parameter
addr | write start address
counter | write data counter
Return values
none

Definition at line 75 of file at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_write().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 106 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c.

◆ qspi_busy_check()

void qspi_busy_check ( void )

qspi check busy

Parameters
none
Return values
none

Definition at line 259 of file at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_write(), and qspi_erase().

◆ qspi_config()

void qspi_config ( void )

qspi config

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 9

< gpio pins number 7

< gpio pins number 6

< gpio pins number 10

< gpio pins number 6

< gpio pins number 8

< gpio pins number 9

< gpio pins number 7

< gpio pins number 6

< gpio pins number 10

< gpio pins number 6

Definition at line 52 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c.

Referenced by main().

◆ qspi_data_read()

void qspi_data_read | ( | uint32_t | addr,
 |  | uint32_t | total_len,
 |  | uint8_t * | buf
 | ) |  |

qspi read data

Parameters
addr | the address for read
total_len | the length for read
buf | the pointer for read data
Return values
none

Definition at line 162 of file at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c.

Referenced by main().

◆ qspi_data_write()

void qspi_data_write | ( | uint32_t | addr,
 |  | uint32_t | total_len,
 |  | uint8_t * | buf
 | ) |  |

qspi write data

Parameters
addr | the address for write
total_len | the length for write
buf | the pointer for write data
Return values
none

Definition at line 200 of file at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c.

Referenced by main().

◆ qspi_erase()

void qspi_erase ( uint32_t sec_addr )

qspi erase data

Parameters
sec_addr the sector address for erase
Return values
none

Definition at line 240 of file at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c.

Referenced by main().

◆ qspi_write_enable()

void qspi_write_enable ( void )

qspi write enable

Parameters
none
Return values
none

Definition at line 278 of file at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c.

Referenced by qspi_data_write(), and qspi_erase().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c.

Variable Documentation

◆ esmt32m_cmd_config [1/2]

qspi_cmd_type esmt32m_cmd_config

Definition at line 40 of file at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c.

Referenced by qspi_busy_check(), qspi_data_read(), qspi_data_write(), qspi_erase(), and qspi_write_enable().

◆ esmt32m_cmd_config [2/2]

qspi_cmd_type esmt32m_cmd_config

Definition at line 40 of file at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c.

◆ rbuf [1/2]

uint8_t rbuf[4096]

Definition at line 45 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c.

Referenced by main().

◆ rbuf [2/2]

uint8_t rbuf[4096]

Definition at line 45 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/main.c.

◆ wbuf [1/2]

uint8_t wbuf[4096]

Definition at line 44 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c.

Referenced by main().

◆ wbuf [2/2]

uint8_t wbuf[4096]

Definition at line 44 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/main.c.


AT32F435/437 Firmwary Library: QSPI_xip_port_write_read

Macros | Functions | Variables
QSPI_xip_port_write_read
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | TEST_SIZE 4096
#define | TEST_SIZE 4096

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | qspi_xip_init_ly68l6400 (void)
void | qspi_config (void)
qspi config More...
int | main (void)
main function. More...
void | xip_init_ly68l6400_config (qspi_xip_type *qspi_xip_struct)
xip init ly68l6400 config More...
void | cmd_rsten_ly68l6400_config (qspi_cmd_type *qspi_cmd_struct)
cmd rsten ly68l6400 config More...
void | cmd_rst_ly68l6400_config (qspi_cmd_type *qspi_cmd_struct)
cmd rst ly68l6400 config More...
void | qspi_cmd_ly68l6400_send (qspi_cmd_type *cmd)

Variables

uint8_t | wbuf [4096]
uint8_t | rbuf [4096]
qspi_xip_type ly68l6400_xip_init
qspi_cmd_type ly68l6400_cmd_config
uint8_t | wbuf [4096]
uint8_t | rbuf [4096]
qspi_xip_type ly68l6400_xip_init
qspi_cmd_type ly68l6400_cmd_config

Detailed Description

Macro Definition Documentation

◆ TEST_SIZE [1/2]

#define TEST_SIZE 4096

Definition at line 41 of file project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c.

◆ TEST_SIZE [2/2]

#define TEST_SIZE 4096

Definition at line 41 of file project/at_start_f437/examples/qspi/xip_port_write_read/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c.

◆ cmd_rst_ly68l6400_config()

void cmd_rst_ly68l6400_config ( qspi_cmd_type * qspi_cmd_struct )

cmd rst ly68l6400 config

Parameters
qspi_cmd_struct the pointer for qspi_cmd_type parameter
Return values
none

Definition at line 89 of file at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c.

Referenced by qspi_xip_init_ly68l6400().

◆ cmd_rsten_ly68l6400_config()

void cmd_rsten_ly68l6400_config ( qspi_cmd_type * qspi_cmd_struct )

cmd rsten ly68l6400 config

Parameters
qspi_cmd_struct the pointer for qspi_cmd_type parameter
Return values
none

Definition at line 68 of file at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c.

Referenced by qspi_xip_init_ly68l6400().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c.

◆ qspi_cmd_ly68l6400_send()

void qspi_cmd_ly68l6400_send ( qspi_cmd_type * cmd )

Definition at line 105 of file at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c.

Referenced by qspi_xip_init_ly68l6400().

◆ qspi_config()

void qspi_config ( void )

qspi config

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 9

< gpio pins number 7

< gpio pins number 6

< gpio pins number 10

< gpio pins number 6

< gpio pins number 8

< gpio pins number 9

< gpio pins number 7

< gpio pins number 6

< gpio pins number 10

< gpio pins number 6

Definition at line 50 of file project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c.

Referenced by main().

◆ qspi_xip_init_ly68l6400()

void qspi_xip_init_ly68l6400 ( void )

Definition at line 114 of file at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c.

◆ xip_init_ly68l6400_config()

void xip_init_ly68l6400_config ( qspi_xip_type * qspi_xip_struct )

xip init ly68l6400 config

Parameters
qspi_xip_struct the pointer for qspi_xip_type parameter
Return values
none

Definition at line 45 of file at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c.

Referenced by qspi_xip_init_ly68l6400().

Variable Documentation

◆ ly68l6400_cmd_config [1/2]

qspi_cmd_type ly68l6400_cmd_config

Definition at line 38 of file at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c.

Referenced by qspi_xip_init_ly68l6400().

◆ ly68l6400_cmd_config [2/2]

qspi_cmd_type ly68l6400_cmd_config

Definition at line 38 of file at_start_f437/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c.

◆ ly68l6400_xip_init [1/2]

qspi_xip_type ly68l6400_xip_init

Definition at line 37 of file at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c.

Referenced by qspi_xip_init_ly68l6400().

◆ ly68l6400_xip_init [2/2]

qspi_xip_type ly68l6400_xip_init

Definition at line 37 of file at_start_f437/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c.

◆ rbuf [1/2]

uint8_t rbuf[4096]

Definition at line 43 of file project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c.

Referenced by main().

◆ rbuf [2/2]

uint8_t rbuf[4096]

Definition at line 43 of file project/at_start_f437/examples/qspi/xip_port_write_read/src/main.c.

◆ wbuf [1/2]

uint8_t wbuf[4096]

Definition at line 42 of file project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c.

Referenced by main().

◆ wbuf [2/2]

uint8_t wbuf[4096]

Definition at line 42 of file project/at_start_f437/examples/qspi/xip_port_write_read/src/main.c.


AT32F435/437 Firmwary Library: SCFG_mem_map_sel

Functions
SCFG_mem_map_sel
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f435/examples/scfg/mem_map_sel/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: SD_mmc_card

Modules
SD_mmc_card
AT32F435_periph_examples | AT32F437_periph_examples

Modules

SDIO_instance_definition
SDIO_exported_types
SDIO_command_index_definition
SDIO_paremeters_definition
SDIO_response_definition
SDIO_command_class_definition
SDIO_cmd8_definition
SDIO_mmc_extend_definition
SDIO_interrupt_flags_definition
SDIO_exported_functions

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: SDIO_instance_definition

Macros
SDIO_instance_definition
AT32F435_periph_examples | AT32F437_periph_examples » SD_mmc_card | AT32F435_periph_examples | AT32F437_periph_examples » SDIO_fatfs

Macros

#define | SDIOx SDIO1
#define | DMAMUX_SDIOx DMAMUX_DMAREQ_ID_SDIO1
#define | SDIOx SDIO1
#define | DMAMUX_SDIOx DMAMUX_DMAREQ_ID_SDIO1
#define | SDIOx SDIO1
#define | DMAMUX_SDIOx DMAMUX_DMAREQ_ID_SDIO1
#define | SDIOx SDIO1
#define | DMAMUX_SDIOx DMAMUX_DMAREQ_ID_SDIO1

Detailed Description

Macro Definition Documentation

◆ DMAMUX_SDIOx [1/4]

#define DMAMUX_SDIOx DMAMUX_DMAREQ_ID_SDIO1

Definition at line 52 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ DMAMUX_SDIOx [2/4]

#define DMAMUX_SDIOx DMAMUX_DMAREQ_ID_SDIO1

Definition at line 52 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ DMAMUX_SDIOx [3/4]

#define DMAMUX_SDIOx DMAMUX_DMAREQ_ID_SDIO1

Definition at line 52 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ DMAMUX_SDIOx [4/4]

#define DMAMUX_SDIOx DMAMUX_DMAREQ_ID_SDIO1

Definition at line 52 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SDIOx [1/4]

#define SDIOx SDIO1

Definition at line 51 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SDIOx [2/4]

#define SDIOx SDIO1

Definition at line 51 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SDIOx [3/4]

#define SDIOx SDIO1

Definition at line 51 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SDIOx [4/4]

#define SDIOx SDIO1

Definition at line 51 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.


AT32F435/437 Firmwary Library: SDIO_command_index_definition

Macros
SDIO_command_index_definition
AT32F435_periph_examples | AT32F437_periph_examples » SD_mmc_card | AT32F435_periph_examples | AT32F437_periph_examples » SDIO_fatfs

Macros

#define | SD_CMD_GO_IDLE_STATE ((uint8_t)0)
#define | SD_CMD_SEND_OP_COND ((uint8_t)1)
#define | SD_CMD_ALL_SEND_CID ((uint8_t)2)
#define | SD_CMD_SET_REL_ADDR ((uint8_t)3)
#define | SD_CMD_SET_DSR ((uint8_t)4)
#define | SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)
#define | SD_CMD_HS_SWITCH ((uint8_t)6)
#define | SD_CMD_SEL_DESEL_CARD ((uint8_t)7)
#define | SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)
#define | SD_CMD_SEND_CSD ((uint8_t)9)
#define | SD_CMD_SEND_CID ((uint8_t)10)
#define | SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)
#define | SD_CMD_STOP_TRANSMISSION ((uint8_t)12)
#define | SD_CMD_SEND_STATUS ((uint8_t)13)
#define | SD_CMD_HS_BUSTEST_READ ((uint8_t)14)
#define | SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)
#define | SD_CMD_SET_BLOCKLEN ((uint8_t)16)
#define | SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)
#define | SD_CMD_READ_MULT_BLOCK ((uint8_t)18)
#define | SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)
#define | SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)
#define | SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)
#define | SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)
#define | SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)
#define | SD_CMD_PROG_CID ((uint8_t)26)
#define | SD_CMD_PROG_CSD ((uint8_t)27)
#define | SD_CMD_SET_WRITE_PROT ((uint8_t)28)
#define | SD_CMD_CLR_WRITE_PROT ((uint8_t)29)
#define | SD_CMD_SEND_WRITE_PROT ((uint8_t)30)
#define | SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)
#define | SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)
#define | SD_CMD_ERASE_GRP_START ((uint8_t)35)
#define | SD_CMD_ERASE_GRP_END ((uint8_t)36)
#define | SD_CMD_ERASE ((uint8_t)38)
#define | SD_CMD_FAST_IO ((uint8_t)39)
#define | SD_CMD_GO_IRQ_STATE ((uint8_t)40)
#define | SD_CMD_LOCK_UNLOCK ((uint8_t)42)
#define | SD_CMD_APP_CMD ((uint8_t)55)
#define | SD_CMD_GEN_CMD ((uint8_t)56)
#define | SD_CMD_NO_CMD ((uint8_t)64)
#define | SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)
#define | SD_CMD_SD_APP_STAUS ((uint8_t)13)
#define | SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)
#define | SD_CMD_SD_APP_OP_COND ((uint8_t)41)
#define | SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)
#define | SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)
#define | SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)
#define | SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)
#define | SD_CMD_SD_APP_GET_MKB ((uint8_t)43)
#define | SD_CMD_SD_APP_GET_MID ((uint8_t)44)
#define | SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)
#define | SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)
#define | SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)
#define | SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)
#define | SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)
#define | SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)
#define | SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)
#define | SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)
#define | SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)
#define | SD_CMD_GO_IDLE_STATE ((uint8_t)0)
#define | SD_CMD_SEND_OP_COND ((uint8_t)1)
#define | SD_CMD_ALL_SEND_CID ((uint8_t)2)
#define | SD_CMD_SET_REL_ADDR ((uint8_t)3)
#define | SD_CMD_SET_DSR ((uint8_t)4)
#define | SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)
#define | SD_CMD_HS_SWITCH ((uint8_t)6)
#define | SD_CMD_SEL_DESEL_CARD ((uint8_t)7)
#define | SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)
#define | SD_CMD_SEND_CSD ((uint8_t)9)
#define | SD_CMD_SEND_CID ((uint8_t)10)
#define | SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)
#define | SD_CMD_STOP_TRANSMISSION ((uint8_t)12)
#define | SD_CMD_SEND_STATUS ((uint8_t)13)
#define | SD_CMD_HS_BUSTEST_READ ((uint8_t)14)
#define | SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)
#define | SD_CMD_SET_BLOCKLEN ((uint8_t)16)
#define | SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)
#define | SD_CMD_READ_MULT_BLOCK ((uint8_t)18)
#define | SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)
#define | SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)
#define | SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)
#define | SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)
#define | SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)
#define | SD_CMD_PROG_CID ((uint8_t)26)
#define | SD_CMD_PROG_CSD ((uint8_t)27)
#define | SD_CMD_SET_WRITE_PROT ((uint8_t)28)
#define | SD_CMD_CLR_WRITE_PROT ((uint8_t)29)
#define | SD_CMD_SEND_WRITE_PROT ((uint8_t)30)
#define | SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)
#define | SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)
#define | SD_CMD_ERASE_GRP_START ((uint8_t)35)
#define | SD_CMD_ERASE_GRP_END ((uint8_t)36)
#define | SD_CMD_ERASE ((uint8_t)38)
#define | SD_CMD_FAST_IO ((uint8_t)39)
#define | SD_CMD_GO_IRQ_STATE ((uint8_t)40)
#define | SD_CMD_LOCK_UNLOCK ((uint8_t)42)
#define | SD_CMD_APP_CMD ((uint8_t)55)
#define | SD_CMD_GEN_CMD ((uint8_t)56)
#define | SD_CMD_NO_CMD ((uint8_t)64)
#define | SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)
#define | SD_CMD_SD_APP_STAUS ((uint8_t)13)
#define | SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)
#define | SD_CMD_SD_APP_OP_COND ((uint8_t)41)
#define | SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)
#define | SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)
#define | SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)
#define | SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)
#define | SD_CMD_SD_APP_GET_MKB ((uint8_t)43)
#define | SD_CMD_SD_APP_GET_MID ((uint8_t)44)
#define | SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)
#define | SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)
#define | SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)
#define | SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)
#define | SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)
#define | SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)
#define | SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)
#define | SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)
#define | SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)
#define | SD_CMD_GO_IDLE_STATE ((uint8_t)0)
#define | SD_CMD_SEND_OP_COND ((uint8_t)1)
#define | SD_CMD_ALL_SEND_CID ((uint8_t)2)
#define | SD_CMD_SET_REL_ADDR ((uint8_t)3)
#define | SD_CMD_SET_DSR ((uint8_t)4)
#define | SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)
#define | SD_CMD_HS_SWITCH ((uint8_t)6)
#define | SD_CMD_SEL_DESEL_CARD ((uint8_t)7)
#define | SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)
#define | SD_CMD_SEND_CSD ((uint8_t)9)
#define | SD_CMD_SEND_CID ((uint8_t)10)
#define | SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)
#define | SD_CMD_STOP_TRANSMISSION ((uint8_t)12)
#define | SD_CMD_SEND_STATUS ((uint8_t)13)
#define | SD_CMD_HS_BUSTEST_READ ((uint8_t)14)
#define | SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)
#define | SD_CMD_SET_BLOCKLEN ((uint8_t)16)
#define | SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)
#define | SD_CMD_READ_MULT_BLOCK ((uint8_t)18)
#define | SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)
#define | SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)
#define | SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)
#define | SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)
#define | SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)
#define | SD_CMD_PROG_CID ((uint8_t)26)
#define | SD_CMD_PROG_CSD ((uint8_t)27)
#define | SD_CMD_SET_WRITE_PROT ((uint8_t)28)
#define | SD_CMD_CLR_WRITE_PROT ((uint8_t)29)
#define | SD_CMD_SEND_WRITE_PROT ((uint8_t)30)
#define | SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)
#define | SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)
#define | SD_CMD_ERASE_GRP_START ((uint8_t)35)
#define | SD_CMD_ERASE_GRP_END ((uint8_t)36)
#define | SD_CMD_ERASE ((uint8_t)38)
#define | SD_CMD_FAST_IO ((uint8_t)39)
#define | SD_CMD_GO_IRQ_STATE ((uint8_t)40)
#define | SD_CMD_LOCK_UNLOCK ((uint8_t)42)
#define | SD_CMD_APP_CMD ((uint8_t)55)
#define | SD_CMD_GEN_CMD ((uint8_t)56)
#define | SD_CMD_NO_CMD ((uint8_t)64)
#define | SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)
#define | SD_CMD_SD_APP_STAUS ((uint8_t)13)
#define | SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)
#define | SD_CMD_SD_APP_OP_COND ((uint8_t)41)
#define | SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)
#define | SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)
#define | SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)
#define | SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)
#define | SD_CMD_SD_APP_GET_MKB ((uint8_t)43)
#define | SD_CMD_SD_APP_GET_MID ((uint8_t)44)
#define | SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)
#define | SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)
#define | SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)
#define | SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)
#define | SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)
#define | SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)
#define | SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)
#define | SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)
#define | SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)
#define | SD_CMD_GO_IDLE_STATE ((uint8_t)0)
#define | SD_CMD_SEND_OP_COND ((uint8_t)1)
#define | SD_CMD_ALL_SEND_CID ((uint8_t)2)
#define | SD_CMD_SET_REL_ADDR ((uint8_t)3)
#define | SD_CMD_SET_DSR ((uint8_t)4)
#define | SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)
#define | SD_CMD_HS_SWITCH ((uint8_t)6)
#define | SD_CMD_SEL_DESEL_CARD ((uint8_t)7)
#define | SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)
#define | SD_CMD_SEND_CSD ((uint8_t)9)
#define | SD_CMD_SEND_CID ((uint8_t)10)
#define | SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)
#define | SD_CMD_STOP_TRANSMISSION ((uint8_t)12)
#define | SD_CMD_SEND_STATUS ((uint8_t)13)
#define | SD_CMD_HS_BUSTEST_READ ((uint8_t)14)
#define | SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)
#define | SD_CMD_SET_BLOCKLEN ((uint8_t)16)
#define | SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)
#define | SD_CMD_READ_MULT_BLOCK ((uint8_t)18)
#define | SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)
#define | SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)
#define | SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)
#define | SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)
#define | SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)
#define | SD_CMD_PROG_CID ((uint8_t)26)
#define | SD_CMD_PROG_CSD ((uint8_t)27)
#define | SD_CMD_SET_WRITE_PROT ((uint8_t)28)
#define | SD_CMD_CLR_WRITE_PROT ((uint8_t)29)
#define | SD_CMD_SEND_WRITE_PROT ((uint8_t)30)
#define | SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)
#define | SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)
#define | SD_CMD_ERASE_GRP_START ((uint8_t)35)
#define | SD_CMD_ERASE_GRP_END ((uint8_t)36)
#define | SD_CMD_ERASE ((uint8_t)38)
#define | SD_CMD_FAST_IO ((uint8_t)39)
#define | SD_CMD_GO_IRQ_STATE ((uint8_t)40)
#define | SD_CMD_LOCK_UNLOCK ((uint8_t)42)
#define | SD_CMD_APP_CMD ((uint8_t)55)
#define | SD_CMD_GEN_CMD ((uint8_t)56)
#define | SD_CMD_NO_CMD ((uint8_t)64)
#define | SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)
#define | SD_CMD_SD_APP_STAUS ((uint8_t)13)
#define | SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)
#define | SD_CMD_SD_APP_OP_COND ((uint8_t)41)
#define | SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)
#define | SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)
#define | SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)
#define | SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)
#define | SD_CMD_SD_APP_GET_MKB ((uint8_t)43)
#define | SD_CMD_SD_APP_GET_MID ((uint8_t)44)
#define | SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)
#define | SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)
#define | SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)
#define | SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)
#define | SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)
#define | SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)
#define | SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)
#define | SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)
#define | SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)

Detailed Description

Macro Definition Documentation

◆ SD_CMD_ALL_SEND_CID [1/4]

#define SD_CMD_ALL_SEND_CID ((uint8_t)2)

Definition at line 263 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_ALL_SEND_CID [2/4]

#define SD_CMD_ALL_SEND_CID ((uint8_t)2)

Definition at line 263 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_ALL_SEND_CID [3/4]

#define SD_CMD_ALL_SEND_CID ((uint8_t)2)

Definition at line 263 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_ALL_SEND_CID [4/4]

#define SD_CMD_ALL_SEND_CID ((uint8_t)2)

Definition at line 263 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_APP_CMD [1/4]

#define SD_CMD_APP_CMD ((uint8_t)55)

Definition at line 298 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_APP_CMD [2/4]

#define SD_CMD_APP_CMD ((uint8_t)55)

Definition at line 298 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_APP_CMD [3/4]

#define SD_CMD_APP_CMD ((uint8_t)55)

Definition at line 298 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_APP_CMD [4/4]

#define SD_CMD_APP_CMD ((uint8_t)55)

Definition at line 298 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_APP_SD_SET_BUSWIDTH [1/4]

#define SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)

following commands are sd card specific commands. should be sent before sending these commands.

Definition at line 306 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_APP_SD_SET_BUSWIDTH [2/4]

#define SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)

following commands are sd card specific commands. should be sent before sending these commands.

Definition at line 306 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_APP_SD_SET_BUSWIDTH [3/4]

#define SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)

following commands are sd card specific commands. should be sent before sending these commands.

Definition at line 306 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_APP_SD_SET_BUSWIDTH [4/4]

#define SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)

following commands are sd card specific commands. should be sent before sending these commands.

Definition at line 306 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_CLR_WRITE_PROT [1/4]

#define SD_CMD_CLR_WRITE_PROT ((uint8_t)29)

Definition at line 288 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_CLR_WRITE_PROT [2/4]

#define SD_CMD_CLR_WRITE_PROT ((uint8_t)29)

Definition at line 288 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_CLR_WRITE_PROT [3/4]

#define SD_CMD_CLR_WRITE_PROT ((uint8_t)29)

Definition at line 288 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_CLR_WRITE_PROT [4/4]

#define SD_CMD_CLR_WRITE_PROT ((uint8_t)29)

Definition at line 288 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_ERASE [1/4]

#define SD_CMD_ERASE ((uint8_t)38)

Definition at line 294 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_ERASE [2/4]

#define SD_CMD_ERASE ((uint8_t)38)

Definition at line 294 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_ERASE [3/4]

#define SD_CMD_ERASE ((uint8_t)38)

Definition at line 294 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_ERASE [4/4]

#define SD_CMD_ERASE ((uint8_t)38)

Definition at line 294 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_ERASE_GRP_END [1/4]

#define SD_CMD_ERASE_GRP_END ((uint8_t)36)

Definition at line 293 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_ERASE_GRP_END [2/4]

#define SD_CMD_ERASE_GRP_END ((uint8_t)36)

Definition at line 293 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_ERASE_GRP_END [3/4]

#define SD_CMD_ERASE_GRP_END ((uint8_t)36)

Definition at line 293 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_ERASE_GRP_END [4/4]

#define SD_CMD_ERASE_GRP_END ((uint8_t)36)

Definition at line 293 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_ERASE_GRP_START [1/4]

#define SD_CMD_ERASE_GRP_START ((uint8_t)35)

Definition at line 292 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_ERASE_GRP_START [2/4]

#define SD_CMD_ERASE_GRP_START ((uint8_t)35)

Definition at line 292 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_ERASE_GRP_START [3/4]

#define SD_CMD_ERASE_GRP_START ((uint8_t)35)

Definition at line 292 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_ERASE_GRP_START [4/4]

#define SD_CMD_ERASE_GRP_START ((uint8_t)35)

Definition at line 292 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_FAST_IO [1/4]

#define SD_CMD_FAST_IO ((uint8_t)39)

Definition at line 295 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_FAST_IO [2/4]

#define SD_CMD_FAST_IO ((uint8_t)39)

Definition at line 295 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_FAST_IO [3/4]

#define SD_CMD_FAST_IO ((uint8_t)39)

Definition at line 295 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_FAST_IO [4/4]

#define SD_CMD_FAST_IO ((uint8_t)39)

Definition at line 295 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_GEN_CMD [1/4]

#define SD_CMD_GEN_CMD ((uint8_t)56)

Definition at line 299 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_GEN_CMD [2/4]

#define SD_CMD_GEN_CMD ((uint8_t)56)

Definition at line 299 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_GEN_CMD [3/4]

#define SD_CMD_GEN_CMD ((uint8_t)56)

Definition at line 299 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_GEN_CMD [4/4]

#define SD_CMD_GEN_CMD ((uint8_t)56)

Definition at line 299 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_GO_IDLE_STATE [1/4]

#define SD_CMD_GO_IDLE_STATE ((uint8_t)0)

sdio commands index

Definition at line 261 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_GO_IDLE_STATE [2/4]

#define SD_CMD_GO_IDLE_STATE ((uint8_t)0)

sdio commands index

Definition at line 261 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_GO_IDLE_STATE [3/4]

#define SD_CMD_GO_IDLE_STATE ((uint8_t)0)

sdio commands index

Definition at line 261 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_GO_IDLE_STATE [4/4]

#define SD_CMD_GO_IDLE_STATE ((uint8_t)0)

sdio commands index

Definition at line 261 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_GO_INACTIVE_STATE [1/4]

#define SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)

Definition at line 276 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_GO_INACTIVE_STATE [2/4]

#define SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)

Definition at line 276 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_GO_INACTIVE_STATE [3/4]

#define SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)

Definition at line 276 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_GO_INACTIVE_STATE [4/4]

#define SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)

Definition at line 276 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_GO_IRQ_STATE [1/4]

#define SD_CMD_GO_IRQ_STATE ((uint8_t)40)

Definition at line 296 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_GO_IRQ_STATE [2/4]

#define SD_CMD_GO_IRQ_STATE ((uint8_t)40)

Definition at line 296 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_GO_IRQ_STATE [3/4]

#define SD_CMD_GO_IRQ_STATE ((uint8_t)40)

Definition at line 296 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_GO_IRQ_STATE [4/4]

#define SD_CMD_GO_IRQ_STATE ((uint8_t)40)

Definition at line 296 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_HS_BUSTEST_READ [1/4]

#define SD_CMD_HS_BUSTEST_READ ((uint8_t)14)

Definition at line 275 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_HS_BUSTEST_READ [2/4]

#define SD_CMD_HS_BUSTEST_READ ((uint8_t)14)

Definition at line 275 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_HS_BUSTEST_READ [3/4]

#define SD_CMD_HS_BUSTEST_READ ((uint8_t)14)

Definition at line 275 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_HS_BUSTEST_READ [4/4]

#define SD_CMD_HS_BUSTEST_READ ((uint8_t)14)

Definition at line 275 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_HS_BUSTEST_WRITE [1/4]

#define SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)

Definition at line 280 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_HS_BUSTEST_WRITE [2/4]

#define SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)

Definition at line 280 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_HS_BUSTEST_WRITE [3/4]

#define SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)

Definition at line 280 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_HS_BUSTEST_WRITE [4/4]

#define SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)

Definition at line 280 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_HS_SEND_EXT_CSD [1/4]

#define SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)

Definition at line 269 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_HS_SEND_EXT_CSD [2/4]

#define SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)

Definition at line 269 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_HS_SEND_EXT_CSD [3/4]

#define SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)

Definition at line 269 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_HS_SEND_EXT_CSD [4/4]

#define SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)

Definition at line 269 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_HS_SWITCH [1/4]

#define SD_CMD_HS_SWITCH ((uint8_t)6)

Definition at line 267 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_HS_SWITCH [2/4]

#define SD_CMD_HS_SWITCH ((uint8_t)6)

Definition at line 267 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_HS_SWITCH [3/4]

#define SD_CMD_HS_SWITCH ((uint8_t)6)

Definition at line 267 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_HS_SWITCH [4/4]

#define SD_CMD_HS_SWITCH ((uint8_t)6)

Definition at line 267 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_LOCK_UNLOCK [1/4]

#define SD_CMD_LOCK_UNLOCK ((uint8_t)42)

Definition at line 297 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_LOCK_UNLOCK [2/4]

#define SD_CMD_LOCK_UNLOCK ((uint8_t)42)

Definition at line 297 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_LOCK_UNLOCK [3/4]

#define SD_CMD_LOCK_UNLOCK ((uint8_t)42)

Definition at line 297 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_LOCK_UNLOCK [4/4]

#define SD_CMD_LOCK_UNLOCK ((uint8_t)42)

Definition at line 297 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_NO_CMD [1/4]

#define SD_CMD_NO_CMD ((uint8_t)64)

Definition at line 300 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_NO_CMD [2/4]

#define SD_CMD_NO_CMD ((uint8_t)64)

Definition at line 300 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_NO_CMD [3/4]

#define SD_CMD_NO_CMD ((uint8_t)64)

Definition at line 300 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_NO_CMD [4/4]

#define SD_CMD_NO_CMD ((uint8_t)64)

Definition at line 300 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_PROG_CID [1/4]

#define SD_CMD_PROG_CID ((uint8_t)26)

Definition at line 285 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_PROG_CID [2/4]

#define SD_CMD_PROG_CID ((uint8_t)26)

Definition at line 285 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_PROG_CID [3/4]

#define SD_CMD_PROG_CID ((uint8_t)26)

Definition at line 285 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_PROG_CID [4/4]

#define SD_CMD_PROG_CID ((uint8_t)26)

Definition at line 285 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_PROG_CSD [1/4]

#define SD_CMD_PROG_CSD ((uint8_t)27)

Definition at line 286 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_PROG_CSD [2/4]

#define SD_CMD_PROG_CSD ((uint8_t)27)

Definition at line 286 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_PROG_CSD [3/4]

#define SD_CMD_PROG_CSD ((uint8_t)27)

Definition at line 286 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_PROG_CSD [4/4]

#define SD_CMD_PROG_CSD ((uint8_t)27)

Definition at line 286 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_READ_DAT_UNTIL_STOP [1/4]

#define SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)

Definition at line 272 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_READ_DAT_UNTIL_STOP [2/4]

#define SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)

Definition at line 272 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_READ_DAT_UNTIL_STOP [3/4]

#define SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)

Definition at line 272 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_READ_DAT_UNTIL_STOP [4/4]

#define SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)

Definition at line 272 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_READ_MULT_BLOCK [1/4]

#define SD_CMD_READ_MULT_BLOCK ((uint8_t)18)

Definition at line 279 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_READ_MULT_BLOCK [2/4]

#define SD_CMD_READ_MULT_BLOCK ((uint8_t)18)

Definition at line 279 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_READ_MULT_BLOCK [3/4]

#define SD_CMD_READ_MULT_BLOCK ((uint8_t)18)

Definition at line 279 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_READ_MULT_BLOCK [4/4]

#define SD_CMD_READ_MULT_BLOCK ((uint8_t)18)

Definition at line 279 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_READ_SINGLE_BLOCK [1/4]

#define SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)

Definition at line 278 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_READ_SINGLE_BLOCK [2/4]

#define SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)

Definition at line 278 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_READ_SINGLE_BLOCK [3/4]

#define SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)

Definition at line 278 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_READ_SINGLE_BLOCK [4/4]

#define SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)

Definition at line 278 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_CHANGE_SECURE_AREA [1/4]

#define SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)

Definition at line 328 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_CHANGE_SECURE_AREA [2/4]

#define SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)

Definition at line 328 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_CHANGE_SECURE_AREA [3/4]

#define SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)

Definition at line 328 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_CHANGE_SECURE_AREA [4/4]

#define SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)

Definition at line 328 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_CER_RES1 [1/4]

#define SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)

Definition at line 324 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_CER_RES1 [2/4]

#define SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)

Definition at line 324 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_CER_RES1 [3/4]

#define SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)

Definition at line 324 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_CER_RES1 [4/4]

#define SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)

Definition at line 324 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_CER_RN2 [1/4]

#define SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)

Definition at line 322 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_CER_RN2 [2/4]

#define SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)

Definition at line 322 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_CER_RN2 [3/4]

#define SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)

Definition at line 322 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_CER_RN2 [4/4]

#define SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)

Definition at line 322 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_MID [1/4]

#define SD_CMD_SD_APP_GET_MID ((uint8_t)44)

Definition at line 320 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_MID [2/4]

#define SD_CMD_SD_APP_GET_MID ((uint8_t)44)

Definition at line 320 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_MID [3/4]

#define SD_CMD_SD_APP_GET_MID ((uint8_t)44)

Definition at line 320 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_MID [4/4]

#define SD_CMD_SD_APP_GET_MID ((uint8_t)44)

Definition at line 320 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_MKB [1/4]

#define SD_CMD_SD_APP_GET_MKB ((uint8_t)43)

following commands are sd card specific security commands. sdio_app_cmd should be sent before sending these commands.

Definition at line 319 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_MKB [2/4]

#define SD_CMD_SD_APP_GET_MKB ((uint8_t)43)

following commands are sd card specific security commands. sdio_app_cmd should be sent before sending these commands.

Definition at line 319 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_MKB [3/4]

#define SD_CMD_SD_APP_GET_MKB ((uint8_t)43)

following commands are sd card specific security commands. sdio_app_cmd should be sent before sending these commands.

Definition at line 319 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_MKB [4/4]

#define SD_CMD_SD_APP_GET_MKB ((uint8_t)43)

following commands are sd card specific security commands. sdio_app_cmd should be sent before sending these commands.

Definition at line 319 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_OP_COND [1/4]

#define SD_CMD_SD_APP_OP_COND ((uint8_t)41)

Definition at line 309 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_OP_COND [2/4]

#define SD_CMD_SD_APP_OP_COND ((uint8_t)41)

Definition at line 309 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_OP_COND [3/4]

#define SD_CMD_SD_APP_OP_COND ((uint8_t)41)

Definition at line 309 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_OP_COND [4/4]

#define SD_CMD_SD_APP_OP_COND ((uint8_t)41)

Definition at line 309 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_ERASE [1/4]

#define SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)

Definition at line 327 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_ERASE [2/4]

#define SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)

Definition at line 327 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_ERASE [3/4]

#define SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)

Definition at line 327 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_ERASE [4/4]

#define SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)

Definition at line 327 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK [1/4]

#define SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)

Definition at line 325 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK [2/4]

#define SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)

Definition at line 325 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK [3/4]

#define SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)

Definition at line 325 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK [4/4]

#define SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)

Definition at line 325 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_WRITE_MKB [1/4]

#define SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)

Definition at line 329 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_WRITE_MKB [2/4]

#define SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)

Definition at line 329 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_WRITE_MKB [3/4]

#define SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)

Definition at line 329 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_WRITE_MKB [4/4]

#define SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)

Definition at line 329 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK [1/4]

#define SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)

Definition at line 326 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK [2/4]

#define SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)

Definition at line 326 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK [3/4]

#define SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)

Definition at line 326 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK [4/4]

#define SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)

Definition at line 326 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS [1/4]

#define SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)

Definition at line 308 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS [2/4]

#define SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)

Definition at line 308 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS [3/4]

#define SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)

Definition at line 308 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS [4/4]

#define SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)

Definition at line 308 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SEND_SCR [1/4]

#define SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)

Definition at line 311 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SEND_SCR [2/4]

#define SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)

Definition at line 311 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SEND_SCR [3/4]

#define SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)

Definition at line 311 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SEND_SCR [4/4]

#define SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)

Definition at line 311 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SET_CER_RES2 [1/4]

#define SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)

Definition at line 323 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SET_CER_RES2 [2/4]

#define SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)

Definition at line 323 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SET_CER_RES2 [3/4]

#define SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)

Definition at line 323 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SET_CER_RES2 [4/4]

#define SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)

Definition at line 323 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SET_CER_RN1 [1/4]

#define SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)

Definition at line 321 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SET_CER_RN1 [2/4]

#define SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)

Definition at line 321 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SET_CER_RN1 [3/4]

#define SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)

Definition at line 321 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SET_CER_RN1 [4/4]

#define SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)

Definition at line 321 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SET_CLR_CARD_DETECT [1/4]

#define SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)

Definition at line 310 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SET_CLR_CARD_DETECT [2/4]

#define SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)

Definition at line 310 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SET_CLR_CARD_DETECT [3/4]

#define SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)

Definition at line 310 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SET_CLR_CARD_DETECT [4/4]

#define SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)

Definition at line 310 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_STAUS [1/4]

#define SD_CMD_SD_APP_STAUS ((uint8_t)13)

Definition at line 307 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_STAUS [2/4]

#define SD_CMD_SD_APP_STAUS ((uint8_t)13)

Definition at line 307 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_STAUS [3/4]

#define SD_CMD_SD_APP_STAUS ((uint8_t)13)

Definition at line 307 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_STAUS [4/4]

#define SD_CMD_SD_APP_STAUS ((uint8_t)13)

Definition at line 307 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_ERASE_GRP_END [1/4]

#define SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)

Definition at line 291 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_ERASE_GRP_END [2/4]

#define SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)

Definition at line 291 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_ERASE_GRP_END [3/4]

#define SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)

Definition at line 291 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_ERASE_GRP_END [4/4]

#define SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)

Definition at line 291 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_ERASE_GRP_START [1/4]

#define SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)

Definition at line 290 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_ERASE_GRP_START [2/4]

#define SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)

Definition at line 290 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_ERASE_GRP_START [3/4]

#define SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)

Definition at line 290 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_ERASE_GRP_START [4/4]

#define SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)

Definition at line 290 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SDIO_RW_DIRECT [1/4]

#define SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)

Definition at line 312 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SDIO_RW_DIRECT [2/4]

#define SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)

Definition at line 312 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SDIO_RW_DIRECT [3/4]

#define SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)

Definition at line 312 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SDIO_RW_DIRECT [4/4]

#define SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)

Definition at line 312 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SDIO_RW_EXTENDED [1/4]

#define SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)

Definition at line 313 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SDIO_RW_EXTENDED [2/4]

#define SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)

Definition at line 313 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SDIO_RW_EXTENDED [3/4]

#define SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)

Definition at line 313 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SDIO_RW_EXTENDED [4/4]

#define SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)

Definition at line 313 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SDIO_SEN_OP_COND [1/4]

#define SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)

Definition at line 266 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SDIO_SEN_OP_COND [2/4]

#define SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)

Definition at line 266 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SDIO_SEN_OP_COND [3/4]

#define SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)

Definition at line 266 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SDIO_SEN_OP_COND [4/4]

#define SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)

Definition at line 266 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SEL_DESEL_CARD [1/4]

#define SD_CMD_SEL_DESEL_CARD ((uint8_t)7)

Definition at line 268 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SEL_DESEL_CARD [2/4]

#define SD_CMD_SEL_DESEL_CARD ((uint8_t)7)

Definition at line 268 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SEL_DESEL_CARD [3/4]

#define SD_CMD_SEL_DESEL_CARD ((uint8_t)7)

Definition at line 268 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SEL_DESEL_CARD [4/4]

#define SD_CMD_SEL_DESEL_CARD ((uint8_t)7)

Definition at line 268 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SEND_CID [1/4]

#define SD_CMD_SEND_CID ((uint8_t)10)

Definition at line 271 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SEND_CID [2/4]

#define SD_CMD_SEND_CID ((uint8_t)10)

Definition at line 271 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SEND_CID [3/4]

#define SD_CMD_SEND_CID ((uint8_t)10)

Definition at line 271 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SEND_CID [4/4]

#define SD_CMD_SEND_CID ((uint8_t)10)

Definition at line 271 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SEND_CSD [1/4]

#define SD_CMD_SEND_CSD ((uint8_t)9)

Definition at line 270 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SEND_CSD [2/4]

#define SD_CMD_SEND_CSD ((uint8_t)9)

Definition at line 270 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SEND_CSD [3/4]

#define SD_CMD_SEND_CSD ((uint8_t)9)

Definition at line 270 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SEND_CSD [4/4]

#define SD_CMD_SEND_CSD ((uint8_t)9)

Definition at line 270 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SEND_OP_COND [1/4]

#define SD_CMD_SEND_OP_COND ((uint8_t)1)

Definition at line 262 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SEND_OP_COND [2/4]

#define SD_CMD_SEND_OP_COND ((uint8_t)1)

Definition at line 262 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SEND_OP_COND [3/4]

#define SD_CMD_SEND_OP_COND ((uint8_t)1)

Definition at line 262 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SEND_OP_COND [4/4]

#define SD_CMD_SEND_OP_COND ((uint8_t)1)

Definition at line 262 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SEND_STATUS [1/4]

#define SD_CMD_SEND_STATUS ((uint8_t)13)

Definition at line 274 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SEND_STATUS [2/4]

#define SD_CMD_SEND_STATUS ((uint8_t)13)

Definition at line 274 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SEND_STATUS [3/4]

#define SD_CMD_SEND_STATUS ((uint8_t)13)

Definition at line 274 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SEND_STATUS [4/4]

#define SD_CMD_SEND_STATUS ((uint8_t)13)

Definition at line 274 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SEND_WRITE_PROT [1/4]

#define SD_CMD_SEND_WRITE_PROT ((uint8_t)30)

Definition at line 289 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SEND_WRITE_PROT [2/4]

#define SD_CMD_SEND_WRITE_PROT ((uint8_t)30)

Definition at line 289 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SEND_WRITE_PROT [3/4]

#define SD_CMD_SEND_WRITE_PROT ((uint8_t)30)

Definition at line 289 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SEND_WRITE_PROT [4/4]

#define SD_CMD_SEND_WRITE_PROT ((uint8_t)30)

Definition at line 289 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SET_BLOCK_COUNT [1/4]

#define SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)

Definition at line 282 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SET_BLOCK_COUNT [2/4]

#define SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)

Definition at line 282 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SET_BLOCK_COUNT [3/4]

#define SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)

Definition at line 282 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SET_BLOCK_COUNT [4/4]

#define SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)

Definition at line 282 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SET_BLOCKLEN [1/4]

#define SD_CMD_SET_BLOCKLEN ((uint8_t)16)

Definition at line 277 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SET_BLOCKLEN [2/4]

#define SD_CMD_SET_BLOCKLEN ((uint8_t)16)

Definition at line 277 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SET_BLOCKLEN [3/4]

#define SD_CMD_SET_BLOCKLEN ((uint8_t)16)

Definition at line 277 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SET_BLOCKLEN [4/4]

#define SD_CMD_SET_BLOCKLEN ((uint8_t)16)

Definition at line 277 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SET_DSR [1/4]

#define SD_CMD_SET_DSR ((uint8_t)4)

Definition at line 265 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SET_DSR [2/4]

#define SD_CMD_SET_DSR ((uint8_t)4)

Definition at line 265 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SET_DSR [3/4]

#define SD_CMD_SET_DSR ((uint8_t)4)

Definition at line 265 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SET_DSR [4/4]

#define SD_CMD_SET_DSR ((uint8_t)4)

Definition at line 265 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SET_REL_ADDR [1/4]

#define SD_CMD_SET_REL_ADDR ((uint8_t)3)

Definition at line 264 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SET_REL_ADDR [2/4]

#define SD_CMD_SET_REL_ADDR ((uint8_t)3)

Definition at line 264 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SET_REL_ADDR [3/4]

#define SD_CMD_SET_REL_ADDR ((uint8_t)3)

Definition at line 264 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SET_REL_ADDR [4/4]

#define SD_CMD_SET_REL_ADDR ((uint8_t)3)

Definition at line 264 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SET_WRITE_PROT [1/4]

#define SD_CMD_SET_WRITE_PROT ((uint8_t)28)

Definition at line 287 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SET_WRITE_PROT [2/4]

#define SD_CMD_SET_WRITE_PROT ((uint8_t)28)

Definition at line 287 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SET_WRITE_PROT [3/4]

#define SD_CMD_SET_WRITE_PROT ((uint8_t)28)

Definition at line 287 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SET_WRITE_PROT [4/4]

#define SD_CMD_SET_WRITE_PROT ((uint8_t)28)

Definition at line 287 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_STOP_TRANSMISSION [1/4]

#define SD_CMD_STOP_TRANSMISSION ((uint8_t)12)

Definition at line 273 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_STOP_TRANSMISSION [2/4]

#define SD_CMD_STOP_TRANSMISSION ((uint8_t)12)

Definition at line 273 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_STOP_TRANSMISSION [3/4]

#define SD_CMD_STOP_TRANSMISSION ((uint8_t)12)

Definition at line 273 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_STOP_TRANSMISSION [4/4]

#define SD_CMD_STOP_TRANSMISSION ((uint8_t)12)

Definition at line 273 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_WRITE_DAT_UNTIL_STOP [1/4]

#define SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)

Definition at line 281 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_WRITE_DAT_UNTIL_STOP [2/4]

#define SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)

Definition at line 281 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_WRITE_DAT_UNTIL_STOP [3/4]

#define SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)

Definition at line 281 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_WRITE_DAT_UNTIL_STOP [4/4]

#define SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)

Definition at line 281 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_WRITE_MULT_BLOCK [1/4]

#define SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)

Definition at line 284 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_WRITE_MULT_BLOCK [2/4]

#define SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)

Definition at line 284 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_WRITE_MULT_BLOCK [3/4]

#define SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)

Definition at line 284 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_WRITE_MULT_BLOCK [4/4]

#define SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)

Definition at line 284 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_WRITE_SINGLE_BLOCK [1/4]

#define SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)

Definition at line 283 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_WRITE_SINGLE_BLOCK [2/4]

#define SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)

Definition at line 283 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_WRITE_SINGLE_BLOCK [3/4]

#define SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)

Definition at line 283 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_WRITE_SINGLE_BLOCK [4/4]

#define SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)

Definition at line 283 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.


AT32F435/437 Firmwary Library: SDIO_paremeters_definition

Macros
SDIO_paremeters_definition
AT32F435_periph_examples | AT32F437_periph_examples » SD_mmc_card | AT32F435_periph_examples | AT32F437_periph_examples » SDIO_fatfs

Macros

#define | NULL 0
#define | SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)
#define | SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)
#define | SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SDIO_FIFO_Address ((uint32_t)0x40018080)
#define | NULL 0
#define | SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)
#define | SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)
#define | SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SDIO_FIFO_Address ((uint32_t)0x40018080)
#define | NULL 0
#define | SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)
#define | SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)
#define | SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SDIO_FIFO_Address ((uint32_t)0x40018080)
#define | NULL 0
#define | SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)
#define | SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)
#define | SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SDIO_FIFO_Address ((uint32_t)0x40018080)

Detailed Description

Macro Definition Documentation

◆ NULL [1/4]

#define NULL 0

sdio paremeters

Definition at line 342 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ NULL [2/4]

#define NULL 0

sdio paremeters

Definition at line 342 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ NULL [3/4]

#define NULL 0

sdio paremeters

Definition at line 342 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ NULL [4/4]

#define NULL 0

sdio paremeters

Definition at line 342 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SDIO_CMD0TIMEOUT [1/4]

#define SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)

Definition at line 344 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SDIO_CMD0TIMEOUT [2/4]

#define SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)

Definition at line 344 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SDIO_CMD0TIMEOUT [3/4]

#define SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)

Definition at line 344 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SDIO_CMD0TIMEOUT [4/4]

#define SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)

Definition at line 344 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SDIO_DATATIMEOUT [1/4]

#define SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)

Definition at line 345 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SDIO_DATATIMEOUT [2/4]

#define SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)

Definition at line 345 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SDIO_DATATIMEOUT [3/4]

#define SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)

Definition at line 345 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SDIO_DATATIMEOUT [4/4]

#define SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)

Definition at line 345 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SDIO_FIFO_Address [1/4]

#define SDIO_FIFO_Address ((uint32_t)0x40018080)

Definition at line 346 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SDIO_FIFO_Address [2/4]

#define SDIO_FIFO_Address ((uint32_t)0x40018080)

Definition at line 346 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SDIO_FIFO_Address [3/4]

#define SDIO_FIFO_Address ((uint32_t)0x40018080)

Definition at line 346 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SDIO_FIFO_Address [4/4]

#define SDIO_FIFO_Address ((uint32_t)0x40018080)

Definition at line 346 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SDIO_STATIC_FLAGS [1/4]

#define SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)

Definition at line 343 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SDIO_STATIC_FLAGS [2/4]

#define SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)

Definition at line 343 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SDIO_STATIC_FLAGS [3/4]

#define SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)

Definition at line 343 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SDIO_STATIC_FLAGS [4/4]

#define SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)

Definition at line 343 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.


AT32F435/437 Firmwary Library: SDIO_response_definition

Macros
SDIO_response_definition
AT32F435_periph_examples | AT32F437_periph_examples » SD_mmc_card | AT32F435_periph_examples | AT32F437_periph_examples » SDIO_fatfs

Macros

#define | SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)
#define | SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)
#define | SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)
#define | SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)
#define | SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)
#define | SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)
#define | SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)
#define | SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)
#define | SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)
#define | SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)
#define | SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)
#define | SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)
#define | SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)
#define | SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)
#define | SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)
#define | SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)
#define | SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)
#define | SD_OCR_ERASE_RESET ((uint32_t)0x00002000)
#define | MMC_SWITCH_ERROR ((uint32_t)0x00000080)
#define | SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)
#define | SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)
#define | SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)
#define | SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)
#define | SD_R5_ERROR ((uint32_t)0x00000800)
#define | SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)
#define | SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)
#define | SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)
#define | SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)
#define | SD_HIGH_CAPACITY ((uint32_t)0x40000000)
#define | SD_STD_CAPACITY ((uint32_t)0x00000000)
#define | SD_CHECK_PATTERN ((uint32_t)0x000001AA)
#define | SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)
#define | SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)
#define | SD_ALLZERO ((uint32_t)0x00000000)
#define | SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)
#define | SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)
#define | SD_CARD_LOCKED ((uint32_t)0x02000000)
#define | SD_CARD_PROGRAMMING ((uint32_t)0x00000007)
#define | SD_CARD_RECEIVING ((uint32_t)0x00000006)
#define | SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SD_0TO7BITS ((uint32_t)0x000000FF)
#define | SD_8TO15BITS ((uint32_t)0x0000FF00)
#define | SD_16TO23BITS ((uint32_t)0x00FF0000)
#define | SD_24TO31BITS ((uint32_t)0xFF000000)
#define | SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)
#define | SD_HALFFIFO ((uint32_t)0x00000008)
#define | SD_HALFFIFOBYTES ((uint32_t)0x00000020)
#define | SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)
#define | SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)
#define | SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)
#define | SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)
#define | SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)
#define | SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)
#define | SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)
#define | SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)
#define | SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)
#define | SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)
#define | SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)
#define | SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)
#define | SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)
#define | SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)
#define | SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)
#define | SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)
#define | SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)
#define | SD_OCR_ERASE_RESET ((uint32_t)0x00002000)
#define | MMC_SWITCH_ERROR ((uint32_t)0x00000080)
#define | SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)
#define | SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)
#define | SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)
#define | SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)
#define | SD_R5_ERROR ((uint32_t)0x00000800)
#define | SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)
#define | SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)
#define | SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)
#define | SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)
#define | SD_HIGH_CAPACITY ((uint32_t)0x40000000)
#define | SD_STD_CAPACITY ((uint32_t)0x00000000)
#define | SD_CHECK_PATTERN ((uint32_t)0x000001AA)
#define | SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)
#define | SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)
#define | SD_ALLZERO ((uint32_t)0x00000000)
#define | SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)
#define | SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)
#define | SD_CARD_LOCKED ((uint32_t)0x02000000)
#define | SD_CARD_PROGRAMMING ((uint32_t)0x00000007)
#define | SD_CARD_RECEIVING ((uint32_t)0x00000006)
#define | SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SD_0TO7BITS ((uint32_t)0x000000FF)
#define | SD_8TO15BITS ((uint32_t)0x0000FF00)
#define | SD_16TO23BITS ((uint32_t)0x00FF0000)
#define | SD_24TO31BITS ((uint32_t)0xFF000000)
#define | SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)
#define | SD_HALFFIFO ((uint32_t)0x00000008)
#define | SD_HALFFIFOBYTES ((uint32_t)0x00000020)
#define | SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)
#define | SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)
#define | SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)
#define | SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)
#define | SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)
#define | SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)
#define | SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)
#define | SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)
#define | SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)
#define | SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)
#define | SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)
#define | SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)
#define | SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)
#define | SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)
#define | SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)
#define | SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)
#define | SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)
#define | SD_OCR_ERASE_RESET ((uint32_t)0x00002000)
#define | MMC_SWITCH_ERROR ((uint32_t)0x00000080)
#define | SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)
#define | SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)
#define | SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)
#define | SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)
#define | SD_R5_ERROR ((uint32_t)0x00000800)
#define | SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)
#define | SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)
#define | SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)
#define | SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)
#define | SD_HIGH_CAPACITY ((uint32_t)0x40000000)
#define | SD_STD_CAPACITY ((uint32_t)0x00000000)
#define | SD_CHECK_PATTERN ((uint32_t)0x000001AA)
#define | SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)
#define | SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)
#define | SD_ALLZERO ((uint32_t)0x00000000)
#define | SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)
#define | SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)
#define | SD_CARD_LOCKED ((uint32_t)0x02000000)
#define | SD_CARD_PROGRAMMING ((uint32_t)0x00000007)
#define | SD_CARD_RECEIVING ((uint32_t)0x00000006)
#define | SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SD_0TO7BITS ((uint32_t)0x000000FF)
#define | SD_8TO15BITS ((uint32_t)0x0000FF00)
#define | SD_16TO23BITS ((uint32_t)0x00FF0000)
#define | SD_24TO31BITS ((uint32_t)0xFF000000)
#define | SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)
#define | SD_HALFFIFO ((uint32_t)0x00000008)
#define | SD_HALFFIFOBYTES ((uint32_t)0x00000020)
#define | SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)
#define | SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)
#define | SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)
#define | SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)
#define | SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)
#define | SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)
#define | SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)
#define | SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)
#define | SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)
#define | SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)
#define | SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)
#define | SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)
#define | SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)
#define | SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)
#define | SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)
#define | SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)
#define | SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)
#define | SD_OCR_ERASE_RESET ((uint32_t)0x00002000)
#define | MMC_SWITCH_ERROR ((uint32_t)0x00000080)
#define | SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)
#define | SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)
#define | SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)
#define | SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)
#define | SD_R5_ERROR ((uint32_t)0x00000800)
#define | SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)
#define | SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)
#define | SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)
#define | SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)
#define | SD_HIGH_CAPACITY ((uint32_t)0x40000000)
#define | SD_STD_CAPACITY ((uint32_t)0x00000000)
#define | SD_CHECK_PATTERN ((uint32_t)0x000001AA)
#define | SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)
#define | SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)
#define | SD_ALLZERO ((uint32_t)0x00000000)
#define | SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)
#define | SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)
#define | SD_CARD_LOCKED ((uint32_t)0x02000000)
#define | SD_CARD_PROGRAMMING ((uint32_t)0x00000007)
#define | SD_CARD_RECEIVING ((uint32_t)0x00000006)
#define | SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SD_0TO7BITS ((uint32_t)0x000000FF)
#define | SD_8TO15BITS ((uint32_t)0x0000FF00)
#define | SD_16TO23BITS ((uint32_t)0x00FF0000)
#define | SD_24TO31BITS ((uint32_t)0xFF000000)
#define | SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)
#define | SD_HALFFIFO ((uint32_t)0x00000008)
#define | SD_HALFFIFOBYTES ((uint32_t)0x00000020)

Detailed Description

Macro Definition Documentation

◆ MMC_SWITCH_ERROR [1/4]

#define MMC_SWITCH_ERROR ((uint32_t)0x00000080)

Definition at line 377 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ MMC_SWITCH_ERROR [2/4]

#define MMC_SWITCH_ERROR ((uint32_t)0x00000080)

Definition at line 377 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ MMC_SWITCH_ERROR [3/4]

#define MMC_SWITCH_ERROR ((uint32_t)0x00000080)

Definition at line 377 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ MMC_SWITCH_ERROR [4/4]

#define MMC_SWITCH_ERROR ((uint32_t)0x00000080)

Definition at line 377 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_0TO7BITS [1/4]

#define SD_0TO7BITS ((uint32_t)0x000000FF)

Definition at line 407 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_0TO7BITS [2/4]

#define SD_0TO7BITS ((uint32_t)0x000000FF)

Definition at line 407 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_0TO7BITS [3/4]

#define SD_0TO7BITS ((uint32_t)0x000000FF)

Definition at line 407 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_0TO7BITS [4/4]

#define SD_0TO7BITS ((uint32_t)0x000000FF)

Definition at line 407 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_16TO23BITS [1/4]

#define SD_16TO23BITS ((uint32_t)0x00FF0000)

Definition at line 409 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_16TO23BITS [2/4]

#define SD_16TO23BITS ((uint32_t)0x00FF0000)

Definition at line 409 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_16TO23BITS [3/4]

#define SD_16TO23BITS ((uint32_t)0x00FF0000)

Definition at line 409 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_16TO23BITS [4/4]

#define SD_16TO23BITS ((uint32_t)0x00FF0000)

Definition at line 409 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_24TO31BITS [1/4]

#define SD_24TO31BITS ((uint32_t)0xFF000000)

Definition at line 410 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_24TO31BITS [2/4]

#define SD_24TO31BITS ((uint32_t)0xFF000000)

Definition at line 410 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_24TO31BITS [3/4]

#define SD_24TO31BITS ((uint32_t)0xFF000000)

Definition at line 410 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_24TO31BITS [4/4]

#define SD_24TO31BITS ((uint32_t)0xFF000000)

Definition at line 410 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_8TO15BITS [1/4]

#define SD_8TO15BITS ((uint32_t)0x0000FF00)

Definition at line 408 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_8TO15BITS [2/4]

#define SD_8TO15BITS ((uint32_t)0x0000FF00)

Definition at line 408 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_8TO15BITS [3/4]

#define SD_8TO15BITS ((uint32_t)0x0000FF00)

Definition at line 408 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_8TO15BITS [4/4]

#define SD_8TO15BITS ((uint32_t)0x0000FF00)

Definition at line 408 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_ALLZERO [1/4]

#define SD_ALLZERO ((uint32_t)0x00000000)

Definition at line 400 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_ALLZERO [2/4]

#define SD_ALLZERO ((uint32_t)0x00000000)

Definition at line 400 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_ALLZERO [3/4]

#define SD_ALLZERO ((uint32_t)0x00000000)

Definition at line 400 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_ALLZERO [4/4]

#define SD_ALLZERO ((uint32_t)0x00000000)

Definition at line 400 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CARD_LOCKED [1/4]

#define SD_CARD_LOCKED ((uint32_t)0x02000000)

Definition at line 403 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CARD_LOCKED [2/4]

#define SD_CARD_LOCKED ((uint32_t)0x02000000)

Definition at line 403 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CARD_LOCKED [3/4]

#define SD_CARD_LOCKED ((uint32_t)0x02000000)

Definition at line 403 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CARD_LOCKED [4/4]

#define SD_CARD_LOCKED ((uint32_t)0x02000000)

Definition at line 403 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CARD_PROGRAMMING [1/4]

#define SD_CARD_PROGRAMMING ((uint32_t)0x00000007)

Definition at line 404 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CARD_PROGRAMMING [2/4]

#define SD_CARD_PROGRAMMING ((uint32_t)0x00000007)

Definition at line 404 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CARD_PROGRAMMING [3/4]

#define SD_CARD_PROGRAMMING ((uint32_t)0x00000007)

Definition at line 404 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CARD_PROGRAMMING [4/4]

#define SD_CARD_PROGRAMMING ((uint32_t)0x00000007)

Definition at line 404 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CARD_RECEIVING [1/4]

#define SD_CARD_RECEIVING ((uint32_t)0x00000006)

Definition at line 405 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CARD_RECEIVING [2/4]

#define SD_CARD_RECEIVING ((uint32_t)0x00000006)

Definition at line 405 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CARD_RECEIVING [3/4]

#define SD_CARD_RECEIVING ((uint32_t)0x00000006)

Definition at line 405 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CARD_RECEIVING [4/4]

#define SD_CARD_RECEIVING ((uint32_t)0x00000006)

Definition at line 405 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CHECK_PATTERN [1/4]

#define SD_CHECK_PATTERN ((uint32_t)0x000001AA)

Definition at line 397 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CHECK_PATTERN [2/4]

#define SD_CHECK_PATTERN ((uint32_t)0x000001AA)

Definition at line 397 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CHECK_PATTERN [3/4]

#define SD_CHECK_PATTERN ((uint32_t)0x000001AA)

Definition at line 397 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CHECK_PATTERN [4/4]

#define SD_CHECK_PATTERN ((uint32_t)0x000001AA)

Definition at line 397 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_DATATIMEOUT [1/4]

#define SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)

Definition at line 406 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_DATATIMEOUT [2/4]

#define SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)

Definition at line 406 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_DATATIMEOUT [3/4]

#define SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)

Definition at line 406 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_DATATIMEOUT [4/4]

#define SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)

Definition at line 406 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_HALFFIFO [1/4]

#define SD_HALFFIFO ((uint32_t)0x00000008)

Definition at line 412 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_HALFFIFO [2/4]

#define SD_HALFFIFO ((uint32_t)0x00000008)

Definition at line 412 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_HALFFIFO [3/4]

#define SD_HALFFIFO ((uint32_t)0x00000008)

Definition at line 412 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_HALFFIFO [4/4]

#define SD_HALFFIFO ((uint32_t)0x00000008)

Definition at line 412 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_HALFFIFOBYTES [1/4]

#define SD_HALFFIFOBYTES ((uint32_t)0x00000020)

Definition at line 413 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_HALFFIFOBYTES [2/4]

#define SD_HALFFIFOBYTES ((uint32_t)0x00000020)

Definition at line 413 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_HALFFIFOBYTES [3/4]

#define SD_HALFFIFOBYTES ((uint32_t)0x00000020)

Definition at line 413 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_HALFFIFOBYTES [4/4]

#define SD_HALFFIFOBYTES ((uint32_t)0x00000020)

Definition at line 413 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_HIGH_CAPACITY [1/4]

#define SD_HIGH_CAPACITY ((uint32_t)0x40000000)

Definition at line 395 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_HIGH_CAPACITY [2/4]

#define SD_HIGH_CAPACITY ((uint32_t)0x40000000)

Definition at line 395 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_HIGH_CAPACITY [3/4]

#define SD_HIGH_CAPACITY ((uint32_t)0x40000000)

Definition at line 395 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_HIGH_CAPACITY [4/4]

#define SD_HIGH_CAPACITY ((uint32_t)0x40000000)

Definition at line 395 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_MAX_DATA_LENGTH [1/4]

#define SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)

Definition at line 411 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_MAX_DATA_LENGTH [2/4]

#define SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)

Definition at line 411 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_MAX_DATA_LENGTH [3/4]

#define SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)

Definition at line 411 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_MAX_DATA_LENGTH [4/4]

#define SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)

Definition at line 411 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_MAX_VOLT_TRIAL [1/4]

#define SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)

Definition at line 399 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_MAX_VOLT_TRIAL [2/4]

#define SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)

Definition at line 399 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_MAX_VOLT_TRIAL [3/4]

#define SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)

Definition at line 399 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_MAX_VOLT_TRIAL [4/4]

#define SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)

Definition at line 399 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_ADDR_MISALIGNED [1/4]

#define SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)

Definition at line 360 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_ADDR_MISALIGNED [2/4]

#define SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)

Definition at line 360 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_ADDR_MISALIGNED [3/4]

#define SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)

Definition at line 360 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_ADDR_MISALIGNED [4/4]

#define SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)

Definition at line 360 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_ADDR_OUT_OF_RANGE [1/4]

#define SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)

mask for errors card status r1 (ocr register)

Definition at line 359 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_ADDR_OUT_OF_RANGE [2/4]

#define SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)

mask for errors card status r1 (ocr register)

Definition at line 359 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_ADDR_OUT_OF_RANGE [3/4]

#define SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)

mask for errors card status r1 (ocr register)

Definition at line 359 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_ADDR_OUT_OF_RANGE [4/4]

#define SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)

mask for errors card status r1 (ocr register)

Definition at line 359 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_AKE_SEQ_ERROR [1/4]

#define SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)

Definition at line 378 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_AKE_SEQ_ERROR [2/4]

#define SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)

Definition at line 378 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_AKE_SEQ_ERROR [3/4]

#define SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)

Definition at line 378 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_AKE_SEQ_ERROR [4/4]

#define SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)

Definition at line 378 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_BLK_LEN_ERR [1/4]

#define SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)

Definition at line 361 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_BLK_LEN_ERR [2/4]

#define SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)

Definition at line 361 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_BLK_LEN_ERR [3/4]

#define SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)

Definition at line 361 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_BLK_LEN_ERR [4/4]

#define SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)

Definition at line 361 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_CARD_CONTROLLER_ERR [1/4]

#define SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)

Definition at line 369 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_CARD_CONTROLLER_ERR [2/4]

#define SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)

Definition at line 369 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_CARD_CONTROLLER_ERR [3/4]

#define SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)

Definition at line 369 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_CARD_CONTROLLER_ERR [4/4]

#define SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)

Definition at line 369 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_CARD_ECC_DISABLED [1/4]

#define SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)

Definition at line 375 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_CARD_ECC_DISABLED [2/4]

#define SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)

Definition at line 375 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_CARD_ECC_DISABLED [3/4]

#define SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)

Definition at line 375 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_CARD_ECC_DISABLED [4/4]

#define SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)

Definition at line 375 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_CARD_ECC_ERROR [1/4]

#define SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)

Definition at line 368 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_CARD_ECC_ERROR [2/4]

#define SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)

Definition at line 368 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_CARD_ECC_ERROR [3/4]

#define SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)

Definition at line 368 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_CARD_ECC_ERROR [4/4]

#define SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)

Definition at line 368 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_CID_CSD_OVERWRIETE [1/4]

#define SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)

Definition at line 373 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_CID_CSD_OVERWRIETE [2/4]

#define SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)

Definition at line 373 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_CID_CSD_OVERWRIETE [3/4]

#define SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)

Definition at line 373 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_CID_CSD_OVERWRIETE [4/4]

#define SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)

Definition at line 373 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_CMD_CRC_ERROR [1/4]

#define SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)

Definition at line 366 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_CMD_CRC_ERROR [2/4]

#define SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)

Definition at line 366 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_CMD_CRC_ERROR [3/4]

#define SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)

Definition at line 366 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_CMD_CRC_ERROR [4/4]

#define SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)

Definition at line 366 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_ERASE_RESET [1/4]

#define SD_OCR_ERASE_RESET ((uint32_t)0x00002000)

Definition at line 376 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_ERASE_RESET [2/4]

#define SD_OCR_ERASE_RESET ((uint32_t)0x00002000)

Definition at line 376 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_ERASE_RESET [3/4]

#define SD_OCR_ERASE_RESET ((uint32_t)0x00002000)

Definition at line 376 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_ERASE_RESET [4/4]

#define SD_OCR_ERASE_RESET ((uint32_t)0x00002000)

Definition at line 376 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_ERASE_SEQ_ERR [1/4]

#define SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)

Definition at line 362 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_ERASE_SEQ_ERR [2/4]

#define SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)

Definition at line 362 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_ERASE_SEQ_ERR [3/4]

#define SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)

Definition at line 362 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_ERASE_SEQ_ERR [4/4]

#define SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)

Definition at line 362 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_ERRORBITS [1/4]

#define SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)

Definition at line 379 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_ERRORBITS [2/4]

#define SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)

Definition at line 379 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_ERRORBITS [3/4]

#define SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)

Definition at line 379 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_ERRORBITS [4/4]

#define SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)

Definition at line 379 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_GENERAL_UNKNOWN_ERROR [1/4]

#define SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)

Definition at line 370 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_GENERAL_UNKNOWN_ERROR [2/4]

#define SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)

Definition at line 370 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_GENERAL_UNKNOWN_ERROR [3/4]

#define SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)

Definition at line 370 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_GENERAL_UNKNOWN_ERROR [4/4]

#define SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)

Definition at line 370 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_ILLEGAL_CMD [1/4]

#define SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)

Definition at line 367 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_ILLEGAL_CMD [2/4]

#define SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)

Definition at line 367 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_ILLEGAL_CMD [3/4]

#define SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)

Definition at line 367 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_ILLEGAL_CMD [4/4]

#define SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)

Definition at line 367 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_INVALID_ERASE_PARAM [1/4]

#define SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)

Definition at line 363 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_INVALID_ERASE_PARAM [2/4]

#define SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)

Definition at line 363 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_INVALID_ERASE_PARAM [3/4]

#define SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)

Definition at line 363 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_INVALID_ERASE_PARAM [4/4]

#define SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)

Definition at line 363 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_LOCK_UNLOCK_ERROR [1/4]

#define SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)

Definition at line 365 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_LOCK_UNLOCK_ERROR [2/4]

#define SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)

Definition at line 365 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_LOCK_UNLOCK_ERROR [3/4]

#define SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)

Definition at line 365 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_LOCK_UNLOCK_ERROR [4/4]

#define SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)

Definition at line 365 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_STREAM_RD_UNDERRUN [1/4]

#define SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)

Definition at line 371 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_STREAM_RD_UNDERRUN [2/4]

#define SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)

Definition at line 371 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_STREAM_RD_UNDERRUN [3/4]

#define SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)

Definition at line 371 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_STREAM_RD_UNDERRUN [4/4]

#define SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)

Definition at line 371 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_STREAM_WR_OVERRUN [1/4]

#define SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)

Definition at line 372 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_STREAM_WR_OVERRUN [2/4]

#define SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)

Definition at line 372 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_STREAM_WR_OVERRUN [3/4]

#define SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)

Definition at line 372 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_STREAM_WR_OVERRUN [4/4]

#define SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)

Definition at line 372 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_WP_ERASE_SKIP [1/4]

#define SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)

Definition at line 374 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_WP_ERASE_SKIP [2/4]

#define SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)

Definition at line 374 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_WP_ERASE_SKIP [3/4]

#define SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)

Definition at line 374 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_WP_ERASE_SKIP [4/4]

#define SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)

Definition at line 374 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_WR_PROTECT_VIOLATION [1/4]

#define SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)

Definition at line 364 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_WR_PROTECT_VIOLATION [2/4]

#define SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)

Definition at line 364 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_WR_PROTECT_VIOLATION [3/4]

#define SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)

Definition at line 364 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_WR_PROTECT_VIOLATION [4/4]

#define SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)

Definition at line 364 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_R5_ERROR [1/4]

#define SD_R5_ERROR ((uint32_t)0x00000800)

Definition at line 386 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_R5_ERROR [2/4]

#define SD_R5_ERROR ((uint32_t)0x00000800)

Definition at line 386 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_R5_ERROR [3/4]

#define SD_R5_ERROR ((uint32_t)0x00000800)

Definition at line 386 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_R5_ERROR [4/4]

#define SD_R5_ERROR ((uint32_t)0x00000800)

Definition at line 386 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_R5_FUNCTION_NUMBER [1/4]

#define SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)

Definition at line 385 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_R5_FUNCTION_NUMBER [2/4]

#define SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)

Definition at line 385 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_R5_FUNCTION_NUMBER [3/4]

#define SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)

Definition at line 385 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_R5_FUNCTION_NUMBER [4/4]

#define SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)

Definition at line 385 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_R5_OUT_OF_RANGE [1/4]

#define SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)

masks for r5 response

Definition at line 384 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_R5_OUT_OF_RANGE [2/4]

#define SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)

masks for r5 response

Definition at line 384 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_R5_OUT_OF_RANGE [3/4]

#define SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)

masks for r5 response

Definition at line 384 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_R5_OUT_OF_RANGE [4/4]

#define SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)

masks for r5 response

Definition at line 384 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_R6_CMD_CRC_ERROR [1/4]

#define SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)

Definition at line 393 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_R6_CMD_CRC_ERROR [2/4]

#define SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)

Definition at line 393 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_R6_CMD_CRC_ERROR [3/4]

#define SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)

Definition at line 393 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_R6_CMD_CRC_ERROR [4/4]

#define SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)

Definition at line 393 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_R6_GENERAL_UNKNOWN_ERROR [1/4]

#define SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)

masks for r6 response

Definition at line 391 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_R6_GENERAL_UNKNOWN_ERROR [2/4]

#define SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)

masks for r6 response

Definition at line 391 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_R6_GENERAL_UNKNOWN_ERROR [3/4]

#define SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)

masks for r6 response

Definition at line 391 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_R6_GENERAL_UNKNOWN_ERROR [4/4]

#define SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)

masks for r6 response

Definition at line 391 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_R6_ILLEGAL_CMD [1/4]

#define SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)

Definition at line 392 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_R6_ILLEGAL_CMD [2/4]

#define SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)

Definition at line 392 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_R6_ILLEGAL_CMD [3/4]

#define SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)

Definition at line 392 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_R6_ILLEGAL_CMD [4/4]

#define SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)

Definition at line 392 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_SINGLE_BUS_SUPPORT [1/4]

#define SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)

Definition at line 402 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_SINGLE_BUS_SUPPORT [2/4]

#define SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)

Definition at line 402 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_SINGLE_BUS_SUPPORT [3/4]

#define SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)

Definition at line 402 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_SINGLE_BUS_SUPPORT [4/4]

#define SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)

Definition at line 402 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_STD_CAPACITY [1/4]

#define SD_STD_CAPACITY ((uint32_t)0x00000000)

Definition at line 396 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_STD_CAPACITY [2/4]

#define SD_STD_CAPACITY ((uint32_t)0x00000000)

Definition at line 396 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_STD_CAPACITY [3/4]

#define SD_STD_CAPACITY ((uint32_t)0x00000000)

Definition at line 396 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_STD_CAPACITY [4/4]

#define SD_STD_CAPACITY ((uint32_t)0x00000000)

Definition at line 396 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_VOLTAGE_WINDOW_MMC [1/4]

#define SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)

Definition at line 398 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_VOLTAGE_WINDOW_MMC [2/4]

#define SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)

Definition at line 398 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_VOLTAGE_WINDOW_MMC [3/4]

#define SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)

Definition at line 398 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_VOLTAGE_WINDOW_MMC [4/4]

#define SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)

Definition at line 398 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_VOLTAGE_WINDOW_SD [1/4]

#define SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)

Definition at line 394 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_VOLTAGE_WINDOW_SD [2/4]

#define SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)

Definition at line 394 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_VOLTAGE_WINDOW_SD [3/4]

#define SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)

Definition at line 394 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_VOLTAGE_WINDOW_SD [4/4]

#define SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)

Definition at line 394 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_WIDE_BUS_SUPPORT [1/4]

#define SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)

Definition at line 401 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_WIDE_BUS_SUPPORT [2/4]

#define SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)

Definition at line 401 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_WIDE_BUS_SUPPORT [3/4]

#define SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)

Definition at line 401 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_WIDE_BUS_SUPPORT [4/4]

#define SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)

Definition at line 401 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.


AT32F435/437 Firmwary Library: SDIO_command_class_definition

Macros
SDIO_command_class_definition
AT32F435_periph_examples | AT32F437_periph_examples » SD_mmc_card | AT32F435_periph_examples | AT32F437_periph_examples » SDIO_fatfs

Macros

#define | SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)
#define | SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)
#define | SD_CCCC_ERASE ((uint32_t)0x00000020)
#define | SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)
#define | SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)
#define | SD_CCCC_ERASE ((uint32_t)0x00000020)
#define | SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)
#define | SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)
#define | SD_CCCC_ERASE ((uint32_t)0x00000020)
#define | SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)
#define | SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)
#define | SD_CCCC_ERASE ((uint32_t)0x00000020)

Detailed Description

Macro Definition Documentation

◆ SD_CCCC_ERASE [1/4]

#define SD_CCCC_ERASE ((uint32_t)0x00000020)

Definition at line 428 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CCCC_ERASE [2/4]

#define SD_CCCC_ERASE ((uint32_t)0x00000020)

Definition at line 428 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CCCC_ERASE [3/4]

#define SD_CCCC_ERASE ((uint32_t)0x00000020)

Definition at line 428 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CCCC_ERASE [4/4]

#define SD_CCCC_ERASE ((uint32_t)0x00000020)

Definition at line 428 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CCCC_LOCK_UNLOCK [1/4]

#define SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)

command class supported

Definition at line 426 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CCCC_LOCK_UNLOCK [2/4]

#define SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)

command class supported

Definition at line 426 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CCCC_LOCK_UNLOCK [3/4]

#define SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)

command class supported

Definition at line 426 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CCCC_LOCK_UNLOCK [4/4]

#define SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)

command class supported

Definition at line 426 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CCCC_WRITE_PROT [1/4]

#define SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)

Definition at line 427 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CCCC_WRITE_PROT [2/4]

#define SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)

Definition at line 427 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SD_CCCC_WRITE_PROT [3/4]

#define SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)

Definition at line 427 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SD_CCCC_WRITE_PROT [4/4]

#define SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)

Definition at line 427 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.


AT32F435/437 Firmwary Library: SDIO_cmd8_definition

Macros
SDIO_cmd8_definition
AT32F435_periph_examples | AT32F437_periph_examples » SD_mmc_card | AT32F435_periph_examples | AT32F437_periph_examples » SDIO_fatfs

Macros

#define | SDIO_SEND_IF_COND ((uint32_t)0x00000008)
#define | SDIO_SEND_IF_COND ((uint32_t)0x00000008)
#define | SDIO_SEND_IF_COND ((uint32_t)0x00000008)
#define | SDIO_SEND_IF_COND ((uint32_t)0x00000008)

Detailed Description

Macro Definition Documentation

◆ SDIO_SEND_IF_COND [1/4]

#define SDIO_SEND_IF_COND ((uint32_t)0x00000008)

cmd8

Definition at line 441 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SDIO_SEND_IF_COND [2/4]

#define SDIO_SEND_IF_COND ((uint32_t)0x00000008)

cmd8

Definition at line 441 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SDIO_SEND_IF_COND [3/4]

#define SDIO_SEND_IF_COND ((uint32_t)0x00000008)

cmd8

Definition at line 441 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SDIO_SEND_IF_COND [4/4]

#define SDIO_SEND_IF_COND ((uint32_t)0x00000008)

cmd8

Definition at line 441 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.


AT32F435/437 Firmwary Library: SDIO_mmc_extend_definition

Macros
SDIO_mmc_extend_definition
AT32F435_periph_examples | AT32F437_periph_examples » SD_mmc_card | AT32F435_periph_examples | AT32F437_periph_examples » SDIO_fatfs

Macros

#define | EXT_CSD_Command_set 0x0
#define | EXT_CSD_Set_bit 0x1
#define | EXT_CSD_Clear_byte 0x2
#define | EXT_CSD_Write_byte 0x3
#define | EXT_CSD_CMD_SET_NORMAL (1<<0)
#define | EXT_CSD_CMD_SET_SECURE (1<<1)
#define | EXT_CSD_CMD_SET_CPSECURE (1<<2)
#define | EXT_CSD_BUS_WIDTH 183
#define | EXT_CSD_HS_TIMING 185
#define | EXT_CSD_Command_set 0x0
#define | EXT_CSD_Set_bit 0x1
#define | EXT_CSD_Clear_byte 0x2
#define | EXT_CSD_Write_byte 0x3
#define | EXT_CSD_CMD_SET_NORMAL (1<<0)
#define | EXT_CSD_CMD_SET_SECURE (1<<1)
#define | EXT_CSD_CMD_SET_CPSECURE (1<<2)
#define | EXT_CSD_BUS_WIDTH 183
#define | EXT_CSD_HS_TIMING 185
#define | EXT_CSD_Command_set 0x0
#define | EXT_CSD_Set_bit 0x1
#define | EXT_CSD_Clear_byte 0x2
#define | EXT_CSD_Write_byte 0x3
#define | EXT_CSD_CMD_SET_NORMAL (1<<0)
#define | EXT_CSD_CMD_SET_SECURE (1<<1)
#define | EXT_CSD_CMD_SET_CPSECURE (1<<2)
#define | EXT_CSD_BUS_WIDTH 183
#define | EXT_CSD_HS_TIMING 185
#define | EXT_CSD_Command_set 0x0
#define | EXT_CSD_Set_bit 0x1
#define | EXT_CSD_Clear_byte 0x2
#define | EXT_CSD_Write_byte 0x3
#define | EXT_CSD_CMD_SET_NORMAL (1<<0)
#define | EXT_CSD_CMD_SET_SECURE (1<<1)
#define | EXT_CSD_CMD_SET_CPSECURE (1<<2)
#define | EXT_CSD_BUS_WIDTH 183
#define | EXT_CSD_HS_TIMING 185

Detailed Description

Macro Definition Documentation

◆ EXT_CSD_BUS_WIDTH [1/4]

#define EXT_CSD_BUS_WIDTH 183

mmc ext_csd offset

Definition at line 466 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_BUS_WIDTH [2/4]

#define EXT_CSD_BUS_WIDTH 183

mmc ext_csd offset

Definition at line 466 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_BUS_WIDTH [3/4]

#define EXT_CSD_BUS_WIDTH 183

mmc ext_csd offset

Definition at line 466 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_BUS_WIDTH [4/4]

#define EXT_CSD_BUS_WIDTH 183

mmc ext_csd offset

Definition at line 466 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_Clear_byte [1/4]

#define EXT_CSD_Clear_byte 0x2

Definition at line 456 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_Clear_byte [2/4]

#define EXT_CSD_Clear_byte 0x2

Definition at line 456 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_Clear_byte [3/4]

#define EXT_CSD_Clear_byte 0x2

Definition at line 456 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_Clear_byte [4/4]

#define EXT_CSD_Clear_byte 0x2

Definition at line 456 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_CMD_SET_CPSECURE [1/4]

#define EXT_CSD_CMD_SET_CPSECURE (1<<2)

Definition at line 461 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_CMD_SET_CPSECURE [2/4]

#define EXT_CSD_CMD_SET_CPSECURE (1<<2)

Definition at line 461 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_CMD_SET_CPSECURE [3/4]

#define EXT_CSD_CMD_SET_CPSECURE (1<<2)

Definition at line 461 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_CMD_SET_CPSECURE [4/4]

#define EXT_CSD_CMD_SET_CPSECURE (1<<2)

Definition at line 461 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_CMD_SET_NORMAL [1/4]

#define EXT_CSD_CMD_SET_NORMAL (1<<0)

Definition at line 459 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_CMD_SET_NORMAL [2/4]

#define EXT_CSD_CMD_SET_NORMAL (1<<0)

Definition at line 459 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_CMD_SET_NORMAL [3/4]

#define EXT_CSD_CMD_SET_NORMAL (1<<0)

Definition at line 459 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_CMD_SET_NORMAL [4/4]

#define EXT_CSD_CMD_SET_NORMAL (1<<0)

Definition at line 459 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_CMD_SET_SECURE [1/4]

#define EXT_CSD_CMD_SET_SECURE (1<<1)

Definition at line 460 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_CMD_SET_SECURE [2/4]

#define EXT_CSD_CMD_SET_SECURE (1<<1)

Definition at line 460 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_CMD_SET_SECURE [3/4]

#define EXT_CSD_CMD_SET_SECURE (1<<1)

Definition at line 460 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_CMD_SET_SECURE [4/4]

#define EXT_CSD_CMD_SET_SECURE (1<<1)

Definition at line 460 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_Command_set [1/4]

#define EXT_CSD_Command_set 0x0

mmc ext_csd operation

Definition at line 454 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_Command_set [2/4]

#define EXT_CSD_Command_set 0x0

mmc ext_csd operation

Definition at line 454 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_Command_set [3/4]

#define EXT_CSD_Command_set 0x0

mmc ext_csd operation

Definition at line 454 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_Command_set [4/4]

#define EXT_CSD_Command_set 0x0

mmc ext_csd operation

Definition at line 454 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_HS_TIMING [1/4]

#define EXT_CSD_HS_TIMING 185

Definition at line 467 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_HS_TIMING [2/4]

#define EXT_CSD_HS_TIMING 185

Definition at line 467 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_HS_TIMING [3/4]

#define EXT_CSD_HS_TIMING 185

Definition at line 467 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_HS_TIMING [4/4]

#define EXT_CSD_HS_TIMING 185

Definition at line 467 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_Set_bit [1/4]

#define EXT_CSD_Set_bit 0x1

Definition at line 455 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_Set_bit [2/4]

#define EXT_CSD_Set_bit 0x1

Definition at line 455 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_Set_bit [3/4]

#define EXT_CSD_Set_bit 0x1

Definition at line 455 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_Set_bit [4/4]

#define EXT_CSD_Set_bit 0x1

Definition at line 455 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_Write_byte [1/4]

#define EXT_CSD_Write_byte 0x3

Definition at line 457 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_Write_byte [2/4]

#define EXT_CSD_Write_byte 0x3

Definition at line 457 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_Write_byte [3/4]

#define EXT_CSD_Write_byte 0x3

Definition at line 457 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_Write_byte [4/4]

#define EXT_CSD_Write_byte 0x3

Definition at line 457 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.


AT32F435/437 Firmwary Library: SDIO_interrupt_flags_definition

Macros
SDIO_interrupt_flags_definition
AT32F435_periph_examples | AT32F437_periph_examples » SD_mmc_card | AT32F435_periph_examples | AT32F437_periph_examples » SDIO_fatfs

Macros

#define | SDIO_INTR_STS_WRITE_MASK
#define | SDIO_INTR_STS_READ_MASK
#define | SDIO_INTR_STS_WRITE_MASK
#define | SDIO_INTR_STS_READ_MASK
#define | SDIO_INTR_STS_WRITE_MASK
#define | SDIO_INTR_STS_READ_MASK
#define | SDIO_INTR_STS_WRITE_MASK
#define | SDIO_INTR_STS_READ_MASK

Detailed Description

Macro Definition Documentation

◆ SDIO_INTR_STS_READ_MASK [1/4]

#define SDIO_INTR_STS_READ_MASK
Value:
(SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_RXERRO_FLAG | \
SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
SDIO_DTFAIL_FLAG
#define SDIO_DTFAIL_FLAG
Definition: at32f435_437_sdio.h:86
SDIO_RXERRO_FLAG
#define SDIO_RXERRO_FLAG
Definition: at32f435_437_sdio.h:90
SDIO_DTTIMEOUT_FLAG
#define SDIO_DTTIMEOUT_FLAG
Definition: at32f435_437_sdio.h:88
SDIO_SBITERR_FLAG
#define SDIO_SBITERR_FLAG
Definition: at32f435_437_sdio.h:94

Definition at line 479 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SDIO_INTR_STS_READ_MASK [2/4]

#define SDIO_INTR_STS_READ_MASK
Value:
(SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_RXERRO_FLAG | \
SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)

Definition at line 479 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SDIO_INTR_STS_READ_MASK [3/4]

#define SDIO_INTR_STS_READ_MASK
Value:
(SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_RXERRO_FLAG | \
SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)

Definition at line 479 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SDIO_INTR_STS_READ_MASK [4/4]

#define SDIO_INTR_STS_READ_MASK
Value:
(SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_RXERRO_FLAG | \
SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)

Definition at line 479 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SDIO_INTR_STS_WRITE_MASK [1/4]

#define SDIO_INTR_STS_WRITE_MASK
Value:
(SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_TXERRU_FLAG | \
SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
SDIO_TXERRU_FLAG
#define SDIO_TXERRU_FLAG
Definition: at32f435_437_sdio.h:89

Definition at line 477 of file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SDIO_INTR_STS_WRITE_MASK [2/4]

#define SDIO_INTR_STS_WRITE_MASK
Value:
(SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_TXERRU_FLAG | \
SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)

Definition at line 477 of file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.

◆ SDIO_INTR_STS_WRITE_MASK [3/4]

#define SDIO_INTR_STS_WRITE_MASK
Value:
(SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_TXERRU_FLAG | \
SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)

Definition at line 477 of file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.

◆ SDIO_INTR_STS_WRITE_MASK [4/4]

#define SDIO_INTR_STS_WRITE_MASK
Value:
(SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_TXERRU_FLAG | \
SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)

Definition at line 477 of file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.


AT32F435/437 Firmwary Library: SD_mmc_card

Macros | Enumerations | Functions | Variables
SD_mmc_card
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | BLOCK_SIZE (512)
#define | BLOCKS_NUMBER (64)
#define | MULTI_BUFFER_SIZE (BLOCK_SIZE * BLOCKS_NUMBER)
#define | STREAM_BUFFER_SIZE (4096)
#define | BLOCK_SIZE (512)
#define | BLOCKS_NUMBER (64)
#define | MULTI_BUFFER_SIZE (BLOCK_SIZE * BLOCKS_NUMBER)
#define | STREAM_BUFFER_SIZE (4096)

Enumerations

enum test_result_type {
TEST_FAIL = 0 , TEST_SUCCESS , TEST_FAIL = 0 , TEST_SUCCESS ,
TEST_FAIL = 0 , TEST_SUCCESS , TEST_FAIL = 0 , TEST_SUCCESS
}
enum test_result_type {
TEST_FAIL = 0 , TEST_SUCCESS , TEST_FAIL = 0 , TEST_SUCCESS ,
TEST_FAIL = 0 , TEST_SUCCESS , TEST_FAIL = 0 , TEST_SUCCESS
}

Functions

sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clk_div)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sdio_command_data_send (sdio_command_struct_type *sdio_cmd_init_t, sdio_data_struct_type *sdio_data_init_t, uint32_t *buf)
read data from or write data to sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
void | SDIO1_IRQHandler (void)
sdio1 isr. More...
void | SDIO2_IRQHandler (void)
sdio2 isr. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static test_result_type | sd_single_block_test (void)
sd card single block read/write test. More...
static test_result_type | sd_multiple_blocks_test (void)
sd card multiple blocks read/write test. More...
static void | sd_test_error (void)
LED2 on off every 300ms for sd test error. More...
static void | nvic_configuration (void)
configures sdio1 irq channel. More...
static test_result_type | mmc_stream_test (void)
mmc card data stream read/write test. More...
void | show_card_info (void)
show sd/mmc card info. More...
int | main (void)
main function. More...

Variables

sdio_command_struct_type sdio_command_init_struct
sdio_data_struct_type sdio_data_init_struct
static sd_memory_card_type | card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1
static uint32_t | csd_table [4]
static uint32_t | cid_table [4]
static uint32_t | rca = 0
static sd_data_transfer_mode_type | device_mode = SD_TRANSFER_POLLING_MODE
static uint8_t | stop_flag = 0
volatile sd_error_status_type | transfer_error = SD_OK
volatile uint8_t | transfer_end = 0
sd_card_info_struct_type sd_card_info
static uint8_t | sblock_tbuffer [(512)]
static uint8_t | sblock_rbuffer [(512)]
static uint8_t | mblock_tbuffer [((512) *(64))]
static uint8_t | mblock_rbuffer [((512) *(64))]
static uint8_t | stream_tbuffer [(4096)]
static uint8_t | stream_rbuffer [(4096)]
sdio_command_struct_type sdio_command_init_struct
sdio_data_struct_type sdio_data_init_struct
static sd_memory_card_type | card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1
static uint32_t | csd_table [4]
static uint32_t | cid_table [4]
static uint32_t | rca = 0
static sd_data_transfer_mode_type | device_mode = SD_TRANSFER_POLLING_MODE
static uint8_t | stop_flag = 0
volatile sd_error_status_type | transfer_error = SD_OK
volatile uint8_t | transfer_end = 0
sd_card_info_struct_type sd_card_info
static uint8_t | sblock_tbuffer [(512)]
static uint8_t | sblock_rbuffer [(512)]
static uint8_t | mblock_tbuffer [((512) *(64))]
static uint8_t | mblock_rbuffer [((512) *(64))]
static uint8_t | stream_tbuffer [(4096)]
static uint8_t | stream_rbuffer [(4096)]

Detailed Description

Macro Definition Documentation

◆ BLOCK_SIZE [1/2]

#define BLOCK_SIZE (512)

Definition at line 41 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c.

◆ BLOCK_SIZE [2/2]

#define BLOCK_SIZE (512)

Definition at line 41 of file project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c.

◆ BLOCKS_NUMBER [1/2]

#define BLOCKS_NUMBER (64)

Definition at line 42 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c.

◆ BLOCKS_NUMBER [2/2]

#define BLOCKS_NUMBER (64)

Definition at line 42 of file project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c.

◆ MULTI_BUFFER_SIZE [1/2]

#define MULTI_BUFFER_SIZE (BLOCK_SIZE * BLOCKS_NUMBER)

Definition at line 43 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c.

◆ MULTI_BUFFER_SIZE [2/2]

#define MULTI_BUFFER_SIZE (BLOCK_SIZE * BLOCKS_NUMBER)

Definition at line 43 of file project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c.

◆ STREAM_BUFFER_SIZE [1/2]

#define STREAM_BUFFER_SIZE (4096)

Definition at line 44 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c.

◆ STREAM_BUFFER_SIZE [2/2]

#define STREAM_BUFFER_SIZE (4096)

Definition at line 44 of file project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c.

Enumeration Type Documentation

◆ test_result_type [1/2]

enum test_result_type

test result

Enumerator
TEST_FAIL
TEST_SUCCESS
TEST_FAIL
TEST_SUCCESS
TEST_FAIL
TEST_SUCCESS
TEST_FAIL
TEST_SUCCESS

Definition at line 53 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c.

◆ test_result_type [2/2]

enum test_result_type

test result

Enumerator
TEST_FAIL
TEST_SUCCESS
TEST_FAIL
TEST_SUCCESS
TEST_FAIL
TEST_SUCCESS
TEST_FAIL
TEST_SUCCESS

Definition at line 53 of file project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 282 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c.

◆ mmc_stream_read()

sd_error_status_type mmc_stream_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint32_t | len
 | ) |  |

read mmc card data stream.

Parameters
buf | buffer of saving data from mmc card
addr | start address of data from mmc card
len | data size
Return values
sd_error_status_type sd card error code.

Definition at line 1653 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

◆ mmc_stream_test()

static test_result_type mmc_stream_test ( void )
static

mmc card data stream read/write test.

Parameters
none
Return values
TEST_FAIL fail. TEST_SUCCESS: success.

Definition at line 166 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c.

Referenced by main().

◆ mmc_stream_write()

sd_error_status_type mmc_stream_write | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint32_t | len
 | ) |  |

write mmc card data stream.

Parameters
buf | data that writing to mmc card
addr | start address mmc card
len | data size
Return values
sd_error_status_type sd card error code.

Definition at line 1700 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c.

◆ nvic_configuration()

static void nvic_configuration ( void )
static

configures sdio1 irq channel.

Parameters
none
Return values
none

Definition at line 247 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c.

Referenced by main().

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c.

◆ sd_block_read()

sd_error_status_type sd_block_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size
 | ) |  |

allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that will contain the received data
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
Return values
sd_error_status_type sd card error code.

Definition at line 1188 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

◆ sd_block_write()

sd_error_status_type sd_block_write | ( | const uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size
 | ) |  |

allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that contain the data to be transferred.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
Return values
sd_error_status_type sd card error code.

Definition at line 1367 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

◆ sd_blocks_erase()

sd_error_status_type sd_blocks_erase | ( | long long | addr,
 |  | uint32_t | nblks
 | ) |  |

erase continuous data block

Parameters
addr | starting address
nblks | amount of erasing data block
Return values
sd_error_status_type sd card error code.

Definition at line 1030 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

◆ sd_card_info_get()

sd_error_status_type sd_card_info_get ( sd_card_info_struct_type * card_info )

returns information about specific card.

Parameters
card_info pointer to a sd_card_info_struct_type structure that contains all sd card information.
Return values
sd_error_status_type sd card error code.

Definition at line 532 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_card_init()

sd_error_status_type sd_card_init ( void )

intialises all cards or single card as the case may be card(s) come into standby state.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 417 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_deselect_select()

sd_error_status_type sd_deselect_select ( uint32_t addr )

selects od deselects the corresponding card.

Parameters
addr address of the card to be selected.
Return values
sd_error_status_type sd card error code.

Definition at line 807 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_device_mode_set()

sd_error_status_type sd_device_mode_set ( uint32_t mode )

set sdio work mode.

Parameters
mode parameter as following values:
  • SD_TRANSFER_POLLING_MODE: dma mode.
  • SD_TRANSFER_POLLING_MODE: polling mode.
Return values
sd_error_status_type sd card error code.

Definition at line 786 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_dma_config()

void sd_dma_config | ( | uint32_t * | mbuf,
 |  | uint32_t | buf_size,
 |  | dma_dir_type | dir
 | ) |  |

set dma configuation for sdio

Parameters
mbuf | buffer address
buf_size | transmission data size
dir | dma direction, it is DMA_DIR_MEMORY_TO_PERIPHERAL(writing data) or DMA_DIR_PERIPHERAL_TO_MEMORY(read data)
Return values
none

Definition at line 2706 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sdio_command_data_send().

◆ sd_init()

sd_error_status_type sd_init ( void )

initializes the sd card and put it into standby state (ready for data transfer).

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 72 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sdio_command_data_send().

◆ sd_irq_service()

sd_error_status_type sd_irq_service ( void )

allows to process all the interrupts that are high.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 1789 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by SDIO1_IRQHandler(), and SDIO2_IRQHandler().

◆ sd_mult_blocks_read()

sd_error_status_type sd_mult_blocks_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size,
 |  | uint32_t | nblks
 | ) |  |

allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that will contain the received data.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
nblks | number of blocks to be read.
Return values
sd_error_status_type sd card error code.

Definition at line 1277 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

◆ sd_mult_blocks_write()

sd_error_status_type sd_mult_blocks_write | ( | const uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size,
 |  | uint32_t | nblks
 | ) |  |

allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only.

Parameters
buf | pointer to the buffer that contain the data to be transferred.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
nblks | number of blocks to be written.
Return values
sd_error_status_type sd card error code.

Definition at line 1489 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

◆ sd_multiple_blocks_test()

static test_result_type sd_multiple_blocks_test ( void )
static

sd card multiple blocks read/write test.

Parameters
none
Return values
TEST_FAIL fail. TEST_SUCCESS: success.

Definition at line 118 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c.

Referenced by main().

◆ sd_power_off()

sd_error_status_type sd_power_off ( void )

turns the sdio output signals off.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 403 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

◆ sd_power_on()

sd_error_status_type sd_power_on ( void )

enquires cards about their operating voltage and configures clock controls.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 203 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_single_block_test()

static test_result_type sd_single_block_test ( void )
static

sd card single block read/write test.

Parameters
none
Return values
TEST_FAIL fail. TEST_SUCCESS: success.

Definition at line 71 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c.

Referenced by main().

◆ sd_state_get()

sd_card_state_type sd_state_get ( void )

returns information about sd card.

Parameters
none.
Return values
sd_card_state_type sd card state code.

Definition at line 2489 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

◆ sd_status_send()

sd_error_status_type sd_status_send ( uint32_t * p_card_status )

read current card status.

Parameters
p_card_status card status.
Return values
sd_error_status_type sd card error code.

Definition at line 2452 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_switch(), sd_block_write(), sd_mult_blocks_write(), and sd_state_get().

◆ sd_test_error()

static void sd_test_error ( void )
static

LED2 on off every 300ms for sd test error.

Parameters
none
Return values
none

Definition at line 234 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c.

Referenced by main().

◆ sd_wide_bus_operation_config()

sd_error_status_type sd_wide_bus_operation_config ( sdio_bus_width_type mode )

enable wide bus opeartion for the requeseted card if supported by card.

Parameters
mode specifies the sd card wide bus mode. this parameter can be one of the following values:
  • SDIO_BUS_WIDTH_D8: 8-bit data transfer (only for mmc)
  • SDIO_BUS_WIDTH_D4: 4-bit data transfer
  • SDIO_BUS_WIDTH_D1: 1-bit data transfer
Return values
sd_error_status_type sd card error code.

Definition at line 743 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

◆ SDIO1_IRQHandler()

void SDIO1_IRQHandler ( void )

sdio1 isr.

Parameters
none.
Return values
none.

Definition at line 1769 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

◆ SDIO2_IRQHandler()

void SDIO2_IRQHandler ( void )

sdio2 isr.

Parameters
none.
Return values
none.

Definition at line 1779 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

◆ sdio_clock_set()

void sdio_clock_set ( uint32_t clk_div )

set sdio clock devision factor.

Parameters
clkdiv sdio_ck = ahbclk / (clkdiv+2)
Return values
none

Definition at line 188 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sdio_command_data_send()

sd_error_status_type sdio_command_data_send | ( | sdio_command_struct_type * | sdio_cmd_init_t,
 |  | sdio_data_struct_type * | sdio_data_init_t,
 |  | uint32_t * | buf
 | ) |  |

read data from or write data to sd card.

Parameters
sdio_cmd_init_struct | pointer to sdio_command_struct_type structure.
sdio_data_init_struct | pointer to sdio_data_struct_type structure.
buf | pointer to data buffer read or write.
Return values
sd_error_status_type sd card error code.

Definition at line 830 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), sd_block_read(), sd_block_write(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sd_switch().

◆ show_card_info()

void show_card_info ( void )

show sd/mmc card info.

Parameters
none
Return values
none

Definition at line 258 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c.

Variable Documentation

◆ card_type [1/2]

sd_memory_card_type card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1
static

Definition at line 42 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_card_info_get(), sd_card_init(), sd_init(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_wide_bus_operation_config(), and speed_change().

◆ card_type [2/2]

sd_memory_card_type card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1
static

Definition at line 42 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_card_info_get(), sd_card_init(), sd_init(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), and sd_wide_bus_operation_config().

◆ cid_table [1/2]

uint32_t cid_table[4]
static

Definition at line 43 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_card_info_get(), and sd_card_init().

◆ cid_table [2/2]

uint32_t cid_table[4]
static

Definition at line 43 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_card_info_get(), and sd_card_init().

◆ csd_table [1/2]

uint32_t csd_table[4]
static

Definition at line 43 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_card_info_get(), and sd_card_init().

◆ csd_table [2/2]

uint32_t csd_table[4]
static

Definition at line 43 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_card_info_get(), and sd_card_init().

◆ device_mode [1/2]

sd_data_transfer_mode_type device_mode = SD_TRANSFER_POLLING_MODE
static

Definition at line 44 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_device_mode_set(), and sdio_command_data_send().

◆ device_mode [2/2]

sd_data_transfer_mode_type device_mode = SD_TRANSFER_POLLING_MODE
static

Definition at line 44 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_device_mode_set().

◆ mblock_rbuffer [1/2]

uint8_t mblock_rbuffer[((512) *(64))]
static

Definition at line 47 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c.

Referenced by sd_multiple_blocks_test().

◆ mblock_rbuffer [2/2]

uint8_t mblock_rbuffer[((512) *(64))]
static

Definition at line 47 of file project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c.

Referenced by sd_multiple_blocks_test().

◆ mblock_tbuffer [1/2]

uint8_t mblock_tbuffer[((512) *(64))]
static

Definition at line 47 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c.

Referenced by sd_multiple_blocks_test().

◆ mblock_tbuffer [2/2]

uint8_t mblock_tbuffer[((512) *(64))]
static

Definition at line 47 of file project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c.

Referenced by sd_multiple_blocks_test().

◆ rca [1/2]

uint32_t rca = 0
static

Definition at line 43 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by check_card_programming(), sd_card_info_get(), sd_card_init(), sd_mult_blocks_write(), and sd_status_send().

◆ rca [2/2]

uint32_t rca = 0
static

Definition at line 43 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_card_info_get(), sd_card_init(), sd_mult_blocks_write(), and sd_status_send().

◆ sblock_rbuffer [1/2]

uint8_t sblock_rbuffer[(512)]
static

Definition at line 46 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c.

Referenced by sd_single_block_test().

◆ sblock_rbuffer [2/2]

uint8_t sblock_rbuffer[(512)]
static

Definition at line 46 of file project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c.

Referenced by sd_single_block_test().

◆ sblock_tbuffer [1/2]

uint8_t sblock_tbuffer[(512)]
static

Definition at line 46 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c.

Referenced by sd_single_block_test().

◆ sblock_tbuffer [2/2]

uint8_t sblock_tbuffer[(512)]
static

Definition at line 46 of file project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c.

Referenced by sd_single_block_test().

◆ sd_card_info [1/2]

sd_card_info_struct_type sd_card_info

Definition at line 48 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by scr_find(), sd_bus_wide_enable(), sd_init(), and speed_change().

◆ sd_card_info [2/2]

sd_card_info_struct_type sd_card_info

Definition at line 48 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sdio_command_init_struct [1/2]

sdio_command_struct_type sdio_command_init_struct

Definition at line 39 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by check_card_programming(), mmc_stream_read(), mmc_stream_write(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), and sd_switch().

◆ sdio_command_init_struct [2/2]

sdio_command_struct_type sdio_command_init_struct

Definition at line 39 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), and sd_status_send().

◆ sdio_data_init_struct [1/2]

sdio_data_struct_type sdio_data_init_struct

Definition at line 40 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sd_switch().

◆ sdio_data_init_struct [2/2]

sdio_data_struct_type sdio_data_init_struct

Definition at line 40 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), and sd_mult_blocks_write().

◆ stop_flag [1/2]

uint8_t stop_flag = 0
static

Definition at line 45 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), sd_block_read(), sd_block_write(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_switch(), and sdio_command_data_send().

◆ stop_flag [2/2]

uint8_t stop_flag = 0
static

Definition at line 45 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), sd_block_read(), sd_block_write(), sd_irq_service(), sd_mult_blocks_read(), and sd_mult_blocks_write().

◆ stream_rbuffer [1/2]

uint8_t stream_rbuffer[(4096)]
static

Definition at line 48 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c.

Referenced by mmc_stream_test().

◆ stream_rbuffer [2/2]

uint8_t stream_rbuffer[(4096)]
static

Definition at line 48 of file project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c.

Referenced by mmc_stream_test().

◆ stream_tbuffer [1/2]

uint8_t stream_tbuffer[(4096)]
static

Definition at line 48 of file project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c.

Referenced by mmc_stream_test().

◆ stream_tbuffer [2/2]

uint8_t stream_tbuffer[(4096)]
static

Definition at line 48 of file project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c.

Referenced by mmc_stream_test().

◆ transfer_end [1/2]

volatile uint8_t transfer_end = 0

Definition at line 47 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_irq_service(), and sdio_command_data_send().

◆ transfer_end [2/2]

volatile uint8_t transfer_end = 0

Definition at line 47 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_irq_service().

◆ transfer_error [1/2]

volatile sd_error_status_type transfer_error = SD_OK

Definition at line 46 of file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_irq_service(), and sdio_command_data_send().

◆ transfer_error [2/2]

volatile sd_error_status_type transfer_error = SD_OK

Definition at line 46 of file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.

Referenced by sd_irq_service().


AT32F435/437 Firmwary Library: SDIO_fatfs

Modules | Enumerations | Functions | Variables
SDIO_fatfs
AT32F435_periph_examples | AT32F437_periph_examples

Modules

SDIO_instance_definition
SDIO_exported_types
SDIO_command_index_definition
SDIO_paremeters_definition
SDIO_response_definition
SDIO_command_class_definition
SDIO_cmd8_definition
SDIO_mmc_extend_definition
SDIO_interrupt_flags_definition
SDIO_exported_functions

Enumerations

enum test_result_type {
TEST_FAIL = 0 , TEST_SUCCESS , TEST_FAIL = 0 , TEST_SUCCESS ,
TEST_FAIL = 0 , TEST_SUCCESS , TEST_FAIL = 0 , TEST_SUCCESS
}
enum test_result_type {
TEST_FAIL = 0 , TEST_SUCCESS , TEST_FAIL = 0 , TEST_SUCCESS ,
TEST_FAIL = 0 , TEST_SUCCESS , TEST_FAIL = 0 , TEST_SUCCESS
}

Functions

sd_error_status_type | command_error (void)
checks for error conditions for cmd0. More...
sd_error_status_type | command_rsp1_error (uint8_t cmd)
checks for error conditions for R1 response. More...
sd_error_status_type | command_rsp2_error (void)
checks for error conditions for R2 (cid or csd) response. More...
sd_error_status_type | command_rsp3_error (void)
checks for error conditions for R3 (ocr) response. More...
sd_error_status_type | command_rsp4_error (uint8_t cmd)
checks for error conditions for r4 response. More...
sd_error_status_type | command_rsp5_error (uint8_t cmd)
checks for error conditions for r5 response. More...
sd_error_status_type | command_rsp6_error (uint8_t cmd, uint16_t *prca)
checks for error conditions for r6 (rca) response. More...
sd_error_status_type | command_rsp7_error (void)
checks for error conditions for R7 response. More...
sd_error_status_type | sd_bus_wide_enable (confirm_state new_state)
enable or disable the sdio wide bus mode. More...
sd_error_status_type | mmc_switch (uint8_t set, uint8_t index, uint8_t value)
switch mmc card speed to high speed More...
sd_error_status_type | sd_switch (uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
switch sd card speed to high speed More...
sd_error_status_type | check_card_programming (uint8_t *p_status)
checks if the sd card is in programming state. More...
sd_error_status_type | speed_change (uint8_t speed)
set bus speed More...
sd_error_status_type | scr_find (void)
find the sd card scr register value. More...
uint8_t | convert_from_bytes_to_power_of_two (uint16_t number_of_bytes)
converts the number of bytes in power of two and returns the power. More...
sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clk_div)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sdio_command_data_send (sdio_command_struct_type *sdio_cmd_init_t, sdio_data_struct_type *sdio_data_init_t, uint32_t *buf)
read data from or write data to sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
void | SDIO1_IRQHandler (void)
sdio1 isr. More...
void | SDIO2_IRQHandler (void)
sdio2 isr. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
static void | sd_test_error (void)
led2 on off every 300ms for sd test error. More...
static void | nvic_configuration (void)
configures sdio1 irq channel. More...
static test_result_type | fatfs_test (void)
fatfs file read/write test. More...
int | main (void)
main function. More...

Variables

sdio_command_struct_type sdio_command_init_struct
sdio_data_struct_type sdio_data_init_struct
static sd_memory_card_type | card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1
static uint32_t | csd_table [4]
static uint32_t | cid_table [4]
static uint32_t | rca = 0
static sd_data_transfer_mode_type | device_mode = SD_TRANSFER_POLLING_MODE
static uint8_t | stop_flag = 0
volatile sd_error_status_type | transfer_error = SD_OK
volatile uint8_t | transfer_end = 0
sd_card_info_struct_type sd_card_info
FATFS | fs
FIL | file
BYTE | work [FF_MAX_SS]
sdio_command_struct_type sdio_command_init_struct
sdio_data_struct_type sdio_data_init_struct
static sd_memory_card_type | card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1
static uint32_t | csd_table [4]
static uint32_t | cid_table [4]
static uint32_t | rca = 0
static sd_data_transfer_mode_type | device_mode = SD_TRANSFER_POLLING_MODE
static uint8_t | stop_flag = 0
volatile sd_error_status_type | transfer_error = SD_OK
volatile uint8_t | transfer_end = 0
sd_card_info_struct_type sd_card_info
FATFS | fs
FIL | file
BYTE | work [FF_MAX_SS]

Detailed Description

Enumeration Type Documentation

◆ test_result_type [1/2]

enum test_result_type

test result

Enumerator
TEST_FAIL
TEST_SUCCESS
TEST_FAIL
TEST_SUCCESS
TEST_FAIL
TEST_SUCCESS
TEST_FAIL
TEST_SUCCESS

Definition at line 49 of file project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c.

◆ test_result_type [2/2]

enum test_result_type

test result

Enumerator
TEST_FAIL
TEST_SUCCESS
TEST_FAIL
TEST_SUCCESS
TEST_FAIL
TEST_SUCCESS
TEST_FAIL
TEST_SUCCESS

Definition at line 49 of file project/at_start_f437/examples/sdio/sdio_fatfs/src/main.c.

Function Documentation

◆ buffer_compare()

uint8_t buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
1 pbuffer1 identical to pbuffer2 0: pbuffer1 differs from pbuffer2

Definition at line 66 of file project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c.

Referenced by fatfs_test().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c.

◆ check_card_programming()

sd_error_status_type check_card_programming ( uint8_t * p_status )

checks if the sd card is in programming state.

Parameters
p_status pointer to the variable that will contain the sd card state.
Return values
sd_error_status_type sd card error code.

Definition at line 2405 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_stream_write(), sd_block_write(), sd_blocks_erase(), and sd_mult_blocks_write().

◆ command_error()

sd_error_status_type command_error ( void )

checks for error conditions for cmd0.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 1880 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_power_on().

◆ command_rsp1_error()

sd_error_status_type command_rsp1_error ( uint8_t cmd )

checks for error conditions for R1 response.

Parameters
cmd the sent command index.
Return values
sd_error_status_type sd card error code.

Definition at line 1944 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), and sdio_command_data_send().

◆ command_rsp2_error()

sd_error_status_type command_rsp2_error ( void )

checks for error conditions for R2 (cid or csd) response.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 2017 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_card_init().

◆ command_rsp3_error()

sd_error_status_type command_rsp3_error ( void )

checks for error conditions for R3 (ocr) response.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 1987 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_power_on().

◆ command_rsp4_error()

sd_error_status_type command_rsp4_error ( uint8_t cmd )

checks for error conditions for r4 response.

Parameters
cmd the sent command index.
Return values
sd_error_status_type sd card error code.

Definition at line 2057 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

◆ command_rsp5_error()

sd_error_status_type command_rsp5_error ( uint8_t cmd )

checks for error conditions for r5 response.

Parameters
cmd the sent command index.
Return values
sd_error_status_type sd card error code.

Definition at line 2100 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

◆ command_rsp6_error()

sd_error_status_type command_rsp6_error | ( | uint8_t | cmd,
 |  | uint16_t * | prca
 | ) |  |

checks for error conditions for r6 (rca) response.

Parameters
cmd | the sent command index.
prca | pointer to the variable that will contain the sd card relative address rca.
Return values
sd_error_status_type sd card error code.

Definition at line 2163 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_card_init().

◆ command_rsp7_error()

sd_error_status_type command_rsp7_error ( void )

checks for error conditions for R7 response.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 1907 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_power_on().

◆ convert_from_bytes_to_power_of_two()

uint8_t convert_from_bytes_to_power_of_two ( uint16_t number_of_bytes )

converts the number of bytes in power of two and returns the power.

Parameters
number_of_bytes number of bytes.
Return values
none

Definition at line 2692 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_block_read(), sd_block_write(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sd_switch().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c.

◆ fatfs_test()

static test_result_type fatfs_test ( void )
static

fatfs file read/write test.

Parameters
none
Return values
TEST_FAIL fail. TEST_SUCCESS: success.

Definition at line 110 of file project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 214 of file project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c.

◆ mmc_stream_read()

sd_error_status_type mmc_stream_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint32_t | len
 | ) |  |

read mmc card data stream.

Parameters
buf | buffer of saving data from mmc card
addr | start address of data from mmc card
len | data size
Return values
sd_error_status_type sd card error code.

Definition at line 1660 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_stream_test().

◆ mmc_stream_write()

sd_error_status_type mmc_stream_write | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint32_t | len
 | ) |  |

write mmc card data stream.

Parameters
buf | data that writing to mmc card
addr | start address mmc card
len | data size
Return values
sd_error_status_type sd card error code.

Definition at line 1707 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_stream_test().

◆ mmc_switch()

sd_error_status_type mmc_switch | ( | uint8_t | set,
 |  | uint8_t | index,
 |  | uint8_t | value
 | ) |  |

switch mmc card speed to high speed

Parameters
set | new state of the sdio wide bus mode.
index | offset.
value | expect speed.
Return values
sd_error_status_type sd card error code.

Definition at line 2298 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_wide_bus_operation_config(), and speed_change().

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c.

◆ nvic_configuration()

static void nvic_configuration ( void )
static

configures sdio1 irq channel.

Parameters
none
Return values
none

Definition at line 98 of file project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c.

Referenced by main().

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c.

◆ scr_find()

sd_error_status_type scr_find ( void )

find the sd card scr register value.

Return values
sd_error_status_type sd card error code.

Definition at line 2514 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_block_read()

sd_error_status_type sd_block_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size
 | ) |  |

allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that will contain the received data
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
Return values
sd_error_status_type sd card error code.

Definition at line 1195 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_read_disk(), and sd_single_block_test().

◆ sd_block_write()

sd_error_status_type sd_block_write | ( | const uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size
 | ) |  |

allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that contain the data to be transferred.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
Return values
sd_error_status_type sd card error code.

Definition at line 1374 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_single_block_test(), and sd_write_disk().

◆ sd_blocks_erase()

sd_error_status_type sd_blocks_erase | ( | long long | addr,
 |  | uint32_t | nblks
 | ) |  |

erase continuous data block

Parameters
addr | starting address
nblks | amount of erasing data block
Return values
sd_error_status_type sd card error code.

Definition at line 1037 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

◆ sd_bus_wide_enable()

sd_error_status_type sd_bus_wide_enable ( confirm_state new_state )

enable or disable the sdio wide bus mode.

Parameters
new_state new state of the sdio wide bus mode. (true or false)
Return values
sd_error_status_type sd card error code.

Definition at line 2229 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_wide_bus_operation_config().

◆ sd_card_info_get()

sd_error_status_type sd_card_info_get ( sd_card_info_struct_type * card_info )

returns information about specific card.

Parameters
card_info pointer to a sd_card_info_struct_type structure that contains all sd card information.
Return values
sd_error_status_type sd card error code.

Definition at line 539 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_card_init()

sd_error_status_type sd_card_init ( void )

intialises all cards or single card as the case may be card(s) come into standby state.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 424 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_deselect_select()

sd_error_status_type sd_deselect_select ( uint32_t addr )

selects od deselects the corresponding card.

Parameters
addr address of the card to be selected.
Return values
sd_error_status_type sd card error code.

Definition at line 814 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_device_mode_set()

sd_error_status_type sd_device_mode_set ( uint32_t mode )

set sdio work mode.

Parameters
mode parameter as following values:
  • SD_TRANSFER_POLLING_MODE: dma mode.
  • SD_TRANSFER_POLLING_MODE: polling mode.
Return values
sd_error_status_type sd card error code.

Definition at line 793 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_dma_config()

void sd_dma_config | ( | uint32_t * | mbuf,
 |  | uint32_t | buf_size,
 |  | dma_dir_type | dir
 | ) |  |

set dma configuation for sdio

Parameters
mbuf | buffer address
buf_size | transmission data size
dir | dma direction, it is DMA_DIR_MEMORY_TO_PERIPHERAL(writing data) or DMA_DIR_PERIPHERAL_TO_MEMORY(read data)
Return values
none

Definition at line 2713 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sdio_command_data_send().

◆ sd_init()

sd_error_status_type sd_init ( void )

initializes the sd card and put it into standby state (ready for data transfer).

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 73 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by disk_initialize(), main(), and sdio_command_data_send().

◆ sd_irq_service()

sd_error_status_type sd_irq_service ( void )

allows to process all the interrupts that are high.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 1796 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by SDIO1_IRQHandler(), and SDIO2_IRQHandler().

◆ sd_mult_blocks_read()

sd_error_status_type sd_mult_blocks_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size,
 |  | uint32_t | nblks
 | ) |  |

allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that will contain the received data.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
nblks | number of blocks to be read.
Return values
sd_error_status_type sd card error code.

Definition at line 1284 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_multiple_blocks_test(), and sd_read_disk().

◆ sd_mult_blocks_write()

sd_error_status_type sd_mult_blocks_write | ( | const uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size,
 |  | uint32_t | nblks
 | ) |  |

allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only.

Parameters
buf | pointer to the buffer that contain the data to be transferred.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
nblks | number of blocks to be written.
Return values
sd_error_status_type sd card error code.

Definition at line 1496 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_multiple_blocks_test(), and sd_write_disk().

◆ sd_power_off()

sd_error_status_type sd_power_off ( void )

turns the sdio output signals off.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 410 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

◆ sd_power_on()

sd_error_status_type sd_power_on ( void )

enquires cards about their operating voltage and configures clock controls.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 210 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_state_get()

sd_card_state_type sd_state_get ( void )

returns information about sd card.

Parameters
none.
Return values
sd_card_state_type sd card state code.

Definition at line 2496 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

◆ sd_status_send()

sd_error_status_type sd_status_send ( uint32_t * p_card_status )

read current card status.

Parameters
p_card_status card status.
Return values
sd_error_status_type sd card error code.

Definition at line 2459 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_switch(), sd_block_write(), sd_mult_blocks_write(), and sd_state_get().

◆ sd_switch()

sd_error_status_type sd_switch | ( | uint32_t | mode,
 |  | uint32_t | group,
 |  | uint8_t | value,
 |  | uint8_t * | rsp
 | ) |  |

switch sd card speed to high speed

Parameters
mode | polling mode or dma mode
group | selected group
value | wanted speed
rsp | switch status
Return values
sd_error_status_type sd card error code.

Definition at line 2349 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by speed_change().

◆ sd_test_error()

static void sd_test_error ( void )
static

led2 on off every 300ms for sd test error.

Parameters
none
Return values
none

Definition at line 85 of file project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c.

Referenced by main().

◆ sd_wide_bus_operation_config()

sd_error_status_type sd_wide_bus_operation_config ( sdio_bus_width_type mode )

enable wide bus opeartion for the requeseted card if supported by card.

Parameters
mode specifies the sd card wide bus mode. this parameter can be one of the following values:
  • SDIO_BUS_WIDTH_D8: 8-bit data transfer (only for mmc)
  • SDIO_BUS_WIDTH_D4: 4-bit data transfer
  • SDIO_BUS_WIDTH_D1: 1-bit data transfer
Return values
sd_error_status_type sd card error code.

Definition at line 750 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_stream_test(), sd_init(), sd_multiple_blocks_test(), and sd_single_block_test().

◆ SDIO1_IRQHandler()

void SDIO1_IRQHandler ( void )

sdio1 isr.

Parameters
none.
Return values
none.

Definition at line 1776 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

◆ SDIO2_IRQHandler()

void SDIO2_IRQHandler ( void )

sdio2 isr.

Parameters
none.
Return values
none.

Definition at line 1786 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

◆ sdio_clock_set()

void sdio_clock_set ( uint32_t clk_div )

set sdio clock devision factor.

Parameters
clkdiv sdio_ck = ahbclk / (clkdiv+2)
Return values
none

Definition at line 195 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_init().

◆ sdio_command_data_send()

sd_error_status_type sdio_command_data_send | ( | sdio_command_struct_type * | sdio_cmd_init_t,
 |  | sdio_data_struct_type * | sdio_data_init_t,
 |  | uint32_t * | buf
 | ) |  |

read data from or write data to sd card.

Parameters
sdio_cmd_init_struct | pointer to sdio_command_struct_type structure.
sdio_data_init_struct | pointer to sdio_data_struct_type structure.
buf | pointer to data buffer read or write.
Return values
sd_error_status_type sd card error code.

Definition at line 837 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), sd_block_read(), sd_block_write(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sd_switch().

◆ speed_change()

sd_error_status_type speed_change ( uint8_t speed )

set bus speed

Parameters
speed 0,normal speed; 1,high speed.
Return values
sd_error_status_type sd card error code.

Definition at line 2628 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_init().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c.

Variable Documentation

◆ card_type [1/2]

sd_memory_card_type card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1
static

Definition at line 43 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_card_info_get(), sd_card_init(), sd_init(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_wide_bus_operation_config(), and speed_change().

◆ card_type [2/2]

sd_memory_card_type card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1
static

Definition at line 43 of file at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c.

◆ cid_table [1/2]

uint32_t cid_table[4]
static

Definition at line 44 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_card_info_get(), and sd_card_init().

◆ cid_table [2/2]

uint32_t cid_table[4]
static

Definition at line 44 of file at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c.

◆ csd_table [1/2]

uint32_t csd_table[4]
static

Definition at line 44 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_card_info_get(), and sd_card_init().

◆ csd_table [2/2]

uint32_t csd_table[4]
static

Definition at line 44 of file at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c.

◆ device_mode [1/2]

sd_data_transfer_mode_type device_mode = SD_TRANSFER_POLLING_MODE
static

Definition at line 45 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_device_mode_set(), and sdio_command_data_send().

◆ device_mode [2/2]

sd_data_transfer_mode_type device_mode = SD_TRANSFER_POLLING_MODE
static

Definition at line 45 of file at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c.

◆ file [1/2]

FIL file

Definition at line 43 of file project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c.

Referenced by fatfs_test(), fs_bytes_left(), fs_close(), fs_open(), and http_recv().

◆ file [2/2]

FIL file

Definition at line 43 of file project/at_start_f437/examples/sdio/sdio_fatfs/src/main.c.

Referenced by fatfs_test().

◆ fs [1/2]

FATFS fs

Definition at line 42 of file project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c.

Referenced by fatfs_test().

◆ fs [2/2]

FATFS fs

Definition at line 42 of file project/at_start_f437/examples/sdio/sdio_fatfs/src/main.c.

Referenced by fatfs_test().

◆ rca [1/2]

uint32_t rca = 0
static

Definition at line 44 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by check_card_programming(), sd_card_info_get(), sd_card_init(), sd_mult_blocks_write(), and sd_status_send().

◆ rca [2/2]

uint32_t rca = 0
static

Definition at line 44 of file at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c.

◆ sd_card_info [1/2]

sd_card_info_struct_type sd_card_info

Definition at line 49 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by scr_find(), sd_bus_wide_enable(), sd_init(), and speed_change().

◆ sd_card_info [2/2]

sd_card_info_struct_type sd_card_info

Definition at line 49 of file at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by disk_ioctl(), main(), and show_card_info().

◆ sdio_command_init_struct [1/2]

sdio_command_struct_type sdio_command_init_struct

Definition at line 40 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by check_card_programming(), mmc_stream_read(), mmc_stream_write(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), and sd_switch().

◆ sdio_command_init_struct [2/2]

sdio_command_struct_type sdio_command_init_struct

Definition at line 40 of file at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c.

◆ sdio_data_init_struct [1/2]

sdio_data_struct_type sdio_data_init_struct

Definition at line 41 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sd_switch().

◆ sdio_data_init_struct [2/2]

sdio_data_struct_type sdio_data_init_struct

Definition at line 41 of file at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c.

◆ stop_flag [1/2]

uint8_t stop_flag = 0
static

Definition at line 46 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), sd_block_read(), sd_block_write(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_switch(), and sdio_command_data_send().

◆ stop_flag [2/2]

uint8_t stop_flag = 0
static

Definition at line 46 of file at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c.

◆ transfer_end [1/2]

volatile uint8_t transfer_end = 0

Definition at line 48 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_irq_service(), and sdio_command_data_send().

◆ transfer_end [2/2]

volatile uint8_t transfer_end = 0

Definition at line 48 of file at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c.

◆ transfer_error [1/2]

volatile sd_error_status_type transfer_error = SD_OK

Definition at line 47 of file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.

Referenced by sd_irq_service(), and sdio_command_data_send().

◆ transfer_error [2/2]

volatile sd_error_status_type transfer_error = SD_OK

Definition at line 47 of file at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c.

◆ work [1/2]

BYTE work[FF_MAX_SS]

Definition at line 44 of file project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c.

Referenced by fatfs_test().

◆ work [2/2]

BYTE work[FF_MAX_SS]

Definition at line 44 of file project/at_start_f437/examples/sdio/sdio_fatfs/src/main.c.

Referenced by fatfs_test().


AT32F435/437 Firmwary Library: SPI_crc_transfer_polling

Macros | Functions | Variables
SPI_crc_transfer_polling
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | BUFFER_SIZE 32
#define | BUFFER_SIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

uint16_t | spi3_buffer_tx [32]
uint16_t | spi2_buffer_tx [32]
uint16_t | spi3_buffer_rx [32]
uint16_t | spi2_buffer_rx [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
__IO uint16_t | crc1_value = 0
__IO uint16_t | crc2_value = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR
uint16_t | spi3_buffer_tx [32]
uint16_t | spi2_buffer_tx [32]
uint16_t | spi3_buffer_rx [32]
uint16_t | spi2_buffer_rx [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
__IO uint16_t | crc1_value = 0
__IO uint16_t | crc2_value = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE [1/2]

#define BUFFER_SIZE 32

Definition at line 38 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c.

◆ BUFFER_SIZE [2/2]

#define BUFFER_SIZE 32

Definition at line 38 of file project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint16_t * | pbuffer1,
 |  | uint16_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer compare function.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
the result of compare

Definition at line 63 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 10

< gpio pins number 11

< gpio pins number 12

< gpio pins number 1

< gpio pins number 2

< gpio pins number 4

Definition at line 114 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< spi or i2s transmit data buffer empty flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

< spi or i2s transmit data buffer empty flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

< spi crc calculation error flag

< spi crc calculation error flag

< spi crc calculation error flag

< spi crc calculation error flag

< spi or i2s transmit data buffer empty flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

< spi or i2s transmit data buffer empty flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

< spi crc calculation error flag

< spi crc calculation error flag

< spi crc calculation error flag

< spi crc calculation error flag

Definition at line 165 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c.

◆ spi_config()

static void spi_config ( void )
static

spi configuration.

Parameters
none
Return values
none

Definition at line 82 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c.

Variable Documentation

◆ crc1_value [1/2]

__IO uint16_t crc1_value = 0

Definition at line 50 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ crc1_value [2/2]

__IO uint16_t crc1_value = 0

Definition at line 50 of file project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c.

◆ crc2_value [1/2]

__IO uint16_t crc2_value = 0

Definition at line 50 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ crc2_value [2/2]

__IO uint16_t crc2_value = 0

Definition at line 50 of file project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c.

◆ rx_index [1/2]

uint32_t rx_index = 0

Definition at line 49 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ rx_index [2/2]

uint32_t rx_index = 0

Definition at line 49 of file project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c.

◆ spi2_buffer_rx [1/2]

uint16_t spi2_buffer_rx[32]

Definition at line 48 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ spi2_buffer_rx [2/2]

uint16_t spi2_buffer_rx[32]

Definition at line 48 of file project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c.

◆ spi2_buffer_tx [1/2]

uint16_t spi2_buffer_tx[32]
Initial value:
= {0x5152, 0x5354, 0x5556, 0x5758, 0x595A, 0x5B5C, 0x5D5E, 0x5F60,
0x6162, 0x6364, 0x6566, 0x6768, 0x696A, 0x6B6C, 0x6D6E, 0x6F70,
0x7172, 0x7374, 0x7576, 0x7778, 0x797A, 0x7B7C, 0x7D7E, 0x7F80,
0x8182, 0x8384, 0x8586, 0x8788, 0x898A, 0x8B8C, 0x8D8E, 0x8F90}

Definition at line 44 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ spi2_buffer_tx [2/2]

uint16_t spi2_buffer_tx[32]
Initial value:
= {0x5152, 0x5354, 0x5556, 0x5758, 0x595A, 0x5B5C, 0x5D5E, 0x5F60,
0x6162, 0x6364, 0x6566, 0x6768, 0x696A, 0x6B6C, 0x6D6E, 0x6F70,
0x7172, 0x7374, 0x7576, 0x7778, 0x797A, 0x7B7C, 0x7D7E, 0x7F80,
0x8182, 0x8384, 0x8586, 0x8788, 0x898A, 0x8B8C, 0x8D8E, 0x8F90}

Definition at line 44 of file project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c.

◆ spi3_buffer_rx [1/2]

uint16_t spi3_buffer_rx[32]

Definition at line 48 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ spi3_buffer_rx [2/2]

uint16_t spi3_buffer_rx[32]

Definition at line 48 of file project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c.

◆ spi3_buffer_tx [1/2]

uint16_t spi3_buffer_tx[32]
Initial value:
= {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C, 0x0D0E, 0x0F10,
0x1112, 0x1314, 0x1516, 0x1718, 0x191A, 0x1B1C, 0x1D1E, 0x1F20,
0x2122, 0x2324, 0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C, 0x3D3E, 0x3F40}

Definition at line 40 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ spi3_buffer_tx [2/2]

uint16_t spi3_buffer_tx[32]
Initial value:
= {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C, 0x0D0E, 0x0F10,
0x1112, 0x1314, 0x1516, 0x1718, 0x191A, 0x1B1C, 0x1D1E, 0x1F20,
0x2122, 0x2324, 0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C, 0x3D3E, 0x3F40}

Definition at line 40 of file project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c.

◆ transfer_status1 [1/2]

volatile error_status transfer_status1 = ERROR

Definition at line 51 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ transfer_status1 [2/2]

volatile error_status transfer_status1 = ERROR

Definition at line 51 of file project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c.

◆ transfer_status2 [1/2]

volatile error_status transfer_status2 = ERROR

Definition at line 51 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ transfer_status2 [2/2]

volatile error_status transfer_status2 = ERROR

Definition at line 51 of file project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c.

◆ tx_index [1/2]

uint32_t tx_index = 0

Definition at line 49 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ tx_index [2/2]

uint32_t tx_index = 0

Definition at line 49 of file project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c.


AT32F435/437 Firmwary Library: SPI_fullduplex_polling

Macros | Functions | Variables
SPI_fullduplex_polling
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | BUFFER_SIZE 32
#define | BUFFER_SIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t bufferlength)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi3_buffer_tx [32]
uint8_t | spi2_buffer_tx [32]
uint8_t | spi3_buffer_rx [32]
uint8_t | spi2_buffer_rx [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR
volatile error_status | transfer_status3 = ERROR
volatile error_status | transfer_status4 = ERROR
spi_init_type spi_init_struct
uint8_t | spi3_buffer_tx [32]
uint8_t | spi2_buffer_tx [32]
uint8_t | spi3_buffer_rx [32]
uint8_t | spi2_buffer_rx [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR
volatile error_status | transfer_status3 = ERROR
volatile error_status | transfer_status4 = ERROR

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE [1/2]

#define BUFFER_SIZE 32

Definition at line 38 of file project/at_start_f435/examples/spi/fullduplex_polling/src/main.c.

◆ BUFFER_SIZE [2/2]

#define BUFFER_SIZE 32

Definition at line 38 of file project/at_start_f437/examples/spi/fullduplex_polling/src/main.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | bufferlength
 | ) |  |

buffer compare function.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
the result of compare

Definition at line 64 of file project/at_start_f435/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 10

< gpio pins number 11

< gpio pins number 12

< gpio pins number 1

< gpio pins number 2

< gpio pins number 4

Definition at line 111 of file project/at_start_f435/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< spi or i2s transmit data buffer empty flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

< spi or i2s transmit data buffer empty flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

< spi or i2s transmit data buffer empty flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

< spi or i2s transmit data buffer empty flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

Definition at line 162 of file project/at_start_f435/examples/spi/fullduplex_polling/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c.

◆ spi_config()

static void spi_config ( void )
static

spi configuration.

Parameters
none
Return values
none

Definition at line 84 of file project/at_start_f435/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c.

Variable Documentation

◆ rx_index [1/2]

uint32_t rx_index = 0

Definition at line 50 of file project/at_start_f435/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ rx_index [2/2]

uint32_t rx_index = 0

Definition at line 50 of file project/at_start_f437/examples/spi/fullduplex_polling/src/main.c.

◆ spi2_buffer_rx [1/2]

uint8_t spi2_buffer_rx[32]

Definition at line 49 of file project/at_start_f435/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ spi2_buffer_rx [2/2]

uint8_t spi2_buffer_rx[32]

Definition at line 49 of file project/at_start_f437/examples/spi/fullduplex_polling/src/main.c.

◆ spi2_buffer_tx [1/2]

uint8_t spi2_buffer_tx[32]
Initial value:
= {0x51, 0x52, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58,
0x59, 0x5A, 0x5B, 0x5C, 0x5D, 0x5E, 0x5F, 0x60,
0x61, 0x62, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68,
0x69, 0x6A, 0x6B, 0x6C, 0x6D, 0x6E, 0x6F, 0x70}

Definition at line 45 of file project/at_start_f435/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ spi2_buffer_tx [2/2]

uint8_t spi2_buffer_tx[32]
Initial value:
= {0x51, 0x52, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58,
0x59, 0x5A, 0x5B, 0x5C, 0x5D, 0x5E, 0x5F, 0x60,
0x61, 0x62, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68,
0x69, 0x6A, 0x6B, 0x6C, 0x6D, 0x6E, 0x6F, 0x70}

Definition at line 45 of file project/at_start_f437/examples/spi/fullduplex_polling/src/main.c.

◆ spi3_buffer_rx [1/2]

uint8_t spi3_buffer_rx[32]

Definition at line 49 of file project/at_start_f435/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ spi3_buffer_rx [2/2]

uint8_t spi3_buffer_rx[32]

Definition at line 49 of file project/at_start_f437/examples/spi/fullduplex_polling/src/main.c.

◆ spi3_buffer_tx [1/2]

uint8_t spi3_buffer_tx[32]
Initial value:
= {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20}

Definition at line 41 of file project/at_start_f435/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ spi3_buffer_tx [2/2]

uint8_t spi3_buffer_tx[32]
Initial value:
= {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20}

Definition at line 41 of file project/at_start_f437/examples/spi/fullduplex_polling/src/main.c.

◆ spi_init_struct [1/2]

spi_init_type spi_init_struct

Definition at line 40 of file project/at_start_f435/examples/spi/fullduplex_polling/src/main.c.

Referenced by main(), spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), touch_pin_init(), and usart_spi_configuration().

◆ spi_init_struct [2/2]

spi_init_type spi_init_struct

Definition at line 40 of file project/at_start_f437/examples/spi/fullduplex_polling/src/main.c.

Referenced by spi_config().

◆ transfer_status1 [1/2]

volatile error_status transfer_status1 = ERROR

Definition at line 51 of file project/at_start_f435/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ transfer_status1 [2/2]

volatile error_status transfer_status1 = ERROR

Definition at line 51 of file project/at_start_f437/examples/spi/fullduplex_polling/src/main.c.

◆ transfer_status2 [1/2]

volatile error_status transfer_status2 = ERROR

Definition at line 51 of file project/at_start_f435/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ transfer_status2 [2/2]

volatile error_status transfer_status2 = ERROR

Definition at line 51 of file project/at_start_f437/examples/spi/fullduplex_polling/src/main.c.

◆ transfer_status3 [1/2]

volatile error_status transfer_status3 = ERROR

Definition at line 52 of file project/at_start_f435/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ transfer_status3 [2/2]

volatile error_status transfer_status3 = ERROR

Definition at line 52 of file project/at_start_f437/examples/spi/fullduplex_polling/src/main.c.

◆ transfer_status4 [1/2]

volatile error_status transfer_status4 = ERROR

Definition at line 52 of file project/at_start_f435/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ transfer_status4 [2/2]

volatile error_status transfer_status4 = ERROR

Definition at line 52 of file project/at_start_f437/examples/spi/fullduplex_polling/src/main.c.

◆ tx_index [1/2]

uint32_t tx_index = 0

Definition at line 50 of file project/at_start_f435/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ tx_index [2/2]

uint32_t tx_index = 0

Definition at line 50 of file project/at_start_f437/examples/spi/fullduplex_polling/src/main.c.


AT32F435/437 Firmwary Library: SPI_halfduplex_interrupt

Macros | Functions | Variables
SPI_halfduplex_interrupt
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | BUFFERSIZE 32
#define | BUFFER_SIZE 32
#define | BUFFERSIZE 32
#define | BUFFER_SIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | SPI3_I2S3EXT_IRQHandler (void)
This function handles the spi3 interrupt request. More...
void | SPI2_I2S2EXT_IRQHandler (void)
This function handles the spi2 interrupt request. More...
static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

uint8_t | spi3_buffer_tx [32]
uint8_t | spi2_buffer_rx [32]
uint32_t | tx_index
uint32_t | rx_index
spi_init_type spi_init_struct
uint8_t | spi3_buffer_tx [32]
uint8_t | spi2_buffer_rx [32]
volatile uint32_t | tx_index = 0
volatile uint32_t | rx_index = 0
volatile error_status | transfer_status = ERROR
uint8_t | spi3_buffer_tx [32]
uint8_t | spi2_buffer_rx [32]
uint32_t | tx_index
uint32_t | rx_index
spi_init_type spi_init_struct
uint8_t | spi3_buffer_tx [32]
uint8_t | spi2_buffer_rx [32]
volatile uint32_t | tx_index = 0
volatile uint32_t | rx_index = 0
volatile error_status | transfer_status = ERROR

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE [1/2]

#define BUFFER_SIZE 32

Definition at line 38 of file project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c.

◆ BUFFER_SIZE [2/2]

#define BUFFER_SIZE 32

Definition at line 38 of file project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c.

◆ BUFFERSIZE [1/2]

#define BUFFERSIZE 32

Definition at line 38 of file project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c.

◆ BUFFERSIZE [2/2]

#define BUFFERSIZE 32

Definition at line 38 of file project/at_start_f437/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer compare function.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
the result of compare

Definition at line 60 of file project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 85 of file project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 10

< gpio pins number 12

< gpio pins number 1

< gpio pins number 2

Definition at line 113 of file project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 59 of file project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 152 of file project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 72 of file project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c.

◆ SPI2_I2S2EXT_IRQHandler()

void SPI2_I2S2EXT_IRQHandler ( void )

This function handles the spi2 interrupt request.

Parameters
None
Return values
None

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

Definition at line 164 of file project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c.

◆ SPI3_I2S3EXT_IRQHandler()

void SPI3_I2S3EXT_IRQHandler ( void )

This function handles the spi3 interrupt request.

Parameters
None
Return values
None

< spi or i2s transmit data buffer empty flag

< transmit data buffer empty interrupt

< spi or i2s transmit data buffer empty flag

< transmit data buffer empty interrupt

Definition at line 147 of file project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c.

◆ spi_config()

static void spi_config ( void )
static

spi configuration.

Parameters
none
Return values
none

< transmit data buffer empty interrupt

< receive data buffer full interrupt

Definition at line 80 of file project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 138 of file project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 98 of file project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c.

Variable Documentation

◆ rx_index [1/4]

uint32_t rx_index
extern

Definition at line 40 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c.

Referenced by SPI2_I2S2EXT_IRQHandler().

◆ rx_index [2/4]

volatile uint32_t rx_index = 0

Definition at line 47 of file project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ rx_index [3/4]

uint32_t rx_index
extern

Definition at line 40 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c.

◆ rx_index [4/4]

volatile uint32_t rx_index = 0

Definition at line 47 of file project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c.

◆ spi2_buffer_rx [1/4]

uint8_t spi2_buffer_rx[32]
extern

Definition at line 53 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by SPI2_I2S2EXT_IRQHandler().

◆ spi2_buffer_rx [2/4]

uint8_t spi2_buffer_rx[32]

Definition at line 46 of file project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ spi2_buffer_rx [3/4]

uint8_t spi2_buffer_rx[32]
extern

Definition at line 53 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

◆ spi2_buffer_rx [4/4]

uint8_t spi2_buffer_rx[32]

Definition at line 46 of file project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c.

◆ spi3_buffer_tx [1/4]

uint8_t spi3_buffer_tx[32]
extern

Definition at line 45 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by SPI3_I2S3EXT_IRQHandler().

◆ spi3_buffer_tx [2/4]

uint8_t spi3_buffer_tx[32]
Initial value:
= {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20}

Definition at line 42 of file project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ spi3_buffer_tx [3/4]

uint8_t spi3_buffer_tx[32]
extern

Definition at line 45 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

◆ spi3_buffer_tx [4/4]

uint8_t spi3_buffer_tx[32]
Initial value:
= {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20}

Definition at line 42 of file project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c.

◆ spi_init_struct [1/2]

spi_init_type spi_init_struct

Definition at line 40 of file project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by spi_config().

◆ spi_init_struct [2/2]

spi_init_type spi_init_struct

Definition at line 40 of file project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by spi_config().

◆ transfer_status [1/2]

volatile error_status transfer_status = ERROR

Definition at line 48 of file project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ transfer_status [2/2]

volatile error_status transfer_status = ERROR

Definition at line 48 of file project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c.

◆ tx_index [1/4]

uint32_t tx_index
extern

Definition at line 45 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by SPI3_I2S3EXT_IRQHandler().

◆ tx_index [2/4]

volatile uint32_t tx_index = 0

Definition at line 47 of file project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c.

◆ tx_index [3/4]

uint32_t tx_index
extern

Definition at line 45 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c.

◆ tx_index [4/4]

volatile uint32_t tx_index = 0

Definition at line 47 of file project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c.


AT32F435/437 Firmwary Library: SPI_halfduplex_transceiver_switch

Macros | Functions | Variables
SPI_halfduplex_transceiver_switch
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | BUFFERSIZE 32
#define | BUFFER_SIZE 32
#define | BUFFERSIZE 32
#define | BUFFER_SIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | SPI3_I2S3EXT_IRQHandler (void)
This function handles the spi3 interrupt request. More...
void | SPI2_I2S2EXT_IRQHandler (void)
This function handles the spi2 interrupt request. More...
static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

uint8_t | spi3_buffer_tx [32]
uint8_t | spi2_buffer_tx [32]
uint8_t | spi3_buffer_rx [32]
uint8_t | spi2_buffer_rx [32]
uint32_t | tx_index
uint32_t | rx_index
spi_init_type spi_init_struct
uint8_t | spi3_buffer_tx [32]
uint8_t | spi2_buffer_tx [32]
uint8_t | spi3_buffer_rx [32]
uint8_t | spi2_buffer_rx [32]
volatile uint32_t | tx_index = 0
volatile uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR
uint8_t | spi3_buffer_tx [32]
uint8_t | spi2_buffer_tx [32]
uint8_t | spi3_buffer_rx [32]
uint8_t | spi2_buffer_rx [32]
uint32_t | tx_index
uint32_t | rx_index
spi_init_type spi_init_struct
uint8_t | spi3_buffer_tx [32]
uint8_t | spi2_buffer_tx [32]
uint8_t | spi3_buffer_rx [32]
uint8_t | spi2_buffer_rx [32]
volatile uint32_t | tx_index = 0
volatile uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE [1/2]

#define BUFFER_SIZE 32

Definition at line 38 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c.

◆ BUFFER_SIZE [2/2]

#define BUFFER_SIZE 32

Definition at line 38 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c.

◆ BUFFERSIZE [1/2]

#define BUFFERSIZE 32

Definition at line 38 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c.

◆ BUFFERSIZE [2/2]

#define BUFFERSIZE 32

Definition at line 38 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer compare function.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
the result of compare

Definition at line 63 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 87 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 10

< gpio pins number 12

< gpio pins number 1

< gpio pins number 2

< gpio pins number 1

Definition at line 116 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 61 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< transmit data buffer empty interrupt

< receive data buffer full interrupt

< receive data buffer full interrupt

< transmit data buffer empty interrupt

< transmit data buffer empty interrupt

< receive data buffer full interrupt

< receive data buffer full interrupt

< transmit data buffer empty interrupt

Definition at line 157 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 74 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c.

◆ SPI2_I2S2EXT_IRQHandler()

void SPI2_I2S2EXT_IRQHandler ( void )

This function handles the spi2 interrupt request.

Parameters
None
Return values
None

< spi or i2s transmit data buffer empty flag

< transmit data buffer empty interrupt

< spi or i2s receive data buffer full flag

< spi or i2s transmit data buffer empty flag

< transmit data buffer empty interrupt

< spi or i2s receive data buffer full flag

Definition at line 182 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c.

◆ SPI3_I2S3EXT_IRQHandler()

void SPI3_I2S3EXT_IRQHandler ( void )

This function handles the spi3 interrupt request.

Parameters
None
Return values
None

< spi or i2s transmit data buffer empty flag

< transmit data buffer empty interrupt

< spi or i2s receive data buffer full flag

< receive data buffer full interrupt

< spi or i2s transmit data buffer empty flag

< transmit data buffer empty interrupt

< spi or i2s receive data buffer full flag

< receive data buffer full interrupt

Definition at line 149 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c.

◆ spi_config()

static void spi_config ( void )
static

spi configuration.

Parameters
none
Return values
none

< transmit data buffer empty interrupt

< receive data buffer full interrupt

Definition at line 83 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 140 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 100 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c.

Variable Documentation

◆ rx_index [1/4]

uint32_t rx_index
extern

Definition at line 40 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c.

Referenced by SPI2_I2S2EXT_IRQHandler(), and SPI3_I2S3EXT_IRQHandler().

◆ rx_index [2/4]

volatile uint32_t rx_index = 0

Definition at line 50 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ rx_index [3/4]

uint32_t rx_index
extern

Definition at line 40 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c.

Referenced by main(), and SPI2_I2S2EXT_IRQHandler().

◆ rx_index [4/4]

volatile uint32_t rx_index = 0

Definition at line 50 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c.

◆ spi2_buffer_rx [1/4]

uint8_t spi2_buffer_rx[32]
extern

Definition at line 53 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by SPI2_I2S2EXT_IRQHandler().

◆ spi2_buffer_rx [2/4]

uint8_t spi2_buffer_rx[32]

Definition at line 49 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ spi2_buffer_rx [3/4]

uint8_t spi2_buffer_rx[32]
extern

Definition at line 53 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main(), and spi_config().

◆ spi2_buffer_rx [4/4]

uint8_t spi2_buffer_rx[32]

Definition at line 49 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c.

◆ spi2_buffer_tx [1/4]

uint8_t spi2_buffer_tx[32]
extern

Definition at line 44 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c.

Referenced by SPI2_I2S2EXT_IRQHandler().

◆ spi2_buffer_tx [2/4]

uint8_t spi2_buffer_tx[32]
Initial value:
= {0x51, 0x52, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58,
0x59, 0x5A, 0x5B, 0x5C, 0x5D, 0x5E, 0x5F, 0x60,
0x61, 0x62, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68,
0x69, 0x6A, 0x6B, 0x6C, 0x6D, 0x6E, 0x6F, 0x70}

Definition at line 45 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ spi2_buffer_tx [3/4]

uint8_t spi2_buffer_tx[32]
extern

Definition at line 44 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main(), and spi_config().

◆ spi2_buffer_tx [4/4]

uint8_t spi2_buffer_tx[32]
Initial value:
= {0x51, 0x52, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58,
0x59, 0x5A, 0x5B, 0x5C, 0x5D, 0x5E, 0x5F, 0x60,
0x61, 0x62, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68,
0x69, 0x6A, 0x6B, 0x6C, 0x6D, 0x6E, 0x6F, 0x70}

Definition at line 45 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c.

◆ spi3_buffer_rx [1/4]

uint8_t spi3_buffer_rx[32]
extern

Definition at line 48 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c.

Referenced by SPI3_I2S3EXT_IRQHandler().

◆ spi3_buffer_rx [2/4]

uint8_t spi3_buffer_rx[32]

Definition at line 49 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ spi3_buffer_rx [3/4]

uint8_t spi3_buffer_rx[32]
extern

Definition at line 48 of file project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main(), and spi_config().

◆ spi3_buffer_rx [4/4]

uint8_t spi3_buffer_rx[32]

Definition at line 49 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c.

◆ spi3_buffer_tx [1/4]

uint8_t spi3_buffer_tx[32]
extern

Definition at line 45 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by SPI3_I2S3EXT_IRQHandler().

◆ spi3_buffer_tx [2/4]

uint8_t spi3_buffer_tx[32]
Initial value:
= {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20}

Definition at line 41 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ spi3_buffer_tx [3/4]

uint8_t spi3_buffer_tx[32]
extern

Definition at line 45 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main(), and spi_config().

◆ spi3_buffer_tx [4/4]

uint8_t spi3_buffer_tx[32]
Initial value:
= {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20}

Definition at line 41 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c.

◆ spi_init_struct [1/2]

spi_init_type spi_init_struct

Definition at line 40 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main(), and spi_config().

◆ spi_init_struct [2/2]

spi_init_type spi_init_struct

Definition at line 40 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by spi_config().

◆ transfer_status1 [1/2]

volatile error_status transfer_status1 = ERROR

Definition at line 51 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ transfer_status1 [2/2]

volatile error_status transfer_status1 = ERROR

Definition at line 51 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c.

◆ transfer_status2 [1/2]

volatile error_status transfer_status2 = ERROR

Definition at line 51 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ transfer_status2 [2/2]

volatile error_status transfer_status2 = ERROR

Definition at line 51 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c.

◆ tx_index [1/4]

uint32_t tx_index
extern

Definition at line 45 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by SPI2_I2S2EXT_IRQHandler(), and SPI3_I2S3EXT_IRQHandler().

◆ tx_index [2/4]

volatile uint32_t tx_index = 0

Definition at line 50 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ tx_index [3/4]

uint32_t tx_index
extern

Definition at line 45 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ tx_index [4/4]

volatile uint32_t tx_index = 0

Definition at line 50 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c.


AT32F435/437 Firmwary Library: SPI_only_receive_mode_polling

Macros | Functions | Variables
SPI_only_receive_mode_polling
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | BUFFER_SIZE 32
#define | BUFFER_SIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi3_buffer_tx [32]
uint8_t | spi2_buffer_rx [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
volatile error_status | transfer_status = ERROR
spi_init_type spi_init_struct
uint8_t | spi3_buffer_tx [32]
uint8_t | spi2_buffer_rx [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
volatile error_status | transfer_status = ERROR

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE [1/2]

#define BUFFER_SIZE 32

Definition at line 38 of file project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c.

◆ BUFFER_SIZE [2/2]

#define BUFFER_SIZE 32

Definition at line 38 of file project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer compare function.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
the result of compare

Definition at line 59 of file project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 10

< gpio pins number 12

< gpio pins number 1

< gpio pins number 4

< gpio pins number 1

Definition at line 107 of file project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

Definition at line 148 of file project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c.

◆ spi_config()

static void spi_config ( void )
static

spi configuration.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c.

Variable Documentation

◆ rx_index [1/2]

uint32_t rx_index = 0

Definition at line 46 of file project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by main().

◆ rx_index [2/2]

uint32_t rx_index = 0

Definition at line 46 of file project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c.

◆ spi2_buffer_rx [1/2]

uint8_t spi2_buffer_rx[32]

Definition at line 45 of file project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by main().

◆ spi2_buffer_rx [2/2]

uint8_t spi2_buffer_rx[32]

Definition at line 45 of file project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c.

◆ spi3_buffer_tx [1/2]

uint8_t spi3_buffer_tx[32]
Initial value:
= {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20}

Definition at line 41 of file project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by main().

◆ spi3_buffer_tx [2/2]

uint8_t spi3_buffer_tx[32]
Initial value:
= {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20}

Definition at line 41 of file project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c.

◆ spi_init_struct [1/2]

spi_init_type spi_init_struct

Definition at line 40 of file project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by spi_config().

◆ spi_init_struct [2/2]

spi_init_type spi_init_struct

Definition at line 40 of file project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by spi_config().

◆ transfer_status [1/2]

volatile error_status transfer_status = ERROR

Definition at line 47 of file project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by main().

◆ transfer_status [2/2]

volatile error_status transfer_status = ERROR

Definition at line 47 of file project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c.

◆ tx_index [1/2]

uint32_t tx_index = 0

Definition at line 46 of file project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by main().

◆ tx_index [2/2]

uint32_t tx_index = 0

Definition at line 46 of file project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c.


AT32F435/437 Firmwary Library: SPI_ti_fullduplex_dma

Macros | Functions | Variables
SPI_ti_fullduplex_dma
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | BUFFER_SIZE 32
#define | BUFFER_SIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t bufferlength)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi3_buffer_tx [32]
uint8_t | spi2_buffer_tx [32]
uint8_t | spi3_buffer_rx [32]
uint8_t | spi2_buffer_rx [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR
spi_init_type spi_init_struct
uint8_t | spi3_buffer_tx [32]
uint8_t | spi2_buffer_tx [32]
uint8_t | spi3_buffer_rx [32]
uint8_t | spi2_buffer_rx [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE [1/2]

#define BUFFER_SIZE 32

Definition at line 38 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c.

◆ BUFFER_SIZE [2/2]

#define BUFFER_SIZE 32

Definition at line 38 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | bufferlength
 | ) |  |

buffer compare function.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
the result of compare

Definition at line 63 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 10

< gpio pins number 11

< gpio pins number 12

< gpio pins number 0

< gpio pins number 1

< gpio pins number 2

< gpio pins number 4

Definition at line 161 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< dma1 channel2 full data transfer flag

< dma1 channel2 full data transfer flag

Definition at line 225 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c.

◆ spi_config()

static void spi_config ( void )
static

spi configuration.

Parameters
none
Return values
none

Definition at line 83 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c.

Variable Documentation

◆ rx_index [1/2]

uint32_t rx_index = 0

Definition at line 50 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c.

◆ rx_index [2/2]

uint32_t rx_index = 0

Definition at line 50 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c.

◆ spi2_buffer_rx [1/2]

uint8_t spi2_buffer_rx[32]

Definition at line 49 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c.

Referenced by main(), and spi_config().

◆ spi2_buffer_rx [2/2]

uint8_t spi2_buffer_rx[32]

Definition at line 49 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c.

Referenced by spi_config().

◆ spi2_buffer_tx [1/2]

uint8_t spi2_buffer_tx[32]
Initial value:
= {0x51, 0x52, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58,
0x59, 0x5A, 0x5B, 0x5C, 0x5D, 0x5E, 0x5F, 0x60,
0x61, 0x62, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68,
0x69, 0x6A, 0x6B, 0x6C, 0x6D, 0x6E, 0x6F, 0x70}

Definition at line 45 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c.

Referenced by main(), and spi_config().

◆ spi2_buffer_tx [2/2]

uint8_t spi2_buffer_tx[32]
Initial value:
= {0x51, 0x52, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58,
0x59, 0x5A, 0x5B, 0x5C, 0x5D, 0x5E, 0x5F, 0x60,
0x61, 0x62, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68,
0x69, 0x6A, 0x6B, 0x6C, 0x6D, 0x6E, 0x6F, 0x70}

Definition at line 45 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c.

Referenced by spi_config().

◆ spi3_buffer_rx [1/2]

uint8_t spi3_buffer_rx[32]

Definition at line 49 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c.

Referenced by main(), and spi_config().

◆ spi3_buffer_rx [2/2]

uint8_t spi3_buffer_rx[32]

Definition at line 49 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c.

Referenced by spi_config().

◆ spi3_buffer_tx [1/2]

uint8_t spi3_buffer_tx[32]
Initial value:
= {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20}

Definition at line 41 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c.

Referenced by main(), and spi_config().

◆ spi3_buffer_tx [2/2]

uint8_t spi3_buffer_tx[32]
Initial value:
= {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20}

Definition at line 41 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c.

Referenced by spi_config().

◆ spi_init_struct [1/2]

spi_init_type spi_init_struct

Definition at line 40 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c.

Referenced by spi_config().

◆ spi_init_struct [2/2]

spi_init_type spi_init_struct

Definition at line 40 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c.

Referenced by spi_config().

◆ transfer_status1 [1/2]

volatile error_status transfer_status1 = ERROR

Definition at line 51 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c.

Referenced by main().

◆ transfer_status1 [2/2]

volatile error_status transfer_status1 = ERROR

Definition at line 51 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c.

◆ transfer_status2 [1/2]

volatile error_status transfer_status2 = ERROR

Definition at line 51 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c.

Referenced by main().

◆ transfer_status2 [2/2]

volatile error_status transfer_status2 = ERROR

Definition at line 51 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c.

◆ tx_index [1/2]

uint32_t tx_index = 0

Definition at line 50 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c.

◆ tx_index [2/2]

uint32_t tx_index = 0

Definition at line 50 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c.


AT32F435/437 Firmwary Library: SPI_use_jtagpin_hardwarecs_dma

Macros | Functions | Variables
SPI_use_jtagpin_hardwarecs_dma
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | BUFFER_SIZE 32
#define | BUFFER_SIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t bufferlength)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi3_buffer_tx [32]
uint8_t | spi2_buffer_tx [32]
uint8_t | spi3_buffer_rx [32]
uint8_t | spi2_buffer_rx [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR
spi_init_type spi_init_struct
uint8_t | spi3_buffer_tx [32]
uint8_t | spi2_buffer_tx [32]
uint8_t | spi3_buffer_rx [32]
uint8_t | spi2_buffer_rx [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE [1/2]

#define BUFFER_SIZE 32

Definition at line 38 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

◆ BUFFER_SIZE [2/2]

#define BUFFER_SIZE 32

Definition at line 38 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | bufferlength
 | ) |  |

buffer compare function.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
the result of compare

Definition at line 63 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 15

< gpio pins number 3

< gpio pins number 13

< gpio pins number 14

< gpio pins number 0

< gpio pins number 1

< gpio pins number 2

< gpio pins number 4

Definition at line 159 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< dma1 channel2 full data transfer flag

< dma1 channel2 full data transfer flag

Definition at line 225 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c.

◆ spi_config()

static void spi_config ( void )
static

spi configuration.

Parameters
none
Return values
none

Definition at line 83 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c.

Variable Documentation

◆ rx_index [1/2]

uint32_t rx_index = 0

Definition at line 50 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

◆ rx_index [2/2]

uint32_t rx_index = 0

Definition at line 50 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by SPI2_I2S2EXT_IRQHandler(), and SPI3_I2S3EXT_IRQHandler().

◆ spi2_buffer_rx [1/2]

uint8_t spi2_buffer_rx[32]

Definition at line 49 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by main(), and spi_config().

◆ spi2_buffer_rx [2/2]

uint8_t spi2_buffer_rx[32]

Definition at line 49 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by SPI2_I2S2EXT_IRQHandler(), and spi_config().

◆ spi2_buffer_tx [1/2]

uint8_t spi2_buffer_tx[32]
Initial value:
= {0x51, 0x52, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58,
0x59, 0x5A, 0x5B, 0x5C, 0x5D, 0x5E, 0x5F, 0x60,
0x61, 0x62, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68,
0x69, 0x6A, 0x6B, 0x6C, 0x6D, 0x6E, 0x6F, 0x70}

Definition at line 45 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by main(), and spi_config().

◆ spi2_buffer_tx [2/2]

uint8_t spi2_buffer_tx[32]
Initial value:
= {0x51, 0x52, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58,
0x59, 0x5A, 0x5B, 0x5C, 0x5D, 0x5E, 0x5F, 0x60,
0x61, 0x62, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68,
0x69, 0x6A, 0x6B, 0x6C, 0x6D, 0x6E, 0x6F, 0x70}

Definition at line 45 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by SPI2_I2S2EXT_IRQHandler(), and spi_config().

◆ spi3_buffer_rx [1/2]

uint8_t spi3_buffer_rx[32]

Definition at line 49 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by main(), and spi_config().

◆ spi3_buffer_rx [2/2]

uint8_t spi3_buffer_rx[32]

Definition at line 49 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by SPI3_I2S3EXT_IRQHandler(), and spi_config().

◆ spi3_buffer_tx [1/2]

uint8_t spi3_buffer_tx[32]
Initial value:
= {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20}

Definition at line 41 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by main(), and spi_config().

◆ spi3_buffer_tx [2/2]

uint8_t spi3_buffer_tx[32]
Initial value:
= {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20}

Definition at line 41 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by SPI3_I2S3EXT_IRQHandler(), and spi_config().

◆ spi_init_struct [1/2]

spi_init_type spi_init_struct

Definition at line 40 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by spi_config().

◆ spi_init_struct [2/2]

spi_init_type spi_init_struct

Definition at line 40 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by spi_config().

◆ transfer_status1 [1/2]

volatile error_status transfer_status1 = ERROR

Definition at line 51 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by main().

◆ transfer_status1 [2/2]

volatile error_status transfer_status1 = ERROR

Definition at line 51 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

◆ transfer_status2 [1/2]

volatile error_status transfer_status2 = ERROR

Definition at line 51 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by main().

◆ transfer_status2 [2/2]

volatile error_status transfer_status2 = ERROR

Definition at line 51 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

◆ tx_index [1/2]

uint32_t tx_index = 0

Definition at line 50 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

◆ tx_index [2/2]

uint32_t tx_index = 0

Definition at line 50 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by SPI2_I2S2EXT_IRQHandler(), and SPI3_I2S3EXT_IRQHandler().


AT32F435/437 Firmwary Library: SPI_w25q_flash

Modules | Macros | Functions | Variables
SPI_w25q_flash
AT32F435_periph_examples | AT32F437_periph_examples

Modules

SPI_flash_cs_pin_definition
SPI_flash_id_definition
SPI_flash_operation_definition
SPI_flash_exported_functions

Macros

#define | SPI_TRANS_DMA
#define | FLASH_TEST_ADDR 0x1000
#define | BUF_SIZE 0x256
#define | SPI_TRANS_DMA
#define | FLASH_TEST_ADDR 0x1000
#define | BUF_SIZE 0x256

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | tx_data_fill (void)
transfer data fill. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...
void | spiflash_init (void)
spi configuration. More...
void | spiflash_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash More...
void | spiflash_read (uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash More...
void | spiflash_sector_erase (uint32_t erase_addr)
erase a sector data More...
void | spiflash_write_nocheck (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data without check More...
void | spiflash_page_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write a page data More...
void | spi_bytes_write (uint8_t *pbuffer, uint32_t length)
write data continuously More...
void | spi_bytes_read (uint8_t *pbuffer, uint32_t length)
read data continuously More...
void | spiflash_wait_busy (void)
wait program done More...
uint8_t | spiflash_read_sr1 (void)
read sr1 register More...
void | spiflash_write_enable (void)
enable write operation More...
uint16_t | spiflash_read_id (void)
read device id More...
uint8_t | spi_byte_write (uint8_t data)
write a byte to flash More...
uint8_t | spi_byte_read (void)
read a byte to flash More...

Variables

uint8_t | buffer_tx [0x256]
uint8_t | buffer_rx [0x256]
volatile error_status | transfer_status = ERROR
uint8_t | spiflash_sector_buf [SPIF_SECTOR_SIZE]
uint8_t | buffer_tx [0x256]
uint8_t | buffer_rx [0x256]
volatile error_status | transfer_status = ERROR
uint8_t | spiflash_sector_buf [SPIF_SECTOR_SIZE]

Detailed Description

Macro Definition Documentation

◆ BUF_SIZE [1/2]

#define BUF_SIZE 0x256

Definition at line 40 of file project/at_start_f435/examples/spi/w25q_flash/src/main.c.

◆ BUF_SIZE [2/2]

#define BUF_SIZE 0x256

Definition at line 40 of file project/at_start_f437/examples/spi/w25q_flash/src/main.c.

◆ FLASH_TEST_ADDR [1/2]

#define FLASH_TEST_ADDR 0x1000

Definition at line 39 of file project/at_start_f435/examples/spi/w25q_flash/src/main.c.

◆ FLASH_TEST_ADDR [2/2]

#define FLASH_TEST_ADDR 0x1000

Definition at line 39 of file project/at_start_f437/examples/spi/w25q_flash/src/main.c.

◆ SPI_TRANS_DMA [1/2]

#define SPI_TRANS_DMA

Definition at line 42 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPI_TRANS_DMA [2/2]

#define SPI_TRANS_DMA

Definition at line 42 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer compare function.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
the result of compare

Definition at line 69 of file project/at_start_f435/examples/spi/w25q_flash/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f435/examples/spi/w25q_flash/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c.

◆ spi_byte_read()

uint8_t spi_byte_read ( void )

read a byte to flash

Parameters
none
Return values
flash return data

Definition at line 514 of file at_start_f435/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by spiflash_read_id(), and spiflash_read_sr1().

◆ spi_byte_write()

uint8_t spi_byte_write ( uint8_t data )

write a byte to flash

Parameters
data data to write
Return values
flash return data

Definition at line 497 of file at_start_f435/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by spi_byte_read(), spiflash_page_write(), spiflash_read(), spiflash_read_id(), spiflash_read_sr1(), spiflash_sector_erase(), and spiflash_write_enable().

◆ spi_bytes_read()

void spi_bytes_read | ( | uint8_t * | pbuffer,
 |  | uint32_t | length
 | ) |  |

read data continuously

Parameters
pbuffer | buffer to save data
length | buffer length
Return values
none

Definition at line 375 of file at_start_f435/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by spiflash_read().

◆ spi_bytes_write()

void spi_bytes_write | ( | uint8_t * | pbuffer,
 |  | uint32_t | length
 | ) |  |

write data continuously

Parameters
pbuffer | the pointer for data buffer
length | buffer length
Return values
none

Definition at line 307 of file at_start_f435/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by spiflash_page_write().

◆ spiflash_init()

void spiflash_init ( void )

spi configuration.

Parameters
none
Return values
none

Definition at line 45 of file at_start_f435/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by main().

◆ spiflash_page_write()

void spiflash_page_write | ( | uint8_t * | pbuffer,
 |  | uint32_t | write_addr,
 |  | uint32_t | length
 | ) |  |

write a page data

Parameters
pbuffer | the pointer for data buffer
write_addr | the address where the data is written
length | buffer length
Return values
none

Definition at line 276 of file at_start_f435/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by spiflash_write_nocheck().

◆ spiflash_read()

void spiflash_read | ( | uint8_t * | pbuffer,
 |  | uint32_t | read_addr,
 |  | uint32_t | length
 | ) |  |

read data from flash

Parameters
pbuffer | the pointer for data buffer
read_addr | the address where the data is read
length | buffer length
Return values
none

Definition at line 191 of file at_start_f435/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by main(), and spiflash_write().

◆ spiflash_read_id()

uint16_t spiflash_read_id ( void )

read device id

Parameters
none
Return values
device id

Definition at line 478 of file at_start_f435/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by main().

◆ spiflash_read_sr1()

uint8_t spiflash_read_sr1 ( void )

read sr1 register

Parameters
none
Return values
none

Definition at line 451 of file at_start_f435/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by spiflash_wait_busy().

◆ spiflash_sector_erase()

void spiflash_sector_erase ( uint32_t erase_addr )

erase a sector data

Parameters
erase_addr sector address to erase
Return values
none

Definition at line 207 of file at_start_f435/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by main(), and spiflash_write().

◆ spiflash_wait_busy()

void spiflash_wait_busy ( void )

wait program done

Parameters
none
Return values
none

Definition at line 441 of file at_start_f435/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by spiflash_page_write(), and spiflash_sector_erase().

◆ spiflash_write()

void spiflash_write | ( | uint8_t * | pbuffer,
 |  | uint32_t | write_addr,
 |  | uint32_t | length
 | ) |  |

write data to flash

Parameters
pbuffer | the pointer for data buffer
write_addr | the address where the data is written
length | buffer length
Return values
none

Definition at line 103 of file at_start_f435/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by main().

◆ spiflash_write_enable()

void spiflash_write_enable ( void )

enable write operation

Parameters
none
Return values
none

Definition at line 466 of file at_start_f435/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by spiflash_page_write(), and spiflash_sector_erase().

◆ spiflash_write_nocheck()

void spiflash_write_nocheck | ( | uint8_t * | pbuffer,
 |  | uint32_t | write_addr,
 |  | uint32_t | length
 | ) |  |

write data without check

Parameters
pbuffer | the pointer for data buffer
write_addr | the address where the data is written
length | buffer length
Return values
none

Definition at line 228 of file at_start_f435/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by spiflash_write().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c.

◆ tx_data_fill()

void tx_data_fill ( void )

transfer data fill.

Parameters
none
Return values
none

Definition at line 54 of file project/at_start_f435/examples/spi/w25q_flash/src/main.c.

Referenced by main().

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c.

Variable Documentation

◆ buffer_rx [1/2]

uint8_t buffer_rx[0x256]

Definition at line 43 of file project/at_start_f435/examples/spi/w25q_flash/src/main.c.

Referenced by main().

◆ buffer_rx [2/2]

uint8_t buffer_rx[0x256]

Definition at line 43 of file project/at_start_f437/examples/spi/w25q_flash/src/main.c.

◆ buffer_tx [1/2]

uint8_t buffer_tx[0x256]

Definition at line 42 of file project/at_start_f435/examples/spi/w25q_flash/src/main.c.

Referenced by main(), and tx_data_fill().

◆ buffer_tx [2/2]

uint8_t buffer_tx[0x256]

Definition at line 42 of file project/at_start_f437/examples/spi/w25q_flash/src/main.c.

◆ spiflash_sector_buf [1/2]

uint8_t spiflash_sector_buf[SPIF_SECTOR_SIZE]

Definition at line 38 of file at_start_f435/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by spiflash_write().

◆ spiflash_sector_buf [2/2]

uint8_t spiflash_sector_buf[SPIF_SECTOR_SIZE]

Definition at line 38 of file at_start_f437/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by spiflash_write().

◆ transfer_status [1/2]

volatile error_status transfer_status = ERROR

Definition at line 44 of file project/at_start_f435/examples/spi/w25q_flash/src/main.c.

Referenced by main().

◆ transfer_status [2/2]

volatile error_status transfer_status = ERROR

Definition at line 44 of file project/at_start_f437/examples/spi/w25q_flash/src/main.c.


AT32F435/437 Firmwary Library: SPI_flash_cs_pin_definition

Macros
SPI_flash_cs_pin_definition
AT32F435_periph_examples | AT32F437_periph_examples » SPI_w25q_flash

Macros

#define | FLASH_CS_HIGH() gpio_bits_set(GPIOD, GPIO_PINS_0)
#define | FLASH_CS_LOW() gpio_bits_reset(GPIOD, GPIO_PINS_0)
#define | FLASH_CS_HIGH() gpio_bits_set(GPIOD, GPIO_PINS_0)
#define | FLASH_CS_LOW() gpio_bits_reset(GPIOD, GPIO_PINS_0)

Detailed Description

Macro Definition Documentation

◆ FLASH_CS_HIGH [1/2]

#define FLASH_CS_HIGH ( ) gpio_bits_set(GPIOD, GPIO_PINS_0)

Definition at line 48 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ FLASH_CS_HIGH [2/2]

#define FLASH_CS_HIGH ( ) gpio_bits_set(GPIOD, GPIO_PINS_0)

Definition at line 48 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ FLASH_CS_LOW [1/2]

#define FLASH_CS_LOW ( ) gpio_bits_reset(GPIOD, GPIO_PINS_0)

Definition at line 49 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ FLASH_CS_LOW [2/2]

#define FLASH_CS_LOW ( ) gpio_bits_reset(GPIOD, GPIO_PINS_0)

Definition at line 49 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.


AT32F435/437 Firmwary Library: SPI_flash_id_definition

Macros
SPI_flash_id_definition
AT32F435_periph_examples | AT32F437_periph_examples » SPI_w25q_flash

Macros

#define | W25Q80 0xEF13
#define | W25Q16 0xEF14
#define | W25Q32 0xEF15
#define | W25Q64 0xEF16
#define | W25Q128 0xEF17
#define | W25Q80 0xEF13
#define | W25Q16 0xEF14
#define | W25Q32 0xEF15
#define | W25Q64 0xEF16
#define | W25Q128 0xEF17

Detailed Description

Macro Definition Documentation

◆ W25Q128 [1/2]

#define W25Q128 0xEF17

Definition at line 67 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ W25Q128 [2/2]

#define W25Q128 0xEF17

Definition at line 67 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ W25Q16 [1/2]

#define W25Q16 0xEF14

Definition at line 63 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ W25Q16 [2/2]

#define W25Q16 0xEF14

Definition at line 63 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ W25Q32 [1/2]

#define W25Q32 0xEF15

Definition at line 64 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ W25Q32 [2/2]

#define W25Q32 0xEF15

Definition at line 64 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ W25Q64 [1/2]

#define W25Q64 0xEF16

Definition at line 65 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ W25Q64 [2/2]

#define W25Q64 0xEF16

Definition at line 65 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ W25Q80 [1/2]

#define W25Q80 0xEF13

Definition at line 62 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ W25Q80 [2/2]

#define W25Q80 0xEF13

Definition at line 62 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.


AT32F435/437 Firmwary Library: SPI_flash_operation_definition

Macros
SPI_flash_operation_definition
AT32F435_periph_examples | AT32F437_periph_examples » SPI_w25q_flash

Macros

#define | SPIF_CHIP_SIZE 0x1000000
#define | SPIF_SECTOR_SIZE 4096
#define | SPIF_PAGE_SIZE 256
#define | SPIF_WRITEENABLE 0x06
#define | SPIF_WRITEDISABLE 0x04
#define | SPIF_READSTATUSREG1 0x05
#define | SPIF_WRITESTATUSREG1 0x01
#define | SPIF_READSTATUSREG2 0x35
#define | SPIF_WRITESTATUSREG2 0x31
#define | SPIF_READSTATUSREG3 0x15
#define | SPIF_WRITESTATUSREG3 0x11
#define | SPIF_READDATA 0x03
#define | SPIF_FASTREADDATA 0x0B
#define | SPIF_FASTREADDUAL 0x3B
#define | SPIF_PAGEPROGRAM 0x02
#define | SPIF_BLOCKERASE 0xD8
#define | SPIF_SECTORERASE 0x20
#define | SPIF_CHIPERASE 0xC7
#define | SPIF_POWERDOWN 0xB9
#define | SPIF_RELEASEPOWERDOWN 0xAB
#define | SPIF_DEVICEID 0xAB
#define | SPIF_MANUFACTDEVICEID 0x90
#define | SPIF_JEDECDEVICEID 0x9F
#define | FLASH_SPI_DUMMY_BYTE 0xA5
#define | SPIF_CHIP_SIZE 0x1000000
#define | SPIF_SECTOR_SIZE 4096
#define | SPIF_PAGE_SIZE 256
#define | SPIF_WRITEENABLE 0x06
#define | SPIF_WRITEDISABLE 0x04
#define | SPIF_READSTATUSREG1 0x05
#define | SPIF_WRITESTATUSREG1 0x01
#define | SPIF_READSTATUSREG2 0x35
#define | SPIF_WRITESTATUSREG2 0x31
#define | SPIF_READSTATUSREG3 0x15
#define | SPIF_WRITESTATUSREG3 0x11
#define | SPIF_READDATA 0x03
#define | SPIF_FASTREADDATA 0x0B
#define | SPIF_FASTREADDUAL 0x3B
#define | SPIF_PAGEPROGRAM 0x02
#define | SPIF_BLOCKERASE 0xD8
#define | SPIF_SECTORERASE 0x20
#define | SPIF_CHIPERASE 0xC7
#define | SPIF_POWERDOWN 0xB9
#define | SPIF_RELEASEPOWERDOWN 0xAB
#define | SPIF_DEVICEID 0xAB
#define | SPIF_MANUFACTDEVICEID 0x90
#define | SPIF_JEDECDEVICEID 0x9F
#define | FLASH_SPI_DUMMY_BYTE 0xA5

Detailed Description

Macro Definition Documentation

◆ FLASH_SPI_DUMMY_BYTE [1/2]

#define FLASH_SPI_DUMMY_BYTE 0xA5

Definition at line 105 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ FLASH_SPI_DUMMY_BYTE [2/2]

#define FLASH_SPI_DUMMY_BYTE 0xA5

Definition at line 105 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_BLOCKERASE [1/2]

#define SPIF_BLOCKERASE 0xD8

Definition at line 97 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_BLOCKERASE [2/2]

#define SPIF_BLOCKERASE 0xD8

Definition at line 97 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_CHIP_SIZE [1/2]

#define SPIF_CHIP_SIZE 0x1000000

Definition at line 77 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_CHIP_SIZE [2/2]

#define SPIF_CHIP_SIZE 0x1000000

Definition at line 77 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_CHIPERASE [1/2]

#define SPIF_CHIPERASE 0xC7

Definition at line 99 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_CHIPERASE [2/2]

#define SPIF_CHIPERASE 0xC7

Definition at line 99 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_DEVICEID [1/2]

#define SPIF_DEVICEID 0xAB

Definition at line 102 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_DEVICEID [2/2]

#define SPIF_DEVICEID 0xAB

Definition at line 102 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_FASTREADDATA [1/2]

#define SPIF_FASTREADDATA 0x0B

Definition at line 93 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_FASTREADDATA [2/2]

#define SPIF_FASTREADDATA 0x0B

Definition at line 93 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_FASTREADDUAL [1/2]

#define SPIF_FASTREADDUAL 0x3B

Definition at line 94 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_FASTREADDUAL [2/2]

#define SPIF_FASTREADDUAL 0x3B

Definition at line 94 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_JEDECDEVICEID [1/2]

#define SPIF_JEDECDEVICEID 0x9F

Definition at line 104 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_JEDECDEVICEID [2/2]

#define SPIF_JEDECDEVICEID 0x9F

Definition at line 104 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_MANUFACTDEVICEID [1/2]

#define SPIF_MANUFACTDEVICEID 0x90

Definition at line 103 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_MANUFACTDEVICEID [2/2]

#define SPIF_MANUFACTDEVICEID 0x90

Definition at line 103 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_PAGE_SIZE [1/2]

#define SPIF_PAGE_SIZE 256

Definition at line 79 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_PAGE_SIZE [2/2]

#define SPIF_PAGE_SIZE 256

Definition at line 79 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_PAGEPROGRAM [1/2]

#define SPIF_PAGEPROGRAM 0x02

Definition at line 95 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_PAGEPROGRAM [2/2]

#define SPIF_PAGEPROGRAM 0x02

Definition at line 95 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_POWERDOWN [1/2]

#define SPIF_POWERDOWN 0xB9

Definition at line 100 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_POWERDOWN [2/2]

#define SPIF_POWERDOWN 0xB9

Definition at line 100 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_READDATA [1/2]

#define SPIF_READDATA 0x03

Definition at line 92 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_READDATA [2/2]

#define SPIF_READDATA 0x03

Definition at line 92 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_READSTATUSREG1 [1/2]

#define SPIF_READSTATUSREG1 0x05

Definition at line 84 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_READSTATUSREG1 [2/2]

#define SPIF_READSTATUSREG1 0x05

Definition at line 84 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_READSTATUSREG2 [1/2]

#define SPIF_READSTATUSREG2 0x35

Definition at line 87 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_READSTATUSREG2 [2/2]

#define SPIF_READSTATUSREG2 0x35

Definition at line 87 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_READSTATUSREG3 [1/2]

#define SPIF_READSTATUSREG3 0x15

Definition at line 90 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_READSTATUSREG3 [2/2]

#define SPIF_READSTATUSREG3 0x15

Definition at line 90 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_RELEASEPOWERDOWN [1/2]

#define SPIF_RELEASEPOWERDOWN 0xAB

Definition at line 101 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_RELEASEPOWERDOWN [2/2]

#define SPIF_RELEASEPOWERDOWN 0xAB

Definition at line 101 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_SECTOR_SIZE [1/2]

#define SPIF_SECTOR_SIZE 4096

Definition at line 78 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_SECTOR_SIZE [2/2]

#define SPIF_SECTOR_SIZE 4096

Definition at line 78 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_SECTORERASE [1/2]

#define SPIF_SECTORERASE 0x20

Definition at line 98 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_SECTORERASE [2/2]

#define SPIF_SECTORERASE 0x20

Definition at line 98 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_WRITEDISABLE [1/2]

#define SPIF_WRITEDISABLE 0x04

Definition at line 82 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_WRITEDISABLE [2/2]

#define SPIF_WRITEDISABLE 0x04

Definition at line 82 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_WRITEENABLE [1/2]

#define SPIF_WRITEENABLE 0x06

Definition at line 81 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_WRITEENABLE [2/2]

#define SPIF_WRITEENABLE 0x06

Definition at line 81 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_WRITESTATUSREG1 [1/2]

#define SPIF_WRITESTATUSREG1 0x01

Definition at line 85 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_WRITESTATUSREG1 [2/2]

#define SPIF_WRITESTATUSREG1 0x01

Definition at line 85 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_WRITESTATUSREG2 [1/2]

#define SPIF_WRITESTATUSREG2 0x31

Definition at line 88 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_WRITESTATUSREG2 [2/2]

#define SPIF_WRITESTATUSREG2 0x31

Definition at line 88 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_WRITESTATUSREG3 [1/2]

#define SPIF_WRITESTATUSREG3 0x11

Definition at line 91 of file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.

◆ SPIF_WRITESTATUSREG3 [2/2]

#define SPIF_WRITESTATUSREG3 0x11

Definition at line 91 of file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.


AT32F435/437 Firmwary Library: SPI_flash_exported_functions

Functions
SPI_flash_exported_functions
AT32F435_periph_examples | AT32F437_periph_examples » SPI_w25q_flash

Functions

void | spiflash_init (void)
spi configuration. More...
void | spiflash_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash More...
void | spiflash_read (uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash More...
void | spiflash_sector_erase (uint32_t erase_addr)
erase a sector data More...
void | spiflash_write_nocheck (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data without check More...
void | spiflash_page_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write a page data More...
void | spi_bytes_write (uint8_t *pbuffer, uint32_t length)
write data continuously More...
void | spi_bytes_read (uint8_t *pbuffer, uint32_t length)
read data continuously More...
void | spiflash_wait_busy (void)
wait program done More...
uint8_t | spiflash_read_sr1 (void)
read sr1 register More...
void | spiflash_write_enable (void)
enable write operation More...
uint16_t | spiflash_read_id (void)
read device id More...
uint8_t | spi_byte_write (uint8_t data)
write a byte to flash More...
uint8_t | spi_byte_read (void)
read a byte to flash More...

Detailed Description

Function Documentation

◆ spi_byte_read()

uint8_t spi_byte_read ( void )

read a byte to flash

Parameters
none
Return values
flash return data

Definition at line 514 of file at_start_f437/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by spiflash_read_id(), and spiflash_read_sr1().

◆ spi_byte_write()

uint8_t spi_byte_write ( uint8_t data )

write a byte to flash

Parameters
data data to write
Return values
flash return data

Definition at line 497 of file at_start_f437/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by spi_byte_read(), spiflash_page_write(), spiflash_read(), spiflash_read_id(), spiflash_read_sr1(), spiflash_sector_erase(), and spiflash_write_enable().

◆ spi_bytes_read()

void spi_bytes_read | ( | uint8_t * | pbuffer,
 |  | uint32_t | length
 | ) |  |

read data continuously

Parameters
pbuffer | buffer to save data
length | buffer length
Return values
none

Definition at line 375 of file at_start_f437/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by spiflash_read().

◆ spi_bytes_write()

void spi_bytes_write | ( | uint8_t * | pbuffer,
 |  | uint32_t | length
 | ) |  |

write data continuously

Parameters
pbuffer | the pointer for data buffer
length | buffer length
Return values
none

Definition at line 307 of file at_start_f437/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by spiflash_page_write().

◆ spiflash_init()

void spiflash_init ( void )

spi configuration.

Parameters
none
Return values
none

Definition at line 45 of file at_start_f437/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by main().

◆ spiflash_page_write()

void spiflash_page_write | ( | uint8_t * | pbuffer,
 |  | uint32_t | write_addr,
 |  | uint32_t | length
 | ) |  |

write a page data

Parameters
pbuffer | the pointer for data buffer
write_addr | the address where the data is written
length | buffer length
Return values
none

Definition at line 276 of file at_start_f437/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by spiflash_write_nocheck().

◆ spiflash_read()

void spiflash_read | ( | uint8_t * | pbuffer,
 |  | uint32_t | read_addr,
 |  | uint32_t | length
 | ) |  |

read data from flash

Parameters
pbuffer | the pointer for data buffer
read_addr | the address where the data is read
length | buffer length
Return values
none

Definition at line 191 of file at_start_f437/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by main(), and spiflash_write().

◆ spiflash_read_id()

uint16_t spiflash_read_id ( void )

read device id

Parameters
none
Return values
device id

Definition at line 478 of file at_start_f437/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by main().

◆ spiflash_read_sr1()

uint8_t spiflash_read_sr1 ( void )

read sr1 register

Parameters
none
Return values
none

Definition at line 451 of file at_start_f437/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by spiflash_wait_busy().

◆ spiflash_sector_erase()

void spiflash_sector_erase ( uint32_t erase_addr )

erase a sector data

Parameters
erase_addr sector address to erase
Return values
none

Definition at line 207 of file at_start_f437/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by main(), and spiflash_write().

◆ spiflash_wait_busy()

void spiflash_wait_busy ( void )

wait program done

Parameters
none
Return values
none

Definition at line 441 of file at_start_f437/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by spiflash_page_write(), and spiflash_sector_erase().

◆ spiflash_write()

void spiflash_write | ( | uint8_t * | pbuffer,
 |  | uint32_t | write_addr,
 |  | uint32_t | length
 | ) |  |

write data to flash

Parameters
pbuffer | the pointer for data buffer
write_addr | the address where the data is written
length | buffer length
Return values
none

Definition at line 103 of file at_start_f437/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by main().

◆ spiflash_write_enable()

void spiflash_write_enable ( void )

enable write operation

Parameters
none
Return values
none

Definition at line 466 of file at_start_f437/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by spiflash_page_write(), and spiflash_sector_erase().

◆ spiflash_write_nocheck()

void spiflash_write_nocheck | ( | uint8_t * | pbuffer,
 |  | uint32_t | write_addr,
 |  | uint32_t | length
 | ) |  |

write data without check

Parameters
pbuffer | the pointer for data buffer
write_addr | the address where the data is written
length | buffer length
Return values
none

Definition at line 228 of file at_start_f437/examples/spi/w25q_flash/src/spi_flash.c.

Referenced by spiflash_write().


AT32F435/437 Firmwary Library: SRAM_extend_sram

Functions
SRAM_extend_sram
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | extend_sram (void)
to extend sram size More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c.

◆ extend_sram()

void extend_sram ( void )

to extend sram size

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f435/examples/sram/extend_sram/src/main.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 75 of file project/at_start_f435/examples/sram/extend_sram/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: TMR_6_steps

Functions | Variables
TMR_6_steps
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | SysTick_Configuration (void)
configures the systick. More...
int | main (void)
main function. More...
void | TMR1_TRG_HALL_TMR11_IRQHandler (void)
this function handles tmr1 trigger and hall interrupts requests. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_brkdt_config_type | tmr_brkdt_config_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
__IO uint32_t | step = 1
gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_brkdt_config_type | tmr_brkdt_config_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
__IO uint32_t | step = 1

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 9

< gpio pins number 10

< gpio pins number 13

< gpio pins number 14

< gpio pins number 15

< gpio pins number 12

< tmr interrupt hall

< gpio pins number 8

< gpio pins number 9

< gpio pins number 10

< gpio pins number 13

< gpio pins number 14

< gpio pins number 15

< gpio pins number 12

< tmr interrupt hall

Definition at line 51 of file project/at_start_f435/examples/tmr/6_steps/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c.

◆ SysTick_Configuration()

void SysTick_Configuration ( void )

configures the systick.

Parameters
none
Return values
none

Definition at line 187 of file project/at_start_f435/examples/tmr/6_steps/src/main.c.

Referenced by main().

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c.

◆ TMR1_TRG_HALL_TMR11_IRQHandler()

void TMR1_TRG_HALL_TMR11_IRQHandler ( void )

this function handles tmr1 trigger and hall interrupts requests.

Parameters
none
Return values
none

< tmr flag hall

< tmr flag hall

Definition at line 204 of file project/at_start_f435/examples/tmr/6_steps/src/main.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c.

Variable Documentation

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 41 of file project/at_start_f435/examples/tmr/6_steps/src/main.c.

Referenced by main(), and SysTick_Configuration().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 41 of file project/at_start_f437/examples/tmr/6_steps/src/main.c.

◆ gpio_init_struct [1/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f435/examples/tmr/6_steps/src/main.c.

Referenced by main().

◆ gpio_init_struct [2/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f437/examples/tmr/6_steps/src/main.c.

◆ step [1/2]

__IO uint32_t step = 1

Definition at line 43 of file project/at_start_f435/examples/tmr/6_steps/src/main.c.

Referenced by TMR1_TRG_HALL_TMR11_IRQHandler().

◆ step [2/2]

__IO uint32_t step = 1

Definition at line 43 of file project/at_start_f437/examples/tmr/6_steps/src/main.c.

◆ tmr_brkdt_config_struct [1/2]

tmr_brkdt_config_type tmr_brkdt_config_struct = {0}

Definition at line 40 of file project/at_start_f435/examples/tmr/6_steps/src/main.c.

Referenced by main().

◆ tmr_brkdt_config_struct [2/2]

tmr_brkdt_config_type tmr_brkdt_config_struct = {0}

Definition at line 40 of file project/at_start_f437/examples/tmr/6_steps/src/main.c.

◆ tmr_output_struct [1/2]

tmr_output_config_type tmr_output_struct

Definition at line 39 of file project/at_start_f435/examples/tmr/6_steps/src/main.c.

Referenced by main().

◆ tmr_output_struct [2/2]

tmr_output_config_type tmr_output_struct

Definition at line 39 of file project/at_start_f437/examples/tmr/6_steps/src/main.c.


AT32F435/437 Firmwary Library: TMR_7_pwm_output

Functions | Variables
TMR_7_pwm_output
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timerperiod = 0
uint16_t | channel1pulse = 0
uint16_t | channel2pulse = 0
uint16_t | channel3pulse = 0
uint16_t | channel4pulse = 0
gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timerperiod = 0
uint16_t | channel1pulse = 0
uint16_t | channel2pulse = 0
uint16_t | channel3pulse = 0
uint16_t | channel4pulse = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 9

< gpio pins number 10

< gpio pins number 11

< gpio pins number 13

< gpio pins number 14

< gpio pins number 15

< gpio pins number 8

< gpio pins number 9

< gpio pins number 10

< gpio pins number 11

< gpio pins number 13

< gpio pins number 14

< gpio pins number 15

Definition at line 50 of file project/at_start_f435/examples/tmr/7_pwm_output/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c.

Variable Documentation

◆ channel1pulse [1/2]

uint16_t channel1pulse = 0

Definition at line 43 of file project/at_start_f435/examples/tmr/7_pwm_output/src/main.c.

Referenced by main().

◆ channel1pulse [2/2]

uint16_t channel1pulse = 0

Definition at line 43 of file project/at_start_f437/examples/tmr/7_pwm_output/src/main.c.

◆ channel2pulse [1/2]

uint16_t channel2pulse = 0

Definition at line 43 of file project/at_start_f435/examples/tmr/7_pwm_output/src/main.c.

Referenced by main().

◆ channel2pulse [2/2]

uint16_t channel2pulse = 0

Definition at line 43 of file project/at_start_f437/examples/tmr/7_pwm_output/src/main.c.

◆ channel3pulse [1/2]

uint16_t channel3pulse = 0

Definition at line 43 of file project/at_start_f435/examples/tmr/7_pwm_output/src/main.c.

Referenced by main().

◆ channel3pulse [2/2]

uint16_t channel3pulse = 0

Definition at line 43 of file project/at_start_f437/examples/tmr/7_pwm_output/src/main.c.

◆ channel4pulse [1/2]

uint16_t channel4pulse = 0

Definition at line 43 of file project/at_start_f435/examples/tmr/7_pwm_output/src/main.c.

Referenced by main().

◆ channel4pulse [2/2]

uint16_t channel4pulse = 0

Definition at line 43 of file project/at_start_f437/examples/tmr/7_pwm_output/src/main.c.

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 40 of file project/at_start_f435/examples/tmr/7_pwm_output/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 40 of file project/at_start_f437/examples/tmr/7_pwm_output/src/main.c.

◆ gpio_init_struct [1/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f435/examples/tmr/7_pwm_output/src/main.c.

Referenced by main().

◆ gpio_init_struct [2/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f437/examples/tmr/7_pwm_output/src/main.c.

◆ timerperiod [1/2]

uint16_t timerperiod = 0

Definition at line 42 of file project/at_start_f435/examples/tmr/7_pwm_output/src/main.c.

Referenced by main().

◆ timerperiod [2/2]

uint16_t timerperiod = 0

Definition at line 42 of file project/at_start_f437/examples/tmr/7_pwm_output/src/main.c.

◆ tmr_output_struct [1/2]

tmr_output_config_type tmr_output_struct

Definition at line 39 of file project/at_start_f435/examples/tmr/7_pwm_output/src/main.c.

Referenced by main().

◆ tmr_output_struct [2/2]

tmr_output_config_type tmr_output_struct

Definition at line 39 of file project/at_start_f437/examples/tmr/7_pwm_output/src/main.c.


AT32F435/437 Firmwary Library: TMR_cascade_synchro

Functions | Variables
TMR_cascade_synchro
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timerperiod = 0
gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timerperiod = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 0

< gpio pins number 6

< gpio pins number 6

< gpio pins number 0

< gpio pins number 6

Definition at line 49 of file project/at_start_f435/examples/tmr/cascade_synchro/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c.

Variable Documentation

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 40 of file project/at_start_f435/examples/tmr/cascade_synchro/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 40 of file project/at_start_f437/examples/tmr/cascade_synchro/src/main.c.

◆ gpio_init_struct [1/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f435/examples/tmr/cascade_synchro/src/main.c.

Referenced by main().

◆ gpio_init_struct [2/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f437/examples/tmr/cascade_synchro/src/main.c.

◆ timerperiod [1/2]

uint16_t timerperiod = 0

Definition at line 42 of file project/at_start_f435/examples/tmr/cascade_synchro/src/main.c.

Referenced by main().

◆ timerperiod [2/2]

uint16_t timerperiod = 0

Definition at line 42 of file project/at_start_f437/examples/tmr/cascade_synchro/src/main.c.

◆ tmr_output_struct [1/2]

tmr_output_config_type tmr_output_struct

Definition at line 39 of file project/at_start_f435/examples/tmr/cascade_synchro/src/main.c.

Referenced by main().

◆ tmr_output_struct [2/2]

tmr_output_config_type tmr_output_struct

Definition at line 39 of file project/at_start_f437/examples/tmr/cascade_synchro/src/main.c.


AT32F435/437 Firmwary Library: TMR_complementary_signals

Functions | Variables
TMR_complementary_signals
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_brkdt_config_type | tmr_brkdt_config_struct = {0}
uint16_t | timerperiod = 0
uint16_t | channel1pulse = 0
uint16_t | channel2pulse = 0
uint16_t | channel3pulse = 0
gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_brkdt_config_type | tmr_brkdt_config_struct = {0}
uint16_t | timerperiod = 0
uint16_t | channel1pulse = 0
uint16_t | channel2pulse = 0
uint16_t | channel3pulse = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 9

< gpio pins number 10

< gpio pins number 13

< gpio pins number 14

< gpio pins number 15

< gpio pins number 12

< gpio pins number 8

< gpio pins number 9

< gpio pins number 10

< gpio pins number 13

< gpio pins number 14

< gpio pins number 15

< gpio pins number 12

Definition at line 51 of file project/at_start_f435/examples/tmr/complementary_signals/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c.

Variable Documentation

◆ channel1pulse [1/2]

uint16_t channel1pulse = 0

Definition at line 44 of file project/at_start_f435/examples/tmr/complementary_signals/src/main.c.

Referenced by main().

◆ channel1pulse [2/2]

uint16_t channel1pulse = 0

Definition at line 44 of file project/at_start_f437/examples/tmr/complementary_signals/src/main.c.

◆ channel2pulse [1/2]

uint16_t channel2pulse = 0

Definition at line 44 of file project/at_start_f435/examples/tmr/complementary_signals/src/main.c.

Referenced by main().

◆ channel2pulse [2/2]

uint16_t channel2pulse = 0

Definition at line 44 of file project/at_start_f437/examples/tmr/complementary_signals/src/main.c.

◆ channel3pulse [1/2]

uint16_t channel3pulse = 0

Definition at line 44 of file project/at_start_f435/examples/tmr/complementary_signals/src/main.c.

Referenced by main().

◆ channel3pulse [2/2]

uint16_t channel3pulse = 0

Definition at line 44 of file project/at_start_f437/examples/tmr/complementary_signals/src/main.c.

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 40 of file project/at_start_f435/examples/tmr/complementary_signals/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 40 of file project/at_start_f437/examples/tmr/complementary_signals/src/main.c.

◆ gpio_init_struct [1/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f435/examples/tmr/complementary_signals/src/main.c.

Referenced by main().

◆ gpio_init_struct [2/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f437/examples/tmr/complementary_signals/src/main.c.

◆ timerperiod [1/2]

uint16_t timerperiod = 0

Definition at line 43 of file project/at_start_f435/examples/tmr/complementary_signals/src/main.c.

Referenced by main().

◆ timerperiod [2/2]

uint16_t timerperiod = 0

Definition at line 43 of file project/at_start_f437/examples/tmr/complementary_signals/src/main.c.

◆ tmr_brkdt_config_struct [1/2]

tmr_brkdt_config_type tmr_brkdt_config_struct = {0}

Definition at line 41 of file project/at_start_f435/examples/tmr/complementary_signals/src/main.c.

Referenced by main().

◆ tmr_brkdt_config_struct [2/2]

tmr_brkdt_config_type tmr_brkdt_config_struct = {0}

Definition at line 41 of file project/at_start_f437/examples/tmr/complementary_signals/src/main.c.

◆ tmr_output_struct [1/2]

tmr_output_config_type tmr_output_struct

Definition at line 39 of file project/at_start_f435/examples/tmr/complementary_signals/src/main.c.

Referenced by main().

◆ tmr_output_struct [2/2]

tmr_output_config_type tmr_output_struct

Definition at line 39 of file project/at_start_f437/examples/tmr/complementary_signals/src/main.c.


AT32F435/437 Firmwary Library: TMR_dma

Functions | Variables
TMR_dma
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
dma_init_type dma_init_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timerperiod = 0
uint16_t | src_buffer [3] = {0, 0, 0}
gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
dma_init_type dma_init_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timerperiod = 0
uint16_t | src_buffer [3] = {0, 0, 0}

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 10

< gpio pins number 15

< gpio pins number 10

< gpio pins number 15

Definition at line 51 of file project/at_start_f435/examples/tmr/dma/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c.

Variable Documentation

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 41 of file project/at_start_f435/examples/tmr/dma/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 41 of file project/at_start_f437/examples/tmr/dma/src/main.c.

◆ dma_init_struct [1/2]

dma_init_type dma_init_struct

Definition at line 40 of file project/at_start_f435/examples/tmr/dma/src/main.c.

Referenced by main().

◆ dma_init_struct [2/2]

dma_init_type dma_init_struct

Definition at line 40 of file project/at_start_f437/examples/tmr/dma/src/main.c.

◆ gpio_init_struct [1/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f435/examples/tmr/dma/src/main.c.

Referenced by main().

◆ gpio_init_struct [2/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f437/examples/tmr/dma/src/main.c.

◆ src_buffer [1/2]

uint16_t src_buffer[3] = {0, 0, 0}

Definition at line 44 of file project/at_start_f435/examples/tmr/dma/src/main.c.

Referenced by main().

◆ src_buffer [2/2]

uint16_t src_buffer[3] = {0, 0, 0}

Definition at line 44 of file project/at_start_f437/examples/tmr/dma/src/main.c.

◆ timerperiod [1/2]

uint16_t timerperiod = 0

Definition at line 43 of file project/at_start_f435/examples/tmr/dma/src/main.c.

Referenced by main().

◆ timerperiod [2/2]

uint16_t timerperiod = 0

Definition at line 43 of file project/at_start_f437/examples/tmr/dma/src/main.c.

◆ tmr_output_struct [1/2]

tmr_output_config_type tmr_output_struct

Definition at line 39 of file project/at_start_f435/examples/tmr/dma/src/main.c.

Referenced by main().

◆ tmr_output_struct [2/2]

tmr_output_config_type tmr_output_struct

Definition at line 39 of file project/at_start_f437/examples/tmr/dma/src/main.c.


AT32F435/437 Firmwary Library: TMR_dma_burst

Functions | Variables
TMR_dma_burst
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
dma_init_type dma_init_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timerperiod = 0
uint16_t | src_buffer [3] = {0x0FFF, 0x0000, 0x0555}
gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
dma_init_type dma_init_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timerperiod = 0
uint16_t | src_buffer [3] = {0x0FFF, 0x0000, 0x0555}

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 8

Definition at line 51 of file project/at_start_f435/examples/tmr/dma_burst/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c.

Variable Documentation

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 41 of file project/at_start_f435/examples/tmr/dma_burst/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 41 of file project/at_start_f437/examples/tmr/dma_burst/src/main.c.

◆ dma_init_struct [1/2]

dma_init_type dma_init_struct

Definition at line 40 of file project/at_start_f435/examples/tmr/dma_burst/src/main.c.

Referenced by main().

◆ dma_init_struct [2/2]

dma_init_type dma_init_struct

Definition at line 40 of file project/at_start_f437/examples/tmr/dma_burst/src/main.c.

◆ gpio_init_struct [1/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f435/examples/tmr/dma_burst/src/main.c.

Referenced by main().

◆ gpio_init_struct [2/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f437/examples/tmr/dma_burst/src/main.c.

◆ src_buffer [1/2]

uint16_t src_buffer[3] = {0x0FFF, 0x0000, 0x0555}

Definition at line 44 of file project/at_start_f435/examples/tmr/dma_burst/src/main.c.

Referenced by main().

◆ src_buffer [2/2]

uint16_t src_buffer[3] = {0x0FFF, 0x0000, 0x0555}

Definition at line 44 of file project/at_start_f437/examples/tmr/dma_burst/src/main.c.

◆ timerperiod [1/2]

uint16_t timerperiod = 0

Definition at line 43 of file project/at_start_f435/examples/tmr/dma_burst/src/main.c.

◆ timerperiod [2/2]

uint16_t timerperiod = 0

Definition at line 43 of file project/at_start_f437/examples/tmr/dma_burst/src/main.c.

◆ tmr_output_struct [1/2]

tmr_output_config_type tmr_output_struct

Definition at line 39 of file project/at_start_f435/examples/tmr/dma_burst/src/main.c.

Referenced by main().

◆ tmr_output_struct [2/2]

tmr_output_config_type tmr_output_struct

Definition at line 39 of file project/at_start_f437/examples/tmr/dma_burst/src/main.c.


AT32F435/437 Firmwary Library: TMR_encoder_tmr2

Functions | Variables
TMR_encoder_tmr2
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint32_t | counter
gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint32_t | counter

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 0

< gpio pins number 1

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

< gpio pins number 0

< gpio pins number 1

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

Definition at line 48 of file project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c.

Variable Documentation

◆ counter [1/2]

uint32_t counter

Definition at line 42 of file project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c.

Referenced by main().

◆ counter [2/2]

uint32_t counter

Definition at line 42 of file project/at_start_f437/examples/tmr/encoder_tmr2/src/main.c.

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f437/examples/tmr/encoder_tmr2/src/main.c.

◆ gpio_init_struct [1/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c.

Referenced by main().

◆ gpio_init_struct [2/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f437/examples/tmr/encoder_tmr2/src/main.c.


AT32F435/437 Firmwary Library: TMR_external_clock

Functions | Variables
TMR_external_clock
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_input_config_type tmr_input_config_struct
uint16_t | timerperiod = 0
gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_input_config_type tmr_input_config_struct
uint16_t | timerperiod = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 0

< gpio pins number 7

< gpio pins number 0

< gpio pins number 7

Definition at line 49 of file project/at_start_f435/examples/tmr/external_clock/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c.

Variable Documentation

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f435/examples/tmr/external_clock/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f437/examples/tmr/external_clock/src/main.c.

◆ gpio_init_struct [1/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f435/examples/tmr/external_clock/src/main.c.

Referenced by main().

◆ gpio_init_struct [2/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f437/examples/tmr/external_clock/src/main.c.

◆ timerperiod [1/2]

uint16_t timerperiod = 0

Definition at line 42 of file project/at_start_f435/examples/tmr/external_clock/src/main.c.

Referenced by main().

◆ timerperiod [2/2]

uint16_t timerperiod = 0

Definition at line 42 of file project/at_start_f437/examples/tmr/external_clock/src/main.c.

◆ tmr_input_config_struct [1/2]

tmr_input_config_type tmr_input_config_struct

Definition at line 41 of file project/at_start_f435/examples/tmr/external_clock/src/main.c.

Referenced by lick_frequency_get(), and main().

◆ tmr_input_config_struct [2/2]

tmr_input_config_type tmr_input_config_struct

Definition at line 41 of file project/at_start_f437/examples/tmr/external_clock/src/main.c.

◆ tmr_output_struct [1/2]

tmr_output_config_type tmr_output_struct

Definition at line 40 of file project/at_start_f435/examples/tmr/external_clock/src/main.c.

Referenced by main().

◆ tmr_output_struct [2/2]

tmr_output_config_type tmr_output_struct

Definition at line 40 of file project/at_start_f437/examples/tmr/external_clock/src/main.c.


AT32F435/437 Firmwary Library: TMR_hall_xor_tmr2

Functions | Variables
TMR_hall_xor_tmr2
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...
void | TMR2_GLOBAL_IRQHandler (void)
this function handles TMR2 trigger exception. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_input_config_type tmr_input_config_struct
gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_input_config_type tmr_input_config_struct

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 0

< gpio pins number 1

< gpio pins number 2

< gpio pins number 3

< gpio pins number 6

< gpio pins number 7

< gpio pins number 8

< tmr interrupt trigger

< gpio pins number 3

< gpio pins number 6

< gpio pins number 7

< gpio pins number 3

< gpio pins number 6

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

< gpio pins number 2

< gpio pins number 3

< gpio pins number 6

< gpio pins number 7

< gpio pins number 8

< tmr interrupt trigger

< gpio pins number 3

< gpio pins number 6

< gpio pins number 7

< gpio pins number 3

< gpio pins number 6

< gpio pins number 7

Definition at line 48 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c.

◆ TMR2_GLOBAL_IRQHandler()

void TMR2_GLOBAL_IRQHandler ( void )

this function handles TMR2 trigger exception.

Parameters
none
Return values
none

< tmr flag trigger

< gpio pins number 8

< tmr flag trigger

< tmr flag trigger

< gpio pins number 8

< tmr flag trigger

Definition at line 143 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c.

Variable Documentation

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/src/main.c.

◆ gpio_init_struct [1/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c.

Referenced by main().

◆ gpio_init_struct [2/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/src/main.c.

◆ tmr_input_config_struct [1/2]

tmr_input_config_type tmr_input_config_struct

Definition at line 41 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c.

Referenced by main().

◆ tmr_input_config_struct [2/2]

tmr_input_config_type tmr_input_config_struct

Definition at line 41 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/src/main.c.

◆ tmr_output_struct [1/2]

tmr_output_config_type tmr_output_struct

Definition at line 40 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c.

◆ tmr_output_struct [2/2]

tmr_output_config_type tmr_output_struct

Definition at line 40 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/src/main.c.


AT32F435/437 Firmwary Library: TMR_hang_mode

Functions | Variables
TMR_hang_mode
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_input_config_type tmr_input_config_struct
uint16_t | timerperiod = 0
gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_input_config_type tmr_input_config_struct
uint16_t | timerperiod = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 9

< gpio pins number 8

< gpio pins number 9

Definition at line 49 of file project/at_start_f435/examples/tmr/hang_mode/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c.

Variable Documentation

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f435/examples/tmr/hang_mode/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f437/examples/tmr/hang_mode/src/main.c.

◆ gpio_init_struct [1/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f435/examples/tmr/hang_mode/src/main.c.

Referenced by main().

◆ gpio_init_struct [2/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f437/examples/tmr/hang_mode/src/main.c.

◆ timerperiod [1/2]

uint16_t timerperiod = 0

Definition at line 42 of file project/at_start_f435/examples/tmr/hang_mode/src/main.c.

Referenced by main().

◆ timerperiod [2/2]

uint16_t timerperiod = 0

Definition at line 42 of file project/at_start_f437/examples/tmr/hang_mode/src/main.c.

◆ tmr_input_config_struct [1/2]

tmr_input_config_type tmr_input_config_struct

Definition at line 41 of file project/at_start_f435/examples/tmr/hang_mode/src/main.c.

Referenced by main().

◆ tmr_input_config_struct [2/2]

tmr_input_config_type tmr_input_config_struct

Definition at line 41 of file project/at_start_f437/examples/tmr/hang_mode/src/main.c.

◆ tmr_output_struct [1/2]

tmr_output_config_type tmr_output_struct

Definition at line 40 of file project/at_start_f435/examples/tmr/hang_mode/src/main.c.

Referenced by main().

◆ tmr_output_struct [2/2]

tmr_output_config_type tmr_output_struct

Definition at line 40 of file project/at_start_f437/examples/tmr/hang_mode/src/main.c.


AT32F435/437 Firmwary Library: TMR_input_capture

Functions | Variables
TMR_input_capture
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | delay (uint32_t time)
delay function More...
void | uart_init (uint32_t bound)
initialize print usart More...
int | main (void)
main function. More...
void | TMR3_GLOBAL_IRQHandler (void)
this function handles tmr3 trigger exception. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_input_config_type tmr_input_config_struct
__IO uint32_t | tmr3freq = 0
__IO uint32_t | sys_counter = 0
__IO uint16_t | capturenumber = 0
__IO uint16_t | ic3readvalue1 = 0
__IO uint16_t | ic3readvalue2 = 0
__IO uint32_t | capture = 0
gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_input_config_type tmr_input_config_struct
__IO uint32_t | tmr3freq = 0
__IO uint32_t | sys_counter = 0
__IO uint16_t | capturenumber = 0
__IO uint16_t | ic3readvalue1 = 0
__IO uint16_t | ic3readvalue2 = 0
__IO uint32_t | capture = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c.

◆ delay()

void delay ( uint32_t time )

delay function

Parameters
time:number of time to delay
Return values
none

Definition at line 120 of file project/at_start_f435/examples/tmr/input_capture/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 7

< tmr interrupt channel 2

< gpio pins number 7

< tmr interrupt channel 2

Definition at line 54 of file project/at_start_f435/examples/tmr/input_capture/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c.

◆ TMR3_GLOBAL_IRQHandler()

void TMR3_GLOBAL_IRQHandler ( void )

this function handles tmr3 trigger exception.

this function handles tmr3 global interrupt request.

Parameters
none
Return values
none

< tmr flag channel 2

< tmr flag channel 2

< tmr flag channel 2

< tmr flag channel 2

Definition at line 132 of file project/at_start_f435/examples/tmr/input_capture/src/main.c.

◆ uart_init()

void uart_init ( uint32_t baudrate )

initialize print usart

Parameters
bound uart baudrate
Return values
none

initialize print usart

Parameters
none
Return values
none

< gpio pins number 9

< gpio pins number 10

< gpio pins number 9

< gpio pins number 10

Definition at line 137 of file project/at_start_f435/examples/edma/link_list_mode/src/main.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c.

Variable Documentation

◆ capture [1/2]

__IO uint32_t capture = 0

Definition at line 47 of file project/at_start_f435/examples/tmr/input_capture/src/main.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ capture [2/2]

__IO uint32_t capture = 0

Definition at line 47 of file project/at_start_f437/examples/tmr/input_capture/src/main.c.

◆ capturenumber [1/2]

__IO uint16_t capturenumber = 0

Definition at line 45 of file project/at_start_f435/examples/tmr/input_capture/src/main.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ capturenumber [2/2]

__IO uint16_t capturenumber = 0

Definition at line 45 of file project/at_start_f437/examples/tmr/input_capture/src/main.c.

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f435/examples/tmr/input_capture/src/main.c.

Referenced by main(), and TMR3_GLOBAL_IRQHandler().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f437/examples/tmr/input_capture/src/main.c.

◆ gpio_init_struct [1/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f435/examples/tmr/input_capture/src/main.c.

Referenced by main().

◆ gpio_init_struct [2/2]

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f437/examples/tmr/input_capture/src/main.c.

◆ ic3readvalue1 [1/2]

__IO uint16_t ic3readvalue1 = 0

Definition at line 46 of file project/at_start_f435/examples/tmr/input_capture/src/main.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ ic3readvalue1 [2/2]

__IO uint16_t ic3readvalue1 = 0

Definition at line 46 of file project/at_start_f437/examples/tmr/input_capture/src/main.c.

◆ ic3readvalue2 [1/2]

__IO uint16_t ic3readvalue2 = 0

Definition at line 46 of file project/at_start_f435/examples/tmr/input_capture/src/main.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ ic3readvalue2 [2/2]

__IO uint16_t ic3readvalue2 = 0

Definition at line 46 of file project/at_start_f437/examples/tmr/input_capture/src/main.c.

◆ sys_counter [1/2]

__IO uint32_t sys_counter = 0

Definition at line 44 of file project/at_start_f435/examples/tmr/input_capture/src/main.c.

◆ sys_counter [2/2]

__IO uint32_t sys_counter = 0

Definition at line 44 of file project/at_start_f437/examples/tmr/input_capture/src/main.c.

◆ tmr3freq [1/2]

__IO uint32_t tmr3freq = 0

Definition at line 43 of file project/at_start_f435/examples/tmr/input_capture/src/main.c.

Referenced by main(), and TMR3_GLOBAL_IRQHandler().

◆ tmr3freq [2/2]

__IO uint32_t tmr3freq = 0

Definition at line 43 of file project/at_start_f437/examples/tmr/input_capture/src/main.c.

◆ tmr_input_config_struct [1/2]

tmr_input_config_type tmr_input_config_struct

Definition at line 40 of file project/at_start_f435/examples/tmr/input_capture/src/main.c.

Referenced by main().

◆ tmr_input_config_struct [2/2]

tmr_input_config_type tmr_input_config_struct

Definition at line 40 of file project/at_start_f437/examples/tmr/input_capture/src/main.c.


AT32F435/437 Firmwary Library: TMR_oc_high

Functions | Variables
TMR_oc_high
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR2_GLOBAL_IRQHandler (void)
this function handles tmr2 global interrupt request. More...
void | gpio_configuration (void)
configure the gpioc pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | ccr1_val = 1000
uint16_t | ccr2_val = 500
uint16_t | ccr3_val = 250
uint16_t | ccr4_val = 125
uint16_t | prescalervalue = 0
tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | ccr1_val = 1000
uint16_t | ccr2_val = 500
uint16_t | ccr3_val = 250
uint16_t | ccr4_val = 125
uint16_t | prescalervalue = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the gpioc pins.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

< gpio pins number 8

< gpio pins number 9

< gpio pins number 6

< gpio pins number 7

< gpio pins number 8

< gpio pins number 9

Definition at line 119 of file project/at_start_f435/examples/tmr/oc_high/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< tmr interrupt channel 1

< tmr interrupt channel 2

< tmr interrupt channel 3

< tmr interrupt channel 4

< gpio pins number 6

< gpio pins number 7

< gpio pins number 8

< gpio pins number 9

< tmr interrupt channel 1

< tmr interrupt channel 2

< tmr interrupt channel 3

< tmr interrupt channel 4

< gpio pins number 6

< gpio pins number 7

< gpio pins number 8

< gpio pins number 9

Definition at line 53 of file project/at_start_f435/examples/tmr/oc_high/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c.

◆ TMR2_GLOBAL_IRQHandler()

void TMR2_GLOBAL_IRQHandler ( void )

this function handles tmr2 global interrupt request.

Parameters
none
Return values
none

< tmr flag channel 1

< tmr flag channel 1

< gpio pins number 6

< tmr flag channel 2

< tmr flag channel 2

< gpio pins number 7

< tmr flag channel 3

< tmr flag channel 3

< gpio pins number 8

< tmr flag channel 4

< gpio pins number 9

< tmr flag channel 1

< tmr flag channel 1

< gpio pins number 6

< tmr flag channel 2

< tmr flag channel 2

< gpio pins number 7

< tmr flag channel 3

< tmr flag channel 3

< gpio pins number 8

< tmr flag channel 4

< gpio pins number 9

Definition at line 140 of file project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c.

Variable Documentation

◆ ccr1_val [1/2]

uint16_t ccr1_val = 1000

Definition at line 40 of file project/at_start_f435/examples/tmr/oc_high/src/main.c.

Referenced by main().

◆ ccr1_val [2/2]

uint16_t ccr1_val = 1000

Definition at line 40 of file project/at_start_f437/examples/tmr/oc_high/src/main.c.

◆ ccr2_val [1/2]

uint16_t ccr2_val = 500

Definition at line 41 of file project/at_start_f435/examples/tmr/oc_high/src/main.c.

Referenced by main().

◆ ccr2_val [2/2]

uint16_t ccr2_val = 500

Definition at line 41 of file project/at_start_f437/examples/tmr/oc_high/src/main.c.

◆ ccr3_val [1/2]

uint16_t ccr3_val = 250

Definition at line 42 of file project/at_start_f435/examples/tmr/oc_high/src/main.c.

Referenced by main().

◆ ccr3_val [2/2]

uint16_t ccr3_val = 250

Definition at line 42 of file project/at_start_f437/examples/tmr/oc_high/src/main.c.

◆ ccr4_val [1/2]

uint16_t ccr4_val = 125

Definition at line 43 of file project/at_start_f435/examples/tmr/oc_high/src/main.c.

Referenced by main().

◆ ccr4_val [2/2]

uint16_t ccr4_val = 125

Definition at line 43 of file project/at_start_f437/examples/tmr/oc_high/src/main.c.

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f435/examples/tmr/oc_high/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f437/examples/tmr/oc_high/src/main.c.

◆ prescalervalue [1/2]

uint16_t prescalervalue = 0

Definition at line 44 of file project/at_start_f435/examples/tmr/oc_high/src/main.c.

Referenced by main().

◆ prescalervalue [2/2]

uint16_t prescalervalue = 0

Definition at line 44 of file project/at_start_f437/examples/tmr/oc_high/src/main.c.

◆ tmr_oc_init_structure [1/2]

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f435/examples/tmr/oc_high/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure [2/2]

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f437/examples/tmr/oc_high/src/main.c.


AT32F435/437 Firmwary Library: TMR_oc_low

Functions | Variables
TMR_oc_low
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR2_GLOBAL_IRQHandler (void)
this function handles tmr2 global interrupt request. More...
void | gpio_configuration (void)
configure the gpioc pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | ccr1_val = 1000
uint16_t | ccr2_val = 500
uint16_t | ccr3_val = 250
uint16_t | ccr4_val = 125
uint16_t | prescalervalue = 0
tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | ccr1_val = 1000
uint16_t | ccr2_val = 500
uint16_t | ccr3_val = 250
uint16_t | ccr4_val = 125
uint16_t | prescalervalue = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the gpioc pins.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

< gpio pins number 8

< gpio pins number 9

< gpio pins number 6

< gpio pins number 7

< gpio pins number 8

< gpio pins number 9

Definition at line 120 of file project/at_start_f435/examples/tmr/oc_low/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< tmr interrupt channel 1

< tmr interrupt channel 2

< tmr interrupt channel 3

< tmr interrupt channel 4

< gpio pins number 6

< gpio pins number 7

< gpio pins number 8

< gpio pins number 9

< tmr interrupt channel 1

< tmr interrupt channel 2

< tmr interrupt channel 3

< tmr interrupt channel 4

< gpio pins number 6

< gpio pins number 7

< gpio pins number 8

< gpio pins number 9

Definition at line 53 of file project/at_start_f435/examples/tmr/oc_low/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c.

◆ TMR2_GLOBAL_IRQHandler()

void TMR2_GLOBAL_IRQHandler ( void )

this function handles tmr2 global interrupt request.

Parameters
none
Return values
none

< tmr flag channel 1

< tmr flag channel 1

< gpio pins number 6

< tmr flag channel 2

< tmr flag channel 2

< gpio pins number 7

< tmr flag channel 3

< tmr flag channel 3

< gpio pins number 8

< tmr flag channel 4

< gpio pins number 9

< tmr flag channel 1

< tmr flag channel 1

< gpio pins number 6

< tmr flag channel 2

< tmr flag channel 2

< gpio pins number 7

< tmr flag channel 3

< tmr flag channel 3

< gpio pins number 8

< tmr flag channel 4

< gpio pins number 9

Definition at line 140 of file project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c.

Variable Documentation

◆ ccr1_val [1/2]

uint16_t ccr1_val = 1000

Definition at line 40 of file project/at_start_f435/examples/tmr/oc_low/src/main.c.

Referenced by main().

◆ ccr1_val [2/2]

uint16_t ccr1_val = 1000

Definition at line 40 of file project/at_start_f437/examples/tmr/oc_low/src/main.c.

◆ ccr2_val [1/2]

uint16_t ccr2_val = 500

Definition at line 41 of file project/at_start_f435/examples/tmr/oc_low/src/main.c.

Referenced by main().

◆ ccr2_val [2/2]

uint16_t ccr2_val = 500

Definition at line 41 of file project/at_start_f437/examples/tmr/oc_low/src/main.c.

◆ ccr3_val [1/2]

uint16_t ccr3_val = 250

Definition at line 42 of file project/at_start_f435/examples/tmr/oc_low/src/main.c.

Referenced by main().

◆ ccr3_val [2/2]

uint16_t ccr3_val = 250

Definition at line 42 of file project/at_start_f437/examples/tmr/oc_low/src/main.c.

◆ ccr4_val [1/2]

uint16_t ccr4_val = 125

Definition at line 43 of file project/at_start_f435/examples/tmr/oc_low/src/main.c.

Referenced by main().

◆ ccr4_val [2/2]

uint16_t ccr4_val = 125

Definition at line 43 of file project/at_start_f437/examples/tmr/oc_low/src/main.c.

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f435/examples/tmr/oc_low/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f437/examples/tmr/oc_low/src/main.c.

◆ prescalervalue [1/2]

uint16_t prescalervalue = 0

Definition at line 44 of file project/at_start_f435/examples/tmr/oc_low/src/main.c.

Referenced by main().

◆ prescalervalue [2/2]

uint16_t prescalervalue = 0

Definition at line 44 of file project/at_start_f437/examples/tmr/oc_low/src/main.c.

◆ tmr_oc_init_structure [1/2]

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f435/examples/tmr/oc_low/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure [2/2]

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f437/examples/tmr/oc_low/src/main.c.


AT32F435/437 Firmwary Library: TMR_oc_toggle_tmr3

Functions | Variables
TMR_oc_toggle_tmr3
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR3_GLOBAL_IRQHandler (void)
this function handles tmr3 global interrupt request. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
int | main (void)
main function. More...

Variables

uint32_t | capture = 0
__IO uint16_t | ccr1_val
__IO uint16_t | ccr2_val
__IO uint16_t | ccr3_val
__IO uint16_t | ccr4_val
tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
__IO uint16_t | ccr1_val = 32768
__IO uint16_t | ccr2_val = 16384
__IO uint16_t | ccr3_val = 8192
__IO uint16_t | ccr4_val = 4096
uint16_t | prescalervalue = 0
uint32_t | capture = 0
__IO uint16_t | ccr1_val
__IO uint16_t | ccr2_val
__IO uint16_t | ccr3_val
__IO uint16_t | ccr4_val
tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
__IO uint16_t | ccr1_val = 32768
__IO uint16_t | ccr2_val = 16384
__IO uint16_t | ccr3_val = 8192
__IO uint16_t | ccr4_val = 4096
uint16_t | prescalervalue = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 84 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 154 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 119 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr3 pins.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

< gpio pins number 6

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

Definition at line 126 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 58 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< tmr interrupt channel 1

< tmr interrupt channel 2

< tmr interrupt channel 3

< tmr interrupt channel 4

< tmr interrupt channel 1

< tmr interrupt channel 2

< tmr interrupt channel 3

< tmr interrupt channel 4

Definition at line 55 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 71 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 49 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 128 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 110 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 137 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c.

◆ TMR3_GLOBAL_IRQHandler()

void TMR3_GLOBAL_IRQHandler ( void )

this function handles tmr3 global interrupt request.

Parameters
none
Return values
none

< tmr flag channel 1

< tmr flag channel 1

< tmr flag channel 2

< tmr flag channel 2

< tmr flag channel 3

< tmr flag channel 3

< tmr flag channel 4

< tmr flag channel 4

< tmr flag channel 1

< tmr flag channel 1

< tmr flag channel 2

< tmr flag channel 2

< tmr flag channel 3

< tmr flag channel 3

< tmr flag channel 4

< tmr flag channel 4

Definition at line 146 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 97 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c.

Variable Documentation

◆ capture [1/2]

uint32_t capture = 0

Definition at line 38 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ capture [2/2]

uint32_t capture = 0

Definition at line 38 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c.

◆ ccr1_val [1/4]

__IO uint16_t ccr1_val
extern

Definition at line 41 of file project/at_start_f435/examples/irtmr/irtmr_output/src/main.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ ccr1_val [2/4]

__IO uint16_t ccr1_val = 32768

Definition at line 40 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c.

Referenced by main().

◆ ccr1_val [3/4]

__IO uint16_t ccr1_val
extern

Definition at line 41 of file project/at_start_f435/examples/irtmr/irtmr_output/src/main.c.

◆ ccr1_val [4/4]

__IO uint16_t ccr1_val = 32768

Definition at line 40 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/main.c.

◆ ccr2_val [1/4]

__IO uint16_t ccr2_val
extern

Definition at line 42 of file project/at_start_f435/examples/irtmr/irtmr_output/src/main.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ ccr2_val [2/4]

__IO uint16_t ccr2_val = 16384

Definition at line 41 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c.

Referenced by main().

◆ ccr2_val [3/4]

__IO uint16_t ccr2_val
extern

Definition at line 42 of file project/at_start_f435/examples/irtmr/irtmr_output/src/main.c.

◆ ccr2_val [4/4]

__IO uint16_t ccr2_val = 16384

Definition at line 41 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/main.c.

◆ ccr3_val [1/4]

__IO uint16_t ccr3_val
extern

Definition at line 42 of file project/at_start_f435/examples/tmr/oc_high/src/main.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ ccr3_val [2/4]

__IO uint16_t ccr3_val = 8192

Definition at line 42 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c.

Referenced by main().

◆ ccr3_val [3/4]

__IO uint16_t ccr3_val
extern

Definition at line 42 of file project/at_start_f435/examples/tmr/oc_high/src/main.c.

◆ ccr3_val [4/4]

__IO uint16_t ccr3_val = 8192

Definition at line 42 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/main.c.

◆ ccr4_val [1/4]

__IO uint16_t ccr4_val
extern

Definition at line 43 of file project/at_start_f435/examples/tmr/oc_high/src/main.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ ccr4_val [2/4]

__IO uint16_t ccr4_val = 4096

Definition at line 43 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c.

Referenced by main().

◆ ccr4_val [3/4]

__IO uint16_t ccr4_val
extern

Definition at line 43 of file project/at_start_f435/examples/tmr/oc_high/src/main.c.

◆ ccr4_val [4/4]

__IO uint16_t ccr4_val = 4096

Definition at line 43 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/main.c.

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/main.c.

◆ prescalervalue [1/2]

uint16_t prescalervalue = 0

Definition at line 44 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c.

Referenced by main().

◆ prescalervalue [2/2]

uint16_t prescalervalue = 0

Definition at line 44 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/main.c.

◆ tmr_oc_init_structure [1/2]

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure [2/2]

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/main.c.


AT32F435/437 Firmwary Library: TMR_oc_toggle_tmr9

Functions | Variables
TMR_oc_toggle_tmr9
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR1_BRK_TMR9_IRQHandler (void)
this function handles TMR9 global interrupt request. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr9 pins. More...
void | nvic_configuration (void)
int | main (void)
main function. More...

Variables

uint16_t | capture = 0
__IO uint16_t | ccr1_val
__IO uint16_t | ccr2_val
tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
__IO uint16_t | ccr1_val = 32768
__IO uint16_t | ccr2_val = 16384
uint16_t | prescalervalue = 0
uint16_t | capture = 0
__IO uint16_t | ccr1_val
__IO uint16_t | ccr2_val
tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
__IO uint16_t | ccr1_val = 32768
__IO uint16_t | ccr2_val = 16384
uint16_t | prescalervalue = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 82 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 136 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 117 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr9 pins.

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

Definition at line 114 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 56 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< tmr interrupt channel 1

< tmr interrupt channel 2

< tmr interrupt channel 3

< tmr interrupt channel 4

< tmr interrupt channel 1

< tmr interrupt channel 2

< tmr interrupt channel 3

< tmr interrupt channel 4

Definition at line 53 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 69 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 47 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c.

◆ nvic_configuration()

void nvic_configuration ( void )

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 126 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 108 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 135 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c.

◆ TMR1_BRK_TMR9_IRQHandler()

void TMR1_BRK_TMR9_IRQHandler ( void )

this function handles TMR9 global interrupt request.

Parameters
none
Return values
none

< tmr flag channel 1

< tmr flag channel 1

< tmr flag channel 2

< tmr flag channel 2

< tmr flag channel 1

< tmr flag channel 1

< tmr flag channel 2

< tmr flag channel 2

Definition at line 144 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 95 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c.

Variable Documentation

◆ capture [1/2]

uint16_t capture = 0

Definition at line 38 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c.

Referenced by TMR1_BRK_TMR9_IRQHandler().

◆ capture [2/2]

uint16_t capture = 0

Definition at line 38 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c.

◆ ccr1_val [1/4]

__IO uint16_t ccr1_val
extern

Definition at line 41 of file project/at_start_f435/examples/irtmr/irtmr_output/src/main.c.

Referenced by TMR1_BRK_TMR9_IRQHandler().

◆ ccr1_val [2/4]

__IO uint16_t ccr1_val = 32768

Definition at line 40 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c.

Referenced by main().

◆ ccr1_val [3/4]

__IO uint16_t ccr1_val
extern

Definition at line 41 of file project/at_start_f435/examples/irtmr/irtmr_output/src/main.c.

◆ ccr1_val [4/4]

__IO uint16_t ccr1_val = 32768

Definition at line 40 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/main.c.

◆ ccr2_val [1/4]

__IO uint16_t ccr2_val
extern

Definition at line 42 of file project/at_start_f435/examples/irtmr/irtmr_output/src/main.c.

Referenced by TMR1_BRK_TMR9_IRQHandler().

◆ ccr2_val [2/4]

__IO uint16_t ccr2_val = 16384

Definition at line 41 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c.

Referenced by main().

◆ ccr2_val [3/4]

__IO uint16_t ccr2_val
extern

Definition at line 42 of file project/at_start_f435/examples/irtmr/irtmr_output/src/main.c.

◆ ccr2_val [4/4]

__IO uint16_t ccr2_val = 16384

Definition at line 41 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/main.c.

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/main.c.

◆ prescalervalue [1/2]

uint16_t prescalervalue = 0

Definition at line 42 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c.

Referenced by main().

◆ prescalervalue [2/2]

uint16_t prescalervalue = 0

Definition at line 42 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/main.c.

◆ tmr_oc_init_structure [1/2]

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure [2/2]

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/main.c.


AT32F435/437 Firmwary Library: TMR_one_cycle

Functions | Variables
TMR_one_cycle
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
tmr_input_config_type tmr_ic_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | prescalervalue = 0
tmr_output_config_type tmr_oc_init_structure
tmr_input_config_type tmr_ic_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | prescalervalue = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 133 of file project/at_start_f435/examples/tmr/one_cycle/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr3 pins.

Parameters
none
Return values
none

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

Definition at line 106 of file project/at_start_f435/examples/tmr/one_cycle/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f435/examples/tmr/one_cycle/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c.

Variable Documentation

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 40 of file project/at_start_f435/examples/tmr/one_cycle/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 40 of file project/at_start_f437/examples/tmr/one_cycle/src/main.c.

◆ prescalervalue [1/2]

uint16_t prescalervalue = 0

Definition at line 41 of file project/at_start_f435/examples/tmr/one_cycle/src/main.c.

Referenced by main().

◆ prescalervalue [2/2]

uint16_t prescalervalue = 0

Definition at line 41 of file project/at_start_f437/examples/tmr/one_cycle/src/main.c.

◆ tmr_ic_init_structure [1/2]

tmr_input_config_type tmr_ic_init_structure

Definition at line 39 of file project/at_start_f435/examples/tmr/one_cycle/src/main.c.

Referenced by main().

◆ tmr_ic_init_structure [2/2]

tmr_input_config_type tmr_ic_init_structure

Definition at line 39 of file project/at_start_f437/examples/tmr/one_cycle/src/main.c.

◆ tmr_oc_init_structure [1/2]

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f435/examples/tmr/one_cycle/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure [2/2]

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f437/examples/tmr/one_cycle/src/main.c.


AT32F435/437 Firmwary Library: TMR_parallel_synchro

Functions | Variables
TMR_parallel_synchro
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timerperiod = 0
tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timerperiod = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 141 of file project/at_start_f435/examples/tmr/parallel_synchro/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr3 pins.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 0

< gpio pins number 6

< gpio pins number 6

< gpio pins number 0

< gpio pins number 6

Definition at line 115 of file project/at_start_f435/examples/tmr/parallel_synchro/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f435/examples/tmr/parallel_synchro/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c.

Variable Documentation

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f435/examples/tmr/parallel_synchro/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f437/examples/tmr/parallel_synchro/src/main.c.

◆ timerperiod [1/2]

uint16_t timerperiod = 0

Definition at line 40 of file project/at_start_f435/examples/tmr/parallel_synchro/src/main.c.

Referenced by main().

◆ timerperiod [2/2]

uint16_t timerperiod = 0

Definition at line 40 of file project/at_start_f437/examples/tmr/parallel_synchro/src/main.c.

◆ tmr_oc_init_structure [1/2]

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f435/examples/tmr/parallel_synchro/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure [2/2]

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f437/examples/tmr/parallel_synchro/src/main.c.


AT32F435/437 Firmwary Library: TMR_pwm_input

Functions | Variables
TMR_pwm_input
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR3_GLOBAL_IRQHandler (void)
this function handles tmr3 global interrupt request. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
Configure the TMR3 Pins. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | ic2value = 0
uint16_t | dutycycle
uint32_t | frequency
tmr_input_config_type tmr_ic_init_structure
__IO uint16_t | dutycycle = 0
__IO uint32_t | frequency = 0
__IO uint16_t | ic2value = 0
uint16_t | dutycycle
uint32_t | frequency
tmr_input_config_type tmr_ic_init_structure
__IO uint16_t | dutycycle = 0
__IO uint32_t | frequency = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 82 of file project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/tmr/pwm_input/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 117 of file project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

Configure the TMR3 Pins.

Parameters
None
Return values
None

< gpio pins number 7

< gpio pins number 7

Definition at line 101 of file project/at_start_f435/examples/tmr/pwm_input/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 56 of file project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< tmr interrupt channel 2

< tmr interrupt channel 2

Definition at line 51 of file project/at_start_f435/examples/tmr/pwm_input/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 69 of file project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 47 of file project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 126 of file project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 108 of file project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 135 of file project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c.

◆ TMR3_GLOBAL_IRQHandler()

void TMR3_GLOBAL_IRQHandler ( void )

this function handles tmr3 global interrupt request.

Parameters
none
Return values
none

< tmr flag channel 2

< tmr flag channel 2

Definition at line 144 of file project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 95 of file project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c.

Variable Documentation

◆ dutycycle [1/4]

uint16_t dutycycle
extern

Definition at line 40 of file project/at_start_f435/examples/tmr/pwm_input/src/main.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ dutycycle [2/4]

__IO uint16_t dutycycle = 0

Definition at line 40 of file project/at_start_f435/examples/tmr/pwm_input/src/main.c.

Referenced by main().

◆ dutycycle [3/4]

uint16_t dutycycle
extern

Definition at line 40 of file project/at_start_f435/examples/tmr/pwm_input/src/main.c.

Referenced by DMA1_Channel2_IRQHandler(), and main().

◆ dutycycle [4/4]

__IO uint16_t dutycycle = 0

Definition at line 40 of file project/at_start_f437/examples/tmr/pwm_input/src/main.c.

◆ frequency [1/4]

uint32_t frequency
extern

Definition at line 41 of file project/at_start_f435/examples/tmr/pwm_input/src/main.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ frequency [2/4]

__IO uint32_t frequency = 0

Definition at line 41 of file project/at_start_f435/examples/tmr/pwm_input/src/main.c.

Referenced by main().

◆ frequency [3/4]

uint32_t frequency
extern

Definition at line 41 of file project/at_start_f435/examples/tmr/pwm_input/src/main.c.

Referenced by DMA1_Channel2_IRQHandler(), and main().

◆ frequency [4/4]

__IO uint32_t frequency = 0

Definition at line 41 of file project/at_start_f437/examples/tmr/pwm_input/src/main.c.

◆ ic2value [1/2]

__IO uint16_t ic2value = 0

Definition at line 38 of file project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ ic2value [2/2]

__IO uint16_t ic2value = 0

Definition at line 38 of file project/at_start_f437/examples/tmr/pwm_input/src/at32f435_437_int.c.

◆ tmr_ic_init_structure [1/2]

tmr_input_config_type tmr_ic_init_structure

Definition at line 38 of file project/at_start_f435/examples/tmr/pwm_input/src/main.c.

Referenced by main().

◆ tmr_ic_init_structure [2/2]

tmr_input_config_type tmr_ic_init_structure

Definition at line 38 of file project/at_start_f437/examples/tmr/pwm_input/src/main.c.


AT32F435/437 Firmwary Library: TMR_pwm_input_dma

Macros | Functions | Variables
TMR_pwm_input_dma
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | tmr1_c1dt_address 0x40010034
#define | tmr1_c2dt_address 0x40010038
#define | SAMPLING_NUM 1000
#define | tmr1_c1dt_address 0x40010034
#define | tmr1_c2dt_address 0x40010038
#define | SAMPLING_NUM 1000

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...
void | DMA1_Channel2_IRQHandler (void)

Variables

tmr_input_config_type tmr_ic_init_structure
dma_init_type dma_init_structure
__IO uint16_t | buffer_cc1 [1000]
__IO uint16_t | buffer_cc2 [1000]
__IO uint16_t | ic1value = 0
__IO uint32_t | frequency = 0
__IO float | dutycycle = 0
uint32_t | freq_result
float | duty_result
tmr_input_config_type tmr_ic_init_structure
dma_init_type dma_init_structure
__IO uint16_t | buffer_cc1 [1000]
__IO uint16_t | buffer_cc2 [1000]
__IO uint16_t | ic1value = 0
__IO uint32_t | frequency = 0
__IO float | dutycycle = 0
uint32_t | freq_result
float | duty_result

Detailed Description

Macro Definition Documentation

◆ SAMPLING_NUM [1/2]

#define SAMPLING_NUM 1000

Definition at line 41 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c.

◆ SAMPLING_NUM [2/2]

#define SAMPLING_NUM 1000

Definition at line 41 of file project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c.

◆ tmr1_c1dt_address [1/2]

#define tmr1_c1dt_address 0x40010034

Definition at line 38 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c.

◆ tmr1_c1dt_address [2/2]

#define tmr1_c1dt_address 0x40010034

Definition at line 38 of file project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c.

◆ tmr1_c2dt_address [1/2]

#define tmr1_c2dt_address 0x40010038

Definition at line 39 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c.

◆ tmr1_c2dt_address [2/2]

#define tmr1_c2dt_address 0x40010038

Definition at line 39 of file project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 184 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c.

◆ DMA1_Channel2_IRQHandler()

void DMA1_Channel2_IRQHandler ( void )

< dma1 channel2 full data transfer flag

< dma1 channel2 full data transfer flag

Definition at line 138 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr1 pins.

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 8

Definition at line 163 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< dma full data transfer interrupt

< dma full data transfer interrupt

Definition at line 64 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c.

Variable Documentation

◆ buffer_cc1 [1/2]

__IO uint16_t buffer_cc1[1000]

Definition at line 46 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c.

Referenced by DMA1_Channel2_IRQHandler(), and main().

◆ buffer_cc1 [2/2]

__IO uint16_t buffer_cc1[1000]

Definition at line 46 of file project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c.

◆ buffer_cc2 [1/2]

__IO uint16_t buffer_cc2[1000]

Definition at line 47 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c.

Referenced by DMA1_Channel2_IRQHandler(), and main().

◆ buffer_cc2 [2/2]

__IO uint16_t buffer_cc2[1000]

Definition at line 47 of file project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c.

◆ dma_init_structure [1/2]

dma_init_type dma_init_structure

Definition at line 44 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c.

Referenced by main().

◆ dma_init_structure [2/2]

dma_init_type dma_init_structure

Definition at line 44 of file project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c.

◆ duty_result [1/2]

float duty_result

Definition at line 54 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c.

Referenced by DMA1_Channel2_IRQHandler().

◆ duty_result [2/2]

float duty_result

Definition at line 54 of file project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c.

◆ dutycycle [1/2]

__IO float dutycycle = 0

Definition at line 51 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c.

Referenced by DMA1_Channel2_IRQHandler(), and main().

◆ dutycycle [2/2]

__IO float dutycycle = 0

Definition at line 51 of file project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ freq_result [1/2]

uint32_t freq_result

Definition at line 53 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c.

Referenced by DMA1_Channel2_IRQHandler().

◆ freq_result [2/2]

uint32_t freq_result

Definition at line 53 of file project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c.

◆ frequency [1/2]

__IO uint32_t frequency = 0

Definition at line 50 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c.

Referenced by DMA1_Channel2_IRQHandler(), and main().

◆ frequency [2/2]

__IO uint32_t frequency = 0

Definition at line 50 of file project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ ic1value [1/2]

__IO uint16_t ic1value = 0

Definition at line 49 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c.

◆ ic1value [2/2]

__IO uint16_t ic1value = 0

Definition at line 49 of file project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c.

◆ tmr_ic_init_structure [1/2]

tmr_input_config_type tmr_ic_init_structure

Definition at line 43 of file project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c.

Referenced by main().

◆ tmr_ic_init_structure [2/2]

tmr_input_config_type tmr_ic_init_structure

Definition at line 43 of file project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c.


AT32F435/437 Firmwary Library: TMR_pwm_output_simulate

Functions | Variables
TMR_pwm_output_simulate
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR2_GLOBAL_IRQHandler (void)
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

uint16_t | capture = 0
__IO uint16_t | ccr1_val
__IO uint16_t | ccr2_val
__IO uint16_t | ccr3_val
__IO uint16_t | ccr4_val
tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | ccr1_val = 40961
uint16_t | ccr2_val = 27309
uint16_t | ccr3_val = 13654
uint16_t | ccr4_val = 6826
uint16_t | prescalervalue = 0
uint16_t | capture = 0
__IO uint16_t | ccr1_val
__IO uint16_t | ccr2_val
__IO uint16_t | ccr3_val
__IO uint16_t | ccr4_val
tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | ccr1_val = 40961
uint16_t | ccr2_val = 27309
uint16_t | ccr3_val = 13654
uint16_t | ccr4_val = 6826
uint16_t | prescalervalue = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 84 of file project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 133 of file project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 119 of file project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr1 pins.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

< gpio pins number 8

< gpio pins number 9

< gpio pins number 6

< gpio pins number 7

< gpio pins number 8

< gpio pins number 9

Definition at line 114 of file project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 58 of file project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< tmr interrupt channel 1

< tmr interrupt channel 2

< tmr interrupt channel 3

< tmr interrupt channel 4

< tmr interrupt channel 1

< tmr interrupt channel 2

< tmr interrupt channel 3

< tmr interrupt channel 4

Definition at line 55 of file project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 71 of file project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 49 of file project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 128 of file project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 110 of file project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 137 of file project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c.

◆ TMR2_GLOBAL_IRQHandler()

void TMR2_GLOBAL_IRQHandler ( void )

< tmr flag channel 1

< tmr flag channel 1

< gpio pins number 6

< tmr flag channel 2

< tmr flag channel 2

< gpio pins number 7

< tmr flag channel 3

< tmr flag channel 3

< gpio pins number 8

< tmr flag channel 4

< gpio pins number 9

< tmr flag channel 1

< tmr flag channel 1

< gpio pins number 6

< tmr flag channel 2

< tmr flag channel 2

< gpio pins number 7

< tmr flag channel 3

< tmr flag channel 3

< gpio pins number 8

< tmr flag channel 4

< gpio pins number 9

Definition at line 141 of file project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 97 of file project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c.

Variable Documentation

◆ capture [1/2]

uint16_t capture = 0

Definition at line 38 of file project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c.

Referenced by TMR2_GLOBAL_IRQHandler().

◆ capture [2/2]

uint16_t capture = 0

Definition at line 38 of file project/at_start_f437/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c.

◆ ccr1_val [1/4]

__IO uint16_t ccr1_val
extern

Definition at line 41 of file project/at_start_f435/examples/irtmr/irtmr_output/src/main.c.

Referenced by TMR2_GLOBAL_IRQHandler().

◆ ccr1_val [2/4]

uint16_t ccr1_val = 40961

Definition at line 41 of file project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().

◆ ccr1_val [3/4]

__IO uint16_t ccr1_val
extern

Definition at line 41 of file project/at_start_f435/examples/irtmr/irtmr_output/src/main.c.

Referenced by main().

◆ ccr1_val [4/4]

uint16_t ccr1_val = 40961

Definition at line 41 of file project/at_start_f437/examples/tmr/pwm_output_simulate/src/main.c.

◆ ccr2_val [1/4]

__IO uint16_t ccr2_val
extern

Definition at line 42 of file project/at_start_f435/examples/irtmr/irtmr_output/src/main.c.

Referenced by TMR2_GLOBAL_IRQHandler().

◆ ccr2_val [2/4]

uint16_t ccr2_val = 27309

Definition at line 42 of file project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().

◆ ccr2_val [3/4]

__IO uint16_t ccr2_val
extern

Definition at line 42 of file project/at_start_f435/examples/irtmr/irtmr_output/src/main.c.

Referenced by main().

◆ ccr2_val [4/4]

uint16_t ccr2_val = 27309

Definition at line 42 of file project/at_start_f437/examples/tmr/pwm_output_simulate/src/main.c.

◆ ccr3_val [1/4]

__IO uint16_t ccr3_val
extern

Definition at line 42 of file project/at_start_f435/examples/tmr/oc_high/src/main.c.

Referenced by TMR2_GLOBAL_IRQHandler().

◆ ccr3_val [2/4]

uint16_t ccr3_val = 13654

Definition at line 43 of file project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().

◆ ccr3_val [3/4]

__IO uint16_t ccr3_val
extern

Definition at line 42 of file project/at_start_f435/examples/tmr/oc_high/src/main.c.

Referenced by main().

◆ ccr3_val [4/4]

uint16_t ccr3_val = 13654

Definition at line 43 of file project/at_start_f437/examples/tmr/pwm_output_simulate/src/main.c.

◆ ccr4_val [1/4]

__IO uint16_t ccr4_val
extern

Definition at line 43 of file project/at_start_f435/examples/tmr/oc_high/src/main.c.

Referenced by TMR2_GLOBAL_IRQHandler().

◆ ccr4_val [2/4]

uint16_t ccr4_val = 6826

Definition at line 44 of file project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().

◆ ccr4_val [3/4]

__IO uint16_t ccr4_val
extern

Definition at line 43 of file project/at_start_f435/examples/tmr/oc_high/src/main.c.

Referenced by main().

◆ ccr4_val [4/4]

uint16_t ccr4_val = 6826

Definition at line 44 of file project/at_start_f437/examples/tmr/pwm_output_simulate/src/main.c.

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f437/examples/tmr/pwm_output_simulate/src/main.c.

◆ prescalervalue [1/2]

uint16_t prescalervalue = 0

Definition at line 45 of file project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().

◆ prescalervalue [2/2]

uint16_t prescalervalue = 0

Definition at line 45 of file project/at_start_f437/examples/tmr/pwm_output_simulate/src/main.c.

◆ tmr_oc_init_structure [1/2]

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure [2/2]

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f437/examples/tmr/pwm_output_simulate/src/main.c.


AT32F435/437 Firmwary Library: TMR_pwm_output_tmr10

Functions | Variables
TMR_pwm_output_tmr10
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | ccr1_val = 249
uint16_t | prescalervalue = 0
tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | ccr1_val = 249
uint16_t | prescalervalue = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 118 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr1 pins.

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 8

Definition at line 97 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c.

Variable Documentation

◆ ccr1_val [1/2]

uint16_t ccr1_val = 249

Definition at line 41 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c.

Referenced by main().

◆ ccr1_val [2/2]

uint16_t ccr1_val = 249

Definition at line 41 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/src/main.c.

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/src/main.c.

◆ prescalervalue [1/2]

uint16_t prescalervalue = 0

Definition at line 42 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c.

Referenced by main().

◆ prescalervalue [2/2]

uint16_t prescalervalue = 0

Definition at line 42 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/src/main.c.

◆ tmr_oc_init_structure [1/2]

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure [2/2]

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/src/main.c.


AT32F435/437 Firmwary Library: TMR_pwm_output_tmr3

Functions | Variables
TMR_pwm_output_tmr3
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | ccr1_val = 333
uint16_t | ccr2_val = 249
uint16_t | ccr3_val = 166
uint16_t | ccr4_val = 83
uint16_t | prescalervalue = 0
tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | ccr1_val = 333
uint16_t | ccr2_val = 249
uint16_t | ccr3_val = 166
uint16_t | ccr4_val = 83
uint16_t | prescalervalue = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 139 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr1 pins.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

< gpio pins number 6

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

Definition at line 112 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c.

Variable Documentation

◆ ccr1_val [1/2]

uint16_t ccr1_val = 333

Definition at line 41 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().

◆ ccr1_val [2/2]

uint16_t ccr1_val = 333

Definition at line 41 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/src/main.c.

◆ ccr2_val [1/2]

uint16_t ccr2_val = 249

Definition at line 42 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().

◆ ccr2_val [2/2]

uint16_t ccr2_val = 249

Definition at line 42 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/src/main.c.

◆ ccr3_val [1/2]

uint16_t ccr3_val = 166

Definition at line 43 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().

◆ ccr3_val [2/2]

uint16_t ccr3_val = 166

Definition at line 43 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/src/main.c.

◆ ccr4_val [1/2]

uint16_t ccr4_val = 83

Definition at line 44 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().

◆ ccr4_val [2/2]

uint16_t ccr4_val = 83

Definition at line 44 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/src/main.c.

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/src/main.c.

◆ prescalervalue [1/2]

uint16_t prescalervalue = 0

Definition at line 45 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().

◆ prescalervalue [2/2]

uint16_t prescalervalue = 0

Definition at line 45 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/src/main.c.

◆ tmr_oc_init_structure [1/2]

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure [2/2]

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/src/main.c.


AT32F435/437 Firmwary Library: TMR_timer_base

Functions | Variables
TMR_timer_base
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...
void | TMR1_OVF_TMR10_IRQHandler (void)
this function handles timer1 overflow handler. More...

Variables

crm_clocks_freq_type | crm_clocks_freq_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< tmr interrupt overflow

< tmr interrupt overflow

Definition at line 45 of file project/at_start_f435/examples/tmr/timer_base/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c.

◆ TMR1_OVF_TMR10_IRQHandler()

void TMR1_OVF_TMR10_IRQHandler ( void )

this function handles timer1 overflow handler.

Parameters
none
Return values
none

< tmr flag overflow

< tmr flag overflow

< tmr flag overflow

< tmr flag overflow

Definition at line 86 of file project/at_start_f435/examples/tmr/timer_base/src/main.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c.

Variable Documentation

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 38 of file project/at_start_f435/examples/tmr/timer_base/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 38 of file project/at_start_f437/examples/tmr/timer_base/src/main.c.


AT32F435/437 Firmwary Library: TMR_tmr1_synchro

Functions | Variables
TMR_tmr1_synchro
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timerperiod = 0
tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timerperiod = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 165 of file project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr1 pins.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 8

< gpio pins number 6

< gpio pins number 6

< gpio pins number 8

< gpio pins number 6

Definition at line 139 of file project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c.

Variable Documentation

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f437/examples/tmr/tmr1_synchro/src/main.c.

◆ timerperiod [1/2]

uint16_t timerperiod = 0

Definition at line 40 of file project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c.

Referenced by main().

◆ timerperiod [2/2]

uint16_t timerperiod = 0

Definition at line 40 of file project/at_start_f437/examples/tmr/tmr1_synchro/src/main.c.

◆ tmr_oc_init_structure [1/2]

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure [2/2]

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f437/examples/tmr/tmr1_synchro/src/main.c.


AT32F435/437 Firmwary Library: TMR_tmr2_32bit

Functions | Variables
TMR_tmr2_32bit
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
uint32_t | ccr1_val = 0x7ffff
uint32_t | ccr2_val = 0x3ffff
uint32_t | ccr3_val = 0x1ffff
uint32_t | ccr4_val = 0xffff
tmr_output_config_type tmr_oc_init_structure
uint32_t | ccr1_val = 0x7ffff
uint32_t | ccr2_val = 0x3ffff
uint32_t | ccr3_val = 0x1ffff
uint32_t | ccr4_val = 0xffff

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr1 pins.

Parameters
none
Return values
none

< gpio pins number 0

< gpio pins number 1

< gpio pins number 2

< gpio pins number 3

< gpio pins number 0

< gpio pins number 1

< gpio pins number 2

< gpio pins number 3

Definition at line 106 of file project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c.

Variable Documentation

◆ ccr1_val [1/2]

uint32_t ccr1_val = 0x7ffff

Definition at line 40 of file project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c.

Referenced by main().

◆ ccr1_val [2/2]

uint32_t ccr1_val = 0x7ffff

Definition at line 40 of file project/at_start_f437/examples/tmr/tmr2_32bit/src/main.c.

Referenced by TMR1_BRK_TMR9_IRQHandler(), TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ ccr2_val [1/2]

uint32_t ccr2_val = 0x3ffff

Definition at line 41 of file project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c.

Referenced by main().

◆ ccr2_val [2/2]

uint32_t ccr2_val = 0x3ffff

Definition at line 41 of file project/at_start_f437/examples/tmr/tmr2_32bit/src/main.c.

Referenced by TMR1_BRK_TMR9_IRQHandler(), TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ ccr3_val [1/2]

uint32_t ccr3_val = 0x1ffff

Definition at line 42 of file project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c.

Referenced by main().

◆ ccr3_val [2/2]

uint32_t ccr3_val = 0x1ffff

Definition at line 42 of file project/at_start_f437/examples/tmr/tmr2_32bit/src/main.c.

Referenced by TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ ccr4_val [1/2]

uint32_t ccr4_val = 0xffff

Definition at line 43 of file project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c.

Referenced by main().

◆ ccr4_val [2/2]

uint32_t ccr4_val = 0xffff

Definition at line 43 of file project/at_start_f437/examples/tmr/tmr2_32bit/src/main.c.

Referenced by TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ tmr_oc_init_structure [1/2]

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure [2/2]

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f437/examples/tmr/tmr2_32bit/src/main.c.


AT32F435/437 Firmwary Library: USART_half_duplex

Macros | Functions | Variables
USART_half_duplex
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)
#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usart_configuration (void)
config usart More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart half-duplex transfer: usart2 -> usart3"
uint8_t | usart3_tx_buffer [] = "usart half-duplex transfer: usart3 -> usart2"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | data_count
uint8_t | usart2_tx_buffer [] = "usart half-duplex transfer: usart2 -> usart3"
uint8_t | usart3_tx_buffer [] = "usart half-duplex transfer: usart3 -> usart2"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | data_count

Detailed Description

Macro Definition Documentation

◆ COUNTOF [1/2]

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 38 of file project/at_start_f435/examples/usart/half_duplex/src/main.c.

◆ COUNTOF [2/2]

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 38 of file project/at_start_f437/examples/usart/half_duplex/src/main.c.

◆ USART2_TX_BUFFER_SIZE [1/2]

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 39 of file project/at_start_f435/examples/usart/half_duplex/src/main.c.

◆ USART2_TX_BUFFER_SIZE [2/2]

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 39 of file project/at_start_f437/examples/usart/half_duplex/src/main.c.

◆ USART3_TX_BUFFER_SIZE [1/2]

#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Definition at line 40 of file project/at_start_f435/examples/usart/half_duplex/src/main.c.

◆ USART3_TX_BUFFER_SIZE [2/2]

#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Definition at line 40 of file project/at_start_f437/examples/usart/half_duplex/src/main.c.

Function Documentation

◆ buffer_compare()

uint8_t buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
1 pbuffer1 identical to pbuffer2 0: pbuffer1 differs from pbuffer2

Definition at line 103 of file project/at_start_f435/examples/usart/half_duplex/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart transmit data buffer empty flag

< usart receive data buffer full flag

< usart transmit data buffer empty flag

< usart receive data buffer full flag

< usart transmit data buffer empty flag

< usart receive data buffer full flag

< usart transmit data buffer empty flag

< usart receive data buffer full flag

Definition at line 122 of file project/at_start_f435/examples/usart/half_duplex/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 10

< gpio pins number 2

< gpio pins number 10

Definition at line 53 of file project/at_start_f435/examples/usart/half_duplex/src/main.c.

Referenced by main().

Variable Documentation

◆ data_count [1/2]

uint8_t data_count

Definition at line 46 of file project/at_start_f435/examples/usart/half_duplex/src/main.c.

Referenced by main().

◆ data_count [2/2]

uint8_t data_count

Definition at line 46 of file project/at_start_f437/examples/usart/half_duplex/src/main.c.

◆ usart2_rx_buffer [1/2]

uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]

Definition at line 44 of file project/at_start_f435/examples/usart/half_duplex/src/main.c.

Referenced by main().

◆ usart2_rx_buffer [2/2]

uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]

Definition at line 44 of file project/at_start_f437/examples/usart/half_duplex/src/main.c.

◆ usart2_tx_buffer [1/2]

uint8_t usart2_tx_buffer[] = "usart half-duplex transfer: usart2 -> usart3"

Definition at line 42 of file project/at_start_f435/examples/usart/half_duplex/src/main.c.

Referenced by main().

◆ usart2_tx_buffer [2/2]

uint8_t usart2_tx_buffer[] = "usart half-duplex transfer: usart2 -> usart3"

Definition at line 42 of file project/at_start_f437/examples/usart/half_duplex/src/main.c.

◆ usart3_rx_buffer [1/2]

uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 45 of file project/at_start_f435/examples/usart/half_duplex/src/main.c.

Referenced by main().

◆ usart3_rx_buffer [2/2]

uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 45 of file project/at_start_f437/examples/usart/half_duplex/src/main.c.

◆ usart3_tx_buffer [1/2]

uint8_t usart3_tx_buffer[] = "usart half-duplex transfer: usart3 -> usart2"

Definition at line 43 of file project/at_start_f435/examples/usart/half_duplex/src/main.c.

Referenced by main().

◆ usart3_tx_buffer [2/2]

uint8_t usart3_tx_buffer[] = "usart half-duplex transfer: usart3 -> usart2"

Definition at line 43 of file project/at_start_f437/examples/usart/half_duplex/src/main.c.


AT32F435/437 Firmwary Library: USART_hw_flow_control

Macros | Functions | Variables
USART_hw_flow_control
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | BUFFER_SIZE 16
#define | BUFFER_SIZE 16

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usart_configuration (void)
config usart More...
int | main (void)
main function. More...

Variables

uint8_t | rx_buffer [16]
uint8_t | data_count
uint8_t | rx_buffer [16]
uint8_t | data_count

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE [1/2]

#define BUFFER_SIZE 16

Definition at line 38 of file project/at_start_f435/examples/usart/hw_flow_control/src/main.c.

◆ BUFFER_SIZE [2/2]

#define BUFFER_SIZE 16

Definition at line 38 of file project/at_start_f437/examples/usart/hw_flow_control/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart receive data buffer full flag

< usart transmit data buffer empty flag

< usart receive data buffer full flag

< usart transmit data buffer empty flag

Definition at line 83 of file project/at_start_f435/examples/usart/hw_flow_control/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 3

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

< gpio pins number 3

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

Definition at line 48 of file project/at_start_f435/examples/usart/hw_flow_control/src/main.c.

Referenced by main().

Variable Documentation

◆ data_count [1/2]

uint8_t data_count

Definition at line 41 of file project/at_start_f435/examples/usart/hw_flow_control/src/main.c.

Referenced by main().

◆ data_count [2/2]

uint8_t data_count

Definition at line 41 of file project/at_start_f437/examples/usart/hw_flow_control/src/main.c.

◆ rx_buffer [1/2]

uint8_t rx_buffer[16]

Definition at line 40 of file project/at_start_f435/examples/usart/hw_flow_control/src/main.c.

Referenced by main().

◆ rx_buffer [2/2]

uint8_t rx_buffer[16]

Definition at line 40 of file project/at_start_f437/examples/usart/hw_flow_control/src/main.c.


AT32F435/437 Firmwary Library: USART_idle_detection

Functions
USART_idle_detection
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | USART2_IRQHandler (void)
this function handles usart2 handler. More...
void | usart_configuration (void)
config usart More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart transmit data buffer empty flag

< usart receive data buffer full flag

< usart transmit data buffer empty flag

< usart receive data buffer full flag

Definition at line 80 of file project/at_start_f435/examples/usart/idle_detection/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c.

◆ USART2_IRQHandler()

void USART2_IRQHandler ( void )

this function handles usart2 handler.

usart2 interrupt handler

Parameters
none
Return values
none

< usart idle flag

< usart idle flag

Definition at line 141 of file project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 3

< usart idle interrupt

< gpio pins number 2

< gpio pins number 3

< usart idle interrupt

Definition at line 43 of file project/at_start_f435/examples/usart/idle_detection/src/main.c.

Referenced by main().


AT32F435/437 Firmwary Library: USART_interrupt

Macros | Functions | Variables
USART_interrupt
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)
#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | USART2_IRQHandler (void)
this function handles usart2 handler. More...
void | USART3_IRQHandler (void)
this function handles usart3 handler. More...
void | usart_configuration (void)
config usart More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer []
uint8_t | usart3_tx_buffer []
uint8_t | usart2_rx_buffer []
uint8_t | usart3_rx_buffer []
uint8_t | usart2_tx_counter
uint8_t | usart3_tx_counter
uint8_t | usart2_rx_counter
uint8_t | usart3_rx_counter
uint8_t | usart2_tx_buffer_size
uint8_t | usart3_tx_buffer_size
uint8_t | usart2_tx_buffer [] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"
uint8_t | usart3_tx_buffer [] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
volatile uint8_t | usart2_tx_counter = 0x00
volatile uint8_t | usart3_tx_counter = 0x00
volatile uint8_t | usart2_rx_counter = 0x00
volatile uint8_t | usart3_rx_counter = 0x00
uint8_t | usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)
uint8_t | usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)
uint8_t | usart2_tx_buffer []
uint8_t | usart3_tx_buffer []
uint8_t | usart2_rx_buffer []
uint8_t | usart3_rx_buffer []
uint8_t | usart2_tx_counter
uint8_t | usart3_tx_counter
uint8_t | usart2_rx_counter
uint8_t | usart3_rx_counter
uint8_t | usart2_tx_buffer_size
uint8_t | usart3_tx_buffer_size
uint8_t | usart2_tx_buffer [] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"
uint8_t | usart3_tx_buffer [] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
volatile uint8_t | usart2_tx_counter = 0x00
volatile uint8_t | usart3_tx_counter = 0x00
volatile uint8_t | usart2_rx_counter = 0x00
volatile uint8_t | usart3_rx_counter = 0x00
uint8_t | usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)
uint8_t | usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)

Detailed Description

Macro Definition Documentation

◆ COUNTOF [1/2]

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 38 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

◆ COUNTOF [2/2]

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 38 of file project/at_start_f437/examples/usart/interrupt/src/main.c.

◆ USART2_TX_BUFFER_SIZE [1/2]

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 39 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

◆ USART2_TX_BUFFER_SIZE [2/2]

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 39 of file project/at_start_f437/examples/usart/interrupt/src/main.c.

◆ USART3_TX_BUFFER_SIZE [1/2]

#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Definition at line 40 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

◆ USART3_TX_BUFFER_SIZE [2/2]

#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Definition at line 40 of file project/at_start_f437/examples/usart/interrupt/src/main.c.

Function Documentation

◆ buffer_compare()

uint8_t buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
1 pbuffer1 identical to pbuffer2 0: pbuffer1 differs from pbuffer2

Definition at line 121 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 124 of file project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 140 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 54 of file project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 133 of file project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 115 of file project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 142 of file project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c.

◆ USART2_IRQHandler()

void USART2_IRQHandler ( void )

this function handles usart2 handler.

Parameters
none
Return values
none

< usart receive data buffer full flag

< usart receive data buffer full interrupt

< usart transmit data buffer empty flag

< usart transmit data buffer empty interrupt

< usart receive data buffer full flag

< usart receive data buffer full interrupt

< usart transmit data buffer empty flag

< usart transmit data buffer empty interrupt

Definition at line 151 of file project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c.

◆ USART3_IRQHandler()

void USART3_IRQHandler ( void )

this function handles usart3 handler.

Parameters
none
Return values
none

< usart receive data buffer full flag

< usart receive data buffer full interrupt

< usart transmit data buffer empty flag

< usart transmit data buffer empty interrupt

< usart receive data buffer full flag

< usart receive data buffer full interrupt

< usart transmit data buffer empty flag

< usart transmit data buffer empty interrupt

Definition at line 183 of file project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 3

< gpio pins number 10

< gpio pins number 11

< usart receive data buffer full interrupt

< usart receive data buffer full interrupt

< usart transmit data buffer empty interrupt

< usart transmit data buffer empty interrupt

< gpio pins number 2

< gpio pins number 3

< gpio pins number 10

< gpio pins number 11

< usart receive data buffer full interrupt

< usart receive data buffer full interrupt

< usart transmit data buffer empty interrupt

< usart transmit data buffer empty interrupt

Definition at line 58 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

Referenced by main().

Variable Documentation

◆ usart2_rx_buffer [1/4]

uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]

Definition at line 44 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart2_rx_buffer [2/4]

uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]

Definition at line 44 of file project/at_start_f437/examples/usart/interrupt/src/main.c.

◆ usart2_rx_buffer [3/4]

uint8_t usart2_rx_buffer[]
extern

Definition at line 44 of file project/at_start_f435/examples/usart/half_duplex/src/main.c.

Referenced by USART2_IRQHandler().

◆ usart2_rx_buffer [4/4]

uint8_t usart2_rx_buffer[]
extern

Definition at line 44 of file project/at_start_f435/examples/usart/half_duplex/src/main.c.

Referenced by dma_configuration(), and main().

◆ usart2_rx_counter [1/4]

uint8_t usart2_rx_counter
extern

Definition at line 48 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

Referenced by USART2_IRQHandler().

◆ usart2_rx_counter [2/4]

volatile uint8_t usart2_rx_counter = 0x00

Definition at line 48 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart2_rx_counter [3/4]

uint8_t usart2_rx_counter
extern

Definition at line 48 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart2_rx_counter [4/4]

volatile uint8_t usart2_rx_counter = 0x00

Definition at line 48 of file project/at_start_f437/examples/usart/interrupt/src/main.c.

◆ usart2_tx_buffer [1/4]

uint8_t usart2_tx_buffer[]
extern

Definition at line 42 of file project/at_start_f435/examples/usart/half_duplex/src/main.c.

Referenced by USART2_IRQHandler().

◆ usart2_tx_buffer [2/4]

uint8_t usart2_tx_buffer[] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"

Definition at line 42 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart2_tx_buffer [3/4]

uint8_t usart2_tx_buffer[]
extern

Definition at line 42 of file project/at_start_f435/examples/usart/half_duplex/src/main.c.

Referenced by dma_configuration(), and main().

◆ usart2_tx_buffer [4/4]

uint8_t usart2_tx_buffer[] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"

Definition at line 42 of file project/at_start_f437/examples/usart/interrupt/src/main.c.

◆ usart2_tx_buffer_size [1/4]

uint8_t usart2_tx_buffer_size
extern

Definition at line 50 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

Referenced by USART2_IRQHandler(), and USART3_IRQHandler().

◆ usart2_tx_buffer_size [2/4]

uint8_t usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)

Definition at line 50 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart2_tx_buffer_size [3/4]

uint8_t usart2_tx_buffer_size
extern

Definition at line 50 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart2_tx_buffer_size [4/4]

uint8_t usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)

Definition at line 50 of file project/at_start_f437/examples/usart/interrupt/src/main.c.

◆ usart2_tx_counter [1/4]

uint8_t usart2_tx_counter
extern

Definition at line 46 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

Referenced by USART2_IRQHandler().

◆ usart2_tx_counter [2/4]

volatile uint8_t usart2_tx_counter = 0x00

Definition at line 46 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

◆ usart2_tx_counter [3/4]

uint8_t usart2_tx_counter
extern

Definition at line 46 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart2_tx_counter [4/4]

volatile uint8_t usart2_tx_counter = 0x00

Definition at line 46 of file project/at_start_f437/examples/usart/interrupt/src/main.c.

◆ usart3_rx_buffer [1/4]

uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 45 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart3_rx_buffer [2/4]

uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 45 of file project/at_start_f437/examples/usart/interrupt/src/main.c.

◆ usart3_rx_buffer [3/4]

uint8_t usart3_rx_buffer[]
extern

Definition at line 45 of file project/at_start_f435/examples/usart/half_duplex/src/main.c.

Referenced by USART3_IRQHandler().

◆ usart3_rx_buffer [4/4]

uint8_t usart3_rx_buffer[]
extern

Definition at line 45 of file project/at_start_f435/examples/usart/half_duplex/src/main.c.

◆ usart3_rx_counter [1/4]

uint8_t usart3_rx_counter
extern

Definition at line 49 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

Referenced by USART3_IRQHandler().

◆ usart3_rx_counter [2/4]

volatile uint8_t usart3_rx_counter = 0x00

Definition at line 49 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart3_rx_counter [3/4]

uint8_t usart3_rx_counter
extern

Definition at line 49 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart3_rx_counter [4/4]

volatile uint8_t usart3_rx_counter = 0x00

Definition at line 49 of file project/at_start_f437/examples/usart/interrupt/src/main.c.

◆ usart3_tx_buffer [1/4]

uint8_t usart3_tx_buffer[]
extern

Definition at line 43 of file project/at_start_f435/examples/usart/half_duplex/src/main.c.

Referenced by USART3_IRQHandler().

◆ usart3_tx_buffer [2/4]

uint8_t usart3_tx_buffer[] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"

Definition at line 43 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart3_tx_buffer [3/4]

uint8_t usart3_tx_buffer[]
extern

Definition at line 43 of file project/at_start_f435/examples/usart/half_duplex/src/main.c.

Referenced by dma_configuration(), and main().

◆ usart3_tx_buffer [4/4]

uint8_t usart3_tx_buffer[] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"

Definition at line 43 of file project/at_start_f437/examples/usart/interrupt/src/main.c.

◆ usart3_tx_buffer_size [1/4]

uint8_t usart3_tx_buffer_size
extern

Definition at line 51 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

Referenced by USART2_IRQHandler(), and USART3_IRQHandler().

◆ usart3_tx_buffer_size [2/4]

uint8_t usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)

Definition at line 51 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart3_tx_buffer_size [3/4]

uint8_t usart3_tx_buffer_size
extern

Definition at line 51 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart3_tx_buffer_size [4/4]

uint8_t usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)

Definition at line 51 of file project/at_start_f437/examples/usart/interrupt/src/main.c.

◆ usart3_tx_counter [1/4]

uint8_t usart3_tx_counter
extern

Definition at line 47 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

Referenced by USART3_IRQHandler().

◆ usart3_tx_counter [2/4]

volatile uint8_t usart3_tx_counter = 0x00

Definition at line 47 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

◆ usart3_tx_counter [3/4]

uint8_t usart3_tx_counter
extern

Definition at line 47 of file project/at_start_f435/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart3_tx_counter [4/4]

volatile uint8_t usart3_tx_counter = 0x00

Definition at line 47 of file project/at_start_f437/examples/usart/interrupt/src/main.c.


AT32F435/437 Firmwary Library: USART_irda

Functions
USART_irda
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usart_configuration (void)
config usart More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f435/examples/usart/irda/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

Definition at line 43 of file project/at_start_f435/examples/usart/irda/src/main.c.

Referenced by main().


AT32F435/437 Firmwary Library: USART_polling

Macros | Functions | Variables
USART_polling
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)
#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usart_configuration (void)
config usart More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"
uint8_t | usart3_tx_buffer [] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | usart2_tx_counter = 0x00
uint8_t | usart3_tx_counter = 0x00
uint8_t | usart2_rx_counter = 0x00
uint8_t | usart3_rx_counter = 0x00
uint8_t | usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)
uint8_t | usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)
uint8_t | usart2_tx_buffer [] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"
uint8_t | usart3_tx_buffer [] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | usart2_tx_counter = 0x00
uint8_t | usart3_tx_counter = 0x00
uint8_t | usart2_rx_counter = 0x00
uint8_t | usart3_rx_counter = 0x00
uint8_t | usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)
uint8_t | usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)

Detailed Description

Macro Definition Documentation

◆ COUNTOF [1/2]

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 38 of file project/at_start_f435/examples/usart/polling/src/main.c.

◆ COUNTOF [2/2]

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 38 of file project/at_start_f437/examples/usart/polling/src/main.c.

◆ USART2_TX_BUFFER_SIZE [1/2]

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 39 of file project/at_start_f435/examples/usart/polling/src/main.c.

◆ USART2_TX_BUFFER_SIZE [2/2]

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 39 of file project/at_start_f437/examples/usart/polling/src/main.c.

◆ USART3_TX_BUFFER_SIZE [1/2]

#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Definition at line 40 of file project/at_start_f435/examples/usart/polling/src/main.c.

◆ USART3_TX_BUFFER_SIZE [2/2]

#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Definition at line 40 of file project/at_start_f437/examples/usart/polling/src/main.c.

Function Documentation

◆ buffer_compare()

uint8_t buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
1 pbuffer1 identical to pbuffer2 0: pbuffer1 differs from pbuffer2

Definition at line 110 of file project/at_start_f435/examples/usart/polling/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart transmit data buffer empty flag

< usart receive data buffer full flag

< usart transmit data buffer empty flag

< usart receive data buffer full flag

< usart transmit data buffer empty flag

< usart receive data buffer full flag

< usart transmit data buffer empty flag

< usart receive data buffer full flag

Definition at line 129 of file project/at_start_f435/examples/usart/polling/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 3

< gpio pins number 10

< gpio pins number 11

< gpio pins number 2

< gpio pins number 3

< gpio pins number 10

< gpio pins number 11

Definition at line 58 of file project/at_start_f435/examples/usart/polling/src/main.c.

Referenced by main().

Variable Documentation

◆ usart2_rx_buffer [1/2]

uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]

Definition at line 44 of file project/at_start_f435/examples/usart/polling/src/main.c.

Referenced by main().

◆ usart2_rx_buffer [2/2]

uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]

Definition at line 44 of file project/at_start_f437/examples/usart/polling/src/main.c.

◆ usart2_rx_counter [1/2]

uint8_t usart2_rx_counter = 0x00

Definition at line 48 of file project/at_start_f435/examples/usart/polling/src/main.c.

Referenced by main().

◆ usart2_rx_counter [2/2]

uint8_t usart2_rx_counter = 0x00

Definition at line 48 of file project/at_start_f437/examples/usart/polling/src/main.c.

◆ usart2_tx_buffer [1/2]

uint8_t usart2_tx_buffer[] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"

Definition at line 42 of file project/at_start_f435/examples/usart/polling/src/main.c.

Referenced by main().

◆ usart2_tx_buffer [2/2]

uint8_t usart2_tx_buffer[] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"

Definition at line 42 of file project/at_start_f437/examples/usart/polling/src/main.c.

◆ usart2_tx_buffer_size [1/2]

uint8_t usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)

Definition at line 50 of file project/at_start_f435/examples/usart/polling/src/main.c.

Referenced by main().

◆ usart2_tx_buffer_size [2/2]

uint8_t usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)

Definition at line 50 of file project/at_start_f437/examples/usart/polling/src/main.c.

◆ usart2_tx_counter [1/2]

uint8_t usart2_tx_counter = 0x00

Definition at line 46 of file project/at_start_f435/examples/usart/polling/src/main.c.

Referenced by main().

◆ usart2_tx_counter [2/2]

uint8_t usart2_tx_counter = 0x00

Definition at line 46 of file project/at_start_f437/examples/usart/polling/src/main.c.

◆ usart3_rx_buffer [1/2]

uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 45 of file project/at_start_f435/examples/usart/polling/src/main.c.

Referenced by main().

◆ usart3_rx_buffer [2/2]

uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 45 of file project/at_start_f437/examples/usart/polling/src/main.c.

◆ usart3_rx_counter [1/2]

uint8_t usart3_rx_counter = 0x00

Definition at line 49 of file project/at_start_f435/examples/usart/polling/src/main.c.

Referenced by main().

◆ usart3_rx_counter [2/2]

uint8_t usart3_rx_counter = 0x00

Definition at line 49 of file project/at_start_f437/examples/usart/polling/src/main.c.

◆ usart3_tx_buffer [1/2]

uint8_t usart3_tx_buffer[] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"

Definition at line 43 of file project/at_start_f435/examples/usart/polling/src/main.c.

Referenced by main().

◆ usart3_tx_buffer [2/2]

uint8_t usart3_tx_buffer[] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"

Definition at line 43 of file project/at_start_f437/examples/usart/polling/src/main.c.

◆ usart3_tx_buffer_size [1/2]

uint8_t usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)

Definition at line 51 of file project/at_start_f435/examples/usart/polling/src/main.c.

Referenced by main().

◆ usart3_tx_buffer_size [2/2]

uint8_t usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)

Definition at line 51 of file project/at_start_f437/examples/usart/polling/src/main.c.

◆ usart3_tx_counter [1/2]

uint8_t usart3_tx_counter = 0x00

Definition at line 47 of file project/at_start_f435/examples/usart/polling/src/main.c.

Referenced by main().

◆ usart3_tx_counter [2/2]

uint8_t usart3_tx_counter = 0x00

Definition at line 47 of file project/at_start_f437/examples/usart/polling/src/main.c.


AT32F435/437 Firmwary Library: USART_printf

Functions | Variables
USART_printf
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | time_cnt = 0
__IO uint32_t | time_cnt = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 45 of file project/at_start_f435/examples/usart/printf/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c.

Variable Documentation

◆ time_cnt [1/2]

__IO uint32_t time_cnt = 0

Definition at line 38 of file project/at_start_f435/examples/usart/printf/src/main.c.

Referenced by main().

◆ time_cnt [2/2]

__IO uint32_t time_cnt = 0

Definition at line 38 of file project/at_start_f437/examples/usart/printf/src/main.c.


AT32F435/437 Firmwary Library: USART_receiver_mute

Macros | Functions | Variables
USART_receiver_mute
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | BUFFER_SIZE 7
#define | MATCH_ID_VAL 0x81
#define | ERROR_ID_VAL 0x82
#define | DATA1_VAL 0x7F
#define | DATA2_VAL 0x7A
#define | DATA3_VAL 0x7B
#define | DATA4_VAL 0x7C
#define | BUFFER_SIZE 7
#define | MATCH_ID_VAL 0x81
#define | ERROR_ID_VAL 0x82
#define | DATA1_VAL 0x7F
#define | DATA2_VAL 0x7A
#define | DATA3_VAL 0x7B
#define | DATA4_VAL 0x7C

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | USART3_IRQHandler (void)
this function handles usart3 handler. More...
void | usart_configuration (void)
config usart More...
int | main (void)
main function. More...

Variables

uint8_t | usart3_rx_buffer []
uint8_t | rx_counter
uint8_t | usart2_tx_buffer [7] = { 0x7F , 0x81 , 0x7A , 0x82 , 0x7B , 0x81 , 0x7C }
uint8_t | usart3_rx_buffer [7]
uint8_t | tx_counter = 0
uint8_t | rx_counter = 0
uint8_t | usart3_rx_buffer []
uint8_t | rx_counter
uint8_t | usart2_tx_buffer [7] = { 0x7F , 0x81 , 0x7A , 0x82 , 0x7B , 0x81 , 0x7C }
uint8_t | usart3_rx_buffer [7]
uint8_t | tx_counter = 0
uint8_t | rx_counter = 0

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE [1/2]

#define BUFFER_SIZE 7

Definition at line 38 of file project/at_start_f435/examples/usart/receiver_mute/src/main.c.

◆ BUFFER_SIZE [2/2]

#define BUFFER_SIZE 7

Definition at line 38 of file project/at_start_f437/examples/usart/receiver_mute/src/main.c.

◆ DATA1_VAL [1/2]

#define DATA1_VAL 0x7F

Definition at line 41 of file project/at_start_f435/examples/usart/receiver_mute/src/main.c.

◆ DATA1_VAL [2/2]

#define DATA1_VAL 0x7F

Definition at line 41 of file project/at_start_f437/examples/usart/receiver_mute/src/main.c.

◆ DATA2_VAL [1/2]

#define DATA2_VAL 0x7A

Definition at line 42 of file project/at_start_f435/examples/usart/receiver_mute/src/main.c.

◆ DATA2_VAL [2/2]

#define DATA2_VAL 0x7A

Definition at line 42 of file project/at_start_f437/examples/usart/receiver_mute/src/main.c.

◆ DATA3_VAL [1/2]

#define DATA3_VAL 0x7B

Definition at line 43 of file project/at_start_f435/examples/usart/receiver_mute/src/main.c.

◆ DATA3_VAL [2/2]

#define DATA3_VAL 0x7B

Definition at line 43 of file project/at_start_f437/examples/usart/receiver_mute/src/main.c.

◆ DATA4_VAL [1/2]

#define DATA4_VAL 0x7C

Definition at line 44 of file project/at_start_f435/examples/usart/receiver_mute/src/main.c.

◆ DATA4_VAL [2/2]

#define DATA4_VAL 0x7C

Definition at line 44 of file project/at_start_f437/examples/usart/receiver_mute/src/main.c.

◆ ERROR_ID_VAL [1/2]

#define ERROR_ID_VAL 0x82

Definition at line 40 of file project/at_start_f435/examples/usart/receiver_mute/src/main.c.

◆ ERROR_ID_VAL [2/2]

#define ERROR_ID_VAL 0x82

Definition at line 40 of file project/at_start_f437/examples/usart/receiver_mute/src/main.c.

◆ MATCH_ID_VAL [1/2]

#define MATCH_ID_VAL 0x81

Definition at line 39 of file project/at_start_f435/examples/usart/receiver_mute/src/main.c.

◆ MATCH_ID_VAL [2/2]

#define MATCH_ID_VAL 0x81

Definition at line 39 of file project/at_start_f437/examples/usart/receiver_mute/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart transmit data buffer empty flag

< usart transmit data complete flag

< usart transmit data buffer empty flag

< usart transmit data complete flag

Definition at line 108 of file project/at_start_f435/examples/usart/receiver_mute/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c.

◆ USART3_IRQHandler()

void USART3_IRQHandler ( void )

this function handles usart3 handler.

Parameters
none
Return values
none

< usart receive data buffer full flag

< usart receive data buffer full flag

Definition at line 143 of file project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 11

< usart receive data buffer full interrupt

< gpio pins number 2

< gpio pins number 11

< usart receive data buffer full interrupt

Definition at line 56 of file project/at_start_f435/examples/usart/receiver_mute/src/main.c.

Referenced by main().

Variable Documentation

◆ rx_counter [1/4]

uint8_t rx_counter
extern

Definition at line 49 of file project/at_start_f435/examples/usart/receiver_mute/src/main.c.

Referenced by USART3_IRQHandler().

◆ rx_counter [2/4]

uint8_t rx_counter = 0

Definition at line 49 of file project/at_start_f435/examples/usart/receiver_mute/src/main.c.

◆ rx_counter [3/4]

uint8_t rx_counter
extern

Definition at line 49 of file project/at_start_f435/examples/usart/receiver_mute/src/main.c.

◆ rx_counter [4/4]

uint8_t rx_counter = 0

Definition at line 49 of file project/at_start_f437/examples/usart/receiver_mute/src/main.c.

Referenced by USART3_IRQHandler().

◆ tx_counter [1/2]

uint8_t tx_counter = 0

Definition at line 48 of file project/at_start_f435/examples/usart/receiver_mute/src/main.c.

Referenced by main().

◆ tx_counter [2/2]

uint8_t tx_counter = 0

Definition at line 48 of file project/at_start_f437/examples/usart/receiver_mute/src/main.c.

◆ usart2_tx_buffer [1/2]

uint8_t usart2_tx_buffer[7] = { 0x7F , 0x81 , 0x7A , 0x82 , 0x7B , 0x81 , 0x7C }

Definition at line 46 of file project/at_start_f435/examples/usart/receiver_mute/src/main.c.

Referenced by main().

◆ usart2_tx_buffer [2/2]

uint8_t usart2_tx_buffer[7] = { 0x7F , 0x81 , 0x7A , 0x82 , 0x7B , 0x81 , 0x7C }

Definition at line 46 of file project/at_start_f437/examples/usart/receiver_mute/src/main.c.

◆ usart3_rx_buffer [1/4]

uint8_t usart3_rx_buffer[7]

Definition at line 47 of file project/at_start_f435/examples/usart/receiver_mute/src/main.c.

Referenced by main().

◆ usart3_rx_buffer [2/4]

uint8_t usart3_rx_buffer[7]

Definition at line 47 of file project/at_start_f437/examples/usart/receiver_mute/src/main.c.

◆ usart3_rx_buffer [3/4]

uint8_t usart3_rx_buffer[]
extern

Definition at line 45 of file project/at_start_f435/examples/usart/half_duplex/src/main.c.

Referenced by USART3_IRQHandler().

◆ usart3_rx_buffer [4/4]

uint8_t usart3_rx_buffer[]
extern

Definition at line 45 of file project/at_start_f435/examples/usart/half_duplex/src/main.c.

Referenced by dma_configuration(), and main().


AT32F435/437 Firmwary Library: _USART_rs485

Macros | Functions | Variables
_USART_rs485
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | RS485_BAUDRATE 9600
#define | RS485_BUFFER_SIZE 128
#define | RS485_BAUDRATE 9600
#define | RS485_BUFFER_SIZE 128

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | rs485_config (void)
rs485 configiguration. More...
static void | rs485_send_data (u8 *buf, u8 cnt)
rs485 send data More...
int | main (void)
main function. More...
void | USART2_IRQHandler (void)
usart2 interrupt handler More...

Variables

uint8_t | rs485_buffer_rx [128]
uint8_t | rs485_buffer_rx_cnt = 0
uint8_t | rs485_buffer_rx [128]
uint8_t | rs485_buffer_rx_cnt = 0

Detailed Description

Macro Definition Documentation

◆ RS485_BAUDRATE [1/2]

#define RS485_BAUDRATE 9600

Definition at line 38 of file project/at_start_f435/examples/usart/rs485/src/main.c.

◆ RS485_BAUDRATE [2/2]

#define RS485_BAUDRATE 9600

Definition at line 38 of file project/at_start_f437/examples/usart/rs485/src/main.c.

◆ RS485_BUFFER_SIZE [1/2]

#define RS485_BUFFER_SIZE 128

Definition at line 39 of file project/at_start_f435/examples/usart/rs485/src/main.c.

◆ RS485_BUFFER_SIZE [2/2]

#define RS485_BUFFER_SIZE 128

Definition at line 39 of file project/at_start_f437/examples/usart/rs485/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart idle flag

< usart receive data buffer full interrupt

< usart receive data buffer full interrupt

< usart idle flag

< usart receive data buffer full interrupt

< usart receive data buffer full interrupt

Definition at line 110 of file project/at_start_f435/examples/usart/rs485/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c.

◆ rs485_config()

static void rs485_config ( void )
static

rs485 configiguration.

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 3

< gpio pins number 1

< usart receive data buffer full flag

< usart receive data buffer full interrupt

Definition at line 49 of file project/at_start_f435/examples/usart/rs485/src/main.c.

Referenced by main().

◆ rs485_send_data()

static void rs485_send_data | ( | u8 * | buf,
 |  | u8 | cnt
 | ) |  |
static

rs485 send data

Parameters
buf | pointer to the buffer that contain the data to be transferred.
cnt | size of buffer in bytes.
Return values
none

< usart transmit data buffer empty flag

Definition at line 97 of file project/at_start_f435/examples/usart/rs485/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c.

◆ USART2_IRQHandler()

void USART2_IRQHandler ( void )

usart2 interrupt handler

Parameters
none
Return values
none

< usart receive data buffer full flag

< usart receive data buffer full flag

Definition at line 141 of file project/at_start_f435/examples/usart/rs485/src/main.c.

Variable Documentation

◆ rs485_buffer_rx [1/2]

uint8_t rs485_buffer_rx[128]

Definition at line 41 of file project/at_start_f435/examples/usart/rs485/src/main.c.

Referenced by main(), and USART2_IRQHandler().

◆ rs485_buffer_rx [2/2]

uint8_t rs485_buffer_rx[128]

Definition at line 41 of file project/at_start_f437/examples/usart/rs485/src/main.c.

◆ rs485_buffer_rx_cnt [1/2]

uint8_t rs485_buffer_rx_cnt = 0

Definition at line 42 of file project/at_start_f435/examples/usart/rs485/src/main.c.

Referenced by main(), and USART2_IRQHandler().

◆ rs485_buffer_rx_cnt [2/2]

uint8_t rs485_buffer_rx_cnt = 0

Definition at line 42 of file project/at_start_f437/examples/usart/rs485/src/main.c.


AT32F435/437 Firmwary Library: USART_smartcard

Data Structures | Macros | Functions | Variables
USART_smartcard
AT32F435_periph_examples | AT32F437_periph_examples

Data Structures

struct sc_atr_type

Macros

#define | T0_PROTOCOL 0x00 /* t0 protocol */
#define | SETUP_LENGTH 20
#define | HIST_LENGTH 20
#define | SC_RECEIVE_TIMEOUT 0xA000 /* direction to reader */
#define | SC_USART_DIV_VAL 20 /* ISO 7816-3 protocol: SC_CLOCK_FREQ(PCLK/(2*USART_DIV_VAL)) is between 1 and 5 MHz */
#define | SC_F_DIV_D 372 /* ISO 7816-3 protocol: F/D = 372 */
#define | T0_PROTOCOL 0x00 /* t0 protocol */
#define | SETUP_LENGTH 20
#define | HIST_LENGTH 20
#define | SC_RECEIVE_TIMEOUT 0xA000 /* direction to reader */
#define | SC_USART_DIV_VAL 20 /* ISO 7816-3 protocol: SC_CLOCK_FREQ(PCLK/(2*USART_DIV_VAL)) is between 1 and 5 MHz */
#define | SC_F_DIV_D 372 /* ISO 7816-3 protocol: F/D = 372 */
#define | SC_USART_IRQHandler USART2_IRQHandler
this function handles sc_usart global interrupt request. More...

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | EXINT9_5_IRQHandler (void)
this function handles external lines 9 to 5 interrupt request. More...
void | SC_USART_IRQHandler (void)
this function handles sc_usart global interrupt request. More...
void | usart_configuration (void)
config usart More...
uint8_t | sc_response_decode (__IO uint8_t *card)
decode the card atr response. More...
int | main (void)
main function. More...

Variables

uint32_t | card_inserted
sc_atr_type sc_a2r_struct
uint32_t | sc_baud_rate = 0
uint32_t | sc_clock_freq = 0
uint32_t | counter = 0
error_status atr_decode_status = ERROR
uint32_t | card_inserted = 0
uint32_t | card_protocol = 1
uint8_t | dst_buffer [50]
uint32_t | card_inserted
sc_atr_type sc_a2r_struct
uint32_t | sc_baud_rate = 0
uint32_t | sc_clock_freq = 0
uint32_t | counter = 0
error_status atr_decode_status = ERROR
uint32_t | card_inserted = 0
uint32_t | card_protocol = 1
uint8_t | dst_buffer [50]

Detailed Description

Macro Definition Documentation

◆ HIST_LENGTH [1/2]

#define HIST_LENGTH 20

Definition at line 41 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

◆ HIST_LENGTH [2/2]

#define HIST_LENGTH 20

Definition at line 41 of file project/at_start_f437/examples/usart/smartcard/src/main.c.

◆ SC_F_DIV_D [1/2]

#define SC_F_DIV_D 372 /* ISO 7816-3 protocol: F/D = 372 */

Definition at line 45 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

◆ SC_F_DIV_D [2/2]

#define SC_F_DIV_D 372 /* ISO 7816-3 protocol: F/D = 372 */

Definition at line 45 of file project/at_start_f437/examples/usart/smartcard/src/main.c.

◆ SC_RECEIVE_TIMEOUT [1/2]

#define SC_RECEIVE_TIMEOUT 0xA000 /* direction to reader */

Definition at line 42 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

◆ SC_RECEIVE_TIMEOUT [2/2]

#define SC_RECEIVE_TIMEOUT 0xA000 /* direction to reader */

Definition at line 42 of file project/at_start_f437/examples/usart/smartcard/src/main.c.

◆ SC_USART_DIV_VAL [1/2]

#define SC_USART_DIV_VAL 20 /* ISO 7816-3 protocol: SC_CLOCK_FREQ(PCLK/(2*USART_DIV_VAL)) is between 1 and 5 MHz */

Definition at line 44 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

◆ SC_USART_DIV_VAL [2/2]

#define SC_USART_DIV_VAL 20 /* ISO 7816-3 protocol: SC_CLOCK_FREQ(PCLK/(2*USART_DIV_VAL)) is between 1 and 5 MHz */

Definition at line 44 of file project/at_start_f437/examples/usart/smartcard/src/main.c.

◆ SC_USART_IRQHandler

void SC_USART_IRQHandler ( void ) USART2_IRQHandler

this function handles sc_usart global interrupt request.

Parameters
none
Return values
none

< usart parity error flag

< usart receive data buffer full interrupt

< usart receive data buffer full flag

< usart receive data buffer full interrupt

Definition at line 40 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

◆ SETUP_LENGTH [1/2]

#define SETUP_LENGTH 20

Definition at line 40 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

◆ SETUP_LENGTH [2/2]

#define SETUP_LENGTH 20

Definition at line 40 of file project/at_start_f437/examples/usart/smartcard/src/main.c.

◆ T0_PROTOCOL [1/2]

#define T0_PROTOCOL 0x00 /* t0 protocol */

Definition at line 39 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

◆ T0_PROTOCOL [2/2]

#define T0_PROTOCOL 0x00 /* t0 protocol */

Definition at line 39 of file project/at_start_f437/examples/usart/smartcard/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c.

◆ EXINT9_5_IRQHandler()

void EXINT9_5_IRQHandler ( void )

this function handles external lines 9 to 5 interrupt request.

Parameters
none
Return values
none

Definition at line 143 of file project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart receive data buffer full flag

< usart receive data buffer full flag

Definition at line 281 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c.

◆ sc_response_decode()

uint8_t sc_response_decode ( __IO uint8_t * card )

decode the card atr response.

Parameters
card pointer to the buffer containing the card atr.
Return values
card protocol

Definition at line 205 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

Referenced by main().

◆ SC_USART_IRQHandler()

void SC_USART_IRQHandler ( void )

this function handles sc_usart global interrupt request.

Parameters
none
Return values
none

< usart parity error flag

< usart receive data buffer full interrupt

< usart receive data buffer full flag

< usart receive data buffer full interrupt

< usart parity error flag

< usart receive data buffer full interrupt

< usart receive data buffer full flag

< usart receive data buffer full interrupt

Definition at line 166 of file project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< usart parity error interrupt

< usart parity error interrupt

Definition at line 75 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

Referenced by main().

Variable Documentation

◆ atr_decode_status [1/2]

error_status atr_decode_status = ERROR

Definition at line 62 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

Referenced by main().

◆ atr_decode_status [2/2]

error_status atr_decode_status = ERROR

Definition at line 62 of file project/at_start_f437/examples/usart/smartcard/src/main.c.

◆ card_inserted [1/4]

uint32_t card_inserted
extern

Definition at line 63 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

Referenced by EXINT9_5_IRQHandler().

◆ card_inserted [2/4]

uint32_t card_inserted = 0

Definition at line 63 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

Referenced by main().

◆ card_inserted [3/4]

uint32_t card_inserted
extern

Definition at line 63 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

Referenced by main().

◆ card_inserted [4/4]

uint32_t card_inserted = 0

Definition at line 63 of file project/at_start_f437/examples/usart/smartcard/src/main.c.

Referenced by EXINT9_5_IRQHandler().

◆ card_protocol [1/2]

uint32_t card_protocol = 1

Definition at line 63 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

Referenced by main().

◆ card_protocol [2/2]

uint32_t card_protocol = 1

Definition at line 63 of file project/at_start_f437/examples/usart/smartcard/src/main.c.

◆ counter [1/2]

uint32_t counter = 0

Definition at line 61 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

Referenced by main().

◆ counter [2/2]

uint32_t counter = 0

Definition at line 61 of file project/at_start_f437/examples/usart/smartcard/src/main.c.

◆ dst_buffer [1/2]

uint8_t dst_buffer[50]
Initial value:
= {
1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1,
1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1,
1, 1, 1, 1, 1, 1, 1, 1, 1, 1
}

Definition at line 64 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

Referenced by main().

◆ dst_buffer [2/2]

uint8_t dst_buffer[50]
Initial value:
= {
1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1,
1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1,
1, 1, 1, 1, 1, 1, 1, 1, 1, 1
}

Definition at line 64 of file project/at_start_f437/examples/usart/smartcard/src/main.c.

◆ sc_a2r_struct [1/2]

sc_atr_type sc_a2r_struct

Definition at line 58 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

Referenced by sc_response_decode().

◆ sc_a2r_struct [2/2]

sc_atr_type sc_a2r_struct

Definition at line 58 of file project/at_start_f437/examples/usart/smartcard/src/main.c.

◆ sc_baud_rate [1/2]

uint32_t sc_baud_rate = 0

Definition at line 59 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

Referenced by usart_configuration().

◆ sc_baud_rate [2/2]

uint32_t sc_baud_rate = 0

Definition at line 59 of file project/at_start_f437/examples/usart/smartcard/src/main.c.

◆ sc_clock_freq [1/2]

uint32_t sc_clock_freq = 0

Definition at line 60 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

Referenced by usart_configuration().

◆ sc_clock_freq [2/2]

uint32_t sc_clock_freq = 0

Definition at line 60 of file project/at_start_f437/examples/usart/smartcard/src/main.c.


AT32F435/437 Firmwary Library: sc_atr_type Struct Reference

Data Fields
sc_atr_type Struct Reference
AT32F435_periph_examples | AT32F437_periph_examples » USART_smartcard

Data Fields

uint8_t | ts
uint8_t | t0
uint8_t | t [20]
uint8_t | h [20]
uint8_t | tlength
uint8_t | hlength

Detailed Description

Definition at line 48 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

Field Documentation

◆ h

uint8_t sc_atr_type::h

Definition at line 53 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

Referenced by sc_response_decode().

◆ hlength

uint8_t sc_atr_type::hlength

Definition at line 55 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

Referenced by sc_response_decode().

◆ t

uint8_t sc_atr_type::t

Definition at line 52 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

Referenced by sc_response_decode().

◆ t0

uint8_t sc_atr_type::t0

Definition at line 51 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

Referenced by sc_response_decode().

◆ tlength

uint8_t sc_atr_type::tlength

Definition at line 54 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

Referenced by sc_response_decode().

◆ ts

uint8_t sc_atr_type::ts

Definition at line 50 of file project/at_start_f435/examples/usart/smartcard/src/main.c.

Referenced by sc_response_decode().

The documentation for this struct was generated from the following files:
  • project/at_start_f435/examples/usart/smartcard/src/main.c
  • project/at_start_f437/examples/usart/smartcard/src/main.c


AT32F435/437 Firmwary Library: USART_synchronous

Macros | Functions | Variables
USART_synchronous
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | SPI1_TX_BUFFER_SIZE (COUNTOF(spi1_tx_buffer) - 1)
#define | DYMMY_BYTE 0x00
#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | SPI1_TX_BUFFER_SIZE (COUNTOF(spi1_tx_buffer) - 1)
#define | DYMMY_BYTE 0x00

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usart_spi_configuration (void)
config usart and spi More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart synchronous example: usart2 -> spi1"
uint8_t | spi1_tx_buffer [] = "usart synchronous example: spi1 -> usart2"
uint8_t | usart2_rx_buffer [((sizeof(spi1_tx_buffer)/sizeof(*(spi1_tx_buffer))) - 1)]
uint8_t | spi1_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | usart2_tx_counter = 0x00
uint8_t | spi1_tx_counter = 0x00
uint8_t | usart2_rx_counter = 0x00
uint8_t | spi1_rx_counter = 0x00
uint8_t | usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)
uint8_t | spi1_tx_buffer_size = ((sizeof( spi1_tx_buffer ) / sizeof(*( spi1_tx_buffer ))) - 1)
uint8_t | usart2_tx_buffer [] = "usart synchronous example: usart2 -> spi1"
uint8_t | spi1_tx_buffer [] = "usart synchronous example: spi1 -> usart2"
uint8_t | usart2_rx_buffer [((sizeof(spi1_tx_buffer)/sizeof(*(spi1_tx_buffer))) - 1)]
uint8_t | spi1_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | usart2_tx_counter = 0x00
uint8_t | spi1_tx_counter = 0x00
uint8_t | usart2_rx_counter = 0x00
uint8_t | spi1_rx_counter = 0x00
uint8_t | usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)
uint8_t | spi1_tx_buffer_size = ((sizeof( spi1_tx_buffer ) / sizeof(*( spi1_tx_buffer ))) - 1)

Detailed Description

Macro Definition Documentation

◆ COUNTOF [1/2]

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 38 of file project/at_start_f435/examples/usart/synchronous/src/main.c.

◆ COUNTOF [2/2]

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 38 of file project/at_start_f437/examples/usart/synchronous/src/main.c.

◆ DYMMY_BYTE [1/2]

#define DYMMY_BYTE 0x00

Definition at line 41 of file project/at_start_f435/examples/usart/synchronous/src/main.c.

◆ DYMMY_BYTE [2/2]

#define DYMMY_BYTE 0x00

Definition at line 41 of file project/at_start_f437/examples/usart/synchronous/src/main.c.

◆ SPI1_TX_BUFFER_SIZE [1/2]

#define SPI1_TX_BUFFER_SIZE (COUNTOF(spi1_tx_buffer) - 1)

Definition at line 40 of file project/at_start_f435/examples/usart/synchronous/src/main.c.

◆ SPI1_TX_BUFFER_SIZE [2/2]

#define SPI1_TX_BUFFER_SIZE (COUNTOF(spi1_tx_buffer) - 1)

Definition at line 40 of file project/at_start_f437/examples/usart/synchronous/src/main.c.

◆ USART2_TX_BUFFER_SIZE [1/2]

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 39 of file project/at_start_f435/examples/usart/synchronous/src/main.c.

◆ USART2_TX_BUFFER_SIZE [2/2]

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 39 of file project/at_start_f437/examples/usart/synchronous/src/main.c.

Function Documentation

◆ buffer_compare()

uint8_t buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
1 pbuffer1 identical to pbuffer2 0: pbuffer1 differs from pbuffer2

Definition at line 124 of file project/at_start_f435/examples/usart/synchronous/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< usart receive data buffer full flag

< spi or i2s transmit data buffer empty flag

< usart transmit data buffer empty flag

< usart receive data buffer full flag

< usart transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< usart receive data buffer full flag

< spi or i2s transmit data buffer empty flag

< usart transmit data buffer empty flag

< usart receive data buffer full flag

Definition at line 143 of file project/at_start_f435/examples/usart/synchronous/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c.

◆ usart_spi_configuration()

void usart_spi_configuration ( void )

config usart and spi

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 3

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

< gpio pins number 7

< gpio pins number 2

< gpio pins number 3

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

< gpio pins number 7

Definition at line 59 of file project/at_start_f435/examples/usart/synchronous/src/main.c.

Referenced by main().

Variable Documentation

◆ spi1_rx_buffer [1/2]

uint8_t spi1_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 46 of file project/at_start_f435/examples/usart/synchronous/src/main.c.

Referenced by main().

◆ spi1_rx_buffer [2/2]

uint8_t spi1_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 46 of file project/at_start_f437/examples/usart/synchronous/src/main.c.

◆ spi1_rx_counter [1/2]

uint8_t spi1_rx_counter = 0x00

Definition at line 50 of file project/at_start_f435/examples/usart/synchronous/src/main.c.

Referenced by main().

◆ spi1_rx_counter [2/2]

uint8_t spi1_rx_counter = 0x00

Definition at line 50 of file project/at_start_f437/examples/usart/synchronous/src/main.c.

◆ spi1_tx_buffer [1/2]

uint8_t spi1_tx_buffer[] = "usart synchronous example: spi1 -> usart2"

Definition at line 44 of file project/at_start_f435/examples/usart/synchronous/src/main.c.

Referenced by main().

◆ spi1_tx_buffer [2/2]

uint8_t spi1_tx_buffer[] = "usart synchronous example: spi1 -> usart2"

Definition at line 44 of file project/at_start_f437/examples/usart/synchronous/src/main.c.

◆ spi1_tx_buffer_size [1/2]

uint8_t spi1_tx_buffer_size = ((sizeof( spi1_tx_buffer ) / sizeof(*( spi1_tx_buffer ))) - 1)

Definition at line 52 of file project/at_start_f435/examples/usart/synchronous/src/main.c.

Referenced by main().

◆ spi1_tx_buffer_size [2/2]

uint8_t spi1_tx_buffer_size = ((sizeof( spi1_tx_buffer ) / sizeof(*( spi1_tx_buffer ))) - 1)

Definition at line 52 of file project/at_start_f437/examples/usart/synchronous/src/main.c.

◆ spi1_tx_counter [1/2]

uint8_t spi1_tx_counter = 0x00

Definition at line 48 of file project/at_start_f435/examples/usart/synchronous/src/main.c.

Referenced by main().

◆ spi1_tx_counter [2/2]

uint8_t spi1_tx_counter = 0x00

Definition at line 48 of file project/at_start_f437/examples/usart/synchronous/src/main.c.

◆ usart2_rx_buffer [1/2]

uint8_t usart2_rx_buffer[((sizeof(spi1_tx_buffer)/sizeof(*(spi1_tx_buffer))) - 1)]

Definition at line 45 of file project/at_start_f435/examples/usart/synchronous/src/main.c.

Referenced by main().

◆ usart2_rx_buffer [2/2]

uint8_t usart2_rx_buffer[((sizeof(spi1_tx_buffer)/sizeof(*(spi1_tx_buffer))) - 1)]

Definition at line 45 of file project/at_start_f437/examples/usart/synchronous/src/main.c.

◆ usart2_rx_counter [1/2]

uint8_t usart2_rx_counter = 0x00

Definition at line 49 of file project/at_start_f435/examples/usart/synchronous/src/main.c.

Referenced by main().

◆ usart2_rx_counter [2/2]

uint8_t usart2_rx_counter = 0x00

Definition at line 49 of file project/at_start_f437/examples/usart/synchronous/src/main.c.

◆ usart2_tx_buffer [1/2]

uint8_t usart2_tx_buffer[] = "usart synchronous example: usart2 -> spi1"

Definition at line 43 of file project/at_start_f435/examples/usart/synchronous/src/main.c.

Referenced by main().

◆ usart2_tx_buffer [2/2]

uint8_t usart2_tx_buffer[] = "usart synchronous example: usart2 -> spi1"

Definition at line 43 of file project/at_start_f437/examples/usart/synchronous/src/main.c.

◆ usart2_tx_buffer_size [1/2]

uint8_t usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)

Definition at line 51 of file project/at_start_f435/examples/usart/synchronous/src/main.c.

Referenced by main().

◆ usart2_tx_buffer_size [2/2]

uint8_t usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)

Definition at line 51 of file project/at_start_f437/examples/usart/synchronous/src/main.c.

◆ usart2_tx_counter [1/2]

uint8_t usart2_tx_counter = 0x00

Definition at line 47 of file project/at_start_f435/examples/usart/synchronous/src/main.c.

Referenced by main().

◆ usart2_tx_counter [2/2]

uint8_t usart2_tx_counter = 0x00

Definition at line 47 of file project/at_start_f437/examples/usart/synchronous/src/main.c.


AT32F435/437 Firmwary Library: USART_transfer_by_dma_interrupt

Macros | Functions | Variables
USART_transfer_by_dma_interrupt
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)
#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1 channel1 handler. More...
void | DMA1_Channel2_IRQHandler (void)
this function handles dma1 channel2 handler. More...
void | DMA1_Channel3_IRQHandler (void)
this function handles dma1 channel3 handler. More...
void | DMA1_Channel4_IRQHandler (void)
this function handles dma1 channel4 handler. More...
void | usart_configuration (void)
config usart More...
void | dma_configuration (void)
config dma for usart2 and usart3 More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_dma_status
uint8_t | usart2_rx_dma_status
uint8_t | usart3_tx_dma_status
uint8_t | usart3_rx_dma_status
uint8_t | usart2_tx_buffer [] = "usart transfer by dma interrupt: usart2 -> usart3 using dma"
uint8_t | usart3_tx_buffer [] = "usart transfer by dma interrupt: usart3 -> usart2 using dma"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
volatile uint8_t | usart2_tx_dma_status = 0
volatile uint8_t | usart2_rx_dma_status = 0
volatile uint8_t | usart3_tx_dma_status = 0
volatile uint8_t | usart3_rx_dma_status = 0
uint8_t | usart2_tx_dma_status
uint8_t | usart2_rx_dma_status
uint8_t | usart3_tx_dma_status
uint8_t | usart3_rx_dma_status
uint8_t | usart2_tx_buffer [] = "usart transfer by dma interrupt: usart2 -> usart3 using dma"
uint8_t | usart3_tx_buffer [] = "usart transfer by dma interrupt: usart3 -> usart2 using dma"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
volatile uint8_t | usart2_tx_dma_status = 0
volatile uint8_t | usart2_rx_dma_status = 0
volatile uint8_t | usart3_tx_dma_status = 0
volatile uint8_t | usart3_rx_dma_status = 0

Detailed Description

Macro Definition Documentation

◆ COUNTOF [1/2]

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 38 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c.

◆ COUNTOF [2/2]

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 38 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c.

◆ USART2_TX_BUFFER_SIZE [1/2]

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 39 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c.

◆ USART2_TX_BUFFER_SIZE [2/2]

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 39 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c.

◆ USART3_TX_BUFFER_SIZE [1/2]

#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Definition at line 40 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c.

◆ USART3_TX_BUFFER_SIZE [2/2]

#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Definition at line 40 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c.

Function Documentation

◆ buffer_compare()

uint8_t buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
1 pbuffer1 identical to pbuffer2 0: pbuffer1 differs from pbuffer2

Definition at line 226 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 83 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 118 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1 channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 145 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c.

◆ DMA1_Channel2_IRQHandler()

void DMA1_Channel2_IRQHandler ( void )

this function handles dma1 channel2 handler.

Parameters
none
Return values
none

< dma1 channel2 full data transfer flag

< dma1 channel2 full data transfer flag

< dma1 channel2 full data transfer flag

< dma1 channel2 full data transfer flag

Definition at line 160 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c.

◆ DMA1_Channel3_IRQHandler()

void DMA1_Channel3_IRQHandler ( void )

this function handles dma1 channel3 handler.

this function handles dma1 channel3 interrupt.

Parameters
none
Return values
none

< dma1 channel3 full data transfer flag

< dma1 channel3 full data transfer flag

< dma1 channel3 full data transfer flag

< dma1 channel3 full data transfer flag

Definition at line 175 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c.

◆ DMA1_Channel4_IRQHandler()

void DMA1_Channel4_IRQHandler ( void )

this function handles dma1 channel4 handler.

this function handles dma1 channel4 interrupt.

Parameters
none
Return values
none

< dma1 channel4 full data transfer flag

< dma1 channel4 full data transfer flag

< dma1 channel4 full data transfer flag

< dma1 channel4 full data transfer flag

Definition at line 190 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c.

◆ dma_configuration()

void dma_configuration ( void )

config dma for usart2 and usart3

Parameters
none
Return values
none

< dma full data transfer interrupt

< dma full data transfer interrupt

< dma full data transfer interrupt

< dma full data transfer interrupt

< dma full data transfer interrupt

< dma full data transfer interrupt

< dma full data transfer interrupt

< dma full data transfer interrupt

Definition at line 107 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 57 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 245 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 48 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 127 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 109 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 136 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 96 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 3

< gpio pins number 10

< gpio pins number 11

< gpio pins number 2

< gpio pins number 3

< gpio pins number 10

< gpio pins number 11

Definition at line 56 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by main().

Variable Documentation

◆ usart2_rx_buffer [1/2]

uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]

Definition at line 44 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by dma_configuration(), and main().

◆ usart2_rx_buffer [2/2]

uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]

Definition at line 44 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c.

◆ usart2_rx_dma_status [1/4]

uint8_t usart2_rx_dma_status
extern

Definition at line 47 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by DMA1_Channel2_IRQHandler().

◆ usart2_rx_dma_status [2/4]

volatile uint8_t usart2_rx_dma_status = 0

Definition at line 47 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by main().

◆ usart2_rx_dma_status [3/4]

uint8_t usart2_rx_dma_status
extern

Definition at line 47 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by main().

◆ usart2_rx_dma_status [4/4]

volatile uint8_t usart2_rx_dma_status = 0

Definition at line 47 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by DMA1_Channel2_IRQHandler().

◆ usart2_tx_buffer [1/2]

uint8_t usart2_tx_buffer[] = "usart transfer by dma interrupt: usart2 -> usart3 using dma"

Definition at line 42 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by dma_configuration(), and main().

◆ usart2_tx_buffer [2/2]

uint8_t usart2_tx_buffer[] = "usart transfer by dma interrupt: usart2 -> usart3 using dma"

Definition at line 42 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c.

◆ usart2_tx_dma_status [1/4]

uint8_t usart2_tx_dma_status
extern

Definition at line 46 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by DMA1_Channel1_IRQHandler().

◆ usart2_tx_dma_status [2/4]

volatile uint8_t usart2_tx_dma_status = 0

Definition at line 46 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by main().

◆ usart2_tx_dma_status [3/4]

uint8_t usart2_tx_dma_status
extern

Definition at line 46 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by main().

◆ usart2_tx_dma_status [4/4]

volatile uint8_t usart2_tx_dma_status = 0

Definition at line 46 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by DMA1_Channel1_IRQHandler().

◆ usart3_rx_buffer [1/2]

uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 45 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by dma_configuration(), and main().

◆ usart3_rx_buffer [2/2]

uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 45 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c.

◆ usart3_rx_dma_status [1/4]

uint8_t usart3_rx_dma_status
extern

Definition at line 49 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by DMA1_Channel4_IRQHandler().

◆ usart3_rx_dma_status [2/4]

volatile uint8_t usart3_rx_dma_status = 0

Definition at line 49 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by main().

◆ usart3_rx_dma_status [3/4]

uint8_t usart3_rx_dma_status
extern

Definition at line 49 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by main().

◆ usart3_rx_dma_status [4/4]

volatile uint8_t usart3_rx_dma_status = 0

Definition at line 49 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by DMA1_Channel4_IRQHandler().

◆ usart3_tx_buffer [1/2]

uint8_t usart3_tx_buffer[] = "usart transfer by dma interrupt: usart3 -> usart2 using dma"

Definition at line 43 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by dma_configuration(), and main().

◆ usart3_tx_buffer [2/2]

uint8_t usart3_tx_buffer[] = "usart transfer by dma interrupt: usart3 -> usart2 using dma"

Definition at line 43 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c.

◆ usart3_tx_dma_status [1/4]

uint8_t usart3_tx_dma_status
extern

Definition at line 48 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by DMA1_Channel3_IRQHandler().

◆ usart3_tx_dma_status [2/4]

volatile uint8_t usart3_tx_dma_status = 0

Definition at line 48 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by main().

◆ usart3_tx_dma_status [3/4]

uint8_t usart3_tx_dma_status
extern

Definition at line 48 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by main().

◆ usart3_tx_dma_status [4/4]

volatile uint8_t usart3_tx_dma_status = 0

Definition at line 48 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by DMA1_Channel3_IRQHandler().


AT32F435/437 Firmwary Library: USART_transfer_by_dma_polling

Macros | Functions | Variables
USART_transfer_by_dma_polling
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)
#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usart_configuration (void)
config usart More...
void | dma_configuration (void)
config dma for usart2 and usart3 More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart transfer by dma interrupt: usart2 -> usart3 using dma"
uint8_t | usart3_tx_buffer [] = "usart transfer by dma interrupt: usart3 -> usart2 using dma"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | usart2_tx_buffer [] = "usart transfer by dma interrupt: usart2 -> usart3 using dma"
uint8_t | usart3_tx_buffer [] = "usart transfer by dma interrupt: usart3 -> usart2 using dma"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Detailed Description

Macro Definition Documentation

◆ COUNTOF [1/2]

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 38 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c.

◆ COUNTOF [2/2]

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 38 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/src/main.c.

◆ USART2_TX_BUFFER_SIZE [1/2]

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 39 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c.

◆ USART2_TX_BUFFER_SIZE [2/2]

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 39 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/src/main.c.

◆ USART3_TX_BUFFER_SIZE [1/2]

#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Definition at line 40 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c.

◆ USART3_TX_BUFFER_SIZE [2/2]

#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Definition at line 40 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/src/main.c.

Function Documentation

◆ buffer_compare()

uint8_t buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
1 pbuffer1 identical to pbuffer2 0: pbuffer1 differs from pbuffer2

Definition at line 197 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c.

◆ dma_configuration()

void dma_configuration ( void )

config dma for usart2 and usart3

Parameters
none
Return values
none

Definition at line 103 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel2 full data transfer flag

< dma1 channel3 full data transfer flag

< dma1 channel4 full data transfer flag

< dma1 channel1 full data transfer flag

< dma1 channel2 full data transfer flag

< dma1 channel3 full data transfer flag

< dma1 channel4 full data transfer flag

Definition at line 216 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 3

< gpio pins number 10

< gpio pins number 11

< gpio pins number 2

< gpio pins number 3

< gpio pins number 10

< gpio pins number 11

Definition at line 52 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c.

Referenced by main().

Variable Documentation

◆ usart2_rx_buffer [1/2]

uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]

Definition at line 44 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c.

Referenced by dma_configuration(), and main().

◆ usart2_rx_buffer [2/2]

uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]

Definition at line 44 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/src/main.c.

◆ usart2_tx_buffer [1/2]

uint8_t usart2_tx_buffer[] = "usart transfer by dma interrupt: usart2 -> usart3 using dma"

Definition at line 42 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c.

Referenced by dma_configuration(), and main().

◆ usart2_tx_buffer [2/2]

uint8_t usart2_tx_buffer[] = "usart transfer by dma interrupt: usart2 -> usart3 using dma"

Definition at line 42 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/src/main.c.

◆ usart3_rx_buffer [1/2]

uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 45 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c.

Referenced by dma_configuration(), and main().

◆ usart3_rx_buffer [2/2]

uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 45 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/src/main.c.

◆ usart3_tx_buffer [1/2]

uint8_t usart3_tx_buffer[] = "usart transfer by dma interrupt: usart3 -> usart2 using dma"

Definition at line 43 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c.

Referenced by dma_configuration(), and main().

◆ usart3_tx_buffer [2/2]

uint8_t usart3_tx_buffer[] = "usart transfer by dma interrupt: usart3 -> usart2 using dma"

Definition at line 43 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/src/main.c.


AT32F435/437 Firmwary Library: USART_tx_rx_swap

Macros | Functions | Variables
USART_tx_rx_swap
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)
#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usart_configuration (void)
config usart More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"
uint8_t | usart3_tx_buffer [] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | usart2_tx_counter = 0x00
uint8_t | usart3_tx_counter = 0x00
uint8_t | usart2_rx_counter = 0x00
uint8_t | usart3_rx_counter = 0x00
uint8_t | usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)
uint8_t | usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)
uint8_t | usart2_tx_buffer [] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"
uint8_t | usart3_tx_buffer [] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | usart2_tx_counter = 0x00
uint8_t | usart3_tx_counter = 0x00
uint8_t | usart2_rx_counter = 0x00
uint8_t | usart3_rx_counter = 0x00
uint8_t | usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)
uint8_t | usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)

Detailed Description

Macro Definition Documentation

◆ COUNTOF [1/2]

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 38 of file project/at_start_f435/examples/usart/tx_rx_swap/src/main.c.

◆ COUNTOF [2/2]

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 38 of file project/at_start_f437/examples/usart/tx_rx_swap/src/main.c.

◆ USART2_TX_BUFFER_SIZE [1/2]

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 39 of file project/at_start_f435/examples/usart/tx_rx_swap/src/main.c.

◆ USART2_TX_BUFFER_SIZE [2/2]

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 39 of file project/at_start_f437/examples/usart/tx_rx_swap/src/main.c.

◆ USART3_TX_BUFFER_SIZE [1/2]

#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Definition at line 40 of file project/at_start_f435/examples/usart/tx_rx_swap/src/main.c.

◆ USART3_TX_BUFFER_SIZE [2/2]

#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Definition at line 40 of file project/at_start_f437/examples/usart/tx_rx_swap/src/main.c.

Function Documentation

◆ buffer_compare()

uint8_t buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
1 pbuffer1 identical to pbuffer2 0: pbuffer1 differs from pbuffer2

Definition at line 109 of file project/at_start_f435/examples/usart/tx_rx_swap/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart transmit data buffer empty flag

< usart receive data buffer full flag

< usart transmit data buffer empty flag

< usart receive data buffer full flag

< usart transmit data buffer empty flag

< usart receive data buffer full flag

< usart transmit data buffer empty flag

< usart receive data buffer full flag

Definition at line 128 of file project/at_start_f435/examples/usart/tx_rx_swap/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 3

< gpio pins number 10

< gpio pins number 11

< gpio pins number 2

< gpio pins number 3

< gpio pins number 10

< gpio pins number 11

Definition at line 58 of file project/at_start_f435/examples/usart/tx_rx_swap/src/main.c.

Referenced by main().

Variable Documentation

◆ usart2_rx_buffer [1/2]

uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]

Definition at line 44 of file project/at_start_f435/examples/usart/tx_rx_swap/src/main.c.

Referenced by main().

◆ usart2_rx_buffer [2/2]

uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]

Definition at line 44 of file project/at_start_f437/examples/usart/tx_rx_swap/src/main.c.

Referenced by USART2_IRQHandler().

◆ usart2_rx_counter [1/2]

uint8_t usart2_rx_counter = 0x00

Definition at line 48 of file project/at_start_f435/examples/usart/tx_rx_swap/src/main.c.

Referenced by main().

◆ usart2_rx_counter [2/2]

uint8_t usart2_rx_counter = 0x00

Definition at line 48 of file project/at_start_f437/examples/usart/tx_rx_swap/src/main.c.

Referenced by USART2_IRQHandler().

◆ usart2_tx_buffer [1/2]

uint8_t usart2_tx_buffer[] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"

Definition at line 42 of file project/at_start_f435/examples/usart/tx_rx_swap/src/main.c.

Referenced by main().

◆ usart2_tx_buffer [2/2]

uint8_t usart2_tx_buffer[] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"

Definition at line 42 of file project/at_start_f437/examples/usart/tx_rx_swap/src/main.c.

Referenced by USART2_IRQHandler().

◆ usart2_tx_buffer_size [1/2]

uint8_t usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)

Definition at line 50 of file project/at_start_f435/examples/usart/tx_rx_swap/src/main.c.

Referenced by main().

◆ usart2_tx_buffer_size [2/2]

uint8_t usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)

Definition at line 50 of file project/at_start_f437/examples/usart/tx_rx_swap/src/main.c.

Referenced by USART2_IRQHandler(), and USART3_IRQHandler().

◆ usart2_tx_counter [1/2]

uint8_t usart2_tx_counter = 0x00

Definition at line 46 of file project/at_start_f435/examples/usart/tx_rx_swap/src/main.c.

Referenced by main().

◆ usart2_tx_counter [2/2]

uint8_t usart2_tx_counter = 0x00

Definition at line 46 of file project/at_start_f437/examples/usart/tx_rx_swap/src/main.c.

◆ usart3_rx_buffer [1/2]

uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 45 of file project/at_start_f435/examples/usart/tx_rx_swap/src/main.c.

Referenced by main().

◆ usart3_rx_buffer [2/2]

uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 45 of file project/at_start_f437/examples/usart/tx_rx_swap/src/main.c.

Referenced by USART3_IRQHandler().

◆ usart3_rx_counter [1/2]

uint8_t usart3_rx_counter = 0x00

Definition at line 49 of file project/at_start_f435/examples/usart/tx_rx_swap/src/main.c.

Referenced by main().

◆ usart3_rx_counter [2/2]

uint8_t usart3_rx_counter = 0x00

Definition at line 49 of file project/at_start_f437/examples/usart/tx_rx_swap/src/main.c.

Referenced by USART3_IRQHandler().

◆ usart3_tx_buffer [1/2]

uint8_t usart3_tx_buffer[] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"

Definition at line 43 of file project/at_start_f435/examples/usart/tx_rx_swap/src/main.c.

Referenced by main().

◆ usart3_tx_buffer [2/2]

uint8_t usart3_tx_buffer[] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"

Definition at line 43 of file project/at_start_f437/examples/usart/tx_rx_swap/src/main.c.

Referenced by USART3_IRQHandler().

◆ usart3_tx_buffer_size [1/2]

uint8_t usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)

Definition at line 51 of file project/at_start_f435/examples/usart/tx_rx_swap/src/main.c.

Referenced by main().

◆ usart3_tx_buffer_size [2/2]

uint8_t usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)

Definition at line 51 of file project/at_start_f437/examples/usart/tx_rx_swap/src/main.c.

Referenced by USART2_IRQHandler(), and USART3_IRQHandler().

◆ usart3_tx_counter [1/2]

uint8_t usart3_tx_counter = 0x00

Definition at line 47 of file project/at_start_f435/examples/usart/tx_rx_swap/src/main.c.

Referenced by main().

◆ usart3_tx_counter [2/2]

uint8_t usart3_tx_counter = 0x00

Definition at line 47 of file project/at_start_f437/examples/usart/tx_rx_swap/src/main.c.

Referenced by USART3_IRQHandler().


AT32F435/437 Firmwary Library: USB_device_audio

Modules | Macros | Functions | Variables
USB_device_audio
AT32F435_periph_examples | AT32F437_periph_examples

Modules

USB_device_audio_codec_reg_definition
USB_device_audio_codec_pin_definition
USB_device_audio_codec_exported_functions

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 64
#define | USBD_EP2_TX_SIZE 16
#define | USBD_EP3_TX_SIZE 16
#define | USBD_EP4_TX_SIZE 0
#define | USBD_EP5_TX_SIZE 0
#define | USBD_EP6_TX_SIZE 0
#define | USBD_EP7_TX_SIZE 0
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 64
#define | USBD2_EP2_TX_SIZE 4
#define | USBD2_EP3_TX_SIZE 0
#define | USBD2_EP4_TX_SIZE 0
#define | USBD2_EP5_TX_SIZE 0
#define | USBD2_EP6_TX_SIZE 0
#define | USBD2_EP7_TX_SIZE 0
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_CLKCTRL 0x80504C4E
#define | I2Cx_ADDRESS 0x00
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_8
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE8
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_MUX GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_9
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE9
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_MUX GPIO_MUX_4
#define | WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)
wm8988 freq More...
#define | WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)
#define | WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)
wm8988 bit width More...
#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 64
#define | USBD_EP2_TX_SIZE 16
#define | USBD_EP3_TX_SIZE 16
#define | USBD_EP4_TX_SIZE 0
#define | USBD_EP5_TX_SIZE 0
#define | USBD_EP6_TX_SIZE 0
#define | USBD_EP7_TX_SIZE 0
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 64
#define | USBD2_EP2_TX_SIZE 4
#define | USBD2_EP3_TX_SIZE 0
#define | USBD2_EP4_TX_SIZE 0
#define | USBD2_EP5_TX_SIZE 0
#define | USBD2_EP6_TX_SIZE 0
#define | USBD2_EP7_TX_SIZE 0
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_CLKCTRL 0x80504C4E
#define | I2Cx_ADDRESS 0x00
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_8
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE8
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_MUX GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_9
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE9
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_MUX GPIO_MUX_4
#define | WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)
wm8988 freq More...
#define | WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)
#define | WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)
wm8988 bit width More...

Functions

void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
codec speaker write fifo More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | DMA1_Channel3_IRQHandler (void)
this function handles dma1 channel3 interrupt. More...
void | DMA1_Channel4_IRQHandler (void)
this function handles dma1 channel4 interrupt. More...
error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
int | main (void)
main function. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...

Variables

uint16_t | reg_addr_data []
wm8988 register default value More...
i2c_handle_type hi2cx
audio_codec_type audio_codec
uint16_t | spk_dma_buffer [DMA_BUFFER_SIZE]
uint16_t | mic_dma_buffer [DMA_BUFFER_SIZE]
otg_core_type otg_core_struct
uint16_t | reg_addr_data []
wm8988 register default value More...
i2c_handle_type hi2cx
audio_codec_type audio_codec
uint16_t | spk_dma_buffer [DMA_BUFFER_SIZE]
uint16_t | mic_dma_buffer [DMA_BUFFER_SIZE]
otg_core_type otg_core_struct

Detailed Description

Macro Definition Documentation

◆ I2C_TIMEOUT [1/2]

#define I2C_TIMEOUT 0xFFFFFFFF

Definition at line 41 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ I2C_TIMEOUT [2/2]

#define I2C_TIMEOUT 0xFFFFFFFF

Definition at line 41 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_ADDRESS [1/2]

#define I2Cx_ADDRESS 0x00

Definition at line 44 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_ADDRESS [2/2]

#define I2Cx_ADDRESS 0x00

Definition at line 44 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_CLK [1/2]

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 47 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_CLK [2/2]

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 47 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_CLKCTRL [1/2]

#define I2Cx_CLKCTRL 0x80504C4E

Definition at line 43 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_CLKCTRL [2/2]

#define I2Cx_CLKCTRL 0x80504C4E

Definition at line 43 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_PORT [1/2]

#define I2Cx_PORT I2C1

Definition at line 46 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_PORT [2/2]

#define I2Cx_PORT I2C1

Definition at line 46 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_CLK [1/2]

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 49 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_CLK [2/2]

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 49 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_MUX [1/2]

#define I2Cx_SCL_GPIO_MUX GPIO_MUX_4

Definition at line 53 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_MUX [2/2]

#define I2Cx_SCL_GPIO_MUX GPIO_MUX_4

Definition at line 53 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_PIN [1/2]

#define I2Cx_SCL_GPIO_PIN GPIO_PINS_8

Definition at line 50 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_PIN [2/2]

#define I2Cx_SCL_GPIO_PIN GPIO_PINS_8

Definition at line 50 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_PinsSource [1/2]

#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE8

Definition at line 51 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_PinsSource [2/2]

#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE8

Definition at line 51 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_PORT [1/2]

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 52 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_PORT [2/2]

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 52 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_CLK [1/2]

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 55 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_CLK [2/2]

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 55 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_MUX [1/2]

#define I2Cx_SDA_GPIO_MUX GPIO_MUX_4

Definition at line 59 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_MUX [2/2]

#define I2Cx_SDA_GPIO_MUX GPIO_MUX_4

Definition at line 59 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_PIN [1/2]

#define I2Cx_SDA_GPIO_PIN GPIO_PINS_9

Definition at line 56 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_PIN [2/2]

#define I2Cx_SDA_GPIO_PIN GPIO_PINS_9

Definition at line 56 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_PinsSource [1/2]

#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE9

Definition at line 57 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_PinsSource [2/2]

#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE9

Definition at line 57 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_PORT [1/2]

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 58 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_PORT [2/2]

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 58 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

◆ OTG_CLOCK [1/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 69 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_CLOCK [2/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 69 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_IRQ [1/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 70 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_IRQ [2/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 70 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [1/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 71 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [2/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 71 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_DM [1/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 82 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_DM [2/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 82 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [1/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 83 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [2/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 83 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_DP [1/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 79 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_DP [2/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 79 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [1/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 80 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [2/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 80 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_GPIO [1/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 76 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_GPIO [2/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 76 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [1/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 77 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [2/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 77 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_ID [1/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 88 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_ID [2/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 88 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [1/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 89 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [2/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 89 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_MUX [1/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 96 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_MUX [2/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 96 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_SOF [1/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 93 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_SOF [2/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 93 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [1/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 91 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [2/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 91 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [1/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 92 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [2/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 92 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [1/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 94 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [2/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 94 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_VBUS [1/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 85 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_VBUS [2/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 85 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [1/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 86 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [2/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 86 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_USB_ID [1/2]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 62 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_USB_ID [2/2]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 62 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [1/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 74 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [2/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 74 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [1/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 73 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [2/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 73 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [1/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 72 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [2/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 72 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ USB_ID [1/2]

#define USB_ID 0

Definition at line 68 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ USB_ID [2/2]

#define USB_ID 0

Definition at line 68 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [1/2]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore

Definition at line 198 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [2/2]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore

Definition at line 198 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [1/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 151 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [2/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 151 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [1/2]

#define USBD2_EP1_TX_SIZE 64

Definition at line 152 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [2/2]

#define USBD2_EP1_TX_SIZE 64

Definition at line 152 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [1/2]

#define USBD2_EP2_TX_SIZE 4

Definition at line 153 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [2/2]

#define USBD2_EP2_TX_SIZE 4

Definition at line 153 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [1/2]

#define USBD2_EP3_TX_SIZE 0

Definition at line 154 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [2/2]

#define USBD2_EP3_TX_SIZE 0

Definition at line 154 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [1/2]

#define USBD2_EP4_TX_SIZE 0

Definition at line 155 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [2/2]

#define USBD2_EP4_TX_SIZE 0

Definition at line 155 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [1/2]

#define USBD2_EP5_TX_SIZE 0

Definition at line 156 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [2/2]

#define USBD2_EP5_TX_SIZE 0

Definition at line 156 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [1/2]

#define USBD2_EP6_TX_SIZE 0

Definition at line 157 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [2/2]

#define USBD2_EP6_TX_SIZE 0

Definition at line 157 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [1/2]

#define USBD2_EP7_TX_SIZE 0

Definition at line 158 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [2/2]

#define USBD2_EP7_TX_SIZE 0

Definition at line 158 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD2_RX_SIZE [1/2]

#define USBD2_RX_SIZE 128

Definition at line 150 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD2_RX_SIZE [2/2]

#define USBD2_RX_SIZE 128

Definition at line 150 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [1/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 140 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [2/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 140 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [1/2]

#define USBD_EP1_TX_SIZE 64

Definition at line 141 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [2/2]

#define USBD_EP1_TX_SIZE 64

Definition at line 141 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [1/2]

#define USBD_EP2_TX_SIZE 16

Definition at line 142 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [2/2]

#define USBD_EP2_TX_SIZE 16

Definition at line 142 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [1/2]

#define USBD_EP3_TX_SIZE 16

Definition at line 143 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [2/2]

#define USBD_EP3_TX_SIZE 16

Definition at line 143 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [1/2]

#define USBD_EP4_TX_SIZE 0

Definition at line 144 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [2/2]

#define USBD_EP4_TX_SIZE 0

Definition at line 144 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [1/2]

#define USBD_EP5_TX_SIZE 0

Definition at line 145 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [2/2]

#define USBD_EP5_TX_SIZE 0

Definition at line 145 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [1/2]

#define USBD_EP6_TX_SIZE 0

Definition at line 146 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [2/2]

#define USBD_EP6_TX_SIZE 0

Definition at line 146 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [1/2]

#define USBD_EP7_TX_SIZE 0

Definition at line 147 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [2/2]

#define USBD_EP7_TX_SIZE 0

Definition at line 147 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD_RX_SIZE [1/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 139 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ USBD_RX_SIZE [2/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 139 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [1/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 50 of file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [2/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 50 of file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.

◆ WM8988_REG_BITW16 [1/2]

#define WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)

wm8988 bit width

Definition at line 70 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ WM8988_REG_BITW16 [2/2]

#define WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)

wm8988 bit width

Definition at line 70 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

◆ WM8988_REG_FREQ16K [1/2]

#define WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)

Definition at line 65 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ WM8988_REG_FREQ16K [2/2]

#define WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)

Definition at line 65 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

◆ WM8988_REG_FREQ48K [1/2]

#define WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)

wm8988 freq

Definition at line 64 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ WM8988_REG_FREQ48K [2/2]

#define WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)

wm8988 freq

Definition at line 64 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

Function Documentation

◆ audio_codec_init()

error_status audio_codec_init ( void )

audio codec init

Parameters
none
Return values
error status

Definition at line 811 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ audio_codec_loop()

error_status audio_codec_loop ( void )

audio codec loop

Parameters
none
Return values
none

Definition at line 870 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ audio_codec_mic_alt_setting()

void audio_codec_mic_alt_setting ( uint32_t alt_seting )

audio codec microphone alt setting config

Parameters
none
Return values
none

Definition at line 173 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ audio_codec_mic_get_data()

uint32_t audio_codec_mic_get_data ( uint8_t * buffer )

codec microphone get data

Parameters
data data buffer
Return values
data len

Definition at line 286 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ audio_codec_modify_freq()

void audio_codec_modify_freq ( uint32_t freq )

audio codec modify freq

Parameters
freq freq (wm8988 microphone and speaker must as same freq)
Return values
none

Definition at line 346 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

Referenced by audio_codec_set_mic_freq(), and audio_codec_set_spk_freq().

◆ audio_codec_set_mic_freq()

void audio_codec_set_mic_freq ( uint32_t freq )

audio codec set microphone freq

Parameters
freq freq (wm8988 microphone and speaker must same freq)
Return values
none

Definition at line 125 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ audio_codec_set_mic_mute()

void audio_codec_set_mic_mute ( uint8_t mute )

audio codec set microphone mute

Parameters
mute mute state
Return values
none

Definition at line 188 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ audio_codec_set_mic_volume()

void audio_codec_set_mic_volume ( uint16_t volume )

audio codec set microphone volume

Parameters
volume the new volume
Return values
none

Definition at line 210 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ audio_codec_set_spk_freq()

void audio_codec_set_spk_freq ( uint32_t freq )

audio codec set speaker freq

Parameters
freq freq(wm8988 microphone and speaker must same freq)
Return values
none

Definition at line 141 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ audio_codec_set_spk_mute()

void audio_codec_set_spk_mute ( uint8_t mute )

audio codec set speaker mute

Parameters
mute mute state
Return values
none

Definition at line 199 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ audio_codec_set_spk_volume()

void audio_codec_set_spk_volume ( uint16_t volume )

audio codec set speaker volume

Parameters
volume the new volume
Return values
none

Definition at line 221 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ audio_codec_spk_alt_setting()

void audio_codec_spk_alt_setting ( uint32_t alt_seting )

audio codec speaker alt setting config

Parameters
none
Return values
none

Definition at line 158 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ audio_codec_spk_feedback()

uint8_t audio_codec_spk_feedback ( uint8_t * feedback )

codec speaker feedback

Parameters
feedback data buffer
Return values
feedback len

Definition at line 232 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ audio_codec_spk_fifo_write()

void audio_codec_spk_fifo_write | ( | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

codec speaker write fifo

audio codec interface

Parameters
data | data buffer
len | data length
Return values
none

Definition at line 248 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c.

◆ DMA1_Channel3_IRQHandler()

void DMA1_Channel3_IRQHandler ( void )

this function handles dma1 channel3 interrupt.

Parameters
none
Return values
none

Definition at line 666 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ DMA1_Channel4_IRQHandler()

void DMA1_Channel4_IRQHandler ( void )

this function handles dma1 channel4 interrupt.

Parameters
none
Return values
none

Definition at line 741 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c.

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 10

< gpio pins number 11

< gpio pins number 10

< gpio pins number 11

Definition at line 403 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f435/examples/usb_device/audio/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c.

◆ OTG_IRQ_HANDLER()

void OTG_IRQ_HANDLER ( void )

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 269 of file project/at_start_f435/examples/usb_device/audio/src/main.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc sof signal select: otg1

< acc hick trim

< acc sof signal select: otg1

< acc hick trim

Definition at line 101 of file project/at_start_f435/examples/usb_device/audio/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb low power wakeup handler enable

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 279 of file project/at_start_f435/examples/usb_device/audio/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 290 of file project/at_start_f435/examples/usb_device/audio/src/main.c.

◆ usb_gpio_config()

void usb_gpio_config ( void )

this function config gpio.

Parameters
none
Return values
none

Definition at line 193 of file project/at_start_f435/examples/usb_device/audio/src/main.c.

Referenced by main().

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

Variable Documentation

◆ audio_codec [1/2]

audio_codec_type audio_codec

Definition at line 110 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

Referenced by audio_codec_init(), audio_codec_loop(), audio_codec_mic_get_data(), audio_codec_set_mic_freq(), audio_codec_set_mic_mute(), audio_codec_set_mic_volume(), audio_codec_set_spk_freq(), audio_codec_set_spk_mute(), audio_codec_set_spk_volume(), audio_codec_spk_feedback(), audio_codec_spk_fifo_write(), DMA1_Channel3_IRQHandler(), and DMA1_Channel4_IRQHandler().

◆ audio_codec [2/2]

audio_codec_type audio_codec

Definition at line 110 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

Referenced by audio_codec_init(), audio_codec_loop(), audio_codec_mic_get_data(), audio_codec_set_mic_freq(), audio_codec_set_mic_mute(), audio_codec_set_mic_volume(), audio_codec_set_spk_freq(), audio_codec_set_spk_mute(), audio_codec_set_spk_volume(), audio_codec_spk_feedback(), and audio_codec_spk_fifo_write().

◆ hi2cx [1/2]

i2c_handle_type hi2cx

Definition at line 108 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

Referenced by audio_codec_init(), audio_codec_loop(), and audio_codec_modify_freq().

◆ hi2cx [2/2]

i2c_handle_type hi2cx

Definition at line 108 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

Referenced by audio_codec_init(), audio_codec_loop(), and audio_codec_modify_freq().

◆ mic_dma_buffer [1/2]

uint16_t mic_dma_buffer[DMA_BUFFER_SIZE]

Definition at line 112 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

Referenced by codec_i2s_init(), and DMA1_Channel4_IRQHandler().

◆ mic_dma_buffer [2/2]

uint16_t mic_dma_buffer[DMA_BUFFER_SIZE]

Definition at line 112 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

◆ otg_core_struct [1/2]

otg_core_type otg_core_struct

Definition at line 45 of file project/at_start_f435/examples/usb_device/audio/src/main.c.

Referenced by main(), and OTG_IRQ_HANDLER().

◆ otg_core_struct [2/2]

otg_core_type otg_core_struct

Definition at line 45 of file project/at_start_f437/examples/usb_device/audio/src/main.c.

◆ reg_addr_data [1/2]

uint16_t reg_addr_data[]

wm8988 register default value

Definition at line 75 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

Referenced by audio_codec_init().

◆ reg_addr_data [2/2]

uint16_t reg_addr_data[]

wm8988 register default value

Definition at line 75 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

Referenced by audio_codec_init().

◆ spk_dma_buffer [1/2]

uint16_t spk_dma_buffer[DMA_BUFFER_SIZE]

Definition at line 111 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

Referenced by codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ spk_dma_buffer [2/2]

uint16_t spk_dma_buffer[DMA_BUFFER_SIZE]

Definition at line 111 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.


AT32F435/437 Firmwary Library: USB_device_audio_codec_reg_definition

Macros
USB_device_audio_codec_reg_definition
AT32F435_periph_examples | AT32F437_periph_examples » USB_device_audio

Macros

#define | WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/
#define | WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/
#define | WM8988_R2_LOUT1_VOLUME 0x02
#define | WM8988_R3_ROUT1_VOLUME 0x03
#define | WM8988_R4_RESERVED 0x04
#define | WM8988_R5_ADC_DAC_CONTROL 0x05
#define | WM8988_R6_RESERVED 0x06
#define | WM8988_R7_AUDIO_INTERFACE 0x07
#define | WM8988_R8_SAMPLE_RATE 0x08
#define | WM8988_R9_RESERVED 0x09
#define | WM8988_R10_LEFT_DAC_VOLUME 0x0A
#define | WM8988_R11_RIGHT_DAC_VOLUME 0x0B
#define | WM8988_R12_BASS_CONTROL 0x0C
#define | WM8988_R13_TREBLE_CONTROL 0x0D
#define | WM8988_R14_
#define | WM8988_R15_RESET 0x0F
#define | WM8988_R16_3D_CONTROL 0x10
#define | WM8988_R17_ALC1 0x11
#define | WM8988_R18_ALC2 0x12
#define | WM8988_R19_ALC3 0x13
#define | WM8988_R20_NOISE_GATE 0x14
#define | WM8988_R21_LEFT_ADC_VOLUME 0x15
#define | WM8988_R22_RIGHT_ADC_VOLUME 0x16
#define | WM8988_R23_ADDITIONAL_1_CONTROL 0x17
#define | WM8988_R24_ADDITIONAL_2_CONTROL 0x18
#define | WM8988_R25_PWR_1_MGMT 0x19
#define | WM8988_R26_PWR_2_MGMT 0x1A
#define | WM8988_R27_ADDITIONAL_3_CONTROL 0x1B
#define | WM8988_R31_ADC_INPUT_MODE 0x1F
#define | WM8988_R32_ADC_L_SIGNAL_PATH 0x20
#define | WM8988_R33_ADC_R_SIGNAL_PATH 0x21
#define | WM8988_R34_LEFT_OUT_MIX_1 0x22
#define | WM8988_R35_LEFT_OUT_MIX_2 0x23
#define | WM8988_R36_RIGHT_OUT_MIX_1 0x24
#define | WM8988_R37_RIGHT_OUT_MIX_2 0x25
#define | WM8988_R38_RESERVED
#define | WM8988_R39_RESERVED
#define | WM8988_R40_LOUT2_VOLUME 0x28
#define | WM8988_R41_ROUT2_VOLUME 0x29
#define | WM8988_R42_RESERVED
#define | WM8988_R43_LOW_POWER_PALYBACK 0x43
#define | WM8988_I2C_ADDR_CSB_LOW 0x34
#define | WM8988_I2C_ADDR_CSB_HIGH 0x36
#define | WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/
#define | WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/
#define | WM8988_R2_LOUT1_VOLUME 0x02
#define | WM8988_R3_ROUT1_VOLUME 0x03
#define | WM8988_R4_RESERVED 0x04
#define | WM8988_R5_ADC_DAC_CONTROL 0x05
#define | WM8988_R6_RESERVED 0x06
#define | WM8988_R7_AUDIO_INTERFACE 0x07
#define | WM8988_R8_SAMPLE_RATE 0x08
#define | WM8988_R9_RESERVED 0x09
#define | WM8988_R10_LEFT_DAC_VOLUME 0x0A
#define | WM8988_R11_RIGHT_DAC_VOLUME 0x0B
#define | WM8988_R12_BASS_CONTROL 0x0C
#define | WM8988_R13_TREBLE_CONTROL 0x0D
#define | WM8988_R14_
#define | WM8988_R15_RESET 0x0F
#define | WM8988_R16_3D_CONTROL 0x10
#define | WM8988_R17_ALC1 0x11
#define | WM8988_R18_ALC2 0x12
#define | WM8988_R19_ALC3 0x13
#define | WM8988_R20_NOISE_GATE 0x14
#define | WM8988_R21_LEFT_ADC_VOLUME 0x15
#define | WM8988_R22_RIGHT_ADC_VOLUME 0x16
#define | WM8988_R23_ADDITIONAL_1_CONTROL 0x17
#define | WM8988_R24_ADDITIONAL_2_CONTROL 0x18
#define | WM8988_R25_PWR_1_MGMT 0x19
#define | WM8988_R26_PWR_2_MGMT 0x1A
#define | WM8988_R27_ADDITIONAL_3_CONTROL 0x1B
#define | WM8988_R31_ADC_INPUT_MODE 0x1F
#define | WM8988_R32_ADC_L_SIGNAL_PATH 0x20
#define | WM8988_R33_ADC_R_SIGNAL_PATH 0x21
#define | WM8988_R34_LEFT_OUT_MIX_1 0x22
#define | WM8988_R35_LEFT_OUT_MIX_2 0x23
#define | WM8988_R36_RIGHT_OUT_MIX_1 0x24
#define | WM8988_R37_RIGHT_OUT_MIX_2 0x25
#define | WM8988_R38_RESERVED
#define | WM8988_R39_RESERVED
#define | WM8988_R40_LOUT2_VOLUME 0x28
#define | WM8988_R41_ROUT2_VOLUME 0x29
#define | WM8988_R42_RESERVED
#define | WM8988_R43_LOW_POWER_PALYBACK 0x43
#define | WM8988_I2C_ADDR_CSB_LOW 0x34
#define | WM8988_I2C_ADDR_CSB_HIGH 0x36

Detailed Description

Macro Definition Documentation

◆ WM8988_I2C_ADDR_CSB_HIGH [1/2]

#define WM8988_I2C_ADDR_CSB_HIGH 0x36

Definition at line 94 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_I2C_ADDR_CSB_HIGH [2/2]

#define WM8988_I2C_ADDR_CSB_HIGH 0x36

Definition at line 94 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_I2C_ADDR_CSB_LOW [1/2]

#define WM8988_I2C_ADDR_CSB_LOW 0x34

Definition at line 93 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_I2C_ADDR_CSB_LOW [2/2]

#define WM8988_I2C_ADDR_CSB_LOW 0x34

Definition at line 93 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R0_LEFT_INPUT_VOLUME [1/2]

#define WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/

Definition at line 50 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R0_LEFT_INPUT_VOLUME [2/2]

#define WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/

Definition at line 50 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R10_LEFT_DAC_VOLUME [1/2]

#define WM8988_R10_LEFT_DAC_VOLUME 0x0A

Definition at line 60 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R10_LEFT_DAC_VOLUME [2/2]

#define WM8988_R10_LEFT_DAC_VOLUME 0x0A

Definition at line 60 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R11_RIGHT_DAC_VOLUME [1/2]

#define WM8988_R11_RIGHT_DAC_VOLUME 0x0B

Definition at line 61 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R11_RIGHT_DAC_VOLUME [2/2]

#define WM8988_R11_RIGHT_DAC_VOLUME 0x0B

Definition at line 61 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R12_BASS_CONTROL [1/2]

#define WM8988_R12_BASS_CONTROL 0x0C

Definition at line 62 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R12_BASS_CONTROL [2/2]

#define WM8988_R12_BASS_CONTROL 0x0C

Definition at line 62 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R13_TREBLE_CONTROL [1/2]

#define WM8988_R13_TREBLE_CONTROL 0x0D

Definition at line 63 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R13_TREBLE_CONTROL [2/2]

#define WM8988_R13_TREBLE_CONTROL 0x0D

Definition at line 63 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R14_ [1/2]

#define WM8988_R14_

Definition at line 64 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R14_ [2/2]

#define WM8988_R14_

Definition at line 64 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R15_RESET [1/2]

#define WM8988_R15_RESET 0x0F

Definition at line 65 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R15_RESET [2/2]

#define WM8988_R15_RESET 0x0F

Definition at line 65 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R16_3D_CONTROL [1/2]

#define WM8988_R16_3D_CONTROL 0x10

Definition at line 66 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R16_3D_CONTROL [2/2]

#define WM8988_R16_3D_CONTROL 0x10

Definition at line 66 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R17_ALC1 [1/2]

#define WM8988_R17_ALC1 0x11

Definition at line 67 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R17_ALC1 [2/2]

#define WM8988_R17_ALC1 0x11

Definition at line 67 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R18_ALC2 [1/2]

#define WM8988_R18_ALC2 0x12

Definition at line 68 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R18_ALC2 [2/2]

#define WM8988_R18_ALC2 0x12

Definition at line 68 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R19_ALC3 [1/2]

#define WM8988_R19_ALC3 0x13

Definition at line 69 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R19_ALC3 [2/2]

#define WM8988_R19_ALC3 0x13

Definition at line 69 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R1_RIGHT_INPUT_VOLUME [1/2]

#define WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/

Definition at line 51 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R1_RIGHT_INPUT_VOLUME [2/2]

#define WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/

Definition at line 51 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R20_NOISE_GATE [1/2]

#define WM8988_R20_NOISE_GATE 0x14

Definition at line 70 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R20_NOISE_GATE [2/2]

#define WM8988_R20_NOISE_GATE 0x14

Definition at line 70 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R21_LEFT_ADC_VOLUME [1/2]

#define WM8988_R21_LEFT_ADC_VOLUME 0x15

Definition at line 71 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R21_LEFT_ADC_VOLUME [2/2]

#define WM8988_R21_LEFT_ADC_VOLUME 0x15

Definition at line 71 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R22_RIGHT_ADC_VOLUME [1/2]

#define WM8988_R22_RIGHT_ADC_VOLUME 0x16

Definition at line 72 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R22_RIGHT_ADC_VOLUME [2/2]

#define WM8988_R22_RIGHT_ADC_VOLUME 0x16

Definition at line 72 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R23_ADDITIONAL_1_CONTROL [1/2]

#define WM8988_R23_ADDITIONAL_1_CONTROL 0x17

Definition at line 73 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R23_ADDITIONAL_1_CONTROL [2/2]

#define WM8988_R23_ADDITIONAL_1_CONTROL 0x17

Definition at line 73 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R24_ADDITIONAL_2_CONTROL [1/2]

#define WM8988_R24_ADDITIONAL_2_CONTROL 0x18

Definition at line 74 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R24_ADDITIONAL_2_CONTROL [2/2]

#define WM8988_R24_ADDITIONAL_2_CONTROL 0x18

Definition at line 74 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R25_PWR_1_MGMT [1/2]

#define WM8988_R25_PWR_1_MGMT 0x19

Definition at line 75 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R25_PWR_1_MGMT [2/2]

#define WM8988_R25_PWR_1_MGMT 0x19

Definition at line 75 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R26_PWR_2_MGMT [1/2]

#define WM8988_R26_PWR_2_MGMT 0x1A

Definition at line 76 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R26_PWR_2_MGMT [2/2]

#define WM8988_R26_PWR_2_MGMT 0x1A

Definition at line 76 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R27_ADDITIONAL_3_CONTROL [1/2]

#define WM8988_R27_ADDITIONAL_3_CONTROL 0x1B

Definition at line 77 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R27_ADDITIONAL_3_CONTROL [2/2]

#define WM8988_R27_ADDITIONAL_3_CONTROL 0x1B

Definition at line 77 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R2_LOUT1_VOLUME [1/2]

#define WM8988_R2_LOUT1_VOLUME 0x02

Definition at line 52 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R2_LOUT1_VOLUME [2/2]

#define WM8988_R2_LOUT1_VOLUME 0x02

Definition at line 52 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R31_ADC_INPUT_MODE [1/2]

#define WM8988_R31_ADC_INPUT_MODE 0x1F

Definition at line 79 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R31_ADC_INPUT_MODE [2/2]

#define WM8988_R31_ADC_INPUT_MODE 0x1F

Definition at line 79 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R32_ADC_L_SIGNAL_PATH [1/2]

#define WM8988_R32_ADC_L_SIGNAL_PATH 0x20

Definition at line 80 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R32_ADC_L_SIGNAL_PATH [2/2]

#define WM8988_R32_ADC_L_SIGNAL_PATH 0x20

Definition at line 80 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R33_ADC_R_SIGNAL_PATH [1/2]

#define WM8988_R33_ADC_R_SIGNAL_PATH 0x21

Definition at line 81 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R33_ADC_R_SIGNAL_PATH [2/2]

#define WM8988_R33_ADC_R_SIGNAL_PATH 0x21

Definition at line 81 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R34_LEFT_OUT_MIX_1 [1/2]

#define WM8988_R34_LEFT_OUT_MIX_1 0x22

Definition at line 82 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R34_LEFT_OUT_MIX_1 [2/2]

#define WM8988_R34_LEFT_OUT_MIX_1 0x22

Definition at line 82 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R35_LEFT_OUT_MIX_2 [1/2]

#define WM8988_R35_LEFT_OUT_MIX_2 0x23

Definition at line 83 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R35_LEFT_OUT_MIX_2 [2/2]

#define WM8988_R35_LEFT_OUT_MIX_2 0x23

Definition at line 83 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R36_RIGHT_OUT_MIX_1 [1/2]

#define WM8988_R36_RIGHT_OUT_MIX_1 0x24

Definition at line 84 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R36_RIGHT_OUT_MIX_1 [2/2]

#define WM8988_R36_RIGHT_OUT_MIX_1 0x24

Definition at line 84 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R37_RIGHT_OUT_MIX_2 [1/2]

#define WM8988_R37_RIGHT_OUT_MIX_2 0x25

Definition at line 85 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R37_RIGHT_OUT_MIX_2 [2/2]

#define WM8988_R37_RIGHT_OUT_MIX_2 0x25

Definition at line 85 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R38_RESERVED [1/2]

#define WM8988_R38_RESERVED

Definition at line 86 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R38_RESERVED [2/2]

#define WM8988_R38_RESERVED

Definition at line 86 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R39_RESERVED [1/2]

#define WM8988_R39_RESERVED

Definition at line 87 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R39_RESERVED [2/2]

#define WM8988_R39_RESERVED

Definition at line 87 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R3_ROUT1_VOLUME [1/2]

#define WM8988_R3_ROUT1_VOLUME 0x03

Definition at line 53 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R3_ROUT1_VOLUME [2/2]

#define WM8988_R3_ROUT1_VOLUME 0x03

Definition at line 53 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R40_LOUT2_VOLUME [1/2]

#define WM8988_R40_LOUT2_VOLUME 0x28

Definition at line 88 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R40_LOUT2_VOLUME [2/2]

#define WM8988_R40_LOUT2_VOLUME 0x28

Definition at line 88 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R41_ROUT2_VOLUME [1/2]

#define WM8988_R41_ROUT2_VOLUME 0x29

Definition at line 89 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R41_ROUT2_VOLUME [2/2]

#define WM8988_R41_ROUT2_VOLUME 0x29

Definition at line 89 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R42_RESERVED [1/2]

#define WM8988_R42_RESERVED

Definition at line 90 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R42_RESERVED [2/2]

#define WM8988_R42_RESERVED

Definition at line 90 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R43_LOW_POWER_PALYBACK [1/2]

#define WM8988_R43_LOW_POWER_PALYBACK 0x43

Definition at line 91 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R43_LOW_POWER_PALYBACK [2/2]

#define WM8988_R43_LOW_POWER_PALYBACK 0x43

Definition at line 91 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R4_RESERVED [1/2]

#define WM8988_R4_RESERVED 0x04

Definition at line 54 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R4_RESERVED [2/2]

#define WM8988_R4_RESERVED 0x04

Definition at line 54 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R5_ADC_DAC_CONTROL [1/2]

#define WM8988_R5_ADC_DAC_CONTROL 0x05

Definition at line 55 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R5_ADC_DAC_CONTROL [2/2]

#define WM8988_R5_ADC_DAC_CONTROL 0x05

Definition at line 55 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R6_RESERVED [1/2]

#define WM8988_R6_RESERVED 0x06

Definition at line 56 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R6_RESERVED [2/2]

#define WM8988_R6_RESERVED 0x06

Definition at line 56 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R7_AUDIO_INTERFACE [1/2]

#define WM8988_R7_AUDIO_INTERFACE 0x07

Definition at line 57 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R7_AUDIO_INTERFACE [2/2]

#define WM8988_R7_AUDIO_INTERFACE 0x07

Definition at line 57 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R8_SAMPLE_RATE [1/2]

#define WM8988_R8_SAMPLE_RATE 0x08

Definition at line 58 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R8_SAMPLE_RATE [2/2]

#define WM8988_R8_SAMPLE_RATE 0x08

Definition at line 58 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R9_RESERVED [1/2]

#define WM8988_R9_RESERVED 0x09

Definition at line 59 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ WM8988_R9_RESERVED [2/2]

#define WM8988_R9_RESERVED 0x09

Definition at line 59 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.


AT32F435/437 Firmwary Library: USB_device_audio_codec_pin_definition

Macros
USB_device_audio_codec_pin_definition
AT32F435_periph_examples | AT32F437_periph_examples » USB_device_audio

Macros

#define | I2S1_WS_PIN GPIO_PINS_4
#define | I2S1_WS_PIN_SOURCE GPIO_PINS_SOURCE4
#define | I2S1_WS_GPIO_MUX GPIO_MUX_5
#define | I2S1_CK_PIN GPIO_PINS_5
#define | I2S1_CK_PIN_SOURCE GPIO_PINS_SOURCE5
#define | I2S1_CK_GPIO_MUX GPIO_MUX_5
#define | I2S1_SD_PIN GPIO_PINS_7
#define | I2S1_SD_PIN_SOURCE GPIO_PINS_SOURCE7
#define | I2S1_SD_GPIO_MUX GPIO_MUX_5
#define | I2S1_GPIO GPIOA
#define | I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
#define | I2S1_DT_ADDRESS (&(SPI1->dt))
#define | I2S2_WS_PIN GPIO_PINS_0
#define | I2S2_WS_PIN_SOURCE GPIO_PINS_SOURCE0
#define | I2S2_WS_GPIO_MUX GPIO_MUX_7
#define | I2S2_CK_PIN GPIO_PINS_1
#define | I2S2_CK_PIN_SOURCE GPIO_PINS_SOURCE1
#define | I2S2_CK_GPIO_MUX GPIO_MUX_6
#define | I2S2_SD_PIN GPIO_PINS_4
#define | I2S2_SD_PIN_SOURCE GPIO_PINS_SOURCE4
#define | I2S2_SD_GPIO_MUX GPIO_MUX_6
#define | I2S2_GPIO GPIOD
#define | I2S2_GPIO_CRM_CLK CRM_GPIOD_PERIPH_CLOCK
#define | I2S2_DT_ADDRESS (&(SPI2->dt))
#define | SPK_TX_FIFO_SIZE (1024 * 4)
#define | I2S1_WS_PIN GPIO_PINS_4
#define | I2S1_WS_PIN_SOURCE GPIO_PINS_SOURCE4
#define | I2S1_WS_GPIO_MUX GPIO_MUX_5
#define | I2S1_CK_PIN GPIO_PINS_5
#define | I2S1_CK_PIN_SOURCE GPIO_PINS_SOURCE5
#define | I2S1_CK_GPIO_MUX GPIO_MUX_5
#define | I2S1_SD_PIN GPIO_PINS_7
#define | I2S1_SD_PIN_SOURCE GPIO_PINS_SOURCE7
#define | I2S1_SD_GPIO_MUX GPIO_MUX_5
#define | I2S1_GPIO GPIOA
#define | I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
#define | I2S1_DT_ADDRESS (&(SPI1->dt))
#define | I2S2_WS_PIN GPIO_PINS_0
#define | I2S2_WS_PIN_SOURCE GPIO_PINS_SOURCE0
#define | I2S2_WS_GPIO_MUX GPIO_MUX_7
#define | I2S2_CK_PIN GPIO_PINS_1
#define | I2S2_CK_PIN_SOURCE GPIO_PINS_SOURCE1
#define | I2S2_CK_GPIO_MUX GPIO_MUX_6
#define | I2S2_SD_PIN GPIO_PINS_4
#define | I2S2_SD_PIN_SOURCE GPIO_PINS_SOURCE4
#define | I2S2_SD_GPIO_MUX GPIO_MUX_6
#define | I2S2_GPIO GPIOD
#define | I2S2_GPIO_CRM_CLK CRM_GPIOD_PERIPH_CLOCK
#define | I2S2_DT_ADDRESS (&(SPI2->dt))
#define | SPK_TX_FIFO_SIZE (1024 * 4)

Detailed Description

Macro Definition Documentation

◆ I2S1_CK_GPIO_MUX [1/2]

#define I2S1_CK_GPIO_MUX GPIO_MUX_5

Definition at line 109 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S1_CK_GPIO_MUX [2/2]

#define I2S1_CK_GPIO_MUX GPIO_MUX_5

Definition at line 109 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S1_CK_PIN [1/2]

#define I2S1_CK_PIN GPIO_PINS_5

Definition at line 107 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S1_CK_PIN [2/2]

#define I2S1_CK_PIN GPIO_PINS_5

Definition at line 107 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S1_CK_PIN_SOURCE [1/2]

#define I2S1_CK_PIN_SOURCE GPIO_PINS_SOURCE5

Definition at line 108 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S1_CK_PIN_SOURCE [2/2]

#define I2S1_CK_PIN_SOURCE GPIO_PINS_SOURCE5

Definition at line 108 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S1_DT_ADDRESS [1/2]

#define I2S1_DT_ADDRESS (&(SPI1->dt))

Definition at line 117 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S1_DT_ADDRESS [2/2]

#define I2S1_DT_ADDRESS (&(SPI1->dt))

Definition at line 117 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S1_GPIO [1/2]

#define I2S1_GPIO GPIOA

Definition at line 115 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S1_GPIO [2/2]

#define I2S1_GPIO GPIOA

Definition at line 115 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S1_GPIO_CRM_CLK [1/2]

#define I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 116 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S1_GPIO_CRM_CLK [2/2]

#define I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 116 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S1_SD_GPIO_MUX [1/2]

#define I2S1_SD_GPIO_MUX GPIO_MUX_5

Definition at line 113 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S1_SD_GPIO_MUX [2/2]

#define I2S1_SD_GPIO_MUX GPIO_MUX_5

Definition at line 113 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S1_SD_PIN [1/2]

#define I2S1_SD_PIN GPIO_PINS_7

Definition at line 111 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S1_SD_PIN [2/2]

#define I2S1_SD_PIN GPIO_PINS_7

Definition at line 111 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S1_SD_PIN_SOURCE [1/2]

#define I2S1_SD_PIN_SOURCE GPIO_PINS_SOURCE7

Definition at line 112 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S1_SD_PIN_SOURCE [2/2]

#define I2S1_SD_PIN_SOURCE GPIO_PINS_SOURCE7

Definition at line 112 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S1_WS_GPIO_MUX [1/2]

#define I2S1_WS_GPIO_MUX GPIO_MUX_5

Definition at line 105 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S1_WS_GPIO_MUX [2/2]

#define I2S1_WS_GPIO_MUX GPIO_MUX_5

Definition at line 105 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S1_WS_PIN [1/2]

#define I2S1_WS_PIN GPIO_PINS_4

Definition at line 103 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S1_WS_PIN [2/2]

#define I2S1_WS_PIN GPIO_PINS_4

Definition at line 103 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S1_WS_PIN_SOURCE [1/2]

#define I2S1_WS_PIN_SOURCE GPIO_PINS_SOURCE4

Definition at line 104 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S1_WS_PIN_SOURCE [2/2]

#define I2S1_WS_PIN_SOURCE GPIO_PINS_SOURCE4

Definition at line 104 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S2_CK_GPIO_MUX [1/2]

#define I2S2_CK_GPIO_MUX GPIO_MUX_6

Definition at line 126 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S2_CK_GPIO_MUX [2/2]

#define I2S2_CK_GPIO_MUX GPIO_MUX_6

Definition at line 126 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S2_CK_PIN [1/2]

#define I2S2_CK_PIN GPIO_PINS_1

Definition at line 124 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S2_CK_PIN [2/2]

#define I2S2_CK_PIN GPIO_PINS_1

Definition at line 124 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S2_CK_PIN_SOURCE [1/2]

#define I2S2_CK_PIN_SOURCE GPIO_PINS_SOURCE1

Definition at line 125 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S2_CK_PIN_SOURCE [2/2]

#define I2S2_CK_PIN_SOURCE GPIO_PINS_SOURCE1

Definition at line 125 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S2_DT_ADDRESS [1/2]

#define I2S2_DT_ADDRESS (&(SPI2->dt))

Definition at line 134 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S2_DT_ADDRESS [2/2]

#define I2S2_DT_ADDRESS (&(SPI2->dt))

Definition at line 134 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S2_GPIO [1/2]

#define I2S2_GPIO GPIOD

Definition at line 132 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S2_GPIO [2/2]

#define I2S2_GPIO GPIOD

Definition at line 132 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S2_GPIO_CRM_CLK [1/2]

#define I2S2_GPIO_CRM_CLK CRM_GPIOD_PERIPH_CLOCK

Definition at line 133 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S2_GPIO_CRM_CLK [2/2]

#define I2S2_GPIO_CRM_CLK CRM_GPIOD_PERIPH_CLOCK

Definition at line 133 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S2_SD_GPIO_MUX [1/2]

#define I2S2_SD_GPIO_MUX GPIO_MUX_6

Definition at line 130 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S2_SD_GPIO_MUX [2/2]

#define I2S2_SD_GPIO_MUX GPIO_MUX_6

Definition at line 130 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S2_SD_PIN [1/2]

#define I2S2_SD_PIN GPIO_PINS_4

Definition at line 128 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S2_SD_PIN [2/2]

#define I2S2_SD_PIN GPIO_PINS_4

Definition at line 128 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S2_SD_PIN_SOURCE [1/2]

#define I2S2_SD_PIN_SOURCE GPIO_PINS_SOURCE4

Definition at line 129 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S2_SD_PIN_SOURCE [2/2]

#define I2S2_SD_PIN_SOURCE GPIO_PINS_SOURCE4

Definition at line 129 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S2_WS_GPIO_MUX [1/2]

#define I2S2_WS_GPIO_MUX GPIO_MUX_7

Definition at line 122 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S2_WS_GPIO_MUX [2/2]

#define I2S2_WS_GPIO_MUX GPIO_MUX_7

Definition at line 122 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S2_WS_PIN [1/2]

#define I2S2_WS_PIN GPIO_PINS_0

Definition at line 120 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S2_WS_PIN [2/2]

#define I2S2_WS_PIN GPIO_PINS_0

Definition at line 120 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S2_WS_PIN_SOURCE [1/2]

#define I2S2_WS_PIN_SOURCE GPIO_PINS_SOURCE0

Definition at line 121 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ I2S2_WS_PIN_SOURCE [2/2]

#define I2S2_WS_PIN_SOURCE GPIO_PINS_SOURCE0

Definition at line 121 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ SPK_TX_FIFO_SIZE [1/2]

#define SPK_TX_FIFO_SIZE (1024 * 4)

Definition at line 136 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ SPK_TX_FIFO_SIZE [2/2]

#define SPK_TX_FIFO_SIZE (1024 * 4)

Definition at line 136 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.


AT32F435/437 Firmwary Library: USB_device_audio_codec_exported_functions

Data Structures | Macros | Functions
USB_device_audio_codec_exported_functions
AT32F435_periph_examples | AT32F437_periph_examples » USB_device_audio

Data Structures

struct audio_codec_type

Macros

#define | MIC_BUFFER_SIZE 1024
#define | SPK_BUFFER_SIZE 4096
#define | DMA_BUFFER_SIZE 288
#define | MIC_BUFFER_SIZE 1024
#define | SPK_BUFFER_SIZE 4096
#define | DMA_BUFFER_SIZE 288

Functions

error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
audio codec interface More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...

Detailed Description

Macro Definition Documentation

◆ DMA_BUFFER_SIZE [1/2]

#define DMA_BUFFER_SIZE 288

Definition at line 147 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ DMA_BUFFER_SIZE [2/2]

#define DMA_BUFFER_SIZE 288

Definition at line 147 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ MIC_BUFFER_SIZE [1/2]

#define MIC_BUFFER_SIZE 1024

Definition at line 145 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ MIC_BUFFER_SIZE [2/2]

#define MIC_BUFFER_SIZE 1024

Definition at line 145 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

◆ SPK_BUFFER_SIZE [1/2]

#define SPK_BUFFER_SIZE 4096

Definition at line 146 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ SPK_BUFFER_SIZE [2/2]

#define SPK_BUFFER_SIZE 4096

Definition at line 146 of file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.

Function Documentation

◆ audio_codec_init()

error_status audio_codec_init ( void )

audio codec init

Parameters
none
Return values
error status

Definition at line 811 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

Referenced by main().

◆ audio_codec_loop()

error_status audio_codec_loop ( void )

audio codec loop

Parameters
none
Return values
none

Definition at line 870 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

Referenced by main().

◆ audio_codec_mic_alt_setting()

void audio_codec_mic_alt_setting ( uint32_t alt_seting )

audio codec microphone alt setting config

Parameters
none
Return values
none

Definition at line 173 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

Referenced by audio_set_interface(), and class_event_handler().

◆ audio_codec_mic_get_data()

uint32_t audio_codec_mic_get_data ( uint8_t * buffer )

codec microphone get data

Parameters
data data buffer
Return values
data len

Definition at line 286 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

Referenced by audio_inisoincom_event(), audio_set_interface(), and class_in_handler().

◆ audio_codec_modify_freq()

void audio_codec_modify_freq ( uint32_t freq )

audio codec modify freq

Parameters
freq freq (wm8988 microphone and speaker must as same freq)
Return values
none

Definition at line 346 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

Referenced by audio_codec_set_mic_freq(), and audio_codec_set_spk_freq().

◆ audio_codec_set_mic_freq()

void audio_codec_set_mic_freq ( uint32_t freq )

audio codec set microphone freq

Parameters
freq freq (wm8988 microphone and speaker must same freq)
Return values
none

Definition at line 125 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_mic_mute()

void audio_codec_set_mic_mute ( uint8_t mute )

audio codec set microphone mute

Parameters
mute mute state
Return values
none

Definition at line 188 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_mic_volume()

void audio_codec_set_mic_volume ( uint16_t volume )

audio codec set microphone volume

Parameters
volume the new volume
Return values
none

Definition at line 210 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_spk_freq()

void audio_codec_set_spk_freq ( uint32_t freq )

audio codec set speaker freq

Parameters
freq freq(wm8988 microphone and speaker must same freq)
Return values
none

Definition at line 141 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_spk_mute()

void audio_codec_set_spk_mute ( uint8_t mute )

audio codec set speaker mute

Parameters
mute mute state
Return values
none

Definition at line 199 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_spk_volume()

void audio_codec_set_spk_volume ( uint16_t volume )

audio codec set speaker volume

Parameters
volume the new volume
Return values
none

Definition at line 221 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_spk_alt_setting()

void audio_codec_spk_alt_setting ( uint32_t alt_seting )

audio codec speaker alt setting config

Parameters
none
Return values
none

Definition at line 158 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

Referenced by audio_set_interface(), and class_event_handler().

◆ audio_codec_spk_feedback()

uint8_t audio_codec_spk_feedback ( uint8_t * feedback )

codec speaker feedback

Parameters
feedback data buffer
Return values
feedback len

Definition at line 232 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

Referenced by class_sof_handler().

◆ audio_codec_spk_fifo_write()

void audio_codec_spk_fifo_write | ( | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

audio codec interface

codec speaker write fifo

Parameters
data | data buffer
len | data length
Return values
none

audio codec interface

Parameters
data | data buffer
len | data length
Return values
none

Definition at line 248 of file at_start_f437/examples/usb_device/audio/src/audio_codec.c.

Referenced by class_out_handler().


AT32F435/437 Firmwary Library: audio_codec_type Struct Reference

Data Fields
audio_codec_type Struct Reference
AT32F435_periph_examples | AT32F437_periph_examples » USB_device_audio » USB_device_audio_codec_exported_functions | AT32F435_periph_examples | AT32F437_periph_examples » USB_device_audio_hid » USB_device_audio_hid_codec_exported_functions

#include <audio_codec.h>

Data Fields

uint32_t | audio_freq
uint32_t | audio_bitw
uint16_t | spk_buffer [4096]
uint16_t * | spk_roff
uint16_t * | spk_woff
uint16_t * | spk_rend
uint32_t | spk_freq
uint32_t | spk_wtotal
uint32_t | spk_rtotal
uint16_t | spk_threshold
uint16_t | spk_calc
uint8_t | spk_stage
uint16_t | mic_buffer [1024]
uint16_t * | mic_roff
uint16_t * | mic_woff
uint16_t * | mic_wend
uint32_t | mic_wtotal
uint32_t | mic_rtotal
uint32_t | mic_delta
uint16_t | mic_calc
uint16_t | mic_adj_count
uint8_t | mic_adj_stage
uint8_t | mic_stage
uint8_t | mic_mute
uint8_t | spk_mute
uint16_t | mic_volume
uint16_t | spk_volume
uint32_t | spk_tx_size
uint32_t | mic_rx_size
uint32_t | spk_enable
uint32_t | mic_enable

Detailed Description

Definition at line 149 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Field Documentation

◆ audio_bitw

uint32_t audio_codec_type::audio_bitw

Definition at line 152 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_init(), and codec_i2s_init().

◆ audio_freq

uint32_t audio_codec_type::audio_freq

Definition at line 151 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_init(), audio_codec_set_mic_freq(), audio_codec_set_spk_freq(), codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ mic_adj_count

uint16_t audio_codec_type::mic_adj_count

Definition at line 174 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), and DMA1_Channel4_IRQHandler().

◆ mic_adj_stage

uint8_t audio_codec_type::mic_adj_stage

Definition at line 175 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), and DMA1_Channel4_IRQHandler().

◆ mic_buffer

uint16_t audio_codec_type::mic_buffer

Definition at line 166 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), codec_i2s_init(), and DMA1_Channel4_IRQHandler().

◆ mic_calc

uint16_t audio_codec_type::mic_calc

Definition at line 173 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by DMA1_Channel4_IRQHandler().

◆ mic_delta

uint32_t audio_codec_type::mic_delta

Definition at line 172 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), and DMA1_Channel4_IRQHandler().

◆ mic_enable

uint32_t audio_codec_type::mic_enable

Definition at line 188 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ mic_mute

uint8_t audio_codec_type::mic_mute

Definition at line 178 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_loop(), and audio_codec_set_mic_mute().

◆ mic_roff

uint16_t * audio_codec_type::mic_roff

Definition at line 167 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), codec_i2s_init(), and DMA1_Channel4_IRQHandler().

◆ mic_rtotal

uint32_t audio_codec_type::mic_rtotal

Definition at line 171 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), and DMA1_Channel4_IRQHandler().

◆ mic_rx_size

uint32_t audio_codec_type::mic_rx_size

Definition at line 185 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), codec_i2s_init(), and DMA1_Channel4_IRQHandler().

◆ mic_stage

uint8_t audio_codec_type::mic_stage

Definition at line 176 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), and DMA1_Channel4_IRQHandler().

◆ mic_volume

uint16_t audio_codec_type::mic_volume

Definition at line 181 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_loop(), and audio_codec_set_mic_volume().

◆ mic_wend

uint16_t * audio_codec_type::mic_wend

Definition at line 169 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), codec_i2s_init(), and DMA1_Channel4_IRQHandler().

◆ mic_woff

uint16_t * audio_codec_type::mic_woff

Definition at line 168 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by codec_i2s_init(), and DMA1_Channel4_IRQHandler().

◆ mic_wtotal

uint32_t audio_codec_type::mic_wtotal

Definition at line 170 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), and DMA1_Channel4_IRQHandler().

◆ spk_buffer

uint16_t audio_codec_type::spk_buffer

Definition at line 154 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_spk_fifo_write(), codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ spk_calc

uint16_t audio_codec_type::spk_calc

Definition at line 162 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by DMA1_Channel3_IRQHandler().

◆ spk_enable

uint32_t audio_codec_type::spk_enable

Definition at line 187 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

◆ spk_freq

uint32_t audio_codec_type::spk_freq

Definition at line 158 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_spk_feedback(), codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ spk_mute

uint8_t audio_codec_type::spk_mute

Definition at line 179 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_loop(), and audio_codec_set_spk_mute().

◆ spk_rend

uint16_t * audio_codec_type::spk_rend

Definition at line 157 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_spk_fifo_write(), codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ spk_roff

uint16_t * audio_codec_type::spk_roff

Definition at line 155 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_spk_fifo_write(), codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ spk_rtotal

uint32_t audio_codec_type::spk_rtotal

Definition at line 160 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_spk_fifo_write(), and DMA1_Channel3_IRQHandler().

◆ spk_stage

uint8_t audio_codec_type::spk_stage

Definition at line 163 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_spk_fifo_write(), and DMA1_Channel3_IRQHandler().

◆ spk_threshold

uint16_t audio_codec_type::spk_threshold

Definition at line 161 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_spk_fifo_write(), and DMA1_Channel3_IRQHandler().

◆ spk_tx_size

uint32_t audio_codec_type::spk_tx_size

Definition at line 184 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ spk_volume

uint16_t audio_codec_type::spk_volume

Definition at line 182 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_loop(), and audio_codec_set_spk_volume().

◆ spk_woff

uint16_t * audio_codec_type::spk_woff

Definition at line 156 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_spk_fifo_write(), codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ spk_wtotal

uint32_t audio_codec_type::spk_wtotal

Definition at line 159 of file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.

Referenced by audio_codec_spk_fifo_write(), and DMA1_Channel3_IRQHandler().

The documentation for this struct was generated from the following files:
  • at_start_f435/examples/usb_device/audio/inc/audio_codec.h
  • at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • at_start_f437/examples/usb_device/audio/inc/audio_codec.h
  • at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h


AT32F435/437 Firmwary Library: USB_device_audio_hid

Modules | Macros | Functions | Variables
USB_device_audio_hid
AT32F435_periph_examples | AT32F437_periph_examples

Modules

USB_device_audio_hid_codec_reg_definition
USB_device_audio_hid_codec_pin_definition
USB_device_audio_hid_codec_exported_functions

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 64
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 16
#define | USBD_EP4_TX_SIZE 0
#define | USBD_EP5_TX_SIZE 0
#define | USBD_EP6_TX_SIZE 0
#define | USBD_EP7_TX_SIZE 0
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 64
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 16
#define | USBD2_EP4_TX_SIZE 0
#define | USBD2_EP5_TX_SIZE 0
#define | USBD2_EP6_TX_SIZE 0
#define | USBD2_EP7_TX_SIZE 0
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_CLKCTRL 0x80504C4E
#define | I2Cx_ADDRESS 0x00
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_8
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE8
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_MUX GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_9
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE9
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_MUX GPIO_MUX_4
#define | WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)
wm8988 freq More...
#define | WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)
#define | WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)
wm8988 bit width More...
#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 64
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 16
#define | USBD_EP4_TX_SIZE 0
#define | USBD_EP5_TX_SIZE 0
#define | USBD_EP6_TX_SIZE 0
#define | USBD_EP7_TX_SIZE 0
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 64
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 16
#define | USBD2_EP4_TX_SIZE 0
#define | USBD2_EP5_TX_SIZE 0
#define | USBD2_EP6_TX_SIZE 0
#define | USBD2_EP7_TX_SIZE 0
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_CLKCTRL 0x80504C4E
#define | I2Cx_ADDRESS 0x00
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_8
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE8
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_MUX GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_9
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE9
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_MUX GPIO_MUX_4
#define | WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)
wm8988 freq More...
#define | WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)
#define | WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)
wm8988 bit width More...

Functions

void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | memset16_buffer (uint16_t *buffer, uint32_t set, uint32_t len)
buffer memset More...
void | codec_i2s_reset (void)
audio codec i2s reset More...
void | codec_i2s_init (audio_codec_type *param)
audio codec i2s init More...
void | mclk_tmr1_init (void)
mclk clock conifg More...
void | copy_buff (uint16_t *dest, uint16_t *src, uint32_t len)
copy buffer More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
codec speaker write fifo More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | DMA1_Channel3_IRQHandler (void)
this function handles dma1 channel3 interrupt. More...
void | DMA1_Channel4_IRQHandler (void)
this function handles dma1 channel4 interrupt. More...
error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
int | main (void)
main function. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...

Variables

uint16_t | reg_addr_data []
wm8988 register default value More...
i2c_handle_type hi2cx
audio_codec_type audio_codec
uint16_t | spk_dma_buffer [DMA_BUFFER_SIZE]
uint16_t | mic_dma_buffer [DMA_BUFFER_SIZE]
otg_core_type otg_core_struct
uint8_t | report_buf [USBD_AUHID_IN_MAXPACKET_SIZE]
uint16_t | reg_addr_data []
wm8988 register default value More...
i2c_handle_type hi2cx
audio_codec_type audio_codec
uint16_t | spk_dma_buffer [DMA_BUFFER_SIZE]
uint16_t | mic_dma_buffer [DMA_BUFFER_SIZE]
otg_core_type otg_core_struct
uint8_t | report_buf [USBD_AUHID_IN_MAXPACKET_SIZE]

Detailed Description

Macro Definition Documentation

◆ I2C_TIMEOUT [1/2]

#define I2C_TIMEOUT 0xFFFFFFFF

Definition at line 41 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2C_TIMEOUT [2/2]

#define I2C_TIMEOUT 0xFFFFFFFF

Definition at line 41 of file at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_ADDRESS [1/2]

#define I2Cx_ADDRESS 0x00

Definition at line 44 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_ADDRESS [2/2]

#define I2Cx_ADDRESS 0x00

Definition at line 44 of file at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_CLK [1/2]

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 47 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_CLK [2/2]

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 47 of file at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_CLKCTRL [1/2]

#define I2Cx_CLKCTRL 0x80504C4E

Definition at line 43 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_CLKCTRL [2/2]

#define I2Cx_CLKCTRL 0x80504C4E

Definition at line 43 of file at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_PORT [1/2]

#define I2Cx_PORT I2C1

Definition at line 46 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_PORT [2/2]

#define I2Cx_PORT I2C1

Definition at line 46 of file at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_CLK [1/2]

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 49 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_CLK [2/2]

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 49 of file at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_MUX [1/2]

#define I2Cx_SCL_GPIO_MUX GPIO_MUX_4

Definition at line 53 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_MUX [2/2]

#define I2Cx_SCL_GPIO_MUX GPIO_MUX_4

Definition at line 53 of file at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_PIN [1/2]

#define I2Cx_SCL_GPIO_PIN GPIO_PINS_8

Definition at line 50 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_PIN [2/2]

#define I2Cx_SCL_GPIO_PIN GPIO_PINS_8

Definition at line 50 of file at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_PinsSource [1/2]

#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE8

Definition at line 51 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_PinsSource [2/2]

#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE8

Definition at line 51 of file at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_PORT [1/2]

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 52 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_PORT [2/2]

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 52 of file at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_CLK [1/2]

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 55 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_CLK [2/2]

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 55 of file at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_MUX [1/2]

#define I2Cx_SDA_GPIO_MUX GPIO_MUX_4

Definition at line 59 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_MUX [2/2]

#define I2Cx_SDA_GPIO_MUX GPIO_MUX_4

Definition at line 59 of file at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_PIN [1/2]

#define I2Cx_SDA_GPIO_PIN GPIO_PINS_9

Definition at line 56 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_PIN [2/2]

#define I2Cx_SDA_GPIO_PIN GPIO_PINS_9

Definition at line 56 of file at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_PinsSource [1/2]

#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE9

Definition at line 57 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_PinsSource [2/2]

#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE9

Definition at line 57 of file at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_PORT [1/2]

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 58 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_PORT [2/2]

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 58 of file at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ OTG_CLOCK [1/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 69 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_CLOCK [2/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 69 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_IRQ [1/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 70 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_IRQ [2/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 70 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [1/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 71 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [2/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 71 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_DM [1/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 82 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_DM [2/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 82 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [1/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 83 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [2/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 83 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_DP [1/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 79 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_DP [2/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 79 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [1/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 80 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [2/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 80 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_GPIO [1/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 76 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_GPIO [2/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 76 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [1/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 77 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [2/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 77 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_ID [1/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 88 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_ID [2/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 88 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [1/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 89 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [2/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 89 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_MUX [1/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 96 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_MUX [2/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 96 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_SOF [1/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 93 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_SOF [2/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 93 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [1/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 91 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [2/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 91 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [1/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 92 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [2/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 92 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [1/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 94 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [2/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 94 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_VBUS [1/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 85 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_VBUS [2/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 85 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [1/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 86 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [2/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 86 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_USB_ID [1/2]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 62 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_USB_ID [2/2]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 62 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [1/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 74 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [2/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 74 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [1/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 73 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [2/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 73 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [1/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 72 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [2/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 72 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USB_ID [1/2]

#define USB_ID 0

Definition at line 68 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USB_ID [2/2]

#define USB_ID 0

Definition at line 68 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [1/2]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore

Definition at line 198 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [2/2]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore

Definition at line 198 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [1/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 151 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [2/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 151 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [1/2]

#define USBD2_EP1_TX_SIZE 64

Definition at line 152 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [2/2]

#define USBD2_EP1_TX_SIZE 64

Definition at line 152 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [1/2]

#define USBD2_EP2_TX_SIZE 20

Definition at line 153 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [2/2]

#define USBD2_EP2_TX_SIZE 20

Definition at line 153 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [1/2]

#define USBD2_EP3_TX_SIZE 16

Definition at line 154 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [2/2]

#define USBD2_EP3_TX_SIZE 16

Definition at line 154 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [1/2]

#define USBD2_EP4_TX_SIZE 0

Definition at line 155 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [2/2]

#define USBD2_EP4_TX_SIZE 0

Definition at line 155 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [1/2]

#define USBD2_EP5_TX_SIZE 0

Definition at line 156 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [2/2]

#define USBD2_EP5_TX_SIZE 0

Definition at line 156 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [1/2]

#define USBD2_EP6_TX_SIZE 0

Definition at line 157 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [2/2]

#define USBD2_EP6_TX_SIZE 0

Definition at line 157 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [1/2]

#define USBD2_EP7_TX_SIZE 0

Definition at line 158 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [2/2]

#define USBD2_EP7_TX_SIZE 0

Definition at line 158 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD2_RX_SIZE [1/2]

#define USBD2_RX_SIZE 128

Definition at line 150 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD2_RX_SIZE [2/2]

#define USBD2_RX_SIZE 128

Definition at line 150 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [1/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 140 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [2/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 140 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [1/2]

#define USBD_EP1_TX_SIZE 64

Definition at line 141 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [2/2]

#define USBD_EP1_TX_SIZE 64

Definition at line 141 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [1/2]

#define USBD_EP2_TX_SIZE 20

Definition at line 142 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [2/2]

#define USBD_EP2_TX_SIZE 20

Definition at line 142 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [1/2]

#define USBD_EP3_TX_SIZE 16

Definition at line 143 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [2/2]

#define USBD_EP3_TX_SIZE 16

Definition at line 143 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [1/2]

#define USBD_EP4_TX_SIZE 0

Definition at line 144 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [2/2]

#define USBD_EP4_TX_SIZE 0

Definition at line 144 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [1/2]

#define USBD_EP5_TX_SIZE 0

Definition at line 145 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [2/2]

#define USBD_EP5_TX_SIZE 0

Definition at line 145 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [1/2]

#define USBD_EP6_TX_SIZE 0

Definition at line 146 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [2/2]

#define USBD_EP6_TX_SIZE 0

Definition at line 146 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [1/2]

#define USBD_EP7_TX_SIZE 0

Definition at line 147 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [2/2]

#define USBD_EP7_TX_SIZE 0

Definition at line 147 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD_RX_SIZE [1/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 139 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USBD_RX_SIZE [2/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 139 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [1/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 50 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [2/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 50 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ WM8988_REG_BITW16 [1/2]

#define WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)

wm8988 bit width

Definition at line 70 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ WM8988_REG_BITW16 [2/2]

#define WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)

wm8988 bit width

Definition at line 70 of file at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ WM8988_REG_FREQ16K [1/2]

#define WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)

Definition at line 65 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ WM8988_REG_FREQ16K [2/2]

#define WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)

Definition at line 65 of file at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ WM8988_REG_FREQ48K [1/2]

#define WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)

wm8988 freq

Definition at line 64 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ WM8988_REG_FREQ48K [2/2]

#define WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)

wm8988 freq

Definition at line 64 of file at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c.

Function Documentation

◆ audio_codec_init()

error_status audio_codec_init ( void )

audio codec init

Parameters
none
Return values
error status

Definition at line 811 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

Referenced by main().

◆ audio_codec_loop()

error_status audio_codec_loop ( void )

audio codec loop

Parameters
none
Return values
none

Definition at line 870 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

Referenced by main().

◆ audio_codec_mic_alt_setting()

void audio_codec_mic_alt_setting ( uint32_t alt_seting )

audio codec microphone alt setting config

Parameters
none
Return values
none

Definition at line 173 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

Referenced by audio_set_interface(), and class_event_handler().

◆ audio_codec_mic_get_data()

uint32_t audio_codec_mic_get_data ( uint8_t * buffer )

codec microphone get data

Parameters
data data buffer
Return values
data len

Definition at line 286 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

Referenced by audio_inisoincom_event(), audio_set_interface(), and class_in_handler().

◆ audio_codec_modify_freq()

void audio_codec_modify_freq ( uint32_t freq )

audio codec modify freq

Parameters
freq freq (wm8988 microphone and speaker must as same freq)
Return values
none

Definition at line 346 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

Referenced by audio_codec_set_mic_freq(), and audio_codec_set_spk_freq().

◆ audio_codec_set_mic_freq()

void audio_codec_set_mic_freq ( uint32_t freq )

audio codec set microphone freq

Parameters
freq freq (wm8988 microphone and speaker must same freq)
Return values
none

Definition at line 125 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_mic_mute()

void audio_codec_set_mic_mute ( uint8_t mute )

audio codec set microphone mute

Parameters
mute mute state
Return values
none

Definition at line 188 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_mic_volume()

void audio_codec_set_mic_volume ( uint16_t volume )

audio codec set microphone volume

Parameters
volume the new volume
Return values
none

Definition at line 210 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_spk_freq()

void audio_codec_set_spk_freq ( uint32_t freq )

audio codec set speaker freq

Parameters
freq freq(wm8988 microphone and speaker must same freq)
Return values
none

Definition at line 141 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_spk_mute()

void audio_codec_set_spk_mute ( uint8_t mute )

audio codec set speaker mute

Parameters
mute mute state
Return values
none

Definition at line 199 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_spk_volume()

void audio_codec_set_spk_volume ( uint16_t volume )

audio codec set speaker volume

Parameters
volume the new volume
Return values
none

Definition at line 221 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_spk_alt_setting()

void audio_codec_spk_alt_setting ( uint32_t alt_seting )

audio codec speaker alt setting config

Parameters
none
Return values
none

Definition at line 158 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

Referenced by audio_set_interface(), and class_event_handler().

◆ audio_codec_spk_feedback()

uint8_t audio_codec_spk_feedback ( uint8_t * feedback )

codec speaker feedback

Parameters
feedback data buffer
Return values
feedback len

Definition at line 232 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

Referenced by class_sof_handler().

◆ audio_codec_spk_fifo_write()

void audio_codec_spk_fifo_write | ( | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

codec speaker write fifo

audio codec interface

Parameters
data | data buffer
len | data length
Return values
none

Definition at line 248 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

Referenced by class_out_handler().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c.

◆ codec_i2s_init()

void codec_i2s_init ( audio_codec_type * param )

audio codec i2s init

Parameters
freq | audio sampling freq
bitw_format | bit width
Return values
error status

Definition at line 500 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

Referenced by audio_codec_init(), audio_codec_set_mic_freq(), and audio_codec_set_spk_freq().

◆ codec_i2s_reset()

void codec_i2s_reset ( void )

audio codec i2s reset

Parameters
none
Return values
none

Definition at line 486 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

Referenced by audio_codec_set_mic_freq(), and audio_codec_set_spk_freq().

◆ copy_buff()

void copy_buff | ( | uint16_t * | dest,
 |  | uint16_t * | src,
 |  | uint32_t | len
 | ) |  |

copy buffer

Parameters
dest | dest data buffer
src | src data buffer
len | data length
Return values
none

Definition at line 389 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c.

◆ DMA1_Channel3_IRQHandler()

void DMA1_Channel3_IRQHandler ( void )

this function handles dma1 channel3 interrupt.

Parameters
none
Return values
none

Definition at line 666 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ DMA1_Channel4_IRQHandler()

void DMA1_Channel4_IRQHandler ( void )

this function handles dma1 channel4 interrupt.

Parameters
none
Return values
none

Definition at line 741 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c.

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 10

< gpio pins number 11

< gpio pins number 10

< gpio pins number 11

Definition at line 403 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 56 of file project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c.

◆ mclk_tmr1_init()

void mclk_tmr1_init ( void )

mclk clock conifg

Parameters
none
Return values
none

Definition at line 444 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

Referenced by audio_codec_init().

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c.

◆ memset16_buffer()

void memset16_buffer | ( | uint16_t * | buffer,
 |  | uint32_t | set,
 |  | uint32_t | len
 | ) |  |

buffer memset

Parameters
buffer | buffer
set | memset data
len | data length
Return values
none

Definition at line 373 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 41 of file project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c.

◆ OTG_IRQ_HANDLER()

void OTG_IRQ_HANDLER ( void )

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 276 of file project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc sof signal select: otg1

< acc hick trim

< acc sof signal select: otg1

< acc hick trim

Definition at line 108 of file project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb low power wakeup handler enable

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 286 of file project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 297 of file project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c.

◆ usb_gpio_config()

void usb_gpio_config ( void )

this function config gpio.

Parameters
none
Return values
none

Definition at line 200 of file project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c.

Referenced by main().

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

Variable Documentation

◆ audio_codec [1/2]

audio_codec_type audio_codec

Definition at line 110 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

Referenced by audio_codec_init(), audio_codec_loop(), audio_codec_mic_get_data(), audio_codec_set_mic_freq(), audio_codec_set_mic_mute(), audio_codec_set_mic_volume(), audio_codec_set_spk_freq(), audio_codec_set_spk_mute(), audio_codec_set_spk_volume(), audio_codec_spk_feedback(), audio_codec_spk_fifo_write(), DMA1_Channel3_IRQHandler(), and DMA1_Channel4_IRQHandler().

◆ audio_codec [2/2]

audio_codec_type audio_codec

Definition at line 110 of file at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ hi2cx [1/2]

i2c_handle_type hi2cx

Definition at line 108 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

Referenced by audio_codec_init(), audio_codec_loop(), and audio_codec_modify_freq().

◆ hi2cx [2/2]

i2c_handle_type hi2cx

Definition at line 108 of file at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c.

Referenced by DMA1_Channel1_IRQHandler(), DMA1_Channel2_IRQHandler(), I2C1_ERR_IRQHandler(), I2C1_EVT_IRQHandler(), I2C2_ERR_IRQHandler(), and I2C2_EVT_IRQHandler().

◆ mic_dma_buffer [1/2]

uint16_t mic_dma_buffer[DMA_BUFFER_SIZE]

Definition at line 112 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

Referenced by codec_i2s_init(), and DMA1_Channel4_IRQHandler().

◆ mic_dma_buffer [2/2]

uint16_t mic_dma_buffer[DMA_BUFFER_SIZE]

Definition at line 112 of file at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ otg_core_struct [1/2]

otg_core_type otg_core_struct

Definition at line 45 of file project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c.

Referenced by main(), and OTG_IRQ_HANDLER().

◆ otg_core_struct [2/2]

otg_core_type otg_core_struct

Definition at line 45 of file project/at_start_f437/examples/usb_device/composite_audio_hid/src/main.c.

◆ reg_addr_data [1/2]

uint16_t reg_addr_data[]

wm8988 register default value

Definition at line 75 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

Referenced by audio_codec_init().

◆ reg_addr_data [2/2]

uint16_t reg_addr_data[]

wm8988 register default value

Definition at line 75 of file at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c.

◆ report_buf [1/2]

uint8_t report_buf[USBD_AUHID_IN_MAXPACKET_SIZE]

Definition at line 49 of file project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c.

Referenced by main().

◆ report_buf [2/2]

uint8_t report_buf[USBD_AUHID_IN_MAXPACKET_SIZE]

Definition at line 49 of file project/at_start_f437/examples/usb_device/composite_audio_hid/src/main.c.

◆ spk_dma_buffer [1/2]

uint16_t spk_dma_buffer[DMA_BUFFER_SIZE]

Definition at line 111 of file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.

Referenced by codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ spk_dma_buffer [2/2]

uint16_t spk_dma_buffer[DMA_BUFFER_SIZE]

Definition at line 111 of file at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c.


AT32F435/437 Firmwary Library: USB_device_audio_hid_codec_reg_definition

Macros
USB_device_audio_hid_codec_reg_definition
AT32F435_periph_examples | AT32F437_periph_examples » USB_device_audio_hid

Macros

#define | WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/
#define | WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/
#define | WM8988_R2_LOUT1_VOLUME 0x02
#define | WM8988_R3_ROUT1_VOLUME 0x03
#define | WM8988_R4_RESERVED 0x04
#define | WM8988_R5_ADC_DAC_CONTROL 0x05
#define | WM8988_R6_RESERVED 0x06
#define | WM8988_R7_AUDIO_INTERFACE 0x07
#define | WM8988_R8_SAMPLE_RATE 0x08
#define | WM8988_R9_RESERVED 0x09
#define | WM8988_R10_LEFT_DAC_VOLUME 0x0A
#define | WM8988_R11_RIGHT_DAC_VOLUME 0x0B
#define | WM8988_R12_BASS_CONTROL 0x0C
#define | WM8988_R13_TREBLE_CONTROL 0x0D
#define | WM8988_R14_
#define | WM8988_R15_RESET 0x0F
#define | WM8988_R16_3D_CONTROL 0x10
#define | WM8988_R17_ALC1 0x11
#define | WM8988_R18_ALC2 0x12
#define | WM8988_R19_ALC3 0x13
#define | WM8988_R20_NOISE_GATE 0x14
#define | WM8988_R21_LEFT_ADC_VOLUME 0x15
#define | WM8988_R22_RIGHT_ADC_VOLUME 0x16
#define | WM8988_R23_ADDITIONAL_1_CONTROL 0x17
#define | WM8988_R24_ADDITIONAL_2_CONTROL 0x18
#define | WM8988_R25_PWR_1_MGMT 0x19
#define | WM8988_R26_PWR_2_MGMT 0x1A
#define | WM8988_R27_ADDITIONAL_3_CONTROL 0x1B
#define | WM8988_R31_ADC_INPUT_MODE 0x1F
#define | WM8988_R32_ADC_L_SIGNAL_PATH 0x20
#define | WM8988_R33_ADC_R_SIGNAL_PATH 0x21
#define | WM8988_R34_LEFT_OUT_MIX_1 0x22
#define | WM8988_R35_LEFT_OUT_MIX_2 0x23
#define | WM8988_R36_RIGHT_OUT_MIX_1 0x24
#define | WM8988_R37_RIGHT_OUT_MIX_2 0x25
#define | WM8988_R38_RESERVED
#define | WM8988_R39_RESERVED
#define | WM8988_R40_LOUT2_VOLUME 0x28
#define | WM8988_R41_ROUT2_VOLUME 0x29
#define | WM8988_R42_RESERVED
#define | WM8988_R43_LOW_POWER_PALYBACK 0x43
#define | WM8988_I2C_ADDR_CSB_LOW 0x34
#define | WM8988_I2C_ADDR_CSB_HIGH 0x36
#define | WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/
#define | WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/
#define | WM8988_R2_LOUT1_VOLUME 0x02
#define | WM8988_R3_ROUT1_VOLUME 0x03
#define | WM8988_R4_RESERVED 0x04
#define | WM8988_R5_ADC_DAC_CONTROL 0x05
#define | WM8988_R6_RESERVED 0x06
#define | WM8988_R7_AUDIO_INTERFACE 0x07
#define | WM8988_R8_SAMPLE_RATE 0x08
#define | WM8988_R9_RESERVED 0x09
#define | WM8988_R10_LEFT_DAC_VOLUME 0x0A
#define | WM8988_R11_RIGHT_DAC_VOLUME 0x0B
#define | WM8988_R12_BASS_CONTROL 0x0C
#define | WM8988_R13_TREBLE_CONTROL 0x0D
#define | WM8988_R14_
#define | WM8988_R15_RESET 0x0F
#define | WM8988_R16_3D_CONTROL 0x10
#define | WM8988_R17_ALC1 0x11
#define | WM8988_R18_ALC2 0x12
#define | WM8988_R19_ALC3 0x13
#define | WM8988_R20_NOISE_GATE 0x14
#define | WM8988_R21_LEFT_ADC_VOLUME 0x15
#define | WM8988_R22_RIGHT_ADC_VOLUME 0x16
#define | WM8988_R23_ADDITIONAL_1_CONTROL 0x17
#define | WM8988_R24_ADDITIONAL_2_CONTROL 0x18
#define | WM8988_R25_PWR_1_MGMT 0x19
#define | WM8988_R26_PWR_2_MGMT 0x1A
#define | WM8988_R27_ADDITIONAL_3_CONTROL 0x1B
#define | WM8988_R31_ADC_INPUT_MODE 0x1F
#define | WM8988_R32_ADC_L_SIGNAL_PATH 0x20
#define | WM8988_R33_ADC_R_SIGNAL_PATH 0x21
#define | WM8988_R34_LEFT_OUT_MIX_1 0x22
#define | WM8988_R35_LEFT_OUT_MIX_2 0x23
#define | WM8988_R36_RIGHT_OUT_MIX_1 0x24
#define | WM8988_R37_RIGHT_OUT_MIX_2 0x25
#define | WM8988_R38_RESERVED
#define | WM8988_R39_RESERVED
#define | WM8988_R40_LOUT2_VOLUME 0x28
#define | WM8988_R41_ROUT2_VOLUME 0x29
#define | WM8988_R42_RESERVED
#define | WM8988_R43_LOW_POWER_PALYBACK 0x43
#define | WM8988_I2C_ADDR_CSB_LOW 0x34
#define | WM8988_I2C_ADDR_CSB_HIGH 0x36

Detailed Description

Macro Definition Documentation

◆ WM8988_I2C_ADDR_CSB_HIGH [1/2]

#define WM8988_I2C_ADDR_CSB_HIGH 0x36

Definition at line 94 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_I2C_ADDR_CSB_HIGH [2/2]

#define WM8988_I2C_ADDR_CSB_HIGH 0x36

Definition at line 94 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_I2C_ADDR_CSB_LOW [1/2]

#define WM8988_I2C_ADDR_CSB_LOW 0x34

Definition at line 93 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_I2C_ADDR_CSB_LOW [2/2]

#define WM8988_I2C_ADDR_CSB_LOW 0x34

Definition at line 93 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R0_LEFT_INPUT_VOLUME [1/2]

#define WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/

Definition at line 50 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R0_LEFT_INPUT_VOLUME [2/2]

#define WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/

Definition at line 50 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R10_LEFT_DAC_VOLUME [1/2]

#define WM8988_R10_LEFT_DAC_VOLUME 0x0A

Definition at line 60 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R10_LEFT_DAC_VOLUME [2/2]

#define WM8988_R10_LEFT_DAC_VOLUME 0x0A

Definition at line 60 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R11_RIGHT_DAC_VOLUME [1/2]

#define WM8988_R11_RIGHT_DAC_VOLUME 0x0B

Definition at line 61 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R11_RIGHT_DAC_VOLUME [2/2]

#define WM8988_R11_RIGHT_DAC_VOLUME 0x0B

Definition at line 61 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R12_BASS_CONTROL [1/2]

#define WM8988_R12_BASS_CONTROL 0x0C

Definition at line 62 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R12_BASS_CONTROL [2/2]

#define WM8988_R12_BASS_CONTROL 0x0C

Definition at line 62 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R13_TREBLE_CONTROL [1/2]

#define WM8988_R13_TREBLE_CONTROL 0x0D

Definition at line 63 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R13_TREBLE_CONTROL [2/2]

#define WM8988_R13_TREBLE_CONTROL 0x0D

Definition at line 63 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R14_ [1/2]

#define WM8988_R14_

Definition at line 64 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R14_ [2/2]

#define WM8988_R14_

Definition at line 64 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R15_RESET [1/2]

#define WM8988_R15_RESET 0x0F

Definition at line 65 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R15_RESET [2/2]

#define WM8988_R15_RESET 0x0F

Definition at line 65 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R16_3D_CONTROL [1/2]

#define WM8988_R16_3D_CONTROL 0x10

Definition at line 66 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R16_3D_CONTROL [2/2]

#define WM8988_R16_3D_CONTROL 0x10

Definition at line 66 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R17_ALC1 [1/2]

#define WM8988_R17_ALC1 0x11

Definition at line 67 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R17_ALC1 [2/2]

#define WM8988_R17_ALC1 0x11

Definition at line 67 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R18_ALC2 [1/2]

#define WM8988_R18_ALC2 0x12

Definition at line 68 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R18_ALC2 [2/2]

#define WM8988_R18_ALC2 0x12

Definition at line 68 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R19_ALC3 [1/2]

#define WM8988_R19_ALC3 0x13

Definition at line 69 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R19_ALC3 [2/2]

#define WM8988_R19_ALC3 0x13

Definition at line 69 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R1_RIGHT_INPUT_VOLUME [1/2]

#define WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/

Definition at line 51 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R1_RIGHT_INPUT_VOLUME [2/2]

#define WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/

Definition at line 51 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R20_NOISE_GATE [1/2]

#define WM8988_R20_NOISE_GATE 0x14

Definition at line 70 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R20_NOISE_GATE [2/2]

#define WM8988_R20_NOISE_GATE 0x14

Definition at line 70 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R21_LEFT_ADC_VOLUME [1/2]

#define WM8988_R21_LEFT_ADC_VOLUME 0x15

Definition at line 71 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R21_LEFT_ADC_VOLUME [2/2]

#define WM8988_R21_LEFT_ADC_VOLUME 0x15

Definition at line 71 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R22_RIGHT_ADC_VOLUME [1/2]

#define WM8988_R22_RIGHT_ADC_VOLUME 0x16

Definition at line 72 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R22_RIGHT_ADC_VOLUME [2/2]

#define WM8988_R22_RIGHT_ADC_VOLUME 0x16

Definition at line 72 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R23_ADDITIONAL_1_CONTROL [1/2]

#define WM8988_R23_ADDITIONAL_1_CONTROL 0x17

Definition at line 73 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R23_ADDITIONAL_1_CONTROL [2/2]

#define WM8988_R23_ADDITIONAL_1_CONTROL 0x17

Definition at line 73 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R24_ADDITIONAL_2_CONTROL [1/2]

#define WM8988_R24_ADDITIONAL_2_CONTROL 0x18

Definition at line 74 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R24_ADDITIONAL_2_CONTROL [2/2]

#define WM8988_R24_ADDITIONAL_2_CONTROL 0x18

Definition at line 74 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R25_PWR_1_MGMT [1/2]

#define WM8988_R25_PWR_1_MGMT 0x19

Definition at line 75 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R25_PWR_1_MGMT [2/2]

#define WM8988_R25_PWR_1_MGMT 0x19

Definition at line 75 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R26_PWR_2_MGMT [1/2]

#define WM8988_R26_PWR_2_MGMT 0x1A

Definition at line 76 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R26_PWR_2_MGMT [2/2]

#define WM8988_R26_PWR_2_MGMT 0x1A

Definition at line 76 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R27_ADDITIONAL_3_CONTROL [1/2]

#define WM8988_R27_ADDITIONAL_3_CONTROL 0x1B

Definition at line 77 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R27_ADDITIONAL_3_CONTROL [2/2]

#define WM8988_R27_ADDITIONAL_3_CONTROL 0x1B

Definition at line 77 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R2_LOUT1_VOLUME [1/2]

#define WM8988_R2_LOUT1_VOLUME 0x02

Definition at line 52 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R2_LOUT1_VOLUME [2/2]

#define WM8988_R2_LOUT1_VOLUME 0x02

Definition at line 52 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R31_ADC_INPUT_MODE [1/2]

#define WM8988_R31_ADC_INPUT_MODE 0x1F

Definition at line 79 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R31_ADC_INPUT_MODE [2/2]

#define WM8988_R31_ADC_INPUT_MODE 0x1F

Definition at line 79 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R32_ADC_L_SIGNAL_PATH [1/2]

#define WM8988_R32_ADC_L_SIGNAL_PATH 0x20

Definition at line 80 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R32_ADC_L_SIGNAL_PATH [2/2]

#define WM8988_R32_ADC_L_SIGNAL_PATH 0x20

Definition at line 80 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R33_ADC_R_SIGNAL_PATH [1/2]

#define WM8988_R33_ADC_R_SIGNAL_PATH 0x21

Definition at line 81 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R33_ADC_R_SIGNAL_PATH [2/2]

#define WM8988_R33_ADC_R_SIGNAL_PATH 0x21

Definition at line 81 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R34_LEFT_OUT_MIX_1 [1/2]

#define WM8988_R34_LEFT_OUT_MIX_1 0x22

Definition at line 82 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R34_LEFT_OUT_MIX_1 [2/2]

#define WM8988_R34_LEFT_OUT_MIX_1 0x22

Definition at line 82 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R35_LEFT_OUT_MIX_2 [1/2]

#define WM8988_R35_LEFT_OUT_MIX_2 0x23

Definition at line 83 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R35_LEFT_OUT_MIX_2 [2/2]

#define WM8988_R35_LEFT_OUT_MIX_2 0x23

Definition at line 83 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R36_RIGHT_OUT_MIX_1 [1/2]

#define WM8988_R36_RIGHT_OUT_MIX_1 0x24

Definition at line 84 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R36_RIGHT_OUT_MIX_1 [2/2]

#define WM8988_R36_RIGHT_OUT_MIX_1 0x24

Definition at line 84 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R37_RIGHT_OUT_MIX_2 [1/2]

#define WM8988_R37_RIGHT_OUT_MIX_2 0x25

Definition at line 85 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R37_RIGHT_OUT_MIX_2 [2/2]

#define WM8988_R37_RIGHT_OUT_MIX_2 0x25

Definition at line 85 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R38_RESERVED [1/2]

#define WM8988_R38_RESERVED

Definition at line 86 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R38_RESERVED [2/2]

#define WM8988_R38_RESERVED

Definition at line 86 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R39_RESERVED [1/2]

#define WM8988_R39_RESERVED

Definition at line 87 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R39_RESERVED [2/2]

#define WM8988_R39_RESERVED

Definition at line 87 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R3_ROUT1_VOLUME [1/2]

#define WM8988_R3_ROUT1_VOLUME 0x03

Definition at line 53 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R3_ROUT1_VOLUME [2/2]

#define WM8988_R3_ROUT1_VOLUME 0x03

Definition at line 53 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R40_LOUT2_VOLUME [1/2]

#define WM8988_R40_LOUT2_VOLUME 0x28

Definition at line 88 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R40_LOUT2_VOLUME [2/2]

#define WM8988_R40_LOUT2_VOLUME 0x28

Definition at line 88 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R41_ROUT2_VOLUME [1/2]

#define WM8988_R41_ROUT2_VOLUME 0x29

Definition at line 89 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R41_ROUT2_VOLUME [2/2]

#define WM8988_R41_ROUT2_VOLUME 0x29

Definition at line 89 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R42_RESERVED [1/2]

#define WM8988_R42_RESERVED

Definition at line 90 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R42_RESERVED [2/2]

#define WM8988_R42_RESERVED

Definition at line 90 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R43_LOW_POWER_PALYBACK [1/2]

#define WM8988_R43_LOW_POWER_PALYBACK 0x43

Definition at line 91 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R43_LOW_POWER_PALYBACK [2/2]

#define WM8988_R43_LOW_POWER_PALYBACK 0x43

Definition at line 91 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R4_RESERVED [1/2]

#define WM8988_R4_RESERVED 0x04

Definition at line 54 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R4_RESERVED [2/2]

#define WM8988_R4_RESERVED 0x04

Definition at line 54 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R5_ADC_DAC_CONTROL [1/2]

#define WM8988_R5_ADC_DAC_CONTROL 0x05

Definition at line 55 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R5_ADC_DAC_CONTROL [2/2]

#define WM8988_R5_ADC_DAC_CONTROL 0x05

Definition at line 55 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R6_RESERVED [1/2]

#define WM8988_R6_RESERVED 0x06

Definition at line 56 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R6_RESERVED [2/2]

#define WM8988_R6_RESERVED 0x06

Definition at line 56 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R7_AUDIO_INTERFACE [1/2]

#define WM8988_R7_AUDIO_INTERFACE 0x07

Definition at line 57 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R7_AUDIO_INTERFACE [2/2]

#define WM8988_R7_AUDIO_INTERFACE 0x07

Definition at line 57 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R8_SAMPLE_RATE [1/2]

#define WM8988_R8_SAMPLE_RATE 0x08

Definition at line 58 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R8_SAMPLE_RATE [2/2]

#define WM8988_R8_SAMPLE_RATE 0x08

Definition at line 58 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R9_RESERVED [1/2]

#define WM8988_R9_RESERVED 0x09

Definition at line 59 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R9_RESERVED [2/2]

#define WM8988_R9_RESERVED 0x09

Definition at line 59 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.


AT32F435/437 Firmwary Library: USB_device_audio_hid_codec_pin_definition

Macros
USB_device_audio_hid_codec_pin_definition
AT32F435_periph_examples | AT32F437_periph_examples » USB_device_audio_hid

Macros

#define | I2S1_WS_PIN GPIO_PINS_4
#define | I2S1_WS_PIN_SOURCE GPIO_PINS_SOURCE4
#define | I2S1_WS_GPIO_MUX GPIO_MUX_5
#define | I2S1_CK_PIN GPIO_PINS_5
#define | I2S1_CK_PIN_SOURCE GPIO_PINS_SOURCE5
#define | I2S1_CK_GPIO_MUX GPIO_MUX_5
#define | I2S1_SD_PIN GPIO_PINS_7
#define | I2S1_SD_PIN_SOURCE GPIO_PINS_SOURCE7
#define | I2S1_SD_GPIO_MUX GPIO_MUX_5
#define | I2S1_GPIO GPIOA
#define | I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
#define | I2S1_DT_ADDRESS (&(SPI1->dt))
#define | I2S2_WS_PIN GPIO_PINS_0
#define | I2S2_WS_PIN_SOURCE GPIO_PINS_SOURCE0
#define | I2S2_WS_GPIO_MUX GPIO_MUX_7
#define | I2S2_CK_PIN GPIO_PINS_1
#define | I2S2_CK_PIN_SOURCE GPIO_PINS_SOURCE1
#define | I2S2_CK_GPIO_MUX GPIO_MUX_6
#define | I2S2_SD_PIN GPIO_PINS_4
#define | I2S2_SD_PIN_SOURCE GPIO_PINS_SOURCE4
#define | I2S2_SD_GPIO_MUX GPIO_MUX_6
#define | I2S2_GPIO GPIOD
#define | I2S2_GPIO_CRM_CLK CRM_GPIOD_PERIPH_CLOCK
#define | I2S2_DT_ADDRESS (&(SPI2->dt))
#define | SPK_TX_FIFO_SIZE (1024 * 4)
#define | I2S1_WS_PIN GPIO_PINS_4
#define | I2S1_WS_PIN_SOURCE GPIO_PINS_SOURCE4
#define | I2S1_WS_GPIO_MUX GPIO_MUX_5
#define | I2S1_CK_PIN GPIO_PINS_5
#define | I2S1_CK_PIN_SOURCE GPIO_PINS_SOURCE5
#define | I2S1_CK_GPIO_MUX GPIO_MUX_5
#define | I2S1_SD_PIN GPIO_PINS_7
#define | I2S1_SD_PIN_SOURCE GPIO_PINS_SOURCE7
#define | I2S1_SD_GPIO_MUX GPIO_MUX_5
#define | I2S1_GPIO GPIOA
#define | I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
#define | I2S1_DT_ADDRESS (&(SPI1->dt))
#define | I2S2_WS_PIN GPIO_PINS_0
#define | I2S2_WS_PIN_SOURCE GPIO_PINS_SOURCE0
#define | I2S2_WS_GPIO_MUX GPIO_MUX_7
#define | I2S2_CK_PIN GPIO_PINS_1
#define | I2S2_CK_PIN_SOURCE GPIO_PINS_SOURCE1
#define | I2S2_CK_GPIO_MUX GPIO_MUX_6
#define | I2S2_SD_PIN GPIO_PINS_4
#define | I2S2_SD_PIN_SOURCE GPIO_PINS_SOURCE4
#define | I2S2_SD_GPIO_MUX GPIO_MUX_6
#define | I2S2_GPIO GPIOD
#define | I2S2_GPIO_CRM_CLK CRM_GPIOD_PERIPH_CLOCK
#define | I2S2_DT_ADDRESS (&(SPI2->dt))
#define | SPK_TX_FIFO_SIZE (1024 * 4)

Detailed Description

Macro Definition Documentation

◆ I2S1_CK_GPIO_MUX [1/2]

#define I2S1_CK_GPIO_MUX GPIO_MUX_5

Definition at line 109 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S1_CK_GPIO_MUX [2/2]

#define I2S1_CK_GPIO_MUX GPIO_MUX_5

Definition at line 109 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S1_CK_PIN [1/2]

#define I2S1_CK_PIN GPIO_PINS_5

Definition at line 107 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S1_CK_PIN [2/2]

#define I2S1_CK_PIN GPIO_PINS_5

Definition at line 107 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S1_CK_PIN_SOURCE [1/2]

#define I2S1_CK_PIN_SOURCE GPIO_PINS_SOURCE5

Definition at line 108 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S1_CK_PIN_SOURCE [2/2]

#define I2S1_CK_PIN_SOURCE GPIO_PINS_SOURCE5

Definition at line 108 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S1_DT_ADDRESS [1/2]

#define I2S1_DT_ADDRESS (&(SPI1->dt))

Definition at line 117 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S1_DT_ADDRESS [2/2]

#define I2S1_DT_ADDRESS (&(SPI1->dt))

Definition at line 117 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S1_GPIO [1/2]

#define I2S1_GPIO GPIOA

Definition at line 115 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S1_GPIO [2/2]

#define I2S1_GPIO GPIOA

Definition at line 115 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S1_GPIO_CRM_CLK [1/2]

#define I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 116 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S1_GPIO_CRM_CLK [2/2]

#define I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 116 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S1_SD_GPIO_MUX [1/2]

#define I2S1_SD_GPIO_MUX GPIO_MUX_5

Definition at line 113 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S1_SD_GPIO_MUX [2/2]

#define I2S1_SD_GPIO_MUX GPIO_MUX_5

Definition at line 113 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S1_SD_PIN [1/2]

#define I2S1_SD_PIN GPIO_PINS_7

Definition at line 111 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S1_SD_PIN [2/2]

#define I2S1_SD_PIN GPIO_PINS_7

Definition at line 111 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S1_SD_PIN_SOURCE [1/2]

#define I2S1_SD_PIN_SOURCE GPIO_PINS_SOURCE7

Definition at line 112 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S1_SD_PIN_SOURCE [2/2]

#define I2S1_SD_PIN_SOURCE GPIO_PINS_SOURCE7

Definition at line 112 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S1_WS_GPIO_MUX [1/2]

#define I2S1_WS_GPIO_MUX GPIO_MUX_5

Definition at line 105 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S1_WS_GPIO_MUX [2/2]

#define I2S1_WS_GPIO_MUX GPIO_MUX_5

Definition at line 105 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S1_WS_PIN [1/2]

#define I2S1_WS_PIN GPIO_PINS_4

Definition at line 103 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S1_WS_PIN [2/2]

#define I2S1_WS_PIN GPIO_PINS_4

Definition at line 103 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S1_WS_PIN_SOURCE [1/2]

#define I2S1_WS_PIN_SOURCE GPIO_PINS_SOURCE4

Definition at line 104 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S1_WS_PIN_SOURCE [2/2]

#define I2S1_WS_PIN_SOURCE GPIO_PINS_SOURCE4

Definition at line 104 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S2_CK_GPIO_MUX [1/2]

#define I2S2_CK_GPIO_MUX GPIO_MUX_6

Definition at line 126 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S2_CK_GPIO_MUX [2/2]

#define I2S2_CK_GPIO_MUX GPIO_MUX_6

Definition at line 126 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S2_CK_PIN [1/2]

#define I2S2_CK_PIN GPIO_PINS_1

Definition at line 124 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S2_CK_PIN [2/2]

#define I2S2_CK_PIN GPIO_PINS_1

Definition at line 124 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S2_CK_PIN_SOURCE [1/2]

#define I2S2_CK_PIN_SOURCE GPIO_PINS_SOURCE1

Definition at line 125 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S2_CK_PIN_SOURCE [2/2]

#define I2S2_CK_PIN_SOURCE GPIO_PINS_SOURCE1

Definition at line 125 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S2_DT_ADDRESS [1/2]

#define I2S2_DT_ADDRESS (&(SPI2->dt))

Definition at line 134 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S2_DT_ADDRESS [2/2]

#define I2S2_DT_ADDRESS (&(SPI2->dt))

Definition at line 134 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S2_GPIO [1/2]

#define I2S2_GPIO GPIOD

Definition at line 132 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S2_GPIO [2/2]

#define I2S2_GPIO GPIOD

Definition at line 132 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S2_GPIO_CRM_CLK [1/2]

#define I2S2_GPIO_CRM_CLK CRM_GPIOD_PERIPH_CLOCK

Definition at line 133 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S2_GPIO_CRM_CLK [2/2]

#define I2S2_GPIO_CRM_CLK CRM_GPIOD_PERIPH_CLOCK

Definition at line 133 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S2_SD_GPIO_MUX [1/2]

#define I2S2_SD_GPIO_MUX GPIO_MUX_6

Definition at line 130 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S2_SD_GPIO_MUX [2/2]

#define I2S2_SD_GPIO_MUX GPIO_MUX_6

Definition at line 130 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S2_SD_PIN [1/2]

#define I2S2_SD_PIN GPIO_PINS_4

Definition at line 128 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S2_SD_PIN [2/2]

#define I2S2_SD_PIN GPIO_PINS_4

Definition at line 128 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S2_SD_PIN_SOURCE [1/2]

#define I2S2_SD_PIN_SOURCE GPIO_PINS_SOURCE4

Definition at line 129 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S2_SD_PIN_SOURCE [2/2]

#define I2S2_SD_PIN_SOURCE GPIO_PINS_SOURCE4

Definition at line 129 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S2_WS_GPIO_MUX [1/2]

#define I2S2_WS_GPIO_MUX GPIO_MUX_7

Definition at line 122 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S2_WS_GPIO_MUX [2/2]

#define I2S2_WS_GPIO_MUX GPIO_MUX_7

Definition at line 122 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S2_WS_PIN [1/2]

#define I2S2_WS_PIN GPIO_PINS_0

Definition at line 120 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S2_WS_PIN [2/2]

#define I2S2_WS_PIN GPIO_PINS_0

Definition at line 120 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S2_WS_PIN_SOURCE [1/2]

#define I2S2_WS_PIN_SOURCE GPIO_PINS_SOURCE0

Definition at line 121 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ I2S2_WS_PIN_SOURCE [2/2]

#define I2S2_WS_PIN_SOURCE GPIO_PINS_SOURCE0

Definition at line 121 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ SPK_TX_FIFO_SIZE [1/2]

#define SPK_TX_FIFO_SIZE (1024 * 4)

Definition at line 136 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ SPK_TX_FIFO_SIZE [2/2]

#define SPK_TX_FIFO_SIZE (1024 * 4)

Definition at line 136 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.


AT32F435/437 Firmwary Library: USB_device_audio_hid_codec_exported_functions

Data Structures | Macros | Functions
USB_device_audio_hid_codec_exported_functions
AT32F435_periph_examples | AT32F437_periph_examples » USB_device_audio_hid

Data Structures

struct audio_codec_type

Macros

#define | MIC_BUFFER_SIZE 1024
#define | SPK_BUFFER_SIZE 4096
#define | DMA_BUFFER_SIZE 288
#define | MIC_BUFFER_SIZE 1024
#define | SPK_BUFFER_SIZE 4096
#define | DMA_BUFFER_SIZE 288

Functions

error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
audio codec interface More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...

Detailed Description

Macro Definition Documentation

◆ DMA_BUFFER_SIZE [1/2]

#define DMA_BUFFER_SIZE 288

Definition at line 147 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ DMA_BUFFER_SIZE [2/2]

#define DMA_BUFFER_SIZE 288

Definition at line 147 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ MIC_BUFFER_SIZE [1/2]

#define MIC_BUFFER_SIZE 1024

Definition at line 145 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ MIC_BUFFER_SIZE [2/2]

#define MIC_BUFFER_SIZE 1024

Definition at line 145 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ SPK_BUFFER_SIZE [1/2]

#define SPK_BUFFER_SIZE 4096

Definition at line 146 of file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

◆ SPK_BUFFER_SIZE [2/2]

#define SPK_BUFFER_SIZE 4096

Definition at line 146 of file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.

Function Documentation

◆ audio_codec_init()

error_status audio_codec_init ( void )

audio codec init

Parameters
none
Return values
error status

Definition at line 811 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ audio_codec_loop()

error_status audio_codec_loop ( void )

audio codec loop

Parameters
none
Return values
none

Definition at line 870 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ audio_codec_mic_alt_setting()

void audio_codec_mic_alt_setting ( uint32_t alt_seting )

audio codec microphone alt setting config

Parameters
none
Return values
none

Definition at line 173 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ audio_codec_mic_get_data()

uint32_t audio_codec_mic_get_data ( uint8_t * buffer )

codec microphone get data

Parameters
data data buffer
Return values
data len

Definition at line 286 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ audio_codec_modify_freq()

void audio_codec_modify_freq ( uint32_t freq )

audio codec modify freq

Parameters
freq freq (wm8988 microphone and speaker must as same freq)
Return values
none

Definition at line 346 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

Referenced by audio_codec_set_mic_freq(), and audio_codec_set_spk_freq().

◆ audio_codec_set_mic_freq()

void audio_codec_set_mic_freq ( uint32_t freq )

audio codec set microphone freq

Parameters
freq freq (wm8988 microphone and speaker must same freq)
Return values
none

Definition at line 125 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ audio_codec_set_mic_mute()

void audio_codec_set_mic_mute ( uint8_t mute )

audio codec set microphone mute

Parameters
mute mute state
Return values
none

Definition at line 188 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ audio_codec_set_mic_volume()

void audio_codec_set_mic_volume ( uint16_t volume )

audio codec set microphone volume

Parameters
volume the new volume
Return values
none

Definition at line 210 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ audio_codec_set_spk_freq()

void audio_codec_set_spk_freq ( uint32_t freq )

audio codec set speaker freq

Parameters
freq freq(wm8988 microphone and speaker must same freq)
Return values
none

Definition at line 141 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ audio_codec_set_spk_mute()

void audio_codec_set_spk_mute ( uint8_t mute )

audio codec set speaker mute

Parameters
mute mute state
Return values
none

Definition at line 199 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ audio_codec_set_spk_volume()

void audio_codec_set_spk_volume ( uint16_t volume )

audio codec set speaker volume

Parameters
volume the new volume
Return values
none

Definition at line 221 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ audio_codec_spk_alt_setting()

void audio_codec_spk_alt_setting ( uint32_t alt_seting )

audio codec speaker alt setting config

Parameters
none
Return values
none

Definition at line 158 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ audio_codec_spk_feedback()

uint8_t audio_codec_spk_feedback ( uint8_t * feedback )

codec speaker feedback

Parameters
feedback data buffer
Return values
feedback len

Definition at line 232 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.

◆ audio_codec_spk_fifo_write()

void audio_codec_spk_fifo_write | ( | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

audio codec interface

audio codec interface

Parameters
data | data buffer
len | data length
Return values
none

Definition at line 248 of file at_start_f435/examples/usb_device/audio/src/audio_codec.c.


AT32F435/437 Firmwary Library: USB_device_composite_vcp_keyboard

Macros | Functions | Variables
USB_device_composite_vcp_keyboard
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | USB_LOW_POWER_WAKUP
usb low power wakeup handler enable More...
#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | USB_LOW_POWER_WAKUP
usb low power wakeup handler enable More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
void | EXINT0_IRQHandler (void)
exint0 interrupt handler More...
int | main (void)
main function. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...

Variables

otg_core_type otg_core_struct
uint8_t | keyboard_send_flag
uint8_t | usb_buffer [256]
otg_core_type otg_core_struct
uint8_t | keyboard_send_flag
uint8_t | usb_buffer [256]

Detailed Description

Macro Definition Documentation

◆ OTG_CLOCK [1/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 71 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_CLOCK [2/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 71 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_IRQ [1/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 72 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_IRQ [2/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 72 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [1/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 73 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [2/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 73 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_DM [1/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 84 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_DM [2/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 84 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [1/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 85 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [2/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 85 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_DP [1/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 81 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_DP [2/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 81 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [1/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 82 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [2/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 82 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_GPIO [1/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 78 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_GPIO [2/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 78 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [1/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 79 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [2/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 79 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_ID [1/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 90 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_ID [2/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 90 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [1/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 91 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [2/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 91 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_MUX [1/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 98 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_MUX [2/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 98 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_SOF [1/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 95 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_SOF [2/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 95 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [1/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 93 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [2/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 93 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [1/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 94 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [2/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 94 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [1/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 96 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [2/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 96 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_VBUS [1/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 87 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_VBUS [2/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 87 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [1/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 88 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [2/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 88 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_USB_ID [1/2]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 64 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_USB_ID [2/2]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 64 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [1/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 76 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [2/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 76 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [1/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 75 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [2/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 75 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [1/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 74 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [2/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 74 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USB_ID [1/2]

#define USB_ID 0

Definition at line 70 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USB_ID [2/2]

#define USB_ID 0

Definition at line 70 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USB_LOW_POWER_WAKUP [1/2]

#define USB_LOW_POWER_WAKUP

usb low power wakeup handler enable

Definition at line 206 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USB_LOW_POWER_WAKUP [2/2]

#define USB_LOW_POWER_WAKUP

usb low power wakeup handler enable

Definition at line 206 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [1/2]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore

Definition at line 201 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [2/2]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore

Definition at line 201 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [1/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 154 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [2/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 154 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [1/2]

#define USBD2_EP1_TX_SIZE 20

Definition at line 155 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [2/2]

#define USBD2_EP1_TX_SIZE 20

Definition at line 155 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [1/2]

#define USBD2_EP2_TX_SIZE 20

Definition at line 156 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [2/2]

#define USBD2_EP2_TX_SIZE 20

Definition at line 156 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [1/2]

#define USBD2_EP3_TX_SIZE 20

Definition at line 157 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [2/2]

#define USBD2_EP3_TX_SIZE 20

Definition at line 157 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [1/2]

#define USBD2_EP4_TX_SIZE 20

Definition at line 158 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [2/2]

#define USBD2_EP4_TX_SIZE 20

Definition at line 158 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [1/2]

#define USBD2_EP5_TX_SIZE 20

Definition at line 159 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [2/2]

#define USBD2_EP5_TX_SIZE 20

Definition at line 159 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [1/2]

#define USBD2_EP6_TX_SIZE 20

Definition at line 160 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [2/2]

#define USBD2_EP6_TX_SIZE 20

Definition at line 160 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [1/2]

#define USBD2_EP7_TX_SIZE 20

Definition at line 161 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [2/2]

#define USBD2_EP7_TX_SIZE 20

Definition at line 161 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD2_RX_SIZE [1/2]

#define USBD2_RX_SIZE 128

Definition at line 153 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD2_RX_SIZE [2/2]

#define USBD2_RX_SIZE 128

Definition at line 153 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [1/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 143 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [2/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 143 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [1/2]

#define USBD_EP1_TX_SIZE 20

Definition at line 144 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [2/2]

#define USBD_EP1_TX_SIZE 20

Definition at line 144 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [1/2]

#define USBD_EP2_TX_SIZE 20

Definition at line 145 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [2/2]

#define USBD_EP2_TX_SIZE 20

Definition at line 145 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [1/2]

#define USBD_EP3_TX_SIZE 20

Definition at line 146 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [2/2]

#define USBD_EP3_TX_SIZE 20

Definition at line 146 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [1/2]

#define USBD_EP4_TX_SIZE 20

Definition at line 147 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [2/2]

#define USBD_EP4_TX_SIZE 20

Definition at line 147 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [1/2]

#define USBD_EP5_TX_SIZE 20

Definition at line 148 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [2/2]

#define USBD_EP5_TX_SIZE 20

Definition at line 148 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [1/2]

#define USBD_EP6_TX_SIZE 20

Definition at line 149 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [2/2]

#define USBD_EP6_TX_SIZE 20

Definition at line 149 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [1/2]

#define USBD_EP7_TX_SIZE 20

Definition at line 150 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [2/2]

#define USBD_EP7_TX_SIZE 20

Definition at line 150 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD_RX_SIZE [1/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 142 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USBD_RX_SIZE [2/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 142 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [1/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 52 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [2/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 52 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c.

◆ EXINT0_IRQHandler()

void EXINT0_IRQHandler ( void )

exint0 interrupt handler

Parameters
none
Return values
none

Definition at line 100 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 147 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c.

◆ OTG_IRQ_HANDLER()

void OTG_IRQ_HANDLER ( void )

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 396 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc sof signal select: otg1

< acc hick trim

< acc sof signal select: otg1

< acc hick trim

Definition at line 228 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

usb low power wakeup handler enable

Parameters
ms number of millisecond delay
Return values
none

Definition at line 406 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 417 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c.

◆ usb_gpio_config()

void usb_gpio_config ( void )

this function config gpio.

Parameters
none
Return values
none

Definition at line 321 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c.

Referenced by main().

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

Variable Documentation

◆ keyboard_send_flag [1/2]

uint8_t keyboard_send_flag

Definition at line 46 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c.

Referenced by button_isr(), and main().

◆ keyboard_send_flag [2/2]

uint8_t keyboard_send_flag

Definition at line 46 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/src/main.c.

◆ otg_core_struct [1/2]

otg_core_type otg_core_struct

Definition at line 45 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c.

Referenced by keyboard_send_string(), main(), and OTG_IRQ_HANDLER().

◆ otg_core_struct [2/2]

otg_core_type otg_core_struct

Definition at line 45 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/src/main.c.

◆ usb_buffer [1/2]

uint8_t usb_buffer[256]

Definition at line 47 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c.

Referenced by main().

◆ usb_buffer [2/2]

uint8_t usb_buffer[256]

Definition at line 47 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/src/main.c.


AT32F435/437 Firmwary Library: USB_device_msc

Macros | Functions | Variables
USB_device_msc
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | INTERNAL_FLASH_LUN 0
#define | SPI_FLASH_LUN 1
#define | SD_LUN 2
#define | USB_FLASH_ADDR_OFFSET 0x08005000
#define | SECTOR_SIZE_1K 1024
#define | SECTOR_SIZE_2K 2048
#define | SECTOR_SIZE_4K 4096
#define | INTERNAL_FLASH_LUN 0
#define | SPI_FLASH_LUN 1
#define | SD_LUN 2
#define | USB_FLASH_ADDR_OFFSET 0x08005000
#define | SECTOR_SIZE_1K 1024
#define | SECTOR_SIZE_2K 2048
#define | SECTOR_SIZE_4K 4096
#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | INTERNAL_FLASH_LUN 0
#define | SPI_FLASH_LUN 1
#define | SD_LUN 2
#define | USB_FLASH_ADDR_OFFSET 0x08005000
#define | SECTOR_SIZE_1K 1024
#define | SECTOR_SIZE_2K 2048
#define | SECTOR_SIZE_4K 4096
#define | INTERNAL_FLASH_LUN 0
#define | SPI_FLASH_LUN 1
#define | SD_LUN 2
#define | USB_FLASH_ADDR_OFFSET 0x08005000
#define | SECTOR_SIZE_1K 1024
#define | SECTOR_SIZE_2K 2048
#define | SECTOR_SIZE_4K 4096
#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
int | main (void)
main function. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...

Variables

otg_core_type otg_core_struct
uint32_t | sector_size = 2048
uint32_t | msc_flash_size
uint8_t | scsi_inquiry [MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
otg_core_type otg_core_struct
uint32_t | sector_size = 2048
uint32_t | msc_flash_size
uint8_t | scsi_inquiry [MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]

Detailed Description

Macro Definition Documentation

◆ INTERNAL_FLASH_LUN [1/4]

#define INTERNAL_FLASH_LUN 0

Definition at line 45 of file at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h.

◆ INTERNAL_FLASH_LUN [2/4]

#define INTERNAL_FLASH_LUN 0

Definition at line 45 of file at_start_f435/examples/usb_device/msc/inc/msc_diskio.h.

◆ INTERNAL_FLASH_LUN [3/4]

#define INTERNAL_FLASH_LUN 0

Definition at line 45 of file at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h.

◆ INTERNAL_FLASH_LUN [4/4]

#define INTERNAL_FLASH_LUN 0

Definition at line 45 of file at_start_f437/examples/usb_device/msc/inc/msc_diskio.h.

◆ OTG_CLOCK [1/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 71 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_CLOCK [2/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 71 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_IRQ [1/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 72 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_IRQ [2/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 72 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [1/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 73 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [2/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 73 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_DM [1/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 84 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_DM [2/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 84 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [1/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 85 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [2/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 85 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_DP [1/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 81 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_DP [2/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 81 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [1/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 82 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [2/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 82 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_GPIO [1/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 78 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_GPIO [2/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 78 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [1/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 79 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [2/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 79 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_ID [1/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 90 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_ID [2/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 90 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [1/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 91 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [2/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 91 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_MUX [1/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 98 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_MUX [2/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 98 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_SOF [1/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 95 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_SOF [2/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 95 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [1/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 93 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [2/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 93 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [1/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 94 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [2/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 94 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [1/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 96 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [2/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 96 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_VBUS [1/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 87 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_VBUS [2/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 87 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [1/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 88 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [2/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 88 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_USB_ID [1/2]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 64 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_USB_ID [2/2]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 64 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [1/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 76 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [2/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 76 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [1/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 75 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [2/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 75 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [1/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 74 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [2/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 74 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ SD_LUN [1/4]

#define SD_LUN 2

Definition at line 47 of file at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h.

◆ SD_LUN [2/4]

#define SD_LUN 2

Definition at line 47 of file at_start_f435/examples/usb_device/msc/inc/msc_diskio.h.

◆ SD_LUN [3/4]

#define SD_LUN 2

Definition at line 47 of file at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h.

◆ SD_LUN [4/4]

#define SD_LUN 2

Definition at line 47 of file at_start_f437/examples/usb_device/msc/inc/msc_diskio.h.

◆ SECTOR_SIZE_1K [1/4]

#define SECTOR_SIZE_1K 1024

Definition at line 51 of file at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h.

◆ SECTOR_SIZE_1K [2/4]

#define SECTOR_SIZE_1K 1024

Definition at line 51 of file at_start_f435/examples/usb_device/msc/inc/msc_diskio.h.

◆ SECTOR_SIZE_1K [3/4]

#define SECTOR_SIZE_1K 1024

Definition at line 51 of file at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h.

◆ SECTOR_SIZE_1K [4/4]

#define SECTOR_SIZE_1K 1024

Definition at line 51 of file at_start_f437/examples/usb_device/msc/inc/msc_diskio.h.

◆ SECTOR_SIZE_2K [1/4]

#define SECTOR_SIZE_2K 2048

Definition at line 52 of file at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h.

◆ SECTOR_SIZE_2K [2/4]

#define SECTOR_SIZE_2K 2048

Definition at line 52 of file at_start_f435/examples/usb_device/msc/inc/msc_diskio.h.

◆ SECTOR_SIZE_2K [3/4]

#define SECTOR_SIZE_2K 2048

Definition at line 52 of file at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h.

◆ SECTOR_SIZE_2K [4/4]

#define SECTOR_SIZE_2K 2048

Definition at line 52 of file at_start_f437/examples/usb_device/msc/inc/msc_diskio.h.

◆ SECTOR_SIZE_4K [1/4]

#define SECTOR_SIZE_4K 4096

Definition at line 53 of file at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h.

◆ SECTOR_SIZE_4K [2/4]

#define SECTOR_SIZE_4K 4096

Definition at line 53 of file at_start_f435/examples/usb_device/msc/inc/msc_diskio.h.

◆ SECTOR_SIZE_4K [3/4]

#define SECTOR_SIZE_4K 4096

Definition at line 53 of file at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h.

◆ SECTOR_SIZE_4K [4/4]

#define SECTOR_SIZE_4K 4096

Definition at line 53 of file at_start_f437/examples/usb_device/msc/inc/msc_diskio.h.

◆ SPI_FLASH_LUN [1/4]

#define SPI_FLASH_LUN 1

Definition at line 46 of file at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h.

◆ SPI_FLASH_LUN [2/4]

#define SPI_FLASH_LUN 1

Definition at line 46 of file at_start_f435/examples/usb_device/msc/inc/msc_diskio.h.

◆ SPI_FLASH_LUN [3/4]

#define SPI_FLASH_LUN 1

Definition at line 46 of file at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h.

◆ SPI_FLASH_LUN [4/4]

#define SPI_FLASH_LUN 1

Definition at line 46 of file at_start_f437/examples/usb_device/msc/inc/msc_diskio.h.

◆ USB_FLASH_ADDR_OFFSET [1/4]

#define USB_FLASH_ADDR_OFFSET 0x08005000

Definition at line 49 of file at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h.

◆ USB_FLASH_ADDR_OFFSET [2/4]

#define USB_FLASH_ADDR_OFFSET 0x08005000

Definition at line 49 of file at_start_f435/examples/usb_device/msc/inc/msc_diskio.h.

◆ USB_FLASH_ADDR_OFFSET [3/4]

#define USB_FLASH_ADDR_OFFSET 0x08005000

Definition at line 49 of file at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h.

◆ USB_FLASH_ADDR_OFFSET [4/4]

#define USB_FLASH_ADDR_OFFSET 0x08005000

Definition at line 49 of file at_start_f437/examples/usb_device/msc/inc/msc_diskio.h.

◆ USB_ID [1/2]

#define USB_ID 0

Definition at line 70 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ USB_ID [2/2]

#define USB_ID 0

Definition at line 70 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [1/2]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore

Definition at line 200 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [2/2]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore

Definition at line 200 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [1/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 153 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [2/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 153 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [1/2]

#define USBD2_EP1_TX_SIZE 20

Definition at line 154 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [2/2]

#define USBD2_EP1_TX_SIZE 20

Definition at line 154 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [1/2]

#define USBD2_EP2_TX_SIZE 20

Definition at line 155 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [2/2]

#define USBD2_EP2_TX_SIZE 20

Definition at line 155 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [1/2]

#define USBD2_EP3_TX_SIZE 20

Definition at line 156 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [2/2]

#define USBD2_EP3_TX_SIZE 20

Definition at line 156 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [1/2]

#define USBD2_EP4_TX_SIZE 20

Definition at line 157 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [2/2]

#define USBD2_EP4_TX_SIZE 20

Definition at line 157 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [1/2]

#define USBD2_EP5_TX_SIZE 20

Definition at line 158 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [2/2]

#define USBD2_EP5_TX_SIZE 20

Definition at line 158 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [1/2]

#define USBD2_EP6_TX_SIZE 20

Definition at line 159 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [2/2]

#define USBD2_EP6_TX_SIZE 20

Definition at line 159 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [1/2]

#define USBD2_EP7_TX_SIZE 20

Definition at line 160 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [2/2]

#define USBD2_EP7_TX_SIZE 20

Definition at line 160 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD2_RX_SIZE [1/2]

#define USBD2_RX_SIZE 128

Definition at line 152 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD2_RX_SIZE [2/2]

#define USBD2_RX_SIZE 128

Definition at line 152 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [1/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 142 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [2/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 142 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [1/2]

#define USBD_EP1_TX_SIZE 20

Definition at line 143 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [2/2]

#define USBD_EP1_TX_SIZE 20

Definition at line 143 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [1/2]

#define USBD_EP2_TX_SIZE 20

Definition at line 144 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [2/2]

#define USBD_EP2_TX_SIZE 20

Definition at line 144 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [1/2]

#define USBD_EP3_TX_SIZE 20

Definition at line 145 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [2/2]

#define USBD_EP3_TX_SIZE 20

Definition at line 145 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [1/2]

#define USBD_EP4_TX_SIZE 20

Definition at line 146 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [2/2]

#define USBD_EP4_TX_SIZE 20

Definition at line 146 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [1/2]

#define USBD_EP5_TX_SIZE 20

Definition at line 147 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [2/2]

#define USBD_EP5_TX_SIZE 20

Definition at line 147 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [1/2]

#define USBD_EP6_TX_SIZE 20

Definition at line 148 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [2/2]

#define USBD_EP6_TX_SIZE 20

Definition at line 148 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [1/2]

#define USBD_EP7_TX_SIZE 20

Definition at line 149 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [2/2]

#define USBD_EP7_TX_SIZE 20

Definition at line 149 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD_RX_SIZE [1/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 141 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ USBD_RX_SIZE [2/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 141 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [1/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 52 of file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [2/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 52 of file project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 56 of file project/at_start_f435/examples/usb_device/msc/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c.

◆ OTG_IRQ_HANDLER()

void OTG_IRQ_HANDLER ( void )

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 265 of file project/at_start_f435/examples/usb_device/msc/src/main.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc sof signal select: otg1

< acc hick trim

< acc sof signal select: otg1

< acc hick trim

Definition at line 98 of file project/at_start_f435/examples/usb_device/msc/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb low power wakeup handler enable

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 275 of file project/at_start_f435/examples/usb_device/msc/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 286 of file project/at_start_f435/examples/usb_device/msc/src/main.c.

◆ usb_gpio_config()

void usb_gpio_config ( void )

this function config gpio.

Parameters
none
Return values
none

Definition at line 190 of file project/at_start_f435/examples/usb_device/msc/src/main.c.

Referenced by main().

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

Variable Documentation

◆ msc_flash_size [1/2]

uint32_t msc_flash_size

Definition at line 37 of file at_start_f435/examples/usb_device/msc/src/msc_diskio.c.

Referenced by msc_disk_capacity().

◆ msc_flash_size [2/2]

uint32_t msc_flash_size

Definition at line 37 of file at_start_f437/examples/usb_device/msc/src/msc_diskio.c.

◆ otg_core_struct [1/2]

otg_core_type otg_core_struct

Definition at line 46 of file project/at_start_f435/examples/usb_device/msc/src/main.c.

Referenced by main(), and OTG_IRQ_HANDLER().

◆ otg_core_struct [2/2]

otg_core_type otg_core_struct

Definition at line 46 of file project/at_start_f437/examples/usb_device/msc/src/main.c.

◆ scsi_inquiry [1/2]

uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
Initial value:
=
{
{
0x00,
0x80,
0x00,
0x01,
SCSI_INQUIRY_DATA_LENGTH - 5,
0x00, 0x00, 0x00,
'A', 'T', '3', '2', ' ', ' ', ' ', ' ',
'D', 'i', 's', 'k', '0', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ',
'2', '.', '0', '0'
}
}
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:157

Definition at line 38 of file at_start_f435/examples/usb_device/msc/src/msc_diskio.c.

Referenced by get_inquiry().

◆ scsi_inquiry [2/2]

uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
Initial value:
=
{
{
0x00,
0x80,
0x00,
0x01,
SCSI_INQUIRY_DATA_LENGTH - 5,
0x00, 0x00, 0x00,
'A', 'T', '3', '2', ' ', ' ', ' ', ' ',
'D', 'i', 's', 'k', '0', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ',
'2', '.', '0', '0'
}
}

Definition at line 38 of file at_start_f437/examples/usb_device/msc/src/msc_diskio.c.

◆ sector_size [1/2]

uint32_t sector_size = 2048

Definition at line 36 of file at_start_f435/examples/usb_device/msc/src/msc_diskio.c.

Referenced by msc_disk_capacity(), and msc_disk_write().

◆ sector_size [2/2]

uint32_t sector_size = 2048

Definition at line 36 of file at_start_f437/examples/usb_device/msc/src/msc_diskio.c.


AT32F435/437 Firmwary Library: USB_device_composite_vcp_msc

Macros | Functions | Variables
USB_device_composite_vcp_msc
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | USB_LOW_POWER_WAKUP
usb low power wakeup handler enable More...
#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | USB_LOW_POWER_WAKUP
usb low power wakeup handler enable More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
void | button_exint_init (void)
configure button exint More...
void | button_isr (void)
button handler function More...
void | EXINT0_IRQHandler (void)
exint0 interrupt handler More...
int | main (void)
main function. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...

Variables

otg_core_type otg_core_struct
uint8_t | usb_buffer [256]
otg_core_type otg_core_struct
uint8_t | usb_buffer [256]

Detailed Description

Macro Definition Documentation

◆ OTG_CLOCK [1/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 71 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_CLOCK [2/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 71 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_IRQ [1/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 72 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_IRQ [2/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 72 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [1/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 73 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [2/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 73 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_DM [1/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 84 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_DM [2/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 84 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [1/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 85 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [2/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 85 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_DP [1/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 81 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_DP [2/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 81 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [1/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 82 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [2/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 82 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_GPIO [1/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 78 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_GPIO [2/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 78 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [1/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 79 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [2/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 79 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_ID [1/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 90 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_ID [2/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 90 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [1/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 91 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [2/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 91 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_MUX [1/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 98 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_MUX [2/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 98 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_SOF [1/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 95 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_SOF [2/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 95 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [1/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 93 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [2/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 93 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [1/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 94 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [2/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 94 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [1/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 96 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [2/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 96 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_VBUS [1/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 87 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_VBUS [2/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 87 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [1/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 88 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [2/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 88 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_USB_ID [1/2]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 64 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_USB_ID [2/2]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 64 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [1/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 76 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [2/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 76 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [1/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 75 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [2/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 75 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [1/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 74 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [2/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 74 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USB_ID [1/2]

#define USB_ID 0

Definition at line 70 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USB_ID [2/2]

#define USB_ID 0

Definition at line 70 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USB_LOW_POWER_WAKUP [1/2]

#define USB_LOW_POWER_WAKUP

usb low power wakeup handler enable

Definition at line 206 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USB_LOW_POWER_WAKUP [2/2]

#define USB_LOW_POWER_WAKUP

usb low power wakeup handler enable

Definition at line 206 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [1/2]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore

Definition at line 201 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [2/2]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore

Definition at line 201 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [1/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 154 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [2/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 154 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [1/2]

#define USBD2_EP1_TX_SIZE 20

Definition at line 155 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [2/2]

#define USBD2_EP1_TX_SIZE 20

Definition at line 155 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [1/2]

#define USBD2_EP2_TX_SIZE 20

Definition at line 156 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [2/2]

#define USBD2_EP2_TX_SIZE 20

Definition at line 156 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [1/2]

#define USBD2_EP3_TX_SIZE 20

Definition at line 157 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [2/2]

#define USBD2_EP3_TX_SIZE 20

Definition at line 157 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [1/2]

#define USBD2_EP4_TX_SIZE 20

Definition at line 158 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [2/2]

#define USBD2_EP4_TX_SIZE 20

Definition at line 158 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [1/2]

#define USBD2_EP5_TX_SIZE 20

Definition at line 159 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [2/2]

#define USBD2_EP5_TX_SIZE 20

Definition at line 159 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [1/2]

#define USBD2_EP6_TX_SIZE 20

Definition at line 160 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [2/2]

#define USBD2_EP6_TX_SIZE 20

Definition at line 160 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [1/2]

#define USBD2_EP7_TX_SIZE 20

Definition at line 161 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [2/2]

#define USBD2_EP7_TX_SIZE 20

Definition at line 161 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD2_RX_SIZE [1/2]

#define USBD2_RX_SIZE 128

Definition at line 153 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD2_RX_SIZE [2/2]

#define USBD2_RX_SIZE 128

Definition at line 153 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [1/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 143 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [2/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 143 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [1/2]

#define USBD_EP1_TX_SIZE 20

Definition at line 144 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [2/2]

#define USBD_EP1_TX_SIZE 20

Definition at line 144 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [1/2]

#define USBD_EP2_TX_SIZE 20

Definition at line 145 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [2/2]

#define USBD_EP2_TX_SIZE 20

Definition at line 145 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [1/2]

#define USBD_EP3_TX_SIZE 20

Definition at line 146 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [2/2]

#define USBD_EP3_TX_SIZE 20

Definition at line 146 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [1/2]

#define USBD_EP4_TX_SIZE 20

Definition at line 147 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [2/2]

#define USBD_EP4_TX_SIZE 20

Definition at line 147 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [1/2]

#define USBD_EP5_TX_SIZE 20

Definition at line 148 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [2/2]

#define USBD_EP5_TX_SIZE 20

Definition at line 148 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [1/2]

#define USBD_EP6_TX_SIZE 20

Definition at line 149 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [2/2]

#define USBD_EP6_TX_SIZE 20

Definition at line 149 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [1/2]

#define USBD_EP7_TX_SIZE 20

Definition at line 150 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [2/2]

#define USBD_EP7_TX_SIZE 20

Definition at line 150 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD_RX_SIZE [1/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 142 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USBD_RX_SIZE [2/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 142 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [1/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 52 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [2/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 52 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c.

◆ button_exint_init()

void button_exint_init ( void )

configure button exint

Parameters
none
Return values
none

< external interrupt line 0

< external interrupt line 0

Definition at line 59 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c.

Referenced by main().

◆ button_isr()

void button_isr ( void )

button handler function

Parameters
none
Return values
none

< external interrupt line 0

< external interrupt line 0

Definition at line 82 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c.

Referenced by EXINT0_IRQHandler().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c.

◆ EXINT0_IRQHandler()

void EXINT0_IRQHandler ( void )

exint0 interrupt handler

Parameters
none
Return values
none

Definition at line 96 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 108 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c.

◆ OTG_IRQ_HANDLER()

void OTG_IRQ_HANDLER ( void )

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 352 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc sof signal select: otg1

< acc hick trim

< acc sof signal select: otg1

< acc hick trim

Definition at line 184 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

usb low power wakeup handler enable

Parameters
ms number of millisecond delay
Return values
none

Definition at line 362 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 373 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c.

◆ usb_gpio_config()

void usb_gpio_config ( void )

this function config gpio.

Parameters
none
Return values
none

Definition at line 277 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c.

Referenced by main().

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

Variable Documentation

◆ otg_core_struct [1/2]

otg_core_type otg_core_struct

Definition at line 45 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c.

Referenced by main(), and OTG_IRQ_HANDLER().

◆ otg_core_struct [2/2]

otg_core_type otg_core_struct

Definition at line 45 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/src/main.c.

◆ usb_buffer [1/2]

uint8_t usb_buffer[256]

Definition at line 46 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c.

Referenced by main().

◆ usb_buffer [2/2]

uint8_t usb_buffer[256]

Definition at line 46 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/src/main.c.


AT32F435/437 Firmwary Library: _USB_device_cdc_msc

Functions | Variables
_USB_device_cdc_msc
AT32F435_periph_examples | AT32F437_periph_examples

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Variables

uint32_t | sector_size = 2048
uint32_t | msc_flash_size
uint8_t | scsi_inquiry [MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
uint32_t | sector_size = 2048
uint32_t | msc_flash_size
uint8_t | scsi_inquiry [MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]

Detailed Description

Function Documentation

◆ get_inquiry()

uint8_t * get_inquiry ( uint8_t lun )

get disk inquiry

Parameters
lun logical units number
Return values
inquiry string

Definition at line 59 of file at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c.

◆ msc_disk_capacity()

usb_sts_type msc_disk_capacity | ( | uint8_t | lun,
 |  | uint32_t * | blk_nbr,
 |  | uint32_t * | blk_size
 | ) |  |

disk capacity

Parameters
lun | logical units number
blk_nbr | pointer to number of block
blk_size | pointer to block size
Return values
status of usb_sts_type

Definition at line 144 of file at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c.

◆ msc_disk_read()

usb_sts_type msc_disk_read | ( | uint8_t | lun,
 |  | uint32_t | addr,
 |  | uint8_t * | read_buf,
 |  | uint32_t | len
 | ) |  |

disk read

Parameters
lun | logical units number
addr | logical address
read_buf | pointer to read buffer
len | read length
Return values
status of usb_sts_type

Definition at line 75 of file at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c.

◆ msc_disk_write()

usb_sts_type msc_disk_write | ( | uint8_t | lun,
 |  | uint32_t | addr,
 |  | uint8_t * | buf,
 |  | uint32_t | len
 | ) |  |

disk write

Parameters
lun | logical units number
addr | logical address
buf | pointer to write buffer
len | write length
Return values
status of usb_sts_type

Definition at line 106 of file at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c.

Variable Documentation

◆ msc_flash_size [1/2]

uint32_t msc_flash_size

Definition at line 37 of file at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c.

Referenced by msc_disk_capacity().

◆ msc_flash_size [2/2]

uint32_t msc_flash_size

Definition at line 37 of file at_start_f437/examples/usb_device/composite_vcp_msc/src/msc_diskio.c.

◆ scsi_inquiry [1/2]

uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
Initial value:
=
{
{
0x00,
0x80,
0x00,
0x01,
SCSI_INQUIRY_DATA_LENGTH - 5,
0x00, 0x00, 0x00,
'A', 'T', '3', '2', ' ', ' ', ' ', ' ',
'D', 'i', 's', 'k', '0', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ',
'2', '.', '0', '0'
}
}
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:157

Definition at line 38 of file at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c.

Referenced by get_inquiry().

◆ scsi_inquiry [2/2]

uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
Initial value:
=
{
{
0x00,
0x80,
0x00,
0x01,
SCSI_INQUIRY_DATA_LENGTH - 5,
0x00, 0x00, 0x00,
'A', 'T', '3', '2', ' ', ' ', ' ', ' ',
'D', 'i', 's', 'k', '0', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ',
'2', '.', '0', '0'
}
}

Definition at line 38 of file at_start_f437/examples/usb_device/composite_vcp_msc/src/msc_diskio.c.

◆ sector_size [1/2]

uint32_t sector_size = 2048

Definition at line 36 of file at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c.

Referenced by main(), msc_disk_capacity(), and msc_disk_write().

◆ sector_size [2/2]

uint32_t sector_size = 2048

Definition at line 36 of file at_start_f437/examples/usb_device/composite_vcp_msc/src/msc_diskio.c.


AT32F435/437 Firmwary Library: USB_device_custom_hid

Macros | Functions | Variables
USB_device_custom_hid
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
int | main (void)
main function. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...

Variables

otg_core_type otg_core_struct
uint8_t | report_buf [USBD_CUSTOM_IN_MAXPACKET_SIZE]
otg_core_type otg_core_struct
uint8_t | report_buf [USBD_CUSTOM_IN_MAXPACKET_SIZE]

Detailed Description

Macro Definition Documentation

◆ OTG_CLOCK [1/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 69 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_CLOCK [2/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 69 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_IRQ [1/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 70 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_IRQ [2/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 70 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [1/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 71 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [2/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 71 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_DM [1/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 82 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_DM [2/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 82 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [1/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 83 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [2/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 83 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_DP [1/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 79 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_DP [2/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 79 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [1/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 80 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [2/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 80 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_GPIO [1/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 76 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_GPIO [2/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 76 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [1/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 77 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [2/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 77 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_ID [1/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 88 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_ID [2/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 88 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [1/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 89 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [2/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 89 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_MUX [1/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 96 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_MUX [2/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 96 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_SOF [1/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 93 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_SOF [2/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 93 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [1/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 91 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [2/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 91 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [1/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 92 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [2/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 92 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [1/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 94 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [2/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 94 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_VBUS [1/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 85 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_VBUS [2/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 85 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [1/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 86 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [2/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 86 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_USB_ID [1/2]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 62 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_USB_ID [2/2]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 62 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [1/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 74 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [2/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 74 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [1/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 73 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [2/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 73 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [1/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 72 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [2/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 72 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USB_ID [1/2]

#define USB_ID 0

Definition at line 68 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USB_ID [2/2]

#define USB_ID 0

Definition at line 68 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [1/2]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore

Definition at line 198 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [2/2]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore

Definition at line 198 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [1/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 151 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [2/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 151 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [1/2]

#define USBD2_EP1_TX_SIZE 20

Definition at line 152 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [2/2]

#define USBD2_EP1_TX_SIZE 20

Definition at line 152 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [1/2]

#define USBD2_EP2_TX_SIZE 20

Definition at line 153 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [2/2]

#define USBD2_EP2_TX_SIZE 20

Definition at line 153 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [1/2]

#define USBD2_EP3_TX_SIZE 20

Definition at line 154 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [2/2]

#define USBD2_EP3_TX_SIZE 20

Definition at line 154 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [1/2]

#define USBD2_EP4_TX_SIZE 20

Definition at line 155 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [2/2]

#define USBD2_EP4_TX_SIZE 20

Definition at line 155 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [1/2]

#define USBD2_EP5_TX_SIZE 20

Definition at line 156 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [2/2]

#define USBD2_EP5_TX_SIZE 20

Definition at line 156 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [1/2]

#define USBD2_EP6_TX_SIZE 20

Definition at line 157 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [2/2]

#define USBD2_EP6_TX_SIZE 20

Definition at line 157 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [1/2]

#define USBD2_EP7_TX_SIZE 20

Definition at line 158 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [2/2]

#define USBD2_EP7_TX_SIZE 20

Definition at line 158 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD2_RX_SIZE [1/2]

#define USBD2_RX_SIZE 128

Definition at line 150 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD2_RX_SIZE [2/2]

#define USBD2_RX_SIZE 128

Definition at line 150 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [1/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 140 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [2/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 140 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [1/2]

#define USBD_EP1_TX_SIZE 20

Definition at line 141 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [2/2]

#define USBD_EP1_TX_SIZE 20

Definition at line 141 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [1/2]

#define USBD_EP2_TX_SIZE 20

Definition at line 142 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [2/2]

#define USBD_EP2_TX_SIZE 20

Definition at line 142 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [1/2]

#define USBD_EP3_TX_SIZE 20

Definition at line 143 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [2/2]

#define USBD_EP3_TX_SIZE 20

Definition at line 143 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [1/2]

#define USBD_EP4_TX_SIZE 20

Definition at line 144 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [2/2]

#define USBD_EP4_TX_SIZE 20

Definition at line 144 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [1/2]

#define USBD_EP5_TX_SIZE 20

Definition at line 145 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [2/2]

#define USBD_EP5_TX_SIZE 20

Definition at line 145 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [1/2]

#define USBD_EP6_TX_SIZE 20

Definition at line 146 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [2/2]

#define USBD_EP6_TX_SIZE 20

Definition at line 146 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [1/2]

#define USBD_EP7_TX_SIZE 20

Definition at line 147 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [2/2]

#define USBD_EP7_TX_SIZE 20

Definition at line 147 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD_RX_SIZE [1/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 139 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USBD_RX_SIZE [2/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 139 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [1/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 50 of file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [2/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 50 of file project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f435/examples/usb_device/custom_hid/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c.

◆ OTG_IRQ_HANDLER()

void OTG_IRQ_HANDLER ( void )

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 269 of file project/at_start_f435/examples/usb_device/custom_hid/src/main.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc sof signal select: otg1

< acc hick trim

< acc sof signal select: otg1

< acc hick trim

Definition at line 102 of file project/at_start_f435/examples/usb_device/custom_hid/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb low power wakeup handler enable

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 279 of file project/at_start_f435/examples/usb_device/custom_hid/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 290 of file project/at_start_f435/examples/usb_device/custom_hid/src/main.c.

◆ usb_gpio_config()

void usb_gpio_config ( void )

this function config gpio.

Parameters
none
Return values
none

Definition at line 194 of file project/at_start_f435/examples/usb_device/custom_hid/src/main.c.

Referenced by main().

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

Variable Documentation

◆ otg_core_struct [1/2]

otg_core_type otg_core_struct

Definition at line 44 of file project/at_start_f435/examples/usb_device/custom_hid/src/main.c.

Referenced by main(), and OTG_IRQ_HANDLER().

◆ otg_core_struct [2/2]

otg_core_type otg_core_struct

Definition at line 44 of file project/at_start_f437/examples/usb_device/custom_hid/src/main.c.

◆ report_buf [1/2]

uint8_t report_buf[USBD_CUSTOM_IN_MAXPACKET_SIZE]

Definition at line 45 of file project/at_start_f435/examples/usb_device/custom_hid/src/main.c.

Referenced by main().

◆ report_buf [2/2]

uint8_t report_buf[USBD_CUSTOM_IN_MAXPACKET_SIZE]

Definition at line 45 of file project/at_start_f437/examples/usb_device/custom_hid/src/main.c.


AT32F435/437 Firmwary Library: USB_device_keyboard

Macros | Functions | Variables
USB_device_keyboard
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | keyboard_send_string (void *udev, uint8_t *string, uint8_t len)
keyboard send string More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
void | system_clock_recover (void)
system clock recover. More...
void | button_exint_init (void)
configure button exint More...
int | main (void)
main function. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...

Variables

otg_core_type otg_core_struct
__IO uint8_t | hid_suspend_flag
otg_core_type otg_core_struct
__IO uint8_t | hid_suspend_flag

Detailed Description

Macro Definition Documentation

◆ OTG_CLOCK [1/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 70 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_CLOCK [2/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 70 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_IRQ [1/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 71 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_IRQ [2/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 71 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [1/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 72 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [2/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 72 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_DM [1/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 83 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_DM [2/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 83 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [1/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 84 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [2/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 84 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_DP [1/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 80 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_DP [2/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 80 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [1/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 81 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [2/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 81 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_GPIO [1/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 77 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_GPIO [2/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 77 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [1/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 78 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [2/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 78 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_ID [1/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 89 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_ID [2/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 89 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [1/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 90 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [2/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 90 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_MUX [1/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 97 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_MUX [2/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 97 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_SOF [1/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 94 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_SOF [2/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 94 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [1/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 92 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [2/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 92 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [1/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 93 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [2/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 93 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [1/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 95 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [2/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 95 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_VBUS [1/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 86 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_VBUS [2/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 86 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [1/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 87 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [2/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 87 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_USB_ID [1/2]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 64 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_USB_ID [2/2]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 64 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [1/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 75 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [2/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 75 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [1/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 74 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [2/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 74 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [1/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 73 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [2/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 73 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USB_ID [1/2]

#define USB_ID 0

Definition at line 69 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USB_ID [2/2]

#define USB_ID 0

Definition at line 69 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [1/2]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore

Definition at line 199 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [2/2]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore

Definition at line 199 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [1/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 152 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [2/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 152 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [1/2]

#define USBD2_EP1_TX_SIZE 20

Definition at line 153 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [2/2]

#define USBD2_EP1_TX_SIZE 20

Definition at line 153 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [1/2]

#define USBD2_EP2_TX_SIZE 20

Definition at line 154 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [2/2]

#define USBD2_EP2_TX_SIZE 20

Definition at line 154 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [1/2]

#define USBD2_EP3_TX_SIZE 20

Definition at line 155 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [2/2]

#define USBD2_EP3_TX_SIZE 20

Definition at line 155 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [1/2]

#define USBD2_EP4_TX_SIZE 20

Definition at line 156 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [2/2]

#define USBD2_EP4_TX_SIZE 20

Definition at line 156 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [1/2]

#define USBD2_EP5_TX_SIZE 20

Definition at line 157 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [2/2]

#define USBD2_EP5_TX_SIZE 20

Definition at line 157 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [1/2]

#define USBD2_EP6_TX_SIZE 20

Definition at line 158 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [2/2]

#define USBD2_EP6_TX_SIZE 20

Definition at line 158 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [1/2]

#define USBD2_EP7_TX_SIZE 20

Definition at line 159 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [2/2]

#define USBD2_EP7_TX_SIZE 20

Definition at line 159 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD2_RX_SIZE [1/2]

#define USBD2_RX_SIZE 128

Definition at line 151 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD2_RX_SIZE [2/2]

#define USBD2_RX_SIZE 128

Definition at line 151 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [1/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 141 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [2/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 141 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [1/2]

#define USBD_EP1_TX_SIZE 20

Definition at line 142 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [2/2]

#define USBD_EP1_TX_SIZE 20

Definition at line 142 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [1/2]

#define USBD_EP2_TX_SIZE 20

Definition at line 143 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [2/2]

#define USBD_EP2_TX_SIZE 20

Definition at line 143 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [1/2]

#define USBD_EP3_TX_SIZE 20

Definition at line 144 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [2/2]

#define USBD_EP3_TX_SIZE 20

Definition at line 144 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [1/2]

#define USBD_EP4_TX_SIZE 20

Definition at line 145 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [2/2]

#define USBD_EP4_TX_SIZE 20

Definition at line 145 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [1/2]

#define USBD_EP5_TX_SIZE 20

Definition at line 146 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [2/2]

#define USBD_EP5_TX_SIZE 20

Definition at line 146 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [1/2]

#define USBD_EP6_TX_SIZE 20

Definition at line 147 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [2/2]

#define USBD_EP6_TX_SIZE 20

Definition at line 147 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [1/2]

#define USBD_EP7_TX_SIZE 20

Definition at line 148 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [2/2]

#define USBD_EP7_TX_SIZE 20

Definition at line 148 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD_RX_SIZE [1/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 140 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USBD_RX_SIZE [2/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 140 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [1/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 52 of file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [2/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 52 of file project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c.

◆ button_exint_init()

void button_exint_init ( void )

configure button exint

Parameters
none
Return values
none

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

Definition at line 61 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c.

◆ keyboard_send_string()

void keyboard_send_string | ( | void * | udev,
 |  | uint8_t * | string,
 |  | uint8_t | len
 | ) |  |

keyboard send string

Parameters
string | send string
len | send string length
Return values
none

Definition at line 60 of file project/at_start_f435/examples/usb_device/keyboard/src/main.c.

Referenced by main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 96 of file project/at_start_f435/examples/usb_device/keyboard/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c.

◆ OTG_IRQ_HANDLER()

void OTG_IRQ_HANDLER ( void )

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 411 of file project/at_start_f435/examples/usb_device/keyboard/src/main.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c.

◆ system_clock_recover()

void system_clock_recover ( void )

system clock recover.

Parameters
none
Return values
none

< phase locking loop stable flag

< phase locking loop stable flag

< phase locking loop stable flag

< phase locking loop stable flag

< phase locking loop stable flag

< phase locking loop stable flag

< phase locking loop stable flag

< phase locking loop stable flag

Definition at line 141 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c.

Referenced by main().

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc sof signal select: otg1

< acc hick trim

< acc sof signal select: otg1

< acc hick trim

Definition at line 182 of file project/at_start_f435/examples/usb_device/keyboard/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb low power wakeup handler enable

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 421 of file project/at_start_f435/examples/usb_device/keyboard/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 432 of file project/at_start_f435/examples/usb_device/keyboard/src/main.c.

◆ usb_gpio_config()

void usb_gpio_config ( void )

this function config gpio.

Parameters
none
Return values
none

Definition at line 274 of file project/at_start_f435/examples/usb_device/keyboard/src/main.c.

Referenced by main().

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

Variable Documentation

◆ hid_suspend_flag [1/2]

__IO uint8_t hid_suspend_flag
extern

Referenced by main().

◆ hid_suspend_flag [2/2]

__IO uint8_t hid_suspend_flag
extern

◆ otg_core_struct [1/2]

otg_core_type otg_core_struct

Definition at line 45 of file project/at_start_f435/examples/usb_device/keyboard/src/main.c.

Referenced by main(), and OTG_IRQ_HANDLER().

◆ otg_core_struct [2/2]

otg_core_type otg_core_struct

Definition at line 45 of file project/at_start_f437/examples/usb_device/keyboard/src/main.c.


AT32F435/437 Firmwary Library: USB_device_mouse

Macros | Functions | Variables
USB_device_mouse
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | USB_LOW_POWER_WAKUP
usb low power wakeup handler enable More...
#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | USB_LOW_POWER_WAKUP
usb low power wakeup handler enable More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | keyboard_send_string (uint8_t *string, uint8_t len)
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
void | system_clock_recover (void)
system clock recover. More...
void | button_exint_init (void)
configure button exint More...
int | main (void)
main function. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...

Variables

otg_core_type otg_core_struct
__IO uint8_t | press_mouse = 0
otg_core_type otg_core_struct
__IO uint8_t | press_mouse = 0

Detailed Description

Macro Definition Documentation

◆ OTG_CLOCK [1/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 71 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_CLOCK [2/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 71 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_IRQ [1/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 72 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_IRQ [2/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 72 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [1/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 73 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [2/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 73 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_DM [1/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 84 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_DM [2/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 84 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [1/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 85 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [2/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 85 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_DP [1/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 81 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_DP [2/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 81 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [1/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 82 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [2/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 82 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_GPIO [1/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 78 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_GPIO [2/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 78 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [1/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 79 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [2/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 79 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_ID [1/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 90 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_ID [2/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 90 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [1/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 91 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [2/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 91 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_MUX [1/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 98 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_MUX [2/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 98 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_SOF [1/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 95 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_SOF [2/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 95 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [1/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 93 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [2/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 93 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [1/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 94 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [2/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 94 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [1/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 96 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [2/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 96 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_VBUS [1/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 87 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_VBUS [2/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 87 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [1/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 88 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [2/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 88 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_USB_ID [1/2]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 64 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_USB_ID [2/2]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 64 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [1/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 76 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [2/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 76 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [1/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 75 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [2/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 75 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [1/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 74 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [2/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 74 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ USB_ID [1/2]

#define USB_ID 0

Definition at line 70 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ USB_ID [2/2]

#define USB_ID 0

Definition at line 70 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ USB_LOW_POWER_WAKUP [1/2]

#define USB_LOW_POWER_WAKUP

usb low power wakeup handler enable

Definition at line 205 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ USB_LOW_POWER_WAKUP [2/2]

#define USB_LOW_POWER_WAKUP

usb low power wakeup handler enable

Definition at line 205 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [1/2]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore

Definition at line 200 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [2/2]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore

Definition at line 200 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [1/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 153 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [2/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 153 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [1/2]

#define USBD2_EP1_TX_SIZE 20

Definition at line 154 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [2/2]

#define USBD2_EP1_TX_SIZE 20

Definition at line 154 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [1/2]

#define USBD2_EP2_TX_SIZE 20

Definition at line 155 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [2/2]

#define USBD2_EP2_TX_SIZE 20

Definition at line 155 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [1/2]

#define USBD2_EP3_TX_SIZE 20

Definition at line 156 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [2/2]

#define USBD2_EP3_TX_SIZE 20

Definition at line 156 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [1/2]

#define USBD2_EP4_TX_SIZE 20

Definition at line 157 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [2/2]

#define USBD2_EP4_TX_SIZE 20

Definition at line 157 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [1/2]

#define USBD2_EP5_TX_SIZE 20

Definition at line 158 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [2/2]

#define USBD2_EP5_TX_SIZE 20

Definition at line 158 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [1/2]

#define USBD2_EP6_TX_SIZE 20

Definition at line 159 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [2/2]

#define USBD2_EP6_TX_SIZE 20

Definition at line 159 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [1/2]

#define USBD2_EP7_TX_SIZE 20

Definition at line 160 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [2/2]

#define USBD2_EP7_TX_SIZE 20

Definition at line 160 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD2_RX_SIZE [1/2]

#define USBD2_RX_SIZE 128

Definition at line 152 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD2_RX_SIZE [2/2]

#define USBD2_RX_SIZE 128

Definition at line 152 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [1/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 142 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [2/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 142 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [1/2]

#define USBD_EP1_TX_SIZE 20

Definition at line 143 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [2/2]

#define USBD_EP1_TX_SIZE 20

Definition at line 143 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [1/2]

#define USBD_EP2_TX_SIZE 20

Definition at line 144 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [2/2]

#define USBD_EP2_TX_SIZE 20

Definition at line 144 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [1/2]

#define USBD_EP3_TX_SIZE 20

Definition at line 145 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [2/2]

#define USBD_EP3_TX_SIZE 20

Definition at line 145 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [1/2]

#define USBD_EP4_TX_SIZE 20

Definition at line 146 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [2/2]

#define USBD_EP4_TX_SIZE 20

Definition at line 146 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [1/2]

#define USBD_EP5_TX_SIZE 20

Definition at line 147 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [2/2]

#define USBD_EP5_TX_SIZE 20

Definition at line 147 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [1/2]

#define USBD_EP6_TX_SIZE 20

Definition at line 148 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [2/2]

#define USBD_EP6_TX_SIZE 20

Definition at line 148 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [1/2]

#define USBD_EP7_TX_SIZE 20

Definition at line 149 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [2/2]

#define USBD_EP7_TX_SIZE 20

Definition at line 149 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD_RX_SIZE [1/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 141 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ USBD_RX_SIZE [2/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 141 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [1/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 52 of file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [2/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 52 of file project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c.

◆ button_exint_init()

void button_exint_init ( void )

configure button exint

Parameters
none
Return values
none

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

Definition at line 61 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c.

◆ keyboard_send_string()

void keyboard_send_string | ( | uint8_t * | string,
 |  | uint8_t | len
 | ) |  |

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 59 of file project/at_start_f435/examples/usb_device/mouse/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c.

◆ OTG_IRQ_HANDLER()

void OTG_IRQ_HANDLER ( void )

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 380 of file project/at_start_f435/examples/usb_device/mouse/src/main.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c.

◆ system_clock_recover()

void system_clock_recover ( void )

system clock recover.

Parameters
none
Return values
none

< phase locking loop stable flag

< phase locking loop stable flag

< phase locking loop stable flag

< phase locking loop stable flag

< phase locking loop stable flag

< phase locking loop stable flag

< phase locking loop stable flag

< phase locking loop stable flag

Definition at line 141 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c.

Referenced by main().

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc sof signal select: otg1

< acc hick trim

< acc sof signal select: otg1

< acc hick trim

Definition at line 152 of file project/at_start_f435/examples/usb_device/mouse/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

usb low power wakeup handler enable

Parameters
ms number of millisecond delay
Return values
none

Definition at line 390 of file project/at_start_f435/examples/usb_device/mouse/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 401 of file project/at_start_f435/examples/usb_device/mouse/src/main.c.

◆ usb_gpio_config()

void usb_gpio_config ( void )

this function config gpio.

Parameters
none
Return values
none

Definition at line 244 of file project/at_start_f435/examples/usb_device/mouse/src/main.c.

Referenced by main().

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

Variable Documentation

◆ otg_core_struct [1/2]

otg_core_type otg_core_struct

Definition at line 45 of file project/at_start_f435/examples/usb_device/mouse/src/main.c.

Referenced by main(), and OTG_IRQ_HANDLER().

◆ otg_core_struct [2/2]

otg_core_type otg_core_struct

Definition at line 45 of file project/at_start_f437/examples/usb_device/mouse/src/main.c.

◆ press_mouse [1/2]

__IO uint8_t press_mouse = 0

Definition at line 46 of file project/at_start_f435/examples/usb_device/mouse/src/main.c.

Referenced by main().

◆ press_mouse [2/2]

__IO uint8_t press_mouse = 0

Definition at line 46 of file project/at_start_f437/examples/usb_device/mouse/src/main.c.


AT32F435/437 Firmwary Library: USB_device_otg1_host_otg2_device_demo

Macros | Functions | Variables
USB_device_otg1_host_otg2_device_demo
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | USE_OTG_HOST_MODE
enable usb host mode More...
#define | USB_ID 0
select otgfs1 or otgfs2 define More...
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | OTG_PIN_POWER_SWITCH_GPIO GPIOH
#define | OTG_PIN_POWER_SWITCH_CLOCK CRM_GPIOH_PERIPH_CLOCK
#define | OTG_PIN_POWER_SWITCH GPIO_PINS_3
#define | USB2_ID 1
#define | OTG2_CLOCK CRM_OTGFS2_PERIPH_CLOCK
#define | OTG2_IRQ OTGFS2_IRQn
#define | OTG2_WKUP_IRQ OTGFS2_WKUP_IRQn
#define | OTG2_WKUP_HANDLER OTGFS2_WKUP_IRQHandler
#define | OTG2_WKUP_EXINT_LINE EXINT_LINE_20
#define | OTG2_PIN_GPIO GPIOB
#define | OTG2_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK
#define | OTG2_PIN_DP GPIO_PINS_15
#define | OTG2_PIN_DP_SOURCE GPIO_PINS_SOURCE15
#define | OTG2_PIN_DM GPIO_PINS_14
#define | OTG2_PIN_DM_SOURCE GPIO_PINS_SOURCE14
#define | OTG2_PIN_VBUS GPIO_PINS_13
#define | OTG2_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13
#define | OTG2_PIN_ID GPIO_PINS_12
#define | OTG2_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG2_PIN_SOF_GPIO GPIOA
#define | OTG2_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG2_PIN_SOF GPIO_PINS_4
#define | OTG2_PIN_SOF_SOURCE GPIO_PINS_SOURCE4
#define | OTG2_PIN_MUX GPIO_MUX_12
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USBH_RX_FIFO_SIZE 128
usb endpoint max num define More...
#define | USBH_NP_TX_FIFO_SIZE 96
#define | USBH_P_TX_FIFO_SIZE 96
#define | USBH2_RX_FIFO_SIZE 128
#define | USBH2_NP_TX_FIFO_SIZE 96
#define | USBH2_P_TX_FIFO_SIZE 96
#define | USBH_5V_POWER_SWITCH
#define | USB_VBUS_IGNORE
usb sof output enable More...
#define | USBH_DEBUG_ENABLE
usb low power wakeup handler enable More...
#define | USBH_DEBUG(...)
#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | USE_OTG_HOST_MODE
enable usb host mode More...
#define | USB_ID 0
select otgfs1 or otgfs2 define More...
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | OTG_PIN_POWER_SWITCH_GPIO GPIOH
#define | OTG_PIN_POWER_SWITCH_CLOCK CRM_GPIOH_PERIPH_CLOCK
#define | OTG_PIN_POWER_SWITCH GPIO_PINS_3
#define | USB2_ID 1
#define | OTG2_CLOCK CRM_OTGFS2_PERIPH_CLOCK
#define | OTG2_IRQ OTGFS2_IRQn
#define | OTG2_IRQ_HANDLER OTGFS2_IRQHandler
#define | OTG2_WKUP_IRQ OTGFS2_WKUP_IRQn
#define | OTG2_WKUP_HANDLER OTGFS2_WKUP_IRQHandler
#define | OTG2_WKUP_EXINT_LINE EXINT_LINE_20
#define | OTG2_PIN_GPIO GPIOB
#define | OTG2_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK
#define | OTG2_PIN_DP GPIO_PINS_15
#define | OTG2_PIN_DP_SOURCE GPIO_PINS_SOURCE15
#define | OTG2_PIN_DM GPIO_PINS_14
#define | OTG2_PIN_DM_SOURCE GPIO_PINS_SOURCE14
#define | OTG2_PIN_VBUS GPIO_PINS_13
#define | OTG2_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13
#define | OTG2_PIN_ID GPIO_PINS_12
#define | OTG2_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG2_PIN_SOF_GPIO GPIOA
#define | OTG2_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG2_PIN_SOF GPIO_PINS_4
#define | OTG2_PIN_SOF_SOURCE GPIO_PINS_SOURCE4
#define | OTG2_PIN_MUX GPIO_MUX_12
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USBH_RX_FIFO_SIZE 128
usb endpoint max num define More...
#define | USBH_NP_TX_FIFO_SIZE 96
#define | USBH_P_TX_FIFO_SIZE 96
#define | USBH2_RX_FIFO_SIZE 128
#define | USBH2_NP_TX_FIFO_SIZE 96
#define | USBH2_P_TX_FIFO_SIZE 96
#define | USBH_5V_POWER_SWITCH
#define | USB_VBUS_IGNORE
usb sof output enable More...
#define | USBH_DEBUG_ENABLE
usb low power wakeup handler enable More...
#define | USBH_DEBUG(...)

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
void | button_exint_init (void)
configure button exint More...
void | button_isr (void)
button handler function More...
int | main (void)
main function. More...
void | EXINT0_IRQHandler (void)
exint0 interrupt handler More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...
void | OTG2_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...
static usb_sts_type | usbh_user_init (void)
usb host init user handler More...
static usb_sts_type | usbh_user_reset (void)
usb host reset user handler More...
static usb_sts_type | usbh_user_attached (void)
usb host check device attached More...
static usb_sts_type | usbh_user_disconnect (void)
usb host discconet user handler More...
static usb_sts_type | usbh_user_speed (uint8_t speed)
usb host speed user handler More...
static usb_sts_type | usbh_user_mfc_string (void *string)
usb host manufacturer string user handler More...
static usb_sts_type | usbh_user_product_string (void *string)
usb host product string user handler More...
static usb_sts_type | usbh_user_serial_string (void *string)
usb host serial string user handler More...
static usb_sts_type | usbh_user_enumeration_done (void)
usb host enumeration done user handler More...
static usb_sts_type | usbh_user_application (void)
usb host application user handler More...
static usb_sts_type | usbh_user_active_vbus (void *uhost, confirm_state state)
usb host active vbus user handler More...
static usb_sts_type | usbh_user_not_support (void)
usb host not support user handler More...

Variables

otg_core_type otg_core_struct
otg_core_type otg2_core_struct
uint8_t | report_buf [USBD_CUSTOM_IN_MAXPACKET_SIZE]
__IO uint8_t | button_press = 0
usbh_user_handler_type | usbh_user_handle
otg_core_type otg_core_struct
otg_core_type otg2_core_struct
uint8_t | report_buf [USBD_CUSTOM_IN_MAXPACKET_SIZE]
__IO uint8_t | button_press = 0
usbh_user_handler_type | usbh_user_handle

Detailed Description

Macro Definition Documentation

◆ OTG2_CLOCK [1/2]

#define OTG2_CLOCK CRM_OTGFS2_PERIPH_CLOCK

Definition at line 97 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_CLOCK [2/2]

#define OTG2_CLOCK CRM_OTGFS2_PERIPH_CLOCK

Definition at line 97 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_IRQ [1/2]

#define OTG2_IRQ OTGFS2_IRQn

Definition at line 98 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_IRQ [2/2]

#define OTG2_IRQ OTGFS2_IRQn

Definition at line 98 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_IRQ_HANDLER

#define OTG2_IRQ_HANDLER ( void ) OTGFS2_IRQHandler

Definition at line 99 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_DM [1/2]

#define OTG2_PIN_DM GPIO_PINS_14

Definition at line 110 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_DM [2/2]

#define OTG2_PIN_DM GPIO_PINS_14

Definition at line 110 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_DM_SOURCE [1/2]

#define OTG2_PIN_DM_SOURCE GPIO_PINS_SOURCE14

Definition at line 111 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_DM_SOURCE [2/2]

#define OTG2_PIN_DM_SOURCE GPIO_PINS_SOURCE14

Definition at line 111 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_DP [1/2]

#define OTG2_PIN_DP GPIO_PINS_15

Definition at line 107 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_DP [2/2]

#define OTG2_PIN_DP GPIO_PINS_15

Definition at line 107 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_DP_SOURCE [1/2]

#define OTG2_PIN_DP_SOURCE GPIO_PINS_SOURCE15

Definition at line 108 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_DP_SOURCE [2/2]

#define OTG2_PIN_DP_SOURCE GPIO_PINS_SOURCE15

Definition at line 108 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_GPIO [1/2]

#define OTG2_PIN_GPIO GPIOB

Definition at line 104 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_GPIO [2/2]

#define OTG2_PIN_GPIO GPIOB

Definition at line 104 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_GPIO_CLOCK [1/2]

#define OTG2_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK

Definition at line 105 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_GPIO_CLOCK [2/2]

#define OTG2_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK

Definition at line 105 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_ID [1/2]

#define OTG2_PIN_ID GPIO_PINS_12

Definition at line 116 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_ID [2/2]

#define OTG2_PIN_ID GPIO_PINS_12

Definition at line 116 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_ID_SOURCE [1/2]

#define OTG2_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 117 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_ID_SOURCE [2/2]

#define OTG2_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 117 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_MUX [1/2]

#define OTG2_PIN_MUX GPIO_MUX_12

Definition at line 124 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_MUX [2/2]

#define OTG2_PIN_MUX GPIO_MUX_12

Definition at line 124 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_SOF [1/2]

#define OTG2_PIN_SOF GPIO_PINS_4

Definition at line 121 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_SOF [2/2]

#define OTG2_PIN_SOF GPIO_PINS_4

Definition at line 121 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_SOF_GPIO [1/2]

#define OTG2_PIN_SOF_GPIO GPIOA

Definition at line 119 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_SOF_GPIO [2/2]

#define OTG2_PIN_SOF_GPIO GPIOA

Definition at line 119 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_SOF_GPIO_CLOCK [1/2]

#define OTG2_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 120 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_SOF_GPIO_CLOCK [2/2]

#define OTG2_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 120 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_SOF_SOURCE [1/2]

#define OTG2_PIN_SOF_SOURCE GPIO_PINS_SOURCE4

Definition at line 122 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_SOF_SOURCE [2/2]

#define OTG2_PIN_SOF_SOURCE GPIO_PINS_SOURCE4

Definition at line 122 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_VBUS [1/2]

#define OTG2_PIN_VBUS GPIO_PINS_13

Definition at line 113 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_VBUS [2/2]

#define OTG2_PIN_VBUS GPIO_PINS_13

Definition at line 113 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_VBUS_SOURCE [1/2]

#define OTG2_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13

Definition at line 114 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_VBUS_SOURCE [2/2]

#define OTG2_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13

Definition at line 114 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_WKUP_EXINT_LINE [1/2]

#define OTG2_WKUP_EXINT_LINE EXINT_LINE_20

Definition at line 102 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_WKUP_EXINT_LINE [2/2]

#define OTG2_WKUP_EXINT_LINE EXINT_LINE_20

Definition at line 102 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_WKUP_HANDLER [1/2]

#define OTG2_WKUP_HANDLER OTGFS2_WKUP_IRQHandler

Definition at line 101 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_WKUP_HANDLER [2/2]

#define OTG2_WKUP_HANDLER OTGFS2_WKUP_IRQHandler

Definition at line 101 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_WKUP_IRQ [1/2]

#define OTG2_WKUP_IRQ OTGFS2_WKUP_IRQn

Definition at line 100 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_WKUP_IRQ [2/2]

#define OTG2_WKUP_IRQ OTGFS2_WKUP_IRQn

Definition at line 100 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_CLOCK [1/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 63 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_CLOCK [2/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 63 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_IRQ [1/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 64 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_IRQ [2/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 64 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [1/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 65 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [2/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 65 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_DM [1/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 76 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_DM [2/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 76 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [1/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 77 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [2/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 77 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_DP [1/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 73 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_DP [2/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 73 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [1/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 74 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [2/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 74 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_GPIO [1/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 70 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_GPIO [2/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 70 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [1/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 71 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [2/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 71 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_ID [1/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 82 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_ID [2/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 82 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [1/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 83 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [2/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 83 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_MUX [1/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 90 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_MUX [2/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 90 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_POWER_SWITCH [1/2]

#define OTG_PIN_POWER_SWITCH GPIO_PINS_3

Definition at line 93 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_POWER_SWITCH [2/2]

#define OTG_PIN_POWER_SWITCH GPIO_PINS_3

Definition at line 93 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_POWER_SWITCH_CLOCK [1/2]

#define OTG_PIN_POWER_SWITCH_CLOCK CRM_GPIOH_PERIPH_CLOCK

Definition at line 92 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_POWER_SWITCH_CLOCK [2/2]

#define OTG_PIN_POWER_SWITCH_CLOCK CRM_GPIOH_PERIPH_CLOCK

Definition at line 92 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_POWER_SWITCH_GPIO [1/2]

#define OTG_PIN_POWER_SWITCH_GPIO GPIOH

Definition at line 91 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_POWER_SWITCH_GPIO [2/2]

#define OTG_PIN_POWER_SWITCH_GPIO GPIOH

Definition at line 91 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF [1/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 87 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF [2/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 87 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [1/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 85 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [2/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 85 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [1/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 86 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [2/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 86 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [1/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 88 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [2/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 88 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_VBUS [1/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 79 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_VBUS [2/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 79 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [1/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 80 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [2/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 80 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [1/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 68 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [2/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 68 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [1/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 67 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [2/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 67 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [1/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 66 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [2/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 66 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USB2_ID [1/2]

#define USB2_ID 1

Definition at line 96 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USB2_ID [2/2]

#define USB2_ID 1

Definition at line 96 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USB_ID [1/2]

#define USB_ID 0

select otgfs1 or otgfs2 define

Definition at line 62 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USB_ID [2/2]

#define USB_ID 0

select otgfs1 or otgfs2 define

Definition at line 62 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [1/2]

#define USB_VBUS_IGNORE

usb sof output enable

usb vbus ignore, not use vbus pin

Definition at line 196 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [2/2]

#define USB_VBUS_IGNORE

usb sof output enable

usb vbus ignore, not use vbus pin

Definition at line 196 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [1/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 146 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [2/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 146 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [1/2]

#define USBD2_EP1_TX_SIZE 20

Definition at line 147 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [2/2]

#define USBD2_EP1_TX_SIZE 20

Definition at line 147 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [1/2]

#define USBD2_EP2_TX_SIZE 20

Definition at line 148 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [2/2]

#define USBD2_EP2_TX_SIZE 20

Definition at line 148 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [1/2]

#define USBD2_EP3_TX_SIZE 20

Definition at line 149 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [2/2]

#define USBD2_EP3_TX_SIZE 20

Definition at line 149 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [1/2]

#define USBD2_EP4_TX_SIZE 20

Definition at line 150 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [2/2]

#define USBD2_EP4_TX_SIZE 20

Definition at line 150 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [1/2]

#define USBD2_EP5_TX_SIZE 20

Definition at line 151 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [2/2]

#define USBD2_EP5_TX_SIZE 20

Definition at line 151 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [1/2]

#define USBD2_EP6_TX_SIZE 20

Definition at line 152 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [2/2]

#define USBD2_EP6_TX_SIZE 20

Definition at line 152 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [1/2]

#define USBD2_EP7_TX_SIZE 20

Definition at line 153 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [2/2]

#define USBD2_EP7_TX_SIZE 20

Definition at line 153 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD2_RX_SIZE [1/2]

#define USBD2_RX_SIZE 128

Definition at line 145 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD2_RX_SIZE [2/2]

#define USBD2_RX_SIZE 128

Definition at line 145 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [1/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 135 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [2/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 135 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [1/2]

#define USBD_EP1_TX_SIZE 20

Definition at line 136 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [2/2]

#define USBD_EP1_TX_SIZE 20

Definition at line 136 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [1/2]

#define USBD_EP2_TX_SIZE 20

Definition at line 137 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [2/2]

#define USBD_EP2_TX_SIZE 20

Definition at line 137 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [1/2]

#define USBD_EP3_TX_SIZE 20

Definition at line 138 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [2/2]

#define USBD_EP3_TX_SIZE 20

Definition at line 138 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [1/2]

#define USBD_EP4_TX_SIZE 20

Definition at line 139 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [2/2]

#define USBD_EP4_TX_SIZE 20

Definition at line 139 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [1/2]

#define USBD_EP5_TX_SIZE 20

Definition at line 140 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [2/2]

#define USBD_EP5_TX_SIZE 20

Definition at line 140 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [1/2]

#define USBD_EP6_TX_SIZE 20

Definition at line 141 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [2/2]

#define USBD_EP6_TX_SIZE 20

Definition at line 141 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [1/2]

#define USBD_EP7_TX_SIZE 20

Definition at line 142 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [2/2]

#define USBD_EP7_TX_SIZE 20

Definition at line 142 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD_RX_SIZE [1/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 134 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBD_RX_SIZE [2/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 134 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBH2_NP_TX_FIFO_SIZE [1/2]

#define USBH2_NP_TX_FIFO_SIZE 96

Definition at line 181 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBH2_NP_TX_FIFO_SIZE [2/2]

#define USBH2_NP_TX_FIFO_SIZE 96

Definition at line 181 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBH2_P_TX_FIFO_SIZE [1/2]

#define USBH2_P_TX_FIFO_SIZE 96

Definition at line 182 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBH2_P_TX_FIFO_SIZE [2/2]

#define USBH2_P_TX_FIFO_SIZE 96

Definition at line 182 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBH2_RX_FIFO_SIZE [1/2]

#define USBH2_RX_FIFO_SIZE 128

Definition at line 180 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBH2_RX_FIFO_SIZE [2/2]

#define USBH2_RX_FIFO_SIZE 128

Definition at line 180 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBH_5V_POWER_SWITCH [1/2]

#define USBH_5V_POWER_SWITCH

Definition at line 185 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBH_5V_POWER_SWITCH [2/2]

#define USBH_5V_POWER_SWITCH

Definition at line 185 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBH_DEBUG [1/2]

#define USBH_DEBUG ( ... )
Value:
printf(__VA_ARGS__);\
printf("\r\n");

Definition at line 206 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBH_DEBUG [2/2]

#define USBH_DEBUG ( ... )
Value:
printf(__VA_ARGS__);\
printf("\r\n");

Definition at line 206 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBH_DEBUG_ENABLE [1/2]

#define USBH_DEBUG_ENABLE

usb low power wakeup handler enable

Definition at line 203 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBH_DEBUG_ENABLE [2/2]

#define USBH_DEBUG_ENABLE

usb low power wakeup handler enable

Definition at line 203 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBH_NP_TX_FIFO_SIZE [1/2]

#define USBH_NP_TX_FIFO_SIZE 96

Definition at line 176 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBH_NP_TX_FIFO_SIZE [2/2]

#define USBH_NP_TX_FIFO_SIZE 96

Definition at line 176 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBH_P_TX_FIFO_SIZE [1/2]

#define USBH_P_TX_FIFO_SIZE 96

Definition at line 177 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBH_P_TX_FIFO_SIZE [2/2]

#define USBH_P_TX_FIFO_SIZE 96

Definition at line 177 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBH_RX_FIFO_SIZE [1/2]

#define USBH_RX_FIFO_SIZE 128

usb endpoint max num define

usb host mode config

usb host mode fifo

Definition at line 175 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USBH_RX_FIFO_SIZE [2/2]

#define USBH_RX_FIFO_SIZE 128

usb endpoint max num define

usb host mode config

usb host mode fifo

Definition at line 175 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [1/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 51 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [2/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 51 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USE_OTG_HOST_MODE [1/2]

#define USE_OTG_HOST_MODE

enable usb host mode

Definition at line 56 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ USE_OTG_HOST_MODE [2/2]

#define USE_OTG_HOST_MODE

enable usb host mode

Definition at line 56 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c.

◆ button_exint_init()

void button_exint_init ( void )

configure button exint

Parameters
none
Return values
none

< external interrupt line 0

< external interrupt line 0

Definition at line 125 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c.

Referenced by main().

◆ button_isr()

void button_isr ( void )

button handler function

Parameters
none
Return values
none

< external interrupt line 0

< external interrupt line 0

Definition at line 148 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c.

Referenced by EXINT0_IRQHandler().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c.

◆ EXINT0_IRQHandler()

void EXINT0_IRQHandler ( void )

exint0 interrupt handler

Parameters
none
Return values
none

Definition at line 164 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c.

◆ OTG2_IRQ_HANDLER()

void OTG2_IRQ_HANDLER ( void )

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 413 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c.

◆ OTG_IRQ_HANDLER()

void OTG_IRQ_HANDLER ( void )

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 403 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc sof signal select: otg2

< acc hick trim

< acc sof signal select: otg2

< acc hick trim

Definition at line 174 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

usb low power wakeup handler enable

Parameters
ms number of millisecond delay
Return values
none

Definition at line 423 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 434 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c.

◆ usb_gpio_config()

void usb_gpio_config ( void )

this function config gpio.

Parameters
none
Return values
none

Definition at line 264 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c.

Referenced by main().

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

◆ usbh_user_active_vbus()

static usb_sts_type usbh_user_active_vbus | ( | void * | uhost,
 |  | confirm_state | state
 | ) |  |
static

usb host active vbus user handler

Parameters
uhost | to the structure of usbh_core_type
state | vbus state TRUE: active vbus FALSE: deactive vbus
Return values
usb_sts_type

Definition at line 202 of file at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

◆ usbh_user_application()

static usb_sts_type usbh_user_application ( void )
static

usb host application user handler

Parameters
none
Return values
usb_sts_type

Definition at line 186 of file at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

◆ usbh_user_attached()

static usb_sts_type usbh_user_attached ( void )
static

usb host check device attached

Parameters
none
Return values
usb_sts_type

Definition at line 95 of file at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

◆ usbh_user_disconnect()

static usb_sts_type usbh_user_disconnect ( void )
static

usb host discconet user handler

Parameters
none
Return values
usb_sts_type

Definition at line 107 of file at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

◆ usbh_user_enumeration_done()

static usb_sts_type usbh_user_enumeration_done ( void )
static

usb host enumeration done user handler

Parameters
none
Return values
usb_sts_type

Definition at line 174 of file at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

◆ usbh_user_init()

static usb_sts_type usbh_user_init ( void )
static

usb host init user handler

Parameters
none
Return values
usb_sts_type

Definition at line 71 of file at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

◆ usbh_user_mfc_string()

static usb_sts_type usbh_user_mfc_string ( void * string )
static

usb host manufacturer string user handler

Parameters
none
Return values
usb_sts_type

Definition at line 138 of file at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

◆ usbh_user_not_support()

static usb_sts_type usbh_user_not_support ( void )
static

usb host not support user handler

Parameters
none
Return values
usb_sts_type

Definition at line 233 of file at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

◆ usbh_user_product_string()

static usb_sts_type usbh_user_product_string ( void * string )
static

usb host product string user handler

Parameters
none
Return values
usb_sts_type

Definition at line 150 of file at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

◆ usbh_user_reset()

static usb_sts_type usbh_user_reset ( void )
static

usb host reset user handler

Parameters
none
Return values
usb_sts_type

Definition at line 83 of file at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

◆ usbh_user_serial_string()

static usb_sts_type usbh_user_serial_string ( void * string )
static

usb host serial string user handler

Parameters
none
Return values
usb_sts_type

Definition at line 162 of file at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

◆ usbh_user_speed()

static usb_sts_type usbh_user_speed ( uint8_t speed )
static

usb host speed user handler

Parameters
none
Return values
usb_sts_type

Definition at line 119 of file at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

Variable Documentation

◆ button_press [1/2]

__IO uint8_t button_press = 0

Definition at line 50 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c.

Referenced by button_isr(), and main().

◆ button_press [2/2]

__IO uint8_t button_press = 0

Definition at line 50 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/main.c.

◆ otg2_core_struct [1/2]

otg_core_type otg2_core_struct

Definition at line 48 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c.

Referenced by main(), and OTG2_IRQ_HANDLER().

◆ otg2_core_struct [2/2]

otg_core_type otg2_core_struct

Definition at line 48 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/main.c.

◆ otg_core_struct [1/2]

otg_core_type otg_core_struct

Definition at line 47 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c.

Referenced by main(), and OTG_IRQ_HANDLER().

◆ otg_core_struct [2/2]

otg_core_type otg_core_struct

Definition at line 47 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/main.c.

◆ report_buf [1/2]

uint8_t report_buf[USBD_CUSTOM_IN_MAXPACKET_SIZE]

Definition at line 49 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c.

Referenced by main().

◆ report_buf [2/2]

uint8_t report_buf[USBD_CUSTOM_IN_MAXPACKET_SIZE]

Definition at line 49 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/main.c.

◆ usbh_user_handle [1/2]

usbh_user_handler_type usbh_user_handle
Initial value:
=
{
usbh_user_init,
usbh_user_reset,
usbh_user_attached,
usbh_user_disconnect,
usbh_user_speed,
usbh_user_mfc_string,
usbh_user_product_string,
usbh_user_serial_string,
usbh_user_enumeration_done,
usbh_user_application,
usbh_user_active_vbus,
usbh_user_not_support,
}
usbh_user_init
static usb_sts_type usbh_user_init(void)
usb host init user handler
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:71
usbh_user_disconnect
static usb_sts_type usbh_user_disconnect(void)
usb host discconet user handler
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:107
usbh_user_not_support
static usb_sts_type usbh_user_not_support(void)
usb host not support user handler
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:233
usbh_user_application
static usb_sts_type usbh_user_application(void)
usb host application user handler
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:186
usbh_user_speed
static usb_sts_type usbh_user_speed(uint8_t speed)
usb host speed user handler
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:119
usbh_user_active_vbus
static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state)
usb host active vbus user handler
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:202
usbh_user_serial_string
static usb_sts_type usbh_user_serial_string(void *string)
usb host serial string user handler
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:162
usbh_user_reset
static usb_sts_type usbh_user_reset(void)
usb host reset user handler
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:83
usbh_user_mfc_string
static usb_sts_type usbh_user_mfc_string(void *string)
usb host manufacturer string user handler
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:138
usbh_user_enumeration_done
static usb_sts_type usbh_user_enumeration_done(void)
usb host enumeration done user handler
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:174
usbh_user_attached
static usb_sts_type usbh_user_attached(void)
usb host check device attached
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:95
usbh_user_product_string
static usb_sts_type usbh_user_product_string(void *string)
usb host product string user handler
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:150

Definition at line 50 of file at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

Referenced by main().

◆ usbh_user_handle [2/2]

usbh_user_handler_type usbh_user_handle
Initial value:
=
{
usbh_user_init,
usbh_user_reset,
usbh_user_attached,
usbh_user_disconnect,
usbh_user_speed,
usbh_user_mfc_string,
usbh_user_product_string,
usbh_user_serial_string,
usbh_user_enumeration_done,
usbh_user_application,
usbh_user_active_vbus,
usbh_user_not_support,
}
usbh_user_init
static usb_sts_type usbh_user_init(void)
usb host init user handler
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:71
usbh_user_disconnect
static usb_sts_type usbh_user_disconnect(void)
usb host discconet user handler
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:107
usbh_user_not_support
static usb_sts_type usbh_user_not_support(void)
usb host not support user handler
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:233
usbh_user_application
static usb_sts_type usbh_user_application(void)
usb host application user handler
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:186
usbh_user_speed
static usb_sts_type usbh_user_speed(uint8_t speed)
usb host speed user handler
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:119
usbh_user_active_vbus
static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state)
usb host active vbus user handler
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:202
usbh_user_serial_string
static usb_sts_type usbh_user_serial_string(void *string)
usb host serial string user handler
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:162
usbh_user_reset
static usb_sts_type usbh_user_reset(void)
usb host reset user handler
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:83
usbh_user_mfc_string
static usb_sts_type usbh_user_mfc_string(void *string)
usb host manufacturer string user handler
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:138
usbh_user_enumeration_done
static usb_sts_type usbh_user_enumeration_done(void)
usb host enumeration done user handler
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:174
usbh_user_attached
static usb_sts_type usbh_user_attached(void)
usb host check device attached
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:95
usbh_user_product_string
static usb_sts_type usbh_user_product_string(void *string)
usb host product string user handler
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:150

Definition at line 50 of file at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.


AT32F435/437 Firmwary Library: USB_device_printer

Macros | Functions | Variables
USB_device_printer
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
int | main (void)
main function. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...

Variables

otg_core_type otg_core_struct
otg_core_type otg_core_struct

Detailed Description

Macro Definition Documentation

◆ OTG_CLOCK [1/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 70 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_CLOCK [2/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 70 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_IRQ [1/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 71 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_IRQ [2/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 71 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [1/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 72 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [2/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 72 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_DM [1/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 83 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_DM [2/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 83 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [1/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 84 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [2/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 84 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_DP [1/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 80 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_DP [2/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 80 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [1/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 81 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [2/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 81 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_GPIO [1/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 77 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_GPIO [2/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 77 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [1/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 78 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [2/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 78 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_ID [1/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 89 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_ID [2/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 89 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [1/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 90 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [2/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 90 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_MUX [1/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 97 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_MUX [2/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 97 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_SOF [1/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 94 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_SOF [2/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 94 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [1/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 92 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [2/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 92 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [1/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 93 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [2/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 93 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [1/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 95 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [2/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 95 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_VBUS [1/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 86 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_VBUS [2/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 86 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [1/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 87 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [2/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 87 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_USB_ID [1/2]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 63 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_USB_ID [2/2]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 63 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [1/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 75 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [2/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 75 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [1/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 74 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [2/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 74 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [1/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 73 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [2/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 73 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ USB_ID [1/2]

#define USB_ID 0

Definition at line 69 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ USB_ID [2/2]

#define USB_ID 0

Definition at line 69 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [1/2]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore

Definition at line 199 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [2/2]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore

Definition at line 199 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [1/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 152 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [2/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 152 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [1/2]

#define USBD2_EP1_TX_SIZE 20

Definition at line 153 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [2/2]

#define USBD2_EP1_TX_SIZE 20

Definition at line 153 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [1/2]

#define USBD2_EP2_TX_SIZE 20

Definition at line 154 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [2/2]

#define USBD2_EP2_TX_SIZE 20

Definition at line 154 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [1/2]

#define USBD2_EP3_TX_SIZE 20

Definition at line 155 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [2/2]

#define USBD2_EP3_TX_SIZE 20

Definition at line 155 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [1/2]

#define USBD2_EP4_TX_SIZE 20

Definition at line 156 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [2/2]

#define USBD2_EP4_TX_SIZE 20

Definition at line 156 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [1/2]

#define USBD2_EP5_TX_SIZE 20

Definition at line 157 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [2/2]

#define USBD2_EP5_TX_SIZE 20

Definition at line 157 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [1/2]

#define USBD2_EP6_TX_SIZE 20

Definition at line 158 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [2/2]

#define USBD2_EP6_TX_SIZE 20

Definition at line 158 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [1/2]

#define USBD2_EP7_TX_SIZE 20

Definition at line 159 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [2/2]

#define USBD2_EP7_TX_SIZE 20

Definition at line 159 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD2_RX_SIZE [1/2]

#define USBD2_RX_SIZE 128

Definition at line 151 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD2_RX_SIZE [2/2]

#define USBD2_RX_SIZE 128

Definition at line 151 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [1/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 141 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [2/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 141 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [1/2]

#define USBD_EP1_TX_SIZE 20

Definition at line 142 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [2/2]

#define USBD_EP1_TX_SIZE 20

Definition at line 142 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [1/2]

#define USBD_EP2_TX_SIZE 20

Definition at line 143 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [2/2]

#define USBD_EP2_TX_SIZE 20

Definition at line 143 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [1/2]

#define USBD_EP3_TX_SIZE 20

Definition at line 144 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [2/2]

#define USBD_EP3_TX_SIZE 20

Definition at line 144 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [1/2]

#define USBD_EP4_TX_SIZE 20

Definition at line 145 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [2/2]

#define USBD_EP4_TX_SIZE 20

Definition at line 145 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [1/2]

#define USBD_EP5_TX_SIZE 20

Definition at line 146 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [2/2]

#define USBD_EP5_TX_SIZE 20

Definition at line 146 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [1/2]

#define USBD_EP6_TX_SIZE 20

Definition at line 147 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [2/2]

#define USBD_EP6_TX_SIZE 20

Definition at line 147 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [1/2]

#define USBD_EP7_TX_SIZE 20

Definition at line 148 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [2/2]

#define USBD_EP7_TX_SIZE 20

Definition at line 148 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD_RX_SIZE [1/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 140 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ USBD_RX_SIZE [2/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 140 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [1/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 51 of file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [2/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 51 of file project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f435/examples/usb_device/printer/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c.

◆ OTG_IRQ_HANDLER()

void OTG_IRQ_HANDLER ( void )

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 267 of file project/at_start_f435/examples/usb_device/printer/src/main.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc sof signal select: otg1

< acc hick trim

< acc sof signal select: otg1

< acc hick trim

Definition at line 100 of file project/at_start_f435/examples/usb_device/printer/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb low power wakeup handler enable

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 277 of file project/at_start_f435/examples/usb_device/printer/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 288 of file project/at_start_f435/examples/usb_device/printer/src/main.c.

◆ usb_gpio_config()

void usb_gpio_config ( void )

this function config gpio.

Parameters
none
Return values
none

Definition at line 192 of file project/at_start_f435/examples/usb_device/printer/src/main.c.

Referenced by main().

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

Variable Documentation

◆ otg_core_struct [1/2]

otg_core_type otg_core_struct

Definition at line 45 of file project/at_start_f435/examples/usb_device/printer/src/main.c.

Referenced by main(), and OTG_IRQ_HANDLER().

◆ otg_core_struct [2/2]

otg_core_type otg_core_struct

Definition at line 45 of file project/at_start_f437/examples/usb_device/printer/src/main.c.


AT32F435/437 Firmwary Library: USB_device_two_otg_device_demo

Macros | Functions | Variables
USB_device_two_otg_device_demo
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | USB_ID 0
enable usb host mode More...
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USB2_ID 1
#define | OTG2_CLOCK CRM_OTGFS2_PERIPH_CLOCK
#define | OTG2_IRQ OTGFS2_IRQn
#define | OTG2_IRQ_HANDLER OTGFS2_IRQHandler
#define | OTG2_WKUP_IRQ OTGFS2_WKUP_IRQn
#define | OTG2_WKUP_HANDLER OTGFS2_WKUP_IRQHandler
#define | OTG2_WKUP_EXINT_LINE EXINT_LINE_20
#define | OTG2_PIN_GPIO GPIOB
#define | OTG2_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK
#define | OTG2_PIN_DP GPIO_PINS_15
#define | OTG2_PIN_DP_SOURCE GPIO_PINS_SOURCE15
#define | OTG2_PIN_DM GPIO_PINS_14
#define | OTG2_PIN_DM_SOURCE GPIO_PINS_SOURCE14
#define | OTG2_PIN_VBUS GPIO_PINS_13
#define | OTG2_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13
#define | OTG2_PIN_ID GPIO_PINS_12
#define | OTG2_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG2_PIN_SOF_GPIO GPIOA
#define | OTG2_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG2_PIN_SOF GPIO_PINS_4
#define | OTG2_PIN_SOF_SOURCE GPIO_PINS_SOURCE4
#define | OTG2_PIN_MUX GPIO_MUX_12
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | USB_ID 0
enable usb host mode More...
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USB2_ID 1
#define | OTG2_CLOCK CRM_OTGFS2_PERIPH_CLOCK
#define | OTG2_IRQ OTGFS2_IRQn
#define | OTG2_IRQ_HANDLER OTGFS2_IRQHandler
#define | OTG2_WKUP_IRQ OTGFS2_WKUP_IRQn
#define | OTG2_WKUP_HANDLER OTGFS2_WKUP_IRQHandler
#define | OTG2_WKUP_EXINT_LINE EXINT_LINE_20
#define | OTG2_PIN_GPIO GPIOB
#define | OTG2_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK
#define | OTG2_PIN_DP GPIO_PINS_15
#define | OTG2_PIN_DP_SOURCE GPIO_PINS_SOURCE15
#define | OTG2_PIN_DM GPIO_PINS_14
#define | OTG2_PIN_DM_SOURCE GPIO_PINS_SOURCE14
#define | OTG2_PIN_VBUS GPIO_PINS_13
#define | OTG2_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13
#define | OTG2_PIN_ID GPIO_PINS_12
#define | OTG2_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG2_PIN_SOF_GPIO GPIOA
#define | OTG2_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG2_PIN_SOF GPIO_PINS_4
#define | OTG2_PIN_SOF_SOURCE GPIO_PINS_SOURCE4
#define | OTG2_PIN_MUX GPIO_MUX_12
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | OTG2_IRQ_HANDLER OTGFS2_IRQHandler
this function handles otgfs interrupt. More...

Functions

void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
void | button_exint_init (void)
configure button exint More...
void | button_isr (void)
button handler function More...
int | main (void)
main function. More...
void | EXINT0_IRQHandler (void)
exint0 interrupt handler More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...
void | OTG2_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...

Variables

otg_core_type otg_core_struct
otg_core_type otg2_core_struct
uint8_t | usb_buffer [256]
uint8_t | report_buf [USBD_CUSTOM_IN_MAXPACKET_SIZE]
__IO uint8_t | button_press = 0
otg_core_type otg_core_struct
otg_core_type otg2_core_struct
uint8_t | usb_buffer [256]
uint8_t | report_buf [USBD_CUSTOM_IN_MAXPACKET_SIZE]
__IO uint8_t | button_press = 0

Detailed Description

Macro Definition Documentation

◆ OTG2_CLOCK [1/2]

#define OTG2_CLOCK CRM_OTGFS2_PERIPH_CLOCK

Definition at line 94 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_CLOCK [2/2]

#define OTG2_CLOCK CRM_OTGFS2_PERIPH_CLOCK

Definition at line 94 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_IRQ [1/2]

#define OTG2_IRQ OTGFS2_IRQn

Definition at line 95 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_IRQ [2/2]

#define OTG2_IRQ OTGFS2_IRQn

Definition at line 95 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_IRQ_HANDLER [1/3]

void OTG2_IRQ_HANDLER ( void ) OTGFS2_IRQHandler

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 99 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.

◆ OTG2_IRQ_HANDLER [2/3]

#define OTG2_IRQ_HANDLER ( void ) OTGFS2_IRQHandler

Definition at line 96 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_IRQ_HANDLER [3/3]

#define OTG2_IRQ_HANDLER ( void ) OTGFS2_IRQHandler

Definition at line 96 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_DM [1/2]

#define OTG2_PIN_DM GPIO_PINS_14

Definition at line 107 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_DM [2/2]

#define OTG2_PIN_DM GPIO_PINS_14

Definition at line 107 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_DM_SOURCE [1/2]

#define OTG2_PIN_DM_SOURCE GPIO_PINS_SOURCE14

Definition at line 108 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_DM_SOURCE [2/2]

#define OTG2_PIN_DM_SOURCE GPIO_PINS_SOURCE14

Definition at line 108 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_DP [1/2]

#define OTG2_PIN_DP GPIO_PINS_15

Definition at line 104 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_DP [2/2]

#define OTG2_PIN_DP GPIO_PINS_15

Definition at line 104 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_DP_SOURCE [1/2]

#define OTG2_PIN_DP_SOURCE GPIO_PINS_SOURCE15

Definition at line 105 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_DP_SOURCE [2/2]

#define OTG2_PIN_DP_SOURCE GPIO_PINS_SOURCE15

Definition at line 105 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_GPIO [1/2]

#define OTG2_PIN_GPIO GPIOB

Definition at line 101 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_GPIO [2/2]

#define OTG2_PIN_GPIO GPIOB

Definition at line 101 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_GPIO_CLOCK [1/2]

#define OTG2_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK

Definition at line 102 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_GPIO_CLOCK [2/2]

#define OTG2_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK

Definition at line 102 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_ID [1/2]

#define OTG2_PIN_ID GPIO_PINS_12

Definition at line 113 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_ID [2/2]

#define OTG2_PIN_ID GPIO_PINS_12

Definition at line 113 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_ID_SOURCE [1/2]

#define OTG2_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 114 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_ID_SOURCE [2/2]

#define OTG2_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 114 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_MUX [1/2]

#define OTG2_PIN_MUX GPIO_MUX_12

Definition at line 121 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_MUX [2/2]

#define OTG2_PIN_MUX GPIO_MUX_12

Definition at line 121 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_SOF [1/2]

#define OTG2_PIN_SOF GPIO_PINS_4

Definition at line 118 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_SOF [2/2]

#define OTG2_PIN_SOF GPIO_PINS_4

Definition at line 118 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_SOF_GPIO [1/2]

#define OTG2_PIN_SOF_GPIO GPIOA

Definition at line 116 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_SOF_GPIO [2/2]

#define OTG2_PIN_SOF_GPIO GPIOA

Definition at line 116 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_SOF_GPIO_CLOCK [1/2]

#define OTG2_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 117 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_SOF_GPIO_CLOCK [2/2]

#define OTG2_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 117 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_SOF_SOURCE [1/2]

#define OTG2_PIN_SOF_SOURCE GPIO_PINS_SOURCE4

Definition at line 119 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_SOF_SOURCE [2/2]

#define OTG2_PIN_SOF_SOURCE GPIO_PINS_SOURCE4

Definition at line 119 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_VBUS [1/2]

#define OTG2_PIN_VBUS GPIO_PINS_13

Definition at line 110 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_VBUS [2/2]

#define OTG2_PIN_VBUS GPIO_PINS_13

Definition at line 110 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_VBUS_SOURCE [1/2]

#define OTG2_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13

Definition at line 111 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_PIN_VBUS_SOURCE [2/2]

#define OTG2_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13

Definition at line 111 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_WKUP_EXINT_LINE [1/2]

#define OTG2_WKUP_EXINT_LINE EXINT_LINE_20

Definition at line 99 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_WKUP_EXINT_LINE [2/2]

#define OTG2_WKUP_EXINT_LINE EXINT_LINE_20

Definition at line 99 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_WKUP_HANDLER [1/2]

#define OTG2_WKUP_HANDLER OTGFS2_WKUP_IRQHandler

Definition at line 98 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_WKUP_HANDLER [2/2]

#define OTG2_WKUP_HANDLER OTGFS2_WKUP_IRQHandler

Definition at line 98 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_WKUP_IRQ [1/2]

#define OTG2_WKUP_IRQ OTGFS2_WKUP_IRQn

Definition at line 97 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG2_WKUP_IRQ [2/2]

#define OTG2_WKUP_IRQ OTGFS2_WKUP_IRQn

Definition at line 97 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_CLOCK [1/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 63 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_CLOCK [2/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 63 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_IRQ [1/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 64 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_IRQ [2/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 64 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [1/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 65 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [2/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 65 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_DM [1/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 76 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_DM [2/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 76 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [1/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 77 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [2/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 77 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_DP [1/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 73 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_DP [2/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 73 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [1/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 74 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [2/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 74 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_GPIO [1/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 70 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_GPIO [2/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 70 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [1/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 71 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [2/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 71 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_ID [1/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 82 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_ID [2/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 82 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [1/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 83 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [2/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 83 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_MUX [1/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 90 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_MUX [2/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 90 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF [1/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 87 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF [2/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 87 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [1/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 85 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [2/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 85 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [1/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 86 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [2/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 86 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [1/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 88 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [2/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 88 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_VBUS [1/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 79 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_VBUS [2/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 79 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [1/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 80 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [2/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 80 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [1/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 68 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [2/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 68 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [1/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 67 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [2/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 67 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [1/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 66 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [2/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 66 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USB2_ID [1/2]

#define USB2_ID 1

Definition at line 93 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USB2_ID [2/2]

#define USB2_ID 1

Definition at line 93 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USB_ID [1/2]

#define USB_ID 0

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 62 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USB_ID [2/2]

#define USB_ID 0

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 62 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [1/2]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore, not use vbus pin

Definition at line 190 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [2/2]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore, not use vbus pin

Definition at line 190 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [1/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 143 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [2/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 143 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [1/2]

#define USBD2_EP1_TX_SIZE 20

Definition at line 144 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [2/2]

#define USBD2_EP1_TX_SIZE 20

Definition at line 144 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [1/2]

#define USBD2_EP2_TX_SIZE 20

Definition at line 145 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [2/2]

#define USBD2_EP2_TX_SIZE 20

Definition at line 145 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [1/2]

#define USBD2_EP3_TX_SIZE 20

Definition at line 146 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [2/2]

#define USBD2_EP3_TX_SIZE 20

Definition at line 146 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [1/2]

#define USBD2_EP4_TX_SIZE 20

Definition at line 147 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [2/2]

#define USBD2_EP4_TX_SIZE 20

Definition at line 147 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [1/2]

#define USBD2_EP5_TX_SIZE 20

Definition at line 148 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [2/2]

#define USBD2_EP5_TX_SIZE 20

Definition at line 148 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [1/2]

#define USBD2_EP6_TX_SIZE 20

Definition at line 149 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [2/2]

#define USBD2_EP6_TX_SIZE 20

Definition at line 149 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [1/2]

#define USBD2_EP7_TX_SIZE 20

Definition at line 150 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [2/2]

#define USBD2_EP7_TX_SIZE 20

Definition at line 150 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD2_RX_SIZE [1/2]

#define USBD2_RX_SIZE 128

Definition at line 142 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD2_RX_SIZE [2/2]

#define USBD2_RX_SIZE 128

Definition at line 142 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [1/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 132 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [2/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 132 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [1/2]

#define USBD_EP1_TX_SIZE 20

Definition at line 133 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [2/2]

#define USBD_EP1_TX_SIZE 20

Definition at line 133 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [1/2]

#define USBD_EP2_TX_SIZE 20

Definition at line 134 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [2/2]

#define USBD_EP2_TX_SIZE 20

Definition at line 134 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [1/2]

#define USBD_EP3_TX_SIZE 20

Definition at line 135 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [2/2]

#define USBD_EP3_TX_SIZE 20

Definition at line 135 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [1/2]

#define USBD_EP4_TX_SIZE 20

Definition at line 136 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [2/2]

#define USBD_EP4_TX_SIZE 20

Definition at line 136 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [1/2]

#define USBD_EP5_TX_SIZE 20

Definition at line 137 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [2/2]

#define USBD_EP5_TX_SIZE 20

Definition at line 137 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [1/2]

#define USBD_EP6_TX_SIZE 20

Definition at line 138 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [2/2]

#define USBD_EP6_TX_SIZE 20

Definition at line 138 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [1/2]

#define USBD_EP7_TX_SIZE 20

Definition at line 139 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [2/2]

#define USBD_EP7_TX_SIZE 20

Definition at line 139 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD_RX_SIZE [1/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 131 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USBD_RX_SIZE [2/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 131 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [1/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 51 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [2/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 51 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c.

◆ button_exint_init()

void button_exint_init ( void )

configure button exint

Parameters
none
Return values
none

< external interrupt line 0

< external interrupt line 0

Definition at line 155 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c.

Referenced by main().

◆ button_isr()

void button_isr ( void )

button handler function

Parameters
none
Return values
none

< external interrupt line 0

< external interrupt line 0

Definition at line 178 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c.

Referenced by EXINT0_IRQHandler().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c.

◆ EXINT0_IRQHandler()

void EXINT0_IRQHandler ( void )

exint0 interrupt handler

Parameters
none
Return values
none

Definition at line 194 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c.

◆ OTG2_IRQ_HANDLER()

void OTG2_IRQ_HANDLER ( void )

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 433 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c.

◆ OTG_IRQ_HANDLER()

void OTG_IRQ_HANDLER ( void )

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 423 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc sof signal select: otg1

< acc hick trim

< acc sof signal select: otg1

< acc hick trim

Definition at line 204 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb low power wakeup handler enable

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 443 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 454 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c.

◆ usb_gpio_config()

void usb_gpio_config ( void )

this function config gpio.

Parameters
none
Return values
none

Definition at line 296 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c.

Referenced by main().

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

Variable Documentation

◆ button_press [1/2]

__IO uint8_t button_press = 0

Definition at line 50 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c.

Referenced by button_isr(), and main().

◆ button_press [2/2]

__IO uint8_t button_press = 0

Definition at line 50 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/src/main.c.

◆ otg2_core_struct [1/2]

otg_core_type otg2_core_struct

Definition at line 47 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c.

Referenced by main(), and OTG2_IRQ_HANDLER().

◆ otg2_core_struct [2/2]

otg_core_type otg2_core_struct

Definition at line 47 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/src/main.c.

◆ otg_core_struct [1/2]

otg_core_type otg_core_struct

Definition at line 46 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c.

Referenced by main(), and OTG_IRQ_HANDLER().

◆ otg_core_struct [2/2]

otg_core_type otg_core_struct

Definition at line 46 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/src/main.c.

◆ report_buf [1/2]

uint8_t report_buf[USBD_CUSTOM_IN_MAXPACKET_SIZE]

Definition at line 49 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c.

Referenced by main().

◆ report_buf [2/2]

uint8_t report_buf[USBD_CUSTOM_IN_MAXPACKET_SIZE]

Definition at line 49 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/src/main.c.

◆ usb_buffer [1/2]

uint8_t usb_buffer[256]

Definition at line 48 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c.

Referenced by main().

◆ usb_buffer [2/2]

uint8_t usb_buffer[256]

Definition at line 48 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/src/main.c.


AT32F435/437 Firmwary Library: _USB_device_virtaul_comport

Functions
_USB_device_virtaul_comport
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: USB_device_virtaul_comport

Macros | Functions | Variables
USB_device_virtaul_comport
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | usart_buffer_size 2048
#define | usart_buffer_size 2048

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
void | usb_usart_config (linecoding_type linecoding)
this function handles usart2 and linecoding config. More...
void | usart_gpio_config (void)
this function handles usart2 gpio config. More...
void | usart_send_data (uint8_t *send_data, uint16_t len)
this function handles usart2 send data. More...
uint16_t | usart_receive_data (void)
this function handles usart2 receive data. More...
int | main (void)
main function. More...
void | USART2_IRQHandler (void)
this function handles usart2 handler. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

otg_core_type otg_core_struct
uint8_t | usb_buffer [256]
uint8_t | usart2_tx_counter = 0
uint16_t | data_len
linecoding_type linecoding
uint8_t | usart_rx_buffer [2048]
uint16_t | hw_usart_rx_index = 0
uint16_t | hw_usart_read_index = 0
uint16_t | usart_rx_data_len = 0
uint16_t | ov_cnt = 0
otg_core_type otg_core_struct
uint8_t | usb_buffer [256]
uint8_t | usart2_tx_counter = 0
uint16_t | data_len
linecoding_type linecoding
uint8_t | usart_rx_buffer [2048]
uint16_t | hw_usart_rx_index = 0
uint16_t | hw_usart_read_index = 0
uint16_t | usart_rx_data_len = 0
uint16_t | ov_cnt = 0

Detailed Description

Macro Definition Documentation

◆ usart_buffer_size [1/2]

#define usart_buffer_size 2048

Definition at line 56 of file project/at_start_f435/examples/usb_device/virtual_comport/src/main.c.

◆ usart_buffer_size [2/2]

#define usart_buffer_size 2048

Definition at line 56 of file project/at_start_f437/examples/usb_device/virtual_comport/src/main.c.

Function Documentation

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 69 of file project/at_start_f435/examples/usb_device/virtual_comport/src/main.c.

◆ OTG_IRQ_HANDLER()

void OTG_IRQ_HANDLER ( void )

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 512 of file project/at_start_f435/examples/usb_device/virtual_comport/src/main.c.

◆ USART2_IRQHandler()

void USART2_IRQHandler ( void )

this function handles usart2 handler.

Parameters
none
Return values
none

< usart receive data buffer full flag

< usart receive data buffer full flag

Definition at line 226 of file project/at_start_f435/examples/usb_device/virtual_comport/src/main.c.

◆ usart_gpio_config()

void usart_gpio_config ( void )

this function handles usart2 gpio config.

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

Definition at line 324 of file project/at_start_f435/examples/usb_device/virtual_comport/src/main.c.

Referenced by main().

◆ usart_receive_data()

uint16_t usart_receive_data ( void )

this function handles usart2 receive data.

Parameters
none
Return values
the data len

Definition at line 200 of file project/at_start_f435/examples/usb_device/virtual_comport/src/main.c.

Referenced by main().

◆ usart_send_data()

void usart_send_data | ( | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

this function handles usart2 send data.

Parameters
send_data | pointer to data
len | data len
Return values
none

< usart transmit data buffer empty flag

< usart transmit data buffer empty flag

Definition at line 181 of file project/at_start_f435/examples/usb_device/virtual_comport/src/main.c.

Referenced by main().

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc sof signal select: otg1

< acc hick trim

< acc sof signal select: otg1

< acc hick trim

Definition at line 345 of file project/at_start_f435/examples/usb_device/virtual_comport/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

usb low power wakeup handler enable

Parameters
ms number of millisecond delay
Return values
none

Definition at line 522 of file project/at_start_f435/examples/usb_device/virtual_comport/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 533 of file project/at_start_f435/examples/usb_device/virtual_comport/src/main.c.

◆ usb_gpio_config()

void usb_gpio_config ( void )

this function config gpio.

Parameters
none
Return values
none

Definition at line 437 of file project/at_start_f435/examples/usb_device/virtual_comport/src/main.c.

Referenced by main().

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

◆ usb_usart_config()

void usb_usart_config ( linecoding_type linecoding )

this function handles usart2 and linecoding config.

Parameters
linecoding linecoding value
Return values
none

< usart receive data buffer full interrupt

< usart receive data buffer full interrupt

Definition at line 241 of file project/at_start_f435/examples/usb_device/virtual_comport/src/main.c.

Referenced by main(), and usb_vcp_cmd_process().

Variable Documentation

◆ data_len [1/2]

uint16_t data_len

Definition at line 47 of file project/at_start_f435/examples/usb_device/virtual_comport/src/main.c.

Referenced by at32_mqtt_publish(), bot_scsi_mode_sense10(), bot_scsi_mode_sense6(), bot_scsi_send_data(), iap_data_write(), main(), usbh_cmd_read(), and usbh_cmd_write().

◆ data_len [2/2]

uint16_t data_len

Definition at line 47 of file project/at_start_f437/examples/usb_device/virtual_comport/src/main.c.

◆ hw_usart_read_index [1/2]

uint16_t hw_usart_read_index = 0

Definition at line 59 of file project/at_start_f435/examples/usb_device/virtual_comport/src/main.c.

Referenced by main(), and usart_receive_data().

◆ hw_usart_read_index [2/2]

uint16_t hw_usart_read_index = 0

Definition at line 59 of file project/at_start_f437/examples/usb_device/virtual_comport/src/main.c.

◆ hw_usart_rx_index [1/2]

uint16_t hw_usart_rx_index = 0

Definition at line 58 of file project/at_start_f435/examples/usb_device/virtual_comport/src/main.c.

Referenced by USART2_IRQHandler(), and usart_receive_data().

◆ hw_usart_rx_index [2/2]

uint16_t hw_usart_rx_index = 0

Definition at line 58 of file project/at_start_f437/examples/usb_device/virtual_comport/src/main.c.

◆ linecoding [1/2]

linecoding_type linecoding
extern

Definition at line 57 of file cdc_class.c.

Referenced by main(), and usb_usart_config().

◆ linecoding [2/2]

linecoding_type linecoding
extern

Definition at line 57 of file cdc_class.c.

Referenced by cdc_struct_init().

◆ otg_core_struct [1/2]

otg_core_type otg_core_struct

Definition at line 44 of file project/at_start_f435/examples/usb_device/virtual_comport/src/main.c.

Referenced by main(), and OTG_IRQ_HANDLER().

◆ otg_core_struct [2/2]

otg_core_type otg_core_struct

Definition at line 44 of file project/at_start_f437/examples/usb_device/virtual_comport/src/main.c.

◆ ov_cnt [1/2]

uint16_t ov_cnt = 0

Definition at line 61 of file project/at_start_f435/examples/usb_device/virtual_comport/src/main.c.

Referenced by main().

◆ ov_cnt [2/2]

uint16_t ov_cnt = 0

Definition at line 61 of file project/at_start_f437/examples/usb_device/virtual_comport/src/main.c.

◆ usart2_tx_counter [1/2]

uint8_t usart2_tx_counter = 0

Definition at line 46 of file project/at_start_f435/examples/usb_device/virtual_comport/src/main.c.

◆ usart2_tx_counter [2/2]

uint8_t usart2_tx_counter = 0

Definition at line 46 of file project/at_start_f437/examples/usb_device/virtual_comport/src/main.c.

Referenced by USART2_IRQHandler().

◆ usart_rx_buffer [1/2]

uint8_t usart_rx_buffer[2048]

Definition at line 57 of file project/at_start_f435/examples/usb_device/virtual_comport/src/main.c.

Referenced by main(), and USART2_IRQHandler().

◆ usart_rx_buffer [2/2]

uint8_t usart_rx_buffer[2048]

Definition at line 57 of file project/at_start_f437/examples/usb_device/virtual_comport/src/main.c.

◆ usart_rx_data_len [1/2]

uint16_t usart_rx_data_len = 0

Definition at line 60 of file project/at_start_f435/examples/usb_device/virtual_comport/src/main.c.

Referenced by main().

◆ usart_rx_data_len [2/2]

uint16_t usart_rx_data_len = 0

Definition at line 60 of file project/at_start_f437/examples/usb_device/virtual_comport/src/main.c.

◆ usb_buffer [1/2]

uint8_t usb_buffer[256]

Definition at line 45 of file project/at_start_f435/examples/usb_device/virtual_comport/src/main.c.

Referenced by main().

◆ usb_buffer [2/2]

uint8_t usb_buffer[256]

Definition at line 45 of file project/at_start_f437/examples/usb_device/virtual_comport/src/main.c.


AT32F435/437 Firmwary Library: USB_device_virtual_msc_iap

Modules | Macros | Functions | Variables
USB_device_virtual_msc_iap
AT32F435_periph_examples | AT32F437_periph_examples

Modules

USB_device_virtual_msc_iap_definition

Macros

#define | INTERNAL_FLASH_LUN 0
#define | SPI_FLASH_LUN 1
#define | SD_LUN 2
#define | USB_FLASH_ADDR_OFFSET 0x08004000
#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | FAT16_SECTOR_SIZE 62
#define | INTERNAL_FLASH_LUN 0
#define | SPI_FLASH_LUN 1
#define | SD_LUN 2
#define | USB_FLASH_ADDR_OFFSET 0x08004000
#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | FAT16_SECTOR_SIZE 62

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...
void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
uint32_t | flash_fat16_boot_dir_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
boot dir write More...
uint32_t | flash_fat16_sector_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
write sector More...
uint32_t | fat16_memory_copy (uint8_t *dst, const uint8_t *src, uint32_t len)
memory copy function More...
uint32_t | fat16_memory_memset (uint8_t *dst, uint32_t set, uint32_t len)
memset function More...
uint32_t | flash_write_data (uint32_t address, uint8_t *data, uint32_t len)
write data to flash More...
uint32_t | flash_read_data (uint32_t address, uint8_t *data, uint32_t len)
read data from flash More...
uint32_t | fat16_memory_cmp (uint8_t *dst, uint8_t *src, uint32_t len)
memory compare function More...
uint32_t | flash_crc_check (uint32_t address, uint8_t *data, uint32_t len)
crc check More...
void | flash_fat16_clear_upgrade_flag (void)
clear iap upgrade flag More...
void | flash_fat16_set_upgrade_flag (void)
set iap upgrade complete flag More...
uint8_t | flash_fat16_get_upgrade_flag (void)
get iap upgrade complete flag More...
uint32_t | flash_fat16_read (uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address More...
uint32_t | flash_fat16_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address More...
uint32_t | flash_fat16_set_name (const uint8_t *file_name, uint8_t len)
set file name More...
uint32_t | flash_fat16_addr_offset (uint8_t *file_name)
get offset address More...
void | flash_fat16_init (void)
flash fat16 iap init More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
void | button_exint_init (button_type button)
void | button_isr (void)
button handler function More...
void | jump_to_app (uint32_t address)
jump to app More...
void | usb_re_connect (void)
int | main (void)
main function. More...
void | usb_reset ()
usb re-connect More...
void | flash_fat16_loop_status (void)
loop status More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...

Variables

static uint8_t | fat16_sector [62]
const uint8_t | fat16_root_dir_sector [FAT16_DIR_SIZE]
const uint8_t | fat16_table_sector0 [FAT16_TABLE_SIZE]
uint8_t | fat16_file_name [FAT16_FILENAME_SIZE]
fat_dir_type g_file_attr
flash_iap_type flash_iap
uint32_t | file_write_nr = 0
uint8_t | file_match = 0
otg_core_type otg_core_struct
void(* | pftarget )(void)
uint8_t | scsi_inquiry [MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
static uint8_t | fat16_sector [62]
const uint8_t | fat16_root_dir_sector [FAT16_DIR_SIZE]
const uint8_t | fat16_table_sector0 [FAT16_TABLE_SIZE]
uint8_t | fat16_file_name [FAT16_FILENAME_SIZE]
fat_dir_type g_file_attr
flash_iap_type flash_iap
uint32_t | file_write_nr = 0
uint8_t | file_match = 0
otg_core_type otg_core_struct
void(* | pftarget )(void)
uint8_t | scsi_inquiry [MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
iapfun jump_to_app
jump to app More...

Detailed Description

Macro Definition Documentation

◆ FAT16_SECTOR_SIZE [1/2]

#define FAT16_SECTOR_SIZE 62

Definition at line 36 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

◆ FAT16_SECTOR_SIZE [2/2]

#define FAT16_SECTOR_SIZE 62

Definition at line 36 of file at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

◆ INTERNAL_FLASH_LUN [1/2]

#define INTERNAL_FLASH_LUN 0

Definition at line 45 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h.

◆ INTERNAL_FLASH_LUN [2/2]

#define INTERNAL_FLASH_LUN 0

Definition at line 45 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h.

◆ OTG_CLOCK [1/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 71 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_CLOCK [2/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 71 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_IRQ [1/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 72 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_IRQ [2/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 72 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [1/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 73 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [2/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 73 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_DM [1/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 84 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_DM [2/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 84 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [1/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 85 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [2/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 85 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_DP [1/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 81 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_DP [2/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 81 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [1/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 82 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [2/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 82 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_GPIO [1/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 78 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_GPIO [2/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 78 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [1/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 79 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [2/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 79 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_ID [1/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 90 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_ID [2/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 90 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [1/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 91 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [2/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 91 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_MUX [1/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 98 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_MUX [2/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 98 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_SOF [1/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 95 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_SOF [2/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 95 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [1/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 93 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [2/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 93 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [1/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 94 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [2/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 94 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [1/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 96 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [2/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 96 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_VBUS [1/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 87 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_VBUS [2/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 87 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [1/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 88 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [2/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 88 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_USB_ID [1/2]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 64 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_USB_ID [2/2]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 64 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [1/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 76 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [2/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 76 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [1/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 75 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [2/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 75 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [1/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 74 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [2/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 74 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ SD_LUN [1/2]

#define SD_LUN 2

Definition at line 47 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h.

◆ SD_LUN [2/2]

#define SD_LUN 2

Definition at line 47 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h.

◆ SPI_FLASH_LUN [1/2]

#define SPI_FLASH_LUN 1

Definition at line 46 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h.

◆ SPI_FLASH_LUN [2/2]

#define SPI_FLASH_LUN 1

Definition at line 46 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h.

◆ USB_FLASH_ADDR_OFFSET [1/2]

#define USB_FLASH_ADDR_OFFSET 0x08004000

Definition at line 49 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h.

◆ USB_FLASH_ADDR_OFFSET [2/2]

#define USB_FLASH_ADDR_OFFSET 0x08004000

Definition at line 49 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h.

◆ USB_ID [1/2]

#define USB_ID 0

Definition at line 70 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USB_ID [2/2]

#define USB_ID 0

Definition at line 70 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [1/2]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore

Definition at line 199 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [2/2]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore

Definition at line 199 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [1/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 152 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [2/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 152 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [1/2]

#define USBD2_EP1_TX_SIZE 20

Definition at line 153 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [2/2]

#define USBD2_EP1_TX_SIZE 20

Definition at line 153 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [1/2]

#define USBD2_EP2_TX_SIZE 20

Definition at line 154 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [2/2]

#define USBD2_EP2_TX_SIZE 20

Definition at line 154 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [1/2]

#define USBD2_EP3_TX_SIZE 20

Definition at line 155 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [2/2]

#define USBD2_EP3_TX_SIZE 20

Definition at line 155 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [1/2]

#define USBD2_EP4_TX_SIZE 20

Definition at line 156 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [2/2]

#define USBD2_EP4_TX_SIZE 20

Definition at line 156 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [1/2]

#define USBD2_EP5_TX_SIZE 20

Definition at line 157 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [2/2]

#define USBD2_EP5_TX_SIZE 20

Definition at line 157 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [1/2]

#define USBD2_EP6_TX_SIZE 20

Definition at line 158 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [2/2]

#define USBD2_EP6_TX_SIZE 20

Definition at line 158 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [1/2]

#define USBD2_EP7_TX_SIZE 20

Definition at line 159 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [2/2]

#define USBD2_EP7_TX_SIZE 20

Definition at line 159 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD2_RX_SIZE [1/2]

#define USBD2_RX_SIZE 128

Definition at line 151 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD2_RX_SIZE [2/2]

#define USBD2_RX_SIZE 128

Definition at line 151 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [1/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 141 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [2/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 141 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [1/2]

#define USBD_EP1_TX_SIZE 20

Definition at line 142 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [2/2]

#define USBD_EP1_TX_SIZE 20

Definition at line 142 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [1/2]

#define USBD_EP2_TX_SIZE 20

Definition at line 143 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [2/2]

#define USBD_EP2_TX_SIZE 20

Definition at line 143 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [1/2]

#define USBD_EP3_TX_SIZE 20

Definition at line 144 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [2/2]

#define USBD_EP3_TX_SIZE 20

Definition at line 144 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [1/2]

#define USBD_EP4_TX_SIZE 20

Definition at line 145 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [2/2]

#define USBD_EP4_TX_SIZE 20

Definition at line 145 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [1/2]

#define USBD_EP5_TX_SIZE 20

Definition at line 146 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [2/2]

#define USBD_EP5_TX_SIZE 20

Definition at line 146 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [1/2]

#define USBD_EP6_TX_SIZE 20

Definition at line 147 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [2/2]

#define USBD_EP6_TX_SIZE 20

Definition at line 147 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [1/2]

#define USBD_EP7_TX_SIZE 20

Definition at line 148 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [2/2]

#define USBD_EP7_TX_SIZE 20

Definition at line 148 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD_RX_SIZE [1/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 140 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USBD_RX_SIZE [2/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 140 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [1/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 52 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [2/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 52 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c.

◆ button_exint_init()

void button_exint_init ( button_type button )

◆ button_isr()

void button_isr ( void )

button handler function

Parameters
none
Return values
none

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

Definition at line 84 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c.

◆ fat16_memory_cmp()

uint32_t fat16_memory_cmp | ( | uint8_t * | dst,
 |  | uint8_t * | src,
 |  | uint32_t | len
 | ) |  |

memory compare function

Parameters
dst | dest buffer pointer
src | src buffer pointer
len | compare length
Return values
compare result

Definition at line 229 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_sector_write().

◆ fat16_memory_copy()

uint32_t fat16_memory_copy | ( | uint8_t * | dst,
 |  | const uint8_t * | src,
 |  | uint32_t | len
 | ) |  |

memory copy function

Parameters
dst | dest buffer pointer
src | src buffer pointer
len | copy length
Return values
nubmer of data copy

Definition at line 195 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_boot_dir_write(), and flash_fat16_read().

◆ fat16_memory_memset()

uint32_t fat16_memory_memset | ( | uint8_t * | dst,
 |  | uint32_t | set,
 |  | uint32_t | len
 | ) |  |

memset function

Parameters
dst | dest buffer pointer
set | set value
len | set length
Return values
nubmer of data set

Definition at line 212 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_boot_dir_write(), and flash_fat16_read().

◆ flash_crc_check()

uint32_t flash_crc_check | ( | uint32_t | address,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

crc check

Parameters
address | flash address
data | pointer to array to store data
len | data length
Return values
crc result

Definition at line 593 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_write_data().

◆ flash_fat16_addr_offset()

uint32_t flash_fat16_addr_offset ( uint8_t * file_name )

get offset address

Parameters
file_name file name
Return values
offset address

Definition at line 440 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_sector_write().

◆ flash_fat16_boot_dir_write()

uint32_t flash_fat16_boot_dir_write | ( | uint32_t | fat_lbk,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

boot dir write

Parameters
fat_lbk | logical block address
data | pointer to array to store data
len | data length
Return values
nubmer of data

Definition at line 382 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_write().

◆ flash_fat16_clear_upgrade_flag()

void flash_fat16_clear_upgrade_flag ( void )

clear iap upgrade flag

Parameters
none
Return values
none

Definition at line 245 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_sector_write().

◆ flash_fat16_get_upgrade_flag()

uint8_t flash_fat16_get_upgrade_flag ( void )

get iap upgrade complete flag

Parameters
none
Return values
the iap flag

Definition at line 270 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by main().

◆ flash_fat16_init()

void flash_fat16_init ( void )

flash fat16 iap init

Parameters
none
Return values
none

Definition at line 712 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by main().

◆ flash_fat16_loop_status()

void flash_fat16_loop_status ( void )

loop status

Parameters
none
Return values
none

Definition at line 294 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by main().

◆ flash_fat16_read()

uint32_t flash_fat16_read | ( | uint32_t | fat_lbk,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

read a logical block address

Parameters
fat_lbk | logical block address to read
data | pointer to array to store data read
len | data length
Return values
read length

Definition at line 291 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by msc_disk_read().

◆ flash_fat16_sector_write()

uint32_t flash_fat16_sector_write | ( | uint32_t | fat_lbk,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

write sector

Parameters
fat_lbk | logical block address
data | pointer to array to store data
len | data length
Return values
nubmer of data

Definition at line 489 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_write().

◆ flash_fat16_set_name()

uint32_t flash_fat16_set_name | ( | const uint8_t * | file_name,
 |  | uint8_t | len
 | ) |  |

set file name

Parameters
file_name | file name
len | filename length
Return values
filename length

Definition at line 360 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_loop_status().

◆ flash_fat16_set_upgrade_flag()

void flash_fat16_set_upgrade_flag ( void )

set iap upgrade complete flag

Parameters
none
Return values
none

Definition at line 257 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_boot_dir_write(), and flash_fat16_sector_write().

◆ flash_fat16_write()

uint32_t flash_fat16_write | ( | uint32_t | fat_lbk,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

write a logical block address

Parameters
fat_lbk | logical block address to read
data | pointer to array to store data read
len | data length
Return values
read length

Definition at line 332 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by msc_disk_write().

◆ flash_read_data()

uint32_t flash_read_data | ( | uint32_t | address,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

read data from flash

Parameters
address | flash address
data | pointer to array to store data
len | data length
Return values
read length

Definition at line 644 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

◆ flash_write_data()

uint32_t flash_write_data | ( | uint32_t | address,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

write data to flash

Parameters
address | flash address
data | pointer to array to store data
len | data length
Return values
write status

Definition at line 663 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_sector_write().

◆ get_inquiry()

uint8_t * get_inquiry ( uint8_t lun )

get disk inquiry

Parameters
lun logical units number
Return values
inquiry string

Definition at line 59 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/msc_diskio.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c.

◆ jump_to_app()

void jump_to_app ( uint32_t address )

jump to app

Parameters
none
Return values
none

Definition at line 350 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by flash_fat16_loop_status(), and main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c.

◆ msc_disk_capacity()

usb_sts_type msc_disk_capacity | ( | uint8_t | lun,
 |  | uint32_t * | blk_nbr,
 |  | uint32_t * | blk_size
 | ) |  |

disk capacity

Parameters
lun | logical units number
blk_nbr | pointer to number of block
blk_size | pointer to block size
Return values
status of usb_sts_type

Definition at line 117 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/msc_diskio.c.

◆ msc_disk_read()

usb_sts_type msc_disk_read | ( | uint8_t | lun,
 |  | uint32_t | addr,
 |  | uint8_t * | read_buf,
 |  | uint32_t | len
 | ) |  |

disk read

Parameters
lun | logical units number
addr | logical address
read_buf | pointer to read buffer
len | read length
Return values
status of usb_sts_type

Definition at line 75 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/msc_diskio.c.

◆ msc_disk_write()

usb_sts_type msc_disk_write | ( | uint8_t | lun,
 |  | uint32_t | addr,
 |  | uint8_t * | buf,
 |  | uint32_t | len
 | ) |  |

disk write

Parameters
lun | logical units number
addr | logical address
buf | pointer to write buffer
len | write length
Return values
status of usb_sts_type

Definition at line 97 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/msc_diskio.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c.

◆ OTG_IRQ_HANDLER()

void OTG_IRQ_HANDLER ( void )

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 382 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc sof signal select: otg1

< acc hick trim

< acc sof signal select: otg1

< acc hick trim

Definition at line 113 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb low power wakeup handler enable

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 392 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 403 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c.

◆ usb_gpio_config()

void usb_gpio_config ( void )

this function config gpio.

Parameters
none
Return values
none

Definition at line 205 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by main().

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

◆ usb_re_connect()

void usb_re_connect ( void )

◆ usb_reset()

void usb_reset ( )

usb re-connect

Parameters
none
Return values
none

Definition at line 281 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by flash_fat16_loop_status().

Variable Documentation

◆ fat16_file_name [1/2]

uint8_t fat16_file_name[FAT16_FILENAME_SIZE]
Initial value:
=
{
'R',
'e',
'a',
'd',
'y',
' ',
' ',
' ',
'T',
'X',
'T'
}

Definition at line 157 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_read(), and flash_fat16_set_name().

◆ fat16_file_name [2/2]

uint8_t fat16_file_name[FAT16_FILENAME_SIZE]
Initial value:
=
{
'R',
'e',
'a',
'd',
'y',
' ',
' ',
' ',
'T',
'X',
'T'
}

Definition at line 157 of file at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_read(), and flash_fat16_set_name().

◆ fat16_root_dir_sector [1/2]

const uint8_t fat16_root_dir_sector[FAT16_DIR_SIZE]

Definition at line 108 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_read().

◆ fat16_root_dir_sector [2/2]

const uint8_t fat16_root_dir_sector[FAT16_DIR_SIZE]

Definition at line 108 of file at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_read().

◆ fat16_sector [1/2]

uint8_t fat16_sector[62]
static

Definition at line 37 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_read().

◆ fat16_sector [2/2]

uint8_t fat16_sector[62]
static

Definition at line 37 of file at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_read().

◆ fat16_table_sector0 [1/2]

const uint8_t fat16_table_sector0[FAT16_TABLE_SIZE]
Initial value:
=
{
0xF8,
0xFF,
0xFF,
0xFF
}

Definition at line 149 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_read().

◆ fat16_table_sector0 [2/2]

const uint8_t fat16_table_sector0[FAT16_TABLE_SIZE]
Initial value:
=
{
0xF8,
0xFF,
0xFF,
0xFF
}

Definition at line 149 of file at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_read().

◆ file_match [1/2]

uint8_t file_match = 0

Definition at line 175 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_boot_dir_write(), and flash_fat16_sector_write().

◆ file_match [2/2]

uint8_t file_match = 0

Definition at line 175 of file at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

◆ file_write_nr [1/2]

uint32_t file_write_nr = 0

Definition at line 174 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

◆ file_write_nr [2/2]

uint32_t file_write_nr = 0

Definition at line 174 of file at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

◆ flash_iap [1/2]

flash_iap_type flash_iap

Definition at line 173 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_addr_offset(), flash_fat16_boot_dir_write(), flash_fat16_clear_upgrade_flag(), flash_fat16_get_upgrade_flag(), flash_fat16_init(), flash_fat16_sector_write(), flash_fat16_set_upgrade_flag(), and flash_write_data().

◆ flash_iap [2/2]

flash_iap_type flash_iap

Definition at line 173 of file at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_get_upgrade_flag(), flash_fat16_init(), flash_fat16_loop_status(), and main().

◆ g_file_attr [1/2]

fat_dir_type g_file_attr

Definition at line 172 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_boot_dir_write(), and flash_fat16_sector_write().

◆ g_file_attr [2/2]

fat_dir_type g_file_attr

Definition at line 172 of file at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

◆ jump_to_app

void jump_to_app

jump to app

Parameters
none
Return values
none

Definition at line 46 of file at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c.

Referenced by app_load(), flash_fat16_loop_status(), and main().

◆ otg_core_struct [1/2]

otg_core_type otg_core_struct

Definition at line 47 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by main(), OTG_IRQ_HANDLER(), and usb_reset().

◆ otg_core_struct [2/2]

otg_core_type otg_core_struct

Definition at line 47 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/src/main.c.

◆ pftarget [1/2]

void(* pftarget) (void) ( void )

Definition at line 48 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by jump_to_app().

◆ pftarget [2/2]

void(* pftarget) (void) ( void )

Definition at line 48 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/src/main.c.

◆ scsi_inquiry [1/2]

uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
Initial value:
=
{
{
0x00,
0x80,
0x00,
0x01,
SCSI_INQUIRY_DATA_LENGTH - 5,
0x00, 0x00, 0x00,
'A', 'T', '3', '2', ' ', ' ', ' ', ' ',
'M', 's', 'c', ' ', 'i', 'a', 'p', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ',
'2', '.', '0', '0'
},
}
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:157

Definition at line 38 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/msc_diskio.c.

Referenced by get_inquiry().

◆ scsi_inquiry [2/2]

uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
Initial value:
=
{
{
0x00,
0x80,
0x00,
0x01,
SCSI_INQUIRY_DATA_LENGTH - 5,
0x00, 0x00, 0x00,
'A', 'T', '3', '2', ' ', ' ', ' ', ' ',
'M', 's', 'c', ' ', 'i', 'a', 'p', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ',
'2', '.', '0', '0'
},
}

Definition at line 38 of file at_start_f437/examples/usb_device/virtual_msc_iap/src/msc_diskio.c.


AT32F435/437 Firmwary Library: USB_device_virtual_msc_iap_definition

Data Structures | Macros | Enumerations | Functions | Variables
USB_device_virtual_msc_iap_definition
AT32F435_periph_examples | AT32F437_periph_examples » USB_device_virtual_msc_iap

Data Structures

struct | fat_dir_type
struct | flash_iap_type

Macros

#define | FAT16_SECTOR_SIZE 62
#define | FAT16_TABLE_SIZE 4
#define | FAT16_BYTE_PER_SIZE 2048
#define | FAT16_FILENAME_SIZE 11
#define | FAT16_DIR_SIZE 47
#define | FLASH_FAT16_BOOT_SECTOR_ADDR 0x00
#define | FLASH_FAT16_1_ADDR 0x3000
#define | FLASH_FAT16_2_ADDR 0x3800
#define | FLASH_FAT16_ROOT_ADDR 0x4000
#define | FLASH_FAT16_FILE_START_ADDR 0x8800
#define | FLASH_APP_START_ADDR 0x08006000
#define | FLASH_SECTOR_1K_SIZE 0x400
#define | FLASH_SECTOR_2K_SIZE 0x800
#define | FLASH_SECTOR_4K_SIZE 0x1000
#define | FLASH_SECTOR_1K_ALLGNED 0x3FF
#define | FLASH_SECTOR_2K_ALLGNED 0x7FF
#define | FLASH_SECTOR_4K_ALLGNED 0xFFF
#define | FILE_SUFFIX1_LEN 3
#define | FILE_SUFFIX2_LEN 3
#define | FILE_SUFFIX1_NAME "BIN"
#define | FILE_SUFFIX2_NAME "bin"
#define | INVAILD_OFFSET_ADDR 0xFFFFFFFF
#define | IAP_UPGRADE_COMPLETE_FLAG 0x41544B38
#define | IAP_SUCCESS 0
#define | IAP_FAILED 1
#define | FAT16_SECTOR_SIZE 62
#define | FAT16_TABLE_SIZE 4
#define | FAT16_BYTE_PER_SIZE 2048
#define | FAT16_FILENAME_SIZE 11
#define | FAT16_DIR_SIZE 47
#define | FLASH_FAT16_BOOT_SECTOR_ADDR 0x00
#define | FLASH_FAT16_1_ADDR 0x3000
#define | FLASH_FAT16_2_ADDR 0x3800
#define | FLASH_FAT16_ROOT_ADDR 0x4000
#define | FLASH_FAT16_FILE_START_ADDR 0x8800
#define | FLASH_APP_START_ADDR 0x08006000
#define | FLASH_SECTOR_1K_SIZE 0x400
#define | FLASH_SECTOR_2K_SIZE 0x800
#define | FLASH_SECTOR_4K_SIZE 0x1000
#define | FLASH_SECTOR_1K_ALLGNED 0x3FF
#define | FLASH_SECTOR_2K_ALLGNED 0x7FF
#define | FLASH_SECTOR_4K_ALLGNED 0xFFF
#define | FILE_SUFFIX1_LEN 3
#define | FILE_SUFFIX2_LEN 3
#define | FILE_SUFFIX1_NAME "BIN"
#define | FILE_SUFFIX2_NAME "bin"
#define | INVAILD_OFFSET_ADDR 0xFFFFFFFF
#define | IAP_UPGRADE_COMPLETE_FLAG 0x41544B38
#define | IAP_SUCCESS 0
#define | IAP_FAILED 1

Enumerations

enum upgrade_status_type {
UPGRADE_READY = 0 , UPGRAGE_ONGOING , UPGRADE_SUCCESS , UPGRADE_FAILED ,
UPGRADE_LARGE , UPGRADE_UNKNOWN , UPGRADE_DONE , UPGRADE_JUMP ,
UPGRADE_READY = 0 , UPGRAGE_ONGOING , UPGRADE_SUCCESS , UPGRADE_FAILED ,
UPGRADE_LARGE , UPGRADE_UNKNOWN , UPGRADE_DONE , UPGRADE_JUMP
}
enum upgrade_status_type {
UPGRADE_READY = 0 , UPGRAGE_ONGOING , UPGRADE_SUCCESS , UPGRADE_FAILED ,
UPGRADE_LARGE , UPGRADE_UNKNOWN , UPGRADE_DONE , UPGRADE_JUMP ,
UPGRADE_READY = 0 , UPGRAGE_ONGOING , UPGRADE_SUCCESS , UPGRADE_FAILED ,
UPGRADE_LARGE , UPGRADE_UNKNOWN , UPGRADE_DONE , UPGRADE_JUMP
}

Functions

uint32_t | flash_fat16_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address More...
uint32_t | flash_fat16_read (uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address More...
void | flash_fat16_init (void)
flash fat16 iap init More...
void | flash_fat16_loop_status (void)
loop status More...
uint32_t | flash_fat16_set_name (const uint8_t *file_name, uint8_t len)
set file name More...
uint8_t | flash_fat16_get_upgrade_flag (void)
get iap upgrade complete flag More...

Variables

flash_iap_type flash_iap
flash_iap_type flash_iap

Detailed Description

Macro Definition Documentation

◆ FAT16_BYTE_PER_SIZE [1/2]

#define FAT16_BYTE_PER_SIZE 2048

Definition at line 50 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FAT16_BYTE_PER_SIZE [2/2]

#define FAT16_BYTE_PER_SIZE 2048

Definition at line 50 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FAT16_DIR_SIZE [1/2]

#define FAT16_DIR_SIZE 47

Definition at line 52 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FAT16_DIR_SIZE [2/2]

#define FAT16_DIR_SIZE 47

Definition at line 52 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FAT16_FILENAME_SIZE [1/2]

#define FAT16_FILENAME_SIZE 11

Definition at line 51 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FAT16_FILENAME_SIZE [2/2]

#define FAT16_FILENAME_SIZE 11

Definition at line 51 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FAT16_SECTOR_SIZE [1/2]

#define FAT16_SECTOR_SIZE 62

Definition at line 48 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FAT16_SECTOR_SIZE [2/2]

#define FAT16_SECTOR_SIZE 62

Definition at line 48 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FAT16_TABLE_SIZE [1/2]

#define FAT16_TABLE_SIZE 4

Definition at line 49 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FAT16_TABLE_SIZE [2/2]

#define FAT16_TABLE_SIZE 4

Definition at line 49 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FILE_SUFFIX1_LEN [1/2]

#define FILE_SUFFIX1_LEN 3

Definition at line 70 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FILE_SUFFIX1_LEN [2/2]

#define FILE_SUFFIX1_LEN 3

Definition at line 70 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FILE_SUFFIX1_NAME [1/2]

#define FILE_SUFFIX1_NAME "BIN"

Definition at line 72 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FILE_SUFFIX1_NAME [2/2]

#define FILE_SUFFIX1_NAME "BIN"

Definition at line 72 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FILE_SUFFIX2_LEN [1/2]

#define FILE_SUFFIX2_LEN 3

Definition at line 71 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FILE_SUFFIX2_LEN [2/2]

#define FILE_SUFFIX2_LEN 3

Definition at line 71 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FILE_SUFFIX2_NAME [1/2]

#define FILE_SUFFIX2_NAME "bin"

Definition at line 73 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FILE_SUFFIX2_NAME [2/2]

#define FILE_SUFFIX2_NAME "bin"

Definition at line 73 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FLASH_APP_START_ADDR [1/2]

#define FLASH_APP_START_ADDR 0x08006000

Definition at line 60 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FLASH_APP_START_ADDR [2/2]

#define FLASH_APP_START_ADDR 0x08006000

Definition at line 60 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FLASH_FAT16_1_ADDR [1/2]

#define FLASH_FAT16_1_ADDR 0x3000

Definition at line 55 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FLASH_FAT16_1_ADDR [2/2]

#define FLASH_FAT16_1_ADDR 0x3000

Definition at line 55 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FLASH_FAT16_2_ADDR [1/2]

#define FLASH_FAT16_2_ADDR 0x3800

Definition at line 56 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FLASH_FAT16_2_ADDR [2/2]

#define FLASH_FAT16_2_ADDR 0x3800

Definition at line 56 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FLASH_FAT16_BOOT_SECTOR_ADDR [1/2]

#define FLASH_FAT16_BOOT_SECTOR_ADDR 0x00

Definition at line 54 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FLASH_FAT16_BOOT_SECTOR_ADDR [2/2]

#define FLASH_FAT16_BOOT_SECTOR_ADDR 0x00

Definition at line 54 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FLASH_FAT16_FILE_START_ADDR [1/2]

#define FLASH_FAT16_FILE_START_ADDR 0x8800

Definition at line 58 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FLASH_FAT16_FILE_START_ADDR [2/2]

#define FLASH_FAT16_FILE_START_ADDR 0x8800

Definition at line 58 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FLASH_FAT16_ROOT_ADDR [1/2]

#define FLASH_FAT16_ROOT_ADDR 0x4000

Definition at line 57 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FLASH_FAT16_ROOT_ADDR [2/2]

#define FLASH_FAT16_ROOT_ADDR 0x4000

Definition at line 57 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FLASH_SECTOR_1K_ALLGNED [1/2]

#define FLASH_SECTOR_1K_ALLGNED 0x3FF

Definition at line 66 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FLASH_SECTOR_1K_ALLGNED [2/2]

#define FLASH_SECTOR_1K_ALLGNED 0x3FF

Definition at line 66 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FLASH_SECTOR_1K_SIZE [1/2]

#define FLASH_SECTOR_1K_SIZE 0x400

Definition at line 62 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FLASH_SECTOR_1K_SIZE [2/2]

#define FLASH_SECTOR_1K_SIZE 0x400

Definition at line 62 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FLASH_SECTOR_2K_ALLGNED [1/2]

#define FLASH_SECTOR_2K_ALLGNED 0x7FF

Definition at line 67 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FLASH_SECTOR_2K_ALLGNED [2/2]

#define FLASH_SECTOR_2K_ALLGNED 0x7FF

Definition at line 67 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FLASH_SECTOR_2K_SIZE [1/2]

#define FLASH_SECTOR_2K_SIZE 0x800

Definition at line 63 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FLASH_SECTOR_2K_SIZE [2/2]

#define FLASH_SECTOR_2K_SIZE 0x800

Definition at line 63 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FLASH_SECTOR_4K_ALLGNED [1/2]

#define FLASH_SECTOR_4K_ALLGNED 0xFFF

Definition at line 68 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FLASH_SECTOR_4K_ALLGNED [2/2]

#define FLASH_SECTOR_4K_ALLGNED 0xFFF

Definition at line 68 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FLASH_SECTOR_4K_SIZE [1/2]

#define FLASH_SECTOR_4K_SIZE 0x1000

Definition at line 64 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ FLASH_SECTOR_4K_SIZE [2/2]

#define FLASH_SECTOR_4K_SIZE 0x1000

Definition at line 64 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ IAP_FAILED [1/2]

#define IAP_FAILED 1

Definition at line 78 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ IAP_FAILED [2/2]

#define IAP_FAILED 1

Definition at line 78 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ IAP_SUCCESS [1/2]

#define IAP_SUCCESS 0

Definition at line 77 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ IAP_SUCCESS [2/2]

#define IAP_SUCCESS 0

Definition at line 77 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ IAP_UPGRADE_COMPLETE_FLAG [1/2]

#define IAP_UPGRADE_COMPLETE_FLAG 0x41544B38

Definition at line 76 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ IAP_UPGRADE_COMPLETE_FLAG [2/2]

#define IAP_UPGRADE_COMPLETE_FLAG 0x41544B38

Definition at line 76 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ INVAILD_OFFSET_ADDR [1/2]

#define INVAILD_OFFSET_ADDR 0xFFFFFFFF

Definition at line 75 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ INVAILD_OFFSET_ADDR [2/2]

#define INVAILD_OFFSET_ADDR 0xFFFFFFFF

Definition at line 75 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

Enumeration Type Documentation

◆ upgrade_status_type [1/2]

enum upgrade_status_type
Enumerator
UPGRADE_READY
UPGRAGE_ONGOING
UPGRADE_SUCCESS
UPGRADE_FAILED
UPGRADE_LARGE
UPGRADE_UNKNOWN
UPGRADE_DONE
UPGRADE_JUMP
UPGRADE_READY
UPGRAGE_ONGOING
UPGRADE_SUCCESS
UPGRADE_FAILED
UPGRADE_LARGE
UPGRADE_UNKNOWN
UPGRADE_DONE
UPGRADE_JUMP

Definition at line 80 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ upgrade_status_type [2/2]

enum upgrade_status_type
Enumerator
UPGRADE_READY
UPGRAGE_ONGOING
UPGRADE_SUCCESS
UPGRADE_FAILED
UPGRADE_LARGE
UPGRADE_UNKNOWN
UPGRADE_DONE
UPGRADE_JUMP
UPGRADE_READY
UPGRAGE_ONGOING
UPGRADE_SUCCESS
UPGRADE_FAILED
UPGRADE_LARGE
UPGRADE_UNKNOWN
UPGRADE_DONE
UPGRADE_JUMP

Definition at line 80 of file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

Function Documentation

◆ flash_fat16_get_upgrade_flag()

uint8_t flash_fat16_get_upgrade_flag ( void )

get iap upgrade complete flag

Parameters
none
Return values
the iap flag

Definition at line 270 of file at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by main().

◆ flash_fat16_init()

void flash_fat16_init ( void )

flash fat16 iap init

Parameters
none
Return values
none

Definition at line 712 of file at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by main().

◆ flash_fat16_loop_status()

void flash_fat16_loop_status ( void )

loop status

Parameters
none
Return values
none

Definition at line 294 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by main().

◆ flash_fat16_read()

uint32_t flash_fat16_read | ( | uint32_t | fat_lbk,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

read a logical block address

Parameters
fat_lbk | logical block address to read
data | pointer to array to store data read
len | data length
Return values
read length

Definition at line 291 of file at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by msc_disk_read().

◆ flash_fat16_set_name()

uint32_t flash_fat16_set_name | ( | const uint8_t * | file_name,
 |  | uint8_t | len
 | ) |  |

set file name

Parameters
file_name | file name
len | filename length
Return values
filename length

Definition at line 360 of file at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_loop_status().

◆ flash_fat16_write()

uint32_t flash_fat16_write | ( | uint32_t | fat_lbk,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

write a logical block address

Parameters
fat_lbk | logical block address to read
data | pointer to array to store data read
len | data length
Return values
read length

Definition at line 332 of file at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by msc_disk_write().

Variable Documentation

◆ flash_iap [1/2]

flash_iap_type flash_iap
extern

Definition at line 173 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_loop_status(), and main().

◆ flash_iap [2/2]

flash_iap_type flash_iap
extern

Definition at line 173 of file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.

Referenced by flash_fat16_addr_offset(), flash_fat16_boot_dir_write(), flash_fat16_clear_upgrade_flag(), flash_fat16_get_upgrade_flag(), flash_fat16_init(), flash_fat16_sector_write(), flash_fat16_set_upgrade_flag(), and flash_write_data().


AT32F435/437 Firmwary Library: fat_dir_type Struct Reference

Data Fields
fat_dir_type Struct Reference
AT32F435_periph_examples | AT32F437_periph_examples » USB_device_virtual_msc_iap » USB_device_virtual_msc_iap_definition

#include <flash_fat16.h>

Data Fields

uint8_t | file_name [11]
uint8_t | attr
uint8_t | res
uint8_t | create_time_tenth
uint16_t | create_time
uint16_t | create_data
uint16_t | last_access_data
uint16_t | clus_high
uint16_t | write_time
uint16_t | write_data
uint16_t | clus_low
uint32_t | file_size

Detailed Description

Definition at line 92 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

Field Documentation

◆ attr

uint8_t fat_dir_type::attr

Definition at line 95 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

Referenced by flash_fat16_boot_dir_write().

◆ clus_high

uint16_t fat_dir_type::clus_high

Definition at line 101 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ clus_low

uint16_t fat_dir_type::clus_low

Definition at line 104 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ create_data

uint16_t fat_dir_type::create_data

Definition at line 99 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ create_time

uint16_t fat_dir_type::create_time

Definition at line 98 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ create_time_tenth

uint8_t fat_dir_type::create_time_tenth

Definition at line 97 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ file_name

uint8_t fat_dir_type::file_name

Definition at line 94 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

Referenced by flash_fat16_sector_write().

◆ file_size

uint32_t fat_dir_type::file_size

Definition at line 105 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

Referenced by flash_fat16_boot_dir_write(), and flash_fat16_sector_write().

◆ last_access_data

uint16_t fat_dir_type::last_access_data

Definition at line 100 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ res

uint8_t fat_dir_type::res

Definition at line 96 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ write_data

uint16_t fat_dir_type::write_data

Definition at line 103 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

Referenced by flash_fat16_boot_dir_write().

◆ write_time

uint16_t fat_dir_type::write_time

Definition at line 102 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

Referenced by flash_fat16_boot_dir_write().

The documentation for this struct was generated from the following files:
  • at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h


AT32F435/437 Firmwary Library: flash_iap_type Struct Reference

Data Fields
flash_iap_type Struct Reference
AT32F435_periph_examples | AT32F437_periph_examples » USB_device_virtual_msc_iap » USB_device_virtual_msc_iap_definition

#include <flash_fat16.h>

Data Fields

uint32_t | flash_base_addr
uint32_t | flash_app_addr
uint32_t | flash_size
uint32_t | flash_app_size
uint32_t | sector_size
uint32_t | sector_mask
uint32_t | firmware_length
uint32_t | write_crc
uint32_t | read_crc
uint32_t | write_addr
uint32_t | file_write_nr
upgrade_status_type msc_up_status

Detailed Description

Definition at line 108 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

Field Documentation

◆ file_write_nr

uint32_t flash_iap_type::file_write_nr

Definition at line 121 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

Referenced by flash_fat16_boot_dir_write(), and flash_fat16_sector_write().

◆ firmware_length

uint32_t flash_iap_type::firmware_length

Definition at line 116 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ flash_app_addr

uint32_t flash_iap_type::flash_app_addr

Definition at line 111 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

Referenced by flash_fat16_addr_offset(), flash_fat16_clear_upgrade_flag(), flash_fat16_get_upgrade_flag(), flash_fat16_init(), flash_fat16_set_upgrade_flag(), and main().

◆ flash_app_size

uint32_t flash_iap_type::flash_app_size

Definition at line 113 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

Referenced by flash_fat16_init(), and flash_fat16_sector_write().

◆ flash_base_addr

uint32_t flash_iap_type::flash_base_addr

Definition at line 110 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

Referenced by flash_fat16_addr_offset(), flash_fat16_init(), flash_fat16_sector_write(), and flash_write_data().

◆ flash_size

uint32_t flash_iap_type::flash_size

Definition at line 112 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

Referenced by flash_fat16_addr_offset(), flash_fat16_init(), and flash_write_data().

◆ msc_up_status

upgrade_status_type flash_iap_type::msc_up_status

Definition at line 122 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

Referenced by flash_fat16_boot_dir_write(), flash_fat16_loop_status(), and flash_fat16_sector_write().

◆ read_crc

uint32_t flash_iap_type::read_crc

Definition at line 118 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

◆ sector_mask

uint32_t flash_iap_type::sector_mask

Definition at line 115 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

Referenced by flash_fat16_init(), and flash_write_data().

◆ sector_size

uint32_t flash_iap_type::sector_size

Definition at line 114 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

Referenced by flash_fat16_clear_upgrade_flag(), flash_fat16_get_upgrade_flag(), flash_fat16_init(), flash_fat16_set_upgrade_flag(), and flash_write_data().

◆ write_addr

uint32_t flash_iap_type::write_addr

Definition at line 120 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

Referenced by flash_fat16_init(), flash_fat16_loop_status(), and flash_fat16_sector_write().

◆ write_crc

uint32_t flash_iap_type::write_crc

Definition at line 117 of file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.

The documentation for this struct was generated from the following files:
  • at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h


AT32F435/437 Firmwary Library: USB_host_hid

Macros | Functions | Variables
USB_host_hid
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | USE_OTG_HOST_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
select otgfs1 or otgfs2 define More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | OTG_PIN_POWER_SWITCH_GPIO GPIOH
#define | OTG_PIN_POWER_SWITCH_CLOCK CRM_GPIOH_PERIPH_CLOCK
#define | OTG_PIN_POWER_SWITCH GPIO_PINS_3
#define | USBH_RX_FIFO_SIZE 128
usb device mode config More...
#define | USBH_NP_TX_FIFO_SIZE 96
#define | USBH_P_TX_FIFO_SIZE 96
#define | USBH2_RX_FIFO_SIZE 128
#define | USBH2_NP_TX_FIFO_SIZE 96
#define | USBH2_P_TX_FIFO_SIZE 96
#define | USBH_5V_POWER_SWITCH
#define | USB_VBUS_IGNORE
usb sof output enable More...
#define | USBH_DEBUG_ENABLE
usb low power wakeup handler enable More...
#define | USBH_DEBUG(...)
#define | USE_OTG_HOST_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
select otgfs1 or otgfs2 define More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | OTG_PIN_POWER_SWITCH_GPIO GPIOH
#define | OTG_PIN_POWER_SWITCH_CLOCK CRM_GPIOH_PERIPH_CLOCK
#define | OTG_PIN_POWER_SWITCH GPIO_PINS_3
#define | USBH_RX_FIFO_SIZE 128
usb device mode config More...
#define | USBH_NP_TX_FIFO_SIZE 96
#define | USBH_P_TX_FIFO_SIZE 96
#define | USBH2_RX_FIFO_SIZE 128
#define | USBH2_NP_TX_FIFO_SIZE 96
#define | USBH2_P_TX_FIFO_SIZE 96
#define | USBH_5V_POWER_SWITCH
#define | USB_VBUS_IGNORE
usb sof output enable More...
#define | USBH_DEBUG_ENABLE
usb low power wakeup handler enable More...
#define | USBH_DEBUG(...)

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
void | button_exint_init (void)
configure button exint More...
void | button_isr (void)
button handler function More...
void | EXINT0_IRQHandler (void)
exint0 interrupt handler More...
int | main (void)
main function. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...
static usb_sts_type | usbh_user_init (void)
usb host init user handler More...
static usb_sts_type | usbh_user_reset (void)
usb host reset user handler More...
static usb_sts_type | usbh_user_attached (void)
usb host check device attached More...
static usb_sts_type | usbh_user_disconnect (void)
usb host discconet user handler More...
static usb_sts_type | usbh_user_speed (uint8_t speed)
usb host speed user handler More...
static usb_sts_type | usbh_user_mfc_string (void *string)
usb host manufacturer string user handler More...
static usb_sts_type | usbh_user_product_string (void *string)
usb host product string user handler More...
static usb_sts_type | usbh_user_serial_string (void *string)
usb host serial string user handler More...
static usb_sts_type | usbh_user_enumeration_done (void)
usb host enumeration done user handler More...
static usb_sts_type | usbh_user_application (void)
usb host application user handler More...
static usb_sts_type | usbh_user_active_vbus (void *uhost, confirm_state state)
usb host active vbus user handler More...
static usb_sts_type | usbh_user_not_support (void)
usb host not support user handler More...

Variables

otg_core_type otg_core_struct
usbh_user_handler_type | usbh_user_handle
otg_core_type otg_core_struct
usbh_user_handler_type | usbh_user_handle

Detailed Description

Macro Definition Documentation

◆ OTG_CLOCK [1/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 69 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_CLOCK [2/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 69 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_IRQ [1/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 70 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_IRQ [2/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 70 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [1/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 71 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [2/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 71 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_DM [1/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 82 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_DM [2/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 82 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [1/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 83 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [2/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 83 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_DP [1/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 79 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_DP [2/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 79 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [1/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 80 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [2/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 80 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_GPIO [1/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 76 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_GPIO [2/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 76 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [1/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 77 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [2/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 77 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_ID [1/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 88 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_ID [2/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 88 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [1/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 89 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [2/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 89 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_MUX [1/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 96 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_MUX [2/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 96 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_POWER_SWITCH [1/2]

#define OTG_PIN_POWER_SWITCH GPIO_PINS_3

Definition at line 100 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_POWER_SWITCH [2/2]

#define OTG_PIN_POWER_SWITCH GPIO_PINS_3

Definition at line 100 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_POWER_SWITCH_CLOCK [1/2]

#define OTG_PIN_POWER_SWITCH_CLOCK CRM_GPIOH_PERIPH_CLOCK

Definition at line 99 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_POWER_SWITCH_CLOCK [2/2]

#define OTG_PIN_POWER_SWITCH_CLOCK CRM_GPIOH_PERIPH_CLOCK

Definition at line 99 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_POWER_SWITCH_GPIO [1/2]

#define OTG_PIN_POWER_SWITCH_GPIO GPIOH

Definition at line 98 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_POWER_SWITCH_GPIO [2/2]

#define OTG_PIN_POWER_SWITCH_GPIO GPIOH

Definition at line 98 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF [1/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 93 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF [2/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 93 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [1/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 91 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [2/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 91 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [1/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 92 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [2/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 92 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [1/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 94 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [2/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 94 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_VBUS [1/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 85 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_VBUS [2/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 85 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [1/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 86 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [2/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 86 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_USB_ID [1/2]

#define OTG_USB_ID 1

select otgfs1 or otgfs2 define

Definition at line 62 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_USB_ID [2/2]

#define OTG_USB_ID 1

select otgfs1 or otgfs2 define

Definition at line 62 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [1/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 74 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [2/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 74 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [1/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 73 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [2/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 73 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [1/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 72 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [2/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 72 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ USB_ID [1/2]

#define USB_ID 0

Definition at line 68 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ USB_ID [2/2]

#define USB_ID 0

Definition at line 68 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [1/2]

#define USB_VBUS_IGNORE

usb sof output enable

usb vbus ignore

Definition at line 211 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [2/2]

#define USB_VBUS_IGNORE

usb sof output enable

usb vbus ignore

Definition at line 211 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ USBH2_NP_TX_FIFO_SIZE [1/2]

#define USBH2_NP_TX_FIFO_SIZE 96

Definition at line 195 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ USBH2_NP_TX_FIFO_SIZE [2/2]

#define USBH2_NP_TX_FIFO_SIZE 96

Definition at line 195 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ USBH2_P_TX_FIFO_SIZE [1/2]

#define USBH2_P_TX_FIFO_SIZE 96

Definition at line 196 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ USBH2_P_TX_FIFO_SIZE [2/2]

#define USBH2_P_TX_FIFO_SIZE 96

Definition at line 196 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ USBH2_RX_FIFO_SIZE [1/2]

#define USBH2_RX_FIFO_SIZE 128

Definition at line 194 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ USBH2_RX_FIFO_SIZE [2/2]

#define USBH2_RX_FIFO_SIZE 128

Definition at line 194 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ USBH_5V_POWER_SWITCH [1/2]

#define USBH_5V_POWER_SWITCH

Definition at line 199 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ USBH_5V_POWER_SWITCH [2/2]

#define USBH_5V_POWER_SWITCH

Definition at line 199 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ USBH_DEBUG [1/2]

#define USBH_DEBUG ( ... )
Value:
printf(__VA_ARGS__);\
printf("\r\n");

Definition at line 221 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ USBH_DEBUG [2/2]

#define USBH_DEBUG ( ... )
Value:
printf(__VA_ARGS__);\
printf("\r\n");

Definition at line 221 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ USBH_DEBUG_ENABLE [1/2]

#define USBH_DEBUG_ENABLE

usb low power wakeup handler enable

Definition at line 218 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ USBH_DEBUG_ENABLE [2/2]

#define USBH_DEBUG_ENABLE

usb low power wakeup handler enable

Definition at line 218 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ USBH_NP_TX_FIFO_SIZE [1/2]

#define USBH_NP_TX_FIFO_SIZE 96

Definition at line 190 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ USBH_NP_TX_FIFO_SIZE [2/2]

#define USBH_NP_TX_FIFO_SIZE 96

Definition at line 190 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ USBH_P_TX_FIFO_SIZE [1/2]

#define USBH_P_TX_FIFO_SIZE 96

Definition at line 191 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ USBH_P_TX_FIFO_SIZE [2/2]

#define USBH_P_TX_FIFO_SIZE 96

Definition at line 191 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ USBH_RX_FIFO_SIZE [1/2]

#define USBH_RX_FIFO_SIZE 128

usb device mode config

usb host mode config

usb host mode fifo

Definition at line 189 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ USBH_RX_FIFO_SIZE [2/2]

#define USBH_RX_FIFO_SIZE 128

usb device mode config

usb host mode config

usb host mode fifo

Definition at line 189 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ USE_OTG_HOST_MODE [1/2]

#define USE_OTG_HOST_MODE

enable usb device mode

enable usb host mode

Definition at line 55 of file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.

◆ USE_OTG_HOST_MODE [2/2]

#define USE_OTG_HOST_MODE

enable usb device mode

enable usb host mode

Definition at line 55 of file project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c.

◆ button_exint_init()

void button_exint_init ( void )

configure button exint

Parameters
none
Return values
none

< external interrupt line 0

< external interrupt line 0

Definition at line 56 of file project/at_start_f435/examples/usb_host/hid_demo/src/main.c.

Referenced by main().

◆ button_isr()

void button_isr ( void )

button handler function

Parameters
none
Return values
none

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

< external interrupt line 0

Definition at line 84 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c.

Referenced by EXINT0_IRQHandler().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c.

◆ EXINT0_IRQHandler()

void EXINT0_IRQHandler ( void )

exint0 interrupt handler

Parameters
none
Return values
none

< external interrupt line 0

< external interrupt line 0

Definition at line 78 of file project/at_start_f435/examples/usb_host/hid_demo/src/main.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 99 of file project/at_start_f435/examples/usb_host/hid_demo/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c.

◆ OTG_IRQ_HANDLER()

void OTG_IRQ_HANDLER ( void )

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 319 of file project/at_start_f435/examples/usb_host/hid_demo/src/main.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

< acc hick trim

Definition at line 144 of file project/at_start_f435/examples/usb_host/hid_demo/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

usb low power wakeup handler enable

Parameters
ms number of millisecond delay
Return values
none

Definition at line 329 of file project/at_start_f435/examples/usb_host/hid_demo/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 340 of file project/at_start_f435/examples/usb_host/hid_demo/src/main.c.

◆ usb_gpio_config()

void usb_gpio_config ( void )

this function config gpio.

Parameters
none
Return values
none

Definition at line 232 of file project/at_start_f435/examples/usb_host/hid_demo/src/main.c.

Referenced by main().

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

◆ usbh_user_active_vbus()

static usb_sts_type usbh_user_active_vbus | ( | void * | uhost,
 |  | confirm_state | state
 | ) |  |
static

usb host active vbus user handler

Parameters
uhost | to the structure of usbh_core_type
state | vbus state TRUE: active vbus FALSE: deactive vbus
Return values
usb_sts_type

Definition at line 202 of file at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c.

◆ usbh_user_application()

static usb_sts_type usbh_user_application ( void )
static

usb host application user handler

Parameters
none
Return values
usb_sts_type

Definition at line 186 of file at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c.

◆ usbh_user_attached()

static usb_sts_type usbh_user_attached ( void )
static

usb host check device attached

Parameters
none
Return values
usb_sts_type

Definition at line 95 of file at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c.

◆ usbh_user_disconnect()

static usb_sts_type usbh_user_disconnect ( void )
static

usb host discconet user handler

Parameters
none
Return values
usb_sts_type

Definition at line 107 of file at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c.

◆ usbh_user_enumeration_done()

static usb_sts_type usbh_user_enumeration_done ( void )
static

usb host enumeration done user handler

Parameters
none
Return values
usb_sts_type

Definition at line 174 of file at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c.

◆ usbh_user_init()

static usb_sts_type usbh_user_init ( void )
static

usb host init user handler

Parameters
none
Return values
usb_sts_type

Definition at line 71 of file at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c.

◆ usbh_user_mfc_string()

static usb_sts_type usbh_user_mfc_string ( void * string )
static

usb host manufacturer string user handler

Parameters
none
Return values
usb_sts_type

Definition at line 138 of file at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c.

◆ usbh_user_not_support()

static usb_sts_type usbh_user_not_support ( void )
static

usb host not support user handler

Parameters
none
Return values
usb_sts_type

Definition at line 225 of file at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c.

◆ usbh_user_product_string()

static usb_sts_type usbh_user_product_string ( void * string )
static

usb host product string user handler

Parameters
none
Return values
usb_sts_type

Definition at line 150 of file at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c.

◆ usbh_user_reset()

static usb_sts_type usbh_user_reset ( void )
static

usb host reset user handler

Parameters
none
Return values
usb_sts_type

Definition at line 83 of file at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c.

◆ usbh_user_serial_string()

static usb_sts_type usbh_user_serial_string ( void * string )
static

usb host serial string user handler

Parameters
none
Return values
usb_sts_type

Definition at line 162 of file at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c.

◆ usbh_user_speed()

static usb_sts_type usbh_user_speed ( uint8_t speed )
static

usb host speed user handler

Parameters
none
Return values
usb_sts_type

Definition at line 119 of file at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c.

Variable Documentation

◆ otg_core_struct [1/2]

otg_core_type otg_core_struct

Definition at line 44 of file project/at_start_f435/examples/usb_host/hid_demo/src/main.c.

Referenced by EXINT0_IRQHandler(), main(), and OTG_IRQ_HANDLER().

◆ otg_core_struct [2/2]

otg_core_type otg_core_struct

Definition at line 44 of file project/at_start_f437/examples/usb_host/hid_demo/src/main.c.

◆ usbh_user_handle [1/2]

usbh_user_handler_type usbh_user_handle
Initial value:
=
{
usbh_user_init,
usbh_user_reset,
usbh_user_attached,
usbh_user_disconnect,
usbh_user_speed,
usbh_user_mfc_string,
usbh_user_product_string,
usbh_user_serial_string,
usbh_user_enumeration_done,
usbh_user_application,
usbh_user_active_vbus,
usbh_user_not_support,
}
usbh_user_init
static usb_sts_type usbh_user_init(void)
usb host init user handler
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:71
usbh_user_disconnect
static usb_sts_type usbh_user_disconnect(void)
usb host discconet user handler
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:107
usbh_user_not_support
static usb_sts_type usbh_user_not_support(void)
usb host not support user handler
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:225
usbh_user_application
static usb_sts_type usbh_user_application(void)
usb host application user handler
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:186
usbh_user_speed
static usb_sts_type usbh_user_speed(uint8_t speed)
usb host speed user handler
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:119
usbh_user_active_vbus
static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state)
usb host active vbus user handler
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:202
usbh_user_serial_string
static usb_sts_type usbh_user_serial_string(void *string)
usb host serial string user handler
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:162
usbh_user_reset
static usb_sts_type usbh_user_reset(void)
usb host reset user handler
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:83
usbh_user_mfc_string
static usb_sts_type usbh_user_mfc_string(void *string)
usb host manufacturer string user handler
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:138
usbh_user_enumeration_done
static usb_sts_type usbh_user_enumeration_done(void)
usb host enumeration done user handler
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:174
usbh_user_attached
static usb_sts_type usbh_user_attached(void)
usb host check device attached
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:95
usbh_user_product_string
static usb_sts_type usbh_user_product_string(void *string)
usb host product string user handler
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:150

Definition at line 50 of file at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c.

◆ usbh_user_handle [2/2]

usbh_user_handler_type usbh_user_handle
Initial value:
=
{
usbh_user_init,
usbh_user_reset,
usbh_user_attached,
usbh_user_disconnect,
usbh_user_speed,
usbh_user_mfc_string,
usbh_user_product_string,
usbh_user_serial_string,
usbh_user_enumeration_done,
usbh_user_application,
usbh_user_active_vbus,
usbh_user_not_support,
}
usbh_user_init
static usb_sts_type usbh_user_init(void)
usb host init user handler
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:71
usbh_user_disconnect
static usb_sts_type usbh_user_disconnect(void)
usb host discconet user handler
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:107
usbh_user_not_support
static usb_sts_type usbh_user_not_support(void)
usb host not support user handler
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:225
usbh_user_application
static usb_sts_type usbh_user_application(void)
usb host application user handler
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:186
usbh_user_speed
static usb_sts_type usbh_user_speed(uint8_t speed)
usb host speed user handler
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:119
usbh_user_active_vbus
static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state)
usb host active vbus user handler
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:202
usbh_user_serial_string
static usb_sts_type usbh_user_serial_string(void *string)
usb host serial string user handler
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:162
usbh_user_reset
static usb_sts_type usbh_user_reset(void)
usb host reset user handler
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:83
usbh_user_mfc_string
static usb_sts_type usbh_user_mfc_string(void *string)
usb host manufacturer string user handler
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:138
usbh_user_enumeration_done
static usb_sts_type usbh_user_enumeration_done(void)
usb host enumeration done user handler
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:174
usbh_user_attached
static usb_sts_type usbh_user_attached(void)
usb host check device attached
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:95
usbh_user_product_string
static usb_sts_type usbh_user_product_string(void *string)
usb host product string user handler
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:150

Definition at line 50 of file at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c.


AT32F435/437 Firmwary Library: USB_host_msc

Macros | Enumerations | Functions | Variables
USB_host_msc
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | USE_OTG_HOST_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
select otgfs1 or otgfs2 define More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | OTG_PIN_POWER_SWITCH_GPIO GPIOH
#define | OTG_PIN_POWER_SWITCH_CLOCK CRM_GPIOH_PERIPH_CLOCK
#define | OTG_PIN_POWER_SWITCH GPIO_PINS_3
#define | USBH_RX_FIFO_SIZE 128
usb device mode config More...
#define | USBH_NP_TX_FIFO_SIZE 96
#define | USBH_P_TX_FIFO_SIZE 96
#define | USBH2_RX_FIFO_SIZE 128
#define | USBH2_NP_TX_FIFO_SIZE 96
#define | USBH2_P_TX_FIFO_SIZE 96
#define | USBH_5V_POWER_SWITCH
#define | USB_VBUS_IGNORE
usb sof output enable More...
#define | USBH_DEBUG_ENABLE
usb low power wakeup handler enable More...
#define | USBH_DEBUG(...)
#define | DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */
#define | DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */
#define | DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */
#define | USE_OTG_HOST_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
select otgfs1 or otgfs2 define More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | OTG_PIN_POWER_SWITCH_GPIO GPIOH
#define | OTG_PIN_POWER_SWITCH_CLOCK CRM_GPIOH_PERIPH_CLOCK
#define | OTG_PIN_POWER_SWITCH GPIO_PINS_3
#define | USBH_RX_FIFO_SIZE 128
usb device mode config More...
#define | USBH_NP_TX_FIFO_SIZE 96
#define | USBH_P_TX_FIFO_SIZE 96
#define | USBH2_RX_FIFO_SIZE 128
#define | USBH2_NP_TX_FIFO_SIZE 96
#define | USBH2_P_TX_FIFO_SIZE 96
#define | USBH_5V_POWER_SWITCH
#define | USB_VBUS_IGNORE
usb sof output enable More...
#define | USBH_DEBUG_ENABLE
usb low power wakeup handler enable More...
#define | USBH_DEBUG(...)
#define | DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */
#define | DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */
#define | DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */

Enumerations

enum msc_usr_state {
USR_IDLE , USR_APP , USR_FINISH , USR_IDLE ,
USR_APP , USR_FINISH , USR_IDLE , USR_APP ,
USR_FINISH , USR_IDLE , USR_APP , USR_FINISH
}
enum msc_usr_state {
USR_IDLE , USR_APP , USR_FINISH , USR_IDLE ,
USR_APP , USR_FINISH , USR_IDLE , USR_APP ,
USR_FINISH , USR_IDLE , USR_APP , USR_FINISH
}

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
int | main (void)
main function. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...
DSTATUS | disk_status (BYTE pdrv)
DSTATUS | disk_initialize (BYTE pdrv)
DRESULT | disk_read (BYTE pdrv, BYTE *buff, LBA_t sector, UINT count)
DRESULT | disk_write (BYTE pdrv, const BYTE *buff, LBA_t sector, UINT count)
DRESULT | disk_ioctl (BYTE pdrv, BYTE cmd, void *buff)
DWORD | get_fattime (void)
static usb_sts_type | usbh_user_init (void)
usb host init user handler More...
static usb_sts_type | usbh_user_reset (void)
usb host reset user handler More...
static usb_sts_type | usbh_user_attached (void)
usb host check device attached More...
static usb_sts_type | usbh_user_disconnect (void)
usb host discconet user handler More...
static usb_sts_type | usbh_user_speed (uint8_t speed)
usb host speed user handler More...
static usb_sts_type | usbh_user_mfc_string (void *string)
usb host manufacturer string user handler More...
static usb_sts_type | usbh_user_product_string (void *string)
usb host product string user handler More...
static usb_sts_type | usbh_user_serial_string (void *string)
usb host serial string user handler More...
static usb_sts_type | usbh_user_enumeration_done (void)
usb host enumeration done user handler More...
static usb_sts_type | usbh_user_application (void)
static usb_sts_type | usbh_user_active_vbus (void *uhost, confirm_state state)
usb host active vbus user handler More...
static usb_sts_type | usbh_user_not_support (void)
usb host not support user handler More...

Variables

otg_core_type otg_core_struct
otg_core_type otg_core_struct
usbh_user_handler_type | usbh_user_handle
msc_usr_state usr_state = USR_IDLE
FIL | file
usb host application user handler More...
FATFS | fs
otg_core_type otg_core_struct
otg_core_type otg_core_struct
usbh_user_handler_type | usbh_user_handle
msc_usr_state usr_state = USR_IDLE
FIL | file
usb host application user handler More...
FATFS | fs

Detailed Description

Macro Definition Documentation

◆ DEV_MMC [1/2]

#define DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */

Definition at line 42 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c.

◆ DEV_MMC [2/2]

#define DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */

Definition at line 42 of file at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c.

◆ DEV_RAM [1/2]

#define DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */

Definition at line 41 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c.

◆ DEV_RAM [2/2]

#define DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */

Definition at line 41 of file at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c.

◆ DEV_USB [1/2]

#define DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */

Definition at line 43 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c.

◆ DEV_USB [2/2]

#define DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */

Definition at line 43 of file at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c.

◆ OTG_CLOCK [1/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 68 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_CLOCK [2/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 68 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_IRQ [1/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 69 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_IRQ [2/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 69 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [1/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 70 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [2/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 70 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_DM [1/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 81 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_DM [2/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 81 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [1/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 82 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [2/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 82 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_DP [1/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 78 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_DP [2/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 78 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [1/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 79 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [2/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 79 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_GPIO [1/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 75 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_GPIO [2/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 75 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [1/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 76 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [2/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 76 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_ID [1/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 87 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_ID [2/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 87 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [1/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 88 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [2/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 88 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_MUX [1/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 95 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_MUX [2/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 95 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_POWER_SWITCH [1/2]

#define OTG_PIN_POWER_SWITCH GPIO_PINS_3

Definition at line 99 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_POWER_SWITCH [2/2]

#define OTG_PIN_POWER_SWITCH GPIO_PINS_3

Definition at line 99 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_POWER_SWITCH_CLOCK [1/2]

#define OTG_PIN_POWER_SWITCH_CLOCK CRM_GPIOH_PERIPH_CLOCK

Definition at line 98 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_POWER_SWITCH_CLOCK [2/2]

#define OTG_PIN_POWER_SWITCH_CLOCK CRM_GPIOH_PERIPH_CLOCK

Definition at line 98 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_POWER_SWITCH_GPIO [1/2]

#define OTG_PIN_POWER_SWITCH_GPIO GPIOH

Definition at line 97 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_POWER_SWITCH_GPIO [2/2]

#define OTG_PIN_POWER_SWITCH_GPIO GPIOH

Definition at line 97 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_SOF [1/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 92 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_SOF [2/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 92 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [1/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 90 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [2/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 90 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [1/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 91 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [2/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 91 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [1/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 93 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [2/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 93 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_VBUS [1/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 84 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_VBUS [2/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 84 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [1/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 85 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [2/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 85 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_USB_ID [1/2]

#define OTG_USB_ID 1

select otgfs1 or otgfs2 define

Definition at line 61 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_USB_ID [2/2]

#define OTG_USB_ID 1

select otgfs1 or otgfs2 define

Definition at line 61 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [1/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 73 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [2/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 73 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [1/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 72 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [2/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 72 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [1/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 71 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [2/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 71 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ USB_ID [1/2]

#define USB_ID 0

Definition at line 67 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ USB_ID [2/2]

#define USB_ID 0

Definition at line 67 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [1/2]

#define USB_VBUS_IGNORE

usb sof output enable

usb vbus ignore

Definition at line 208 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [2/2]

#define USB_VBUS_IGNORE

usb sof output enable

usb vbus ignore

Definition at line 208 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ USBH2_NP_TX_FIFO_SIZE [1/2]

#define USBH2_NP_TX_FIFO_SIZE 96

Definition at line 193 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ USBH2_NP_TX_FIFO_SIZE [2/2]

#define USBH2_NP_TX_FIFO_SIZE 96

Definition at line 193 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ USBH2_P_TX_FIFO_SIZE [1/2]

#define USBH2_P_TX_FIFO_SIZE 96

Definition at line 194 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ USBH2_P_TX_FIFO_SIZE [2/2]

#define USBH2_P_TX_FIFO_SIZE 96

Definition at line 194 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ USBH2_RX_FIFO_SIZE [1/2]

#define USBH2_RX_FIFO_SIZE 128

Definition at line 192 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ USBH2_RX_FIFO_SIZE [2/2]

#define USBH2_RX_FIFO_SIZE 128

Definition at line 192 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ USBH_5V_POWER_SWITCH [1/2]

#define USBH_5V_POWER_SWITCH

Definition at line 197 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ USBH_5V_POWER_SWITCH [2/2]

#define USBH_5V_POWER_SWITCH

Definition at line 197 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ USBH_DEBUG [1/2]

#define USBH_DEBUG ( ... )
Value:
printf(__VA_ARGS__);\
printf("\r\n");

Definition at line 218 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ USBH_DEBUG [2/2]

#define USBH_DEBUG ( ... )
Value:
printf(__VA_ARGS__);\
printf("\r\n");

Definition at line 218 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ USBH_DEBUG_ENABLE [1/2]

#define USBH_DEBUG_ENABLE

usb low power wakeup handler enable

Definition at line 215 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ USBH_DEBUG_ENABLE [2/2]

#define USBH_DEBUG_ENABLE

usb low power wakeup handler enable

Definition at line 215 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ USBH_NP_TX_FIFO_SIZE [1/2]

#define USBH_NP_TX_FIFO_SIZE 96

Definition at line 188 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ USBH_NP_TX_FIFO_SIZE [2/2]

#define USBH_NP_TX_FIFO_SIZE 96

Definition at line 188 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ USBH_P_TX_FIFO_SIZE [1/2]

#define USBH_P_TX_FIFO_SIZE 96

Definition at line 189 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ USBH_P_TX_FIFO_SIZE [2/2]

#define USBH_P_TX_FIFO_SIZE 96

Definition at line 189 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ USBH_RX_FIFO_SIZE [1/2]

#define USBH_RX_FIFO_SIZE 128

usb device mode config

usb host mode config

usb host mode fifo

Definition at line 187 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ USBH_RX_FIFO_SIZE [2/2]

#define USBH_RX_FIFO_SIZE 128

usb device mode config

usb host mode config

usb host mode fifo

Definition at line 187 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ USE_OTG_HOST_MODE [1/2]

#define USE_OTG_HOST_MODE

enable usb device mode

enable usb host mode

Definition at line 54 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

◆ USE_OTG_HOST_MODE [2/2]

#define USE_OTG_HOST_MODE

enable usb device mode

enable usb host mode

Definition at line 54 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h.

Enumeration Type Documentation

◆ msc_usr_state [1/2]

enum msc_usr_state
Enumerator
USR_IDLE
USR_APP
USR_FINISH
USR_IDLE
USR_APP
USR_FINISH
USR_IDLE
USR_APP
USR_FINISH
USR_IDLE
USR_APP
USR_FINISH

Definition at line 67 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ msc_usr_state [2/2]

enum msc_usr_state
Enumerator
USR_IDLE
USR_APP
USR_FINISH
USR_IDLE
USR_APP
USR_FINISH
USR_IDLE
USR_APP
USR_FINISH
USR_IDLE
USR_APP
USR_FINISH

Definition at line 67 of file at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 75 of file project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 110 of file project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c.

◆ disk_initialize()

DSTATUS disk_initialize ( BYTE pdrv )

Definition at line 68 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c.

◆ disk_ioctl()

DRESULT disk_ioctl | ( | BYTE | pdrv,
 |  | BYTE | cmd,
 |  | void * | buff
 | ) |  |

Definition at line 131 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c.

◆ disk_read()

DRESULT disk_read | ( | BYTE | pdrv,
 |  | BYTE * | buff,
 |  | LBA_t | sector,
 |  | UINT | count
 | ) |  |

Definition at line 80 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c.

◆ disk_status()

DSTATUS disk_status ( BYTE pdrv )

Definition at line 50 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c.

◆ disk_write()

DRESULT disk_write | ( | BYTE | pdrv,
 |  | const BYTE * | buff,
 |  | LBA_t | sector,
 |  | UINT | count
 | ) |  |

Definition at line 105 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c.

◆ get_fattime()

DWORD get_fattime ( void )

Definition at line 163 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 49 of file project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f435/examples/usb_host/msc_only_fat32/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 62 of file project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 40 of file project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c.

◆ OTG_IRQ_HANDLER()

void OTG_IRQ_HANDLER ( void )

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 273 of file project/at_start_f435/examples/usb_host/msc_only_fat32/src/main.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 119 of file project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 101 of file project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 128 of file project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 88 of file project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

< acc hick trim

Definition at line 98 of file project/at_start_f435/examples/usb_host/msc_only_fat32/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

usb low power wakeup handler enable

Parameters
ms number of millisecond delay
Return values
none

Definition at line 283 of file project/at_start_f435/examples/usb_host/msc_only_fat32/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 294 of file project/at_start_f435/examples/usb_host/msc_only_fat32/src/main.c.

◆ usb_gpio_config()

void usb_gpio_config ( void )

this function config gpio.

Parameters
none
Return values
none

Definition at line 186 of file project/at_start_f435/examples/usb_host/msc_only_fat32/src/main.c.

Referenced by main().

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

◆ usbh_user_active_vbus()

static usb_sts_type usbh_user_active_vbus | ( | void * | uhost,
 |  | confirm_state | state
 | ) |  |
static

usb host active vbus user handler

Parameters
uhost | to the structure of usbh_core_type
state | vbus state TRUE: active vbus FALSE: deactive vbus
Return values
usb_sts_type

Definition at line 278 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ usbh_user_application()

static usb_sts_type usbh_user_application ( void )
static

Definition at line 199 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ usbh_user_attached()

static usb_sts_type usbh_user_attached ( void )
static

usb host check device attached

Parameters
none
Return values
usb_sts_type

Definition at line 105 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ usbh_user_disconnect()

static usb_sts_type usbh_user_disconnect ( void )
static

usb host discconet user handler

Parameters
none
Return values
usb_sts_type

Definition at line 117 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ usbh_user_enumeration_done()

static usb_sts_type usbh_user_enumeration_done ( void )
static

usb host enumeration done user handler

Parameters
none
Return values
usb_sts_type

Definition at line 185 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ usbh_user_init()

static usb_sts_type usbh_user_init ( void )
static

usb host init user handler

Parameters
none
Return values
usb_sts_type

Definition at line 81 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ usbh_user_mfc_string()

static usb_sts_type usbh_user_mfc_string ( void * string )
static

usb host manufacturer string user handler

Parameters
none
Return values
usb_sts_type

Definition at line 149 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ usbh_user_not_support()

static usb_sts_type usbh_user_not_support ( void )
static

usb host not support user handler

Parameters
none
Return values
usb_sts_type

Definition at line 301 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ usbh_user_product_string()

static usb_sts_type usbh_user_product_string ( void * string )
static

usb host product string user handler

Parameters
none
Return values
usb_sts_type

Definition at line 161 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ usbh_user_reset()

static usb_sts_type usbh_user_reset ( void )
static

usb host reset user handler

Parameters
none
Return values
usb_sts_type

Definition at line 93 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ usbh_user_serial_string()

static usb_sts_type usbh_user_serial_string ( void * string )
static

usb host serial string user handler

Parameters
none
Return values
usb_sts_type

Definition at line 173 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ usbh_user_speed()

static usb_sts_type usbh_user_speed ( uint8_t speed )
static

usb host speed user handler

Parameters
none
Return values
usb_sts_type

Definition at line 130 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c.

Variable Documentation

◆ file [1/2]

FIL file

usb host application user handler

Parameters
none
Return values
usb_sts_type

Definition at line 197 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c.

Referenced by usbh_user_application().

◆ file [2/2]

FIL file

usb host application user handler

Parameters
none
Return values
usb_sts_type

Definition at line 197 of file at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c.

Referenced by usbh_user_application().

◆ fs [1/2]

FATFS fs

Definition at line 198 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c.

Referenced by usbh_user_application().

◆ fs [2/2]

FATFS fs

Definition at line 198 of file at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c.

Referenced by usbh_user_application().

◆ otg_core_struct [1/4]

otg_core_type otg_core_struct

Definition at line 45 of file project/at_start_f435/examples/usb_host/msc_only_fat32/src/main.c.

Referenced by main(), and OTG_IRQ_HANDLER().

◆ otg_core_struct [2/4]

otg_core_type otg_core_struct
extern

Definition at line 45 of file project/at_start_f435/examples/acc/calibration/src/main.c.

Referenced by disk_ioctl(), disk_read(), disk_status(), and disk_write().

◆ otg_core_struct [3/4]

otg_core_type otg_core_struct

Definition at line 45 of file project/at_start_f437/examples/usb_host/msc_only_fat32/src/main.c.

◆ otg_core_struct [4/4]

otg_core_type otg_core_struct
extern

Definition at line 45 of file project/at_start_f435/examples/acc/calibration/src/main.c.

◆ usbh_user_handle [1/2]

usbh_user_handler_type usbh_user_handle
Initial value:
=
{
usbh_user_init,
usbh_user_reset,
usbh_user_attached,
usbh_user_disconnect,
usbh_user_speed,
usbh_user_mfc_string,
usbh_user_product_string,
usbh_user_serial_string,
usbh_user_enumeration_done,
usbh_user_application,
usbh_user_active_vbus,
usbh_user_not_support,
}
usbh_user_init
static usb_sts_type usbh_user_init(void)
usb host init user handler
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:81
usbh_user_disconnect
static usb_sts_type usbh_user_disconnect(void)
usb host discconet user handler
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:117
usbh_user_not_support
static usb_sts_type usbh_user_not_support(void)
usb host not support user handler
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:301
usbh_user_application
static usb_sts_type usbh_user_application(void)
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:199
usbh_user_speed
static usb_sts_type usbh_user_speed(uint8_t speed)
usb host speed user handler
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:130
usbh_user_active_vbus
static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state)
usb host active vbus user handler
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:278
usbh_user_serial_string
static usb_sts_type usbh_user_serial_string(void *string)
usb host serial string user handler
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:173
usbh_user_reset
static usb_sts_type usbh_user_reset(void)
usb host reset user handler
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:93
usbh_user_mfc_string
static usb_sts_type usbh_user_mfc_string(void *string)
usb host manufacturer string user handler
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:149
usbh_user_enumeration_done
static usb_sts_type usbh_user_enumeration_done(void)
usb host enumeration done user handler
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:185
usbh_user_attached
static usb_sts_type usbh_user_attached(void)
usb host check device attached
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:105
usbh_user_product_string
static usb_sts_type usbh_user_product_string(void *string)
usb host product string user handler
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:161

Definition at line 51 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ usbh_user_handle [2/2]

usbh_user_handler_type usbh_user_handle
Initial value:
=
{
usbh_user_init,
usbh_user_reset,
usbh_user_attached,
usbh_user_disconnect,
usbh_user_speed,
usbh_user_mfc_string,
usbh_user_product_string,
usbh_user_serial_string,
usbh_user_enumeration_done,
usbh_user_application,
usbh_user_active_vbus,
usbh_user_not_support,
}
usbh_user_init
static usb_sts_type usbh_user_init(void)
usb host init user handler
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:81
usbh_user_disconnect
static usb_sts_type usbh_user_disconnect(void)
usb host discconet user handler
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:117
usbh_user_not_support
static usb_sts_type usbh_user_not_support(void)
usb host not support user handler
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:301
usbh_user_application
static usb_sts_type usbh_user_application(void)
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:199
usbh_user_speed
static usb_sts_type usbh_user_speed(uint8_t speed)
usb host speed user handler
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:130
usbh_user_active_vbus
static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state)
usb host active vbus user handler
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:278
usbh_user_serial_string
static usb_sts_type usbh_user_serial_string(void *string)
usb host serial string user handler
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:173
usbh_user_reset
static usb_sts_type usbh_user_reset(void)
usb host reset user handler
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:93
usbh_user_mfc_string
static usb_sts_type usbh_user_mfc_string(void *string)
usb host manufacturer string user handler
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:149
usbh_user_enumeration_done
static usb_sts_type usbh_user_enumeration_done(void)
usb host enumeration done user handler
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:185
usbh_user_attached
static usb_sts_type usbh_user_attached(void)
usb host check device attached
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:105
usbh_user_product_string
static usb_sts_type usbh_user_product_string(void *string)
usb host product string user handler
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:161

Definition at line 51 of file at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ usr_state [1/2]

msc_usr_state usr_state = USR_IDLE

Definition at line 74 of file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c.

Referenced by usbh_user_application(), and usbh_user_disconnect().

◆ usr_state [2/2]

msc_usr_state usr_state = USR_IDLE

Definition at line 74 of file at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c.

Referenced by usbh_user_application(), and usbh_user_disconnect().


AT32F435/437 Firmwary Library: USB_host_two_otg_host_demo

Macros | Enumerations | Functions | Variables
USB_host_two_otg_host_demo
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | USE_OTG_HOST_MODE
enable usb device mode More...
#define | USB_ID 0
select otgfs1 or otgfs2 define More...
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | OTG_PIN_POWER_SWITCH_GPIO GPIOH
#define | OTG_PIN_POWER_SWITCH_CLOCK CRM_GPIOH_PERIPH_CLOCK
#define | OTG_PIN_POWER_SWITCH GPIO_PINS_3
#define | USB2_ID 1
#define | OTG2_CLOCK CRM_OTGFS2_PERIPH_CLOCK
#define | OTG2_IRQ OTGFS2_IRQn
#define | OTG2_IRQ_HANDLER OTGFS2_IRQHandler
#define | OTG2_WKUP_IRQ OTGFS2_WKUP_IRQn
#define | OTG2_WKUP_HANDLER OTGFS2_WKUP_IRQHandler
#define | OTG2_WKUP_EXINT_LINE EXINT_LINE_20
#define | OTG2_PIN_GPIO GPIOB
#define | OTG2_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK
#define | OTG2_PIN_DP GPIO_PINS_15
#define | OTG2_PIN_DP_SOURCE GPIO_PINS_SOURCE15
#define | OTG2_PIN_DM GPIO_PINS_14
#define | OTG2_PIN_DM_SOURCE GPIO_PINS_SOURCE14
#define | OTG2_PIN_VBUS GPIO_PINS_13
#define | OTG2_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13
#define | OTG2_PIN_ID GPIO_PINS_12
#define | OTG2_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG2_PIN_SOF_GPIO GPIOA
#define | OTG2_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG2_PIN_SOF GPIO_PINS_4
#define | OTG2_PIN_SOF_SOURCE GPIO_PINS_SOURCE4
#define | OTG2_PIN_MUX GPIO_MUX_12
#define | OTG2_PIN_POWER_SWITCH_GPIO GPIOB
#define | OTG2_PIN_POWER_SWITCH_CLOCK CRM_GPIOB_PERIPH_CLOCK
#define | OTG2_PIN_POWER_SWITCH GPIO_PINS_10
#define | USBH_RX_FIFO_SIZE 128
usb device mode config More...
#define | USBH_NP_TX_FIFO_SIZE 96
#define | USBH_P_TX_FIFO_SIZE 96
#define | USBH2_RX_FIFO_SIZE 128
#define | USBH2_NP_TX_FIFO_SIZE 96
#define | USBH2_P_TX_FIFO_SIZE 96
#define | USBH_5V_POWER_SWITCH
#define | USB_VBUS_IGNORE
usb sof output enable More...
#define | USBH_DEBUG_ENABLE
usb low power wakeup handler enable More...
#define | USBH_DEBUG(...)
#define | DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */
#define | DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */
#define | DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */
#define | USE_OTG_HOST_MODE
enable usb device mode More...
#define | USB_ID 0
select otgfs1 or otgfs2 define More...
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | OTG_PIN_POWER_SWITCH_GPIO GPIOH
#define | OTG_PIN_POWER_SWITCH_CLOCK CRM_GPIOH_PERIPH_CLOCK
#define | OTG_PIN_POWER_SWITCH GPIO_PINS_3
#define | USB2_ID 1
#define | OTG2_CLOCK CRM_OTGFS2_PERIPH_CLOCK
#define | OTG2_IRQ OTGFS2_IRQn
#define | OTG2_IRQ_HANDLER OTGFS2_IRQHandler
#define | OTG2_WKUP_IRQ OTGFS2_WKUP_IRQn
#define | OTG2_WKUP_HANDLER OTGFS2_WKUP_IRQHandler
#define | OTG2_WKUP_EXINT_LINE EXINT_LINE_20
#define | OTG2_PIN_GPIO GPIOB
#define | OTG2_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK
#define | OTG2_PIN_DP GPIO_PINS_15
#define | OTG2_PIN_DP_SOURCE GPIO_PINS_SOURCE15
#define | OTG2_PIN_DM GPIO_PINS_14
#define | OTG2_PIN_DM_SOURCE GPIO_PINS_SOURCE14
#define | OTG2_PIN_VBUS GPIO_PINS_13
#define | OTG2_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13
#define | OTG2_PIN_ID GPIO_PINS_12
#define | OTG2_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG2_PIN_SOF_GPIO GPIOA
#define | OTG2_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG2_PIN_SOF GPIO_PINS_4
#define | OTG2_PIN_SOF_SOURCE GPIO_PINS_SOURCE4
#define | OTG2_PIN_MUX GPIO_MUX_12
#define | OTG2_PIN_POWER_SWITCH_GPIO GPIOB
#define | OTG2_PIN_POWER_SWITCH_CLOCK CRM_GPIOB_PERIPH_CLOCK
#define | OTG2_PIN_POWER_SWITCH GPIO_PINS_10
#define | USBH_RX_FIFO_SIZE 128
usb device mode config More...
#define | USBH_NP_TX_FIFO_SIZE 96
#define | USBH_P_TX_FIFO_SIZE 96
#define | USBH2_RX_FIFO_SIZE 128
#define | USBH2_NP_TX_FIFO_SIZE 96
#define | USBH2_P_TX_FIFO_SIZE 96
#define | USBH_5V_POWER_SWITCH
#define | USB_VBUS_IGNORE
usb sof output enable More...
#define | USBH_DEBUG_ENABLE
usb low power wakeup handler enable More...
#define | USBH_DEBUG(...)
#define | DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */
#define | DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */
#define | DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */

Enumerations

enum msc_usr_state {
USR_IDLE , USR_APP , USR_FINISH , USR_IDLE ,
USR_APP , USR_FINISH , USR_IDLE , USR_APP ,
USR_FINISH , USR_IDLE , USR_APP , USR_FINISH
}
enum msc_usr_state {
USR_IDLE , USR_APP , USR_FINISH , USR_IDLE ,
USR_APP , USR_FINISH , USR_IDLE , USR_APP ,
USR_FINISH , USR_IDLE , USR_APP , USR_FINISH
}

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
int | main (void)
main function. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...
void | OTG2_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...
DSTATUS | disk_status (BYTE pdrv)
DSTATUS | disk_initialize (BYTE pdrv)
DRESULT | disk_read (BYTE pdrv, BYTE *buff, LBA_t sector, UINT count)
DRESULT | disk_write (BYTE pdrv, const BYTE *buff, LBA_t sector, UINT count)
DRESULT | disk_ioctl (BYTE pdrv, BYTE cmd, void *buff)
DWORD | get_fattime (void)
static usb_sts_type | usbh_user_init (void)
usb host init user handler More...
static usb_sts_type | usbh_user_reset (void)
usb host reset user handler More...
static usb_sts_type | usbh_user_attached (void)
usb host check device attached More...
static usb_sts_type | usbh_user_disconnect (void)
usb host discconet user handler More...
static usb_sts_type | usbh_user_speed (uint8_t speed)
usb host speed user handler More...
static usb_sts_type | usbh_user_mfc_string (void *string)
usb host manufacturer string user handler More...
static usb_sts_type | usbh_user_product_string (void *string)
usb host product string user handler More...
static usb_sts_type | usbh_user_serial_string (void *string)
usb host serial string user handler More...
static usb_sts_type | usbh_user_enumeration_done (void)
usb host enumeration done user handler More...
static usb_sts_type | usbh_user_application (void)
static usb_sts_type | usbh_user_active_vbus (void *uhost, confirm_state state)
usb host active vbus user handler More...
static usb_sts_type | usbh_user_not_support (void)
usb host not support user handler More...

Variables

otg_core_type otg_core_struct
otg_core_type otg2_core_struct
otg_core_type otg_core_struct
usbh_user_handler_type | usbh_user_handle
msc_usr_state usr_state = USR_IDLE
FIL | file
usb host application user handler More...
FATFS | fs
otg_core_type otg_core_struct
otg_core_type otg2_core_struct
otg_core_type otg_core_struct
usbh_user_handler_type | usbh_user_handle
msc_usr_state usr_state = USR_IDLE
FIL | file
usb host application user handler More...
FATFS | fs

Detailed Description

Macro Definition Documentation

◆ DEV_MMC [1/2]

#define DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */

Definition at line 42 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c.

◆ DEV_MMC [2/2]

#define DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */

Definition at line 42 of file at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c.

◆ DEV_RAM [1/2]

#define DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */

Definition at line 41 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c.

◆ DEV_RAM [2/2]

#define DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */

Definition at line 41 of file at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c.

◆ DEV_USB [1/2]

#define DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */

Definition at line 43 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c.

◆ DEV_USB [2/2]

#define DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */

Definition at line 43 of file at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c.

◆ OTG2_CLOCK [1/2]

#define OTG2_CLOCK CRM_OTGFS2_PERIPH_CLOCK

Definition at line 97 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_CLOCK [2/2]

#define OTG2_CLOCK CRM_OTGFS2_PERIPH_CLOCK

Definition at line 97 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_IRQ [1/2]

#define OTG2_IRQ OTGFS2_IRQn

Definition at line 98 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_IRQ [2/2]

#define OTG2_IRQ OTGFS2_IRQn

Definition at line 98 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_IRQ_HANDLER [1/2]

#define OTG2_IRQ_HANDLER ( void ) OTGFS2_IRQHandler

Definition at line 99 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_IRQ_HANDLER [2/2]

#define OTG2_IRQ_HANDLER ( void ) OTGFS2_IRQHandler

Definition at line 99 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_DM [1/2]

#define OTG2_PIN_DM GPIO_PINS_14

Definition at line 110 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_DM [2/2]

#define OTG2_PIN_DM GPIO_PINS_14

Definition at line 110 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_DM_SOURCE [1/2]

#define OTG2_PIN_DM_SOURCE GPIO_PINS_SOURCE14

Definition at line 111 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_DM_SOURCE [2/2]

#define OTG2_PIN_DM_SOURCE GPIO_PINS_SOURCE14

Definition at line 111 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_DP [1/2]

#define OTG2_PIN_DP GPIO_PINS_15

Definition at line 107 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_DP [2/2]

#define OTG2_PIN_DP GPIO_PINS_15

Definition at line 107 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_DP_SOURCE [1/2]

#define OTG2_PIN_DP_SOURCE GPIO_PINS_SOURCE15

Definition at line 108 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_DP_SOURCE [2/2]

#define OTG2_PIN_DP_SOURCE GPIO_PINS_SOURCE15

Definition at line 108 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_GPIO [1/2]

#define OTG2_PIN_GPIO GPIOB

Definition at line 104 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_GPIO [2/2]

#define OTG2_PIN_GPIO GPIOB

Definition at line 104 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_GPIO_CLOCK [1/2]

#define OTG2_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK

Definition at line 105 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_GPIO_CLOCK [2/2]

#define OTG2_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK

Definition at line 105 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_ID [1/2]

#define OTG2_PIN_ID GPIO_PINS_12

Definition at line 116 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_ID [2/2]

#define OTG2_PIN_ID GPIO_PINS_12

Definition at line 116 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_ID_SOURCE [1/2]

#define OTG2_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 117 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_ID_SOURCE [2/2]

#define OTG2_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 117 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_MUX [1/2]

#define OTG2_PIN_MUX GPIO_MUX_12

Definition at line 124 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_MUX [2/2]

#define OTG2_PIN_MUX GPIO_MUX_12

Definition at line 124 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_POWER_SWITCH [1/2]

#define OTG2_PIN_POWER_SWITCH GPIO_PINS_10

Definition at line 129 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_POWER_SWITCH [2/2]

#define OTG2_PIN_POWER_SWITCH GPIO_PINS_10

Definition at line 129 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_POWER_SWITCH_CLOCK [1/2]

#define OTG2_PIN_POWER_SWITCH_CLOCK CRM_GPIOB_PERIPH_CLOCK

Definition at line 128 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_POWER_SWITCH_CLOCK [2/2]

#define OTG2_PIN_POWER_SWITCH_CLOCK CRM_GPIOB_PERIPH_CLOCK

Definition at line 128 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_POWER_SWITCH_GPIO [1/2]

#define OTG2_PIN_POWER_SWITCH_GPIO GPIOB

Definition at line 127 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_POWER_SWITCH_GPIO [2/2]

#define OTG2_PIN_POWER_SWITCH_GPIO GPIOB

Definition at line 127 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_SOF [1/2]

#define OTG2_PIN_SOF GPIO_PINS_4

Definition at line 121 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_SOF [2/2]

#define OTG2_PIN_SOF GPIO_PINS_4

Definition at line 121 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_SOF_GPIO [1/2]

#define OTG2_PIN_SOF_GPIO GPIOA

Definition at line 119 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_SOF_GPIO [2/2]

#define OTG2_PIN_SOF_GPIO GPIOA

Definition at line 119 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_SOF_GPIO_CLOCK [1/2]

#define OTG2_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 120 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_SOF_GPIO_CLOCK [2/2]

#define OTG2_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 120 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_SOF_SOURCE [1/2]

#define OTG2_PIN_SOF_SOURCE GPIO_PINS_SOURCE4

Definition at line 122 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_SOF_SOURCE [2/2]

#define OTG2_PIN_SOF_SOURCE GPIO_PINS_SOURCE4

Definition at line 122 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_VBUS [1/2]

#define OTG2_PIN_VBUS GPIO_PINS_13

Definition at line 113 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_VBUS [2/2]

#define OTG2_PIN_VBUS GPIO_PINS_13

Definition at line 113 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_VBUS_SOURCE [1/2]

#define OTG2_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13

Definition at line 114 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_PIN_VBUS_SOURCE [2/2]

#define OTG2_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13

Definition at line 114 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_WKUP_EXINT_LINE [1/2]

#define OTG2_WKUP_EXINT_LINE EXINT_LINE_20

Definition at line 102 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_WKUP_EXINT_LINE [2/2]

#define OTG2_WKUP_EXINT_LINE EXINT_LINE_20

Definition at line 102 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_WKUP_HANDLER [1/2]

#define OTG2_WKUP_HANDLER OTGFS2_WKUP_IRQHandler

Definition at line 101 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_WKUP_HANDLER [2/2]

#define OTG2_WKUP_HANDLER OTGFS2_WKUP_IRQHandler

Definition at line 101 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_WKUP_IRQ [1/2]

#define OTG2_WKUP_IRQ OTGFS2_WKUP_IRQn

Definition at line 100 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG2_WKUP_IRQ [2/2]

#define OTG2_WKUP_IRQ OTGFS2_WKUP_IRQn

Definition at line 100 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_CLOCK [1/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 62 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_CLOCK [2/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 62 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_IRQ [1/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 63 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_IRQ [2/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 63 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [1/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 64 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [2/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 64 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_DM [1/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 75 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_DM [2/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 75 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [1/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 76 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [2/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 76 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_DP [1/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 72 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_DP [2/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 72 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [1/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 73 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [2/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 73 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_GPIO [1/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 69 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_GPIO [2/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 69 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [1/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 70 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [2/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 70 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_ID [1/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 81 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_ID [2/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 81 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [1/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 82 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [2/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 82 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_MUX [1/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 89 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_MUX [2/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 89 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_POWER_SWITCH [1/2]

#define OTG_PIN_POWER_SWITCH GPIO_PINS_3

Definition at line 93 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_POWER_SWITCH [2/2]

#define OTG_PIN_POWER_SWITCH GPIO_PINS_3

Definition at line 93 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_POWER_SWITCH_CLOCK [1/2]

#define OTG_PIN_POWER_SWITCH_CLOCK CRM_GPIOH_PERIPH_CLOCK

Definition at line 92 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_POWER_SWITCH_CLOCK [2/2]

#define OTG_PIN_POWER_SWITCH_CLOCK CRM_GPIOH_PERIPH_CLOCK

Definition at line 92 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_POWER_SWITCH_GPIO [1/2]

#define OTG_PIN_POWER_SWITCH_GPIO GPIOH

Definition at line 91 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_POWER_SWITCH_GPIO [2/2]

#define OTG_PIN_POWER_SWITCH_GPIO GPIOH

Definition at line 91 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF [1/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 86 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF [2/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 86 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [1/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 84 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [2/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 84 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [1/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 85 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [2/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 85 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [1/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 87 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [2/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 87 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_VBUS [1/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 78 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_VBUS [2/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 78 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [1/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 79 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [2/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 79 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [1/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 67 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [2/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 67 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [1/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 66 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [2/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 66 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [1/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 65 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [2/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 65 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USB2_ID [1/2]

#define USB2_ID 1

Definition at line 96 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USB2_ID [2/2]

#define USB2_ID 1

Definition at line 96 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USB_ID [1/2]

#define USB_ID 0

select otgfs1 or otgfs2 define

Definition at line 61 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USB_ID [2/2]

#define USB_ID 0

select otgfs1 or otgfs2 define

Definition at line 61 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [1/2]

#define USB_VBUS_IGNORE

usb sof output enable

usb vbus ignore

Definition at line 202 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [2/2]

#define USB_VBUS_IGNORE

usb sof output enable

usb vbus ignore

Definition at line 202 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USBH2_NP_TX_FIFO_SIZE [1/2]

#define USBH2_NP_TX_FIFO_SIZE 96

Definition at line 187 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USBH2_NP_TX_FIFO_SIZE [2/2]

#define USBH2_NP_TX_FIFO_SIZE 96

Definition at line 187 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USBH2_P_TX_FIFO_SIZE [1/2]

#define USBH2_P_TX_FIFO_SIZE 96

Definition at line 188 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USBH2_P_TX_FIFO_SIZE [2/2]

#define USBH2_P_TX_FIFO_SIZE 96

Definition at line 188 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USBH2_RX_FIFO_SIZE [1/2]

#define USBH2_RX_FIFO_SIZE 128

Definition at line 186 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USBH2_RX_FIFO_SIZE [2/2]

#define USBH2_RX_FIFO_SIZE 128

Definition at line 186 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USBH_5V_POWER_SWITCH [1/2]

#define USBH_5V_POWER_SWITCH

Definition at line 191 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USBH_5V_POWER_SWITCH [2/2]

#define USBH_5V_POWER_SWITCH

Definition at line 191 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USBH_DEBUG [1/2]

#define USBH_DEBUG ( ... )
Value:
printf(__VA_ARGS__);\
printf("\r\n");

Definition at line 212 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USBH_DEBUG [2/2]

#define USBH_DEBUG ( ... )
Value:
printf(__VA_ARGS__);\
printf("\r\n");

Definition at line 212 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USBH_DEBUG_ENABLE [1/2]

#define USBH_DEBUG_ENABLE

usb low power wakeup handler enable

Definition at line 209 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USBH_DEBUG_ENABLE [2/2]

#define USBH_DEBUG_ENABLE

usb low power wakeup handler enable

Definition at line 209 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USBH_NP_TX_FIFO_SIZE [1/2]

#define USBH_NP_TX_FIFO_SIZE 96

Definition at line 182 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USBH_NP_TX_FIFO_SIZE [2/2]

#define USBH_NP_TX_FIFO_SIZE 96

Definition at line 182 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USBH_P_TX_FIFO_SIZE [1/2]

#define USBH_P_TX_FIFO_SIZE 96

Definition at line 183 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USBH_P_TX_FIFO_SIZE [2/2]

#define USBH_P_TX_FIFO_SIZE 96

Definition at line 183 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USBH_RX_FIFO_SIZE [1/2]

#define USBH_RX_FIFO_SIZE 128

usb device mode config

usb host mode config

usb host mode fifo

Definition at line 181 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USBH_RX_FIFO_SIZE [2/2]

#define USBH_RX_FIFO_SIZE 128

usb device mode config

usb host mode config

usb host mode fifo

Definition at line 181 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USE_OTG_HOST_MODE [1/2]

#define USE_OTG_HOST_MODE

enable usb device mode

enable usb host mode

Definition at line 54 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

◆ USE_OTG_HOST_MODE [2/2]

#define USE_OTG_HOST_MODE

enable usb device mode

enable usb host mode

Definition at line 54 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.

Enumeration Type Documentation

◆ msc_usr_state [1/2]

enum msc_usr_state
Enumerator
USR_IDLE
USR_APP
USR_FINISH
USR_IDLE
USR_APP
USR_FINISH
USR_IDLE
USR_APP
USR_FINISH
USR_IDLE
USR_APP
USR_FINISH

Definition at line 67 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ msc_usr_state [2/2]

enum msc_usr_state
Enumerator
USR_IDLE
USR_APP
USR_FINISH
USR_IDLE
USR_APP
USR_FINISH
USR_IDLE
USR_APP
USR_FINISH
USR_IDLE
USR_APP
USR_FINISH

Definition at line 67 of file at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 75 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 110 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c.

◆ disk_initialize()

DSTATUS disk_initialize ( BYTE pdrv )

Definition at line 68 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c.

◆ disk_ioctl()

DRESULT disk_ioctl | ( | BYTE | pdrv,
 |  | BYTE | cmd,
 |  | void * | buff
 | ) |  |

Definition at line 131 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c.

◆ disk_read()

DRESULT disk_read | ( | BYTE | pdrv,
 |  | BYTE * | buff,
 |  | LBA_t | sector,
 |  | UINT | count
 | ) |  |

Definition at line 80 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c.

◆ disk_status()

DSTATUS disk_status ( BYTE pdrv )

Definition at line 50 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c.

◆ disk_write()

DRESULT disk_write | ( | BYTE | pdrv,
 |  | const BYTE * | buff,
 |  | LBA_t | sector,
 |  | UINT | count
 | ) |  |

Definition at line 105 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c.

◆ get_fattime()

DWORD get_fattime ( void )

Definition at line 163 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 49 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 57 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 62 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 40 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c.

◆ OTG2_IRQ_HANDLER()

void OTG2_IRQ_HANDLER ( void )

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 356 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c.

◆ OTG_IRQ_HANDLER()

void OTG_IRQ_HANDLER ( void )

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 346 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 119 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 101 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 128 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 88 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

< acc hick trim

Definition at line 109 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

usb low power wakeup handler enable

Parameters
ms number of millisecond delay
Return values
none

Definition at line 366 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 377 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c.

◆ usb_gpio_config()

void usb_gpio_config ( void )

this function config gpio.

Parameters
none
Return values
none

Definition at line 197 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c.

Referenced by main().

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

◆ usbh_user_active_vbus()

static usb_sts_type usbh_user_active_vbus | ( | void * | uhost,
 |  | confirm_state | state
 | ) |  |
static

usb host active vbus user handler

Parameters
uhost | to the structure of usbh_core_type
state | vbus state TRUE: active vbus FALSE: deactive vbus
Return values
usb_sts_type

Definition at line 278 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ usbh_user_application()

static usb_sts_type usbh_user_application ( void )
static

Definition at line 199 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ usbh_user_attached()

static usb_sts_type usbh_user_attached ( void )
static

usb host check device attached

Parameters
none
Return values
usb_sts_type

Definition at line 105 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ usbh_user_disconnect()

static usb_sts_type usbh_user_disconnect ( void )
static

usb host discconet user handler

Parameters
none
Return values
usb_sts_type

Definition at line 117 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ usbh_user_enumeration_done()

static usb_sts_type usbh_user_enumeration_done ( void )
static

usb host enumeration done user handler

Parameters
none
Return values
usb_sts_type

Definition at line 185 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ usbh_user_init()

static usb_sts_type usbh_user_init ( void )
static

usb host init user handler

Parameters
none
Return values
usb_sts_type

Definition at line 81 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ usbh_user_mfc_string()

static usb_sts_type usbh_user_mfc_string ( void * string )
static

usb host manufacturer string user handler

Parameters
none
Return values
usb_sts_type

Definition at line 149 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ usbh_user_not_support()

static usb_sts_type usbh_user_not_support ( void )
static

usb host not support user handler

Parameters
none
Return values
usb_sts_type

Definition at line 316 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ usbh_user_product_string()

static usb_sts_type usbh_user_product_string ( void * string )
static

usb host product string user handler

Parameters
none
Return values
usb_sts_type

Definition at line 161 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ usbh_user_reset()

static usb_sts_type usbh_user_reset ( void )
static

usb host reset user handler

Parameters
none
Return values
usb_sts_type

Definition at line 93 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ usbh_user_serial_string()

static usb_sts_type usbh_user_serial_string ( void * string )
static

usb host serial string user handler

Parameters
none
Return values
usb_sts_type

Definition at line 173 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ usbh_user_speed()

static usb_sts_type usbh_user_speed ( uint8_t speed )
static

usb host speed user handler

Parameters
none
Return values
usb_sts_type

Definition at line 130 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

Variable Documentation

◆ file [1/2]

FIL file

usb host application user handler

Parameters
none
Return values
usb_sts_type

Definition at line 197 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

Referenced by usbh_user_application().

◆ file [2/2]

FIL file

usb host application user handler

Parameters
none
Return values
usb_sts_type

Definition at line 197 of file at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

Referenced by usbh_user_application().

◆ fs [1/2]

FATFS fs

Definition at line 198 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

Referenced by usbh_user_application().

◆ fs [2/2]

FATFS fs

Definition at line 198 of file at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

Referenced by usbh_user_application().

◆ otg2_core_struct [1/2]

otg_core_type otg2_core_struct

Definition at line 47 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c.

Referenced by main(), and OTG2_IRQ_HANDLER().

◆ otg2_core_struct [2/2]

otg_core_type otg2_core_struct

Definition at line 47 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/src/main.c.

◆ otg_core_struct [1/4]

otg_core_type otg_core_struct

Definition at line 46 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c.

Referenced by main(), and OTG_IRQ_HANDLER().

◆ otg_core_struct [2/4]

otg_core_type otg_core_struct
extern

Definition at line 45 of file project/at_start_f435/examples/acc/calibration/src/main.c.

Referenced by disk_ioctl(), disk_read(), disk_status(), and disk_write().

◆ otg_core_struct [3/4]

otg_core_type otg_core_struct

Definition at line 46 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/src/main.c.

◆ otg_core_struct [4/4]

otg_core_type otg_core_struct
extern

Definition at line 45 of file project/at_start_f435/examples/acc/calibration/src/main.c.

Referenced by EXINT0_IRQHandler(), keyboard_send_string(), main(), OTG_IRQ_HANDLER(), and usb_reset().

◆ usbh_user_handle [1/2]

usbh_user_handler_type usbh_user_handle
Initial value:
=
{
usbh_user_init,
usbh_user_reset,
usbh_user_attached,
usbh_user_disconnect,
usbh_user_speed,
usbh_user_mfc_string,
usbh_user_product_string,
usbh_user_serial_string,
usbh_user_enumeration_done,
usbh_user_application,
usbh_user_active_vbus,
usbh_user_not_support,
}
usbh_user_init
static usb_sts_type usbh_user_init(void)
usb host init user handler
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:81
usbh_user_disconnect
static usb_sts_type usbh_user_disconnect(void)
usb host discconet user handler
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:117
usbh_user_not_support
static usb_sts_type usbh_user_not_support(void)
usb host not support user handler
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:316
usbh_user_application
static usb_sts_type usbh_user_application(void)
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:199
usbh_user_speed
static usb_sts_type usbh_user_speed(uint8_t speed)
usb host speed user handler
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:130
usbh_user_active_vbus
static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state)
usb host active vbus user handler
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:278
usbh_user_serial_string
static usb_sts_type usbh_user_serial_string(void *string)
usb host serial string user handler
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:173
usbh_user_reset
static usb_sts_type usbh_user_reset(void)
usb host reset user handler
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:93
usbh_user_mfc_string
static usb_sts_type usbh_user_mfc_string(void *string)
usb host manufacturer string user handler
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:149
usbh_user_enumeration_done
static usb_sts_type usbh_user_enumeration_done(void)
usb host enumeration done user handler
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:185
usbh_user_attached
static usb_sts_type usbh_user_attached(void)
usb host check device attached
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:105
usbh_user_product_string
static usb_sts_type usbh_user_product_string(void *string)
usb host product string user handler
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:161

Definition at line 51 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ usbh_user_handle [2/2]

usbh_user_handler_type usbh_user_handle
Initial value:
=
{
usbh_user_init,
usbh_user_reset,
usbh_user_attached,
usbh_user_disconnect,
usbh_user_speed,
usbh_user_mfc_string,
usbh_user_product_string,
usbh_user_serial_string,
usbh_user_enumeration_done,
usbh_user_application,
usbh_user_active_vbus,
usbh_user_not_support,
}
usbh_user_init
static usb_sts_type usbh_user_init(void)
usb host init user handler
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:81
usbh_user_disconnect
static usb_sts_type usbh_user_disconnect(void)
usb host discconet user handler
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:117
usbh_user_not_support
static usb_sts_type usbh_user_not_support(void)
usb host not support user handler
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:316
usbh_user_application
static usb_sts_type usbh_user_application(void)
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:199
usbh_user_speed
static usb_sts_type usbh_user_speed(uint8_t speed)
usb host speed user handler
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:130
usbh_user_active_vbus
static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state)
usb host active vbus user handler
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:278
usbh_user_serial_string
static usb_sts_type usbh_user_serial_string(void *string)
usb host serial string user handler
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:173
usbh_user_reset
static usb_sts_type usbh_user_reset(void)
usb host reset user handler
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:93
usbh_user_mfc_string
static usb_sts_type usbh_user_mfc_string(void *string)
usb host manufacturer string user handler
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:149
usbh_user_enumeration_done
static usb_sts_type usbh_user_enumeration_done(void)
usb host enumeration done user handler
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:185
usbh_user_attached
static usb_sts_type usbh_user_attached(void)
usb host check device attached
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:105
usbh_user_product_string
static usb_sts_type usbh_user_product_string(void *string)
usb host product string user handler
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:161

Definition at line 51 of file at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ usr_state [1/2]

msc_usr_state usr_state = USR_IDLE

Definition at line 74 of file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

Referenced by usbh_user_application(), and usbh_user_disconnect().

◆ usr_state [2/2]

msc_usr_state usr_state = USR_IDLE

Definition at line 74 of file at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

Referenced by usbh_user_application(), and usbh_user_disconnect().


AT32F435/437 Firmwary Library: WDT_wdt_reset

Functions
WDT_wdt_reset
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< watchdog timer reset flag

< watchdog timer reset flag

< watchdog timer reset flag

< watchdog timer reset flag

Definition at line 43 of file project/at_start_f435/examples/wdt/wdt_reset/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: WDT_WDT_standby

Functions
WDT_WDT_standby
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< watchdog timer reset flag

< watchdog timer reset flag

< watchdog timer reset flag

< watchdog timer reset flag

Definition at line 43 of file project/at_start_f435/examples/wdt/wdt_standby/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: WWDT_wwdt_reset

Functions
WWDT_wwdt_reset
AT32F435_periph_examples | AT32F437_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< window watchdog timer reset flag

< window watchdog timer reset flag

< window watchdog timer reset flag

< window watchdog timer reset flag

Definition at line 43 of file project/at_start_f435/examples/wwdt/wwdt_reset/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: XMC_lcd_8bit

Modules | Macros | Functions | Variables
XMC_lcd_8bit
AT32F435_periph_examples | AT32F437_periph_examples

Modules

ADDRESS_of_data_and_command
LCD_reset_line
XMC_lcd_exported_functions

Macros

#define | WHITE 0xFFFF
#define | BLACK 0x0000
#define | BLUE 0x001F
#define | BRED 0xF81F
#define | GRED 0xFFE0
#define | GBLUE 0x07FF
#define | RED 0xF800
#define | MAGENTA 0xF81F
#define | GREEN 0x07E0
#define | CYAN 0x7FFF
#define | YELLOW 0xFFE0
#define | BROWN 0xBC40
#define | BRRED 0xFC07
#define | GRAY 0x8430
#define | WHITE 0xFFFF
#define | BLACK 0x0000
#define | BLUE 0x001F
#define | BRED 0xF81F
#define | GRED 0xFFE0
#define | GBLUE 0x07FF
#define | RED 0xF800
#define | MAGENTA 0xF81F
#define | GREEN 0x07E0
#define | CYAN 0x7FFF
#define | YELLOW 0xFFE0
#define | BROWN 0xBC40
#define | BRRED 0xFC07
#define | GRAY 0x8430

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...
void | xmc_init (void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_init (void)
configures the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_wr_command (uint8_t command)
this function is write command to lcd. More...
void | lcd_wr_data (uint8_t data)
this function is write data to lcd. More...
void | lcd_setblock (uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd. More...
void | lcd_writeonepoint (uint16_t color)
this function is write one point to lcd. More...
void | lcd_drawpoint (uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd. More...
void | lcd_clear (uint16_t color)
this function is clear the lcd. More...
void | lcd_display_number (void)
this function is display number on the lcd. More...

Variables

uint16_t | point_color
uint16_t | point_color

Detailed Description

Macro Definition Documentation

◆ BLACK [1/2]

#define BLACK 0x0000

Definition at line 61 of file at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ BLACK [2/2]

#define BLACK 0x0000

Definition at line 61 of file at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ BLUE [1/2]

#define BLUE 0x001F

Definition at line 62 of file at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ BLUE [2/2]

#define BLUE 0x001F

Definition at line 62 of file at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ BRED [1/2]

#define BRED 0xF81F

Definition at line 63 of file at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ BRED [2/2]

#define BRED 0xF81F

Definition at line 63 of file at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ BROWN [1/2]

#define BROWN 0xBC40

Definition at line 71 of file at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ BROWN [2/2]

#define BROWN 0xBC40

Definition at line 71 of file at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ BRRED [1/2]

#define BRRED 0xFC07

Definition at line 72 of file at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ BRRED [2/2]

#define BRRED 0xFC07

Definition at line 72 of file at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ CYAN [1/2]

#define CYAN 0x7FFF

Definition at line 69 of file at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ CYAN [2/2]

#define CYAN 0x7FFF

Definition at line 69 of file at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ GBLUE [1/2]

#define GBLUE 0x07FF

Definition at line 65 of file at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ GBLUE [2/2]

#define GBLUE 0x07FF

Definition at line 65 of file at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ GRAY [1/2]

#define GRAY 0x8430

Definition at line 73 of file at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ GRAY [2/2]

#define GRAY 0x8430

Definition at line 73 of file at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ GRED [1/2]

#define GRED 0xFFE0

Definition at line 64 of file at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ GRED [2/2]

#define GRED 0xFFE0

Definition at line 64 of file at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ GREEN [1/2]

#define GREEN 0x07E0

Definition at line 68 of file at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ GREEN [2/2]

#define GREEN 0x07E0

Definition at line 68 of file at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ MAGENTA [1/2]

#define MAGENTA 0xF81F

Definition at line 67 of file at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ MAGENTA [2/2]

#define MAGENTA 0xF81F

Definition at line 67 of file at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ RED [1/2]

#define RED 0xF800

Definition at line 66 of file at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ RED [2/2]

#define RED 0xF800

Definition at line 66 of file at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ WHITE [1/2]

#define WHITE 0xFFFF

Definition at line 60 of file at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ WHITE [2/2]

#define WHITE 0xFFFF

Definition at line 60 of file at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ YELLOW [1/2]

#define YELLOW 0xFFE0

Definition at line 70 of file at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

◆ YELLOW [2/2]

#define YELLOW 0xFFE0

Definition at line 70 of file at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c.

◆ lcd_clear()

void lcd_clear ( uint16_t color )

this function is clear the lcd.

Parameters
data : the data to write.
Return values
none

Definition at line 330 of file at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c.

◆ lcd_display_number()

void lcd_display_number ( void )

this function is display number on the lcd.

Parameters
none
Return values
none

Definition at line 347 of file at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c.

Referenced by main().

◆ lcd_drawpoint()

void lcd_drawpoint | ( | uint16_t | x,
 |  | uint16_t | y,
 |  | uint16_t | color
 | ) |  |

this function is draw point to lcd.

Parameters
data : the data to write.
Return values
none

Definition at line 318 of file at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c.

◆ lcd_init()

void lcd_init ( void )

configures the lcd. this function must be called before any write/read operation on the lcd.

Parameters
none
Return values
none

Definition at line 168 of file at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c.

◆ lcd_setblock()

void lcd_setblock | ( | uint16_t | xstart,
 |  | uint16_t | ystart,
 |  | uint16_t | xend,
 |  | uint16_t | yend
 | ) |  |

this function is set row&column coordinates for lcd.

Parameters
xstart | : row coordinates starting vaule.
ystart | : column coordinates starting vaule.
xend | : row coordinates ending vaule.
yend | : column coordinates ending vaule.
Return values
none

Definition at line 283 of file at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c.

Referenced by lcd_clear(), lcd_display_number(), and lcd_drawpoint().

◆ lcd_wr_command()

void lcd_wr_command ( uint8_t command )

this function is write command to lcd.

Parameters
command : the command to write.
Return values
none

Definition at line 260 of file at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c.

Referenced by lcd_init(), and lcd_setblock().

◆ lcd_wr_data()

void lcd_wr_data ( uint8_t data )

this function is write data to lcd.

Parameters
data : the data to write.
Return values
none

Definition at line 270 of file at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c.

Referenced by lcd_display_number(), lcd_init(), lcd_setblock(), and lcd_writeonepoint().

◆ lcd_writeonepoint()

void lcd_writeonepoint ( uint16_t color )

this function is write one point to lcd.

Parameters
data : the data to write.
Return values
none

Definition at line 307 of file at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c.

Referenced by lcd_clear(), and lcd_drawpoint().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f435/examples/xmc/lcd_8bit/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c.

◆ xmc_init()

void xmc_init ( void )

configures the xmc and gpios to interface with the lcd. this function must be called before any write/read operation on the lcd.

Parameters
none
Return values
none

Definition at line 46 of file at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c.

Referenced by lcd_init().

Variable Documentation

◆ point_color [1/2]

uint16_t point_color

Definition at line 39 of file project/at_start_f435/examples/xmc/lcd_8bit/src/main.c.

Referenced by main().

◆ point_color [2/2]

uint16_t point_color

Definition at line 39 of file project/at_start_f437/examples/xmc/lcd_8bit/src/main.c.


AT32F435/437 Firmwary Library: XMC_lcd_touch_16bit

Modules | Macros | Functions | Variables
XMC_lcd_touch_16bit
AT32F435_periph_examples | AT32F437_periph_examples

Modules

TOUCH_device_type
TOUCH_exported_functions
LCD_device_type
ADDRESS_of_data_and_command
LCD_reset_line
XMC_lcd_exported_functions

Macros

#define | TCLK_HIGH gpio_bits_set(GPIOB,GPIO_PINS_13)
#define | TCLK_LOW gpio_bits_reset(GPIOB,GPIO_PINS_13)
#define | TDOUT gpio_input_data_bit_read(GPIOB,GPIO_PINS_8)
#define | TDIN_HIGH gpio_bits_set(GPIOA,GPIO_PINS_1)
#define | TDIN_LOW gpio_bits_reset(GPIOA,GPIO_PINS_1)
#define | PEN_HIGH gpio_input_data_bit_read(GPIOB,GPIO_PINS_11)
#define | TCS_HIGH gpio_bits_set(GPIOB,GPIO_PINS_12)
#define | TCS_LOW gpio_bits_reset(GPIOB,GPIO_PINS_12)
#define | LCD_BL_HIGH gpio_bits_set(GPIOC,GPIO_PINS_0)
#define | LCD_BL_LOW gpio_bits_reset(GPIOC,GPIO_PINS_0)
#define | WHITE 0xFFFF
#define | BLACK 0x0000
#define | BLUE 0x001F
#define | BRED 0xF81F
#define | GRED 0xFFE0
#define | GBLUE 0x07FF
#define | RED 0xF800
#define | MAGENTA 0xF81F
#define | GREEN 0x07E0
#define | CYAN 0x7FFF
#define | YELLOW 0xFFE0
#define | BROWN 0xBC40
#define | BRRED 0xFC07
#define | GRAY 0x8430
#define | READ_TIMES 5
this function is processing data that read from touch. More...
#define | LOST_VAL 1
#define | TCLK_HIGH gpio_bits_set(GPIOB,GPIO_PINS_13)
#define | TCLK_LOW gpio_bits_reset(GPIOB,GPIO_PINS_13)
#define | TDOUT gpio_input_data_bit_read(GPIOB,GPIO_PINS_8)
#define | TDIN_HIGH gpio_bits_set(GPIOA,GPIO_PINS_1)
#define | TDIN_LOW gpio_bits_reset(GPIOA,GPIO_PINS_1)
#define | PEN_HIGH gpio_input_data_bit_read(GPIOB,GPIO_PINS_11)
#define | TCS_HIGH gpio_bits_set(GPIOB,GPIO_PINS_12)
#define | TCS_LOW gpio_bits_reset(GPIOB,GPIO_PINS_12)
#define | LCD_BL_HIGH gpio_bits_set(GPIOC,GPIO_PINS_0)
#define | LCD_BL_LOW gpio_bits_reset(GPIOC,GPIO_PINS_0)
#define | WHITE 0xFFFF
#define | BLACK 0x0000
#define | BLUE 0x001F
#define | BRED 0xF81F
#define | GRED 0xFFE0
#define | GBLUE 0x07FF
#define | RED 0xF800
#define | MAGENTA 0xF81F
#define | GREEN 0x07E0
#define | CYAN 0x7FFF
#define | YELLOW 0xFFE0
#define | BROWN 0xBC40
#define | BRRED 0xFC07
#define | GRAY 0x8430
#define | READ_TIMES 5
this function is processing data that read from touch. More...
#define | LOST_VAL 1

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...
void | touch_pin_init (void)
this function is init touch pin. More...
void | touch_read_xy (uint16_t *x, uint16_t *y)
this function is read data from touch. More...
uint16_t | touch_read_x_or_y (uint8_t xy)
uint16_t | touch_read_ad (uint8_t xy)
this function is read data from touch. More...
void | touch_write_1byte (uint8_t cmd)
this function is write command to touch. More...
uint8_t | touch_read_1byte (void)
this function is read data from touch. More...
void | touch_scan (void)
this function is scanning the screen. More...
error_status | touch_adjust (void)
this function is adjust the screen. More...
void | xmc_init (void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_init (void)
configures the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_wr_command (uint16_t command)
this function is write command to lcd. More...
void | lcd_wr_data (uint16_t data)
this function is write data to lcd. More...
uint16_t | lcd_rd_data (void)
void | lcd_setblock (uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd. More...
void | lcd_writeonepoint (uint16_t color)
this function is write one point to lcd. More...
void | lcd_drawpoint (uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd. More...
void | lcd_clear (uint16_t color)
this function is clear the lcd. More...

Variables

touch_dev_type touch_dev_struct
touch_dev_type * touch_struct
lcd_dev_type lcd_dev_struct
lcd_dev_type * lcd_struct
static uint16_t | LCD_ID
uint16_t | point_color
touch_dev_type touch_dev_struct
uint8_t | cmd_rdx = 0xd0
uint8_t | cmd_rdy = 0x90
touch_dev_type * touch_struct
lcd_dev_type lcd_dev_struct
lcd_dev_type * lcd_struct
touch_dev_type touch_dev_struct
touch_dev_type * touch_struct
lcd_dev_type lcd_dev_struct
lcd_dev_type * lcd_struct
static uint16_t | LCD_ID
uint16_t | point_color
touch_dev_type touch_dev_struct
uint8_t | cmd_rdx = 0xd0
uint8_t | cmd_rdy = 0x90
touch_dev_type * touch_struct
lcd_dev_type lcd_dev_struct
lcd_dev_type * lcd_struct

Detailed Description

Macro Definition Documentation

◆ BLACK [1/2]

#define BLACK 0x0000

Definition at line 83 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ BLACK [2/2]

#define BLACK 0x0000

Definition at line 83 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ BLUE [1/2]

#define BLUE 0x001F

Definition at line 84 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ BLUE [2/2]

#define BLUE 0x001F

Definition at line 84 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ BRED [1/2]

#define BRED 0xF81F

Definition at line 85 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ BRED [2/2]

#define BRED 0xF81F

Definition at line 85 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ BROWN [1/2]

#define BROWN 0xBC40

Definition at line 93 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ BROWN [2/2]

#define BROWN 0xBC40

Definition at line 93 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ BRRED [1/2]

#define BRRED 0xFC07

Definition at line 94 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ BRRED [2/2]

#define BRRED 0xFC07

Definition at line 94 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ CYAN [1/2]

#define CYAN 0x7FFF

Definition at line 91 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ CYAN [2/2]

#define CYAN 0x7FFF

Definition at line 91 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ GBLUE [1/2]

#define GBLUE 0x07FF

Definition at line 87 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ GBLUE [2/2]

#define GBLUE 0x07FF

Definition at line 87 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ GRAY [1/2]

#define GRAY 0x8430

Definition at line 95 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ GRAY [2/2]

#define GRAY 0x8430

Definition at line 95 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ GRED [1/2]

#define GRED 0xFFE0

Definition at line 86 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ GRED [2/2]

#define GRED 0xFFE0

Definition at line 86 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ GREEN [1/2]

#define GREEN 0x07E0

Definition at line 90 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ GREEN [2/2]

#define GREEN 0x07E0

Definition at line 90 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ LCD_BL_HIGH [1/2]

#define LCD_BL_HIGH gpio_bits_set(GPIOC,GPIO_PINS_0)

Definition at line 79 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ LCD_BL_HIGH [2/2]

#define LCD_BL_HIGH gpio_bits_set(GPIOC,GPIO_PINS_0)

Definition at line 79 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ LCD_BL_LOW [1/2]

#define LCD_BL_LOW gpio_bits_reset(GPIOC,GPIO_PINS_0)

Definition at line 80 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ LCD_BL_LOW [2/2]

#define LCD_BL_LOW gpio_bits_reset(GPIOC,GPIO_PINS_0)

Definition at line 80 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ LOST_VAL [1/2]

#define LOST_VAL 1

Definition at line 137 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c.

◆ LOST_VAL [2/2]

#define LOST_VAL 1

Definition at line 137 of file at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c.

◆ MAGENTA [1/2]

#define MAGENTA 0xF81F

Definition at line 89 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ MAGENTA [2/2]

#define MAGENTA 0xF81F

Definition at line 89 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ PEN_HIGH [1/2]

#define PEN_HIGH gpio_input_data_bit_read(GPIOB,GPIO_PINS_11)

Definition at line 71 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h.

◆ PEN_HIGH [2/2]

#define PEN_HIGH gpio_input_data_bit_read(GPIOB,GPIO_PINS_11)

Definition at line 71 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h.

◆ READ_TIMES [1/2]

#define READ_TIMES 5

this function is processing data that read from touch.

Parameters
xy data.
Return values
processed data

Definition at line 136 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c.

◆ READ_TIMES [2/2]

#define READ_TIMES 5

this function is processing data that read from touch.

Parameters
xy data.
Return values
processed data

Definition at line 136 of file at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c.

◆ RED [1/2]

#define RED 0xF800

Definition at line 88 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ RED [2/2]

#define RED 0xF800

Definition at line 88 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ TCLK_HIGH [1/2]

#define TCLK_HIGH gpio_bits_set(GPIOB,GPIO_PINS_13)

Definition at line 63 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h.

◆ TCLK_HIGH [2/2]

#define TCLK_HIGH gpio_bits_set(GPIOB,GPIO_PINS_13)

Definition at line 63 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h.

◆ TCLK_LOW [1/2]

#define TCLK_LOW gpio_bits_reset(GPIOB,GPIO_PINS_13)

Definition at line 64 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h.

◆ TCLK_LOW [2/2]

#define TCLK_LOW gpio_bits_reset(GPIOB,GPIO_PINS_13)

Definition at line 64 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h.

◆ TCS_HIGH [1/2]

#define TCS_HIGH gpio_bits_set(GPIOB,GPIO_PINS_12)

Definition at line 73 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h.

◆ TCS_HIGH [2/2]

#define TCS_HIGH gpio_bits_set(GPIOB,GPIO_PINS_12)

Definition at line 73 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h.

◆ TCS_LOW [1/2]

#define TCS_LOW gpio_bits_reset(GPIOB,GPIO_PINS_12)

Definition at line 74 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h.

◆ TCS_LOW [2/2]

#define TCS_LOW gpio_bits_reset(GPIOB,GPIO_PINS_12)

Definition at line 74 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h.

◆ TDIN_HIGH [1/2]

#define TDIN_HIGH gpio_bits_set(GPIOA,GPIO_PINS_1)

Definition at line 68 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h.

◆ TDIN_HIGH [2/2]

#define TDIN_HIGH gpio_bits_set(GPIOA,GPIO_PINS_1)

Definition at line 68 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h.

◆ TDIN_LOW [1/2]

#define TDIN_LOW gpio_bits_reset(GPIOA,GPIO_PINS_1)

Definition at line 69 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h.

◆ TDIN_LOW [2/2]

#define TDIN_LOW gpio_bits_reset(GPIOA,GPIO_PINS_1)

Definition at line 69 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h.

◆ TDOUT [1/2]

#define TDOUT gpio_input_data_bit_read(GPIOB,GPIO_PINS_8)

Definition at line 66 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h.

◆ TDOUT [2/2]

#define TDOUT gpio_input_data_bit_read(GPIOB,GPIO_PINS_8)

Definition at line 66 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h.

◆ WHITE [1/2]

#define WHITE 0xFFFF

Definition at line 82 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ WHITE [2/2]

#define WHITE 0xFFFF

Definition at line 82 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ YELLOW [1/2]

#define YELLOW 0xFFE0

Definition at line 92 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ YELLOW [2/2]

#define YELLOW 0xFFE0

Definition at line 92 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c.

◆ lcd_clear()

void lcd_clear ( uint16_t color )

this function is clear the lcd.

Parameters
data : the data to write.
Return values
none

Definition at line 384 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c.

◆ lcd_drawpoint()

void lcd_drawpoint | ( | uint16_t | x,
 |  | uint16_t | y,
 |  | uint16_t | color
 | ) |  |

this function is draw point to lcd.

Parameters
data : the data to write.
Return values
None

Definition at line 372 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c.

◆ lcd_init()

void lcd_init ( void )

configures the lcd. this function must be called before any write/read operation on the lcd.

Parameters
none
Return values
none

Definition at line 172 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c.

◆ lcd_rd_data()

uint16_t lcd_rd_data ( void )

Definition at line 320 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c.

Referenced by lcd_init().

◆ lcd_setblock()

void lcd_setblock | ( | uint16_t | xstart,
 |  | uint16_t | ystart,
 |  | uint16_t | xend,
 |  | uint16_t | yend
 | ) |  |

this function is set row&column coordinates for lcd.

Parameters
xstart | : row coordinates starting vaule.
ystart | : column coordinates starting vaule.
xend | : row coordinates ending vaule.
yend | : column coordinates ending vaule.
Return values
none

Definition at line 337 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c.

◆ lcd_wr_command()

void lcd_wr_command ( uint16_t command )

this function is write command to lcd.

Parameters
command : the command to write.
Return values
none

Definition at line 305 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c.

Referenced by lcd_init(), and lcd_setblock().

◆ lcd_wr_data()

void lcd_wr_data ( uint16_t data )

this function is write data to lcd.

Parameters
data : the data to write.
Return values
none

Definition at line 315 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c.

Referenced by lcd_init(), lcd_setblock(), and lcd_writeonepoint().

◆ lcd_writeonepoint()

void lcd_writeonepoint ( uint16_t color )

this function is write one point to lcd.

Parameters
data : the data to write.
Return values
none

Definition at line 362 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c.

Referenced by lcd_clear(), and lcd_drawpoint().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 47 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c.

◆ touch_adjust()

error_status touch_adjust ( void )

this function is adjust the screen.

Parameters
none
Return values
state

Definition at line 263 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c.

◆ touch_pin_init()

void touch_pin_init ( void )

this function is init touch pin.

Parameters
none
Return values
none

Definition at line 58 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c.

◆ touch_read_1byte()

uint8_t touch_read_1byte ( void )

this function is read data from touch.

Parameters
none
Return values
data

Definition at line 222 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c.

Referenced by touch_read_ad().

◆ touch_read_ad()

uint16_t touch_read_ad ( uint8_t xy )

this function is read data from touch.

Parameters
xy : command.
Return values
data

Definition at line 181 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c.

Referenced by touch_read_x_or_y().

◆ touch_read_x_or_y()

uint16_t touch_read_x_or_y ( uint8_t xy )

Definition at line 138 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c.

Referenced by touch_read_xy().

◆ touch_read_xy()

void touch_read_xy | ( | uint16_t * | x,
 |  | uint16_t * | y
 | ) |  |

this function is read data from touch.

Parameters
x/y : coordinate vaule.
Return values
none

Definition at line 120 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c.

◆ touch_scan()

void touch_scan ( void )

this function is scanning the screen.

Parameters
none
Return values
none

Definition at line 240 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c.

◆ touch_write_1byte()

void touch_write_1byte ( uint8_t cmd )

this function is write command to touch.

Parameters
cmd : command.
Return values
none

Definition at line 208 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c.

Referenced by touch_read_ad().

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c.

◆ xmc_init()

void xmc_init ( void )

configures the xmc and gpios to interface with the lcd. this function must be called before any write/read operation on the lcd.

Parameters
none
Return values
none

Definition at line 56 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c.

Variable Documentation

◆ cmd_rdx [1/2]

uint8_t cmd_rdx = 0xd0

Definition at line 48 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c.

Referenced by touch_read_xy().

◆ cmd_rdx [2/2]

uint8_t cmd_rdx = 0xd0

Definition at line 48 of file at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c.

Referenced by touch_read_xy().

◆ cmd_rdy [1/2]

uint8_t cmd_rdy = 0x90

Definition at line 49 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c.

Referenced by touch_read_xy().

◆ cmd_rdy [2/2]

uint8_t cmd_rdy = 0x90

Definition at line 49 of file at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c.

Referenced by touch_read_xy().

◆ lcd_dev_struct [1/4]

lcd_dev_type lcd_dev_struct
extern

Definition at line 38 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

◆ lcd_dev_struct [2/4]

lcd_dev_type lcd_dev_struct
Initial value:
=
{
0,
xmc_init,
lcd_init,
lcd_setblock,
lcd_drawpoint,
lcd_clear,
}
lcd_setblock
void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd.
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c:337
lcd_init
void lcd_init(void)
configures the lcd. this function must be called before any write/read operation on the lcd.
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c:172
lcd_drawpoint
void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd.
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c:372
lcd_clear
void lcd_clear(uint16_t color)
this function is clear the lcd.
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c:384
xmc_init
void xmc_init(void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write...
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c:56

Definition at line 37 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c.

◆ lcd_dev_struct [3/4]

lcd_dev_type lcd_dev_struct
extern

Definition at line 38 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

Referenced by main().

◆ lcd_dev_struct [4/4]

lcd_dev_type lcd_dev_struct
Initial value:
=
{
0,
xmc_init,
lcd_init,
lcd_setblock,
lcd_drawpoint,
lcd_clear,
}
lcd_setblock
void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:332
lcd_init
void lcd_init(void)
configures the lcd. this function must be called before any write/read operation on the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:165
lcd_drawpoint
void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:367
lcd_clear
void lcd_clear(uint16_t color)
this function is clear the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:379
xmc_init
void xmc_init(void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write...
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:57

Definition at line 37 of file at_start_f437/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c.

◆ LCD_ID [1/2]

uint16_t LCD_ID
static

Definition at line 81 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ LCD_ID [2/2]

uint16_t LCD_ID
static

Definition at line 81 of file at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.

◆ lcd_struct [1/4]

lcd_dev_type* lcd_struct
extern

Definition at line 48 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

◆ lcd_struct [2/4]

lcd_dev_type* lcd_struct

Definition at line 47 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c.

Referenced by lcd_clear(), lcd_drawpoint(), and lcd_init().

◆ lcd_struct [3/4]

lcd_dev_type* lcd_struct
extern

Definition at line 48 of file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.

Referenced by dvp_frame_done(), dvp_start(), lcd_clear(), lcd_color_fill(), lcd_drawpoint(), lcd_fill(), lcd_init(), and main().

◆ lcd_struct [4/4]

lcd_dev_type* lcd_struct

Definition at line 47 of file at_start_f437/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c.

◆ point_color [1/2]

uint16_t point_color

Definition at line 40 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/src/main.c.

Referenced by main().

◆ point_color [2/2]

uint16_t point_color

Definition at line 40 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/src/main.c.

◆ touch_dev_struct [1/4]

touch_dev_type touch_dev_struct
extern

Definition at line 38 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c.

Referenced by main().

◆ touch_dev_struct [2/4]

touch_dev_type touch_dev_struct
Initial value:
=
{
touch_pin_init,
touch_read_xy,
touch_scan,
touch_adjust,
0,
0,
}
touch_scan
void touch_scan(void)
this function is scanning the screen.
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c:240
touch_read_xy
void touch_read_xy(uint16_t *x, uint16_t *y)
this function is read data from touch.
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c:120
touch_adjust
error_status touch_adjust(void)
this function is adjust the screen.
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c:263
touch_pin_init
void touch_pin_init(void)
this function is init touch pin.
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c:58

Definition at line 38 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c.

Referenced by touch_scan().

◆ touch_dev_struct [3/4]

touch_dev_type touch_dev_struct
extern

Definition at line 38 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c.

Referenced by touch_scan().

◆ touch_dev_struct [4/4]

touch_dev_type touch_dev_struct
Initial value:
=
{
touch_pin_init,
touch_read_xy,
touch_scan,
touch_adjust,
0,
0,
}
touch_scan
void touch_scan(void)
this function is scanning the screen.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:240
touch_read_xy
void touch_read_xy(uint16_t *x, uint16_t *y)
this function is read data from touch.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:120
touch_adjust
error_status touch_adjust(void)
this function is adjust the screen.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:263
touch_pin_init
void touch_pin_init(void)
this function is init touch pin.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:58

Definition at line 38 of file at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c.

Referenced by main(), and touch_scan().

◆ touch_struct [1/4]

touch_dev_type* touch_struct
extern

Definition at line 51 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c.

Referenced by main().

◆ touch_struct [2/4]

touch_dev_type* touch_struct

Definition at line 51 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c.

◆ touch_struct [3/4]

touch_dev_type* touch_struct
extern

Definition at line 51 of file at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c.

◆ touch_struct [4/4]

touch_dev_type* touch_struct

Definition at line 51 of file at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c.

Referenced by main().


AT32F435/437 Firmwary Library: TOUCH_device_type

Data Structures
TOUCH_device_type
AT32F435_periph_examples | AT32F437_periph_examples » XMC_lcd_touch_16bit

Data Structures

struct touch_dev_type

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: touch_dev_type Struct Reference

Data Fields
touch_dev_type Struct Reference
AT32F435_periph_examples | AT32F437_periph_examples » XMC_lcd_touch_16bit » TOUCH_device_type

#include <touch.h>

Data Fields

void(* | init )(void)
void(* | touch_read_xy )(uint16_t *x, uint16_t *y)
void(* | touch_scan )(void)
error_status(* | touch_adjust )(void)
uint16_t | x_p [6]
uint16_t | y_p [6]

Detailed Description

Definition at line 46 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h.

Field Documentation

◆ init

void(* touch_dev_type::init)(void) ( void )

pin init

Definition at line 48 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h.

Referenced by main().

◆ touch_adjust

error_status(* touch_dev_type::touch_adjust)(void) ( void )

touch adjust func

Definition at line 51 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h.

◆ touch_read_xy

void(* touch_dev_type::touch_read_xy)(uint16_t *x, uint16_t *y)

read x/y coordinate

Definition at line 49 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h.

Referenced by touch_scan().

◆ touch_scan

void(* touch_dev_type::touch_scan)(void) ( void )

touch scan func

Definition at line 50 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h.

Referenced by main().

◆ x_p

uint16_t touch_dev_type::x_p

save x coordinate

Definition at line 52 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h.

Referenced by touch_scan().

◆ y_p

uint16_t touch_dev_type::y_p

save y coordinate

Definition at line 53 of file at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h.

Referenced by touch_scan().

The documentation for this struct was generated from the following files:
  • at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h
  • at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h


AT32F435/437 Firmwary Library: TOUCH_exported_functions

Functions
TOUCH_exported_functions
AT32F435_periph_examples | AT32F437_periph_examples » XMC_lcd_touch_16bit

Functions

void | touch_pin_init (void)
this function is init touch pin. More...
void | touch_read_xy (uint16_t *x, uint16_t *y)
this function is read data from touch. More...
void | touch_scan (void)
this function is scanning the screen. More...
uint16_t | touch_read_x_or_y (uint8_t xy)
uint16_t | touch_read_ad (uint8_t xy)
this function is read data from touch. More...
void | touch_write_1byte (uint8_t cmd)
this function is write command to touch. More...
uint8_t | touch_read_1byte (void)
this function is read data from touch. More...
error_status | touch_adjust (void)
this function is adjust the screen. More...

Detailed Description

Function Documentation

◆ touch_adjust()

error_status touch_adjust ( void )

this function is adjust the screen.

Parameters
none
Return values
state

Definition at line 263 of file at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c.

◆ touch_pin_init()

void touch_pin_init ( void )

this function is init touch pin.

Parameters
none
Return values
none

Definition at line 58 of file at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c.

◆ touch_read_1byte()

uint8_t touch_read_1byte ( void )

this function is read data from touch.

Parameters
none
Return values
data

Definition at line 222 of file at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c.

Referenced by touch_read_ad().

◆ touch_read_ad()

uint16_t touch_read_ad ( uint8_t xy )

this function is read data from touch.

Parameters
xy : command.
Return values
data

Definition at line 181 of file at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c.

Referenced by touch_read_x_or_y().

◆ touch_read_x_or_y()

uint16_t touch_read_x_or_y ( uint8_t xy )

Definition at line 138 of file at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c.

Referenced by touch_read_xy().

◆ touch_read_xy()

void touch_read_xy | ( | uint16_t * | x,
 |  | uint16_t * | y
 | ) |  |

this function is read data from touch.

Parameters
x/y : coordinate vaule.
Return values
none

Definition at line 120 of file at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c.

◆ touch_scan()

void touch_scan ( void )

this function is scanning the screen.

Parameters
none
Return values
none

Definition at line 240 of file at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c.

◆ touch_write_1byte()

void touch_write_1byte ( uint8_t cmd )

this function is write command to touch.

Parameters
cmd : command.
Return values
none

Definition at line 208 of file at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c.

Referenced by touch_read_ad().


AT32F435/437 Firmwary Library: XMC_nand_ecc

Modules | Macros | Functions | Variables
XMC_nand_ecc
AT32F435_periph_examples | AT32F437_periph_examples

Modules

NAND_id_define
NAND_address_define
NAND_area_define
XMC_nand_memory_command
XMC_nand_status
XMC_nand_parameters
XMC_nand_address_computation
XMC_nand_ecc_functions

Macros

#define | ROW_ADDRESS (address_struct.page + (address_struct.block + (address_struct.zone * NAND_ZONE_SIZE)) * NAND_BLOCK_SIZE)
#define | COL_ADDRESS address_struct.byte
#define | BUFFER_SIZE NAND_PAGE_SIZE
#define | XMC_Bank_NAND XMC_Bank2_NAND
#define | Bank_NAND_ADDR Bank2_NAND_ADDR
#define | Bank2_NAND_ADDR ((uint32_t)0x70000000)
#define | ROW_ADDRESS (address_struct.page + (address_struct.block + (address_struct.zone * NAND_ZONE_SIZE)) * NAND_BLOCK_SIZE)
#define | COL_ADDRESS address_struct.byte
#define | BUFFER_SIZE NAND_PAGE_SIZE
#define | XMC_Bank_NAND XMC_Bank2_NAND
#define | Bank_NAND_ADDR Bank2_NAND_ADDR
#define | Bank2_NAND_ADDR ((uint32_t)0x70000000)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | nand_ecc_correction (uint8_t *pbuffer, uint32_t tx_ecc_value,uint32_t rx_ecc_value)
ecc correct 1 bit error More...
int | main (void)
main function. More...
void | nand_init (void)
configures the xmc and gpios to interface with the nand memory. this function must be called before any write/read operation on the nand. More...
void | nand_read_id (nand_id_type *nand_id_struct)
reads nand memory's id. More...
uint32_t | nand_write_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write)
this routine is for writing one or several 512 bytes page size. More...
uint32_t | nand_read_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read)
this routine is for sequential read from one or several 512 bytes page size. More...
uint32_t | nand_write_spare_area (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write)
this routine write the spare area information for the specified pages addresses. More...
uint32_t | nand_read_spare_area (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read)
this routine read the spare area information from the specified pages addresses. More...
uint32_t | nand_erase_block (nand_address_type address_struct)
this routine erase complete block from nand flash More...
uint32_t | nand_reset (void)
this routine reset the nand flash. More...
uint32_t | nand_get_status (void)
get the nand operation status. More...
uint32_t | nand_read_status (void)
reads the nand memory status using the read status command. More...
uint32_t | nand_address_increment (nand_address_type *address_struct)
increment the nand memory address. More...

Variables

uint32_t | ecc_value_write
uint32_t | ecc_value_read
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
nand_id_type nand_id_struct
nand_address_type write_read_addr_struct
uint8_t | tx_buffer [BUFFER_SIZE]
uint8_t | rx_buffer [BUFFER_SIZE]
uint32_t | page_number = 1
uint32_t | status = 0
uint32_t | j = 0
uint32_t | ecc_value_write = 0
uint32_t | ecc_value_read = 0
uint32_t | ecc_value_write_last = 0
uint32_t | ecc_value_write
uint32_t | ecc_value_read
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
nand_id_type nand_id_struct
nand_address_type write_read_addr_struct
uint8_t | tx_buffer [BUFFER_SIZE]
uint8_t | rx_buffer [BUFFER_SIZE]
uint32_t | page_number = 1
uint32_t | status = 0
uint32_t | j = 0
uint32_t | ecc_value_write = 0
uint32_t | ecc_value_read = 0
uint32_t | ecc_value_write_last = 0

Detailed Description

Macro Definition Documentation

◆ Bank2_NAND_ADDR [1/2]

#define Bank2_NAND_ADDR ((uint32_t)0x70000000)

Definition at line 81 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ Bank2_NAND_ADDR [2/2]

#define Bank2_NAND_ADDR ((uint32_t)0x70000000)

Definition at line 81 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ Bank_NAND_ADDR [1/2]

#define Bank_NAND_ADDR Bank2_NAND_ADDR

Definition at line 80 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ Bank_NAND_ADDR [2/2]

#define Bank_NAND_ADDR Bank2_NAND_ADDR

Definition at line 80 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ BUFFER_SIZE [1/2]

#define BUFFER_SIZE NAND_PAGE_SIZE

Definition at line 77 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ BUFFER_SIZE [2/2]

#define BUFFER_SIZE NAND_PAGE_SIZE

Definition at line 77 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ COL_ADDRESS [1/2]

#define COL_ADDRESS address_struct.byte

Definition at line 75 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ COL_ADDRESS [2/2]

#define COL_ADDRESS address_struct.byte

Definition at line 75 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ ROW_ADDRESS [1/2]

#define ROW_ADDRESS (address_struct.page + (address_struct.block + (address_struct.zone * NAND_ZONE_SIZE)) * NAND_BLOCK_SIZE)

Definition at line 74 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ ROW_ADDRESS [2/2]

#define ROW_ADDRESS (address_struct.page + (address_struct.block + (address_struct.zone * NAND_ZONE_SIZE)) * NAND_BLOCK_SIZE)

Definition at line 74 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ XMC_Bank_NAND [1/2]

#define XMC_Bank_NAND XMC_Bank2_NAND

Definition at line 79 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ XMC_Bank_NAND [2/2]

#define XMC_Bank_NAND XMC_Bank2_NAND

Definition at line 79 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 118 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c.

◆ nand_address_increment()

uint32_t nand_address_increment ( nand_address_type * address_struct )

increment the nand memory address.

Parameters
address address to be incremented.
Return values
the new status of the increment address operation. it can be:
  • NAND_VALID_ADDRESS: when the new address is valid address
  • NAND_INVALID_ADDRESS: when the new address is invalid address

Definition at line 502 of file at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

Referenced by nand_read_small_page(), nand_read_spare_area(), nand_write_small_page(), and nand_write_spare_area().

◆ nand_ecc_correction()

void nand_ecc_correction | ( | uint8_t * | pbuffer,
 |  | uint32_t | tx_ecc_value,
 |  | uint32_t | rx_ecc_value
 | ) |  |

ecc correct 1 bit error

Parameters
pbuffer | pointer on the buffer to correct
tx_ecc_value | ecc value for transmiting to nand flash
rx_ecc_value | ecc value for receiving from nand flash

Definition at line 72 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c.

Referenced by main().

◆ nand_erase_block()

uint32_t nand_erase_block ( nand_address_type address_struct )

this routine erase complete block from nand flash

Parameters
address any address into block to be erased
Return values
new status of the nand operation. this parameter can be:
  • NAND_TIMEOUT_ERROR: when the previous operation generate a timeout error
  • NAND_READY: when memory is ready for the next operation

Definition at line 403 of file at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

◆ nand_get_status()

uint32_t nand_get_status ( void )

get the nand operation status.

Parameters
none
Return values
new status of the nand operation. this parameter can be:
  • NAND_TIMEOUT_ERROR: when the previous operation generate a timeout error
  • NAND_READY: when memory is ready for the next operation

Definition at line 441 of file at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

Referenced by nand_erase_block(), nand_read_small_page(), nand_read_spare_area(), nand_write_small_page(), and nand_write_spare_area().

◆ nand_init()

void nand_init ( void )

configures the xmc and gpios to interface with the nand memory. this function must be called before any write/read operation on the nand.

Parameters
none
Return values
none

Definition at line 44 of file at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

◆ nand_read_id()

void nand_read_id ( nand_id_type * nand_id_struct )

reads nand memory's id.

Parameters
nand_id pointer to a nand_id_type structure which will hold the manufacturer and device id.
Return values
none

Definition at line 120 of file at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

◆ nand_read_small_page()

uint32_t nand_read_small_page | ( | uint8_t * | pbuffer,
 |  | nand_address_type | address_struct,
 |  | uint32_t | num_page_to_read
 | ) |  |

this routine is for sequential read from one or several 512 bytes page size.

Parameters
pbuffer | pointer on the buffer to fill
address | first page address
num_page_to_read | number of page to read
Return values
new status of the nand operation. this parameter can be:
  • NAND_TIMEOUT_ERROR: when the previous operation generate a timeout error
  • NAND_READY: when memory is ready for the next operation and the new status of the increment address operation. it can be:
  • NAND_VALID_ADDRESS: when the new address is valid address
  • NAND_INVALID_ADDRESS: when the new address is invalid address

Definition at line 228 of file at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

◆ nand_read_spare_area()

uint32_t nand_read_spare_area | ( | uint8_t * | pbuffer,
 |  | nand_address_type | address_struct,
 |  | uint32_t | num_spare_area_to_read
 | ) |  |

this routine read the spare area information from the specified pages addresses.

Parameters
pbuffer | pointer on the buffer to fill
address | first page address
num_spare_area_to_read | number of spare area to read
Return values
new status of the nand operation. this parameter can be:
  • NAND_TIMEOUT_ERROR: when the previous operation generate a timeout error
  • NAND_READY: when memory is ready for the next operation and the new status of the increment address operation. it can be:
  • NAND_VALID_ADDRESS: when the new address is valid address
  • NAND_INVALID_ADDRESS: when the new address is invalid address

Definition at line 353 of file at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

◆ nand_read_status()

uint32_t nand_read_status ( void )

reads the nand memory status using the read status command.

Parameters
none
Return values
the status of the nand memory. this parameter can be:
  • NAND_BUSY: when memory is busy
  • NAND_READY: when memory is ready for the next operation
  • NAND_ERROR: when the previous operation gererates error

Definition at line 471 of file at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

Referenced by nand_get_status().

◆ nand_reset()

uint32_t nand_reset ( void )

this routine reset the nand flash.

Parameters
none
Return values
NAND_READY

Definition at line 426 of file at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

◆ nand_write_small_page()

uint32_t nand_write_small_page | ( | uint8_t * | pbuffer,
 |  | nand_address_type | address_struct,
 |  | uint32_t | num_page_to_write
 | ) |  |

this routine is for writing one or several 512 bytes page size.

Parameters
pbuffer | pointer on the buffer containing data to be written
address | first page address
num_page_to_write | number of page to write
Return values
new status of the nand operation. this parameter can be:
  • NAND_TIMEOUT_ERROR: when the previous operation generate a timeout error
  • NAND_READY: when memory is ready for the next operation and the new status of the increment address operation. it can be:
  • NAND_VALID_ADDRESS: when the new address is valid address
  • NAND_INVALID_ADDRESS: when the new address is invalid address

Definition at line 161 of file at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

◆ nand_write_spare_area()

uint32_t nand_write_spare_area | ( | uint8_t * | pbuffer,
 |  | nand_address_type | address_struct,
 |  | uint32_t | num_spare_area_to_write
 | ) |  |

this routine write the spare area information for the specified pages addresses.

Parameters
pbuffer | pointer on the buffer containing data to be written
address | first page address
num_spare_area_to_write | number of spare area to write
Return values
new status of the nand operation. this parameter can be:
  • NAND_TIMEOUT_ERROR: when the previous operation generate a timeout error
  • NAND_READY: when memory is ready for the next operation and the new status of the increment address operation. it can be:
  • NAND_VALID_ADDRESS: when the new address is valid address
  • NAND_INVALID_ADDRESS: when the new address is invalid address

Definition at line 294 of file at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c.

Variable Documentation

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c.

◆ ecc_value_read [1/4]

uint32_t ecc_value_read
extern

Definition at line 44 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c.

Referenced by nand_read_small_page().

◆ ecc_value_read [2/4]

uint32_t ecc_value_read = 0

Definition at line 44 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c.

Referenced by main().

◆ ecc_value_read [3/4]

uint32_t ecc_value_read
extern

Definition at line 44 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c.

Referenced by main().

◆ ecc_value_read [4/4]

uint32_t ecc_value_read = 0

Definition at line 44 of file project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c.

Referenced by nand_read_small_page().

◆ ecc_value_write [1/4]

uint32_t ecc_value_write
extern

Definition at line 44 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c.

Referenced by nand_write_small_page().

◆ ecc_value_write [2/4]

uint32_t ecc_value_write = 0

Definition at line 44 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c.

Referenced by main().

◆ ecc_value_write [3/4]

uint32_t ecc_value_write
extern

Definition at line 44 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c.

Referenced by main().

◆ ecc_value_write [4/4]

uint32_t ecc_value_write = 0

Definition at line 44 of file project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c.

Referenced by nand_write_small_page().

◆ ecc_value_write_last [1/2]

uint32_t ecc_value_write_last = 0

Definition at line 44 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c.

Referenced by main().

◆ ecc_value_write_last [2/2]

uint32_t ecc_value_write_last = 0

Definition at line 44 of file project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c.

◆ j [1/2]

uint32_t j = 0

Definition at line 44 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c.

Referenced by arm_calc_guard_bits(), http_recv(), lcd_color_fill(), SCCB_RD_Byte(), SCCB_WR_Byte(), slib_enable(), and touch_read_x_or_y().

◆ j [2/2]

uint32_t j = 0

Definition at line 44 of file project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c.

◆ nand_id_struct [1/2]

nand_id_type nand_id_struct

Definition at line 40 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c.

Referenced by main(), and nand_read_id().

◆ nand_id_struct [2/2]

nand_id_type nand_id_struct

Definition at line 40 of file project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c.

◆ page_number [1/2]

uint32_t page_number = 1

Definition at line 43 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c.

Referenced by main().

◆ page_number [2/2]

uint32_t page_number = 1

Definition at line 43 of file project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c.

◆ rx_buffer [1/2]

uint8_t rx_buffer[BUFFER_SIZE]

Definition at line 42 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c.

Referenced by main().

◆ rx_buffer [2/2]

uint8_t rx_buffer[BUFFER_SIZE]

Definition at line 42 of file project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c.

◆ status [1/2]

uint32_t status = 0

Definition at line 43 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c.

Referenced by adc_flag_get(), at32_mqtt_connection_cb(), audio_hid_class_send_report(), bot_scsi_cmd_process(), bot_scsi_inquiry(), bot_scsi_send_csw(), bot_scsi_test_unit(), can_doze_mode_enter(), can_doze_mode_exit(), can_operating_mode_set(), cdc_class_setup_handler(), class_audio_setup_handler(), class_clear_handler(), class_ept0_rx_handler(), class_ept0_tx_handler(), class_event_handler(), class_hid_setup_handler(), class_in_handler(), class_init_handler(), class_out_handler(), class_setup_handler(), class_sof_handler(), command_error(), command_rsp2_error(), command_rsp6_error(), command_rsp7_error(), crm_flag_get(), crm_hext_stable_wait(), custom_hid_class_send_report(), dac_udr_flag_get(), disk_read(), disk_write(), dvp_basic_status_get(), dvp_flag_get(), edma_flag_get(), emac_dma_flag_get(), emac_ptp_timestamp_status_get(), emac_system_init(), ertc_wait_flag(), exint_flag_get(), flash_bank1_erase(), flash_bank1_operation_wait_for(), flash_bank2_erase(), flash_bank2_operation_wait_for(), flash_block_erase(), flash_byte_program(), flash_eopb0_config(), flash_epp_set(), flash_fap_enable(), flash_fat16_loop_status(), flash_fat16_sector_write(), flash_flag_get(), flash_halfword_program(), flash_internal_all_erase(), flash_operation_wait_for(), flash_sector_erase(), flash_slib_disable(), flash_slib_enable(), flash_ssb_set(), flash_user_system_data_erase(), flash_user_system_data_program(), flash_word_program(), flash_write(), flash_write_nocheck(), gpio_input_data_bit_read(), gpio_output_data_bit_read(), iap_address(), keyboard_class_setup_handler(), main(), mmc_stream_test(), mmc_stream_write(), mmc_switch(), msc_class_setup_handler(), nand_address_increment(), nand_get_status(), nand_read_small_page(), nand_read_spare_area(), nand_read_status(), nand_write_small_page(), nand_write_spare_area(), nor_getstatus(), nor_writebuffer(), pwc_flag_get(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_info_get(), sd_card_init(), sd_device_mode_set(), sd_init(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_multiple_blocks_test(), sd_power_on(), sd_single_block_test(), sd_status_send(), sd_switch(), sd_wide_bus_operation_config(), sdio_command_data_send(), sdio_flag_get(), slib_enable(), speed_change(), spi_i2s_flag_get(), tmr_flag_get(), uhost_init_handler(), uhost_process_handler(), uhost_request_handler(), uhost_reset_handler(), usb_bot_request(), usb_iap_class_send_report(), usb_keyboard_class_send_report(), usb_mouse_class_send_report(), usb_printer_send_data(), usb_vcp_send_data(), usb_vcpkybrd_class_send_report(), usb_vcpkybrd_vcp_send_data(), usbd_hid_iap_process(), usbh_check_csw(), usbh_class_request(), usbh_clear_dev_feature(), usbh_clear_endpoint_feature(), usbh_clear_ept_feature(), usbh_core_init(), usbh_ctrl_data_in_handler(), usbh_ctrl_data_in_wait_handler(), usbh_ctrl_data_out_handler(), usbh_ctrl_data_out_wait_handler(), usbh_ctrl_error_handler(), usbh_ctrl_request(), usbh_ctrl_result_check(), usbh_ctrl_setup_wait_handler(), usbh_ctrl_status_in_handler(), usbh_ctrl_status_in_wait_handler(), usbh_ctrl_status_out_handler(), usbh_ctrl_status_out_wait_handler(), usbh_ctrl_transfer_loop(), usbh_enum_handler(), usbh_get_configure_descriptor(), usbh_get_descriptor(), usbh_get_device_descriptor(), usbh_get_sting_descriptor(), usbh_hid_get_desc(), usbh_hid_get_report(), usbh_hid_set_idle(), usbh_hid_set_protocol(), usbh_in_out_request(), usbh_loop_handler(), usbh_msc_bot_scsi_capacity(), usbh_msc_bot_scsi_get_inquiry(), usbh_msc_bot_scsi_read(), usbh_msc_bot_scsi_request_sense(), usbh_msc_bot_scsi_test_unit_ready(), usbh_msc_bot_scsi_write(), usbh_msc_clear_feature(), usbh_msc_get_max_lun(), usbh_msc_rw_handle(), usbh_set_address(), usbh_set_configuration(), usbh_set_feature(), usbh_set_interface(), usbh_user_active_vbus(), usbh_user_application(), usbh_user_attached(), usbh_user_disconnect(), usbh_user_enumeration_done(), usbh_user_init(), usbh_user_mfc_string(), usbh_user_not_support(), usbh_user_product_string(), usbh_user_reset(), usbh_user_serial_string(), usbh_user_speed(), wdt_flag_get(), and xmc_flag_status_get().

◆ status [2/2]

uint32_t status = 0

Definition at line 43 of file project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c.

◆ tx_buffer [1/2]

uint8_t tx_buffer[BUFFER_SIZE]

Definition at line 42 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c.

Referenced by main().

◆ tx_buffer [2/2]

uint8_t tx_buffer[BUFFER_SIZE]

Definition at line 42 of file project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c.

◆ write_read_addr_struct [1/2]

nand_address_type write_read_addr_struct

Definition at line 41 of file project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c.

Referenced by main().

◆ write_read_addr_struct [2/2]

nand_address_type write_read_addr_struct

Definition at line 41 of file project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c.


AT32F435/437 Firmwary Library: NAND_id_define

Data Structures
NAND_id_define
AT32F435_periph_examples | AT32F437_periph_examples » XMC_nand_ecc | AT32F435_periph_examples | AT32F437_periph_examples » XMC_nand

Data Structures

struct nand_id_type

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: nand_id_type Struct Reference

Data Fields
nand_id_type Struct Reference
AT32F435_periph_examples | AT32F437_periph_examples » XMC_nand_ecc | AT32F435_periph_examples | AT32F437_periph_examples » XMC_nand » NAND_id_define

#include <xmc_ecc.h>

Data Fields

uint8_t | maker_id
uint8_t | device_id
uint8_t | third_id
uint8_t | fourth_id
uint8_t | fifth_id
uint8_t | sixth_id

Detailed Description

Definition at line 44 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

Field Documentation

◆ device_id

uint8_t nand_id_type::device_id

device id

Definition at line 47 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

Referenced by main(), and nand_read_id().

◆ fifth_id

uint8_t nand_id_type::fifth_id

fifth id

Definition at line 50 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

Referenced by nand_read_id().

◆ fourth_id

uint8_t nand_id_type::fourth_id

fourth id

Definition at line 49 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

Referenced by nand_read_id().

◆ maker_id

uint8_t nand_id_type::maker_id

maker id

Definition at line 46 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

Referenced by main(), and nand_read_id().

◆ sixth_id

uint8_t nand_id_type::sixth_id

sixth id

Definition at line 51 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

Referenced by nand_read_id().

◆ third_id

uint8_t nand_id_type::third_id

third id

Definition at line 48 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

Referenced by nand_read_id().

The documentation for this struct was generated from the following files:
  • at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h
  • at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h
  • at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h


AT32F435/437 Firmwary Library: NAND_address_define

Data Structures
NAND_address_define
AT32F435_periph_examples | AT32F437_periph_examples » XMC_nand_ecc | AT32F435_periph_examples | AT32F437_periph_examples » XMC_nand

Data Structures

struct nand_address_type

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: nand_address_type Struct Reference

Data Fields
nand_address_type Struct Reference
AT32F435_periph_examples | AT32F437_periph_examples » XMC_nand_ecc | AT32F435_periph_examples | AT32F437_periph_examples » XMC_nand » NAND_address_define

#include <xmc_ecc.h>

Data Fields

uint16_t | zone
uint16_t | block
uint16_t | page
uint16_t | byte

Detailed Description

Definition at line 62 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

Field Documentation

◆ block

uint16_t nand_address_type::block

nand device block address

Definition at line 65 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

Referenced by main(), and nand_address_increment().

◆ byte

uint16_t nand_address_type::byte

nand device byte address

Definition at line 67 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

Referenced by main().

◆ page

uint16_t nand_address_type::page

nand device page address

Definition at line 66 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

Referenced by main(), and nand_address_increment().

◆ zone

uint16_t nand_address_type::zone

nand device zone address

Definition at line 64 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

Referenced by main(), and nand_address_increment().

The documentation for this struct was generated from the following files:
  • at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h
  • at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h
  • at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h


AT32F435/437 Firmwary Library: NAND_area_define

Macros
NAND_area_define
AT32F435_periph_examples | AT32F437_periph_examples » XMC_nand_ecc | AT32F435_periph_examples | AT32F437_periph_examples » XMC_nand

Macros

#define | CMD_AREA (uint32_t)(1<<16)
#define | ADDR_AREA (uint32_t)(1<<17)
#define | DATA_AREA ((uint32_t)0x00000000)
#define | CMD_AREA (uint32_t)(1<<16)
#define | ADDR_AREA (uint32_t)(1<<17)
#define | DATA_AREA ((uint32_t)0x00000000)
#define | CMD_AREA (uint32_t)(1<<16)
#define | ADDR_AREA (uint32_t)(1<<17)
#define | DATA_AREA ((uint32_t)0x00000000)
#define | CMD_AREA (uint32_t)(1<<16)
#define | ADDR_AREA (uint32_t)(1<<17)
#define | DATA_AREA ((uint32_t)0x00000000)

Detailed Description

Macro Definition Documentation

◆ ADDR_AREA [1/4]

#define ADDR_AREA (uint32_t)(1<<17)

Definition at line 98 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ ADDR_AREA [2/4]

#define ADDR_AREA (uint32_t)(1<<17)

Definition at line 99 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ ADDR_AREA [3/4]

#define ADDR_AREA (uint32_t)(1<<17)

Definition at line 98 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ ADDR_AREA [4/4]

#define ADDR_AREA (uint32_t)(1<<17)

Definition at line 99 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ CMD_AREA [1/4]

#define CMD_AREA (uint32_t)(1<<16)

Definition at line 96 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ CMD_AREA [2/4]

#define CMD_AREA (uint32_t)(1<<16)

Definition at line 97 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ CMD_AREA [3/4]

#define CMD_AREA (uint32_t)(1<<16)

Definition at line 96 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ CMD_AREA [4/4]

#define CMD_AREA (uint32_t)(1<<16)

Definition at line 97 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ DATA_AREA [1/4]

#define DATA_AREA ((uint32_t)0x00000000)

Definition at line 100 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ DATA_AREA [2/4]

#define DATA_AREA ((uint32_t)0x00000000)

Definition at line 101 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ DATA_AREA [3/4]

#define DATA_AREA ((uint32_t)0x00000000)

Definition at line 100 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ DATA_AREA [4/4]

#define DATA_AREA ((uint32_t)0x00000000)

Definition at line 101 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.


AT32F435/437 Firmwary Library: XMC_nand_memory_command

Macros
XMC_nand_memory_command
AT32F435_periph_examples | AT32F437_periph_examples » XMC_nand_ecc | AT32F435_periph_examples | AT32F437_periph_examples » XMC_nand

Macros

#define | NAND_CMD_AREA_A ((uint8_t)0x00)
#define | NAND_CMD_AREA_B ((uint8_t)0x01)
#define | NAND_CMD_AREA_C ((uint8_t)0x50)
#define | NAND_CMD_AREA_TRUE1 ((uint8_t)0x30)
#define | NAND_CMD_WRITE0 ((uint8_t)0x80)
#define | NAND_CMD_WRITE_TRUE1 ((uint8_t)0x10)
#define | NAND_CMD_ERASE0 ((uint8_t)0x60)
#define | NAND_CMD_ERASE1 ((uint8_t)0xD0)
#define | NAND_CMD_READID ((uint8_t)0x90)
#define | NAND_CMD_STATUS ((uint8_t)0x70)
#define | NAND_CMD_LOCK_STATUS ((uint8_t)0x7A)
#define | NAND_CMD_RESET ((uint8_t)0xFF)
#define | NAND_CMD_AREA_A ((uint8_t)0x00)
#define | NAND_CMD_AREA_B ((uint8_t)0x01)
#define | NAND_CMD_AREA_C ((uint8_t)0x50)
#define | NAND_CMD_AREA_TRUE1 ((uint8_t)0x30)
#define | NAND_CMD_WRITE0 ((uint8_t)0x80)
#define | NAND_CMD_WRITE_TRUE1 ((uint8_t)0x10)
#define | NAND_CMD_ERASE0 ((uint8_t)0x60)
#define | NAND_CMD_ERASE1 ((uint8_t)0xD0)
#define | NAND_CMD_READID ((uint8_t)0x90)
#define | NAND_CMD_STATUS ((uint8_t)0x70)
#define | NAND_CMD_LOCK_STATUS ((uint8_t)0x7A)
#define | NAND_CMD_RESET ((uint8_t)0xFF)
#define | NAND_CMD_AREA_A ((uint8_t)0x00)
#define | NAND_CMD_AREA_B ((uint8_t)0x01)
#define | NAND_CMD_AREA_C ((uint8_t)0x50)
#define | NAND_CMD_AREA_TRUE1 ((uint8_t)0x30)
#define | NAND_CMD_WRITE0 ((uint8_t)0x80)
#define | NAND_CMD_WRITE_TRUE1 ((uint8_t)0x10)
#define | NAND_CMD_ERASE0 ((uint8_t)0x60)
#define | NAND_CMD_ERASE1 ((uint8_t)0xD0)
#define | NAND_CMD_READID ((uint8_t)0x90)
#define | NAND_CMD_STATUS ((uint8_t)0x70)
#define | NAND_CMD_LOCK_STATUS ((uint8_t)0x7A)
#define | NAND_CMD_RESET ((uint8_t)0xFF)
#define | NAND_CMD_AREA_A ((uint8_t)0x00)
#define | NAND_CMD_AREA_B ((uint8_t)0x01)
#define | NAND_CMD_AREA_C ((uint8_t)0x50)
#define | NAND_CMD_AREA_TRUE1 ((uint8_t)0x30)
#define | NAND_CMD_WRITE0 ((uint8_t)0x80)
#define | NAND_CMD_WRITE_TRUE1 ((uint8_t)0x10)
#define | NAND_CMD_ERASE0 ((uint8_t)0x60)
#define | NAND_CMD_ERASE1 ((uint8_t)0xD0)
#define | NAND_CMD_READID ((uint8_t)0x90)
#define | NAND_CMD_STATUS ((uint8_t)0x70)
#define | NAND_CMD_LOCK_STATUS ((uint8_t)0x7A)
#define | NAND_CMD_RESET ((uint8_t)0xFF)

Detailed Description

Macro Definition Documentation

◆ NAND_CMD_AREA_A [1/4]

#define NAND_CMD_AREA_A ((uint8_t)0x00)

Definition at line 111 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_CMD_AREA_A [2/4]

#define NAND_CMD_AREA_A ((uint8_t)0x00)

Definition at line 112 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_CMD_AREA_A [3/4]

#define NAND_CMD_AREA_A ((uint8_t)0x00)

Definition at line 111 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_CMD_AREA_A [4/4]

#define NAND_CMD_AREA_A ((uint8_t)0x00)

Definition at line 112 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_CMD_AREA_B [1/4]

#define NAND_CMD_AREA_B ((uint8_t)0x01)

Definition at line 112 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_CMD_AREA_B [2/4]

#define NAND_CMD_AREA_B ((uint8_t)0x01)

Definition at line 113 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_CMD_AREA_B [3/4]

#define NAND_CMD_AREA_B ((uint8_t)0x01)

Definition at line 112 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_CMD_AREA_B [4/4]

#define NAND_CMD_AREA_B ((uint8_t)0x01)

Definition at line 113 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_CMD_AREA_C [1/4]

#define NAND_CMD_AREA_C ((uint8_t)0x50)

Definition at line 113 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_CMD_AREA_C [2/4]

#define NAND_CMD_AREA_C ((uint8_t)0x50)

Definition at line 114 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_CMD_AREA_C [3/4]

#define NAND_CMD_AREA_C ((uint8_t)0x50)

Definition at line 113 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_CMD_AREA_C [4/4]

#define NAND_CMD_AREA_C ((uint8_t)0x50)

Definition at line 114 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_CMD_AREA_TRUE1 [1/4]

#define NAND_CMD_AREA_TRUE1 ((uint8_t)0x30)

Definition at line 114 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_CMD_AREA_TRUE1 [2/4]

#define NAND_CMD_AREA_TRUE1 ((uint8_t)0x30)

Definition at line 115 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_CMD_AREA_TRUE1 [3/4]

#define NAND_CMD_AREA_TRUE1 ((uint8_t)0x30)

Definition at line 114 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_CMD_AREA_TRUE1 [4/4]

#define NAND_CMD_AREA_TRUE1 ((uint8_t)0x30)

Definition at line 115 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_CMD_ERASE0 [1/4]

#define NAND_CMD_ERASE0 ((uint8_t)0x60)

Definition at line 119 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_CMD_ERASE0 [2/4]

#define NAND_CMD_ERASE0 ((uint8_t)0x60)

Definition at line 120 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_CMD_ERASE0 [3/4]

#define NAND_CMD_ERASE0 ((uint8_t)0x60)

Definition at line 119 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_CMD_ERASE0 [4/4]

#define NAND_CMD_ERASE0 ((uint8_t)0x60)

Definition at line 120 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_CMD_ERASE1 [1/4]

#define NAND_CMD_ERASE1 ((uint8_t)0xD0)

Definition at line 120 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_CMD_ERASE1 [2/4]

#define NAND_CMD_ERASE1 ((uint8_t)0xD0)

Definition at line 121 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_CMD_ERASE1 [3/4]

#define NAND_CMD_ERASE1 ((uint8_t)0xD0)

Definition at line 120 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_CMD_ERASE1 [4/4]

#define NAND_CMD_ERASE1 ((uint8_t)0xD0)

Definition at line 121 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_CMD_LOCK_STATUS [1/4]

#define NAND_CMD_LOCK_STATUS ((uint8_t)0x7A)

Definition at line 124 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_CMD_LOCK_STATUS [2/4]

#define NAND_CMD_LOCK_STATUS ((uint8_t)0x7A)

Definition at line 125 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_CMD_LOCK_STATUS [3/4]

#define NAND_CMD_LOCK_STATUS ((uint8_t)0x7A)

Definition at line 124 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_CMD_LOCK_STATUS [4/4]

#define NAND_CMD_LOCK_STATUS ((uint8_t)0x7A)

Definition at line 125 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_CMD_READID [1/4]

#define NAND_CMD_READID ((uint8_t)0x90)

Definition at line 122 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_CMD_READID [2/4]

#define NAND_CMD_READID ((uint8_t)0x90)

Definition at line 123 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_CMD_READID [3/4]

#define NAND_CMD_READID ((uint8_t)0x90)

Definition at line 122 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_CMD_READID [4/4]

#define NAND_CMD_READID ((uint8_t)0x90)

Definition at line 123 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_CMD_RESET [1/4]

#define NAND_CMD_RESET ((uint8_t)0xFF)

Definition at line 125 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_CMD_RESET [2/4]

#define NAND_CMD_RESET ((uint8_t)0xFF)

Definition at line 126 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_CMD_RESET [3/4]

#define NAND_CMD_RESET ((uint8_t)0xFF)

Definition at line 125 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_CMD_RESET [4/4]

#define NAND_CMD_RESET ((uint8_t)0xFF)

Definition at line 126 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_CMD_STATUS [1/4]

#define NAND_CMD_STATUS ((uint8_t)0x70)

Definition at line 123 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_CMD_STATUS [2/4]

#define NAND_CMD_STATUS ((uint8_t)0x70)

Definition at line 124 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_CMD_STATUS [3/4]

#define NAND_CMD_STATUS ((uint8_t)0x70)

Definition at line 123 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_CMD_STATUS [4/4]

#define NAND_CMD_STATUS ((uint8_t)0x70)

Definition at line 124 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_CMD_WRITE0 [1/4]

#define NAND_CMD_WRITE0 ((uint8_t)0x80)

Definition at line 116 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_CMD_WRITE0 [2/4]

#define NAND_CMD_WRITE0 ((uint8_t)0x80)

Definition at line 117 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_CMD_WRITE0 [3/4]

#define NAND_CMD_WRITE0 ((uint8_t)0x80)

Definition at line 116 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_CMD_WRITE0 [4/4]

#define NAND_CMD_WRITE0 ((uint8_t)0x80)

Definition at line 117 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_CMD_WRITE_TRUE1 [1/4]

#define NAND_CMD_WRITE_TRUE1 ((uint8_t)0x10)

Definition at line 117 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_CMD_WRITE_TRUE1 [2/4]

#define NAND_CMD_WRITE_TRUE1 ((uint8_t)0x10)

Definition at line 118 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_CMD_WRITE_TRUE1 [3/4]

#define NAND_CMD_WRITE_TRUE1 ((uint8_t)0x10)

Definition at line 117 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_CMD_WRITE_TRUE1 [4/4]

#define NAND_CMD_WRITE_TRUE1 ((uint8_t)0x10)

Definition at line 118 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.


AT32F435/437 Firmwary Library: XMC_nand_status

Macros
XMC_nand_status
AT32F435_periph_examples | AT32F437_periph_examples » XMC_nand_ecc | AT32F435_periph_examples | AT32F437_periph_examples » XMC_nand

Macros

#define | NAND_VALID_ADDRESS ((uint32_t)0x00000100)
#define | NAND_INVALID_ADDRESS ((uint32_t)0x00000200)
#define | NAND_TIMEOUT_ERROR ((uint32_t)0x00000400)
#define | NAND_BUSY ((uint32_t)0x00000000)
#define | NAND_ERROR ((uint32_t)0x00000001)
#define | NAND_READY ((uint32_t)0x00000040)
#define | NAND_VALID_ADDRESS ((uint32_t)0x00000100)
#define | NAND_INVALID_ADDRESS ((uint32_t)0x00000200)
#define | NAND_TIMEOUT_ERROR ((uint32_t)0x00000400)
#define | NAND_BUSY ((uint32_t)0x00000000)
#define | NAND_ERROR ((uint32_t)0x00000001)
#define | NAND_READY ((uint32_t)0x00000040)
#define | NAND_VALID_ADDRESS ((uint32_t)0x00000100)
#define | NAND_INVALID_ADDRESS ((uint32_t)0x00000200)
#define | NAND_TIMEOUT_ERROR ((uint32_t)0x00000400)
#define | NAND_BUSY ((uint32_t)0x00000000)
#define | NAND_ERROR ((uint32_t)0x00000001)
#define | NAND_READY ((uint32_t)0x00000040)
#define | NAND_VALID_ADDRESS ((uint32_t)0x00000100)
#define | NAND_INVALID_ADDRESS ((uint32_t)0x00000200)
#define | NAND_TIMEOUT_ERROR ((uint32_t)0x00000400)
#define | NAND_BUSY ((uint32_t)0x00000000)
#define | NAND_ERROR ((uint32_t)0x00000001)
#define | NAND_READY ((uint32_t)0x00000040)

Detailed Description

Macro Definition Documentation

◆ NAND_BUSY [1/4]

#define NAND_BUSY ((uint32_t)0x00000000)

Definition at line 139 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_BUSY [2/4]

#define NAND_BUSY ((uint32_t)0x00000000)

Definition at line 140 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_BUSY [3/4]

#define NAND_BUSY ((uint32_t)0x00000000)

Definition at line 139 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_BUSY [4/4]

#define NAND_BUSY ((uint32_t)0x00000000)

Definition at line 140 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_ERROR [1/4]

#define NAND_ERROR ((uint32_t)0x00000001)

Definition at line 140 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_ERROR [2/4]

#define NAND_ERROR ((uint32_t)0x00000001)

Definition at line 141 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_ERROR [3/4]

#define NAND_ERROR ((uint32_t)0x00000001)

Definition at line 140 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_ERROR [4/4]

#define NAND_ERROR ((uint32_t)0x00000001)

Definition at line 141 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_INVALID_ADDRESS [1/4]

#define NAND_INVALID_ADDRESS ((uint32_t)0x00000200)

Definition at line 137 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_INVALID_ADDRESS [2/4]

#define NAND_INVALID_ADDRESS ((uint32_t)0x00000200)

Definition at line 138 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_INVALID_ADDRESS [3/4]

#define NAND_INVALID_ADDRESS ((uint32_t)0x00000200)

Definition at line 137 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_INVALID_ADDRESS [4/4]

#define NAND_INVALID_ADDRESS ((uint32_t)0x00000200)

Definition at line 138 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_READY [1/4]

#define NAND_READY ((uint32_t)0x00000040)

Definition at line 141 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_READY [2/4]

#define NAND_READY ((uint32_t)0x00000040)

Definition at line 142 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_READY [3/4]

#define NAND_READY ((uint32_t)0x00000040)

Definition at line 141 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_READY [4/4]

#define NAND_READY ((uint32_t)0x00000040)

Definition at line 142 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_TIMEOUT_ERROR [1/4]

#define NAND_TIMEOUT_ERROR ((uint32_t)0x00000400)

Definition at line 138 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_TIMEOUT_ERROR [2/4]

#define NAND_TIMEOUT_ERROR ((uint32_t)0x00000400)

Definition at line 139 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_TIMEOUT_ERROR [3/4]

#define NAND_TIMEOUT_ERROR ((uint32_t)0x00000400)

Definition at line 138 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_TIMEOUT_ERROR [4/4]

#define NAND_TIMEOUT_ERROR ((uint32_t)0x00000400)

Definition at line 139 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_VALID_ADDRESS [1/4]

#define NAND_VALID_ADDRESS ((uint32_t)0x00000100)

Definition at line 136 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_VALID_ADDRESS [2/4]

#define NAND_VALID_ADDRESS ((uint32_t)0x00000100)

Definition at line 137 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ NAND_VALID_ADDRESS [3/4]

#define NAND_VALID_ADDRESS ((uint32_t)0x00000100)

Definition at line 136 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ NAND_VALID_ADDRESS [4/4]

#define NAND_VALID_ADDRESS ((uint32_t)0x00000100)

Definition at line 137 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.


AT32F435/437 Firmwary Library: XMC_nand_parameters

XMC_nand_parameters
AT32F435_periph_examples | AT32F437_periph_examples » XMC_nand_ecc | AT32F435_periph_examples | AT32F437_periph_examples » XMC_nand


AT32F435/437 Firmwary Library: XMC_nand_address_computation

Macros
XMC_nand_address_computation
AT32F435_periph_examples | AT32F437_periph_examples » XMC_nand_ecc | AT32F435_periph_examples | AT32F437_periph_examples » XMC_nand

Macros

#define | addr_1st_cycle(addr) (uint8_t)((addr) & 0xFF)
#define | addr_2nd_cycle(addr) (uint8_t)(((addr) & 0xFF00) >> 8)
#define | addr_3rd_cycle(addr) (uint8_t)(((addr) & 0xFF0000) >> 16)
#define | addr_4th_cycle(addr) (uint8_t)(((addr) & 0xFF000000) >> 24)
#define | addr_1st_cycle(addr) (uint8_t)((addr) & (uint32_t)0x000000FF)
#define | addr_2nd_cycle(addr) (uint8_t)(((addr) & (uint32_t)0x0000FF00) >> 8)
#define | addr_3rd_cycle(addr) (uint8_t)(((addr) & (uint32_t)0x00FF0000) >> 16)
#define | addr_4th_cycle(addr) (uint8_t)(((addr) & (uint32_t)0xFF000000) >> 24)
#define | addr_1st_cycle(addr) (uint8_t)((addr) & 0xFF)
#define | addr_2nd_cycle(addr) (uint8_t)(((addr) & 0xFF00) >> 8)
#define | addr_3rd_cycle(addr) (uint8_t)(((addr) & 0xFF0000) >> 16)
#define | addr_4th_cycle(addr) (uint8_t)(((addr) & 0xFF000000) >> 24)
#define | addr_1st_cycle(addr) (uint8_t)((addr) & (uint32_t)0x000000FF)
#define | addr_2nd_cycle(addr) (uint8_t)(((addr) & (uint32_t)0x0000FF00) >> 8)
#define | addr_3rd_cycle(addr) (uint8_t)(((addr) & (uint32_t)0x00FF0000) >> 16)
#define | addr_4th_cycle(addr) (uint8_t)(((addr) & (uint32_t)0xFF000000) >> 24)

Detailed Description

Macro Definition Documentation

◆ addr_1st_cycle [1/4]

#define addr_1st_cycle ( addr ) (uint8_t)((addr) & 0xFF)

Definition at line 186 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ addr_1st_cycle [2/4]

#define addr_1st_cycle ( addr ) (uint8_t)((addr) & (uint32_t)0x000000FF)

Definition at line 187 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ addr_1st_cycle [3/4]

#define addr_1st_cycle ( addr ) (uint8_t)((addr) & 0xFF)

Definition at line 186 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ addr_1st_cycle [4/4]

#define addr_1st_cycle ( addr ) (uint8_t)((addr) & (uint32_t)0x000000FF)

Definition at line 187 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ addr_2nd_cycle [1/4]

#define addr_2nd_cycle ( addr ) (uint8_t)(((addr) & 0xFF00) >> 8)

Definition at line 188 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ addr_2nd_cycle [2/4]

#define addr_2nd_cycle ( addr ) (uint8_t)(((addr) & (uint32_t)0x0000FF00) >> 8)

Definition at line 189 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ addr_2nd_cycle [3/4]

#define addr_2nd_cycle ( addr ) (uint8_t)(((addr) & 0xFF00) >> 8)

Definition at line 188 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ addr_2nd_cycle [4/4]

#define addr_2nd_cycle ( addr ) (uint8_t)(((addr) & (uint32_t)0x0000FF00) >> 8)

Definition at line 189 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ addr_3rd_cycle [1/4]

#define addr_3rd_cycle ( addr ) (uint8_t)(((addr) & 0xFF0000) >> 16)

Definition at line 190 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ addr_3rd_cycle [2/4]

#define addr_3rd_cycle ( addr ) (uint8_t)(((addr) & (uint32_t)0x00FF0000) >> 16)

Definition at line 191 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ addr_3rd_cycle [3/4]

#define addr_3rd_cycle ( addr ) (uint8_t)(((addr) & 0xFF0000) >> 16)

Definition at line 190 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ addr_3rd_cycle [4/4]

#define addr_3rd_cycle ( addr ) (uint8_t)(((addr) & (uint32_t)0x00FF0000) >> 16)

Definition at line 191 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ addr_4th_cycle [1/4]

#define addr_4th_cycle ( addr ) (uint8_t)(((addr) & 0xFF000000) >> 24)

Definition at line 192 of file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ addr_4th_cycle [2/4]

#define addr_4th_cycle ( addr ) (uint8_t)(((addr) & (uint32_t)0xFF000000) >> 24)

Definition at line 193 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ addr_4th_cycle [3/4]

#define addr_4th_cycle ( addr ) (uint8_t)(((addr) & 0xFF000000) >> 24)

Definition at line 192 of file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.

◆ addr_4th_cycle [4/4]

#define addr_4th_cycle ( addr ) (uint8_t)(((addr) & (uint32_t)0xFF000000) >> 24)

Definition at line 193 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.


AT32F435/437 Firmwary Library: XMC_nand_ecc_functions

Functions
XMC_nand_ecc_functions
AT32F435_periph_examples | AT32F437_periph_examples » XMC_nand_ecc

Functions

void | nand_init (void)
configures the xmc and gpios to interface with the nand memory. this function must be called before any write/read operation on the nand. More...
void | nand_read_id (nand_id_type *nand_id_struct)
reads nand memory's id. More...
uint32_t | nand_write_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write)
this routine is for writing one or several 512 bytes page size. More...
uint32_t | nand_read_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read)
this routine is for sequential read from one or several 512 bytes page size. More...
uint32_t | nand_write_spare_area (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write)
this routine write the spare area information for the specified pages addresses. More...
uint32_t | nand_read_spare_area (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read)
this routine read the spare area information from the specified pages addresses. More...
uint32_t | nand_erase_block (nand_address_type address_struct)
this routine erase complete block from nand flash More...
uint32_t | nand_reset (void)
this routine reset the nand flash. More...
uint32_t | nand_get_status (void)
get the nand operation status. More...
uint32_t | nand_read_status (void)
reads the nand memory status using the read status command. More...
uint32_t | nand_address_increment (nand_address_type *address_struct)
increment the nand memory address. More...

Detailed Description

Function Documentation

◆ nand_address_increment()

uint32_t nand_address_increment ( nand_address_type * address_struct )

increment the nand memory address.

Parameters
address address to be incremented.
Return values
the new status of the increment address operation. it can be:
  • NAND_VALID_ADDRESS: when the new address is valid address
  • NAND_INVALID_ADDRESS: when the new address is invalid address

Definition at line 502 of file at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

Referenced by nand_read_small_page(), nand_read_spare_area(), nand_write_small_page(), and nand_write_spare_area().

◆ nand_erase_block()

uint32_t nand_erase_block ( nand_address_type address_struct )

this routine erase complete block from nand flash

Parameters
address any address into block to be erased
Return values
new status of the nand operation. this parameter can be:
  • NAND_TIMEOUT_ERROR: when the previous operation generate a timeout error
  • NAND_READY: when memory is ready for the next operation

Definition at line 403 of file at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

Referenced by main().

◆ nand_get_status()

uint32_t nand_get_status ( void )

get the nand operation status.

Parameters
none
Return values
new status of the nand operation. this parameter can be:
  • NAND_TIMEOUT_ERROR: when the previous operation generate a timeout error
  • NAND_READY: when memory is ready for the next operation

Definition at line 441 of file at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

Referenced by nand_erase_block(), nand_read_small_page(), nand_read_spare_area(), nand_write_small_page(), and nand_write_spare_area().

◆ nand_init()

void nand_init ( void )

configures the xmc and gpios to interface with the nand memory. this function must be called before any write/read operation on the nand.

Parameters
none
Return values
none

Definition at line 44 of file at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

Referenced by main().

◆ nand_read_id()

void nand_read_id ( nand_id_type * nand_id_struct )

reads nand memory's id.

Parameters
nand_id pointer to a nand_id_type structure which will hold the manufacturer and device id.
Return values
none

Definition at line 120 of file at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

Referenced by main().

◆ nand_read_small_page()

uint32_t nand_read_small_page | ( | uint8_t * | pbuffer,
 |  | nand_address_type | address_struct,
 |  | uint32_t | num_page_to_read
 | ) |  |

this routine is for sequential read from one or several 512 bytes page size.

Parameters
pbuffer | pointer on the buffer to fill
address | first page address
num_page_to_read | number of page to read
Return values
new status of the nand operation. this parameter can be:
  • NAND_TIMEOUT_ERROR: when the previous operation generate a timeout error
  • NAND_READY: when memory is ready for the next operation and the new status of the increment address operation. it can be:
  • NAND_VALID_ADDRESS: when the new address is valid address
  • NAND_INVALID_ADDRESS: when the new address is invalid address

Definition at line 228 of file at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

Referenced by main().

◆ nand_read_spare_area()

uint32_t nand_read_spare_area | ( | uint8_t * | pbuffer,
 |  | nand_address_type | address_struct,
 |  | uint32_t | num_spare_area_to_read
 | ) |  |

this routine read the spare area information from the specified pages addresses.

Parameters
pbuffer | pointer on the buffer to fill
address | first page address
num_spare_area_to_read | number of spare area to read
Return values
new status of the nand operation. this parameter can be:
  • NAND_TIMEOUT_ERROR: when the previous operation generate a timeout error
  • NAND_READY: when memory is ready for the next operation and the new status of the increment address operation. it can be:
  • NAND_VALID_ADDRESS: when the new address is valid address
  • NAND_INVALID_ADDRESS: when the new address is invalid address

Definition at line 353 of file at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

◆ nand_read_status()

uint32_t nand_read_status ( void )

reads the nand memory status using the read status command.

Parameters
none
Return values
the status of the nand memory. this parameter can be:
  • NAND_BUSY: when memory is busy
  • NAND_READY: when memory is ready for the next operation
  • NAND_ERROR: when the previous operation gererates error

Definition at line 471 of file at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

Referenced by nand_get_status().

◆ nand_reset()

uint32_t nand_reset ( void )

this routine reset the nand flash.

Parameters
none
Return values
NAND_READY

Definition at line 426 of file at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

Referenced by main().

◆ nand_write_small_page()

uint32_t nand_write_small_page | ( | uint8_t * | pbuffer,
 |  | nand_address_type | address_struct,
 |  | uint32_t | num_page_to_write
 | ) |  |

this routine is for writing one or several 512 bytes page size.

Parameters
pbuffer | pointer on the buffer containing data to be written
address | first page address
num_page_to_write | number of page to write
Return values
new status of the nand operation. this parameter can be:
  • NAND_TIMEOUT_ERROR: when the previous operation generate a timeout error
  • NAND_READY: when memory is ready for the next operation and the new status of the increment address operation. it can be:
  • NAND_VALID_ADDRESS: when the new address is valid address
  • NAND_INVALID_ADDRESS: when the new address is invalid address

Definition at line 161 of file at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

Referenced by main().

◆ nand_write_spare_area()

uint32_t nand_write_spare_area | ( | uint8_t * | pbuffer,
 |  | nand_address_type | address_struct,
 |  | uint32_t | num_spare_area_to_write
 | ) |  |

this routine write the spare area information for the specified pages addresses.

Parameters
pbuffer | pointer on the buffer containing data to be written
address | first page address
num_spare_area_to_write | number of spare area to write
Return values
new status of the nand operation. this parameter can be:
  • NAND_TIMEOUT_ERROR: when the previous operation generate a timeout error
  • NAND_READY: when memory is ready for the next operation and the new status of the increment address operation. it can be:
  • NAND_VALID_ADDRESS: when the new address is valid address
  • NAND_INVALID_ADDRESS: when the new address is invalid address

Definition at line 294 of file at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.


AT32F435/437 Firmwary Library: XMC_nand

Modules | Macros | Functions | Variables
XMC_nand
AT32F435_periph_examples | AT32F437_periph_examples

Modules

NAND_id_define
NAND_address_define
NAND_area_define
XMC_nand_memory_command
XMC_nand_status
XMC_nand_parameters
XMC_nand_address_computation
XMC_nand_functions

Macros

#define | ROW_ADDRESS (address_struct.page + (address_struct.block + (address_struct.zone * NAND_ZONE_SIZE)) * NAND_BLOCK_SIZE)
#define | COL_ADDRESS address_struct.byte
#define | BUFFER_SIZE NAND_PAGE_SIZE
#define | XMC_Bank_NAND XMC_Bank2_NAND
#define | Bank_NAND_ADDR Bank2_NAND_ADDR
#define | Bank2_NAND_ADDR ((uint32_t)0x70000000)
#define | ROW_ADDRESS (address_struct.page + (address_struct.block + (address_struct.zone * NAND_ZONE_SIZE)) * NAND_BLOCK_SIZE)
#define | COL_ADDRESS address_struct.byte
#define | BUFFER_SIZE NAND_PAGE_SIZE
#define | XMC_Bank_NAND XMC_Bank2_NAND
#define | Bank_NAND_ADDR Bank2_NAND_ADDR
#define | Bank2_NAND_ADDR ((uint32_t)0x70000000)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | fill_buffer (uint8_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...
int | main (void)
main function. More...
void | nand_init (void)
configures the xmc and gpios to interface with the nand memory. this function must be called before any write/read operation on the nand. More...
void | nand_read_id (nand_id_type *nand_id_struct)
reads nand memory's id. More...
uint32_t | nand_write_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write)
this routine is for writing one or several 512 bytes page size. More...
uint32_t | nand_read_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read)
this routine is for sequential read from one or several 512 bytes page size. More...
uint32_t | nand_write_spare_area (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write)
this routine write the spare area information for the specified pages addresses. More...
uint32_t | nand_read_spare_area (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read)
this routine read the spare area information from the specified pages addresses. More...
uint32_t | nand_erase_block (nand_address_type address_struct)
this routine erase complete block from nand flash More...
uint32_t | nand_reset (void)
this routine reset the nand flash. More...
uint32_t | nand_get_status (void)
get the nand operation status. More...
uint32_t | nand_read_status (void)
reads the nand memory status using the read status command. More...
uint32_t | nand_address_increment (nand_address_type *address_struct)
increment the nand memory address. More...

Variables

crm_clocks_freq_type | crm_clocks_freq_struct = {0}
nand_id_type | nand_id_struct = {0}
nand_address_type write_read_addr_struct
uint8_t | txbuffer [BUFFER_SIZE]
uint8_t | rxbuffer [BUFFER_SIZE+NAND_SPARE_AREA_SIZE]
uint32_t | pagenumber = BUFFER_SIZE / NAND_PAGE_SIZE
uint32_t | writereadstatus = 0
uint32_t | status = 0
uint32_t | j = 0
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
nand_id_type | nand_id_struct = {0}
nand_address_type write_read_addr_struct
uint8_t | txbuffer [BUFFER_SIZE]
uint8_t | rxbuffer [BUFFER_SIZE+NAND_SPARE_AREA_SIZE]
uint32_t | pagenumber = BUFFER_SIZE / NAND_PAGE_SIZE
uint32_t | writereadstatus = 0
uint32_t | status = 0
uint32_t | j = 0

Detailed Description

Macro Definition Documentation

◆ Bank2_NAND_ADDR [1/2]

#define Bank2_NAND_ADDR ((uint32_t)0x70000000)

Definition at line 83 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ Bank2_NAND_ADDR [2/2]

#define Bank2_NAND_ADDR ((uint32_t)0x70000000)

Definition at line 83 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ Bank_NAND_ADDR [1/2]

#define Bank_NAND_ADDR Bank2_NAND_ADDR

Definition at line 82 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ Bank_NAND_ADDR [2/2]

#define Bank_NAND_ADDR Bank2_NAND_ADDR

Definition at line 82 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ BUFFER_SIZE [1/2]

#define BUFFER_SIZE NAND_PAGE_SIZE

Definition at line 79 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ BUFFER_SIZE [2/2]

#define BUFFER_SIZE NAND_PAGE_SIZE

Definition at line 79 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ COL_ADDRESS [1/2]

#define COL_ADDRESS address_struct.byte

Definition at line 77 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ COL_ADDRESS [2/2]

#define COL_ADDRESS address_struct.byte

Definition at line 77 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ ROW_ADDRESS [1/2]

#define ROW_ADDRESS (address_struct.page + (address_struct.block + (address_struct.zone * NAND_ZONE_SIZE)) * NAND_BLOCK_SIZE)

Definition at line 76 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ ROW_ADDRESS [2/2]

#define ROW_ADDRESS (address_struct.page + (address_struct.block + (address_struct.zone * NAND_ZONE_SIZE)) * NAND_BLOCK_SIZE)

Definition at line 76 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ XMC_Bank_NAND [1/2]

#define XMC_Bank_NAND XMC_Bank2_NAND

Definition at line 81 of file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

◆ XMC_Bank_NAND [2/2]

#define XMC_Bank_NAND XMC_Bank2_NAND

Definition at line 81 of file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c.

◆ fill_buffer()

void fill_buffer | ( | uint8_t * | pbuffer,
 |  | uint16_t | bufferlenght,
 |  | uint32_t | offset
 | ) |  |

fill the global buffer

Parameters
pbuffer | pointer on the buffer to fill
buffersize | size of the buffer to fill
offset | first value to fill on the buffer

Definition at line 140 of file project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c.

◆ nand_address_increment()

uint32_t nand_address_increment ( nand_address_type * address_struct )

increment the nand memory address.

Parameters
address address to be incremented.
Return values
the new status of the increment address operation. it can be:
  • NAND_VALID_ADDRESS: when the new address is valid address
  • NAND_INVALID_ADDRESS: when the new address is invalid address

Definition at line 496 of file at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c.

Referenced by nand_read_small_page(), nand_read_spare_area(), nand_write_small_page(), and nand_write_spare_area().

◆ nand_erase_block()

uint32_t nand_erase_block ( nand_address_type address_struct )

this routine erase complete block from nand flash

Parameters
address any address into block to be erased
Return values
new status of the nand operation. this parameter can be:
  • NAND_TIMEOUT_ERROR: when the previous operation generate a timeout error
  • NAND_READY: when memory is ready for the next operation

Definition at line 398 of file at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c.

Referenced by main().

◆ nand_get_status()

uint32_t nand_get_status ( void )

get the nand operation status.

Parameters
none
Return values
new status of the nand operation. this parameter can be:
  • NAND_TIMEOUT_ERROR: when the previous operation generate a timeout error
  • NAND_READY: when memory is ready for the next operation

Definition at line 435 of file at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c.

Referenced by nand_erase_block(), nand_read_small_page(), nand_read_spare_area(), nand_write_small_page(), and nand_write_spare_area().

◆ nand_init()

void nand_init ( void )

configures the xmc and gpios to interface with the nand memory. this function must be called before any write/read operation on the nand.

Parameters
none
Return values
none

Definition at line 43 of file at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c.

Referenced by main().

◆ nand_read_id()

void nand_read_id ( nand_id_type * nand_id_struct )

reads nand memory's id.

Parameters
nand_id pointer to a nand_id_type structure which will hold the manufacturer and device id.
Return values
none

Definition at line 124 of file at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c.

Referenced by main().

◆ nand_read_small_page()

uint32_t nand_read_small_page | ( | uint8_t * | pbuffer,
 |  | nand_address_type | address_struct,
 |  | uint32_t | num_page_to_read
 | ) |  |

this routine is for sequential read from one or several 512 bytes page size.

Parameters
pbuffer | pointer on the buffer to fill
address | first page address
num_page_to_read | number of page to read
Return values
new status of the nand operation. this parameter can be:
  • NAND_TIMEOUT_ERROR: when the previous operation generate a timeout error
  • NAND_READY: when memory is ready for the next operation and the new status of the increment address operation. it can be:
  • NAND_VALID_ADDRESS: when the new address is valid address
  • NAND_INVALID_ADDRESS: when the new address is invalid address

Definition at line 228 of file at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c.

Referenced by main().

◆ nand_read_spare_area()

uint32_t nand_read_spare_area | ( | uint8_t * | pbuffer,
 |  | nand_address_type | address_struct,
 |  | uint32_t | num_spare_area_to_read
 | ) |  |

this routine read the spare area information from the specified pages addresses.

Parameters
pbuffer | pointer on the buffer to fill
address | first page address
num_spare_area_to_read | number of spare area to read
Return values
new status of the nand operation. this parameter can be:
  • NAND_TIMEOUT_ERROR: when the previous operation generate a timeout error
  • NAND_READY: when memory is ready for the next operation and the new status of the increment address operation. it can be:
  • NAND_VALID_ADDRESS: when the new address is valid address
  • NAND_INVALID_ADDRESS: when the new address is invalid address

Definition at line 348 of file at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c.

◆ nand_read_status()

uint32_t nand_read_status ( void )

reads the nand memory status using the read status command.

Parameters
none
Return values
the status of the nand memory. this parameter can be:
  • NAND_BUSY: when memory is busy
  • NAND_READY: when memory is ready for the next operation
  • NAND_ERROR: when the previous operation gererates error

Definition at line 465 of file at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c.

Referenced by nand_get_status().

◆ nand_reset()

uint32_t nand_reset ( void )

this routine reset the nand flash.

Parameters
none
Return values
NAND_READY

Definition at line 420 of file at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c.

Referenced by main().

◆ nand_write_small_page()

uint32_t nand_write_small_page | ( | uint8_t * | pbuffer,
 |  | nand_address_type | address_struct,
 |  | uint32_t | num_page_to_write
 | ) |  |

this routine is for writing one or several 512 bytes page size.

Parameters
pbuffer | pointer on the buffer containing data to be written
address | first page address
num_page_to_write | number of page to write
Return values
new status of the nand operation. this parameter can be:
  • NAND_TIMEOUT_ERROR: when the previous operation generate a timeout error
  • NAND_READY: when memory is ready for the next operation and the new status of the increment address operation. it can be:
  • NAND_VALID_ADDRESS: when the new address is valid address
  • NAND_INVALID_ADDRESS: when the new address is invalid address

Definition at line 165 of file at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c.

Referenced by main().

◆ nand_write_spare_area()

uint32_t nand_write_spare_area | ( | uint8_t * | pbuffer,
 |  | nand_address_type | address_struct,
 |  | uint32_t | num_spare_area_to_write
 | ) |  |

this routine write the spare area information for the specified pages addresses.

Parameters
pbuffer | pointer on the buffer containing data to be written
address | first page address
num_spare_area_to_write | number of spare area to write
Return values
new status of the nand operation. this parameter can be:
  • NAND_TIMEOUT_ERROR: when the previous operation generate a timeout error
  • NAND_READY: when memory is ready for the next operation and the new status of the increment address operation. it can be:
  • NAND_VALID_ADDRESS: when the new address is valid address
  • NAND_INVALID_ADDRESS: when the new address is invalid address

Definition at line 290 of file at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c.

Variable Documentation

◆ crm_clocks_freq_struct [1/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct [2/2]

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c.

◆ j [1/2]

uint32_t j = 0

Definition at line 44 of file project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c.

Referenced by main().

◆ j [2/2]

uint32_t j = 0

Definition at line 44 of file project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c.

◆ nand_id_struct [1/2]

nand_id_type nand_id_struct = {0}

Definition at line 40 of file project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c.

Referenced by main().

◆ nand_id_struct [2/2]

nand_id_type nand_id_struct = {0}

Definition at line 40 of file project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c.

◆ pagenumber [1/2]

uint32_t pagenumber = BUFFER_SIZE / NAND_PAGE_SIZE

Definition at line 43 of file project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c.

Referenced by main().

◆ pagenumber [2/2]

uint32_t pagenumber = BUFFER_SIZE / NAND_PAGE_SIZE

Definition at line 43 of file project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c.

◆ rxbuffer [1/2]

uint8_t rxbuffer[BUFFER_SIZE+NAND_SPARE_AREA_SIZE]

Definition at line 42 of file project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c.

Referenced by main().

◆ rxbuffer [2/2]

uint8_t rxbuffer[BUFFER_SIZE+NAND_SPARE_AREA_SIZE]

Definition at line 42 of file project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c.

◆ status [1/2]

uint32_t status = 0

Definition at line 43 of file project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c.

Referenced by main().

◆ status [2/2]

uint32_t status = 0

Definition at line 43 of file project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c.

◆ txbuffer [1/2]

uint8_t txbuffer[BUFFER_SIZE]

Definition at line 42 of file project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c.

Referenced by main().

◆ txbuffer [2/2]

uint8_t txbuffer[BUFFER_SIZE]

Definition at line 42 of file project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c.

◆ write_read_addr_struct [1/2]

nand_address_type write_read_addr_struct

Definition at line 41 of file project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c.

Referenced by main().

◆ write_read_addr_struct [2/2]

nand_address_type write_read_addr_struct

Definition at line 41 of file project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c.

◆ writereadstatus [1/2]

uint32_t writereadstatus = 0

Definition at line 43 of file project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c.

Referenced by main().

◆ writereadstatus [2/2]

uint32_t writereadstatus = 0

Definition at line 43 of file project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c.


AT32F435/437 Firmwary Library: XMC_nand_functions

Functions
XMC_nand_functions
AT32F435_periph_examples | AT32F437_periph_examples » XMC_nand

Functions

void | nand_init (void)
configures the xmc and gpios to interface with the nand memory. this function must be called before any write/read operation on the nand. More...
void | nand_read_id (nand_id_type *nand_id_struct)
reads nand memory's id. More...
uint32_t | nand_write_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write)
this routine is for writing one or several 512 bytes page size. More...
uint32_t | nand_read_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read)
this routine is for sequential read from one or several 512 bytes page size. More...
uint32_t | nand_write_spare_area (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write)
this routine write the spare area information for the specified pages addresses. More...
uint32_t | nand_read_spare_area (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read)
this routine read the spare area information from the specified pages addresses. More...
uint32_t | nand_erase_block (nand_address_type address_struct)
this routine erase complete block from nand flash More...
uint32_t | nand_reset (void)
this routine reset the nand flash. More...
uint32_t | nand_get_status (void)
get the nand operation status. More...
uint32_t | nand_read_status (void)
reads the nand memory status using the read status command. More...
uint32_t | nand_address_increment (nand_address_type *address_struct)
increment the nand memory address. More...

Detailed Description

Function Documentation

◆ nand_address_increment()

uint32_t nand_address_increment ( nand_address_type * address_struct )

increment the nand memory address.

Parameters
address address to be incremented.
Return values
the new status of the increment address operation. it can be:
  • NAND_VALID_ADDRESS: when the new address is valid address
  • NAND_INVALID_ADDRESS: when the new address is invalid address

Definition at line 502 of file at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

Referenced by nand_read_small_page(), nand_read_spare_area(), nand_write_small_page(), and nand_write_spare_area().

◆ nand_erase_block()

uint32_t nand_erase_block ( nand_address_type address_struct )

this routine erase complete block from nand flash

Parameters
address any address into block to be erased
Return values
new status of the nand operation. this parameter can be:
  • NAND_TIMEOUT_ERROR: when the previous operation generate a timeout error
  • NAND_READY: when memory is ready for the next operation

Definition at line 403 of file at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

◆ nand_get_status()

uint32_t nand_get_status ( void )

get the nand operation status.

Parameters
none
Return values
new status of the nand operation. this parameter can be:
  • NAND_TIMEOUT_ERROR: when the previous operation generate a timeout error
  • NAND_READY: when memory is ready for the next operation

Definition at line 441 of file at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

Referenced by nand_erase_block(), nand_read_small_page(), nand_read_spare_area(), nand_write_small_page(), and nand_write_spare_area().

◆ nand_init()

void nand_init ( void )

configures the xmc and gpios to interface with the nand memory. this function must be called before any write/read operation on the nand.

Parameters
none
Return values
none

Definition at line 44 of file at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

◆ nand_read_id()

void nand_read_id ( nand_id_type * nand_id_struct )

reads nand memory's id.

Parameters
nand_id pointer to a nand_id_type structure which will hold the manufacturer and device id.
Return values
none

Definition at line 120 of file at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

◆ nand_read_small_page()

uint32_t nand_read_small_page | ( | uint8_t * | pbuffer,
 |  | nand_address_type | address_struct,
 |  | uint32_t | num_page_to_read
 | ) |  |

this routine is for sequential read from one or several 512 bytes page size.

Parameters
pbuffer | pointer on the buffer to fill
address | first page address
num_page_to_read | number of page to read
Return values
new status of the nand operation. this parameter can be:
  • NAND_TIMEOUT_ERROR: when the previous operation generate a timeout error
  • NAND_READY: when memory is ready for the next operation and the new status of the increment address operation. it can be:
  • NAND_VALID_ADDRESS: when the new address is valid address
  • NAND_INVALID_ADDRESS: when the new address is invalid address

Definition at line 228 of file at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

◆ nand_read_spare_area()

uint32_t nand_read_spare_area | ( | uint8_t * | pbuffer,
 |  | nand_address_type | address_struct,
 |  | uint32_t | num_spare_area_to_read
 | ) |  |

this routine read the spare area information from the specified pages addresses.

Parameters
pbuffer | pointer on the buffer to fill
address | first page address
num_spare_area_to_read | number of spare area to read
Return values
new status of the nand operation. this parameter can be:
  • NAND_TIMEOUT_ERROR: when the previous operation generate a timeout error
  • NAND_READY: when memory is ready for the next operation and the new status of the increment address operation. it can be:
  • NAND_VALID_ADDRESS: when the new address is valid address
  • NAND_INVALID_ADDRESS: when the new address is invalid address

Definition at line 353 of file at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

◆ nand_read_status()

uint32_t nand_read_status ( void )

reads the nand memory status using the read status command.

Parameters
none
Return values
the status of the nand memory. this parameter can be:
  • NAND_BUSY: when memory is busy
  • NAND_READY: when memory is ready for the next operation
  • NAND_ERROR: when the previous operation gererates error

Definition at line 471 of file at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

Referenced by nand_get_status().

◆ nand_reset()

uint32_t nand_reset ( void )

this routine reset the nand flash.

Parameters
none
Return values
NAND_READY

Definition at line 426 of file at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

◆ nand_write_small_page()

uint32_t nand_write_small_page | ( | uint8_t * | pbuffer,
 |  | nand_address_type | address_struct,
 |  | uint32_t | num_page_to_write
 | ) |  |

this routine is for writing one or several 512 bytes page size.

Parameters
pbuffer | pointer on the buffer containing data to be written
address | first page address
num_page_to_write | number of page to write
Return values
new status of the nand operation. this parameter can be:
  • NAND_TIMEOUT_ERROR: when the previous operation generate a timeout error
  • NAND_READY: when memory is ready for the next operation and the new status of the increment address operation. it can be:
  • NAND_VALID_ADDRESS: when the new address is valid address
  • NAND_INVALID_ADDRESS: when the new address is invalid address

Definition at line 161 of file at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.

◆ nand_write_spare_area()

uint32_t nand_write_spare_area | ( | uint8_t * | pbuffer,
 |  | nand_address_type | address_struct,
 |  | uint32_t | num_spare_area_to_write
 | ) |  |

this routine write the spare area information for the specified pages addresses.

Parameters
pbuffer | pointer on the buffer containing data to be written
address | first page address
num_spare_area_to_write | number of spare area to write
Return values
new status of the nand operation. this parameter can be:
  • NAND_TIMEOUT_ERROR: when the previous operation generate a timeout error
  • NAND_READY: when memory is ready for the next operation and the new status of the increment address operation. it can be:
  • NAND_VALID_ADDRESS: when the new address is valid address
  • NAND_INVALID_ADDRESS: when the new address is invalid address

Definition at line 294 of file at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.


AT32F435/437 Firmwary Library: XMC_nor_flash

Macros | Functions | Variables
XMC_nor_flash
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | buffer_size 0x400
#define | write_read_addr 0x8000
#define | BANK1_NOR2_ADDR ((uint32_t)0x64000000)
#define | BLOCKERASE_TIMEOUT ((uint32_t)0x00A00000)
#define | CHIPERASE_TIMEOUT ((uint32_t)0x30000000)
#define | PROGRAM_TIMEOUT ((uint32_t)0x00001400)
#define | ADDR_SHIFT(A) (BANK1_NOR2_ADDR + (2 * (A)))
#define | NOR_WRITE(address, data) (*(__IO uint16_t *)(address) = (data))
#define | buffer_size 0x400
#define | write_read_addr 0x8000
#define | BANK1_NOR2_ADDR ((uint32_t)0x64000000)
#define | BLOCKERASE_TIMEOUT ((uint32_t)0x00A00000)
#define | CHIPERASE_TIMEOUT ((uint32_t)0x30000000)
#define | PROGRAM_TIMEOUT ((uint32_t)0x00001400)
#define | ADDR_SHIFT(A) (BANK1_NOR2_ADDR + (2 * (A)))
#define | NOR_WRITE(address, data) (*(__IO uint16_t *)(address) = (data))

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...
void | nor_init (void)
init nor flash interface More...
void | nor_readid (nor_idtype *nor_id)
reads nor memory's manufacturer and device code. More...
nor_status | nor_eraseblock (uint32_t blockaddr)
erases the specified nor memory block. More...
nor_status | nor_erasechip (void)
erases the entire chip. More...
nor_status | nor_writehalfword (uint32_t writeaddr, uint16_t data)
writes a half-word to the nor memory. More...
nor_status | nor_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc nor memory. More...
nor_status | nor_programbuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc nor memory. this function must be used only with s29gl128p nor memory. More...
uint16_t | nor_readhalfword (uint32_t readaddr)
reads a half-word from the nor memory. More...
void | nor_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc nor memory. More...
nor_status | nor_returntoreadmode (void)
returns the nor memory to read mode. More...
nor_status | nor_reset (void)
returns the nor memory to read mode and resets the errors in the nor memory status register. More...
nor_status | nor_getstatus (uint32_t timeout)
returns the nor operation status. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...

Variables

uint16_t | txbuffer [0x400]
uint16_t | rxbuffer [0x400]
uint32_t | writereadstatus = 0
uint32_t | number = 0
nor_idtype nor_id
uint16_t | txbuffer [0x400]
uint16_t | rxbuffer [0x400]
uint32_t | writereadstatus = 0
uint32_t | number = 0
nor_idtype nor_id

Detailed Description

Macro Definition Documentation

◆ ADDR_SHIFT [1/2]

#define ADDR_SHIFT ( A ) (BANK1_NOR2_ADDR + (2 * (A)))

Definition at line 44 of file at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c.

◆ ADDR_SHIFT [2/2]

#define ADDR_SHIFT ( A ) (BANK1_NOR2_ADDR + (2 * (A)))

Definition at line 44 of file at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c.

◆ BANK1_NOR2_ADDR [1/2]

#define BANK1_NOR2_ADDR ((uint32_t)0x64000000)

Definition at line 37 of file at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c.

◆ BANK1_NOR2_ADDR [2/2]

#define BANK1_NOR2_ADDR ((uint32_t)0x64000000)

Definition at line 37 of file at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c.

◆ BLOCKERASE_TIMEOUT [1/2]

#define BLOCKERASE_TIMEOUT ((uint32_t)0x00A00000)

Definition at line 40 of file at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c.

◆ BLOCKERASE_TIMEOUT [2/2]

#define BLOCKERASE_TIMEOUT ((uint32_t)0x00A00000)

Definition at line 40 of file at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c.

◆ buffer_size [1/2]

#define buffer_size 0x400

Definition at line 39 of file project/at_start_f435/examples/xmc/nor_flash/src/main.c.

◆ buffer_size [2/2]

#define buffer_size 0x400

Definition at line 39 of file project/at_start_f437/examples/xmc/nor_flash/src/main.c.

◆ CHIPERASE_TIMEOUT [1/2]

#define CHIPERASE_TIMEOUT ((uint32_t)0x30000000)

Definition at line 41 of file at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c.

◆ CHIPERASE_TIMEOUT [2/2]

#define CHIPERASE_TIMEOUT ((uint32_t)0x30000000)

Definition at line 41 of file at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c.

◆ NOR_WRITE [1/2]

#define NOR_WRITE | ( | address,
 |  | data
 | ) | (*(__IO uint16_t *)(address) = (data))

Definition at line 45 of file at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c.

◆ NOR_WRITE [2/2]

#define NOR_WRITE | ( | address,
 |  | data
 | ) | (*(__IO uint16_t *)(address) = (data))

Definition at line 45 of file at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c.

◆ PROGRAM_TIMEOUT [1/2]

#define PROGRAM_TIMEOUT ((uint32_t)0x00001400)

Definition at line 42 of file at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c.

◆ PROGRAM_TIMEOUT [2/2]

#define PROGRAM_TIMEOUT ((uint32_t)0x00001400)

Definition at line 42 of file at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c.

◆ write_read_addr [1/2]

#define write_read_addr 0x8000

Definition at line 40 of file project/at_start_f435/examples/xmc/nor_flash/src/main.c.

◆ write_read_addr [2/2]

#define write_read_addr 0x8000

Definition at line 40 of file project/at_start_f437/examples/xmc/nor_flash/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c.

◆ fill_buffer()

void fill_buffer | ( | uint16_t * | pbuffer,
 |  | uint16_t | bufferlenght,
 |  | uint32_t | offset
 | ) |  |

fill the global buffer

Parameters
pbuffer | pointer on the buffer to fill
buffersize | size of the buffer to fill
offset | first value to fill on the buffer

Definition at line 520 of file at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/xmc/nor_flash/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c.

◆ nor_eraseblock()

nor_status nor_eraseblock ( uint32_t blockaddr )

erases the specified nor memory block.

Parameters
blockaddr address of the block to erase.
Return values
nor_status the returned value can be: nor_success, nor_error or nor_timeout

Definition at line 266 of file at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c.

Referenced by main().

◆ nor_erasechip()

nor_status nor_erasechip ( void )

erases the entire chip.

Parameters
none
Return values
nor_status the returned value can be: nor_success, nor_error or nor_timeout

Definition at line 284 of file at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c.

◆ nor_getstatus()

nor_status nor_getstatus ( uint32_t timeout )

returns the nor operation status.

Parameters
timeout nor progamming timeout
Return values
nor_status the returned value can be: nor_success, nor_error or nor_timeout

< poll on nor memory ready/busy signal -------------------------------—

< read dq6 and dq5

< if dq6 did not toggle between the two reads then return nor_success

< poll on nor memory ready/busy signal -------------------------------—

< read dq6 and dq5

< if dq6 did not toggle between the two reads then return nor_success

Definition at line 453 of file at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c.

Referenced by nor_eraseblock(), nor_erasechip(), nor_programbuffer(), and nor_writehalfword().

◆ nor_init()

void nor_init ( void )

init nor flash interface

Parameters
none
Return values
none

Definition at line 51 of file at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c.

Referenced by main().

◆ nor_programbuffer()

nor_status nor_programbuffer | ( | uint16_t * | pbuffer,
 |  | uint32_t | writeaddr,
 |  | uint32_t | numhalfwordtowrite
 | ) |  |

writes a half-word buffer to the xmc nor memory. this function must be used only with s29gl128p nor memory.

Parameters
pbuffer | pointer to buffer.
writeaddr | nor memory internal address from which the data will be written.
numhalfwordtowrite | number of half words to write. the maximum allowed value is 32 half words (64 bytes).
Return values
nor_status the returned value can be: nor_success, nor_error or nor_timeout

< initialize variables

< Issue unlock command sequence

< Write Write Buffer Load Command

< Load Data into NOR Buffer

< Store last loaded address & data value (for polling)

< initialize variables

< Issue unlock command sequence

< Write Write Buffer Load Command

< Load Data into NOR Buffer

< Store last loaded address & data value (for polling)

Definition at line 349 of file at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c.

◆ nor_readbuffer()

void nor_readbuffer | ( | uint16_t * | pbuffer,
 |  | uint32_t | readaddr,
 |  | uint32_t | numhalfwordtoread
 | ) |  |

reads a block of data from the xmc nor memory.

Parameters
pbuffer | pointer to the buffer that receives the data read from the nor memory.
readaddr | nor memory internal address to read from.
numhalfwordtoread | : number of half word to read.
Return values
none

< while there is data to read

< read a halfword from the nor

< while there is data to read

< read a halfword from the nor

Definition at line 406 of file at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c.

Referenced by main().

◆ nor_readhalfword()

uint16_t nor_readhalfword ( uint32_t readaddr )

reads a half-word from the nor memory.

Parameters
readaddr nor memory internal address to read from.
Return values
half-word read from the nor memory

Definition at line 389 of file at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c.

◆ nor_readid()

void nor_readid ( nor_idtype * nor_id )

reads nor memory's manufacturer and device code.

Parameters
nor_id pointer to a nor_idtypedef structure which will hold the manufacturer and device code.
Return values
none

Definition at line 248 of file at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c.

Referenced by main().

◆ nor_reset()

nor_status nor_reset ( void )

returns the nor memory to read mode and resets the errors in the nor memory status register.

Parameters
none
Return values
nor_success

Definition at line 438 of file at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c.

◆ nor_returntoreadmode()

nor_status nor_returntoreadmode ( void )

returns the nor memory to read mode.

Parameters
none
Return values
nor_success

Definition at line 425 of file at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c.

Referenced by main().

◆ nor_writebuffer()

nor_status nor_writebuffer | ( | uint16_t * | pbuffer,
 |  | uint32_t | writeaddr,
 |  | uint32_t | numhalfwordtowrite
 | ) |  |

writes a half-word buffer to the xmc nor memory.

Parameters
pbuffer | pointer to buffer.
writeaddr | nor memory internal address from which the data will be written.
numhalfwordtowrite | number of half words to write.
Return values
nor_status the returned value can be: nor_success, nor_error or nor_timeout

< Transfer data to the memory

< Transfer data to the memory

Definition at line 322 of file at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c.

Referenced by main().

◆ nor_writehalfword()

nor_status nor_writehalfword | ( | uint32_t | writeaddr,
 |  | uint16_t | data
 | ) |  |

writes a half-word to the nor memory.

Parameters
writeaddr | nor memory internal address to write to.
data | data to write.
Return values
nor_status the returned value can be: nor_success, nor_error or nor_timeout

Definition at line 303 of file at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c.

Referenced by nor_writebuffer().

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c.

Variable Documentation

◆ nor_id [1/2]

nor_idtype nor_id

Definition at line 45 of file project/at_start_f435/examples/xmc/nor_flash/src/main.c.

Referenced by main(), and nor_readid().

◆ nor_id [2/2]

nor_idtype nor_id

Definition at line 45 of file project/at_start_f437/examples/xmc/nor_flash/src/main.c.

◆ number [1/2]

uint32_t number = 0

Definition at line 44 of file project/at_start_f435/examples/xmc/nor_flash/src/main.c.

Referenced by emac_dma_application_missing_frame_get(), emac_dma_controller_missing_frame_get(), emac_dma_fifo_overflow_bit_get(), emac_dma_missing_overflow_bit_get(), emac_interframe_gap_set(), main(), and xmc_sdram_auto_refresh_set().

◆ number [2/2]

uint32_t number = 0

Definition at line 44 of file project/at_start_f437/examples/xmc/nor_flash/src/main.c.

◆ rxbuffer [1/2]

uint16_t rxbuffer[0x400]

Definition at line 43 of file project/at_start_f435/examples/xmc/nor_flash/src/main.c.

Referenced by main().

◆ rxbuffer [2/2]

uint16_t rxbuffer[0x400]

Definition at line 43 of file project/at_start_f437/examples/xmc/nor_flash/src/main.c.

◆ txbuffer [1/2]

uint16_t txbuffer[0x400]

Definition at line 42 of file project/at_start_f435/examples/xmc/nor_flash/src/main.c.

Referenced by main().

◆ txbuffer [2/2]

uint16_t txbuffer[0x400]

Definition at line 42 of file project/at_start_f437/examples/xmc/nor_flash/src/main.c.

◆ writereadstatus [1/2]

uint32_t writereadstatus = 0

Definition at line 44 of file project/at_start_f435/examples/xmc/nor_flash/src/main.c.

Referenced by main().

◆ writereadstatus [2/2]

uint32_t writereadstatus = 0

Definition at line 44 of file project/at_start_f437/examples/xmc/nor_flash/src/main.c.


AT32F435/437 Firmwary Library: XMC_psram

Macros | Functions | Variables
XMC_psram
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | buffer_size (uint16_t)0x400
#define | write_read_addr (uint32_t)0x8000
#define | BANK1_SRAM3_ADDR (uint32_t)0x68000000
#define | buffer_size (uint16_t)0x400
#define | write_read_addr (uint32_t)0x8000
#define | BANK1_SRAM3_ADDR (uint32_t)0x68000000

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...
void | psram_init (void)
init psram interface More...
void | psram_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc psram memory. More...
void | psram_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc psram memory. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...

Variables

uint16_t | txbuffer [(uint16_t) 0x400]
uint16_t | rxbuffer [(uint16_t) 0x400]
uint32_t | writereadstatus = 0
uint32_t | number = 0
uint16_t | txbuffer [(uint16_t) 0x400]
uint16_t | rxbuffer [(uint16_t) 0x400]
uint32_t | writereadstatus = 0
uint32_t | number = 0

Detailed Description

Macro Definition Documentation

◆ BANK1_SRAM3_ADDR [1/2]

#define BANK1_SRAM3_ADDR (uint32_t)0x68000000

Definition at line 37 of file at_start_f435/examples/xmc/psram/src/xmc_psram.c.

◆ BANK1_SRAM3_ADDR [2/2]

#define BANK1_SRAM3_ADDR (uint32_t)0x68000000

Definition at line 37 of file at_start_f437/examples/xmc/psram/src/xmc_psram.c.

◆ buffer_size [1/2]

#define buffer_size (uint16_t)0x400

Definition at line 39 of file project/at_start_f435/examples/xmc/psram/src/main.c.

◆ buffer_size [2/2]

#define buffer_size (uint16_t)0x400

Definition at line 39 of file project/at_start_f437/examples/xmc/psram/src/main.c.

◆ write_read_addr [1/2]

#define write_read_addr (uint32_t)0x8000

Definition at line 40 of file project/at_start_f435/examples/xmc/psram/src/main.c.

◆ write_read_addr [2/2]

#define write_read_addr (uint32_t)0x8000

Definition at line 40 of file project/at_start_f437/examples/xmc/psram/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c.

◆ fill_buffer()

void fill_buffer | ( | uint16_t * | pbuffer,
 |  | uint16_t | bufferlenght,
 |  | uint32_t | offset
 | ) |  |

fill the global buffer

Parameters
pbuffer | pointer on the buffer to fill
buffersize | size of the buffer to fill
offset | first value to fill on the buffer

Definition at line 253 of file at_start_f435/examples/xmc/psram/src/xmc_psram.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/xmc/psram/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c.

◆ psram_init()

void psram_init ( void )

init psram interface

Parameters
none
Return values
none

Definition at line 44 of file at_start_f435/examples/xmc/psram/src/xmc_psram.c.

Referenced by main().

◆ psram_readbuffer()

void psram_readbuffer | ( | uint16_t * | pbuffer,
 |  | uint32_t | readaddr,
 |  | uint32_t | numhalfwordtoread
 | ) |  |

reads a block of data from the xmc psram memory.

Parameters
pbuffer | : pointer to the buffer that receives the data read from the psram memory.
readaddr | : psram memory internal address to read from.
numhalfwordtoread | : number of half-words to read.
Return values
none

< while there is data to read

< read a half-word from the memory

< increment the address

< while there is data to read

< read a half-word from the memory

< increment the address

Definition at line 235 of file at_start_f435/examples/xmc/psram/src/xmc_psram.c.

Referenced by main().

◆ psram_writebuffer()

void psram_writebuffer | ( | uint16_t * | pbuffer,
 |  | uint32_t | writeaddr,
 |  | uint32_t | numhalfwordtowrite
 | ) |  |

writes a half-word buffer to the xmc psram memory.

Parameters
pbuffer | : pointer to buffer.
writeaddr | : psram memory internal address from which the data will be written.
numhalfwordtowrite | : number of half-words to write.
Return values
none

< while there is data to write

< Transfer data to the memory

< increment the address

< while there is data to write

< Transfer data to the memory

< increment the address

Definition at line 215 of file at_start_f435/examples/xmc/psram/src/xmc_psram.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c.

Variable Documentation

◆ number [1/2]

uint32_t number = 0

Definition at line 44 of file project/at_start_f435/examples/xmc/psram/src/main.c.

Referenced by main().

◆ number [2/2]

uint32_t number = 0

Definition at line 44 of file project/at_start_f437/examples/xmc/psram/src/main.c.

◆ rxbuffer [1/2]

uint16_t rxbuffer[(uint16_t) 0x400]

Definition at line 43 of file project/at_start_f435/examples/xmc/psram/src/main.c.

Referenced by main().

◆ rxbuffer [2/2]

uint16_t rxbuffer[(uint16_t) 0x400]

Definition at line 43 of file project/at_start_f437/examples/xmc/psram/src/main.c.

◆ txbuffer [1/2]

uint16_t txbuffer[(uint16_t) 0x400]

Definition at line 42 of file project/at_start_f435/examples/xmc/psram/src/main.c.

Referenced by main().

◆ txbuffer [2/2]

uint16_t txbuffer[(uint16_t) 0x400]

Definition at line 42 of file project/at_start_f437/examples/xmc/psram/src/main.c.

◆ writereadstatus [1/2]

uint32_t writereadstatus = 0

Definition at line 44 of file project/at_start_f435/examples/xmc/psram/src/main.c.

Referenced by main().

◆ writereadstatus [2/2]

uint32_t writereadstatus = 0

Definition at line 44 of file project/at_start_f437/examples/xmc/psram/src/main.c.


AT32F435/437 Firmwary Library: XMC_sdram_basic

Macros | Functions | Variables
XMC_sdram_basic
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | buffer_size 0x400
#define | write_read_addr 0x8000
#define | SDRAM_BANK1_ADDR ((uint32_t)0xC0000000)
#define | buffer_size 0x400
#define | write_read_addr 0x8000
#define | SDRAM_BANK1_ADDR ((uint32_t)0xC0000000)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...
void | sdram_init (void)
init sdram interface More...
void | sdram_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the sdram memory. More...
void | sdram_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the sdram. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...

Variables

uint16_t | txbuffer [0x400]
uint16_t | rxbuffer [0x400]
uint32_t | writereadstatus = 0
uint32_t | number = 0
uint16_t | txbuffer [0x400]
uint16_t | rxbuffer [0x400]
uint32_t | writereadstatus = 0
uint32_t | number = 0

Detailed Description

Macro Definition Documentation

◆ buffer_size [1/2]

#define buffer_size 0x400

Definition at line 39 of file project/at_start_f435/examples/xmc/sdram_basic/src/main.c.

◆ buffer_size [2/2]

#define buffer_size 0x400

Definition at line 39 of file project/at_start_f437/examples/xmc/sdram_basic/src/main.c.

◆ SDRAM_BANK1_ADDR [1/2]

#define SDRAM_BANK1_ADDR ((uint32_t)0xC0000000)

Definition at line 38 of file at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c.

◆ SDRAM_BANK1_ADDR [2/2]

#define SDRAM_BANK1_ADDR ((uint32_t)0xC0000000)

Definition at line 38 of file at_start_f437/examples/xmc/sdram_basic/src/xmc_sdram.c.

◆ write_read_addr [1/2]

#define write_read_addr 0x8000

Definition at line 40 of file project/at_start_f435/examples/xmc/sdram_basic/src/main.c.

◆ write_read_addr [2/2]

#define write_read_addr 0x8000

Definition at line 40 of file project/at_start_f437/examples/xmc/sdram_basic/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c.

◆ fill_buffer()

void fill_buffer | ( | uint16_t * | pbuffer,
 |  | uint16_t | bufferlenght,
 |  | uint32_t | offset
 | ) |  |

fill the global buffer

Parameters
pbuffer | pointer on the buffer to fill
buffersize | size of the buffer to fill
offset | first value to fill on the buffer

Definition at line 286 of file at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/xmc/sdram_basic/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c.

◆ sdram_init()

void sdram_init ( void )

init sdram interface

Parameters
none
Return values
none

Definition at line 46 of file at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c.

◆ sdram_readbuffer()

void sdram_readbuffer | ( | uint16_t * | pbuffer,
 |  | uint32_t | readaddr,
 |  | uint32_t | numhalfwordtoread
 | ) |  |

reads a block of data from the sdram.

Parameters
pbuffer | : pointer to the buffer that receives the data read from the sdram memory.
readaddr | : sdram memory internal address to read from.
numhalfwordtoread | : number of half-words to read.
Return values
none

< while there is data to read

< read a half-word from the memory

< increment the address

< while there is data to read

< read a half-word from the memory

< increment the address

Definition at line 268 of file at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c.

◆ sdram_writebuffer()

void sdram_writebuffer | ( | uint16_t * | pbuffer,
 |  | uint32_t | writeaddr,
 |  | uint32_t | numhalfwordtowrite
 | ) |  |

writes a half-word buffer to the sdram memory.

Parameters
pbuffer | : pointer to buffer.
writeaddr | : sdram memory internal address from which the data will be written.
numhalfwordtowrite | : number of half-words to write.
Return values
none

< while there is data to write

< Transfer data to the memory

< increment the address

< while there is data to write

< Transfer data to the memory

< increment the address

Definition at line 248 of file at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c.

Variable Documentation

◆ number [1/2]

uint32_t number = 0

Definition at line 44 of file project/at_start_f435/examples/xmc/sdram_basic/src/main.c.

Referenced by main().

◆ number [2/2]

uint32_t number = 0

Definition at line 44 of file project/at_start_f437/examples/xmc/sdram_basic/src/main.c.

◆ rxbuffer [1/2]

uint16_t rxbuffer[0x400]

Definition at line 43 of file project/at_start_f435/examples/xmc/sdram_basic/src/main.c.

Referenced by main().

◆ rxbuffer [2/2]

uint16_t rxbuffer[0x400]

Definition at line 43 of file project/at_start_f437/examples/xmc/sdram_basic/src/main.c.

◆ txbuffer [1/2]

uint16_t txbuffer[0x400]

Definition at line 42 of file project/at_start_f435/examples/xmc/sdram_basic/src/main.c.

Referenced by main().

◆ txbuffer [2/2]

uint16_t txbuffer[0x400]

Definition at line 42 of file project/at_start_f437/examples/xmc/sdram_basic/src/main.c.

◆ writereadstatus [1/2]

uint32_t writereadstatus = 0

Definition at line 44 of file project/at_start_f435/examples/xmc/sdram_basic/src/main.c.

Referenced by main().

◆ writereadstatus [2/2]

uint32_t writereadstatus = 0

Definition at line 44 of file project/at_start_f437/examples/xmc/sdram_basic/src/main.c.


AT32F435/437 Firmwary Library: XMC_sdram_dma

Macros | Functions | Variables
XMC_sdram_dma
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | buffer_size 0x400
#define | write_read_addr 0x0000
#define | SDRAM_BANK1_ADDR ((uint32_t)0xC0000000)
#define | buffer_size 0x400
#define | write_read_addr 0x0000
#define | SDRAM_BANK1_ADDR ((uint32_t)0xC0000000)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...
void | sdram_init_sequence (xmc_cmd_bank1_2_type cmd_bank)
init sdram sequence More...
void | sdram_init (void)
init sdram interface More...
void | sdram_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the sdram memory. More...
void | sdram_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the sdram. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...
void | sdram_copy_to_sram_dma (uint16_t *buffer, uint32_t length)
copy sdram data to sram More...
void | sram_copy_to_sdram_dma (uint16_t *buffer, uint32_t length)
copy sram data copy to sdram More...

Variables

uint16_t | txbuffer [0x400]
uint16_t | rxbuffer [0x400]
uint32_t | writereadstatus = 0
uint32_t | number = 0
dma_init_type dma_init_struct
uint16_t | txbuffer [0x400]
uint16_t | rxbuffer [0x400]
uint32_t | writereadstatus = 0
uint32_t | number = 0
dma_init_type dma_init_struct

Detailed Description

Macro Definition Documentation

◆ buffer_size [1/2]

#define buffer_size 0x400

Definition at line 39 of file project/at_start_f435/examples/xmc/sdram_dma/src/main.c.

◆ buffer_size [2/2]

#define buffer_size 0x400

Definition at line 39 of file project/at_start_f437/examples/xmc/sdram_dma/src/main.c.

◆ SDRAM_BANK1_ADDR [1/2]

#define SDRAM_BANK1_ADDR ((uint32_t)0xC0000000)

Definition at line 38 of file at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c.

◆ SDRAM_BANK1_ADDR [2/2]

#define SDRAM_BANK1_ADDR ((uint32_t)0xC0000000)

Definition at line 38 of file at_start_f437/examples/xmc/sdram_dma/src/xmc_sdram.c.

◆ write_read_addr [1/2]

#define write_read_addr 0x0000

Definition at line 40 of file project/at_start_f435/examples/xmc/sdram_dma/src/main.c.

◆ write_read_addr [2/2]

#define write_read_addr 0x0000

Definition at line 40 of file project/at_start_f437/examples/xmc/sdram_dma/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c.

◆ fill_buffer()

void fill_buffer | ( | uint16_t * | pbuffer,
 |  | uint16_t | bufferlenght,
 |  | uint32_t | offset
 | ) |  |

fill the global buffer

Parameters
pbuffer | pointer on the buffer to fill
buffersize | size of the buffer to fill
offset | first value to fill on the buffer
Return values
none

Definition at line 288 of file at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/xmc/sdram_dma/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c.

◆ sdram_copy_to_sram_dma()

void sdram_copy_to_sram_dma | ( | uint16_t * | buffer,
 |  | uint32_t | length
 | ) |  |

copy sdram data to sram

Parameters
buffer | pointer on the buffer to
length | copy length
Return values
none

Definition at line 305 of file at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c.

Referenced by main().

◆ sdram_init()

void sdram_init ( void )

init sdram interface

Parameters
none
Return values
none

Definition at line 48 of file at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c.

Referenced by main().

◆ sdram_init_sequence()

void sdram_init_sequence ( xmc_cmd_bank1_2_type cmd_bank )

init sdram sequence

Parameters
none
Return values
none

Definition at line 179 of file at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c.

Referenced by sdram_init().

◆ sdram_readbuffer()

void sdram_readbuffer | ( | uint16_t * | pbuffer,
 |  | uint32_t | readaddr,
 |  | uint32_t | numhalfwordtoread
 | ) |  |

reads a block of data from the sdram.

Parameters
pbuffer | : pointer to the buffer that receives the data read from the sdram memory.
readaddr | : sdram memory internal address to read from.
numhalfwordtoread | : number of half-words to read.
Return values
none

< while there is data to read

< read a half-word from the memory

< increment the address

< while there is data to read

< read a half-word from the memory

< increment the address

Definition at line 269 of file at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c.

Referenced by main().

◆ sdram_writebuffer()

void sdram_writebuffer | ( | uint16_t * | pbuffer,
 |  | uint32_t | writeaddr,
 |  | uint32_t | numhalfwordtowrite
 | ) |  |

writes a half-word buffer to the sdram memory.

Parameters
pbuffer | : pointer to buffer.
writeaddr | : sdram memory internal address from which the data will be written.
numhalfwordtowrite | : number of half-words to write.
Return values
none

< while there is data to write

< Transfer data to the memory

< increment the address

< while there is data to write

< Transfer data to the memory

< increment the address

Definition at line 249 of file at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c.

Referenced by main().

◆ sram_copy_to_sdram_dma()

void sram_copy_to_sdram_dma | ( | uint16_t * | buffer,
 |  | uint32_t | length
 | ) |  |

copy sram data copy to sdram

Parameters
buffer | pointer on the buffer to
length | copy length
Return values
none

Definition at line 336 of file at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c.

Variable Documentation

◆ dma_init_struct [1/2]

dma_init_type dma_init_struct

Definition at line 40 of file at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c.

Referenced by sdram_copy_to_sram_dma(), and sram_copy_to_sdram_dma().

◆ dma_init_struct [2/2]

dma_init_type dma_init_struct

Definition at line 40 of file at_start_f437/examples/xmc/sdram_dma/src/xmc_sdram.c.

Referenced by sdram_copy_to_sram_dma(), and sram_copy_to_sdram_dma().

◆ number [1/2]

uint32_t number = 0

Definition at line 44 of file project/at_start_f435/examples/xmc/sdram_dma/src/main.c.

Referenced by main().

◆ number [2/2]

uint32_t number = 0

Definition at line 44 of file project/at_start_f437/examples/xmc/sdram_dma/src/main.c.

◆ rxbuffer [1/2]

uint16_t rxbuffer[0x400]

Definition at line 43 of file project/at_start_f435/examples/xmc/sdram_dma/src/main.c.

Referenced by main().

◆ rxbuffer [2/2]

uint16_t rxbuffer[0x400]

Definition at line 43 of file project/at_start_f437/examples/xmc/sdram_dma/src/main.c.

◆ txbuffer [1/2]

uint16_t txbuffer[0x400]

Definition at line 42 of file project/at_start_f435/examples/xmc/sdram_dma/src/main.c.

Referenced by main().

◆ txbuffer [2/2]

uint16_t txbuffer[0x400]

Definition at line 42 of file project/at_start_f437/examples/xmc/sdram_dma/src/main.c.

◆ writereadstatus [1/2]

uint32_t writereadstatus = 0

Definition at line 44 of file project/at_start_f435/examples/xmc/sdram_dma/src/main.c.

Referenced by main().

◆ writereadstatus [2/2]

uint32_t writereadstatus = 0

Definition at line 44 of file project/at_start_f437/examples/xmc/sdram_dma/src/main.c.


AT32F435/437 Firmwary Library: XMC_sram

Macros | Functions | Variables
XMC_sram
AT32F435_periph_examples | AT32F437_periph_examples

Macros

#define | buffer_size (uint16_t)0x400
#define | write_read_addr (uint32_t)0x8000
#define | BANK1_SRAM3_ADDR ((uint32_t)0x68000000)
#define | buffer_size (uint16_t)0x400
#define | write_read_addr (uint32_t)0x8000
#define | BANK1_SRAM3_ADDR ((uint32_t)0x68000000)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...
void | sram_init (void)
init sram interface More...
void | sram_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc sram memory. More...
void | sram_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc sram memory. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...

Variables

uint16_t | txbuffer [(uint16_t) 0x400]
uint16_t | rxbuffer [(uint16_t) 0x400]
uint32_t | writereadstatus = 0
uint32_t | number = 0
uint16_t | txbuffer [(uint16_t) 0x400]
uint16_t | rxbuffer [(uint16_t) 0x400]
uint32_t | writereadstatus = 0
uint32_t | number = 0

Detailed Description

Macro Definition Documentation

◆ BANK1_SRAM3_ADDR [1/2]

#define BANK1_SRAM3_ADDR ((uint32_t)0x68000000)

Definition at line 37 of file at_start_f435/examples/xmc/sram/src/xmc_sram.c.

◆ BANK1_SRAM3_ADDR [2/2]

#define BANK1_SRAM3_ADDR ((uint32_t)0x68000000)

Definition at line 37 of file at_start_f437/examples/xmc/sram/src/xmc_sram.c.

◆ buffer_size [1/2]

#define buffer_size (uint16_t)0x400

Definition at line 39 of file project/at_start_f435/examples/xmc/sram/src/main.c.

◆ buffer_size [2/2]

#define buffer_size (uint16_t)0x400

Definition at line 39 of file project/at_start_f437/examples/xmc/sram/src/main.c.

◆ write_read_addr [1/2]

#define write_read_addr (uint32_t)0x8000

Definition at line 40 of file project/at_start_f435/examples/xmc/sram/src/main.c.

◆ write_read_addr [2/2]

#define write_read_addr (uint32_t)0x8000

Definition at line 40 of file project/at_start_f437/examples/xmc/sram/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c.

◆ fill_buffer()

void fill_buffer | ( | uint16_t * | pbuffer,
 |  | uint16_t | bufferlenght,
 |  | uint32_t | offset
 | ) |  |

fill the global buffer

Parameters
pbuffer | pointer on the buffer to fill
buffersize | size of the buffer to fill
offset | first value to fill on the buffer

Definition at line 267 of file at_start_f435/examples/xmc/sram/src/xmc_sram.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f435/examples/xmc/sram/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c.

◆ sram_init()

void sram_init ( void )

init sram interface

Parameters
none
Return values
none

Definition at line 44 of file at_start_f435/examples/xmc/sram/src/xmc_sram.c.

Referenced by main().

◆ sram_readbuffer()

void sram_readbuffer | ( | uint16_t * | pbuffer,
 |  | uint32_t | readaddr,
 |  | uint32_t | numhalfwordtoread
 | ) |  |

reads a block of data from the xmc sram memory.

Parameters
pbuffer | : pointer to the buffer that receives the data read from the sram memory.
readaddr | : sram memory internal address to read from.
numhalfwordtoread | : number of half-words to read.
Return values
none

< while there is data to read

< read a half-word from the memory

< increment the address

< while there is data to read

< read a half-word from the memory

< increment the address

Definition at line 249 of file at_start_f435/examples/xmc/sram/src/xmc_sram.c.

Referenced by main().

◆ sram_writebuffer()

void sram_writebuffer | ( | uint16_t * | pbuffer,
 |  | uint32_t | writeaddr,
 |  | uint32_t | numhalfwordtowrite
 | ) |  |

writes a half-word buffer to the xmc sram memory.

Parameters
pbuffer | : pointer to buffer.
writeaddr | : sram memory internal address from which the data will be written.
numhalfwordtowrite | : number of half-words to write.
Return values
none

< while there is data to write

< Transfer data to the memory

< increment the address

< while there is data to write

< Transfer data to the memory

< increment the address

Definition at line 229 of file at_start_f435/examples/xmc/sram/src/xmc_sram.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c.

Variable Documentation

◆ number [1/2]

uint32_t number = 0

Definition at line 44 of file project/at_start_f435/examples/xmc/sram/src/main.c.

Referenced by main().

◆ number [2/2]

uint32_t number = 0

Definition at line 44 of file project/at_start_f437/examples/xmc/sram/src/main.c.

◆ rxbuffer [1/2]

uint16_t rxbuffer[(uint16_t) 0x400]

Definition at line 43 of file project/at_start_f435/examples/xmc/sram/src/main.c.

Referenced by main().

◆ rxbuffer [2/2]

uint16_t rxbuffer[(uint16_t) 0x400]

Definition at line 43 of file project/at_start_f437/examples/xmc/sram/src/main.c.

◆ txbuffer [1/2]

uint16_t txbuffer[(uint16_t) 0x400]

Definition at line 42 of file project/at_start_f435/examples/xmc/sram/src/main.c.

Referenced by main().

◆ txbuffer [2/2]

uint16_t txbuffer[(uint16_t) 0x400]

Definition at line 42 of file project/at_start_f437/examples/xmc/sram/src/main.c.

◆ writereadstatus [1/2]

uint32_t writereadstatus = 0

Definition at line 44 of file project/at_start_f435/examples/xmc/sram/src/main.c.

Referenced by main().

◆ writereadstatus [2/2]

uint32_t writereadstatus = 0

Definition at line 44 of file project/at_start_f437/examples/xmc/sram/src/main.c.


AT32F435/437 Firmwary Library: AT32F435_periph_template

Modules
AT32F435_periph_template

Modules

Library_configuration
System_clock_configuration
LED_toggle

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: Library_configuration

Macros
Library_configuration
AT32F435_periph_template | AT32F437_periph_template

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED
#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED
#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED
#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

Macro Definition Documentation

◆ ACC_MODULE_ENABLED [1/4]

#define ACC_MODULE_ENABLED

Definition at line 86 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ ACC_MODULE_ENABLED [2/4]

#define ACC_MODULE_ENABLED

Definition at line 86 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ ACC_MODULE_ENABLED [3/4]

#define ACC_MODULE_ENABLED

Definition at line 86 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ ACC_MODULE_ENABLED [4/4]

#define ACC_MODULE_ENABLED

Definition at line 86 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED [1/4]

#define ADC_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED [2/4]

#define ADC_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED [3/4]

#define ADC_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED [4/4]

#define ADC_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED [1/4]

#define CAN_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED [2/4]

#define CAN_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED [3/4]

#define CAN_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED [4/4]

#define CAN_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED [1/4]

#define CRC_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED [2/4]

#define CRC_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED [3/4]

#define CRC_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED [4/4]

#define CRC_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED [1/4]

#define CRM_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED [2/4]

#define CRM_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED [3/4]

#define CRM_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED [4/4]

#define CRM_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED [1/4]

#define DAC_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED [2/4]

#define DAC_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED [3/4]

#define DAC_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED [4/4]

#define DAC_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED [1/4]

#define DEBUG_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED [2/4]

#define DEBUG_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED [3/4]

#define DEBUG_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED [4/4]

#define DEBUG_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED [1/4]

#define DMA_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED [2/4]

#define DMA_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED [3/4]

#define DMA_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED [4/4]

#define DMA_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED [1/4]

#define DVP_MODULE_ENABLED

Definition at line 89 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED [2/4]

#define DVP_MODULE_ENABLED

Definition at line 89 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED [3/4]

#define DVP_MODULE_ENABLED

Definition at line 89 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED [4/4]

#define DVP_MODULE_ENABLED

Definition at line 89 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED [1/4]

#define EDMA_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED [2/4]

#define EDMA_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED [3/4]

#define EDMA_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED [4/4]

#define EDMA_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED [1/4]

#define EMAC_MODULE_ENABLED

Definition at line 91 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED [2/4]

#define EMAC_MODULE_ENABLED

Definition at line 91 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED [3/4]

#define EMAC_MODULE_ENABLED

Definition at line 91 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED [4/4]

#define EMAC_MODULE_ENABLED

Definition at line 91 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED [1/4]

#define ERTC_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED [2/4]

#define ERTC_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED [3/4]

#define ERTC_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED [4/4]

#define ERTC_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED [1/4]

#define EXINT_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED [2/4]

#define EXINT_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED [3/4]

#define EXINT_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED [4/4]

#define EXINT_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED [1/4]

#define FLASH_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED [2/4]

#define FLASH_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED [3/4]

#define FLASH_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED [4/4]

#define FLASH_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED [1/4]

#define GPIO_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED [2/4]

#define GPIO_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED [3/4]

#define GPIO_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED [4/4]

#define GPIO_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT [1/4]

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 60 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT [2/4]

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 60 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT [3/4]

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 60 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT [4/4]

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 60 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ HEXT_VALUE [1/4]

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 53 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ HEXT_VALUE [2/4]

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 53 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ HEXT_VALUE [3/4]

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 53 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ HEXT_VALUE [4/4]

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 53 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ HICK_VALUE [1/4]

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 61 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ HICK_VALUE [2/4]

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 61 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ HICK_VALUE [3/4]

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 61 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ HICK_VALUE [4/4]

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 61 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED [1/4]

#define I2C_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED [2/4]

#define I2C_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED [3/4]

#define I2C_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED [4/4]

#define I2C_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED [1/4]

#define MISC_MODULE_ENABLED

Definition at line 87 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED [2/4]

#define MISC_MODULE_ENABLED

Definition at line 87 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED [3/4]

#define MISC_MODULE_ENABLED

Definition at line 87 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED [4/4]

#define MISC_MODULE_ENABLED

Definition at line 87 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED [1/4]

#define PWC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED [2/4]

#define PWC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED [3/4]

#define PWC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED [4/4]

#define PWC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED [1/4]

#define QSPI_MODULE_ENABLED

Definition at line 88 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED [2/4]

#define QSPI_MODULE_ENABLED

Definition at line 88 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED [3/4]

#define QSPI_MODULE_ENABLED

Definition at line 88 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED [4/4]

#define QSPI_MODULE_ENABLED

Definition at line 88 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED [1/4]

#define SCFG_MODULE_ENABLED

Definition at line 90 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED [2/4]

#define SCFG_MODULE_ENABLED

Definition at line 90 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED [3/4]

#define SCFG_MODULE_ENABLED

Definition at line 90 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED [4/4]

#define SCFG_MODULE_ENABLED

Definition at line 90 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED [1/4]

#define SDIO_MODULE_ENABLED

Definition at line 83 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED [2/4]

#define SDIO_MODULE_ENABLED

Definition at line 83 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED [3/4]

#define SDIO_MODULE_ENABLED

Definition at line 83 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED [4/4]

#define SDIO_MODULE_ENABLED

Definition at line 83 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED [1/4]

#define SPI_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED [2/4]

#define SPI_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED [3/4]

#define SPI_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED [4/4]

#define SPI_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED [1/4]

#define TMR_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED [2/4]

#define TMR_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED [3/4]

#define TMR_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED [4/4]

#define TMR_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED [1/4]

#define USART_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED [2/4]

#define USART_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED [3/4]

#define USART_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED [4/4]

#define USART_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED [1/4]

#define USB_MODULE_ENABLED

Definition at line 85 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED [2/4]

#define USB_MODULE_ENABLED

Definition at line 85 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED [3/4]

#define USB_MODULE_ENABLED

Definition at line 85 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED [4/4]

#define USB_MODULE_ENABLED

Definition at line 85 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED [1/4]

#define WDT_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED [2/4]

#define WDT_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED [3/4]

#define WDT_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED [4/4]

#define WDT_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED [1/4]

#define WWDT_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED [2/4]

#define WWDT_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED [3/4]

#define WWDT_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED [4/4]

#define WWDT_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED [1/4]

#define XMC_MODULE_ENABLED

Definition at line 84 of file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED [2/4]

#define XMC_MODULE_ENABLED

Definition at line 84 of file project/at_start_f435/templates/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED [3/4]

#define XMC_MODULE_ENABLED

Definition at line 84 of file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED [4/4]

#define XMC_MODULE_ENABLED

Definition at line 84 of file project/at_start_f437/templates/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: LED_toggle

Macros | Functions | Variables
LED_toggle
AT32F435_periph_template | AT32F437_periph_template

Macros

#define | DELAY 100
#define | FAST 1
#define | SLOW 4
#define | DELAY 100
#define | FAST 1
#define | SLOW 4

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | button_exint_init (void)
configure button exint More...
void | button_isr (void)
button handler function More...
void | EXINT0_IRQHandler (void)
exint0 interrupt handler More...
int | main (void)
main function. More...

Variables

uint8_t | g_speed = 1
uint8_t | g_speed = 1

Detailed Description

Macro Definition Documentation

◆ DELAY [1/2]

#define DELAY 100

Definition at line 38 of file project/at_start_f435/templates/src/main.c.

◆ DELAY [2/2]

#define DELAY 100

Definition at line 38 of file project/at_start_f437/templates/src/main.c.

◆ FAST [1/2]

#define FAST 1

Definition at line 39 of file project/at_start_f435/templates/src/main.c.

◆ FAST [2/2]

#define FAST 1

Definition at line 39 of file project/at_start_f437/templates/src/main.c.

◆ SLOW [1/2]

#define SLOW 4

Definition at line 40 of file project/at_start_f435/templates/src/main.c.

◆ SLOW [2/2]

#define SLOW 4

Definition at line 40 of file project/at_start_f437/templates/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f435/templates/src/at32f435_437_int.c.

◆ button_exint_init()

void button_exint_init ( void )

configure button exint

Parameters
none
Return values
none

< external interrupt line 0

< external interrupt line 0

Definition at line 52 of file project/at_start_f435/templates/src/main.c.

Referenced by main().

◆ button_isr()

void button_isr ( void )

button handler function

Parameters
none
Return values
none

< external interrupt line 0

< external interrupt line 0

Definition at line 75 of file project/at_start_f435/templates/src/main.c.

Referenced by EXINT0_IRQHandler().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f435/templates/src/at32f435_437_int.c.

◆ EXINT0_IRQHandler()

void EXINT0_IRQHandler ( void )

exint0 interrupt handler

Parameters
none
Return values
none

Definition at line 98 of file project/at_start_f435/templates/src/main.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f435/templates/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 108 of file project/at_start_f435/templates/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f435/templates/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f435/templates/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f435/templates/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f435/templates/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f435/templates/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f435/templates/src/at32f435_437_int.c.

Variable Documentation

◆ g_speed [1/2]

uint8_t g_speed = 1

Definition at line 42 of file project/at_start_f435/templates/src/main.c.

Referenced by button_isr(), and main().

◆ g_speed [2/2]

uint8_t g_speed = 1

Definition at line 42 of file project/at_start_f437/templates/src/main.c.


AT32F435/437 Firmwary Library: AT32F437_periph_examples

Modules
AT32F437_periph_examples

Modules

USB_device_vcp_loopback
ACC_calibration
ADC_combine_mode_ordinary_shift_twoslave_dma3
ADC_combine_mode_ordinary_shift_twoslave_dma4
ADC_combine_mode_ordinary_smlt_oneslave_dma2
ADC_combine_mode_ordinary_smlt_oneslave_edma
ADC_combine_mode_ordinary_smlt_twoslave_dma1
ADC_combine_mode_ordinary_smlt_twoslave_dma5
ADC_combine_mode_preempt_interltrig_twoslave
ADC_conversion_abort
ADC_current_vref_value_check
ADC_edma_double_buffer
ADC_exint_trigger_partitioned
ADC_internal_temperature_sensor
ADC_ordinary_preempt_oversampling
ADC_software_trigger_repeat
ADC_tmr_trigger_automatic_preempted
ADC_use_polling_get_conversion_data
ADC_vbat_monitor
ADC_voltage_monitoring
CAN_communication_mode
CAN_filter
CAN_loopback_mode
CORTEX_m4_bit_band
System_clock_configuration
CORTEX_m4_cmsis_dsp
CORTEX_m4_fpu
CORTEX_m4_systick_interrupt
CRC_calculation
CRM_clock_failure_detection
CRM_pll_parameter_calculate
CRM_sysclk_switch
DAC_double_mode_dma_sinewave
DAC_double_mode_dma_squarewave
DAC_one_dac_dma_escalator
DAC_one_dac_noisewave
DAC_two_dac_trianglewave
DEBUG_tmr
DMA_data_to_gpio
DMAMUX_genertor_exint
DMAMUX_synchronization_exint
DMA_flash_to_sram
DVP_ov2640_capture
DVP_ov5640_capture
EDMA_continuous_mode
EDMA_dmamux_genertor_exint
EDMA_dmamux_synchronization_exint
EDMA_flash_to_sram
EDMA_i2s_halfduplex_edma_doublebuffer
EDMA_link_list_mode
EDMA_two_dimension_mode
EMAC_dns_client
EMAC_http_server
EMAC_iperf
EMAC_mqtt_client
EMAC_tcp_client
EMAC_tcp_server
EMAC_telnet
EMAC_wake_on_lan
ERTC_bpr_domain
ERTC_calendar
ERTC_lick_calibration
ERTC_tamper
ERTC_time_stamp
ERTC_wakeup_timer
EXINT_exint_config
EXINT_exint_software_trigger
FLASH_fap_enable
FLASH_write_read
GPIO_io_toggle
GPIO_led_toggle
_GPIO_swjtag_mux
GPIO_swjtag_mux
I2C_communication_dma
I2C_communication_int
I2C_communication_poll
I2C_communication_smbus
I2C_eeprom
I2S_fullduplex_dma
I2S_halfduplex_dma
I2S_halfduplex_interrupt
I2S_spii2s_switch_halfduplex_polling
IRTMR_output
PWC_deepsleep_ertc_alarm
PWC_deepsleep_ertc_tamper
PWC_deepsleep_ertc_wakeup
PWC_ldo_set
PWC_power_voltage_monitor
PWC_sleep_tmr2
PWC_sleep_usart1
_PWC_standby_ertc_alarm
PWC_standby_ertc_alarm
PWC_standby_wakeup_pin
QSPI_command_port_using_dma
QSPI_command_port_using_dma_and_pem
QSPI_command_port_using_dma_in_qpi_mode
QSPI_command_port_using_interrupt
QSPI_command_port_using_polling
QSPI_command_port_using_rdsr_sw
QSPI_xip_port_write_read
SCFG_mem_map_sel
SD_mmc_card
SD_mmc_card
SDIO_fatfs
SPI_crc_transfer_polling
SPI_fullduplex_polling
SPI_halfduplex_interrupt
SPI_halfduplex_transceiver_switch
SPI_only_receive_mode_polling
SPI_ti_fullduplex_dma
SPI_use_jtagpin_hardwarecs_dma
SPI_w25q_flash
SRAM_extend_sram
TMR_6_steps
TMR_7_pwm_output
TMR_cascade_synchro
TMR_complementary_signals
TMR_dma
TMR_dma_burst
TMR_encoder_tmr2
TMR_external_clock
TMR_hall_xor_tmr2
TMR_hang_mode
TMR_input_capture
TMR_oc_high
TMR_oc_low
TMR_oc_toggle_tmr3
TMR_oc_toggle_tmr9
TMR_one_cycle
TMR_parallel_synchro
TMR_pwm_input
TMR_pwm_input_dma
TMR_pwm_output_simulate
TMR_pwm_output_tmr10
TMR_pwm_output_tmr3
TMR_timer_base
TMR_tmr1_synchro
TMR_tmr2_32bit
USART_half_duplex
USART_hw_flow_control
USART_idle_detection
USART_interrupt
USART_irda
USART_polling
USART_printf
USART_receiver_mute
_USART_rs485
USART_smartcard
USART_synchronous
USART_transfer_by_dma_interrupt
USART_transfer_by_dma_polling
USART_tx_rx_swap
USB_device_audio
USB_device_audio_hid
USB_device_composite_vcp_keyboard
USB_device_msc
USB_device_composite_vcp_msc
_USB_device_cdc_msc
USB_device_custom_hid
USB_device_keyboard
USB_device_mouse
USB_device_otg1_host_otg2_device_demo
USB_device_printer
USB_device_two_otg_device_demo
_USB_device_virtaul_comport
USB_device_virtaul_comport
USB_device_virtual_msc_iap
USB_host_hid
USB_host_msc
USB_host_two_otg_host_demo
WDT_wdt_reset
WDT_WDT_standby
WWDT_wwdt_reset
XMC_lcd_8bit
XMC_lcd_touch_16bit
XMC_nand_ecc
XMC_nand
XMC_nor_flash
XMC_psram
XMC_sdram_basic
XMC_sdram_dma
XMC_sram
_USB_device_hid_app_led3
_USB_device_hid_iap

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: EMAC_dns_client

Modules | Macros | Functions | Variables
EMAC_dns_client
AT32F437_periph_examples

Modules

Network_configuration_prototype
Network_configuration

Macros

#define | RX_REMAP (1)
#define | CRYSTAL_ON_PHY (0)
#define | RMII_MODE
#define | DM9162
#define | LINK_DETECTION (1)
#define | PHY_ADDRESS (0x03)
#define | PHY_CONTROL_REG (0x00)
#define | PHY_STATUS_REG (0x01)
#define | PHY_SPECIFIED_CS_REG (0x11)
#define | PHY_AUTO_NEGOTIATION_BIT (0x1000)
#define | PHY_LOOPBACK_BIT (0x4000)
#define | PHY_RESET_BIT (0x8000)
#define | PHY_LINKED_STATUS_BIT (0x0004)
#define | PHY_NEGO_COMPLETE_BIT (0x0020)
#define | PHY_FULL_DUPLEX_100MBPS_BIT (0x8000)
#define | PHY_HALF_DUPLEX_100MBPS_BIT (0x4000)
#define | PHY_FULL_DUPLEX_10MBPS_BIT (0x2000)
#define | PHY_HALF_DUPLEX_10MBPS_BIT (0x1000)
#define | DELAY 100
#define | FAST 1
#define | SLOW 4
#define | DOMAIN_NAME "www.arterytek.com"

Functions

static void | reset_phy (void)
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR6_DAC_GLOBAL_IRQHandler (void)
this function handles timer6 overflow handler. More...
void | EMAC_IRQHandler (void)
this function handles emac handler. More...
void | dns_test (void)
void | parsing_result (const char *name, ip_addr_t *ipaddr, void *arg)
int | main (void)
main function. More...

Variables

emac_control_config_type mac_control_para
uint8_t | g_speed = 1
volatile uint32_t | local_time = 0

Detailed Description

Macro Definition Documentation

◆ CRYSTAL_ON_PHY

#define CRYSTAL_ON_PHY (0)

Definition at line 48 of file project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h.

◆ DELAY

#define DELAY 100

Definition at line 42 of file project/at_start_f437/examples/emac/dns_client/src/main.c.

◆ DM9162

#define DM9162

Definition at line 53 of file project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h.

◆ DOMAIN_NAME

#define DOMAIN_NAME "www.arterytek.com"

Definition at line 46 of file project/at_start_f437/examples/emac/dns_client/src/main.c.

◆ FAST

#define FAST 1

Definition at line 43 of file project/at_start_f437/examples/emac/dns_client/src/main.c.

◆ LINK_DETECTION

#define LINK_DETECTION (1)

link status detection, 0: no detection, 1: detect with polling

Definition at line 56 of file project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h.

◆ PHY_ADDRESS

#define PHY_ADDRESS (0x03)

relative to at32 board

Definition at line 59 of file project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h.

◆ PHY_AUTO_NEGOTIATION_BIT

#define PHY_AUTO_NEGOTIATION_BIT (0x1000)

enable auto negotiation

Definition at line 64 of file project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h.

◆ PHY_CONTROL_REG

#define PHY_CONTROL_REG (0x00)

basic mode control register

Definition at line 60 of file project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h.

◆ PHY_FULL_DUPLEX_100MBPS_BIT

#define PHY_FULL_DUPLEX_100MBPS_BIT (0x8000)

full duplex 100 mbps

Definition at line 71 of file project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h.

◆ PHY_FULL_DUPLEX_10MBPS_BIT

#define PHY_FULL_DUPLEX_10MBPS_BIT (0x2000)

full duplex 10 mbps

Definition at line 73 of file project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h.

◆ PHY_HALF_DUPLEX_100MBPS_BIT

#define PHY_HALF_DUPLEX_100MBPS_BIT (0x4000)

half duplex 100 mbps

Definition at line 72 of file project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h.

◆ PHY_HALF_DUPLEX_10MBPS_BIT

#define PHY_HALF_DUPLEX_10MBPS_BIT (0x1000)

half duplex 10 mbps

Definition at line 74 of file project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h.

◆ PHY_LINKED_STATUS_BIT

#define PHY_LINKED_STATUS_BIT (0x0004)

link status

Definition at line 68 of file project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h.

◆ PHY_LOOPBACK_BIT

#define PHY_LOOPBACK_BIT (0x4000)

enable loopback

Definition at line 65 of file project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h.

◆ PHY_NEGO_COMPLETE_BIT

#define PHY_NEGO_COMPLETE_BIT (0x0020)

auto negotiation complete

Definition at line 69 of file project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h.

◆ PHY_RESET_BIT

#define PHY_RESET_BIT (0x8000)

reset phy

Definition at line 66 of file project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h.

◆ PHY_SPECIFIED_CS_REG

#define PHY_SPECIFIED_CS_REG (0x11)

specified configuration and status register

Definition at line 62 of file project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h.

◆ PHY_STATUS_REG

#define PHY_STATUS_REG (0x01)

basic mode status register

Definition at line 61 of file project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h.

◆ RMII_MODE

#define RMII_MODE

Definition at line 51 of file project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h.

◆ RX_REMAP

#define RX_REMAP (1)

Definition at line 47 of file project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h.

◆ SLOW

#define SLOW 4

Definition at line 44 of file project/at_start_f437/examples/emac/dns_client/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c.

◆ dns_test()

void dns_test ( void )

Referenced by main().

◆ EMAC_IRQHandler()

void EMAC_IRQHandler ( void )

this function handles emac handler.

Parameters
none
Return values
none

< emac dma receive interrupt

< emac dma normal interrupt summary

Definition at line 156 of file project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 59 of file project/at_start_f437/examples/emac/dns_client/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c.

◆ parsing_result()

void parsing_result | ( | const char * | name,
 |  | ip_addr_t * | ipaddr,
 |  | void * | arg
 | ) |  |

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c.

◆ reset_phy()

static void reset_phy ( void )
static

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c.

◆ TMR6_DAC_GLOBAL_IRQHandler()

void TMR6_DAC_GLOBAL_IRQHandler ( void )

this function handles timer6 overflow handler.

Parameters
none
Return values
none

< tmr flag overflow

< tmr flag overflow

Definition at line 141 of file project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c.

Variable Documentation

◆ g_speed

uint8_t g_speed = 1

Definition at line 48 of file project/at_start_f437/examples/emac/dns_client/src/main.c.

◆ local_time

volatile uint32_t local_time = 0

Definition at line 49 of file project/at_start_f437/examples/emac/dns_client/src/main.c.

Referenced by main().

◆ mac_control_para

emac_control_config_type mac_control_para

Definition at line 40 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

Referenced by emac_layer2_configuration(), and ethernetif_update_config().


AT32F435/437 Firmwary Library: Network_configuration_prototype

Network_configuration_prototype
AT32F437_periph_examples » EMAC_dns_client | AT32F437_periph_examples » EMAC_http_server | AT32F437_periph_examples » EMAC_iperf | AT32F437_periph_examples » EMAC_mqtt_client | AT32F437_periph_examples » EMAC_tcp_client | AT32F437_periph_examples » EMAC_tcp_server | AT32F437_periph_examples » EMAC_telnet | AT32F437_periph_examples » EMAC_wake_on_lan

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: Network_configuration

Macros | Functions | Variables
Network_configuration
AT32F437_periph_examples » EMAC_dns_client | AT32F437_periph_examples » EMAC_http_server | AT32F437_periph_examples » EMAC_iperf | AT32F437_periph_examples » EMAC_mqtt_client | AT32F437_periph_examples » EMAC_tcp_client | AT32F437_periph_examples » EMAC_tcp_server | AT32F437_periph_examples » EMAC_telnet | AT32F437_periph_examples » EMAC_wake_on_lan

Macros

#define | MAC_ADDR_LENGTH (6)
#define | ADDR_LENGTH (4)
#define | SYSTEMTICK_PERIOD_MS 10
#define | MAC_ADDR_LENGTH (6)
#define | ADDR_LENGTH (4)
#define | SYSTEMTICK_PERIOD_MS 10
#define | MAC_ADDR_LENGTH (6)
#define | ADDR_LENGTH (4)
#define | SYSTEMTICK_PERIOD_MS 10
#define | MAC_ADDR_LENGTH (6)
#define | ADDR_LENGTH (4)
#define | SYSTEMTICK_PERIOD_MS 10
#define | MAC_ADDR_LENGTH (6)
#define | ADDR_LENGTH (4)
#define | SYSTEMTICK_PERIOD_MS 10
#define | MAC_ADDR_LENGTH (6)
#define | ADDR_LENGTH (4)
#define | SYSTEMTICK_PERIOD_MS 10
#define | MAC_ADDR_LENGTH (6)
#define | ADDR_LENGTH (4)
#define | SYSTEMTICK_PERIOD_MS 10
#define | MAC_ADDR_LENGTH (6)
#define | ADDR_LENGTH (4)
#define | SYSTEMTICK_PERIOD_MS 10

Functions

void | tcpip_stack_init (void)
initializes the lwip stack More...
void | lwip_pkt_handle (void)
called when a frame is received More...
void | time_update (void)
updates the system local time More...
void | lwip_periodic_handle (volatile uint32_t localtime)
lwip periodic tasks More...

Variables

volatile uint32_t | local_time
struct netif | netif
volatile uint32_t | tcp_timer = 0
volatile uint32_t | arp_timer = 0
volatile uint32_t | link_timer = 0
static uint8_t | mac_address [(6)] = {0, 0, 0x44, 0x45, 0x56, 1}
static uint8_t | local_ip [(4)] = {192, 168, 81, 37}
static uint8_t | local_gw [(4)] = {192, 168, 81, 187}
static uint8_t | local_mask [(4)] = {255, 255, 255, 0}
volatile uint32_t | local_time
struct netif | netif
volatile uint32_t | tcp_timer = 0
volatile uint32_t | arp_timer = 0
volatile uint32_t | link_timer = 0
static uint8_t | mac_address [(6)] = {0, 0, 0x44, 0x45, 0x56, 1}
static uint8_t | local_ip [(4)] = {192, 168, 81, 37}
static uint8_t | local_gw [(4)] = {192, 168, 81, 187}
static uint8_t | local_mask [(4)] = {255, 255, 255, 0}
volatile uint32_t | local_time
struct netif | netif
volatile uint32_t | tcp_timer = 0
volatile uint32_t | arp_timer = 0
volatile uint32_t | link_timer = 0
static uint8_t | mac_address [(6)] = {0, 0, 0x44, 0x45, 0x56, 1}
static uint8_t | local_ip [(4)] = {192, 168, 81, 37}
static uint8_t | local_gw [(4)] = {192, 168, 81, 187}
static uint8_t | local_mask [(4)] = {255, 255, 255, 0}
uint8_t | message_cnt = 0
char | message_test [] = "Hello mqtt server, 000"
mqtt_client_t * | s__mqtt_client_instance
volatile uint32_t | local_time
struct netif | netif
struct tcp_pcb * | pcb
volatile uint32_t | tcp_timer = 0
volatile uint32_t | arp_timer = 0
volatile uint32_t | link_timer = 0
volatile uint32_t | mqtt_send_timer = 0
static uint8_t | mac_address [(6)] = {0, 0, 0x44, 0x45, 0x56, 1}
static uint8_t | local_ip [(4)] = {192, 168, 81, 37}
static uint8_t | local_gw [(4)] = {192, 168, 81, 187}
static uint8_t | local_mask [(4)] = {255, 255, 255, 0}
volatile uint32_t | local_time
struct netif | netif
struct tcp_pcb * | pcb
volatile uint32_t | tcp_timer = 0
volatile uint32_t | arp_timer = 0
volatile uint32_t | link_timer = 0
volatile uint32_t | tcp_send_timer = 0
static uint8_t | mac_address [(6)] = {0, 0, 0x44, 0x45, 0x56, 1}
static uint8_t | local_ip [(4)] = {192, 168, 81, 37}
static uint8_t | local_gw [(4)] = {192, 168, 81, 187}
static uint8_t | local_mask [(4)] = {255, 255, 255, 0}
volatile uint32_t | local_time
struct netif | netif
volatile uint32_t | tcp_timer = 0
volatile uint32_t | arp_timer = 0
volatile uint32_t | link_timer = 0
static uint8_t | mac_address [(6)] = {0, 0, 0x44, 0x45, 0x56, 1}
static uint8_t | local_ip [(4)] = {192, 168, 81, 37}
static uint8_t | local_gw [(4)] = {192, 168, 81, 187}
static uint8_t | local_mask [(4)] = {255, 255, 255, 0}
volatile uint32_t | local_time
struct netif | netif
volatile uint32_t | tcp_timer = 0
volatile uint32_t | arp_timer = 0
volatile uint32_t | link_timer = 0
static uint8_t | mac_address [(6)] = {0, 0, 0x44, 0x45, 0x56, 1}
static uint8_t | local_ip [(4)] = {192, 168, 81, 37}
static uint8_t | local_gw [(4)] = {192, 168, 81, 187}
static uint8_t | local_mask [(4)] = {255, 255, 255, 0}
volatile uint32_t | local_time
struct netif | netif
volatile uint32_t | tcp_timer = 0
volatile uint32_t | arp_timer = 0
volatile uint32_t | link_timer = 0
static uint8_t | mac_address [(6)] = {0, 0, 0x44, 0x45, 0x56, 1}
static uint8_t | local_ip [(4)] = {192, 168, 81, 37}
static uint8_t | local_gw [(4)] = {192, 168, 81, 187}
static uint8_t | local_mask [(4)] = {255, 255, 255, 0}

Detailed Description

Macro Definition Documentation

◆ ADDR_LENGTH [1/8]

#define ADDR_LENGTH (4)

Definition at line 55 of file project/at_start_f437/examples/emac/dns_client/src/netconf.c.

◆ ADDR_LENGTH [2/8]

#define ADDR_LENGTH (4)

Definition at line 54 of file project/at_start_f437/examples/emac/http_server/src/netconf.c.

◆ ADDR_LENGTH [3/8]

#define ADDR_LENGTH (4)

Definition at line 54 of file project/at_start_f437/examples/emac/iperf/src/netconf.c.

◆ ADDR_LENGTH [4/8]

#define ADDR_LENGTH (4)

Definition at line 55 of file project/at_start_f437/examples/emac/mqtt_client/src/netconf.c.

◆ ADDR_LENGTH [5/8]

#define ADDR_LENGTH (4)

Definition at line 55 of file project/at_start_f437/examples/emac/tcp_client/src/netconf.c.

◆ ADDR_LENGTH [6/8]

#define ADDR_LENGTH (4)

Definition at line 54 of file project/at_start_f437/examples/emac/tcp_server/src/netconf.c.

◆ ADDR_LENGTH [7/8]

#define ADDR_LENGTH (4)

Definition at line 54 of file project/at_start_f437/examples/emac/telnet/src/netconf.c.

◆ ADDR_LENGTH [8/8]

#define ADDR_LENGTH (4)

Definition at line 54 of file project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c.

◆ MAC_ADDR_LENGTH [1/8]

#define MAC_ADDR_LENGTH (6)

Definition at line 54 of file project/at_start_f437/examples/emac/dns_client/src/netconf.c.

◆ MAC_ADDR_LENGTH [2/8]

#define MAC_ADDR_LENGTH (6)

Definition at line 53 of file project/at_start_f437/examples/emac/http_server/src/netconf.c.

◆ MAC_ADDR_LENGTH [3/8]

#define MAC_ADDR_LENGTH (6)

Definition at line 53 of file project/at_start_f437/examples/emac/iperf/src/netconf.c.

◆ MAC_ADDR_LENGTH [4/8]

#define MAC_ADDR_LENGTH (6)

Definition at line 54 of file project/at_start_f437/examples/emac/mqtt_client/src/netconf.c.

◆ MAC_ADDR_LENGTH [5/8]

#define MAC_ADDR_LENGTH (6)

Definition at line 54 of file project/at_start_f437/examples/emac/tcp_client/src/netconf.c.

◆ MAC_ADDR_LENGTH [6/8]

#define MAC_ADDR_LENGTH (6)

Definition at line 53 of file project/at_start_f437/examples/emac/tcp_server/src/netconf.c.

◆ MAC_ADDR_LENGTH [7/8]

#define MAC_ADDR_LENGTH (6)

Definition at line 53 of file project/at_start_f437/examples/emac/telnet/src/netconf.c.

◆ MAC_ADDR_LENGTH [8/8]

#define MAC_ADDR_LENGTH (6)

Definition at line 53 of file project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c.

◆ SYSTEMTICK_PERIOD_MS [1/8]

#define SYSTEMTICK_PERIOD_MS 10

Definition at line 56 of file project/at_start_f437/examples/emac/dns_client/src/netconf.c.

◆ SYSTEMTICK_PERIOD_MS [2/8]

#define SYSTEMTICK_PERIOD_MS 10

Definition at line 55 of file project/at_start_f437/examples/emac/http_server/src/netconf.c.

◆ SYSTEMTICK_PERIOD_MS [3/8]

#define SYSTEMTICK_PERIOD_MS 10

Definition at line 55 of file project/at_start_f437/examples/emac/iperf/src/netconf.c.

◆ SYSTEMTICK_PERIOD_MS [4/8]

#define SYSTEMTICK_PERIOD_MS 10

Definition at line 56 of file project/at_start_f437/examples/emac/mqtt_client/src/netconf.c.

◆ SYSTEMTICK_PERIOD_MS [5/8]

#define SYSTEMTICK_PERIOD_MS 10

Definition at line 56 of file project/at_start_f437/examples/emac/tcp_client/src/netconf.c.

◆ SYSTEMTICK_PERIOD_MS [6/8]

#define SYSTEMTICK_PERIOD_MS 10

Definition at line 55 of file project/at_start_f437/examples/emac/tcp_server/src/netconf.c.

◆ SYSTEMTICK_PERIOD_MS [7/8]

#define SYSTEMTICK_PERIOD_MS 10

Definition at line 55 of file project/at_start_f437/examples/emac/telnet/src/netconf.c.

◆ SYSTEMTICK_PERIOD_MS [8/8]

#define SYSTEMTICK_PERIOD_MS 10

Definition at line 55 of file project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c.

Function Documentation

◆ lwip_periodic_handle()

void lwip_periodic_handle ( volatile uint32_t localtime )

lwip periodic tasks

Parameters
localtime the current localtime value
Return values
none

Definition at line 168 of file project/at_start_f437/examples/emac/dns_client/src/netconf.c.

◆ lwip_pkt_handle()

void lwip_pkt_handle ( void )

called when a frame is received

Parameters
none
Return values
none

Definition at line 144 of file project/at_start_f437/examples/emac/dns_client/src/netconf.c.

◆ tcpip_stack_init()

void tcpip_stack_init ( void )

initializes the lwip stack

Parameters
none
Return values
none

Definition at line 85 of file project/at_start_f437/examples/emac/dns_client/src/netconf.c.

◆ time_update()

void time_update ( void )

updates the system local time

Parameters
none
Return values
none

Definition at line 158 of file project/at_start_f437/examples/emac/dns_client/src/netconf.c.

Variable Documentation

◆ arp_timer [1/8]

volatile uint32_t arp_timer = 0

Definition at line 61 of file project/at_start_f437/examples/emac/dns_client/src/netconf.c.

Referenced by lwip_periodic_handle().

◆ arp_timer [2/8]

volatile uint32_t arp_timer = 0

Definition at line 60 of file project/at_start_f437/examples/emac/http_server/src/netconf.c.

Referenced by lwip_periodic_handle().

◆ arp_timer [3/8]

volatile uint32_t arp_timer = 0

Definition at line 60 of file project/at_start_f437/examples/emac/iperf/src/netconf.c.

◆ arp_timer [4/8]

volatile uint32_t arp_timer = 0

Definition at line 65 of file project/at_start_f437/examples/emac/mqtt_client/src/netconf.c.

◆ arp_timer [5/8]

volatile uint32_t arp_timer = 0

Definition at line 62 of file project/at_start_f437/examples/emac/tcp_client/src/netconf.c.

◆ arp_timer [6/8]

volatile uint32_t arp_timer = 0

Definition at line 60 of file project/at_start_f437/examples/emac/tcp_server/src/netconf.c.

◆ arp_timer [7/8]

volatile uint32_t arp_timer = 0

Definition at line 60 of file project/at_start_f437/examples/emac/telnet/src/netconf.c.

◆ arp_timer [8/8]

volatile uint32_t arp_timer = 0

Definition at line 60 of file project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c.

◆ link_timer [1/8]

volatile uint32_t link_timer = 0

Definition at line 62 of file project/at_start_f437/examples/emac/dns_client/src/netconf.c.

Referenced by lwip_periodic_handle().

◆ link_timer [2/8]

volatile uint32_t link_timer = 0

Definition at line 61 of file project/at_start_f437/examples/emac/http_server/src/netconf.c.

Referenced by lwip_periodic_handle().

◆ link_timer [3/8]

volatile uint32_t link_timer = 0

Definition at line 61 of file project/at_start_f437/examples/emac/iperf/src/netconf.c.

◆ link_timer [4/8]

volatile uint32_t link_timer = 0

Definition at line 66 of file project/at_start_f437/examples/emac/mqtt_client/src/netconf.c.

◆ link_timer [5/8]

volatile uint32_t link_timer = 0

Definition at line 63 of file project/at_start_f437/examples/emac/tcp_client/src/netconf.c.

◆ link_timer [6/8]

volatile uint32_t link_timer = 0

Definition at line 61 of file project/at_start_f437/examples/emac/tcp_server/src/netconf.c.

◆ link_timer [7/8]

volatile uint32_t link_timer = 0

Definition at line 61 of file project/at_start_f437/examples/emac/telnet/src/netconf.c.

◆ link_timer [8/8]

volatile uint32_t link_timer = 0

Definition at line 61 of file project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c.

◆ local_gw [1/8]

uint8_t local_gw[(4)] = {192, 168, 81, 187}
static

Definition at line 73 of file project/at_start_f437/examples/emac/dns_client/src/netconf.c.

Referenced by tcpip_stack_init().

◆ local_gw [2/8]

uint8_t local_gw[(4)] = {192, 168, 81, 187}
static

Definition at line 69 of file project/at_start_f437/examples/emac/http_server/src/netconf.c.

Referenced by tcpip_stack_init().

◆ local_gw [3/8]

uint8_t local_gw[(4)] = {192, 168, 81, 187}
static

Definition at line 69 of file project/at_start_f437/examples/emac/iperf/src/netconf.c.

◆ local_gw [4/8]

uint8_t local_gw[(4)] = {192, 168, 81, 187}
static

Definition at line 75 of file project/at_start_f437/examples/emac/mqtt_client/src/netconf.c.

◆ local_gw [5/8]

uint8_t local_gw[(4)] = {192, 168, 81, 187}
static

Definition at line 72 of file project/at_start_f437/examples/emac/tcp_client/src/netconf.c.

◆ local_gw [6/8]

uint8_t local_gw[(4)] = {192, 168, 81, 187}
static

Definition at line 69 of file project/at_start_f437/examples/emac/tcp_server/src/netconf.c.

◆ local_gw [7/8]

uint8_t local_gw[(4)] = {192, 168, 81, 187}
static

Definition at line 69 of file project/at_start_f437/examples/emac/telnet/src/netconf.c.

◆ local_gw [8/8]

uint8_t local_gw[(4)] = {192, 168, 81, 187}
static

Definition at line 69 of file project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c.

◆ local_ip [1/8]

uint8_t local_ip[(4)] = {192, 168, 81, 37}
static

Definition at line 72 of file project/at_start_f437/examples/emac/dns_client/src/netconf.c.

Referenced by tcpip_stack_init().

◆ local_ip [2/8]

uint8_t local_ip[(4)] = {192, 168, 81, 37}
static

Definition at line 68 of file project/at_start_f437/examples/emac/http_server/src/netconf.c.

Referenced by tcpip_stack_init().

◆ local_ip [3/8]

uint8_t local_ip[(4)] = {192, 168, 81, 37}
static

Definition at line 68 of file project/at_start_f437/examples/emac/iperf/src/netconf.c.

◆ local_ip [4/8]

uint8_t local_ip[(4)] = {192, 168, 81, 37}
static

Definition at line 74 of file project/at_start_f437/examples/emac/mqtt_client/src/netconf.c.

◆ local_ip [5/8]

uint8_t local_ip[(4)] = {192, 168, 81, 37}
static

Definition at line 71 of file project/at_start_f437/examples/emac/tcp_client/src/netconf.c.

◆ local_ip [6/8]

uint8_t local_ip[(4)] = {192, 168, 81, 37}
static

Definition at line 68 of file project/at_start_f437/examples/emac/tcp_server/src/netconf.c.

◆ local_ip [7/8]

uint8_t local_ip[(4)] = {192, 168, 81, 37}
static

Definition at line 68 of file project/at_start_f437/examples/emac/telnet/src/netconf.c.

◆ local_ip [8/8]

uint8_t local_ip[(4)] = {192, 168, 81, 37}
static

Definition at line 68 of file project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c.

◆ local_mask [1/8]

uint8_t local_mask[(4)] = {255, 255, 255, 0}
static

Definition at line 74 of file project/at_start_f437/examples/emac/dns_client/src/netconf.c.

Referenced by tcpip_stack_init().

◆ local_mask [2/8]

uint8_t local_mask[(4)] = {255, 255, 255, 0}
static

Definition at line 70 of file project/at_start_f437/examples/emac/http_server/src/netconf.c.

Referenced by tcpip_stack_init().

◆ local_mask [3/8]

uint8_t local_mask[(4)] = {255, 255, 255, 0}
static

Definition at line 70 of file project/at_start_f437/examples/emac/iperf/src/netconf.c.

◆ local_mask [4/8]

uint8_t local_mask[(4)] = {255, 255, 255, 0}
static

Definition at line 76 of file project/at_start_f437/examples/emac/mqtt_client/src/netconf.c.

◆ local_mask [5/8]

uint8_t local_mask[(4)] = {255, 255, 255, 0}
static

Definition at line 73 of file project/at_start_f437/examples/emac/tcp_client/src/netconf.c.

◆ local_mask [6/8]

uint8_t local_mask[(4)] = {255, 255, 255, 0}
static

Definition at line 70 of file project/at_start_f437/examples/emac/tcp_server/src/netconf.c.

◆ local_mask [7/8]

uint8_t local_mask[(4)] = {255, 255, 255, 0}
static

Definition at line 70 of file project/at_start_f437/examples/emac/telnet/src/netconf.c.

◆ local_mask [8/8]

uint8_t local_mask[(4)] = {255, 255, 255, 0}
static

Definition at line 70 of file project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c.

◆ local_time [1/8]

volatile uint32_t local_time
extern

Definition at line 49 of file project/at_start_f437/examples/emac/dns_client/src/main.c.

Referenced by time_update().

◆ local_time [2/8]

volatile uint32_t local_time
extern

Definition at line 49 of file project/at_start_f437/examples/emac/dns_client/src/main.c.

Referenced by time_update().

◆ local_time [3/8]

volatile uint32_t local_time
extern

Definition at line 49 of file project/at_start_f437/examples/emac/dns_client/src/main.c.

◆ local_time [4/8]

volatile uint32_t local_time
extern

Definition at line 49 of file project/at_start_f437/examples/emac/dns_client/src/main.c.

◆ local_time [5/8]

volatile uint32_t local_time
extern

Definition at line 49 of file project/at_start_f437/examples/emac/dns_client/src/main.c.

◆ local_time [6/8]

volatile uint32_t local_time
extern

Definition at line 49 of file project/at_start_f437/examples/emac/dns_client/src/main.c.

◆ local_time [7/8]

volatile uint32_t local_time
extern

Definition at line 49 of file project/at_start_f437/examples/emac/dns_client/src/main.c.

◆ local_time [8/8]

volatile uint32_t local_time
extern

Definition at line 49 of file project/at_start_f437/examples/emac/dns_client/src/main.c.

◆ mac_address [1/8]

uint8_t mac_address[(6)] = {0, 0, 0x44, 0x45, 0x56, 1}
static

Definition at line 67 of file project/at_start_f437/examples/emac/dns_client/src/netconf.c.

Referenced by tcpip_stack_init().

◆ mac_address [2/8]

uint8_t mac_address[(6)] = {0, 0, 0x44, 0x45, 0x56, 1}
static

Definition at line 63 of file project/at_start_f437/examples/emac/http_server/src/netconf.c.

Referenced by tcpip_stack_init().

◆ mac_address [3/8]

uint8_t mac_address[(6)] = {0, 0, 0x44, 0x45, 0x56, 1}
static

Definition at line 63 of file project/at_start_f437/examples/emac/iperf/src/netconf.c.

◆ mac_address [4/8]

uint8_t mac_address[(6)] = {0, 0, 0x44, 0x45, 0x56, 1}
static

Definition at line 69 of file project/at_start_f437/examples/emac/mqtt_client/src/netconf.c.

◆ mac_address [5/8]

uint8_t mac_address[(6)] = {0, 0, 0x44, 0x45, 0x56, 1}
static

Definition at line 66 of file project/at_start_f437/examples/emac/tcp_client/src/netconf.c.

◆ mac_address [6/8]

uint8_t mac_address[(6)] = {0, 0, 0x44, 0x45, 0x56, 1}
static

Definition at line 63 of file project/at_start_f437/examples/emac/tcp_server/src/netconf.c.

◆ mac_address [7/8]

uint8_t mac_address[(6)] = {0, 0, 0x44, 0x45, 0x56, 1}
static

Definition at line 63 of file project/at_start_f437/examples/emac/telnet/src/netconf.c.

◆ mac_address [8/8]

uint8_t mac_address[(6)] = {0, 0, 0x44, 0x45, 0x56, 1}
static

Definition at line 63 of file project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c.

◆ message_cnt

uint8_t message_cnt = 0

Definition at line 58 of file project/at_start_f437/examples/emac/mqtt_client/src/netconf.c.

◆ message_test

char message_test[] = "Hello mqtt server, 000"

Definition at line 59 of file project/at_start_f437/examples/emac/mqtt_client/src/netconf.c.

◆ mqtt_send_timer

volatile uint32_t mqtt_send_timer = 0

Definition at line 67 of file project/at_start_f437/examples/emac/mqtt_client/src/netconf.c.

◆ netif [1/8]

struct netif netif

Definition at line 59 of file project/at_start_f437/examples/emac/dns_client/src/netconf.c.

Referenced by ethernetif_notify_conn_changed(), ethernetif_set_link(), ethernetif_update_config(), lwip_periodic_handle(), lwip_pkt_handle(), and tcpip_stack_init().

◆ netif [2/8]

struct netif netif

Definition at line 58 of file project/at_start_f437/examples/emac/http_server/src/netconf.c.

Referenced by lwip_periodic_handle(), lwip_pkt_handle(), and tcpip_stack_init().

◆ netif [3/8]

struct netif netif

Definition at line 58 of file project/at_start_f437/examples/emac/iperf/src/netconf.c.

◆ netif [4/8]

struct netif netif

Definition at line 62 of file project/at_start_f437/examples/emac/mqtt_client/src/netconf.c.

◆ netif [5/8]

struct netif netif

Definition at line 59 of file project/at_start_f437/examples/emac/tcp_client/src/netconf.c.

◆ netif [6/8]

struct netif netif

Definition at line 58 of file project/at_start_f437/examples/emac/tcp_server/src/netconf.c.

◆ netif [7/8]

struct netif netif

Definition at line 58 of file project/at_start_f437/examples/emac/telnet/src/netconf.c.

◆ netif [8/8]

struct netif netif

Definition at line 58 of file project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c.

◆ pcb [1/2]

struct tcp_pcb* pcb

Definition at line 63 of file project/at_start_f437/examples/emac/mqtt_client/src/netconf.c.

Referenced by helloworld_accept(), helloworld_init(), helloworld_recv(), http_accept(), http_check_eof(), http_close_conn(), http_close_or_abort_conn(), http_eof(), http_poll(), http_recv(), http_send(), http_send_data_nonssi(), http_sent(), http_write(), httpd_init(), httpd_init_pcb(), iperf_accept(), iperf_init(), iperf_recv(), tcp_client_recv(), tcp_server_accept(), tcp_server_init(), and tcp_server_recv().

◆ pcb [2/2]

struct tcp_pcb* pcb

Definition at line 60 of file project/at_start_f437/examples/emac/tcp_client/src/netconf.c.

◆ s__mqtt_client_instance

mqtt_client_t* s__mqtt_client_instance
extern

Definition at line 44 of file mqtt_client.c.

Referenced by mqtt_client_init().

◆ tcp_send_timer

volatile uint32_t tcp_send_timer = 0

Definition at line 64 of file project/at_start_f437/examples/emac/tcp_client/src/netconf.c.

◆ tcp_timer [1/8]

volatile uint32_t tcp_timer = 0

Definition at line 60 of file project/at_start_f437/examples/emac/dns_client/src/netconf.c.

Referenced by lwip_periodic_handle().

◆ tcp_timer [2/8]

volatile uint32_t tcp_timer = 0

Definition at line 59 of file project/at_start_f437/examples/emac/http_server/src/netconf.c.

Referenced by lwip_periodic_handle().

◆ tcp_timer [3/8]

volatile uint32_t tcp_timer = 0

Definition at line 59 of file project/at_start_f437/examples/emac/iperf/src/netconf.c.

◆ tcp_timer [4/8]

volatile uint32_t tcp_timer = 0

Definition at line 64 of file project/at_start_f437/examples/emac/mqtt_client/src/netconf.c.

◆ tcp_timer [5/8]

volatile uint32_t tcp_timer = 0

Definition at line 61 of file project/at_start_f437/examples/emac/tcp_client/src/netconf.c.

◆ tcp_timer [6/8]

volatile uint32_t tcp_timer = 0

Definition at line 59 of file project/at_start_f437/examples/emac/tcp_server/src/netconf.c.

◆ tcp_timer [7/8]

volatile uint32_t tcp_timer = 0

Definition at line 59 of file project/at_start_f437/examples/emac/telnet/src/netconf.c.

◆ tcp_timer [8/8]

volatile uint32_t tcp_timer = 0

Definition at line 59 of file project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c.


AT32F435/437 Firmwary Library: EMAC_http_server

Modules | Data Structures | Macros | Functions | Variables
EMAC_http_server
AT32F437_periph_examples

Modules

Network_configuration_prototype
Filesystem
Network_configuration

Data Structures

struct | default_filename
struct | http_state

Macros

#define | RX_REMAP (1)
#define | CRYSTAL_ON_PHY (0)
#define | RMII_MODE
#define | DM9162
#define | LINK_DETECTION (1)
#define | PHY_ADDRESS (0x03)
#define | PHY_CONTROL_REG (0x00)
#define | PHY_STATUS_REG (0x01)
#define | PHY_SPECIFIED_CS_REG (0x11)
#define | PHY_AUTO_NEGOTIATION_BIT (0x1000)
#define | PHY_LOOPBACK_BIT (0x4000)
#define | PHY_RESET_BIT (0x8000)
#define | PHY_LINKED_STATUS_BIT (0x0004)
#define | PHY_NEGO_COMPLETE_BIT (0x0020)
#define | PHY_FULL_DUPLEX_100MBPS_BIT (0x8000)
#define | PHY_HALF_DUPLEX_100MBPS_BIT (0x4000)
#define | PHY_FULL_DUPLEX_10MBPS_BIT (0x2000)
#define | PHY_HALF_DUPLEX_10MBPS_BIT (0x1000)
#define | MIN_REQ_LEN 7
#define | CRLF "\r\n"
#define | HTTP_IS_DYNAMIC_FILE(hs) 0
#define | HTTP_IS_DATA_VOLATILE(hs) (HTTP_IS_DYNAMIC_FILE(hs) ? TCP_WRITE_FLAG_COPY : 0)
#define | HTTP_IS_HDR_VOLATILE(hs, ptr) 0
#define | HTTP_DATA_TO_SEND_FREED 3
#define | HTTP_DATA_TO_SEND_BREAK 2
#define | HTTP_DATA_TO_SEND_CONTINUE 1
#define | HTTP_NO_DATA_TO_SEND 0
#define | CUSTOM_HTTP_SERVER
#define | NUM_DEFAULT_FILENAMES LWIP_ARRAYSIZE(httpd_default_filenames)
#define | LWIP_HTTPD_URI_BUF_LEN LWIP_HTTPD_MAX_REQUEST_URI_LEN
#define | HTTP_ALLOC_HTTP_STATE() (struct http_state *)mem_malloc(sizeof(struct http_state))
#define | HTTP_FREE_HTTP_STATE(x) mem_free(x)
#define | http_add_connection(hs)
#define | http_remove_connection(hs)
#define | http_find_error_file(hs, error_nr) ERR_ARG
#define | DELAY 100
#define | FAST 1
#define | SLOW 4

Functions

error_status | emac_system_init (void)
enable emac clock and gpio clock More...
void | emac_nvic_configuration (void)
configures emac irq channel. More...
void | emac_pins_configuration (void)
configures emac required pins. More...
error_status | emac_layer2_configuration (void)
configures emac layer2 More...
static void | reset_phy (void)
error_status | emac_phy_register_reset (void)
reset phy register More...
error_status | emac_speed_config (emac_auto_negotiation_type nego, emac_duplex_type mode, emac_speed_type speed)
set mac speed related parameters More...
error_status | emac_phy_init (emac_control_config_type *control_para)
initialize emac phy More...
uint16_t | link_update (void)
updates the link states More...
void | ethernetif_set_link (void const *argument)
this function sets the netif link status. More...
void | ethernetif_notify_conn_changed (struct netif *netif)
this function notify user about link status changement. More...
void | ethernetif_update_config (struct netif *netif)
link callback function, this function is called on change of link status to update low level driver configuration. More...
void | emac_tmr_init (void)
initialize tmr6 for emac More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR6_DAC_GLOBAL_IRQHandler (void)
this function handles timer6 overflow handler. More...
void | EMAC_IRQHandler (void)
this function handles emac handler. More...
static err_t | http_close_conn (struct altcp_pcb *pcb, struct http_state *hs)
static err_t | http_close_or_abort_conn (struct altcp_pcb *pcb, struct http_state *hs, uint8_t abort_conn)
static err_t | http_poll (void *arg, struct altcp_pcb *pcb)
static uint8_t | http_check_eof (struct altcp_pcb *pcb, struct http_state *hs)
static void | http_state_init (struct http_state *hs)
static struct http_state * | http_state_alloc (void)
static void | http_state_eof (struct http_state *hs)
static void | http_state_free (struct http_state *hs)
static err_t | http_write (struct altcp_pcb *pcb, const void *ptr, uint16_t *length, uint8_t apiflags)
static void | http_eof (struct altcp_pcb *pcb, struct http_state *hs)
static uint8_t | http_send_data_nonssi (struct altcp_pcb *pcb, struct http_state *hs)
static uint8_t | http_send (struct altcp_pcb *pcb, struct http_state *hs)
static void | http_err (void *arg, err_t err)
static err_t | http_sent (void *arg, struct altcp_pcb *pcb, uint16_t len)
static err_t | http_recv (void *arg, struct altcp_pcb *pcb, struct pbuf *p, err_t err)
static err_t | http_accept (void *arg, struct altcp_pcb *pcb, err_t err)
static void | httpd_init_pcb (struct altcp_pcb *pcb, uint16_t port)
void | httpd_init (void)
void | adc_configuration (void)
int | main (void)
main function. More...

Variables

emac_control_config_type mac_control_para
char | html_tmp [4096] = {0}
uint8_t | g_speed = 1
volatile uint32_t | local_time = 0

Detailed Description

Macro Definition Documentation

◆ CRLF

#define CRLF "\r\n"

Definition at line 79 of file httpd.c.

◆ CRYSTAL_ON_PHY

#define CRYSTAL_ON_PHY (0)

Definition at line 48 of file project/at_start_f437/examples/emac/http_server/inc/at32_emac.h.

◆ CUSTOM_HTTP_SERVER

#define CUSTOM_HTTP_SERVER

Definition at line 108 of file httpd.c.

◆ DELAY

#define DELAY 100

Definition at line 41 of file project/at_start_f437/examples/emac/http_server/src/main.c.

◆ DM9162

#define DM9162

Definition at line 53 of file project/at_start_f437/examples/emac/http_server/inc/at32_emac.h.

◆ FAST

#define FAST 1

Definition at line 42 of file project/at_start_f437/examples/emac/http_server/src/main.c.

◆ http_add_connection

#define http_add_connection ( hs )

Definition at line 357 of file httpd.c.

◆ HTTP_ALLOC_HTTP_STATE

#define HTTP_ALLOC_HTTP_STATE ( ) (struct http_state *)mem_malloc(sizeof(struct http_state))

Definition at line 250 of file httpd.c.

◆ HTTP_DATA_TO_SEND_BREAK

#define HTTP_DATA_TO_SEND_BREAK 2

Definition at line 104 of file httpd.c.

◆ HTTP_DATA_TO_SEND_CONTINUE

#define HTTP_DATA_TO_SEND_CONTINUE 1

Definition at line 105 of file httpd.c.

◆ HTTP_DATA_TO_SEND_FREED

#define HTTP_DATA_TO_SEND_FREED 3

Definition at line 103 of file httpd.c.

◆ http_find_error_file

#define http_find_error_file | ( | hs,
 |  | error_nr
 | ) | ERR_ARG

Definition at line 1539 of file httpd.c.

◆ HTTP_FREE_HTTP_STATE

#define HTTP_FREE_HTTP_STATE ( x ) mem_free(x)

Definition at line 251 of file httpd.c.

◆ HTTP_IS_DATA_VOLATILE

#define HTTP_IS_DATA_VOLATILE ( hs ) (HTTP_IS_DYNAMIC_FILE(hs) ? TCP_WRITE_FLAG_COPY : 0)

tcp_write does not have to copy data when sent from rom-file-system directly

Definition at line 95 of file httpd.c.

◆ HTTP_IS_DYNAMIC_FILE

#define HTTP_IS_DYNAMIC_FILE ( hs ) 0

Definition at line 88 of file httpd.c.

◆ HTTP_IS_HDR_VOLATILE

#define HTTP_IS_HDR_VOLATILE | ( | hs,
 |  | ptr
 | ) | 0

Default: dynamic headers are sent from ROM (non-dynamic headers are handled like file data)

Definition at line 99 of file httpd.c.

◆ HTTP_NO_DATA_TO_SEND

#define HTTP_NO_DATA_TO_SEND 0

Definition at line 106 of file httpd.c.

◆ http_remove_connection

#define http_remove_connection ( hs )

Definition at line 358 of file httpd.c.

◆ LINK_DETECTION

#define LINK_DETECTION (1)

link status detection, 0: no detection, 1: detect with polling

Definition at line 56 of file project/at_start_f437/examples/emac/http_server/inc/at32_emac.h.

◆ LWIP_HTTPD_URI_BUF_LEN

#define LWIP_HTTPD_URI_BUF_LEN LWIP_HTTPD_MAX_REQUEST_URI_LEN

Definition at line 130 of file httpd.c.

◆ MIN_REQ_LEN

#define MIN_REQ_LEN 7

Minimum length for a valid HTTP/0.9 request: "GET /\r\n" -> 7 bytes

Definition at line 77 of file httpd.c.

◆ NUM_DEFAULT_FILENAMES

#define NUM_DEFAULT_FILENAMES LWIP_ARRAYSIZE(httpd_default_filenames)

Definition at line 117 of file httpd.c.

◆ PHY_ADDRESS

#define PHY_ADDRESS (0x03)

relative to at32 board

Definition at line 59 of file project/at_start_f437/examples/emac/http_server/inc/at32_emac.h.

◆ PHY_AUTO_NEGOTIATION_BIT

#define PHY_AUTO_NEGOTIATION_BIT (0x1000)

enable auto negotiation

Definition at line 64 of file project/at_start_f437/examples/emac/http_server/inc/at32_emac.h.

◆ PHY_CONTROL_REG

#define PHY_CONTROL_REG (0x00)

basic mode control register

Definition at line 60 of file project/at_start_f437/examples/emac/http_server/inc/at32_emac.h.

◆ PHY_FULL_DUPLEX_100MBPS_BIT

#define PHY_FULL_DUPLEX_100MBPS_BIT (0x8000)

full duplex 100 mbps

Definition at line 71 of file project/at_start_f437/examples/emac/http_server/inc/at32_emac.h.

◆ PHY_FULL_DUPLEX_10MBPS_BIT

#define PHY_FULL_DUPLEX_10MBPS_BIT (0x2000)

full duplex 10 mbps

Definition at line 73 of file project/at_start_f437/examples/emac/http_server/inc/at32_emac.h.

◆ PHY_HALF_DUPLEX_100MBPS_BIT

#define PHY_HALF_DUPLEX_100MBPS_BIT (0x4000)

half duplex 100 mbps

Definition at line 72 of file project/at_start_f437/examples/emac/http_server/inc/at32_emac.h.

◆ PHY_HALF_DUPLEX_10MBPS_BIT

#define PHY_HALF_DUPLEX_10MBPS_BIT (0x1000)

half duplex 10 mbps

Definition at line 74 of file project/at_start_f437/examples/emac/http_server/inc/at32_emac.h.

◆ PHY_LINKED_STATUS_BIT

#define PHY_LINKED_STATUS_BIT (0x0004)

link status

Definition at line 68 of file project/at_start_f437/examples/emac/http_server/inc/at32_emac.h.

◆ PHY_LOOPBACK_BIT

#define PHY_LOOPBACK_BIT (0x4000)

enable loopback

Definition at line 65 of file project/at_start_f437/examples/emac/http_server/inc/at32_emac.h.

◆ PHY_NEGO_COMPLETE_BIT

#define PHY_NEGO_COMPLETE_BIT (0x0020)

auto negotiation complete

Definition at line 69 of file project/at_start_f437/examples/emac/http_server/inc/at32_emac.h.

◆ PHY_RESET_BIT

#define PHY_RESET_BIT (0x8000)

reset phy

Definition at line 66 of file project/at_start_f437/examples/emac/http_server/inc/at32_emac.h.

◆ PHY_SPECIFIED_CS_REG

#define PHY_SPECIFIED_CS_REG (0x11)

specified configuration and status register

Definition at line 62 of file project/at_start_f437/examples/emac/http_server/inc/at32_emac.h.

◆ PHY_STATUS_REG

#define PHY_STATUS_REG (0x01)

basic mode status register

Definition at line 61 of file project/at_start_f437/examples/emac/http_server/inc/at32_emac.h.

◆ RMII_MODE

#define RMII_MODE

Definition at line 51 of file project/at_start_f437/examples/emac/http_server/inc/at32_emac.h.

◆ RX_REMAP

#define RX_REMAP (1)

Definition at line 47 of file project/at_start_f437/examples/emac/http_server/inc/at32_emac.h.

◆ SLOW

#define SLOW 4

Definition at line 43 of file project/at_start_f437/examples/emac/http_server/src/main.c.

Function Documentation

◆ adc_configuration()

void adc_configuration ( void )

< gpio pins number 4

< adc ready to conversion flag

Definition at line 82 of file project/at_start_f437/examples/emac/http_server/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c.

◆ EMAC_IRQHandler()

void EMAC_IRQHandler ( void )

this function handles emac handler.

Parameters
none
Return values
none

< emac dma receive interrupt

< emac dma normal interrupt summary

Definition at line 156 of file project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c.

◆ emac_layer2_configuration()

error_status emac_layer2_configuration ( void )

configures emac layer2

Parameters
none
Return values
error or success

Definition at line 205 of file project/at_start_f437/examples/emac/http_server/src/at32_emac.c.

◆ emac_nvic_configuration()

void emac_nvic_configuration ( void )

configures emac irq channel.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f437/examples/emac/http_server/src/at32_emac.c.

◆ emac_phy_init()

error_status emac_phy_init ( emac_control_config_type * control_para )

initialize emac phy

Parameters
none
Return values
SUCCESS or ERROR

Definition at line 455 of file project/at_start_f437/examples/emac/http_server/src/at32_emac.c.

◆ emac_phy_register_reset()

error_status emac_phy_register_reset ( void )

reset phy register

Parameters
none
Return values
SUCCESS or ERROR

Definition at line 291 of file project/at_start_f437/examples/emac/http_server/src/at32_emac.c.

◆ emac_pins_configuration()

void emac_pins_configuration ( void )

configures emac required pins.

Parameters
none
Return values
none

Definition at line 80 of file project/at_start_f437/examples/emac/http_server/src/at32_emac.c.

◆ emac_speed_config()

error_status emac_speed_config | ( | emac_auto_negotiation_type | nego,
 |  | emac_duplex_type | mode,
 |  | emac_speed_type | speed
 | ) |  |

set mac speed related parameters

Parameters
nego auto negotiation on or off. this parameter can be one of the following values:
  • EMAC_AUTO_NEGOTIATION_OFF
  • EMAC_AUTO_NEGOTIATION_ON.
mode half-duplex or full-duplex. this parameter can be one of the following values:
  • EMAC_HALF_DUPLEX
  • EMAC_FULL_DUPLEX.
speed 10 mbps or 100 mbps this parameter can be one of the following values:
  • EMAC_SPEED_10MBPS
  • EMAC_SPEED_100MBPS.
Return values
none

Definition at line 337 of file project/at_start_f437/examples/emac/http_server/src/at32_emac.c.

◆ emac_system_init()

error_status emac_system_init ( void )

enable emac clock and gpio clock

Parameters
none
Return values
success or error

Definition at line 47 of file project/at_start_f437/examples/emac/http_server/src/at32_emac.c.

◆ emac_tmr_init()

void emac_tmr_init ( void )

initialize tmr6 for emac

Parameters
none
Return values
none

Definition at line 576 of file project/at_start_f437/examples/emac/http_server/src/at32_emac.c.

◆ ethernetif_notify_conn_changed()

void ethernetif_notify_conn_changed ( struct netif * netif )

this function notify user about link status changement.

Parameters
netif the network interface
Return values
none

Definition at line 525 of file project/at_start_f437/examples/emac/http_server/src/at32_emac.c.

◆ ethernetif_set_link()

void ethernetif_set_link ( void const * argument )

this function sets the netif link status.

Parameters
netif the network interface
Return values
none

Definition at line 489 of file project/at_start_f437/examples/emac/http_server/src/at32_emac.c.

◆ ethernetif_update_config()

void ethernetif_update_config ( struct netif * netif )

link callback function, this function is called on change of link status to update low level driver configuration.

Parameters
netif the network interface
Return values
none

Definition at line 552 of file project/at_start_f437/examples/emac/http_server/src/at32_emac.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c.

◆ http_accept()

static err_t http_accept | ( | void * | arg,
 |  | struct altcp_pcb * | pcb,
 |  | err_t | err
 | ) |  |
static

A new incoming connection has been accepted.

Definition at line 2186 of file httpd.c.

Referenced by httpd_init_pcb().

◆ http_check_eof()

static uint8_t http_check_eof | ( | struct altcp_pcb * | pcb,
 |  | struct http_state * | hs
 | ) |  |
static

Sub-function of http_send(): end-of-file (or block) is reached, either close the file or read the next block (if supported).

Returns
: 0 if the file is finished or no data has been read 1 if the file is not finished and data has been read

Definition at line 970 of file httpd.c.

Referenced by http_send().

◆ http_close_conn()

static err_t http_close_conn | ( | struct altcp_pcb * | pcb,
 |  | struct http_state * | hs
 | ) |  |
static

The connection shall be actively closed. Reset the sent- and recv-callbacks.

Parameters
pcb | the tcp pcb to reset callbacks
hs | connection state to free

Definition at line 593 of file httpd.c.

Referenced by http_eof(), http_poll(), and http_recv().

◆ http_close_or_abort_conn()

static err_t http_close_or_abort_conn | ( | struct altcp_pcb * | pcb,
 |  | struct http_state * | hs,
 |  | uint8_t | abort_conn
 | ) |  |
static

The connection shall be actively closed (using RST to close from fault states). Reset the sent- and recv-callbacks.

Parameters
pcb | the tcp pcb to reset callbacks
hs | connection state to free

Definition at line 543 of file httpd.c.

Referenced by http_close_conn().

◆ http_eof()

static void http_eof | ( | struct altcp_pcb * | pcb,
 |  | struct http_state * | hs
 | ) |  |
static

End of file: either close the connection (Connection: close) or close the file (Connection: keep-alive)

Definition at line 602 of file httpd.c.

Referenced by http_check_eof(), and http_send().

◆ http_err()

static void http_err | ( | void * | arg,
 |  | err_t | err
 | ) |  |
static

The pcb had an error and is already deallocated. The argument might still be valid (if != NULL).

Definition at line 1829 of file httpd.c.

Referenced by http_accept().

◆ http_poll()

static err_t http_poll | ( | void * | arg,
 |  | struct altcp_pcb * | pcb
 | ) |  |
static

The poll function is called every 2nd second. If there has been no data sent (which resets the retries) in 8 seconds, close. If the last portion of a file has not been sent in 2 seconds, close.

This could be increased, but we don't want to waste resources for bad connections.

Definition at line 1873 of file httpd.c.

Referenced by http_accept(), and http_close_or_abort_conn().

◆ http_recv()

static err_t http_recv | ( | void * | arg,
 |  | struct altcp_pcb * | pcb,
 |  | struct pbuf * | p,
 |  | err_t | err
 | ) |  |
static

Data has been received on this pcb. For HTTP 1.0, this should normally only happen once (if the request fits in one packet).

Definition at line 1921 of file httpd.c.

Referenced by http_accept().

◆ http_send()

static uint8_t http_send | ( | struct altcp_pcb * | pcb,
 |  | struct http_state * | hs
 | ) |  |
static

Try to send more data on this pcb.

Parameters
pcb | the pcb to send data
hs | connection state

Definition at line 1436 of file httpd.c.

Referenced by http_poll(), http_recv(), and http_sent().

◆ http_send_data_nonssi()

static uint8_t http_send_data_nonssi | ( | struct altcp_pcb * | pcb,
 |  | struct http_state * | hs
 | ) |  |
static

Sub-function of http_send(): This is the normal send-routine for non-ssi files

Returns
: - 1: data has been written (so call tcp_ouput)
  • 0: no data has been written (no need to call tcp_output)

Definition at line 1069 of file httpd.c.

Referenced by http_send().

◆ http_sent()

static err_t http_sent | ( | void * | arg,
 |  | struct altcp_pcb * | pcb,
 |  | uint16_t | len
 | ) |  |
static

Data has been sent and acknowledged by the remote host. This means that more data can be sent.

Definition at line 1846 of file httpd.c.

Referenced by http_accept(), and http_recv().

◆ http_state_alloc()

static struct http_state * http_state_alloc ( void )
static

Allocate a struct http_state.

Definition at line 405 of file httpd.c.

Referenced by http_accept().

◆ http_state_eof()

static void http_state_eof ( struct http_state * hs )
static

Free a struct http_state. Also frees the file data if dynamic.

Definition at line 425 of file httpd.c.

Referenced by http_eof(), and http_state_free().

◆ http_state_free()

static void http_state_free ( struct http_state * hs )
static

Free a struct http_state. Also frees the file data if dynamic.

Definition at line 461 of file httpd.c.

Referenced by http_close_or_abort_conn(), and http_err().

◆ http_state_init()

static void http_state_init ( struct http_state * hs )
static

Initialize a struct http_state.

Definition at line 393 of file httpd.c.

Referenced by http_eof(), and http_state_alloc().

◆ http_write()

static err_t http_write | ( | struct altcp_pcb * | pcb,
 |  | const void * | ptr,
 |  | uint16_t * | length,
 |  | uint8_t | apiflags
 | ) |  |
static

Call tcp_write() in a loop trying smaller and smaller length

Parameters
pcb | altcp_pcb to send
ptr | Data to send
length | Length of data to send (in/out: on return, contains the amount of data sent)
apiflags | directly success to tcp_write
Returns
the return value of tcp_write

Definition at line 480 of file httpd.c.

Referenced by http_send_data_nonssi().

◆ httpd_init()

void httpd_init ( void )

Initialize the httpd: set up a listening PCB and bind it to the defined port

Definition at line 2244 of file httpd.c.

Referenced by main().

◆ httpd_init_pcb()

static void httpd_init_pcb | ( | struct altcp_pcb * | pcb,
 |  | uint16_t | port
 | ) |  |
static

Definition at line 2223 of file httpd.c.

Referenced by httpd_init().

◆ link_update()

uint16_t link_update ( void )

updates the link states

Parameters
none
Return values
link state 0: disconnect, 1: connection

Definition at line 472 of file project/at_start_f437/examples/emac/http_server/src/at32_emac.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f437/examples/emac/http_server/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c.

◆ reset_phy()

static void reset_phy ( void )
static

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c.

◆ TMR6_DAC_GLOBAL_IRQHandler()

void TMR6_DAC_GLOBAL_IRQHandler ( void )

this function handles timer6 overflow handler.

Parameters
none
Return values
none

< tmr flag overflow

< tmr flag overflow

Definition at line 141 of file project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c.

Variable Documentation

◆ g_speed

uint8_t g_speed = 1

Definition at line 45 of file project/at_start_f437/examples/emac/http_server/src/main.c.

◆ html_tmp

char html_tmp[4096] = {0}

Definition at line 115 of file httpd.c.

Referenced by http_recv().

◆ local_time

volatile uint32_t local_time = 0

Definition at line 46 of file project/at_start_f437/examples/emac/http_server/src/main.c.

Referenced by main().

◆ mac_control_para

emac_control_config_type mac_control_para

Definition at line 40 of file project/at_start_f437/examples/emac/http_server/src/at32_emac.c.

Referenced by emac_layer2_configuration(), and ethernetif_update_config().


AT32F435/437 Firmwary Library: Filesystem

Functions
Filesystem
AT32F437_periph_examples » EMAC_http_server

Functions

err_t | fs_open (struct fs_file *file, const char *name)
void | fs_close (struct fs_file *file)
int | fs_bytes_left (struct fs_file *file)

Detailed Description

Function Documentation

◆ fs_bytes_left()

int fs_bytes_left ( struct fs_file * file )

Definition at line 180 of file fs.c.

Referenced by http_check_eof(), and http_send().

◆ fs_close()

void fs_close ( struct fs_file * file )

Definition at line 105 of file fs.c.

Referenced by http_state_eof().

◆ fs_open()

err_t fs_open | ( | struct fs_file * | file,
 |  | const char * | name
 | ) |  |

Definition at line 66 of file fs.c.

Referenced by http_recv().


AT32F435/437 Firmwary Library: default_filename Struct Reference

Data Fields
default_filename Struct Reference
AT32F437_periph_examples » EMAC_http_server

Data Fields

const char * | name
uint8_t | shtml

Detailed Description

Definition at line 110 of file httpd.c.

Field Documentation

◆ name

const char* default_filename::name

Definition at line 111 of file httpd.c.

◆ shtml

uint8_t default_filename::shtml

Definition at line 112 of file httpd.c.

The documentation for this struct was generated from the following file:
  • httpd.c


AT32F435/437 Firmwary Library: http_state Struct Reference

Data Fields
http_state Struct Reference
AT32F437_periph_examples » EMAC_http_server

Data Fields

struct fs_file | file_handle
struct fs_file * | handle
const char * | file
struct altcp_pcb * | pcb
uint32_t | left
uint8_t | retries

Detailed Description

Definition at line 191 of file httpd.c.

Field Documentation

◆ file

const char* http_state::file

Definition at line 197 of file httpd.c.

Referenced by http_check_eof(), http_recv(), and http_send_data_nonssi().

◆ file_handle

struct fs_file http_state::file_handle

Definition at line 195 of file httpd.c.

◆ handle

struct fs_file* http_state::handle

Definition at line 196 of file httpd.c.

Referenced by http_check_eof(), http_poll(), http_recv(), http_send(), and http_state_eof().

◆ left

uint32_t http_state::left

Definition at line 208 of file httpd.c.

Referenced by http_check_eof(), http_recv(), http_send(), and http_send_data_nonssi().

◆ pcb

struct altcp_pcb* http_state::pcb

Definition at line 199 of file httpd.c.

Referenced by http_accept(), and http_eof().

◆ retries

uint8_t http_state::retries

Definition at line 209 of file httpd.c.

Referenced by http_poll(), http_recv(), and http_sent().

The documentation for this struct was generated from the following file:
  • httpd.c


AT32F435/437 Firmwary Library: EMAC_iperf

Modules | Macros | Functions | Variables
EMAC_iperf
AT32F437_periph_examples

Modules

Iperf_prototype
Network_configuration_prototype
Network_configuration

Macros

#define | RX_REMAP (1)
#define | CRYSTAL_ON_PHY (0)
#define | RMII_MODE
#define | DM9162
#define | LINK_DETECTION (1)
#define | PHY_ADDRESS (0x03)
#define | PHY_CONTROL_REG (0x00)
#define | PHY_STATUS_REG (0x01)
#define | PHY_SPECIFIED_CS_REG (0x11)
#define | PHY_AUTO_NEGOTIATION_BIT (0x1000)
#define | PHY_LOOPBACK_BIT (0x4000)
#define | PHY_RESET_BIT (0x8000)
#define | PHY_LINKED_STATUS_BIT (0x0004)
#define | PHY_NEGO_COMPLETE_BIT (0x0020)
#define | PHY_FULL_DUPLEX_100MBPS_BIT (0x8000)
#define | PHY_HALF_DUPLEX_100MBPS_BIT (0x4000)
#define | PHY_FULL_DUPLEX_10MBPS_BIT (0x2000)
#define | PHY_HALF_DUPLEX_10MBPS_BIT (0x1000)
#define | DELAY 100
#define | FAST 1
#define | SLOW 4

Functions

error_status | emac_system_init (void)
enable emac clock and gpio clock More...
void | emac_nvic_configuration (void)
configures emac irq channel. More...
void | emac_pins_configuration (void)
configures emac required pins. More...
error_status | emac_layer2_configuration (void)
configures emac layer2 More...
static void | reset_phy (void)
error_status | emac_phy_register_reset (void)
reset phy register More...
error_status | emac_speed_config (emac_auto_negotiation_type nego, emac_duplex_type mode, emac_speed_type speed)
set mac speed related parameters More...
error_status | emac_phy_init (emac_control_config_type *control_para)
initialize emac phy More...
uint16_t | link_update (void)
updates the link states More...
void | ethernetif_set_link (void const *argument)
this function sets the netif link status. More...
void | ethernetif_notify_conn_changed (struct netif *netif)
this function notify user about link status changement. More...
void | ethernetif_update_config (struct netif *netif)
link callback function, this function is called on change of link status to update low level driver configuration. More...
void | emac_tmr_init (void)
initialize tmr6 for emac More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR6_DAC_GLOBAL_IRQHandler (void)
this function handles timer6 overflow handler. More...
void | EMAC_IRQHandler (void)
this function handles emac handler. More...
static err_t | iperf_recv (void *arg, struct tcp_pcb *pcb, struct pbuf *p, err_t err)
iperf receive callback More...
static err_t | iperf_accept (void *arg, struct tcp_pcb *pcb, err_t err)
accept iperf connection More...
void | iperf_init (void)
initialize iperf server More...
int | main (void)
main function. More...

Variables

emac_control_config_type mac_control_para
uint8_t | g_speed = 1
volatile uint32_t | local_time = 0

Detailed Description

Macro Definition Documentation

◆ CRYSTAL_ON_PHY

#define CRYSTAL_ON_PHY (0)

Definition at line 48 of file project/at_start_f437/examples/emac/iperf/inc/at32_emac.h.

◆ DELAY

#define DELAY 100

Definition at line 41 of file project/at_start_f437/examples/emac/iperf/src/main.c.

◆ DM9162

#define DM9162

Definition at line 53 of file project/at_start_f437/examples/emac/iperf/inc/at32_emac.h.

◆ FAST

#define FAST 1

Definition at line 42 of file project/at_start_f437/examples/emac/iperf/src/main.c.

◆ LINK_DETECTION

#define LINK_DETECTION (1)

link status detection, 0: no detection, 1: detect with polling

Definition at line 56 of file project/at_start_f437/examples/emac/iperf/inc/at32_emac.h.

◆ PHY_ADDRESS

#define PHY_ADDRESS (0x03)

relative to at32 board

Definition at line 59 of file project/at_start_f437/examples/emac/iperf/inc/at32_emac.h.

◆ PHY_AUTO_NEGOTIATION_BIT

#define PHY_AUTO_NEGOTIATION_BIT (0x1000)

enable auto negotiation

Definition at line 64 of file project/at_start_f437/examples/emac/iperf/inc/at32_emac.h.

◆ PHY_CONTROL_REG

#define PHY_CONTROL_REG (0x00)

basic mode control register

Definition at line 60 of file project/at_start_f437/examples/emac/iperf/inc/at32_emac.h.

◆ PHY_FULL_DUPLEX_100MBPS_BIT

#define PHY_FULL_DUPLEX_100MBPS_BIT (0x8000)

full duplex 100 mbps

Definition at line 71 of file project/at_start_f437/examples/emac/iperf/inc/at32_emac.h.

◆ PHY_FULL_DUPLEX_10MBPS_BIT

#define PHY_FULL_DUPLEX_10MBPS_BIT (0x2000)

full duplex 10 mbps

Definition at line 73 of file project/at_start_f437/examples/emac/iperf/inc/at32_emac.h.

◆ PHY_HALF_DUPLEX_100MBPS_BIT

#define PHY_HALF_DUPLEX_100MBPS_BIT (0x4000)

half duplex 100 mbps

Definition at line 72 of file project/at_start_f437/examples/emac/iperf/inc/at32_emac.h.

◆ PHY_HALF_DUPLEX_10MBPS_BIT

#define PHY_HALF_DUPLEX_10MBPS_BIT (0x1000)

half duplex 10 mbps

Definition at line 74 of file project/at_start_f437/examples/emac/iperf/inc/at32_emac.h.

◆ PHY_LINKED_STATUS_BIT

#define PHY_LINKED_STATUS_BIT (0x0004)

link status

Definition at line 68 of file project/at_start_f437/examples/emac/iperf/inc/at32_emac.h.

◆ PHY_LOOPBACK_BIT

#define PHY_LOOPBACK_BIT (0x4000)

enable loopback

Definition at line 65 of file project/at_start_f437/examples/emac/iperf/inc/at32_emac.h.

◆ PHY_NEGO_COMPLETE_BIT

#define PHY_NEGO_COMPLETE_BIT (0x0020)

auto negotiation complete

Definition at line 69 of file project/at_start_f437/examples/emac/iperf/inc/at32_emac.h.

◆ PHY_RESET_BIT

#define PHY_RESET_BIT (0x8000)

reset phy

Definition at line 66 of file project/at_start_f437/examples/emac/iperf/inc/at32_emac.h.

◆ PHY_SPECIFIED_CS_REG

#define PHY_SPECIFIED_CS_REG (0x11)

specified configuration and status register

Definition at line 62 of file project/at_start_f437/examples/emac/iperf/inc/at32_emac.h.

◆ PHY_STATUS_REG

#define PHY_STATUS_REG (0x01)

basic mode status register

Definition at line 61 of file project/at_start_f437/examples/emac/iperf/inc/at32_emac.h.

◆ RMII_MODE

#define RMII_MODE

Definition at line 51 of file project/at_start_f437/examples/emac/iperf/inc/at32_emac.h.

◆ RX_REMAP

#define RX_REMAP (1)

Definition at line 47 of file project/at_start_f437/examples/emac/iperf/inc/at32_emac.h.

◆ SLOW

#define SLOW 4

Definition at line 43 of file project/at_start_f437/examples/emac/iperf/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c.

◆ EMAC_IRQHandler()

void EMAC_IRQHandler ( void )

this function handles emac handler.

Parameters
none
Return values
none

< emac dma receive interrupt

< emac dma normal interrupt summary

Definition at line 156 of file project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c.

◆ emac_layer2_configuration()

error_status emac_layer2_configuration ( void )

configures emac layer2

Parameters
none
Return values
error or success

Definition at line 205 of file project/at_start_f437/examples/emac/iperf/src/at32_emac.c.

◆ emac_nvic_configuration()

void emac_nvic_configuration ( void )

configures emac irq channel.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f437/examples/emac/iperf/src/at32_emac.c.

◆ emac_phy_init()

error_status emac_phy_init ( emac_control_config_type * control_para )

initialize emac phy

Parameters
none
Return values
SUCCESS or ERROR

Definition at line 453 of file project/at_start_f437/examples/emac/iperf/src/at32_emac.c.

◆ emac_phy_register_reset()

error_status emac_phy_register_reset ( void )

reset phy register

Parameters
none
Return values
SUCCESS or ERROR

Definition at line 289 of file project/at_start_f437/examples/emac/iperf/src/at32_emac.c.

◆ emac_pins_configuration()

void emac_pins_configuration ( void )

configures emac required pins.

Parameters
none
Return values
none

Definition at line 80 of file project/at_start_f437/examples/emac/iperf/src/at32_emac.c.

◆ emac_speed_config()

error_status emac_speed_config | ( | emac_auto_negotiation_type | nego,
 |  | emac_duplex_type | mode,
 |  | emac_speed_type | speed
 | ) |  |

set mac speed related parameters

Parameters
nego auto negotiation on or off. this parameter can be one of the following values:
  • EMAC_AUTO_NEGOTIATION_OFF
  • EMAC_AUTO_NEGOTIATION_ON.
mode half-duplex or full-duplex. this parameter can be one of the following values:
  • EMAC_HALF_DUPLEX
  • EMAC_FULL_DUPLEX.
speed 10 mbps or 100 mbps this parameter can be one of the following values:
  • EMAC_SPEED_10MBPS
  • EMAC_SPEED_100MBPS.
Return values
none

Definition at line 335 of file project/at_start_f437/examples/emac/iperf/src/at32_emac.c.

◆ emac_system_init()

error_status emac_system_init ( void )

enable emac clock and gpio clock

Parameters
none
Return values
success or error

Definition at line 47 of file project/at_start_f437/examples/emac/iperf/src/at32_emac.c.

◆ emac_tmr_init()

void emac_tmr_init ( void )

initialize tmr6 for emac

Parameters
none
Return values
none

Definition at line 574 of file project/at_start_f437/examples/emac/iperf/src/at32_emac.c.

◆ ethernetif_notify_conn_changed()

void ethernetif_notify_conn_changed ( struct netif * netif )

this function notify user about link status changement.

Parameters
netif the network interface
Return values
none

Definition at line 523 of file project/at_start_f437/examples/emac/iperf/src/at32_emac.c.

◆ ethernetif_set_link()

void ethernetif_set_link ( void const * argument )

this function sets the netif link status.

Parameters
netif the network interface
Return values
none

Definition at line 487 of file project/at_start_f437/examples/emac/iperf/src/at32_emac.c.

◆ ethernetif_update_config()

void ethernetif_update_config ( struct netif * netif )

link callback function, this function is called on change of link status to update low level driver configuration.

Parameters
netif the network interface
Return values
none

Definition at line 550 of file project/at_start_f437/examples/emac/iperf/src/at32_emac.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c.

◆ iperf_accept()

static err_t iperf_accept | ( | void * | arg,
 |  | struct tcp_pcb * | pcb,
 |  | err_t | err
 | ) |  |
static

accept iperf connection

Parameters
arg | user supplied argument
pcb | the tcp_pcb which accepted the connection
err | error value
Return values
error value

Definition at line 76 of file iperf.c.

Referenced by iperf_init().

◆ iperf_init()

void iperf_init ( void )

initialize iperf server

Parameters
none
Return values
none

Definition at line 92 of file iperf.c.

Referenced by main().

◆ iperf_recv()

static err_t iperf_recv | ( | void * | arg,
 |  | struct tcp_pcb * | pcb,
 |  | struct pbuf * | p,
 |  | err_t | err
 | ) |  |
static

iperf receive callback

Parameters
arg | the user argument
pcb | the tcp_pcb that has received the data
p | the packet buffer
err | the error value linked with the received data
Return values
error value

Definition at line 48 of file iperf.c.

Referenced by iperf_accept().

◆ link_update()

uint16_t link_update ( void )

updates the link states

Parameters
none
Return values
link state 0: disconnect, 1: connection

Definition at line 470 of file project/at_start_f437/examples/emac/iperf/src/at32_emac.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f437/examples/emac/iperf/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c.

◆ reset_phy()

static void reset_phy ( void )
static

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c.

◆ TMR6_DAC_GLOBAL_IRQHandler()

void TMR6_DAC_GLOBAL_IRQHandler ( void )

this function handles timer6 overflow handler.

Parameters
none
Return values
none

< tmr flag overflow

< tmr flag overflow

Definition at line 141 of file project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c.

Variable Documentation

◆ g_speed

uint8_t g_speed = 1

Definition at line 45 of file project/at_start_f437/examples/emac/iperf/src/main.c.

◆ local_time

volatile uint32_t local_time = 0

Definition at line 46 of file project/at_start_f437/examples/emac/iperf/src/main.c.

Referenced by main().

◆ mac_control_para

emac_control_config_type mac_control_para

Definition at line 40 of file project/at_start_f437/examples/emac/iperf/src/at32_emac.c.

Referenced by emac_layer2_configuration(), and ethernetif_update_config().


AT32F435/437 Firmwary Library: Iperf_prototype

Functions
Iperf_prototype
AT32F437_periph_examples » EMAC_iperf

Functions

void iperf_init (void)
initialize iperf server More...

Detailed Description

Function Documentation

◆ iperf_init()

void iperf_init ( void )

initialize iperf server

Parameters
none
Return values
none

Definition at line 92 of file iperf.c.

Referenced by main().


AT32F435/437 Firmwary Library: EMAC_mqtt_client

Modules | Macros | Functions | Variables
EMAC_mqtt_client
AT32F437_periph_examples

Modules

Network_configuration_prototype
Network_configuration

Macros

#define | RX_REMAP (1)
#define | CRYSTAL_ON_PHY (0)
#define | RMII_MODE
#define | DM9162
#define | LINK_DETECTION (1)
#define | PHY_ADDRESS (0x03)
#define | PHY_CONTROL_REG (0x00)
#define | PHY_STATUS_REG (0x01)
#define | PHY_SPECIFIED_CS_REG (0x11)
#define | PHY_AUTO_NEGOTIATION_BIT (0x1000)
#define | PHY_LOOPBACK_BIT (0x4000)
#define | PHY_RESET_BIT (0x8000)
#define | PHY_LINKED_STATUS_BIT (0x0004)
#define | PHY_NEGO_COMPLETE_BIT (0x0020)
#define | PHY_FULL_DUPLEX_100MBPS_BIT (0x8000)
#define | PHY_HALF_DUPLEX_100MBPS_BIT (0x4000)
#define | PHY_FULL_DUPLEX_10MBPS_BIT (0x2000)
#define | PHY_HALF_DUPLEX_10MBPS_BIT (0x1000)
#define | MQTT_SERVER_ADDRESS "192.168.81.1"
#define | MQTT_SERVER_PORT 1883
#define | DELAY 100
#define | FAST 1
#define | SLOW 4

Functions

error_status | emac_system_init (void)
enable emac clock and gpio clock More...
void | emac_nvic_configuration (void)
configures emac irq channel. More...
void | emac_pins_configuration (void)
configures emac required pins. More...
error_status | emac_layer2_configuration (void)
configures emac layer2 More...
static void | reset_phy (void)
error_status | emac_phy_register_reset (void)
reset phy register More...
error_status | emac_speed_config (emac_auto_negotiation_type nego, emac_duplex_type mode, emac_speed_type speed)
set mac speed related parameters More...
error_status | emac_phy_init (emac_control_config_type *control_para)
initialize emac phy More...
uint16_t | link_update (void)
updates the link states More...
void | ethernetif_set_link (void const *argument)
this function sets the netif link status. More...
void | ethernetif_notify_conn_changed (struct netif *netif)
this function notify user about link status changement. More...
void | ethernetif_update_config (struct netif *netif)
link callback function, this function is called on change of link status to update low level driver configuration. More...
void | emac_tmr_init (void)
initialize tmr6 for emac More...
err_t | mqtt_client_init (void)
connect to mqtt server More...
static void | at32_mqtt_connection_cb (mqtt_client_t *client, void *arg, mqtt_connection_status_t status)
static void | at32_mqtt_incoming_data_cb (void *arg, const u8_t *data, u16_t len, u8_t flags)
static void | at32_mqtt_incoming_publish_cb (void *arg, const char *topic, u32_t tot_len)
static void | mqtt_client_pub_request_cb (void *arg, err_t result)
err_t | at32_mqtt_publish (mqtt_client_t *client, char *pub_topic, char *pub_buf, uint16_t data_len, uint8_t qos, uint8_t retain)
mqtt send data to server More...
static void | at32_mqtt_request_cb (void *arg, err_t err)
static err_t | at32_mqtt_subscribe (mqtt_client_t *mqtt_client, char *sub_topic, uint8_t qos)
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR6_DAC_GLOBAL_IRQHandler (void)
this function handles timer6 overflow handler. More...
void | EMAC_IRQHandler (void)
this function handles emac handler. More...
int | main (void)
main function. More...
__weak void | mqtt_conn_sub_proc (mqtt_client_t *client, void *arg)
mqtt connection subscription process More...
__weak void | mqtt_error_process_callback (mqtt_client_t *client, void *arg)
mqtt error process callback More...

Variables

emac_control_config_type mac_control_para
uint8_t | g_speed = 1
volatile uint32_t | local_time = 0
mqtt_client_t * | s__mqtt_client_instance

Detailed Description

Macro Definition Documentation

◆ CRYSTAL_ON_PHY

#define CRYSTAL_ON_PHY (0)

Definition at line 48 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h.

◆ DELAY

#define DELAY 100

Definition at line 41 of file project/at_start_f437/examples/emac/mqtt_client/src/main.c.

◆ DM9162

#define DM9162

Definition at line 53 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h.

◆ FAST

#define FAST 1

Definition at line 42 of file project/at_start_f437/examples/emac/mqtt_client/src/main.c.

◆ LINK_DETECTION

#define LINK_DETECTION (1)

link status detection, 0: no detection, 1: detect with polling

Definition at line 56 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h.

◆ MQTT_SERVER_ADDRESS

#define MQTT_SERVER_ADDRESS "192.168.81.1"

Definition at line 50 of file mqtt_client.h.

◆ MQTT_SERVER_PORT

#define MQTT_SERVER_PORT 1883

Definition at line 51 of file mqtt_client.h.

◆ PHY_ADDRESS

#define PHY_ADDRESS (0x03)

relative to at32 board

Definition at line 59 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h.

◆ PHY_AUTO_NEGOTIATION_BIT

#define PHY_AUTO_NEGOTIATION_BIT (0x1000)

enable auto negotiation

Definition at line 64 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h.

◆ PHY_CONTROL_REG

#define PHY_CONTROL_REG (0x00)

basic mode control register

Definition at line 60 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h.

◆ PHY_FULL_DUPLEX_100MBPS_BIT

#define PHY_FULL_DUPLEX_100MBPS_BIT (0x8000)

full duplex 100 mbps

Definition at line 71 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h.

◆ PHY_FULL_DUPLEX_10MBPS_BIT

#define PHY_FULL_DUPLEX_10MBPS_BIT (0x2000)

full duplex 10 mbps

Definition at line 73 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h.

◆ PHY_HALF_DUPLEX_100MBPS_BIT

#define PHY_HALF_DUPLEX_100MBPS_BIT (0x4000)

half duplex 100 mbps

Definition at line 72 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h.

◆ PHY_HALF_DUPLEX_10MBPS_BIT

#define PHY_HALF_DUPLEX_10MBPS_BIT (0x1000)

half duplex 10 mbps

Definition at line 74 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h.

◆ PHY_LINKED_STATUS_BIT

#define PHY_LINKED_STATUS_BIT (0x0004)

link status

Definition at line 68 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h.

◆ PHY_LOOPBACK_BIT

#define PHY_LOOPBACK_BIT (0x4000)

enable loopback

Definition at line 65 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h.

◆ PHY_NEGO_COMPLETE_BIT

#define PHY_NEGO_COMPLETE_BIT (0x0020)

auto negotiation complete

Definition at line 69 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h.

◆ PHY_RESET_BIT

#define PHY_RESET_BIT (0x8000)

reset phy

Definition at line 66 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h.

◆ PHY_SPECIFIED_CS_REG

#define PHY_SPECIFIED_CS_REG (0x11)

specified configuration and status register

Definition at line 62 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h.

◆ PHY_STATUS_REG

#define PHY_STATUS_REG (0x01)

basic mode status register

Definition at line 61 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h.

◆ RMII_MODE

#define RMII_MODE

Definition at line 51 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h.

◆ RX_REMAP

#define RX_REMAP (1)

Definition at line 47 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h.

◆ SLOW

#define SLOW 4

Definition at line 43 of file project/at_start_f437/examples/emac/mqtt_client/src/main.c.

Function Documentation

◆ at32_mqtt_connection_cb()

static void at32_mqtt_connection_cb | ( | mqtt_client_t * | client,
 |  | void * | arg,
 |  | mqtt_connection_status_t | status
 | ) |  |
static

◆ at32_mqtt_incoming_data_cb()

static void at32_mqtt_incoming_data_cb | ( | void * | arg,
 |  | const u8_t * | data,
 |  | u16_t | len,
 |  | u8_t | flags
 | ) |  |
static

◆ at32_mqtt_incoming_publish_cb()

static void at32_mqtt_incoming_publish_cb | ( | void * | arg,
 |  | const char * | topic,
 |  | u32_t | tot_len
 | ) |  |
static

◆ at32_mqtt_publish()

err_t at32_mqtt_publish | ( | mqtt_client_t * | client,
 |  | char * | pub_topic,
 |  | char * | pub_buf,
 |  | uint16_t | data_len,
 |  | uint8_t | qos,
 |  | uint8_t | retain
 | ) |  |

mqtt send data to server

Parameters
client | mqtt connection handle
pub_topic | mqtt publish topic
pub_buf | mqtt publish buffer
data_len | data length
qos£ºquality | of service, 0 1 or 2
retain£ºmqtt | retain flag
Return values
send status

Definition at line 221 of file mqtt_client.c.

◆ at32_mqtt_request_cb()

static void at32_mqtt_request_cb | ( | void * | arg,
 |  | err_t | err
 | ) |  |
static

◆ at32_mqtt_subscribe()

static err_t at32_mqtt_subscribe | ( | mqtt_client_t * | mqtt_client,
 |  | char * | sub_topic,
 |  | uint8_t | qos
 | ) |  |
static

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c.

◆ EMAC_IRQHandler()

void EMAC_IRQHandler ( void )

this function handles emac handler.

Parameters
none
Return values
none

< emac dma receive interrupt

< emac dma normal interrupt summary

Definition at line 156 of file project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c.

◆ emac_layer2_configuration()

error_status emac_layer2_configuration ( void )

configures emac layer2

Parameters
none
Return values
error or success

Definition at line 205 of file project/at_start_f437/examples/emac/mqtt_client/src/at32_emac.c.

◆ emac_nvic_configuration()

void emac_nvic_configuration ( void )

configures emac irq channel.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f437/examples/emac/mqtt_client/src/at32_emac.c.

◆ emac_phy_init()

error_status emac_phy_init ( emac_control_config_type * control_para )

initialize emac phy

Parameters
none
Return values
SUCCESS or ERROR

Definition at line 453 of file project/at_start_f437/examples/emac/mqtt_client/src/at32_emac.c.

◆ emac_phy_register_reset()

error_status emac_phy_register_reset ( void )

reset phy register

Parameters
none
Return values
SUCCESS or ERROR

Definition at line 289 of file project/at_start_f437/examples/emac/mqtt_client/src/at32_emac.c.

◆ emac_pins_configuration()

void emac_pins_configuration ( void )

configures emac required pins.

Parameters
none
Return values
none

Definition at line 80 of file project/at_start_f437/examples/emac/mqtt_client/src/at32_emac.c.

◆ emac_speed_config()

error_status emac_speed_config | ( | emac_auto_negotiation_type | nego,
 |  | emac_duplex_type | mode,
 |  | emac_speed_type | speed
 | ) |  |

set mac speed related parameters

Parameters
nego auto negotiation on or off. this parameter can be one of the following values:
  • EMAC_AUTO_NEGOTIATION_OFF
  • EMAC_AUTO_NEGOTIATION_ON.
mode half-duplex or full-duplex. this parameter can be one of the following values:
  • EMAC_HALF_DUPLEX
  • EMAC_FULL_DUPLEX.
speed 10 mbps or 100 mbps this parameter can be one of the following values:
  • EMAC_SPEED_10MBPS
  • EMAC_SPEED_100MBPS.
Return values
none

Definition at line 335 of file project/at_start_f437/examples/emac/mqtt_client/src/at32_emac.c.

◆ emac_system_init()

error_status emac_system_init ( void )

enable emac clock and gpio clock

Parameters
none
Return values
success or error

Definition at line 47 of file project/at_start_f437/examples/emac/mqtt_client/src/at32_emac.c.

◆ emac_tmr_init()

void emac_tmr_init ( void )

initialize tmr6 for emac

Parameters
none
Return values
none

Definition at line 574 of file project/at_start_f437/examples/emac/mqtt_client/src/at32_emac.c.

◆ ethernetif_notify_conn_changed()

void ethernetif_notify_conn_changed ( struct netif * netif )

this function notify user about link status changement.

Parameters
netif the network interface
Return values
none

Definition at line 523 of file project/at_start_f437/examples/emac/mqtt_client/src/at32_emac.c.

◆ ethernetif_set_link()

void ethernetif_set_link ( void const * argument )

this function sets the netif link status.

Parameters
netif the network interface
Return values
none

Definition at line 487 of file project/at_start_f437/examples/emac/mqtt_client/src/at32_emac.c.

◆ ethernetif_update_config()

void ethernetif_update_config ( struct netif * netif )

link callback function, this function is called on change of link status to update low level driver configuration.

Parameters
netif the network interface
Return values
none

Definition at line 550 of file project/at_start_f437/examples/emac/mqtt_client/src/at32_emac.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c.

◆ link_update()

uint16_t link_update ( void )

updates the link states

Parameters
none
Return values
link state 0: disconnect, 1: connection

Definition at line 470 of file project/at_start_f437/examples/emac/mqtt_client/src/at32_emac.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f437/examples/emac/mqtt_client/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c.

◆ mqtt_client_init()

err_t mqtt_client_init ( void )

connect to mqtt server

Return values
error status

Definition at line 106 of file mqtt_client.c.

Referenced by main().

◆ mqtt_client_pub_request_cb()

static void mqtt_client_pub_request_cb | ( | void * | arg,
 |  | err_t | result
 | ) |  |
static

◆ mqtt_conn_sub_proc()

__weak void mqtt_conn_sub_proc | ( | mqtt_client_t * | client,
 |  | void * | arg
 | ) |  |

mqtt connection subscription process

Parameters
client | mqtt connection handle
arg | mqtt connection parameter point
Return values
none

Definition at line 52 of file mqtt_client.c.

Referenced by at32_mqtt_connection_cb().

◆ mqtt_error_process_callback()

__weak void mqtt_error_process_callback | ( | mqtt_client_t * | client,
 |  | void * | arg
 | ) |  |

mqtt error process callback

Parameters
client | mqtt connection handle
arg | mqtt connection parameter point
Return values
none

Definition at line 65 of file mqtt_client.c.

Referenced by at32_mqtt_connection_cb(), at32_mqtt_request_cb(), and mqtt_client_pub_request_cb().

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c.

◆ reset_phy()

static void reset_phy ( void )
static

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c.

◆ TMR6_DAC_GLOBAL_IRQHandler()

void TMR6_DAC_GLOBAL_IRQHandler ( void )

this function handles timer6 overflow handler.

Parameters
none
Return values
none

< tmr flag overflow

< tmr flag overflow

Definition at line 141 of file project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c.

Variable Documentation

◆ g_speed

uint8_t g_speed = 1

Definition at line 44 of file project/at_start_f437/examples/emac/mqtt_client/src/main.c.

◆ local_time

volatile uint32_t local_time = 0

Definition at line 45 of file project/at_start_f437/examples/emac/mqtt_client/src/main.c.

Referenced by main().

◆ mac_control_para

emac_control_config_type mac_control_para

Definition at line 40 of file project/at_start_f437/examples/emac/mqtt_client/src/at32_emac.c.

Referenced by emac_layer2_configuration(), and ethernetif_update_config().

◆ s__mqtt_client_instance

mqtt_client_t* s__mqtt_client_instance

Definition at line 44 of file mqtt_client.c.

Referenced by mqtt_client_init().


AT32F435/437 Firmwary Library: EMAC_tcp_client

Modules | Macros | Functions | Variables
EMAC_tcp_client
AT32F437_periph_examples

Modules

TCP_instance_definition
TCP_client_prototype
Network_configuration_prototype
Network_configuration

Macros

#define | RX_REMAP (1)
#define | CRYSTAL_ON_PHY (0)
#define | RMII_MODE
#define | DM9162
#define | LINK_DETECTION (1)
#define | TCP_CLIENT_TEST_DATA "tcp client experiment!\n"
#define | PHY_ADDRESS (0x03)
#define | PHY_CONTROL_REG (0x00)
#define | PHY_STATUS_REG (0x01)
#define | PHY_SPECIFIED_CS_REG (0x11)
#define | PHY_AUTO_NEGOTIATION_BIT (0x1000)
#define | PHY_LOOPBACK_BIT (0x4000)
#define | PHY_RESET_BIT (0x8000)
#define | PHY_LINKED_STATUS_BIT (0x0004)
#define | PHY_NEGO_COMPLETE_BIT (0x0020)
#define | PHY_FULL_DUPLEX_100MBPS_BIT (0x8000)
#define | PHY_HALF_DUPLEX_100MBPS_BIT (0x4000)
#define | PHY_FULL_DUPLEX_10MBPS_BIT (0x2000)
#define | PHY_HALF_DUPLEX_10MBPS_BIT (0x1000)
#define | DELAY 100
#define | FAST 1
#define | SLOW 4

Functions

error_status | emac_system_init (void)
enable emac clock and gpio clock More...
void | emac_nvic_configuration (void)
configures emac irq channel. More...
void | emac_pins_configuration (void)
configures emac required pins. More...
error_status | emac_layer2_configuration (void)
configures emac layer2 More...
static void | reset_phy (void)
error_status | emac_phy_register_reset (void)
reset phy register More...
error_status | emac_speed_config (emac_auto_negotiation_type nego, emac_duplex_type mode, emac_speed_type speed)
set mac speed related parameters More...
error_status | emac_phy_init (emac_control_config_type *control_para)
initialize emac phy More...
uint16_t | link_update (void)
updates the link states More...
void | ethernetif_set_link (void const *argument)
this function sets the netif link status. More...
void | ethernetif_notify_conn_changed (struct netif *netif)
this function notify user about link status changement. More...
void | ethernetif_update_config (struct netif *netif)
link callback function, this function is called on change of link status to update low level driver configuration. More...
void | emac_tmr_init (void)
initialize tmr6 for emac More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR6_DAC_GLOBAL_IRQHandler (void)
this function handles timer6 overflow handler. More...
void | EMAC_IRQHandler (void)
this function handles emac handler. More...
int | main (void)
main function. More...
void | Delay_s (unsigned long ulVal)
generate delay More...
err_t | tcp_client_send_data (struct tcp_pcb *cpcb, unsigned char *buff, unsigned int length)
tcp client send data More...
struct tcp_pcb * | check_tcp_connect (void)
check connection More...
err_t | tcp_connected (void *arg, struct tcp_pcb *pcb, err_t err)
report connection is establish More...
err_t | tcp_client_recv (void *arg, struct tcp_pcb *pcb, struct pbuf *p, err_t err)
receiving callback funtion for TCP client More...
void | tcp_client_init (uint16_t local_port, uint16_t remote_port, unsigned char a, unsigned char b, unsigned char c, unsigned char d)
initialize tcp client More...

Variables

struct tcp_pcb * | tcp_client_pcb
emac_control_config_type mac_control_para
uint8_t | g_speed = 1
volatile uint32_t | local_time = 0
struct tcp_pcb * | tcp_active_pcbs
unsigned char | connect_flag = 0

Detailed Description

Macro Definition Documentation

◆ CRYSTAL_ON_PHY

#define CRYSTAL_ON_PHY (0)

Definition at line 48 of file project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h.

◆ DELAY

#define DELAY 100

Definition at line 41 of file project/at_start_f437/examples/emac/tcp_client/src/main.c.

◆ DM9162

#define DM9162

Definition at line 53 of file project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h.

◆ FAST

#define FAST 1

Definition at line 42 of file project/at_start_f437/examples/emac/tcp_client/src/main.c.

◆ LINK_DETECTION

#define LINK_DETECTION (1)

link status detection, 0: no detection, 1: detect with polling

Definition at line 56 of file project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h.

◆ PHY_ADDRESS

#define PHY_ADDRESS (0x03)

relative to at32 board

Definition at line 61 of file project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h.

◆ PHY_AUTO_NEGOTIATION_BIT

#define PHY_AUTO_NEGOTIATION_BIT (0x1000)

enable auto negotiation

Definition at line 66 of file project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h.

◆ PHY_CONTROL_REG

#define PHY_CONTROL_REG (0x00)

basic mode control register

Definition at line 62 of file project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h.

◆ PHY_FULL_DUPLEX_100MBPS_BIT

#define PHY_FULL_DUPLEX_100MBPS_BIT (0x8000)

full duplex 100 mbps

Definition at line 73 of file project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h.

◆ PHY_FULL_DUPLEX_10MBPS_BIT

#define PHY_FULL_DUPLEX_10MBPS_BIT (0x2000)

full duplex 10 mbps

Definition at line 75 of file project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h.

◆ PHY_HALF_DUPLEX_100MBPS_BIT

#define PHY_HALF_DUPLEX_100MBPS_BIT (0x4000)

half duplex 100 mbps

Definition at line 74 of file project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h.

◆ PHY_HALF_DUPLEX_10MBPS_BIT

#define PHY_HALF_DUPLEX_10MBPS_BIT (0x1000)

half duplex 10 mbps

Definition at line 76 of file project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h.

◆ PHY_LINKED_STATUS_BIT

#define PHY_LINKED_STATUS_BIT (0x0004)

link status

Definition at line 70 of file project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h.

◆ PHY_LOOPBACK_BIT

#define PHY_LOOPBACK_BIT (0x4000)

enable loopback

Definition at line 67 of file project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h.

◆ PHY_NEGO_COMPLETE_BIT

#define PHY_NEGO_COMPLETE_BIT (0x0020)

auto negotiation complete

Definition at line 71 of file project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h.

◆ PHY_RESET_BIT

#define PHY_RESET_BIT (0x8000)

reset phy

Definition at line 68 of file project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h.

◆ PHY_SPECIFIED_CS_REG

#define PHY_SPECIFIED_CS_REG (0x11)

specified configuration and status register

Definition at line 64 of file project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h.

◆ PHY_STATUS_REG

#define PHY_STATUS_REG (0x01)

basic mode status register

Definition at line 63 of file project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h.

◆ RMII_MODE

#define RMII_MODE

Definition at line 51 of file project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h.

◆ RX_REMAP

#define RX_REMAP (1)

Definition at line 47 of file project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h.

◆ SLOW

#define SLOW 4

Definition at line 43 of file project/at_start_f437/examples/emac/tcp_client/src/main.c.

◆ TCP_CLIENT_TEST_DATA

#define TCP_CLIENT_TEST_DATA "tcp client experiment!\n"

Definition at line 58 of file project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c.

◆ check_tcp_connect()

struct tcp_pcb * check_tcp_connect ( void )

check connection

Parameters
none
Return values
the tcp_pcb which accepted the connection

Definition at line 74 of file tcp_client.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c.

◆ Delay_s()

void Delay_s ( unsigned long ulVal )

generate delay

Parameters
ulval loop times
Return values
none

Definition at line 47 of file tcp_client.c.

◆ EMAC_IRQHandler()

void EMAC_IRQHandler ( void )

this function handles emac handler.

Parameters
none
Return values
none

< emac dma receive interrupt

< emac dma normal interrupt summary

Definition at line 156 of file project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c.

◆ emac_layer2_configuration()

error_status emac_layer2_configuration ( void )

configures emac layer2

Parameters
none
Return values
error or success

Definition at line 205 of file project/at_start_f437/examples/emac/tcp_client/src/at32_emac.c.

◆ emac_nvic_configuration()

void emac_nvic_configuration ( void )

configures emac irq channel.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f437/examples/emac/tcp_client/src/at32_emac.c.

◆ emac_phy_init()

error_status emac_phy_init ( emac_control_config_type * control_para )

initialize emac phy

Parameters
none
Return values
SUCCESS or ERROR

Definition at line 453 of file project/at_start_f437/examples/emac/tcp_client/src/at32_emac.c.

◆ emac_phy_register_reset()

error_status emac_phy_register_reset ( void )

reset phy register

Parameters
none
Return values
SUCCESS or ERROR

Definition at line 289 of file project/at_start_f437/examples/emac/tcp_client/src/at32_emac.c.

◆ emac_pins_configuration()

void emac_pins_configuration ( void )

configures emac required pins.

Parameters
none
Return values
none

Definition at line 80 of file project/at_start_f437/examples/emac/tcp_client/src/at32_emac.c.

◆ emac_speed_config()

error_status emac_speed_config | ( | emac_auto_negotiation_type | nego,
 |  | emac_duplex_type | mode,
 |  | emac_speed_type | speed
 | ) |  |

set mac speed related parameters

Parameters
nego auto negotiation on or off. this parameter can be one of the following values:
  • EMAC_AUTO_NEGOTIATION_OFF
  • EMAC_AUTO_NEGOTIATION_ON.
mode half-duplex or full-duplex. this parameter can be one of the following values:
  • EMAC_HALF_DUPLEX
  • EMAC_FULL_DUPLEX.
speed 10 mbps or 100 mbps this parameter can be one of the following values:
  • EMAC_SPEED_10MBPS
  • EMAC_SPEED_100MBPS.
Return values
none

Definition at line 335 of file project/at_start_f437/examples/emac/tcp_client/src/at32_emac.c.

◆ emac_system_init()

error_status emac_system_init ( void )

enable emac clock and gpio clock

Parameters
none
Return values
success or error

Definition at line 47 of file project/at_start_f437/examples/emac/tcp_client/src/at32_emac.c.

◆ emac_tmr_init()

void emac_tmr_init ( void )

initialize tmr6 for emac

Parameters
none
Return values
none

Definition at line 574 of file project/at_start_f437/examples/emac/tcp_client/src/at32_emac.c.

◆ ethernetif_notify_conn_changed()

void ethernetif_notify_conn_changed ( struct netif * netif )

this function notify user about link status changement.

Parameters
netif the network interface
Return values
none

Definition at line 523 of file project/at_start_f437/examples/emac/tcp_client/src/at32_emac.c.

◆ ethernetif_set_link()

void ethernetif_set_link ( void const * argument )

this function sets the netif link status.

Parameters
netif the network interface
Return values
none

Definition at line 487 of file project/at_start_f437/examples/emac/tcp_client/src/at32_emac.c.

◆ ethernetif_update_config()

void ethernetif_update_config ( struct netif * netif )

link callback function, this function is called on change of link status to update low level driver configuration.

Parameters
netif the network interface
Return values
none

Definition at line 550 of file project/at_start_f437/examples/emac/tcp_client/src/at32_emac.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c.

◆ link_update()

uint16_t link_update ( void )

updates the link states

Parameters
none
Return values
link state 0: disconnect, 1: connection

Definition at line 470 of file project/at_start_f437/examples/emac/tcp_client/src/at32_emac.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f437/examples/emac/tcp_client/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c.

◆ reset_phy()

static void reset_phy ( void )
static

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c.

◆ tcp_client_init()

void tcp_client_init | ( | uint16_t | local_port,
 |  | uint16_t | remote_port,
 |  | unsigned char | a,
 |  | unsigned char | b,
 |  | unsigned char | c,
 |  | unsigned char | d
 | ) |  |

initialize tcp client

Parameters
local_port | local port
remote_port | remote port
a | ip byte 0
b | ip byte 1
c | ip byte 2
d | ip byte 3
Return values
none

Definition at line 144 of file tcp_client.c.

Referenced by check_tcp_connect(), and main().

◆ tcp_client_recv()

err_t tcp_client_recv | ( | void * | arg,
 |  | struct tcp_pcb * | pcb,
 |  | struct pbuf * | p,
 |  | err_t | err
 | ) |  |

receiving callback funtion for TCP client

Parameters
arg | the user argument
pcb | the tcp_pcb that has received the data
p | the packet buffer
err | the error value linked with the received data
Return values
error value

Definition at line 116 of file tcp_client.c.

Referenced by tcp_client_init().

◆ tcp_client_send_data()

err_t tcp_client_send_data | ( | struct tcp_pcb * | cpcb,
 |  | unsigned char * | buff,
 |  | unsigned int | length
 | ) |  |

tcp client send data

Parameters
cpcb | the tcp_pcb that has sent the data
buff | the packet buffer
length | data size
Return values
error value

Definition at line 59 of file tcp_client.c.

◆ tcp_connected()

err_t tcp_connected | ( | void * | arg,
 |  | struct tcp_pcb * | pcb,
 |  | err_t | err
 | ) |  |

report connection is establish

Parameters
arg | user supplied argument
pcb | the tcp_pcb which accepted the connection
err | error value
Return values
err_t it will response error code

Definition at line 102 of file tcp_client.c.

Referenced by tcp_client_init().

◆ TMR6_DAC_GLOBAL_IRQHandler()

void TMR6_DAC_GLOBAL_IRQHandler ( void )

this function handles timer6 overflow handler.

Parameters
none
Return values
none

< tmr flag overflow

< tmr flag overflow

Definition at line 141 of file project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c.

Variable Documentation

◆ connect_flag

unsigned char connect_flag = 0

Definition at line 40 of file tcp_client.c.

Referenced by check_tcp_connect().

◆ g_speed

uint8_t g_speed = 1

Definition at line 44 of file project/at_start_f437/examples/emac/tcp_client/src/main.c.

◆ local_time

volatile uint32_t local_time = 0

Definition at line 45 of file project/at_start_f437/examples/emac/tcp_client/src/main.c.

Referenced by main().

◆ mac_control_para

emac_control_config_type mac_control_para

Definition at line 40 of file project/at_start_f437/examples/emac/tcp_client/src/at32_emac.c.

Referenced by emac_layer2_configuration(), and ethernetif_update_config().

◆ tcp_active_pcbs

struct tcp_pcb* tcp_active_pcbs
extern

Referenced by check_tcp_connect().

◆ tcp_client_pcb

struct tcp_pcb* tcp_client_pcb
extern

Referenced by tcp_client_init().


AT32F435/437 Firmwary Library: TCP_instance_definition

Macros
TCP_instance_definition
AT32F437_periph_examples » EMAC_tcp_client

Macros

#define | TCP_LOCAL_PORT (1030)
#define | TCP_SERVER_PORT (1031)
#define | TCP_SERVER_IP 192,168,81,19

Detailed Description

Macro Definition Documentation

◆ TCP_LOCAL_PORT

#define TCP_LOCAL_PORT (1030)

Definition at line 50 of file tcp_client.h.

◆ TCP_SERVER_IP

#define TCP_SERVER_IP 192,168,81,19

Definition at line 53 of file tcp_client.h.

◆ TCP_SERVER_PORT

#define TCP_SERVER_PORT (1031)

Definition at line 51 of file tcp_client.h.


AT32F435/437 Firmwary Library: TCP_client_prototype

Functions
TCP_client_prototype
AT32F437_periph_examples » EMAC_tcp_client

Functions

void | tcp_client_init (uint16_t local_port, uint16_t remote_port, unsigned char a, unsigned char b, unsigned char c, unsigned char d)
initialize tcp client More...
err_t | tcp_client_send_data (struct tcp_pcb *cpcb, unsigned char *buff, unsigned int length)
tcp client send data More...
struct tcp_pcb * | check_tcp_connect (void)
check connection More...

Detailed Description

Function Documentation

◆ check_tcp_connect()

struct tcp_pcb * check_tcp_connect ( void )

check connection

Parameters
none
Return values
the tcp_pcb which accepted the connection

Definition at line 74 of file tcp_client.c.

◆ tcp_client_init()

void tcp_client_init | ( | uint16_t | local_port,
 |  | uint16_t | remote_port,
 |  | unsigned char | a,
 |  | unsigned char | b,
 |  | unsigned char | c,
 |  | unsigned char | d
 | ) |  |

initialize tcp client

Parameters
local_port | local port
remote_port | remote port
a | ip byte 0
b | ip byte 1
c | ip byte 2
d | ip byte 3
Return values
none

Definition at line 144 of file tcp_client.c.

Referenced by check_tcp_connect(), and main().

◆ tcp_client_send_data()

err_t tcp_client_send_data | ( | struct tcp_pcb * | cpcb,
 |  | unsigned char * | buff,
 |  | unsigned int | length
 | ) |  |

tcp client send data

Parameters
cpcb | the tcp_pcb that has sent the data
buff | the packet buffer
length | data size
Return values
error value

Definition at line 59 of file tcp_client.c.


AT32F435/437 Firmwary Library: EMAC_tcp_server

Modules | Macros | Functions | Variables
EMAC_tcp_server
AT32F437_periph_examples

Modules

TCP_server_definition
TCP_server_prototype
Network_configuration_prototype
Network_configuration

Macros

#define | RX_REMAP (1)
#define | CRYSTAL_ON_PHY (0)
#define | RMII_MODE
#define | DM9162
#define | LINK_DETECTION (1)
#define | PHY_ADDRESS (0x03)
#define | PHY_CONTROL_REG (0x00)
#define | PHY_STATUS_REG (0x01)
#define | PHY_SPECIFIED_CS_REG (0x11)
#define | PHY_AUTO_NEGOTIATION_BIT (0x1000)
#define | PHY_LOOPBACK_BIT (0x4000)
#define | PHY_RESET_BIT (0x8000)
#define | PHY_LINKED_STATUS_BIT (0x0004)
#define | PHY_NEGO_COMPLETE_BIT (0x0020)
#define | PHY_FULL_DUPLEX_100MBPS_BIT (0x8000)
#define | PHY_HALF_DUPLEX_100MBPS_BIT (0x4000)
#define | PHY_FULL_DUPLEX_10MBPS_BIT (0x2000)
#define | PHY_HALF_DUPLEX_10MBPS_BIT (0x1000)
#define | DELAY 100
#define | FAST 1
#define | SLOW 4

Functions

error_status | emac_system_init (void)
enable emac clock and gpio clock More...
void | emac_nvic_configuration (void)
configures emac irq channel. More...
void | emac_pins_configuration (void)
configures emac required pins. More...
error_status | emac_layer2_configuration (void)
configures emac layer2 More...
static void | reset_phy (void)
error_status | emac_phy_register_reset (void)
reset phy register More...
error_status | emac_speed_config (emac_auto_negotiation_type nego, emac_duplex_type mode, emac_speed_type speed)
set mac speed related parameters More...
error_status | emac_phy_init (emac_control_config_type *control_para)
initialize emac phy More...
uint16_t | link_update (void)
updates the link states More...
void | ethernetif_set_link (void const *argument)
this function sets the netif link status. More...
void | ethernetif_notify_conn_changed (struct netif *netif)
this function notify user about link status changement. More...
void | ethernetif_update_config (struct netif *netif)
link callback function, this function is called on change of link status to update low level driver configuration. More...
void | emac_tmr_init (void)
initialize tmr6 for emac More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR6_DAC_GLOBAL_IRQHandler (void)
this function handles timer6 overflow handler. More...
void | EMAC_IRQHandler (void)
this function handles emac handler. More...
int | main (void)
main function. More...
static err_t | tcp_server_recv (void *arg, struct tcp_pcb *pcb, struct pbuf *p, err_t err)
receive and transmit tcp data More...
static err_t | tcp_server_accept (void *arg, struct tcp_pcb *pcb, err_t err)
callback function for receiving data More...
void | tcp_server_init (void)
initialize tcp server More...

Variables

emac_control_config_type mac_control_para
uint8_t | g_speed = 1
volatile uint32_t | local_time = 0

Detailed Description

Macro Definition Documentation

◆ CRYSTAL_ON_PHY

#define CRYSTAL_ON_PHY (0)

Definition at line 48 of file project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h.

◆ DELAY

#define DELAY 100

Definition at line 41 of file project/at_start_f437/examples/emac/tcp_server/src/main.c.

◆ DM9162

#define DM9162

Definition at line 53 of file project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h.

◆ FAST

#define FAST 1

Definition at line 42 of file project/at_start_f437/examples/emac/tcp_server/src/main.c.

◆ LINK_DETECTION

#define LINK_DETECTION (1)

link status detection, 0: no detection, 1: detect with polling

Definition at line 56 of file project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h.

◆ PHY_ADDRESS

#define PHY_ADDRESS (0x03)

relative to at32 board

Definition at line 59 of file project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h.

◆ PHY_AUTO_NEGOTIATION_BIT

#define PHY_AUTO_NEGOTIATION_BIT (0x1000)

enable auto negotiation

Definition at line 64 of file project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h.

◆ PHY_CONTROL_REG

#define PHY_CONTROL_REG (0x00)

basic mode control register

Definition at line 60 of file project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h.

◆ PHY_FULL_DUPLEX_100MBPS_BIT

#define PHY_FULL_DUPLEX_100MBPS_BIT (0x8000)

full duplex 100 mbps

Definition at line 71 of file project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h.

◆ PHY_FULL_DUPLEX_10MBPS_BIT

#define PHY_FULL_DUPLEX_10MBPS_BIT (0x2000)

full duplex 10 mbps

Definition at line 73 of file project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h.

◆ PHY_HALF_DUPLEX_100MBPS_BIT

#define PHY_HALF_DUPLEX_100MBPS_BIT (0x4000)

half duplex 100 mbps

Definition at line 72 of file project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h.

◆ PHY_HALF_DUPLEX_10MBPS_BIT

#define PHY_HALF_DUPLEX_10MBPS_BIT (0x1000)

half duplex 10 mbps

Definition at line 74 of file project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h.

◆ PHY_LINKED_STATUS_BIT

#define PHY_LINKED_STATUS_BIT (0x0004)

link status

Definition at line 68 of file project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h.

◆ PHY_LOOPBACK_BIT

#define PHY_LOOPBACK_BIT (0x4000)

enable loopback

Definition at line 65 of file project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h.

◆ PHY_NEGO_COMPLETE_BIT

#define PHY_NEGO_COMPLETE_BIT (0x0020)

auto negotiation complete

Definition at line 69 of file project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h.

◆ PHY_RESET_BIT

#define PHY_RESET_BIT (0x8000)

reset phy

Definition at line 66 of file project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h.

◆ PHY_SPECIFIED_CS_REG

#define PHY_SPECIFIED_CS_REG (0x11)

specified configuration and status register

Definition at line 62 of file project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h.

◆ PHY_STATUS_REG

#define PHY_STATUS_REG (0x01)

basic mode status register

Definition at line 61 of file project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h.

◆ RMII_MODE

#define RMII_MODE

Definition at line 51 of file project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h.

◆ RX_REMAP

#define RX_REMAP (1)

Definition at line 47 of file project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h.

◆ SLOW

#define SLOW 4

Definition at line 43 of file project/at_start_f437/examples/emac/tcp_server/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c.

◆ EMAC_IRQHandler()

void EMAC_IRQHandler ( void )

this function handles emac handler.

Parameters
none
Return values
none

< emac dma receive interrupt

< emac dma normal interrupt summary

Definition at line 156 of file project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c.

◆ emac_layer2_configuration()

error_status emac_layer2_configuration ( void )

configures emac layer2

Parameters
none
Return values
error or success

Definition at line 205 of file project/at_start_f437/examples/emac/tcp_server/src/at32_emac.c.

◆ emac_nvic_configuration()

void emac_nvic_configuration ( void )

configures emac irq channel.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f437/examples/emac/tcp_server/src/at32_emac.c.

◆ emac_phy_init()

error_status emac_phy_init ( emac_control_config_type * control_para )

initialize emac phy

Parameters
none
Return values
SUCCESS or ERROR

Definition at line 453 of file project/at_start_f437/examples/emac/tcp_server/src/at32_emac.c.

◆ emac_phy_register_reset()

error_status emac_phy_register_reset ( void )

reset phy register

Parameters
none
Return values
SUCCESS or ERROR

Definition at line 289 of file project/at_start_f437/examples/emac/tcp_server/src/at32_emac.c.

◆ emac_pins_configuration()

void emac_pins_configuration ( void )

configures emac required pins.

Parameters
none
Return values
none

Definition at line 80 of file project/at_start_f437/examples/emac/tcp_server/src/at32_emac.c.

◆ emac_speed_config()

error_status emac_speed_config | ( | emac_auto_negotiation_type | nego,
 |  | emac_duplex_type | mode,
 |  | emac_speed_type | speed
 | ) |  |

set mac speed related parameters

Parameters
nego auto negotiation on or off. this parameter can be one of the following values:
  • EMAC_AUTO_NEGOTIATION_OFF
  • EMAC_AUTO_NEGOTIATION_ON.
mode half-duplex or full-duplex. this parameter can be one of the following values:
  • EMAC_HALF_DUPLEX
  • EMAC_FULL_DUPLEX.
speed 10 mbps or 100 mbps this parameter can be one of the following values:
  • EMAC_SPEED_10MBPS
  • EMAC_SPEED_100MBPS.
Return values
none

Definition at line 335 of file project/at_start_f437/examples/emac/tcp_server/src/at32_emac.c.

◆ emac_system_init()

error_status emac_system_init ( void )

enable emac clock and gpio clock

Parameters
none
Return values
success or error

Definition at line 47 of file project/at_start_f437/examples/emac/tcp_server/src/at32_emac.c.

◆ emac_tmr_init()

void emac_tmr_init ( void )

initialize tmr6 for emac

Parameters
none
Return values
none

Definition at line 574 of file project/at_start_f437/examples/emac/tcp_server/src/at32_emac.c.

◆ ethernetif_notify_conn_changed()

void ethernetif_notify_conn_changed ( struct netif * netif )

this function notify user about link status changement.

Parameters
netif the network interface
Return values
none

Definition at line 523 of file project/at_start_f437/examples/emac/tcp_server/src/at32_emac.c.

◆ ethernetif_set_link()

void ethernetif_set_link ( void const * argument )

this function sets the netif link status.

Parameters
netif the network interface
Return values
none

Definition at line 487 of file project/at_start_f437/examples/emac/tcp_server/src/at32_emac.c.

◆ ethernetif_update_config()

void ethernetif_update_config ( struct netif * netif )

link callback function, this function is called on change of link status to update low level driver configuration.

Parameters
netif the network interface
Return values
none

Definition at line 550 of file project/at_start_f437/examples/emac/tcp_server/src/at32_emac.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c.

◆ link_update()

uint16_t link_update ( void )

updates the link states

Parameters
none
Return values
link state 0: disconnect, 1: connection

Definition at line 470 of file project/at_start_f437/examples/emac/tcp_server/src/at32_emac.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f437/examples/emac/tcp_server/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c.

◆ reset_phy()

static void reset_phy ( void )
static

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c.

◆ tcp_server_accept()

static err_t tcp_server_accept | ( | void * | arg,
 |  | struct tcp_pcb * | pcb,
 |  | err_t | err
 | ) |  |
static

callback function for receiving data

Parameters
arg | user supplied argument
pcb | the tcp_pcb which accepted the connection
err | error value
Return values
error value

Definition at line 78 of file tcp_server.c.

Referenced by tcp_server_init().

◆ tcp_server_init()

void tcp_server_init ( void )

initialize tcp server

Parameters
none
Return values
none

Definition at line 93 of file tcp_server.c.

Referenced by main().

◆ tcp_server_recv()

static err_t tcp_server_recv | ( | void * | arg,
 |  | struct tcp_pcb * | pcb,
 |  | struct pbuf * | p,
 |  | err_t | err
 | ) |  |
static

receive and transmit tcp data

Parameters
arg | the user argument
pcb | the tcp_pcb that has received the data
p | the packet buffer
err | the error value linked with the received data
Return values
error value

Definition at line 48 of file tcp_server.c.

Referenced by tcp_server_accept().

◆ TMR6_DAC_GLOBAL_IRQHandler()

void TMR6_DAC_GLOBAL_IRQHandler ( void )

this function handles timer6 overflow handler.

Parameters
none
Return values
none

< tmr flag overflow

< tmr flag overflow

Definition at line 141 of file project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c.

Variable Documentation

◆ g_speed

uint8_t g_speed = 1

Definition at line 45 of file project/at_start_f437/examples/emac/tcp_server/src/main.c.

◆ local_time

volatile uint32_t local_time = 0

Definition at line 46 of file project/at_start_f437/examples/emac/tcp_server/src/main.c.

Referenced by main().

◆ mac_control_para

emac_control_config_type mac_control_para

Definition at line 40 of file project/at_start_f437/examples/emac/tcp_server/src/at32_emac.c.

Referenced by emac_layer2_configuration(), and ethernetif_update_config().


AT32F435/437 Firmwary Library: TCP_server_definition

Macros
TCP_server_definition
AT32F437_periph_examples » EMAC_tcp_server

Macros

#define | TCP_LOCAL_PORT (1030)
#define | QUIZ_MESSAGE "\r\nHello. 8+9 = ?\r\n"

Detailed Description

Macro Definition Documentation

◆ QUIZ_MESSAGE

#define QUIZ_MESSAGE "\r\nHello. 8+9 = ?\r\n"

Definition at line 48 of file tcp_server.h.

◆ TCP_LOCAL_PORT

#define TCP_LOCAL_PORT (1030)

Definition at line 47 of file tcp_server.h.


AT32F435/437 Firmwary Library: TCP_server_prototype

Functions
TCP_server_prototype
AT32F437_periph_examples » EMAC_tcp_server

Functions

void tcp_server_init (void)
initialize tcp server More...

Detailed Description

Function Documentation

◆ tcp_server_init()

void tcp_server_init ( void )

initialize tcp server

Parameters
none
Return values
none

Definition at line 93 of file tcp_server.c.

Referenced by main().


AT32F435/437 Firmwary Library: EMAC_telnet

Modules | Data Structures | Macros | Functions | Variables
EMAC_telnet
AT32F437_periph_examples

Modules

TELENT_instance_definition
TELNET_prototype
Network_configuration_prototype
Network_configuration

Data Structures

struct name

Macros

#define | RX_REMAP (1)
#define | CRYSTAL_ON_PHY (0)
#define | RMII_MODE
#define | DM9162
#define | LINK_DETECTION (1)
#define | PHY_ADDRESS (0x03)
#define | PHY_CONTROL_REG (0x00)
#define | PHY_STATUS_REG (0x01)
#define | PHY_SPECIFIED_CS_REG (0x11)
#define | PHY_AUTO_NEGOTIATION_BIT (0x1000)
#define | PHY_LOOPBACK_BIT (0x4000)
#define | PHY_RESET_BIT (0x8000)
#define | PHY_LINKED_STATUS_BIT (0x0004)
#define | PHY_NEGO_COMPLETE_BIT (0x0020)
#define | PHY_FULL_DUPLEX_100MBPS_BIT (0x8000)
#define | PHY_HALF_DUPLEX_100MBPS_BIT (0x4000)
#define | PHY_FULL_DUPLEX_10MBPS_BIT (0x2000)
#define | PHY_HALF_DUPLEX_10MBPS_BIT (0x1000)
#define | DELAY 100
#define | FAST 1
#define | SLOW 4
#define | GREETING "Hello. What is your name?\r\n"
#define | HELLO "Nice to meet you, "
#define | MAX_NAME_SIZE (32)

Functions

error_status | emac_system_init (void)
enable emac clock and gpio clock More...
void | emac_nvic_configuration (void)
configures emac irq channel. More...
void | emac_pins_configuration (void)
configures emac required pins. More...
error_status | emac_layer2_configuration (void)
configures emac layer2 More...
static void | reset_phy (void)
error_status | emac_phy_register_reset (void)
reset phy register More...
error_status | emac_speed_config (emac_auto_negotiation_type nego, emac_duplex_type mode, emac_speed_type speed)
set mac speed related parameters More...
error_status | emac_phy_init (emac_control_config_type *control_para)
initialize emac phy More...
uint16_t | link_update (void)
updates the link states More...
void | ethernetif_set_link (void const *argument)
this function sets the netif link status. More...
void | ethernetif_notify_conn_changed (struct netif *netif)
this function notify user about link status changement. More...
void | ethernetif_update_config (struct netif *netif)
link callback function, this function is called on change of link status to update low level driver configuration. More...
void | emac_tmr_init (void)
initialize tmr6 for emac More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR6_DAC_GLOBAL_IRQHandler (void)
this function handles timer6 overflow handler. More...
void | EMAC_IRQHandler (void)
this function handles emac handler. More...
int | main (void)
main function. More...
static err_t | helloworld_recv (void *arg, struct tcp_pcb *pcb, struct pbuf *p, err_t err)
called when a data is received on the telnet connection More...
static err_t | helloworld_accept (void *arg, struct tcp_pcb *pcb, err_t err)
this function when the telnet connection is established More...
static void | helloworld_conn_err (void *arg, err_t err)
this function is called when an error occurs on the connection More...
void | helloworld_init (void)
initialize the hello application More...

Variables

emac_control_config_type mac_control_para
uint8_t | g_speed = 1
volatile uint32_t | local_time = 0

Detailed Description

Macro Definition Documentation

◆ CRYSTAL_ON_PHY

#define CRYSTAL_ON_PHY (0)

Definition at line 48 of file project/at_start_f437/examples/emac/telnet/inc/at32_emac.h.

◆ DELAY

#define DELAY 100

Definition at line 41 of file project/at_start_f437/examples/emac/telnet/src/main.c.

◆ DM9162

#define DM9162

Definition at line 53 of file project/at_start_f437/examples/emac/telnet/inc/at32_emac.h.

◆ FAST

#define FAST 1

Definition at line 42 of file project/at_start_f437/examples/emac/telnet/src/main.c.

◆ GREETING

#define GREETING "Hello. What is your name?\r\n"

Definition at line 43 of file telnet.c.

◆ HELLO

#define HELLO "Nice to meet you, "

Definition at line 44 of file telnet.c.

◆ LINK_DETECTION

#define LINK_DETECTION (1)

link status detection, 0: no detection, 1: detect with polling

Definition at line 56 of file project/at_start_f437/examples/emac/telnet/inc/at32_emac.h.

◆ MAX_NAME_SIZE

#define MAX_NAME_SIZE (32)

Definition at line 45 of file telnet.c.

◆ PHY_ADDRESS

#define PHY_ADDRESS (0x03)

relative to at32 board

Definition at line 59 of file project/at_start_f437/examples/emac/telnet/inc/at32_emac.h.

◆ PHY_AUTO_NEGOTIATION_BIT

#define PHY_AUTO_NEGOTIATION_BIT (0x1000)

enable auto negotiation

Definition at line 64 of file project/at_start_f437/examples/emac/telnet/inc/at32_emac.h.

◆ PHY_CONTROL_REG

#define PHY_CONTROL_REG (0x00)

basic mode control register

Definition at line 60 of file project/at_start_f437/examples/emac/telnet/inc/at32_emac.h.

◆ PHY_FULL_DUPLEX_100MBPS_BIT

#define PHY_FULL_DUPLEX_100MBPS_BIT (0x8000)

full duplex 100 mbps

Definition at line 71 of file project/at_start_f437/examples/emac/telnet/inc/at32_emac.h.

◆ PHY_FULL_DUPLEX_10MBPS_BIT

#define PHY_FULL_DUPLEX_10MBPS_BIT (0x2000)

full duplex 10 mbps

Definition at line 73 of file project/at_start_f437/examples/emac/telnet/inc/at32_emac.h.

◆ PHY_HALF_DUPLEX_100MBPS_BIT

#define PHY_HALF_DUPLEX_100MBPS_BIT (0x4000)

half duplex 100 mbps

Definition at line 72 of file project/at_start_f437/examples/emac/telnet/inc/at32_emac.h.

◆ PHY_HALF_DUPLEX_10MBPS_BIT

#define PHY_HALF_DUPLEX_10MBPS_BIT (0x1000)

half duplex 10 mbps

Definition at line 74 of file project/at_start_f437/examples/emac/telnet/inc/at32_emac.h.

◆ PHY_LINKED_STATUS_BIT

#define PHY_LINKED_STATUS_BIT (0x0004)

link status

Definition at line 68 of file project/at_start_f437/examples/emac/telnet/inc/at32_emac.h.

◆ PHY_LOOPBACK_BIT

#define PHY_LOOPBACK_BIT (0x4000)

enable loopback

Definition at line 65 of file project/at_start_f437/examples/emac/telnet/inc/at32_emac.h.

◆ PHY_NEGO_COMPLETE_BIT

#define PHY_NEGO_COMPLETE_BIT (0x0020)

auto negotiation complete

Definition at line 69 of file project/at_start_f437/examples/emac/telnet/inc/at32_emac.h.

◆ PHY_RESET_BIT

#define PHY_RESET_BIT (0x8000)

reset phy

Definition at line 66 of file project/at_start_f437/examples/emac/telnet/inc/at32_emac.h.

◆ PHY_SPECIFIED_CS_REG

#define PHY_SPECIFIED_CS_REG (0x11)

specified configuration and status register

Definition at line 62 of file project/at_start_f437/examples/emac/telnet/inc/at32_emac.h.

◆ PHY_STATUS_REG

#define PHY_STATUS_REG (0x01)

basic mode status register

Definition at line 61 of file project/at_start_f437/examples/emac/telnet/inc/at32_emac.h.

◆ RMII_MODE

#define RMII_MODE

Definition at line 51 of file project/at_start_f437/examples/emac/telnet/inc/at32_emac.h.

◆ RX_REMAP

#define RX_REMAP (1)

Definition at line 47 of file project/at_start_f437/examples/emac/telnet/inc/at32_emac.h.

◆ SLOW

#define SLOW 4

Definition at line 43 of file project/at_start_f437/examples/emac/telnet/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c.

◆ EMAC_IRQHandler()

void EMAC_IRQHandler ( void )

this function handles emac handler.

Parameters
none
Return values
none

< emac dma receive interrupt

< emac dma normal interrupt summary

Definition at line 156 of file project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c.

◆ emac_layer2_configuration()

error_status emac_layer2_configuration ( void )

configures emac layer2

Parameters
none
Return values
error or success

Definition at line 205 of file project/at_start_f437/examples/emac/telnet/src/at32_emac.c.

◆ emac_nvic_configuration()

void emac_nvic_configuration ( void )

configures emac irq channel.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f437/examples/emac/telnet/src/at32_emac.c.

◆ emac_phy_init()

error_status emac_phy_init ( emac_control_config_type * control_para )

initialize emac phy

Parameters
none
Return values
SUCCESS or ERROR

Definition at line 453 of file project/at_start_f437/examples/emac/telnet/src/at32_emac.c.

◆ emac_phy_register_reset()

error_status emac_phy_register_reset ( void )

reset phy register

Parameters
none
Return values
SUCCESS or ERROR

Definition at line 289 of file project/at_start_f437/examples/emac/telnet/src/at32_emac.c.

◆ emac_pins_configuration()

void emac_pins_configuration ( void )

configures emac required pins.

Parameters
none
Return values
none

Definition at line 80 of file project/at_start_f437/examples/emac/telnet/src/at32_emac.c.

◆ emac_speed_config()

error_status emac_speed_config | ( | emac_auto_negotiation_type | nego,
 |  | emac_duplex_type | mode,
 |  | emac_speed_type | speed
 | ) |  |

set mac speed related parameters

Parameters
nego auto negotiation on or off. this parameter can be one of the following values:
  • EMAC_AUTO_NEGOTIATION_OFF
  • EMAC_AUTO_NEGOTIATION_ON.
mode half-duplex or full-duplex. this parameter can be one of the following values:
  • EMAC_HALF_DUPLEX
  • EMAC_FULL_DUPLEX.
speed 10 mbps or 100 mbps this parameter can be one of the following values:
  • EMAC_SPEED_10MBPS
  • EMAC_SPEED_100MBPS.
Return values
none

Definition at line 335 of file project/at_start_f437/examples/emac/telnet/src/at32_emac.c.

◆ emac_system_init()

error_status emac_system_init ( void )

enable emac clock and gpio clock

Parameters
none
Return values
success or error

Definition at line 47 of file project/at_start_f437/examples/emac/telnet/src/at32_emac.c.

◆ emac_tmr_init()

void emac_tmr_init ( void )

initialize tmr6 for emac

Parameters
none
Return values
none

Definition at line 574 of file project/at_start_f437/examples/emac/telnet/src/at32_emac.c.

◆ ethernetif_notify_conn_changed()

void ethernetif_notify_conn_changed ( struct netif * netif )

this function notify user about link status changement.

Parameters
netif the network interface
Return values
none

Definition at line 523 of file project/at_start_f437/examples/emac/telnet/src/at32_emac.c.

◆ ethernetif_set_link()

void ethernetif_set_link ( void const * argument )

this function sets the netif link status.

Parameters
netif the network interface
Return values
none

Definition at line 487 of file project/at_start_f437/examples/emac/telnet/src/at32_emac.c.

◆ ethernetif_update_config()

void ethernetif_update_config ( struct netif * netif )

link callback function, this function is called on change of link status to update low level driver configuration.

Parameters
netif the network interface
Return values
none

Definition at line 550 of file project/at_start_f437/examples/emac/telnet/src/at32_emac.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c.

◆ helloworld_accept()

static err_t helloworld_accept | ( | void * | arg,
 |  | struct tcp_pcb * | pcb,
 |  | err_t | err
 | ) |  |
static

this function when the telnet connection is established

Parameters
arg | user supplied argument
pcb | the tcp_pcb which accepted the connection
err | error value
Return values
error value

Definition at line 157 of file telnet.c.

Referenced by helloworld_init().

◆ helloworld_conn_err()

static void helloworld_conn_err | ( | void * | arg,
 |  | err_t | err
 | ) |  |
static

this function is called when an error occurs on the connection

Parameters
arg user supplied argument @parm err: error value
Return values
none

Definition at line 204 of file telnet.c.

Referenced by helloworld_accept().

◆ helloworld_init()

void helloworld_init ( void )

initialize the hello application

Parameters
none
Return values
none

Definition at line 177 of file telnet.c.

Referenced by main().

◆ helloworld_recv()

static err_t helloworld_recv | ( | void * | arg,
 |  | struct tcp_pcb * | pcb,
 |  | struct pbuf * | p,
 |  | err_t | err
 | ) |  |
static

called when a data is received on the telnet connection

Parameters
arg | the user argument
pcb | the tcp_pcb that has received the data
p | the packet buffer
err | the error value linked with the received data
Return values
error value

Definition at line 70 of file telnet.c.

Referenced by helloworld_accept().

◆ link_update()

uint16_t link_update ( void )

updates the link states

Parameters
none
Return values
link state 0: disconnect, 1: connection

Definition at line 470 of file project/at_start_f437/examples/emac/telnet/src/at32_emac.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f437/examples/emac/telnet/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c.

◆ reset_phy()

static void reset_phy ( void )
static

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c.

◆ TMR6_DAC_GLOBAL_IRQHandler()

void TMR6_DAC_GLOBAL_IRQHandler ( void )

this function handles timer6 overflow handler.

Parameters
none
Return values
none

< tmr flag overflow

< tmr flag overflow

Definition at line 141 of file project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c.

Variable Documentation

◆ g_speed

uint8_t g_speed = 1

Definition at line 45 of file project/at_start_f437/examples/emac/telnet/src/main.c.

◆ local_time

volatile uint32_t local_time = 0

Definition at line 46 of file project/at_start_f437/examples/emac/telnet/src/main.c.

Referenced by main().

◆ mac_control_para

emac_control_config_type mac_control_para

Definition at line 40 of file project/at_start_f437/examples/emac/telnet/src/at32_emac.c.

Referenced by emac_layer2_configuration(), and ethernetif_update_config().


AT32F435/437 Firmwary Library: TELENT_instance_definition

Macros
TELENT_instance_definition
AT32F437_periph_examples » EMAC_telnet

Macros

#define | TELNET_IP_ADDR_0 (192)
#define | TELNET_IP_ADDR_1 (168)
#define | TELNET_IP_ADDR_2 (81)
#define | TELNET_IP_ADDR_3 (37)

Detailed Description

Macro Definition Documentation

◆ TELNET_IP_ADDR_0

#define TELNET_IP_ADDR_0 (192)

Definition at line 46 of file telnet.h.

◆ TELNET_IP_ADDR_1

#define TELNET_IP_ADDR_1 (168)

Definition at line 47 of file telnet.h.

◆ TELNET_IP_ADDR_2

#define TELNET_IP_ADDR_2 (81)

Definition at line 48 of file telnet.h.

◆ TELNET_IP_ADDR_3

#define TELNET_IP_ADDR_3 (37)

Definition at line 49 of file telnet.h.


AT32F435/437 Firmwary Library: TELNET_prototype

Functions
TELNET_prototype
AT32F437_periph_examples » EMAC_telnet

Functions

void | helloworld_init (void)
initialize the hello application More...
void | httpd_init (void)

Detailed Description

Function Documentation

◆ helloworld_init()

void helloworld_init ( void )

initialize the hello application

Parameters
none
Return values
none

Definition at line 177 of file telnet.c.

Referenced by main().

◆ httpd_init()

void httpd_init ( void )

Initialize the httpd: set up a listening PCB and bind it to the defined port

Definition at line 2244 of file httpd.c.

Referenced by main().


AT32F435/437 Firmwary Library: name Struct Reference

Data Fields
name Struct Reference
AT32F437_periph_examples » EMAC_telnet

Data Fields

int | length
char | bytes [(32)]

Detailed Description

Definition at line 49 of file telnet.c.

Field Documentation

◆ bytes

char name::bytes[(32)]

Definition at line 52 of file telnet.c.

Referenced by helloworld_recv().

◆ length

int name::length

Definition at line 51 of file telnet.c.

Referenced by helloworld_recv().

The documentation for this struct was generated from the following file:
  • telnet.c


AT32F435/437 Firmwary Library: EMAC_wake_on_lan

Modules | Macros | Functions | Variables
EMAC_wake_on_lan
AT32F437_periph_examples

Modules

Network_configuration_prototype
Network_configuration

Macros

#define | RX_REMAP (1)
#define | CRYSTAL_ON_PHY (0)
#define | RMII_MODE
#define | DM9162
#define | LINK_DETECTION (1)
#define | PHY_ADDRESS (0x03)
#define | PHY_CONTROL_REG (0x00)
#define | PHY_STATUS_REG (0x01)
#define | PHY_SPECIFIED_CS_REG (0x11)
#define | PHY_AUTO_NEGOTIATION_BIT (0x1000)
#define | PHY_LOOPBACK_BIT (0x4000)
#define | PHY_RESET_BIT (0x8000)
#define | PHY_LINKED_STATUS_BIT (0x0004)
#define | PHY_NEGO_COMPLETE_BIT (0x0020)
#define | PHY_FULL_DUPLEX_100MBPS_BIT (0x8000)
#define | PHY_HALF_DUPLEX_100MBPS_BIT (0x4000)
#define | PHY_FULL_DUPLEX_10MBPS_BIT (0x2000)
#define | PHY_HALF_DUPLEX_10MBPS_BIT (0x1000)
#define | DELAY 100
#define | FAST 1
#define | SLOW 4

Functions

error_status | emac_system_init (void)
enable emac clock and gpio clock More...
void | emac_nvic_configuration (void)
configures emac irq channel. More...
void | emac_pins_configuration (void)
configures emac required pins. More...
error_status | emac_layer2_configuration (void)
configures emac layer2 More...
static void | reset_phy (void)
error_status | emac_phy_register_reset (void)
reset phy register More...
error_status | emac_speed_config (emac_auto_negotiation_type nego, emac_duplex_type mode, emac_speed_type speed)
set mac speed related parameters More...
error_status | emac_phy_init (emac_control_config_type *control_para)
initialize emac phy More...
uint16_t | link_update (void)
updates the link states More...
void | ethernetif_set_link (void const *argument)
this function sets the netif link status. More...
void | ethernetif_notify_conn_changed (struct netif *netif)
this function notify user about link status changement. More...
void | ethernetif_update_config (struct netif *netif)
link callback function, this function is called on change of link status to update low level driver configuration. More...
void | emac_tmr_init (void)
initialize tmr6 for emac More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR6_DAC_GLOBAL_IRQHandler (void)
this function handles timer6 overflow handler. More...
void | EMAC_IRQHandler (void)
this function handles emac handler. More...
void | EMAC_WKUP_IRQHandler (void)
this function handles wakeup frames and magic packets More...
void | emac_wake_on_lan_init (void)
wake on lan configuration, it will be woken by magic packet More...
int | main (void)
main function. More...

Variables

emac_control_config_type mac_control_para
uint8_t | g_speed = 1
volatile uint32_t | local_time = 0

Detailed Description

Macro Definition Documentation

◆ CRYSTAL_ON_PHY

#define CRYSTAL_ON_PHY (0)

Definition at line 48 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h.

◆ DELAY

#define DELAY 100

Definition at line 41 of file project/at_start_f437/examples/emac/wake_on_lan/src/main.c.

◆ DM9162

#define DM9162

Definition at line 53 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h.

◆ FAST

#define FAST 1

Definition at line 42 of file project/at_start_f437/examples/emac/wake_on_lan/src/main.c.

◆ LINK_DETECTION

#define LINK_DETECTION (1)

link status detection, 0: no detection, 1: detect with polling

Definition at line 56 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h.

◆ PHY_ADDRESS

#define PHY_ADDRESS (0x03)

relative to at32 board

Definition at line 59 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h.

◆ PHY_AUTO_NEGOTIATION_BIT

#define PHY_AUTO_NEGOTIATION_BIT (0x1000)

enable auto negotiation

Definition at line 64 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h.

◆ PHY_CONTROL_REG

#define PHY_CONTROL_REG (0x00)

basic mode control register

Definition at line 60 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h.

◆ PHY_FULL_DUPLEX_100MBPS_BIT

#define PHY_FULL_DUPLEX_100MBPS_BIT (0x8000)

full duplex 100 mbps

Definition at line 71 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h.

◆ PHY_FULL_DUPLEX_10MBPS_BIT

#define PHY_FULL_DUPLEX_10MBPS_BIT (0x2000)

full duplex 10 mbps

Definition at line 73 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h.

◆ PHY_HALF_DUPLEX_100MBPS_BIT

#define PHY_HALF_DUPLEX_100MBPS_BIT (0x4000)

half duplex 100 mbps

Definition at line 72 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h.

◆ PHY_HALF_DUPLEX_10MBPS_BIT

#define PHY_HALF_DUPLEX_10MBPS_BIT (0x1000)

half duplex 10 mbps

Definition at line 74 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h.

◆ PHY_LINKED_STATUS_BIT

#define PHY_LINKED_STATUS_BIT (0x0004)

link status

Definition at line 68 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h.

◆ PHY_LOOPBACK_BIT

#define PHY_LOOPBACK_BIT (0x4000)

enable loopback

Definition at line 65 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h.

◆ PHY_NEGO_COMPLETE_BIT

#define PHY_NEGO_COMPLETE_BIT (0x0020)

auto negotiation complete

Definition at line 69 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h.

◆ PHY_RESET_BIT

#define PHY_RESET_BIT (0x8000)

reset phy

Definition at line 66 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h.

◆ PHY_SPECIFIED_CS_REG

#define PHY_SPECIFIED_CS_REG (0x11)

specified configuration and status register

Definition at line 62 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h.

◆ PHY_STATUS_REG

#define PHY_STATUS_REG (0x01)

basic mode status register

Definition at line 61 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h.

◆ RMII_MODE

#define RMII_MODE

Definition at line 51 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h.

◆ RX_REMAP

#define RX_REMAP (1)

Definition at line 47 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h.

◆ SLOW

#define SLOW 4

Definition at line 43 of file project/at_start_f437/examples/emac/wake_on_lan/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 80 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 115 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c.

◆ EMAC_IRQHandler()

void EMAC_IRQHandler ( void )

this function handles emac handler.

Parameters
none
Return values
none

< emac dma receive interrupt

< emac dma normal interrupt summary

Definition at line 156 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c.

◆ emac_layer2_configuration()

error_status emac_layer2_configuration ( void )

configures emac layer2

Parameters
none
Return values
error or success

Definition at line 205 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32_emac.c.

◆ emac_nvic_configuration()

void emac_nvic_configuration ( void )

configures emac irq channel.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32_emac.c.

◆ emac_phy_init()

error_status emac_phy_init ( emac_control_config_type * control_para )

initialize emac phy

Parameters
none
Return values
SUCCESS or ERROR

Definition at line 453 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32_emac.c.

◆ emac_phy_register_reset()

error_status emac_phy_register_reset ( void )

reset phy register

Parameters
none
Return values
SUCCESS or ERROR

Definition at line 289 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32_emac.c.

◆ emac_pins_configuration()

void emac_pins_configuration ( void )

configures emac required pins.

Parameters
none
Return values
none

Definition at line 80 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32_emac.c.

◆ emac_speed_config()

error_status emac_speed_config | ( | emac_auto_negotiation_type | nego,
 |  | emac_duplex_type | mode,
 |  | emac_speed_type | speed
 | ) |  |

set mac speed related parameters

Parameters
nego auto negotiation on or off. this parameter can be one of the following values:
  • EMAC_AUTO_NEGOTIATION_OFF
  • EMAC_AUTO_NEGOTIATION_ON.
mode half-duplex or full-duplex. this parameter can be one of the following values:
  • EMAC_HALF_DUPLEX
  • EMAC_FULL_DUPLEX.
speed 10 mbps or 100 mbps this parameter can be one of the following values:
  • EMAC_SPEED_10MBPS
  • EMAC_SPEED_100MBPS.
Return values
none

Definition at line 335 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32_emac.c.

◆ emac_system_init()

error_status emac_system_init ( void )

enable emac clock and gpio clock

Parameters
none
Return values
success or error

Definition at line 47 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32_emac.c.

◆ emac_tmr_init()

void emac_tmr_init ( void )

initialize tmr6 for emac

Parameters
none
Return values
none

Definition at line 574 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32_emac.c.

◆ emac_wake_on_lan_init()

void emac_wake_on_lan_init ( void )

wake on lan configuration, it will be woken by magic packet

Parameters
none
Return values
none

< external interrupt line 19

< external interrupt line 19

Definition at line 86 of file project/at_start_f437/examples/emac/wake_on_lan/src/main.c.

Referenced by main().

◆ EMAC_WKUP_IRQHandler()

void EMAC_WKUP_IRQHandler ( void )

this function handles wakeup frames and magic packets

Parameters
none
Return values
none

< external interrupt line 19

Definition at line 174 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c.

◆ ethernetif_notify_conn_changed()

void ethernetif_notify_conn_changed ( struct netif * netif )

this function notify user about link status changement.

Parameters
netif the network interface
Return values
none

Definition at line 523 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32_emac.c.

◆ ethernetif_set_link()

void ethernetif_set_link ( void const * argument )

this function sets the netif link status.

Parameters
netif the network interface
Return values
none

Definition at line 487 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32_emac.c.

◆ ethernetif_update_config()

void ethernetif_update_config ( struct netif * netif )

link callback function, this function is called on change of link status to update low level driver configuration.

Parameters
netif the network interface
Return values
none

Definition at line 550 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32_emac.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 54 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c.

◆ link_update()

uint16_t link_update ( void )

updates the link states

Parameters
none
Return values
link state 0: disconnect, 1: connection

Definition at line 470 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32_emac.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f437/examples/emac/wake_on_lan/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 67 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 45 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 124 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c.

◆ reset_phy()

static void reset_phy ( void )
static

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 106 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 133 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c.

◆ TMR6_DAC_GLOBAL_IRQHandler()

void TMR6_DAC_GLOBAL_IRQHandler ( void )

this function handles timer6 overflow handler.

Parameters
none
Return values
none

< tmr flag overflow

< tmr flag overflow

Definition at line 142 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 93 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c.

Variable Documentation

◆ g_speed

uint8_t g_speed = 1

Definition at line 45 of file project/at_start_f437/examples/emac/wake_on_lan/src/main.c.

◆ local_time

volatile uint32_t local_time = 0

Definition at line 46 of file project/at_start_f437/examples/emac/wake_on_lan/src/main.c.

Referenced by main().

◆ mac_control_para

emac_control_config_type mac_control_para

Definition at line 40 of file project/at_start_f437/examples/emac/wake_on_lan/src/at32_emac.c.

Referenced by emac_layer2_configuration(), and ethernetif_update_config().


AT32F435/437 Firmwary Library: _USB_device_hid_app_led3

Macros | Functions
_USB_device_hid_app_led3
AT32F437_periph_examples

Macros

#define | FLASH_APP_ADDRESS 0x08005000
#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | FLASH_APP_ADDRESS 0x08005000
#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...

Functions

void | iap_init (void)
iap init. More...
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | app_loop (void)
iap loop More...
void | jump_to_iap (uint32_t address)
void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

Macro Definition Documentation

◆ FLASH_APP_ADDRESS [1/2]

#define FLASH_APP_ADDRESS 0x08005000

Definition at line 46 of file app_led3_toggle/inc/hid_iap_user.h.

◆ FLASH_APP_ADDRESS [2/2]

#define FLASH_APP_ADDRESS 0x08005000

Definition at line 46 of file app_led4_toggle/inc/hid_iap_user.h.

◆ OTG_CLOCK [1/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 69 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ OTG_CLOCK [2/2]

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 69 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ OTG_IRQ [1/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 70 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ OTG_IRQ [2/2]

#define OTG_IRQ OTGFS1_IRQn

Definition at line 70 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [1/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 71 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER [2/2]

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 71 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ OTG_PIN_DM [1/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 82 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ OTG_PIN_DM [2/2]

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 82 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [1/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 83 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE [2/2]

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 83 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ OTG_PIN_DP [1/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 79 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ OTG_PIN_DP [2/2]

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 79 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [1/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 80 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE [2/2]

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 80 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ OTG_PIN_GPIO [1/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 76 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ OTG_PIN_GPIO [2/2]

#define OTG_PIN_GPIO GPIOA

Definition at line 76 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [1/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 77 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK [2/2]

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 77 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ OTG_PIN_ID [1/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 88 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ OTG_PIN_ID [2/2]

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 88 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [1/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 89 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE [2/2]

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 89 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ OTG_PIN_MUX [1/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 96 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ OTG_PIN_MUX [2/2]

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 96 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ OTG_PIN_SOF [1/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 93 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ OTG_PIN_SOF [2/2]

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 93 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [1/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 91 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO [2/2]

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 91 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [1/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 92 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK [2/2]

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 92 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [1/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 94 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE [2/2]

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 94 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ OTG_PIN_VBUS [1/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 85 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ OTG_PIN_VBUS [2/2]

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 85 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [1/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 86 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE [2/2]

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 86 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ OTG_USB_ID [1/2]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 62 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ OTG_USB_ID [2/2]

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 62 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [1/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 74 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE [2/2]

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 74 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [1/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 73 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER [2/2]

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 73 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [1/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 72 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ OTG_WKUP_IRQ [2/2]

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 72 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ USB_ID [1/2]

#define USB_ID 0

Definition at line 68 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ USB_ID [2/2]

#define USB_ID 0

Definition at line 68 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [1/2]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore

Definition at line 198 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ USB_VBUS_IGNORE [2/2]

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore

Definition at line 198 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [1/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 151 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE [2/2]

#define USBD2_EP0_TX_SIZE 24

Definition at line 151 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [1/2]

#define USBD2_EP1_TX_SIZE 20

Definition at line 152 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE [2/2]

#define USBD2_EP1_TX_SIZE 20

Definition at line 152 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [1/2]

#define USBD2_EP2_TX_SIZE 20

Definition at line 153 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE [2/2]

#define USBD2_EP2_TX_SIZE 20

Definition at line 153 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [1/2]

#define USBD2_EP3_TX_SIZE 20

Definition at line 154 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE [2/2]

#define USBD2_EP3_TX_SIZE 20

Definition at line 154 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [1/2]

#define USBD2_EP4_TX_SIZE 20

Definition at line 155 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE [2/2]

#define USBD2_EP4_TX_SIZE 20

Definition at line 155 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [1/2]

#define USBD2_EP5_TX_SIZE 20

Definition at line 156 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE [2/2]

#define USBD2_EP5_TX_SIZE 20

Definition at line 156 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [1/2]

#define USBD2_EP6_TX_SIZE 20

Definition at line 157 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE [2/2]

#define USBD2_EP6_TX_SIZE 20

Definition at line 157 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [1/2]

#define USBD2_EP7_TX_SIZE 20

Definition at line 158 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE [2/2]

#define USBD2_EP7_TX_SIZE 20

Definition at line 158 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ USBD2_RX_SIZE [1/2]

#define USBD2_RX_SIZE 128

Definition at line 150 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ USBD2_RX_SIZE [2/2]

#define USBD2_RX_SIZE 128

Definition at line 150 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [1/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 140 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE [2/2]

#define USBD_EP0_TX_SIZE 24

Definition at line 140 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [1/2]

#define USBD_EP1_TX_SIZE 20

Definition at line 141 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE [2/2]

#define USBD_EP1_TX_SIZE 20

Definition at line 141 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [1/2]

#define USBD_EP2_TX_SIZE 20

Definition at line 142 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE [2/2]

#define USBD_EP2_TX_SIZE 20

Definition at line 142 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [1/2]

#define USBD_EP3_TX_SIZE 20

Definition at line 143 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE [2/2]

#define USBD_EP3_TX_SIZE 20

Definition at line 143 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [1/2]

#define USBD_EP4_TX_SIZE 20

Definition at line 144 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE [2/2]

#define USBD_EP4_TX_SIZE 20

Definition at line 144 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [1/2]

#define USBD_EP5_TX_SIZE 20

Definition at line 145 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE [2/2]

#define USBD_EP5_TX_SIZE 20

Definition at line 145 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [1/2]

#define USBD_EP6_TX_SIZE 20

Definition at line 146 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE [2/2]

#define USBD_EP6_TX_SIZE 20

Definition at line 146 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [1/2]

#define USBD_EP7_TX_SIZE 20

Definition at line 147 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE [2/2]

#define USBD_EP7_TX_SIZE 20

Definition at line 147 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ USBD_RX_SIZE [1/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 139 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ USBD_RX_SIZE [2/2]

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 139 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [1/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 50 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE [2/2]

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 50 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

Function Documentation

◆ app_loop()

void app_loop ( void )

iap loop

Parameters
none
Return values
none

Definition at line 260 of file app_led3_toggle/src/hid_iap_user.c.

Referenced by main().

◆ iap_get_upgrade_flag()

iap_result_type iap_get_upgrade_flag ( void )

get iap upgrade complete flag

Parameters
none
Return values
the status of the iap flag

Definition at line 77 of file app_led3_toggle/src/hid_iap_user.c.

Referenced by main().

◆ iap_init()

void iap_init ( void )

iap init.

Parameters
none
Return values
none

iap init.

Parameters
none
Return values
none

Definition at line 61 of file at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c.

◆ jump_to_iap()

void jump_to_iap ( uint32_t address )

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb low power wakeup handler enable

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

usb low power wakeup handler enable

Parameters
ms number of millisecond delay
Return values
none

Definition at line 304 of file project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 315 of file project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c.


AT32F435/437 Firmwary Library: _USB_device_hid_iap

Macros | Functions
_USB_device_hid_iap
AT32F437_periph_examples

Macros

#define | FLASH_APP_ADDRESS 0x08005000
#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...

Functions

void | iap_init (void)
iap init. More...
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | iap_loop (void)
iap loop More...
void | jump_to_app (uint32_t address)
jump to app More...
void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

Macro Definition Documentation

◆ FLASH_APP_ADDRESS

#define FLASH_APP_ADDRESS 0x08005000

Definition at line 45 of file bootloader/inc/hid_iap_user.h.

◆ OTG_CLOCK

#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK

Definition at line 69 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ OTG_IRQ

#define OTG_IRQ OTGFS1_IRQn

Definition at line 70 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ OTG_IRQ_HANDLER

#define OTG_IRQ_HANDLER ( void ) OTGFS1_IRQHandler

Definition at line 71 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ OTG_PIN_DM

#define OTG_PIN_DM GPIO_PINS_11

Definition at line 82 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ OTG_PIN_DM_SOURCE

#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11

Definition at line 83 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ OTG_PIN_DP

#define OTG_PIN_DP GPIO_PINS_12

Definition at line 79 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ OTG_PIN_DP_SOURCE

#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12

Definition at line 80 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ OTG_PIN_GPIO

#define OTG_PIN_GPIO GPIOA

Definition at line 76 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ OTG_PIN_GPIO_CLOCK

#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 77 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ OTG_PIN_ID

#define OTG_PIN_ID GPIO_PINS_10

Definition at line 88 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ OTG_PIN_ID_SOURCE

#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10

Definition at line 89 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ OTG_PIN_MUX

#define OTG_PIN_MUX GPIO_MUX_10

Definition at line 96 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ OTG_PIN_SOF

#define OTG_PIN_SOF GPIO_PINS_8

Definition at line 93 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO

#define OTG_PIN_SOF_GPIO GPIOA

Definition at line 91 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ OTG_PIN_SOF_GPIO_CLOCK

#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK

Definition at line 92 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ OTG_PIN_SOF_SOURCE

#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8

Definition at line 94 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ OTG_PIN_VBUS

#define OTG_PIN_VBUS GPIO_PINS_9

Definition at line 85 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ OTG_PIN_VBUS_SOURCE

#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9

Definition at line 86 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ OTG_USB_ID

#define OTG_USB_ID 1

enable usb host mode

select otgfs1 or otgfs2 define

Definition at line 62 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ OTG_WKUP_EXINT_LINE

#define OTG_WKUP_EXINT_LINE EXINT_LINE_18

Definition at line 74 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ OTG_WKUP_HANDLER

#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler

Definition at line 73 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ OTG_WKUP_IRQ

#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn

Definition at line 72 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ USB_ID

#define USB_ID 0

Definition at line 68 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ USB_VBUS_IGNORE

#define USB_VBUS_IGNORE

usb endpoint max num define

usb host mode config

usb sof output enable

usb vbus ignore

Definition at line 198 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ USBD2_EP0_TX_SIZE

#define USBD2_EP0_TX_SIZE 24

Definition at line 151 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ USBD2_EP1_TX_SIZE

#define USBD2_EP1_TX_SIZE 20

Definition at line 152 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ USBD2_EP2_TX_SIZE

#define USBD2_EP2_TX_SIZE 20

Definition at line 153 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ USBD2_EP3_TX_SIZE

#define USBD2_EP3_TX_SIZE 20

Definition at line 154 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ USBD2_EP4_TX_SIZE

#define USBD2_EP4_TX_SIZE 20

Definition at line 155 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ USBD2_EP5_TX_SIZE

#define USBD2_EP5_TX_SIZE 20

Definition at line 156 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ USBD2_EP6_TX_SIZE

#define USBD2_EP6_TX_SIZE 20

Definition at line 157 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ USBD2_EP7_TX_SIZE

#define USBD2_EP7_TX_SIZE 20

Definition at line 158 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ USBD2_RX_SIZE

#define USBD2_RX_SIZE 128

Definition at line 150 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ USBD_EP0_TX_SIZE

#define USBD_EP0_TX_SIZE 24

Definition at line 140 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ USBD_EP1_TX_SIZE

#define USBD_EP1_TX_SIZE 20

Definition at line 141 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ USBD_EP2_TX_SIZE

#define USBD_EP2_TX_SIZE 20

Definition at line 142 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ USBD_EP3_TX_SIZE

#define USBD_EP3_TX_SIZE 20

Definition at line 143 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ USBD_EP4_TX_SIZE

#define USBD_EP4_TX_SIZE 20

Definition at line 144 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ USBD_EP5_TX_SIZE

#define USBD_EP5_TX_SIZE 20

Definition at line 145 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ USBD_EP6_TX_SIZE

#define USBD_EP6_TX_SIZE 20

Definition at line 146 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ USBD_EP7_TX_SIZE

#define USBD_EP7_TX_SIZE 20

Definition at line 147 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ USBD_RX_SIZE

#define USBD_RX_SIZE 128

usb device mode config

usb device mode fifo

Definition at line 139 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

◆ USE_OTG_DEVICE_MODE

#define USE_OTG_DEVICE_MODE

enable usb device mode

Definition at line 50 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

Function Documentation

◆ iap_get_upgrade_flag()

iap_result_type iap_get_upgrade_flag ( void )

get iap upgrade complete flag

Parameters
none
Return values
the status of the iap flag

Definition at line 77 of file app_led3_toggle/src/hid_iap_user.c.

◆ iap_init()

void iap_init ( void )

iap init.

Parameters
none
Return values
none

iap init.

Parameters
none
Return values
none

Definition at line 61 of file at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c.

◆ iap_loop()

void iap_loop ( void )

iap loop

Parameters
none
Return values
none

Definition at line 491 of file bootloader/src/hid_iap_user.c.

Referenced by main().

◆ jump_to_app()

void jump_to_app ( uint32_t address )

jump to app

Parameters
none
Return values
none

Definition at line 350 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by flash_fat16_loop_status(), iap_loop(), and main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb low power wakeup handler enable

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

usb low power wakeup handler enable

Parameters
ms number of millisecond delay
Return values
none

Definition at line 304 of file project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c.

Referenced by usbd_remote_wakeup(), usbh_loop_handler(), usbh_reset_port(), usbh_resume(), and usbh_suspend().

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 315 of file project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c.


AT32F435/437 Firmwary Library: AT32F437_periph_template

Modules
AT32F437_periph_template

Modules

Library_configuration
System_clock_configuration
LED_toggle

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: AT32F435_437_periph_template

Modules
AT32F435_437_periph_template

Modules

Library_configuration

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: Library_configuration

Macros
Library_configuration
AT32F435_437_periph_template

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED
#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED
#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED
#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED
#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED
#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED
#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

Macro Definition Documentation

◆ ACC_MODULE_ENABLED [1/7]

#define ACC_MODULE_ENABLED

Definition at line 84 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ ACC_MODULE_ENABLED [2/7]

#define ACC_MODULE_ENABLED

Definition at line 84 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ ACC_MODULE_ENABLED [3/7]

#define ACC_MODULE_ENABLED

Definition at line 84 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ ACC_MODULE_ENABLED [4/7]

#define ACC_MODULE_ENABLED

Definition at line 84 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ ACC_MODULE_ENABLED [5/7]

#define ACC_MODULE_ENABLED

Definition at line 84 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ ACC_MODULE_ENABLED [6/7]

#define ACC_MODULE_ENABLED

Definition at line 84 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ ACC_MODULE_ENABLED [7/7]

#define ACC_MODULE_ENABLED

Definition at line 84 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED [1/7]

#define ADC_MODULE_ENABLED

Definition at line 70 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED [2/7]

#define ADC_MODULE_ENABLED

Definition at line 70 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED [3/7]

#define ADC_MODULE_ENABLED

Definition at line 70 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED [4/7]

#define ADC_MODULE_ENABLED

Definition at line 70 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED [5/7]

#define ADC_MODULE_ENABLED

Definition at line 70 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED [6/7]

#define ADC_MODULE_ENABLED

Definition at line 70 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED [7/7]

#define ADC_MODULE_ENABLED

Definition at line 70 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED [1/7]

#define CAN_MODULE_ENABLED

Definition at line 69 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED [2/7]

#define CAN_MODULE_ENABLED

Definition at line 69 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED [3/7]

#define CAN_MODULE_ENABLED

Definition at line 69 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED [4/7]

#define CAN_MODULE_ENABLED

Definition at line 69 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED [5/7]

#define CAN_MODULE_ENABLED

Definition at line 69 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED [6/7]

#define CAN_MODULE_ENABLED

Definition at line 69 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED [7/7]

#define CAN_MODULE_ENABLED

Definition at line 69 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED [1/7]

#define CRC_MODULE_ENABLED

Definition at line 77 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED [2/7]

#define CRC_MODULE_ENABLED

Definition at line 77 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED [3/7]

#define CRC_MODULE_ENABLED

Definition at line 77 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED [4/7]

#define CRC_MODULE_ENABLED

Definition at line 77 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED [5/7]

#define CRC_MODULE_ENABLED

Definition at line 77 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED [6/7]

#define CRC_MODULE_ENABLED

Definition at line 77 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED [7/7]

#define CRC_MODULE_ENABLED

Definition at line 77 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED [1/7]

#define CRM_MODULE_ENABLED

Definition at line 62 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED [2/7]

#define CRM_MODULE_ENABLED

Definition at line 62 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED [3/7]

#define CRM_MODULE_ENABLED

Definition at line 62 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED [4/7]

#define CRM_MODULE_ENABLED

Definition at line 62 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED [5/7]

#define CRM_MODULE_ENABLED

Definition at line 62 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED [6/7]

#define CRM_MODULE_ENABLED

Definition at line 62 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED [7/7]

#define CRM_MODULE_ENABLED

Definition at line 62 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED [1/7]

#define DAC_MODULE_ENABLED

Definition at line 71 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED [2/7]

#define DAC_MODULE_ENABLED

Definition at line 71 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED [3/7]

#define DAC_MODULE_ENABLED

Definition at line 71 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED [4/7]

#define DAC_MODULE_ENABLED

Definition at line 71 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED [5/7]

#define DAC_MODULE_ENABLED

Definition at line 71 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED [6/7]

#define DAC_MODULE_ENABLED

Definition at line 71 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED [7/7]

#define DAC_MODULE_ENABLED

Definition at line 71 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED [1/7]

#define DEBUG_MODULE_ENABLED

Definition at line 75 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED [2/7]

#define DEBUG_MODULE_ENABLED

Definition at line 75 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED [3/7]

#define DEBUG_MODULE_ENABLED

Definition at line 75 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED [4/7]

#define DEBUG_MODULE_ENABLED

Definition at line 75 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED [5/7]

#define DEBUG_MODULE_ENABLED

Definition at line 75 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED [6/7]

#define DEBUG_MODULE_ENABLED

Definition at line 75 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED [7/7]

#define DEBUG_MODULE_ENABLED

Definition at line 75 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED [1/7]

#define DMA_MODULE_ENABLED

Definition at line 74 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED [2/7]

#define DMA_MODULE_ENABLED

Definition at line 74 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED [3/7]

#define DMA_MODULE_ENABLED

Definition at line 74 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED [4/7]

#define DMA_MODULE_ENABLED

Definition at line 74 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED [5/7]

#define DMA_MODULE_ENABLED

Definition at line 74 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED [6/7]

#define DMA_MODULE_ENABLED

Definition at line 74 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED [7/7]

#define DMA_MODULE_ENABLED

Definition at line 74 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED [1/7]

#define DVP_MODULE_ENABLED

Definition at line 87 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED [2/7]

#define DVP_MODULE_ENABLED

Definition at line 87 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED [3/7]

#define DVP_MODULE_ENABLED

Definition at line 87 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED [4/7]

#define DVP_MODULE_ENABLED

Definition at line 87 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED [5/7]

#define DVP_MODULE_ENABLED

Definition at line 87 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED [6/7]

#define DVP_MODULE_ENABLED

Definition at line 87 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED [7/7]

#define DVP_MODULE_ENABLED

Definition at line 87 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED [1/7]

#define EDMA_MODULE_ENABLED

Definition at line 73 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED [2/7]

#define EDMA_MODULE_ENABLED

Definition at line 73 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED [3/7]

#define EDMA_MODULE_ENABLED

Definition at line 73 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED [4/7]

#define EDMA_MODULE_ENABLED

Definition at line 73 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED [5/7]

#define EDMA_MODULE_ENABLED

Definition at line 73 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED [6/7]

#define EDMA_MODULE_ENABLED

Definition at line 73 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED [7/7]

#define EDMA_MODULE_ENABLED

Definition at line 73 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED [1/7]

#define EMAC_MODULE_ENABLED

Definition at line 89 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED [2/7]

#define EMAC_MODULE_ENABLED

Definition at line 89 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED [3/7]

#define EMAC_MODULE_ENABLED

Definition at line 89 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED [4/7]

#define EMAC_MODULE_ENABLED

Definition at line 89 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED [5/7]

#define EMAC_MODULE_ENABLED

Definition at line 89 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED [6/7]

#define EMAC_MODULE_ENABLED

Definition at line 89 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED [7/7]

#define EMAC_MODULE_ENABLED

Definition at line 89 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED [1/7]

#define ERTC_MODULE_ENABLED

Definition at line 64 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED [2/7]

#define ERTC_MODULE_ENABLED

Definition at line 64 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED [3/7]

#define ERTC_MODULE_ENABLED

Definition at line 64 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED [4/7]

#define ERTC_MODULE_ENABLED

Definition at line 64 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED [5/7]

#define ERTC_MODULE_ENABLED

Definition at line 64 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED [6/7]

#define ERTC_MODULE_ENABLED

Definition at line 64 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED [7/7]

#define ERTC_MODULE_ENABLED

Definition at line 64 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED [1/7]

#define EXINT_MODULE_ENABLED

Definition at line 80 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED [2/7]

#define EXINT_MODULE_ENABLED

Definition at line 80 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED [3/7]

#define EXINT_MODULE_ENABLED

Definition at line 80 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED [4/7]

#define EXINT_MODULE_ENABLED

Definition at line 80 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED [5/7]

#define EXINT_MODULE_ENABLED

Definition at line 80 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED [6/7]

#define EXINT_MODULE_ENABLED

Definition at line 80 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED [7/7]

#define EXINT_MODULE_ENABLED

Definition at line 80 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED [1/7]

#define FLASH_MODULE_ENABLED

Definition at line 76 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED [2/7]

#define FLASH_MODULE_ENABLED

Definition at line 76 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED [3/7]

#define FLASH_MODULE_ENABLED

Definition at line 76 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED [4/7]

#define FLASH_MODULE_ENABLED

Definition at line 76 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED [5/7]

#define FLASH_MODULE_ENABLED

Definition at line 76 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED [6/7]

#define FLASH_MODULE_ENABLED

Definition at line 76 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED [7/7]

#define FLASH_MODULE_ENABLED

Definition at line 76 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED [1/7]

#define GPIO_MODULE_ENABLED

Definition at line 65 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED [2/7]

#define GPIO_MODULE_ENABLED

Definition at line 65 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED [3/7]

#define GPIO_MODULE_ENABLED

Definition at line 65 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED [4/7]

#define GPIO_MODULE_ENABLED

Definition at line 65 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED [5/7]

#define GPIO_MODULE_ENABLED

Definition at line 65 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED [6/7]

#define GPIO_MODULE_ENABLED

Definition at line 65 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED [7/7]

#define GPIO_MODULE_ENABLED

Definition at line 65 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT [1/7]

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 58 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT [2/7]

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 58 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT [3/7]

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 58 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT [4/7]

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 58 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT [5/7]

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 58 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT [6/7]

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 58 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT [7/7]

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 58 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ HEXT_VALUE [1/7]

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor.

value of the high speed exernal crystal in hz

Definition at line 51 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ HEXT_VALUE [2/7]

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor.

value of the high speed exernal crystal in hz

Definition at line 51 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ HEXT_VALUE [3/7]

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor.

value of the high speed exernal crystal in hz

Definition at line 51 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ HEXT_VALUE [4/7]

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor.

value of the high speed exernal crystal in hz

Definition at line 51 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ HEXT_VALUE [5/7]

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor.

value of the high speed exernal crystal in hz

Definition at line 51 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ HEXT_VALUE [6/7]

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor.

value of the high speed exernal crystal in hz

Definition at line 51 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ HEXT_VALUE [7/7]

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor.

value of the high speed exernal crystal in hz

Definition at line 51 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ HICK_VALUE [1/7]

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 59 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ HICK_VALUE [2/7]

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 59 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ HICK_VALUE [3/7]

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 59 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ HICK_VALUE [4/7]

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 59 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ HICK_VALUE [5/7]

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 59 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ HICK_VALUE [6/7]

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 59 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ HICK_VALUE [7/7]

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 59 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED [1/7]

#define I2C_MODULE_ENABLED

Definition at line 66 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED [2/7]

#define I2C_MODULE_ENABLED

Definition at line 66 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED [3/7]

#define I2C_MODULE_ENABLED

Definition at line 66 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED [4/7]

#define I2C_MODULE_ENABLED

Definition at line 66 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED [5/7]

#define I2C_MODULE_ENABLED

Definition at line 66 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED [6/7]

#define I2C_MODULE_ENABLED

Definition at line 66 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED [7/7]

#define I2C_MODULE_ENABLED

Definition at line 66 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED [1/7]

#define MISC_MODULE_ENABLED

Definition at line 85 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED [2/7]

#define MISC_MODULE_ENABLED

Definition at line 85 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED [3/7]

#define MISC_MODULE_ENABLED

Definition at line 85 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED [4/7]

#define MISC_MODULE_ENABLED

Definition at line 85 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED [5/7]

#define MISC_MODULE_ENABLED

Definition at line 85 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED [6/7]

#define MISC_MODULE_ENABLED

Definition at line 85 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED [7/7]

#define MISC_MODULE_ENABLED

Definition at line 85 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED [1/7]

#define PWC_MODULE_ENABLED

Definition at line 68 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED [2/7]

#define PWC_MODULE_ENABLED

Definition at line 68 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED [3/7]

#define PWC_MODULE_ENABLED

Definition at line 68 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED [4/7]

#define PWC_MODULE_ENABLED

Definition at line 68 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED [5/7]

#define PWC_MODULE_ENABLED

Definition at line 68 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED [6/7]

#define PWC_MODULE_ENABLED

Definition at line 68 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED [7/7]

#define PWC_MODULE_ENABLED

Definition at line 68 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED [1/7]

#define QSPI_MODULE_ENABLED

Definition at line 86 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED [2/7]

#define QSPI_MODULE_ENABLED

Definition at line 86 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED [3/7]

#define QSPI_MODULE_ENABLED

Definition at line 86 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED [4/7]

#define QSPI_MODULE_ENABLED

Definition at line 86 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED [5/7]

#define QSPI_MODULE_ENABLED

Definition at line 86 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED [6/7]

#define QSPI_MODULE_ENABLED

Definition at line 86 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED [7/7]

#define QSPI_MODULE_ENABLED

Definition at line 86 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED [1/7]

#define SCFG_MODULE_ENABLED

Definition at line 88 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED [2/7]

#define SCFG_MODULE_ENABLED

Definition at line 88 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED [3/7]

#define SCFG_MODULE_ENABLED

Definition at line 88 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED [4/7]

#define SCFG_MODULE_ENABLED

Definition at line 88 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED [5/7]

#define SCFG_MODULE_ENABLED

Definition at line 88 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED [6/7]

#define SCFG_MODULE_ENABLED

Definition at line 88 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED [7/7]

#define SCFG_MODULE_ENABLED

Definition at line 88 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED [1/7]

#define SDIO_MODULE_ENABLED

Definition at line 81 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED [2/7]

#define SDIO_MODULE_ENABLED

Definition at line 81 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED [3/7]

#define SDIO_MODULE_ENABLED

Definition at line 81 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED [4/7]

#define SDIO_MODULE_ENABLED

Definition at line 81 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED [5/7]

#define SDIO_MODULE_ENABLED

Definition at line 81 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED [6/7]

#define SDIO_MODULE_ENABLED

Definition at line 81 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED [7/7]

#define SDIO_MODULE_ENABLED

Definition at line 81 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED [1/7]

#define SPI_MODULE_ENABLED

Definition at line 72 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED [2/7]

#define SPI_MODULE_ENABLED

Definition at line 72 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED [3/7]

#define SPI_MODULE_ENABLED

Definition at line 72 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED [4/7]

#define SPI_MODULE_ENABLED

Definition at line 72 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED [5/7]

#define SPI_MODULE_ENABLED

Definition at line 72 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED [6/7]

#define SPI_MODULE_ENABLED

Definition at line 72 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED [7/7]

#define SPI_MODULE_ENABLED

Definition at line 72 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED [1/7]

#define TMR_MODULE_ENABLED

Definition at line 63 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED [2/7]

#define TMR_MODULE_ENABLED

Definition at line 63 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED [3/7]

#define TMR_MODULE_ENABLED

Definition at line 63 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED [4/7]

#define TMR_MODULE_ENABLED

Definition at line 63 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED [5/7]

#define TMR_MODULE_ENABLED

Definition at line 63 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED [6/7]

#define TMR_MODULE_ENABLED

Definition at line 63 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED [7/7]

#define TMR_MODULE_ENABLED

Definition at line 63 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED [1/7]

#define USART_MODULE_ENABLED

Definition at line 67 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED [2/7]

#define USART_MODULE_ENABLED

Definition at line 67 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED [3/7]

#define USART_MODULE_ENABLED

Definition at line 67 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED [4/7]

#define USART_MODULE_ENABLED

Definition at line 67 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED [5/7]

#define USART_MODULE_ENABLED

Definition at line 67 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED [6/7]

#define USART_MODULE_ENABLED

Definition at line 67 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED [7/7]

#define USART_MODULE_ENABLED

Definition at line 67 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED [1/7]

#define USB_MODULE_ENABLED

Definition at line 83 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED [2/7]

#define USB_MODULE_ENABLED

Definition at line 83 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED [3/7]

#define USB_MODULE_ENABLED

Definition at line 83 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED [4/7]

#define USB_MODULE_ENABLED

Definition at line 83 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED [5/7]

#define USB_MODULE_ENABLED

Definition at line 83 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED [6/7]

#define USB_MODULE_ENABLED

Definition at line 83 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED [7/7]

#define USB_MODULE_ENABLED

Definition at line 83 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED [1/7]

#define WDT_MODULE_ENABLED

Definition at line 79 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED [2/7]

#define WDT_MODULE_ENABLED

Definition at line 79 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED [3/7]

#define WDT_MODULE_ENABLED

Definition at line 79 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED [4/7]

#define WDT_MODULE_ENABLED

Definition at line 79 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED [5/7]

#define WDT_MODULE_ENABLED

Definition at line 79 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED [6/7]

#define WDT_MODULE_ENABLED

Definition at line 79 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED [7/7]

#define WDT_MODULE_ENABLED

Definition at line 79 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED [1/7]

#define WWDT_MODULE_ENABLED

Definition at line 78 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED [2/7]

#define WWDT_MODULE_ENABLED

Definition at line 78 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED [3/7]

#define WWDT_MODULE_ENABLED

Definition at line 78 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED [4/7]

#define WWDT_MODULE_ENABLED

Definition at line 78 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED [5/7]

#define WWDT_MODULE_ENABLED

Definition at line 78 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED [6/7]

#define WWDT_MODULE_ENABLED

Definition at line 78 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED [7/7]

#define WWDT_MODULE_ENABLED

Definition at line 78 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED [1/7]

#define XMC_MODULE_ENABLED

Definition at line 82 of file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED [2/7]

#define XMC_MODULE_ENABLED

Definition at line 82 of file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED [3/7]

#define XMC_MODULE_ENABLED

Definition at line 82 of file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED [4/7]

#define XMC_MODULE_ENABLED

Definition at line 82 of file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED [5/7]

#define XMC_MODULE_ENABLED

Definition at line 82 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED [6/7]

#define XMC_MODULE_ENABLED

Definition at line 82 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED [7/7]

#define XMC_MODULE_ENABLED

Definition at line 82 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: UTILITIES_examples

Modules
UTILITIES_examples

Modules

FreeRTOS_demo
GEN_random_number_demo
Bootloader
QSPI_flash_algorithm_for_iar
Qspi_algorithm_for_keil
QSPI_flash_algorithm_for_keil
SLIB_project_l0
SLIB_project_l1
IAP_app_led3_toggle
IAP_bootloader
IAP_app_led4_toggle
USB_IAP_app_led3_toggle
USB_IAP_app_led4_toggle
USB_IAP_bootloader
EMAC_IAP_app_led3_toggle
EMAC_IAP_bootloader

Detailed Description

Generated by doxygen 1.9.2


AT32F435/437 Firmwary Library: FreeRTOS_demo

Functions | Variables
FreeRTOS_demo
UTILITIES_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | DebugMon_Handler (void)
this function handles svcall exception. More...
void | led2_task_function (void *pvParameters)
void | led3_task_function (void *pvParameters)
int | main (void)
main function. More...

Variables

TaskHandle_t | led2_handler
TaskHandle_t | led3_handler

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file utilities/at32f435_437_freertos_demo/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles svcall exception.

this function handles debug monitor exception.

Parameters
none
Return values
none

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file utilities/at32f435_437_freertos_demo/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file utilities/at32f435_437_freertos_demo/src/at32f435_437_int.c.

◆ led2_task_function()

void led2_task_function ( void * pvParameters )

Definition at line 105 of file utilities/at32f435_437_freertos_demo/src/main.c.

Referenced by main().

◆ led3_task_function()

void led3_task_function ( void * pvParameters )

Definition at line 115 of file utilities/at32f435_437_freertos_demo/src/main.c.

Referenced by main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 52 of file utilities/at32f435_437_freertos_demo/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file utilities/at32f435_437_freertos_demo/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file utilities/at32f435_437_freertos_demo/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file utilities/at32f435_437_freertos_demo/src/at32f435_437_int.c.

Variable Documentation

◆ led2_handler

TaskHandle_t led2_handler

Definition at line 39 of file utilities/at32f435_437_freertos_demo/src/main.c.

Referenced by main().

◆ led3_handler

TaskHandle_t led3_handler

Definition at line 40 of file utilities/at32f435_437_freertos_demo/src/main.c.

Referenced by main().


AT32F435/437 Firmwary Library: GEN_random_number_demo

Modules | Macros | Functions | Variables
GEN_random_number_demo
UTILITIES_examples

Modules

ERTC_asseed_definition
GEN_random_number_demo_exported_functions

Macros

#define DEVICE_ID_ADDR1 0x1FFFF7E8

Functions

int | main (void)
main function. More...
int | get_uid_for_seed (void)
get uid value as seed More...
void | randnum_test (void)
enable ertc as seed More...

Variables

ertc_time_type * time
uint16_t | ertc_clk_div_a = 0
uint16_t | ertc_clk_div_b = 0

Detailed Description

Macro Definition Documentation

◆ DEVICE_ID_ADDR1

#define DEVICE_ID_ADDR1 0x1FFFF7E8

Definition at line 40 of file random.c.

Function Documentation

◆ get_uid_for_seed()

int get_uid_for_seed ( void )

get uid value as seed

Parameters
none
Return values
uid_one_word

Definition at line 51 of file random.c.

Referenced by randnum_test().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 43 of file utilities/at32f435_437_gen_random_number_demo/src/main.c.

◆ randnum_test()

void randnum_test ( void )

enable ertc as seed

Parameters
none
Return values
none

random number test

Parameters
none
Return values
none

Definition at line 142 of file random.c.

Referenced by main().

Variable Documentation

◆ ertc_clk_div_a

uint16_t ertc_clk_div_a = 0

Definition at line 43 of file random.c.

◆ ertc_clk_div_b

uint16_t ertc_clk_div_b = 0

Definition at line 44 of file random.c.

◆ time

ertc_time_type* time

Definition at line 41 of file random.c.

Referenced by delay(), ertc_calendar_get(), ertc_time_show(), ertc_timestamp_get(), ertc_timestamp_show(), main(), and randnum_test().


AT32F435/437 Firmwary Library: ERTC_asseed_definition

Macros
ERTC_asseed_definition
UTILITIES_examples » GEN_random_number_demo

Macros

#define ENABLE_ERTC_ASSEED (1)

Detailed Description

Macro Definition Documentation

◆ ENABLE_ERTC_ASSEED

#define ENABLE_ERTC_ASSEED (1)

Definition at line 49 of file random.h.


AT32F435/437 Firmwary Library: GEN_random_number_demo_exported_functions

Functions
GEN_random_number_demo_exported_functions
UTILITIES_examples » GEN_random_number_demo

Functions

void randnum_test (void)
enable ertc as seed More...

Detailed Description

Function Documentation

◆ randnum_test()

void randnum_test ( void )

enable ertc as seed

Parameters
none
Return values
none

random number test

Parameters
none
Return values
none

Definition at line 142 of file random.c.

Referenced by main().


AT32F435/437 Firmwary Library: Bootloader

Modules | Functions | Variables
Bootloader
UTILITIES_examples

Modules

Bootloader_address_definition
Bootloader_exported_functions
Bootloader_flag_definition
Bootloader_exported_types
Bootloader_definition

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | flash_2kb_write (uint32_t write_addr, uint8_t *pbuffer)
flash erase/program operation. More...
flag_status | flash_upgrade_flag_read (void)
check flash upgrade flag. More...
void | app_load (uint32_t app_addr)
app load. More...
uint8_t | data_take (void)
take data from usart buf. More...
void | command_handle (void)
command analysis handle. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...
void | app_update_handle (void)
app update flow handle. More...
void | iap_upgrade_app_handle (void)
iap upgrade app handle. More...
int | main (void)
main function. More...
void | tmr_init (void)
init tmr. More...
void | TMR3_GLOBAL_IRQHandler (void)
tmr3 global interrupt handler. More...
void | uart_init (uint32_t baudrate)
init usart. More...
void | USART1_IRQHandler (void)
usart1 interrupt handler. More...

Variables

cmd_data_group_type cmd_data_group_type_struct
cmd_data_step_type cmd_data_step
cmd_ctr_step_type cmd_ctr_step
update_status_type update_status
usart_group_type usart_group_struct
cmd_data_step_type cmd_data_step = CMD_DATA_IDLE
cmd_ctr_step_type cmd_ctr_step = CMD_CTR_IDLE
cmd_data_group_type cmd_data_group_struct
update_status_type update_status = UPDATE_PRE
static uint8_t | cmd_addr_cnt = 0
static uint32_t | cmd_data_cnt = 0
uint8_t | time_ira_cnt =0
uint8_t | get_data_from_usart_flag = 0
usart_group_type usart_group_struct

Detailed Description

Function Documentation

◆ app_load()

void app_load ( uint32_t app_addr )

app load.

Parameters
app_addr app code starting address
Return values
none

Definition at line 60 of file at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c.

Referenced by app_update_handle().

◆ app_update_handle()

void app_update_handle ( void )

app update flow handle.

Parameters
none
Return values
none

Definition at line 262 of file at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c.

Referenced by iap_upgrade_app_handle().

◆ back_err()

void back_err ( void )

command response error.

Parameters
none
Return values
none

Definition at line 241 of file at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c.

Referenced by app_update_handle(), and TMR3_GLOBAL_IRQHandler().

◆ back_ok()

void back_ok ( void )

command response ok.

Parameters
none
Return values
none

Definition at line 228 of file at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c.

Referenced by app_update_handle(), and main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c.

◆ command_handle()

void command_handle ( void )

command analysis handle.

Parameters
none
Return values
none

Definition at line 106 of file at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c.

Referenced by iap_upgrade_app_handle().

◆ data_take()

uint8_t data_take ( void )

take data from usart buf.

Parameters
app_addr app code starting address
Return values
val took data

Definition at line 89 of file at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c.

Referenced by command_handle().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c.

◆ flash_2kb_write()

void flash_2kb_write | ( | uint32_t | write_addr,
 |  | uint8_t * | pbuffer
 | ) |  |

flash erase/program operation.

Note
follow 2kb operation of ont time
Parameters
none
Return values
none

Definition at line 45 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/src/flash.c.

◆ flash_upgrade_flag_read()

flag_status flash_upgrade_flag_read ( void )

check flash upgrade flag.

Parameters
none
Return values
none

Definition at line 76 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/src/flash.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c.

◆ iap_upgrade_app_handle()

void iap_upgrade_app_handle ( void )

iap upgrade app handle.

Parameters
none
Return values
none

Definition at line 344 of file at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c.

Referenced by main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 47 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c.

◆ TMR3_GLOBAL_IRQHandler()

void TMR3_GLOBAL_IRQHandler ( void )

tmr3 global interrupt handler.

Parameters
none
Return values
none

Definition at line 75 of file at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c.

◆ tmr_init()

void tmr_init ( void )

init tmr.

Parameters
none
Return values
none

Definition at line 47 of file at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c.

◆ uart_init()

void uart_init ( uint32_t baudrate )

init usart.

initialize print usart

Parameters
none
Return values
none

< gpio pins number 9

< gpio pins number 10

< gpio pins number 9

< gpio pins number 10

Definition at line 45 of file bootloader/src/usart.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c.

◆ USART1_IRQHandler()

void USART1_IRQHandler ( void )

usart1 interrupt handler.

Parameters
none
Return values
none

Definition at line 81 of file bootloader/src/usart.c.

Variable Documentation

◆ cmd_addr_cnt

uint8_t cmd_addr_cnt = 0
static

Definition at line 44 of file at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c.

Referenced by back_err(), and command_handle().

◆ cmd_ctr_step [1/2]

cmd_ctr_step_type cmd_ctr_step
extern

Definition at line 41 of file at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c.

Referenced by app_update_handle(), back_err(), and command_handle().

◆ cmd_ctr_step [2/2]

cmd_ctr_step_type cmd_ctr_step = CMD_CTR_IDLE

Definition at line 41 of file at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c.

Referenced by app_update_handle(), back_err(), and command_handle().

◆ cmd_data_cnt

uint32_t cmd_data_cnt = 0
static

Definition at line 45 of file at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c.

Referenced by back_err(), and command_handle().

◆ cmd_data_group_struct

cmd_data_group_type cmd_data_group_struct

Definition at line 42 of file at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c.

Referenced by app_update_handle(), and command_handle().

◆ cmd_data_group_type_struct

cmd_data_group_type cmd_data_group_type_struct
extern

◆ cmd_data_step [1/2]

cmd_data_step_type cmd_data_step
extern

Definition at line 40 of file at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c.

Referenced by app_update_handle(), back_err(), and command_handle().

◆ cmd_data_step [2/2]

cmd_data_step_type cmd_data_step = CMD_DATA_IDLE

Definition at line 40 of file at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c.

Referenced by app_update_handle(), back_err(), and command_handle().

◆ get_data_from_usart_flag

uint8_t get_data_from_usart_flag = 0

Definition at line 40 of file at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c.

Referenced by app_update_handle(), back_err(), and TMR3_GLOBAL_IRQHandler().

◆ time_ira_cnt

uint8_t time_ira_cnt =0

Definition at line 39 of file at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c.

Referenced by back_err(), TMR3_GLOBAL_IRQHandler(), and USART1_IRQHandler().

◆ update_status [1/2]

update_status_type update_status
extern

Definition at line 43 of file at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c.

Referenced by app_update_handle(), back_err(), and command_handle().

◆ update_status [2/2]

update_status_type update_status = UPDATE_PRE

Definition at line 43 of file at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c.

Referenced by app_update_handle(), back_err(), and command_handle().

◆ usart_group_struct [1/2]

usart_group_type usart_group_struct
extern

Definition at line 38 of file bootloader/src/usart.c.

Referenced by command_handle(), data_take(), and USART1_IRQHandler().

◆ usart_group_struct [2/2]

usart_group_type usart_group_struct

Definition at line 38 of file bootloader/src/usart.c.

Referenced by command_handle(), data_take(), and USART1_IRQHandler().


AT32F435/437 Firmwary Library: Bootloader_address_definition

Macros
Bootloader_address_definition
UTILITIES_examples » Bootloader

Macros

#define | SECTOR_SIZE_INDEX (((*(uint32_t*)0xE0042000) >> 12) & 0x07)
#define | FLASH_SIZE (*(uint32_t*)0x1FFFF7E0) /* read from at32 flash capacity register(unit:kbyte) */
#define | SRAM_SIZE 384 /* sram size, unit:kbyte */
#define | APP_START_ADDR 0x08004000
#define | IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x1000)

Detailed Description

Macro Definition Documentation

◆ APP_START_ADDR

#define APP_START_ADDR 0x08004000

Definition at line 49 of file at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h.

◆ FLASH_SIZE

#define FLASH_SIZE (*(uint32_t*)0x1FFFF7E0) /* read from at32 flash capacity register(unit:kbyte) */

Definition at line 49 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/flash.h.

◆ IAP_UPGRADE_FLAG_ADDR

#define IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x1000)

Definition at line 52 of file at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h.

◆ SECTOR_SIZE_INDEX

#define SECTOR_SIZE_INDEX (((*(uint32_t*)0xE0042000) >> 12) & 0x07)

Definition at line 48 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/flash.h.

◆ SRAM_SIZE

#define SRAM_SIZE 384 /* sram size, unit:kbyte */

Definition at line 50 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/flash.h.


AT32F435/437 Firmwary Library: Bootloader_exported_functions

Typedefs | Functions
Bootloader_exported_functions
UTILITIES_examples » Bootloader | UTILITIES_examples » EMAC_IAP_bootloader

Typedefs

typedef void(* iapfun) (void)

Functions

void | flash_2kb_write (uint32_t write_addr, uint8_t *pbuffer)
flash erase/program operation. More...
flag_status | flash_upgrade_flag_read (void)
check flash upgrade flag. More...
void | command_handle (void)
command analysis handle. More...
void | back_err (void)
command response error. More...
void | back_ok (void)
command response ok. More...
void | iap_upgrade_app_handle (void)
iap upgrade app handle. More...
void | app_load (uint32_t appxaddr)
app load. More...
void | tmr_init (void)
init tmr. More...
void | uart_init (uint32_t baudrate)
initialize print usart More...
uint32_t | flash_if_write (__IO uint32_t *flash_address, uint32_t *data, uint16_t data_length)
this function writes a data buffer in flash (data are 32-bit aligned). More...
void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...

Detailed Description

Typedef Documentation

◆ iapfun

typedef void(* iapfun) (void)

Definition at line 71 of file at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h.

Function Documentation

◆ app_load()

void app_load ( uint32_t app_addr )

app load.

Parameters
app_addr app code starting address
Return values
none

Definition at line 60 of file at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c.

Referenced by app_update_handle(), and main().

◆ back_err()

void back_err ( void )

command response error.

Parameters
none
Return values
none

Definition at line 114 of file app_led3_toggle/src/usart.c.

Referenced by app_update_handle().

◆ back_ok()

void back_ok ( void )

command response ok.

Parameters
none
Return values
none

Definition at line 101 of file app_led3_toggle/src/usart.c.

Referenced by app_update_handle().

◆ command_handle()

void command_handle ( void )

command analysis handle.

Parameters
none
Return values
none

Definition at line 106 of file at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c.

Referenced by iap_upgrade_app_handle().

◆ flash_2kb_write()

void flash_2kb_write | ( | uint32_t | write_addr,
 |  | uint8_t * | pbuffer
 | ) |  |

flash erase/program operation.

Note
follow 2kb operation of ont time
Parameters
none
Return values
none

Definition at line 45 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/src/flash.c.

Referenced by app_update_handle().

◆ flash_if_write()

uint32_t flash_if_write | ( | __IO uint32_t * | flash_address,
 |  | uint32_t * | data,
 |  | uint16_t | data_length
 | ) |  |

this function writes a data buffer in flash (data are 32-bit aligned).

Note
after writing data buffer, the flash content is checked.
Parameters
flash_address | start address for writing data buffer
data | pointer on data buffer
data_length | length of data buffer (unit is 32-bit word)
Return values
0 data successfully written to flash memory 1: error occurred while writing data in flash memory 2: written data in flash memory is different from expected one

Definition at line 83 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/flash.c.

◆ flash_upgrade_flag_read()

flag_status flash_upgrade_flag_read ( void )

check flash upgrade flag.

Parameters
none
Return values
none

Definition at line 76 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/src/flash.c.

Referenced by main().

◆ iap_command_handle()

void iap_command_handle ( void )

iap command handle handle.

Parameters
none
Return values
none

Definition at line 44 of file at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c.

◆ iap_init()

void iap_init ( void )

iap init.

Parameters
none
Return values
none

iap init.

Parameters
none
Return values
none

Definition at line 61 of file at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c.

Referenced by iap_idle(), and iap_start().

◆ iap_upgrade_app_handle()

void iap_upgrade_app_handle ( void )

iap upgrade app handle.

Parameters
none
Return values
none

Definition at line 344 of file at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c.

Referenced by main().

◆ tmr_init()

void tmr_init ( void )

init tmr.

Parameters
none
Return values
none

Definition at line 44 of file at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/tmr.c.

◆ uart_init()

void uart_init ( uint32_t baudrate )

initialize print usart

Parameters
bound uart baudrate
Return values
none

initialize print usart

Parameters
none
Return values
none

< gpio pins number 9

< gpio pins number 10

< gpio pins number 9

< gpio pins number 10

< gpio pins number 9

< gpio pins number 10

< gpio pins number 9

< gpio pins number 10

< gpio pins number 9

< gpio pins number 10

< gpio pins number 9

< gpio pins number 10

< gpio pins number 9

< gpio pins number 10

< gpio pins number 9

< gpio pins number 10

Definition at line 137 of file project/at_start_f435/examples/edma/link_list_mode/src/main.c.

Referenced by main().


AT32F435/437 Firmwary Library: Bootloader_flag_definition

Macros
Bootloader_flag_definition
UTILITIES_examples » Bootloader

Macros

#define IAP_UPGRADE_FLAG 0x41544B38

Detailed Description

Macro Definition Documentation

◆ IAP_UPGRADE_FLAG

#define IAP_UPGRADE_FLAG 0x41544B38

Definition at line 64 of file at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h.


AT32F435/437 Firmwary Library: Bootloader_exported_types

Data Structures | Typedefs | Enumerations
Bootloader_exported_types
UTILITIES_examples » Bootloader

Data Structures

struct | cmd_data_group_type
cmd data group type More...
struct | usart_group_type
usart group type More...

Typedefs

typedef void(* iapfun) (void)

Enumerations

enum cmd_data_step_type {
CMD_DATA_IDLE , CMD_DATA_ADDR , CMD_DATA_BUF , CMD_DATA_CHACK ,
CMD_DATA_DONE , CMD_DATA_ERR
}
cmd data step type More...
enum cmd_ctr_step_type {
CMD_CTR_IDLE , CMD_CTR_INIT , CMD_CTR_DONE , CMD_CTR_ERR ,
CMD_CTR_APP
}
cmd ctr step type More...
enum update_status_type { UPDATE_PRE , UPDATE_CLEAR_FLAG , UPDATE_ING , UPDATE_DONE }
update status type More...

Detailed Description

Typedef Documentation

◆ iapfun

typedef void(* iapfun) (void)

Definition at line 121 of file at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h.

Enumeration Type Documentation

◆ cmd_ctr_step_type

enum cmd_ctr_step_type

cmd ctr step type

Enumerator
CMD_CTR_IDLE
CMD_CTR_INIT
CMD_CTR_DONE
CMD_CTR_ERR
CMD_CTR_APP

Definition at line 101 of file at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h.

◆ cmd_data_step_type

enum cmd_data_step_type

cmd data step type

Enumerator
CMD_DATA_IDLE
CMD_DATA_ADDR
CMD_DATA_BUF
CMD_DATA_CHACK
CMD_DATA_DONE
CMD_DATA_ERR

Definition at line 88 of file at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h.

◆ update_status_type

enum update_status_type

update status type

Enumerator
UPDATE_PRE
UPDATE_CLEAR_FLAG
UPDATE_ING
UPDATE_DONE

Definition at line 113 of file at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h.


AT32F435/437 Firmwary Library: cmd_data_group_type Struct Reference

Data Fields
cmd_data_group_type Struct Reference
UTILITIES_examples » Bootloader » Bootloader_exported_types

cmd data group type More...

#include <iap.h>

Data Fields

uint8_t | cmd_head
uint8_t | cmd_addr [4]
uint8_t | cmd_buf [0x800]
uint8_t | cmd_check

Detailed Description

cmd data group type

Definition at line 77 of file at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h.

Field Documentation

◆ cmd_addr

uint8_t cmd_data_group_type::cmd_addr[4]

Definition at line 80 of file at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h.

Referenced by app_update_handle(), and command_handle().

◆ cmd_buf

uint8_t cmd_data_group_type::cmd_buf[0x800]

Definition at line 81 of file at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h.

Referenced by app_update_handle(), and command_handle().

◆ cmd_check

uint8_t cmd_data_group_type::cmd_check

Definition at line 82 of file at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h.

◆ cmd_head

uint8_t cmd_data_group_type::cmd_head

Definition at line 79 of file at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h.

The documentation for this struct was generated from the following file:
  • at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h


AT32F435/437 Firmwary Library: usart_group_type Struct Reference

Data Fields
usart_group_type Struct Reference
UTILITIES_examples » Bootloader » Bootloader_exported_types

usart group type More...

#include <usart.h>

Data Fields

uint16_t | buf [1024]
uint16_t | head
uint16_t | tail
uint16_t | count

Detailed Description

usart group type

Definition at line 61 of file bootloader/inc/usart.h.

Field Documentation

◆ buf

uint16_t usart_group_type::buf[1024]

Definition at line 63 of file bootloader/inc/usart.h.

Referenced by data_take(), and USART1_IRQHandler().

◆ count

uint16_t usart_group_type::count

Definition at line 66 of file bootloader/inc/usart.h.

Referenced by command_handle(), data_take(), and USART1_IRQHandler().

◆ head

uint16_t usart_group_type::head

Definition at line 64 of file bootloader/inc/usart.h.

Referenced by USART1_IRQHandler().

◆ tail

uint16_t usart_group_type::tail

Definition at line 65 of file bootloader/inc/usart.h.

Referenced by data_take(), and USART1_IRQHandler().

The documentation for this struct was generated from the following file:
  • bootloader/inc/usart.h


AT32F435/437 Firmwary Library: Bootloader_definition

Macros
Bootloader_definition
UTILITIES_examples » Bootloader | UTILITIES_examples » EMAC_IAP_bootloader

Macros

#define | USART_REC_LEN 1024
#define | RX_REMAP (1)
#define | CRYSTAL_ON_PHY (0)
#define | RMII_MODE
#define | DM9162
#define | LINK_DETECTION (1)
#define | PHY_ADDRESS (0x03)
#define | PHY_CONTROL_REG (0x00)
#define | PHY_STATUS_REG (0x01)
#define | PHY_SPECIFIED_CS_REG (0x11)
#define | PHY_AUTO_NEGOTIATION_BIT (0x1000)
#define | PHY_LOOPBACK_BIT (0x4000)
#define | PHY_RESET_BIT (0x8000)
#define | PHY_LINKED_STATUS_BIT (0x0004)
#define | PHY_NEGO_COMPLETE_BIT (0x0020)
#define | PHY_FULL_DUPLEX_100MBPS_BIT (0x8000)
#define | PHY_HALF_DUPLEX_100MBPS_BIT (0x4000)
#define | PHY_FULL_DUPLEX_10MBPS_BIT (0x2000)
#define | PHY_HALF_DUPLEX_10MBPS_BIT (0x1000)
#define | SECTOR_SIZE_INDEX (((*(uint32_t*)0xE0042000) >> 12) & 0x07)
#define | FLASH_SIZE (*(uint32_t*)0x1FFFF7E0) /* read from at32 flash capacity register(unit:kbyte) */
#define | SRAM_SIZE 384 /* sram size, unit:kbyte */
#define | USE_IAP_TFTP
#define | USE_IAP_HTTP
#define | APP_START_SECTOR_ADDR 0x08010000
#define | APP_LAST_SECTOR_ADDR 0x080FF800
#define | APP_END_ADDR 0x080FFFFF
#define | IAP_UPGRADE_FLAG_ADDR (APP_START_SECTOR_ADDR - 0x1000)
#define | IAP_UPGRADE_FLAG 0x41544B38

Detailed Description

Macro Definition Documentation

◆ APP_END_ADDR

#define APP_END_ADDR 0x080FFFFF

Definition at line 54 of file at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h.

◆ APP_LAST_SECTOR_ADDR

#define APP_LAST_SECTOR_ADDR 0x080FF800

Definition at line 53 of file at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h.

◆ APP_START_SECTOR_ADDR

#define APP_START_SECTOR_ADDR 0x08010000

Definition at line 52 of file at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h.

◆ CRYSTAL_ON_PHY

#define CRYSTAL_ON_PHY (0)

Definition at line 52 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h.

◆ DM9162

#define DM9162

Definition at line 57 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h.

◆ FLASH_SIZE

#define FLASH_SIZE (*(uint32_t*)0x1FFFF7E0) /* read from at32 flash capacity register(unit:kbyte) */

Definition at line 49 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/flash.h.

◆ IAP_UPGRADE_FLAG

#define IAP_UPGRADE_FLAG 0x41544B38

Definition at line 61 of file at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h.

◆ IAP_UPGRADE_FLAG_ADDR

#define IAP_UPGRADE_FLAG_ADDR (APP_START_SECTOR_ADDR - 0x1000)

Definition at line 57 of file at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h.

◆ LINK_DETECTION

#define LINK_DETECTION (1)

link status detection, 0: no detection, 1: detect with polling

Definition at line 60 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h.

◆ PHY_ADDRESS

#define PHY_ADDRESS (0x03)

relative to at32 board

Definition at line 63 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h.

◆ PHY_AUTO_NEGOTIATION_BIT

#define PHY_AUTO_NEGOTIATION_BIT (0x1000)

enable auto negotiation

Definition at line 68 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h.

◆ PHY_CONTROL_REG

#define PHY_CONTROL_REG (0x00)

basic mode control register

Definition at line 64 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h.

◆ PHY_FULL_DUPLEX_100MBPS_BIT

#define PHY_FULL_DUPLEX_100MBPS_BIT (0x8000)

full duplex 100 mbps

Definition at line 75 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h.

◆ PHY_FULL_DUPLEX_10MBPS_BIT

#define PHY_FULL_DUPLEX_10MBPS_BIT (0x2000)

full duplex 10 mbps

Definition at line 77 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h.

◆ PHY_HALF_DUPLEX_100MBPS_BIT

#define PHY_HALF_DUPLEX_100MBPS_BIT (0x4000)

half duplex 100 mbps

Definition at line 76 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h.

◆ PHY_HALF_DUPLEX_10MBPS_BIT

#define PHY_HALF_DUPLEX_10MBPS_BIT (0x1000)

half duplex 10 mbps

Definition at line 78 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h.

◆ PHY_LINKED_STATUS_BIT

#define PHY_LINKED_STATUS_BIT (0x0004)

link status

Definition at line 72 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h.

◆ PHY_LOOPBACK_BIT

#define PHY_LOOPBACK_BIT (0x4000)

enable loopback

Definition at line 69 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h.

◆ PHY_NEGO_COMPLETE_BIT

#define PHY_NEGO_COMPLETE_BIT (0x0020)

auto negotiation complete

Definition at line 73 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h.

◆ PHY_RESET_BIT

#define PHY_RESET_BIT (0x8000)

reset phy

Definition at line 70 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h.

◆ PHY_SPECIFIED_CS_REG

#define PHY_SPECIFIED_CS_REG (0x11)

specified configuration and status register

Definition at line 66 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h.

◆ PHY_STATUS_REG

#define PHY_STATUS_REG (0x01)

basic mode status register

Definition at line 65 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h.

◆ RMII_MODE

#define RMII_MODE

Definition at line 55 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h.

◆ RX_REMAP

#define RX_REMAP (1)

Definition at line 51 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h.

◆ SECTOR_SIZE_INDEX

#define SECTOR_SIZE_INDEX (((*(uint32_t*)0xE0042000) >> 12) & 0x07)

Definition at line 48 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/flash.h.

◆ SRAM_SIZE

#define SRAM_SIZE 384 /* sram size, unit:kbyte */

Definition at line 50 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/flash.h.

◆ USART_REC_LEN

#define USART_REC_LEN 1024

Definition at line 48 of file bootloader/inc/usart.h.

◆ USE_IAP_HTTP

#define USE_IAP_HTTP

enable iap using http

Definition at line 49 of file at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h.

◆ USE_IAP_TFTP

#define USE_IAP_TFTP

enable iap using tftp

Definition at line 48 of file at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h.


AT32F435/437 Firmwary Library: QSPI_flash_algorithm_for_iar

Macros | Functions
QSPI_flash_algorithm_for_iar
UTILITIES_examples

Macros

#define FLASH_PAGE_PROGRAM_SIZE 256

Functions

void | custom_qspi_xip_enable (confirm_state new_state)
qspi xip mode enable or disable More...
void | custom_xip_enable_config (void)
qspi xip mode enable config More...
void | custom_qspi_rstqpi (void)
esmt32m rstqpi command More...
void | custom_qspi_rsten (void)
esmt32m rsten command More...
void | custom_qspi_rst (void)
esmt32m rst command More...
void | custom_qspi_write_enable (void)
esmt32m write enable command More...
void | custom_qspi_busy_check (void)
esmt32m check busy command More...
void | custom_qspi_sector_erase (uint32_t adr)
esmt32m sector erase command More...
void | custom_qspi_chip_erase (void)
esmt32m chip erase command More...
void | init_clk (void)
sysclk set to pll 96mhz More...
void | uninit_clk (void)
sysclk uninit More...
void | qspi_gpio_init (void)
qspi gpio initilize More...
void | qspi_cmd_init (void)
qspi command port init flow More...
uint32_t | FlashInit (void *base_of_flash, uint32_t image_size, uint32_t link_address, uint32_t flags)
uint32_t | FlashWrite (void *block_start, uint32_t offset_into_block, uint32_t count, char const *buffer)
uint32_t | FlashErase (void *block_start, uint32_t block_size)
OPTIONAL_SIGNOFF uint32_t | FlashSignoff (void)

Detailed Description

Macro Definition Documentation

◆ FLASH_PAGE_PROGRAM_SIZE

#define FLASH_PAGE_PROGRAM_SIZE 256

Definition at line 21 of file qspi_algorithm.c.

Function Documentation

◆ custom_qspi_busy_check()

void custom_qspi_busy_check ( void )

esmt32m check busy command

Parameters
none
Return values
none

Definition at line 155 of file qspi_algorithm.c.

Referenced by FlashErase(), and FlashWrite().

◆ custom_qspi_chip_erase()

void custom_qspi_chip_erase ( void )

esmt32m chip erase command

Parameters
none
Return values
none

Definition at line 185 of file qspi_algorithm.c.

◆ custom_qspi_rst()

void custom_qspi_rst ( void )

esmt32m rst command

Parameters
none
Return values
none

Definition at line 125 of file qspi_algorithm.c.

Referenced by qspi_cmd_init().

◆ custom_qspi_rsten()

void custom_qspi_rsten ( void )

esmt32m rsten command

Parameters
none
Return values
none

Definition at line 110 of file qspi_algorithm.c.

Referenced by qspi_cmd_init().

◆ custom_qspi_rstqpi()

void custom_qspi_rstqpi ( void )

esmt32m rstqpi command

Parameters
none
Return values
none

Definition at line 95 of file qspi_algorithm.c.

Referenced by qspi_cmd_init().

◆ custom_qspi_sector_erase()

void custom_qspi_sector_erase ( uint32_t adr )

esmt32m sector erase command

Parameters
none
Return values
none

Definition at line 170 of file qspi_algorithm.c.

Referenced by FlashErase().

◆ custom_qspi_write_enable()

void custom_qspi_write_enable ( void )

esmt32m write enable command

Parameters
none
Return values
none

Definition at line 140 of file qspi_algorithm.c.

Referenced by FlashErase(), and FlashWrite().

◆ custom_qspi_xip_enable()

void custom_qspi_xip_enable ( confirm_state new_state )

qspi xip mode enable or disable

Parameters
none
Return values
none

Definition at line 28 of file qspi_algorithm.c.

Referenced by custom_xip_enable_config(), FlashErase(), FlashWrite(), and qspi_cmd_init().

◆ custom_xip_enable_config()

void custom_xip_enable_config ( void )

qspi xip mode enable config

Parameters
none
Return values
none

Definition at line 51 of file qspi_algorithm.c.

Referenced by FlashErase(), FlashInit(), and FlashWrite().

◆ FlashErase()

uint32_t FlashErase | ( | void * | block_start,
 |  | uint32_t | block_size
 | ) |  |

Definition at line 355 of file qspi_algorithm.c.

Referenced by Fl2FlashEraseWriteEntry().

◆ FlashInit()

uint32_t FlashInit | ( | void * | base_of_flash,
 |  | uint32_t | image_size,
 |  | uint32_t | link_address,
 |  | uint32_t | flags
 | ) |  |

Definition at line 292 of file qspi_algorithm.c.

Referenced by Fl2FlashInitEntry().

◆ FlashSignoff()

OPTIONAL_SIGNOFF uint32_t FlashSignoff ( void )

Definition at line 380 of file qspi_algorithm.c.

Referenced by Fl2FlashSignoffEntry().

◆ FlashWrite()

uint32_t FlashWrite | ( | void * | block_start,
 |  | uint32_t | offset_into_block,
 |  | uint32_t | count,
 |  | char const * | buffer
 | ) |  |

Definition at line 304 of file qspi_algorithm.c.

Referenced by Fl2FlashEraseWriteEntry(), and Fl2FlashWriteEntry().

◆ init_clk()

void init_clk ( void )

sysclk set to pll 96mhz

Parameters
none
Return values
none

Definition at line 200 of file qspi_algorithm.c.

Referenced by FlashInit().

◆ qspi_cmd_init()

void qspi_cmd_init ( void )

qspi command port init flow

Parameters
none
Return values
none

Definition at line 259 of file qspi_algorithm.c.

Referenced by FlashInit().

◆ qspi_gpio_init()

void qspi_gpio_init ( void )

qspi gpio initilize

Parameters
none
Return values
none

Definition at line 235 of file qspi_algorithm.c.

Referenced by FlashInit().

◆ uninit_clk()

void uninit_clk ( void )

sysclk uninit

Parameters
none
Return values
none

Definition at line 223 of file qspi_algorithm.c.


AT32F435/437 Firmwary Library: Qspi_algorithm_for_keil

Variables
Qspi_algorithm_for_keil
UTILITIES_examples

Variables

struct FlashDevice const FlashDevice

Detailed Description

Variable Documentation

◆ FlashDevice

struct FlashDevice const FlashDevice
Initial value:
= {
FLASH_DRV_VERS,
"AT32F435/437 QSPI1 ESMT32M",
EXTSPI,
0x90000000,
16*1024*1024,
256,
0,
0xFF,
1000,
1000,
4096, 0x000000,
SECTOR_END
}
SECTOR_END
#define SECTOR_END
Definition: FlashOS.h:28
EXTSPI
#define EXTSPI
Definition: FlashOS.h:18
FLASH_DRV_VERS
#define FLASH_DRV_VERS
Definition: FlashOS.h:46

Definition at line 37 of file FlashDev.c.


AT32F435/437 Firmwary Library: QSPI_flash_algorithm_for_keil

Functions
QSPI_flash_algorithm_for_keil
UTILITIES_examples

Functions

void | custom_qspi_xip_enable (confirm_state new_state)
qspi xip mode enable or disable More...
void | custom_xip_enable_config (void)
qspi xip mode enable config More...
void | custom_qspi_rstqpi (void)
esmt32m rstqpi command More...
void | custom_qspi_rsten (void)
esmt32m rsten command More...
void | custom_qspi_rst (void)
esmt32m rst command More...
void | custom_qspi_write_enable (void)
esmt32m write enable command More...
void | custom_qspi_busy_check (void)
esmt32m check busy command More...
void | custom_qspi_sector_erase (uint32_t adr)
esmt32m sector erase command More...
void | custom_qspi_chip_erase (void)
esmt32m chip erase command More...
void | init_clk (void)
sysclk set to pll 96mhz More...
void | uninit_clk (void)
sysclk uninit More...
void | qspi_gpio_init (void)
qspi gpio initilize More...
void | qspi_cmd_init (void)
qspi command port init flow More...
int | Init (unsigned long adr, unsigned long clk, unsigned long fnc)
initialize flash. More...
int | UnInit (unsigned long fnc)
de-initialize flash. More...
int | EraseChip (void)
int | EraseSector (unsigned long adr)
erase sector. More...
int | ProgramPage (unsigned long adr, unsigned long sz, unsigned char *buf)
program page. More...

Detailed Description

Function Documentation

◆ custom_qspi_busy_check()

void custom_qspi_busy_check ( void )

esmt32m check busy command

Parameters
none
Return values
none

Definition at line 170 of file FlashPrg.c.

Referenced by EraseChip(), EraseSector(), and ProgramPage().

◆ custom_qspi_chip_erase()

void custom_qspi_chip_erase ( void )

esmt32m chip erase command

Parameters
none
Return values
none

Definition at line 200 of file FlashPrg.c.

Referenced by EraseChip().

◆ custom_qspi_rst()

void custom_qspi_rst ( void )

esmt32m rst command

Parameters
none
Return values
none

Definition at line 140 of file FlashPrg.c.

Referenced by qspi_cmd_init().

◆ custom_qspi_rsten()

void custom_qspi_rsten ( void )

esmt32m rsten command

Parameters
none
Return values
none

Definition at line 125 of file FlashPrg.c.

Referenced by qspi_cmd_init().

◆ custom_qspi_rstqpi()

void custom_qspi_rstqpi ( void )

esmt32m rstqpi command

Parameters
none
Return values
none

Definition at line 110 of file FlashPrg.c.

Referenced by qspi_cmd_init().

◆ custom_qspi_sector_erase()

void custom_qspi_sector_erase ( uint32_t adr )

esmt32m sector erase command

Parameters
none
Return values
none

Definition at line 185 of file FlashPrg.c.

Referenced by EraseSector().

◆ custom_qspi_write_enable()

void custom_qspi_write_enable ( void )

esmt32m write enable command

Parameters
none
Return values
none

Definition at line 155 of file FlashPrg.c.

Referenced by EraseChip(), EraseSector(), and ProgramPage().

◆ custom_qspi_xip_enable()

void custom_qspi_xip_enable ( confirm_state new_state )

qspi xip mode enable or disable

Parameters
none
Return values
none

Definition at line 43 of file FlashPrg.c.

Referenced by custom_xip_enable_config(), EraseChip(), EraseSector(), ProgramPage(), and qspi_cmd_init().

◆ custom_xip_enable_config()

void custom_xip_enable_config ( void )

qspi xip mode enable config

Parameters
none
Return values
none

Definition at line 66 of file FlashPrg.c.

Referenced by EraseChip(), EraseSector(), Init(), ProgramPage(), and UnInit().

◆ EraseChip()

int EraseChip ( void )

Definition at line 330 of file FlashPrg.c.

◆ EraseSector()

int EraseSector ( unsigned long adr )

erase sector.

Parameters
adr sector address
Return values
0 if success, 1 if failed

Definition at line 352 of file FlashPrg.c.

◆ Init()

int Init | ( | unsigned long | adr,
 |  | unsigned long | clk,
 |  | unsigned long | fnc
 | ) |  |

initialize flash.

Parameters
adr device base address clk: clock frequency (Hz) fnc: function code (1-erase, 2-program, 3-verify)
Return values
0 if success, 1 if failed

Definition at line 309 of file FlashPrg.c.

◆ init_clk()

void init_clk ( void )

sysclk set to pll 96mhz

Parameters
none
Return values
none

Definition at line 215 of file FlashPrg.c.

Referenced by Init().

◆ ProgramPage()

int ProgramPage | ( | unsigned long | adr,
 |  | unsigned long | sz,
 |  | unsigned char * | buf
 | ) |  |

program page.

Parameters
adr page start address sz: page size buf: page data
Return values
0 if success, 1 if failed

Definition at line 377 of file FlashPrg.c.

◆ qspi_cmd_init()

void qspi_cmd_init ( void )

qspi command port init flow

Parameters
none
Return values
none

Definition at line 274 of file FlashPrg.c.

Referenced by Init().

◆ qspi_gpio_init()

void qspi_gpio_init ( void )

qspi gpio initilize

Parameters
none
Return values
none

Definition at line 250 of file FlashPrg.c.

Referenced by Init().

◆ UnInit()

int UnInit ( unsigned long fnc )

de-initialize flash.

Parameters
fnc function code (1-erase, 2-program, 3-verify)
Return values
0 if success, 1 if failed

Definition at line 323 of file FlashPrg.c.

◆ uninit_clk()

void uninit_clk ( void )

sysclk uninit

Parameters
none
Return values
none

Definition at line 238 of file FlashPrg.c.

Referenced by UnInit().


AT32F435/437 Firmwary Library: SLIB_project_l0

Macros | Functions | Variables
SLIB_project_l0
UTILITIES_examples

Macros

#define | USE_SLIB_FUNCTION /* define it when user want to activate slib in this project */
#define | FLASH_START_ADDR 0x08000000
#define | TEST_SLIB_PSW 0x55665566
#define | SLIB_START_ADDR 0x08001000
#define | SLIB_INST_ADDR 0x08002000
#define | SLIB_END_ADDR 0x08002000
#define | FLASH_SECTOR_SIZE 0x1000
#define | SECTOR_NUM(dwAddr) ((dwAddr & (FLASH_START_ADDR - 1)) / FLASH_SECTOR_SIZE)
#define | SECTOR_WORD_CNT (FLASH_SECTOR_SIZE >> 2) /* words per sector */
#define | SNR_THRESHOLD_F32 140.0f
#define | TEST_LENGTH_SAMPLES 320

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | FLASH_IRQHandler (void)
flash handler. More...
flash_status_type | slib_enable (void)
config slib enable and program slib area. More...
int | main (void)
main function. More...

Variables

uint32_t | dw_start_sector
uint32_t | dw_inst_start_sector
uint32_t | dw_end_sector
uint32_t | temp_buf [1024]
static float32_t | testOutput [320]

Detailed Description

Macro Definition Documentation

◆ FLASH_SECTOR_SIZE

#define FLASH_SECTOR_SIZE 0x1000

Definition at line 51 of file utilities/at32f435_437_slib_demo/project_l0/src/main.c.

◆ FLASH_START_ADDR

#define FLASH_START_ADDR 0x08000000

Definition at line 46 of file utilities/at32f435_437_slib_demo/project_l0/src/main.c.

◆ SECTOR_NUM

#define SECTOR_NUM ( dwAddr ) ((dwAddr & (FLASH_START_ADDR - 1)) / FLASH_SECTOR_SIZE)

Definition at line 52 of file utilities/at32f435_437_slib_demo/project_l0/src/main.c.

◆ SECTOR_WORD_CNT

#define SECTOR_WORD_CNT (FLASH_SECTOR_SIZE >> 2) /* words per sector */

Definition at line 53 of file utilities/at32f435_437_slib_demo/project_l0/src/main.c.

◆ SLIB_END_ADDR

#define SLIB_END_ADDR 0x08002000

Definition at line 50 of file utilities/at32f435_437_slib_demo/project_l0/src/main.c.

◆ SLIB_INST_ADDR

#define SLIB_INST_ADDR 0x08002000

Definition at line 49 of file utilities/at32f435_437_slib_demo/project_l0/src/main.c.

◆ SLIB_START_ADDR

#define SLIB_START_ADDR 0x08001000

Definition at line 48 of file utilities/at32f435_437_slib_demo/project_l0/src/main.c.

◆ SNR_THRESHOLD_F32

#define SNR_THRESHOLD_F32 140.0f

Definition at line 55 of file utilities/at32f435_437_slib_demo/project_l0/src/main.c.

◆ TEST_LENGTH_SAMPLES

#define TEST_LENGTH_SAMPLES 320

Definition at line 56 of file utilities/at32f435_437_slib_demo/project_l0/src/main.c.

◆ TEST_SLIB_PSW

#define TEST_SLIB_PSW 0x55665566

Definition at line 47 of file utilities/at32f435_437_slib_demo/project_l0/src/main.c.

◆ USE_SLIB_FUNCTION

#define USE_SLIB_FUNCTION /* define it when user want to activate slib in this project */

Definition at line 43 of file utilities/at32f435_437_slib_demo/project_l0/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c.

◆ FLASH_IRQHandler()

void FLASH_IRQHandler ( void )

flash handler.

Parameters
none
Return values
none

< flash bank1 erase/program protection error flag

< flash erase/program protection error flag

< flash bank1 erase/program protection error flag

< flash erase/program protection error flag

Definition at line 141 of file utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 128 of file utilities/at32f435_437_slib_demo/project_l0/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c.

◆ slib_enable()

flash_status_type slib_enable ( void )

config slib enable and program slib area.

Parameters
none
Return values
flash status

Definition at line 92 of file utilities/at32f435_437_slib_demo/project_l0/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c.

Variable Documentation

◆ dw_end_sector

uint32_t dw_end_sector

Definition at line 59 of file utilities/at32f435_437_slib_demo/project_l0/src/main.c.

Referenced by slib_enable().

◆ dw_inst_start_sector

uint32_t dw_inst_start_sector

Definition at line 59 of file utilities/at32f435_437_slib_demo/project_l0/src/main.c.

Referenced by slib_enable().

◆ dw_start_sector

uint32_t dw_start_sector

Definition at line 59 of file utilities/at32f435_437_slib_demo/project_l0/src/main.c.

Referenced by slib_enable().

◆ temp_buf

uint32_t temp_buf[1024]

Definition at line 60 of file utilities/at32f435_437_slib_demo/project_l0/src/main.c.

Referenced by slib_enable().

◆ testOutput

float32_t testOutput[320]
static

Definition at line 63 of file utilities/at32f435_437_slib_demo/project_l0/src/main.c.

Referenced by main().


AT32F435/437 Firmwary Library: SLIB_project_l1

Macros | Functions | Variables
SLIB_project_l1
UTILITIES_examples

Macros

#define | SNR_THRESHOLD_F32 140.0f
#define | TEST_LENGTH_SAMPLES 320

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | FLASH_IRQHandler (void)
flash handler. More...
void | config_flash_interrupt (void)
config flash error interrupt. More...
int | main (void)
main function. More...

Variables

static float32_t testOutput [320]

Detailed Description

Macro Definition Documentation

◆ SNR_THRESHOLD_F32

#define SNR_THRESHOLD_F32 140.0f

Definition at line 43 of file utilities/at32f435_437_slib_demo/project_l1/src/main.c.

◆ TEST_LENGTH_SAMPLES

#define TEST_LENGTH_SAMPLES 320

Definition at line 44 of file utilities/at32f435_437_slib_demo/project_l1/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c.

◆ config_flash_interrupt()

void config_flash_interrupt ( void )

config flash error interrupt.

Parameters
none
Return values
flash status

< flash bank1 error interrupt

Definition at line 55 of file utilities/at32f435_437_slib_demo/project_l1/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c.

◆ FLASH_IRQHandler()

void FLASH_IRQHandler ( void )

flash handler.

Parameters
none
Return values
none

< flash bank1 erase/program protection error flag

< flash erase/program protection error flag

< flash bank1 erase/program protection error flag

< flash erase/program protection error flag

Definition at line 141 of file utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 71 of file utilities/at32f435_437_slib_demo/project_l1/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c.

Variable Documentation

◆ testOutput

float32_t testOutput[320]
static

Definition at line 46 of file utilities/at32f435_437_slib_demo/project_l1/src/main.c.

Referenced by main().


AT32F435/437 Firmwary Library: IAP_app_led3_toggle

Modules | Functions | Variables
IAP_app_led3_toggle
UTILITIES_examples

Modules

IAP_app_led3_address_definition
IAP_app_led3_flag_definition
IAP_app_led3_exported_functions

Functions

void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...
int | main (void)
main function. More...
void | tmr_init (void)
init tmr. More...
void | TMR3_GLOBAL_IRQHandler (void)
tmr3 global interrupt handler. More...
void | uart_init (uint32_t baudrate)
init usart. More...
void | USART1_IRQHandler (void)
usart1 interrupt handler. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...

Variables

uint8_t iap_flag = IAP_REV_FLAG_NO

Detailed Description

Function Documentation

◆ back_err()

void back_err ( void )

command response error.

Parameters
none
Return values
none

Definition at line 114 of file app_led3_toggle/src/usart.c.

◆ back_ok()

void back_ok ( void )

command response ok.

Parameters
none
Return values
none

Definition at line 101 of file app_led3_toggle/src/usart.c.

◆ iap_command_handle()

void iap_command_handle ( void )

iap command handle handle.

Parameters
none
Return values
none

Definition at line 44 of file at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c.

◆ iap_init()

void iap_init ( void )

iap init.

Parameters
none
Return values
none

Definition at line 61 of file at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< nvic vector table based flash address

Definition at line 46 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/main.c.

◆ TMR3_GLOBAL_IRQHandler()

void TMR3_GLOBAL_IRQHandler ( void )

tmr3 global interrupt handler.

Parameters
none
Return values
none

Definition at line 72 of file at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/tmr.c.

◆ tmr_init()

void tmr_init ( void )

init tmr.

Parameters
none
Return values
none

Definition at line 44 of file at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/tmr.c.

◆ uart_init()

void uart_init ( uint32_t baudrate )

init usart.

initialize print usart

Parameters
none
Return values
none

< gpio pins number 9

< gpio pins number 10

< gpio pins number 9

< gpio pins number 10

Definition at line 45 of file app_led3_toggle/src/usart.c.

◆ USART1_IRQHandler()

void USART1_IRQHandler ( void )

usart1 interrupt handler.

Parameters
none
Return values
none

Definition at line 81 of file app_led3_toggle/src/usart.c.

Variable Documentation

◆ iap_flag

uint8_t iap_flag = IAP_REV_FLAG_NO

Definition at line 38 of file app_led3_toggle/src/usart.c.

Referenced by USART1_IRQHandler().


AT32F435/437 Firmwary Library: IAP_app_led3_address_definition

Macros
IAP_app_led3_address_definition
UTILITIES_examples » IAP_app_led3_toggle | UTILITIES_examples » IAP_app_led4_toggle

Macros

#define | APP_START_ADDR 0x08004000
#define | IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x1000)
#define | APP_START_ADDR 0x08004000
#define | IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x1000)

Detailed Description

Macro Definition Documentation

◆ APP_START_ADDR [1/2]

#define APP_START_ADDR 0x08004000

Definition at line 49 of file at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h.

◆ APP_START_ADDR [2/2]

#define APP_START_ADDR 0x08004000

Definition at line 49 of file at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/iap.h.

◆ IAP_UPGRADE_FLAG_ADDR [1/2]

#define IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x1000)

Definition at line 52 of file at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h.

◆ IAP_UPGRADE_FLAG_ADDR [2/2]

#define IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x1000)

Definition at line 52 of file at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/iap.h.


AT32F435/437 Firmwary Library: IAP_app_led3_flag_definition

Macros
IAP_app_led3_flag_definition
UTILITIES_examples » IAP_app_led3_toggle | UTILITIES_examples » IAP_app_led4_toggle

Macros

#define | IAP_UPGRADE_FLAG 0x41544B38
#define | IAP_REV_FLAG_NO 0
#define | IAP_REV_FLAG_5A 1
#define | IAP_REV_FLAG_DONE 2
#define | IAP_REV_FLAG_ERROR 3
#define | IAP_UPGRADE_FLAG 0x41544B38
#define | IAP_REV_FLAG_NO 0
#define | IAP_REV_FLAG_5A 1
#define | IAP_REV_FLAG_DONE 2
#define | IAP_REV_FLAG_ERROR 3

Detailed Description

Macro Definition Documentation

◆ IAP_REV_FLAG_5A [1/2]

#define IAP_REV_FLAG_5A 1

Definition at line 51 of file app_led3_toggle/inc/usart.h.

◆ IAP_REV_FLAG_5A [2/2]

#define IAP_REV_FLAG_5A 1

Definition at line 51 of file app_led4_toggle/inc/usart.h.

◆ IAP_REV_FLAG_DONE [1/2]

#define IAP_REV_FLAG_DONE 2

Definition at line 52 of file app_led3_toggle/inc/usart.h.

◆ IAP_REV_FLAG_DONE [2/2]

#define IAP_REV_FLAG_DONE 2

Definition at line 52 of file app_led4_toggle/inc/usart.h.

◆ IAP_REV_FLAG_ERROR [1/2]

#define IAP_REV_FLAG_ERROR 3

Definition at line 53 of file app_led3_toggle/inc/usart.h.

◆ IAP_REV_FLAG_ERROR [2/2]

#define IAP_REV_FLAG_ERROR 3

Definition at line 53 of file app_led4_toggle/inc/usart.h.

◆ IAP_REV_FLAG_NO [1/2]

#define IAP_REV_FLAG_NO 0

Definition at line 50 of file app_led3_toggle/inc/usart.h.

◆ IAP_REV_FLAG_NO [2/2]

#define IAP_REV_FLAG_NO 0

Definition at line 50 of file app_led4_toggle/inc/usart.h.

◆ IAP_UPGRADE_FLAG [1/2]

#define IAP_UPGRADE_FLAG 0x41544B38

Definition at line 64 of file at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h.

◆ IAP_UPGRADE_FLAG [2/2]

#define IAP_UPGRADE_FLAG 0x41544B38

Definition at line 64 of file at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/iap.h.


AT32F435/437 Firmwary Library: IAP_app_led3_exported_functions

Functions
IAP_app_led3_exported_functions
UTILITIES_examples » IAP_app_led3_toggle | UTILITIES_examples » IAP_app_led4_toggle

Functions

void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...
void | tmr_init (void)
init tmr. More...
void | uart_init (uint32_t baudrate)
initialize print usart More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...

Detailed Description

Function Documentation

◆ back_err()

void back_err ( void )

command response error.

Parameters
none
Return values
none

Definition at line 114 of file app_led3_toggle/src/usart.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ back_ok()

void back_ok ( void )

command response ok.

Parameters
none
Return values
none

Definition at line 101 of file app_led3_toggle/src/usart.c.

Referenced by main().

◆ iap_command_handle()

void iap_command_handle ( void )

iap command handle handle.

Parameters
none
Return values
none

Definition at line 44 of file at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c.

Referenced by main().

◆ iap_init()

void iap_init ( void )

iap init.

Parameters
none
Return values
none

iap init.

Parameters
none
Return values
none

Definition at line 61 of file at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c.

Referenced by main().

◆ tmr_init()

void tmr_init ( void )

init tmr.

Parameters
none
Return values
none

Definition at line 44 of file at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/tmr.c.

Referenced by main().

◆ uart_init()

void uart_init ( uint32_t baudrate )

initialize print usart

Parameters
bound uart baudrate
Return values
none

initialize print usart

Parameters
none
Return values
none

< gpio pins number 9

< gpio pins number 10

< gpio pins number 9

< gpio pins number 10

< gpio pins number 9

< gpio pins number 10

< gpio pins number 9

< gpio pins number 10

< gpio pins number 9

< gpio pins number 10

< gpio pins number 9

< gpio pins number 10

< gpio pins number 9

< gpio pins number 10

< gpio pins number 9

< gpio pins number 10

Definition at line 137 of file project/at_start_f435/examples/edma/link_list_mode/src/main.c.


AT32F435/437 Firmwary Library: IAP_bootloader

Functions
IAP_bootloader
UTILITIES_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: IAP_app_led4_toggle

Modules | Functions | Variables
IAP_app_led4_toggle
UTILITIES_examples

Modules

IAP_app_led3_address_definition
IAP_app_led3_flag_definition
IAP_app_led3_exported_functions

Functions

void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...
int | main (void)
main function. More...
void | tmr_init (void)
init tmr. More...
void | TMR3_GLOBAL_IRQHandler (void)
tmr3 global interrupt handler. More...
void | uart_init (uint32_t baudrate)
init usart. More...
void | USART1_IRQHandler (void)
usart1 interrupt handler. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...

Variables

uint8_t iap_flag = IAP_REV_FLAG_NO

Detailed Description

Function Documentation

◆ back_err()

void back_err ( void )

command response error.

Parameters
none
Return values
none

Definition at line 114 of file app_led4_toggle/src/usart.c.

◆ back_ok()

void back_ok ( void )

command response ok.

Parameters
none
Return values
none

Definition at line 101 of file app_led4_toggle/src/usart.c.

◆ iap_command_handle()

void iap_command_handle ( void )

iap command handle handle.

Parameters
none
Return values
none

Definition at line 44 of file at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/iap.c.

◆ iap_init()

void iap_init ( void )

iap init.

Parameters
none
Return values
none

Definition at line 61 of file at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/iap.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< nvic vector table based flash address

Definition at line 46 of file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/main.c.

◆ TMR3_GLOBAL_IRQHandler()

void TMR3_GLOBAL_IRQHandler ( void )

tmr3 global interrupt handler.

Parameters
none
Return values
none

Definition at line 72 of file at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/tmr.c.

◆ tmr_init()

void tmr_init ( void )

init tmr.

Parameters
none
Return values
none

Definition at line 44 of file at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/tmr.c.

◆ uart_init()

void uart_init ( uint32_t baudrate )

init usart.

initialize print usart

Parameters
none
Return values
none

< gpio pins number 9

< gpio pins number 10

< gpio pins number 9

< gpio pins number 10

Definition at line 45 of file app_led4_toggle/src/usart.c.

◆ USART1_IRQHandler()

void USART1_IRQHandler ( void )

usart1 interrupt handler.

Parameters
none
Return values
none

Definition at line 81 of file app_led4_toggle/src/usart.c.

Variable Documentation

◆ iap_flag

uint8_t iap_flag = IAP_REV_FLAG_NO

Definition at line 38 of file app_led4_toggle/src/usart.c.

Referenced by iap_command_handle(), and USART1_IRQHandler().


AT32F435/437 Firmwary Library: USB_IAP_app_led3_toggle

Functions | Variables
USB_IAP_app_led3_toggle
UTILITIES_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | iap_finish (void)
void | iap_respond (uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | iap_init (void)
iap init More...
void | iap_jump ()
void | iap_get ()
iap_result_type | usbd_hid_iap_process (void *udev, uint8_t *pdata, uint16_t len)
usb device iap function More...
void | usbd_hid_iap_in_complete (void *udev)
usb device in transfer complete function More...
void | app_loop (void)
iap loop More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
int | main (void)
main function. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

otg_core_type otg_core_struct

Detailed Description

Function Documentation

◆ app_loop()

void app_loop ( void )

iap loop

Parameters
none
Return values
none

Definition at line 260 of file app_led3_toggle/src/hid_iap_user.c.

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c.

◆ iap_finish()

void iap_finish ( void )

Definition at line 333 of file bootloader/src/hid_iap_user.c.

◆ iap_get()

void iap_get ( )

Definition at line 166 of file app_led3_toggle/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_get_upgrade_flag()

iap_result_type iap_get_upgrade_flag ( void )

get iap upgrade complete flag

Parameters
none
Return values
the status of the iap flag

Definition at line 77 of file app_led3_toggle/src/hid_iap_user.c.

◆ iap_init()

void iap_init ( void )

iap init

iap init.

Parameters
none
Return values
none

Definition at line 95 of file app_led3_toggle/src/hid_iap_user.c.

Referenced by iap_idle(), and iap_start().

◆ iap_jump()

void iap_jump ( void )

Definition at line 155 of file app_led3_toggle/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_respond()

void iap_respond | ( | uint8_t * | res_buf,
 |  | uint16_t | iap_cmd,
 |  | uint16_t | result
 | ) |  |

Definition at line 184 of file app_led3_toggle/src/hid_iap_user.c.

Referenced by iap_get(), iap_idle(), iap_jump(), and iap_start().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< nvic vector table based flash address

Definition at line 55 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c.

◆ OTG_IRQ_HANDLER()

void OTG_IRQ_HANDLER ( void )

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 271 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc sof signal select: otg1

< acc hick trim

Definition at line 104 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

usb low power wakeup handler enable

Parameters
ms number of millisecond delay
Return values
none

Definition at line 281 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 292 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c.

◆ usb_gpio_config()

void usb_gpio_config ( void )

this function config gpio.

Parameters
none
Return values
none

Definition at line 196 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c.

Referenced by main().

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

◆ usbd_hid_iap_in_complete()

void usbd_hid_iap_in_complete ( void * udev )

usb device in transfer complete function

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 247 of file app_led3_toggle/src/hid_iap_user.c.

◆ usbd_hid_iap_process()

iap_result_type usbd_hid_iap_process | ( | void * | udev,
 |  | uint8_t * | pdata,
 |  | uint16_t | len
 | ) |  |

usb device iap function

Parameters
udev | to the structure of usbd_core_type
pdata | data buffer point
len | data length
Return values
iap_result_type

Definition at line 201 of file app_led3_toggle/src/hid_iap_user.c.

Variable Documentation

◆ otg_core_struct

otg_core_type otg_core_struct

Definition at line 45 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c.

Referenced by main(), and OTG_IRQ_HANDLER().


AT32F435/437 Firmwary Library: USB_IAP_app_led4_toggle

Functions | Variables
USB_IAP_app_led4_toggle
UTILITIES_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | iap_clear_upgrade_flag (void)
clear iap upgrade flag More...
void | iap_set_upgrade_flag (void)
set iap upgrade complete flag More...
uint32_t | crc_cal (uint32_t addr, uint16_t nk)
crc cal More...
void | iap_idle (void)
iap idle function More...
void | iap_start (void)
iap start function More...
void | iap_finish (void)
void | iap_respond (uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | iap_init (void)
iap init More...
void | iap_jump ()
void | iap_get ()
iap_result_type | usbd_hid_iap_process (void *udev, uint8_t *pdata, uint16_t len)
usb device iap function More...
void | usbd_hid_iap_in_complete (void *udev)
usb device in transfer complete function More...
void | app_loop (void)
iap loop More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
int | main (void)
main function. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

otg_core_type otg_core_struct

Detailed Description

Function Documentation

◆ app_loop()

void app_loop ( void )

iap loop

Parameters
none
Return values
none

Definition at line 260 of file app_led4_toggle/src/hid_iap_user.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c.

◆ crc_cal()

uint32_t crc_cal | ( | uint32_t | addr,
 |  | uint16_t | nk
 | ) |  |

crc cal

Parameters
addr | start address
nk | nk byte
Return values
crc value

Definition at line 162 of file bootloader/src/hid_iap_user.c.

Referenced by iap_crc().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c.

◆ iap_clear_upgrade_flag()

void iap_clear_upgrade_flag ( void )

clear iap upgrade flag

Parameters
none
Return values
none

Definition at line 52 of file app_led4_toggle/src/hid_iap_user.c.

Referenced by app_loop().

◆ iap_finish()

void iap_finish ( void )

Definition at line 333 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_get()

void iap_get ( )

Definition at line 166 of file app_led4_toggle/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_get_upgrade_flag()

iap_result_type iap_get_upgrade_flag ( void )

get iap upgrade complete flag

Parameters
none
Return values
the status of the iap flag

Definition at line 77 of file app_led4_toggle/src/hid_iap_user.c.

◆ iap_idle()

void iap_idle ( void )

iap idle function

Parameters
none
Return values
none

Definition at line 131 of file app_led4_toggle/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_init()

void iap_init ( void )

iap init

iap init.

Parameters
none
Return values
none

Definition at line 95 of file app_led4_toggle/src/hid_iap_user.c.

Referenced by iap_idle(), and iap_start().

◆ iap_jump()

void iap_jump ( void )

Definition at line 155 of file app_led4_toggle/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_respond()

void iap_respond | ( | uint8_t * | res_buf,
 |  | uint16_t | iap_cmd,
 |  | uint16_t | result
 | ) |  |

Definition at line 184 of file app_led4_toggle/src/hid_iap_user.c.

Referenced by iap_get(), iap_idle(), iap_jump(), and iap_start().

◆ iap_set_upgrade_flag()

void iap_set_upgrade_flag ( void )

set iap upgrade complete flag

Parameters
none
Return values
none

Definition at line 64 of file app_led4_toggle/src/hid_iap_user.c.

◆ iap_start()

void iap_start ( void )

iap start function

Parameters
none
Return values
none

Definition at line 143 of file app_led4_toggle/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< nvic vector table based flash address

Definition at line 55 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c.

◆ OTG_IRQ_HANDLER()

void OTG_IRQ_HANDLER ( void )

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 271 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc sof signal select: otg1

< acc hick trim

Definition at line 104 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

usb low power wakeup handler enable

Parameters
ms number of millisecond delay
Return values
none

Definition at line 281 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 292 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c.

◆ usb_gpio_config()

void usb_gpio_config ( void )

this function config gpio.

Parameters
none
Return values
none

Definition at line 196 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c.

Referenced by main().

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

◆ usbd_hid_iap_in_complete()

void usbd_hid_iap_in_complete ( void * udev )

usb device in transfer complete function

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 247 of file app_led4_toggle/src/hid_iap_user.c.

◆ usbd_hid_iap_process()

iap_result_type usbd_hid_iap_process | ( | void * | udev,
 |  | uint8_t * | pdata,
 |  | uint16_t | len
 | ) |  |

usb device iap function

Parameters
udev | to the structure of usbd_core_type
pdata | data buffer point
len | data length
Return values
iap_result_type

Definition at line 201 of file app_led4_toggle/src/hid_iap_user.c.

Variable Documentation

◆ otg_core_struct

otg_core_type otg_core_struct

Definition at line 45 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c.

Referenced by main(), and OTG_IRQ_HANDLER().


AT32F435/437 Firmwary Library: USB_IAP_bootloader

Functions | Variables
USB_IAP_bootloader
UTILITIES_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | iap_clear_upgrade_flag (void)
clear iap upgrade flag More...
void | iap_set_upgrade_flag (void)
set iap upgrade complete flag More...
uint32_t | crc_cal (uint32_t addr, uint16_t nk)
crc cal More...
void | iap_idle (void)
iap idle function More...
void | iap_start (void)
iap start function More...
iap_result_type | iap_address (uint8_t *pdata, uint32_t len)
iap parse address More...
void | iap_finish (void)
iap_result_type | iap_data_write (uint8_t *pdata, uint32_t len)
void | iap_jump (void)
void | iap_respond (uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
void | jump_to_app (uint32_t address)
jump to app More...
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | iap_erase_sector (uint32_t address)
set iap upgrade complete flag More...
void | iap_init (void)
iap init More...
void | iap_crc (uint8_t *pdata, uint32_t len)
void | iap_get ()
iap_result_type | usbd_hid_iap_process (void *udev, uint8_t *pdata, uint16_t len)
usb device iap function More...
void | usbd_hid_iap_in_complete (void *udev)
usb device in transfer complete function More...
void | iap_loop (void)
iap loop More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
int | main (void)
main function. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

void(* pftarget )(void)
otg_core_type otg_core_struct

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c.

◆ crc_cal()

uint32_t crc_cal | ( | uint32_t | addr,
 |  | uint16_t | nk
 | ) |  |

crc cal

Parameters
addr | start address
nk | nk byte
Return values
crc value

Definition at line 162 of file bootloader/src/hid_iap_user.c.

Referenced by iap_crc().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c.

◆ iap_address()

iap_result_type iap_address | ( | uint8_t * | pdata,
 |  | uint32_t | len
 | ) |  |

iap parse address

Parameters
pdata | data buffer pointer.
len | data length
Return values
the result of the address parse

Definition at line 247 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_clear_upgrade_flag()

void iap_clear_upgrade_flag ( void )

clear iap upgrade flag

Parameters
none
Return values
none

Definition at line 89 of file bootloader/src/hid_iap_user.c.

Referenced by iap_address().

◆ iap_crc()

void iap_crc | ( | uint8_t * | pdata,
 |  | uint32_t | len
 | ) |  |

Definition at line 346 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_data_write()

iap_result_type iap_data_write | ( | uint8_t * | pdata,
 |  | uint32_t | len
 | ) |  |

Definition at line 288 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_erase_sector()

void iap_erase_sector ( uint32_t address )

set iap upgrade complete flag

Parameters
none
Return values
none

Definition at line 131 of file bootloader/src/hid_iap_user.c.

Referenced by iap_address().

◆ iap_finish()

void iap_finish ( void )

Definition at line 333 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_get()

void iap_get ( )

Definition at line 385 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_get_upgrade_flag()

iap_result_type iap_get_upgrade_flag ( void )

get iap upgrade complete flag

Parameters
none
Return values
the status of the iap flag

Definition at line 113 of file bootloader/src/hid_iap_user.c.

Referenced by main().

◆ iap_idle()

void iap_idle ( void )

iap idle function

Parameters
none
Return values
none

Definition at line 222 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_init()

void iap_init ( void )

iap init

iap init.

Parameters
none
Return values
none

Definition at line 185 of file bootloader/src/hid_iap_user.c.

Referenced by iap_idle(), and iap_start().

◆ iap_jump()

void iap_jump ( void )

Definition at line 374 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_loop()

void iap_loop ( void )

iap loop

Parameters
none
Return values
none

Definition at line 491 of file bootloader/src/hid_iap_user.c.

Referenced by main().

◆ iap_respond()

void iap_respond | ( | uint8_t * | res_buf,
 |  | uint16_t | iap_cmd,
 |  | uint16_t | result
 | ) |  |

Definition at line 403 of file bootloader/src/hid_iap_user.c.

Referenced by iap_address(), iap_crc(), iap_data_write(), iap_finish(), iap_get(), iap_idle(), iap_jump(), and iap_start().

◆ iap_set_upgrade_flag()

void iap_set_upgrade_flag ( void )

set iap upgrade complete flag

Parameters
none
Return values
none

Definition at line 101 of file bootloader/src/hid_iap_user.c.

Referenced by iap_finish().

◆ iap_start()

void iap_start ( void )

iap start function

Parameters
none
Return values
none

Definition at line 234 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ jump_to_app()

void jump_to_app ( uint32_t address )

jump to app

Parameters
none
Return values
none

Definition at line 57 of file bootloader/src/hid_iap_user.c.

Referenced by iap_loop().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 55 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c.

◆ OTG_IRQ_HANDLER()

void OTG_IRQ_HANDLER ( void )

this function handles otgfs interrupt.

Parameters
none
Return values
none

Definition at line 273 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc sof signal select: otg1

< acc hick trim

Definition at line 106 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

usb low power wakeup handler enable

Parameters
ms number of millisecond delay
Return values
none

Definition at line 283 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 294 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c.

◆ usb_gpio_config()

void usb_gpio_config ( void )

this function config gpio.

Parameters
none
Return values
none

Definition at line 198 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c.

Referenced by main().

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

◆ usbd_hid_iap_in_complete()

void usbd_hid_iap_in_complete ( void * udev )

usb device in transfer complete function

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 478 of file bootloader/src/hid_iap_user.c.

Referenced by class_in_handler().

◆ usbd_hid_iap_process()

iap_result_type usbd_hid_iap_process | ( | void * | udev,
 |  | uint8_t * | pdata,
 |  | uint16_t | len
 | ) |  |

usb device iap function

Parameters
udev | to the structure of usbd_core_type
pdata | data buffer point
len | data length
Return values
iap_result_type

Definition at line 420 of file bootloader/src/hid_iap_user.c.

Referenced by class_out_handler().

Variable Documentation

◆ otg_core_struct

otg_core_type otg_core_struct

Definition at line 45 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c.

Referenced by disk_ioctl(), disk_read(), disk_status(), disk_write(), main(), and OTG_IRQ_HANDLER().

◆ pftarget

void(* pftarget) (void) ( void )

Definition at line 39 of file bootloader/src/hid_iap_user.c.

Referenced by jump_to_app().


AT32F435/437 Firmwary Library: EMAC_IAP_app_led3_toggle

Modules | Functions | Variables
EMAC_IAP_app_led3_toggle
UTILITIES_examples

Modules

App_led3_definition
App_led3_exported_functions

Functions

error_status | emac_system_init (void)
enable emac clock and gpio clock More...
void | emac_nvic_configuration (void)
configures emac irq channel. More...
void | emac_pins_configuration (void)
configures emac required pins. More...
error_status | emac_layer2_configuration (void)
configures emac layer2 More...
static void | reset_phy (void)
reset layer 1 More...
error_status | emac_phy_register_reset (void)
reset phy register More...
error_status | emac_speed_config (emac_auto_negotiation_type nego, emac_duplex_type mode, emac_speed_type speed)
set mac speed related parameters More...
error_status | emac_phy_init (emac_control_config_type *control_para)
initialize emac phy More...
uint16_t | link_update (void)
updates the link states More...
void | ethernetif_set_link (void const *argument)
this function sets the netif link status. More...
void | ethernetif_notify_conn_changed (struct netif *netif)
this function notify user about link status changement. More...
void | ethernetif_update_config (struct netif *netif)
link callback function, this function is called on change of link status to update low level driver configuration. More...
void | emac_tmr_init (void)
initialize tmr6 for emac More...
void | flash_2kb_write (uint32_t write_addr, uint8_t *pbuffer)
flash erase/program operation. More...
flag_status | flash_upgrade_flag_read (void)
check flash upgrade flag. More...
uint32_t | flash_if_write (__IO uint32_t *flash_address, uint32_t *data, uint16_t data_length)
this function writes a data buffer in flash (data are 32-bit aligned). More...
void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...
int | main (void)
main function. More...
void | tmr_init (void)
init tmr. More...
void | TMR3_GLOBAL_IRQHandler (void)
tmr3 global interrupt handler. More...

Variables

emac_control_config_type mac_control_para
volatile uint32_t local_time = 0

Detailed Description

Function Documentation

◆ emac_layer2_configuration()

error_status emac_layer2_configuration ( void )

configures emac layer2

Parameters
none
Return values
error or success

Definition at line 205 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c.

Referenced by emac_system_init().

◆ emac_nvic_configuration()

void emac_nvic_configuration ( void )

configures emac irq channel.

Parameters
none
Return values
none

Definition at line 70 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c.

Referenced by emac_system_init().

◆ emac_phy_init()

error_status emac_phy_init ( emac_control_config_type * control_para )

initialize emac phy

Parameters
none
Return values
SUCCESS or ERROR

Definition at line 453 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c.

Referenced by emac_layer2_configuration().

◆ emac_phy_register_reset()

error_status emac_phy_register_reset ( void )

reset phy register

Parameters
none
Return values
SUCCESS or ERROR

Definition at line 289 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c.

Referenced by emac_phy_init().

◆ emac_pins_configuration()

void emac_pins_configuration ( void )

configures emac required pins.

Parameters
none
Return values
none

Definition at line 80 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c.

Referenced by emac_system_init().

◆ emac_speed_config()

error_status emac_speed_config | ( | emac_auto_negotiation_type | nego,
 |  | emac_duplex_type | mode,
 |  | emac_speed_type | speed
 | ) |  |

set mac speed related parameters

Parameters
nego auto negotiation on or off. this parameter can be one of the following values:
  • EMAC_AUTO_NEGOTIATION_OFF
  • EMAC_AUTO_NEGOTIATION_ON.
mode half-duplex or full-duplex. this parameter can be one of the following values:
  • EMAC_HALF_DUPLEX
  • EMAC_FULL_DUPLEX.
speed 10 mbps or 100 mbps this parameter can be one of the following values:
  • EMAC_SPEED_10MBPS
  • EMAC_SPEED_100MBPS.
Return values
none

Definition at line 335 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c.

Referenced by ethernetif_update_config().

◆ emac_system_init()

error_status emac_system_init ( void )

enable emac clock and gpio clock

Parameters
none
Return values
success or error

Definition at line 47 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c.

◆ emac_tmr_init()

void emac_tmr_init ( void )

initialize tmr6 for emac

Parameters
none
Return values
none

Definition at line 564 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c.

Referenced by emac_system_init().

◆ ethernetif_notify_conn_changed()

void ethernetif_notify_conn_changed ( struct netif * netif )

this function notify user about link status changement.

Parameters
netif the network interface
Return values
none

Definition at line 513 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c.

Referenced by ethernetif_update_config().

◆ ethernetif_set_link()

void ethernetif_set_link ( void const * argument )

this function sets the netif link status.

Parameters
netif the network interface
Return values
none

Definition at line 487 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c.

◆ ethernetif_update_config()

void ethernetif_update_config ( struct netif * netif )

link callback function, this function is called on change of link status to update low level driver configuration.

Parameters
netif the network interface
Return values
none

Definition at line 540 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c.

◆ flash_2kb_write()

void flash_2kb_write | ( | uint32_t | write_addr,
 |  | uint8_t * | pbuffer
 | ) |  |

flash erase/program operation.

Note
follow 2kb operation of ont time
Parameters
none
Return values
none

Definition at line 44 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/flash.c.

◆ flash_if_write()

uint32_t flash_if_write | ( | __IO uint32_t * | flash_address,
 |  | uint32_t * | data,
 |  | uint16_t | data_length
 | ) |  |

this function writes a data buffer in flash (data are 32-bit aligned).

Note
after writing data buffer, the flash content is checked.
Parameters
flash_address | start address for writing data buffer
data | pointer on data buffer
data_length | length of data buffer (unit is 32-bit word)
Return values
0 data successfully written to flash memory 1: error occurred while writing data in flash memory 2: written data in flash memory is different from expected one

Definition at line 83 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/flash.c.

◆ flash_upgrade_flag_read()

flag_status flash_upgrade_flag_read ( void )

check flash upgrade flag.

Parameters
none
Return values
none

Definition at line 65 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/flash.c.

◆ iap_command_handle()

void iap_command_handle ( void )

iap command handle handle.

Parameters
none
Return values
none

Definition at line 43 of file at32f437_emac_iap_demo/source_code/app_led3_toggle/src/iap.c.

◆ iap_init()

void iap_init ( void )

iap init.

Parameters
none
Return values
none

Definition at line 57 of file at32f437_emac_iap_demo/source_code/app_led3_toggle/src/iap.c.

◆ link_update()

uint16_t link_update ( void )

updates the link states

Parameters
none
Return values
link state 0: disconnect, 1: connection

Definition at line 470 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c.

Referenced by ethernetif_set_link().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< nvic vector table based flash address

Definition at line 50 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/main.c.

◆ reset_phy()

static void reset_phy ( void )
static

reset layer 1

Parameters
none
Return values
none

Definition at line 261 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c.

Referenced by emac_layer2_configuration().

◆ TMR3_GLOBAL_IRQHandler()

void TMR3_GLOBAL_IRQHandler ( void )

tmr3 global interrupt handler.

Parameters
none
Return values
none

Definition at line 73 of file at32f437_emac_iap_demo/source_code/app_led3_toggle/src/tmr.c.

◆ tmr_init()

void tmr_init ( void )

init tmr.

Parameters
none
Return values
none

Definition at line 44 of file at32f437_emac_iap_demo/source_code/app_led3_toggle/src/tmr.c.

Variable Documentation

◆ local_time

volatile uint32_t local_time = 0

Definition at line 43 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/main.c.

Referenced by main().

◆ mac_control_para

emac_control_config_type mac_control_para

Definition at line 40 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c.

Referenced by emac_layer2_configuration(), and ethernetif_update_config().


AT32F435/437 Firmwary Library: App_led3_definition

Macros
App_led3_definition
UTILITIES_examples » EMAC_IAP_app_led3_toggle

Macros

#define | RX_REMAP (1)
#define | CRYSTAL_ON_PHY (0)
#define | RMII_MODE
#define | DM9162
#define | LINK_DETECTION (1)
#define | PHY_ADDRESS (0x03)
#define | PHY_CONTROL_REG (0x00)
#define | PHY_STATUS_REG (0x01)
#define | PHY_SPECIFIED_CS_REG (0x11)
#define | PHY_AUTO_NEGOTIATION_BIT (0x1000)
#define | PHY_LOOPBACK_BIT (0x4000)
#define | PHY_RESET_BIT (0x8000)
#define | PHY_LINKED_STATUS_BIT (0x0004)
#define | PHY_NEGO_COMPLETE_BIT (0x0020)
#define | PHY_FULL_DUPLEX_100MBPS_BIT (0x8000)
#define | PHY_HALF_DUPLEX_100MBPS_BIT (0x4000)
#define | PHY_FULL_DUPLEX_10MBPS_BIT (0x2000)
#define | PHY_HALF_DUPLEX_10MBPS_BIT (0x1000)
#define | FLASH_SIZE (*((uint32_t*)0x1FFFF7E0)) /* read from at32 flash capacity register(unit:kbyte) */
#define | SRAM_SIZE 224 /* sram size, unit:kbyte */
#define | USER_FLASH_END_ADDRESS 0x080FFFFF
#define | APP_START_ADDR 0x08010000
#define | IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x1000)
#define | IAP_UPGRADE_FLAG 0x41544B38

Detailed Description

Macro Definition Documentation

◆ APP_START_ADDR

#define APP_START_ADDR 0x08010000

Definition at line 49 of file at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/iap.h.

◆ CRYSTAL_ON_PHY

#define CRYSTAL_ON_PHY (0)

Definition at line 52 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h.

◆ DM9162

#define DM9162

Definition at line 57 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h.

◆ FLASH_SIZE

#define FLASH_SIZE (*((uint32_t*)0x1FFFF7E0)) /* read from at32 flash capacity register(unit:kbyte) */

Definition at line 48 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/flash.h.

◆ IAP_UPGRADE_FLAG

#define IAP_UPGRADE_FLAG 0x41544B38

Definition at line 56 of file at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/iap.h.

◆ IAP_UPGRADE_FLAG_ADDR

#define IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x1000)

Definition at line 52 of file at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/iap.h.

◆ LINK_DETECTION

#define LINK_DETECTION (1)

link status detection, 0: no detection, 1: detect with polling

Definition at line 60 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h.

◆ PHY_ADDRESS

#define PHY_ADDRESS (0x03)

relative to at32 board

Definition at line 63 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h.

◆ PHY_AUTO_NEGOTIATION_BIT

#define PHY_AUTO_NEGOTIATION_BIT (0x1000)

enable auto negotiation

Definition at line 68 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h.

◆ PHY_CONTROL_REG

#define PHY_CONTROL_REG (0x00)

basic mode control register

Definition at line 64 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h.

◆ PHY_FULL_DUPLEX_100MBPS_BIT

#define PHY_FULL_DUPLEX_100MBPS_BIT (0x8000)

full duplex 100 mbps

Definition at line 75 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h.

◆ PHY_FULL_DUPLEX_10MBPS_BIT

#define PHY_FULL_DUPLEX_10MBPS_BIT (0x2000)

full duplex 10 mbps

Definition at line 77 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h.

◆ PHY_HALF_DUPLEX_100MBPS_BIT

#define PHY_HALF_DUPLEX_100MBPS_BIT (0x4000)

half duplex 100 mbps

Definition at line 76 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h.

◆ PHY_HALF_DUPLEX_10MBPS_BIT

#define PHY_HALF_DUPLEX_10MBPS_BIT (0x1000)

half duplex 10 mbps

Definition at line 78 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h.

◆ PHY_LINKED_STATUS_BIT

#define PHY_LINKED_STATUS_BIT (0x0004)

link status

Definition at line 72 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h.

◆ PHY_LOOPBACK_BIT

#define PHY_LOOPBACK_BIT (0x4000)

enable loopback

Definition at line 69 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h.

◆ PHY_NEGO_COMPLETE_BIT

#define PHY_NEGO_COMPLETE_BIT (0x0020)

auto negotiation complete

Definition at line 73 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h.

◆ PHY_RESET_BIT

#define PHY_RESET_BIT (0x8000)

reset phy

Definition at line 70 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h.

◆ PHY_SPECIFIED_CS_REG

#define PHY_SPECIFIED_CS_REG (0x11)

specified configuration and status register

Definition at line 66 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h.

◆ PHY_STATUS_REG

#define PHY_STATUS_REG (0x01)

basic mode status register

Definition at line 65 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h.

◆ RMII_MODE

#define RMII_MODE

Definition at line 55 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h.

◆ RX_REMAP

#define RX_REMAP (1)

Definition at line 51 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h.

◆ SRAM_SIZE

#define SRAM_SIZE 224 /* sram size, unit:kbyte */

Definition at line 49 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/flash.h.

◆ USER_FLASH_END_ADDRESS

#define USER_FLASH_END_ADDRESS 0x080FFFFF

Definition at line 50 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/flash.h.


AT32F435/437 Firmwary Library: App_led3_exported_functions

Functions
App_led3_exported_functions
UTILITIES_examples » EMAC_IAP_app_led3_toggle

Functions

error_status | emac_system_init (void)
enable emac clock and gpio clock More...
void | emac_nvic_configuration (void)
configures emac irq channel. More...
void | emac_pins_configuration (void)
configures emac required pins. More...
error_status | emac_layer2_configuration (void)
configures emac layer2 More...
static void | reset_phy (void)
error_status | emac_phy_register_reset (void)
reset phy register More...
error_status | emac_speed_config (emac_auto_negotiation_type nego, emac_duplex_type mode, emac_speed_type speed)
set mac speed related parameters More...
error_status | emac_phy_init (emac_control_config_type *control_para)
initialize emac phy More...
uint16_t | link_update (void)
updates the link states More...
void | ethernetif_set_link (void const *argument)
this function sets the netif link status. More...
void | ethernetif_notify_conn_changed (struct netif *netif)
this function notify user about link status changement. More...
void | ethernetif_update_config (struct netif *netif)
link callback function, this function is called on change of link status to update low level driver configuration. More...
void | emac_tmr_init (void)
initialize tmr6 for emac More...
void | flash_2kb_write (uint32_t write_addr, uint8_t *pbuffer)
flash erase/program operation. More...
flag_status | flash_upgrade_flag_read (void)
check flash upgrade flag. More...
uint32_t | flash_if_write (__IO uint32_t *flash_address, uint32_t *data, uint16_t data_length)
this function writes a data buffer in flash (data are 32-bit aligned). More...
void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...
void | tmr_init (void)
init tmr. More...

Detailed Description

Function Documentation

◆ emac_layer2_configuration()

error_status emac_layer2_configuration ( void )

configures emac layer2

Parameters
none
Return values
error or success

Definition at line 205 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

◆ emac_nvic_configuration()

void emac_nvic_configuration ( void )

configures emac irq channel.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

◆ emac_phy_init()

error_status emac_phy_init ( emac_control_config_type * control_para )

initialize emac phy

Parameters
none
Return values
SUCCESS or ERROR

Definition at line 453 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

◆ emac_phy_register_reset()

error_status emac_phy_register_reset ( void )

reset phy register

Parameters
none
Return values
SUCCESS or ERROR

Definition at line 289 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

◆ emac_pins_configuration()

void emac_pins_configuration ( void )

configures emac required pins.

Parameters
none
Return values
none

Definition at line 80 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

◆ emac_speed_config()

error_status emac_speed_config | ( | emac_auto_negotiation_type | nego,
 |  | emac_duplex_type | mode,
 |  | emac_speed_type | speed
 | ) |  |

set mac speed related parameters

Parameters
nego auto negotiation on or off. this parameter can be one of the following values:
  • EMAC_AUTO_NEGOTIATION_OFF
  • EMAC_AUTO_NEGOTIATION_ON.
mode half-duplex or full-duplex. this parameter can be one of the following values:
  • EMAC_HALF_DUPLEX
  • EMAC_FULL_DUPLEX.
speed 10 mbps or 100 mbps this parameter can be one of the following values:
  • EMAC_SPEED_10MBPS
  • EMAC_SPEED_100MBPS.
Return values
none

Definition at line 335 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

◆ emac_system_init()

error_status emac_system_init ( void )

enable emac clock and gpio clock

Parameters
none
Return values
success or error

Definition at line 47 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

◆ emac_tmr_init()

void emac_tmr_init ( void )

initialize tmr6 for emac

Parameters
none
Return values
none

Definition at line 574 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

◆ ethernetif_notify_conn_changed()

void ethernetif_notify_conn_changed ( struct netif * netif )

this function notify user about link status changement.

Parameters
netif the network interface
Return values
none

Definition at line 523 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

◆ ethernetif_set_link()

void ethernetif_set_link ( void const * argument )

this function sets the netif link status.

Parameters
netif the network interface
Return values
none

Definition at line 487 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

◆ ethernetif_update_config()

void ethernetif_update_config ( struct netif * netif )

link callback function, this function is called on change of link status to update low level driver configuration.

Parameters
netif the network interface
Return values
none

Definition at line 550 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

◆ flash_2kb_write()

void flash_2kb_write | ( | uint32_t | write_addr,
 |  | uint8_t * | pbuffer
 | ) |  |

flash erase/program operation.

Note
follow 2kb operation of ont time
Parameters
none
Return values
none

Definition at line 45 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/src/flash.c.

◆ flash_if_write()

uint32_t flash_if_write | ( | __IO uint32_t * | flash_address,
 |  | uint32_t * | data,
 |  | uint16_t | data_length
 | ) |  |

this function writes a data buffer in flash (data are 32-bit aligned).

Note
after writing data buffer, the flash content is checked.
Parameters
flash_address | start address for writing data buffer
data | pointer on data buffer
data_length | length of data buffer (unit is 32-bit word)
Return values
0 data successfully written to flash memory 1: error occurred while writing data in flash memory 2: written data in flash memory is different from expected one

Definition at line 83 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/flash.c.

◆ flash_upgrade_flag_read()

flag_status flash_upgrade_flag_read ( void )

check flash upgrade flag.

Parameters
none
Return values
none

Definition at line 76 of file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/src/flash.c.

◆ iap_command_handle()

void iap_command_handle ( void )

iap command handle handle.

Parameters
none
Return values
none

Definition at line 44 of file at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c.

◆ iap_init()

void iap_init ( void )

iap init.

Parameters
none
Return values
none

iap init.

Parameters
none
Return values
none

Definition at line 61 of file at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c.

◆ link_update()

uint16_t link_update ( void )

updates the link states

Parameters
none
Return values
link state 0: disconnect, 1: connection

Definition at line 470 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

◆ reset_phy()

static void reset_phy ( void )
static

◆ tmr_init()

void tmr_init ( void )

init tmr.

Parameters
none
Return values
none

Definition at line 44 of file at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/tmr.c.


AT32F435/437 Firmwary Library: EMAC_IAP_bootloader

Modules | Functions | Variables
EMAC_IAP_bootloader
UTILITIES_examples

Modules

Bootloader_definition
EMAC_IAP_bootloader_exported_functions
Bootloader_exported_functions

Functions

error_status | emac_system_init (void)
enable emac clock and gpio clock More...
void | emac_nvic_configuration (void)
configures emac irq channel. More...
void | emac_pins_configuration (void)
configures emac required pins. More...
error_status | emac_layer2_configuration (void)
configures emac layer2 More...
static void | reset_phy (void)
reset layer 1 More...
error_status | emac_phy_register_reset (void)
reset phy register More...
error_status | emac_speed_config (emac_auto_negotiation_type nego, emac_duplex_type mode, emac_speed_type speed)
set mac speed related parameters More...
error_status | emac_phy_init (emac_control_config_type *control_para)
initialize emac phy More...
uint16_t | link_update (void)
updates the link states More...
void | ethernetif_set_link (void const *argument)
this function sets the netif link status. More...
void | ethernetif_notify_conn_changed (struct netif *netif)
this function notify user about link status changement. More...
void | ethernetif_update_config (struct netif *netif)
link callback function, this function is called on change of link status to update low level driver configuration. More...
void | emac_tmr_init (void)
initialize tmr6 for emac More...
void | flash_2kb_write (uint32_t write_addr, uint8_t *pbuffer)
flash erase/program operation. More...
uint32_t | flash_if_write (__IO uint32_t *flash_address, uint32_t *data, uint16_t data_length)
this function writes a data buffer in flash (data are 32-bit aligned). More...
flag_status | flash_upgrade_flag_read (void)
check flash upgrade flag. More...
void | app_load (uint32_t app_addr)
app load. More...
void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...
int | main (void)
main function. More...
void | tmr_init (void)
init tmr. More...
void | TMR3_GLOBAL_IRQHandler (void)
tmr3 global interrupt handler. More...

Variables

emac_control_config_type mac_control_para
iapfun jump_to_app
volatile uint32_t local_time = 0

Detailed Description

Function Documentation

◆ app_load()

void app_load ( uint32_t app_addr )

app load.

Parameters
app_addr app code starting address
Return values
none

Definition at line 55 of file at32f437_emac_iap_demo/source_code/bootloader/src/iap.c.

Referenced by main().

◆ emac_layer2_configuration()

error_status emac_layer2_configuration ( void )

configures emac layer2

Parameters
none
Return values
error or success

Definition at line 205 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c.

Referenced by emac_system_init().

◆ emac_nvic_configuration()

void emac_nvic_configuration ( void )

configures emac irq channel.

Parameters
none
Return values
none

Definition at line 70 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c.

Referenced by emac_system_init().

◆ emac_phy_init()

error_status emac_phy_init ( emac_control_config_type * control_para )

initialize emac phy

Parameters
none
Return values
SUCCESS or ERROR

Definition at line 453 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c.

Referenced by emac_layer2_configuration().

◆ emac_phy_register_reset()

error_status emac_phy_register_reset ( void )

reset phy register

Parameters
none
Return values
SUCCESS or ERROR

Definition at line 289 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c.

Referenced by emac_phy_init().

◆ emac_pins_configuration()

void emac_pins_configuration ( void )

configures emac required pins.

Parameters
none
Return values
none

Definition at line 80 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c.

Referenced by emac_system_init().

◆ emac_speed_config()

error_status emac_speed_config | ( | emac_auto_negotiation_type | nego,
 |  | emac_duplex_type | mode,
 |  | emac_speed_type | speed
 | ) |  |

set mac speed related parameters

Parameters
nego auto negotiation on or off. this parameter can be one of the following values:
  • EMAC_AUTO_NEGOTIATION_OFF
  • EMAC_AUTO_NEGOTIATION_ON.
mode half-duplex or full-duplex. this parameter can be one of the following values:
  • EMAC_HALF_DUPLEX
  • EMAC_FULL_DUPLEX.
speed 10 mbps or 100 mbps this parameter can be one of the following values:
  • EMAC_SPEED_10MBPS
  • EMAC_SPEED_100MBPS.
Return values
none

Definition at line 335 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c.

Referenced by emac_phy_init(), and ethernetif_update_config().

◆ emac_system_init()

error_status emac_system_init ( void )

enable emac clock and gpio clock

Parameters
none
Return values
success or error

Definition at line 47 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c.

◆ emac_tmr_init()

void emac_tmr_init ( void )

initialize tmr6 for emac

Parameters
none
Return values
none

Definition at line 565 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c.

Referenced by emac_system_init().

◆ ethernetif_notify_conn_changed()

void ethernetif_notify_conn_changed ( struct netif * netif )

this function notify user about link status changement.

Parameters
netif the network interface
Return values
none

Definition at line 514 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c.

Referenced by ethernetif_update_config().

◆ ethernetif_set_link()

void ethernetif_set_link ( void const * argument )

this function sets the netif link status.

Parameters
netif the network interface
Return values
none

Definition at line 488 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c.

◆ ethernetif_update_config()

void ethernetif_update_config ( struct netif * netif )

link callback function, this function is called on change of link status to update low level driver configuration.

Parameters
netif the network interface
Return values
none

Definition at line 541 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c.

◆ flash_2kb_write()

void flash_2kb_write | ( | uint32_t | write_addr,
 |  | uint8_t * | pbuffer
 | ) |  |

flash erase/program operation.

Note
follow 2kb operation of ont time
Parameters
none
Return values
none

Definition at line 44 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/src/flash.c.

Referenced by app_update_handle().

◆ flash_if_write()

uint32_t flash_if_write | ( | __IO uint32_t * | flash_address,
 |  | uint32_t * | data,
 |  | uint16_t | data_length
 | ) |  |

this function writes a data buffer in flash (data are 32-bit aligned).

Note
after writing data buffer, the flash content is checked.
Parameters
flash_address | start address for writing data buffer
data | pointer on data buffer
data_length | length of data buffer (unit is 32-bit word)
Return values
0 data successfully written to flash memory 1: error occurred while writing data in flash memory 2: written data in flash memory is different from expected one

Definition at line 80 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/src/flash.c.

◆ flash_upgrade_flag_read()

flag_status flash_upgrade_flag_read ( void )

check flash upgrade flag.

Parameters
none
Return values
none

Definition at line 114 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/src/flash.c.

Referenced by main().

◆ iap_command_handle()

void iap_command_handle ( void )

iap command handle handle.

Parameters
none
Return values
none

Definition at line 83 of file at32f437_emac_iap_demo/source_code/bootloader/src/iap.c.

Referenced by main().

◆ iap_init()

void iap_init ( void )

iap init.

Parameters
none
Return values
none

Definition at line 96 of file at32f437_emac_iap_demo/source_code/bootloader/src/iap.c.

Referenced by main().

◆ link_update()

uint16_t link_update ( void )

updates the link states

Parameters
none
Return values
link state 0: disconnect, 1: connection

Definition at line 471 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c.

Referenced by ethernetif_set_link().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 53 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/src/main.c.

◆ reset_phy()

static void reset_phy ( void )
static

reset layer 1

Parameters
none
Return values
none

Definition at line 261 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c.

Referenced by emac_layer2_configuration().

◆ TMR3_GLOBAL_IRQHandler()

void TMR3_GLOBAL_IRQHandler ( void )

tmr3 global interrupt handler.

Parameters
none
Return values
none

Definition at line 73 of file at32f437_emac_iap_demo/source_code/bootloader/src/tmr.c.

◆ tmr_init()

void tmr_init ( void )

init tmr.

Parameters
none
Return values
none

Definition at line 44 of file at32f437_emac_iap_demo/source_code/bootloader/src/tmr.c.

Referenced by main().

Variable Documentation

◆ jump_to_app

iapfun jump_to_app

Definition at line 41 of file at32f437_emac_iap_demo/source_code/bootloader/src/iap.c.

Referenced by app_load().

◆ local_time

volatile uint32_t local_time = 0

Definition at line 46 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/src/main.c.

Referenced by main(), and time_update().

◆ mac_control_para

emac_control_config_type mac_control_para

Definition at line 40 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c.

Referenced by emac_layer2_configuration(), emac_phy_init(), and ethernetif_update_config().


AT32F435/437 Firmwary Library: EMAC_IAP_bootloader_exported_functions

Functions
EMAC_IAP_bootloader_exported_functions
UTILITIES_examples » EMAC_IAP_bootloader

Functions

error_status | emac_system_init (void)
enable emac clock and gpio clock More...
void | emac_nvic_configuration (void)
configures emac irq channel. More...
void | emac_pins_configuration (void)
configures emac required pins. More...
error_status | emac_layer2_configuration (void)
configures emac layer2 More...
static void | reset_phy (void)
error_status | emac_phy_register_reset (void)
reset phy register More...
error_status | emac_speed_config (emac_auto_negotiation_type nego, emac_duplex_type mode, emac_speed_type speed)
set mac speed related parameters More...
error_status | emac_phy_init (emac_control_config_type *control_para)
initialize emac phy More...
uint16_t | link_update (void)
updates the link states More...
void | ethernetif_set_link (void const *argument)
this function sets the netif link status. More...
void | ethernetif_notify_conn_changed (struct netif *netif)
this function notify user about link status changement. More...
void | ethernetif_update_config (struct netif *netif)
link callback function, this function is called on change of link status to update low level driver configuration. More...
void | emac_tmr_init (void)
initialize tmr6 for emac More...

Detailed Description

Function Documentation

◆ emac_layer2_configuration()

error_status emac_layer2_configuration ( void )

configures emac layer2

Parameters
none
Return values
error or success

Definition at line 205 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

Referenced by emac_system_init().

◆ emac_nvic_configuration()

void emac_nvic_configuration ( void )

configures emac irq channel.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

Referenced by emac_system_init().

◆ emac_phy_init()

error_status emac_phy_init ( emac_control_config_type * control_para )

initialize emac phy

Parameters
none
Return values
SUCCESS or ERROR

Definition at line 453 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

Referenced by emac_layer2_configuration().

◆ emac_phy_register_reset()

error_status emac_phy_register_reset ( void )

reset phy register

Parameters
none
Return values
SUCCESS or ERROR

Definition at line 289 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

Referenced by emac_phy_init().

◆ emac_pins_configuration()

void emac_pins_configuration ( void )

configures emac required pins.

Parameters
none
Return values
none

Definition at line 80 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

Referenced by emac_system_init().

◆ emac_speed_config()

error_status emac_speed_config | ( | emac_auto_negotiation_type | nego,
 |  | emac_duplex_type | mode,
 |  | emac_speed_type | speed
 | ) |  |

set mac speed related parameters

Parameters
nego auto negotiation on or off. this parameter can be one of the following values:
  • EMAC_AUTO_NEGOTIATION_OFF
  • EMAC_AUTO_NEGOTIATION_ON.
mode half-duplex or full-duplex. this parameter can be one of the following values:
  • EMAC_HALF_DUPLEX
  • EMAC_FULL_DUPLEX.
speed 10 mbps or 100 mbps this parameter can be one of the following values:
  • EMAC_SPEED_10MBPS
  • EMAC_SPEED_100MBPS.
Return values
none

Definition at line 335 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

Referenced by emac_phy_init(), and ethernetif_update_config().

◆ emac_system_init()

error_status emac_system_init ( void )

enable emac clock and gpio clock

Parameters
none
Return values
success or error

Definition at line 47 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

Referenced by main().

◆ emac_tmr_init()

void emac_tmr_init ( void )

initialize tmr6 for emac

Parameters
none
Return values
none

Definition at line 574 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

Referenced by emac_system_init().

◆ ethernetif_notify_conn_changed()

void ethernetif_notify_conn_changed ( struct netif * netif )

this function notify user about link status changement.

Parameters
netif the network interface
Return values
none

Definition at line 523 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

Referenced by ethernetif_update_config().

◆ ethernetif_set_link()

void ethernetif_set_link ( void const * argument )

this function sets the netif link status.

Parameters
netif the network interface
Return values
none

Definition at line 487 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

Referenced by lwip_periodic_handle().

◆ ethernetif_update_config()

void ethernetif_update_config ( struct netif * netif )

link callback function, this function is called on change of link status to update low level driver configuration.

Parameters
netif the network interface
Return values
none

Definition at line 550 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

Referenced by tcpip_stack_init().

◆ link_update()

uint16_t link_update ( void )

updates the link states

Parameters
none
Return values
link state 0: disconnect, 1: connection

Definition at line 470 of file project/at_start_f437/examples/emac/dns_client/src/at32_emac.c.

Referenced by ethernetif_set_link().

◆ reset_phy()

static void reset_phy ( void )
static


AT32F435/437 Firmwary Library: Data Structures

Data Structures
Here are the data structures with brief descriptions:
C acc_type | Type define acc register all
C adc_base_config_type | Adc base config type
C adc_common_config_type | Adc common config type
C adc_type | Type define adc register all
C adccom_type | Type define adc register all
C audio_codec_type |
C can_base_type | Can init structure definition
C can_baudrate_type | Can baudrate structure definition
C can_fifo_mailbox_type | Can controller area network fifo mailbox
C can_filter_init_type | Can filter init structure definition
C can_filter_register_type | Can controller area network filter bit register
C can_rx_message_type | Can rx message structure definition
C can_tx_mailbox_type | Can controller area network tx mailbox
C can_tx_message_type | Can tx message structure definition
C can_type | Type define can register all
C cbd_extended_type | Extended command block description
C cbd_typical_type | Typical command block description
C cbw_type | Command block wrapper
C cdc_msc_struct_type | Usb cdc class struct
C cdc_struct_type | Usb cdc class struct
C cmd_data_group_type | Cmd data group type
C crc_type | Type define crc register all
C crm_clocks_freq_type | Crm clocks freqency structure
C crm_type | Type define crm register all
C csw_type | Command block wrapper
C custom_hid_type |
C dac_type | Type define dac register all
C debug_type | Type define debug register all
C default_filename |
C Descriptors_Format_def |
C dma_channel_type | Type define dma channel register all
C dma_init_type | Dma init type
C dma_type | Type define dma1 register
C dmamux_channel_type | Type define dmamux muxsctrl register
C dmamux_gen_init_type | Dmamux generator init type
C dmamux_generator_type | Type define dmamux request generator register all
C dmamux_sync_init_type | Dmamux sync init type
C dvp_type |
C edma_init_type | Edma init type
C edma_stream_2d_type | Type define edma 2d register all
C edma_stream_link_list_type | Type define edma stream link list pointer register
C edma_stream_type | Type define edma stream register all
C edma_type | Type define edma register all
C edmamux_channel_type | Type define edmamux muxsctrl register
C edmamux_gen_init_type | Edmamux generator init type
C edmamux_generator_type | Type define edmamux request generator register all
C edmamux_sync_init_type | Edmamux sync init type
C emac_control_config_type | Ethernet mac control config type
C emac_dma_config_type | Ethernet mac dma config type
C emac_dma_desc_type | Dma desciptors data structure definition
C emac_dma_type | Type define emac ptp register all
C emac_mmc_type | Type define emac mmc register all
C emac_ptp_type | Type define emac ptp register all
C emac_type | Type define emac mac register all
C ertc_alarm_value_type | Ertc alarm
C ertc_reg_alarm_type | Ertc alarm reg union
C ertc_reg_date_type | Ertc date reg union
C ertc_reg_scal_type | Ertc scal reg union
C ertc_reg_tadj_type | Ertc tadj reg union
C ertc_reg_time_type | Ertc time reg union
C ertc_reg_tsdt_type | Ertc tsdt register, offset:0x34
C ertc_reg_tstm_type | Ertc tstm reg union
C ertc_time_type | Ertc time
C ertc_type | Type define ertc register all
C exint_init_type | Exint init type
C exint_type | Type define exint register all
C fat_dir_type |
C flash_iap_type |
C flash_type | Type define flash register all
C FlashDevice |
C FlashEraseData |
C FlashParamsHolder |
C FlashSectors |
C fs_file |
C fsdata_file |
C fsdata_file_noconst |
C gpio_init_type | Gpio init type
C gpio_type | Type define gpio register all
C http_state |
C i2c_handle_type |
C i2c_type | Type define i2c register all
C i2s_init_type | I2s init type
C iap_info_type |
C keyboard_type |
C lcd_dev_type |
C linecoding_type | Usb cdc class set line coding struct
C ll_descriptors_type |
C mouse_type |
C msc_bot_cbw_type | Usb msc bulk-only command block wrapper type
C msc_bot_csw_type | Usb msc bulk-only command status wrapper type
C msc_bot_trans_type | Usb msc bulk-only transfer control type
C msc_scsi_data_capacity | Usb msc capacity data type
C msc_scsi_data_inquiry | Usb msc inquiry data type
C msc_type |
C name |
C nand_address_type |
C nand_id_type |
C nor_idtype |
C otg_core_type | Usb otg core struct type
C otg_device_type |
C otg_eptin_type |
C otg_eptout_type |
C otg_global_type |
C otg_hchannel_type |
C otg_host_type |
C otg_pcgcctl_type |
C printer_type |
C pwc_type | Type define pwc register all
C qspi_cmd_type | Qspi cmd type
C qspi_type | Type define qspi register all
C qspi_xip_type | Qspi xip type
C sc_atr_type |
C scfg_type | Type define system config register all
C sd_card_info_struct_type |
C sd_cid_struct_type |
C sd_csd_struct_type |
C sd_scr_struct_type |
C sdio_command_struct_type | Sdio command structure
C sdio_data_struct_type | Sdio data structure
C sdio_type | Type define sdio register all
C sense_type | Request sense standard data
C spi_init_type | Spi init type
C spi_type | Type define spi register all
C tftp_connection_args |
C tmr_brkdt_config_type | Tmr brkdt config type
C tmr_input_config_type | Tmr input capture config type
C tmr_output_config_type | Tmr output config type
C tmr_type | Type define tmr register all
C touch_dev_type |
C usart_group_type | Usart group type
C usart_type | Type define usart register all
C usb_audio_hid_type | Usb audio control struct
C usb_audio_type | Usb audio control struct
C usb_configuration_desc_type | Format of standard configuration descriptor
C usb_core_cfg | Usb core cofig struct
C usb_device_desc_type | Format of standard device descriptor
C usb_endpoint_desc_type | Format of standard endpoint descriptor
C usb_ept_info | Usb endpoint infomation structure definition
C usb_hch_type | Usb host channel infomation structure definition
C usb_header_desc_type | Format of header
C usb_hid_desc_type | Usb hid descriptor type
C usb_hid_mouse_type | Usb hid mouse type
C usb_interface_desc_type | Format of standard interface descriptor
C usb_setup_type | Format of usb setup data
C usbh_hid_type | Usb hid struct
C usbh_msc_type | Usb msc struct
C usbh_msc_unit_type | Usb msc bank type
C usd_type | User system data
C vcp_keyboard_type |
C wdt_type | Type define wdt register all
C wwdt_type | Type define wwdt register all
C xmc_bank1_ctrl_tmg_reg_type |
C xmc_bank1_tmgwr_reg_type |
C xmc_bank1_type | Xmc bank1 registers
C xmc_bank2_type | Xmc bank2 registers
C xmc_bank3_type | Xmc bank3 registers
C xmc_bank4_type | Xmc bank4 registers
C xmc_nand_init_type | Xmc nand init structure definition
C xmc_nand_pccard_timinginit_type | Nand and pccard timing parameters xmc
C xmc_norsram_init_type | Xmc nor/sram init structure definition
C xmc_norsram_timing_init_type | Nor/sram banks timing parameters
C xmc_pccard_init_type | Xmc pccard init structure definition
C xmc_sdram_cmd_type | Xmc sdram command structure definition
C xmc_sdram_init_type | Xmc sdram init structure definition
C xmc_sdram_timing_type | Xmc sdram timing structure definition
C xmc_sdram_type | Xmc sdram type


AT32F435/437 Firmwary Library: FlashDevice Struct Reference

Data Fields
FlashDevice Struct Reference

#include <FlashOS.h>

Data Fields

unsigned short | Vers
char | DevName [128]
unsigned short | DevType
unsigned long | DevAdr
unsigned long | szDev
unsigned long | szPage
unsigned long | Res
unsigned char | valEmpty
unsigned long | toProg
unsigned long | toErase
struct FlashSectors | sectors [512]

Detailed Description

Definition at line 30 of file FlashOS.h.

Field Documentation

◆ DevAdr

unsigned long FlashDevice::DevAdr

Definition at line 34 of file FlashOS.h.

◆ DevName

char FlashDevice::DevName[128]

Definition at line 32 of file FlashOS.h.

◆ DevType

unsigned short FlashDevice::DevType

Definition at line 33 of file FlashOS.h.

◆ Res

unsigned long FlashDevice::Res

Definition at line 37 of file FlashOS.h.

◆ sectors

struct FlashSectors FlashDevice::sectors[512]

Definition at line 43 of file FlashOS.h.

◆ szDev

unsigned long FlashDevice::szDev

Definition at line 35 of file FlashOS.h.

◆ szPage

unsigned long FlashDevice::szPage

Definition at line 36 of file FlashOS.h.

◆ toErase

unsigned long FlashDevice::toErase

Definition at line 41 of file FlashOS.h.

◆ toProg

unsigned long FlashDevice::toProg

Definition at line 40 of file FlashOS.h.

◆ valEmpty

unsigned char FlashDevice::valEmpty

Definition at line 38 of file FlashOS.h.

◆ Vers

unsigned short FlashDevice::Vers

Definition at line 31 of file FlashOS.h.

The documentation for this struct was generated from the following file:
  • FlashOS.h


AT32F435/437 Firmwary Library: FlashEraseData Struct Reference

Data Fields
FlashEraseData Struct Reference

#include <flash_loader_extra.h>

Data Fields

uint32_t | start
uint32_t | length

Detailed Description

Definition at line 20 of file flash_loader_extra.h.

Field Documentation

◆ length

uint32_t FlashEraseData::length

Definition at line 22 of file flash_loader_extra.h.

Referenced by Fl2FlashEraseWriteEntry().

◆ start

uint32_t FlashEraseData::start

Definition at line 21 of file flash_loader_extra.h.

Referenced by Fl2FlashEraseWriteEntry().

The documentation for this struct was generated from the following file:
  • flash_loader_extra.h


AT32F435/437 Firmwary Library: FlashParamsHolder Struct Reference

Data Fields
FlashParamsHolder Struct Reference

#include <flash_loader_extra.h>

Data Fields

uint32_t | base_ptr
uint32_t | count
uint32_t | offset_into_block
void * | buffer
uint32_t | block_size

Detailed Description

Definition at line 12 of file flash_loader_extra.h.

Field Documentation

◆ base_ptr

uint32_t FlashParamsHolder::base_ptr

Definition at line 13 of file flash_loader_extra.h.

Referenced by Fl2FlashChecksumEntry(), Fl2FlashEraseWriteEntry(), Fl2FlashInitEntry(), and Fl2FlashWriteEntry().

◆ block_size

uint32_t FlashParamsHolder::block_size

Definition at line 17 of file flash_loader_extra.h.

Referenced by Fl2FlashEraseWriteEntry(), and Fl2FlashInitEntry().

◆ buffer

void* FlashParamsHolder::buffer

Definition at line 16 of file flash_loader_extra.h.

Referenced by Fl2FlashEraseWriteEntry(), and Fl2FlashWriteEntry().

◆ count

uint32_t FlashParamsHolder::count

Definition at line 14 of file flash_loader_extra.h.

Referenced by Fl2FlashChecksumEntry(), Fl2FlashEraseWriteEntry(), Fl2FlashInitEntry(), Fl2FlashSignoffEntry(), and Fl2FlashWriteEntry().

◆ offset_into_block

uint32_t FlashParamsHolder::offset_into_block

Definition at line 15 of file flash_loader_extra.h.

Referenced by Fl2FlashEraseWriteEntry(), Fl2FlashInitEntry(), and Fl2FlashWriteEntry().

The documentation for this struct was generated from the following file:
  • flash_loader_extra.h


AT32F435/437 Firmwary Library: FlashSectors Struct Reference

Data Fields
FlashSectors Struct Reference

#include <FlashOS.h>

Data Fields

unsigned long | szSector
unsigned long | AddrSector

Detailed Description

Definition at line 23 of file FlashOS.h.

Field Documentation

◆ AddrSector

unsigned long FlashSectors::AddrSector

Definition at line 25 of file FlashOS.h.

◆ szSector

unsigned long FlashSectors::szSector

Definition at line 24 of file FlashOS.h.

The documentation for this struct was generated from the following file:
  • FlashOS.h


AT32F435/437 Firmwary Library: fs_file Struct Reference

Data Fields
fs_file Struct Reference

#include <httpserver.h>

Data Fields

char * | data
int | len

Detailed Description

Definition at line 41 of file httpserver.h.

Field Documentation

◆ data

char* fs_file::data

Definition at line 42 of file httpserver.h.

◆ len

int fs_file::len

Definition at line 43 of file httpserver.h.

Referenced by http_state_eof().

The documentation for this struct was generated from the following file:
  • httpserver.h


AT32F435/437 Firmwary Library: fsdata_file Struct Reference

Data Fields
fsdata_file Struct Reference

#include <fsdata.h>

Data Fields

const struct fsdata_file * | next
const char * | name
const char * | data
const int | len

Detailed Description

Definition at line 37 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h.

Field Documentation

◆ data

const char* fsdata_file::data

Definition at line 40 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h.

Referenced by fs_open().

◆ len

const int fsdata_file::len

Definition at line 41 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h.

Referenced by fs_open().

◆ name

const char* fsdata_file::name

Definition at line 39 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h.

Referenced by fs_open().

◆ next

const struct fsdata_file* fsdata_file::next

Definition at line 38 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h.

Referenced by fs_open().

The documentation for this struct was generated from the following file:
  • utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h


AT32F435/437 Firmwary Library: fsdata_file_noconst Struct Reference

Data Fields
fsdata_file_noconst Struct Reference

#include <fsdata.h>

Data Fields

struct fsdata_file * | next
char * | name
char * | data
int | len

Detailed Description

Definition at line 44 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h.

Field Documentation

◆ data

char* fsdata_file_noconst::data

Definition at line 47 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h.

◆ len

int fsdata_file_noconst::len

Definition at line 48 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h.

◆ name

char* fsdata_file_noconst::name

Definition at line 46 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h.

◆ next

struct fsdata_file* fsdata_file_noconst::next

Definition at line 45 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h.

The documentation for this struct was generated from the following file:
  • utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h


AT32F435/437 Firmwary Library: nor_idtype Struct Reference

Data Fields
nor_idtype Struct Reference

#include <xmc_nor.h>

Data Fields

uint16_t | manufacturer_code
uint16_t | device_code1
uint16_t | device_code2
uint16_t | device_code3

Detailed Description

Definition at line 32 of file at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h.

Field Documentation

◆ device_code1

uint16_t nor_idtype::device_code1

Definition at line 35 of file at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h.

Referenced by nor_readid().

◆ device_code2

uint16_t nor_idtype::device_code2

Definition at line 36 of file at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h.

Referenced by nor_readid().

◆ device_code3

uint16_t nor_idtype::device_code3

Definition at line 37 of file at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h.

Referenced by nor_readid().

◆ manufacturer_code

uint16_t nor_idtype::manufacturer_code

Definition at line 34 of file at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h.

Referenced by nor_readid().

The documentation for this struct was generated from the following files:
  • at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h
  • at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h


AT32F435/437 Firmwary Library: tftp_connection_args Struct Reference

Data Fields
tftp_connection_args Struct Reference

#include <tftpserver.h>

Data Fields

int | op
char | data [((2+2)+512)]
int | data_len
ip_addr_t | to_ip
int | to_port
int | block
int | tot_bytes
unsigned long long | last_time

Detailed Description

Definition at line 21 of file tftpserver.h.

Field Documentation

◆ block

int tftp_connection_args::block

Definition at line 31 of file tftpserver.h.

◆ data

char tftp_connection_args::data[((2+ 2)+ 512)]

Definition at line 25 of file tftpserver.h.

◆ data_len

int tftp_connection_args::data_len

Definition at line 26 of file tftpserver.h.

◆ last_time

unsigned long long tftp_connection_args::last_time

Definition at line 36 of file tftpserver.h.

◆ op

int tftp_connection_args::op

Definition at line 23 of file tftpserver.h.

◆ to_ip

ip_addr_t tftp_connection_args::to_ip

Definition at line 28 of file tftpserver.h.

◆ to_port

int tftp_connection_args::to_port

Definition at line 29 of file tftpserver.h.

◆ tot_bytes

int tftp_connection_args::tot_bytes

Definition at line 33 of file tftpserver.h.

The documentation for this struct was generated from the following file:
  • tftpserver.h


AT32F435/437 Firmwary Library: Data Structure Index

Data Structure Index
A | C | D | E | F | G | H | I | K | L | M | N | O | P | Q | S | T | U | V | W | X
A
acc_type
adc_base_config_type
adc_common_config_type
adc_type
adccom_type
audio_codec_type
C
can_base_type
can_baudrate_type
can_fifo_mailbox_type
can_filter_init_type
can_filter_register_type
can_rx_message_type
can_tx_mailbox_type
can_tx_message_type
can_type
cbd_extended_type
cbd_typical_type
cbw_type
cdc_msc_struct_type
cdc_struct_type
cmd_data_group_type
crc_type
crm_clocks_freq_type
crm_type
csw_type
custom_hid_type
D
dac_type
debug_type
default_filename
Descriptors_Format_def
dma_channel_type
dma_init_type
dma_type
dmamux_channel_type
dmamux_gen_init_type
dmamux_generator_type
dmamux_sync_init_type
dvp_type
E
edma_init_type
edma_stream_2d_type
edma_stream_link_list_type
edma_stream_type
edma_type
edmamux_channel_type
edmamux_gen_init_type
edmamux_generator_type
edmamux_sync_init_type
emac_control_config_type
emac_dma_config_type
emac_dma_desc_type
emac_dma_type
emac_mmc_type
emac_ptp_type
emac_type
ertc_alarm_value_type
ertc_reg_alarm_type
ertc_reg_date_type
ertc_reg_scal_type
ertc_reg_tadj_type
ertc_reg_time_type
ertc_reg_tsdt_type
ertc_reg_tstm_type
ertc_time_type
ertc_type
exint_init_type
exint_type
F
fat_dir_type
flash_iap_type
flash_type
FlashDevice
FlashEraseData
FlashParamsHolder
FlashSectors
fs_file
fsdata_file
fsdata_file_noconst
G
gpio_init_type
gpio_type
H
http_state
I
i2c_handle_type
i2c_type
i2s_init_type
iap_info_type
K
keyboard_type
L
lcd_dev_type
linecoding_type
ll_descriptors_type
M
mouse_type
msc_bot_cbw_type
msc_bot_csw_type
msc_bot_trans_type
msc_scsi_data_capacity
msc_scsi_data_inquiry
msc_type
N
name
nand_address_type
nand_id_type
nor_idtype
O
otg_core_type
otg_device_type
otg_eptin_type
otg_eptout_type
otg_global_type
otg_hchannel_type
otg_host_type
otg_pcgcctl_type
P
printer_type
pwc_type
Q
qspi_cmd_type
qspi_type
qspi_xip_type
S
sc_atr_type
scfg_type
sd_card_info_struct_type
sd_cid_struct_type
sd_csd_struct_type
sd_scr_struct_type
sdio_command_struct_type
sdio_data_struct_type
sdio_type
sense_type
spi_init_type
spi_type
T
tftp_connection_args
tmr_brkdt_config_type
tmr_input_config_type
tmr_output_config_type
tmr_type
touch_dev_type
U
usart_group_type
usart_type
usb_audio_hid_type
usb_audio_type
usb_configuration_desc_type
usb_core_cfg
usb_device_desc_type
usb_endpoint_desc_type
usb_ept_info
usb_hch_type
usb_header_desc_type
usb_hid_desc_type
usb_hid_mouse_type
usb_interface_desc_type
usb_setup_type
usbh_hid_type
usbh_msc_type
usbh_msc_unit_type
usd_type
V
vcp_keyboard_type
W
wdt_type
wwdt_type
X
xmc_bank1_ctrl_tmg_reg_type
xmc_bank1_tmgwr_reg_type
xmc_bank1_type
xmc_bank2_type
xmc_bank3_type
xmc_bank4_type
xmc_nand_init_type
xmc_nand_pccard_timinginit_type
xmc_norsram_init_type
xmc_norsram_timing_init_type
xmc_pccard_init_type
xmc_sdram_cmd_type
xmc_sdram_init_type
xmc_sdram_timing_type
xmc_sdram_type


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- a -

  • a0h : emac_type
  • a0h_bit : emac_type
  • a0l : emac_type
  • a0l_bit : emac_type
  • a1h : emac_type
  • a1h_bit : emac_type
  • a1l : emac_type
  • a1l_bit : emac_type
  • a2h : emac_type
  • a2h_bit : emac_type
  • a2l : emac_type
  • a2l_bit : emac_type
  • a3h : emac_type
  • a3h_bit : emac_type
  • a3l : emac_type
  • a3l_bit : emac_type
  • aab : emac_dma_type
  • aab_enable : emac_dma_config_type
  • abort : qspi_type
  • accen : crm_type
  • acclpen : crm_type
  • accrst : crm_type
  • ack : otg_hchannel_type
  • ackfail : i2c_type
  • ackfailc : i2c_type
  • ackfailien : i2c_type
  • ackmsk : otg_hchannel_type
  • acs : emac_type, spi_type
  • actr : qspi_type
  • actr_bit : qspi_type
  • actrl : dvp_type
  • actrl_bit : dvp_type
  • adabrt : adc_type
  • adc14en : crm_type
  • adc14lpen : crm_type
  • adc14rst : crm_type
  • adcal : adc_type
  • adcalinit : adc_type
  • adcdiv : adccom_type
  • adcen : adc_type, crm_type
  • adclpen : crm_type
  • adcrst : crm_type
  • add : ertc_reg_scal_type, ertc_type
  • add1h : ertc_type
  • add1s : ertc_reg_tadj_type, ertc_type
  • addr : flash_type, i2c_type, tmr_type
  • addr1 : i2c_type
  • addr10 : i2c_type
  • addr1en : i2c_type
  • addr1mode : i2c_type
  • addr2 : flash_type, i2c_type
  • addr2_bit : flash_type
  • addr2en : i2c_type
  • addr2mask : i2c_type
  • addr_bit : flash_type
  • addr_hold_time : xmc_norsram_timing_init_type
  • addr_setup_time : xmc_norsram_timing_init_type
  • addrc : i2c_type
  • address : cbd_extended_type, cbd_typical_type, usb_hch_type
  • address_code : qspi_cmd_type
  • address_length : qspi_cmd_type
  • addrf : i2c_type
  • addrht : xmc_bank1_ctrl_tmg_reg_type, xmc_bank1_tmgwr_reg_type
  • addrien : i2c_type
  • AddrSector : FlashSectors
  • addrst : xmc_bank1_ctrl_tmg_reg_type, xmc_bank1_tmgwr_reg_type
  • admuxen : xmc_bank1_ctrl_tmg_reg_type
  • adrlen : qspi_type
  • ae : emac_type
  • aebo_enable : can_base_type
  • aeboen : can_type
  • aed_enable : can_base_type
  • aeden : can_type
  • ahb_freq : crm_clocks_freq_type
  • ahbdiv : crm_type
  • ahben1 : crm_type
  • ahben1_bit : crm_type
  • ahben2 : crm_type
  • ahben2_bit : crm_type
  • ahben3 : crm_type
  • ahben3_bit : crm_type
  • ahbidle : otg_global_type
  • ahblpen1 : crm_type
  • ahblpen1_bit : crm_type
  • ahblpen2 : crm_type
  • ahblpen2_bit : crm_type
  • ahblpen3 : crm_type
  • ahblpen3_bit : crm_type
  • ahbrst1 : crm_type
  • ahbrst1_bit : crm_type
  • ahbrst2 : crm_type
  • ahbrst2_bit : crm_type
  • ahbrst3 : crm_type
  • ahbrst3_bit : crm_type
  • aie : emac_dma_type
  • ais : emac_dma_type
  • ala : ertc_reg_alarm_type, ertc_type
  • ala_bit : ertc_reg_alarm_type, ertc_type
  • alaen : ertc_type
  • alaf : ertc_type
  • alaien : ertc_type
  • alasbs : ertc_type
  • alasbs_bit : ertc_type
  • alawf : ertc_type
  • alb : ertc_type
  • alb_bit : ertc_type
  • alben : ertc_type
  • albf : ertc_type
  • albien : ertc_type
  • albsbs : ertc_type
  • albsbs_bit : ertc_type
  • albwf : ertc_type
  • alertc : i2c_type
  • alertf : i2c_type
  • alloc_length : cbd_extended_type, cbd_typical_type
  • alt_setting : cdc_msc_struct_type, cdc_struct_type, custom_hid_type, iap_info_type, keyboard_type, mouse_type, msc_type, printer_type, usb_audio_hid_type, vcp_keyboard_type
  • amdhizt : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • amht : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • ampm : ertc_alarm_value_type, ertc_reg_alarm_type, ertc_reg_time_type, ertc_reg_tstm_type, ertc_time_type, ertc_type
  • amst : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • amwt : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • aoen : tmr_type
  • apb1_freq : crm_clocks_freq_type
  • apb1_frz : debug_type
  • apb1_frz_bit : debug_type
  • apb1div : crm_type
  • apb1en : crm_type
  • apb1en_bit : crm_type
  • apb1lpen : crm_type
  • apb1lpen_bit : crm_type
  • apb1rst : crm_type
  • apb1rst_bit : crm_type
  • apb2_freq : crm_clocks_freq_type
  • apb2_frz : debug_type
  • apb2_frz_bit : debug_type
  • apb2div : crm_type
  • apb2en : crm_type
  • apb2en_bit : crm_type
  • apb2lpen : crm_type
  • apb2lpen_bit : crm_type
  • apb2rst : crm_type
  • apb2rst_bit : crm_type
  • app_address : iap_info_type
  • argu : sdio_type
  • argu_bit : sdio_type
  • argument : sdio_command_struct_type
  • arlost : i2c_type
  • arlostc : i2c_type
  • art : xmc_sdram_type
  • aru : emac_ptp_type
  • as_length : sense_type
  • asc : sense_type
  • ascq : sense_type
  • asisel : adccom_type
  • ast : emac_ptp_type
  • astopen : i2c_type
  • asyncm : xmc_bank1_ctrl_tmg_reg_type, xmc_bank1_tmgwr_reg_type
  • asynwait_enable : xmc_norsram_init_type
  • attr : fat_dir_type
  • audio_bitw : audio_codec_type
  • audio_cmd : usb_audio_hid_type, usb_audio_type
  • audio_cmd_len : usb_audio_hid_type, usb_audio_type
  • audio_feed_back : usb_audio_hid_type, usb_audio_type
  • audio_feedback_state : usb_audio_hid_type, usb_audio_type
  • audio_freq : audio_codec_type
  • audio_mic_data : usb_audio_hid_type, usb_audio_type
  • audio_protocol : i2s_init_type
  • audio_sampling_freq : i2s_init_type
  • audio_spk_data : usb_audio_hid_type, usb_audio_type
  • audio_spk_out_stage : usb_audio_hid_type, usb_audio_type
  • auto_nego : emac_control_config_type
  • auto_output_enable : tmr_brkdt_config_type
  • auto_pad_crc_strip : emac_control_config_type
  • auto_refresh : xmc_sdram_cmd_type
  • auto_step_en : crm_type


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- b -

  • b2bsetupmsk : otg_device_type
  • b2pstup : otg_eptout_type
  • back_off_limit : emac_control_config_type
  • bAlternateSetting : usb_interface_desc_type
  • bankers : flash_type
  • base_ptr : FlashParamsHolder
  • baudr : usart_type
  • baudr_bit : usart_type
  • baudrate_div : can_baudrate_type
  • bblerr : otg_hchannel_type
  • bblerrmsk : otg_hchannel_type
  • bCBWCBLength : cbw_type, msc_bot_cbw_type
  • bCBWLUN : cbw_type, msc_bot_cbw_type
  • bcdDevice : usb_device_desc_type
  • bcdHID : usb_hid_desc_type
  • bcdUSB : usb_device_desc_type
  • bcnt : otg_global_type
  • bConfigurationValue : usb_configuration_desc_type
  • bCountryCode : usb_hid_desc_type
  • bCSWStatus : csw_type, msc_bot_csw_type
  • bDescriptorType : usb_configuration_desc_type, usb_device_desc_type, usb_endpoint_desc_type, usb_header_desc_type, usb_hid_desc_type, usb_interface_desc_type
  • bDeviceClass : usb_device_desc_type
  • bDeviceProtocol : usb_device_desc_type
  • bDeviceSubClass : usb_device_desc_type
  • bEndpointAddress : usb_endpoint_desc_type
  • bf : spi_type
  • bfbn : usart_type
  • bff : usart_type
  • bfien : usart_type
  • bfrc : dvp_type
  • bInterfaceClass : usb_interface_desc_type
  • bInterfaceNumber : usb_interface_desc_type
  • bInterfaceProtocol : usb_interface_desc_type
  • bInterfaceSubClass : usb_interface_desc_type
  • bInterval : usb_endpoint_desc_type
  • bitrate : linecoding_type
  • bk1 : xmc_sdram_type
  • bk1ctrl : xmc_bank1_ctrl_tmg_reg_type
  • bk1ctrl_bit : xmc_bank1_ctrl_tmg_reg_type
  • bk1sts : xmc_sdram_type
  • bk1tmg : xmc_bank1_ctrl_tmg_reg_type
  • bk1tmg_bit : xmc_bank1_ctrl_tmg_reg_type
  • bk1tmgwr : xmc_bank1_tmgwr_reg_type
  • bk1tmgwr_bit : xmc_bank1_tmgwr_reg_type
  • bk2 : xmc_sdram_type
  • bk2ctrl : xmc_bank2_type
  • bk2ctrl_bit : xmc_bank2_type
  • bk2ecc : xmc_bank2_type
  • bk2ecc_bit : xmc_bank2_type
  • bk2is : xmc_bank2_type
  • bk2is_bit : xmc_bank2_type
  • bk2sts : xmc_sdram_type
  • bk2tmgatt : xmc_bank2_type
  • bk2tmgatt_bit : xmc_bank2_type
  • bk2tmgmem : xmc_bank2_type
  • bk2tmgmem_bit : xmc_bank2_type
  • bk3ctrl : xmc_bank3_type
  • bk3ctrl_bit : xmc_bank3_type
  • bk3ecc : xmc_bank3_type
  • bk3ecc_bit : xmc_bank3_type
  • bk3is : xmc_bank3_type
  • bk3is_bit : xmc_bank3_type
  • bk3tmgatt : xmc_bank3_type
  • bk3tmgatt_bit : xmc_bank3_type
  • bk3tmgmem : xmc_bank3_type
  • bk3tmgmem_bit : xmc_bank3_type
  • bk4ctrl : xmc_bank4_type
  • bk4ctrl_bit : xmc_bank4_type
  • bk4is : xmc_bank4_type
  • bk4is_bit : xmc_bank4_type
  • bk4tmgatt : xmc_bank4_type
  • bk4tmgatt_bit : xmc_bank4_type
  • bk4tmgio : xmc_bank4_type
  • bk4tmgio_bit : xmc_bank4_type
  • bk4tmgmem : xmc_bank4_type
  • bk4tmgmem_bit : xmc_bank4_type
  • bl : emac_type
  • bLength : usb_configuration_desc_type, usb_device_desc_type, usb_endpoint_desc_type, usb_header_desc_type, usb_hid_desc_type, usb_interface_desc_type
  • blk_addr : cdc_msc_struct_type, msc_type
  • blk_len : cdc_msc_struct_type, msc_type
  • blk_nbr : cdc_msc_struct_type, msc_scsi_data_capacity, msc_type
  • blk_size : cdc_msc_struct_type, msc_scsi_data_capacity, msc_type
  • blkers : flash_type
  • blksize : sdio_type
  • block : nand_address_type, tftp_connection_args
  • block_size : FlashParamsHolder, sdio_data_struct_type
  • bm : emac_dma_type
  • bm_bit : emac_dma_type
  • bmAttributes : usb_configuration_desc_type, usb_endpoint_desc_type
  • bMaxPacketSize0 : usb_device_desc_type
  • bMaxPower : usb_configuration_desc_type
  • bmCBWFlags : cbw_type, msc_bot_cbw_type
  • bmRequestType : usb_setup_type
  • bnainmsk : otg_device_type
  • bnaoutmsk : otg_device_type
  • bNumConfigurations : usb_device_desc_type
  • bNumDescriptors : usb_hid_desc_type
  • bNumEndpoints : usb_interface_desc_type
  • bNumInterfaces : usb_configuration_desc_type
  • bof : can_type
  • boien : can_type
  • bot_state : msc_bot_trans_type
  • bot_status : cdc_msc_struct_type, msc_type
  • bot_trans : usbh_msc_type
  • bpdc : crm_type
  • bpdc_bit : crm_type
  • bpdrst : crm_type
  • bpr : ertc_type
  • bpwen : pwc_type
  • brdiv : can_type
  • bReportDescriptorType : usb_hid_desc_type
  • bRequest : usb_setup_type
  • brk : tmr_type
  • brk_bit : tmr_type
  • brk_enable : tmr_brkdt_config_type
  • brk_polarity : tmr_brkdt_config_type
  • brken : tmr_type
  • brkie : tmr_type
  • brkif : tmr_type
  • brkswtr : tmr_type
  • brkv : tmr_type
  • bstr : xmc_sdram_type
  • bth : dvp_type
  • bth_bit : dvp_type
  • btmg : can_type
  • btmg_bit : can_type
  • btopt : flash_type
  • bts1 : can_type
  • bts1_size : can_baudrate_type
  • bts2 : can_type
  • bts2_size : can_baudrate_type
  • buf : sdio_type, usart_group_type
  • buf1addr : emac_dma_desc_type
  • buf2nextdescaddr : emac_dma_desc_type
  • buf_bit : sdio_type
  • bufcnt : sdio_type
  • bufcnt_bit : sdio_type
  • buffer : FlashParamsHolder, msc_bot_trans_type, usbh_hid_type, usbh_msc_type
  • buffer_size : dma_init_type, edma_init_type
  • burst_mode_enable : xmc_norsram_init_type
  • burst_read : xmc_sdram_init_type
  • bus_latency_time : xmc_norsram_timing_init_type
  • bus_type : xmc_nand_init_type, xmc_norsram_init_type
  • buserr : i2c_type
  • buserrc : i2c_type
  • buslat : xmc_bank1_ctrl_tmg_reg_type, xmc_bank1_tmgwr_reg_type
  • buslatr2r : xmc_bank1_type
  • buslatw2w : xmc_bank1_type
  • busws : sdio_type
  • busy : qspi_type, xmc_sdram_type
  • busyf : i2c_type
  • button : usb_hid_mouse_type
  • bypassc : qspi_type
  • bypsen : sdio_type
  • byte : nand_address_type
  • bytes : name


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- c -

  • c1 : acc_type
  • c1_bit : acc_type
  • c1c : tmr_type
  • c1cen : tmr_type
  • c1cios : tmr_type
  • c1cp : tmr_type
  • c1den : tmr_type
  • c1df : tmr_type
  • c1dt : tmr_type
  • c1dt_bit : tmr_type
  • c1en : tmr_type
  • c1idiv : tmr_type
  • c1ien : tmr_type
  • c1if : tmr_type
  • c1insel : tmr_type
  • c1ios : tmr_type
  • c1oben : tmr_type
  • c1octrl : tmr_type
  • c1oien : tmr_type
  • c1osen : tmr_type
  • c1p : tmr_type
  • c1rf : tmr_type
  • c1swtr : tmr_type
  • c2 : acc_type
  • c2_bit : acc_type
  • c2c : tmr_type
  • c2cen : tmr_type
  • c2cios : tmr_type
  • c2cp : tmr_type
  • c2den : tmr_type
  • c2df : tmr_type
  • c2dt : tmr_type
  • c2dt_bit : tmr_type
  • c2en : tmr_type
  • c2idiv : tmr_type
  • c2ien : tmr_type
  • c2if : tmr_type
  • c2ios : tmr_type
  • c2oben : tmr_type
  • c2octrl : tmr_type
  • c2oien : tmr_type
  • c2osen : tmr_type
  • c2p : tmr_type
  • c2rf : tmr_type
  • c2swtr : tmr_type
  • c3 : acc_type
  • c3_bit : acc_type
  • c3c : tmr_type
  • c3cen : tmr_type
  • c3cios : tmr_type
  • c3cp : tmr_type
  • c3den : tmr_type
  • c3df : tmr_type
  • c3dt : tmr_type
  • c3dt_bit : tmr_type
  • c3en : tmr_type
  • c3idiv : tmr_type
  • c3ien : tmr_type
  • c3if : tmr_type
  • c3ios : tmr_type
  • c3oben : tmr_type
  • c3octrl : tmr_type
  • c3oien : tmr_type
  • c3osen : tmr_type
  • c3p : tmr_type
  • c3rf : tmr_type
  • c3swtr : tmr_type
  • c4c : tmr_type
  • c4den : tmr_type
  • c4df : tmr_type
  • c4dt : tmr_type
  • c4dt_bit : tmr_type
  • c4en : tmr_type
  • c4idiv : tmr_type
  • c4ien : tmr_type
  • c4if : tmr_type
  • c4ios : tmr_type
  • c4oben : tmr_type
  • c4octrl : tmr_type
  • c4oien : tmr_type
  • c4osen : tmr_type
  • c4p : tmr_type
  • c4rf : tmr_type
  • c4swtr : tmr_type
  • c5dt : tmr_type
  • c5dt_bit : tmr_type
  • c5oben : tmr_type
  • c5octrl : tmr_type
  • c5oien : tmr_type
  • c5osen : tmr_type
  • ca : xmc_sdram_type
  • cal16 : ertc_reg_scal_type, ertc_type
  • cal8 : ertc_reg_scal_type, ertc_type
  • caldir : ertc_type
  • caloen : ertc_type
  • calon : acc_type
  • calosel : ertc_type
  • calrdy : acc_type
  • calrdyien : acc_type
  • calupdf : ertc_type
  • calval : adc_type, ertc_type
  • calval_bit : adc_type
  • can1_pause : debug_type
  • can1en : crm_type
  • can1lpen : crm_type
  • can1rst : crm_type
  • can2_pause : debug_type
  • can2en : crm_type
  • can2lpen : crm_type
  • can2rst : crm_type
  • cap : dvp_type
  • capacity : usbh_msc_unit_type
  • card_blk_size : sd_card_info_struct_type
  • card_capacity : sd_card_info_struct_type
  • card_cmd_classes : sd_csd_struct_type
  • card_type : sd_card_info_struct_type
  • cardsts1 : sdio_type
  • cardsts2 : sdio_type
  • cardsts3 : sdio_type
  • cardsts4 : sdio_type
  • carrier_sense_disable : emac_control_config_type
  • cas : xmc_sdram_init_type, xmc_sdram_type
  • cbctrl : tmr_type
  • cbw : msc_bot_trans_type
  • cbw_struct : cdc_msc_struct_type, msc_type
  • CBWCB : cbw_type, msc_bot_cbw_type
  • ccal : ertc_type
  • ccal_bit : ertc_type
  • ccalen : ertc_type
  • ccen : spi_type
  • ccerr : spi_type
  • ccfs : tmr_type
  • ccsmen : sdio_type
  • cctrl : adccom_type, tmr_type
  • cctrl_bit : adccom_type, tmr_type
  • cdt : crc_type
  • cdt_bit : crc_type
  • cfden : crm_type
  • cfdes : dvp_type
  • cfdf : crm_type
  • cfdfc : crm_type
  • cfdic : dvp_type
  • cfdie : dvp_type
  • cfdis : dvp_type
  • cfg : crm_type, otg_core_type, wwdt_type
  • cfg1 : scfg_type
  • cfg1_bit : scfg_type
  • cfg2 : scfg_type
  • cfg2_bit : scfg_type
  • cfg_bit : crm_type, wwdt_type
  • cfgr : gpio_type
  • cfgr_bit : gpio_type
  • cfm : dvp_type
  • cgnpinak : otg_device_type
  • cgoutnak : otg_device_type
  • ch_num : usb_hch_type
  • change : usbh_msc_unit_type
  • chdis : otg_hchannel_type
  • chen : dma_channel_type
  • chena : otg_hchannel_type
  • chhltd : otg_hchannel_type
  • chhltdmsk : otg_hchannel_type
  • chin : usbh_hid_type, usbh_msc_type
  • chnum : dvp_type, otg_global_type
  • chout : usbh_hid_type, usbh_msc_type
  • chpl : dma_channel_type
  • chstr : dvp_type
  • cid_crc : sd_cid_struct_type
  • cidsts : otg_global_type
  • ckp : dvp_type
  • class_bank : xmc_nand_pccard_timinginit_type
  • clk_psc : xmc_norsram_timing_init_type
  • clk_to_tmr : crm_type
  • clkctrl : i2c_type, sdio_type
  • clkctrl_bit : i2c_type, sdio_type
  • clkdiv : qspi_type, tmr_type, xmc_sdram_init_type, xmc_sdram_type
  • clkdiv_h : sdio_type
  • clkdiv_l : sdio_type
  • clkegs : sdio_type
  • clken : usart_type
  • clkint : crm_type
  • clkint_bit : crm_type
  • clkoen : sdio_type
  • clkout1_sel : crm_type
  • clkout1div1 : crm_type
  • clkout1div2 : crm_type
  • clkout2_sel1 : crm_type
  • clkout2_sel2 : crm_type
  • clkout2div1 : crm_type
  • clkout2div2 : crm_type
  • clkpha : spi_type, usart_type
  • clkpol : spi_type, usart_type
  • clkpsc : xmc_bank1_ctrl_tmg_reg_type
  • clock_phase : spi_init_type
  • clock_polarity : i2s_init_type, spi_init_type
  • clr : dma_type, gpio_type, i2c_type
  • clr1 : edma_type
  • clr1_bit : edma_type
  • clr2 : edma_type
  • clr2_bit : edma_type
  • clr_bit : dma_type, gpio_type, i2c_type
  • clsef : pwc_type
  • clswef : pwc_type
  • clus_high : fat_dir_type
  • clus_low : fat_dir_type
  • cm : edma_stream_type
  • cm1 : tmr_type
  • cm1_input_bit : tmr_type
  • cm1_output_bit : tmr_type
  • cm2 : tmr_type
  • cm2_input_bit : tmr_type
  • cm2_output_bit : tmr_type
  • cm3 : tmr_type
  • cm3_output_bit : tmr_type
  • cmd : ertc_type, wdt_type, xmc_sdram_cmd_type, xmc_sdram_type
  • cmd20_support : sd_scr_struct_type
  • cmd23_support : sd_scr_struct_type
  • cmd_addr : cmd_data_group_type
  • cmd_banks : xmc_sdram_cmd_type
  • cmd_bit : wdt_type, xmc_sdram_type
  • cmd_buf : cmd_data_group_type
  • cmd_check : cmd_data_group_type
  • cmd_head : cmd_data_group_type
  • cmd_index : sdio_command_struct_type
  • cmd_state : msc_bot_trans_type
  • cmd_w0 : qspi_type
  • cmd_w0_bit : qspi_type
  • cmd_w1 : qspi_type
  • cmd_w1_bit : qspi_type
  • cmd_w2 : qspi_type
  • cmd_w2_bit : qspi_type
  • cmd_w3 : qspi_type
  • cmd_w3_bit : qspi_type
  • cmdcmpl : sdio_type
  • cmdcmplien : sdio_type
  • cmdctrl : sdio_type
  • cmdctrl_bit : sdio_type
  • cmdfail : sdio_type
  • cmdfailien : sdio_type
  • cmdhizt : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • cmdidx : sdio_type
  • cmdie : qspi_type
  • cmdrspcmpl : sdio_type
  • cmdrspcmplien : sdio_type
  • cmdsts : qspi_type
  • cmdsts_bit : qspi_type
  • cmdtimeout : sdio_type
  • cmdtimeoutien : sdio_type
  • cmht : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • cmst : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • cmwt : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • cnak : otg_eptin_type, otg_eptout_type
  • cnt : dma_channel_type, edma_stream_type, i2c_type, sdio_type, wwdt_type
  • cnt_dir : tmr_type
  • codt : adccom_type
  • codt_bit : adccom_type
  • codth : adccom_type
  • codtl : adccom_type
  • column_address : xmc_sdram_init_type
  • combine_mode : adc_common_config_type
  • common_dma_mode : adc_common_config_type
  • common_dma_request_repeat_state : adc_common_config_type
  • compsplt : otg_hchannel_type
  • conidschg : otg_global_type
  • conidschgmsk : otg_global_type
  • content_protect_app : sd_csd_struct_type
  • contr : flash_type
  • contr_bit : flash_type
  • controlsize : emac_dma_desc_type
  • copy_flag : sd_csd_struct_type
  • core_id : usb_core_cfg
  • cotxpkt : otg_global_type
  • count : FlashParamsHolder, usart_group_type
  • cpoly : spi_type
  • cpoly_bit : spi_type
  • cr : emac_type
  • CR_NDT : Descriptors_Format_def
  • crbaddr : emac_dma_type
  • crbaddr_bit : emac_dma_type
  • crc_chkr : flash_type
  • crc_chkr_bit : flash_type
  • crc_ctrl : flash_type
  • crc_ctrl_bit : flash_type
  • crc_sn : flash_type
  • crc_ss : flash_type
  • crc_strt : flash_type
  • crcen : crm_type
  • crclpen : crm_type
  • crcrst : crm_type
  • crd : emac_dma_type
  • crd_bit : emac_dma_type
  • create_data : fat_dir_type
  • create_time : fat_dir_type
  • create_time_tenth : fat_dir_type
  • crp : dvp_type
  • crpgs : xmc_bank1_ctrl_tmg_reg_type
  • crsel : adc_type
  • cs_mode_selection : spi_init_type
  • csd_crc : sd_csd_struct_type
  • csd_struct : sd_csd_struct_type
  • csdly : qspi_type
  • csftrst : otg_global_type
  • cspas : spi_type
  • cspt0 : adc_type
  • cspt1 : adc_type
  • cspt10 : adc_type
  • cspt11 : adc_type
  • cspt12 : adc_type
  • cspt13 : adc_type
  • cspt14 : adc_type
  • cspt15 : adc_type
  • cspt16 : adc_type
  • cspt17 : adc_type
  • cspt18 : adc_type
  • cspt2 : adc_type
  • cspt3 : adc_type
  • cspt4 : adc_type
  • cspt5 : adc_type
  • cspt6 : adc_type
  • cspt7 : adc_type
  • cspt8 : adc_type
  • cspt9 : adc_type
  • csts : adccom_type, qspi_type
  • csts_bit : adccom_type
  • csw : msc_bot_trans_type
  • csw_struct : cdc_msc_struct_type, msc_type
  • ctbaddr : emac_dma_type
  • ctbaddr_bit : emac_dma_type
  • ctd : emac_dma_type
  • ctd_bit : emac_dma_type
  • ctrl : crc_type, crm_type, dac_type, debug_type, dma_channel_type, dvp_type, edma_stream_type, emac_mmc_type, emac_type, ertc_type, flash_type, pwc_type, qspi_type, wwdt_type, xmc_sdram_type
  • ctrl1 : acc_type, adc_type, i2c_type, spi_type, tmr_type, usart_type
  • ctrl1_bit : acc_type, adc_type, i2c_type, spi_type, tmr_type, usart_type
  • ctrl2 : acc_type, adc_type, flash_type, i2c_type, qspi_type, spi_type, tmr_type, usart_type
  • ctrl2_bit : acc_type, adc_type, flash_type, i2c_type, qspi_type, spi_type, tmr_type, usart_type
  • ctrl3 : usart_type
  • ctrl3_bit : usart_type
  • ctrl_bit : crc_type, crm_type, dac_type, debug_type, dma_channel_type, dvp_type, edma_stream_type, emac_mmc_type, emac_type, ertc_type, flash_type, pwc_type, qspi_type, wwdt_type, xmc_sdram_type
  • ctrl_dtcnt : ll_descriptors_type
  • ctrl_state : usbh_hid_type, usbh_msc_type
  • ctrl_tmg_group : xmc_bank1_type
  • ctrlsts : crm_type, pwc_type
  • ctrlsts_bit : crm_type, pwc_type
  • ctscf : usart_type
  • ctscfien : usart_type
  • ctsen : usart_type
  • cur_lun : usbh_msc_type
  • curmod : otg_global_type
  • curmode : otg_global_type
  • curs : can_type
  • cuss : can_type
  • cval : tmr_type
  • cval_bit : tmr_type
  • cvnum : dvp_type
  • cvstr : dvp_type
  • cwst : dvp_type
  • cwst_bit : dvp_type
  • cwsz : dvp_type
  • cwsz_bit : dvp_type


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- d -

  • d : ertc_reg_alarm_type, ertc_reg_date_type, ertc_reg_tsdt_type, ertc_type
  • d1dmaen : dac_type
  • d1dmaudrf : dac_type
  • d1dmaudrien : dac_type
  • d1dt12l : dac_type
  • d1dt12r : dac_type
  • d1dt8r : dac_type
  • d1dth12l : dac_type
  • d1dth12l_bit : dac_type
  • d1dth12r : dac_type
  • d1dth12r_bit : dac_type
  • d1dth8r : dac_type
  • d1dth8r_bit : dac_type
  • d1en : dac_type
  • d1nbsel : dac_type
  • d1nm : dac_type
  • d1obdis : dac_type
  • d1odt : dac_type
  • d1odt_bit : dac_type
  • d1swtrg : dac_type
  • d1trgen : dac_type
  • d1trgsel : dac_type
  • d2dmaen : dac_type
  • d2dmaudrf : dac_type
  • d2dmaudrien : dac_type
  • d2dt12l : dac_type
  • d2dt12r : dac_type
  • d2dt8r : dac_type
  • d2dth12l : dac_type
  • d2dth12l_bit : dac_type
  • d2dth12r : dac_type
  • d2dth12r_bit : dac_type
  • d2dth8r : dac_type
  • d2dth8r_bit : dac_type
  • d2en : dac_type
  • d2nbsel : dac_type
  • d2nm : dac_type
  • d2obdis : dac_type
  • d2odt : dac_type
  • d2odt_bit : dac_type
  • d2swtrg : dac_type
  • d2trgen : dac_type
  • d2trgsel : dac_type
  • da : emac_dma_type
  • da_enable : emac_dma_config_type
  • dacen : crm_type
  • daclpen : crm_type
  • dacrst : crm_type
  • daif : emac_type
  • daint : otg_device_type
  • daint_bit : otg_device_type
  • daintmsk : otg_device_type
  • daintmsk_bit : otg_device_type
  • data : can_rx_message_type, can_tx_message_type, cdc_msc_struct_type, fs_file, fsdata_file, fsdata_file_noconst, linecoding_type, msc_bot_trans_type, msc_type, tftp_connection_args, xmc_sdram_cmd_type
  • data0 : usd_type
  • data1 : usd_type
  • data_addr_multiplex : xmc_norsram_init_type
  • data_align : adc_base_config_type
  • data_channel_format : i2s_init_type
  • data_counter : qspi_cmd_type
  • data_format : msc_scsi_data_inquiry
  • data_latency_time : xmc_norsram_timing_init_type
  • data_len : cdc_msc_struct_type, msc_type, tftp_connection_args
  • data_length : sdio_data_struct_type
  • data_pid : usb_hch_type
  • data_setup_time : xmc_norsram_timing_init_type
  • data_stat_after_erase : sd_scr_struct_type
  • date : ertc_reg_date_type, ertc_type
  • date_bit : ertc_reg_date_type, ertc_type
  • day : ertc_alarm_value_type, ertc_time_type
  • db : xmc_sdram_type
  • dbf : emac_type
  • dbn_h : usart_type
  • dbn_l : usart_type
  • dc : emac_type
  • dCBWDataTransferLength : cbw_type, msc_bot_cbw_type
  • dCBWSignature : cbw_type, msc_bot_cbw_type, msc_bot_csw_type
  • dCBWTag : msc_bot_cbw_type, msc_bot_csw_type
  • dCBWTage : cbw_type
  • dcfg : otg_device_type
  • dcfg_bit : otg_device_type
  • dcnt : qspi_type
  • dcs : emac_type
  • dCSWDataResidue : csw_type, msc_bot_csw_type
  • dCSWSignature : csw_type
  • dCSWTag : csw_type
  • dctl : otg_device_type
  • dctl_bit : otg_device_type
  • dd1dt12l : dac_type
  • dd1dt12r : dac_type
  • dd1dt8r : dac_type
  • dd2dt12l : dac_type
  • dd2dt12r : dac_type
  • dd2dt8r : dac_type
  • ddth12l : dac_type
  • ddth12l_bit : dac_type
  • ddth12r : dac_type
  • ddth12r_bit : dac_type
  • ddth8r : dac_type
  • ddth8r_bit : dac_type
  • deadtime : tmr_brkdt_config_type
  • dec : ertc_reg_scal_type, ertc_type
  • dec1h : ertc_type
  • decsbs : ertc_reg_tadj_type, ertc_type
  • deepsleep_debug : debug_type
  • deferral_check : emac_control_config_type
  • delay_time_ar : xmc_nand_init_type, xmc_pccard_init_type
  • delay_time_cr : xmc_pccard_init_type
  • delay_time_cycle : xmc_nand_init_type
  • dep : usart_type
  • depslp_rst : flash_type
  • desc_skip_length : emac_dma_config_type
  • dev : xmc_bank1_ctrl_tmg_reg_type, xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • devaddr : otg_device_type, otg_hchannel_type
  • devaddren : i2c_type
  • DevAdr : FlashDevice
  • device : xmc_norsram_init_type
  • device_code1 : nor_idtype
  • device_code2 : nor_idtype
  • device_code3 : nor_idtype
  • device_id : nand_id_type
  • device_size : sd_csd_struct_type
  • device_size_mult : sd_csd_struct_type
  • DevName : FlashDevice
  • devspd : otg_device_type
  • DevType : FlashDevice
  • dflt : i2c_type
  • dfrf : emac_dma_type
  • diepctl : otg_eptin_type
  • diepctl_bit : otg_eptin_type
  • diepempmsk : otg_device_type
  • diepempmsk_bit : otg_device_type
  • diepint : otg_eptin_type
  • diepint_bit : otg_eptin_type
  • diepmsk : otg_device_type
  • diepmsk_bit : otg_device_type
  • dieptsiz : otg_eptin_type
  • dieptsiz_bit : otg_eptin_type
  • dieptxfn : otg_global_type
  • dieptxfn_bit : otg_global_type
  • dir : i2c_type, usb_hch_type
  • direction : dma_init_type, edma_init_type
  • disconint : otg_global_type
  • disconintmsk : otg_global_type
  • div : adc_common_config_type, ertc_type, tmr_type, usart_type, wdt_type, wwdt_type
  • div_bit : ertc_type, tmr_type, wdt_type
  • diva : ertc_type
  • divb : ertc_type
  • divf : wdt_type
  • divh : i2c_type
  • divl : i2c_type
  • divr : flash_type
  • divr_bit : flash_type
  • dlc : can_rx_message_type, can_tx_message_type
  • dm : emac_type
  • dma1en : crm_type
  • dma1lpen : crm_type
  • dma1rst : crm_type
  • dma2en : crm_type
  • dma2lpen : crm_type
  • dma2rst : crm_type
  • dma_en : usb_core_cfg
  • dma_init_struct : i2c_handle_type
  • dma_rx_channel : i2c_handle_type
  • dma_tx_channel : i2c_handle_type
  • dmabt : dvp_type
  • dmactrl : tmr_type
  • dmactrl_bit : tmr_type
  • dmadt : tmr_type
  • dmadt_bit : tmr_type
  • dmaen : qspi_type, sdio_type
  • dmaren : i2c_type, spi_type, usart_type
  • dmaten : i2c_type, spi_type, usart_type
  • dmerrf1 : edma_type
  • dmerrf2 : edma_type
  • dmerrf3 : edma_type
  • dmerrf4 : edma_type
  • dmerrf5 : edma_type
  • dmerrf6 : edma_type
  • dmerrf7 : edma_type
  • dmerrf8 : edma_type
  • dmerrfc1 : edma_type
  • dmerrfc2 : edma_type
  • dmerrfc3 : edma_type
  • dmerrfc4 : edma_type
  • dmerrfc5 : edma_type
  • dmerrfc6 : edma_type
  • dmerrfc7 : edma_type
  • dmerrfc8 : edma_type
  • dmerrien : edma_stream_type
  • dmm : edma_stream_type
  • docmd : sdio_type
  • docmdien : sdio_type
  • doepctl : otg_eptout_type
  • doepctl_bit : otg_eptout_type
  • doepint : otg_eptout_type
  • doepint_bit : otg_eptout_type
  • doepmsk : otg_device_type
  • doepmsk_bit : otg_device_type
  • doeptsiz : otg_eptout_type
  • doeptsiz_bit : otg_eptout_type
  • dorx : sdio_type
  • dorxien : sdio_type
  • dotx : sdio_type
  • dotxien : sdio_type
  • dpid : otg_eptin_type, otg_eptout_type, otg_global_type
  • dr : emac_type
  • dr0 : dvp_type
  • dr1 : dvp_type
  • dr2 : dvp_type
  • dr3 : dvp_type
  • draw_point : lcd_dev_type
  • dren : ertc_type
  • dro : emac_type
  • drs : tmr_type
  • dsl : emac_dma_type
  • dsr_implemented : sd_csd_struct_type
  • dsts : otg_device_type
  • dsts_bit : otg_device_type
  • dststd : edma_stream_2d_type
  • dt : crc_type, dvp_type, emac_dma_type, ertc_type, i2c_type, qspi_type, sdio_type, spi_type, usart_type
  • dt1 : ertc_type
  • dt10 : ertc_type
  • dt10_bit : ertc_type
  • dt11 : ertc_type
  • dt11_bit : ertc_type
  • dt12 : ertc_type
  • dt12_bit : ertc_type
  • dt13 : ertc_type
  • dt13_bit : ertc_type
  • dt14 : ertc_type
  • dt14_bit : ertc_type
  • dt15 : ertc_type
  • dt15_bit : ertc_type
  • dt16 : ertc_type
  • dt16_bit : ertc_type
  • dt17 : ertc_type
  • dt17_bit : ertc_type
  • dt18 : ertc_type
  • dt18_bit : ertc_type
  • dt19 : ertc_type
  • dt19_bit : ertc_type
  • dt1_bit : ertc_type
  • dt2 : ertc_type
  • dt20 : ertc_type
  • dt20_bit : ertc_type
  • dt2_bit : ertc_type
  • dt3 : ertc_type
  • dt3_bit : ertc_type
  • dt4 : ertc_type
  • dt4_bit : ertc_type
  • dt5 : ertc_type
  • dt5_bit : ertc_type
  • dt6 : ertc_type
  • dt6_bit : ertc_type
  • dt7 : ertc_type
  • dt7_bit : ertc_type
  • dt8 : ertc_type
  • dt8_bit : ertc_type
  • dt9 : ertc_type
  • dt9_bit : ertc_type
  • dt_bit : crc_type, dvp_type, qspi_type, spi_type, usart_type
  • dt_disable : emac_dma_config_type
  • dt_u16 : qspi_type
  • dt_u8 : qspi_type
  • dtalign : adc_type
  • dtb : tmr_type
  • dtblkcmpl : sdio_type
  • dtblkcmplien : sdio_type
  • dtc : tmr_type
  • dtcmpl : sdio_type
  • dtcmplien : sdio_type
  • dtcnt : dma_channel_type, edma_stream_type, sdio_type
  • dtcnt_bit : dma_channel_type, edma_stream_type, sdio_type
  • dtctrl : sdio_type
  • dtctrl_bit : sdio_type
  • dtd : dma_channel_type, edma_stream_type
  • dterrf1 : dma_type, edma_type
  • dterrf2 : dma_type, edma_type
  • dterrf3 : dma_type, edma_type
  • dterrf4 : dma_type, edma_type
  • dterrf5 : dma_type, edma_type
  • dterrf6 : dma_type, edma_type
  • dterrf7 : dma_type, edma_type
  • dterrf8 : edma_type
  • dterrfc1 : dma_type, edma_type
  • dterrfc2 : dma_type, edma_type
  • dterrfc3 : dma_type, edma_type
  • dterrfc4 : dma_type, edma_type
  • dterrfc5 : dma_type, edma_type
  • dterrfc6 : dma_type, edma_type
  • dterrfc7 : dma_type, edma_type
  • dterrfc8 : edma_type
  • dterrien : dma_channel_type, edma_stream_type
  • dtfail : sdio_type
  • dtfailien : sdio_type
  • dtglerr : otg_hchannel_type
  • dtglerrmsk : otg_hchannel_type
  • dtlat : xmc_bank1_ctrl_tmg_reg_type
  • dtlen : sdio_type
  • dtlen_bit : sdio_type
  • dtst : xmc_bank1_ctrl_tmg_reg_type, xmc_bank1_tmgwr_reg_type
  • dttimeout : sdio_type
  • dttimeoutien : sdio_type
  • dttmr : sdio_type
  • dttmr_bit : sdio_type
  • dtxfsts : otg_eptin_type
  • dtxfsts_bit : otg_eptin_type
  • dum2 : qspi_type
  • dup : emac_type
  • duplex_mode : emac_control_config_type
  • dvpen : crm_type
  • dvplpen : crm_type
  • dvprst : crm_type
  • dzc : can_type
  • dzen : can_type
  • dzqp : emac_type


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- e -

  • eaf : can_type
  • eaien : can_type
  • eb : emac_dma_type
  • ecc : xmc_bank2_type, xmc_bank3_type
  • ecc_code : sd_csd_struct_type
  • ecc_enable : xmc_nand_init_type
  • ecc_pagesize : xmc_nand_init_type
  • eccen : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • eccpgs : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • ecmben : tmr_type
  • edmaen : crm_type
  • edmalpen : crm_type
  • edmarst : crm_type
  • edzien : can_type
  • edzif : can_type
  • efdf : dvp_type
  • efrce : dvp_type
  • efrcsf : dvp_type
  • efrctf : dvp_type
  • eie : emac_dma_type
  • eien : acc_type
  • eisre : dvp_type
  • emac_pps_sel : crm_type
  • emafpff : emac_ptp_type
  • emp : emac_type
  • en : xmc_bank1_ctrl_tmg_reg_type, xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • ena : dvp_type
  • enable_wait : xmc_pccard_init_type
  • enpd : usb_audio_hid_type, usb_audio_type
  • entrim : acc_type
  • enumdone : otg_global_type
  • enumdonemsk : otg_global_type
  • enumspd : otg_device_type
  • eocsfen : adc_type
  • eoien : can_type
  • eoif : can_type
  • eopb0 : usd_type
  • eopf : otg_global_type
  • eopfmsk : otg_global_type
  • epdisd : otg_eptin_type, otg_eptout_type
  • epf : can_type
  • epien : can_type
  • epp0 : usd_type
  • epp1 : usd_type
  • epp2 : usd_type
  • epp3 : usd_type
  • epp4 : usd_type
  • epp5 : usd_type
  • epp6 : usd_type
  • epp7 : usd_type
  • eppef : emac_ptp_type
  • epperr : flash_type
  • eppfsip4u : emac_ptp_type
  • eppfsip6u : emac_ptp_type
  • epps : flash_type
  • epps0 : flash_type
  • epps0_bit : flash_type
  • epps1 : flash_type
  • epps1_bit : flash_type
  • eppv2f : emac_ptp_type
  • ept0_slen : usb_ept_info
  • ept_address : usb_ept_info
  • ept_num : usb_core_cfg, usb_hch_type
  • ept_type : usb_hch_type
  • eptdir : otg_hchannel_type
  • eptdis : otg_eptin_type, otg_eptout_type
  • eptdismsk : otg_device_type
  • eptena : otg_eptin_type, otg_eptout_type
  • eptin : usbh_hid_type, usbh_msc_type
  • eptn : usb_ept_info
  • eptnum : otg_global_type, otg_hchannel_type
  • eptout : usbh_hid_type, usbh_msc_type
  • eptype : otg_eptin_type, otg_eptout_type, otg_hchannel_type
  • erase_group_size : sd_csd_struct_type
  • erase_group_size_mult : sd_csd_struct_type
  • ere : emac_dma_type
  • erf : emac_type
  • eri : emac_dma_type
  • erien : xmc_sdram_type
  • erlysusp : otg_global_type
  • erlysuspmsk : otg_global_type
  • err : xmc_sdram_type
  • err_code : sense_type
  • errc : xmc_sdram_type
  • errie : flash_type, spi_type
  • errien : i2c_type, usart_type
  • error : usbh_msc_type
  • error_code : i2c_handle_type
  • erstr : flash_type
  • ertc_512_pause : debug_type
  • ertc_pause : debug_type
  • ertcdiv : crm_type
  • ertcen : crm_type
  • ertcsel : crm_type
  • erwf : emac_type
  • esdiv : tmr_type
  • esees : dvp_type
  • eseic : dvp_type
  • eseie : dvp_type
  • eseis : dvp_type
  • esf : tmr_type
  • esfmrtm : emac_ptp_type
  • esp : tmr_type
  • ests : can_type, dvp_type
  • ests_bit : can_type, dvp_type
  • etaf : emac_ptp_type
  • etf : emac_type
  • eti : emac_dma_type
  • eticerr : otg_device_type
  • etr : can_type
  • etrien : can_type
  • etsfem : emac_ptp_type
  • etv : emac_type
  • evten : exint_type
  • evten_bit : exint_type
  • evtenx : exint_type
  • evtgen : dmamux_channel_type, edmamux_channel_type
  • exint0 : scfg_type
  • exint1 : scfg_type
  • exint10 : scfg_type
  • exint11 : scfg_type
  • exint12 : scfg_type
  • exint13 : scfg_type
  • exint14 : scfg_type
  • exint15 : scfg_type
  • exint2 : scfg_type
  • exint3 : scfg_type
  • exint4 : scfg_type
  • exint5 : scfg_type
  • exint6 : scfg_type
  • exint7 : scfg_type
  • exint8 : scfg_type
  • exint9 : scfg_type
  • exintc1 : scfg_type
  • exintc1_bit : scfg_type
  • exintc2 : scfg_type
  • exintc2_bit : scfg_type
  • exintc3 : scfg_type
  • exintc3_bit : scfg_type
  • exintc4 : scfg_type
  • exintc4_bit : scfg_type
  • ext : xmc_bank1_type
  • ext_bit : xmc_bank1_type
  • exten : i2c_type
  • extended_id : can_rx_message_type, can_tx_message_type
  • extmdbw : xmc_bank1_ctrl_tmg_reg_type, xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • exttime : i2c_type


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- f -

  • fa : flash_type
  • facfg : can_type
  • facfg_bit : can_type
  • faen0 : can_type
  • faen1 : can_type
  • faen10 : can_type
  • faen11 : can_type
  • faen12 : can_type
  • faen13 : can_type
  • faen14 : can_type
  • faen15 : can_type
  • faen16 : can_type
  • faen17 : can_type
  • faen18 : can_type
  • faen19 : can_type
  • faen2 : can_type
  • faen20 : can_type
  • faen21 : can_type
  • faen22 : can_type
  • faen23 : can_type
  • faen24 : can_type
  • faen25 : can_type
  • faen26 : can_type
  • faen27 : can_type
  • faen3 : can_type
  • faen4 : can_type
  • faen5 : can_type
  • faen6 : can_type
  • faen7 : can_type
  • faen8 : can_type
  • faen9 : can_type
  • fap : flash_type, usd_type
  • fast_ethernet_speed : emac_control_config_type
  • fb : emac_dma_type
  • fb_enable : emac_dma_config_type
  • fbee : emac_dma_type
  • fbei : emac_dma_type
  • fbn : spi_type
  • fbwcfg : can_type
  • fbwcfg_bit : can_type
  • fbwsel0 : can_type
  • fbwsel1 : can_type
  • fbwsel10 : can_type
  • fbwsel11 : can_type
  • fbwsel12 : can_type
  • fbwsel13 : can_type
  • fbwsel14 : can_type
  • fbwsel15 : can_type
  • fbwsel16 : can_type
  • fbwsel17 : can_type
  • fbwsel18 : can_type
  • fbwsel19 : can_type
  • fbwsel2 : can_type
  • fbwsel20 : can_type
  • fbwsel21 : can_type
  • fbwsel22 : can_type
  • fbwsel23 : can_type
  • fbwsel24 : can_type
  • fbwsel25 : can_type
  • fbwsel26 : can_type
  • fbwsel27 : can_type
  • fbwsel3 : can_type
  • fbwsel4 : can_type
  • fbwsel5 : can_type
  • fbwsel6 : can_type
  • fbwsel7 : can_type
  • fbwsel8 : can_type
  • fbwsel9 : can_type
  • fcbbpa : emac_type
  • fcontr_en : flash_type
  • fcs : can_type
  • fcsodis : tmr_type
  • fcsodis_state : tmr_brkdt_config_type
  • fcsoen : tmr_type
  • fcsoen_state : tmr_brkdt_config_type
  • fctrl : can_type, edma_stream_type, emac_type
  • fctrl_bit : can_type, edma_stream_type, emac_type
  • fdevmode : otg_global_type
  • fdiv : flash_type
  • fdiv_sts : flash_type
  • fdtf1 : dma_type, edma_type
  • fdtf2 : dma_type, edma_type
  • fdtf3 : dma_type, edma_type
  • fdtf4 : dma_type, edma_type
  • fdtf5 : dma_type, edma_type
  • fdtf6 : dma_type, edma_type
  • fdtf7 : dma_type, edma_type
  • fdtf8 : edma_type
  • fdtfc1 : dma_type, edma_type
  • fdtfc2 : dma_type, edma_type
  • fdtfc3 : dma_type, edma_type
  • fdtfc4 : dma_type, edma_type
  • fdtfc5 : dma_type, edma_type
  • fdtfc6 : dma_type, edma_type
  • fdtfc7 : dma_type, edma_type
  • fdtfc8 : edma_type
  • fdtien : dma_channel_type, edma_stream_type
  • fef : emac_dma_type
  • fef_enable : emac_dma_config_type
  • feien : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • fen : edma_stream_type
  • ferr : usart_type
  • ferrf1 : edma_type
  • ferrf2 : edma_type
  • ferrf3 : edma_type
  • ferrf4 : edma_type
  • ferrf5 : edma_type
  • ferrf6 : edma_type
  • ferrf7 : edma_type
  • ferrf8 : edma_type
  • ferrfc1 : edma_type
  • ferrfc2 : edma_type
  • ferrfc3 : edma_type
  • ferrfc4 : edma_type
  • ferrfc5 : edma_type
  • ferrfc6 : edma_type
  • ferrfc7 : edma_type
  • ferrfc8 : edma_type
  • ferrien : edma_stream_type
  • fes : emac_type, xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • ffb : can_type
  • ffdb1 : can_filter_register_type
  • ffdb2 : can_filter_register_type
  • fhstmode : otg_global_type
  • fifo_length : iap_info_type
  • fifo_mailbox : can_type
  • fifo_mode_enable : edma_init_type
  • fifo_size : usb_core_cfg
  • fifo_threshold : edma_init_type
  • fifoe : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • fifosts : qspi_type
  • fifosts_bit : qspi_type
  • fifth_id : nand_id_type
  • file : http_state
  • file_formart : sd_csd_struct_type
  • file_format_group : sd_csd_struct_type
  • file_handle : http_state
  • file_name : fat_dir_type
  • file_size : fat_dir_type
  • file_write_nr : flash_iap_type
  • filter_activate_enable : can_filter_init_type
  • filter_bit : can_filter_init_type
  • filter_fifo : can_filter_init_type
  • filter_id_high : can_filter_init_type
  • filter_id_low : can_filter_init_type
  • filter_index : can_rx_message_type
  • filter_mask_high : can_filter_init_type
  • filter_mask_low : can_filter_init_type
  • filter_mode : can_filter_init_type
  • filter_number : can_filter_init_type
  • firmware_length : flash_iap_type
  • first_bit_transmission : spi_init_type
  • flag_address : iap_info_type
  • flash_app_addr : flash_iap_type
  • flash_app_size : flash_iap_type
  • flash_base_addr : flash_iap_type
  • flash_end_address : iap_info_type
  • flash_size : flash_iap_type, iap_info_type
  • flash_start_address : iap_info_type
  • flush_rx_disable : emac_dma_config_type
  • fmc : emac_mmc_type
  • fmcfg : can_type
  • fmcfg_bit : can_type
  • fmec : dvp_type
  • fmeu : dvp_type
  • fmsc : dvp_type
  • fmsel0 : can_type
  • fmsel1 : can_type
  • fmsel10 : can_type
  • fmsel11 : can_type
  • fmsel12 : can_type
  • fmsel13 : can_type
  • fmsel14 : can_type
  • fmsel15 : can_type
  • fmsel16 : can_type
  • fmsel17 : can_type
  • fmsel18 : can_type
  • fmsel19 : can_type
  • fmsel2 : can_type
  • fmsel20 : can_type
  • fmsel21 : can_type
  • fmsel22 : can_type
  • fmsel23 : can_type
  • fmsel24 : can_type
  • fmsel25 : can_type
  • fmsel26 : can_type
  • fmsel27 : can_type
  • fmsel3 : can_type
  • fmsel4 : can_type
  • fmsel5 : can_type
  • fmsel6 : can_type
  • fmsel7 : can_type
  • fmsel8 : can_type
  • fmsel9 : can_type
  • fmsu : dvp_type
  • fn : otg_global_type
  • format : linecoding_type
  • fourth_id : nand_id_type
  • fprgm : flash_type
  • fpx : exint_type
  • frame_bit_num : spi_init_type
  • frame_type : can_rx_message_type, can_tx_message_type
  • frf : can_type, dvp_type
  • frf_bit : can_type, dvp_type
  • frfsel0 : can_type
  • frfsel1 : can_type
  • frfsel10 : can_type
  • frfsel11 : can_type
  • frfsel12 : can_type
  • frfsel13 : can_type
  • frfsel14 : can_type
  • frfsel15 : can_type
  • frfsel16 : can_type
  • frfsel17 : can_type
  • frfsel18 : can_type
  • frfsel19 : can_type
  • frfsel2 : can_type
  • frfsel20 : can_type
  • frfsel21 : can_type
  • frfsel22 : can_type
  • frfsel23 : can_type
  • frfsel24 : can_type
  • frfsel25 : can_type
  • frfsel26 : can_type
  • frfsel27 : can_type
  • frfsel3 : can_type
  • frfsel4 : can_type
  • frfsel5 : can_type
  • frfsel6 : can_type
  • frfsel7 : can_type
  • frfsel8 : can_type
  • frfsel9 : can_type
  • frint : otg_host_type
  • frmcntrst : otg_global_type
  • frmf : emac_type
  • frmf_bit : emac_type
  • frmovrun : otg_hchannel_type
  • frmovrunmsk : otg_hchannel_type
  • frnum : otg_host_type
  • fsize : qspi_type
  • fsize_bit : qspi_type
  • fslspclksel : otg_host_type
  • fslssupp : otg_host_type
  • fsts : edma_stream_type
  • ftf : emac_dma_type
  • fthsel : edma_stream_type
  • ftrem : otg_host_type
  • fugf : emac_dma_type
  • fugf_enable : emac_dma_config_type
  • fzc : can_type
  • fzen : can_type


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- g -

  • g_audio_cur : usb_audio_hid_type, usb_audio_type
  • g_cmd : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • g_keyboard_tx_completed : vcp_keyboard_type
  • g_len : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • g_printer_data : printer_type
  • g_printer_port_status : printer_type
  • g_req : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • g_rx_buff : cdc_msc_struct_type, cdc_struct_type, printer_type, vcp_keyboard_type
  • g_rx_completed : cdc_msc_struct_type, cdc_struct_type, printer_type, vcp_keyboard_type
  • g_rxhid_buff : custom_hid_type, iap_info_type, usb_audio_hid_type
  • g_rxlen : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • g_tx_completed : cdc_msc_struct_type, cdc_struct_type, printer_type, vcp_keyboard_type
  • g_txhid_buff : custom_hid_type, usb_audio_hid_type
  • g_u8tx_completed : keyboard_type
  • gahbcfg : otg_global_type
  • gahbcfg_bit : otg_global_type
  • gcaen : i2c_type
  • gccfg : otg_global_type
  • gccfg_bit : otg_global_type
  • gctrl : dmamux_generator_type, edmamux_generator_type
  • gctrl_bit : dmamux_generator_type, edmamux_generator_type
  • gdiv : usart_type
  • gdiv_bit : usart_type
  • gen : dmamux_generator_type, edmamux_generator_type
  • gen_enable : dmamux_gen_init_type, edmamux_gen_init_type
  • gen_polarity : dmamux_gen_init_type, edmamux_gen_init_type
  • gen_request_number : dmamux_gen_init_type, edmamux_gen_init_type
  • gen_signal_sel : dmamux_gen_init_type, edmamux_gen_init_type
  • genstart : i2c_type
  • genstop : i2c_type
  • gf1 : dma_type
  • gf2 : dma_type
  • gf3 : dma_type
  • gf4 : dma_type
  • gf5 : dma_type
  • gf6 : dma_type
  • gf7 : dma_type
  • gfc1 : dma_type
  • gfc2 : dma_type
  • gfc3 : dma_type
  • gfc4 : dma_type
  • gfc5 : dma_type
  • gfc6 : dma_type
  • gfc7 : dma_type
  • ginnakeff : otg_global_type
  • ginnakeffmsk : otg_global_type
  • gintmsk : otg_global_type
  • gintmsk_bit : otg_global_type
  • gintsts : otg_global_type
  • gintsts_bit : otg_global_type
  • glbintmsk : otg_global_type
  • gnpinnaksts : otg_device_type
  • gnptxfsiz_ept0tx : otg_global_type
  • gnptxfsiz_ept0tx_bit : otg_global_type
  • gnptxsts : otg_global_type
  • gnptxsts_bit : otg_global_type
  • gotgctrl : otg_global_type
  • gotgctrl_bit : otg_global_type
  • gotgint : otg_global_type
  • gotgint_bit : otg_global_type
  • goutnakeff : otg_global_type
  • goutnakeffmsk : otg_global_type
  • goutnaksts : otg_device_type
  • gpio_drive_strength : gpio_init_type
  • gpio_mode : gpio_init_type
  • gpio_out_type : gpio_init_type
  • gpio_pins : gpio_init_type
  • gpio_pull : gpio_init_type
  • gpioaen : crm_type
  • gpioalpen : crm_type
  • gpioarst : crm_type
  • gpioben : crm_type
  • gpioblpen : crm_type
  • gpiobrst : crm_type
  • gpiocen : crm_type
  • gpioclpen : crm_type
  • gpiocrst : crm_type
  • gpioden : crm_type
  • gpiodlpen : crm_type
  • gpiodrst : crm_type
  • gpioeen : crm_type
  • gpioelpen : crm_type
  • gpioerst : crm_type
  • gpiofen : crm_type
  • gpioflpen : crm_type
  • gpiofrst : crm_type
  • gpiogen : crm_type
  • gpioglpen : crm_type
  • gpiogrst : crm_type
  • gpiohen : crm_type
  • gpiohlpen : crm_type
  • gpiohrst : crm_type
  • gpol : dmamux_generator_type, edmamux_generator_type
  • greqcnt : dmamux_generator_type, edmamux_generator_type
  • grstctl : otg_global_type
  • grstctl_bit : otg_global_type
  • grxfsiz : otg_global_type
  • grxfsiz_bit : otg_global_type
  • grxstsp : otg_global_type
  • grxstsp_bit : otg_global_type
  • grxstsr : otg_global_type
  • grxstsr_bit : otg_global_type
  • guc : emac_type
  • guid : otg_global_type
  • guid_bit : otg_global_type
  • gusbcfg : otg_global_type
  • gusbcfg_bit : otg_global_type


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- h -

  • h : ertc_reg_alarm_type, ertc_reg_time_type, ertc_reg_tstm_type, ertc_type, sc_atr_type
  • haddren : i2c_type
  • haint : otg_host_type
  • haint_bit : otg_host_type
  • haintmsk : otg_host_type
  • haintmsk_bit : otg_host_type
  • hallde : tmr_type
  • hallien : tmr_type
  • hallif : tmr_type
  • hallswtr : tmr_type
  • handle : http_state
  • hc_num : usb_core_cfg
  • hcchar : otg_hchannel_type
  • hcchar_bit : otg_hchannel_type
  • hcfg : otg_host_type
  • hcfg_bit : otg_host_type
  • hchint : otg_global_type
  • hchintmsk : otg_global_type
  • hcint : otg_hchannel_type
  • hcint_bit : otg_hchannel_type
  • hcintmsk : otg_hchannel_type
  • hcintmsk_bit : otg_hchannel_type
  • hcsplt : otg_hchannel_type
  • hcsplt_bit : otg_hchannel_type
  • hctsiz : otg_hchannel_type
  • hctsiz_bit : otg_hchannel_type
  • hdrv : gpio_type
  • hdrv0 : gpio_type
  • hdrv1 : gpio_type
  • hdrv10 : gpio_type
  • hdrv11 : gpio_type
  • hdrv12 : gpio_type
  • hdrv13 : gpio_type
  • hdrv14 : gpio_type
  • hdrv15 : gpio_type
  • hdrv2 : gpio_type
  • hdrv3 : gpio_type
  • hdrv4 : gpio_type
  • hdrv5 : gpio_type
  • hdrv6 : gpio_type
  • hdrv7 : gpio_type
  • hdrv8 : gpio_type
  • hdrv9 : gpio_type
  • hdrv_bit : gpio_type
  • hdtf1 : dma_type, edma_type
  • hdtf2 : dma_type, edma_type
  • hdtf3 : dma_type, edma_type
  • hdtf4 : dma_type, edma_type
  • hdtf5 : dma_type, edma_type
  • hdtf6 : dma_type, edma_type
  • hdtf7 : dma_type, edma_type
  • hdtf8 : edma_type
  • hdtfc1 : dma_type, edma_type
  • hdtfc2 : dma_type, edma_type
  • hdtfc3 : dma_type, edma_type
  • hdtfc4 : dma_type, edma_type
  • hdtfc5 : dma_type, edma_type
  • hdtfc6 : dma_type, edma_type
  • hdtfc7 : dma_type, edma_type
  • hdtfc8 : edma_type
  • hdtien : dma_channel_type, edma_stream_type
  • head : usart_group_type
  • hextbyps : crm_type
  • hexten : crm_type
  • hextstbl : crm_type
  • hextstblf : crm_type
  • hextstblfc : crm_type
  • hextstblien : crm_type
  • hfcen : sdio_type
  • hfir : otg_host_type
  • hfir_bit : otg_host_type
  • hfnum : otg_host_type
  • hfnum_bit : otg_host_type
  • hick_to_sclk : crm_type
  • hick_to_usb : crm_type
  • hickcal : acc_type, crm_type
  • hickcal_key : crm_type
  • hickdiv : crm_type
  • hicken : crm_type
  • hickstbl : crm_type
  • hickstblf : crm_type
  • hickstblfc : crm_type
  • hickstblien : crm_type
  • hicktrim : acc_type, crm_type
  • hid_desc : usbh_hid_type
  • hid_protocol : custom_hid_type, iap_info_type, keyboard_type, mouse_type, usb_audio_hid_type, vcp_keyboard_type
  • hid_set_idle : custom_hid_type, iap_info_type, keyboard_type, mouse_type, usb_audio_hid_type, vcp_keyboard_type
  • hid_set_report : custom_hid_type, iap_info_type, keyboard_type, mouse_type, usb_audio_hid_type, vcp_keyboard_type
  • hid_state : custom_hid_type, iap_info_type, keyboard_type, mouse_type, usb_audio_hid_type, vcp_keyboard_type
  • hid_suspend_flag : keyboard_type, mouse_type
  • hlength : sc_atr_type
  • hlien : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • hls : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • hm : ertc_type
  • hmc : emac_type
  • hour : ertc_alarm_value_type, ertc_time_type
  • hpf : emac_type
  • hprt : otg_host_type
  • hprt_bit : otg_host_type
  • hptxfsiz : otg_global_type
  • hptxfsiz_bit : otg_global_type
  • hptxsts : otg_host_type
  • hptxsts_bit : otg_host_type
  • hrbap : emac_dma_type
  • hrdap : emac_dma_type
  • hscf : dvp_type
  • hscf_bit : dvp_type
  • hseid : dvp_type
  • hses : dvp_type
  • hsic : dvp_type
  • hsie : dvp_type
  • hsis : dvp_type
  • hsp : dvp_type
  • hsrss : dvp_type
  • hsrts : dvp_type
  • hsyn : dvp_type
  • htbap : emac_dma_type
  • htdap : emac_dma_type
  • hth : emac_type
  • hth_bit : emac_type
  • htl : emac_type
  • htl_bit : emac_type
  • hubaddr : otg_hchannel_type
  • huc : emac_type
  • hwcsoe : spi_type


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- i -

  • i2c1_smbus_timeout : debug_type
  • i2c1en : crm_type
  • i2c1lpen : crm_type
  • i2c1rst : crm_type
  • i2c2_smbus_timeout : debug_type
  • i2c2en : crm_type
  • i2c2lpen : crm_type
  • i2c2rst : crm_type
  • i2c3_smbus_timeout : debug_type
  • i2c3en : crm_type
  • i2c3lpen : crm_type
  • i2c3rst : crm_type
  • i2cen : i2c_type
  • i2cx : i2c_handle_type
  • i2scbn : spi_type
  • i2sclk : spi_type
  • i2sclk_bit : spi_type
  • i2sclkpol : spi_type
  • i2sctrl : spi_type
  • i2sctrl_bit : spi_type
  • i2sdbn : spi_type
  • i2sdiv_h : spi_type
  • i2sdiv_l : spi_type
  • i2sen : spi_type
  • i2smclkoe : spi_type
  • i2smsel : spi_type
  • i2sodd : spi_type
  • iap_address : iap_info_type
  • iap_fifo : iap_info_type
  • iap_rx : iap_info_type
  • iap_tx : iap_info_type
  • iclr : dvp_type
  • iclr_bit : dvp_type
  • iConfiguration : usb_configuration_desc_type
  • id_h : usart_type
  • id_l : usart_type
  • id_type : can_rx_message_type, can_tx_message_type
  • idbn : usart_type
  • idcode_bit : debug_type
  • iden : tmr_type
  • iden_bit : tmr_type
  • idlef : usart_type
  • idleien : usart_type
  • idProduct : usb_device_desc_type
  • idt : crc_type, gpio_type
  • idt0 : gpio_type
  • idt1 : gpio_type
  • idt10 : gpio_type
  • idt11 : gpio_type
  • idt12 : gpio_type
  • idt13 : gpio_type
  • idt14 : gpio_type
  • idt15 : gpio_type
  • idt2 : gpio_type
  • idt3 : gpio_type
  • idt4 : gpio_type
  • idt5 : gpio_type
  • idt6 : gpio_type
  • idt7 : gpio_type
  • idt8 : gpio_type
  • idt9 : gpio_type
  • idt_bit : crc_type, gpio_type
  • idun : dvp_type
  • idus : dvp_type
  • idVendor : usb_device_desc_type
  • ie : emac_dma_type
  • ie_bit : emac_dma_type
  • ieptint : otg_global_type
  • ieptintmsk : otg_global_type
  • ier : dvp_type
  • ier_bit : dvp_type
  • ifg : emac_type
  • iInterface : usb_interface_desc_type
  • iManufacturer : usb_device_desc_type
  • imen : ertc_type
  • imf : ertc_type
  • imr : emac_type
  • imr_bit : emac_type
  • in_maxpacket : usbh_hid_type, usbh_msc_type
  • in_poll : usbh_hid_type, usbh_msc_type
  • inbk : xmc_sdram_type
  • incompip_incompisoout : otg_global_type
  • incompip_incompisooutmsk : otg_global_type
  • incompisoin : otg_global_type
  • incompisoinmsk : otg_global_type
  • ineptint : otg_device_type
  • ineptmsk : otg_device_type
  • ineptnak : otg_eptin_type
  • ineptnakmsk : otg_device_type
  • ineptxfdep : otg_global_type
  • ineptxfemsk : otg_device_type
  • ineptxfsav : otg_eptin_type
  • ineptxfstaddr : otg_global_type
  • information : sense_type
  • init : touch_dev_type
  • initf : ertc_type
  • inout : usb_ept_info
  • input_channel_select : tmr_input_config_type
  • input_filter_value : tmr_input_config_type
  • input_mapped_select : tmr_input_config_type
  • input_polarity_select : tmr_input_config_type
  • inquiry : usbh_msc_unit_type
  • insc : qspi_type
  • inslen : qspi_type
  • instruction_code : qspi_cmd_type
  • instruction_length : qspi_cmd_type
  • intclr : sdio_type
  • intclr_bit : sdio_type
  • inten : can_type, exint_type, sdio_type
  • inten_bit : can_type, exint_type, sdio_type
  • intenx : exint_type
  • interface : usb_audio_hid_type, usb_audio_type
  • interframe_gap : emac_control_config_type
  • internel_banks : xmc_sdram_init_type
  • intkneptmismsk : otg_device_type
  • intkntxfemp : otg_eptin_type
  • intkntxfempmsk : otg_device_type
  • intsts : exint_type
  • intsts_bit : exint_type
  • intwt : sdio_type
  • iocb0 : gpio_type
  • iocb1 : gpio_type
  • iocb10 : gpio_type
  • iocb11 : gpio_type
  • iocb12 : gpio_type
  • iocb13 : gpio_type
  • iocb14 : gpio_type
  • iocb15 : gpio_type
  • iocb2 : gpio_type
  • iocb3 : gpio_type
  • iocb4 : gpio_type
  • iocb5 : gpio_type
  • iocb6 : gpio_type
  • iocb7 : gpio_type
  • iocb8 : gpio_type
  • iocb9 : gpio_type
  • ioen : sdio_type
  • iohizt : xmc_bank4_type
  • ioht : xmc_bank4_type
  • ioif : sdio_type
  • ioifien : sdio_type
  • iomc0 : gpio_type
  • iomc1 : gpio_type
  • iomc10 : gpio_type
  • iomc11 : gpio_type
  • iomc12 : gpio_type
  • iomc13 : gpio_type
  • iomc14 : gpio_type
  • iomc15 : gpio_type
  • iomc2 : gpio_type
  • iomc3 : gpio_type
  • iomc4 : gpio_type
  • iomc5 : gpio_type
  • iomc6 : gpio_type
  • iomc7 : gpio_type
  • iomc8 : gpio_type
  • iomc9 : gpio_type
  • iosb0 : gpio_type
  • iosb1 : gpio_type
  • iosb10 : gpio_type
  • iosb11 : gpio_type
  • iosb12 : gpio_type
  • iosb13 : gpio_type
  • iosb14 : gpio_type
  • iosb15 : gpio_type
  • iosb2 : gpio_type
  • iosb3 : gpio_type
  • iosb4 : gpio_type
  • iosb5 : gpio_type
  • iosb6 : gpio_type
  • iosb7 : gpio_type
  • iosb8 : gpio_type
  • iosb9 : gpio_type
  • iost : xmc_bank4_type
  • iosusp : sdio_type
  • iowt : xmc_bank4_type
  • ipc : emac_type
  • iProduct : usb_device_desc_type
  • ipv4_checksum_offload : emac_control_config_type
  • ir_pol : scfg_type
  • ir_src_sel : scfg_type
  • irdaen : usart_type
  • irdalp : usart_type
  • is_double_buffer : usb_ept_info
  • isdiv : usart_type
  • iSerialNumber : usb_device_desc_type
  • isooutdrop : otg_global_type
  • isooutdropmsk : otg_global_type
  • ists : dvp_type, emac_type, tmr_type
  • ists_bit : dvp_type, emac_type, tmr_type
  • itsrven : adccom_type


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- j -

  • jabber_disable : emac_control_config_type
  • jd : emac_type
  • jpeg : dvp_type


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- k -

  • keyboard_buf : keyboard_type
  • keyen : qspi_type


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- l -

  • l_unit_n : usbh_msc_type
  • last_access_data : fat_dir_type
  • last_len : usb_ept_info
  • last_time : tftp_connection_args
  • lbcp : usart_type
  • lben : can_type
  • lcd_clear : lcd_dev_type
  • lcd_id : lcd_dev_type
  • lcd_init : lcd_dev_type
  • lcd_setblock : lcd_dev_type
  • lcdc : dvp_type
  • lcds : dvp_type
  • ldoov : pwc_type
  • ldoov_bit : pwc_type
  • ldoovsel : pwc_type
  • left : http_state
  • len : fs_file, fsdata_file, fsdata_file_noconst
  • length : FlashEraseData, msc_scsi_data_inquiry, name
  • lextbyps : crm_type
  • lexten : crm_type
  • lextstbl : crm_type
  • lextstblf : crm_type
  • lextstblfc : crm_type
  • lextstblien : crm_type
  • licken : crm_type
  • lickstbl : crm_type
  • lickstblf : crm_type
  • lickstblfc : crm_type
  • lickstblien : crm_type
  • line_enable : exint_init_type
  • line_mode : exint_init_type
  • line_polarity : exint_init_type
  • line_select : exint_init_type
  • linecoding : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • linen : usart_type
  • linex : exint_type
  • llctrl : edma_type
  • llctrl_bit : edma_type
  • LLP : Descriptors_Format_def
  • llp : edma_stream_link_list_type, ll_descriptors_type
  • llp_bit : edma_stream_link_list_type
  • lm : dma_channel_type, edma_stream_type, emac_type
  • lnec : dvp_type
  • lneu : dvp_type
  • lnsc : dvp_type
  • lnsu : dvp_type
  • loen : can_type
  • loop_mode_enable : dma_init_type, edma_init_type
  • loopback_mode : emac_control_config_type
  • low_power : usb_core_cfg
  • lp_mode : otg_global_type
  • lprstf : crm_type
  • lpsel : pwc_type
  • lsamprx : can_type
  • lspddev : otg_hchannel_type
  • ltf : spi_type
  • lun : cbd_extended_type, cbd_typical_type


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- m -

  • m : ertc_reg_alarm_type, ertc_reg_date_type, ertc_reg_time_type, ertc_reg_tsdt_type, ertc_reg_tstm_type, ertc_type
  • M0A : Descriptors_Format_def
  • m0addr : edma_stream_type, ll_descriptors_type
  • m0addr_bit : edma_stream_type
  • m1addr : edma_stream_type
  • m1addr_bit : edma_stream_type
  • m2m : dma_channel_type
  • ma0h : emac_type
  • ma0l : emac_type
  • ma1h : emac_type
  • ma1l : emac_type
  • ma2h : emac_type
  • ma2l : emac_type
  • ma3h : emac_type
  • ma3l : emac_type
  • maddr : dma_channel_type
  • maddr_bit : dma_channel_type
  • maker_id : nand_id_type
  • manufact_date : sd_cid_struct_type
  • manufacturer_code : nor_idtype
  • manufacturer_default_ecc : sd_csd_struct_type
  • manufacturer_id : sd_cid_struct_type
  • mask : ertc_alarm_value_type
  • mask1 : ertc_reg_alarm_type, ertc_type
  • mask2 : ertc_reg_alarm_type, ertc_type
  • mask3 : ertc_reg_alarm_type, ertc_type
  • mask4 : ertc_reg_alarm_type, ertc_type
  • master_slave_mode : spi_init_type
  • max_bus_clk_freq : sd_csd_struct_type
  • max_lun : cdc_msc_struct_type, msc_type, usbh_msc_type
  • max_read_blk_length : sd_csd_struct_type
  • max_read_current_vdd_max : sd_csd_struct_type
  • max_read_current_vdd_min : sd_csd_struct_type
  • max_size : usb_core_cfg
  • max_write_blk_length : sd_csd_struct_type
  • max_write_current_vdd_max : sd_csd_struct_type
  • max_write_current_vdd_min : sd_csd_struct_type
  • maxpacket : usb_ept_info, usb_hch_type
  • mb : emac_type
  • mbc : emac_type
  • mc : otg_eptin_type, otg_hchannel_type
  • mclk_freq_division : spi_init_type
  • mclk_output_enable : i2s_init_type
  • mct : edma_stream_type
  • mctrl : can_type
  • mctrl_bit : can_type
  • md : emac_type
  • mdiv3en : spi_type
  • mdiv_h : spi_type
  • mdiv_l : spi_type
  • mdrsel : can_type
  • mdrsel_selection : can_base_type
  • mem_hiz_time : xmc_nand_pccard_timinginit_type
  • mem_hold_time : xmc_nand_pccard_timinginit_type
  • mem_map_sel : scfg_type
  • mem_setup_time : xmc_nand_pccard_timinginit_type
  • mem_waite_time : xmc_nand_pccard_timinginit_type
  • memory0_base_addr : edma_init_type
  • memory_base_addr : dma_init_type
  • memory_burst_mode : edma_init_type
  • memory_data_width : dma_init_type, edma_init_type
  • memory_inc_enable : dma_init_type, edma_init_type
  • mfbocnt : emac_dma_type
  • mfbocnt_bit : emac_dma_type
  • mfc : emac_dma_type
  • mibe : dvp_type
  • mibthd : dvp_type
  • mic_adj_count : audio_codec_type
  • mic_adj_stage : audio_codec_type
  • mic_alt_setting : usb_audio_hid_type, usb_audio_type
  • mic_buffer : audio_codec_type
  • mic_calc : audio_codec_type
  • mic_delta : audio_codec_type
  • mic_enable : audio_codec_type
  • mic_freq : usb_audio_hid_type, usb_audio_type
  • mic_mute : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • mic_roff : audio_codec_type
  • mic_rtotal : audio_codec_type
  • mic_rx_size : audio_codec_type
  • mic_stage : audio_codec_type
  • mic_volume : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • mic_volume_limits : usb_audio_hid_type, usb_audio_type
  • mic_wend : audio_codec_type
  • mic_woff : audio_codec_type
  • mic_wtotal : audio_codec_type
  • mii : emac_type
  • mii_rmii_sel : scfg_type
  • miiaddr : emac_type
  • miiaddr_bit : emac_type
  • miidt : emac_type
  • miidt_bit : emac_type
  • min : ertc_alarm_value_type, ertc_time_type
  • mincm : dma_channel_type, edma_stream_type
  • mis : emac_type
  • misc1 : crm_type
  • misc1_bit : crm_type
  • misc2 : crm_type
  • misc2_bit : crm_type
  • mmerr : spi_type
  • mmi : emac_dma_type
  • mmssr : can_type
  • mmssr_selection : can_base_type
  • mode : i2c_handle_type, xmc_norsram_timing_init_type
  • mode_selection : can_base_type
  • modemis : otg_global_type
  • modemismsk : otg_global_type
  • month : ertc_time_type
  • mouse_buffer : mouse_type
  • mpi : emac_dma_type
  • mps : otg_eptin_type, otg_eptout_type, otg_hchannel_type
  • mrd : xmc_sdram_type
  • mris : emac_type
  • msc_state : cdc_msc_struct_type, msc_type
  • msc_struct : msc_bot_trans_type
  • msc_up_status : flash_iap_type
  • msdmasel_h : adccom_type
  • msdmasel_l : adccom_type
  • msdrcen : adccom_type
  • mssel : adccom_type
  • msten : spi_type
  • msts : can_type
  • msts_bit : can_type
  • mtis : emac_type
  • muxctrl : dmamux_channel_type, edmamux_channel_type
  • muxctrl_bit : dmamux_channel_type, edmamux_channel_type
  • muxgclr : dma_type, edma_type
  • muxgclr_bit : dma_type, edma_type
  • muxgsts : dma_type, edma_type
  • muxgsts_bit : dma_type, edma_type
  • muxh : gpio_type
  • muxh10 : gpio_type
  • muxh11 : gpio_type
  • muxh12 : gpio_type
  • muxh13 : gpio_type
  • muxh14 : gpio_type
  • muxh15 : gpio_type
  • muxh8 : gpio_type
  • muxh9 : gpio_type
  • muxh_bit : gpio_type
  • muxl : gpio_type
  • muxl0 : gpio_type
  • muxl1 : gpio_type
  • muxl2 : gpio_type
  • muxl3 : gpio_type
  • muxl4 : gpio_type
  • muxl5 : gpio_type
  • muxl6 : gpio_type
  • muxl7 : gpio_type
  • muxl_bit : gpio_type
  • muxsel : dma_type, edma_type
  • muxsel_bit : dma_type, edma_type
  • muxsyncclr : dma_type, edma_type
  • muxsyncclr_bit : dma_type, edma_type
  • muxsyncsts : dma_type, edma_type
  • muxsyncsts_bit : dma_type, edma_type
  • mw : emac_type
  • mwidth : dma_channel_type, edma_stream_type
  • mwmc : xmc_bank1_ctrl_tmg_reg_type


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- n -

  • nacken : i2c_type
  • nak : otg_hchannel_type
  • nakmsk : otg_hchannel_type
  • naksts : otg_eptin_type, otg_eptout_type
  • name : default_filename, fsdata_file, fsdata_file_noconst
  • nand_bank : xmc_nand_init_type
  • nerr : usart_type
  • next : fsdata_file, fsdata_file_noconst
  • nie : emac_dma_type
  • nis : emac_dma_type
  • noren : xmc_bank1_ctrl_tmg_reg_type
  • nptxfdep : otg_global_type
  • nptxfemp : otg_global_type
  • nptxfemplvl : otg_global_type
  • nptxfempmsk : otg_global_type
  • nptxfspcavail : otg_global_type
  • nptxfstaddr : otg_global_type
  • nptxqspcavail : otg_global_type
  • nptxqtop : otg_global_type
  • nrstf : crm_type
  • nsac : sd_csd_struct_type
  • ntc : spi_type
  • nwasen : xmc_bank1_ctrl_tmg_reg_type
  • nwen : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • nwpol : xmc_bank1_ctrl_tmg_reg_type
  • nwsen : xmc_bank1_ctrl_tmg_reg_type
  • nwtcfg : xmc_bank1_ctrl_tmg_reg_type
  • nzstsouthshk : otg_device_type
  • nzw_bst : flash_type
  • nzw_bst_sts : flash_type


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- o -

  • oaddr1 : i2c_type
  • oaddr1_bit : i2c_type
  • oaddr2 : i2c_type
  • oaddr2_bit : i2c_type
  • obf : flash_type
  • obfoc : emac_dma_type
  • obmfc : emac_dma_type
  • oc_idle_state : tmr_output_config_type
  • oc_mode : tmr_output_config_type
  • oc_output_state : tmr_output_config_type
  • oc_polarity : tmr_output_config_type
  • occ_idle_state : tmr_output_config_type
  • occ_output_state : tmr_output_config_type
  • occ_polarity : tmr_output_config_type
  • occe : adc_type
  • occe1 : adccom_type
  • occe2 : adccom_type
  • occe3 : adccom_type
  • occeien : adc_type
  • occo : adc_type
  • occo1 : adccom_type
  • occo2 : adccom_type
  • occo3 : adccom_type
  • occoien : adc_type
  • occs : adc_type
  • occs1 : adccom_type
  • occs2 : adccom_type
  • occs3 : adccom_type
  • ocdmaen : adc_type
  • ocdrcen : adc_type
  • ocete : adc_type
  • oclen : adc_type
  • ocmen : tmr_type
  • ocpcnt : adc_type
  • ocpen : adc_type
  • ocswtrg : adc_type
  • octesel_h : adc_type
  • octesel_l : adc_type
  • ocvmen : adc_type
  • oddfrm : otg_hchannel_type
  • odf : flash_type
  • odfie : flash_type
  • odrv0 : gpio_type
  • odrv1 : gpio_type
  • odrv10 : gpio_type
  • odrv11 : gpio_type
  • odrv12 : gpio_type
  • odrv13 : gpio_type
  • odrv14 : gpio_type
  • odrv15 : gpio_type
  • odrv2 : gpio_type
  • odrv3 : gpio_type
  • odrv4 : gpio_type
  • odrv5 : gpio_type
  • odrv6 : gpio_type
  • odrv7 : gpio_type
  • odrv8 : gpio_type
  • odrv9 : gpio_type
  • odrvr : gpio_type
  • odrvr_bit : gpio_type
  • odt : adc_type, gpio_type
  • odt0 : gpio_type
  • odt1 : gpio_type
  • odt10 : gpio_type
  • odt11 : gpio_type
  • odt12 : gpio_type
  • odt13 : gpio_type
  • odt14 : gpio_type
  • odt15 : gpio_type
  • odt2 : gpio_type
  • odt3 : gpio_type
  • odt4 : gpio_type
  • odt5 : gpio_type
  • odt6 : gpio_type
  • odt7 : gpio_type
  • odt8 : gpio_type
  • odt9 : gpio_type
  • odt_bit : adc_type, gpio_type
  • oem_app_id : sd_cid_struct_type
  • oen : tmr_type
  • oeptint : otg_global_type
  • oeptintmsk : otg_global_type
  • ofc : emac_dma_type
  • offset_into_block : FlashParamsHolder
  • ofne : dvp_type
  • om0 : gpio_type
  • om1 : gpio_type
  • om10 : gpio_type
  • om11 : gpio_type
  • om12 : gpio_type
  • om13 : gpio_type
  • om14 : gpio_type
  • om15 : gpio_type
  • om2 : gpio_type
  • om3 : gpio_type
  • om4 : gpio_type
  • om5 : gpio_type
  • om6 : gpio_type
  • om7 : gpio_type
  • om8 : gpio_type
  • om9 : gpio_type
  • omode : gpio_type
  • omode_bit : gpio_type
  • oosen : adc_type
  • oosrsel : adc_type
  • oostren : adc_type
  • op : tftp_connection_args
  • opcode : cbd_extended_type, cbd_typical_type
  • operation_mode : i2s_init_type, qspi_cmd_type
  • opersel : spi_type
  • oplk : flash_type
  • opm : emac_dma_type
  • opm_bit : emac_dma_type
  • opmode : qspi_type
  • ora : spi_type
  • ordinary_channel_length : adc_base_config_type
  • osf : emac_dma_type
  • osf_enable : emac_dma_config_type
  • osn1 : adc_type
  • osn10 : adc_type
  • osn11 : adc_type
  • osn12 : adc_type
  • osn13 : adc_type
  • osn14 : adc_type
  • osn15 : adc_type
  • osn16 : adc_type
  • osn2 : adc_type
  • osn3 : adc_type
  • osn4 : adc_type
  • osn5 : adc_type
  • osn6 : adc_type
  • osn7 : adc_type
  • osn8 : adc_type
  • osn9 : adc_type
  • osq1 : adc_type
  • osq1_bit : adc_type
  • osq2 : adc_type
  • osq2_bit : adc_type
  • osq3 : adc_type
  • osq3_bit : adc_type
  • osrsel : adc_type
  • osssel : adc_type
  • otgfs1en : crm_type
  • otgfs1lpen : crm_type
  • otgfs1rst : crm_type
  • otgfs2en : crm_type
  • otgfs2lpen : crm_type
  • otgfs2rst : crm_type
  • otgint : otg_global_type
  • otgintmsk : otg_global_type
  • ouf : i2c_type
  • oufc : i2c_type
  • out_maxpacket : usbh_hid_type, usbh_msc_type
  • out_poll : usbh_hid_type, usbh_msc_type
  • outeptint : otg_device_type
  • outeptmsk : otg_device_type
  • outp : ertc_type
  • outperrmsk : otg_device_type
  • outsel : ertc_type
  • outtepd : otg_eptout_type
  • outtepdmsk : otg_device_type
  • outtype : ertc_type
  • ove : emac_dma_type
  • ovf : emac_dma_type
  • ovfden : tmr_type
  • ovfen : tmr_type
  • ovfien : tmr_type
  • ovfif : tmr_type
  • ovfs : tmr_type
  • ovfswtr : tmr_type
  • ovres : dvp_type
  • ovric : dvp_type
  • ovrie : dvp_type
  • ovris : dvp_type
  • ovsp : adc_type
  • ovsp_bit : adc_type


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- p -

  • PA : Descriptors_Format_def
  • pa : emac_type
  • paddr : dma_channel_type, edma_stream_type, ll_descriptors_type
  • paddr_bit : dma_channel_type, edma_stream_type
  • page : nand_address_type
  • parity : linecoding_type
  • part_blk_read : sd_csd_struct_type
  • part_blk_write : sd_csd_struct_type
  • pb10_uh : scfg_type
  • pb3_uh : scfg_type
  • pb9_uh : scfg_type
  • pbl : emac_dma_type
  • pblx8 : emac_dma_type
  • pbuff : i2c_handle_type
  • pcautoen : adc_type
  • pcb : http_state
  • pcce : adc_type
  • pcce1 : adccom_type
  • pcce2 : adccom_type
  • pcce3 : adccom_type
  • pcceien : adc_type
  • pccs : adc_type
  • pccs1 : adccom_type
  • pccs2 : adccom_type
  • pccs3 : adccom_type
  • pcdc : dvp_type
  • pcdes : dvp_type
  • pcds : dvp_type
  • pcdto1 : adc_type
  • pcdto1_bit : adc_type
  • pcdto2 : adc_type
  • pcdto2_bit : adc_type
  • pcdto3 : adc_type
  • pcdto3_bit : adc_type
  • pcdto4 : adc_type
  • pcdto4_bit : adc_type
  • pcete : adc_type
  • pcf : emac_type
  • pcgcctl : otg_pcgcctl_type
  • pcgcctl_bit : otg_pcgcctl_type
  • pclen : adc_type
  • pcmfssel : spi_type
  • pcount : i2c_handle_type
  • pcpen : adc_type
  • pcswtrg : adc_type
  • pct : edma_stream_type
  • pctesel_h : adc_type
  • pctesel_l : adc_type
  • pcvmen : adc_type
  • pd : emac_type
  • pd12_uh : scfg_type
  • pd13_uh : scfg_type
  • pd14_uh : scfg_type
  • pd15_uh : scfg_type
  • pdev_type : msc_scsi_data_inquiry
  • pdl : dvp_type
  • pdt1 : adc_type
  • pdt1_bit : adc_type
  • pdt2 : adc_type
  • pdt2_bit : adc_type
  • pdt3 : adc_type
  • pdt3_bit : adc_type
  • pdt4 : adc_type
  • pdt4_bit : adc_type
  • pe_mode_enable : qspi_cmd_type
  • pe_mode_operate_code : qspi_cmd_type
  • pec : i2c_type
  • pec_bit : i2c_type
  • pecen : i2c_type
  • pecerr : i2c_type
  • pecerrc : i2c_type
  • pecten : i2c_type
  • pecval : i2c_type
  • pemen : qspi_type
  • pemopc : qspi_type
  • pen : usart_type
  • perfrint : otg_device_type
  • peripheral_base_addr : dma_init_type, edma_init_type
  • peripheral_burst_mode : edma_init_type
  • peripheral_data_width : dma_init_type, edma_init_type
  • peripheral_inc_enable : dma_init_type, edma_init_type
  • permanent_write_protect : sd_csd_struct_type
  • perr : usart_type
  • perrien : usart_type
  • pf14_uh : scfg_type
  • pf15_uh : scfg_type
  • pfctrl : edma_stream_type
  • phy_itface : usb_core_cfg
  • pid : debug_type, otg_hchannel_type
  • pim : emac_type
  • pincm : dma_channel_type, edma_stream_type
  • pincos : edma_stream_type
  • pis : emac_type
  • piusftrst : otg_global_type
  • pktcnt : otg_eptin_type, otg_eptout_type, otg_hchannel_type
  • pktsts : otg_global_type
  • pllcfg : crm_type
  • pllcfg_bit : crm_type
  • pllen : crm_type
  • pllfr : crm_type
  • pllms : crm_type
  • pllns : crm_type
  • pllrcs : crm_type
  • pllstbl : crm_type
  • pllstblf : crm_type
  • pllstblfc : crm_type
  • pllstblien : crm_type
  • plt : emac_type
  • pmc : emac_type
  • pmen : tmr_type
  • pmtctrlsts : emac_type
  • pmtctrlsts_bit : emac_type
  • pndwt : sdio_type
  • pofc : emac_ptp_type
  • polcfg1 : exint_type
  • polcfg1_bit : exint_type
  • polcfg2 : exint_type
  • polcfg2_bit : exint_type
  • poll_timer : usbh_hid_type, usbh_msc_type
  • porrstf : crm_type
  • posen : adc_type
  • ppscr : emac_ptp_type
  • ppscr_bit : emac_ptp_type
  • pr : emac_dma_type, emac_type, tmr_type
  • pr_bit : tmr_type
  • prben : tmr_type
  • pre_state : usbh_msc_unit_type
  • prgmerr : flash_type
  • priority : dma_init_type, edma_init_type
  • priority_ratio : emac_dma_config_type
  • product : msc_scsi_data_inquiry
  • product_name1 : sd_cid_struct_type
  • product_name2 : sd_cid_struct_type
  • product_reversion : sd_cid_struct_type
  • product_sn : sd_cid_struct_type
  • protocol : usbh_hid_type, usbh_msc_type
  • prsf_enable : can_base_type
  • prsfen : can_type
  • prtaddr : otg_hchannel_type
  • prtcondet : otg_host_type
  • prtconsts : otg_host_type
  • prtena : otg_host_type
  • prtenchng : otg_host_type
  • prtint : otg_global_type
  • prtintmsk : otg_global_type
  • prtlnsts : otg_host_type
  • prtovrcact : otg_host_type
  • prtovrcchng : otg_host_type
  • prtpwr : otg_host_type
  • prtres : otg_host_type
  • prtrst : otg_host_type
  • prtspd : otg_host_type
  • prtsusp : otg_host_type
  • prttsctl : otg_host_type
  • ps : sdio_type
  • psel : usart_type
  • psize : i2c_handle_type
  • psn1 : adc_type
  • psn2 : adc_type
  • psn3 : adc_type
  • psn4 : adc_type
  • psq : adc_type
  • psq_bit : adc_type
  • psr : flash_type
  • psr_bit : flash_type
  • pt : emac_type
  • ptd : can_type
  • ptos : tmr_type
  • ptxfemp : otg_global_type
  • ptxfemplvl : otg_global_type
  • ptxfempmsk : otg_global_type
  • ptxfsize : otg_global_type
  • ptxfspcavil : otg_host_type
  • ptxfstaddr : otg_global_type
  • ptxqspcavil : otg_host_type
  • ptxqtop : otg_host_type
  • pull : gpio_type
  • pull0 : gpio_type
  • pull1 : gpio_type
  • pull10 : gpio_type
  • pull11 : gpio_type
  • pull12 : gpio_type
  • pull13 : gpio_type
  • pull14 : gpio_type
  • pull15 : gpio_type
  • pull2 : gpio_type
  • pull3 : gpio_type
  • pull4 : gpio_type
  • pull5 : gpio_type
  • pull6 : gpio_type
  • pull7 : gpio_type
  • pull8 : gpio_type
  • pull9 : gpio_type
  • pull_bit : gpio_type
  • pvmen : pwc_type
  • pvmof : pwc_type
  • pvmsel : pwc_type
  • pwcen : crm_type
  • pwclpen : crm_type
  • pwcrst : crm_type
  • pwidth : dma_channel_type, edma_stream_type
  • pwrctrl : sdio_type
  • pwrctrl_bit : sdio_type
  • pwrdown : otg_global_type
  • pwroprgdne : otg_device_type
  • pwrsven : sdio_type


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- q -

  • qdzien : can_type
  • qdzif : can_type
  • qspi1en : crm_type
  • qspi1lpen : crm_type
  • qspi1rst : crm_type
  • qspi2en : crm_type
  • qspi2lpen : crm_type
  • qspi2rst : crm_type
  • qspikey : usd_type


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- r -

  • ra : emac_type, xmc_sdram_type
  • raefacim : emac_mmc_type
  • rbu : emac_dma_type
  • rbue : emac_dma_type
  • rc : emac_mmc_type, xmc_sdram_type
  • rca : sd_card_info_struct_type
  • rcden : ertc_type
  • rcefcim : emac_mmc_type
  • rcnt : xmc_sdram_type
  • rcnt_bit : xmc_sdram_type
  • rcrc : spi_type
  • rcrc_bit : spi_type
  • rd : xmc_sdram_type
  • rdbf : i2c_type, spi_type, usart_type
  • rdbfie : spi_type
  • rdbfien : usart_type
  • rdien : i2c_type
  • rdladdr : emac_dma_type
  • rdladdr_bit : emac_dma_type
  • rdp : emac_dma_type
  • rdwtmode : sdio_type
  • rdwtstart : sdio_type
  • rdwtstop : sdio_type
  • rdy : adc_type
  • rdy1 : adccom_type
  • rdy2 : adccom_type
  • rdy3 : adccom_type
  • re : emac_type
  • read_address_length : qspi_xip_type
  • read_blk_misalign : sd_csd_struct_type
  • read_crc : flash_iap_type
  • read_data_counter : qspi_xip_type
  • read_delay : xmc_sdram_init_type
  • read_instruction_code : qspi_xip_type
  • read_operation_mode : qspi_xip_type
  • read_second_dummy_cycle_num : qspi_xip_type
  • read_select_mode : qspi_xip_type
  • read_status_config : qspi_cmd_type
  • read_status_enable : qspi_cmd_type
  • read_time_counter : qspi_xip_type
  • readh10 : i2c_type
  • ready : usbh_msc_unit_type
  • realrx : can_type
  • rec : can_type
  • receive_own_disable : emac_control_config_type
  • reien : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • rem0_len : usb_ept_info
  • ren : usart_type
  • repeat_mode : adc_base_config_type
  • reqcnt : dmamux_channel_type, edmamux_channel_type
  • reqsel : dmamux_channel_type, edmamux_channel_type
  • request_no : usb_audio_hid_type, usb_audio_type
  • res : fat_dir_type
  • Res : FlashDevice
  • res : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • reserved : msc_scsi_data_inquiry, tmr_type
  • reserved1 : acc_type, adc_type, adccom_type, can_fifo_mailbox_type, can_tx_mailbox_type, can_type, cbd_extended_type, cbd_typical_type, crc_type, crm_type, dac_type, debug_type, dma_channel_type, dma_type, dmamux_channel_type, dmamux_generator_type, dvp_type, edma_stream_type, edma_type, edmamux_channel_type, edmamux_generator_type, emac_dma_type, emac_mmc_type, emac_ptp_type, emac_type, ertc_reg_date_type, ertc_reg_scal_type, ertc_reg_tadj_type, ertc_reg_time_type, ertc_reg_tsdt_type, ertc_reg_tstm_type, ertc_type, exint_type, flash_type, gpio_type, i2c_type, otg_device_type, otg_eptin_type, otg_eptout_type, otg_global_type, otg_hchannel_type, otg_host_type, otg_pcgcctl_type, pwc_type, qspi_type, scfg_type, sd_cid_struct_type, sd_csd_struct_type, sd_scr_struct_type, sdio_type, sense_type, spi_type, tmr_type, usart_type, usd_type, wdt_type, wwdt_type, xmc_bank1_ctrl_tmg_reg_type, xmc_bank1_tmgwr_reg_type, xmc_bank1_type, xmc_bank2_type, xmc_bank3_type, xmc_bank4_type, xmc_sdram_type
  • reserved2 : acc_type, adc_type, adccom_type, can_tx_mailbox_type, can_type, cbd_extended_type, cbd_typical_type, crc_type, crm_type, dac_type, debug_type, dma_type, dmamux_channel_type, dmamux_generator_type, dvp_type, edma_stream_type, edma_type, edmamux_channel_type, edmamux_generator_type, emac_dma_type, emac_mmc_type, emac_ptp_type, emac_type, ertc_reg_date_type, ertc_reg_scal_type, ertc_reg_time_type, ertc_reg_tsdt_type, ertc_reg_tstm_type, ertc_type, flash_type, i2c_type, otg_device_type, otg_eptin_type, otg_eptout_type, otg_global_type, otg_hchannel_type, otg_host_type, otg_pcgcctl_type, pwc_type, qspi_type, scfg_type, sd_cid_struct_type, sd_csd_struct_type, sdio_type, sense_type, spi_type, tmr_type, usart_type, usd_type, xmc_bank1_ctrl_tmg_reg_type, xmc_bank1_tmgwr_reg_type, xmc_bank1_type, xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • reserved3 : acc_type, adccom_type, can_type, crm_type, dac_type, debug_type, dmamux_channel_type, dmamux_generator_type, dvp_type, edma_stream_type, edma_type, edmamux_channel_type, edmamux_generator_type, emac_dma_type, emac_mmc_type, emac_type, ertc_reg_time_type, ertc_reg_tstm_type, ertc_type, flash_type, i2c_type, otg_device_type, otg_eptin_type, otg_eptout_type, otg_global_type, otg_hchannel_type, qspi_type, scfg_type, sd_csd_struct_type, sense_type, tmr_type, usart_type, xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • reserved4 : adccom_type, can_type, crm_type, debug_type, dvp_type, edma_type, emac_dma_type, emac_mmc_type, emac_type, flash_type, otg_device_type, otg_global_type, qspi_type, sd_csd_struct_type
  • reserved5 : adccom_type, can_type, crm_type, dvp_type, edma_type, emac_dma_type, emac_type, flash_type, otg_global_type
  • reserved6 : can_type, crm_type, dvp_type, edma_type, emac_dma_type, flash_type, otg_global_type
  • reserved7 : crm_type, dvp_type, flash_type
  • reserved8 : dvp_type
  • reserverd2 : sd_scr_struct_type
  • reserverd3 : sd_scr_struct_type
  • respond_flag : iap_info_type
  • retries : http_state
  • retry_disable : emac_control_config_type
  • rev : qspi_type
  • rev_bit : qspi_type
  • revid : crc_type
  • revision : msc_scsi_data_inquiry
  • revod : crc_type
  • rf0 : can_type
  • rf0_bit : can_type
  • rf0ff : can_type
  • rf0fien : can_type
  • rf0mien : can_type
  • rf0mn : can_type
  • rf0of : can_type
  • rf0oien : can_type
  • rf0r : can_type
  • rf1 : can_type
  • rf1_bit : can_type
  • rf1ff : can_type
  • rf1fien : can_type
  • rf1mien : can_type
  • rf1mn : can_type
  • rf1of : can_type
  • rf1oien : can_type
  • rf1r : can_type
  • rfae : emac_mmc_type
  • rfaec : emac_mmc_type
  • rfaecnt : emac_mmc_type
  • rfaecnt_bit : emac_mmc_type
  • rfc : can_fifo_mailbox_type
  • rfc_bit : can_fifo_mailbox_type
  • rfce : emac_mmc_type
  • rfcec : emac_mmc_type
  • rfcecnt : emac_mmc_type
  • rfcecnt_bit : emac_mmc_type
  • rfdt0 : can_fifo_mailbox_type
  • rfdt1 : can_fifo_mailbox_type
  • rfdt2 : can_fifo_mailbox_type
  • rfdt3 : can_fifo_mailbox_type
  • rfdt4 : can_fifo_mailbox_type
  • rfdt5 : can_fifo_mailbox_type
  • rfdt6 : can_fifo_mailbox_type
  • rfdt7 : can_fifo_mailbox_type
  • rfdth : can_fifo_mailbox_type
  • rfdth_bit : can_fifo_mailbox_type
  • rfdtl : can_fifo_mailbox_type
  • rfdtl_bit : can_fifo_mailbox_type
  • rfeid : can_fifo_mailbox_type
  • rffmn : can_fifo_mailbox_type
  • rffri : can_fifo_mailbox_type
  • rfi : can_fifo_mailbox_type
  • rfi_bit : can_fifo_mailbox_type
  • rfidi : can_fifo_mailbox_type
  • rfsid : can_fifo_mailbox_type
  • rfts : can_fifo_mailbox_type
  • rguf : emac_mmc_type
  • rgufc : emac_mmc_type
  • rgufcnt : emac_mmc_type
  • rgufcnt_bit : emac_mmc_type
  • ri : emac_dma_type, emac_mmc_type
  • ri_bit : emac_mmc_type
  • rie : emac_dma_type
  • rim : emac_mmc_type
  • rim_bit : emac_mmc_type
  • rld : wdt_type
  • rld_bit : wdt_type
  • rlden : i2c_type
  • rldf : wdt_type, wwdt_type
  • rldien : wwdt_type
  • rm : usart_type
  • rmb : msc_scsi_data_inquiry
  • rmp : emac_type, tmr_type
  • rmp_bit : tmr_type
  • roerr : spi_type, usart_type
  • row_address : xmc_sdram_init_type
  • rpd : emac_dma_type
  • rpd_bit : emac_dma_type
  • rpen : adc_type
  • rpr : tmr_type
  • rpr_bit : tmr_type
  • rps : emac_dma_type
  • rpx : exint_type
  • rr : emac_mmc_type
  • rrwf : emac_type
  • rs : emac_dma_type
  • rs485en : usart_type
  • rsaw : can_type
  • rsaw_size : can_baudrate_type
  • rse : emac_dma_type
  • rsf : emac_dma_type
  • rsf_enable : emac_dma_config_type
  • rslost : acc_type
  • rsp1 : sdio_type
  • rsp1_bit : sdio_type
  • rsp2 : sdio_type
  • rsp2_bit : sdio_type
  • rsp3 : sdio_type
  • rsp3_bit : sdio_type
  • rsp4 : sdio_type
  • rsp4_bit : sdio_type
  • rsp_type : sdio_command_struct_type
  • rspcmd : sdio_type
  • rspcmd_bit : sdio_type
  • rspwt : sdio_type
  • rst : crc_type
  • rstfc : crm_type
  • rsts : qspi_type
  • rsts_bit : qspi_type
  • rstsc : qspi_type
  • rstsen : qspi_type
  • rtc : emac_dma_type
  • rtsen : usart_type
  • rugfcim : emac_mmc_type
  • rwff : emac_type
  • rwffpr : emac_type
  • rwkupsig : otg_device_type
  • rwt : emac_dma_type
  • rwtd : xmc_bank1_ctrl_tmg_reg_type
  • rwte : emac_dma_type
  • rx_addr : usb_ept_info
  • rx_dma_pal : emac_dma_config_type
  • rx_threshold : emac_dma_config_type
  • rxbuf : sdio_type
  • rxbufe : sdio_type
  • rxbufeien : sdio_type
  • rxbuff : sdio_type
  • rxbuffien : sdio_type
  • rxbufh : sdio_type
  • rxbufhien : sdio_type
  • rxbufien : sdio_type
  • rxdpid_setupcnt : otg_eptout_type
  • rxdt : i2c_type
  • rxdt_bit : i2c_type
  • rxerro : sdio_type
  • rxerroien : sdio_type
  • rxfdep : otg_global_type
  • rxfflsh : otg_global_type
  • rxfifo_thod : qspi_type
  • rxfifordy : qspi_type
  • rxflvl : otg_global_type
  • rxflvlmsk : otg_global_type


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- s -

  • s : ertc_reg_alarm_type, ertc_reg_time_type, ertc_reg_tstm_type, ertc_type
  • s12den : edma_type
  • s1llen : edma_type
  • s22den : edma_type
  • s2dcnt : edma_stream_2d_type
  • s2dcnt_bit : edma_stream_2d_type
  • s2dctrl : edma_type
  • s2dctrl_bit : edma_type
  • s2llen : edma_type
  • s32den : edma_type
  • s3llen : edma_type
  • s42den : edma_type
  • s4llen : edma_type
  • s52den : edma_type
  • s5llen : edma_type
  • s62den : edma_type
  • s6llen : edma_type
  • s72den : edma_type
  • s7llen : edma_type
  • s82den : edma_type
  • s8llen : edma_type
  • sa : emac_type
  • saddr : i2c_type
  • saf : emac_type
  • saif : emac_type
  • sampling_interval : adc_common_config_type
  • sbf : usart_type
  • sbiterr : sdio_type
  • sbiterrien : sdio_type
  • sbs : ertc_type
  • sbs_bit : ertc_type
  • sbsmsk : ertc_type
  • scal : ertc_reg_scal_type, ertc_type
  • scal_bit : ertc_reg_scal_type, ertc_type
  • scfgen : crm_type
  • scfglpen : crm_type
  • scfgrst : crm_type
  • scgt : usart_type
  • sckmode : qspi_type
  • scld : i2c_type
  • sclh : i2c_type
  • sclk_freq : crm_clocks_freq_type
  • sclksel : crm_type
  • sclksts : crm_type
  • scll : i2c_type
  • scmen : usart_type
  • scnacken : usart_type
  • scr : dvp_type, emac_mmc_type, gpio_type
  • scr_bit : dvp_type, gpio_type
  • scr_structure : sd_scr_struct_type
  • sctrl : i2c_type
  • sd_bus_width : sd_scr_struct_type
  • sd_cid_reg : sd_card_info_struct_type
  • sd_csd_reg : sd_card_info_struct_type
  • sd_scr_reg : sd_card_info_struct_type
  • sd_security : sd_scr_struct_type
  • sd_spec : sd_scr_struct_type
  • sd_spec3 : sd_scr_struct_type
  • sdad : i2c_type
  • sdio1en : crm_type
  • sdio1lpen : crm_type
  • sdio1rst : crm_type
  • sdio2en : crm_type
  • sdio2lpen : crm_type
  • sdio2rst : crm_type
  • sdir : i2c_type
  • sdram_bank : xmc_sdram_init_type
  • sec : ertc_alarm_value_type, ertc_time_type
  • secers : flash_type
  • second_dummy_cycle_num : qspi_cmd_type
  • sector_mask : flash_iap_type
  • sector_size : flash_iap_type, iap_info_type
  • sectors : FlashDevice
  • sef : pwc_type
  • sen : edma_stream_type
  • sense_key : sense_type
  • sequence_mode : adc_base_config_type
  • sesenddet : otg_global_type
  • set_slib_strt : flash_type
  • setd0pid : otg_eptin_type, otg_eptout_type
  • setd1pid : otg_eptin_type, otg_eptout_type
  • setup : otg_eptout_type
  • setupmsk : otg_device_type
  • sftdiscon : otg_device_type
  • sgnpinak : otg_device_type
  • sgoutnak : otg_device_type
  • shtml : default_filename
  • sigsel : dmamux_generator_type, edmamux_generator_type
  • sixth_id : nand_id_type
  • slben : spi_type, usart_type
  • slbtd : spi_type
  • sleep_debug : debug_type
  • slib_enf : flash_type
  • slib_es : flash_type
  • slib_es_set : flash_type
  • slib_inst_ss : flash_type
  • slib_iss_set : flash_type
  • slib_misc_sts : flash_type
  • slib_misc_sts_bit : flash_type
  • slib_pclr_val : flash_type
  • slib_pset_val : flash_type
  • slib_pwd_clr : flash_type
  • slib_pwd_clr_bit : flash_type
  • slib_pwd_err : flash_type
  • slib_pwd_ok : flash_type
  • slib_rcnt : flash_type
  • slib_set_pwd : flash_type
  • slib_set_pwd_bit : flash_type
  • slib_set_range0 : flash_type
  • slib_set_range0_bit : flash_type
  • slib_set_range1 : flash_type
  • slib_set_range1_bit : flash_type
  • slib_ss : flash_type
  • slib_ss_set : flash_type
  • slib_sts0 : flash_type
  • slib_sts0_bit : flash_type
  • slib_sts1 : flash_type
  • slib_sts1_bit : flash_type
  • slib_sts2 : flash_type
  • slib_sts2_bit : flash_type
  • slib_ukval : flash_type
  • slib_ulkf : flash_type
  • slib_unlock : flash_type
  • slib_unlock_bit : flash_type
  • sm : dvp_type
  • smbalert : i2c_type
  • smsel : tmr_type
  • snak : otg_eptin_type, otg_eptout_type
  • snpm : otg_eptout_type
  • sof : otg_global_type
  • sof_out : usb_core_cfg
  • soffn : otg_device_type
  • sofmsk : otg_global_type
  • sofouten : otg_global_type
  • spec_version : sd_csd_struct_type
  • speed : usb_core_cfg, usb_hch_type
  • spi1en : crm_type
  • spi1lpen : crm_type
  • spi1rst : crm_type
  • spi2en : crm_type
  • spi2lpen : crm_type
  • spi2rst : crm_type
  • spi3en : crm_type
  • spi3lpen : crm_type
  • spi3rst : crm_type
  • spi4en : crm_type
  • spi4lpen : crm_type
  • spi4rst : crm_type
  • spiadr : qspi_type
  • spien : spi_type
  • spifsize : qspi_type
  • spists : qspi_type
  • spk_alt_setting : usb_audio_hid_type, usb_audio_type
  • spk_buffer : audio_codec_type
  • spk_calc : audio_codec_type
  • spk_enable : audio_codec_type
  • spk_freq : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • spk_mute : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • spk_rend : audio_codec_type
  • spk_roff : audio_codec_type
  • spk_rtotal : audio_codec_type
  • spk_stage : audio_codec_type
  • spk_threshold : audio_codec_type
  • spk_tx_size : audio_codec_type
  • spk_volume : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • spk_volume_limits : usb_audio_hid_type, usb_audio_type
  • spk_woff : audio_codec_type
  • spk_wtotal : audio_codec_type
  • spl : edma_stream_type
  • spltena : otg_hchannel_type
  • sppfts : emac_ptp_type
  • sprst : can_type
  • spt1 : adc_type
  • spt1_bit : adc_type
  • spt2 : adc_type
  • spt2_bit : adc_type
  • sqen : adc_type
  • srcstd : edma_stream_2d_type
  • srl : emac_dma_type
  • ssb : usd_type
  • ssinc : emac_ptp_type
  • ssinc_bit : emac_ptp_type
  • ssiv : emac_ptp_type
  • ssr : emac_dma_type
  • sstc : emac_dma_type
  • stall : otg_eptin_type, otg_eptout_type, otg_hchannel_type, usb_ept_info, usb_hch_type
  • stallmsk : otg_hchannel_type
  • standard_id : can_rx_message_type, can_tx_message_type
  • standby_debug : debug_type
  • start : FlashEraseData
  • state : iap_info_type, usb_hch_type, usbh_hid_type, usbh_msc_type, usbh_msc_unit_type
  • status : emac_dma_desc_type, i2c_handle_type, usb_ept_info, usb_hch_type
  • stctrl : tmr_type
  • stctrl_bit : tmr_type
  • stdby_rst : flash_type
  • stdsel : spi_type
  • step : acc_type
  • stis : tmr_type
  • stl : emac_dma_type
  • stopbn : usart_type
  • stopc : i2c_type
  • stopf : i2c_type
  • stopien : i2c_type
  • stoppclk : otg_pcgcctl_type
  • stretch : i2c_type
  • stride : edma_stream_2d_type
  • stride_bit : edma_stream_2d_type
  • sts : acc_type, adc_type, dac_type, dma_type, dvp_type, emac_dma_type, ertc_type, flash_type, i2c_type, sdio_type, spi_type, tmr_type, usart_type, wdt_type, wwdt_type, xmc_sdram_type
  • sts1 : edma_type
  • sts1_bit : edma_type
  • sts2 : edma_type, flash_type
  • sts2_bit : edma_type, flash_type
  • sts_bit : acc_type, adc_type, dac_type, dma_type, dvp_type, emac_dma_type, ertc_type, flash_type, i2c_type, sdio_type, spi_type, usart_type, wdt_type, wwdt_type, xmc_sdram_type
  • subbank : xmc_norsram_init_type, xmc_norsram_timing_init_type
  • sur : dvp_type
  • sur_bit : dvp_type
  • suspendm : otg_pcgcctl_type
  • suspsts : otg_device_type
  • swap_xmc : scfg_type
  • swcsen : spi_type
  • swcsil : spi_type
  • swef : pwc_type
  • swevt : tmr_type
  • swevt_bit : tmr_type
  • swpen1 : pwc_type
  • swpen2 : pwc_type
  • swr : emac_dma_type
  • swrstf : crm_type
  • swtrg : dac_type, exint_type
  • swtrg_bit : dac_type, exint_type
  • swtx : exint_type
  • sync_enable : dmamux_sync_init_type, edmamux_sync_init_type
  • sync_event_enable : dmamux_sync_init_type, edmamux_sync_init_type
  • sync_polarity : dmamux_sync_init_type, edmamux_sync_init_type
  • sync_request_number : dmamux_sync_init_type, edmamux_sync_init_type
  • sync_signal_sel : dmamux_sync_init_type, edmamux_sync_init_type
  • syncben : xmc_bank1_ctrl_tmg_reg_type
  • syncen : dmamux_channel_type, edmamux_channel_type
  • syncovf : dma_type, edma_type
  • syncovfc : dma_type, edma_type
  • syncovien : dmamux_channel_type, edmamux_channel_type
  • syncpol : dmamux_channel_type, edmamux_channel_type
  • syncsel : dmamux_channel_type, edmamux_channel_type
  • szDev : FlashDevice
  • szPage : FlashDevice
  • szSector : FlashSectors


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- t -

  • t : sc_atr_type
  • t0 : sc_atr_type
  • taac : sd_csd_struct_type
  • tadj : ertc_reg_tadj_type, ertc_type
  • tadj_bit : ertc_reg_tadj_type, ertc_type
  • tadjf : ertc_type
  • tail : usart_group_type
  • tamp : ertc_type
  • tamp_bit : ertc_type
  • tar : emac_ptp_type, xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • tblsel : dma_type, edma_type
  • tbu : emac_dma_type
  • tcdt : usart_type
  • tcien : can_type
  • tcr : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • tcrc : spi_type
  • tcrc_bit : spi_type
  • tcrld : i2c_type
  • tdbe : i2c_type, spi_type, usart_type
  • tdbeie : spi_type
  • tdbeien : usart_type
  • tdbrc : emac_ptp_type
  • tdc : i2c_type, usart_type
  • tdcien : i2c_type, usart_type
  • tden : tmr_type
  • tdien : i2c_type
  • tdis : i2c_type
  • tdladdr : emac_dma_type
  • tdladdr_bit : emac_dma_type
  • te : emac_ptp_type, emac_type
  • tec : can_type
  • temp : keyboard_type
  • temp_write_protect : sd_csd_struct_type
  • tempervintrv_state : adc_common_config_type
  • ten : usart_type
  • tfcnt : emac_mmc_type
  • tfcnt_bit : emac_mmc_type
  • tfcu : emac_ptp_type
  • tfmscc : emac_mmc_type
  • tfmscc_bit : emac_mmc_type
  • tfrdir : sdio_type
  • tfren : sdio_type
  • tfrmode : sdio_type
  • tfscc : emac_mmc_type
  • tfscc_bit : emac_mmc_type
  • tgf : emac_mmc_type
  • tgfc : emac_mmc_type
  • tgfcim : emac_mmc_type
  • tgfmsc : emac_mmc_type
  • tgfmscc : emac_mmc_type
  • tgfscc : emac_mmc_type
  • third_id : nand_id_type
  • ti : emac_dma_type, emac_mmc_type, emac_ptp_type
  • ti_bit : emac_mmc_type
  • tie : emac_dma_type
  • tien : spi_type, tmr_type
  • tim : emac_mmc_type, emac_type
  • tim_bit : emac_mmc_type
  • time : ertc_reg_time_type, ertc_type
  • time_bit : ertc_reg_time_type, ertc_type
  • timeout : i2c_type, otg_eptin_type, sdio_data_struct_type, sdio_type
  • timeout_bit : i2c_type
  • timeoutmsk : otg_device_type
  • tis : emac_type
  • tite : emac_ptp_type
  • tje : emac_dma_type
  • tjt : emac_dma_type
  • tlength : sc_atr_type
  • tm : xmc_sdram_type
  • tm0alf : can_type
  • tm0ct : can_type
  • tm0ef : can_type
  • tm0lpf : can_type
  • tm0tcf : can_type
  • tm0tef : can_type
  • tm0tsf : can_type
  • tm1alf : can_type
  • tm1ct : can_type
  • tm1ef : can_type
  • tm1lpf : can_type
  • tm1tcf : can_type
  • tm1tef : can_type
  • tm1tsf : can_type
  • tm2alf : can_type
  • tm2ct : can_type
  • tm2ef : can_type
  • tm2lpf : can_type
  • tm2tcf : can_type
  • tm2tef : can_type
  • tm2tsf : can_type
  • tm_bit : xmc_sdram_type
  • tmc : can_tx_mailbox_type
  • tmc_bit : can_tx_mailbox_type
  • tmcgfcim : emac_mmc_type
  • tmdt0 : can_tx_mailbox_type
  • tmdt1 : can_tx_mailbox_type
  • tmdt2 : can_tx_mailbox_type
  • tmdt3 : can_tx_mailbox_type
  • tmdt4 : can_tx_mailbox_type
  • tmdt5 : can_tx_mailbox_type
  • tmdt6 : can_tx_mailbox_type
  • tmdt7 : can_tx_mailbox_type
  • tmdtbl : can_tx_mailbox_type
  • tmdth : can_tx_mailbox_type
  • tmdth_bit : can_tx_mailbox_type
  • tmdtl : can_tx_mailbox_type
  • tmdtl_bit : can_tx_mailbox_type
  • tmeid : can_tx_mailbox_type
  • tmfrsel : can_tx_mailbox_type
  • tmgwr_group : xmc_bank1_type
  • tmi : can_tx_mailbox_type
  • tmi_bit : can_tx_mailbox_type
  • tmidsel : can_tx_mailbox_type
  • tmnr : can_type
  • tmout : i2c_type
  • tmoutc : i2c_type
  • tmr10_pause : debug_type
  • tmr10en : crm_type
  • tmr10lpen : crm_type
  • tmr10rst : crm_type
  • tmr11_pause : debug_type
  • tmr11en : crm_type
  • tmr11lpen : crm_type
  • tmr11rst : crm_type
  • tmr12_pause : debug_type
  • tmr12en : crm_type
  • tmr12lpen : crm_type
  • tmr12rst : crm_type
  • tmr13_pause : debug_type
  • tmr13en : crm_type
  • tmr13lpen : crm_type
  • tmr13rst : crm_type
  • tmr14_pause : debug_type
  • tmr1_pause : debug_type
  • tmr1en : crm_type
  • tmr1lpen : crm_type
  • tmr1rst : crm_type
  • tmr20_pause : debug_type
  • tmr20en : crm_type
  • tmr20lpen : crm_type
  • tmr20rst : crm_type
  • tmr2_ch1_irmp : tmr_type
  • tmr2_pause : debug_type
  • tmr2en : crm_type
  • tmr2lpen : crm_type
  • tmr2rst : crm_type
  • tmr3_pause : debug_type
  • tmr3en : crm_type
  • tmr3lpen : crm_type
  • tmr3rst : crm_type
  • tmr4_pause : debug_type
  • tmr4en : crm_type
  • tmr4lpen : crm_type
  • tmr4rst : crm_type
  • tmr5_ch4_irmp : tmr_type
  • tmr5_pause : debug_type
  • tmr5en : crm_type
  • tmr5lpen : crm_type
  • tmr5rst : crm_type
  • tmr6_pause : debug_type
  • tmr6en : crm_type
  • tmr6lpen : crm_type
  • tmr6rst : crm_type
  • tmr7_pause : debug_type
  • tmr7en : crm_type
  • tmr7lpen : crm_type
  • tmr7rst : crm_type
  • tmr8_pause : debug_type
  • tmr8en : crm_type
  • tmr8lpen : crm_type
  • tmr8rst : crm_type
  • tmr9_pause : debug_type
  • tmr9en : crm_type
  • tmr9lpen : crm_type
  • tmr9rst : crm_type
  • tmrd : xmc_sdram_timing_type, xmc_sdram_type
  • tmren : tmr_type
  • tmsid : can_tx_mailbox_type
  • tmsr : can_tx_mailbox_type
  • tmts : can_tx_mailbox_type
  • tmtsten : can_tx_mailbox_type
  • to_ip : tftp_connection_args
  • to_port : tftp_connection_args
  • toen : i2c_type
  • toErase : FlashDevice
  • toggle_in : usb_hch_type
  • toggle_out : usb_hch_type
  • tomode : i2c_type
  • toProg : FlashDevice
  • tot_bytes : tftp_connection_args
  • total_len : usb_ept_info
  • totime : i2c_type
  • touch_adjust : touch_dev_type
  • touch_read_xy : touch_dev_type
  • touch_scan : touch_dev_type
  • toutcal : otg_global_type
  • tp1edg : ertc_type
  • tp1en : ertc_type
  • tp1f : ertc_type
  • tp1pin : ertc_type
  • tp2edg : ertc_type
  • tp2en : ertc_type
  • tp2f : ertc_type
  • tpd : emac_dma_type
  • tpd_bit : emac_dma_type
  • tpflt : ertc_type
  • tpfreq : ertc_type
  • tpien : ertc_type
  • tppr : ertc_type
  • tppu : ertc_type
  • tps : emac_dma_type
  • tptsen : ertc_type
  • trans_buf : usb_ept_info, usb_hch_type
  • trans_count : usb_hch_type
  • trans_len : usb_ept_info, usb_hch_type
  • trans_type : usb_ept_info
  • transfer_direction : sdio_data_struct_type
  • transfer_mode : sdio_data_struct_type
  • transmission_mode : spi_init_type
  • tras : xmc_sdram_timing_type, xmc_sdram_type
  • trc : xmc_sdram_timing_type, xmc_sdram_type
  • trcd : xmc_sdram_timing_type, xmc_sdram_type
  • trgif : tmr_type
  • trgout2en : tmr_type
  • trgovf : dma_type, edma_type
  • trgovfc : dma_type, edma_type
  • trgovien : dmamux_generator_type, edmamux_generator_type
  • trgswtr : tmr_type
  • trp : xmc_sdram_timing_type, xmc_sdram_type
  • trpswap : usart_type
  • ts : emac_dma_type, emac_ptp_type, sc_atr_type
  • tsad : emac_ptp_type
  • tsad_bit : emac_ptp_type
  • tscgfci : emac_mmc_type
  • tscgfcim : emac_mmc_type
  • tsctrl : emac_ptp_type
  • tsctrl_bit : emac_ptp_type
  • tsdt : ertc_reg_tsdt_type, ertc_type, usart_type
  • tsdt_bit : ertc_reg_tsdt_type, ertc_type
  • tse : emac_dma_type
  • tsedg : ertc_type
  • tsen : ertc_type
  • tsf : emac_dma_type, ertc_type
  • tsf_enable : emac_dma_config_type
  • tsh : emac_ptp_type
  • tsh_bit : emac_ptp_type
  • tshud : emac_ptp_type
  • tshud_bit : emac_ptp_type
  • tsien : ertc_type
  • tsl : emac_ptp_type
  • tsl_bit : emac_ptp_type
  • tslud : emac_ptp_type
  • tslud_bit : emac_ptp_type
  • tso : emac_ptp_type
  • tsof : ertc_type
  • tspin : ertc_type
  • tss : emac_ptp_type
  • tssbs : ertc_type
  • tssbs_bit : ertc_type
  • tssr : emac_ptp_type
  • tssr_bit : emac_ptp_type
  • tstctl : otg_device_type
  • tstm : ertc_reg_tstm_type, ertc_type
  • tstm_bit : ertc_reg_tstm_type, ertc_type
  • tsts : can_type
  • tsts_bit : can_type
  • ttc : emac_dma_type
  • ttc_enable : can_base_type
  • ttcen : can_type
  • tth : emac_ptp_type
  • tth_bit : emac_ptp_type
  • tti : emac_dma_type
  • ttl : emac_ptp_type
  • ttl_bit : emac_ptp_type
  • ttlr : emac_ptp_type
  • ttsr : emac_ptp_type
  • tttr : emac_ptp_type
  • tu : emac_ptp_type
  • tue : emac_dma_type
  • tuerr : spi_type
  • twr : xmc_sdram_timing_type, xmc_sdram_type
  • tx_addr : usb_ept_info
  • tx_dma_pal : emac_dma_config_type
  • tx_length : iap_info_type
  • tx_mailbox : can_type
  • tx_threshold : emac_dma_config_type
  • txbuf : sdio_type
  • txbufe : sdio_type
  • txbufeien : sdio_type
  • txbuff : sdio_type
  • txbuffien : sdio_type
  • txbufh : sdio_type
  • txbufhien : sdio_type
  • txbufien : sdio_type
  • txdt : i2c_type
  • txdt_bit : i2c_type
  • txerru : sdio_type
  • txerruien : sdio_type
  • txfemp : otg_eptin_type
  • txfflsh : otg_global_type
  • txfifo_thod : qspi_type
  • txfifordy : qspi_type
  • txfifoudrmsk : otg_device_type
  • txfnum : otg_eptin_type, otg_global_type
  • txsr : xmc_sdram_timing_type, xmc_sdram_type


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- u -

  • uart4en : crm_type
  • uart4lpen : crm_type
  • uart4rst : crm_type
  • uart5en : crm_type
  • uart5lpen : crm_type
  • uart5rst : crm_type
  • uart7en : crm_type
  • uart7lpen : crm_type
  • uart7rst : crm_type
  • uart8en : crm_type
  • uart8lpen : crm_type
  • uart8rst : crm_type
  • uen : usart_type
  • uhdrv : scfg_type
  • uhdrv_bit : scfg_type
  • uint32_t : dvp_type
  • ukval : flash_type
  • une : emac_dma_type
  • unf : emac_dma_type
  • unlock : flash_type
  • unlock2 : flash_type
  • unlock2_bit : flash_type
  • unlock_bit : flash_type
  • updf : ertc_type
  • urb_sts : usb_hch_type
  • usart1en : crm_type
  • usart1lpen : crm_type
  • usart1rst : crm_type
  • usart2en : crm_type
  • usart2lpen : crm_type
  • usart2rst : crm_type
  • usart3en : crm_type
  • usart3lpen : crm_type
  • usart3rst : crm_type
  • usart6en : crm_type
  • usart6lpen : crm_type
  • usart6rst : crm_type
  • usb_id : usb_core_cfg
  • usb_reg : otg_core_type
  • usbacept : otg_eptin_type, otg_eptout_type
  • usbdiv : crm_type
  • usbrst : otg_global_type
  • usbrstmsk : otg_global_type
  • usbsusp : otg_global_type
  • usbsuspmsk : otg_global_type
  • usbtrdtim : otg_global_type
  • usd : flash_type
  • usd_bit : flash_type
  • usd_ukval : flash_type
  • usd_unlock : flash_type
  • usd_unlock_bit : flash_type
  • usderr : flash_type
  • usders : flash_type
  • usdprgm : flash_type
  • usdulks : flash_type
  • use_lun : usbh_msc_type
  • user_d0 : flash_type
  • user_d1 : flash_type
  • userid : otg_global_type
  • usp : emac_dma_type
  • usp_enable : emac_dma_config_type


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- v -

  • val : ertc_type
  • valEmpty : FlashDevice
  • vbat_state : adc_common_config_type
  • vbaten : adccom_type
  • vbusig : otg_global_type, usb_core_cfg
  • vendor : msc_scsi_data_inquiry
  • Vers : FlashDevice
  • version : msc_scsi_data_inquiry
  • vlt : emac_type
  • vlt_bit : emac_type
  • vmcsel : adc_type
  • vmhb : adc_type
  • vmhb_bit : adc_type
  • vmlb : adc_type
  • vmlb_bit : adc_type
  • vmor : adc_type
  • vmor1 : adccom_type
  • vmor2 : adccom_type
  • vmor3 : adccom_type
  • vmorien : adc_type
  • vmsgen : adc_type
  • vrsel : pwc_type
  • vscf : dvp_type
  • vscf_bit : dvp_type
  • vseid : dvp_type
  • vses : dvp_type
  • vsic : dvp_type
  • vsie : dvp_type
  • vsis : dvp_type
  • vsp : dvp_type
  • vsrss : dvp_type
  • vsrts : dvp_type
  • vsyn : dvp_type
  • vti : emac_type


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- w -

  • wait_enable : xmc_nand_init_type
  • wait_signal_config : xmc_norsram_init_type
  • wait_signal_enable : xmc_norsram_init_type
  • wait_signal_lv : xmc_norsram_init_type
  • wait_type : sdio_command_struct_type
  • wat : ertc_type
  • wat_bit : ertc_type
  • watchdog_disable : emac_control_config_type
  • watclk : ertc_type
  • waten : ertc_type
  • watf : ertc_type
  • watien : ertc_type
  • watwf : ertc_type
  • wd : emac_type
  • wdt_ato_en : flash_type
  • wdt_depslp : flash_type
  • wdt_pause : debug_type
  • wdt_stdby : flash_type
  • wdtrstf : crm_type
  • week : ertc_alarm_value_type, ertc_time_type
  • week_date_sel : ertc_alarm_value_type
  • wen : qspi_type, xmc_bank1_ctrl_tmg_reg_type
  • width : xmc_sdram_init_type
  • win : wdt_type, wwdt_type
  • win_bit : wdt_type
  • wIndex : usb_setup_type
  • wItemLength : usb_hid_desc_type
  • wk : ertc_reg_date_type, ertc_reg_tsdt_type, ertc_type
  • wksel : ertc_reg_alarm_type, ertc_type
  • wkupint : otg_global_type
  • wkupintmsk : otg_global_type
  • wLength : usb_setup_type
  • wMaxPacketSize : usb_endpoint_desc_type
  • wp : ertc_type
  • wp_bit : ertc_type
  • wp_level : tmr_brkdt_config_type
  • wpc : tmr_type
  • wpen0 : gpio_type
  • wpen1 : gpio_type
  • wpen10 : gpio_type
  • wpen11 : gpio_type
  • wpen12 : gpio_type
  • wpen13 : gpio_type
  • wpen14 : gpio_type
  • wpen15 : gpio_type
  • wpen2 : gpio_type
  • wpen3 : gpio_type
  • wpen4 : gpio_type
  • wpen5 : gpio_type
  • wpen6 : gpio_type
  • wpen7 : gpio_type
  • wpen8 : gpio_type
  • wpen9 : gpio_type
  • wpr : gpio_type
  • wpr_bit : gpio_type
  • wpseq : gpio_type
  • wrapen : xmc_bank1_ctrl_tmg_reg_type
  • wrapped_mode_enable : xmc_norsram_init_type
  • write_addr : flash_iap_type
  • write_address_length : qspi_xip_type
  • write_blk_misalign : sd_csd_struct_type
  • write_burst_syn : xmc_norsram_init_type
  • write_crc : flash_iap_type
  • write_data : fat_dir_type
  • write_data_counter : qspi_xip_type
  • write_data_enable : qspi_cmd_type
  • write_enable : xmc_norsram_init_type
  • write_instruction_code : qspi_xip_type
  • write_operation_mode : qspi_xip_type
  • write_protect_group_enable : sd_csd_struct_type
  • write_protect_group_size : sd_csd_struct_type
  • write_protection : xmc_sdram_init_type
  • write_second_dummy_cycle_num : qspi_xip_type
  • write_select_mode : qspi_xip_type
  • write_speed_factor : sd_csd_struct_type
  • write_time : fat_dir_type
  • write_time_counter : qspi_xip_type
  • write_timing_enable : xmc_norsram_init_type, xmc_norsram_timing_init_type
  • wrp : xmc_sdram_type
  • wTotalLength : usb_configuration_desc_type
  • wum : usart_type
  • wValue : usb_setup_type
  • wwdt_pause : debug_type
  • wwdten : crm_type, wwdt_type
  • wwdtlpen : crm_type
  • wwdtrst : crm_type
  • wwdtrstf : crm_type


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- x -

  • x : usb_hid_mouse_type
  • x_p : touch_dev_type
  • xacterr : otg_hchannel_type
  • xacterrmsk : otg_hchannel_type
  • xactpos : otg_hchannel_type
  • xcnt : edma_stream_2d_type
  • xferc : otg_eptin_type, otg_eptout_type, otg_hchannel_type
  • xfercmsk : otg_device_type, otg_hchannel_type
  • xfersize : otg_eptin_type, otg_eptout_type, otg_hchannel_type
  • xip_cmd_w0 : qspi_type
  • xip_cmd_w0_bit : qspi_type
  • xip_cmd_w1 : qspi_type
  • xip_cmd_w1_bit : qspi_type
  • xip_cmd_w2 : qspi_type
  • xip_cmd_w2_bit : qspi_type
  • xip_cmd_w3 : qspi_type
  • xip_cmd_w3_bit : qspi_type
  • xipidle : qspi_type
  • xipr_adrlen : qspi_type
  • xipr_dcnt : qspi_type
  • xipr_dum2 : qspi_type
  • xipr_insc : qspi_type
  • xipr_opmode : qspi_type
  • xipr_sel : qspi_type
  • xipr_tcnt : qspi_type
  • xiprcmdf : qspi_type
  • xipsel : qspi_type
  • xipw_dcnt : qspi_type
  • xipw_sel : qspi_type
  • xipw_tcnt : qspi_type
  • xmc_init : lcd_dev_type
  • xmcen : crm_type
  • xmclpen : crm_type
  • xmcrst : crm_type


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- y -

  • y : ertc_reg_date_type, ertc_type, usb_hid_mouse_type
  • y_p : touch_dev_type
  • ycnt : edma_stream_2d_type
  • year : ertc_time_type


AT32F435/437 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- z -

  • z : usb_hid_mouse_type
  • zone : nand_address_type


AT32F435/437 Firmwary Library: Data Fields - Variables

- a -

  • a0h : emac_type
  • a0h_bit : emac_type
  • a0l : emac_type
  • a0l_bit : emac_type
  • a1h : emac_type
  • a1h_bit : emac_type
  • a1l : emac_type
  • a1l_bit : emac_type
  • a2h : emac_type
  • a2h_bit : emac_type
  • a2l : emac_type
  • a2l_bit : emac_type
  • a3h : emac_type
  • a3h_bit : emac_type
  • a3l : emac_type
  • a3l_bit : emac_type
  • aab : emac_dma_type
  • aab_enable : emac_dma_config_type
  • abort : qspi_type
  • accen : crm_type
  • acclpen : crm_type
  • accrst : crm_type
  • ack : otg_hchannel_type
  • ackfail : i2c_type
  • ackfailc : i2c_type
  • ackfailien : i2c_type
  • ackmsk : otg_hchannel_type
  • acs : emac_type, spi_type
  • actr : qspi_type
  • actr_bit : qspi_type
  • actrl : dvp_type
  • actrl_bit : dvp_type
  • adabrt : adc_type
  • adc14en : crm_type
  • adc14lpen : crm_type
  • adc14rst : crm_type
  • adcal : adc_type
  • adcalinit : adc_type
  • adcdiv : adccom_type
  • adcen : adc_type, crm_type
  • adclpen : crm_type
  • adcrst : crm_type
  • add : ertc_reg_scal_type, ertc_type
  • add1h : ertc_type
  • add1s : ertc_reg_tadj_type, ertc_type
  • addr : flash_type, i2c_type, tmr_type
  • addr1 : i2c_type
  • addr10 : i2c_type
  • addr1en : i2c_type
  • addr1mode : i2c_type
  • addr2 : flash_type, i2c_type
  • addr2_bit : flash_type
  • addr2en : i2c_type
  • addr2mask : i2c_type
  • addr_bit : flash_type
  • addr_hold_time : xmc_norsram_timing_init_type
  • addr_setup_time : xmc_norsram_timing_init_type
  • addrc : i2c_type
  • address : cbd_extended_type, cbd_typical_type, usb_hch_type
  • address_code : qspi_cmd_type
  • address_length : qspi_cmd_type
  • addrf : i2c_type
  • addrht : xmc_bank1_ctrl_tmg_reg_type, xmc_bank1_tmgwr_reg_type
  • addrien : i2c_type
  • AddrSector : FlashSectors
  • addrst : xmc_bank1_ctrl_tmg_reg_type, xmc_bank1_tmgwr_reg_type
  • admuxen : xmc_bank1_ctrl_tmg_reg_type
  • adrlen : qspi_type
  • ae : emac_type
  • aebo_enable : can_base_type
  • aeboen : can_type
  • aed_enable : can_base_type
  • aeden : can_type
  • ahb_freq : crm_clocks_freq_type
  • ahbdiv : crm_type
  • ahben1 : crm_type
  • ahben1_bit : crm_type
  • ahben2 : crm_type
  • ahben2_bit : crm_type
  • ahben3 : crm_type
  • ahben3_bit : crm_type
  • ahbidle : otg_global_type
  • ahblpen1 : crm_type
  • ahblpen1_bit : crm_type
  • ahblpen2 : crm_type
  • ahblpen2_bit : crm_type
  • ahblpen3 : crm_type
  • ahblpen3_bit : crm_type
  • ahbrst1 : crm_type
  • ahbrst1_bit : crm_type
  • ahbrst2 : crm_type
  • ahbrst2_bit : crm_type
  • ahbrst3 : crm_type
  • ahbrst3_bit : crm_type
  • aie : emac_dma_type
  • ais : emac_dma_type
  • ala : ertc_reg_alarm_type, ertc_type
  • ala_bit : ertc_reg_alarm_type, ertc_type
  • alaen : ertc_type
  • alaf : ertc_type
  • alaien : ertc_type
  • alasbs : ertc_type
  • alasbs_bit : ertc_type
  • alawf : ertc_type
  • alb : ertc_type
  • alb_bit : ertc_type
  • alben : ertc_type
  • albf : ertc_type
  • albien : ertc_type
  • albsbs : ertc_type
  • albsbs_bit : ertc_type
  • albwf : ertc_type
  • alertc : i2c_type
  • alertf : i2c_type
  • alloc_length : cbd_extended_type, cbd_typical_type
  • alt_setting : cdc_msc_struct_type, cdc_struct_type, custom_hid_type, iap_info_type, keyboard_type, mouse_type, msc_type, printer_type, usb_audio_hid_type, vcp_keyboard_type
  • amdhizt : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • amht : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • ampm : ertc_alarm_value_type, ertc_reg_alarm_type, ertc_reg_time_type, ertc_reg_tstm_type, ertc_time_type, ertc_type
  • amst : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • amwt : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • aoen : tmr_type
  • apb1_freq : crm_clocks_freq_type
  • apb1_frz : debug_type
  • apb1_frz_bit : debug_type
  • apb1div : crm_type
  • apb1en : crm_type
  • apb1en_bit : crm_type
  • apb1lpen : crm_type
  • apb1lpen_bit : crm_type
  • apb1rst : crm_type
  • apb1rst_bit : crm_type
  • apb2_freq : crm_clocks_freq_type
  • apb2_frz : debug_type
  • apb2_frz_bit : debug_type
  • apb2div : crm_type
  • apb2en : crm_type
  • apb2en_bit : crm_type
  • apb2lpen : crm_type
  • apb2lpen_bit : crm_type
  • apb2rst : crm_type
  • apb2rst_bit : crm_type
  • app_address : iap_info_type
  • argu : sdio_type
  • argu_bit : sdio_type
  • argument : sdio_command_struct_type
  • arlost : i2c_type
  • arlostc : i2c_type
  • art : xmc_sdram_type
  • aru : emac_ptp_type
  • as_length : sense_type
  • asc : sense_type
  • ascq : sense_type
  • asisel : adccom_type
  • ast : emac_ptp_type
  • astopen : i2c_type
  • asyncm : xmc_bank1_ctrl_tmg_reg_type, xmc_bank1_tmgwr_reg_type
  • asynwait_enable : xmc_norsram_init_type
  • attr : fat_dir_type
  • audio_bitw : audio_codec_type
  • audio_cmd : usb_audio_hid_type, usb_audio_type
  • audio_cmd_len : usb_audio_hid_type, usb_audio_type
  • audio_feed_back : usb_audio_hid_type, usb_audio_type
  • audio_feedback_state : usb_audio_hid_type, usb_audio_type
  • audio_freq : audio_codec_type
  • audio_mic_data : usb_audio_hid_type, usb_audio_type
  • audio_protocol : i2s_init_type
  • audio_sampling_freq : i2s_init_type
  • audio_spk_data : usb_audio_hid_type, usb_audio_type
  • audio_spk_out_stage : usb_audio_hid_type, usb_audio_type
  • auto_nego : emac_control_config_type
  • auto_output_enable : tmr_brkdt_config_type
  • auto_pad_crc_strip : emac_control_config_type
  • auto_refresh : xmc_sdram_cmd_type
  • auto_step_en : crm_type


AT32F435/437 Firmwary Library: Data Fields - Variables

- b -

  • b2bsetupmsk : otg_device_type
  • b2pstup : otg_eptout_type
  • back_off_limit : emac_control_config_type
  • bAlternateSetting : usb_interface_desc_type
  • bankers : flash_type
  • base_ptr : FlashParamsHolder
  • baudr : usart_type
  • baudr_bit : usart_type
  • baudrate_div : can_baudrate_type
  • bblerr : otg_hchannel_type
  • bblerrmsk : otg_hchannel_type
  • bCBWCBLength : cbw_type, msc_bot_cbw_type
  • bCBWLUN : cbw_type, msc_bot_cbw_type
  • bcdDevice : usb_device_desc_type
  • bcdHID : usb_hid_desc_type
  • bcdUSB : usb_device_desc_type
  • bcnt : otg_global_type
  • bConfigurationValue : usb_configuration_desc_type
  • bCountryCode : usb_hid_desc_type
  • bCSWStatus : csw_type, msc_bot_csw_type
  • bDescriptorType : usb_configuration_desc_type, usb_device_desc_type, usb_endpoint_desc_type, usb_header_desc_type, usb_hid_desc_type, usb_interface_desc_type
  • bDeviceClass : usb_device_desc_type
  • bDeviceProtocol : usb_device_desc_type
  • bDeviceSubClass : usb_device_desc_type
  • bEndpointAddress : usb_endpoint_desc_type
  • bf : spi_type
  • bfbn : usart_type
  • bff : usart_type
  • bfien : usart_type
  • bfrc : dvp_type
  • bInterfaceClass : usb_interface_desc_type
  • bInterfaceNumber : usb_interface_desc_type
  • bInterfaceProtocol : usb_interface_desc_type
  • bInterfaceSubClass : usb_interface_desc_type
  • bInterval : usb_endpoint_desc_type
  • bitrate : linecoding_type
  • bk1 : xmc_sdram_type
  • bk1ctrl : xmc_bank1_ctrl_tmg_reg_type
  • bk1ctrl_bit : xmc_bank1_ctrl_tmg_reg_type
  • bk1sts : xmc_sdram_type
  • bk1tmg : xmc_bank1_ctrl_tmg_reg_type
  • bk1tmg_bit : xmc_bank1_ctrl_tmg_reg_type
  • bk1tmgwr : xmc_bank1_tmgwr_reg_type
  • bk1tmgwr_bit : xmc_bank1_tmgwr_reg_type
  • bk2 : xmc_sdram_type
  • bk2ctrl : xmc_bank2_type
  • bk2ctrl_bit : xmc_bank2_type
  • bk2ecc : xmc_bank2_type
  • bk2ecc_bit : xmc_bank2_type
  • bk2is : xmc_bank2_type
  • bk2is_bit : xmc_bank2_type
  • bk2sts : xmc_sdram_type
  • bk2tmgatt : xmc_bank2_type
  • bk2tmgatt_bit : xmc_bank2_type
  • bk2tmgmem : xmc_bank2_type
  • bk2tmgmem_bit : xmc_bank2_type
  • bk3ctrl : xmc_bank3_type
  • bk3ctrl_bit : xmc_bank3_type
  • bk3ecc : xmc_bank3_type
  • bk3ecc_bit : xmc_bank3_type
  • bk3is : xmc_bank3_type
  • bk3is_bit : xmc_bank3_type
  • bk3tmgatt : xmc_bank3_type
  • bk3tmgatt_bit : xmc_bank3_type
  • bk3tmgmem : xmc_bank3_type
  • bk3tmgmem_bit : xmc_bank3_type
  • bk4ctrl : xmc_bank4_type
  • bk4ctrl_bit : xmc_bank4_type
  • bk4is : xmc_bank4_type
  • bk4is_bit : xmc_bank4_type
  • bk4tmgatt : xmc_bank4_type
  • bk4tmgatt_bit : xmc_bank4_type
  • bk4tmgio : xmc_bank4_type
  • bk4tmgio_bit : xmc_bank4_type
  • bk4tmgmem : xmc_bank4_type
  • bk4tmgmem_bit : xmc_bank4_type
  • bl : emac_type
  • bLength : usb_configuration_desc_type, usb_device_desc_type, usb_endpoint_desc_type, usb_header_desc_type, usb_hid_desc_type, usb_interface_desc_type
  • blk_addr : cdc_msc_struct_type, msc_type
  • blk_len : cdc_msc_struct_type, msc_type
  • blk_nbr : cdc_msc_struct_type, msc_scsi_data_capacity, msc_type
  • blk_size : cdc_msc_struct_type, msc_scsi_data_capacity, msc_type
  • blkers : flash_type
  • blksize : sdio_type
  • block : nand_address_type, tftp_connection_args
  • block_size : FlashParamsHolder, sdio_data_struct_type
  • bm : emac_dma_type
  • bm_bit : emac_dma_type
  • bmAttributes : usb_configuration_desc_type, usb_endpoint_desc_type
  • bMaxPacketSize0 : usb_device_desc_type
  • bMaxPower : usb_configuration_desc_type
  • bmCBWFlags : cbw_type, msc_bot_cbw_type
  • bmRequestType : usb_setup_type
  • bnainmsk : otg_device_type
  • bnaoutmsk : otg_device_type
  • bNumConfigurations : usb_device_desc_type
  • bNumDescriptors : usb_hid_desc_type
  • bNumEndpoints : usb_interface_desc_type
  • bNumInterfaces : usb_configuration_desc_type
  • bof : can_type
  • boien : can_type
  • bot_state : msc_bot_trans_type
  • bot_status : cdc_msc_struct_type, msc_type
  • bot_trans : usbh_msc_type
  • bpdc : crm_type
  • bpdc_bit : crm_type
  • bpdrst : crm_type
  • bpr : ertc_type
  • bpwen : pwc_type
  • brdiv : can_type
  • bReportDescriptorType : usb_hid_desc_type
  • bRequest : usb_setup_type
  • brk : tmr_type
  • brk_bit : tmr_type
  • brk_enable : tmr_brkdt_config_type
  • brk_polarity : tmr_brkdt_config_type
  • brken : tmr_type
  • brkie : tmr_type
  • brkif : tmr_type
  • brkswtr : tmr_type
  • brkv : tmr_type
  • bstr : xmc_sdram_type
  • bth : dvp_type
  • bth_bit : dvp_type
  • btmg : can_type
  • btmg_bit : can_type
  • btopt : flash_type
  • bts1 : can_type
  • bts1_size : can_baudrate_type
  • bts2 : can_type
  • bts2_size : can_baudrate_type
  • buf : sdio_type, usart_group_type
  • buf1addr : emac_dma_desc_type
  • buf2nextdescaddr : emac_dma_desc_type
  • buf_bit : sdio_type
  • bufcnt : sdio_type
  • bufcnt_bit : sdio_type
  • buffer : FlashParamsHolder, msc_bot_trans_type, usbh_hid_type, usbh_msc_type
  • buffer_size : dma_init_type, edma_init_type
  • burst_mode_enable : xmc_norsram_init_type
  • burst_read : xmc_sdram_init_type
  • bus_latency_time : xmc_norsram_timing_init_type
  • bus_type : xmc_nand_init_type, xmc_norsram_init_type
  • buserr : i2c_type
  • buserrc : i2c_type
  • buslat : xmc_bank1_ctrl_tmg_reg_type, xmc_bank1_tmgwr_reg_type
  • buslatr2r : xmc_bank1_type
  • buslatw2w : xmc_bank1_type
  • busws : sdio_type
  • busy : qspi_type, xmc_sdram_type
  • busyf : i2c_type
  • button : usb_hid_mouse_type
  • bypassc : qspi_type
  • bypsen : sdio_type
  • byte : nand_address_type
  • bytes : name


AT32F435/437 Firmwary Library: Data Fields - Variables

- c -

  • c1 : acc_type
  • c1_bit : acc_type
  • c1c : tmr_type
  • c1cen : tmr_type
  • c1cios : tmr_type
  • c1cp : tmr_type
  • c1den : tmr_type
  • c1df : tmr_type
  • c1dt : tmr_type
  • c1dt_bit : tmr_type
  • c1en : tmr_type
  • c1idiv : tmr_type
  • c1ien : tmr_type
  • c1if : tmr_type
  • c1insel : tmr_type
  • c1ios : tmr_type
  • c1oben : tmr_type
  • c1octrl : tmr_type
  • c1oien : tmr_type
  • c1osen : tmr_type
  • c1p : tmr_type
  • c1rf : tmr_type
  • c1swtr : tmr_type
  • c2 : acc_type
  • c2_bit : acc_type
  • c2c : tmr_type
  • c2cen : tmr_type
  • c2cios : tmr_type
  • c2cp : tmr_type
  • c2den : tmr_type
  • c2df : tmr_type
  • c2dt : tmr_type
  • c2dt_bit : tmr_type
  • c2en : tmr_type
  • c2idiv : tmr_type
  • c2ien : tmr_type
  • c2if : tmr_type
  • c2ios : tmr_type
  • c2oben : tmr_type
  • c2octrl : tmr_type
  • c2oien : tmr_type
  • c2osen : tmr_type
  • c2p : tmr_type
  • c2rf : tmr_type
  • c2swtr : tmr_type
  • c3 : acc_type
  • c3_bit : acc_type
  • c3c : tmr_type
  • c3cen : tmr_type
  • c3cios : tmr_type
  • c3cp : tmr_type
  • c3den : tmr_type
  • c3df : tmr_type
  • c3dt : tmr_type
  • c3dt_bit : tmr_type
  • c3en : tmr_type
  • c3idiv : tmr_type
  • c3ien : tmr_type
  • c3if : tmr_type
  • c3ios : tmr_type
  • c3oben : tmr_type
  • c3octrl : tmr_type
  • c3oien : tmr_type
  • c3osen : tmr_type
  • c3p : tmr_type
  • c3rf : tmr_type
  • c3swtr : tmr_type
  • c4c : tmr_type
  • c4den : tmr_type
  • c4df : tmr_type
  • c4dt : tmr_type
  • c4dt_bit : tmr_type
  • c4en : tmr_type
  • c4idiv : tmr_type
  • c4ien : tmr_type
  • c4if : tmr_type
  • c4ios : tmr_type
  • c4oben : tmr_type
  • c4octrl : tmr_type
  • c4oien : tmr_type
  • c4osen : tmr_type
  • c4p : tmr_type
  • c4rf : tmr_type
  • c4swtr : tmr_type
  • c5dt : tmr_type
  • c5dt_bit : tmr_type
  • c5oben : tmr_type
  • c5octrl : tmr_type
  • c5oien : tmr_type
  • c5osen : tmr_type
  • ca : xmc_sdram_type
  • cal16 : ertc_reg_scal_type, ertc_type
  • cal8 : ertc_reg_scal_type, ertc_type
  • caldir : ertc_type
  • caloen : ertc_type
  • calon : acc_type
  • calosel : ertc_type
  • calrdy : acc_type
  • calrdyien : acc_type
  • calupdf : ertc_type
  • calval : adc_type, ertc_type
  • calval_bit : adc_type
  • can1_pause : debug_type
  • can1en : crm_type
  • can1lpen : crm_type
  • can1rst : crm_type
  • can2_pause : debug_type
  • can2en : crm_type
  • can2lpen : crm_type
  • can2rst : crm_type
  • cap : dvp_type
  • capacity : usbh_msc_unit_type
  • card_blk_size : sd_card_info_struct_type
  • card_capacity : sd_card_info_struct_type
  • card_cmd_classes : sd_csd_struct_type
  • card_type : sd_card_info_struct_type
  • cardsts1 : sdio_type
  • cardsts2 : sdio_type
  • cardsts3 : sdio_type
  • cardsts4 : sdio_type
  • carrier_sense_disable : emac_control_config_type
  • cas : xmc_sdram_init_type, xmc_sdram_type
  • cbctrl : tmr_type
  • cbw : msc_bot_trans_type
  • cbw_struct : cdc_msc_struct_type, msc_type
  • CBWCB : cbw_type, msc_bot_cbw_type
  • ccal : ertc_type
  • ccal_bit : ertc_type
  • ccalen : ertc_type
  • ccen : spi_type
  • ccerr : spi_type
  • ccfs : tmr_type
  • ccsmen : sdio_type
  • cctrl : adccom_type, tmr_type
  • cctrl_bit : adccom_type, tmr_type
  • cdt : crc_type
  • cdt_bit : crc_type
  • cfden : crm_type
  • cfdes : dvp_type
  • cfdf : crm_type
  • cfdfc : crm_type
  • cfdic : dvp_type
  • cfdie : dvp_type
  • cfdis : dvp_type
  • cfg : crm_type, otg_core_type, wwdt_type
  • cfg1 : scfg_type
  • cfg1_bit : scfg_type
  • cfg2 : scfg_type
  • cfg2_bit : scfg_type
  • cfg_bit : crm_type, wwdt_type
  • cfgr : gpio_type
  • cfgr_bit : gpio_type
  • cfm : dvp_type
  • cgnpinak : otg_device_type
  • cgoutnak : otg_device_type
  • ch_num : usb_hch_type
  • change : usbh_msc_unit_type
  • chdis : otg_hchannel_type
  • chen : dma_channel_type
  • chena : otg_hchannel_type
  • chhltd : otg_hchannel_type
  • chhltdmsk : otg_hchannel_type
  • chin : usbh_hid_type, usbh_msc_type
  • chnum : dvp_type, otg_global_type
  • chout : usbh_hid_type, usbh_msc_type
  • chpl : dma_channel_type
  • chstr : dvp_type
  • cid_crc : sd_cid_struct_type
  • cidsts : otg_global_type
  • ckp : dvp_type
  • class_bank : xmc_nand_pccard_timinginit_type
  • clk_psc : xmc_norsram_timing_init_type
  • clk_to_tmr : crm_type
  • clkctrl : i2c_type, sdio_type
  • clkctrl_bit : i2c_type, sdio_type
  • clkdiv : qspi_type, tmr_type, xmc_sdram_init_type, xmc_sdram_type
  • clkdiv_h : sdio_type
  • clkdiv_l : sdio_type
  • clkegs : sdio_type
  • clken : usart_type
  • clkint : crm_type
  • clkint_bit : crm_type
  • clkoen : sdio_type
  • clkout1_sel : crm_type
  • clkout1div1 : crm_type
  • clkout1div2 : crm_type
  • clkout2_sel1 : crm_type
  • clkout2_sel2 : crm_type
  • clkout2div1 : crm_type
  • clkout2div2 : crm_type
  • clkpha : spi_type, usart_type
  • clkpol : spi_type, usart_type
  • clkpsc : xmc_bank1_ctrl_tmg_reg_type
  • clock_phase : spi_init_type
  • clock_polarity : i2s_init_type, spi_init_type
  • clr : dma_type, gpio_type, i2c_type
  • clr1 : edma_type
  • clr1_bit : edma_type
  • clr2 : edma_type
  • clr2_bit : edma_type
  • clr_bit : dma_type, gpio_type, i2c_type
  • clsef : pwc_type
  • clswef : pwc_type
  • clus_high : fat_dir_type
  • clus_low : fat_dir_type
  • cm : edma_stream_type
  • cm1 : tmr_type
  • cm1_input_bit : tmr_type
  • cm1_output_bit : tmr_type
  • cm2 : tmr_type
  • cm2_input_bit : tmr_type
  • cm2_output_bit : tmr_type
  • cm3 : tmr_type
  • cm3_output_bit : tmr_type
  • cmd : ertc_type, wdt_type, xmc_sdram_cmd_type, xmc_sdram_type
  • cmd20_support : sd_scr_struct_type
  • cmd23_support : sd_scr_struct_type
  • cmd_addr : cmd_data_group_type
  • cmd_banks : xmc_sdram_cmd_type
  • cmd_bit : wdt_type, xmc_sdram_type
  • cmd_buf : cmd_data_group_type
  • cmd_check : cmd_data_group_type
  • cmd_head : cmd_data_group_type
  • cmd_index : sdio_command_struct_type
  • cmd_state : msc_bot_trans_type
  • cmd_w0 : qspi_type
  • cmd_w0_bit : qspi_type
  • cmd_w1 : qspi_type
  • cmd_w1_bit : qspi_type
  • cmd_w2 : qspi_type
  • cmd_w2_bit : qspi_type
  • cmd_w3 : qspi_type
  • cmd_w3_bit : qspi_type
  • cmdcmpl : sdio_type
  • cmdcmplien : sdio_type
  • cmdctrl : sdio_type
  • cmdctrl_bit : sdio_type
  • cmdfail : sdio_type
  • cmdfailien : sdio_type
  • cmdhizt : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • cmdidx : sdio_type
  • cmdie : qspi_type
  • cmdrspcmpl : sdio_type
  • cmdrspcmplien : sdio_type
  • cmdsts : qspi_type
  • cmdsts_bit : qspi_type
  • cmdtimeout : sdio_type
  • cmdtimeoutien : sdio_type
  • cmht : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • cmst : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • cmwt : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • cnak : otg_eptin_type, otg_eptout_type
  • cnt : dma_channel_type, edma_stream_type, i2c_type, sdio_type, wwdt_type
  • cnt_dir : tmr_type
  • codt : adccom_type
  • codt_bit : adccom_type
  • codth : adccom_type
  • codtl : adccom_type
  • column_address : xmc_sdram_init_type
  • combine_mode : adc_common_config_type
  • common_dma_mode : adc_common_config_type
  • common_dma_request_repeat_state : adc_common_config_type
  • compsplt : otg_hchannel_type
  • conidschg : otg_global_type
  • conidschgmsk : otg_global_type
  • content_protect_app : sd_csd_struct_type
  • contr : flash_type
  • contr_bit : flash_type
  • controlsize : emac_dma_desc_type
  • copy_flag : sd_csd_struct_type
  • core_id : usb_core_cfg
  • cotxpkt : otg_global_type
  • count : FlashParamsHolder, usart_group_type
  • cpoly : spi_type
  • cpoly_bit : spi_type
  • cr : emac_type
  • CR_NDT : Descriptors_Format_def
  • crbaddr : emac_dma_type
  • crbaddr_bit : emac_dma_type
  • crc_chkr : flash_type
  • crc_chkr_bit : flash_type
  • crc_ctrl : flash_type
  • crc_ctrl_bit : flash_type
  • crc_sn : flash_type
  • crc_ss : flash_type
  • crc_strt : flash_type
  • crcen : crm_type
  • crclpen : crm_type
  • crcrst : crm_type
  • crd : emac_dma_type
  • crd_bit : emac_dma_type
  • create_data : fat_dir_type
  • create_time : fat_dir_type
  • create_time_tenth : fat_dir_type
  • crp : dvp_type
  • crpgs : xmc_bank1_ctrl_tmg_reg_type
  • crsel : adc_type
  • cs_mode_selection : spi_init_type
  • csd_crc : sd_csd_struct_type
  • csd_struct : sd_csd_struct_type
  • csdly : qspi_type
  • csftrst : otg_global_type
  • cspas : spi_type
  • cspt0 : adc_type
  • cspt1 : adc_type
  • cspt10 : adc_type
  • cspt11 : adc_type
  • cspt12 : adc_type
  • cspt13 : adc_type
  • cspt14 : adc_type
  • cspt15 : adc_type
  • cspt16 : adc_type
  • cspt17 : adc_type
  • cspt18 : adc_type
  • cspt2 : adc_type
  • cspt3 : adc_type
  • cspt4 : adc_type
  • cspt5 : adc_type
  • cspt6 : adc_type
  • cspt7 : adc_type
  • cspt8 : adc_type
  • cspt9 : adc_type
  • csts : adccom_type, qspi_type
  • csts_bit : adccom_type
  • csw : msc_bot_trans_type
  • csw_struct : cdc_msc_struct_type, msc_type
  • ctbaddr : emac_dma_type
  • ctbaddr_bit : emac_dma_type
  • ctd : emac_dma_type
  • ctd_bit : emac_dma_type
  • ctrl : crc_type, crm_type, dac_type, debug_type, dma_channel_type, dvp_type, edma_stream_type, emac_mmc_type, emac_type, ertc_type, flash_type, pwc_type, qspi_type, wwdt_type, xmc_sdram_type
  • ctrl1 : acc_type, adc_type, i2c_type, spi_type, tmr_type, usart_type
  • ctrl1_bit : acc_type, adc_type, i2c_type, spi_type, tmr_type, usart_type
  • ctrl2 : acc_type, adc_type, flash_type, i2c_type, qspi_type, spi_type, tmr_type, usart_type
  • ctrl2_bit : acc_type, adc_type, flash_type, i2c_type, qspi_type, spi_type, tmr_type, usart_type
  • ctrl3 : usart_type
  • ctrl3_bit : usart_type
  • ctrl_bit : crc_type, crm_type, dac_type, debug_type, dma_channel_type, dvp_type, edma_stream_type, emac_mmc_type, emac_type, ertc_type, flash_type, pwc_type, qspi_type, wwdt_type, xmc_sdram_type
  • ctrl_dtcnt : ll_descriptors_type
  • ctrl_state : usbh_hid_type, usbh_msc_type
  • ctrl_tmg_group : xmc_bank1_type
  • ctrlsts : crm_type, pwc_type
  • ctrlsts_bit : crm_type, pwc_type
  • ctscf : usart_type
  • ctscfien : usart_type
  • ctsen : usart_type
  • cur_lun : usbh_msc_type
  • curmod : otg_global_type
  • curmode : otg_global_type
  • curs : can_type
  • cuss : can_type
  • cval : tmr_type
  • cval_bit : tmr_type
  • cvnum : dvp_type
  • cvstr : dvp_type
  • cwst : dvp_type
  • cwst_bit : dvp_type
  • cwsz : dvp_type
  • cwsz_bit : dvp_type


AT32F435/437 Firmwary Library: Data Fields - Variables

- d -

  • d : ertc_reg_alarm_type, ertc_reg_date_type, ertc_reg_tsdt_type, ertc_type
  • d1dmaen : dac_type
  • d1dmaudrf : dac_type
  • d1dmaudrien : dac_type
  • d1dt12l : dac_type
  • d1dt12r : dac_type
  • d1dt8r : dac_type
  • d1dth12l : dac_type
  • d1dth12l_bit : dac_type
  • d1dth12r : dac_type
  • d1dth12r_bit : dac_type
  • d1dth8r : dac_type
  • d1dth8r_bit : dac_type
  • d1en : dac_type
  • d1nbsel : dac_type
  • d1nm : dac_type
  • d1obdis : dac_type
  • d1odt : dac_type
  • d1odt_bit : dac_type
  • d1swtrg : dac_type
  • d1trgen : dac_type
  • d1trgsel : dac_type
  • d2dmaen : dac_type
  • d2dmaudrf : dac_type
  • d2dmaudrien : dac_type
  • d2dt12l : dac_type
  • d2dt12r : dac_type
  • d2dt8r : dac_type
  • d2dth12l : dac_type
  • d2dth12l_bit : dac_type
  • d2dth12r : dac_type
  • d2dth12r_bit : dac_type
  • d2dth8r : dac_type
  • d2dth8r_bit : dac_type
  • d2en : dac_type
  • d2nbsel : dac_type
  • d2nm : dac_type
  • d2obdis : dac_type
  • d2odt : dac_type
  • d2odt_bit : dac_type
  • d2swtrg : dac_type
  • d2trgen : dac_type
  • d2trgsel : dac_type
  • da : emac_dma_type
  • da_enable : emac_dma_config_type
  • dacen : crm_type
  • daclpen : crm_type
  • dacrst : crm_type
  • daif : emac_type
  • daint : otg_device_type
  • daint_bit : otg_device_type
  • daintmsk : otg_device_type
  • daintmsk_bit : otg_device_type
  • data : can_rx_message_type, can_tx_message_type, cdc_msc_struct_type, fs_file, fsdata_file, fsdata_file_noconst, linecoding_type, msc_bot_trans_type, msc_type, tftp_connection_args, xmc_sdram_cmd_type
  • data0 : usd_type
  • data1 : usd_type
  • data_addr_multiplex : xmc_norsram_init_type
  • data_align : adc_base_config_type
  • data_channel_format : i2s_init_type
  • data_counter : qspi_cmd_type
  • data_format : msc_scsi_data_inquiry
  • data_latency_time : xmc_norsram_timing_init_type
  • data_len : cdc_msc_struct_type, msc_type, tftp_connection_args
  • data_length : sdio_data_struct_type
  • data_pid : usb_hch_type
  • data_setup_time : xmc_norsram_timing_init_type
  • data_stat_after_erase : sd_scr_struct_type
  • date : ertc_reg_date_type, ertc_type
  • date_bit : ertc_reg_date_type, ertc_type
  • day : ertc_alarm_value_type, ertc_time_type
  • db : xmc_sdram_type
  • dbf : emac_type
  • dbn_h : usart_type
  • dbn_l : usart_type
  • dc : emac_type
  • dCBWDataTransferLength : cbw_type, msc_bot_cbw_type
  • dCBWSignature : cbw_type, msc_bot_cbw_type, msc_bot_csw_type
  • dCBWTag : msc_bot_cbw_type, msc_bot_csw_type
  • dCBWTage : cbw_type
  • dcfg : otg_device_type
  • dcfg_bit : otg_device_type
  • dcnt : qspi_type
  • dcs : emac_type
  • dCSWDataResidue : csw_type, msc_bot_csw_type
  • dCSWSignature : csw_type
  • dCSWTag : csw_type
  • dctl : otg_device_type
  • dctl_bit : otg_device_type
  • dd1dt12l : dac_type
  • dd1dt12r : dac_type
  • dd1dt8r : dac_type
  • dd2dt12l : dac_type
  • dd2dt12r : dac_type
  • dd2dt8r : dac_type
  • ddth12l : dac_type
  • ddth12l_bit : dac_type
  • ddth12r : dac_type
  • ddth12r_bit : dac_type
  • ddth8r : dac_type
  • ddth8r_bit : dac_type
  • deadtime : tmr_brkdt_config_type
  • dec : ertc_reg_scal_type, ertc_type
  • dec1h : ertc_type
  • decsbs : ertc_reg_tadj_type, ertc_type
  • deepsleep_debug : debug_type
  • deferral_check : emac_control_config_type
  • delay_time_ar : xmc_nand_init_type, xmc_pccard_init_type
  • delay_time_cr : xmc_pccard_init_type
  • delay_time_cycle : xmc_nand_init_type
  • dep : usart_type
  • depslp_rst : flash_type
  • desc_skip_length : emac_dma_config_type
  • dev : xmc_bank1_ctrl_tmg_reg_type, xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • devaddr : otg_device_type, otg_hchannel_type
  • devaddren : i2c_type
  • DevAdr : FlashDevice
  • device : xmc_norsram_init_type
  • device_code1 : nor_idtype
  • device_code2 : nor_idtype
  • device_code3 : nor_idtype
  • device_id : nand_id_type
  • device_size : sd_csd_struct_type
  • device_size_mult : sd_csd_struct_type
  • DevName : FlashDevice
  • devspd : otg_device_type
  • DevType : FlashDevice
  • dflt : i2c_type
  • dfrf : emac_dma_type
  • diepctl : otg_eptin_type
  • diepctl_bit : otg_eptin_type
  • diepempmsk : otg_device_type
  • diepempmsk_bit : otg_device_type
  • diepint : otg_eptin_type
  • diepint_bit : otg_eptin_type
  • diepmsk : otg_device_type
  • diepmsk_bit : otg_device_type
  • dieptsiz : otg_eptin_type
  • dieptsiz_bit : otg_eptin_type
  • dieptxfn : otg_global_type
  • dieptxfn_bit : otg_global_type
  • dir : i2c_type, usb_hch_type
  • direction : dma_init_type, edma_init_type
  • disconint : otg_global_type
  • disconintmsk : otg_global_type
  • div : adc_common_config_type, ertc_type, tmr_type, usart_type, wdt_type, wwdt_type
  • div_bit : ertc_type, tmr_type, wdt_type
  • diva : ertc_type
  • divb : ertc_type
  • divf : wdt_type
  • divh : i2c_type
  • divl : i2c_type
  • divr : flash_type
  • divr_bit : flash_type
  • dlc : can_rx_message_type, can_tx_message_type
  • dm : emac_type
  • dma1en : crm_type
  • dma1lpen : crm_type
  • dma1rst : crm_type
  • dma2en : crm_type
  • dma2lpen : crm_type
  • dma2rst : crm_type
  • dma_en : usb_core_cfg
  • dma_init_struct : i2c_handle_type
  • dma_rx_channel : i2c_handle_type
  • dma_tx_channel : i2c_handle_type
  • dmabt : dvp_type
  • dmactrl : tmr_type
  • dmactrl_bit : tmr_type
  • dmadt : tmr_type
  • dmadt_bit : tmr_type
  • dmaen : qspi_type, sdio_type
  • dmaren : i2c_type, spi_type, usart_type
  • dmaten : i2c_type, spi_type, usart_type
  • dmerrf1 : edma_type
  • dmerrf2 : edma_type
  • dmerrf3 : edma_type
  • dmerrf4 : edma_type
  • dmerrf5 : edma_type
  • dmerrf6 : edma_type
  • dmerrf7 : edma_type
  • dmerrf8 : edma_type
  • dmerrfc1 : edma_type
  • dmerrfc2 : edma_type
  • dmerrfc3 : edma_type
  • dmerrfc4 : edma_type
  • dmerrfc5 : edma_type
  • dmerrfc6 : edma_type
  • dmerrfc7 : edma_type
  • dmerrfc8 : edma_type
  • dmerrien : edma_stream_type
  • dmm : edma_stream_type
  • docmd : sdio_type
  • docmdien : sdio_type
  • doepctl : otg_eptout_type
  • doepctl_bit : otg_eptout_type
  • doepint : otg_eptout_type
  • doepint_bit : otg_eptout_type
  • doepmsk : otg_device_type
  • doepmsk_bit : otg_device_type
  • doeptsiz : otg_eptout_type
  • doeptsiz_bit : otg_eptout_type
  • dorx : sdio_type
  • dorxien : sdio_type
  • dotx : sdio_type
  • dotxien : sdio_type
  • dpid : otg_eptin_type, otg_eptout_type, otg_global_type
  • dr : emac_type
  • dr0 : dvp_type
  • dr1 : dvp_type
  • dr2 : dvp_type
  • dr3 : dvp_type
  • draw_point : lcd_dev_type
  • dren : ertc_type
  • dro : emac_type
  • drs : tmr_type
  • dsl : emac_dma_type
  • dsr_implemented : sd_csd_struct_type
  • dsts : otg_device_type
  • dsts_bit : otg_device_type
  • dststd : edma_stream_2d_type
  • dt : crc_type, dvp_type, emac_dma_type, ertc_type, i2c_type, qspi_type, sdio_type, spi_type, usart_type
  • dt1 : ertc_type
  • dt10 : ertc_type
  • dt10_bit : ertc_type
  • dt11 : ertc_type
  • dt11_bit : ertc_type
  • dt12 : ertc_type
  • dt12_bit : ertc_type
  • dt13 : ertc_type
  • dt13_bit : ertc_type
  • dt14 : ertc_type
  • dt14_bit : ertc_type
  • dt15 : ertc_type
  • dt15_bit : ertc_type
  • dt16 : ertc_type
  • dt16_bit : ertc_type
  • dt17 : ertc_type
  • dt17_bit : ertc_type
  • dt18 : ertc_type
  • dt18_bit : ertc_type
  • dt19 : ertc_type
  • dt19_bit : ertc_type
  • dt1_bit : ertc_type
  • dt2 : ertc_type
  • dt20 : ertc_type
  • dt20_bit : ertc_type
  • dt2_bit : ertc_type
  • dt3 : ertc_type
  • dt3_bit : ertc_type
  • dt4 : ertc_type
  • dt4_bit : ertc_type
  • dt5 : ertc_type
  • dt5_bit : ertc_type
  • dt6 : ertc_type
  • dt6_bit : ertc_type
  • dt7 : ertc_type
  • dt7_bit : ertc_type
  • dt8 : ertc_type
  • dt8_bit : ertc_type
  • dt9 : ertc_type
  • dt9_bit : ertc_type
  • dt_bit : crc_type, dvp_type, qspi_type, spi_type, usart_type
  • dt_disable : emac_dma_config_type
  • dt_u16 : qspi_type
  • dt_u8 : qspi_type
  • dtalign : adc_type
  • dtb : tmr_type
  • dtblkcmpl : sdio_type
  • dtblkcmplien : sdio_type
  • dtc : tmr_type
  • dtcmpl : sdio_type
  • dtcmplien : sdio_type
  • dtcnt : dma_channel_type, edma_stream_type, sdio_type
  • dtcnt_bit : dma_channel_type, edma_stream_type, sdio_type
  • dtctrl : sdio_type
  • dtctrl_bit : sdio_type
  • dtd : dma_channel_type, edma_stream_type
  • dterrf1 : dma_type, edma_type
  • dterrf2 : dma_type, edma_type
  • dterrf3 : dma_type, edma_type
  • dterrf4 : dma_type, edma_type
  • dterrf5 : dma_type, edma_type
  • dterrf6 : dma_type, edma_type
  • dterrf7 : dma_type, edma_type
  • dterrf8 : edma_type
  • dterrfc1 : dma_type, edma_type
  • dterrfc2 : dma_type, edma_type
  • dterrfc3 : dma_type, edma_type
  • dterrfc4 : dma_type, edma_type
  • dterrfc5 : dma_type, edma_type
  • dterrfc6 : dma_type, edma_type
  • dterrfc7 : dma_type, edma_type
  • dterrfc8 : edma_type
  • dterrien : dma_channel_type, edma_stream_type
  • dtfail : sdio_type
  • dtfailien : sdio_type
  • dtglerr : otg_hchannel_type
  • dtglerrmsk : otg_hchannel_type
  • dtlat : xmc_bank1_ctrl_tmg_reg_type
  • dtlen : sdio_type
  • dtlen_bit : sdio_type
  • dtst : xmc_bank1_ctrl_tmg_reg_type, xmc_bank1_tmgwr_reg_type
  • dttimeout : sdio_type
  • dttimeoutien : sdio_type
  • dttmr : sdio_type
  • dttmr_bit : sdio_type
  • dtxfsts : otg_eptin_type
  • dtxfsts_bit : otg_eptin_type
  • dum2 : qspi_type
  • dup : emac_type
  • duplex_mode : emac_control_config_type
  • dvpen : crm_type
  • dvplpen : crm_type
  • dvprst : crm_type
  • dzc : can_type
  • dzen : can_type
  • dzqp : emac_type


AT32F435/437 Firmwary Library: Data Fields - Variables

- e -

  • eaf : can_type
  • eaien : can_type
  • eb : emac_dma_type
  • ecc : xmc_bank2_type, xmc_bank3_type
  • ecc_code : sd_csd_struct_type
  • ecc_enable : xmc_nand_init_type
  • ecc_pagesize : xmc_nand_init_type
  • eccen : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • eccpgs : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • ecmben : tmr_type
  • edmaen : crm_type
  • edmalpen : crm_type
  • edmarst : crm_type
  • edzien : can_type
  • edzif : can_type
  • efdf : dvp_type
  • efrce : dvp_type
  • efrcsf : dvp_type
  • efrctf : dvp_type
  • eie : emac_dma_type
  • eien : acc_type
  • eisre : dvp_type
  • emac_pps_sel : crm_type
  • emafpff : emac_ptp_type
  • emp : emac_type
  • en : xmc_bank1_ctrl_tmg_reg_type, xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • ena : dvp_type
  • enable_wait : xmc_pccard_init_type
  • enpd : usb_audio_hid_type, usb_audio_type
  • entrim : acc_type
  • enumdone : otg_global_type
  • enumdonemsk : otg_global_type
  • enumspd : otg_device_type
  • eocsfen : adc_type
  • eoien : can_type
  • eoif : can_type
  • eopb0 : usd_type
  • eopf : otg_global_type
  • eopfmsk : otg_global_type
  • epdisd : otg_eptin_type, otg_eptout_type
  • epf : can_type
  • epien : can_type
  • epp0 : usd_type
  • epp1 : usd_type
  • epp2 : usd_type
  • epp3 : usd_type
  • epp4 : usd_type
  • epp5 : usd_type
  • epp6 : usd_type
  • epp7 : usd_type
  • eppef : emac_ptp_type
  • epperr : flash_type
  • eppfsip4u : emac_ptp_type
  • eppfsip6u : emac_ptp_type
  • epps : flash_type
  • epps0 : flash_type
  • epps0_bit : flash_type
  • epps1 : flash_type
  • epps1_bit : flash_type
  • eppv2f : emac_ptp_type
  • ept0_slen : usb_ept_info
  • ept_address : usb_ept_info
  • ept_num : usb_core_cfg, usb_hch_type
  • ept_type : usb_hch_type
  • eptdir : otg_hchannel_type
  • eptdis : otg_eptin_type, otg_eptout_type
  • eptdismsk : otg_device_type
  • eptena : otg_eptin_type, otg_eptout_type
  • eptin : usbh_hid_type, usbh_msc_type
  • eptn : usb_ept_info
  • eptnum : otg_global_type, otg_hchannel_type
  • eptout : usbh_hid_type, usbh_msc_type
  • eptype : otg_eptin_type, otg_eptout_type, otg_hchannel_type
  • erase_group_size : sd_csd_struct_type
  • erase_group_size_mult : sd_csd_struct_type
  • ere : emac_dma_type
  • erf : emac_type
  • eri : emac_dma_type
  • erien : xmc_sdram_type
  • erlysusp : otg_global_type
  • erlysuspmsk : otg_global_type
  • err : xmc_sdram_type
  • err_code : sense_type
  • errc : xmc_sdram_type
  • errie : flash_type, spi_type
  • errien : i2c_type, usart_type
  • error : usbh_msc_type
  • error_code : i2c_handle_type
  • erstr : flash_type
  • ertc_512_pause : debug_type
  • ertc_pause : debug_type
  • ertcdiv : crm_type
  • ertcen : crm_type
  • ertcsel : crm_type
  • erwf : emac_type
  • esdiv : tmr_type
  • esees : dvp_type
  • eseic : dvp_type
  • eseie : dvp_type
  • eseis : dvp_type
  • esf : tmr_type
  • esfmrtm : emac_ptp_type
  • esp : tmr_type
  • ests : can_type, dvp_type
  • ests_bit : can_type, dvp_type
  • etaf : emac_ptp_type
  • etf : emac_type
  • eti : emac_dma_type
  • eticerr : otg_device_type
  • etr : can_type
  • etrien : can_type
  • etsfem : emac_ptp_type
  • etv : emac_type
  • evten : exint_type
  • evten_bit : exint_type
  • evtenx : exint_type
  • evtgen : dmamux_channel_type, edmamux_channel_type
  • exint0 : scfg_type
  • exint1 : scfg_type
  • exint10 : scfg_type
  • exint11 : scfg_type
  • exint12 : scfg_type
  • exint13 : scfg_type
  • exint14 : scfg_type
  • exint15 : scfg_type
  • exint2 : scfg_type
  • exint3 : scfg_type
  • exint4 : scfg_type
  • exint5 : scfg_type
  • exint6 : scfg_type
  • exint7 : scfg_type
  • exint8 : scfg_type
  • exint9 : scfg_type
  • exintc1 : scfg_type
  • exintc1_bit : scfg_type
  • exintc2 : scfg_type
  • exintc2_bit : scfg_type
  • exintc3 : scfg_type
  • exintc3_bit : scfg_type
  • exintc4 : scfg_type
  • exintc4_bit : scfg_type
  • ext : xmc_bank1_type
  • ext_bit : xmc_bank1_type
  • exten : i2c_type
  • extended_id : can_rx_message_type, can_tx_message_type
  • extmdbw : xmc_bank1_ctrl_tmg_reg_type, xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • exttime : i2c_type


AT32F435/437 Firmwary Library: Data Fields - Variables

- f -

  • fa : flash_type
  • facfg : can_type
  • facfg_bit : can_type
  • faen0 : can_type
  • faen1 : can_type
  • faen10 : can_type
  • faen11 : can_type
  • faen12 : can_type
  • faen13 : can_type
  • faen14 : can_type
  • faen15 : can_type
  • faen16 : can_type
  • faen17 : can_type
  • faen18 : can_type
  • faen19 : can_type
  • faen2 : can_type
  • faen20 : can_type
  • faen21 : can_type
  • faen22 : can_type
  • faen23 : can_type
  • faen24 : can_type
  • faen25 : can_type
  • faen26 : can_type
  • faen27 : can_type
  • faen3 : can_type
  • faen4 : can_type
  • faen5 : can_type
  • faen6 : can_type
  • faen7 : can_type
  • faen8 : can_type
  • faen9 : can_type
  • fap : flash_type, usd_type
  • fast_ethernet_speed : emac_control_config_type
  • fb : emac_dma_type
  • fb_enable : emac_dma_config_type
  • fbee : emac_dma_type
  • fbei : emac_dma_type
  • fbn : spi_type
  • fbwcfg : can_type
  • fbwcfg_bit : can_type
  • fbwsel0 : can_type
  • fbwsel1 : can_type
  • fbwsel10 : can_type
  • fbwsel11 : can_type
  • fbwsel12 : can_type
  • fbwsel13 : can_type
  • fbwsel14 : can_type
  • fbwsel15 : can_type
  • fbwsel16 : can_type
  • fbwsel17 : can_type
  • fbwsel18 : can_type
  • fbwsel19 : can_type
  • fbwsel2 : can_type
  • fbwsel20 : can_type
  • fbwsel21 : can_type
  • fbwsel22 : can_type
  • fbwsel23 : can_type
  • fbwsel24 : can_type
  • fbwsel25 : can_type
  • fbwsel26 : can_type
  • fbwsel27 : can_type
  • fbwsel3 : can_type
  • fbwsel4 : can_type
  • fbwsel5 : can_type
  • fbwsel6 : can_type
  • fbwsel7 : can_type
  • fbwsel8 : can_type
  • fbwsel9 : can_type
  • fcbbpa : emac_type
  • fcontr_en : flash_type
  • fcs : can_type
  • fcsodis : tmr_type
  • fcsodis_state : tmr_brkdt_config_type
  • fcsoen : tmr_type
  • fcsoen_state : tmr_brkdt_config_type
  • fctrl : can_type, edma_stream_type, emac_type
  • fctrl_bit : can_type, edma_stream_type, emac_type
  • fdevmode : otg_global_type
  • fdiv : flash_type
  • fdiv_sts : flash_type
  • fdtf1 : dma_type, edma_type
  • fdtf2 : dma_type, edma_type
  • fdtf3 : dma_type, edma_type
  • fdtf4 : dma_type, edma_type
  • fdtf5 : dma_type, edma_type
  • fdtf6 : dma_type, edma_type
  • fdtf7 : dma_type, edma_type
  • fdtf8 : edma_type
  • fdtfc1 : dma_type, edma_type
  • fdtfc2 : dma_type, edma_type
  • fdtfc3 : dma_type, edma_type
  • fdtfc4 : dma_type, edma_type
  • fdtfc5 : dma_type, edma_type
  • fdtfc6 : dma_type, edma_type
  • fdtfc7 : dma_type, edma_type
  • fdtfc8 : edma_type
  • fdtien : dma_channel_type, edma_stream_type
  • fef : emac_dma_type
  • fef_enable : emac_dma_config_type
  • feien : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • fen : edma_stream_type
  • ferr : usart_type
  • ferrf1 : edma_type
  • ferrf2 : edma_type
  • ferrf3 : edma_type
  • ferrf4 : edma_type
  • ferrf5 : edma_type
  • ferrf6 : edma_type
  • ferrf7 : edma_type
  • ferrf8 : edma_type
  • ferrfc1 : edma_type
  • ferrfc2 : edma_type
  • ferrfc3 : edma_type
  • ferrfc4 : edma_type
  • ferrfc5 : edma_type
  • ferrfc6 : edma_type
  • ferrfc7 : edma_type
  • ferrfc8 : edma_type
  • ferrien : edma_stream_type
  • fes : emac_type, xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • ffb : can_type
  • ffdb1 : can_filter_register_type
  • ffdb2 : can_filter_register_type
  • fhstmode : otg_global_type
  • fifo_length : iap_info_type
  • fifo_mailbox : can_type
  • fifo_mode_enable : edma_init_type
  • fifo_size : usb_core_cfg
  • fifo_threshold : edma_init_type
  • fifoe : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • fifosts : qspi_type
  • fifosts_bit : qspi_type
  • fifth_id : nand_id_type
  • file : http_state
  • file_formart : sd_csd_struct_type
  • file_format_group : sd_csd_struct_type
  • file_handle : http_state
  • file_name : fat_dir_type
  • file_size : fat_dir_type
  • file_write_nr : flash_iap_type
  • filter_activate_enable : can_filter_init_type
  • filter_bit : can_filter_init_type
  • filter_fifo : can_filter_init_type
  • filter_id_high : can_filter_init_type
  • filter_id_low : can_filter_init_type
  • filter_index : can_rx_message_type
  • filter_mask_high : can_filter_init_type
  • filter_mask_low : can_filter_init_type
  • filter_mode : can_filter_init_type
  • filter_number : can_filter_init_type
  • firmware_length : flash_iap_type
  • first_bit_transmission : spi_init_type
  • flag_address : iap_info_type
  • flash_app_addr : flash_iap_type
  • flash_app_size : flash_iap_type
  • flash_base_addr : flash_iap_type
  • flash_end_address : iap_info_type
  • flash_size : flash_iap_type, iap_info_type
  • flash_start_address : iap_info_type
  • flush_rx_disable : emac_dma_config_type
  • fmc : emac_mmc_type
  • fmcfg : can_type
  • fmcfg_bit : can_type
  • fmec : dvp_type
  • fmeu : dvp_type
  • fmsc : dvp_type
  • fmsel0 : can_type
  • fmsel1 : can_type
  • fmsel10 : can_type
  • fmsel11 : can_type
  • fmsel12 : can_type
  • fmsel13 : can_type
  • fmsel14 : can_type
  • fmsel15 : can_type
  • fmsel16 : can_type
  • fmsel17 : can_type
  • fmsel18 : can_type
  • fmsel19 : can_type
  • fmsel2 : can_type
  • fmsel20 : can_type
  • fmsel21 : can_type
  • fmsel22 : can_type
  • fmsel23 : can_type
  • fmsel24 : can_type
  • fmsel25 : can_type
  • fmsel26 : can_type
  • fmsel27 : can_type
  • fmsel3 : can_type
  • fmsel4 : can_type
  • fmsel5 : can_type
  • fmsel6 : can_type
  • fmsel7 : can_type
  • fmsel8 : can_type
  • fmsel9 : can_type
  • fmsu : dvp_type
  • fn : otg_global_type
  • format : linecoding_type
  • fourth_id : nand_id_type
  • fprgm : flash_type
  • fpx : exint_type
  • frame_bit_num : spi_init_type
  • frame_type : can_rx_message_type, can_tx_message_type
  • frf : can_type, dvp_type
  • frf_bit : can_type, dvp_type
  • frfsel0 : can_type
  • frfsel1 : can_type
  • frfsel10 : can_type
  • frfsel11 : can_type
  • frfsel12 : can_type
  • frfsel13 : can_type
  • frfsel14 : can_type
  • frfsel15 : can_type
  • frfsel16 : can_type
  • frfsel17 : can_type
  • frfsel18 : can_type
  • frfsel19 : can_type
  • frfsel2 : can_type
  • frfsel20 : can_type
  • frfsel21 : can_type
  • frfsel22 : can_type
  • frfsel23 : can_type
  • frfsel24 : can_type
  • frfsel25 : can_type
  • frfsel26 : can_type
  • frfsel27 : can_type
  • frfsel3 : can_type
  • frfsel4 : can_type
  • frfsel5 : can_type
  • frfsel6 : can_type
  • frfsel7 : can_type
  • frfsel8 : can_type
  • frfsel9 : can_type
  • frint : otg_host_type
  • frmcntrst : otg_global_type
  • frmf : emac_type
  • frmf_bit : emac_type
  • frmovrun : otg_hchannel_type
  • frmovrunmsk : otg_hchannel_type
  • frnum : otg_host_type
  • fsize : qspi_type
  • fsize_bit : qspi_type
  • fslspclksel : otg_host_type
  • fslssupp : otg_host_type
  • fsts : edma_stream_type
  • ftf : emac_dma_type
  • fthsel : edma_stream_type
  • ftrem : otg_host_type
  • fugf : emac_dma_type
  • fugf_enable : emac_dma_config_type
  • fzc : can_type
  • fzen : can_type


AT32F435/437 Firmwary Library: Data Fields - Variables

- g -

  • g_audio_cur : usb_audio_hid_type, usb_audio_type
  • g_cmd : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • g_keyboard_tx_completed : vcp_keyboard_type
  • g_len : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • g_printer_data : printer_type
  • g_printer_port_status : printer_type
  • g_req : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • g_rx_buff : cdc_msc_struct_type, cdc_struct_type, printer_type, vcp_keyboard_type
  • g_rx_completed : cdc_msc_struct_type, cdc_struct_type, printer_type, vcp_keyboard_type
  • g_rxhid_buff : custom_hid_type, iap_info_type, usb_audio_hid_type
  • g_rxlen : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • g_tx_completed : cdc_msc_struct_type, cdc_struct_type, printer_type, vcp_keyboard_type
  • g_txhid_buff : custom_hid_type, usb_audio_hid_type
  • g_u8tx_completed : keyboard_type
  • gahbcfg : otg_global_type
  • gahbcfg_bit : otg_global_type
  • gcaen : i2c_type
  • gccfg : otg_global_type
  • gccfg_bit : otg_global_type
  • gctrl : dmamux_generator_type, edmamux_generator_type
  • gctrl_bit : dmamux_generator_type, edmamux_generator_type
  • gdiv : usart_type
  • gdiv_bit : usart_type
  • gen : dmamux_generator_type, edmamux_generator_type
  • gen_enable : dmamux_gen_init_type, edmamux_gen_init_type
  • gen_polarity : dmamux_gen_init_type, edmamux_gen_init_type
  • gen_request_number : dmamux_gen_init_type, edmamux_gen_init_type
  • gen_signal_sel : dmamux_gen_init_type, edmamux_gen_init_type
  • genstart : i2c_type
  • genstop : i2c_type
  • gf1 : dma_type
  • gf2 : dma_type
  • gf3 : dma_type
  • gf4 : dma_type
  • gf5 : dma_type
  • gf6 : dma_type
  • gf7 : dma_type
  • gfc1 : dma_type
  • gfc2 : dma_type
  • gfc3 : dma_type
  • gfc4 : dma_type
  • gfc5 : dma_type
  • gfc6 : dma_type
  • gfc7 : dma_type
  • ginnakeff : otg_global_type
  • ginnakeffmsk : otg_global_type
  • gintmsk : otg_global_type
  • gintmsk_bit : otg_global_type
  • gintsts : otg_global_type
  • gintsts_bit : otg_global_type
  • glbintmsk : otg_global_type
  • gnpinnaksts : otg_device_type
  • gnptxfsiz_ept0tx : otg_global_type
  • gnptxfsiz_ept0tx_bit : otg_global_type
  • gnptxsts : otg_global_type
  • gnptxsts_bit : otg_global_type
  • gotgctrl : otg_global_type
  • gotgctrl_bit : otg_global_type
  • gotgint : otg_global_type
  • gotgint_bit : otg_global_type
  • goutnakeff : otg_global_type
  • goutnakeffmsk : otg_global_type
  • goutnaksts : otg_device_type
  • gpio_drive_strength : gpio_init_type
  • gpio_mode : gpio_init_type
  • gpio_out_type : gpio_init_type
  • gpio_pins : gpio_init_type
  • gpio_pull : gpio_init_type
  • gpioaen : crm_type
  • gpioalpen : crm_type
  • gpioarst : crm_type
  • gpioben : crm_type
  • gpioblpen : crm_type
  • gpiobrst : crm_type
  • gpiocen : crm_type
  • gpioclpen : crm_type
  • gpiocrst : crm_type
  • gpioden : crm_type
  • gpiodlpen : crm_type
  • gpiodrst : crm_type
  • gpioeen : crm_type
  • gpioelpen : crm_type
  • gpioerst : crm_type
  • gpiofen : crm_type
  • gpioflpen : crm_type
  • gpiofrst : crm_type
  • gpiogen : crm_type
  • gpioglpen : crm_type
  • gpiogrst : crm_type
  • gpiohen : crm_type
  • gpiohlpen : crm_type
  • gpiohrst : crm_type
  • gpol : dmamux_generator_type, edmamux_generator_type
  • greqcnt : dmamux_generator_type, edmamux_generator_type
  • grstctl : otg_global_type
  • grstctl_bit : otg_global_type
  • grxfsiz : otg_global_type
  • grxfsiz_bit : otg_global_type
  • grxstsp : otg_global_type
  • grxstsp_bit : otg_global_type
  • grxstsr : otg_global_type
  • grxstsr_bit : otg_global_type
  • guc : emac_type
  • guid : otg_global_type
  • guid_bit : otg_global_type
  • gusbcfg : otg_global_type
  • gusbcfg_bit : otg_global_type


AT32F435/437 Firmwary Library: Data Fields - Variables

- h -

  • h : ertc_reg_alarm_type, ertc_reg_time_type, ertc_reg_tstm_type, ertc_type, sc_atr_type
  • haddren : i2c_type
  • haint : otg_host_type
  • haint_bit : otg_host_type
  • haintmsk : otg_host_type
  • haintmsk_bit : otg_host_type
  • hallde : tmr_type
  • hallien : tmr_type
  • hallif : tmr_type
  • hallswtr : tmr_type
  • handle : http_state
  • hc_num : usb_core_cfg
  • hcchar : otg_hchannel_type
  • hcchar_bit : otg_hchannel_type
  • hcfg : otg_host_type
  • hcfg_bit : otg_host_type
  • hchint : otg_global_type
  • hchintmsk : otg_global_type
  • hcint : otg_hchannel_type
  • hcint_bit : otg_hchannel_type
  • hcintmsk : otg_hchannel_type
  • hcintmsk_bit : otg_hchannel_type
  • hcsplt : otg_hchannel_type
  • hcsplt_bit : otg_hchannel_type
  • hctsiz : otg_hchannel_type
  • hctsiz_bit : otg_hchannel_type
  • hdrv : gpio_type
  • hdrv0 : gpio_type
  • hdrv1 : gpio_type
  • hdrv10 : gpio_type
  • hdrv11 : gpio_type
  • hdrv12 : gpio_type
  • hdrv13 : gpio_type
  • hdrv14 : gpio_type
  • hdrv15 : gpio_type
  • hdrv2 : gpio_type
  • hdrv3 : gpio_type
  • hdrv4 : gpio_type
  • hdrv5 : gpio_type
  • hdrv6 : gpio_type
  • hdrv7 : gpio_type
  • hdrv8 : gpio_type
  • hdrv9 : gpio_type
  • hdrv_bit : gpio_type
  • hdtf1 : dma_type, edma_type
  • hdtf2 : dma_type, edma_type
  • hdtf3 : dma_type, edma_type
  • hdtf4 : dma_type, edma_type
  • hdtf5 : dma_type, edma_type
  • hdtf6 : dma_type, edma_type
  • hdtf7 : dma_type, edma_type
  • hdtf8 : edma_type
  • hdtfc1 : dma_type, edma_type
  • hdtfc2 : dma_type, edma_type
  • hdtfc3 : dma_type, edma_type
  • hdtfc4 : dma_type, edma_type
  • hdtfc5 : dma_type, edma_type
  • hdtfc6 : dma_type, edma_type
  • hdtfc7 : dma_type, edma_type
  • hdtfc8 : edma_type
  • hdtien : dma_channel_type, edma_stream_type
  • head : usart_group_type
  • hextbyps : crm_type
  • hexten : crm_type
  • hextstbl : crm_type
  • hextstblf : crm_type
  • hextstblfc : crm_type
  • hextstblien : crm_type
  • hfcen : sdio_type
  • hfir : otg_host_type
  • hfir_bit : otg_host_type
  • hfnum : otg_host_type
  • hfnum_bit : otg_host_type
  • hick_to_sclk : crm_type
  • hick_to_usb : crm_type
  • hickcal : acc_type, crm_type
  • hickcal_key : crm_type
  • hickdiv : crm_type
  • hicken : crm_type
  • hickstbl : crm_type
  • hickstblf : crm_type
  • hickstblfc : crm_type
  • hickstblien : crm_type
  • hicktrim : acc_type, crm_type
  • hid_desc : usbh_hid_type
  • hid_protocol : custom_hid_type, iap_info_type, keyboard_type, mouse_type, usb_audio_hid_type, vcp_keyboard_type
  • hid_set_idle : custom_hid_type, iap_info_type, keyboard_type, mouse_type, usb_audio_hid_type, vcp_keyboard_type
  • hid_set_report : custom_hid_type, iap_info_type, keyboard_type, mouse_type, usb_audio_hid_type, vcp_keyboard_type
  • hid_state : custom_hid_type, iap_info_type, keyboard_type, mouse_type, usb_audio_hid_type, vcp_keyboard_type
  • hid_suspend_flag : keyboard_type, mouse_type
  • hlength : sc_atr_type
  • hlien : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • hls : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • hm : ertc_type
  • hmc : emac_type
  • hour : ertc_alarm_value_type, ertc_time_type
  • hpf : emac_type
  • hprt : otg_host_type
  • hprt_bit : otg_host_type
  • hptxfsiz : otg_global_type
  • hptxfsiz_bit : otg_global_type
  • hptxsts : otg_host_type
  • hptxsts_bit : otg_host_type
  • hrbap : emac_dma_type
  • hrdap : emac_dma_type
  • hscf : dvp_type
  • hscf_bit : dvp_type
  • hseid : dvp_type
  • hses : dvp_type
  • hsic : dvp_type
  • hsie : dvp_type
  • hsis : dvp_type
  • hsp : dvp_type
  • hsrss : dvp_type
  • hsrts : dvp_type
  • hsyn : dvp_type
  • htbap : emac_dma_type
  • htdap : emac_dma_type
  • hth : emac_type
  • hth_bit : emac_type
  • htl : emac_type
  • htl_bit : emac_type
  • hubaddr : otg_hchannel_type
  • huc : emac_type
  • hwcsoe : spi_type


AT32F435/437 Firmwary Library: Data Fields - Variables

- i -

  • i2c1_smbus_timeout : debug_type
  • i2c1en : crm_type
  • i2c1lpen : crm_type
  • i2c1rst : crm_type
  • i2c2_smbus_timeout : debug_type
  • i2c2en : crm_type
  • i2c2lpen : crm_type
  • i2c2rst : crm_type
  • i2c3_smbus_timeout : debug_type
  • i2c3en : crm_type
  • i2c3lpen : crm_type
  • i2c3rst : crm_type
  • i2cen : i2c_type
  • i2cx : i2c_handle_type
  • i2scbn : spi_type
  • i2sclk : spi_type
  • i2sclk_bit : spi_type
  • i2sclkpol : spi_type
  • i2sctrl : spi_type
  • i2sctrl_bit : spi_type
  • i2sdbn : spi_type
  • i2sdiv_h : spi_type
  • i2sdiv_l : spi_type
  • i2sen : spi_type
  • i2smclkoe : spi_type
  • i2smsel : spi_type
  • i2sodd : spi_type
  • iap_address : iap_info_type
  • iap_fifo : iap_info_type
  • iap_rx : iap_info_type
  • iap_tx : iap_info_type
  • iclr : dvp_type
  • iclr_bit : dvp_type
  • iConfiguration : usb_configuration_desc_type
  • id_h : usart_type
  • id_l : usart_type
  • id_type : can_rx_message_type, can_tx_message_type
  • idbn : usart_type
  • idcode_bit : debug_type
  • iden : tmr_type
  • iden_bit : tmr_type
  • idlef : usart_type
  • idleien : usart_type
  • idProduct : usb_device_desc_type
  • idt : crc_type, gpio_type
  • idt0 : gpio_type
  • idt1 : gpio_type
  • idt10 : gpio_type
  • idt11 : gpio_type
  • idt12 : gpio_type
  • idt13 : gpio_type
  • idt14 : gpio_type
  • idt15 : gpio_type
  • idt2 : gpio_type
  • idt3 : gpio_type
  • idt4 : gpio_type
  • idt5 : gpio_type
  • idt6 : gpio_type
  • idt7 : gpio_type
  • idt8 : gpio_type
  • idt9 : gpio_type
  • idt_bit : crc_type, gpio_type
  • idun : dvp_type
  • idus : dvp_type
  • idVendor : usb_device_desc_type
  • ie : emac_dma_type
  • ie_bit : emac_dma_type
  • ieptint : otg_global_type
  • ieptintmsk : otg_global_type
  • ier : dvp_type
  • ier_bit : dvp_type
  • ifg : emac_type
  • iInterface : usb_interface_desc_type
  • iManufacturer : usb_device_desc_type
  • imen : ertc_type
  • imf : ertc_type
  • imr : emac_type
  • imr_bit : emac_type
  • in_maxpacket : usbh_hid_type, usbh_msc_type
  • in_poll : usbh_hid_type, usbh_msc_type
  • inbk : xmc_sdram_type
  • incompip_incompisoout : otg_global_type
  • incompip_incompisooutmsk : otg_global_type
  • incompisoin : otg_global_type
  • incompisoinmsk : otg_global_type
  • ineptint : otg_device_type
  • ineptmsk : otg_device_type
  • ineptnak : otg_eptin_type
  • ineptnakmsk : otg_device_type
  • ineptxfdep : otg_global_type
  • ineptxfemsk : otg_device_type
  • ineptxfsav : otg_eptin_type
  • ineptxfstaddr : otg_global_type
  • information : sense_type
  • init : touch_dev_type
  • initf : ertc_type
  • inout : usb_ept_info
  • input_channel_select : tmr_input_config_type
  • input_filter_value : tmr_input_config_type
  • input_mapped_select : tmr_input_config_type
  • input_polarity_select : tmr_input_config_type
  • inquiry : usbh_msc_unit_type
  • insc : qspi_type
  • inslen : qspi_type
  • instruction_code : qspi_cmd_type
  • instruction_length : qspi_cmd_type
  • intclr : sdio_type
  • intclr_bit : sdio_type
  • inten : can_type, exint_type, sdio_type
  • inten_bit : can_type, exint_type, sdio_type
  • intenx : exint_type
  • interface : usb_audio_hid_type, usb_audio_type
  • interframe_gap : emac_control_config_type
  • internel_banks : xmc_sdram_init_type
  • intkneptmismsk : otg_device_type
  • intkntxfemp : otg_eptin_type
  • intkntxfempmsk : otg_device_type
  • intsts : exint_type
  • intsts_bit : exint_type
  • intwt : sdio_type
  • iocb0 : gpio_type
  • iocb1 : gpio_type
  • iocb10 : gpio_type
  • iocb11 : gpio_type
  • iocb12 : gpio_type
  • iocb13 : gpio_type
  • iocb14 : gpio_type
  • iocb15 : gpio_type
  • iocb2 : gpio_type
  • iocb3 : gpio_type
  • iocb4 : gpio_type
  • iocb5 : gpio_type
  • iocb6 : gpio_type
  • iocb7 : gpio_type
  • iocb8 : gpio_type
  • iocb9 : gpio_type
  • ioen : sdio_type
  • iohizt : xmc_bank4_type
  • ioht : xmc_bank4_type
  • ioif : sdio_type
  • ioifien : sdio_type
  • iomc0 : gpio_type
  • iomc1 : gpio_type
  • iomc10 : gpio_type
  • iomc11 : gpio_type
  • iomc12 : gpio_type
  • iomc13 : gpio_type
  • iomc14 : gpio_type
  • iomc15 : gpio_type
  • iomc2 : gpio_type
  • iomc3 : gpio_type
  • iomc4 : gpio_type
  • iomc5 : gpio_type
  • iomc6 : gpio_type
  • iomc7 : gpio_type
  • iomc8 : gpio_type
  • iomc9 : gpio_type
  • iosb0 : gpio_type
  • iosb1 : gpio_type
  • iosb10 : gpio_type
  • iosb11 : gpio_type
  • iosb12 : gpio_type
  • iosb13 : gpio_type
  • iosb14 : gpio_type
  • iosb15 : gpio_type
  • iosb2 : gpio_type
  • iosb3 : gpio_type
  • iosb4 : gpio_type
  • iosb5 : gpio_type
  • iosb6 : gpio_type
  • iosb7 : gpio_type
  • iosb8 : gpio_type
  • iosb9 : gpio_type
  • iost : xmc_bank4_type
  • iosusp : sdio_type
  • iowt : xmc_bank4_type
  • ipc : emac_type
  • iProduct : usb_device_desc_type
  • ipv4_checksum_offload : emac_control_config_type
  • ir_pol : scfg_type
  • ir_src_sel : scfg_type
  • irdaen : usart_type
  • irdalp : usart_type
  • is_double_buffer : usb_ept_info
  • isdiv : usart_type
  • iSerialNumber : usb_device_desc_type
  • isooutdrop : otg_global_type
  • isooutdropmsk : otg_global_type
  • ists : dvp_type, emac_type, tmr_type
  • ists_bit : dvp_type, emac_type, tmr_type
  • itsrven : adccom_type


AT32F435/437 Firmwary Library: Data Fields - Variables

- j -

  • jabber_disable : emac_control_config_type
  • jd : emac_type
  • jpeg : dvp_type


AT32F435/437 Firmwary Library: Data Fields - Variables

- k -

  • keyboard_buf : keyboard_type
  • keyen : qspi_type


AT32F435/437 Firmwary Library: Data Fields - Variables

- l -

  • l_unit_n : usbh_msc_type
  • last_access_data : fat_dir_type
  • last_len : usb_ept_info
  • last_time : tftp_connection_args
  • lbcp : usart_type
  • lben : can_type
  • lcd_clear : lcd_dev_type
  • lcd_id : lcd_dev_type
  • lcd_init : lcd_dev_type
  • lcd_setblock : lcd_dev_type
  • lcdc : dvp_type
  • lcds : dvp_type
  • ldoov : pwc_type
  • ldoov_bit : pwc_type
  • ldoovsel : pwc_type
  • left : http_state
  • len : fs_file, fsdata_file, fsdata_file_noconst
  • length : FlashEraseData, msc_scsi_data_inquiry, name
  • lextbyps : crm_type
  • lexten : crm_type
  • lextstbl : crm_type
  • lextstblf : crm_type
  • lextstblfc : crm_type
  • lextstblien : crm_type
  • licken : crm_type
  • lickstbl : crm_type
  • lickstblf : crm_type
  • lickstblfc : crm_type
  • lickstblien : crm_type
  • line_enable : exint_init_type
  • line_mode : exint_init_type
  • line_polarity : exint_init_type
  • line_select : exint_init_type
  • linecoding : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • linen : usart_type
  • linex : exint_type
  • llctrl : edma_type
  • llctrl_bit : edma_type
  • LLP : Descriptors_Format_def
  • llp : edma_stream_link_list_type, ll_descriptors_type
  • llp_bit : edma_stream_link_list_type
  • lm : dma_channel_type, edma_stream_type, emac_type
  • lnec : dvp_type
  • lneu : dvp_type
  • lnsc : dvp_type
  • lnsu : dvp_type
  • loen : can_type
  • loop_mode_enable : dma_init_type, edma_init_type
  • loopback_mode : emac_control_config_type
  • low_power : usb_core_cfg
  • lp_mode : otg_global_type
  • lprstf : crm_type
  • lpsel : pwc_type
  • lsamprx : can_type
  • lspddev : otg_hchannel_type
  • ltf : spi_type
  • lun : cbd_extended_type, cbd_typical_type


AT32F435/437 Firmwary Library: Data Fields - Variables

- m -

  • m : ertc_reg_alarm_type, ertc_reg_date_type, ertc_reg_time_type, ertc_reg_tsdt_type, ertc_reg_tstm_type, ertc_type
  • M0A : Descriptors_Format_def
  • m0addr : edma_stream_type, ll_descriptors_type
  • m0addr_bit : edma_stream_type
  • m1addr : edma_stream_type
  • m1addr_bit : edma_stream_type
  • m2m : dma_channel_type
  • ma0h : emac_type
  • ma0l : emac_type
  • ma1h : emac_type
  • ma1l : emac_type
  • ma2h : emac_type
  • ma2l : emac_type
  • ma3h : emac_type
  • ma3l : emac_type
  • maddr : dma_channel_type
  • maddr_bit : dma_channel_type
  • maker_id : nand_id_type
  • manufact_date : sd_cid_struct_type
  • manufacturer_code : nor_idtype
  • manufacturer_default_ecc : sd_csd_struct_type
  • manufacturer_id : sd_cid_struct_type
  • mask : ertc_alarm_value_type
  • mask1 : ertc_reg_alarm_type, ertc_type
  • mask2 : ertc_reg_alarm_type, ertc_type
  • mask3 : ertc_reg_alarm_type, ertc_type
  • mask4 : ertc_reg_alarm_type, ertc_type
  • master_slave_mode : spi_init_type
  • max_bus_clk_freq : sd_csd_struct_type
  • max_lun : cdc_msc_struct_type, msc_type, usbh_msc_type
  • max_read_blk_length : sd_csd_struct_type
  • max_read_current_vdd_max : sd_csd_struct_type
  • max_read_current_vdd_min : sd_csd_struct_type
  • max_size : usb_core_cfg
  • max_write_blk_length : sd_csd_struct_type
  • max_write_current_vdd_max : sd_csd_struct_type
  • max_write_current_vdd_min : sd_csd_struct_type
  • maxpacket : usb_ept_info, usb_hch_type
  • mb : emac_type
  • mbc : emac_type
  • mc : otg_eptin_type, otg_hchannel_type
  • mclk_freq_division : spi_init_type
  • mclk_output_enable : i2s_init_type
  • mct : edma_stream_type
  • mctrl : can_type
  • mctrl_bit : can_type
  • md : emac_type
  • mdiv3en : spi_type
  • mdiv_h : spi_type
  • mdiv_l : spi_type
  • mdrsel : can_type
  • mdrsel_selection : can_base_type
  • mem_hiz_time : xmc_nand_pccard_timinginit_type
  • mem_hold_time : xmc_nand_pccard_timinginit_type
  • mem_map_sel : scfg_type
  • mem_setup_time : xmc_nand_pccard_timinginit_type
  • mem_waite_time : xmc_nand_pccard_timinginit_type
  • memory0_base_addr : edma_init_type
  • memory_base_addr : dma_init_type
  • memory_burst_mode : edma_init_type
  • memory_data_width : dma_init_type, edma_init_type
  • memory_inc_enable : dma_init_type, edma_init_type
  • mfbocnt : emac_dma_type
  • mfbocnt_bit : emac_dma_type
  • mfc : emac_dma_type
  • mibe : dvp_type
  • mibthd : dvp_type
  • mic_adj_count : audio_codec_type
  • mic_adj_stage : audio_codec_type
  • mic_alt_setting : usb_audio_hid_type, usb_audio_type
  • mic_buffer : audio_codec_type
  • mic_calc : audio_codec_type
  • mic_delta : audio_codec_type
  • mic_enable : audio_codec_type
  • mic_freq : usb_audio_hid_type, usb_audio_type
  • mic_mute : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • mic_roff : audio_codec_type
  • mic_rtotal : audio_codec_type
  • mic_rx_size : audio_codec_type
  • mic_stage : audio_codec_type
  • mic_volume : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • mic_volume_limits : usb_audio_hid_type, usb_audio_type
  • mic_wend : audio_codec_type
  • mic_woff : audio_codec_type
  • mic_wtotal : audio_codec_type
  • mii : emac_type
  • mii_rmii_sel : scfg_type
  • miiaddr : emac_type
  • miiaddr_bit : emac_type
  • miidt : emac_type
  • miidt_bit : emac_type
  • min : ertc_alarm_value_type, ertc_time_type
  • mincm : dma_channel_type, edma_stream_type
  • mis : emac_type
  • misc1 : crm_type
  • misc1_bit : crm_type
  • misc2 : crm_type
  • misc2_bit : crm_type
  • mmerr : spi_type
  • mmi : emac_dma_type
  • mmssr : can_type
  • mmssr_selection : can_base_type
  • mode : i2c_handle_type, xmc_norsram_timing_init_type
  • mode_selection : can_base_type
  • modemis : otg_global_type
  • modemismsk : otg_global_type
  • month : ertc_time_type
  • mouse_buffer : mouse_type
  • mpi : emac_dma_type
  • mps : otg_eptin_type, otg_eptout_type, otg_hchannel_type
  • mrd : xmc_sdram_type
  • mris : emac_type
  • msc_state : cdc_msc_struct_type, msc_type
  • msc_struct : msc_bot_trans_type
  • msc_up_status : flash_iap_type
  • msdmasel_h : adccom_type
  • msdmasel_l : adccom_type
  • msdrcen : adccom_type
  • mssel : adccom_type
  • msten : spi_type
  • msts : can_type
  • msts_bit : can_type
  • mtis : emac_type
  • muxctrl : dmamux_channel_type, edmamux_channel_type
  • muxctrl_bit : dmamux_channel_type, edmamux_channel_type
  • muxgclr : dma_type, edma_type
  • muxgclr_bit : dma_type, edma_type
  • muxgsts : dma_type, edma_type
  • muxgsts_bit : dma_type, edma_type
  • muxh : gpio_type
  • muxh10 : gpio_type
  • muxh11 : gpio_type
  • muxh12 : gpio_type
  • muxh13 : gpio_type
  • muxh14 : gpio_type
  • muxh15 : gpio_type
  • muxh8 : gpio_type
  • muxh9 : gpio_type
  • muxh_bit : gpio_type
  • muxl : gpio_type
  • muxl0 : gpio_type
  • muxl1 : gpio_type
  • muxl2 : gpio_type
  • muxl3 : gpio_type
  • muxl4 : gpio_type
  • muxl5 : gpio_type
  • muxl6 : gpio_type
  • muxl7 : gpio_type
  • muxl_bit : gpio_type
  • muxsel : dma_type, edma_type
  • muxsel_bit : dma_type, edma_type
  • muxsyncclr : dma_type, edma_type
  • muxsyncclr_bit : dma_type, edma_type
  • muxsyncsts : dma_type, edma_type
  • muxsyncsts_bit : dma_type, edma_type
  • mw : emac_type
  • mwidth : dma_channel_type, edma_stream_type
  • mwmc : xmc_bank1_ctrl_tmg_reg_type


AT32F435/437 Firmwary Library: Data Fields - Variables

- n -

  • nacken : i2c_type
  • nak : otg_hchannel_type
  • nakmsk : otg_hchannel_type
  • naksts : otg_eptin_type, otg_eptout_type
  • name : default_filename, fsdata_file, fsdata_file_noconst
  • nand_bank : xmc_nand_init_type
  • nerr : usart_type
  • next : fsdata_file, fsdata_file_noconst
  • nie : emac_dma_type
  • nis : emac_dma_type
  • noren : xmc_bank1_ctrl_tmg_reg_type
  • nptxfdep : otg_global_type
  • nptxfemp : otg_global_type
  • nptxfemplvl : otg_global_type
  • nptxfempmsk : otg_global_type
  • nptxfspcavail : otg_global_type
  • nptxfstaddr : otg_global_type
  • nptxqspcavail : otg_global_type
  • nptxqtop : otg_global_type
  • nrstf : crm_type
  • nsac : sd_csd_struct_type
  • ntc : spi_type
  • nwasen : xmc_bank1_ctrl_tmg_reg_type
  • nwen : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • nwpol : xmc_bank1_ctrl_tmg_reg_type
  • nwsen : xmc_bank1_ctrl_tmg_reg_type
  • nwtcfg : xmc_bank1_ctrl_tmg_reg_type
  • nzstsouthshk : otg_device_type
  • nzw_bst : flash_type
  • nzw_bst_sts : flash_type


AT32F435/437 Firmwary Library: Data Fields - Variables

- o -

  • oaddr1 : i2c_type
  • oaddr1_bit : i2c_type
  • oaddr2 : i2c_type
  • oaddr2_bit : i2c_type
  • obf : flash_type
  • obfoc : emac_dma_type
  • obmfc : emac_dma_type
  • oc_idle_state : tmr_output_config_type
  • oc_mode : tmr_output_config_type
  • oc_output_state : tmr_output_config_type
  • oc_polarity : tmr_output_config_type
  • occ_idle_state : tmr_output_config_type
  • occ_output_state : tmr_output_config_type
  • occ_polarity : tmr_output_config_type
  • occe : adc_type
  • occe1 : adccom_type
  • occe2 : adccom_type
  • occe3 : adccom_type
  • occeien : adc_type
  • occo : adc_type
  • occo1 : adccom_type
  • occo2 : adccom_type
  • occo3 : adccom_type
  • occoien : adc_type
  • occs : adc_type
  • occs1 : adccom_type
  • occs2 : adccom_type
  • occs3 : adccom_type
  • ocdmaen : adc_type
  • ocdrcen : adc_type
  • ocete : adc_type
  • oclen : adc_type
  • ocmen : tmr_type
  • ocpcnt : adc_type
  • ocpen : adc_type
  • ocswtrg : adc_type
  • octesel_h : adc_type
  • octesel_l : adc_type
  • ocvmen : adc_type
  • oddfrm : otg_hchannel_type
  • odf : flash_type
  • odfie : flash_type
  • odrv0 : gpio_type
  • odrv1 : gpio_type
  • odrv10 : gpio_type
  • odrv11 : gpio_type
  • odrv12 : gpio_type
  • odrv13 : gpio_type
  • odrv14 : gpio_type
  • odrv15 : gpio_type
  • odrv2 : gpio_type
  • odrv3 : gpio_type
  • odrv4 : gpio_type
  • odrv5 : gpio_type
  • odrv6 : gpio_type
  • odrv7 : gpio_type
  • odrv8 : gpio_type
  • odrv9 : gpio_type
  • odrvr : gpio_type
  • odrvr_bit : gpio_type
  • odt : adc_type, gpio_type
  • odt0 : gpio_type
  • odt1 : gpio_type
  • odt10 : gpio_type
  • odt11 : gpio_type
  • odt12 : gpio_type
  • odt13 : gpio_type
  • odt14 : gpio_type
  • odt15 : gpio_type
  • odt2 : gpio_type
  • odt3 : gpio_type
  • odt4 : gpio_type
  • odt5 : gpio_type
  • odt6 : gpio_type
  • odt7 : gpio_type
  • odt8 : gpio_type
  • odt9 : gpio_type
  • odt_bit : adc_type, gpio_type
  • oem_app_id : sd_cid_struct_type
  • oen : tmr_type
  • oeptint : otg_global_type
  • oeptintmsk : otg_global_type
  • ofc : emac_dma_type
  • offset_into_block : FlashParamsHolder
  • ofne : dvp_type
  • om0 : gpio_type
  • om1 : gpio_type
  • om10 : gpio_type
  • om11 : gpio_type
  • om12 : gpio_type
  • om13 : gpio_type
  • om14 : gpio_type
  • om15 : gpio_type
  • om2 : gpio_type
  • om3 : gpio_type
  • om4 : gpio_type
  • om5 : gpio_type
  • om6 : gpio_type
  • om7 : gpio_type
  • om8 : gpio_type
  • om9 : gpio_type
  • omode : gpio_type
  • omode_bit : gpio_type
  • oosen : adc_type
  • oosrsel : adc_type
  • oostren : adc_type
  • op : tftp_connection_args
  • opcode : cbd_extended_type, cbd_typical_type
  • operation_mode : i2s_init_type, qspi_cmd_type
  • opersel : spi_type
  • oplk : flash_type
  • opm : emac_dma_type
  • opm_bit : emac_dma_type
  • opmode : qspi_type
  • ora : spi_type
  • ordinary_channel_length : adc_base_config_type
  • osf : emac_dma_type
  • osf_enable : emac_dma_config_type
  • osn1 : adc_type
  • osn10 : adc_type
  • osn11 : adc_type
  • osn12 : adc_type
  • osn13 : adc_type
  • osn14 : adc_type
  • osn15 : adc_type
  • osn16 : adc_type
  • osn2 : adc_type
  • osn3 : adc_type
  • osn4 : adc_type
  • osn5 : adc_type
  • osn6 : adc_type
  • osn7 : adc_type
  • osn8 : adc_type
  • osn9 : adc_type
  • osq1 : adc_type
  • osq1_bit : adc_type
  • osq2 : adc_type
  • osq2_bit : adc_type
  • osq3 : adc_type
  • osq3_bit : adc_type
  • osrsel : adc_type
  • osssel : adc_type
  • otgfs1en : crm_type
  • otgfs1lpen : crm_type
  • otgfs1rst : crm_type
  • otgfs2en : crm_type
  • otgfs2lpen : crm_type
  • otgfs2rst : crm_type
  • otgint : otg_global_type
  • otgintmsk : otg_global_type
  • ouf : i2c_type
  • oufc : i2c_type
  • out_maxpacket : usbh_hid_type, usbh_msc_type
  • out_poll : usbh_hid_type, usbh_msc_type
  • outeptint : otg_device_type
  • outeptmsk : otg_device_type
  • outp : ertc_type
  • outperrmsk : otg_device_type
  • outsel : ertc_type
  • outtepd : otg_eptout_type
  • outtepdmsk : otg_device_type
  • outtype : ertc_type
  • ove : emac_dma_type
  • ovf : emac_dma_type
  • ovfden : tmr_type
  • ovfen : tmr_type
  • ovfien : tmr_type
  • ovfif : tmr_type
  • ovfs : tmr_type
  • ovfswtr : tmr_type
  • ovres : dvp_type
  • ovric : dvp_type
  • ovrie : dvp_type
  • ovris : dvp_type
  • ovsp : adc_type
  • ovsp_bit : adc_type


AT32F435/437 Firmwary Library: Data Fields - Variables

- p -

  • PA : Descriptors_Format_def
  • pa : emac_type
  • paddr : dma_channel_type, edma_stream_type, ll_descriptors_type
  • paddr_bit : dma_channel_type, edma_stream_type
  • page : nand_address_type
  • parity : linecoding_type
  • part_blk_read : sd_csd_struct_type
  • part_blk_write : sd_csd_struct_type
  • pb10_uh : scfg_type
  • pb3_uh : scfg_type
  • pb9_uh : scfg_type
  • pbl : emac_dma_type
  • pblx8 : emac_dma_type
  • pbuff : i2c_handle_type
  • pcautoen : adc_type
  • pcb : http_state
  • pcce : adc_type
  • pcce1 : adccom_type
  • pcce2 : adccom_type
  • pcce3 : adccom_type
  • pcceien : adc_type
  • pccs : adc_type
  • pccs1 : adccom_type
  • pccs2 : adccom_type
  • pccs3 : adccom_type
  • pcdc : dvp_type
  • pcdes : dvp_type
  • pcds : dvp_type
  • pcdto1 : adc_type
  • pcdto1_bit : adc_type
  • pcdto2 : adc_type
  • pcdto2_bit : adc_type
  • pcdto3 : adc_type
  • pcdto3_bit : adc_type
  • pcdto4 : adc_type
  • pcdto4_bit : adc_type
  • pcete : adc_type
  • pcf : emac_type
  • pcgcctl : otg_pcgcctl_type
  • pcgcctl_bit : otg_pcgcctl_type
  • pclen : adc_type
  • pcmfssel : spi_type
  • pcount : i2c_handle_type
  • pcpen : adc_type
  • pcswtrg : adc_type
  • pct : edma_stream_type
  • pctesel_h : adc_type
  • pctesel_l : adc_type
  • pcvmen : adc_type
  • pd : emac_type
  • pd12_uh : scfg_type
  • pd13_uh : scfg_type
  • pd14_uh : scfg_type
  • pd15_uh : scfg_type
  • pdev_type : msc_scsi_data_inquiry
  • pdl : dvp_type
  • pdt1 : adc_type
  • pdt1_bit : adc_type
  • pdt2 : adc_type
  • pdt2_bit : adc_type
  • pdt3 : adc_type
  • pdt3_bit : adc_type
  • pdt4 : adc_type
  • pdt4_bit : adc_type
  • pe_mode_enable : qspi_cmd_type
  • pe_mode_operate_code : qspi_cmd_type
  • pec : i2c_type
  • pec_bit : i2c_type
  • pecen : i2c_type
  • pecerr : i2c_type
  • pecerrc : i2c_type
  • pecten : i2c_type
  • pecval : i2c_type
  • pemen : qspi_type
  • pemopc : qspi_type
  • pen : usart_type
  • perfrint : otg_device_type
  • peripheral_base_addr : dma_init_type, edma_init_type
  • peripheral_burst_mode : edma_init_type
  • peripheral_data_width : dma_init_type, edma_init_type
  • peripheral_inc_enable : dma_init_type, edma_init_type
  • permanent_write_protect : sd_csd_struct_type
  • perr : usart_type
  • perrien : usart_type
  • pf14_uh : scfg_type
  • pf15_uh : scfg_type
  • pfctrl : edma_stream_type
  • phy_itface : usb_core_cfg
  • pid : debug_type, otg_hchannel_type
  • pim : emac_type
  • pincm : dma_channel_type, edma_stream_type
  • pincos : edma_stream_type
  • pis : emac_type
  • piusftrst : otg_global_type
  • pktcnt : otg_eptin_type, otg_eptout_type, otg_hchannel_type
  • pktsts : otg_global_type
  • pllcfg : crm_type
  • pllcfg_bit : crm_type
  • pllen : crm_type
  • pllfr : crm_type
  • pllms : crm_type
  • pllns : crm_type
  • pllrcs : crm_type
  • pllstbl : crm_type
  • pllstblf : crm_type
  • pllstblfc : crm_type
  • pllstblien : crm_type
  • plt : emac_type
  • pmc : emac_type
  • pmen : tmr_type
  • pmtctrlsts : emac_type
  • pmtctrlsts_bit : emac_type
  • pndwt : sdio_type
  • pofc : emac_ptp_type
  • polcfg1 : exint_type
  • polcfg1_bit : exint_type
  • polcfg2 : exint_type
  • polcfg2_bit : exint_type
  • poll_timer : usbh_hid_type, usbh_msc_type
  • porrstf : crm_type
  • posen : adc_type
  • ppscr : emac_ptp_type
  • ppscr_bit : emac_ptp_type
  • pr : emac_dma_type, emac_type, tmr_type
  • pr_bit : tmr_type
  • prben : tmr_type
  • pre_state : usbh_msc_unit_type
  • prgmerr : flash_type
  • priority : dma_init_type, edma_init_type
  • priority_ratio : emac_dma_config_type
  • product : msc_scsi_data_inquiry
  • product_name1 : sd_cid_struct_type
  • product_name2 : sd_cid_struct_type
  • product_reversion : sd_cid_struct_type
  • product_sn : sd_cid_struct_type
  • protocol : usbh_hid_type, usbh_msc_type
  • prsf_enable : can_base_type
  • prsfen : can_type
  • prtaddr : otg_hchannel_type
  • prtcondet : otg_host_type
  • prtconsts : otg_host_type
  • prtena : otg_host_type
  • prtenchng : otg_host_type
  • prtint : otg_global_type
  • prtintmsk : otg_global_type
  • prtlnsts : otg_host_type
  • prtovrcact : otg_host_type
  • prtovrcchng : otg_host_type
  • prtpwr : otg_host_type
  • prtres : otg_host_type
  • prtrst : otg_host_type
  • prtspd : otg_host_type
  • prtsusp : otg_host_type
  • prttsctl : otg_host_type
  • ps : sdio_type
  • psel : usart_type
  • psize : i2c_handle_type
  • psn1 : adc_type
  • psn2 : adc_type
  • psn3 : adc_type
  • psn4 : adc_type
  • psq : adc_type
  • psq_bit : adc_type
  • psr : flash_type
  • psr_bit : flash_type
  • pt : emac_type
  • ptd : can_type
  • ptos : tmr_type
  • ptxfemp : otg_global_type
  • ptxfemplvl : otg_global_type
  • ptxfempmsk : otg_global_type
  • ptxfsize : otg_global_type
  • ptxfspcavil : otg_host_type
  • ptxfstaddr : otg_global_type
  • ptxqspcavil : otg_host_type
  • ptxqtop : otg_host_type
  • pull : gpio_type
  • pull0 : gpio_type
  • pull1 : gpio_type
  • pull10 : gpio_type
  • pull11 : gpio_type
  • pull12 : gpio_type
  • pull13 : gpio_type
  • pull14 : gpio_type
  • pull15 : gpio_type
  • pull2 : gpio_type
  • pull3 : gpio_type
  • pull4 : gpio_type
  • pull5 : gpio_type
  • pull6 : gpio_type
  • pull7 : gpio_type
  • pull8 : gpio_type
  • pull9 : gpio_type
  • pull_bit : gpio_type
  • pvmen : pwc_type
  • pvmof : pwc_type
  • pvmsel : pwc_type
  • pwcen : crm_type
  • pwclpen : crm_type
  • pwcrst : crm_type
  • pwidth : dma_channel_type, edma_stream_type
  • pwrctrl : sdio_type
  • pwrctrl_bit : sdio_type
  • pwrdown : otg_global_type
  • pwroprgdne : otg_device_type
  • pwrsven : sdio_type


AT32F435/437 Firmwary Library: Data Fields - Variables

- q -

  • qdzien : can_type
  • qdzif : can_type
  • qspi1en : crm_type
  • qspi1lpen : crm_type
  • qspi1rst : crm_type
  • qspi2en : crm_type
  • qspi2lpen : crm_type
  • qspi2rst : crm_type
  • qspikey : usd_type


AT32F435/437 Firmwary Library: Data Fields - Variables

- r -

  • ra : emac_type, xmc_sdram_type
  • raefacim : emac_mmc_type
  • rbu : emac_dma_type
  • rbue : emac_dma_type
  • rc : emac_mmc_type, xmc_sdram_type
  • rca : sd_card_info_struct_type
  • rcden : ertc_type
  • rcefcim : emac_mmc_type
  • rcnt : xmc_sdram_type
  • rcnt_bit : xmc_sdram_type
  • rcrc : spi_type
  • rcrc_bit : spi_type
  • rd : xmc_sdram_type
  • rdbf : i2c_type, spi_type, usart_type
  • rdbfie : spi_type
  • rdbfien : usart_type
  • rdien : i2c_type
  • rdladdr : emac_dma_type
  • rdladdr_bit : emac_dma_type
  • rdp : emac_dma_type
  • rdwtmode : sdio_type
  • rdwtstart : sdio_type
  • rdwtstop : sdio_type
  • rdy : adc_type
  • rdy1 : adccom_type
  • rdy2 : adccom_type
  • rdy3 : adccom_type
  • re : emac_type
  • read_address_length : qspi_xip_type
  • read_blk_misalign : sd_csd_struct_type
  • read_crc : flash_iap_type
  • read_data_counter : qspi_xip_type
  • read_delay : xmc_sdram_init_type
  • read_instruction_code : qspi_xip_type
  • read_operation_mode : qspi_xip_type
  • read_second_dummy_cycle_num : qspi_xip_type
  • read_select_mode : qspi_xip_type
  • read_status_config : qspi_cmd_type
  • read_status_enable : qspi_cmd_type
  • read_time_counter : qspi_xip_type
  • readh10 : i2c_type
  • ready : usbh_msc_unit_type
  • realrx : can_type
  • rec : can_type
  • receive_own_disable : emac_control_config_type
  • reien : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • rem0_len : usb_ept_info
  • ren : usart_type
  • repeat_mode : adc_base_config_type
  • reqcnt : dmamux_channel_type, edmamux_channel_type
  • reqsel : dmamux_channel_type, edmamux_channel_type
  • request_no : usb_audio_hid_type, usb_audio_type
  • res : fat_dir_type
  • Res : FlashDevice
  • res : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • reserved : msc_scsi_data_inquiry, tmr_type
  • reserved1 : acc_type, adc_type, adccom_type, can_fifo_mailbox_type, can_tx_mailbox_type, can_type, cbd_extended_type, cbd_typical_type, crc_type, crm_type, dac_type, debug_type, dma_channel_type, dma_type, dmamux_channel_type, dmamux_generator_type, dvp_type, edma_stream_type, edma_type, edmamux_channel_type, edmamux_generator_type, emac_dma_type, emac_mmc_type, emac_ptp_type, emac_type, ertc_reg_date_type, ertc_reg_scal_type, ertc_reg_tadj_type, ertc_reg_time_type, ertc_reg_tsdt_type, ertc_reg_tstm_type, ertc_type, exint_type, flash_type, gpio_type, i2c_type, otg_device_type, otg_eptin_type, otg_eptout_type, otg_global_type, otg_hchannel_type, otg_host_type, otg_pcgcctl_type, pwc_type, qspi_type, scfg_type, sd_cid_struct_type, sd_csd_struct_type, sd_scr_struct_type, sdio_type, sense_type, spi_type, tmr_type, usart_type, usd_type, wdt_type, wwdt_type, xmc_bank1_ctrl_tmg_reg_type, xmc_bank1_tmgwr_reg_type, xmc_bank1_type, xmc_bank2_type, xmc_bank3_type, xmc_bank4_type, xmc_sdram_type
  • reserved2 : acc_type, adc_type, adccom_type, can_tx_mailbox_type, can_type, cbd_extended_type, cbd_typical_type, crc_type, crm_type, dac_type, debug_type, dma_type, dmamux_channel_type, dmamux_generator_type, dvp_type, edma_stream_type, edma_type, edmamux_channel_type, edmamux_generator_type, emac_dma_type, emac_mmc_type, emac_ptp_type, emac_type, ertc_reg_date_type, ertc_reg_scal_type, ertc_reg_time_type, ertc_reg_tsdt_type, ertc_reg_tstm_type, ertc_type, flash_type, i2c_type, otg_device_type, otg_eptin_type, otg_eptout_type, otg_global_type, otg_hchannel_type, otg_host_type, otg_pcgcctl_type, pwc_type, qspi_type, scfg_type, sd_cid_struct_type, sd_csd_struct_type, sdio_type, sense_type, spi_type, tmr_type, usart_type, usd_type, xmc_bank1_ctrl_tmg_reg_type, xmc_bank1_tmgwr_reg_type, xmc_bank1_type, xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • reserved3 : acc_type, adccom_type, can_type, crm_type, dac_type, debug_type, dmamux_channel_type, dmamux_generator_type, dvp_type, edma_stream_type, edma_type, edmamux_channel_type, edmamux_generator_type, emac_dma_type, emac_mmc_type, emac_type, ertc_reg_time_type, ertc_reg_tstm_type, ertc_type, flash_type, i2c_type, otg_device_type, otg_eptin_type, otg_eptout_type, otg_global_type, otg_hchannel_type, qspi_type, scfg_type, sd_csd_struct_type, sense_type, tmr_type, usart_type, xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • reserved4 : adccom_type, can_type, crm_type, debug_type, dvp_type, edma_type, emac_dma_type, emac_mmc_type, emac_type, flash_type, otg_device_type, otg_global_type, qspi_type, sd_csd_struct_type
  • reserved5 : adccom_type, can_type, crm_type, dvp_type, edma_type, emac_dma_type, emac_type, flash_type, otg_global_type
  • reserved6 : can_type, crm_type, dvp_type, edma_type, emac_dma_type, flash_type, otg_global_type
  • reserved7 : crm_type, dvp_type, flash_type
  • reserved8 : dvp_type
  • reserverd2 : sd_scr_struct_type
  • reserverd3 : sd_scr_struct_type
  • respond_flag : iap_info_type
  • retries : http_state
  • retry_disable : emac_control_config_type
  • rev : qspi_type
  • rev_bit : qspi_type
  • revid : crc_type
  • revision : msc_scsi_data_inquiry
  • revod : crc_type
  • rf0 : can_type
  • rf0_bit : can_type
  • rf0ff : can_type
  • rf0fien : can_type
  • rf0mien : can_type
  • rf0mn : can_type
  • rf0of : can_type
  • rf0oien : can_type
  • rf0r : can_type
  • rf1 : can_type
  • rf1_bit : can_type
  • rf1ff : can_type
  • rf1fien : can_type
  • rf1mien : can_type
  • rf1mn : can_type
  • rf1of : can_type
  • rf1oien : can_type
  • rf1r : can_type
  • rfae : emac_mmc_type
  • rfaec : emac_mmc_type
  • rfaecnt : emac_mmc_type
  • rfaecnt_bit : emac_mmc_type
  • rfc : can_fifo_mailbox_type
  • rfc_bit : can_fifo_mailbox_type
  • rfce : emac_mmc_type
  • rfcec : emac_mmc_type
  • rfcecnt : emac_mmc_type
  • rfcecnt_bit : emac_mmc_type
  • rfdt0 : can_fifo_mailbox_type
  • rfdt1 : can_fifo_mailbox_type
  • rfdt2 : can_fifo_mailbox_type
  • rfdt3 : can_fifo_mailbox_type
  • rfdt4 : can_fifo_mailbox_type
  • rfdt5 : can_fifo_mailbox_type
  • rfdt6 : can_fifo_mailbox_type
  • rfdt7 : can_fifo_mailbox_type
  • rfdth : can_fifo_mailbox_type
  • rfdth_bit : can_fifo_mailbox_type
  • rfdtl : can_fifo_mailbox_type
  • rfdtl_bit : can_fifo_mailbox_type
  • rfeid : can_fifo_mailbox_type
  • rffmn : can_fifo_mailbox_type
  • rffri : can_fifo_mailbox_type
  • rfi : can_fifo_mailbox_type
  • rfi_bit : can_fifo_mailbox_type
  • rfidi : can_fifo_mailbox_type
  • rfsid : can_fifo_mailbox_type
  • rfts : can_fifo_mailbox_type
  • rguf : emac_mmc_type
  • rgufc : emac_mmc_type
  • rgufcnt : emac_mmc_type
  • rgufcnt_bit : emac_mmc_type
  • ri : emac_dma_type, emac_mmc_type
  • ri_bit : emac_mmc_type
  • rie : emac_dma_type
  • rim : emac_mmc_type
  • rim_bit : emac_mmc_type
  • rld : wdt_type
  • rld_bit : wdt_type
  • rlden : i2c_type
  • rldf : wdt_type, wwdt_type
  • rldien : wwdt_type
  • rm : usart_type
  • rmb : msc_scsi_data_inquiry
  • rmp : emac_type, tmr_type
  • rmp_bit : tmr_type
  • roerr : spi_type, usart_type
  • row_address : xmc_sdram_init_type
  • rpd : emac_dma_type
  • rpd_bit : emac_dma_type
  • rpen : adc_type
  • rpr : tmr_type
  • rpr_bit : tmr_type
  • rps : emac_dma_type
  • rpx : exint_type
  • rr : emac_mmc_type
  • rrwf : emac_type
  • rs : emac_dma_type
  • rs485en : usart_type
  • rsaw : can_type
  • rsaw_size : can_baudrate_type
  • rse : emac_dma_type
  • rsf : emac_dma_type
  • rsf_enable : emac_dma_config_type
  • rslost : acc_type
  • rsp1 : sdio_type
  • rsp1_bit : sdio_type
  • rsp2 : sdio_type
  • rsp2_bit : sdio_type
  • rsp3 : sdio_type
  • rsp3_bit : sdio_type
  • rsp4 : sdio_type
  • rsp4_bit : sdio_type
  • rsp_type : sdio_command_struct_type
  • rspcmd : sdio_type
  • rspcmd_bit : sdio_type
  • rspwt : sdio_type
  • rst : crc_type
  • rstfc : crm_type
  • rsts : qspi_type
  • rsts_bit : qspi_type
  • rstsc : qspi_type
  • rstsen : qspi_type
  • rtc : emac_dma_type
  • rtsen : usart_type
  • rugfcim : emac_mmc_type
  • rwff : emac_type
  • rwffpr : emac_type
  • rwkupsig : otg_device_type
  • rwt : emac_dma_type
  • rwtd : xmc_bank1_ctrl_tmg_reg_type
  • rwte : emac_dma_type
  • rx_addr : usb_ept_info
  • rx_dma_pal : emac_dma_config_type
  • rx_threshold : emac_dma_config_type
  • rxbuf : sdio_type
  • rxbufe : sdio_type
  • rxbufeien : sdio_type
  • rxbuff : sdio_type
  • rxbuffien : sdio_type
  • rxbufh : sdio_type
  • rxbufhien : sdio_type
  • rxbufien : sdio_type
  • rxdpid_setupcnt : otg_eptout_type
  • rxdt : i2c_type
  • rxdt_bit : i2c_type
  • rxerro : sdio_type
  • rxerroien : sdio_type
  • rxfdep : otg_global_type
  • rxfflsh : otg_global_type
  • rxfifo_thod : qspi_type
  • rxfifordy : qspi_type
  • rxflvl : otg_global_type
  • rxflvlmsk : otg_global_type


AT32F435/437 Firmwary Library: Data Fields - Variables

- s -

  • s : ertc_reg_alarm_type, ertc_reg_time_type, ertc_reg_tstm_type, ertc_type
  • s12den : edma_type
  • s1llen : edma_type
  • s22den : edma_type
  • s2dcnt : edma_stream_2d_type
  • s2dcnt_bit : edma_stream_2d_type
  • s2dctrl : edma_type
  • s2dctrl_bit : edma_type
  • s2llen : edma_type
  • s32den : edma_type
  • s3llen : edma_type
  • s42den : edma_type
  • s4llen : edma_type
  • s52den : edma_type
  • s5llen : edma_type
  • s62den : edma_type
  • s6llen : edma_type
  • s72den : edma_type
  • s7llen : edma_type
  • s82den : edma_type
  • s8llen : edma_type
  • sa : emac_type
  • saddr : i2c_type
  • saf : emac_type
  • saif : emac_type
  • sampling_interval : adc_common_config_type
  • sbf : usart_type
  • sbiterr : sdio_type
  • sbiterrien : sdio_type
  • sbs : ertc_type
  • sbs_bit : ertc_type
  • sbsmsk : ertc_type
  • scal : ertc_reg_scal_type, ertc_type
  • scal_bit : ertc_reg_scal_type, ertc_type
  • scfgen : crm_type
  • scfglpen : crm_type
  • scfgrst : crm_type
  • scgt : usart_type
  • sckmode : qspi_type
  • scld : i2c_type
  • sclh : i2c_type
  • sclk_freq : crm_clocks_freq_type
  • sclksel : crm_type
  • sclksts : crm_type
  • scll : i2c_type
  • scmen : usart_type
  • scnacken : usart_type
  • scr : dvp_type, emac_mmc_type, gpio_type
  • scr_bit : dvp_type, gpio_type
  • scr_structure : sd_scr_struct_type
  • sctrl : i2c_type
  • sd_bus_width : sd_scr_struct_type
  • sd_cid_reg : sd_card_info_struct_type
  • sd_csd_reg : sd_card_info_struct_type
  • sd_scr_reg : sd_card_info_struct_type
  • sd_security : sd_scr_struct_type
  • sd_spec : sd_scr_struct_type
  • sd_spec3 : sd_scr_struct_type
  • sdad : i2c_type
  • sdio1en : crm_type
  • sdio1lpen : crm_type
  • sdio1rst : crm_type
  • sdio2en : crm_type
  • sdio2lpen : crm_type
  • sdio2rst : crm_type
  • sdir : i2c_type
  • sdram_bank : xmc_sdram_init_type
  • sec : ertc_alarm_value_type, ertc_time_type
  • secers : flash_type
  • second_dummy_cycle_num : qspi_cmd_type
  • sector_mask : flash_iap_type
  • sector_size : flash_iap_type, iap_info_type
  • sectors : FlashDevice
  • sef : pwc_type
  • sen : edma_stream_type
  • sense_key : sense_type
  • sequence_mode : adc_base_config_type
  • sesenddet : otg_global_type
  • set_slib_strt : flash_type
  • setd0pid : otg_eptin_type, otg_eptout_type
  • setd1pid : otg_eptin_type, otg_eptout_type
  • setup : otg_eptout_type
  • setupmsk : otg_device_type
  • sftdiscon : otg_device_type
  • sgnpinak : otg_device_type
  • sgoutnak : otg_device_type
  • shtml : default_filename
  • sigsel : dmamux_generator_type, edmamux_generator_type
  • sixth_id : nand_id_type
  • slben : spi_type, usart_type
  • slbtd : spi_type
  • sleep_debug : debug_type
  • slib_enf : flash_type
  • slib_es : flash_type
  • slib_es_set : flash_type
  • slib_inst_ss : flash_type
  • slib_iss_set : flash_type
  • slib_misc_sts : flash_type
  • slib_misc_sts_bit : flash_type
  • slib_pclr_val : flash_type
  • slib_pset_val : flash_type
  • slib_pwd_clr : flash_type
  • slib_pwd_clr_bit : flash_type
  • slib_pwd_err : flash_type
  • slib_pwd_ok : flash_type
  • slib_rcnt : flash_type
  • slib_set_pwd : flash_type
  • slib_set_pwd_bit : flash_type
  • slib_set_range0 : flash_type
  • slib_set_range0_bit : flash_type
  • slib_set_range1 : flash_type
  • slib_set_range1_bit : flash_type
  • slib_ss : flash_type
  • slib_ss_set : flash_type
  • slib_sts0 : flash_type
  • slib_sts0_bit : flash_type
  • slib_sts1 : flash_type
  • slib_sts1_bit : flash_type
  • slib_sts2 : flash_type
  • slib_sts2_bit : flash_type
  • slib_ukval : flash_type
  • slib_ulkf : flash_type
  • slib_unlock : flash_type
  • slib_unlock_bit : flash_type
  • sm : dvp_type
  • smbalert : i2c_type
  • smsel : tmr_type
  • snak : otg_eptin_type, otg_eptout_type
  • snpm : otg_eptout_type
  • sof : otg_global_type
  • sof_out : usb_core_cfg
  • soffn : otg_device_type
  • sofmsk : otg_global_type
  • sofouten : otg_global_type
  • spec_version : sd_csd_struct_type
  • speed : usb_core_cfg, usb_hch_type
  • spi1en : crm_type
  • spi1lpen : crm_type
  • spi1rst : crm_type
  • spi2en : crm_type
  • spi2lpen : crm_type
  • spi2rst : crm_type
  • spi3en : crm_type
  • spi3lpen : crm_type
  • spi3rst : crm_type
  • spi4en : crm_type
  • spi4lpen : crm_type
  • spi4rst : crm_type
  • spiadr : qspi_type
  • spien : spi_type
  • spifsize : qspi_type
  • spists : qspi_type
  • spk_alt_setting : usb_audio_hid_type, usb_audio_type
  • spk_buffer : audio_codec_type
  • spk_calc : audio_codec_type
  • spk_enable : audio_codec_type
  • spk_freq : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • spk_mute : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • spk_rend : audio_codec_type
  • spk_roff : audio_codec_type
  • spk_rtotal : audio_codec_type
  • spk_stage : audio_codec_type
  • spk_threshold : audio_codec_type
  • spk_tx_size : audio_codec_type
  • spk_volume : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • spk_volume_limits : usb_audio_hid_type, usb_audio_type
  • spk_woff : audio_codec_type
  • spk_wtotal : audio_codec_type
  • spl : edma_stream_type
  • spltena : otg_hchannel_type
  • sppfts : emac_ptp_type
  • sprst : can_type
  • spt1 : adc_type
  • spt1_bit : adc_type
  • spt2 : adc_type
  • spt2_bit : adc_type
  • sqen : adc_type
  • srcstd : edma_stream_2d_type
  • srl : emac_dma_type
  • ssb : usd_type
  • ssinc : emac_ptp_type
  • ssinc_bit : emac_ptp_type
  • ssiv : emac_ptp_type
  • ssr : emac_dma_type
  • sstc : emac_dma_type
  • stall : otg_eptin_type, otg_eptout_type, otg_hchannel_type, usb_ept_info, usb_hch_type
  • stallmsk : otg_hchannel_type
  • standard_id : can_rx_message_type, can_tx_message_type
  • standby_debug : debug_type
  • start : FlashEraseData
  • state : iap_info_type, usb_hch_type, usbh_hid_type, usbh_msc_type, usbh_msc_unit_type
  • status : emac_dma_desc_type, i2c_handle_type, usb_ept_info, usb_hch_type
  • stctrl : tmr_type
  • stctrl_bit : tmr_type
  • stdby_rst : flash_type
  • stdsel : spi_type
  • step : acc_type
  • stis : tmr_type
  • stl : emac_dma_type
  • stopbn : usart_type
  • stopc : i2c_type
  • stopf : i2c_type
  • stopien : i2c_type
  • stoppclk : otg_pcgcctl_type
  • stretch : i2c_type
  • stride : edma_stream_2d_type
  • stride_bit : edma_stream_2d_type
  • sts : acc_type, adc_type, dac_type, dma_type, dvp_type, emac_dma_type, ertc_type, flash_type, i2c_type, sdio_type, spi_type, tmr_type, usart_type, wdt_type, wwdt_type, xmc_sdram_type
  • sts1 : edma_type
  • sts1_bit : edma_type
  • sts2 : edma_type, flash_type
  • sts2_bit : edma_type, flash_type
  • sts_bit : acc_type, adc_type, dac_type, dma_type, dvp_type, emac_dma_type, ertc_type, flash_type, i2c_type, sdio_type, spi_type, usart_type, wdt_type, wwdt_type, xmc_sdram_type
  • subbank : xmc_norsram_init_type, xmc_norsram_timing_init_type
  • sur : dvp_type
  • sur_bit : dvp_type
  • suspendm : otg_pcgcctl_type
  • suspsts : otg_device_type
  • swap_xmc : scfg_type
  • swcsen : spi_type
  • swcsil : spi_type
  • swef : pwc_type
  • swevt : tmr_type
  • swevt_bit : tmr_type
  • swpen1 : pwc_type
  • swpen2 : pwc_type
  • swr : emac_dma_type
  • swrstf : crm_type
  • swtrg : dac_type, exint_type
  • swtrg_bit : dac_type, exint_type
  • swtx : exint_type
  • sync_enable : dmamux_sync_init_type, edmamux_sync_init_type
  • sync_event_enable : dmamux_sync_init_type, edmamux_sync_init_type
  • sync_polarity : dmamux_sync_init_type, edmamux_sync_init_type
  • sync_request_number : dmamux_sync_init_type, edmamux_sync_init_type
  • sync_signal_sel : dmamux_sync_init_type, edmamux_sync_init_type
  • syncben : xmc_bank1_ctrl_tmg_reg_type
  • syncen : dmamux_channel_type, edmamux_channel_type
  • syncovf : dma_type, edma_type
  • syncovfc : dma_type, edma_type
  • syncovien : dmamux_channel_type, edmamux_channel_type
  • syncpol : dmamux_channel_type, edmamux_channel_type
  • syncsel : dmamux_channel_type, edmamux_channel_type
  • szDev : FlashDevice
  • szPage : FlashDevice
  • szSector : FlashSectors


AT32F435/437 Firmwary Library: Data Fields - Variables

- t -

  • t : sc_atr_type
  • t0 : sc_atr_type
  • taac : sd_csd_struct_type
  • tadj : ertc_reg_tadj_type, ertc_type
  • tadj_bit : ertc_reg_tadj_type, ertc_type
  • tadjf : ertc_type
  • tail : usart_group_type
  • tamp : ertc_type
  • tamp_bit : ertc_type
  • tar : emac_ptp_type, xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • tblsel : dma_type, edma_type
  • tbu : emac_dma_type
  • tcdt : usart_type
  • tcien : can_type
  • tcr : xmc_bank2_type, xmc_bank3_type, xmc_bank4_type
  • tcrc : spi_type
  • tcrc_bit : spi_type
  • tcrld : i2c_type
  • tdbe : i2c_type, spi_type, usart_type
  • tdbeie : spi_type
  • tdbeien : usart_type
  • tdbrc : emac_ptp_type
  • tdc : i2c_type, usart_type
  • tdcien : i2c_type, usart_type
  • tden : tmr_type
  • tdien : i2c_type
  • tdis : i2c_type
  • tdladdr : emac_dma_type
  • tdladdr_bit : emac_dma_type
  • te : emac_ptp_type, emac_type
  • tec : can_type
  • temp : keyboard_type
  • temp_write_protect : sd_csd_struct_type
  • tempervintrv_state : adc_common_config_type
  • ten : usart_type
  • tfcnt : emac_mmc_type
  • tfcnt_bit : emac_mmc_type
  • tfcu : emac_ptp_type
  • tfmscc : emac_mmc_type
  • tfmscc_bit : emac_mmc_type
  • tfrdir : sdio_type
  • tfren : sdio_type
  • tfrmode : sdio_type
  • tfscc : emac_mmc_type
  • tfscc_bit : emac_mmc_type
  • tgf : emac_mmc_type
  • tgfc : emac_mmc_type
  • tgfcim : emac_mmc_type
  • tgfmsc : emac_mmc_type
  • tgfmscc : emac_mmc_type
  • tgfscc : emac_mmc_type
  • third_id : nand_id_type
  • ti : emac_dma_type, emac_mmc_type, emac_ptp_type
  • ti_bit : emac_mmc_type
  • tie : emac_dma_type
  • tien : spi_type, tmr_type
  • tim : emac_mmc_type, emac_type
  • tim_bit : emac_mmc_type
  • time : ertc_reg_time_type, ertc_type
  • time_bit : ertc_reg_time_type, ertc_type
  • timeout : i2c_type, otg_eptin_type, sdio_data_struct_type, sdio_type
  • timeout_bit : i2c_type
  • timeoutmsk : otg_device_type
  • tis : emac_type
  • tite : emac_ptp_type
  • tje : emac_dma_type
  • tjt : emac_dma_type
  • tlength : sc_atr_type
  • tm : xmc_sdram_type
  • tm0alf : can_type
  • tm0ct : can_type
  • tm0ef : can_type
  • tm0lpf : can_type
  • tm0tcf : can_type
  • tm0tef : can_type
  • tm0tsf : can_type
  • tm1alf : can_type
  • tm1ct : can_type
  • tm1ef : can_type
  • tm1lpf : can_type
  • tm1tcf : can_type
  • tm1tef : can_type
  • tm1tsf : can_type
  • tm2alf : can_type
  • tm2ct : can_type
  • tm2ef : can_type
  • tm2lpf : can_type
  • tm2tcf : can_type
  • tm2tef : can_type
  • tm2tsf : can_type
  • tm_bit : xmc_sdram_type
  • tmc : can_tx_mailbox_type
  • tmc_bit : can_tx_mailbox_type
  • tmcgfcim : emac_mmc_type
  • tmdt0 : can_tx_mailbox_type
  • tmdt1 : can_tx_mailbox_type
  • tmdt2 : can_tx_mailbox_type
  • tmdt3 : can_tx_mailbox_type
  • tmdt4 : can_tx_mailbox_type
  • tmdt5 : can_tx_mailbox_type
  • tmdt6 : can_tx_mailbox_type
  • tmdt7 : can_tx_mailbox_type
  • tmdtbl : can_tx_mailbox_type
  • tmdth : can_tx_mailbox_type
  • tmdth_bit : can_tx_mailbox_type
  • tmdtl : can_tx_mailbox_type
  • tmdtl_bit : can_tx_mailbox_type
  • tmeid : can_tx_mailbox_type
  • tmfrsel : can_tx_mailbox_type
  • tmgwr_group : xmc_bank1_type
  • tmi : can_tx_mailbox_type
  • tmi_bit : can_tx_mailbox_type
  • tmidsel : can_tx_mailbox_type
  • tmnr : can_type
  • tmout : i2c_type
  • tmoutc : i2c_type
  • tmr10_pause : debug_type
  • tmr10en : crm_type
  • tmr10lpen : crm_type
  • tmr10rst : crm_type
  • tmr11_pause : debug_type
  • tmr11en : crm_type
  • tmr11lpen : crm_type
  • tmr11rst : crm_type
  • tmr12_pause : debug_type
  • tmr12en : crm_type
  • tmr12lpen : crm_type
  • tmr12rst : crm_type
  • tmr13_pause : debug_type
  • tmr13en : crm_type
  • tmr13lpen : crm_type
  • tmr13rst : crm_type
  • tmr14_pause : debug_type
  • tmr1_pause : debug_type
  • tmr1en : crm_type
  • tmr1lpen : crm_type
  • tmr1rst : crm_type
  • tmr20_pause : debug_type
  • tmr20en : crm_type
  • tmr20lpen : crm_type
  • tmr20rst : crm_type
  • tmr2_ch1_irmp : tmr_type
  • tmr2_pause : debug_type
  • tmr2en : crm_type
  • tmr2lpen : crm_type
  • tmr2rst : crm_type
  • tmr3_pause : debug_type
  • tmr3en : crm_type
  • tmr3lpen : crm_type
  • tmr3rst : crm_type
  • tmr4_pause : debug_type
  • tmr4en : crm_type
  • tmr4lpen : crm_type
  • tmr4rst : crm_type
  • tmr5_ch4_irmp : tmr_type
  • tmr5_pause : debug_type
  • tmr5en : crm_type
  • tmr5lpen : crm_type
  • tmr5rst : crm_type
  • tmr6_pause : debug_type
  • tmr6en : crm_type
  • tmr6lpen : crm_type
  • tmr6rst : crm_type
  • tmr7_pause : debug_type
  • tmr7en : crm_type
  • tmr7lpen : crm_type
  • tmr7rst : crm_type
  • tmr8_pause : debug_type
  • tmr8en : crm_type
  • tmr8lpen : crm_type
  • tmr8rst : crm_type
  • tmr9_pause : debug_type
  • tmr9en : crm_type
  • tmr9lpen : crm_type
  • tmr9rst : crm_type
  • tmrd : xmc_sdram_timing_type, xmc_sdram_type
  • tmren : tmr_type
  • tmsid : can_tx_mailbox_type
  • tmsr : can_tx_mailbox_type
  • tmts : can_tx_mailbox_type
  • tmtsten : can_tx_mailbox_type
  • to_ip : tftp_connection_args
  • to_port : tftp_connection_args
  • toen : i2c_type
  • toErase : FlashDevice
  • toggle_in : usb_hch_type
  • toggle_out : usb_hch_type
  • tomode : i2c_type
  • toProg : FlashDevice
  • tot_bytes : tftp_connection_args
  • total_len : usb_ept_info
  • totime : i2c_type
  • touch_adjust : touch_dev_type
  • touch_read_xy : touch_dev_type
  • touch_scan : touch_dev_type
  • toutcal : otg_global_type
  • tp1edg : ertc_type
  • tp1en : ertc_type
  • tp1f : ertc_type
  • tp1pin : ertc_type
  • tp2edg : ertc_type
  • tp2en : ertc_type
  • tp2f : ertc_type
  • tpd : emac_dma_type
  • tpd_bit : emac_dma_type
  • tpflt : ertc_type
  • tpfreq : ertc_type
  • tpien : ertc_type
  • tppr : ertc_type
  • tppu : ertc_type
  • tps : emac_dma_type
  • tptsen : ertc_type
  • trans_buf : usb_ept_info, usb_hch_type
  • trans_count : usb_hch_type
  • trans_len : usb_ept_info, usb_hch_type
  • trans_type : usb_ept_info
  • transfer_direction : sdio_data_struct_type
  • transfer_mode : sdio_data_struct_type
  • transmission_mode : spi_init_type
  • tras : xmc_sdram_timing_type, xmc_sdram_type
  • trc : xmc_sdram_timing_type, xmc_sdram_type
  • trcd : xmc_sdram_timing_type, xmc_sdram_type
  • trgif : tmr_type
  • trgout2en : tmr_type
  • trgovf : dma_type, edma_type
  • trgovfc : dma_type, edma_type
  • trgovien : dmamux_generator_type, edmamux_generator_type
  • trgswtr : tmr_type
  • trp : xmc_sdram_timing_type, xmc_sdram_type
  • trpswap : usart_type
  • ts : emac_dma_type, emac_ptp_type, sc_atr_type
  • tsad : emac_ptp_type
  • tsad_bit : emac_ptp_type
  • tscgfci : emac_mmc_type
  • tscgfcim : emac_mmc_type
  • tsctrl : emac_ptp_type
  • tsctrl_bit : emac_ptp_type
  • tsdt : ertc_reg_tsdt_type, ertc_type, usart_type
  • tsdt_bit : ertc_reg_tsdt_type, ertc_type
  • tse : emac_dma_type
  • tsedg : ertc_type
  • tsen : ertc_type
  • tsf : emac_dma_type, ertc_type
  • tsf_enable : emac_dma_config_type
  • tsh : emac_ptp_type
  • tsh_bit : emac_ptp_type
  • tshud : emac_ptp_type
  • tshud_bit : emac_ptp_type
  • tsien : ertc_type
  • tsl : emac_ptp_type
  • tsl_bit : emac_ptp_type
  • tslud : emac_ptp_type
  • tslud_bit : emac_ptp_type
  • tso : emac_ptp_type
  • tsof : ertc_type
  • tspin : ertc_type
  • tss : emac_ptp_type
  • tssbs : ertc_type
  • tssbs_bit : ertc_type
  • tssr : emac_ptp_type
  • tssr_bit : emac_ptp_type
  • tstctl : otg_device_type
  • tstm : ertc_reg_tstm_type, ertc_type
  • tstm_bit : ertc_reg_tstm_type, ertc_type
  • tsts : can_type
  • tsts_bit : can_type
  • ttc : emac_dma_type
  • ttc_enable : can_base_type
  • ttcen : can_type
  • tth : emac_ptp_type
  • tth_bit : emac_ptp_type
  • tti : emac_dma_type
  • ttl : emac_ptp_type
  • ttl_bit : emac_ptp_type
  • ttlr : emac_ptp_type
  • ttsr : emac_ptp_type
  • tttr : emac_ptp_type
  • tu : emac_ptp_type
  • tue : emac_dma_type
  • tuerr : spi_type
  • twr : xmc_sdram_timing_type, xmc_sdram_type
  • tx_addr : usb_ept_info
  • tx_dma_pal : emac_dma_config_type
  • tx_length : iap_info_type
  • tx_mailbox : can_type
  • tx_threshold : emac_dma_config_type
  • txbuf : sdio_type
  • txbufe : sdio_type
  • txbufeien : sdio_type
  • txbuff : sdio_type
  • txbuffien : sdio_type
  • txbufh : sdio_type
  • txbufhien : sdio_type
  • txbufien : sdio_type
  • txdt : i2c_type
  • txdt_bit : i2c_type
  • txerru : sdio_type
  • txerruien : sdio_type
  • txfemp : otg_eptin_type
  • txfflsh : otg_global_type
  • txfifo_thod : qspi_type
  • txfifordy : qspi_type
  • txfifoudrmsk : otg_device_type
  • txfnum : otg_eptin_type, otg_global_type
  • txsr : xmc_sdram_timing_type, xmc_sdram_type


AT32F435/437 Firmwary Library: Data Fields - Variables

- u -

  • uart4en : crm_type
  • uart4lpen : crm_type
  • uart4rst : crm_type
  • uart5en : crm_type
  • uart5lpen : crm_type
  • uart5rst : crm_type
  • uart7en : crm_type
  • uart7lpen : crm_type
  • uart7rst : crm_type
  • uart8en : crm_type
  • uart8lpen : crm_type
  • uart8rst : crm_type
  • uen : usart_type
  • uhdrv : scfg_type
  • uhdrv_bit : scfg_type
  • uint32_t : dvp_type
  • ukval : flash_type
  • une : emac_dma_type
  • unf : emac_dma_type
  • unlock : flash_type
  • unlock2 : flash_type
  • unlock2_bit : flash_type
  • unlock_bit : flash_type
  • updf : ertc_type
  • urb_sts : usb_hch_type
  • usart1en : crm_type
  • usart1lpen : crm_type
  • usart1rst : crm_type
  • usart2en : crm_type
  • usart2lpen : crm_type
  • usart2rst : crm_type
  • usart3en : crm_type
  • usart3lpen : crm_type
  • usart3rst : crm_type
  • usart6en : crm_type
  • usart6lpen : crm_type
  • usart6rst : crm_type
  • usb_id : usb_core_cfg
  • usb_reg : otg_core_type
  • usbacept : otg_eptin_type, otg_eptout_type
  • usbdiv : crm_type
  • usbrst : otg_global_type
  • usbrstmsk : otg_global_type
  • usbsusp : otg_global_type
  • usbsuspmsk : otg_global_type
  • usbtrdtim : otg_global_type
  • usd : flash_type
  • usd_bit : flash_type
  • usd_ukval : flash_type
  • usd_unlock : flash_type
  • usd_unlock_bit : flash_type
  • usderr : flash_type
  • usders : flash_type
  • usdprgm : flash_type
  • usdulks : flash_type
  • use_lun : usbh_msc_type
  • user_d0 : flash_type
  • user_d1 : flash_type
  • userid : otg_global_type
  • usp : emac_dma_type
  • usp_enable : emac_dma_config_type


AT32F435/437 Firmwary Library: Data Fields - Variables

- v -

  • val : ertc_type
  • valEmpty : FlashDevice
  • vbat_state : adc_common_config_type
  • vbaten : adccom_type
  • vbusig : otg_global_type, usb_core_cfg
  • vendor : msc_scsi_data_inquiry
  • Vers : FlashDevice
  • version : msc_scsi_data_inquiry
  • vlt : emac_type
  • vlt_bit : emac_type
  • vmcsel : adc_type
  • vmhb : adc_type
  • vmhb_bit : adc_type
  • vmlb : adc_type
  • vmlb_bit : adc_type
  • vmor : adc_type
  • vmor1 : adccom_type
  • vmor2 : adccom_type
  • vmor3 : adccom_type
  • vmorien : adc_type
  • vmsgen : adc_type
  • vrsel : pwc_type
  • vscf : dvp_type
  • vscf_bit : dvp_type
  • vseid : dvp_type
  • vses : dvp_type
  • vsic : dvp_type
  • vsie : dvp_type
  • vsis : dvp_type
  • vsp : dvp_type
  • vsrss : dvp_type
  • vsrts : dvp_type
  • vsyn : dvp_type
  • vti : emac_type


AT32F435/437 Firmwary Library: Data Fields - Variables

- w -

  • wait_enable : xmc_nand_init_type
  • wait_signal_config : xmc_norsram_init_type
  • wait_signal_enable : xmc_norsram_init_type
  • wait_signal_lv : xmc_norsram_init_type
  • wait_type : sdio_command_struct_type
  • wat : ertc_type
  • wat_bit : ertc_type
  • watchdog_disable : emac_control_config_type
  • watclk : ertc_type
  • waten : ertc_type
  • watf : ertc_type
  • watien : ertc_type
  • watwf : ertc_type
  • wd : emac_type
  • wdt_ato_en : flash_type
  • wdt_depslp : flash_type
  • wdt_pause : debug_type
  • wdt_stdby : flash_type
  • wdtrstf : crm_type
  • week : ertc_alarm_value_type, ertc_time_type
  • week_date_sel : ertc_alarm_value_type
  • wen : qspi_type, xmc_bank1_ctrl_tmg_reg_type
  • width : xmc_sdram_init_type
  • win : wdt_type, wwdt_type
  • win_bit : wdt_type
  • wIndex : usb_setup_type
  • wItemLength : usb_hid_desc_type
  • wk : ertc_reg_date_type, ertc_reg_tsdt_type, ertc_type
  • wksel : ertc_reg_alarm_type, ertc_type
  • wkupint : otg_global_type
  • wkupintmsk : otg_global_type
  • wLength : usb_setup_type
  • wMaxPacketSize : usb_endpoint_desc_type
  • wp : ertc_type
  • wp_bit : ertc_type
  • wp_level : tmr_brkdt_config_type
  • wpc : tmr_type
  • wpen0 : gpio_type
  • wpen1 : gpio_type
  • wpen10 : gpio_type
  • wpen11 : gpio_type
  • wpen12 : gpio_type
  • wpen13 : gpio_type
  • wpen14 : gpio_type
  • wpen15 : gpio_type
  • wpen2 : gpio_type
  • wpen3 : gpio_type
  • wpen4 : gpio_type
  • wpen5 : gpio_type
  • wpen6 : gpio_type
  • wpen7 : gpio_type
  • wpen8 : gpio_type
  • wpen9 : gpio_type
  • wpr : gpio_type
  • wpr_bit : gpio_type
  • wpseq : gpio_type
  • wrapen : xmc_bank1_ctrl_tmg_reg_type
  • wrapped_mode_enable : xmc_norsram_init_type
  • write_addr : flash_iap_type
  • write_address_length : qspi_xip_type
  • write_blk_misalign : sd_csd_struct_type
  • write_burst_syn : xmc_norsram_init_type
  • write_crc : flash_iap_type
  • write_data : fat_dir_type
  • write_data_counter : qspi_xip_type
  • write_data_enable : qspi_cmd_type
  • write_enable : xmc_norsram_init_type
  • write_instruction_code : qspi_xip_type
  • write_operation_mode : qspi_xip_type
  • write_protect_group_enable : sd_csd_struct_type
  • write_protect_group_size : sd_csd_struct_type
  • write_protection : xmc_sdram_init_type
  • write_second_dummy_cycle_num : qspi_xip_type
  • write_select_mode : qspi_xip_type
  • write_speed_factor : sd_csd_struct_type
  • write_time : fat_dir_type
  • write_time_counter : qspi_xip_type
  • write_timing_enable : xmc_norsram_init_type, xmc_norsram_timing_init_type
  • wrp : xmc_sdram_type
  • wTotalLength : usb_configuration_desc_type
  • wum : usart_type
  • wValue : usb_setup_type
  • wwdt_pause : debug_type
  • wwdten : crm_type, wwdt_type
  • wwdtlpen : crm_type
  • wwdtrst : crm_type
  • wwdtrstf : crm_type


AT32F435/437 Firmwary Library: Data Fields - Variables

- x -

  • x : usb_hid_mouse_type
  • x_p : touch_dev_type
  • xacterr : otg_hchannel_type
  • xacterrmsk : otg_hchannel_type
  • xactpos : otg_hchannel_type
  • xcnt : edma_stream_2d_type
  • xferc : otg_eptin_type, otg_eptout_type, otg_hchannel_type
  • xfercmsk : otg_device_type, otg_hchannel_type
  • xfersize : otg_eptin_type, otg_eptout_type, otg_hchannel_type
  • xip_cmd_w0 : qspi_type
  • xip_cmd_w0_bit : qspi_type
  • xip_cmd_w1 : qspi_type
  • xip_cmd_w1_bit : qspi_type
  • xip_cmd_w2 : qspi_type
  • xip_cmd_w2_bit : qspi_type
  • xip_cmd_w3 : qspi_type
  • xip_cmd_w3_bit : qspi_type
  • xipidle : qspi_type
  • xipr_adrlen : qspi_type
  • xipr_dcnt : qspi_type
  • xipr_dum2 : qspi_type
  • xipr_insc : qspi_type
  • xipr_opmode : qspi_type
  • xipr_sel : qspi_type
  • xipr_tcnt : qspi_type
  • xiprcmdf : qspi_type
  • xipsel : qspi_type
  • xipw_dcnt : qspi_type
  • xipw_sel : qspi_type
  • xipw_tcnt : qspi_type
  • xmc_init : lcd_dev_type
  • xmcen : crm_type
  • xmclpen : crm_type
  • xmcrst : crm_type


AT32F435/437 Firmwary Library: Data Fields - Variables

- y -

  • y : ertc_reg_date_type, ertc_type, usb_hid_mouse_type
  • y_p : touch_dev_type
  • ycnt : edma_stream_2d_type
  • year : ertc_time_type


AT32F435/437 Firmwary Library: Data Fields - Variables

- z -

  • z : usb_hid_mouse_type
  • zone : nand_address_type


AT32F435/437 Firmwary Library: File List

File List
Here is a list of all files with brief descriptions:
at32f435_437.h | At32f435_437 header file
system_at32f435_437.c | All the functions for cmsis cortex-m4 system source file
system_at32f435_437.h | Cmsis cortex-m4 system header file
at32f435_437_acc.h | At32f435_437 acc header file
at32f435_437_adc.h | At32f435_437 adc header file
at32f435_437_can.h | At32f435_437 can header file
at32f435_437_crc.h | At32f435_437 crc header file
at32f435_437_crm.h | At32f435_437 crm header file
at32f435_437_dac.h | At32f435_437 dac header file
at32f435_437_debug.h |
at32f435_437_def.h | At32f435_437 macros header file
at32f435_437_dma.h | At32f435_437 dma header file
at32f435_437_dvp.h | At32f435_437 dvp header file
at32f435_437_edma.h | At32f435_437 edma header file
at32f435_437_emac.h | At32f435_437 eth header file
at32f435_437_ertc.h | At32f435_437 ertc header file
at32f435_437_exint.h | At32f435_437 exint header file
at32f435_437_flash.h | At32f435_437 flash header file
at32f435_437_gpio.h | At32f435_437 gpio header file
at32f435_437_i2c.h | At32f435_437 i2c header file
at32f435_437_misc.h | At32f435_437 misc header file
at32f435_437_pwc.h | At32f435_437 pwr header file
at32f435_437_qspi.h | At32f435_437 qspi header file
at32f435_437_scfg.h | At32f435_437 system config header file
at32f435_437_sdio.h | At32f435_437 sdio header file
at32f435_437_spi.h | At32f435_437 spi header file
at32f435_437_tmr.h | At32f435_437 tmr header file
at32f435_437_usart.h | At32f435_437 usart header file
at32f435_437_usb.h | At32f435_437 usb header file
at32f435_437_wdt.h | At32f435_437 wdt header file
at32f435_437_wwdt.h | At32f435_437 wwdt header file
at32f435_437_xmc.h | At32f435_437 xmc header file
at32f435_437_acc.c | All the functions for the acc firmware library
at32f435_437_adc.c | All the functions for the adc firmware library
at32f435_437_can.c | All the functions for the can firmware library
at32f435_437_crc.c | All the functions for the crc firmware library
at32f435_437_crm.c | All the functions for the crm firmware library
at32f435_437_dac.c | All the functions for the dac firmware library
at32f435_437_debug.c |
at32f435_437_dma.c | All the functions for the dma firmware library
at32f435_437_dvp.c | All the functions for the dvp firmware library
at32f435_437_edma.c | All the functions for the edma firmware library
at32f435_437_emac.c | All the functions for the emac firmware library
at32f435_437_ertc.c | All the functions for the ertc firmware library
at32f435_437_exint.c | All the functions for the exint firmware library
at32f435_437_flash.c | All the functions for the flash firmware library
at32f435_437_gpio.c | All the functions for the gpio firmware library
at32f435_437_i2c.c | All the functions for the i2c firmware library
at32f435_437_misc.c | All the functions for the misc firmware library
at32f435_437_pwc.c | All the functions for the pwc firmware library
at32f435_437_qspi.c | Contain all the functions for qspi firmware library
at32f435_437_scfg.c | All the functions for the system config firmware library
at32f435_437_sdio.c | All the functions for the sdio firmware library
at32f435_437_spi.c | All the functions for the spi firmware library
at32f435_437_tmr.c | All the functions for the tmr firmware library
at32f435_437_usart.c | All the functions for the usart firmware library
at32f435_437_usb.c | All the functions for the usb firmware library
at32f435_437_wdt.c | All the functions for the wdt firmware library
at32f435_437_wwdt.c | All the functions for the wwdt firmware library
at32f435_437_xmc.c | All the functions for the xmc firmware library
main_page.h |
i2c_application.c | Driver library of the i2c peripheral
i2c_application.h | I2c application libray header file
usb_core.h | Usb core header file
usb_std.h | Usb standard header file
usbd_core.h | Usb device core header file
usbd_int.h | Usb interrupt header file
usbd_sdr.h |
usbh_core.h | Usb host core header file
usbh_ctrl.h | Usb header file
usbh_int.h | Usb header file
usb_core.c | Usb driver
usbd_core.c | Usb device driver
usbd_int.c | Usb interrupt request
usbd_sdr.c | Usb standard device request
usbh_core.c | Usb host driver
usbh_ctrl.c | Usb host control request
usbh_int.c | Usb host interrupt request
audio_class.c | Usb audio class type
audio_class.h | Usb audio class file
audio/audio_conf.h | Usb audio config
audio_hid/audio_conf.h | Usb audio config
audio_desc.c | Usb audio device descriptor
audio_desc.h | Usb audio descriptor header file
audio_hid_class.c |
audio_hid_class.h |
audio_hid_desc.c |
audio_hid_desc.h |
cdc_class.c | Usb cdc class type
cdc_class.h | Usb cdc class file
cdc_desc.c | Usb cdc device descriptor
cdc_desc.h | Usb cdc descriptor header file
cdc_keyboard_class.c | Usb cdc and keyboard class type
cdc_keyboard_class.h | Usb cdc and keyboard class file
cdc_keyboard_desc.c | Usb cdc and keyboard device descriptor
cdc_keyboard_desc.h | Usb cdc and keyboard descriptor header file
cdc_msc_class.c | Usb cdc class type
cdc_msc_class.h | Usb cdc class file
cdc_msc_desc.c | Usb cdc device descriptor
cdc_msc_desc.h | Usb cdc descriptor header file
composite_cdc_msc/msc_bot_scsi.c | Usb mass storage bulk-only transport and scsi command
msc/msc_bot_scsi.c | Usb mass storage bulk-only transport and scsi command
custom_hid_class.c | Usb custom hid class type
custom_hid_class.h | Usb hid header file
custom_hid_desc.c | Usb hid device descriptor
custom_hid_desc.h | Usb custom hid descriptor header file
hid_iap_class.c | Usb hid iap class type
hid_iap_class.h | Usb hid iap header file
hid_iap_desc.c | Usb hid iap device descriptor
hid_iap_desc.h | Usb hid iap descriptor header file
keyboard_class.c | Usb hid keyboard class type
keyboard_class.h | Usb hid keyboard header file
keyboard_desc.c | Usb hid keyboard device descriptor
keyboard_desc.h | Usb keyboard descriptor header file
mouse_class.c | Usb hid mouse class type
mouse_class.h | Usb hid mouse header file
mouse_desc.c | Usb hid mouse device descriptor
mouse_desc.h | Usb mouse descriptor header file
msc_bot_scsi.h | Usb mass storage bulk-only transport and scsi command header file
msc_class.c | Usb msc class type
msc_class.h | Usb msc class file
msc_desc.c | Usb msc device descriptor
msc_desc.h | Usb msc descriptor header file
printer_class.c | Usb printer class type
printer_class.h | Usb cdc class file
printer_desc.c | Usb printer device descriptor
printer_desc.h | Usb printer descriptor header file
usbh_hid_class.c | Usb host hid class type
usbh_hid_class.h | Usb host hid class header file
usbh_hid_keyboard.c | Usb host hid keyboard type
usbh_hid_keyboard.h | Usb host hid keyboard header file
usbh_hid_mouse.c | Usb host hid mouse type
usbh_hid_mouse.h | Usb host hid mouse header file
usbh_msc_bot_scsi.c | Usb host msc bulk-only transfer and scsi type
usbh_msc_bot_scsi.h | Usb host msc bulk-only transfer and scsi header file
usbh_msc_class.c | Usb host msc class type
usbh_msc_class.h | Usb host msc class header file
at32f435_437_board.c | Set of firmware functions to manage leds and push-button. initialize delay function
at32f435_437_board.h |
project/at_start_f435/examples/acc/calibration/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/can/filter/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/crc/calculation/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/dma/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usart/irda/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usart/polling/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usart/printf/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usart/rs485/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/xmc/psram/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/xmc/sram/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/templates/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/acc/calibration/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/can/filter/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/crc/calculation/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/emac/http_server/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/emac/iperf/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/emac/telnet/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/dma/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usart/irda/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usart/polling/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usart/printf/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usart/rs485/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/xmc/psram/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/examples/xmc/sram/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f437/templates/inc/at32f435_437_clock.h | Header file of clock program
utilities/at32f435_437_freertos_demo/inc/at32f435_437_clock.h | Header file of clock program
utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_clock.h | Header file of clock program
utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_clock.h | Header file of clock program
utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_clock.h | Header file of clock program
utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_clock.h | Header file of clock program
utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_clock.h | Header file of clock program
utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_clock.h | Header file of clock program
utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_clock.h | Header file of clock program
utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_clock.h | Header file of clock program
utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_clock.h | Header file of clock program
utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_clock.h | Header file of clock program
utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_clock.h | Header file of clock program
project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/templates/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f437/templates/inc/at32f435_437_conf.h | At32f435_437 config header file
utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h | At32f435_437 config header file
utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h | At32f435_437 config header file
utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h | At32f435_437 config header file
utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h | At32f435_437 config header file
utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h | At32f435_437 config header file
utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h | At32f435_437 config header file
utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h | At32f435_437 config header file
utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h | At32f435_437 config header file
utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h | At32f435_437 config header file
utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h | At32f435_437 config header file
utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h | At32f435_437 config header file
utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h | At32f435_437 config header file
utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h | At32f435_437 config header file
utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h | At32f435_437 config header file
project/at_start_f435/examples/acc/calibration/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/can/filter/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/crc/calculation/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/dma/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usart/irda/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usart/polling/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usart/printf/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usart/rs485/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/xmc/psram/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/xmc/sram/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/templates/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/acc/calibration/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/can/filter/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/crc/calculation/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/emac/http_server/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/emac/iperf/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/emac/telnet/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/dma/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usart/irda/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usart/polling/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usart/printf/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usart/rs485/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/xmc/psram/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/examples/xmc/sram/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f437/templates/inc/at32f435_437_int.h | Header file of main interrupt service routines
utilities/at32f435_437_freertos_demo/inc/at32f435_437_int.h | Header file of main interrupt service routines
utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_int.h | Header file of main interrupt service routines
utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_int.h | Header file of main interrupt service routines
utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_int.h | Header file of main interrupt service routines
utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h | Header file of main interrupt service routines
utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h | Header file of main interrupt service routines
utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_int.h | Header file of main interrupt service routines
utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h | Header file of main interrupt service routines
utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h | Header file of main interrupt service routines
utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_int.h | Header file of main interrupt service routines
utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h | Header file of main interrupt service routines
utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_int.h | Header file of main interrupt service routines
project/at_start_f435/examples/acc/calibration/inc/usb_conf.h | Usb config header file
project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h | Usb config header file
project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h | Usb config header file
project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h | Usb config header file
project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h | Usb config header file
project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h | Usb config header file
project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h | Usb config header file
project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h | Usb config header file
project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h | Usb config header file
project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h | Usb config header file
project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h | Usb config header file
project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h | Usb config header file
project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h | Usb config header file
project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h | Usb config header file
project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h | Usb config header file
project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h | Usb config header file
project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h | Usb config header file
project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h | Usb config header file
project/at_start_f437/examples/acc/calibration/inc/usb_conf.h | Usb config header file
project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h | Usb config header file
project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h | Usb config header file
project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h | Usb config header file
project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h | Usb config header file
project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h | Usb config header file
project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h | Usb config header file
project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h | Usb config header file
project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h | Usb config header file
project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h | Usb config header file
project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h | Usb config header file
project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h | Usb config header file
project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h | Usb config header file
project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h | Usb config header file
project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h | Usb config header file
project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h | Usb config header file
project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h | Usb config header file
project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h | Usb config header file
utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h | Usb config header file
utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h | Usb config header file
utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h | Usb config header file
project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/can/communication_mode/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/can/filter/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/crc/calculation/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/debug/tmr1/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/ertc/calendar/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/ertc/tamper/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/exint/exint_config/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/dma/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usart/interrupt/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usart/irda/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usart/polling/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usart/printf/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usart/rs485/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usart/smartcard/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usart/synchronous/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usb_device/audio/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usb_device/msc/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usb_device/printer/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/xmc/psram/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/xmc/sram/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/templates/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/acc/calibration/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/adc/conversion_abort/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/adc/current_vref_value_check/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/adc/edma_double_buffer/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/adc/exint_trigger_partitioned/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/adc/internal_temperature_sensor/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/adc/resolution_6bit/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/adc/software_trigger_repeat/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/adc/use_polling_get_conversion_data/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/adc/vbat_monitor/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/adc/voltage_monitoring/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/can/communication_mode/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/can/filter/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/can/loopback_mode/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/cortex_m4/bit_band/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/cortex_m4/fpu/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/cortex_m4/systick_interrupt/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/crc/calculation/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/crm/clock_failure_detection/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/crm/pll_parameter_calculate/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/crm/sysclk_switch/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/dac/double_mode_dma_squarewave/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/dac/one_dac_dma_escalator/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/dac/one_dac_noisewave/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/dac/two_dac_trianglewave/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/debug/tmr1/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/dma/dmamux_data_to_gpio/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/dma/dmamux_genertor_exint/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/dma/flash_to_sram/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/dvp/ov2640_capture/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/dvp/ov5640_capture/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/edma/burst_mode/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/edma/dmamux_genertor_exint/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/edma/flash_to_sram/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/edma/link_list_mode/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/edma/two_dimension_mode/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/emac/dns_client/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/emac/http_server/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/emac/iperf/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/emac/telnet/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/ertc/bpr_domain/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/ertc/calendar/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/ertc/lick_calibration/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/ertc/tamper/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/ertc/time_stamp/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/ertc/wakeup_timer/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/exint/exint_config/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/exint/exint_software_trigger/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/flash/fap_enable/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/flash/flash_write_read/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/gpio/io_toggle/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/gpio/led_toggle/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/gpio/swjtag_mux/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/i2c/communication_dma/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/i2c/communication_int/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/i2c/communication_poll/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/i2c/communication_smbus/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/i2c/eeprom/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/i2s/fullduplex_dma/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/i2s/halfduplex_dma/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/i2s/halfduplex_interrupt/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/irtmr/irtmr_output/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/pwc/ldo_set/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/pwc/power_voltage_monitor/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/pwc/sleep_tmr2/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/pwc/sleep_usart1/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/pwc/standby_ertc_alarm/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/pwc/standby_wakeup_pin/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/qspi/command_port_using_dma/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/qspi/command_port_using_interrupt/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/qspi/command_port_using_polling/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/qspi/xip_port_write_read/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/scfg/mem_map_sel/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/sdio/sd_mmc_card/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/sdio/sdio_fatfs/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/spi/crc_transfer_polling/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/spi/fullduplex_polling/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/spi/halfduplex_interrupt/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/spi/only_receive_mode_polling/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/spi/ti_fullduplex_dma/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/spi/w25q_flash/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/sram/extend_sram/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/6_steps/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/7_pwm_output/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/cascade_synchro/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/complementary_signals/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/dma/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/dma_burst/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/encoder_tmr2/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/external_clock/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/hall_xor_tmr2/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/hang_mode/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/input_capture/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/oc_high/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/oc_low/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/one_cycle/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/parallel_synchro/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/pwm_input/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/pwm_input_dma/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/pwm_output_simulate/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/pwm_output_tmr10/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/pwm_output_tmr3/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/timer_base/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/tmr1_synchro/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/tmr/tmr2_32bit/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usart/half_duplex/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usart/hw_flow_control/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usart/idle_detection/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usart/interrupt/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usart/irda/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usart/polling/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usart/printf/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usart/receiver_mute/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usart/rs485/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usart/smartcard/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usart/synchronous/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usart/transfer_by_dma_polling/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usart/tx_rx_swap/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usb_device/audio/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usb_device/composite_audio_hid/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usb_device/composite_vcp_msc/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usb_device/custom_hid/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usb_device/keyboard/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usb_device/mouse/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usb_device/msc/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usb_device/printer/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usb_device/two_otg_device_demo/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usb_device/vcp_loopback/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usb_device/virtual_comport/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usb_device/virtual_msc_iap/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usb_host/hid_demo/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usb_host/msc_only_fat32/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/usb_host/two_otg_host_demo/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/wdt/wdt_reset/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/wdt/wdt_standby/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/wwdt/wwdt_reset/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/xmc/lcd_8bit/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/xmc/lcd_touch_16bit/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/xmc/nand_flash/ecc/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/xmc/nand_flash/nand/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/xmc/nor_flash/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/xmc/psram/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/xmc/sdram_basic/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/xmc/sdram_dma/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/examples/xmc/sram/src/at32f435_437_clock.c | System clock config program
project/at_start_f437/templates/src/at32f435_437_clock.c | System clock config program
utilities/at32f435_437_freertos_demo/src/at32f435_437_clock.c | System clock config program
utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_clock.c | System clock config program
utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_clock.c | System clock config program
utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_clock.c | System clock config program
utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_clock.c | System clock config program
utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/at32f435_437_clock.c | System clock config program
utilities/at32f435_437_usart_iap_demo/source_code/bootloader/src/at32f435_437_clock.c | System clock config program
utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_clock.c | System clock config program
utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_clock.c | System clock config program
utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_clock.c | System clock config program
utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_clock.c | System clock config program
utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_clock.c | System clock config program
project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/can/filter/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/templates/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/acc/calibration/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/adc/conversion_abort/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/adc/current_vref_value_check/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/adc/edma_double_buffer/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/adc/resolution_6bit/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/adc/software_trigger_repeat/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/adc/vbat_monitor/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/adc/voltage_monitoring/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/can/communication_mode/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/can/filter/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/can/loopback_mode/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/cortex_m4/bit_band/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/cortex_m4/fpu/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/crc/calculation/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/crm/clock_failure_detection/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/crm/sysclk_switch/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/dac/one_dac_noisewave/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/debug/tmr1/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/dma/flash_to_sram/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/dvp/ov2640_capture/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/dvp/ov5640_capture/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/edma/burst_mode/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/edma/flash_to_sram/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/edma/link_list_mode/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/edma/two_dimension_mode/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/ertc/bpr_domain/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/ertc/calendar/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/ertc/lick_calibration/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/ertc/tamper/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/ertc/time_stamp/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/ertc/wakeup_timer/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/exint/exint_config/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/exint/exint_software_trigger/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/flash/fap_enable/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/flash/flash_write_read/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/gpio/io_toggle/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/gpio/led_toggle/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/gpio/swjtag_mux/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/i2c/communication_dma/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/i2c/communication_int/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/i2c/communication_poll/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/i2c/communication_smbus/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/i2c/eeprom/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/i2s/fullduplex_dma/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/i2s/halfduplex_dma/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/irtmr/irtmr_output/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/pwc/ldo_set/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/pwc/sleep_tmr2/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/pwc/sleep_usart1/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/qspi/command_port_using_dma/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/qspi/command_port_using_polling/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/qspi/xip_port_write_read/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/scfg/mem_map_sel/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/sdio/sd_mmc_card/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/sdio/sdio_fatfs/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/spi/crc_transfer_polling/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/spi/fullduplex_polling/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/spi/w25q_flash/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/sram/extend_sram/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/6_steps/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/7_pwm_output/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/cascade_synchro/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/complementary_signals/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/dma/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/dma_burst/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/encoder_tmr2/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/external_clock/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/hang_mode/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/input_capture/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/oc_high/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/oc_low/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/one_cycle/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/parallel_synchro/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/pwm_input/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/pwm_input_dma/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/timer_base/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/tmr1_synchro/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/tmr/tmr2_32bit/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usart/half_duplex/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usart/hw_flow_control/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usart/idle_detection/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usart/interrupt/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usart/irda/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usart/polling/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usart/printf/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usart/receiver_mute/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usart/rs485/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usart/smartcard/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usart/synchronous/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usart/tx_rx_swap/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usb_device/audio/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usb_device/custom_hid/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usb_device/keyboard/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usb_device/mouse/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usb_device/msc/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usb_device/printer/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usb_device/vcp_loopback/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usb_device/virtual_comport/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usb_host/hid_demo/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/wdt/wdt_reset/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/wdt/wdt_standby/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/wwdt/wwdt_reset/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/xmc/lcd_8bit/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/xmc/nand_flash/nand/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/xmc/nor_flash/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/xmc/psram/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/xmc/sdram_basic/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/xmc/sdram_dma/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/examples/xmc/sram/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f437/templates/src/at32f435_437_int.c | Main interrupt service routines
utilities/at32f435_437_freertos_demo/src/at32f435_437_int.c | Main interrupt service routines
utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c | Main interrupt service routines
utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c | Main interrupt service routines
utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c | Main interrupt service routines
utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c | Main interrupt service routines
utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c | Main interrupt service routines
utilities/at32f435_437_usart_iap_demo/source_code/bootloader/src/at32f435_437_int.c | Main interrupt service routines
utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c | Main interrupt service routines
utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c | Main interrupt service routines
utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c | Main interrupt service routines
utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c | Main interrupt service routines
utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_int.c | Main interrupt service routines
project/at_start_f435/examples/acc/calibration/src/main.c | Main program
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c | Main program
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c | Main program
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c | Main program
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c | Main program
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c | Main program
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c | Main program
project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c | Main program
project/at_start_f435/examples/adc/conversion_abort/src/main.c | Main program
project/at_start_f435/examples/adc/current_vref_value_check/src/main.c | Main program
project/at_start_f435/examples/adc/edma_double_buffer/src/main.c | Main program
project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c | Main program
project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c | Main program
project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c | Main program
project/at_start_f435/examples/adc/resolution_6bit/src/main.c | Main program
project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c | Main program
project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c | Main program
project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c | Main program
project/at_start_f435/examples/adc/vbat_monitor/src/main.c | Main program
project/at_start_f435/examples/adc/voltage_monitoring/src/main.c | Main program
project/at_start_f435/examples/can/communication_mode/src/main.c | Main program
project/at_start_f435/examples/can/filter/src/main.c | Main program
project/at_start_f435/examples/can/loopback_mode/src/main.c | Main program
project/at_start_f435/examples/cortex_m4/bit_band/src/main.c | Main program
project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c | Main program
project/at_start_f435/examples/cortex_m4/fpu/src/main.c | Main program
project/at_start_f435/examples/cortex_m4/systick_interrupt/src/main.c | Main program
project/at_start_f435/examples/crc/calculation/src/main.c | Main program
project/at_start_f435/examples/crm/clock_failure_detection/src/main.c | Main program
project/at_start_f435/examples/crm/pll_parameter_calculate/src/main.c | Main program
project/at_start_f435/examples/crm/sysclk_switch/src/main.c | Main program
project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c | Main program
project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/main.c | Main program
project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c | Main program
project/at_start_f435/examples/dac/one_dac_noisewave/src/main.c | Main program
project/at_start_f435/examples/dac/two_dac_trianglewave/src/main.c | Main program
project/at_start_f435/examples/debug/tmr1/src/main.c | Main program
project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c | Main program
project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c | Main program
project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c | Main program
project/at_start_f435/examples/dma/flash_to_sram/src/main.c | Main program
project/at_start_f435/examples/dvp/ov2640_capture/src/main.c | Main program
project/at_start_f435/examples/dvp/ov5640_capture/src/main.c | Main program
project/at_start_f435/examples/edma/burst_mode/src/main.c | Main program
project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c | Main program
project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c | Main program
project/at_start_f435/examples/edma/flash_to_sram/src/main.c | Main program
project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c | Main program
project/at_start_f435/examples/edma/link_list_mode/src/main.c | Main program
project/at_start_f435/examples/edma/two_dimension_mode/src/main.c | Main program
project/at_start_f435/examples/ertc/bpr_domain/src/main.c | Main program
project/at_start_f435/examples/ertc/calendar/src/main.c | Main program
project/at_start_f435/examples/ertc/lick_calibration/src/main.c | Main program
project/at_start_f435/examples/ertc/tamper/src/main.c | Main program
project/at_start_f435/examples/ertc/time_stamp/src/main.c | Main program
project/at_start_f435/examples/ertc/wakeup_timer/src/main.c | Main program
project/at_start_f435/examples/exint/exint_config/src/main.c | Main program
project/at_start_f435/examples/exint/exint_software_trigger/src/main.c | Main program
project/at_start_f435/examples/flash/fap_enable/src/main.c | Main program
project/at_start_f435/examples/flash/flash_write_read/src/main.c | Main program
project/at_start_f435/examples/gpio/io_toggle/src/main.c | Main program
project/at_start_f435/examples/gpio/led_toggle/src/main.c | Main program
project/at_start_f435/examples/gpio/swjtag_mux/src/main.c | Main program
project/at_start_f435/examples/i2c/communication_dma/src/main.c | Main program
project/at_start_f435/examples/i2c/communication_int/src/main.c | Main program
project/at_start_f435/examples/i2c/communication_poll/src/main.c | Main program
project/at_start_f435/examples/i2c/communication_smbus/src/main.c | Main program
project/at_start_f435/examples/i2c/eeprom/src/main.c | Main program
project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c | Main program
project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c | Main program
project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c | Main program
project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c | Main program
project/at_start_f435/examples/irtmr/irtmr_output/src/main.c | Main program
project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c | Main program
project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/main.c | Main program
project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/main.c | Main program
project/at_start_f435/examples/pwc/ldo_set/src/main.c | Main program
project/at_start_f435/examples/pwc/power_voltage_monitor/src/main.c | Main program
project/at_start_f435/examples/pwc/sleep_tmr2/src/main.c | Main program
project/at_start_f435/examples/pwc/sleep_usart1/src/main.c | Main program
project/at_start_f435/examples/pwc/standby_ertc_alarm/src/main.c | Main program
project/at_start_f435/examples/pwc/standby_wakeup_pin/src/main.c | Main program
project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c | Main program
project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c | Main program
project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c | Main program
project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c | Main program
project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c | Main program
project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c | Main program
project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c | Main program
project/at_start_f435/examples/scfg/mem_map_sel/src/main.c | Main program
project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c | Main program
project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c | Main program
project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c | Main program
project/at_start_f435/examples/spi/fullduplex_polling/src/main.c | Main program
project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c | Main program
project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c | Main program
project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c | Main program
project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c | Main program
project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c | Main program
project/at_start_f435/examples/spi/w25q_flash/src/main.c | Main program
project/at_start_f435/examples/sram/extend_sram/src/main.c | Main program
project/at_start_f435/examples/tmr/6_steps/src/main.c | Main program
project/at_start_f435/examples/tmr/7_pwm_output/src/main.c | Main program
project/at_start_f435/examples/tmr/cascade_synchro/src/main.c | Main program
project/at_start_f435/examples/tmr/complementary_signals/src/main.c | Main program
project/at_start_f435/examples/tmr/dma/src/main.c | Main program
project/at_start_f435/examples/tmr/dma_burst/src/main.c | Main program
project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c | Main program
project/at_start_f435/examples/tmr/external_clock/src/main.c | Main program
project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c | Main program
project/at_start_f435/examples/tmr/hang_mode/src/main.c | Main program
project/at_start_f435/examples/tmr/input_capture/src/main.c | Main program
project/at_start_f435/examples/tmr/oc_high/src/main.c | Main program
project/at_start_f435/examples/tmr/oc_low/src/main.c | Main program
project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c | Main program
project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c | Main program
project/at_start_f435/examples/tmr/one_cycle/src/main.c | Main program
project/at_start_f435/examples/tmr/parallel_synchro/src/main.c | Main program
project/at_start_f435/examples/tmr/pwm_input/src/main.c | Main program
project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c | Main program
project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c | Main program
project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c | Main program
project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c | Main program
project/at_start_f435/examples/tmr/timer_base/src/main.c | Main program
project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c | Main program
project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c | Main program
project/at_start_f435/examples/usart/half_duplex/src/main.c | Main program
project/at_start_f435/examples/usart/hw_flow_control/src/main.c | Main program
project/at_start_f435/examples/usart/idle_detection/src/main.c | Main program
project/at_start_f435/examples/usart/interrupt/src/main.c | Main program
project/at_start_f435/examples/usart/irda/src/main.c | Main program
project/at_start_f435/examples/usart/polling/src/main.c | Main program
project/at_start_f435/examples/usart/printf/src/main.c | Main program
project/at_start_f435/examples/usart/receiver_mute/src/main.c | Main program
project/at_start_f435/examples/usart/rs485/src/main.c | Main program
project/at_start_f435/examples/usart/smartcard/src/main.c | Main program
project/at_start_f435/examples/usart/synchronous/src/main.c | Main program
project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c | Main program
project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c | Main program
project/at_start_f435/examples/usart/tx_rx_swap/src/main.c | Main program
project/at_start_f435/examples/usb_device/audio/src/main.c | Main program
project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c | Main program
project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c | Main program
project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c | Main program
project/at_start_f435/examples/usb_device/custom_hid/src/main.c | Main program
project/at_start_f435/examples/usb_device/keyboard/src/main.c | Main program
project/at_start_f435/examples/usb_device/mouse/src/main.c | Main program
project/at_start_f435/examples/usb_device/msc/src/main.c | Main program
project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c | Main program
project/at_start_f435/examples/usb_device/printer/src/main.c | Main program
project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c | Main program
project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c | Main program
project/at_start_f435/examples/usb_device/virtual_comport/src/main.c | Main program
project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c | Main program
project/at_start_f435/examples/usb_host/hid_demo/src/main.c | Main program
project/at_start_f435/examples/usb_host/msc_only_fat32/src/main.c | Main program
project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c | Main program
project/at_start_f435/examples/wdt/wdt_reset/src/main.c | Main program
project/at_start_f435/examples/wdt/wdt_standby/src/main.c | Main program
project/at_start_f435/examples/wwdt/wwdt_reset/src/main.c | Main program
project/at_start_f435/examples/xmc/lcd_8bit/src/main.c | Main program
project/at_start_f435/examples/xmc/lcd_touch_16bit/src/main.c | Main program
project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c | Main program
project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c | Main program
project/at_start_f435/examples/xmc/nor_flash/src/main.c | Main program
project/at_start_f435/examples/xmc/psram/src/main.c | Main program
project/at_start_f435/examples/xmc/sdram_basic/src/main.c | Main program
project/at_start_f435/examples/xmc/sdram_dma/src/main.c | Main program
project/at_start_f435/examples/xmc/sram/src/main.c | Main program
project/at_start_f435/templates/src/main.c | Main program
project/at_start_f437/examples/acc/calibration/src/main.c | Main program
project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c | Main program
project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c | Main program
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c | Main program
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c | Main program
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c | Main program
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c | Main program
project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c | Main program
project/at_start_f437/examples/adc/conversion_abort/src/main.c | Main program
project/at_start_f437/examples/adc/current_vref_value_check/src/main.c | Main program
project/at_start_f437/examples/adc/edma_double_buffer/src/main.c | Main program
project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c | Main program
project/at_start_f437/examples/adc/internal_temperature_sensor/src/main.c | Main program
project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/main.c | Main program
project/at_start_f437/examples/adc/resolution_6bit/src/main.c | Main program
project/at_start_f437/examples/adc/software_trigger_repeat/src/main.c | Main program
project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c | Main program
project/at_start_f437/examples/adc/use_polling_get_conversion_data/src/main.c | Main program
project/at_start_f437/examples/adc/vbat_monitor/src/main.c | Main program
project/at_start_f437/examples/adc/voltage_monitoring/src/main.c | Main program
project/at_start_f437/examples/can/communication_mode/src/main.c | Main program
project/at_start_f437/examples/can/filter/src/main.c | Main program
project/at_start_f437/examples/can/loopback_mode/src/main.c | Main program
project/at_start_f437/examples/cortex_m4/bit_band/src/main.c | Main program
project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c | Main program
project/at_start_f437/examples/cortex_m4/fpu/src/main.c | Main program
project/at_start_f437/examples/cortex_m4/systick_interrupt/src/main.c | Main program
project/at_start_f437/examples/crc/calculation/src/main.c | Main program
project/at_start_f437/examples/crm/clock_failure_detection/src/main.c | Main program
project/at_start_f437/examples/crm/pll_parameter_calculate/src/main.c | Main program
project/at_start_f437/examples/crm/sysclk_switch/src/main.c | Main program
project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/main.c | Main program
project/at_start_f437/examples/dac/double_mode_dma_squarewave/src/main.c | Main program
project/at_start_f437/examples/dac/one_dac_dma_escalator/src/main.c | Main program
project/at_start_f437/examples/dac/one_dac_noisewave/src/main.c | Main program
project/at_start_f437/examples/dac/two_dac_trianglewave/src/main.c | Main program
project/at_start_f437/examples/debug/tmr1/src/main.c | Main program
project/at_start_f437/examples/dma/dmamux_data_to_gpio/src/main.c | Main program
project/at_start_f437/examples/dma/dmamux_genertor_exint/src/main.c | Main program
project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/main.c | Main program
project/at_start_f437/examples/dma/flash_to_sram/src/main.c | Main program
project/at_start_f437/examples/dvp/ov2640_capture/src/main.c | Main program
project/at_start_f437/examples/dvp/ov5640_capture/src/main.c | Main program
project/at_start_f437/examples/edma/burst_mode/src/main.c | Main program
project/at_start_f437/examples/edma/dmamux_genertor_exint/src/main.c | Main program
project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/main.c | Main program
project/at_start_f437/examples/edma/flash_to_sram/src/main.c | Main program
project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c | Main program
project/at_start_f437/examples/edma/link_list_mode/src/main.c | Main program
project/at_start_f437/examples/edma/two_dimension_mode/src/main.c | Main program
project/at_start_f437/examples/emac/dns_client/src/main.c | Main program
project/at_start_f437/examples/emac/http_server/src/main.c | Main program
project/at_start_f437/examples/emac/iperf/src/main.c | Main program
project/at_start_f437/examples/emac/mqtt_client/src/main.c | Main program
project/at_start_f437/examples/emac/tcp_client/src/main.c | Main program
project/at_start_f437/examples/emac/tcp_server/src/main.c | Main program
project/at_start_f437/examples/emac/telnet/src/main.c | Main program
project/at_start_f437/examples/emac/wake_on_lan/src/main.c | Main program
project/at_start_f437/examples/ertc/bpr_domain/src/main.c | Main program
project/at_start_f437/examples/ertc/calendar/src/main.c | Main program
project/at_start_f437/examples/ertc/lick_calibration/src/main.c | Main program
project/at_start_f437/examples/ertc/tamper/src/main.c | Main program
project/at_start_f437/examples/ertc/time_stamp/src/main.c | Main program
project/at_start_f437/examples/ertc/wakeup_timer/src/main.c | Main program
project/at_start_f437/examples/exint/exint_config/src/main.c | Main program
project/at_start_f437/examples/exint/exint_software_trigger/src/main.c | Main program
project/at_start_f437/examples/flash/fap_enable/src/main.c | Main program
project/at_start_f437/examples/flash/flash_write_read/src/main.c | Main program
project/at_start_f437/examples/gpio/io_toggle/src/main.c | Main program
project/at_start_f437/examples/gpio/led_toggle/src/main.c | Main program
project/at_start_f437/examples/gpio/swjtag_mux/src/main.c | Main program
project/at_start_f437/examples/i2c/communication_dma/src/main.c | Main program
project/at_start_f437/examples/i2c/communication_int/src/main.c | Main program
project/at_start_f437/examples/i2c/communication_poll/src/main.c | Main program
project/at_start_f437/examples/i2c/communication_smbus/src/main.c | Main program
project/at_start_f437/examples/i2c/eeprom/src/main.c | Main program
project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c | Main program
project/at_start_f437/examples/i2s/halfduplex_dma/src/main.c | Main program
project/at_start_f437/examples/i2s/halfduplex_interrupt/src/main.c | Main program
project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c | Main program
project/at_start_f437/examples/irtmr/irtmr_output/src/main.c | Main program
project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/src/main.c | Main program
project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/src/main.c | Main program
project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/src/main.c | Main program
project/at_start_f437/examples/pwc/ldo_set/src/main.c | Main program
project/at_start_f437/examples/pwc/power_voltage_monitor/src/main.c | Main program
project/at_start_f437/examples/pwc/sleep_tmr2/src/main.c | Main program
project/at_start_f437/examples/pwc/sleep_usart1/src/main.c | Main program
project/at_start_f437/examples/pwc/standby_ertc_alarm/src/main.c | Main program
project/at_start_f437/examples/pwc/standby_wakeup_pin/src/main.c | Main program
project/at_start_f437/examples/qspi/command_port_using_dma/src/main.c | Main program
project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/main.c | Main program
project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/main.c | Main program
project/at_start_f437/examples/qspi/command_port_using_interrupt/src/main.c | Main program
project/at_start_f437/examples/qspi/command_port_using_polling/src/main.c | Main program
project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/main.c | Main program
project/at_start_f437/examples/qspi/xip_port_write_read/src/main.c | Main program
project/at_start_f437/examples/scfg/mem_map_sel/src/main.c | Main program
project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c | Main program
project/at_start_f437/examples/sdio/sdio_fatfs/src/main.c | Main program
project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c | Main program
project/at_start_f437/examples/spi/fullduplex_polling/src/main.c | Main program
project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c | Main program
project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c | Main program
project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c | Main program
project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c | Main program
project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c | Main program
project/at_start_f437/examples/spi/w25q_flash/src/main.c | Main program
project/at_start_f437/examples/sram/extend_sram/src/main.c | Main program
project/at_start_f437/examples/tmr/6_steps/src/main.c | Main program
project/at_start_f437/examples/tmr/7_pwm_output/src/main.c | Main program
project/at_start_f437/examples/tmr/cascade_synchro/src/main.c | Main program
project/at_start_f437/examples/tmr/complementary_signals/src/main.c | Main program
project/at_start_f437/examples/tmr/dma/src/main.c | Main program
project/at_start_f437/examples/tmr/dma_burst/src/main.c | Main program
project/at_start_f437/examples/tmr/encoder_tmr2/src/main.c | Main program
project/at_start_f437/examples/tmr/external_clock/src/main.c | Main program
project/at_start_f437/examples/tmr/hall_xor_tmr2/src/main.c | Main program
project/at_start_f437/examples/tmr/hang_mode/src/main.c | Main program
project/at_start_f437/examples/tmr/input_capture/src/main.c | Main program
project/at_start_f437/examples/tmr/oc_high/src/main.c | Main program
project/at_start_f437/examples/tmr/oc_low/src/main.c | Main program
project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/main.c | Main program
project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/main.c | Main program
project/at_start_f437/examples/tmr/one_cycle/src/main.c | Main program
project/at_start_f437/examples/tmr/parallel_synchro/src/main.c | Main program
project/at_start_f437/examples/tmr/pwm_input/src/main.c | Main program
project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c | Main program
project/at_start_f437/examples/tmr/pwm_output_simulate/src/main.c | Main program
project/at_start_f437/examples/tmr/pwm_output_tmr10/src/main.c | Main program
project/at_start_f437/examples/tmr/pwm_output_tmr3/src/main.c | Main program
project/at_start_f437/examples/tmr/timer_base/src/main.c | Main program
project/at_start_f437/examples/tmr/tmr1_synchro/src/main.c | Main program
project/at_start_f437/examples/tmr/tmr2_32bit/src/main.c | Main program
project/at_start_f437/examples/usart/half_duplex/src/main.c | Main program
project/at_start_f437/examples/usart/hw_flow_control/src/main.c | Main program
project/at_start_f437/examples/usart/idle_detection/src/main.c | Main program
project/at_start_f437/examples/usart/interrupt/src/main.c | Main program
project/at_start_f437/examples/usart/irda/src/main.c | Main program
project/at_start_f437/examples/usart/polling/src/main.c | Main program
project/at_start_f437/examples/usart/printf/src/main.c | Main program
project/at_start_f437/examples/usart/receiver_mute/src/main.c | Main program
project/at_start_f437/examples/usart/rs485/src/main.c | Main program
project/at_start_f437/examples/usart/smartcard/src/main.c | Main program
project/at_start_f437/examples/usart/synchronous/src/main.c | Main program
project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c | Main program
project/at_start_f437/examples/usart/transfer_by_dma_polling/src/main.c | Main program
project/at_start_f437/examples/usart/tx_rx_swap/src/main.c | Main program
project/at_start_f437/examples/usb_device/audio/src/main.c | Main program
project/at_start_f437/examples/usb_device/composite_audio_hid/src/main.c | Main program
project/at_start_f437/examples/usb_device/composite_vcp_keyboard/src/main.c | Main program
project/at_start_f437/examples/usb_device/composite_vcp_msc/src/main.c | Main program
project/at_start_f437/examples/usb_device/custom_hid/src/main.c | Main program
project/at_start_f437/examples/usb_device/keyboard/src/main.c | Main program
project/at_start_f437/examples/usb_device/mouse/src/main.c | Main program
project/at_start_f437/examples/usb_device/msc/src/main.c | Main program
project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/main.c | Main program
project/at_start_f437/examples/usb_device/printer/src/main.c | Main program
project/at_start_f437/examples/usb_device/two_otg_device_demo/src/main.c | Main program
project/at_start_f437/examples/usb_device/vcp_loopback/src/main.c | Main program
project/at_start_f437/examples/usb_device/virtual_comport/src/main.c | Main program
project/at_start_f437/examples/usb_device/virtual_msc_iap/src/main.c | Main program
project/at_start_f437/examples/usb_host/hid_demo/src/main.c | Main program
project/at_start_f437/examples/usb_host/msc_only_fat32/src/main.c | Main program
project/at_start_f437/examples/usb_host/two_otg_host_demo/src/main.c | Main program
project/at_start_f437/examples/wdt/wdt_reset/src/main.c | Main program
project/at_start_f437/examples/wdt/wdt_standby/src/main.c | Main program
project/at_start_f437/examples/wwdt/wwdt_reset/src/main.c | Main program
project/at_start_f437/examples/xmc/lcd_8bit/src/main.c | Main program
project/at_start_f437/examples/xmc/lcd_touch_16bit/src/main.c | Main program
project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c | Main program
project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c | Main program
project/at_start_f437/examples/xmc/nor_flash/src/main.c | Main program
project/at_start_f437/examples/xmc/psram/src/main.c | Main program
project/at_start_f437/examples/xmc/sdram_basic/src/main.c | Main program
project/at_start_f437/examples/xmc/sdram_dma/src/main.c | Main program
project/at_start_f437/examples/xmc/sram/src/main.c | Main program
project/at_start_f437/templates/src/main.c | Main program
utilities/at32f435_437_freertos_demo/src/main.c | Main program
utilities/at32f435_437_gen_random_number_demo/src/main.c | Main program
utilities/at32f435_437_slib_demo/project_l0/src/main.c | Main program
utilities/at32f435_437_slib_demo/project_l1/src/main.c | Main program
utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/main.c | Main program
utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/main.c | Main program
utilities/at32f435_437_usart_iap_demo/source_code/bootloader/src/main.c | Main program
utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c | Main program
utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c | Main program
utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c | Main program
utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/main.c | Main program
utilities/at32f437_emac_iap_demo/source_code/bootloader/src/main.c | Main program
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_board.d |
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_board.d |
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_clock.d |
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_clock.d |
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_crm.d |
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_crm.d |
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_gpio.d |
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_gpio.d |
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_int.d |
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_int.d |
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_misc.d |
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_misc.d |
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_usart.d |
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_usart.d |
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/basicmathfunctions.d |
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/basicmathfunctions.d |
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/bayesfunctions.d |
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/bayesfunctions.d |
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/commontables.d |
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/commontables.d |
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/complexmathfunctions.d |
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/complexmathfunctions.d |
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/controllerfunctions.d |
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/controllerfunctions.d |
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/distancefunctions.d |
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/distancefunctions.d |
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/fastmathfunctions.d |
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/fastmathfunctions.d |
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/filteringfunctions.d |
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/filteringfunctions.d |
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/main.d |
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/main.d |
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/matrixfunctions.d |
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/matrixfunctions.d |
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/startup_at32f435_437.d |
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/startup_at32f435_437.d |
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/statisticsfunctions.d |
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/statisticsfunctions.d |
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/supportfunctions.d |
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/supportfunctions.d |
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/svmfunctions.d |
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/svmfunctions.d |
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/system_at32f435_437.d |
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/system_at32f435_437.d |
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/transformfunctions.d |
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/transformfunctions.d |
at_start_f435/examples/cortex_m4/fpu/inc/julia_fpu.h | Julia_fpu header file
at_start_f437/examples/cortex_m4/fpu/inc/julia_fpu.h | Julia_fpu header file
at_start_f435/examples/cortex_m4/fpu/src/julia_fpu.c | Julia_fpu source file
at_start_f437/examples/cortex_m4/fpu/src/julia_fpu.c | Julia_fpu source file
at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c | Dvp program
at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c | Dvp program
at_start_f437/examples/dvp/ov2640_capture/hardware/dvp/dvp.c | Dvp program
at_start_f437/examples/dvp/ov5640_capture/hardware/dvp/dvp.c | Dvp program
at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.h | Header file of dvp program
at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.h | Header file of dvp program
at_start_f437/examples/dvp/ov2640_capture/hardware/dvp/dvp.h | Header file of dvp program
at_start_f437/examples/dvp/ov5640_capture/hardware/dvp/dvp.h | Header file of dvp program
at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h |
at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/font.h |
at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/font.h |
at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/font.h |
at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c | Xmc_lcd program file
at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c | Xmc_lcd program file
at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c | Xmc_lcd config program
at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c | Xmc_lcd program file
at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c | Xmc_lcd program file
at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c | Xmc_lcd program file
at_start_f437/examples/xmc/lcd_8bit/src/xmc_lcd.c | Xmc_lcd config program
at_start_f437/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c | Xmc_lcd program file
at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h | Xmc_lcd program header
at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h | Xmc_lcd program header
at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h | Xmc_lcd header file
at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h | Xmc_lcd program header
at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h | Xmc_lcd program header
at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h | Xmc_lcd program header
at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h | Xmc_lcd header file
at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h | Xmc_lcd program header
at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c |
at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c |
at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h |
at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h |
at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h |
at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h |
at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c |
at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c |
at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h |
at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h |
at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c | Ov5640 program
at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c | Ov5640 program
at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h |
at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h |
at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640af.h | Header file of ov5640af program
at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640af.h | Header file of ov5640af program
at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h | Header file of ov5640cfg program
at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h | Header file of ov5640cfg program
project/at_start_f435/examples/flash/flash_write_read/inc/flash.h | Flash header file
project/at_start_f437/examples/flash/flash_write_read/inc/flash.h | Flash header file
utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/flash.h | Flash header file
utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/flash.h | Flash header file
utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/flash.h | Flash header file
project/at_start_f435/examples/flash/flash_write_read/src/flash.c | Flash program
project/at_start_f437/examples/flash/flash_write_read/src/flash.c | Flash program
utilities/at32f435_437_usart_iap_demo/source_code/bootloader/src/flash.c | Flash program
utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/flash.c | Flash program
utilities/at32f437_emac_iap_demo/source_code/bootloader/src/flash.c | Flash program
at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c | Qspi_cmd_esmt32m program
at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c | Qspi_cmd_esmt32m program
at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c | Qspi_cmd_esmt32m program
at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c | Qspi_cmd_esmt32m program
at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c | Qspi_cmd_esmt32m program
at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c | Qspi_cmd_esmt32m program
at_start_f437/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c | Qspi_cmd_esmt32m program
at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c | Qspi_cmd_esmt32m program
at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c | Qspi_cmd_esmt32m program
at_start_f437/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c | Qspi_cmd_esmt32m program
at_start_f437/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c | Qspi_cmd_esmt32m program
at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c | Qspi_cmd_esmt32m program
at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c |
at_start_f437/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c |
at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h | This file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library
at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h | This file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library
at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h | This file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library
at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h | This file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library
at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h |
at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h |
at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h |
at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h |
at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h |
at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h |
at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c | This file provides a set of functions needed to manage the sdio/mmc card memory
at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c | This file provides a set of functions needed to manage the sdio/mmc card memory
at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c | This file provides a set of functions needed to manage the sdio/mmc card memory
at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c | This file provides a set of functions needed to manage the sdio/mmc card memory
at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c |
at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c |
at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h | Header file of spi_flash
at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h | Header file of spi_flash
at_start_f435/examples/spi/w25q_flash/src/spi_flash.c | Spi_flash source code
at_start_f437/examples/spi/w25q_flash/src/spi_flash.c | Spi_flash source code
at_start_f435/examples/usart/smartcard/inc/smartcard_config.h | Header file of clock program
at_start_f437/examples/usart/smartcard/inc/smartcard_config.h | Header file of clock program
at_start_f435/examples/usb_device/audio/inc/audio_codec.h | Audio codec header file
at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h | Audio codec header file
at_start_f437/examples/usb_device/audio/inc/audio_codec.h | Audio codec header file
at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h | Audio codec header file
at_start_f435/examples/usb_device/audio/src/audio_codec.c | Audio codec function
at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c | Audio codec function
at_start_f437/examples/usb_device/audio/src/audio_codec.c | Audio codec function
at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c | Audio codec function
at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h | Usb mass storage disk interface header file
at_start_f435/examples/usb_device/msc/inc/msc_diskio.h | Usb mass storage disk interface header file
at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h | Usb mass storage disk interface header file
at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h | Usb mass storage disk interface header file
at_start_f437/examples/usb_device/msc/inc/msc_diskio.h | Usb mass storage disk interface header file
at_start_f437/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h | Usb mass storage disk interface header file
at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c | Usb mass storage disk function
at_start_f435/examples/usb_device/msc/src/msc_diskio.c | Usb mass storage disk function
at_start_f435/examples/usb_device/virtual_msc_iap/src/msc_diskio.c | Usb mass storage disk function
at_start_f437/examples/usb_device/composite_vcp_msc/src/msc_diskio.c | Usb mass storage disk function
at_start_f437/examples/usb_device/msc/src/msc_diskio.c | Usb mass storage disk function
at_start_f437/examples/usb_device/virtual_msc_iap/src/msc_diskio.c | Usb mass storage disk function
at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c | Usb user function
at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c | Usb user function
at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c | Usb user function
at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c | Usb user function
at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c | Usb user function
at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c | Usb user function
at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c | Usb user function
at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c | Usb user function
at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.h | Usb host user header file
at_start_f435/examples/usb_host/hid_demo/inc/usbh_user.h | Usb host user header file
at_start_f435/examples/usb_host/msc_only_fat32/inc/usbh_user.h | Usb host user header file
at_start_f435/examples/usb_host/two_otg_host_demo/inc/usbh_user.h | Usb host user header file
at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.h | Usb host user header file
at_start_f437/examples/usb_host/hid_demo/inc/usbh_user.h | Usb host user header file
at_start_f437/examples/usb_host/msc_only_fat32/inc/usbh_user.h | Usb host user header file
at_start_f437/examples/usb_host/two_otg_host_demo/inc/usbh_user.h | Usb host user header file
at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h | Fat16 file system header file
at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h | Fat16 file system header file
at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c | Fat16 file system
at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c | Fat16 file system
at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c | Usb mass storage disk io
at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c | Usb mass storage disk io
at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c | Usb mass storage disk io
at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c | Usb mass storage disk io
at_start_f435/examples/xmc/lcd_8bit/inc/picture.h | This file contains all the picture used for lcd display
at_start_f437/examples/xmc/lcd_8bit/inc/picture.h | This file contains all the picture used for lcd display
at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h | This file contains all the functions prototypes for the touch firmware driver
at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h | This file contains all the functions prototypes for the touch firmware driver
at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c | This file contains all the functions prototypes for the touch firmware driver
at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c | This file contains all the functions prototypes for the touch firmware driver
at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h | Header file for the nand ecc configuration
at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h | Header file for the nand ecc configuration
at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c | Nand ecc configuration
at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c | Nand ecc configuration
at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h | Header file for the nand configuration
at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h | Header file for the nand configuration
at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c | Nand configuration
at_start_f437/examples/xmc/nand_flash/nand/src/xmc_nand.c | Nand configuration
at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h |
at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h |
at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c |
at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c |
at_start_f435/examples/xmc/psram/inc/xmc_psram.h |
at_start_f437/examples/xmc/psram/inc/xmc_psram.h |
at_start_f435/examples/xmc/psram/src/xmc_psram.c | Xmc_psram program
at_start_f437/examples/xmc/psram/src/xmc_psram.c | Xmc_psram program
at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h | Header file for the sdram configuration
at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h | Header file for the sdram configuration
at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h | Header file for the sdram configuration
at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h | Header file for the sdram configuration
at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c | Sdram program
at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c | Sdram program
at_start_f437/examples/xmc/sdram_basic/src/xmc_sdram.c | Sdram program
at_start_f437/examples/xmc/sdram_dma/src/xmc_sdram.c | Sdram program
at_start_f435/examples/xmc/sram/inc/xmc_sram.h | Header file for the nand configuration
at_start_f437/examples/xmc/sram/inc/xmc_sram.h | Header file for the nand configuration
at_start_f435/examples/xmc/sram/src/xmc_sram.c | Sram program
at_start_f437/examples/xmc/sram/src/xmc_sram.c | Sram program
project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h | Header file of emac config program
project/at_start_f437/examples/emac/http_server/inc/at32_emac.h | Header file of emac config program
project/at_start_f437/examples/emac/iperf/inc/at32_emac.h | Header file of emac config program
project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h | Header file of emac config program
project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h | Header file of emac config program
project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h | Header file of emac config program
project/at_start_f437/examples/emac/telnet/inc/at32_emac.h | Header file of emac config program
project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h | Header file of emac config program
utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h | Header file of emac config program
utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h | Header file of emac config program
project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h |
project/at_start_f437/examples/emac/http_server/inc/lwipopts.h |
project/at_start_f437/examples/emac/iperf/inc/lwipopts.h |
project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h |
project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h |
project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h |
project/at_start_f437/examples/emac/telnet/inc/lwipopts.h |
project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h |
utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h |
utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h |
project/at_start_f437/examples/emac/dns_client/inc/netconf.h | This file contains all the functions prototypes for the netconf.c file
project/at_start_f437/examples/emac/http_server/inc/netconf.h | This file contains all the functions prototypes for the netconf.c file
project/at_start_f437/examples/emac/iperf/inc/netconf.h | This file contains all the functions prototypes for the netconf.c file
project/at_start_f437/examples/emac/mqtt_client/inc/netconf.h | This file contains all the functions prototypes for the netconf.c file
project/at_start_f437/examples/emac/tcp_client/inc/netconf.h | This file contains all the functions prototypes for the netconf.c file
project/at_start_f437/examples/emac/tcp_server/inc/netconf.h | This file contains all the functions prototypes for the netconf.c file
project/at_start_f437/examples/emac/telnet/inc/netconf.h | This file contains all the functions prototypes for the netconf.c file
project/at_start_f437/examples/emac/wake_on_lan/inc/netconf.h | This file contains all the functions prototypes for the netconf.c file
utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/netconf.h | This file contains all the functions prototypes for the netconf.c file
utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/netconf.h | This file contains all the functions prototypes for the netconf.c file
project/at_start_f437/examples/emac/dns_client/src/at32_emac.c | Emac config program
project/at_start_f437/examples/emac/http_server/src/at32_emac.c | Emac config program
project/at_start_f437/examples/emac/iperf/src/at32_emac.c | Emac config program
project/at_start_f437/examples/emac/mqtt_client/src/at32_emac.c | Emac config program
project/at_start_f437/examples/emac/tcp_client/src/at32_emac.c | Emac config program
project/at_start_f437/examples/emac/tcp_server/src/at32_emac.c | Emac config program
project/at_start_f437/examples/emac/telnet/src/at32_emac.c | Emac config program
project/at_start_f437/examples/emac/wake_on_lan/src/at32_emac.c | Emac config program
utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c | Emac config program
utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c | Emac config program
project/at_start_f437/examples/emac/dns_client/src/netconf.c | Network connection configuration
project/at_start_f437/examples/emac/http_server/src/netconf.c | Network connection configuration
project/at_start_f437/examples/emac/iperf/src/netconf.c | Network connection configuration
project/at_start_f437/examples/emac/mqtt_client/src/netconf.c | Network connection configuration
project/at_start_f437/examples/emac/tcp_client/src/netconf.c | Network connection configuration
project/at_start_f437/examples/emac/tcp_server/src/netconf.c | Network connection configuration
project/at_start_f437/examples/emac/telnet/src/netconf.c | Network connection configuration
project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c | Network connection configuration
utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c | Network connection configuration
utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c | Network connection configuration
project/at_start_f437/examples/emac/http_server/inc/fsdata.h |
utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h | Fsdata header file
httpd_structs.h |
fs.c |
project/at_start_f437/examples/emac/http_server/src/fsdata.c |
utilities/at32f437_emac_iap_demo/source_code/bootloader/src/fsdata.c | Fsdata
httpd.c |
iperf.h | Iperf tool header
iperf.c | Iperf tool
mqtt_client.h | Mqtt client header
mqtt_client.c | Mqtt client config program
tcp_client.h | Tcp client header
tcp_client.c | Implement tcp client
tcp_server.h | Tcp server header
tcp_server.c | Implement tcp server
telnet.h |
telnet.c | Telnet implement header file
FreeRTOSConfig.h |
random.h | At32f435_437 random header file
random.c | Set of firmware functions to random function
flash_loader.c |
flash_loader.h |
flash_loader_extra.h |
flash_loader_ram.c |
flash_config.h |
qspi_algorithm.c |
FlashOS.h |
FlashDev.c | Device description for new device flash
FlashPrg.c | Device algorithm for new device flash
project_l0/inc/fir_filter.h |
project_l1/inc/fir_filter.h |
project_l0/inc/math_helper.h |
project_l1/inc/math_helper.h |
project_l0/src/arm_fir_data.c |
project_l1/src/arm_fir_data.c |
arm_fir_init_f32.c |
fir_coefficient.c |
fir_filter.c |
project_l0/src/math_helper.c |
project_l1/src/math_helper.c |
at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h | Iap header file
at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/iap.h | Iap header file
at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h | Iap header file
at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/iap.h | Iap header file
at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h | Iap header file
at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/tmr.h | Tmr header file
at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/tmr.h | Tmr header file
at32f435_437_usart_iap_demo/source_code/bootloader/inc/tmr.h | Tmr header file
at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/tmr.h | Tmr header file
at32f437_emac_iap_demo/source_code/bootloader/inc/tmr.h | Tmr header file
app_led3_toggle/inc/usart.h | Usart header file
app_led4_toggle/inc/usart.h | Usart header file
bootloader/inc/usart.h | Usart header file
at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c | Iap program
at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/iap.c | Iap program
at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c | Iap program
at32f437_emac_iap_demo/source_code/app_led3_toggle/src/iap.c | Iap program
at32f437_emac_iap_demo/source_code/bootloader/src/iap.c | Iap program
at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/tmr.c | Tmr program
at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/tmr.c | Tmr program
at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c | Tmr program
at32f437_emac_iap_demo/source_code/app_led3_toggle/src/tmr.c | Tmr program
at32f437_emac_iap_demo/source_code/bootloader/src/tmr.c | Tmr program
app_led3_toggle/src/usart.c | Usart program
app_led4_toggle/src/usart.c | Usart program
bootloader/src/usart.c | Usart program
app_led3_toggle/inc/hid_iap_user.h | Usb config header file
app_led4_toggle/inc/hid_iap_user.h | Usb config header file
bootloader/inc/hid_iap_user.h | Usb config header file
app_led3_toggle/src/hid_iap_user.c | Usb hid iap user file
app_led4_toggle/src/hid_iap_user.c | Usb hid iap user file
bootloader/src/hid_iap_user.c | Usb hid iap user file
httpserver.h | Httpserver header file
tftpserver.h |
httpserver.c | Httpserver program
tftpserver.c | Basic tftp server implementation for IAP (only Write Req supported)


AT32F435/437 Firmwary Library: at32f435_437.h File Reference

  • AT32F435_437_Firmware_Library_V2.0.9
  • libraries
  • cmsis
  • cm4
  • device_support
Macros | Typedefs | Enumerations
at32f435_437.h File Reference

at32f435_437 header file More...

#include "core_cm4.h"
#include "system_at32f435_437.h"
#include <stdint.h>
#include "at32f435_437_def.h"
#include "at32f435_437_conf.h"

Go to the source code of this file.

Macros

#define | __AT32F435_437_LIBRARY_VERSION_MAJOR (0x02)
at32f435_437 standard peripheral library version number More...
#define | __AT32F435_437_LIBRARY_VERSION_MIDDLE (0x00)
#define | __AT32F435_437_LIBRARY_VERSION_MINOR (0x09)
#define | __AT32F435_437_LIBRARY_VERSION_RC (0x00)
#define | __AT32F435_437_LIBRARY_VERSION
#define | __CM4_REV 0x0001U
configuration of the cortex-m4 processor and core peripherals More...
#define | __MPU_PRESENT 1
#define | __NVIC_PRIO_BITS 4
#define | __Vendor_SysTickConfig 0
#define | __FPU_PRESENT 1U
#define | REG8(addr) *(volatile uint8_t *)(addr)
#define | REG16(addr) *(volatile uint16_t *)(addr)
#define | REG32(addr) *(volatile uint32_t *)(addr)
#define | MAKE_VALUE(reg_offset, bit_num) (((reg_offset) << 16) | (bit_num & 0x1f))
#define | PERIPH_REG(periph_base, value) REG32((periph_base + (value >> 16)))
#define | PERIPH_REG_BIT(value) (0x1u << (value & 0x1f))
#define | XMC_SDRAM_MEM_BASE ((uint32_t)0xC0000000)
#define | QSPI2_MEM_BASE ((uint32_t)0xB0000000)
#define | XMC_CARD_MEM_BASE ((uint32_t)0xA8000000)
#define | QSPI2_REG_BASE ((uint32_t)0xA0002000)
#define | QSPI1_REG_BASE ((uint32_t)0xA0001000)
#define | XMC_REG_BASE ((uint32_t)0xA0000000)
#define | XMC_BANK1_REG_BASE (XMC_REG_BASE + 0x0000)
#define | XMC_BANK2_REG_BASE (XMC_REG_BASE + 0x0060)
#define | XMC_BANK3_REG_BASE (XMC_REG_BASE + 0x0080)
#define | XMC_BANK4_REG_BASE (XMC_REG_BASE + 0x00A0)
#define | XMC_SDRAM_REG_BASE (XMC_REG_BASE + 0x0140)
#define | QSPI1_MEM_BASE ((uint32_t)0x90000000)
#define | XMC_MEM_BASE ((uint32_t)0x60000000)
#define | PERIPH_BASE ((uint32_t)0x40000000)
#define | SRAM_BB_BASE ((uint32_t)0x22000000)
#define | PERIPH_BB_BASE ((uint32_t)0x42000000)
#define | SRAM_BASE ((uint32_t)0x20000000)
#define | USD_BASE ((uint32_t)0x1FFFC000)
#define | FLASH_BASE ((uint32_t)0x08000000)
#define | DEBUG_BASE ((uint32_t)0xE0042000)
#define | APB1PERIPH_BASE (PERIPH_BASE)
#define | APB2PERIPH_BASE (PERIPH_BASE + 0x10000)
#define | AHBPERIPH1_BASE (PERIPH_BASE + 0x20000)
#define | AHBPERIPH2_BASE (PERIPH_BASE + 0x10000000)
#define | UART8_BASE (APB1PERIPH_BASE + 0x7C00)
#define | UART7_BASE (APB1PERIPH_BASE + 0x7800)
#define | DAC_BASE (APB1PERIPH_BASE + 0x7400)
#define | PWC_BASE (APB1PERIPH_BASE + 0x7000)
#define | CAN2_BASE (APB1PERIPH_BASE + 0x6800)
#define | CAN1_BASE (APB1PERIPH_BASE + 0x6400)
#define | I2C3_BASE (APB1PERIPH_BASE + 0x5C00)
#define | I2C2_BASE (APB1PERIPH_BASE + 0x5800)
#define | I2C1_BASE (APB1PERIPH_BASE + 0x5400)
#define | UART5_BASE (APB1PERIPH_BASE + 0x5000)
#define | UART4_BASE (APB1PERIPH_BASE + 0x4C00)
#define | USART3_BASE (APB1PERIPH_BASE + 0x4800)
#define | USART2_BASE (APB1PERIPH_BASE + 0x4400)
#define | SPI3_BASE (APB1PERIPH_BASE + 0x3C00)
#define | SPI2_BASE (APB1PERIPH_BASE + 0x3800)
#define | WDT_BASE (APB1PERIPH_BASE + 0x3000)
#define | WWDT_BASE (APB1PERIPH_BASE + 0x2C00)
#define | ERTC_BASE (APB1PERIPH_BASE + 0x2800)
#define | TMR14_BASE (APB1PERIPH_BASE + 0x2000)
#define | TMR13_BASE (APB1PERIPH_BASE + 0x1C00)
#define | TMR12_BASE (APB1PERIPH_BASE + 0x1800)
#define | TMR7_BASE (APB1PERIPH_BASE + 0x1400)
#define | TMR6_BASE (APB1PERIPH_BASE + 0x1000)
#define | TMR5_BASE (APB1PERIPH_BASE + 0x0C00)
#define | TMR4_BASE (APB1PERIPH_BASE + 0x0800)
#define | TMR3_BASE (APB1PERIPH_BASE + 0x0400)
#define | TMR2_BASE (APB1PERIPH_BASE + 0x0000)
#define | I2S2EXT_BASE (APB2PERIPH_BASE + 0x7800)
#define | I2S3EXT_BASE (APB2PERIPH_BASE + 0x7C00)
#define | ACC_BASE (APB2PERIPH_BASE + 0x7400)
#define | TMR20_BASE (APB2PERIPH_BASE + 0x4C00)
#define | TMR11_BASE (APB2PERIPH_BASE + 0x4800)
#define | TMR10_BASE (APB2PERIPH_BASE + 0x4400)
#define | TMR9_BASE (APB2PERIPH_BASE + 0x4000)
#define | EXINT_BASE (APB2PERIPH_BASE + 0x3C00)
#define | SCFG_BASE (APB2PERIPH_BASE + 0x3800)
#define | SPI4_BASE (APB2PERIPH_BASE + 0x3400)
#define | SPI1_BASE (APB2PERIPH_BASE + 0x3000)
#define | ADC1_BASE (APB2PERIPH_BASE + 0x2000)
#define | ADC2_BASE (APB2PERIPH_BASE + 0x2100)
#define | ADC3_BASE (APB2PERIPH_BASE + 0x2200)
#define | ADCCOM_BASE (APB2PERIPH_BASE + 0x2300)
#define | USART6_BASE (APB2PERIPH_BASE + 0x1400)
#define | USART1_BASE (APB2PERIPH_BASE + 0x1000)
#define | TMR8_BASE (APB2PERIPH_BASE + 0x0400)
#define | TMR1_BASE (APB2PERIPH_BASE + 0x0000)
#define | OTGFS2_BASE (AHBPERIPH1_BASE + 0x20000)
#define | SDIO1_BASE (AHBPERIPH1_BASE + 0xC400)
#define | GPIOH_BASE (AHBPERIPH1_BASE + 0x1C00)
#define | GPIOG_BASE (AHBPERIPH1_BASE + 0x1800)
#define | GPIOF_BASE (AHBPERIPH1_BASE + 0x1400)
#define | GPIOE_BASE (AHBPERIPH1_BASE + 0x1000)
#define | GPIOD_BASE (AHBPERIPH1_BASE + 0x0C00)
#define | GPIOC_BASE (AHBPERIPH1_BASE + 0x0800)
#define | GPIOB_BASE (AHBPERIPH1_BASE + 0x0400)
#define | GPIOA_BASE (AHBPERIPH1_BASE + 0x0000)
#define | DMA1_BASE (AHBPERIPH1_BASE + 0x6400)
#define | DMA1_CHANNEL1_BASE (DMA1_BASE + 0x0008)
#define | DMA1_CHANNEL2_BASE (DMA1_BASE + 0x001C)
#define | DMA1_CHANNEL3_BASE (DMA1_BASE + 0x0030)
#define | DMA1_CHANNEL4_BASE (DMA1_BASE + 0x0044)
#define | DMA1_CHANNEL5_BASE (DMA1_BASE + 0x0058)
#define | DMA1_CHANNEL6_BASE (DMA1_BASE + 0x006C)
#define | DMA1_CHANNEL7_BASE (DMA1_BASE + 0x0080)
#define | DMA1MUX_BASE (DMA1_BASE + 0x0104)
#define | DMA1MUX_CHANNEL1_BASE (DMA1MUX_BASE)
#define | DMA1MUX_CHANNEL2_BASE (DMA1MUX_BASE + 0x0004)
#define | DMA1MUX_CHANNEL3_BASE (DMA1MUX_BASE + 0x0008)
#define | DMA1MUX_CHANNEL4_BASE (DMA1MUX_BASE + 0x000C)
#define | DMA1MUX_CHANNEL5_BASE (DMA1MUX_BASE + 0x0010)
#define | DMA1MUX_CHANNEL6_BASE (DMA1MUX_BASE + 0x0014)
#define | DMA1MUX_CHANNEL7_BASE (DMA1MUX_BASE + 0x0018)
#define | DMA1MUX_GENERATOR1_BASE (DMA1_BASE + 0x0120)
#define | DMA1MUX_GENERATOR2_BASE (DMA1_BASE + 0x0124)
#define | DMA1MUX_GENERATOR3_BASE (DMA1_BASE + 0x0128)
#define | DMA1MUX_GENERATOR4_BASE (DMA1_BASE + 0x012C)
#define | DMA2_BASE (AHBPERIPH1_BASE + 0x6600)
#define | DMA2_CHANNEL1_BASE (DMA2_BASE + 0x0008)
#define | DMA2_CHANNEL2_BASE (DMA2_BASE + 0x001C)
#define | DMA2_CHANNEL3_BASE (DMA2_BASE + 0x0030)
#define | DMA2_CHANNEL4_BASE (DMA2_BASE + 0x0044)
#define | DMA2_CHANNEL5_BASE (DMA2_BASE + 0x0058)
#define | DMA2_CHANNEL6_BASE (DMA2_BASE + 0x006C)
#define | DMA2_CHANNEL7_BASE (DMA2_BASE + 0x0080)
#define | DMA2MUX_BASE (DMA2_BASE + 0x0104)
#define | DMA2MUX_CHANNEL1_BASE (DMA2MUX_BASE)
#define | DMA2MUX_CHANNEL2_BASE (DMA2MUX_BASE + 0x0004)
#define | DMA2MUX_CHANNEL3_BASE (DMA2MUX_BASE + 0x0008)
#define | DMA2MUX_CHANNEL4_BASE (DMA2MUX_BASE + 0x000C)
#define | DMA2MUX_CHANNEL5_BASE (DMA2MUX_BASE + 0x0010)
#define | DMA2MUX_CHANNEL6_BASE (DMA2MUX_BASE + 0x0014)
#define | DMA2MUX_CHANNEL7_BASE (DMA2MUX_BASE + 0x0018)
#define | DMA2MUX_GENERATOR1_BASE (DMA2_BASE + 0x0120)
#define | DMA2MUX_GENERATOR2_BASE (DMA2_BASE + 0x0124)
#define | DMA2MUX_GENERATOR3_BASE (DMA2_BASE + 0x0128)
#define | DMA2MUX_GENERATOR4_BASE (DMA2_BASE + 0x012C)
#define | EDMA_BASE (AHBPERIPH1_BASE + 0x6000)
#define | EDMA_STREAM1_BASE (EDMA_BASE + 0x0010)
#define | EDMA_STREAM2_BASE (EDMA_BASE + 0x0028)
#define | EDMA_STREAM3_BASE (EDMA_BASE + 0x0040)
#define | EDMA_STREAM4_BASE (EDMA_BASE + 0x0058)
#define | EDMA_STREAM5_BASE (EDMA_BASE + 0x0070)
#define | EDMA_STREAM6_BASE (EDMA_BASE + 0x0088)
#define | EDMA_STREAM7_BASE (EDMA_BASE + 0x00A0)
#define | EDMA_STREAM8_BASE (EDMA_BASE + 0x00B8)
#define | EDMA_2D_BASE (EDMA_BASE + 0x00F4)
#define | EDMA_STREAM1_2D_BASE (EDMA_2D_BASE + 0x0004)
#define | EDMA_STREAM2_2D_BASE (EDMA_2D_BASE + 0x000C)
#define | EDMA_STREAM3_2D_BASE (EDMA_2D_BASE + 0x0014)
#define | EDMA_STREAM4_2D_BASE (EDMA_2D_BASE + 0x001C)
#define | EDMA_STREAM5_2D_BASE (EDMA_2D_BASE + 0x0024)
#define | EDMA_STREAM6_2D_BASE (EDMA_2D_BASE + 0x002C)
#define | EDMA_STREAM7_2D_BASE (EDMA_2D_BASE + 0x0034)
#define | EDMA_STREAM8_2D_BASE (EDMA_2D_BASE + 0x003C)
#define | EDMA_LL_BASE (EDMA_BASE + 0x00D0)
#define | EDMA_STREAM1_LL_BASE (EDMA_LL_BASE + 0x0004)
#define | EDMA_STREAM2_LL_BASE (EDMA_LL_BASE + 0x0008)
#define | EDMA_STREAM3_LL_BASE (EDMA_LL_BASE + 0x000C)
#define | EDMA_STREAM4_LL_BASE (EDMA_LL_BASE + 0x0010)
#define | EDMA_STREAM5_LL_BASE (EDMA_LL_BASE + 0x0014)
#define | EDMA_STREAM6_LL_BASE (EDMA_LL_BASE + 0x0018)
#define | EDMA_STREAM7_LL_BASE (EDMA_LL_BASE + 0x001C)
#define | EDMA_STREAM8_LL_BASE (EDMA_LL_BASE + 0x0020)
#define | EDMAMUX_BASE (EDMA_BASE + 0x0140)
#define | EDMAMUX_CHANNEL1_BASE (EDMAMUX_BASE)
#define | EDMAMUX_CHANNEL2_BASE (EDMAMUX_BASE + 0x0004)
#define | EDMAMUX_CHANNEL3_BASE (EDMAMUX_BASE + 0x0008)
#define | EDMAMUX_CHANNEL4_BASE (EDMAMUX_BASE + 0x000C)
#define | EDMAMUX_CHANNEL5_BASE (EDMAMUX_BASE + 0x0010)
#define | EDMAMUX_CHANNEL6_BASE (EDMAMUX_BASE + 0x0014)
#define | EDMAMUX_CHANNEL7_BASE (EDMAMUX_BASE + 0x0018)
#define | EDMAMUX_CHANNEL8_BASE (EDMAMUX_BASE + 0x001C)
#define | EDMAMUX_GENERATOR1_BASE (EDMA_BASE + 0x0160)
#define | EDMAMUX_GENERATOR2_BASE (EDMA_BASE + 0x0164)
#define | EDMAMUX_GENERATOR3_BASE (EDMA_BASE + 0x0168)
#define | EDMAMUX_GENERATOR4_BASE (EDMA_BASE + 0x016C)
#define | FLASH_REG_BASE (AHBPERIPH1_BASE + 0x3C00)
#define | CRM_BASE (AHBPERIPH1_BASE + 0x3800)
#define | CRC_BASE (AHBPERIPH1_BASE + 0x3000)
#define | SDIO2_BASE (AHBPERIPH2_BASE + 0x61000)
#define | DVP_BASE (AHBPERIPH2_BASE + 0x50000)
#define | OTGFS1_BASE (AHBPERIPH2_BASE + 0x00000)

Typedefs

typedef enum IRQn | IRQn_Type
at32f435_437 interrupt number definition, according to the selected device in library_configuration_section More...
typedef int32_t | INT32
typedef int16_t | INT16
typedef int8_t | INT8
typedef uint32_t | UINT32
typedef uint16_t | UINT16
typedef uint8_t | UINT8
typedef int32_t | s32
typedef int16_t | s16
typedef int8_t | s8
typedef const int32_t | sc32
typedef const int16_t | sc16
typedef const int8_t | sc8
typedef __IO int32_t | vs32
typedef __IO int16_t | vs16
typedef __IO int8_t | vs8
typedef __I int32_t | vsc32
typedef __I int16_t | vsc16
typedef __I int8_t | vsc8
typedef uint32_t | u32
typedef uint16_t | u16
typedef uint8_t | u8
typedef const uint32_t | uc32
typedef const uint16_t | uc16
typedef const uint8_t | uc8
typedef __IO uint32_t | vu32
typedef __IO uint16_t | vu16
typedef __IO uint8_t | vu8
typedef __I uint32_t | vuc32
typedef __I uint16_t | vuc16
typedef __I uint8_t | vuc8

Enumerations

enum IRQn {
Reset_IRQn = -15 , NonMaskableInt_IRQn = -14 , HardFault_IRQn = -13 , MemoryManagement_IRQn = -12 ,
BusFault_IRQn = -11 , UsageFault_IRQn = -10 , SVCall_IRQn = -5 , DebugMonitor_IRQn = -4 ,
PendSV_IRQn = -2 , SysTick_IRQn = -1 , WWDT_IRQn = 0 , PVM_IRQn = 1 ,
TAMP_STAMP_IRQn = 2 , ERTC_WKUP_IRQn = 3 , FLASH_IRQn = 4 , CRM_IRQn = 5 ,
EXINT0_IRQn = 6 , EXINT1_IRQn = 7 , EXINT2_IRQn = 8 , EXINT3_IRQn = 9 ,
EXINT4_IRQn = 10 , EDMA_Stream1_IRQn = 11 , EDMA_Stream2_IRQn = 12 , EDMA_Stream3_IRQn = 13 ,
EDMA_Stream4_IRQn = 14 , EDMA_Stream5_IRQn = 15 , EDMA_Stream6_IRQn = 16 , EDMA_Stream7_IRQn = 17 ,
ADC1_2_3_IRQn = 18 , CAN1_TX_IRQn = 19 , CAN1_RX0_IRQn = 20 , CAN1_RX1_IRQn = 21 ,
CAN1_SE_IRQn = 22 , EXINT9_5_IRQn = 23 , TMR1_BRK_TMR9_IRQn = 24 , TMR1_OVF_TMR10_IRQn = 25 ,
TMR1_TRG_HALL_TMR11_IRQn = 26 , TMR1_CH_IRQn = 27 , TMR2_GLOBAL_IRQn = 28 , TMR3_GLOBAL_IRQn = 29 ,
TMR4_GLOBAL_IRQn = 30 , I2C1_EVT_IRQn = 31 , I2C1_ERR_IRQn = 32 , I2C2_EVT_IRQn = 33 ,
I2C2_ERR_IRQn = 34 , SPI1_IRQn = 35 , SPI2_I2S2EXT_IRQn = 36 , USART1_IRQn = 37 ,
USART2_IRQn = 38 , USART3_IRQn = 39 , EXINT15_10_IRQn = 40 , ERTCAlarm_IRQn = 41 ,
OTGFS1_WKUP_IRQn = 42 , TMR8_BRK_TMR12_IRQn = 43 , TMR8_OVF_TMR13_IRQn = 44 , TMR8_TRG_HALL_TMR14_IRQn = 45 ,
TMR8_CH_IRQn = 46 , EDMA_Stream8_IRQn = 47 , XMC_IRQn = 48 , SDIO1_IRQn = 49 ,
TMR5_GLOBAL_IRQn = 50 , SPI3_I2S3EXT_IRQn = 51 , UART4_IRQn = 52 , UART5_IRQn = 53 ,
TMR6_DAC_GLOBAL_IRQn = 54 , TMR7_GLOBAL_IRQn = 55 , DMA1_Channel1_IRQn = 56 , DMA1_Channel2_IRQn = 57 ,
DMA1_Channel3_IRQn = 58 , DMA1_Channel4_IRQn = 59 , DMA1_Channel5_IRQn = 60 , CAN2_TX_IRQn = 63 ,
CAN2_RX0_IRQn = 64 , CAN2_RX1_IRQn = 65 , CAN2_SE_IRQn = 66 , OTGFS1_IRQn = 67 ,
DMA1_Channel6_IRQn = 68 , DMA1_Channel7_IRQn = 69 , USART6_IRQn = 71 , I2C3_EVT_IRQn = 72 ,
I2C3_ERR_IRQn = 73 , OTGFS2_WKUP_IRQn = 76 , OTGFS2_IRQn = 77 , DVP_IRQn = 78 ,
FPU_IRQn = 81 , UART7_IRQn = 82 , UART8_IRQn = 83 , SPI4_IRQn = 84 ,
QSPI2_IRQn = 91 , QSPI1_IRQn = 92 , DMAMUX_IRQn = 94 , SDIO2_IRQn = 102 ,
ACC_IRQn = 103 , TMR20_BRK_IRQn = 104 , TMR20_OVF_IRQn = 105 , TMR20_TRG_HALL_IRQn = 106 ,
TMR20_CH_IRQn = 107 , DMA2_Channel1_IRQn = 108 , DMA2_Channel2_IRQn = 109 , DMA2_Channel3_IRQn = 110 ,
DMA2_Channel4_IRQn = 111 , DMA2_Channel5_IRQn = 112 , DMA2_Channel6_IRQn = 113 , DMA2_Channel7_IRQn = 114
}
at32f435_437 interrupt number definition, according to the selected device in library_configuration_section More...
enum | flag_status { RESET = 0 , SET = !RESET }
enum | confirm_state { FALSE = 0 , TRUE = !FALSE }
enum | error_status { ERROR = 0 , SUCCESS = !ERROR }

Detailed Description

at32f435_437 header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437.h.


AT32F435/437 Firmwary Library: system_at32f435_437.c File Reference

  • libraries
  • cmsis
  • cm4
  • device_support
Macros | Functions | Variables
system_at32f435_437.c File Reference

contains all the functions for cmsis cortex-m4 system source file More...

#include "at32f435_437.h"

Go to the source code of this file.

Macros

#define VECT_TAB_OFFSET 0x0

Functions

void | SystemInit (void)
setup the microcontroller system initialize the flash interface. More...
void | system_core_clock_update (void)
update system_core_clock variable according to clock register values. the system_core_clock variable contains the core clock (hclk), it can be used by the user application to setup the systick timer or configure other parameters. More...

Variables

unsigned int system_core_clock = ((uint32_t)8000000)

Detailed Description

contains all the functions for cmsis cortex-m4 system source file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file system_at32f435_437.c.


AT32F435/437 Firmwary Library: system_at32f435_437.h File Reference

  • libraries
  • cmsis
  • cm4
  • device_support
Macros | Functions | Variables
system_at32f435_437.h File Reference

cmsis cortex-m4 system header file. More...

Go to the source code of this file.

Macros

#define SystemCoreClock system_core_clock

Functions

void | SystemInit (void)
setup the microcontroller system initialize the flash interface. More...
void | system_core_clock_update (void)
update system_core_clock variable according to clock register values. the system_core_clock variable contains the core clock (hclk), it can be used by the user application to setup the systick timer or configure other parameters. More...

Variables

unsigned int system_core_clock

Detailed Description

cmsis cortex-m4 system header file.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file system_at32f435_437.h.


AT32F435/437 Firmwary Library: at32f435_437_acc.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Functions
at32f435_437_acc.h File Reference

at32f435_437 acc header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct acc_type
type define acc register all More...

Macros

#define | ACC_CAL_HICKCAL ((uint16_t)0x0000)
#define | ACC_CAL_HICKTRIM ((uint16_t)0x0002)
#define | ACC_RSLOST_FLAG ((uint16_t)0x0002)
#define | ACC_CALRDY_FLAG ((uint16_t)0x0001)
#define | ACC_CALRDYIEN_INT ((uint16_t)0x0020)
#define | ACC_EIEN_INT ((uint16_t)0x0010)
#define | ACC_SOF_OTG1 ((uint16_t)0x0000)
#define | ACC_SOF_OTG2 ((uint16_t)0x0004)
#define | ACC ((acc_type *) ACC_BASE)

Functions

void | acc_calibration_mode_enable (uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode. More...
void | acc_step_set (uint8_t step_value)
store calibration step data in acc's ctrl1 register. More...
void | acc_sof_select (uint16_t sof_sel)
select sof sourse for acc in acc's ctrl1 register. More...
void | acc_interrupt_enable (uint16_t acc_int, confirm_state new_state)
enable or disable the specified acc interrupts. More...
uint8_t | acc_hicktrim_get (void)
return the current acc hicktrim value. More...
uint8_t | acc_hickcal_get (void)
return the current acc hickcal value. More...
void | acc_write_c1 (uint16_t acc_c1_value)
wtire the value to acc c1 register. More...
void | acc_write_c2 (uint16_t acc_c2_value)
wtire the value to acc c2 register. More...
void | acc_write_c3 (uint16_t acc_c3_value)
wtire the value to acc c3 register. More...
uint16_t | acc_read_c1 (void)
return the current acc c1 value. More...
uint16_t | acc_read_c2 (void)
return the current acc c2 value. More...
uint16_t | acc_read_c3 (void)
return the current acc c3 value. More...
flag_status | acc_flag_get (uint16_t acc_flag)
check whether the specified acc flag is set or not. More...
void | acc_flag_clear (uint16_t acc_flag)
clear the specified acc flag is set or not. More...

Detailed Description

at32f435_437 acc header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_acc.h.


AT32F435/437 Firmwary Library: at32f435_437_adc.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f435_437_adc.h File Reference

at32f435_437 adc header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct | adc_common_config_type
adc common config type More...
struct | adc_base_config_type
adc base config type More...
struct | adc_type
type define adc register all More...
struct | adccom_type
type define adc register all More...

Macros

#define | ADC_OCCE_INT ((uint32_t)0x00000020)
#define | ADC_VMOR_INT ((uint32_t)0x00000040)
#define | ADC_PCCE_INT ((uint32_t)0x00000080)
#define | ADC_OCCO_INT ((uint32_t)0x04000000)
#define | ADC_VMOR_FLAG ((uint8_t)0x01)
#define | ADC_OCCE_FLAG ((uint8_t)0x02)
#define | ADC_PCCE_FLAG ((uint8_t)0x04)
#define | ADC_PCCS_FLAG ((uint8_t)0x08)
#define | ADC_OCCS_FLAG ((uint8_t)0x10)
#define | ADC_OCCO_FLAG ((uint8_t)0x20)
#define | ADC_RDY_FLAG ((uint8_t)0x40)
#define | ADC1 ((adc_type *) ADC1_BASE)
#define | ADC2 ((adc_type *) ADC2_BASE)
#define | ADC3 ((adc_type *) ADC3_BASE)
#define | ADCCOM ((adccom_type *) ADCCOM_BASE)

Enumerations

enum adc_div_type {
ADC_HCLK_DIV_2 = 0x00 , ADC_HCLK_DIV_3 = 0x01 , ADC_HCLK_DIV_4 = 0x02 , ADC_HCLK_DIV_5 = 0x03 ,
ADC_HCLK_DIV_6 = 0x04 , ADC_HCLK_DIV_7 = 0x05 , ADC_HCLK_DIV_8 = 0x06 , ADC_HCLK_DIV_9 = 0x07 ,
ADC_HCLK_DIV_10 = 0x08 , ADC_HCLK_DIV_11 = 0x09 , ADC_HCLK_DIV_12 = 0x0A , ADC_HCLK_DIV_13 = 0x0B ,
ADC_HCLK_DIV_14 = 0x0C , ADC_HCLK_DIV_15 = 0x0D , ADC_HCLK_DIV_16 = 0x0E , ADC_HCLK_DIV_17 = 0x0F
}
adc division type More...
enum adc_combine_mode_type {
ADC_INDEPENDENT_MODE = 0x00 , ADC_ORDINARY_SMLT_PREEMPT_SMLT_ONESLAVE_MODE = 0x01 , ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_ONESLAVE_MODE = 0x02 , ADC_PREEMPT_SMLT_ONLY_ONESLAVE_MODE = 0x05 ,
ADC_ORDINARY_SMLT_ONLY_ONESLAVE_MODE = 0x06 , ADC_ORDINARY_SHIFT_ONLY_ONESLAVE_MODE = 0x07 , ADC_PREEMPT_INTERLTRIG_ONLY_ONESLAVE_MODE = 0x09 , ADC_ORDINARY_SMLT_PREEMPT_SMLT_TWOSLAVE_MODE = 0x11 ,
ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_TWOSLAVE_MODE = 0x12 , ADC_PREEMPT_SMLT_ONLY_TWOSLAVE_MODE = 0x15 , ADC_ORDINARY_SMLT_ONLY_TWOSLAVE_MODE = 0x16 , ADC_ORDINARY_SHIFT_ONLY_TWOSLAVE_MODE = 0x17 ,
ADC_PREEMPT_INTERLTRIG_ONLY_TWOSLAVE_MODE = 0x19
}
adc combine mode type More...
enum adc_common_dma_mode_type {
ADC_COMMON_DMAMODE_DISABLE = 0x00 , ADC_COMMON_DMAMODE_1 = 0x01 , ADC_COMMON_DMAMODE_2 = 0x02 , ADC_COMMON_DMAMODE_3 = 0x03 ,
ADC_COMMON_DMAMODE_4 = 0x04 , ADC_COMMON_DMAMODE_5 = 0x05
}
adc common dma mode type More...
enum adc_sampling_interval_type {
ADC_SAMPLING_INTERVAL_5CYCLES = 0x00 , ADC_SAMPLING_INTERVAL_6CYCLES = 0x01 , ADC_SAMPLING_INTERVAL_7CYCLES = 0x02 , ADC_SAMPLING_INTERVAL_8CYCLES = 0x03 ,
ADC_SAMPLING_INTERVAL_9CYCLES = 0x04 , ADC_SAMPLING_INTERVAL_10CYCLES = 0x05 , ADC_SAMPLING_INTERVAL_11CYCLES = 0x06 , ADC_SAMPLING_INTERVAL_12CYCLES = 0x07 ,
ADC_SAMPLING_INTERVAL_13CYCLES = 0x08 , ADC_SAMPLING_INTERVAL_14CYCLES = 0x09 , ADC_SAMPLING_INTERVAL_15CYCLES = 0x0A , ADC_SAMPLING_INTERVAL_16CYCLES = 0x0B ,
ADC_SAMPLING_INTERVAL_17CYCLES = 0x0C , ADC_SAMPLING_INTERVAL_18CYCLES = 0x0D , ADC_SAMPLING_INTERVAL_19CYCLES = 0x0E , ADC_SAMPLING_INTERVAL_20CYCLES = 0x0F
}
adc common sampling interval type More...
enum | adc_resolution_type { ADC_RESOLUTION_12B = 0x00 , ADC_RESOLUTION_10B = 0x01 , ADC_RESOLUTION_8B = 0x02 , ADC_RESOLUTION_6B = 0x03 }
adc conversion resolution type More...
enum | adc_data_align_type { ADC_RIGHT_ALIGNMENT = 0x00 , ADC_LEFT_ALIGNMENT = 0x01 }
adc data align type More...
enum adc_channel_select_type {
ADC_CHANNEL_0 = 0x00 , ADC_CHANNEL_1 = 0x01 , ADC_CHANNEL_2 = 0x02 , ADC_CHANNEL_3 = 0x03 ,
ADC_CHANNEL_4 = 0x04 , ADC_CHANNEL_5 = 0x05 , ADC_CHANNEL_6 = 0x06 , ADC_CHANNEL_7 = 0x07 ,
ADC_CHANNEL_8 = 0x08 , ADC_CHANNEL_9 = 0x09 , ADC_CHANNEL_10 = 0x0A , ADC_CHANNEL_11 = 0x0B ,
ADC_CHANNEL_12 = 0x0C , ADC_CHANNEL_13 = 0x0D , ADC_CHANNEL_14 = 0x0E , ADC_CHANNEL_15 = 0x0F ,
ADC_CHANNEL_16 = 0x10 , ADC_CHANNEL_17 = 0x11 , ADC_CHANNEL_18 = 0x12
}
adc channel select type More...
enum adc_sampletime_select_type {
ADC_SAMPLETIME_2_5 = 0x00 , ADC_SAMPLETIME_6_5 = 0x01 , ADC_SAMPLETIME_12_5 = 0x02 , ADC_SAMPLETIME_24_5 = 0x03 ,
ADC_SAMPLETIME_47_5 = 0x04 , ADC_SAMPLETIME_92_5 = 0x05 , ADC_SAMPLETIME_247_5 = 0x06 , ADC_SAMPLETIME_640_5 = 0x07
}
adc sampletime select type More...
enum adc_ordinary_trig_select_type {
ADC_ORDINARY_TRIG_TMR1CH1 = 0x00 , ADC_ORDINARY_TRIG_TMR1CH2 = 0x01 , ADC_ORDINARY_TRIG_TMR1CH3 = 0x02 , ADC_ORDINARY_TRIG_TMR2CH2 = 0x03 ,
ADC_ORDINARY_TRIG_TMR2CH3 = 0x04 , ADC_ORDINARY_TRIG_TMR2CH4 = 0x05 , ADC_ORDINARY_TRIG_TMR2TRGOUT = 0x06 , ADC_ORDINARY_TRIG_TMR3CH1 = 0x07 ,
ADC_ORDINARY_TRIG_TMR3TRGOUT = 0x08 , ADC_ORDINARY_TRIG_TMR4CH4 = 0x09 , ADC_ORDINARY_TRIG_TMR5CH1 = 0x0A , ADC_ORDINARY_TRIG_TMR5CH2 = 0x0B ,
ADC_ORDINARY_TRIG_TMR5CH3 = 0x0C , ADC_ORDINARY_TRIG_TMR8CH1 = 0x0D , ADC_ORDINARY_TRIG_TMR8TRGOUT = 0x0E , ADC_ORDINARY_TRIG_EXINT11 = 0x0F ,
ADC_ORDINARY_TRIG_TMR20TRGOUT = 0x10 , ADC_ORDINARY_TRIG_TMR20TRGOUT2 = 0x11 , ADC_ORDINARY_TRIG_TMR20CH1 = 0x12 , ADC_ORDINARY_TRIG_TMR20CH2 = 0x13 ,
ADC_ORDINARY_TRIG_TMR20CH3 = 0x14 , ADC_ORDINARY_TRIG_TMR8TRGOUT2 = 0x15 , ADC_ORDINARY_TRIG_TMR1TRGOUT2 = 0x16 , ADC_ORDINARY_TRIG_TMR4TRGOUT = 0x17 ,
ADC_ORDINARY_TRIG_TMR6TRGOUT = 0x18 , ADC_ORDINARY_TRIG_TMR3CH4 = 0x19 , ADC_ORDINARY_TRIG_TMR4CH1 = 0x1A , ADC_ORDINARY_TRIG_TMR1TRGOUT = 0x1B ,
ADC_ORDINARY_TRIG_TMR2CH1 = 0x1C , ADC_ORDINARY_TRIG_TMR7TRGOUT = 0x1E
}
adc ordinary group trigger event select type More...
enum | adc_ordinary_trig_edge_type { ADC_ORDINARY_TRIG_EDGE_NONE = 0x00 , ADC_ORDINARY_TRIG_EDGE_RISING = 0x01 , ADC_ORDINARY_TRIG_EDGE_FALLING = 0x02 , ADC_ORDINARY_TRIG_EDGE_RISING_FALLING = 0x03 }
adc ordinary channel conversion's external_trigger_edge type More...
enum adc_preempt_trig_select_type {
ADC_PREEMPT_TRIG_TMR1CH4 = 0x00 , ADC_PREEMPT_TRIG_TMR1TRGOUT = 0x01 , ADC_PREEMPT_TRIG_TMR2CH1 = 0x02 , ADC_PREEMPT_TRIG_TMR2TRGOUT = 0x03 ,
ADC_PREEMPT_TRIG_TMR3CH2 = 0x04 , ADC_PREEMPT_TRIG_TMR3CH4 = 0x05 , ADC_PREEMPT_TRIG_TMR4CH1 = 0x06 , ADC_PREEMPT_TRIG_TMR4CH2 = 0x07 ,
ADC_PREEMPT_TRIG_TMR4CH3 = 0x08 , ADC_PREEMPT_TRIG_TMR4TRGOUT = 0x09 , ADC_PREEMPT_TRIG_TMR5CH4 = 0x0A , ADC_PREEMPT_TRIG_TMR5TRGOUT = 0x0B ,
ADC_PREEMPT_TRIG_TMR8CH2 = 0x0C , ADC_PREEMPT_TRIG_TMR8CH3 = 0x0D , ADC_PREEMPT_TRIG_TMR8CH4 = 0x0E , ADC_PREEMPT_TRIG_EXINT15 = 0x0F ,
ADC_PREEMPT_TRIG_TMR20TRGOUT = 0x10 , ADC_PREEMPT_TRIG_TMR20TRGOUT2 = 0x11 , ADC_PREEMPT_TRIG_TMR20CH4 = 0x12 , ADC_PREEMPT_TRIG_TMR1TRGOUT2 = 0x13 ,
ADC_PREEMPT_TRIG_TMR8TRGOUT = 0x14 , ADC_PREEMPT_TRIG_TMR8TRGOUT2 = 0x15 , ADC_PREEMPT_TRIG_TMR3CH3 = 0x16 , ADC_PREEMPT_TRIG_TMR3TRGOUT = 0x17 ,
ADC_PREEMPT_TRIG_TMR3CH1 = 0x18 , ADC_PREEMPT_TRIG_TMR6TRGOUT = 0x19 , ADC_PREEMPT_TRIG_TMR4CH4 = 0x1A , ADC_PREEMPT_TRIG_TMR1CH3 = 0x1B ,
ADC_PREEMPT_TRIG_TMR20CH2 = 0x1C , ADC_PREEMPT_TRIG_TMR7TRGOUT = 0x1E
}
adc preempt group external trigger event select type More...
enum | adc_preempt_trig_edge_type { ADC_PREEMPT_TRIG_EDGE_NONE = 0x00 , ADC_PREEMPT_TRIG_EDGE_RISING = 0x01 , ADC_PREEMPT_TRIG_EDGE_FALLING = 0x02 , ADC_PREEMPT_TRIG_EDGE_RISING_FALLING = 0x03 }
adc preempt channel conversion's external_trigger_edge type More...
enum | adc_preempt_channel_type { ADC_PREEMPT_CHANNEL_1 = 0x00 , ADC_PREEMPT_CHANNEL_2 = 0x01 , ADC_PREEMPT_CHANNEL_3 = 0x02 , ADC_PREEMPT_CHANNEL_4 = 0x03 }
adc preempt channel type More...
enum adc_voltage_monitoring_type {
ADC_VMONITOR_SINGLE_ORDINARY = 0x00800200 , ADC_VMONITOR_SINGLE_PREEMPT = 0x00400200 , ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT = 0x00C00200 , ADC_VMONITOR_ALL_ORDINARY = 0x00800000 ,
ADC_VMONITOR_ALL_PREEMPT = 0x00400000 , ADC_VMONITOR_ALL_ORDINARY_PREEMPT = 0x00C00000 , ADC_VMONITOR_NONE = 0x00000000
}
adc voltage_monitoring type More...
enum adc_oversample_ratio_type {
ADC_OVERSAMPLE_RATIO_2 = 0x00 , ADC_OVERSAMPLE_RATIO_4 = 0x01 , ADC_OVERSAMPLE_RATIO_8 = 0x02 , ADC_OVERSAMPLE_RATIO_16 = 0x03 ,
ADC_OVERSAMPLE_RATIO_32 = 0x04 , ADC_OVERSAMPLE_RATIO_64 = 0x05 , ADC_OVERSAMPLE_RATIO_128 = 0x06 , ADC_OVERSAMPLE_RATIO_256 = 0x07
}
adc oversample ratio type More...
enum adc_oversample_shift_type {
ADC_OVERSAMPLE_SHIFT_0 = 0x00 , ADC_OVERSAMPLE_SHIFT_1 = 0x01 , ADC_OVERSAMPLE_SHIFT_2 = 0x02 , ADC_OVERSAMPLE_SHIFT_3 = 0x03 ,
ADC_OVERSAMPLE_SHIFT_4 = 0x04 , ADC_OVERSAMPLE_SHIFT_5 = 0x05 , ADC_OVERSAMPLE_SHIFT_6 = 0x06 , ADC_OVERSAMPLE_SHIFT_7 = 0x07 ,
ADC_OVERSAMPLE_SHIFT_8 = 0x08
}
adc oversample shift type More...
enum | adc_ordinary_oversample_restart_type { ADC_OVERSAMPLE_CONTINUE = 0x00 , ADC_OVERSAMPLE_RESTART = 0x01 }
adc ordinary oversample recover type More...

Functions

void | adc_reset (void)
deinitialize the adc peripheral registers to their default reset values. More...
void | adc_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral. More...
void | adc_base_default_para_init (adc_base_config_type *adc_base_struct)
adc base default para init. More...
void | adc_base_config (adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters. More...
void | adc_common_default_para_init (adc_common_config_type *adc_common_struct)
adc common default para init. More...
void | adc_common_config (adc_common_config_type *adc_common_struct)
adc common default para init. More...
void | adc_resolution_set (adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral. More...
void | adc_voltage_battery_enable (confirm_state new_state)
enable or disable the adc voltage battery. More...
void | adc_dma_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer. More...
void | adc_dma_request_repeat_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat. More...
void | adc_interrupt_enable (adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts. More...
void | adc_calibration_value_set (adc_type *adc_x, uint8_t adc_calibration_value)
set calibration value of the specified adc peripheral. More...
void | adc_calibration_init (adc_type *adc_x)
initialize calibration register of the specified adc peripheral. More...
flag_status | adc_calibration_init_status_get (adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral. More...
void | adc_calibration_start (adc_type *adc_x)
start calibration process of the specified adc peripheral. More...
flag_status | adc_calibration_status_get (adc_type *adc_x)
get calibration status of the specified adc peripheral. More...
void | adc_voltage_monitor_enable (adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring)
enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified adc peripheral. More...
void | adc_voltage_monitor_threshold_value_set (adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold)
set voltage monitoring's high and low thresholds value of the specified adc peripheral. More...
void | adc_voltage_monitor_single_channel_select (adc_type *adc_x, adc_channel_select_type adc_channel)
select the voltage monitoring's channel of the specified adc peripheral. More...
void | adc_ordinary_channel_set (adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc peripheral. More...
void | adc_preempt_channel_length_set (adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral. More...
void | adc_preempt_channel_set (adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc peripheral. More...
void | adc_ordinary_conversion_trigger_set (adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc peripheral. More...
void | adc_preempt_conversion_trigger_set (adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, adc_preempt_trig_edge_type adc_preempt_trig_edge)
enable or disable the preempt channel's external trigger and set external trigger event of the specified adc peripheral. More...
void | adc_preempt_offset_value_set (adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel, uint16_t adc_offset_value)
set preempt channel's conversion value offset of the specified adc peripheral. More...
void | adc_ordinary_part_count_set (adc_type *adc_x, uint8_t adc_channel_count)
set partitioned mode channel count of the specified adc peripheral. More...
void | adc_ordinary_part_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on ordinary channel of the specified adc peripheral. More...
void | adc_preempt_part_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on preempt channel of the specified adc peripheral. More...
void | adc_preempt_auto_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable automatic preempt group conversion of the specified adc peripheral. More...
void | adc_conversion_stop (adc_type *adc_x)
stop the ongoing conversion of the specified adc peripheral. More...
flag_status | adc_conversion_stop_status_get (adc_type *adc_x)
get stop conversion's status of the specified adc peripheral. More...
void | adc_occe_each_conversion_enable (adc_type *adc_x, confirm_state new_state)
enable or disable each ordinary channel conversion set occe flag of the specified adc peripheral. More...
void | adc_ordinary_software_trigger_enable (adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral. More...
flag_status | adc_ordinary_software_trigger_status_get (adc_type *adc_x)
get ordinary software start conversion status of the specified adc peripheral. More...
void | adc_preempt_software_trigger_enable (adc_type *adc_x, confirm_state new_state)
enable or disable preempt software start conversion of the specified adc peripheral. More...
flag_status | adc_preempt_software_trigger_status_get (adc_type *adc_x)
get preempt software start conversion status of the specified adc peripheral. More...
uint16_t | adc_ordinary_conversion_data_get (adc_type *adc_x)
return the last conversion data for ordinary channel of the specified adc peripheral. More...
uint32_t | adc_combine_ordinary_conversion_data_get (void)
return the last ordinary conversion data of combine adc. More...
uint16_t | adc_preempt_conversion_data_get (adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral. More...
flag_status | adc_flag_get (adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral. More...
void | adc_flag_clear (adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral. More...
void | adc_ordinary_oversample_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the ordinary oversampling of the specified adc peripheral. More...
void | adc_preempt_oversample_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the preempt oversampling of the specified adc peripheral. More...
void | adc_oversample_ratio_shift_set (adc_type *adc_x, adc_oversample_ratio_type adc_oversample_ratio, adc_oversample_shift_type adc_oversample_shift)
config the oversampling ratio and shift of the specified adc peripheral. More...
void | adc_ordinary_oversample_trig_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the ordinary oversampling trigger mode of the specified adc peripheral. More...
void | adc_ordinary_oversample_restart_set (adc_type *adc_x, adc_ordinary_oversample_restart_type adc_ordinary_oversample_restart)
set ordinary oversample restart mode of the specified adc peripheral. More...

Detailed Description

at32f435_437 adc header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_adc.h.


AT32F435/437 Firmwary Library: at32f435_437_can.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f435_437_can.h File Reference

at32f435_437 can header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct | can_base_type
can init structure definition More...
struct | can_baudrate_type
can baudrate structure definition More...
struct | can_filter_init_type
can filter init structure definition More...
struct | can_tx_message_type
can tx message structure definition More...
struct | can_rx_message_type
can rx message structure definition More...
struct | can_tx_mailbox_type
can controller area network tx mailbox More...
struct | can_fifo_mailbox_type
can controller area network fifo mailbox More...
struct | can_filter_register_type
can controller area network filter bit register More...
struct | can_type
type define can register all More...

Macros

#define | FZC_TIMEOUT ((uint32_t)0x0000FFFF)
#define | DZC_TIMEOUT ((uint32_t)0x0000FFFF)
#define | CAN_EAF_FLAG ((uint32_t)0x01)
#define | CAN_EPF_FLAG ((uint32_t)0x02)
#define | CAN_BOF_FLAG ((uint32_t)0x03)
#define | CAN_ETR_FLAG ((uint32_t)0x04)
#define | CAN_EOIF_FLAG ((uint32_t)0x05)
#define | CAN_TM0TCF_FLAG ((uint32_t)0x06)
#define | CAN_TM1TCF_FLAG ((uint32_t)0x07)
#define | CAN_TM2TCF_FLAG ((uint32_t)0x08)
#define | CAN_RF0MN_FLAG ((uint32_t)0x09)
#define | CAN_RF0FF_FLAG ((uint32_t)0x0A)
#define | CAN_RF0OF_FLAG ((uint32_t)0x0B)
#define | CAN_RF1MN_FLAG ((uint32_t)0x0C)
#define | CAN_RF1FF_FLAG ((uint32_t)0x0D)
#define | CAN_RF1OF_FLAG ((uint32_t)0x0E)
#define | CAN_QDZIF_FLAG ((uint32_t)0x0F)
#define | CAN_EDZC_FLAG ((uint32_t)0x10)
#define | CAN_TMEF_FLAG ((uint32_t)0x11)
#define | CAN_TCIEN_INT ((uint32_t)0x00000001)
#define | CAN_RF0MIEN_INT ((uint32_t)0x00000002)
#define | CAN_RF0FIEN_INT ((uint32_t)0x00000004)
#define | CAN_RF0OIEN_INT ((uint32_t)0x00000008)
#define | CAN_RF1MIEN_INT ((uint32_t)0x00000010)
#define | CAN_RF1FIEN_INT ((uint32_t)0x00000020)
#define | CAN_RF1OIEN_INT ((uint32_t)0x00000040)
#define | CAN_EAIEN_INT ((uint32_t)0x00000100)
#define | CAN_EPIEN_INT ((uint32_t)0x00000200)
#define | CAN_BOIEN_INT ((uint32_t)0x00000400)
#define | CAN_ETRIEN_INT ((uint32_t)0x00000800)
#define | CAN_EOIEN_INT ((uint32_t)0x00008000)
#define | CAN_QDZIEN_INT ((uint32_t)0x00010000)
#define | CAN_EDZIEN_INT ((uint32_t)0x00020000)
#define | CAN_MSTS_EOIF_VAL ((uint32_t)0x00000004)
can flag clear operation macro definition val More...
#define | CAN_MSTS_QDZIF_VAL ((uint32_t)0x00000008)
#define | CAN_MSTS_EDZIF_VAL ((uint32_t)0x00000010)
#define | CAN_TSTS_TM0TCF_VAL ((uint32_t)0x00000001)
#define | CAN_TSTS_TM1TCF_VAL ((uint32_t)0x00000100)
#define | CAN_TSTS_TM2TCF_VAL ((uint32_t)0x00010000)
#define | CAN_TSTS_TM0CT_VAL ((uint32_t)0x00000080)
#define | CAN_TSTS_TM1CT_VAL ((uint32_t)0x00008000)
#define | CAN_TSTS_TM2CT_VAL ((uint32_t)0x00800000)
#define | CAN_RF0_RF0FF_VAL ((uint32_t)0x00000008)
#define | CAN_RF0_RF0OF_VAL ((uint32_t)0x00000010)
#define | CAN_RF0_RF0R_VAL ((uint32_t)0x00000020)
#define | CAN_RF1_RF1FF_VAL ((uint32_t)0x00000008)
#define | CAN_RF1_RF1OF_VAL ((uint32_t)0x00000010)
#define | CAN_RF1_RF1R_VAL ((uint32_t)0x00000020)
#define | CAN1 ((can_type *) CAN1_BASE)
#define | CAN2 ((can_type *) CAN2_BASE)

Enumerations

enum | can_filter_fifo_type { CAN_FILTER_FIFO0 = 0x00 , CAN_FILTER_FIFO1 = 0x01 }
can filter fifo More...
enum | can_filter_mode_type { CAN_FILTER_MODE_ID_MASK = 0x00 , CAN_FILTER_MODE_ID_LIST = 0x01 }
can filter mode More...
enum | can_filter_bit_width_type { CAN_FILTER_16BIT = 0x00 , CAN_FILTER_32BIT = 0x01 }
can filter bit width select More...
enum | can_mode_type { CAN_MODE_COMMUNICATE = 0x00 , CAN_MODE_LOOPBACK = 0x01 , CAN_MODE_LISTENONLY = 0x02 , CAN_MODE_LISTENONLY_LOOPBACK = 0x03 }
can mode More...
enum | can_operating_mode_type { CAN_OPERATINGMODE_FREEZE = 0x00 , CAN_OPERATINGMODE_DOZE = 0x01 , CAN_OPERATINGMODE_COMMUNICATE = 0x02 }
can operating mode More...
enum | can_rsaw_type { CAN_RSAW_1TQ = 0x00 , CAN_RSAW_2TQ = 0x01 , CAN_RSAW_3TQ = 0x02 , CAN_RSAW_4TQ = 0x03 }
can resynchronization adjust width More...
enum can_bts1_type {
CAN_BTS1_1TQ = 0x00 , CAN_BTS1_2TQ = 0x01 , CAN_BTS1_3TQ = 0x02 , CAN_BTS1_4TQ = 0x03 ,
CAN_BTS1_5TQ = 0x04 , CAN_BTS1_6TQ = 0x05 , CAN_BTS1_7TQ = 0x06 , CAN_BTS1_8TQ = 0x07 ,
CAN_BTS1_9TQ = 0x08 , CAN_BTS1_10TQ = 0x09 , CAN_BTS1_11TQ = 0x0A , CAN_BTS1_12TQ = 0x0B ,
CAN_BTS1_13TQ = 0x0C , CAN_BTS1_14TQ = 0x0D , CAN_BTS1_15TQ = 0x0E , CAN_BTS1_16TQ = 0x0F
}
can bit time segment 1 More...
enum can_bts2_type {
CAN_BTS2_1TQ = 0x00 , CAN_BTS2_2TQ = 0x01 , CAN_BTS2_3TQ = 0x02 , CAN_BTS2_4TQ = 0x03 ,
CAN_BTS2_5TQ = 0x04 , CAN_BTS2_6TQ = 0x05 , CAN_BTS2_7TQ = 0x06 , CAN_BTS2_8TQ = 0x07
}
can bit time segment 2 More...
enum | can_identifier_type { CAN_ID_STANDARD = 0x00 , CAN_ID_EXTENDED = 0x01 }
can identifier type More...
enum | can_trans_frame_type { CAN_TFT_DATA = 0x00 , CAN_TFT_REMOTE = 0x01 }
can transmission frame type More...
enum | can_tx_mailbox_num_type { CAN_TX_MAILBOX0 = 0x00 , CAN_TX_MAILBOX1 = 0x01 , CAN_TX_MAILBOX2 = 0x02 }
can tx mailboxes More...
enum | can_rx_fifo_num_type { CAN_RX_FIFO0 = 0x00 , CAN_RX_FIFO1 = 0x01 }
can receive fifo More...
enum | can_transmit_status_type { CAN_TX_STATUS_FAILED = 0x00 , CAN_TX_STATUS_SUCCESSFUL = 0x01 , CAN_TX_STATUS_PENDING = 0x02 , CAN_TX_STATUS_NO_EMPTY = 0x04 }
can transmit status More...
enum | can_enter_doze_status_type { CAN_ENTER_DOZE_FAILED = 0x00 , CAN_ENTER_DOZE_SUCCESSFUL = 0x01 }
can enter doze mode status More...
enum | can_quit_doze_status_type { CAN_QUIT_DOZE_FAILED = 0x00 , CAN_QUIT_DOZE_SUCCESSFUL = 0x01 }
can quit doze mode status More...
enum | can_msg_discarding_rule_type { CAN_DISCARDING_FIRST_RECEIVED = 0x00 , CAN_DISCARDING_LAST_RECEIVED = 0x01 }
can message discarding rule select when overflow More...
enum | can_msg_sending_rule_type { CAN_SENDING_BY_ID = 0x00 , CAN_SENDING_BY_REQUEST = 0x01 }
can multiple message sending sequence rule More...
enum can_error_record_type {
CAN_ERRORRECORD_NOERR = 0x00 , CAN_ERRORRECORD_STUFFERR = 0x01 , CAN_ERRORRECORD_FORMERR = 0x02 , CAN_ERRORRECORD_ACKERR = 0x03 ,
CAN_ERRORRECORD_BITRECESSIVEERR = 0x04 , CAN_ERRORRECORD_BITDOMINANTERR = 0x05 , CAN_ERRORRECORD_CRCERR = 0x06 , CAN_ERRORRECORD_SOFTWARESETERR = 0x07
}
can error type record More...

Functions

void | can_reset (can_type *can_x)
deinitialize the can peripheral registers to their default reset values. More...
void | can_baudrate_default_para_init (can_baudrate_type *can_baudrate_struct)
fill each can_baudrate_struct member with its default value. More...
error_status | can_baudrate_set (can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral More...
void | can_default_para_init (can_base_type *can_base_struct)
fill each can_init_struct member with its default value. More...
error_status | can_base_init (can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct. More...
void | can_filter_default_para_init (can_filter_init_type *can_filter_init_struct)
fill each can_filter_init_struct member with its default value. More...
void | can_filter_init (can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct. More...
void | can_debug_transmission_prohibit (can_type *can_x, confirm_state new_state)
enable or disable the debug transmission prohibit of the specified can peripheral. More...
void | can_ttc_mode_enable (can_type *can_x, confirm_state new_state)
enable or disable time trigger operation communication mode of the specified can peripheral. More...
uint8_t | can_message_transmit (can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral. More...
can_transmit_status_type | can_transmit_status_get (can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral. More...
void | can_transmit_cancel (can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
cancel a transmit request of the specified can peripheral. More...
void | can_message_receive (can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral. More...
void | can_receive_fifo_release (can_type *can_x, can_rx_fifo_num_type fifo_number)
release the specified fifo of the specified can peripheral. More...
uint8_t | can_receive_message_pending_get (can_type *can_x, can_rx_fifo_num_type fifo_number)
return the number of pending messages of the specified can peripheral. More...
error_status | can_operating_mode_set (can_type *can_x, can_operating_mode_type can_operating_mode)
set the operation mode of the specified can peripheral. More...
can_enter_doze_status_type | can_doze_mode_enter (can_type *can_x)
enter the low power mode of the specified can peripheral. More...
can_quit_doze_status_type | can_doze_mode_exit (can_type *can_x)
exit the doze mode of the specified can peripheral. More...
can_error_record_type | can_error_type_record_get (can_type *can_x)
return the error type record (etr) of the specified can peripheral. More...
uint8_t | can_receive_error_counter_get (can_type *can_x)
return the receive error counter (rec) of the specified can peripheral. More...
uint8_t | can_transmit_error_counter_get (can_type *can_x)
return the transmit error counter of the specified can peripheral. More...
void | can_interrupt_enable (can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral. More...
flag_status | can_flag_get (can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral. More...
void | can_flag_clear (can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral. More...

Detailed Description

at32f435_437 can header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_can.h.


AT32F435/437 Firmwary Library: at32f435_437_crc.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f435_437_crc.h File Reference

at32f435_437 crc header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct crc_type
type define crc register all More...

Macros

#define CRC ((crc_type *) CRC_BASE)

Enumerations

enum | crc_reverse_input_type { CRC_REVERSE_INPUT_NO_AFFECTE = 0x00 , CRC_REVERSE_INPUT_BY_BYTE = 0x01 , CRC_REVERSE_INPUT_BY_HALFWORD = 0x02 , CRC_REVERSE_INPUT_BY_WORD = 0x03 }
crc reverse input data More...
enum | crc_reverse_output_type { CRC_REVERSE_OUTPUT_NO_AFFECTE = 0x00 , CRC_REVERSE_OUTPUT_DATA = 0x01 }
crc reverse output data More...

Functions

void | crc_data_reset (void)
reset the crc data register. More...
uint32_t | crc_one_word_calculate (uint32_t data)
compute the 32-bit crc of a given data word(32-bit). More...
uint32_t | crc_block_calculate (uint32_t *pbuffer, uint32_t length)
compute the 32-bit crc of a given buffer of data word(32-bit). More...
uint32_t | crc_data_get (void)
return the current crc value. More...
void | crc_common_data_set (uint8_t cdt_value)
store a 8-bit data in the common data register. More...
uint8_t | crc_common_date_get (void)
return the 8-bit data stored in the common data register More...
void | crc_init_data_set (uint32_t value)
set the 32-bit initial data of crc More...
void | crc_reverse_input_data_set (crc_reverse_input_type value)
control the reversal of the bit order in the input data More...
void | crc_reverse_output_data_set (crc_reverse_output_type value)
control the reversal of the bit order in the output data More...

Detailed Description

at32f435_437 crc header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_crc.h.


AT32F435/437 Firmwary Library: at32f435_437_crm.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f435_437_crm.h File Reference

at32f435_437 crm header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct | crm_clocks_freq_type
crm clocks freqency structure More...
struct | crm_type
type define crm register all More...

Macros

#define | CRM_REG(value) PERIPH_REG(CRM_BASE, value)
#define | CRM_REG_BIT(value) PERIPH_REG_BIT(value)
#define | CRM_HICK_STABLE_FLAG MAKE_VALUE(0x00, 1)
#define | CRM_HEXT_STABLE_FLAG MAKE_VALUE(0x00, 17)
#define | CRM_PLL_STABLE_FLAG MAKE_VALUE(0x00, 25)
#define | CRM_LEXT_STABLE_FLAG MAKE_VALUE(0x70, 1)
#define | CRM_LICK_STABLE_FLAG MAKE_VALUE(0x74, 1)
#define | CRM_ALL_RESET_FLAG MAKE_VALUE(0x74, 24)
#define | CRM_NRST_RESET_FLAG MAKE_VALUE(0x74, 26)
#define | CRM_POR_RESET_FLAG MAKE_VALUE(0x74, 27)
#define | CRM_SW_RESET_FLAG MAKE_VALUE(0x74, 28)
#define | CRM_WDT_RESET_FLAG MAKE_VALUE(0x74, 29)
#define | CRM_WWDT_RESET_FLAG MAKE_VALUE(0x74, 30)
#define | CRM_LOWPOWER_RESET_FLAG MAKE_VALUE(0x74, 31)
#define | CRM_LICK_READY_INT_FLAG MAKE_VALUE(0x0C, 0)
#define | CRM_LEXT_READY_INT_FLAG MAKE_VALUE(0x0C, 1)
#define | CRM_HICK_READY_INT_FLAG MAKE_VALUE(0x0C, 2)
#define | CRM_HEXT_READY_INT_FLAG MAKE_VALUE(0x0C, 3)
#define | CRM_PLL_READY_INT_FLAG MAKE_VALUE(0x0C, 4)
#define | CRM_CLOCK_FAILURE_INT_FLAG MAKE_VALUE(0x0C, 7)
#define | CRM_LICK_STABLE_INT ((uint32_t)0x00000100)
#define | CRM_LEXT_STABLE_INT ((uint32_t)0x00000200)
#define | CRM_HICK_STABLE_INT ((uint32_t)0x00000400)
#define | CRM_HEXT_STABLE_INT ((uint32_t)0x00000800)
#define | CRM_PLL_STABLE_INT ((uint32_t)0x00001000)
#define | CRM_CLOCK_FAILURE_INT ((uint32_t)0x00800000)
#define | CRM ((crm_type *) CRM_BASE)

Enumerations

enum crm_periph_clock_type {
CRM_GPIOA_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 0 & 0x1f)) , CRM_GPIOB_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 1 & 0x1f)) , CRM_GPIOC_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 2 & 0x1f)) , CRM_GPIOD_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 3 & 0x1f)) ,
CRM_GPIOE_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 4 & 0x1f)) , CRM_GPIOF_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 5 & 0x1f)) , CRM_GPIOG_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 6 & 0x1f)) , CRM_GPIOH_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 7 & 0x1f)) ,
CRM_CRC_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 12 & 0x1f)) , CRM_EDMA_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 21 & 0x1f)) , CRM_DMA1_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 22 & 0x1f)) , CRM_DMA2_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 24 & 0x1f)) ,
CRM_OTGFS2_PERIPH_CLOCK = ((( 0x30 ) << 16) | ( 29 & 0x1f)) , CRM_DVP_PERIPH_CLOCK = ((( 0x34 ) << 16) | ( 0 & 0x1f)) , CRM_OTGFS1_PERIPH_CLOCK = ((( 0x34 ) << 16) | ( 7 & 0x1f)) , CRM_SDIO1_PERIPH_CLOCK = ((( 0x34 ) << 16) | ( 15 & 0x1f)) ,
CRM_XMC_PERIPH_CLOCK = ((( 0x38 ) << 16) | ( 0 & 0x1f)) , CRM_QSPI1_PERIPH_CLOCK = ((( 0x38 ) << 16) | ( 1 & 0x1f)) , CRM_QSPI2_PERIPH_CLOCK = ((( 0x38 ) << 16) | ( 14 & 0x1f)) , CRM_SDIO2_PERIPH_CLOCK = ((( 0x38 ) << 16) | ( 15 & 0x1f)) ,
CRM_TMR2_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 0 & 0x1f)) , CRM_TMR3_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 1 & 0x1f)) , CRM_TMR4_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 2 & 0x1f)) , CRM_TMR5_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 3 & 0x1f)) ,
CRM_TMR6_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 4 & 0x1f)) , CRM_TMR7_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 5 & 0x1f)) , CRM_TMR12_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 6 & 0x1f)) , CRM_TMR13_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 7 & 0x1f)) ,
CRM_TMR14_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 8 & 0x1f)) , CRM_WWDT_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 11 & 0x1f)) , CRM_SPI2_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 14 & 0x1f)) , CRM_SPI3_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 15 & 0x1f)) ,
CRM_USART2_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 17 & 0x1f)) , CRM_USART3_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 18 & 0x1f)) , CRM_UART4_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 19 & 0x1f)) , CRM_UART5_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 20 & 0x1f)) ,
CRM_I2C1_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 21 & 0x1f)) , CRM_I2C2_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 22 & 0x1f)) , CRM_I2C3_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 23 & 0x1f)) , CRM_CAN1_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 25 & 0x1f)) ,
CRM_CAN2_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 26 & 0x1f)) , CRM_PWC_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 28 & 0x1f)) , CRM_DAC_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 29 & 0x1f)) , CRM_UART7_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 30 & 0x1f)) ,
CRM_UART8_PERIPH_CLOCK = ((( 0x40 ) << 16) | ( 31 & 0x1f)) , CRM_TMR1_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 0 & 0x1f)) , CRM_TMR8_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 1 & 0x1f)) , CRM_USART1_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 4 & 0x1f)) ,
CRM_USART6_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 5 & 0x1f)) , CRM_ADC1_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 8 & 0x1f)) , CRM_ADC2_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 9 & 0x1f)) , CRM_ADC3_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 10 & 0x1f)) ,
CRM_SPI1_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 12 & 0x1f)) , CRM_SPI4_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 13 & 0x1f)) , CRM_SCFG_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 14 & 0x1f)) , CRM_TMR9_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 16 & 0x1f)) ,
CRM_TMR10_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 17 & 0x1f)) , CRM_TMR11_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 18 & 0x1f)) , CRM_TMR20_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 20 & 0x1f)) , CRM_ACC_PERIPH_CLOCK = ((( 0x44 ) << 16) | ( 29 & 0x1f))
}
crm periph clock More...
enum crm_periph_reset_type {
CRM_GPIOA_PERIPH_RESET = ((( 0x10 ) << 16) | ( 0 & 0x1f)) , CRM_GPIOB_PERIPH_RESET = ((( 0x10 ) << 16) | ( 1 & 0x1f)) , CRM_GPIOC_PERIPH_RESET = ((( 0x10 ) << 16) | ( 2 & 0x1f)) , CRM_GPIOD_PERIPH_RESET = ((( 0x10 ) << 16) | ( 3 & 0x1f)) ,
CRM_GPIOE_PERIPH_RESET = ((( 0x10 ) << 16) | ( 4 & 0x1f)) , CRM_GPIOF_PERIPH_RESET = ((( 0x10 ) << 16) | ( 5 & 0x1f)) , CRM_GPIOG_PERIPH_RESET = ((( 0x10 ) << 16) | ( 6 & 0x1f)) , CRM_GPIOH_PERIPH_RESET = ((( 0x10 ) << 16) | ( 7 & 0x1f)) ,
CRM_CRC_PERIPH_RESET = ((( 0x10 ) << 16) | ( 12 & 0x1f)) , CRM_EDMA_PERIPH_RESET = ((( 0x10 ) << 16) | ( 21 & 0x1f)) , CRM_DMA1_PERIPH_RESET = ((( 0x10 ) << 16) | ( 22 & 0x1f)) , CRM_DMA2_PERIPH_RESET = ((( 0x10 ) << 16) | ( 24 & 0x1f)) ,
CRM_OTGFS2_PERIPH_RESET = ((( 0x10 ) << 16) | ( 29 & 0x1f)) , CRM_DVP_PERIPH_RESET = ((( 0x14 ) << 16) | ( 0 & 0x1f)) , CRM_OTGFS1_PERIPH_RESET = ((( 0x14 ) << 16) | ( 7 & 0x1f)) , CRM_SDIO1_PERIPH_RESET = ((( 0x14 ) << 16) | ( 15 & 0x1f)) ,
CRM_XMC_PERIPH_RESET = ((( 0x18 ) << 16) | ( 0 & 0x1f)) , CRM_QSPI1_PERIPH_RESET = ((( 0x18 ) << 16) | ( 1 & 0x1f)) , CRM_QSPI2_PERIPH_RESET = ((( 0x18 ) << 16) | ( 14 & 0x1f)) , CRM_SDIO2_PERIPH_RESET = ((( 0x18 ) << 16) | ( 15 & 0x1f)) ,
CRM_TMR2_PERIPH_RESET = ((( 0x20 ) << 16) | ( 0 & 0x1f)) , CRM_TMR3_PERIPH_RESET = ((( 0x20 ) << 16) | ( 1 & 0x1f)) , CRM_TMR4_PERIPH_RESET = ((( 0x20 ) << 16) | ( 2 & 0x1f)) , CRM_TMR5_PERIPH_RESET = ((( 0x20 ) << 16) | ( 3 & 0x1f)) ,
CRM_TMR6_PERIPH_RESET = ((( 0x20 ) << 16) | ( 4 & 0x1f)) , CRM_TMR7_PERIPH_RESET = ((( 0x20 ) << 16) | ( 5 & 0x1f)) , CRM_TMR12_PERIPH_RESET = ((( 0x20 ) << 16) | ( 6 & 0x1f)) , CRM_TMR13_PERIPH_RESET = ((( 0x20 ) << 16) | ( 7 & 0x1f)) ,
CRM_TMR14_PERIPH_RESET = ((( 0x20 ) << 16) | ( 8 & 0x1f)) , CRM_WWDT_PERIPH_RESET = ((( 0x20 ) << 16) | ( 11 & 0x1f)) , CRM_SPI2_PERIPH_RESET = ((( 0x20 ) << 16) | ( 14 & 0x1f)) , CRM_SPI3_PERIPH_RESET = ((( 0x20 ) << 16) | ( 15 & 0x1f)) ,
CRM_USART2_PERIPH_RESET = ((( 0x20 ) << 16) | ( 17 & 0x1f)) , CRM_USART3_PERIPH_RESET = ((( 0x20 ) << 16) | ( 18 & 0x1f)) , CRM_UART4_PERIPH_RESET = ((( 0x20 ) << 16) | ( 19 & 0x1f)) , CRM_UART5_PERIPH_RESET = ((( 0x20 ) << 16) | ( 20 & 0x1f)) ,
CRM_I2C1_PERIPH_RESET = ((( 0x20 ) << 16) | ( 21 & 0x1f)) , CRM_I2C2_PERIPH_RESET = ((( 0x20 ) << 16) | ( 22 & 0x1f)) , CRM_I2C3_PERIPH_RESET = ((( 0x20 ) << 16) | ( 23 & 0x1f)) , CRM_CAN1_PERIPH_RESET = ((( 0x20 ) << 16) | ( 25 & 0x1f)) ,
CRM_CAN2_PERIPH_RESET = ((( 0x20 ) << 16) | ( 26 & 0x1f)) , CRM_PWC_PERIPH_RESET = ((( 0x20 ) << 16) | ( 28 & 0x1f)) , CRM_DAC_PERIPH_RESET = ((( 0x20 ) << 16) | ( 29 & 0x1f)) , CRM_UART7_PERIPH_RESET = ((( 0x20 ) << 16) | ( 30 & 0x1f)) ,
CRM_UART8_PERIPH_RESET = ((( 0x20 ) << 16) | ( 31 & 0x1f)) , CRM_TMR1_PERIPH_RESET = ((( 0x24 ) << 16) | ( 0 & 0x1f)) , CRM_TMR8_PERIPH_RESET = ((( 0x24 ) << 16) | ( 1 & 0x1f)) , CRM_USART1_PERIPH_RESET = ((( 0x24 ) << 16) | ( 4 & 0x1f)) ,
CRM_USART6_PERIPH_RESET = ((( 0x24 ) << 16) | ( 5 & 0x1f)) , CRM_ADC_PERIPH_RESET = ((( 0x24 ) << 16) | ( 8 & 0x1f)) , CRM_SPI1_PERIPH_RESET = ((( 0x24 ) << 16) | ( 12 & 0x1f)) , CRM_SPI4_PERIPH_RESET = ((( 0x24 ) << 16) | ( 13 & 0x1f)) ,
CRM_SCFG_PERIPH_RESET = ((( 0x24 ) << 16) | ( 14 & 0x1f)) , CRM_TMR9_PERIPH_RESET = ((( 0x24 ) << 16) | ( 16 & 0x1f)) , CRM_TMR10_PERIPH_RESET = ((( 0x24 ) << 16) | ( 17 & 0x1f)) , CRM_TMR11_PERIPH_RESET = ((( 0x24 ) << 16) | ( 18 & 0x1f)) ,
CRM_TMR20_PERIPH_RESET = ((( 0x24 ) << 16) | ( 20 & 0x1f)) , CRM_ACC_PERIPH_RESET = ((( 0x24 ) << 16) | ( 29 & 0x1f))
}
crm periph reset More...
enum crm_periph_clock_lowpower_type {
CRM_GPIOA_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 0 & 0x1f)) , CRM_GPIOB_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 1 & 0x1f)) , CRM_GPIOC_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 2 & 0x1f)) , CRM_GPIOD_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 3 & 0x1f)) ,
CRM_GPIOE_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 4 & 0x1f)) , CRM_GPIOF_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 5 & 0x1f)) , CRM_GPIOG_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 6 & 0x1f)) , CRM_GPIOH_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 7 & 0x1f)) ,
CRM_CRC_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 12 & 0x1f)) , CRM_EDMA_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 21 & 0x1f)) , CRM_DMA1_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 22 & 0x1f)) , CRM_DMA2_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 24 & 0x1f)) ,
CRM_EMAC_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 25 & 0x1f)) , CRM_EMACTX_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 26 & 0x1f)) , CRM_EMACRX_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 27 & 0x1f)) , CRM_EMACPTP_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 28 & 0x1f)) ,
CRM_OTGFS2_PERIPH_LOWPOWER = ((( 0x50 ) << 16) | ( 29 & 0x1f)) , CRM_DVP_PERIPH_LOWPOWER = ((( 0x54 ) << 16) | ( 0 & 0x1f)) , CRM_OTGFS1_PERIPH_LOWPOWER = ((( 0x54 ) << 16) | ( 7 & 0x1f)) , CRM_SDIO1_PERIPH_LOWPOWER = ((( 0x54 ) << 16) | ( 15 & 0x1f)) ,
CRM_XMC_PERIPH_LOWPOWER = ((( 0x58 ) << 16) | ( 0 & 0x1f)) , CRM_QSPI1_PERIPH_LOWPOWER = ((( 0x58 ) << 16) | ( 1 & 0x1f)) , CRM_QSPI2_PERIPH_LOWPOWER = ((( 0x58 ) << 16) | ( 14 & 0x1f)) , CRM_SDIO2_PERIPH_LOWPOWER = ((( 0x58 ) << 16) | ( 15 & 0x1f)) ,
CRM_TMR2_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 0 & 0x1f)) , CRM_TMR3_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 1 & 0x1f)) , CRM_TMR4_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 2 & 0x1f)) , CRM_TMR5_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 3 & 0x1f)) ,
CRM_TMR6_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 4 & 0x1f)) , CRM_TMR7_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 5 & 0x1f)) , CRM_TMR12_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 6 & 0x1f)) , CRM_TMR13_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 7 & 0x1f)) ,
CRM_TMR14_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 8 & 0x1f)) , CRM_WWDT_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 11 & 0x1f)) , CRM_SPI2_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 14 & 0x1f)) , CRM_SPI3_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 15 & 0x1f)) ,
CRM_USART2_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 17 & 0x1f)) , CRM_USART3_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 18 & 0x1f)) , CRM_UART4_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 19 & 0x1f)) , CRM_UART5_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 20 & 0x1f)) ,
CRM_I2C1_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 21 & 0x1f)) , CRM_I2C2_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 22 & 0x1f)) , CRM_I2C3_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 23 & 0x1f)) , CRM_CAN1_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 25 & 0x1f)) ,
CRM_CAN2_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 26 & 0x1f)) , CRM_PWC_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 28 & 0x1f)) , CRM_DAC_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 29 & 0x1f)) , CRM_UART7_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 30 & 0x1f)) ,
CRM_UART8_PERIPH_LOWPOWER = ((( 0x60 ) << 16) | ( 31 & 0x1f)) , CRM_TMR1_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 0 & 0x1f)) , CRM_TMR8_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 1 & 0x1f)) , CRM_USART1_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 4 & 0x1f)) ,
CRM_USART6_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 5 & 0x1f)) , CRM_ADC1_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 8 & 0x1f)) , CRM_ADC2_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 9 & 0x1f)) , CRM_ADC3_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 10 & 0x1f)) ,
CRM_SPI1_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 12 & 0x1f)) , CRM_SPI4_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 13 & 0x1f)) , CRM_SCFG_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 14 & 0x1f)) , CRM_TMR9_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 16 & 0x1f)) ,
CRM_TMR10_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 17 & 0x1f)) , CRM_TMR11_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 18 & 0x1f)) , CRM_TMR20_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 20 & 0x1f)) , CRM_ACC_PERIPH_LOWPOWER = ((( 0x64 ) << 16) | ( 29 & 0x1f))
}
crm periph clock in low power mode More...
enum | crm_pll_clock_source_type { CRM_PLL_SOURCE_HICK = 0x00 , CRM_PLL_SOURCE_HEXT = 0x01 }
crm pll clock source More...
enum crm_pll_fr_type {
CRM_PLL_FR_1 = 0x00 , CRM_PLL_FR_2 = 0x01 , CRM_PLL_FR_4 = 0x02 , CRM_PLL_FR_8 = 0x03 ,
CRM_PLL_FR_16 = 0x04 , CRM_PLL_FR_32 = 0x05
}
crm pll fr More...
enum crm_clock_source_type {
CRM_CLOCK_SOURCE_HICK = 0x00 , CRM_CLOCK_SOURCE_HEXT = 0x01 , CRM_CLOCK_SOURCE_PLL = 0x02 , CRM_CLOCK_SOURCE_LEXT = 0x03 ,
CRM_CLOCK_SOURCE_LICK = 0x04
}
crm clock source More...
enum crm_ahb_div_type {
CRM_AHB_DIV_1 = 0x00 , CRM_AHB_DIV_2 = 0x08 , CRM_AHB_DIV_4 = 0x09 , CRM_AHB_DIV_8 = 0x0A ,
CRM_AHB_DIV_16 = 0x0B , CRM_AHB_DIV_64 = 0x0C , CRM_AHB_DIV_128 = 0x0D , CRM_AHB_DIV_256 = 0x0E ,
CRM_AHB_DIV_512 = 0x0F
}
crm ahb division More...
enum crm_apb1_div_type {
CRM_APB1_DIV_1 = 0x00 , CRM_APB1_DIV_2 = 0x04 , CRM_APB1_DIV_4 = 0x05 , CRM_APB1_DIV_8 = 0x06 ,
CRM_APB1_DIV_16 = 0x07
}
crm apb1 division More...
enum crm_apb2_div_type {
CRM_APB2_DIV_1 = 0x00 , CRM_APB2_DIV_2 = 0x04 , CRM_APB2_DIV_4 = 0x05 , CRM_APB2_DIV_8 = 0x06 ,
CRM_APB2_DIV_16 = 0x07
}
crm apb2 division More...
enum crm_usb_div_type {
CRM_USB_DIV_1_5 = 0x00 , CRM_USB_DIV_1 = 0x01 , CRM_USB_DIV_2_5 = 0x02 , CRM_USB_DIV_2 = 0x03 ,
CRM_USB_DIV_3_5 = 0x04 , CRM_USB_DIV_3 = 0x05 , CRM_USB_DIV_4_5 = 0x06 , CRM_USB_DIV_4 = 0x07 ,
CRM_USB_DIV_5_5 = 0x08 , CRM_USB_DIV_5 = 0x09 , CRM_USB_DIV_6_5 = 0x0A , CRM_USB_DIV_6 = 0x0B ,
CRM_USB_DIV_7 = 0x0C
}
crm usb division More...
enum crm_ertc_clock_type {
CRM_ERTC_CLOCK_NOCLK = 0x000 , CRM_ERTC_CLOCK_LEXT = 0x001 , CRM_ERTC_CLOCK_LICK = 0x002 , CRM_ERTC_CLOCK_HEXT_DIV_2 = 0x023 ,
CRM_ERTC_CLOCK_HEXT_DIV_3 = 0x033 , CRM_ERTC_CLOCK_HEXT_DIV_4 = 0x043 , CRM_ERTC_CLOCK_HEXT_DIV_5 = 0x053 , CRM_ERTC_CLOCK_HEXT_DIV_6 = 0x063 ,
CRM_ERTC_CLOCK_HEXT_DIV_7 = 0x073 , CRM_ERTC_CLOCK_HEXT_DIV_8 = 0x083 , CRM_ERTC_CLOCK_HEXT_DIV_9 = 0x093 , CRM_ERTC_CLOCK_HEXT_DIV_10 = 0x0A3 ,
CRM_ERTC_CLOCK_HEXT_DIV_11 = 0x0B3 , CRM_ERTC_CLOCK_HEXT_DIV_12 = 0x0C3 , CRM_ERTC_CLOCK_HEXT_DIV_13 = 0x0D3 , CRM_ERTC_CLOCK_HEXT_DIV_14 = 0x0E3 ,
CRM_ERTC_CLOCK_HEXT_DIV_15 = 0x0F3 , CRM_ERTC_CLOCK_HEXT_DIV_16 = 0x103 , CRM_ERTC_CLOCK_HEXT_DIV_17 = 0x113 , CRM_ERTC_CLOCK_HEXT_DIV_18 = 0x123 ,
CRM_ERTC_CLOCK_HEXT_DIV_19 = 0x133 , CRM_ERTC_CLOCK_HEXT_DIV_20 = 0x143 , CRM_ERTC_CLOCK_HEXT_DIV_21 = 0x153 , CRM_ERTC_CLOCK_HEXT_DIV_22 = 0x163 ,
CRM_ERTC_CLOCK_HEXT_DIV_23 = 0x173 , CRM_ERTC_CLOCK_HEXT_DIV_24 = 0x183 , CRM_ERTC_CLOCK_HEXT_DIV_25 = 0x193 , CRM_ERTC_CLOCK_HEXT_DIV_26 = 0x1A3 ,
CRM_ERTC_CLOCK_HEXT_DIV_27 = 0x1B3 , CRM_ERTC_CLOCK_HEXT_DIV_28 = 0x1C3 , CRM_ERTC_CLOCK_HEXT_DIV_29 = 0x1D3 , CRM_ERTC_CLOCK_HEXT_DIV_30 = 0x1E3 ,
CRM_ERTC_CLOCK_HEXT_DIV_31 = 0x1F3
}
crm ertc clock More...
enum | crm_hick_div_6_type { CRM_HICK48_DIV6 = 0x00 , CRM_HICK48_NODIV = 0x01 }
crm hick 48mhz division More...
enum | crm_sclk_type { CRM_SCLK_HICK = 0x00 , CRM_SCLK_HEXT = 0x01 , CRM_SCLK_PLL = 0x02 }
crm sclk select More...
enum | crm_clkout_index_type { CRM_CLKOUT_INDEX_1 = 0x00 , CRM_CLKOUT_INDEX_2 = 0x01 }
crm clkout index More...
enum | crm_clkout1_select_type { CRM_CLKOUT1_HICK = 0x00 , CRM_CLKOUT1_LEXT = 0x01 , CRM_CLKOUT1_HEXT = 0x02 , CRM_CLKOUT1_PLL = 0x03 }
crm clkout1 select More...
enum crm_clkout2_select_type {
CRM_CLKOUT2_SCLK = 0x00 , CRM_CLKOUT2_HEXT = 0x02 , CRM_CLKOUT2_PLL = 0x03 , CRM_CLKOUT2_USB = 0x10 ,
CRM_CLKOUT2_ADC = 0x11 , CRM_CLKOUT2_HICK = 0x12 , CRM_CLKOUT2_LICK = 0x13 , CRM_CLKOUT2_LEXT = 0x14
}
crm clkout2 select More...
enum crm_clkout_div1_type {
CRM_CLKOUT_DIV1_1 = 0x00 , CRM_CLKOUT_DIV1_2 = 0x04 , CRM_CLKOUT_DIV1_3 = 0x05 , CRM_CLKOUT_DIV1_4 = 0x06 ,
CRM_CLKOUT_DIV1_5 = 0x07
}
crm clkout division1 More...
enum crm_clkout_div2_type {
CRM_CLKOUT_DIV2_1 = 0x00 , CRM_CLKOUT_DIV2_2 = 0x08 , CRM_CLKOUT_DIV2_4 = 0x09 , CRM_CLKOUT_DIV2_8 = 0x0A ,
CRM_CLKOUT_DIV2_16 = 0x0B , CRM_CLKOUT_DIV2_64 = 0x0C , CRM_CLKOUT_DIV2_128 = 0x0D , CRM_CLKOUT_DIV2_256 = 0x0E ,
CRM_CLKOUT_DIV2_512 = 0x0F
}
crm clkout division2 More...
enum | crm_auto_step_mode_type { CRM_AUTO_STEP_MODE_DISABLE = 0x00 , CRM_AUTO_STEP_MODE_ENABLE = 0x03 }
crm auto step mode More...
enum | crm_usb_clock_source_type { CRM_USB_CLOCK_SOURCE_PLL = 0x00 , CRM_USB_CLOCK_SOURCE_HICK = 0x01 }
crm usb 48 mhz clock source select More...
enum | crm_hick_sclk_frequency_type { CRM_HICK_SCLK_8MHZ = 0x00 , CRM_HICK_SCLK_48MHZ = 0x01 }
crm hick as system clock frequency select More...
enum | crm_emac_output_pulse_type { CRM_EMAC_PULSE_125MS = 0x00 , CRM_EMAC_PULSE_1SCLK = 0x01 }
crm emac output pulse width More...

Functions

void | crm_reset (void)
reset the crm register More...
void | crm_lext_bypass (confirm_state new_state)
enable or disable crm low speed external crystal bypass More...
void | crm_hext_bypass (confirm_state new_state)
enable or disable crm high speed external crystal bypass More...
flag_status | crm_flag_get (uint32_t flag)
get crm flag status More...
error_status | crm_hext_stable_wait (void)
wait for hext stable More...
void | crm_hick_clock_trimming_set (uint8_t trim_value)
set the hick trimming value More...
void | crm_hick_clock_calibration_set (uint8_t cali_value)
set the crm calibration value More...
void | crm_periph_clock_enable (crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock More...
void | crm_periph_reset (crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset More...
void | crm_periph_lowpower_mode_enable (crm_periph_clock_lowpower_type value, confirm_state new_state)
enable or disable the peripheral clock in lowpower mode More...
void | crm_clock_source_enable (crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source More...
void | crm_flag_clear (uint32_t flag)
clear the crm reset flags More...
void | crm_ertc_clock_select (crm_ertc_clock_type value)
select ertc clock More...
void | crm_ertc_clock_enable (confirm_state new_state)
enable or disable ertc More...
void | crm_ahb_div_set (crm_ahb_div_type value)
set crm ahb division More...
void | crm_apb1_div_set (crm_apb1_div_type value)
set crm apb1 division More...
void | crm_apb2_div_set (crm_apb2_div_type value)
set crm apb2 division More...
void | crm_usb_clock_div_set (crm_usb_div_type value)
set usb division More...
void | crm_clock_failure_detection_enable (confirm_state new_state)
enable or disable clock failure detection More...
void | crm_battery_powered_domain_reset (confirm_state new_state)
battery powered domain software reset More...
void | crm_auto_step_mode_enable (confirm_state new_state)
auto step clock switch enable More...
void | crm_hick_divider_select (crm_hick_div_6_type value)
config hick divider select More...
void | crm_hick_sclk_frequency_select (crm_hick_sclk_frequency_type value)
hick as system clock frequency select More...
void | crm_usb_clock_source_select (crm_usb_clock_source_type value)
usb 48 mhz clock source select More...
void | crm_clkout_to_tmr10_enable (confirm_state new_state)
enable or disable clkout direct to tmr10 channel 1 More...
void | crm_pll_config (crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n attemtion: 31 <= pll_ns <= 500 1 <= pll_ms <= 15 More...
void | crm_sysclk_switch (crm_sclk_type value)
select system clock source More...
crm_sclk_type | crm_sysclk_switch_status_get (void)
indicate which clock source is used as system clock More...
void | crm_clocks_freq_get (crm_clocks_freq_type *clocks_struct)
get crm clocks freqency More...
void | crm_clock_out1_set (crm_clkout1_select_type clkout)
set crm clkout1 More...
void | crm_clock_out2_set (crm_clkout2_select_type clkout)
set crm clkout2 More...
void | crm_clkout_div_set (crm_clkout_index_type index, crm_clkout_div1_type div1, crm_clkout_div2_type div2)
set crm clkout1 division1 More...
void | crm_emac_output_pulse_set (crm_emac_output_pulse_type width)
set emac output pulse width More...
void | crm_interrupt_enable (uint32_t crm_int, confirm_state new_state)
config crm interrupt More...
error_status | crm_pll_parameter_calculate (crm_pll_clock_source_type pll_rcs, uint32_t target_sclk_freq, uint16_t *ret_ms, uint16_t *ret_ns, uint16_t *ret_fr)
calculate the pll parameters with pll reference clock and target pll output frequency. pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n attemtion: 31 <= pll_ns <= 500 1 <= pll_ms <= 15 More...

Detailed Description

at32f435_437 crm header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_crm.h.


AT32F435/437 Firmwary Library: at32f435_437_dac.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f435_437_dac.h File Reference

at32f435_437 dac header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct dac_type
type define dac register all More...

Macros

#define | DAC1_D1DMAUDRF ((uint32_t)(0x00002000))
#define | DAC2_D2DMAUDRF ((uint32_t)(0x20000000))
#define | DAC ((dac_type *) DAC_BASE)

Enumerations

enum | dac_select_type { DAC1_SELECT = 0x01 , DAC2_SELECT = 0x02 }
dac select type More...
enum dac_trigger_type {
DAC_TMR6_TRGOUT_EVENT = 0x00 , DAC_TMR8_TRGOUT_EVENT = 0x01 , DAC_TMR7_TRGOUT_EVENT = 0x02 , DAC_TMR5_TRGOUT_EVENT = 0x03 ,
DAC_TMR2_TRGOUT_EVENT = 0x04 , DAC_TMR4_TRGOUT_EVENT = 0x05 , DAC_EXTERNAL_INTERRUPT_LINE_9 = 0x06 , DAC_SOFTWARE_TRIGGER = 0x07
}
dac trigger type More...
enum | dac_wave_type { DAC_WAVE_GENERATE_NONE = 0x00 , DAC_WAVE_GENERATE_NOISE = 0x01 , DAC_WAVE_GENERATE_TRIANGLE = 0x02 }
dac wave type More...
enum dac_mask_amplitude_type {
DAC_LSFR_BIT0_AMPLITUDE_1 = 0x00 , DAC_LSFR_BIT10_AMPLITUDE_3 = 0x01 , DAC_LSFR_BIT20_AMPLITUDE_7 = 0x02 , DAC_LSFR_BIT30_AMPLITUDE_15 = 0x03 ,
DAC_LSFR_BIT40_AMPLITUDE_31 = 0x04 , DAC_LSFR_BIT50_AMPLITUDE_63 = 0x05 , DAC_LSFR_BIT60_AMPLITUDE_127 = 0x06 , DAC_LSFR_BIT70_AMPLITUDE_255 = 0x07 ,
DAC_LSFR_BIT80_AMPLITUDE_511 = 0x08 , DAC_LSFR_BIT90_AMPLITUDE_1023 = 0x09 , DAC_LSFR_BITA0_AMPLITUDE_2047 = 0x0A , DAC_LSFR_BITB0_AMPLITUDE_4095 = 0x0B
}
dac mask amplitude type More...
enum | dac1_aligned_data_type { DAC1_12BIT_RIGHT = 0x40007408 , DAC1_12BIT_LEFT = 0x4000740C , DAC1_8BIT_RIGHT = 0x40007410 }
dac1 aligned data type More...
enum | dac2_aligned_data_type { DAC2_12BIT_RIGHT = 0x40007414 , DAC2_12BIT_LEFT = 0x40007418 , DAC2_8BIT_RIGHT = 0x4000741C }
dac2 aligned data type More...
enum | dac_dual_data_type { DAC_DUAL_12BIT_RIGHT = 0x40007420 , DAC_DUAL_12BIT_LEFT = 0x40007424 , DAC_DUAL_8BIT_RIGHT = 0x40007428 }
dac dual data type More...

Functions

void | dac_reset (void)
dac reset More...
void | dac_enable (dac_select_type dac_select, confirm_state new_state)
enable or disable dac More...
void | dac_output_buffer_enable (dac_select_type dac_select, confirm_state new_state)
enable or disable dac output buffer More...
void | dac_trigger_enable (dac_select_type dac_select, confirm_state new_state)
enable or disable dac trigger More...
void | dac_trigger_select (dac_select_type dac_select, dac_trigger_type dac_trigger_source)
select dac trigger More...
void | dac_software_trigger_generate (dac_select_type dac_select)
generate dac software trigger More...
void | dac_dual_software_trigger_generate (void)
generate dac dual software trigger synchronously More...
void | dac_wave_generate (dac_select_type dac_select, dac_wave_type dac_wave)
generate dac wave More...
void | dac_mask_amplitude_select (dac_select_type dac_select, dac_mask_amplitude_type dac_mask_amplitude)
select dac mask amplitude More...
void | dac_dma_enable (dac_select_type dac_select, confirm_state new_state)
enable or disable dac dma More...
uint16_t | dac_data_output_get (dac_select_type dac_select)
get dac data output More...
void | dac_1_data_set (dac1_aligned_data_type dac1_aligned, uint16_t dac1_data)
set dac1 data More...
void | dac_2_data_set (dac2_aligned_data_type dac2_aligned, uint16_t dac2_data)
set dac2 data More...
void | dac_dual_data_set (dac_dual_data_type dac_dual, uint16_t data1, uint16_t data2)
set dac dual data More...
void | dac_udr_enable (dac_select_type dac_select, confirm_state new_state)
enable/disable dac dma udr interrupt More...
flag_status | dac_udr_flag_get (dac_select_type dac_select)
get flag of the dac udr flag. More...
void | dac_udr_flag_clear (dac_select_type dac_select)
clear the dac udr flag. More...

Detailed Description

at32f435_437 dac header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_dac.h.


AT32F435/437 Firmwary Library: at32f435_437_debug.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Functions
at32f435_437_debug.h File Reference
#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct debug_type
type define debug register all More...

Macros

#define | DEBUG_SLEEP 0x00000001
#define | DEBUG_DEEPSLEEP 0x00000002
#define | DEBUG_STANDBY 0x00000004
#define | DEBUG_TMR2_PAUSE 0x00000001
#define | DEBUG_TMR3_PAUSE 0x00000002
#define | DEBUG_TMR4_PAUSE 0x00000004
#define | DEBUG_TMR5_PAUSE 0x00000008
#define | DEBUG_TMR6_PAUSE 0x00000010
#define | DEBUG_TMR7_PAUSE 0x00000020
#define | DEBUG_TMR12_PAUSE 0x00000040
#define | DEBUG_TMR13_PAUSE 0x00000080
#define | DEBUG_TMR14_PAUSE 0x00000100
#define | DEBUG_ERTC_PAUSE 0x00000400
#define | DEBUG_WWDT_PAUSE 0x00000800
#define | DEBUG_WDT_PAUSE 0x00001000
#define | DEBUG_ERTC_512_PAUSE 0x00008000
#define | DEBUG_I2C1_SMBUS_TIMEOUT 0x01000000
#define | DEBUG_I2C2_SMBUS_TIMEOUT 0x08000000
#define | DEBUG_I2C3_SMBUS_TIMEOUT 0x10000000
#define | DEBUG_CAN1_PAUSE 0x02000000
#define | DEBUG_CAN2_PAUSE 0x04000000
#define | DEBUG_TMR1_PAUSE 0x00000001
#define | DEBUG_TMR8_PAUSE 0x00000002
#define | DEBUG_TMR20_PAUSE 0x00000040
#define | DEBUG_TMR9_PAUSE 0x00010000
#define | DEBUG_TMR10_PAUSE 0x00020000
#define | DEBUG_TMR11_PAUSE 0x00040000
#define | DEBUGMCU ((debug_type *) DEBUG_BASE)

Functions

uint32_t | debug_device_id_get (void)
get debug device id More...
void | debug_low_power_mode_set (uint32_t low_power_mode, confirm_state new_state)
set periph debug mode More...
void | debug_apb1_periph_mode_set (uint32_t apb1_periph, confirm_state new_state)
set apb1 periph debug mode More...
void | debug_apb2_periph_mode_set (uint32_t apb2_periph, confirm_state new_state)
set apb2 periph debug mode More...


AT32F435/437 Firmwary Library: at32f435_437_def.h File Reference

  • libraries
  • drivers
  • inc
Macros
at32f435_437_def.h File Reference

at32f435_437 macros header file More...

Go to the source code of this file.

Macros

#define UNUSED(x) (void)x /* to avoid gcc/g++ warnings */

Detailed Description

at32f435_437 macros header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_def.h.

Macro Definition Documentation

◆ UNUSED

#define UNUSED ( x ) (void)x /* to avoid gcc/g++ warnings */

Definition at line 65 of file at32f435_437_def.h.


AT32F435/437 Firmwary Library: at32f435_437_dma.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f435_437_dma.h File Reference

at32f435_437 dma header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct | dma_init_type
dma init type More...
struct | dmamux_sync_init_type
dmamux sync init type More...
struct | dmamux_gen_init_type
dmamux generator init type More...
struct | dma_type
type define dma1 register More...
struct | dma_channel_type
type define dma channel register all More...
struct | dmamux_channel_type
type define dmamux muxsctrl register More...
struct | dmamux_generator_type
type define dmamux request generator register all More...

Macros

#define | DMA_FDT_INT ((uint32_t)0x00000002)
#define | DMA_HDT_INT ((uint32_t)0x00000004)
#define | DMA_DTERR_INT ((uint32_t)0x00000008)
#define | DMA1_GL1_FLAG ((uint32_t)0x00000001)
#define | DMA1_FDT1_FLAG ((uint32_t)0x00000002)
#define | DMA1_HDT1_FLAG ((uint32_t)0x00000004)
#define | DMA1_DTERR1_FLAG ((uint32_t)0x00000008)
#define | DMA1_GL2_FLAG ((uint32_t)0x00000010)
#define | DMA1_FDT2_FLAG ((uint32_t)0x00000020)
#define | DMA1_HDT2_FLAG ((uint32_t)0x00000040)
#define | DMA1_DTERR2_FLAG ((uint32_t)0x00000080)
#define | DMA1_GL3_FLAG ((uint32_t)0x00000100)
#define | DMA1_FDT3_FLAG ((uint32_t)0x00000200)
#define | DMA1_HDT3_FLAG ((uint32_t)0x00000400)
#define | DMA1_DTERR3_FLAG ((uint32_t)0x00000800)
#define | DMA1_GL4_FLAG ((uint32_t)0x00001000)
#define | DMA1_FDT4_FLAG ((uint32_t)0x00002000)
#define | DMA1_HDT4_FLAG ((uint32_t)0x00004000)
#define | DMA1_DTERR4_FLAG ((uint32_t)0x00008000)
#define | DMA1_GL5_FLAG ((uint32_t)0x00010000)
#define | DMA1_FDT5_FLAG ((uint32_t)0x00020000)
#define | DMA1_HDT5_FLAG ((uint32_t)0x00040000)
#define | DMA1_DTERR5_FLAG ((uint32_t)0x00080000)
#define | DMA1_GL6_FLAG ((uint32_t)0x00100000)
#define | DMA1_FDT6_FLAG ((uint32_t)0x00200000)
#define | DMA1_HDT6_FLAG ((uint32_t)0x00400000)
#define | DMA1_DTERR6_FLAG ((uint32_t)0x00800000)
#define | DMA1_GL7_FLAG ((uint32_t)0x01000000)
#define | DMA1_FDT7_FLAG ((uint32_t)0x02000000)
#define | DMA1_HDT7_FLAG ((uint32_t)0x04000000)
#define | DMA1_DTERR7_FLAG ((uint32_t)0x08000000)
#define | DMA2_GL1_FLAG ((uint32_t)0x10000001)
#define | DMA2_FDT1_FLAG ((uint32_t)0x10000002)
#define | DMA2_HDT1_FLAG ((uint32_t)0x10000004)
#define | DMA2_DTERR1_FLAG ((uint32_t)0x10000008)
#define | DMA2_GL2_FLAG ((uint32_t)0x10000010)
#define | DMA2_FDT2_FLAG ((uint32_t)0x10000020)
#define | DMA2_HDT2_FLAG ((uint32_t)0x10000040)
#define | DMA2_DTERR2_FLAG ((uint32_t)0x10000080)
#define | DMA2_GL3_FLAG ((uint32_t)0x10000100)
#define | DMA2_FDT3_FLAG ((uint32_t)0x10000200)
#define | DMA2_HDT3_FLAG ((uint32_t)0x10000400)
#define | DMA2_DTERR3_FLAG ((uint32_t)0x10000800)
#define | DMA2_GL4_FLAG ((uint32_t)0x10001000)
#define | DMA2_FDT4_FLAG ((uint32_t)0x10002000)
#define | DMA2_HDT4_FLAG ((uint32_t)0x10004000)
#define | DMA2_DTERR4_FLAG ((uint32_t)0x10008000)
#define | DMA2_GL5_FLAG ((uint32_t)0x10010000)
#define | DMA2_FDT5_FLAG ((uint32_t)0x10020000)
#define | DMA2_HDT5_FLAG ((uint32_t)0x10040000)
#define | DMA2_DTERR5_FLAG ((uint32_t)0x10080000)
#define | DMA2_GL6_FLAG ((uint32_t)0x10100000)
#define | DMA2_FDT6_FLAG ((uint32_t)0x10200000)
#define | DMA2_HDT6_FLAG ((uint32_t)0x10400000)
#define | DMA2_DTERR6_FLAG ((uint32_t)0x10800000)
#define | DMA2_GL7_FLAG ((uint32_t)0x11000000)
#define | DMA2_FDT7_FLAG ((uint32_t)0x12000000)
#define | DMA2_HDT7_FLAG ((uint32_t)0x14000000)
#define | DMA2_DTERR7_FLAG ((uint32_t)0x18000000)
#define | DMAMUX_SYNC_OV1_FLAG ((uint32_t)0x00000001)
dmamux flag More...
#define | DMAMUX_SYNC_OV2_FLAG ((uint32_t)0x00000002)
#define | DMAMUX_SYNC_OV3_FLAG ((uint32_t)0x00000004)
#define | DMAMUX_SYNC_OV4_FLAG ((uint32_t)0x00000008)
#define | DMAMUX_SYNC_OV5_FLAG ((uint32_t)0x00000010)
#define | DMAMUX_SYNC_OV6_FLAG ((uint32_t)0x00000020)
#define | DMAMUX_SYNC_OV7_FLAG ((uint32_t)0x00000040)
#define | DMAMUX_GEN_TRIG_OV1_FLAG ((uint32_t)0x00000001)
#define | DMAMUX_GEN_TRIG_OV2_FLAG ((uint32_t)0x00000002)
#define | DMAMUX_GEN_TRIG_OV3_FLAG ((uint32_t)0x00000004)
#define | DMAMUX_GEN_TRIG_OV4_FLAG ((uint32_t)0x00000008)
#define | DMA1 ((dma_type *) DMA1_BASE)
#define | DMA1_CHANNEL1 ((dma_channel_type *) DMA1_CHANNEL1_BASE)
#define | DMA1_CHANNEL2 ((dma_channel_type *) DMA1_CHANNEL2_BASE)
#define | DMA1_CHANNEL3 ((dma_channel_type *) DMA1_CHANNEL3_BASE)
#define | DMA1_CHANNEL4 ((dma_channel_type *) DMA1_CHANNEL4_BASE)
#define | DMA1_CHANNEL5 ((dma_channel_type *) DMA1_CHANNEL5_BASE)
#define | DMA1_CHANNEL6 ((dma_channel_type *) DMA1_CHANNEL6_BASE)
#define | DMA1_CHANNEL7 ((dma_channel_type *) DMA1_CHANNEL7_BASE)
#define | DMA1MUX_CHANNEL1 ((dmamux_channel_type *) DMA1MUX_CHANNEL1_BASE)
#define | DMA1MUX_CHANNEL2 ((dmamux_channel_type *) DMA1MUX_CHANNEL2_BASE)
#define | DMA1MUX_CHANNEL3 ((dmamux_channel_type *) DMA1MUX_CHANNEL3_BASE)
#define | DMA1MUX_CHANNEL4 ((dmamux_channel_type *) DMA1MUX_CHANNEL4_BASE)
#define | DMA1MUX_CHANNEL5 ((dmamux_channel_type *) DMA1MUX_CHANNEL5_BASE)
#define | DMA1MUX_CHANNEL6 ((dmamux_channel_type *) DMA1MUX_CHANNEL6_BASE)
#define | DMA1MUX_CHANNEL7 ((dmamux_channel_type *) DMA1MUX_CHANNEL7_BASE)
#define | DMA1MUX_GENERATOR1 ((dmamux_generator_type *) DMA1MUX_GENERATOR1_BASE)
#define | DMA1MUX_GENERATOR2 ((dmamux_generator_type *) DMA1MUX_GENERATOR2_BASE)
#define | DMA1MUX_GENERATOR3 ((dmamux_generator_type *) DMA1MUX_GENERATOR3_BASE)
#define | DMA1MUX_GENERATOR4 ((dmamux_generator_type *) DMA1MUX_GENERATOR4_BASE)
#define | DMA2 ((dma_type *) DMA2_BASE)
#define | DMA2_CHANNEL1 ((dma_channel_type *) DMA2_CHANNEL1_BASE)
#define | DMA2_CHANNEL2 ((dma_channel_type *) DMA2_CHANNEL2_BASE)
#define | DMA2_CHANNEL3 ((dma_channel_type *) DMA2_CHANNEL3_BASE)
#define | DMA2_CHANNEL4 ((dma_channel_type *) DMA2_CHANNEL4_BASE)
#define | DMA2_CHANNEL5 ((dma_channel_type *) DMA2_CHANNEL5_BASE)
#define | DMA2_CHANNEL6 ((dma_channel_type *) DMA2_CHANNEL6_BASE)
#define | DMA2_CHANNEL7 ((dma_channel_type *) DMA2_CHANNEL7_BASE)
#define | DMA2MUX_CHANNEL1 ((dmamux_channel_type *) DMA2MUX_CHANNEL1_BASE)
#define | DMA2MUX_CHANNEL2 ((dmamux_channel_type *) DMA2MUX_CHANNEL2_BASE)
#define | DMA2MUX_CHANNEL3 ((dmamux_channel_type *) DMA2MUX_CHANNEL3_BASE)
#define | DMA2MUX_CHANNEL4 ((dmamux_channel_type *) DMA2MUX_CHANNEL4_BASE)
#define | DMA2MUX_CHANNEL5 ((dmamux_channel_type *) DMA2MUX_CHANNEL5_BASE)
#define | DMA2MUX_CHANNEL6 ((dmamux_channel_type *) DMA2MUX_CHANNEL6_BASE)
#define | DMA2MUX_CHANNEL7 ((dmamux_channel_type *) DMA2MUX_CHANNEL7_BASE)
#define | DMA2MUX_GENERATOR1 ((dmamux_generator_type *) DMA2MUX_GENERATOR1_BASE)
#define | DMA2MUX_GENERATOR2 ((dmamux_generator_type *) DMA2MUX_GENERATOR2_BASE)
#define | DMA2MUX_GENERATOR3 ((dmamux_generator_type *) DMA2MUX_GENERATOR3_BASE)
#define | DMA2MUX_GENERATOR4 ((dmamux_generator_type *) DMA2MUX_GENERATOR4_BASE)

Enumerations

enum | dma_dir_type { DMA_DIR_PERIPHERAL_TO_MEMORY = 0x0000 , DMA_DIR_MEMORY_TO_PERIPHERAL = 0x0010 , DMA_DIR_MEMORY_TO_MEMORY = 0x4000 }
dma direction type More...
enum | dma_peripheral_data_size_type { DMA_PERIPHERAL_DATA_WIDTH_BYTE = 0x00 , DMA_PERIPHERAL_DATA_WIDTH_HALFWORD = 0x01 , DMA_PERIPHERAL_DATA_WIDTH_WORD = 0x02 }
dma peripheral data size type More...
enum | dma_memory_data_size_type { DMA_MEMORY_DATA_WIDTH_BYTE = 0x00 , DMA_MEMORY_DATA_WIDTH_HALFWORD = 0x01 , DMA_MEMORY_DATA_WIDTH_WORD = 0x02 }
dma memory data size type More...
enum | dma_priority_level_type { DMA_PRIORITY_LOW = 0x00 , DMA_PRIORITY_MEDIUM = 0x01 , DMA_PRIORITY_HIGH = 0x02 , DMA_PRIORITY_VERY_HIGH = 0x03 }
dma priority level type More...
enum dmamux_requst_id_sel_type {
DMAMUX_DMAREQ_ID_REQ_G1 = 0x01 , DMAMUX_DMAREQ_ID_REQ_G2 = 0x02 , DMAMUX_DMAREQ_ID_REQ_G3 = 0x03 , DMAMUX_DMAREQ_ID_REQ_G4 = 0x04 ,
DMAMUX_DMAREQ_ID_ADC1 = 0x05 , DMAMUX_DMAREQ_ID_ADC2 = 0x24 , DMAMUX_DMAREQ_ID_ADC3 = 0x25 , DMAMUX_DMAREQ_ID_DAC1 = 0x06 ,
DMAMUX_DMAREQ_ID_DAC2 = 0x29 , DMAMUX_DMAREQ_ID_TMR6_OVERFLOW = 0x08 , DMAMUX_DMAREQ_ID_TMR7_OVERFLOW = 0x09 , DMAMUX_DMAREQ_ID_SPI1_RX = 0x0A ,
DMAMUX_DMAREQ_ID_SPI1_TX = 0x0B , DMAMUX_DMAREQ_ID_SPI2_RX = 0x0C , DMAMUX_DMAREQ_ID_SPI2_TX = 0x0D , DMAMUX_DMAREQ_ID_SPI3_RX = 0x0E ,
DMAMUX_DMAREQ_ID_SPI3_TX = 0x0F , DMAMUX_DMAREQ_ID_SPI4_RX = 0x6A , DMAMUX_DMAREQ_ID_SPI4_TX = 0x6B , DMAMUX_DMAREQ_ID_I2S2_EXT_RX = 0x6E ,
DMAMUX_DMAREQ_ID_I2S2_EXT_TX = 0x6F , DMAMUX_DMAREQ_ID_I2S3_EXT_RX = 0x70 , DMAMUX_DMAREQ_ID_I2S3_EXT_TX = 0x71 , DMAMUX_DMAREQ_ID_I2C1_RX = 0x10 ,
DMAMUX_DMAREQ_ID_I2C1_TX = 0x11 , DMAMUX_DMAREQ_ID_I2C2_RX = 0x12 , DMAMUX_DMAREQ_ID_I2C2_TX = 0x13 , DMAMUX_DMAREQ_ID_I2C3_RX = 0x14 ,
DMAMUX_DMAREQ_ID_I2C3_TX = 0x15 , DMAMUX_DMAREQ_ID_USART1_RX = 0x18 , DMAMUX_DMAREQ_ID_USART1_TX = 0x19 , DMAMUX_DMAREQ_ID_USART2_RX = 0x1A ,
DMAMUX_DMAREQ_ID_USART2_TX = 0x1B , DMAMUX_DMAREQ_ID_USART3_RX = 0x1C , DMAMUX_DMAREQ_ID_USART3_TX = 0x1D , DMAMUX_DMAREQ_ID_UART4_RX = 0x1E ,
DMAMUX_DMAREQ_ID_UART4_TX = 0x1F , DMAMUX_DMAREQ_ID_UART5_RX = 0x20 , DMAMUX_DMAREQ_ID_UART5_TX = 0x21 , DMAMUX_DMAREQ_ID_USART6_RX = 0x72 ,
DMAMUX_DMAREQ_ID_USART6_TX = 0x73 , DMAMUX_DMAREQ_ID_UART7_RX = 0x74 , DMAMUX_DMAREQ_ID_UART7_TX = 0x75 , DMAMUX_DMAREQ_ID_UART8_RX = 0x76 ,
DMAMUX_DMAREQ_ID_UART8_TX = 0x77 , DMAMUX_DMAREQ_ID_SDIO1 = 0x27 , DMAMUX_DMAREQ_ID_SDIO2 = 0x67 , DMAMUX_DMAREQ_ID_QSPI1 = 0x28 ,
DMAMUX_DMAREQ_ID_QSPI2 = 0x68 , DMAMUX_DMAREQ_ID_TMR1_CH1 = 0x2A , DMAMUX_DMAREQ_ID_TMR1_CH2 = 0x2B , DMAMUX_DMAREQ_ID_TMR1_CH3 = 0x2C ,
DMAMUX_DMAREQ_ID_TMR1_CH4 = 0x2D , DMAMUX_DMAREQ_ID_TMR1_OVERFLOW = 0x2E , DMAMUX_DMAREQ_ID_TMR1_TRIG = 0x2F , DMAMUX_DMAREQ_ID_TMR1_HALL = 0x30 ,
DMAMUX_DMAREQ_ID_TMR8_CH1 = 0x31 , DMAMUX_DMAREQ_ID_TMR8_CH2 = 0x32 , DMAMUX_DMAREQ_ID_TMR8_CH3 = 0x33 , DMAMUX_DMAREQ_ID_TMR8_CH4 = 0x34 ,
DMAMUX_DMAREQ_ID_TMR8_OVERFLOW = 0x35 , DMAMUX_DMAREQ_ID_TMR8_TRIG = 0x36 , DMAMUX_DMAREQ_ID_TMR8_HALL = 0x37 , DMAMUX_DMAREQ_ID_TMR2_CH1 = 0x38 ,
DMAMUX_DMAREQ_ID_TMR2_CH2 = 0x39 , DMAMUX_DMAREQ_ID_TMR2_CH3 = 0x3A , DMAMUX_DMAREQ_ID_TMR2_CH4 = 0x3B , DMAMUX_DMAREQ_ID_TMR2_OVERFLOW = 0x3C ,
DMAMUX_DMAREQ_ID_TMR2_TRIG = 0x7E , DMAMUX_DMAREQ_ID_TMR3_CH1 = 0x3D , DMAMUX_DMAREQ_ID_TMR3_CH2 = 0x3E , DMAMUX_DMAREQ_ID_TMR3_CH3 = 0x3F ,
DMAMUX_DMAREQ_ID_TMR3_CH4 = 0x40 , DMAMUX_DMAREQ_ID_TMR3_OVERFLOW = 0x41 , DMAMUX_DMAREQ_ID_TMR3_TRIG = 0x42 , DMAMUX_DMAREQ_ID_TMR4_CH1 = 0x43 ,
DMAMUX_DMAREQ_ID_TMR4_CH2 = 0x44 , DMAMUX_DMAREQ_ID_TMR4_CH3 = 0x45 , DMAMUX_DMAREQ_ID_TMR4_CH4 = 0x46 , DMAMUX_DMAREQ_ID_TMR4_OVERFLOW = 0x47 ,
DMAMUX_DMAREQ_ID_TMR4_TRIG = 0x7F , DMAMUX_DMAREQ_ID_TMR5_CH1 = 0x48 , DMAMUX_DMAREQ_ID_TMR5_CH2 = 0x49 , DMAMUX_DMAREQ_ID_TMR5_CH3 = 0x4A ,
DMAMUX_DMAREQ_ID_TMR5_CH4 = 0x4B , DMAMUX_DMAREQ_ID_TMR5_OVERFLOW = 0x4C , DMAMUX_DMAREQ_ID_TMR5_TRIG = 0x4D , DMAMUX_DMAREQ_ID_TMR20_CH1 = 0x56 ,
DMAMUX_DMAREQ_ID_TMR20_CH2 = 0x57 , DMAMUX_DMAREQ_ID_TMR20_CH3 = 0x58 , DMAMUX_DMAREQ_ID_TMR20_CH4 = 0x59 , DMAMUX_DMAREQ_ID_TMR20_OVERFLOW = 0x5A ,
DMAMUX_DMAREQ_ID_TMR20_TRIG = 0x5D , DMAMUX_DMAREQ_ID_TMR20_HALL = 0x5E , DMAMUX_DMAREQ_ID_DVP = 0x69
}
dmamux request type More...
enum dmamux_sync_id_sel_type {
DMAMUX_SYNC_ID_EXINT0 = 0x00 , DMAMUX_SYNC_ID_EXINT1 = 0x01 , DMAMUX_SYNC_ID_EXINT2 = 0x02 , DMAMUX_SYNC_ID_EXINT3 = 0x03 ,
DMAMUX_SYNC_ID_EXINT4 = 0x04 , DMAMUX_SYNC_ID_EXINT5 = 0x05 , DMAMUX_SYNC_ID_EXINT6 = 0x06 , DMAMUX_SYNC_ID_EXINT7 = 0x07 ,
DMAMUX_SYNC_ID_EXINT8 = 0x08 , DMAMUX_SYNC_ID_EXINT9 = 0x09 , DMAMUX_SYNC_ID_EXINT10 = 0x0A , DMAMUX_SYNC_ID_EXINT11 = 0x0B ,
DMAMUX_SYNC_ID_EXINT12 = 0x0C , DMAMUX_SYNC_ID_EXINT13 = 0x0D , DMAMUX_SYNC_ID_EXINT14 = 0x0E , DMAMUX_SYNC_ID_EXINT15 = 0x0F ,
DMAMUX_SYNC_ID_DMAMUX_CH1_EVT = 0x10 , DMAMUX_SYNC_ID_DMAMUX_CH2_EVT = 0x11 , DMAMUX_SYNC_ID_DMAMUX_CH3_EVT = 0x12 , DMAMUX_SYNC_ID_DMAMUX_CH4_EVT = 0x13 ,
DMAMUX_SYNC_ID_DMAMUX_CH5_EVT = 0x14 , DMAMUX_SYNC_ID_DMAMUX_CH6_EVT = 0x15 , DMAMUX_SYNC_ID_DMAMUX_CH7_EVT = 0x16
}
dmamux sync id type More...
enum | dmamux_sync_pol_type { DMAMUX_SYNC_POLARITY_DISABLE = 0x00 , DMAMUX_SYNC_POLARITY_RISING = 0x01 , DMAMUX_SYNC_POLARITY_FALLING = 0x02 , DMAMUX_SYNC_POLARITY_RISING_FALLING = 0x03 }
dmamux sync polarity type More...
enum dmamux_gen_id_sel_type {
DMAMUX_GEN_ID_EXINT0 = 0x00 , DMAMUX_GEN_ID_EXINT1 = 0x01 , DMAMUX_GEN_ID_EXINT2 = 0x02 , DMAMUX_GEN_ID_EXINT3 = 0x03 ,
DMAMUX_GEN_ID_EXINT4 = 0x04 , DMAMUX_GEN_ID_EXINT5 = 0x05 , DMAMUX_GEN_ID_EXINT6 = 0x06 , DMAMUX_GEN_ID_EXINT7 = 0x07 ,
DMAMUX_GEN_ID_EXINT8 = 0x08 , DMAMUX_GEN_ID_EXINT9 = 0x09 , DMAMUX_GEN_ID_EXINT10 = 0x0A , DMAMUX_GEN_ID_EXINT11 = 0x0B ,
DMAMUX_GEN_ID_EXINT12 = 0x0C , DMAMUX_GEN_ID_EXINT13 = 0x0D , DMAMUX_GEN_ID_EXINT14 = 0x0E , DMAMUX_GEN_ID_EXINT15 = 0x0F ,
DMAMUX_GEN_ID_DMAMUX_CH1_EVT = 0x10 , DMAMUX_GEN_ID_DMAMUX_CH2_EVT = 0x11 , DMAMUX_GEN_ID_DMAMUX_CH3_EVT = 0x12 , DMAMUX_GEN_ID_DMAMUX_CH4_EVT = 0x13 ,
DMAMUX_GEN_ID_DMAMUX_CH5_EVT = 0x14 , DMAMUX_GEN_ID_DMAMUX_CH6_EVT = 0x15 , DMAMUX_GEN_ID_DMAMUX_CH7_EVT = 0x16
}
dmamux generator id type More...
enum | dmamux_gen_pol_type { DMAMUX_GEN_POLARITY_DISABLE = 0x00 , DMAMUX_GEN_POLARITY_RISING = 0x01 , DMAMUX_GEN_POLARITY_FALLING = 0x02 , DMAMUX_GEN_POLARITY_RISING_FALLING = 0x03 }
dmamux generator polarity type More...

Functions

void | dma_reset (dma_channel_type *dmax_channely)
reset dmax channely register. More...
void | dma_data_number_set (dma_channel_type *dmax_channely, uint16_t data_number)
set the number of data to be transferred. More...
uint16_t | dma_data_number_get (dma_channel_type *dmax_channely)
get the number of data to be transferred. More...
void | dma_interrupt_enable (dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt. More...
void | dma_channel_enable (dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel. More...
flag_status | dma_flag_get (uint32_t dmax_flag)
dma flag get. More...
void | dma_flag_clear (uint32_t dmax_flag)
dma flag clear. More...
void | dma_default_para_init (dma_init_type *dma_init_struct)
dma init config with its default value. More...
void | dma_init (dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init. More...
void | dma_flexible_config (dma_type *dma_x, dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init. More...
void | dmamux_enable (dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux. More...
void | dmamux_init (dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init. More...
void | dmamux_sync_default_para_init (dmamux_sync_init_type *dmamux_sync_init_struct)
dmamux sync init struct config with its default value. More...
void | dmamux_sync_config (dmamux_channel_type *dmamux_channelx, dmamux_sync_init_type *dmamux_sync_init_struct)
dmamux synchronization config. More...
void | dmamux_generator_default_para_init (dmamux_gen_init_type *dmamux_gen_init_struct)
dmamux request generator init struct config with its default value. More...
void | dmamux_generator_config (dmamux_generator_type *dmamux_gen_x, dmamux_gen_init_type *dmamux_gen_init_struct)
dmamux request generator init. More...
void | dmamux_sync_interrupt_enable (dmamux_channel_type *dmamux_channelx, confirm_state new_state)
enable or disable the dmamux sync interrupts. More...
void | dmamux_generator_interrupt_enable (dmamux_generator_type *dmamux_gen_x, confirm_state new_state)
enable or disable the dmamux request generator interrupts. More...
flag_status | dmamux_sync_flag_get (dma_type *dma_x, uint32_t flag)
dmamux sync flag get. More...
void | dmamux_sync_flag_clear (dma_type *dma_x, uint32_t flag)
dmamux sync flag clear. More...
flag_status | dmamux_generator_flag_get (dma_type *dma_x, uint32_t flag)
dmamux request generator flag get. More...
void | dmamux_generator_flag_clear (dma_type *dma_x, uint32_t flag)
dmamux request generator flag clear. More...

Detailed Description

at32f435_437 dma header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_dma.h.


AT32F435/437 Firmwary Library: at32f435_437_dvp.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f435_437_dvp.h File Reference

at32f435_437 dvp header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct dvp_type

Macros

#define | DVP_CFD_EVT_FLAG ((uint32_t)0x00000001)
#define | DVP_OVR_EVT_FLAG ((uint32_t)0x00000002)
#define | DVP_ESE_EVT_FLAG ((uint32_t)0x00000004)
#define | DVP_VS_EVT_FLAG ((uint32_t)0x00000008)
#define | DVP_HS_EVT_FLAG ((uint32_t)0x00000010)
#define | DVP_CFD_INT_FLAG ((uint32_t)0x80000001)
#define | DVP_OVR_INT_FLAG ((uint32_t)0x80000002)
#define | DVP_ESE_INT_FLAG ((uint32_t)0x80000004)
#define | DVP_VS_INT_FLAG ((uint32_t)0x80000008)
#define | DVP_HS_INT_FLAG ((uint32_t)0x80000010)
#define | DVP_CFD_INT ((uint32_t)0x00000001)
#define | DVP_OVR_INT ((uint32_t)0x00000002)
#define | DVP_ESE_INT ((uint32_t)0x00000004)
#define | DVP_VS_INT ((uint32_t)0x00000008)
#define | DVP_HS_INT ((uint32_t)0x00000010)
#define | DVP ((dvp_type *) DVP_BASE)

Enumerations

enum | dvp_cfm_type { DVP_CAP_FUNC_MODE_CONTINUOUS = 0x00 , DVP_CAP_FUNC_MODE_SINGLE = 0x01 }
dvp cfm type More...
enum | dvp_sm_type { DVP_SYNC_MODE_HARDWARE = 0x00 , DVP_SYNC_MODE_EMBEDDED = 0x01 }
dvp sm type More...
enum | dvp_ckp_type { DVP_CLK_POLARITY_RISING = 0x00 , DVP_CLK_POLARITY_FALLING = 0x01 }
dvp ckp type More...
enum | dvp_hsp_type { DVP_HSYNC_POLARITY_HIGH = 0x00 , DVP_HSYNC_POLARITY_LOW = 0x01 }
dvp hsp type More...
enum | dvp_vsp_type { DVP_VSYNC_POLARITY_LOW = 0x00 , DVP_VSYNC_POLARITY_HIGH = 0x01 }
dvp vsp type More...
enum | dvp_bfrc_type { DVP_BFRC_ALL = 0x00 , DVP_BFRC_HALF = 0x01 , DVP_BFRC_QUARTER = 0x02 }
dvp bfrc type More...
enum | dvp_pdl_type { DVP_PIXEL_DATA_LENGTH_8 = 0x00 , DVP_PIXEL_DATA_LENGTH_10 = 0x01 , DVP_PIXEL_DATA_LENGTH_12 = 0x02 , DVP_PIXEL_DATA_LENGTH_14 = 0x03 }
dvp pdl type More...
enum | dvp_pcdc_type { DVP_PCDC_ALL = 0x00 , DVP_PCDC_ONE_IN_TWO = 0x01 , DVP_PCDC_ONE_IN_FOUR = 0x02 , DVP_PCDC_TWO_IN_FOUR = 0x03 }
dvp pcdc type More...
enum | dvp_pcds_type { DVP_PCDS_CAP_FIRST = 0x00 , DVP_PCDS_DROP_FIRST = 0x01 }
dvp pcds type More...
enum | dvp_lcdc_type { DVP_LCDC_ALL = 0x00 , DVP_LCDC_ONE_IN_TWO = 0x01 }
dvp lcdc type More...
enum | dvp_lcds_type { DVP_LCDS_CAP_FIRST = 0x00 , DVP_LCDS_DROP_FIRST = 0x01 }
dvp lcds type More...
enum | dvp_status_basic_type { DVP_STATUS_HSYN = 0x00 , DVP_STATUS_VSYN = 0x01 , DVP_STATUS_OFNE = 0x02 }
dvp status basic type More...
enum | dvp_pcdes_type { DVP_PCDES_CAP_FIRST = 0x00 , DVP_PCDES_DROP_FIRST = 0x01 }
dvp pcdes type More...
enum dvp_efdf_type {
DVP_EFDF_BYPASS = 0x00 , DVP_EFDF_YUV422_UYVY = 0x04 , DVP_EFDF_YUV422_YUYV = 0x05 , DVP_EFDF_RGB565_555 = 0x06 ,
DVP_EFDF_Y8 = 0x07
}
dvp efdf type More...
enum | dvp_idus_type { DVP_IDUS_MSB = 0x00 , DVP_IDUS_LSB = 0x01 }
dvp idus type More...
enum | dvp_dmabt_type { DVP_DMABT_SINGLE = 0x00 , DVP_DMABT_BURST = 0x01 }
dvp dmabt type More...
enum | dvp_hseid_type { DVP_HSEID_LINE_END = 0x00 , DVP_HSEID_LINE_START = 0x01 }
dvp hseid type More...
enum | dvp_vseid_type { DVP_VSEID_FRAME_END = 0x00 , DVP_VSEID_FRMAE_START = 0x01 }
dvp vseid type More...
enum | dvp_idun_type { DVP_IDUN_0 = 0x00 , DVP_IDUN_2 = 0x01 , DVP_IDUN_4 = 0x02 , DVP_IDUN_6 = 0x03 }
dvp idun type More...

Functions

void | dvp_reset (void)
reset the dvp register More...
void | dvp_capture_enable (confirm_state new_state)
enable or disable dvp capture More...
void | dvp_capture_mode_set (dvp_cfm_type cap_mode)
set dvp capture mode More...
void | dvp_window_crop_enable (confirm_state new_state)
set dvp cropping window enable More...
void | dvp_window_crop_set (uint16_t crop_x, uint16_t crop_y, uint16_t crop_w, uint16_t crop_h, uint8_t bytes)
set dvp cropping window configuration More...
void | dvp_jpeg_enable (confirm_state new_state)
enable or disable dvp jpeg More...
void | dvp_sync_mode_set (dvp_sm_type sync_mode)
set dvp synchronization mode More...
void | dvp_sync_code_set (uint8_t fmsc, uint8_t fmec, uint8_t lnsc, uint8_t lnec)
set dvp synchronization code configuration More...
void | dvp_sync_unmask_set (uint8_t fmsu, uint8_t fmeu, uint8_t lnsu, uint8_t lneu)
set dvp synchronization unmask configuration More...
void | dvp_pclk_polarity_set (dvp_ckp_type eage)
set dvp pixel clock polarity More...
void | dvp_hsync_polarity_set (dvp_hsp_type hsync_pol)
set dvp horizontal synchronization polarity More...
void | dvp_vsync_polarity_set (dvp_vsp_type vsync_pol)
set dvp vertical synchronization polarity More...
void | dvp_basic_frame_rate_control_set (dvp_bfrc_type dvp_bfrc)
config dvp basic frame rate control More...
void | dvp_pixel_data_length_set (dvp_pdl_type dvp_pdl)
config dvp pixel data length More...
void | dvp_enable (confirm_state new_state)
enable or disable dvp function More...
void | dvp_zoomout_select (dvp_pcdes_type dvp_pcdes)
set dvp zoomout select More...
void | dvp_zoomout_set (dvp_pcdc_type dvp_pcdc, dvp_pcds_type dvp_pcds, dvp_lcdc_type dvp_lcdc, dvp_lcds_type dvp_lcds)
set dvp zoomout configuration More...
flag_status | dvp_basic_status_get (dvp_status_basic_type dvp_status_basic)
get dvp basic status More...
void | dvp_interrupt_enable (uint32_t dvp_int, confirm_state new_state)
enable or disable dvp interrupt More...
flag_status | dvp_flag_get (uint32_t flag)
get dvp event/interrupt flag status More...
void | dvp_flag_clear (uint32_t flag)
clear dvp's pending flags More...
void | dvp_enhanced_scaling_resize_enable (confirm_state new_state)
set dvp enhanced image scaling resize enable More...
void | dvp_enhanced_scaling_resize_set (uint16_t src_w, uint16_t des_w, uint16_t src_h, uint16_t des_h)
set dvp enhanced image scaling resize configuration More...
void | dvp_enhanced_framerate_set (uint16_t efrcsf, uint16_t efrctf, confirm_state new_state)
set enhanced frame rate control configuration More...
void | dvp_monochrome_image_binarization_set (uint8_t mibthd, confirm_state new_state)
set dvp monochrome image binarization configuration More...
void | dvp_enhanced_data_format_set (dvp_efdf_type dvp_efdf)
set dvp enhanced function data format configuration More...
void | dvp_input_data_unused_set (dvp_idus_type dvp_idus, dvp_idun_type dvp_idun)
set dvp input data un-used condition/number configuration More...
void | dvp_dma_burst_set (dvp_dmabt_type dvp_dmabt)
set dvp dma burst transfer configuration More...
void | dvp_sync_event_interrupt_set (dvp_hseid_type dvp_hseid, dvp_vseid_type dvp_vseid)
set dvp hsync/vsync event interrupt strategy configuration More...

Detailed Description

at32f435_437 dvp header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_dvp.h.


AT32F435/437 Firmwary Library: at32f435_437_edma.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f435_437_edma.h File Reference

at32f435_437 edma header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct | edma_init_type
edma init type More...
struct | edmamux_sync_init_type
edmamux sync init type More...
struct | edmamux_gen_init_type
edmamux generator init type More...
struct | edma_type
type define edma register all More...
struct | edma_stream_type
type define edma stream register all More...
struct | edma_stream_link_list_type
type define edma stream link list pointer register More...
struct | edma_stream_2d_type
type define edma 2d register all More...
struct | edmamux_channel_type
type define edmamux muxsctrl register More...
struct | edmamux_generator_type
type define edmamux request generator register all More...

Macros

#define | EDMA_DMERR_INT ((uint32_t)0x00000002) /* edma direct mode error intterrupt */
#define | EDMA_DTERR_INT ((uint32_t)0x00000004) /* edma data transfer error intterrupt */
#define | EDMA_HDT_INT ((uint32_t)0x00000008) /* edma half data transfer intterrupt */
#define | EDMA_FDT_INT ((uint32_t)0x00000010) /* edma full data transfer intterrupt */
#define | EDMA_FERR_INT ((uint32_t)0x00000080) /* edma fifo error interrupt */
#define | EDMA_FERR1_FLAG ((uint32_t)0x10000001) /* edma stream1 fifo error flag */
#define | EDMA_DMERR1_FLAG ((uint32_t)0x10000004) /* edma stream1 direct mode error flag */
#define | EDMA_DTERR1_FLAG ((uint32_t)0x10000008) /* edma stream1 data transfer error flag */
#define | EDMA_HDT1_FLAG ((uint32_t)0x10000010) /* edma stream1 half data transfer flag */
#define | EDMA_FDT1_FLAG ((uint32_t)0x10000020) /* edma stream1 full data transfer flag */
#define | EDMA_FERR2_FLAG ((uint32_t)0x10000040) /* edma stream2 fifo error flag */
#define | EDMA_DMERR2_FLAG ((uint32_t)0x10000100) /* edma stream2 direct mode error flag */
#define | EDMA_DTERR2_FLAG ((uint32_t)0x10000200) /* edma stream2 data transfer error flag */
#define | EDMA_HDT2_FLAG ((uint32_t)0x10000400) /* edma stream2 half data transfer flag */
#define | EDMA_FDT2_FLAG ((uint32_t)0x10000800) /* edma stream2 full data transfer flag */
#define | EDMA_FERR3_FLAG ((uint32_t)0x10010000) /* edma stream3 fifo error flag */
#define | EDMA_DMERR3_FLAG ((uint32_t)0x10040000) /* edma stream3 direct mode error flag */
#define | EDMA_DTERR3_FLAG ((uint32_t)0x10080000) /* edma stream3 data transfer error flag */
#define | EDMA_HDT3_FLAG ((uint32_t)0x10100000) /* edma stream3 half data transfer flag */
#define | EDMA_FDT3_FLAG ((uint32_t)0x10200000) /* edma stream3 full data transfer flag */
#define | EDMA_FERR4_FLAG ((uint32_t)0x10400000) /* edma stream4 fifo error flag */
#define | EDMA_DMERR4_FLAG ((uint32_t)0x11000000) /* edma stream4 direct mode error flag */
#define | EDMA_DTERR4_FLAG ((uint32_t)0x12000000) /* edma stream4 data transfer error flag */
#define | EDMA_HDT4_FLAG ((uint32_t)0x14000000) /* edma stream4 half data transfer flag */
#define | EDMA_FDT4_FLAG ((uint32_t)0x18000000) /* edma stream4 full data transfer flag */
#define | EDMA_FERR5_FLAG ((uint32_t)0x20000001) /* edma stream5 fifo error flag */
#define | EDMA_DMERR5_FLAG ((uint32_t)0x20000004) /* edma stream5 direct mode error flag */
#define | EDMA_DTERR5_FLAG ((uint32_t)0x20000008) /* edma stream5 data transfer error flag */
#define | EDMA_HDT5_FLAG ((uint32_t)0x20000010) /* edma stream5 half data transfer flag */
#define | EDMA_FDT5_FLAG ((uint32_t)0x20000020) /* edma stream5 full data transfer flag */
#define | EDMA_FERR6_FLAG ((uint32_t)0x20000040) /* edma stream6 fifo error flag */
#define | EDMA_DMERR6_FLAG ((uint32_t)0x20000100) /* edma stream6 direct mode error flag */
#define | EDMA_DTERR6_FLAG ((uint32_t)0x20000200) /* edma stream6 data transfer error flag */
#define | EDMA_HDT6_FLAG ((uint32_t)0x20000400) /* edma stream6 half data transfer flag */
#define | EDMA_FDT6_FLAG ((uint32_t)0x20000800) /* edma stream6 full data transfer flag */
#define | EDMA_FERR7_FLAG ((uint32_t)0x20010000) /* edma stream7 fifo error flag */
#define | EDMA_DMERR7_FLAG ((uint32_t)0x20040000) /* edma stream7 direct mode error flag */
#define | EDMA_DTERR7_FLAG ((uint32_t)0x20080000) /* edma stream7 data transfer error flag */
#define | EDMA_HDT7_FLAG ((uint32_t)0x20100000) /* edma stream7 half data transfer flag */
#define | EDMA_FDT7_FLAG ((uint32_t)0x20200000) /* edma stream7 full data transfer flag */
#define | EDMA_FERR8_FLAG ((uint32_t)0x20400000) /* edma stream8 fifo error flag */
#define | EDMA_DMERR8_FLAG ((uint32_t)0x21000000) /* edma stream8 direct mode error flag */
#define | EDMA_DTERR8_FLAG ((uint32_t)0x22000000) /* edma stream8 data transfer error flag */
#define | EDMA_HDT8_FLAG ((uint32_t)0x24000000) /* edma stream8 half data transfer flag */
#define | EDMA_FDT8_FLAG ((uint32_t)0x28000000) /* edma stream8 full data transfer flag */
#define | EDMA_STREAM1_INT_MASK (uint32_t)(0x0000003D)
masks define More...
#define | EDMA_STREAM2_INT_MASK (uint32_t)(EDMA_STREAM1_INT_MASK << 6)
#define | EDMA_STREAM3_INT_MASK (uint32_t)(EDMA_STREAM1_INT_MASK << 16)
#define | EDMA_STREAM4_INT_MASK (uint32_t)(EDMA_STREAM1_INT_MASK << 22)
#define | EDMA_STREAM5_INT_MASK (uint32_t)(EDMA_STREAM1_INT_MASK)
#define | EDMA_STREAM6_INT_MASK (uint32_t)(EDMA_STREAM2_INT_MASK)
#define | EDMA_STREAM7_INT_MASK (uint32_t)(EDMA_STREAM3_INT_MASK)
#define | EDMA_STREAM8_INT_MASK (uint32_t)(EDMA_STREAM4_INT_MASK)
#define | EDMAMUX_SYNC_OV1_FLAG ((uint32_t)0x00000001)
edmamux flag More...
#define | EDMAMUX_SYNC_OV2_FLAG ((uint32_t)0x00000002)
#define | EDMAMUX_SYNC_OV3_FLAG ((uint32_t)0x00000004)
#define | EDMAMUX_SYNC_OV4_FLAG ((uint32_t)0x00000008)
#define | EDMAMUX_SYNC_OV5_FLAG ((uint32_t)0x00000010)
#define | EDMAMUX_SYNC_OV6_FLAG ((uint32_t)0x00000020)
#define | EDMAMUX_SYNC_OV7_FLAG ((uint32_t)0x00000040)
#define | EDMAMUX_SYNC_OV8_FLAG ((uint32_t)0x00000080)
#define | EDMAMUX_GEN_TRIG_OV1_FLAG ((uint32_t)0x00000001)
#define | EDMAMUX_GEN_TRIG_OV2_FLAG ((uint32_t)0x00000002)
#define | EDMAMUX_GEN_TRIG_OV3_FLAG ((uint32_t)0x00000004)
#define | EDMAMUX_GEN_TRIG_OV4_FLAG ((uint32_t)0x00000008)
#define | EDMA ((edma_type *) EDMA_BASE)
#define | EDMA_STREAM1 ((edma_stream_type *) EDMA_STREAM1_BASE)
#define | EDMA_STREAM2 ((edma_stream_type *) EDMA_STREAM2_BASE)
#define | EDMA_STREAM3 ((edma_stream_type *) EDMA_STREAM3_BASE)
#define | EDMA_STREAM4 ((edma_stream_type *) EDMA_STREAM4_BASE)
#define | EDMA_STREAM5 ((edma_stream_type *) EDMA_STREAM5_BASE)
#define | EDMA_STREAM6 ((edma_stream_type *) EDMA_STREAM6_BASE)
#define | EDMA_STREAM7 ((edma_stream_type *) EDMA_STREAM7_BASE)
#define | EDMA_STREAM8 ((edma_stream_type *) EDMA_STREAM8_BASE)
#define | EDMA_STREAM1_2D ((edma_stream_2d_type *) EDMA_STREAM1_2D_BASE)
#define | EDMA_STREAM2_2D ((edma_stream_2d_type *) EDMA_STREAM2_2D_BASE)
#define | EDMA_STREAM3_2D ((edma_stream_2d_type *) EDMA_STREAM3_2D_BASE)
#define | EDMA_STREAM4_2D ((edma_stream_2d_type *) EDMA_STREAM4_2D_BASE)
#define | EDMA_STREAM5_2D ((edma_stream_2d_type *) EDMA_STREAM5_2D_BASE)
#define | EDMA_STREAM6_2D ((edma_stream_2d_type *) EDMA_STREAM6_2D_BASE)
#define | EDMA_STREAM7_2D ((edma_stream_2d_type *) EDMA_STREAM7_2D_BASE)
#define | EDMA_STREAM8_2D ((edma_stream_2d_type *) EDMA_STREAM8_2D_BASE)
#define | EDMA_STREAM1_LL ((edma_stream_link_list_type *) EDMA_STREAM1_LL_BASE)
#define | EDMA_STREAM2_LL ((edma_stream_link_list_type *) EDMA_STREAM2_LL_BASE)
#define | EDMA_STREAM3_LL ((edma_stream_link_list_type *) EDMA_STREAM3_LL_BASE)
#define | EDMA_STREAM4_LL ((edma_stream_link_list_type *) EDMA_STREAM4_LL_BASE)
#define | EDMA_STREAM5_LL ((edma_stream_link_list_type *) EDMA_STREAM5_LL_BASE)
#define | EDMA_STREAM6_LL ((edma_stream_link_list_type *) EDMA_STREAM6_LL_BASE)
#define | EDMA_STREAM7_LL ((edma_stream_link_list_type *) EDMA_STREAM7_LL_BASE)
#define | EDMA_STREAM8_LL ((edma_stream_link_list_type *) EDMA_STREAM8_LL_BASE)
#define | EDMAMUX_CHANNEL1 ((edmamux_channel_type *) EDMAMUX_CHANNEL1_BASE)
#define | EDMAMUX_CHANNEL2 ((edmamux_channel_type *) EDMAMUX_CHANNEL2_BASE)
#define | EDMAMUX_CHANNEL3 ((edmamux_channel_type *) EDMAMUX_CHANNEL3_BASE)
#define | EDMAMUX_CHANNEL4 ((edmamux_channel_type *) EDMAMUX_CHANNEL4_BASE)
#define | EDMAMUX_CHANNEL5 ((edmamux_channel_type *) EDMAMUX_CHANNEL5_BASE)
#define | EDMAMUX_CHANNEL6 ((edmamux_channel_type *) EDMAMUX_CHANNEL6_BASE)
#define | EDMAMUX_CHANNEL7 ((edmamux_channel_type *) EDMAMUX_CHANNEL7_BASE)
#define | EDMAMUX_CHANNEL8 ((edmamux_channel_type *) EDMAMUX_CHANNEL8_BASE)
#define | EDMAMUX_GENERATOR1 ((edmamux_generator_type *) EDMAMUX_GENERATOR1_BASE)
#define | EDMAMUX_GENERATOR2 ((edmamux_generator_type *) EDMAMUX_GENERATOR2_BASE)
#define | EDMAMUX_GENERATOR3 ((edmamux_generator_type *) EDMAMUX_GENERATOR3_BASE)
#define | EDMAMUX_GENERATOR4 ((edmamux_generator_type *) EDMAMUX_GENERATOR4_BASE)

Enumerations

enum | edma_memory_type { EDMA_MEMORY_0 = 0x00 , EDMA_MEMORY_1 = 0x01 }
edma memory targets define More...
enum | edma_dir_type { EDMA_DIR_PERIPHERAL_TO_MEMORY = 0x00 , EDMA_DIR_MEMORY_TO_PERIPHERAL = 0x01 , EDMA_DIR_MEMORY_TO_MEMORY = 0x02 }
edma direction type More...
enum | edma_peripheral_data_size_type { EDMA_PERIPHERAL_DATA_WIDTH_BYTE = 0x00 , EDMA_PERIPHERAL_DATA_WIDTH_HALFWORD = 0x01 , EDMA_PERIPHERAL_DATA_WIDTH_WORD = 0x02 }
edma peripheral data size type More...
enum | edma_memory_data_size_type { EDMA_MEMORY_DATA_WIDTH_BYTE = 0x00 , EDMA_MEMORY_DATA_WIDTH_HALFWORD = 0x01 , EDMA_MEMORY_DATA_WIDTH_WORD = 0x02 }
edma memory data size type More...
enum | edma_priority_level_type { EDMA_PRIORITY_LOW = 0x00 , EDMA_PRIORITY_MEDIUM = 0x01 , EDMA_PRIORITY_HIGH = 0x02 , EDMA_PRIORITY_VERY_HIGH = 0x03 }
edma priority level type More...
enum | edma_fifo_threshold_type { EDMA_FIFO_THRESHOLD_1QUARTER = 0x00 , EDMA_FIFO_THRESHOLD_HALF = 0x01 , EDMA_FIFO_THRESHOLD_3QUARTER = 0x02 , EDMA_FIFO_THRESHOLD_FULL = 0x03 }
edma fifo threshold level type More...
enum edma_fifo_stutas_type {
EDMA_FIFO_STATUS_LESS_1QUARTER = 0x00 , EDMA_FIFO_STATUS_1QUARTER = 0x01 , EDMA_FIFO_STATUS_HALF = 0x02 , EDMA_FIFO_STATUS_3QUARTER = 0x03 ,
EDMA_FIFO_STATUS_EMPTY = 0x04 , EDMA_FIFO_STATUS_FULL = 0x05
}
edma fifo stutas level type More...
enum | edma_memory_burst_type { EDMA_MEMORY_SINGLE = 0x00 , EDMA_MEMORY_BURST_4 = 0x01 , EDMA_MEMORY_BURST_8 = 0x02 , EDMA_MEMORY_BURST_16 = 0x03 }
edma memory continuous mode type More...
enum | edma_peripheral_burst_type { EDMA_PERIPHERAL_SINGLE = 0x00 , EDMA_PERIPHERAL_BURST_4 = 0x01 , EDMA_PERIPHERAL_BURST_8 = 0x02 , EDMA_PERIPHERAL_BURST_16 = 0x03 }
edma peripheral continuous mode type More...
enum | edma_peripheral_inc_offset_type { EDMA_PERIPHERAL_INC_PSIZE = 0x00 , EDMA_PERIPHERAL_INC_4_BYTE = 0x01 }
edma peripheral increment offset size type More...
enum edmamux_requst_id_sel_type {
EDMAMUX_DMAREQ_ID_REQ_G1 = 0x01 , EDMAMUX_DMAREQ_ID_REQ_G2 = 0x02 , EDMAMUX_DMAREQ_ID_REQ_G3 = 0x03 , EDMAMUX_DMAREQ_ID_REQ_G4 = 0x04 ,
EDMAMUX_DMAREQ_ID_ADC1 = 0x05 , EDMAMUX_DMAREQ_ID_ADC2 = 0x24 , EDMAMUX_DMAREQ_ID_ADC3 = 0x25 , EDMAMUX_DMAREQ_ID_DAC1 = 0x06 ,
EDMAMUX_DMAREQ_ID_DAC2 = 0x29 , EDMAMUX_DMAREQ_ID_TMR6_OVERFLOW = 0x08 , EDMAMUX_DMAREQ_ID_TMR7_OVERFLOW = 0x09 , EDMAMUX_DMAREQ_ID_SPI1_RX = 0x0A ,
EDMAMUX_DMAREQ_ID_SPI1_TX = 0x0B , EDMAMUX_DMAREQ_ID_SPI2_RX = 0x0C , EDMAMUX_DMAREQ_ID_SPI2_TX = 0x0D , EDMAMUX_DMAREQ_ID_SPI3_RX = 0x0E ,
EDMAMUX_DMAREQ_ID_SPI3_TX = 0x0F , EDMAMUX_DMAREQ_ID_SPI4_RX = 0x6A , EDMAMUX_DMAREQ_ID_SPI4_TX = 0x6B , EDMAMUX_DMAREQ_ID_I2S2_EXT_RX = 0x6E ,
EDMAMUX_DMAREQ_ID_I2S2_EXT_TX = 0x6F , EDMAMUX_DMAREQ_ID_I2S3_EXT_RX = 0x70 , EDMAMUX_DMAREQ_ID_I2S3_EXT_TX = 0x71 , EDMAMUX_DMAREQ_ID_I2C1_RX = 0x10 ,
EDMAMUX_DMAREQ_ID_I2C1_TX = 0x11 , EDMAMUX_DMAREQ_ID_I2C2_RX = 0x12 , EDMAMUX_DMAREQ_ID_I2C2_TX = 0x13 , EDMAMUX_DMAREQ_ID_I2C3_RX = 0x14 ,
EDMAMUX_DMAREQ_ID_I2C3_TX = 0x15 , EDMAMUX_DMAREQ_ID_USART1_RX = 0x18 , EDMAMUX_DMAREQ_ID_USART1_TX = 0x19 , EDMAMUX_DMAREQ_ID_USART2_RX = 0x1A ,
EDMAMUX_DMAREQ_ID_USART2_TX = 0x1B , EDMAMUX_DMAREQ_ID_USART3_RX = 0x1C , EDMAMUX_DMAREQ_ID_USART3_TX = 0x1D , EDMAMUX_DMAREQ_ID_UART4_RX = 0x1E ,
EDMAMUX_DMAREQ_ID_UART4_TX = 0x1F , EDMAMUX_DMAREQ_ID_UART5_RX = 0x20 , EDMAMUX_DMAREQ_ID_UART5_TX = 0x21 , EDMAMUX_DMAREQ_ID_USART6_RX = 0x72 ,
EDMAMUX_DMAREQ_ID_USART6_TX = 0x73 , EDMAMUX_DMAREQ_ID_UART7_RX = 0x74 , EDMAMUX_DMAREQ_ID_UART7_TX = 0x75 , EDMAMUX_DMAREQ_ID_UART8_RX = 0x76 ,
EDMAMUX_DMAREQ_ID_UART8_TX = 0x77 , EDMAMUX_DMAREQ_ID_SDIO1 = 0x27 , EDMAMUX_DMAREQ_ID_SDIO2 = 0x67 , EDMAMUX_DMAREQ_ID_QSPI1 = 0x28 ,
EDMAMUX_DMAREQ_ID_QSPI2 = 0x68 , EDMAMUX_DMAREQ_ID_TMR1_CH1 = 0x2A , EDMAMUX_DMAREQ_ID_TMR1_CH2 = 0x2B , EDMAMUX_DMAREQ_ID_TMR1_CH3 = 0x2C ,
EDMAMUX_DMAREQ_ID_TMR1_CH4 = 0x2D , EDMAMUX_DMAREQ_ID_TMR1_OVERFLOW = 0x2E , EDMAMUX_DMAREQ_ID_TMR1_TRIG = 0x2F , EDMAMUX_DMAREQ_ID_TMR1_HALL = 0x30 ,
EDMAMUX_DMAREQ_ID_TMR8_CH1 = 0x31 , EDMAMUX_DMAREQ_ID_TMR8_CH2 = 0x32 , EDMAMUX_DMAREQ_ID_TMR8_CH3 = 0x33 , EDMAMUX_DMAREQ_ID_TMR8_CH4 = 0x34 ,
EDMAMUX_DMAREQ_ID_TMR8_OVERFLOW = 0x35 , EDMAMUX_DMAREQ_ID_TMR8_TRIG = 0x36 , EDMAMUX_DMAREQ_ID_TMR8_HALL = 0x37 , EDMAMUX_DMAREQ_ID_TMR2_CH1 = 0x38 ,
EDMAMUX_DMAREQ_ID_TMR2_CH2 = 0x39 , EDMAMUX_DMAREQ_ID_TMR2_CH3 = 0x3A , EDMAMUX_DMAREQ_ID_TMR2_CH4 = 0x3B , EDMAMUX_DMAREQ_ID_TMR2_OVERFLOW = 0x3C ,
EDMAMUX_DMAREQ_ID_TMR2_TRIG = 0x7E , EDMAMUX_DMAREQ_ID_TMR3_CH1 = 0x3D , EDMAMUX_DMAREQ_ID_TMR3_CH2 = 0x3E , EDMAMUX_DMAREQ_ID_TMR3_CH3 = 0x3F ,
EDMAMUX_DMAREQ_ID_TMR3_CH4 = 0x40 , EDMAMUX_DMAREQ_ID_TMR3_OVERFLOW = 0x41 , EDMAMUX_DMAREQ_ID_TMR3_TRIG = 0x42 , EDMAMUX_DMAREQ_ID_TMR4_CH1 = 0x43 ,
EDMAMUX_DMAREQ_ID_TMR4_CH2 = 0x44 , EDMAMUX_DMAREQ_ID_TMR4_CH3 = 0x45 , EDMAMUX_DMAREQ_ID_TMR4_CH4 = 0x46 , EDMAMUX_DMAREQ_ID_TMR4_OVERFLOW = 0x47 ,
EDMAMUX_DMAREQ_ID_TMR4_TRIG = 0x7F , EDMAMUX_DMAREQ_ID_TMR5_CH1 = 0x48 , EDMAMUX_DMAREQ_ID_TMR5_CH2 = 0x49 , EDMAMUX_DMAREQ_ID_TMR5_CH3 = 0x4A ,
EDMAMUX_DMAREQ_ID_TMR5_CH4 = 0x4B , EDMAMUX_DMAREQ_ID_TMR5_OVERFLOW = 0x4C , EDMAMUX_DMAREQ_ID_TMR5_TRIG = 0x4D , EDMAMUX_DMAREQ_ID_TMR20_CH1 = 0x56 ,
EDMAMUX_DMAREQ_ID_TMR20_CH2 = 0x57 , EDMAMUX_DMAREQ_ID_TMR20_CH3 = 0x58 , EDMAMUX_DMAREQ_ID_TMR20_CH4 = 0x59 , EDMAMUX_DMAREQ_ID_TMR20_OVERFLOW = 0x5A ,
EDMAMUX_DMAREQ_ID_TMR20_TRIG = 0x5D , EDMAMUX_DMAREQ_ID_TMR20_HALL = 0x5E , EDMAMUX_DMAREQ_ID_DVP = 0x69
}
edmamux request id select type More...
enum edmamux_sync_id_sel_type {
EDMAMUX_SYNC_ID_EXINT0 = 0x00 , EDMAMUX_SYNC_ID_EXINT1 = 0x01 , EDMAMUX_SYNC_ID_EXINT2 = 0x02 , EDMAMUX_SYNC_ID_EXINT3 = 0x03 ,
EDMAMUX_SYNC_ID_EXINT4 = 0x04 , EDMAMUX_SYNC_ID_EXINT5 = 0x05 , EDMAMUX_SYNC_ID_EXINT6 = 0x06 , EDMAMUX_SYNC_ID_EXINT7 = 0x07 ,
EDMAMUX_SYNC_ID_EXINT8 = 0x08 , EDMAMUX_SYNC_ID_EXINT9 = 0x09 , EDMAMUX_SYNC_ID_EXINT10 = 0x0A , EDMAMUX_SYNC_ID_EXINT11 = 0x0B ,
EDMAMUX_SYNC_ID_EXINT12 = 0x0C , EDMAMUX_SYNC_ID_EXINT13 = 0x0D , EDMAMUX_SYNC_ID_EXINT14 = 0x0E , EDMAMUX_SYNC_ID_EXINT15 = 0x0F ,
EDMAMUX_SYNC_ID_DMAMUX_CH1_EVT = 0x10 , EDMAMUX_SYNC_ID_DMAMUX_CH2_EVT = 0x11 , EDMAMUX_SYNC_ID_DMAMUX_CH3_EVT = 0x12 , EDMAMUX_SYNC_ID_DMAMUX_CH4_EVT = 0x13 ,
EDMAMUX_SYNC_ID_DMAMUX_CH5_EVT = 0x14 , EDMAMUX_SYNC_ID_DMAMUX_CH6_EVT = 0x15 , EDMAMUX_SYNC_ID_DMAMUX_CH7_EVT = 0x16 , EDMAMUX_SYNC_ID_DMAMUX_CH8_EVT = 0x17
}
dmamux sync id select type More...
enum | edmamux_sync_pol_type { EDMAMUX_SYNC_POLARITY_DISABLE = 0x00 , EDMAMUX_SYNC_POLARITY_RISING = 0x01 , EDMAMUX_SYNC_POLARITY_FALLING = 0x02 , EDMAMUX_SYNC_POLARITY_RISING_FALLING = 0x03 }
dmamux sync polarity type More...
enum edmamux_gen_id_sel_type {
EDMAMUX_GEN_ID_EXINT0 = 0x00 , EDMAMUX_GEN_ID_EXINT1 = 0x01 , EDMAMUX_GEN_ID_EXINT2 = 0x02 , EDMAMUX_GEN_ID_EXINT3 = 0x03 ,
EDMAMUX_GEN_ID_EXINT4 = 0x04 , EDMAMUX_GEN_ID_EXINT5 = 0x05 , EDMAMUX_GEN_ID_EXINT6 = 0x06 , EDMAMUX_GEN_ID_EXINT7 = 0x07 ,
EDMAMUX_GEN_ID_EXINT8 = 0x08 , EDMAMUX_GEN_ID_EXINT9 = 0x09 , EDMAMUX_GEN_ID_EXINT10 = 0x0A , EDMAMUX_GEN_ID_EXINT11 = 0x0B ,
EDMAMUX_GEN_ID_EXINT12 = 0x0C , EDMAMUX_GEN_ID_EXINT13 = 0x0D , EDMAMUX_GEN_ID_EXINT14 = 0x0E , EDMAMUX_GEN_ID_EXINT15 = 0x0F ,
EDMAMUX_GEN_ID_DMAMUX_CH1_EVT = 0x10 , EDMAMUX_GEN_ID_DMAMUX_CH2_EVT = 0x11 , EDMAMUX_GEN_ID_DMAMUX_CH3_EVT = 0x12 , EDMAMUX_GEN_ID_DMAMUX_CH4_EVT = 0x13 ,
EDMAMUX_GEN_ID_DMAMUX_CH5_EVT = 0x14 , EDMAMUX_GEN_ID_DMAMUX_CH6_EVT = 0x15 , EDMAMUX_GEN_ID_DMAMUX_CH7_EVT = 0x16 , EDMAMUX_GEN_ID_DMAMUX_CH8_EVT = 0x17
}
dmamux generator id select type More...
enum | edmamux_gen_pol_type { EDMAMUX_GEN_POLARITY_DISABLE = 0x00 , EDMAMUX_GEN_POLARITY_RISING = 0x01 , EDMAMUX_GEN_POLARITY_FALLING = 0x02 , EDMAMUX_GEN_POLARITY_RISING_FALLING = 0x03 }
dmamux generator polarity type More...

Functions

void | edma_reset (edma_stream_type *edma_streamx)
reset edma_streamx channely register. More...
void | edma_init (edma_stream_type *edma_streamx, edma_init_type *edma_init_struct)
edma init. More...
void | edma_default_para_init (edma_init_type *edma_init_struct)
edma init struct config with its default value. More...
void | edma_stream_enable (edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx. More...
void | edma_interrupt_enable (edma_stream_type *edma_streamx, uint32_t edma_int, confirm_state new_state)
enable or disable the edma streamx interrupts. More...
void | edma_peripheral_inc_offset_set (edma_stream_type *edma_streamx, edma_peripheral_inc_offset_type offset)
config the edma peripheral increment offset size mode. More...
void | edma_flow_controller_enable (edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx flow controller. More...
void | edma_data_number_set (edma_stream_type *edma_streamx, uint16_t data_number)
set the number of data to be transferred. More...
uint16_t | edma_data_number_get (edma_stream_type *edma_streamx)
get the number of data to be transferred. More...
void | edma_double_buffer_mode_init (edma_stream_type *edma_streamx, uint32_t memory1_addr, edma_memory_type current_memory)
config the the double buffer mode. More...
void | edma_double_buffer_mode_enable (edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the double memory mode. More...
void | edma_memory_addr_set (edma_stream_type *edma_streamx, uint32_t memory_addr, uint32_t memory_target)
config the memory address in double buffer mode. More...
edma_memory_type | edma_memory_target_get (edma_stream_type *edma_streamx)
get the current memory target. More...
flag_status | edma_stream_status_get (edma_stream_type *edma_streamx)
get the enable status of edma streamx. More...
uint8_t | edma_fifo_status_get (edma_stream_type *edma_streamx)
get the fifo level status. More...
flag_status | edma_flag_get (uint32_t edma_flag)
get the edma flag. More...
void | edma_flag_clear (uint32_t edma_flag)
clear the edma flag. More...
void | edma_2d_init (edma_stream_2d_type *edma_streamx_2d, int16_t src_stride, int16_t dst_stride, uint16_t xcnt, uint16_t ycnt)
initialize the edma 2d mode. More...
void | edma_2d_enable (edma_stream_2d_type *edma_streamx_2d, confirm_state new_state)
enable or disable the edma 2d mode. More...
void | edma_link_list_init (edma_stream_link_list_type *edma_streamx_ll, uint32_t pointer)
initialize the edma link list. More...
void | edma_link_list_enable (edma_stream_link_list_type *edma_streamx_ll, confirm_state new_state)
enable or disable the edma stream link list mode. More...
void | edmamux_enable (confirm_state new_state)
enable or disable the edma edmamux. More...
void | edmamux_init (edmamux_channel_type *edmamux_channelx, edmamux_requst_id_sel_type edmamux_req_id)
edmamux init. More...
void | edmamux_sync_default_para_init (edmamux_sync_init_type *edmamux_sync_init_struct)
edmamux sync init struct config with its default value. More...
void | edmamux_sync_config (edmamux_channel_type *edmamux_channelx, edmamux_sync_init_type *edmamux_sync_init_struct)
edmamux synchronization config. More...
void | edmamux_generator_default_para_init (edmamux_gen_init_type *edmamux_gen_init_struct)
edmamux request generator init struct config with its default value. More...
void | edmamux_generator_config (edmamux_generator_type *edmamux_gen_x, edmamux_gen_init_type *edmamux_gen_init_struct)
edmamux request generator init. More...
void | edmamux_sync_interrupt_enable (edmamux_channel_type *edmamux_channelx, confirm_state new_state)
enable or disable the edmamux sync interrupts. More...
void | edmamux_generator_interrupt_enable (edmamux_generator_type *edmamux_gen_x, confirm_state new_state)
enable or disable the edmamux request generator interrupts. More...
flag_status | edmamux_sync_flag_get (uint32_t flag)
edmamux sync flag get. More...
void | edmamux_sync_flag_clear (uint32_t flag)
edmamux sync flag clear. More...
flag_status | edmamux_generator_flag_get (uint32_t flag)
edmamux request generator flag get. More...
void | edmamux_generator_flag_clear (uint32_t flag)
edmamux request generator flag clear. More...

Detailed Description

at32f435_437 edma header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_edma.h.


AT32F435/437 Firmwary Library: at32f435_437_emac.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f435_437_emac.h File Reference

at32f435_437 eth header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct | emac_control_config_type
ethernet mac control config type More...
struct | emac_dma_config_type
ethernet mac dma config type More...
struct | emac_dma_desc_type
dma desciptors data structure definition More...
struct | emac_type
type define emac mac register all More...
struct | emac_mmc_type
type define emac mmc register all More...
struct | emac_ptp_type
type define emac ptp register all More...
struct | emac_dma_type
type define emac ptp register all More...

Macros

#define | PHY_TIMEOUT (0x000FFFFF)
#define | EMAC_HCLK_BORDER_20MHZ (20000000)
#define | EMAC_HCLK_BORDER_35MHZ (35000000)
#define | EMAC_HCLK_BORDER_60MHZ (60000000)
#define | EMAC_HCLK_BORDER_100MHZ (100000000)
#define | EMAC_HCLK_BORDER_150MHZ (150000000)
#define | EMAC_HCLK_BORDER_250MHZ (250000000)
#define | EMAC_HCLK_BORDER_288MHZ (288000000)
#define | EMAC_PMT_FLAG ((uint32_t)0x00000008)
#define | EMAC_MMC_FLAG ((uint32_t)0x00000010)
#define | EMAC_MMCR_FLAG ((uint32_t)0x00000020)
#define | EMAC_MMCT_FLAG ((uint32_t)0x00000040)
#define | EMAC_TST_FLAG ((uint32_t)0x00000200)
#define | MMC_RX_CRC_ERROR ((uint32_t)0x00000020)
#define | MMC_RX_ALIGN_ERROR ((uint32_t)0x00000040)
#define | MMC_RX_GOOD_UNICAST ((uint32_t)0x00020000)
#define | MMC_TX_SINGLE_COL ((uint32_t)0x00004000)
#define | MMC_TX_MULTIPLE_COL ((uint32_t)0x00008000)
#define | MMC_TX_GOOD_FRAMES ((uint32_t)0x00200000)
#define | EMAC_MAX_PACKET_LENGTH 1520
#define | EMAC_HEADER 14
#define | EMAC_CRC 4
#define | EMAC_EXTRA 2
#define | VLAN_TAG 4
#define | EMAC_MIN_PAYLOAD 46
#define | EMAC_MAX_PAYLOAD 1500
#define | JUMBO_FRAME_PAYLOAD 9000
#define | EMAC_DMARXDESC_FRAME_LENGTHSHIFT 16
#define | EMAC_DMATXDESC_OWN ((uint32_t)0x80000000)
#define | EMAC_DMATXDESC_IC ((uint32_t)0x40000000)
#define | EMAC_DMATXDESC_LS ((uint32_t)0x20000000)
#define | EMAC_DMATXDESC_FS ((uint32_t)0x10000000)
#define | EMAC_DMATXDESC_DC ((uint32_t)0x08000000)
#define | EMAC_DMATXDESC_DP ((uint32_t)0x04000000)
#define | EMAC_DMATXDESC_TTSE ((uint32_t)0x02000000)
#define | EMAC_DMATXDESC_CIC ((uint32_t)0x00C00000)
#define | EMAC_DMATXDESC_CIC_BYPASS ((uint32_t)0x00000000)
#define | EMAC_DMATXDESC_CIC_IPV4HEADER ((uint32_t)0x00400000)
#define | EMAC_DMATXDESC_CIC_TUI_SEG ((uint32_t)0x00800000)
#define | EMAC_DMATXDESC_CIC_TUI_FULL ((uint32_t)0x00C00000)
#define | EMAC_DMATXDESC_TER ((uint32_t)0x00200000)
#define | EMAC_DMATXDESC_TCH ((uint32_t)0x00100000)
#define | EMAC_DMATXDESC_TTSS ((uint32_t)0x00020000)
#define | EMAC_DMATXDESC_IHE ((uint32_t)0x00010000)
#define | EMAC_DMATXDESC_ES ((uint32_t)0x00008000)
#define | EMAC_DMATXDESC_JT ((uint32_t)0x00004000)
#define | EMAC_DMATXDESC_FF ((uint32_t)0x00002000)
#define | EMAC_DMATXDESC_PCE ((uint32_t)0x00001000)
#define | EMAC_DMATXDESC_LCA ((uint32_t)0x00000800)
#define | EMAC_DMATXDESC_NC ((uint32_t)0x00000400)
#define | EMAC_DMATXDESC_LCO ((uint32_t)0x00000200)
#define | EMAC_DMATXDESC_EC ((uint32_t)0x00000100)
#define | EMAC_DMATXDESC_VF ((uint32_t)0x00000080)
#define | EMAC_DMATXDESC_CC ((uint32_t)0x00000078)
#define | EMAC_DMATXDESC_ED ((uint32_t)0x00000004)
#define | EMAC_DMATXDESC_UF ((uint32_t)0x00000002)
#define | EMAC_DMATXDESC_DB ((uint32_t)0x00000001)
#define | EMAC_DMATXDESC_TBS2 ((uint32_t)0x1FFF0000)
#define | EMAC_DMATXDESC_TBS1 ((uint32_t)0x00001FFF)
#define | EMAC_DMATXDESC_B1AP ((uint32_t)0xFFFFFFFF)
#define | EMAC_DMATxDesc_B2AP ((uint32_t)0xFFFFFFFF)
#define | EMAC_DMARXDESC_OWN ((uint32_t)0x80000000)
#define | EMAC_DMARXDESC_AFM ((uint32_t)0x40000000)
#define | EMAC_DMARXDESC_FL ((uint32_t)0x3FFF0000)
#define | EMAC_DMARXDESC_ES ((uint32_t)0x00008000)
#define | EMAC_DMARXDESC_DE ((uint32_t)0x00004000)
#define | EMAC_DMARXDESC_SAF ((uint32_t)0x00002000)
#define | EMAC_DMARXDESC_LE ((uint32_t)0x00001000)
#define | EMAC_DMARXDESC_OE ((uint32_t)0x00000800)
#define | EMAC_DMARXDESC_VLAN ((uint32_t)0x00000400)
#define | EMAC_DMARXDESC_FS ((uint32_t)0x00000200)
#define | EMAC_DMARXDESC_LS ((uint32_t)0x00000100)
#define | EMAC_DMARXDESC_IPV4HCE ((uint32_t)0x00000080)
#define | EMAC_DMARXDESC_LC ((uint32_t)0x00000040)
#define | EMAC_DMARXDESC_FT ((uint32_t)0x00000020)
#define | EMAC_DMARXDESC_RWT ((uint32_t)0x00000010)
#define | EMAC_DMARXDESC_RE ((uint32_t)0x00000008)
#define | EMAC_DMARXDESC_DBE ((uint32_t)0x00000004)
#define | EMAC_DMARXDESC_CE ((uint32_t)0x00000002)
#define | EMAC_DMARXDESC_MAMPCE ((uint32_t)0x00000001)
#define | EMAC_DMARXDESC_DIC ((uint32_t)0x80000000)
#define | EMAC_DMARXDESC_RBS2 ((uint32_t)0x1FFF0000)
#define | EMAC_DMARXDESC_RER ((uint32_t)0x00008000)
#define | EMAC_DMARXDESC_RCH ((uint32_t)0x00004000)
#define | EMAC_DMARXDESC_RBS1 ((uint32_t)0x00001FFF)
#define | EMAC_DMARXDESC_B1AP ((uint32_t)0xFFFFFFFF)
#define | EMAC_DMARXDESC_B2AP ((uint32_t)0xFFFFFFFF)
#define | EMAC_DMA_TI_FLAG ((uint32_t)0x00000001)
emac dma flag More...
#define | EMAC_DMA_TPS_FLAG ((uint32_t)0x00000002)
#define | EMAC_DMA_TBU_FLAG ((uint32_t)0x00000004)
#define | EMAC_DMA_TJT_FLAG ((uint32_t)0x00000008)
#define | EMAC_DMA_OVF_FLAG ((uint32_t)0x00000010)
#define | EMAC_DMA_UNF_FLAG ((uint32_t)0x00000020)
#define | EMAC_DMA_RI_FLAG ((uint32_t)0x00000040)
#define | EMAC_DMA_RBU_FLAG ((uint32_t)0x00000080)
#define | EMAC_DMA_RPS_FLAG ((uint32_t)0x00000100)
#define | EMAC_DMA_RWT_FLAG ((uint32_t)0x00000200)
#define | EMAC_DMA_ETI_FLAG ((uint32_t)0x00000400)
#define | EMAC_DMA_FBEI_FLAG ((uint32_t)0x00002000)
#define | EMAC_DMA_ERI_FLAG ((uint32_t)0x00004000)
#define | EMAC_DMA_AIS_FLAG ((uint32_t)0x00008000)
#define | EMAC_DMA_NIS_FLAG ((uint32_t)0x00010000)
#define | EMAC ((emac_type *) EMAC_BASE)
#define | EMAC_MMC ((emac_mmc_type *) EMAC_MMC_BASE)
#define | EMAC_PTP ((emac_ptp_type *) EMAC_PTP_BASE)
#define | EMAC_DMA ((emac_dma_type *) EMAC_DMA_BASE)

Enumerations

enum | emac_auto_negotiation_type { EMAC_AUTO_NEGOTIATION_OFF = 0x00 , EMAC_AUTO_NEGOTIATION_ON = 0x01 }
emac auto negotiation type More...
enum | emac_bol_type { EMAC_BACKOFF_LIMIT_0 = 0x00 , EMAC_BACKOFF_LIMIT_1 = 0x01 , EMAC_BACKOFF_LIMIT_2 = 0x02 , EMAC_BACKOFF_LIMIT_3 = 0x03 }
emac back_off limit type More...
enum | emac_duplex_type { EMAC_HALF_DUPLEX = 0x00 , EMAC_FULL_DUPLEX = 0x01 }
emac duplex type More...
enum | emac_speed_type { EMAC_SPEED_10MBPS = 0x00 , EMAC_SPEED_100MBPS = 0x01 }
emac speed type More...
enum emac_intergrame_gap_type {
EMAC_INTERFRAME_GAP_96BIT = 0x00 , EMAC_INTERFRAME_GAP_88BIT = 0x01 , EMAC_INTERFRAME_GAP_80BIT = 0x02 , EMAC_INTERFRAME_GAP_72BIT = 0x03 ,
EMAC_INTERFRAME_GAP_64BIT = 0x04 , EMAC_INTERFRAME_GAP_56BIT = 0x05 , EMAC_INTERFRAME_GAP_48BIT = 0x06 , EMAC_INTERFRAME_GAP_40BIT = 0x07
}
emac interframe gap type More...
enum emac_clock_range_type {
EMAC_CLOCK_RANGE_60_TO_100 = 0x00 , EMAC_CLOCK_RANGE_100_TO_150 = 0x01 , EMAC_CLOCK_RANGE_20_TO_35 = 0x02 , EMAC_CLOCK_RANGE_35_TO_60 = 0x03 ,
EMAC_CLOCK_RANGE_150_TO_250 = 0x04 , EMAC_CLOCK_RANGE_250_TO_288 = 0x05
}
mdc clock range type More...
enum | emac_control_frames_filter_type { EMAC_CONTROL_FRAME_PASSING_NO = 0x00 , EMAC_CONTROL_FRAME_PASSING_ALL = 0x02 , EMAC_CONTROL_FRAME_PASSING_MATCH = 0x03 }
emac control frames filter type More...
enum | emac_pause_slot_threshold_type { EMAC_PAUSE_4_SLOT_TIME = 0x00 , EMAC_PAUSE_28_SLOT_TIME = 0x01 , EMAC_PAUSE_144_SLOT_TIME = 0x02 , EMAC_PAUSE_256_SLOT_TIME = 0x03 }
pause threshold type More...
enum | emac_interrupt_mask_type { EMAC_INTERRUPT_PMT_MASK = 0x00 , EMAC_INTERRUPT_TST_MASK = 0x01 }
interrupt mask type More...
enum | emac_address_type { EMAC_ADDRESS_FILTER_1 = 0x01 , EMAC_ADDRESS_FILTER_2 = 0x02 , EMAC_ADDRESS_FILTER_3 = 0x03 }
mac address type More...
enum | emac_address_filter_type { EMAC_DESTINATION_FILTER = 0x00 , EMAC_SOURCE_FILTER = 0x01 }
address filter type More...
enum emac_address_mask_type {
EMAC_ADDRESS_MASK_8L0 = 0x01 , EMAC_ADDRESS_MASK_15L8 = 0x02 , EMAC_ADDRESS_MASK_23L16 = 0x04 , EMAC_ADDRESS_MASK_31L24 = 0x08 ,
EMAC_ADDRESS_MASK_7H0 = 0x10 , EMAC_ADDRESS_MASK_15H8 = 0x20
}
address mask type More...
enum | emac_dma_rx_tx_ratio_type { EMAC_DMA_1_RX_1_TX = 0x00 , EMAC_DMA_2_RX_1_TX = 0x01 , EMAC_DMA_3_RX_1_TX = 0x02 , EMAC_DMA_4_RX_1_TX = 0x03 }
rx tx priority ratio type More...
enum emac_dma_pbl_type {
EMAC_DMA_PBL_1 = 0x01 , EMAC_DMA_PBL_2 = 0x02 , EMAC_DMA_PBL_4 = 0x04 , EMAC_DMA_PBL_8 = 0x08 ,
EMAC_DMA_PBL_16 = 0x10 , EMAC_DMA_PBL_32 = 0x20
}
programmable burst length More...
enum | emac_dma_tx_rx_type { EMAC_DMA_TRANSMIT = 0x00 , EMAC_DMA_RECEIVE = 0x01 }
dma tx rx type More...
enum emac_dma_receive_process_status_type {
EMAC_DMA_RX_RESET_STOP_COMMAND = 0x00 , EMAC_DMA_RX_FETCH_DESCRIPTOR = 0x01 , EMAC_DMA_RX_WAITING_PACKET = 0x03 , EMAC_DMA_RX_DESCRIPTOR_UNAVAILABLE = 0x04 ,
EMAC_DMA_RX_CLOSE_DESCRIPTOR = 0x05 , EMAC_DMA_RX_FIFO_TO_HOST = 0x07
}
dma receive process status type More...
enum emac_dma_transmit_process_status_type {
EMAC_DMA_TX_RESET_STOP_COMMAND = 0x00 , EMAC_DMA_TX_FETCH_DESCRIPTOR = 0x01 , EMAC_DMA_TX_WAITING_FOR_STATUS = 0x02 , EMAC_DMA_TX_HOST_TO_FIFO = 0x03 ,
EMAC_DMA_TX_DESCRIPTOR_UNAVAILABLE = 0x06 , EMAC_DMA_TX_CLOSE_DESCRIPTOR = 0x07
}
dma transmit process status type More...
enum emac_dma_operations_type {
EMAC_DMA_OPS_START_STOP_RECEIVE = 0x00 , EMAC_DMA_OPS_SECOND_FRAME = 0x01 , EMAC_DMA_OPS_FORWARD_UNDERSIZED = 0x02 , EMAC_DMA_OPS_FORWARD_ERROR = 0x03 ,
EMAC_DMA_OPS_START_STOP_TRANSMIT = 0x04 , EMAC_DMA_OPS_FLUSH_TRANSMIT_FIFO = 0x05 , EMAC_DMA_OPS_TRANSMIT_STORE_FORWARD = 0x06 , EMAC_DMA_OPS_RECEIVE_FLUSH_DISABLE = 0x07 ,
EMAC_DMA_OPS_RECEIVE_STORE_FORWARD = 0x08 , EMAC_DMA_OPS_DROP_ERROR_DISABLE = 0x09
}
dma operations type More...
enum | emac_dma_receive_threshold_type { EMAC_DMA_RX_THRESHOLD_64_BYTES = 0x00 , EMAC_DMA_RX_THRESHOLD_32_BYTES = 0x01 , EMAC_DMA_RX_THRESHOLD_96_BYTES = 0x02 , EMAC_DMA_RX_THRESHOLD_128_BYTES = 0x03 }
receive threshold control type More...
enum emac_dma_transmit_threshold_type {
EMAC_DMA_TX_THRESHOLD_64_BYTES = 0x00 , EMAC_DMA_TX_THRESHOLD_128_BYTES = 0x01 , EMAC_DMA_TX_THRESHOLD_192_BYTES = 0x02 , EMAC_DMA_TX_THRESHOLD_256_BYTES = 0x03 ,
EMAC_DMA_TX_THRESHOLD_40_BYTES = 0x04 , EMAC_DMA_TX_THRESHOLD_32_BYTES = 0x05 , EMAC_DMA_TX_THRESHOLD_24_BYTES = 0x06 , EMAC_DMA_TX_THRESHOLD_16_BYTES = 0x07
}
transmit threshold control type More...
enum emac_dma_interrupt_type {
EMAC_DMA_INTERRUPT_TX = 0x00 , EMAC_DMA_INTERRUPT_TX_STOP = 0x01 , EMAC_DMA_INTERRUPT_TX_UNAVAILABLE = 0x02 , EMAC_DMA_INTERRUPT_TX_JABBER = 0x03 ,
EMAC_DMA_INTERRUPT_RX_OVERFLOW = 0x04 , EMAC_DMA_INTERRUPT_TX_UNDERFLOW = 0x05 , EMAC_DMA_INTERRUPT_RX = 0x06 , EMAC_DMA_INTERRUPT_RX_UNAVAILABLE = 0x07 ,
EMAC_DMA_INTERRUPT_RX_STOP = 0x08 , EMAC_DMA_INTERRUPT_RX_TIMEOUT = 0x09 , EMAC_DMA_INTERRUPT_TX_EARLY = 0x0A , EMAC_DMA_INTERRUPT_FATAL_BUS_ERROR = 0x0B ,
EMAC_DMA_INTERRUPT_RX_EARLY = 0x0C , EMAC_DMA_INTERRUPT_ABNORMAL_SUMMARY = 0x0D , EMAC_DMA_INTERRUPT_NORMAL_SUMMARY = 0x0E
}
dma interrupt type More...
enum | emac_dma_transfer_address_type { EMAC_DMA_TX_DESCRIPTOR = 0x00 , EMAC_DMA_RX_DESCRIPTOR = 0x01 , EMAC_DMA_TX_BUFFER = 0x02 , EMAC_DMA_RX_BUFFER = 0x03 }
dma tansfer address type More...
enum | emac_ptp_clock_node_type { EMAC_PTP_NORMAL_CLOCK = 0x00 , EMAC_PTP_BOUNDARY_CLOCK = 0x01 , EMAC_PTP_END_TO_END_CLOCK = 0x02 , EMAC_PTP_PEER_TO_PEER_CLOCK = 0x03 }
clock node type More...
enum | emac_ptp_timestamp_status_type { EMAC_PTP_SECOND_OVERFLOW = 0x00 , EMAC_PTP_TARGET_TIME_REACH = 0x01 }
time stamp status type More...
enum emac_ptp_pps_control_type {
EMAC_PTP_PPS_1HZ = 0x00 , EMAC_PTP_PPS_2HZ = 0x01 , EMAC_PTP_PPS_4HZ = 0x02 , EMAC_PTP_PPS_8HZ = 0x03 ,
EMAC_PTP_PPS_16HZ = 0x04 , EMAC_PTP_PPS_32HZ = 0x05 , EMAC_PTP_PPS_64HZ = 0x06 , EMAC_PTP_PPS_128HZ = 0x07 ,
EMAC_PTP_PPS_256HZ = 0x08 , EMAC_PTP_PPS_512HZ = 0x09 , EMAC_PTP_PPS_1024HZ = 0x0A , EMAC_PTP_PPS_2048HZ = 0x0B ,
EMAC_PTP_PPS_4096HZ = 0x0C , EMAC_PTP_PPS_8192HZ = 0x0D , EMAC_PTP_PPS_16384HZ = 0x0E , EMAC_PTP_PPS_32768HZ = 0x0F
}
pps control type More...

Functions

void | emac_reset (void)
deinitialize the emac peripheral registers to their default reset values. More...
void | emac_clock_range_set (void)
according to hclk to set mdc clock frequency. More...
void | emac_dma_software_reset_set (void)
reset emac dma More...
flag_status | emac_dma_software_reset_get (void)
get emac dma reset status More...
void | emac_start (void)
enable emac and dma reception/transmission More...
void | emac_stop (void)
stop emac and dma reception/transmission More...
error_status | emac_phy_register_write (uint8_t address, uint8_t reg, uint16_t data)
write phy data. More...
error_status | emac_phy_register_read (uint8_t address, uint8_t reg, uint16_t *data)
read phy data More...
void | emac_control_para_init (emac_control_config_type *control_para)
initialize emac control structure More...
void | emac_control_config (emac_control_config_type *control_struct)
configure emac control setting. More...
void | emac_receiver_enable (confirm_state new_state)
emac receiver enable. More...
void | emac_trasmitter_enable (confirm_state new_state)
emac transmitter enable. More...
void | emac_deferral_check_set (confirm_state new_state)
emac defferal check enable, only avalible in half-duplex mode. More...
void | emac_backoff_limit_set (emac_bol_type slot_time)
emac back-off limit, only avalible in half-duplex mode. More...
void | emac_auto_pad_crc_stripping_set (confirm_state new_state)
set mac automatic pad/CRC stripping. More...
void | emac_retry_disable (confirm_state new_state)
transmittion retry disable. More...
void | emac_ipv4_checksum_offload_set (confirm_state new_state)
set ipv4 checksum offload. More...
void | emac_loopback_mode_enable (confirm_state new_state)
enable loopback mode. More...
void | emac_receive_own_disable (confirm_state new_state)
receive own disable. More...
void | emac_carrier_sense_disable (confirm_state new_state)
carrier sense disbale. More...
void | emac_interframe_gap_set (emac_intergrame_gap_type number)
set minimum interframe gap between frames during transmission. More...
void | emac_jabber_disable (confirm_state new_state)
jabber disable. More...
void | emac_watchdog_disable (confirm_state new_state)
watchdog disable. More...
void | emac_fast_speed_set (emac_speed_type speed)
set mac fast emac speed. More...
void | emac_duplex_mode_set (emac_duplex_type duplex_mode)
set duplex mode. More...
void | emac_promiscuous_mode_set (confirm_state new_state)
set mac promiscuous mode. More...
void | emac_hash_unicast_set (confirm_state new_state)
hash unicast. More...
void | emac_hash_multicast_set (confirm_state new_state)
hash multicast. More...
void | emac_dstaddr_inverse_filter_set (confirm_state new_state)
destination address inverse filtering. More...
void | emac_pass_all_multicasting_set (confirm_state new_state)
pass all multicasting frames. More...
void | emac_broadcast_frames_disable (confirm_state new_state)
broadcast frames disable. More...
void | emac_pass_control_frames_set (emac_control_frames_filter_type condition)
set mac how to pass control frames. More...
void | emac_srcaddr_inverse_filter_set (confirm_state new_state)
source address inverse filtering. More...
void | emac_srcaddr_filter_set (confirm_state new_state)
source address filtering. More...
void | emac_hash_perfect_filter_set (confirm_state new_state)
mac uses hash or perfect filter. More...
void | emac_receive_all_set (confirm_state new_state)
mac receives all frames. More...
void | emac_hash_table_high32bits_set (uint32_t high32bits)
hash table high 32-bit. More...
void | emac_hash_table_low32bits_set (uint32_t low32bits)
hash table low 32-bit. More...
flag_status | emac_mii_busy_get (void)
mii busy status. More...
void | emac_mii_write (confirm_state new_state)
tell phy that will be written. More...
void | emac_fcb_bpa_set (confirm_state new_state)
set flow control busy in full-duplex mode, back pressure activate in half-duplex mode. More...
void | emac_transmit_flow_control_enable (confirm_state new_state)
set transmit flow control. More...
void | emac_receive_flow_control_enable (confirm_state new_state)
set receive flow control. More...
void | emac_unicast_pause_frame_detect (confirm_state new_state)
set unicast pause frame detect. More...
void | emac_pause_low_threshold_set (emac_pause_slot_threshold_type pasue_threshold)
set pause low threshold. More...
void | emac_zero_quanta_pause_disable (confirm_state new_state)
set zero-quanta pause disable. More...
void | emac_pause_time_set (uint16_t pause_time)
set pause time. More...
void | emac_vlan_tag_identifier_set (uint16_t identifier)
identify coming vlan frame field with setting value. More...
void | emac_vlan_tag_comparison_set (confirm_state new_state)
set 12-bit vlan identifier. More...
void | emac_wakeup_frame_set (uint32_t value)
set wakeup frame. More...
uint32_t | emac_wakeup_frame_get (void)
get wakeup frame. More...
void | emac_power_down_set (confirm_state new_state)
all frame will be droppped except wakeup frame or magic packet. More...
void | emac_magic_packet_enable (confirm_state new_state)
magic packet enable More...
void | emac_wakeup_frame_enable (confirm_state new_state)
wakeup frame enable More...
flag_status | emac_received_magic_packet_get (void)
received magic packet More...
flag_status | emac_received_wakeup_frame_get (void)
received wakeup frame. More...
void | emac_global_unicast_set (confirm_state new_state)
set unicast frame that passes DAF as wakeup frame. More...
void | emac_wakeup_frame_filter_reset (confirm_state new_state)
reset wakeup frame filter resgister More...
flag_status | emac_interrupt_status_read (uint32_t flag)
read interrupt status More...
void | emac_interrupt_mask_set (emac_interrupt_mask_type mask_type, confirm_state new_state)
set interrupt mask More...
void | emac_local_address_set (uint8_t *address)
set local mac address More...
void | emac_address_filter_set (emac_address_type mac, emac_address_filter_type filter, emac_address_mask_type mask_bit, confirm_state new_state)
set mac filter address More...
uint32_t | emac_received_packet_size_get (void)
get the size of received the received packet. More...
uint32_t | emac_dmarxdesc_frame_length_get (emac_dma_desc_type *dma_rx_desc)
get the specified dma rx descsriptor frame length. More...
void | emac_dma_descriptor_list_address_set (emac_dma_tx_rx_type transfer_type, emac_dma_desc_type *dma_desc_tab, uint8_t *buff, uint32_t buffer_count)
set transmit/receive descriptor list address More...
uint32_t | emac_dma_descriptor_list_address_get (emac_dma_tx_rx_type transfer_type)
get transmit/receive descriptor list address More...
void | emac_dma_rx_desc_interrupt_config (emac_dma_desc_type *dma_rx_desc, confirm_state new_state)
enable or disable the specified dma rx descriptor receive interrupt More...
void | emac_dma_para_init (emac_dma_config_type *control_para)
init emac dma parameters More...
void | emac_dma_config (emac_dma_config_type *control_para)
configure emac dma More...
void | emac_dma_arbitation_set (emac_dma_rx_tx_ratio_type ratio, confirm_state new_state)
set rx tx priority More...
void | emac_dma_descriptor_skip_length_set (uint8_t length)
set descriptor skip mength More...
void | emac_dma_separate_pbl_set (emac_dma_pbl_type tx_length, emac_dma_pbl_type rx_length, confirm_state new_state)
set programmable burst length More...
void | emac_dma_eight_pbl_mode_set (confirm_state new_state)
set 8 times programmable burst length More...
void | emac_dma_address_aligned_beats_set (confirm_state new_state)
set address-aligned beats More...
void | emac_dma_poll_demand_set (emac_dma_tx_rx_type transfer_type, uint32_t value)
set transmit/receive poll demand More...
uint32_t | emac_dma_poll_demand_get (emac_dma_tx_rx_type transfer_type)
get transmit poll demand More...
emac_dma_receive_process_status_type | emac_dma_receive_status_get (void)
get receive dma process status More...
emac_dma_transmit_process_status_type | emac_dma_transmit_status_get (void)
get transmit dma process status More...
void | emac_dma_operations_set (emac_dma_operations_type ops, confirm_state new_state)
set dma operations More...
void | emac_dma_receive_threshold_set (emac_dma_receive_threshold_type value)
set receive dma threshold More...
void | emac_dma_transmit_threshold_set (emac_dma_transmit_threshold_type value)
set transmit dma threshold More...
void | emac_dma_interrupt_enable (emac_dma_interrupt_type it, confirm_state new_state)
enable dma interrupt More...
uint16_t | emac_dma_controller_missing_frame_get (void)
get missed frames by the controller More...
uint8_t | emac_dma_missing_overflow_bit_get (void)
get overflow bit for missed frame counter More...
uint16_t | emac_dma_application_missing_frame_get (void)
get missed frames by the application More...
uint8_t | emac_dma_fifo_overflow_bit_get (void)
get overflow bit for FIFO overflow counter More...
uint32_t | emac_dma_tansfer_address_get (emac_dma_transfer_address_type transfer_type)
get overflow bit for FIFO overflow counter More...
void | emac_mmc_counter_reset (void)
reset all counter More...
void | emac_mmc_rollover_stop (confirm_state new_state)
counter stop counting from zero when it reaches maximum More...
void | emac_mmc_reset_on_read_enable (confirm_state new_state)
enable reset on read More...
void | emac_mmc_counter_freeze (confirm_state new_state)
freeze mmc counter More...
flag_status | emac_mmc_received_status_get (uint32_t flag)
interupt status of received frames More...
flag_status | emac_mmc_transmit_status_get (uint32_t flag)
interupt status of transmit frames More...
void | emac_mmc_received_interrupt_mask_set (uint32_t flag, confirm_state new_state)
mask received mmc interrupt More...
void | emac_mmc_transmit_interrupt_mask_set (uint32_t flag, confirm_state new_state)
mask transmit mmc interrupt More...
uint32_t | emac_mmc_transmit_good_frames_get (uint32_t flag)
get good frame numbers as single collision occurs. More...
uint32_t | emac_mmc_received_error_frames_get (uint32_t flag)
get good frame numbers as single collision occurs. More...
void | emac_ptp_timestamp_enable (confirm_state new_state)
enable timestamp. More...
void | emac_ptp_timestamp_fine_update_enable (confirm_state new_state)
enable timestamp fine update. More...
void | emac_ptp_timestamp_system_time_init (confirm_state new_state)
initialize timestamp time system. More...
void | emac_ptp_timestamp_system_time_update (confirm_state new_state)
update timestamp time system. More...
void | emac_ptp_interrupt_trigger_enable (confirm_state new_state)
enable timestamp interrupt trigger. More...
void | emac_ptp_addend_register_update (confirm_state new_state)
update timestamp addend register. More...
void | emac_ptp_snapshot_received_frames_enable (confirm_state new_state)
enable timestamp snapshot for all received frames. More...
void | emac_ptp_subsecond_rollover_enable (confirm_state new_state)
enable digital rollover. More...
void | emac_ptp_psv2_enable (confirm_state new_state)
enable packet snooping for version 2. More...
void | emac_ptp_snapshot_emac_frames_enable (confirm_state new_state)
enable snapshot over emac. More...
void | emac_ptp_snapshot_ipv6_frames_enable (confirm_state new_state)
enable snapshot for ipv6 frames. More...
void | emac_ptp_snapshot_ipv4_frames_enable (confirm_state new_state)
enable snapshot for ipv4 frames. More...
void | emac_ptp_snapshot_event_message_enable (confirm_state new_state)
enable snapshot for event message. More...
void | emac_ptp_snapshot_master_event_enable (confirm_state new_state)
enable snapshot for message relevant to master More...
void | emac_ptp_clock_node_set (emac_ptp_clock_node_type node)
set clock node type More...
void | emac_ptp_mac_address_filter_enable (confirm_state new_state)
enable ptp frame filtering mac address More...
void | emac_ptp_subsecond_increment_set (uint8_t value)
set subsecond increment value More...
uint32_t | emac_ptp_system_second_get (void)
get system time second More...
uint32_t | emac_ptp_system_subsecond_get (void)
get system time subsecond More...
confirm_state | emac_ptp_system_time_sign_get (void)
get system time sign More...
void | emac_ptp_system_second_set (uint32_t second)
set system time second More...
void | emac_ptp_system_subsecond_set (uint32_t subsecond)
set system time subsecond More...
void | emac_ptp_system_time_sign_set (confirm_state sign)
set system time sign More...
void | emac_ptp_timestamp_addend_set (uint32_t value)
set time stamp addend More...
void | emac_ptp_target_second_set (uint32_t value)
set target time stamp high More...
void | emac_ptp_target_nanosecond_set (uint32_t value)
set target time stamp low More...
confirm_state emac_ptp_timestamp_status_get (emac_ptp_timestamp_status_type status)
set target time stamp low More...
void | emac_ptp_pps_frequency_set (emac_ptp_pps_control_type freq)
set pps frequency More...
flag_status | emac_dma_flag_get (uint32_t dma_flag)
check whether the specified emac dma flag is set or not. More...
void | emac_dma_flag_clear (uint32_t dma_flag)
clear the emac dma flag. More...

Detailed Description

at32f435_437 eth header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_emac.h.


AT32F435/437 Firmwary Library: at32f435_437_ertc.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f435_437_ertc.h File Reference

at32f435_437 ertc header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct | ertc_time_type
ertc time More...
struct | ertc_alarm_value_type
ertc alarm More...
union | ertc_reg_time_type
ertc time reg union More...
union | ertc_reg_date_type
ertc date reg union More...
union | ertc_reg_alarm_type
ertc alarm reg union More...
union | ertc_reg_scal_type
ertc scal reg union More...
union | ertc_reg_tadj_type
ertc tadj reg union More...
union | ertc_reg_tstm_type
ertc tstm reg union More...
union | ertc_reg_tsdt_type
ertc tsdt register, offset:0x34 More...
struct | ertc_type
type define ertc register all More...

Macros

#define | ERTC_TP_INT ((uint32_t)0x00000004)
#define | ERTC_ALA_INT ((uint32_t)0x00001000)
#define | ERTC_ALB_INT ((uint32_t)0x00002000)
#define | ERTC_WAT_INT ((uint32_t)0x00004000)
#define | ERTC_TS_INT ((uint32_t)0x00008000)
#define | ERTC_ALAWF_FLAG ((uint32_t)0x00000001)
#define | ERTC_ALBWF_FLAG ((uint32_t)0x00000002)
#define | ERTC_WATWF_FLAG ((uint32_t)0x00000004)
#define | ERTC_TADJF_FLAG ((uint32_t)0x00000008)
#define | ERTC_INITF_FLAG ((uint32_t)0x00000010)
#define | ERTC_UPDF_FLAG ((uint32_t)0x00000020)
#define | ERTC_IMF_FLAG ((uint32_t)0x00000040)
#define | ERTC_ALAF_FLAG ((uint32_t)0x00000100)
#define | ERTC_ALBF_FLAG ((uint32_t)0x00000200)
#define | ERTC_WATF_FLAG ((uint32_t)0x00000400)
#define | ERTC_TSF_FLAG ((uint32_t)0x00000800)
#define | ERTC_TSOF_FLAG ((uint32_t)0x00001000)
#define | ERTC_TP1F_FLAG ((uint32_t)0x00002000)
#define | ERTC_TP2F_FLAG ((uint32_t)0x00004000)
#define | ERTC_CALUPDF_FLAG ((uint32_t)0x00010000)
#define | ERTC_ALARM_MASK_NONE ((uint32_t)0x00000000)
ertc alarm mask More...
#define | ERTC_ALARM_MASK_SEC ((uint32_t)0x00000080)
#define | ERTC_ALARM_MASK_MIN ((uint32_t)0x00008000)
#define | ERTC_ALARM_MASK_HOUR ((uint32_t)0x00800000)
#define | ERTC_ALARM_MASK_DATE_WEEK ((uint32_t)0x80000000)
#define | ERTC_ALARM_MASK_ALL ((uint32_t)0x80808080)
#define | ERTC_WAT_CLK_CK_A_16BITS ERTC_WAT_CLK_CK_B_16BITS
compatible with older versions More...
#define | ERTC_WAT_CLK_CK_A_17BITS ERTC_WAT_CLK_CK_B_17BITS
#define | ERTC ((ertc_type *) ERTC_BASE)

Enumerations

enum | ertc_hour_mode_set_type { ERTC_HOUR_MODE_24 = 0x00 , ERTC_HOUR_MODE_12 = 0x01 }
ertc hour mode More...
enum | ertc_am_pm_type { ERTC_24H = 0x00 , ERTC_AM = 0x00 , ERTC_PM = 0x01 }
ertc 12-hour format am/pm More...
enum | ertc_week_date_select_type { ERTC_SLECT_DATE = 0x00 , ERTC_SLECT_WEEK = 0x01 }
ertc week or date select More...
enum | ertc_alarm_type { ERTC_ALA = 0x00 , ERTC_ALB = 0x01 }
ertc alarm x select More...
enum ertc_alarm_sbs_mask_type {
ERTC_ALARM_SBS_MASK_ALL = 0x00 , ERTC_ALARM_SBS_MASK_14_1 = 0x01 , ERTC_ALARM_SBS_MASK_14_2 = 0x02 , ERTC_ALARM_SBS_MASK_14_3 = 0x03 ,
ERTC_ALARM_SBS_MASK_14_4 = 0x04 , ERTC_ALARM_SBS_MASK_14_5 = 0x05 , ERTC_ALARM_SBS_MASK_14_6 = 0x06 , ERTC_ALARM_SBS_MASK_14_7 = 0x07 ,
ERTC_ALARM_SBS_MASK_14_8 = 0x08 , ERTC_ALARM_SBS_MASK_14_9 = 0x09 , ERTC_ALARM_SBS_MASK_14_10 = 0x0A , ERTC_ALARM_SBS_MASK_14_11 = 0x0B ,
ERTC_ALARM_SBS_MASK_14_12 = 0x0C , ERTC_ALARM_SBS_MASK_14_13 = 0x0D , ERTC_ALARM_SBS_MASK_14 = 0x0E , ERTC_ALARM_SBS_MASK_NONE = 0x0F
}
ertc alarm sub second mask More...
enum ertc_wakeup_clock_type {
ERTC_WAT_CLK_ERTCCLK_DIV16 = 0x00 , ERTC_WAT_CLK_ERTCCLK_DIV8 = 0x01 , ERTC_WAT_CLK_ERTCCLK_DIV4 = 0x02 , ERTC_WAT_CLK_ERTCCLK_DIV2 = 0x03 ,
ERTC_WAT_CLK_CK_B_16BITS = 0x04 , ERTC_WAT_CLK_CK_B_17BITS = 0x06
}
ertc wakeup timer clock select More...
enum | ertc_smooth_cal_period_type { ERTC_SMOOTH_CAL_PERIOD_32 = 0x00 , ERTC_SMOOTH_CAL_PERIOD_16 = 0x01 , ERTC_SMOOTH_CAL_PERIOD_8 = 0x02 }
ertc smooth calibration period More...
enum | ertc_smooth_cal_clk_add_type { ERTC_SMOOTH_CAL_CLK_ADD_0 = 0x00 , ERTC_SMOOTH_CAL_CLK_ADD_512 = 0x01 }
ertc smooth calibration clock add mode More...
enum | ertc_cal_direction_type { ERTC_CAL_DIR_POSITIVE = 0x00 , ERTC_CAL_DIR_NEGATIVE = 0x01 }
ertc calibration direction mode More...
enum | ertc_cal_output_select_type { ERTC_CAL_OUTPUT_512HZ = 0x00 , ERTC_CAL_OUTPUT_1HZ = 0x01 }
ertc calibration output mode More...
enum | ertc_time_adjust_type { ERTC_TIME_ADD_NONE = 0x00 , ERTC_TIME_ADD_1S = 0x01 }
time adjust add mode More...
enum | ertc_dst_operation_type { ERTC_DST_ADD_1H = 0x00 , ERTC_DST_DEC_1H = 0x01 }
ertc daylight saving time hour adjustment mode More...
enum | ertc_dst_save_type { ERTC_DST_SAVE_0 = 0x00 , ERTC_DST_SAVE_1 = 0x01 }
ertc daylight saving time store operation mode More...
enum | ertc_output_source_type { ERTC_OUTPUT_DISABLE = 0x00 , ERTC_OUTPUT_ALARM_A = 0x01 , ERTC_OUTPUT_ALARM_B = 0x02 , ERTC_OUTPUT_WAKEUP = 0x03 }
output source More...
enum | ertc_output_polarity_type { ERTC_OUTPUT_POLARITY_HIGH = 0x00 , ERTC_OUTPUT_POLARITY_LOW = 0x01 }
output polarity More...
enum | ertc_output_type { ERTC_OUTPUT_TYPE_OPEN_DRAIN = 0x00 , ERTC_OUTPUT_TYPE_PUSH_PULL = 0x01 }
output type More...
enum | ertc_pin_select_type { ERTC_PIN_PC13 = 0x00 , ERTC_PIN_PA0 = 0x01 }
timestamp/ tamper detection pin selection More...
enum | ertc_timestamp_valid_edge_type { ERTC_TIMESTAMP_EDGE_RISING = 0x00 , ERTC_TIMESTAMP_EDGE_FALLING = 0x01 }
ertc timestamp valid edge More...
enum | ertc_tamper_select_type { ERTC_TAMPER_1 = 0x00 , ERTC_TAMPER_2 = 0x01 }
ertc tamper x select More...
enum | ertc_tamper_precharge_type { ERTC_TAMPER_PR_1_ERTCCLK = 0x00 , ERTC_TAMPER_PR_2_ERTCCLK = 0x01 , ERTC_TAMPER_PR_4_ERTCCLK = 0x02 , ERTC_TAMPER_PR_8_ERTCCLK = 0x03 }
tamper detection pre-charge time More...
enum | ertc_tamper_filter_type { ERTC_TAMPER_FILTER_DISABLE = 0x00 , ERTC_TAMPER_FILTER_2 = 0x01 , ERTC_TAMPER_FILTER_4 = 0x02 , ERTC_TAMPER_FILTER_8 = 0x03 }
ertc tamper filter More...
enum ertc_tamper_detect_freq_type {
ERTC_TAMPER_FREQ_DIV_32768 = 0x00 , ERTC_TAMPER_FREQ_DIV_16384 = 0x01 , ERTC_TAMPER_FREQ_DIV_8192 = 0x02 , ERTC_TAMPER_FREQ_DIV_4096 = 0x03 ,
ERTC_TAMPER_FREQ_DIV_2048 = 0x04 , ERTC_TAMPER_FREQ_DIV_1024 = 0x05 , ERTC_TAMPER_FREQ_DIV_512 = 0x06 , ERTC_TAMPER_FREQ_DIV_256 = 0x07
}
ertc tamper detection frequency More...
enum | ertc_tamper_valid_edge_type { ERTC_TAMPER_EDGE_RISING = 0x00 , ERTC_TAMPER_EDGE_FALLING = 0x01 , ERTC_TAMPER_EDGE_LOW = 0x00 , ERTC_TAMPER_EDGE_HIGH = 0x01 }
ertc tamper valid edge More...
enum ertc_dt_type {
ERTC_DT1 = 0 , ERTC_DT2 = 1 , ERTC_DT3 = 2 , ERTC_DT4 = 3 ,
ERTC_DT5 = 4 , ERTC_DT6 = 5 , ERTC_DT7 = 6 , ERTC_DT8 = 7 ,
ERTC_DT9 = 8 , ERTC_DT10 = 9 , ERTC_DT11 = 10 , ERTC_DT12 = 11 ,
ERTC_DT13 = 12 , ERTC_DT14 = 13 , ERTC_DT15 = 14 , ERTC_DT16 = 15 ,
ERTC_DT17 = 16 , ERTC_DT18 = 17 , ERTC_DT19 = 18 , ERTC_DT20 = 19
}
ertc bpr register More...

Functions

uint8_t | ertc_num_to_bcd (uint8_t num)
number conversion to bcd code. More...
uint8_t | ertc_bcd_to_num (uint8_t bcd)
bcd code conversion to number. More...
void | ertc_write_protect_enable (void)
enable write protection. More...
void | ertc_write_protect_disable (void)
disable write protection. More...
error_status | ertc_wait_update (void)
ertc wait register update finish. More...
error_status | ertc_wait_flag (uint32_t flag, flag_status status)
ertc wait flag status. More...
error_status | ertc_init_mode_enter (void)
ertc enter init mode. More...
void | ertc_init_mode_exit (void)
ertc exit init mode. More...
error_status | ertc_reset (void)
ertc reset all register. More...
error_status | ertc_divider_set (uint16_t div_a, uint16_t div_b)
ertc division set. More...
error_status | ertc_hour_mode_set (ertc_hour_mode_set_type mode)
ertc hour mode set. More...
error_status | ertc_date_set (uint8_t year, uint8_t month, uint8_t date, uint8_t week)
set date. More...
error_status | ertc_time_set (uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
set time. More...
void | ertc_calendar_get (ertc_time_type *time)
get calendar More...
uint32_t | ertc_sub_second_get (void)
get current sub second. More...
void | ertc_alarm_mask_set (ertc_alarm_type alarm_x, uint32_t mask)
set which bits are irrelevant to the alarm match. More...
void | ertc_alarm_week_date_select (ertc_alarm_type alarm_x, ertc_week_date_select_type wk)
alarm week or date mode select. More...
void | ertc_alarm_set (ertc_alarm_type alarm_x, uint8_t week_date, uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
set alarm. More...
void | ertc_alarm_sub_second_set (ertc_alarm_type alarm_x, uint32_t value, ertc_alarm_sbs_mask_type mask)
set alarm sub second. More...
error_status | ertc_alarm_enable (ertc_alarm_type alarm_x, confirm_state new_state)
enable or disable alarm clock. More...
void | ertc_alarm_get (ertc_alarm_type alarm_x, ertc_alarm_value_type *alarm)
get alarm value. More...
uint32_t | ertc_alarm_sub_second_get (ertc_alarm_type alarm_x)
get alarm sub second. More...
void | ertc_wakeup_clock_set (ertc_wakeup_clock_type clock)
set wakeup timer clock. More...
void | ertc_wakeup_counter_set (uint32_t counter)
set wakeup counter. More...
uint16_t | ertc_wakeup_counter_get (void)
get wakeup counter. More...
error_status | ertc_wakeup_enable (confirm_state new_state)
enable or disable wakeup timer. More...
error_status | ertc_smooth_calibration_config (ertc_smooth_cal_period_type period, ertc_smooth_cal_clk_add_type clk_add, uint32_t clk_dec)
config the smooth calibration. More...
error_status | ertc_coarse_calibration_set (ertc_cal_direction_type dir, uint32_t value)
set the coarse digital calibration. More...
error_status | ertc_coarse_calibration_enable (confirm_state new_state)
enable or disable coarse calibration. More...
void | ertc_cal_output_select (ertc_cal_output_select_type output)
calibration output source select. More...
void | ertc_cal_output_enable (confirm_state new_state)
enable or disable calibration output. More...
error_status | ertc_time_adjust (ertc_time_adjust_type add1s, uint32_t decsbs)
adjust the time. More...
void | ertc_daylight_set (ertc_dst_operation_type operation, ertc_dst_save_type save)
config the daylight saving time. More...
uint8_t | ertc_daylight_bpr_get (void)
get the bpr value. More...
error_status | ertc_refer_clock_detect_enable (confirm_state new_state)
enable or disable refer clock detect. More...
void | ertc_direct_read_enable (confirm_state new_state)
enable or disable direct read mode. More...
void | ertc_output_set (ertc_output_source_type source, ertc_output_polarity_type polarity, ertc_output_type type)
set the output mode. More...
void | ertc_timestamp_pin_select (ertc_pin_select_type pin)
timestamp detection pin selection. More...
void | ertc_timestamp_valid_edge_set (ertc_timestamp_valid_edge_type edge)
set the timestamp valid edge. More...
void | ertc_timestamp_enable (confirm_state new_state)
enable or disable timestamp. More...
void | ertc_timestamp_get (ertc_time_type *time)
get the timestamp. More...
uint32_t | ertc_timestamp_sub_second_get (void)
get the timestamp sub second. More...
void | ertc_tamper_1_pin_select (ertc_pin_select_type pin)
tamper 1 detection pin selection. More...
void | ertc_tamper_pull_up_enable (confirm_state new_state)
enable or disable tamper pin pull up. More...
void | ertc_tamper_precharge_set (ertc_tamper_precharge_type precharge)
set the tamper pin pre-charge time. More...
void | ertc_tamper_filter_set (ertc_tamper_filter_type filter)
set the tamper filter time. More...
void | ertc_tamper_detect_freq_set (ertc_tamper_detect_freq_type freq)
set the tamper detection frequency. More...
void | ertc_tamper_valid_edge_set (ertc_tamper_select_type tamper_x, ertc_tamper_valid_edge_type trigger)
set the tamper trigger. More...
void | ertc_tamper_timestamp_enable (confirm_state new_state)
enable or disable trigger timestamp when tamper event occurs. More...
void | ertc_tamper_enable (ertc_tamper_select_type tamper_x, confirm_state new_state)
enable or disable tamper. More...
void | ertc_interrupt_enable (uint32_t source, confirm_state new_state)
enable or disable interrupt. More...
flag_status | ertc_interrupt_get (uint32_t source)
get interrupt status More...
flag_status | ertc_flag_get (uint32_t flag)
get flag status. More...
void | ertc_flag_clear (uint32_t flag)
clear flag status More...
void | ertc_bpr_data_write (ertc_dt_type dt, uint32_t data)
write data to the bpr register. More...
uint32_t | ertc_bpr_data_read (ertc_dt_type dt)
read data from bpr register. More...

Detailed Description

at32f435_437 ertc header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_ertc.h.


AT32F435/437 Firmwary Library: at32f435_437_exint.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f435_437_exint.h File Reference

at32f435_437 exint header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct | exint_init_type
exint init type More...
struct | exint_type
type define exint register all More...

Macros

#define | EXINT_LINE_NONE ((uint32_t)0x000000)
#define | EXINT_LINE_0 ((uint32_t)0x000001)
#define | EXINT_LINE_1 ((uint32_t)0x000002)
#define | EXINT_LINE_2 ((uint32_t)0x000004)
#define | EXINT_LINE_3 ((uint32_t)0x000008)
#define | EXINT_LINE_4 ((uint32_t)0x000010)
#define | EXINT_LINE_5 ((uint32_t)0x000020)
#define | EXINT_LINE_6 ((uint32_t)0x000040)
#define | EXINT_LINE_7 ((uint32_t)0x000080)
#define | EXINT_LINE_8 ((uint32_t)0x000100)
#define | EXINT_LINE_9 ((uint32_t)0x000200)
#define | EXINT_LINE_10 ((uint32_t)0x000400)
#define | EXINT_LINE_11 ((uint32_t)0x000800)
#define | EXINT_LINE_12 ((uint32_t)0x001000)
#define | EXINT_LINE_13 ((uint32_t)0x002000)
#define | EXINT_LINE_14 ((uint32_t)0x004000)
#define | EXINT_LINE_15 ((uint32_t)0x008000)
#define | EXINT_LINE_16 ((uint32_t)0x010000)
#define | EXINT_LINE_17 ((uint32_t)0x020000)
#define | EXINT_LINE_18 ((uint32_t)0x040000)
#define | EXINT_LINE_19 ((uint32_t)0x080000)
#define | EXINT_LINE_20 ((uint32_t)0x100000)
#define | EXINT_LINE_21 ((uint32_t)0x200000)
#define | EXINT_LINE_22 ((uint32_t)0x400000)
#define | EXINT ((exint_type *) EXINT_BASE)

Enumerations

enum | exint_line_mode_type { EXINT_LINE_INTERRUPUT = 0x00 , EXINT_LINE_EVENT = 0x01 }
exint line mode type More...
enum | exint_polarity_config_type { EXINT_TRIGGER_RISING_EDGE = 0x00 , EXINT_TRIGGER_FALLING_EDGE = 0x01 , EXINT_TRIGGER_BOTH_EDGE = 0x02 }
exint polarity configuration type More...

Functions

void | exint_reset (void)
exint reset More...
void | exint_default_para_init (exint_init_type *exint_struct)
exint default para init More...
void | exint_init (exint_init_type *exint_struct)
exint init More...
void | exint_flag_clear (uint32_t exint_line)
clear exint flag More...
flag_status | exint_flag_get (uint32_t exint_line)
get exint flag More...
void | exint_software_interrupt_event_generate (uint32_t exint_line)
generate exint software interrupt event More...
void | exint_interrupt_enable (uint32_t exint_line, confirm_state new_state)
enable or disable exint interrupt More...
void | exint_event_enable (uint32_t exint_line, confirm_state new_state)
enable or disable exint event More...

Detailed Description

at32f435_437 exint header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_exint.h.


AT32F435/437 Firmwary Library: at32f435_437_flash.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f435_437_flash.h File Reference

at32f435_437 flash header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct | flash_type
type define flash register all More...
struct | usd_type
user system data More...

Macros

#define | FLASH_UNLOCK_KEY1 ((uint32_t)0x45670123)
flash unlock keys More...
#define | FLASH_UNLOCK_KEY2 ((uint32_t)0xCDEF89AB)
#define | FAP_RELIEVE_KEY ((uint16_t)0x00A5)
#define | SLIB_UNLOCK_KEY ((uint32_t)0xA35F6D24)
#define | FLASH_BANK1_START_ADDR ((uint32_t)0x08000000)
flash bank address More...
#define | FLASH_BANK1_END_ADDR ((uint32_t)0x0807FFFF)
#define | FLASH_BANK2_START_ADDR ((uint32_t)0x08080000)
#define | FLASH_BANK2_END_ADDR ((uint32_t)0x080FFFFF)
#define | FLASH_OBF_FLAG FLASH_BANK1_OBF_FLAG
flash flag More...
#define | FLASH_ODF_FLAG FLASH_BANK1_ODF_FLAG
#define | FLASH_PRGMERR_FLAG FLASH_BANK1_PRGMERR_FLAG
#define | FLASH_EPPERR_FLAG FLASH_BANK1_EPPERR_FLAG
#define | FLASH_BANK1_OBF_FLAG ((uint32_t)0x00000001)
#define | FLASH_BANK1_ODF_FLAG ((uint32_t)0x00000020)
#define | FLASH_BANK1_PRGMERR_FLAG ((uint32_t)0x00000004)
#define | FLASH_BANK1_EPPERR_FLAG ((uint32_t)0x00000010)
#define | FLASH_BANK2_OBF_FLAG ((uint32_t)0x10000001)
#define | FLASH_BANK2_ODF_FLAG ((uint32_t)0x10000020)
#define | FLASH_BANK2_PRGMERR_FLAG ((uint32_t)0x10000004)
#define | FLASH_BANK2_EPPERR_FLAG ((uint32_t)0x10000010)
#define | FLASH_USDERR_FLAG ((uint32_t)0x40000001)
#define | FLASH_ERR_INT FLASH_BANK1_ERR_INT
flash interrupts More...
#define | FLASH_ODF_INT FLASH_BANK1_ODF_INT
#define | FLASH_BANK1_ERR_INT ((uint32_t)0x00000001)
#define | FLASH_BANK1_ODF_INT ((uint32_t)0x00000002)
#define | FLASH_BANK2_ERR_INT ((uint32_t)0x00000004)
#define | FLASH_BANK2_ODF_INT ((uint32_t)0x00000008)
#define | FLASH_SLIB_START_SECTOR ((uint32_t)0x0000FFFF)
flash slib mask More...
#define | FLASH_SLIB_INST_START_SECTOR ((uint32_t)0x0000FFFF)
#define | FLASH_SLIB_END_SECTOR ((uint32_t)0xFFFF0000)
#define | USD_WDT_ATO_DISABLE ((uint16_t)0x0001)
user system data wdt_ato More...
#define | USD_WDT_ATO_ENABLE ((uint16_t)0x0000)
#define | USD_DEPSLP_NO_RST ((uint16_t)0x0002)
user system data depslp_rst More...
#define | USD_DEPSLP_RST ((uint16_t)0x0000)
#define | USD_STDBY_NO_RST ((uint16_t)0x0004)
user system data stdby_rst More...
#define | USD_STDBY_RST ((uint16_t)0x0000)
#define | FLASH_BOOT_FROM_BANK1 ((uint16_t)0x0008)
user system data btopt More...
#define | FLASH_BOOT_FROM_BANK2 ((uint16_t)0x0000)
#define | USD_WDT_DEPSLP_CONTINUE ((uint16_t)0x0020)
user system data wdt_depslp More...
#define | USD_WDT_DEPSLP_STOP ((uint16_t)0x0000)
#define | USD_WDT_STDBY_CONTINUE ((uint16_t)0x0040)
user system data wdt_stdby More...
#define | USD_WDT_STDBY_STOP ((uint16_t)0x0000)
#define | ERASE_TIMEOUT ((uint32_t)0x80000000)
flash timeout definition More...
#define | PROGRAMMING_TIMEOUT ((uint32_t)0x00100000)
#define | OPERATION_TIMEOUT ((uint32_t)0x10000000)
#define | flash_clock_divider_set(div) (FLASH->divr_bit.fdiv = div)
set the flash clock divider definition More...
#define | FLASH ((flash_type *) FLASH_REG_BASE)
#define | USD ((usd_type *) USD_BASE)

Enumerations

enum flash_usd_eopb0_type {
FLASH_EOPB0_SRAM_512K = 0x00 , FLASH_EOPB0_SRAM_448K = 0x01 , FLASH_EOPB0_SRAM_384K = 0x02 , FLASH_EOPB0_SRAM_320K = 0x03 ,
FLASH_EOPB0_SRAM_256K = 0x04 , FLASH_EOPB0_SRAM_192K = 0x05 , FLASH_EOPB0_SRAM_128K = 0x06
}
flash usd eopb0 type More...
enum flash_clock_divider_type { FLASH_CLOCK_DIV_2 = 0x00 , FLASH_CLOCK_DIV_3 = 0x01 , FLASH_CLOCK_DIV_4 = 0x02 }
flash clock divider type More...
enum flash_status_type {
FLASH_OPERATE_BUSY = 0x00 , FLASH_PROGRAM_ERROR = 0x01 , FLASH_EPP_ERROR = 0x02 , FLASH_OPERATE_DONE = 0x03 ,
FLASH_OPERATE_TIMEOUT = 0x04
}
flash status type More...

Functions

flag_status | flash_flag_get (uint32_t flash_flag)
check whether the specified flash flag is set or not. More...
void | flash_flag_clear (uint32_t flash_flag)
clear the flash flag. More...
flash_status_type | flash_operation_status_get (void)
return the flash operation status. More...
flash_status_type | flash_bank1_operation_status_get (void)
return the flash bank1 operation status. More...
flash_status_type | flash_bank2_operation_status_get (void)
return the flash bank2 operation status. More...
flash_status_type | flash_operation_wait_for (uint32_t time_out)
wait for flash operation complete or timeout. More...
flash_status_type | flash_bank1_operation_wait_for (uint32_t time_out)
wait for flash bank1 operation complete or timeout. More...
flash_status_type | flash_bank2_operation_wait_for (uint32_t time_out)
wait for flash bank2 operation complete or timeout. More...
void | flash_unlock (void)
unlock the flash controller. More...
void | flash_bank1_unlock (void)
unlock the flash bank1 controller. More...
void | flash_bank2_unlock (void)
unlock the flash bank2 controller. More...
void | flash_lock (void)
lock the flash controller. More...
void | flash_bank1_lock (void)
lock the flash bank1 controller. More...
void | flash_bank2_lock (void)
lock the flash bank2 controller. More...
flash_status_type | flash_sector_erase (uint32_t sector_address)
erase a specified flash sector. More...
flash_status_type | flash_block_erase (uint32_t block_address)
erase a specified flash block. More...
flash_status_type | flash_internal_all_erase (void)
erase flash all internal sectors. More...
flash_status_type | flash_bank1_erase (void)
erase flash bank1 sectors. More...
flash_status_type | flash_bank2_erase (void)
erase flash bank2 sectors. More...
flash_status_type | flash_user_system_data_erase (void)
erase the flash user system data. More...
flash_status_type | flash_eopb0_config (flash_usd_eopb0_type data)
config the extend sram byte eopb0 in user system data. More...
flash_status_type | flash_word_program (uint32_t address, uint32_t data)
program a word at a specified address. More...
flash_status_type | flash_halfword_program (uint32_t address, uint16_t data)
program a halfword at a specified address. More...
flash_status_type | flash_byte_program (uint32_t address, uint8_t data)
program a byte at a specified address. More...
flash_status_type | flash_user_system_data_program (uint32_t address, uint8_t data)
program a halfword at a specified user system data address. More...
flash_status_type | flash_epp_set (uint32_t *sector_bits)
config erase/program protection for the desired sectors. More...
void | flash_epp_status_get (uint32_t *sector_bits)
return the flash erase/program protection status. More...
flash_status_type | flash_fap_enable (confirm_state new_state)
enable or disable the flash access protection. More...
flag_status | flash_fap_status_get (void)
check the flash access protection status. More...
flash_status_type | flash_ssb_set (uint8_t usd_ssb)
program the flash system setting byte in usd: wdt_ato_en / depslp_rst / stdby_rst / btopt. More...
uint8_t | flash_ssb_status_get (void)
return the flash system setting byte status. More...
void | flash_interrupt_enable (uint32_t flash_int, confirm_state new_state)
enable or disable the specified flash interrupts. More...
flash_status_type | flash_slib_enable (uint32_t pwd, uint16_t start_sector, uint16_t inst_start_sector, uint16_t end_sector)
enable security library function. More...
error_status | flash_slib_disable (uint32_t pwd)
disable slib when slib enabled. More...
uint32_t | flash_slib_remaining_count_get (void)
get remaining count of slib(range: 256~0). More...
flag_status | flash_slib_state_get (void)
get the slib state. More...
uint16_t | flash_slib_start_sector_get (void)
get the start sector of slib. More...
uint16_t | flash_slib_inststart_sector_get (void)
get the instruction start sector of slib. More...
uint16_t | flash_slib_end_sector_get (void)
get the end sector of slib. More...
uint32_t | flash_crc_calibrate (uint32_t start_sector, uint32_t sector_cnt)
flash crc calibration in main block. More...
void | flash_nzw_boost_enable (confirm_state new_state)
flash non-zero wait area boost enable. More...
void | flash_continue_read_enable (confirm_state new_state)
flash continue read enable. More...

Detailed Description

at32f435_437 flash header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_flash.h.


AT32F435/437 Firmwary Library: at32f435_437_gpio.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f435_437_gpio.h File Reference

at32f435_437 gpio header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct | gpio_init_type
gpio init type More...
struct | gpio_type
type define gpio register all More...

Macros

#define | GPIO_PINS_0 0x0001
#define | GPIO_PINS_1 0x0002
#define | GPIO_PINS_2 0x0004
#define | GPIO_PINS_3 0x0008
#define | GPIO_PINS_4 0x0010
#define | GPIO_PINS_5 0x0020
#define | GPIO_PINS_6 0x0040
#define | GPIO_PINS_7 0x0080
#define | GPIO_PINS_8 0x0100
#define | GPIO_PINS_9 0x0200
#define | GPIO_PINS_10 0x0400
#define | GPIO_PINS_11 0x0800
#define | GPIO_PINS_12 0x1000
#define | GPIO_PINS_13 0x2000
#define | GPIO_PINS_14 0x4000
#define | GPIO_PINS_15 0x8000
#define | GPIO_PINS_ALL 0xFFFF
#define | GPIOA ((gpio_type *) GPIOA_BASE)
#define | GPIOB ((gpio_type *) GPIOB_BASE)
#define | GPIOC ((gpio_type *) GPIOC_BASE)
#define | GPIOD ((gpio_type *) GPIOD_BASE)
#define | GPIOE ((gpio_type *) GPIOE_BASE)
#define | GPIOF ((gpio_type *) GPIOF_BASE)
#define | GPIOG ((gpio_type *) GPIOG_BASE)
#define | GPIOH ((gpio_type *) GPIOH_BASE)

Enumerations

enum | gpio_mode_type { GPIO_MODE_INPUT = 0x00 , GPIO_MODE_OUTPUT = 0x01 , GPIO_MODE_MUX = 0x02 , GPIO_MODE_ANALOG = 0x03 }
gpio mode select More...
enum | gpio_drive_type { GPIO_DRIVE_STRENGTH_STRONGER = 0x01 , GPIO_DRIVE_STRENGTH_MODERATE = 0x02 }
gpio output drive strength select More...
enum | gpio_output_type { GPIO_OUTPUT_PUSH_PULL = 0x00 , GPIO_OUTPUT_OPEN_DRAIN = 0x01 }
gpio output type More...
enum | gpio_pull_type { GPIO_PULL_NONE = 0x00 , GPIO_PULL_UP = 0x01 , GPIO_PULL_DOWN = 0x02 }
gpio pull type More...
enum gpio_pins_source_type {
GPIO_PINS_SOURCE0 = 0x00 , GPIO_PINS_SOURCE1 = 0x01 , GPIO_PINS_SOURCE2 = 0x02 , GPIO_PINS_SOURCE3 = 0x03 ,
GPIO_PINS_SOURCE4 = 0x04 , GPIO_PINS_SOURCE5 = 0x05 , GPIO_PINS_SOURCE6 = 0x06 , GPIO_PINS_SOURCE7 = 0x07 ,
GPIO_PINS_SOURCE8 = 0x08 , GPIO_PINS_SOURCE9 = 0x09 , GPIO_PINS_SOURCE10 = 0x0A , GPIO_PINS_SOURCE11 = 0x0B ,
GPIO_PINS_SOURCE12 = 0x0C , GPIO_PINS_SOURCE13 = 0x0D , GPIO_PINS_SOURCE14 = 0x0E , GPIO_PINS_SOURCE15 = 0x0F
}
gpio pins source type More...
enum gpio_mux_sel_type {
GPIO_MUX_0 = 0x00 , GPIO_MUX_1 = 0x01 , GPIO_MUX_2 = 0x02 , GPIO_MUX_3 = 0x03 ,
GPIO_MUX_4 = 0x04 , GPIO_MUX_5 = 0x05 , GPIO_MUX_6 = 0x06 , GPIO_MUX_7 = 0x07 ,
GPIO_MUX_8 = 0x08 , GPIO_MUX_9 = 0x09 , GPIO_MUX_10 = 0x0A , GPIO_MUX_11 = 0x0B ,
GPIO_MUX_12 = 0x0C , GPIO_MUX_13 = 0x0D , GPIO_MUX_14 = 0x0E , GPIO_MUX_15 = 0x0F
}
gpio muxing function selection type More...

Functions

void | gpio_reset (gpio_type *gpio_x)
reset the gpio register More...
void | gpio_init (gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral. More...
void | gpio_default_para_init (gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value. More...
flag_status | gpio_input_data_bit_read (gpio_type *gpio_x, uint16_t pins)
read the specified input port pin. More...
uint16_t | gpio_input_data_read (gpio_type *gpio_x)
read the specified gpio input data port. More...
flag_status | gpio_output_data_bit_read (gpio_type *gpio_x, uint16_t pins)
read the specified output port pin. More...
uint16_t | gpio_output_data_read (gpio_type *gpio_x)
read the specified gpio ouput data port. More...
void | gpio_bits_set (gpio_type *gpio_x, uint16_t pins)
set the selected data port bits. More...
void | gpio_bits_reset (gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits. More...
void | gpio_bits_write (gpio_type *gpio_x, uint16_t pins, confirm_state bit_state)
set or clear the selected data port bit. More...
void | gpio_port_write (gpio_type *gpio_x, uint16_t port_value)
write data to the specified gpio data port. More...
void | gpio_pin_wp_config (gpio_type *gpio_x, uint16_t pins)
write protect gpio pins configuration registers. More...
void | gpio_pins_huge_driven_config (gpio_type *gpio_x, uint16_t pins, confirm_state new_state)
enable or disable gpio pins huge driven. More...
void | gpio_pin_mux_config (gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function. More...

Detailed Description

at32f435_437 gpio header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_gpio.h.


AT32F435/437 Firmwary Library: at32f435_437_i2c.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f435_437_i2c.h File Reference

at32f435_437 i2c header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct i2c_type
type define i2c register all More...

Macros

#define | MAX_TRANSFER_CNT 255
maximum number of single transfers More...
#define | I2C_TD_INT ((uint32_t)0x00000002)
#define | I2C_RD_INT ((uint32_t)0x00000004)
#define | I2C_ADDR_INT ((uint32_t)0x00000008)
#define | I2C_ACKFIAL_INT ((uint32_t)0x00000010)
#define | I2C_STOP_INT ((uint32_t)0x00000020)
#define | I2C_TDC_INT ((uint32_t)0x00000040)
#define | I2C_ERR_INT ((uint32_t)0x00000080)
#define | I2C_TDBE_FLAG ((uint32_t)0x00000001)
#define | I2C_TDIS_FLAG ((uint32_t)0x00000002)
#define | I2C_RDBF_FLAG ((uint32_t)0x00000004)
#define | I2C_ADDRF_FLAG ((uint32_t)0x00000008)
#define | I2C_ACKFAIL_FLAG ((uint32_t)0x00000010)
#define | I2C_STOPF_FLAG ((uint32_t)0x00000020)
#define | I2C_TDC_FLAG ((uint32_t)0x00000040)
#define | I2C_TCRLD_FLAG ((uint32_t)0x00000080)
#define | I2C_BUSERR_FLAG ((uint32_t)0x00000100)
#define | I2C_ARLOST_FLAG ((uint32_t)0x00000200)
#define | I2C_OUF_FLAG ((uint32_t)0x00000400)
#define | I2C_PECERR_FLAG ((uint32_t)0x00000800)
#define | I2C_TMOUT_FLAG ((uint32_t)0x00001000)
#define | I2C_ALERTF_FLAG ((uint32_t)0x00002000)
#define | I2C_BUSYF_FLAG ((uint32_t)0x00008000)
#define | I2C_SDIR_FLAG ((uint32_t)0x00010000)
#define | I2C1 ((i2c_type *) I2C1_BASE)
#define | I2C2 ((i2c_type *) I2C2_BASE)
#define | I2C3 ((i2c_type *) I2C3_BASE)

Enumerations

enum | i2c_smbus_mode_type { I2C_SMBUS_MODE_DEVICE = 0x00 , I2C_SMBUS_MODE_HOST = 0x01 }
i2c smbus mode set More...
enum | i2c_address_mode_type { I2C_ADDRESS_MODE_7BIT = 0x00 , I2C_ADDRESS_MODE_10BIT = 0x01 }
i2c address mode More...
enum | i2c_transfer_dir_type { I2C_DIR_TRANSMIT = 0x00 , I2C_DIR_RECEIVE = 0x01 }
i2c transfer direction More...
enum | i2c_dma_request_type { I2C_DMA_REQUEST_TX = 0x00 , I2C_DMA_REQUEST_RX = 0x01 }
i2c dma requests direction More...
enum | i2c_smbus_alert_set_type { I2C_SMBUS_ALERT_HIGH = 0x00 , I2C_SMBUS_ALERT_LOW = 0x01 }
i2c smbus alert pin set More...
enum | i2c_timeout_detcet_type { I2C_TIMEOUT_DETCET_LOW = 0x00 , I2C_TIMEOUT_DETCET_HIGH = 0x01 }
i2c clock timeout detection mode More...
enum i2c_addr2_mask_type {
I2C_ADDR2_NOMASK = 0x00 , I2C_ADDR2_MASK01 = 0x01 , I2C_ADDR2_MASK02 = 0x02 , I2C_ADDR2_MASK03 = 0x03 ,
I2C_ADDR2_MASK04 = 0x04 , I2C_ADDR2_MASK05 = 0x05 , I2C_ADDR2_MASK06 = 0x06 , I2C_ADDR2_MASK07 = 0x07
}
i2c own address2 mask More...
enum | i2c_reload_stop_mode_type { I2C_AUTO_STOP_MODE = 0x02000000 , I2C_SOFT_STOP_MODE = 0x00000000 , I2C_RELOAD_MODE = 0x01000000 }
i2c reload end mode More...
enum | i2c_start_mode_type { I2C_WITHOUT_START = 0x00000000 , I2C_GEN_START_READ = 0x00002400 , I2C_GEN_START_WRITE = 0x00002000 }
i2c start mode More...

Functions

void | i2c_reset (i2c_type *i2c_x)
reset the i2c register More...
void | i2c_init (i2c_type *i2c_x, uint8_t dfilters, uint32_t clk)
init i2c digit filters and clock control register. More...
void | i2c_own_address1_set (i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config i2c own address 1. More...
void | i2c_own_address2_set (i2c_type *i2c_x, uint8_t address, i2c_addr2_mask_type mask)
config i2c own address 2 and mask. More...
void | i2c_own_address2_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable own address 2. More...
void | i2c_smbus_enable (i2c_type *i2c_x, i2c_smbus_mode_type mode, confirm_state new_state)
enable or disable smbus mode. More...
void | i2c_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable peripheral. More...
void | i2c_clock_stretch_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable clock stretch. More...
void | i2c_ack_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable ack. More...
void | i2c_addr10_mode_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable 10-bit address mode (master transfer). More...
void | i2c_transfer_addr_set (i2c_type *i2c_x, uint16_t address)
config the slave address to be transmitted. More...
uint16_t | i2c_transfer_addr_get (i2c_type *i2c_x)
get the slave address to be transmitted. More...
void | i2c_transfer_dir_set (i2c_type *i2c_x, i2c_transfer_dir_type i2c_direction)
config the master transfer direction. More...
i2c_transfer_dir_type | i2c_transfer_dir_get (i2c_type *i2c_x)
slave get the i2c transfer direction. More...
uint8_t | i2c_matched_addr_get (i2c_type *i2c_x)
get the i2c slave matched address. More...
void | i2c_auto_stop_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable auto send stop mode. More...
void | i2c_reload_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable cnt reload mode. More...
void | i2c_cnt_set (i2c_type *i2c_x, uint8_t cnt)
config the transfer cnt . More...
void | i2c_addr10_header_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable read 10-bit header, this mode only used in 10-bit address mode read. More...
void | i2c_general_call_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable general call mode. More...
void | i2c_smbus_alert_set (i2c_type *i2c_x, i2c_smbus_alert_set_type level)
drives the smbus alert pin high or low. More...
void | i2c_slave_data_ctrl_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable slave data control. More...
void | i2c_pec_calculate_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable pec calculate. More...
void | i2c_pec_transmit_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable pec transfer. More...
uint8_t | i2c_pec_value_get (i2c_type *i2c_x)
get the i2c pec value. More...
void | i2c_timeout_set (i2c_type *i2c_x, uint16_t timeout)
config the i2c bus timeout. More...
void | i2c_timeout_detcet_set (i2c_type *i2c_x, i2c_timeout_detcet_type mode)
config the bus timeout detcet level. More...
void | i2c_timeout_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable bus timeout. More...
void | i2c_ext_timeout_set (i2c_type *i2c_x, uint16_t timeout)
config the i2c extend bus timeout. More...
void | i2c_ext_timeout_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable extend bus timeout. More...
void | i2c_interrupt_enable (i2c_type *i2c_x, uint32_t source, confirm_state new_state)
enable or disable interrupts. More...
flag_status | i2c_interrupt_get (i2c_type *i2c_x, uint16_t source)
get interrupt status More...
void | i2c_dma_enable (i2c_type *i2c_x, i2c_dma_request_type dma_req, confirm_state new_state)
enable or disable dma requests. More...
void | i2c_transmit_set (i2c_type *i2c_x, uint16_t address, uint8_t cnt, i2c_reload_stop_mode_type rld_stop, i2c_start_mode_type start)
config data transfer. More...
void | i2c_start_generate (i2c_type *i2c_x)
generate start condition. More...
void | i2c_stop_generate (i2c_type *i2c_x)
generate stop condition. More...
void | i2c_data_send (i2c_type *i2c_x, uint8_t data)
send a byte through the i2c periph. More...
uint8_t | i2c_data_receive (i2c_type *i2c_x)
receive a byte through the i2c periph. More...
flag_status | i2c_flag_get (i2c_type *i2c_x, uint32_t flag)
get flag status. More...
void | i2c_flag_clear (i2c_type *i2c_x, uint32_t flag)
clear flag status More...

Detailed Description

at32f435_437 i2c header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_i2c.h.


AT32F435/437 Firmwary Library: at32f435_437_misc.h File Reference

  • libraries
  • drivers
  • inc
Macros | Enumerations | Functions
at32f435_437_misc.h File Reference

at32f435_437 misc header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Macros

#define | NVIC_VECTTAB_RAM ((uint32_t)0x20000000)
#define | NVIC_VECTTAB_FLASH ((uint32_t)0x08000000)

Enumerations

enum nvic_priority_group_type {
NVIC_PRIORITY_GROUP_0 = ((uint32_t)0x7) , NVIC_PRIORITY_GROUP_1 = ((uint32_t)0x6) , NVIC_PRIORITY_GROUP_2 = ((uint32_t)0x5) , NVIC_PRIORITY_GROUP_3 = ((uint32_t)0x4) ,
NVIC_PRIORITY_GROUP_4 = ((uint32_t)0x3)
}
nvic interrupt priority group More...
enum | nvic_lowpower_mode_type { NVIC_LP_SLEEPONEXIT = 0x02 , NVIC_LP_SLEEPDEEP = 0x04 , NVIC_LP_SEVONPEND = 0x10 }
nvic low power mode More...
enum | systick_clock_source_type { SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8 = ((uint32_t)0x00000000) , SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV = ((uint32_t)0x00000004) }
systick clock source More...

Functions

void | nvic_system_reset (void)
system reset More...
void | nvic_irq_enable (IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq More...
void | nvic_irq_disable (IRQn_Type irqn)
disable nvic irq number More...
void | nvic_priority_group_config (nvic_priority_group_type priority_group)
config nvic priority group More...
void | nvic_vector_table_set (uint32_t base, uint32_t offset)
set the vector table location and offset. More...
void | nvic_lowpower_mode_config (nvic_lowpower_mode_type lp_mode, confirm_state new_state)
config nvic lowpower mode More...
void | systick_clock_source_config (systick_clock_source_type source)
config systick clock source More...

Detailed Description

at32f435_437 misc header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_misc.h.


AT32F435/437 Firmwary Library: at32f435_437_pwc.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f435_437_pwc.h File Reference

at32f435_437 pwr header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct pwc_type
type define pwc register all More...

Macros

#define | PWC_WAKEUP_FLAG ((uint32_t)0x00000001)
#define | PWC_STANDBY_FLAG ((uint32_t)0x00000002)
#define | PWC_PVM_OUTPUT_FLAG ((uint32_t)0x00000004)
#define | PWC_WAKEUP_PIN_1 ((uint32_t)0x00000100)
pwc wakeup pin num definition More...
#define | PWC_WAKEUP_PIN_2 ((uint32_t)0x00000200)
#define | pwc_ldo_output_voltage_set(val) (PWC->ldoov_bit.ldoovsel = val)
select ldo output voltage. More...
#define | PWC ((pwc_type *) PWC_BASE)

Enumerations

enum pwc_pvm_voltage_type {
PWC_PVM_VOLTAGE_2V3 = 0x01 , PWC_PVM_VOLTAGE_2V4 = 0x02 , PWC_PVM_VOLTAGE_2V5 = 0x03 , PWC_PVM_VOLTAGE_2V6 = 0x04 ,
PWC_PVM_VOLTAGE_2V7 = 0x05 , PWC_PVM_VOLTAGE_2V8 = 0x06 , PWC_PVM_VOLTAGE_2V9 = 0x07
}
pwc pvm voltage type More...
enum | pwc_ldo_output_voltage_type { PWC_LDO_OUTPUT_1V2 = 0x00 , PWC_LDO_OUTPUT_1V3 = 0x01 , PWC_LDO_OUTPUT_1V1 = 0x04 , PWC_LDO_OUTPUT_1V0 = 0x05 }
pwc ldo output voltage type More...
enum | pwc_sleep_enter_type { PWC_SLEEP_ENTER_WFI = 0x00 , PWC_SLEEP_ENTER_WFE = 0x01 }
pwc sleep enter type More...
enum | pwc_deep_sleep_enter_type { PWC_DEEP_SLEEP_ENTER_WFI = 0x00 , PWC_DEEP_SLEEP_ENTER_WFE = 0x01 }
pwc deep sleep enter type More...
enum | pwc_regulator_type { PWC_REGULATOR_ON = 0x00 , PWC_REGULATOR_LOW_POWER = 0x01 }
pwc regulator type More...

Functions

void | pwc_reset (void)
deinitialize the pwc peripheral registers to their default reset values. More...
void | pwc_battery_powered_domain_access (confirm_state new_state)
enable or disable access to the battery powered domain. More...
void | pwc_pvm_level_select (pwc_pvm_voltage_type pvm_voltage)
select the voltage threshold detected by the power voltage detector. More...
void | pwc_power_voltage_monitor_enable (confirm_state new_state)
enable or disable pwc power voltage monitor (pvm) More...
void | pwc_wakeup_pin_enable (uint32_t pin_num, confirm_state new_state)
enable or disable pwc standby wakeup pin More...
void | pwc_flag_clear (uint32_t pwc_flag)
clear flag of pwc More...
flag_status | pwc_flag_get (uint32_t pwc_flag)
get flag of pwc More...
void | pwc_sleep_mode_enter (pwc_sleep_enter_type pwc_sleep_enter)
enter pwc sleep mode More...
void | pwc_deep_sleep_mode_enter (pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode More...
void | pwc_voltage_regulate_set (pwc_regulator_type pwc_regulator)
regulate low power consumption in the deep sleep mode More...
void | pwc_standby_mode_enter (void)
enter pwc standby mode More...

Detailed Description

at32f435_437 pwr header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_pwc.h.


AT32F435/437 Firmwary Library: at32f435_437_qspi.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f435_437_qspi.h File Reference

at32f435_437 qspi header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct | qspi_cmd_type
qspi cmd type More...
struct | qspi_xip_type
qspi xip type More...
struct | qspi_type
type define qspi register all More...

Macros

#define | QSPI_CMDSTS_FLAG ((uint32_t)0x00000001)
#define | QSPI_RXFIFORDY_FLAG ((uint32_t)0x00000002)
#define | QSPI_TXFIFORDY_FLAG ((uint32_t)0x00000004)
#define | QSPI1 ((qspi_type*)QSPI1_REG_BASE)
#define | QSPI2 ((qspi_type*)QSPI2_REG_BASE)

Enumerations

enum | qspi_xip_read_sel_type { QSPI_XIPR_SEL_MODED = 0x00 , QSPI_XIPR_SEL_MODET = 0x01 }
qspi xip read access mode type More...
enum | qspi_xip_write_sel_type { QSPI_XIPW_SEL_MODED = 0x00 , QSPI_XIPW_SEL_MODET = 0x01 }
qspi xip write access mode type More...
enum qspi_busy_pos_type {
QSPI_BUSY_OFFSET_0 = 0x00 , QSPI_BUSY_OFFSET_1 = 0x01 , QSPI_BUSY_OFFSET_2 = 0x02 , QSPI_BUSY_OFFSET_3 = 0x03 ,
QSPI_BUSY_OFFSET_4 = 0x04 , QSPI_BUSY_OFFSET_5 = 0x05 , QSPI_BUSY_OFFSET_6 = 0x06 , QSPI_BUSY_OFFSET_7 = 0x07
}
qspi busy bit offset position in status register type More...
enum | qspi_read_status_conf_type { QSPI_RSTSC_HW_AUTO = 0x00 , QSPI_RSTSC_SW_ONCE = 0x01 }
qspi read status configure type More...
enum qspi_operate_mode_type {
QSPI_OPERATE_MODE_111 = 0x00 , QSPI_OPERATE_MODE_112 = 0x01 , QSPI_OPERATE_MODE_114 = 0x02 , QSPI_OPERATE_MODE_122 = 0x03 ,
QSPI_OPERATE_MODE_144 = 0x04 , QSPI_OPERATE_MODE_222 = 0x05 , QSPI_OPERATE_MODE_444 = 0x06
}
qspi operate mode type More...
enum qspi_clk_div_type {
QSPI_CLK_DIV_2 = 0x00 , QSPI_CLK_DIV_4 = 0x01 , QSPI_CLK_DIV_6 = 0x02 , QSPI_CLK_DIV_8 = 0x03 ,
QSPI_CLK_DIV_3 = 0x04 , QSPI_CLK_DIV_5 = 0x05 , QSPI_CLK_DIV_10 = 0x06 , QSPI_CLK_DIV_12 = 0x07
}
qspi clock division type More...
enum qspi_cmd_adrlen_type {
QSPI_CMD_ADRLEN_0_BYTE = 0x00 , QSPI_CMD_ADRLEN_1_BYTE = 0x01 , QSPI_CMD_ADRLEN_2_BYTE = 0x02 , QSPI_CMD_ADRLEN_3_BYTE = 0x03 ,
QSPI_CMD_ADRLEN_4_BYTE = 0x04
}
qspi command port address length type More...
enum | qspi_cmd_inslen_type { QSPI_CMD_INSLEN_0_BYTE = 0x00 , QSPI_CMD_INSLEN_1_BYTE = 0x01 , QSPI_CMD_INSLEN_2_BYTE = 0x02 }
qspi command port instruction length type More...
enum | qspi_xip_addrlen_type { QSPI_XIP_ADDRLEN_3_BYTE = 0x00 , QSPI_XIP_ADDRLEN_4_BYTE = 0x01 }
qspi xip r/w address length type More...
enum | qspi_clk_mode_type { QSPI_SCK_MODE_0 = 0x00 , QSPI_SCK_MODE_3 = 0x01 }
qspi sckout mode type More...
enum | qspi_dma_fifo_thod_type { QSPI_DMA_FIFO_THOD_WORD08 = 0x00 , QSPI_DMA_FIFO_THOD_WORD16 = 0x01 , QSPI_DMA_FIFO_THOD_WORD32 = 0x02 }
qspi dma tx/rx fifo threshold type More...

Functions

void | qspi_encryption_enable (qspi_type *qspi_x, confirm_state new_state)
enable/disable encryption for qspi. More...
void | qspi_sck_mode_set (qspi_type *qspi_x, qspi_clk_mode_type new_mode)
set qspi sck mode. More...
void | qspi_clk_division_set (qspi_type *qspi_x, qspi_clk_div_type new_clkdiv)
set qspi clock division More...
void | qspi_xip_cache_bypass_set (qspi_type *qspi_x, confirm_state new_state)
enable/disable cache in xip mode More...
void | qspi_interrupt_enable (qspi_type *qspi_x, confirm_state new_state)
enable/disable interrupt when command is completed More...
flag_status | qspi_flag_get (qspi_type *qspi_x, uint32_t flag)
get status flags. More...
void | qspi_flag_clear (qspi_type *qspi_x, uint32_t flag)
clear flags More...
void | qspi_dma_rx_threshold_set (qspi_type *qspi_x, qspi_dma_fifo_thod_type new_threshold)
set dma threshold for dma rx More...
void | qspi_dma_tx_threshold_set (qspi_type *qspi_x, qspi_dma_fifo_thod_type new_threshold)
set dma threshold for dma tx More...
void | qspi_dma_enable (qspi_type *qspi_x, confirm_state new_state)
enable/disable dma transfer More...
void | qspi_busy_config (qspi_type *qspi_x, qspi_busy_pos_type busy_pos)
set wip position in status register of flash More...
void | qspi_xip_enable (qspi_type *qspi_x, confirm_state new_state)
enable xip mode or command-port mode. More...
void | qspi_cmd_operation_kick (qspi_type *qspi_x, qspi_cmd_type *qspi_cmd_struct)
set command-port and qspi_x will start to work More...
void | qspi_xip_init (qspi_type *qspi_x, qspi_xip_type *xip_init_struct)
initial xip mode for qspi_x More...
uint8_t | qspi_byte_read (qspi_type *qspi_x)
read one byte from qspi device in command mode More...
uint16_t | qspi_half_word_read (qspi_type *qspi_x)
read one half-word from qspi device in command mode More...
uint32_t | qspi_word_read (qspi_type *qspi_x)
read one word from qspi device in command mode More...
void | qspi_word_write (qspi_type *qspi_x, uint32_t value)
write one word to qspi device in command mode More...
void | qspi_half_word_write (qspi_type *qspi_x, uint16_t value)
write one half-word to qspi device in command mode More...
void | qspi_byte_write (qspi_type *qspi_x, uint8_t value)
write one byte to qspi device in command mode More...

Detailed Description

at32f435_437 qspi header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_qspi.h.


AT32F435/437 Firmwary Library: at32f435_437_scfg.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f435_437_scfg.h File Reference

at32f435_437 system config header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct scfg_type
type define system config register all More...

Macros

#define | SCFG_REG(value) PERIPH_REG(SCFG_BASE, value)
#define | SCFG_REG_BIT(value) PERIPH_REG_BIT(value)
#define | SCFG ((scfg_type *) SCFG_BASE)

Enumerations

enum | scfg_xmc_swap_type { SCFG_XMC_SWAP_NONE = 0x00 , SCFG_XMC_SWAP_MODE1 = 0x01 , SCFG_XMC_SWAP_MODE2 = 0x02 , SCFG_XMC_SWAP_MODE3 = 0x03 }
scfg xmc addres mapping swap type More...
enum | scfg_ir_source_type { SCFG_IR_SOURCE_TMR10 = 0x00 , SCFG_IR_SOURCE_USART1 = 0x01 , SCFG_IR_SOURCE_USART2 = 0x02 }
scfg infrared modulation signal source selecting type More...
enum | scfg_ir_polarity_type { SCFG_IR_POLARITY_NO_AFFECTE = 0x00 , SCFG_IR_POLARITY_REVERSE = 0x01 }
scfg infrared output polarity selecting type More...
enum scfg_mem_map_type {
SCFG_MEM_MAP_MAIN_MEMORY = 0x00 , SCFG_MEM_MAP_BOOT_MEMORY = 0x01 , SCFG_MEM_MAP_XMC_BANK1 = 0x02 , SCFG_MEM_MAP_INTERNAL_SRAM = 0x03 ,
SCFG_MEM_MAP_XMC_SDRAM_BANK1 = 0x04
}
scfg memory address mapping selecting type More...
enum scfg_pins_source_type {
SCFG_PINS_SOURCE0 = 0x00 , SCFG_PINS_SOURCE1 = 0x01 , SCFG_PINS_SOURCE2 = 0x02 , SCFG_PINS_SOURCE3 = 0x03 ,
SCFG_PINS_SOURCE4 = 0x04 , SCFG_PINS_SOURCE5 = 0x05 , SCFG_PINS_SOURCE6 = 0x06 , SCFG_PINS_SOURCE7 = 0x07 ,
SCFG_PINS_SOURCE8 = 0x08 , SCFG_PINS_SOURCE9 = 0x09 , SCFG_PINS_SOURCE10 = 0x0A , SCFG_PINS_SOURCE11 = 0x0B ,
SCFG_PINS_SOURCE12 = 0x0C , SCFG_PINS_SOURCE13 = 0x0D , SCFG_PINS_SOURCE14 = 0x0E , SCFG_PINS_SOURCE15 = 0x0F
}
scfg pin source type More...
enum scfg_port_source_type {
SCFG_PORT_SOURCE_GPIOA = 0x00 , SCFG_PORT_SOURCE_GPIOB = 0x01 , SCFG_PORT_SOURCE_GPIOC = 0x02 , SCFG_PORT_SOURCE_GPIOD = 0x03 ,
SCFG_PORT_SOURCE_GPIOE = 0x04 , SCFG_PORT_SOURCE_GPIOF = 0x05 , SCFG_PORT_SOURCE_GPIOG = 0x06 , SCFG_PORT_SOURCE_GPIOH = 0x07
}
gpio port source type More...
enum | scfg_emac_interface_type { SCFG_EMAC_SELECT_MII = 0x00 , SCFG_EMAC_SELECT_RMII = 0x01 }
scfg emac interface selecting type More...
enum scfg_ultra_driven_pins_type {
SCFG_ULTRA_DRIVEN_PB3 = ((( 0x2C ) << 16) | ( 0 & 0x1f)) , SCFG_ULTRA_DRIVEN_PB9 = ((( 0x2C ) << 16) | ( 1 & 0x1f)) , SCFG_ULTRA_DRIVEN_PB10 = ((( 0x2C ) << 16) | ( 2 & 0x1f)) , SCFG_ULTRA_DRIVEN_PD12 = ((( 0x2C ) << 16) | ( 5 & 0x1f)) ,
SCFG_ULTRA_DRIVEN_PD13 = ((( 0x2C ) << 16) | ( 6 & 0x1f)) , SCFG_ULTRA_DRIVEN_PD14 = ((( 0x2C ) << 16) | ( 7 & 0x1f)) , SCFG_ULTRA_DRIVEN_PD15 = ((( 0x2C ) << 16) | ( 8 & 0x1f)) , SCFG_ULTRA_DRIVEN_PF14 = ((( 0x2C ) << 16) | ( 9 & 0x1f)) ,
SCFG_ULTRA_DRIVEN_PF15 = ((( 0x2C ) << 16) | ( 10 & 0x1f))
}
scfg ultra high sourcing/sinking strength pins type More...

Functions

void | scfg_reset (void)
scfg reset More...
void | scfg_xmc_mapping_swap_set (scfg_xmc_swap_type xmc_swap)
scfg xmc address mapping swap set More...
void | scfg_infrared_config (scfg_ir_source_type source, scfg_ir_polarity_type polarity)
scfg infrared config More...
void | scfg_mem_map_set (scfg_mem_map_type mem_map)
scfg memory address mapping set More...
void | scfg_emac_interface_set (scfg_emac_interface_type mode)
scfg emac interface set More...
void | scfg_exint_line_config (scfg_port_source_type port_source, scfg_pins_source_type pin_source)
select the gpio pin used as exint line. More...
void | scfg_pins_ultra_driven_enable (scfg_ultra_driven_pins_type value, confirm_state new_state)
enable or disable gpio pins ultra driven. More...

Detailed Description

at32f435_437 system config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_scfg.h.


AT32F435/437 Firmwary Library: at32f435_437_sdio.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f435_437_sdio.h File Reference

at32f435_437 sdio header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct | sdio_command_struct_type
sdio command structure More...
struct | sdio_data_struct_type
sdio data structure More...
struct | sdio_type
type define sdio register all More...

Macros

#define | SDIO_CMDFAIL_INT ((uint32_t)0x00000001)
#define | SDIO_DTFAIL_INT ((uint32_t)0x00000002)
#define | SDIO_CMDTIMEOUT_INT ((uint32_t)0x00000004)
#define | SDIO_DTTIMEOUT_INT ((uint32_t)0x00000008)
#define | SDIO_TXERRU_INT ((uint32_t)0x00000010)
#define | SDIO_RXERRO_INT ((uint32_t)0x00000020)
#define | SDIO_CMDRSPCMPL_INT ((uint32_t)0x00000040)
#define | SDIO_CMDCMPL_INT ((uint32_t)0x00000080)
#define | SDIO_DTCMP_INT ((uint32_t)0x00000100)
#define | SDIO_SBITERR_INT ((uint32_t)0x00000200)
#define | SDIO_DTBLKCMPL_INT ((uint32_t)0x00000400)
#define | SDIO_DOCMD_INT ((uint32_t)0x00000800)
#define | SDIO_DOTX_INT ((uint32_t)0x00001000)
#define | SDIO_DORX_INT ((uint32_t)0x00002000)
#define | SDIO_TXBUFH_INT ((uint32_t)0x00004000)
#define | SDIO_RXBUFH_INT ((uint32_t)0x00008000)
#define | SDIO_TXBUFF_INT ((uint32_t)0x00010000)
#define | SDIO_RXBUFF_INT ((uint32_t)0x00020000)
#define | SDIO_TXBUFE_INT ((uint32_t)0x00040000)
#define | SDIO_RXBUFE_INT ((uint32_t)0x00080000)
#define | SDIO_TXBUF_INT ((uint32_t)0x00100000)
#define | SDIO_RXBUF_INT ((uint32_t)0x00200000)
#define | SDIO_SDIOIF_INT ((uint32_t)0x00400000)
#define | SDIO_CMDFAIL_FLAG ((uint32_t)0x00000001)
#define | SDIO_DTFAIL_FLAG ((uint32_t)0x00000002)
#define | SDIO_CMDTIMEOUT_FLAG ((uint32_t)0x00000004)
#define | SDIO_DTTIMEOUT_FLAG ((uint32_t)0x00000008)
#define | SDIO_TXERRU_FLAG ((uint32_t)0x00000010)
#define | SDIO_RXERRO_FLAG ((uint32_t)0x00000020)
#define | SDIO_CMDRSPCMPL_FLAG ((uint32_t)0x00000040)
#define | SDIO_CMDCMPL_FLAG ((uint32_t)0x00000080)
#define | SDIO_DTCMPL_FLAG ((uint32_t)0x00000100)
#define | SDIO_SBITERR_FLAG ((uint32_t)0x00000200)
#define | SDIO_DTBLKCMPL_FLAG ((uint32_t)0x00000400)
#define | SDIO_DOCMD_FLAG ((uint32_t)0x00000800)
#define | SDIO_DOTX_FLAG ((uint32_t)0x00001000)
#define | SDIO_DORX_FLAG ((uint32_t)0x00002000)
#define | SDIO_TXBUFH_FLAG ((uint32_t)0x00004000)
#define | SDIO_RXBUFH_FLAG ((uint32_t)0x00008000)
#define | SDIO_TXBUFF_FLAG ((uint32_t)0x00010000)
#define | SDIO_RXBUFF_FLAG ((uint32_t)0x00020000)
#define | SDIO_TXBUFE_FLAG ((uint32_t)0x00040000)
#define | SDIO_RXBUFE_FLAG ((uint32_t)0x00080000)
#define | SDIO_TXBUF_FLAG ((uint32_t)0x00100000)
#define | SDIO_RXBUF_FLAG ((uint32_t)0x00200000)
#define | SDIO_SDIOIF_FLAG ((uint32_t)0x00400000)
#define | SDIO1 ((sdio_type *) SDIO1_BASE)
#define | SDIO2 ((sdio_type *) SDIO2_BASE)

Enumerations

enum | sdio_power_state_type { SDIO_POWER_OFF = 0x00 , SDIO_POWER_ON = 0x03 }
sdio power state More...
enum | sdio_edge_phase_type { SDIO_CLOCK_EDGE_RISING = 0x00 , SDIO_CLOCK_EDGE_FALLING = 0x01 }
sdio edge phase More...
enum | sdio_bus_width_type { SDIO_BUS_WIDTH_D1 = 0x00 , SDIO_BUS_WIDTH_D4 = 0x01 , SDIO_BUS_WIDTH_D8 = 0x02 }
sdio bus width More...
enum | sdio_reponse_type { SDIO_RESPONSE_NO = 0x00 , SDIO_RESPONSE_SHORT = 0x01 , SDIO_RESPONSE_LONG = 0x03 }
sdio response type More...
enum | sdio_wait_type { SDIO_WAIT_FOR_NO = 0x00 , SDIO_WAIT_FOR_INT = 0x01 , SDIO_WAIT_FOR_PEND = 0x02 }
sdio wait type More...
enum | sdio_rsp_index_type { SDIO_RSP1_INDEX = 0x00 , SDIO_RSP2_INDEX = 0x01 , SDIO_RSP3_INDEX = 0x02 , SDIO_RSP4_INDEX = 0x03 }
sdio response register index More...
enum sdio_block_size_type {
SDIO_DATA_BLOCK_SIZE_1B = 0x00 , SDIO_DATA_BLOCK_SIZE_2B = 0x01 , SDIO_DATA_BLOCK_SIZE_4B = 0x02 , SDIO_DATA_BLOCK_SIZE_8B = 0x03 ,
SDIO_DATA_BLOCK_SIZE_16B = 0x04 , SDIO_DATA_BLOCK_SIZE_32B = 0x05 , SDIO_DATA_BLOCK_SIZE_64B = 0x06 , SDIO_DATA_BLOCK_SIZE_128B = 0x07 ,
SDIO_DATA_BLOCK_SIZE_256B = 0x08 , SDIO_DATA_BLOCK_SIZE_512B = 0x09 , SDIO_DATA_BLOCK_SIZE_1024B = 0x0A , SDIO_DATA_BLOCK_SIZE_2048B = 0x0B ,
SDIO_DATA_BLOCK_SIZE_4096B = 0x0C , SDIO_DATA_BLOCK_SIZE_8192B = 0x0D , SDIO_DATA_BLOCK_SIZE_16384B = 0x0E
}
sdio data block size More...
enum | sdio_transfer_mode_type { SDIO_DATA_BLOCK_TRANSFER = 0x00 , SDIO_DATA_STREAM_TRANSFER = 0x01 }
sdio data transfer mode More...
enum | sdio_transfer_direction_type { SDIO_DATA_TRANSFER_TO_CARD = 0x00 , SDIO_DATA_TRANSFER_TO_CONTROLLER = 0x01 }
sdio data transfer direction More...
enum | sdio_read_wait_mode_type { SDIO_READ_WAIT_CONTROLLED_BY_D2 = 0x00 , SDIO_READ_WAIT_CONTROLLED_BY_CK = 0x01 }
sdio read wait mode More...

Functions

void | sdio_reset (sdio_type *sdio_x)
reset the sdio register More...
void | sdio_power_set (sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller More...
sdio_power_state_type | sdio_power_status_get (sdio_type *sdio_x)
get power status. More...
void | sdio_clock_config (sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock More...
void | sdio_bus_width_config (sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width More...
void | sdio_clock_bypass (sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss More...
void | sdio_power_saving_mode_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle. More...
void | sdio_flow_control_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control. More...
void | sdio_clock_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output. More...
void | sdio_dma_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable dma. More...
void | sdio_interrupt_enable (sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt. More...
flag_status | sdio_flag_get (sdio_type *sdio_x, uint32_t flag)
get sdio flag. More...
void | sdio_flag_clear (sdio_type *sdio_x, uint32_t flag)
clear sdio flag. More...
void | sdio_command_config (sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command. More...
void | sdio_command_state_machine_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM). More...
uint8_t | sdio_command_response_get (sdio_type *sdio_x)
get command index of last command for which response received. More...
uint32_t | sdio_response_get (sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command. More...
void | sdio_data_config (sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data. More...
void | sdio_data_state_machine_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM). More...
uint32_t | sdio_data_counter_get (sdio_type *sdio_x)
get the number of remaining data bytes to be transferred. More...
uint32_t | sdio_data_read (sdio_type *sdio_x)
read a word data from sdio fifo. More...
uint32_t | sdio_buffer_counter_get (sdio_type *sdio_x)
get the number of words left to be written to or read from fifo.. More...
void | sdio_data_write (sdio_type *sdio_x, uint32_t data)
write one word data to fifo. More...
void | sdio_read_wait_mode_set (sdio_type *sdio_x, sdio_read_wait_mode_type mode)
set the read wait mode. More...
void | sdio_read_wait_start (sdio_type *sdio_x, confirm_state new_state)
enable or disable to start sd i/o read wait operation. More...
void | sdio_read_wait_stop (sdio_type *sdio_x, confirm_state new_state)
enable or disable to stop sd i/o read wait operation. More...
void | sdio_io_function_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable the sd i/o function. More...
void | sdio_io_suspend_command_set (sdio_type *sdio_x, confirm_state new_state)
enable or disable sd i/o suspend command sending. More...

Detailed Description

at32f435_437 sdio header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_sdio.h.


AT32F435/437 Firmwary Library: at32f435_437_spi.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f435_437_spi.h File Reference

at32f435_437 spi header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct | spi_init_type
spi init type More...
struct | i2s_init_type
i2s init type More...
struct | spi_type
type define spi register all More...

Macros

#define | SPI_I2S_RDBF_FLAG 0x0001
#define | SPI_I2S_TDBE_FLAG 0x0002
#define | I2S_ACS_FLAG 0x0004
#define | I2S_TUERR_FLAG 0x0008
#define | SPI_CCERR_FLAG 0x0010
#define | SPI_MMERR_FLAG 0x0020
#define | SPI_I2S_ROERR_FLAG 0x0040
#define | SPI_I2S_BF_FLAG 0x0080
#define | SPI_CSPAS_FLAG 0x0100
#define | SPI_I2S_ERROR_INT 0x0020
#define | SPI_I2S_RDBF_INT 0x0040
#define | SPI_I2S_TDBE_INT 0x0080
#define | SPI1 ((spi_type *) SPI1_BASE)
#define | SPI2 ((spi_type *) SPI2_BASE)
#define | SPI3 ((spi_type *) SPI3_BASE)
#define | SPI4 ((spi_type *) SPI4_BASE)
#define | I2S2EXT ((spi_type *) I2S2EXT_BASE)
#define | I2S3EXT ((spi_type *) I2S3EXT_BASE)

Enumerations

enum | spi_frame_bit_num_type { SPI_FRAME_8BIT = 0x00 , SPI_FRAME_16BIT = 0x01 }
spi frame bit num type More...
enum | spi_master_slave_mode_type { SPI_MODE_SLAVE = 0x00 , SPI_MODE_MASTER = 0x01 }
spi master/slave mode type More...
enum | spi_clock_polarity_type { SPI_CLOCK_POLARITY_LOW = 0x00 , SPI_CLOCK_POLARITY_HIGH = 0x01 }
spi clock polarity (clkpol) type More...
enum | spi_clock_phase_type { SPI_CLOCK_PHASE_1EDGE = 0x00 , SPI_CLOCK_PHASE_2EDGE = 0x01 }
spi clock phase (clkpha) type More...
enum | spi_cs_mode_type { SPI_CS_HARDWARE_MODE = 0x00 , SPI_CS_SOFTWARE_MODE = 0x01 }
spi cs mode type More...
enum spi_mclk_freq_div_type {
SPI_MCLK_DIV_2 = 0x00 , SPI_MCLK_DIV_3 = 0x0A , SPI_MCLK_DIV_4 = 0x01 , SPI_MCLK_DIV_8 = 0x02 ,
SPI_MCLK_DIV_16 = 0x03 , SPI_MCLK_DIV_32 = 0x04 , SPI_MCLK_DIV_64 = 0x05 , SPI_MCLK_DIV_128 = 0x06 ,
SPI_MCLK_DIV_256 = 0x07 , SPI_MCLK_DIV_512 = 0x08 , SPI_MCLK_DIV_1024 = 0x09
}
spi master clock frequency division type More...
enum | spi_first_bit_type { SPI_FIRST_BIT_MSB = 0x00 , SPI_FIRST_BIT_LSB = 0x01 }
spi transmit first bit (lsb/msb) type More...
enum | spi_transmission_mode_type { SPI_TRANSMIT_FULL_DUPLEX = 0x00 , SPI_TRANSMIT_SIMPLEX_RX = 0x01 , SPI_TRANSMIT_HALF_DUPLEX_RX = 0x02 , SPI_TRANSMIT_HALF_DUPLEX_TX = 0x03 }
spi transmission mode type More...
enum | spi_crc_direction_type { SPI_CRC_RX = 0x0014 , SPI_CRC_TX = 0x0018 }
spi crc direction type More...
enum | spi_half_duplex_direction_type { SPI_HALF_DUPLEX_DIRECTION_RX = 0x00 , SPI_HALF_DUPLEX_DIRECTION_TX = 0x01 }
spi single line bidirectional direction type More...
enum | spi_software_cs_level_type { SPI_SWCS_INTERNAL_LEVEL_LOW = 0x00 , SPI_SWCS_INTERNAL_LEVEL_HIGHT = 0x01 }
spi software cs internal level type More...
enum i2s_audio_protocol_type {
I2S_AUDIO_PROTOCOL_PHILLIPS = 0x00 , I2S_AUDIO_PROTOCOL_MSB = 0x01 , I2S_AUDIO_PROTOCOL_LSB = 0x02 , I2S_AUDIO_PROTOCOL_PCM_SHORT = 0x03 ,
I2S_AUDIO_PROTOCOL_PCM_LONG = 0x04
}
i2s audio protocol type More...
enum i2s_audio_sampling_freq_type {
I2S_AUDIO_FREQUENCY_DEFAULT = 2 , I2S_AUDIO_FREQUENCY_8K = 8000 , I2S_AUDIO_FREQUENCY_11_025K = 11025 , I2S_AUDIO_FREQUENCY_16K = 16000 ,
I2S_AUDIO_FREQUENCY_22_05K = 22050 , I2S_AUDIO_FREQUENCY_32K = 32000 , I2S_AUDIO_FREQUENCY_44_1K = 44100 , I2S_AUDIO_FREQUENCY_48K = 48000 ,
I2S_AUDIO_FREQUENCY_96K = 96000 , I2S_AUDIO_FREQUENCY_192K = 192000
}
i2s audio frequency type More...
enum | i2s_data_channel_format_type { I2S_DATA_16BIT_CHANNEL_16BIT = 0x01 , I2S_DATA_16BIT_CHANNEL_32BIT = 0x02 , I2S_DATA_24BIT_CHANNEL_32BIT = 0x03 , I2S_DATA_32BIT_CHANNEL_32BIT = 0x04 }
i2s data bit num and channel bit num type More...
enum | i2s_operation_mode_type { I2S_MODE_SLAVE_TX = 0x00 , I2S_MODE_SLAVE_RX = 0x01 , I2S_MODE_MASTER_TX = 0x02 , I2S_MODE_MASTER_RX = 0x03 }
i2s operation mode type More...
enum | i2s_clock_polarity_type { I2S_CLOCK_POLARITY_LOW = 0x00 , I2S_CLOCK_POLARITY_HIGH = 0x01 }
i2s clock polarity type More...

Functions

void | spi_i2s_reset (spi_type *spi_x)
spi reset by crm reset register More...
void | spi_default_para_init (spi_init_type *spi_init_struct)
spi init config with its default value. More...
void | spi_init (spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value. More...
void | spi_ti_mode_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the ti mode for the spi peripheral. More...
void | spi_crc_next_transmit (spi_type *spi_x)
spi next transmit crc for the spi peripheral. More...
void | spi_crc_polynomial_set (spi_type *spi_x, uint16_t crc_poly)
set the crc polynomial value for the spi peripheral. More...
uint16_t | spi_crc_polynomial_get (spi_type *spi_x)
return the crc polynomial register value for the spi peripheral. More...
void | spi_crc_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the hardware crc calculation for the spi peripheral. More...
uint16_t | spi_crc_value_get (spi_type *spi_x, spi_crc_direction_type crc_direction)
return the transmit or the receive crc value for the spi peripheral. More...
void | spi_hardware_cs_output_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the hardware cs output for the spi peripheral. More...
void | spi_software_cs_internal_level_set (spi_type *spi_x, spi_software_cs_level_type level)
set the software cs internal level for the spi peripheral. More...
void | spi_frame_bit_num_set (spi_type *spi_x, spi_frame_bit_num_type bit_num)
set the data frame bit num for the spi peripheral. More...
void | spi_half_duplex_direction_set (spi_type *spi_x, spi_half_duplex_direction_type direction)
set the data transmission direction in single line bidirectiona half duplex mode of the spi peripheral. More...
void | spi_enable (spi_type *spi_x, confirm_state new_state)
enable or disable spi. More...
void | i2s_default_para_init (i2s_init_type *i2s_init_struct)
i2s init config with its default value. More...
void | i2s_init (spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value. More...
void | i2s_enable (spi_type *spi_x, confirm_state new_state)
enable or disable i2s. More...
void | spi_i2s_interrupt_enable (spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts. More...
void | spi_i2s_dma_transmitter_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode. More...
void | spi_i2s_dma_receiver_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode. More...
void | spi_i2s_data_transmit (spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit More...
uint16_t | spi_i2s_data_receive (spi_type *spi_x)
spi/i2s data receive More...
flag_status | spi_i2s_flag_get (spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral. More...
void | spi_i2s_flag_clear (spi_type *spi_x, uint32_t spi_i2s_flag)
clear flag of the specified spi/i2s peripheral. More...

Detailed Description

at32f435_437 spi header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_spi.h.


AT32F435/437 Firmwary Library: at32f435_437_tmr.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f435_437_tmr.h File Reference

at32f435_437 tmr header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct | tmr_output_config_type
tmr output config type More...
struct | tmr_input_config_type
tmr input capture config type More...
struct | tmr_brkdt_config_type
tmr brkdt config type More...
struct | tmr_type
type define tmr register all More...

Macros

#define | TMR_OVF_FLAG ((uint32_t)0x000001)
#define | TMR_C1_FLAG ((uint32_t)0x000002)
#define | TMR_C2_FLAG ((uint32_t)0x000004)
#define | TMR_C3_FLAG ((uint32_t)0x000008)
#define | TMR_C4_FLAG ((uint32_t)0x000010)
#define | TMR_C5_FLAG ((uint32_t)0x010000)
#define | TMR_HALL_FLAG ((uint32_t)0x000020)
#define | TMR_TRIGGER_FLAG ((uint32_t)0x000040)
#define | TMR_BRK_FLAG ((uint32_t)0x000080)
#define | TMR_C1_RECAPTURE_FLAG ((uint32_t)0x000200)
#define | TMR_C2_RECAPTURE_FLAG ((uint32_t)0x000400)
#define | TMR_C3_RECAPTURE_FLAG ((uint32_t)0x000800)
#define | TMR_C4_RECAPTURE_FLAG ((uint32_t)0x001000)
#define | TMR_OVF_INT ((uint32_t)0x000001)
#define | TMR_C1_INT ((uint32_t)0x000002)
#define | TMR_C2_INT ((uint32_t)0x000004)
#define | TMR_C3_INT ((uint32_t)0x000008)
#define | TMR_C4_INT ((uint32_t)0x000010)
#define | TMR_HALL_INT ((uint32_t)0x000020)
#define | TMR_TRIGGER_INT ((uint32_t)0x000040)
#define | TMR_BRK_INT ((uint32_t)0x000080)
#define | TMR1 ((tmr_type *) TMR1_BASE)
#define | TMR2 ((tmr_type *) TMR2_BASE)
#define | TMR3 ((tmr_type *) TMR3_BASE)
#define | TMR4 ((tmr_type *) TMR4_BASE)
#define | TMR5 ((tmr_type *) TMR5_BASE)
#define | TMR6 ((tmr_type *) TMR6_BASE)
#define | TMR7 ((tmr_type *) TMR7_BASE)
#define | TMR8 ((tmr_type *) TMR8_BASE)
#define | TMR9 ((tmr_type *) TMR9_BASE)
#define | TMR10 ((tmr_type *) TMR10_BASE)
#define | TMR11 ((tmr_type *) TMR11_BASE)
#define | TMR12 ((tmr_type *) TMR12_BASE)
#define | TMR13 ((tmr_type *) TMR13_BASE)
#define | TMR14 ((tmr_type *) TMR14_BASE)
#define | TMR20 ((tmr_type *) TMR20_BASE)

Enumerations

enum | tmr_clock_division_type { TMR_CLOCK_DIV1 = 0x00 , TMR_CLOCK_DIV2 = 0x01 , TMR_CLOCK_DIV4 = 0x02 }
tmr clock division type More...
enum tmr_count_mode_type {
TMR_COUNT_UP = 0x00 , TMR_COUNT_DOWN = 0x01 , TMR_COUNT_TWO_WAY_1 = 0x02 , TMR_COUNT_TWO_WAY_2 = 0x04 ,
TMR_COUNT_TWO_WAY_3 = 0x06
}
tmr counter mode type More...
enum tmr_primary_select_type {
TMR_PRIMARY_SEL_RESET = 0x00 , TMR_PRIMARY_SEL_ENABLE = 0x01 , TMR_PRIMARY_SEL_OVERFLOW = 0x02 , TMR_PRIMARY_SEL_COMPARE = 0x03 ,
TMR_PRIMARY_SEL_C1ORAW = 0x04 , TMR_PRIMARY_SEL_C2ORAW = 0x05 , TMR_PRIMARY_SEL_C3ORAW = 0x06 , TMR_PRIMARY_SEL_C4ORAW = 0x07
}
tmr primary mode select type More...
enum sub_tmr_input_sel_type {
TMR_SUB_INPUT_SEL_IS0 = 0x00 , TMR_SUB_INPUT_SEL_IS1 = 0x01 , TMR_SUB_INPUT_SEL_IS2 = 0x02 , TMR_SUB_INPUT_SEL_IS3 = 0x03 ,
TMR_SUB_INPUT_SEL_C1INC = 0x04 , TMR_SUB_INPUT_SEL_C1DF1 = 0x05 , TMR_SUB_INPUT_SEL_C2DF2 = 0x06 , TMR_SUB_INPUT_SEL_EXTIN = 0x07
}
tmr subordinate mode input select type More...
enum tmr_sub_mode_select_type {
TMR_SUB_MODE_DIABLE = 0x00 , TMR_SUB_ENCODER_MODE_A = 0x01 , TMR_SUB_ENCODER_MODE_B = 0x02 , TMR_SUB_ENCODER_MODE_C = 0x03 ,
TMR_SUB_RESET_MODE = 0x04 , TMR_SUB_HANG_MODE = 0x05 , TMR_SUB_TRIGGER_MODE = 0x06 , TMR_SUB_EXTERNAL_CLOCK_MODE_A = 0x07
}
tmr subordinate mode select type More...
enum | tmr_encoder_mode_type { TMR_ENCODER_MODE_A = TMR_SUB_ENCODER_MODE_A , TMR_ENCODER_MODE_B = TMR_SUB_ENCODER_MODE_B , TMR_ENCODER_MODE_C = TMR_SUB_ENCODER_MODE_C }
tmr encoder mode type More...
enum tmr_output_control_mode_type {
TMR_OUTPUT_CONTROL_OFF = 0x00 , TMR_OUTPUT_CONTROL_HIGH = 0x01 , TMR_OUTPUT_CONTROL_LOW = 0x02 , TMR_OUTPUT_CONTROL_SWITCH = 0x03 ,
TMR_OUTPUT_CONTROL_FORCE_LOW = 0x04 , TMR_OUTPUT_CONTROL_FORCE_HIGH = 0x05 , TMR_OUTPUT_CONTROL_PWM_MODE_A = 0x06 , TMR_OUTPUT_CONTROL_PWM_MODE_B = 0x07
}
tmr output control mode type More...
enum | tmr_force_output_type { TMR_FORCE_OUTPUT_HIGH = TMR_OUTPUT_CONTROL_FORCE_HIGH , TMR_FORCE_OUTPUT_LOW = TMR_OUTPUT_CONTROL_FORCE_LOW }
tmr force output type More...
enum | tmr_output_polarity_type { TMR_OUTPUT_ACTIVE_HIGH = 0x00 , TMR_OUTPUT_ACTIVE_LOW = 0x01 }
tmr output channel polarity type More...
enum | tmr_input_polarity_type { TMR_INPUT_RISING_EDGE = 0x00 , TMR_INPUT_FALLING_EDGE = 0x01 , TMR_INPUT_BOTH_EDGE = 0x03 }
tmr input channel polarity type More...
enum tmr_channel_select_type {
TMR_SELECT_CHANNEL_1 = 0x00 , TMR_SELECT_CHANNEL_1C = 0x01 , TMR_SELECT_CHANNEL_2 = 0x02 , TMR_SELECT_CHANNEL_2C = 0x03 ,
TMR_SELECT_CHANNEL_3 = 0x04 , TMR_SELECT_CHANNEL_3C = 0x05 , TMR_SELECT_CHANNEL_4 = 0x06 , TMR_SELECT_CHANNEL_5 = 0x07
}
tmr channel select type More...
enum | tmr_channel1_input_connected_type { TMR_CHANEL1_CONNECTED_C1IRAW = 0x00 , TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR = 0x01 }
tmr channel1 input connected type More...
enum | tmr_input_direction_mapped_type { TMR_CC_CHANNEL_MAPPED_DIRECT = 0x01 , TMR_CC_CHANNEL_MAPPED_INDIRECT = 0x02 , TMR_CC_CHANNEL_MAPPED_STI = 0x03 }
tmr input channel mapped type channel direction More...
enum | tmr_channel_input_divider_type { TMR_CHANNEL_INPUT_DIV_1 = 0x00 , TMR_CHANNEL_INPUT_DIV_2 = 0x01 , TMR_CHANNEL_INPUT_DIV_4 = 0x02 , TMR_CHANNEL_INPUT_DIV_8 = 0x03 }
tmr input divider type More...
enum | tmr_dma_request_source_type { TMR_DMA_REQUEST_BY_CHANNEL = 0x00 , TMR_DMA_REQUEST_BY_OVERFLOW = 0x01 }
tmr dma request source select type More...
enum tmr_dma_request_type {
TMR_OVERFLOW_DMA_REQUEST = 0x00000100 , TMR_C1_DMA_REQUEST = 0x00000200 , TMR_C2_DMA_REQUEST = 0x00000400 , TMR_C3_DMA_REQUEST = 0x00000800 ,
TMR_C4_DMA_REQUEST = 0x00001000 , TMR_HALL_DMA_REQUEST = 0x00002000 , TMR_TRIGGER_DMA_REQUEST = 0x00004000
}
tmr dma request type More...
enum tmr_event_trigger_type {
TMR_OVERFLOW_SWTRIG = 0x00000001 , TMR_C1_SWTRIG = 0x00000002 , TMR_C2_SWTRIG = 0x00000004 , TMR_C3_SWTRIG = 0x00000008 ,
TMR_C4_SWTRIG = 0x00000010 , TMR_HALL_SWTRIG = 0x00000020 , TMR_TRIGGER_SWTRIG = 0x00000040 , TMR_BRK_SWTRIG = 0x00000080
}
tmr event triggered by software type More...
enum | tmr_polarity_active_type { TMR_POLARITY_ACTIVE_HIGH = 0x00 , TMR_POLARITY_ACTIVE_LOW = 0x01 , TMR_POLARITY_ACTIVE_BOTH = 0x02 }
tmr polarity active type More...
enum | tmr_external_signal_divider_type { TMR_ES_FREQUENCY_DIV_1 = 0x00 , TMR_ES_FREQUENCY_DIV_2 = 0x01 , TMR_ES_FREQUENCY_DIV_4 = 0x02 , TMR_ES_FREQUENCY_DIV_8 = 0x03 }
tmr external signal divider type More...
enum | tmr_external_signal_polarity_type { TMR_ES_POLARITY_NON_INVERTED = 0x00 , TMR_ES_POLARITY_INVERTED = 0x01 }
tmr external signal polarity type More...
enum tmr_dma_transfer_length_type {
TMR_DMA_TRANSFER_1BYTE = 0x00 , TMR_DMA_TRANSFER_2BYTES = 0x01 , TMR_DMA_TRANSFER_3BYTES = 0x02 , TMR_DMA_TRANSFER_4BYTES = 0x03 ,
TMR_DMA_TRANSFER_5BYTES = 0x04 , TMR_DMA_TRANSFER_6BYTES = 0x05 , TMR_DMA_TRANSFER_7BYTES = 0x06 , TMR_DMA_TRANSFER_8BYTES = 0x07 ,
TMR_DMA_TRANSFER_9BYTES = 0x08 , TMR_DMA_TRANSFER_10BYTES = 0x09 , TMR_DMA_TRANSFER_11BYTES = 0x0A , TMR_DMA_TRANSFER_12BYTES = 0x0B ,
TMR_DMA_TRANSFER_13BYTES = 0x0C , TMR_DMA_TRANSFER_14BYTES = 0x0D , TMR_DMA_TRANSFER_15BYTES = 0x0E , TMR_DMA_TRANSFER_16BYTES = 0x0F ,
TMR_DMA_TRANSFER_17BYTES = 0x10 , TMR_DMA_TRANSFER_18BYTES = 0x11
}
tmr dma transfer length type More...
enum tmr_dma_address_type {
TMR_CTRL1_ADDRESS = 0x0000 , TMR_CTRL2_ADDRESS = 0x0001 , TMR_STCTRL_ADDRESS = 0x0002 , TMR_IDEN_ADDRESS = 0x0003 ,
TMR_ISTS_ADDRESS = 0x0004 , TMR_SWEVT_ADDRESS = 0x0005 , TMR_CM1_ADDRESS = 0x0006 , TMR_CM2_ADDRESS = 0x0007 ,
TMR_CCTRL_ADDRESS = 0x0008 , TMR_CVAL_ADDRESS = 0x0009 , TMR_DIV_ADDRESS = 0x000A , TMR_PR_ADDRESS = 0x000B ,
TMR_RPR_ADDRESS = 0x000C , TMR_C1DT_ADDRESS = 0x000D , TMR_C2DT_ADDRESS = 0x000E , TMR_C3DT_ADDRESS = 0x000F ,
TMR_C4DT_ADDRESS = 0x0010 , TMR_BRK_ADDRESS = 0x0011 , TMR_DMACTRL_ADDRESS = 0x0012
}
tmr dma base address type More...
enum | tmr_brk_polarity_type { TMR_BRK_INPUT_ACTIVE_LOW = 0x00 , TMR_BRK_INPUT_ACTIVE_HIGH = 0x01 }
tmr brk polarity type More...
enum | tmr_wp_level_type { TMR_WP_OFF = 0x00 , TMR_WP_LEVEL_3 = 0x01 , TMR_WP_LEVEL_2 = 0x02 , TMR_WP_LEVEL_1 = 0x03 }
tmr write protect level type More...
enum | tmr_input_remap_type { TMR2_TMR8TRGOUT_TMR5_GPIO = 0x00 , TMR2_PTP_TMR5_LICK = 0x01 , TMR2_OTG1FS_TMR5_LEXT = 0x02 , TMR2_OTG2FS_TMR5_ERTC = 0x03 }
tmr input remap type More...

Functions

void | tmr_reset (tmr_type *tmr_x)
tmr reset by crm reset register More...
void | tmr_counter_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter More...
void | tmr_output_default_para_init (tmr_output_config_type *tmr_output_struct)
init tmr output default para More...
void | tmr_input_default_para_init (tmr_input_config_type *tmr_input_struct)
init tmr input default para More...
void | tmr_brkdt_default_para_init (tmr_brkdt_config_type *tmr_brkdt_struct)
init tmr brkdt default para More...
void | tmr_base_init (tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base More...
void | tmr_clock_source_div_set (tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division More...
void | tmr_cnt_dir_set (tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction More...
void | tmr_repetition_counter_set (tmr_type *tmr_x, uint8_t tmr_rpr_value)
set the repetition counter register(rpr) value More...
void | tmr_counter_value_set (tmr_type *tmr_x, uint32_t tmr_cnt_value)
set tmr counter value More...
uint32_t | tmr_counter_value_get (tmr_type *tmr_x)
get tmr counter value More...
void | tmr_div_value_set (tmr_type *tmr_x, uint32_t tmr_div_value)
set tmr div value More...
uint32_t | tmr_div_value_get (tmr_type *tmr_x)
get tmr div value More...
void | tmr_output_channel_config (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel More...
void | tmr_output_channel_mode_select (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_control_mode_type oc_mode)
select tmr output channel mode More...
void | tmr_period_value_set (tmr_type *tmr_x, uint32_t tmr_pr_value)
set tmr period value More...
uint32_t | tmr_period_value_get (tmr_type *tmr_x)
get tmr period value More...
void | tmr_channel_value_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value More...
uint32_t | tmr_channel_value_get (tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value More...
void | tmr_period_buffer_enable (tmr_type *tmr_x, confirm_state new_state)
set tmr period buffer More...
void | tmr_output_channel_buffer_enable (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel buffer More...
void | tmr_output_channel_immediately_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel immediately More...
void | tmr_output_channel_switch_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel switch More...
void | tmr_one_cycle_mode_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr one cycle mode More...
void | tmr_32_bit_function_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode) More...
void | tmr_overflow_request_source_set (tmr_type *tmr_x, confirm_state new_state)
select tmr the overflow event sources More...
void | tmr_overflow_event_disable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr overflow event generation More...
void | tmr_input_channel_init (tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel More...
void | tmr_channel_enable (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable More...
void | tmr_input_channel_filter_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint16_t filter_value)
set tmr input channel filter More...
void | tmr_pwm_input_config (tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
config tmr pwm input More...
void | tmr_channel1_input_select (tmr_type *tmr_x, tmr_channel1_input_connected_type ch1_connect)
select tmr channel1 input More...
void | tmr_input_channel_divider_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_channel_input_divider_type divider_factor)
set tmr input channel divider More...
void | tmr_primary_mode_select (tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode More...
void | tmr_sub_mode_select (tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode More...
void | tmr_channel_dma_select (tmr_type *tmr_x, tmr_dma_request_source_type cc_dma_select)
select tmr channel dma More...
void | tmr_hall_select (tmr_type *tmr_x, confirm_state new_state)
select tmr hall More...
void | tmr_channel_buffer_enable (tmr_type *tmr_x, confirm_state new_state)
select tmr channel buffer More...
void | tmr_trgout2_enable (tmr_type *tmr_x, confirm_state new_state)
select tmr trgout2 More...
void | tmr_trigger_input_select (tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger More...
void | tmr_sub_sync_mode_set (tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode More...
void | tmr_dma_request_enable (tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request More...
void | tmr_interrupt_enable (tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt More...
flag_status | tmr_flag_get (tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag More...
void | tmr_flag_clear (tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag More...
void | tmr_event_sw_trigger (tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event More...
void | tmr_output_enable (tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable More...
void | tmr_internal_clock_set (tmr_type *tmr_x)
set tmr select internal clock More...
void | tmr_output_channel_polarity_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_polarity_active_type oc_polarity)
set tmr output channel polarity More...
void | tmr_external_clock_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock More...
void | tmr_external_clock_mode1_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode1 More...
void | tmr_external_clock_mode2_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode2 More...
void | tmr_encoder_mode_config (tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type ic1_polarity, tmr_input_polarity_type ic2_polarity)
config tmr encoder mode More...
void | tmr_force_output_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_force_output_type force_output)
set tmr force output More...
void | tmr_dma_control_config (tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, tmr_dma_address_type dma_base_address)
config tmr dma control More...
void | tmr_brkdt_config (tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
config tmr break mode and dead-time More...
void | tmr_iremap_config (tmr_type *tmr_x, tmr_input_remap_type input_remap)
set tmr2/tmr5 input channel remap More...

Detailed Description

at32f435_437 tmr header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_tmr.h.


AT32F435/437 Firmwary Library: at32f435_437_usart.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f435_437_usart.h File Reference

at32f435_437 usart header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct usart_type
type define usart register all More...

Macros

#define | USART_PERR_FLAG ((uint32_t)0x00000001)
#define | USART_FERR_FLAG ((uint32_t)0x00000002)
#define | USART_NERR_FLAG ((uint32_t)0x00000004)
#define | USART_ROERR_FLAG ((uint32_t)0x00000008)
#define | USART_IDLEF_FLAG ((uint32_t)0x00000010)
#define | USART_RDBF_FLAG ((uint32_t)0x00000020)
#define | USART_TDC_FLAG ((uint32_t)0x00000040)
#define | USART_TDBE_FLAG ((uint32_t)0x00000080)
#define | USART_BFF_FLAG ((uint32_t)0x00000100)
#define | USART_CTSCF_FLAG ((uint32_t)0x00000200)
#define | USART_IDLE_INT MAKE_VALUE(0x0C,0x04)
#define | USART_RDBF_INT MAKE_VALUE(0x0C,0x05)
#define | USART_TDC_INT MAKE_VALUE(0x0C,0x06)
#define | USART_TDBE_INT MAKE_VALUE(0x0C,0x07)
#define | USART_PERR_INT MAKE_VALUE(0x0C,0x08)
#define | USART_BF_INT MAKE_VALUE(0x10,0x06)
#define | USART_ERR_INT MAKE_VALUE(0x14,0x00)
#define | USART_CTSCF_INT MAKE_VALUE(0x14,0x0A)
#define | USART1 ((usart_type *) USART1_BASE)
#define | USART2 ((usart_type *) USART2_BASE)
#define | USART3 ((usart_type *) USART3_BASE)
#define | UART4 ((usart_type *) UART4_BASE)
#define | UART5 ((usart_type *) UART5_BASE)
#define | USART6 ((usart_type *) USART6_BASE)
#define | UART7 ((usart_type *) UART7_BASE)
#define | UART8 ((usart_type *) UART8_BASE)

Enumerations

enum | usart_parity_selection_type { USART_PARITY_NONE = 0x00 , USART_PARITY_EVEN = 0x01 , USART_PARITY_ODD = 0x02 }
usart parity selection type More...
enum | usart_wakeup_mode_type { USART_WAKEUP_BY_IDLE_FRAME = 0x00 , USART_WAKEUP_BY_MATCHING_ID = 0x01 }
usart wakeup mode type More...
enum | usart_data_bit_num_type { USART_DATA_7BITS = 0x00 , USART_DATA_8BITS = 0x01 , USART_DATA_9BITS = 0x02 }
usart data bit num type More...
enum | usart_break_bit_num_type { USART_BREAK_10BITS = 0x00 , USART_BREAK_11BITS = 0x01 }
usart break frame bit num type More...
enum | usart_clock_phase_type { USART_CLOCK_PHASE_1EDGE = 0x00 , USART_CLOCK_PHASE_2EDGE = 0x01 }
usart phase of the clock type More...
enum | usart_clock_polarity_type { USART_CLOCK_POLARITY_LOW = 0x00 , USART_CLOCK_POLARITY_HIGH = 0x01 }
usart polarity of the clock type More...
enum | usart_lbcp_type { USART_CLOCK_LAST_BIT_NONE = 0x00 , USART_CLOCK_LAST_BIT_OUTPUT = 0x01 }
usart last bit clock pulse type More...
enum | usart_stop_bit_num_type { USART_STOP_1_BIT = 0x00 , USART_STOP_0_5_BIT = 0x01 , USART_STOP_2_BIT = 0x02 , USART_STOP_1_5_BIT = 0x03 }
usart stop bit num type More...
enum | usart_hardware_flow_control_type { USART_HARDWARE_FLOW_NONE = 0x00 , USART_HARDWARE_FLOW_RTS = 0x01 , USART_HARDWARE_FLOW_CTS = 0x02 , USART_HARDWARE_FLOW_RTS_CTS = 0x03 }
usart hardware flow control type More...
enum | usart_identification_bit_num_type { USART_ID_FIXED_4_BIT = 0x00 , USART_ID_RELATED_DATA_BIT = 0x01 }
usart identification bit num type More...
enum | usart_de_polarity_type { USART_DE_POLARITY_HIGH = 0x00 , USART_DE_POLARITY_LOW = 0x01 }
usart de polarity type More...

Functions

void | usart_reset (usart_type *usart_x)
deinitialize the usart peripheral registers to their default reset values. More...
void | usart_init (usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters. More...
void | usart_parity_selection_config (usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config. More...
void | usart_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral. More...
void | usart_transmitter_enable (usart_type *usart_x, confirm_state new_state)
usart transmitter enable. More...
void | usart_receiver_enable (usart_type *usart_x, confirm_state new_state)
usart receiver enable. More...
void | usart_clock_config (usart_type *usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
usart clock config. More...
void | usart_clock_enable (usart_type *usart_x, confirm_state new_state)
usart enable the ck pin. More...
void | usart_interrupt_enable (usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts. More...
void | usart_dma_transmitter_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface. More...
void | usart_dma_receiver_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma receiver interface. More...
void | usart_wakeup_id_set (usart_type *usart_x, uint8_t usart_id)
set the wakeup id of the usart. More...
void | usart_wakeup_mode_set (usart_type *usart_x, usart_wakeup_mode_type wakeup_mode)
select the usart wakeup method in multi-processor communication. More...
void | usart_receiver_mute_enable (usart_type *usart_x, confirm_state new_state)
config the usart in mute mode in multi-processor communication. More...
void | usart_break_bit_num_set (usart_type *usart_x, usart_break_bit_num_type break_bit)
set the usart break frame bit num. More...
void | usart_lin_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart lin mode. More...
void | usart_data_transmit (usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral. More...
uint16_t | usart_data_receive (usart_type *usart_x)
return the most recent received data by the usart peripheral. More...
void | usart_break_send (usart_type *usart_x)
transmit break characters. More...
void | usart_smartcard_guard_time_set (usart_type *usart_x, uint8_t guard_time_val)
config the specified usart smartcard guard time. More...
void | usart_irda_smartcard_division_set (usart_type *usart_x, uint8_t div_val)
config the irda/smartcard division. More...
void | usart_smartcard_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart smart card mode. More...
void | usart_smartcard_nack_set (usart_type *usart_x, confirm_state new_state)
enable or disable nack transmission in smartcard mode. More...
void | usart_single_line_halfduplex_select (usart_type *usart_x, confirm_state new_state)
enable or disable the usart single line bidirectional half-duplex communication. More...
void | usart_irda_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's irda interface. More...
void | usart_irda_low_power_enable (usart_type *usart_x, confirm_state new_state)
configure the usart's irda low power. More...
void | usart_hardware_flow_control_set (usart_type *usart_x, usart_hardware_flow_control_type flow_state)
configure the usart's hardware flow control. More...
flag_status | usart_flag_get (usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not. More...
void | usart_flag_clear (usart_type *usart_x, uint32_t flag)
clear the usart's pending flags. More...
void | usart_rs485_delay_time_config (usart_type *usart_x, uint8_t start_delay_time, uint8_t complete_delay_time)
configure the usart's rs485 transmit delay time. More...
void | usart_transmit_receive_pin_swap (usart_type *usart_x, confirm_state new_state)
swap the usart's transmit receive pin. More...
void | usart_id_bit_num_set (usart_type *usart_x, usart_identification_bit_num_type id_bit_num)
set the usart's identification bit num. More...
void | usart_de_polarity_set (usart_type *usart_x, usart_de_polarity_type de_polarity)
set the usart's de polarity. More...
void | usart_rs485_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's rs485 mode. More...

Detailed Description

at32f435_437 usart header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_usart.h.


AT32F435/437 Firmwary Library: at32f435_437_usb.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Typedefs | Enumerations | Functions
at32f435_437_usb.h File Reference

at32f435_437 usb header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct | usb_ept_info
usb endpoint infomation structure definition More...
struct | usb_hch_type
usb host channel infomation structure definition More...
struct | otg_global_type
struct | otg_host_type
struct | otg_hchannel_type
struct | otg_device_type
struct | otg_eptin_type
struct | otg_eptout_type
struct | otg_pcgcctl_type

Macros

#define | USB_OTG_MODEMIS_INT ((uint32_t)0x00000002)
#define | USB_OTG_OTGINT_INT ((uint32_t)0x00000004)
#define | USB_OTG_SOF_INT ((uint32_t)0x00000008)
#define | USB_OTG_RXFLVL_INT ((uint32_t)0x00000010)
#define | USB_OTG_NPTXFEMP_INT ((uint32_t)0x00000020)
#define | USB_OTG_GINNAKEFF_INT ((uint32_t)0x00000040)
#define | USB_OTG_GOUTNAKEFF_INT ((uint32_t)0x00000080)
#define | USB_OTG_ERLYSUSP_INT ((uint32_t)0x00000400)
#define | USB_OTG_USBSUSP_INT ((uint32_t)0x00000800)
#define | USB_OTG_USBRST_INT ((uint32_t)0x00001000)
#define | USB_OTG_ENUMDONE_INT ((uint32_t)0x00002000)
#define | USB_OTG_ISOOUTDROP_INT ((uint32_t)0x00004000)
#define | USB_OTG_EOPF_INT ((uint32_t)0x00008000)
#define | USB_OTG_IEPT_INT ((uint32_t)0x00040000)
#define | USB_OTG_OEPT_INT ((uint32_t)0x00080000)
#define | USB_OTG_INCOMISOIN_INT ((uint32_t)0x00100000)
#define | USB_OTG_INCOMPIP_INCOMPISOOUT_INT ((uint32_t)0x00200000)
#define | USB_OTG_PRT_INT ((uint32_t)0x01000000)
#define | USB_OTG_HCH_INT ((uint32_t)0x02000000)
#define | USB_OTG_PTXFEMP_INT ((uint32_t)0x04000000)
#define | USB_OTG_CONIDSCHG_INT ((uint32_t)0x10000000)
#define | USB_OTG_DISCON_INT ((uint32_t)0x20000000)
#define | USB_OTG_WKUP_INT ((uint32_t)0x80000000)
#define | USB_OTG_CURMODE ((uint32_t)0x00000001)
#define | USB_OTG_MODEMIS_FLAG ((uint32_t)0x00000002)
#define | USB_OTG_OTGINT_FLAG ((uint32_t)0x00000004)
#define | USB_OTG_SOF_FLAG ((uint32_t)0x00000008)
#define | USB_OTG_RXFLVL_FLAG ((uint32_t)0x00000010)
#define | USB_OTG_NPTXFEMP_FLAG ((uint32_t)0x00000020)
#define | USB_OTG_GINNAKEFF_FLAG ((uint32_t)0x00000040)
#define | USB_OTG_GOUTNAKEFF_FLAG ((uint32_t)0x00000080)
#define | USB_OTG_ERLYSUSP_FLAG ((uint32_t)0x00000400)
#define | USB_OTG_USBSUSP_FLAG ((uint32_t)0x00000800)
#define | USB_OTG_USBRST_FLAG ((uint32_t)0x00001000)
#define | USB_OTG_ENUMDONE_FLAG ((uint32_t)0x00002000)
#define | USB_OTG_ISOOUTDROP_FLAG ((uint32_t)0x00004000)
#define | USB_OTG_EOPF_FLAG ((uint32_t)0x00008000)
#define | USB_OTG_IEPT_FLAG ((uint32_t)0x00040000)
#define | USB_OTG_OEPT_FLAG ((uint32_t)0x00080000)
#define | USB_OTG_INCOMISOIN_FLAG ((uint32_t)0x00100000)
#define | USB_OTG_INCOMPIP_INCOMPISOOUT_FLAG ((uint32_t)0x00200000)
#define | USB_OTG_PRT_FLAG ((uint32_t)0x01000000)
#define | USB_OTG_HCH_FLAG ((uint32_t)0x02000000)
#define | USB_OTG_PTXFEMP_FLAG ((uint32_t)0x04000000)
#define | USB_OTG_CONIDSCHG_FLAG ((uint32_t)0x10000000)
#define | USB_OTG_DISCON_FLAG ((uint32_t)0x20000000)
#define | USB_OTG_WKUP_FLAG ((uint32_t)0x80000000)
#define | USB_TRDTIM_8 0x9
usb turnaround time More...
#define | USB_TRDTIM_16 0x5
#define | USB_OTG_GRXSTSP_EPTNUM ((uint32_t)0x0000000F)
usb receive status More...
#define | USB_OTG_GRXSTSP_CHNUM ((uint32_t)0x0000000F)
#define | USB_OTG_GRXSTSP_BCNT ((uint32_t)0x00007FF0)
#define | USB_OTG_GRXSTSP_DPID ((uint32_t)0x00018000)
#define | USB_OTG_GRXSTSP_PKTSTS ((uint32_t)0x001E0000)
#define | PKTSTS_IN_DATA_PACKET_RECV 0x2
usb host packet status More...
#define | PKTSTS_IN_TRANSFER_COMPLETE 0x3
#define | PKTSTS_DATA_BIT_ERROR 0x5
#define | PKTSTS_CHANNEL_STOP 0x7
#define | USB_OUT_STS_NAK 0x1
usb device packet status More...
#define | USB_OUT_STS_DATA 0x2
#define | USB_OUT_STS_COMP 0x3
#define | USB_SETUP_STS_COMP 0x4
#define | USB_SETUP_STS_DATA 0x6
#define | USB_HCFG_CLK_60M 0
usb host phy clock More...
#define | USB_HCFG_CLK_48M 1
#define | USB_HCFG_CLK_6M 2
#define | USB_OTG_HPRT_PRTCONSTS ((uint32_t)0x00000001)
usb host port status More...
#define | USB_OTG_HPRT_PRTCONDET ((uint32_t)0x00000002)
#define | USB_OTG_HPRT_PRTENA ((uint32_t)0x00000004)
#define | USB_OTG_HPRT_PRTENCHNG ((uint32_t)0x00000008)
#define | USB_OTG_HPRT_PRTOVRCACT ((uint32_t)0x00000010)
#define | USB_OTG_HPRT_PRTOVRCCHNG ((uint32_t)0x00000020)
#define | USB_OTG_HPRT_PRTRES ((uint32_t)0x00000040)
#define | USB_OTG_HPRT_PRTSUSP ((uint32_t)0x00000080)
#define | USB_OTG_HPRT_PRTRST ((uint32_t)0x00000100)
#define | USB_OTG_HPRT_PRTLNSTS ((uint32_t)0x00000C00)
#define | USB_OTG_HPRT_PRTPWR ((uint32_t)0x00001000)
#define | USB_OTG_HPRT_PRTSPD ((uint32_t)0x00060000)
#define | USB_PRTSPD_HIGH_SPEED 0
usb port speed More...
#define | USB_PRTSPD_FULL_SPEED 1
#define | USB_PRTSPD_LOW_SPEED 2
#define | USB_OTG_HCCHAR_MPS ((uint32_t)0x000007FF)
usb host register hcchar bit define More...
#define | USB_OTG_HCCHAR_EPTNUM ((uint32_t)0x00007800)
#define | USB_OTG_HCCHAR_EPTDIR ((uint32_t)0x00008000)
#define | USB_OTG_HCCHAR_LSPDDEV ((uint32_t)0x00020000)
#define | USB_OTG_HCCHAR_EPTYPE ((uint32_t)0x000C0000)
#define | USB_OTG_HCCHAR_MC ((uint32_t)0x00300000)
#define | USB_OTG_HCCHAR_DEVADDR ((uint32_t)0x1FC00000)
#define | USB_OTG_HCCHAR_ODDFRM ((uint32_t)0x20000000)
#define | USB_OTG_HCCHAR_CHDIS ((uint32_t)0x40000000)
#define | USB_OTG_HCCHAR_CHENA ((uint32_t)0x80000000)
#define | USB_OTG_HCTSIZ_XFERSIZE ((uint32_t)0x0007FFFF)
usb host register hctsiz bit define More...
#define | USB_OTG_HCTSIZ_PKTCNT ((uint32_t)0x1FF80000)
#define | USB_OTG_HCTSIZ_PID ((uint32_t)0x60000000)
#define | USB_OTG_HC_XFERCM_INT ((uint32_t)0x00000001)
usb host channel interrupt mask More...
#define | USB_OTG_HC_CHHLTDM_INT ((uint32_t)0x00000002)
#define | USB_OTG_HC_STALLM_INT ((uint32_t)0x00000008)
#define | USB_OTG_HC_NAKM_INT ((uint32_t)0x00000010)
#define | USB_OTG_HC_ACKM_INT ((uint32_t)0x00000020)
#define | USB_OTG_HC_NYETM_INT ((uint32_t)0x00000040)
#define | USB_OTG_HC_XACTERRM_INT ((uint32_t)0x00000080)
#define | USB_OTG_HC_BBLERRM_INT ((uint32_t)0x00000100)
#define | USB_OTG_HC_FRMOVRRUN_INT ((uint32_t)0x00000200)
#define | USB_OTG_HC_DTGLERRM_INT ((uint32_t)0x00000400)
#define | USB_OTG_HC_XFERC_FLAG ((uint32_t)0x00000001)
usb host channel interrupt flag More...
#define | USB_OTG_HC_CHHLTD_FLAG ((uint32_t)0x00000002)
#define | USB_OTG_HC_STALL_FLAG ((uint32_t)0x00000008)
#define | USB_OTG_HC_NAK_FLAG ((uint32_t)0x00000010)
#define | USB_OTG_HC_ACK_FLAG ((uint32_t)0x00000020)
#define | USB_OTG_HC_NYET_FLAG ((uint32_t)0x00000040)
#define | USB_OTG_HC_XACTERR_FLAG ((uint32_t)0x00000080)
#define | USB_OTG_HC_BBLERR_FLAG ((uint32_t)0x00000100)
#define | USB_OTG_HC_FRMOVRRUN_FLAG ((uint32_t)0x00000200)
#define | USB_OTG_HC_DTGLERR_FLAG ((uint32_t)0x00000400)
#define | USB_DCFG_FULL_SPEED 3
usb device full speed More...
#define | USB_OTG_DCTL_RWKUPSIG ((uint32_t)0x00000001)
usb device ctrl define More...
#define | USB_OTG_DCTL_SFTDISCON ((uint32_t)0x00000002)
#define | USB_OTG_DCTL_GNPINNAKSTS ((uint32_t)0x00000004)
#define | USB_OTG_DCTL_GOUTNAKSTS ((uint32_t)0x00000008)
#define | USB_OTG_DCTL_SGNPINNAK ((uint32_t)0x00000080)
#define | USB_OTG_DCTL_CGNPINNAK ((uint32_t)0x00000100)
#define | USB_OTG_DCTL_SGOUTNAK ((uint32_t)0x00000200)
#define | USB_OTG_DCTL_CGOUTNAK ((uint32_t)0x00000400)
#define | USB_OTG_DCTL_PWROPRGDNE ((uint32_t)0x00000800)
#define | USB_OTG_DIEPINT_XFERC_FLAG ((uint32_t)0x00000001)
usb device in endpoint flag More...
#define | USB_OTG_DIEPINT_EPTDISD_FLAG ((uint32_t)0x00000002)
#define | USB_OTG_DIEPINT_TIMEOUT_FLAG ((uint32_t)0x00000008)
#define | USB_OTG_DIEPINT_INTKNTXFEMP_FLAG ((uint32_t)0x00000010)
#define | USB_OTG_DIEPINT_INEPTNAK_FLAG ((uint32_t)0x00000040)
#define | USB_OTG_DIEPINT_TXFEMP_FLAG ((uint32_t)0x00000080)
#define | USB_OTG_DOEPINT_XFERC_FLAG ((uint32_t)0x00000001)
usb device out endpoint flag More...
#define | USB_OTG_DOEPINT_EPTDISD_FLAG ((uint32_t)0x00000002)
#define | USB_OTG_DOEPINT_SETUP_FLAG ((uint32_t)0x00000008)
#define | USB_OTG_DOEPINT_OUTTEPD_FLAG ((uint32_t)0x00000010)
#define | USB_OTG_DOEPINT_B2BSTUP_FLAG ((uint32_t)0x00000040)
#define | USB_OTG_DTXFSTS_INEPTFSAV ((uint32_t)0x0000FFFF)
usb device in endpoint fifo space mask More...
#define | USB_EPT0_MPS_64 0
endpoint0 maximum packet size More...
#define | USB_EPT0_MPS_32 1
#define | USB_EPT0_MPS_16 2
#define | USB_EPT0_MPS_8 3
#define | OTG_FIFO_SIZE 320
otg fifo size (word) More...
#define | USB_MAX_DATA_LENGTH 0x200
otg host max buffer length (byte) More...
#define | OTGFS_USB_GLOBAL
#define | OTGFS_USB_DEVICE
#define | OTGFS_USB_HOST
#define | OTG_HOST_ADDR_OFFSET 0x400
usb host and device offset address More...
#define | OTG_HOST_CHANNEL_ADDR_OFFSET 0x500
#define | OTG_DEVICE_ADDR_OFFSET 0x800
#define | OTG_DEVICE_EPTIN_ADDR_OFFSET 0x900
#define | OTG_DEVICE_EPTOUT_ADDR_OFFSET 0xB00
#define | OTG_PCGCCTL_ADDR_OFFSET 0xE00
#define | OTG_FIFO_ADDR_OFFSET 0x1000
#define | OTG1_GLOBAL ((otg_global_type *)(OTGFS1_BASE))
usb host and device register define More...
#define | OTG2_GLOBAL ((otg_global_type *)(OTGFS2_BASE))
#define | OTG_PCGCCTL(usbx) ((otg_pcgcctl_type *)((uint32_t)usbx + OTG_PCGCCTL_ADDR_OFFSET))
#define | OTG_DEVICE(usbx) ((otg_device_type *)((uint32_t)usbx + OTG_DEVICE_ADDR_OFFSET))
#define | OTG_HOST(usbx) ((otg_host_type *)((uint32_t)usbx + OTG_HOST_ADDR_OFFSET))
#define | USB_CHL(usbx, n) ((otg_hchannel_type *)((uint32_t)usbx + OTG_HOST_CHANNEL_ADDR_OFFSET + n * 0x20))
#define | USB_INEPT(usbx, eptn) ((otg_eptin_type *)((uint32_t)usbx + OTG_DEVICE_EPTIN_ADDR_OFFSET + eptn * 0x20))
#define | USB_OUTEPT(usbx, eptn) ((otg_eptout_type *)((uint32_t)usbx + OTG_DEVICE_EPTOUT_ADDR_OFFSET + eptn * 0x20))
#define | USB_FIFO(usbx, eptn) *(__IO uint32_t *)((uint32_t)usbx + OTG_FIFO_ADDR_OFFSET + eptn * 0x1000)

Typedefs

typedef otg_global_type usb_reg_type

Enumerations

enum | dcfg_perfrint_type { DCFG_PERFRINT_80 = 0x00 , DCFG_PERFRINT_85 = 0x01 , DCFG_PERFRINT_90 = 0x02 , DCFG_PERFRINT_95 = 0x03 }
usb device periodic frame interval More...
enum | otg_mode_type { OTG_DEVICE_MODE , OTG_HOST_MODE , OTG_DRD_MODE }
usb mode define(device, host, drd) More...
enum | endpoint_trans_type { EPT_CONTROL_TYPE = 0x00 , EPT_ISO_TYPE = 0x01 , EPT_BULK_TYPE = 0x02 , EPT_INT_TYPE = 0x03 }
endpoint type define More...
enum usb_endpoint_number_type {
USB_EPT0 = 0x00 , USB_EPT1 = 0x01 , USB_EPT2 = 0x02 , USB_EPT3 = 0x03 ,
USB_EPT4 = 0x04 , USB_EPT5 = 0x05 , USB_EPT6 = 0x06 , USB_EPT7 = 0x07
}
usb endpoint number define type More...
enum | endpoint_dir_type { EPT_DIR_IN = 0x00 , EPT_DIR_OUT = 0x01 }
usb endpoint max num define More...
enum | otg_id_type { USB_OTG1_ID , USB_OTG2_ID }
otgfs1 and otgfs2 select type More...
enum | usb_clk48_s { USB_CLK_HICK , USB_CLK_HEXT }
usb clock select More...

Functions

error_status | usb_global_reset (otg_global_type *usbx)
usb global core soft reset More...
void | usb_global_init (otg_global_type *usbx)
usb global initialization More...
otg_global_type * | usb_global_select_core (uint8_t usb_id)
usb global select usb core (otg1 or otg2). More...
void | usb_flush_tx_fifo (otg_global_type *usbx, uint32_t fifo_num)
flush tx fifo More...
void | usb_flush_rx_fifo (otg_global_type *usbx)
flush rx fifo More...
void | usb_global_interrupt_enable (otg_global_type *usbx, uint16_t interrupt, confirm_state new_state)
usb interrupt mask enable More...
uint32_t | usb_global_get_all_interrupt (otg_global_type *usbx)
get all global core interrupt flag More...
void | usb_global_clear_interrupt (otg_global_type *usbx, uint32_t flag)
clear the global interrupt flag More...
void | usb_interrupt_enable (otg_global_type *usbx)
usb global interrupt enable More...
void | usb_interrupt_disable (otg_global_type *usbx)
usb global interrupt disable More...
void | usb_set_rx_fifo (otg_global_type *usbx, uint16_t size)
usb set rx fifo size More...
void | usb_set_tx_fifo (otg_global_type *usbx, uint8_t txfifo, uint16_t size)
usb set tx fifo size More...
void | usb_global_set_mode (otg_global_type *usbx, uint32_t mode)
set otg mode(device or host mode) More...
void | usb_global_power_on (otg_global_type *usbx)
disable the transceiver power down mode More...
void | usb_write_packet (otg_global_type *usbx, uint8_t *pusr_buf, uint16_t num, uint16_t nbytes)
write data from user memory to usb buffer More...
void | usb_read_packet (otg_global_type *usbx, uint8_t *pusr_buf, uint16_t num, uint16_t nbytes)
read data from usb buffer to user buffer More...
void | usb_stop_phy_clk (otg_global_type *usbx)
usb stop phy clock More...
void | usb_open_phy_clk (otg_global_type *usbx)
usb open phy clock More...
void | usb_ept_open (otg_global_type *usbx, usb_ept_info *ept_info)
open usb endpoint More...
void | usb_ept_close (otg_global_type *usbx, usb_ept_info *ept_info)
close usb endpoint More...
void | usb_ept_stall (otg_global_type *usbx, usb_ept_info *ept_info)
set endpoint tx or rx status to stall More...
void | usb_ept_clear_stall (otg_global_type *usbx, usb_ept_info *ept_info)
clear endpoint tx or rx status to stall More...
uint32_t | usb_get_all_out_interrupt (otg_global_type *usbx)
get all out endpoint interrupt bits More...
uint32_t | usb_get_all_in_interrupt (otg_global_type *usbx)
get all in endpoint interrupt bits More...
uint32_t | usb_ept_out_interrupt (otg_global_type *usbx, uint32_t eptn)
get out endpoint interrupt flag More...
uint32_t | usb_ept_in_interrupt (otg_global_type *usbx, uint32_t eptn)
get in endpoint interrupt flag More...
void | usb_ept_out_clear (otg_global_type *usbx, uint32_t eptn, uint32_t flag)
clear out endpoint interrupt flag More...
void | usb_ept_in_clear (otg_global_type *usbx, uint32_t eptn, uint32_t flag)
clear in endpoint interrupt flag More...
void | usb_set_address (otg_global_type *usbx, uint8_t address)
set the host assignment address More...
void | usb_ept0_start (otg_global_type *usbx)
enable endpoint 0 out More...
void | usb_ept0_setup (otg_global_type *usbx)
endpoint 0 start setup More...
void | usb_connect (otg_global_type *usbx)
connect usb device by enable pull-up More...
void | usb_disconnect (otg_global_type *usbx)
disconnect usb device by disable pull-up More...
void | usb_remote_wkup_set (otg_global_type *usbx)
usb remote wakeup set More...
void | usb_remote_wkup_clear (otg_global_type *usbx)
usb remote wakeup clear More...
uint8_t | usb_suspend_status_get (otg_global_type *usbx)
usb suspend status get More...
void | usb_port_power_on (otg_global_type *usbx, confirm_state state)
usb port power on More...
uint32_t | usbh_get_frame (otg_global_type *usbx)
get current frame number More...
void | usb_hc_enable (otg_global_type *usbx, uint8_t chn, uint8_t ept_num, uint8_t dev_address, uint8_t type, uint16_t maxpacket, uint8_t speed)
enable one host channel More...
uint32_t | usb_hch_read_interrupt (otg_global_type *usbx)
host read channel interrupt More...
void | usb_host_disable (otg_global_type *usbx)
disable host More...
void | usb_hch_halt (otg_global_type *usbx, uint8_t chn)
halt channel More...
void | usbh_fsls_clksel (otg_global_type *usbx, uint8_t clk)
select full or low speed clock More...

Detailed Description

at32f435_437 usb header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_usb.h.


AT32F435/437 Firmwary Library: at32f435_437_wdt.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f435_437_wdt.h File Reference

at32f435_437 wdt header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct wdt_type
type define wdt register all More...

Macros

#define | WDT_DIVF_UPDATE_FLAG ((uint16_t)0x0001)
#define | WDT_RLDF_UPDATE_FLAG ((uint16_t)0x0002)
#define | WDT_WINF_UPDATE_FLAG ((uint16_t)0x0004)
#define | WDT ((wdt_type *) WDT_BASE)

Enumerations

enum wdt_division_type {
WDT_CLK_DIV_4 = 0x00 , WDT_CLK_DIV_8 = 0x01 , WDT_CLK_DIV_16 = 0x02 , WDT_CLK_DIV_32 = 0x03 ,
WDT_CLK_DIV_64 = 0x04 , WDT_CLK_DIV_128 = 0x05 , WDT_CLK_DIV_256 = 0x06
}
wdt division value type More...
enum wdt_cmd_value_type { WDT_CMD_LOCK = 0x0000 , WDT_CMD_UNLOCK = 0x5555 , WDT_CMD_ENABLE = 0xCCCC , WDT_CMD_RELOAD = 0xAAAA }
wdt cmd value type More...

Functions

void | wdt_enable (void)
wdt enable ,the reload value will be sent to the counter More...
void | wdt_counter_reload (void)
reload wdt counter More...
void | wdt_reload_value_set (uint16_t reload_value)
set wdt counter reload value More...
void | wdt_divider_set (wdt_division_type division)
set wdt division divider More...
void | wdt_register_write_enable (confirm_state new_state)
enable or disable wdt cmd register write More...
flag_status | wdt_flag_get (uint16_t wdt_flag)
get wdt flag More...
void | wdt_window_counter_set (uint16_t window_cnt)
wdt window counter value set More...

Detailed Description

at32f435_437 wdt header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_wdt.h.


AT32F435/437 Firmwary Library: at32f435_437_wwdt.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f435_437_wwdt.h File Reference

at32f435_437 wwdt header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct wwdt_type
type define wwdt register all More...

Macros

#define | WWDT_EN_BIT ((uint32_t)0x00000080)
#define | WWDT ((wwdt_type *) WWDT_BASE)

Enumerations

enum wwdt_division_type { WWDT_PCLK1_DIV_4096 = 0x00 , WWDT_PCLK1_DIV_8192 = 0x01 , WWDT_PCLK1_DIV_16384 = 0x02 , WWDT_PCLK1_DIV_32768 = 0x03 }
wwdt division type More...

Functions

void | wwdt_reset (void)
wwdt reset by crm reset register More...
void | wwdt_divider_set (wwdt_division_type division)
wwdt division set More...
void | wwdt_flag_clear (void)
wwdt reload counter interrupt flag clear More...
void | wwdt_enable (uint8_t wwdt_cnt)
wwdt enable and the counter value load More...
void | wwdt_interrupt_enable (void)
wwdt reload counter interrupt enable More...
flag_status | wwdt_flag_get (void)
wwdt reload counter interrupt flag get More...
void | wwdt_counter_set (uint8_t wwdt_cnt)
wwdt counter value set More...
void | wwdt_window_counter_set (uint8_t window_cnt)
wwdt window counter value set More...

Detailed Description

at32f435_437 wwdt header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_wwdt.h.


AT32F435/437 Firmwary Library: at32f435_437_xmc.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f435_437_xmc.h File Reference

at32f435_437 xmc header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct | xmc_norsram_timing_init_type
nor/sram banks timing parameters More...
struct | xmc_norsram_init_type
xmc nor/sram init structure definition More...
struct | xmc_nand_pccard_timinginit_type
nand and pccard timing parameters xmc More...
struct | xmc_nand_init_type
xmc nand init structure definition More...
struct | xmc_pccard_init_type
xmc pccard init structure definition More...
struct | xmc_sdram_init_type
xmc sdram init structure definition More...
struct | xmc_sdram_timing_type
xmc sdram timing structure definition More...
struct | xmc_sdram_cmd_type
xmc sdram command structure definition More...
struct | xmc_bank1_ctrl_tmg_reg_type
struct | xmc_bank1_tmgwr_reg_type
struct | xmc_bank1_type
xmc bank1 registers More...
struct | xmc_bank2_type
xmc bank2 registers More...
struct | xmc_bank3_type
xmc bank3 registers More...
struct | xmc_bank4_type
xmc bank4 registers More...
struct | xmc_sdram_type
xmc sdram type More...

Macros

#define | XMC_BANK1 ((xmc_bank1_type *) XMC_BANK1_REG_BASE)
#define | XMC_BANK2 ((xmc_bank2_type *) XMC_BANK2_REG_BASE)
#define | XMC_BANK3 ((xmc_bank3_type *) XMC_BANK3_REG_BASE)
#define | XMC_BANK4 ((xmc_bank4_type *) XMC_BANK4_REG_BASE)
#define | XMC_SDRAM ((xmc_sdram_type *) XMC_SDRAM_REG_BASE)

Enumerations

enum | xmc_data_addr_mux_type { XMC_DATA_ADDR_MUX_DISABLE = 0x00000000 , XMC_DATA_ADDR_MUX_ENABLE = 0x00000002 }
xmc data address bus multiplexing type More...
enum | xmc_burst_access_mode_type { XMC_BURST_MODE_DISABLE = 0x00000000 , XMC_BURST_MODE_ENABLE = 0x00000100 }
xmc burst access mode type More...
enum | xmc_asyn_wait_type { XMC_ASYN_WAIT_DISABLE = 0x00000000 , XMC_ASYN_WAIT_ENABLE = 0x00008000 }
xmc asynchronous wait type More...
enum | xmc_wrap_mode_type { XMC_WRAPPED_MODE_DISABLE = 0x00000000 , XMC_WRAPPED_MODE_ENABLE = 0x00000400 }
xmc wrapped mode type More...
enum | xmc_write_operation_type { XMC_WRITE_OPERATION_DISABLE = 0x00000000 , XMC_WRITE_OPERATION_ENABLE = 0x00001000 }
xmc write operation type More...
enum | xmc_wait_signal_type { XMC_WAIT_SIGNAL_DISABLE = 0x00000000 , XMC_WAIT_SIGNAL_ENABLE = 0x00002000 }
xmc wait signal type More...
enum | xmc_write_burst_type { XMC_WRITE_BURST_SYN_DISABLE = 0x00000000 , XMC_WRITE_BURST_SYN_ENABLE = 0x00080000 }
xmc write burst type More...
enum | xmc_extended_mode_type { XMC_WRITE_TIMING_DISABLE = 0x00000000 , XMC_WRITE_TIMING_ENABLE = 0x00004000 }
xmc extended mode type More...
enum | xmc_nand_pccard_wait_type { XMC_WAIT_OPERATION_DISABLE = 0x00000000 , XMC_WAIT_OPERATION_ENABLE = 0x00000002 }
xmc pccard wait type More...
enum | xmc_ecc_enable_type { XMC_ECC_OPERATION_DISABLE = 0x00000000 , XMC_ECC_OPERATION_ENABLE = 0x00000040 }
xmc ecc enable type More...
enum | xmc_nor_sram_subbank_type { XMC_BANK1_NOR_SRAM1 = 0x00000000 , XMC_BANK1_NOR_SRAM2 = 0x00000001 , XMC_BANK1_NOR_SRAM3 = 0x00000002 , XMC_BANK1_NOR_SRAM4 = 0x00000003 }
xmc nor/sram subbank type More...
enum | xmc_class_bank_type { XMC_BANK2_NAND = 0x00000000 , XMC_BANK3_NAND = 0x00000001 , XMC_BANK4_PCCARD = 0x00000002 , XMC_BANK5_6_SDRAM = 0x00000003 }
xmc class bank type More...
enum | xmc_memory_type { XMC_DEVICE_SRAM = 0x00000000 , XMC_DEVICE_PSRAM = 0x00000004 , XMC_DEVICE_NOR = 0x00000008 }
xmc memory type More...
enum | xmc_data_width_type { XMC_BUSTYPE_8_BITS = 0x00000000 , XMC_BUSTYPE_16_BITS = 0x00000010 }
xmc data width type More...
enum | xmc_wait_signal_polarity_type { XMC_WAIT_SIGNAL_LEVEL_LOW = 0x00000000 , XMC_WAIT_SIGNAL_LEVEL_HIGH = 0x00000200 }
xmc wait signal polarity type More...
enum | xmc_wait_timing_type { XMC_WAIT_SIGNAL_SYN_BEFORE = 0x00000000 , XMC_WAIT_SIGNAL_SYN_DURING = 0x00000800 }
xmc wait timing type More...
enum | xmc_access_mode_type { XMC_ACCESS_MODE_A = 0x00000000 , XMC_ACCESS_MODE_B = 0x10000000 , XMC_ACCESS_MODE_C = 0x20000000 , XMC_ACCESS_MODE_D = 0x30000000 }
xmc access mode type More...
enum xmc_ecc_pagesize_type {
XMC_ECC_PAGESIZE_256_BYTES = 0x00000000 , XMC_ECC_PAGESIZE_512_BYTES = 0x00020000 , XMC_ECC_PAGESIZE_1024_BYTES = 0x00040000 , XMC_ECC_PAGESIZE_2048_BYTES = 0x00060000 ,
XMC_ECC_PAGESIZE_4096_BYTES = 0x00080000 , XMC_ECC_PAGESIZE_8192_BYTES = 0x000A0000
}
xmc ecc page size type More...
enum | xmc_interrupt_sources_type { XMC_INT_RISING_EDGE = 0x00000008 , XMC_INT_LEVEL = 0x00000010 , XMC_INT_FALLING_EDGE = 0x00000020 , XMC_INT_ERR = 0x00004000 }
xmc interrupt sources type More...
enum xmc_interrupt_flag_type {
XMC_RISINGEDGE_FLAG = 0x00000001 , XMC_LEVEL_FLAG = 0x00000002 , XMC_FALLINGEDGE_FLAG = 0x00000004 , XMC_FEMPT_FLAG = 0x00000040 ,
XMC_ERR_FLAG = 0x00000001 , XMC_BUSY_FLAG = 0x00000020
}
xmc interrupt flag type More...
enum | xmc_sdram_column_type { XMC_COLUMN_8 = 0x00000000 , XMC_COLUMN_9 = 0x00000001 , XMC_COLUMN_10 = 0x00000002 , XMC_COLUMN_11 = 0x00000003 }
xmc sdram number of column address type More...
enum | xmc_sdram_row_type { XMC_ROW_11 = 0x00000000 , XMC_ROW_12 = 0x00000001 , XMC_ROW_13 = 0x00000002 }
xmc sdram number of row address type More...
enum | xmc_sdram_width_type { XMC_MEM_WIDTH_8 = 0x00000000 , XMC_MEM_WIDTH_16 = 0x00000001 }
xmc sdram memory data bus width type More...
enum | xmc_sdram_inbk_type { XMC_INBK_2 = 0x00000000 , XMC_INBK_4 = 0x00000001 }
xmc sdram number of internal banks type More...
enum | xmc_sdram_cas_type { XMC_CAS_1 = 0x00000001 , XMC_CAS_2 = 0x00000002 , XMC_CAS_3 = 0x00000003 }
xmc sdram cas latency type More...
enum | xmc_sdram_clkdiv_type { XMC_NO_CLK = 0x00000000 , XMC_CLKDIV_2 = 0x00000002 , XMC_CLKDIV_3 = 0x00000003 , XMC_CLKDIV_4 = 0x00000001 }
xmc sdram clock div type More...
enum | xmc_sdram_rd_delay_type { XMC_READ_DELAY_0 = 0x00000000 , XMC_READ_DELAY_1 = 0x00000001 , XMC_READ_DELAY_2 = 0x00000002 }
xmc sdram read delay More...
enum | xmc_sdram_bank_type { XMC_SDRAM_BANK1 = 0x00000000 , XMC_SDRAM_BANK2 = 0x00000001 }
xmc sdram bank type More...
enum xmc_sdram_delay_type {
XMC_DELAY_CYCLE_1 = 0x00000000 , XMC_DELAY_CYCLE_2 = 0x00000001 , XMC_DELAY_CYCLE_3 = 0x00000002 , XMC_DELAY_CYCLE_4 = 0x00000003 ,
XMC_DELAY_CYCLE_5 = 0x00000004 , XMC_DELAY_CYCLE_6 = 0x00000005 , XMC_DELAY_CYCLE_7 = 0x00000006 , XMC_DELAY_CYCLE_8 = 0x00000007 ,
XMC_DELAY_CYCLE_9 = 0x00000008 , XMC_DELAY_CYCLE_10 = 0x00000009 , XMC_DELAY_CYCLE_11 = 0x0000000A , XMC_DELAY_CYCLE_12 = 0x0000000B ,
XMC_DELAY_CYCLE_13 = 0x0000000C , XMC_DELAY_CYCLE_14 = 0x0000000D , XMC_DELAY_CYCLE_15 = 0x0000000E , XMC_DELAY_CYCLE_16 = 0x0000000F
}
xmc sdram timing delay cycle type More...
enum xmc_command_type {
XMC_CMD_NORMAL = 0x00000000 , XMC_CMD_CLK = 0x00000001 , XMC_CMD_PRECHARG_ALL = 0x00000002 , XMC_CMD_AUTO_REFRESH = 0x00000003 ,
XMC_CMD_LOAD_MODE = 0x00000004 , XMC_CMD_SELF_REFRESH = 0x00000005 , XMC_CMD_POWER_DOWN = 0x00000006
}
xmc sdram command type More...
enum | xmc_cmd_bank1_2_type { XMC_CMD_BANK1 = 0x00000010 , XMC_CMD_BANK2 = 0x00000008 , XMC_CMD_BANK1_2 = 0x00000018 }
xmc sdram command bank select type More...
enum | xmc_bank_status_type { XMC_STATUS_NORMAL = 0x00000000 , XMC_STATUS_SELF_REFRESH = 0x00000001 , XMC_STATUS_POWER_DOWN = 0x00000002 , XMC_STATUS_MASK = 0x00000003 }
xmc sdram bank status type More...

Functions

void | xmc_nor_sram_reset (xmc_nor_sram_subbank_type xmc_subbank)
xmc nor or sram registers reset More...
void | xmc_nor_sram_init (xmc_norsram_init_type *xmc_norsram_init_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_norsraminitstruct. More...
void | xmc_nor_sram_timing_config (xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_rw_timing_struct and xmc_w_timing_struct. More...
void | xmc_norsram_default_para_init (xmc_norsram_init_type *xmc_nor_sram_init_struct)
fill each xmc_nor_sram_init_struct member with its default value. More...
void | xmc_norsram_timing_default_para_init (xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
fill each xmc_rw_timing_struct and xmc_w_timing_struct member with its default value. More...
void | xmc_nor_sram_enable (xmc_nor_sram_subbank_type xmc_subbank, confirm_state new_state)
enable or disable the specified nor/sram memory bank. More...
void | xmc_ext_timing_config (xmc_nor_sram_subbank_type xmc_sub_bank, uint16_t w2w_timing, uint16_t r2r_timing)
config the bus turnaround phase. More...
void | xmc_nand_reset (xmc_class_bank_type xmc_bank)
xmc nand flash registers reset More...
void | xmc_nand_init (xmc_nand_init_type *xmc_nand_init_struct)
initialize the xmc nand banks according to the specified parameters in the xmc_nandinitstruct. More...
void | xmc_nand_timing_config (xmc_nand_pccard_timinginit_type *xmc_common_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_attribute_spacetiming_struct)
initialize the xmc nand banks according to the specified parameters in the xmc_nandinitstruct. More...
void | xmc_nand_default_para_init (xmc_nand_init_type *xmc_nand_init_struct)
fill each xmc_nand_init_struct member with its default value. More...
void | xmc_nand_timing_default_para_init (xmc_nand_pccard_timinginit_type *xmc_common_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_attribute_spacetiming_struct)
fill each xmc_common_spacetiming_struct and xmc_attribute_spacetiming_struct member with its default value. More...
void | xmc_nand_enable (xmc_class_bank_type xmc_bank, confirm_state new_state)
enable or disable the specified nand memory bank. More...
void | xmc_nand_ecc_enable (xmc_class_bank_type xmc_bank, confirm_state new_state)
enable or disable the xmc nand ecc feature. More...
uint32_t | xmc_ecc_get (xmc_class_bank_type xmc_bank)
return the error correction code register value. More...
void | xmc_interrupt_enable (xmc_class_bank_type xmc_bank, xmc_interrupt_sources_type xmc_int, confirm_state new_state)
enable or disable the specified xmc interrupts. More...
flag_status | xmc_flag_status_get (xmc_class_bank_type xmc_bank, xmc_interrupt_flag_type xmc_flag)
check whether the specified xmc flag is set or not. More...
void | xmc_flag_clear (xmc_class_bank_type xmc_bank, xmc_interrupt_flag_type xmc_flag)
clear the xmc's pending flags. More...
void | xmc_pccard_reset (void)
xmc pc card registers reset More...
void | xmc_pccard_init (xmc_pccard_init_type *xmc_pccard_init_struct)
initialize the xmc pccard bank according to the specified parameters in the xmc_pccard_init_struct. More...
void | xmc_pccard_timing_config (xmc_nand_pccard_timinginit_type *xmc_common_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_attribute_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_iospace_timing_struct)
initialize the xmc pccard bank according to the specified parameters in the xmc_common_spacetiming_struct/xmc_attribute_spacetiming_struct and xmc_iospace_timing_struct. More...
void | xmc_pccard_default_para_init (xmc_pccard_init_type *xmc_pccard_init_struct)
fill each xmc_pccard_init_struct member with its default value. More...
void | xmc_pccard_timing_default_para_init (xmc_nand_pccard_timinginit_type *xmc_common_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_attribute_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_iospace_timing_struct)
fill each xmc_common_spacetiming_struct/xmc_attribute_spacetiming_struct and xmc_iospace_timing_struct member with its default value. More...
void | xmc_pccard_enable (confirm_state new_state)
enable or disable the pccard memory bank. More...
void | xmc_sdram_reset (xmc_sdram_bank_type xmc_bank)
xmc sdram registers reset More...
void | xmc_sdram_init (xmc_sdram_init_type *xmc_sdram_init_struct, xmc_sdram_timing_type *xmc_sdram_timing_struct)
initialize the xmc sdram banks according to the specified parameters in the xmc_sdram_init_struct and xmc_sdram_timing_struct. More...
void | xmc_sdram_default_para_init (xmc_sdram_init_type *xmc_sdram_init_struct, xmc_sdram_timing_type *xmc_sdram_timing_struct)
fill each xmc_sdram_init_struct member with its default value. More...
void | xmc_sdram_cmd (xmc_sdram_cmd_type *xmc_sdram_cmd_struct)
sdram command confg More...
uint32_t | xmc_sdram_status_get (xmc_sdram_bank_type xmc_bank)
get sdram bank status More...
void | xmc_sdram_refresh_counter_set (uint32_t counter)
set sdram refresh counter More...
void | xmc_sdram_auto_refresh_set (uint32_t number)
set sdram auto refresh number More...

Detailed Description

at32f435_437 xmc header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_xmc.h.


AT32F435/437 Firmwary Library: at32f435_437_acc.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_acc.c File Reference

contains all the functions for the acc firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

void | acc_calibration_mode_enable (uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode. More...
void | acc_step_set (uint8_t step_value)
store calibration step data in acc's ctrl1 register. More...
void | acc_sof_select (uint16_t sof_sel)
select sof sourse for acc in acc's ctrl1 register. More...
void | acc_interrupt_enable (uint16_t acc_int, confirm_state new_state)
enable or disable the specified acc interrupts. More...
uint8_t | acc_hicktrim_get (void)
return the current acc hicktrim value. More...
uint8_t | acc_hickcal_get (void)
return the current acc hickcal value. More...
void | acc_write_c1 (uint16_t acc_c1_value)
wtire the value to acc c1 register. More...
void | acc_write_c2 (uint16_t acc_c2_value)
wtire the value to acc c2 register. More...
void | acc_write_c3 (uint16_t acc_c3_value)
wtire the value to acc c3 register. More...
uint16_t | acc_read_c1 (void)
return the current acc c1 value. More...
uint16_t | acc_read_c2 (void)
return the current acc c2 value. More...
uint16_t | acc_read_c3 (void)
return the current acc c3 value. More...
flag_status | acc_flag_get (uint16_t acc_flag)
check whether the specified acc flag is set or not. More...
void | acc_flag_clear (uint16_t acc_flag)
clear the specified acc flag is set or not. More...

Detailed Description

contains all the functions for the acc firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_acc.c.


AT32F435/437 Firmwary Library: at32f435_437_adc.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_adc.c File Reference

contains all the functions for the adc firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

void | adc_reset (void)
deinitialize the adc peripheral registers to their default reset values. More...
void | adc_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral. More...
void | adc_base_default_para_init (adc_base_config_type *adc_base_struct)
adc base default para init. More...
void | adc_base_config (adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters. More...
void | adc_common_default_para_init (adc_common_config_type *adc_common_struct)
adc common default para init. More...
void | adc_common_config (adc_common_config_type *adc_common_struct)
adc common default para init. More...
void | adc_resolution_set (adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral. More...
void | adc_voltage_battery_enable (confirm_state new_state)
enable or disable the adc voltage battery. More...
void | adc_dma_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer. More...
void | adc_dma_request_repeat_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat. More...
void | adc_interrupt_enable (adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts. More...
void | adc_calibration_value_set (adc_type *adc_x, uint8_t adc_calibration_value)
set calibration value of the specified adc peripheral. More...
void | adc_calibration_init (adc_type *adc_x)
initialize calibration register of the specified adc peripheral. More...
flag_status | adc_calibration_init_status_get (adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral. More...
void | adc_calibration_start (adc_type *adc_x)
start calibration process of the specified adc peripheral. More...
flag_status | adc_calibration_status_get (adc_type *adc_x)
get calibration status of the specified adc peripheral. More...
void | adc_voltage_monitor_enable (adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring)
enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified adc peripheral. More...
void | adc_voltage_monitor_threshold_value_set (adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold)
set voltage monitoring's high and low thresholds value of the specified adc peripheral. More...
void | adc_voltage_monitor_single_channel_select (adc_type *adc_x, adc_channel_select_type adc_channel)
select the voltage monitoring's channel of the specified adc peripheral. More...
void | adc_ordinary_channel_set (adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc peripheral. More...
void | adc_preempt_channel_length_set (adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral. More...
void | adc_preempt_channel_set (adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc peripheral. More...
void | adc_ordinary_conversion_trigger_set (adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc peripheral. More...
void | adc_preempt_conversion_trigger_set (adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, adc_preempt_trig_edge_type adc_preempt_trig_edge)
enable or disable the preempt channel's external trigger and set external trigger event of the specified adc peripheral. More...
void | adc_preempt_offset_value_set (adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel, uint16_t adc_offset_value)
set preempt channel's conversion value offset of the specified adc peripheral. More...
void | adc_ordinary_part_count_set (adc_type *adc_x, uint8_t adc_channel_count)
set partitioned mode channel count of the specified adc peripheral. More...
void | adc_ordinary_part_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on ordinary channel of the specified adc peripheral. More...
void | adc_preempt_part_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on preempt channel of the specified adc peripheral. More...
void | adc_preempt_auto_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable automatic preempt group conversion of the specified adc peripheral. More...
void | adc_conversion_stop (adc_type *adc_x)
stop the ongoing conversion of the specified adc peripheral. More...
flag_status | adc_conversion_stop_status_get (adc_type *adc_x)
get stop conversion's status of the specified adc peripheral. More...
void | adc_occe_each_conversion_enable (adc_type *adc_x, confirm_state new_state)
enable or disable each ordinary channel conversion set occe flag of the specified adc peripheral. More...
void | adc_ordinary_software_trigger_enable (adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral. More...
flag_status | adc_ordinary_software_trigger_status_get (adc_type *adc_x)
get ordinary software start conversion status of the specified adc peripheral. More...
void | adc_preempt_software_trigger_enable (adc_type *adc_x, confirm_state new_state)
enable or disable preempt software start conversion of the specified adc peripheral. More...
flag_status | adc_preempt_software_trigger_status_get (adc_type *adc_x)
get preempt software start conversion status of the specified adc peripheral. More...
uint16_t | adc_ordinary_conversion_data_get (adc_type *adc_x)
return the last conversion data for ordinary channel of the specified adc peripheral. More...
uint32_t | adc_combine_ordinary_conversion_data_get (void)
return the last ordinary conversion data of combine adc. More...
uint16_t | adc_preempt_conversion_data_get (adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral. More...
flag_status | adc_flag_get (adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral. More...
void | adc_flag_clear (adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral. More...
void | adc_ordinary_oversample_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the ordinary oversampling of the specified adc peripheral. More...
void | adc_preempt_oversample_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the preempt oversampling of the specified adc peripheral. More...
void | adc_oversample_ratio_shift_set (adc_type *adc_x, adc_oversample_ratio_type adc_oversample_ratio, adc_oversample_shift_type adc_oversample_shift)
config the oversampling ratio and shift of the specified adc peripheral. More...
void | adc_ordinary_oversample_trig_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the ordinary oversampling trigger mode of the specified adc peripheral. More...
void | adc_ordinary_oversample_restart_set (adc_type *adc_x, adc_ordinary_oversample_restart_type adc_ordinary_oversample_restart)
set ordinary oversample restart mode of the specified adc peripheral. More...

Detailed Description

contains all the functions for the adc firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_adc.c.


AT32F435/437 Firmwary Library: at32f435_437_can.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_can.c File Reference

contains all the functions for the can firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

void | can_reset (can_type *can_x)
deinitialize the can peripheral registers to their default reset values. More...
void | can_baudrate_default_para_init (can_baudrate_type *can_baudrate_struct)
fill each can_baudrate_struct member with its default value. More...
error_status | can_baudrate_set (can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral More...
void | can_default_para_init (can_base_type *can_base_struct)
fill each can_init_struct member with its default value. More...
error_status | can_base_init (can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct. More...
void | can_filter_default_para_init (can_filter_init_type *can_filter_init_struct)
fill each can_filter_init_struct member with its default value. More...
void | can_filter_init (can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct. More...
void | can_debug_transmission_prohibit (can_type *can_x, confirm_state new_state)
enable or disable the debug transmission prohibit of the specified can peripheral. More...
void | can_ttc_mode_enable (can_type *can_x, confirm_state new_state)
enable or disable time trigger operation communication mode of the specified can peripheral. More...
uint8_t | can_message_transmit (can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral. More...
can_transmit_status_type | can_transmit_status_get (can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral. More...
void | can_transmit_cancel (can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
cancel a transmit request of the specified can peripheral. More...
void | can_message_receive (can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral. More...
void | can_receive_fifo_release (can_type *can_x, can_rx_fifo_num_type fifo_number)
release the specified fifo of the specified can peripheral. More...
uint8_t | can_receive_message_pending_get (can_type *can_x, can_rx_fifo_num_type fifo_number)
return the number of pending messages of the specified can peripheral. More...
error_status | can_operating_mode_set (can_type *can_x, can_operating_mode_type can_operating_mode)
set the operation mode of the specified can peripheral. More...
can_enter_doze_status_type | can_doze_mode_enter (can_type *can_x)
enter the low power mode of the specified can peripheral. More...
can_quit_doze_status_type | can_doze_mode_exit (can_type *can_x)
exit the doze mode of the specified can peripheral. More...
can_error_record_type | can_error_type_record_get (can_type *can_x)
return the error type record (etr) of the specified can peripheral. More...
uint8_t | can_receive_error_counter_get (can_type *can_x)
return the receive error counter (rec) of the specified can peripheral. More...
uint8_t | can_transmit_error_counter_get (can_type *can_x)
return the transmit error counter of the specified can peripheral. More...
void | can_interrupt_enable (can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral. More...
flag_status | can_flag_get (can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral. More...
void | can_flag_clear (can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral. More...

Detailed Description

contains all the functions for the can firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_can.c.


AT32F435/437 Firmwary Library: at32f435_437_crc.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_crc.c File Reference

contains all the functions for the crc firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

void | crc_data_reset (void)
reset the crc data register. More...
uint32_t | crc_one_word_calculate (uint32_t data)
compute the 32-bit crc of a given data word(32-bit). More...
uint32_t | crc_block_calculate (uint32_t *pbuffer, uint32_t length)
compute the 32-bit crc of a given buffer of data word(32-bit). More...
uint32_t | crc_data_get (void)
return the current crc value. More...
void | crc_common_data_set (uint8_t cdt_value)
store a 8-bit data in the common data register. More...
uint8_t | crc_common_date_get (void)
return the 8-bit data stored in the common data register More...
void | crc_init_data_set (uint32_t value)
set the 32-bit initial data of crc More...
void | crc_reverse_input_data_set (crc_reverse_input_type value)
control the reversal of the bit order in the input data More...
void | crc_reverse_output_data_set (crc_reverse_output_type value)
control the reversal of the bit order in the output data More...

Detailed Description

contains all the functions for the crc firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_crc.c.


AT32F435/437 Firmwary Library: at32f435_437_crm.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_crm.c File Reference

contains all the functions for the crm firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

void | crm_reset (void)
reset the crm register More...
void | crm_lext_bypass (confirm_state new_state)
enable or disable crm low speed external crystal bypass More...
void | crm_hext_bypass (confirm_state new_state)
enable or disable crm high speed external crystal bypass More...
flag_status | crm_flag_get (uint32_t flag)
get crm flag status More...
error_status | crm_hext_stable_wait (void)
wait for hext stable More...
void | crm_hick_clock_trimming_set (uint8_t trim_value)
set the hick trimming value More...
void | crm_hick_clock_calibration_set (uint8_t cali_value)
set the crm calibration value More...
void | crm_periph_clock_enable (crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock More...
void | crm_periph_reset (crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset More...
void | crm_periph_lowpower_mode_enable (crm_periph_clock_lowpower_type value, confirm_state new_state)
enable or disable the peripheral clock in lowpower mode More...
void | crm_clock_source_enable (crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source More...
void | crm_flag_clear (uint32_t flag)
clear the crm reset flags More...
void | crm_ertc_clock_select (crm_ertc_clock_type value)
select ertc clock More...
void | crm_ertc_clock_enable (confirm_state new_state)
enable or disable ertc More...
void | crm_ahb_div_set (crm_ahb_div_type value)
set crm ahb division More...
void | crm_apb1_div_set (crm_apb1_div_type value)
set crm apb1 division More...
void | crm_apb2_div_set (crm_apb2_div_type value)
set crm apb2 division More...
void | crm_usb_clock_div_set (crm_usb_div_type value)
set usb division More...
void | crm_clock_failure_detection_enable (confirm_state new_state)
enable or disable clock failure detection More...
void | crm_battery_powered_domain_reset (confirm_state new_state)
battery powered domain software reset More...
void | crm_auto_step_mode_enable (confirm_state new_state)
auto step clock switch enable More...
void | crm_hick_divider_select (crm_hick_div_6_type value)
config hick divider select More...
void | crm_hick_sclk_frequency_select (crm_hick_sclk_frequency_type value)
hick as system clock frequency select More...
void | crm_usb_clock_source_select (crm_usb_clock_source_type value)
usb 48 mhz clock source select More...
void | crm_clkout_to_tmr10_enable (confirm_state new_state)
enable or disable clkout direct to tmr10 channel 1 More...
void | crm_pll_config (crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n attemtion: 31 <= pll_ns <= 500 1 <= pll_ms <= 15 More...
void | crm_sysclk_switch (crm_sclk_type value)
select system clock source More...
crm_sclk_type | crm_sysclk_switch_status_get (void)
indicate which clock source is used as system clock More...
void | crm_clocks_freq_get (crm_clocks_freq_type *clocks_struct)
get crm clocks freqency More...
void | crm_clock_out1_set (crm_clkout1_select_type clkout)
set crm clkout1 More...
void | crm_clock_out2_set (crm_clkout2_select_type clkout)
set crm clkout2 More...
void | crm_clkout_div_set (crm_clkout_index_type index, crm_clkout_div1_type div1, crm_clkout_div2_type div2)
set crm clkout1 division1 More...
void | crm_emac_output_pulse_set (crm_emac_output_pulse_type width)
set emac output pulse width More...
void | crm_interrupt_enable (uint32_t crm_int, confirm_state new_state)
config crm interrupt More...
error_status | crm_pll_parameter_calculate (crm_pll_clock_source_type pll_rcs, uint32_t target_sclk_freq, uint16_t *ret_ms, uint16_t *ret_ns, uint16_t *ret_fr)
calculate the pll parameters with pll reference clock and target pll output frequency. pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n attemtion: 31 <= pll_ns <= 500 1 <= pll_ms <= 15 More...

Detailed Description

contains all the functions for the crm firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_crm.c.


AT32F435/437 Firmwary Library: at32f435_437_dac.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_dac.c File Reference

contains all the functions for the dac firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

void | dac_reset (void)
dac reset More...
void | dac_enable (dac_select_type dac_select, confirm_state new_state)
enable or disable dac More...
void | dac_output_buffer_enable (dac_select_type dac_select, confirm_state new_state)
enable or disable dac output buffer More...
void | dac_trigger_enable (dac_select_type dac_select, confirm_state new_state)
enable or disable dac trigger More...
void | dac_trigger_select (dac_select_type dac_select, dac_trigger_type dac_trigger_source)
select dac trigger More...
void | dac_software_trigger_generate (dac_select_type dac_select)
generate dac software trigger More...
void | dac_dual_software_trigger_generate (void)
generate dac dual software trigger synchronously More...
void | dac_wave_generate (dac_select_type dac_select, dac_wave_type dac_wave)
generate dac wave More...
void | dac_mask_amplitude_select (dac_select_type dac_select, dac_mask_amplitude_type dac_mask_amplitude)
select dac mask amplitude More...
void | dac_dma_enable (dac_select_type dac_select, confirm_state new_state)
enable or disable dac dma More...
uint16_t | dac_data_output_get (dac_select_type dac_select)
get dac data output More...
void | dac_1_data_set (dac1_aligned_data_type dac1_aligned, uint16_t dac1_data)
set dac1 data More...
void | dac_2_data_set (dac2_aligned_data_type dac2_aligned, uint16_t dac2_data)
set dac2 data More...
void | dac_dual_data_set (dac_dual_data_type dac_dual, uint16_t data1, uint16_t data2)
set dac dual data More...
void | dac_udr_enable (dac_select_type dac_select, confirm_state new_state)
enable/disable dac dma udr interrupt More...
flag_status | dac_udr_flag_get (dac_select_type dac_select)
get flag of the dac udr flag. More...
void | dac_udr_flag_clear (dac_select_type dac_select)
clear the dac udr flag. More...

Detailed Description

contains all the functions for the dac firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_dac.c.


AT32F435/437 Firmwary Library: at32f435_437_debug.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_debug.c File Reference
#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

uint32_t | debug_device_id_get (void)
get debug device id More...
void | debug_low_power_mode_set (uint32_t low_power_mode, confirm_state new_state)
set periph debug mode More...
void | debug_apb1_periph_mode_set (uint32_t apb1_periph, confirm_state new_state)
set apb1 periph debug mode More...
void | debug_apb2_periph_mode_set (uint32_t apb2_periph, confirm_state new_state)
set apb2 periph debug mode More...


AT32F435/437 Firmwary Library: at32f435_437_dma.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_dma.c File Reference

contains all the functions for the dma firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

void | dma_reset (dma_channel_type *dmax_channely)
reset dmax channely register. More...
void | dma_data_number_set (dma_channel_type *dmax_channely, uint16_t data_number)
set the number of data to be transferred. More...
uint16_t | dma_data_number_get (dma_channel_type *dmax_channely)
get the number of data to be transferred. More...
void | dma_interrupt_enable (dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt. More...
void | dma_channel_enable (dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel. More...
flag_status | dma_flag_get (uint32_t dmax_flag)
dma flag get. More...
void | dma_flag_clear (uint32_t dmax_flag)
dma flag clear. More...
void | dma_default_para_init (dma_init_type *dma_init_struct)
dma init config with its default value. More...
void | dma_init (dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init. More...
void | dma_flexible_config (dma_type *dma_x, dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init. More...
void | dmamux_enable (dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux. More...
void | dmamux_init (dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init. More...
void | dmamux_sync_default_para_init (dmamux_sync_init_type *dmamux_sync_init_struct)
dmamux sync init struct config with its default value. More...
void | dmamux_sync_config (dmamux_channel_type *dmamux_channelx, dmamux_sync_init_type *dmamux_sync_init_struct)
dmamux synchronization config. More...
void | dmamux_generator_default_para_init (dmamux_gen_init_type *dmamux_gen_init_struct)
dmamux request generator init struct config with its default value. More...
void | dmamux_generator_config (dmamux_generator_type *dmamux_gen_x, dmamux_gen_init_type *dmamux_gen_init_struct)
dmamux request generator init. More...
void | dmamux_sync_interrupt_enable (dmamux_channel_type *dmamux_channelx, confirm_state new_state)
enable or disable the dmamux sync interrupts. More...
void | dmamux_generator_interrupt_enable (dmamux_generator_type *dmamux_gen_x, confirm_state new_state)
enable or disable the dmamux request generator interrupts. More...
flag_status | dmamux_sync_flag_get (dma_type *dma_x, uint32_t flag)
dmamux sync flag get. More...
void | dmamux_sync_flag_clear (dma_type *dma_x, uint32_t flag)
dmamux sync flag clear. More...
flag_status | dmamux_generator_flag_get (dma_type *dma_x, uint32_t flag)
dmamux request generator flag get. More...
void | dmamux_generator_flag_clear (dma_type *dma_x, uint32_t flag)
dmamux request generator flag clear. More...

Detailed Description

contains all the functions for the dma firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_dma.c.


AT32F435/437 Firmwary Library: at32f435_437_dvp.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_dvp.c File Reference

contains all the functions for the dvp firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

void | dvp_reset (void)
reset the dvp register More...
void | dvp_capture_enable (confirm_state new_state)
enable or disable dvp capture More...
void | dvp_capture_mode_set (dvp_cfm_type cap_mode)
set dvp capture mode More...
void | dvp_window_crop_enable (confirm_state new_state)
set dvp cropping window enable More...
void | dvp_window_crop_set (uint16_t crop_x, uint16_t crop_y, uint16_t crop_w, uint16_t crop_h, uint8_t bytes)
set dvp cropping window configuration More...
void | dvp_jpeg_enable (confirm_state new_state)
enable or disable dvp jpeg More...
void | dvp_sync_mode_set (dvp_sm_type sync_mode)
set dvp synchronization mode More...
void | dvp_sync_code_set (uint8_t fmsc, uint8_t fmec, uint8_t lnsc, uint8_t lnec)
set dvp synchronization code configuration More...
void | dvp_sync_unmask_set (uint8_t fmsu, uint8_t fmeu, uint8_t lnsu, uint8_t lneu)
set dvp synchronization unmask configuration More...
void | dvp_pclk_polarity_set (dvp_ckp_type edge)
set dvp pixel clock polarity More...
void | dvp_hsync_polarity_set (dvp_hsp_type hsync_pol)
set dvp horizontal synchronization polarity More...
void | dvp_vsync_polarity_set (dvp_vsp_type vsync_pol)
set dvp vertical synchronization polarity More...
void | dvp_basic_frame_rate_control_set (dvp_bfrc_type dvp_bfrc)
config dvp basic frame rate control More...
void | dvp_pixel_data_length_set (dvp_pdl_type dvp_pdl)
config dvp pixel data length More...
void | dvp_enable (confirm_state new_state)
enable or disable dvp function More...
void | dvp_zoomout_select (dvp_pcdes_type dvp_pcdes)
set dvp zoomout select More...
void | dvp_zoomout_set (dvp_pcdc_type dvp_pcdc, dvp_pcds_type dvp_pcds, dvp_lcdc_type dvp_lcdc, dvp_lcds_type dvp_lcds)
set dvp zoomout configuration More...
flag_status | dvp_basic_status_get (dvp_status_basic_type dvp_status_basic)
get dvp basic status More...
void | dvp_interrupt_enable (uint32_t dvp_int, confirm_state new_state)
enable or disable dvp interrupt More...
flag_status | dvp_flag_get (uint32_t flag)
get dvp event/interrupt flag status More...
void | dvp_flag_clear (uint32_t flag)
clear dvp's pending flags More...
void | dvp_enhanced_scaling_resize_enable (confirm_state new_state)
set dvp enhanced image scaling resize enable More...
void | dvp_enhanced_scaling_resize_set (uint16_t src_w, uint16_t des_w, uint16_t src_h, uint16_t des_h)
set dvp enhanced image scaling resize configuration More...
void | dvp_enhanced_framerate_set (uint16_t efrcsf, uint16_t efrctf, confirm_state new_state)
set enhanced frame rate control configuration More...
void | dvp_monochrome_image_binarization_set (uint8_t mibthd, confirm_state new_state)
set dvp monochrome image binarization configuration More...
void | dvp_enhanced_data_format_set (dvp_efdf_type dvp_efdf)
set dvp enhanced function data format configuration More...
void | dvp_input_data_unused_set (dvp_idus_type dvp_idus, dvp_idun_type dvp_idun)
set dvp input data un-used condition/number configuration More...
void | dvp_dma_burst_set (dvp_dmabt_type dvp_dmabt)
set dvp dma burst transfer configuration More...
void | dvp_sync_event_interrupt_set (dvp_hseid_type dvp_hseid, dvp_vseid_type dvp_vseid)
set dvp hsync/vsync event interrupt strategy configuration More...

Detailed Description

contains all the functions for the dvp firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_dvp.c.


AT32F435/437 Firmwary Library: at32f435_437_edma.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_edma.c File Reference

contains all the functions for the edma firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

void | edma_reset (edma_stream_type *edma_streamx)
reset edma_streamx channely register. More...
void | edma_init (edma_stream_type *edma_streamx, edma_init_type *edma_init_struct)
edma init. More...
void | edma_default_para_init (edma_init_type *edma_init_struct)
edma init struct config with its default value. More...
void | edma_stream_enable (edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx. More...
void | edma_interrupt_enable (edma_stream_type *edma_streamx, uint32_t edma_int, confirm_state new_state)
enable or disable the edma streamx interrupts. More...
void | edma_peripheral_inc_offset_set (edma_stream_type *edma_streamx, edma_peripheral_inc_offset_type offset)
config the edma peripheral increment offset size mode. More...
void | edma_flow_controller_enable (edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx flow controller. More...
void | edma_data_number_set (edma_stream_type *edma_streamx, uint16_t data_number)
set the number of data to be transferred. More...
uint16_t | edma_data_number_get (edma_stream_type *edma_streamx)
get the number of data to be transferred. More...
void | edma_double_buffer_mode_init (edma_stream_type *edma_streamx, uint32_t memory1_addr, edma_memory_type current_memory)
config the the double buffer mode. More...
void | edma_double_buffer_mode_enable (edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the double memory mode. More...
void | edma_memory_addr_set (edma_stream_type *edma_streamx, uint32_t memory_addr, uint32_t memory_target)
config the memory address in double buffer mode. More...
edma_memory_type | edma_memory_target_get (edma_stream_type *edma_streamx)
get the current memory target. More...
flag_status | edma_stream_status_get (edma_stream_type *edma_streamx)
get the enable status of edma streamx. More...
uint8_t | edma_fifo_status_get (edma_stream_type *edma_streamx)
get the fifo level status. More...
flag_status | edma_flag_get (uint32_t edma_flag)
get the edma flag. More...
void | edma_flag_clear (uint32_t edma_flag)
clear the edma flag. More...
void | edma_2d_init (edma_stream_2d_type *edma_streamx_2d, int16_t src_stride, int16_t dst_stride, uint16_t xcnt, uint16_t ycnt)
initialize the edma 2d mode. More...
void | edma_2d_enable (edma_stream_2d_type *edma_streamx_2d, confirm_state new_state)
enable or disable the edma 2d mode. More...
void | edma_link_list_init (edma_stream_link_list_type *edma_streamx_ll, uint32_t pointer)
initialize the edma link list. More...
void | edma_link_list_enable (edma_stream_link_list_type *edma_streamx_ll, confirm_state new_state)
enable or disable the edma stream link list mode. More...
void | edmamux_enable (confirm_state new_state)
enable or disable the edma edmamux. More...
void | edmamux_init (edmamux_channel_type *edmamux_channelx, edmamux_requst_id_sel_type edmamux_req_id)
edmamux init. More...
void | edmamux_sync_default_para_init (edmamux_sync_init_type *edmamux_sync_init_struct)
edmamux sync init struct config with its default value. More...
void | edmamux_sync_config (edmamux_channel_type *edmamux_channelx, edmamux_sync_init_type *edmamux_sync_init_struct)
edmamux synchronization config. More...
void | edmamux_generator_default_para_init (edmamux_gen_init_type *edmamux_gen_init_struct)
edmamux request generator init struct config with its default value. More...
void | edmamux_generator_config (edmamux_generator_type *edmamux_gen_x, edmamux_gen_init_type *edmamux_gen_init_struct)
edmamux request generator init. More...
void | edmamux_sync_interrupt_enable (edmamux_channel_type *edmamux_channelx, confirm_state new_state)
enable or disable the edmamux sync interrupts. More...
void | edmamux_generator_interrupt_enable (edmamux_generator_type *edmamux_gen_x, confirm_state new_state)
enable or disable the edmamux request generator interrupts. More...
flag_status | edmamux_sync_flag_get (uint32_t flag)
edmamux sync flag get. More...
void | edmamux_sync_flag_clear (uint32_t flag)
edmamux sync flag clear. More...
flag_status | edmamux_generator_flag_get (uint32_t flag)
edmamux request generator flag get. More...
void | edmamux_generator_flag_clear (uint32_t flag)
edmamux request generator flag clear. More...

Detailed Description

contains all the functions for the edma firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_edma.c.


AT32F435/437 Firmwary Library: at32f435_437_emac.c File Reference

  • libraries
  • drivers
  • src
Functions | Variables
at32f435_437_emac.c File Reference

contains all the functions for the emac firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

static void | emac_delay (uint32_t delay)
this is delay function base on system clock. More...
void | emac_reset (void)
deinitialize the emac peripheral registers to their default reset values. More...
void | emac_control_para_init (emac_control_config_type *control_para)
initialize emac control structure More...
void | emac_clock_range_set (void)
according to hclk to set mdc clock frequency. More...
void | emac_control_config (emac_control_config_type *control_struct)
configure emac control setting. More...
void | emac_dma_software_reset_set (void)
reset emac dma More...
flag_status | emac_dma_software_reset_get (void)
get emac dma reset status More...
void | emac_start (void)
enable emac and dma reception/transmission More...
void | emac_stop (void)
stop emac and dma reception/transmission More...
error_status | emac_phy_register_write (uint8_t address, uint8_t reg, uint16_t data)
write phy data. More...
error_status | emac_phy_register_read (uint8_t address, uint8_t reg, uint16_t *data)
read phy data More...
void | emac_receiver_enable (confirm_state new_state)
emac receiver enable. More...
void | emac_trasmitter_enable (confirm_state new_state)
emac transmitter enable. More...
void | emac_deferral_check_set (confirm_state new_state)
emac defferal check enable, only avalible in half-duplex mode. More...
void | emac_backoff_limit_set (emac_bol_type slot_time)
emac back-off limit, only avalible in half-duplex mode. More...
void | emac_auto_pad_crc_stripping_set (confirm_state new_state)
set mac automatic pad/CRC stripping. More...
void | emac_retry_disable (confirm_state new_state)
transmittion retry disable. More...
void | emac_ipv4_checksum_offload_set (confirm_state new_state)
set ipv4 checksum offload. More...
void | emac_loopback_mode_enable (confirm_state new_state)
enable loopback mode. More...
void | emac_receive_own_disable (confirm_state new_state)
receive own disable. More...
void | emac_carrier_sense_disable (confirm_state new_state)
carrier sense disbale. More...
void | emac_interframe_gap_set (emac_intergrame_gap_type number)
set minimum interframe gap between frames during transmission. More...
void | emac_jabber_disable (confirm_state new_state)
jabber disable. More...
void | emac_watchdog_disable (confirm_state new_state)
watchdog disable. More...
void | emac_fast_speed_set (emac_speed_type speed)
set mac fast emac speed. More...
void | emac_duplex_mode_set (emac_duplex_type duplex_mode)
set duplex mode. More...
void | emac_promiscuous_mode_set (confirm_state new_state)
set mac promiscuous mode. More...
void | emac_hash_unicast_set (confirm_state new_state)
hash unicast. More...
void | emac_hash_multicast_set (confirm_state new_state)
hash multicast. More...
void | emac_dstaddr_inverse_filter_set (confirm_state new_state)
destination address inverse filtering. More...
void | emac_pass_all_multicasting_set (confirm_state new_state)
pass all multicasting frames. More...
void | emac_broadcast_frames_disable (confirm_state new_state)
broadcast frames disable. More...
void | emac_pass_control_frames_set (emac_control_frames_filter_type condition)
set mac how to pass control frames. More...
void | emac_srcaddr_inverse_filter_set (confirm_state new_state)
source address inverse filtering. More...
void | emac_srcaddr_filter_set (confirm_state new_state)
source address filtering. More...
void | emac_hash_perfect_filter_set (confirm_state new_state)
mac uses hash or perfect filter. More...
void | emac_receive_all_set (confirm_state new_state)
mac receives all frames. More...
void | emac_hash_table_high32bits_set (uint32_t high32bits)
hash table high 32-bit. More...
void | emac_hash_table_low32bits_set (uint32_t low32bits)
hash table low 32-bit. More...
flag_status | emac_mii_busy_get (void)
mii busy status. More...
void | emac_mii_write (confirm_state new_state)
tell phy that will be written. More...
void | emac_fcb_bpa_set (confirm_state new_state)
set flow control busy in full-duplex mode, back pressure activate in half-duplex mode. More...
void | emac_transmit_flow_control_enable (confirm_state new_state)
set transmit flow control. More...
void | emac_receive_flow_control_enable (confirm_state new_state)
set receive flow control. More...
void | emac_unicast_pause_frame_detect (confirm_state new_state)
set unicast pause frame detect. More...
void | emac_pause_low_threshold_set (emac_pause_slot_threshold_type pasue_threshold)
set pause low threshold. More...
void | emac_zero_quanta_pause_disable (confirm_state new_state)
set zero-quanta pause disable. More...
void | emac_pause_time_set (uint16_t pause_time)
set pause time. More...
void | emac_vlan_tag_identifier_set (uint16_t identifier)
identify coming vlan frame field with setting value. More...
void | emac_vlan_tag_comparison_set (confirm_state new_state)
set 12-bit vlan identifier. More...
void | emac_wakeup_frame_set (uint32_t value)
set wakeup frame. More...
uint32_t | emac_wakeup_frame_get (void)
get wakeup frame. More...
void | emac_power_down_set (confirm_state new_state)
all frame will be droppped except wakeup frame or magic packet. More...
void | emac_magic_packet_enable (confirm_state new_state)
magic packet enable More...
void | emac_wakeup_frame_enable (confirm_state new_state)
wakeup frame enable More...
flag_status | emac_received_magic_packet_get (void)
received magic packet More...
flag_status | emac_received_wakeup_frame_get (void)
received wakeup frame. More...
void | emac_global_unicast_set (confirm_state new_state)
set unicast frame that passes DAF as wakeup frame. More...
void | emac_wakeup_frame_filter_reset (confirm_state new_state)
reset wakeup frame filter resgister More...
flag_status | emac_interrupt_status_read (uint32_t flag)
read interrupt status More...
void | emac_interrupt_mask_set (emac_interrupt_mask_type mask_type, confirm_state new_state)
set interrupt mask More...
void | emac_local_address_set (uint8_t *address)
set local mac address More...
void | emac_address_filter_set (emac_address_type mac, emac_address_filter_type filter, emac_address_mask_type mask_bit, confirm_state new_state)
set mac filter address More...
void | emac_dma_descriptor_list_address_set (emac_dma_tx_rx_type transfer_type, emac_dma_desc_type *dma_desc_tab, uint8_t *buff, uint32_t buffer_count)
set transmit/receive descriptor list address More...
void | emac_dma_rx_desc_interrupt_config (emac_dma_desc_type *dma_rx_desc, confirm_state new_state)
enable or disable the specified dma rx descriptor receive interrupt More...
uint32_t | emac_dma_descriptor_list_address_get (emac_dma_tx_rx_type transfer_type)
get transmit/receive descriptor list address More...
uint32_t | emac_received_packet_size_get (void)
get the size of received the received packet. More...
uint32_t | emac_dmarxdesc_frame_length_get (emac_dma_desc_type *dma_rx_desc)
get the specified dma rx descsriptor frame length. More...
void | emac_dma_para_init (emac_dma_config_type *control_para)
init emac dma parameters More...
void | emac_dma_config (emac_dma_config_type *control_para)
configure emac dma More...
void | emac_dma_arbitation_set (emac_dma_rx_tx_ratio_type ratio, confirm_state new_state)
set rx tx priority More...
void | emac_dma_descriptor_skip_length_set (uint8_t length)
set descriptor skip mength More...
void | emac_dma_separate_pbl_set (emac_dma_pbl_type tx_length, emac_dma_pbl_type rx_length, confirm_state new_state)
set programmable burst length More...
void | emac_dma_eight_pbl_mode_set (confirm_state new_state)
set 8 times programmable burst length More...
void | emac_dma_address_aligned_beats_set (confirm_state new_state)
set address-aligned beats More...
void | emac_dma_poll_demand_set (emac_dma_tx_rx_type transfer_type, uint32_t value)
set transmit/receive poll demand More...
uint32_t | emac_dma_poll_demand_get (emac_dma_tx_rx_type transfer_type)
get transmit poll demand More...
emac_dma_receive_process_status_type | emac_dma_receive_status_get (void)
get receive dma process status More...
emac_dma_transmit_process_status_type | emac_dma_transmit_status_get (void)
get transmit dma process status More...
void | emac_dma_operations_set (emac_dma_operations_type ops, confirm_state new_state)
set dma operations More...
void | emac_dma_receive_threshold_set (emac_dma_receive_threshold_type value)
set receive dma threshold More...
void | emac_dma_transmit_threshold_set (emac_dma_transmit_threshold_type value)
set transmit dma threshold More...
void | emac_dma_interrupt_enable (emac_dma_interrupt_type it, confirm_state new_state)
enable dma interrupt More...
uint16_t | emac_dma_controller_missing_frame_get (void)
get missed frames by the controller More...
uint8_t | emac_dma_missing_overflow_bit_get (void)
get overflow bit for missed frame counter More...
uint16_t | emac_dma_application_missing_frame_get (void)
get missed frames by the application More...
uint8_t | emac_dma_fifo_overflow_bit_get (void)
get overflow bit for FIFO overflow counter More...
uint32_t | emac_dma_tansfer_address_get (emac_dma_transfer_address_type transfer_type)
get overflow bit for FIFO overflow counter More...
void | emac_mmc_counter_reset (void)
reset all counter More...
void | emac_mmc_rollover_stop (confirm_state new_state)
counter stop counting from zero when it reaches maximum More...
void | emac_mmc_reset_on_read_enable (confirm_state new_state)
enable reset on read More...
void | emac_mmc_counter_freeze (confirm_state new_state)
freeze mmc counter More...
flag_status | emac_mmc_received_status_get (uint32_t flag)
interupt status of received frames More...
flag_status | emac_mmc_transmit_status_get (uint32_t flag)
interupt status of transmit frames More...
void | emac_mmc_received_interrupt_mask_set (uint32_t flag, confirm_state new_state)
mask received mmc interrupt More...
void | emac_mmc_transmit_interrupt_mask_set (uint32_t flag, confirm_state new_state)
mask transmit mmc interrupt More...
uint32_t | emac_mmc_transmit_good_frames_get (uint32_t flag)
get good frame numbers as single collision occurs. More...
uint32_t | emac_mmc_received_error_frames_get (uint32_t flag)
get good frame numbers as single collision occurs. More...
void | emac_ptp_timestamp_enable (confirm_state new_state)
enable timestamp. More...
void | emac_ptp_timestamp_fine_update_enable (confirm_state new_state)
enable timestamp fine update. More...
void | emac_ptp_timestamp_system_time_init (confirm_state new_state)
initialize timestamp time system. More...
void | emac_ptp_timestamp_system_time_update (confirm_state new_state)
update timestamp time system. More...
void | emac_ptp_interrupt_trigger_enable (confirm_state new_state)
enable timestamp interrupt trigger. More...
void | emac_ptp_addend_register_update (confirm_state new_state)
update timestamp addend register. More...
void | emac_ptp_snapshot_received_frames_enable (confirm_state new_state)
enable timestamp snapshot for all received frames. More...
void | emac_ptp_subsecond_rollover_enable (confirm_state new_state)
enable digital rollover. More...
void | emac_ptp_psv2_enable (confirm_state new_state)
enable packet snooping for version 2. More...
void | emac_ptp_snapshot_emac_frames_enable (confirm_state new_state)
enable snapshot over emac. More...
void | emac_ptp_snapshot_ipv6_frames_enable (confirm_state new_state)
enable snapshot for ipv6 frames. More...
void | emac_ptp_snapshot_ipv4_frames_enable (confirm_state new_state)
enable snapshot for ipv4 frames. More...
void | emac_ptp_snapshot_event_message_enable (confirm_state new_state)
enable snapshot for event message. More...
void | emac_ptp_snapshot_master_event_enable (confirm_state new_state)
enable snapshot for message relevant to master More...
void | emac_ptp_clock_node_set (emac_ptp_clock_node_type node)
set clock node type More...
void | emac_ptp_mac_address_filter_enable (confirm_state new_state)
enable ptp frame filtering mac address More...
void | emac_ptp_subsecond_increment_set (uint8_t value)
set subsecond increment value More...
uint32_t | emac_ptp_system_second_get (void)
get system time second More...
uint32_t | emac_ptp_system_subsecond_get (void)
get system time subsecond More...
confirm_state | emac_ptp_system_time_sign_get (void)
get system time sign More...
void | emac_ptp_system_second_set (uint32_t second)
set system time second More...
void | emac_ptp_system_subsecond_set (uint32_t subsecond)
set system time subsecond More...
void | emac_ptp_system_time_sign_set (confirm_state sign)
set system time sign More...
void | emac_ptp_timestamp_addend_set (uint32_t value)
set time stamp addend More...
void | emac_ptp_target_second_set (uint32_t value)
set target time stamp high More...
void | emac_ptp_target_nanosecond_set (uint32_t value)
set target time stamp low More...
confirm_state emac_ptp_timestamp_status_get (emac_ptp_timestamp_status_type status)
set target time stamp low More...
void | emac_ptp_pps_frequency_set (emac_ptp_pps_control_type freq)
set pps frequency More...
flag_status | emac_dma_flag_get (uint32_t dma_flag)
check whether the specified emac dma flag is set or not. More...
void | emac_dma_flag_clear (uint32_t dma_flag)
clear the emac dma flag. More...

Variables

emac_dma_desc_type * dma_tx_desc_to_set
global pointers on tx and rx descriptor used to track transmit and receive descriptors More...
emac_dma_desc_type * dma_rx_desc_to_get

Detailed Description

contains all the functions for the emac firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_emac.c.


AT32F435/437 Firmwary Library: at32f435_437_ertc.c File Reference

  • libraries
  • drivers
  • src
Macros | Functions
at32f435_437_ertc.c File Reference

contains all the functions for the ertc firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Macros

#define ERTC_TIMEOUT ((uint32_t) 0x00360000)

Functions

uint8_t | ertc_num_to_bcd (uint8_t num)
number conversion to bcd code. More...
uint8_t | ertc_bcd_to_num (uint8_t bcd)
bcd code conversion to number. More...
void | ertc_write_protect_enable (void)
enable write protection. More...
void | ertc_write_protect_disable (void)
disable write protection. More...
error_status | ertc_wait_update (void)
ertc wait register update finish. More...
error_status | ertc_wait_flag (uint32_t flag, flag_status status)
ertc wait flag status. More...
error_status | ertc_init_mode_enter (void)
ertc enter init mode. More...
void | ertc_init_mode_exit (void)
ertc exit init mode. More...
error_status | ertc_reset (void)
ertc reset all register. More...
error_status | ertc_divider_set (uint16_t div_a, uint16_t div_b)
ertc division set. More...
error_status | ertc_hour_mode_set (ertc_hour_mode_set_type mode)
ertc hour mode set. More...
error_status | ertc_date_set (uint8_t year, uint8_t month, uint8_t date, uint8_t week)
set date. More...
error_status | ertc_time_set (uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
set time. More...
void | ertc_calendar_get (ertc_time_type *time)
get calendar More...
uint32_t | ertc_sub_second_get (void)
get current sub second. More...
void | ertc_alarm_mask_set (ertc_alarm_type alarm_x, uint32_t mask)
set which bits are irrelevant to the alarm match. More...
void | ertc_alarm_week_date_select (ertc_alarm_type alarm_x, ertc_week_date_select_type wk)
alarm week or date mode select. More...
void | ertc_alarm_set (ertc_alarm_type alarm_x, uint8_t week_date, uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
set alarm. More...
void | ertc_alarm_sub_second_set (ertc_alarm_type alarm_x, uint32_t value, ertc_alarm_sbs_mask_type mask)
set alarm sub second. More...
error_status | ertc_alarm_enable (ertc_alarm_type alarm_x, confirm_state new_state)
enable or disable alarm clock. More...
void | ertc_alarm_get (ertc_alarm_type alarm_x, ertc_alarm_value_type *alarm)
get alarm value. More...
uint32_t | ertc_alarm_sub_second_get (ertc_alarm_type alarm_x)
get alarm sub second. More...
void | ertc_wakeup_clock_set (ertc_wakeup_clock_type clock)
set wakeup timer clock. More...
void | ertc_wakeup_counter_set (uint32_t counter)
set wakeup counter. More...
uint16_t | ertc_wakeup_counter_get (void)
get wakeup counter. More...
error_status | ertc_wakeup_enable (confirm_state new_state)
enable or disable wakeup timer. More...
error_status | ertc_smooth_calibration_config (ertc_smooth_cal_period_type period, ertc_smooth_cal_clk_add_type clk_add, uint32_t clk_dec)
config the smooth calibration. More...
error_status | ertc_coarse_calibration_set (ertc_cal_direction_type dir, uint32_t value)
set the coarse digital calibration. More...
error_status | ertc_coarse_calibration_enable (confirm_state new_state)
enable or disable coarse calibration. More...
void | ertc_cal_output_select (ertc_cal_output_select_type output)
calibration output source select. More...
void | ertc_cal_output_enable (confirm_state new_state)
enable or disable calibration output. More...
error_status | ertc_time_adjust (ertc_time_adjust_type add1s, uint32_t decsbs)
adjust the time. More...
void | ertc_daylight_set (ertc_dst_operation_type operation, ertc_dst_save_type save)
config the daylight saving time. More...
uint8_t | ertc_daylight_bpr_get (void)
get the bpr value. More...
error_status | ertc_refer_clock_detect_enable (confirm_state new_state)
enable or disable refer clock detect. More...
void | ertc_direct_read_enable (confirm_state new_state)
enable or disable direct read mode. More...
void | ertc_output_set (ertc_output_source_type source, ertc_output_polarity_type polarity, ertc_output_type type)
set the output mode. More...
void | ertc_timestamp_pin_select (ertc_pin_select_type pin)
timestamp detection pin selection. More...
void | ertc_timestamp_valid_edge_set (ertc_timestamp_valid_edge_type edge)
set the timestamp valid edge. More...
void | ertc_timestamp_enable (confirm_state new_state)
enable or disable timestamp. More...
void | ertc_timestamp_get (ertc_time_type *time)
get the timestamp. More...
uint32_t | ertc_timestamp_sub_second_get (void)
get the timestamp sub second. More...
void | ertc_tamper_1_pin_select (ertc_pin_select_type pin)
tamper 1 detection pin selection. More...
void | ertc_tamper_pull_up_enable (confirm_state new_state)
enable or disable tamper pin pull up. More...
void | ertc_tamper_precharge_set (ertc_tamper_precharge_type precharge)
set the tamper pin pre-charge time. More...
void | ertc_tamper_filter_set (ertc_tamper_filter_type filter)
set the tamper filter time. More...
void | ertc_tamper_detect_freq_set (ertc_tamper_detect_freq_type freq)
set the tamper detection frequency. More...
void | ertc_tamper_valid_edge_set (ertc_tamper_select_type tamper_x, ertc_tamper_valid_edge_type trigger)
set the tamper trigger. More...
void | ertc_tamper_timestamp_enable (confirm_state new_state)
enable or disable trigger timestamp when tamper event occurs. More...
void | ertc_tamper_enable (ertc_tamper_select_type tamper_x, confirm_state new_state)
enable or disable tamper. More...
void | ertc_interrupt_enable (uint32_t source, confirm_state new_state)
enable or disable interrupt. More...
flag_status | ertc_interrupt_get (uint32_t source)
get interrupt status More...
flag_status | ertc_flag_get (uint32_t flag)
get flag status. More...
void | ertc_flag_clear (uint32_t flag)
clear flag status More...
void | ertc_bpr_data_write (ertc_dt_type dt, uint32_t data)
write data to the bpr register. More...
uint32_t | ertc_bpr_data_read (ertc_dt_type dt)
read data from bpr register. More...

Detailed Description

contains all the functions for the ertc firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_ertc.c.


AT32F435/437 Firmwary Library: at32f435_437_exint.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_exint.c File Reference

contains all the functions for the exint firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

void | exint_reset (void)
exint reset More...
void | exint_default_para_init (exint_init_type *exint_struct)
exint default para init More...
void | exint_init (exint_init_type *exint_struct)
exint init More...
void | exint_flag_clear (uint32_t exint_line)
clear exint flag More...
flag_status | exint_flag_get (uint32_t exint_line)
get exint flag More...
void | exint_software_interrupt_event_generate (uint32_t exint_line)
generate exint software interrupt event More...
void | exint_interrupt_enable (uint32_t exint_line, confirm_state new_state)
enable or disable exint interrupt More...
void | exint_event_enable (uint32_t exint_line, confirm_state new_state)
enable or disable exint event More...

Detailed Description

contains all the functions for the exint firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_exint.c.


AT32F435/437 Firmwary Library: at32f435_437_flash.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_flash.c File Reference

contains all the functions for the flash firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

flag_status | flash_flag_get (uint32_t flash_flag)
check whether the specified flash flag is set or not. More...
void | flash_flag_clear (uint32_t flash_flag)
clear the flash flag. More...
flash_status_type | flash_operation_status_get (void)
return the flash operation status. More...
flash_status_type | flash_bank1_operation_status_get (void)
return the flash bank1 operation status. More...
flash_status_type | flash_bank2_operation_status_get (void)
return the flash bank2 operation status. More...
flash_status_type | flash_operation_wait_for (uint32_t time_out)
wait for flash operation complete or timeout. More...
flash_status_type | flash_bank1_operation_wait_for (uint32_t time_out)
wait for flash bank1 operation complete or timeout. More...
flash_status_type | flash_bank2_operation_wait_for (uint32_t time_out)
wait for flash bank2 operation complete or timeout. More...
void | flash_unlock (void)
unlock the flash controller. More...
void | flash_bank1_unlock (void)
unlock the flash bank1 controller. More...
void | flash_bank2_unlock (void)
unlock the flash bank2 controller. More...
void | flash_lock (void)
lock the flash controller. More...
void | flash_bank1_lock (void)
lock the flash bank1 controller. More...
void | flash_bank2_lock (void)
lock the flash bank2 controller. More...
flash_status_type | flash_sector_erase (uint32_t sector_address)
erase a specified flash sector. More...
flash_status_type | flash_block_erase (uint32_t block_address)
erase a specified flash block. More...
flash_status_type | flash_internal_all_erase (void)
erase flash all internal sectors. More...
flash_status_type | flash_bank1_erase (void)
erase flash bank1 sectors. More...
flash_status_type | flash_bank2_erase (void)
erase flash bank2 sectors. More...
flash_status_type | flash_user_system_data_erase (void)
erase the flash user system data. More...
flash_status_type | flash_eopb0_config (flash_usd_eopb0_type data)
config the extend sram byte eopb0 in user system data. More...
flash_status_type | flash_word_program (uint32_t address, uint32_t data)
program a word at a specified address. More...
flash_status_type | flash_halfword_program (uint32_t address, uint16_t data)
program a halfword at a specified address. More...
flash_status_type | flash_byte_program (uint32_t address, uint8_t data)
program a byte at a specified address. More...
flash_status_type | flash_user_system_data_program (uint32_t address, uint8_t data)
program a halfword at a specified user system data address. More...
flash_status_type | flash_epp_set (uint32_t *sector_bits)
config erase/program protection for the desired sectors. More...
void | flash_epp_status_get (uint32_t *sector_bits)
return the flash erase/program protection status. More...
flash_status_type | flash_fap_enable (confirm_state new_state)
enable or disable the flash access protection. More...
flag_status | flash_fap_status_get (void)
check the flash access protection status. More...
flash_status_type | flash_ssb_set (uint8_t usd_ssb)
program the flash system setting byte in usd: wdt_ato_en / depslp_rst / stdby_rst / btopt. More...
uint8_t | flash_ssb_status_get (void)
return the flash system setting byte status. More...
void | flash_interrupt_enable (uint32_t flash_int, confirm_state new_state)
enable or disable the specified flash interrupts. More...
flash_status_type | flash_slib_enable (uint32_t pwd, uint16_t start_sector, uint16_t inst_start_sector, uint16_t end_sector)
enable security library function. More...
error_status | flash_slib_disable (uint32_t pwd)
disable slib when slib enabled. More...
uint32_t | flash_slib_remaining_count_get (void)
get remaining count of slib(range: 256~0). More...
flag_status | flash_slib_state_get (void)
get the slib state. More...
uint16_t | flash_slib_start_sector_get (void)
get the start sector of slib. More...
uint16_t | flash_slib_inststart_sector_get (void)
get the instruction start sector of slib. More...
uint16_t | flash_slib_end_sector_get (void)
get the end sector of slib. More...
uint32_t | flash_crc_calibrate (uint32_t start_sector, uint32_t sector_cnt)
flash crc calibration in main block. More...
void | flash_nzw_boost_enable (confirm_state new_state)
flash non-zero wait area boost enable. More...
void | flash_continue_read_enable (confirm_state new_state)
flash continue read enable. More...

Detailed Description

contains all the functions for the flash firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_flash.c.


AT32F435/437 Firmwary Library: at32f435_437_gpio.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_gpio.c File Reference

contains all the functions for the gpio firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

void | gpio_reset (gpio_type *gpio_x)
reset the gpio register More...
void | gpio_init (gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral. More...
void | gpio_default_para_init (gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value. More...
flag_status | gpio_input_data_bit_read (gpio_type *gpio_x, uint16_t pins)
read the specified input port pin. More...
uint16_t | gpio_input_data_read (gpio_type *gpio_x)
read the specified gpio input data port. More...
flag_status | gpio_output_data_bit_read (gpio_type *gpio_x, uint16_t pins)
read the specified output port pin. More...
uint16_t | gpio_output_data_read (gpio_type *gpio_x)
read the specified gpio ouput data port. More...
void | gpio_bits_set (gpio_type *gpio_x, uint16_t pins)
set the selected data port bits. More...
void | gpio_bits_reset (gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits. More...
void | gpio_bits_write (gpio_type *gpio_x, uint16_t pins, confirm_state bit_state)
set or clear the selected data port bit. More...
void | gpio_port_write (gpio_type *gpio_x, uint16_t port_value)
write data to the specified gpio data port. More...
void | gpio_pin_wp_config (gpio_type *gpio_x, uint16_t pins)
write protect gpio pins configuration registers. More...
void | gpio_pins_huge_driven_config (gpio_type *gpio_x, uint16_t pins, confirm_state new_state)
enable or disable gpio pins huge driven. More...
void | gpio_pin_mux_config (gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function. More...

Detailed Description

contains all the functions for the gpio firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_gpio.c.


AT32F435/437 Firmwary Library: at32f435_437_i2c.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_i2c.c File Reference

contains all the functions for the i2c firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

void | i2c_reset (i2c_type *i2c_x)
reset the i2c register More...
void | i2c_init (i2c_type *i2c_x, uint8_t dfilters, uint32_t clk)
init i2c digit filters and clock control register. More...
void | i2c_own_address1_set (i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config i2c own address 1. More...
void | i2c_own_address2_set (i2c_type *i2c_x, uint8_t address, i2c_addr2_mask_type mask)
config i2c own address 2 and mask. More...
void | i2c_own_address2_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable own address 2. More...
void | i2c_smbus_enable (i2c_type *i2c_x, i2c_smbus_mode_type mode, confirm_state new_state)
enable or disable smbus mode. More...
void | i2c_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable peripheral. More...
void | i2c_clock_stretch_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable clock stretch. More...
void | i2c_ack_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable ack. More...
void | i2c_addr10_mode_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable 10-bit address mode (master transfer). More...
void | i2c_transfer_addr_set (i2c_type *i2c_x, uint16_t address)
config the slave address to be transmitted. More...
uint16_t | i2c_transfer_addr_get (i2c_type *i2c_x)
get the slave address to be transmitted. More...
void | i2c_transfer_dir_set (i2c_type *i2c_x, i2c_transfer_dir_type i2c_direction)
config the master transfer direction. More...
i2c_transfer_dir_type | i2c_transfer_dir_get (i2c_type *i2c_x)
slave get the i2c transfer direction. More...
uint8_t | i2c_matched_addr_get (i2c_type *i2c_x)
get the i2c slave matched address. More...
void | i2c_auto_stop_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable auto send stop mode. More...
void | i2c_reload_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable cnt reload mode. More...
void | i2c_cnt_set (i2c_type *i2c_x, uint8_t cnt)
config the transfer cnt . More...
void | i2c_addr10_header_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable read 10-bit header, this mode only used in 10-bit address mode read. More...
void | i2c_general_call_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable general call mode. More...
void | i2c_smbus_alert_set (i2c_type *i2c_x, i2c_smbus_alert_set_type level)
drives the smbus alert pin high or low. More...
void | i2c_slave_data_ctrl_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable slave data control. More...
void | i2c_pec_calculate_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable pec calculate. More...
void | i2c_pec_transmit_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable pec transfer. More...
uint8_t | i2c_pec_value_get (i2c_type *i2c_x)
get the i2c pec value. More...
void | i2c_timeout_set (i2c_type *i2c_x, uint16_t timeout)
config the i2c bus timeout. More...
void | i2c_timeout_detcet_set (i2c_type *i2c_x, i2c_timeout_detcet_type mode)
config the bus timeout detcet level. More...
void | i2c_timeout_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable bus timeout. More...
void | i2c_ext_timeout_set (i2c_type *i2c_x, uint16_t timeout)
config the i2c extend bus timeout. More...
void | i2c_ext_timeout_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable extend bus timeout. More...
void | i2c_interrupt_enable (i2c_type *i2c_x, uint32_t source, confirm_state new_state)
enable or disable interrupts. More...
flag_status | i2c_interrupt_get (i2c_type *i2c_x, uint16_t source)
get interrupt status More...
void | i2c_dma_enable (i2c_type *i2c_x, i2c_dma_request_type dma_req, confirm_state new_state)
enable or disable dma requests. More...
void | i2c_transmit_set (i2c_type *i2c_x, uint16_t address, uint8_t cnt, i2c_reload_stop_mode_type rld_stop, i2c_start_mode_type start)
config data transfer. More...
void | i2c_start_generate (i2c_type *i2c_x)
generate start condition. More...
void | i2c_stop_generate (i2c_type *i2c_x)
generate stop condition. More...
void | i2c_data_send (i2c_type *i2c_x, uint8_t data)
send a byte through the i2c periph. More...
uint8_t | i2c_data_receive (i2c_type *i2c_x)
receive a byte through the i2c periph. More...
flag_status | i2c_flag_get (i2c_type *i2c_x, uint32_t flag)
get flag status. More...
void | i2c_flag_clear (i2c_type *i2c_x, uint32_t flag)
clear flag status More...

Detailed Description

contains all the functions for the i2c firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_i2c.c.


AT32F435/437 Firmwary Library: at32f435_437_misc.c File Reference

  • libraries
  • drivers
  • src
Macros | Functions
at32f435_437_misc.c File Reference

contains all the functions for the misc firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Macros

#define AIRCR_VECTKEY_MASK ((uint32_t)0x05FA0000)

Functions

void | nvic_system_reset (void)
system reset More...
void | nvic_irq_enable (IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq More...
void | nvic_irq_disable (IRQn_Type irqn)
disable nvic irq number More...
void | nvic_priority_group_config (nvic_priority_group_type priority_group)
config nvic priority group More...
void | nvic_vector_table_set (uint32_t base, uint32_t offset)
set the vector table location and offset. More...
void | nvic_lowpower_mode_config (nvic_lowpower_mode_type lp_mode, confirm_state new_state)
config nvic lowpower mode More...
void | systick_clock_source_config (systick_clock_source_type source)
config systick clock source More...

Detailed Description

contains all the functions for the misc firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_misc.c.


AT32F435/437 Firmwary Library: at32f435_437_pwc.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_pwc.c File Reference

contains all the functions for the pwc firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

void | pwc_reset (void)
deinitialize the pwc peripheral registers to their default reset values. More...
void | pwc_battery_powered_domain_access (confirm_state new_state)
enable or disable access to the battery powered domain. More...
void | pwc_pvm_level_select (pwc_pvm_voltage_type pvm_voltage)
select the voltage threshold detected by the power voltage detector. More...
void | pwc_power_voltage_monitor_enable (confirm_state new_state)
enable or disable pwc power voltage monitor (pvm) More...
void | pwc_wakeup_pin_enable (uint32_t pin_num, confirm_state new_state)
enable or disable pwc standby wakeup pin More...
void | pwc_flag_clear (uint32_t pwc_flag)
clear flag of pwc More...
flag_status | pwc_flag_get (uint32_t pwc_flag)
get flag of pwc More...
void | pwc_sleep_mode_enter (pwc_sleep_enter_type pwc_sleep_enter)
enter pwc sleep mode More...
void | pwc_deep_sleep_mode_enter (pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode More...
void | pwc_voltage_regulate_set (pwc_regulator_type pwc_regulator)
regulate low power consumption in the deep sleep mode More...
void | pwc_standby_mode_enter (void)
enter pwc standby mode More...

Detailed Description

contains all the functions for the pwc firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_pwc.c.


AT32F435/437 Firmwary Library: at32f435_437_qspi.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_qspi.c File Reference

contain all the functions for qspi firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

void | qspi_encryption_enable (qspi_type *qspi_x, confirm_state new_state)
enable/disable encryption for qspi. More...
void | qspi_sck_mode_set (qspi_type *qspi_x, qspi_clk_mode_type new_mode)
set qspi sck mode. More...
void | qspi_clk_division_set (qspi_type *qspi_x, qspi_clk_div_type new_clkdiv)
set qspi clock division More...
void | qspi_xip_cache_bypass_set (qspi_type *qspi_x, confirm_state new_state)
enable/disable cache in xip mode More...
void | qspi_interrupt_enable (qspi_type *qspi_x, confirm_state new_state)
enable/disable interrupt when command is completed More...
flag_status | qspi_flag_get (qspi_type *qspi_x, uint32_t flag)
get status flags. More...
void | qspi_flag_clear (qspi_type *qspi_x, uint32_t flag)
clear flags More...
void | qspi_dma_rx_threshold_set (qspi_type *qspi_x, qspi_dma_fifo_thod_type new_threshold)
set dma threshold for dma rx More...
void | qspi_dma_tx_threshold_set (qspi_type *qspi_x, qspi_dma_fifo_thod_type new_threshold)
set dma threshold for dma tx More...
void | qspi_dma_enable (qspi_type *qspi_x, confirm_state new_state)
enable/disable dma transfer More...
void | qspi_busy_config (qspi_type *qspi_x, qspi_busy_pos_type busy_pos)
set wip position in status register of flash More...
void | qspi_xip_enable (qspi_type *qspi_x, confirm_state new_state)
enable xip mode or command-port mode. More...
void | qspi_cmd_operation_kick (qspi_type *qspi_x, qspi_cmd_type *qspi_cmd_struct)
set command-port and qspi_x will start to work More...
void | qspi_xip_init (qspi_type *qspi_x, qspi_xip_type *xip_init_struct)
initial xip mode for qspi_x More...
uint8_t | qspi_byte_read (qspi_type *qspi_x)
read one byte from qspi device in command mode More...
uint16_t | qspi_half_word_read (qspi_type *qspi_x)
read one half-word from qspi device in command mode More...
uint32_t | qspi_word_read (qspi_type *qspi_x)
read one word from qspi device in command mode More...
void | qspi_byte_write (qspi_type *qspi_x, uint8_t value)
write one byte to qspi device in command mode More...
void | qspi_half_word_write (qspi_type *qspi_x, uint16_t value)
write one half-word to qspi device in command mode More...
void | qspi_word_write (qspi_type *qspi_x, uint32_t value)
write one word to qspi device in command mode More...

Detailed Description

contain all the functions for qspi firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_qspi.c.


AT32F435/437 Firmwary Library: at32f435_437_scfg.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_scfg.c File Reference

contains all the functions for the system config firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

void | scfg_reset (void)
scfg reset More...
void | scfg_xmc_mapping_swap_set (scfg_xmc_swap_type xmc_swap)
scfg xmc address mapping swap set More...
void | scfg_infrared_config (scfg_ir_source_type source, scfg_ir_polarity_type polarity)
scfg infrared config More...
void | scfg_mem_map_set (scfg_mem_map_type mem_map)
scfg memory address mapping set More...
void | scfg_emac_interface_set (scfg_emac_interface_type mode)
scfg emac interface set More...
void | scfg_exint_line_config (scfg_port_source_type port_source, scfg_pins_source_type pin_source)
select the gpio pin used as exint line. More...
void | scfg_pins_ultra_driven_enable (scfg_ultra_driven_pins_type value, confirm_state new_state)
enable or disable gpio pins ultra driven. More...

Detailed Description

contains all the functions for the system config firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_scfg.c.


AT32F435/437 Firmwary Library: at32f435_437_sdio.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_sdio.c File Reference

contains all the functions for the sdio firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

void | sdio_reset (sdio_type *sdio_x)
reset the sdio register More...
void | sdio_power_set (sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller More...
sdio_power_state_type | sdio_power_status_get (sdio_type *sdio_x)
get power status. More...
void | sdio_clock_config (sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock More...
void | sdio_bus_width_config (sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width More...
void | sdio_clock_bypass (sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss More...
void | sdio_power_saving_mode_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle. More...
void | sdio_flow_control_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control. More...
void | sdio_clock_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output. More...
void | sdio_dma_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable dma. More...
void | sdio_interrupt_enable (sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt. More...
flag_status | sdio_flag_get (sdio_type *sdio_x, uint32_t flag)
get sdio flag. More...
void | sdio_flag_clear (sdio_type *sdio_x, uint32_t flag)
clear sdio flag. More...
void | sdio_command_config (sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command. More...
void | sdio_command_state_machine_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM). More...
uint8_t | sdio_command_response_get (sdio_type *sdio_x)
get command index of last command for which response received. More...
uint32_t | sdio_response_get (sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command. More...
void | sdio_data_config (sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data. More...
void | sdio_data_state_machine_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM). More...
uint32_t | sdio_data_counter_get (sdio_type *sdio_x)
get the number of remaining data bytes to be transferred. More...
uint32_t | sdio_data_read (sdio_type *sdio_x)
read a word data from sdio fifo. More...
uint32_t | sdio_buffer_counter_get (sdio_type *sdio_x)
get the number of words left to be written to or read from fifo.. More...
void | sdio_data_write (sdio_type *sdio_x, uint32_t data)
write one word data to fifo. More...
void | sdio_read_wait_mode_set (sdio_type *sdio_x, sdio_read_wait_mode_type mode)
set the read wait mode. More...
void | sdio_read_wait_start (sdio_type *sdio_x, confirm_state new_state)
enable or disable to start sd i/o read wait operation. More...
void | sdio_read_wait_stop (sdio_type *sdio_x, confirm_state new_state)
enable or disable to stop sd i/o read wait operation. More...
void | sdio_io_function_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable the sd i/o function. More...
void | sdio_io_suspend_command_set (sdio_type *sdio_x, confirm_state new_state)
enable or disable sd i/o suspend command sending. More...

Detailed Description

contains all the functions for the sdio firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_sdio.c.


AT32F435/437 Firmwary Library: at32f435_437_spi.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_spi.c File Reference

contains all the functions for the spi firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

void | spi_i2s_reset (spi_type *spi_x)
spi reset by crm reset register More...
void | spi_default_para_init (spi_init_type *spi_init_struct)
spi init config with its default value. More...
void | spi_init (spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value. More...
void | spi_ti_mode_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the ti mode for the spi peripheral. More...
void | spi_crc_next_transmit (spi_type *spi_x)
spi next transmit crc for the spi peripheral. More...
void | spi_crc_polynomial_set (spi_type *spi_x, uint16_t crc_poly)
set the crc polynomial value for the spi peripheral. More...
uint16_t | spi_crc_polynomial_get (spi_type *spi_x)
return the crc polynomial register value for the spi peripheral. More...
void | spi_crc_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the hardware crc calculation for the spi peripheral. More...
uint16_t | spi_crc_value_get (spi_type *spi_x, spi_crc_direction_type crc_direction)
return the transmit or the receive crc value for the spi peripheral. More...
void | spi_hardware_cs_output_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the hardware cs output for the spi peripheral. More...
void | spi_software_cs_internal_level_set (spi_type *spi_x, spi_software_cs_level_type level)
set the software cs internal level for the spi peripheral. More...
void | spi_frame_bit_num_set (spi_type *spi_x, spi_frame_bit_num_type bit_num)
set the data frame bit num for the spi peripheral. More...
void | spi_half_duplex_direction_set (spi_type *spi_x, spi_half_duplex_direction_type direction)
set the data transmission direction in single line bidirectiona half duplex mode of the spi peripheral. More...
void | spi_enable (spi_type *spi_x, confirm_state new_state)
enable or disable spi. More...
void | i2s_default_para_init (i2s_init_type *i2s_init_struct)
i2s init config with its default value. More...
void | i2s_init (spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value. More...
void | i2s_enable (spi_type *spi_x, confirm_state new_state)
enable or disable i2s. More...
void | spi_i2s_interrupt_enable (spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts. More...
void | spi_i2s_dma_transmitter_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode. More...
void | spi_i2s_dma_receiver_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode. More...
void | spi_i2s_data_transmit (spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit More...
uint16_t | spi_i2s_data_receive (spi_type *spi_x)
spi/i2s data receive More...
flag_status | spi_i2s_flag_get (spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral. More...
void | spi_i2s_flag_clear (spi_type *spi_x, uint32_t spi_i2s_flag)
clear flag of the specified spi/i2s peripheral. More...

Detailed Description

contains all the functions for the spi firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_spi.c.


AT32F435/437 Firmwary Library: at32f435_437_tmr.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_tmr.c File Reference

contains all the functions for the tmr firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

void | tmr_reset (tmr_type *tmr_x)
tmr reset by crm reset register More...
void | tmr_counter_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter More...
void | tmr_output_default_para_init (tmr_output_config_type *tmr_output_struct)
init tmr output default para More...
void | tmr_input_default_para_init (tmr_input_config_type *tmr_input_struct)
init tmr input default para More...
void | tmr_brkdt_default_para_init (tmr_brkdt_config_type *tmr_brkdt_struct)
init tmr brkdt default para More...
void | tmr_base_init (tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base More...
void | tmr_clock_source_div_set (tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division More...
void | tmr_cnt_dir_set (tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction More...
void | tmr_repetition_counter_set (tmr_type *tmr_x, uint8_t tmr_rpr_value)
set the repetition counter register(rpr) value More...
void | tmr_counter_value_set (tmr_type *tmr_x, uint32_t tmr_cnt_value)
set tmr counter value More...
uint32_t | tmr_counter_value_get (tmr_type *tmr_x)
get tmr counter value More...
void | tmr_div_value_set (tmr_type *tmr_x, uint32_t tmr_div_value)
set tmr div value More...
uint32_t | tmr_div_value_get (tmr_type *tmr_x)
get tmr div value More...
void | tmr_output_channel_config (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel More...
void | tmr_output_channel_mode_select (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_control_mode_type oc_mode)
select tmr output channel mode More...
void | tmr_period_value_set (tmr_type *tmr_x, uint32_t tmr_pr_value)
set tmr period value More...
uint32_t | tmr_period_value_get (tmr_type *tmr_x)
get tmr period value More...
void | tmr_channel_value_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value More...
uint32_t | tmr_channel_value_get (tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value More...
void | tmr_period_buffer_enable (tmr_type *tmr_x, confirm_state new_state)
set tmr period buffer More...
void | tmr_output_channel_buffer_enable (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel buffer More...
void | tmr_output_channel_immediately_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel immediately More...
void | tmr_output_channel_switch_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel switch More...
void | tmr_one_cycle_mode_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr one cycle mode More...
void | tmr_32_bit_function_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode) More...
void | tmr_overflow_request_source_set (tmr_type *tmr_x, confirm_state new_state)
select tmr the overflow event sources More...
void | tmr_overflow_event_disable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr overflow event generation More...
void | tmr_input_channel_init (tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel More...
void | tmr_channel_enable (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable More...
void | tmr_input_channel_filter_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint16_t filter_value)
set tmr input channel filter More...
void | tmr_pwm_input_config (tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
config tmr pwm input More...
void | tmr_channel1_input_select (tmr_type *tmr_x, tmr_channel1_input_connected_type ch1_connect)
select tmr channel1 input More...
void | tmr_input_channel_divider_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_channel_input_divider_type divider_factor)
set tmr input channel divider More...
void | tmr_primary_mode_select (tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode More...
void | tmr_sub_mode_select (tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode More...
void | tmr_channel_dma_select (tmr_type *tmr_x, tmr_dma_request_source_type cc_dma_select)
select tmr channel dma More...
void | tmr_hall_select (tmr_type *tmr_x, confirm_state new_state)
select tmr hall More...
void | tmr_channel_buffer_enable (tmr_type *tmr_x, confirm_state new_state)
select tmr channel buffer More...
void | tmr_trgout2_enable (tmr_type *tmr_x, confirm_state new_state)
select tmr trgout2 More...
void | tmr_trigger_input_select (tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger More...
void | tmr_sub_sync_mode_set (tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode More...
void | tmr_dma_request_enable (tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request More...
void | tmr_interrupt_enable (tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt More...
flag_status | tmr_flag_get (tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag More...
void | tmr_flag_clear (tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag More...
void | tmr_event_sw_trigger (tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event More...
void | tmr_output_enable (tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable More...
void | tmr_internal_clock_set (tmr_type *tmr_x)
set tmr select internal clock More...
void | tmr_output_channel_polarity_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_polarity_active_type oc_polarity)
set tmr output channel polarity More...
void | tmr_external_clock_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock More...
void | tmr_external_clock_mode1_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode1 More...
void | tmr_external_clock_mode2_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode2 More...
void | tmr_encoder_mode_config (tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type ic1_polarity, tmr_input_polarity_type ic2_polarity)
config tmr encoder mode More...
void | tmr_force_output_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_force_output_type force_output)
set tmr force output More...
void | tmr_dma_control_config (tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, tmr_dma_address_type dma_base_address)
config tmr dma control More...
void | tmr_brkdt_config (tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
config tmr break mode and dead-time More...
void | tmr_iremap_config (tmr_type *tmr_x, tmr_input_remap_type input_remap)
set tmr2/tmr5 input channel remap More...

Detailed Description

contains all the functions for the tmr firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_tmr.c.


AT32F435/437 Firmwary Library: at32f435_437_usart.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_usart.c File Reference

contains all the functions for the usart firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

void | usart_reset (usart_type *usart_x)
deinitialize the usart peripheral registers to their default reset values. More...
void | usart_init (usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters. More...
void | usart_parity_selection_config (usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config. More...
void | usart_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral. More...
void | usart_transmitter_enable (usart_type *usart_x, confirm_state new_state)
usart transmitter enable. More...
void | usart_receiver_enable (usart_type *usart_x, confirm_state new_state)
usart receiver enable. More...
void | usart_clock_config (usart_type *usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
usart clock config. More...
void | usart_clock_enable (usart_type *usart_x, confirm_state new_state)
usart enable the ck pin. More...
void | usart_interrupt_enable (usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts. More...
void | usart_dma_transmitter_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface. More...
void | usart_dma_receiver_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma receiver interface. More...
void | usart_wakeup_id_set (usart_type *usart_x, uint8_t usart_id)
set the wakeup id of the usart. More...
void | usart_wakeup_mode_set (usart_type *usart_x, usart_wakeup_mode_type wakeup_mode)
select the usart wakeup method in multi-processor communication. More...
void | usart_receiver_mute_enable (usart_type *usart_x, confirm_state new_state)
config the usart in mute mode in multi-processor communication. More...
void | usart_break_bit_num_set (usart_type *usart_x, usart_break_bit_num_type break_bit)
set the usart break frame bit num. More...
void | usart_lin_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart lin mode. More...
void | usart_data_transmit (usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral. More...
uint16_t | usart_data_receive (usart_type *usart_x)
return the most recent received data by the usart peripheral. More...
void | usart_break_send (usart_type *usart_x)
transmit break characters. More...
void | usart_smartcard_guard_time_set (usart_type *usart_x, uint8_t guard_time_val)
config the specified usart smartcard guard time. More...
void | usart_irda_smartcard_division_set (usart_type *usart_x, uint8_t div_val)
config the irda/smartcard division. More...
void | usart_smartcard_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart smart card mode. More...
void | usart_smartcard_nack_set (usart_type *usart_x, confirm_state new_state)
enable or disable nack transmission in smartcard mode. More...
void | usart_single_line_halfduplex_select (usart_type *usart_x, confirm_state new_state)
enable or disable the usart single line bidirectional half-duplex communication. More...
void | usart_irda_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's irda interface. More...
void | usart_irda_low_power_enable (usart_type *usart_x, confirm_state new_state)
configure the usart's irda low power. More...
void | usart_hardware_flow_control_set (usart_type *usart_x, usart_hardware_flow_control_type flow_state)
configure the usart's hardware flow control. More...
flag_status | usart_flag_get (usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not. More...
void | usart_flag_clear (usart_type *usart_x, uint32_t flag)
clear the usart's pending flags. More...
void | usart_rs485_delay_time_config (usart_type *usart_x, uint8_t start_delay_time, uint8_t complete_delay_time)
configure the usart's rs485 transmit delay time. More...
void | usart_transmit_receive_pin_swap (usart_type *usart_x, confirm_state new_state)
swap the usart's transmit receive pin. More...
void | usart_id_bit_num_set (usart_type *usart_x, usart_identification_bit_num_type id_bit_num)
set the usart's identification bit num. More...
void | usart_de_polarity_set (usart_type *usart_x, usart_de_polarity_type de_polarity)
set the usart's de polarity. More...
void | usart_rs485_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's rs485 mode. More...

Detailed Description

contains all the functions for the usart firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_usart.c.


AT32F435/437 Firmwary Library: at32f435_437_usb.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_usb.c File Reference

contains all the functions for the usb firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

error_status | usb_global_reset (otg_global_type *usbx)
usb global core soft reset More...
void | usb_global_init (otg_global_type *usbx)
usb global initialization More...
otg_global_type * | usb_global_select_core (uint8_t usb_id)
usb global select usb core (otg1 or otg2). More...
void | usb_flush_tx_fifo (otg_global_type *usbx, uint32_t fifo_num)
flush tx fifo More...
void | usb_flush_rx_fifo (otg_global_type *usbx)
flush rx fifo More...
void | usb_global_interrupt_enable (otg_global_type *usbx, uint16_t interrupt, confirm_state new_state)
usb interrupt mask enable More...
uint32_t | usb_global_get_all_interrupt (otg_global_type *usbx)
get all global core interrupt flag More...
void | usb_global_clear_interrupt (otg_global_type *usbx, uint32_t flag)
clear the global interrupt flag More...
void | usb_interrupt_enable (otg_global_type *usbx)
usb global interrupt enable More...
void | usb_interrupt_disable (otg_global_type *usbx)
usb global interrupt disable More...
void | usb_set_rx_fifo (otg_global_type *usbx, uint16_t size)
usb set rx fifo size More...
void | usb_set_tx_fifo (otg_global_type *usbx, uint8_t txfifo, uint16_t size)
usb set tx fifo size More...
void | usb_global_set_mode (otg_global_type *usbx, uint32_t mode)
set otg mode(device or host mode) More...
void | usb_global_power_on (otg_global_type *usbx)
disable the transceiver power down mode More...
void | usb_stop_phy_clk (otg_global_type *usbx)
usb stop phy clock More...
void | usb_open_phy_clk (otg_global_type *usbx)
usb open phy clock More...
void | usb_write_packet (otg_global_type *usbx, uint8_t *pusr_buf, uint16_t num, uint16_t nbytes)
write data from user memory to usb buffer More...
void | usb_read_packet (otg_global_type *usbx, uint8_t *pusr_buf, uint16_t num, uint16_t nbytes)
read data from usb buffer to user buffer More...
void | usb_ept_open (otg_global_type *usbx, usb_ept_info *ept_info)
open usb endpoint More...
void | usb_ept_close (otg_global_type *usbx, usb_ept_info *ept_info)
close usb endpoint More...
void | usb_ept_stall (otg_global_type *usbx, usb_ept_info *ept_info)
set endpoint tx or rx status to stall More...
void | usb_ept_clear_stall (otg_global_type *usbx, usb_ept_info *ept_info)
clear endpoint tx or rx status to stall More...
uint32_t | usb_get_all_out_interrupt (otg_global_type *usbx)
get all out endpoint interrupt bits More...
uint32_t | usb_get_all_in_interrupt (otg_global_type *usbx)
get all in endpoint interrupt bits More...
uint32_t | usb_ept_out_interrupt (otg_global_type *usbx, uint32_t eptn)
get out endpoint interrupt flag More...
uint32_t | usb_ept_in_interrupt (otg_global_type *usbx, uint32_t eptn)
get in endpoint interrupt flag More...
void | usb_ept_out_clear (otg_global_type *usbx, uint32_t eptn, uint32_t flag)
clear out endpoint interrupt flag More...
void | usb_ept_in_clear (otg_global_type *usbx, uint32_t eptn, uint32_t flag)
clear in endpoint interrupt flag More...
void | usb_set_address (otg_global_type *usbx, uint8_t address)
set the host assignment address More...
void | usb_ept0_start (otg_global_type *usbx)
enable endpoint 0 out More...
void | usb_ept0_setup (otg_global_type *usbx)
endpoint 0 start setup More...
void | usb_connect (otg_global_type *usbx)
connect usb device by enable pull-up More...
void | usb_disconnect (otg_global_type *usbx)
disconnect usb device by disable pull-up More...
void | usb_remote_wkup_set (otg_global_type *usbx)
usb remote wakeup set More...
void | usb_remote_wkup_clear (otg_global_type *usbx)
usb remote wakeup clear More...
uint8_t | usb_suspend_status_get (otg_global_type *usbx)
usb suspend status get More...
void | usb_port_power_on (otg_global_type *usbx, confirm_state state)
usb port power on More...
uint32_t | usbh_get_frame (otg_global_type *usbx)
get current frame number More...
void | usb_hc_enable (otg_global_type *usbx, uint8_t chn, uint8_t ept_num, uint8_t dev_address, uint8_t type, uint16_t maxpacket, uint8_t speed)
enable one host channel More...
uint32_t | usb_hch_read_interrupt (otg_global_type *usbx)
host read channel interrupt More...
void | usb_host_disable (otg_global_type *usbx)
disable host More...
void | usb_hch_halt (otg_global_type *usbx, uint8_t chn)
halt channel More...
void | usbh_fsls_clksel (otg_global_type *usbx, uint8_t clk)
select full or low speed clock More...

Detailed Description

contains all the functions for the usb firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_usb.c.


AT32F435/437 Firmwary Library: at32f435_437_wdt.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_wdt.c File Reference

contains all the functions for the wdt firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

void | wdt_enable (void)
wdt enable ,the reload value will be sent to the counter More...
void | wdt_counter_reload (void)
reload wdt counter More...
void | wdt_reload_value_set (uint16_t reload_value)
set wdt counter reload value More...
void | wdt_divider_set (wdt_division_type division)
set wdt division divider More...
void | wdt_register_write_enable (confirm_state new_state)
enable or disable wdt cmd register write More...
flag_status | wdt_flag_get (uint16_t wdt_flag)
get wdt flag More...
void | wdt_window_counter_set (uint16_t window_cnt)
wdt window counter value set More...

Detailed Description

contains all the functions for the wdt firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_wdt.c.


AT32F435/437 Firmwary Library: at32f435_437_wwdt.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_wwdt.c File Reference

contains all the functions for the wwdt firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

void | wwdt_reset (void)
wwdt reset by crm reset register More...
void | wwdt_divider_set (wwdt_division_type division)
wwdt division set More...
void | wwdt_flag_clear (void)
wwdt reload counter interrupt flag clear More...
void | wwdt_enable (uint8_t wwdt_cnt)
wwdt enable and the counter value load More...
void | wwdt_interrupt_enable (void)
wwdt reload counter interrupt enable More...
flag_status | wwdt_flag_get (void)
wwdt reload counter interrupt flag get More...
void | wwdt_counter_set (uint8_t wwdt_cnt)
wwdt counter value set More...
void | wwdt_window_counter_set (uint8_t window_cnt)
wwdt window counter value set More...

Detailed Description

contains all the functions for the wwdt firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_wwdt.c.


AT32F435/437 Firmwary Library: at32f435_437_xmc.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f435_437_xmc.c File Reference

contains all the functions for the xmc firmware library More...

#include "at32f435_437_conf.h"

Go to the source code of this file.

Functions

void | xmc_nor_sram_reset (xmc_nor_sram_subbank_type xmc_subbank)
xmc nor or sram registers reset More...
void | xmc_nor_sram_init (xmc_norsram_init_type *xmc_norsram_init_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_norsraminitstruct. More...
void | xmc_nor_sram_timing_config (xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_rw_timing_struct and xmc_w_timing_struct. More...
void | xmc_norsram_default_para_init (xmc_norsram_init_type *xmc_nor_sram_init_struct)
fill each xmc_nor_sram_init_struct member with its default value. More...
void | xmc_norsram_timing_default_para_init (xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
fill each xmc_rw_timing_struct and xmc_w_timing_struct member with its default value. More...
void | xmc_nor_sram_enable (xmc_nor_sram_subbank_type xmc_subbank, confirm_state new_state)
enable or disable the specified nor/sram memory bank. More...
void | xmc_ext_timing_config (xmc_nor_sram_subbank_type xmc_sub_bank, uint16_t w2w_timing, uint16_t r2r_timing)
config the bus turnaround phase. More...
void | xmc_nand_reset (xmc_class_bank_type xmc_bank)
xmc nand flash registers reset More...
void | xmc_nand_init (xmc_nand_init_type *xmc_nand_init_struct)
initialize the xmc nand banks according to the specified parameters in the xmc_nandinitstruct. More...
void | xmc_nand_timing_config (xmc_nand_pccard_timinginit_type *xmc_regular_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_special_spacetiming_struct)
initialize the xmc nand banks according to the specified parameters in the xmc_nandinitstruct. More...
void | xmc_nand_default_para_init (xmc_nand_init_type *xmc_nand_init_struct)
fill each xmc_nand_init_struct member with its default value. More...
void | xmc_nand_timing_default_para_init (xmc_nand_pccard_timinginit_type *xmc_regular_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_special_spacetiming_struct)
fill each xmc_common_spacetiming_struct and xmc_attribute_spacetiming_struct member with its default value. More...
void | xmc_nand_enable (xmc_class_bank_type xmc_bank, confirm_state new_state)
enable or disable the specified nand memory bank. More...
void | xmc_nand_ecc_enable (xmc_class_bank_type xmc_bank, confirm_state new_state)
enable or disable the xmc nand ecc feature. More...
uint32_t | xmc_ecc_get (xmc_class_bank_type xmc_bank)
return the error correction code register value. More...
void | xmc_sdram_reset (xmc_sdram_bank_type xmc_bank)
xmc sdram registers reset More...
void | xmc_sdram_init (xmc_sdram_init_type *xmc_sdram_init_struct, xmc_sdram_timing_type *xmc_sdram_timing_struct)
initialize the xmc sdram banks according to the specified parameters in the xmc_sdram_init_struct and xmc_sdram_timing_struct. More...
void | xmc_sdram_default_para_init (xmc_sdram_init_type *xmc_sdram_init_struct, xmc_sdram_timing_type *xmc_sdram_timing_struct)
fill each xmc_sdram_init_struct member with its default value. More...
void | xmc_sdram_cmd (xmc_sdram_cmd_type *xmc_sdram_cmd_struct)
sdram command confg More...
uint32_t | xmc_sdram_status_get (xmc_sdram_bank_type xmc_bank)
get sdram bank status More...
void | xmc_sdram_refresh_counter_set (uint32_t counter)
set sdram refresh counter More...
void | xmc_sdram_auto_refresh_set (uint32_t number)
set sdram auto refresh number More...
void | xmc_interrupt_enable (xmc_class_bank_type xmc_bank, xmc_interrupt_sources_type xmc_int, confirm_state new_state)
enable or disable the specified xmc interrupts. More...
flag_status | xmc_flag_status_get (xmc_class_bank_type xmc_bank, xmc_interrupt_flag_type xmc_flag)
check whether the specified xmc flag is set or not. More...
void | xmc_flag_clear (xmc_class_bank_type xmc_bank, xmc_interrupt_flag_type xmc_flag)
clear the xmc's pending flags. More...
void | xmc_pccard_reset (void)
xmc pc card registers reset More...
void | xmc_pccard_init (xmc_pccard_init_type *xmc_pccard_init_struct)
initialize the xmc pccard bank according to the specified parameters in the xmc_pccard_init_struct. More...
void | xmc_pccard_timing_config (xmc_nand_pccard_timinginit_type *xmc_regular_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_special_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_iospace_timing_struct)
initialize the xmc pccard bank according to the specified parameters in the xmc_common_spacetiming_struct/xmc_attribute_spacetiming_struct and xmc_iospace_timing_struct. More...
void | xmc_pccard_default_para_init (xmc_pccard_init_type *xmc_pccard_init_struct)
fill each xmc_pccard_init_struct member with its default value. More...
void | xmc_pccard_timing_default_para_init (xmc_nand_pccard_timinginit_type *xmc_regular_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_special_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_iospace_timing_struct)
fill each xmc_common_spacetiming_struct/xmc_attribute_spacetiming_struct and xmc_iospace_timing_struct member with its default value. More...
void | xmc_pccard_enable (confirm_state new_state)
enable or disable the pccard memory bank. More...

Detailed Description

contains all the functions for the xmc firmware library

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_xmc.c.


AT32F435/437 Firmwary Library: main_page.h File Reference

  • main_page
main_page.h File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: i2c_application.c File Reference

  • middlewares
  • i2c_application_library
Macros | Functions
i2c_application.c File Reference

the driver library of the i2c peripheral More...

#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | DMA_GET_REQUEST(DMA_CHANNEL) (((uint32_t)(DMA_CHANNEL) == ((uint32_t)hi2c->dma_tx_channel)) ? I2C_DMA_REQUEST_TX : I2C_DMA_REQUEST_RX)
get the dma transfer direction flag through the channel More...
#define | DMA_GET_TC_FLAG(DMA_CHANNEL)
get the dma transfer complete flag through the channel More...
#define | DMA_GET_HT_FLAG(DMA_CHANNEL)
get the dma half transfer flag through the channel More...
#define | DMA_GET_TERR_FLAG(DMA_CHANNEL)
get the dma transfer error flag through the channel More...
#define | I2C_START 0
i2c transmission status More...
#define | I2C_END 1

Functions

__WEAK void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | i2c_config (i2c_handle_type *hi2c)
i2c peripheral initialization. More...
void | i2c_refresh_txdt_register (i2c_handle_type *hi2c)
refresh i2c register. More...
void | i2c_reset_ctrl2_register (i2c_handle_type *hi2c)
reset ctrl2 register. More...
i2c_status_type | i2c_wait_end (i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end. More...
i2c_status_type | i2c_wait_flag (i2c_handle_type *hi2c, uint32_t flag, uint32_t event_check, uint32_t timeout)
wait for the flag to be set or reset, only BUSYF flag is waiting to be reset, and other flags are waiting to be set More...
void | i2c_dma_config (i2c_handle_type *hi2c, dma_channel_type *dma_channel, uint8_t *pdata, uint16_t size)
dma transfer cofiguration. More...
void | i2c_start_transfer (i2c_handle_type *hi2c, uint16_t address, i2c_start_mode_type start)
start transfer in poll mode or interrupt mode. More...
void | i2c_start_transfer_dma (i2c_handle_type *hi2c, dma_channel_type *dma_channelx, uint16_t address, i2c_start_mode_type start)
start transfer in dma mode. More...
i2c_status_type | i2c_master_transmit (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode. More...
i2c_status_type | i2c_slave_receive (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through polling mode. More...
i2c_status_type | i2c_master_receive (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through polling mode. More...
i2c_status_type | i2c_slave_transmit (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through polling mode. More...
i2c_status_type | i2c_master_transmit_int (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through interrupt mode. More...
i2c_status_type | i2c_slave_receive_int (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through interrupt mode. More...
i2c_status_type | i2c_master_receive_int (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through interrupt mode. More...
i2c_status_type | i2c_slave_transmit_int (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through interrupt mode. More...
i2c_status_type | i2c_master_transmit_dma (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through dma mode. More...
i2c_status_type | i2c_slave_receive_dma (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through dma mode. More...
i2c_status_type | i2c_master_receive_dma (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through dma mode. More...
i2c_status_type | i2c_slave_transmit_dma (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through dma mode. More...
i2c_status_type | i2c_memory_write (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through polling mode. More...
i2c_status_type | i2c_memory_read (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode. More...
i2c_status_type | i2c_memory_write_int (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through interrupt mode. More...
i2c_status_type | i2c_memory_read_int (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through interrupt mode. More...
i2c_status_type | i2c_memory_write_dma (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through dma mode. More...
i2c_status_type | i2c_memory_read_dma (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode. More...
i2c_status_type | i2c_smbus_master_transmit (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through SMBus mode. More...
i2c_status_type | i2c_smbus_slave_receive (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through SMBus mode. More...
i2c_status_type | i2c_smbus_master_receive (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through SMBus mode. More...
i2c_status_type | i2c_smbus_slave_transmit (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through SMBus mode. More...
i2c_status_type | i2c_master_irq_handler_int (i2c_handle_type *hi2c)
master interrupt processing function in interrupt mode. More...
i2c_status_type | i2c_slave_irq_handler_int (i2c_handle_type *hi2c)
slave interrupt processing function in interrupt mode. More...
i2c_status_type | i2c_master_irq_handler_dma (i2c_handle_type *hi2c)
master interrupt processing function in dma mode. More...
i2c_status_type | i2c_slave_irq_handler_dma (i2c_handle_type *hi2c)
slave interrupt processing function in dma mode. More...
void | i2c_dma_tx_rx_irq_handler (i2c_handle_type *hi2c, dma_channel_type *dma_channel)
dma processing function. More...
void | i2c_dma_tx_irq_handler (i2c_handle_type *hi2c)
dma transmission complete interrupt function. More...
void | i2c_dma_rx_irq_handler (i2c_handle_type *hi2c)
dma reveive complete interrupt function. More...
void | i2c_evt_irq_handler (i2c_handle_type *hi2c)
interrupt procession function. More...
void | i2c_err_irq_handler (i2c_handle_type *hi2c)
dma reveive complete interrupt function. More...

Detailed Description

the driver library of the i2c peripheral

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file i2c_application.c.

Macro Definition Documentation

◆ DMA_GET_HT_FLAG

#define DMA_GET_HT_FLAG ( DMA_CHANNEL )
Value:
(((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL1))? DMA1_HDT1_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL2))? DMA1_HDT2_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL3))? DMA1_HDT3_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL4))? DMA1_HDT4_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL5))? DMA1_HDT5_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL6))? DMA1_HDT6_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL7))? DMA1_HDT7_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL1))? DMA2_HDT1_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL2))? DMA2_HDT2_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL3))? DMA2_HDT3_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL4))? DMA2_HDT4_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL5))? DMA2_HDT5_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL6))? DMA2_HDT6_FLAG : \
DMA2_HDT7_FLAG)
DMA1_HDT5_FLAG
#define DMA1_HDT5_FLAG
Definition: at32f435_437_dma.h:83
DMA2_HDT6_FLAG
#define DMA2_HDT6_FLAG
Definition: at32f435_437_dma.h:116
DMA1_HDT7_FLAG
#define DMA1_HDT7_FLAG
Definition: at32f435_437_dma.h:91
DMA2_HDT3_FLAG
#define DMA2_HDT3_FLAG
Definition: at32f435_437_dma.h:104
DMA1_HDT4_FLAG
#define DMA1_HDT4_FLAG
Definition: at32f435_437_dma.h:79
DMA2_HDT5_FLAG
#define DMA2_HDT5_FLAG
Definition: at32f435_437_dma.h:112
DMA1_HDT3_FLAG
#define DMA1_HDT3_FLAG
Definition: at32f435_437_dma.h:75
DMA2_HDT1_FLAG
#define DMA2_HDT1_FLAG
Definition: at32f435_437_dma.h:96
DMA2_HDT2_FLAG
#define DMA2_HDT2_FLAG
Definition: at32f435_437_dma.h:100
DMA1_HDT1_FLAG
#define DMA1_HDT1_FLAG
Definition: at32f435_437_dma.h:67
DMA2_HDT4_FLAG
#define DMA2_HDT4_FLAG
Definition: at32f435_437_dma.h:108
DMA2_HDT7_FLAG
#define DMA2_HDT7_FLAG
Definition: at32f435_437_dma.h:120
DMA1_HDT2_FLAG
#define DMA1_HDT2_FLAG
Definition: at32f435_437_dma.h:71
DMA1_HDT6_FLAG
#define DMA1_HDT6_FLAG
Definition: at32f435_437_dma.h:87
DMA2_CHANNEL5
#define DMA2_CHANNEL5
Definition: at32f435_437_dma.h:722
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f435_437_dma.h:698
DMA1_CHANNEL5
#define DMA1_CHANNEL5
Definition: at32f435_437_dma.h:700
DMA2_CHANNEL2
#define DMA2_CHANNEL2
Definition: at32f435_437_dma.h:719
DMA2_CHANNEL3
#define DMA2_CHANNEL3
Definition: at32f435_437_dma.h:720
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f435_437_dma.h:699
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA2_CHANNEL6
#define DMA2_CHANNEL6
Definition: at32f435_437_dma.h:723
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f435_437_dma.h:697
DMA2_CHANNEL4
#define DMA2_CHANNEL4
Definition: at32f435_437_dma.h:721
DMA2_CHANNEL1
#define DMA2_CHANNEL1
Definition: at32f435_437_dma.h:718
DMA1_CHANNEL6
#define DMA1_CHANNEL6
Definition: at32f435_437_dma.h:701
DMA1_CHANNEL7
#define DMA1_CHANNEL7
Definition: at32f435_437_dma.h:702

get the dma half transfer flag through the channel

Definition at line 57 of file i2c_application.c.

◆ DMA_GET_REQUEST

#define DMA_GET_REQUEST ( DMA_CHANNEL ) (((uint32_t)(DMA_CHANNEL) == ((uint32_t)hi2c->dma_tx_channel)) ? I2C_DMA_REQUEST_TX : I2C_DMA_REQUEST_RX)

get the dma transfer direction flag through the channel

Definition at line 32 of file i2c_application.c.

◆ DMA_GET_TC_FLAG

#define DMA_GET_TC_FLAG ( DMA_CHANNEL )
Value:
(((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL1))? DMA1_FDT1_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL2))? DMA1_FDT2_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL3))? DMA1_FDT3_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL4))? DMA1_FDT4_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL5))? DMA1_FDT5_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL6))? DMA1_FDT6_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL7))? DMA1_FDT7_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL1))? DMA2_FDT1_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL2))? DMA2_FDT2_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL3))? DMA2_FDT3_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL4))? DMA2_FDT4_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL5))? DMA2_FDT5_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL6))? DMA2_FDT6_FLAG : \
DMA2_FDT7_FLAG)
DMA1_FDT7_FLAG
#define DMA1_FDT7_FLAG
Definition: at32f435_437_dma.h:90
DMA2_FDT7_FLAG
#define DMA2_FDT7_FLAG
Definition: at32f435_437_dma.h:119
DMA2_FDT4_FLAG
#define DMA2_FDT4_FLAG
Definition: at32f435_437_dma.h:107
DMA2_FDT6_FLAG
#define DMA2_FDT6_FLAG
Definition: at32f435_437_dma.h:115
DMA2_FDT2_FLAG
#define DMA2_FDT2_FLAG
Definition: at32f435_437_dma.h:99
DMA1_FDT4_FLAG
#define DMA1_FDT4_FLAG
Definition: at32f435_437_dma.h:78
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f435_437_dma.h:66
DMA1_FDT6_FLAG
#define DMA1_FDT6_FLAG
Definition: at32f435_437_dma.h:86
DMA2_FDT5_FLAG
#define DMA2_FDT5_FLAG
Definition: at32f435_437_dma.h:111
DMA2_FDT1_FLAG
#define DMA2_FDT1_FLAG
Definition: at32f435_437_dma.h:95
DMA2_FDT3_FLAG
#define DMA2_FDT3_FLAG
Definition: at32f435_437_dma.h:103
DMA1_FDT5_FLAG
#define DMA1_FDT5_FLAG
Definition: at32f435_437_dma.h:82
DMA1_FDT2_FLAG
#define DMA1_FDT2_FLAG
Definition: at32f435_437_dma.h:70
DMA1_FDT3_FLAG
#define DMA1_FDT3_FLAG
Definition: at32f435_437_dma.h:74

get the dma transfer complete flag through the channel

Definition at line 38 of file i2c_application.c.

◆ DMA_GET_TERR_FLAG

#define DMA_GET_TERR_FLAG ( DMA_CHANNEL )
Value:
(((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL1))? DMA1_DTERR1_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL2))? DMA1_DTERR2_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL3))? DMA1_DTERR3_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL4))? DMA1_DTERR4_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL5))? DMA1_DTERR5_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL6))? DMA1_DTERR6_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL7))? DMA1_DTERR7_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL1))? DMA2_DTERR1_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL2))? DMA2_DTERR2_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL3))? DMA2_DTERR3_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL4))? DMA2_DTERR4_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL5))? DMA2_DTERR5_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL6))? DMA2_DTERR6_FLAG : \
DMA2_DTERR7_FLAG)
DMA1_DTERR7_FLAG
#define DMA1_DTERR7_FLAG
Definition: at32f435_437_dma.h:92
DMA1_DTERR3_FLAG
#define DMA1_DTERR3_FLAG
Definition: at32f435_437_dma.h:76
DMA2_DTERR4_FLAG
#define DMA2_DTERR4_FLAG
Definition: at32f435_437_dma.h:109
DMA2_DTERR7_FLAG
#define DMA2_DTERR7_FLAG
Definition: at32f435_437_dma.h:121
DMA1_DTERR1_FLAG
#define DMA1_DTERR1_FLAG
Definition: at32f435_437_dma.h:68
DMA1_DTERR4_FLAG
#define DMA1_DTERR4_FLAG
Definition: at32f435_437_dma.h:80
DMA2_DTERR6_FLAG
#define DMA2_DTERR6_FLAG
Definition: at32f435_437_dma.h:117
DMA1_DTERR6_FLAG
#define DMA1_DTERR6_FLAG
Definition: at32f435_437_dma.h:88
DMA1_DTERR5_FLAG
#define DMA1_DTERR5_FLAG
Definition: at32f435_437_dma.h:84
DMA1_DTERR2_FLAG
#define DMA1_DTERR2_FLAG
Definition: at32f435_437_dma.h:72
DMA2_DTERR3_FLAG
#define DMA2_DTERR3_FLAG
Definition: at32f435_437_dma.h:105
DMA2_DTERR5_FLAG
#define DMA2_DTERR5_FLAG
Definition: at32f435_437_dma.h:113
DMA2_DTERR1_FLAG
#define DMA2_DTERR1_FLAG
Definition: at32f435_437_dma.h:97
DMA2_DTERR2_FLAG
#define DMA2_DTERR2_FLAG
Definition: at32f435_437_dma.h:101

get the dma transfer error flag through the channel

Definition at line 76 of file i2c_application.c.

◆ I2C_END

#define I2C_END 1

Definition at line 96 of file i2c_application.c.

◆ I2C_START

#define I2C_START 0

i2c transmission status

Definition at line 95 of file i2c_application.c.

Function Documentation

◆ i2c_dma_config()

void i2c_dma_config | ( | i2c_handle_type * | hi2c,
 |  | dma_channel_type * | dma_channel,
 |  | uint8_t * | pdata,
 |  | uint16_t | size
 | ) |  |

dma transfer cofiguration.

Parameters
hi2c | the handle points to the operation information.
dma_channelx | dma channel to be cofigured.
pdata | data buffer.
size | data size.
Return values
none.

< dma full data transfer interrupt

< dma full data transfer interrupt

Definition at line 284 of file i2c_application.c.

Referenced by i2c_dma_tx_rx_irq_handler(), i2c_slave_receive_dma(), i2c_slave_transmit_dma(), and i2c_start_transfer_dma().

◆ i2c_dma_tx_rx_irq_handler()

void i2c_dma_tx_rx_irq_handler | ( | i2c_handle_type * | hi2c,
 |  | dma_channel_type * | dma_channel
 | ) |  |

dma processing function.

Parameters
hi2c the handle points to the operation information.
Return values
none.

< dma1 channel1 full data transfer flag

< dma1 channel2 full data transfer flag

< dma1 channel3 full data transfer flag

< dma1 channel4 full data transfer flag

< dma1 channel5 full data transfer flag

< dma1 channel6 full data transfer flag

< dma1 channel7 full data transfer flag

< dma2 channel1 full data transfer flag

< dma2 channel2 full data transfer flag

< dma2 channel3 full data transfer flag

< dma2 channel4 full data transfer flag

< dma2 channel5 full data transfer flag

< dma2 channel6 full data transfer flag

< dma2 channel7 full data transfer flag

< dma full data transfer interrupt

< dma1 channel1 full data transfer flag

< dma1 channel2 full data transfer flag

< dma1 channel3 full data transfer flag

< dma1 channel4 full data transfer flag

< dma1 channel5 full data transfer flag

< dma1 channel6 full data transfer flag

< dma1 channel7 full data transfer flag

< dma2 channel1 full data transfer flag

< dma2 channel2 full data transfer flag

< dma2 channel3 full data transfer flag

< dma2 channel4 full data transfer flag

< dma2 channel5 full data transfer flag

< dma2 channel6 full data transfer flag

< dma2 channel7 full data transfer flag

< i2c stop detect interrupt

< maximum number of single transfers

< maximum number of single transfers

< i2c transmit data complete interrupt

Definition at line 2050 of file i2c_application.c.

Referenced by i2c_dma_rx_irq_handler(), and i2c_dma_tx_irq_handler().

◆ i2c_master_irq_handler_dma()

i2c_status_type i2c_master_irq_handler_dma ( i2c_handle_type * hi2c )

master interrupt processing function in dma mode.

Parameters
hi2c the handle points to the operation information.
Return values
i2c status.

< i2c acknowledge failure flag

< i2c acknowledge failure flag

< i2c stop detect interrupt

< i2c transmission is complete, waiting to load data

< i2c transmit data complete interrupt

< i2c stop condition generation complete flag

< i2c stop condition generation complete flag

< i2c acknowledge failure flag

< i2c acknowledge failure flag

< i2c bus error interrupt

< i2c transmit data complete interrupt

< i2c stop detect interrupt

< i2c ack fail interrupt

< i2c transmit data interrupt

< i2c receive data interrupt

Definition at line 1924 of file i2c_application.c.

Referenced by i2c_evt_irq_handler().

◆ i2c_master_irq_handler_int()

i2c_status_type i2c_master_irq_handler_int ( i2c_handle_type * hi2c )

master interrupt processing function in interrupt mode.

Parameters
hi2c the handle points to the operation information.
Return values
i2c status.

< i2c acknowledge failure flag

< i2c acknowledge failure flag

< i2c send interrupt status

< i2c transmission is complete, waiting to load data

< i2c receive data buffer full flag

< i2c transmit data complete flag

< i2c stop condition generation complete flag

< i2c stop condition generation complete flag

< i2c acknowledge failure flag

< i2c acknowledge failure flag

< i2c bus error interrupt

< i2c transmit data complete interrupt

< i2c stop detect interrupt

< i2c ack fail interrupt

< i2c transmit data interrupt

< i2c receive data interrupt

Definition at line 1753 of file i2c_application.c.

Referenced by i2c_evt_irq_handler().

◆ i2c_refresh_txdt_register()

void i2c_refresh_txdt_register ( i2c_handle_type * hi2c )

refresh i2c register.

Parameters
hi2c the handle points to the operation information.
Return values
none.

< i2c send interrupt status

< i2c transmit data buffer empty flag

Definition at line 130 of file i2c_application.c.

Referenced by i2c_master_irq_handler_dma(), i2c_master_irq_handler_int(), i2c_slave_irq_handler_dma(), i2c_slave_irq_handler_int(), i2c_slave_transmit(), i2c_slave_transmit_int(), and i2c_smbus_slave_transmit().

◆ i2c_slave_irq_handler_dma()

i2c_status_type i2c_slave_irq_handler_dma ( i2c_handle_type * hi2c )

slave interrupt processing function in dma mode.

Parameters
hi2c the handle points to the operation information.
Return values
i2c status.

< i2c acknowledge failure flag

< i2c acknowledge failure flag

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< i2c stop condition generation complete flag

< i2c stop condition generation complete flag

< i2c address match interrupt

< i2c stop detect interrupt

< i2c ack fail interrupt

< i2c bus error interrupt

< i2c transmit data complete interrupt

< i2c transmit data interrupt

< i2c receive data interrupt

< i2c receive data buffer full flag

Definition at line 1999 of file i2c_application.c.

Referenced by i2c_evt_irq_handler().

◆ i2c_slave_irq_handler_int()

i2c_status_type i2c_slave_irq_handler_int ( i2c_handle_type * hi2c )

slave interrupt processing function in interrupt mode.

Parameters
hi2c the handle points to the operation information.
Return values
i2c status.

< i2c acknowledge failure flag

< i2c acknowledge failure flag

< i2c acknowledge failure flag

< i2c 0~7 bit address match flag

< i2c 0~7 bit address match flag

< i2c send interrupt status

< i2c receive data buffer full flag

< i2c stop condition generation complete flag

< i2c stop condition generation complete flag

< i2c address match interrupt

< i2c stop detect interrupt

< i2c ack fail interrupt

< i2c bus error interrupt

< i2c transmit data complete interrupt

< i2c transmit data interrupt

< i2c receive data interrupt

< i2c receive data buffer full flag

Definition at line 1841 of file i2c_application.c.

Referenced by i2c_evt_irq_handler().

◆ i2c_start_transfer()

void i2c_start_transfer | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | i2c_start_mode_type | start
 | ) |  |

start transfer in poll mode or interrupt mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
start config gen start condition mode. parameter as following values:
  • I2C_WITHOUT_START: transfer data without start condition.
  • I2C_GEN_START_READ: read data and generate start.
  • I2C_GEN_START_WRITE: send data and generate start.
Return values
i2c status.

< maximum number of single transfers

< maximum number of single transfers

Definition at line 317 of file i2c_application.c.

Referenced by i2c_master_irq_handler_dma(), i2c_master_irq_handler_int(), i2c_master_receive(), i2c_master_receive_int(), i2c_master_transmit(), i2c_master_transmit_int(), i2c_memory_read(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_int(), i2c_smbus_master_receive(), and i2c_smbus_master_transmit().

◆ i2c_start_transfer_dma()

void i2c_start_transfer_dma | ( | i2c_handle_type * | hi2c,
 |  | dma_channel_type * | dma_channelx,
 |  | uint16_t | address,
 |  | i2c_start_mode_type | start
 | ) |  |

start transfer in dma mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
start config gen start condition mode. parameter as following values:
  • I2C_WITHOUT_START: transfer data without start condition.
  • I2C_GEN_START_READ: read data and generate start.
  • I2C_GEN_START_WRITE: send data and generate start.
Return values
i2c status.

< maximum number of single transfers

< maximum number of single transfers

Definition at line 344 of file i2c_application.c.

Referenced by i2c_master_receive_dma(), i2c_master_transmit_dma(), i2c_memory_read_dma(), and i2c_memory_write_dma().


AT32F435/437 Firmwary Library: i2c_application.h File Reference

  • middlewares
  • i2c_application_library
Data Structures | Macros | Enumerations | Functions
i2c_application.h File Reference

i2c application libray header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct i2c_handle_type

Macros

#define | I2C_EVENT_CHECK_NONE ((uint32_t)0x00000000)
#define | I2C_EVENT_CHECK_ACKFAIL ((uint32_t)0x00000001)
#define | I2C_EVENT_CHECK_STOP ((uint32_t)0x00000002)

Enumerations

enum i2c_mode_type {
I2C_INT_MA_TX = 0 , I2C_INT_MA_RX , I2C_INT_SLA_TX , I2C_INT_SLA_RX ,
I2C_DMA_MA_TX , I2C_DMA_MA_RX , I2C_DMA_SLA_TX , I2C_DMA_SLA_RX
}
enum i2c_status_type {
I2C_OK = 0 , I2C_ERR_STEP_1 , I2C_ERR_STEP_2 , I2C_ERR_STEP_3 ,
I2C_ERR_STEP_4 , I2C_ERR_STEP_5 , I2C_ERR_STEP_6 , I2C_ERR_STEP_7 ,
I2C_ERR_STEP_8 , I2C_ERR_STEP_9 , I2C_ERR_STEP_10 , I2C_ERR_STEP_11 ,
I2C_ERR_STEP_12 , I2C_ERR_TCRLD , I2C_ERR_TDC , I2C_ERR_ADDR ,
I2C_ERR_STOP , I2C_ERR_ACKFAIL , I2C_ERR_TIMEOUT , I2C_ERR_INTERRUPT
}

Functions

void | i2c_config (i2c_handle_type *hi2c)
i2c peripheral initialization. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | i2c_reset_ctrl2_register (i2c_handle_type *hi2c)
reset ctrl2 register. More...
i2c_status_type | i2c_wait_end (i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end. More...
i2c_status_type | i2c_wait_flag (i2c_handle_type *hi2c, uint32_t flag, uint32_t event_check, uint32_t timeout)
wait for the flag to be set or reset, only BUSYF flag is waiting to be reset, and other flags are waiting to be set More...
i2c_status_type | i2c_master_transmit (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode. More...
i2c_status_type | i2c_master_receive (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through polling mode. More...
i2c_status_type | i2c_slave_transmit (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through polling mode. More...
i2c_status_type | i2c_slave_receive (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through polling mode. More...
i2c_status_type | i2c_master_transmit_int (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through interrupt mode. More...
i2c_status_type | i2c_master_receive_int (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through interrupt mode. More...
i2c_status_type | i2c_slave_transmit_int (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through interrupt mode. More...
i2c_status_type | i2c_slave_receive_int (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through interrupt mode. More...
i2c_status_type | i2c_master_transmit_dma (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through dma mode. More...
i2c_status_type | i2c_master_receive_dma (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through dma mode. More...
i2c_status_type | i2c_slave_transmit_dma (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through dma mode. More...
i2c_status_type | i2c_slave_receive_dma (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through dma mode. More...
i2c_status_type | i2c_smbus_master_transmit (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through SMBus mode. More...
i2c_status_type | i2c_smbus_master_receive (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through SMBus mode. More...
i2c_status_type | i2c_smbus_slave_transmit (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through SMBus mode. More...
i2c_status_type | i2c_smbus_slave_receive (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through SMBus mode. More...
i2c_status_type | i2c_memory_write (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through polling mode. More...
i2c_status_type | i2c_memory_write_int (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through interrupt mode. More...
i2c_status_type | i2c_memory_write_dma (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through dma mode. More...
i2c_status_type | i2c_memory_read (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode. More...
i2c_status_type | i2c_memory_read_int (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through interrupt mode. More...
i2c_status_type | i2c_memory_read_dma (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode. More...
void | i2c_evt_irq_handler (i2c_handle_type *hi2c)
interrupt procession function. More...
void | i2c_err_irq_handler (i2c_handle_type *hi2c)
dma reveive complete interrupt function. More...
void | i2c_dma_tx_irq_handler (i2c_handle_type *hi2c)
dma transmission complete interrupt function. More...
void | i2c_dma_rx_irq_handler (i2c_handle_type *hi2c)
dma reveive complete interrupt function. More...

Detailed Description

i2c application libray header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file i2c_application.h.


AT32F435/437 Firmwary Library: usb_core.h File Reference

  • middlewares
  • usb_drivers
  • inc
Data Structures | Enumerations | Functions
usb_core.h File Reference

usb core header file More...

#include "usb_std.h"
#include "usb_conf.h"

Go to the source code of this file.

Data Structures

struct | usb_core_cfg
usb core cofig struct More...
struct | otg_core_type
usb otg core struct type More...

Enumerations

enum usb_speed_type { USB_LOW_SPEED_CORE_ID , USB_FULL_SPEED_CORE_ID , USB_HIGH_SPEED_CORE_ID }
usb core speed select More...

Functions

usb_sts_type usb_core_config (otg_core_type *otgdev, uint8_t core_id)
usb core config More...

Detailed Description

usb core header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usb_core.h.


AT32F435/437 Firmwary Library: usb_std.h File Reference

  • middlewares
  • usb_drivers
  • inc
Data Structures | Macros | Enumerations
usb_std.h File Reference

usb standard header file More...

#include "usb_conf.h"

Go to the source code of this file.

Data Structures

struct | linecoding_type
usb cdc class set line coding struct More...
struct | usb_setup_type
format of usb setup data More...
struct | usb_device_desc_type
format of standard device descriptor More...
struct | usb_configuration_desc_type
format of standard configuration descriptor More...
struct | usb_interface_desc_type
format of standard interface descriptor More...
struct | usb_endpoint_desc_type
format of standard endpoint descriptor More...
struct | usb_header_desc_type
format of header More...

Macros

#define | USB_REQ_RECIPIENT_DEVICE 0x00
usb request recipient More...
#define | USB_REQ_RECIPIENT_INTERFACE 0x01
#define | USB_REQ_RECIPIENT_ENDPOINT 0x02
#define | USB_REQ_RECIPIENT_OTHER 0x03
#define | USB_REQ_RECIPIENT_MASK 0x1F
#define | USB_REQ_TYPE_STANDARD 0x00
usb request type More...
#define | USB_REQ_TYPE_CLASS 0x20
#define | USB_REQ_TYPE_VENDOR 0x40
#define | USB_REQ_TYPE_RESERVED 0x60
#define | USB_REQ_DIR_HTD 0x00
usb request data transfer direction More...
#define | USB_REQ_DIR_DTH 0x80
#define | USB_STD_REQ_GET_STATUS 0
usb standard device requests codes More...
#define | USB_STD_REQ_CLEAR_FEATURE 1
#define | USB_STD_REQ_SET_FEATURE 3
#define | USB_STD_REQ_SET_ADDRESS 5
#define | USB_STD_REQ_GET_DESCRIPTOR 6
#define | USB_STD_REQ_SET_DESCRIPTOR 7
#define | USB_STD_REQ_GET_CONFIGURATION 8
#define | USB_STD_REQ_SET_CONFIGURATION 9
#define | USB_STD_REQ_GET_INTERFACE 10
#define | USB_STD_REQ_SET_INTERFACE 11
#define | USB_STD_REQ_SYNCH_FRAME 12
#define | USB_DESCIPTOR_TYPE_DEVICE 1
usb standard device type More...
#define | USB_DESCIPTOR_TYPE_CONFIGURATION 2
#define | USB_DESCIPTOR_TYPE_STRING 3
#define | USB_DESCIPTOR_TYPE_INTERFACE 4
#define | USB_DESCIPTOR_TYPE_ENDPOINT 5
#define | USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER 6
#define | USB_DESCIPTOR_TYPE_OTHER_SPEED 7
#define | USB_DESCIPTOR_TYPE_INTERFACE_POWER 8
#define | USB_LANGID_STRING 0
usb standard string type More...
#define | USB_MFC_STRING 1
#define | USB_PRODUCT_STRING 2
#define | USB_SERIAL_STRING 3
#define | USB_CONFIG_STRING 4
#define | USB_INTERFACE_STRING 5
#define | USB_CONF_REMOTE_WAKEUP 2
usb configuration attributes More...
#define | USB_CONF_SELF_POWERED 1
#define | USB_FEATURE_EPT_HALT 0
usb standard feature selectors More...
#define | USB_FEATURE_REMOTE_WAKEUP 1
#define | USB_FEATURE_TEST_MODE 2
#define | USB_EPT0_IDLE 0
endpoint 0 state More...
#define | USB_EPT0_SETUP 1
#define | USB_EPT0_DATA_IN 2
#define | USB_EPT0_DATA_OUT 3
#define | USB_EPT0_STATUS_IN 4
#define | USB_EPT0_STATUS_OUT 5
#define | USB_EPT0_STALL 6
#define | USB_DEVICE_QUALIFIER_DESC_LEN 0x0A
usb descriptor length More...
#define | USB_DEVICE_DESC_LEN 0x12
#define | USB_DEVICE_CFG_DESC_LEN 0x09
#define | USB_DEVICE_IF_DESC_LEN 0x09
#define | USB_DEVICE_EPT_LEN 0x07
#define | USB_DEVICE_OTG_DESC_LEN 0x03
#define | USB_DEVICE_LANGID_STR_DESC_LEN 0x04
#define | USB_DEVICE_OTHER_SPEED_DESC_SIZ_LEN 0x09
#define | USB_CLASS_CODE_AUDIO 0x01
usb class code More...
#define | USB_CLASS_CODE_CDC 0x02
#define | USB_CLASS_CODE_HID 0x03
#define | USB_CLASS_CODE_PRINTER 0x07
#define | USB_CLASS_CODE_MSC 0x08
#define | USB_CLASS_CODE_HUB 0x09
#define | USB_CLASS_CODE_CDCDATA 0x0A
#define | USB_CLASS_CODE_CCID 0x0B
#define | USB_CLASS_CODE_VIDEO 0x0E
#define | USB_CLASS_CODE_VENDOR 0xFF
#define | USB_EPT_DESC_CONTROL 0x00
usb endpoint type More...
#define | USB_EPT_DESC_ISO 0x01
#define | USB_EPT_DESC_BULK 0x02
#define | USB_EPT_DESC_INTERRUPT 0x03
#define | USB_EPT_DESC_NSYNC 0x00
#define | USB_ETP_DESC_ASYNC 0x04
#define | USB_ETP_DESC_ADAPTIVE 0x08
#define | USB_ETP_DESC_SYNC 0x0C
#define | USB_EPT_DESC_DATA_EPT 0x00
#define | USB_EPT_DESC_FD_EPT 0x10
#define | USB_EPT_DESC_FDDATA_EPT 0x20
#define | USBD_CDC_CS_INTERFACE 0x24
usb cdc class descriptor define More...
#define | USBD_CDC_CS_ENDPOINT 0x25
#define | USBD_CDC_SUBTYPE_HEADER 0x00
usb cdc class sub-type define More...
#define | USBD_CDC_SUBTYPE_CMF 0x01
#define | USBD_CDC_SUBTYPE_ACM 0x02
#define | USBD_CDC_SUBTYPE_UFD 0x06
#define | SET_LINE_CODING 0x20
usb cdc class request code define More...
#define | GET_LINE_CODING 0x21
#define | HID_CLASS_DESC_HID 0x21
usb hid class descriptor define More...
#define | HID_CLASS_DESC_REPORT 0x22
#define | HID_CLASS_DESC_PHYSICAL 0x23
#define | HID_REQ_SET_PROTOCOL 0x0B
usb hid class request code define More...
#define | HID_REQ_GET_PROTOCOL 0x03
#define | HID_REQ_SET_IDLE 0x0A
#define | HID_REQ_GET_IDLE 0x02
#define | HID_REQ_SET_REPORT 0x09
#define | HID_REQ_GET_REPORT 0x01
#define | HID_DESCRIPTOR_TYPE 0x21
#define | HID_REPORT_DESC 0x22
#define | USB_MAX_EP0_SIZE 64
endpoint 0 max size More...
#define | SWAPBYTE(addr)
usb swap address More...
#define | MIN(a, b) (uint16_t)(((a) < (b)) ? (a) : (b))
min and max define More...
#define | MAX(a, b) (uint16_t)(((a) > (b)) ? (a) : (b))
#define | LBYTE(x) ((uint8_t)(x & 0x00FF))
low byte and high byte define More...
#define | HBYTE(x) ((uint8_t)((x & 0xFF00) >>8))

Enumerations

enum usbd_conn_state { USB_CONN_STATE_DEFAULT =1 , USB_CONN_STATE_ADDRESSED , USB_CONN_STATE_CONFIGURED , USB_CONN_STATE_SUSPENDED }
usb device connect state More...
enum usb_sts_type {
USB_OK , USB_FAIL , USB_WAIT , USB_NOT_SUPPORT ,
USB_ERROR
}
usb return status More...

Detailed Description

usb standard header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usb_std.h.


AT32F435/437 Firmwary Library: usbd_core.h File Reference

  • middlewares
  • usb_drivers
  • inc
usbd_core.h File Reference

usb device core header file More...

#include "usb_conf.h"
#include "usb_std.h"

Go to the source code of this file.

Detailed Description

usb device core header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbd_core.h.


AT32F435/437 Firmwary Library: usbd_int.h File Reference

  • middlewares
  • usb_drivers
  • inc
Functions
usbd_int.h File Reference

usb interrupt header file More...

#include "usbd_core.h"
#include "usb_core.h"

Go to the source code of this file.

Functions

void | usbd_irq_handler (otg_core_type *udev)
usb device interrput request handler. More...
void | usbd_ept_handler (usbd_core_type *udev)
void | usbd_reset_handler (usbd_core_type *udev)
usb device reset interrupt request handler. More...
void | usbd_sof_handler (usbd_core_type *udev)
usb device sof interrupt request handler. More...
void | usbd_suspend_handler (usbd_core_type *udev)
usb device suspend interrupt request handler. More...
void | usbd_wakeup_handler (usbd_core_type *udev)
usb device wakup interrupt request handler. More...
void | usbd_inept_handler (usbd_core_type *udev)
usb in endpoint handler More...
void | usbd_outept_handler (usbd_core_type *udev)
usb out endpoint handler More...
void | usbd_enumdone_handler (usbd_core_type *udev)
usb enumeration done handler More...
void | usbd_rxflvl_handler (usbd_core_type *udev)
usb rx non-empty handler More...
void | usbd_incomisioin_handler (usbd_core_type *udev)
usb incomplete in handler More...
void | usbd_discon_handler (usbd_core_type *udev)
usb disconnect handler More...
void | usbd_incomisoout_handler (usbd_core_type *udev)
usb incomplete out handler More...
void | usb_write_empty_txfifo (usbd_core_type *udev, uint32_t ept_num)
usb write tx fifo. More...

Detailed Description

usb interrupt header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbd_int.h.


AT32F435/437 Firmwary Library: usbd_sdr.h File Reference

  • middlewares
  • usb_drivers
  • inc
Functions
usbd_sdr.h File Reference
#include "usb_conf.h"
#include "usb_core.h"

Go to the source code of this file.

Functions

void | usbd_setup_request_parse (usb_setup_type *setup, uint8_t *buf)
usb parse standard setup request More...
usb_sts_type | usbd_device_request (usbd_core_type *udev)
standard usb device requests More...
usb_sts_type | usbd_interface_request (usbd_core_type *udev)
standard usb interface requests More...
usb_sts_type | usbd_endpoint_request (usbd_core_type *udev)
standard usb endpoint requests More...


AT32F435/437 Firmwary Library: usbh_core.h File Reference

  • middlewares
  • usb_drivers
  • inc
usbh_core.h File Reference

usb host core header file More...

#include "usb_conf.h"
#include "usb_std.h"

Go to the source code of this file.

Detailed Description

usb host core header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbh_core.h.


AT32F435/437 Firmwary Library: usbh_ctrl.h File Reference

  • middlewares
  • usb_drivers
  • inc
Functions
usbh_ctrl.h File Reference

usb header file More...

#include "usb_conf.h"
#include "usbh_core.h"

Go to the source code of this file.

Functions

usb_sts_type | usbh_ctrl_send_setup (usbh_core_type *uhost, uint8_t *buffer, uint8_t hc_num)
usb host control send setup packet More...
usb_sts_type | usbh_ctrl_recv_data (usbh_core_type *uhost, uint8_t *buffer, uint8_t length, uint16_t hc_num)
usb host control receive data from device More...
usb_sts_type | usbh_ctrl_send_data (usbh_core_type *uhost, uint8_t *buffer, uint8_t length, uint16_t hc_num)
usb host control send data packet More...
usb_sts_type | usbh_ctrl_setup_handler (usbh_core_type *uhost)
usb host control setup request handler More...
usb_sts_type | usbh_ctrl_setup_wait_handler (usbh_core_type *uhost, uint32_t *timeout)
usb host control setup request wait handler More...
usb_sts_type | usbh_ctrl_data_in_handler (usbh_core_type *uhost)
usb host control data in request handler More...
usb_sts_type | usbh_ctrl_data_in_wait_handler (usbh_core_type *uhost, uint32_t timeout)
usb host control data in wait handler More...
usb_sts_type | usbh_ctrl_data_out_handler (usbh_core_type *uhost)
usb host control data out request handler More...
usb_sts_type | usbh_ctrl_data_out_wait_handler (usbh_core_type *uhost, uint32_t timeout)
usb host control data out wait handler More...
usb_sts_type | usbh_ctrl_status_in_handler (usbh_core_type *uhost)
usb host control status data in handler More...
usb_sts_type | usbh_ctrl_status_in_wait_handler (usbh_core_type *uhost, uint32_t timeout)
usb host control status data in wait handler More...
usb_sts_type | usbh_ctrl_status_out_handler (usbh_core_type *uhost)
usb host control status data out wait handler More...
usb_sts_type | usbh_ctrl_status_out_wait_handler (usbh_core_type *uhost, uint32_t timeout)
usb host control status data out wait handler More...
usb_sts_type | usbh_ctrl_error_handler (usbh_core_type *uhost)
usb host control error handler More...
usb_sts_type | usbh_ctrl_stall_handler (usbh_core_type *uhost)
usb host control stall handler More...
usb_sts_type | usbh_ctrl_complete_handler (usbh_core_type *uhost)
usb host control complete handler More...
usb_sts_type | usbh_ctrl_transfer_loop (usbh_core_type *uhost)
usb host control transfer loop function More...
usb_sts_type | usbh_ctrl_request (usbh_core_type *uhost, uint8_t *buffer, uint16_t length)
usb host control request More...
usb_sts_type | usbh_get_descriptor (usbh_core_type *uhost, uint16_t length, uint8_t req_type, uint16_t wvalue, uint8_t *buffer)
usb host get device descriptor More...
void | usbh_parse_dev_desc (usbh_core_type *uhost, uint8_t *buffer, uint16_t length)
usb host parse device descriptor More...
usb_header_desc_type * | usbh_get_next_header (uint8_t *buf, uint16_t *index_len)
usb host get next header More...
void | usbh_parse_interface_desc (usb_interface_desc_type *intf, uint8_t *buf)
usb host parse interface descriptor More...
void | usbh_parse_endpoint_desc (usb_endpoint_desc_type *ept_desc, uint8_t *buf)
usb host parse endpoint descriptor More...
usb_sts_type | usbh_parse_configure_desc (usbh_core_type *uhost, uint8_t *buffer, uint16_t length)
usb host parse configure descriptor More...
uint8_t | usbh_find_interface (usbh_core_type *uhost, uint8_t class_code, uint8_t sub_class, uint8_t protocol)
usb host find interface More...
void | usbh_parse_string_desc (uint8_t *src, uint8_t *dest, uint16_t length)
usbh parse string descriptor More...
usb_sts_type | usbh_get_device_descriptor (usbh_core_type *uhost, uint16_t length)
usb host get device descriptor More...
usb_sts_type | usbh_get_configure_descriptor (usbh_core_type *uhost, uint16_t length)
usb host get configure descriptor More...
usb_sts_type | usbh_get_sting_descriptor (usbh_core_type *uhost, uint8_t string_id, uint8_t *buffer, uint16_t length)
usb host get string descriptor More...
usb_sts_type | usbh_set_configuration (usbh_core_type *uhost, uint16_t config)
usb host set configurtion More...
usb_sts_type | usbh_set_address (usbh_core_type *uhost, uint8_t address)
usb host set device address More...
usb_sts_type | usbh_set_interface (usbh_core_type *uhost, uint8_t ept_num, uint8_t altsetting)
usb host set interface More...
usb_sts_type | usbh_set_feature (usbh_core_type *uhost, uint8_t feature, uint16_t index)
usb host set feature More...
usb_sts_type | usbh_clear_dev_feature (usbh_core_type *uhost, uint8_t feature, uint16_t index)
usb host clear device feature More...
usb_sts_type | usbh_clear_ept_feature (usbh_core_type *uhost, uint8_t ept_num, uint8_t hc_num)
usb host clear endpoint feature More...

Detailed Description

usb header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbh_ctrl.h.


AT32F435/437 Firmwary Library: usbh_int.h File Reference

  • middlewares
  • usb_drivers
  • inc
Functions
usbh_int.h File Reference

usb header file More...

#include "usbh_core.h"
#include "usb_core.h"

Go to the source code of this file.

Functions

void | usbh_irq_handler (otg_core_type *hdev)
usb host interrupt handler More...
void | usbh_hch_handler (usbh_core_type *uhost)
usb host channel request handler More...
void | usbh_port_handler (usbh_core_type *uhost)
usb host port request handler More...
void | usbh_disconnect_handler (usbh_core_type *uhost)
usb host disconnect handler More...
void | usbh_hch_in_handler (usbh_core_type *uhost, uint8_t chn)
usb host in transfer request handler More...
void | usbh_hch_out_handler (usbh_core_type *uhost, uint8_t chn)
usb host out transfer request handler More...
void | usbh_rx_qlvl_handler (usbh_core_type *uhost)
usb host rx buffer not empty request handler More...
void | usbh_wakeup_handler (usbh_core_type *uhost)
usb host wakeup handler More...
void | usbh_sof_handler (usbh_core_type *uhost)
usb host sof handler More...

Detailed Description

usb header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbh_int.h.


AT32F435/437 Firmwary Library: usb_core.c File Reference

  • middlewares
  • usb_drivers
  • src
Functions
usb_core.c File Reference

usb driver More...

#include "usb_core.h"

Go to the source code of this file.

Functions

usb_sts_type usb_core_config (otg_core_type *otgdev, uint8_t core_id)
usb core config More...

Detailed Description

usb driver

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usb_core.c.


AT32F435/437 Firmwary Library: usbd_core.c File Reference

  • middlewares
  • usb_drivers
  • src
Functions
usbd_core.c File Reference

usb device driver More...

#include "usb_core.h"
#include "usbd_core.h"
#include "usbd_sdr.h"

Go to the source code of this file.

Functions

void | usbd_core_in_handler (usbd_core_type *udev, uint8_t ept_addr)
usb core in transfer complete handler More...
void | usbd_core_out_handler (usbd_core_type *udev, uint8_t ept_addr)
usb core out transfer complete handler More...
void | usbd_core_setup_handler (usbd_core_type *udev, uint8_t ept_num)
usb core setup transfer complete handler More...
void | usbd_ctrl_send (usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data More...
void | usbd_ctrl_recv (usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint recv data More...
void | usbd_ctrl_send_status (usbd_core_type *udev)
usb control endpoint send in status More...
void | usbd_ctrl_recv_status (usbd_core_type *udev)
usb control endpoint send out status More...
void | usbd_clear_stall (usbd_core_type *udev, uint8_t ept_addr)
clear endpoint stall More...
void | usbd_set_stall (usbd_core_type *udev, uint8_t ept_addr)
usb set endpoint to stall status More...
void | usbd_ctrl_unsupport (usbd_core_type *udev)
un-support device request More...
uint32_t | usbd_get_recv_len (usbd_core_type *udev, uint8_t ept_addr)
get endpoint receive data length More...
void | usbd_ept_open (usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint More...
void | usbd_ept_close (usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint More...
void | usbd_connect (usbd_core_type *udev)
usb device connect to host More...
void | usbd_disconnect (usbd_core_type *udev)
usb device disconnect to host More...
void | usbd_set_device_addr (usbd_core_type *udev, uint8_t address)
usb device set device address. More...
void | usb_ept_default_init (usbd_core_type *udev)
usb endpoint structure initialization More...
void | usbd_ept_send (usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint send data More...
void | usbd_ept_recv (usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint receive data More...
usbd_conn_state | usbd_connect_state_get (usbd_core_type *udev)
get usb connect state More...
void | usbd_remote_wakeup (usbd_core_type *udev)
usb device remote wakeup More...
void | usbd_enter_suspend (usbd_core_type *udev)
usb device enter suspend mode More...
void | usbd_flush_tx_fifo (usbd_core_type *udev, uint8_t ept_num)
usb device flush in endpoint fifo More...
void | usbd_fifo_alloc (usbd_core_type *udev)
usb device endpoint fifo alloc More...
usb_sts_type | usbd_core_init (usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *class_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
usb device core initialization More...

Detailed Description

usb device driver

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbd_core.c.


AT32F435/437 Firmwary Library: usbd_int.c File Reference

  • middlewares
  • usb_drivers
  • src
Functions
usbd_int.c File Reference

usb interrupt request More...

#include "usbd_int.h"

Go to the source code of this file.

Functions

void | usbd_irq_handler (otg_core_type *otgdev)
usb device interrput request handler. More...
void | usb_write_empty_txfifo (usbd_core_type *udev, uint32_t ept_num)
usb write tx fifo. More...
void | usbd_inept_handler (usbd_core_type *udev)
usb in endpoint handler More...
void | usbd_outept_handler (usbd_core_type *udev)
usb out endpoint handler More...
void | usbd_enumdone_handler (usbd_core_type *udev)
usb enumeration done handler More...
void | usbd_rxflvl_handler (usbd_core_type *udev)
usb rx non-empty handler More...
void | usbd_discon_handler (usbd_core_type *udev)
usb disconnect handler More...
void | usbd_incomisoout_handler (usbd_core_type *udev)
usb incomplete out handler More...
void | usbd_incomisioin_handler (usbd_core_type *udev)
usb incomplete in handler More...
void | usbd_reset_handler (usbd_core_type *udev)
usb device reset interrupt request handler. More...
void | usbd_sof_handler (usbd_core_type *udev)
usb device sof interrupt request handler. More...
void | usbd_suspend_handler (usbd_core_type *udev)
usb device suspend interrupt request handler. More...
void | usbd_wakeup_handler (usbd_core_type *udev)
usb device wakup interrupt request handler. More...

Detailed Description

usb interrupt request

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbd_int.c.


AT32F435/437 Firmwary Library: usbd_sdr.c File Reference

  • middlewares
  • usb_drivers
  • src
Functions
usbd_sdr.c File Reference

usb standard device request More...

#include "usbd_sdr.h"

Go to the source code of this file.

Functions

static usb_sts_type | usbd_get_descriptor (usbd_core_type *udev)
get usb standard device description request More...
static usb_sts_type | usbd_set_address (usbd_core_type *udev)
this request sets the device address More...
static usb_sts_type | usbd_get_status (usbd_core_type *udev)
get usb status request More...
static usb_sts_type | usbd_clear_feature (usbd_core_type *udev)
clear usb feature request More...
static usb_sts_type | usbd_set_feature (usbd_core_type *udev)
set usb feature request More...
static usb_sts_type | usbd_get_configuration (usbd_core_type *udev)
get usb configuration request More...
static usb_sts_type | usbd_set_configuration (usbd_core_type *udev)
sets the usb device configuration request More...
void | usbd_setup_request_parse (usb_setup_type *setup, uint8_t *buf)
usb parse standard setup request More...
usb_sts_type | usbd_device_request (usbd_core_type *udev)
standard usb device requests More...
usb_sts_type | usbd_interface_request (usbd_core_type *udev)
standard usb interface requests More...
usb_sts_type | usbd_endpoint_request (usbd_core_type *udev)
standard usb endpoint requests More...

Detailed Description

usb standard device request

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbd_sdr.c.


AT32F435/437 Firmwary Library: usbh_core.c File Reference

  • middlewares
  • usb_drivers
  • src
Functions
usbh_core.c File Reference

usb host driver More...

#include "usbh_core.h"
#include "usb_core.h"
#include "usbh_ctrl.h"
#include "usb_conf.h"

Go to the source code of this file.

Functions

static void | usbh_attached (usbh_core_type *uhost)
usb host attached More...
static void | usbh_enumeration (usbh_core_type *uhost)
usb host enumeration More...
static void | usbh_class_request (usbh_core_type *uhost)
usb host class request More...
static void | usbh_class (usbh_core_type *uhost)
usb host class handler More...
static void | usbh_suspend (usbh_core_type *uhost)
usb host suspend More...
static void | usbh_wakeup (usbh_core_type *uhost)
usb host wakeup More...
static void | usbh_disconnect (usbh_core_type *uhost)
usb host disconnect More...
void | usbh_free_channel (usbh_core_type *uhost, uint8_t index)
usb host free channel More...
uint16_t | usbh_get_free_channel (usbh_core_type *uhost)
get usb host free channel More...
usb_sts_type | usbh_set_toggle (usbh_core_type *uhost, uint8_t hc_num, uint8_t toggle)
usb host set toggle More...
usb_sts_type | usbh_in_out_request (usbh_core_type *uhost, uint8_t hc_num)
usb host in out request More...
usb_sts_type | usbh_interrupt_recv (usbh_core_type *uhost, uint8_t hc_num, uint8_t *buffer, uint16_t length)
usb host interrupt receive request More...
usb_sts_type | usbh_interrupt_send (usbh_core_type *uhost, uint8_t hc_num, uint8_t *buffer, uint16_t length)
usb host interrupt send request More...
usb_sts_type | usbh_bulk_recv (usbh_core_type *uhost, uint8_t hc_num, uint8_t *buffer, uint16_t length)
usb host bulk receive request More...
usb_sts_type | usbh_bulk_send (usbh_core_type *uhost, uint8_t hc_num, uint8_t *buffer, uint16_t length)
usb host bulk send request More...
usb_sts_type | usbh_isoc_send (usbh_core_type *uhost, uint8_t hc_num, uint8_t *buffer, uint16_t length)
usb host iso send request More...
usb_sts_type | usbh_isoc_recv (usbh_core_type *uhost, uint8_t hc_num, uint8_t *buffer, uint16_t length)
usb host iso receive request More...
usb_sts_type | usbh_cfg_default_init (usbh_core_type *uhost)
usb host cfg default init More...
void | usbh_enter_suspend (usbh_core_type *uhost)
usb host enter suspend More...
void | usbh_resume (usbh_core_type *uhost)
usb host resume More...
usb_sts_type | usbh_core_init (usbh_core_type *uhost, usb_reg_type *usb_reg, usbh_class_handler_type *class_handler, usbh_user_handler_type *user_handler, uint8_t core_id)
usb host core initialize More...
void | usbh_hc_open (usbh_core_type *uhost, uint8_t chn, uint8_t ept_num, uint8_t dev_address, uint8_t type, uint16_t maxpacket, uint8_t speed)
usb host open channel More...
void | usbh_ch_disable (usbh_core_type *uhost, uint8_t chn)
disable host channel More...
uint16_t | usbh_alloc_channel (usbh_core_type *uhost, uint8_t ept_addr)
usb host alloc channel More...
urb_sts_type | usbh_get_urb_status (usbh_core_type *uhost, uint8_t ch_num)
usb host get urb status More...
usb_sts_type | usbh_ctrl_result_check (usbh_core_type *uhost, ctrl_ept0_sts_type next_ctrl_state, uint8_t next_enum_state)
usb wait control setup complete More...
uint8_t | usbh_alloc_address (void)
auto alloc address (1...20) More...
usb_sts_type | usbh_enum_handler (usbh_core_type *uhost)
usb host enumeration handler More...
void | usbh_active_vbus (usbh_core_type *uhost, confirm_state state)
active vbus. More...
void | usbh_reset_port (usbh_core_type *uhost)
reset usb port More...
usb_sts_type | usbh_loop_handler (usbh_core_type *uhost)
usb host enum loop handler More...

Detailed Description

usb host driver

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbh_core.c.


AT32F435/437 Firmwary Library: usbh_ctrl.c File Reference

  • middlewares
  • usb_drivers
  • src
Macros | Functions
usbh_ctrl.c File Reference

usb host control request More...

#include "usbh_ctrl.h"
#include "usbh_core.h"
#include "usb_std.h"

Go to the source code of this file.

Macros

#define CTRL_TIMEOUT 5000

Functions

usb_sts_type | usbh_ctrl_send_setup (usbh_core_type *uhost, uint8_t *buffer, uint8_t hc_num)
usb host control send setup packet More...
usb_sts_type | usbh_ctrl_recv_data (usbh_core_type *uhost, uint8_t *buffer, uint8_t length, uint16_t hc_num)
usb host control receive data from device More...
usb_sts_type | usbh_ctrl_send_data (usbh_core_type *uhost, uint8_t *buffer, uint8_t length, uint16_t hc_num)
usb host control send data packet More...
usb_sts_type | usbh_ctrl_setup_handler (usbh_core_type *uhost)
usb host control setup request handler More...
usb_sts_type | usbh_ctrl_setup_wait_handler (usbh_core_type *uhost, uint32_t *timeout)
usb host control setup request wait handler More...
usb_sts_type | usbh_ctrl_data_in_handler (usbh_core_type *uhost)
usb host control data in request handler More...
usb_sts_type | usbh_ctrl_data_in_wait_handler (usbh_core_type *uhost, uint32_t timeout)
usb host control data in wait handler More...
usb_sts_type | usbh_ctrl_data_out_handler (usbh_core_type *uhost)
usb host control data out request handler More...
usb_sts_type | usbh_ctrl_data_out_wait_handler (usbh_core_type *uhost, uint32_t timeout)
usb host control data out wait handler More...
usb_sts_type | usbh_ctrl_status_in_handler (usbh_core_type *uhost)
usb host control status data in handler More...
usb_sts_type | usbh_ctrl_status_in_wait_handler (usbh_core_type *uhost, uint32_t timeout)
usb host control status data in wait handler More...
usb_sts_type | usbh_ctrl_status_out_handler (usbh_core_type *uhost)
usb host control status data out wait handler More...
usb_sts_type | usbh_ctrl_status_out_wait_handler (usbh_core_type *uhost, uint32_t timeout)
usb host control status data out wait handler More...
usb_sts_type | usbh_ctrl_error_handler (usbh_core_type *uhost)
usb host control error handler More...
usb_sts_type | usbh_ctrl_stall_handler (usbh_core_type *uhost)
usb host control stall handler More...
usb_sts_type | usbh_ctrl_complete_handler (usbh_core_type *uhost)
usb host control complete handler More...
usb_sts_type | usbh_ctrl_transfer_loop (usbh_core_type *uhost)
usb host control transfer loop function More...
usb_sts_type | usbh_ctrl_request (usbh_core_type *uhost, uint8_t *buffer, uint16_t length)
usb host control request More...
usb_sts_type | usbh_get_descriptor (usbh_core_type *uhost, uint16_t length, uint8_t req_type, uint16_t wvalue, uint8_t *buffer)
usb host get device descriptor More...
void | usbh_parse_dev_desc (usbh_core_type *uhost, uint8_t *buffer, uint16_t length)
usb host parse device descriptor More...
usb_header_desc_type * | usbh_get_next_header (uint8_t *buf, uint16_t *index_len)
usb host get next header More...
void | usbh_parse_interface_desc (usb_interface_desc_type *intf, uint8_t *buf)
usb host parse interface descriptor More...
void | usbh_parse_endpoint_desc (usb_endpoint_desc_type *ept_desc, uint8_t *buf)
usb host parse endpoint descriptor More...
usb_sts_type | usbh_parse_configure_desc (usbh_core_type *uhost, uint8_t *buffer, uint16_t length)
usb host parse configure descriptor More...
uint8_t | usbh_find_interface (usbh_core_type *uhost, uint8_t class_code, uint8_t sub_class, uint8_t protocol)
usb host find interface More...
void | usbh_parse_string_desc (uint8_t *src, uint8_t *dest, uint16_t length)
usbh parse string descriptor More...
usb_sts_type | usbh_get_device_descriptor (usbh_core_type *uhost, uint16_t length)
usb host get device descriptor More...
usb_sts_type | usbh_get_configure_descriptor (usbh_core_type *uhost, uint16_t length)
usb host get configure descriptor More...
usb_sts_type | usbh_get_sting_descriptor (usbh_core_type *uhost, uint8_t string_id, uint8_t *buffer, uint16_t length)
usb host get string descriptor More...
usb_sts_type | usbh_set_configuration (usbh_core_type *uhost, uint16_t config)
usb host set configurtion More...
usb_sts_type | usbh_set_address (usbh_core_type *uhost, uint8_t address)
usb host set device address More...
usb_sts_type | usbh_set_interface (usbh_core_type *uhost, uint8_t ept_num, uint8_t altsetting)
usb host set interface More...
usb_sts_type | usbh_set_feature (usbh_core_type *uhost, uint8_t feature, uint16_t index)
usb host set feature More...
usb_sts_type | usbh_clear_dev_feature (usbh_core_type *uhost, uint8_t feature, uint16_t index)
usb host clear device feature More...
usb_sts_type | usbh_clear_ept_feature (usbh_core_type *uhost, uint8_t ept_num, uint8_t hc_num)
usb host clear endpoint feature More...

Detailed Description

usb host control request

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbh_ctrl.c.


AT32F435/437 Firmwary Library: usbh_int.c File Reference

  • middlewares
  • usb_drivers
  • src
Functions
usbh_int.c File Reference

usb host interrupt request More...

#include "usbh_int.h"

Go to the source code of this file.

Functions

void | usbh_irq_handler (otg_core_type *otgdev)
usb host interrupt handler More...
void | usbh_wakeup_handler (usbh_core_type *uhost)
usb host wakeup handler More...
void | usbh_sof_handler (usbh_core_type *uhost)
usb host sof handler More...
void | usbh_disconnect_handler (usbh_core_type *uhost)
usb host disconnect handler More...
void | usbh_hch_in_handler (usbh_core_type *uhost, uint8_t chn)
usb host in transfer request handler More...
void | usbh_hch_out_handler (usbh_core_type *uhost, uint8_t chn)
usb host out transfer request handler More...
void | usbh_hch_handler (usbh_core_type *uhost)
usb host channel request handler More...
void | usbh_rx_qlvl_handler (usbh_core_type *uhost)
usb host rx buffer not empty request handler More...
void | usbh_port_handler (usbh_core_type *uhost)
usb host port request handler More...

Detailed Description

usb host interrupt request

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbh_int.c.


AT32F435/437 Firmwary Library: audio_class.c File Reference

  • middlewares
  • usbd_class
  • audio
Functions | Variables
audio_class.c File Reference

usb audio class type More...

#include "usbd_core.h"
#include "audio_class.h"
#include "audio_desc.h"
#include "audio_codec.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
static void | audio_inisoincom_event (void *udev)
usb audio in iso incom event More...
static void | audio_req_get_cur (void *udev, usb_setup_type *setup)
usb audio request get cur More...
static void | audio_req_set_cur (void *udev, usb_setup_type *setup)
usb audio request set cur More...
static void | audio_req_get_min (void *udev, usb_setup_type *setup)
usb audio request get min More...
static void | audio_req_get_max (void *udev, usb_setup_type *setup)
usb audio request get max More...
static void | audio_req_get_res (void *udev, usb_setup_type *setup)
usb audio request get res More...
static void | audio_get_interface (void *udev, usb_setup_type *setup)
usb audio get interface More...
static void | audio_set_interface (void *udev, usb_setup_type *setup)
usb audio set interface More...

Variables

usb_audio_type | audio_struct = {0, 0, 0, 0, 0, 0x1400, 0, 0, 0, {0x0000, 0x1400, 0x33}, {0x0000, 0x1400, 0x33}, 0, 0}
usbd_class_handler | audio_class_handler

Detailed Description

usb audio class type

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file audio_class.c.


AT32F435/437 Firmwary Library: audio_class.h File Reference

  • middlewares
  • usbd_class
  • audio
Data Structures | Macros | Variables
audio_class.h File Reference

usb audio class file More...

#include "usb_std.h"
#include "usbd_core.h"
#include "audio_conf.h"

Go to the source code of this file.

Data Structures

struct usb_audio_type
usb audio control struct More...

Macros

#define | USBD_AUDIO_MIC_IN_EPT 0x81
endpoint define More...
#define | USBD_AUDIO_SPK_OUT_EPT 0x02
#define | USBD_AUDIO_FEEDBACK_EPT 0x83
#define | AUDIO_REMAIN_SIZE 40
endpoint support max size More...
#define | AUDIO_MIC_IN_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_MIC_CHANEL_NUM * (AUDIO_MIC_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
#define | AUDIO_SPK_OUT_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_SPK_CHANEL_NUM * (AUDIO_SPK_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
#define | AUDIO_FEEDBACK_MAXPACKET_SIZE 0x3
#define | FEEDBACK_REFRESH_TIME 0x8
#define | AUDIO_REQ_CONTROL_INTERFACE 0x01
request type define More...
#define | AUDIO_REQ_CONTROL_ENDPOINT 0x02
#define | AUDIO_REQ_CONTROL_MASK 0x03
#define | AUDIO_MUTE_CONTROL 0x01
audio set cur type define More...
#define | AUDIO_VOLUME_CONTROL 0x02
#define | AUDIO_FREQ_SET_CONTROL 0x03
#define | AUDIO_DESCRIPTOR_TYPE 0x21
audio descriptor type More...
#define | AUDIO_DESCRIPTOR_SIZE 0x09

Variables

usbd_class_handler audio_class_handler

Detailed Description

usb audio class file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file audio_class.h.


AT32F435/437 Firmwary Library: audio_conf.h File Reference

  • middlewares
  • usbd_class
  • audio
Macros
audio/audio_conf.h File Reference

usb audio config More...

Go to the source code of this file.

Macros

#define | AUDIO_SUPPORT_SPK 1
#define | AUDIO_SUPPORT_MIC 1
#define | AUDIO_SUPPORT_FEEDBACK 1
#define | AUDIO_SUPPORT_FREQ_16K 0
#define | AUDIO_SUPPORT_FREQ_48K 1
#define | AUDIO_SUPPORT_FREQ
#define | AUDIO_FREQ_16K 16000
#define | AUDIO_FREQ_48K 48000
#define | AUDIO_BITW_16 16
#define | AUDIO_MIC_CHANEL_NUM 2
#define | AUDIO_MIC_DEFAULT_BITW AUDIO_BITW_16
#define | AUDIO_SPK_CHANEL_NUM 2
#define | AUDIO_SPK_DEFAULT_BITW AUDIO_BITW_16
#define | AUDIO_SUPPORT_MAX_FREQ 48
#define | AUDIO_DEFAULT_FREQ AUDIO_FREQ_48K
#define | AUDIO_DEFAULT_BITW AUDIO_BITW_16

Detailed Description

usb audio config

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file audio/audio_conf.h.


AT32F435/437 Firmwary Library: audio_conf.h File Reference

  • middlewares
  • usbd_class
  • audio_hid
Macros
audio_hid/audio_conf.h File Reference

usb audio config More...

Go to the source code of this file.

Macros

#define | AUDIO_SUPPORT_SPK 1
#define | AUDIO_SUPPORT_MIC 1
#define | AUDIO_SUPPORT_FEEDBACK 1
#define | AUDIO_SUPPORT_FREQ_16K 0
#define | AUDIO_SUPPORT_FREQ_48K 1
#define | AUDIO_SUPPORT_FREQ
#define | AUDIO_FREQ_16K 16000
#define | AUDIO_FREQ_48K 48000
#define | AUDIO_BITW_16 16
#define | AUDIO_MIC_CHANEL_NUM 2
#define | AUDIO_MIC_DEFAULT_BITW AUDIO_BITW_16
#define | AUDIO_SPK_CHANEL_NUM 2
#define | AUDIO_SPK_DEFAULT_BITW AUDIO_BITW_16
#define | AUDIO_SUPPORT_MAX_FREQ 48
#define | AUDIO_DEFAULT_FREQ AUDIO_FREQ_48K
#define | AUDIO_DEFAULT_BITW AUDIO_BITW_16

Detailed Description

usb audio config

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file audio_hid/audio_conf.h.


AT32F435/437 Firmwary Library: audio_desc.c File Reference

  • middlewares
  • usbd_class
  • audio
Functions | Variables
audio_desc.c File Reference

usb audio device descriptor More...

#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "audio_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler | audio_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb audio device descriptor

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file audio_desc.c.


AT32F435/437 Firmwary Library: audio_desc.h File Reference

  • middlewares
  • usbd_class
  • audio
Macros | Variables
audio_desc.h File Reference

usb audio descriptor header file More...

#include "audio_class.h"
#include "usbd_core.h"
#include "audio_conf.h"

Go to the source code of this file.

Macros

#define | AUDIO_BCD_NUM 0x0100
#define | USBD_AUDIO_VENDOR_ID 0x2E3C
#define | USBD_AUDIO_PRODUCT_ID 0x5730
#define | USBD_AUDIO_SIZ_STRING_LANGID 4
#define | USBD_AUDIO_SIZ_STRING_SERIAL 0x1A
#define | USBD_AUDIO_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_AUDIO_DESC_PRODUCT_STRING "AT32 Audio"
#define | USBD_AUDIO_DESC_CONFIGURATION_STRING "Audio Config"
#define | USBD_AUDIO_DESC_INTERFACE_STRING "Audio Interface"
#define | AUDIO_SUBCLASS_UNDEFINED 0x00
audio interface subclass codes More...
#define | AUDIO_SUBCLASS_AUDIOCONTROL 0x01
#define | AUDIO_SUBCLASS_AUDIOSTREAMING 0x02
#define | AUDIO_SUBCLASS_MIDISTREMING 0x03
#define | AUDIO_CS_INTERFACE 0x24
audio class-specific descriptor types More...
#define | AUDIO_CS_ENDPOINT 0x25
#define | AUDIO_CS_STRING 0x23
#define | AUDIO_CS_CONFIGURATION 0x22
#define | AUDIO_CS_DEVICE 0x21
#define | AUDIO_CS_UNDEFINED 0x20
#define | AUDIO_PROTOCOL_UNDEFINED 0x00
audio interface protocol codes More...
#define | AUDIO_AC_DESCRIPTOR_UNDEFINED 0x00
audio class-specific ac interface descriptor subtypes More...
#define | AUDIO_AC_HEADER 0x01
#define | AUDIO_AC_INPUT_TERMINAL 0x02
#define | AUDIO_AC_OUTPUT_TERMINAL 0x03
#define | AUDIO_AC_MIXER_UNIT 0x04
#define | AUDIO_AC_SELECTOR_UNIT 0x05
#define | AUDIO_AC_FEATURE_UNIT 0x06
#define | AUDIO_AC_PROCESSING_UNIT 0x07
#define | AUDIO_AC_EXTENSION_UNIT 0x08
#define | AUDIO_AS_DESCRIPTOR_UNDEFINED 0x00
audio class-specific as interface descriptor subtypes More...
#define | AUDIO_AS_GENERAL 0x01
#define | AUDIO_AS_FORMAT_TYPE 0x02
#define | AUDIO_AS_FORMAT_SPECIFIC 0x03
#define | AUDIO_REQUEST_CODE_UNDEFINED 0x00
audio class-specific request codes More...
#define | AUDIO_REQ_SET_CUR 0x01
#define | AUDIO_REQ_GET_CUR 0x81
#define | AUDIO_REQ_SET_MIN 0x02
#define | AUDIO_REQ_GET_MIN 0x82
#define | AUDIO_REQ_SET_MAX 0x03
#define | AUDIO_REQ_GET_MAX 0x83
#define | AUDIO_REQ_SET_RES 0x04
#define | AUDIO_REQ_GET_RES 0x84
#define | AUDIO_REQ_SET_MEM 0x05
#define | AUDIO_REQ_GET_MEM 0x85
#define | AUDIO_REQ_GET_STAT 0xFF
#define | AUDIO_FU_CONTROL_UNDEFINED 0x00
audio feature unit control selectors More...
#define | AUDIO_FU_MUTE_CONTROL 0x01
#define | AUDIO_FU_VOLUME_CONTROL 0x02
#define | AUDIO_FU_BASS_CONTROL 0x03
#define | AUDIO_FU_MID_CONTROL 0x04
#define | AUDIO_FU_TREBLE_CONTROL 0x05
#define | AUDIO_TERMINAL_TYPE_UNDEFINED 0x0100
audio terminal type More...
#define | AUDIO_TERMINAL_TYPE_STREAMING 0x0101
#define | AUDIO_TERMINAL_TYPE_VENDOR 0x01FF
#define | AUDIO_INPUT_TERMINAL_UNDEFINED 0x0200
#define | AUDIO_INPUT_TERMINAL_MICROPHONE 0x0201
#define | AUDIO_OUTPUT_TERMINAL_UNDEFINED 0x0300
#define | AUDIO_OUTPUT_TERMINAL_SPEAKER 0x0301
#define | AUDIO_FORMAT_TYPE_I 0x01
audio format type 1 More...
#define | AUDIO_INTERFACE_NUM (AUDIO_SUPPORT_SPK + AUDIO_SUPPORT_MIC)
audio interface config More...
#define | AUDIO_INTERFACE_LEN ((0x08 + AUDIO_INTERFACE_NUM) + AUDIO_INTERFACE_NUM * 0x1E)
#define | AUDIO_MIC_INTERFACE 0x01
#define | AUDIO_SPK_INTERFACE 0x02
#define | AUDIO_INPUT_TERMINAL_SIZE 0x0C
audio interface descriptor size define More...
#define | AUDIO_OUTPUT_TERMINAL_SIZE 0x09
#define | AUDIO_FEATURE_UNIT_SIZE 0x09
#define | AUDIO_MIC_INPUT_TERMINAL_ID 0x01
audio terminal id define More...
#define | AUDIO_MIC_FEATURE_UNIT_ID 0x02
#define | AUDIO_MIC_OUTPUT_TERMINAL_ID 0x03
#define | AUDIO_SPK_INPUT_TERMINAL_ID 0x04
#define | AUDIO_SPK_FEATURE_UNIT_ID 0x05
#define | AUDIO_SPK_OUTPUT_TERMINAL_ID 0x06
#define | AUDIO_MIC_INTERFACE_NUMBER 0x01
audio interface number More...
#define | AUDIO_SPK_INTERFACE_NUMBER 0x02
#define | AT32_AUDIO_FREQ_16K 16000
audio support freq More...
#define | AT32_AUDIO_FREQ_48K 48000
#define | AUDIO_MIC_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
audio microphone freq and channel config More...
#define | AUDIO_MIC_CHR AUDIO_MIC_CHANEL_NUM
#define | AUDIO_MIC_BITW (AUDIO_MIC_DEFAULT_BITW)
#define | AUDIO_SPK_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
audio speaker freq and channel config More...
#define | AUDIO_SPK_CHR AUDIO_SPK_CHANEL_NUM
#define | AUDIO_SPK_BITW (AUDIO_SPK_DEFAULT_BITW)
#define | AUDIO_BINTERVAL_TIME 0x01
#define | USBD_AUDIO_CONFIG_DESC_SIZE
#define | SAMPLE_FREQ(frq) (uint8_t)(frq), (uint8_t)((frq >> 8)), (uint8_t)((frq >> 16))
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

usbd_desc_handler audio_desc_handler
device descriptor handler structure More...

Detailed Description

usb audio descriptor header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file audio_desc.h.


AT32F435/437 Firmwary Library: audio_hid_class.c File Reference

  • middlewares
  • usbd_class
  • audio_hid
Functions | Variables
audio_hid_class.c File Reference
#include "usbd_core.h"
#include "audio_hid_class.h"
#include "audio_hid_desc.h"
#include "audio_codec.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
static void | audio_inisoincom_event (void *udev)
usb audio in iso incom event More...
static void | audio_req_get_cur (void *udev, usb_setup_type *setup)
usb audio request get cur More...
static void | audio_req_set_cur (void *udev, usb_setup_type *setup)
usb audio request set cur More...
static void | audio_req_get_min (void *udev, usb_setup_type *setup)
usb audio request get min More...
static void | audio_req_get_max (void *udev, usb_setup_type *setup)
usb audio request get max More...
static void | audio_req_get_res (void *udev, usb_setup_type *setup)
usb audio request get res More...
static void | audio_get_interface (void *udev, usb_setup_type *setup)
usb audio get interface More...
static void | audio_set_interface (void *udev, usb_setup_type *setup)
usb audio set interface More...
static void | usb_hid_buf_process (void *udev, uint8_t *report, uint16_t len)
usb device report function More...
static usb_sts_type | class_audio_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_hid_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
usb_sts_type | audio_hid_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

usb_audio_hid_type | audio_hid_struct = {0, 0, 0, 0, 0, 0x1400, 0, 0, 0, {0x0000, 0x1400, 0x33}, {0x0000, 0x1400, 0x33}, 0, 0}
usbd_class_handler | audio_hid_class_handler


AT32F435/437 Firmwary Library: audio_hid_class.h File Reference

  • middlewares
  • usbd_class
  • audio_hid
Data Structures | Macros | Functions | Variables
audio_hid_class.h File Reference
#include "usb_std.h"
#include "usbd_core.h"
#include "audio_conf.h"

Go to the source code of this file.

Data Structures

struct usb_audio_hid_type
usb audio control struct More...

Macros

#define | USBD_AUHID_AUDIO_MIC_IN_EPT 0x81
endpoint define More...
#define | USBD_AUHID_AUDIO_SPK_OUT_EPT 0x02
#define | USBD_AUHID_AUDIO_FEEDBACK_EPT 0x83
#define | USBD_AUHID_HID_IN_EPT 0x82
usb custom hid use endpoint define More...
#define | USBD_AUHID_HID_OUT_EPT 0x01
#define | USBD_AUHID_IN_MAXPACKET_SIZE 0x40
usb custom hid in and out max packet size define More...
#define | USBD_AUHID_OUT_MAXPACKET_SIZE 0x40
#define | AUDIO_REMAIN_SIZE 40
endpoint support max size More...
#define | AUDIO_MIC_IN_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_MIC_CHANEL_NUM * (AUDIO_MIC_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
#define | AUDIO_SPK_OUT_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_SPK_CHANEL_NUM * (AUDIO_SPK_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
#define | AUDIO_FEEDBACK_MAXPACKET_SIZE 0x3
#define | FEEDBACK_REFRESH_TIME 0x8
#define | AUDIO_REQ_CONTROL_INTERFACE 0x01
request type define More...
#define | AUDIO_REQ_CONTROL_ENDPOINT 0x02
#define | AUDIO_REQ_CONTROL_MASK 0x03
#define | AUDIO_MUTE_CONTROL 0x01
audio set cur type define More...
#define | AUDIO_VOLUME_CONTROL 0x02
#define | AUDIO_FREQ_SET_CONTROL 0x03
#define | AUDIO_MUTE_CONTROL 0x01
audio set cur type define More...
#define | AUDIO_VOLUME_CONTROL 0x02
#define | AUDIO_FREQ_SET_CONTROL 0x03
#define | AUDIO_DESCRIPTOR_TYPE 0x21
audio descriptor type More...
#define | AUDIO_DESCRIPTOR_SIZE 0x09

Functions

usb_sts_type audio_hid_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

usbd_class_handler audio_hid_class_handler


AT32F435/437 Firmwary Library: audio_hid_desc.c File Reference

  • middlewares
  • usbd_class
  • audio_hid
Functions | Variables
audio_hid_desc.c File Reference
#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "audio_hid_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler | audio_hid_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc


AT32F435/437 Firmwary Library: audio_hid_desc.h File Reference

  • middlewares
  • usbd_class
  • audio_hid
Macros | Variables
audio_hid_desc.h File Reference
#include "audio_hid_class.h"
#include "usbd_core.h"
#include "audio_conf.h"

Go to the source code of this file.

Macros

#define | AUHID_BCD_NUM 0x0100
#define | USBD_AUHID_VENDOR_ID 0x2E3C
#define | USBD_AUHID_PRODUCT_ID 0x5555
#define | USBD_AUHID_SIZ_STRING_LANGID 4
#define | USBD_AUHID_SIZ_STRING_SERIAL 0x1A
#define | USBD_AUHID_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_AUHID_DESC_PRODUCT_STRING "AT32 Audio"
#define | USBD_AUHID_DESC_CONFIGURATION_STRING "Audio Config"
#define | USBD_AUHID_DESC_INTERFACE_STRING "Audio Interface"
#define | AUDIO_SUBCLASS_UNDEFINED 0x00
audio interface subclass codes More...
#define | AUDIO_SUBCLASS_AUDIOCONTROL 0x01
#define | AUDIO_SUBCLASS_AUDIOSTREAMING 0x02
#define | AUDIO_SUBCLASS_MIDISTREMING 0x03
#define | AUDIO_CS_INTERFACE 0x24
audio class-specific descriptor types More...
#define | AUDIO_CS_ENDPOINT 0x25
#define | AUDIO_CS_STRING 0x23
#define | AUDIO_CS_CONFIGURATION 0x22
#define | AUDIO_CS_DEVICE 0x21
#define | AUDIO_CS_UNDEFINED 0x20
#define | AUDIO_PROTOCOL_UNDEFINED 0x00
audio interface protocol codes More...
#define | AUDIO_AC_DESCRIPTOR_UNDEFINED 0x00
audio class-specific ac interface descriptor subtypes More...
#define | AUDIO_AC_HEADER 0x01
#define | AUDIO_AC_INPUT_TERMINAL 0x02
#define | AUDIO_AC_OUTPUT_TERMINAL 0x03
#define | AUDIO_AC_MIXER_UNIT 0x04
#define | AUDIO_AC_SELECTOR_UNIT 0x05
#define | AUDIO_AC_FEATURE_UNIT 0x06
#define | AUDIO_AC_PROCESSING_UNIT 0x07
#define | AUDIO_AC_EXTENSION_UNIT 0x08
#define | AUDIO_AS_DESCRIPTOR_UNDEFINED 0x00
audio class-specific as interface descriptor subtypes More...
#define | AUDIO_AS_GENERAL 0x01
#define | AUDIO_AS_FORMAT_TYPE 0x02
#define | AUDIO_AS_FORMAT_SPECIFIC 0x03
#define | AUDIO_REQUEST_CODE_UNDEFINED 0x00
audio class-specific request codes More...
#define | AUDIO_REQ_SET_CUR 0x01
#define | AUDIO_REQ_GET_CUR 0x81
#define | AUDIO_REQ_SET_MIN 0x02
#define | AUDIO_REQ_GET_MIN 0x82
#define | AUDIO_REQ_SET_MAX 0x03
#define | AUDIO_REQ_GET_MAX 0x83
#define | AUDIO_REQ_SET_RES 0x04
#define | AUDIO_REQ_GET_RES 0x84
#define | AUDIO_REQ_SET_MEM 0x05
#define | AUDIO_REQ_GET_MEM 0x85
#define | AUDIO_REQ_GET_STAT 0xFF
#define | AUDIO_FU_CONTROL_UNDEFINED 0x00
audio feature unit control selectors More...
#define | AUDIO_FU_MUTE_CONTROL 0x01
#define | AUDIO_FU_VOLUME_CONTROL 0x02
#define | AUDIO_FU_BASS_CONTROL 0x03
#define | AUDIO_FU_MID_CONTROL 0x04
#define | AUDIO_FU_TREBLE_CONTROL 0x05
#define | AUDIO_TERMINAL_TYPE_UNDEFINED 0x0100
audio terminal type More...
#define | AUDIO_TERMINAL_TYPE_STREAMING 0x0101
#define | AUDIO_TERMINAL_TYPE_VENDOR 0x01FF
#define | AUDIO_INPUT_TERMINAL_UNDEFINED 0x0200
#define | AUDIO_INPUT_TERMINAL_MICROPHONE 0x0201
#define | AUDIO_OUTPUT_TERMINAL_UNDEFINED 0x0300
#define | AUDIO_OUTPUT_TERMINAL_SPEAKER 0x0301
#define | AUDIO_FORMAT_TYPE_I 0x01
audio format type 1 More...
#define | AUDIO_INTERFACE_NUM (AUDIO_SUPPORT_SPK + AUDIO_SUPPORT_MIC)
audio interface config More...
#define | AUDIO_INTERFACE_LEN ((0x08 + AUDIO_INTERFACE_NUM) + AUDIO_INTERFACE_NUM * 0x1E)
#define | AUDIO_MIC_INTERFACE 0x01
#define | AUDIO_SPK_INTERFACE 0x02
#define | AUDIO_INPUT_TERMINAL_SIZE 0x0C
audio interface descriptor size define More...
#define | AUDIO_OUTPUT_TERMINAL_SIZE 0x09
#define | AUDIO_FEATURE_UNIT_SIZE 0x09
#define | AUDIO_MIC_INPUT_TERMINAL_ID 0x01
audio terminal id define More...
#define | AUDIO_MIC_FEATURE_UNIT_ID 0x02
#define | AUDIO_MIC_OUTPUT_TERMINAL_ID 0x03
#define | AUDIO_SPK_INPUT_TERMINAL_ID 0x04
#define | AUDIO_SPK_FEATURE_UNIT_ID 0x05
#define | AUDIO_SPK_OUTPUT_TERMINAL_ID 0x06
#define | AUDIO_MIC_INTERFACE_NUMBER 0x01
audio interface number More...
#define | AUDIO_SPK_INTERFACE_NUMBER 0x02
#define | HID_INTERFACE_NUMBER 0x03
#define | AT32_AUDIO_FREQ_16K 16000
audio support freq More...
#define | AT32_AUDIO_FREQ_48K 48000
#define | AUDIO_MIC_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
audio microphone freq and channel config More...
#define | AUDIO_MIC_CHR AUDIO_MIC_CHANEL_NUM
#define | AUDIO_MIC_BITW (AUDIO_MIC_DEFAULT_BITW)
#define | AUDIO_SPK_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
audio speaker freq and channel config More...
#define | AUDIO_SPK_CHR AUDIO_SPK_CHANEL_NUM
#define | AUDIO_SPK_BITW (AUDIO_SPK_DEFAULT_BITW)
#define | AUHID_HID_BINTERVAL_TIME 0x01
#define | AUHID_HID_BCD_NUM 0x0110
usb bcd number define More...
#define | HID_CLASS_DESC_HID 0x21
usb hid class descriptor define More...
#define | HID_CLASS_DESC_REPORT 0x22
#define | HID_CLASS_DESC_PHYSICAL 0x23
#define | HID_REPORT_ID_1 0x01
usb hid report id define More...
#define | HID_REPORT_ID_2 0x02
#define | HID_REPORT_ID_3 0x03
#define | HID_REPORT_ID_4 0x04
#define | HID_REPORT_ID_5 0x05
#define | HID_REPORT_ID_6 0xF0
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)
#define | SAMPLE_FREQ(frq) (uint8_t)(frq), (uint8_t)((frq >> 8)), (uint8_t)((frq >> 16))
#define | USBD_AUHID_HID_SIZ_REPORT_DESC 126
#define | USBD_AUHID_HID_DESC_SIZE 32
#define | USBD_AUHID_CONFIG_DESC_SIZE

Variables

uint8_t | g_usbd_audio_hid_report [126]
usb hid report descriptor More...
uint8_t | g_audio_hid_usb_desc [9]
usb hid descriptor More...
usbd_desc_handler | audio_hid_desc_handler
device descriptor handler structure More...


AT32F435/437 Firmwary Library: cdc_class.c File Reference

  • middlewares
  • usbd_class
  • cdc
Functions | Variables
cdc_class.c File Reference

usb cdc class type More...

#include "usbd_core.h"
#include "cdc_class.h"
#include "cdc_desc.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
static usb_sts_type | cdc_struct_init (cdc_struct_type *pcdc)
usb device cdc init More...
void | usb_usart_config (linecoding_type linecoding)
this function handles usart2 and linecoding config. More...
static void | usb_vcp_cmd_process (void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device function More...
uint16_t | usb_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

linecoding_type linecoding
cdc_struct_type cdc_struct
usbd_class_handler cdc_class_handler

Detailed Description

usb cdc class type

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_class.c.


AT32F435/437 Firmwary Library: cdc_class.h File Reference

  • middlewares
  • usbd_class
  • cdc
Data Structures | Macros | Functions | Variables
cdc_class.h File Reference

usb cdc class file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct cdc_struct_type
usb cdc class struct More...

Macros

#define | USBD_CDC_INT_EPT 0x82
usb cdc use endpoint define More...
#define | USBD_CDC_BULK_IN_EPT 0x81
#define | USBD_CDC_BULK_OUT_EPT 0x01
#define | USBD_CDC_IN_MAXPACKET_SIZE 0x40
usb cdc in and out max packet size define More...
#define | USBD_CDC_OUT_MAXPACKET_SIZE 0x40
#define | USBD_CDC_CMD_MAXPACKET_SIZE 0x08

Functions

uint16_t | usb_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

usbd_class_handler cdc_class_handler

Detailed Description

usb cdc class file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_class.h.


AT32F435/437 Firmwary Library: cdc_desc.c File Reference

  • middlewares
  • usbd_class
  • cdc
Functions | Variables
cdc_desc.c File Reference

usb cdc device descriptor More...

#include "stdio.h"
#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "cdc_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler | cdc_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb cdc device descriptor

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_desc.c.


AT32F435/437 Firmwary Library: cdc_desc.h File Reference

  • middlewares
  • usbd_class
  • cdc
Macros | Variables
cdc_desc.h File Reference

usb cdc descriptor header file More...

#include "cdc_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | CDC_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_CDC_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_CDC_PRODUCT_ID 0x5740
#define | USBD_CDC_CONFIG_DESC_SIZE 67
usb descriptor size define More...
#define | USBD_CDC_SIZ_STRING_LANGID 4
#define | USBD_CDC_SIZ_STRING_SERIAL 0x1A
#define | USBD_CDC_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_CDC_DESC_PRODUCT_STRING "AT32 Virtual Com Port "
#define | USBD_CDC_DESC_CONFIGURATION_STRING "Virtual ComPort Config"
#define | USBD_CDC_DESC_INTERFACE_STRING "Virtual ComPort Interface"
#define | CDC_HID_BINTERVAL_TIME 0xFF
usb endpoint interval define More...
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

usbd_desc_handler cdc_desc_handler
device descriptor handler structure More...

Detailed Description

usb cdc descriptor header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_desc.h.


AT32F435/437 Firmwary Library: cdc_keyboard_class.c File Reference

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
Macros | Functions | Variables
cdc_keyboard_class.c File Reference

usb cdc and keyboard class type More...

#include "usbd_core.h"
#include "cdc_keyboard_class.h"
#include "cdc_keyboard_desc.h"

Go to the source code of this file.

Macros

#define SHIFT 0x80

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
static usb_sts_type | cdc_class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | keyboard_class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static void | usb_vcp_cmd_process (void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device class request function More...
uint16_t | usb_vcpkybrd_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcpkybrd_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...
usb_sts_type | usb_vcpkybrd_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_vcpkybrd_keyboard_send_char (void *udev, uint8_t ascii_code)
usb keyoard send char More...

Variables

vcp_keyboard_type vcp_keyboard_struct
static const unsigned char | _asciimap [128]
linecoding_type linecoding_vcpkybrd
usbd_class_handler | cdc_keyboard_class_handler

Detailed Description

usb cdc and keyboard class type

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_keyboard_class.c.


AT32F435/437 Firmwary Library: cdc_keyboard_class.h File Reference

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
Data Structures | Macros | Functions | Variables
cdc_keyboard_class.h File Reference

usb cdc and keyboard class file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct vcp_keyboard_type

Macros

#define | USBD_VCPKYBRD_CDC_INT_EPT 0x82
usb use endpoint define More...
#define | USBD_VCPKYBRD_CDC_BULK_IN_EPT 0x81
#define | USBD_VCPKYBRD_CDC_BULK_OUT_EPT 0x01
#define | USBD_VCPKYBRD_HID_IN_EPT 0x83
#define | USBD_VCPKYBRD_IN_MAXPACKET_SIZE 0x40
usb in and out max packet size define More...
#define | USBD_VCPKYBRD_OUT_MAXPACKET_SIZE 0x40
#define | USBD_VCPKYBRD_CMD_MAXPACKET_SIZE 0x08

Functions

uint16_t | usb_vcpkybrd_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcpkybrd_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...
usb_sts_type | usb_vcpkybrd_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_vcpkybrd_keyboard_send_char (void *udev, uint8_t ascii_code)
usb keyoard send char More...

Variables

usbd_class_handler cdc_keyboard_class_handler

Detailed Description

usb cdc and keyboard class file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_keyboard_class.h.


AT32F435/437 Firmwary Library: cdc_keyboard_desc.c File Reference

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
Functions | Variables
cdc_keyboard_desc.c File Reference

usb cdc and keyboard device descriptor More...

#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "cdc_keyboard_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler | cdc_keyboard_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb cdc and keyboard device descriptor

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_keyboard_desc.c.


AT32F435/437 Firmwary Library: cdc_keyboard_desc.h File Reference

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
Macros | Variables
cdc_keyboard_desc.h File Reference

usb cdc and keyboard descriptor header file More...

#include "cdc_keyboard_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | VCPKYBRD_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_VCPKYBRD_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_VCPKYBRD_PRODUCT_ID 0x5750
#define | USBD_VCPKYBRD_CONFIG_DESC_SIZE 108
usb descriptor size define More...
#define | USBD_VCPKYBRD_HID_SIZ_REPORT_DESC 63
#define | USBD_VCPKYBRD_SIZ_STRING_LANGID 4
#define | USBD_VCPKYBRD_SIZ_STRING_SERIAL 0x1A
#define | USBD_VCPKYBRD_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_VCPKYBRD_DESC_PRODUCT_STRING "AT32 Composite VCP and Keyboard"
#define | USBD_VCPKYBRD_DESC_CONFIGURATION_STRING "Composite VCP and Keyboard Config"
#define | USBD_VCPKYBRD_DESC_INTERFACE_STRING "Composite VCP and Keyboard Interface"
#define | VCPKYBRD_HID_BINTERVAL_TIME 0x0A
usb endpoint interval define More...
#define | VCPKYBRD_CDC_INTERFACE 0x00
usb interface define More...
#define | VCPKYBRD_CDC_DATA_INTERFACE 0x01
#define | VCPKYBRD_KEYBOARD_INTERFACE 0x02
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

uint8_t | g_usbd_vcpkybrd_hid_report [63]
usb hid keyboard report descriptor More...
uint8_t | g_vcpkybrd_hid_usb_desc [9]
usb hid descriptor More...
usbd_desc_handler | cdc_keyboard_desc_handler
device descriptor handler structure More...

Detailed Description

usb cdc and keyboard descriptor header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_keyboard_desc.h.


AT32F435/437 Firmwary Library: cdc_msc_class.c File Reference

  • middlewares
  • usbd_class
  • composite_cdc_msc
Functions | Variables
cdc_msc_class.c File Reference

usb cdc class type More...

#include "usbd_core.h"
#include "cdc_msc_class.h"
#include "cdc_msc_desc.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
static usb_sts_type | cdc_struct_init (cdc_msc_struct_type *pcdc)
usb device cdc init More...
void | usb_usart_config (linecoding_type linecoding)
this function handles usart2 and linecoding config. More...
static void | usb_vcp_cmd_process (void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device function More...
static usb_sts_type | cdc_class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | msc_class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
uint16_t | usb_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

linecoding_type linecoding
cdc_msc_struct_type cdc_msc_struct
usbd_class_handler cdc_msc_class_handler

Detailed Description

usb cdc class type

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_msc_class.c.

Function Documentation

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 127 of file cdc_msc_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device endpoint 0 out status stage complete

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 332 of file cdc_msc_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 318 of file cdc_msc_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 427 of file cdc_msc_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 354 of file cdc_msc_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb custom hid endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 90 of file cdc_msc_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 383 of file cdc_msc_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 156 of file cdc_msc_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 412 of file cdc_msc_class.c.

◆ usb_vcp_cmd_process()

static void usb_vcp_cmd_process | ( | void * | udev,
 |  | uint8_t | cmd,
 |  | uint8_t * | buff,
 |  | uint16_t | len
 | ) |  |
static

usb device function

Parameters
udev | to the structure of usbd_core_type
cmd | request number
buff | request buffer
len | buffer length
Return values
none

Definition at line 535 of file cdc_msc_class.c.

Referenced by cdc_class_setup_handler(), and class_ept0_rx_handler().


AT32F435/437 Firmwary Library: cdc_msc_class.h File Reference

  • middlewares
  • usbd_class
  • composite_cdc_msc
Data Structures | Macros | Functions | Variables
cdc_msc_class.h File Reference

usb cdc class file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct | cbd_typical_type
typical command block description More...
struct | cbd_extended_type
extended command block description More...
struct | cbw_type
command block wrapper More...
struct | csw_type
command block wrapper More...
struct | sense_type
request sense standard data More...
struct | msc_type
struct | cdc_msc_struct_type
usb cdc class struct More...

Macros

#define | USBD_CDC_INT_EPT 0x82
usb cdc use endpoint define More...
#define | USBD_CDC_BULK_IN_EPT 0x83
#define | USBD_CDC_BULK_OUT_EPT 0x02
#define | USBD_MSC_BULK_IN_EPT 0x81
#define | USBD_MSC_BULK_OUT_EPT 0x01
#define | USBD_CDC_MSC_IN_MAXPACKET_SIZE 0x40
usb cdc in and out max packet size define More...
#define | USBD_CDC_MSC_OUT_MAXPACKET_SIZE 0x40
#define | USBD_CDC_CMD_MAXPACKET_SIZE 0x08
#define | MSC_SUPPORT_MAX_LUN 1
#define | MSC_MAX_DATA_BUF_LEN 4096
#define | MSC_CMD_FORMAT_UNIT 0x04
#define | MSC_CMD_INQUIRY 0x12
#define | MSC_CMD_START_STOP 0x1B
#define | MSC_CMD_MODE_SENSE6 0x1A
#define | MSC_CMD_MODE_SENSE10 0x5A
#define | MSC_CMD_ALLOW_MEDIUM_REMOVAL 0x1E
#define | MSC_CMD_READ_10 0x28
#define | MSC_CMD_READ_12 0xA8
#define | MSC_CMD_READ_CAPACITY 0x25
#define | MSC_CMD_READ_FORMAT_CAPACITY 0x23
#define | MSC_CMD_REQUEST_SENSE 0x03
#define | MSC_CMD_TEST_UNIT 0x00
#define | MSC_CMD_VERIFY 0x2F
#define | MSC_CMD_WRITE_10 0x2A
#define | MSC_CMD_WRITE_12 0xAA
#define | MSC_CMD_WRITE_VERIFY 0x2E
#define | MSC_REQ_GET_MAX_LUN 0xFE
#define | MSC_REQ_BO_RESET 0xFF
#define | SET_LINE_CODING 0x20
#define | GET_LINE_CODING 0x21
#define | CBW_CMD_LENGTH 31
#define | CBW_DCBWSIGNATURE 0x43425355
#define | CBW_BMCBWFLAGS_DIR_OUT 0x00
#define | CBW_BMCBWFLAGS_DIR_IN 0x80
#define | CSW_CMD_LENGTH 13
#define | CSW_DCSWSIGNATURE 0x53425355
#define | CSW_BCSWSTATUS_PASS 0x00
#define | CSW_BCSWSTATUS_FAILED 0x01
#define | CSW_BCSWSTATUS_PHASE_ERR 0x02
#define | MSC_STATE_MACHINE_CMD 0x00
#define | MSC_STATE_MACHINE_DATA_IN 0x01
#define | MSC_STATE_MACHINE_DATA_OUT 0x02
#define | MSC_STATE_MACHINE_SEND_DATA 0x03
#define | MSC_STATE_MACHINE_LAST_DATA 0x04
#define | MSC_STATE_MACHINE_STATUS 0x05
#define | MSC_STATE_MACHINE_FAILED 0x06
#define | MSC_STATE_MACHINE_IDLE 0x07
#define | MSC_BOT_STATE_IDLE 0x00
#define | MSC_BOT_STATE_RECOVERY 0x01
#define | MSC_BOT_STATE_ERROR 0x02
#define | REQ_SENSE_STANDARD_DATA_LEN 0x12
#define | SENSE_KEY_NO_SENSE 0x00
#define | SENSE_KEY_RECOVERED_ERROR 0x01
#define | SENSE_KEY_NOT_READY 0x02
#define | SENSE_KEY_MEDIUM_ERROR 0x03
#define | SENSE_KEY_HARDWARE_ERROR 0x04
#define | SENSE_KEY_ILLEGAL_REQUEST 0x05
#define | SENSE_KEY_UNIT_ATTENTION 0x06
#define | SENSE_KEY_DATA_PROTECT 0x07
#define | SENSE_KEY_BLANK_CHECK 0x08
#define | SENSE_KEY_VENDERO_SPECIFIC 0x09
#define | SENSE_KEY_ABORTED_COMMAND 0x0B
#define | SENSE_KEY_VOLUME_OVERFLOW 0x0D
#define | SENSE_KEY_MISCOMPARE 0x0E
#define | INVALID_COMMAND 0x20
#define | INVALID_FIELED_IN_COMMAND 0x24
#define | PARAMETER_LIST_LENGTH_ERROR 0x1A
#define | INVALID_FIELD_IN_PARAMETER_LIST 0x26
#define | ADDRESS_OUT_OF_RANGE 0x21
#define | MEDIUM_NOT_PRESENT 0x3A
#define | MEDIUM_HAVE_CHANGED 0x28
#define | SCSI_INQUIRY_DATA_LENGTH 36

Functions

uint16_t | usb_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...
void | bot_scsi_init (void *udev)
initialize bulk-only transport and scsi More...
void | bot_scsi_reset (void *udev)
reset bulk-only transport and scsi More...
void | bot_scsi_datain_handler (void *pudev, uint8_t ept_num)
bulk-only transport data in handler More...
void | bot_scsi_dataout_handler (void *pudev, uint8_t ept_num)
bulk-only transport data out handler More...
void | bot_cbw_decode (void *udev)
bulk-only cbw decode More...
void | bot_scsi_send_data (void *udev, uint8_t *buffer, uint32_t len)
send bot data More...
void | bot_scsi_send_csw (void *udev, uint8_t status)
send command status More...
void | bot_scsi_sense_code (void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code More...
usb_sts_type | bot_scsi_check_address (void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address More...
void | bot_scsi_stall (void *udev)
bot endpoint stall More...
usb_sts_type | bot_scsi_cmd_process (void *udev)
bulk-only transport scsi command process More...
usb_sts_type | bot_scsi_test_unit (void *udev, uint8_t lun)
bulk-only transport scsi command test unit More...
usb_sts_type | bot_scsi_inquiry (void *udev, uint8_t lun)
bulk-only transport scsi command inquiry More...
usb_sts_type | bot_scsi_start_stop (void *udev, uint8_t lun)
bulk-only transport scsi command start stop More...
usb_sts_type | bot_scsi_allow_medium_removal (void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal More...
usb_sts_type | bot_scsi_mode_sense6 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6 More...
usb_sts_type | bot_scsi_mode_sense10 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10 More...
usb_sts_type | bot_scsi_read10 (void *udev, uint8_t lun)
bulk-only transport scsi command read10 More...
usb_sts_type | bot_scsi_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command capacity More...
usb_sts_type | bot_scsi_format_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command format capacity More...
usb_sts_type | bot_scsi_request_sense (void *udev, uint8_t lun)
bulk-only transport scsi command request sense More...
usb_sts_type | bot_scsi_verify (void *udev, uint8_t lun)
bulk-only transport scsi command verify More...
usb_sts_type | bot_scsi_write10 (void *udev, uint8_t lun)
bulk-only transport scsi command write10 More...
void | bot_scsi_clear_feature (void *udev, uint8_t ept_num)
clear feature More...

Variables

usbd_class_handler cdc_msc_class_handler

Detailed Description

usb cdc class file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_msc_class.h.


AT32F435/437 Firmwary Library: cdc_msc_desc.c File Reference

  • middlewares
  • usbd_class
  • composite_cdc_msc
Macros | Functions | Variables
cdc_msc_desc.c File Reference

usb cdc device descriptor More...

#include "stdio.h"
#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "cdc_msc_desc.h"

Go to the source code of this file.

Macros

#define USB_INTERFACE_ASSOCIATION_TYPE 0x0B

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler | cdc_msc_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb cdc device descriptor

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_msc_desc.c.


AT32F435/437 Firmwary Library: cdc_msc_desc.h File Reference

  • middlewares
  • usbd_class
  • composite_cdc_msc
Macros | Variables
cdc_msc_desc.h File Reference

usb cdc descriptor header file More...

#include "cdc_msc_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | CDC_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_CDC_MSC_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_CDC_MSC_PRODUCT_ID 0x5760
#define | USBD_CDC_MSC_CONFIG_DESC_SIZE 106
usb descriptor size define More...
#define | USBD_CDC_SIZ_STRING_LANGID 4
#define | USBD_CDC_SIZ_STRING_SERIAL 0x1A
#define | USBD_CDC_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_CDC_DESC_PRODUCT_STRING "AT32 Composite VCP and MSC "
#define | USBD_CDC_DESC_CONFIGURATION_STRING "Composite VCP and MSC Config"
#define | USBD_CDC_DESC_INTERFACE_STRING "Composite VCP and MSC Interface"
#define | CDC_HID_BINTERVAL_TIME 0xFF
usb endpoint interval define More...
#define | VCPMSC_MSC_INTERFACE 0x00
usb interface define More...
#define | VCPMSC_CDC_INTERFACE 0x01
#define | VCPMSC_CDC_DATA_INTERFACE 0x02
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

usbd_desc_handler cdc_msc_desc_handler
device descriptor handler structure More...

Detailed Description

usb cdc descriptor header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_msc_desc.h.


AT32F435/437 Firmwary Library: msc_bot_scsi.c File Reference

  • middlewares
  • usbd_class
  • composite_cdc_msc
Functions | Variables
composite_cdc_msc/msc_bot_scsi.c File Reference

usb mass storage bulk-only transport and scsi command More...

#include "cdc_msc_class.h"
#include "msc_diskio.h"

Go to the source code of this file.

Functions

void | bot_scsi_init (void *udev)
initialize bulk-only transport and scsi More...
void | bot_scsi_reset (void *udev)
reset bulk-only transport and scsi More...
void | bot_scsi_datain_handler (void *udev, uint8_t ept_num)
bulk-only transport data in handler More...
void | bot_scsi_dataout_handler (void *udev, uint8_t ept_num)
bulk-only transport data out handler More...
void | bot_cbw_decode (void *udev)
bulk-only cbw decode More...
void | bot_scsi_send_data (void *udev, uint8_t *buffer, uint32_t len)
send bot data More...
void | bot_scsi_send_csw (void *udev, uint8_t status)
send command status More...
void | bot_scsi_sense_code (void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code More...
usb_sts_type | bot_scsi_check_address (void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address More...
void | bot_scsi_stall (void *udev)
bot endpoint stall More...
usb_sts_type | bot_scsi_test_unit (void *udev, uint8_t lun)
bulk-only transport scsi command test unit More...
usb_sts_type | bot_scsi_inquiry (void *udev, uint8_t lun)
bulk-only transport scsi command inquiry More...
usb_sts_type | bot_scsi_start_stop (void *udev, uint8_t lun)
bulk-only transport scsi command start stop More...
usb_sts_type | bot_scsi_allow_medium_removal (void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal More...
usb_sts_type | bot_scsi_mode_sense6 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6 More...
usb_sts_type | bot_scsi_mode_sense10 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10 More...
usb_sts_type | bot_scsi_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command capacity More...
usb_sts_type | bot_scsi_format_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command format capacity More...
usb_sts_type | bot_scsi_request_sense (void *udev, uint8_t lun)
bulk-only transport scsi command request sense More...
usb_sts_type | bot_scsi_verify (void *udev, uint8_t lun)
bulk-only transport scsi command verify More...
usb_sts_type | bot_scsi_read10 (void *udev, uint8_t lun)
bulk-only transport scsi command read10 More...
usb_sts_type | bot_scsi_write10 (void *udev, uint8_t lun)
bulk-only transport scsi command write10 More...
void | bot_scsi_clear_feature (void *udev, uint8_t ept_num)
clear feature More...
usb_sts_type | bot_scsi_cmd_process (void *udev)
bulk-only transport scsi command process More...

Variables

ALIGNED_HEAD uint8_t page00_inquiry_data[] ALIGNED_TAIL

Detailed Description

usb mass storage bulk-only transport and scsi command

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file composite_cdc_msc/msc_bot_scsi.c.


AT32F435/437 Firmwary Library: msc_bot_scsi.c File Reference

  • middlewares
  • usbd_class
  • msc
Functions | Variables
msc/msc_bot_scsi.c File Reference

usb mass storage bulk-only transport and scsi command More...

#include "msc_bot_scsi.h"
#include "msc_diskio.h"

Go to the source code of this file.

Functions

void | bot_scsi_init (void *udev)
initialize bulk-only transport and scsi More...
void | bot_scsi_reset (void *udev)
reset bulk-only transport and scsi More...
void | bot_scsi_datain_handler (void *udev, uint8_t ept_num)
bulk-only transport data in handler More...
void | bot_scsi_dataout_handler (void *udev, uint8_t ept_num)
bulk-only transport data out handler More...
void | bot_cbw_decode (void *udev)
bulk-only cbw decode More...
void | bot_scsi_send_data (void *udev, uint8_t *buffer, uint32_t len)
send bot data More...
void | bot_scsi_send_csw (void *udev, uint8_t status)
send command status More...
void | bot_scsi_sense_code (void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code More...
usb_sts_type | bot_scsi_check_address (void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address More...
void | bot_scsi_stall (void *udev)
bot endpoint stall More...
usb_sts_type | bot_scsi_test_unit (void *udev, uint8_t lun)
bulk-only transport scsi command test unit More...
usb_sts_type | bot_scsi_inquiry (void *udev, uint8_t lun)
bulk-only transport scsi command inquiry More...
usb_sts_type | bot_scsi_start_stop (void *udev, uint8_t lun)
bulk-only transport scsi command start stop More...
usb_sts_type | bot_scsi_allow_medium_removal (void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal More...
usb_sts_type | bot_scsi_mode_sense6 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6 More...
usb_sts_type | bot_scsi_mode_sense10 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10 More...
usb_sts_type | bot_scsi_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command capacity More...
usb_sts_type | bot_scsi_format_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command format capacity More...
usb_sts_type | bot_scsi_request_sense (void *udev, uint8_t lun)
bulk-only transport scsi command request sense More...
usb_sts_type | bot_scsi_verify (void *udev, uint8_t lun)
bulk-only transport scsi command verify More...
usb_sts_type | bot_scsi_read10 (void *udev, uint8_t lun)
bulk-only transport scsi command read10 More...
usb_sts_type | bot_scsi_write10 (void *udev, uint8_t lun)
bulk-only transport scsi command write10 More...
void | bot_scsi_clear_feature (void *udev, uint8_t ept_num)
clear feature More...
usb_sts_type | bot_scsi_cmd_process (void *udev)
bulk-only transport scsi command process More...

Variables

ALIGNED_HEAD uint8_t page00_inquiry_data[] ALIGNED_TAIL

Detailed Description

usb mass storage bulk-only transport and scsi command

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file msc/msc_bot_scsi.c.


AT32F435/437 Firmwary Library: custom_hid_class.c File Reference

  • middlewares
  • usbd_class
  • custom_hid
Functions | Variables
custom_hid_class.c File Reference

usb custom hid class type More...

#include "usbd_core.h"
#include "custom_hid_class.h"
#include "custom_hid_desc.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
static void | usb_hid_buf_process (void *udev, uint8_t *report, uint16_t len)
usb device report function More...
usb_sts_type | custom_hid_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

custom_hid_type custom_hid_struct
usbd_class_handler custom_hid_class_handler

Detailed Description

usb custom hid class type

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file custom_hid_class.c.


AT32F435/437 Firmwary Library: custom_hid_class.h File Reference

  • middlewares
  • usbd_class
  • custom_hid
Data Structures | Macros | Functions | Variables
custom_hid_class.h File Reference

usb hid header file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct custom_hid_type

Macros

#define | USBD_CUSTOM_HID_IN_EPT 0x81
usb custom hid use endpoint define More...
#define | USBD_CUSTOM_HID_OUT_EPT 0x01
#define | USBD_CUSTOM_IN_MAXPACKET_SIZE 0x40
usb custom hid in and out max packet size define More...
#define | USBD_CUSTOM_OUT_MAXPACKET_SIZE 0x40

Functions

usb_sts_type custom_hid_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

usbd_class_handler custom_hid_class_handler

Detailed Description

usb hid header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file custom_hid_class.h.


AT32F435/437 Firmwary Library: custom_hid_desc.c File Reference

  • middlewares
  • usbd_class
  • custom_hid
Functions | Variables
custom_hid_desc.c File Reference

usb hid device descriptor More...

#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "custom_hid_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler | custom_hid_desc_handler
custom hid device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb hid device descriptor

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file custom_hid_desc.c.


AT32F435/437 Firmwary Library: custom_hid_desc.h File Reference

  • middlewares
  • usbd_class
  • custom_hid
Macros | Variables
custom_hid_desc.h File Reference

usb custom hid descriptor header file More...

#include "custom_hid_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | CUSHID_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_CUSHID_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_CUSHID_PRODUCT_ID 0x5745
#define | USBD_CUSHID_CONFIG_DESC_SIZE 41
usb descriptor size define More...
#define | USBD_CUSHID_SIZ_REPORT_DESC 126
#define | USBD_CUSHID_SIZ_STRING_LANGID 4
#define | USBD_CUSHID_SIZ_STRING_SERIAL 0x1A
#define | USBD_CUSHID_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_CUSHID_DESC_PRODUCT_STRING "Custom HID"
#define | USBD_CUSHID_DESC_CONFIGURATION_STRING "Custom HID Config"
#define | USBD_CUSHID_DESC_INTERFACE_STRING "Custom HID Interface"
#define | CUSHID_BINTERVAL_TIME 0x0A
#define | HID_REPORT_ID_1 0x01
usb hid report id define More...
#define | HID_REPORT_ID_2 0x02
#define | HID_REPORT_ID_3 0x03
#define | HID_REPORT_ID_4 0x04
#define | HID_REPORT_ID_5 0x05
#define | HID_REPORT_ID_6 0xF0
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

uint8_t | g_usbd_custom_hid_report [126]
usb hid report descriptor More...
uint8_t | g_custom_hid_usb_desc [9]
usb hid descriptor More...
usbd_desc_handler | custom_hid_desc_handler
custom hid device descriptor handler structure More...

Detailed Description

usb custom hid descriptor header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file custom_hid_desc.h.


AT32F435/437 Firmwary Library: hid_iap_class.c File Reference

  • middlewares
  • usbd_class
  • hid_iap
Functions | Variables
hid_iap_class.c File Reference

usb hid iap class type More...

#include "usbd_core.h"
#include "hid_iap_class.h"
#include "hid_iap_desc.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
usb_sts_type | usb_iap_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

iap_info_type iap_info
usbd_class_handler hid_iap_class_handler

Detailed Description

usb hid iap class type

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file hid_iap_class.c.


AT32F435/437 Firmwary Library: hid_iap_class.h File Reference

  • middlewares
  • usbd_class
  • hid_iap
Data Structures | Macros | Enumerations | Functions | Variables
hid_iap_class.h File Reference

usb hid iap header file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct iap_info_type

Macros

#define | USBD_HIDIAP_IN_EPT 0x81
#define | USBD_HIDIAP_OUT_EPT 0x01
#define | USBD_HIDIAP_IN_MAXPACKET_SIZE 0x40
#define | USBD_HIDIAP_OUT_MAXPACKET_SIZE 0x40
#define | FLASH_SIZE_REG() ((*(uint32_t *)0x1FFFF7E0) & 0xFFFF) /*Get Flash size*/
#define | KB_TO_B(kb) ((kb) << 10)
#define | SECTOR_SIZE_1K 0x400
#define | SECTOR_SIZE_2K 0x800
#define | SECTOR_SIZE_4K 0x1000
#define | IAP_CMD_IDLE 0x5AA0
iap command More...
#define | IAP_CMD_START 0x5AA1
#define | IAP_CMD_ADDR 0x5AA2
#define | IAP_CMD_DATA 0x5AA3
#define | IAP_CMD_FINISH 0x5AA4
#define | IAP_CMD_CRC 0x5AA5
#define | IAP_CMD_JMP 0x5AA6
#define | IAP_CMD_GET 0x5AA7
#define | HID_IAP_BUFFER_LEN 1024
#define | IAP_UPGRADE_COMPLETE_FLAG 0x41544B38
#define | CONVERT_ENDIAN(dwValue)
#define | IAP_ACK 0xFF00
#define | IAP_NACK 0x00FF

Enumerations

enum iap_result_type { IAP_SUCCESS , IAP_WAIT , IAP_FAILED }
enum iap_machine_state_type {
IAP_STS_IDLE , IAP_STS_START , IAP_STS_ADDR , IAP_STS_DATA ,
IAP_STS_FINISH , IAP_STS_CRC , IAP_STS_JMP_WAIT , IAP_STS_JMP
}

Functions

usb_sts_type | usb_iap_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
iap_result_type | usbd_hid_iap_process (void *udev, uint8_t *report, uint16_t len)
usb device iap function More...
void | usbd_hid_iap_in_complete (void *udev)
usb device in transfer complete function More...

Variables

usbd_class_handler hid_iap_class_handler
iap_info_type iap_info

Detailed Description

usb hid iap header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file hid_iap_class.h.


AT32F435/437 Firmwary Library: hid_iap_desc.c File Reference

  • middlewares
  • usbd_class
  • hid_iap
Functions | Variables
hid_iap_desc.c File Reference

usb hid iap device descriptor More...

#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "hid_iap_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler | hid_iap_desc_handler
hid device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb hid iap device descriptor

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file hid_iap_desc.c.


AT32F435/437 Firmwary Library: hid_iap_desc.h File Reference

  • middlewares
  • usbd_class
  • hid_iap
Macros | Variables
hid_iap_desc.h File Reference

usb hid iap descriptor header file More...

#include "hid_iap_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | HIDIAP_BCD_NUM 0x0110
#define | USBD_HIDIAP_VENDOR_ID 0x2E3C
#define | USBD_HIDIAP_PRODUCT_ID 0xAF01
#define | USBD_HIDIAP_CONFIG_DESC_SIZE 41
#define | USBD_HIDIAP_SIZ_REPORT_DESC 32
#define | USBD_HIDIAP_SIZ_STRING_LANGID 4
#define | USBD_HIDIAP_SIZ_STRING_SERIAL 0x1A
#define | USBD_HIDIAP_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_HIDIAP_DESC_PRODUCT_STRING "HID IAP"
#define | USBD_HIDIAP_DESC_CONFIGURATION_STRING "HID IAP Config"
#define | USBD_HIDIAP_DESC_INTERFACE_STRING "HID IAP Interface"
#define | HIDIAP_BINTERVAL_TIME 0x01
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

uint8_t | g_usbd_hidiap_report [32]
usb hid report descriptor More...
uint8_t | g_hidiap_usb_desc [9]
usb hid descriptor More...
usbd_desc_handler | hid_iap_desc_handler
hid device descriptor handler structure More...

Detailed Description

usb hid iap descriptor header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file hid_iap_desc.h.


AT32F435/437 Firmwary Library: keyboard_class.c File Reference

  • middlewares
  • usbd_class
  • keyboard
Macros | Functions | Variables
keyboard_class.c File Reference

usb hid keyboard class type More...

#include "usbd_core.h"
#include "keyboard_class.h"
#include "keyboard_desc.h"

Go to the source code of this file.

Macros

#define SHIFT 0x80

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
usb_sts_type | usb_keyboard_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_hid_keyboard_send_char (void *udev, uint8_t ascii_code)
usb device class report function More...

Variables

keyboard_type keyboard_struct
static const unsigned char | _asciimap [128]
usbd_class_handler | keyboard_class_handler

Detailed Description

usb hid keyboard class type

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file keyboard_class.c.


AT32F435/437 Firmwary Library: keyboard_class.h File Reference

  • middlewares
  • usbd_class
  • keyboard
Data Structures | Macros | Functions | Variables
keyboard_class.h File Reference

usb hid keyboard header file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct keyboard_type

Macros

#define | USBD_KEYBOARD_IN_EPT 0x81
usb hid use endpoint define More...
#define | USBD_KEYBOARD_IN_MAXPACKET_SIZE 0x40
usb hid in and out max packet size define More...
#define | USBD_KEYBOARD_OUT_MAXPACKET_SIZE 0x40

Functions

usb_sts_type | usb_keyboard_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_hid_keyboard_send_char (void *udev, uint8_t ascii_code)
usb device class report function More...

Variables

usbd_class_handler keyboard_class_handler

Detailed Description

usb hid keyboard header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file keyboard_class.h.


AT32F435/437 Firmwary Library: keyboard_desc.c File Reference

  • middlewares
  • usbd_class
  • keyboard
Functions | Variables
keyboard_desc.c File Reference

usb hid keyboard device descriptor More...

#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "keyboard_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler | keyboard_desc_handler
keyboard device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb hid keyboard device descriptor

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file keyboard_desc.c.


AT32F435/437 Firmwary Library: keyboard_desc.h File Reference

  • middlewares
  • usbd_class
  • keyboard
Macros | Variables
keyboard_desc.h File Reference

usb keyboard descriptor header file More...

#include "keyboard_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | KEYBOARD_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_KEYBOARD_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_KEYBOARD_PRODUCT_ID 0x6040
#define | USBD_KEYBOARD_CONFIG_DESC_SIZE 34
usb descriptor size define More...
#define | USBD_KEYBOARD_SIZ_REPORT_DESC 63
#define | USBD_KEYBOARD_SIZ_STRING_LANGID 4
#define | USBD_KEYBOARD_SIZ_STRING_SERIAL 0x1A
#define | USBD_KEYBOARD_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_KEYBOARD_DESC_PRODUCT_STRING "Keyboard"
#define | USBD_KEYBOARD_DESC_CONFIGURATION_STRING "Keyboard Config"
#define | USBD_KEYBOARD_DESC_INTERFACE_STRING "Keyboard Interface"
#define | KEYBOARD_BINTERVAL_TIME 0x0A
usb hid endpoint interval define More...
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

uint8_t | g_usbd_keyboard_report [63]
usb mouse report descriptor More...
uint8_t | g_keyboard_usb_desc [9]
usb hid descriptor More...
usbd_desc_handler | keyboard_desc_handler
keyboard device descriptor handler structure More...

Detailed Description

usb keyboard descriptor header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file keyboard_desc.h.


AT32F435/437 Firmwary Library: mouse_class.c File Reference

  • middlewares
  • usbd_class
  • mouse
Functions | Variables
mouse_class.c File Reference

usb hid mouse class type More...

#include "usbd_core.h"
#include "mouse_class.h"
#include "mouse_desc.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
usb_sts_type | usb_mouse_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_hid_mouse_send (void *udev, uint8_t op)
usb device class report function More...

Variables

mouse_type mouse_struct
usbd_class_handler mouse_class_handler

Detailed Description

usb hid mouse class type

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file mouse_class.c.


AT32F435/437 Firmwary Library: mouse_class.h File Reference

  • middlewares
  • usbd_class
  • mouse
Data Structures | Macros | Functions | Variables
mouse_class.h File Reference

usb hid mouse header file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct mouse_type

Macros

#define | USBD_MOUSE_IN_EPT 0x81
usb hid use endpoint define More...
#define | USBD_MOUSE_IN_MAXPACKET_SIZE 0x40
usb hid in and out max packet size define More...
#define | MOVE_STEP 20
usb hid mouse operation More...
#define | BUTTON_RELEASE 0
#define | LEFT_BUTTON 1
#define | RIGHT_BUTTON 2
#define | LEFT_MOVE 3
#define | RIGHT_MOVE 4
#define | UP_MOVE 5
#define | DOWN_MOVE 6

Functions

usb_sts_type | usb_mouse_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_hid_mouse_send (void *udev, uint8_t op)
usb device class report function More...

Variables

usbd_class_handler mouse_class_handler

Detailed Description

usb hid mouse header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file mouse_class.h.


AT32F435/437 Firmwary Library: mouse_desc.c File Reference

  • middlewares
  • usbd_class
  • mouse
Functions | Variables
mouse_desc.c File Reference

usb hid mouse device descriptor More...

#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "mouse_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler | mouse_desc_handler
mouse device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb hid mouse device descriptor

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file mouse_desc.c.


AT32F435/437 Firmwary Library: mouse_desc.h File Reference

  • middlewares
  • usbd_class
  • mouse
Macros | Variables
mouse_desc.h File Reference

usb mouse descriptor header file More...

#include "mouse_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | MOUSE_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_MOUSE_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_MOUSE_PRODUCT_ID 0x5710
#define | USBD_MOUSE_CONFIG_DESC_SIZE 34
usb descriptor size define More...
#define | USBD_MOUSE_SIZ_REPORT_DESC 74
#define | USBD_MOUSE_SIZ_STRING_LANGID 4
#define | USBD_MOUSE_SIZ_STRING_SERIAL 0x1A
#define | USBD_MOUSE_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_MOUSE_DESC_PRODUCT_STRING "Mouse"
#define | USBD_MOUSE_DESC_CONFIGURATION_STRING "Mouse Config"
#define | USBD_MOUSE_DESC_INTERFACE_STRING "Mouse Interface"
#define | MOUSE_BINTERVAL_TIME 0x0A
usb hid endpoint interval define More...
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

uint8_t | g_usbd_mouse_report [74]
usb mouse report descriptor More...
uint8_t | g_mouse_usb_desc [9]
usb hid descriptor More...
usbd_desc_handler | mouse_desc_handler
mouse device descriptor handler structure More...

Detailed Description

usb mouse descriptor header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file mouse_desc.h.


AT32F435/437 Firmwary Library: msc_bot_scsi.h File Reference

  • middlewares
  • usbd_class
  • msc
Data Structures | Macros | Functions
msc_bot_scsi.h File Reference

usb mass storage bulk-only transport and scsi command header file More...

#include "msc_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct | cbd_typical_type
typical command block description More...
struct | cbd_extended_type
extended command block description More...
struct | cbw_type
command block wrapper More...
struct | csw_type
command block wrapper More...
struct | sense_type
request sense standard data More...
struct | msc_type

Macros

#define | MSC_SUPPORT_MAX_LUN 1
#define | MSC_MAX_DATA_BUF_LEN 4096
#define | MSC_CMD_FORMAT_UNIT 0x04
#define | MSC_CMD_INQUIRY 0x12
#define | MSC_CMD_START_STOP 0x1B
#define | MSC_CMD_MODE_SENSE6 0x1A
#define | MSC_CMD_MODE_SENSE10 0x5A
#define | MSC_CMD_ALLOW_MEDIUM_REMOVAL 0x1E
#define | MSC_CMD_READ_10 0x28
#define | MSC_CMD_READ_12 0xA8
#define | MSC_CMD_READ_CAPACITY 0x25
#define | MSC_CMD_READ_FORMAT_CAPACITY 0x23
#define | MSC_CMD_REQUEST_SENSE 0x03
#define | MSC_CMD_TEST_UNIT 0x00
#define | MSC_CMD_VERIFY 0x2F
#define | MSC_CMD_WRITE_10 0x2A
#define | MSC_CMD_WRITE_12 0xAA
#define | MSC_CMD_WRITE_VERIFY 0x2E
#define | MSC_REQ_GET_MAX_LUN 0xFE
#define | MSC_REQ_BO_RESET 0xFF
#define | SET_LINE_CODING 0x20
#define | GET_LINE_CODING 0x21
#define | CBW_CMD_LENGTH 31
#define | CBW_DCBWSIGNATURE 0x43425355
#define | CBW_BMCBWFLAGS_DIR_OUT 0x00
#define | CBW_BMCBWFLAGS_DIR_IN 0x80
#define | CSW_CMD_LENGTH 13
#define | CSW_DCSWSIGNATURE 0x53425355
#define | CSW_BCSWSTATUS_PASS 0x00
#define | CSW_BCSWSTATUS_FAILED 0x01
#define | CSW_BCSWSTATUS_PHASE_ERR 0x02
#define | MSC_STATE_MACHINE_CMD 0x00
#define | MSC_STATE_MACHINE_DATA_IN 0x01
#define | MSC_STATE_MACHINE_DATA_OUT 0x02
#define | MSC_STATE_MACHINE_SEND_DATA 0x03
#define | MSC_STATE_MACHINE_LAST_DATA 0x04
#define | MSC_STATE_MACHINE_STATUS 0x05
#define | MSC_STATE_MACHINE_FAILED 0x06
#define | MSC_STATE_MACHINE_IDLE 0x07
#define | MSC_BOT_STATE_IDLE 0x00
#define | MSC_BOT_STATE_RECOVERY 0x01
#define | MSC_BOT_STATE_ERROR 0x02
#define | REQ_SENSE_STANDARD_DATA_LEN 0x12
#define | SENSE_KEY_NO_SENSE 0x00
#define | SENSE_KEY_RECOVERED_ERROR 0x01
#define | SENSE_KEY_NOT_READY 0x02
#define | SENSE_KEY_MEDIUM_ERROR 0x03
#define | SENSE_KEY_HARDWARE_ERROR 0x04
#define | SENSE_KEY_ILLEGAL_REQUEST 0x05
#define | SENSE_KEY_UNIT_ATTENTION 0x06
#define | SENSE_KEY_DATA_PROTECT 0x07
#define | SENSE_KEY_BLANK_CHECK 0x08
#define | SENSE_KEY_VENDERO_SPECIFIC 0x09
#define | SENSE_KEY_ABORTED_COMMAND 0x0B
#define | SENSE_KEY_VOLUME_OVERFLOW 0x0D
#define | SENSE_KEY_MISCOMPARE 0x0E
#define | INVALID_COMMAND 0x20
#define | INVALID_FIELED_IN_COMMAND 0x24
#define | PARAMETER_LIST_LENGTH_ERROR 0x1A
#define | INVALID_FIELD_IN_PARAMETER_LIST 0x26
#define | ADDRESS_OUT_OF_RANGE 0x21
#define | MEDIUM_NOT_PRESENT 0x3A
#define | MEDIUM_HAVE_CHANGED 0x28
#define | SCSI_INQUIRY_DATA_LENGTH 36

Functions

void | bot_scsi_init (void *udev)
initialize bulk-only transport and scsi More...
void | bot_scsi_reset (void *udev)
reset bulk-only transport and scsi More...
void | bot_scsi_datain_handler (void *pudev, uint8_t ept_num)
bulk-only transport data in handler More...
void | bot_scsi_dataout_handler (void *pudev, uint8_t ept_num)
bulk-only transport data out handler More...
void | bot_cbw_decode (void *udev)
bulk-only cbw decode More...
void | bot_scsi_send_data (void *udev, uint8_t *buffer, uint32_t len)
send bot data More...
void | bot_scsi_send_csw (void *udev, uint8_t status)
send command status More...
void | bot_scsi_sense_code (void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code More...
usb_sts_type | bot_scsi_check_address (void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address More...
void | bot_scsi_stall (void *udev)
bot endpoint stall More...
usb_sts_type | bot_scsi_cmd_process (void *udev)
bulk-only transport scsi command process More...
usb_sts_type | bot_scsi_test_unit (void *udev, uint8_t lun)
bulk-only transport scsi command test unit More...
usb_sts_type | bot_scsi_inquiry (void *udev, uint8_t lun)
bulk-only transport scsi command inquiry More...
usb_sts_type | bot_scsi_start_stop (void *udev, uint8_t lun)
bulk-only transport scsi command start stop More...
usb_sts_type | bot_scsi_allow_medium_removal (void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal More...
usb_sts_type | bot_scsi_mode_sense6 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6 More...
usb_sts_type | bot_scsi_mode_sense10 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10 More...
usb_sts_type | bot_scsi_read10 (void *udev, uint8_t lun)
bulk-only transport scsi command read10 More...
usb_sts_type | bot_scsi_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command capacity More...
usb_sts_type | bot_scsi_format_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command format capacity More...
usb_sts_type | bot_scsi_request_sense (void *udev, uint8_t lun)
bulk-only transport scsi command request sense More...
usb_sts_type | bot_scsi_verify (void *udev, uint8_t lun)
bulk-only transport scsi command verify More...
usb_sts_type | bot_scsi_write10 (void *udev, uint8_t lun)
bulk-only transport scsi command write10 More...
void | bot_scsi_clear_feature (void *udev, uint8_t ept_num)
clear feature More...

Detailed Description

usb mass storage bulk-only transport and scsi command header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file msc_bot_scsi.h.


AT32F435/437 Firmwary Library: msc_class.c File Reference

  • middlewares
  • usbd_class
  • msc
Functions | Variables
msc_class.c File Reference

usb msc class type More...

#include "usbd_core.h"
#include "msc_class.h"
#include "msc_desc.h"
#include "msc_bot_scsi.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...

Variables

msc_type msc_struct
usbd_class_handler msc_class_handler

Detailed Description

usb msc class type

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file msc_class.c.


AT32F435/437 Firmwary Library: msc_class.h File Reference

  • middlewares
  • usbd_class
  • msc
Macros | Variables
msc_class.h File Reference

usb msc class file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | USBD_MSC_BULK_IN_EPT 0x81
#define | USBD_MSC_BULK_OUT_EPT 0x01
#define | USBD_IN_MAXPACKET_SIZE 0x40
#define | USBD_OUT_MAXPACKET_SIZE 0x40

Variables

usbd_class_handler msc_class_handler

Detailed Description

usb msc class file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file msc_class.h.


AT32F435/437 Firmwary Library: msc_desc.c File Reference

  • middlewares
  • usbd_class
  • msc
Functions | Variables
msc_desc.c File Reference

usb msc device descriptor More...

#include "stdio.h"
#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "msc_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler | msc_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb msc device descriptor

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file msc_desc.c.


AT32F435/437 Firmwary Library: msc_desc.h File Reference

  • middlewares
  • usbd_class
  • msc
Macros | Variables
msc_desc.h File Reference

usb msc descriptor header file More...

#include "msc_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | MSC_BCD_NUM 0x0110
#define | USBD_MSC_VENDOR_ID 0x2E3C
#define | USBD_MSC_PRODUCT_ID 0x5720
#define | USBD_MSC_CONFIG_DESC_SIZE 32
#define | USBD_MSC_SIZ_STRING_LANGID 4
#define | USBD_MSC_SIZ_STRING_SERIAL 0x1A
#define | USBD_MSC_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_MSC_DESC_PRODUCT_STRING "AT32 Mass Storage"
#define | USBD_MSC_DESC_CONFIGURATION_STRING "Mass Storage Config"
#define | USBD_MSC_DESC_INTERFACE_STRING "Mass Storage Interface"
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

usbd_desc_handler msc_desc_handler
device descriptor handler structure More...

Detailed Description

usb msc descriptor header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file msc_desc.h.


AT32F435/437 Firmwary Library: printer_class.c File Reference

  • middlewares
  • usbd_class
  • printer
Functions | Variables
printer_class.c File Reference

usb printer class type More...

#include "usbd_core.h"
#include "printer_class.h"
#include "printer_desc.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
error_status | usb_printer_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

static ALIGNED_HEAD uint8_t printer_device_id[24] | ALIGNED_TAIL
printer_type printer_struct
usbd_class_handler | printer_class_handler

Detailed Description

usb printer class type

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file printer_class.c.


AT32F435/437 Firmwary Library: printer_class.h File Reference

  • middlewares
  • usbd_class
  • printer
Data Structures | Macros | Enumerations | Functions | Variables
printer_class.h File Reference

usb cdc class file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct printer_type

Macros

#define | USBD_PRINTER_BULK_IN_EPT 0x81
#define | USBD_PRINTER_BULK_OUT_EPT 0x01
#define | USBD_PRINTER_IN_MAXPACKET_SIZE 0x40
#define | USBD_PRINTER_OUT_MAXPACKET_SIZE 0x40
#define | PRINTER_DEVICE_ID_LEN 24

Enumerations

enum printer_req_type { PRINTER_REQ_GET_DEVICE_ID = 0x00 , PRINTER_REQ_GET_PORT_STATUS = 0x01 , PRINTER_REQ_GET_SOFT_RESET = 0x02 }

Functions

uint16_t | usb_printer_get_rxdata (void *udev, uint8_t *recv_data)
error_status | usb_printer_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

usbd_class_handler printer_class_handler

Detailed Description

usb cdc class file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file printer_class.h.


AT32F435/437 Firmwary Library: printer_desc.c File Reference

  • middlewares
  • usbd_class
  • printer
Functions | Variables
printer_desc.c File Reference

usb printer device descriptor More...

#include "stdio.h"
#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "printer_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler | printer_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb printer device descriptor

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file printer_desc.c.


AT32F435/437 Firmwary Library: printer_desc.h File Reference

  • middlewares
  • usbd_class
  • printer
Macros | Variables
printer_desc.h File Reference

usb printer descriptor header file More...

#include "printer_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | PRINTER_BCD_NUM 0x0110
#define | USBD_PRINTER_VENDOR_ID 0x2E3C
#define | USBD_PRINTER_PRODUCT_ID 0x57FF
#define | USBD_PRINTER_CONFIG_DESC_SIZE 32
#define | USBD_PRINTER_SIZ_STRING_LANGID 4
#define | USBD_PRINTER_SIZ_STRING_SERIAL 0x1A
#define | USBD_PRINTER_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_PRINTER_DESC_PRODUCT_STRING "AT32 Printer"
#define | USBD_PRINTER_DESC_CONFIGURATION_STRING "Printer Config"
#define | USBD_PRINTER_DESC_INTERFACE_STRING "Printer Interface"
#define | PRINTER_PROTOCOL_UNIDIRECTIONAL 0x01
#define | PRINTER_PROTOCOL_BI_DIRECTIONAL 0x02
#define | PRINTER_PROTOCOL_1284_4 0x03
#define | PRINTER_PROTOCOL_VENDOR_SPECIFIC 0xFF
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

usbd_desc_handler printer_desc_handler
device descriptor handler structure More...

Detailed Description

usb printer descriptor header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file printer_desc.h.


AT32F435/437 Firmwary Library: usbh_hid_class.c File Reference

  • middlewares
  • usbh_class
  • usbh_hid
Functions | Variables
usbh_hid_class.c File Reference

usb host hid class type More...

#include "usbh_hid_class.h"
#include "usb_conf.h"
#include "usbh_core.h"
#include "usbh_ctrl.h"
#include "usbh_hid_mouse.h"
#include "usbh_hid_keyboard.h"

Go to the source code of this file.

Functions

static usb_sts_type | uhost_init_handler (void *uhost)
usb host class init handler More...
static usb_sts_type | uhost_reset_handler (void *uhost)
usb host class reset handler More...
static usb_sts_type | uhost_request_handler (void *uhost)
usb host hid class request handler More...
static usb_sts_type | uhost_process_handler (void *uhost)
usb host hid class process handler More...
usb_sts_type | usbh_hid_get_desc (void *uhost, uint16_t length)
usb host hid class get descriptor More...
usb_sts_type | usbh_hid_get_report (void *uhost, uint16_t length)
usb host hid class get report More...
usb_sts_type | usbh_hid_set_idle (void *uhost, uint8_t id, uint8_t dr)
usb host hid class set idle More...
usb_sts_type | usbh_hid_set_protocol (void *uhost, uint8_t protocol)
usb host hid class set protocol More...
usb_sts_type | usbh_clear_endpoint_feature (usbh_core_type *uhost, uint8_t ept_num, uint8_t hc_num)
usb host clear feature More...

Variables

usbh_hid_type usbh_hid
usbh_class_handler_type uhost_hid_class_handler

Detailed Description

usb host hid class type

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbh_hid_class.c.


AT32F435/437 Firmwary Library: usbh_hid_class.h File Reference

  • middlewares
  • usbh_class
  • usbh_hid
Data Structures | Macros | Enumerations | Variables
usbh_hid_class.h File Reference

usb host hid class header file More...

#include "usbh_core.h"
#include "usb_conf.h"

Go to the source code of this file.

Data Structures

struct | usb_hid_desc_type
usb hid descriptor type More...
struct | usbh_hid_type
usb hid struct More...

Macros

#define | USB_HID_NONE_PROTOCOL_CODE 0x00
usb hid protocol code More...
#define | USB_HID_KEYBOARD_PROTOCOL_CODE 0x01
#define | USB_HID_MOUSE_PROTOCOL_CODE 0x02
#define | USB_HID_GET_REPORT 0x01
usb hid request code More...
#define | USB_HID_GET_IDLE 0x02
#define | USB_HID_GET_PROTOCOL 0x03
#define | USB_HID_SET_REPORT 0x09
#define | USB_HID_SET_IDLE 0x0A
#define | USB_HID_SET_PROTOCOL 0x0B

Enumerations

enum usb_hid_ctrl_state_type {
USB_HID_STATE_IDLE , USB_HID_STATE_GET_DESC , USB_HID_STATE_GET_REPORT , USB_HID_STATE_SET_IDLE ,
USB_HID_STATE_SET_PROTOCOL , USB_HID_STATE_COMPLETE
}
usb hid request state More...
enum usb_hid_state_type {
USB_HID_INIT , USB_HID_GET , USB_HID_SEND , USB_HID_POLL ,
USB_HID_BUSY , USB_HID_ERROR
}
usb hid process state More...

Variables

usbh_class_handler_type uhost_hid_class_handler

Detailed Description

usb host hid class header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbh_hid_class.h.


AT32F435/437 Firmwary Library: usbh_hid_keyboard.c File Reference

  • middlewares
  • usbh_class
  • usbh_hid
Functions | Variables
usbh_hid_keyboard.c File Reference

usb host hid keyboard type More...

#include "usbh_hid_keyboard.h"

Go to the source code of this file.

Functions

void usbh_hid_keyboard_decode (uint8_t *data)
usb host hid keyboard decode More...

Variables

static const uint8_t | hid_keyboard_codes []
static const int8_t | hid_keyboard_key []
static const int8_t | hid_keyboard_key_shift []

Detailed Description

usb host hid keyboard type

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbh_hid_keyboard.c.


AT32F435/437 Firmwary Library: usbh_hid_keyboard.h File Reference

  • middlewares
  • usbh_class
  • usbh_hid
Macros | Functions
usbh_hid_keyboard.h File Reference

usb host hid keyboard header file More...

#include "usb_conf.h"

Go to the source code of this file.

Macros

#define | KEYBOARD_LEFT_CTRL 0x01
usb keyboard option code More...
#define | KEYBOARD_LEFT_SHIFT 0x02
#define | KEYBOARD_LEFT_ALT 0x04
#define | KEYBOARD_LEFT_GUI 0x08
#define | KEYBOARD_RIGHT_CTRL 0x10
#define | KEYBOARD_RIGHT_SHIFT 0x20
#define | KEYBOARD_RIGHT_ALT 0x40
#define | KEYBOARD_RIGHT_GUI 0x80
#define | KEYBOARD_MAX_NB_PRESSED 6
#define | QWERTY_KEYBOARD

Functions

void usbh_hid_keyboard_decode (uint8_t *data)
usb host hid keyboard decode More...

Detailed Description

usb host hid keyboard header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbh_hid_keyboard.h.


AT32F435/437 Firmwary Library: usbh_hid_mouse.c File Reference

  • middlewares
  • usbh_class
  • usbh_hid
Functions | Variables
usbh_hid_mouse.c File Reference

usb host hid mouse type More...

#include "usbh_hid_mouse.h"

Go to the source code of this file.

Functions

void | usbh_hid_mouse_position (uint8_t x, uint8_t y)
usb host hid position More...
void | usbh_hid_mouse_button_press (uint8_t button)
usb host hid button press More...
void | usbh_hid_mouse_button_release (uint8_t button)
usb host hid button release More...
void | usbh_hid_mouse_process (usb_hid_mouse_type *mouse)
usb host hid mouse process More...
void | usbh_hid_mouse_decode (uint8_t *mouse_data)
usb host hid mouse decode More...

Variables

usb_hid_mouse_type hid_mouse
uint16_t | x_pos = 0
uint16_t | y_pos = 0

Detailed Description

usb host hid mouse type

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbh_hid_mouse.c.


AT32F435/437 Firmwary Library: usbh_hid_mouse.h File Reference

  • middlewares
  • usbh_class
  • usbh_hid
Data Structures | Macros | Functions
usbh_hid_mouse.h File Reference

usb host hid mouse header file More...

#include "usb_conf.h"

Go to the source code of this file.

Data Structures

struct usb_hid_mouse_type
usb hid mouse type More...

Macros

#define | MOUSE_WINDOW_X 100
usb hid mouse x y More...
#define | MOUSE_WINDOW_Y 220
#define | MOUSE_WINDOW_HEIGHT 90
#define | MOUSE_WINDOW_WIDTH 128
#define | MOUSE_BUTTON_LEFT 0x00
usb hid mouse button More...
#define | MOUSE_BUTTON_RIGHT 0x01
#define | MOUSE_BUTTON_MIDDLE 0x02

Functions

void usbh_hid_mouse_decode (uint8_t *mouse_data)
usb host hid mouse decode More...

Detailed Description

usb host hid mouse header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbh_hid_mouse.h.


AT32F435/437 Firmwary Library: usbh_msc_bot_scsi.c File Reference

  • middlewares
  • usbh_class
  • usbh_msc
Functions
usbh_msc_bot_scsi.c File Reference

usb host msc bulk-only transfer and scsi type More...

#include "usbh_msc_bot_scsi.h"
#include "usbh_msc_class.h"
#include "usb_conf.h"
#include "usbh_core.h"
#include "usbh_ctrl.h"

Go to the source code of this file.

Functions

static usb_sts_type | usbh_bot_cbw (msc_bot_cbw_type *cbw, uint32_t data_length, uint8_t cmd_len, uint8_t flag)
usb host bulk-only cbw More...
static usb_sts_type | usbh_cmd_inquiry (msc_bot_trans_type *bot_trans, uint8_t *cmd, uint8_t lun)
usb host msc command inquiry More...
static usb_sts_type | usbh_cmd_capacity10 (msc_bot_trans_type *bot_trans, uint8_t *cmd, uint8_t lun)
usb host msc command capacity10 More...
static usb_sts_type | usbh_cmd_test_unit_ready (msc_bot_trans_type *bot_trans, uint8_t *cmd, uint8_t lun)
usb host msc command test unit ready More...
static usb_sts_type | usbh_cmd_requset_sense (msc_bot_trans_type *bot_trans, uint8_t *cmd, uint8_t lun)
usb host msc command request sense More...
static usb_sts_type | usbh_cmd_write (msc_bot_trans_type *bot_trans, uint8_t *cmd, uint8_t lun, uint32_t data_len, uint32_t address, uint8_t *buffer)
usb host msc command write More...
static usb_sts_type | usbh_cmd_read (msc_bot_trans_type *bot_trans, uint8_t *cmd, uint8_t lun, uint32_t data_len, uint32_t address, uint8_t *buffer)
usb host msc command read More...
usb_sts_type | usbh_check_csw (void *uhost, msc_bot_cbw_type *cbw, msc_bot_csw_type *csw)
usb host csw check More...
usb_sts_type | usb_bot_request (void *uhost, msc_bot_trans_type *bot_trans)
usb host msc bulk-only request More...
usb_sts_type | usbh_msc_bot_scsi_get_inquiry (void *uhost, msc_bot_trans_type *bot_trans, uint8_t lun, msc_scsi_data_inquiry *inquiry)
usb host msc bulk-only get inquiry request More...
usb_sts_type | usbh_msc_bot_scsi_capacity (void *uhost, msc_bot_trans_type *bot_trans, uint8_t lun, msc_scsi_data_capacity *capacity)
usb host msc bulk-only capacity request More...
usb_sts_type | usbh_msc_bot_scsi_test_unit_ready (void *uhost, msc_bot_trans_type *bot_trans, uint8_t lun)
usb host msc bulk-only tet unit ready request More...
usb_sts_type | usbh_msc_bot_scsi_request_sense (void *uhost, msc_bot_trans_type *bot_trans, uint8_t lun)
usb host msc bulk-only request sense request More...
usb_sts_type | usbh_msc_bot_scsi_write (void *uhost, msc_bot_trans_type *bot_trans, uint32_t address, uint8_t *write_data, uint32_t write_len, uint8_t lun)
usb host msc bulk-only write request More...
usb_sts_type | usbh_msc_bot_scsi_read (void *uhost, msc_bot_trans_type *bot_trans, uint32_t address, uint8_t *read_data, uint32_t read_len, uint8_t lun)
usb host msc bulk-only read request More...
usb_sts_type msc_bot_scsi_init (usbh_msc_type *msc_struct)
usb host msc init More...

Detailed Description

usb host msc bulk-only transfer and scsi type

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbh_msc_bot_scsi.c.


AT32F435/437 Firmwary Library: usbh_msc_bot_scsi.h File Reference

  • middlewares
  • usbh_class
  • usbh_msc
Data Structures | Macros | Enumerations | Functions
usbh_msc_bot_scsi.h File Reference

usb host msc bulk-only transfer and scsi header file More...

#include "usbh_core.h"
#include "usb_conf.h"

Go to the source code of this file.

Data Structures

struct | msc_scsi_data_inquiry
usb msc inquiry data type More...
struct | msc_scsi_data_capacity
usb msc capacity data type More...
struct | msc_bot_cbw_type
usb msc bulk-only command block wrapper type More...
struct | msc_bot_csw_type
usb msc bulk-only command status wrapper type More...
struct | msc_bot_trans_type
usb msc bulk-only transfer control type More...
struct | usbh_msc_unit_type
usb msc bank type More...

Macros

#define | MSC_CBW_SIGNATURE 0x43425355
#define | MSC_CSW_SIGNATURE 0x53425355
#define | MSC_CBW_TAG 0x50607080
#define | MSC_CBW_FLAG_IN 0x80
#define | MSC_CBW_FLAG_OUT 0x00
#define | MSC_CBW_LEN 31
#define | MSC_CSW_LEN 13
#define | MSC_CBW_CB_LEN 16
#define | MSC_TEST_UNIT_READY_CMD_LEN 12
#define | MSC_TEST_UNIT_READY_DATA_LEN 0
#define | MSC_INQUIRY_CMD_LEN 12
#define | MSC_INQUIRY_DATA_LEN 36
#define | MSC_CAPACITY10_CMD_LEN 12
#define | MSC_CAPACITY10_DATA_LEN 8
#define | MSC_REQUEST_SENSE_CMD_LEN 12
#define | MSC_REQUEST_SENSE_DATA_LEN 18
#define | MSC_WRITE_CMD_LEN 12
#define | MSC_READ_CMD_LEN 10
#define | MSC_OPCODE_INQUIRY 0x12
#define | MSC_OPCODE_CAPACITY 0x25
#define | MSC_OPCODE_TEST_UNIT_READY 0x00
#define | MSC_OPCODE_REQUEST_SENSE 0x03
#define | MSC_OPCODE_WRITE10 0x2A
#define | MSC_OPCODE_READ10 0x28

Enumerations

enum msc_bot_state_type {
BOT_STATE_IDLE , BOT_STATE_SEND_CBW , BOT_STATE_SEND_CBW_WAIT , BOT_STATE_DATA_IN ,
BOT_STATE_DATA_IN_WAIT , BOT_STATE_DATA_OUT , BOT_STATE_DATA_OUT_WAIT , BOT_STATE_RECV_CSW ,
BOT_STATE_RECV_CSW_WAIT , BOT_STATE_ERROR_IN , BOT_STATE_ERROR_OUT , BOT_STATE_COMPLETE
}
enum | msc_cmd_state_type { CMD_STATE_SEND , CMD_STATE_WAIT }
enum msc_state_type {
USBH_MSC_INIT , USBH_MSC_INQUIRY , USBH_MSC_TEST_UNIT_READY , USBH_MSC_READ_CAPACITY10 ,
USBH_MSC_REQUEST_SENSE , USBH_MSC_READ10 , USBH_MSC_WRITE , USBH_MSC_BUSY ,
USBH_MSC_ERROR , USBH_MSC_IDLE
}
usb msc process state More...
enum | msc_error_type { MSC_OK , MSC_NOT_READY , MSC_ERROR }

Functions

usb_sts_type | usb_bot_request (void *uhost, msc_bot_trans_type *bot_trans)
usb host msc bulk-only request More...
usb_sts_type | usbh_msc_bot_scsi_get_inquiry (void *uhost, msc_bot_trans_type *bot_trans, uint8_t lun, msc_scsi_data_inquiry *inquiry)
usb host msc bulk-only get inquiry request More...
usb_sts_type | usbh_msc_bot_scsi_capacity (void *uhost, msc_bot_trans_type *bot_trans, uint8_t lun, msc_scsi_data_capacity *capacity)
usb host msc bulk-only capacity request More...
usb_sts_type | usbh_msc_bot_scsi_test_unit_ready (void *uhost, msc_bot_trans_type *bot_trans, uint8_t lun)
usb host msc bulk-only tet unit ready request More...
usb_sts_type | usbh_msc_bot_scsi_request_sense (void *uhost, msc_bot_trans_type *bot_trans, uint8_t lun)
usb host msc bulk-only request sense request More...
usb_sts_type | usbh_msc_bot_scsi_write (void *uhost, msc_bot_trans_type *bot_trans, uint32_t address, uint8_t *write_data, uint32_t write_len, uint8_t lun)
usb host msc bulk-only write request More...
usb_sts_type | usbh_msc_bot_scsi_read (void *uhost, msc_bot_trans_type *bot_trans, uint32_t address, uint8_t *read_data, uint32_t read_len, uint8_t lun)
usb host msc bulk-only read request More...

Detailed Description

usb host msc bulk-only transfer and scsi header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbh_msc_bot_scsi.h.


AT32F435/437 Firmwary Library: usbh_msc_class.c File Reference

  • middlewares
  • usbh_class
  • usbh_msc
Functions | Variables
usbh_msc_class.c File Reference

usb host msc class type More...

#include "usbh_msc_class.h"
#include "usb_conf.h"
#include "usbh_core.h"
#include "usbh_ctrl.h"

Go to the source code of this file.

Functions

static usb_sts_type | uhost_init_handler (void *uhost)
usb host class init handler More...
static usb_sts_type | uhost_reset_handler (void *uhost)
usb host class reset handler More...
static usb_sts_type | uhost_request_handler (void *uhost)
usb host hid class request handler More...
static usb_sts_type | uhost_process_handler (void *uhost)
usb host class process handler More...
static usb_sts_type | usbh_msc_get_max_lun (void *uhost, uint8_t *lun)
usb host msc get max lun More...
static usb_sts_type | usbh_msc_clear_feature (void *uhost, uint8_t ept_num)
usb host msc clear feature More...
msc_error_type | usbh_msc_is_ready (void *uhost, uint8_t lun)
usb host msc clear feature More...
usb_sts_type | usbh_msc_rw_handle (void *uhost, uint32_t address, uint32_t len, uint8_t *buffer, uint8_t lun)
usb host msc read and write handle More...
usb_sts_type | usbh_msc_read (void *uhost, uint32_t address, uint32_t len, uint8_t *buffer, uint8_t lun)
usb host msc read More...
usb_sts_type | usbh_msc_write (void *uhost, uint32_t address, uint32_t len, uint8_t *buffer, uint8_t lun)
usb host msc write More...

Variables

usbh_msc_type usbh_msc
usbh_class_handler_type uhost_msc_class_handler

Detailed Description

usb host msc class type

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbh_msc_class.c.


AT32F435/437 Firmwary Library: usbh_msc_class.h File Reference

  • middlewares
  • usbh_class
  • usbh_msc
Data Structures | Macros | Enumerations | Functions | Variables
usbh_msc_class.h File Reference

usb host msc class header file More...

#include "usbh_core.h"
#include "usb_conf.h"
#include "usbh_msc_bot_scsi.h"

Go to the source code of this file.

Data Structures

struct usbh_msc_type
usb msc struct More...

Macros

#define | MSC_SUBCLASS_SCSI_TRANS 0x06
usb msc subclass code More...
#define | MSC_PROTOCOL_BBB 0x50
usb msc protocol code More...
#define | MSC_REQ_GET_MAX_LUN 0xFE
usb msc request code More...
#define | MSC_REQ_BOMSR 0xFF
#define | USB_HID_GET_REPORT 0x01
usb hid request code More...
#define | USB_HID_GET_IDLE 0x02
#define | USB_HID_GET_PROTOCOL 0x03
#define | USB_HID_SET_REPORT 0x09
#define | USB_HID_SET_IDLE 0x0A
#define | USB_HID_SET_PROTOCOL 0x0B
#define | USBH_SUPPORT_MAX_LUN 0x2

Enumerations

enum usbh_msc_ctrl_state_type { USBH_MSC_STATE_IDLE , USBH_MSC_STATE_GET_LUN , USBH_MSC_STATE_ERROR , USBH_MSC_STATE_COMPLETE }
usb msc request state More...

Functions

msc_error_type | usbh_msc_is_ready (void *uhost, uint8_t lun)
usb host msc clear feature More...
usb_sts_type | usbh_msc_write (void *uhost, uint32_t address, uint32_t len, uint8_t *buffer, uint8_t lun)
usb host msc write More...
usb_sts_type | usbh_msc_read (void *uhost, uint32_t address, uint32_t len, uint8_t *buffer, uint8_t lun)
usb host msc read More...
usb_sts_type | usbh_msc_rw_handle (void *uhost, uint32_t address, uint32_t len, uint8_t *buffer, uint8_t lun)
usb host msc read and write handle More...
usb_sts_type msc_bot_scsi_init (usbh_msc_type *msc_struct)
usb host msc init More...

Variables

usbh_class_handler_type uhost_msc_class_handler
usbh_msc_type usbh_msc

Detailed Description

usb host msc class header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbh_msc_class.h.


AT32F435/437 Firmwary Library: at32f435_437_board.c File Reference

  • project
  • at32f435_437_board
Macros | Functions | Variables
at32f435_437_board.c File Reference

set of firmware functions to manage leds and push-button. initialize delay function. More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | STEP_DELAY_MS 50
#define | PUTCHAR_PROTOTYPE int fputc(int ch, FILE *f)

Functions

int | fputc (int ch, FILE *f)
retargets the c library printf function to the usart. More...
void | uart_print_init (uint32_t baudrate)
initialize uart More...
void | at32_board_init ()
board initialize interface init led and button More...
void | at32_button_init (void)
configure button gpio More...
uint8_t | at32_button_state (void)
returns the selected button state More...
button_type at32_button_press ()
returns which button have press down More...
void | at32_led_init (led_type led)
configure led gpio More...
void | at32_led_on (led_type led)
turns selected led on. More...
void | at32_led_off (led_type led)
turns selected led off. More...
void | at32_led_toggle (led_type led)
turns selected led toggle. More...
void | delay_init ()
initialize delay function More...
void | delay_us (uint32_t nus)
inserts a delay time. More...
void | delay_ms (uint16_t nms)
inserts a delay time. More...
void | delay_sec (uint16_t sec)
inserts a delay time. More...

Variables

gpio_type * | led_gpio_port [3] = {LED2_GPIO, LED3_GPIO, LED4_GPIO}
uint16_t | led_gpio_pin [3] = {LED2_PIN, LED3_PIN, LED4_PIN}
crm_periph_clock_type | led_gpio_crm_clk [3] = {LED2_GPIO_CRM_CLK, LED3_GPIO_CRM_CLK, LED4_GPIO_CRM_CLK}
static __IO uint32_t | fac_us
static __IO uint32_t | fac_ms

Detailed Description

set of firmware functions to manage leds and push-button. initialize delay function.

header file for at-start board. set of firmware functions to manage leds and push-button. initialize delay function.

Version
v2.0.9
Date
2022-06-28
        Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_board.c.


AT32F435/437 Firmwary Library: at32f435_437_board.h File Reference

  • at32f435_437_board
Macros | Enumerations | Functions
at32f435_437_board.h File Reference
#include "stdio.h"
#include "at32f435_437.h"

Go to the source code of this file.

Macros

#define | LED_NUM 3
#define | PRINT_UART USART1
#define | PRINT_UART_CRM_CLK CRM_USART1_PERIPH_CLOCK
#define | PRINT_UART_TX_PIN GPIO_PINS_9
#define | PRINT_UART_TX_GPIO GPIOA
#define | PRINT_UART_TX_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
#define | PRINT_UART_TX_PIN_SOURCE GPIO_PINS_SOURCE9
#define | PRINT_UART_TX_PIN_MUX_NUM GPIO_MUX_7
#define | USER_BUTTON_PIN GPIO_PINS_0
#define | USER_BUTTON_PORT GPIOA
#define | USER_BUTTON_CRM_CLK CRM_GPIOA_PERIPH_CLOCK

Enumerations

enum | led_type { LED2 = 0 , LED3 = 1 , LED4 = 2 }
enum | button_type { USER_BUTTON = 0 , NO_BUTTON = 1 }

Functions

void | at32_board_init (void)
board initialize interface init led and button More...
void | at32_led_init (led_type led)
configure led gpio More...
void | at32_led_on (led_type led)
turns selected led on. More...
void | at32_led_off (led_type led)
turns selected led off. More...
void | at32_led_toggle (led_type led)
turns selected led toggle. More...
void | at32_button_init (void)
configure button gpio More...
button_type | at32_button_press (void)
returns which button have press down More...
uint8_t | at32_button_state (void)
returns the selected button state More...
void | delay_init (void)
initialize delay function More...
void | delay_us (uint32_t nus)
inserts a delay time. More...
void | delay_ms (uint16_t nms)
inserts a delay time. More...
void | delay_sec (uint16_t sec)
inserts a delay time. More...
void | uart_print_init (uint32_t baudrate)
initialize uart More...


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • acc
  • calibration
  • inc
Functions
project/at_start_f435/examples/acc/calibration/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma3
  • inc
Functions
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma4
  • inc
Functions
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_dma2
  • inc
Functions
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_edma
  • inc
Functions
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma1
  • inc
Functions
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma5
  • inc
Functions
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_preempt_interltrig_twoslave
  • inc
Functions
project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • adc
  • conversion_abort
  • inc
Functions
project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • adc
  • current_vref_value_check
  • inc
Functions
project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • adc
  • edma_double_buffer
  • inc
Functions
project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • adc
  • exint_trigger_partitioned
  • inc
Functions
project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • adc
  • internal_temperature_sensor
  • inc
Functions
project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • adc
  • ordinary_preempt_oversampling
  • inc
Functions
project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • adc
  • resolution_6bit
  • inc
Functions
project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • adc
  • software_trigger_repeat
  • inc
Functions
project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • adc
  • tmr_trigger_automatic_preempted
  • inc
Functions
project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • adc
  • use_polling_get_conversion_data
  • inc
Functions
project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • adc
  • vbat_monitor
  • inc
Functions
project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • adc
  • voltage_monitoring
  • inc
Functions
project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • can
  • communication_mode
  • inc
Functions
project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • can
  • filter
  • inc
Functions
project/at_start_f435/examples/can/filter/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/can/filter/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • can
  • loopback_mode
  • inc
Functions
project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • bit_band
  • inc
Functions
project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • inc
Functions
project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • fpu
  • inc
Functions
project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • systick_interrupt
  • inc
Functions
project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • crc
  • calculation
  • inc
Functions
project/at_start_f435/examples/crc/calculation/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • crm
  • clock_failure_detection
  • inc
Functions
project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • crm
  • pll_parameter_calculate
  • inc
Functions
project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • crm
  • sysclk_switch
  • inc
Functions
project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_sinewave
  • inc
Functions
project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_squarewave
  • inc
Functions
project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • dac
  • one_dac_dma_escalator
  • inc
Functions
project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • dac
  • one_dac_noisewave
  • inc
Functions
project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • dac
  • two_dac_trianglewave
  • inc
Functions
project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • debug
  • tmr1
  • inc
Functions
project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_data_to_gpio
  • inc
Functions
project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_genertor_exint
  • inc
Functions
project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_synchronization_exint
  • inc
Functions
project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • dma
  • flash_to_sram
  • inc
Functions
project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • inc
Functions
project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • inc
Functions
project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • edma
  • burst_mode
  • inc
Functions
project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • edma
  • dmamux_genertor_exint
  • inc
Functions
project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • edma
  • dmamux_synchronization_exint
  • inc
Functions
project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • edma
  • flash_to_sram
  • inc
Functions
project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • edma
  • i2s_halfduplex_edma_doublebuffer
  • inc
Functions
project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • edma
  • link_list_mode
  • inc
Functions
project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • edma
  • two_dimension_mode
  • inc
Functions
project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • ertc
  • bpr_domain
  • inc
Functions
project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • ertc
  • calendar
  • inc
Functions
project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • ertc
  • lick_calibration
  • inc
Functions
project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • ertc
  • tamper
  • inc
Functions
project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • ertc
  • time_stamp
  • inc
Functions
project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • ertc
  • wakeup_timer
  • inc
Functions
project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • exint
  • exint_config
  • inc
Functions
project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • exint
  • exint_software_trigger
  • inc
Functions
project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • flash
  • fap_enable
  • inc
Functions
project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • flash
  • flash_write_read
  • inc
Functions
project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • gpio
  • io_toggle
  • inc
Functions
project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • gpio
  • led_toggle
  • inc
Functions
project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • gpio
  • swjtag_mux
  • inc
Functions
project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • i2c
  • communication_dma
  • inc
Functions
project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • i2c
  • communication_int
  • inc
Functions
project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • i2c
  • communication_poll
  • inc
Functions
project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • i2c
  • communication_smbus
  • inc
Functions
project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • i2c
  • eeprom
  • inc
Functions
project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • i2s
  • fullduplex_dma
  • inc
Functions
project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • i2s
  • halfduplex_dma
  • inc
Functions
project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • i2s
  • halfduplex_interrupt
  • inc
Functions
project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
Functions
project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • irtmr
  • irtmr_output
  • inc
Functions
project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_alarm
  • inc
Functions
project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_tamper
  • inc
Functions
project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_wakeup
  • inc
Functions
project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • pwc
  • ldo_set
  • inc
Functions
project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • pwc
  • power_voltage_monitor
  • inc
Functions
project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • pwc
  • sleep_tmr2
  • inc
Functions
project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • pwc
  • sleep_usart1
  • inc
Functions
project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • pwc
  • standby_ertc_alarm
  • inc
Functions
project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • pwc
  • standby_wakeup_pin
  • inc
Functions
project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma
  • inc
Functions
project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_and_pem
  • inc
Functions
project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
  • inc
Functions
project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_interrupt
  • inc
Functions
project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_polling
  • inc
Functions
project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_rdsr_sw
  • inc
Functions
project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • qspi
  • xip_port_write_read
  • inc
Functions
project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • scfg
  • mem_map_sel
  • inc
Functions
project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • sdio
  • sd_mmc_card
  • inc
Functions
project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • sdio
  • sdio_fatfs
  • inc
Functions
project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • spi
  • crc_transfer_polling
  • inc
Functions
project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • spi
  • fullduplex_polling
  • inc
Functions
project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • spi
  • halfduplex_interrupt
  • inc
Functions
project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • spi
  • halfduplex_transceiver_switch
  • inc
Functions
project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • spi
  • only_receive_mode_polling
  • inc
Functions
project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • spi
  • ti_fullduplex_dma
  • inc
Functions
project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
Functions
project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • spi
  • w25q_flash
  • inc
Functions
project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • sram
  • extend_sram
  • inc
Functions
project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • 6_steps
  • inc
Functions
project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • 7_pwm_output
  • inc
Functions
project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • cascade_synchro
  • inc
Functions
project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • complementary_signals
  • inc
Functions
project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • dma
  • inc
Functions
project/at_start_f435/examples/tmr/dma/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • dma_burst
  • inc
Functions
project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • encoder_tmr2
  • inc
Functions
project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • external_clock
  • inc
Functions
project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • hall_xor_tmr2
  • inc
Functions
project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • hang_mode
  • inc
Functions
project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • input_capture
  • inc
Functions
project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • oc_high
  • inc
Functions
project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • oc_low
  • inc
Functions
project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr3
  • inc
Functions
project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr9
  • inc
Functions
project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • one_cycle
  • inc
Functions
project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • parallel_synchro
  • inc
Functions
project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_input
  • inc
Functions
project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_input_dma
  • inc
Functions
project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_simulate
  • inc
Functions
project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr10
  • inc
Functions
project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr3
  • inc
Functions
project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • timer_base
  • inc
Functions
project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • tmr1_synchro
  • inc
Functions
project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • tmr
  • tmr2_32bit
  • inc
Functions
project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usart
  • half_duplex
  • inc
Functions
project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usart
  • hw_flow_control
  • inc
Functions
project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usart
  • idle_detection
  • inc
Functions
project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usart
  • interrupt
  • inc
Functions
project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usart
  • irda
  • inc
Functions
project/at_start_f435/examples/usart/irda/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/irda/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usart
  • polling
  • inc
Functions
project/at_start_f435/examples/usart/polling/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/polling/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usart
  • printf
  • inc
Functions
project/at_start_f435/examples/usart/printf/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/printf/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usart
  • receiver_mute
  • inc
Functions
project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usart
  • rs485
  • inc
Functions
project/at_start_f435/examples/usart/rs485/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usart
  • smartcard
  • inc
Functions
project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usart
  • synchronous
  • inc
Functions
project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_interrupt
  • inc
Functions
project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_polling
  • inc
Functions
project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usart
  • tx_rx_swap
  • inc
Functions
project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • audio
  • inc
Functions
project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_audio_hid
  • inc
Functions
project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_keyboard
  • inc
Functions
project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_msc
  • inc
Functions
project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • custom_hid
  • inc
Functions
project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • keyboard
  • inc
Functions
project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • mouse
  • inc
Functions
project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • msc
  • inc
Functions
project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
  • inc
Functions
project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • printer
  • inc
Functions
project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • two_otg_device_demo
  • inc
Functions
project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • vcp_loopback
  • inc
Functions
project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • virtual_comport
  • inc
Functions
project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • virtual_msc_iap
  • inc
Functions
project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usb_host
  • hid_demo
  • inc
Functions
project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usb_host
  • msc_only_fat32
  • inc
Functions
project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • usb_host
  • two_otg_host_demo
  • inc
Functions
project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • wdt
  • wdt_reset
  • inc
Functions
project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • wdt
  • wdt_standby
  • inc
Functions
project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • wwdt
  • wwdt_reset
  • inc
Functions
project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • xmc
  • lcd_8bit
  • inc
Functions
project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • xmc
  • lcd_touch_16bit
  • inc
Functions
project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • xmc
  • nand_flash
  • ecc
  • inc
Functions
project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • xmc
  • nand_flash
  • nand
  • inc
Functions
project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • xmc
  • nor_flash
  • inc
Functions
project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • xmc
  • psram
  • inc
Functions
project/at_start_f435/examples/xmc/psram/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • xmc
  • sdram_basic
  • inc
Functions
project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • xmc
  • sdram_dma
  • inc
Functions
project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • examples
  • xmc
  • sram
  • inc
Functions
project/at_start_f435/examples/xmc/sram/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f435
  • templates
  • inc
Functions
project/at_start_f435/templates/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/templates/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • acc
  • calibration
  • inc
Functions
project/at_start_f437/examples/acc/calibration/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma3
  • inc
Functions
project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma4
  • inc
Functions
project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_dma2
  • inc
Functions
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_edma
  • inc
Functions
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma1
  • inc
Functions
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma5
  • inc
Functions
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_preempt_interltrig_twoslave
  • inc
Functions
project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • adc
  • conversion_abort
  • inc
Functions
project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • adc
  • current_vref_value_check
  • inc
Functions
project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • adc
  • edma_double_buffer
  • inc
Functions
project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • adc
  • exint_trigger_partitioned
  • inc
Functions
project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • adc
  • internal_temperature_sensor
  • inc
Functions
project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • adc
  • ordinary_preempt_oversampling
  • inc
Functions
project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • adc
  • resolution_6bit
  • inc
Functions
project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • adc
  • software_trigger_repeat
  • inc
Functions
project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • adc
  • tmr_trigger_automatic_preempted
  • inc
Functions
project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • adc
  • use_polling_get_conversion_data
  • inc
Functions
project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • adc
  • vbat_monitor
  • inc
Functions
project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • adc
  • voltage_monitoring
  • inc
Functions
project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • can
  • communication_mode
  • inc
Functions
project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • can
  • filter
  • inc
Functions
project/at_start_f437/examples/can/filter/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/can/filter/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • can
  • loopback_mode
  • inc
Functions
project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • bit_band
  • inc
Functions
project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • inc
Functions
project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • fpu
  • inc
Functions
project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • systick_interrupt
  • inc
Functions
project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • crc
  • calculation
  • inc
Functions
project/at_start_f437/examples/crc/calculation/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • crm
  • clock_failure_detection
  • inc
Functions
project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • crm
  • pll_parameter_calculate
  • inc
Functions
project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • crm
  • sysclk_switch
  • inc
Functions
project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • dac
  • double_mode_dma_sinewave
  • inc
Functions
project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • dac
  • double_mode_dma_squarewave
  • inc
Functions
project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • dac
  • one_dac_dma_escalator
  • inc
Functions
project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • dac
  • one_dac_noisewave
  • inc
Functions
project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • dac
  • two_dac_trianglewave
  • inc
Functions
project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • debug
  • tmr1
  • inc
Functions
project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • dma
  • dmamux_data_to_gpio
  • inc
Functions
project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • dma
  • dmamux_genertor_exint
  • inc
Functions
project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • dma
  • dmamux_synchronization_exint
  • inc
Functions
project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • dma
  • flash_to_sram
  • inc
Functions
project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • inc
Functions
project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • inc
Functions
project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • edma
  • burst_mode
  • inc
Functions
project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • edma
  • dmamux_genertor_exint
  • inc
Functions
project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • edma
  • dmamux_synchronization_exint
  • inc
Functions
project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • edma
  • flash_to_sram
  • inc
Functions
project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • edma
  • i2s_halfduplex_edma_doublebuffer
  • inc
Functions
project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • edma
  • link_list_mode
  • inc
Functions
project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • edma
  • two_dimension_mode
  • inc
Functions
project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • emac
  • dns_client
  • inc
Functions
project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • emac
  • http_server
  • inc
Functions
project/at_start_f437/examples/emac/http_server/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • emac
  • iperf
  • inc
Functions
project/at_start_f437/examples/emac/iperf/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • emac
  • mqtt_client
  • inc
Functions
project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • emac
  • tcp_client
  • inc
Functions
project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • emac
  • tcp_server
  • inc
Functions
project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • emac
  • telnet
  • inc
Functions
project/at_start_f437/examples/emac/telnet/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • emac
  • wake_on_lan
  • inc
Functions
project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • ertc
  • bpr_domain
  • inc
Functions
project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • ertc
  • calendar
  • inc
Functions
project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • ertc
  • lick_calibration
  • inc
Functions
project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • ertc
  • tamper
  • inc
Functions
project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • ertc
  • time_stamp
  • inc
Functions
project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • ertc
  • wakeup_timer
  • inc
Functions
project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • exint
  • exint_config
  • inc
Functions
project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • exint
  • exint_software_trigger
  • inc
Functions
project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • flash
  • fap_enable
  • inc
Functions
project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • flash
  • flash_write_read
  • inc
Functions
project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • gpio
  • io_toggle
  • inc
Functions
project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • gpio
  • led_toggle
  • inc
Functions
project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • gpio
  • swjtag_mux
  • inc
Functions
project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • i2c
  • communication_dma
  • inc
Functions
project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • i2c
  • communication_int
  • inc
Functions
project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • i2c
  • communication_poll
  • inc
Functions
project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • i2c
  • communication_smbus
  • inc
Functions
project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • i2c
  • eeprom
  • inc
Functions
project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • i2s
  • fullduplex_dma
  • inc
Functions
project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • i2s
  • halfduplex_dma
  • inc
Functions
project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • i2s
  • halfduplex_interrupt
  • inc
Functions
project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
Functions
project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • irtmr
  • irtmr_output
  • inc
Functions
project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • pwc
  • deepsleep_ertc_alarm
  • inc
Functions
project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • pwc
  • deepsleep_ertc_tamper
  • inc
Functions
project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • pwc
  • deepsleep_ertc_wakeup
  • inc
Functions
project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • pwc
  • ldo_set
  • inc
Functions
project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • pwc
  • power_voltage_monitor
  • inc
Functions
project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • pwc
  • sleep_tmr2
  • inc
Functions
project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • pwc
  • sleep_usart1
  • inc
Functions
project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • pwc
  • standby_ertc_alarm
  • inc
Functions
project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • pwc
  • standby_wakeup_pin
  • inc
Functions
project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_dma
  • inc
Functions
project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_dma_and_pem
  • inc
Functions
project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
  • inc
Functions
project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_interrupt
  • inc
Functions
project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_polling
  • inc
Functions
project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_rdsr_sw
  • inc
Functions
project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • qspi
  • xip_port_write_read
  • inc
Functions
project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • scfg
  • mem_map_sel
  • inc
Functions
project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • sdio
  • sd_mmc_card
  • inc
Functions
project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • sdio
  • sdio_fatfs
  • inc
Functions
project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • spi
  • crc_transfer_polling
  • inc
Functions
project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • spi
  • fullduplex_polling
  • inc
Functions
project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • spi
  • halfduplex_interrupt
  • inc
Functions
project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • spi
  • halfduplex_transceiver_switch
  • inc
Functions
project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • spi
  • only_receive_mode_polling
  • inc
Functions
project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • spi
  • ti_fullduplex_dma
  • inc
Functions
project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
Functions
project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • spi
  • w25q_flash
  • inc
Functions
project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • sram
  • extend_sram
  • inc
Functions
project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • 6_steps
  • inc
Functions
project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • 7_pwm_output
  • inc
Functions
project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • cascade_synchro
  • inc
Functions
project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • complementary_signals
  • inc
Functions
project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • dma
  • inc
Functions
project/at_start_f437/examples/tmr/dma/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • dma_burst
  • inc
Functions
project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • encoder_tmr2
  • inc
Functions
project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • external_clock
  • inc
Functions
project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • hall_xor_tmr2
  • inc
Functions
project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • hang_mode
  • inc
Functions
project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • input_capture
  • inc
Functions
project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • oc_high
  • inc
Functions
project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • oc_low
  • inc
Functions
project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • oc_toggle_tmr3
  • inc
Functions
project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • oc_toggle_tmr9
  • inc
Functions
project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • one_cycle
  • inc
Functions
project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • parallel_synchro
  • inc
Functions
project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_input
  • inc
Functions
project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_input_dma
  • inc
Functions
project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_output_simulate
  • inc
Functions
project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_output_tmr10
  • inc
Functions
project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_output_tmr3
  • inc
Functions
project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • timer_base
  • inc
Functions
project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • tmr1_synchro
  • inc
Functions
project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • tmr
  • tmr2_32bit
  • inc
Functions
project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usart
  • half_duplex
  • inc
Functions
project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usart
  • hw_flow_control
  • inc
Functions
project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usart
  • idle_detection
  • inc
Functions
project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usart
  • interrupt
  • inc
Functions
project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usart
  • irda
  • inc
Functions
project/at_start_f437/examples/usart/irda/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/irda/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usart
  • polling
  • inc
Functions
project/at_start_f437/examples/usart/polling/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/polling/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usart
  • printf
  • inc
Functions
project/at_start_f437/examples/usart/printf/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/printf/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usart
  • receiver_mute
  • inc
Functions
project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usart
  • rs485
  • inc
Functions
project/at_start_f437/examples/usart/rs485/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usart
  • smartcard
  • inc
Functions
project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usart
  • synchronous
  • inc
Functions
project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usart
  • transfer_by_dma_interrupt
  • inc
Functions
project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usart
  • transfer_by_dma_polling
  • inc
Functions
project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usart
  • tx_rx_swap
  • inc
Functions
project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • audio
  • inc
Functions
project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • composite_audio_hid
  • inc
Functions
project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • composite_vcp_keyboard
  • inc
Functions
project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • composite_vcp_msc
  • inc
Functions
project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • custom_hid
  • inc
Functions
project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • keyboard
  • inc
Functions
project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • mouse
  • inc
Functions
project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • msc
  • inc
Functions
project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
  • inc
Functions
project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • printer
  • inc
Functions
project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • two_otg_device_demo
  • inc
Functions
project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • vcp_loopback
  • inc
Functions
project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • virtual_comport
  • inc
Functions
project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • virtual_msc_iap
  • inc
Functions
project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usb_host
  • hid_demo
  • inc
Functions
project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usb_host
  • msc_only_fat32
  • inc
Functions
project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • usb_host
  • two_otg_host_demo
  • inc
Functions
project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • wdt
  • wdt_reset
  • inc
Functions
project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • wdt
  • wdt_standby
  • inc
Functions
project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • wwdt
  • wwdt_reset
  • inc
Functions
project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • xmc
  • lcd_8bit
  • inc
Functions
project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • xmc
  • lcd_touch_16bit
  • inc
Functions
project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • xmc
  • nand_flash
  • ecc
  • inc
Functions
project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • xmc
  • nand_flash
  • nand
  • inc
Functions
project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • xmc
  • nor_flash
  • inc
Functions
project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • xmc
  • psram
  • inc
Functions
project/at_start_f437/examples/xmc/psram/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • xmc
  • sdram_basic
  • inc
Functions
project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • xmc
  • sdram_dma
  • inc
Functions
project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • examples
  • xmc
  • sram
  • inc
Functions
project/at_start_f437/examples/xmc/sram/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • at_start_f437
  • templates
  • inc
Functions
project/at_start_f437/templates/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/templates/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • utilities
  • at32f435_437_freertos_demo
  • inc
Functions
utilities/at32f435_437_freertos_demo/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_freertos_demo/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • utilities
  • at32f435_437_gen_random_number_demo
  • inc
Functions
utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • utilities
  • at32f435_437_slib_demo
  • project_l0
  • inc
Functions
utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • utilities
  • at32f435_437_slib_demo
  • project_l1
  • inc
Functions
utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Functions
utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Functions
utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • bootloader
  • inc
Functions
utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Functions
utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Functions
utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • bootloader
  • inc
Functions
utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Functions
utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_clock.h File Reference

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • bootloader
  • inc
Functions
utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_clock.h File Reference

header file of clock program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_clock.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • acc
  • calibration
  • inc
Macros
project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma3
  • inc
Macros
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma4
  • inc
Macros
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_dma2
  • inc
Macros
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_edma
  • inc
Macros
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma1
  • inc
Macros
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma5
  • inc
Macros
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_preempt_interltrig_twoslave
  • inc
Macros
project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • adc
  • conversion_abort
  • inc
Macros
project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • adc
  • current_vref_value_check
  • inc
Macros
project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • adc
  • edma_double_buffer
  • inc
Macros
project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • adc
  • exint_trigger_partitioned
  • inc
Macros
project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • adc
  • internal_temperature_sensor
  • inc
Macros
project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • adc
  • ordinary_preempt_oversampling
  • inc
Macros
project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • adc
  • resolution_6bit
  • inc
Macros
project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • adc
  • software_trigger_repeat
  • inc
Macros
project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • adc
  • tmr_trigger_automatic_preempted
  • inc
Macros
project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • adc
  • use_polling_get_conversion_data
  • inc
Macros
project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • adc
  • vbat_monitor
  • inc
Macros
project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • adc
  • voltage_monitoring
  • inc
Macros
project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • can
  • communication_mode
  • inc
Macros
project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • can
  • filter
  • inc
Macros
project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • can
  • loopback_mode
  • inc
Macros
project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • bit_band
  • inc
Macros
project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • inc
Macros
project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • fpu
  • inc
Macros
project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • systick_interrupt
  • inc
Macros
project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • crc
  • calculation
  • inc
Macros
project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • crm
  • clock_failure_detection
  • inc
Macros
project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • crm
  • pll_parameter_calculate
  • inc
Macros
project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • crm
  • sysclk_switch
  • inc
Macros
project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_sinewave
  • inc
Macros
project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_squarewave
  • inc
Macros
project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • dac
  • one_dac_dma_escalator
  • inc
Macros
project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • dac
  • one_dac_noisewave
  • inc
Macros
project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • dac
  • two_dac_trianglewave
  • inc
Macros
project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • debug
  • tmr1
  • inc
Macros
project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_data_to_gpio
  • inc
Macros
project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_genertor_exint
  • inc
Macros
project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_synchronization_exint
  • inc
Macros
project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • dma
  • flash_to_sram
  • inc
Macros
project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • inc
Macros
project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • inc
Macros
project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • edma
  • burst_mode
  • inc
Macros
project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • edma
  • dmamux_genertor_exint
  • inc
Macros
project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • edma
  • dmamux_synchronization_exint
  • inc
Macros
project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • edma
  • flash_to_sram
  • inc
Macros
project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • edma
  • i2s_halfduplex_edma_doublebuffer
  • inc
Macros
project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • edma
  • link_list_mode
  • inc
Macros
project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • edma
  • two_dimension_mode
  • inc
Macros
project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • ertc
  • bpr_domain
  • inc
Macros
project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • ertc
  • calendar
  • inc
Macros
project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • ertc
  • lick_calibration
  • inc
Macros
project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • ertc
  • tamper
  • inc
Macros
project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • ertc
  • time_stamp
  • inc
Macros
project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • ertc
  • wakeup_timer
  • inc
Macros
project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • exint
  • exint_config
  • inc
Macros
project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • exint
  • exint_software_trigger
  • inc
Macros
project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • flash
  • fap_enable
  • inc
Macros
project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • flash
  • flash_write_read
  • inc
Macros
project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • gpio
  • io_toggle
  • inc
Macros
project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • gpio
  • led_toggle
  • inc
Macros
project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • gpio
  • swjtag_mux
  • inc
Macros
project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • i2c
  • communication_dma
  • inc
Macros
project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • i2c
  • communication_int
  • inc
Macros
project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • i2c
  • communication_poll
  • inc
Macros
project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • i2c
  • communication_smbus
  • inc
Macros
project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • i2c
  • eeprom
  • inc
Macros
project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • i2s
  • fullduplex_dma
  • inc
Macros
project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • i2s
  • halfduplex_dma
  • inc
Macros
project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • i2s
  • halfduplex_interrupt
  • inc
Macros
project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
Macros
project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • irtmr
  • irtmr_output
  • inc
Macros
project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_alarm
  • inc
Macros
project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_tamper
  • inc
Macros
project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_wakeup
  • inc
Macros
project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • pwc
  • ldo_set
  • inc
Macros
project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • pwc
  • power_voltage_monitor
  • inc
Macros
project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • pwc
  • sleep_tmr2
  • inc
Macros
project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • pwc
  • sleep_usart1
  • inc
Macros
project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • pwc
  • standby_ertc_alarm
  • inc
Macros
project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • pwc
  • standby_wakeup_pin
  • inc
Macros
project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma
  • inc
Macros
project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_and_pem
  • inc
Macros
project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
  • inc
Macros
project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_interrupt
  • inc
Macros
project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_polling
  • inc
Macros
project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_rdsr_sw
  • inc
Macros
project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • qspi
  • xip_port_write_read
  • inc
Macros
project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • scfg
  • mem_map_sel
  • inc
Macros
project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • sdio
  • sd_mmc_card
  • inc
Macros
project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • sdio
  • sdio_fatfs
  • inc
Macros
project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • spi
  • crc_transfer_polling
  • inc
Macros
project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • spi
  • fullduplex_polling
  • inc
Macros
project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • spi
  • halfduplex_interrupt
  • inc
Macros
project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • spi
  • halfduplex_transceiver_switch
  • inc
Macros
project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • spi
  • only_receive_mode_polling
  • inc
Macros
project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • spi
  • ti_fullduplex_dma
  • inc
Macros
project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
Macros
project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • spi
  • w25q_flash
  • inc
Macros
project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • sram
  • extend_sram
  • inc
Macros
project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • 6_steps
  • inc
Macros
project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • 7_pwm_output
  • inc
Macros
project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • cascade_synchro
  • inc
Macros
project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • complementary_signals
  • inc
Macros
project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • dma
  • inc
Macros
project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • dma_burst
  • inc
Macros
project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • encoder_tmr2
  • inc
Macros
project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • external_clock
  • inc
Macros
project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • hall_xor_tmr2
  • inc
Macros
project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • hang_mode
  • inc
Macros
project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • input_capture
  • inc
Macros
project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • oc_high
  • inc
Macros
project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • oc_low
  • inc
Macros
project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr3
  • inc
Macros
project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr9
  • inc
Macros
project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • one_cycle
  • inc
Macros
project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • parallel_synchro
  • inc
Macros
project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_input
  • inc
Macros
project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_input_dma
  • inc
Macros
project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_simulate
  • inc
Macros
project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr10
  • inc
Macros
project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr3
  • inc
Macros
project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • timer_base
  • inc
Macros
project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • tmr1_synchro
  • inc
Macros
project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • tmr
  • tmr2_32bit
  • inc
Macros
project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usart
  • half_duplex
  • inc
Macros
project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usart
  • hw_flow_control
  • inc
Macros
project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usart
  • idle_detection
  • inc
Macros
project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usart
  • interrupt
  • inc
Macros
project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usart
  • irda
  • inc
Macros
project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usart
  • polling
  • inc
Macros
project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usart
  • printf
  • inc
Macros
project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usart
  • receiver_mute
  • inc
Macros
project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usart
  • rs485
  • inc
Macros
project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usart
  • smartcard
  • inc
Macros
project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usart
  • synchronous
  • inc
Macros
project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_interrupt
  • inc
Macros
project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_polling
  • inc
Macros
project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usart
  • tx_rx_swap
  • inc
Macros
project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • audio
  • inc
Macros
project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_audio_hid
  • inc
Macros
project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_keyboard
  • inc
Macros
project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_msc
  • inc
Macros
project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • custom_hid
  • inc
Macros
project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • keyboard
  • inc
Macros
project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • mouse
  • inc
Macros
project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • msc
  • inc
Macros
project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
  • inc
Macros
project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • printer
  • inc
Macros
project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • two_otg_device_demo
  • inc
Macros
project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • vcp_loopback
  • inc
Macros
project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • virtual_comport
  • inc
Macros
project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • virtual_msc_iap
  • inc
Macros
project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usb_host
  • hid_demo
  • inc
Macros
project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usb_host
  • msc_only_fat32
  • inc
Macros
project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • usb_host
  • two_otg_host_demo
  • inc
Macros
project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • wdt
  • wdt_reset
  • inc
Macros
project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • wdt
  • wdt_standby
  • inc
Macros
project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • wwdt
  • wwdt_reset
  • inc
Macros
project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • xmc
  • lcd_8bit
  • inc
Macros
project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • xmc
  • lcd_touch_16bit
  • inc
Macros
project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • xmc
  • nand_flash
  • ecc
  • inc
Macros
project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • xmc
  • nand_flash
  • nand
  • inc
Macros
project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • xmc
  • nor_flash
  • inc
Macros
project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • xmc
  • psram
  • inc
Macros
project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • xmc
  • sdram_basic
  • inc
Macros
project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • xmc
  • sdram_dma
  • inc
Macros
project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • examples
  • xmc
  • sram
  • inc
Macros
project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f435
  • templates
  • inc
Macros
project/at_start_f435/templates/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/templates/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • acc
  • calibration
  • inc
Macros
project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma3
  • inc
Macros
project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma4
  • inc
Macros
project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_dma2
  • inc
Macros
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_edma
  • inc
Macros
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma1
  • inc
Macros
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma5
  • inc
Macros
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_preempt_interltrig_twoslave
  • inc
Macros
project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • adc
  • conversion_abort
  • inc
Macros
project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • adc
  • current_vref_value_check
  • inc
Macros
project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • adc
  • edma_double_buffer
  • inc
Macros
project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • adc
  • exint_trigger_partitioned
  • inc
Macros
project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • adc
  • internal_temperature_sensor
  • inc
Macros
project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • adc
  • ordinary_preempt_oversampling
  • inc
Macros
project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • adc
  • resolution_6bit
  • inc
Macros
project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • adc
  • software_trigger_repeat
  • inc
Macros
project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • adc
  • tmr_trigger_automatic_preempted
  • inc
Macros
project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • adc
  • use_polling_get_conversion_data
  • inc
Macros
project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • adc
  • vbat_monitor
  • inc
Macros
project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • adc
  • voltage_monitoring
  • inc
Macros
project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • can
  • communication_mode
  • inc
Macros
project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • can
  • filter
  • inc
Macros
project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • can
  • loopback_mode
  • inc
Macros
project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • bit_band
  • inc
Macros
project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • inc
Macros
project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • fpu
  • inc
Macros
project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • systick_interrupt
  • inc
Macros
project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • crc
  • calculation
  • inc
Macros
project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • crm
  • clock_failure_detection
  • inc
Macros
project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • crm
  • pll_parameter_calculate
  • inc
Macros
project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • crm
  • sysclk_switch
  • inc
Macros
project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • dac
  • double_mode_dma_sinewave
  • inc
Macros
project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • dac
  • double_mode_dma_squarewave
  • inc
Macros
project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • dac
  • one_dac_dma_escalator
  • inc
Macros
project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • dac
  • one_dac_noisewave
  • inc
Macros
project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • dac
  • two_dac_trianglewave
  • inc
Macros
project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • debug
  • tmr1
  • inc
Macros
project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • dma
  • dmamux_data_to_gpio
  • inc
Macros
project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • dma
  • dmamux_genertor_exint
  • inc
Macros
project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • dma
  • dmamux_synchronization_exint
  • inc
Macros
project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • dma
  • flash_to_sram
  • inc
Macros
project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • inc
Macros
project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • inc
Macros
project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • edma
  • burst_mode
  • inc
Macros
project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • edma
  • dmamux_genertor_exint
  • inc
Macros
project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • edma
  • dmamux_synchronization_exint
  • inc
Macros
project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • edma
  • flash_to_sram
  • inc
Macros
project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • edma
  • i2s_halfduplex_edma_doublebuffer
  • inc
Macros
project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • edma
  • link_list_mode
  • inc
Macros
project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • edma
  • two_dimension_mode
  • inc
Macros
project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • emac
  • dns_client
  • inc
Macros
project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • emac
  • http_server
  • inc
Macros
project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • emac
  • iperf
  • inc
Macros
project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • emac
  • mqtt_client
  • inc
Macros
project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • emac
  • tcp_client
  • inc
Macros
project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • emac
  • tcp_server
  • inc
Macros
project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • emac
  • telnet
  • inc
Macros
project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • emac
  • wake_on_lan
  • inc
Macros
project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • ertc
  • bpr_domain
  • inc
Macros
project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • ertc
  • calendar
  • inc
Macros
project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • ertc
  • lick_calibration
  • inc
Macros
project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • ertc
  • tamper
  • inc
Macros
project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • ertc
  • time_stamp
  • inc
Macros
project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • ertc
  • wakeup_timer
  • inc
Macros
project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • exint
  • exint_config
  • inc
Macros
project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • exint
  • exint_software_trigger
  • inc
Macros
project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • flash
  • fap_enable
  • inc
Macros
project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • flash
  • flash_write_read
  • inc
Macros
project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • gpio
  • io_toggle
  • inc
Macros
project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • gpio
  • led_toggle
  • inc
Macros
project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • gpio
  • swjtag_mux
  • inc
Macros
project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • i2c
  • communication_dma
  • inc
Macros
project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • i2c
  • communication_int
  • inc
Macros
project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • i2c
  • communication_poll
  • inc
Macros
project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • i2c
  • communication_smbus
  • inc
Macros
project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • i2c
  • eeprom
  • inc
Macros
project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • i2s
  • fullduplex_dma
  • inc
Macros
project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • i2s
  • halfduplex_dma
  • inc
Macros
project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • i2s
  • halfduplex_interrupt
  • inc
Macros
project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
Macros
project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • irtmr
  • irtmr_output
  • inc
Macros
project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • pwc
  • deepsleep_ertc_alarm
  • inc
Macros
project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • pwc
  • deepsleep_ertc_tamper
  • inc
Macros
project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • pwc
  • deepsleep_ertc_wakeup
  • inc
Macros
project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • pwc
  • ldo_set
  • inc
Macros
project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • pwc
  • power_voltage_monitor
  • inc
Macros
project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • pwc
  • sleep_tmr2
  • inc
Macros
project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • pwc
  • sleep_usart1
  • inc
Macros
project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • pwc
  • standby_ertc_alarm
  • inc
Macros
project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • pwc
  • standby_wakeup_pin
  • inc
Macros
project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_dma
  • inc
Macros
project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_dma_and_pem
  • inc
Macros
project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
  • inc
Macros
project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_interrupt
  • inc
Macros
project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_polling
  • inc
Macros
project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_rdsr_sw
  • inc
Macros
project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • qspi
  • xip_port_write_read
  • inc
Macros
project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • scfg
  • mem_map_sel
  • inc
Macros
project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • sdio
  • sd_mmc_card
  • inc
Macros
project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • sdio
  • sdio_fatfs
  • inc
Macros
project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • spi
  • crc_transfer_polling
  • inc
Macros
project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • spi
  • fullduplex_polling
  • inc
Macros
project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • spi
  • halfduplex_interrupt
  • inc
Macros
project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • spi
  • halfduplex_transceiver_switch
  • inc
Macros
project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • spi
  • only_receive_mode_polling
  • inc
Macros
project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • spi
  • ti_fullduplex_dma
  • inc
Macros
project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
Macros
project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • spi
  • w25q_flash
  • inc
Macros
project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • sram
  • extend_sram
  • inc
Macros
project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • 6_steps
  • inc
Macros
project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • 7_pwm_output
  • inc
Macros
project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • cascade_synchro
  • inc
Macros
project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • complementary_signals
  • inc
Macros
project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • dma
  • inc
Macros
project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • dma_burst
  • inc
Macros
project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • encoder_tmr2
  • inc
Macros
project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • external_clock
  • inc
Macros
project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • hall_xor_tmr2
  • inc
Macros
project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • hang_mode
  • inc
Macros
project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • input_capture
  • inc
Macros
project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • oc_high
  • inc
Macros
project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • oc_low
  • inc
Macros
project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • oc_toggle_tmr3
  • inc
Macros
project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • oc_toggle_tmr9
  • inc
Macros
project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • one_cycle
  • inc
Macros
project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • parallel_synchro
  • inc
Macros
project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_input
  • inc
Macros
project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_input_dma
  • inc
Macros
project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_output_simulate
  • inc
Macros
project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_output_tmr10
  • inc
Macros
project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_output_tmr3
  • inc
Macros
project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • timer_base
  • inc
Macros
project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • tmr1_synchro
  • inc
Macros
project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • tmr
  • tmr2_32bit
  • inc
Macros
project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usart
  • half_duplex
  • inc
Macros
project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usart
  • hw_flow_control
  • inc
Macros
project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usart
  • idle_detection
  • inc
Macros
project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usart
  • interrupt
  • inc
Macros
project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usart
  • irda
  • inc
Macros
project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usart
  • polling
  • inc
Macros
project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usart
  • printf
  • inc
Macros
project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usart
  • receiver_mute
  • inc
Macros
project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usart
  • rs485
  • inc
Macros
project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usart
  • smartcard
  • inc
Macros
project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usart
  • synchronous
  • inc
Macros
project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usart
  • transfer_by_dma_interrupt
  • inc
Macros
project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usart
  • transfer_by_dma_polling
  • inc
Macros
project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usart
  • tx_rx_swap
  • inc
Macros
project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • audio
  • inc
Macros
project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • composite_audio_hid
  • inc
Macros
project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • composite_vcp_keyboard
  • inc
Macros
project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • composite_vcp_msc
  • inc
Macros
project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • custom_hid
  • inc
Macros
project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • keyboard
  • inc
Macros
project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • mouse
  • inc
Macros
project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • msc
  • inc
Macros
project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
  • inc
Macros
project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • printer
  • inc
Macros
project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • two_otg_device_demo
  • inc
Macros
project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • vcp_loopback
  • inc
Macros
project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • virtual_comport
  • inc
Macros
project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • virtual_msc_iap
  • inc
Macros
project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usb_host
  • hid_demo
  • inc
Macros
project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usb_host
  • msc_only_fat32
  • inc
Macros
project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • usb_host
  • two_otg_host_demo
  • inc
Macros
project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • wdt
  • wdt_reset
  • inc
Macros
project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • wdt
  • wdt_standby
  • inc
Macros
project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • wwdt
  • wwdt_reset
  • inc
Macros
project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • xmc
  • lcd_8bit
  • inc
Macros
project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • xmc
  • lcd_touch_16bit
  • inc
Macros
project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • xmc
  • nand_flash
  • ecc
  • inc
Macros
project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • xmc
  • nand_flash
  • nand
  • inc
Macros
project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • xmc
  • nor_flash
  • inc
Macros
project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • xmc
  • psram
  • inc
Macros
project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • xmc
  • sdram_basic
  • inc
Macros
project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • xmc
  • sdram_dma
  • inc
Macros
project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • examples
  • xmc
  • sram
  • inc
Macros
project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • at_start_f437
  • templates
  • inc
Macros
project/at_start_f437/templates/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/templates/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • utilities
  • at32f435_437_freertos_demo
  • inc
Macros
utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • utilities
  • at32f435_437_gen_random_number_demo
  • inc
Macros
utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • iar_out
  • inc
Macros
utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • keil_flm
  • inc
Macros
utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • utilities
  • at32f435_437_slib_demo
  • project_l0
  • inc
Macros
utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • utilities
  • at32f435_437_slib_demo
  • project_l1
  • inc
Macros
utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Macros
utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Macros
utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • bootloader
  • inc
Macros
utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Macros
utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Macros
utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • bootloader
  • inc
Macros
utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 77 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 63 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 62 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 70 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 64 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 68 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 67 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 80 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 66 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 82 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 57 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 73 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 69 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 58 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 59 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 78 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 61 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 79 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 81 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 74 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 60 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 76 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 72 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Macros
utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28

Definition in file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 62 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 48 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 47 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 55 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 40 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 49 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 53 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 52 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 65 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 51 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 67 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 42 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 58 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 54 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 43 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 36 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor.

value of the high speed exernal crystal in hz

Definition at line 29 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 37 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 44 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 63 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 46 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 64 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 66 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 59 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 50 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 41 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 45 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 61 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 57 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 56 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 60 of file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_conf.h File Reference

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • bootloader
  • inc
Macros
utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h File Reference

at32f435_437 config header file More...

#include "at32f435_437_crm.h"
#include "at32f435_437_tmr.h"
#include "at32f435_437_ertc.h"
#include "at32f435_437_gpio.h"
#include "at32f435_437_i2c.h"
#include "at32f435_437_usart.h"
#include "at32f435_437_pwc.h"
#include "at32f435_437_can.h"
#include "at32f435_437_adc.h"
#include "at32f435_437_dac.h"
#include "at32f435_437_spi.h"
#include "at32f435_437_dma.h"
#include "at32f435_437_debug.h"
#include "at32f435_437_flash.h"
#include "at32f435_437_crc.h"
#include "at32f435_437_wwdt.h"
#include "at32f435_437_wdt.h"
#include "at32f435_437_exint.h"
#include "at32f435_437_sdio.h"
#include "at32f435_437_xmc.h"
#include "at32f435_437_acc.h"
#include "at32f435_437_misc.h"
#include "at32f435_437_edma.h"
#include "at32f435_437_qspi.h"
#include "at32f435_437_scfg.h"
#include "at32f435_437_emac.h"
#include "at32f435_437_dvp.h"
#include "at32f435_437_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | ERTC_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | DAC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | EDMA_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | XMC_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED
#define | QSPI_MODULE_ENABLED
#define | DVP_MODULE_ENABLED
#define | SCFG_MODULE_ENABLED
#define | EMAC_MODULE_ENABLED

Detailed Description

at32f435_437 config header file

Version
v2.0.9
Date
2022-06-28

Definition in file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 62 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 48 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 47 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 55 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 40 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ DAC_MODULE_ENABLED

#define DAC_MODULE_ENABLED

Definition at line 49 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 53 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 52 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ DVP_MODULE_ENABLED

#define DVP_MODULE_ENABLED

Definition at line 65 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ EDMA_MODULE_ENABLED

#define EDMA_MODULE_ENABLED

Definition at line 51 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ EMAC_MODULE_ENABLED

#define EMAC_MODULE_ENABLED

Definition at line 67 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ ERTC_MODULE_ENABLED

#define ERTC_MODULE_ENABLED

Definition at line 42 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 58 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 54 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 43 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 36 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor.

value of the high speed exernal crystal in hz

Definition at line 29 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 37 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 44 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 63 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 46 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ QSPI_MODULE_ENABLED

#define QSPI_MODULE_ENABLED

Definition at line 64 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ SCFG_MODULE_ENABLED

#define SCFG_MODULE_ENABLED

Definition at line 66 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 59 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 50 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 41 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 45 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 61 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 57 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 56 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.

◆ XMC_MODULE_ENABLED

#define XMC_MODULE_ENABLED

Definition at line 60 of file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • acc
  • calibration
  • inc
Functions
project/at_start_f435/examples/acc/calibration/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/acc/calibration/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma3
  • inc
Functions
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma4
  • inc
Functions
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_dma2
  • inc
Functions
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_edma
  • inc
Functions
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma1
  • inc
Functions
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma5
  • inc
Functions
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_preempt_interltrig_twoslave
  • inc
Functions
project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • adc
  • conversion_abort
  • inc
Functions
project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • adc
  • current_vref_value_check
  • inc
Functions
project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • adc
  • edma_double_buffer
  • inc
Functions
project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • adc
  • exint_trigger_partitioned
  • inc
Functions
project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • adc
  • internal_temperature_sensor
  • inc
Functions
project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • adc
  • ordinary_preempt_oversampling
  • inc
Functions
project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • adc
  • resolution_6bit
  • inc
Functions
project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • adc
  • software_trigger_repeat
  • inc
Functions
project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • adc
  • tmr_trigger_automatic_preempted
  • inc
Functions
project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • adc
  • use_polling_get_conversion_data
  • inc
Functions
project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • adc
  • vbat_monitor
  • inc
Functions
project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • adc
  • voltage_monitoring
  • inc
Functions
project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • can
  • communication_mode
  • inc
Functions
project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • can
  • filter
  • inc
Functions
project/at_start_f435/examples/can/filter/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/can/filter/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • can
  • loopback_mode
  • inc
Functions
project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • bit_band
  • inc
Functions
project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • inc
Functions
project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • fpu
  • inc
Functions
project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • systick_interrupt
  • inc
Functions
project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • crc
  • calculation
  • inc
Functions
project/at_start_f435/examples/crc/calculation/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/crc/calculation/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • crm
  • clock_failure_detection
  • inc
Functions
project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • crm
  • pll_parameter_calculate
  • inc
Functions
project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • crm
  • sysclk_switch
  • inc
Functions
project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_sinewave
  • inc
Functions
project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_squarewave
  • inc
Functions
project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • dac
  • one_dac_dma_escalator
  • inc
Functions
project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • dac
  • one_dac_noisewave
  • inc
Functions
project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • dac
  • two_dac_trianglewave
  • inc
Functions
project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • debug
  • tmr1
  • inc
Functions
project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_data_to_gpio
  • inc
Functions
project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_genertor_exint
  • inc
Functions
project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_synchronization_exint
  • inc
Functions
project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • dma
  • flash_to_sram
  • inc
Functions
project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • inc
Functions
project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • inc
Functions
project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • edma
  • burst_mode
  • inc
Functions
project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • edma
  • dmamux_genertor_exint
  • inc
Functions
project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • edma
  • dmamux_synchronization_exint
  • inc
Functions
project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • edma
  • flash_to_sram
  • inc
Functions
project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • edma
  • i2s_halfduplex_edma_doublebuffer
  • inc
Functions
project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • edma
  • link_list_mode
  • inc
Functions
project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • edma
  • two_dimension_mode
  • inc
Functions
project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • ertc
  • bpr_domain
  • inc
Functions
project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • ertc
  • calendar
  • inc
Functions
project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • ertc
  • lick_calibration
  • inc
Functions
project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • ertc
  • tamper
  • inc
Functions
project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • ertc
  • time_stamp
  • inc
Functions
project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • ertc
  • wakeup_timer
  • inc
Functions
project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • exint
  • exint_config
  • inc
Functions
project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • exint
  • exint_software_trigger
  • inc
Functions
project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • flash
  • fap_enable
  • inc
Functions
project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • flash
  • flash_write_read
  • inc
Functions
project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • gpio
  • io_toggle
  • inc
Functions
project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • gpio
  • led_toggle
  • inc
Functions
project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • gpio
  • swjtag_mux
  • inc
Functions
project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • i2c
  • communication_dma
  • inc
Functions
project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • i2c
  • communication_int
  • inc
Functions
project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • i2c
  • communication_poll
  • inc
Functions
project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • i2c
  • communication_smbus
  • inc
Functions
project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • i2c
  • eeprom
  • inc
Functions
project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • i2s
  • fullduplex_dma
  • inc
Functions
project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • i2s
  • halfduplex_dma
  • inc
Functions
project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • i2s
  • halfduplex_interrupt
  • inc
Functions
project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
Functions
project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • irtmr
  • irtmr_output
  • inc
Functions
project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_alarm
  • inc
Functions
project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_tamper
  • inc
Functions
project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_wakeup
  • inc
Functions
project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • pwc
  • ldo_set
  • inc
Functions
project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • pwc
  • power_voltage_monitor
  • inc
Functions
project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • pwc
  • sleep_tmr2
  • inc
Functions
project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • pwc
  • sleep_usart1
  • inc
Functions
project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • pwc
  • standby_ertc_alarm
  • inc
Functions
project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • pwc
  • standby_wakeup_pin
  • inc
Functions
project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma
  • inc
Functions
project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_and_pem
  • inc
Functions
project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
  • inc
Functions
project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_interrupt
  • inc
Functions
project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_polling
  • inc
Functions
project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_rdsr_sw
  • inc
Functions
project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • qspi
  • xip_port_write_read
  • inc
Functions
project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • scfg
  • mem_map_sel
  • inc
Functions
project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • sdio
  • sd_mmc_card
  • inc
Functions
project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • sdio
  • sdio_fatfs
  • inc
Functions
project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • spi
  • crc_transfer_polling
  • inc
Functions
project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • spi
  • fullduplex_polling
  • inc
Functions
project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • spi
  • halfduplex_interrupt
  • inc
Functions
project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • spi
  • halfduplex_transceiver_switch
  • inc
Functions
project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • spi
  • only_receive_mode_polling
  • inc
Functions
project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • spi
  • ti_fullduplex_dma
  • inc
Functions
project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
Functions
project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • spi
  • w25q_flash
  • inc
Functions
project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • sram
  • extend_sram
  • inc
Functions
project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • 6_steps
  • inc
Functions
project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • 7_pwm_output
  • inc
Functions
project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • cascade_synchro
  • inc
Functions
project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • complementary_signals
  • inc
Functions
project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • dma
  • inc
Functions
project/at_start_f435/examples/tmr/dma/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/dma/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • dma_burst
  • inc
Functions
project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • encoder_tmr2
  • inc
Functions
project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • external_clock
  • inc
Functions
project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • hall_xor_tmr2
  • inc
Functions
project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • hang_mode
  • inc
Functions
project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • input_capture
  • inc
Functions
project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • oc_high
  • inc
Functions
project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • oc_low
  • inc
Functions
project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr3
  • inc
Functions
project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr9
  • inc
Functions
project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • one_cycle
  • inc
Functions
project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • parallel_synchro
  • inc
Functions
project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_input
  • inc
Functions
project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_input_dma
  • inc
Functions
project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_simulate
  • inc
Functions
project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr10
  • inc
Functions
project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr3
  • inc
Functions
project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • timer_base
  • inc
Functions
project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • tmr1_synchro
  • inc
Functions
project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • tmr
  • tmr2_32bit
  • inc
Functions
project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usart
  • half_duplex
  • inc
Functions
project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usart
  • hw_flow_control
  • inc
Functions
project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usart
  • idle_detection
  • inc
Functions
project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usart
  • interrupt
  • inc
Functions
project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usart
  • irda
  • inc
Functions
project/at_start_f435/examples/usart/irda/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/irda/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usart
  • polling
  • inc
Functions
project/at_start_f435/examples/usart/polling/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/polling/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usart
  • printf
  • inc
Functions
project/at_start_f435/examples/usart/printf/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/printf/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usart
  • receiver_mute
  • inc
Functions
project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usart
  • rs485
  • inc
Functions
project/at_start_f435/examples/usart/rs485/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/rs485/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usart
  • smartcard
  • inc
Functions
project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usart
  • synchronous
  • inc
Functions
project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_interrupt
  • inc
Functions
project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_polling
  • inc
Functions
project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usart
  • tx_rx_swap
  • inc
Functions
project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • audio
  • inc
Functions
project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_audio_hid
  • inc
Functions
project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_keyboard
  • inc
Functions
project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_msc
  • inc
Functions
project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • custom_hid
  • inc
Functions
project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • keyboard
  • inc
Functions
project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • mouse
  • inc
Functions
project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • msc
  • inc
Functions
project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
  • inc
Functions
project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • printer
  • inc
Functions
project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • two_otg_device_demo
  • inc
Functions
project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • vcp_loopback
  • inc
Functions
project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • virtual_comport
  • inc
Functions
project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • virtual_msc_iap
  • inc
Functions
project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usb_host
  • hid_demo
  • inc
Functions
project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usb_host
  • msc_only_fat32
  • inc
Functions
project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • usb_host
  • two_otg_host_demo
  • inc
Functions
project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • wdt
  • wdt_reset
  • inc
Functions
project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • wdt
  • wdt_standby
  • inc
Functions
project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • wwdt
  • wwdt_reset
  • inc
Functions
project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • xmc
  • lcd_8bit
  • inc
Functions
project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • xmc
  • lcd_touch_16bit
  • inc
Functions
project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • xmc
  • nand_flash
  • ecc
  • inc
Functions
project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • xmc
  • nand_flash
  • nand
  • inc
Functions
project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • xmc
  • nor_flash
  • inc
Functions
project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • xmc
  • psram
  • inc
Functions
project/at_start_f435/examples/xmc/psram/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/psram/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • xmc
  • sdram_basic
  • inc
Functions
project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • xmc
  • sdram_dma
  • inc
Functions
project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • examples
  • xmc
  • sram
  • inc
Functions
project/at_start_f435/examples/xmc/sram/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/xmc/sram/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f435
  • templates
  • inc
Functions
project/at_start_f435/templates/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/templates/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • acc
  • calibration
  • inc
Functions
project/at_start_f437/examples/acc/calibration/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/acc/calibration/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma3
  • inc
Functions
project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma4
  • inc
Functions
project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_dma2
  • inc
Functions
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_edma
  • inc
Functions
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma1
  • inc
Functions
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma5
  • inc
Functions
project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_preempt_interltrig_twoslave
  • inc
Functions
project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • adc
  • conversion_abort
  • inc
Functions
project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • adc
  • current_vref_value_check
  • inc
Functions
project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • adc
  • edma_double_buffer
  • inc
Functions
project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • adc
  • exint_trigger_partitioned
  • inc
Functions
project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • adc
  • internal_temperature_sensor
  • inc
Functions
project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • adc
  • ordinary_preempt_oversampling
  • inc
Functions
project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • adc
  • resolution_6bit
  • inc
Functions
project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • adc
  • software_trigger_repeat
  • inc
Functions
project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • adc
  • tmr_trigger_automatic_preempted
  • inc
Functions
project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • adc
  • use_polling_get_conversion_data
  • inc
Functions
project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • adc
  • vbat_monitor
  • inc
Functions
project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • adc
  • voltage_monitoring
  • inc
Functions
project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • can
  • communication_mode
  • inc
Functions
project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • can
  • filter
  • inc
Functions
project/at_start_f437/examples/can/filter/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/can/filter/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • can
  • loopback_mode
  • inc
Functions
project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • bit_band
  • inc
Functions
project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • inc
Functions
project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • fpu
  • inc
Functions
project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • systick_interrupt
  • inc
Functions
project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • crc
  • calculation
  • inc
Functions
project/at_start_f437/examples/crc/calculation/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/crc/calculation/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • crm
  • clock_failure_detection
  • inc
Functions
project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • crm
  • pll_parameter_calculate
  • inc
Functions
project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • crm
  • sysclk_switch
  • inc
Functions
project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • dac
  • double_mode_dma_sinewave
  • inc
Functions
project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • dac
  • double_mode_dma_squarewave
  • inc
Functions
project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • dac
  • one_dac_dma_escalator
  • inc
Functions
project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • dac
  • one_dac_noisewave
  • inc
Functions
project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • dac
  • two_dac_trianglewave
  • inc
Functions
project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • debug
  • tmr1
  • inc
Functions
project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • dma
  • dmamux_data_to_gpio
  • inc
Functions
project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • dma
  • dmamux_genertor_exint
  • inc
Functions
project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • dma
  • dmamux_synchronization_exint
  • inc
Functions
project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • dma
  • flash_to_sram
  • inc
Functions
project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • inc
Functions
project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • inc
Functions
project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • edma
  • burst_mode
  • inc
Functions
project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • edma
  • dmamux_genertor_exint
  • inc
Functions
project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • edma
  • dmamux_synchronization_exint
  • inc
Functions
project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • edma
  • flash_to_sram
  • inc
Functions
project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • edma
  • i2s_halfduplex_edma_doublebuffer
  • inc
Functions
project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • edma
  • link_list_mode
  • inc
Functions
project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • edma
  • two_dimension_mode
  • inc
Functions
project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • emac
  • dns_client
  • inc
Functions
project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • emac
  • http_server
  • inc
Functions
project/at_start_f437/examples/emac/http_server/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/emac/http_server/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • emac
  • iperf
  • inc
Functions
project/at_start_f437/examples/emac/iperf/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/emac/iperf/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • emac
  • mqtt_client
  • inc
Functions
project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • emac
  • tcp_client
  • inc
Functions
project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • emac
  • tcp_server
  • inc
Functions
project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • emac
  • telnet
  • inc
Functions
project/at_start_f437/examples/emac/telnet/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/emac/telnet/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • emac
  • wake_on_lan
  • inc
Functions
project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • ertc
  • bpr_domain
  • inc
Functions
project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • ertc
  • calendar
  • inc
Functions
project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • ertc
  • lick_calibration
  • inc
Functions
project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • ertc
  • tamper
  • inc
Functions
project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • ertc
  • time_stamp
  • inc
Functions
project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • ertc
  • wakeup_timer
  • inc
Functions
project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • exint
  • exint_config
  • inc
Functions
project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • exint
  • exint_software_trigger
  • inc
Functions
project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • flash
  • fap_enable
  • inc
Functions
project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • flash
  • flash_write_read
  • inc
Functions
project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • gpio
  • io_toggle
  • inc
Functions
project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • gpio
  • led_toggle
  • inc
Functions
project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • gpio
  • swjtag_mux
  • inc
Functions
project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • i2c
  • communication_dma
  • inc
Functions
project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • i2c
  • communication_int
  • inc
Functions
project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • i2c
  • communication_poll
  • inc
Functions
project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • i2c
  • communication_smbus
  • inc
Functions
project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • i2c
  • eeprom
  • inc
Functions
project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • i2s
  • fullduplex_dma
  • inc
Functions
project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • i2s
  • halfduplex_dma
  • inc
Functions
project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • i2s
  • halfduplex_interrupt
  • inc
Functions
project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
Functions
project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • irtmr
  • irtmr_output
  • inc
Functions
project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • pwc
  • deepsleep_ertc_alarm
  • inc
Functions
project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • pwc
  • deepsleep_ertc_tamper
  • inc
Functions
project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • pwc
  • deepsleep_ertc_wakeup
  • inc
Functions
project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • pwc
  • ldo_set
  • inc
Functions
project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • pwc
  • power_voltage_monitor
  • inc
Functions
project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • pwc
  • sleep_tmr2
  • inc
Functions
project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • pwc
  • sleep_usart1
  • inc
Functions
project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • pwc
  • standby_ertc_alarm
  • inc
Functions
project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • pwc
  • standby_wakeup_pin
  • inc
Functions
project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_dma
  • inc
Functions
project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_dma_and_pem
  • inc
Functions
project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
  • inc
Functions
project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_interrupt
  • inc
Functions
project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_polling
  • inc
Functions
project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_rdsr_sw
  • inc
Functions
project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • qspi
  • xip_port_write_read
  • inc
Functions
project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • scfg
  • mem_map_sel
  • inc
Functions
project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • sdio
  • sd_mmc_card
  • inc
Functions
project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • sdio
  • sdio_fatfs
  • inc
Functions
project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • spi
  • crc_transfer_polling
  • inc
Functions
project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • spi
  • fullduplex_polling
  • inc
Functions
project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • spi
  • halfduplex_interrupt
  • inc
Functions
project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • spi
  • halfduplex_transceiver_switch
  • inc
Functions
project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • spi
  • only_receive_mode_polling
  • inc
Functions
project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • spi
  • ti_fullduplex_dma
  • inc
Functions
project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
Functions
project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • spi
  • w25q_flash
  • inc
Functions
project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • sram
  • extend_sram
  • inc
Functions
project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • 6_steps
  • inc
Functions
project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • 7_pwm_output
  • inc
Functions
project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • cascade_synchro
  • inc
Functions
project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • complementary_signals
  • inc
Functions
project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • dma
  • inc
Functions
project/at_start_f437/examples/tmr/dma/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/dma/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • dma_burst
  • inc
Functions
project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • encoder_tmr2
  • inc
Functions
project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • external_clock
  • inc
Functions
project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • hall_xor_tmr2
  • inc
Functions
project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • hang_mode
  • inc
Functions
project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • input_capture
  • inc
Functions
project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • oc_high
  • inc
Functions
project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • oc_low
  • inc
Functions
project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • oc_toggle_tmr3
  • inc
Functions
project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • oc_toggle_tmr9
  • inc
Functions
project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • one_cycle
  • inc
Functions
project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • parallel_synchro
  • inc
Functions
project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_input
  • inc
Functions
project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_input_dma
  • inc
Functions
project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_output_simulate
  • inc
Functions
project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_output_tmr10
  • inc
Functions
project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_output_tmr3
  • inc
Functions
project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • timer_base
  • inc
Functions
project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • tmr1_synchro
  • inc
Functions
project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • tmr
  • tmr2_32bit
  • inc
Functions
project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usart
  • half_duplex
  • inc
Functions
project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usart
  • hw_flow_control
  • inc
Functions
project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usart
  • idle_detection
  • inc
Functions
project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usart
  • interrupt
  • inc
Functions
project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usart
  • irda
  • inc
Functions
project/at_start_f437/examples/usart/irda/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/irda/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usart
  • polling
  • inc
Functions
project/at_start_f437/examples/usart/polling/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/polling/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usart
  • printf
  • inc
Functions
project/at_start_f437/examples/usart/printf/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/printf/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usart
  • receiver_mute
  • inc
Functions
project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usart
  • rs485
  • inc
Functions
project/at_start_f437/examples/usart/rs485/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/rs485/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usart
  • smartcard
  • inc
Functions
project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usart
  • synchronous
  • inc
Functions
project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usart
  • transfer_by_dma_interrupt
  • inc
Functions
project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usart
  • transfer_by_dma_polling
  • inc
Functions
project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usart
  • tx_rx_swap
  • inc
Functions
project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • audio
  • inc
Functions
project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • composite_audio_hid
  • inc
Functions
project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • composite_vcp_keyboard
  • inc
Functions
project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • composite_vcp_msc
  • inc
Functions
project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • custom_hid
  • inc
Functions
project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • keyboard
  • inc
Functions
project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • mouse
  • inc
Functions
project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • msc
  • inc
Functions
project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
  • inc
Functions
project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • printer
  • inc
Functions
project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • two_otg_device_demo
  • inc
Functions
project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • vcp_loopback
  • inc
Functions
project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • virtual_comport
  • inc
Functions
project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • virtual_msc_iap
  • inc
Functions
project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usb_host
  • hid_demo
  • inc
Functions
project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usb_host
  • msc_only_fat32
  • inc
Functions
project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • usb_host
  • two_otg_host_demo
  • inc
Functions
project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • wdt
  • wdt_reset
  • inc
Functions
project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • wdt
  • wdt_standby
  • inc
Functions
project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • wwdt
  • wwdt_reset
  • inc
Functions
project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • xmc
  • lcd_8bit
  • inc
Functions
project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • xmc
  • lcd_touch_16bit
  • inc
Functions
project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • xmc
  • nand_flash
  • ecc
  • inc
Functions
project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • xmc
  • nand_flash
  • nand
  • inc
Functions
project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • xmc
  • nor_flash
  • inc
Functions
project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • xmc
  • psram
  • inc
Functions
project/at_start_f437/examples/xmc/psram/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/psram/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • xmc
  • sdram_basic
  • inc
Functions
project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • xmc
  • sdram_dma
  • inc
Functions
project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • examples
  • xmc
  • sram
  • inc
Functions
project/at_start_f437/examples/xmc/sram/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/xmc/sram/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • at_start_f437
  • templates
  • inc
Functions
project/at_start_f437/templates/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/templates/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • utilities
  • at32f435_437_freertos_demo
  • inc
Functions
utilities/at32f435_437_freertos_demo/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_freertos_demo/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • utilities
  • at32f435_437_gen_random_number_demo
  • inc
Functions
utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • utilities
  • at32f435_437_slib_demo
  • project_l0
  • inc
Functions
utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • utilities
  • at32f435_437_slib_demo
  • project_l1
  • inc
Functions
utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Functions
utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Functions
utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • bootloader
  • inc
Functions
utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Functions
utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Functions
utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • bootloader
  • inc
Functions
utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Functions
utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: at32f435_437_int.h File Reference

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • bootloader
  • inc
Functions
utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_int.h.


AT32F435/437 Firmwary Library: usb_conf.h File Reference

  • at_start_f435
  • examples
  • acc
  • calibration
  • inc
Macros | Functions
project/at_start_f435/examples/acc/calibration/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f435_437_usb.h"
#include "at32f435_437.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
this function handles otgfs interrupt. More...
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/acc/calibration/inc/usb_conf.h.


AT32F435/437 Firmwary Library: usb_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • audio
  • inc
Macros | Functions
project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f435_437_usb.h"
#include "at32f435_437.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 64
#define | USBD_EP2_TX_SIZE 16
#define | USBD_EP3_TX_SIZE 16
#define | USBD_EP4_TX_SIZE 0
#define | USBD_EP5_TX_SIZE 0
#define | USBD_EP6_TX_SIZE 0
#define | USBD_EP7_TX_SIZE 0
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 64
#define | USBD2_EP2_TX_SIZE 4
#define | USBD2_EP3_TX_SIZE 0
#define | USBD2_EP4_TX_SIZE 0
#define | USBD2_EP5_TX_SIZE 0
#define | USBD2_EP6_TX_SIZE 0
#define | USBD2_EP7_TX_SIZE 0
#define | USB_VBUS_IGNORE
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h.


AT32F435/437 Firmwary Library: usb_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_audio_hid
  • inc
Macros | Functions
project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f435_437_usb.h"
#include "at32f435_437.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 64
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 16
#define | USBD_EP4_TX_SIZE 0
#define | USBD_EP5_TX_SIZE 0
#define | USBD_EP6_TX_SIZE 0
#define | USBD_EP7_TX_SIZE 0
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 64
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 16
#define | USBD2_EP4_TX_SIZE 0
#define | USBD2_EP5_TX_SIZE 0
#define | USBD2_EP6_TX_SIZE 0
#define | USBD2_EP7_TX_SIZE 0
#define | USB_VBUS_IGNORE
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h.


AT32F435/437 Firmwary Library: usb_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_keyboard
  • inc
Macros | Functions
project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f435_437_usb.h"
#include "at32f435_437.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | USB_LOW_POWER_WAKUP
usb low power wakeup handler enable More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.


AT32F435/437 Firmwary Library: usb_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_msc
  • inc
Macros | Functions
project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f435_437_usb.h"
#include "at32f435_437.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | USB_LOW_POWER_WAKUP
usb low power wakeup handler enable More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.


AT32F435/437 Firmwary Library: usb_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • custom_hid
  • inc
Macros | Functions
project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f435_437_usb.h"
#include "at32f435_437.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h.


AT32F435/437 Firmwary Library: usb_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • keyboard
  • inc
Macros | Functions
project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f435_437_usb.h"
#include "at32f435_437.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h.


AT32F435/437 Firmwary Library: usb_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • mouse
  • inc
Macros | Functions
project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f435_437_usb.h"
#include "at32f435_437.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | USB_LOW_POWER_WAKUP
usb low power wakeup handler enable More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h.


AT32F435/437 Firmwary Library: usb_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • msc
  • inc
Macros | Functions
project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f435_437_usb.h"
#include "at32f435_437.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h.


AT32F435/437 Firmwary Library: usb_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
  • inc
Macros | Functions
project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f435_437_usb.h"
#include "at32f435_437.h"
#include "at32f435_437_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | USE_OTG_HOST_MODE
enable usb host mode More...
#define | USB_ID 0
select otgfs1 or otgfs2 define More...
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | OTG_PIN_POWER_SWITCH_GPIO GPIOH
#define | OTG_PIN_POWER_SWITCH_CLOCK CRM_GPIOH_PERIPH_CLOCK
#define | OTG_PIN_POWER_SWITCH GPIO_PINS_3
#define | USB2_ID 1
#define | OTG2_CLOCK CRM_OTGFS2_PERIPH_CLOCK
#define | OTG2_IRQ OTGFS2_IRQn
#define | OTG2_IRQ_HANDLER OTGFS2_IRQHandler
this function handles otgfs interrupt. More...
#define | OTG2_WKUP_IRQ OTGFS2_WKUP_IRQn
#define | OTG2_WKUP_HANDLER OTGFS2_WKUP_IRQHandler
#define | OTG2_WKUP_EXINT_LINE EXINT_LINE_20
#define | OTG2_PIN_GPIO GPIOB
#define | OTG2_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK
#define | OTG2_PIN_DP GPIO_PINS_15
#define | OTG2_PIN_DP_SOURCE GPIO_PINS_SOURCE15
#define | OTG2_PIN_DM GPIO_PINS_14
#define | OTG2_PIN_DM_SOURCE GPIO_PINS_SOURCE14
#define | OTG2_PIN_VBUS GPIO_PINS_13
#define | OTG2_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13
#define | OTG2_PIN_ID GPIO_PINS_12
#define | OTG2_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG2_PIN_SOF_GPIO GPIOA
#define | OTG2_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG2_PIN_SOF GPIO_PINS_4
#define | OTG2_PIN_SOF_SOURCE GPIO_PINS_SOURCE4
#define | OTG2_PIN_MUX GPIO_MUX_12
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USBH_RX_FIFO_SIZE 128
usb endpoint max num define More...
#define | USBH_NP_TX_FIFO_SIZE 96
#define | USBH_P_TX_FIFO_SIZE 96
#define | USBH2_RX_FIFO_SIZE 128
#define | USBH2_NP_TX_FIFO_SIZE 96
#define | USBH2_P_TX_FIFO_SIZE 96
#define | USBH_5V_POWER_SWITCH
#define | USB_VBUS_IGNORE
usb sof output enable More...
#define | USBH_DEBUG_ENABLE
usb low power wakeup handler enable More...
#define | USBH_DEBUG(...)

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h.


AT32F435/437 Firmwary Library: usb_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • printer
  • inc
Macros | Functions
project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f435_437_usb.h"
#include "at32f435_437.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h.


AT32F435/437 Firmwary Library: usb_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • two_otg_device_demo
  • inc
Macros | Functions
project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f435_437_usb.h"
#include "at32f435_437.h"
#include "at32f435_437_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | USB_ID 0
enable usb host mode More...
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USB2_ID 1
#define | OTG2_CLOCK CRM_OTGFS2_PERIPH_CLOCK
#define | OTG2_IRQ OTGFS2_IRQn
#define | OTG2_IRQ_HANDLER OTGFS2_IRQHandler
#define | OTG2_WKUP_IRQ OTGFS2_WKUP_IRQn
#define | OTG2_WKUP_HANDLER OTGFS2_WKUP_IRQHandler
#define | OTG2_WKUP_EXINT_LINE EXINT_LINE_20
#define | OTG2_PIN_GPIO GPIOB
#define | OTG2_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK
#define | OTG2_PIN_DP GPIO_PINS_15
#define | OTG2_PIN_DP_SOURCE GPIO_PINS_SOURCE15
#define | OTG2_PIN_DM GPIO_PINS_14
#define | OTG2_PIN_DM_SOURCE GPIO_PINS_SOURCE14
#define | OTG2_PIN_VBUS GPIO_PINS_13
#define | OTG2_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13
#define | OTG2_PIN_ID GPIO_PINS_12
#define | OTG2_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG2_PIN_SOF_GPIO GPIOA
#define | OTG2_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG2_PIN_SOF GPIO_PINS_4
#define | OTG2_PIN_SOF_SOURCE GPIO_PINS_SOURCE4
#define | OTG2_PIN_MUX GPIO_MUX_12
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h.


AT32F435/437 Firmwary Library: usb_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • vcp_loopback
  • inc
Macros | Functions
project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f435_437_usb.h"
#include "at32f435_437.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h.


AT32F435/437 Firmwary Library: usb_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • virtual_comport
  • inc
Macros | Functions
project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f435_437_usb.h"
#include "at32f435_437.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...
#define | USB_VIRTUAL_COMPORT
usb low power wakeup handler enable More...

Functions

void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h.


AT32F435/437 Firmwary Library: usb_conf.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • virtual_msc_iap
  • inc
Macros | Functions
project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f435_437_usb.h"
#include "at32f435_437.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.


AT32F435/437 Firmwary Library: usb_conf.h File Reference

  • at_start_f435
  • examples
  • usb_host
  • hid_demo
  • inc
Macros | Functions
project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f435_437_usb.h"
#include "at32f435_437.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USE_OTG_HOST_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
select otgfs1 or otgfs2 define More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | OTG_PIN_POWER_SWITCH_GPIO GPIOH
#define | OTG_PIN_POWER_SWITCH_CLOCK CRM_GPIOH_PERIPH_CLOCK
#define | OTG_PIN_POWER_SWITCH GPIO_PINS_3
#define | USBH_RX_FIFO_SIZE 128
usb device mode config More...
#define | USBH_NP_TX_FIFO_SIZE 96
#define | USBH_P_TX_FIFO_SIZE 96
#define | USBH2_RX_FIFO_SIZE 128
#define | USBH2_NP_TX_FIFO_SIZE 96
#define | USBH2_P_TX_FIFO_SIZE 96
#define | USBH_5V_POWER_SWITCH
#define | USB_VBUS_IGNORE
usb sof output enable More...
#define | USBH_DEBUG_ENABLE
usb low power wakeup handler enable More...
#define | USBH_DEBUG(...)

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h.


AT32F435/437 Firmwary Library: usb_conf.h File Reference

  • at_start_f435
  • examples
  • usb_host
  • msc_only_fat32
  • inc
Macros | Functions
project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f435_437_usb.h"
#include "at32f435_437.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USE_OTG_HOST_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
select otgfs1 or otgfs2 define More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | OTG_PIN_POWER_SWITCH_GPIO GPIOH
#define | OTG_PIN_POWER_SWITCH_CLOCK CRM_GPIOH_PERIPH_CLOCK
#define | OTG_PIN_POWER_SWITCH GPIO_PINS_3
#define | USBH_RX_FIFO_SIZE 128
usb device mode config More...
#define | USBH_NP_TX_FIFO_SIZE 96
#define | USBH_P_TX_FIFO_SIZE 96
#define | USBH2_RX_FIFO_SIZE 128
#define | USBH2_NP_TX_FIFO_SIZE 96
#define | USBH2_P_TX_FIFO_SIZE 96
#define | USBH_5V_POWER_SWITCH
#define | USB_VBUS_IGNORE
usb sof output enable More...
#define | USBH_DEBUG_ENABLE
usb low power wakeup handler enable More...
#define | USBH_DEBUG(...)

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h.


AT32F435/437 Firmwary Library: usb_conf.h File Reference

  • at_start_f435
  • examples
  • usb_host
  • two_otg_host_demo
  • inc
Macros | Functions
project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f435_437_usb.h"
#include "at32f435_437.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USE_OTG_HOST_MODE
enable usb device mode More...
#define | USB_ID 0
select otgfs1 or otgfs2 define More...
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | OTG_PIN_POWER_SWITCH_GPIO GPIOH
#define | OTG_PIN_POWER_SWITCH_CLOCK CRM_GPIOH_PERIPH_CLOCK
#define | OTG_PIN_POWER_SWITCH GPIO_PINS_3
#define | USB2_ID 1
#define | OTG2_CLOCK CRM_OTGFS2_PERIPH_CLOCK
#define | OTG2_IRQ OTGFS2_IRQn
#define | OTG2_IRQ_HANDLER OTGFS2_IRQHandler
#define | OTG2_WKUP_IRQ OTGFS2_WKUP_IRQn
#define | OTG2_WKUP_HANDLER OTGFS2_WKUP_IRQHandler
#define | OTG2_WKUP_EXINT_LINE EXINT_LINE_20
#define | OTG2_PIN_GPIO GPIOB
#define | OTG2_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK
#define | OTG2_PIN_DP GPIO_PINS_15
#define | OTG2_PIN_DP_SOURCE GPIO_PINS_SOURCE15
#define | OTG2_PIN_DM GPIO_PINS_14
#define | OTG2_PIN_DM_SOURCE GPIO_PINS_SOURCE14
#define | OTG2_PIN_VBUS GPIO_PINS_13
#define | OTG2_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13
#define | OTG2_PIN_ID GPIO_PINS_12
#define | OTG2_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG2_PIN_SOF_GPIO GPIOA
#define | OTG2_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG2_PIN_SOF GPIO_PINS_4
#define | OTG2_PIN_SOF_SOURCE GPIO_PINS_SOURCE4
#define | OTG2_PIN_MUX GPIO_MUX_12
#define | OTG2_PIN_POWER_SWITCH_GPIO GPIOB
#define | OTG2_PIN_POWER_SWITCH_CLOCK CRM_GPIOB_PERIPH_CLOCK
#define | OTG2_PIN_POWER_SWITCH GPIO_PINS_10
#define | USBH_RX_FIFO_SIZE 128
usb device mode config More...
#define | USBH_NP_TX_FIFO_SIZE 96
#define | USBH_P_TX_FIFO_SIZE 96
#define | USBH2_RX_FIFO_SIZE 128
#define | USBH2_NP_TX_FIFO_SIZE 96
#define | USBH2_P_TX_FIFO_SIZE 96
#define | USBH_5V_POWER_SWITCH
#define | USB_VBUS_IGNORE
usb sof output enable More...
#define | USBH_DEBUG_ENABLE
usb low power wakeup handler enable More...
#define | USBH_DEBUG(...)

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h.


AT32F435/437 Firmwary Library: usb_conf.h File Reference

  • at_start_f437
  • examples
  • acc
  • calibration
  • inc
Macros | Functions
project/at_start_f437/examples/acc/calibration/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f435_437_usb.h"
#include "at32f435_437.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 20
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 20
#define | USBD_EP4_TX_SIZE 20
#define | USBD_EP5_TX_SIZE 20
#define | USBD_EP6_TX_SIZE 20
#define | USBD_EP7_TX_SIZE 20
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 20
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 20
#define | USBD2_EP4_TX_SIZE 20
#define | USBD2_EP5_TX_SIZE 20
#define | USBD2_EP6_TX_SIZE 20
#define | USBD2_EP7_TX_SIZE 20
#define | USB_VBUS_IGNORE
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/acc/calibration/inc/usb_conf.h.


AT32F435/437 Firmwary Library: usb_conf.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • audio
  • inc
Macros | Functions
project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f435_437_usb.h"
#include "at32f435_437.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 64
#define | USBD_EP2_TX_SIZE 16
#define | USBD_EP3_TX_SIZE 16
#define | USBD_EP4_TX_SIZE 0
#define | USBD_EP5_TX_SIZE 0
#define | USBD_EP6_TX_SIZE 0
#define | USBD_EP7_TX_SIZE 0
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 64
#define | USBD2_EP2_TX_SIZE 4
#define | USBD2_EP3_TX_SIZE 0
#define | USBD2_EP4_TX_SIZE 0
#define | USBD2_EP5_TX_SIZE 0
#define | USBD2_EP6_TX_SIZE 0
#define | USBD2_EP7_TX_SIZE 0
#define | USB_VBUS_IGNORE
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h.


AT32F435/437 Firmwary Library: usb_conf.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • composite_audio_hid
  • inc
Macros | Functions
project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f435_437_usb.h"
#include "at32f435_437.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | USE_OTG_DEVICE_MODE
enable usb device mode More...
#define | OTG_USB_ID 1
enable usb host mode More...
#define | USB_ID 0
#define | OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
#define | OTG_IRQ OTGFS1_IRQn
#define | OTG_IRQ_HANDLER OTGFS1_IRQHandler
#define | OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
#define | OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
#define | OTG_WKUP_EXINT_LINE EXINT_LINE_18
#define | OTG_PIN_GPIO GPIOA
#define | OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_DP GPIO_PINS_12
#define | OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
#define | OTG_PIN_DM GPIO_PINS_11
#define | OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
#define | OTG_PIN_VBUS GPIO_PINS_9
#define | OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
#define | OTG_PIN_ID GPIO_PINS_10
#define | OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
#define | OTG_PIN_SOF_GPIO GPIOA
#define | OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
#define | OTG_PIN_SOF GPIO_PINS_8
#define | OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
#define | OTG_PIN_MUX GPIO_MUX_10
#define | USBD_RX_SIZE 128
usb device mode config More...
#define | USBD_EP0_TX_SIZE 24
#define | USBD_EP1_TX_SIZE 64
#define | USBD_EP2_TX_SIZE 20
#define | USBD_EP3_TX_SIZE 16
#define | USBD_EP4_TX_SIZE 0
#define | USBD_EP5_TX_SIZE 0
#define | USBD_EP6_TX_SIZE 0
#define | USBD_EP7_TX_SIZE 0
#define | USBD2_RX_SIZE 128
#define | USBD2_EP0_TX_SIZE 24
#define | USBD2_EP1_TX_SIZE 64
#define | USBD2_EP2_TX_SIZE 20
#define | USBD2_EP3_TX_SIZE 16
#define | USBD2_EP4_TX_SIZE 0
#define | USBD2_EP5_TX_SIZE 0
#define | USBD2_EP6_TX_SIZE 0
#define | USBD2_EP7_TX_SIZE 0
#define | USB_VBUS_IGNORE
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h.


AT32F435/437 Firmwary Library: FlashDev.c File Reference

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • keil_flm
  • src
Variables
FlashDev.c File Reference

device description for new device flash More...

#include "FlashOS.H"

Go to the source code of this file.

Variables

struct FlashDevice const FlashDevice

Detailed Description

device description for new device flash

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file FlashDev.c.


AT32F435/437 Firmwary Library: FlashDev.c Source File

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • keil_flm
  • src
FlashDev.c
Go to the documentation of this file.
1
27#include "FlashOS.H" // FlashOS Structures
28
37struct FlashDevice const FlashDevice = {
38 FLASH_DRV_VERS, // Driver Version, do not modify!
39 "AT32F435/437 QSPI1 ESMT32M", // Device Name
40 EXTSPI, // Device Type
41 0x90000000, // Device Start Address
42 16*1024*1024, // Device Size in Bytes
43 256, // Programming Page Size
44 0, // Reserved, must be 0
45 0xFF, // Initial Content of Erased Memory
46 1000, // Program Page Timeout mSec
47 1000, // Erase Sector Timeout mSec
48
49// Specify Size and Address of Sectors
50 4096, 0x000000, // Sector Size (1 Sectors)
51 SECTOR_END
52};
53
FlashOS.h
SECTOR_END
#define SECTOR_END
Definition: FlashOS.h:28
EXTSPI
#define EXTSPI
Definition: FlashOS.h:18
FLASH_DRV_VERS
#define FLASH_DRV_VERS
Definition: FlashOS.h:46
FlashDevice
Definition: FlashOS.h:30


AT32F435/437 Firmwary Library: FlashOS.h File Reference

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • keil_flm
  • inc
Data Structures | Macros | Functions
FlashOS.h File Reference

Go to the source code of this file.

Data Structures

struct | FlashSectors
struct | FlashDevice

Macros

#define | VERS 1
#define | UNKNOWN 0
#define | ONCHIP 1
#define | EXT8BIT 2
#define | EXT16BIT 3
#define | EXT32BIT 4
#define | EXTSPI 5
#define | SECTOR_NUM 512
#define | PAGE_MAX 65536
#define | SECTOR_END 0xFFFFFFFF, 0xFFFFFFFF
#define | FLASH_DRV_VERS (0x0100+VERS)

Functions

int | Init (unsigned long adr, unsigned long clk, unsigned long fnc)
initialize flash. More...
int | UnInit (unsigned long fnc)
de-initialize flash. More...
int | BlankCheck (unsigned long adr, unsigned long sz, unsigned char pat)
int | EraseChip (void)
int | EraseSector (unsigned long adr)
erase sector. More...
int | ProgramPage (unsigned long adr, unsigned long sz, unsigned char *buf)
program page. More...
unsigned long | Verify (unsigned long adr, unsigned long sz, unsigned char *buf)

Macro Definition Documentation

◆ EXT16BIT

#define EXT16BIT 3

Definition at line 16 of file FlashOS.h.

◆ EXT32BIT

#define EXT32BIT 4

Definition at line 17 of file FlashOS.h.

◆ EXT8BIT

#define EXT8BIT 2

Definition at line 15 of file FlashOS.h.

◆ EXTSPI

#define EXTSPI 5

Definition at line 18 of file FlashOS.h.

◆ FLASH_DRV_VERS

#define FLASH_DRV_VERS (0x0100+VERS)

Definition at line 46 of file FlashOS.h.

◆ ONCHIP

#define ONCHIP 1

Definition at line 14 of file FlashOS.h.

◆ PAGE_MAX

#define PAGE_MAX 65536

Definition at line 21 of file FlashOS.h.

◆ SECTOR_END

#define SECTOR_END 0xFFFFFFFF, 0xFFFFFFFF

Definition at line 28 of file FlashOS.h.

◆ SECTOR_NUM

#define SECTOR_NUM 512

Definition at line 20 of file FlashOS.h.

◆ UNKNOWN

#define UNKNOWN 0

Definition at line 13 of file FlashOS.h.

◆ VERS

#define VERS 1

Definition at line 11 of file FlashOS.h.

Function Documentation

◆ BlankCheck()

int BlankCheck | ( | unsigned long | adr,
 |  | unsigned long | sz,
 |  | unsigned char | pat
 | ) |  |

◆ Verify()

unsigned long Verify | ( | unsigned long | adr,
 |  | unsigned long | sz,
 |  | unsigned char * | buf
 | ) |  |


AT32F435/437 Firmwary Library: FlashOS.h Source File

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • keil_flm
  • inc
FlashOS.h
Go to the documentation of this file.
1/***********************************************************************/
2/* This file is part of the ARM Toolchain package */
3/* Copyright KEIL ELEKTRONIK GmbH 2003 - 2007 */
4/***********************************************************************/
5/* */
6/* FlashOS.H: Data structures and entries */
7/* for Flash Programming Functions */
8/* */
9/***********************************************************************/
10
11#define VERS 1 // Interface Version 1.01
12
13#define UNKNOWN 0 // Unknown
14#define ONCHIP 1 // On-chip Flash Memory
15#define EXT8BIT 2 // External Flash Device on 8-bit Bus
16#define EXT16BIT 3 // External Flash Device on 16-bit Bus
17#define EXT32BIT 4 // External Flash Device on 32-bit Bus
18#define EXTSPI 5 // External Flash Device on SPI
19
20#define SECTOR_NUM 512 // Max Number of Sector Items
21#define PAGE_MAX 65536 // Max Page Size for Programming
22
23struct FlashSectors {
24 unsigned long szSector; // Sector Size in Bytes
25 unsigned long AddrSector; // Address of Sector
26};
27
28#define SECTOR_END 0xFFFFFFFF, 0xFFFFFFFF
29
30struct FlashDevice {
31 unsigned short Vers; // Version Number and Architecture
32 char DevName[128]; // Device Name and Description
33 unsigned short DevType; // Device Type: ONCHIP, EXT8BIT, EXT16BIT, ...
34 unsigned long DevAdr; // Default Device Start Address
35 unsigned long szDev; // Total Size of Device
36 unsigned long szPage; // Programming Page Size
37 unsigned long Res; // Reserved for future Extension
38 unsigned char valEmpty; // Content of Erased Memory
39
40 unsigned long toProg; // Time Out of Program Page Function
41 unsigned long toErase; // Time Out of Erase Sector Function
42
43 struct FlashSectors sectors[SECTOR_NUM];
44};
45
46#define FLASH_DRV_VERS (0x0100+VERS) // Driver Version, do not modify!
47
48// Flash Programming Functions (Called by FlashOS)
49extern int Init (unsigned long adr, // Initialize Flash
50 unsigned long clk,
51 unsigned long fnc);
52extern int UnInit (unsigned long fnc); // De-initialize Flash
53extern int BlankCheck (unsigned long adr, // Blank Check
54 unsigned long sz,
55 unsigned char pat);
56extern int EraseChip (void); // Erase complete Device
57extern int EraseSector (unsigned long adr); // Erase Sector Function
58extern int ProgramPage (unsigned long adr, // Program Page Function
59 unsigned long sz,
60 unsigned char *buf);
61extern unsigned long Verify (unsigned long adr, // Verify Function
62 unsigned long sz,
63 unsigned char *buf);
Verify
unsigned long Verify(unsigned long adr, unsigned long sz, unsigned char *buf)
SECTOR_NUM
#define SECTOR_NUM
Definition: FlashOS.h:20
BlankCheck
int BlankCheck(unsigned long adr, unsigned long sz, unsigned char pat)
ProgramPage
int ProgramPage(unsigned long adr, unsigned long sz, unsigned char *buf)
program page.
Definition: FlashPrg.c:377
Init
int Init(unsigned long adr, unsigned long clk, unsigned long fnc)
initialize flash.
Definition: FlashPrg.c:309
UnInit
int UnInit(unsigned long fnc)
de-initialize flash.
Definition: FlashPrg.c:323
EraseChip
int EraseChip(void)
Definition: FlashPrg.c:330
EraseSector
int EraseSector(unsigned long adr)
erase sector.
Definition: FlashPrg.c:352
FlashDevice
Definition: FlashOS.h:30
FlashDevice::toErase
unsigned long toErase
Definition: FlashOS.h:41
FlashDevice::sectors
struct FlashSectors sectors[512]
Definition: FlashOS.h:43
FlashDevice::toProg
unsigned long toProg
Definition: FlashOS.h:40
FlashDevice::Vers
unsigned short Vers
Definition: FlashOS.h:31
FlashDevice::szDev
unsigned long szDev
Definition: FlashOS.h:35
FlashDevice::Res
unsigned long Res
Definition: FlashOS.h:37
FlashDevice::valEmpty
unsigned char valEmpty
Definition: FlashOS.h:38
FlashDevice::DevType
unsigned short DevType
Definition: FlashOS.h:33
FlashDevice::szPage
unsigned long szPage
Definition: FlashOS.h:36
FlashDevice::DevAdr
unsigned long DevAdr
Definition: FlashOS.h:34
FlashDevice::DevName
char DevName[128]
Definition: FlashOS.h:32
FlashSectors
Definition: FlashOS.h:23
FlashSectors::szSector
unsigned long szSector
Definition: FlashOS.h:24
FlashSectors::AddrSector
unsigned long AddrSector
Definition: FlashOS.h:25


AT32F435/437 Firmwary Library: FlashPrg.c File Reference

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • keil_flm
  • src
Functions
FlashPrg.c File Reference

device algorithm for new device flash More...

#include "FlashOS.H"
#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | custom_qspi_xip_enable (confirm_state new_state)
qspi xip mode enable or disable More...
void | custom_xip_enable_config (void)
qspi xip mode enable config More...
void | custom_qspi_rstqpi (void)
esmt32m rstqpi command More...
void | custom_qspi_rsten (void)
esmt32m rsten command More...
void | custom_qspi_rst (void)
esmt32m rst command More...
void | custom_qspi_write_enable (void)
esmt32m write enable command More...
void | custom_qspi_busy_check (void)
esmt32m check busy command More...
void | custom_qspi_sector_erase (uint32_t adr)
esmt32m sector erase command More...
void | custom_qspi_chip_erase (void)
esmt32m chip erase command More...
void | init_clk (void)
sysclk set to pll 96mhz More...
void | uninit_clk (void)
sysclk uninit More...
void | qspi_gpio_init (void)
qspi gpio initilize More...
void | qspi_cmd_init (void)
qspi command port init flow More...
int | Init (unsigned long adr, unsigned long clk, unsigned long fnc)
initialize flash. More...
int | UnInit (unsigned long fnc)
de-initialize flash. More...
int | EraseChip (void)
int | EraseSector (unsigned long adr)
erase sector. More...
int | ProgramPage (unsigned long adr, unsigned long sz, unsigned char *buf)
program page. More...

Detailed Description

device algorithm for new device flash

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file FlashPrg.c.


AT32F435/437 Firmwary Library: FlashPrg.c Source File

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • keil_flm
  • src
FlashPrg.c
Go to the documentation of this file.
1
27#include "FlashOS.H" // FlashOS Structures
28#include "at32f435_437.h"
29
43void custom_qspi_xip_enable(confirm_state new_state)
44{
45 if(new_state == TRUE)
46 {
47 QSPI1->ctrl_bit.xipsel = TRUE;
48 while(QSPI1->xip_cmd_w3_bit.csts != RESET);
49 while(QSPI1->ctrl_bit.xipidle == RESET);
50 }
51 else
52 {
53 while(QSPI1->fifosts_bit.txfifordy == RESET);
54 while((QSPI1->ctrl_bit.abort != RESET) && (QSPI1->ctrl_bit.xipidle == RESET));
55 QSPI1->ctrl_bit.xiprcmdf = TRUE;
56 while(QSPI1->ctrl_bit.abort != RESET || QSPI1->ctrl_bit.xipidle == RESET);
57 QSPI1->ctrl_bit.xipsel = FALSE;
58 }
59}
60
66void custom_xip_enable_config(void)
67{
68 uint32_t xc0_val = 0, xc1_val = 0, xc2_val = 0;
69 qspi_xip_type *custom_xip_config;
70
71 custom_xip_config->read_instruction_code = 0xEB;
72 custom_xip_config->read_address_length = QSPI_XIP_ADDRLEN_3_BYTE;
73 custom_xip_config->read_operation_mode = QSPI_OPERATE_MODE_144;
74 custom_xip_config->read_second_dummy_cycle_num = 6;
75 custom_xip_config->read_select_mode = QSPI_XIPR_SEL_MODED;
76 custom_xip_config->read_time_counter = 0xF;
77 custom_xip_config->read_data_counter = 32;
78
79 /* config analyse xip_cmd_w0 register */
80 xc0_val = (uint32_t)custom_xip_config->read_second_dummy_cycle_num;
81 xc0_val |= (uint32_t)(custom_xip_config->read_operation_mode << 8);
82 xc0_val |= (uint32_t)(custom_xip_config->read_address_length << 11);
83 xc0_val |= (uint32_t)(custom_xip_config->read_instruction_code << 12);
84 QSPI1->xip_cmd_w0 = xc0_val;
85
86 /* config analyse xip_cmd_w1 register */
87 xc1_val = (uint32_t)custom_xip_config->write_second_dummy_cycle_num;
88 xc1_val |= (uint32_t)(custom_xip_config->write_operation_mode << 8);
89 xc1_val |= (uint32_t)(custom_xip_config->write_address_length << 11);
90 xc1_val |= (uint32_t)(custom_xip_config->write_instruction_code << 12);
91 QSPI1->xip_cmd_w1 = xc1_val;
92
93 /* config analyse xip_cmd_w2 register */
94 xc2_val = (uint32_t)custom_xip_config->read_data_counter;
95 xc2_val |= (uint32_t)(custom_xip_config->read_time_counter << 8);
96 xc2_val |= (uint32_t)(custom_xip_config->read_select_mode << 15);
97 xc2_val |= (uint32_t)(custom_xip_config->write_data_counter << 16);
98 xc2_val |= (uint32_t)(custom_xip_config->write_time_counter << 24);
99 xc2_val |= (uint32_t)(custom_xip_config->write_select_mode << 31);
100 QSPI1->xip_cmd_w2 = xc2_val;
101
102 custom_qspi_xip_enable(TRUE);
103}
104
110void custom_qspi_rstqpi(void)
111{
112 QSPI1->cmd_w0 = 0;
113 QSPI1->cmd_w1 = 0x01000000;
114 QSPI1->cmd_w2 = 0;
115 QSPI1->cmd_w3 = 0xFF0000C2;
116 while((flag_status)(QSPI1->cmdsts_bit.cmdsts) == RESET);
117 QSPI1->cmdsts_bit.cmdsts = TRUE;
118}
119
125void custom_qspi_rsten(void)
126{
127 QSPI1->cmd_w0 = 0;
128 QSPI1->cmd_w1 = 0x01000000;
129 QSPI1->cmd_w2 = 0;
130 QSPI1->cmd_w3 = 0x66000002;
131 while((flag_status)(QSPI1->cmdsts_bit.cmdsts) == RESET);
132 QSPI1->cmdsts_bit.cmdsts = TRUE;
133}
134
140void custom_qspi_rst(void)
141{
142 QSPI1->cmd_w0 = 0;
143 QSPI1->cmd_w1 = 0x01000000;
144 QSPI1->cmd_w2 = 0;
145 QSPI1->cmd_w3 = 0x99000002;
146 while((flag_status)(QSPI1->cmdsts_bit.cmdsts) == RESET);
147 QSPI1->cmdsts_bit.cmdsts = TRUE;
148}
149
155void custom_qspi_write_enable(void)
156{
157 QSPI1->cmd_w0 = 0;
158 QSPI1->cmd_w1 = 0x01000000;
159 QSPI1->cmd_w2 = 0;
160 QSPI1->cmd_w3 = 0x06000002;
161 while((flag_status)(QSPI1->cmdsts_bit.cmdsts) == RESET);
162 QSPI1->cmdsts_bit.cmdsts = TRUE;
163}
164
170void custom_qspi_busy_check(void)
171{
172 QSPI1->cmd_w0 = 0;
173 QSPI1->cmd_w1 = 0x01000000;
174 QSPI1->cmd_w2 = 0;
175 QSPI1->cmd_w3 = 0x05000004;
176 while((flag_status)(QSPI1->cmdsts_bit.cmdsts) == RESET);
177 QSPI1->cmdsts_bit.cmdsts = TRUE;
178}
179
185void custom_qspi_sector_erase(uint32_t adr)
186{
187 QSPI1->cmd_w0 = adr;
188 QSPI1->cmd_w1 = 0x01000003;
189 QSPI1->cmd_w2 = 0;
190 QSPI1->cmd_w3 = 0x20000002;
191 while((flag_status)(QSPI1->cmdsts_bit.cmdsts) == RESET);
192 QSPI1->cmdsts_bit.cmdsts = TRUE;
193}
194
200void custom_qspi_chip_erase(void)
201{
202 QSPI1->cmd_w0 = 0;
203 QSPI1->cmd_w1 = 0x01000000;
204 QSPI1->cmd_w2 = 0;
205 QSPI1->cmd_w3 = 0x60000002;
206 while((flag_status)(QSPI1->cmdsts_bit.cmdsts) == RESET);
207 QSPI1->cmdsts_bit.cmdsts = TRUE;
208}
209
215void init_clk(void)
216{
217 /* pll configuration: 96 mhz */
218 CRM->pllcfg = 0x00031801;
219
220 /* enable pll */
221 CRM->ctrl_bit.pllen = TRUE;
222
223 /* wait till pll is ready */
224 while(CRM->ctrl_bit.pllstbl == RESET);
225
226 /* select pll as system clock source */
227 CRM->cfg_bit.sclksel = CRM_SCLK_PLL;
228
229 /* wait till pll is used as system clock source */
230 while (CRM->cfg_bit.sclksts != CRM_SCLK_PLL);
231}
232
238void uninit_clk(void)
239{
240 CRM->cfg_bit.sclksel = CRM_SCLK_HICK;
241 CRM->ctrl_bit.pllen = FALSE;
242 CRM->pllcfg = 0x00033002; /* default */
243}
244
250void qspi_gpio_init(void)
251{
252 /* enable the qspi clock */
253 CRM->ahben3 |= 0x02;
254
255 /* enable the gpio pin clock */
256 CRM->ahben1 |= 0x60;
257
258 /* configure the gpio */
259 GPIOF->cfgr = 0x002AA000;
260 GPIOF->odrvr = 0x00155000;
261 GPIOF->muxl = 0x99000000;
262 GPIOF->muxh = 0x000009AA;
263
264 GPIOG->cfgr = 0x00002000;
265 GPIOG->odrvr = 0x00001000;
266 GPIOG->muxl = 0x0A000000;
267}
268
274void qspi_cmd_init(void)
275{
276 __IO uint32_t num;
277 /* xip disable */
278 custom_qspi_xip_enable(FALSE);
279
280 /* clk mode 0 */
281 QSPI1->ctrl_bit.sckmode = QSPI_SCK_MODE_0;
282
283 /* busy offset 0 */
284 QSPI1->ctrl_bit.busy = QSPI_BUSY_OFFSET_0;
285
286 /* clk div2 */
287 QSPI1->ctrl_bit.clkdiv = QSPI_CLK_DIV_2;
288
289 /* reset qpi mode and reset the device */
290 custom_qspi_rstqpi();
291 custom_qspi_rsten();
292 custom_qspi_rst();
293
294 /* wait about 30us */
295 num = 600;
296 while(num--)
297 {
298 __NOP();
299 }
300}
301
309int Init (unsigned long adr, unsigned long clk, unsigned long fnc)
310{
311 init_clk();
312 qspi_gpio_init();
313 qspi_cmd_init();
314 custom_xip_enable_config();
315 return (0);
316}
317
323int UnInit (unsigned long fnc)
324{
325 uninit_clk();
326 custom_xip_enable_config();
327 return (0);
328}
329
330int EraseChip (void)
331{
332 custom_qspi_xip_enable(FALSE);
333
334 /* qspi write enable */
335 custom_qspi_write_enable();
336
337 /* qspi chip erase */
338 custom_qspi_chip_erase();
339
340 /* qspi check busy */
341 custom_qspi_busy_check();
342
343 custom_xip_enable_config();
344 return (0);
345}
346
352int EraseSector (unsigned long adr)
353{
354 adr -= QSPI1_MEM_BASE;
355 custom_qspi_xip_enable(FALSE);
356
357 /* qspi write enable */
358 custom_qspi_write_enable();
359
360 /* qspi sector erase */
361 custom_qspi_sector_erase(adr);
362
363 /* qspi check busy */
364 custom_qspi_busy_check();
365
366 custom_xip_enable_config();
367 return (0);
368}
369
377int ProgramPage (unsigned long adr, unsigned long sz, unsigned char *buf)
378{
379 uint32_t i;
380 adr -= QSPI1_MEM_BASE;
381 custom_qspi_xip_enable(FALSE);
382 /* qspi write enable */
383 custom_qspi_write_enable();
384
385 /* qspi program */
386 QSPI1->cmd_w0 = adr;
387 QSPI1->cmd_w1 = 0x01000003;
388 QSPI1->cmd_w2 = sz;
389 QSPI1->cmd_w3 = 0x32000042;
390 for(i = 0; i < sz; ++i)
391 {
392 while((flag_status)(QSPI1->fifosts_bit.txfifordy) == RESET);
393 QSPI1->dt_u8 = *buf++;
394 }
395 while((flag_status)(QSPI1->cmdsts_bit.cmdsts) == RESET);
396 QSPI1->cmdsts_bit.cmdsts = TRUE;
397
398 /* qspi check busy */
399 custom_qspi_busy_check();
400
401 custom_xip_enable_config();
402 return 0;
403}
404
FlashOS.h
at32f435_437.h
at32f435_437 header file
CRM_SCLK_HICK
@ CRM_SCLK_HICK
Definition: at32f435_437_crm.h:680
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM
#define CRM
Definition: at32f435_437_crm.h:1506
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
GPIOG
#define GPIOG
Definition: at32f435_437_gpio.h:527
GPIOF
#define GPIOF
Definition: at32f435_437_gpio.h:526
QSPI1_MEM_BASE
#define QSPI1_MEM_BASE
Definition: at32f435_437.h:418
QSPI_XIP_ADDRLEN_3_BYTE
@ QSPI_XIP_ADDRLEN_3_BYTE
Definition: at32f435_437_qspi.h:162
QSPI_BUSY_OFFSET_0
@ QSPI_BUSY_OFFSET_0
Definition: at32f435_437_qspi.h:87
QSPI_SCK_MODE_0
@ QSPI_SCK_MODE_0
Definition: at32f435_437_qspi.h:171
QSPI_OPERATE_MODE_144
@ QSPI_OPERATE_MODE_144
Definition: at32f435_437_qspi.h:115
QSPI_CLK_DIV_2
@ QSPI_CLK_DIV_2
Definition: at32f435_437_qspi.h:125
QSPI_XIPR_SEL_MODED
@ QSPI_XIPR_SEL_MODED
Definition: at32f435_437_qspi.h:69
ProgramPage
int ProgramPage(unsigned long adr, unsigned long sz, unsigned char *buf)
program page.
Definition: FlashPrg.c:377
custom_qspi_sector_erase
void custom_qspi_sector_erase(uint32_t adr)
esmt32m sector erase command
Definition: FlashPrg.c:185
custom_qspi_rstqpi
void custom_qspi_rstqpi(void)
esmt32m rstqpi command
Definition: FlashPrg.c:110
custom_xip_enable_config
void custom_xip_enable_config(void)
qspi xip mode enable config
Definition: FlashPrg.c:66
custom_qspi_rst
void custom_qspi_rst(void)
esmt32m rst command
Definition: FlashPrg.c:140
qspi_cmd_init
void qspi_cmd_init(void)
qspi command port init flow
Definition: FlashPrg.c:274
custom_qspi_chip_erase
void custom_qspi_chip_erase(void)
esmt32m chip erase command
Definition: FlashPrg.c:200
Init
int Init(unsigned long adr, unsigned long clk, unsigned long fnc)
initialize flash.
Definition: FlashPrg.c:309
UnInit
int UnInit(unsigned long fnc)
de-initialize flash.
Definition: FlashPrg.c:323
qspi_gpio_init
void qspi_gpio_init(void)
qspi gpio initilize
Definition: FlashPrg.c:250
custom_qspi_rsten
void custom_qspi_rsten(void)
esmt32m rsten command
Definition: FlashPrg.c:125
custom_qspi_xip_enable
void custom_qspi_xip_enable(confirm_state new_state)
qspi xip mode enable or disable
Definition: FlashPrg.c:43
custom_qspi_busy_check
void custom_qspi_busy_check(void)
esmt32m check busy command
Definition: FlashPrg.c:170
EraseChip
int EraseChip(void)
Definition: FlashPrg.c:330
custom_qspi_write_enable
void custom_qspi_write_enable(void)
esmt32m write enable command
Definition: FlashPrg.c:155
init_clk
void init_clk(void)
sysclk set to pll 96mhz
Definition: FlashPrg.c:215
uninit_clk
void uninit_clk(void)
sysclk uninit
Definition: FlashPrg.c:238
EraseSector
int EraseSector(unsigned long adr)
erase sector.
Definition: FlashPrg.c:352
QSPI1
#define QSPI1
Definition: at32f435_437_qspi.h:512
qspi_xip_type
qspi xip type
Definition: at32f435_437_qspi.h:208
qspi_xip_type::write_operation_mode
qspi_operate_mode_type write_operation_mode
Definition: at32f435_437_qspi.h:215
qspi_xip_type::read_second_dummy_cycle_num
uint8_t read_second_dummy_cycle_num
Definition: at32f435_437_qspi.h:212
qspi_xip_type::write_address_length
qspi_xip_addrlen_type write_address_length
Definition: at32f435_437_qspi.h:214
qspi_xip_type::write_instruction_code
uint8_t write_instruction_code
Definition: at32f435_437_qspi.h:213
qspi_xip_type::write_data_counter
uint8_t write_data_counter
Definition: at32f435_437_qspi.h:219
qspi_xip_type::read_select_mode
qspi_xip_read_sel_type read_select_mode
Definition: at32f435_437_qspi.h:220
qspi_xip_type::write_time_counter
uint8_t write_time_counter
Definition: at32f435_437_qspi.h:218
qspi_xip_type::read_operation_mode
qspi_operate_mode_type read_operation_mode
Definition: at32f435_437_qspi.h:211
qspi_xip_type::read_address_length
qspi_xip_addrlen_type read_address_length
Definition: at32f435_437_qspi.h:210
qspi_xip_type::read_data_counter
uint8_t read_data_counter
Definition: at32f435_437_qspi.h:222
qspi_xip_type::read_time_counter
uint8_t read_time_counter
Definition: at32f435_437_qspi.h:221
qspi_xip_type::write_select_mode
qspi_xip_write_sel_type write_select_mode
Definition: at32f435_437_qspi.h:217
qspi_xip_type::write_second_dummy_cycle_num
uint8_t write_second_dummy_cycle_num
Definition: at32f435_437_qspi.h:216
qspi_xip_type::read_instruction_code
uint8_t read_instruction_code
Definition: at32f435_437_qspi.h:209


AT32F435/437 Firmwary Library: FreeRTOSConfig.h File Reference

  • utilities
  • at32f435_437_freertos_demo
  • inc
Macros
FreeRTOSConfig.h File Reference

Go to the source code of this file.

Macros

#define | configUSE_PREEMPTION 1
#define | configUSE_IDLE_HOOK 0
#define | configUSE_TICK_HOOK 0
#define | configCPU_CLOCK_HZ ( ( unsigned long ) systemcoreclock )
#define | configTICK_RATE_HZ ( ( TickType_t ) 1000 )
#define | configMAX_PRIORITIES ( 5 )
#define | configMINIMAL_STACK_SIZE ( ( unsigned short ) 128 )
#define | configSUPPORT_DYNAMIC_ALLOCATION 1
#define | configTOTAL_HEAP_SIZE ( ( size_t ) ( 8 * 1024 ) )
#define | configMAX_TASK_NAME_LEN ( 16 )
#define | configUSE_16_BIT_TICKS 0
#define | configIDLE_SHOULD_YIELD 1
#define | configUSE_CO_ROUTINES 0
#define | configMAX_CO_ROUTINE_PRIORITIES ( 2 )
#define | INCLUDE_vTaskPrioritySet 1
#define | INCLUDE_uxTaskPriorityGet 1
#define | INCLUDE_vTaskDelete 1
#define | INCLUDE_vTaskCleanUpResources 0
#define | INCLUDE_vTaskSuspend 1
#define | INCLUDE_vTaskDelayUntil 1
#define | INCLUDE_vTaskDelay 1
#define | INCLUDE_xTaskGetCurrentTaskHandle 1
#define | configPRIO_BITS 4 /* 15 priority levels */
#define | configLIBRARY_LOWEST_INTERRUPT_PRIORITY 0x0f
#define | configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY 0x01
#define | configKERNEL_INTERRUPT_PRIORITY ( configLIBRARY_LOWEST_INTERRUPT_PRIORITY << (8 - configPRIO_BITS) )
#define | configMAX_SYSCALL_INTERRUPT_PRIORITY ( configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY << (8 - configPRIO_BITS) )
#define | configASSERT(x) if( ( x ) == 0 ) { taskDISABLE_INTERRUPTS(); for( ;; ); }
#define | vPortSVCHandler SVC_Handler
#define | xPortPendSVHandler PendSV_Handler
#define | xPortSysTickHandler SysTick_Handler

Macro Definition Documentation

◆ configASSERT

#define configASSERT ( x ) if( ( x ) == 0 ) { taskDISABLE_INTERRUPTS(); for( ;; ); }

Definition at line 163 of file FreeRTOSConfig.h.

◆ configCPU_CLOCK_HZ

#define configCPU_CLOCK_HZ ( ( unsigned long ) systemcoreclock )

Definition at line 110 of file FreeRTOSConfig.h.

◆ configIDLE_SHOULD_YIELD

#define configIDLE_SHOULD_YIELD 1

Definition at line 118 of file FreeRTOSConfig.h.

◆ configKERNEL_INTERRUPT_PRIORITY

#define configKERNEL_INTERRUPT_PRIORITY ( configLIBRARY_LOWEST_INTERRUPT_PRIORITY << (8 - configPRIO_BITS) )

Definition at line 156 of file FreeRTOSConfig.h.

◆ configLIBRARY_LOWEST_INTERRUPT_PRIORITY

#define configLIBRARY_LOWEST_INTERRUPT_PRIORITY 0x0f

Definition at line 146 of file FreeRTOSConfig.h.

◆ configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY

#define configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY 0x01

Definition at line 152 of file FreeRTOSConfig.h.

◆ configMAX_CO_ROUTINE_PRIORITIES

#define configMAX_CO_ROUTINE_PRIORITIES ( 2 )

Definition at line 123 of file FreeRTOSConfig.h.

◆ configMAX_PRIORITIES

#define configMAX_PRIORITIES ( 5 )

Definition at line 112 of file FreeRTOSConfig.h.

◆ configMAX_SYSCALL_INTERRUPT_PRIORITY

#define configMAX_SYSCALL_INTERRUPT_PRIORITY ( configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY << (8 - configPRIO_BITS) )

Definition at line 159 of file FreeRTOSConfig.h.

◆ configMAX_TASK_NAME_LEN

#define configMAX_TASK_NAME_LEN ( 16 )

Definition at line 116 of file FreeRTOSConfig.h.

◆ configMINIMAL_STACK_SIZE

#define configMINIMAL_STACK_SIZE ( ( unsigned short ) 128 )

Definition at line 113 of file FreeRTOSConfig.h.

◆ configPRIO_BITS

#define configPRIO_BITS 4 /* 15 priority levels */

Definition at line 141 of file FreeRTOSConfig.h.

◆ configSUPPORT_DYNAMIC_ALLOCATION

#define configSUPPORT_DYNAMIC_ALLOCATION 1

Definition at line 114 of file FreeRTOSConfig.h.

◆ configTICK_RATE_HZ

#define configTICK_RATE_HZ ( ( TickType_t ) 1000 )

Definition at line 111 of file FreeRTOSConfig.h.

◆ configTOTAL_HEAP_SIZE

#define configTOTAL_HEAP_SIZE ( ( size_t ) ( 8 * 1024 ) )

Definition at line 115 of file FreeRTOSConfig.h.

◆ configUSE_16_BIT_TICKS

#define configUSE_16_BIT_TICKS 0

Definition at line 117 of file FreeRTOSConfig.h.

◆ configUSE_CO_ROUTINES

#define configUSE_CO_ROUTINES 0

Definition at line 122 of file FreeRTOSConfig.h.

◆ configUSE_IDLE_HOOK

#define configUSE_IDLE_HOOK 0

Definition at line 108 of file FreeRTOSConfig.h.

◆ configUSE_PREEMPTION

#define configUSE_PREEMPTION 1

Definition at line 107 of file FreeRTOSConfig.h.

◆ configUSE_TICK_HOOK

#define configUSE_TICK_HOOK 0

Definition at line 109 of file FreeRTOSConfig.h.

◆ INCLUDE_uxTaskPriorityGet

#define INCLUDE_uxTaskPriorityGet 1

Definition at line 129 of file FreeRTOSConfig.h.

◆ INCLUDE_vTaskCleanUpResources

#define INCLUDE_vTaskCleanUpResources 0

Definition at line 131 of file FreeRTOSConfig.h.

◆ INCLUDE_vTaskDelay

#define INCLUDE_vTaskDelay 1

Definition at line 134 of file FreeRTOSConfig.h.

◆ INCLUDE_vTaskDelayUntil

#define INCLUDE_vTaskDelayUntil 1

Definition at line 133 of file FreeRTOSConfig.h.

◆ INCLUDE_vTaskDelete

#define INCLUDE_vTaskDelete 1

Definition at line 130 of file FreeRTOSConfig.h.

◆ INCLUDE_vTaskPrioritySet

#define INCLUDE_vTaskPrioritySet 1

Definition at line 128 of file FreeRTOSConfig.h.

◆ INCLUDE_vTaskSuspend

#define INCLUDE_vTaskSuspend 1

Definition at line 132 of file FreeRTOSConfig.h.

◆ INCLUDE_xTaskGetCurrentTaskHandle

#define INCLUDE_xTaskGetCurrentTaskHandle 1

Definition at line 135 of file FreeRTOSConfig.h.

◆ vPortSVCHandler

#define vPortSVCHandler SVC_Handler

Definition at line 167 of file FreeRTOSConfig.h.

◆ xPortPendSVHandler

#define xPortPendSVHandler PendSV_Handler

Definition at line 168 of file FreeRTOSConfig.h.

◆ xPortSysTickHandler

#define xPortSysTickHandler SysTick_Handler

Definition at line 169 of file FreeRTOSConfig.h.


AT32F435/437 Firmwary Library: FreeRTOSConfig.h Source File

  • utilities
  • at32f435_437_freertos_demo
  • inc
FreeRTOSConfig.h
Go to the documentation of this file.
1/*
2 FreeRTOS V8.2.3 - Copyright (C) 2015 Real Time Engineers Ltd.
3 All rights reserved
4
5 VISIT http://www.FreeRTOS.org TO ENSURE YOU ARE USING THE LATEST VERSION.
6
7 This file is part of the FreeRTOS distribution.
8
9 FreeRTOS is free software; you can redistribute it and/or modify it under
10 the terms of the GNU General Public License (version 2) as published by the
11 Free Software Foundation >>>> AND MODIFIED BY <<<< the FreeRTOS exception.
12
13 ***************************************************************************
14 >>! NOTE: The modification to the GPL is included to allow you to !<<
15 >>! distribute a combined work that includes FreeRTOS without being !<<
16 >>! obliged to provide the source code for proprietary components !<<
17 >>! outside of the FreeRTOS kernel. !<<
18 ***************************************************************************
19
20 FreeRTOS is distributed in the hope that it will be useful, but WITHOUT ANY
21 WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
22 FOR A PARTICULAR PURPOSE. Full license text is available on the following
23 link: http://www.freertos.org/a00114.html
24
25 ***************************************************************************
26 * *
27 * FreeRTOS provides completely free yet professionally developed, *
28 * robust, strictly quality controlled, supported, and cross *
29 * platform software that is more than just the market leader, it *
30 * is the industry's de facto standard. *
31 * *
32 * Help yourself get started quickly while simultaneously helping *
33 * to support the FreeRTOS project by purchasing a FreeRTOS *
34 * tutorial book, reference manual, or both: *
35 * http://www.FreeRTOS.org/Documentation *
36 * *
37 ***************************************************************************
38
39 http://www.FreeRTOS.org/FAQHelp.html - Having a problem? Start by reading
40 the FAQ page "My application does not run, what could be wrong?". Have you
41 defined configASSERT()?
42
43 http://www.FreeRTOS.org/support - In return for receiving this top quality
44 embedded software for free we request you assist our global community by
45 participating in the support forum.
46
47 http://www.FreeRTOS.org/training - Investing in training allows your team to
48 be as productive as possible as early as possible. Now you can receive
49 FreeRTOS training directly from Richard Barry, CEO of Real Time Engineers
50 Ltd, and the world's leading authority on the world's leading RTOS.
51
52 http://www.FreeRTOS.org/plus - A selection of FreeRTOS ecosystem products,
53 including FreeRTOS+Trace - an indispensable productivity tool, a DOS
54 compatible FAT file system, and our tiny thread aware UDP/IP stack.
55
56 http://www.FreeRTOS.org/labs - Where new FreeRTOS products go to incubate.
57 Come and try FreeRTOS+TCP, our new open source TCP/IP stack for FreeRTOS.
58
59 http://www.OpenRTOS.com - Real Time Engineers ltd. license FreeRTOS to High
60 Integrity Systems ltd. to sell under the OpenRTOS brand. Low cost OpenRTOS
61 licenses offer ticketed support, indemnification and commercial middleware.
62
63 http://www.SafeRTOS.com - High Integrity Systems also provide a safety
64 engineered and independently SIL3 certified version for use in safety and
65 mission critical applications that require provable dependability.
66
67 1 tab == 4 spaces!
68 * Copyright notice & Disclaimer
69 *
70 * The software Board Support Package (BSP) that is made available to
71 * download from Artery official website is the copyrighted work of Artery.
72 * Artery authorizes customers to use, copy, and distribute the BSP
73 * software and its related documentation for the purpose of design and
74 * development in conjunction with Artery microcontrollers. Use of the
75 * software is governed by this copyright notice and the following disclaimer.
76 *
77 * THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES,
78 * GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS,
79 * TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR
80 * STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS,
81 * INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY,
82 * FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.
83 *
84 **************************************************************************
85*/
86
87#ifndef FREERTOS_CONFIG_H
88#define FREERTOS_CONFIG_H
89#if defined(__ICCARM__) || defined(__CC_ARM) || defined(__GNUC__)
90 #include <stdint.h>
91 static uint32_t systemcoreclock = 288000000;
92#endif
93
94
95
96/*-----------------------------------------------------------
97 * Application specific definitions.
98 *
99 * These definitions should be adjusted for your particular hardware and
100 * application requirements.
101 *
102 * THESE PARAMETERS ARE DESCRIBED WITHIN THE 'CONFIGURATION' SECTION OF THE
103 * FreeRTOS API DOCUMENTATION AVAILABLE ON THE FreeRTOS.org WEB SITE.
104 *
105 * See http://www.freertos.org/a00110.html.
106 *----------------------------------------------------------*/
107#define configUSE_PREEMPTION 1
108#define configUSE_IDLE_HOOK 0
109#define configUSE_TICK_HOOK 0
110#define configCPU_CLOCK_HZ ( ( unsigned long ) systemcoreclock )
111#define configTICK_RATE_HZ ( ( TickType_t ) 1000 )
112#define configMAX_PRIORITIES ( 5 )
113#define configMINIMAL_STACK_SIZE ( ( unsigned short ) 128 )
114#define configSUPPORT_DYNAMIC_ALLOCATION 1
115#define configTOTAL_HEAP_SIZE ( ( size_t ) ( 8 * 1024 ) )
116#define configMAX_TASK_NAME_LEN ( 16 )
117#define configUSE_16_BIT_TICKS 0
118#define configIDLE_SHOULD_YIELD 1
119
120
121/* Co-routine definitions. */
122#define configUSE_CO_ROUTINES 0
123#define configMAX_CO_ROUTINE_PRIORITIES ( 2 )
124
125/* Set the following definitions to 1 to include the API function, or zero
126to exclude the API function. */
127
128#define INCLUDE_vTaskPrioritySet 1
129#define INCLUDE_uxTaskPriorityGet 1
130#define INCLUDE_vTaskDelete 1
131#define INCLUDE_vTaskCleanUpResources 0
132#define INCLUDE_vTaskSuspend 1
133#define INCLUDE_vTaskDelayUntil 1
134#define INCLUDE_vTaskDelay 1
135#define INCLUDE_xTaskGetCurrentTaskHandle 1
136/* Cortex-M specific definitions. */
137#ifdef __NVIC_PRIO_BITS
138 /* __BVIC_PRIO_BITS will be specified when CMSIS is being used. */
139 #define configPRIO_BITS __NVIC_PRIO_BITS
140#else
141 #define configPRIO_BITS 4 /* 15 priority levels */
142#endif
143
144/* The lowest interrupt priority that can be used in a call to a "set priority"
145function. */
146#define configLIBRARY_LOWEST_INTERRUPT_PRIORITY 0x0f
147
148/* The highest interrupt priority that can be used by any interrupt service
149routine that makes calls to interrupt safe FreeRTOS API functions. DO NOT CALL
150INTERRUPT SAFE FREERTOS API FUNCTIONS FROM ANY INTERRUPT THAT HAS A HIGHER
151PRIORITY THAN THIS! (higher priorities are lower numeric values. */
152#define configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY 0x01
153
154/* Interrupt priorities used by the kernel port layer itself. These are generic
155to all Cortex-M ports, and do not rely on any particular library functions. */
156#define configKERNEL_INTERRUPT_PRIORITY ( configLIBRARY_LOWEST_INTERRUPT_PRIORITY << (8 - configPRIO_BITS) )
157/* !!!! configMAX_SYSCALL_INTERRUPT_PRIORITY must not be set to zero !!!!
158See http://www.FreeRTOS.org/RTOS-Cortex-M3-M4.html. */
159#define configMAX_SYSCALL_INTERRUPT_PRIORITY ( configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY << (8 - configPRIO_BITS) )
160
161/* Normal assert() semantics without relying on the provision of an assert.h
162header file. */
163#define configASSERT( x ) if( ( x ) == 0 ) { taskDISABLE_INTERRUPTS(); for( ;; ); }
164
165/* Definitions that map the FreeRTOS port interrupt handlers to their CMSIS
166standard names. */
167#define vPortSVCHandler SVC_Handler
168#define xPortPendSVHandler PendSV_Handler
169#define xPortSysTickHandler SysTick_Handler
170
171
172#endif /* FREERTOS_CONFIG_H */
173


AT32F435/437 Firmwary Library: hid_iap_user.h File Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Macros | Functions
app_led3_toggle/inc/hid_iap_user.h File Reference

usb config header file More...

#include "hid_iap_class.h"

Go to the source code of this file.

Macros

#define FLASH_APP_ADDRESS 0x08005000

Functions

void | iap_init (void)
iap init. More...
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | app_loop (void)
iap loop More...
void | jump_to_iap (uint32_t address)

Detailed Description

usb config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led3_toggle/inc/hid_iap_user.h.


AT32F435/437 Firmwary Library: hid_iap_user.h Source File

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
app_led3_toggle/inc/hid_iap_user.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __HID_IAP_USER_H
29#define __HID_IAP_USER_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "hid_iap_class.h"
36
46#define FLASH_APP_ADDRESS 0x08005000
47
48void iap_init(void);
49 iap_result_type iap_get_upgrade_flag(void);
50void app_loop(void);
51void jump_to_iap(uint32_t address);
52
60#ifdef __cplusplus
61}
62#endif
63
64#endif
iap_init
void iap_init(void)
iap init.
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c:61
iap_get_upgrade_flag
iap_result_type iap_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: app_led3_toggle/src/hid_iap_user.c:77
jump_to_iap
void jump_to_iap(uint32_t address)
app_loop
void app_loop(void)
iap loop
Definition: app_led3_toggle/src/hid_iap_user.c:260
iap_result_type
iap_result_type
Definition: hid_iap_class.h:86
hid_iap_class.h
usb hid iap header file


AT32F435/437 Firmwary Library: usart.h File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Macros | Functions | Variables
app_led3_toggle/inc/usart.h File Reference

usart header file More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | IAP_REV_FLAG_NO 0
#define | IAP_REV_FLAG_5A 1
#define | IAP_REV_FLAG_DONE 2
#define | IAP_REV_FLAG_ERROR 3

Functions

void | uart_init (uint32_t baudrate)
initialize print usart More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...

Variables

uint8_t iap_flag

Detailed Description

usart header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led3_toggle/inc/usart.h.


AT32F435/437 Firmwary Library: usart.h Source File

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
app_led3_toggle/inc/usart.h
Go to the documentation of this file.
1
27#ifndef __USART_H
28#define __USART_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "at32f435_437_board.h"
35
36extern uint8_t iap_flag;
37
50#define IAP_REV_FLAG_NO 0
51#define IAP_REV_FLAG_5A 1
52#define IAP_REV_FLAG_DONE 2
53#define IAP_REV_FLAG_ERROR 3
54
63void uart_init(uint32_t baudrate);
64void back_ok(void);
65void back_err(void);
66
79#ifdef __cplusplus
80}
81#endif
82
83#endif
84
85
at32f435_437_board.h
uart_init
void uart_init(uint32_t baudrate)
initialize print usart
Definition: project/at_start_f435/examples/edma/link_list_mode/src/main.c:137
back_err
void back_err(void)
command response error.
Definition: app_led3_toggle/src/usart.c:114
back_ok
void back_ok(void)
command response ok.
Definition: app_led3_toggle/src/usart.c:101
iap_flag
uint8_t iap_flag
Definition: app_led3_toggle/src/usart.c:38


AT32F435/437 Firmwary Library: hid_iap_user.c File Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions
app_led3_toggle/src/hid_iap_user.c File Reference

usb hid iap user file More...

#include "hid_iap_user.h"
#include "hid_iap_class.h"
#include "string.h"

Go to the source code of this file.

Functions

void | iap_clear_upgrade_flag (void)
clear iap upgrade flag More...
void | iap_set_upgrade_flag (void)
set iap upgrade complete flag More...
uint32_t | crc_cal (uint32_t addr, uint16_t nk)
crc cal More...
void | iap_idle (void)
iap idle function More...
void | iap_start (void)
iap start function More...
void | iap_finish (void)
void | iap_respond (uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | iap_init (void)
iap init More...
void | iap_jump ()
void | iap_get ()
iap_result_type | usbd_hid_iap_process (void *udev, uint8_t *pdata, uint16_t len)
usb device iap function More...
void | usbd_hid_iap_in_complete (void *udev)
usb device in transfer complete function More...
void | app_loop (void)
iap loop More...

Detailed Description

usb hid iap user file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led3_toggle/src/hid_iap_user.c.


AT32F435/437 Firmwary Library: hid_iap_user.c Source File

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • app_led3_toggle
  • src
app_led3_toggle/src/hid_iap_user.c
Go to the documentation of this file.
1
27#include "hid_iap_user.h"
28#include "hid_iap_class.h"
29#include "string.h"
30
39void iap_clear_upgrade_flag(void);
40void iap_set_upgrade_flag(void);
41uint32_t crc_cal(uint32_t addr, uint16_t nk);
42void iap_idle(void);
43void iap_start(void);
44void iap_finish(void);
45void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result);
46
52void iap_clear_upgrade_flag(void)
53{
54 flash_unlock();
55 flash_sector_erase(iap_info.flag_address);
56 flash_lock();
57}
58
64void iap_set_upgrade_flag(void)
65{
66 flash_unlock();
67 flash_word_program(iap_info.flag_address,
68 IAP_UPGRADE_COMPLETE_FLAG);
69 flash_lock();
70}
71
77 iap_result_type iap_get_upgrade_flag(void)
78{
79 uint32_t flag_address = iap_info.flag_address;
80 if(*((uint32_t *)flag_address) == IAP_UPGRADE_COMPLETE_FLAG)
81 {
82 return IAP_SUCCESS;
83 }
84 else
85 {
86 return IAP_FAILED;
87 }
88}
89
95void iap_init(void)
96{
97 uint32_t devid = (*((uint32_t *)DEBUG_BASE) & 0x00007000) >> 12;
98
99 switch(devid)
100 {
101 case 2:
102 iap_info.sector_size = SECTOR_SIZE_1K;
103 break;
104 case 3:
105 iap_info.sector_size = SECTOR_SIZE_2K;
106 break;
107 case 4:
108 iap_info.sector_size = SECTOR_SIZE_4K;
109 break;
110 default:
111 iap_info.sector_size = SECTOR_SIZE_2K;
112 break;
113 }
114 iap_info.flash_size = KB_TO_B(FLASH_SIZE_REG());
115
116 iap_info.flash_start_address = FLASH_BASE;
117 iap_info.flash_end_address = iap_info.flash_start_address + iap_info.flash_size;
118
119 iap_info.app_address = FLASH_APP_ADDRESS;
120 iap_info.flag_address = iap_info.app_address - iap_info.sector_size;
121
122 iap_info.fifo_length = 0;
123 iap_info.iap_address = 0;
124}
125
131void iap_idle(void)
132{
133 iap_info.state = IAP_STS_JMP_WAIT;
134 iap_init();
135 iap_respond(iap_info.iap_tx, IAP_CMD_IDLE, IAP_ACK);
136}
137
143void iap_start(void)
144{
145 iap_info.state = IAP_STS_START;
146 iap_init();
147 iap_respond(iap_info.iap_tx, IAP_CMD_START, IAP_ACK);
148}
149
150/*
151 * @brief iap jump
152 * @param none
153 * @retval none
154 */
155void iap_jump()
156{
157 iap_info.state = IAP_STS_JMP_WAIT;
158 iap_respond(iap_info.iap_tx, IAP_CMD_JMP, IAP_ACK);
159}
160
161/*
162 * @brief iap get
163 * @param none
164 * @retval none
165 */
166void iap_get()
167{
168 iap_respond(iap_info.iap_tx, IAP_CMD_GET, IAP_ACK);
169 iap_info.iap_tx[4] = (uint8_t)((iap_info.app_address >> 24) & 0xFF);
170 iap_info.iap_tx[5] = (uint8_t)((iap_info.app_address >> 16) & 0xFF);
171 iap_info.iap_tx[6] = (uint8_t)((iap_info.app_address >> 8) & 0xFF);
172 iap_info.iap_tx[7] = (uint8_t)((iap_info.app_address) & 0xFF);
173}
174
175
176
177/*
178 * @brief iap respond
179 * @param res_buf: data buffer pointer.
180 * @param iap_cmd: iap command
181 * @param result: iap result
182 * @retval the result of the address parse
183 */
184void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
185{
186 res_buf[0] = (uint8_t)((iap_cmd >> 8) & 0xFF);
187 res_buf[1] = (uint8_t)((iap_cmd) & 0xFF);
188 res_buf[2] = (uint8_t)((result >> 8) & 0xFF);
189 res_buf[3] = (uint8_t)((result) & 0xFF);
190
191 iap_info.respond_flag = 1;
192}
193
201 iap_result_type usbd_hid_iap_process(void *udev, uint8_t *pdata, uint16_t len)
202{
203 iap_result_type status = IAP_SUCCESS;
204 uint16_t iap_cmd;
205
206 if(len < 2)
207 {
208 return IAP_FAILED;
209 }
210
211 iap_info.respond_flag = 0;
212
213 iap_cmd = (pdata[0] << 8) | pdata[1];
214
215 switch(iap_cmd)
216 {
217 case IAP_CMD_IDLE:
218 iap_idle();
219 break;
220 case IAP_CMD_START:
221 iap_start();
222 break;
223 case IAP_CMD_JMP:
224 iap_jump();
225 break;
226 case IAP_CMD_GET:
227 iap_get();
228 break;
229 default:
230 status = IAP_FAILED;
231 break;
232 }
233
234 if(iap_info.respond_flag)
235 {
236 usb_iap_class_send_report(udev, iap_info.iap_tx, 64);
237 }
238
239 return status;
240}
241
247void usbd_hid_iap_in_complete(void *udev)
248{
249 if(iap_info.state == IAP_STS_JMP_WAIT)
250 {
251 iap_info.state = IAP_STS_JMP;
252 }
253}
254
260void app_loop(void)
261{
262 if(iap_info.state == IAP_STS_JMP)
263 {
264 iap_clear_upgrade_flag();
265 nvic_system_reset();
266 }
267}
FLASH_APP_ADDRESS
#define FLASH_APP_ADDRESS
Definition: app_led3_toggle/inc/hid_iap_user.h:46
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f435_437_flash.c:357
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f435_437_flash.c:290
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f435_437_flash.c:608
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f435_437_flash.c:325
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f435_437_misc.c:52
DEBUG_BASE
#define DEBUG_BASE
Definition: at32f435_437.h:427
FLASH_BASE
#define FLASH_BASE
Definition: at32f435_437.h:425
iap_set_upgrade_flag
void iap_set_upgrade_flag(void)
set iap upgrade complete flag
Definition: app_led3_toggle/src/hid_iap_user.c:64
iap_idle
void iap_idle(void)
iap idle function
Definition: app_led3_toggle/src/hid_iap_user.c:131
iap_respond
void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
Definition: app_led3_toggle/src/hid_iap_user.c:184
iap_init
void iap_init(void)
iap init
Definition: app_led3_toggle/src/hid_iap_user.c:95
usbd_hid_iap_process
iap_result_type usbd_hid_iap_process(void *udev, uint8_t *pdata, uint16_t len)
usb device iap function
Definition: app_led3_toggle/src/hid_iap_user.c:201
crc_cal
uint32_t crc_cal(uint32_t addr, uint16_t nk)
crc cal
Definition: bootloader/src/hid_iap_user.c:162
iap_jump
void iap_jump()
Definition: app_led3_toggle/src/hid_iap_user.c:155
iap_get_upgrade_flag
iap_result_type iap_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: app_led3_toggle/src/hid_iap_user.c:77
iap_finish
void iap_finish(void)
Definition: bootloader/src/hid_iap_user.c:333
iap_start
void iap_start(void)
iap start function
Definition: app_led3_toggle/src/hid_iap_user.c:143
iap_clear_upgrade_flag
void iap_clear_upgrade_flag(void)
clear iap upgrade flag
Definition: app_led3_toggle/src/hid_iap_user.c:52
iap_get
void iap_get()
Definition: app_led3_toggle/src/hid_iap_user.c:166
app_loop
void app_loop(void)
iap loop
Definition: app_led3_toggle/src/hid_iap_user.c:260
usbd_hid_iap_in_complete
void usbd_hid_iap_in_complete(void *udev)
usb device in transfer complete function
Definition: app_led3_toggle/src/hid_iap_user.c:247
IAP_CMD_IDLE
#define IAP_CMD_IDLE
iap command
Definition: hid_iap_class.h:68
IAP_CMD_GET
#define IAP_CMD_GET
Definition: hid_iap_class.h:75
SECTOR_SIZE_1K
#define SECTOR_SIZE_1K
Definition: hid_iap_class.h:61
iap_result_type
iap_result_type
Definition: hid_iap_class.h:86
IAP_ACK
#define IAP_ACK
Definition: hid_iap_class.h:82
SECTOR_SIZE_2K
#define SECTOR_SIZE_2K
Definition: hid_iap_class.h:62
SECTOR_SIZE_4K
#define SECTOR_SIZE_4K
Definition: hid_iap_class.h:63
IAP_UPGRADE_COMPLETE_FLAG
#define IAP_UPGRADE_COMPLETE_FLAG
Definition: hid_iap_class.h:78
FLASH_SIZE_REG
#define FLASH_SIZE_REG()
Definition: hid_iap_class.h:58
IAP_CMD_START
#define IAP_CMD_START
Definition: hid_iap_class.h:69
IAP_CMD_JMP
#define IAP_CMD_JMP
Definition: hid_iap_class.h:74
KB_TO_B
#define KB_TO_B(kb)
Definition: hid_iap_class.h:59
IAP_FAILED
@ IAP_FAILED
Definition: hid_iap_class.h:89
IAP_SUCCESS
@ IAP_SUCCESS
Definition: hid_iap_class.h:87
IAP_STS_START
@ IAP_STS_START
Definition: hid_iap_class.h:95
IAP_STS_JMP
@ IAP_STS_JMP
Definition: hid_iap_class.h:101
IAP_STS_JMP_WAIT
@ IAP_STS_JMP_WAIT
Definition: hid_iap_class.h:100
iap_info
iap_info_type iap_info
Definition: hid_iap_class.c:54
usb_iap_class_send_report
usb_sts_type usb_iap_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: hid_iap_class.c:316
hid_iap_class.h
usb hid iap header file
iap_info_type::respond_flag
uint32_t respond_flag
Definition: hid_iap_class.h:124
iap_info_type::flag_address
uint32_t flag_address
Definition: hid_iap_class.h:116
iap_info_type::sector_size
uint32_t sector_size
Definition: hid_iap_class.h:121
iap_info_type::iap_address
uint32_t iap_address
Definition: hid_iap_class.h:115
iap_info_type::flash_start_address
uint32_t flash_start_address
Definition: hid_iap_class.h:118
iap_info_type::flash_end_address
uint32_t flash_end_address
Definition: hid_iap_class.h:119
iap_info_type::fifo_length
uint32_t fifo_length
Definition: hid_iap_class.h:111
iap_info_type::flash_size
uint32_t flash_size
Definition: hid_iap_class.h:122
iap_info_type::iap_tx
uint8_t iap_tx[0x40]
Definition: hid_iap_class.h:109
iap_info_type::app_address
uint32_t app_address
Definition: hid_iap_class.h:114
iap_info_type::state
iap_machine_state_type state
Definition: hid_iap_class.h:133


AT32F435/437 Firmwary Library: usart.c File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions | Variables
app_led3_toggle/src/usart.c File Reference

usart program More...

#include "usart.h"
#include "tmr.h"

Go to the source code of this file.

Functions

void | uart_init (uint32_t baudrate)
init usart. More...
void | USART1_IRQHandler (void)
usart1 interrupt handler. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...

Variables

uint8_t iap_flag = IAP_REV_FLAG_NO

Detailed Description

usart program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led3_toggle/src/usart.c.


AT32F435/437 Firmwary Library: usart.c Source File

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
app_led3_toggle/src/usart.c
Go to the documentation of this file.
1
27#include "usart.h"
28#include "tmr.h"
29
38uint8_t iap_flag = IAP_REV_FLAG_NO;
39
45void uart_init(uint32_t baudrate)
46{
47 gpio_init_type gpio_init_struct;
48 /* enable the usart and it's io clock */
49 crm_periph_clock_enable(CRM_USART1_PERIPH_CLOCK, TRUE);
50 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
51
52 /* set default parameter */
53 gpio_default_para_init(&gpio_init_struct);
54
55 /* configure the usart1_tx rx pa9 pa10 */
56 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
57 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
58 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
59 gpio_init_struct.gpio_pins = GPIO_PINS_9 | GPIO_PINS_10;
60 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
61 gpio_init(GPIOA, &gpio_init_struct);
62 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE9 ,GPIO_MUX_7);
63 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE10 ,GPIO_MUX_7);
64
65 /*configure usart nvic interrupt */
66 nvic_irq_enable(USART1_IRQn, 0, 0);
67
68 /*configure usart param*/
69 usart_init(USART1, baudrate, USART_DATA_8BITS, USART_STOP_1_BIT);
70 usart_transmitter_enable(USART1, TRUE);
71 usart_receiver_enable(USART1, TRUE);
72 usart_interrupt_enable(USART1, USART_RDBF_INT, TRUE);
73 usart_enable(USART1, TRUE);
74}
75
81void USART1_IRQHandler(void)
82{
83 uint16_t reval;
84 if(usart_flag_get(USART1, USART_RDBF_FLAG) != RESET)
85 {
86 reval = usart_data_receive(USART1);
87 if((reval == 0x5A) && (iap_flag == IAP_REV_FLAG_NO))
88 iap_flag = IAP_REV_FLAG_5A;
89 else if((reval == 0xA5) && (iap_flag == IAP_REV_FLAG_5A))
90 iap_flag = IAP_REV_FLAG_DONE;
91 else
92 iap_flag = IAP_REV_FLAG_NO;
93 }
94}
95
101void back_ok(void)
102{
103 usart_data_transmit(USART1, 0xCC);
104 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
105 usart_data_transmit(USART1, 0xDD);
106 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
107}
108
114void back_err(void)
115{
116 usart_data_transmit(USART1, 0xEE);
117 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
118 usart_data_transmit(USART1, 0xFF);
119 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
120}
121
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_USART1_PERIPH_CLOCK
@ CRM_USART1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:156
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
IAP_REV_FLAG_DONE
#define IAP_REV_FLAG_DONE
Definition: app_led3_toggle/inc/usart.h:52
IAP_REV_FLAG_NO
#define IAP_REV_FLAG_NO
Definition: app_led3_toggle/inc/usart.h:50
IAP_REV_FLAG_5A
#define IAP_REV_FLAG_5A
Definition: app_led3_toggle/inc/usart.h:51
USART1_IRQHandler
void USART1_IRQHandler(void)
usart1 interrupt handler.
Definition: app_led3_toggle/src/usart.c:81
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: app_led3_toggle/src/usart.c:45
iap_flag
uint8_t iap_flag
Definition: app_led3_toggle/src/usart.c:38
back_err
void back_err(void)
command response error.
Definition: app_led3_toggle/src/usart.c:114
back_ok
void back_ok(void)
command response ok.
Definition: app_led3_toggle/src/usart.c:101
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f435_437_usart.c:413
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f435_437_usart.c:598
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f435_437_usart.c:209
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f435_437_usart.c:115
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f435_437_usart.c:196
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f435_437_usart.c:222
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f435_437_usart.c:287
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f435_437_usart.c:425
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f435_437_usart.h:159
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f435_437_usart.h:114
USART_TDC_FLAG
#define USART_TDC_FLAG
Definition: at32f435_437_usart.h:58
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f435_437_usart.h:57
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f435_437_usart.h:73
USART1
#define USART1
Definition: at32f435_437_usart.h:348
USART1_IRQn
@ USART1_IRQn
Definition: at32f435_437.h:185
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121


AT32F435/437 Firmwary Library: hid_iap_user.h File Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Macros | Functions
app_led4_toggle/inc/hid_iap_user.h File Reference

usb config header file More...

#include "hid_iap_class.h"

Go to the source code of this file.

Macros

#define FLASH_APP_ADDRESS 0x08005000

Functions

void | iap_init (void)
iap init. More...
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | app_loop (void)
iap loop More...
void | jump_to_iap (uint32_t address)

Detailed Description

usb config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led4_toggle/inc/hid_iap_user.h.


AT32F435/437 Firmwary Library: hid_iap_user.h Source File

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
app_led4_toggle/inc/hid_iap_user.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __HID_IAP_USER_H
29#define __HID_IAP_USER_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "hid_iap_class.h"
36
46#define FLASH_APP_ADDRESS 0x08005000
47
48void iap_init(void);
49 iap_result_type iap_get_upgrade_flag(void);
50void app_loop(void);
51void jump_to_iap(uint32_t address);
52
60#ifdef __cplusplus
61}
62#endif
63
64#endif
iap_get_upgrade_flag
iap_result_type iap_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: app_led3_toggle/src/hid_iap_user.c:77
jump_to_iap
void jump_to_iap(uint32_t address)
app_loop
void app_loop(void)
iap loop
Definition: app_led3_toggle/src/hid_iap_user.c:260
iap_init
void iap_init(void)
iap init.
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c:61
iap_result_type
iap_result_type
Definition: hid_iap_class.h:86
hid_iap_class.h
usb hid iap header file


AT32F435/437 Firmwary Library: usart.h File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Macros | Functions | Variables
app_led4_toggle/inc/usart.h File Reference

usart header file More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | IAP_REV_FLAG_NO 0
#define | IAP_REV_FLAG_5A 1
#define | IAP_REV_FLAG_DONE 2
#define | IAP_REV_FLAG_ERROR 3

Functions

void | uart_init (uint32_t baudrate)
initialize print usart More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...

Variables

uint8_t iap_flag

Detailed Description

usart header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led4_toggle/inc/usart.h.


AT32F435/437 Firmwary Library: usart.h Source File

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
app_led4_toggle/inc/usart.h
Go to the documentation of this file.
1
27#ifndef __USART_H
28#define __USART_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "at32f435_437_board.h"
35
36extern uint8_t iap_flag;
37
50#define IAP_REV_FLAG_NO 0
51#define IAP_REV_FLAG_5A 1
52#define IAP_REV_FLAG_DONE 2
53#define IAP_REV_FLAG_ERROR 3
54
63void uart_init(uint32_t baudrate);
64void back_ok(void);
65void back_err(void);
66
79#ifdef __cplusplus
80}
81#endif
82
83#endif
84
85
at32f435_437_board.h
uart_init
void uart_init(uint32_t bound)
initialize print usart
Definition: project/at_start_f435/examples/edma/link_list_mode/src/main.c:137
back_err
void back_err(void)
command response error.
Definition: app_led3_toggle/src/usart.c:114
back_ok
void back_ok(void)
command response ok.
Definition: app_led3_toggle/src/usart.c:101
iap_flag
uint8_t iap_flag
Definition: app_led3_toggle/src/usart.c:38


AT32F435/437 Firmwary Library: hid_iap_user.c File Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • app_led4_toggle
  • src
Functions
app_led4_toggle/src/hid_iap_user.c File Reference

usb hid iap user file More...

#include "hid_iap_user.h"
#include "hid_iap_class.h"
#include "string.h"

Go to the source code of this file.

Functions

void | iap_clear_upgrade_flag (void)
clear iap upgrade flag More...
void | iap_set_upgrade_flag (void)
set iap upgrade complete flag More...
uint32_t | crc_cal (uint32_t addr, uint16_t nk)
crc cal More...
void | iap_idle (void)
iap idle function More...
void | iap_start (void)
iap start function More...
void | iap_finish (void)
void | iap_respond (uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | iap_init (void)
iap init More...
void | iap_jump ()
void | iap_get ()
iap_result_type | usbd_hid_iap_process (void *udev, uint8_t *pdata, uint16_t len)
usb device iap function More...
void | usbd_hid_iap_in_complete (void *udev)
usb device in transfer complete function More...
void | app_loop (void)
iap loop More...

Detailed Description

usb hid iap user file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led4_toggle/src/hid_iap_user.c.


AT32F435/437 Firmwary Library: hid_iap_user.c Source File

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • app_led4_toggle
  • src
app_led4_toggle/src/hid_iap_user.c
Go to the documentation of this file.
1
27#include "hid_iap_user.h"
28#include "hid_iap_class.h"
29#include "string.h"
30
39void iap_clear_upgrade_flag(void);
40void iap_set_upgrade_flag(void);
41uint32_t crc_cal(uint32_t addr, uint16_t nk);
42void iap_idle(void);
43void iap_start(void);
44void iap_finish(void);
45void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result);
46
52void iap_clear_upgrade_flag(void)
53{
54 flash_unlock();
55 flash_sector_erase(iap_info.flag_address);
56 flash_lock();
57}
58
64void iap_set_upgrade_flag(void)
65{
66 flash_unlock();
67 flash_word_program(iap_info.flag_address,
68 IAP_UPGRADE_COMPLETE_FLAG);
69 flash_lock();
70}
71
77 iap_result_type iap_get_upgrade_flag(void)
78{
79 uint32_t flag_address = iap_info.flag_address;
80 if(*((uint32_t *)flag_address) == IAP_UPGRADE_COMPLETE_FLAG)
81 {
82 return IAP_SUCCESS;
83 }
84 else
85 {
86 return IAP_FAILED;
87 }
88}
89
95void iap_init(void)
96{
97 uint32_t devid = (*((uint32_t *)DEBUG_BASE) & 0x00007000) >> 12;
98
99 switch(devid)
100 {
101 case 2:
102 iap_info.sector_size = SECTOR_SIZE_1K;
103 break;
104 case 3:
105 iap_info.sector_size = SECTOR_SIZE_2K;
106 break;
107 case 4:
108 iap_info.sector_size = SECTOR_SIZE_4K;
109 break;
110 default:
111 iap_info.sector_size = SECTOR_SIZE_2K;
112 break;
113 }
114 iap_info.flash_size = KB_TO_B(FLASH_SIZE_REG());
115
116 iap_info.flash_start_address = FLASH_BASE;
117 iap_info.flash_end_address = iap_info.flash_start_address + iap_info.flash_size;
118
119 iap_info.app_address = FLASH_APP_ADDRESS;
120 iap_info.flag_address = iap_info.app_address - iap_info.sector_size;
121
122 iap_info.fifo_length = 0;
123 iap_info.iap_address = 0;
124}
125
131void iap_idle(void)
132{
133 iap_info.state = IAP_STS_JMP_WAIT;
134 iap_init();
135 iap_respond(iap_info.iap_tx, IAP_CMD_IDLE, IAP_ACK);
136}
137
143void iap_start(void)
144{
145 iap_info.state = IAP_STS_START;
146 iap_init();
147 iap_respond(iap_info.iap_tx, IAP_CMD_START, IAP_ACK);
148}
149
150/*
151 * @brief iap jump
152 * @param none
153 * @retval none
154 */
155void iap_jump()
156{
157 iap_info.state = IAP_STS_JMP_WAIT;
158 iap_respond(iap_info.iap_tx, IAP_CMD_JMP, IAP_ACK);
159}
160
161/*
162 * @brief iap get
163 * @param none
164 * @retval none
165 */
166void iap_get()
167{
168 iap_respond(iap_info.iap_tx, IAP_CMD_GET, IAP_ACK);
169 iap_info.iap_tx[4] = (uint8_t)((iap_info.app_address >> 24) & 0xFF);
170 iap_info.iap_tx[5] = (uint8_t)((iap_info.app_address >> 16) & 0xFF);
171 iap_info.iap_tx[6] = (uint8_t)((iap_info.app_address >> 8) & 0xFF);
172 iap_info.iap_tx[7] = (uint8_t)((iap_info.app_address) & 0xFF);
173}
174
175
176
177/*
178 * @brief iap respond
179 * @param res_buf: data buffer pointer.
180 * @param iap_cmd: iap command
181 * @param result: iap result
182 * @retval the result of the address parse
183 */
184void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
185{
186 res_buf[0] = (uint8_t)((iap_cmd >> 8) & 0xFF);
187 res_buf[1] = (uint8_t)((iap_cmd) & 0xFF);
188 res_buf[2] = (uint8_t)((result >> 8) & 0xFF);
189 res_buf[3] = (uint8_t)((result) & 0xFF);
190
191 iap_info.respond_flag = 1;
192}
193
201 iap_result_type usbd_hid_iap_process(void *udev, uint8_t *pdata, uint16_t len)
202{
203 iap_result_type status = IAP_SUCCESS;
204 uint16_t iap_cmd;
205
206 if(len < 2)
207 {
208 return IAP_FAILED;
209 }
210
211 iap_info.respond_flag = 0;
212
213 iap_cmd = (pdata[0] << 8) | pdata[1];
214
215 switch(iap_cmd)
216 {
217 case IAP_CMD_IDLE:
218 iap_idle();
219 break;
220 case IAP_CMD_START:
221 iap_start();
222 break;
223 case IAP_CMD_JMP:
224 iap_jump();
225 break;
226 case IAP_CMD_GET:
227 iap_get();
228 break;
229 default:
230 status = IAP_FAILED;
231 break;
232 }
233
234 if(iap_info.respond_flag)
235 {
236 usb_iap_class_send_report(udev, iap_info.iap_tx, 64);
237 }
238
239 return status;
240}
241
247void usbd_hid_iap_in_complete(void *udev)
248{
249 if(iap_info.state == IAP_STS_JMP_WAIT)
250 {
251 iap_info.state = IAP_STS_JMP;
252 }
253}
254
260void app_loop(void)
261{
262 if(iap_info.state == IAP_STS_JMP)
263 {
264 iap_clear_upgrade_flag();
265 nvic_system_reset();
266 }
267}
FLASH_APP_ADDRESS
#define FLASH_APP_ADDRESS
Definition: app_led3_toggle/inc/hid_iap_user.h:46
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f435_437_flash.c:357
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f435_437_flash.c:290
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f435_437_flash.c:608
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f435_437_flash.c:325
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f435_437_misc.c:52
DEBUG_BASE
#define DEBUG_BASE
Definition: at32f435_437.h:427
FLASH_BASE
#define FLASH_BASE
Definition: at32f435_437.h:425
iap_set_upgrade_flag
void iap_set_upgrade_flag(void)
set iap upgrade complete flag
Definition: app_led4_toggle/src/hid_iap_user.c:64
iap_idle
void iap_idle(void)
iap idle function
Definition: app_led4_toggle/src/hid_iap_user.c:131
iap_respond
void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
Definition: app_led4_toggle/src/hid_iap_user.c:184
iap_init
void iap_init(void)
iap init
Definition: app_led4_toggle/src/hid_iap_user.c:95
usbd_hid_iap_process
iap_result_type usbd_hid_iap_process(void *udev, uint8_t *pdata, uint16_t len)
usb device iap function
Definition: app_led4_toggle/src/hid_iap_user.c:201
crc_cal
uint32_t crc_cal(uint32_t addr, uint16_t nk)
crc cal
Definition: bootloader/src/hid_iap_user.c:162
iap_jump
void iap_jump()
Definition: app_led4_toggle/src/hid_iap_user.c:155
iap_get_upgrade_flag
iap_result_type iap_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: app_led4_toggle/src/hid_iap_user.c:77
iap_finish
void iap_finish(void)
Definition: bootloader/src/hid_iap_user.c:333
iap_start
void iap_start(void)
iap start function
Definition: app_led4_toggle/src/hid_iap_user.c:143
iap_clear_upgrade_flag
void iap_clear_upgrade_flag(void)
clear iap upgrade flag
Definition: app_led4_toggle/src/hid_iap_user.c:52
iap_get
void iap_get()
Definition: app_led4_toggle/src/hid_iap_user.c:166
app_loop
void app_loop(void)
iap loop
Definition: app_led4_toggle/src/hid_iap_user.c:260
usbd_hid_iap_in_complete
void usbd_hid_iap_in_complete(void *udev)
usb device in transfer complete function
Definition: app_led4_toggle/src/hid_iap_user.c:247
IAP_CMD_IDLE
#define IAP_CMD_IDLE
iap command
Definition: hid_iap_class.h:68
IAP_CMD_GET
#define IAP_CMD_GET
Definition: hid_iap_class.h:75
SECTOR_SIZE_1K
#define SECTOR_SIZE_1K
Definition: hid_iap_class.h:61
iap_result_type
iap_result_type
Definition: hid_iap_class.h:86
IAP_ACK
#define IAP_ACK
Definition: hid_iap_class.h:82
SECTOR_SIZE_2K
#define SECTOR_SIZE_2K
Definition: hid_iap_class.h:62
SECTOR_SIZE_4K
#define SECTOR_SIZE_4K
Definition: hid_iap_class.h:63
IAP_UPGRADE_COMPLETE_FLAG
#define IAP_UPGRADE_COMPLETE_FLAG
Definition: hid_iap_class.h:78
FLASH_SIZE_REG
#define FLASH_SIZE_REG()
Definition: hid_iap_class.h:58
IAP_CMD_START
#define IAP_CMD_START
Definition: hid_iap_class.h:69
IAP_CMD_JMP
#define IAP_CMD_JMP
Definition: hid_iap_class.h:74
KB_TO_B
#define KB_TO_B(kb)
Definition: hid_iap_class.h:59
IAP_FAILED
@ IAP_FAILED
Definition: hid_iap_class.h:89
IAP_SUCCESS
@ IAP_SUCCESS
Definition: hid_iap_class.h:87
IAP_STS_START
@ IAP_STS_START
Definition: hid_iap_class.h:95
IAP_STS_JMP
@ IAP_STS_JMP
Definition: hid_iap_class.h:101
IAP_STS_JMP_WAIT
@ IAP_STS_JMP_WAIT
Definition: hid_iap_class.h:100
iap_info
iap_info_type iap_info
Definition: hid_iap_class.c:54
usb_iap_class_send_report
usb_sts_type usb_iap_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: hid_iap_class.c:316
hid_iap_class.h
usb hid iap header file
iap_info_type::respond_flag
uint32_t respond_flag
Definition: hid_iap_class.h:124
iap_info_type::flag_address
uint32_t flag_address
Definition: hid_iap_class.h:116
iap_info_type::sector_size
uint32_t sector_size
Definition: hid_iap_class.h:121
iap_info_type::iap_address
uint32_t iap_address
Definition: hid_iap_class.h:115
iap_info_type::flash_start_address
uint32_t flash_start_address
Definition: hid_iap_class.h:118
iap_info_type::flash_end_address
uint32_t flash_end_address
Definition: hid_iap_class.h:119
iap_info_type::fifo_length
uint32_t fifo_length
Definition: hid_iap_class.h:111
iap_info_type::flash_size
uint32_t flash_size
Definition: hid_iap_class.h:122
iap_info_type::iap_tx
uint8_t iap_tx[0x40]
Definition: hid_iap_class.h:109
iap_info_type::app_address
uint32_t app_address
Definition: hid_iap_class.h:114
iap_info_type::state
iap_machine_state_type state
Definition: hid_iap_class.h:133


AT32F435/437 Firmwary Library: usart.c File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
Functions | Variables
app_led4_toggle/src/usart.c File Reference

usart program More...

#include "usart.h"
#include "tmr.h"

Go to the source code of this file.

Functions

void | uart_init (uint32_t baudrate)
init usart. More...
void | USART1_IRQHandler (void)
usart1 interrupt handler. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...

Variables

uint8_t iap_flag = IAP_REV_FLAG_NO

Detailed Description

usart program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led4_toggle/src/usart.c.


AT32F435/437 Firmwary Library: usart.c Source File

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
app_led4_toggle/src/usart.c
Go to the documentation of this file.
1
27#include "usart.h"
28#include "tmr.h"
29
38uint8_t iap_flag = IAP_REV_FLAG_NO;
39
45void uart_init(uint32_t baudrate)
46{
47 gpio_init_type gpio_init_struct;
48 /* enable the usart and it's io clock */
49 crm_periph_clock_enable(CRM_USART1_PERIPH_CLOCK, TRUE);
50 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
51
52 /* set default parameter */
53 gpio_default_para_init(&gpio_init_struct);
54
55 /* configure the usart1_tx rx pa9 pa10 */
56 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
57 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
58 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
59 gpio_init_struct.gpio_pins = GPIO_PINS_9 | GPIO_PINS_10;
60 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
61 gpio_init(GPIOA, &gpio_init_struct);
62 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE9 ,GPIO_MUX_7);
63 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE10 ,GPIO_MUX_7);
64
65 /*configure usart nvic interrupt */
66 nvic_irq_enable(USART1_IRQn, 0, 0);
67
68 /*configure usart param*/
69 usart_init(USART1, baudrate, USART_DATA_8BITS, USART_STOP_1_BIT);
70 usart_transmitter_enable(USART1, TRUE);
71 usart_receiver_enable(USART1, TRUE);
72 usart_interrupt_enable(USART1, USART_RDBF_INT, TRUE);
73 usart_enable(USART1, TRUE);
74}
75
81void USART1_IRQHandler(void)
82{
83 uint16_t reval;
84 if(usart_flag_get(USART1, USART_RDBF_FLAG) != RESET)
85 {
86 reval = usart_data_receive(USART1);
87 if((reval == 0x5A) && (iap_flag == IAP_REV_FLAG_NO))
88 iap_flag = IAP_REV_FLAG_5A;
89 else if((reval == 0xA5) && (iap_flag == IAP_REV_FLAG_5A))
90 iap_flag = IAP_REV_FLAG_DONE;
91 else
92 iap_flag = IAP_REV_FLAG_NO;
93 }
94}
95
101void back_ok(void)
102{
103 usart_data_transmit(USART1, 0xCC);
104 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
105 usart_data_transmit(USART1, 0xDD);
106 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
107}
108
114void back_err(void)
115{
116 usart_data_transmit(USART1, 0xEE);
117 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
118 usart_data_transmit(USART1, 0xFF);
119 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
120}
121
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_USART1_PERIPH_CLOCK
@ CRM_USART1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:156
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
IAP_REV_FLAG_DONE
#define IAP_REV_FLAG_DONE
Definition: app_led3_toggle/inc/usart.h:52
IAP_REV_FLAG_NO
#define IAP_REV_FLAG_NO
Definition: app_led3_toggle/inc/usart.h:50
IAP_REV_FLAG_5A
#define IAP_REV_FLAG_5A
Definition: app_led3_toggle/inc/usart.h:51
USART1_IRQHandler
void USART1_IRQHandler(void)
usart1 interrupt handler.
Definition: app_led4_toggle/src/usart.c:81
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: app_led4_toggle/src/usart.c:45
iap_flag
uint8_t iap_flag
Definition: app_led4_toggle/src/usart.c:38
back_err
void back_err(void)
command response error.
Definition: app_led4_toggle/src/usart.c:114
back_ok
void back_ok(void)
command response ok.
Definition: app_led4_toggle/src/usart.c:101
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f435_437_usart.c:413
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f435_437_usart.c:598
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f435_437_usart.c:209
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f435_437_usart.c:115
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f435_437_usart.c:196
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f435_437_usart.c:222
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f435_437_usart.c:287
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f435_437_usart.c:425
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f435_437_usart.h:159
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f435_437_usart.h:114
USART_TDC_FLAG
#define USART_TDC_FLAG
Definition: at32f435_437_usart.h:58
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f435_437_usart.h:57
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f435_437_usart.h:73
USART1
#define USART1
Definition: at32f435_437_usart.h:348
USART1_IRQn
@ USART1_IRQn
Definition: at32f435_437.h:185
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121


AT32F435/437 Firmwary Library: arm_fir_init_f32.c File Reference

  • utilities
  • at32f435_437_slib_demo
  • project_l0
  • src
Functions
arm_fir_init_f32.c File Reference
#include "arm_math.h"

Go to the source code of this file.

Functions

void * | my_memset (void *s, int c, size_t n)
void | arm_fir_init_f32 (arm_fir_instance_f32 *S, uint16_t numTaps, const float32_t *pCoeffs, float32_t *pState, uint32_t blockSize)
Initialization function for the floating-point FIR filter. More...

Function Documentation

◆ arm_fir_init_f32()

void arm_fir_init_f32 | ( | arm_fir_instance_f32 * | S,
 |  | uint16_t | numTaps,
 |  | const float32_t * | pCoeffs,
 |  | float32_t * | pState,
 |  | uint32_t | blockSize
 | ) |  |

Initialization function for the floating-point FIR filter.

Parameters
[in,out] | S | points to an instance of the floating-point FIR filter structure
[in] | numTaps | number of filter coefficients in the filter
[in] | pCoeffs | points to the filter coefficients buffer
[in] | pState | points to the state buffer
[in] | blockSize | number of samples processed per call
Returns
none
Details
pCoeffs points to the array of filter coefficients stored in time reversed order:
    {b[numTaps-1], b[numTaps-2], b[N-2], ..., b[1], b[0]}
pState points to the array of state variables. pState is of length numTaps+blockSize-1 samples, where blockSize is the number of input samples processed by each call to arm_fir_f32().
Initialization of Helium version
For Helium version the array of coefficients must be a multiple of 16 even if less then 16 coefficients are used. The additional coefficients must be set to 0. It does not mean that all the coefficients will be used in the filter (numTaps is still set to its right value in the init function.) It just means that the implementation may require to read more coefficients due to the vectorization and to avoid having to manage too many different cases in the code.

Definition at line 59 of file arm_fir_init_f32.c.

Referenced by FIR_lowpass_filter().

◆ my_memset()

void * my_memset | ( | void * | s,
 |  | int | c,
 |  | size_t | n
 | ) |  |

Definition at line 79 of file arm_fir_init_f32.c.

Referenced by arm_fir_init_f32().


AT32F435/437 Firmwary Library: arm_fir_init_f32.c Source File

  • utilities
  • at32f435_437_slib_demo
  • project_l0
  • src
arm_fir_init_f32.c
Go to the documentation of this file.
1/* ----------------------------------------------------------------------
2 * Project: CMSIS DSP Library
3 * Title: arm_fir_init_f32.c
4 * Description: Floating-point FIR filter initialization function
5 *
6 * $Date: 18. March 2019
7 * $Revision: V1.6.0
8 *
9 * Target Processor: Cortex-M cores
10 * -------------------------------------------------------------------- */
11/*
12 * Copyright (C) 2010-2019 ARM Limited or its affiliates. All rights reserved.
13 *
14 * SPDX-License-Identifier: Apache-2.0
15 *
16 * Licensed under the Apache License, Version 2.0 (the License); you may
17 * not use this file except in compliance with the License.
18 * You may obtain a copy of the License at
19 *
20 * www.apache.org/licenses/LICENSE-2.0
21 *
22 * Unless required by applicable law or agreed to in writing, software
23 * distributed under the License is distributed on an AS IS BASIS, WITHOUT
24 * WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
25 * See the License for the specific language governing permissions and
26 * limitations under the License.
27 */
28
29#include "arm_math.h"
30
31void* my_memset(void *s, int c, size_t n);
32
59void arm_fir_init_f32(
60 arm_fir_instance_f32 * S,
61 uint16_t numTaps,
62 const float32_t * pCoeffs,
63 float32_t * pState,
64 uint32_t blockSize)
65{
66 /* Assign filter taps */
67 S->numTaps = numTaps;
68
69 /* Assign coefficient pointer */
70 S->pCoeffs = pCoeffs;
71
72 /* Clear state buffer. The size is always (blockSize + numTaps - 1) */
73 my_memset(pState, 0, (numTaps + (blockSize - 1u)) * sizeof(float32_t));
74
75 /* Assign state pointer */
76 S->pState = pState;
77}
78
79void* my_memset(void *s, int c, size_t n)
80{
81 while (n>0)
82 *( (char*)s + n-- -1 ) = (char)c;
83
84 return (s);
85}
my_memset
void * my_memset(void *s, int c, size_t n)
Definition: arm_fir_init_f32.c:79
arm_fir_init_f32
void arm_fir_init_f32(arm_fir_instance_f32 *S, uint16_t numTaps, const float32_t *pCoeffs, float32_t *pState, uint32_t blockSize)
Initialization function for the floating-point FIR filter.
Definition: arm_fir_init_f32.c:59


AT32F435/437 Firmwary Library: at32f435_437.h Source File

  • libraries
  • cmsis
  • cm4
  • device_support
at32f435_437.h
Go to the documentation of this file.
1
27#ifndef __AT32F435_437_H
28#define __AT32F435_437_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#if defined (__CC_ARM)
35 #pragma anon_unions
36#endif
37
38
56#if !defined (AT32F435CCU7) && !defined (AT32F435CGU7) && !defined (AT32F435CMU7) && \
57 !defined (AT32F435CCT7) && !defined (AT32F435CGT7) && !defined (AT32F435CMT7) && \
58 !defined (AT32F435RCT7) && !defined (AT32F435RGT7) && !defined (AT32F435RMT7) && \
59 !defined (AT32F435VCT7) && !defined (AT32F435VGT7) && !defined (AT32F435VMT7) && \
60 !defined (AT32F435ZCT7) && !defined (AT32F435ZGT7) && !defined (AT32F435ZMT7) && \
61 !defined (AT32F437RCT7) && !defined (AT32F437RGT7) && !defined (AT32F437RMT7) && \
62 !defined (AT32F437VCT7) && !defined (AT32F437VGT7) && !defined (AT32F437VMT7) && \
63 !defined (AT32F437ZCT7) && !defined (AT32F437ZGT7) && !defined (AT32F437ZMT7)
64
65 #error "Please select first the target device used in your application (in at32f435_437.h file)"
66#endif
67
68#if defined (AT32F435CCU7) || defined (AT32F435CGU7) || defined (AT32F435CMU7) || \
69 defined (AT32F435CCT7) || defined (AT32F435CGT7) || defined (AT32F435CMT7) || \
70 defined (AT32F435RCT7) || defined (AT32F435RGT7) || defined (AT32F435RMT7) || \
71 defined (AT32F435VCT7) || defined (AT32F435VGT7) || defined (AT32F435VMT7) || \
72 defined (AT32F435ZCT7) || defined (AT32F435ZGT7) || defined (AT32F435ZMT7)
73
74 #define AT32F435xx
75#endif
76
77#if defined (AT32F437RCT7) || defined (AT32F437RGT7) || defined (AT32F437RMT7) || \
78 defined (AT32F437VCT7) || defined (AT32F437VGT7) || defined (AT32F437VMT7) || \
79 defined (AT32F437ZCT7) || defined (AT32F437ZGT7) || defined (AT32F437ZMT7)
80
81 #define AT32F437xx
82#endif
83
84#ifndef USE_STDPERIPH_DRIVER
90 #ifdef _RTE_
91 #include "RTE_Components.h"
92 #ifdef RTE_DEVICE_STDPERIPH_FRAMEWORK
93 #define USE_STDPERIPH_DRIVER
94 #endif
95 #endif
96#endif
97
101#define __AT32F435_437_LIBRARY_VERSION_MAJOR (0x02)
102#define __AT32F435_437_LIBRARY_VERSION_MIDDLE (0x00)
103#define __AT32F435_437_LIBRARY_VERSION_MINOR (0x09)
104#define __AT32F435_437_LIBRARY_VERSION_RC (0x00)
105#define __AT32F435_437_LIBRARY_VERSION ((__AT32F435_437_LIBRARY_VERSION_MAJOR << 24) | \
106 (__AT32F435_437_LIBRARY_VERSION_MIDDLE << 16) | \
107 (__AT32F435_437_LIBRARY_VERSION_MINOR << 8) | \
108 (__AT32F435_437_LIBRARY_VERSION_RC))
109
121#define __CM4_REV 0x0001U
122#define __MPU_PRESENT 1
123#define __NVIC_PRIO_BITS 4
124#define __Vendor_SysTickConfig 0
125#define __FPU_PRESENT 1U
131typedef enum IRQn
132{
133 /****** cortex-m4 processor exceptions numbers ***************************************************/
134 Reset_IRQn = -15,
135 NonMaskableInt_IRQn = -14,
136 HardFault_IRQn = -13,
137 MemoryManagement_IRQn = -12,
138 BusFault_IRQn = -11,
139 UsageFault_IRQn = -10,
140 SVCall_IRQn = -5,
141 DebugMonitor_IRQn = -4,
142 PendSV_IRQn = -2,
143 SysTick_IRQn = -1,
145 /****** at32 specific interrupt numbers *********************************************************/
146 WWDT_IRQn = 0,
147 PVM_IRQn = 1,
148 TAMP_STAMP_IRQn = 2,
149 ERTC_WKUP_IRQn = 3,
150 FLASH_IRQn = 4,
151 CRM_IRQn = 5,
152 EXINT0_IRQn = 6,
153 EXINT1_IRQn = 7,
154 EXINT2_IRQn = 8,
155 EXINT3_IRQn = 9,
156 EXINT4_IRQn = 10,
157 EDMA_Stream1_IRQn = 11,
158 EDMA_Stream2_IRQn = 12,
159 EDMA_Stream3_IRQn = 13,
160 EDMA_Stream4_IRQn = 14,
161 EDMA_Stream5_IRQn = 15,
162 EDMA_Stream6_IRQn = 16,
163 EDMA_Stream7_IRQn = 17,
165#if defined (AT32F435xx)
166 ADC1_2_3_IRQn = 18,
167 CAN1_TX_IRQn = 19,
168 CAN1_RX0_IRQn = 20,
169 CAN1_RX1_IRQn = 21,
170 CAN1_SE_IRQn = 22,
171 EXINT9_5_IRQn = 23,
172 TMR1_BRK_TMR9_IRQn = 24,
173 TMR1_OVF_TMR10_IRQn = 25,
174 TMR1_TRG_HALL_TMR11_IRQn = 26,
175 TMR1_CH_IRQn = 27,
176 TMR2_GLOBAL_IRQn = 28,
177 TMR3_GLOBAL_IRQn = 29,
178 TMR4_GLOBAL_IRQn = 30,
179 I2C1_EVT_IRQn = 31,
180 I2C1_ERR_IRQn = 32,
181 I2C2_EVT_IRQn = 33,
182 I2C2_ERR_IRQn = 34,
183 SPI1_IRQn = 35,
184 SPI2_I2S2EXT_IRQn = 36,
185 USART1_IRQn = 37,
186 USART2_IRQn = 38,
187 USART3_IRQn = 39,
188 EXINT15_10_IRQn = 40,
189 ERTCAlarm_IRQn = 41,
190 OTGFS1_WKUP_IRQn = 42,
191 TMR8_BRK_TMR12_IRQn = 43,
192 TMR8_OVF_TMR13_IRQn = 44,
193 TMR8_TRG_HALL_TMR14_IRQn = 45,
194 TMR8_CH_IRQn = 46,
195 EDMA_Stream8_IRQn = 47,
196 XMC_IRQn = 48,
197 SDIO1_IRQn = 49,
198 TMR5_GLOBAL_IRQn = 50,
199 SPI3_I2S3EXT_IRQn = 51,
200 UART4_IRQn = 52,
201 UART5_IRQn = 53,
202 TMR6_DAC_GLOBAL_IRQn = 54,
203 TMR7_GLOBAL_IRQn = 55,
204 DMA1_Channel1_IRQn = 56,
205 DMA1_Channel2_IRQn = 57,
206 DMA1_Channel3_IRQn = 58,
207 DMA1_Channel4_IRQn = 59,
208 DMA1_Channel5_IRQn = 60,
209 CAN2_TX_IRQn = 63,
210 CAN2_RX0_IRQn = 64,
211 CAN2_RX1_IRQn = 65,
212 CAN2_SE_IRQn = 66,
213 OTGFS1_IRQn = 67,
214 DMA1_Channel6_IRQn = 68,
215 DMA1_Channel7_IRQn = 69,
216 USART6_IRQn = 71,
217 I2C3_EVT_IRQn = 72,
218 I2C3_ERR_IRQn = 73,
219 OTGFS2_WKUP_IRQn = 76,
220 OTGFS2_IRQn = 77,
221 DVP_IRQn = 78,
222 FPU_IRQn = 81,
223 UART7_IRQn = 82,
224 UART8_IRQn = 83,
225 SPI4_IRQn = 84,
226 QSPI2_IRQn = 91,
227 QSPI1_IRQn = 92,
228 DMAMUX_IRQn = 94,
229 SDIO2_IRQn = 102,
230 ACC_IRQn = 103,
231 TMR20_BRK_IRQn = 104,
232 TMR20_OVF_IRQn = 105,
233 TMR20_TRG_HALL_IRQn = 106,
234 TMR20_CH_IRQn = 107,
235 DMA2_Channel1_IRQn = 108,
236 DMA2_Channel2_IRQn = 109,
237 DMA2_Channel3_IRQn = 110,
238 DMA2_Channel4_IRQn = 111,
239 DMA2_Channel5_IRQn = 112,
240 DMA2_Channel6_IRQn = 113,
241 DMA2_Channel7_IRQn = 114,
242#endif
243
244#if defined (AT32F437xx)
245 ADC1_2_3_IRQn = 18,
246 CAN1_TX_IRQn = 19,
247 CAN1_RX0_IRQn = 20,
248 CAN1_RX1_IRQn = 21,
249 CAN1_SE_IRQn = 22,
250 EXINT9_5_IRQn = 23,
251 TMR1_BRK_TMR9_IRQn = 24,
252 TMR1_OVF_TMR10_IRQn = 25,
253 TMR1_TRG_HALL_TMR11_IRQn = 26,
254 TMR1_CH_IRQn = 27,
255 TMR2_GLOBAL_IRQn = 28,
256 TMR3_GLOBAL_IRQn = 29,
257 TMR4_GLOBAL_IRQn = 30,
258 I2C1_EVT_IRQn = 31,
259 I2C1_ERR_IRQn = 32,
260 I2C2_EVT_IRQn = 33,
261 I2C2_ERR_IRQn = 34,
262 SPI1_IRQn = 35,
263 SPI2_I2S2EXT_IRQn = 36,
264 USART1_IRQn = 37,
265 USART2_IRQn = 38,
266 USART3_IRQn = 39,
267 EXINT15_10_IRQn = 40,
268 ERTCAlarm_IRQn = 41,
269 OTGFS1_WKUP_IRQn = 42,
270 TMR8_BRK_TMR12_IRQn = 43,
271 TMR8_OVF_TMR13_IRQn = 44,
272 TMR8_TRG_HALL_TMR14_IRQn = 45,
273 TMR8_CH_IRQn = 46,
274 EDMA_Stream8_IRQn = 47,
275 XMC_IRQn = 48,
276 SDIO1_IRQn = 49,
277 TMR5_GLOBAL_IRQn = 50,
278 SPI3_I2S3EXT_IRQn = 51,
279 UART4_IRQn = 52,
280 UART5_IRQn = 53,
281 TMR6_DAC_GLOBAL_IRQn = 54,
282 TMR7_GLOBAL_IRQn = 55,
283 DMA1_Channel1_IRQn = 56,
284 DMA1_Channel2_IRQn = 57,
285 DMA1_Channel3_IRQn = 58,
286 DMA1_Channel4_IRQn = 59,
287 DMA1_Channel5_IRQn = 60,
288 EMAC_IRQn = 61,
289 EMAC_WKUP_IRQn = 62,
290 CAN2_TX_IRQn = 63,
291 CAN2_RX0_IRQn = 64,
292 CAN2_RX1_IRQn = 65,
293 CAN2_SE_IRQn = 66,
294 OTGFS1_IRQn = 67,
295 DMA1_Channel6_IRQn = 68,
296 DMA1_Channel7_IRQn = 69,
297 USART6_IRQn = 71,
298 I2C3_EVT_IRQn = 72,
299 I2C3_ERR_IRQn = 73,
300 OTGFS2_WKUP_IRQn = 76,
301 OTGFS2_IRQn = 77,
302 DVP_IRQn = 78,
303 FPU_IRQn = 81,
304 UART7_IRQn = 82,
305 UART8_IRQn = 83,
306 SPI4_IRQn = 84,
307 QSPI2_IRQn = 91,
308 QSPI1_IRQn = 92,
309 DMAMUX_IRQn = 94,
310 SDIO2_IRQn = 102,
311 ACC_IRQn = 103,
312 TMR20_BRK_IRQn = 104,
313 TMR20_OVF_IRQn = 105,
314 TMR20_TRG_HALL_IRQn = 106,
315 TMR20_CH_IRQn = 107,
316 DMA2_Channel1_IRQn = 108,
317 DMA2_Channel2_IRQn = 109,
318 DMA2_Channel3_IRQn = 110,
319 DMA2_Channel4_IRQn = 111,
320 DMA2_Channel5_IRQn = 112,
321 DMA2_Channel6_IRQn = 113,
322 DMA2_Channel7_IRQn = 114,
323#endif
324
325} IRQn_Type;
326
331#include "core_cm4.h"
332#include "system_at32f435_437.h"
333#include <stdint.h>
334
339typedef int32_t INT32;
340typedef int16_t INT16;
341typedef int8_t INT8;
342typedef uint32_t UINT32;
343typedef uint16_t UINT16;
344typedef uint8_t UINT8;
345
346typedef int32_t s32;
347typedef int16_t s16;
348typedef int8_t s8;
349
350typedef const int32_t sc32;
351typedef const int16_t sc16;
352typedef const int8_t sc8;
354typedef __IO int32_t vs32;
355typedef __IO int16_t vs16;
356typedef __IO int8_t vs8;
357
358typedef __I int32_t vsc32;
359typedef __I int16_t vsc16;
360typedef __I int8_t vsc8;
362typedef uint32_t u32;
363typedef uint16_t u16;
364typedef uint8_t u8;
365
366typedef const uint32_t uc32;
367typedef const uint16_t uc16;
368typedef const uint8_t uc8;
370typedef __IO uint32_t vu32;
371typedef __IO uint16_t vu16;
372typedef __IO uint8_t vu8;
373
374typedef __I uint32_t vuc32;
375typedef __I uint16_t vuc16;
376typedef __I uint8_t vuc8;
378typedef enum {RESET = 0, SET = !RESET} flag_status;
379typedef enum {FALSE = 0, TRUE = !FALSE} confirm_state;
380typedef enum {ERROR = 0, SUCCESS = !ERROR} error_status;
381
390#define REG8(addr) *(volatile uint8_t *)(addr)
391#define REG16(addr) *(volatile uint16_t *)(addr)
392#define REG32(addr) *(volatile uint32_t *)(addr)
393
394#define MAKE_VALUE(reg_offset, bit_num) (((reg_offset) << 16) | (bit_num & 0x1f))
395
396#define PERIPH_REG(periph_base, value) REG32((periph_base + (value >> 16)))
397#define PERIPH_REG_BIT(value) (0x1u << (value & 0x1f))
398
407#define XMC_SDRAM_MEM_BASE ((uint32_t)0xC0000000)
408#define QSPI2_MEM_BASE ((uint32_t)0xB0000000)
409#define XMC_CARD_MEM_BASE ((uint32_t)0xA8000000)
410#define QSPI2_REG_BASE ((uint32_t)0xA0002000)
411#define QSPI1_REG_BASE ((uint32_t)0xA0001000)
412#define XMC_REG_BASE ((uint32_t)0xA0000000)
413#define XMC_BANK1_REG_BASE (XMC_REG_BASE + 0x0000)
414#define XMC_BANK2_REG_BASE (XMC_REG_BASE + 0x0060)
415#define XMC_BANK3_REG_BASE (XMC_REG_BASE + 0x0080)
416#define XMC_BANK4_REG_BASE (XMC_REG_BASE + 0x00A0)
417#define XMC_SDRAM_REG_BASE (XMC_REG_BASE + 0x0140)
418#define QSPI1_MEM_BASE ((uint32_t)0x90000000)
419#define XMC_MEM_BASE ((uint32_t)0x60000000)
420#define PERIPH_BASE ((uint32_t)0x40000000)
421#define SRAM_BB_BASE ((uint32_t)0x22000000)
422#define PERIPH_BB_BASE ((uint32_t)0x42000000)
423#define SRAM_BASE ((uint32_t)0x20000000)
424#define USD_BASE ((uint32_t)0x1FFFC000)
425#define FLASH_BASE ((uint32_t)0x08000000)
426
427#define DEBUG_BASE ((uint32_t)0xE0042000)
428
429#define APB1PERIPH_BASE (PERIPH_BASE)
430#define APB2PERIPH_BASE (PERIPH_BASE + 0x10000)
431#define AHBPERIPH1_BASE (PERIPH_BASE + 0x20000)
432#define AHBPERIPH2_BASE (PERIPH_BASE + 0x10000000)
433
434#if defined (AT32F435xx)
435/* apb1 bus base address */
436#define UART8_BASE (APB1PERIPH_BASE + 0x7C00)
437#define UART7_BASE (APB1PERIPH_BASE + 0x7800)
438#define DAC_BASE (APB1PERIPH_BASE + 0x7400)
439#define PWC_BASE (APB1PERIPH_BASE + 0x7000)
440#define CAN2_BASE (APB1PERIPH_BASE + 0x6800)
441#define CAN1_BASE (APB1PERIPH_BASE + 0x6400)
442#define I2C3_BASE (APB1PERIPH_BASE + 0x5C00)
443#define I2C2_BASE (APB1PERIPH_BASE + 0x5800)
444#define I2C1_BASE (APB1PERIPH_BASE + 0x5400)
445#define UART5_BASE (APB1PERIPH_BASE + 0x5000)
446#define UART4_BASE (APB1PERIPH_BASE + 0x4C00)
447#define USART3_BASE (APB1PERIPH_BASE + 0x4800)
448#define USART2_BASE (APB1PERIPH_BASE + 0x4400)
449#define SPI3_BASE (APB1PERIPH_BASE + 0x3C00)
450#define SPI2_BASE (APB1PERIPH_BASE + 0x3800)
451#define WDT_BASE (APB1PERIPH_BASE + 0x3000)
452#define WWDT_BASE (APB1PERIPH_BASE + 0x2C00)
453#define ERTC_BASE (APB1PERIPH_BASE + 0x2800)
454#define TMR14_BASE (APB1PERIPH_BASE + 0x2000)
455#define TMR13_BASE (APB1PERIPH_BASE + 0x1C00)
456#define TMR12_BASE (APB1PERIPH_BASE + 0x1800)
457#define TMR7_BASE (APB1PERIPH_BASE + 0x1400)
458#define TMR6_BASE (APB1PERIPH_BASE + 0x1000)
459#define TMR5_BASE (APB1PERIPH_BASE + 0x0C00)
460#define TMR4_BASE (APB1PERIPH_BASE + 0x0800)
461#define TMR3_BASE (APB1PERIPH_BASE + 0x0400)
462#define TMR2_BASE (APB1PERIPH_BASE + 0x0000)
463/* apb2 bus base address */
464#define I2S2EXT_BASE (APB2PERIPH_BASE + 0x7800)
465#define I2S3EXT_BASE (APB2PERIPH_BASE + 0x7C00)
466#define ACC_BASE (APB2PERIPH_BASE + 0x7400)
467#define TMR20_BASE (APB2PERIPH_BASE + 0x4C00)
468#define TMR11_BASE (APB2PERIPH_BASE + 0x4800)
469#define TMR10_BASE (APB2PERIPH_BASE + 0x4400)
470#define TMR9_BASE (APB2PERIPH_BASE + 0x4000)
471#define EXINT_BASE (APB2PERIPH_BASE + 0x3C00)
472#define SCFG_BASE (APB2PERIPH_BASE + 0x3800)
473#define SPI4_BASE (APB2PERIPH_BASE + 0x3400)
474#define SPI1_BASE (APB2PERIPH_BASE + 0x3000)
475#define ADC1_BASE (APB2PERIPH_BASE + 0x2000)
476#define ADC2_BASE (APB2PERIPH_BASE + 0x2100)
477#define ADC3_BASE (APB2PERIPH_BASE + 0x2200)
478#define ADCCOM_BASE (APB2PERIPH_BASE + 0x2300)
479#define USART6_BASE (APB2PERIPH_BASE + 0x1400)
480#define USART1_BASE (APB2PERIPH_BASE + 0x1000)
481#define TMR8_BASE (APB2PERIPH_BASE + 0x0400)
482#define TMR1_BASE (APB2PERIPH_BASE + 0x0000)
483/* ahb bus base address */
484#define OTGFS2_BASE (AHBPERIPH1_BASE + 0x20000)
485#define SDIO1_BASE (AHBPERIPH1_BASE + 0xC400)
486#define GPIOH_BASE (AHBPERIPH1_BASE + 0x1C00)
487#define GPIOG_BASE (AHBPERIPH1_BASE + 0x1800)
488#define GPIOF_BASE (AHBPERIPH1_BASE + 0x1400)
489#define GPIOE_BASE (AHBPERIPH1_BASE + 0x1000)
490#define GPIOD_BASE (AHBPERIPH1_BASE + 0x0C00)
491#define GPIOC_BASE (AHBPERIPH1_BASE + 0x0800)
492#define GPIOB_BASE (AHBPERIPH1_BASE + 0x0400)
493#define GPIOA_BASE (AHBPERIPH1_BASE + 0x0000)
494
495#define DMA1_BASE (AHBPERIPH1_BASE + 0x6400)
496#define DMA1_CHANNEL1_BASE (DMA1_BASE + 0x0008)
497#define DMA1_CHANNEL2_BASE (DMA1_BASE + 0x001C)
498#define DMA1_CHANNEL3_BASE (DMA1_BASE + 0x0030)
499#define DMA1_CHANNEL4_BASE (DMA1_BASE + 0x0044)
500#define DMA1_CHANNEL5_BASE (DMA1_BASE + 0x0058)
501#define DMA1_CHANNEL6_BASE (DMA1_BASE + 0x006C)
502#define DMA1_CHANNEL7_BASE (DMA1_BASE + 0x0080)
503
504#define DMA1MUX_BASE (DMA1_BASE + 0x0104)
505#define DMA1MUX_CHANNEL1_BASE (DMA1MUX_BASE)
506#define DMA1MUX_CHANNEL2_BASE (DMA1MUX_BASE + 0x0004)
507#define DMA1MUX_CHANNEL3_BASE (DMA1MUX_BASE + 0x0008)
508#define DMA1MUX_CHANNEL4_BASE (DMA1MUX_BASE + 0x000C)
509#define DMA1MUX_CHANNEL5_BASE (DMA1MUX_BASE + 0x0010)
510#define DMA1MUX_CHANNEL6_BASE (DMA1MUX_BASE + 0x0014)
511#define DMA1MUX_CHANNEL7_BASE (DMA1MUX_BASE + 0x0018)
512
513#define DMA1MUX_GENERATOR1_BASE (DMA1_BASE + 0x0120)
514#define DMA1MUX_GENERATOR2_BASE (DMA1_BASE + 0x0124)
515#define DMA1MUX_GENERATOR3_BASE (DMA1_BASE + 0x0128)
516#define DMA1MUX_GENERATOR4_BASE (DMA1_BASE + 0x012C)
517
518#define DMA2_BASE (AHBPERIPH1_BASE + 0x6600)
519#define DMA2_CHANNEL1_BASE (DMA2_BASE + 0x0008)
520#define DMA2_CHANNEL2_BASE (DMA2_BASE + 0x001C)
521#define DMA2_CHANNEL3_BASE (DMA2_BASE + 0x0030)
522#define DMA2_CHANNEL4_BASE (DMA2_BASE + 0x0044)
523#define DMA2_CHANNEL5_BASE (DMA2_BASE + 0x0058)
524#define DMA2_CHANNEL6_BASE (DMA2_BASE + 0x006C)
525#define DMA2_CHANNEL7_BASE (DMA2_BASE + 0x0080)
526
527#define DMA2MUX_BASE (DMA2_BASE + 0x0104)
528#define DMA2MUX_CHANNEL1_BASE (DMA2MUX_BASE)
529#define DMA2MUX_CHANNEL2_BASE (DMA2MUX_BASE + 0x0004)
530#define DMA2MUX_CHANNEL3_BASE (DMA2MUX_BASE + 0x0008)
531#define DMA2MUX_CHANNEL4_BASE (DMA2MUX_BASE + 0x000C)
532#define DMA2MUX_CHANNEL5_BASE (DMA2MUX_BASE + 0x0010)
533#define DMA2MUX_CHANNEL6_BASE (DMA2MUX_BASE + 0x0014)
534#define DMA2MUX_CHANNEL7_BASE (DMA2MUX_BASE + 0x0018)
535
536#define DMA2MUX_GENERATOR1_BASE (DMA2_BASE + 0x0120)
537#define DMA2MUX_GENERATOR2_BASE (DMA2_BASE + 0x0124)
538#define DMA2MUX_GENERATOR3_BASE (DMA2_BASE + 0x0128)
539#define DMA2MUX_GENERATOR4_BASE (DMA2_BASE + 0x012C)
540
541#define EDMA_BASE (AHBPERIPH1_BASE + 0x6000)
542#define EDMA_STREAM1_BASE (EDMA_BASE + 0x0010)
543#define EDMA_STREAM2_BASE (EDMA_BASE + 0x0028)
544#define EDMA_STREAM3_BASE (EDMA_BASE + 0x0040)
545#define EDMA_STREAM4_BASE (EDMA_BASE + 0x0058)
546#define EDMA_STREAM5_BASE (EDMA_BASE + 0x0070)
547#define EDMA_STREAM6_BASE (EDMA_BASE + 0x0088)
548#define EDMA_STREAM7_BASE (EDMA_BASE + 0x00A0)
549#define EDMA_STREAM8_BASE (EDMA_BASE + 0x00B8)
550
551#define EDMA_2D_BASE (EDMA_BASE + 0x00F4)
552#define EDMA_STREAM1_2D_BASE (EDMA_2D_BASE + 0x0004)
553#define EDMA_STREAM2_2D_BASE (EDMA_2D_BASE + 0x000C)
554#define EDMA_STREAM3_2D_BASE (EDMA_2D_BASE + 0x0014)
555#define EDMA_STREAM4_2D_BASE (EDMA_2D_BASE + 0x001C)
556#define EDMA_STREAM5_2D_BASE (EDMA_2D_BASE + 0x0024)
557#define EDMA_STREAM6_2D_BASE (EDMA_2D_BASE + 0x002C)
558#define EDMA_STREAM7_2D_BASE (EDMA_2D_BASE + 0x0034)
559#define EDMA_STREAM8_2D_BASE (EDMA_2D_BASE + 0x003C)
560
561#define EDMA_LL_BASE (EDMA_BASE + 0x00D0)
562#define EDMA_STREAM1_LL_BASE (EDMA_LL_BASE + 0x0004)
563#define EDMA_STREAM2_LL_BASE (EDMA_LL_BASE + 0x0008)
564#define EDMA_STREAM3_LL_BASE (EDMA_LL_BASE + 0x000C)
565#define EDMA_STREAM4_LL_BASE (EDMA_LL_BASE + 0x0010)
566#define EDMA_STREAM5_LL_BASE (EDMA_LL_BASE + 0x0014)
567#define EDMA_STREAM6_LL_BASE (EDMA_LL_BASE + 0x0018)
568#define EDMA_STREAM7_LL_BASE (EDMA_LL_BASE + 0x001C)
569#define EDMA_STREAM8_LL_BASE (EDMA_LL_BASE + 0x0020)
570
571#define EDMAMUX_BASE (EDMA_BASE + 0x0140)
572#define EDMAMUX_CHANNEL1_BASE (EDMAMUX_BASE)
573#define EDMAMUX_CHANNEL2_BASE (EDMAMUX_BASE + 0x0004)
574#define EDMAMUX_CHANNEL3_BASE (EDMAMUX_BASE + 0x0008)
575#define EDMAMUX_CHANNEL4_BASE (EDMAMUX_BASE + 0x000C)
576#define EDMAMUX_CHANNEL5_BASE (EDMAMUX_BASE + 0x0010)
577#define EDMAMUX_CHANNEL6_BASE (EDMAMUX_BASE + 0x0014)
578#define EDMAMUX_CHANNEL7_BASE (EDMAMUX_BASE + 0x0018)
579#define EDMAMUX_CHANNEL8_BASE (EDMAMUX_BASE + 0x001C)
580
581#define EDMAMUX_GENERATOR1_BASE (EDMA_BASE + 0x0160)
582#define EDMAMUX_GENERATOR2_BASE (EDMA_BASE + 0x0164)
583#define EDMAMUX_GENERATOR3_BASE (EDMA_BASE + 0x0168)
584#define EDMAMUX_GENERATOR4_BASE (EDMA_BASE + 0x016C)
585
586#define FLASH_REG_BASE (AHBPERIPH1_BASE + 0x3C00)
587#define CRM_BASE (AHBPERIPH1_BASE + 0x3800)
588#define CRC_BASE (AHBPERIPH1_BASE + 0x3000)
589#define SDIO2_BASE (AHBPERIPH2_BASE + 0x61000)
590#define DVP_BASE (AHBPERIPH2_BASE + 0x50000)
591#define OTGFS1_BASE (AHBPERIPH2_BASE + 0x00000)
592#endif
593
594#if defined (AT32F437xx)
595/* apb1 bus base address */
596#define UART8_BASE (APB1PERIPH_BASE + 0x7C00)
597#define UART7_BASE (APB1PERIPH_BASE + 0x7800)
598#define DAC_BASE (APB1PERIPH_BASE + 0x7400)
599#define PWC_BASE (APB1PERIPH_BASE + 0x7000)
600#define CAN2_BASE (APB1PERIPH_BASE + 0x6800)
601#define CAN1_BASE (APB1PERIPH_BASE + 0x6400)
602#define I2C3_BASE (APB1PERIPH_BASE + 0x5C00)
603#define I2C2_BASE (APB1PERIPH_BASE + 0x5800)
604#define I2C1_BASE (APB1PERIPH_BASE + 0x5400)
605#define UART5_BASE (APB1PERIPH_BASE + 0x5000)
606#define UART4_BASE (APB1PERIPH_BASE + 0x4C00)
607#define USART3_BASE (APB1PERIPH_BASE + 0x4800)
608#define USART2_BASE (APB1PERIPH_BASE + 0x4400)
609#define SPI3_BASE (APB1PERIPH_BASE + 0x3C00)
610#define SPI2_BASE (APB1PERIPH_BASE + 0x3800)
611#define WDT_BASE (APB1PERIPH_BASE + 0x3000)
612#define WWDT_BASE (APB1PERIPH_BASE + 0x2C00)
613#define ERTC_BASE (APB1PERIPH_BASE + 0x2800)
614#define TMR14_BASE (APB1PERIPH_BASE + 0x2000)
615#define TMR13_BASE (APB1PERIPH_BASE + 0x1C00)
616#define TMR12_BASE (APB1PERIPH_BASE + 0x1800)
617#define TMR7_BASE (APB1PERIPH_BASE + 0x1400)
618#define TMR6_BASE (APB1PERIPH_BASE + 0x1000)
619#define TMR5_BASE (APB1PERIPH_BASE + 0x0C00)
620#define TMR4_BASE (APB1PERIPH_BASE + 0x0800)
621#define TMR3_BASE (APB1PERIPH_BASE + 0x0400)
622#define TMR2_BASE (APB1PERIPH_BASE + 0x0000)
623/* apb2 bus base address */
624#define I2S2EXT_BASE (APB2PERIPH_BASE + 0x7800)
625#define I2S3EXT_BASE (APB2PERIPH_BASE + 0x7C00)
626#define ACC_BASE (APB2PERIPH_BASE + 0x7400)
627#define TMR20_BASE (APB2PERIPH_BASE + 0x4C00)
628#define TMR11_BASE (APB2PERIPH_BASE + 0x4800)
629#define TMR10_BASE (APB2PERIPH_BASE + 0x4400)
630#define TMR9_BASE (APB2PERIPH_BASE + 0x4000)
631#define EXINT_BASE (APB2PERIPH_BASE + 0x3C00)
632#define SCFG_BASE (APB2PERIPH_BASE + 0x3800)
633#define SPI4_BASE (APB2PERIPH_BASE + 0x3400)
634#define SPI1_BASE (APB2PERIPH_BASE + 0x3000)
635#define ADC1_BASE (APB2PERIPH_BASE + 0x2000)
636#define ADC2_BASE (APB2PERIPH_BASE + 0x2100)
637#define ADC3_BASE (APB2PERIPH_BASE + 0x2200)
638#define ADCCOM_BASE (APB2PERIPH_BASE + 0x2300)
639#define USART6_BASE (APB2PERIPH_BASE + 0x1400)
640#define USART1_BASE (APB2PERIPH_BASE + 0x1000)
641#define TMR8_BASE (APB2PERIPH_BASE + 0x0400)
642#define TMR1_BASE (APB2PERIPH_BASE + 0x0000)
643/* ahb bus base address */
644#define OTGFS2_BASE (AHBPERIPH1_BASE + 0x20000)
645#define SDIO1_BASE (AHBPERIPH1_BASE + 0xC400)
646#define EMAC_BASE (AHBPERIPH1_BASE + 0x8000)
647#define GPIOH_BASE (AHBPERIPH1_BASE + 0x1C00)
648#define GPIOG_BASE (AHBPERIPH1_BASE + 0x1800)
649#define GPIOF_BASE (AHBPERIPH1_BASE + 0x1400)
650#define GPIOE_BASE (AHBPERIPH1_BASE + 0x1000)
651#define GPIOD_BASE (AHBPERIPH1_BASE + 0x0C00)
652#define GPIOC_BASE (AHBPERIPH1_BASE + 0x0800)
653#define GPIOB_BASE (AHBPERIPH1_BASE + 0x0400)
654#define GPIOA_BASE (AHBPERIPH1_BASE + 0x0000)
655
656#define DMA1_BASE (AHBPERIPH1_BASE + 0x6400)
657#define DMA1_CHANNEL1_BASE (DMA1_BASE + 0x0008)
658#define DMA1_CHANNEL2_BASE (DMA1_BASE + 0x001C)
659#define DMA1_CHANNEL3_BASE (DMA1_BASE + 0x0030)
660#define DMA1_CHANNEL4_BASE (DMA1_BASE + 0x0044)
661#define DMA1_CHANNEL5_BASE (DMA1_BASE + 0x0058)
662#define DMA1_CHANNEL6_BASE (DMA1_BASE + 0x006C)
663#define DMA1_CHANNEL7_BASE (DMA1_BASE + 0x0080)
664
665#define DMA1MUX_BASE (DMA1_BASE + 0x0104)
666#define DMA1MUX_CHANNEL1_BASE (DMA1MUX_BASE)
667#define DMA1MUX_CHANNEL2_BASE (DMA1MUX_BASE + 0x0004)
668#define DMA1MUX_CHANNEL3_BASE (DMA1MUX_BASE + 0x0008)
669#define DMA1MUX_CHANNEL4_BASE (DMA1MUX_BASE + 0x000C)
670#define DMA1MUX_CHANNEL5_BASE (DMA1MUX_BASE + 0x0010)
671#define DMA1MUX_CHANNEL6_BASE (DMA1MUX_BASE + 0x0014)
672#define DMA1MUX_CHANNEL7_BASE (DMA1MUX_BASE + 0x0018)
673
674#define DMA1MUX_GENERATOR1_BASE (DMA1_BASE + 0x0120)
675#define DMA1MUX_GENERATOR2_BASE (DMA1_BASE + 0x0124)
676#define DMA1MUX_GENERATOR3_BASE (DMA1_BASE + 0x0128)
677#define DMA1MUX_GENERATOR4_BASE (DMA1_BASE + 0x012C)
678
679#define DMA2_BASE (AHBPERIPH1_BASE + 0x6600)
680#define DMA2_CHANNEL1_BASE (DMA2_BASE + 0x0008)
681#define DMA2_CHANNEL2_BASE (DMA2_BASE + 0x001C)
682#define DMA2_CHANNEL3_BASE (DMA2_BASE + 0x0030)
683#define DMA2_CHANNEL4_BASE (DMA2_BASE + 0x0044)
684#define DMA2_CHANNEL5_BASE (DMA2_BASE + 0x0058)
685#define DMA2_CHANNEL6_BASE (DMA2_BASE + 0x006C)
686#define DMA2_CHANNEL7_BASE (DMA2_BASE + 0x0080)
687
688#define DMA2MUX_BASE (DMA2_BASE + 0x0104)
689#define DMA2MUX_CHANNEL1_BASE (DMA2MUX_BASE)
690#define DMA2MUX_CHANNEL2_BASE (DMA2MUX_BASE + 0x0004)
691#define DMA2MUX_CHANNEL3_BASE (DMA2MUX_BASE + 0x0008)
692#define DMA2MUX_CHANNEL4_BASE (DMA2MUX_BASE + 0x000C)
693#define DMA2MUX_CHANNEL5_BASE (DMA2MUX_BASE + 0x0010)
694#define DMA2MUX_CHANNEL6_BASE (DMA2MUX_BASE + 0x0014)
695#define DMA2MUX_CHANNEL7_BASE (DMA2MUX_BASE + 0x0018)
696
697#define DMA2MUX_GENERATOR1_BASE (DMA2_BASE + 0x0120)
698#define DMA2MUX_GENERATOR2_BASE (DMA2_BASE + 0x0124)
699#define DMA2MUX_GENERATOR3_BASE (DMA2_BASE + 0x0128)
700#define DMA2MUX_GENERATOR4_BASE (DMA2_BASE + 0x012C)
701
702#define EDMA_BASE (AHBPERIPH1_BASE + 0x6000)
703#define EDMA_STREAM1_BASE (EDMA_BASE + 0x0010)
704#define EDMA_STREAM2_BASE (EDMA_BASE + 0x0028)
705#define EDMA_STREAM3_BASE (EDMA_BASE + 0x0040)
706#define EDMA_STREAM4_BASE (EDMA_BASE + 0x0058)
707#define EDMA_STREAM5_BASE (EDMA_BASE + 0x0070)
708#define EDMA_STREAM6_BASE (EDMA_BASE + 0x0088)
709#define EDMA_STREAM7_BASE (EDMA_BASE + 0x00A0)
710#define EDMA_STREAM8_BASE (EDMA_BASE + 0x00B8)
711
712#define EDMA_2D_BASE (EDMA_BASE + 0x00F4)
713#define EDMA_STREAM1_2D_BASE (EDMA_2D_BASE + 0x0004)
714#define EDMA_STREAM2_2D_BASE (EDMA_2D_BASE + 0x000C)
715#define EDMA_STREAM3_2D_BASE (EDMA_2D_BASE + 0x0014)
716#define EDMA_STREAM4_2D_BASE (EDMA_2D_BASE + 0x001C)
717#define EDMA_STREAM5_2D_BASE (EDMA_2D_BASE + 0x0024)
718#define EDMA_STREAM6_2D_BASE (EDMA_2D_BASE + 0x002C)
719#define EDMA_STREAM7_2D_BASE (EDMA_2D_BASE + 0x0034)
720#define EDMA_STREAM8_2D_BASE (EDMA_2D_BASE + 0x003C)
721
722#define EDMA_LL_BASE (EDMA_BASE + 0x00D0)
723#define EDMA_STREAM1_LL_BASE (EDMA_LL_BASE + 0x0004)
724#define EDMA_STREAM2_LL_BASE (EDMA_LL_BASE + 0x0008)
725#define EDMA_STREAM3_LL_BASE (EDMA_LL_BASE + 0x000C)
726#define EDMA_STREAM4_LL_BASE (EDMA_LL_BASE + 0x0010)
727#define EDMA_STREAM5_LL_BASE (EDMA_LL_BASE + 0x0014)
728#define EDMA_STREAM6_LL_BASE (EDMA_LL_BASE + 0x0018)
729#define EDMA_STREAM7_LL_BASE (EDMA_LL_BASE + 0x001C)
730#define EDMA_STREAM8_LL_BASE (EDMA_LL_BASE + 0x0020)
731
732#define EDMAMUX_BASE (EDMA_BASE + 0x0140)
733#define EDMAMUX_CHANNEL1_BASE (EDMAMUX_BASE)
734#define EDMAMUX_CHANNEL2_BASE (EDMAMUX_BASE + 0x0004)
735#define EDMAMUX_CHANNEL3_BASE (EDMAMUX_BASE + 0x0008)
736#define EDMAMUX_CHANNEL4_BASE (EDMAMUX_BASE + 0x000C)
737#define EDMAMUX_CHANNEL5_BASE (EDMAMUX_BASE + 0x0010)
738#define EDMAMUX_CHANNEL6_BASE (EDMAMUX_BASE + 0x0014)
739#define EDMAMUX_CHANNEL7_BASE (EDMAMUX_BASE + 0x0018)
740#define EDMAMUX_CHANNEL8_BASE (EDMAMUX_BASE + 0x001C)
741
742#define EDMAMUX_GENERATOR1_BASE (EDMA_BASE + 0x0160)
743#define EDMAMUX_GENERATOR2_BASE (EDMA_BASE + 0x0164)
744#define EDMAMUX_GENERATOR3_BASE (EDMA_BASE + 0x0168)
745#define EDMAMUX_GENERATOR4_BASE (EDMA_BASE + 0x016C)
746
747#define FLASH_REG_BASE (AHBPERIPH1_BASE + 0x3C00)
748#define CRM_BASE (AHBPERIPH1_BASE + 0x3800)
749#define CRC_BASE (AHBPERIPH1_BASE + 0x3000)
750#define SDIO2_BASE (AHBPERIPH2_BASE + 0x61000)
751#define DVP_BASE (AHBPERIPH2_BASE + 0x50000)
752#define OTGFS1_BASE (AHBPERIPH2_BASE + 0x00000)
753
754#define EMAC_MAC_BASE (EMAC_BASE)
755#define EMAC_MMC_BASE (EMAC_BASE + 0x0100)
756#define EMAC_PTP_BASE (EMAC_BASE + 0x0700)
757#define EMAC_DMA_BASE (EMAC_BASE + 0x1000)
758#endif
759
772#include "at32f435_437_def.h"
773#include "at32f435_437_conf.h"
774
775#ifdef __cplusplus
776}
777#endif
778
779#endif
at32f435_437_def.h
at32f435_437 macros header file
vu32
__IO uint32_t vu32
Definition: at32f435_437.h:370
INT8
int8_t INT8
Definition: at32f435_437.h:341
vs16
__IO int16_t vs16
Definition: at32f435_437.h:355
error_status
error_status
Definition: at32f435_437.h:380
INT32
int32_t INT32
Definition: at32f435_437.h:339
vuc32
__I uint32_t vuc32
Definition: at32f435_437.h:374
sc8
const int8_t sc8
Definition: at32f435_437.h:352
vsc16
__I int16_t vsc16
Definition: at32f435_437.h:359
confirm_state
confirm_state
Definition: at32f435_437.h:379
vsc8
__I int8_t vsc8
Definition: at32f435_437.h:360
vs32
__IO int32_t vs32
Definition: at32f435_437.h:354
vu8
__IO uint8_t vu8
Definition: at32f435_437.h:372
uc32
const uint32_t uc32
Definition: at32f435_437.h:366
sc16
const int16_t sc16
Definition: at32f435_437.h:351
vuc16
__I uint16_t vuc16
Definition: at32f435_437.h:375
flag_status
flag_status
Definition: at32f435_437.h:378
u8
uint8_t u8
Definition: at32f435_437.h:364
vu16
__IO uint16_t vu16
Definition: at32f435_437.h:371
s8
int8_t s8
Definition: at32f435_437.h:348
vs8
__IO int8_t vs8
Definition: at32f435_437.h:356
s16
int16_t s16
Definition: at32f435_437.h:347
vuc8
__I uint8_t vuc8
Definition: at32f435_437.h:376
uc16
const uint16_t uc16
Definition: at32f435_437.h:367
uc8
const uint8_t uc8
Definition: at32f435_437.h:368
INT16
int16_t INT16
Definition: at32f435_437.h:340
UINT16
uint16_t UINT16
Definition: at32f435_437.h:343
u16
uint16_t u16
Definition: at32f435_437.h:363
sc32
const int32_t sc32
Definition: at32f435_437.h:350
UINT32
uint32_t UINT32
Definition: at32f435_437.h:342
s32
int32_t s32
Definition: at32f435_437.h:346
vsc32
__I int32_t vsc32
Definition: at32f435_437.h:358
UINT8
uint8_t UINT8
Definition: at32f435_437.h:344
u32
uint32_t u32
Definition: at32f435_437.h:362
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
IRQn_Type
enum IRQn IRQn_Type
at32f435_437 interrupt number definition, according to the selected device in library_configuration_s...
IRQn
IRQn
at32f435_437 interrupt number definition, according to the selected device in library_configuration_s...
Definition: at32f435_437.h:132
PendSV_IRQn
@ PendSV_IRQn
Definition: at32f435_437.h:142
DMA2_Channel4_IRQn
@ DMA2_Channel4_IRQn
Definition: at32f435_437.h:238
TMR6_DAC_GLOBAL_IRQn
@ TMR6_DAC_GLOBAL_IRQn
Definition: at32f435_437.h:202
TMR1_BRK_TMR9_IRQn
@ TMR1_BRK_TMR9_IRQn
Definition: at32f435_437.h:172
EDMA_Stream1_IRQn
@ EDMA_Stream1_IRQn
Definition: at32f435_437.h:157
DMA1_Channel2_IRQn
@ DMA1_Channel2_IRQn
Definition: at32f435_437.h:205
EDMA_Stream5_IRQn
@ EDMA_Stream5_IRQn
Definition: at32f435_437.h:161
TMR8_TRG_HALL_TMR14_IRQn
@ TMR8_TRG_HALL_TMR14_IRQn
Definition: at32f435_437.h:193
TMR1_OVF_TMR10_IRQn
@ TMR1_OVF_TMR10_IRQn
Definition: at32f435_437.h:173
XMC_IRQn
@ XMC_IRQn
Definition: at32f435_437.h:196
UART7_IRQn
@ UART7_IRQn
Definition: at32f435_437.h:223
OTGFS1_WKUP_IRQn
@ OTGFS1_WKUP_IRQn
Definition: at32f435_437.h:190
TMR8_CH_IRQn
@ TMR8_CH_IRQn
Definition: at32f435_437.h:194
ERTC_WKUP_IRQn
@ ERTC_WKUP_IRQn
Definition: at32f435_437.h:149
MemoryManagement_IRQn
@ MemoryManagement_IRQn
Definition: at32f435_437.h:137
OTGFS2_IRQn
@ OTGFS2_IRQn
Definition: at32f435_437.h:220
QSPI1_IRQn
@ QSPI1_IRQn
Definition: at32f435_437.h:227
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f435_437.h:204
DMA1_Channel3_IRQn
@ DMA1_Channel3_IRQn
Definition: at32f435_437.h:206
SDIO2_IRQn
@ SDIO2_IRQn
Definition: at32f435_437.h:229
TMR8_OVF_TMR13_IRQn
@ TMR8_OVF_TMR13_IRQn
Definition: at32f435_437.h:192
USART2_IRQn
@ USART2_IRQn
Definition: at32f435_437.h:186
DMA2_Channel7_IRQn
@ DMA2_Channel7_IRQn
Definition: at32f435_437.h:241
I2C3_ERR_IRQn
@ I2C3_ERR_IRQn
Definition: at32f435_437.h:218
CAN2_SE_IRQn
@ CAN2_SE_IRQn
Definition: at32f435_437.h:212
EDMA_Stream6_IRQn
@ EDMA_Stream6_IRQn
Definition: at32f435_437.h:162
I2C1_ERR_IRQn
@ I2C1_ERR_IRQn
Definition: at32f435_437.h:180
SVCall_IRQn
@ SVCall_IRQn
Definition: at32f435_437.h:140
I2C1_EVT_IRQn
@ I2C1_EVT_IRQn
Definition: at32f435_437.h:179
TMR20_TRG_HALL_IRQn
@ TMR20_TRG_HALL_IRQn
Definition: at32f435_437.h:233
Reset_IRQn
@ Reset_IRQn
Definition: at32f435_437.h:134
ERTCAlarm_IRQn
@ ERTCAlarm_IRQn
Definition: at32f435_437.h:189
DMAMUX_IRQn
@ DMAMUX_IRQn
Definition: at32f435_437.h:228
UART8_IRQn
@ UART8_IRQn
Definition: at32f435_437.h:224
EDMA_Stream2_IRQn
@ EDMA_Stream2_IRQn
Definition: at32f435_437.h:158
TMR8_BRK_TMR12_IRQn
@ TMR8_BRK_TMR12_IRQn
Definition: at32f435_437.h:191
DMA1_Channel7_IRQn
@ DMA1_Channel7_IRQn
Definition: at32f435_437.h:215
UsageFault_IRQn
@ UsageFault_IRQn
Definition: at32f435_437.h:139
SysTick_IRQn
@ SysTick_IRQn
Definition: at32f435_437.h:143
EDMA_Stream3_IRQn
@ EDMA_Stream3_IRQn
Definition: at32f435_437.h:159
ADC1_2_3_IRQn
@ ADC1_2_3_IRQn
Definition: at32f435_437.h:166
EXINT9_5_IRQn
@ EXINT9_5_IRQn
Definition: at32f435_437.h:171
EXINT1_IRQn
@ EXINT1_IRQn
Definition: at32f435_437.h:153
CAN2_RX0_IRQn
@ CAN2_RX0_IRQn
Definition: at32f435_437.h:210
BusFault_IRQn
@ BusFault_IRQn
Definition: at32f435_437.h:138
WWDT_IRQn
@ WWDT_IRQn
Definition: at32f435_437.h:146
DMA2_Channel6_IRQn
@ DMA2_Channel6_IRQn
Definition: at32f435_437.h:240
TMR4_GLOBAL_IRQn
@ TMR4_GLOBAL_IRQn
Definition: at32f435_437.h:178
DebugMonitor_IRQn
@ DebugMonitor_IRQn
Definition: at32f435_437.h:141
EXINT0_IRQn
@ EXINT0_IRQn
Definition: at32f435_437.h:152
FLASH_IRQn
@ FLASH_IRQn
Definition: at32f435_437.h:150
CRM_IRQn
@ CRM_IRQn
Definition: at32f435_437.h:151
PVM_IRQn
@ PVM_IRQn
Definition: at32f435_437.h:147
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f435_437.h:177
QSPI2_IRQn
@ QSPI2_IRQn
Definition: at32f435_437.h:226
SDIO1_IRQn
@ SDIO1_IRQn
Definition: at32f435_437.h:197
TMR5_GLOBAL_IRQn
@ TMR5_GLOBAL_IRQn
Definition: at32f435_437.h:198
CAN1_TX_IRQn
@ CAN1_TX_IRQn
Definition: at32f435_437.h:167
EXINT3_IRQn
@ EXINT3_IRQn
Definition: at32f435_437.h:155
SPI4_IRQn
@ SPI4_IRQn
Definition: at32f435_437.h:225
DVP_IRQn
@ DVP_IRQn
Definition: at32f435_437.h:221
FPU_IRQn
@ FPU_IRQn
Definition: at32f435_437.h:222
USART6_IRQn
@ USART6_IRQn
Definition: at32f435_437.h:216
DMA1_Channel6_IRQn
@ DMA1_Channel6_IRQn
Definition: at32f435_437.h:214
SPI1_IRQn
@ SPI1_IRQn
Definition: at32f435_437.h:183
HardFault_IRQn
@ HardFault_IRQn
Definition: at32f435_437.h:136
OTGFS1_IRQn
@ OTGFS1_IRQn
Definition: at32f435_437.h:213
CAN2_RX1_IRQn
@ CAN2_RX1_IRQn
Definition: at32f435_437.h:211
CAN1_RX0_IRQn
@ CAN1_RX0_IRQn
Definition: at32f435_437.h:168
TMR7_GLOBAL_IRQn
@ TMR7_GLOBAL_IRQn
Definition: at32f435_437.h:203
EDMA_Stream8_IRQn
@ EDMA_Stream8_IRQn
Definition: at32f435_437.h:195
EXINT15_10_IRQn
@ EXINT15_10_IRQn
Definition: at32f435_437.h:188
DMA2_Channel1_IRQn
@ DMA2_Channel1_IRQn
Definition: at32f435_437.h:235
DMA1_Channel5_IRQn
@ DMA1_Channel5_IRQn
Definition: at32f435_437.h:208
TAMP_STAMP_IRQn
@ TAMP_STAMP_IRQn
Definition: at32f435_437.h:148
DMA2_Channel5_IRQn
@ DMA2_Channel5_IRQn
Definition: at32f435_437.h:239
UART5_IRQn
@ UART5_IRQn
Definition: at32f435_437.h:201
DMA2_Channel2_IRQn
@ DMA2_Channel2_IRQn
Definition: at32f435_437.h:236
OTGFS2_WKUP_IRQn
@ OTGFS2_WKUP_IRQn
Definition: at32f435_437.h:219
SPI2_I2S2EXT_IRQn
@ SPI2_I2S2EXT_IRQn
Definition: at32f435_437.h:184
TMR1_TRG_HALL_TMR11_IRQn
@ TMR1_TRG_HALL_TMR11_IRQn
Definition: at32f435_437.h:174
TMR1_CH_IRQn
@ TMR1_CH_IRQn
Definition: at32f435_437.h:175
EXINT4_IRQn
@ EXINT4_IRQn
Definition: at32f435_437.h:156
TMR20_OVF_IRQn
@ TMR20_OVF_IRQn
Definition: at32f435_437.h:232
I2C2_ERR_IRQn
@ I2C2_ERR_IRQn
Definition: at32f435_437.h:182
USART1_IRQn
@ USART1_IRQn
Definition: at32f435_437.h:185
DMA2_Channel3_IRQn
@ DMA2_Channel3_IRQn
Definition: at32f435_437.h:237
TMR20_CH_IRQn
@ TMR20_CH_IRQn
Definition: at32f435_437.h:234
CAN1_SE_IRQn
@ CAN1_SE_IRQn
Definition: at32f435_437.h:170
TMR20_BRK_IRQn
@ TMR20_BRK_IRQn
Definition: at32f435_437.h:231
NonMaskableInt_IRQn
@ NonMaskableInt_IRQn
Definition: at32f435_437.h:135
SPI3_I2S3EXT_IRQn
@ SPI3_I2S3EXT_IRQn
Definition: at32f435_437.h:199
UART4_IRQn
@ UART4_IRQn
Definition: at32f435_437.h:200
DMA1_Channel4_IRQn
@ DMA1_Channel4_IRQn
Definition: at32f435_437.h:207
EXINT2_IRQn
@ EXINT2_IRQn
Definition: at32f435_437.h:154
I2C2_EVT_IRQn
@ I2C2_EVT_IRQn
Definition: at32f435_437.h:181
ACC_IRQn
@ ACC_IRQn
Definition: at32f435_437.h:230
EDMA_Stream7_IRQn
@ EDMA_Stream7_IRQn
Definition: at32f435_437.h:163
CAN2_TX_IRQn
@ CAN2_TX_IRQn
Definition: at32f435_437.h:209
CAN1_RX1_IRQn
@ CAN1_RX1_IRQn
Definition: at32f435_437.h:169
EDMA_Stream4_IRQn
@ EDMA_Stream4_IRQn
Definition: at32f435_437.h:160
TMR2_GLOBAL_IRQn
@ TMR2_GLOBAL_IRQn
Definition: at32f435_437.h:176
USART3_IRQn
@ USART3_IRQn
Definition: at32f435_437.h:187
I2C3_EVT_IRQn
@ I2C3_EVT_IRQn
Definition: at32f435_437.h:217
system_at32f435_437.h
cmsis cortex-m4 system header file.
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_acc.c Source File

  • libraries
  • drivers
  • src
at32f435_437_acc.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef ACC_MODULE_ENABLED
39
53void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
54{
55 if(acc_trim == ACC_CAL_HICKCAL)
56 {
57 ACC->ctrl1_bit.entrim = FALSE;
58 }
59 else
60 {
61 ACC->ctrl1_bit.entrim = TRUE;
62 }
63 ACC->ctrl1_bit.calon = new_state;
64}
65
71void acc_step_set(uint8_t step_value)
72{
73 ACC->ctrl1_bit.step = step_value;
74}
75
84void acc_sof_select(uint16_t sof_sel)
85{
86 ACC->ctrl1 |= sof_sel;
87}
88
98void acc_interrupt_enable(uint16_t acc_int, confirm_state new_state)
99{
100 if(acc_int == ACC_CALRDYIEN_INT)
101 {
102 ACC->ctrl1_bit.calrdyien = new_state;
103 }
104 else
105 {
106 ACC->ctrl1_bit.eien = new_state;
107 }
108}
109
115uint8_t acc_hicktrim_get(void)
116{
117 return ((uint8_t)(ACC->ctrl2_bit.hicktrim));
118}
119
125uint8_t acc_hickcal_get(void)
126{
127 return ((uint8_t)(ACC->ctrl2_bit.hickcal));
128}
129
135void acc_write_c1(uint16_t acc_c1_value)
136{
137 ACC->c1 = acc_c1_value;
138}
139
145void acc_write_c2(uint16_t acc_c2_value)
146{
147 ACC->c2 = acc_c2_value;
148}
149
155void acc_write_c3(uint16_t acc_c3_value)
156{
157 ACC->c3 = acc_c3_value;
158}
159
165uint16_t acc_read_c1(void)
166{
167 return ((uint16_t)(ACC->c1));
168}
169
175uint16_t acc_read_c2(void)
176{
177 return ((uint16_t)(ACC->c2));
178}
179
185uint16_t acc_read_c3(void)
186{
187 return ((uint16_t)(ACC->c3));
188}
189
198 flag_status acc_flag_get(uint16_t acc_flag)
199{
200 if(acc_flag == ACC_CALRDY_FLAG)
201 return (flag_status)(ACC->sts_bit.calrdy);
202 else
203 return (flag_status)(ACC->sts_bit.rslost);
204}
205
214void acc_flag_clear(uint16_t acc_flag)
215{
216 ACC->sts = ~acc_flag;
217}
218
223#endif
224
acc_c2_value
uint32_t acc_c2_value
Definition: project/at_start_f435/examples/acc/calibration/src/main.c:55
ACC_CAL_HICKCAL
#define ACC_CAL_HICKCAL
Definition: at32f435_437_acc.h:51
ACC_CALRDYIEN_INT
#define ACC_CALRDYIEN_INT
Definition: at32f435_437_acc.h:57
ACC_CALRDY_FLAG
#define ACC_CALRDY_FLAG
Definition: at32f435_437_acc.h:55
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f435_437_acc.c:145
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f435_437_acc.c:155
acc_step_set
void acc_step_set(uint8_t step_value)
store calibration step data in acc's ctrl1 register.
Definition: at32f435_437_acc.c:71
acc_read_c2
uint16_t acc_read_c2(void)
return the current acc c2 value.
Definition: at32f435_437_acc.c:175
acc_hickcal_get
uint8_t acc_hickcal_get(void)
return the current acc hickcal value.
Definition: at32f435_437_acc.c:125
acc_interrupt_enable
void acc_interrupt_enable(uint16_t acc_int, confirm_state new_state)
enable or disable the specified acc interrupts.
Definition: at32f435_437_acc.c:98
acc_read_c3
uint16_t acc_read_c3(void)
return the current acc c3 value.
Definition: at32f435_437_acc.c:185
acc_read_c1
uint16_t acc_read_c1(void)
return the current acc c1 value.
Definition: at32f435_437_acc.c:165
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f435_437_acc.c:135
acc_flag_get
flag_status acc_flag_get(uint16_t acc_flag)
check whether the specified acc flag is set or not.
Definition: at32f435_437_acc.c:198
acc_sof_select
void acc_sof_select(uint16_t sof_sel)
select sof sourse for acc in acc's ctrl1 register.
Definition: at32f435_437_acc.c:84
acc_flag_clear
void acc_flag_clear(uint16_t acc_flag)
clear the specified acc flag is set or not.
Definition: at32f435_437_acc.c:214
acc_hicktrim_get
uint8_t acc_hicktrim_get(void)
return the current acc hicktrim value.
Definition: at32f435_437_acc.c:115
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f435_437_acc.c:53
ACC
#define ACC
Definition: at32f435_437_acc.h:168
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_acc.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_acc.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_ACC_H
29#define __AT32F435_437_ACC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
51#define ACC_CAL_HICKCAL ((uint16_t)0x0000)
52#define ACC_CAL_HICKTRIM ((uint16_t)0x0002)
54#define ACC_RSLOST_FLAG ((uint16_t)0x0002)
55#define ACC_CALRDY_FLAG ((uint16_t)0x0001)
57#define ACC_CALRDYIEN_INT ((uint16_t)0x0020)
58#define ACC_EIEN_INT ((uint16_t)0x0010)
60#define ACC_SOF_OTG1 ((uint16_t)0x0000)
61#define ACC_SOF_OTG2 ((uint16_t)0x0004)
74typedef struct
75{
76
80 union
81 {
82 __IO uint32_t sts;
83 struct
84 {
85 __IO uint32_t calrdy : 1; /* [0] */
86 __IO uint32_t rslost : 1; /* [1] */
87 __IO uint32_t reserved1 : 30;/* [31:2] */
88 } sts_bit;
89 };
90
94 union
95 {
96 __IO uint32_t ctrl1;
97 struct
98 {
99 __IO uint32_t calon : 1; /* [0] */
100 __IO uint32_t entrim : 1; /* [1] */
101 __IO uint32_t reserved1 : 2; /* [3:2] */
102 __IO uint32_t eien : 1; /* [4] */
103 __IO uint32_t calrdyien : 1; /* [5] */
104 __IO uint32_t reserved2 : 2; /* [7:6] */
105 __IO uint32_t step : 4; /* [11:8] */
106 __IO uint32_t reserved3 : 20;/* [31:12] */
107 } ctrl1_bit;
108 };
109
113 union
114 {
115 __IO uint32_t ctrl2;
116 struct
117 {
118 __IO uint32_t hickcal : 8; /* [7:0] */
119 __IO uint32_t hicktrim : 6; /* [13:8] */
120 __IO uint32_t reserved1 : 18;/* [31:14] */
121 } ctrl2_bit;
122 };
123
127 union
128 {
129 __IO uint32_t c1;
130 struct
131 {
132 __IO uint32_t c1 : 16;/* [15:0] */
133 __IO uint32_t reserved1 : 16;/* [31:16] */
134 } c1_bit;
135 };
136
140 union
141 {
142 __IO uint32_t c2;
143 struct
144 {
145 __IO uint32_t c2 : 16;/* [15:0] */
146 __IO uint32_t reserved1 : 16;/* [31:16] */
147 } c2_bit;
148 };
149
153 union
154 {
155 __IO uint32_t c3;
156 struct
157 {
158 __IO uint32_t c3 : 16;/* [15:0] */
159 __IO uint32_t reserved1 : 16;/* [31:16] */
160 } c3_bit;
161 };
162} acc_type;
163
168#define ACC ((acc_type *) ACC_BASE)
169
174void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state);
175void acc_step_set(uint8_t step_value);
176void acc_sof_select(uint16_t sof_sel);
177void acc_interrupt_enable(uint16_t acc_int, confirm_state new_state);
178uint8_t acc_hicktrim_get(void);
179uint8_t acc_hickcal_get(void);
180void acc_write_c1(uint16_t acc_c1_value);
181void acc_write_c2(uint16_t acc_c2_value);
182void acc_write_c3(uint16_t acc_c3_value);
183uint16_t acc_read_c1(void);
184uint16_t acc_read_c2(void);
185uint16_t acc_read_c3(void);
186 flag_status acc_flag_get(uint16_t acc_flag);
187void acc_flag_clear(uint16_t acc_flag);
188
201#ifdef __cplusplus
202}
203#endif
204
205#endif
at32f435_437.h
at32f435_437 header file
acc_c2_value
uint32_t acc_c2_value
Definition: project/at_start_f435/examples/acc/calibration/src/main.c:55
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f435_437_acc.c:145
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f435_437_acc.c:155
acc_step_set
void acc_step_set(uint8_t step_value)
store calibration step data in acc's ctrl1 register.
Definition: at32f435_437_acc.c:71
acc_read_c2
uint16_t acc_read_c2(void)
return the current acc c2 value.
Definition: at32f435_437_acc.c:175
acc_hickcal_get
uint8_t acc_hickcal_get(void)
return the current acc hickcal value.
Definition: at32f435_437_acc.c:125
acc_interrupt_enable
void acc_interrupt_enable(uint16_t acc_int, confirm_state new_state)
enable or disable the specified acc interrupts.
Definition: at32f435_437_acc.c:98
acc_read_c3
uint16_t acc_read_c3(void)
return the current acc c3 value.
Definition: at32f435_437_acc.c:185
acc_read_c1
uint16_t acc_read_c1(void)
return the current acc c1 value.
Definition: at32f435_437_acc.c:165
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f435_437_acc.c:135
acc_flag_get
flag_status acc_flag_get(uint16_t acc_flag)
check whether the specified acc flag is set or not.
Definition: at32f435_437_acc.c:198
acc_sof_select
void acc_sof_select(uint16_t sof_sel)
select sof sourse for acc in acc's ctrl1 register.
Definition: at32f435_437_acc.c:84
acc_flag_clear
void acc_flag_clear(uint16_t acc_flag)
clear the specified acc flag is set or not.
Definition: at32f435_437_acc.c:214
acc_hicktrim_get
uint8_t acc_hicktrim_get(void)
return the current acc hicktrim value.
Definition: at32f435_437_acc.c:115
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f435_437_acc.c:53
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
acc_type
type define acc register all
Definition: at32f435_437_acc.h:75
acc_type::entrim
__IO uint32_t entrim
Definition: at32f435_437_acc.h:100
acc_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f435_437_acc.h:96
acc_type::hicktrim
__IO uint32_t hicktrim
Definition: at32f435_437_acc.h:119
acc_type::c2
__IO uint32_t c2
Definition: at32f435_437_acc.h:142
acc_type::rslost
__IO uint32_t rslost
Definition: at32f435_437_acc.h:86
acc_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_acc.h:104
acc_type::c3
__IO uint32_t c3
Definition: at32f435_437_acc.h:155
acc_type::calrdyien
__IO uint32_t calrdyien
Definition: at32f435_437_acc.h:103
acc_type::calon
__IO uint32_t calon
Definition: at32f435_437_acc.h:99
acc_type::eien
__IO uint32_t eien
Definition: at32f435_437_acc.h:102
acc_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_acc.h:87
acc_type::sts
__IO uint32_t sts
Definition: at32f435_437_acc.h:82
acc_type::hickcal
__IO uint32_t hickcal
Definition: at32f435_437_acc.h:118
acc_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f435_437_acc.h:115
acc_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_acc.h:106
acc_type::c1
__IO uint32_t c1
Definition: at32f435_437_acc.h:129
acc_type::calrdy
__IO uint32_t calrdy
Definition: at32f435_437_acc.h:85
acc_type::step
__IO uint32_t step
Definition: at32f435_437_acc.h:105


AT32F435/437 Firmwary Library: at32f435_437_adc.c Source File

  • libraries
  • drivers
  • src
at32f435_437_adc.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef ADC_MODULE_ENABLED
39
49void adc_reset(void)
50{
51 crm_periph_reset(CRM_ADC_PERIPH_RESET, TRUE);
52 crm_periph_reset(CRM_ADC_PERIPH_RESET, FALSE);
53}
54
64void adc_enable(adc_type *adc_x, confirm_state new_state)
65{
66 adc_x->ctrl2_bit.adcen = new_state;
67}
68
84void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
85{
86 adc_base_struct->sequence_mode = FALSE;
87 adc_base_struct->repeat_mode = FALSE;
88 adc_base_struct->data_align = ADC_RIGHT_ALIGNMENT;
89 adc_base_struct->ordinary_channel_length = 1;
90}
91
110void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
111{
112 adc_x->ctrl1_bit.sqen = adc_base_struct->sequence_mode;
113 adc_x->ctrl2_bit.rpen = adc_base_struct->repeat_mode;
114 adc_x->ctrl2_bit.dtalign = adc_base_struct->data_align;
115 adc_x->osq1_bit.oclen = adc_base_struct->ordinary_channel_length - 1;
116}
117
155void adc_common_default_para_init(adc_common_config_type *adc_common_struct)
156{
157 adc_common_struct->combine_mode = ADC_INDEPENDENT_MODE;
158 adc_common_struct->div = ADC_HCLK_DIV_2;
159 adc_common_struct->common_dma_mode = ADC_COMMON_DMAMODE_DISABLE;
160 adc_common_struct->common_dma_request_repeat_state = FALSE;
161 adc_common_struct->sampling_interval = ADC_SAMPLING_INTERVAL_5CYCLES;
162 adc_common_struct->tempervintrv_state = FALSE;
163 adc_common_struct->vbat_state = FALSE;
164}
165
203void adc_common_config(adc_common_config_type *adc_common_struct)
204{
205 ADCCOM->cctrl_bit.mssel = adc_common_struct->combine_mode;
206 ADCCOM->cctrl_bit.adcdiv = adc_common_struct->div;
207 if(adc_common_struct->common_dma_mode & 0x04)
208 {
209 ADCCOM->cctrl_bit.msdmasel_h = TRUE;
210 }
211 else
212 {
213 ADCCOM->cctrl_bit.msdmasel_h = FALSE;
214 }
215 ADCCOM->cctrl_bit.msdmasel_l = adc_common_struct->common_dma_mode &0x03;
216 ADCCOM->cctrl_bit.msdrcen = adc_common_struct->common_dma_request_repeat_state;
217 ADCCOM->cctrl_bit.asisel = adc_common_struct->sampling_interval;
218 ADCCOM->cctrl_bit.itsrven = adc_common_struct->tempervintrv_state;
219 ADCCOM->cctrl_bit.vbaten = adc_common_struct->vbat_state;
220}
221
235void adc_resolution_set(adc_type *adc_x, adc_resolution_type resolution)
236{
237 adc_x->ctrl1_bit.crsel = resolution;
238}
239
246void adc_voltage_battery_enable(confirm_state new_state)
247{
248 ADCCOM->cctrl_bit.vbaten = new_state;
249}
250
260void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
261{
262 adc_x->ctrl2_bit.ocdmaen = new_state;
263}
264
274void adc_dma_request_repeat_enable(adc_type *adc_x, confirm_state new_state)
275{
276 adc_x->ctrl2_bit.ocdrcen = new_state;
277}
278
294void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
295{
296 if(new_state == TRUE)
297 {
298 adc_x->ctrl1 |= adc_int;
299 }
300 else if(new_state == FALSE)
301 {
302 adc_x->ctrl1 &= ~adc_int;
303 }
304}
305
316void adc_calibration_value_set(adc_type *adc_x, uint8_t adc_calibration_value)
317{
318 adc_x->calval = adc_calibration_value;
319}
320
328void adc_calibration_init(adc_type *adc_x)
329{
330 adc_x->ctrl2_bit.adcalinit = TRUE;
331}
332
340 flag_status adc_calibration_init_status_get(adc_type *adc_x)
341{
342 if(adc_x->ctrl2_bit.adcalinit)
343 {
344 return SET;
345 }
346 else
347 {
348 return RESET;
349 }
350}
351
359void adc_calibration_start(adc_type *adc_x)
360{
361 adc_x->ctrl2_bit.adcal = TRUE;
362}
363
371 flag_status adc_calibration_status_get(adc_type *adc_x)
372{
373 if(adc_x->ctrl2_bit.adcal)
374 {
375 return SET;
376 }
377 else
378 {
379 return RESET;
380 }
381}
382
399void adc_voltage_monitor_enable(adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring)
400{
401 adc_x->ctrl1_bit.ocvmen = FALSE;
402 adc_x->ctrl1_bit.pcvmen = FALSE;
403 adc_x->ctrl1_bit.vmsgen = FALSE;
404 adc_x->ctrl1 |= adc_voltage_monitoring;
405}
406
420void adc_voltage_monitor_threshold_value_set(adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold)
421{
422 adc_x->vmhb_bit.vmhb = adc_high_threshold;
423 adc_x->vmlb_bit.vmlb = adc_low_threshold;
424}
425
440void adc_voltage_monitor_single_channel_select(adc_type *adc_x, adc_channel_select_type adc_channel)
441{
442 adc_x->ctrl1_bit.vmcsel = adc_channel;
443}
444
472void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
473{
474 switch(adc_channel)
475 {
476 case ADC_CHANNEL_0:
477 adc_x->spt2_bit.cspt0 = adc_sampletime;
478 break;
479 case ADC_CHANNEL_1:
480 adc_x->spt2_bit.cspt1 = adc_sampletime;
481 break;
482 case ADC_CHANNEL_2:
483 adc_x->spt2_bit.cspt2 = adc_sampletime;
484 break;
485 case ADC_CHANNEL_3:
486 adc_x->spt2_bit.cspt3 = adc_sampletime;
487 break;
488 case ADC_CHANNEL_4:
489 adc_x->spt2_bit.cspt4 = adc_sampletime;
490 break;
491 case ADC_CHANNEL_5:
492 adc_x->spt2_bit.cspt5 = adc_sampletime;
493 break;
494 case ADC_CHANNEL_6:
495 adc_x->spt2_bit.cspt6 = adc_sampletime;
496 break;
497 case ADC_CHANNEL_7:
498 adc_x->spt2_bit.cspt7 = adc_sampletime;
499 break;
500 case ADC_CHANNEL_8:
501 adc_x->spt2_bit.cspt8 = adc_sampletime;
502 break;
503 case ADC_CHANNEL_9:
504 adc_x->spt2_bit.cspt9 = adc_sampletime;
505 break;
506 case ADC_CHANNEL_10:
507 adc_x->spt1_bit.cspt10 = adc_sampletime;
508 break;
509 case ADC_CHANNEL_11:
510 adc_x->spt1_bit.cspt11 = adc_sampletime;
511 break;
512 case ADC_CHANNEL_12:
513 adc_x->spt1_bit.cspt12 = adc_sampletime;
514 break;
515 case ADC_CHANNEL_13:
516 adc_x->spt1_bit.cspt13 = adc_sampletime;
517 break;
518 case ADC_CHANNEL_14:
519 adc_x->spt1_bit.cspt14 = adc_sampletime;
520 break;
521 case ADC_CHANNEL_15:
522 adc_x->spt1_bit.cspt15 = adc_sampletime;
523 break;
524 case ADC_CHANNEL_16:
525 adc_x->spt1_bit.cspt16 = adc_sampletime;
526 break;
527 case ADC_CHANNEL_17:
528 adc_x->spt1_bit.cspt17 = adc_sampletime;
529 break;
530 case ADC_CHANNEL_18:
531 adc_x->spt1_bit.cspt18 = adc_sampletime;
532 break;
533 default:
534 break;
535 }
536 switch(adc_sequence)
537 {
538 case 1:
539 adc_x->osq3_bit.osn1 = adc_channel;
540 break;
541 case 2:
542 adc_x->osq3_bit.osn2 = adc_channel;
543 break;
544 case 3:
545 adc_x->osq3_bit.osn3 = adc_channel;
546 break;
547 case 4:
548 adc_x->osq3_bit.osn4 = adc_channel;
549 break;
550 case 5:
551 adc_x->osq3_bit.osn5 = adc_channel;
552 break;
553 case 6:
554 adc_x->osq3_bit.osn6 = adc_channel;
555 break;
556 case 7:
557 adc_x->osq2_bit.osn7 = adc_channel;
558 break;
559 case 8:
560 adc_x->osq2_bit.osn8 = adc_channel;
561 break;
562 case 9:
563 adc_x->osq2_bit.osn9 = adc_channel;
564 break;
565 case 10:
566 adc_x->osq2_bit.osn10 = adc_channel;
567 break;
568 case 11:
569 adc_x->osq2_bit.osn11 = adc_channel;
570 break;
571 case 12:
572 adc_x->osq2_bit.osn12 = adc_channel;
573 break;
574 case 13:
575 adc_x->osq1_bit.osn13 = adc_channel;
576 break;
577 case 14:
578 adc_x->osq1_bit.osn14 = adc_channel;
579 break;
580 case 15:
581 adc_x->osq1_bit.osn15 = adc_channel;
582 break;
583 case 16:
584 adc_x->osq1_bit.osn16 = adc_channel;
585 break;
586 default:
587 break;
588 }
589}
590
601void adc_preempt_channel_length_set(adc_type *adc_x, uint8_t adc_channel_lenght)
602{
603 adc_x->psq_bit.pclen = adc_channel_lenght - 1;
604}
605
633void adc_preempt_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
634{
635 uint16_t sequence_index=0;
636 switch(adc_channel)
637 {
638 case ADC_CHANNEL_0:
639 adc_x->spt2_bit.cspt0 = adc_sampletime;
640 break;
641 case ADC_CHANNEL_1:
642 adc_x->spt2_bit.cspt1 = adc_sampletime;
643 break;
644 case ADC_CHANNEL_2:
645 adc_x->spt2_bit.cspt2 = adc_sampletime;
646 break;
647 case ADC_CHANNEL_3:
648 adc_x->spt2_bit.cspt3 = adc_sampletime;
649 break;
650 case ADC_CHANNEL_4:
651 adc_x->spt2_bit.cspt4 = adc_sampletime;
652 break;
653 case ADC_CHANNEL_5:
654 adc_x->spt2_bit.cspt5 = adc_sampletime;
655 break;
656 case ADC_CHANNEL_6:
657 adc_x->spt2_bit.cspt6 = adc_sampletime;
658 break;
659 case ADC_CHANNEL_7:
660 adc_x->spt2_bit.cspt7 = adc_sampletime;
661 break;
662 case ADC_CHANNEL_8:
663 adc_x->spt2_bit.cspt8 = adc_sampletime;
664 break;
665 case ADC_CHANNEL_9:
666 adc_x->spt2_bit.cspt9 = adc_sampletime;
667 break;
668 case ADC_CHANNEL_10:
669 adc_x->spt1_bit.cspt10 = adc_sampletime;
670 break;
671 case ADC_CHANNEL_11:
672 adc_x->spt1_bit.cspt11 = adc_sampletime;
673 break;
674 case ADC_CHANNEL_12:
675 adc_x->spt1_bit.cspt12 = adc_sampletime;
676 break;
677 case ADC_CHANNEL_13:
678 adc_x->spt1_bit.cspt13 = adc_sampletime;
679 break;
680 case ADC_CHANNEL_14:
681 adc_x->spt1_bit.cspt14 = adc_sampletime;
682 break;
683 case ADC_CHANNEL_15:
684 adc_x->spt1_bit.cspt15 = adc_sampletime;
685 break;
686 case ADC_CHANNEL_16:
687 adc_x->spt1_bit.cspt16 = adc_sampletime;
688 break;
689 case ADC_CHANNEL_17:
690 adc_x->spt1_bit.cspt17 = adc_sampletime;
691 break;
692 case ADC_CHANNEL_18:
693 adc_x->spt1_bit.cspt18 = adc_sampletime;
694 break;
695 default:
696 break;
697 }
698 sequence_index = adc_sequence + 3 - adc_x->psq_bit.pclen;
699 switch(sequence_index)
700 {
701 case 1:
702 adc_x->psq_bit.psn1 = adc_channel;
703 break;
704 case 2:
705 adc_x->psq_bit.psn2 = adc_channel;
706 break;
707 case 3:
708 adc_x->psq_bit.psn3 = adc_channel;
709 break;
710 case 4:
711 adc_x->psq_bit.psn4 = adc_channel;
712 break;
713 default:
714 break;
715 }
716}
717
742void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
743{
744 if(adc_ordinary_trig > ADC_ORDINARY_TRIG_EXINT11)
745 {
746 adc_x->ctrl2_bit.octesel_h = 1;
747 adc_x->ctrl2_bit.octesel_l = adc_ordinary_trig & 0x0F;
748 }
749 else
750 {
751 adc_x->ctrl2_bit.octesel_h = 0;
752 adc_x->ctrl2_bit.octesel_l = adc_ordinary_trig & 0x0F;
753 }
754 adc_x->ctrl2_bit.ocete = adc_ordinary_trig_edge;
755}
756
781void adc_preempt_conversion_trigger_set(adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, adc_preempt_trig_edge_type adc_preempt_trig_edge)
782{
783 if(adc_preempt_trig > ADC_PREEMPT_TRIG_EXINT15)
784 {
785 adc_x->ctrl2_bit.pctesel_h = 1;
786 adc_x->ctrl2_bit.pctesel_l = adc_preempt_trig & 0x0F;
787 }
788 else
789 {
790 adc_x->ctrl2_bit.pctesel_h = 0;
791 adc_x->ctrl2_bit.pctesel_l = adc_preempt_trig & 0x0F;
792 }
793 adc_x->ctrl2_bit.pcete = adc_preempt_trig_edge;
794}
795
812void adc_preempt_offset_value_set(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel, uint16_t adc_offset_value)
813{
814 switch(adc_preempt_channel)
815 {
816 case ADC_PREEMPT_CHANNEL_1:
817 adc_x->pcdto1_bit.pcdto1 = adc_offset_value;
818 break;
819 case ADC_PREEMPT_CHANNEL_2:
820 adc_x->pcdto2_bit.pcdto2 = adc_offset_value;
821 break;
822 case ADC_PREEMPT_CHANNEL_3:
823 adc_x->pcdto3_bit.pcdto3 = adc_offset_value;
824 break;
825 case ADC_PREEMPT_CHANNEL_4:
826 adc_x->pcdto4_bit.pcdto4 = adc_offset_value;
827 break;
828 default:
829 break;
830 }
831}
832
843void adc_ordinary_part_count_set(adc_type *adc_x, uint8_t adc_channel_count)
844{
845
846 adc_x->ctrl1_bit.ocpcnt = adc_channel_count - 1;
847}
848
858void adc_ordinary_part_mode_enable(adc_type *adc_x, confirm_state new_state)
859{
860 adc_x->ctrl1_bit.ocpen = new_state;
861}
862
872void adc_preempt_part_mode_enable(adc_type *adc_x, confirm_state new_state)
873{
874 adc_x->ctrl1_bit.pcpen = new_state;
875}
876
886void adc_preempt_auto_mode_enable(adc_type *adc_x, confirm_state new_state)
887{
888 adc_x->ctrl1_bit.pcautoen = new_state;
889}
890
898void adc_conversion_stop(adc_type *adc_x)
899{
900 adc_x->ctrl2_bit.adabrt = TRUE;
901}
902
910 flag_status adc_conversion_stop_status_get(adc_type *adc_x)
911{
912 if(adc_x->ctrl2_bit.adabrt)
913 {
914 return SET;
915 }
916 else
917 {
918 return RESET;
919 }
920}
921
931void adc_occe_each_conversion_enable(adc_type *adc_x, confirm_state new_state)
932{
933 adc_x->ctrl2_bit.eocsfen = new_state;
934}
935
945void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
946{
947 adc_x->ctrl2_bit.ocswtrg = new_state;
948}
949
957 flag_status adc_ordinary_software_trigger_status_get(adc_type *adc_x)
958{
959 if(adc_x->ctrl2_bit.ocswtrg)
960 {
961 return SET;
962 }
963 else
964 {
965 return RESET;
966 }
967}
968
978void adc_preempt_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
979{
980 adc_x->ctrl2_bit.pcswtrg = new_state;
981}
982
990 flag_status adc_preempt_software_trigger_status_get(adc_type *adc_x)
991{
992 if(adc_x->ctrl2_bit.pcswtrg)
993 {
994 return SET;
995 }
996 else
997 {
998 return RESET;
999 }
1000}
1001
1009uint16_t adc_ordinary_conversion_data_get(adc_type *adc_x)
1010{
1011 return (uint16_t)(adc_x->odt_bit.odt);
1012}
1013
1018uint32_t adc_combine_ordinary_conversion_data_get(void)
1019{
1020 return (uint32_t)(ADCCOM->codt);
1021}
1022
1036uint16_t adc_preempt_conversion_data_get(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
1037{
1038 uint16_t preempt_conv_data_index = 0;
1039 switch(adc_preempt_channel)
1040 {
1041 case ADC_PREEMPT_CHANNEL_1:
1042 preempt_conv_data_index = (uint16_t)(adc_x->pdt1_bit.pdt1);
1043 break;
1044 case ADC_PREEMPT_CHANNEL_2:
1045 preempt_conv_data_index = (uint16_t)(adc_x->pdt2_bit.pdt2);
1046 break;
1047 case ADC_PREEMPT_CHANNEL_3:
1048 preempt_conv_data_index = (uint16_t)(adc_x->pdt3_bit.pdt3);
1049 break;
1050 case ADC_PREEMPT_CHANNEL_4:
1051 preempt_conv_data_index = (uint16_t)(adc_x->pdt4_bit.pdt4);
1052 break;
1053 default:
1054 break;
1055 }
1056 return preempt_conv_data_index;
1057}
1058
1075 flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
1076{
1077 flag_status status = RESET;
1078
1079 if((adc_x->sts & adc_flag) == RESET)
1080 {
1081 status = RESET;
1082 }
1083 else
1084 {
1085 status = SET;
1086 }
1087 return status;
1088}
1089
1106void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
1107{
1108 adc_x->sts = ~adc_flag;
1109}
1110
1120void adc_ordinary_oversample_enable(adc_type *adc_x, confirm_state new_state)
1121{
1122 adc_x->ovsp_bit.oosen = new_state;
1123}
1124
1134void adc_preempt_oversample_enable(adc_type *adc_x, confirm_state new_state)
1135{
1136 adc_x->ovsp_bit.posen = new_state;
1137}
1138
1167void adc_oversample_ratio_shift_set(adc_type *adc_x, adc_oversample_ratio_type adc_oversample_ratio, adc_oversample_shift_type adc_oversample_shift)
1168{
1169 adc_x->ovsp_bit.osrsel = adc_oversample_ratio;
1170 adc_x->ovsp_bit.osssel = adc_oversample_shift;
1171}
1172
1182void adc_ordinary_oversample_trig_enable(adc_type *adc_x, confirm_state new_state)
1183{
1184 adc_x->ovsp_bit.oostren = new_state;
1185}
1186
1198void adc_ordinary_oversample_restart_set(adc_type *adc_x, adc_ordinary_oversample_restart_type adc_ordinary_oversample_restart)
1199{
1200 adc_x->ovsp_bit.oosrsel = adc_ordinary_oversample_restart;
1201}
1202
1207#endif
1208
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
adc_voltage_monitoring_type
adc_voltage_monitoring_type
adc voltage_monitoring type
Definition: at32f435_437_adc.h:334
adc_channel_select_type
adc_channel_select_type
adc channel select type
Definition: at32f435_437_adc.h:186
adc_sampletime_select_type
adc_sampletime_select_type
adc sampletime select type
Definition: at32f435_437_adc.h:212
adc_oversample_shift_type
adc_oversample_shift_type
adc oversample shift type
Definition: at32f435_437_adc.h:363
adc_preempt_trig_select_type
adc_preempt_trig_select_type
adc preempt group external trigger event select type
Definition: at32f435_437_adc.h:275
adc_ordinary_trig_select_type
adc_ordinary_trig_select_type
adc ordinary group trigger event select type
Definition: at32f435_437_adc.h:227
adc_preempt_trig_edge_type
adc_preempt_trig_edge_type
adc preempt channel conversion's external_trigger_edge type
Definition: at32f435_437_adc.h:312
adc_oversample_ratio_type
adc_oversample_ratio_type
adc oversample ratio type
Definition: at32f435_437_adc.h:348
adc_ordinary_trig_edge_type
adc_ordinary_trig_edge_type
adc ordinary channel conversion's external_trigger_edge type
Definition: at32f435_437_adc.h:264
adc_resolution_type
adc_resolution_type
adc conversion resolution type
Definition: at32f435_437_adc.h:166
adc_preempt_channel_type
adc_preempt_channel_type
adc preempt channel type
Definition: at32f435_437_adc.h:323
adc_ordinary_oversample_restart_type
adc_ordinary_oversample_restart_type
adc ordinary oversample recover type
Definition: at32f435_437_adc.h:379
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f435_437_adc.h:178
ADC_CHANNEL_9
@ ADC_CHANNEL_9
Definition: at32f435_437_adc.h:196
ADC_CHANNEL_1
@ ADC_CHANNEL_1
Definition: at32f435_437_adc.h:188
ADC_CHANNEL_17
@ ADC_CHANNEL_17
Definition: at32f435_437_adc.h:204
ADC_CHANNEL_8
@ ADC_CHANNEL_8
Definition: at32f435_437_adc.h:195
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f435_437_adc.h:191
ADC_CHANNEL_12
@ ADC_CHANNEL_12
Definition: at32f435_437_adc.h:199
ADC_CHANNEL_16
@ ADC_CHANNEL_16
Definition: at32f435_437_adc.h:203
ADC_CHANNEL_0
@ ADC_CHANNEL_0
Definition: at32f435_437_adc.h:187
ADC_CHANNEL_3
@ ADC_CHANNEL_3
Definition: at32f435_437_adc.h:190
ADC_CHANNEL_14
@ ADC_CHANNEL_14
Definition: at32f435_437_adc.h:201
ADC_CHANNEL_10
@ ADC_CHANNEL_10
Definition: at32f435_437_adc.h:197
ADC_CHANNEL_13
@ ADC_CHANNEL_13
Definition: at32f435_437_adc.h:200
ADC_CHANNEL_2
@ ADC_CHANNEL_2
Definition: at32f435_437_adc.h:189
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f435_437_adc.h:193
ADC_CHANNEL_7
@ ADC_CHANNEL_7
Definition: at32f435_437_adc.h:194
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f435_437_adc.h:192
ADC_CHANNEL_18
@ ADC_CHANNEL_18
Definition: at32f435_437_adc.h:205
ADC_CHANNEL_11
@ ADC_CHANNEL_11
Definition: at32f435_437_adc.h:198
ADC_CHANNEL_15
@ ADC_CHANNEL_15
Definition: at32f435_437_adc.h:202
ADC_SAMPLING_INTERVAL_5CYCLES
@ ADC_SAMPLING_INTERVAL_5CYCLES
Definition: at32f435_437_adc.h:144
ADC_COMMON_DMAMODE_DISABLE
@ ADC_COMMON_DMAMODE_DISABLE
Definition: at32f435_437_adc.h:131
ADC_PREEMPT_TRIG_EXINT15
@ ADC_PREEMPT_TRIG_EXINT15
Definition: at32f435_437_adc.h:291
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f435_437_adc.h:111
ADC_ORDINARY_TRIG_EXINT11
@ ADC_ORDINARY_TRIG_EXINT11
Definition: at32f435_437_adc.h:243
ADC_PREEMPT_CHANNEL_3
@ ADC_PREEMPT_CHANNEL_3
Definition: at32f435_437_adc.h:326
ADC_PREEMPT_CHANNEL_4
@ ADC_PREEMPT_CHANNEL_4
Definition: at32f435_437_adc.h:327
ADC_PREEMPT_CHANNEL_2
@ ADC_PREEMPT_CHANNEL_2
Definition: at32f435_437_adc.h:325
ADC_PREEMPT_CHANNEL_1
@ ADC_PREEMPT_CHANNEL_1
Definition: at32f435_437_adc.h:324
ADC_HCLK_DIV_2
@ ADC_HCLK_DIV_2
Definition: at32f435_437_adc.h:88
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:945
adc_voltage_monitor_enable
void adc_voltage_monitor_enable(adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring)
enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified ...
Definition: at32f435_437_adc.c:399
adc_voltage_monitor_single_channel_select
void adc_voltage_monitor_single_channel_select(adc_type *adc_x, adc_channel_select_type adc_channel)
select the voltage monitoring's channel of the specified adc peripheral.
Definition: at32f435_437_adc.c:440
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc ...
Definition: at32f435_437_adc.c:742
adc_ordinary_conversion_data_get
uint16_t adc_ordinary_conversion_data_get(adc_type *adc_x)
return the last conversion data for ordinary channel of the specified adc peripheral.
Definition: at32f435_437_adc.c:1009
adc_preempt_offset_value_set
void adc_preempt_offset_value_set(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel, uint16_t adc_offset_value)
set preempt channel's conversion value offset of the specified adc peripheral.
Definition: at32f435_437_adc.c:812
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f435_437_adc.c:110
adc_ordinary_software_trigger_status_get
flag_status adc_ordinary_software_trigger_status_get(adc_type *adc_x)
get ordinary software start conversion status of the specified adc peripheral.
Definition: at32f435_437_adc.c:957
adc_voltage_battery_enable
void adc_voltage_battery_enable(confirm_state new_state)
enable or disable the adc voltage battery.
Definition: at32f435_437_adc.c:246
adc_preempt_auto_mode_enable
void adc_preempt_auto_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable automatic preempt group conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:886
adc_preempt_software_trigger_status_get
flag_status adc_preempt_software_trigger_status_get(adc_type *adc_x)
get preempt software start conversion status of the specified adc peripheral.
Definition: at32f435_437_adc.c:990
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f435_437_adc.c:64
adc_ordinary_part_count_set
void adc_ordinary_part_count_set(adc_type *adc_x, uint8_t adc_channel_count)
set partitioned mode channel count of the specified adc peripheral.
Definition: at32f435_437_adc.c:843
adc_preempt_conversion_data_get
uint16_t adc_preempt_conversion_data_get(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral.
Definition: at32f435_437_adc.c:1036
adc_ordinary_oversample_enable
void adc_ordinary_oversample_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the ordinary oversampling of the specified adc peripheral.
Definition: at32f435_437_adc.c:1120
adc_oversample_ratio_shift_set
void adc_oversample_ratio_shift_set(adc_type *adc_x, adc_oversample_ratio_type adc_oversample_ratio, adc_oversample_shift_type adc_oversample_shift)
config the oversampling ratio and shift of the specified adc peripheral.
Definition: at32f435_437_adc.c:1167
adc_preempt_oversample_enable
void adc_preempt_oversample_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the preempt oversampling of the specified adc peripheral.
Definition: at32f435_437_adc.c:1134
adc_preempt_conversion_trigger_set
void adc_preempt_conversion_trigger_set(adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, adc_preempt_trig_edge_type adc_preempt_trig_edge)
enable or disable the preempt channel's external trigger and set external trigger event of the specif...
Definition: at32f435_437_adc.c:781
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1106
adc_common_config
void adc_common_config(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:203
adc_conversion_stop_status_get
flag_status adc_conversion_stop_status_get(adc_type *adc_x)
get stop conversion's status of the specified adc peripheral.
Definition: at32f435_437_adc.c:910
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f435_437_adc.c:294
adc_resolution_set
void adc_resolution_set(adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral.
Definition: at32f435_437_adc.c:235
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f435_437_adc.c:84
adc_ordinary_oversample_trig_enable
void adc_ordinary_oversample_trig_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the ordinary oversampling trigger mode of the specified adc peripheral.
Definition: at32f435_437_adc.c:1182
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f435_437_adc.c:359
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f435_437_adc.c:371
adc_dma_request_repeat_enable
void adc_dma_request_repeat_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat.
Definition: at32f435_437_adc.c:274
adc_ordinary_oversample_restart_set
void adc_ordinary_oversample_restart_set(adc_type *adc_x, adc_ordinary_oversample_restart_type adc_ordinary_oversample_restart)
set ordinary oversample restart mode of the specified adc peripheral.
Definition: at32f435_437_adc.c:1198
adc_calibration_value_set
void adc_calibration_value_set(adc_type *adc_x, uint8_t adc_calibration_value)
set calibration value of the specified adc peripheral.
Definition: at32f435_437_adc.c:316
adc_reset
void adc_reset(void)
deinitialize the adc peripheral registers to their default reset values.
Definition: at32f435_437_adc.c:49
adc_voltage_monitor_threshold_value_set
void adc_voltage_monitor_threshold_value_set(adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold)
set voltage monitoring's high and low thresholds value of the specified adc peripheral.
Definition: at32f435_437_adc.c:420
adc_preempt_part_mode_enable
void adc_preempt_part_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on preempt channel of the specified adc peripheral.
Definition: at32f435_437_adc.c:872
adc_conversion_stop
void adc_conversion_stop(adc_type *adc_x)
stop the ongoing conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:898
adc_occe_each_conversion_enable
void adc_occe_each_conversion_enable(adc_type *adc_x, confirm_state new_state)
enable or disable each ordinary channel conversion set occe flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:931
adc_combine_ordinary_conversion_data_get
uint32_t adc_combine_ordinary_conversion_data_get(void)
return the last ordinary conversion data of combine adc.
Definition: at32f435_437_adc.c:1018
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f435_437_adc.c:328
adc_preempt_channel_set
void adc_preempt_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc ...
Definition: at32f435_437_adc.c:633
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f435_437_adc.c:340
adc_ordinary_part_mode_enable
void adc_ordinary_part_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on ordinary channel of the specified adc peripheral.
Definition: at32f435_437_adc.c:858
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f435_437_adc.c:260
adc_preempt_channel_length_set
void adc_preempt_channel_length_set(adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral.
Definition: at32f435_437_adc.c:601
adc_common_default_para_init
void adc_common_default_para_init(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:155
adc_preempt_software_trigger_enable
void adc_preempt_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable preempt software start conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:978
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f435_437_adc.c:472
ADCCOM
#define ADCCOM
Definition: at32f435_437_adc.h:869
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f435_437_crm.c:251
CRM_ADC_PERIPH_RESET
@ CRM_ADC_PERIPH_RESET
Definition: at32f435_437_crm.h:305
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
adc_base_config_type
adc base config type
Definition: at32f435_437_adc.h:402
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f435_437_adc.h:405
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f435_437_adc.h:404
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f435_437_adc.h:403
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f435_437_adc.h:406
adc_common_config_type
adc common config type
Definition: at32f435_437_adc.h:388
adc_common_config_type::sampling_interval
adc_sampling_interval_type sampling_interval
Definition: at32f435_437_adc.h:393
adc_common_config_type::tempervintrv_state
confirm_state tempervintrv_state
Definition: at32f435_437_adc.h:394
adc_common_config_type::div
adc_div_type div
Definition: at32f435_437_adc.h:390
adc_common_config_type::common_dma_mode
adc_common_dma_mode_type common_dma_mode
Definition: at32f435_437_adc.h:391
adc_common_config_type::common_dma_request_repeat_state
confirm_state common_dma_request_repeat_state
Definition: at32f435_437_adc.h:392
adc_common_config_type::combine_mode
adc_combine_mode_type combine_mode
Definition: at32f435_437_adc.h:389
adc_common_config_type::vbat_state
confirm_state vbat_state
Definition: at32f435_437_adc.h:395
adc_type
type define adc register all
Definition: at32f435_437_adc.h:413
adc_type::cspt1
__IO uint32_t cspt1
Definition: at32f435_437_adc.h:521
adc_type::ctrl1_bit
struct adc_type::@20::@63 ctrl1_bit
adc_type::dtalign
__IO uint32_t dtalign
Definition: at32f435_437_adc.h:478
adc_type::pdt4_bit
struct adc_type::@54::@80 pdt4_bit
adc_type::ocdmaen
__IO uint32_t ocdmaen
Definition: at32f435_437_adc.h:475
adc_type::ocswtrg
__IO uint32_t ocswtrg
Definition: at32f435_437_adc.h:486
adc_type::osn14
__IO uint32_t osn14
Definition: at32f435_437_adc.h:621
adc_type::rpen
__IO uint32_t rpen
Definition: at32f435_437_adc.h:470
adc_type::sqen
__IO uint32_t sqen
Definition: at32f435_437_adc.h:446
adc_type::pctesel_h
__IO uint32_t pctesel_h
Definition: at32f435_437_adc.h:483
adc_type::pdt4
__IO uint32_t pdt4
Definition: at32f435_437_adc.h:726
adc_type::cspt15
__IO uint32_t cspt15
Definition: at32f435_437_adc.h:504
adc_type::pclen
__IO uint32_t pclen
Definition: at32f435_437_adc.h:677
adc_type::vmcsel
__IO uint32_t vmcsel
Definition: at32f435_437_adc.h:442
adc_type::cspt7
__IO uint32_t cspt7
Definition: at32f435_437_adc.h:527
adc_type::odt
__IO uint32_t odt
Definition: at32f435_437_adc.h:739
adc_type::adabrt
__IO uint32_t adabrt
Definition: at32f435_437_adc.h:473
adc_type::vmlb_bit
struct adc_type::@38::@72 vmlb_bit
adc_type::pcvmen
__IO uint32_t pcvmen
Definition: at32f435_437_adc.h:453
adc_type::osn1
__IO uint32_t osn1
Definition: at32f435_437_adc.h:655
adc_type::osrsel
__IO uint32_t osrsel
Definition: at32f435_437_adc.h:759
adc_type::ocdrcen
__IO uint32_t ocdrcen
Definition: at32f435_437_adc.h:476
adc_type::oostren
__IO uint32_t oostren
Definition: at32f435_437_adc.h:761
adc_type::pcdto4
__IO uint32_t pcdto4
Definition: at32f435_437_adc.h:578
adc_type::pcdto3_bit
struct adc_type::@32::@69 pcdto3_bit
adc_type::pdt1
__IO uint32_t pdt1
Definition: at32f435_437_adc.h:687
adc_type::vmhb_bit
struct adc_type::@36::@71 vmhb_bit
adc_type::posen
__IO uint32_t posen
Definition: at32f435_437_adc.h:758
adc_type::pcdto2
__IO uint32_t pcdto2
Definition: at32f435_437_adc.h:552
adc_type::cspt6
__IO uint32_t cspt6
Definition: at32f435_437_adc.h:526
adc_type::osn6
__IO uint32_t osn6
Definition: at32f435_437_adc.h:660
adc_type::osn8
__IO uint32_t osn8
Definition: at32f435_437_adc.h:638
adc_type::pcpen
__IO uint32_t pcpen
Definition: at32f435_437_adc.h:450
adc_type::osn16
__IO uint32_t osn16
Definition: at32f435_437_adc.h:623
adc_type::cspt13
__IO uint32_t cspt13
Definition: at32f435_437_adc.h:502
adc_type::ovsp_bit
struct adc_type::@58::@82 ovsp_bit
adc_type::vmsgen
__IO uint32_t vmsgen
Definition: at32f435_437_adc.h:447
adc_type::osn3
__IO uint32_t osn3
Definition: at32f435_437_adc.h:657
adc_type::pcdto2_bit
struct adc_type::@30::@68 pcdto2_bit
adc_type::ocete
__IO uint32_t ocete
Definition: at32f435_437_adc.h:485
adc_type::ocvmen
__IO uint32_t ocvmen
Definition: at32f435_437_adc.h:454
adc_type::eocsfen
__IO uint32_t eocsfen
Definition: at32f435_437_adc.h:477
adc_type::osq3_bit
struct adc_type::@44::@75 osq3_bit
adc_type::oclen
__IO uint32_t oclen
Definition: at32f435_437_adc.h:624
adc_type::pcdto1
__IO uint32_t pcdto1
Definition: at32f435_437_adc.h:539
adc_type::oosen
__IO uint32_t oosen
Definition: at32f435_437_adc.h:757
adc_type::osn9
__IO uint32_t osn9
Definition: at32f435_437_adc.h:639
adc_type::cspt5
__IO uint32_t cspt5
Definition: at32f435_437_adc.h:525
adc_type::psn4
__IO uint32_t psn4
Definition: at32f435_437_adc.h:676
adc_type::pdt3_bit
struct adc_type::@52::@79 pdt3_bit
adc_type::cspt12
__IO uint32_t cspt12
Definition: at32f435_437_adc.h:501
adc_type::adcal
__IO uint32_t adcal
Definition: at32f435_437_adc.h:471
adc_type::cspt14
__IO uint32_t cspt14
Definition: at32f435_437_adc.h:503
adc_type::octesel_l
__IO uint32_t octesel_l
Definition: at32f435_437_adc.h:484
adc_type::pcete
__IO uint32_t pcete
Definition: at32f435_437_adc.h:481
adc_type::osq2_bit
struct adc_type::@42::@74 osq2_bit
adc_type::pctesel_l
__IO uint32_t pctesel_l
Definition: at32f435_437_adc.h:480
adc_type::octesel_h
__IO uint32_t octesel_h
Definition: at32f435_437_adc.h:487
adc_type::psn3
__IO uint32_t psn3
Definition: at32f435_437_adc.h:675
adc_type::osn4
__IO uint32_t osn4
Definition: at32f435_437_adc.h:658
adc_type::adcen
__IO uint32_t adcen
Definition: at32f435_437_adc.h:469
adc_type::spt1_bit
struct adc_type::@24::@65 spt1_bit
adc_type::oosrsel
__IO uint32_t oosrsel
Definition: at32f435_437_adc.h:762
adc_type::vmhb
__IO uint32_t vmhb
Definition: at32f435_437_adc.h:591
adc_type::ocpen
__IO uint32_t ocpen
Definition: at32f435_437_adc.h:449
adc_type::cspt9
__IO uint32_t cspt9
Definition: at32f435_437_adc.h:529
adc_type::adcalinit
__IO uint32_t adcalinit
Definition: at32f435_437_adc.h:472
adc_type::pdt3
__IO uint32_t pdt3
Definition: at32f435_437_adc.h:713
adc_type::cspt18
__IO uint32_t cspt18
Definition: at32f435_437_adc.h:507
adc_type::osq1_bit
struct adc_type::@40::@73 osq1_bit
adc_type::psn1
__IO uint32_t psn1
Definition: at32f435_437_adc.h:673
adc_type::cspt10
__IO uint32_t cspt10
Definition: at32f435_437_adc.h:499
adc_type::osn10
__IO uint32_t osn10
Definition: at32f435_437_adc.h:640
adc_type::osn12
__IO uint32_t osn12
Definition: at32f435_437_adc.h:642
adc_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f435_437_adc.h:439
adc_type::sts
__IO uint32_t sts
Definition: at32f435_437_adc.h:420
adc_type::cspt0
__IO uint32_t cspt0
Definition: at32f435_437_adc.h:520
adc_type::cspt16
__IO uint32_t cspt16
Definition: at32f435_437_adc.h:505
adc_type::osssel
__IO uint32_t osssel
Definition: at32f435_437_adc.h:760
adc_type::psn2
__IO uint32_t psn2
Definition: at32f435_437_adc.h:674
adc_type::osn2
__IO uint32_t osn2
Definition: at32f435_437_adc.h:656
adc_type::pdt2_bit
struct adc_type::@50::@78 pdt2_bit
adc_type::crsel
__IO uint32_t crsel
Definition: at32f435_437_adc.h:455
adc_type::osn15
__IO uint32_t osn15
Definition: at32f435_437_adc.h:622
adc_type::osn11
__IO uint32_t osn11
Definition: at32f435_437_adc.h:641
adc_type::spt2_bit
struct adc_type::@26::@66 spt2_bit
adc_type::vmlb
__IO uint32_t vmlb
Definition: at32f435_437_adc.h:604
adc_type::osn5
__IO uint32_t osn5
Definition: at32f435_437_adc.h:659
adc_type::pdt2
__IO uint32_t pdt2
Definition: at32f435_437_adc.h:700
adc_type::pcdto1_bit
struct adc_type::@28::@67 pcdto1_bit
adc_type::cspt4
__IO uint32_t cspt4
Definition: at32f435_437_adc.h:524
adc_type::psq_bit
struct adc_type::@46::@76 psq_bit
adc_type::ocpcnt
__IO uint32_t ocpcnt
Definition: at32f435_437_adc.h:451
adc_type::pcautoen
__IO uint32_t pcautoen
Definition: at32f435_437_adc.h:448
adc_type::cspt2
__IO uint32_t cspt2
Definition: at32f435_437_adc.h:522
adc_type::ctrl2_bit
struct adc_type::@22::@64 ctrl2_bit
adc_type::cspt17
__IO uint32_t cspt17
Definition: at32f435_437_adc.h:506
adc_type::cspt11
__IO uint32_t cspt11
Definition: at32f435_437_adc.h:500
adc_type::calval
__IO uint32_t calval
Definition: at32f435_437_adc.h:774
adc_type::pcdto3
__IO uint32_t pcdto3
Definition: at32f435_437_adc.h:565
adc_type::pcdto4_bit
struct adc_type::@34::@70 pcdto4_bit
adc_type::cspt8
__IO uint32_t cspt8
Definition: at32f435_437_adc.h:528
adc_type::osn7
__IO uint32_t osn7
Definition: at32f435_437_adc.h:637
adc_type::pdt1_bit
struct adc_type::@48::@77 pdt1_bit
adc_type::pcswtrg
__IO uint32_t pcswtrg
Definition: at32f435_437_adc.h:482
adc_type::odt_bit
struct adc_type::@56::@81 odt_bit
adc_type::osn13
__IO uint32_t osn13
Definition: at32f435_437_adc.h:620
adc_type::cspt3
__IO uint32_t cspt3
Definition: at32f435_437_adc.h:523
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_adc.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_adc.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_ADC_H
29#define __AT32F435_437_ADC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
39
53#define ADC_OCCE_INT ((uint32_t)0x00000020)
54#define ADC_VMOR_INT ((uint32_t)0x00000040)
55#define ADC_PCCE_INT ((uint32_t)0x00000080)
56#define ADC_OCCO_INT ((uint32_t)0x04000000)
67#define ADC_VMOR_FLAG ((uint8_t)0x01)
68#define ADC_OCCE_FLAG ((uint8_t)0x02)
69#define ADC_PCCE_FLAG ((uint8_t)0x04)
70#define ADC_PCCS_FLAG ((uint8_t)0x08)
71#define ADC_OCCS_FLAG ((uint8_t)0x10)
72#define ADC_OCCO_FLAG ((uint8_t)0x20)
73#define ADC_RDY_FLAG ((uint8_t)0x40)
86typedef enum
87{
88 ADC_HCLK_DIV_2 = 0x00,
89 ADC_HCLK_DIV_3 = 0x01,
90 ADC_HCLK_DIV_4 = 0x02,
91 ADC_HCLK_DIV_5 = 0x03,
92 ADC_HCLK_DIV_6 = 0x04,
93 ADC_HCLK_DIV_7 = 0x05,
94 ADC_HCLK_DIV_8 = 0x06,
95 ADC_HCLK_DIV_9 = 0x07,
96 ADC_HCLK_DIV_10 = 0x08,
97 ADC_HCLK_DIV_11 = 0x09,
98 ADC_HCLK_DIV_12 = 0x0A,
99 ADC_HCLK_DIV_13 = 0x0B,
100 ADC_HCLK_DIV_14 = 0x0C,
101 ADC_HCLK_DIV_15 = 0x0D,
102 ADC_HCLK_DIV_16 = 0x0E,
103 ADC_HCLK_DIV_17 = 0x0F
104} adc_div_type;
105
109typedef enum
110{
111 ADC_INDEPENDENT_MODE = 0x00,
112 ADC_ORDINARY_SMLT_PREEMPT_SMLT_ONESLAVE_MODE = 0x01,
113 ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_ONESLAVE_MODE = 0x02,
114 ADC_PREEMPT_SMLT_ONLY_ONESLAVE_MODE = 0x05,
115 ADC_ORDINARY_SMLT_ONLY_ONESLAVE_MODE = 0x06,
116 ADC_ORDINARY_SHIFT_ONLY_ONESLAVE_MODE = 0x07,
117 ADC_PREEMPT_INTERLTRIG_ONLY_ONESLAVE_MODE = 0x09,
118 ADC_ORDINARY_SMLT_PREEMPT_SMLT_TWOSLAVE_MODE = 0x11,
119 ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_TWOSLAVE_MODE = 0x12,
120 ADC_PREEMPT_SMLT_ONLY_TWOSLAVE_MODE = 0x15,
121 ADC_ORDINARY_SMLT_ONLY_TWOSLAVE_MODE = 0x16,
122 ADC_ORDINARY_SHIFT_ONLY_TWOSLAVE_MODE = 0x17,
123 ADC_PREEMPT_INTERLTRIG_ONLY_TWOSLAVE_MODE = 0x19
124} adc_combine_mode_type;
125
129typedef enum
130{
131 ADC_COMMON_DMAMODE_DISABLE = 0x00,
132 ADC_COMMON_DMAMODE_1 = 0x01,
133 ADC_COMMON_DMAMODE_2 = 0x02,
134 ADC_COMMON_DMAMODE_3 = 0x03,
135 ADC_COMMON_DMAMODE_4 = 0x04,
136 ADC_COMMON_DMAMODE_5 = 0x05
137} adc_common_dma_mode_type;
138
142typedef enum
143{
144 ADC_SAMPLING_INTERVAL_5CYCLES = 0x00,
145 ADC_SAMPLING_INTERVAL_6CYCLES = 0x01,
146 ADC_SAMPLING_INTERVAL_7CYCLES = 0x02,
147 ADC_SAMPLING_INTERVAL_8CYCLES = 0x03,
148 ADC_SAMPLING_INTERVAL_9CYCLES = 0x04,
149 ADC_SAMPLING_INTERVAL_10CYCLES = 0x05,
150 ADC_SAMPLING_INTERVAL_11CYCLES = 0x06,
151 ADC_SAMPLING_INTERVAL_12CYCLES = 0x07,
152 ADC_SAMPLING_INTERVAL_13CYCLES = 0x08,
153 ADC_SAMPLING_INTERVAL_14CYCLES = 0x09,
154 ADC_SAMPLING_INTERVAL_15CYCLES = 0x0A,
155 ADC_SAMPLING_INTERVAL_16CYCLES = 0x0B,
156 ADC_SAMPLING_INTERVAL_17CYCLES = 0x0C,
157 ADC_SAMPLING_INTERVAL_18CYCLES = 0x0D,
158 ADC_SAMPLING_INTERVAL_19CYCLES = 0x0E,
159 ADC_SAMPLING_INTERVAL_20CYCLES = 0x0F
160} adc_sampling_interval_type;
161
165typedef enum
166{
167 ADC_RESOLUTION_12B = 0x00,
168 ADC_RESOLUTION_10B = 0x01,
169 ADC_RESOLUTION_8B = 0x02,
170 ADC_RESOLUTION_6B = 0x03
171} adc_resolution_type;
172
176typedef enum
177{
178 ADC_RIGHT_ALIGNMENT = 0x00,
179 ADC_LEFT_ALIGNMENT = 0x01
180} adc_data_align_type;
181
185typedef enum
186{
187 ADC_CHANNEL_0 = 0x00,
188 ADC_CHANNEL_1 = 0x01,
189 ADC_CHANNEL_2 = 0x02,
190 ADC_CHANNEL_3 = 0x03,
191 ADC_CHANNEL_4 = 0x04,
192 ADC_CHANNEL_5 = 0x05,
193 ADC_CHANNEL_6 = 0x06,
194 ADC_CHANNEL_7 = 0x07,
195 ADC_CHANNEL_8 = 0x08,
196 ADC_CHANNEL_9 = 0x09,
197 ADC_CHANNEL_10 = 0x0A,
198 ADC_CHANNEL_11 = 0x0B,
199 ADC_CHANNEL_12 = 0x0C,
200 ADC_CHANNEL_13 = 0x0D,
201 ADC_CHANNEL_14 = 0x0E,
202 ADC_CHANNEL_15 = 0x0F,
203 ADC_CHANNEL_16 = 0x10,
204 ADC_CHANNEL_17 = 0x11,
205 ADC_CHANNEL_18 = 0x12
206} adc_channel_select_type;
207
211typedef enum
212{
213 ADC_SAMPLETIME_2_5 = 0x00,
214 ADC_SAMPLETIME_6_5 = 0x01,
215 ADC_SAMPLETIME_12_5 = 0x02,
216 ADC_SAMPLETIME_24_5 = 0x03,
217 ADC_SAMPLETIME_47_5 = 0x04,
218 ADC_SAMPLETIME_92_5 = 0x05,
219 ADC_SAMPLETIME_247_5 = 0x06,
220 ADC_SAMPLETIME_640_5 = 0x07
221} adc_sampletime_select_type;
222
226typedef enum
227{
228 ADC_ORDINARY_TRIG_TMR1CH1 = 0x00,
229 ADC_ORDINARY_TRIG_TMR1CH2 = 0x01,
230 ADC_ORDINARY_TRIG_TMR1CH3 = 0x02,
231 ADC_ORDINARY_TRIG_TMR2CH2 = 0x03,
232 ADC_ORDINARY_TRIG_TMR2CH3 = 0x04,
233 ADC_ORDINARY_TRIG_TMR2CH4 = 0x05,
234 ADC_ORDINARY_TRIG_TMR2TRGOUT = 0x06,
235 ADC_ORDINARY_TRIG_TMR3CH1 = 0x07,
236 ADC_ORDINARY_TRIG_TMR3TRGOUT = 0x08,
237 ADC_ORDINARY_TRIG_TMR4CH4 = 0x09,
238 ADC_ORDINARY_TRIG_TMR5CH1 = 0x0A,
239 ADC_ORDINARY_TRIG_TMR5CH2 = 0x0B,
240 ADC_ORDINARY_TRIG_TMR5CH3 = 0x0C,
241 ADC_ORDINARY_TRIG_TMR8CH1 = 0x0D,
242 ADC_ORDINARY_TRIG_TMR8TRGOUT = 0x0E,
243 ADC_ORDINARY_TRIG_EXINT11 = 0x0F,
244 ADC_ORDINARY_TRIG_TMR20TRGOUT = 0x10,
245 ADC_ORDINARY_TRIG_TMR20TRGOUT2 = 0x11,
246 ADC_ORDINARY_TRIG_TMR20CH1 = 0x12,
247 ADC_ORDINARY_TRIG_TMR20CH2 = 0x13,
248 ADC_ORDINARY_TRIG_TMR20CH3 = 0x14,
249 ADC_ORDINARY_TRIG_TMR8TRGOUT2 = 0x15,
250 ADC_ORDINARY_TRIG_TMR1TRGOUT2 = 0x16,
251 ADC_ORDINARY_TRIG_TMR4TRGOUT = 0x17,
252 ADC_ORDINARY_TRIG_TMR6TRGOUT = 0x18,
253 ADC_ORDINARY_TRIG_TMR3CH4 = 0x19,
254 ADC_ORDINARY_TRIG_TMR4CH1 = 0x1A,
255 ADC_ORDINARY_TRIG_TMR1TRGOUT = 0x1B,
256 ADC_ORDINARY_TRIG_TMR2CH1 = 0x1C,
257 ADC_ORDINARY_TRIG_TMR7TRGOUT = 0x1E
258} adc_ordinary_trig_select_type;
259
263typedef enum
264{
265 ADC_ORDINARY_TRIG_EDGE_NONE = 0x00,
266 ADC_ORDINARY_TRIG_EDGE_RISING = 0x01,
267 ADC_ORDINARY_TRIG_EDGE_FALLING = 0x02,
268 ADC_ORDINARY_TRIG_EDGE_RISING_FALLING = 0x03
269} adc_ordinary_trig_edge_type;
270
274typedef enum
275{
276 ADC_PREEMPT_TRIG_TMR1CH4 = 0x00,
277 ADC_PREEMPT_TRIG_TMR1TRGOUT = 0x01,
278 ADC_PREEMPT_TRIG_TMR2CH1 = 0x02,
279 ADC_PREEMPT_TRIG_TMR2TRGOUT = 0x03,
280 ADC_PREEMPT_TRIG_TMR3CH2 = 0x04,
281 ADC_PREEMPT_TRIG_TMR3CH4 = 0x05,
282 ADC_PREEMPT_TRIG_TMR4CH1 = 0x06,
283 ADC_PREEMPT_TRIG_TMR4CH2 = 0x07,
284 ADC_PREEMPT_TRIG_TMR4CH3 = 0x08,
285 ADC_PREEMPT_TRIG_TMR4TRGOUT = 0x09,
286 ADC_PREEMPT_TRIG_TMR5CH4 = 0x0A,
287 ADC_PREEMPT_TRIG_TMR5TRGOUT = 0x0B,
288 ADC_PREEMPT_TRIG_TMR8CH2 = 0x0C,
289 ADC_PREEMPT_TRIG_TMR8CH3 = 0x0D,
290 ADC_PREEMPT_TRIG_TMR8CH4 = 0x0E,
291 ADC_PREEMPT_TRIG_EXINT15 = 0x0F,
292 ADC_PREEMPT_TRIG_TMR20TRGOUT = 0x10,
293 ADC_PREEMPT_TRIG_TMR20TRGOUT2 = 0x11,
294 ADC_PREEMPT_TRIG_TMR20CH4 = 0x12,
295 ADC_PREEMPT_TRIG_TMR1TRGOUT2 = 0x13,
296 ADC_PREEMPT_TRIG_TMR8TRGOUT = 0x14,
297 ADC_PREEMPT_TRIG_TMR8TRGOUT2 = 0x15,
298 ADC_PREEMPT_TRIG_TMR3CH3 = 0x16,
299 ADC_PREEMPT_TRIG_TMR3TRGOUT = 0x17,
300 ADC_PREEMPT_TRIG_TMR3CH1 = 0x18,
301 ADC_PREEMPT_TRIG_TMR6TRGOUT = 0x19,
302 ADC_PREEMPT_TRIG_TMR4CH4 = 0x1A,
303 ADC_PREEMPT_TRIG_TMR1CH3 = 0x1B,
304 ADC_PREEMPT_TRIG_TMR20CH2 = 0x1C,
305 ADC_PREEMPT_TRIG_TMR7TRGOUT = 0x1E
306} adc_preempt_trig_select_type;
307
311typedef enum
312{
313 ADC_PREEMPT_TRIG_EDGE_NONE = 0x00,
314 ADC_PREEMPT_TRIG_EDGE_RISING = 0x01,
315 ADC_PREEMPT_TRIG_EDGE_FALLING = 0x02,
316 ADC_PREEMPT_TRIG_EDGE_RISING_FALLING = 0x03
317} adc_preempt_trig_edge_type;
318
322typedef enum
323{
324 ADC_PREEMPT_CHANNEL_1 = 0x00,
325 ADC_PREEMPT_CHANNEL_2 = 0x01,
326 ADC_PREEMPT_CHANNEL_3 = 0x02,
327 ADC_PREEMPT_CHANNEL_4 = 0x03
328} adc_preempt_channel_type;
329
333typedef enum
334{
335 ADC_VMONITOR_SINGLE_ORDINARY = 0x00800200,
336 ADC_VMONITOR_SINGLE_PREEMPT = 0x00400200,
337 ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT = 0x00C00200,
338 ADC_VMONITOR_ALL_ORDINARY = 0x00800000,
339 ADC_VMONITOR_ALL_PREEMPT = 0x00400000,
340 ADC_VMONITOR_ALL_ORDINARY_PREEMPT = 0x00C00000,
341 ADC_VMONITOR_NONE = 0x00000000
342} adc_voltage_monitoring_type;
343
347typedef enum
348{
349 ADC_OVERSAMPLE_RATIO_2 = 0x00,
350 ADC_OVERSAMPLE_RATIO_4 = 0x01,
351 ADC_OVERSAMPLE_RATIO_8 = 0x02,
352 ADC_OVERSAMPLE_RATIO_16 = 0x03,
353 ADC_OVERSAMPLE_RATIO_32 = 0x04,
354 ADC_OVERSAMPLE_RATIO_64 = 0x05,
355 ADC_OVERSAMPLE_RATIO_128 = 0x06,
356 ADC_OVERSAMPLE_RATIO_256 = 0x07
357} adc_oversample_ratio_type;
358
362typedef enum
363{
364 ADC_OVERSAMPLE_SHIFT_0 = 0x00,
365 ADC_OVERSAMPLE_SHIFT_1 = 0x01,
366 ADC_OVERSAMPLE_SHIFT_2 = 0x02,
367 ADC_OVERSAMPLE_SHIFT_3 = 0x03,
368 ADC_OVERSAMPLE_SHIFT_4 = 0x04,
369 ADC_OVERSAMPLE_SHIFT_5 = 0x05,
370 ADC_OVERSAMPLE_SHIFT_6 = 0x06,
371 ADC_OVERSAMPLE_SHIFT_7 = 0x07,
372 ADC_OVERSAMPLE_SHIFT_8 = 0x08
373} adc_oversample_shift_type;
374
378typedef enum
379{
380 ADC_OVERSAMPLE_CONTINUE = 0x00,
381 ADC_OVERSAMPLE_RESTART = 0x01
382} adc_ordinary_oversample_restart_type;
383
387typedef struct
388{
389 adc_combine_mode_type combine_mode;
390 adc_div_type div;
391 adc_common_dma_mode_type common_dma_mode;
392 confirm_state common_dma_request_repeat_state;
393 adc_sampling_interval_type sampling_interval;
394 confirm_state tempervintrv_state;
395 confirm_state vbat_state;
396} adc_common_config_type;
397
401typedef struct
402{
403 confirm_state sequence_mode;
404 confirm_state repeat_mode;
405 adc_data_align_type data_align;
406 uint8_t ordinary_channel_length;
407} adc_base_config_type;
408
412typedef struct
413{
414
418 union
419 {
420 __IO uint32_t sts;
421 struct
422 {
423 __IO uint32_t vmor : 1; /* [0] */
424 __IO uint32_t occe : 1; /* [1] */
425 __IO uint32_t pcce : 1; /* [2] */
426 __IO uint32_t pccs : 1; /* [3] */
427 __IO uint32_t occs : 1; /* [4] */
428 __IO uint32_t occo : 1; /* [5] */
429 __IO uint32_t rdy : 1; /* [6] */
430 __IO uint32_t reserved1 : 25;/* [31:7] */
431 } sts_bit;
432 };
433
437 union
438 {
439 __IO uint32_t ctrl1;
440 struct
441 {
442 __IO uint32_t vmcsel : 5; /* [4:0] */
443 __IO uint32_t occeien : 1; /* [5] */
444 __IO uint32_t vmorien : 1; /* [6] */
445 __IO uint32_t pcceien : 1; /* [7] */
446 __IO uint32_t sqen : 1; /* [8] */
447 __IO uint32_t vmsgen : 1; /* [9] */
448 __IO uint32_t pcautoen : 1; /* [10] */
449 __IO uint32_t ocpen : 1; /* [11] */
450 __IO uint32_t pcpen : 1; /* [12] */
451 __IO uint32_t ocpcnt : 3; /* [15:13] */
452 __IO uint32_t reserved1 : 6; /* [21:16] */
453 __IO uint32_t pcvmen : 1; /* [22] */
454 __IO uint32_t ocvmen : 1; /* [23] */
455 __IO uint32_t crsel : 2; /* [25:24] */
456 __IO uint32_t occoien : 1; /* [26] */
457 __IO uint32_t reserved2 : 5; /* [31:27] */
458 } ctrl1_bit;
459 };
460
464 union
465 {
466 __IO uint32_t ctrl2;
467 struct
468 {
469 __IO uint32_t adcen : 1; /* [0] */
470 __IO uint32_t rpen : 1; /* [1] */
471 __IO uint32_t adcal : 1; /* [2] */
472 __IO uint32_t adcalinit : 1; /* [3] */
473 __IO uint32_t adabrt : 1; /* [4] */
474 __IO uint32_t reserved1 : 3; /* [7:5] */
475 __IO uint32_t ocdmaen : 1; /* [8] */
476 __IO uint32_t ocdrcen : 1; /* [9] */
477 __IO uint32_t eocsfen : 1; /* [10] */
478 __IO uint32_t dtalign : 1; /* [11] */
479 __IO uint32_t reserved2 : 4; /* [15:12] */
480 __IO uint32_t pctesel_l : 4; /* [19:16] */
481 __IO uint32_t pcete : 2; /* [21:20] */
482 __IO uint32_t pcswtrg : 1; /* [22] */
483 __IO uint32_t pctesel_h : 1; /* [23] */
484 __IO uint32_t octesel_l : 4; /* [27:24] */
485 __IO uint32_t ocete : 2; /* [29:28] */
486 __IO uint32_t ocswtrg : 1; /* [30] */
487 __IO uint32_t octesel_h : 1; /* [31] */
488 } ctrl2_bit;
489 };
490
494 union
495 {
496 __IO uint32_t spt1;
497 struct
498 {
499 __IO uint32_t cspt10 : 3; /* [2:0] */
500 __IO uint32_t cspt11 : 3; /* [5:3] */
501 __IO uint32_t cspt12 : 3; /* [8:6] */
502 __IO uint32_t cspt13 : 3; /* [11:9] */
503 __IO uint32_t cspt14 : 3; /* [14:12] */
504 __IO uint32_t cspt15 : 3; /* [17:15] */
505 __IO uint32_t cspt16 : 3; /* [20:18] */
506 __IO uint32_t cspt17 : 3; /* [23:21] */
507 __IO uint32_t cspt18 : 3; /* [26:24] */
508 __IO uint32_t reserved1 : 5;/* [31:27] */
509 } spt1_bit;
510 };
511
515 union
516 {
517 __IO uint32_t spt2;
518 struct
519 {
520 __IO uint32_t cspt0 : 3;/* [2:0] */
521 __IO uint32_t cspt1 : 3;/* [5:3] */
522 __IO uint32_t cspt2 : 3;/* [8:6] */
523 __IO uint32_t cspt3 : 3;/* [11:9] */
524 __IO uint32_t cspt4 : 3;/* [14:12] */
525 __IO uint32_t cspt5 : 3;/* [17:15] */
526 __IO uint32_t cspt6 : 3;/* [20:18] */
527 __IO uint32_t cspt7 : 3;/* [23:21] */
528 __IO uint32_t cspt8 : 3;/* [26:24] */
529 __IO uint32_t cspt9 : 3;/* [29:27] */
530 __IO uint32_t reserved1 : 2;/* [31:30] */
531 } spt2_bit;
532 };
533
537 union
538 {
539 __IO uint32_t pcdto1;
540 struct
541 {
542 __IO uint32_t pcdto1 : 12; /* [11:0] */
543 __IO uint32_t reserved1 : 20; /* [31:12] */
544 } pcdto1_bit;
545 };
546
550 union
551 {
552 __IO uint32_t pcdto2;
553 struct
554 {
555 __IO uint32_t pcdto2 : 12; /* [11:0] */
556 __IO uint32_t reserved1 : 20; /* [31:12] */
557 } pcdto2_bit;
558 };
559
563 union
564 {
565 __IO uint32_t pcdto3;
566 struct
567 {
568 __IO uint32_t pcdto3 : 12; /* [11:0] */
569 __IO uint32_t reserved1 : 20; /* [31:12] */
570 } pcdto3_bit;
571 };
572
576 union
577 {
578 __IO uint32_t pcdto4;
579 struct
580 {
581 __IO uint32_t pcdto4 : 12; /* [11:0] */
582 __IO uint32_t reserved1 : 20; /* [31:12] */
583 } pcdto4_bit;
584 };
585
589 union
590 {
591 __IO uint32_t vmhb;
592 struct
593 {
594 __IO uint32_t vmhb : 12; /* [11:0] */
595 __IO uint32_t reserved1 : 20; /* [31:12] */
596 } vmhb_bit;
597 };
598
602 union
603 {
604 __IO uint32_t vmlb;
605 struct
606 {
607 __IO uint32_t vmlb : 12; /* [11:0] */
608 __IO uint32_t reserved1 : 20; /* [31:12] */
609 } vmlb_bit;
610 };
611
615 union
616 {
617 __IO uint32_t osq1;
618 struct
619 {
620 __IO uint32_t osn13 : 5; /* [4:0] */
621 __IO uint32_t osn14 : 5; /* [9:5] */
622 __IO uint32_t osn15 : 5; /* [14:10] */
623 __IO uint32_t osn16 : 5; /* [19:15] */
624 __IO uint32_t oclen : 4; /* [23:20] */
625 __IO uint32_t reserved1 : 8; /* [31:24] */
626 } osq1_bit;
627 };
628
632 union
633 {
634 __IO uint32_t osq2;
635 struct
636 {
637 __IO uint32_t osn7 : 5; /* [4:0] */
638 __IO uint32_t osn8 : 5; /* [9:5] */
639 __IO uint32_t osn9 : 5; /* [14:10] */
640 __IO uint32_t osn10 : 5; /* [19:15] */
641 __IO uint32_t osn11 : 5; /* [24:20] */
642 __IO uint32_t osn12 : 5; /* [29:25] */
643 __IO uint32_t reserved1 : 2; /* [31:30] */
644 } osq2_bit;
645 };
646
650 union
651 {
652 __IO uint32_t osq3;
653 struct
654 {
655 __IO uint32_t osn1 : 5; /* [4:0] */
656 __IO uint32_t osn2 : 5; /* [9:5] */
657 __IO uint32_t osn3 : 5; /* [14:10] */
658 __IO uint32_t osn4 : 5; /* [19:15] */
659 __IO uint32_t osn5 : 5; /* [24:20] */
660 __IO uint32_t osn6 : 5; /* [29:25] */
661 __IO uint32_t reserved1 : 2; /* [31:30] */
662 } osq3_bit;
663 };
664
668 union
669 {
670 __IO uint32_t psq;
671 struct
672 {
673 __IO uint32_t psn1 : 5; /* [4:0] */
674 __IO uint32_t psn2 : 5; /* [9:5] */
675 __IO uint32_t psn3 : 5; /* [14:10] */
676 __IO uint32_t psn4 : 5; /* [19:15] */
677 __IO uint32_t pclen : 2; /* [21:20] */
678 __IO uint32_t reserved1 : 10;/* [31:22] */
679 } psq_bit;
680 };
681
685 union
686 {
687 __IO uint32_t pdt1;
688 struct
689 {
690 __IO uint32_t pdt1 : 16; /* [15:0] */
691 __IO uint32_t reserved1 : 16; /* [31:16] */
692 } pdt1_bit;
693 };
694
698 union
699 {
700 __IO uint32_t pdt2;
701 struct
702 {
703 __IO uint32_t pdt2 : 16; /* [15:0] */
704 __IO uint32_t reserved1 : 16; /* [31:16] */
705 } pdt2_bit;
706 };
707
711 union
712 {
713 __IO uint32_t pdt3;
714 struct
715 {
716 __IO uint32_t pdt3 : 16; /* [15:0] */
717 __IO uint32_t reserved1 : 16; /* [31:16] */
718 } pdt3_bit;
719 };
720
724 union
725 {
726 __IO uint32_t pdt4;
727 struct
728 {
729 __IO uint32_t pdt4 : 16; /* [15:0] */
730 __IO uint32_t reserved1 : 16; /* [31:16] */
731 } pdt4_bit;
732 };
733
737 union
738 {
739 __IO uint32_t odt;
740 struct
741 {
742 __IO uint32_t odt : 16; /* [15:0] */
743 __IO uint32_t reserved1 : 16; /* [31:16] */
744 } odt_bit;
745 };
746
747 __IO uint32_t reserved1[12];
748
752 union
753 {
754 __IO uint32_t ovsp;
755 struct
756 {
757 __IO uint32_t oosen : 1; /* [0] */
758 __IO uint32_t posen : 1; /* [1] */
759 __IO uint32_t osrsel : 3; /* [4:2] */
760 __IO uint32_t osssel : 4; /* [8:5] */
761 __IO uint32_t oostren : 1; /* [9] */
762 __IO uint32_t oosrsel : 1; /* [10] */
763 __IO uint32_t reserved1 : 21; /* [31:11] */
764 } ovsp_bit;
765 };
766
767 __IO uint32_t reserved2[12];
768
772 union
773 {
774 __IO uint32_t calval;
775 struct
776 {
777 __IO uint32_t calval : 7; /* [6:0] */
778 __IO uint32_t reserved1 : 25; /* [31:7] */
779 } calval_bit;
780 };
781} adc_type;
782
786typedef struct
787{
788
792 union
793 {
794 __IO uint32_t csts;
795 struct
796 {
797 __IO uint32_t vmor1 : 1; /* [0] */
798 __IO uint32_t occe1 : 1; /* [1] */
799 __IO uint32_t pcce1 : 1; /* [2] */
800 __IO uint32_t pccs1 : 1; /* [3] */
801 __IO uint32_t occs1 : 1; /* [4] */
802 __IO uint32_t occo1 : 1; /* [5] */
803 __IO uint32_t rdy1 : 1; /* [6] */
804 __IO uint32_t reserved1 : 1; /* [7] */
805 __IO uint32_t vmor2 : 1; /* [8] */
806 __IO uint32_t occe2 : 1; /* [9] */
807 __IO uint32_t pcce2 : 1; /* [10] */
808 __IO uint32_t pccs2 : 1; /* [11] */
809 __IO uint32_t occs2 : 1; /* [12] */
810 __IO uint32_t occo2 : 1; /* [13] */
811 __IO uint32_t rdy2 : 1; /* [14] */
812 __IO uint32_t reserved2 : 1; /* [15] */
813 __IO uint32_t vmor3 : 1; /* [16] */
814 __IO uint32_t occe3 : 1; /* [17] */
815 __IO uint32_t pcce3 : 1; /* [18] */
816 __IO uint32_t pccs3 : 1; /* [19] */
817 __IO uint32_t occs3 : 1; /* [20] */
818 __IO uint32_t occo3 : 1; /* [21] */
819 __IO uint32_t rdy3 : 1; /* [22] */
820 __IO uint32_t reserved3 : 9; /* [31:23] */
821 } csts_bit;
822 };
823
827 union
828 {
829 __IO uint32_t cctrl;
830 struct
831 {
832 __IO uint32_t mssel : 5; /* [4_0] */
833 __IO uint32_t reserved1 : 3; /* [7:5] */
834 __IO uint32_t asisel : 4; /* [11:8] */
835 __IO uint32_t reserved2 : 1; /* [12] */
836 __IO uint32_t msdrcen : 1; /* [13] */
837 __IO uint32_t msdmasel_l : 2; /* [15:14] */
838 __IO uint32_t adcdiv : 4; /* [19:16] */
839 __IO uint32_t reserved3 : 2; /* [21:20] */
840 __IO uint32_t vbaten : 1; /* [22] */
841 __IO uint32_t itsrven : 1; /* [23] */
842 __IO uint32_t reserved4 : 4; /* [27:24] */
843 __IO uint32_t msdmasel_h : 1; /* [28] */
844 __IO uint32_t reserved5 : 3; /* [31:29] */
845 } cctrl_bit;
846 };
847
851 union
852 {
853 __IO uint32_t codt;
854 struct
855 {
856 __IO uint32_t codtl : 16; /* [15:0] */
857 __IO uint32_t codth : 16; /* [31:16] */
858 } codt_bit;
859 };
860} adccom_type;
861
866#define ADC1 ((adc_type *) ADC1_BASE)
867#define ADC2 ((adc_type *) ADC2_BASE)
868#define ADC3 ((adc_type *) ADC3_BASE)
869#define ADCCOM ((adccom_type *) ADCCOM_BASE)
870
875void adc_reset(void);
876void adc_enable(adc_type *adc_x, confirm_state new_state);
877void adc_base_default_para_init(adc_base_config_type *adc_base_struct);
878void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct);
879void adc_common_default_para_init(adc_common_config_type *adc_common_struct);
880void adc_common_config(adc_common_config_type *adc_common_struct);
881void adc_resolution_set(adc_type *adc_x, adc_resolution_type resolution);
882void adc_voltage_battery_enable(confirm_state new_state);
883void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state);
884void adc_dma_request_repeat_enable(adc_type *adc_x, confirm_state new_state);
885void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state);
886void adc_calibration_value_set(adc_type *adc_x, uint8_t adc_calibration_value);
887void adc_calibration_init(adc_type *adc_x);
888 flag_status adc_calibration_init_status_get(adc_type *adc_x);
889void adc_calibration_start(adc_type *adc_x);
890 flag_status adc_calibration_status_get(adc_type *adc_x);
891void adc_voltage_monitor_enable(adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring);
892void adc_voltage_monitor_threshold_value_set(adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold);
893void adc_voltage_monitor_single_channel_select(adc_type *adc_x, adc_channel_select_type adc_channel);
894void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime);
895void adc_preempt_channel_length_set(adc_type *adc_x, uint8_t adc_channel_lenght);
896void adc_preempt_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime);
897void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge);
898void adc_preempt_conversion_trigger_set(adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, adc_preempt_trig_edge_type adc_preempt_trig_edge);
899void adc_preempt_offset_value_set(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel, uint16_t adc_offset_value);
900void adc_ordinary_part_count_set(adc_type *adc_x, uint8_t adc_channel_count);
901void adc_ordinary_part_mode_enable(adc_type *adc_x, confirm_state new_state);
902void adc_preempt_part_mode_enable(adc_type *adc_x, confirm_state new_state);
903void adc_preempt_auto_mode_enable(adc_type *adc_x, confirm_state new_state);
904void adc_conversion_stop(adc_type *adc_x);
905 flag_status adc_conversion_stop_status_get(adc_type *adc_x);
906void adc_occe_each_conversion_enable(adc_type *adc_x, confirm_state new_state);
907void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state);
908 flag_status adc_ordinary_software_trigger_status_get(adc_type *adc_x);
909void adc_preempt_software_trigger_enable(adc_type *adc_x, confirm_state new_state);
910 flag_status adc_preempt_software_trigger_status_get(adc_type *adc_x);
911uint16_t adc_ordinary_conversion_data_get(adc_type *adc_x);
912uint32_t adc_combine_ordinary_conversion_data_get(void);
913uint16_t adc_preempt_conversion_data_get(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel);
914 flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag);
915void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag);
916void adc_ordinary_oversample_enable(adc_type *adc_x, confirm_state new_state);
917void adc_preempt_oversample_enable(adc_type *adc_x, confirm_state new_state);
918void adc_oversample_ratio_shift_set(adc_type *adc_x, adc_oversample_ratio_type adc_oversample_ratio, adc_oversample_shift_type adc_oversample_shift);
919void adc_ordinary_oversample_trig_enable(adc_type *adc_x, confirm_state new_state);
920void adc_ordinary_oversample_restart_set(adc_type *adc_x, adc_ordinary_oversample_restart_type adc_ordinary_oversample_restart);
921
934#ifdef __cplusplus
935}
936#endif
937
938#endif
at32f435_437.h
at32f435_437 header file
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:945
adc_voltage_monitor_enable
void adc_voltage_monitor_enable(adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring)
enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified ...
Definition: at32f435_437_adc.c:399
adc_voltage_monitor_single_channel_select
void adc_voltage_monitor_single_channel_select(adc_type *adc_x, adc_channel_select_type adc_channel)
select the voltage monitoring's channel of the specified adc peripheral.
Definition: at32f435_437_adc.c:440
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc ...
Definition: at32f435_437_adc.c:742
adc_ordinary_conversion_data_get
uint16_t adc_ordinary_conversion_data_get(adc_type *adc_x)
return the last conversion data for ordinary channel of the specified adc peripheral.
Definition: at32f435_437_adc.c:1009
adc_preempt_offset_value_set
void adc_preempt_offset_value_set(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel, uint16_t adc_offset_value)
set preempt channel's conversion value offset of the specified adc peripheral.
Definition: at32f435_437_adc.c:812
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f435_437_adc.c:110
adc_ordinary_software_trigger_status_get
flag_status adc_ordinary_software_trigger_status_get(adc_type *adc_x)
get ordinary software start conversion status of the specified adc peripheral.
Definition: at32f435_437_adc.c:957
adc_voltage_battery_enable
void adc_voltage_battery_enable(confirm_state new_state)
enable or disable the adc voltage battery.
Definition: at32f435_437_adc.c:246
adc_preempt_auto_mode_enable
void adc_preempt_auto_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable automatic preempt group conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:886
adc_preempt_software_trigger_status_get
flag_status adc_preempt_software_trigger_status_get(adc_type *adc_x)
get preempt software start conversion status of the specified adc peripheral.
Definition: at32f435_437_adc.c:990
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f435_437_adc.c:64
adc_ordinary_part_count_set
void adc_ordinary_part_count_set(adc_type *adc_x, uint8_t adc_channel_count)
set partitioned mode channel count of the specified adc peripheral.
Definition: at32f435_437_adc.c:843
adc_preempt_conversion_data_get
uint16_t adc_preempt_conversion_data_get(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral.
Definition: at32f435_437_adc.c:1036
adc_ordinary_oversample_enable
void adc_ordinary_oversample_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the ordinary oversampling of the specified adc peripheral.
Definition: at32f435_437_adc.c:1120
adc_oversample_ratio_shift_set
void adc_oversample_ratio_shift_set(adc_type *adc_x, adc_oversample_ratio_type adc_oversample_ratio, adc_oversample_shift_type adc_oversample_shift)
config the oversampling ratio and shift of the specified adc peripheral.
Definition: at32f435_437_adc.c:1167
adc_preempt_oversample_enable
void adc_preempt_oversample_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the preempt oversampling of the specified adc peripheral.
Definition: at32f435_437_adc.c:1134
adc_preempt_conversion_trigger_set
void adc_preempt_conversion_trigger_set(adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, adc_preempt_trig_edge_type adc_preempt_trig_edge)
enable or disable the preempt channel's external trigger and set external trigger event of the specif...
Definition: at32f435_437_adc.c:781
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1106
adc_common_config
void adc_common_config(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:203
adc_conversion_stop_status_get
flag_status adc_conversion_stop_status_get(adc_type *adc_x)
get stop conversion's status of the specified adc peripheral.
Definition: at32f435_437_adc.c:910
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f435_437_adc.c:294
adc_resolution_set
void adc_resolution_set(adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral.
Definition: at32f435_437_adc.c:235
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f435_437_adc.c:84
adc_ordinary_oversample_trig_enable
void adc_ordinary_oversample_trig_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the ordinary oversampling trigger mode of the specified adc peripheral.
Definition: at32f435_437_adc.c:1182
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f435_437_adc.c:359
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f435_437_adc.c:371
adc_dma_request_repeat_enable
void adc_dma_request_repeat_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat.
Definition: at32f435_437_adc.c:274
adc_ordinary_oversample_restart_set
void adc_ordinary_oversample_restart_set(adc_type *adc_x, adc_ordinary_oversample_restart_type adc_ordinary_oversample_restart)
set ordinary oversample restart mode of the specified adc peripheral.
Definition: at32f435_437_adc.c:1198
adc_calibration_value_set
void adc_calibration_value_set(adc_type *adc_x, uint8_t adc_calibration_value)
set calibration value of the specified adc peripheral.
Definition: at32f435_437_adc.c:316
adc_reset
void adc_reset(void)
deinitialize the adc peripheral registers to their default reset values.
Definition: at32f435_437_adc.c:49
adc_voltage_monitor_threshold_value_set
void adc_voltage_monitor_threshold_value_set(adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold)
set voltage monitoring's high and low thresholds value of the specified adc peripheral.
Definition: at32f435_437_adc.c:420
adc_preempt_part_mode_enable
void adc_preempt_part_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on preempt channel of the specified adc peripheral.
Definition: at32f435_437_adc.c:872
adc_conversion_stop
void adc_conversion_stop(adc_type *adc_x)
stop the ongoing conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:898
adc_occe_each_conversion_enable
void adc_occe_each_conversion_enable(adc_type *adc_x, confirm_state new_state)
enable or disable each ordinary channel conversion set occe flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:931
adc_combine_ordinary_conversion_data_get
uint32_t adc_combine_ordinary_conversion_data_get(void)
return the last ordinary conversion data of combine adc.
Definition: at32f435_437_adc.c:1018
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f435_437_adc.c:328
adc_preempt_channel_set
void adc_preempt_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc ...
Definition: at32f435_437_adc.c:633
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f435_437_adc.c:340
adc_ordinary_part_mode_enable
void adc_ordinary_part_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on ordinary channel of the specified adc peripheral.
Definition: at32f435_437_adc.c:858
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f435_437_adc.c:260
adc_preempt_channel_length_set
void adc_preempt_channel_length_set(adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral.
Definition: at32f435_437_adc.c:601
adc_common_default_para_init
void adc_common_default_para_init(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:155
adc_preempt_software_trigger_enable
void adc_preempt_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable preempt software start conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:978
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f435_437_adc.c:472
adc_voltage_monitoring_type
adc_voltage_monitoring_type
adc voltage_monitoring type
Definition: at32f435_437_adc.h:334
adc_data_align_type
adc_data_align_type
adc data align type
Definition: at32f435_437_adc.h:177
adc_channel_select_type
adc_channel_select_type
adc channel select type
Definition: at32f435_437_adc.h:186
adc_sampletime_select_type
adc_sampletime_select_type
adc sampletime select type
Definition: at32f435_437_adc.h:212
adc_sampling_interval_type
adc_sampling_interval_type
adc common sampling interval type
Definition: at32f435_437_adc.h:143
adc_oversample_shift_type
adc_oversample_shift_type
adc oversample shift type
Definition: at32f435_437_adc.h:363
adc_common_dma_mode_type
adc_common_dma_mode_type
adc common dma mode type
Definition: at32f435_437_adc.h:130
adc_preempt_trig_select_type
adc_preempt_trig_select_type
adc preempt group external trigger event select type
Definition: at32f435_437_adc.h:275
adc_combine_mode_type
adc_combine_mode_type
adc combine mode type
Definition: at32f435_437_adc.h:110
adc_ordinary_trig_select_type
adc_ordinary_trig_select_type
adc ordinary group trigger event select type
Definition: at32f435_437_adc.h:227
adc_preempt_trig_edge_type
adc_preempt_trig_edge_type
adc preempt channel conversion's external_trigger_edge type
Definition: at32f435_437_adc.h:312
adc_oversample_ratio_type
adc_oversample_ratio_type
adc oversample ratio type
Definition: at32f435_437_adc.h:348
adc_ordinary_trig_edge_type
adc_ordinary_trig_edge_type
adc ordinary channel conversion's external_trigger_edge type
Definition: at32f435_437_adc.h:264
adc_resolution_type
adc_resolution_type
adc conversion resolution type
Definition: at32f435_437_adc.h:166
adc_preempt_channel_type
adc_preempt_channel_type
adc preempt channel type
Definition: at32f435_437_adc.h:323
adc_ordinary_oversample_restart_type
adc_ordinary_oversample_restart_type
adc ordinary oversample recover type
Definition: at32f435_437_adc.h:379
adc_div_type
adc_div_type
adc division type
Definition: at32f435_437_adc.h:87
ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT
@ ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT
Definition: at32f435_437_adc.h:337
ADC_VMONITOR_SINGLE_ORDINARY
@ ADC_VMONITOR_SINGLE_ORDINARY
Definition: at32f435_437_adc.h:335
ADC_VMONITOR_ALL_ORDINARY
@ ADC_VMONITOR_ALL_ORDINARY
Definition: at32f435_437_adc.h:338
ADC_VMONITOR_ALL_PREEMPT
@ ADC_VMONITOR_ALL_PREEMPT
Definition: at32f435_437_adc.h:339
ADC_VMONITOR_ALL_ORDINARY_PREEMPT
@ ADC_VMONITOR_ALL_ORDINARY_PREEMPT
Definition: at32f435_437_adc.h:340
ADC_VMONITOR_NONE
@ ADC_VMONITOR_NONE
Definition: at32f435_437_adc.h:341
ADC_VMONITOR_SINGLE_PREEMPT
@ ADC_VMONITOR_SINGLE_PREEMPT
Definition: at32f435_437_adc.h:336
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f435_437_adc.h:178
ADC_LEFT_ALIGNMENT
@ ADC_LEFT_ALIGNMENT
Definition: at32f435_437_adc.h:179
ADC_CHANNEL_9
@ ADC_CHANNEL_9
Definition: at32f435_437_adc.h:196
ADC_CHANNEL_1
@ ADC_CHANNEL_1
Definition: at32f435_437_adc.h:188
ADC_CHANNEL_17
@ ADC_CHANNEL_17
Definition: at32f435_437_adc.h:204
ADC_CHANNEL_8
@ ADC_CHANNEL_8
Definition: at32f435_437_adc.h:195
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f435_437_adc.h:191
ADC_CHANNEL_12
@ ADC_CHANNEL_12
Definition: at32f435_437_adc.h:199
ADC_CHANNEL_16
@ ADC_CHANNEL_16
Definition: at32f435_437_adc.h:203
ADC_CHANNEL_0
@ ADC_CHANNEL_0
Definition: at32f435_437_adc.h:187
ADC_CHANNEL_3
@ ADC_CHANNEL_3
Definition: at32f435_437_adc.h:190
ADC_CHANNEL_14
@ ADC_CHANNEL_14
Definition: at32f435_437_adc.h:201
ADC_CHANNEL_10
@ ADC_CHANNEL_10
Definition: at32f435_437_adc.h:197
ADC_CHANNEL_13
@ ADC_CHANNEL_13
Definition: at32f435_437_adc.h:200
ADC_CHANNEL_2
@ ADC_CHANNEL_2
Definition: at32f435_437_adc.h:189
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f435_437_adc.h:193
ADC_CHANNEL_7
@ ADC_CHANNEL_7
Definition: at32f435_437_adc.h:194
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f435_437_adc.h:192
ADC_CHANNEL_18
@ ADC_CHANNEL_18
Definition: at32f435_437_adc.h:205
ADC_CHANNEL_11
@ ADC_CHANNEL_11
Definition: at32f435_437_adc.h:198
ADC_CHANNEL_15
@ ADC_CHANNEL_15
Definition: at32f435_437_adc.h:202
ADC_SAMPLETIME_47_5
@ ADC_SAMPLETIME_47_5
Definition: at32f435_437_adc.h:217
ADC_SAMPLETIME_92_5
@ ADC_SAMPLETIME_92_5
Definition: at32f435_437_adc.h:218
ADC_SAMPLETIME_12_5
@ ADC_SAMPLETIME_12_5
Definition: at32f435_437_adc.h:215
ADC_SAMPLETIME_24_5
@ ADC_SAMPLETIME_24_5
Definition: at32f435_437_adc.h:216
ADC_SAMPLETIME_2_5
@ ADC_SAMPLETIME_2_5
Definition: at32f435_437_adc.h:213
ADC_SAMPLETIME_640_5
@ ADC_SAMPLETIME_640_5
Definition: at32f435_437_adc.h:220
ADC_SAMPLETIME_247_5
@ ADC_SAMPLETIME_247_5
Definition: at32f435_437_adc.h:219
ADC_SAMPLETIME_6_5
@ ADC_SAMPLETIME_6_5
Definition: at32f435_437_adc.h:214
ADC_SAMPLING_INTERVAL_6CYCLES
@ ADC_SAMPLING_INTERVAL_6CYCLES
Definition: at32f435_437_adc.h:145
ADC_SAMPLING_INTERVAL_19CYCLES
@ ADC_SAMPLING_INTERVAL_19CYCLES
Definition: at32f435_437_adc.h:158
ADC_SAMPLING_INTERVAL_8CYCLES
@ ADC_SAMPLING_INTERVAL_8CYCLES
Definition: at32f435_437_adc.h:147
ADC_SAMPLING_INTERVAL_12CYCLES
@ ADC_SAMPLING_INTERVAL_12CYCLES
Definition: at32f435_437_adc.h:151
ADC_SAMPLING_INTERVAL_20CYCLES
@ ADC_SAMPLING_INTERVAL_20CYCLES
Definition: at32f435_437_adc.h:159
ADC_SAMPLING_INTERVAL_10CYCLES
@ ADC_SAMPLING_INTERVAL_10CYCLES
Definition: at32f435_437_adc.h:149
ADC_SAMPLING_INTERVAL_9CYCLES
@ ADC_SAMPLING_INTERVAL_9CYCLES
Definition: at32f435_437_adc.h:148
ADC_SAMPLING_INTERVAL_18CYCLES
@ ADC_SAMPLING_INTERVAL_18CYCLES
Definition: at32f435_437_adc.h:157
ADC_SAMPLING_INTERVAL_15CYCLES
@ ADC_SAMPLING_INTERVAL_15CYCLES
Definition: at32f435_437_adc.h:154
ADC_SAMPLING_INTERVAL_14CYCLES
@ ADC_SAMPLING_INTERVAL_14CYCLES
Definition: at32f435_437_adc.h:153
ADC_SAMPLING_INTERVAL_11CYCLES
@ ADC_SAMPLING_INTERVAL_11CYCLES
Definition: at32f435_437_adc.h:150
ADC_SAMPLING_INTERVAL_7CYCLES
@ ADC_SAMPLING_INTERVAL_7CYCLES
Definition: at32f435_437_adc.h:146
ADC_SAMPLING_INTERVAL_16CYCLES
@ ADC_SAMPLING_INTERVAL_16CYCLES
Definition: at32f435_437_adc.h:155
ADC_SAMPLING_INTERVAL_5CYCLES
@ ADC_SAMPLING_INTERVAL_5CYCLES
Definition: at32f435_437_adc.h:144
ADC_SAMPLING_INTERVAL_13CYCLES
@ ADC_SAMPLING_INTERVAL_13CYCLES
Definition: at32f435_437_adc.h:152
ADC_SAMPLING_INTERVAL_17CYCLES
@ ADC_SAMPLING_INTERVAL_17CYCLES
Definition: at32f435_437_adc.h:156
ADC_OVERSAMPLE_SHIFT_3
@ ADC_OVERSAMPLE_SHIFT_3
Definition: at32f435_437_adc.h:367
ADC_OVERSAMPLE_SHIFT_4
@ ADC_OVERSAMPLE_SHIFT_4
Definition: at32f435_437_adc.h:368
ADC_OVERSAMPLE_SHIFT_7
@ ADC_OVERSAMPLE_SHIFT_7
Definition: at32f435_437_adc.h:371
ADC_OVERSAMPLE_SHIFT_0
@ ADC_OVERSAMPLE_SHIFT_0
Definition: at32f435_437_adc.h:364
ADC_OVERSAMPLE_SHIFT_8
@ ADC_OVERSAMPLE_SHIFT_8
Definition: at32f435_437_adc.h:372
ADC_OVERSAMPLE_SHIFT_2
@ ADC_OVERSAMPLE_SHIFT_2
Definition: at32f435_437_adc.h:366
ADC_OVERSAMPLE_SHIFT_1
@ ADC_OVERSAMPLE_SHIFT_1
Definition: at32f435_437_adc.h:365
ADC_OVERSAMPLE_SHIFT_6
@ ADC_OVERSAMPLE_SHIFT_6
Definition: at32f435_437_adc.h:370
ADC_OVERSAMPLE_SHIFT_5
@ ADC_OVERSAMPLE_SHIFT_5
Definition: at32f435_437_adc.h:369
ADC_COMMON_DMAMODE_4
@ ADC_COMMON_DMAMODE_4
Definition: at32f435_437_adc.h:135
ADC_COMMON_DMAMODE_DISABLE
@ ADC_COMMON_DMAMODE_DISABLE
Definition: at32f435_437_adc.h:131
ADC_COMMON_DMAMODE_5
@ ADC_COMMON_DMAMODE_5
Definition: at32f435_437_adc.h:136
ADC_COMMON_DMAMODE_1
@ ADC_COMMON_DMAMODE_1
Definition: at32f435_437_adc.h:132
ADC_COMMON_DMAMODE_2
@ ADC_COMMON_DMAMODE_2
Definition: at32f435_437_adc.h:133
ADC_COMMON_DMAMODE_3
@ ADC_COMMON_DMAMODE_3
Definition: at32f435_437_adc.h:134
ADC_PREEMPT_TRIG_TMR4CH1
@ ADC_PREEMPT_TRIG_TMR4CH1
Definition: at32f435_437_adc.h:282
ADC_PREEMPT_TRIG_TMR8CH3
@ ADC_PREEMPT_TRIG_TMR8CH3
Definition: at32f435_437_adc.h:289
ADC_PREEMPT_TRIG_TMR6TRGOUT
@ ADC_PREEMPT_TRIG_TMR6TRGOUT
Definition: at32f435_437_adc.h:301
ADC_PREEMPT_TRIG_TMR5TRGOUT
@ ADC_PREEMPT_TRIG_TMR5TRGOUT
Definition: at32f435_437_adc.h:287
ADC_PREEMPT_TRIG_TMR4CH3
@ ADC_PREEMPT_TRIG_TMR4CH3
Definition: at32f435_437_adc.h:284
ADC_PREEMPT_TRIG_TMR1CH4
@ ADC_PREEMPT_TRIG_TMR1CH4
Definition: at32f435_437_adc.h:276
ADC_PREEMPT_TRIG_TMR20CH2
@ ADC_PREEMPT_TRIG_TMR20CH2
Definition: at32f435_437_adc.h:304
ADC_PREEMPT_TRIG_TMR1CH3
@ ADC_PREEMPT_TRIG_TMR1CH3
Definition: at32f435_437_adc.h:303
ADC_PREEMPT_TRIG_TMR8CH4
@ ADC_PREEMPT_TRIG_TMR8CH4
Definition: at32f435_437_adc.h:290
ADC_PREEMPT_TRIG_TMR8TRGOUT
@ ADC_PREEMPT_TRIG_TMR8TRGOUT
Definition: at32f435_437_adc.h:296
ADC_PREEMPT_TRIG_TMR1TRGOUT
@ ADC_PREEMPT_TRIG_TMR1TRGOUT
Definition: at32f435_437_adc.h:277
ADC_PREEMPT_TRIG_TMR8CH2
@ ADC_PREEMPT_TRIG_TMR8CH2
Definition: at32f435_437_adc.h:288
ADC_PREEMPT_TRIG_TMR7TRGOUT
@ ADC_PREEMPT_TRIG_TMR7TRGOUT
Definition: at32f435_437_adc.h:305
ADC_PREEMPT_TRIG_TMR8TRGOUT2
@ ADC_PREEMPT_TRIG_TMR8TRGOUT2
Definition: at32f435_437_adc.h:297
ADC_PREEMPT_TRIG_TMR2TRGOUT
@ ADC_PREEMPT_TRIG_TMR2TRGOUT
Definition: at32f435_437_adc.h:279
ADC_PREEMPT_TRIG_EXINT15
@ ADC_PREEMPT_TRIG_EXINT15
Definition: at32f435_437_adc.h:291
ADC_PREEMPT_TRIG_TMR5CH4
@ ADC_PREEMPT_TRIG_TMR5CH4
Definition: at32f435_437_adc.h:286
ADC_PREEMPT_TRIG_TMR4TRGOUT
@ ADC_PREEMPT_TRIG_TMR4TRGOUT
Definition: at32f435_437_adc.h:285
ADC_PREEMPT_TRIG_TMR3CH4
@ ADC_PREEMPT_TRIG_TMR3CH4
Definition: at32f435_437_adc.h:281
ADC_PREEMPT_TRIG_TMR3TRGOUT
@ ADC_PREEMPT_TRIG_TMR3TRGOUT
Definition: at32f435_437_adc.h:299
ADC_PREEMPT_TRIG_TMR20CH4
@ ADC_PREEMPT_TRIG_TMR20CH4
Definition: at32f435_437_adc.h:294
ADC_PREEMPT_TRIG_TMR2CH1
@ ADC_PREEMPT_TRIG_TMR2CH1
Definition: at32f435_437_adc.h:278
ADC_PREEMPT_TRIG_TMR20TRGOUT
@ ADC_PREEMPT_TRIG_TMR20TRGOUT
Definition: at32f435_437_adc.h:292
ADC_PREEMPT_TRIG_TMR4CH4
@ ADC_PREEMPT_TRIG_TMR4CH4
Definition: at32f435_437_adc.h:302
ADC_PREEMPT_TRIG_TMR3CH3
@ ADC_PREEMPT_TRIG_TMR3CH3
Definition: at32f435_437_adc.h:298
ADC_PREEMPT_TRIG_TMR20TRGOUT2
@ ADC_PREEMPT_TRIG_TMR20TRGOUT2
Definition: at32f435_437_adc.h:293
ADC_PREEMPT_TRIG_TMR4CH2
@ ADC_PREEMPT_TRIG_TMR4CH2
Definition: at32f435_437_adc.h:283
ADC_PREEMPT_TRIG_TMR3CH2
@ ADC_PREEMPT_TRIG_TMR3CH2
Definition: at32f435_437_adc.h:280
ADC_PREEMPT_TRIG_TMR1TRGOUT2
@ ADC_PREEMPT_TRIG_TMR1TRGOUT2
Definition: at32f435_437_adc.h:295
ADC_PREEMPT_TRIG_TMR3CH1
@ ADC_PREEMPT_TRIG_TMR3CH1
Definition: at32f435_437_adc.h:300
ADC_PREEMPT_SMLT_ONLY_ONESLAVE_MODE
@ ADC_PREEMPT_SMLT_ONLY_ONESLAVE_MODE
Definition: at32f435_437_adc.h:114
ADC_PREEMPT_INTERLTRIG_ONLY_TWOSLAVE_MODE
@ ADC_PREEMPT_INTERLTRIG_ONLY_TWOSLAVE_MODE
Definition: at32f435_437_adc.h:123
ADC_ORDINARY_SMLT_ONLY_TWOSLAVE_MODE
@ ADC_ORDINARY_SMLT_ONLY_TWOSLAVE_MODE
Definition: at32f435_437_adc.h:121
ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_TWOSLAVE_MODE
@ ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_TWOSLAVE_MODE
Definition: at32f435_437_adc.h:119
ADC_PREEMPT_INTERLTRIG_ONLY_ONESLAVE_MODE
@ ADC_PREEMPT_INTERLTRIG_ONLY_ONESLAVE_MODE
Definition: at32f435_437_adc.h:117
ADC_ORDINARY_SHIFT_ONLY_TWOSLAVE_MODE
@ ADC_ORDINARY_SHIFT_ONLY_TWOSLAVE_MODE
Definition: at32f435_437_adc.h:122
ADC_ORDINARY_SMLT_PREEMPT_SMLT_TWOSLAVE_MODE
@ ADC_ORDINARY_SMLT_PREEMPT_SMLT_TWOSLAVE_MODE
Definition: at32f435_437_adc.h:118
ADC_PREEMPT_SMLT_ONLY_TWOSLAVE_MODE
@ ADC_PREEMPT_SMLT_ONLY_TWOSLAVE_MODE
Definition: at32f435_437_adc.h:120
ADC_ORDINARY_SMLT_PREEMPT_SMLT_ONESLAVE_MODE
@ ADC_ORDINARY_SMLT_PREEMPT_SMLT_ONESLAVE_MODE
Definition: at32f435_437_adc.h:112
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f435_437_adc.h:111
ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_ONESLAVE_MODE
@ ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_ONESLAVE_MODE
Definition: at32f435_437_adc.h:113
ADC_ORDINARY_SHIFT_ONLY_ONESLAVE_MODE
@ ADC_ORDINARY_SHIFT_ONLY_ONESLAVE_MODE
Definition: at32f435_437_adc.h:116
ADC_ORDINARY_SMLT_ONLY_ONESLAVE_MODE
@ ADC_ORDINARY_SMLT_ONLY_ONESLAVE_MODE
Definition: at32f435_437_adc.h:115
ADC_ORDINARY_TRIG_TMR6TRGOUT
@ ADC_ORDINARY_TRIG_TMR6TRGOUT
Definition: at32f435_437_adc.h:252
ADC_ORDINARY_TRIG_TMR4CH1
@ ADC_ORDINARY_TRIG_TMR4CH1
Definition: at32f435_437_adc.h:254
ADC_ORDINARY_TRIG_TMR20CH1
@ ADC_ORDINARY_TRIG_TMR20CH1
Definition: at32f435_437_adc.h:246
ADC_ORDINARY_TRIG_TMR2CH1
@ ADC_ORDINARY_TRIG_TMR2CH1
Definition: at32f435_437_adc.h:256
ADC_ORDINARY_TRIG_TMR20CH3
@ ADC_ORDINARY_TRIG_TMR20CH3
Definition: at32f435_437_adc.h:248
ADC_ORDINARY_TRIG_TMR1TRGOUT
@ ADC_ORDINARY_TRIG_TMR1TRGOUT
Definition: at32f435_437_adc.h:255
ADC_ORDINARY_TRIG_TMR4TRGOUT
@ ADC_ORDINARY_TRIG_TMR4TRGOUT
Definition: at32f435_437_adc.h:251
ADC_ORDINARY_TRIG_TMR5CH1
@ ADC_ORDINARY_TRIG_TMR5CH1
Definition: at32f435_437_adc.h:238
ADC_ORDINARY_TRIG_TMR8CH1
@ ADC_ORDINARY_TRIG_TMR8CH1
Definition: at32f435_437_adc.h:241
ADC_ORDINARY_TRIG_TMR1CH2
@ ADC_ORDINARY_TRIG_TMR1CH2
Definition: at32f435_437_adc.h:229
ADC_ORDINARY_TRIG_TMR1CH1
@ ADC_ORDINARY_TRIG_TMR1CH1
Definition: at32f435_437_adc.h:228
ADC_ORDINARY_TRIG_TMR20CH2
@ ADC_ORDINARY_TRIG_TMR20CH2
Definition: at32f435_437_adc.h:247
ADC_ORDINARY_TRIG_TMR2TRGOUT
@ ADC_ORDINARY_TRIG_TMR2TRGOUT
Definition: at32f435_437_adc.h:234
ADC_ORDINARY_TRIG_TMR2CH2
@ ADC_ORDINARY_TRIG_TMR2CH2
Definition: at32f435_437_adc.h:231
ADC_ORDINARY_TRIG_TMR7TRGOUT
@ ADC_ORDINARY_TRIG_TMR7TRGOUT
Definition: at32f435_437_adc.h:257
ADC_ORDINARY_TRIG_EXINT11
@ ADC_ORDINARY_TRIG_EXINT11
Definition: at32f435_437_adc.h:243
ADC_ORDINARY_TRIG_TMR5CH2
@ ADC_ORDINARY_TRIG_TMR5CH2
Definition: at32f435_437_adc.h:239
ADC_ORDINARY_TRIG_TMR3CH4
@ ADC_ORDINARY_TRIG_TMR3CH4
Definition: at32f435_437_adc.h:253
ADC_ORDINARY_TRIG_TMR8TRGOUT2
@ ADC_ORDINARY_TRIG_TMR8TRGOUT2
Definition: at32f435_437_adc.h:249
ADC_ORDINARY_TRIG_TMR3TRGOUT
@ ADC_ORDINARY_TRIG_TMR3TRGOUT
Definition: at32f435_437_adc.h:236
ADC_ORDINARY_TRIG_TMR3CH1
@ ADC_ORDINARY_TRIG_TMR3CH1
Definition: at32f435_437_adc.h:235
ADC_ORDINARY_TRIG_TMR8TRGOUT
@ ADC_ORDINARY_TRIG_TMR8TRGOUT
Definition: at32f435_437_adc.h:242
ADC_ORDINARY_TRIG_TMR2CH4
@ ADC_ORDINARY_TRIG_TMR2CH4
Definition: at32f435_437_adc.h:233
ADC_ORDINARY_TRIG_TMR20TRGOUT2
@ ADC_ORDINARY_TRIG_TMR20TRGOUT2
Definition: at32f435_437_adc.h:245
ADC_ORDINARY_TRIG_TMR20TRGOUT
@ ADC_ORDINARY_TRIG_TMR20TRGOUT
Definition: at32f435_437_adc.h:244
ADC_ORDINARY_TRIG_TMR5CH3
@ ADC_ORDINARY_TRIG_TMR5CH3
Definition: at32f435_437_adc.h:240
ADC_ORDINARY_TRIG_TMR1TRGOUT2
@ ADC_ORDINARY_TRIG_TMR1TRGOUT2
Definition: at32f435_437_adc.h:250
ADC_ORDINARY_TRIG_TMR1CH3
@ ADC_ORDINARY_TRIG_TMR1CH3
Definition: at32f435_437_adc.h:230
ADC_ORDINARY_TRIG_TMR2CH3
@ ADC_ORDINARY_TRIG_TMR2CH3
Definition: at32f435_437_adc.h:232
ADC_ORDINARY_TRIG_TMR4CH4
@ ADC_ORDINARY_TRIG_TMR4CH4
Definition: at32f435_437_adc.h:237
ADC_PREEMPT_TRIG_EDGE_NONE
@ ADC_PREEMPT_TRIG_EDGE_NONE
Definition: at32f435_437_adc.h:313
ADC_PREEMPT_TRIG_EDGE_FALLING
@ ADC_PREEMPT_TRIG_EDGE_FALLING
Definition: at32f435_437_adc.h:315
ADC_PREEMPT_TRIG_EDGE_RISING_FALLING
@ ADC_PREEMPT_TRIG_EDGE_RISING_FALLING
Definition: at32f435_437_adc.h:316
ADC_PREEMPT_TRIG_EDGE_RISING
@ ADC_PREEMPT_TRIG_EDGE_RISING
Definition: at32f435_437_adc.h:314
ADC_OVERSAMPLE_RATIO_2
@ ADC_OVERSAMPLE_RATIO_2
Definition: at32f435_437_adc.h:349
ADC_OVERSAMPLE_RATIO_256
@ ADC_OVERSAMPLE_RATIO_256
Definition: at32f435_437_adc.h:356
ADC_OVERSAMPLE_RATIO_8
@ ADC_OVERSAMPLE_RATIO_8
Definition: at32f435_437_adc.h:351
ADC_OVERSAMPLE_RATIO_64
@ ADC_OVERSAMPLE_RATIO_64
Definition: at32f435_437_adc.h:354
ADC_OVERSAMPLE_RATIO_32
@ ADC_OVERSAMPLE_RATIO_32
Definition: at32f435_437_adc.h:353
ADC_OVERSAMPLE_RATIO_16
@ ADC_OVERSAMPLE_RATIO_16
Definition: at32f435_437_adc.h:352
ADC_OVERSAMPLE_RATIO_4
@ ADC_OVERSAMPLE_RATIO_4
Definition: at32f435_437_adc.h:350
ADC_OVERSAMPLE_RATIO_128
@ ADC_OVERSAMPLE_RATIO_128
Definition: at32f435_437_adc.h:355
ADC_ORDINARY_TRIG_EDGE_RISING
@ ADC_ORDINARY_TRIG_EDGE_RISING
Definition: at32f435_437_adc.h:266
ADC_ORDINARY_TRIG_EDGE_FALLING
@ ADC_ORDINARY_TRIG_EDGE_FALLING
Definition: at32f435_437_adc.h:267
ADC_ORDINARY_TRIG_EDGE_NONE
@ ADC_ORDINARY_TRIG_EDGE_NONE
Definition: at32f435_437_adc.h:265
ADC_ORDINARY_TRIG_EDGE_RISING_FALLING
@ ADC_ORDINARY_TRIG_EDGE_RISING_FALLING
Definition: at32f435_437_adc.h:268
ADC_RESOLUTION_6B
@ ADC_RESOLUTION_6B
Definition: at32f435_437_adc.h:170
ADC_RESOLUTION_10B
@ ADC_RESOLUTION_10B
Definition: at32f435_437_adc.h:168
ADC_RESOLUTION_12B
@ ADC_RESOLUTION_12B
Definition: at32f435_437_adc.h:167
ADC_RESOLUTION_8B
@ ADC_RESOLUTION_8B
Definition: at32f435_437_adc.h:169
ADC_PREEMPT_CHANNEL_3
@ ADC_PREEMPT_CHANNEL_3
Definition: at32f435_437_adc.h:326
ADC_PREEMPT_CHANNEL_4
@ ADC_PREEMPT_CHANNEL_4
Definition: at32f435_437_adc.h:327
ADC_PREEMPT_CHANNEL_2
@ ADC_PREEMPT_CHANNEL_2
Definition: at32f435_437_adc.h:325
ADC_PREEMPT_CHANNEL_1
@ ADC_PREEMPT_CHANNEL_1
Definition: at32f435_437_adc.h:324
ADC_OVERSAMPLE_RESTART
@ ADC_OVERSAMPLE_RESTART
Definition: at32f435_437_adc.h:381
ADC_OVERSAMPLE_CONTINUE
@ ADC_OVERSAMPLE_CONTINUE
Definition: at32f435_437_adc.h:380
ADC_HCLK_DIV_17
@ ADC_HCLK_DIV_17
Definition: at32f435_437_adc.h:103
ADC_HCLK_DIV_5
@ ADC_HCLK_DIV_5
Definition: at32f435_437_adc.h:91
ADC_HCLK_DIV_12
@ ADC_HCLK_DIV_12
Definition: at32f435_437_adc.h:98
ADC_HCLK_DIV_10
@ ADC_HCLK_DIV_10
Definition: at32f435_437_adc.h:96
ADC_HCLK_DIV_4
@ ADC_HCLK_DIV_4
Definition: at32f435_437_adc.h:90
ADC_HCLK_DIV_7
@ ADC_HCLK_DIV_7
Definition: at32f435_437_adc.h:93
ADC_HCLK_DIV_8
@ ADC_HCLK_DIV_8
Definition: at32f435_437_adc.h:94
ADC_HCLK_DIV_13
@ ADC_HCLK_DIV_13
Definition: at32f435_437_adc.h:99
ADC_HCLK_DIV_6
@ ADC_HCLK_DIV_6
Definition: at32f435_437_adc.h:92
ADC_HCLK_DIV_9
@ ADC_HCLK_DIV_9
Definition: at32f435_437_adc.h:95
ADC_HCLK_DIV_11
@ ADC_HCLK_DIV_11
Definition: at32f435_437_adc.h:97
ADC_HCLK_DIV_2
@ ADC_HCLK_DIV_2
Definition: at32f435_437_adc.h:88
ADC_HCLK_DIV_3
@ ADC_HCLK_DIV_3
Definition: at32f435_437_adc.h:89
ADC_HCLK_DIV_15
@ ADC_HCLK_DIV_15
Definition: at32f435_437_adc.h:101
ADC_HCLK_DIV_16
@ ADC_HCLK_DIV_16
Definition: at32f435_437_adc.h:102
ADC_HCLK_DIV_14
@ ADC_HCLK_DIV_14
Definition: at32f435_437_adc.h:100
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
adc_base_config_type
adc base config type
Definition: at32f435_437_adc.h:402
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f435_437_adc.h:405
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f435_437_adc.h:404
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f435_437_adc.h:403
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f435_437_adc.h:406
adc_common_config_type
adc common config type
Definition: at32f435_437_adc.h:388
adc_common_config_type::sampling_interval
adc_sampling_interval_type sampling_interval
Definition: at32f435_437_adc.h:393
adc_common_config_type::tempervintrv_state
confirm_state tempervintrv_state
Definition: at32f435_437_adc.h:394
adc_common_config_type::div
adc_div_type div
Definition: at32f435_437_adc.h:390
adc_common_config_type::common_dma_mode
adc_common_dma_mode_type common_dma_mode
Definition: at32f435_437_adc.h:391
adc_common_config_type::common_dma_request_repeat_state
confirm_state common_dma_request_repeat_state
Definition: at32f435_437_adc.h:392
adc_common_config_type::combine_mode
adc_combine_mode_type combine_mode
Definition: at32f435_437_adc.h:389
adc_common_config_type::vbat_state
confirm_state vbat_state
Definition: at32f435_437_adc.h:395
adc_type
type define adc register all
Definition: at32f435_437_adc.h:413
adc_type::cspt1
__IO uint32_t cspt1
Definition: at32f435_437_adc.h:521
adc_type::pcce
__IO uint32_t pcce
Definition: at32f435_437_adc.h:425
adc_type::dtalign
__IO uint32_t dtalign
Definition: at32f435_437_adc.h:478
adc_type::osq2
__IO uint32_t osq2
Definition: at32f435_437_adc.h:634
adc_type::ocdmaen
__IO uint32_t ocdmaen
Definition: at32f435_437_adc.h:475
adc_type::ocswtrg
__IO uint32_t ocswtrg
Definition: at32f435_437_adc.h:486
adc_type::osn14
__IO uint32_t osn14
Definition: at32f435_437_adc.h:621
adc_type::rpen
__IO uint32_t rpen
Definition: at32f435_437_adc.h:470
adc_type::sqen
__IO uint32_t sqen
Definition: at32f435_437_adc.h:446
adc_type::pctesel_h
__IO uint32_t pctesel_h
Definition: at32f435_437_adc.h:483
adc_type::pdt4
__IO uint32_t pdt4
Definition: at32f435_437_adc.h:726
adc_type::cspt15
__IO uint32_t cspt15
Definition: at32f435_437_adc.h:504
adc_type::pclen
__IO uint32_t pclen
Definition: at32f435_437_adc.h:677
adc_type::vmcsel
__IO uint32_t vmcsel
Definition: at32f435_437_adc.h:442
adc_type::cspt7
__IO uint32_t cspt7
Definition: at32f435_437_adc.h:527
adc_type::odt
__IO uint32_t odt
Definition: at32f435_437_adc.h:739
adc_type::adabrt
__IO uint32_t adabrt
Definition: at32f435_437_adc.h:473
adc_type::pcvmen
__IO uint32_t pcvmen
Definition: at32f435_437_adc.h:453
adc_type::osn1
__IO uint32_t osn1
Definition: at32f435_437_adc.h:655
adc_type::osrsel
__IO uint32_t osrsel
Definition: at32f435_437_adc.h:759
adc_type::rdy
__IO uint32_t rdy
Definition: at32f435_437_adc.h:429
adc_type::ocdrcen
__IO uint32_t ocdrcen
Definition: at32f435_437_adc.h:476
adc_type::oostren
__IO uint32_t oostren
Definition: at32f435_437_adc.h:761
adc_type::pcdto4
__IO uint32_t pcdto4
Definition: at32f435_437_adc.h:578
adc_type::pdt1
__IO uint32_t pdt1
Definition: at32f435_437_adc.h:687
adc_type::posen
__IO uint32_t posen
Definition: at32f435_437_adc.h:758
adc_type::pcdto2
__IO uint32_t pcdto2
Definition: at32f435_437_adc.h:552
adc_type::occo
__IO uint32_t occo
Definition: at32f435_437_adc.h:428
adc_type::cspt6
__IO uint32_t cspt6
Definition: at32f435_437_adc.h:526
adc_type::osn6
__IO uint32_t osn6
Definition: at32f435_437_adc.h:660
adc_type::osn8
__IO uint32_t osn8
Definition: at32f435_437_adc.h:638
adc_type::pcpen
__IO uint32_t pcpen
Definition: at32f435_437_adc.h:450
adc_type::osn16
__IO uint32_t osn16
Definition: at32f435_437_adc.h:623
adc_type::cspt13
__IO uint32_t cspt13
Definition: at32f435_437_adc.h:502
adc_type::vmsgen
__IO uint32_t vmsgen
Definition: at32f435_437_adc.h:447
adc_type::psq
__IO uint32_t psq
Definition: at32f435_437_adc.h:670
adc_type::osn3
__IO uint32_t osn3
Definition: at32f435_437_adc.h:657
adc_type::pcceien
__IO uint32_t pcceien
Definition: at32f435_437_adc.h:445
adc_type::occe
__IO uint32_t occe
Definition: at32f435_437_adc.h:424
adc_type::occeien
__IO uint32_t occeien
Definition: at32f435_437_adc.h:443
adc_type::ocete
__IO uint32_t ocete
Definition: at32f435_437_adc.h:485
adc_type::vmorien
__IO uint32_t vmorien
Definition: at32f435_437_adc.h:444
adc_type::ocvmen
__IO uint32_t ocvmen
Definition: at32f435_437_adc.h:454
adc_type::eocsfen
__IO uint32_t eocsfen
Definition: at32f435_437_adc.h:477
adc_type::oclen
__IO uint32_t oclen
Definition: at32f435_437_adc.h:624
adc_type::pcdto1
__IO uint32_t pcdto1
Definition: at32f435_437_adc.h:539
adc_type::oosen
__IO uint32_t oosen
Definition: at32f435_437_adc.h:757
adc_type::occs
__IO uint32_t occs
Definition: at32f435_437_adc.h:427
adc_type::occoien
__IO uint32_t occoien
Definition: at32f435_437_adc.h:456
adc_type::osn9
__IO uint32_t osn9
Definition: at32f435_437_adc.h:639
adc_type::cspt5
__IO uint32_t cspt5
Definition: at32f435_437_adc.h:525
adc_type::spt1
__IO uint32_t spt1
Definition: at32f435_437_adc.h:496
adc_type::psn4
__IO uint32_t psn4
Definition: at32f435_437_adc.h:676
adc_type::cspt12
__IO uint32_t cspt12
Definition: at32f435_437_adc.h:501
adc_type::adcal
__IO uint32_t adcal
Definition: at32f435_437_adc.h:471
adc_type::cspt14
__IO uint32_t cspt14
Definition: at32f435_437_adc.h:503
adc_type::octesel_l
__IO uint32_t octesel_l
Definition: at32f435_437_adc.h:484
adc_type::pcete
__IO uint32_t pcete
Definition: at32f435_437_adc.h:481
adc_type::pctesel_l
__IO uint32_t pctesel_l
Definition: at32f435_437_adc.h:480
adc_type::octesel_h
__IO uint32_t octesel_h
Definition: at32f435_437_adc.h:487
adc_type::psn3
__IO uint32_t psn3
Definition: at32f435_437_adc.h:675
adc_type::spt2
__IO uint32_t spt2
Definition: at32f435_437_adc.h:517
adc_type::osn4
__IO uint32_t osn4
Definition: at32f435_437_adc.h:658
adc_type::adcen
__IO uint32_t adcen
Definition: at32f435_437_adc.h:469
adc_type::oosrsel
__IO uint32_t oosrsel
Definition: at32f435_437_adc.h:762
adc_type::vmhb
__IO uint32_t vmhb
Definition: at32f435_437_adc.h:591
adc_type::ocpen
__IO uint32_t ocpen
Definition: at32f435_437_adc.h:449
adc_type::cspt9
__IO uint32_t cspt9
Definition: at32f435_437_adc.h:529
adc_type::adcalinit
__IO uint32_t adcalinit
Definition: at32f435_437_adc.h:472
adc_type::pdt3
__IO uint32_t pdt3
Definition: at32f435_437_adc.h:713
adc_type::cspt18
__IO uint32_t cspt18
Definition: at32f435_437_adc.h:507
adc_type::psn1
__IO uint32_t psn1
Definition: at32f435_437_adc.h:673
adc_type::cspt10
__IO uint32_t cspt10
Definition: at32f435_437_adc.h:499
adc_type::osn10
__IO uint32_t osn10
Definition: at32f435_437_adc.h:640
adc_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_adc.h:457
adc_type::osn12
__IO uint32_t osn12
Definition: at32f435_437_adc.h:642
adc_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f435_437_adc.h:439
adc_type::sts
__IO uint32_t sts
Definition: at32f435_437_adc.h:420
adc_type::ovsp
__IO uint32_t ovsp
Definition: at32f435_437_adc.h:754
adc_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f435_437_adc.h:466
adc_type::cspt0
__IO uint32_t cspt0
Definition: at32f435_437_adc.h:520
adc_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_adc.h:430
adc_type::osq1
__IO uint32_t osq1
Definition: at32f435_437_adc.h:617
adc_type::cspt16
__IO uint32_t cspt16
Definition: at32f435_437_adc.h:505
adc_type::osssel
__IO uint32_t osssel
Definition: at32f435_437_adc.h:760
adc_type::psn2
__IO uint32_t psn2
Definition: at32f435_437_adc.h:674
adc_type::osn2
__IO uint32_t osn2
Definition: at32f435_437_adc.h:656
adc_type::vmor
__IO uint32_t vmor
Definition: at32f435_437_adc.h:423
adc_type::crsel
__IO uint32_t crsel
Definition: at32f435_437_adc.h:455
adc_type::osn15
__IO uint32_t osn15
Definition: at32f435_437_adc.h:622
adc_type::osn11
__IO uint32_t osn11
Definition: at32f435_437_adc.h:641
adc_type::vmlb
__IO uint32_t vmlb
Definition: at32f435_437_adc.h:604
adc_type::osn5
__IO uint32_t osn5
Definition: at32f435_437_adc.h:659
adc_type::pdt2
__IO uint32_t pdt2
Definition: at32f435_437_adc.h:700
adc_type::cspt4
__IO uint32_t cspt4
Definition: at32f435_437_adc.h:524
adc_type::ocpcnt
__IO uint32_t ocpcnt
Definition: at32f435_437_adc.h:451
adc_type::osq3
__IO uint32_t osq3
Definition: at32f435_437_adc.h:652
adc_type::pcautoen
__IO uint32_t pcautoen
Definition: at32f435_437_adc.h:448
adc_type::cspt2
__IO uint32_t cspt2
Definition: at32f435_437_adc.h:522
adc_type::cspt17
__IO uint32_t cspt17
Definition: at32f435_437_adc.h:506
adc_type::cspt11
__IO uint32_t cspt11
Definition: at32f435_437_adc.h:500
adc_type::calval
__IO uint32_t calval
Definition: at32f435_437_adc.h:774
adc_type::pcdto3
__IO uint32_t pcdto3
Definition: at32f435_437_adc.h:565
adc_type::cspt8
__IO uint32_t cspt8
Definition: at32f435_437_adc.h:528
adc_type::osn7
__IO uint32_t osn7
Definition: at32f435_437_adc.h:637
adc_type::pcswtrg
__IO uint32_t pcswtrg
Definition: at32f435_437_adc.h:482
adc_type::osn13
__IO uint32_t osn13
Definition: at32f435_437_adc.h:620
adc_type::cspt3
__IO uint32_t cspt3
Definition: at32f435_437_adc.h:523
adc_type::pccs
__IO uint32_t pccs
Definition: at32f435_437_adc.h:426
adccom_type
type define adc register all
Definition: at32f435_437_adc.h:787
adccom_type::pcce3
__IO uint32_t pcce3
Definition: at32f435_437_adc.h:815
adccom_type::occe1
__IO uint32_t occe1
Definition: at32f435_437_adc.h:798
adccom_type::codt
__IO uint32_t codt
Definition: at32f435_437_adc.h:853
adccom_type::csts
__IO uint32_t csts
Definition: at32f435_437_adc.h:794
adccom_type::occe2
__IO uint32_t occe2
Definition: at32f435_437_adc.h:806
adccom_type::pcce1
__IO uint32_t pcce1
Definition: at32f435_437_adc.h:799
adccom_type::vmor3
__IO uint32_t vmor3
Definition: at32f435_437_adc.h:813
adccom_type::pccs2
__IO uint32_t pccs2
Definition: at32f435_437_adc.h:808
adccom_type::adcdiv
__IO uint32_t adcdiv
Definition: at32f435_437_adc.h:838
adccom_type::codtl
__IO uint32_t codtl
Definition: at32f435_437_adc.h:856
adccom_type::pcce2
__IO uint32_t pcce2
Definition: at32f435_437_adc.h:807
adccom_type::msdmasel_l
__IO uint32_t msdmasel_l
Definition: at32f435_437_adc.h:837
adccom_type::reserved5
__IO uint32_t reserved5
Definition: at32f435_437_adc.h:844
adccom_type::msdmasel_h
__IO uint32_t msdmasel_h
Definition: at32f435_437_adc.h:843
adccom_type::occe3
__IO uint32_t occe3
Definition: at32f435_437_adc.h:814
adccom_type::occs2
__IO uint32_t occs2
Definition: at32f435_437_adc.h:809
adccom_type::codth
__IO uint32_t codth
Definition: at32f435_437_adc.h:857
adccom_type::occo3
__IO uint32_t occo3
Definition: at32f435_437_adc.h:818
adccom_type::vmor2
__IO uint32_t vmor2
Definition: at32f435_437_adc.h:805
adccom_type::reserved4
__IO uint32_t reserved4
Definition: at32f435_437_adc.h:842
adccom_type::asisel
__IO uint32_t asisel
Definition: at32f435_437_adc.h:834
adccom_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_adc.h:804
adccom_type::vmor1
__IO uint32_t vmor1
Definition: at32f435_437_adc.h:797
adccom_type::mssel
__IO uint32_t mssel
Definition: at32f435_437_adc.h:832
adccom_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_adc.h:812
adccom_type::pccs3
__IO uint32_t pccs3
Definition: at32f435_437_adc.h:816
adccom_type::pccs1
__IO uint32_t pccs1
Definition: at32f435_437_adc.h:800
adccom_type::itsrven
__IO uint32_t itsrven
Definition: at32f435_437_adc.h:841
adccom_type::vbaten
__IO uint32_t vbaten
Definition: at32f435_437_adc.h:840
adccom_type::occo2
__IO uint32_t occo2
Definition: at32f435_437_adc.h:810
adccom_type::rdy2
__IO uint32_t rdy2
Definition: at32f435_437_adc.h:811
adccom_type::occs3
__IO uint32_t occs3
Definition: at32f435_437_adc.h:817
adccom_type::cctrl
__IO uint32_t cctrl
Definition: at32f435_437_adc.h:829
adccom_type::rdy3
__IO uint32_t rdy3
Definition: at32f435_437_adc.h:819
adccom_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_adc.h:820
adccom_type::rdy1
__IO uint32_t rdy1
Definition: at32f435_437_adc.h:803
adccom_type::msdrcen
__IO uint32_t msdrcen
Definition: at32f435_437_adc.h:836
adccom_type::occs1
__IO uint32_t occs1
Definition: at32f435_437_adc.h:801
adccom_type::occo1
__IO uint32_t occo1
Definition: at32f435_437_adc.h:802


AT32F435/437 Firmwary Library: at32f435_437_board.c Source File

  • at32f435_437_board
at32f435_437_board.c
Go to the documentation of this file.
1
28#include "at32f435_437_board.h"
29
39/* delay macros */
40#define STEP_DELAY_MS 50
41
42/* at-start led resouce array */
43 gpio_type *led_gpio_port[LED_NUM] = {LED2_GPIO, LED3_GPIO, LED4_GPIO};
44uint16_t led_gpio_pin[LED_NUM] = {LED2_PIN, LED3_PIN, LED4_PIN};
45 crm_periph_clock_type led_gpio_crm_clk[LED_NUM] = {LED2_GPIO_CRM_CLK, LED3_GPIO_CRM_CLK, LED4_GPIO_CRM_CLK};
46
47/* delay variable */
48static __IO uint32_t fac_us;
49static __IO uint32_t fac_ms;
50
51/* support printf function, usemicrolib is unnecessary */
52#if (__ARMCC_VERSION > 6000000)
53 __asm (".global __use_no_semihosting\n\t");
54 void _sys_exit(int x)
55 {
56 x = x;
57 }
58 /* __use_no_semihosting was requested, but _ttywrch was */
59 void _ttywrch(int ch)
60 {
61 ch = ch;
62 }
63 FILE __stdout;
64#else
65 #ifdef __CC_ARM
66 #pragma import(__use_no_semihosting)
67 struct __FILE
68 {
69 int handle;
70 };
71 FILE __stdout;
72 void _sys_exit(int x)
73 {
74 x = x;
75 }
76 /* __use_no_semihosting was requested, but _ttywrch was */
77 void _ttywrch(int ch)
78 {
79 ch = ch;
80 }
81 #endif
82#endif
83
84#if defined (__GNUC__) && !defined (__clang__)
85 #define PUTCHAR_PROTOTYPE int __io_putchar(int ch)
86#else
87 #define PUTCHAR_PROTOTYPE int fputc(int ch, FILE *f)
88#endif
89
95 PUTCHAR_PROTOTYPE
96{
97 while(usart_flag_get(PRINT_UART, USART_TDBE_FLAG) == RESET);
98 usart_data_transmit(PRINT_UART, ch);
99 return ch;
100}
101
107void uart_print_init(uint32_t baudrate)
108{
109 gpio_init_type gpio_init_struct;
110
111 /* enable the uart and gpio clock */
112 crm_periph_clock_enable(PRINT_UART_CRM_CLK, TRUE);
113 crm_periph_clock_enable(PRINT_UART_TX_GPIO_CRM_CLK, TRUE);
114
115 gpio_default_para_init(&gpio_init_struct);
116
117 /* configure the uart tx pin */
118 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
119 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
120 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
121 gpio_init_struct.gpio_pins = PRINT_UART_TX_PIN;
122 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
123 gpio_init(PRINT_UART_TX_GPIO, &gpio_init_struct);
124
125 gpio_pin_mux_config(PRINT_UART_TX_GPIO, PRINT_UART_TX_PIN_SOURCE, PRINT_UART_TX_PIN_MUX_NUM);
126
127 /* configure uart param */
128 usart_init(PRINT_UART, baudrate, USART_DATA_8BITS, USART_STOP_1_BIT);
129 usart_transmitter_enable(PRINT_UART, TRUE);
130 usart_enable(PRINT_UART, TRUE);
131}
132
138void at32_board_init()
139{
140 /* initialize delay function */
141 delay_init();
142
143 /* configure led in at_start_board */
144 at32_led_init(LED2);
145 at32_led_init(LED3);
146 at32_led_init(LED4);
147 at32_led_off(LED2);
148 at32_led_off(LED3);
149 at32_led_off(LED4);
150
151 /* configure button in at_start board */
152 at32_button_init();
153}
154
160void at32_button_init(void)
161{
162 gpio_init_type gpio_init_struct;
163
164 /* enable the button clock */
165 crm_periph_clock_enable(USER_BUTTON_CRM_CLK, TRUE);
166
167 /* set default parameter */
168 gpio_default_para_init(&gpio_init_struct);
169
170 /* configure button pin as input with pull-up/pull-down */
171 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
172 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
173 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
174 gpio_init_struct.gpio_pins = USER_BUTTON_PIN;
175 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
176 gpio_init(USER_BUTTON_PORT, &gpio_init_struct);
177}
178
184uint8_t at32_button_state(void)
185{
186 return gpio_input_data_bit_read(USER_BUTTON_PORT, USER_BUTTON_PIN);
187}
188
194 button_type at32_button_press()
195{
196 static uint8_t pressed = 1;
197 /* get button state in at_start board */
198 if((pressed == 1) && (at32_button_state() != RESET))
199 {
200 /* debounce */
201 pressed = 0;
202 delay_ms(10);
203 if(at32_button_state() != RESET)
204 return USER_BUTTON;
205 }
206 else if(at32_button_state() == RESET)
207 {
208 pressed = 1;
209 }
210 return NO_BUTTON;
211}
212
218void at32_led_init(led_type led)
219{
220 gpio_init_type gpio_init_struct;
221
222 /* enable the led clock */
223 crm_periph_clock_enable(led_gpio_crm_clk[led], TRUE);
224
225 /* set default parameter */
226 gpio_default_para_init(&gpio_init_struct);
227
228 /* configure the led gpio */
229 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
230 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
231 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
232 gpio_init_struct.gpio_pins = led_gpio_pin[led];
233 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
234 gpio_init(led_gpio_port[led], &gpio_init_struct);
235}
236
246void at32_led_on(led_type led)
247{
248 if(led > (LED_NUM - 1))
249 return;
250 if(led_gpio_pin[led])
251 led_gpio_port[led]->clr = led_gpio_pin[led];
252}
253
263void at32_led_off(led_type led)
264{
265 if(led > (LED_NUM - 1))
266 return;
267 if(led_gpio_pin[led])
268 led_gpio_port[led]->scr = led_gpio_pin[led];
269}
270
280void at32_led_toggle(led_type led)
281{
282 if(led > (LED_NUM - 1))
283 return;
284 if(led_gpio_pin[led])
285 led_gpio_port[led]->odt ^= led_gpio_pin[led];
286}
287
293void delay_init()
294{
295 /* configure systick */
296 systick_clock_source_config(SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV);
297 fac_us = system_core_clock / (1000000U);
298 fac_ms = fac_us * (1000U);
299}
300
306void delay_us(uint32_t nus)
307{
308 uint32_t temp = 0;
309 SysTick->LOAD = (uint32_t)(nus * fac_us);
310 SysTick->VAL = 0x00;
311 SysTick->CTRL |= SysTick_CTRL_ENABLE_Msk ;
312 do
313 {
314 temp = SysTick->CTRL;
315 }while((temp & 0x01) && !(temp & (1 << 16)));
316
317 SysTick->CTRL &= ~SysTick_CTRL_ENABLE_Msk;
318 SysTick->VAL = 0x00;
319}
320
326void delay_ms(uint16_t nms)
327{
328 uint32_t temp = 0;
329 while(nms)
330 {
331 if(nms > STEP_DELAY_MS)
332 {
333 SysTick->LOAD = (uint32_t)(STEP_DELAY_MS * fac_ms);
334 nms -= STEP_DELAY_MS;
335 }
336 else
337 {
338 SysTick->LOAD = (uint32_t)(nms * fac_ms);
339 nms = 0;
340 }
341 SysTick->VAL = 0x00;
342 SysTick->CTRL |= SysTick_CTRL_ENABLE_Msk;
343 do
344 {
345 temp = SysTick->CTRL;
346 }while((temp & 0x01) && !(temp & (1 << 16)));
347
348 SysTick->CTRL &= ~SysTick_CTRL_ENABLE_Msk;
349 SysTick->VAL = 0x00;
350 }
351}
352
358void delay_sec(uint16_t sec)
359{
360 uint16_t index;
361 for(index = 0; index < sec; index++)
362 {
363 delay_ms(500);
364 delay_ms(500);
365 }
366}
367
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_core_clock
unsigned int system_core_clock
Definition: system_at32f435_437.c:48
USER_BUTTON_PORT
#define USER_BUTTON_PORT
Definition: at32f435_437_board.h:103
PRINT_UART_CRM_CLK
#define PRINT_UART_CRM_CLK
Definition: at32f435_437_board.h:88
USER_BUTTON_PIN
#define USER_BUTTON_PIN
Definition: at32f435_437_board.h:102
PRINT_UART_TX_PIN
#define PRINT_UART_TX_PIN
Definition: at32f435_437_board.h:89
LED_NUM
#define LED_NUM
Definition: at32f435_437_board.h:70
led_type
led_type
Definition: at32f435_437_board.h:64
PRINT_UART
#define PRINT_UART
Definition: at32f435_437_board.h:87
PRINT_UART_TX_GPIO
#define PRINT_UART_TX_GPIO
Definition: at32f435_437_board.h:90
USER_BUTTON_CRM_CLK
#define USER_BUTTON_CRM_CLK
Definition: at32f435_437_board.h:104
PRINT_UART_TX_PIN_SOURCE
#define PRINT_UART_TX_PIN_SOURCE
Definition: at32f435_437_board.h:92
PRINT_UART_TX_GPIO_CRM_CLK
#define PRINT_UART_TX_GPIO_CRM_CLK
Definition: at32f435_437_board.h:91
PRINT_UART_TX_PIN_MUX_NUM
#define PRINT_UART_TX_PIN_MUX_NUM
Definition: at32f435_437_board.h:93
button_type
button_type
Definition: at32f435_437_board.h:97
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
NO_BUTTON
@ NO_BUTTON
Definition: at32f435_437_board.h:99
USER_BUTTON
@ USER_BUTTON
Definition: at32f435_437_board.h:98
led_gpio_port
gpio_type * led_gpio_port[3]
Definition: at32f435_437_board.c:43
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f435_437_board.c:194
fac_ms
static __IO uint32_t fac_ms
Definition: at32f435_437_board.c:49
led_gpio_pin
uint16_t led_gpio_pin[3]
Definition: at32f435_437_board.c:44
at32_led_init
void at32_led_init(led_type led)
configure led gpio
Definition: at32f435_437_board.c:218
delay_init
void delay_init()
initialize delay function
Definition: at32f435_437_board.c:293
at32_button_state
uint8_t at32_button_state(void)
returns the selected button state
Definition: at32f435_437_board.c:184
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
STEP_DELAY_MS
#define STEP_DELAY_MS
Definition: at32f435_437_board.c:40
led_gpio_crm_clk
crm_periph_clock_type led_gpio_crm_clk[3]
Definition: at32f435_437_board.c:45
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
PUTCHAR_PROTOTYPE
#define PUTCHAR_PROTOTYPE
Definition: at32f435_437_board.c:87
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
at32_button_init
void at32_button_init(void)
configure button gpio
Definition: at32f435_437_board.c:160
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f435_437_board.c:306
fac_us
static __IO uint32_t fac_us
Definition: at32f435_437_board.c:48
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_periph_clock_type
crm_periph_clock_type
crm periph clock
Definition: at32f435_437_crm.h:102
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_input_data_bit_read
flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified input port pin.
Definition: at32f435_437_gpio.c:170
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f435_437_gpio.h:82
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
systick_clock_source_config
void systick_clock_source_config(systick_clock_source_type source)
config systick clock source
Definition: at32f435_437_misc.c:147
SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
@ SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
Definition: at32f435_437_misc.h:90
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f435_437_usart.c:413
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f435_437_usart.c:598
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f435_437_usart.c:209
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f435_437_usart.c:115
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f435_437_usart.c:196
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f435_437_usart.h:159
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f435_437_usart.h:114
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f435_437_usart.h:59
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
gpio_type
type define gpio register all
Definition: at32f435_437_gpio.h:178
gpio_type::scr
__IO uint32_t scr
Definition: at32f435_437_gpio.h:349
gpio_type::odt
__IO uint32_t odt
Definition: at32f435_437_gpio.h:321
gpio_type::clr
__IO uint32_t clr
Definition: at32f435_437_gpio.h:459


AT32F435/437 Firmwary Library: at32f435_437_board.h Source File

  • at32f435_437_board
at32f435_437_board.h
Go to the documentation of this file.
1
28#ifndef __AT32F435_437_BOARD_H
29#define __AT32F435_437_BOARD_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "stdio.h"
36#include "at32f435_437.h"
37
58#if !defined (AT_START_F435_V1) && !defined (AT_START_F437_V1)
59#error "please select first the board at-start device used in your application (in at32f435_437_board.h file)"
60#endif
61
62/******************** define led ********************/
63typedef enum
64{
65 LED2 = 0,
66 LED3 = 1,
67 LED4 = 2
68}led_type;
69
70#define LED_NUM 3
71
72#if defined (AT_START_F435_V1) || defined (AT_START_F437_V1)
73#define LED2_PIN GPIO_PINS_13
74#define LED2_GPIO GPIOD
75#define LED2_GPIO_CRM_CLK CRM_GPIOD_PERIPH_CLOCK
76
77#define LED3_PIN GPIO_PINS_14
78#define LED3_GPIO GPIOD
79#define LED3_GPIO_CRM_CLK CRM_GPIOD_PERIPH_CLOCK
80
81#define LED4_PIN GPIO_PINS_15
82#define LED4_GPIO GPIOD
83#define LED4_GPIO_CRM_CLK CRM_GPIOD_PERIPH_CLOCK
84#endif
85
86/**************** define print uart ******************/
87#define PRINT_UART USART1
88#define PRINT_UART_CRM_CLK CRM_USART1_PERIPH_CLOCK
89#define PRINT_UART_TX_PIN GPIO_PINS_9
90#define PRINT_UART_TX_GPIO GPIOA
91#define PRINT_UART_TX_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
92#define PRINT_UART_TX_PIN_SOURCE GPIO_PINS_SOURCE9
93#define PRINT_UART_TX_PIN_MUX_NUM GPIO_MUX_7
94
95/******************* define button *******************/
96typedef enum
97{
98 USER_BUTTON = 0,
99 NO_BUTTON = 1
100} button_type;
101
102#define USER_BUTTON_PIN GPIO_PINS_0
103#define USER_BUTTON_PORT GPIOA
104#define USER_BUTTON_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
105
114/******************** functions ********************/
115void at32_board_init(void);
116
117/* led operation function */
118void at32_led_init(led_type led);
119void at32_led_on(led_type led);
120void at32_led_off(led_type led);
121void at32_led_toggle(led_type led);
122
123/* button operation function */
124void at32_button_init(void);
125 button_type at32_button_press(void);
126uint8_t at32_button_state(void);
127
128/* delay function */
129void delay_init(void);
130void delay_us(uint32_t nus);
131void delay_ms(uint16_t nms);
132void delay_sec(uint16_t sec);
133
134/* printf uart init function */
135void uart_print_init(uint32_t baudrate);
136
149#ifdef __cplusplus
150}
151#endif
152
153#endif
154
at32f435_437.h
at32f435_437 header file
at32_board_init
void at32_board_init(void)
board initialize interface init led and button
Definition: at32f435_437_board.c:138
at32_led_init
void at32_led_init(led_type led)
configure led gpio
Definition: at32f435_437_board.c:218
at32_button_state
uint8_t at32_button_state(void)
returns the selected button state
Definition: at32f435_437_board.c:184
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_button_press
button_type at32_button_press(void)
returns which button have press down
Definition: at32f435_437_board.c:194
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
at32_button_init
void at32_button_init(void)
configure button gpio
Definition: at32f435_437_board.c:160
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f435_437_board.c:306
delay_init
void delay_init(void)
initialize delay function
Definition: at32f435_437_board.c:293
led_type
led_type
Definition: at32f435_437_board.h:64
button_type
button_type
Definition: at32f435_437_board.h:97
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
NO_BUTTON
@ NO_BUTTON
Definition: at32f435_437_board.h:99
USER_BUTTON
@ USER_BUTTON
Definition: at32f435_437_board.h:98


AT32F435/437 Firmwary Library: at32f435_437_can.c Source File

  • libraries
  • drivers
  • src
at32f435_437_can.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef CAN_MODULE_ENABLED
39
51void can_reset(can_type* can_x)
52{
53 if(can_x == CAN1)
54 {
55 crm_periph_reset(CRM_CAN1_PERIPH_RESET, TRUE);
56 crm_periph_reset(CRM_CAN1_PERIPH_RESET, FALSE);
57 }
58 else if(can_x == CAN2)
59 {
60 crm_periph_reset(CRM_CAN2_PERIPH_RESET, TRUE);
61 crm_periph_reset(CRM_CAN2_PERIPH_RESET, FALSE);
62 }
63}
64
70void can_baudrate_default_para_init(can_baudrate_type* can_baudrate_struct)
71{
72 /* reset can baudrate structure parameters values */
73
74 /* baud rate division */
75 can_baudrate_struct->baudrate_div = 1;
76
77 /* resynchronization adjust width */
78 can_baudrate_struct->rsaw_size = CAN_RSAW_2TQ;
79
80 /* bit time segment 1 */
81 can_baudrate_struct->bts1_size = CAN_BTS1_4TQ;
82
83 /* bit time segment 2 */
84 can_baudrate_struct->bts2_size = CAN_BTS2_3TQ;
85}
86
99 error_status can_baudrate_set(can_type* can_x, can_baudrate_type* can_baudrate_struct)
100{
101 error_status status_index = ERROR;
102 uint32_t wait_ack_index = 0x00000000;
103 /* exit from doze mode */
104 can_x->mctrl_bit.dzen = FALSE;
105
106 /* request freeze mode */
107 can_x->mctrl_bit.fzen = TRUE;
108
109 /* wait the acknowledge */
110 while((!can_x->msts_bit.fzc) && (wait_ack_index != FZC_TIMEOUT))
111 {
112 wait_ack_index++;
113 }
114
115 /* check acknowledge */
116 if(can_x->msts_bit.fzc)
117 {
118 can_x->btmg_bit.brdiv = can_baudrate_struct->baudrate_div - 1;
119 can_x->btmg_bit.rsaw = can_baudrate_struct->rsaw_size;
120 can_x->btmg_bit.bts1 = can_baudrate_struct->bts1_size;
121 can_x->btmg_bit.bts2 = can_baudrate_struct->bts2_size;
122
123 /* request leave freeze mode */
124 can_x->mctrl_bit.fzen = FALSE;
125
126 /* wait the acknowledge */
127 wait_ack_index = 0;
128 while((can_x->msts_bit.fzc) && (wait_ack_index != FZC_TIMEOUT))
129 {
130 wait_ack_index++;
131 }
132
133 /* check acknowledged */
134 if(can_x->msts_bit.fzc)
135 {
136 status_index = ERROR;
137 }
138 else
139 {
140 status_index = SUCCESS ;
141 }
142 }
143 else
144 {
145 status_index = ERROR;
146 }
147
148 /* return the status of baudrate set */
149 return status_index;
150}
151
157void can_default_para_init(can_base_type* can_base_struct)
158{
159 /* reset can init structure parameters values */
160
161 /* initialize the time triggered communication mode */
162 can_base_struct->ttc_enable = FALSE;
163
164 /* initialize the automatic exit bus-off management */
165 can_base_struct->aebo_enable = FALSE;
166
167 /* initialize the automatic exit doze mode */
168 can_base_struct->aed_enable = FALSE;
169
170 /* initialize the prohibit retransmission when sending fails */
171 can_base_struct->prsf_enable = FALSE;
172
173 /* initialize the message discarding rule select when overflow */
174 can_base_struct->mdrsel_selection = CAN_DISCARDING_FIRST_RECEIVED;
175
176 /* initialize the multiple message sending sequence rule */
177 can_base_struct->mmssr_selection = CAN_SENDING_BY_ID;
178
179 /* initialize the can_mode */
180 can_base_struct->mode_selection = CAN_MODE_COMMUNICATE;
181}
182
194 error_status can_base_init(can_type* can_x, can_base_type* can_base_struct)
195{
196 error_status init_status_index = ERROR;
197 uint32_t wait_ack_index = 0x00000000;
198 /* exit from doze mode */
199 can_x->mctrl_bit.dzen = FALSE;
200
201 /* request freeze mode */
202 can_x->mctrl_bit.fzen = TRUE;
203
204 /* wait the acknowledge */
205 while((!can_x->msts_bit.fzc) && (wait_ack_index != FZC_TIMEOUT))
206 {
207 wait_ack_index++;
208 }
209
210 /* check acknowledge */
211 if(can_x->msts_bit.fzc)
212 {
213 /* set the time triggered communication mode */
214 can_x->mctrl_bit.ttcen = can_base_struct->ttc_enable;
215
216 /* set the automatic exit bus-off management */
217 can_x->mctrl_bit.aeboen = can_base_struct->aebo_enable;
218
219 /* set the automatic automatic exit doze mode */
220 can_x->mctrl_bit.aeden = can_base_struct->aed_enable;
221
222 /* set the prohibit retransmission when sending fails */
223 can_x->mctrl_bit.prsfen = can_base_struct->prsf_enable;
224
225 /* set the message discarding rule select when overflow */
226 can_x->mctrl_bit.mdrsel = can_base_struct->mdrsel_selection;
227
228 /* set the multiple message sending sequence rule */
229 can_x->mctrl_bit.mmssr = can_base_struct->mmssr_selection;
230
231 /* set the test mode */
232 can_x->btmg_bit.lben = can_base_struct->mode_selection & 0x01;
233 can_x->btmg_bit.loen = (can_base_struct->mode_selection >> 1) & 0x01;
234
235 /* request leave freeze mode */
236 can_x->mctrl_bit.fzen = FALSE;
237
238 /* wait the acknowledge */
239 wait_ack_index = 0;
240 while((can_x->msts_bit.fzc) && (wait_ack_index != FZC_TIMEOUT))
241 {
242 wait_ack_index++;
243 }
244
245 /* check acknowledged */
246 if(can_x->msts_bit.fzc)
247 {
248 init_status_index = ERROR;
249 }
250 else
251 {
252 init_status_index = SUCCESS ;
253 }
254 }
255 else
256 {
257 init_status_index = ERROR;
258 }
259
260 /* return the status of initialization */
261 return init_status_index;
262}
263
269void can_filter_default_para_init(can_filter_init_type* can_filter_init_struct)
270{
271 /* reset can filter init structure parameters values */
272
273 /* initialize the filter activate state */
274 can_filter_init_struct->filter_activate_enable = FALSE;
275
276 /* filter mode */
277 can_filter_init_struct->filter_mode = CAN_FILTER_MODE_ID_MASK;
278
279 /* filter relation fifo select */
280 can_filter_init_struct->filter_fifo = CAN_FILTER_FIFO0;
281
282 /* filter number select */
283 can_filter_init_struct->filter_number = 0;
284
285 /* initialize the filter bit width */
286 can_filter_init_struct->filter_bit = CAN_FILTER_16BIT;
287
288 /* initialize the filters filter data bit */
289 can_filter_init_struct->filter_id_high = 0;
290 can_filter_init_struct->filter_id_low = 0;
291 can_filter_init_struct->filter_mask_high = 0;
292 can_filter_init_struct->filter_mask_low = 0;
293}
294
304void can_filter_init(can_type* can_x, can_filter_init_type* can_filter_init_struct)
305{
306 uint32_t filter_number_bit_pos = 0;
307 filter_number_bit_pos = ((uint32_t)1) << can_filter_init_struct->filter_number;
308 /* set the filter turn into configuration condition */
309 can_x->fctrl_bit.fcs = TRUE;
310
311 /* filter activate disable */
312 can_x->facfg &= ~(uint32_t)filter_number_bit_pos;
313
314 /* filter bit width */
315 switch(can_filter_init_struct->filter_bit)
316 {
317 case CAN_FILTER_16BIT:
318 can_x->fbwcfg &= ~(uint32_t)filter_number_bit_pos;
319 /* first 16-bit identifier and first 16-bit mask or first 16-bit identifier and second 16-bit identifier */
320 can_x->ffb[can_filter_init_struct->filter_number].ffdb1 = ((0x0000FFFF & (uint32_t)can_filter_init_struct->filter_mask_low) << 16);
321 can_x->ffb[can_filter_init_struct->filter_number].ffdb1 |= (0x0000FFFF & (uint32_t)can_filter_init_struct->filter_id_low);
322
323 /* second 16-bit identifier and second 16-bit mask or third 16-bit identifier and fourth 16-bit identifier */
324 can_x->ffb[can_filter_init_struct->filter_number].ffdb2 = ((0x0000FFFF & (uint32_t)can_filter_init_struct->filter_mask_high) << 16);
325 can_x->ffb[can_filter_init_struct->filter_number].ffdb2 |= (0x0000FFFF & (uint32_t)can_filter_init_struct->filter_id_high);
326
327 break;
328 case CAN_FILTER_32BIT:
329 can_x->fbwcfg |= filter_number_bit_pos;
330 /* 32-bit identifier or first 32-bit identifier */
331 can_x->ffb[can_filter_init_struct->filter_number].ffdb1 = ((0x0000FFFF & (uint32_t)can_filter_init_struct->filter_id_high) << 16);
332 can_x->ffb[can_filter_init_struct->filter_number].ffdb1 |= (0x0000FFFF & (uint32_t)can_filter_init_struct->filter_id_low);
333
334 /* 32-bit mask or second 32-bit identifier */
335 can_x->ffb[can_filter_init_struct->filter_number].ffdb2 = ((0x0000FFFF & (uint32_t)can_filter_init_struct->filter_mask_high) << 16);
336 can_x->ffb[can_filter_init_struct->filter_number].ffdb2 |= (0x0000FFFF & (uint32_t)can_filter_init_struct->filter_mask_low);
337
338 break;
339 default:
340 break;
341 }
342
343 /* filter mode */
344 switch(can_filter_init_struct->filter_mode)
345 {
346 case CAN_FILTER_MODE_ID_MASK:
347 can_x->fmcfg &= ~(uint32_t)filter_number_bit_pos;
348 break;
349 case CAN_FILTER_MODE_ID_LIST:
350 can_x->fmcfg |= (uint32_t)filter_number_bit_pos;
351 break;
352 default:
353 break;
354 }
355
356 /* filter relation fifo select */
357 switch(can_filter_init_struct->filter_fifo)
358 {
359 case CAN_FILTER_FIFO0:
360 can_x->frf &= ~(uint32_t)filter_number_bit_pos;
361 break;
362 case CAN_FILTER_FIFO1:
363 can_x->frf |= (uint32_t)filter_number_bit_pos;
364 break;
365 default:
366 break;
367 }
368
369 /* filter activate enable */
370 switch(can_filter_init_struct->filter_activate_enable)
371 {
372 case TRUE:
373 can_x->facfg |= (uint32_t)filter_number_bit_pos;
374 break;
375 case FALSE:
376 can_x->facfg &= ~(uint32_t)filter_number_bit_pos;
377 break;
378 default:
379 break;
380 }
381
382 /* set the filter turn into working condition */
383 can_x->fctrl_bit.fcs = FALSE;
384}
385
395void can_debug_transmission_prohibit(can_type* can_x, confirm_state new_state)
396{
397 can_x->mctrl_bit.ptd = new_state;
398}
399
416void can_ttc_mode_enable(can_type* can_x, confirm_state new_state)
417{
418 /* config the ttc mode new_state */
419 can_x->mctrl_bit.ttcen = new_state;
420
421 /* config tmtsten bits new_state */
422 can_x->tx_mailbox[0].tmc_bit.tmtsten = new_state;
423 can_x->tx_mailbox[1].tmc_bit.tmtsten = new_state;
424 can_x->tx_mailbox[2].tmc_bit.tmtsten = new_state;
425}
426
440uint8_t can_message_transmit(can_type* can_x, can_tx_message_type* tx_message_struct)
441{
442 uint8_t transmit_mailbox = CAN_TX_STATUS_NO_EMPTY;
443
444 /* select one empty transmit mailbox */
445 if(can_x->tsts_bit.tm0ef)
446 {
447 transmit_mailbox = CAN_TX_MAILBOX0;
448 }
449 else if(can_x->tsts_bit.tm1ef)
450 {
451 transmit_mailbox = CAN_TX_MAILBOX1;
452 }
453 else if(can_x->tsts_bit.tm2ef)
454 {
455 transmit_mailbox = CAN_TX_MAILBOX2;
456 }
457 else
458 {
459 transmit_mailbox = CAN_TX_STATUS_NO_EMPTY;
460 }
461
462 if(transmit_mailbox != CAN_TX_STATUS_NO_EMPTY)
463 {
464 /* set up the id */
465 can_x->tx_mailbox[transmit_mailbox].tmi &= 0x00000001;
466 can_x->tx_mailbox[transmit_mailbox].tmi_bit.tmidsel = tx_message_struct->id_type;
467 switch(tx_message_struct->id_type)
468 {
469 case CAN_ID_STANDARD:
470 can_x->tx_mailbox[transmit_mailbox].tmi_bit.tmsid = tx_message_struct->standard_id;
471 break;
472 case CAN_ID_EXTENDED:
473 can_x->tx_mailbox[transmit_mailbox].tmi |= (tx_message_struct->extended_id << 3);
474 break;
475 default:
476 break;
477 }
478 can_x->tx_mailbox[transmit_mailbox].tmi_bit.tmfrsel = tx_message_struct->frame_type;
479 /* set up the dlc */
480 can_x->tx_mailbox[transmit_mailbox].tmc_bit.tmdtbl = (tx_message_struct->dlc & ((uint8_t)0x0F));
481
482 /* set up the data field */
483 can_x->tx_mailbox[transmit_mailbox].tmdtl = (((uint32_t)tx_message_struct->data[3] << 24) |
484 ((uint32_t)tx_message_struct->data[2] << 16) |
485 ((uint32_t)tx_message_struct->data[1] << 8) |
486 ((uint32_t)tx_message_struct->data[0]));
487 can_x->tx_mailbox[transmit_mailbox].tmdth = (((uint32_t)tx_message_struct->data[7] << 24) |
488 ((uint32_t)tx_message_struct->data[6] << 16) |
489 ((uint32_t)tx_message_struct->data[5] << 8) |
490 ((uint32_t)tx_message_struct->data[4]));
491
492 /* request transmission */
493 can_x->tx_mailbox[transmit_mailbox].tmi_bit.tmsr = TRUE;
494 }
495 return transmit_mailbox;
496}
497
514 can_transmit_status_type can_transmit_status_get(can_type* can_x, can_tx_mailbox_num_type transmit_mailbox)
515{
516 can_transmit_status_type state_index = CAN_TX_STATUS_FAILED;
517 switch(transmit_mailbox)
518 {
519 case CAN_TX_MAILBOX0:
520 if(can_x->tsts_bit.tm0tcf != RESET)
521 {
522 if(can_x->tsts_bit.tm0tsf != RESET)
523 {
524 state_index = CAN_TX_STATUS_SUCCESSFUL;
525 }
526 else
527 {
528 state_index = CAN_TX_STATUS_FAILED;
529 }
530 }
531 else
532 {
533 state_index = CAN_TX_STATUS_PENDING;
534 }
535 break;
536 case CAN_TX_MAILBOX1:
537 if(can_x->tsts_bit.tm1tcf != RESET)
538 {
539 if(can_x->tsts_bit.tm1tsf != RESET)
540 {
541 state_index = CAN_TX_STATUS_SUCCESSFUL;
542 }
543 else
544 {
545 state_index = CAN_TX_STATUS_FAILED;
546 }
547 }
548 else
549 {
550 state_index = CAN_TX_STATUS_PENDING;
551 }
552 break;
553 case CAN_TX_MAILBOX2:
554 if(can_x->tsts_bit.tm2tcf != RESET)
555 {
556 if(can_x->tsts_bit.tm2tsf != RESET)
557 {
558 state_index = CAN_TX_STATUS_SUCCESSFUL;
559 }
560 else
561 {
562 state_index = CAN_TX_STATUS_FAILED;
563 }
564 }
565 else
566 {
567 state_index = CAN_TX_STATUS_PENDING;
568 }
569 break;
570 default:
571 state_index = CAN_TX_STATUS_FAILED;
572 break;
573 }
574 return state_index;
575}
576
589void can_transmit_cancel(can_type* can_x, can_tx_mailbox_num_type transmit_mailbox)
590{
591 switch (transmit_mailbox)
592 {
593 case CAN_TX_MAILBOX0:
594 can_x->tsts = CAN_TSTS_TM0CT_VAL;
595 break;
596 case CAN_TX_MAILBOX1:
597 can_x->tsts = CAN_TSTS_TM1CT_VAL;
598 break;
599 case CAN_TX_MAILBOX2:
600 can_x->tsts = CAN_TSTS_TM2CT_VAL;
601 break;
602 default:
603 break;
604 }
605}
606
619void can_message_receive(can_type* can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type* rx_message_struct)
620{
621 /* get the id type */
622 rx_message_struct->id_type = (can_identifier_type)can_x->fifo_mailbox[fifo_number].rfi_bit.rfidi;
623 switch (rx_message_struct->id_type)
624 {
625 case CAN_ID_STANDARD:
626 rx_message_struct->standard_id = can_x->fifo_mailbox[fifo_number].rfi_bit.rfsid;
627 break;
628 case CAN_ID_EXTENDED:
629 rx_message_struct->extended_id = 0x1FFFFFFF & (can_x->fifo_mailbox[fifo_number].rfi >> 3);
630 break;
631 default:
632 break;
633 }
634 rx_message_struct->frame_type = (can_trans_frame_type)can_x->fifo_mailbox[fifo_number].rfi_bit.rffri;
635 /* get the dlc */
636 rx_message_struct->dlc = can_x->fifo_mailbox[fifo_number].rfc_bit.rfdtl;
637
638 /* get the filter match number */
639 rx_message_struct->filter_index = can_x->fifo_mailbox[fifo_number].rfc_bit.rffmn;
640
641 /* get the data field */
642 rx_message_struct->data[0] = can_x->fifo_mailbox[fifo_number].rfdtl_bit.rfdt0;
643 rx_message_struct->data[1] = can_x->fifo_mailbox[fifo_number].rfdtl_bit.rfdt1;
644 rx_message_struct->data[2] = can_x->fifo_mailbox[fifo_number].rfdtl_bit.rfdt2;
645 rx_message_struct->data[3] = can_x->fifo_mailbox[fifo_number].rfdtl_bit.rfdt3;
646 rx_message_struct->data[4] = can_x->fifo_mailbox[fifo_number].rfdth_bit.rfdt4;
647 rx_message_struct->data[5] = can_x->fifo_mailbox[fifo_number].rfdth_bit.rfdt5;
648 rx_message_struct->data[6] = can_x->fifo_mailbox[fifo_number].rfdth_bit.rfdt6;
649 rx_message_struct->data[7] = can_x->fifo_mailbox[fifo_number].rfdth_bit.rfdt7;
650
651 /* release the fifo */
652 can_receive_fifo_release(can_x, fifo_number);
653}
654
666void can_receive_fifo_release(can_type* can_x, can_rx_fifo_num_type fifo_number)
667{
668 switch (fifo_number)
669 {
670 case CAN_RX_FIFO0:
671 can_x->rf0 = CAN_RF0_RF0R_VAL;
672 break;
673 case CAN_RX_FIFO1:
674 can_x->rf1 = CAN_RF1_RF1R_VAL;
675 break;
676 default:
677 break;
678 }
679}
680
692uint8_t can_receive_message_pending_get(can_type* can_x, can_rx_fifo_num_type fifo_number)
693{
694 uint8_t message_pending = 0;
695 switch (fifo_number)
696 {
697 case CAN_RX_FIFO0:
698 message_pending = can_x->rf0_bit.rf0mn;
699 break;
700 case CAN_RX_FIFO1:
701 message_pending = can_x->rf1_bit.rf1mn;
702 break;
703 default:
704 break;
705 }
706 return message_pending;
707}
708
723 error_status can_operating_mode_set(can_type* can_x, can_operating_mode_type can_operating_mode)
724{
725 error_status status = ERROR;
726 uint32_t time_out_index = FZC_TIMEOUT;
727
728 if (can_operating_mode == CAN_OPERATINGMODE_FREEZE)
729 {
730 /* request enter freeze mode */
731 can_x->mctrl_bit.dzen = FALSE;
732 can_x->mctrl_bit.fzen = TRUE;
733
734 while(((can_x->msts_bit.dzc) || (!can_x->msts_bit.fzc)) && (time_out_index != 0))
735 {
736 time_out_index--;
737 }
738 if((can_x->msts_bit.dzc) || (!can_x->msts_bit.fzc))
739 {
740 status = ERROR;
741 }
742 else
743 {
744 status = SUCCESS;
745 }
746 }
747 else if(can_operating_mode == CAN_OPERATINGMODE_DOZE)
748 {
749 /* request enter doze mode */
750 can_x->mctrl_bit.dzen = TRUE;
751 can_x->mctrl_bit.fzen = FALSE;
752
753 while(((!can_x->msts_bit.dzc) || (can_x->msts_bit.fzc)) && (time_out_index != 0))
754 {
755 time_out_index--;
756 }
757 if((!can_x->msts_bit.dzc) || (can_x->msts_bit.fzc))
758 {
759 status = ERROR;
760 }
761 else
762 {
763 status = SUCCESS;
764 }
765 }
766 else if(can_operating_mode == CAN_OPERATINGMODE_COMMUNICATE)
767 {
768 /* request enter normal mode */
769 can_x->mctrl_bit.dzen = FALSE;
770 can_x->mctrl_bit.fzen = FALSE;
771
772 while(((can_x->msts_bit.dzc) || (can_x->msts_bit.fzc)) && (time_out_index != 0))
773 {
774 time_out_index--;
775 }
776 if((can_x->msts_bit.dzc) || (can_x->msts_bit.fzc))
777 {
778 status = ERROR;
779 }
780 else
781 {
782 status = SUCCESS;
783 }
784 }
785 else
786 {
787 status = ERROR;
788 }
789 return status;
790}
791
801 can_enter_doze_status_type can_doze_mode_enter(can_type* can_x)
802{
803 can_enter_doze_status_type status = CAN_ENTER_DOZE_FAILED;
804 uint32_t time_out_index = FZC_TIMEOUT;
805 can_x->mctrl_bit.fzen = FALSE;
806 can_x->mctrl_bit.dzen = TRUE;
807 while(((!can_x->msts_bit.dzc) || (can_x->msts_bit.fzc)) && (time_out_index != 0))
808 {
809 time_out_index--;
810 }
811 if((!can_x->msts_bit.dzc) || (can_x->msts_bit.fzc))
812 {
813 status = CAN_ENTER_DOZE_FAILED;
814 }
815 else
816 {
817 status = CAN_ENTER_DOZE_SUCCESSFUL;
818 }
819 return status;
820}
821
831 can_quit_doze_status_type can_doze_mode_exit(can_type* can_x)
832{
833 can_quit_doze_status_type status = CAN_QUIT_DOZE_FAILED;
834 uint32_t time_out_index = DZC_TIMEOUT;
835 can_x->mctrl_bit.dzen = FALSE;
836 while((can_x->msts_bit.dzc) && (time_out_index != 0))
837 {
838 time_out_index--;
839 }
840 if(!can_x->msts_bit.dzc)
841 {
842 status = CAN_QUIT_DOZE_SUCCESSFUL;
843 }
844 return status;
845}
846
863 can_error_record_type can_error_type_record_get(can_type* can_x)
864{
865 can_error_record_type error_code = CAN_ERRORRECORD_NOERR;
866
867 error_code = (can_error_record_type)can_x->ests_bit.etr;
868 return error_code;
869}
870
878uint8_t can_receive_error_counter_get(can_type* can_x)
879{
880 uint8_t counter = 0;
881 counter = can_x->ests_bit.rec;
882 return counter;
883}
884
892uint8_t can_transmit_error_counter_get(can_type* can_x)
893{
894 uint8_t counter = 0;
895 counter = can_x->ests_bit.tec;
896 return counter;
897}
898
924void can_interrupt_enable(can_type* can_x, uint32_t can_int, confirm_state new_state)
925{
926 if (new_state != FALSE)
927 {
928 can_x->inten |= can_int;
929 }
930 else
931 {
932 can_x->inten &= ~can_int;
933 }
934}
935
964 flag_status can_flag_get(can_type* can_x, uint32_t can_flag)
965{
966 flag_status bit_status = RESET;
967 switch(can_flag)
968 {
969 case CAN_EAF_FLAG:
970 bit_status = (flag_status)can_x->ests_bit.eaf;
971 break;
972 case CAN_EPF_FLAG:
973 bit_status = (flag_status)can_x->ests_bit.epf;
974 break;
975 case CAN_BOF_FLAG:
976 bit_status = (flag_status)can_x->ests_bit.bof;
977 break;
978 case CAN_ETR_FLAG:
979 if(can_x->ests_bit.etr != 0)
980 {
981 bit_status = SET;
982 }
983 else
984 {
985 bit_status = RESET;
986 }
987 break;
988 case CAN_EOIF_FLAG:
989 bit_status = (flag_status)can_x->msts_bit.eoif;
990 break;
991 case CAN_TM0TCF_FLAG:
992 bit_status = (flag_status)can_x->tsts_bit.tm0tcf;
993 break;
994 case CAN_TM1TCF_FLAG:
995 bit_status = (flag_status)can_x->tsts_bit.tm1tcf;
996 break;
997 case CAN_TM2TCF_FLAG:
998 bit_status = (flag_status)can_x->tsts_bit.tm2tcf;
999 break;
1000 case CAN_RF0MN_FLAG:
1001 if(can_x->rf0_bit.rf0mn != 0)
1002 {
1003 bit_status = SET;
1004 }
1005 else
1006 {
1007 bit_status = RESET;
1008 }
1009 break;
1010 case CAN_RF0FF_FLAG:
1011 bit_status = (flag_status)can_x->rf0_bit.rf0ff;
1012 break;
1013 case CAN_RF0OF_FLAG:
1014 bit_status = (flag_status)can_x->rf0_bit.rf0of;
1015 break;
1016 case CAN_RF1MN_FLAG:
1017 if(can_x->rf1_bit.rf1mn != 0)
1018 {
1019 bit_status = SET;
1020 }
1021 else
1022 {
1023 bit_status = RESET;
1024 }
1025 break;
1026 case CAN_RF1FF_FLAG:
1027 bit_status = (flag_status)can_x->rf1_bit.rf1ff;
1028 break;
1029 case CAN_RF1OF_FLAG:
1030 bit_status = (flag_status)can_x->rf1_bit.rf1of;
1031 break;
1032 case CAN_QDZIF_FLAG:
1033 bit_status = (flag_status)can_x->msts_bit.qdzif;
1034 break;
1035 case CAN_EDZC_FLAG:
1036 if((can_x->msts_bit.dzc != RESET) ||(can_x->msts_bit.edzif != RESET))
1037 {
1038 bit_status = SET;
1039 }
1040 else
1041 {
1042 bit_status = RESET;
1043 }
1044 break;
1045 case CAN_TMEF_FLAG:
1046 if((can_x->tsts_bit.tm0ef != RESET) || (can_x->tsts_bit.tm1ef != RESET) || (can_x->tsts_bit.tm2ef != RESET))
1047 {
1048 bit_status = SET;
1049 }
1050 else
1051 {
1052 bit_status = RESET;
1053 }
1054 break;
1055 default:
1056 bit_status = RESET;
1057 break;
1058 }
1059 return bit_status;
1060}
1061
1087void can_flag_clear(can_type* can_x, uint32_t can_flag)
1088{
1089 switch(can_flag)
1090 {
1091 case CAN_EAF_FLAG:
1092 case CAN_EPF_FLAG:
1093 case CAN_BOF_FLAG:
1094 case CAN_EOIF_FLAG:
1095 can_x->msts = CAN_MSTS_EOIF_VAL;
1096 break;
1097 case CAN_ETR_FLAG:
1098 can_x->msts = CAN_MSTS_EOIF_VAL;
1099 can_x->ests = 0;
1100 break;
1101 case CAN_TM0TCF_FLAG:
1102 can_x->tsts = CAN_TSTS_TM0TCF_VAL;
1103 break;
1104 case CAN_TM1TCF_FLAG:
1105 can_x->tsts = CAN_TSTS_TM1TCF_VAL;
1106 break;
1107 case CAN_TM2TCF_FLAG:
1108 can_x->tsts = CAN_TSTS_TM2TCF_VAL;
1109 break;
1110 case CAN_RF0FF_FLAG:
1111 can_x->rf0 = CAN_RF0_RF0FF_VAL;
1112 break;
1113 case CAN_RF0OF_FLAG:
1114 can_x->rf0 = CAN_RF0_RF0OF_VAL;
1115 break;
1116 case CAN_RF1FF_FLAG:
1117 can_x->rf1 = CAN_RF1_RF1FF_VAL;
1118 break;
1119 case CAN_RF1OF_FLAG:
1120 can_x->rf1 = CAN_RF1_RF1OF_VAL;
1121 break;
1122 case CAN_QDZIF_FLAG:
1123 can_x->msts = CAN_MSTS_QDZIF_VAL;
1124 break;
1125 case CAN_EDZC_FLAG:
1126 can_x->msts = CAN_MSTS_EDZIF_VAL;
1127 break;
1128 case CAN_TMEF_FLAG:
1129 can_x->tsts = CAN_TSTS_TM0TCF_VAL | CAN_TSTS_TM1TCF_VAL | CAN_TSTS_TM2TCF_VAL;
1130 break;
1131 default:
1132 break;
1133 }
1134}
1135
1140#endif
1141
counter
uint16_t counter
Definition: project/at_start_f435/examples/debug/tmr1/src/main.c:39
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
can_transmit_status_type
can_transmit_status_type
can transmit status
Definition: at32f435_437_can.h:271
can_quit_doze_status_type
can_quit_doze_status_type
can quit doze mode status
Definition: at32f435_437_can.h:291
can_trans_frame_type
can_trans_frame_type
can transmission frame type
Definition: at32f435_437_can.h:243
can_error_record_type
can_error_record_type
can error type record
Definition: at32f435_437_can.h:318
can_operating_mode_type
can_operating_mode_type
can operating mode
Definition: at32f435_437_can.h:175
can_tx_mailbox_num_type
can_tx_mailbox_num_type
can tx mailboxes
Definition: at32f435_437_can.h:252
can_enter_doze_status_type
can_enter_doze_status_type
can enter doze mode status
Definition: at32f435_437_can.h:282
can_rx_fifo_num_type
can_rx_fifo_num_type
can receive fifo
Definition: at32f435_437_can.h:262
can_identifier_type
can_identifier_type
can identifier type
Definition: at32f435_437_can.h:234
CAN_FILTER_FIFO0
@ CAN_FILTER_FIFO0
Definition: at32f435_437_can.h:138
CAN_FILTER_FIFO1
@ CAN_FILTER_FIFO1
Definition: at32f435_437_can.h:139
CAN_TX_STATUS_SUCCESSFUL
@ CAN_TX_STATUS_SUCCESSFUL
Definition: at32f435_437_can.h:273
CAN_TX_STATUS_PENDING
@ CAN_TX_STATUS_PENDING
Definition: at32f435_437_can.h:274
CAN_TX_STATUS_NO_EMPTY
@ CAN_TX_STATUS_NO_EMPTY
Definition: at32f435_437_can.h:275
CAN_TX_STATUS_FAILED
@ CAN_TX_STATUS_FAILED
Definition: at32f435_437_can.h:272
CAN_DISCARDING_FIRST_RECEIVED
@ CAN_DISCARDING_FIRST_RECEIVED
Definition: at32f435_437_can.h:301
CAN_BTS2_3TQ
@ CAN_BTS2_3TQ
Definition: at32f435_437_can.h:222
CAN_QUIT_DOZE_FAILED
@ CAN_QUIT_DOZE_FAILED
Definition: at32f435_437_can.h:292
CAN_QUIT_DOZE_SUCCESSFUL
@ CAN_QUIT_DOZE_SUCCESSFUL
Definition: at32f435_437_can.h:293
CAN_BTS1_4TQ
@ CAN_BTS1_4TQ
Definition: at32f435_437_can.h:200
CAN_ERRORRECORD_NOERR
@ CAN_ERRORRECORD_NOERR
Definition: at32f435_437_can.h:319
CAN_FILTER_MODE_ID_LIST
@ CAN_FILTER_MODE_ID_LIST
Definition: at32f435_437_can.h:148
CAN_FILTER_MODE_ID_MASK
@ CAN_FILTER_MODE_ID_MASK
Definition: at32f435_437_can.h:147
CAN_OPERATINGMODE_FREEZE
@ CAN_OPERATINGMODE_FREEZE
Definition: at32f435_437_can.h:176
CAN_OPERATINGMODE_COMMUNICATE
@ CAN_OPERATINGMODE_COMMUNICATE
Definition: at32f435_437_can.h:178
CAN_OPERATINGMODE_DOZE
@ CAN_OPERATINGMODE_DOZE
Definition: at32f435_437_can.h:177
CAN_SENDING_BY_ID
@ CAN_SENDING_BY_ID
Definition: at32f435_437_can.h:310
CAN_TX_MAILBOX2
@ CAN_TX_MAILBOX2
Definition: at32f435_437_can.h:255
CAN_TX_MAILBOX0
@ CAN_TX_MAILBOX0
Definition: at32f435_437_can.h:253
CAN_TX_MAILBOX1
@ CAN_TX_MAILBOX1
Definition: at32f435_437_can.h:254
CAN_FILTER_16BIT
@ CAN_FILTER_16BIT
Definition: at32f435_437_can.h:156
CAN_FILTER_32BIT
@ CAN_FILTER_32BIT
Definition: at32f435_437_can.h:157
CAN_ENTER_DOZE_FAILED
@ CAN_ENTER_DOZE_FAILED
Definition: at32f435_437_can.h:283
CAN_ENTER_DOZE_SUCCESSFUL
@ CAN_ENTER_DOZE_SUCCESSFUL
Definition: at32f435_437_can.h:284
CAN_RX_FIFO0
@ CAN_RX_FIFO0
Definition: at32f435_437_can.h:263
CAN_RX_FIFO1
@ CAN_RX_FIFO1
Definition: at32f435_437_can.h:264
CAN_ID_STANDARD
@ CAN_ID_STANDARD
Definition: at32f435_437_can.h:235
CAN_ID_EXTENDED
@ CAN_ID_EXTENDED
Definition: at32f435_437_can.h:236
CAN_MODE_COMMUNICATE
@ CAN_MODE_COMMUNICATE
Definition: at32f435_437_can.h:165
CAN_RSAW_2TQ
@ CAN_RSAW_2TQ
Definition: at32f435_437_can.h:187
CAN_EDZC_FLAG
#define CAN_EDZC_FLAG
Definition: at32f435_437_can.h:79
CAN_TM1TCF_FLAG
#define CAN_TM1TCF_FLAG
Definition: at32f435_437_can.h:70
CAN_QDZIF_FLAG
#define CAN_QDZIF_FLAG
Definition: at32f435_437_can.h:78
CAN_TM0TCF_FLAG
#define CAN_TM0TCF_FLAG
Definition: at32f435_437_can.h:69
CAN_RF1FF_FLAG
#define CAN_RF1FF_FLAG
Definition: at32f435_437_can.h:76
CAN_RF0FF_FLAG
#define CAN_RF0FF_FLAG
Definition: at32f435_437_can.h:73
CAN_RF1MN_FLAG
#define CAN_RF1MN_FLAG
Definition: at32f435_437_can.h:75
CAN_EPF_FLAG
#define CAN_EPF_FLAG
Definition: at32f435_437_can.h:65
CAN_RF1OF_FLAG
#define CAN_RF1OF_FLAG
Definition: at32f435_437_can.h:77
CAN_EAF_FLAG
#define CAN_EAF_FLAG
Definition: at32f435_437_can.h:64
CAN_RF0MN_FLAG
#define CAN_RF0MN_FLAG
Definition: at32f435_437_can.h:72
CAN_TM2TCF_FLAG
#define CAN_TM2TCF_FLAG
Definition: at32f435_437_can.h:71
CAN_ETR_FLAG
#define CAN_ETR_FLAG
Definition: at32f435_437_can.h:67
CAN_RF0OF_FLAG
#define CAN_RF0OF_FLAG
Definition: at32f435_437_can.h:74
CAN_EOIF_FLAG
#define CAN_EOIF_FLAG
Definition: at32f435_437_can.h:68
CAN_TMEF_FLAG
#define CAN_TMEF_FLAG
Definition: at32f435_437_can.h:80
CAN_BOF_FLAG
#define CAN_BOF_FLAG
Definition: at32f435_437_can.h:66
can_base_init
error_status can_base_init(can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct.
Definition: at32f435_437_can.c:194
can_reset
void can_reset(can_type *can_x)
deinitialize the can peripheral registers to their default reset values.
Definition: at32f435_437_can.c:51
can_transmit_error_counter_get
uint8_t can_transmit_error_counter_get(can_type *can_x)
return the transmit error counter of the specified can peripheral.
Definition: at32f435_437_can.c:892
can_transmit_status_get
can_transmit_status_type can_transmit_status_get(can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral.
Definition: at32f435_437_can.c:514
can_ttc_mode_enable
void can_ttc_mode_enable(can_type *can_x, confirm_state new_state)
enable or disable time trigger operation communication mode of the specified can peripheral.
Definition: at32f435_437_can.c:416
can_filter_default_para_init
void can_filter_default_para_init(can_filter_init_type *can_filter_init_struct)
fill each can_filter_init_struct member with its default value.
Definition: at32f435_437_can.c:269
can_receive_fifo_release
void can_receive_fifo_release(can_type *can_x, can_rx_fifo_num_type fifo_number)
release the specified fifo of the specified can peripheral.
Definition: at32f435_437_can.c:666
can_receive_error_counter_get
uint8_t can_receive_error_counter_get(can_type *can_x)
return the receive error counter (rec) of the specified can peripheral.
Definition: at32f435_437_can.c:878
can_operating_mode_set
error_status can_operating_mode_set(can_type *can_x, can_operating_mode_type can_operating_mode)
set the operation mode of the specified can peripheral.
Definition: at32f435_437_can.c:723
can_baudrate_default_para_init
void can_baudrate_default_para_init(can_baudrate_type *can_baudrate_struct)
fill each can_baudrate_struct member with its default value.
Definition: at32f435_437_can.c:70
can_transmit_cancel
void can_transmit_cancel(can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
cancel a transmit request of the specified can peripheral.
Definition: at32f435_437_can.c:589
can_receive_message_pending_get
uint8_t can_receive_message_pending_get(can_type *can_x, can_rx_fifo_num_type fifo_number)
return the number of pending messages of the specified can peripheral.
Definition: at32f435_437_can.c:692
can_message_transmit
uint8_t can_message_transmit(can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral.
Definition: at32f435_437_can.c:440
can_message_receive
void can_message_receive(can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral.
Definition: at32f435_437_can.c:619
can_interrupt_enable
void can_interrupt_enable(can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral.
Definition: at32f435_437_can.c:924
can_flag_get
flag_status can_flag_get(can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral.
Definition: at32f435_437_can.c:964
can_flag_clear
void can_flag_clear(can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral.
Definition: at32f435_437_can.c:1087
can_baudrate_set
error_status can_baudrate_set(can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral
Definition: at32f435_437_can.c:99
can_debug_transmission_prohibit
void can_debug_transmission_prohibit(can_type *can_x, confirm_state new_state)
enable or disable the debug transmission prohibit of the specified can peripheral.
Definition: at32f435_437_can.c:395
can_error_type_record_get
can_error_record_type can_error_type_record_get(can_type *can_x)
return the error type record (etr) of the specified can peripheral.
Definition: at32f435_437_can.c:863
can_filter_init
void can_filter_init(can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct.
Definition: at32f435_437_can.c:304
can_default_para_init
void can_default_para_init(can_base_type *can_base_struct)
fill each can_init_struct member with its default value.
Definition: at32f435_437_can.c:157
can_doze_mode_exit
can_quit_doze_status_type can_doze_mode_exit(can_type *can_x)
exit the doze mode of the specified can peripheral.
Definition: at32f435_437_can.c:831
can_doze_mode_enter
can_enter_doze_status_type can_doze_mode_enter(can_type *can_x)
enter the low power mode of the specified can peripheral.
Definition: at32f435_437_can.c:801
DZC_TIMEOUT
#define DZC_TIMEOUT
Definition: at32f435_437_can.h:53
FZC_TIMEOUT
#define FZC_TIMEOUT
Definition: at32f435_437_can.h:52
CAN_RF1_RF1FF_VAL
#define CAN_RF1_RF1FF_VAL
Definition: at32f435_437_can.h:125
CAN_RF0_RF0FF_VAL
#define CAN_RF0_RF0FF_VAL
Definition: at32f435_437_can.h:122
CAN_TSTS_TM0TCF_VAL
#define CAN_TSTS_TM0TCF_VAL
Definition: at32f435_437_can.h:116
CAN_TSTS_TM2CT_VAL
#define CAN_TSTS_TM2CT_VAL
Definition: at32f435_437_can.h:121
CAN_RF1_RF1R_VAL
#define CAN_RF1_RF1R_VAL
Definition: at32f435_437_can.h:127
CAN1
#define CAN1
Definition: at32f435_437_can.h:994
CAN_MSTS_EOIF_VAL
#define CAN_MSTS_EOIF_VAL
can flag clear operation macro definition val
Definition: at32f435_437_can.h:113
CAN_MSTS_QDZIF_VAL
#define CAN_MSTS_QDZIF_VAL
Definition: at32f435_437_can.h:114
CAN_TSTS_TM2TCF_VAL
#define CAN_TSTS_TM2TCF_VAL
Definition: at32f435_437_can.h:118
CAN_RF0_RF0OF_VAL
#define CAN_RF0_RF0OF_VAL
Definition: at32f435_437_can.h:123
CAN_RF0_RF0R_VAL
#define CAN_RF0_RF0R_VAL
Definition: at32f435_437_can.h:124
CAN_RF1_RF1OF_VAL
#define CAN_RF1_RF1OF_VAL
Definition: at32f435_437_can.h:126
CAN_TSTS_TM1TCF_VAL
#define CAN_TSTS_TM1TCF_VAL
Definition: at32f435_437_can.h:117
CAN2
#define CAN2
Definition: at32f435_437_can.h:995
CAN_TSTS_TM0CT_VAL
#define CAN_TSTS_TM0CT_VAL
Definition: at32f435_437_can.h:119
CAN_TSTS_TM1CT_VAL
#define CAN_TSTS_TM1CT_VAL
Definition: at32f435_437_can.h:120
CAN_MSTS_EDZIF_VAL
#define CAN_MSTS_EDZIF_VAL
Definition: at32f435_437_can.h:115
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f435_437_crm.c:251
CRM_CAN1_PERIPH_RESET
@ CRM_CAN1_PERIPH_RESET
Definition: at32f435_437_crm.h:294
CRM_CAN2_PERIPH_RESET
@ CRM_CAN2_PERIPH_RESET
Definition: at32f435_437_crm.h:295
error_status
error_status
Definition: at32f435_437.h:380
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
can_base_type
can init structure definition
Definition: at32f435_437_can.h:333
can_base_type::prsf_enable
confirm_state prsf_enable
Definition: at32f435_437_can.h:342
can_base_type::mdrsel_selection
can_msg_discarding_rule_type mdrsel_selection
Definition: at32f435_437_can.h:344
can_base_type::aed_enable
confirm_state aed_enable
Definition: at32f435_437_can.h:340
can_base_type::mmssr_selection
can_msg_sending_rule_type mmssr_selection
Definition: at32f435_437_can.h:346
can_base_type::ttc_enable
confirm_state ttc_enable
Definition: at32f435_437_can.h:336
can_base_type::mode_selection
can_mode_type mode_selection
Definition: at32f435_437_can.h:334
can_base_type::aebo_enable
confirm_state aebo_enable
Definition: at32f435_437_can.h:338
can_baudrate_type
can baudrate structure definition
Definition: at32f435_437_can.h:354
can_baudrate_type::baudrate_div
uint16_t baudrate_div
Definition: at32f435_437_can.h:355
can_baudrate_type::rsaw_size
can_rsaw_type rsaw_size
Definition: at32f435_437_can.h:357
can_baudrate_type::bts2_size
can_bts2_type bts2_size
Definition: at32f435_437_can.h:361
can_baudrate_type::bts1_size
can_bts1_type bts1_size
Definition: at32f435_437_can.h:359
can_fifo_mailbox_type::rfdt4
__IO uint32_t rfdt4
Definition: at32f435_437_can.h:566
can_fifo_mailbox_type::rfi
__IO uint32_t rfi
Definition: at32f435_437_can.h:517
can_fifo_mailbox_type::rfdt0
__IO uint32_t rfdt0
Definition: at32f435_437_can.h:551
can_fifo_mailbox_type::rfsid
__IO uint32_t rfsid
Definition: at32f435_437_can.h:524
can_fifo_mailbox_type::rfdt2
__IO uint32_t rfdt2
Definition: at32f435_437_can.h:553
can_fifo_mailbox_type::rfdtl
__IO uint32_t rfdtl
Definition: at32f435_437_can.h:536
can_fifo_mailbox_type::rfidi
__IO uint32_t rfidi
Definition: at32f435_437_can.h:522
can_fifo_mailbox_type::rfdth_bit
struct can_fifo_mailbox_type::@111::@116 rfdth_bit
can_fifo_mailbox_type::rfdt1
__IO uint32_t rfdt1
Definition: at32f435_437_can.h:552
can_fifo_mailbox_type::rfdtl_bit
struct can_fifo_mailbox_type::@109::@115 rfdtl_bit
can_fifo_mailbox_type::rfdt6
__IO uint32_t rfdt6
Definition: at32f435_437_can.h:568
can_fifo_mailbox_type::rffri
__IO uint32_t rffri
Definition: at32f435_437_can.h:521
can_fifo_mailbox_type::rfc_bit
struct can_fifo_mailbox_type::@107::@114 rfc_bit
can_fifo_mailbox_type::rfi_bit
struct can_fifo_mailbox_type::@105::@113 rfi_bit
can_fifo_mailbox_type::rfdt3
__IO uint32_t rfdt3
Definition: at32f435_437_can.h:554
can_fifo_mailbox_type::rfdt5
__IO uint32_t rfdt5
Definition: at32f435_437_can.h:567
can_fifo_mailbox_type::rfdt7
__IO uint32_t rfdt7
Definition: at32f435_437_can.h:569
can_fifo_mailbox_type::rffmn
__IO uint32_t rffmn
Definition: at32f435_437_can.h:538
can_filter_init_type
can filter init structure definition
Definition: at32f435_437_can.h:369
can_filter_init_type::filter_mask_low
uint16_t filter_mask_low
Definition: at32f435_437_can.h:389
can_filter_init_type::filter_number
uint8_t filter_number
Definition: at32f435_437_can.h:376
can_filter_init_type::filter_fifo
can_filter_fifo_type filter_fifo
Definition: at32f435_437_can.h:374
can_filter_init_type::filter_bit
can_filter_bit_width_type filter_bit
Definition: at32f435_437_can.h:378
can_filter_init_type::filter_mode
can_filter_mode_type filter_mode
Definition: at32f435_437_can.h:372
can_filter_init_type::filter_activate_enable
confirm_state filter_activate_enable
Definition: at32f435_437_can.h:370
can_filter_init_type::filter_mask_high
uint16_t filter_mask_high
Definition: at32f435_437_can.h:386
can_filter_init_type::filter_id_high
uint16_t filter_id_high
Definition: at32f435_437_can.h:380
can_filter_init_type::filter_id_low
uint16_t filter_id_low
Definition: at32f435_437_can.h:383
can_filter_register_type::ffdb1
__IO uint32_t ffdb1
Definition: at32f435_437_can.h:579
can_filter_register_type::ffdb2
__IO uint32_t ffdb2
Definition: at32f435_437_can.h:580
can_rx_message_type
can rx message structure definition
Definition: at32f435_437_can.h:419
can_rx_message_type::standard_id
uint32_t standard_id
Definition: at32f435_437_can.h:420
can_rx_message_type::id_type
can_identifier_type id_type
Definition: at32f435_437_can.h:426
can_rx_message_type::frame_type
can_trans_frame_type frame_type
Definition: at32f435_437_can.h:428
can_rx_message_type::data
uint8_t data[8]
Definition: at32f435_437_can.h:433
can_rx_message_type::dlc
uint8_t dlc
Definition: at32f435_437_can.h:430
can_rx_message_type::extended_id
uint32_t extended_id
Definition: at32f435_437_can.h:423
can_rx_message_type::filter_index
uint8_t filter_index
Definition: at32f435_437_can.h:435
can_tx_mailbox_type::tmtsten
__IO uint32_t tmtsten
Definition: at32f435_437_can.h:470
can_tx_mailbox_type::tmi_bit
struct can_tx_mailbox_type::@93::@101 tmi_bit
can_tx_mailbox_type::tmi
__IO uint32_t tmi
Definition: at32f435_437_can.h:449
can_tx_mailbox_type::tmsr
__IO uint32_t tmsr
Definition: at32f435_437_can.h:452
can_tx_mailbox_type::tmdtl
__IO uint32_t tmdtl
Definition: at32f435_437_can.h:481
can_tx_mailbox_type::tmdtbl
__IO uint32_t tmdtbl
Definition: at32f435_437_can.h:468
can_tx_mailbox_type::tmfrsel
__IO uint32_t tmfrsel
Definition: at32f435_437_can.h:453
can_tx_mailbox_type::tmsid
__IO uint32_t tmsid
Definition: at32f435_437_can.h:456
can_tx_mailbox_type::tmc_bit
struct can_tx_mailbox_type::@95::@102 tmc_bit
can_tx_mailbox_type::tmdth
__IO uint32_t tmdth
Definition: at32f435_437_can.h:496
can_tx_mailbox_type::tmidsel
__IO uint32_t tmidsel
Definition: at32f435_437_can.h:454
can_tx_message_type
can tx message structure definition
Definition: at32f435_437_can.h:397
can_tx_message_type::extended_id
uint32_t extended_id
Definition: at32f435_437_can.h:401
can_tx_message_type::frame_type
can_trans_frame_type frame_type
Definition: at32f435_437_can.h:406
can_tx_message_type::data
uint8_t data[8]
Definition: at32f435_437_can.h:411
can_tx_message_type::dlc
uint8_t dlc
Definition: at32f435_437_can.h:408
can_tx_message_type::id_type
can_identifier_type id_type
Definition: at32f435_437_can.h:404
can_tx_message_type::standard_id
uint32_t standard_id
Definition: at32f435_437_can.h:398
can_type
type define can register all
Definition: at32f435_437_can.h:587
can_type::rf0of
__IO uint32_t rf0of
Definition: at32f435_437_can.h:681
can_type::mctrl_bit
struct can_type::@117::@143 mctrl_bit
can_type::tm2ef
__IO uint32_t tm2ef
Definition: at32f435_437_can.h:663
can_type::eaf
__IO uint32_t eaf
Definition: at32f435_437_can.h:740
can_type::rf1
__IO uint32_t rf1
Definition: at32f435_437_can.h:692
can_type::tm0tsf
__IO uint32_t tm0tsf
Definition: at32f435_437_can.h:643
can_type::aeden
__IO uint32_t aeden
Definition: at32f435_437_can.h:602
can_type::dzc
__IO uint32_t dzc
Definition: at32f435_437_can.h:621
can_type::tm0tcf
__IO uint32_t tm0tcf
Definition: at32f435_437_can.h:642
can_type::edzif
__IO uint32_t edzif
Definition: at32f435_437_can.h:624
can_type::mdrsel
__IO uint32_t mdrsel
Definition: at32f435_437_can.h:600
can_type::rf1ff
__IO uint32_t rf1ff
Definition: at32f435_437_can.h:697
can_type::bof
__IO uint32_t bof
Definition: at32f435_437_can.h:742
can_type::tec
__IO uint32_t tec
Definition: at32f435_437_can.h:746
can_type::rf0_bit
struct can_type::@123::@146 rf0_bit
can_type::ttcen
__IO uint32_t ttcen
Definition: at32f435_437_can.h:604
can_type::tx_mailbox
can_tx_mailbox_type tx_mailbox[3]
can controller area network tx mailbox register, offset:0x180~0x1AC
Definition: at32f435_437_can.h:779
can_type::tm1tcf
__IO uint32_t tm1tcf
Definition: at32f435_437_can.h:648
can_type::lben
__IO uint32_t lben
Definition: at32f435_437_can.h:766
can_type::rf1_bit
struct can_type::@125::@147 rf1_bit
can_type::ptd
__IO uint32_t ptd
Definition: at32f435_437_can.h:607
can_type::fzc
__IO uint32_t fzc
Definition: at32f435_437_can.h:620
can_type::tm0ef
__IO uint32_t tm0ef
Definition: at32f435_437_can.h:661
can_type::bts2
__IO uint32_t bts2
Definition: at32f435_437_can.h:762
can_type::loen
__IO uint32_t loen
Definition: at32f435_437_can.h:767
can_type::ests_bit
struct can_type::@129::@149 ests_bit
can_type::ests
__IO uint32_t ests
Definition: at32f435_437_can.h:737
can_type::ffb
can_filter_register_type ffb[28]
can ffb register, offset:0x240~0x2AC
Definition: at32f435_437_can.h:987
can_type::frf
__IO uint32_t frf
Definition: at32f435_437_can.h:899
can_type::rsaw
__IO uint32_t rsaw
Definition: at32f435_437_can.h:764
can_type::rf0
__IO uint32_t rf0
Definition: at32f435_437_can.h:675
can_type::tsts_bit
struct can_type::@121::@145 tsts_bit
can_type::rf1mn
__IO uint32_t rf1mn
Definition: at32f435_437_can.h:695
can_type::prsfen
__IO uint32_t prsfen
Definition: at32f435_437_can.h:601
can_type::facfg
__IO uint32_t facfg
Definition: at32f435_437_can.h:944
can_type::tm1ef
__IO uint32_t tm1ef
Definition: at32f435_437_can.h:662
can_type::aeboen
__IO uint32_t aeboen
Definition: at32f435_437_can.h:603
can_type::eoif
__IO uint32_t eoif
Definition: at32f435_437_can.h:622
can_type::tm2tcf
__IO uint32_t tm2tcf
Definition: at32f435_437_can.h:654
can_type::brdiv
__IO uint32_t brdiv
Definition: at32f435_437_can.h:759
can_type::epf
__IO uint32_t epf
Definition: at32f435_437_can.h:741
can_type::dzen
__IO uint32_t dzen
Definition: at32f435_437_can.h:598
can_type::etr
__IO uint32_t etr
Definition: at32f435_437_can.h:744
can_type::fifo_mailbox
can_fifo_mailbox_type fifo_mailbox[2]
can controller area network fifo mailbox register, offset:0x1B0~0x1CC
Definition: at32f435_437_can.h:784
can_type::tsts
__IO uint32_t tsts
Definition: at32f435_437_can.h:639
can_type::fbwcfg
__IO uint32_t fbwcfg
Definition: at32f435_437_can.h:854
can_type::fctrl_bit
struct can_type::@133::@151 fctrl_bit
can_type::qdzif
__IO uint32_t qdzif
Definition: at32f435_437_can.h:623
can_type::rf0mn
__IO uint32_t rf0mn
Definition: at32f435_437_can.h:678
can_type::rf0ff
__IO uint32_t rf0ff
Definition: at32f435_437_can.h:680
can_type::fcs
__IO uint32_t fcs
Definition: at32f435_437_can.h:799
can_type::msts
__IO uint32_t msts
Definition: at32f435_437_can.h:617
can_type::rec
__IO uint32_t rec
Definition: at32f435_437_can.h:747
can_type::bts1
__IO uint32_t bts1
Definition: at32f435_437_can.h:761
can_type::tm2tsf
__IO uint32_t tm2tsf
Definition: at32f435_437_can.h:655
can_type::btmg_bit
struct can_type::@131::@150 btmg_bit
can_type::msts_bit
struct can_type::@119::@144 msts_bit
can_type::rf1of
__IO uint32_t rf1of
Definition: at32f435_437_can.h:698
can_type::fzen
__IO uint32_t fzen
Definition: at32f435_437_can.h:597
can_type::mmssr
__IO uint32_t mmssr
Definition: at32f435_437_can.h:599
can_type::inten
__IO uint32_t inten
Definition: at32f435_437_can.h:709
can_type::fmcfg
__IO uint32_t fmcfg
Definition: at32f435_437_can.h:809
can_type::tm1tsf
__IO uint32_t tm1tsf
Definition: at32f435_437_can.h:649
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_can.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_can.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CAN_H
29#define __AT32F435_437_CAN_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
52#define FZC_TIMEOUT ((uint32_t)0x0000FFFF)
53#define DZC_TIMEOUT ((uint32_t)0x0000FFFF)
64#define CAN_EAF_FLAG ((uint32_t)0x01)
65#define CAN_EPF_FLAG ((uint32_t)0x02)
66#define CAN_BOF_FLAG ((uint32_t)0x03)
67#define CAN_ETR_FLAG ((uint32_t)0x04)
68#define CAN_EOIF_FLAG ((uint32_t)0x05)
69#define CAN_TM0TCF_FLAG ((uint32_t)0x06)
70#define CAN_TM1TCF_FLAG ((uint32_t)0x07)
71#define CAN_TM2TCF_FLAG ((uint32_t)0x08)
72#define CAN_RF0MN_FLAG ((uint32_t)0x09)
73#define CAN_RF0FF_FLAG ((uint32_t)0x0A)
74#define CAN_RF0OF_FLAG ((uint32_t)0x0B)
75#define CAN_RF1MN_FLAG ((uint32_t)0x0C)
76#define CAN_RF1FF_FLAG ((uint32_t)0x0D)
77#define CAN_RF1OF_FLAG ((uint32_t)0x0E)
78#define CAN_QDZIF_FLAG ((uint32_t)0x0F)
79#define CAN_EDZC_FLAG ((uint32_t)0x10)
80#define CAN_TMEF_FLAG ((uint32_t)0x11)
91#define CAN_TCIEN_INT ((uint32_t)0x00000001)
92#define CAN_RF0MIEN_INT ((uint32_t)0x00000002)
93#define CAN_RF0FIEN_INT ((uint32_t)0x00000004)
94#define CAN_RF0OIEN_INT ((uint32_t)0x00000008)
95#define CAN_RF1MIEN_INT ((uint32_t)0x00000010)
96#define CAN_RF1FIEN_INT ((uint32_t)0x00000020)
97#define CAN_RF1OIEN_INT ((uint32_t)0x00000040)
98#define CAN_EAIEN_INT ((uint32_t)0x00000100)
99#define CAN_EPIEN_INT ((uint32_t)0x00000200)
100#define CAN_BOIEN_INT ((uint32_t)0x00000400)
101#define CAN_ETRIEN_INT ((uint32_t)0x00000800)
102#define CAN_EOIEN_INT ((uint32_t)0x00008000)
103#define CAN_QDZIEN_INT ((uint32_t)0x00010000)
104#define CAN_EDZIEN_INT ((uint32_t)0x00020000)
113#define CAN_MSTS_EOIF_VAL ((uint32_t)0x00000004)
114#define CAN_MSTS_QDZIF_VAL ((uint32_t)0x00000008)
115#define CAN_MSTS_EDZIF_VAL ((uint32_t)0x00000010)
116#define CAN_TSTS_TM0TCF_VAL ((uint32_t)0x00000001)
117#define CAN_TSTS_TM1TCF_VAL ((uint32_t)0x00000100)
118#define CAN_TSTS_TM2TCF_VAL ((uint32_t)0x00010000)
119#define CAN_TSTS_TM0CT_VAL ((uint32_t)0x00000080)
120#define CAN_TSTS_TM1CT_VAL ((uint32_t)0x00008000)
121#define CAN_TSTS_TM2CT_VAL ((uint32_t)0x00800000)
122#define CAN_RF0_RF0FF_VAL ((uint32_t)0x00000008)
123#define CAN_RF0_RF0OF_VAL ((uint32_t)0x00000010)
124#define CAN_RF0_RF0R_VAL ((uint32_t)0x00000020)
125#define CAN_RF1_RF1FF_VAL ((uint32_t)0x00000008)
126#define CAN_RF1_RF1OF_VAL ((uint32_t)0x00000010)
127#define CAN_RF1_RF1R_VAL ((uint32_t)0x00000020)
136typedef enum
137{
138 CAN_FILTER_FIFO0 = 0x00,
139 CAN_FILTER_FIFO1 = 0x01
140} can_filter_fifo_type;
141
145typedef enum
146{
147 CAN_FILTER_MODE_ID_MASK = 0x00,
148 CAN_FILTER_MODE_ID_LIST = 0x01
149} can_filter_mode_type;
150
154typedef enum
155{
156 CAN_FILTER_16BIT = 0x00,
157 CAN_FILTER_32BIT = 0x01
158} can_filter_bit_width_type;
159
163typedef enum
164{
165 CAN_MODE_COMMUNICATE = 0x00,
166 CAN_MODE_LOOPBACK = 0x01,
167 CAN_MODE_LISTENONLY = 0x02,
168 CAN_MODE_LISTENONLY_LOOPBACK = 0x03
169} can_mode_type;
170
174typedef enum
175{
176 CAN_OPERATINGMODE_FREEZE = 0x00,
177 CAN_OPERATINGMODE_DOZE = 0x01,
178 CAN_OPERATINGMODE_COMMUNICATE = 0x02
179} can_operating_mode_type;
180
184typedef enum
185{
186 CAN_RSAW_1TQ = 0x00,
187 CAN_RSAW_2TQ = 0x01,
188 CAN_RSAW_3TQ = 0x02,
189 CAN_RSAW_4TQ = 0x03
190} can_rsaw_type;
191
195typedef enum
196{
197 CAN_BTS1_1TQ = 0x00,
198 CAN_BTS1_2TQ = 0x01,
199 CAN_BTS1_3TQ = 0x02,
200 CAN_BTS1_4TQ = 0x03,
201 CAN_BTS1_5TQ = 0x04,
202 CAN_BTS1_6TQ = 0x05,
203 CAN_BTS1_7TQ = 0x06,
204 CAN_BTS1_8TQ = 0x07,
205 CAN_BTS1_9TQ = 0x08,
206 CAN_BTS1_10TQ = 0x09,
207 CAN_BTS1_11TQ = 0x0A,
208 CAN_BTS1_12TQ = 0x0B,
209 CAN_BTS1_13TQ = 0x0C,
210 CAN_BTS1_14TQ = 0x0D,
211 CAN_BTS1_15TQ = 0x0E,
212 CAN_BTS1_16TQ = 0x0F
213} can_bts1_type;
214
218typedef enum
219{
220 CAN_BTS2_1TQ = 0x00,
221 CAN_BTS2_2TQ = 0x01,
222 CAN_BTS2_3TQ = 0x02,
223 CAN_BTS2_4TQ = 0x03,
224 CAN_BTS2_5TQ = 0x04,
225 CAN_BTS2_6TQ = 0x05,
226 CAN_BTS2_7TQ = 0x06,
227 CAN_BTS2_8TQ = 0x07
228} can_bts2_type;
229
233typedef enum
234{
235 CAN_ID_STANDARD = 0x00,
236 CAN_ID_EXTENDED = 0x01
237} can_identifier_type;
238
242typedef enum
243{
244 CAN_TFT_DATA = 0x00,
245 CAN_TFT_REMOTE = 0x01
246} can_trans_frame_type;
247
251typedef enum
252{
253 CAN_TX_MAILBOX0 = 0x00,
254 CAN_TX_MAILBOX1 = 0x01,
255 CAN_TX_MAILBOX2 = 0x02
256} can_tx_mailbox_num_type;
257
261typedef enum
262{
263 CAN_RX_FIFO0 = 0x00,
264 CAN_RX_FIFO1 = 0x01
265} can_rx_fifo_num_type;
266
270typedef enum
271{
272 CAN_TX_STATUS_FAILED = 0x00,
273 CAN_TX_STATUS_SUCCESSFUL = 0x01,
274 CAN_TX_STATUS_PENDING = 0x02,
275 CAN_TX_STATUS_NO_EMPTY = 0x04
276} can_transmit_status_type;
277
281typedef enum
282{
283 CAN_ENTER_DOZE_FAILED = 0x00,
284 CAN_ENTER_DOZE_SUCCESSFUL = 0x01
285} can_enter_doze_status_type;
286
290typedef enum
291{
292 CAN_QUIT_DOZE_FAILED = 0x00,
293 CAN_QUIT_DOZE_SUCCESSFUL = 0x01
294} can_quit_doze_status_type;
295
299typedef enum
300{
301 CAN_DISCARDING_FIRST_RECEIVED = 0x00,
302 CAN_DISCARDING_LAST_RECEIVED = 0x01
303} can_msg_discarding_rule_type;
304
308typedef enum
309{
310 CAN_SENDING_BY_ID = 0x00,
311 CAN_SENDING_BY_REQUEST = 0x01
312} can_msg_sending_rule_type;
313
317typedef enum
318{
319 CAN_ERRORRECORD_NOERR = 0x00,
320 CAN_ERRORRECORD_STUFFERR = 0x01,
321 CAN_ERRORRECORD_FORMERR = 0x02,
322 CAN_ERRORRECORD_ACKERR = 0x03,
323 CAN_ERRORRECORD_BITRECESSIVEERR = 0x04,
324 CAN_ERRORRECORD_BITDOMINANTERR = 0x05,
325 CAN_ERRORRECORD_CRCERR = 0x06,
326 CAN_ERRORRECORD_SOFTWARESETERR = 0x07
327} can_error_record_type;
328
332typedef struct
333{
334 can_mode_type mode_selection;
336 confirm_state ttc_enable;
338 confirm_state aebo_enable;
340 confirm_state aed_enable;
342 confirm_state prsf_enable;
344 can_msg_discarding_rule_type mdrsel_selection;
346 can_msg_sending_rule_type mmssr_selection;
348} can_base_type;
349
353typedef struct
354{
355 uint16_t baudrate_div;
357 can_rsaw_type rsaw_size;
359 can_bts1_type bts1_size;
361 can_bts2_type bts2_size;
363} can_baudrate_type;
364
368typedef struct
369{
370 confirm_state filter_activate_enable;
372 can_filter_mode_type filter_mode;
374 can_filter_fifo_type filter_fifo;
376 uint8_t filter_number;
378 can_filter_bit_width_type filter_bit;
380 uint16_t filter_id_high;
383 uint16_t filter_id_low;
386 uint16_t filter_mask_high;
389 uint16_t filter_mask_low;
391} can_filter_init_type;
392
396typedef struct
397{
398 uint32_t standard_id;
401 uint32_t extended_id;
404 can_identifier_type id_type;
406 can_trans_frame_type frame_type;
408 uint8_t dlc;
411 uint8_t data[8];
413} can_tx_message_type;
414
418typedef struct
419{
420 uint32_t standard_id;
423 uint32_t extended_id;
426 can_identifier_type id_type;
428 can_trans_frame_type frame_type;
430 uint8_t dlc;
433 uint8_t data[8];
435 uint8_t filter_index;
437} can_rx_message_type;
438
442typedef struct
443{
447 union
448 {
449 __IO uint32_t tmi;
450 struct
451 {
452 __IO uint32_t tmsr : 1; /* [0] */
453 __IO uint32_t tmfrsel : 1; /* [1] */
454 __IO uint32_t tmidsel : 1; /* [2] */
455 __IO uint32_t tmeid : 18;/* [20:3] */
456 __IO uint32_t tmsid : 11;/* [31:21] */
457 } tmi_bit;
458 };
459
463 union
464 {
465 __IO uint32_t tmc;
466 struct
467 {
468 __IO uint32_t tmdtbl : 4; /* [3:0] */
469 __IO uint32_t reserved1 : 4; /* [7:4] */
470 __IO uint32_t tmtsten : 1; /* [8] */
471 __IO uint32_t reserved2 : 7; /* [15:9] */
472 __IO uint32_t tmts : 16;/* [31:16] */
473 } tmc_bit;
474 };
475
479 union
480 {
481 __IO uint32_t tmdtl;
482 struct
483 {
484 __IO uint32_t tmdt0 : 8; /* [7:0] */
485 __IO uint32_t tmdt1 : 8; /* [15:8] */
486 __IO uint32_t tmdt2 : 8; /* [23:16] */
487 __IO uint32_t tmdt3 : 8; /* [31:24] */
488 } tmdtl_bit;
489 };
490
494 union
495 {
496 __IO uint32_t tmdth;
497 struct
498 {
499 __IO uint32_t tmdt4 : 8; /* [7:0] */
500 __IO uint32_t tmdt5 : 8; /* [15:8] */
501 __IO uint32_t tmdt6 : 8; /* [23:16] */
502 __IO uint32_t tmdt7 : 8; /* [31:24] */
503 } tmdth_bit;
504 };
505} can_tx_mailbox_type;
506
510typedef struct
511{
515 union
516 {
517 __IO uint32_t rfi;
518 struct
519 {
520 __IO uint32_t reserved1 : 1; /* [0] */
521 __IO uint32_t rffri : 1; /* [1] */
522 __IO uint32_t rfidi : 1; /* [2] */
523 __IO uint32_t rfeid : 18;/* [20:3] */
524 __IO uint32_t rfsid : 11;/* [31:21] */
525 } rfi_bit;
526 };
527
531 union
532 {
533 __IO uint32_t rfc;
534 struct
535 {
536 __IO uint32_t rfdtl : 4; /* [3:0] */
537 __IO uint32_t reserved1 : 4; /* [7:4] */
538 __IO uint32_t rffmn : 8; /* [15:8] */
539 __IO uint32_t rfts : 16;/* [31:16] */
540 } rfc_bit;
541 };
542
546 union
547 {
548 __IO uint32_t rfdtl;
549 struct
550 {
551 __IO uint32_t rfdt0 : 8; /* [7:0] */
552 __IO uint32_t rfdt1 : 8; /* [15:8] */
553 __IO uint32_t rfdt2 : 8; /* [23:16] */
554 __IO uint32_t rfdt3 : 8; /* [31:24] */
555 } rfdtl_bit;
556 };
557
561 union
562 {
563 __IO uint32_t rfdth;
564 struct
565 {
566 __IO uint32_t rfdt4 : 8; /* [7:0] */
567 __IO uint32_t rfdt5 : 8; /* [15:8] */
568 __IO uint32_t rfdt6 : 8; /* [23:16] */
569 __IO uint32_t rfdt7 : 8; /* [31:24] */
570 } rfdth_bit;
571 };
572} can_fifo_mailbox_type;
573
577typedef struct
578{
579 __IO uint32_t ffdb1;
580 __IO uint32_t ffdb2;
581} can_filter_register_type;
582
586typedef struct
587{
588
592 union
593 {
594 __IO uint32_t mctrl;
595 struct
596 {
597 __IO uint32_t fzen : 1; /* [0] */
598 __IO uint32_t dzen : 1; /* [1] */
599 __IO uint32_t mmssr : 1; /* [2] */
600 __IO uint32_t mdrsel : 1; /* [3] */
601 __IO uint32_t prsfen : 1; /* [4] */
602 __IO uint32_t aeden : 1; /* [5] */
603 __IO uint32_t aeboen : 1; /* [6] */
604 __IO uint32_t ttcen : 1; /* [7] */
605 __IO uint32_t reserved1 : 7; /* [14:8] */
606 __IO uint32_t sprst : 1; /* [15] */
607 __IO uint32_t ptd : 1; /* [16] */
608 __IO uint32_t reserved2 : 15;/*[31:17] */
609 } mctrl_bit;
610 };
611
615 union
616 {
617 __IO uint32_t msts;
618 struct
619 {
620 __IO uint32_t fzc : 1; /* [0] */
621 __IO uint32_t dzc : 1; /* [1] */
622 __IO uint32_t eoif : 1; /* [2] */
623 __IO uint32_t qdzif : 1; /* [3] */
624 __IO uint32_t edzif : 1; /* [4] */
625 __IO uint32_t reserved1 : 3; /* [7:5] */
626 __IO uint32_t cuss : 1; /* [8] */
627 __IO uint32_t curs : 1; /* [9] */
628 __IO uint32_t lsamprx : 1; /* [10] */
629 __IO uint32_t realrx : 1; /* [11] */
630 __IO uint32_t reserved2 : 20;/*[31:12] */
631 } msts_bit;
632 };
633
637 union
638 {
639 __IO uint32_t tsts;
640 struct
641 {
642 __IO uint32_t tm0tcf : 1; /* [0] */
643 __IO uint32_t tm0tsf : 1; /* [1] */
644 __IO uint32_t tm0alf : 1; /* [2] */
645 __IO uint32_t tm0tef : 1; /* [3] */
646 __IO uint32_t reserved1 : 3; /* [6:4] */
647 __IO uint32_t tm0ct : 1; /* [7] */
648 __IO uint32_t tm1tcf : 1; /* [8] */
649 __IO uint32_t tm1tsf : 1; /* [9] */
650 __IO uint32_t tm1alf : 1; /* [10] */
651 __IO uint32_t tm1tef : 1; /* [11] */
652 __IO uint32_t reserved2 : 3; /* [14:12] */
653 __IO uint32_t tm1ct : 1; /* [15] */
654 __IO uint32_t tm2tcf : 1; /* [16] */
655 __IO uint32_t tm2tsf : 1; /* [17] */
656 __IO uint32_t tm2alf : 1; /* [18] */
657 __IO uint32_t tm2tef : 1; /* [19] */
658 __IO uint32_t reserved3 : 3; /* [22:20] */
659 __IO uint32_t tm2ct : 1; /* [23] */
660 __IO uint32_t tmnr : 2; /* [25:24] */
661 __IO uint32_t tm0ef : 1; /* [26] */
662 __IO uint32_t tm1ef : 1; /* [27] */
663 __IO uint32_t tm2ef : 1; /* [28] */
664 __IO uint32_t tm0lpf : 1; /* [29] */
665 __IO uint32_t tm1lpf : 1; /* [30] */
666 __IO uint32_t tm2lpf : 1; /* [31] */
667 } tsts_bit;
668 };
669
673 union
674 {
675 __IO uint32_t rf0;
676 struct
677 {
678 __IO uint32_t rf0mn : 2; /* [1:0] */
679 __IO uint32_t reserved1 : 1; /* [2] */
680 __IO uint32_t rf0ff : 1; /* [3] */
681 __IO uint32_t rf0of : 1; /* [4] */
682 __IO uint32_t rf0r : 1; /* [5] */
683 __IO uint32_t reserved2 : 26;/* [31:6] */
684 } rf0_bit;
685 };
686
690 union
691 {
692 __IO uint32_t rf1;
693 struct
694 {
695 __IO uint32_t rf1mn : 2; /* [1:0] */
696 __IO uint32_t reserved1 : 1; /* [2] */
697 __IO uint32_t rf1ff : 1; /* [3] */
698 __IO uint32_t rf1of : 1; /* [4] */
699 __IO uint32_t rf1r : 1; /* [5] */
700 __IO uint32_t reserved2 : 26;/* [31:6] */
701 } rf1_bit;
702 };
703
707 union
708 {
709 __IO uint32_t inten;
710 struct
711 {
712 __IO uint32_t tcien : 1; /* [0] */
713 __IO uint32_t rf0mien : 1; /* [1] */
714 __IO uint32_t rf0fien : 1; /* [2] */
715 __IO uint32_t rf0oien : 1; /* [3] */
716 __IO uint32_t rf1mien : 1; /* [4] */
717 __IO uint32_t rf1fien : 1; /* [5] */
718 __IO uint32_t rf1oien : 1; /* [6] */
719 __IO uint32_t reserved1 : 1; /* [7] */
720 __IO uint32_t eaien : 1; /* [8] */
721 __IO uint32_t epien : 1; /* [9] */
722 __IO uint32_t boien : 1; /* [10] */
723 __IO uint32_t etrien : 1; /* [11] */
724 __IO uint32_t reserved2 : 3; /* [14:12] */
725 __IO uint32_t eoien : 1; /* [15] */
726 __IO uint32_t qdzien : 1; /* [16] */
727 __IO uint32_t edzien : 1; /* [17] */
728 __IO uint32_t reserved3 : 14;/* [31:18] */
729 } inten_bit;
730 };
731
735 union
736 {
737 __IO uint32_t ests;
738 struct
739 {
740 __IO uint32_t eaf : 1; /* [0] */
741 __IO uint32_t epf : 1; /* [1] */
742 __IO uint32_t bof : 1; /* [2] */
743 __IO uint32_t reserved1 : 1; /* [3] */
744 __IO uint32_t etr : 3; /* [6:4] */
745 __IO uint32_t reserved2 : 9; /* [15:7] */
746 __IO uint32_t tec : 8; /* [23:16] */
747 __IO uint32_t rec : 8; /* [31:24] */
748 } ests_bit;
749 };
750
754 union
755 {
756 __IO uint32_t btmg;
757 struct
758 {
759 __IO uint32_t brdiv : 12;/* [11:0] */
760 __IO uint32_t reserved1 : 4; /* [15:12] */
761 __IO uint32_t bts1 : 4; /* [19:16] */
762 __IO uint32_t bts2 : 3; /* [22:20] */
763 __IO uint32_t reserved2 : 1; /* [23] */
764 __IO uint32_t rsaw : 2; /* [25:24] */
765 __IO uint32_t reserved3 : 4; /* [29:26] */
766 __IO uint32_t lben : 1; /* [30] */
767 __IO uint32_t loen : 1; /* [31] */
768 } btmg_bit;
769 };
770
774 __IO uint32_t reserved1[88];
775
779 can_tx_mailbox_type tx_mailbox[3];
780
784 can_fifo_mailbox_type fifo_mailbox[2];
785
789 __IO uint32_t reserved2[12];
790
794 union
795 {
796 __IO uint32_t fctrl;
797 struct
798 {
799 __IO uint32_t fcs : 1; /* [0] */
800 __IO uint32_t reserved1 : 31;/* [31:1] */
801 } fctrl_bit;
802 };
803
807 union
808 {
809 __IO uint32_t fmcfg;
810 struct
811 {
812 __IO uint32_t fmsel0 : 1; /* [0] */
813 __IO uint32_t fmsel1 : 1; /* [1] */
814 __IO uint32_t fmsel2 : 1; /* [2] */
815 __IO uint32_t fmsel3 : 1; /* [3] */
816 __IO uint32_t fmsel4 : 1; /* [4] */
817 __IO uint32_t fmsel5 : 1; /* [5] */
818 __IO uint32_t fmsel6 : 1; /* [6] */
819 __IO uint32_t fmsel7 : 1; /* [7] */
820 __IO uint32_t fmsel8 : 1; /* [8] */
821 __IO uint32_t fmsel9 : 1; /* [9] */
822 __IO uint32_t fmsel10 : 1; /* [10] */
823 __IO uint32_t fmsel11 : 1; /* [11] */
824 __IO uint32_t fmsel12 : 1; /* [12] */
825 __IO uint32_t fmsel13 : 1; /* [13] */
826 __IO uint32_t fmsel14 : 1; /* [14] */
827 __IO uint32_t fmsel15 : 1; /* [15] */
828 __IO uint32_t fmsel16 : 1; /* [16] */
829 __IO uint32_t fmsel17 : 1; /* [17] */
830 __IO uint32_t fmsel18 : 1; /* [18] */
831 __IO uint32_t fmsel19 : 1; /* [19] */
832 __IO uint32_t fmsel20 : 1; /* [20] */
833 __IO uint32_t fmsel21 : 1; /* [21] */
834 __IO uint32_t fmsel22 : 1; /* [22] */
835 __IO uint32_t fmsel23 : 1; /* [23] */
836 __IO uint32_t fmsel24 : 1; /* [24] */
837 __IO uint32_t fmsel25 : 1; /* [25] */
838 __IO uint32_t fmsel26 : 1; /* [26] */
839 __IO uint32_t fmsel27 : 1; /* [27] */
840 __IO uint32_t reserved1 : 4;/* [31:28] */
841 } fmcfg_bit;
842 };
843
847 __IO uint32_t reserved3;
848
852 union
853 {
854 __IO uint32_t fbwcfg;
855 struct
856 {
857 __IO uint32_t fbwsel0 : 1; /* [0] */
858 __IO uint32_t fbwsel1 : 1; /* [1] */
859 __IO uint32_t fbwsel2 : 1; /* [2] */
860 __IO uint32_t fbwsel3 : 1; /* [3] */
861 __IO uint32_t fbwsel4 : 1; /* [4] */
862 __IO uint32_t fbwsel5 : 1; /* [5] */
863 __IO uint32_t fbwsel6 : 1; /* [6] */
864 __IO uint32_t fbwsel7 : 1; /* [7] */
865 __IO uint32_t fbwsel8 : 1; /* [8] */
866 __IO uint32_t fbwsel9 : 1; /* [9] */
867 __IO uint32_t fbwsel10 : 1; /* [10] */
868 __IO uint32_t fbwsel11 : 1; /* [11] */
869 __IO uint32_t fbwsel12 : 1; /* [12] */
870 __IO uint32_t fbwsel13 : 1; /* [13] */
871 __IO uint32_t fbwsel14 : 1; /* [14] */
872 __IO uint32_t fbwsel15 : 1; /* [15] */
873 __IO uint32_t fbwsel16 : 1; /* [16] */
874 __IO uint32_t fbwsel17 : 1; /* [17] */
875 __IO uint32_t fbwsel18 : 1; /* [18] */
876 __IO uint32_t fbwsel19 : 1; /* [19] */
877 __IO uint32_t fbwsel20 : 1; /* [20] */
878 __IO uint32_t fbwsel21 : 1; /* [21] */
879 __IO uint32_t fbwsel22 : 1; /* [22] */
880 __IO uint32_t fbwsel23 : 1; /* [23] */
881 __IO uint32_t fbwsel24 : 1; /* [24] */
882 __IO uint32_t fbwsel25 : 1; /* [25] */
883 __IO uint32_t fbwsel26 : 1; /* [26] */
884 __IO uint32_t fbwsel27 : 1; /* [27] */
885 __IO uint32_t reserved1 : 4;/* [31:28] */
886 } fbwcfg_bit;
887 };
888
892 __IO uint32_t reserved4;
893
897 union
898 {
899 __IO uint32_t frf;
900 struct
901 {
902 __IO uint32_t frfsel0 : 1; /* [0] */
903 __IO uint32_t frfsel1 : 1; /* [1] */
904 __IO uint32_t frfsel2 : 1; /* [2] */
905 __IO uint32_t frfsel3 : 1; /* [3] */
906 __IO uint32_t frfsel4 : 1; /* [4] */
907 __IO uint32_t frfsel5 : 1; /* [5] */
908 __IO uint32_t frfsel6 : 1; /* [6] */
909 __IO uint32_t frfsel7 : 1; /* [7] */
910 __IO uint32_t frfsel8 : 1; /* [8] */
911 __IO uint32_t frfsel9 : 1; /* [9] */
912 __IO uint32_t frfsel10 : 1; /* [10] */
913 __IO uint32_t frfsel11 : 1; /* [11] */
914 __IO uint32_t frfsel12 : 1; /* [12] */
915 __IO uint32_t frfsel13 : 1; /* [13] */
916 __IO uint32_t frfsel14 : 1; /* [14] */
917 __IO uint32_t frfsel15 : 1; /* [15] */
918 __IO uint32_t frfsel16 : 1; /* [16] */
919 __IO uint32_t frfsel17 : 1; /* [17] */
920 __IO uint32_t frfsel18 : 1; /* [18] */
921 __IO uint32_t frfsel19 : 1; /* [19] */
922 __IO uint32_t frfsel20 : 1; /* [20] */
923 __IO uint32_t frfsel21 : 1; /* [21] */
924 __IO uint32_t frfsel22 : 1; /* [22] */
925 __IO uint32_t frfsel23 : 1; /* [23] */
926 __IO uint32_t frfsel24 : 1; /* [24] */
927 __IO uint32_t frfsel25 : 1; /* [25] */
928 __IO uint32_t frfsel26 : 1; /* [26] */
929 __IO uint32_t frfsel27 : 1; /* [27] */
930 __IO uint32_t reserved1 : 4;/* [31:28] */
931 } frf_bit;
932 };
933
937 __IO uint32_t reserved5;
938
942 union
943 {
944 __IO uint32_t facfg;
945 struct
946 {
947 __IO uint32_t faen0 : 1; /* [0] */
948 __IO uint32_t faen1 : 1; /* [1] */
949 __IO uint32_t faen2 : 1; /* [2] */
950 __IO uint32_t faen3 : 1; /* [3] */
951 __IO uint32_t faen4 : 1; /* [4] */
952 __IO uint32_t faen5 : 1; /* [5] */
953 __IO uint32_t faen6 : 1; /* [6] */
954 __IO uint32_t faen7 : 1; /* [7] */
955 __IO uint32_t faen8 : 1; /* [8] */
956 __IO uint32_t faen9 : 1; /* [9] */
957 __IO uint32_t faen10 : 1; /* [10] */
958 __IO uint32_t faen11 : 1; /* [11] */
959 __IO uint32_t faen12 : 1; /* [12] */
960 __IO uint32_t faen13 : 1; /* [13] */
961 __IO uint32_t faen14 : 1; /* [14] */
962 __IO uint32_t faen15 : 1; /* [15] */
963 __IO uint32_t faen16 : 1; /* [16] */
964 __IO uint32_t faen17 : 1; /* [17] */
965 __IO uint32_t faen18 : 1; /* [18] */
966 __IO uint32_t faen19 : 1; /* [19] */
967 __IO uint32_t faen20 : 1; /* [20] */
968 __IO uint32_t faen21 : 1; /* [21] */
969 __IO uint32_t faen22 : 1; /* [22] */
970 __IO uint32_t faen23 : 1; /* [23] */
971 __IO uint32_t faen24 : 1; /* [24] */
972 __IO uint32_t faen25 : 1; /* [25] */
973 __IO uint32_t faen26 : 1; /* [26] */
974 __IO uint32_t faen27 : 1; /* [27] */
975 __IO uint32_t reserved1 : 4;/* [31:28] */
976 } facfg_bit;
977 };
978
982 __IO uint32_t reserved6[8];
983
987 can_filter_register_type ffb[28];
988} can_type;
989
994#define CAN1 ((can_type *) CAN1_BASE)
995#define CAN2 ((can_type *) CAN2_BASE)
996
1001void can_reset(can_type* can_x);
1002void can_baudrate_default_para_init(can_baudrate_type* can_baudrate_struct);
1003 error_status can_baudrate_set(can_type* can_x, can_baudrate_type* can_baudrate_struct);
1004void can_default_para_init(can_base_type* can_base_struct);
1005 error_status can_base_init(can_type* can_x, can_base_type* can_base_struct);
1006void can_filter_default_para_init(can_filter_init_type* can_filter_init_struct);
1007void can_filter_init(can_type* can_x, can_filter_init_type* can_filter_init_struct);
1008void can_debug_transmission_prohibit(can_type* can_x, confirm_state new_state);
1009void can_ttc_mode_enable(can_type* can_x, confirm_state new_state);
1010uint8_t can_message_transmit(can_type* can_x, can_tx_message_type* tx_message_struct);
1011 can_transmit_status_type can_transmit_status_get(can_type* can_x, can_tx_mailbox_num_type transmit_mailbox);
1012void can_transmit_cancel(can_type* can_x, can_tx_mailbox_num_type transmit_mailbox);
1013void can_message_receive(can_type* can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type* rx_message_struct);
1014void can_receive_fifo_release(can_type* can_x, can_rx_fifo_num_type fifo_number);
1015uint8_t can_receive_message_pending_get(can_type* can_x, can_rx_fifo_num_type fifo_number);
1016 error_status can_operating_mode_set(can_type* can_x, can_operating_mode_type can_operating_mode);
1017 can_enter_doze_status_type can_doze_mode_enter(can_type* can_x);
1018 can_quit_doze_status_type can_doze_mode_exit(can_type* can_x);
1019 can_error_record_type can_error_type_record_get(can_type* can_x);
1020uint8_t can_receive_error_counter_get(can_type* can_x);
1021uint8_t can_transmit_error_counter_get(can_type* can_x);
1022void can_interrupt_enable(can_type* can_x, uint32_t can_int, confirm_state new_state);
1023 flag_status can_flag_get(can_type* can_x, uint32_t can_flag);
1024void can_flag_clear(can_type* can_x, uint32_t can_flag);
1025
1038#ifdef __cplusplus
1039}
1040#endif
1041
1042#endif
at32f435_437.h
at32f435_437 header file
can_base_init
error_status can_base_init(can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct.
Definition: at32f435_437_can.c:194
can_reset
void can_reset(can_type *can_x)
deinitialize the can peripheral registers to their default reset values.
Definition: at32f435_437_can.c:51
can_transmit_error_counter_get
uint8_t can_transmit_error_counter_get(can_type *can_x)
return the transmit error counter of the specified can peripheral.
Definition: at32f435_437_can.c:892
can_transmit_status_get
can_transmit_status_type can_transmit_status_get(can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral.
Definition: at32f435_437_can.c:514
can_ttc_mode_enable
void can_ttc_mode_enable(can_type *can_x, confirm_state new_state)
enable or disable time trigger operation communication mode of the specified can peripheral.
Definition: at32f435_437_can.c:416
can_filter_default_para_init
void can_filter_default_para_init(can_filter_init_type *can_filter_init_struct)
fill each can_filter_init_struct member with its default value.
Definition: at32f435_437_can.c:269
can_receive_fifo_release
void can_receive_fifo_release(can_type *can_x, can_rx_fifo_num_type fifo_number)
release the specified fifo of the specified can peripheral.
Definition: at32f435_437_can.c:666
can_receive_error_counter_get
uint8_t can_receive_error_counter_get(can_type *can_x)
return the receive error counter (rec) of the specified can peripheral.
Definition: at32f435_437_can.c:878
can_operating_mode_set
error_status can_operating_mode_set(can_type *can_x, can_operating_mode_type can_operating_mode)
set the operation mode of the specified can peripheral.
Definition: at32f435_437_can.c:723
can_baudrate_default_para_init
void can_baudrate_default_para_init(can_baudrate_type *can_baudrate_struct)
fill each can_baudrate_struct member with its default value.
Definition: at32f435_437_can.c:70
can_transmit_cancel
void can_transmit_cancel(can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
cancel a transmit request of the specified can peripheral.
Definition: at32f435_437_can.c:589
can_receive_message_pending_get
uint8_t can_receive_message_pending_get(can_type *can_x, can_rx_fifo_num_type fifo_number)
return the number of pending messages of the specified can peripheral.
Definition: at32f435_437_can.c:692
can_message_transmit
uint8_t can_message_transmit(can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral.
Definition: at32f435_437_can.c:440
can_message_receive
void can_message_receive(can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral.
Definition: at32f435_437_can.c:619
can_interrupt_enable
void can_interrupt_enable(can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral.
Definition: at32f435_437_can.c:924
can_flag_get
flag_status can_flag_get(can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral.
Definition: at32f435_437_can.c:964
can_flag_clear
void can_flag_clear(can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral.
Definition: at32f435_437_can.c:1087
can_baudrate_set
error_status can_baudrate_set(can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral
Definition: at32f435_437_can.c:99
can_debug_transmission_prohibit
void can_debug_transmission_prohibit(can_type *can_x, confirm_state new_state)
enable or disable the debug transmission prohibit of the specified can peripheral.
Definition: at32f435_437_can.c:395
can_error_type_record_get
can_error_record_type can_error_type_record_get(can_type *can_x)
return the error type record (etr) of the specified can peripheral.
Definition: at32f435_437_can.c:863
can_filter_init
void can_filter_init(can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct.
Definition: at32f435_437_can.c:304
can_default_para_init
void can_default_para_init(can_base_type *can_base_struct)
fill each can_init_struct member with its default value.
Definition: at32f435_437_can.c:157
can_doze_mode_exit
can_quit_doze_status_type can_doze_mode_exit(can_type *can_x)
exit the doze mode of the specified can peripheral.
Definition: at32f435_437_can.c:831
can_doze_mode_enter
can_enter_doze_status_type can_doze_mode_enter(can_type *can_x)
enter the low power mode of the specified can peripheral.
Definition: at32f435_437_can.c:801
can_filter_fifo_type
can_filter_fifo_type
can filter fifo
Definition: at32f435_437_can.h:137
can_transmit_status_type
can_transmit_status_type
can transmit status
Definition: at32f435_437_can.h:271
can_msg_discarding_rule_type
can_msg_discarding_rule_type
can message discarding rule select when overflow
Definition: at32f435_437_can.h:300
can_bts2_type
can_bts2_type
can bit time segment 2
Definition: at32f435_437_can.h:219
can_quit_doze_status_type
can_quit_doze_status_type
can quit doze mode status
Definition: at32f435_437_can.h:291
can_trans_frame_type
can_trans_frame_type
can transmission frame type
Definition: at32f435_437_can.h:243
can_bts1_type
can_bts1_type
can bit time segment 1
Definition: at32f435_437_can.h:196
can_error_record_type
can_error_record_type
can error type record
Definition: at32f435_437_can.h:318
can_filter_mode_type
can_filter_mode_type
can filter mode
Definition: at32f435_437_can.h:146
can_operating_mode_type
can_operating_mode_type
can operating mode
Definition: at32f435_437_can.h:175
can_msg_sending_rule_type
can_msg_sending_rule_type
can multiple message sending sequence rule
Definition: at32f435_437_can.h:309
can_tx_mailbox_num_type
can_tx_mailbox_num_type
can tx mailboxes
Definition: at32f435_437_can.h:252
can_filter_bit_width_type
can_filter_bit_width_type
can filter bit width select
Definition: at32f435_437_can.h:155
can_enter_doze_status_type
can_enter_doze_status_type
can enter doze mode status
Definition: at32f435_437_can.h:282
can_rx_fifo_num_type
can_rx_fifo_num_type
can receive fifo
Definition: at32f435_437_can.h:262
can_identifier_type
can_identifier_type
can identifier type
Definition: at32f435_437_can.h:234
can_mode_type
can_mode_type
can mode
Definition: at32f435_437_can.h:164
can_rsaw_type
can_rsaw_type
can resynchronization adjust width
Definition: at32f435_437_can.h:185
CAN_FILTER_FIFO0
@ CAN_FILTER_FIFO0
Definition: at32f435_437_can.h:138
CAN_FILTER_FIFO1
@ CAN_FILTER_FIFO1
Definition: at32f435_437_can.h:139
CAN_TX_STATUS_SUCCESSFUL
@ CAN_TX_STATUS_SUCCESSFUL
Definition: at32f435_437_can.h:273
CAN_TX_STATUS_PENDING
@ CAN_TX_STATUS_PENDING
Definition: at32f435_437_can.h:274
CAN_TX_STATUS_NO_EMPTY
@ CAN_TX_STATUS_NO_EMPTY
Definition: at32f435_437_can.h:275
CAN_TX_STATUS_FAILED
@ CAN_TX_STATUS_FAILED
Definition: at32f435_437_can.h:272
CAN_DISCARDING_FIRST_RECEIVED
@ CAN_DISCARDING_FIRST_RECEIVED
Definition: at32f435_437_can.h:301
CAN_DISCARDING_LAST_RECEIVED
@ CAN_DISCARDING_LAST_RECEIVED
Definition: at32f435_437_can.h:302
CAN_BTS2_4TQ
@ CAN_BTS2_4TQ
Definition: at32f435_437_can.h:223
CAN_BTS2_2TQ
@ CAN_BTS2_2TQ
Definition: at32f435_437_can.h:221
CAN_BTS2_5TQ
@ CAN_BTS2_5TQ
Definition: at32f435_437_can.h:224
CAN_BTS2_6TQ
@ CAN_BTS2_6TQ
Definition: at32f435_437_can.h:225
CAN_BTS2_7TQ
@ CAN_BTS2_7TQ
Definition: at32f435_437_can.h:226
CAN_BTS2_8TQ
@ CAN_BTS2_8TQ
Definition: at32f435_437_can.h:227
CAN_BTS2_3TQ
@ CAN_BTS2_3TQ
Definition: at32f435_437_can.h:222
CAN_BTS2_1TQ
@ CAN_BTS2_1TQ
Definition: at32f435_437_can.h:220
CAN_QUIT_DOZE_FAILED
@ CAN_QUIT_DOZE_FAILED
Definition: at32f435_437_can.h:292
CAN_QUIT_DOZE_SUCCESSFUL
@ CAN_QUIT_DOZE_SUCCESSFUL
Definition: at32f435_437_can.h:293
CAN_TFT_REMOTE
@ CAN_TFT_REMOTE
Definition: at32f435_437_can.h:245
CAN_TFT_DATA
@ CAN_TFT_DATA
Definition: at32f435_437_can.h:244
CAN_BTS1_7TQ
@ CAN_BTS1_7TQ
Definition: at32f435_437_can.h:203
CAN_BTS1_1TQ
@ CAN_BTS1_1TQ
Definition: at32f435_437_can.h:197
CAN_BTS1_14TQ
@ CAN_BTS1_14TQ
Definition: at32f435_437_can.h:210
CAN_BTS1_4TQ
@ CAN_BTS1_4TQ
Definition: at32f435_437_can.h:200
CAN_BTS1_15TQ
@ CAN_BTS1_15TQ
Definition: at32f435_437_can.h:211
CAN_BTS1_11TQ
@ CAN_BTS1_11TQ
Definition: at32f435_437_can.h:207
CAN_BTS1_10TQ
@ CAN_BTS1_10TQ
Definition: at32f435_437_can.h:206
CAN_BTS1_16TQ
@ CAN_BTS1_16TQ
Definition: at32f435_437_can.h:212
CAN_BTS1_8TQ
@ CAN_BTS1_8TQ
Definition: at32f435_437_can.h:204
CAN_BTS1_3TQ
@ CAN_BTS1_3TQ
Definition: at32f435_437_can.h:199
CAN_BTS1_12TQ
@ CAN_BTS1_12TQ
Definition: at32f435_437_can.h:208
CAN_BTS1_9TQ
@ CAN_BTS1_9TQ
Definition: at32f435_437_can.h:205
CAN_BTS1_5TQ
@ CAN_BTS1_5TQ
Definition: at32f435_437_can.h:201
CAN_BTS1_6TQ
@ CAN_BTS1_6TQ
Definition: at32f435_437_can.h:202
CAN_BTS1_2TQ
@ CAN_BTS1_2TQ
Definition: at32f435_437_can.h:198
CAN_BTS1_13TQ
@ CAN_BTS1_13TQ
Definition: at32f435_437_can.h:209
CAN_ERRORRECORD_CRCERR
@ CAN_ERRORRECORD_CRCERR
Definition: at32f435_437_can.h:325
CAN_ERRORRECORD_FORMERR
@ CAN_ERRORRECORD_FORMERR
Definition: at32f435_437_can.h:321
CAN_ERRORRECORD_BITDOMINANTERR
@ CAN_ERRORRECORD_BITDOMINANTERR
Definition: at32f435_437_can.h:324
CAN_ERRORRECORD_BITRECESSIVEERR
@ CAN_ERRORRECORD_BITRECESSIVEERR
Definition: at32f435_437_can.h:323
CAN_ERRORRECORD_NOERR
@ CAN_ERRORRECORD_NOERR
Definition: at32f435_437_can.h:319
CAN_ERRORRECORD_STUFFERR
@ CAN_ERRORRECORD_STUFFERR
Definition: at32f435_437_can.h:320
CAN_ERRORRECORD_SOFTWARESETERR
@ CAN_ERRORRECORD_SOFTWARESETERR
Definition: at32f435_437_can.h:326
CAN_ERRORRECORD_ACKERR
@ CAN_ERRORRECORD_ACKERR
Definition: at32f435_437_can.h:322
CAN_FILTER_MODE_ID_LIST
@ CAN_FILTER_MODE_ID_LIST
Definition: at32f435_437_can.h:148
CAN_FILTER_MODE_ID_MASK
@ CAN_FILTER_MODE_ID_MASK
Definition: at32f435_437_can.h:147
CAN_OPERATINGMODE_FREEZE
@ CAN_OPERATINGMODE_FREEZE
Definition: at32f435_437_can.h:176
CAN_OPERATINGMODE_COMMUNICATE
@ CAN_OPERATINGMODE_COMMUNICATE
Definition: at32f435_437_can.h:178
CAN_OPERATINGMODE_DOZE
@ CAN_OPERATINGMODE_DOZE
Definition: at32f435_437_can.h:177
CAN_SENDING_BY_ID
@ CAN_SENDING_BY_ID
Definition: at32f435_437_can.h:310
CAN_SENDING_BY_REQUEST
@ CAN_SENDING_BY_REQUEST
Definition: at32f435_437_can.h:311
CAN_TX_MAILBOX2
@ CAN_TX_MAILBOX2
Definition: at32f435_437_can.h:255
CAN_TX_MAILBOX0
@ CAN_TX_MAILBOX0
Definition: at32f435_437_can.h:253
CAN_TX_MAILBOX1
@ CAN_TX_MAILBOX1
Definition: at32f435_437_can.h:254
CAN_FILTER_16BIT
@ CAN_FILTER_16BIT
Definition: at32f435_437_can.h:156
CAN_FILTER_32BIT
@ CAN_FILTER_32BIT
Definition: at32f435_437_can.h:157
CAN_ENTER_DOZE_FAILED
@ CAN_ENTER_DOZE_FAILED
Definition: at32f435_437_can.h:283
CAN_ENTER_DOZE_SUCCESSFUL
@ CAN_ENTER_DOZE_SUCCESSFUL
Definition: at32f435_437_can.h:284
CAN_RX_FIFO0
@ CAN_RX_FIFO0
Definition: at32f435_437_can.h:263
CAN_RX_FIFO1
@ CAN_RX_FIFO1
Definition: at32f435_437_can.h:264
CAN_ID_STANDARD
@ CAN_ID_STANDARD
Definition: at32f435_437_can.h:235
CAN_ID_EXTENDED
@ CAN_ID_EXTENDED
Definition: at32f435_437_can.h:236
CAN_MODE_COMMUNICATE
@ CAN_MODE_COMMUNICATE
Definition: at32f435_437_can.h:165
CAN_MODE_LISTENONLY
@ CAN_MODE_LISTENONLY
Definition: at32f435_437_can.h:167
CAN_MODE_LISTENONLY_LOOPBACK
@ CAN_MODE_LISTENONLY_LOOPBACK
Definition: at32f435_437_can.h:168
CAN_MODE_LOOPBACK
@ CAN_MODE_LOOPBACK
Definition: at32f435_437_can.h:166
CAN_RSAW_1TQ
@ CAN_RSAW_1TQ
Definition: at32f435_437_can.h:186
CAN_RSAW_4TQ
@ CAN_RSAW_4TQ
Definition: at32f435_437_can.h:189
CAN_RSAW_3TQ
@ CAN_RSAW_3TQ
Definition: at32f435_437_can.h:188
CAN_RSAW_2TQ
@ CAN_RSAW_2TQ
Definition: at32f435_437_can.h:187
error_status
error_status
Definition: at32f435_437.h:380
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
can_base_type
can init structure definition
Definition: at32f435_437_can.h:333
can_base_type::prsf_enable
confirm_state prsf_enable
Definition: at32f435_437_can.h:342
can_base_type::mdrsel_selection
can_msg_discarding_rule_type mdrsel_selection
Definition: at32f435_437_can.h:344
can_base_type::aed_enable
confirm_state aed_enable
Definition: at32f435_437_can.h:340
can_base_type::mmssr_selection
can_msg_sending_rule_type mmssr_selection
Definition: at32f435_437_can.h:346
can_base_type::ttc_enable
confirm_state ttc_enable
Definition: at32f435_437_can.h:336
can_base_type::mode_selection
can_mode_type mode_selection
Definition: at32f435_437_can.h:334
can_base_type::aebo_enable
confirm_state aebo_enable
Definition: at32f435_437_can.h:338
can_baudrate_type
can baudrate structure definition
Definition: at32f435_437_can.h:354
can_baudrate_type::baudrate_div
uint16_t baudrate_div
Definition: at32f435_437_can.h:355
can_baudrate_type::rsaw_size
can_rsaw_type rsaw_size
Definition: at32f435_437_can.h:357
can_baudrate_type::bts2_size
can_bts2_type bts2_size
Definition: at32f435_437_can.h:361
can_baudrate_type::bts1_size
can_bts1_type bts1_size
Definition: at32f435_437_can.h:359
can_fifo_mailbox_type
can controller area network fifo mailbox
Definition: at32f435_437_can.h:511
can_fifo_mailbox_type::rfdt4
__IO uint32_t rfdt4
Definition: at32f435_437_can.h:566
can_fifo_mailbox_type::rfi
__IO uint32_t rfi
Definition: at32f435_437_can.h:517
can_fifo_mailbox_type::rfdt0
__IO uint32_t rfdt0
Definition: at32f435_437_can.h:551
can_fifo_mailbox_type::rfsid
__IO uint32_t rfsid
Definition: at32f435_437_can.h:524
can_fifo_mailbox_type::rfdt2
__IO uint32_t rfdt2
Definition: at32f435_437_can.h:553
can_fifo_mailbox_type::rfdth
__IO uint32_t rfdth
Definition: at32f435_437_can.h:563
can_fifo_mailbox_type::rfdtl
__IO uint32_t rfdtl
Definition: at32f435_437_can.h:536
can_fifo_mailbox_type::rfidi
__IO uint32_t rfidi
Definition: at32f435_437_can.h:522
can_fifo_mailbox_type::rfdt1
__IO uint32_t rfdt1
Definition: at32f435_437_can.h:552
can_fifo_mailbox_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_can.h:520
can_fifo_mailbox_type::rfdt6
__IO uint32_t rfdt6
Definition: at32f435_437_can.h:568
can_fifo_mailbox_type::rffri
__IO uint32_t rffri
Definition: at32f435_437_can.h:521
can_fifo_mailbox_type::rfc
__IO uint32_t rfc
Definition: at32f435_437_can.h:533
can_fifo_mailbox_type::rfdt3
__IO uint32_t rfdt3
Definition: at32f435_437_can.h:554
can_fifo_mailbox_type::rfdt5
__IO uint32_t rfdt5
Definition: at32f435_437_can.h:567
can_fifo_mailbox_type::rfdt7
__IO uint32_t rfdt7
Definition: at32f435_437_can.h:569
can_fifo_mailbox_type::rfts
__IO uint32_t rfts
Definition: at32f435_437_can.h:539
can_fifo_mailbox_type::rffmn
__IO uint32_t rffmn
Definition: at32f435_437_can.h:538
can_fifo_mailbox_type::rfeid
__IO uint32_t rfeid
Definition: at32f435_437_can.h:523
can_filter_init_type
can filter init structure definition
Definition: at32f435_437_can.h:369
can_filter_init_type::filter_mask_low
uint16_t filter_mask_low
Definition: at32f435_437_can.h:389
can_filter_init_type::filter_number
uint8_t filter_number
Definition: at32f435_437_can.h:376
can_filter_init_type::filter_fifo
can_filter_fifo_type filter_fifo
Definition: at32f435_437_can.h:374
can_filter_init_type::filter_bit
can_filter_bit_width_type filter_bit
Definition: at32f435_437_can.h:378
can_filter_init_type::filter_mode
can_filter_mode_type filter_mode
Definition: at32f435_437_can.h:372
can_filter_init_type::filter_activate_enable
confirm_state filter_activate_enable
Definition: at32f435_437_can.h:370
can_filter_init_type::filter_mask_high
uint16_t filter_mask_high
Definition: at32f435_437_can.h:386
can_filter_init_type::filter_id_high
uint16_t filter_id_high
Definition: at32f435_437_can.h:380
can_filter_init_type::filter_id_low
uint16_t filter_id_low
Definition: at32f435_437_can.h:383
can_filter_register_type
can controller area network filter bit register
Definition: at32f435_437_can.h:578
can_filter_register_type::ffdb1
__IO uint32_t ffdb1
Definition: at32f435_437_can.h:579
can_filter_register_type::ffdb2
__IO uint32_t ffdb2
Definition: at32f435_437_can.h:580
can_rx_message_type
can rx message structure definition
Definition: at32f435_437_can.h:419
can_rx_message_type::standard_id
uint32_t standard_id
Definition: at32f435_437_can.h:420
can_rx_message_type::id_type
can_identifier_type id_type
Definition: at32f435_437_can.h:426
can_rx_message_type::frame_type
can_trans_frame_type frame_type
Definition: at32f435_437_can.h:428
can_rx_message_type::dlc
uint8_t dlc
Definition: at32f435_437_can.h:430
can_rx_message_type::extended_id
uint32_t extended_id
Definition: at32f435_437_can.h:423
can_rx_message_type::filter_index
uint8_t filter_index
Definition: at32f435_437_can.h:435
can_tx_mailbox_type
can controller area network tx mailbox
Definition: at32f435_437_can.h:443
can_tx_mailbox_type::tmdt5
__IO uint32_t tmdt5
Definition: at32f435_437_can.h:500
can_tx_mailbox_type::tmtsten
__IO uint32_t tmtsten
Definition: at32f435_437_can.h:470
can_tx_mailbox_type::tmi
__IO uint32_t tmi
Definition: at32f435_437_can.h:449
can_tx_mailbox_type::tmc
__IO uint32_t tmc
Definition: at32f435_437_can.h:465
can_tx_mailbox_type::tmts
__IO uint32_t tmts
Definition: at32f435_437_can.h:472
can_tx_mailbox_type::tmdt0
__IO uint32_t tmdt0
Definition: at32f435_437_can.h:484
can_tx_mailbox_type::tmsr
__IO uint32_t tmsr
Definition: at32f435_437_can.h:452
can_tx_mailbox_type::tmdtl
__IO uint32_t tmdtl
Definition: at32f435_437_can.h:481
can_tx_mailbox_type::tmdt2
__IO uint32_t tmdt2
Definition: at32f435_437_can.h:486
can_tx_mailbox_type::tmdtbl
__IO uint32_t tmdtbl
Definition: at32f435_437_can.h:468
can_tx_mailbox_type::tmdt3
__IO uint32_t tmdt3
Definition: at32f435_437_can.h:487
can_tx_mailbox_type::tmdt1
__IO uint32_t tmdt1
Definition: at32f435_437_can.h:485
can_tx_mailbox_type::tmdt4
__IO uint32_t tmdt4
Definition: at32f435_437_can.h:499
can_tx_mailbox_type::tmfrsel
__IO uint32_t tmfrsel
Definition: at32f435_437_can.h:453
can_tx_mailbox_type::tmsid
__IO uint32_t tmsid
Definition: at32f435_437_can.h:456
can_tx_mailbox_type::tmdt6
__IO uint32_t tmdt6
Definition: at32f435_437_can.h:501
can_tx_mailbox_type::tmdth
__IO uint32_t tmdth
Definition: at32f435_437_can.h:496
can_tx_mailbox_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_can.h:469
can_tx_mailbox_type::tmidsel
__IO uint32_t tmidsel
Definition: at32f435_437_can.h:454
can_tx_mailbox_type::tmdt7
__IO uint32_t tmdt7
Definition: at32f435_437_can.h:502
can_tx_mailbox_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_can.h:471
can_tx_mailbox_type::tmeid
__IO uint32_t tmeid
Definition: at32f435_437_can.h:455
can_tx_message_type
can tx message structure definition
Definition: at32f435_437_can.h:397
can_tx_message_type::extended_id
uint32_t extended_id
Definition: at32f435_437_can.h:401
can_tx_message_type::frame_type
can_trans_frame_type frame_type
Definition: at32f435_437_can.h:406
can_tx_message_type::dlc
uint8_t dlc
Definition: at32f435_437_can.h:408
can_tx_message_type::id_type
can_identifier_type id_type
Definition: at32f435_437_can.h:404
can_tx_message_type::standard_id
uint32_t standard_id
Definition: at32f435_437_can.h:398
can_type
type define can register all
Definition: at32f435_437_can.h:587
can_type::fbwsel15
__IO uint32_t fbwsel15
Definition: at32f435_437_can.h:872
can_type::fmsel21
__IO uint32_t fmsel21
Definition: at32f435_437_can.h:833
can_type::tmnr
__IO uint32_t tmnr
Definition: at32f435_437_can.h:660
can_type::fbwsel10
__IO uint32_t fbwsel10
Definition: at32f435_437_can.h:867
can_type::rf0of
__IO uint32_t rf0of
Definition: at32f435_437_can.h:681
can_type::tm1alf
__IO uint32_t tm1alf
Definition: at32f435_437_can.h:650
can_type::fbwsel19
__IO uint32_t fbwsel19
Definition: at32f435_437_can.h:876
can_type::tm2lpf
__IO uint32_t tm2lpf
Definition: at32f435_437_can.h:666
can_type::fmsel13
__IO uint32_t fmsel13
Definition: at32f435_437_can.h:825
can_type::frfsel16
__IO uint32_t frfsel16
Definition: at32f435_437_can.h:918
can_type::frfsel17
__IO uint32_t frfsel17
Definition: at32f435_437_can.h:919
can_type::tm2ef
__IO uint32_t tm2ef
Definition: at32f435_437_can.h:663
can_type::tm2ct
__IO uint32_t tm2ct
Definition: at32f435_437_can.h:659
can_type::frfsel1
__IO uint32_t frfsel1
Definition: at32f435_437_can.h:903
can_type::frfsel12
__IO uint32_t frfsel12
Definition: at32f435_437_can.h:914
can_type::fmsel4
__IO uint32_t fmsel4
Definition: at32f435_437_can.h:816
can_type::etrien
__IO uint32_t etrien
Definition: at32f435_437_can.h:723
can_type::fmsel27
__IO uint32_t fmsel27
Definition: at32f435_437_can.h:839
can_type::tm1tef
__IO uint32_t tm1tef
Definition: at32f435_437_can.h:651
can_type::fbwsel8
__IO uint32_t fbwsel8
Definition: at32f435_437_can.h:865
can_type::boien
__IO uint32_t boien
Definition: at32f435_437_can.h:722
can_type::faen21
__IO uint32_t faen21
Definition: at32f435_437_can.h:968
can_type::eoien
__IO uint32_t eoien
Definition: at32f435_437_can.h:725
can_type::fctrl
__IO uint32_t fctrl
Definition: at32f435_437_can.h:796
can_type::frfsel4
__IO uint32_t frfsel4
Definition: at32f435_437_can.h:906
can_type::faen16
__IO uint32_t faen16
Definition: at32f435_437_can.h:963
can_type::tm0ct
__IO uint32_t tm0ct
Definition: at32f435_437_can.h:647
can_type::eaf
__IO uint32_t eaf
Definition: at32f435_437_can.h:740
can_type::rf1
__IO uint32_t rf1
Definition: at32f435_437_can.h:692
can_type::tm0tsf
__IO uint32_t tm0tsf
Definition: at32f435_437_can.h:643
can_type::fmsel26
__IO uint32_t fmsel26
Definition: at32f435_437_can.h:838
can_type::tm0lpf
__IO uint32_t tm0lpf
Definition: at32f435_437_can.h:664
can_type::frfsel2
__IO uint32_t frfsel2
Definition: at32f435_437_can.h:904
can_type::aeden
__IO uint32_t aeden
Definition: at32f435_437_can.h:602
can_type::dzc
__IO uint32_t dzc
Definition: at32f435_437_can.h:621
can_type::fmsel0
__IO uint32_t fmsel0
Definition: at32f435_437_can.h:812
can_type::faen4
__IO uint32_t faen4
Definition: at32f435_437_can.h:951
can_type::tm0tcf
__IO uint32_t tm0tcf
Definition: at32f435_437_can.h:642
can_type::fmsel12
__IO uint32_t fmsel12
Definition: at32f435_437_can.h:824
can_type::eaien
__IO uint32_t eaien
Definition: at32f435_437_can.h:720
can_type::faen22
__IO uint32_t faen22
Definition: at32f435_437_can.h:969
can_type::frfsel18
__IO uint32_t frfsel18
Definition: at32f435_437_can.h:920
can_type::faen23
__IO uint32_t faen23
Definition: at32f435_437_can.h:970
can_type::frfsel20
__IO uint32_t frfsel20
Definition: at32f435_437_can.h:922
can_type::fbwsel4
__IO uint32_t fbwsel4
Definition: at32f435_437_can.h:861
can_type::fbwsel9
__IO uint32_t fbwsel9
Definition: at32f435_437_can.h:866
can_type::fmsel20
__IO uint32_t fmsel20
Definition: at32f435_437_can.h:832
can_type::reserved5
__IO uint32_t reserved5
can reserved register, offset:0x218
Definition: at32f435_437_can.h:937
can_type::edzif
__IO uint32_t edzif
Definition: at32f435_437_can.h:624
can_type::frfsel11
__IO uint32_t frfsel11
Definition: at32f435_437_can.h:913
can_type::fmsel9
__IO uint32_t fmsel9
Definition: at32f435_437_can.h:821
can_type::faen27
__IO uint32_t faen27
Definition: at32f435_437_can.h:974
can_type::frfsel10
__IO uint32_t frfsel10
Definition: at32f435_437_can.h:912
can_type::fbwsel14
__IO uint32_t fbwsel14
Definition: at32f435_437_can.h:871
can_type::mctrl
__IO uint32_t mctrl
Definition: at32f435_437_can.h:594
can_type::frfsel13
__IO uint32_t frfsel13
Definition: at32f435_437_can.h:915
can_type::fmsel16
__IO uint32_t fmsel16
Definition: at32f435_437_can.h:828
can_type::faen25
__IO uint32_t faen25
Definition: at32f435_437_can.h:972
can_type::frfsel26
__IO uint32_t frfsel26
Definition: at32f435_437_can.h:928
can_type::faen7
__IO uint32_t faen7
Definition: at32f435_437_can.h:954
can_type::faen6
__IO uint32_t faen6
Definition: at32f435_437_can.h:953
can_type::fmsel25
__IO uint32_t fmsel25
Definition: at32f435_437_can.h:837
can_type::mdrsel
__IO uint32_t mdrsel
Definition: at32f435_437_can.h:600
can_type::faen8
__IO uint32_t faen8
Definition: at32f435_437_can.h:955
can_type::fbwsel23
__IO uint32_t fbwsel23
Definition: at32f435_437_can.h:880
can_type::rf0fien
__IO uint32_t rf0fien
Definition: at32f435_437_can.h:714
can_type::rf1ff
__IO uint32_t rf1ff
Definition: at32f435_437_can.h:697
can_type::fmsel22
__IO uint32_t fmsel22
Definition: at32f435_437_can.h:834
can_type::faen17
__IO uint32_t faen17
Definition: at32f435_437_can.h:964
can_type::cuss
__IO uint32_t cuss
Definition: at32f435_437_can.h:626
can_type::bof
__IO uint32_t bof
Definition: at32f435_437_can.h:742
can_type::faen10
__IO uint32_t faen10
Definition: at32f435_437_can.h:957
can_type::faen18
__IO uint32_t faen18
Definition: at32f435_437_can.h:965
can_type::tec
__IO uint32_t tec
Definition: at32f435_437_can.h:746
can_type::btmg
__IO uint32_t btmg
Definition: at32f435_437_can.h:756
can_type::faen20
__IO uint32_t faen20
Definition: at32f435_437_can.h:967
can_type::fbwsel0
__IO uint32_t fbwsel0
Definition: at32f435_437_can.h:857
can_type::sprst
__IO uint32_t sprst
Definition: at32f435_437_can.h:606
can_type::ttcen
__IO uint32_t ttcen
Definition: at32f435_437_can.h:604
can_type::tm1tcf
__IO uint32_t tm1tcf
Definition: at32f435_437_can.h:648
can_type::lben
__IO uint32_t lben
Definition: at32f435_437_can.h:766
can_type::faen24
__IO uint32_t faen24
Definition: at32f435_437_can.h:971
can_type::frfsel25
__IO uint32_t frfsel25
Definition: at32f435_437_can.h:927
can_type::ptd
__IO uint32_t ptd
Definition: at32f435_437_can.h:607
can_type::fzc
__IO uint32_t fzc
Definition: at32f435_437_can.h:620
can_type::epien
__IO uint32_t epien
Definition: at32f435_437_can.h:721
can_type::fbwsel11
__IO uint32_t fbwsel11
Definition: at32f435_437_can.h:868
can_type::faen3
__IO uint32_t faen3
Definition: at32f435_437_can.h:950
can_type::rf1oien
__IO uint32_t rf1oien
Definition: at32f435_437_can.h:718
can_type::rf0oien
__IO uint32_t rf0oien
Definition: at32f435_437_can.h:715
can_type::fbwsel27
__IO uint32_t fbwsel27
Definition: at32f435_437_can.h:884
can_type::tm0ef
__IO uint32_t tm0ef
Definition: at32f435_437_can.h:661
can_type::fbwsel1
__IO uint32_t fbwsel1
Definition: at32f435_437_can.h:858
can_type::frfsel8
__IO uint32_t frfsel8
Definition: at32f435_437_can.h:910
can_type::fbwsel6
__IO uint32_t fbwsel6
Definition: at32f435_437_can.h:863
can_type::bts2
__IO uint32_t bts2
Definition: at32f435_437_can.h:762
can_type::faen15
__IO uint32_t faen15
Definition: at32f435_437_can.h:962
can_type::loen
__IO uint32_t loen
Definition: at32f435_437_can.h:767
can_type::fbwsel7
__IO uint32_t fbwsel7
Definition: at32f435_437_can.h:864
can_type::fmsel3
__IO uint32_t fmsel3
Definition: at32f435_437_can.h:815
can_type::ests
__IO uint32_t ests
Definition: at32f435_437_can.h:737
can_type::frfsel9
__IO uint32_t frfsel9
Definition: at32f435_437_can.h:911
can_type::frf
__IO uint32_t frf
Definition: at32f435_437_can.h:899
can_type::fbwsel24
__IO uint32_t fbwsel24
Definition: at32f435_437_can.h:881
can_type::fbwsel22
__IO uint32_t fbwsel22
Definition: at32f435_437_can.h:879
can_type::reserved4
__IO uint32_t reserved4
can reserved register, offset:0x210
Definition: at32f435_437_can.h:892
can_type::frfsel27
__IO uint32_t frfsel27
Definition: at32f435_437_can.h:929
can_type::qdzien
__IO uint32_t qdzien
Definition: at32f435_437_can.h:726
can_type::fbwsel13
__IO uint32_t fbwsel13
Definition: at32f435_437_can.h:870
can_type::fmsel14
__IO uint32_t fmsel14
Definition: at32f435_437_can.h:826
can_type::reserved3
__IO uint32_t reserved3
can reserved register, offset:0x208
Definition: at32f435_437_can.h:658
can_type::fbwsel16
__IO uint32_t fbwsel16
Definition: at32f435_437_can.h:873
can_type::faen14
__IO uint32_t faen14
Definition: at32f435_437_can.h:961
can_type::rsaw
__IO uint32_t rsaw
Definition: at32f435_437_can.h:764
can_type::rf0r
__IO uint32_t rf0r
Definition: at32f435_437_can.h:682
can_type::rf0
__IO uint32_t rf0
Definition: at32f435_437_can.h:675
can_type::rf1mien
__IO uint32_t rf1mien
Definition: at32f435_437_can.h:716
can_type::fmsel15
__IO uint32_t fmsel15
Definition: at32f435_437_can.h:827
can_type::frfsel21
__IO uint32_t frfsel21
Definition: at32f435_437_can.h:923
can_type::fmsel1
__IO uint32_t fmsel1
Definition: at32f435_437_can.h:813
can_type::fbwsel20
__IO uint32_t fbwsel20
Definition: at32f435_437_can.h:877
can_type::fbwsel17
__IO uint32_t fbwsel17
Definition: at32f435_437_can.h:874
can_type::frfsel6
__IO uint32_t frfsel6
Definition: at32f435_437_can.h:908
can_type::tm1ct
__IO uint32_t tm1ct
Definition: at32f435_437_can.h:653
can_type::rf0mien
__IO uint32_t rf0mien
Definition: at32f435_437_can.h:713
can_type::fmsel24
__IO uint32_t fmsel24
Definition: at32f435_437_can.h:836
can_type::rf1mn
__IO uint32_t rf1mn
Definition: at32f435_437_can.h:695
can_type::edzien
__IO uint32_t edzien
Definition: at32f435_437_can.h:727
can_type::fmsel23
__IO uint32_t fmsel23
Definition: at32f435_437_can.h:835
can_type::reserved1
__IO uint32_t reserved1
can reserved register, offset:0x20~0x17C
Definition: at32f435_437_can.h:605
can_type::prsfen
__IO uint32_t prsfen
Definition: at32f435_437_can.h:601
can_type::facfg
__IO uint32_t facfg
Definition: at32f435_437_can.h:944
can_type::fmsel11
__IO uint32_t fmsel11
Definition: at32f435_437_can.h:823
can_type::tm1ef
__IO uint32_t tm1ef
Definition: at32f435_437_can.h:662
can_type::realrx
__IO uint32_t realrx
Definition: at32f435_437_can.h:629
can_type::aeboen
__IO uint32_t aeboen
Definition: at32f435_437_can.h:603
can_type::eoif
__IO uint32_t eoif
Definition: at32f435_437_can.h:622
can_type::tm2tcf
__IO uint32_t tm2tcf
Definition: at32f435_437_can.h:654
can_type::fbwsel21
__IO uint32_t fbwsel21
Definition: at32f435_437_can.h:878
can_type::frfsel15
__IO uint32_t frfsel15
Definition: at32f435_437_can.h:917
can_type::faen11
__IO uint32_t faen11
Definition: at32f435_437_can.h:958
can_type::faen1
__IO uint32_t faen1
Definition: at32f435_437_can.h:948
can_type::frfsel24
__IO uint32_t frfsel24
Definition: at32f435_437_can.h:926
can_type::brdiv
__IO uint32_t brdiv
Definition: at32f435_437_can.h:759
can_type::fmsel2
__IO uint32_t fmsel2
Definition: at32f435_437_can.h:814
can_type::frfsel14
__IO uint32_t frfsel14
Definition: at32f435_437_can.h:916
can_type::fbwsel25
__IO uint32_t fbwsel25
Definition: at32f435_437_can.h:882
can_type::fbwsel3
__IO uint32_t fbwsel3
Definition: at32f435_437_can.h:860
can_type::frfsel7
__IO uint32_t frfsel7
Definition: at32f435_437_can.h:909
can_type::epf
__IO uint32_t epf
Definition: at32f435_437_can.h:741
can_type::faen0
__IO uint32_t faen0
Definition: at32f435_437_can.h:947
can_type::fbwsel18
__IO uint32_t fbwsel18
Definition: at32f435_437_can.h:875
can_type::dzen
__IO uint32_t dzen
Definition: at32f435_437_can.h:598
can_type::tm2alf
__IO uint32_t tm2alf
Definition: at32f435_437_can.h:656
can_type::faen2
__IO uint32_t faen2
Definition: at32f435_437_can.h:949
can_type::fmsel10
__IO uint32_t fmsel10
Definition: at32f435_437_can.h:822
can_type::etr
__IO uint32_t etr
Definition: at32f435_437_can.h:744
can_type::tsts
__IO uint32_t tsts
Definition: at32f435_437_can.h:639
can_type::fbwsel5
__IO uint32_t fbwsel5
Definition: at32f435_437_can.h:862
can_type::fbwcfg
__IO uint32_t fbwcfg
Definition: at32f435_437_can.h:854
can_type::frfsel19
__IO uint32_t frfsel19
Definition: at32f435_437_can.h:921
can_type::faen26
__IO uint32_t faen26
Definition: at32f435_437_can.h:973
can_type::qdzif
__IO uint32_t qdzif
Definition: at32f435_437_can.h:623
can_type::tcien
__IO uint32_t tcien
Definition: at32f435_437_can.h:712
can_type::fbwsel2
__IO uint32_t fbwsel2
Definition: at32f435_437_can.h:859
can_type::faen19
__IO uint32_t faen19
Definition: at32f435_437_can.h:966
can_type::fmsel8
__IO uint32_t fmsel8
Definition: at32f435_437_can.h:820
can_type::rf0mn
__IO uint32_t rf0mn
Definition: at32f435_437_can.h:678
can_type::fmsel5
__IO uint32_t fmsel5
Definition: at32f435_437_can.h:817
can_type::rf0ff
__IO uint32_t rf0ff
Definition: at32f435_437_can.h:680
can_type::frfsel0
__IO uint32_t frfsel0
Definition: at32f435_437_can.h:902
can_type::reserved2
__IO uint32_t reserved2
can reserved register, offset:0x1D0~0x1FC
Definition: at32f435_437_can.h:608
can_type::fmsel18
__IO uint32_t fmsel18
Definition: at32f435_437_can.h:830
can_type::fcs
__IO uint32_t fcs
Definition: at32f435_437_can.h:799
can_type::frfsel23
__IO uint32_t frfsel23
Definition: at32f435_437_can.h:925
can_type::msts
__IO uint32_t msts
Definition: at32f435_437_can.h:617
can_type::lsamprx
__IO uint32_t lsamprx
Definition: at32f435_437_can.h:628
can_type::faen13
__IO uint32_t faen13
Definition: at32f435_437_can.h:960
can_type::tm0alf
__IO uint32_t tm0alf
Definition: at32f435_437_can.h:644
can_type::rec
__IO uint32_t rec
Definition: at32f435_437_can.h:747
can_type::bts1
__IO uint32_t bts1
Definition: at32f435_437_can.h:761
can_type::fmsel7
__IO uint32_t fmsel7
Definition: at32f435_437_can.h:819
can_type::rf1r
__IO uint32_t rf1r
Definition: at32f435_437_can.h:699
can_type::tm1lpf
__IO uint32_t tm1lpf
Definition: at32f435_437_can.h:665
can_type::tm2tsf
__IO uint32_t tm2tsf
Definition: at32f435_437_can.h:655
can_type::fmsel19
__IO uint32_t fmsel19
Definition: at32f435_437_can.h:831
can_type::frfsel5
__IO uint32_t frfsel5
Definition: at32f435_437_can.h:907
can_type::faen9
__IO uint32_t faen9
Definition: at32f435_437_can.h:956
can_type::fmsel6
__IO uint32_t fmsel6
Definition: at32f435_437_can.h:818
can_type::rf1fien
__IO uint32_t rf1fien
Definition: at32f435_437_can.h:717
can_type::faen5
__IO uint32_t faen5
Definition: at32f435_437_can.h:952
can_type::rf1of
__IO uint32_t rf1of
Definition: at32f435_437_can.h:698
can_type::fbwsel12
__IO uint32_t fbwsel12
Definition: at32f435_437_can.h:869
can_type::frfsel22
__IO uint32_t frfsel22
Definition: at32f435_437_can.h:924
can_type::tm0tef
__IO uint32_t tm0tef
Definition: at32f435_437_can.h:645
can_type::fmsel17
__IO uint32_t fmsel17
Definition: at32f435_437_can.h:829
can_type::fzen
__IO uint32_t fzen
Definition: at32f435_437_can.h:597
can_type::mmssr
__IO uint32_t mmssr
Definition: at32f435_437_can.h:599
can_type::faen12
__IO uint32_t faen12
Definition: at32f435_437_can.h:959
can_type::frfsel3
__IO uint32_t frfsel3
Definition: at32f435_437_can.h:905
can_type::fbwsel26
__IO uint32_t fbwsel26
Definition: at32f435_437_can.h:883
can_type::tm2tef
__IO uint32_t tm2tef
Definition: at32f435_437_can.h:657
can_type::inten
__IO uint32_t inten
Definition: at32f435_437_can.h:709
can_type::fmcfg
__IO uint32_t fmcfg
Definition: at32f435_437_can.h:809
can_type::tm1tsf
__IO uint32_t tm1tsf
Definition: at32f435_437_can.h:649
can_type::curs
__IO uint32_t curs
Definition: at32f435_437_can.h:627


AT32F435/437 Firmwary Library: at32f435_437_crc.c Source File

  • libraries
  • drivers
  • src
at32f435_437_crc.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef CRC_MODULE_ENABLED
39
49void crc_data_reset(void)
50{
51 /* reset crc generator */
52 CRC->ctrl_bit.rst = 0x1;
53}
54
60uint32_t crc_one_word_calculate(uint32_t data)
61{
62 CRC->dt = data;
63 return (CRC->dt);
64}
65
72uint32_t crc_block_calculate(uint32_t *pbuffer, uint32_t length)
73{
74 uint32_t index = 0;
75
76 for(index = 0; index < length; index++)
77 {
78 CRC->dt = pbuffer[index];
79 }
80
81 return (CRC->dt);
82}
83
89uint32_t crc_data_get(void)
90{
91 return (CRC->dt);
92}
93
99void crc_common_data_set(uint8_t cdt_value)
100{
101 CRC->cdt_bit.cdt = cdt_value;
102}
103
109uint8_t crc_common_date_get(void)
110{
111 return (CRC->cdt_bit.cdt);
112}
113
119void crc_init_data_set(uint32_t value)
120{
121 CRC->idt = value;
122}
123
134void crc_reverse_input_data_set(crc_reverse_input_type value)
135{
136 CRC->ctrl_bit.revid = value;
137}
138
147void crc_reverse_output_data_set(crc_reverse_output_type value)
148{
149 CRC->ctrl_bit.revod = value;
150}
151
156#endif
157
crc_reverse_output_type
crc_reverse_output_type
crc reverse output data
Definition: at32f435_437_crc.h:66
crc_reverse_input_type
crc_reverse_input_type
crc reverse input data
Definition: at32f435_437_crc.h:55
crc_reverse_input_data_set
void crc_reverse_input_data_set(crc_reverse_input_type value)
control the reversal of the bit order in the input data
Definition: at32f435_437_crc.c:134
crc_block_calculate
uint32_t crc_block_calculate(uint32_t *pbuffer, uint32_t length)
compute the 32-bit crc of a given buffer of data word(32-bit).
Definition: at32f435_437_crc.c:72
crc_init_data_set
void crc_init_data_set(uint32_t value)
set the 32-bit initial data of crc
Definition: at32f435_437_crc.c:119
crc_common_data_set
void crc_common_data_set(uint8_t cdt_value)
store a 8-bit data in the common data register.
Definition: at32f435_437_crc.c:99
crc_data_reset
void crc_data_reset(void)
reset the crc data register.
Definition: at32f435_437_crc.c:49
crc_common_date_get
uint8_t crc_common_date_get(void)
return the 8-bit data stored in the common data register
Definition: at32f435_437_crc.c:109
crc_data_get
uint32_t crc_data_get(void)
return the current crc value.
Definition: at32f435_437_crc.c:89
crc_one_word_calculate
uint32_t crc_one_word_calculate(uint32_t data)
compute the 32-bit crc of a given data word(32-bit).
Definition: at32f435_437_crc.c:60
crc_reverse_output_data_set
void crc_reverse_output_data_set(crc_reverse_output_type value)
control the reversal of the bit order in the output data
Definition: at32f435_437_crc.c:147
CRC
#define CRC
Definition: at32f435_437_crc.h:140
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_crc.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_crc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CRC_H
29#define __AT32F435_437_CRC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
54typedef enum
55{
56 CRC_REVERSE_INPUT_NO_AFFECTE = 0x00,
57 CRC_REVERSE_INPUT_BY_BYTE = 0x01,
58 CRC_REVERSE_INPUT_BY_HALFWORD = 0x02,
59 CRC_REVERSE_INPUT_BY_WORD = 0x03
60} crc_reverse_input_type;
61
65typedef enum
66{
67 CRC_REVERSE_OUTPUT_NO_AFFECTE = 0x00,
68 CRC_REVERSE_OUTPUT_DATA = 0x01
69} crc_reverse_output_type;
70
74typedef struct
75{
79 union
80 {
81 __IO uint32_t dt;
82 struct
83 {
84 __IO uint32_t dt : 32; /* [31:0] */
85 } dt_bit;
86 };
87
91 union
92 {
93 __IO uint32_t cdt;
94 struct
95 {
96 __IO uint32_t cdt : 8 ; /* [7:0] */
97 __IO uint32_t reserved1 : 24 ;/* [31:8] */
98 } cdt_bit;
99 };
100
104 union
105 {
106 __IO uint32_t ctrl;
107 struct
108 {
109 __IO uint32_t rst : 1 ; /* [0] */
110 __IO uint32_t reserved1 : 4 ; /* [4:1] */
111 __IO uint32_t revid : 2 ; /* [6:5] */
112 __IO uint32_t revod : 1 ; /* [7] */
113 __IO uint32_t reserved2 : 24 ;/* [31:8] */
114 } ctrl_bit;
115 };
116
120 __IO uint32_t reserved1;
121
125 union
126 {
127 __IO uint32_t idt;
128 struct
129 {
130 __IO uint32_t idt : 32; /* [31:0] */
131 } idt_bit;
132 };
133
134} crc_type;
135
140#define CRC ((crc_type *) CRC_BASE)
141
146void crc_data_reset(void);
147uint32_t crc_one_word_calculate(uint32_t data);
148uint32_t crc_block_calculate(uint32_t *pbuffer, uint32_t length);
149uint32_t crc_data_get(void);
150void crc_common_data_set(uint8_t cdt_value);
151uint8_t crc_common_date_get(void);
152void crc_init_data_set(uint32_t value);
153void crc_reverse_input_data_set(crc_reverse_input_type value);
154void crc_reverse_output_data_set(crc_reverse_output_type value);
155
168#ifdef __cplusplus
169}
170#endif
171
172#endif
at32f435_437.h
at32f435_437 header file
crc_reverse_input_data_set
void crc_reverse_input_data_set(crc_reverse_input_type value)
control the reversal of the bit order in the input data
Definition: at32f435_437_crc.c:134
crc_block_calculate
uint32_t crc_block_calculate(uint32_t *pbuffer, uint32_t length)
compute the 32-bit crc of a given buffer of data word(32-bit).
Definition: at32f435_437_crc.c:72
crc_init_data_set
void crc_init_data_set(uint32_t value)
set the 32-bit initial data of crc
Definition: at32f435_437_crc.c:119
crc_common_data_set
void crc_common_data_set(uint8_t cdt_value)
store a 8-bit data in the common data register.
Definition: at32f435_437_crc.c:99
crc_data_reset
void crc_data_reset(void)
reset the crc data register.
Definition: at32f435_437_crc.c:49
crc_common_date_get
uint8_t crc_common_date_get(void)
return the 8-bit data stored in the common data register
Definition: at32f435_437_crc.c:109
crc_data_get
uint32_t crc_data_get(void)
return the current crc value.
Definition: at32f435_437_crc.c:89
crc_one_word_calculate
uint32_t crc_one_word_calculate(uint32_t data)
compute the 32-bit crc of a given data word(32-bit).
Definition: at32f435_437_crc.c:60
crc_reverse_output_data_set
void crc_reverse_output_data_set(crc_reverse_output_type value)
control the reversal of the bit order in the output data
Definition: at32f435_437_crc.c:147
crc_reverse_output_type
crc_reverse_output_type
crc reverse output data
Definition: at32f435_437_crc.h:66
crc_reverse_input_type
crc_reverse_input_type
crc reverse input data
Definition: at32f435_437_crc.h:55
CRC_REVERSE_OUTPUT_DATA
@ CRC_REVERSE_OUTPUT_DATA
Definition: at32f435_437_crc.h:68
CRC_REVERSE_OUTPUT_NO_AFFECTE
@ CRC_REVERSE_OUTPUT_NO_AFFECTE
Definition: at32f435_437_crc.h:67
CRC_REVERSE_INPUT_BY_HALFWORD
@ CRC_REVERSE_INPUT_BY_HALFWORD
Definition: at32f435_437_crc.h:58
CRC_REVERSE_INPUT_BY_WORD
@ CRC_REVERSE_INPUT_BY_WORD
Definition: at32f435_437_crc.h:59
CRC_REVERSE_INPUT_BY_BYTE
@ CRC_REVERSE_INPUT_BY_BYTE
Definition: at32f435_437_crc.h:57
CRC_REVERSE_INPUT_NO_AFFECTE
@ CRC_REVERSE_INPUT_NO_AFFECTE
Definition: at32f435_437_crc.h:56
crc_type
type define crc register all
Definition: at32f435_437_crc.h:75
crc_type::ctrl
__IO uint32_t ctrl
Definition: at32f435_437_crc.h:106
crc_type::cdt
__IO uint32_t cdt
Definition: at32f435_437_crc.h:93
crc_type::dt
__IO uint32_t dt
Definition: at32f435_437_crc.h:81
crc_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_crc.h:113
crc_type::rst
__IO uint32_t rst
Definition: at32f435_437_crc.h:109
crc_type::revod
__IO uint32_t revod
Definition: at32f435_437_crc.h:112
crc_type::idt
__IO uint32_t idt
Definition: at32f435_437_crc.h:127
crc_type::reserved1
__IO uint32_t reserved1
crm reserved1 register, offset:0x0C
Definition: at32f435_437_crc.h:97
crc_type::revid
__IO uint32_t revid
Definition: at32f435_437_crc.h:111


AT32F435/437 Firmwary Library: at32f435_437_crm.c Source File

  • libraries
  • drivers
  • src
at32f435_437_crm.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef CRM_MODULE_ENABLED
39
49void crm_reset(void)
50{
51 /* reset the crm clock configuration to the default reset state(for debug purpose) */
52 /* set hicken bit */
53 CRM->ctrl_bit.hicken = TRUE;
54
55 /* wait hick stable */
56 while(CRM->ctrl_bit.hickstbl != SET);
57
58 /* hick used as system clock */
59 CRM->cfg_bit.sclksel = CRM_SCLK_HICK;
60
61 /* wait sclk switch status */
62 while(CRM->cfg_bit.sclksts != CRM_SCLK_HICK);
63
64 /* reset hexten, hextbyps, cfden and pllen bits */
65 CRM->ctrl &= ~(0x010D0000U);
66
67 /* reset cfg register, include sclk switch, ahbdiv, apb1div, apb2div, adcdiv, clkout bits */
68 CRM->cfg = 0;
69
70 /* reset pllms pllns pllfr pllrcs bits */
71 CRM->pllcfg = 0x00033002U;
72
73 /* reset clkout[3], usbbufs, hickdiv, clkoutdiv */
74 CRM->misc1 = 0;
75
76 /* disable all interrupts enable and clear pending bits */
77 CRM->clkint = 0x009F0000U;
78}
79
85void crm_lext_bypass(confirm_state new_state)
86{
87 CRM->bpdc_bit.lextbyps = new_state;
88}
89
95void crm_hext_bypass(confirm_state new_state)
96{
97 CRM->ctrl_bit.hextbyps = new_state;
98}
99
124 flag_status crm_flag_get(uint32_t flag)
125{
126 flag_status status = RESET;
127 if((CRM_REG(flag) & CRM_REG_BIT(flag)) != CRM_REG_BIT(flag))
128 {
129 status = RESET;
130 }
131 else
132 {
133 status = SET;
134 }
135 return status;
136}
137
143 error_status crm_hext_stable_wait(void)
144{
145 uint32_t stable_cnt = 0;
146 error_status status = ERROR;
147
148 while((crm_flag_get(CRM_HEXT_STABLE_FLAG) != SET) && (stable_cnt < HEXT_STARTUP_TIMEOUT))
149 {
150 stable_cnt ++;
151 }
152
153 if(crm_flag_get(CRM_HEXT_STABLE_FLAG) != SET)
154 {
155 status = ERROR;
156 }
157 else
158 {
159 status = SUCCESS;
160 }
161
162 return status;
163}
164
170void crm_hick_clock_trimming_set(uint8_t trim_value)
171{
172 CRM->ctrl_bit.hicktrim = trim_value;
173}
174
180void crm_hick_clock_calibration_set(uint8_t cali_value)
181{
182 /* enable write hick calibration */
183 CRM->misc1_bit.hickcal_key = 0x5A;
184
185 /* write hick calibration value */
186 CRM->ctrl_bit.hickcal = cali_value;
187
188 /* disable write hick calibration */
189 CRM->misc1_bit.hickcal_key = 0x0;
190}
191
215void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
216{
217 /* enable periph clock */
218 if(TRUE == new_state)
219 {
220 CRM_REG(value) |= CRM_REG_BIT(value);
221 }
222 /* disable periph clock */
223 else
224 {
225 CRM_REG(value) &= ~(CRM_REG_BIT(value));
226 }
227}
228
251void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
252{
253 /* enable periph reset */
254 if(new_state == TRUE)
255 {
256 CRM_REG(value) |= (CRM_REG_BIT(value));
257 }
258 /* disable periph reset */
259 else
260 {
261 CRM_REG(value) &= ~(CRM_REG_BIT(value));
262 }
263}
264
288void crm_periph_lowpower_mode_enable(crm_periph_clock_lowpower_type value, confirm_state new_state)
289{
290 /* enable periph clock in lowpower mode */
291 if(new_state == TRUE)
292 {
293 CRM_REG(value) |= (CRM_REG_BIT(value));
294 }
295 /* disable periph clock in lowpower mode */
296 else
297 {
298 CRM_REG(value) &= ~(CRM_REG_BIT(value));
299 }
300}
301
314void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
315{
316 switch(source)
317 {
318 case CRM_CLOCK_SOURCE_HICK:
319 CRM->ctrl_bit.hicken = new_state;
320 break;
321 case CRM_CLOCK_SOURCE_HEXT:
322 CRM->ctrl_bit.hexten = new_state;
323 break;
324 case CRM_CLOCK_SOURCE_PLL:
325 CRM->ctrl_bit.pllen = new_state;
326 break;
327 case CRM_CLOCK_SOURCE_LEXT:
328 CRM->bpdc_bit.lexten = new_state;
329 break;
330 case CRM_CLOCK_SOURCE_LICK:
331 CRM->ctrlsts_bit.licken = new_state;
332 break;
333 default: break;
334 }
335}
336
358void crm_flag_clear(uint32_t flag)
359{
360 switch(flag)
361 {
362 case CRM_NRST_RESET_FLAG:
363 case CRM_POR_RESET_FLAG:
364 case CRM_SW_RESET_FLAG:
365 case CRM_WDT_RESET_FLAG:
366 case CRM_WWDT_RESET_FLAG:
367 case CRM_LOWPOWER_RESET_FLAG:
368 case CRM_ALL_RESET_FLAG:
369 CRM->ctrlsts_bit.rstfc = TRUE;
370 while(CRM->ctrlsts_bit.rstfc == TRUE);
371 break;
372 case CRM_LICK_READY_INT_FLAG:
373 CRM->clkint_bit.lickstblfc = TRUE;
374 break;
375 case CRM_LEXT_READY_INT_FLAG:
376 CRM->clkint_bit.lextstblfc = TRUE;
377 break;
378 case CRM_HICK_READY_INT_FLAG:
379 CRM->clkint_bit.hickstblfc = TRUE;
380 break;
381 case CRM_HEXT_READY_INT_FLAG:
382 CRM->clkint_bit.hextstblfc = TRUE;
383 break;
384 case CRM_PLL_READY_INT_FLAG:
385 CRM->clkint_bit.pllstblfc = TRUE;
386 break;
387 case CRM_CLOCK_FAILURE_INT_FLAG:
388 CRM->clkint_bit.cfdfc = TRUE;
389 break;
390 default:
391 break;
392 }
393}
394
434void crm_ertc_clock_select(crm_ertc_clock_type value)
435{
436 CRM->cfg_bit.ertcdiv = ((value & 0x1F0) >> 4);
437 CRM->bpdc_bit.ertcsel = (value & 0xF);
438}
439
445void crm_ertc_clock_enable(confirm_state new_state)
446{
447 CRM->bpdc_bit.ertcen = new_state;
448}
449
465void crm_ahb_div_set(crm_ahb_div_type value)
466{
467 CRM->cfg_bit.ahbdiv = value;
468}
469
481void crm_apb1_div_set(crm_apb1_div_type value)
482{
483 CRM->cfg_bit.apb1div = value;
484}
485
497void crm_apb2_div_set(crm_apb2_div_type value)
498{
499 CRM->cfg_bit.apb2div = value;
500}
501
521void crm_usb_clock_div_set(crm_usb_div_type value)
522{
523 CRM->misc2_bit.usbdiv = value;
524}
525
531void crm_clock_failure_detection_enable(confirm_state new_state)
532{
533 CRM->ctrl_bit.cfden = new_state;
534}
535
541void crm_battery_powered_domain_reset(confirm_state new_state)
542{
543 CRM->bpdc_bit.bpdrst = new_state;
544}
545
551void crm_auto_step_mode_enable(confirm_state new_state)
552{
553 if(new_state == TRUE)
554 CRM->misc2_bit.auto_step_en = CRM_AUTO_STEP_MODE_ENABLE;
555 else
556 CRM->misc2_bit.auto_step_en = CRM_AUTO_STEP_MODE_DISABLE;
557}
558
567void crm_hick_divider_select(crm_hick_div_6_type value)
568{
569 CRM->misc1_bit.hickdiv = value;
570}
571
580void crm_hick_sclk_frequency_select(crm_hick_sclk_frequency_type value)
581{
582 crm_hick_divider_select(CRM_HICK48_NODIV);
583 CRM->misc1_bit.hick_to_sclk = value;
584}
585
594void crm_usb_clock_source_select(crm_usb_clock_source_type value)
595{
596 if(value == CRM_USB_CLOCK_SOURCE_HICK)
597 {
598 crm_hick_sclk_frequency_select(CRM_HICK_SCLK_48MHZ);
599 }
600 CRM->misc1_bit.hick_to_usb = value;
601}
602
608void crm_clkout_to_tmr10_enable(confirm_state new_state)
609{
610 CRM->misc2_bit.clk_to_tmr = new_state;
611}
612
645void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, \
646 uint16_t pll_ms, crm_pll_fr_type pll_fr)
647{
648 /* config pll clock source */
649 CRM->pllcfg_bit.pllrcs = clock_source;
650
651 /* config pll multiplication factor */
652 CRM->pllcfg_bit.pllns = pll_ns;
653 CRM->pllcfg_bit.pllms = pll_ms;
654 CRM->pllcfg_bit.pllfr = pll_fr;
655}
656
666void crm_sysclk_switch(crm_sclk_type value)
667{
668 CRM->cfg_bit.sclksel = value;
669}
670
680 crm_sclk_type crm_sysclk_switch_status_get(void)
681{
682 return (crm_sclk_type)CRM->cfg_bit.sclksts;
683}
684
691void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
692{
693 uint32_t pll_ns = 0, pll_ms = 0, pll_fr = 0, pll_clock_source = 0, pllrcsfreq = 0;
694 uint32_t temp = 0, div_value = 0;
695 crm_sclk_type sclk_source;
696
697 static const uint8_t sclk_ahb_div_table[16] = {0, 0, 0, 0, 0, 0, 0, 0, 1, 2, 3, 4, 6, 7, 8, 9};
698 static const uint8_t ahb_apb1_div_table[8] = {0, 0, 0, 0, 1, 2, 3, 4};
699 static const uint8_t ahb_apb2_div_table[8] = {0, 0, 0, 0, 1, 2, 3, 4};
700 static const uint8_t pll_fr_table[6] = {1, 2, 4, 8, 16, 32};
701
702 /* get sclk source */
703 sclk_source = crm_sysclk_switch_status_get();
704
705 switch(sclk_source)
706 {
707 case CRM_SCLK_HICK:
708 if(((CRM->misc1_bit.hick_to_sclk) != RESET) && ((CRM->misc1_bit.hickdiv) != RESET))
709 clocks_struct->sclk_freq = HICK_VALUE * 6;
710 else
711 clocks_struct->sclk_freq = HICK_VALUE;
712 break;
713 case CRM_SCLK_HEXT:
714 clocks_struct->sclk_freq = HEXT_VALUE;
715 break;
716 case CRM_SCLK_PLL:
717 /* get pll clock source */
718 pll_clock_source = CRM->pllcfg_bit.pllrcs;
719
720 /* get multiplication factor */
721 pll_ns = CRM->pllcfg_bit.pllns;
722 pll_ms = CRM->pllcfg_bit.pllms;
723 pll_fr = pll_fr_table[CRM->pllcfg_bit.pllfr];
724
725 if (pll_clock_source == CRM_PLL_SOURCE_HICK)
726 {
727 /* hick selected as pll clock entry */
728 pllrcsfreq = HICK_VALUE;
729 }
730 else
731 {
732 /* hext selected as pll clock entry */
733 pllrcsfreq = HEXT_VALUE;
734 }
735
736 clocks_struct->sclk_freq = (uint32_t)(((uint64_t)pllrcsfreq * pll_ns) / (pll_ms * pll_fr));
737 break;
738 default:
739 clocks_struct->sclk_freq = HICK_VALUE;
740 break;
741 }
742
743 /* compute sclk, ahbclk, abp1clk and apb2clk frequencies */
744 /* get ahb division */
745 temp = CRM->cfg_bit.ahbdiv;
746 div_value = sclk_ahb_div_table[temp];
747 /* ahbclk frequency */
748 clocks_struct->ahb_freq = clocks_struct->sclk_freq >> div_value;
749
750 /* get apb1 division */
751 temp = CRM->cfg_bit.apb1div;
752 div_value = ahb_apb1_div_table[temp];
753 /* apb1clk frequency */
754 clocks_struct->apb1_freq = clocks_struct->ahb_freq >> div_value;
755
756 /* get apb2 division */
757 temp = CRM->cfg_bit.apb2div;
758 div_value = ahb_apb2_div_table[temp];
759 /* apb2clk frequency */
760 clocks_struct->apb2_freq = clocks_struct->ahb_freq >> div_value;
761}
762
773void crm_clock_out1_set(crm_clkout1_select_type clkout)
774{
775 CRM->cfg_bit.clkout1_sel = clkout;
776}
777
792void crm_clock_out2_set(crm_clkout2_select_type clkout)
793{
794 if(clkout < 0x10)
795 {
796 CRM->cfg_bit.clkout2_sel1 = (clkout & 0x3);
797 }
798 else
799 {
800 CRM->cfg_bit.clkout2_sel1 = 0x1;
801 CRM->misc1_bit.clkout2_sel2 = (clkout & 0xF);
802 }
803}
804
831void crm_clkout_div_set(crm_clkout_index_type index, crm_clkout_div1_type div1, crm_clkout_div2_type div2)
832{
833 if(index == CRM_CLKOUT_INDEX_1)
834 {
835 CRM->cfg_bit.clkout1div1 = div1;
836 CRM->misc1_bit.clkout1div2 = div2;
837 }
838 else
839 {
840 CRM->cfg_bit.clkout2div1 = div1;
841 CRM->misc1_bit.clkout2div2 = div2;
842 }
843}
844
853void crm_emac_output_pulse_set(crm_emac_output_pulse_type width)
854{
855 CRM->misc2_bit.emac_pps_sel = width;
856}
857
870void crm_interrupt_enable(uint32_t crm_int, confirm_state new_state)
871{
872 if(TRUE == new_state)
873 CRM->clkint |= crm_int;
874 else
875 CRM->clkint &= ~crm_int;
876}
877
904 error_status crm_pll_parameter_calculate(crm_pll_clock_source_type pll_rcs, uint32_t target_sclk_freq, \
905 uint16_t *ret_ms, uint16_t *ret_ns, uint16_t *ret_fr)
906{
907 uint32_t pll_rcs_freq = 0, ns = 0, ms = 0, fr = 0;
908 uint32_t ms_min = 0, ms_max = 0, error_min = 0xFFFFFFFF;
909 uint32_t result = 0, absolute_value = 0;
910
911 /* reduce calculate accuracy, target_sclk_freq accuracy with khz */
912 target_sclk_freq = target_sclk_freq / 1000;
913
914 /* get pll reference clock frequency, accuracy with khz */
915 if(pll_rcs == CRM_PLL_SOURCE_HICK)
916 pll_rcs_freq = HICK_VALUE / 1000;
917 else
918 pll_rcs_freq = HEXT_VALUE / 1000;
919
920 /* polling ms range, accuracy with khz */
921 for(ms = 1; ms <= 15; ms ++)
922 {
923 result = pll_rcs_freq / ms;
924 if((result >= 2000U) && (result <= 16000U))
925 {
926 if(ms_min == 0)
927 ms_min = ms;
928
929 ms_max = ms;
930 }
931 }
932
933 /* polling pll parameters */
934 for(ms = ms_min; ms <= ms_max; ms ++)
935 {
936 for(fr = 0; fr <= 5; fr ++)
937 {
938 for(ns = 31; ns <= 500; ns ++)
939 {
940 result = (pll_rcs_freq * ns) / (ms);
941 /* check vco frequency range, accuracy with khz */
942 if((result < 500000U) || (result > 1000000U))
943 {
944 continue;
945 }
946 /* calculate pll output frequency */
947 result = result / (0x1 << fr);
948 /* check frequency */
949 if(target_sclk_freq == result)
950 {
951 *ret_ms = ms;
952 *ret_ns = ns;
953 *ret_fr = fr;
954 /* the pll parameters that is equal to target_sclk_freq */
955 return SUCCESS;
956 }
957 /* calculate error range, accuracy with khz */
958 absolute_value = (result > target_sclk_freq) ? (result - target_sclk_freq) : (target_sclk_freq - result);
959 if(absolute_value < error_min)
960 {
961 error_min = absolute_value;
962 *ret_ms = ms;
963 *ret_ns = ns;
964 *ret_fr = fr;
965 }
966 }
967 }
968 }
969 /* the pll parameters that is the closest approach to target_sclk_freq */
970 return ERROR;
971}
972
977#endif
978
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
crm_periph_clock_type
crm_periph_clock_type
crm periph clock
Definition: at32f435_437_crm.h:102
crm_hick_sclk_frequency_type
crm_hick_sclk_frequency_type
crm hick as system clock frequency select
Definition: at32f435_437_crm.h:770
crm_apb1_div_type
crm_apb1_div_type
crm apb1 division
Definition: at32f435_437_crm.h:586
crm_clock_source_type
crm_clock_source_type
crm clock source
Definition: at32f435_437_crm.h:558
crm_usb_div_type
crm_usb_div_type
crm usb division
Definition: at32f435_437_crm.h:610
crm_clkout_div1_type
crm_clkout_div1_type
crm clkout division1
Definition: at32f435_437_crm.h:724
crm_usb_clock_source_type
crm_usb_clock_source_type
crm usb 48 mhz clock source select
Definition: at32f435_437_crm.h:761
crm_emac_output_pulse_type
crm_emac_output_pulse_type
crm emac output pulse width
Definition: at32f435_437_crm.h:779
crm_pll_clock_source_type
crm_pll_clock_source_type
crm pll clock source
Definition: at32f435_437_crm.h:536
crm_clkout_div2_type
crm_clkout_div2_type
crm clkout division2
Definition: at32f435_437_crm.h:736
crm_ahb_div_type
crm_ahb_div_type
crm ahb division
Definition: at32f435_437_crm.h:570
crm_periph_clock_lowpower_type
crm_periph_clock_lowpower_type
crm periph clock in low power mode
Definition: at32f435_437_crm.h:389
crm_clkout1_select_type
crm_clkout1_select_type
crm clkout1 select
Definition: at32f435_437_crm.h:698
crm_sclk_type
crm_sclk_type
crm sclk select
Definition: at32f435_437_crm.h:679
crm_periph_reset_type
crm_periph_reset_type
crm periph reset
Definition: at32f435_437_crm.h:249
crm_apb2_div_type
crm_apb2_div_type
crm apb2 division
Definition: at32f435_437_crm.h:598
crm_ertc_clock_type
crm_ertc_clock_type
crm ertc clock
Definition: at32f435_437_crm.h:630
crm_pll_fr_type
crm_pll_fr_type
crm pll fr
Definition: at32f435_437_crm.h:545
crm_clkout_index_type
crm_clkout_index_type
crm clkout index
Definition: at32f435_437_crm.h:689
crm_hick_div_6_type
crm_hick_div_6_type
crm hick 48mhz division
Definition: at32f435_437_crm.h:670
crm_clkout2_select_type
crm_clkout2_select_type
crm clkout2 select
Definition: at32f435_437_crm.h:709
CRM_HICK_SCLK_48MHZ
@ CRM_HICK_SCLK_48MHZ
Definition: at32f435_437_crm.h:772
CRM_CLOCK_SOURCE_HICK
@ CRM_CLOCK_SOURCE_HICK
Definition: at32f435_437_crm.h:559
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_LEXT
@ CRM_CLOCK_SOURCE_LEXT
Definition: at32f435_437_crm.h:562
CRM_CLOCK_SOURCE_LICK
@ CRM_CLOCK_SOURCE_LICK
Definition: at32f435_437_crm.h:563
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f435_437_crm.h:763
CRM_PLL_SOURCE_HICK
@ CRM_PLL_SOURCE_HICK
Definition: at32f435_437_crm.h:537
CRM_AUTO_STEP_MODE_ENABLE
@ CRM_AUTO_STEP_MODE_ENABLE
Definition: at32f435_437_crm.h:754
CRM_AUTO_STEP_MODE_DISABLE
@ CRM_AUTO_STEP_MODE_DISABLE
Definition: at32f435_437_crm.h:753
CRM_SCLK_HICK
@ CRM_SCLK_HICK
Definition: at32f435_437_crm.h:680
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_SCLK_HEXT
@ CRM_SCLK_HEXT
Definition: at32f435_437_crm.h:681
CRM_CLKOUT_INDEX_1
@ CRM_CLKOUT_INDEX_1
Definition: at32f435_437_crm.h:690
CRM_HICK48_NODIV
@ CRM_HICK48_NODIV
Definition: at32f435_437_crm.h:672
CRM_PLL_READY_INT_FLAG
#define CRM_PLL_READY_INT_FLAG
Definition: at32f435_437_crm.h:71
CRM_HEXT_READY_INT_FLAG
#define CRM_HEXT_READY_INT_FLAG
Definition: at32f435_437_crm.h:70
CRM_LOWPOWER_RESET_FLAG
#define CRM_LOWPOWER_RESET_FLAG
Definition: at32f435_437_crm.h:66
CRM_CLOCK_FAILURE_INT_FLAG
#define CRM_CLOCK_FAILURE_INT_FLAG
Definition: at32f435_437_crm.h:72
CRM_HICK_READY_INT_FLAG
#define CRM_HICK_READY_INT_FLAG
Definition: at32f435_437_crm.h:69
CRM_LEXT_READY_INT_FLAG
#define CRM_LEXT_READY_INT_FLAG
Definition: at32f435_437_crm.h:68
CRM_POR_RESET_FLAG
#define CRM_POR_RESET_FLAG
Definition: at32f435_437_crm.h:62
CRM_HEXT_STABLE_FLAG
#define CRM_HEXT_STABLE_FLAG
Definition: at32f435_437_crm.h:56
CRM_SW_RESET_FLAG
#define CRM_SW_RESET_FLAG
Definition: at32f435_437_crm.h:63
CRM_NRST_RESET_FLAG
#define CRM_NRST_RESET_FLAG
Definition: at32f435_437_crm.h:61
CRM_WWDT_RESET_FLAG
#define CRM_WWDT_RESET_FLAG
Definition: at32f435_437_crm.h:65
CRM_LICK_READY_INT_FLAG
#define CRM_LICK_READY_INT_FLAG
Definition: at32f435_437_crm.h:67
CRM_ALL_RESET_FLAG
#define CRM_ALL_RESET_FLAG
Definition: at32f435_437_crm.h:60
CRM_WDT_RESET_FLAG
#define CRM_WDT_RESET_FLAG
Definition: at32f435_437_crm.h:64
crm_clkout_div_set
void crm_clkout_div_set(crm_clkout_index_type index, crm_clkout_div1_type div1, crm_clkout_div2_type div2)
set crm clkout1 division1
Definition: at32f435_437_crm.c:831
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type value)
set usb division
Definition: at32f435_437_crm.c:521
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hick_clock_calibration_set
void crm_hick_clock_calibration_set(uint8_t cali_value)
set the crm calibration value
Definition: at32f435_437_crm.c:180
crm_pll_parameter_calculate
error_status crm_pll_parameter_calculate(crm_pll_clock_source_type pll_rcs, uint32_t target_sclk_freq, uint16_t *ret_ms, uint16_t *ret_ns, uint16_t *ret_fr)
calculate the pll parameters with pll reference clock and target pll output frequency....
Definition: at32f435_437_crm.c:904
crm_periph_lowpower_mode_enable
void crm_periph_lowpower_mode_enable(crm_periph_clock_lowpower_type value, confirm_state new_state)
enable or disable the peripheral clock in lowpower mode
Definition: at32f435_437_crm.c:288
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_clock_out1_set
void crm_clock_out1_set(crm_clkout1_select_type clkout)
set crm clkout1
Definition: at32f435_437_crm.c:773
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_interrupt_enable
void crm_interrupt_enable(uint32_t crm_int, confirm_state new_state)
config crm interrupt
Definition: at32f435_437_crm.c:870
crm_flag_clear
void crm_flag_clear(uint32_t flag)
clear the crm reset flags
Definition: at32f435_437_crm.c:358
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_lext_bypass
void crm_lext_bypass(confirm_state new_state)
enable or disable crm low speed external crystal bypass
Definition: at32f435_437_crm.c:85
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_ertc_clock_select
void crm_ertc_clock_select(crm_ertc_clock_type value)
select ertc clock
Definition: at32f435_437_crm.c:434
crm_hick_sclk_frequency_select
void crm_hick_sclk_frequency_select(crm_hick_sclk_frequency_type value)
hick as system clock frequency select
Definition: at32f435_437_crm.c:580
crm_hick_divider_select
void crm_hick_divider_select(crm_hick_div_6_type value)
config hick divider select
Definition: at32f435_437_crm.c:567
crm_emac_output_pulse_set
void crm_emac_output_pulse_set(crm_emac_output_pulse_type width)
set emac output pulse width
Definition: at32f435_437_crm.c:853
crm_clock_failure_detection_enable
void crm_clock_failure_detection_enable(confirm_state new_state)
enable or disable clock failure detection
Definition: at32f435_437_crm.c:531
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f435_437_crm.c:251
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_clkout_to_tmr10_enable
void crm_clkout_to_tmr10_enable(confirm_state new_state)
enable or disable clkout direct to tmr10 channel 1
Definition: at32f435_437_crm.c:608
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_clock_out2_set
void crm_clock_out2_set(crm_clkout2_select_type clkout)
set crm clkout2
Definition: at32f435_437_crm.c:792
crm_hick_clock_trimming_set
void crm_hick_clock_trimming_set(uint8_t trim_value)
set the hick trimming value
Definition: at32f435_437_crm.c:170
crm_ertc_clock_enable
void crm_ertc_clock_enable(confirm_state new_state)
enable or disable ertc
Definition: at32f435_437_crm.c:445
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
crm_battery_powered_domain_reset
void crm_battery_powered_domain_reset(confirm_state new_state)
battery powered domain software reset
Definition: at32f435_437_crm.c:541
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f435_437_crm.c:594
crm_hext_bypass
void crm_hext_bypass(confirm_state new_state)
enable or disable crm high speed external crystal bypass
Definition: at32f435_437_crm.c:95
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_REG_BIT
#define CRM_REG_BIT(value)
Definition: at32f435_437_crm.h:48
CRM
#define CRM
Definition: at32f435_437_crm.h:1506
CRM_REG
#define CRM_REG(value)
Definition: at32f435_437_crm.h:47
error_status
error_status
Definition: at32f435_437.h:380
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
HEXT_VALUE
#define HEXT_VALUE
in the following line adjust the value of high speed exernal crystal (hext) used in your application
Definition: project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h:44
HICK_VALUE
#define HICK_VALUE
Definition: project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h:52
HEXT_STARTUP_TIMEOUT
#define HEXT_STARTUP_TIMEOUT
in the following line adjust the high speed exernal crystal (hext) startup timeout value
Definition: project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h:51
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f435_437_crm.h:792
crm_clocks_freq_type::apb2_freq
uint32_t apb2_freq
Definition: at32f435_437_crm.h:791
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f435_437_crm.h:789
crm_clocks_freq_type::ahb_freq
uint32_t ahb_freq
Definition: at32f435_437_crm.h:790
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_crm.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_crm.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CRM_H
29#define __AT32F435_437_CRM_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
47#define CRM_REG(value) PERIPH_REG(CRM_BASE, value)
48#define CRM_REG_BIT(value) PERIPH_REG_BIT(value)
49
55#define CRM_HICK_STABLE_FLAG MAKE_VALUE(0x00, 1)
56#define CRM_HEXT_STABLE_FLAG MAKE_VALUE(0x00, 17)
57#define CRM_PLL_STABLE_FLAG MAKE_VALUE(0x00, 25)
58#define CRM_LEXT_STABLE_FLAG MAKE_VALUE(0x70, 1)
59#define CRM_LICK_STABLE_FLAG MAKE_VALUE(0x74, 1)
60#define CRM_ALL_RESET_FLAG MAKE_VALUE(0x74, 24)
61#define CRM_NRST_RESET_FLAG MAKE_VALUE(0x74, 26)
62#define CRM_POR_RESET_FLAG MAKE_VALUE(0x74, 27)
63#define CRM_SW_RESET_FLAG MAKE_VALUE(0x74, 28)
64#define CRM_WDT_RESET_FLAG MAKE_VALUE(0x74, 29)
65#define CRM_WWDT_RESET_FLAG MAKE_VALUE(0x74, 30)
66#define CRM_LOWPOWER_RESET_FLAG MAKE_VALUE(0x74, 31)
67#define CRM_LICK_READY_INT_FLAG MAKE_VALUE(0x0C, 0)
68#define CRM_LEXT_READY_INT_FLAG MAKE_VALUE(0x0C, 1)
69#define CRM_HICK_READY_INT_FLAG MAKE_VALUE(0x0C, 2)
70#define CRM_HEXT_READY_INT_FLAG MAKE_VALUE(0x0C, 3)
71#define CRM_PLL_READY_INT_FLAG MAKE_VALUE(0x0C, 4)
72#define CRM_CLOCK_FAILURE_INT_FLAG MAKE_VALUE(0x0C, 7)
83#define CRM_LICK_STABLE_INT ((uint32_t)0x00000100)
84#define CRM_LEXT_STABLE_INT ((uint32_t)0x00000200)
85#define CRM_HICK_STABLE_INT ((uint32_t)0x00000400)
86#define CRM_HEXT_STABLE_INT ((uint32_t)0x00000800)
87#define CRM_PLL_STABLE_INT ((uint32_t)0x00001000)
88#define CRM_CLOCK_FAILURE_INT ((uint32_t)0x00800000)
101typedef enum
102{
103#if defined (AT32F435xx)
104 /* ahb periph1 */
105 CRM_GPIOA_PERIPH_CLOCK = MAKE_VALUE(0x30, 0),
106 CRM_GPIOB_PERIPH_CLOCK = MAKE_VALUE(0x30, 1),
107 CRM_GPIOC_PERIPH_CLOCK = MAKE_VALUE(0x30, 2),
108 CRM_GPIOD_PERIPH_CLOCK = MAKE_VALUE(0x30, 3),
109 CRM_GPIOE_PERIPH_CLOCK = MAKE_VALUE(0x30, 4),
110 CRM_GPIOF_PERIPH_CLOCK = MAKE_VALUE(0x30, 5),
111 CRM_GPIOG_PERIPH_CLOCK = MAKE_VALUE(0x30, 6),
112 CRM_GPIOH_PERIPH_CLOCK = MAKE_VALUE(0x30, 7),
113 CRM_CRC_PERIPH_CLOCK = MAKE_VALUE(0x30, 12),
114 CRM_EDMA_PERIPH_CLOCK = MAKE_VALUE(0x30, 21),
115 CRM_DMA1_PERIPH_CLOCK = MAKE_VALUE(0x30, 22),
116 CRM_DMA2_PERIPH_CLOCK = MAKE_VALUE(0x30, 24),
117 CRM_OTGFS2_PERIPH_CLOCK = MAKE_VALUE(0x30, 29),
118 /* ahb periph2 */
119 CRM_DVP_PERIPH_CLOCK = MAKE_VALUE(0x34, 0),
120 CRM_OTGFS1_PERIPH_CLOCK = MAKE_VALUE(0x34, 7),
121 CRM_SDIO1_PERIPH_CLOCK = MAKE_VALUE(0x34, 15),
122 /* ahb periph3 */
123 CRM_XMC_PERIPH_CLOCK = MAKE_VALUE(0x38, 0),
124 CRM_QSPI1_PERIPH_CLOCK = MAKE_VALUE(0x38, 1),
125 CRM_QSPI2_PERIPH_CLOCK = MAKE_VALUE(0x38, 14),
126 CRM_SDIO2_PERIPH_CLOCK = MAKE_VALUE(0x38, 15),
127 /* apb1 periph */
128 CRM_TMR2_PERIPH_CLOCK = MAKE_VALUE(0x40, 0),
129 CRM_TMR3_PERIPH_CLOCK = MAKE_VALUE(0x40, 1),
130 CRM_TMR4_PERIPH_CLOCK = MAKE_VALUE(0x40, 2),
131 CRM_TMR5_PERIPH_CLOCK = MAKE_VALUE(0x40, 3),
132 CRM_TMR6_PERIPH_CLOCK = MAKE_VALUE(0x40, 4),
133 CRM_TMR7_PERIPH_CLOCK = MAKE_VALUE(0x40, 5),
134 CRM_TMR12_PERIPH_CLOCK = MAKE_VALUE(0x40, 6),
135 CRM_TMR13_PERIPH_CLOCK = MAKE_VALUE(0x40, 7),
136 CRM_TMR14_PERIPH_CLOCK = MAKE_VALUE(0x40, 8),
137 CRM_WWDT_PERIPH_CLOCK = MAKE_VALUE(0x40, 11),
138 CRM_SPI2_PERIPH_CLOCK = MAKE_VALUE(0x40, 14),
139 CRM_SPI3_PERIPH_CLOCK = MAKE_VALUE(0x40, 15),
140 CRM_USART2_PERIPH_CLOCK = MAKE_VALUE(0x40, 17),
141 CRM_USART3_PERIPH_CLOCK = MAKE_VALUE(0x40, 18),
142 CRM_UART4_PERIPH_CLOCK = MAKE_VALUE(0x40, 19),
143 CRM_UART5_PERIPH_CLOCK = MAKE_VALUE(0x40, 20),
144 CRM_I2C1_PERIPH_CLOCK = MAKE_VALUE(0x40, 21),
145 CRM_I2C2_PERIPH_CLOCK = MAKE_VALUE(0x40, 22),
146 CRM_I2C3_PERIPH_CLOCK = MAKE_VALUE(0x40, 23),
147 CRM_CAN1_PERIPH_CLOCK = MAKE_VALUE(0x40, 25),
148 CRM_CAN2_PERIPH_CLOCK = MAKE_VALUE(0x40, 26),
149 CRM_PWC_PERIPH_CLOCK = MAKE_VALUE(0x40, 28),
150 CRM_DAC_PERIPH_CLOCK = MAKE_VALUE(0x40, 29),
151 CRM_UART7_PERIPH_CLOCK = MAKE_VALUE(0x40, 30),
152 CRM_UART8_PERIPH_CLOCK = MAKE_VALUE(0x40, 31),
153 /* apb2 periph */
154 CRM_TMR1_PERIPH_CLOCK = MAKE_VALUE(0x44, 0),
155 CRM_TMR8_PERIPH_CLOCK = MAKE_VALUE(0x44, 1),
156 CRM_USART1_PERIPH_CLOCK = MAKE_VALUE(0x44, 4),
157 CRM_USART6_PERIPH_CLOCK = MAKE_VALUE(0x44, 5),
158 CRM_ADC1_PERIPH_CLOCK = MAKE_VALUE(0x44, 8),
159 CRM_ADC2_PERIPH_CLOCK = MAKE_VALUE(0x44, 9),
160 CRM_ADC3_PERIPH_CLOCK = MAKE_VALUE(0x44, 10),
161 CRM_SPI1_PERIPH_CLOCK = MAKE_VALUE(0x44, 12),
162 CRM_SPI4_PERIPH_CLOCK = MAKE_VALUE(0x44, 13),
163 CRM_SCFG_PERIPH_CLOCK = MAKE_VALUE(0x44, 14),
164 CRM_TMR9_PERIPH_CLOCK = MAKE_VALUE(0x44, 16),
165 CRM_TMR10_PERIPH_CLOCK = MAKE_VALUE(0x44, 17),
166 CRM_TMR11_PERIPH_CLOCK = MAKE_VALUE(0x44, 18),
167 CRM_TMR20_PERIPH_CLOCK = MAKE_VALUE(0x44, 20),
168 CRM_ACC_PERIPH_CLOCK = MAKE_VALUE(0x44, 29)
169#endif
170
171#if defined (AT32F437xx)
172 /* ahb periph1 */
173 CRM_GPIOA_PERIPH_CLOCK = MAKE_VALUE(0x30, 0),
174 CRM_GPIOB_PERIPH_CLOCK = MAKE_VALUE(0x30, 1),
175 CRM_GPIOC_PERIPH_CLOCK = MAKE_VALUE(0x30, 2),
176 CRM_GPIOD_PERIPH_CLOCK = MAKE_VALUE(0x30, 3),
177 CRM_GPIOE_PERIPH_CLOCK = MAKE_VALUE(0x30, 4),
178 CRM_GPIOF_PERIPH_CLOCK = MAKE_VALUE(0x30, 5),
179 CRM_GPIOG_PERIPH_CLOCK = MAKE_VALUE(0x30, 6),
180 CRM_GPIOH_PERIPH_CLOCK = MAKE_VALUE(0x30, 7),
181 CRM_CRC_PERIPH_CLOCK = MAKE_VALUE(0x30, 12),
182 CRM_EDMA_PERIPH_CLOCK = MAKE_VALUE(0x30, 21),
183 CRM_DMA1_PERIPH_CLOCK = MAKE_VALUE(0x30, 22),
184 CRM_DMA2_PERIPH_CLOCK = MAKE_VALUE(0x30, 24),
185 CRM_EMAC_PERIPH_CLOCK = MAKE_VALUE(0x30, 25),
186 CRM_EMACTX_PERIPH_CLOCK = MAKE_VALUE(0x30, 26),
187 CRM_EMACRX_PERIPH_CLOCK = MAKE_VALUE(0x30, 27),
188 CRM_EMACPTP_PERIPH_CLOCK = MAKE_VALUE(0x30, 28),
189 CRM_OTGFS2_PERIPH_CLOCK = MAKE_VALUE(0x30, 29),
190 /* ahb periph2 */
191 CRM_DVP_PERIPH_CLOCK = MAKE_VALUE(0x34, 0),
192 CRM_OTGFS1_PERIPH_CLOCK = MAKE_VALUE(0x34, 7),
193 CRM_SDIO1_PERIPH_CLOCK = MAKE_VALUE(0x34, 15),
194 /* ahb periph3 */
195 CRM_XMC_PERIPH_CLOCK = MAKE_VALUE(0x38, 0),
196 CRM_QSPI1_PERIPH_CLOCK = MAKE_VALUE(0x38, 1),
197 CRM_QSPI2_PERIPH_CLOCK = MAKE_VALUE(0x38, 14),
198 CRM_SDIO2_PERIPH_CLOCK = MAKE_VALUE(0x38, 15),
199 /* apb1 periph */
200 CRM_TMR2_PERIPH_CLOCK = MAKE_VALUE(0x40, 0),
201 CRM_TMR3_PERIPH_CLOCK = MAKE_VALUE(0x40, 1),
202 CRM_TMR4_PERIPH_CLOCK = MAKE_VALUE(0x40, 2),
203 CRM_TMR5_PERIPH_CLOCK = MAKE_VALUE(0x40, 3),
204 CRM_TMR6_PERIPH_CLOCK = MAKE_VALUE(0x40, 4),
205 CRM_TMR7_PERIPH_CLOCK = MAKE_VALUE(0x40, 5),
206 CRM_TMR12_PERIPH_CLOCK = MAKE_VALUE(0x40, 6),
207 CRM_TMR13_PERIPH_CLOCK = MAKE_VALUE(0x40, 7),
208 CRM_TMR14_PERIPH_CLOCK = MAKE_VALUE(0x40, 8),
209 CRM_WWDT_PERIPH_CLOCK = MAKE_VALUE(0x40, 11),
210 CRM_SPI2_PERIPH_CLOCK = MAKE_VALUE(0x40, 14),
211 CRM_SPI3_PERIPH_CLOCK = MAKE_VALUE(0x40, 15),
212 CRM_USART2_PERIPH_CLOCK = MAKE_VALUE(0x40, 17),
213 CRM_USART3_PERIPH_CLOCK = MAKE_VALUE(0x40, 18),
214 CRM_UART4_PERIPH_CLOCK = MAKE_VALUE(0x40, 19),
215 CRM_UART5_PERIPH_CLOCK = MAKE_VALUE(0x40, 20),
216 CRM_I2C1_PERIPH_CLOCK = MAKE_VALUE(0x40, 21),
217 CRM_I2C2_PERIPH_CLOCK = MAKE_VALUE(0x40, 22),
218 CRM_I2C3_PERIPH_CLOCK = MAKE_VALUE(0x40, 23),
219 CRM_CAN1_PERIPH_CLOCK = MAKE_VALUE(0x40, 25),
220 CRM_CAN2_PERIPH_CLOCK = MAKE_VALUE(0x40, 26),
221 CRM_PWC_PERIPH_CLOCK = MAKE_VALUE(0x40, 28),
222 CRM_DAC_PERIPH_CLOCK = MAKE_VALUE(0x40, 29),
223 CRM_UART7_PERIPH_CLOCK = MAKE_VALUE(0x40, 30),
224 CRM_UART8_PERIPH_CLOCK = MAKE_VALUE(0x40, 31),
225 /* apb2 periph */
226 CRM_TMR1_PERIPH_CLOCK = MAKE_VALUE(0x44, 0),
227 CRM_TMR8_PERIPH_CLOCK = MAKE_VALUE(0x44, 1),
228 CRM_USART1_PERIPH_CLOCK = MAKE_VALUE(0x44, 4),
229 CRM_USART6_PERIPH_CLOCK = MAKE_VALUE(0x44, 5),
230 CRM_ADC1_PERIPH_CLOCK = MAKE_VALUE(0x44, 8),
231 CRM_ADC2_PERIPH_CLOCK = MAKE_VALUE(0x44, 9),
232 CRM_ADC3_PERIPH_CLOCK = MAKE_VALUE(0x44, 10),
233 CRM_SPI1_PERIPH_CLOCK = MAKE_VALUE(0x44, 12),
234 CRM_SPI4_PERIPH_CLOCK = MAKE_VALUE(0x44, 13),
235 CRM_SCFG_PERIPH_CLOCK = MAKE_VALUE(0x44, 14),
236 CRM_TMR9_PERIPH_CLOCK = MAKE_VALUE(0x44, 16),
237 CRM_TMR10_PERIPH_CLOCK = MAKE_VALUE(0x44, 17),
238 CRM_TMR11_PERIPH_CLOCK = MAKE_VALUE(0x44, 18),
239 CRM_TMR20_PERIPH_CLOCK = MAKE_VALUE(0x44, 20),
240 CRM_ACC_PERIPH_CLOCK = MAKE_VALUE(0x44, 29)
241#endif
242
243} crm_periph_clock_type;
244
248typedef enum
249{
250#if defined (AT32F435xx)
251 /* ahb periph1 */
252 CRM_GPIOA_PERIPH_RESET = MAKE_VALUE(0x10, 0),
253 CRM_GPIOB_PERIPH_RESET = MAKE_VALUE(0x10, 1),
254 CRM_GPIOC_PERIPH_RESET = MAKE_VALUE(0x10, 2),
255 CRM_GPIOD_PERIPH_RESET = MAKE_VALUE(0x10, 3),
256 CRM_GPIOE_PERIPH_RESET = MAKE_VALUE(0x10, 4),
257 CRM_GPIOF_PERIPH_RESET = MAKE_VALUE(0x10, 5),
258 CRM_GPIOG_PERIPH_RESET = MAKE_VALUE(0x10, 6),
259 CRM_GPIOH_PERIPH_RESET = MAKE_VALUE(0x10, 7),
260 CRM_CRC_PERIPH_RESET = MAKE_VALUE(0x10, 12),
261 CRM_EDMA_PERIPH_RESET = MAKE_VALUE(0x10, 21),
262 CRM_DMA1_PERIPH_RESET = MAKE_VALUE(0x10, 22),
263 CRM_DMA2_PERIPH_RESET = MAKE_VALUE(0x10, 24),
264 CRM_OTGFS2_PERIPH_RESET = MAKE_VALUE(0x10, 29),
265 /* ahb periph2 */
266 CRM_DVP_PERIPH_RESET = MAKE_VALUE(0x14, 0),
267 CRM_OTGFS1_PERIPH_RESET = MAKE_VALUE(0x14, 7),
268 CRM_SDIO1_PERIPH_RESET = MAKE_VALUE(0x14, 15),
269 /* ahb periph3 */
270 CRM_XMC_PERIPH_RESET = MAKE_VALUE(0x18, 0),
271 CRM_QSPI1_PERIPH_RESET = MAKE_VALUE(0x18, 1),
272 CRM_QSPI2_PERIPH_RESET = MAKE_VALUE(0x18, 14),
273 CRM_SDIO2_PERIPH_RESET = MAKE_VALUE(0x18, 15),
274 /* apb1 periph */
275 CRM_TMR2_PERIPH_RESET = MAKE_VALUE(0x20, 0),
276 CRM_TMR3_PERIPH_RESET = MAKE_VALUE(0x20, 1),
277 CRM_TMR4_PERIPH_RESET = MAKE_VALUE(0x20, 2),
278 CRM_TMR5_PERIPH_RESET = MAKE_VALUE(0x20, 3),
279 CRM_TMR6_PERIPH_RESET = MAKE_VALUE(0x20, 4),
280 CRM_TMR7_PERIPH_RESET = MAKE_VALUE(0x20, 5),
281 CRM_TMR12_PERIPH_RESET = MAKE_VALUE(0x20, 6),
282 CRM_TMR13_PERIPH_RESET = MAKE_VALUE(0x20, 7),
283 CRM_TMR14_PERIPH_RESET = MAKE_VALUE(0x20, 8),
284 CRM_WWDT_PERIPH_RESET = MAKE_VALUE(0x20, 11),
285 CRM_SPI2_PERIPH_RESET = MAKE_VALUE(0x20, 14),
286 CRM_SPI3_PERIPH_RESET = MAKE_VALUE(0x20, 15),
287 CRM_USART2_PERIPH_RESET = MAKE_VALUE(0x20, 17),
288 CRM_USART3_PERIPH_RESET = MAKE_VALUE(0x20, 18),
289 CRM_UART4_PERIPH_RESET = MAKE_VALUE(0x20, 19),
290 CRM_UART5_PERIPH_RESET = MAKE_VALUE(0x20, 20),
291 CRM_I2C1_PERIPH_RESET = MAKE_VALUE(0x20, 21),
292 CRM_I2C2_PERIPH_RESET = MAKE_VALUE(0x20, 22),
293 CRM_I2C3_PERIPH_RESET = MAKE_VALUE(0x20, 23),
294 CRM_CAN1_PERIPH_RESET = MAKE_VALUE(0x20, 25),
295 CRM_CAN2_PERIPH_RESET = MAKE_VALUE(0x20, 26),
296 CRM_PWC_PERIPH_RESET = MAKE_VALUE(0x20, 28),
297 CRM_DAC_PERIPH_RESET = MAKE_VALUE(0x20, 29),
298 CRM_UART7_PERIPH_RESET = MAKE_VALUE(0x20, 30),
299 CRM_UART8_PERIPH_RESET = MAKE_VALUE(0x20, 31),
300 /* apb2 periph */
301 CRM_TMR1_PERIPH_RESET = MAKE_VALUE(0x24, 0),
302 CRM_TMR8_PERIPH_RESET = MAKE_VALUE(0x24, 1),
303 CRM_USART1_PERIPH_RESET = MAKE_VALUE(0x24, 4),
304 CRM_USART6_PERIPH_RESET = MAKE_VALUE(0x24, 5),
305 CRM_ADC_PERIPH_RESET = MAKE_VALUE(0x24, 8),
306 CRM_SPI1_PERIPH_RESET = MAKE_VALUE(0x24, 12),
307 CRM_SPI4_PERIPH_RESET = MAKE_VALUE(0x24, 13),
308 CRM_SCFG_PERIPH_RESET = MAKE_VALUE(0x24, 14),
309 CRM_TMR9_PERIPH_RESET = MAKE_VALUE(0x24, 16),
310 CRM_TMR10_PERIPH_RESET = MAKE_VALUE(0x24, 17),
311 CRM_TMR11_PERIPH_RESET = MAKE_VALUE(0x24, 18),
312 CRM_TMR20_PERIPH_RESET = MAKE_VALUE(0x24, 20),
313 CRM_ACC_PERIPH_RESET = MAKE_VALUE(0x24, 29)
314#endif
315
316#if defined (AT32F437xx)
317 /* ahb periph1 */
318 CRM_GPIOA_PERIPH_RESET = MAKE_VALUE(0x10, 0),
319 CRM_GPIOB_PERIPH_RESET = MAKE_VALUE(0x10, 1),
320 CRM_GPIOC_PERIPH_RESET = MAKE_VALUE(0x10, 2),
321 CRM_GPIOD_PERIPH_RESET = MAKE_VALUE(0x10, 3),
322 CRM_GPIOE_PERIPH_RESET = MAKE_VALUE(0x10, 4),
323 CRM_GPIOF_PERIPH_RESET = MAKE_VALUE(0x10, 5),
324 CRM_GPIOG_PERIPH_RESET = MAKE_VALUE(0x10, 6),
325 CRM_GPIOH_PERIPH_RESET = MAKE_VALUE(0x10, 7),
326 CRM_CRC_PERIPH_RESET = MAKE_VALUE(0x10, 12),
327 CRM_EDMA_PERIPH_RESET = MAKE_VALUE(0x10, 21),
328 CRM_DMA1_PERIPH_RESET = MAKE_VALUE(0x10, 22),
329 CRM_DMA2_PERIPH_RESET = MAKE_VALUE(0x10, 24),
330 CRM_EMAC_PERIPH_RESET = MAKE_VALUE(0x10, 25),
331 CRM_OTGFS2_PERIPH_RESET = MAKE_VALUE(0x10, 29),
332 /* ahb periph2 */
333 CRM_DVP_PERIPH_RESET = MAKE_VALUE(0x14, 0),
334 CRM_OTGFS1_PERIPH_RESET = MAKE_VALUE(0x14, 7),
335 CRM_SDIO1_PERIPH_RESET = MAKE_VALUE(0x14, 15),
336 /* ahb periph3 */
337 CRM_XMC_PERIPH_RESET = MAKE_VALUE(0x18, 0),
338 CRM_QSPI1_PERIPH_RESET = MAKE_VALUE(0x18, 1),
339 CRM_QSPI2_PERIPH_RESET = MAKE_VALUE(0x18, 14),
340 CRM_SDIO2_PERIPH_RESET = MAKE_VALUE(0x18, 15),
341 /* apb1 periph */
342 CRM_TMR2_PERIPH_RESET = MAKE_VALUE(0x20, 0),
343 CRM_TMR3_PERIPH_RESET = MAKE_VALUE(0x20, 1),
344 CRM_TMR4_PERIPH_RESET = MAKE_VALUE(0x20, 2),
345 CRM_TMR5_PERIPH_RESET = MAKE_VALUE(0x20, 3),
346 CRM_TMR6_PERIPH_RESET = MAKE_VALUE(0x20, 4),
347 CRM_TMR7_PERIPH_RESET = MAKE_VALUE(0x20, 5),
348 CRM_TMR12_PERIPH_RESET = MAKE_VALUE(0x20, 6),
349 CRM_TMR13_PERIPH_RESET = MAKE_VALUE(0x20, 7),
350 CRM_TMR14_PERIPH_RESET = MAKE_VALUE(0x20, 8),
351 CRM_WWDT_PERIPH_RESET = MAKE_VALUE(0x20, 11),
352 CRM_SPI2_PERIPH_RESET = MAKE_VALUE(0x20, 14),
353 CRM_SPI3_PERIPH_RESET = MAKE_VALUE(0x20, 15),
354 CRM_USART2_PERIPH_RESET = MAKE_VALUE(0x20, 17),
355 CRM_USART3_PERIPH_RESET = MAKE_VALUE(0x20, 18),
356 CRM_UART4_PERIPH_RESET = MAKE_VALUE(0x20, 19),
357 CRM_UART5_PERIPH_RESET = MAKE_VALUE(0x20, 20),
358 CRM_I2C1_PERIPH_RESET = MAKE_VALUE(0x20, 21),
359 CRM_I2C2_PERIPH_RESET = MAKE_VALUE(0x20, 22),
360 CRM_I2C3_PERIPH_RESET = MAKE_VALUE(0x20, 23),
361 CRM_CAN1_PERIPH_RESET = MAKE_VALUE(0x20, 25),
362 CRM_CAN2_PERIPH_RESET = MAKE_VALUE(0x20, 26),
363 CRM_PWC_PERIPH_RESET = MAKE_VALUE(0x20, 28),
364 CRM_DAC_PERIPH_RESET = MAKE_VALUE(0x20, 29),
365 CRM_UART7_PERIPH_RESET = MAKE_VALUE(0x20, 30),
366 CRM_UART8_PERIPH_RESET = MAKE_VALUE(0x20, 31),
367 /* apb2 periph */
368 CRM_TMR1_PERIPH_RESET = MAKE_VALUE(0x24, 0),
369 CRM_TMR8_PERIPH_RESET = MAKE_VALUE(0x24, 1),
370 CRM_USART1_PERIPH_RESET = MAKE_VALUE(0x24, 4),
371 CRM_USART6_PERIPH_RESET = MAKE_VALUE(0x24, 5),
372 CRM_ADC_PERIPH_RESET = MAKE_VALUE(0x24, 8),
373 CRM_SPI1_PERIPH_RESET = MAKE_VALUE(0x24, 12),
374 CRM_SPI4_PERIPH_RESET = MAKE_VALUE(0x24, 13),
375 CRM_SCFG_PERIPH_RESET = MAKE_VALUE(0x24, 14),
376 CRM_TMR9_PERIPH_RESET = MAKE_VALUE(0x24, 16),
377 CRM_TMR10_PERIPH_RESET = MAKE_VALUE(0x24, 17),
378 CRM_TMR11_PERIPH_RESET = MAKE_VALUE(0x24, 18),
379 CRM_TMR20_PERIPH_RESET = MAKE_VALUE(0x24, 20),
380 CRM_ACC_PERIPH_RESET = MAKE_VALUE(0x24, 29)
381#endif
382
383} crm_periph_reset_type;
384
388typedef enum
389{
390#if defined (AT32F435xx)
391 /* ahb periph1 */
392 CRM_GPIOA_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 0),
393 CRM_GPIOB_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 1),
394 CRM_GPIOC_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 2),
395 CRM_GPIOD_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 3),
396 CRM_GPIOE_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 4),
397 CRM_GPIOF_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 5),
398 CRM_GPIOG_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 6),
399 CRM_GPIOH_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 7),
400 CRM_CRC_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 12),
401 CRM_EDMA_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 21),
402 CRM_DMA1_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 22),
403 CRM_DMA2_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 24),
404 CRM_EMAC_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 25),
405 CRM_EMACTX_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 26),
406 CRM_EMACRX_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 27),
407 CRM_EMACPTP_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 28),
408 CRM_OTGFS2_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 29),
409 /* ahb periph2 */
410 CRM_DVP_PERIPH_LOWPOWER = MAKE_VALUE(0x54, 0),
411 CRM_OTGFS1_PERIPH_LOWPOWER = MAKE_VALUE(0x54, 7),
412 CRM_SDIO1_PERIPH_LOWPOWER = MAKE_VALUE(0x54, 15),
413 /* ahb periph3 */
414 CRM_XMC_PERIPH_LOWPOWER = MAKE_VALUE(0x58, 0),
415 CRM_QSPI1_PERIPH_LOWPOWER = MAKE_VALUE(0x58, 1),
416 CRM_QSPI2_PERIPH_LOWPOWER = MAKE_VALUE(0x58, 14),
417 CRM_SDIO2_PERIPH_LOWPOWER = MAKE_VALUE(0x58, 15),
418 /* apb1 periph */
419 CRM_TMR2_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 0),
420 CRM_TMR3_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 1),
421 CRM_TMR4_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 2),
422 CRM_TMR5_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 3),
423 CRM_TMR6_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 4),
424 CRM_TMR7_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 5),
425 CRM_TMR12_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 6),
426 CRM_TMR13_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 7),
427 CRM_TMR14_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 8),
428 CRM_WWDT_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 11),
429 CRM_SPI2_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 14),
430 CRM_SPI3_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 15),
431 CRM_USART2_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 17),
432 CRM_USART3_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 18),
433 CRM_UART4_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 19),
434 CRM_UART5_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 20),
435 CRM_I2C1_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 21),
436 CRM_I2C2_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 22),
437 CRM_I2C3_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 23),
438 CRM_CAN1_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 25),
439 CRM_CAN2_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 26),
440 CRM_PWC_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 28),
441 CRM_DAC_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 29),
442 CRM_UART7_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 30),
443 CRM_UART8_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 31),
444 /* apb2 periph */
445 CRM_TMR1_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 0),
446 CRM_TMR8_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 1),
447 CRM_USART1_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 4),
448 CRM_USART6_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 5),
449 CRM_ADC1_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 8),
450 CRM_ADC2_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 9),
451 CRM_ADC3_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 10),
452 CRM_SPI1_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 12),
453 CRM_SPI4_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 13),
454 CRM_SCFG_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 14),
455 CRM_TMR9_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 16),
456 CRM_TMR10_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 17),
457 CRM_TMR11_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 18),
458 CRM_TMR20_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 20),
459 CRM_ACC_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 29)
460#endif
461
462#if defined (AT32F437xx)
463 /* ahb periph1 */
464 CRM_GPIOA_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 0),
465 CRM_GPIOB_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 1),
466 CRM_GPIOC_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 2),
467 CRM_GPIOD_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 3),
468 CRM_GPIOE_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 4),
469 CRM_GPIOF_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 5),
470 CRM_GPIOG_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 6),
471 CRM_GPIOH_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 7),
472 CRM_CRC_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 12),
473 CRM_EDMA_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 21),
474 CRM_DMA1_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 22),
475 CRM_DMA2_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 24),
476 CRM_OTGFS2_PERIPH_LOWPOWER = MAKE_VALUE(0x50, 29),
477 /* ahb periph2 */
478 CRM_DVP_PERIPH_LOWPOWER = MAKE_VALUE(0x54, 0),
479 CRM_OTGFS1_PERIPH_LOWPOWER = MAKE_VALUE(0x54, 7),
480 CRM_SDIO1_PERIPH_LOWPOWER = MAKE_VALUE(0x54, 15),
481 /* ahb periph3 */
482 CRM_XMC_PERIPH_LOWPOWER = MAKE_VALUE(0x58, 0),
483 CRM_QSPI1_PERIPH_LOWPOWER = MAKE_VALUE(0x58, 1),
484 CRM_QSPI2_PERIPH_LOWPOWER = MAKE_VALUE(0x58, 14),
485 CRM_SDIO2_PERIPH_LOWPOWER = MAKE_VALUE(0x58, 15),
486 /* apb1 periph */
487 CRM_TMR2_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 0),
488 CRM_TMR3_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 1),
489 CRM_TMR4_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 2),
490 CRM_TMR5_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 3),
491 CRM_TMR6_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 4),
492 CRM_TMR7_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 5),
493 CRM_TMR12_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 6),
494 CRM_TMR13_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 7),
495 CRM_TMR14_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 8),
496 CRM_WWDT_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 11),
497 CRM_SPI2_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 14),
498 CRM_SPI3_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 15),
499 CRM_USART2_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 17),
500 CRM_USART3_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 18),
501 CRM_UART4_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 19),
502 CRM_UART5_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 20),
503 CRM_I2C1_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 21),
504 CRM_I2C2_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 22),
505 CRM_I2C3_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 23),
506 CRM_CAN1_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 25),
507 CRM_CAN2_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 26),
508 CRM_PWC_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 28),
509 CRM_DAC_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 29),
510 CRM_UART7_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 30),
511 CRM_UART8_PERIPH_LOWPOWER = MAKE_VALUE(0x60, 31),
512 /* apb2 periph */
513 CRM_TMR1_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 0),
514 CRM_TMR8_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 1),
515 CRM_USART1_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 4),
516 CRM_USART6_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 5),
517 CRM_ADC1_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 8),
518 CRM_ADC2_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 9),
519 CRM_ADC3_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 10),
520 CRM_SPI1_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 12),
521 CRM_SPI4_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 13),
522 CRM_SCFG_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 14),
523 CRM_TMR9_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 16),
524 CRM_TMR10_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 17),
525 CRM_TMR11_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 18),
526 CRM_TMR20_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 20),
527 CRM_ACC_PERIPH_LOWPOWER = MAKE_VALUE(0x64, 29)
528#endif
529
530} crm_periph_clock_lowpower_type;
531
535typedef enum
536{
537 CRM_PLL_SOURCE_HICK = 0x00,
538 CRM_PLL_SOURCE_HEXT = 0x01
539} crm_pll_clock_source_type;
540
544typedef enum
545{
546 CRM_PLL_FR_1 = 0x00,
547 CRM_PLL_FR_2 = 0x01,
548 CRM_PLL_FR_4 = 0x02,
549 CRM_PLL_FR_8 = 0x03,
550 CRM_PLL_FR_16 = 0x04,
551 CRM_PLL_FR_32 = 0x05
552} crm_pll_fr_type;
553
557typedef enum
558{
559 CRM_CLOCK_SOURCE_HICK = 0x00,
560 CRM_CLOCK_SOURCE_HEXT = 0x01,
561 CRM_CLOCK_SOURCE_PLL = 0x02,
562 CRM_CLOCK_SOURCE_LEXT = 0x03,
563 CRM_CLOCK_SOURCE_LICK = 0x04
564} crm_clock_source_type;
565
569typedef enum
570{
571 CRM_AHB_DIV_1 = 0x00,
572 CRM_AHB_DIV_2 = 0x08,
573 CRM_AHB_DIV_4 = 0x09,
574 CRM_AHB_DIV_8 = 0x0A,
575 CRM_AHB_DIV_16 = 0x0B,
576 CRM_AHB_DIV_64 = 0x0C,
577 CRM_AHB_DIV_128 = 0x0D,
578 CRM_AHB_DIV_256 = 0x0E,
579 CRM_AHB_DIV_512 = 0x0F
580} crm_ahb_div_type;
581
585typedef enum
586{
587 CRM_APB1_DIV_1 = 0x00,
588 CRM_APB1_DIV_2 = 0x04,
589 CRM_APB1_DIV_4 = 0x05,
590 CRM_APB1_DIV_8 = 0x06,
591 CRM_APB1_DIV_16 = 0x07
592} crm_apb1_div_type;
593
597typedef enum
598{
599 CRM_APB2_DIV_1 = 0x00,
600 CRM_APB2_DIV_2 = 0x04,
601 CRM_APB2_DIV_4 = 0x05,
602 CRM_APB2_DIV_8 = 0x06,
603 CRM_APB2_DIV_16 = 0x07
604} crm_apb2_div_type;
605
609typedef enum
610{
611 CRM_USB_DIV_1_5 = 0x00,
612 CRM_USB_DIV_1 = 0x01,
613 CRM_USB_DIV_2_5 = 0x02,
614 CRM_USB_DIV_2 = 0x03,
615 CRM_USB_DIV_3_5 = 0x04,
616 CRM_USB_DIV_3 = 0x05,
617 CRM_USB_DIV_4_5 = 0x06,
618 CRM_USB_DIV_4 = 0x07,
619 CRM_USB_DIV_5_5 = 0x08,
620 CRM_USB_DIV_5 = 0x09,
621 CRM_USB_DIV_6_5 = 0x0A,
622 CRM_USB_DIV_6 = 0x0B,
623 CRM_USB_DIV_7 = 0x0C
624} crm_usb_div_type;
625
629typedef enum
630{
631 CRM_ERTC_CLOCK_NOCLK = 0x000,
632 CRM_ERTC_CLOCK_LEXT = 0x001,
633 CRM_ERTC_CLOCK_LICK = 0x002,
634 CRM_ERTC_CLOCK_HEXT_DIV_2 = 0x023,
635 CRM_ERTC_CLOCK_HEXT_DIV_3 = 0x033,
636 CRM_ERTC_CLOCK_HEXT_DIV_4 = 0x043,
637 CRM_ERTC_CLOCK_HEXT_DIV_5 = 0x053,
638 CRM_ERTC_CLOCK_HEXT_DIV_6 = 0x063,
639 CRM_ERTC_CLOCK_HEXT_DIV_7 = 0x073,
640 CRM_ERTC_CLOCK_HEXT_DIV_8 = 0x083,
641 CRM_ERTC_CLOCK_HEXT_DIV_9 = 0x093,
642 CRM_ERTC_CLOCK_HEXT_DIV_10 = 0x0A3,
643 CRM_ERTC_CLOCK_HEXT_DIV_11 = 0x0B3,
644 CRM_ERTC_CLOCK_HEXT_DIV_12 = 0x0C3,
645 CRM_ERTC_CLOCK_HEXT_DIV_13 = 0x0D3,
646 CRM_ERTC_CLOCK_HEXT_DIV_14 = 0x0E3,
647 CRM_ERTC_CLOCK_HEXT_DIV_15 = 0x0F3,
648 CRM_ERTC_CLOCK_HEXT_DIV_16 = 0x103,
649 CRM_ERTC_CLOCK_HEXT_DIV_17 = 0x113,
650 CRM_ERTC_CLOCK_HEXT_DIV_18 = 0x123,
651 CRM_ERTC_CLOCK_HEXT_DIV_19 = 0x133,
652 CRM_ERTC_CLOCK_HEXT_DIV_20 = 0x143,
653 CRM_ERTC_CLOCK_HEXT_DIV_21 = 0x153,
654 CRM_ERTC_CLOCK_HEXT_DIV_22 = 0x163,
655 CRM_ERTC_CLOCK_HEXT_DIV_23 = 0x173,
656 CRM_ERTC_CLOCK_HEXT_DIV_24 = 0x183,
657 CRM_ERTC_CLOCK_HEXT_DIV_25 = 0x193,
658 CRM_ERTC_CLOCK_HEXT_DIV_26 = 0x1A3,
659 CRM_ERTC_CLOCK_HEXT_DIV_27 = 0x1B3,
660 CRM_ERTC_CLOCK_HEXT_DIV_28 = 0x1C3,
661 CRM_ERTC_CLOCK_HEXT_DIV_29 = 0x1D3,
662 CRM_ERTC_CLOCK_HEXT_DIV_30 = 0x1E3,
663 CRM_ERTC_CLOCK_HEXT_DIV_31 = 0x1F3
664} crm_ertc_clock_type;
665
669typedef enum
670{
671 CRM_HICK48_DIV6 = 0x00,
672 CRM_HICK48_NODIV = 0x01
673} crm_hick_div_6_type;
674
678typedef enum
679{
680 CRM_SCLK_HICK = 0x00,
681 CRM_SCLK_HEXT = 0x01,
682 CRM_SCLK_PLL = 0x02
683} crm_sclk_type;
684
688typedef enum
689{
690 CRM_CLKOUT_INDEX_1 = 0x00,
691 CRM_CLKOUT_INDEX_2 = 0x01
692} crm_clkout_index_type;
693
697typedef enum
698{
699 CRM_CLKOUT1_HICK = 0x00,
700 CRM_CLKOUT1_LEXT = 0x01,
701 CRM_CLKOUT1_HEXT = 0x02,
702 CRM_CLKOUT1_PLL = 0x03
703} crm_clkout1_select_type;
704
708typedef enum
709{
710 CRM_CLKOUT2_SCLK = 0x00,
711 CRM_CLKOUT2_HEXT = 0x02,
712 CRM_CLKOUT2_PLL = 0x03,
713 CRM_CLKOUT2_USB = 0x10,
714 CRM_CLKOUT2_ADC = 0x11,
715 CRM_CLKOUT2_HICK = 0x12,
716 CRM_CLKOUT2_LICK = 0x13,
717 CRM_CLKOUT2_LEXT = 0x14
718} crm_clkout2_select_type;
719
723typedef enum
724{
725 CRM_CLKOUT_DIV1_1 = 0x00,
726 CRM_CLKOUT_DIV1_2 = 0x04,
727 CRM_CLKOUT_DIV1_3 = 0x05,
728 CRM_CLKOUT_DIV1_4 = 0x06,
729 CRM_CLKOUT_DIV1_5 = 0x07
730} crm_clkout_div1_type;
731
735typedef enum
736{
737 CRM_CLKOUT_DIV2_1 = 0x00,
738 CRM_CLKOUT_DIV2_2 = 0x08,
739 CRM_CLKOUT_DIV2_4 = 0x09,
740 CRM_CLKOUT_DIV2_8 = 0x0A,
741 CRM_CLKOUT_DIV2_16 = 0x0B,
742 CRM_CLKOUT_DIV2_64 = 0x0C,
743 CRM_CLKOUT_DIV2_128 = 0x0D,
744 CRM_CLKOUT_DIV2_256 = 0x0E,
745 CRM_CLKOUT_DIV2_512 = 0x0F
746} crm_clkout_div2_type;
747
751typedef enum
752{
753 CRM_AUTO_STEP_MODE_DISABLE = 0x00,
754 CRM_AUTO_STEP_MODE_ENABLE = 0x03
755} crm_auto_step_mode_type;
756
760typedef enum
761{
762 CRM_USB_CLOCK_SOURCE_PLL = 0x00,
763 CRM_USB_CLOCK_SOURCE_HICK = 0x01
764} crm_usb_clock_source_type;
765
769typedef enum
770{
771 CRM_HICK_SCLK_8MHZ = 0x00,
772 CRM_HICK_SCLK_48MHZ = 0x01
773} crm_hick_sclk_frequency_type;
774
778typedef enum
779{
780 CRM_EMAC_PULSE_125MS = 0x00,
781 CRM_EMAC_PULSE_1SCLK = 0x01
782} crm_emac_output_pulse_type;
783
787typedef struct
788{
789 uint32_t sclk_freq;
790 uint32_t ahb_freq;
791 uint32_t apb2_freq;
792 uint32_t apb1_freq;
793} crm_clocks_freq_type;
794
798typedef struct
799{
803 union
804 {
805 __IO uint32_t ctrl;
806 struct
807 {
808 __IO uint32_t hicken : 1; /* [0] */
809 __IO uint32_t hickstbl : 1; /* [1] */
810 __IO uint32_t hicktrim : 6; /* [7:2] */
811 __IO uint32_t hickcal : 8; /* [15:8] */
812 __IO uint32_t hexten : 1; /* [16] */
813 __IO uint32_t hextstbl : 1; /* [17] */
814 __IO uint32_t hextbyps : 1; /* [18] */
815 __IO uint32_t cfden : 1; /* [19] */
816 __IO uint32_t reserved1 : 4; /* [23:20] */
817 __IO uint32_t pllen : 1; /* [24] */
818 __IO uint32_t pllstbl : 1; /* [25] */
819 __IO uint32_t reserved2 : 6; /* [31:26] */
820 } ctrl_bit;
821 };
822
826 union
827 {
828 __IO uint32_t pllcfg;
829 struct
830 {
831 __IO uint32_t pllms : 4; /* [3:0] */
832 __IO uint32_t reserved1 : 2; /* [5:4] */
833 __IO uint32_t pllns : 9; /* [14:6] */
834 __IO uint32_t reserved2 : 1; /* [15] */
835 __IO uint32_t pllfr : 3; /* [18:16] */
836 __IO uint32_t reserved3 : 3; /* [21:19] */
837 __IO uint32_t pllrcs : 1; /* [22] */
838 __IO uint32_t reserved4 : 9; /* [31:23] */
839 } pllcfg_bit;
840 };
841
845 union
846 {
847 __IO uint32_t cfg;
848 struct
849 {
850 __IO uint32_t sclksel : 2; /* [1:0] */
851 __IO uint32_t sclksts : 2; /* [3:2] */
852 __IO uint32_t ahbdiv : 4; /* [7:4] */
853 __IO uint32_t reserved1 : 2; /* [9:8] */
854 __IO uint32_t apb1div : 3; /* [12:10] */
855 __IO uint32_t apb2div : 3; /* [15:13] */
856 __IO uint32_t ertcdiv : 5; /* [20:16] */
857 __IO uint32_t clkout1_sel : 2; /* [22:21] */
858 __IO uint32_t reserved2 : 1; /* [23] */
859 __IO uint32_t clkout1div1 : 3; /* [26:24] */
860 __IO uint32_t clkout2div1 : 3; /* [29:27] */
861 __IO uint32_t clkout2_sel1 : 2; /* [31:30] */
862 } cfg_bit;
863 };
864
868 union
869 {
870 __IO uint32_t clkint;
871 struct
872 {
873 __IO uint32_t lickstblf : 1; /* [0] */
874 __IO uint32_t lextstblf : 1; /* [1] */
875 __IO uint32_t hickstblf : 1; /* [2] */
876 __IO uint32_t hextstblf : 1; /* [3] */
877 __IO uint32_t pllstblf : 1; /* [4] */
878 __IO uint32_t reserved1 : 2; /* [6:5] */
879 __IO uint32_t cfdf : 1; /* [7] */
880 __IO uint32_t lickstblien : 1; /* [8] */
881 __IO uint32_t lextstblien : 1; /* [9] */
882 __IO uint32_t hickstblien : 1; /* [10] */
883 __IO uint32_t hextstblien : 1; /* [11] */
884 __IO uint32_t pllstblien : 1; /* [12] */
885 __IO uint32_t reserved2 : 3; /* [15:13] */
886 __IO uint32_t lickstblfc : 1; /* [16] */
887 __IO uint32_t lextstblfc : 1; /* [17] */
888 __IO uint32_t hickstblfc : 1; /* [18] */
889 __IO uint32_t hextstblfc : 1; /* [19] */
890 __IO uint32_t pllstblfc : 1; /* [20] */
891 __IO uint32_t reserved3 : 2; /* [22:21] */
892 __IO uint32_t cfdfc : 1; /* [23] */
893 __IO uint32_t reserved4 : 8; /* [31:24] */
894 } clkint_bit;
895 };
896
900 union
901 {
902 __IO uint32_t ahbrst1;
903#if defined (AT32F435xx)
904 struct
905 {
906 __IO uint32_t gpioarst : 1; /* [0] */
907 __IO uint32_t gpiobrst : 1; /* [1] */
908 __IO uint32_t gpiocrst : 1; /* [2] */
909 __IO uint32_t gpiodrst : 1; /* [3] */
910 __IO uint32_t gpioerst : 1; /* [4] */
911 __IO uint32_t gpiofrst : 1; /* [5] */
912 __IO uint32_t gpiogrst : 1; /* [6] */
913 __IO uint32_t gpiohrst : 1; /* [7] */
914 __IO uint32_t reserved1 : 4; /* [11:8] */
915 __IO uint32_t crcrst : 1; /* [12] */
916 __IO uint32_t reserved2 : 8; /* [20:13] */
917 __IO uint32_t edmarst : 1; /* [21] */
918 __IO uint32_t dma1rst : 1; /* [22] */
919 __IO uint32_t reserved3 : 1; /* [23] */
920 __IO uint32_t dma2rst : 1; /* [24] */
921 __IO uint32_t reserved4 : 4; /* [28:25] */
922 __IO uint32_t otgfs2rst : 1; /* [29] */
923 __IO uint32_t reserved5 : 2; /* [31:30] */
924 } ahbrst1_bit;
925#endif
926
927#if defined (AT32F437xx)
928 struct
929 {
930 __IO uint32_t gpioarst : 1; /* [0] */
931 __IO uint32_t gpiobrst : 1; /* [1] */
932 __IO uint32_t gpiocrst : 1; /* [2] */
933 __IO uint32_t gpiodrst : 1; /* [3] */
934 __IO uint32_t gpioerst : 1; /* [4] */
935 __IO uint32_t gpiofrst : 1; /* [5] */
936 __IO uint32_t gpiogrst : 1; /* [6] */
937 __IO uint32_t gpiohrst : 1; /* [7] */
938 __IO uint32_t reserved1 : 4; /* [11:8] */
939 __IO uint32_t crcrst : 1; /* [12] */
940 __IO uint32_t reserved2 : 8; /* [20:13] */
941 __IO uint32_t edmarst : 1; /* [21] */
942 __IO uint32_t dma1rst : 1; /* [22] */
943 __IO uint32_t reserved3 : 1; /* [23] */
944 __IO uint32_t dma2rst : 1; /* [24] */
945 __IO uint32_t emacrst : 1; /* [25] */
946 __IO uint32_t reserved4 : 3; /* [28:26] */
947 __IO uint32_t otgfs2rst : 1; /* [29] */
948 __IO uint32_t reserved5 : 2; /* [31:30] */
949 } ahbrst1_bit;
950#endif
951 };
952
956 union
957 {
958 __IO uint32_t ahbrst2;
959 struct
960 {
961 __IO uint32_t dvprst : 1; /* [0] */
962 __IO uint32_t reserved1 : 6; /* [6:1] */
963 __IO uint32_t otgfs1rst : 1; /* [7] */
964 __IO uint32_t reserved2 : 7; /* [14:8] */
965 __IO uint32_t sdio1rst : 1; /* [15] */
966 __IO uint32_t reserved3 : 16;/* [31:16] */
967 } ahbrst2_bit;
968 };
969
973 union
974 {
975 __IO uint32_t ahbrst3;
976 struct
977 {
978 __IO uint32_t xmcrst : 1; /* [0] */
979 __IO uint32_t qspi1rst : 1; /* [1] */
980 __IO uint32_t reserved1 : 12;/* [13:2] */
981 __IO uint32_t qspi2rst : 1; /* [14] */
982 __IO uint32_t sdio2rst : 1; /* [15] */
983 __IO uint32_t reserved3 : 16;/* [31:16] */
984 } ahbrst3_bit;
985 };
986
990 __IO uint32_t reserved1;
991
995 union
996 {
997 __IO uint32_t apb1rst;
998 struct
999 {
1000 __IO uint32_t tmr2rst : 1; /* [0] */
1001 __IO uint32_t tmr3rst : 1; /* [1] */
1002 __IO uint32_t tmr4rst : 1; /* [2] */
1003 __IO uint32_t tmr5rst : 1; /* [3] */
1004 __IO uint32_t tmr6rst : 1; /* [4] */
1005 __IO uint32_t tmr7rst : 1; /* [5] */
1006 __IO uint32_t tmr12rst : 1; /* [6] */
1007 __IO uint32_t tmr13rst : 1; /* [7] */
1008 __IO uint32_t adc14rst : 1; /* [8] */
1009 __IO uint32_t reserved1 : 2; /* [10:9] */
1010 __IO uint32_t wwdtrst : 1; /* [11] */
1011 __IO uint32_t reserved2 : 2; /* [13:12] */
1012 __IO uint32_t spi2rst : 1; /* [14] */
1013 __IO uint32_t spi3rst : 1; /* [15] */
1014 __IO uint32_t reserved3 : 1; /* [16] */
1015 __IO uint32_t usart2rst : 1; /* [17] */
1016 __IO uint32_t usart3rst : 1; /* [18] */
1017 __IO uint32_t uart4rst : 1; /* [19] */
1018 __IO uint32_t uart5rst : 1; /* [20] */
1019 __IO uint32_t i2c1rst : 1; /* [21] */
1020 __IO uint32_t i2c2rst : 1; /* [22] */
1021 __IO uint32_t i2c3rst : 1; /* [23] */
1022 __IO uint32_t reserved4 : 1; /* [24] */
1023 __IO uint32_t can1rst : 1; /* [25] */
1024 __IO uint32_t can2rst : 1; /* [26] */
1025 __IO uint32_t reserved5 : 1; /* [27] */
1026 __IO uint32_t pwcrst : 1; /* [28] */
1027 __IO uint32_t dacrst : 1; /* [29] */
1028 __IO uint32_t uart7rst : 1; /* [30] */
1029 __IO uint32_t uart8rst : 1; /* [31] */
1030 } apb1rst_bit;
1031 };
1032
1036 union
1037 {
1038 __IO uint32_t apb2rst;
1039 struct
1040 {
1041 __IO uint32_t tmr1rst : 1; /* [0] */
1042 __IO uint32_t tmr8rst : 1; /* [1] */
1043 __IO uint32_t reserved1 : 2; /* [3:2] */
1044 __IO uint32_t usart1rst : 1; /* [4] */
1045 __IO uint32_t usart6rst : 1; /* [5] */
1046 __IO uint32_t reserved2 : 2; /* [7:6] */
1047 __IO uint32_t adcrst : 1; /* [8] */
1048 __IO uint32_t reserved3 : 3; /* [11:9] */
1049 __IO uint32_t spi1rst : 1; /* [12] */
1050 __IO uint32_t spi4rst : 1; /* [13] */
1051 __IO uint32_t scfgrst : 1; /* [14] */
1052 __IO uint32_t reserved4 : 1; /* [15] */
1053 __IO uint32_t tmr9rst : 1; /* [16] */
1054 __IO uint32_t tmr10rst : 1; /* [17] */
1055 __IO uint32_t tmr11rst : 1; /* [18] */
1056 __IO uint32_t reserved5 : 1; /* [19] */
1057 __IO uint32_t tmr20rst : 1; /* [20] */
1058 __IO uint32_t reserved6 : 8; /* [28:21] */
1059 __IO uint32_t accrst : 1; /* [29] */
1060 __IO uint32_t reserved7 : 2; /* [31:30] */
1061 } apb2rst_bit;
1062 };
1063
1067 __IO uint32_t reserved2[2];
1068
1072 union
1073 {
1074 __IO uint32_t ahben1;
1075#if defined (AT32F435xx)
1076 struct
1077 {
1078 __IO uint32_t gpioaen : 1; /* [0] */
1079 __IO uint32_t gpioben : 1; /* [1] */
1080 __IO uint32_t gpiocen : 1; /* [2] */
1081 __IO uint32_t gpioden : 1; /* [3] */
1082 __IO uint32_t gpioeen : 1; /* [4] */
1083 __IO uint32_t gpiofen : 1; /* [5] */
1084 __IO uint32_t gpiogen : 1; /* [6] */
1085 __IO uint32_t gpiohen : 1; /* [7] */
1086 __IO uint32_t reserved1 : 4; /* [11:8] */
1087 __IO uint32_t crcen : 1; /* [12] */
1088 __IO uint32_t reserved2 : 8; /* [20:13] */
1089 __IO uint32_t edmaen : 1; /* [21] */
1090 __IO uint32_t dma1en : 1; /* [22] */
1091 __IO uint32_t reserved3 : 1; /* [23] */
1092 __IO uint32_t dma2en : 1; /* [24] */
1093 __IO uint32_t reserved4 : 4; /* [28:25] */
1094 __IO uint32_t otgfs2en : 1; /* [29] */
1095 __IO uint32_t reserved5 : 2; /* [31:30] */
1096 } ahben1_bit;
1097#endif
1098
1099#if defined (AT32F437xx)
1100 struct
1101 {
1102 __IO uint32_t gpioaen : 1; /* [0] */
1103 __IO uint32_t gpioben : 1; /* [1] */
1104 __IO uint32_t gpiocen : 1; /* [2] */
1105 __IO uint32_t gpioden : 1; /* [3] */
1106 __IO uint32_t gpioeen : 1; /* [4] */
1107 __IO uint32_t gpiofen : 1; /* [5] */
1108 __IO uint32_t gpiogen : 1; /* [6] */
1109 __IO uint32_t gpiohen : 1; /* [7] */
1110 __IO uint32_t reserved1 : 4; /* [11:8] */
1111 __IO uint32_t crcen : 1; /* [12] */
1112 __IO uint32_t reserved2 : 8; /* [20:13] */
1113 __IO uint32_t edmaen : 1; /* [21] */
1114 __IO uint32_t dma1en : 1; /* [22] */
1115 __IO uint32_t reserved3 : 1; /* [23] */
1116 __IO uint32_t dma2en : 1; /* [24] */
1117 __IO uint32_t emacen : 1; /* [25] */
1118 __IO uint32_t reserved4 : 3; /* [28:26] */
1119 __IO uint32_t otgfs2en : 1; /* [29] */
1120 __IO uint32_t reserved5 : 2; /* [31:30] */
1121 } ahben1_bit;
1122#endif
1123 };
1124
1128 union
1129 {
1130 __IO uint32_t ahben2;
1131 struct
1132 {
1133 __IO uint32_t dvpen : 1; /* [0] */
1134 __IO uint32_t reserved1 : 6; /* [6:1] */
1135 __IO uint32_t otgfs1en : 1; /* [7] */
1136 __IO uint32_t reserved2 : 7; /* [14:8] */
1137 __IO uint32_t sdio1en : 1; /* [15] */
1138 __IO uint32_t reserved3 : 16;/* [31:16] */
1139 } ahben2_bit;
1140 };
1141
1145 union
1146 {
1147 __IO uint32_t ahben3;
1148 struct
1149 {
1150 __IO uint32_t xmcen : 1; /* [0] */
1151 __IO uint32_t qspi1en : 1; /* [1] */
1152 __IO uint32_t reserved1 : 12;/* [13:2] */
1153 __IO uint32_t qspi2en : 1; /* [14] */
1154 __IO uint32_t sdio2en : 1; /* [15] */
1155 __IO uint32_t reserved3 : 16;/* [31:16] */
1156 } ahben3_bit;
1157 };
1158
1162 __IO uint32_t reserved3;
1163
1167 union
1168 {
1169 __IO uint32_t apb1en;
1170 struct
1171 {
1172 __IO uint32_t tmr2en : 1; /* [0] */
1173 __IO uint32_t tmr3en : 1; /* [1] */
1174 __IO uint32_t tmr4en : 1; /* [2] */
1175 __IO uint32_t tmr5en : 1; /* [3] */
1176 __IO uint32_t tmr6en : 1; /* [4] */
1177 __IO uint32_t tmr7en : 1; /* [5] */
1178 __IO uint32_t tmr12en : 1; /* [6] */
1179 __IO uint32_t tmr13en : 1; /* [7] */
1180 __IO uint32_t adc14en : 1; /* [8] */
1181 __IO uint32_t reserved1 : 2; /* [10:9] */
1182 __IO uint32_t wwdten : 1; /* [11] */
1183 __IO uint32_t reserved2 : 2; /* [13:12] */
1184 __IO uint32_t spi2en : 1; /* [14] */
1185 __IO uint32_t spi3en : 1; /* [15] */
1186 __IO uint32_t reserved3 : 1; /* [16] */
1187 __IO uint32_t usart2en : 1; /* [17] */
1188 __IO uint32_t usart3en : 1; /* [18] */
1189 __IO uint32_t uart4en : 1; /* [19] */
1190 __IO uint32_t uart5en : 1; /* [20] */
1191 __IO uint32_t i2c1en : 1; /* [21] */
1192 __IO uint32_t i2c2en : 1; /* [22] */
1193 __IO uint32_t i2c3en : 1; /* [23] */
1194 __IO uint32_t reserved4 : 1; /* [24] */
1195 __IO uint32_t can1en : 1; /* [25] */
1196 __IO uint32_t can2en : 1; /* [26] */
1197 __IO uint32_t reserved5 : 1; /* [27] */
1198 __IO uint32_t pwcen : 1; /* [28] */
1199 __IO uint32_t dacen : 1; /* [29] */
1200 __IO uint32_t uart7en : 1; /* [30] */
1201 __IO uint32_t uart8en : 1; /* [31] */
1202 } apb1en_bit;
1203 };
1204
1208 union
1209 {
1210 __IO uint32_t apb2en;
1211 struct
1212 {
1213 __IO uint32_t tmr1en : 1; /* [0] */
1214 __IO uint32_t tmr8en : 1; /* [1] */
1215 __IO uint32_t reserved1 : 2; /* [3:2] */
1216 __IO uint32_t usart1en : 1; /* [4] */
1217 __IO uint32_t usart6en : 1; /* [5] */
1218 __IO uint32_t reserved2 : 2; /* [7:6] */
1219 __IO uint32_t adcen : 1; /* [8] */
1220 __IO uint32_t reserved3 : 3; /* [11:9] */
1221 __IO uint32_t spi1en : 1; /* [12] */
1222 __IO uint32_t spi4en : 1; /* [13] */
1223 __IO uint32_t scfgen : 1; /* [14] */
1224 __IO uint32_t reserved4 : 1; /* [15] */
1225 __IO uint32_t tmr9en : 1; /* [16] */
1226 __IO uint32_t tmr10en : 1; /* [17] */
1227 __IO uint32_t tmr11en : 1; /* [18] */
1228 __IO uint32_t reserved5 : 1; /* [19] */
1229 __IO uint32_t tmr20en : 1; /* [20] */
1230 __IO uint32_t reserved6 : 8; /* [28:21] */
1231 __IO uint32_t accen : 1; /* [29] */
1232 __IO uint32_t reserved7 : 2; /* [31:30] */
1233 } apb2en_bit;
1234 };
1235
1239 __IO uint32_t reserved4[2];
1240
1244 union
1245 {
1246 __IO uint32_t ahblpen1;
1247#if defined (AT32F435xx)
1248 struct
1249 {
1250 __IO uint32_t gpioalpen : 1; /* [0] */
1251 __IO uint32_t gpioblpen : 1; /* [1] */
1252 __IO uint32_t gpioclpen : 1; /* [2] */
1253 __IO uint32_t gpiodlpen : 1; /* [3] */
1254 __IO uint32_t gpioelpen : 1; /* [4] */
1255 __IO uint32_t gpioflpen : 1; /* [5] */
1256 __IO uint32_t gpioglpen : 1; /* [6] */
1257 __IO uint32_t gpiohlpen : 1; /* [7] */
1258 __IO uint32_t reserved1 : 4; /* [11:8] */
1259 __IO uint32_t crclpen : 1; /* [12] */
1260 __IO uint32_t reserved2 : 8; /* [20:13] */
1261 __IO uint32_t edmalpen : 1; /* [21] */
1262 __IO uint32_t dma1lpen : 1; /* [22] */
1263 __IO uint32_t reserved3 : 1; /* [23] */
1264 __IO uint32_t dma2lpen : 1; /* [24] */
1265 __IO uint32_t reserved4 : 4; /* [28:25] */
1266 __IO uint32_t otgfs2lpen : 1; /* [29] */
1267 __IO uint32_t reserved5 : 2; /* [31:30] */
1268 } ahblpen1_bit;
1269#endif
1270
1271#if defined (AT32F437xx)
1272 struct
1273 {
1274 __IO uint32_t gpioalpen : 1; /* [0] */
1275 __IO uint32_t gpioblpen : 1; /* [1] */
1276 __IO uint32_t gpioclpen : 1; /* [2] */
1277 __IO uint32_t gpiodlpen : 1; /* [3] */
1278 __IO uint32_t gpioelpen : 1; /* [4] */
1279 __IO uint32_t gpioflpen : 1; /* [5] */
1280 __IO uint32_t gpioglpen : 1; /* [6] */
1281 __IO uint32_t gpiohlpen : 1; /* [7] */
1282 __IO uint32_t reserved1 : 4; /* [11:8] */
1283 __IO uint32_t crclpen : 1; /* [12] */
1284 __IO uint32_t reserved2 : 8; /* [20:13] */
1285 __IO uint32_t edmalpen : 1; /* [21] */
1286 __IO uint32_t dma1lpen : 1; /* [22] */
1287 __IO uint32_t reserved3 : 1; /* [23] */
1288 __IO uint32_t dma2lpen : 1; /* [24] */
1289 __IO uint32_t emaclpen : 1; /* [25] */
1290 __IO uint32_t reserved4 : 3; /* [28:26] */
1291 __IO uint32_t otgfs2lpen : 1; /* [29] */
1292 __IO uint32_t reserved5 : 2; /* [31:30] */
1293 } ahblpen1_bit;
1294#endif
1295 };
1296
1300 union
1301 {
1302 __IO uint32_t ahblpen2;
1303 struct
1304 {
1305 __IO uint32_t dvplpen : 1; /* [0] */
1306 __IO uint32_t reserved1 : 6; /* [6:1] */
1307 __IO uint32_t otgfs1lpen : 1; /* [7] */
1308 __IO uint32_t reserved2 : 7; /* [14:8] */
1309 __IO uint32_t sdio1lpen : 1; /* [15] */
1310 __IO uint32_t reserved3 : 16;/* [31:16] */
1311 } ahblpen2_bit;
1312 };
1313
1317 union
1318 {
1319 __IO uint32_t ahblpen3;
1320 struct
1321 {
1322 __IO uint32_t xmclpen : 1; /* [0] */
1323 __IO uint32_t qspi1lpen : 1; /* [1] */
1324 __IO uint32_t reserved1 : 12;/* [13:2] */
1325 __IO uint32_t qspi2lpen : 1; /* [14] */
1326 __IO uint32_t sdio2lpen : 1; /* [15] */
1327 __IO uint32_t reserved3 : 16;/* [31:16] */
1328 } ahblpen3_bit;
1329 };
1330
1334 __IO uint32_t reserved5;
1335
1339 union
1340 {
1341 __IO uint32_t apb1lpen;
1342 struct
1343 {
1344 __IO uint32_t tmr2lpen : 1; /* [0] */
1345 __IO uint32_t tmr3lpen : 1; /* [1] */
1346 __IO uint32_t tmr4lpen : 1; /* [2] */
1347 __IO uint32_t tmr5lpen : 1; /* [3] */
1348 __IO uint32_t tmr6lpen : 1; /* [4] */
1349 __IO uint32_t tmr7lpen : 1; /* [5] */
1350 __IO uint32_t tmr12lpen : 1; /* [6] */
1351 __IO uint32_t tmr13lpen : 1; /* [7] */
1352 __IO uint32_t adc14lpen : 1; /* [8] */
1353 __IO uint32_t reserved1 : 2; /* [10:9] */
1354 __IO uint32_t wwdtlpen : 1; /* [11] */
1355 __IO uint32_t reserved2 : 2; /* [13:12] */
1356 __IO uint32_t spi2lpen : 1; /* [14] */
1357 __IO uint32_t spi3lpen : 1; /* [15] */
1358 __IO uint32_t reserved3 : 1; /* [16] */
1359 __IO uint32_t usart2lpen : 1; /* [17] */
1360 __IO uint32_t usart3lpen : 1; /* [18] */
1361 __IO uint32_t uart4lpen : 1; /* [19] */
1362 __IO uint32_t uart5lpen : 1; /* [20] */
1363 __IO uint32_t i2c1lpen : 1; /* [21] */
1364 __IO uint32_t i2c2lpen : 1; /* [22] */
1365 __IO uint32_t i2c3lpen : 1; /* [23] */
1366 __IO uint32_t reserved4 : 1; /* [24] */
1367 __IO uint32_t can1lpen : 1; /* [25] */
1368 __IO uint32_t can2lpen : 1; /* [26] */
1369 __IO uint32_t reserved5 : 1; /* [27] */
1370 __IO uint32_t pwclpen : 1; /* [28] */
1371 __IO uint32_t daclpen : 1; /* [29] */
1372 __IO uint32_t uart7lpen : 1; /* [30] */
1373 __IO uint32_t uart8lpen : 1; /* [31] */
1374 } apb1lpen_bit;
1375 };
1376
1380 union
1381 {
1382 __IO uint32_t apb2lpen;
1383 struct
1384 {
1385 __IO uint32_t tmr1lpen : 1; /* [0] */
1386 __IO uint32_t tmr8lpen : 1; /* [1] */
1387 __IO uint32_t reserved1 : 2; /* [3:2] */
1388 __IO uint32_t usart1lpen : 1; /* [4] */
1389 __IO uint32_t usart6lpen : 1; /* [5] */
1390 __IO uint32_t reserved2 : 2; /* [7:6] */
1391 __IO uint32_t adclpen : 1; /* [8] */
1392 __IO uint32_t reserved3 : 3; /* [11:9] */
1393 __IO uint32_t spi1lpen : 1; /* [12] */
1394 __IO uint32_t spi4lpen : 1; /* [13] */
1395 __IO uint32_t scfglpen : 1; /* [14] */
1396 __IO uint32_t reserved4 : 1; /* [15] */
1397 __IO uint32_t tmr9lpen : 1; /* [16] */
1398 __IO uint32_t tmr10lpen : 1; /* [17] */
1399 __IO uint32_t tmr11lpen : 1; /* [18] */
1400 __IO uint32_t reserved5 : 1; /* [19] */
1401 __IO uint32_t tmr20lpen : 1; /* [20] */
1402 __IO uint32_t reserved6 : 8; /* [28:21] */
1403 __IO uint32_t acclpen : 1; /* [29] */
1404 __IO uint32_t reserved7 : 2; /* [31:30] */
1405 } apb2lpen_bit;
1406 };
1407
1411 __IO uint32_t reserved6[2];
1412
1416 union
1417 {
1418 __IO uint32_t bpdc;
1419 struct
1420 {
1421 __IO uint32_t lexten : 1; /* [0] */
1422 __IO uint32_t lextstbl : 1; /* [1] */
1423 __IO uint32_t lextbyps : 1; /* [2] */
1424 __IO uint32_t reserved1 : 5; /* [7:3] */
1425 __IO uint32_t ertcsel : 2; /* [9:8] */
1426 __IO uint32_t reserved2 : 5; /* [14:10] */
1427 __IO uint32_t ertcen : 1; /* [15] */
1428 __IO uint32_t bpdrst : 1; /* [16] */
1429 __IO uint32_t reserved3 : 15;/* [31:17] */
1430 } bpdc_bit;
1431 };
1432
1436 union
1437 {
1438 __IO uint32_t ctrlsts;
1439 struct
1440 {
1441 __IO uint32_t licken : 1; /* [0] */
1442 __IO uint32_t lickstbl : 1; /* [1] */
1443 __IO uint32_t reserved1 : 22;/* [23:2] */
1444 __IO uint32_t rstfc : 1; /* [24] */
1445 __IO uint32_t reserved2 : 1; /* [25] */
1446 __IO uint32_t nrstf : 1; /* [26] */
1447 __IO uint32_t porrstf : 1; /* [27] */
1448 __IO uint32_t swrstf : 1; /* [28] */
1449 __IO uint32_t wdtrstf : 1; /* [29] */
1450 __IO uint32_t wwdtrstf : 1; /* [30] */
1451 __IO uint32_t lprstf : 1; /* [31] */
1452 } ctrlsts_bit;
1453 };
1454
1458 __IO uint32_t reserved7[10];
1459
1463 union
1464 {
1465 __IO uint32_t misc1;
1466 struct
1467 {
1468 __IO uint32_t hickcal_key : 8; /* [7:0] */
1469 __IO uint32_t reserved1 : 4; /* [11:8] */
1470 __IO uint32_t hickdiv : 1; /* [12] */
1471 __IO uint32_t hick_to_usb : 1; /* [13] */
1472 __IO uint32_t hick_to_sclk : 1; /* [14] */
1473 __IO uint32_t reserved2 : 1; /* [15] */
1474 __IO uint32_t clkout2_sel2 : 4; /* [19:16] */
1475 __IO uint32_t reserved3 : 4; /* [23:20] */
1476 __IO uint32_t clkout1div2 : 4; /* [27:24] */
1477 __IO uint32_t clkout2div2 : 4; /* [31:28] */
1478 } misc1_bit;
1479 };
1480
1484 union
1485 {
1486 __IO uint32_t misc2;
1487 struct
1488 {
1489 __IO uint32_t reserved1 : 4; /* [3:0] */
1490 __IO uint32_t auto_step_en : 2; /* [5:4] */
1491 __IO uint32_t reserved2 : 2; /* [7:6] */
1492 __IO uint32_t clk_to_tmr : 1; /* [8] */
1493 __IO uint32_t emac_pps_sel : 1; /* [9] */
1494 __IO uint32_t reserved3 : 2; /* [11:10] */
1495 __IO uint32_t usbdiv : 4; /* [15:12] */
1496 __IO uint32_t reserved4 : 16;/* [31:16] */
1497 } misc2_bit;
1498 };
1499
1500} crm_type;
1501
1506#define CRM ((crm_type *) CRM_BASE)
1507
1512void crm_reset(void);
1513void crm_lext_bypass(confirm_state new_state);
1514void crm_hext_bypass(confirm_state new_state);
1515 flag_status crm_flag_get(uint32_t flag);
1516 error_status crm_hext_stable_wait(void);
1517void crm_hick_clock_trimming_set(uint8_t trim_value);
1518void crm_hick_clock_calibration_set(uint8_t cali_value);
1519void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state);
1520void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state);
1521void crm_periph_lowpower_mode_enable(crm_periph_clock_lowpower_type value, confirm_state new_state);
1522void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state);
1523void crm_flag_clear(uint32_t flag);
1524void crm_ertc_clock_select(crm_ertc_clock_type value);
1525void crm_ertc_clock_enable(confirm_state new_state);
1526void crm_ahb_div_set(crm_ahb_div_type value);
1527void crm_apb1_div_set(crm_apb1_div_type value);
1528void crm_apb2_div_set(crm_apb2_div_type value);
1529void crm_usb_clock_div_set(crm_usb_div_type value);
1530void crm_clock_failure_detection_enable(confirm_state new_state);
1531void crm_battery_powered_domain_reset(confirm_state new_state);
1532void crm_auto_step_mode_enable(confirm_state new_state);
1533void crm_hick_divider_select(crm_hick_div_6_type value);
1534void crm_hick_sclk_frequency_select(crm_hick_sclk_frequency_type value);
1535void crm_usb_clock_source_select(crm_usb_clock_source_type value);
1536void crm_clkout_to_tmr10_enable(confirm_state new_state);
1537void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, \
1538 uint16_t pll_ms, crm_pll_fr_type pll_fr);
1539void crm_sysclk_switch(crm_sclk_type value);
1540 crm_sclk_type crm_sysclk_switch_status_get(void);
1541void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct);
1542void crm_clock_out1_set(crm_clkout1_select_type clkout);
1543void crm_clock_out2_set(crm_clkout2_select_type clkout);
1544void crm_clkout_div_set(crm_clkout_index_type index, crm_clkout_div1_type div1, crm_clkout_div2_type div2);
1545void crm_emac_output_pulse_set(crm_emac_output_pulse_type width);
1546void crm_interrupt_enable(uint32_t crm_int, confirm_state new_state);
1547 error_status crm_pll_parameter_calculate(crm_pll_clock_source_type pll_rcs, uint32_t target_sclk_freq, \
1548 uint16_t *ret_ms, uint16_t *ret_ns, uint16_t *ret_fr);
1549
1562#ifdef __cplusplus
1563}
1564#endif
1565
1566#endif
at32f435_437.h
at32f435_437 header file
crm_clkout_div_set
void crm_clkout_div_set(crm_clkout_index_type index, crm_clkout_div1_type div1, crm_clkout_div2_type div2)
set crm clkout1 division1
Definition: at32f435_437_crm.c:831
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type value)
set usb division
Definition: at32f435_437_crm.c:521
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hick_clock_calibration_set
void crm_hick_clock_calibration_set(uint8_t cali_value)
set the crm calibration value
Definition: at32f435_437_crm.c:180
crm_pll_parameter_calculate
error_status crm_pll_parameter_calculate(crm_pll_clock_source_type pll_rcs, uint32_t target_sclk_freq, uint16_t *ret_ms, uint16_t *ret_ns, uint16_t *ret_fr)
calculate the pll parameters with pll reference clock and target pll output frequency....
Definition: at32f435_437_crm.c:904
crm_periph_lowpower_mode_enable
void crm_periph_lowpower_mode_enable(crm_periph_clock_lowpower_type value, confirm_state new_state)
enable or disable the peripheral clock in lowpower mode
Definition: at32f435_437_crm.c:288
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_clock_out1_set
void crm_clock_out1_set(crm_clkout1_select_type clkout)
set crm clkout1
Definition: at32f435_437_crm.c:773
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_interrupt_enable
void crm_interrupt_enable(uint32_t crm_int, confirm_state new_state)
config crm interrupt
Definition: at32f435_437_crm.c:870
crm_flag_clear
void crm_flag_clear(uint32_t flag)
clear the crm reset flags
Definition: at32f435_437_crm.c:358
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_lext_bypass
void crm_lext_bypass(confirm_state new_state)
enable or disable crm low speed external crystal bypass
Definition: at32f435_437_crm.c:85
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_ertc_clock_select
void crm_ertc_clock_select(crm_ertc_clock_type value)
select ertc clock
Definition: at32f435_437_crm.c:434
crm_hick_sclk_frequency_select
void crm_hick_sclk_frequency_select(crm_hick_sclk_frequency_type value)
hick as system clock frequency select
Definition: at32f435_437_crm.c:580
crm_hick_divider_select
void crm_hick_divider_select(crm_hick_div_6_type value)
config hick divider select
Definition: at32f435_437_crm.c:567
crm_emac_output_pulse_set
void crm_emac_output_pulse_set(crm_emac_output_pulse_type width)
set emac output pulse width
Definition: at32f435_437_crm.c:853
crm_clock_failure_detection_enable
void crm_clock_failure_detection_enable(confirm_state new_state)
enable or disable clock failure detection
Definition: at32f435_437_crm.c:531
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f435_437_crm.c:251
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_clkout_to_tmr10_enable
void crm_clkout_to_tmr10_enable(confirm_state new_state)
enable or disable clkout direct to tmr10 channel 1
Definition: at32f435_437_crm.c:608
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_clock_out2_set
void crm_clock_out2_set(crm_clkout2_select_type clkout)
set crm clkout2
Definition: at32f435_437_crm.c:792
crm_hick_clock_trimming_set
void crm_hick_clock_trimming_set(uint8_t trim_value)
set the hick trimming value
Definition: at32f435_437_crm.c:170
crm_ertc_clock_enable
void crm_ertc_clock_enable(confirm_state new_state)
enable or disable ertc
Definition: at32f435_437_crm.c:445
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
crm_battery_powered_domain_reset
void crm_battery_powered_domain_reset(confirm_state new_state)
battery powered domain software reset
Definition: at32f435_437_crm.c:541
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f435_437_crm.c:594
crm_hext_bypass
void crm_hext_bypass(confirm_state new_state)
enable or disable crm high speed external crystal bypass
Definition: at32f435_437_crm.c:95
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
crm_periph_clock_type
crm_periph_clock_type
crm periph clock
Definition: at32f435_437_crm.h:102
crm_hick_sclk_frequency_type
crm_hick_sclk_frequency_type
crm hick as system clock frequency select
Definition: at32f435_437_crm.h:770
crm_apb1_div_type
crm_apb1_div_type
crm apb1 division
Definition: at32f435_437_crm.h:586
crm_clock_source_type
crm_clock_source_type
crm clock source
Definition: at32f435_437_crm.h:558
crm_usb_div_type
crm_usb_div_type
crm usb division
Definition: at32f435_437_crm.h:610
crm_clkout_div1_type
crm_clkout_div1_type
crm clkout division1
Definition: at32f435_437_crm.h:724
crm_usb_clock_source_type
crm_usb_clock_source_type
crm usb 48 mhz clock source select
Definition: at32f435_437_crm.h:761
crm_emac_output_pulse_type
crm_emac_output_pulse_type
crm emac output pulse width
Definition: at32f435_437_crm.h:779
crm_pll_clock_source_type
crm_pll_clock_source_type
crm pll clock source
Definition: at32f435_437_crm.h:536
crm_clkout_div2_type
crm_clkout_div2_type
crm clkout division2
Definition: at32f435_437_crm.h:736
crm_ahb_div_type
crm_ahb_div_type
crm ahb division
Definition: at32f435_437_crm.h:570
crm_periph_clock_lowpower_type
crm_periph_clock_lowpower_type
crm periph clock in low power mode
Definition: at32f435_437_crm.h:389
crm_clkout1_select_type
crm_clkout1_select_type
crm clkout1 select
Definition: at32f435_437_crm.h:698
crm_auto_step_mode_type
crm_auto_step_mode_type
crm auto step mode
Definition: at32f435_437_crm.h:752
crm_sclk_type
crm_sclk_type
crm sclk select
Definition: at32f435_437_crm.h:679
crm_periph_reset_type
crm_periph_reset_type
crm periph reset
Definition: at32f435_437_crm.h:249
crm_apb2_div_type
crm_apb2_div_type
crm apb2 division
Definition: at32f435_437_crm.h:598
crm_ertc_clock_type
crm_ertc_clock_type
crm ertc clock
Definition: at32f435_437_crm.h:630
crm_pll_fr_type
crm_pll_fr_type
crm pll fr
Definition: at32f435_437_crm.h:545
crm_clkout_index_type
crm_clkout_index_type
crm clkout index
Definition: at32f435_437_crm.h:689
crm_hick_div_6_type
crm_hick_div_6_type
crm hick 48mhz division
Definition: at32f435_437_crm.h:670
crm_clkout2_select_type
crm_clkout2_select_type
crm clkout2 select
Definition: at32f435_437_crm.h:709
CRM_SDIO1_PERIPH_CLOCK
@ CRM_SDIO1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:121
CRM_TMR10_PERIPH_CLOCK
@ CRM_TMR10_PERIPH_CLOCK
Definition: at32f435_437_crm.h:165
CRM_TMR6_PERIPH_CLOCK
@ CRM_TMR6_PERIPH_CLOCK
Definition: at32f435_437_crm.h:132
CRM_UART7_PERIPH_CLOCK
@ CRM_UART7_PERIPH_CLOCK
Definition: at32f435_437_crm.h:151
CRM_DAC_PERIPH_CLOCK
@ CRM_DAC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:150
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_XMC_PERIPH_CLOCK
@ CRM_XMC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:123
CRM_GPIOF_PERIPH_CLOCK
@ CRM_GPIOF_PERIPH_CLOCK
Definition: at32f435_437_crm.h:110
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_UART5_PERIPH_CLOCK
@ CRM_UART5_PERIPH_CLOCK
Definition: at32f435_437_crm.h:143
CRM_OTGFS1_PERIPH_CLOCK
@ CRM_OTGFS1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:120
CRM_TMR14_PERIPH_CLOCK
@ CRM_TMR14_PERIPH_CLOCK
Definition: at32f435_437_crm.h:136
CRM_SCFG_PERIPH_CLOCK
@ CRM_SCFG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:163
CRM_SPI4_PERIPH_CLOCK
@ CRM_SPI4_PERIPH_CLOCK
Definition: at32f435_437_crm.h:162
CRM_TMR13_PERIPH_CLOCK
@ CRM_TMR13_PERIPH_CLOCK
Definition: at32f435_437_crm.h:135
CRM_SPI3_PERIPH_CLOCK
@ CRM_SPI3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:139
CRM_EDMA_PERIPH_CLOCK
@ CRM_EDMA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:114
CRM_TMR20_PERIPH_CLOCK
@ CRM_TMR20_PERIPH_CLOCK
Definition: at32f435_437_crm.h:167
CRM_OTGFS2_PERIPH_CLOCK
@ CRM_OTGFS2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:117
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_TMR9_PERIPH_CLOCK
@ CRM_TMR9_PERIPH_CLOCK
Definition: at32f435_437_crm.h:164
CRM_USART3_PERIPH_CLOCK
@ CRM_USART3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:141
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:128
CRM_I2C1_PERIPH_CLOCK
@ CRM_I2C1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:144
CRM_TMR4_PERIPH_CLOCK
@ CRM_TMR4_PERIPH_CLOCK
Definition: at32f435_437_crm.h:130
CRM_GPIOH_PERIPH_CLOCK
@ CRM_GPIOH_PERIPH_CLOCK
Definition: at32f435_437_crm.h:112
CRM_UART8_PERIPH_CLOCK
@ CRM_UART8_PERIPH_CLOCK
Definition: at32f435_437_crm.h:152
CRM_USART6_PERIPH_CLOCK
@ CRM_USART6_PERIPH_CLOCK
Definition: at32f435_437_crm.h:157
CRM_TMR12_PERIPH_CLOCK
@ CRM_TMR12_PERIPH_CLOCK
Definition: at32f435_437_crm.h:134
CRM_GPIOG_PERIPH_CLOCK
@ CRM_GPIOG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:111
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:138
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:168
CRM_CRC_PERIPH_CLOCK
@ CRM_CRC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:113
CRM_SDIO2_PERIPH_CLOCK
@ CRM_SDIO2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:126
CRM_I2C3_PERIPH_CLOCK
@ CRM_I2C3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:146
CRM_QSPI2_PERIPH_CLOCK
@ CRM_QSPI2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:125
CRM_DVP_PERIPH_CLOCK
@ CRM_DVP_PERIPH_CLOCK
Definition: at32f435_437_crm.h:119
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:129
CRM_QSPI1_PERIPH_CLOCK
@ CRM_QSPI1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:124
CRM_TMR8_PERIPH_CLOCK
@ CRM_TMR8_PERIPH_CLOCK
Definition: at32f435_437_crm.h:155
CRM_TMR7_PERIPH_CLOCK
@ CRM_TMR7_PERIPH_CLOCK
Definition: at32f435_437_crm.h:133
CRM_USART1_PERIPH_CLOCK
@ CRM_USART1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:156
CRM_ADC3_PERIPH_CLOCK
@ CRM_ADC3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:160
CRM_UART4_PERIPH_CLOCK
@ CRM_UART4_PERIPH_CLOCK
Definition: at32f435_437_crm.h:142
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:161
CRM_CAN1_PERIPH_CLOCK
@ CRM_CAN1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:147
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:158
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
CRM_CAN2_PERIPH_CLOCK
@ CRM_CAN2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:148
CRM_I2C2_PERIPH_CLOCK
@ CRM_I2C2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:145
CRM_DMA2_PERIPH_CLOCK
@ CRM_DMA2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:116
CRM_TMR5_PERIPH_CLOCK
@ CRM_TMR5_PERIPH_CLOCK
Definition: at32f435_437_crm.h:131
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:140
CRM_TMR11_PERIPH_CLOCK
@ CRM_TMR11_PERIPH_CLOCK
Definition: at32f435_437_crm.h:166
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:154
CRM_WWDT_PERIPH_CLOCK
@ CRM_WWDT_PERIPH_CLOCK
Definition: at32f435_437_crm.h:137
CRM_ADC2_PERIPH_CLOCK
@ CRM_ADC2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:159
CRM_HICK_SCLK_48MHZ
@ CRM_HICK_SCLK_48MHZ
Definition: at32f435_437_crm.h:772
CRM_HICK_SCLK_8MHZ
@ CRM_HICK_SCLK_8MHZ
Definition: at32f435_437_crm.h:771
CRM_APB1_DIV_8
@ CRM_APB1_DIV_8
Definition: at32f435_437_crm.h:590
CRM_APB1_DIV_4
@ CRM_APB1_DIV_4
Definition: at32f435_437_crm.h:589
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_APB1_DIV_16
@ CRM_APB1_DIV_16
Definition: at32f435_437_crm.h:591
CRM_APB1_DIV_1
@ CRM_APB1_DIV_1
Definition: at32f435_437_crm.h:587
CRM_CLOCK_SOURCE_HICK
@ CRM_CLOCK_SOURCE_HICK
Definition: at32f435_437_crm.h:559
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_LEXT
@ CRM_CLOCK_SOURCE_LEXT
Definition: at32f435_437_crm.h:562
CRM_CLOCK_SOURCE_LICK
@ CRM_CLOCK_SOURCE_LICK
Definition: at32f435_437_crm.h:563
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_USB_DIV_5
@ CRM_USB_DIV_5
Definition: at32f435_437_crm.h:620
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f435_437_crm.h:616
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f435_437_crm.h:611
CRM_USB_DIV_7
@ CRM_USB_DIV_7
Definition: at32f435_437_crm.h:623
CRM_USB_DIV_5_5
@ CRM_USB_DIV_5_5
Definition: at32f435_437_crm.h:619
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f435_437_crm.h:618
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f435_437_crm.h:615
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f435_437_crm.h:614
CRM_USB_DIV_6
@ CRM_USB_DIV_6
Definition: at32f435_437_crm.h:622
CRM_USB_DIV_4_5
@ CRM_USB_DIV_4_5
Definition: at32f435_437_crm.h:617
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f435_437_crm.h:612
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f435_437_crm.h:613
CRM_USB_DIV_6_5
@ CRM_USB_DIV_6_5
Definition: at32f435_437_crm.h:621
CRM_CLKOUT_DIV1_1
@ CRM_CLKOUT_DIV1_1
Definition: at32f435_437_crm.h:725
CRM_CLKOUT_DIV1_2
@ CRM_CLKOUT_DIV1_2
Definition: at32f435_437_crm.h:726
CRM_CLKOUT_DIV1_3
@ CRM_CLKOUT_DIV1_3
Definition: at32f435_437_crm.h:727
CRM_CLKOUT_DIV1_4
@ CRM_CLKOUT_DIV1_4
Definition: at32f435_437_crm.h:728
CRM_CLKOUT_DIV1_5
@ CRM_CLKOUT_DIV1_5
Definition: at32f435_437_crm.h:729
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f435_437_crm.h:763
CRM_USB_CLOCK_SOURCE_PLL
@ CRM_USB_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:762
CRM_EMAC_PULSE_125MS
@ CRM_EMAC_PULSE_125MS
Definition: at32f435_437_crm.h:780
CRM_EMAC_PULSE_1SCLK
@ CRM_EMAC_PULSE_1SCLK
Definition: at32f435_437_crm.h:781
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_PLL_SOURCE_HICK
@ CRM_PLL_SOURCE_HICK
Definition: at32f435_437_crm.h:537
CRM_CLKOUT_DIV2_2
@ CRM_CLKOUT_DIV2_2
Definition: at32f435_437_crm.h:738
CRM_CLKOUT_DIV2_1
@ CRM_CLKOUT_DIV2_1
Definition: at32f435_437_crm.h:737
CRM_CLKOUT_DIV2_16
@ CRM_CLKOUT_DIV2_16
Definition: at32f435_437_crm.h:741
CRM_CLKOUT_DIV2_64
@ CRM_CLKOUT_DIV2_64
Definition: at32f435_437_crm.h:742
CRM_CLKOUT_DIV2_256
@ CRM_CLKOUT_DIV2_256
Definition: at32f435_437_crm.h:744
CRM_CLKOUT_DIV2_4
@ CRM_CLKOUT_DIV2_4
Definition: at32f435_437_crm.h:739
CRM_CLKOUT_DIV2_8
@ CRM_CLKOUT_DIV2_8
Definition: at32f435_437_crm.h:740
CRM_CLKOUT_DIV2_512
@ CRM_CLKOUT_DIV2_512
Definition: at32f435_437_crm.h:745
CRM_CLKOUT_DIV2_128
@ CRM_CLKOUT_DIV2_128
Definition: at32f435_437_crm.h:743
CRM_AHB_DIV_4
@ CRM_AHB_DIV_4
Definition: at32f435_437_crm.h:573
CRM_AHB_DIV_16
@ CRM_AHB_DIV_16
Definition: at32f435_437_crm.h:575
CRM_AHB_DIV_64
@ CRM_AHB_DIV_64
Definition: at32f435_437_crm.h:576
CRM_AHB_DIV_8
@ CRM_AHB_DIV_8
Definition: at32f435_437_crm.h:574
CRM_AHB_DIV_512
@ CRM_AHB_DIV_512
Definition: at32f435_437_crm.h:579
CRM_AHB_DIV_128
@ CRM_AHB_DIV_128
Definition: at32f435_437_crm.h:577
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_AHB_DIV_256
@ CRM_AHB_DIV_256
Definition: at32f435_437_crm.h:578
CRM_AHB_DIV_2
@ CRM_AHB_DIV_2
Definition: at32f435_437_crm.h:572
CRM_GPIOH_PERIPH_LOWPOWER
@ CRM_GPIOH_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:399
CRM_SPI1_PERIPH_LOWPOWER
@ CRM_SPI1_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:452
CRM_SDIO1_PERIPH_LOWPOWER
@ CRM_SDIO1_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:412
CRM_TMR5_PERIPH_LOWPOWER
@ CRM_TMR5_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:422
CRM_SPI3_PERIPH_LOWPOWER
@ CRM_SPI3_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:430
CRM_XMC_PERIPH_LOWPOWER
@ CRM_XMC_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:414
CRM_GPIOA_PERIPH_LOWPOWER
@ CRM_GPIOA_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:392
CRM_TMR2_PERIPH_LOWPOWER
@ CRM_TMR2_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:419
CRM_I2C3_PERIPH_LOWPOWER
@ CRM_I2C3_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:437
CRM_ADC2_PERIPH_LOWPOWER
@ CRM_ADC2_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:450
CRM_UART7_PERIPH_LOWPOWER
@ CRM_UART7_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:442
CRM_USART3_PERIPH_LOWPOWER
@ CRM_USART3_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:432
CRM_WWDT_PERIPH_LOWPOWER
@ CRM_WWDT_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:428
CRM_TMR6_PERIPH_LOWPOWER
@ CRM_TMR6_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:423
CRM_CAN2_PERIPH_LOWPOWER
@ CRM_CAN2_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:439
CRM_TMR3_PERIPH_LOWPOWER
@ CRM_TMR3_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:420
CRM_GPIOB_PERIPH_LOWPOWER
@ CRM_GPIOB_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:393
CRM_UART4_PERIPH_LOWPOWER
@ CRM_UART4_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:433
CRM_GPIOE_PERIPH_LOWPOWER
@ CRM_GPIOE_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:396
CRM_TMR7_PERIPH_LOWPOWER
@ CRM_TMR7_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:424
CRM_DMA1_PERIPH_LOWPOWER
@ CRM_DMA1_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:402
CRM_EMACTX_PERIPH_LOWPOWER
@ CRM_EMACTX_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:405
CRM_GPIOD_PERIPH_LOWPOWER
@ CRM_GPIOD_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:395
CRM_EMAC_PERIPH_LOWPOWER
@ CRM_EMAC_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:404
CRM_TMR8_PERIPH_LOWPOWER
@ CRM_TMR8_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:446
CRM_ADC1_PERIPH_LOWPOWER
@ CRM_ADC1_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:449
CRM_CAN1_PERIPH_LOWPOWER
@ CRM_CAN1_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:438
CRM_SDIO2_PERIPH_LOWPOWER
@ CRM_SDIO2_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:417
CRM_ACC_PERIPH_LOWPOWER
@ CRM_ACC_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:459
CRM_CRC_PERIPH_LOWPOWER
@ CRM_CRC_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:400
CRM_EDMA_PERIPH_LOWPOWER
@ CRM_EDMA_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:401
CRM_QSPI2_PERIPH_LOWPOWER
@ CRM_QSPI2_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:416
CRM_ADC3_PERIPH_LOWPOWER
@ CRM_ADC3_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:451
CRM_SPI4_PERIPH_LOWPOWER
@ CRM_SPI4_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:453
CRM_GPIOC_PERIPH_LOWPOWER
@ CRM_GPIOC_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:394
CRM_TMR20_PERIPH_LOWPOWER
@ CRM_TMR20_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:458
CRM_GPIOG_PERIPH_LOWPOWER
@ CRM_GPIOG_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:398
CRM_DAC_PERIPH_LOWPOWER
@ CRM_DAC_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:441
CRM_USART6_PERIPH_LOWPOWER
@ CRM_USART6_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:448
CRM_TMR10_PERIPH_LOWPOWER
@ CRM_TMR10_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:456
CRM_EMACRX_PERIPH_LOWPOWER
@ CRM_EMACRX_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:406
CRM_OTGFS1_PERIPH_LOWPOWER
@ CRM_OTGFS1_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:411
CRM_DMA2_PERIPH_LOWPOWER
@ CRM_DMA2_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:403
CRM_UART8_PERIPH_LOWPOWER
@ CRM_UART8_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:443
CRM_UART5_PERIPH_LOWPOWER
@ CRM_UART5_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:434
CRM_QSPI1_PERIPH_LOWPOWER
@ CRM_QSPI1_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:415
CRM_DVP_PERIPH_LOWPOWER
@ CRM_DVP_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:410
CRM_GPIOF_PERIPH_LOWPOWER
@ CRM_GPIOF_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:397
CRM_SCFG_PERIPH_LOWPOWER
@ CRM_SCFG_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:454
CRM_TMR13_PERIPH_LOWPOWER
@ CRM_TMR13_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:426
CRM_I2C1_PERIPH_LOWPOWER
@ CRM_I2C1_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:435
CRM_TMR4_PERIPH_LOWPOWER
@ CRM_TMR4_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:421
CRM_USART2_PERIPH_LOWPOWER
@ CRM_USART2_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:431
CRM_OTGFS2_PERIPH_LOWPOWER
@ CRM_OTGFS2_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:408
CRM_TMR1_PERIPH_LOWPOWER
@ CRM_TMR1_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:445
CRM_TMR12_PERIPH_LOWPOWER
@ CRM_TMR12_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:425
CRM_TMR14_PERIPH_LOWPOWER
@ CRM_TMR14_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:427
CRM_USART1_PERIPH_LOWPOWER
@ CRM_USART1_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:447
CRM_I2C2_PERIPH_LOWPOWER
@ CRM_I2C2_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:436
CRM_TMR11_PERIPH_LOWPOWER
@ CRM_TMR11_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:457
CRM_PWC_PERIPH_LOWPOWER
@ CRM_PWC_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:440
CRM_EMACPTP_PERIPH_LOWPOWER
@ CRM_EMACPTP_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:407
CRM_TMR9_PERIPH_LOWPOWER
@ CRM_TMR9_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:455
CRM_SPI2_PERIPH_LOWPOWER
@ CRM_SPI2_PERIPH_LOWPOWER
Definition: at32f435_437_crm.h:429
CRM_CLKOUT1_HICK
@ CRM_CLKOUT1_HICK
Definition: at32f435_437_crm.h:699
CRM_CLKOUT1_LEXT
@ CRM_CLKOUT1_LEXT
Definition: at32f435_437_crm.h:700
CRM_CLKOUT1_HEXT
@ CRM_CLKOUT1_HEXT
Definition: at32f435_437_crm.h:701
CRM_CLKOUT1_PLL
@ CRM_CLKOUT1_PLL
Definition: at32f435_437_crm.h:702
CRM_AUTO_STEP_MODE_ENABLE
@ CRM_AUTO_STEP_MODE_ENABLE
Definition: at32f435_437_crm.h:754
CRM_AUTO_STEP_MODE_DISABLE
@ CRM_AUTO_STEP_MODE_DISABLE
Definition: at32f435_437_crm.h:753
CRM_SCLK_HICK
@ CRM_SCLK_HICK
Definition: at32f435_437_crm.h:680
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_SCLK_HEXT
@ CRM_SCLK_HEXT
Definition: at32f435_437_crm.h:681
CRM_EDMA_PERIPH_RESET
@ CRM_EDMA_PERIPH_RESET
Definition: at32f435_437_crm.h:261
CRM_DAC_PERIPH_RESET
@ CRM_DAC_PERIPH_RESET
Definition: at32f435_437_crm.h:297
CRM_TMR2_PERIPH_RESET
@ CRM_TMR2_PERIPH_RESET
Definition: at32f435_437_crm.h:275
CRM_TMR4_PERIPH_RESET
@ CRM_TMR4_PERIPH_RESET
Definition: at32f435_437_crm.h:277
CRM_DMA2_PERIPH_RESET
@ CRM_DMA2_PERIPH_RESET
Definition: at32f435_437_crm.h:263
CRM_SPI1_PERIPH_RESET
@ CRM_SPI1_PERIPH_RESET
Definition: at32f435_437_crm.h:306
CRM_SPI3_PERIPH_RESET
@ CRM_SPI3_PERIPH_RESET
Definition: at32f435_437_crm.h:286
CRM_I2C3_PERIPH_RESET
@ CRM_I2C3_PERIPH_RESET
Definition: at32f435_437_crm.h:293
CRM_TMR10_PERIPH_RESET
@ CRM_TMR10_PERIPH_RESET
Definition: at32f435_437_crm.h:310
CRM_GPIOH_PERIPH_RESET
@ CRM_GPIOH_PERIPH_RESET
Definition: at32f435_437_crm.h:259
CRM_CRC_PERIPH_RESET
@ CRM_CRC_PERIPH_RESET
Definition: at32f435_437_crm.h:260
CRM_TMR13_PERIPH_RESET
@ CRM_TMR13_PERIPH_RESET
Definition: at32f435_437_crm.h:282
CRM_I2C2_PERIPH_RESET
@ CRM_I2C2_PERIPH_RESET
Definition: at32f435_437_crm.h:292
CRM_SDIO2_PERIPH_RESET
@ CRM_SDIO2_PERIPH_RESET
Definition: at32f435_437_crm.h:273
CRM_DMA1_PERIPH_RESET
@ CRM_DMA1_PERIPH_RESET
Definition: at32f435_437_crm.h:262
CRM_TMR20_PERIPH_RESET
@ CRM_TMR20_PERIPH_RESET
Definition: at32f435_437_crm.h:312
CRM_UART4_PERIPH_RESET
@ CRM_UART4_PERIPH_RESET
Definition: at32f435_437_crm.h:289
CRM_TMR14_PERIPH_RESET
@ CRM_TMR14_PERIPH_RESET
Definition: at32f435_437_crm.h:283
CRM_XMC_PERIPH_RESET
@ CRM_XMC_PERIPH_RESET
Definition: at32f435_437_crm.h:270
CRM_USART1_PERIPH_RESET
@ CRM_USART1_PERIPH_RESET
Definition: at32f435_437_crm.h:303
CRM_DVP_PERIPH_RESET
@ CRM_DVP_PERIPH_RESET
Definition: at32f435_437_crm.h:266
CRM_UART7_PERIPH_RESET
@ CRM_UART7_PERIPH_RESET
Definition: at32f435_437_crm.h:298
CRM_ADC_PERIPH_RESET
@ CRM_ADC_PERIPH_RESET
Definition: at32f435_437_crm.h:305
CRM_OTGFS1_PERIPH_RESET
@ CRM_OTGFS1_PERIPH_RESET
Definition: at32f435_437_crm.h:267
CRM_GPIOE_PERIPH_RESET
@ CRM_GPIOE_PERIPH_RESET
Definition: at32f435_437_crm.h:256
CRM_UART8_PERIPH_RESET
@ CRM_UART8_PERIPH_RESET
Definition: at32f435_437_crm.h:299
CRM_CAN1_PERIPH_RESET
@ CRM_CAN1_PERIPH_RESET
Definition: at32f435_437_crm.h:294
CRM_TMR5_PERIPH_RESET
@ CRM_TMR5_PERIPH_RESET
Definition: at32f435_437_crm.h:278
CRM_SCFG_PERIPH_RESET
@ CRM_SCFG_PERIPH_RESET
Definition: at32f435_437_crm.h:308
CRM_TMR9_PERIPH_RESET
@ CRM_TMR9_PERIPH_RESET
Definition: at32f435_437_crm.h:309
CRM_GPIOF_PERIPH_RESET
@ CRM_GPIOF_PERIPH_RESET
Definition: at32f435_437_crm.h:257
CRM_TMR1_PERIPH_RESET
@ CRM_TMR1_PERIPH_RESET
Definition: at32f435_437_crm.h:301
CRM_GPIOD_PERIPH_RESET
@ CRM_GPIOD_PERIPH_RESET
Definition: at32f435_437_crm.h:255
CRM_USART2_PERIPH_RESET
@ CRM_USART2_PERIPH_RESET
Definition: at32f435_437_crm.h:287
CRM_GPIOC_PERIPH_RESET
@ CRM_GPIOC_PERIPH_RESET
Definition: at32f435_437_crm.h:254
CRM_CAN2_PERIPH_RESET
@ CRM_CAN2_PERIPH_RESET
Definition: at32f435_437_crm.h:295
CRM_ACC_PERIPH_RESET
@ CRM_ACC_PERIPH_RESET
Definition: at32f435_437_crm.h:313
CRM_SPI4_PERIPH_RESET
@ CRM_SPI4_PERIPH_RESET
Definition: at32f435_437_crm.h:307
CRM_GPIOG_PERIPH_RESET
@ CRM_GPIOG_PERIPH_RESET
Definition: at32f435_437_crm.h:258
CRM_TMR8_PERIPH_RESET
@ CRM_TMR8_PERIPH_RESET
Definition: at32f435_437_crm.h:302
CRM_WWDT_PERIPH_RESET
@ CRM_WWDT_PERIPH_RESET
Definition: at32f435_437_crm.h:284
CRM_UART5_PERIPH_RESET
@ CRM_UART5_PERIPH_RESET
Definition: at32f435_437_crm.h:290
CRM_OTGFS2_PERIPH_RESET
@ CRM_OTGFS2_PERIPH_RESET
Definition: at32f435_437_crm.h:264
CRM_TMR3_PERIPH_RESET
@ CRM_TMR3_PERIPH_RESET
Definition: at32f435_437_crm.h:276
CRM_TMR7_PERIPH_RESET
@ CRM_TMR7_PERIPH_RESET
Definition: at32f435_437_crm.h:280
CRM_SDIO1_PERIPH_RESET
@ CRM_SDIO1_PERIPH_RESET
Definition: at32f435_437_crm.h:268
CRM_SPI2_PERIPH_RESET
@ CRM_SPI2_PERIPH_RESET
Definition: at32f435_437_crm.h:285
CRM_USART6_PERIPH_RESET
@ CRM_USART6_PERIPH_RESET
Definition: at32f435_437_crm.h:304
CRM_TMR12_PERIPH_RESET
@ CRM_TMR12_PERIPH_RESET
Definition: at32f435_437_crm.h:281
CRM_PWC_PERIPH_RESET
@ CRM_PWC_PERIPH_RESET
Definition: at32f435_437_crm.h:296
CRM_GPIOA_PERIPH_RESET
@ CRM_GPIOA_PERIPH_RESET
Definition: at32f435_437_crm.h:252
CRM_QSPI1_PERIPH_RESET
@ CRM_QSPI1_PERIPH_RESET
Definition: at32f435_437_crm.h:271
CRM_TMR11_PERIPH_RESET
@ CRM_TMR11_PERIPH_RESET
Definition: at32f435_437_crm.h:311
CRM_QSPI2_PERIPH_RESET
@ CRM_QSPI2_PERIPH_RESET
Definition: at32f435_437_crm.h:272
CRM_USART3_PERIPH_RESET
@ CRM_USART3_PERIPH_RESET
Definition: at32f435_437_crm.h:288
CRM_GPIOB_PERIPH_RESET
@ CRM_GPIOB_PERIPH_RESET
Definition: at32f435_437_crm.h:253
CRM_I2C1_PERIPH_RESET
@ CRM_I2C1_PERIPH_RESET
Definition: at32f435_437_crm.h:291
CRM_TMR6_PERIPH_RESET
@ CRM_TMR6_PERIPH_RESET
Definition: at32f435_437_crm.h:279
CRM_APB2_DIV_4
@ CRM_APB2_DIV_4
Definition: at32f435_437_crm.h:601
CRM_APB2_DIV_1
@ CRM_APB2_DIV_1
Definition: at32f435_437_crm.h:599
CRM_APB2_DIV_16
@ CRM_APB2_DIV_16
Definition: at32f435_437_crm.h:603
CRM_APB2_DIV_8
@ CRM_APB2_DIV_8
Definition: at32f435_437_crm.h:602
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_ERTC_CLOCK_HEXT_DIV_26
@ CRM_ERTC_CLOCK_HEXT_DIV_26
Definition: at32f435_437_crm.h:658
CRM_ERTC_CLOCK_HEXT_DIV_30
@ CRM_ERTC_CLOCK_HEXT_DIV_30
Definition: at32f435_437_crm.h:662
CRM_ERTC_CLOCK_HEXT_DIV_22
@ CRM_ERTC_CLOCK_HEXT_DIV_22
Definition: at32f435_437_crm.h:654
CRM_ERTC_CLOCK_HEXT_DIV_15
@ CRM_ERTC_CLOCK_HEXT_DIV_15
Definition: at32f435_437_crm.h:647
CRM_ERTC_CLOCK_LICK
@ CRM_ERTC_CLOCK_LICK
Definition: at32f435_437_crm.h:633
CRM_ERTC_CLOCK_HEXT_DIV_16
@ CRM_ERTC_CLOCK_HEXT_DIV_16
Definition: at32f435_437_crm.h:648
CRM_ERTC_CLOCK_HEXT_DIV_25
@ CRM_ERTC_CLOCK_HEXT_DIV_25
Definition: at32f435_437_crm.h:657
CRM_ERTC_CLOCK_HEXT_DIV_6
@ CRM_ERTC_CLOCK_HEXT_DIV_6
Definition: at32f435_437_crm.h:638
CRM_ERTC_CLOCK_HEXT_DIV_21
@ CRM_ERTC_CLOCK_HEXT_DIV_21
Definition: at32f435_437_crm.h:653
CRM_ERTC_CLOCK_HEXT_DIV_27
@ CRM_ERTC_CLOCK_HEXT_DIV_27
Definition: at32f435_437_crm.h:659
CRM_ERTC_CLOCK_HEXT_DIV_10
@ CRM_ERTC_CLOCK_HEXT_DIV_10
Definition: at32f435_437_crm.h:642
CRM_ERTC_CLOCK_HEXT_DIV_7
@ CRM_ERTC_CLOCK_HEXT_DIV_7
Definition: at32f435_437_crm.h:639
CRM_ERTC_CLOCK_HEXT_DIV_18
@ CRM_ERTC_CLOCK_HEXT_DIV_18
Definition: at32f435_437_crm.h:650
CRM_ERTC_CLOCK_HEXT_DIV_3
@ CRM_ERTC_CLOCK_HEXT_DIV_3
Definition: at32f435_437_crm.h:635
CRM_ERTC_CLOCK_LEXT
@ CRM_ERTC_CLOCK_LEXT
Definition: at32f435_437_crm.h:632
CRM_ERTC_CLOCK_HEXT_DIV_14
@ CRM_ERTC_CLOCK_HEXT_DIV_14
Definition: at32f435_437_crm.h:646
CRM_ERTC_CLOCK_HEXT_DIV_2
@ CRM_ERTC_CLOCK_HEXT_DIV_2
Definition: at32f435_437_crm.h:634
CRM_ERTC_CLOCK_HEXT_DIV_31
@ CRM_ERTC_CLOCK_HEXT_DIV_31
Definition: at32f435_437_crm.h:663
CRM_ERTC_CLOCK_HEXT_DIV_17
@ CRM_ERTC_CLOCK_HEXT_DIV_17
Definition: at32f435_437_crm.h:649
CRM_ERTC_CLOCK_HEXT_DIV_24
@ CRM_ERTC_CLOCK_HEXT_DIV_24
Definition: at32f435_437_crm.h:656
CRM_ERTC_CLOCK_HEXT_DIV_28
@ CRM_ERTC_CLOCK_HEXT_DIV_28
Definition: at32f435_437_crm.h:660
CRM_ERTC_CLOCK_HEXT_DIV_4
@ CRM_ERTC_CLOCK_HEXT_DIV_4
Definition: at32f435_437_crm.h:636
CRM_ERTC_CLOCK_NOCLK
@ CRM_ERTC_CLOCK_NOCLK
Definition: at32f435_437_crm.h:631
CRM_ERTC_CLOCK_HEXT_DIV_8
@ CRM_ERTC_CLOCK_HEXT_DIV_8
Definition: at32f435_437_crm.h:640
CRM_ERTC_CLOCK_HEXT_DIV_20
@ CRM_ERTC_CLOCK_HEXT_DIV_20
Definition: at32f435_437_crm.h:652
CRM_ERTC_CLOCK_HEXT_DIV_23
@ CRM_ERTC_CLOCK_HEXT_DIV_23
Definition: at32f435_437_crm.h:655
CRM_ERTC_CLOCK_HEXT_DIV_12
@ CRM_ERTC_CLOCK_HEXT_DIV_12
Definition: at32f435_437_crm.h:644
CRM_ERTC_CLOCK_HEXT_DIV_19
@ CRM_ERTC_CLOCK_HEXT_DIV_19
Definition: at32f435_437_crm.h:651
CRM_ERTC_CLOCK_HEXT_DIV_11
@ CRM_ERTC_CLOCK_HEXT_DIV_11
Definition: at32f435_437_crm.h:643
CRM_ERTC_CLOCK_HEXT_DIV_5
@ CRM_ERTC_CLOCK_HEXT_DIV_5
Definition: at32f435_437_crm.h:637
CRM_ERTC_CLOCK_HEXT_DIV_9
@ CRM_ERTC_CLOCK_HEXT_DIV_9
Definition: at32f435_437_crm.h:641
CRM_ERTC_CLOCK_HEXT_DIV_29
@ CRM_ERTC_CLOCK_HEXT_DIV_29
Definition: at32f435_437_crm.h:661
CRM_ERTC_CLOCK_HEXT_DIV_13
@ CRM_ERTC_CLOCK_HEXT_DIV_13
Definition: at32f435_437_crm.h:645
CRM_PLL_FR_32
@ CRM_PLL_FR_32
Definition: at32f435_437_crm.h:551
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_FR_16
@ CRM_PLL_FR_16
Definition: at32f435_437_crm.h:550
CRM_PLL_FR_4
@ CRM_PLL_FR_4
Definition: at32f435_437_crm.h:548
CRM_PLL_FR_8
@ CRM_PLL_FR_8
Definition: at32f435_437_crm.h:549
CRM_PLL_FR_1
@ CRM_PLL_FR_1
Definition: at32f435_437_crm.h:546
CRM_CLKOUT_INDEX_2
@ CRM_CLKOUT_INDEX_2
Definition: at32f435_437_crm.h:691
CRM_CLKOUT_INDEX_1
@ CRM_CLKOUT_INDEX_1
Definition: at32f435_437_crm.h:690
CRM_HICK48_NODIV
@ CRM_HICK48_NODIV
Definition: at32f435_437_crm.h:672
CRM_HICK48_DIV6
@ CRM_HICK48_DIV6
Definition: at32f435_437_crm.h:671
CRM_CLKOUT2_LEXT
@ CRM_CLKOUT2_LEXT
Definition: at32f435_437_crm.h:717
CRM_CLKOUT2_LICK
@ CRM_CLKOUT2_LICK
Definition: at32f435_437_crm.h:716
CRM_CLKOUT2_HEXT
@ CRM_CLKOUT2_HEXT
Definition: at32f435_437_crm.h:711
CRM_CLKOUT2_ADC
@ CRM_CLKOUT2_ADC
Definition: at32f435_437_crm.h:714
CRM_CLKOUT2_HICK
@ CRM_CLKOUT2_HICK
Definition: at32f435_437_crm.h:715
CRM_CLKOUT2_SCLK
@ CRM_CLKOUT2_SCLK
Definition: at32f435_437_crm.h:710
CRM_CLKOUT2_PLL
@ CRM_CLKOUT2_PLL
Definition: at32f435_437_crm.h:712
CRM_CLKOUT2_USB
@ CRM_CLKOUT2_USB
Definition: at32f435_437_crm.h:713
MAKE_VALUE
#define MAKE_VALUE(reg_offset, bit_num)
Definition: at32f435_437.h:394
error_status
error_status
Definition: at32f435_437.h:380
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f435_437_crm.h:792
crm_clocks_freq_type::apb2_freq
uint32_t apb2_freq
Definition: at32f435_437_crm.h:791
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f435_437_crm.h:789
crm_clocks_freq_type::ahb_freq
uint32_t ahb_freq
Definition: at32f435_437_crm.h:790
crm_type
type define crm register all
Definition: at32f435_437_crm.h:799
crm_type::misc1
__IO uint32_t misc1
Definition: at32f435_437_crm.h:1465
crm_type::lickstblien
__IO uint32_t lickstblien
Definition: at32f435_437_crm.h:880
crm_type::adcrst
__IO uint32_t adcrst
Definition: at32f435_437_crm.h:1047
crm_type::ertcsel
__IO uint32_t ertcsel
Definition: at32f435_437_crm.h:1425
crm_type::uart4en
__IO uint32_t uart4en
Definition: at32f435_437_crm.h:1189
crm_type::auto_step_en
__IO uint32_t auto_step_en
Definition: at32f435_437_crm.h:1490
crm_type::usart1en
__IO uint32_t usart1en
Definition: at32f435_437_crm.h:1216
crm_type::ctrl
__IO uint32_t ctrl
Definition: at32f435_437_crm.h:805
crm_type::dma2rst
__IO uint32_t dma2rst
Definition: at32f435_437_crm.h:920
crm_type::apb2en
__IO uint32_t apb2en
Definition: at32f435_437_crm.h:1210
crm_type::edmalpen
__IO uint32_t edmalpen
Definition: at32f435_437_crm.h:1261
crm_type::i2c3en
__IO uint32_t i2c3en
Definition: at32f435_437_crm.h:1193
crm_type::qspi2lpen
__IO uint32_t qspi2lpen
Definition: at32f435_437_crm.h:1325
crm_type::gpiodlpen
__IO uint32_t gpiodlpen
Definition: at32f435_437_crm.h:1253
crm_type::apb1rst
__IO uint32_t apb1rst
Definition: at32f435_437_crm.h:997
crm_type::uart4rst
__IO uint32_t uart4rst
Definition: at32f435_437_crm.h:1017
crm_type::spi4lpen
__IO uint32_t spi4lpen
Definition: at32f435_437_crm.h:1394
crm_type::misc2
__IO uint32_t misc2
Definition: at32f435_437_crm.h:1486
crm_type::qspi2en
__IO uint32_t qspi2en
Definition: at32f435_437_crm.h:1153
crm_type::tmr11rst
__IO uint32_t tmr11rst
Definition: at32f435_437_crm.h:1055
crm_type::tmr5lpen
__IO uint32_t tmr5lpen
Definition: at32f435_437_crm.h:1347
crm_type::gpioeen
__IO uint32_t gpioeen
Definition: at32f435_437_crm.h:1082
crm_type::uart8lpen
__IO uint32_t uart8lpen
Definition: at32f435_437_crm.h:1373
crm_type::sdio1lpen
__IO uint32_t sdio1lpen
Definition: at32f435_437_crm.h:1309
crm_type::accen
__IO uint32_t accen
Definition: at32f435_437_crm.h:1231
crm_type::i2c2rst
__IO uint32_t i2c2rst
Definition: at32f435_437_crm.h:1020
crm_type::uart7rst
__IO uint32_t uart7rst
Definition: at32f435_437_crm.h:1028
crm_type::can2lpen
__IO uint32_t can2lpen
Definition: at32f435_437_crm.h:1368
crm_type::ahben1
__IO uint32_t ahben1
Definition: at32f435_437_crm.h:1074
crm_type::gpiohlpen
__IO uint32_t gpiohlpen
Definition: at32f435_437_crm.h:1257
crm_type::apb2rst
__IO uint32_t apb2rst
Definition: at32f435_437_crm.h:1038
crm_type::cfdf
__IO uint32_t cfdf
Definition: at32f435_437_crm.h:879
crm_type::qspi2rst
__IO uint32_t qspi2rst
Definition: at32f435_437_crm.h:981
crm_type::usart3lpen
__IO uint32_t usart3lpen
Definition: at32f435_437_crm.h:1360
crm_type::gpioerst
__IO uint32_t gpioerst
Definition: at32f435_437_crm.h:910
crm_type::usart2lpen
__IO uint32_t usart2lpen
Definition: at32f435_437_crm.h:1359
crm_type::reserved5
__IO uint32_t reserved5
crm reserved5 register, offset:0x5C
Definition: at32f435_437_crm.h:923
crm_type::tmr3en
__IO uint32_t tmr3en
Definition: at32f435_437_crm.h:1173
crm_type::usart2rst
__IO uint32_t usart2rst
Definition: at32f435_437_crm.h:1015
crm_type::tmr3rst
__IO uint32_t tmr3rst
Definition: at32f435_437_crm.h:1001
crm_type::spi3en
__IO uint32_t spi3en
Definition: at32f435_437_crm.h:1185
crm_type::tmr20rst
__IO uint32_t tmr20rst
Definition: at32f435_437_crm.h:1057
crm_type::scfglpen
__IO uint32_t scfglpen
Definition: at32f435_437_crm.h:1395
crm_type::i2c3rst
__IO uint32_t i2c3rst
Definition: at32f435_437_crm.h:1021
crm_type::tmr13en
__IO uint32_t tmr13en
Definition: at32f435_437_crm.h:1179
crm_type::hexten
__IO uint32_t hexten
Definition: at32f435_437_crm.h:812
crm_type::pllns
__IO uint32_t pllns
Definition: at32f435_437_crm.h:833
crm_type::tmr8lpen
__IO uint32_t tmr8lpen
Definition: at32f435_437_crm.h:1386
crm_type::tmr7rst
__IO uint32_t tmr7rst
Definition: at32f435_437_crm.h:1005
crm_type::gpiocrst
__IO uint32_t gpiocrst
Definition: at32f435_437_crm.h:908
crm_type::spi3rst
__IO uint32_t spi3rst
Definition: at32f435_437_crm.h:1013
crm_type::bpdc
__IO uint32_t bpdc
Definition: at32f435_437_crm.h:1418
crm_type::dma1en
__IO uint32_t dma1en
Definition: at32f435_437_crm.h:1090
crm_type::dma1lpen
__IO uint32_t dma1lpen
Definition: at32f435_437_crm.h:1262
crm_type::usbdiv
__IO uint32_t usbdiv
Definition: at32f435_437_crm.h:1495
crm_type::ahblpen2
__IO uint32_t ahblpen2
Definition: at32f435_437_crm.h:1302
crm_type::clkout1div1
__IO uint32_t clkout1div1
Definition: at32f435_437_crm.h:859
crm_type::tmr4en
__IO uint32_t tmr4en
Definition: at32f435_437_crm.h:1174
crm_type::dma2lpen
__IO uint32_t dma2lpen
Definition: at32f435_437_crm.h:1264
crm_type::tmr1en
__IO uint32_t tmr1en
Definition: at32f435_437_crm.h:1213
crm_type::qspi1rst
__IO uint32_t qspi1rst
Definition: at32f435_437_crm.h:979
crm_type::hickcal_key
__IO uint32_t hickcal_key
Definition: at32f435_437_crm.h:1468
crm_type::pllstblfc
__IO uint32_t pllstblfc
Definition: at32f435_437_crm.h:890
crm_type::clk_to_tmr
__IO uint32_t clk_to_tmr
Definition: at32f435_437_crm.h:1492
crm_type::clkout2_sel1
__IO uint32_t clkout2_sel1
Definition: at32f435_437_crm.h:861
crm_type::uart5en
__IO uint32_t uart5en
Definition: at32f435_437_crm.h:1190
crm_type::hick_to_usb
__IO uint32_t hick_to_usb
Definition: at32f435_437_crm.h:1471
crm_type::uart7lpen
__IO uint32_t uart7lpen
Definition: at32f435_437_crm.h:1372
crm_type::tmr6rst
__IO uint32_t tmr6rst
Definition: at32f435_437_crm.h:1004
crm_type::lprstf
__IO uint32_t lprstf
Definition: at32f435_437_crm.h:1451
crm_type::uart5rst
__IO uint32_t uart5rst
Definition: at32f435_437_crm.h:1018
crm_type::hickcal
__IO uint32_t hickcal
Definition: at32f435_437_crm.h:811
crm_type::tmr10lpen
__IO uint32_t tmr10lpen
Definition: at32f435_437_crm.h:1398
crm_type::sclksel
__IO uint32_t sclksel
Definition: at32f435_437_crm.h:850
crm_type::gpioben
__IO uint32_t gpioben
Definition: at32f435_437_crm.h:1079
crm_type::clkout1div2
__IO uint32_t clkout1div2
Definition: at32f435_437_crm.h:1476
crm_type::tmr11en
__IO uint32_t tmr11en
Definition: at32f435_437_crm.h:1227
crm_type::tmr3lpen
__IO uint32_t tmr3lpen
Definition: at32f435_437_crm.h:1345
crm_type::edmarst
__IO uint32_t edmarst
Definition: at32f435_437_crm.h:917
crm_type::tmr9lpen
__IO uint32_t tmr9lpen
Definition: at32f435_437_crm.h:1397
crm_type::gpioden
__IO uint32_t gpioden
Definition: at32f435_437_crm.h:1081
crm_type::ahblpen1
__IO uint32_t ahblpen1
Definition: at32f435_437_crm.h:1246
crm_type::lextstblfc
__IO uint32_t lextstblfc
Definition: at32f435_437_crm.h:887
crm_type::apb2lpen
__IO uint32_t apb2lpen
Definition: at32f435_437_crm.h:1382
crm_type::reserved1
__IO uint32_t reserved1
crm reserved1 register, offset:0x1C
Definition: at32f435_437_crm.h:816
crm_type::emac_pps_sel
__IO uint32_t emac_pps_sel
Definition: at32f435_437_crm.h:1493
crm_type::tmr8en
__IO uint32_t tmr8en
Definition: at32f435_437_crm.h:1214
crm_type::gpiofen
__IO uint32_t gpiofen
Definition: at32f435_437_crm.h:1083
crm_type::dacen
__IO uint32_t dacen
Definition: at32f435_437_crm.h:1199
crm_type::hextbyps
__IO uint32_t hextbyps
Definition: at32f435_437_crm.h:814
crm_type::adc14lpen
__IO uint32_t adc14lpen
Definition: at32f435_437_crm.h:1352
crm_type::tmr7en
__IO uint32_t tmr7en
Definition: at32f435_437_crm.h:1177
crm_type::daclpen
__IO uint32_t daclpen
Definition: at32f435_437_crm.h:1371
crm_type::reserved7
__IO uint32_t reserved7
crm reserved7 register, offset:0x78~0x9C
Definition: at32f435_437_crm.h:1060
crm_type::dvplpen
__IO uint32_t dvplpen
Definition: at32f435_437_crm.h:1305
crm_type::wdtrstf
__IO uint32_t wdtrstf
Definition: at32f435_437_crm.h:1449
crm_type::otgfs1lpen
__IO uint32_t otgfs1lpen
Definition: at32f435_437_crm.h:1307
crm_type::bpdrst
__IO uint32_t bpdrst
Definition: at32f435_437_crm.h:1428
crm_type::spi2lpen
__IO uint32_t spi2lpen
Definition: at32f435_437_crm.h:1356
crm_type::tmr4lpen
__IO uint32_t tmr4lpen
Definition: at32f435_437_crm.h:1346
crm_type::tmr10en
__IO uint32_t tmr10en
Definition: at32f435_437_crm.h:1226
crm_type::clkout2div1
__IO uint32_t clkout2div1
Definition: at32f435_437_crm.h:860
crm_type::gpiogen
__IO uint32_t gpiogen
Definition: at32f435_437_crm.h:1084
crm_type::i2c3lpen
__IO uint32_t i2c3lpen
Definition: at32f435_437_crm.h:1365
crm_type::dvprst
__IO uint32_t dvprst
Definition: at32f435_437_crm.h:961
crm_type::adcen
__IO uint32_t adcen
Definition: at32f435_437_crm.h:1219
crm_type::otgfs1rst
__IO uint32_t otgfs1rst
Definition: at32f435_437_crm.h:963
crm_type::usart2en
__IO uint32_t usart2en
Definition: at32f435_437_crm.h:1187
crm_type::lickstbl
__IO uint32_t lickstbl
Definition: at32f435_437_crm.h:1442
crm_type::tmr6lpen
__IO uint32_t tmr6lpen
Definition: at32f435_437_crm.h:1348
crm_type::tmr9rst
__IO uint32_t tmr9rst
Definition: at32f435_437_crm.h:1053
crm_type::apb1lpen
__IO uint32_t apb1lpen
Definition: at32f435_437_crm.h:1341
crm_type::tmr8rst
__IO uint32_t tmr8rst
Definition: at32f435_437_crm.h:1042
crm_type::xmcrst
__IO uint32_t xmcrst
Definition: at32f435_437_crm.h:978
crm_type::nrstf
__IO uint32_t nrstf
Definition: at32f435_437_crm.h:1446
crm_type::gpiohen
__IO uint32_t gpiohen
Definition: at32f435_437_crm.h:1085
crm_type::i2c2lpen
__IO uint32_t i2c2lpen
Definition: at32f435_437_crm.h:1364
crm_type::lickstblfc
__IO uint32_t lickstblfc
Definition: at32f435_437_crm.h:886
crm_type::tmr12en
__IO uint32_t tmr12en
Definition: at32f435_437_crm.h:1178
crm_type::ertcdiv
__IO uint32_t ertcdiv
Definition: at32f435_437_crm.h:856
crm_type::swrstf
__IO uint32_t swrstf
Definition: at32f435_437_crm.h:1448
crm_type::cfdfc
__IO uint32_t cfdfc
Definition: at32f435_437_crm.h:892
crm_type::tmr12rst
__IO uint32_t tmr12rst
Definition: at32f435_437_crm.h:1006
crm_type::gpioelpen
__IO uint32_t gpioelpen
Definition: at32f435_437_crm.h:1254
crm_type::i2c1lpen
__IO uint32_t i2c1lpen
Definition: at32f435_437_crm.h:1363
crm_type::can2rst
__IO uint32_t can2rst
Definition: at32f435_437_crm.h:1024
crm_type::gpioarst
__IO uint32_t gpioarst
Definition: at32f435_437_crm.h:906
crm_type::apb1en
__IO uint32_t apb1en
Definition: at32f435_437_crm.h:1169
crm_type::adc14en
__IO uint32_t adc14en
Definition: at32f435_437_crm.h:1180
crm_type::tmr10rst
__IO uint32_t tmr10rst
Definition: at32f435_437_crm.h:1054
crm_type::rstfc
__IO uint32_t rstfc
Definition: at32f435_437_crm.h:1444
crm_type::tmr1rst
__IO uint32_t tmr1rst
Definition: at32f435_437_crm.h:1041
crm_type::usart6rst
__IO uint32_t usart6rst
Definition: at32f435_437_crm.h:1045
crm_type::tmr5en
__IO uint32_t tmr5en
Definition: at32f435_437_crm.h:1175
crm_type::hextstbl
__IO uint32_t hextstbl
Definition: at32f435_437_crm.h:813
crm_type::usart1rst
__IO uint32_t usart1rst
Definition: at32f435_437_crm.h:1044
crm_type::tmr13rst
__IO uint32_t tmr13rst
Definition: at32f435_437_crm.h:1007
crm_type::qspi1en
__IO uint32_t qspi1en
Definition: at32f435_437_crm.h:1151
crm_type::gpioaen
__IO uint32_t gpioaen
Definition: at32f435_437_crm.h:1078
crm_type::spi2rst
__IO uint32_t spi2rst
Definition: at32f435_437_crm.h:1012
crm_type::spi1rst
__IO uint32_t spi1rst
Definition: at32f435_437_crm.h:1049
crm_type::cfg
__IO uint32_t cfg
Definition: at32f435_437_crm.h:847
crm_type::pwclpen
__IO uint32_t pwclpen
Definition: at32f435_437_crm.h:1370
crm_type::dacrst
__IO uint32_t dacrst
Definition: at32f435_437_crm.h:1027
crm_type::i2c1rst
__IO uint32_t i2c1rst
Definition: at32f435_437_crm.h:1019
crm_type::otgfs2en
__IO uint32_t otgfs2en
Definition: at32f435_437_crm.h:1094
crm_type::licken
__IO uint32_t licken
Definition: at32f435_437_crm.h:1441
crm_type::pllrcs
__IO uint32_t pllrcs
Definition: at32f435_437_crm.h:837
crm_type::clkout1_sel
__IO uint32_t clkout1_sel
Definition: at32f435_437_crm.h:857
crm_type::tmr9en
__IO uint32_t tmr9en
Definition: at32f435_437_crm.h:1225
crm_type::uart8en
__IO uint32_t uart8en
Definition: at32f435_437_crm.h:1201
crm_type::tmr12lpen
__IO uint32_t tmr12lpen
Definition: at32f435_437_crm.h:1350
crm_type::hickstblfc
__IO uint32_t hickstblfc
Definition: at32f435_437_crm.h:888
crm_type::gpiofrst
__IO uint32_t gpiofrst
Definition: at32f435_437_crm.h:911
crm_type::usart6en
__IO uint32_t usart6en
Definition: at32f435_437_crm.h:1217
crm_type::tmr6en
__IO uint32_t tmr6en
Definition: at32f435_437_crm.h:1176
crm_type::hickstblien
__IO uint32_t hickstblien
Definition: at32f435_437_crm.h:882
crm_type::ahbrst3
__IO uint32_t ahbrst3
Definition: at32f435_437_crm.h:975
crm_type::ahbrst2
__IO uint32_t ahbrst2
Definition: at32f435_437_crm.h:958
crm_type::pllstblf
__IO uint32_t pllstblf
Definition: at32f435_437_crm.h:877
crm_type::usart1lpen
__IO uint32_t usart1lpen
Definition: at32f435_437_crm.h:1388
crm_type::tmr13lpen
__IO uint32_t tmr13lpen
Definition: at32f435_437_crm.h:1351
crm_type::hicktrim
__IO uint32_t hicktrim
Definition: at32f435_437_crm.h:810
crm_type::gpioalpen
__IO uint32_t gpioalpen
Definition: at32f435_437_crm.h:1250
crm_type::uart7en
__IO uint32_t uart7en
Definition: at32f435_437_crm.h:1200
crm_type::sdio1en
__IO uint32_t sdio1en
Definition: at32f435_437_crm.h:1137
crm_type::usart6lpen
__IO uint32_t usart6lpen
Definition: at32f435_437_crm.h:1389
crm_type::sdio2rst
__IO uint32_t sdio2rst
Definition: at32f435_437_crm.h:982
crm_type::wwdten
__IO uint32_t wwdten
Definition: at32f435_437_crm.h:1182
crm_type::reserved6
__IO uint32_t reserved6
crm reserved6 register, offset:0x68~0x6C
Definition: at32f435_437_crm.h:1058
crm_type::xmcen
__IO uint32_t xmcen
Definition: at32f435_437_crm.h:1150
crm_type::usart3rst
__IO uint32_t usart3rst
Definition: at32f435_437_crm.h:1016
crm_type::gpiocen
__IO uint32_t gpiocen
Definition: at32f435_437_crm.h:1080
crm_type::pllfr
__IO uint32_t pllfr
Definition: at32f435_437_crm.h:835
crm_type::uart5lpen
__IO uint32_t uart5lpen
Definition: at32f435_437_crm.h:1362
crm_type::spi4rst
__IO uint32_t spi4rst
Definition: at32f435_437_crm.h:1050
crm_type::tmr20lpen
__IO uint32_t tmr20lpen
Definition: at32f435_437_crm.h:1401
crm_type::lextstblf
__IO uint32_t lextstblf
Definition: at32f435_437_crm.h:874
crm_type::pwcrst
__IO uint32_t pwcrst
Definition: at32f435_437_crm.h:1026
crm_type::can1lpen
__IO uint32_t can1lpen
Definition: at32f435_437_crm.h:1367
crm_type::apb2div
__IO uint32_t apb2div
Definition: at32f435_437_crm.h:855
crm_type::wwdtrst
__IO uint32_t wwdtrst
Definition: at32f435_437_crm.h:1010
crm_type::usart3en
__IO uint32_t usart3en
Definition: at32f435_437_crm.h:1188
crm_type::tmr2rst
__IO uint32_t tmr2rst
Definition: at32f435_437_crm.h:1000
crm_type::adclpen
__IO uint32_t adclpen
Definition: at32f435_437_crm.h:1391
crm_type::pllstbl
__IO uint32_t pllstbl
Definition: at32f435_437_crm.h:818
crm_type::dma1rst
__IO uint32_t dma1rst
Definition: at32f435_437_crm.h:918
crm_type::tmr11lpen
__IO uint32_t tmr11lpen
Definition: at32f435_437_crm.h:1399
crm_type::ahben3
__IO uint32_t ahben3
Definition: at32f435_437_crm.h:1147
crm_type::pllstblien
__IO uint32_t pllstblien
Definition: at32f435_437_crm.h:884
crm_type::can1rst
__IO uint32_t can1rst
Definition: at32f435_437_crm.h:1023
crm_type::uart8rst
__IO uint32_t uart8rst
Definition: at32f435_437_crm.h:1029
crm_type::can1en
__IO uint32_t can1en
Definition: at32f435_437_crm.h:1195
crm_type::lextbyps
__IO uint32_t lextbyps
Definition: at32f435_437_crm.h:1423
crm_type::lextstbl
__IO uint32_t lextstbl
Definition: at32f435_437_crm.h:1422
crm_type::clkout2_sel2
__IO uint32_t clkout2_sel2
Definition: at32f435_437_crm.h:1474
crm_type::reserved3
__IO uint32_t reserved3
crm reserved3 register, offset:0x3C
Definition: at32f435_437_crm.h:836
crm_type::crcen
__IO uint32_t crcen
Definition: at32f435_437_crm.h:1087
crm_type::tmr2en
__IO uint32_t tmr2en
Definition: at32f435_437_crm.h:1172
crm_type::hick_to_sclk
__IO uint32_t hick_to_sclk
Definition: at32f435_437_crm.h:1472
crm_type::sclksts
__IO uint32_t sclksts
Definition: at32f435_437_crm.h:851
crm_type::i2c1en
__IO uint32_t i2c1en
Definition: at32f435_437_crm.h:1191
crm_type::otgfs2lpen
__IO uint32_t otgfs2lpen
Definition: at32f435_437_crm.h:1266
crm_type::ahbrst1
__IO uint32_t ahbrst1
Definition: at32f435_437_crm.h:902
crm_type::hextstblien
__IO uint32_t hextstblien
Definition: at32f435_437_crm.h:883
crm_type::gpiodrst
__IO uint32_t gpiodrst
Definition: at32f435_437_crm.h:909
crm_type::ertcen
__IO uint32_t ertcen
Definition: at32f435_437_crm.h:1427
crm_type::ctrlsts
__IO uint32_t ctrlsts
Definition: at32f435_437_crm.h:1438
crm_type::gpiogrst
__IO uint32_t gpiogrst
Definition: at32f435_437_crm.h:912
crm_type::uart4lpen
__IO uint32_t uart4lpen
Definition: at32f435_437_crm.h:1361
crm_type::reserved2
__IO uint32_t reserved2
crm reserved2 register, offset:0x28~0x2C
Definition: at32f435_437_crm.h:819
crm_type::hickdiv
__IO uint32_t hickdiv
Definition: at32f435_437_crm.h:1470
crm_type::accrst
__IO uint32_t accrst
Definition: at32f435_437_crm.h:1059
crm_type::reserved4
__IO uint32_t reserved4
crm reserved4 register, offset:0x48~0x4C
Definition: at32f435_437_crm.h:838
crm_type::tmr1lpen
__IO uint32_t tmr1lpen
Definition: at32f435_437_crm.h:1385
crm_type::pllms
__IO uint32_t pllms
Definition: at32f435_437_crm.h:831
crm_type::wwdtrstf
__IO uint32_t wwdtrstf
Definition: at32f435_437_crm.h:1450
crm_type::ahblpen3
__IO uint32_t ahblpen3
Definition: at32f435_437_crm.h:1319
crm_type::gpioclpen
__IO uint32_t gpioclpen
Definition: at32f435_437_crm.h:1252
crm_type::tmr20en
__IO uint32_t tmr20en
Definition: at32f435_437_crm.h:1229
crm_type::sdio1rst
__IO uint32_t sdio1rst
Definition: at32f435_437_crm.h:965
crm_type::porrstf
__IO uint32_t porrstf
Definition: at32f435_437_crm.h:1447
crm_type::spi4en
__IO uint32_t spi4en
Definition: at32f435_437_crm.h:1222
crm_type::hextstblfc
__IO uint32_t hextstblfc
Definition: at32f435_437_crm.h:889
crm_type::sdio2en
__IO uint32_t sdio2en
Definition: at32f435_437_crm.h:1154
crm_type::gpioglpen
__IO uint32_t gpioglpen
Definition: at32f435_437_crm.h:1256
crm_type::sdio2lpen
__IO uint32_t sdio2lpen
Definition: at32f435_437_crm.h:1326
crm_type::spi3lpen
__IO uint32_t spi3lpen
Definition: at32f435_437_crm.h:1357
crm_type::gpioflpen
__IO uint32_t gpioflpen
Definition: at32f435_437_crm.h:1255
crm_type::dvpen
__IO uint32_t dvpen
Definition: at32f435_437_crm.h:1133
crm_type::tmr4rst
__IO uint32_t tmr4rst
Definition: at32f435_437_crm.h:1002
crm_type::gpiohrst
__IO uint32_t gpiohrst
Definition: at32f435_437_crm.h:913
crm_type::tmr2lpen
__IO uint32_t tmr2lpen
Definition: at32f435_437_crm.h:1344
crm_type::cfden
__IO uint32_t cfden
Definition: at32f435_437_crm.h:815
crm_type::tmr7lpen
__IO uint32_t tmr7lpen
Definition: at32f435_437_crm.h:1349
crm_type::apb1div
__IO uint32_t apb1div
Definition: at32f435_437_crm.h:854
crm_type::gpioblpen
__IO uint32_t gpioblpen
Definition: at32f435_437_crm.h:1251
crm_type::pwcen
__IO uint32_t pwcen
Definition: at32f435_437_crm.h:1198
crm_type::lextstblien
__IO uint32_t lextstblien
Definition: at32f435_437_crm.h:881
crm_type::lickstblf
__IO uint32_t lickstblf
Definition: at32f435_437_crm.h:873
crm_type::clkout2div2
__IO uint32_t clkout2div2
Definition: at32f435_437_crm.h:1477
crm_type::hicken
__IO uint32_t hicken
Definition: at32f435_437_crm.h:808
crm_type::spi1lpen
__IO uint32_t spi1lpen
Definition: at32f435_437_crm.h:1393
crm_type::otgfs2rst
__IO uint32_t otgfs2rst
Definition: at32f435_437_crm.h:922
crm_type::lexten
__IO uint32_t lexten
Definition: at32f435_437_crm.h:1421
crm_type::scfgen
__IO uint32_t scfgen
Definition: at32f435_437_crm.h:1223
crm_type::hickstbl
__IO uint32_t hickstbl
Definition: at32f435_437_crm.h:809
crm_type::i2c2en
__IO uint32_t i2c2en
Definition: at32f435_437_crm.h:1192
crm_type::crcrst
__IO uint32_t crcrst
Definition: at32f435_437_crm.h:915
crm_type::wwdtlpen
__IO uint32_t wwdtlpen
Definition: at32f435_437_crm.h:1354
crm_type::edmaen
__IO uint32_t edmaen
Definition: at32f435_437_crm.h:1089
crm_type::pllcfg
__IO uint32_t pllcfg
Definition: at32f435_437_crm.h:828
crm_type::spi1en
__IO uint32_t spi1en
Definition: at32f435_437_crm.h:1221
crm_type::dma2en
__IO uint32_t dma2en
Definition: at32f435_437_crm.h:1092
crm_type::crclpen
__IO uint32_t crclpen
Definition: at32f435_437_crm.h:1259
crm_type::scfgrst
__IO uint32_t scfgrst
Definition: at32f435_437_crm.h:1051
crm_type::hextstblf
__IO uint32_t hextstblf
Definition: at32f435_437_crm.h:876
crm_type::spi2en
__IO uint32_t spi2en
Definition: at32f435_437_crm.h:1184
crm_type::gpiobrst
__IO uint32_t gpiobrst
Definition: at32f435_437_crm.h:907
crm_type::pllen
__IO uint32_t pllen
Definition: at32f435_437_crm.h:817
crm_type::ahben2
__IO uint32_t ahben2
Definition: at32f435_437_crm.h:1130
crm_type::adc14rst
__IO uint32_t adc14rst
Definition: at32f435_437_crm.h:1008
crm_type::tmr5rst
__IO uint32_t tmr5rst
Definition: at32f435_437_crm.h:1003
crm_type::can2en
__IO uint32_t can2en
Definition: at32f435_437_crm.h:1196
crm_type::hickstblf
__IO uint32_t hickstblf
Definition: at32f435_437_crm.h:875
crm_type::clkint
__IO uint32_t clkint
Definition: at32f435_437_crm.h:870
crm_type::otgfs1en
__IO uint32_t otgfs1en
Definition: at32f435_437_crm.h:1135
crm_type::xmclpen
__IO uint32_t xmclpen
Definition: at32f435_437_crm.h:1322
crm_type::ahbdiv
__IO uint32_t ahbdiv
Definition: at32f435_437_crm.h:852
crm_type::acclpen
__IO uint32_t acclpen
Definition: at32f435_437_crm.h:1403
crm_type::qspi1lpen
__IO uint32_t qspi1lpen
Definition: at32f435_437_crm.h:1323


AT32F435/437 Firmwary Library: at32f435_437_dac.c Source File

  • libraries
  • drivers
  • src
at32f435_437_dac.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef DAC_MODULE_ENABLED
39
49void dac_reset(void)
50{
51 crm_periph_reset(CRM_DAC_PERIPH_RESET, TRUE);
52 crm_periph_reset(CRM_DAC_PERIPH_RESET, FALSE);
53}
54
64void dac_enable(dac_select_type dac_select, confirm_state new_state)
65{
66 switch(dac_select)
67 {
68 case DAC1_SELECT:
69 DAC->ctrl_bit.d1en = new_state;
70 break;
71 case DAC2_SELECT:
72 DAC->ctrl_bit.d2en = new_state;
73 break;
74 default:
75 break;
76 }
77}
78
88void dac_output_buffer_enable(dac_select_type dac_select, confirm_state new_state)
89{
90 new_state = (confirm_state)!new_state;
91 switch(dac_select)
92 {
93 case DAC1_SELECT:
94 DAC->ctrl_bit.d1obdis = new_state;
95 break;
96 case DAC2_SELECT:
97 DAC->ctrl_bit.d2obdis = new_state;
98 break;
99 default:
100 break;
101 }
102}
103
113void dac_trigger_enable(dac_select_type dac_select, confirm_state new_state)
114{
115 switch(dac_select)
116 {
117 case DAC1_SELECT:
118 DAC->ctrl_bit.d1trgen = new_state;
119 break;
120 case DAC2_SELECT:
121 DAC->ctrl_bit.d2trgen = new_state;
122 break;
123 default:
124 break;
125 }
126}
127
146void dac_trigger_select(dac_select_type dac_select, dac_trigger_type dac_trigger_source)
147{
148 switch(dac_select)
149 {
150 case DAC1_SELECT:
151 DAC->ctrl_bit.d1trgsel = dac_trigger_source;
152 break;
153 case DAC2_SELECT:
154 DAC->ctrl_bit.d2trgsel = dac_trigger_source;
155 break;
156 default:
157 break;
158 }
159}
160
169void dac_software_trigger_generate(dac_select_type dac_select)
170{
171 switch(dac_select)
172 {
173 case DAC1_SELECT:
174 DAC->swtrg_bit.d1swtrg = TRUE;
175 break;
176 case DAC2_SELECT:
177 DAC->swtrg_bit.d2swtrg = TRUE;
178 break;
179 default:
180 break;
181 }
182}
183
189void dac_dual_software_trigger_generate(void)
190{
191 DAC->swtrg |= 0x03;
192}
193
207void dac_wave_generate(dac_select_type dac_select, dac_wave_type dac_wave)
208{
209 switch(dac_select)
210 {
211 case DAC1_SELECT:
212 DAC->ctrl_bit.d1nm = dac_wave;
213 break;
214 case DAC2_SELECT:
215 DAC->ctrl_bit.d2nm = dac_wave;
216 break;
217 default:
218 break;
219 }
220}
221
244void dac_mask_amplitude_select(dac_select_type dac_select, dac_mask_amplitude_type dac_mask_amplitude)
245{
246 switch(dac_select)
247 {
248 case DAC1_SELECT:
249 DAC->ctrl_bit.d1nbsel = dac_mask_amplitude;
250 break;
251 case DAC2_SELECT:
252 DAC->ctrl_bit.d2nbsel = dac_mask_amplitude;
253 break;
254 default:
255 break;
256 }
257}
258
268void dac_dma_enable(dac_select_type dac_select, confirm_state new_state)
269{
270 switch(dac_select)
271 {
272 case DAC1_SELECT:
273 DAC->ctrl_bit.d1dmaen = new_state;
274 break;
275 case DAC2_SELECT:
276 DAC->ctrl_bit.d2dmaen = new_state;
277 break;
278 default:
279 break;
280 }
281}
282
291uint16_t dac_data_output_get(dac_select_type dac_select)
292{
293 uint16_t data_output =0;
294 switch(dac_select)
295 {
296 case DAC1_SELECT:
297 data_output = DAC->d1odt_bit.d1odt;
298 break;
299 case DAC2_SELECT:
300 data_output = DAC->d2odt_bit.d2odt;
301 break;
302 default:
303 break;
304 }
305 return data_output;
306}
307
318void dac_1_data_set(dac1_aligned_data_type dac1_aligned, uint16_t dac1_data)
319{
320 *(__IO uint32_t *) dac1_aligned = dac1_data;
321}
322
333void dac_2_data_set(dac2_aligned_data_type dac2_aligned, uint16_t dac2_data)
334{
335 *(__IO uint32_t *) dac2_aligned = dac2_data;
336}
337
349void dac_dual_data_set(dac_dual_data_type dac_dual, uint16_t data1, uint16_t data2)
350{
351 switch(dac_dual)
352 {
353 case DAC_DUAL_12BIT_RIGHT:
354 *(__IO uint32_t *) dac_dual = (uint32_t)(data1 | (data2 << 16));
355 break;
356 case DAC_DUAL_12BIT_LEFT:
357 *(__IO uint32_t *) dac_dual = (uint32_t)(data1 | (data2 << 16));
358 break;
359 case DAC_DUAL_8BIT_RIGHT:
360 *(__IO uint32_t *) dac_dual = (uint32_t)(data1 | (data2 << 8));
361 break;
362 default:
363 break;
364 }
365}
366
376void dac_udr_enable(dac_select_type dac_select, confirm_state new_state)
377{
378 switch(dac_select)
379 {
380 case DAC1_SELECT:
381 DAC->ctrl_bit.d1dmaudrien = new_state;
382 break;
383 case DAC2_SELECT:
384 DAC->ctrl_bit.d2dmaudrien = new_state;
385 break;
386 default:
387 break;
388 }
389}
390
399 flag_status dac_udr_flag_get(dac_select_type dac_select)
400{
401 flag_status status = RESET;
402
403 switch(dac_select)
404 {
405 case DAC1_SELECT:
406 if(DAC->sts_bit.d1dmaudrf != 0)
407 status = SET;
408 break;
409 case DAC2_SELECT:
410 if(DAC->sts_bit.d2dmaudrf != 0)
411 status = SET;
412 break;
413 default:
414 break;
415 }
416 return status;
417}
418
427void dac_udr_flag_clear(dac_select_type dac_select)
428{
429 switch(dac_select)
430 {
431 case DAC1_SELECT:
432 DAC->sts = DAC1_D1DMAUDRF;
433 break;
434 case DAC2_SELECT:
435 DAC->sts = DAC2_D2DMAUDRF;
436 break;
437 default:
438 break;
439 }
440}
441
446#endif
447
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f435_437_crm.c:251
CRM_DAC_PERIPH_RESET
@ CRM_DAC_PERIPH_RESET
Definition: at32f435_437_crm.h:297
dac_select_type
dac_select_type
dac select type
Definition: at32f435_437_dac.h:58
dac1_aligned_data_type
dac1_aligned_data_type
dac1 aligned data type
Definition: at32f435_437_dac.h:111
dac2_aligned_data_type
dac2_aligned_data_type
dac2 aligned data type
Definition: at32f435_437_dac.h:121
dac_wave_type
dac_wave_type
dac wave type
Definition: at32f435_437_dac.h:82
dac_mask_amplitude_type
dac_mask_amplitude_type
dac mask amplitude type
Definition: at32f435_437_dac.h:92
dac_trigger_type
dac_trigger_type
dac trigger type
Definition: at32f435_437_dac.h:67
dac_dual_data_type
dac_dual_data_type
dac dual data type
Definition: at32f435_437_dac.h:131
DAC2_SELECT
@ DAC2_SELECT
Definition: at32f435_437_dac.h:60
DAC1_SELECT
@ DAC1_SELECT
Definition: at32f435_437_dac.h:59
DAC_DUAL_12BIT_LEFT
@ DAC_DUAL_12BIT_LEFT
Definition: at32f435_437_dac.h:133
DAC_DUAL_8BIT_RIGHT
@ DAC_DUAL_8BIT_RIGHT
Definition: at32f435_437_dac.h:134
DAC_DUAL_12BIT_RIGHT
@ DAC_DUAL_12BIT_RIGHT
Definition: at32f435_437_dac.h:132
dac_data_output_get
uint16_t dac_data_output_get(dac_select_type dac_select)
get dac data output
Definition: at32f435_437_dac.c:291
dac_output_buffer_enable
void dac_output_buffer_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac output buffer
Definition: at32f435_437_dac.c:88
dac_reset
void dac_reset(void)
dac reset
Definition: at32f435_437_dac.c:49
dac_dma_enable
void dac_dma_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac dma
Definition: at32f435_437_dac.c:268
dac_1_data_set
void dac_1_data_set(dac1_aligned_data_type dac1_aligned, uint16_t dac1_data)
set dac1 data
Definition: at32f435_437_dac.c:318
dac_udr_flag_get
flag_status dac_udr_flag_get(dac_select_type dac_select)
get flag of the dac udr flag.
Definition: at32f435_437_dac.c:399
dac_wave_generate
void dac_wave_generate(dac_select_type dac_select, dac_wave_type dac_wave)
generate dac wave
Definition: at32f435_437_dac.c:207
dac_software_trigger_generate
void dac_software_trigger_generate(dac_select_type dac_select)
generate dac software trigger
Definition: at32f435_437_dac.c:169
dac_mask_amplitude_select
void dac_mask_amplitude_select(dac_select_type dac_select, dac_mask_amplitude_type dac_mask_amplitude)
select dac mask amplitude
Definition: at32f435_437_dac.c:244
dac_trigger_select
void dac_trigger_select(dac_select_type dac_select, dac_trigger_type dac_trigger_source)
select dac trigger
Definition: at32f435_437_dac.c:146
dac_enable
void dac_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac
Definition: at32f435_437_dac.c:64
dac_dual_data_set
void dac_dual_data_set(dac_dual_data_type dac_dual, uint16_t data1, uint16_t data2)
set dac dual data
Definition: at32f435_437_dac.c:349
dac_udr_enable
void dac_udr_enable(dac_select_type dac_select, confirm_state new_state)
enable/disable dac dma udr interrupt
Definition: at32f435_437_dac.c:376
dac_trigger_enable
void dac_trigger_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac trigger
Definition: at32f435_437_dac.c:113
dac_dual_software_trigger_generate
void dac_dual_software_trigger_generate(void)
generate dac dual software trigger synchronously
Definition: at32f435_437_dac.c:189
dac_udr_flag_clear
void dac_udr_flag_clear(dac_select_type dac_select)
clear the dac udr flag.
Definition: at32f435_437_dac.c:427
dac_2_data_set
void dac_2_data_set(dac2_aligned_data_type dac2_aligned, uint16_t dac2_data)
set dac2 data
Definition: at32f435_437_dac.c:333
DAC
#define DAC
Definition: at32f435_437_dac.h:354
DAC1_D1DMAUDRF
#define DAC1_D1DMAUDRF
Definition: at32f435_437_dac.h:47
DAC2_D2DMAUDRF
#define DAC2_D2DMAUDRF
Definition: at32f435_437_dac.h:48
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_dac.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_dac.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_DAC_H
29#define __AT32F435_437_DAC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
47#define DAC1_D1DMAUDRF ((uint32_t)(0x00002000))
48#define DAC2_D2DMAUDRF ((uint32_t)(0x20000000))
49
57typedef enum
58{
59 DAC1_SELECT = 0x01,
60 DAC2_SELECT = 0x02
61} dac_select_type;
62
66typedef enum
67{
68 DAC_TMR6_TRGOUT_EVENT = 0x00,
69 DAC_TMR8_TRGOUT_EVENT = 0x01,
70 DAC_TMR7_TRGOUT_EVENT = 0x02,
71 DAC_TMR5_TRGOUT_EVENT = 0x03,
72 DAC_TMR2_TRGOUT_EVENT = 0x04,
73 DAC_TMR4_TRGOUT_EVENT = 0x05,
74 DAC_EXTERNAL_INTERRUPT_LINE_9 = 0x06,
75 DAC_SOFTWARE_TRIGGER = 0x07
76} dac_trigger_type;
77
81typedef enum
82{
83 DAC_WAVE_GENERATE_NONE = 0x00,
84 DAC_WAVE_GENERATE_NOISE = 0x01,
85 DAC_WAVE_GENERATE_TRIANGLE = 0x02
86} dac_wave_type;
87
91typedef enum
92{
93 DAC_LSFR_BIT0_AMPLITUDE_1 = 0x00,
94 DAC_LSFR_BIT10_AMPLITUDE_3 = 0x01,
95 DAC_LSFR_BIT20_AMPLITUDE_7 = 0x02,
96 DAC_LSFR_BIT30_AMPLITUDE_15 = 0x03,
97 DAC_LSFR_BIT40_AMPLITUDE_31 = 0x04,
98 DAC_LSFR_BIT50_AMPLITUDE_63 = 0x05,
99 DAC_LSFR_BIT60_AMPLITUDE_127 = 0x06,
100 DAC_LSFR_BIT70_AMPLITUDE_255 = 0x07,
101 DAC_LSFR_BIT80_AMPLITUDE_511 = 0x08,
102 DAC_LSFR_BIT90_AMPLITUDE_1023 = 0x09,
103 DAC_LSFR_BITA0_AMPLITUDE_2047 = 0x0A,
104 DAC_LSFR_BITB0_AMPLITUDE_4095 = 0x0B
105} dac_mask_amplitude_type;
106
110typedef enum
111{
112 DAC1_12BIT_RIGHT = 0x40007408,
113 DAC1_12BIT_LEFT = 0x4000740C,
114 DAC1_8BIT_RIGHT = 0x40007410
115} dac1_aligned_data_type;
116
120typedef enum
121{
122 DAC2_12BIT_RIGHT = 0x40007414,
123 DAC2_12BIT_LEFT = 0x40007418,
124 DAC2_8BIT_RIGHT = 0x4000741C
125} dac2_aligned_data_type;
126
130typedef enum
131{
132 DAC_DUAL_12BIT_RIGHT = 0x40007420,
133 DAC_DUAL_12BIT_LEFT = 0x40007424,
134 DAC_DUAL_8BIT_RIGHT = 0x40007428
135} dac_dual_data_type;
136
140typedef struct
141{
145 union
146 {
147 __IO uint32_t ctrl;
148 struct
149 {
150 __IO uint32_t d1en : 1; /* [0] */
151 __IO uint32_t d1obdis : 1; /* [1] */
152 __IO uint32_t d1trgen : 1; /* [2] */
153 __IO uint32_t d1trgsel : 3; /* [5:3] */
154 __IO uint32_t d1nm : 2; /* [7:6] */
155 __IO uint32_t d1nbsel : 4; /* [11:8] */
156 __IO uint32_t d1dmaen : 1; /* [12] */
157 __IO uint32_t d1dmaudrien : 1; /* [13] */
158 __IO uint32_t reserved1 : 2; /* [15:14] */
159 __IO uint32_t d2en : 1; /* [16] */
160 __IO uint32_t d2obdis : 1; /* [17] */
161 __IO uint32_t d2trgen : 1; /* [18] */
162 __IO uint32_t d2trgsel : 3; /* [21:19] */
163 __IO uint32_t d2nm : 2; /* [23:22] */
164 __IO uint32_t d2nbsel : 4; /* [27:24] */
165 __IO uint32_t d2dmaen : 1; /* [28] */
166 __IO uint32_t d2dmaudrien : 1; /* [29] */
167 __IO uint32_t reserved2 : 2; /* [31:30] */
168 } ctrl_bit;
169 };
170
174 union
175 {
176 __IO uint32_t swtrg;
177 struct
178 {
179 __IO uint32_t d1swtrg : 1; /* [0] */
180 __IO uint32_t d2swtrg : 1; /* [1] */
181 __IO uint32_t reserved1 : 30;/* [31:2] */
182 } swtrg_bit;
183 };
184
188 union
189 {
190 __IO uint32_t d1dth12r;
191 struct
192 {
193 __IO uint32_t d1dt12r : 12;/* [11:0] */
194 __IO uint32_t reserved1 : 20;/* [31:2] */
195 } d1dth12r_bit;
196 };
197
201 union
202 {
203 __IO uint32_t d1dth12l;
204 struct
205 {
206 __IO uint32_t d1dt12l : 12;/* [11:0] */
207 __IO uint32_t reserved1 : 20;/* [31:2] */
208 } d1dth12l_bit;
209 };
210
214 union
215 {
216 __IO uint32_t d1dth8r;
217 struct
218 {
219 __IO uint32_t d1dt8r : 8; /* [7:0] */
220 __IO uint32_t reserved1 : 24;/* [31:8] */
221 } d1dth8r_bit;
222 };
223
227 union
228 {
229 __IO uint32_t d2dth12r;
230 struct
231 {
232 __IO uint32_t d2dt12r : 12;/* [11:0] */
233 __IO uint32_t reserved1 : 20;/* [31:2] */
234 } d2dth12r_bit;
235 };
236
240 union
241 {
242 __IO uint32_t d2dth12l;
243 struct
244 {
245 __IO uint32_t d2dt12l : 12;/* [11:0] */
246 __IO uint32_t reserved1 : 20;/* [31:2] */
247 } d2dth12l_bit;
248 };
249
253 union
254 {
255 __IO uint32_t d2dth8r;
256 struct
257 {
258 __IO uint32_t d2dt8r : 8; /* [7:0] */
259 __IO uint32_t reserved1 : 24;/* [31:8] */
260 } d2dth8r_bit;
261 };
262
266 union
267 {
268 __IO uint32_t ddth12r;
269 struct
270 {
271 __IO uint32_t dd1dt12r : 12;/* [11:0] */
272 __IO uint32_t reserved1 : 4; /* [15:12] */
273 __IO uint32_t dd2dt12r : 12;/* [27:16] */
274 __IO uint32_t reserved2 : 4; /* [31:28] */
275 } ddth12r_bit;
276 };
277
281 union
282 {
283 __IO uint32_t ddth12l;
284 struct
285 {
286 __IO uint32_t reserved1 : 4; /* [3:0] */
287 __IO uint32_t dd1dt12l : 12;/* [15:4] */
288 __IO uint32_t reserved2 : 4; /* [19:16] */
289 __IO uint32_t dd2dt12l : 12;/* [31:20] */
290 } ddth12l_bit;
291 };
292
296 union
297 {
298 __IO uint32_t ddth8r;
299 struct
300 {
301 __IO uint32_t dd1dt8r : 8; /* [7:0] */
302 __IO uint32_t dd2dt8r : 8; /* [15:8] */
303 __IO uint32_t reserved1 : 16;/* [31:16] */
304 } ddth8r_bit;
305 };
306
310 union
311 {
312 __IO uint32_t d1odt;
313 struct
314 {
315 __IO uint32_t d1odt : 12;/* [11:0] */
316 __IO uint32_t reserved1 : 20;/* [31:12] */
317 } d1odt_bit;
318 };
319
323 union
324 {
325 __IO uint32_t d2odt;
326 struct
327 {
328 __IO uint32_t d2odt : 12;/* [11:0] */
329 __IO uint32_t reserved1 : 20;/* [31:12] */
330 } d2odt_bit;
331 };
332
336 union
337 {
338 __IO uint32_t sts;
339 struct
340 {
341 __IO uint32_t reserved1 : 13;/* [12:0] */
342 __IO uint32_t d1dmaudrf : 1; /* [13] */
343 __IO uint32_t reserved2 : 15;/* [28:14] */
344 __IO uint32_t d2dmaudrf : 1; /* [29] */
345 __IO uint32_t reserved3 : 2;/* [31:30] */
346 } sts_bit;
347 };
348} dac_type;
349
354#define DAC ((dac_type *) DAC_BASE)
355
360void dac_reset(void);
361void dac_enable(dac_select_type dac_select, confirm_state new_state);
362void dac_output_buffer_enable(dac_select_type dac_select, confirm_state new_state);
363void dac_trigger_enable(dac_select_type dac_select, confirm_state new_state);
364void dac_trigger_select(dac_select_type dac_select, dac_trigger_type dac_trigger_source);
365void dac_software_trigger_generate(dac_select_type dac_select);
366void dac_dual_software_trigger_generate(void);
367void dac_wave_generate(dac_select_type dac_select, dac_wave_type dac_wave);
368void dac_mask_amplitude_select(dac_select_type dac_select, dac_mask_amplitude_type dac_mask_amplitude);
369void dac_dma_enable(dac_select_type dac_select, confirm_state new_state);
370uint16_t dac_data_output_get(dac_select_type dac_select);
371void dac_1_data_set(dac1_aligned_data_type dac1_aligned, uint16_t dac1_data);
372void dac_2_data_set(dac2_aligned_data_type dac2_aligned, uint16_t dac2_data);
373void dac_dual_data_set(dac_dual_data_type dac_dual, uint16_t data1, uint16_t data2);
374void dac_udr_enable(dac_select_type dac_select, confirm_state new_state);
375 flag_status dac_udr_flag_get(dac_select_type dac_select);
376void dac_udr_flag_clear(dac_select_type dac_select);
377
390#ifdef __cplusplus
391}
392#endif
393
394#endif
at32f435_437.h
at32f435_437 header file
dac_data_output_get
uint16_t dac_data_output_get(dac_select_type dac_select)
get dac data output
Definition: at32f435_437_dac.c:291
dac_output_buffer_enable
void dac_output_buffer_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac output buffer
Definition: at32f435_437_dac.c:88
dac_reset
void dac_reset(void)
dac reset
Definition: at32f435_437_dac.c:49
dac_dma_enable
void dac_dma_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac dma
Definition: at32f435_437_dac.c:268
dac_1_data_set
void dac_1_data_set(dac1_aligned_data_type dac1_aligned, uint16_t dac1_data)
set dac1 data
Definition: at32f435_437_dac.c:318
dac_udr_flag_get
flag_status dac_udr_flag_get(dac_select_type dac_select)
get flag of the dac udr flag.
Definition: at32f435_437_dac.c:399
dac_wave_generate
void dac_wave_generate(dac_select_type dac_select, dac_wave_type dac_wave)
generate dac wave
Definition: at32f435_437_dac.c:207
dac_software_trigger_generate
void dac_software_trigger_generate(dac_select_type dac_select)
generate dac software trigger
Definition: at32f435_437_dac.c:169
dac_mask_amplitude_select
void dac_mask_amplitude_select(dac_select_type dac_select, dac_mask_amplitude_type dac_mask_amplitude)
select dac mask amplitude
Definition: at32f435_437_dac.c:244
dac_trigger_select
void dac_trigger_select(dac_select_type dac_select, dac_trigger_type dac_trigger_source)
select dac trigger
Definition: at32f435_437_dac.c:146
dac_enable
void dac_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac
Definition: at32f435_437_dac.c:64
dac_dual_data_set
void dac_dual_data_set(dac_dual_data_type dac_dual, uint16_t data1, uint16_t data2)
set dac dual data
Definition: at32f435_437_dac.c:349
dac_udr_enable
void dac_udr_enable(dac_select_type dac_select, confirm_state new_state)
enable/disable dac dma udr interrupt
Definition: at32f435_437_dac.c:376
dac_trigger_enable
void dac_trigger_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac trigger
Definition: at32f435_437_dac.c:113
dac_dual_software_trigger_generate
void dac_dual_software_trigger_generate(void)
generate dac dual software trigger synchronously
Definition: at32f435_437_dac.c:189
dac_udr_flag_clear
void dac_udr_flag_clear(dac_select_type dac_select)
clear the dac udr flag.
Definition: at32f435_437_dac.c:427
dac_2_data_set
void dac_2_data_set(dac2_aligned_data_type dac2_aligned, uint16_t dac2_data)
set dac2 data
Definition: at32f435_437_dac.c:333
dac_select_type
dac_select_type
dac select type
Definition: at32f435_437_dac.h:58
dac1_aligned_data_type
dac1_aligned_data_type
dac1 aligned data type
Definition: at32f435_437_dac.h:111
dac2_aligned_data_type
dac2_aligned_data_type
dac2 aligned data type
Definition: at32f435_437_dac.h:121
dac_wave_type
dac_wave_type
dac wave type
Definition: at32f435_437_dac.h:82
dac_mask_amplitude_type
dac_mask_amplitude_type
dac mask amplitude type
Definition: at32f435_437_dac.h:92
dac_trigger_type
dac_trigger_type
dac trigger type
Definition: at32f435_437_dac.h:67
dac_dual_data_type
dac_dual_data_type
dac dual data type
Definition: at32f435_437_dac.h:131
DAC2_SELECT
@ DAC2_SELECT
Definition: at32f435_437_dac.h:60
DAC1_SELECT
@ DAC1_SELECT
Definition: at32f435_437_dac.h:59
DAC1_12BIT_RIGHT
@ DAC1_12BIT_RIGHT
Definition: at32f435_437_dac.h:112
DAC1_8BIT_RIGHT
@ DAC1_8BIT_RIGHT
Definition: at32f435_437_dac.h:114
DAC1_12BIT_LEFT
@ DAC1_12BIT_LEFT
Definition: at32f435_437_dac.h:113
DAC2_8BIT_RIGHT
@ DAC2_8BIT_RIGHT
Definition: at32f435_437_dac.h:124
DAC2_12BIT_RIGHT
@ DAC2_12BIT_RIGHT
Definition: at32f435_437_dac.h:122
DAC2_12BIT_LEFT
@ DAC2_12BIT_LEFT
Definition: at32f435_437_dac.h:123
DAC_WAVE_GENERATE_TRIANGLE
@ DAC_WAVE_GENERATE_TRIANGLE
Definition: at32f435_437_dac.h:85
DAC_WAVE_GENERATE_NOISE
@ DAC_WAVE_GENERATE_NOISE
Definition: at32f435_437_dac.h:84
DAC_WAVE_GENERATE_NONE
@ DAC_WAVE_GENERATE_NONE
Definition: at32f435_437_dac.h:83
DAC_LSFR_BIT10_AMPLITUDE_3
@ DAC_LSFR_BIT10_AMPLITUDE_3
Definition: at32f435_437_dac.h:94
DAC_LSFR_BIT90_AMPLITUDE_1023
@ DAC_LSFR_BIT90_AMPLITUDE_1023
Definition: at32f435_437_dac.h:102
DAC_LSFR_BIT80_AMPLITUDE_511
@ DAC_LSFR_BIT80_AMPLITUDE_511
Definition: at32f435_437_dac.h:101
DAC_LSFR_BIT70_AMPLITUDE_255
@ DAC_LSFR_BIT70_AMPLITUDE_255
Definition: at32f435_437_dac.h:100
DAC_LSFR_BIT20_AMPLITUDE_7
@ DAC_LSFR_BIT20_AMPLITUDE_7
Definition: at32f435_437_dac.h:95
DAC_LSFR_BITB0_AMPLITUDE_4095
@ DAC_LSFR_BITB0_AMPLITUDE_4095
Definition: at32f435_437_dac.h:104
DAC_LSFR_BIT40_AMPLITUDE_31
@ DAC_LSFR_BIT40_AMPLITUDE_31
Definition: at32f435_437_dac.h:97
DAC_LSFR_BIT60_AMPLITUDE_127
@ DAC_LSFR_BIT60_AMPLITUDE_127
Definition: at32f435_437_dac.h:99
DAC_LSFR_BIT50_AMPLITUDE_63
@ DAC_LSFR_BIT50_AMPLITUDE_63
Definition: at32f435_437_dac.h:98
DAC_LSFR_BITA0_AMPLITUDE_2047
@ DAC_LSFR_BITA0_AMPLITUDE_2047
Definition: at32f435_437_dac.h:103
DAC_LSFR_BIT30_AMPLITUDE_15
@ DAC_LSFR_BIT30_AMPLITUDE_15
Definition: at32f435_437_dac.h:96
DAC_LSFR_BIT0_AMPLITUDE_1
@ DAC_LSFR_BIT0_AMPLITUDE_1
Definition: at32f435_437_dac.h:93
DAC_TMR4_TRGOUT_EVENT
@ DAC_TMR4_TRGOUT_EVENT
Definition: at32f435_437_dac.h:73
DAC_TMR2_TRGOUT_EVENT
@ DAC_TMR2_TRGOUT_EVENT
Definition: at32f435_437_dac.h:72
DAC_TMR7_TRGOUT_EVENT
@ DAC_TMR7_TRGOUT_EVENT
Definition: at32f435_437_dac.h:70
DAC_TMR5_TRGOUT_EVENT
@ DAC_TMR5_TRGOUT_EVENT
Definition: at32f435_437_dac.h:71
DAC_EXTERNAL_INTERRUPT_LINE_9
@ DAC_EXTERNAL_INTERRUPT_LINE_9
Definition: at32f435_437_dac.h:74
DAC_TMR8_TRGOUT_EVENT
@ DAC_TMR8_TRGOUT_EVENT
Definition: at32f435_437_dac.h:69
DAC_TMR6_TRGOUT_EVENT
@ DAC_TMR6_TRGOUT_EVENT
Definition: at32f435_437_dac.h:68
DAC_SOFTWARE_TRIGGER
@ DAC_SOFTWARE_TRIGGER
Definition: at32f435_437_dac.h:75
DAC_DUAL_12BIT_LEFT
@ DAC_DUAL_12BIT_LEFT
Definition: at32f435_437_dac.h:133
DAC_DUAL_8BIT_RIGHT
@ DAC_DUAL_8BIT_RIGHT
Definition: at32f435_437_dac.h:134
DAC_DUAL_12BIT_RIGHT
@ DAC_DUAL_12BIT_RIGHT
Definition: at32f435_437_dac.h:132
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
dac_type
type define dac register all
Definition: at32f435_437_dac.h:141
dac_type::d2dmaudrien
__IO uint32_t d2dmaudrien
Definition: at32f435_437_dac.h:166
dac_type::d1obdis
__IO uint32_t d1obdis
Definition: at32f435_437_dac.h:151
dac_type::d2dmaudrf
__IO uint32_t d2dmaudrf
Definition: at32f435_437_dac.h:344
dac_type::d2dth8r
__IO uint32_t d2dth8r
Definition: at32f435_437_dac.h:255
dac_type::ctrl
__IO uint32_t ctrl
Definition: at32f435_437_dac.h:147
dac_type::dd2dt8r
__IO uint32_t dd2dt8r
Definition: at32f435_437_dac.h:302
dac_type::dd2dt12l
__IO uint32_t dd2dt12l
Definition: at32f435_437_dac.h:289
dac_type::d2dt12l
__IO uint32_t d2dt12l
Definition: at32f435_437_dac.h:245
dac_type::ddth12l
__IO uint32_t ddth12l
Definition: at32f435_437_dac.h:283
dac_type::d2odt
__IO uint32_t d2odt
Definition: at32f435_437_dac.h:325
dac_type::d2dth12r
__IO uint32_t d2dth12r
Definition: at32f435_437_dac.h:229
dac_type::d1dth12r
__IO uint32_t d1dth12r
Definition: at32f435_437_dac.h:190
dac_type::d2swtrg
__IO uint32_t d2swtrg
Definition: at32f435_437_dac.h:180
dac_type::ddth8r
__IO uint32_t ddth8r
Definition: at32f435_437_dac.h:298
dac_type::d2trgsel
__IO uint32_t d2trgsel
Definition: at32f435_437_dac.h:162
dac_type::dd1dt12l
__IO uint32_t dd1dt12l
Definition: at32f435_437_dac.h:287
dac_type::d1nm
__IO uint32_t d1nm
Definition: at32f435_437_dac.h:154
dac_type::d1dmaudrien
__IO uint32_t d1dmaudrien
Definition: at32f435_437_dac.h:157
dac_type::d1dt12l
__IO uint32_t d1dt12l
Definition: at32f435_437_dac.h:206
dac_type::d2dt12r
__IO uint32_t d2dt12r
Definition: at32f435_437_dac.h:232
dac_type::d2dth12l
__IO uint32_t d2dth12l
Definition: at32f435_437_dac.h:242
dac_type::dd1dt8r
__IO uint32_t dd1dt8r
Definition: at32f435_437_dac.h:301
dac_type::d2en
__IO uint32_t d2en
Definition: at32f435_437_dac.h:159
dac_type::sts
__IO uint32_t sts
Definition: at32f435_437_dac.h:338
dac_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_dac.h:158
dac_type::d1trgsel
__IO uint32_t d1trgsel
Definition: at32f435_437_dac.h:153
dac_type::d1dth8r
__IO uint32_t d1dth8r
Definition: at32f435_437_dac.h:216
dac_type::swtrg
__IO uint32_t swtrg
Definition: at32f435_437_dac.h:176
dac_type::d2nbsel
__IO uint32_t d2nbsel
Definition: at32f435_437_dac.h:164
dac_type::d1dmaudrf
__IO uint32_t d1dmaudrf
Definition: at32f435_437_dac.h:342
dac_type::d1dth12l
__IO uint32_t d1dth12l
Definition: at32f435_437_dac.h:203
dac_type::d2dt8r
__IO uint32_t d2dt8r
Definition: at32f435_437_dac.h:258
dac_type::d2trgen
__IO uint32_t d2trgen
Definition: at32f435_437_dac.h:161
dac_type::d2nm
__IO uint32_t d2nm
Definition: at32f435_437_dac.h:163
dac_type::d1trgen
__IO uint32_t d1trgen
Definition: at32f435_437_dac.h:152
dac_type::d1dt12r
__IO uint32_t d1dt12r
Definition: at32f435_437_dac.h:193
dac_type::d1dt8r
__IO uint32_t d1dt8r
Definition: at32f435_437_dac.h:219
dac_type::d1swtrg
__IO uint32_t d1swtrg
Definition: at32f435_437_dac.h:179
dac_type::dd2dt12r
__IO uint32_t dd2dt12r
Definition: at32f435_437_dac.h:273
dac_type::d1dmaen
__IO uint32_t d1dmaen
Definition: at32f435_437_dac.h:156
dac_type::d2obdis
__IO uint32_t d2obdis
Definition: at32f435_437_dac.h:160
dac_type::d1odt
__IO uint32_t d1odt
Definition: at32f435_437_dac.h:312
dac_type::d2dmaen
__IO uint32_t d2dmaen
Definition: at32f435_437_dac.h:165
dac_type::d1nbsel
__IO uint32_t d1nbsel
Definition: at32f435_437_dac.h:155
dac_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_dac.h:167
dac_type::ddth12r
__IO uint32_t ddth12r
Definition: at32f435_437_dac.h:268
dac_type::d1en
__IO uint32_t d1en
Definition: at32f435_437_dac.h:150
dac_type::dd1dt12r
__IO uint32_t dd1dt12r
Definition: at32f435_437_dac.h:271
dac_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_dac.h:345


AT32F435/437 Firmwary Library: at32f435_437_debug.c Source File

  • libraries
  • drivers
  • src
at32f435_437_debug.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef DEBUG_MODULE_ENABLED
39
49uint32_t debug_device_id_get(void)
50{
51 return DEBUGMCU->pid;
52}
63void debug_low_power_mode_set(uint32_t low_power_mode, confirm_state new_state)
64{
65 if(new_state != FALSE)
66 {
67 DEBUGMCU->ctrl |= low_power_mode;
68 }
69 else
70 {
71 DEBUGMCU->ctrl &= ~low_power_mode;
72 }
73}
90void debug_apb1_periph_mode_set(uint32_t apb1_periph, confirm_state new_state)
91{
92 if(new_state != FALSE)
93 {
94 DEBUGMCU->apb1_frz |= apb1_periph;
95 }
96 else
97 {
98 DEBUGMCU->apb1_frz &= ~apb1_periph;
99 }
100}
111void debug_apb2_periph_mode_set(uint32_t apb2_periph, confirm_state new_state)
112{
113 if(new_state != FALSE)
114 {
115 DEBUGMCU->apb2_frz |= apb2_periph;
116 }
117 else
118 {
119 DEBUGMCU->apb2_frz &= ~apb2_periph;
120 }
121}
122
127#endif
128
debug_apb2_periph_mode_set
void debug_apb2_periph_mode_set(uint32_t apb2_periph, confirm_state new_state)
set apb2 periph debug mode
Definition: at32f435_437_debug.c:111
debug_apb1_periph_mode_set
void debug_apb1_periph_mode_set(uint32_t apb1_periph, confirm_state new_state)
set apb1 periph debug mode
Definition: at32f435_437_debug.c:90
debug_low_power_mode_set
void debug_low_power_mode_set(uint32_t low_power_mode, confirm_state new_state)
set periph debug mode
Definition: at32f435_437_debug.c:63
debug_device_id_get
uint32_t debug_device_id_get(void)
get debug device id
Definition: at32f435_437_debug.c:49
DEBUGMCU
#define DEBUGMCU
Definition: at32f435_437_debug.h:181
confirm_state
confirm_state
Definition: at32f435_437.h:379
FALSE
@ FALSE
Definition: at32f435_437.h:379
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_debug.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_debug.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_MCUDBG_H
29#define __AT32F435_437_MCUDBG_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
51/* debug ctrl register bit */
52#define DEBUG_SLEEP 0x00000001
53#define DEBUG_DEEPSLEEP 0x00000002
54#define DEBUG_STANDBY 0x00000004
56/* debug apb1 frz register bit */
57#define DEBUG_TMR2_PAUSE 0x00000001
58#define DEBUG_TMR3_PAUSE 0x00000002
59#define DEBUG_TMR4_PAUSE 0x00000004
60#define DEBUG_TMR5_PAUSE 0x00000008
61#define DEBUG_TMR6_PAUSE 0x00000010
62#define DEBUG_TMR7_PAUSE 0x00000020
63#define DEBUG_TMR12_PAUSE 0x00000040
64#define DEBUG_TMR13_PAUSE 0x00000080
65#define DEBUG_TMR14_PAUSE 0x00000100
66#define DEBUG_ERTC_PAUSE 0x00000400
67#define DEBUG_WWDT_PAUSE 0x00000800
68#define DEBUG_WDT_PAUSE 0x00001000
69#define DEBUG_ERTC_512_PAUSE 0x00008000
70#define DEBUG_I2C1_SMBUS_TIMEOUT 0x01000000
71#define DEBUG_I2C2_SMBUS_TIMEOUT 0x08000000
72#define DEBUG_I2C3_SMBUS_TIMEOUT 0x10000000
73#define DEBUG_CAN1_PAUSE 0x02000000
74#define DEBUG_CAN2_PAUSE 0x04000000
76/* debug apb2 frz register bit */
77#define DEBUG_TMR1_PAUSE 0x00000001
78#define DEBUG_TMR8_PAUSE 0x00000002
79#define DEBUG_TMR20_PAUSE 0x00000040
80#define DEBUG_TMR9_PAUSE 0x00010000
81#define DEBUG_TMR10_PAUSE 0x00020000
82#define DEBUG_TMR11_PAUSE 0x00040000
95typedef struct
96{
100 union
101 {
102 __IO uint32_t pid;
103 struct
104 {
105 __IO uint32_t pid : 32;/* [31:0] */
106 } idcode_bit;
107 };
108
112 union
113 {
114 __IO uint32_t ctrl;
115 struct
116 {
117 __IO uint32_t sleep_debug : 1;/* [0] */
118 __IO uint32_t deepsleep_debug : 1;/* [1] */
119 __IO uint32_t standby_debug : 1;/* [2] */
120 __IO uint32_t reserved1 : 29;/* [31:3] */
121 } ctrl_bit;
122 };
126 union
127 {
128 __IO uint32_t apb1_frz;
129 struct
130 {
131 __IO uint32_t tmr2_pause : 1;/* [0] */
132 __IO uint32_t tmr3_pause : 1;/* [1] */
133 __IO uint32_t tmr4_pause : 1;/* [2] */
134 __IO uint32_t tmr5_pause : 1;/* [3] */
135 __IO uint32_t tmr6_pause : 1;/* [4] */
136 __IO uint32_t tmr7_pause : 1;/* [5] */
137 __IO uint32_t tmr12_pause : 1;/* [6] */
138 __IO uint32_t tmr13_pause : 1;/* [7] */
139 __IO uint32_t tmr14_pause : 1;/* [8] */
140 __IO uint32_t reserved1 : 1;/* [9] */
141 __IO uint32_t ertc_pause : 1;/* [10] */
142 __IO uint32_t wwdt_pause : 1;/* [11] */
143 __IO uint32_t wdt_pause : 1;/* [12] */
144 __IO uint32_t reserved2 : 2;/* [14:13] */
145 __IO uint32_t ertc_512_pause : 1;/* [15] */
146 __IO uint32_t reserved3 : 8;/* [23:16] */
147 __IO uint32_t i2c1_smbus_timeout : 1;/* [24] */
148 __IO uint32_t can1_pause : 1;/* [25] */
149 __IO uint32_t can2_pause : 1;/* [26] */
150 __IO uint32_t i2c2_smbus_timeout : 1;/* [27] */
151 __IO uint32_t i2c3_smbus_timeout : 1;/* [28] */
152 __IO uint32_t reserved4 : 3;/* [31:29] */
153 } apb1_frz_bit;
154 };
158 union
159 {
160 __IO uint32_t apb2_frz;
161 struct
162 {
163 __IO uint32_t tmr1_pause : 1;/* [0] */
164 __IO uint32_t tmr8_pause : 1;/* [1] */
165 __IO uint32_t reserved1 : 4;/* [5:2] */
166 __IO uint32_t tmr20_pause : 1;/* [6] */
167 __IO uint32_t reserved2 : 9;/* [15:7] */
168 __IO uint32_t tmr9_pause : 1;/* [16] */
169 __IO uint32_t tmr10_pause : 1;/* [17] */
170 __IO uint32_t tmr11_pause : 1;/* [18] */
171 __IO uint32_t reserved3 : 13;/* [31:19] */
172 } apb2_frz_bit;
173 };
174
175} debug_type;
176
181#define DEBUGMCU ((debug_type *) DEBUG_BASE)
182
187uint32_t debug_device_id_get(void);
188void debug_low_power_mode_set(uint32_t low_power_mode, confirm_state new_state);
189void debug_apb1_periph_mode_set(uint32_t apb1_periph, confirm_state new_state);
190void debug_apb2_periph_mode_set(uint32_t apb2_periph, confirm_state new_state);
191
204#ifdef __cplusplus
205}
206#endif
207
208#endif
at32f435_437.h
at32f435_437 header file
debug_apb2_periph_mode_set
void debug_apb2_periph_mode_set(uint32_t apb2_periph, confirm_state new_state)
set apb2 periph debug mode
Definition: at32f435_437_debug.c:111
debug_apb1_periph_mode_set
void debug_apb1_periph_mode_set(uint32_t apb1_periph, confirm_state new_state)
set apb1 periph debug mode
Definition: at32f435_437_debug.c:90
debug_low_power_mode_set
void debug_low_power_mode_set(uint32_t low_power_mode, confirm_state new_state)
set periph debug mode
Definition: at32f435_437_debug.c:63
debug_device_id_get
uint32_t debug_device_id_get(void)
get debug device id
Definition: at32f435_437_debug.c:49
confirm_state
confirm_state
Definition: at32f435_437.h:379
debug_type
type define debug register all
Definition: at32f435_437_debug.h:96
debug_type::can2_pause
__IO uint32_t can2_pause
Definition: at32f435_437_debug.h:149
debug_type::tmr11_pause
__IO uint32_t tmr11_pause
Definition: at32f435_437_debug.h:170
debug_type::apb2_frz
__IO uint32_t apb2_frz
Definition: at32f435_437_debug.h:160
debug_type::i2c2_smbus_timeout
__IO uint32_t i2c2_smbus_timeout
Definition: at32f435_437_debug.h:150
debug_type::tmr12_pause
__IO uint32_t tmr12_pause
Definition: at32f435_437_debug.h:137
debug_type::pid
__IO uint32_t pid
Definition: at32f435_437_debug.h:102
debug_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_debug.h:144
debug_type::tmr20_pause
__IO uint32_t tmr20_pause
Definition: at32f435_437_debug.h:166
debug_type::sleep_debug
__IO uint32_t sleep_debug
Definition: at32f435_437_debug.h:117
debug_type::tmr8_pause
__IO uint32_t tmr8_pause
Definition: at32f435_437_debug.h:164
debug_type::ctrl
__IO uint32_t ctrl
Definition: at32f435_437_debug.h:114
debug_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_debug.h:146
debug_type::tmr9_pause
__IO uint32_t tmr9_pause
Definition: at32f435_437_debug.h:168
debug_type::tmr13_pause
__IO uint32_t tmr13_pause
Definition: at32f435_437_debug.h:138
debug_type::tmr2_pause
__IO uint32_t tmr2_pause
Definition: at32f435_437_debug.h:131
debug_type::wdt_pause
__IO uint32_t wdt_pause
Definition: at32f435_437_debug.h:143
debug_type::deepsleep_debug
__IO uint32_t deepsleep_debug
Definition: at32f435_437_debug.h:118
debug_type::tmr1_pause
__IO uint32_t tmr1_pause
Definition: at32f435_437_debug.h:163
debug_type::i2c1_smbus_timeout
__IO uint32_t i2c1_smbus_timeout
Definition: at32f435_437_debug.h:147
debug_type::tmr14_pause
__IO uint32_t tmr14_pause
Definition: at32f435_437_debug.h:139
debug_type::reserved4
__IO uint32_t reserved4
Definition: at32f435_437_debug.h:152
debug_type::standby_debug
__IO uint32_t standby_debug
Definition: at32f435_437_debug.h:119
debug_type::tmr10_pause
__IO uint32_t tmr10_pause
Definition: at32f435_437_debug.h:169
debug_type::ertc_pause
__IO uint32_t ertc_pause
Definition: at32f435_437_debug.h:141
debug_type::apb1_frz
__IO uint32_t apb1_frz
Definition: at32f435_437_debug.h:128
debug_type::wwdt_pause
__IO uint32_t wwdt_pause
Definition: at32f435_437_debug.h:142
debug_type::can1_pause
__IO uint32_t can1_pause
Definition: at32f435_437_debug.h:148
debug_type::tmr6_pause
__IO uint32_t tmr6_pause
Definition: at32f435_437_debug.h:135
debug_type::tmr4_pause
__IO uint32_t tmr4_pause
Definition: at32f435_437_debug.h:133
debug_type::tmr5_pause
__IO uint32_t tmr5_pause
Definition: at32f435_437_debug.h:134
debug_type::i2c3_smbus_timeout
__IO uint32_t i2c3_smbus_timeout
Definition: at32f435_437_debug.h:151
debug_type::tmr3_pause
__IO uint32_t tmr3_pause
Definition: at32f435_437_debug.h:132
debug_type::ertc_512_pause
__IO uint32_t ertc_512_pause
Definition: at32f435_437_debug.h:145
debug_type::tmr7_pause
__IO uint32_t tmr7_pause
Definition: at32f435_437_debug.h:136
debug_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_debug.h:120


AT32F435/437 Firmwary Library: at32f435_437_def.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_def.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_DEF_H
29#define __AT32F435_437_DEF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* gnu compiler */
36#if defined (__GNUC__)
37 #ifndef ALIGNED_HEAD
38 #define ALIGNED_HEAD
39 #endif
40 #ifndef ALIGNED_TAIL
41 #define ALIGNED_TAIL __attribute__ ((aligned (4)))
42 #endif
43#endif
44
45/* arm compiler */
46#if defined (__CC_ARM)
47 #ifndef ALIGNED_HEAD
48 #define ALIGNED_HEAD __align(4)
49 #endif
50 #ifndef ALIGNED_TAIL
51 #define ALIGNED_TAIL
52 #endif
53#endif
54
55/* iar compiler */
56#if defined (__ICCARM__)
57 #ifndef ALIGNED_HEAD
58 #define ALIGNED_HEAD
59 #endif
60 #ifndef ALIGNED_TAIL
61 #define ALIGNED_TAIL
62 #endif
63#endif
64
65#define UNUSED(x) (void)x /* to avoid gcc/g++ warnings */
66
67#ifdef __cplusplus
68}
69#endif
70
71#endif


AT32F435/437 Firmwary Library: at32f435_437_dma.c Source File

  • libraries
  • drivers
  • src
at32f435_437_dma.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef DMA_MODULE_ENABLED
39
64void dma_reset(dma_channel_type *dmax_channely)
65{
66 uint32_t temp = 0;
67 dmax_channely->ctrl_bit.chen = FALSE;
68 dmax_channely->ctrl = 0;
69 dmax_channely->dtcnt = 0;
70 dmax_channely->paddr = 0;
71 dmax_channely->maddr = 0;
72
73 temp = (uint32_t)dmax_channely;
74
75 if((temp & 0x6FF) < 0x608)
76 {
77 /* dma1 channel */
78 DMA1->clr |= (uint32_t)(0x0F << ((((temp & 0xFF) - 0x08) / 0x14) * 4));
79 }
80 else if((temp & 0x6FF) < 0x688)
81 {
82 /* dma2 channel */
83 DMA2->clr |= (uint32_t)(0x0F << ((((temp & 0xFF) - 0x08) / 0x14) * 4));
84 }
85}
86
108void dma_data_number_set(dma_channel_type *dmax_channely, uint16_t data_number)
109{
110 dmax_channely->dtcnt = data_number;
111}
112
133uint16_t dma_data_number_get(dma_channel_type *dmax_channely)
134{
135 return (uint16_t)dmax_channely->dtcnt;
136}
137
164void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
165{
166 if(new_state != FALSE)
167 {
168 dmax_channely->ctrl |= dma_int;
169 }
170 else
171 {
172 dmax_channely->ctrl &= ~dma_int;
173 }
174}
175
197void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
198{
199 dmax_channely->ctrl_bit.chen = new_state;
200}
201
221 flag_status dma_flag_get(uint32_t dmax_flag)
222{
223 uint32_t temp = 0;
224
225 if(dmax_flag > 0x10000000)
226 {
227 temp = DMA2->sts;
228 }
229 else
230 {
231 temp = DMA1->sts;
232 }
233
234 if((temp & dmax_flag) != RESET)
235 {
236 return SET;
237 }
238 else
239 {
240 return RESET;
241 }
242}
243
264void dma_flag_clear(uint32_t dmax_flag)
265{
266 if(dmax_flag > ((uint32_t)0x10000000))
267 {
268 DMA2->clr = (uint32_t)(dmax_flag & 0x0FFFFFFF);
269 }
270 else
271 {
272 DMA1->clr = dmax_flag;
273 }
274}
275
281void dma_default_para_init(dma_init_type *dma_init_struct)
282{
283 dma_init_struct->peripheral_base_addr = 0;
284 dma_init_struct->memory_base_addr = 0;
285 dma_init_struct->direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
286 dma_init_struct->buffer_size = 0;
287 dma_init_struct->peripheral_inc_enable = FALSE;
288 dma_init_struct->memory_inc_enable = FALSE;
289 dma_init_struct->peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
290 dma_init_struct->memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
291 dma_init_struct->loop_mode_enable = FALSE;
292 dma_init_struct->priority = DMA_PRIORITY_LOW;
293}
294
316void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
317{
318 /* clear ctrl register dtd bit and m2m bit */
319 dmax_channely->ctrl &= 0xbfef;
320 dmax_channely->ctrl |= dma_init_struct->direction;
321
322 dmax_channely->ctrl_bit.chpl = dma_init_struct->priority;
323 dmax_channely->ctrl_bit.mwidth = dma_init_struct->memory_data_width;
324 dmax_channely->ctrl_bit.pwidth = dma_init_struct->peripheral_data_width;
325 dmax_channely->ctrl_bit.mincm = dma_init_struct->memory_inc_enable;
326 dmax_channely->ctrl_bit.pincm = dma_init_struct->peripheral_inc_enable;
327 dmax_channely->ctrl_bit.lm = dma_init_struct->loop_mode_enable;
328 dmax_channely->dtcnt_bit.cnt = dma_init_struct->buffer_size;
329 dmax_channely->paddr = dma_init_struct->peripheral_base_addr;
330 dmax_channely->maddr = dma_init_struct->memory_base_addr;
331}
379void dma_flexible_config(dma_type* dma_x, dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
380{
381 dma_x->muxsel_bit.tblsel = TRUE;
382 dmamux_channelx->muxctrl_bit.reqsel = dmamux_req_sel;
383}
384
391void dmamux_enable(dma_type *dma_x, confirm_state new_state)
392{
393 dma_x->muxsel_bit.tblsel = new_state;
394}
395
442void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
443{
444 dmamux_channelx->muxctrl_bit.reqsel = dmamux_req_sel;
445}
446
452void dmamux_sync_default_para_init(dmamux_sync_init_type *dmamux_sync_init_struct)
453{
454 dmamux_sync_init_struct->sync_enable = FALSE;
455 dmamux_sync_init_struct->sync_event_enable = FALSE;
456 dmamux_sync_init_struct->sync_polarity = DMAMUX_SYNC_POLARITY_DISABLE;
457 dmamux_sync_init_struct->sync_request_number = 0x0;
458 dmamux_sync_init_struct->sync_signal_sel = (dmamux_sync_id_sel_type)0;
459}
460
482void dmamux_sync_config(dmamux_channel_type *dmamux_channelx, dmamux_sync_init_type *dmamux_sync_init_struct)
483{
484 dmamux_channelx->muxctrl_bit.syncsel = dmamux_sync_init_struct->sync_signal_sel;
485 dmamux_channelx->muxctrl_bit.syncpol = dmamux_sync_init_struct->sync_polarity;
486 dmamux_channelx->muxctrl_bit.reqcnt = dmamux_sync_init_struct->sync_request_number;
487 dmamux_channelx->muxctrl_bit.evtgen = dmamux_sync_init_struct->sync_event_enable;
488 dmamux_channelx->muxctrl_bit.syncen = dmamux_sync_init_struct->sync_enable;
489}
490
496void dmamux_generator_default_para_init(dmamux_gen_init_type *dmamux_gen_init_struct)
497{
498 dmamux_gen_init_struct->gen_enable = FALSE;
499 dmamux_gen_init_struct->gen_polarity = DMAMUX_GEN_POLARITY_DISABLE;
500 dmamux_gen_init_struct->gen_request_number = 0x0;
501 dmamux_gen_init_struct->gen_signal_sel = (dmamux_gen_id_sel_type)0x0;
502}
503
519void dmamux_generator_config(dmamux_generator_type *dmamux_gen_x, dmamux_gen_init_type *dmamux_gen_init_struct)
520{
521 dmamux_gen_x->gctrl_bit.sigsel = dmamux_gen_init_struct->gen_signal_sel;
522 dmamux_gen_x->gctrl_bit.gpol = dmamux_gen_init_struct->gen_polarity;
523 dmamux_gen_x->gctrl_bit.greqcnt = dmamux_gen_init_struct->gen_request_number;
524 dmamux_gen_x->gctrl_bit.gen = dmamux_gen_init_struct->gen_enable;
525}
526
548void dmamux_sync_interrupt_enable(dmamux_channel_type *dmamux_channelx, confirm_state new_state)
549{
550 if(new_state != FALSE)
551 {
552 dmamux_channelx->muxctrl_bit.syncovien = TRUE;
553 }
554 else
555 {
556 dmamux_channelx->muxctrl_bit.syncovien = FALSE;
557 }
558}
559
575void dmamux_generator_interrupt_enable(dmamux_generator_type *dmamux_gen_x, confirm_state new_state)
576{
577 if(new_state != FALSE)
578 {
579 dmamux_gen_x->gctrl_bit.trgovien = TRUE;
580 }
581 else
582 {
583 dmamux_gen_x->gctrl_bit.trgovien = FALSE;
584 }
585}
586
601 flag_status dmamux_sync_flag_get(dma_type *dma_x, uint32_t flag)
602{
603 if((dma_x->muxsyncsts & flag) != RESET)
604 {
605 return SET;
606 }
607 else
608 {
609 return RESET;
610 }
611}
612
627void dmamux_sync_flag_clear(dma_type *dma_x, uint32_t flag)
628{
629 dma_x->muxsyncclr = flag;
630}
631
643 flag_status dmamux_generator_flag_get(dma_type *dma_x, uint32_t flag)
644{
645 if((dma_x->muxgsts & flag) != RESET)
646 {
647 return SET;
648 }
649 else
650 {
651 return RESET;
652 }
653}
654
666void dmamux_generator_flag_clear(dma_type *dma_x, uint32_t flag)
667{
668 dma_x->muxgclr = flag;
669}
670
675#endif
676
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
dmamux_gen_init_struct
dmamux_gen_init_type dmamux_gen_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:40
dmamux_sync_init_struct
dmamux_sync_init_type dmamux_sync_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c:40
dmamux_gen_id_sel_type
dmamux_gen_id_sel_type
dmamux generator id type
Definition: at32f435_437_dma.h:335
dmamux_sync_id_sel_type
dmamux_sync_id_sel_type
dmamux sync id type
Definition: at32f435_437_dma.h:294
dmamux_requst_id_sel_type
dmamux_requst_id_sel_type
dmamux request type
Definition: at32f435_437_dma.h:192
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:162
DMAMUX_GEN_POLARITY_DISABLE
@ DMAMUX_GEN_POLARITY_DISABLE
Definition: at32f435_437_dma.h:366
DMAMUX_SYNC_POLARITY_DISABLE
@ DMAMUX_SYNC_POLARITY_DISABLE
Definition: at32f435_437_dma.h:325
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:172
DMA_PRIORITY_LOW
@ DMA_PRIORITY_LOW
Definition: at32f435_437_dma.h:182
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dmamux_generator_interrupt_enable
void dmamux_generator_interrupt_enable(dmamux_generator_type *dmamux_gen_x, confirm_state new_state)
enable or disable the dmamux request generator interrupts.
Definition: at32f435_437_dma.c:575
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dmamux_generator_config
void dmamux_generator_config(dmamux_generator_type *dmamux_gen_x, dmamux_gen_init_type *dmamux_gen_init_struct)
dmamux request generator init.
Definition: at32f435_437_dma.c:519
dmamux_sync_config
void dmamux_sync_config(dmamux_channel_type *dmamux_channelx, dmamux_sync_init_type *dmamux_sync_init_struct)
dmamux synchronization config.
Definition: at32f435_437_dma.c:482
dmamux_generator_default_para_init
void dmamux_generator_default_para_init(dmamux_gen_init_type *dmamux_gen_init_struct)
dmamux request generator init struct config with its default value.
Definition: at32f435_437_dma.c:496
dmamux_sync_default_para_init
void dmamux_sync_default_para_init(dmamux_sync_init_type *dmamux_sync_init_struct)
dmamux sync init struct config with its default value.
Definition: at32f435_437_dma.c:452
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_data_number_get
uint16_t dma_data_number_get(dma_channel_type *dmax_channely)
get the number of data to be transferred.
Definition: at32f435_437_dma.c:133
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dmamux_generator_flag_get
flag_status dmamux_generator_flag_get(dma_type *dma_x, uint32_t flag)
dmamux request generator flag get.
Definition: at32f435_437_dma.c:643
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
dma_data_number_set
void dma_data_number_set(dma_channel_type *dmax_channely, uint16_t data_number)
set the number of data to be transferred.
Definition: at32f435_437_dma.c:108
dmamux_generator_flag_clear
void dmamux_generator_flag_clear(dma_type *dma_x, uint32_t flag)
dmamux request generator flag clear.
Definition: at32f435_437_dma.c:666
dmamux_sync_interrupt_enable
void dmamux_sync_interrupt_enable(dmamux_channel_type *dmamux_channelx, confirm_state new_state)
enable or disable the dmamux sync interrupts.
Definition: at32f435_437_dma.c:548
dma_flexible_config
void dma_flexible_config(dma_type *dma_x, dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:379
dmamux_sync_flag_get
flag_status dmamux_sync_flag_get(dma_type *dma_x, uint32_t flag)
dmamux sync flag get.
Definition: at32f435_437_dma.c:601
dmamux_sync_flag_clear
void dmamux_sync_flag_clear(dma_type *dma_x, uint32_t flag)
dmamux sync flag clear.
Definition: at32f435_437_dma.c:627
DMA2
#define DMA2
Definition: at32f435_437_dma.h:717
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
dma_channel_type
type define dma channel register all
Definition: at32f435_437_dma.h:576
dma_channel_type::dtcnt
__IO uint32_t dtcnt
Definition: at32f435_437_dma.h:606
dma_channel_type::cnt
__IO uint32_t cnt
Definition: at32f435_437_dma.h:609
dma_channel_type::pwidth
__IO uint32_t pwidth
Definition: at32f435_437_dma.h:593
dma_channel_type::paddr
__IO uint32_t paddr
Definition: at32f435_437_dma.h:619
dma_channel_type::mincm
__IO uint32_t mincm
Definition: at32f435_437_dma.h:592
dma_channel_type::ctrl_bit
struct dma_channel_type::@312::@320 ctrl_bit
dma_channel_type::chen
__IO uint32_t chen
Definition: at32f435_437_dma.h:585
dma_channel_type::lm
__IO uint32_t lm
Definition: at32f435_437_dma.h:590
dma_channel_type::mwidth
__IO uint32_t mwidth
Definition: at32f435_437_dma.h:594
dma_channel_type::maddr
__IO uint32_t maddr
Definition: at32f435_437_dma.h:631
dma_channel_type::dtcnt_bit
struct dma_channel_type::@314::@321 dtcnt_bit
dma_channel_type::pincm
__IO uint32_t pincm
Definition: at32f435_437_dma.h:591
dma_channel_type::ctrl
__IO uint32_t ctrl
Definition: at32f435_437_dma.h:582
dma_channel_type::chpl
__IO uint32_t chpl
Definition: at32f435_437_dma.h:595
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
dma_type
type define dma1 register
Definition: at32f435_437_dma.h:416
dma_type::tblsel
__IO uint32_t tblsel
Definition: at32f435_437_dma.h:510
dma_type::muxsel_bit
struct dma_type::@295::@307 muxsel_bit
dma_type::muxgclr
__IO uint32_t muxgclr
Definition: at32f435_437_dma.h:563
dma_type::muxsyncclr
__IO uint32_t muxsyncclr
Definition: at32f435_437_dma.h:538
dma_type::muxgsts
__IO uint32_t muxgsts
Definition: at32f435_437_dma.h:551
dma_type::muxsyncsts
__IO uint32_t muxsyncsts
Definition: at32f435_437_dma.h:525
dmamux_channel_type
type define dmamux muxsctrl register
Definition: at32f435_437_dma.h:643
dmamux_channel_type::muxctrl_bit
struct dmamux_channel_type::@324::@326 muxctrl_bit
dmamux_channel_type::evtgen
__IO uint32_t evtgen
Definition: at32f435_437_dma.h:655
dmamux_channel_type::syncovien
__IO uint32_t syncovien
Definition: at32f435_437_dma.h:654
dmamux_channel_type::syncen
__IO uint32_t syncen
Definition: at32f435_437_dma.h:657
dmamux_channel_type::syncpol
__IO uint32_t syncpol
Definition: at32f435_437_dma.h:658
dmamux_channel_type::reqsel
__IO uint32_t reqsel
Definition: at32f435_437_dma.h:652
dmamux_channel_type::syncsel
__IO uint32_t syncsel
Definition: at32f435_437_dma.h:660
dmamux_channel_type::reqcnt
__IO uint32_t reqcnt
Definition: at32f435_437_dma.h:659
dmamux_gen_init_type
dmamux generator init type
Definition: at32f435_437_dma.h:405
dmamux_gen_init_type::gen_enable
confirm_state gen_enable
Definition: at32f435_437_dma.h:409
dmamux_gen_init_type::gen_request_number
uint32_t gen_request_number
Definition: at32f435_437_dma.h:408
dmamux_gen_init_type::gen_signal_sel
dmamux_gen_id_sel_type gen_signal_sel
Definition: at32f435_437_dma.h:406
dmamux_gen_init_type::gen_polarity
dmamux_gen_pol_type gen_polarity
Definition: at32f435_437_dma.h:407
dmamux_generator_type
type define dmamux request generator register all
Definition: at32f435_437_dma.h:670
dmamux_generator_type::gen
__IO uint32_t gen
Definition: at32f435_437_dma.h:683
dmamux_generator_type::gpol
__IO uint32_t gpol
Definition: at32f435_437_dma.h:684
dmamux_generator_type::gctrl_bit
struct dmamux_generator_type::@327::@329 gctrl_bit
dmamux_generator_type::trgovien
__IO uint32_t trgovien
Definition: at32f435_437_dma.h:681
dmamux_generator_type::greqcnt
__IO uint32_t greqcnt
Definition: at32f435_437_dma.h:685
dmamux_generator_type::sigsel
__IO uint32_t sigsel
Definition: at32f435_437_dma.h:679
dmamux_sync_init_type
dmamux sync init type
Definition: at32f435_437_dma.h:393
dmamux_sync_init_type::sync_enable
confirm_state sync_enable
Definition: at32f435_437_dma.h:398
dmamux_sync_init_type::sync_request_number
uint32_t sync_request_number
Definition: at32f435_437_dma.h:396
dmamux_sync_init_type::sync_event_enable
confirm_state sync_event_enable
Definition: at32f435_437_dma.h:397
dmamux_sync_init_type::sync_polarity
uint32_t sync_polarity
Definition: at32f435_437_dma.h:395
dmamux_sync_init_type::sync_signal_sel
dmamux_sync_id_sel_type sync_signal_sel
Definition: at32f435_437_dma.h:394
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_dma.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_dma.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_DMA_H
29#define __AT32F435_437_DMA_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
52#define DMA_FDT_INT ((uint32_t)0x00000002)
53#define DMA_HDT_INT ((uint32_t)0x00000004)
54#define DMA_DTERR_INT ((uint32_t)0x00000008)
65#define DMA1_GL1_FLAG ((uint32_t)0x00000001)
66#define DMA1_FDT1_FLAG ((uint32_t)0x00000002)
67#define DMA1_HDT1_FLAG ((uint32_t)0x00000004)
68#define DMA1_DTERR1_FLAG ((uint32_t)0x00000008)
69#define DMA1_GL2_FLAG ((uint32_t)0x00000010)
70#define DMA1_FDT2_FLAG ((uint32_t)0x00000020)
71#define DMA1_HDT2_FLAG ((uint32_t)0x00000040)
72#define DMA1_DTERR2_FLAG ((uint32_t)0x00000080)
73#define DMA1_GL3_FLAG ((uint32_t)0x00000100)
74#define DMA1_FDT3_FLAG ((uint32_t)0x00000200)
75#define DMA1_HDT3_FLAG ((uint32_t)0x00000400)
76#define DMA1_DTERR3_FLAG ((uint32_t)0x00000800)
77#define DMA1_GL4_FLAG ((uint32_t)0x00001000)
78#define DMA1_FDT4_FLAG ((uint32_t)0x00002000)
79#define DMA1_HDT4_FLAG ((uint32_t)0x00004000)
80#define DMA1_DTERR4_FLAG ((uint32_t)0x00008000)
81#define DMA1_GL5_FLAG ((uint32_t)0x00010000)
82#define DMA1_FDT5_FLAG ((uint32_t)0x00020000)
83#define DMA1_HDT5_FLAG ((uint32_t)0x00040000)
84#define DMA1_DTERR5_FLAG ((uint32_t)0x00080000)
85#define DMA1_GL6_FLAG ((uint32_t)0x00100000)
86#define DMA1_FDT6_FLAG ((uint32_t)0x00200000)
87#define DMA1_HDT6_FLAG ((uint32_t)0x00400000)
88#define DMA1_DTERR6_FLAG ((uint32_t)0x00800000)
89#define DMA1_GL7_FLAG ((uint32_t)0x01000000)
90#define DMA1_FDT7_FLAG ((uint32_t)0x02000000)
91#define DMA1_HDT7_FLAG ((uint32_t)0x04000000)
92#define DMA1_DTERR7_FLAG ((uint32_t)0x08000000)
94#define DMA2_GL1_FLAG ((uint32_t)0x10000001)
95#define DMA2_FDT1_FLAG ((uint32_t)0x10000002)
96#define DMA2_HDT1_FLAG ((uint32_t)0x10000004)
97#define DMA2_DTERR1_FLAG ((uint32_t)0x10000008)
98#define DMA2_GL2_FLAG ((uint32_t)0x10000010)
99#define DMA2_FDT2_FLAG ((uint32_t)0x10000020)
100#define DMA2_HDT2_FLAG ((uint32_t)0x10000040)
101#define DMA2_DTERR2_FLAG ((uint32_t)0x10000080)
102#define DMA2_GL3_FLAG ((uint32_t)0x10000100)
103#define DMA2_FDT3_FLAG ((uint32_t)0x10000200)
104#define DMA2_HDT3_FLAG ((uint32_t)0x10000400)
105#define DMA2_DTERR3_FLAG ((uint32_t)0x10000800)
106#define DMA2_GL4_FLAG ((uint32_t)0x10001000)
107#define DMA2_FDT4_FLAG ((uint32_t)0x10002000)
108#define DMA2_HDT4_FLAG ((uint32_t)0x10004000)
109#define DMA2_DTERR4_FLAG ((uint32_t)0x10008000)
110#define DMA2_GL5_FLAG ((uint32_t)0x10010000)
111#define DMA2_FDT5_FLAG ((uint32_t)0x10020000)
112#define DMA2_HDT5_FLAG ((uint32_t)0x10040000)
113#define DMA2_DTERR5_FLAG ((uint32_t)0x10080000)
114#define DMA2_GL6_FLAG ((uint32_t)0x10100000)
115#define DMA2_FDT6_FLAG ((uint32_t)0x10200000)
116#define DMA2_HDT6_FLAG ((uint32_t)0x10400000)
117#define DMA2_DTERR6_FLAG ((uint32_t)0x10800000)
118#define DMA2_GL7_FLAG ((uint32_t)0x11000000)
119#define DMA2_FDT7_FLAG ((uint32_t)0x12000000)
120#define DMA2_HDT7_FLAG ((uint32_t)0x14000000)
121#define DMA2_DTERR7_FLAG ((uint32_t)0x18000000)
126#define DMAMUX_SYNC_OV1_FLAG ((uint32_t)0x00000001)
127#define DMAMUX_SYNC_OV2_FLAG ((uint32_t)0x00000002)
128#define DMAMUX_SYNC_OV3_FLAG ((uint32_t)0x00000004)
129#define DMAMUX_SYNC_OV4_FLAG ((uint32_t)0x00000008)
130#define DMAMUX_SYNC_OV5_FLAG ((uint32_t)0x00000010)
131#define DMAMUX_SYNC_OV6_FLAG ((uint32_t)0x00000020)
132#define DMAMUX_SYNC_OV7_FLAG ((uint32_t)0x00000040)
134#define DMAMUX_GEN_TRIG_OV1_FLAG ((uint32_t)0x00000001)
135#define DMAMUX_GEN_TRIG_OV2_FLAG ((uint32_t)0x00000002)
136#define DMAMUX_GEN_TRIG_OV3_FLAG ((uint32_t)0x00000004)
137#define DMAMUX_GEN_TRIG_OV4_FLAG ((uint32_t)0x00000008)
150typedef enum
151{
152 DMA_DIR_PERIPHERAL_TO_MEMORY = 0x0000,
153 DMA_DIR_MEMORY_TO_PERIPHERAL = 0x0010,
154 DMA_DIR_MEMORY_TO_MEMORY = 0x4000
155} dma_dir_type;
156
160typedef enum
161{
162 DMA_PERIPHERAL_DATA_WIDTH_BYTE = 0x00,
163 DMA_PERIPHERAL_DATA_WIDTH_HALFWORD = 0x01,
164 DMA_PERIPHERAL_DATA_WIDTH_WORD = 0x02
165} dma_peripheral_data_size_type;
166
170typedef enum
171{
172 DMA_MEMORY_DATA_WIDTH_BYTE = 0x00,
173 DMA_MEMORY_DATA_WIDTH_HALFWORD = 0x01,
174 DMA_MEMORY_DATA_WIDTH_WORD = 0x02
175} dma_memory_data_size_type;
176
180typedef enum
181{
182 DMA_PRIORITY_LOW = 0x00,
183 DMA_PRIORITY_MEDIUM = 0x01,
184 DMA_PRIORITY_HIGH = 0x02,
185 DMA_PRIORITY_VERY_HIGH = 0x03
186} dma_priority_level_type;
187
191typedef enum
192{
193 DMAMUX_DMAREQ_ID_REQ_G1 = 0x01,
194 DMAMUX_DMAREQ_ID_REQ_G2 = 0x02,
195 DMAMUX_DMAREQ_ID_REQ_G3 = 0x03,
196 DMAMUX_DMAREQ_ID_REQ_G4 = 0x04,
197 DMAMUX_DMAREQ_ID_ADC1 = 0x05,
198 DMAMUX_DMAREQ_ID_ADC2 = 0x24,
199 DMAMUX_DMAREQ_ID_ADC3 = 0x25,
200 DMAMUX_DMAREQ_ID_DAC1 = 0x06,
201 DMAMUX_DMAREQ_ID_DAC2 = 0x29,
202 DMAMUX_DMAREQ_ID_TMR6_OVERFLOW = 0x08,
203 DMAMUX_DMAREQ_ID_TMR7_OVERFLOW = 0x09,
204 DMAMUX_DMAREQ_ID_SPI1_RX = 0x0A,
205 DMAMUX_DMAREQ_ID_SPI1_TX = 0x0B,
206 DMAMUX_DMAREQ_ID_SPI2_RX = 0x0C,
207 DMAMUX_DMAREQ_ID_SPI2_TX = 0x0D,
208 DMAMUX_DMAREQ_ID_SPI3_RX = 0x0E,
209 DMAMUX_DMAREQ_ID_SPI3_TX = 0x0F,
210 DMAMUX_DMAREQ_ID_SPI4_RX = 0x6A,
211 DMAMUX_DMAREQ_ID_SPI4_TX = 0x6B,
212 DMAMUX_DMAREQ_ID_I2S2_EXT_RX = 0x6E,
213 DMAMUX_DMAREQ_ID_I2S2_EXT_TX = 0x6F,
214 DMAMUX_DMAREQ_ID_I2S3_EXT_RX = 0x70,
215 DMAMUX_DMAREQ_ID_I2S3_EXT_TX = 0x71,
216 DMAMUX_DMAREQ_ID_I2C1_RX = 0x10,
217 DMAMUX_DMAREQ_ID_I2C1_TX = 0x11,
218 DMAMUX_DMAREQ_ID_I2C2_RX = 0x12,
219 DMAMUX_DMAREQ_ID_I2C2_TX = 0x13,
220 DMAMUX_DMAREQ_ID_I2C3_RX = 0x14,
221 DMAMUX_DMAREQ_ID_I2C3_TX = 0x15,
222 DMAMUX_DMAREQ_ID_USART1_RX = 0x18,
223 DMAMUX_DMAREQ_ID_USART1_TX = 0x19,
224 DMAMUX_DMAREQ_ID_USART2_RX = 0x1A,
225 DMAMUX_DMAREQ_ID_USART2_TX = 0x1B,
226 DMAMUX_DMAREQ_ID_USART3_RX = 0x1C,
227 DMAMUX_DMAREQ_ID_USART3_TX = 0x1D,
228 DMAMUX_DMAREQ_ID_UART4_RX = 0x1E,
229 DMAMUX_DMAREQ_ID_UART4_TX = 0x1F,
230 DMAMUX_DMAREQ_ID_UART5_RX = 0x20,
231 DMAMUX_DMAREQ_ID_UART5_TX = 0x21,
232 DMAMUX_DMAREQ_ID_USART6_RX = 0x72,
233 DMAMUX_DMAREQ_ID_USART6_TX = 0x73,
234 DMAMUX_DMAREQ_ID_UART7_RX = 0x74,
235 DMAMUX_DMAREQ_ID_UART7_TX = 0x75,
236 DMAMUX_DMAREQ_ID_UART8_RX = 0x76,
237 DMAMUX_DMAREQ_ID_UART8_TX = 0x77,
238 DMAMUX_DMAREQ_ID_SDIO1 = 0x27,
239 DMAMUX_DMAREQ_ID_SDIO2 = 0x67,
240 DMAMUX_DMAREQ_ID_QSPI1 = 0x28,
241 DMAMUX_DMAREQ_ID_QSPI2 = 0x68,
242 DMAMUX_DMAREQ_ID_TMR1_CH1 = 0x2A,
243 DMAMUX_DMAREQ_ID_TMR1_CH2 = 0x2B,
244 DMAMUX_DMAREQ_ID_TMR1_CH3 = 0x2C,
245 DMAMUX_DMAREQ_ID_TMR1_CH4 = 0x2D,
246 DMAMUX_DMAREQ_ID_TMR1_OVERFLOW = 0x2E,
247 DMAMUX_DMAREQ_ID_TMR1_TRIG = 0x2F,
248 DMAMUX_DMAREQ_ID_TMR1_HALL = 0x30,
249 DMAMUX_DMAREQ_ID_TMR8_CH1 = 0x31,
250 DMAMUX_DMAREQ_ID_TMR8_CH2 = 0x32,
251 DMAMUX_DMAREQ_ID_TMR8_CH3 = 0x33,
252 DMAMUX_DMAREQ_ID_TMR8_CH4 = 0x34,
253 DMAMUX_DMAREQ_ID_TMR8_OVERFLOW = 0x35,
254 DMAMUX_DMAREQ_ID_TMR8_TRIG = 0x36,
255 DMAMUX_DMAREQ_ID_TMR8_HALL = 0x37,
256 DMAMUX_DMAREQ_ID_TMR2_CH1 = 0x38,
257 DMAMUX_DMAREQ_ID_TMR2_CH2 = 0x39,
258 DMAMUX_DMAREQ_ID_TMR2_CH3 = 0x3A,
259 DMAMUX_DMAREQ_ID_TMR2_CH4 = 0x3B,
260 DMAMUX_DMAREQ_ID_TMR2_OVERFLOW = 0x3C,
261 DMAMUX_DMAREQ_ID_TMR2_TRIG = 0x7E,
262 DMAMUX_DMAREQ_ID_TMR3_CH1 = 0x3D,
263 DMAMUX_DMAREQ_ID_TMR3_CH2 = 0x3E,
264 DMAMUX_DMAREQ_ID_TMR3_CH3 = 0x3F,
265 DMAMUX_DMAREQ_ID_TMR3_CH4 = 0x40,
266 DMAMUX_DMAREQ_ID_TMR3_OVERFLOW = 0x41,
267 DMAMUX_DMAREQ_ID_TMR3_TRIG = 0x42,
268 DMAMUX_DMAREQ_ID_TMR4_CH1 = 0x43,
269 DMAMUX_DMAREQ_ID_TMR4_CH2 = 0x44,
270 DMAMUX_DMAREQ_ID_TMR4_CH3 = 0x45,
271 DMAMUX_DMAREQ_ID_TMR4_CH4 = 0x46,
272 DMAMUX_DMAREQ_ID_TMR4_OVERFLOW = 0x47,
273 DMAMUX_DMAREQ_ID_TMR4_TRIG = 0x7F,
274 DMAMUX_DMAREQ_ID_TMR5_CH1 = 0x48,
275 DMAMUX_DMAREQ_ID_TMR5_CH2 = 0x49,
276 DMAMUX_DMAREQ_ID_TMR5_CH3 = 0x4A,
277 DMAMUX_DMAREQ_ID_TMR5_CH4 = 0x4B,
278 DMAMUX_DMAREQ_ID_TMR5_OVERFLOW = 0x4C,
279 DMAMUX_DMAREQ_ID_TMR5_TRIG = 0x4D,
280 DMAMUX_DMAREQ_ID_TMR20_CH1 = 0x56,
281 DMAMUX_DMAREQ_ID_TMR20_CH2 = 0x57,
282 DMAMUX_DMAREQ_ID_TMR20_CH3 = 0x58,
283 DMAMUX_DMAREQ_ID_TMR20_CH4 = 0x59,
284 DMAMUX_DMAREQ_ID_TMR20_OVERFLOW = 0x5A,
285 DMAMUX_DMAREQ_ID_TMR20_TRIG = 0x5D,
286 DMAMUX_DMAREQ_ID_TMR20_HALL = 0x5E,
287 DMAMUX_DMAREQ_ID_DVP = 0x69
288} dmamux_requst_id_sel_type;
289
293typedef enum
294{
295 DMAMUX_SYNC_ID_EXINT0 = 0x00,
296 DMAMUX_SYNC_ID_EXINT1 = 0x01,
297 DMAMUX_SYNC_ID_EXINT2 = 0x02,
298 DMAMUX_SYNC_ID_EXINT3 = 0x03,
299 DMAMUX_SYNC_ID_EXINT4 = 0x04,
300 DMAMUX_SYNC_ID_EXINT5 = 0x05,
301 DMAMUX_SYNC_ID_EXINT6 = 0x06,
302 DMAMUX_SYNC_ID_EXINT7 = 0x07,
303 DMAMUX_SYNC_ID_EXINT8 = 0x08,
304 DMAMUX_SYNC_ID_EXINT9 = 0x09,
305 DMAMUX_SYNC_ID_EXINT10 = 0x0A,
306 DMAMUX_SYNC_ID_EXINT11 = 0x0B,
307 DMAMUX_SYNC_ID_EXINT12 = 0x0C,
308 DMAMUX_SYNC_ID_EXINT13 = 0x0D,
309 DMAMUX_SYNC_ID_EXINT14 = 0x0E,
310 DMAMUX_SYNC_ID_EXINT15 = 0x0F,
311 DMAMUX_SYNC_ID_DMAMUX_CH1_EVT = 0x10,
312 DMAMUX_SYNC_ID_DMAMUX_CH2_EVT = 0x11,
313 DMAMUX_SYNC_ID_DMAMUX_CH3_EVT = 0x12,
314 DMAMUX_SYNC_ID_DMAMUX_CH4_EVT = 0x13,
315 DMAMUX_SYNC_ID_DMAMUX_CH5_EVT = 0x14,
316 DMAMUX_SYNC_ID_DMAMUX_CH6_EVT = 0x15,
317 DMAMUX_SYNC_ID_DMAMUX_CH7_EVT = 0x16
318} dmamux_sync_id_sel_type;
319
323typedef enum
324{
325 DMAMUX_SYNC_POLARITY_DISABLE = 0x00,
326 DMAMUX_SYNC_POLARITY_RISING = 0x01,
327 DMAMUX_SYNC_POLARITY_FALLING = 0x02,
328 DMAMUX_SYNC_POLARITY_RISING_FALLING = 0x03
329} dmamux_sync_pol_type;
330
334typedef enum
335{
336 DMAMUX_GEN_ID_EXINT0 = 0x00,
337 DMAMUX_GEN_ID_EXINT1 = 0x01,
338 DMAMUX_GEN_ID_EXINT2 = 0x02,
339 DMAMUX_GEN_ID_EXINT3 = 0x03,
340 DMAMUX_GEN_ID_EXINT4 = 0x04,
341 DMAMUX_GEN_ID_EXINT5 = 0x05,
342 DMAMUX_GEN_ID_EXINT6 = 0x06,
343 DMAMUX_GEN_ID_EXINT7 = 0x07,
344 DMAMUX_GEN_ID_EXINT8 = 0x08,
345 DMAMUX_GEN_ID_EXINT9 = 0x09,
346 DMAMUX_GEN_ID_EXINT10 = 0x0A,
347 DMAMUX_GEN_ID_EXINT11 = 0x0B,
348 DMAMUX_GEN_ID_EXINT12 = 0x0C,
349 DMAMUX_GEN_ID_EXINT13 = 0x0D,
350 DMAMUX_GEN_ID_EXINT14 = 0x0E,
351 DMAMUX_GEN_ID_EXINT15 = 0x0F,
352 DMAMUX_GEN_ID_DMAMUX_CH1_EVT = 0x10,
353 DMAMUX_GEN_ID_DMAMUX_CH2_EVT = 0x11,
354 DMAMUX_GEN_ID_DMAMUX_CH3_EVT = 0x12,
355 DMAMUX_GEN_ID_DMAMUX_CH4_EVT = 0x13,
356 DMAMUX_GEN_ID_DMAMUX_CH5_EVT = 0x14,
357 DMAMUX_GEN_ID_DMAMUX_CH6_EVT = 0x15,
358 DMAMUX_GEN_ID_DMAMUX_CH7_EVT = 0x16
359} dmamux_gen_id_sel_type;
360
364typedef enum
365{
366 DMAMUX_GEN_POLARITY_DISABLE = 0x00,
367 DMAMUX_GEN_POLARITY_RISING = 0x01,
368 DMAMUX_GEN_POLARITY_FALLING = 0x02,
369 DMAMUX_GEN_POLARITY_RISING_FALLING = 0x03
370} dmamux_gen_pol_type;
371
375typedef struct
376{
377 uint32_t peripheral_base_addr;
378 uint32_t memory_base_addr;
379 dma_dir_type direction;
380 uint16_t buffer_size;
381 confirm_state peripheral_inc_enable;
382 confirm_state memory_inc_enable;
383 dma_peripheral_data_size_type peripheral_data_width;
384 dma_memory_data_size_type memory_data_width;
385 confirm_state loop_mode_enable;
386 dma_priority_level_type priority;
387} dma_init_type;
388
392typedef struct
393{
394 dmamux_sync_id_sel_type sync_signal_sel;
395 uint32_t sync_polarity;
396 uint32_t sync_request_number;
397 confirm_state sync_event_enable;
398 confirm_state sync_enable;
399} dmamux_sync_init_type;
400
404typedef struct
405{
406 dmamux_gen_id_sel_type gen_signal_sel;
407 dmamux_gen_pol_type gen_polarity;
408 uint32_t gen_request_number;
409 confirm_state gen_enable;
410} dmamux_gen_init_type;
411
415typedef struct
416{
420 union
421 {
422 __IO uint32_t sts;
423 struct
424 {
425 __IO uint32_t gf1 : 1; /* [0] */
426 __IO uint32_t fdtf1 : 1; /* [1] */
427 __IO uint32_t hdtf1 : 1; /* [2] */
428 __IO uint32_t dterrf1 : 1; /* [3] */
429 __IO uint32_t gf2 : 1; /* [4] */
430 __IO uint32_t fdtf2 : 1; /* [5] */
431 __IO uint32_t hdtf2 : 1; /* [6] */
432 __IO uint32_t dterrf2 : 1; /* [7] */
433 __IO uint32_t gf3 : 1; /* [8] */
434 __IO uint32_t fdtf3 : 1; /* [9] */
435 __IO uint32_t hdtf3 : 1; /* [10] */
436 __IO uint32_t dterrf3 : 1; /* [11] */
437 __IO uint32_t gf4 : 1; /* [12] */
438 __IO uint32_t fdtf4 : 1; /* [13] */
439 __IO uint32_t hdtf4 : 1; /* [14] */
440 __IO uint32_t dterrf4 : 1; /* [15] */
441 __IO uint32_t gf5 : 1; /* [16] */
442 __IO uint32_t fdtf5 : 1; /* [17] */
443 __IO uint32_t hdtf5 : 1; /* [18] */
444 __IO uint32_t dterrf5 : 1; /* [19] */
445 __IO uint32_t gf6 : 1; /* [20] */
446 __IO uint32_t fdtf6 : 1; /* [21] */
447 __IO uint32_t hdtf6 : 1; /* [22] */
448 __IO uint32_t dterrf6 : 1; /* [23] */
449 __IO uint32_t gf7 : 1; /* [24] */
450 __IO uint32_t fdtf7 : 1; /* [25] */
451 __IO uint32_t hdtf7 : 1; /* [26] */
452 __IO uint32_t dterrf7 : 1; /* [27] */
453 __IO uint32_t reserved1 : 4; /* [31:28] */
454 } sts_bit;
455 };
456
460 union
461 {
462 __IO uint32_t clr;
463 struct
464 {
465 __IO uint32_t gfc1 : 1; /* [0] */
466 __IO uint32_t fdtfc1 : 1; /* [1] */
467 __IO uint32_t hdtfc1 : 1; /* [2] */
468 __IO uint32_t dterrfc1 : 1; /* [3] */
469 __IO uint32_t gfc2 : 1; /* [4] */
470 __IO uint32_t fdtfc2 : 1; /* [5] */
471 __IO uint32_t hdtfc2 : 1; /* [6] */
472 __IO uint32_t dterrfc2 : 1; /* [7] */
473 __IO uint32_t gfc3 : 1; /* [8] */
474 __IO uint32_t fdtfc3 : 1; /* [9] */
475 __IO uint32_t hdtfc3 : 1; /* [10] */
476 __IO uint32_t dterrfc3 : 1; /* [11] */
477 __IO uint32_t gfc4 : 1; /* [12] */
478 __IO uint32_t fdtfc4 : 1; /* [13] */
479 __IO uint32_t hdtfc4 : 1; /* [14] */
480 __IO uint32_t dterrfc4 : 1; /* [15] */
481 __IO uint32_t gfc5 : 1; /* [16] */
482 __IO uint32_t fdtfc5 : 1; /* [17] */
483 __IO uint32_t hdtfc5 : 1; /* [18] */
484 __IO uint32_t dterrfc5 : 1; /* [19] */
485 __IO uint32_t gfc6 : 1; /* [20] */
486 __IO uint32_t fdtfc6 : 1; /* [21] */
487 __IO uint32_t hdtfc6 : 1; /* [22] */
488 __IO uint32_t dterrfc6 : 1; /* [23] */
489 __IO uint32_t gfc7 : 1; /* [24] */
490 __IO uint32_t fdtfc7 : 1; /* [25] */
491 __IO uint32_t hdtfc7 : 1; /* [26] */
492 __IO uint32_t dterrfc7 : 1; /* [27] */
493 __IO uint32_t reserved1 : 4; /* [31:28] */
494 } clr_bit;
495 };
496
500 __IO uint32_t reserved1[62];
501
505 union
506 {
507 __IO uint32_t muxsel;
508 struct
509 {
510 __IO uint32_t tblsel : 1; /* [0] */
511 __IO uint32_t reserved1 : 31;/* [31:1] */
512 }muxsel_bit;
513 };
514
518 __IO uint32_t reserved2[11];
519
523 union
524 {
525 __IO uint32_t muxsyncsts;
526 struct
527 {
528 __IO uint32_t syncovf : 7; /* [6:0] */
529 __IO uint32_t reserved1 : 25;/* [31:7] */
530 }muxsyncsts_bit;
531 };
532
536 union
537 {
538 __IO uint32_t muxsyncclr;
539 struct
540 {
541 __IO uint32_t syncovfc : 7; /* [6:0] */
542 __IO uint32_t reserved1 : 25;/* [31:7] */
543 }muxsyncclr_bit;
544 };
545
549 union
550 {
551 __IO uint32_t muxgsts;
552 struct
553 {
554 __IO uint32_t trgovf : 4; /* [3:0] */
555 __IO uint32_t reserved1 : 28;/* [31:4] */
556 }muxgsts_bit;
557 };
561 union
562 {
563 __IO uint32_t muxgclr;
564 struct
565 {
566 __IO uint32_t trgovfc : 4; /* [3:0] */
567 __IO uint32_t reserved1 : 28;/* [31:4] */
568 }muxgclr_bit;
569 };
570} dma_type;
571
575typedef struct
576{
580 union
581 {
582 __IO uint32_t ctrl;
583 struct
584 {
585 __IO uint32_t chen : 1; /* [0] */
586 __IO uint32_t fdtien : 1; /* [1] */
587 __IO uint32_t hdtien : 1; /* [2] */
588 __IO uint32_t dterrien : 1; /* [3] */
589 __IO uint32_t dtd : 1; /* [4] */
590 __IO uint32_t lm : 1; /* [5] */
591 __IO uint32_t pincm : 1; /* [6] */
592 __IO uint32_t mincm : 1; /* [7] */
593 __IO uint32_t pwidth : 2; /* [9:8] */
594 __IO uint32_t mwidth : 2; /* [11:10] */
595 __IO uint32_t chpl : 2; /* [13:12] */
596 __IO uint32_t m2m : 1; /* [14] */
597 __IO uint32_t reserved1 : 17;/* [31:15] */
598 } ctrl_bit;
599 };
600
604 union
605 {
606 __IO uint32_t dtcnt;
607 struct
608 {
609 __IO uint32_t cnt : 16;/* [15:0] */
610 __IO uint32_t reserved1 : 16;/* [31:16] */
611 } dtcnt_bit;
612 };
613
617 union
618 {
619 __IO uint32_t paddr;
620 struct
621 {
622 __IO uint32_t paddr : 32;/* [31:0] */
623 } paddr_bit;
624 };
625
629 union
630 {
631 __IO uint32_t maddr;
632 struct
633 {
634 __IO uint32_t maddr : 32;/* [31:0] */
635 } maddr_bit;
636 };
637} dma_channel_type;
638
642typedef struct
643{
647 union
648 {
649 __IO uint32_t muxctrl;
650 struct
651 {
652 __IO uint32_t reqsel : 7; /* [6:0] */
653 __IO uint32_t reserved1 : 1; /* [7] */
654 __IO uint32_t syncovien : 1; /* [8] */
655 __IO uint32_t evtgen : 1; /* [9] */
656 __IO uint32_t reserved2 : 6; /* [15:10] */
657 __IO uint32_t syncen : 1; /* [16] */
658 __IO uint32_t syncpol : 2; /* [18:17] */
659 __IO uint32_t reqcnt : 5; /* [23:19] */
660 __IO uint32_t syncsel : 5; /* [28:24] */
661 __IO uint32_t reserved3 : 3; /* [31:29] */
662 }muxctrl_bit;
663 };
664} dmamux_channel_type;
665
669typedef struct
670{
674 union
675 {
676 __IO uint32_t gctrl;
677 struct
678 {
679 __IO uint32_t sigsel : 5; /* [4:0] */
680 __IO uint32_t reserved1 : 3; /* [7:5] */
681 __IO uint32_t trgovien : 1; /* [8] */
682 __IO uint32_t reserved2 : 7; /* [15:9] */
683 __IO uint32_t gen : 1; /* [16] */
684 __IO uint32_t gpol : 2; /* [18:17] */
685 __IO uint32_t greqcnt : 5; /* [23:19] */
686 __IO uint32_t reserved3 : 8; /* [31:24] */
687 }gctrl_bit;
688 };
689} dmamux_generator_type;
690
695#define DMA1 ((dma_type *) DMA1_BASE)
696#define DMA1_CHANNEL1 ((dma_channel_type *) DMA1_CHANNEL1_BASE)
697#define DMA1_CHANNEL2 ((dma_channel_type *) DMA1_CHANNEL2_BASE)
698#define DMA1_CHANNEL3 ((dma_channel_type *) DMA1_CHANNEL3_BASE)
699#define DMA1_CHANNEL4 ((dma_channel_type *) DMA1_CHANNEL4_BASE)
700#define DMA1_CHANNEL5 ((dma_channel_type *) DMA1_CHANNEL5_BASE)
701#define DMA1_CHANNEL6 ((dma_channel_type *) DMA1_CHANNEL6_BASE)
702#define DMA1_CHANNEL7 ((dma_channel_type *) DMA1_CHANNEL7_BASE)
703
704#define DMA1MUX_CHANNEL1 ((dmamux_channel_type *) DMA1MUX_CHANNEL1_BASE)
705#define DMA1MUX_CHANNEL2 ((dmamux_channel_type *) DMA1MUX_CHANNEL2_BASE)
706#define DMA1MUX_CHANNEL3 ((dmamux_channel_type *) DMA1MUX_CHANNEL3_BASE)
707#define DMA1MUX_CHANNEL4 ((dmamux_channel_type *) DMA1MUX_CHANNEL4_BASE)
708#define DMA1MUX_CHANNEL5 ((dmamux_channel_type *) DMA1MUX_CHANNEL5_BASE)
709#define DMA1MUX_CHANNEL6 ((dmamux_channel_type *) DMA1MUX_CHANNEL6_BASE)
710#define DMA1MUX_CHANNEL7 ((dmamux_channel_type *) DMA1MUX_CHANNEL7_BASE)
711
712#define DMA1MUX_GENERATOR1 ((dmamux_generator_type *) DMA1MUX_GENERATOR1_BASE)
713#define DMA1MUX_GENERATOR2 ((dmamux_generator_type *) DMA1MUX_GENERATOR2_BASE)
714#define DMA1MUX_GENERATOR3 ((dmamux_generator_type *) DMA1MUX_GENERATOR3_BASE)
715#define DMA1MUX_GENERATOR4 ((dmamux_generator_type *) DMA1MUX_GENERATOR4_BASE)
716
717#define DMA2 ((dma_type *) DMA2_BASE)
718#define DMA2_CHANNEL1 ((dma_channel_type *) DMA2_CHANNEL1_BASE)
719#define DMA2_CHANNEL2 ((dma_channel_type *) DMA2_CHANNEL2_BASE)
720#define DMA2_CHANNEL3 ((dma_channel_type *) DMA2_CHANNEL3_BASE)
721#define DMA2_CHANNEL4 ((dma_channel_type *) DMA2_CHANNEL4_BASE)
722#define DMA2_CHANNEL5 ((dma_channel_type *) DMA2_CHANNEL5_BASE)
723#define DMA2_CHANNEL6 ((dma_channel_type *) DMA2_CHANNEL6_BASE)
724#define DMA2_CHANNEL7 ((dma_channel_type *) DMA2_CHANNEL7_BASE)
725
726#define DMA2MUX_CHANNEL1 ((dmamux_channel_type *) DMA2MUX_CHANNEL1_BASE)
727#define DMA2MUX_CHANNEL2 ((dmamux_channel_type *) DMA2MUX_CHANNEL2_BASE)
728#define DMA2MUX_CHANNEL3 ((dmamux_channel_type *) DMA2MUX_CHANNEL3_BASE)
729#define DMA2MUX_CHANNEL4 ((dmamux_channel_type *) DMA2MUX_CHANNEL4_BASE)
730#define DMA2MUX_CHANNEL5 ((dmamux_channel_type *) DMA2MUX_CHANNEL5_BASE)
731#define DMA2MUX_CHANNEL6 ((dmamux_channel_type *) DMA2MUX_CHANNEL6_BASE)
732#define DMA2MUX_CHANNEL7 ((dmamux_channel_type *) DMA2MUX_CHANNEL7_BASE)
733
734#define DMA2MUX_GENERATOR1 ((dmamux_generator_type *) DMA2MUX_GENERATOR1_BASE)
735#define DMA2MUX_GENERATOR2 ((dmamux_generator_type *) DMA2MUX_GENERATOR2_BASE)
736#define DMA2MUX_GENERATOR3 ((dmamux_generator_type *) DMA2MUX_GENERATOR3_BASE)
737#define DMA2MUX_GENERATOR4 ((dmamux_generator_type *) DMA2MUX_GENERATOR4_BASE)
738
743/* dma controller function */
744void dma_reset(dma_channel_type *dmax_channely);
745void dma_data_number_set(dma_channel_type *dmax_channely, uint16_t data_number);
746uint16_t dma_data_number_get(dma_channel_type *dmax_channely);
747void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state);
748void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state);
749 flag_status dma_flag_get(uint32_t dmax_flag);
750void dma_flag_clear(uint32_t dmax_flag);
751void dma_default_para_init(dma_init_type *dma_init_struct);
752void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct);
753
754/* dma requst multiplexer function */
755void dma_flexible_config(dma_type* dma_x, dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel);
756void dmamux_enable(dma_type *dma_x, confirm_state new_state);
757void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel);
758void dmamux_sync_default_para_init(dmamux_sync_init_type *dmamux_sync_init_struct);
759void dmamux_sync_config(dmamux_channel_type *dmamux_channelx, dmamux_sync_init_type *dmamux_sync_init_struct);
760void dmamux_generator_default_para_init(dmamux_gen_init_type *dmamux_gen_init_struct);
761void dmamux_generator_config(dmamux_generator_type *dmamux_gen_x, dmamux_gen_init_type *dmamux_gen_init_struct);
762void dmamux_sync_interrupt_enable(dmamux_channel_type *dmamux_channelx, confirm_state new_state);
763void dmamux_generator_interrupt_enable(dmamux_generator_type *dmamux_gen_x, confirm_state new_state);
764 flag_status dmamux_sync_flag_get(dma_type *dma_x, uint32_t flag);
765void dmamux_sync_flag_clear(dma_type *dma_x, uint32_t flag);
766 flag_status dmamux_generator_flag_get(dma_type *dma_x, uint32_t flag);
767void dmamux_generator_flag_clear(dma_type *dma_x, uint32_t flag);
768
781#ifdef __cplusplus
782}
783#endif
784
785#endif
at32f435_437.h
at32f435_437 header file
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
dmamux_gen_init_struct
dmamux_gen_init_type dmamux_gen_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:40
dmamux_sync_init_struct
dmamux_sync_init_type dmamux_sync_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c:40
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dmamux_generator_interrupt_enable
void dmamux_generator_interrupt_enable(dmamux_generator_type *dmamux_gen_x, confirm_state new_state)
enable or disable the dmamux request generator interrupts.
Definition: at32f435_437_dma.c:575
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dmamux_generator_config
void dmamux_generator_config(dmamux_generator_type *dmamux_gen_x, dmamux_gen_init_type *dmamux_gen_init_struct)
dmamux request generator init.
Definition: at32f435_437_dma.c:519
dmamux_sync_config
void dmamux_sync_config(dmamux_channel_type *dmamux_channelx, dmamux_sync_init_type *dmamux_sync_init_struct)
dmamux synchronization config.
Definition: at32f435_437_dma.c:482
dmamux_generator_default_para_init
void dmamux_generator_default_para_init(dmamux_gen_init_type *dmamux_gen_init_struct)
dmamux request generator init struct config with its default value.
Definition: at32f435_437_dma.c:496
dmamux_sync_default_para_init
void dmamux_sync_default_para_init(dmamux_sync_init_type *dmamux_sync_init_struct)
dmamux sync init struct config with its default value.
Definition: at32f435_437_dma.c:452
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_data_number_get
uint16_t dma_data_number_get(dma_channel_type *dmax_channely)
get the number of data to be transferred.
Definition: at32f435_437_dma.c:133
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dmamux_generator_flag_get
flag_status dmamux_generator_flag_get(dma_type *dma_x, uint32_t flag)
dmamux request generator flag get.
Definition: at32f435_437_dma.c:643
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
dma_data_number_set
void dma_data_number_set(dma_channel_type *dmax_channely, uint16_t data_number)
set the number of data to be transferred.
Definition: at32f435_437_dma.c:108
dmamux_generator_flag_clear
void dmamux_generator_flag_clear(dma_type *dma_x, uint32_t flag)
dmamux request generator flag clear.
Definition: at32f435_437_dma.c:666
dmamux_sync_interrupt_enable
void dmamux_sync_interrupt_enable(dmamux_channel_type *dmamux_channelx, confirm_state new_state)
enable or disable the dmamux sync interrupts.
Definition: at32f435_437_dma.c:548
dma_flexible_config
void dma_flexible_config(dma_type *dma_x, dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:379
dmamux_sync_flag_get
flag_status dmamux_sync_flag_get(dma_type *dma_x, uint32_t flag)
dmamux sync flag get.
Definition: at32f435_437_dma.c:601
dmamux_sync_flag_clear
void dmamux_sync_flag_clear(dma_type *dma_x, uint32_t flag)
dmamux sync flag clear.
Definition: at32f435_437_dma.c:627
dma_peripheral_data_size_type
dma_peripheral_data_size_type
dma peripheral data size type
Definition: at32f435_437_dma.h:161
dmamux_gen_pol_type
dmamux_gen_pol_type
dmamux generator polarity type
Definition: at32f435_437_dma.h:365
dmamux_sync_pol_type
dmamux_sync_pol_type
dmamux sync polarity type
Definition: at32f435_437_dma.h:324
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f435_437_dma.h:151
dma_memory_data_size_type
dma_memory_data_size_type
dma memory data size type
Definition: at32f435_437_dma.h:171
dmamux_gen_id_sel_type
dmamux_gen_id_sel_type
dmamux generator id type
Definition: at32f435_437_dma.h:335
dma_priority_level_type
dma_priority_level_type
dma priority level type
Definition: at32f435_437_dma.h:181
dmamux_sync_id_sel_type
dmamux_sync_id_sel_type
dmamux sync id type
Definition: at32f435_437_dma.h:294
dmamux_requst_id_sel_type
dmamux_requst_id_sel_type
dmamux request type
Definition: at32f435_437_dma.h:192
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:164
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:162
DMAMUX_GEN_POLARITY_FALLING
@ DMAMUX_GEN_POLARITY_FALLING
Definition: at32f435_437_dma.h:368
DMAMUX_GEN_POLARITY_DISABLE
@ DMAMUX_GEN_POLARITY_DISABLE
Definition: at32f435_437_dma.h:366
DMAMUX_GEN_POLARITY_RISING
@ DMAMUX_GEN_POLARITY_RISING
Definition: at32f435_437_dma.h:367
DMAMUX_GEN_POLARITY_RISING_FALLING
@ DMAMUX_GEN_POLARITY_RISING_FALLING
Definition: at32f435_437_dma.h:369
DMAMUX_SYNC_POLARITY_RISING
@ DMAMUX_SYNC_POLARITY_RISING
Definition: at32f435_437_dma.h:326
DMAMUX_SYNC_POLARITY_FALLING
@ DMAMUX_SYNC_POLARITY_FALLING
Definition: at32f435_437_dma.h:327
DMAMUX_SYNC_POLARITY_DISABLE
@ DMAMUX_SYNC_POLARITY_DISABLE
Definition: at32f435_437_dma.h:325
DMAMUX_SYNC_POLARITY_RISING_FALLING
@ DMAMUX_SYNC_POLARITY_RISING_FALLING
Definition: at32f435_437_dma.h:328
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_DIR_MEMORY_TO_MEMORY
@ DMA_DIR_MEMORY_TO_MEMORY
Definition: at32f435_437_dma.h:154
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:174
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:172
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMAMUX_GEN_ID_EXINT15
@ DMAMUX_GEN_ID_EXINT15
Definition: at32f435_437_dma.h:351
DMAMUX_GEN_ID_EXINT1
@ DMAMUX_GEN_ID_EXINT1
Definition: at32f435_437_dma.h:337
DMAMUX_GEN_ID_DMAMUX_CH1_EVT
@ DMAMUX_GEN_ID_DMAMUX_CH1_EVT
Definition: at32f435_437_dma.h:352
DMAMUX_GEN_ID_EXINT0
@ DMAMUX_GEN_ID_EXINT0
Definition: at32f435_437_dma.h:336
DMAMUX_GEN_ID_DMAMUX_CH5_EVT
@ DMAMUX_GEN_ID_DMAMUX_CH5_EVT
Definition: at32f435_437_dma.h:356
DMAMUX_GEN_ID_DMAMUX_CH7_EVT
@ DMAMUX_GEN_ID_DMAMUX_CH7_EVT
Definition: at32f435_437_dma.h:358
DMAMUX_GEN_ID_DMAMUX_CH6_EVT
@ DMAMUX_GEN_ID_DMAMUX_CH6_EVT
Definition: at32f435_437_dma.h:357
DMAMUX_GEN_ID_EXINT2
@ DMAMUX_GEN_ID_EXINT2
Definition: at32f435_437_dma.h:338
DMAMUX_GEN_ID_DMAMUX_CH2_EVT
@ DMAMUX_GEN_ID_DMAMUX_CH2_EVT
Definition: at32f435_437_dma.h:353
DMAMUX_GEN_ID_EXINT8
@ DMAMUX_GEN_ID_EXINT8
Definition: at32f435_437_dma.h:344
DMAMUX_GEN_ID_DMAMUX_CH3_EVT
@ DMAMUX_GEN_ID_DMAMUX_CH3_EVT
Definition: at32f435_437_dma.h:354
DMAMUX_GEN_ID_EXINT9
@ DMAMUX_GEN_ID_EXINT9
Definition: at32f435_437_dma.h:345
DMAMUX_GEN_ID_EXINT11
@ DMAMUX_GEN_ID_EXINT11
Definition: at32f435_437_dma.h:347
DMAMUX_GEN_ID_EXINT14
@ DMAMUX_GEN_ID_EXINT14
Definition: at32f435_437_dma.h:350
DMAMUX_GEN_ID_EXINT12
@ DMAMUX_GEN_ID_EXINT12
Definition: at32f435_437_dma.h:348
DMAMUX_GEN_ID_EXINT5
@ DMAMUX_GEN_ID_EXINT5
Definition: at32f435_437_dma.h:341
DMAMUX_GEN_ID_EXINT10
@ DMAMUX_GEN_ID_EXINT10
Definition: at32f435_437_dma.h:346
DMAMUX_GEN_ID_DMAMUX_CH4_EVT
@ DMAMUX_GEN_ID_DMAMUX_CH4_EVT
Definition: at32f435_437_dma.h:355
DMAMUX_GEN_ID_EXINT7
@ DMAMUX_GEN_ID_EXINT7
Definition: at32f435_437_dma.h:343
DMAMUX_GEN_ID_EXINT4
@ DMAMUX_GEN_ID_EXINT4
Definition: at32f435_437_dma.h:340
DMAMUX_GEN_ID_EXINT13
@ DMAMUX_GEN_ID_EXINT13
Definition: at32f435_437_dma.h:349
DMAMUX_GEN_ID_EXINT3
@ DMAMUX_GEN_ID_EXINT3
Definition: at32f435_437_dma.h:339
DMAMUX_GEN_ID_EXINT6
@ DMAMUX_GEN_ID_EXINT6
Definition: at32f435_437_dma.h:342
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f435_437_dma.h:183
DMA_PRIORITY_VERY_HIGH
@ DMA_PRIORITY_VERY_HIGH
Definition: at32f435_437_dma.h:185
DMA_PRIORITY_LOW
@ DMA_PRIORITY_LOW
Definition: at32f435_437_dma.h:182
DMAMUX_SYNC_ID_EXINT9
@ DMAMUX_SYNC_ID_EXINT9
Definition: at32f435_437_dma.h:304
DMAMUX_SYNC_ID_EXINT10
@ DMAMUX_SYNC_ID_EXINT10
Definition: at32f435_437_dma.h:305
DMAMUX_SYNC_ID_EXINT7
@ DMAMUX_SYNC_ID_EXINT7
Definition: at32f435_437_dma.h:302
DMAMUX_SYNC_ID_DMAMUX_CH3_EVT
@ DMAMUX_SYNC_ID_DMAMUX_CH3_EVT
Definition: at32f435_437_dma.h:313
DMAMUX_SYNC_ID_DMAMUX_CH4_EVT
@ DMAMUX_SYNC_ID_DMAMUX_CH4_EVT
Definition: at32f435_437_dma.h:314
DMAMUX_SYNC_ID_EXINT8
@ DMAMUX_SYNC_ID_EXINT8
Definition: at32f435_437_dma.h:303
DMAMUX_SYNC_ID_EXINT0
@ DMAMUX_SYNC_ID_EXINT0
Definition: at32f435_437_dma.h:295
DMAMUX_SYNC_ID_EXINT3
@ DMAMUX_SYNC_ID_EXINT3
Definition: at32f435_437_dma.h:298
DMAMUX_SYNC_ID_EXINT15
@ DMAMUX_SYNC_ID_EXINT15
Definition: at32f435_437_dma.h:310
DMAMUX_SYNC_ID_DMAMUX_CH6_EVT
@ DMAMUX_SYNC_ID_DMAMUX_CH6_EVT
Definition: at32f435_437_dma.h:316
DMAMUX_SYNC_ID_DMAMUX_CH7_EVT
@ DMAMUX_SYNC_ID_DMAMUX_CH7_EVT
Definition: at32f435_437_dma.h:317
DMAMUX_SYNC_ID_EXINT6
@ DMAMUX_SYNC_ID_EXINT6
Definition: at32f435_437_dma.h:301
DMAMUX_SYNC_ID_EXINT5
@ DMAMUX_SYNC_ID_EXINT5
Definition: at32f435_437_dma.h:300
DMAMUX_SYNC_ID_EXINT13
@ DMAMUX_SYNC_ID_EXINT13
Definition: at32f435_437_dma.h:308
DMAMUX_SYNC_ID_DMAMUX_CH5_EVT
@ DMAMUX_SYNC_ID_DMAMUX_CH5_EVT
Definition: at32f435_437_dma.h:315
DMAMUX_SYNC_ID_EXINT14
@ DMAMUX_SYNC_ID_EXINT14
Definition: at32f435_437_dma.h:309
DMAMUX_SYNC_ID_EXINT4
@ DMAMUX_SYNC_ID_EXINT4
Definition: at32f435_437_dma.h:299
DMAMUX_SYNC_ID_DMAMUX_CH1_EVT
@ DMAMUX_SYNC_ID_DMAMUX_CH1_EVT
Definition: at32f435_437_dma.h:311
DMAMUX_SYNC_ID_EXINT11
@ DMAMUX_SYNC_ID_EXINT11
Definition: at32f435_437_dma.h:306
DMAMUX_SYNC_ID_EXINT12
@ DMAMUX_SYNC_ID_EXINT12
Definition: at32f435_437_dma.h:307
DMAMUX_SYNC_ID_EXINT2
@ DMAMUX_SYNC_ID_EXINT2
Definition: at32f435_437_dma.h:297
DMAMUX_SYNC_ID_DMAMUX_CH2_EVT
@ DMAMUX_SYNC_ID_DMAMUX_CH2_EVT
Definition: at32f435_437_dma.h:312
DMAMUX_SYNC_ID_EXINT1
@ DMAMUX_SYNC_ID_EXINT1
Definition: at32f435_437_dma.h:296
DMAMUX_DMAREQ_ID_TMR5_CH4
@ DMAMUX_DMAREQ_ID_TMR5_CH4
Definition: at32f435_437_dma.h:277
DMAMUX_DMAREQ_ID_TMR2_OVERFLOW
@ DMAMUX_DMAREQ_ID_TMR2_OVERFLOW
Definition: at32f435_437_dma.h:260
DMAMUX_DMAREQ_ID_TMR3_CH3
@ DMAMUX_DMAREQ_ID_TMR3_CH3
Definition: at32f435_437_dma.h:264
DMAMUX_DMAREQ_ID_TMR2_CH4
@ DMAMUX_DMAREQ_ID_TMR2_CH4
Definition: at32f435_437_dma.h:259
DMAMUX_DMAREQ_ID_TMR8_CH4
@ DMAMUX_DMAREQ_ID_TMR8_CH4
Definition: at32f435_437_dma.h:252
DMAMUX_DMAREQ_ID_TMR5_OVERFLOW
@ DMAMUX_DMAREQ_ID_TMR5_OVERFLOW
Definition: at32f435_437_dma.h:278
DMAMUX_DMAREQ_ID_SPI2_TX
@ DMAMUX_DMAREQ_ID_SPI2_TX
Definition: at32f435_437_dma.h:207
DMAMUX_DMAREQ_ID_TMR4_CH3
@ DMAMUX_DMAREQ_ID_TMR4_CH3
Definition: at32f435_437_dma.h:270
DMAMUX_DMAREQ_ID_DAC2
@ DMAMUX_DMAREQ_ID_DAC2
Definition: at32f435_437_dma.h:201
DMAMUX_DMAREQ_ID_SDIO1
@ DMAMUX_DMAREQ_ID_SDIO1
Definition: at32f435_437_dma.h:238
DMAMUX_DMAREQ_ID_QSPI1
@ DMAMUX_DMAREQ_ID_QSPI1
Definition: at32f435_437_dma.h:240
DMAMUX_DMAREQ_ID_TMR4_CH4
@ DMAMUX_DMAREQ_ID_TMR4_CH4
Definition: at32f435_437_dma.h:271
DMAMUX_DMAREQ_ID_DVP
@ DMAMUX_DMAREQ_ID_DVP
Definition: at32f435_437_dma.h:287
DMAMUX_DMAREQ_ID_UART5_TX
@ DMAMUX_DMAREQ_ID_UART5_TX
Definition: at32f435_437_dma.h:231
DMAMUX_DMAREQ_ID_TMR1_OVERFLOW
@ DMAMUX_DMAREQ_ID_TMR1_OVERFLOW
Definition: at32f435_437_dma.h:246
DMAMUX_DMAREQ_ID_UART5_RX
@ DMAMUX_DMAREQ_ID_UART5_RX
Definition: at32f435_437_dma.h:230
DMAMUX_DMAREQ_ID_SDIO2
@ DMAMUX_DMAREQ_ID_SDIO2
Definition: at32f435_437_dma.h:239
DMAMUX_DMAREQ_ID_TMR1_TRIG
@ DMAMUX_DMAREQ_ID_TMR1_TRIG
Definition: at32f435_437_dma.h:247
DMAMUX_DMAREQ_ID_TMR2_TRIG
@ DMAMUX_DMAREQ_ID_TMR2_TRIG
Definition: at32f435_437_dma.h:261
DMAMUX_DMAREQ_ID_REQ_G3
@ DMAMUX_DMAREQ_ID_REQ_G3
Definition: at32f435_437_dma.h:195
DMAMUX_DMAREQ_ID_USART1_TX
@ DMAMUX_DMAREQ_ID_USART1_TX
Definition: at32f435_437_dma.h:223
DMAMUX_DMAREQ_ID_TMR2_CH2
@ DMAMUX_DMAREQ_ID_TMR2_CH2
Definition: at32f435_437_dma.h:257
DMAMUX_DMAREQ_ID_TMR1_CH4
@ DMAMUX_DMAREQ_ID_TMR1_CH4
Definition: at32f435_437_dma.h:245
DMAMUX_DMAREQ_ID_I2C3_RX
@ DMAMUX_DMAREQ_ID_I2C3_RX
Definition: at32f435_437_dma.h:220
DMAMUX_DMAREQ_ID_SPI3_RX
@ DMAMUX_DMAREQ_ID_SPI3_RX
Definition: at32f435_437_dma.h:208
DMAMUX_DMAREQ_ID_TMR7_OVERFLOW
@ DMAMUX_DMAREQ_ID_TMR7_OVERFLOW
Definition: at32f435_437_dma.h:203
DMAMUX_DMAREQ_ID_REQ_G4
@ DMAMUX_DMAREQ_ID_REQ_G4
Definition: at32f435_437_dma.h:196
DMAMUX_DMAREQ_ID_REQ_G2
@ DMAMUX_DMAREQ_ID_REQ_G2
Definition: at32f435_437_dma.h:194
DMAMUX_DMAREQ_ID_USART6_RX
@ DMAMUX_DMAREQ_ID_USART6_RX
Definition: at32f435_437_dma.h:232
DMAMUX_DMAREQ_ID_SPI2_RX
@ DMAMUX_DMAREQ_ID_SPI2_RX
Definition: at32f435_437_dma.h:206
DMAMUX_DMAREQ_ID_TMR3_CH4
@ DMAMUX_DMAREQ_ID_TMR3_CH4
Definition: at32f435_437_dma.h:265
DMAMUX_DMAREQ_ID_TMR5_CH1
@ DMAMUX_DMAREQ_ID_TMR5_CH1
Definition: at32f435_437_dma.h:274
DMAMUX_DMAREQ_ID_TMR8_CH3
@ DMAMUX_DMAREQ_ID_TMR8_CH3
Definition: at32f435_437_dma.h:251
DMAMUX_DMAREQ_ID_TMR8_HALL
@ DMAMUX_DMAREQ_ID_TMR8_HALL
Definition: at32f435_437_dma.h:255
DMAMUX_DMAREQ_ID_USART3_TX
@ DMAMUX_DMAREQ_ID_USART3_TX
Definition: at32f435_437_dma.h:227
DMAMUX_DMAREQ_ID_TMR1_CH2
@ DMAMUX_DMAREQ_ID_TMR1_CH2
Definition: at32f435_437_dma.h:243
DMAMUX_DMAREQ_ID_USART6_TX
@ DMAMUX_DMAREQ_ID_USART6_TX
Definition: at32f435_437_dma.h:233
DMAMUX_DMAREQ_ID_TMR20_TRIG
@ DMAMUX_DMAREQ_ID_TMR20_TRIG
Definition: at32f435_437_dma.h:285
DMAMUX_DMAREQ_ID_QSPI2
@ DMAMUX_DMAREQ_ID_QSPI2
Definition: at32f435_437_dma.h:241
DMAMUX_DMAREQ_ID_USART3_RX
@ DMAMUX_DMAREQ_ID_USART3_RX
Definition: at32f435_437_dma.h:226
DMAMUX_DMAREQ_ID_TMR1_CH1
@ DMAMUX_DMAREQ_ID_TMR1_CH1
Definition: at32f435_437_dma.h:242
DMAMUX_DMAREQ_ID_TMR4_CH2
@ DMAMUX_DMAREQ_ID_TMR4_CH2
Definition: at32f435_437_dma.h:269
DMAMUX_DMAREQ_ID_I2S3_EXT_RX
@ DMAMUX_DMAREQ_ID_I2S3_EXT_RX
Definition: at32f435_437_dma.h:214
DMAMUX_DMAREQ_ID_TMR8_CH1
@ DMAMUX_DMAREQ_ID_TMR8_CH1
Definition: at32f435_437_dma.h:249
DMAMUX_DMAREQ_ID_I2S3_EXT_TX
@ DMAMUX_DMAREQ_ID_I2S3_EXT_TX
Definition: at32f435_437_dma.h:215
DMAMUX_DMAREQ_ID_SPI4_TX
@ DMAMUX_DMAREQ_ID_SPI4_TX
Definition: at32f435_437_dma.h:211
DMAMUX_DMAREQ_ID_ADC3
@ DMAMUX_DMAREQ_ID_ADC3
Definition: at32f435_437_dma.h:199
DMAMUX_DMAREQ_ID_I2C1_RX
@ DMAMUX_DMAREQ_ID_I2C1_RX
Definition: at32f435_437_dma.h:216
DMAMUX_DMAREQ_ID_I2S2_EXT_RX
@ DMAMUX_DMAREQ_ID_I2S2_EXT_RX
Definition: at32f435_437_dma.h:212
DMAMUX_DMAREQ_ID_TMR4_TRIG
@ DMAMUX_DMAREQ_ID_TMR4_TRIG
Definition: at32f435_437_dma.h:273
DMAMUX_DMAREQ_ID_TMR3_TRIG
@ DMAMUX_DMAREQ_ID_TMR3_TRIG
Definition: at32f435_437_dma.h:267
DMAMUX_DMAREQ_ID_TMR8_CH2
@ DMAMUX_DMAREQ_ID_TMR8_CH2
Definition: at32f435_437_dma.h:250
DMAMUX_DMAREQ_ID_TMR5_CH2
@ DMAMUX_DMAREQ_ID_TMR5_CH2
Definition: at32f435_437_dma.h:275
DMAMUX_DMAREQ_ID_TMR20_CH4
@ DMAMUX_DMAREQ_ID_TMR20_CH4
Definition: at32f435_437_dma.h:283
DMAMUX_DMAREQ_ID_USART2_TX
@ DMAMUX_DMAREQ_ID_USART2_TX
Definition: at32f435_437_dma.h:225
DMAMUX_DMAREQ_ID_UART7_TX
@ DMAMUX_DMAREQ_ID_UART7_TX
Definition: at32f435_437_dma.h:235
DMAMUX_DMAREQ_ID_I2S2_EXT_TX
@ DMAMUX_DMAREQ_ID_I2S2_EXT_TX
Definition: at32f435_437_dma.h:213
DMAMUX_DMAREQ_ID_USART1_RX
@ DMAMUX_DMAREQ_ID_USART1_RX
Definition: at32f435_437_dma.h:222
DMAMUX_DMAREQ_ID_TMR20_CH1
@ DMAMUX_DMAREQ_ID_TMR20_CH1
Definition: at32f435_437_dma.h:280
DMAMUX_DMAREQ_ID_TMR2_CH1
@ DMAMUX_DMAREQ_ID_TMR2_CH1
Definition: at32f435_437_dma.h:256
DMAMUX_DMAREQ_ID_UART8_RX
@ DMAMUX_DMAREQ_ID_UART8_RX
Definition: at32f435_437_dma.h:236
DMAMUX_DMAREQ_ID_I2C3_TX
@ DMAMUX_DMAREQ_ID_I2C3_TX
Definition: at32f435_437_dma.h:221
DMAMUX_DMAREQ_ID_I2C1_TX
@ DMAMUX_DMAREQ_ID_I2C1_TX
Definition: at32f435_437_dma.h:217
DMAMUX_DMAREQ_ID_TMR4_OVERFLOW
@ DMAMUX_DMAREQ_ID_TMR4_OVERFLOW
Definition: at32f435_437_dma.h:272
DMAMUX_DMAREQ_ID_SPI4_RX
@ DMAMUX_DMAREQ_ID_SPI4_RX
Definition: at32f435_437_dma.h:210
DMAMUX_DMAREQ_ID_ADC1
@ DMAMUX_DMAREQ_ID_ADC1
Definition: at32f435_437_dma.h:197
DMAMUX_DMAREQ_ID_SPI1_TX
@ DMAMUX_DMAREQ_ID_SPI1_TX
Definition: at32f435_437_dma.h:205
DMAMUX_DMAREQ_ID_TMR2_CH3
@ DMAMUX_DMAREQ_ID_TMR2_CH3
Definition: at32f435_437_dma.h:258
DMAMUX_DMAREQ_ID_TMR3_CH2
@ DMAMUX_DMAREQ_ID_TMR3_CH2
Definition: at32f435_437_dma.h:263
DMAMUX_DMAREQ_ID_TMR1_HALL
@ DMAMUX_DMAREQ_ID_TMR1_HALL
Definition: at32f435_437_dma.h:248
DMAMUX_DMAREQ_ID_UART8_TX
@ DMAMUX_DMAREQ_ID_UART8_TX
Definition: at32f435_437_dma.h:237
DMAMUX_DMAREQ_ID_TMR20_HALL
@ DMAMUX_DMAREQ_ID_TMR20_HALL
Definition: at32f435_437_dma.h:286
DMAMUX_DMAREQ_ID_I2C2_RX
@ DMAMUX_DMAREQ_ID_I2C2_RX
Definition: at32f435_437_dma.h:218
DMAMUX_DMAREQ_ID_TMR1_CH3
@ DMAMUX_DMAREQ_ID_TMR1_CH3
Definition: at32f435_437_dma.h:244
DMAMUX_DMAREQ_ID_ADC2
@ DMAMUX_DMAREQ_ID_ADC2
Definition: at32f435_437_dma.h:198
DMAMUX_DMAREQ_ID_UART4_TX
@ DMAMUX_DMAREQ_ID_UART4_TX
Definition: at32f435_437_dma.h:229
DMAMUX_DMAREQ_ID_TMR20_OVERFLOW
@ DMAMUX_DMAREQ_ID_TMR20_OVERFLOW
Definition: at32f435_437_dma.h:284
DMAMUX_DMAREQ_ID_UART4_RX
@ DMAMUX_DMAREQ_ID_UART4_RX
Definition: at32f435_437_dma.h:228
DMAMUX_DMAREQ_ID_TMR20_CH2
@ DMAMUX_DMAREQ_ID_TMR20_CH2
Definition: at32f435_437_dma.h:281
DMAMUX_DMAREQ_ID_SPI3_TX
@ DMAMUX_DMAREQ_ID_SPI3_TX
Definition: at32f435_437_dma.h:209
DMAMUX_DMAREQ_ID_TMR4_CH1
@ DMAMUX_DMAREQ_ID_TMR4_CH1
Definition: at32f435_437_dma.h:268
DMAMUX_DMAREQ_ID_SPI1_RX
@ DMAMUX_DMAREQ_ID_SPI1_RX
Definition: at32f435_437_dma.h:204
DMAMUX_DMAREQ_ID_TMR3_OVERFLOW
@ DMAMUX_DMAREQ_ID_TMR3_OVERFLOW
Definition: at32f435_437_dma.h:266
DMAMUX_DMAREQ_ID_I2C2_TX
@ DMAMUX_DMAREQ_ID_I2C2_TX
Definition: at32f435_437_dma.h:219
DMAMUX_DMAREQ_ID_TMR5_TRIG
@ DMAMUX_DMAREQ_ID_TMR5_TRIG
Definition: at32f435_437_dma.h:279
DMAMUX_DMAREQ_ID_USART2_RX
@ DMAMUX_DMAREQ_ID_USART2_RX
Definition: at32f435_437_dma.h:224
DMAMUX_DMAREQ_ID_DAC1
@ DMAMUX_DMAREQ_ID_DAC1
Definition: at32f435_437_dma.h:200
DMAMUX_DMAREQ_ID_TMR20_CH3
@ DMAMUX_DMAREQ_ID_TMR20_CH3
Definition: at32f435_437_dma.h:282
DMAMUX_DMAREQ_ID_TMR3_CH1
@ DMAMUX_DMAREQ_ID_TMR3_CH1
Definition: at32f435_437_dma.h:262
DMAMUX_DMAREQ_ID_REQ_G1
@ DMAMUX_DMAREQ_ID_REQ_G1
Definition: at32f435_437_dma.h:193
DMAMUX_DMAREQ_ID_TMR8_TRIG
@ DMAMUX_DMAREQ_ID_TMR8_TRIG
Definition: at32f435_437_dma.h:254
DMAMUX_DMAREQ_ID_TMR8_OVERFLOW
@ DMAMUX_DMAREQ_ID_TMR8_OVERFLOW
Definition: at32f435_437_dma.h:253
DMAMUX_DMAREQ_ID_TMR6_OVERFLOW
@ DMAMUX_DMAREQ_ID_TMR6_OVERFLOW
Definition: at32f435_437_dma.h:202
DMAMUX_DMAREQ_ID_UART7_RX
@ DMAMUX_DMAREQ_ID_UART7_RX
Definition: at32f435_437_dma.h:234
DMAMUX_DMAREQ_ID_TMR5_CH3
@ DMAMUX_DMAREQ_ID_TMR5_CH3
Definition: at32f435_437_dma.h:276
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
dma_channel_type
type define dma channel register all
Definition: at32f435_437_dma.h:576
dma_channel_type::dtcnt
__IO uint32_t dtcnt
Definition: at32f435_437_dma.h:606
dma_channel_type::cnt
__IO uint32_t cnt
Definition: at32f435_437_dma.h:609
dma_channel_type::pwidth
__IO uint32_t pwidth
Definition: at32f435_437_dma.h:593
dma_channel_type::paddr
__IO uint32_t paddr
Definition: at32f435_437_dma.h:619
dma_channel_type::mincm
__IO uint32_t mincm
Definition: at32f435_437_dma.h:592
dma_channel_type::dterrien
__IO uint32_t dterrien
Definition: at32f435_437_dma.h:588
dma_channel_type::chen
__IO uint32_t chen
Definition: at32f435_437_dma.h:585
dma_channel_type::lm
__IO uint32_t lm
Definition: at32f435_437_dma.h:590
dma_channel_type::mwidth
__IO uint32_t mwidth
Definition: at32f435_437_dma.h:594
dma_channel_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_dma.h:597
dma_channel_type::dtd
__IO uint32_t dtd
Definition: at32f435_437_dma.h:589
dma_channel_type::maddr
__IO uint32_t maddr
Definition: at32f435_437_dma.h:631
dma_channel_type::hdtien
__IO uint32_t hdtien
Definition: at32f435_437_dma.h:587
dma_channel_type::m2m
__IO uint32_t m2m
Definition: at32f435_437_dma.h:596
dma_channel_type::pincm
__IO uint32_t pincm
Definition: at32f435_437_dma.h:591
dma_channel_type::ctrl
__IO uint32_t ctrl
Definition: at32f435_437_dma.h:582
dma_channel_type::fdtien
__IO uint32_t fdtien
Definition: at32f435_437_dma.h:586
dma_channel_type::chpl
__IO uint32_t chpl
Definition: at32f435_437_dma.h:595
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
dma_type
type define dma1 register
Definition: at32f435_437_dma.h:416
dma_type::tblsel
__IO uint32_t tblsel
Definition: at32f435_437_dma.h:510
dma_type::gfc3
__IO uint32_t gfc3
Definition: at32f435_437_dma.h:473
dma_type::dterrfc1
__IO uint32_t dterrfc1
Definition: at32f435_437_dma.h:468
dma_type::gfc2
__IO uint32_t gfc2
Definition: at32f435_437_dma.h:469
dma_type::muxgclr
__IO uint32_t muxgclr
Definition: at32f435_437_dma.h:563
dma_type::hdtfc3
__IO uint32_t hdtfc3
Definition: at32f435_437_dma.h:475
dma_type::fdtfc2
__IO uint32_t fdtfc2
Definition: at32f435_437_dma.h:470
dma_type::hdtf7
__IO uint32_t hdtf7
Definition: at32f435_437_dma.h:451
dma_type::gfc1
__IO uint32_t gfc1
Definition: at32f435_437_dma.h:465
dma_type::gf4
__IO uint32_t gf4
Definition: at32f435_437_dma.h:437
dma_type::hdtf2
__IO uint32_t hdtf2
Definition: at32f435_437_dma.h:431
dma_type::hdtf3
__IO uint32_t hdtf3
Definition: at32f435_437_dma.h:435
dma_type::fdtf7
__IO uint32_t fdtf7
Definition: at32f435_437_dma.h:450
dma_type::reserved1
__IO uint32_t reserved1
reserved, offset:0x08~0xFC
Definition: at32f435_437_dma.h:453
dma_type::dterrfc2
__IO uint32_t dterrfc2
Definition: at32f435_437_dma.h:472
dma_type::dterrf4
__IO uint32_t dterrf4
Definition: at32f435_437_dma.h:440
dma_type::gf7
__IO uint32_t gf7
Definition: at32f435_437_dma.h:449
dma_type::fdtfc4
__IO uint32_t fdtfc4
Definition: at32f435_437_dma.h:478
dma_type::gf2
__IO uint32_t gf2
Definition: at32f435_437_dma.h:429
dma_type::hdtfc6
__IO uint32_t hdtfc6
Definition: at32f435_437_dma.h:487
dma_type::dterrf5
__IO uint32_t dterrf5
Definition: at32f435_437_dma.h:444
dma_type::hdtf5
__IO uint32_t hdtf5
Definition: at32f435_437_dma.h:443
dma_type::fdtfc5
__IO uint32_t fdtfc5
Definition: at32f435_437_dma.h:482
dma_type::fdtfc1
__IO uint32_t fdtfc1
Definition: at32f435_437_dma.h:466
dma_type::hdtf4
__IO uint32_t hdtf4
Definition: at32f435_437_dma.h:439
dma_type::muxsyncclr
__IO uint32_t muxsyncclr
Definition: at32f435_437_dma.h:538
dma_type::fdtf1
__IO uint32_t fdtf1
Definition: at32f435_437_dma.h:426
dma_type::gfc6
__IO uint32_t gfc6
Definition: at32f435_437_dma.h:485
dma_type::dterrf6
__IO uint32_t dterrf6
Definition: at32f435_437_dma.h:448
dma_type::fdtf4
__IO uint32_t fdtf4
Definition: at32f435_437_dma.h:438
dma_type::dterrf2
__IO uint32_t dterrf2
Definition: at32f435_437_dma.h:432
dma_type::trgovfc
__IO uint32_t trgovfc
Definition: at32f435_437_dma.h:566
dma_type::muxsel
__IO uint32_t muxsel
Definition: at32f435_437_dma.h:507
dma_type::gfc4
__IO uint32_t gfc4
Definition: at32f435_437_dma.h:477
dma_type::dterrfc3
__IO uint32_t dterrfc3
Definition: at32f435_437_dma.h:476
dma_type::dterrf1
__IO uint32_t dterrf1
Definition: at32f435_437_dma.h:428
dma_type::hdtfc1
__IO uint32_t hdtfc1
Definition: at32f435_437_dma.h:467
dma_type::sts
__IO uint32_t sts
Definition: at32f435_437_dma.h:422
dma_type::dterrf3
__IO uint32_t dterrf3
Definition: at32f435_437_dma.h:436
dma_type::fdtf5
__IO uint32_t fdtf5
Definition: at32f435_437_dma.h:442
dma_type::clr
__IO uint32_t clr
Definition: at32f435_437_dma.h:462
dma_type::fdtfc7
__IO uint32_t fdtfc7
Definition: at32f435_437_dma.h:490
dma_type::fdtf2
__IO uint32_t fdtf2
Definition: at32f435_437_dma.h:430
dma_type::gf1
__IO uint32_t gf1
Definition: at32f435_437_dma.h:425
dma_type::fdtf3
__IO uint32_t fdtf3
Definition: at32f435_437_dma.h:434
dma_type::muxgsts
__IO uint32_t muxgsts
Definition: at32f435_437_dma.h:551
dma_type::hdtfc5
__IO uint32_t hdtfc5
Definition: at32f435_437_dma.h:483
dma_type::gf3
__IO uint32_t gf3
Definition: at32f435_437_dma.h:433
dma_type::dterrfc6
__IO uint32_t dterrfc6
Definition: at32f435_437_dma.h:488
dma_type::fdtfc3
__IO uint32_t fdtfc3
Definition: at32f435_437_dma.h:474
dma_type::hdtfc2
__IO uint32_t hdtfc2
Definition: at32f435_437_dma.h:471
dma_type::fdtfc6
__IO uint32_t fdtfc6
Definition: at32f435_437_dma.h:486
dma_type::syncovfc
__IO uint32_t syncovfc
Definition: at32f435_437_dma.h:541
dma_type::syncovf
__IO uint32_t syncovf
Definition: at32f435_437_dma.h:528
dma_type::dterrfc7
__IO uint32_t dterrfc7
Definition: at32f435_437_dma.h:492
dma_type::gf6
__IO uint32_t gf6
Definition: at32f435_437_dma.h:445
dma_type::fdtf6
__IO uint32_t fdtf6
Definition: at32f435_437_dma.h:446
dma_type::gfc5
__IO uint32_t gfc5
Definition: at32f435_437_dma.h:481
dma_type::trgovf
__IO uint32_t trgovf
Definition: at32f435_437_dma.h:554
dma_type::hdtfc7
__IO uint32_t hdtfc7
Definition: at32f435_437_dma.h:491
dma_type::dterrfc5
__IO uint32_t dterrfc5
Definition: at32f435_437_dma.h:484
dma_type::muxsyncsts
__IO uint32_t muxsyncsts
Definition: at32f435_437_dma.h:525
dma_type::gfc7
__IO uint32_t gfc7
Definition: at32f435_437_dma.h:489
dma_type::hdtf1
__IO uint32_t hdtf1
Definition: at32f435_437_dma.h:427
dma_type::dterrf7
__IO uint32_t dterrf7
Definition: at32f435_437_dma.h:452
dma_type::dterrfc4
__IO uint32_t dterrfc4
Definition: at32f435_437_dma.h:480
dma_type::gf5
__IO uint32_t gf5
Definition: at32f435_437_dma.h:441
dma_type::hdtfc4
__IO uint32_t hdtfc4
Definition: at32f435_437_dma.h:479
dma_type::hdtf6
__IO uint32_t hdtf6
Definition: at32f435_437_dma.h:447
dmamux_channel_type
type define dmamux muxsctrl register
Definition: at32f435_437_dma.h:643
dmamux_channel_type::evtgen
__IO uint32_t evtgen
Definition: at32f435_437_dma.h:655
dmamux_channel_type::syncovien
__IO uint32_t syncovien
Definition: at32f435_437_dma.h:654
dmamux_channel_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_dma.h:653
dmamux_channel_type::muxctrl
__IO uint32_t muxctrl
Definition: at32f435_437_dma.h:649
dmamux_channel_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_dma.h:661
dmamux_channel_type::syncen
__IO uint32_t syncen
Definition: at32f435_437_dma.h:657
dmamux_channel_type::syncpol
__IO uint32_t syncpol
Definition: at32f435_437_dma.h:658
dmamux_channel_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_dma.h:656
dmamux_channel_type::reqsel
__IO uint32_t reqsel
Definition: at32f435_437_dma.h:652
dmamux_channel_type::syncsel
__IO uint32_t syncsel
Definition: at32f435_437_dma.h:660
dmamux_channel_type::reqcnt
__IO uint32_t reqcnt
Definition: at32f435_437_dma.h:659
dmamux_gen_init_type
dmamux generator init type
Definition: at32f435_437_dma.h:405
dmamux_gen_init_type::gen_enable
confirm_state gen_enable
Definition: at32f435_437_dma.h:409
dmamux_gen_init_type::gen_request_number
uint32_t gen_request_number
Definition: at32f435_437_dma.h:408
dmamux_gen_init_type::gen_signal_sel
dmamux_gen_id_sel_type gen_signal_sel
Definition: at32f435_437_dma.h:406
dmamux_gen_init_type::gen_polarity
dmamux_gen_pol_type gen_polarity
Definition: at32f435_437_dma.h:407
dmamux_generator_type
type define dmamux request generator register all
Definition: at32f435_437_dma.h:670
dmamux_generator_type::gen
__IO uint32_t gen
Definition: at32f435_437_dma.h:683
dmamux_generator_type::gpol
__IO uint32_t gpol
Definition: at32f435_437_dma.h:684
dmamux_generator_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_dma.h:680
dmamux_generator_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_dma.h:682
dmamux_generator_type::trgovien
__IO uint32_t trgovien
Definition: at32f435_437_dma.h:681
dmamux_generator_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_dma.h:686
dmamux_generator_type::gctrl
__IO uint32_t gctrl
Definition: at32f435_437_dma.h:676
dmamux_generator_type::greqcnt
__IO uint32_t greqcnt
Definition: at32f435_437_dma.h:685
dmamux_generator_type::sigsel
__IO uint32_t sigsel
Definition: at32f435_437_dma.h:679
dmamux_sync_init_type
dmamux sync init type
Definition: at32f435_437_dma.h:393
dmamux_sync_init_type::sync_enable
confirm_state sync_enable
Definition: at32f435_437_dma.h:398
dmamux_sync_init_type::sync_request_number
uint32_t sync_request_number
Definition: at32f435_437_dma.h:396
dmamux_sync_init_type::sync_event_enable
confirm_state sync_event_enable
Definition: at32f435_437_dma.h:397
dmamux_sync_init_type::sync_polarity
uint32_t sync_polarity
Definition: at32f435_437_dma.h:395
dmamux_sync_init_type::sync_signal_sel
dmamux_sync_id_sel_type sync_signal_sel
Definition: at32f435_437_dma.h:394


AT32F435/437 Firmwary Library: at32f435_437_dvp.c Source File

  • libraries
  • drivers
  • src
at32f435_437_dvp.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef DVP_MODULE_ENABLED
39
49void dvp_reset(void)
50{
51 crm_periph_reset(CRM_DVP_PERIPH_RESET, TRUE);
52 crm_periph_reset(CRM_DVP_PERIPH_RESET, FALSE);
53}
54
60void dvp_capture_enable(confirm_state new_state)
61{
62 DVP->ctrl_bit.cap = new_state;
63}
64
73void dvp_capture_mode_set(dvp_cfm_type cap_mode)
74{
75 DVP->ctrl_bit.cfm = cap_mode;
76}
77
83void dvp_window_crop_enable(confirm_state new_state)
84{
85 DVP->ctrl_bit.crp = new_state;
86}
87
98void dvp_window_crop_set(uint16_t crop_x, uint16_t crop_y, uint16_t crop_w, uint16_t crop_h, uint8_t bytes)
99{
100 DVP->cwst = ((crop_x * bytes) | (crop_y << 16));
101 DVP->cwsz = ((crop_w * bytes - 1) | ((crop_h - 1) << 16));
102}
103
109void dvp_jpeg_enable(confirm_state new_state)
110{
111 DVP->ctrl_bit.jpeg = new_state;
112}
113
122void dvp_sync_mode_set(dvp_sm_type sync_mode)
123{
124 DVP->ctrl_bit.sm = sync_mode;
125}
126
135void dvp_sync_code_set(uint8_t fmsc, uint8_t fmec, uint8_t lnsc, uint8_t lnec)
136{
137 DVP->scr = (fmsc | (lnsc << 8) | (lnec << 16) | (fmec << 24));
138}
139
148void dvp_sync_unmask_set(uint8_t fmsu, uint8_t fmeu, uint8_t lnsu, uint8_t lneu)
149{
150 DVP->sur = (fmsu | (lnsu << 8) | (lneu << 16) | (fmeu << 24));
151}
152
161void dvp_pclk_polarity_set(dvp_ckp_type edge)
162{
163 DVP->ctrl_bit.ckp = edge;
164}
165
174void dvp_hsync_polarity_set(dvp_hsp_type hsync_pol)
175{
176 DVP->ctrl_bit.hsp = hsync_pol;
177}
178
187void dvp_vsync_polarity_set(dvp_vsp_type vsync_pol)
188{
189 DVP->ctrl_bit.vsp = vsync_pol;
190}
191
202void dvp_basic_frame_rate_control_set(dvp_bfrc_type dvp_bfrc)
203{
204 DVP->ctrl_bit.bfrc = dvp_bfrc;
205}
206
217void dvp_pixel_data_length_set(dvp_pdl_type dvp_pdl)
218{
219 DVP->ctrl_bit.pdl = dvp_pdl;
220}
221
227void dvp_enable(confirm_state new_state)
228{
229 DVP->ctrl_bit.ena = new_state;
230}
231
240void dvp_zoomout_select(dvp_pcdes_type dvp_pcdes)
241{
242 DVP->actrl_bit.pcdes = dvp_pcdes;
243}
244
267void dvp_zoomout_set(dvp_pcdc_type dvp_pcdc, dvp_pcds_type dvp_pcds, dvp_lcdc_type dvp_lcdc, dvp_lcds_type dvp_lcds)
268{
269 DVP->ctrl_bit.pcdc = dvp_pcdc;
270 DVP->ctrl_bit.pcds = dvp_pcds;
271 DVP->ctrl_bit.lcdc = dvp_lcdc;
272 DVP->ctrl_bit.lcds = dvp_lcds;
273}
274
284 flag_status dvp_basic_status_get(dvp_status_basic_type dvp_status_basic)
285{
286 flag_status status = RESET;
287
288 if ((DVP->sts & (0x1 << dvp_status_basic)) != (uint16_t)RESET)
289 {
290 status = SET;
291 }
292 else
293 {
294 status = RESET;
295 }
296
297 return status;
298}
299
312void dvp_interrupt_enable(uint32_t dvp_int, confirm_state new_state)
313{
314 if(new_state == TRUE)
315 {
316 DVP->ier |= dvp_int;
317 }
318 else
319 {
320 DVP->ier &= ~dvp_int;
321 }
322}
323
342 flag_status dvp_flag_get(uint32_t flag)
343{
344 flag_status status = RESET;
345 if(flag & 0x80000000)
346 {
347 if((DVP->ists & flag) != RESET)
348 {
349 status = SET;
350 }
351 else
352 {
353 status = RESET;
354 }
355 }
356 else
357 {
358 if((DVP->ests & flag) != RESET)
359 {
360 status = SET;
361 }
362 else
363 {
364 status = RESET;
365 }
366 }
367 return status;
368}
369
388void dvp_flag_clear(uint32_t flag)
389{
390 flag &= ~0x80000000;
391 DVP->iclr = flag;
392}
393
399void dvp_enhanced_scaling_resize_enable(confirm_state new_state)
400{
401 DVP->actrl_bit.eisre = new_state;
402}
411void dvp_enhanced_scaling_resize_set(uint16_t src_w, uint16_t des_w, uint16_t src_h, uint16_t des_h)
412{
413 if((!DVP->ctrl_bit.pcdc) && (!DVP->ctrl_bit.lcdc) && DVP->actrl_bit.efdf)
414 {
415 DVP->hscf = (src_w | (des_w << 16));
416 DVP->vscf = (src_h | (des_h << 16));
417 }
418}
419
427void dvp_enhanced_framerate_set(uint16_t efrcsf, uint16_t efrctf, confirm_state new_state)
428{
429 if((!DVP->ctrl_bit.cfm) && (!DVP->ctrl_bit.bfrc) && (efrctf <= efrcsf))
430 {
431 DVP->frf = (efrcsf | (efrctf << 8));
432 }
433
434 DVP->actrl_bit.efrce = new_state;
435}
436
443void dvp_monochrome_image_binarization_set(uint8_t mibthd, confirm_state new_state)
444{
445 DVP->bth_bit.mibthd = mibthd;
446 DVP->actrl_bit.mibe = new_state;
447}
448
460void dvp_enhanced_data_format_set(dvp_efdf_type dvp_efdf)
461{
462 DVP->actrl_bit.efdf = dvp_efdf;
463}
464
479void dvp_input_data_unused_set(dvp_idus_type dvp_idus, dvp_idun_type dvp_idun)
480{
481 DVP->actrl_bit.idus = dvp_idus;
482 DVP->actrl_bit.idun = dvp_idun;
483}
484
493void dvp_dma_burst_set(dvp_dmabt_type dvp_dmabt)
494{
495 DVP->actrl_bit.dmabt = dvp_dmabt;
496}
497
510void dvp_sync_event_interrupt_set(dvp_hseid_type dvp_hseid, dvp_vseid_type dvp_vseid)
511{
512 DVP->actrl_bit.hseid = dvp_hseid;
513 DVP->actrl_bit.vseid = dvp_vseid;
514}
515
520#endif
521
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f435_437_crm.c:251
CRM_DVP_PERIPH_RESET
@ CRM_DVP_PERIPH_RESET
Definition: at32f435_437_crm.h:266
dvp_status_basic_type
dvp_status_basic_type
dvp status basic type
Definition: at32f435_437_dvp.h:204
dvp_vsp_type
dvp_vsp_type
dvp vsp type
Definition: at32f435_437_dvp.h:136
dvp_pdl_type
dvp_pdl_type
dvp pdl type
Definition: at32f435_437_dvp.h:155
dvp_sm_type
dvp_sm_type
dvp sm type
Definition: at32f435_437_dvp.h:109
dvp_hsp_type
dvp_hsp_type
dvp hsp type
Definition: at32f435_437_dvp.h:127
dvp_cfm_type
dvp_cfm_type
dvp cfm type
Definition: at32f435_437_dvp.h:100
dvp_bfrc_type
dvp_bfrc_type
dvp bfrc type
Definition: at32f435_437_dvp.h:145
dvp_hseid_type
dvp_hseid_type
dvp hseid type
Definition: at32f435_437_dvp.h:253
dvp_idun_type
dvp_idun_type
dvp idun type
Definition: at32f435_437_dvp.h:270
dvp_pcdes_type
dvp_pcdes_type
dvp pcdes type
Definition: at32f435_437_dvp.h:214
dvp_efdf_type
dvp_efdf_type
dvp efdf type
Definition: at32f435_437_dvp.h:223
dvp_ckp_type
dvp_ckp_type
dvp ckp type
Definition: at32f435_437_dvp.h:118
dvp_lcds_type
dvp_lcds_type
dvp lcds type
Definition: at32f435_437_dvp.h:195
dvp_lcdc_type
dvp_lcdc_type
dvp lcdc type
Definition: at32f435_437_dvp.h:186
dvp_pcdc_type
dvp_pcdc_type
dvp pcdc type
Definition: at32f435_437_dvp.h:166
dvp_idus_type
dvp_idus_type
dvp idus type
Definition: at32f435_437_dvp.h:235
dvp_pcds_type
dvp_pcds_type
dvp pcds type
Definition: at32f435_437_dvp.h:177
dvp_vseid_type
dvp_vseid_type
dvp vseid type
Definition: at32f435_437_dvp.h:262
dvp_dmabt_type
dvp_dmabt_type
dvp dmabt type
Definition: at32f435_437_dvp.h:244
dvp_monochrome_image_binarization_set
void dvp_monochrome_image_binarization_set(uint8_t mibthd, confirm_state new_state)
set dvp monochrome image binarization configuration
Definition: at32f435_437_dvp.c:443
dvp_capture_mode_set
void dvp_capture_mode_set(dvp_cfm_type cap_mode)
set dvp capture mode
Definition: at32f435_437_dvp.c:73
dvp_capture_enable
void dvp_capture_enable(confirm_state new_state)
enable or disable dvp capture
Definition: at32f435_437_dvp.c:60
dvp_enhanced_framerate_set
void dvp_enhanced_framerate_set(uint16_t efrcsf, uint16_t efrctf, confirm_state new_state)
set enhanced frame rate control configuration
Definition: at32f435_437_dvp.c:427
dvp_flag_get
flag_status dvp_flag_get(uint32_t flag)
get dvp event/interrupt flag status
Definition: at32f435_437_dvp.c:342
dvp_sync_code_set
void dvp_sync_code_set(uint8_t fmsc, uint8_t fmec, uint8_t lnsc, uint8_t lnec)
set dvp synchronization code configuration
Definition: at32f435_437_dvp.c:135
dvp_pixel_data_length_set
void dvp_pixel_data_length_set(dvp_pdl_type dvp_pdl)
config dvp pixel data length
Definition: at32f435_437_dvp.c:217
dvp_hsync_polarity_set
void dvp_hsync_polarity_set(dvp_hsp_type hsync_pol)
set dvp horizontal synchronization polarity
Definition: at32f435_437_dvp.c:174
dvp_zoomout_select
void dvp_zoomout_select(dvp_pcdes_type dvp_pcdes)
set dvp zoomout select
Definition: at32f435_437_dvp.c:240
dvp_enhanced_scaling_resize_enable
void dvp_enhanced_scaling_resize_enable(confirm_state new_state)
set dvp enhanced image scaling resize enable
Definition: at32f435_437_dvp.c:399
dvp_dma_burst_set
void dvp_dma_burst_set(dvp_dmabt_type dvp_dmabt)
set dvp dma burst transfer configuration
Definition: at32f435_437_dvp.c:493
dvp_input_data_unused_set
void dvp_input_data_unused_set(dvp_idus_type dvp_idus, dvp_idun_type dvp_idun)
set dvp input data un-used condition/number configuration
Definition: at32f435_437_dvp.c:479
dvp_pclk_polarity_set
void dvp_pclk_polarity_set(dvp_ckp_type edge)
set dvp pixel clock polarity
Definition: at32f435_437_dvp.c:161
dvp_sync_mode_set
void dvp_sync_mode_set(dvp_sm_type sync_mode)
set dvp synchronization mode
Definition: at32f435_437_dvp.c:122
dvp_basic_frame_rate_control_set
void dvp_basic_frame_rate_control_set(dvp_bfrc_type dvp_bfrc)
config dvp basic frame rate control
Definition: at32f435_437_dvp.c:202
dvp_reset
void dvp_reset(void)
reset the dvp register
Definition: at32f435_437_dvp.c:49
dvp_window_crop_enable
void dvp_window_crop_enable(confirm_state new_state)
set dvp cropping window enable
Definition: at32f435_437_dvp.c:83
dvp_vsync_polarity_set
void dvp_vsync_polarity_set(dvp_vsp_type vsync_pol)
set dvp vertical synchronization polarity
Definition: at32f435_437_dvp.c:187
dvp_zoomout_set
void dvp_zoomout_set(dvp_pcdc_type dvp_pcdc, dvp_pcds_type dvp_pcds, dvp_lcdc_type dvp_lcdc, dvp_lcds_type dvp_lcds)
set dvp zoomout configuration
Definition: at32f435_437_dvp.c:267
dvp_jpeg_enable
void dvp_jpeg_enable(confirm_state new_state)
enable or disable dvp jpeg
Definition: at32f435_437_dvp.c:109
dvp_basic_status_get
flag_status dvp_basic_status_get(dvp_status_basic_type dvp_status_basic)
get dvp basic status
Definition: at32f435_437_dvp.c:284
dvp_interrupt_enable
void dvp_interrupt_enable(uint32_t dvp_int, confirm_state new_state)
enable or disable dvp interrupt
Definition: at32f435_437_dvp.c:312
dvp_enable
void dvp_enable(confirm_state new_state)
enable or disable dvp function
Definition: at32f435_437_dvp.c:227
dvp_sync_unmask_set
void dvp_sync_unmask_set(uint8_t fmsu, uint8_t fmeu, uint8_t lnsu, uint8_t lneu)
set dvp synchronization unmask configuration
Definition: at32f435_437_dvp.c:148
dvp_flag_clear
void dvp_flag_clear(uint32_t flag)
clear dvp's pending flags
Definition: at32f435_437_dvp.c:388
dvp_enhanced_data_format_set
void dvp_enhanced_data_format_set(dvp_efdf_type dvp_efdf)
set dvp enhanced function data format configuration
Definition: at32f435_437_dvp.c:460
dvp_enhanced_scaling_resize_set
void dvp_enhanced_scaling_resize_set(uint16_t src_w, uint16_t des_w, uint16_t src_h, uint16_t des_h)
set dvp enhanced image scaling resize configuration
Definition: at32f435_437_dvp.c:411
dvp_sync_event_interrupt_set
void dvp_sync_event_interrupt_set(dvp_hseid_type dvp_hseid, dvp_vseid_type dvp_vseid)
set dvp hsync/vsync event interrupt strategy configuration
Definition: at32f435_437_dvp.c:510
dvp_window_crop_set
void dvp_window_crop_set(uint16_t crop_x, uint16_t crop_y, uint16_t crop_w, uint16_t crop_h, uint8_t bytes)
set dvp cropping window configuration
Definition: at32f435_437_dvp.c:98
DVP
#define DVP
Definition: at32f435_437_dvp.h:569
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_dvp.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_dvp.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_DVP_H
29#define __AT32F435_437_DVP_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
52#define DVP_CFD_EVT_FLAG ((uint32_t)0x00000001)
53#define DVP_OVR_EVT_FLAG ((uint32_t)0x00000002)
54#define DVP_ESE_EVT_FLAG ((uint32_t)0x00000004)
55#define DVP_VS_EVT_FLAG ((uint32_t)0x00000008)
56#define DVP_HS_EVT_FLAG ((uint32_t)0x00000010)
67#define DVP_CFD_INT_FLAG ((uint32_t)0x80000001)
68#define DVP_OVR_INT_FLAG ((uint32_t)0x80000002)
69#define DVP_ESE_INT_FLAG ((uint32_t)0x80000004)
70#define DVP_VS_INT_FLAG ((uint32_t)0x80000008)
71#define DVP_HS_INT_FLAG ((uint32_t)0x80000010)
82#define DVP_CFD_INT ((uint32_t)0x00000001)
83#define DVP_OVR_INT ((uint32_t)0x00000002)
84#define DVP_ESE_INT ((uint32_t)0x00000004)
85#define DVP_VS_INT ((uint32_t)0x00000008)
86#define DVP_HS_INT ((uint32_t)0x00000010)
99typedef enum
100{
101 DVP_CAP_FUNC_MODE_CONTINUOUS = 0x00,
102 DVP_CAP_FUNC_MODE_SINGLE = 0x01
103} dvp_cfm_type;
104
108typedef enum
109{
110 DVP_SYNC_MODE_HARDWARE = 0x00,
111 DVP_SYNC_MODE_EMBEDDED = 0x01
112} dvp_sm_type;
113
117typedef enum
118{
119 DVP_CLK_POLARITY_RISING = 0x00,
120 DVP_CLK_POLARITY_FALLING = 0x01
121} dvp_ckp_type;
122
126typedef enum
127{
128 DVP_HSYNC_POLARITY_HIGH = 0x00,
129 DVP_HSYNC_POLARITY_LOW = 0x01
130} dvp_hsp_type;
131
135typedef enum
136{
137 DVP_VSYNC_POLARITY_LOW = 0x00,
138 DVP_VSYNC_POLARITY_HIGH = 0x01
139} dvp_vsp_type;
140
144typedef enum
145{
146 DVP_BFRC_ALL = 0x00,
147 DVP_BFRC_HALF = 0x01,
148 DVP_BFRC_QUARTER = 0x02
149} dvp_bfrc_type;
150
154typedef enum
155{
156 DVP_PIXEL_DATA_LENGTH_8 = 0x00,
157 DVP_PIXEL_DATA_LENGTH_10 = 0x01,
158 DVP_PIXEL_DATA_LENGTH_12 = 0x02,
159 DVP_PIXEL_DATA_LENGTH_14 = 0x03
160} dvp_pdl_type;
161
165typedef enum
166{
167 DVP_PCDC_ALL = 0x00,
168 DVP_PCDC_ONE_IN_TWO = 0x01,
169 DVP_PCDC_ONE_IN_FOUR = 0x02,
170 DVP_PCDC_TWO_IN_FOUR = 0x03
171} dvp_pcdc_type;
172
176typedef enum
177{
178 DVP_PCDS_CAP_FIRST = 0x00,
179 DVP_PCDS_DROP_FIRST = 0x01
180} dvp_pcds_type;
181
185typedef enum
186{
187 DVP_LCDC_ALL = 0x00,
188 DVP_LCDC_ONE_IN_TWO = 0x01
189} dvp_lcdc_type;
190
194typedef enum
195{
196 DVP_LCDS_CAP_FIRST = 0x00,
197 DVP_LCDS_DROP_FIRST = 0x01
198} dvp_lcds_type;
199
203typedef enum
204{
205 DVP_STATUS_HSYN = 0x00,
206 DVP_STATUS_VSYN = 0x01,
207 DVP_STATUS_OFNE = 0x02
208} dvp_status_basic_type;
209
213typedef enum
214{
215 DVP_PCDES_CAP_FIRST = 0x00,
216 DVP_PCDES_DROP_FIRST = 0x01
217} dvp_pcdes_type;
218
222typedef enum
223{
224 DVP_EFDF_BYPASS = 0x00,
225 DVP_EFDF_YUV422_UYVY = 0x04,
226 DVP_EFDF_YUV422_YUYV = 0x05,
227 DVP_EFDF_RGB565_555 = 0x06,
228 DVP_EFDF_Y8 = 0x07
229} dvp_efdf_type;
230
234typedef enum
235{
236 DVP_IDUS_MSB = 0x00,
237 DVP_IDUS_LSB = 0x01
238} dvp_idus_type;
239
243typedef enum
244{
245 DVP_DMABT_SINGLE = 0x00,
246 DVP_DMABT_BURST = 0x01
247} dvp_dmabt_type;
248
252typedef enum
253{
254 DVP_HSEID_LINE_END = 0x00,
255 DVP_HSEID_LINE_START = 0x01
256} dvp_hseid_type;
257
261typedef enum
262{
263 DVP_VSEID_FRAME_END = 0x00,
264 DVP_VSEID_FRMAE_START = 0x01
265} dvp_vseid_type;
269typedef enum
270{
271 DVP_IDUN_0 = 0x00,
272 DVP_IDUN_2 = 0x01,
273 DVP_IDUN_4 = 0x02,
274 DVP_IDUN_6 = 0x03
275} dvp_idun_type;
276
277typedef struct
278{
282 union
283 {
284 __IO uint32_t ctrl;
285 struct
286 {
287 __IO uint32_t cap : 1; /* [0] */
288 __IO uint32_t cfm : 1; /* [1] */
289 __IO uint32_t crp : 1; /* [2] */
290 __IO uint32_t jpeg : 1; /* [3] */
291 __IO uint32_t sm : 1; /* [4] */
292 __IO uint32_t ckp : 1; /* [5] */
293 __IO uint32_t hsp : 1; /* [6] */
294 __IO uint32_t vsp : 1; /* [7] */
295 __IO uint32_t bfrc : 2; /* [9:8] */
296 __IO uint32_t pdl : 2; /* [11:10] */
297 __IO uint32_t reserved1 : 2; /* [13:12] */
298 __IO uint32_t ena : 1; /* [14] */
299 __IO uint32_t reserved2 : 1; /* [15] */
300 __IO uint32_t pcdc : 2; /* [17:16] */
301 __IO uint32_t pcds : 1; /* [18] */
302 __IO uint32_t lcdc : 1; /* [19] */
303 __IO uint32_t lcds : 1; /* [20] */
304 __IO uint32_t : 11;/* [31:21] */
305 } ctrl_bit;
306 };
307
311 union
312 {
313 __IO uint32_t sts;
314 struct
315 {
316 __IO uint32_t hsyn : 1; /* [0] */
317 __IO uint32_t vsyn : 1; /* [1] */
318 __IO uint32_t ofne : 1; /* [2] */
319 __IO uint32_t reserved1 : 29;/* [31:3] */
320 } sts_bit;
321 };
322
326 union
327 {
328 __IO uint32_t ests;
329 struct
330 {
331 __IO uint32_t cfdes : 1; /* [0] */
332 __IO uint32_t ovres : 1; /* [1] */
333 __IO uint32_t esees : 1; /* [2] */
334 __IO uint32_t vses : 1; /* [3] */
335 __IO uint32_t hses : 1; /* [4] */
336 __IO uint32_t reserved1 : 27;/* [31:5] */
337 } ests_bit;
338 };
339
343 union
344 {
345 __IO uint32_t ier;
346 struct
347 {
348 __IO uint32_t cfdie : 1; /* [0] */
349 __IO uint32_t ovrie : 1; /* [1] */
350 __IO uint32_t eseie : 1; /* [2] */
351 __IO uint32_t vsie : 1; /* [3] */
352 __IO uint32_t hsie : 1; /* [4] */
353 __IO uint32_t reserved1 : 27;/* [31:5] */
354 } ier_bit;
355 };
356
360 union
361 {
362 __IO uint32_t ists;
363 struct
364 {
365 __IO uint32_t cfdis : 1; /* [0] */
366 __IO uint32_t ovris : 1; /* [1] */
367 __IO uint32_t eseis : 1; /* [2] */
368 __IO uint32_t vsis : 1; /* [3] */
369 __IO uint32_t hsis : 1; /* [4] */
370 __IO uint32_t reserved1 : 27;/* [31:5] */
371 } ists_bit;
372 };
373
377 union
378 {
379 __IO uint32_t iclr;
380 struct
381 {
382 __IO uint32_t cfdic : 1; /* [0] */
383 __IO uint32_t ovric : 1; /* [1] */
384 __IO uint32_t eseic : 1; /* [2] */
385 __IO uint32_t vsic : 1; /* [3] */
386 __IO uint32_t hsic : 1; /* [4] */
387 __IO uint32_t reserved1 : 27;/* [31:5] */
388 } iclr_bit;
389 };
390
394 union
395 {
396 __IO uint32_t scr;
397 struct
398 {
399 __IO uint32_t fmsc : 8; /* [7:0] */
400 __IO uint32_t lnsc : 8; /* [15:8] */
401 __IO uint32_t lnec : 8; /* [23:16] */
402 __IO uint32_t fmec : 8; /* [31:24] */
403 } scr_bit;
404 };
405
409 union
410 {
411 __IO uint32_t sur;
412 struct
413 {
414 __IO uint32_t fmsu : 8; /* [7:0] */
415 __IO uint32_t lnsu : 8; /* [15:8] */
416 __IO uint32_t lneu : 8; /* [23:16] */
417 __IO uint32_t fmeu : 8; /* [31:24] */
418 } sur_bit;
419 };
420
424 union
425 {
426 __IO uint32_t cwst;
427 struct
428 {
429 __IO uint32_t chstr : 14;/* [13:0] */
430 __IO uint32_t reserved1 : 2; /* [15:14] */
431 __IO uint32_t cvstr : 13;/* [28:16] */
432 __IO uint32_t reserved2 : 3; /* [31:29] */
433 } cwst_bit;
434 };
435
439 union
440 {
441 __IO uint32_t cwsz;
442 struct
443 {
444 __IO uint32_t chnum : 14;/* [13:0] */
445 __IO uint32_t reserved1 : 2; /* [15:14] */
446 __IO uint32_t cvnum : 14;/* [29:16] */
447 __IO uint32_t reserved2 : 2; /* [31:30] */
448 } cwsz_bit;
449 };
450
454 union
455 {
456 __IO uint32_t dt;
457 struct
458 {
459 __IO uint32_t dr0 : 8; /* [7:0] */
460 __IO uint32_t dr1 : 8; /* [15:8] */
461 __IO uint32_t dr2 : 8; /* [23:16] */
462 __IO uint32_t dr3 : 8; /* [31:24] */
463 } dt_bit;
464 };
465
469 __IO uint32_t reserved1[5];
470
474 union
475 {
476 __IO uint32_t actrl;
477 struct
478 {
479 __IO uint32_t eisre : 1; /* [0] */
480 __IO uint32_t efrce : 1; /* [1] */
481 __IO uint32_t mibe : 1; /* [2] */
482 __IO uint32_t pcdes : 1; /* [3] */
483 __IO uint32_t efdf : 3; /* [6:4] */
484 __IO uint32_t reserved1 : 1; /* [7] */
485 __IO uint32_t idun : 2; /* [9:8] */
486 __IO uint32_t idus : 1; /* [10] */
487 __IO uint32_t reserved2 : 1; /* [11] */
488 __IO uint32_t dmabt : 1; /* [12] */
489 __IO uint32_t reserved3 : 1; /* [13] */
490 __IO uint32_t reserved4 : 1; /* [14] */
491 __IO uint32_t reserved5 : 1; /* [15] */
492 __IO uint32_t hseid : 1; /* [16] */
493 __IO uint32_t vseid : 1; /* [17] */
494 __IO uint32_t reserved6 : 1; /* [18] */
495 __IO uint32_t reserved7 : 2; /* [20:19] */
496 __IO uint32_t reserved8 : 11;/* [31:21] */
497 } actrl_bit;
498 };
499
503 __IO uint32_t reserved2;
504
508 union
509 {
510 __IO uint32_t hscf;
511 struct
512 {
513 __IO uint32_t hsrss : 13;/* [12:0] */
514 __IO uint32_t reserved1 : 3; /* [15:13] */
515 __IO uint32_t hsrts : 13;/* [28:16] */
516 __IO uint32_t reserved2 : 3; /* [31:29] */
517 } hscf_bit;
518 };
519
523 union
524 {
525 __IO uint32_t vscf;
526 struct
527 {
528 __IO uint32_t vsrss : 13;/* [12:0] */
529 __IO uint32_t reserved1 : 3; /* [15:13] */
530 __IO uint32_t vsrts : 13;/* [28:16] */
531 __IO uint32_t reserved2 : 3; /* [31:29] */
532 } vscf_bit;
533 };
534
538 union
539 {
540 __IO uint32_t frf;
541 struct
542 {
543 __IO uint32_t efrcsf : 5; /* [4:0] */
544 __IO uint32_t reserved1 : 3; /* [7:5] */
545 __IO uint32_t efrctf : 5; /* [12:8] */
546 __IO uint32_t reserved2 : 19;/* [31:13] */
547 } frf_bit;
548 };
549
553 union
554 {
555 __IO uint32_t bth;
556 struct
557 {
558 __IO uint32_t mibthd : 8; /* [7:0] */
559 __IO uint32_t reserved1 : 24;/* [31:8] */
560 } bth_bit;
561 };
562
563} dvp_type;
564
569#define DVP ((dvp_type *) DVP_BASE)
570
575void dvp_reset(void);
576void dvp_capture_enable(confirm_state new_state);
577void dvp_capture_enable(confirm_state new_state);
578void dvp_capture_mode_set(dvp_cfm_type cap_mode);
579void dvp_window_crop_enable(confirm_state new_state);
580void dvp_window_crop_set(uint16_t crop_x, uint16_t crop_y, uint16_t crop_w, uint16_t crop_h, uint8_t bytes);
581void dvp_jpeg_enable(confirm_state new_state);
582void dvp_sync_mode_set(dvp_sm_type sync_mode);
583void dvp_sync_code_set(uint8_t fmsc, uint8_t fmec, uint8_t lnsc, uint8_t lnec);
584void dvp_sync_unmask_set(uint8_t fmsu, uint8_t fmeu, uint8_t lnsu, uint8_t lneu);
585void dvp_pclk_polarity_set(dvp_ckp_type eage);
586void dvp_hsync_polarity_set(dvp_hsp_type hsync_pol);
587void dvp_vsync_polarity_set(dvp_vsp_type vsync_pol);
588void dvp_basic_frame_rate_control_set(dvp_bfrc_type dvp_bfrc);
589void dvp_pixel_data_length_set(dvp_pdl_type dvp_pdl);
590void dvp_enable(confirm_state new_state);
591void dvp_zoomout_select(dvp_pcdes_type dvp_pcdes);
592void dvp_zoomout_set(dvp_pcdc_type dvp_pcdc, dvp_pcds_type dvp_pcds, dvp_lcdc_type dvp_lcdc, dvp_lcds_type dvp_lcds);
593 flag_status dvp_basic_status_get(dvp_status_basic_type dvp_status_basic);
594void dvp_interrupt_enable(uint32_t dvp_int, confirm_state new_state);
595 flag_status dvp_flag_get(uint32_t flag);
596void dvp_flag_clear(uint32_t flag);
597void dvp_enhanced_scaling_resize_enable(confirm_state new_state);
598void dvp_enhanced_scaling_resize_set(uint16_t src_w, uint16_t des_w, uint16_t src_h, uint16_t des_h);
599void dvp_enhanced_framerate_set(uint16_t efrcsf, uint16_t efrctf, confirm_state new_state);
600void dvp_monochrome_image_binarization_set(uint8_t mibthd, confirm_state new_state);
601void dvp_enhanced_data_format_set(dvp_efdf_type dvp_efdf);
602void dvp_input_data_unused_set(dvp_idus_type dvp_idus, dvp_idun_type dvp_idun);
603void dvp_dma_burst_set(dvp_dmabt_type dvp_dmabt);
604void dvp_sync_event_interrupt_set(dvp_hseid_type dvp_hseid, dvp_vseid_type dvp_vseid);
605
618#ifdef __cplusplus
619}
620#endif
621
622#endif
at32f435_437.h
at32f435_437 header file
dvp_monochrome_image_binarization_set
void dvp_monochrome_image_binarization_set(uint8_t mibthd, confirm_state new_state)
set dvp monochrome image binarization configuration
Definition: at32f435_437_dvp.c:443
dvp_capture_mode_set
void dvp_capture_mode_set(dvp_cfm_type cap_mode)
set dvp capture mode
Definition: at32f435_437_dvp.c:73
dvp_capture_enable
void dvp_capture_enable(confirm_state new_state)
enable or disable dvp capture
Definition: at32f435_437_dvp.c:60
dvp_enhanced_framerate_set
void dvp_enhanced_framerate_set(uint16_t efrcsf, uint16_t efrctf, confirm_state new_state)
set enhanced frame rate control configuration
Definition: at32f435_437_dvp.c:427
dvp_flag_get
flag_status dvp_flag_get(uint32_t flag)
get dvp event/interrupt flag status
Definition: at32f435_437_dvp.c:342
dvp_sync_code_set
void dvp_sync_code_set(uint8_t fmsc, uint8_t fmec, uint8_t lnsc, uint8_t lnec)
set dvp synchronization code configuration
Definition: at32f435_437_dvp.c:135
dvp_pixel_data_length_set
void dvp_pixel_data_length_set(dvp_pdl_type dvp_pdl)
config dvp pixel data length
Definition: at32f435_437_dvp.c:217
dvp_hsync_polarity_set
void dvp_hsync_polarity_set(dvp_hsp_type hsync_pol)
set dvp horizontal synchronization polarity
Definition: at32f435_437_dvp.c:174
dvp_zoomout_select
void dvp_zoomout_select(dvp_pcdes_type dvp_pcdes)
set dvp zoomout select
Definition: at32f435_437_dvp.c:240
dvp_enhanced_scaling_resize_enable
void dvp_enhanced_scaling_resize_enable(confirm_state new_state)
set dvp enhanced image scaling resize enable
Definition: at32f435_437_dvp.c:399
dvp_dma_burst_set
void dvp_dma_burst_set(dvp_dmabt_type dvp_dmabt)
set dvp dma burst transfer configuration
Definition: at32f435_437_dvp.c:493
dvp_input_data_unused_set
void dvp_input_data_unused_set(dvp_idus_type dvp_idus, dvp_idun_type dvp_idun)
set dvp input data un-used condition/number configuration
Definition: at32f435_437_dvp.c:479
dvp_sync_mode_set
void dvp_sync_mode_set(dvp_sm_type sync_mode)
set dvp synchronization mode
Definition: at32f435_437_dvp.c:122
dvp_basic_frame_rate_control_set
void dvp_basic_frame_rate_control_set(dvp_bfrc_type dvp_bfrc)
config dvp basic frame rate control
Definition: at32f435_437_dvp.c:202
dvp_reset
void dvp_reset(void)
reset the dvp register
Definition: at32f435_437_dvp.c:49
dvp_window_crop_enable
void dvp_window_crop_enable(confirm_state new_state)
set dvp cropping window enable
Definition: at32f435_437_dvp.c:83
dvp_vsync_polarity_set
void dvp_vsync_polarity_set(dvp_vsp_type vsync_pol)
set dvp vertical synchronization polarity
Definition: at32f435_437_dvp.c:187
dvp_zoomout_set
void dvp_zoomout_set(dvp_pcdc_type dvp_pcdc, dvp_pcds_type dvp_pcds, dvp_lcdc_type dvp_lcdc, dvp_lcds_type dvp_lcds)
set dvp zoomout configuration
Definition: at32f435_437_dvp.c:267
dvp_jpeg_enable
void dvp_jpeg_enable(confirm_state new_state)
enable or disable dvp jpeg
Definition: at32f435_437_dvp.c:109
dvp_basic_status_get
flag_status dvp_basic_status_get(dvp_status_basic_type dvp_status_basic)
get dvp basic status
Definition: at32f435_437_dvp.c:284
dvp_interrupt_enable
void dvp_interrupt_enable(uint32_t dvp_int, confirm_state new_state)
enable or disable dvp interrupt
Definition: at32f435_437_dvp.c:312
dvp_enable
void dvp_enable(confirm_state new_state)
enable or disable dvp function
Definition: at32f435_437_dvp.c:227
dvp_sync_unmask_set
void dvp_sync_unmask_set(uint8_t fmsu, uint8_t fmeu, uint8_t lnsu, uint8_t lneu)
set dvp synchronization unmask configuration
Definition: at32f435_437_dvp.c:148
dvp_pclk_polarity_set
void dvp_pclk_polarity_set(dvp_ckp_type eage)
set dvp pixel clock polarity
Definition: at32f435_437_dvp.c:161
dvp_flag_clear
void dvp_flag_clear(uint32_t flag)
clear dvp's pending flags
Definition: at32f435_437_dvp.c:388
dvp_enhanced_data_format_set
void dvp_enhanced_data_format_set(dvp_efdf_type dvp_efdf)
set dvp enhanced function data format configuration
Definition: at32f435_437_dvp.c:460
dvp_enhanced_scaling_resize_set
void dvp_enhanced_scaling_resize_set(uint16_t src_w, uint16_t des_w, uint16_t src_h, uint16_t des_h)
set dvp enhanced image scaling resize configuration
Definition: at32f435_437_dvp.c:411
dvp_sync_event_interrupt_set
void dvp_sync_event_interrupt_set(dvp_hseid_type dvp_hseid, dvp_vseid_type dvp_vseid)
set dvp hsync/vsync event interrupt strategy configuration
Definition: at32f435_437_dvp.c:510
dvp_window_crop_set
void dvp_window_crop_set(uint16_t crop_x, uint16_t crop_y, uint16_t crop_w, uint16_t crop_h, uint8_t bytes)
set dvp cropping window configuration
Definition: at32f435_437_dvp.c:98
dvp_status_basic_type
dvp_status_basic_type
dvp status basic type
Definition: at32f435_437_dvp.h:204
dvp_vsp_type
dvp_vsp_type
dvp vsp type
Definition: at32f435_437_dvp.h:136
dvp_pdl_type
dvp_pdl_type
dvp pdl type
Definition: at32f435_437_dvp.h:155
dvp_sm_type
dvp_sm_type
dvp sm type
Definition: at32f435_437_dvp.h:109
dvp_hsp_type
dvp_hsp_type
dvp hsp type
Definition: at32f435_437_dvp.h:127
dvp_cfm_type
dvp_cfm_type
dvp cfm type
Definition: at32f435_437_dvp.h:100
dvp_bfrc_type
dvp_bfrc_type
dvp bfrc type
Definition: at32f435_437_dvp.h:145
dvp_hseid_type
dvp_hseid_type
dvp hseid type
Definition: at32f435_437_dvp.h:253
dvp_idun_type
dvp_idun_type
dvp idun type
Definition: at32f435_437_dvp.h:270
dvp_pcdes_type
dvp_pcdes_type
dvp pcdes type
Definition: at32f435_437_dvp.h:214
dvp_efdf_type
dvp_efdf_type
dvp efdf type
Definition: at32f435_437_dvp.h:223
dvp_ckp_type
dvp_ckp_type
dvp ckp type
Definition: at32f435_437_dvp.h:118
dvp_lcds_type
dvp_lcds_type
dvp lcds type
Definition: at32f435_437_dvp.h:195
dvp_lcdc_type
dvp_lcdc_type
dvp lcdc type
Definition: at32f435_437_dvp.h:186
dvp_pcdc_type
dvp_pcdc_type
dvp pcdc type
Definition: at32f435_437_dvp.h:166
dvp_idus_type
dvp_idus_type
dvp idus type
Definition: at32f435_437_dvp.h:235
dvp_pcds_type
dvp_pcds_type
dvp pcds type
Definition: at32f435_437_dvp.h:177
dvp_vseid_type
dvp_vseid_type
dvp vseid type
Definition: at32f435_437_dvp.h:262
dvp_dmabt_type
dvp_dmabt_type
dvp dmabt type
Definition: at32f435_437_dvp.h:244
DVP_STATUS_OFNE
@ DVP_STATUS_OFNE
Definition: at32f435_437_dvp.h:207
DVP_STATUS_HSYN
@ DVP_STATUS_HSYN
Definition: at32f435_437_dvp.h:205
DVP_STATUS_VSYN
@ DVP_STATUS_VSYN
Definition: at32f435_437_dvp.h:206
DVP_VSYNC_POLARITY_LOW
@ DVP_VSYNC_POLARITY_LOW
Definition: at32f435_437_dvp.h:137
DVP_VSYNC_POLARITY_HIGH
@ DVP_VSYNC_POLARITY_HIGH
Definition: at32f435_437_dvp.h:138
DVP_PIXEL_DATA_LENGTH_10
@ DVP_PIXEL_DATA_LENGTH_10
Definition: at32f435_437_dvp.h:157
DVP_PIXEL_DATA_LENGTH_8
@ DVP_PIXEL_DATA_LENGTH_8
Definition: at32f435_437_dvp.h:156
DVP_PIXEL_DATA_LENGTH_12
@ DVP_PIXEL_DATA_LENGTH_12
Definition: at32f435_437_dvp.h:158
DVP_PIXEL_DATA_LENGTH_14
@ DVP_PIXEL_DATA_LENGTH_14
Definition: at32f435_437_dvp.h:159
DVP_SYNC_MODE_EMBEDDED
@ DVP_SYNC_MODE_EMBEDDED
Definition: at32f435_437_dvp.h:111
DVP_SYNC_MODE_HARDWARE
@ DVP_SYNC_MODE_HARDWARE
Definition: at32f435_437_dvp.h:110
DVP_HSYNC_POLARITY_HIGH
@ DVP_HSYNC_POLARITY_HIGH
Definition: at32f435_437_dvp.h:128
DVP_HSYNC_POLARITY_LOW
@ DVP_HSYNC_POLARITY_LOW
Definition: at32f435_437_dvp.h:129
DVP_CAP_FUNC_MODE_SINGLE
@ DVP_CAP_FUNC_MODE_SINGLE
Definition: at32f435_437_dvp.h:102
DVP_CAP_FUNC_MODE_CONTINUOUS
@ DVP_CAP_FUNC_MODE_CONTINUOUS
Definition: at32f435_437_dvp.h:101
DVP_BFRC_ALL
@ DVP_BFRC_ALL
Definition: at32f435_437_dvp.h:146
DVP_BFRC_QUARTER
@ DVP_BFRC_QUARTER
Definition: at32f435_437_dvp.h:148
DVP_BFRC_HALF
@ DVP_BFRC_HALF
Definition: at32f435_437_dvp.h:147
DVP_HSEID_LINE_END
@ DVP_HSEID_LINE_END
Definition: at32f435_437_dvp.h:254
DVP_HSEID_LINE_START
@ DVP_HSEID_LINE_START
Definition: at32f435_437_dvp.h:255
DVP_IDUN_0
@ DVP_IDUN_0
Definition: at32f435_437_dvp.h:271
DVP_IDUN_2
@ DVP_IDUN_2
Definition: at32f435_437_dvp.h:272
DVP_IDUN_6
@ DVP_IDUN_6
Definition: at32f435_437_dvp.h:274
DVP_IDUN_4
@ DVP_IDUN_4
Definition: at32f435_437_dvp.h:273
DVP_PCDES_CAP_FIRST
@ DVP_PCDES_CAP_FIRST
Definition: at32f435_437_dvp.h:215
DVP_PCDES_DROP_FIRST
@ DVP_PCDES_DROP_FIRST
Definition: at32f435_437_dvp.h:216
DVP_EFDF_Y8
@ DVP_EFDF_Y8
Definition: at32f435_437_dvp.h:228
DVP_EFDF_RGB565_555
@ DVP_EFDF_RGB565_555
Definition: at32f435_437_dvp.h:227
DVP_EFDF_BYPASS
@ DVP_EFDF_BYPASS
Definition: at32f435_437_dvp.h:224
DVP_EFDF_YUV422_UYVY
@ DVP_EFDF_YUV422_UYVY
Definition: at32f435_437_dvp.h:225
DVP_EFDF_YUV422_YUYV
@ DVP_EFDF_YUV422_YUYV
Definition: at32f435_437_dvp.h:226
DVP_CLK_POLARITY_FALLING
@ DVP_CLK_POLARITY_FALLING
Definition: at32f435_437_dvp.h:120
DVP_CLK_POLARITY_RISING
@ DVP_CLK_POLARITY_RISING
Definition: at32f435_437_dvp.h:119
DVP_LCDS_CAP_FIRST
@ DVP_LCDS_CAP_FIRST
Definition: at32f435_437_dvp.h:196
DVP_LCDS_DROP_FIRST
@ DVP_LCDS_DROP_FIRST
Definition: at32f435_437_dvp.h:197
DVP_LCDC_ONE_IN_TWO
@ DVP_LCDC_ONE_IN_TWO
Definition: at32f435_437_dvp.h:188
DVP_LCDC_ALL
@ DVP_LCDC_ALL
Definition: at32f435_437_dvp.h:187
DVP_PCDC_ALL
@ DVP_PCDC_ALL
Definition: at32f435_437_dvp.h:167
DVP_PCDC_ONE_IN_TWO
@ DVP_PCDC_ONE_IN_TWO
Definition: at32f435_437_dvp.h:168
DVP_PCDC_ONE_IN_FOUR
@ DVP_PCDC_ONE_IN_FOUR
Definition: at32f435_437_dvp.h:169
DVP_PCDC_TWO_IN_FOUR
@ DVP_PCDC_TWO_IN_FOUR
Definition: at32f435_437_dvp.h:170
DVP_IDUS_LSB
@ DVP_IDUS_LSB
Definition: at32f435_437_dvp.h:237
DVP_IDUS_MSB
@ DVP_IDUS_MSB
Definition: at32f435_437_dvp.h:236
DVP_PCDS_CAP_FIRST
@ DVP_PCDS_CAP_FIRST
Definition: at32f435_437_dvp.h:178
DVP_PCDS_DROP_FIRST
@ DVP_PCDS_DROP_FIRST
Definition: at32f435_437_dvp.h:179
DVP_VSEID_FRMAE_START
@ DVP_VSEID_FRMAE_START
Definition: at32f435_437_dvp.h:264
DVP_VSEID_FRAME_END
@ DVP_VSEID_FRAME_END
Definition: at32f435_437_dvp.h:263
DVP_DMABT_SINGLE
@ DVP_DMABT_SINGLE
Definition: at32f435_437_dvp.h:245
DVP_DMABT_BURST
@ DVP_DMABT_BURST
Definition: at32f435_437_dvp.h:246
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
dvp_type
Definition: at32f435_437_dvp.h:278
dvp_type::frf
__IO uint32_t frf
Definition: at32f435_437_dvp.h:540
dvp_type::uint32_t
__IO uint32_t
Definition: at32f435_437_dvp.h:304
dvp_type::scr
__IO uint32_t scr
Definition: at32f435_437_dvp.h:396
dvp_type::ier
__IO uint32_t ier
Definition: at32f435_437_dvp.h:345
dvp_type::fmsu
__IO uint32_t fmsu
Definition: at32f435_437_dvp.h:414
dvp_type::dr3
__IO uint32_t dr3
Definition: at32f435_437_dvp.h:462
dvp_type::ists
__IO uint32_t ists
Definition: at32f435_437_dvp.h:362
dvp_type::hscf
__IO uint32_t hscf
Definition: at32f435_437_dvp.h:510
dvp_type::ovres
__IO uint32_t ovres
Definition: at32f435_437_dvp.h:332
dvp_type::hsis
__IO uint32_t hsis
Definition: at32f435_437_dvp.h:369
dvp_type::efrctf
__IO uint32_t efrctf
Definition: at32f435_437_dvp.h:545
dvp_type::ckp
__IO uint32_t ckp
Definition: at32f435_437_dvp.h:292
dvp_type::cfdes
__IO uint32_t cfdes
Definition: at32f435_437_dvp.h:331
dvp_type::reserved8
__IO uint32_t reserved8
Definition: at32f435_437_dvp.h:496
dvp_type::sur
__IO uint32_t sur
Definition: at32f435_437_dvp.h:411
dvp_type::vsis
__IO uint32_t vsis
Definition: at32f435_437_dvp.h:368
dvp_type::dt
__IO uint32_t dt
Definition: at32f435_437_dvp.h:456
dvp_type::hsic
__IO uint32_t hsic
Definition: at32f435_437_dvp.h:386
dvp_type::fmsc
__IO uint32_t fmsc
Definition: at32f435_437_dvp.h:399
dvp_type::eseie
__IO uint32_t eseie
Definition: at32f435_437_dvp.h:350
dvp_type::vsrss
__IO uint32_t vsrss
Definition: at32f435_437_dvp.h:528
dvp_type::crp
__IO uint32_t crp
Definition: at32f435_437_dvp.h:289
dvp_type::mibe
__IO uint32_t mibe
Definition: at32f435_437_dvp.h:481
dvp_type::efrce
__IO uint32_t efrce
Definition: at32f435_437_dvp.h:480
dvp_type::lnsu
__IO uint32_t lnsu
Definition: at32f435_437_dvp.h:415
dvp_type::fmeu
__IO uint32_t fmeu
Definition: at32f435_437_dvp.h:417
dvp_type::chnum
__IO uint32_t chnum
Definition: at32f435_437_dvp.h:444
dvp_type::vses
__IO uint32_t vses
Definition: at32f435_437_dvp.h:334
dvp_type::lcds
__IO uint32_t lcds
Definition: at32f435_437_dvp.h:303
dvp_type::idun
__IO uint32_t idun
Definition: at32f435_437_dvp.h:485
dvp_type::vscf
__IO uint32_t vscf
Definition: at32f435_437_dvp.h:525
dvp_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_dvp.h:489
dvp_type::cvstr
__IO uint32_t cvstr
Definition: at32f435_437_dvp.h:431
dvp_type::bth
__IO uint32_t bth
Definition: at32f435_437_dvp.h:555
dvp_type::ovric
__IO uint32_t ovric
Definition: at32f435_437_dvp.h:383
dvp_type::cfdie
__IO uint32_t cfdie
Definition: at32f435_437_dvp.h:348
dvp_type::ovrie
__IO uint32_t ovrie
Definition: at32f435_437_dvp.h:349
dvp_type::eseic
__IO uint32_t eseic
Definition: at32f435_437_dvp.h:384
dvp_type::iclr
__IO uint32_t iclr
Definition: at32f435_437_dvp.h:379
dvp_type::reserved4
__IO uint32_t reserved4
Definition: at32f435_437_dvp.h:490
dvp_type::ofne
__IO uint32_t ofne
Definition: at32f435_437_dvp.h:318
dvp_type::lneu
__IO uint32_t lneu
Definition: at32f435_437_dvp.h:416
dvp_type::reserved1
__IO uint32_t reserved1
dvp reserved1 register, offset:0x2C-0x3C
Definition: at32f435_437_dvp.h:297
dvp_type::cfdis
__IO uint32_t cfdis
Definition: at32f435_437_dvp.h:365
dvp_type::dmabt
__IO uint32_t dmabt
Definition: at32f435_437_dvp.h:488
dvp_type::chstr
__IO uint32_t chstr
Definition: at32f435_437_dvp.h:429
dvp_type::pcds
__IO uint32_t pcds
Definition: at32f435_437_dvp.h:301
dvp_type::pcdc
__IO uint32_t pcdc
Definition: at32f435_437_dvp.h:300
dvp_type::lnec
__IO uint32_t lnec
Definition: at32f435_437_dvp.h:401
dvp_type::cwsz
__IO uint32_t cwsz
Definition: at32f435_437_dvp.h:441
dvp_type::reserved5
__IO uint32_t reserved5
Definition: at32f435_437_dvp.h:491
dvp_type::sts
__IO uint32_t sts
Definition: at32f435_437_dvp.h:313
dvp_type::pdl
__IO uint32_t pdl
Definition: at32f435_437_dvp.h:296
dvp_type::cfm
__IO uint32_t cfm
Definition: at32f435_437_dvp.h:288
dvp_type::jpeg
__IO uint32_t jpeg
Definition: at32f435_437_dvp.h:290
dvp_type::dr1
__IO uint32_t dr1
Definition: at32f435_437_dvp.h:460
dvp_type::hses
__IO uint32_t hses
Definition: at32f435_437_dvp.h:335
dvp_type::dr0
__IO uint32_t dr0
Definition: at32f435_437_dvp.h:459
dvp_type::cap
__IO uint32_t cap
Definition: at32f435_437_dvp.h:287
dvp_type::efdf
__IO uint32_t efdf
Definition: at32f435_437_dvp.h:483
dvp_type::hsrts
__IO uint32_t hsrts
Definition: at32f435_437_dvp.h:515
dvp_type::fmec
__IO uint32_t fmec
Definition: at32f435_437_dvp.h:402
dvp_type::sm
__IO uint32_t sm
Definition: at32f435_437_dvp.h:291
dvp_type::efrcsf
__IO uint32_t efrcsf
Definition: at32f435_437_dvp.h:543
dvp_type::dr2
__IO uint32_t dr2
Definition: at32f435_437_dvp.h:461
dvp_type::ctrl
__IO uint32_t ctrl
Definition: at32f435_437_dvp.h:284
dvp_type::ests
__IO uint32_t ests
Definition: at32f435_437_dvp.h:328
dvp_type::hsp
__IO uint32_t hsp
Definition: at32f435_437_dvp.h:293
dvp_type::actrl
__IO uint32_t actrl
Definition: at32f435_437_dvp.h:476
dvp_type::lnsc
__IO uint32_t lnsc
Definition: at32f435_437_dvp.h:400
dvp_type::vsp
__IO uint32_t vsp
Definition: at32f435_437_dvp.h:294
dvp_type::hsrss
__IO uint32_t hsrss
Definition: at32f435_437_dvp.h:513
dvp_type::eisre
__IO uint32_t eisre
Definition: at32f435_437_dvp.h:479
dvp_type::cwst
__IO uint32_t cwst
Definition: at32f435_437_dvp.h:426
dvp_type::hsyn
__IO uint32_t hsyn
Definition: at32f435_437_dvp.h:316
dvp_type::mibthd
__IO uint32_t mibthd
Definition: at32f435_437_dvp.h:558
dvp_type::reserved7
__IO uint32_t reserved7
Definition: at32f435_437_dvp.h:495
dvp_type::ena
__IO uint32_t ena
Definition: at32f435_437_dvp.h:298
dvp_type::vsie
__IO uint32_t vsie
Definition: at32f435_437_dvp.h:351
dvp_type::reserved6
__IO uint32_t reserved6
Definition: at32f435_437_dvp.h:494
dvp_type::pcdes
__IO uint32_t pcdes
Definition: at32f435_437_dvp.h:482
dvp_type::vsic
__IO uint32_t vsic
Definition: at32f435_437_dvp.h:385
dvp_type::hseid
__IO uint32_t hseid
Definition: at32f435_437_dvp.h:492
dvp_type::vseid
__IO uint32_t vseid
Definition: at32f435_437_dvp.h:493
dvp_type::cfdic
__IO uint32_t cfdic
Definition: at32f435_437_dvp.h:382
dvp_type::vsrts
__IO uint32_t vsrts
Definition: at32f435_437_dvp.h:530
dvp_type::esees
__IO uint32_t esees
Definition: at32f435_437_dvp.h:333
dvp_type::hsie
__IO uint32_t hsie
Definition: at32f435_437_dvp.h:352
dvp_type::reserved2
__IO uint32_t reserved2
dvp reserved2 register, offset:0x44
Definition: at32f435_437_dvp.h:299
dvp_type::lcdc
__IO uint32_t lcdc
Definition: at32f435_437_dvp.h:302
dvp_type::eseis
__IO uint32_t eseis
Definition: at32f435_437_dvp.h:367
dvp_type::ovris
__IO uint32_t ovris
Definition: at32f435_437_dvp.h:366
dvp_type::vsyn
__IO uint32_t vsyn
Definition: at32f435_437_dvp.h:317
dvp_type::bfrc
__IO uint32_t bfrc
Definition: at32f435_437_dvp.h:295
dvp_type::idus
__IO uint32_t idus
Definition: at32f435_437_dvp.h:486
dvp_type::cvnum
__IO uint32_t cvnum
Definition: at32f435_437_dvp.h:446


AT32F435/437 Firmwary Library: at32f435_437_edma.c Source File

  • libraries
  • drivers
  • src
at32f435_437_edma.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef EDMA_MODULE_ENABLED
39
58void edma_reset(edma_stream_type *edma_streamx)
59{
60 /* reset registers for the selected stream */
61 edma_streamx->ctrl_bit.sen = FALSE;
62 edma_streamx->ctrl = 0x0;
63 edma_streamx->dtcnt = 0x0;
64 edma_streamx->paddr = 0x0;
65 edma_streamx->m0addr = 0x0;
66 edma_streamx->m1addr = 0x0;
67 edma_streamx->fctrl = (uint32_t)0x00000021;
68
69 /* reset interrupt pending bits for the selected stream */
70 switch((uint32_t)edma_streamx)
71 {
72 case EDMA_STREAM1_BASE:
73 EDMA->clr1 = EDMA_STREAM1_INT_MASK;
74 break;
75 case EDMA_STREAM2_BASE:
76 EDMA->clr1 = EDMA_STREAM2_INT_MASK;
77 break;
78 case EDMA_STREAM3_BASE:
79 EDMA->clr1 = EDMA_STREAM3_INT_MASK;
80 break;
81 case EDMA_STREAM4_BASE:
82 EDMA->clr1 = EDMA_STREAM4_INT_MASK;
83 break;
84 case EDMA_STREAM5_BASE:
85 EDMA->clr2 = EDMA_STREAM5_INT_MASK;
86 break;
87 case EDMA_STREAM6_BASE:
88 EDMA->clr2 = EDMA_STREAM6_INT_MASK;
89 break;
90 case EDMA_STREAM7_BASE:
91 EDMA->clr2 = EDMA_STREAM7_INT_MASK;
92 break;
93 case EDMA_STREAM8_BASE:
94 EDMA->clr2 = EDMA_STREAM8_INT_MASK;
95 break;
96 default: break;
97 }
98}
99
115void edma_init(edma_stream_type *edma_streamx, edma_init_type *edma_init_struct)
116{
117 /* config dtd bits */
118 edma_streamx->ctrl_bit.dtd = edma_init_struct->direction;
119
120 /* config pincm bit */
121 edma_streamx->ctrl_bit.pincm = edma_init_struct->peripheral_inc_enable;
122
123 /* config mincm bit*/
124 edma_streamx->ctrl_bit.mincm = edma_init_struct->memory_inc_enable;
125
126 /* config pwidth bits */
127 edma_streamx->ctrl_bit.pwidth = edma_init_struct->peripheral_data_width;
128
129 /* config mwidth bits */
130 edma_streamx->ctrl_bit.mwidth = edma_init_struct->memory_data_width;
131
132 /* config lm bit */
133 edma_streamx->ctrl_bit.lm = edma_init_struct->loop_mode_enable;
134
135 /* config spl bits */
136 edma_streamx->ctrl_bit.spl = edma_init_struct->priority;
137
138 /* config mct bits */
139 edma_streamx->ctrl_bit.mct = edma_init_struct->memory_burst_mode;
140
141 /* config pct bits */
142 edma_streamx->ctrl_bit.pct = edma_init_struct->peripheral_burst_mode;
143
144 /* config fen bits */
145 edma_streamx->fctrl_bit.fen = edma_init_struct->fifo_mode_enable;
146
147 /* config fthsel bits*/
148 edma_streamx->fctrl_bit.fthsel = edma_init_struct->fifo_threshold;
149
150 /* config dtcnt */
151 edma_streamx->dtcnt = edma_init_struct->buffer_size;
152
153 /* config paddr */
154 edma_streamx->paddr = edma_init_struct->peripheral_base_addr;
155
156 /* config m0addr */
157 edma_streamx->m0addr = edma_init_struct->memory0_base_addr;
158}
159
165void edma_default_para_init(edma_init_type *edma_init_struct)
166{
167 edma_init_struct->buffer_size = 0;
168 edma_init_struct->loop_mode_enable = FALSE;
169 edma_init_struct->direction = EDMA_DIR_PERIPHERAL_TO_MEMORY;
170 edma_init_struct->fifo_threshold = EDMA_FIFO_THRESHOLD_1QUARTER;
171 edma_init_struct->fifo_mode_enable = FALSE;
172 edma_init_struct->memory0_base_addr = 0;
173 edma_init_struct->memory_burst_mode = EDMA_MEMORY_SINGLE;
174 edma_init_struct->memory_data_width = EDMA_MEMORY_DATA_WIDTH_BYTE;
175 edma_init_struct->memory_inc_enable = FALSE;
176 edma_init_struct->peripheral_base_addr = 0;
177 edma_init_struct->peripheral_burst_mode = EDMA_PERIPHERAL_SINGLE;
178 edma_init_struct->peripheral_data_width = EDMA_PERIPHERAL_DATA_WIDTH_BYTE;
179 edma_init_struct->peripheral_inc_enable = FALSE;
180 edma_init_struct->priority = EDMA_PRIORITY_LOW;
181}
182
198void edma_stream_enable(edma_stream_type *edma_streamx, confirm_state new_state)
199{
200 edma_streamx->ctrl_bit.sen = new_state;
201}
202
225void edma_interrupt_enable(edma_stream_type *edma_streamx, uint32_t edma_int, confirm_state new_state)
226{
227 if((edma_int & EDMA_FERR_INT) != 0)
228 {
229 if(new_state != FALSE)
230 {
231 edma_streamx->fctrl |= (uint32_t)EDMA_FERR_INT;
232 }
233 else
234 {
235 edma_streamx->fctrl &= ~(uint32_t)EDMA_FERR_INT;
236 }
237 }
238
239 if(edma_int != EDMA_FERR_INT)
240 {
241 if(new_state != FALSE)
242 {
243 edma_streamx->ctrl |= (uint32_t)edma_int;
244 }
245 else
246 {
247 edma_streamx->ctrl &= ~(uint32_t)edma_int;
248 }
249 }
250}
251
270void edma_peripheral_inc_offset_set(edma_stream_type *edma_streamx, edma_peripheral_inc_offset_type offset)
271{
272 edma_streamx->ctrl_bit.pincos = offset;
273}
274
290void edma_flow_controller_enable(edma_stream_type *edma_streamx, confirm_state new_state)
291{
292 edma_streamx->ctrl_bit.pfctrl = new_state;
293}
294
310void edma_data_number_set(edma_stream_type *edma_streamx, uint16_t data_number)
311{
312 /* write the number of data units to be transferred */
313 edma_streamx->dtcnt = data_number;
314}
315
330uint16_t edma_data_number_get(edma_stream_type *edma_streamx)
331{
332 return ((uint16_t)(edma_streamx->dtcnt));
333}
334
354void edma_double_buffer_mode_init(edma_stream_type *edma_streamx, uint32_t memory1_addr, edma_memory_type current_memory)
355{
356 if(current_memory != EDMA_MEMORY_0)
357 {
358 edma_streamx->ctrl_bit.cm = 1;
359 }
360 else
361 {
362 edma_streamx->ctrl_bit.cm = 0;
363 }
364
365 edma_streamx->m1addr = memory1_addr;
366}
367
383void edma_double_buffer_mode_enable(edma_stream_type *edma_streamx, confirm_state new_state)
384{
385 if(new_state != FALSE)
386 {
387 edma_streamx->ctrl_bit.dmm = 1;
388 }
389 else
390 {
391 edma_streamx->ctrl_bit.dmm = 0;
392 }
393}
394
414void edma_memory_addr_set(edma_stream_type *edma_streamx, uint32_t memory_addr, uint32_t memory_target)
415{
416 if(memory_target != EDMA_MEMORY_0)
417 {
418 edma_streamx->m1addr = memory_addr;
419 }
420 else
421 {
422 edma_streamx->m0addr = memory_addr;
423 }
424}
425
442 edma_memory_type edma_memory_target_get(edma_stream_type *edma_streamx)
443{
444 return (edma_memory_type)(edma_streamx->ctrl_bit.cm);
445}
446
461 flag_status edma_stream_status_get(edma_stream_type *edma_streamx)
462{
463 if((edma_streamx->ctrl_bit.sen) != RESET)
464 {
465 return SET;
466 }
467 else
468 {
469 return RESET;
470 }
471}
472
493uint8_t edma_fifo_status_get(edma_stream_type *edma_streamx)
494{
495 return (uint8_t)(edma_streamx->fctrl_bit.fsts);
496}
497
512 flag_status edma_flag_get(uint32_t edma_flag)
513{
514 uint32_t status;
515
516 if(edma_flag > ((uint32_t)0x20000000))
517 {
518 status = EDMA->sts2;
519 }
520 else
521 {
522 status = EDMA->sts1;
523 }
524
525 if((status & edma_flag) != ((uint32_t)RESET))
526 {
527 return SET;
528 }
529 else
530 {
531 return RESET;
532 }
533}
534
549void edma_flag_clear(uint32_t edma_flag)
550{
551 if(edma_flag > ((uint32_t)0x20000000))
552 {
553 EDMA->clr2 = (uint32_t)(edma_flag & 0x0FFFFFFF);
554 }
555 else
556 {
557 EDMA->clr1 = edma_flag;
558 }
559}
560
579void edma_2d_init(edma_stream_2d_type *edma_streamx_2d, int16_t src_stride, int16_t dst_stride, uint16_t xcnt, uint16_t ycnt)
580{
581 edma_streamx_2d->s2dcnt = (uint32_t)((ycnt << 16) | (xcnt));
582
583 edma_streamx_2d->stride = (uint32_t)((dst_stride << 16) | (src_stride));
584}
585
601void edma_2d_enable(edma_stream_2d_type *edma_streamx_2d, confirm_state new_state)
602{
603 uint32_t offset;
604
605 offset = ((uint32_t)edma_streamx_2d - EDMA_STREAM1_2D_BASE) / 4;
606
607 if(new_state != FALSE)
608 {
609 EDMA->s2dctrl |= (uint16_t)0x0001 << offset;
610 }
611 else
612 {
613 EDMA->s2dctrl &= ~((uint16_t)0x0001 << offset);
614 }
615}
616
632void edma_link_list_init(edma_stream_link_list_type *edma_streamx_ll, uint32_t pointer)
633{
634 edma_streamx_ll->llp = pointer;
635}
636
652void edma_link_list_enable(edma_stream_link_list_type *edma_streamx_ll, confirm_state new_state)
653{
654 uint32_t offset;
655
656 offset = ((uint32_t)edma_streamx_ll - EDMA_STREAM1_LL_BASE) / 4;
657
658 if(new_state != FALSE)
659 {
660 EDMA->llctrl |= (uint16_t)0x0001 << offset;
661 }
662 else
663 {
664 EDMA->llctrl &= ~((uint16_t)0x0001 << offset);
665 }
666}
667
673void edmamux_enable(confirm_state new_state)
674{
675 EDMA->muxsel_bit.tblsel = new_state;
676}
677
718void edmamux_init(edmamux_channel_type *edmamux_channelx, edmamux_requst_id_sel_type edmamux_req_id)
719{
720 edmamux_channelx->muxctrl_bit.reqsel = edmamux_req_id;
721}
722
728void edmamux_sync_default_para_init(edmamux_sync_init_type *edmamux_sync_init_struct)
729{
730 edmamux_sync_init_struct->sync_enable = FALSE;
731 edmamux_sync_init_struct->sync_event_enable = FALSE;
732 edmamux_sync_init_struct->sync_polarity = EDMAMUX_SYNC_POLARITY_DISABLE;
733 edmamux_sync_init_struct->sync_request_number = 0x0;
734 edmamux_sync_init_struct->sync_signal_sel = EDMAMUX_SYNC_ID_EXINT0;
735}
736
752void edmamux_sync_config(edmamux_channel_type *edmamux_channelx, edmamux_sync_init_type *edmamux_sync_init_struct)
753{
754 edmamux_channelx->muxctrl_bit.syncsel = edmamux_sync_init_struct->sync_signal_sel;
755 edmamux_channelx->muxctrl_bit.syncpol = edmamux_sync_init_struct->sync_polarity;
756 edmamux_channelx->muxctrl_bit.reqcnt = edmamux_sync_init_struct->sync_request_number;
757 edmamux_channelx->muxctrl_bit.evtgen = edmamux_sync_init_struct->sync_event_enable;
758 edmamux_channelx->muxctrl_bit.syncen = edmamux_sync_init_struct->sync_enable;
759}
760
766void edmamux_generator_default_para_init(edmamux_gen_init_type *edmamux_gen_init_struct)
767{
768 edmamux_gen_init_struct->gen_enable = FALSE;
769 edmamux_gen_init_struct->gen_polarity = EDMAMUX_GEN_POLARITY_DISABLE;
770 edmamux_gen_init_struct->gen_request_number = 0x0;
771 edmamux_gen_init_struct->gen_signal_sel = EDMAMUX_GEN_ID_EXINT0;
772}
773
779void edmamux_generator_config(edmamux_generator_type *edmamux_gen_x, edmamux_gen_init_type *edmamux_gen_init_struct)
780{
781 edmamux_gen_x->gctrl_bit.sigsel = edmamux_gen_init_struct->gen_signal_sel;
782 edmamux_gen_x->gctrl_bit.gpol = edmamux_gen_init_struct->gen_polarity;
783 edmamux_gen_x->gctrl_bit.greqcnt = edmamux_gen_init_struct->gen_request_number;
784 edmamux_gen_x->gctrl_bit.gen = edmamux_gen_init_struct->gen_enable;
785}
786
802void edmamux_sync_interrupt_enable(edmamux_channel_type *edmamux_channelx, confirm_state new_state)
803{
804 if(new_state != FALSE)
805 {
806 edmamux_channelx->muxctrl_bit.syncovien = TRUE;
807 }
808 else
809 {
810 edmamux_channelx->muxctrl_bit.syncovien = FALSE;
811 }
812}
813
825void edmamux_generator_interrupt_enable(edmamux_generator_type *edmamux_gen_x, confirm_state new_state)
826{
827 if(new_state != FALSE)
828 {
829 edmamux_gen_x->gctrl_bit.trgovien = TRUE;
830 }
831 else
832 {
833 edmamux_gen_x->gctrl_bit.trgovien = FALSE;
834 }
835}
836
851 flag_status edmamux_sync_flag_get(uint32_t flag)
852{
853 if((EDMA->muxsyncsts & flag) != RESET)
854 {
855 return SET;
856 }
857 else
858 {
859 return RESET;
860 }
861}
862
877void edmamux_sync_flag_clear(uint32_t flag)
878{
879 EDMA->muxsyncclr = flag;
880}
881
892 flag_status edmamux_generator_flag_get(uint32_t flag)
893{
894 if((EDMA->muxgsts & flag) != RESET)
895 {
896 return SET;
897 }
898 else
899 {
900 return RESET;
901 }
902}
903
914void edmamux_generator_flag_clear(uint32_t flag)
915{
916 EDMA->muxgclr = flag;
917}
918
923#endif
924
edma_init_struct
edma_init_type edma_init_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:40
edmamux_sync_init_struct
edmamux_sync_init_type edmamux_sync_init_struct
Definition: project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c:40
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
edma_peripheral_inc_offset_type
edma_peripheral_inc_offset_type
edma peripheral increment offset size type
Definition: at32f435_437_edma.h:245
edma_memory_type
edma_memory_type
edma memory targets define
Definition: at32f435_437_edma.h:149
edmamux_requst_id_sel_type
edmamux_requst_id_sel_type
edmamux request id select type
Definition: at32f435_437_edma.h:254
EDMA_PRIORITY_LOW
@ EDMA_PRIORITY_LOW
Definition: at32f435_437_edma.h:189
EDMAMUX_SYNC_ID_EXINT0
@ EDMAMUX_SYNC_ID_EXINT0
Definition: at32f435_437_edma.h:357
EDMA_PERIPHERAL_DATA_WIDTH_BYTE
@ EDMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f435_437_edma.h:169
EDMA_MEMORY_DATA_WIDTH_BYTE
@ EDMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f435_437_edma.h:179
EDMA_MEMORY_SINGLE
@ EDMA_MEMORY_SINGLE
Definition: at32f435_437_edma.h:224
EDMAMUX_GEN_ID_EXINT0
@ EDMAMUX_GEN_ID_EXINT0
Definition: at32f435_437_edma.h:399
EDMA_PERIPHERAL_SINGLE
@ EDMA_PERIPHERAL_SINGLE
Definition: at32f435_437_edma.h:235
EDMA_FIFO_THRESHOLD_1QUARTER
@ EDMA_FIFO_THRESHOLD_1QUARTER
Definition: at32f435_437_edma.h:200
EDMA_MEMORY_0
@ EDMA_MEMORY_0
Definition: at32f435_437_edma.h:150
EDMAMUX_GEN_POLARITY_DISABLE
@ EDMAMUX_GEN_POLARITY_DISABLE
Definition: at32f435_437_edma.h:430
EDMA_DIR_PERIPHERAL_TO_MEMORY
@ EDMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_edma.h:159
EDMAMUX_SYNC_POLARITY_DISABLE
@ EDMAMUX_SYNC_POLARITY_DISABLE
Definition: at32f435_437_edma.h:388
EDMA_STREAM3_INT_MASK
#define EDMA_STREAM3_INT_MASK
Definition: at32f435_437_edma.h:113
EDMA_STREAM6_INT_MASK
#define EDMA_STREAM6_INT_MASK
Definition: at32f435_437_edma.h:116
EDMA_STREAM8_INT_MASK
#define EDMA_STREAM8_INT_MASK
Definition: at32f435_437_edma.h:118
EDMA_STREAM7_INT_MASK
#define EDMA_STREAM7_INT_MASK
Definition: at32f435_437_edma.h:117
EDMA_STREAM4_INT_MASK
#define EDMA_STREAM4_INT_MASK
Definition: at32f435_437_edma.h:114
EDMA_STREAM1_INT_MASK
#define EDMA_STREAM1_INT_MASK
masks define
Definition: at32f435_437_edma.h:111
EDMA_STREAM5_INT_MASK
#define EDMA_STREAM5_INT_MASK
Definition: at32f435_437_edma.h:115
EDMA_STREAM2_INT_MASK
#define EDMA_STREAM2_INT_MASK
Definition: at32f435_437_edma.h:112
EDMA_FERR_INT
#define EDMA_FERR_INT
Definition: at32f435_437_edma.h:56
edma_flag_get
flag_status edma_flag_get(uint32_t edma_flag)
get the edma flag.
Definition: at32f435_437_edma.c:512
edma_flag_clear
void edma_flag_clear(uint32_t edma_flag)
clear the edma flag.
Definition: at32f435_437_edma.c:549
edma_double_buffer_mode_init
void edma_double_buffer_mode_init(edma_stream_type *edma_streamx, uint32_t memory1_addr, edma_memory_type current_memory)
config the the double buffer mode.
Definition: at32f435_437_edma.c:354
edmamux_init
void edmamux_init(edmamux_channel_type *edmamux_channelx, edmamux_requst_id_sel_type edmamux_req_id)
edmamux init.
Definition: at32f435_437_edma.c:718
edmamux_generator_default_para_init
void edmamux_generator_default_para_init(edmamux_gen_init_type *edmamux_gen_init_struct)
edmamux request generator init struct config with its default value.
Definition: at32f435_437_edma.c:766
edma_flow_controller_enable
void edma_flow_controller_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx flow controller.
Definition: at32f435_437_edma.c:290
edma_memory_addr_set
void edma_memory_addr_set(edma_stream_type *edma_streamx, uint32_t memory_addr, uint32_t memory_target)
config the memory address in double buffer mode.
Definition: at32f435_437_edma.c:414
edma_init
void edma_init(edma_stream_type *edma_streamx, edma_init_type *edma_init_struct)
edma init.
Definition: at32f435_437_edma.c:115
edma_link_list_init
void edma_link_list_init(edma_stream_link_list_type *edma_streamx_ll, uint32_t pointer)
initialize the edma link list.
Definition: at32f435_437_edma.c:632
edma_memory_target_get
edma_memory_type edma_memory_target_get(edma_stream_type *edma_streamx)
get the current memory target.
Definition: at32f435_437_edma.c:442
edma_peripheral_inc_offset_set
void edma_peripheral_inc_offset_set(edma_stream_type *edma_streamx, edma_peripheral_inc_offset_type offset)
config the edma peripheral increment offset size mode.
Definition: at32f435_437_edma.c:270
edmamux_generator_config
void edmamux_generator_config(edmamux_generator_type *edmamux_gen_x, edmamux_gen_init_type *edmamux_gen_init_struct)
edmamux request generator init.
Definition: at32f435_437_edma.c:779
edma_2d_init
void edma_2d_init(edma_stream_2d_type *edma_streamx_2d, int16_t src_stride, int16_t dst_stride, uint16_t xcnt, uint16_t ycnt)
initialize the edma 2d mode.
Definition: at32f435_437_edma.c:579
edma_double_buffer_mode_enable
void edma_double_buffer_mode_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the double memory mode.
Definition: at32f435_437_edma.c:383
edma_data_number_get
uint16_t edma_data_number_get(edma_stream_type *edma_streamx)
get the number of data to be transferred.
Definition: at32f435_437_edma.c:330
edmamux_sync_default_para_init
void edmamux_sync_default_para_init(edmamux_sync_init_type *edmamux_sync_init_struct)
edmamux sync init struct config with its default value.
Definition: at32f435_437_edma.c:728
edma_2d_enable
void edma_2d_enable(edma_stream_2d_type *edma_streamx_2d, confirm_state new_state)
enable or disable the edma 2d mode.
Definition: at32f435_437_edma.c:601
edma_stream_status_get
flag_status edma_stream_status_get(edma_stream_type *edma_streamx)
get the enable status of edma streamx.
Definition: at32f435_437_edma.c:461
edma_stream_enable
void edma_stream_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx.
Definition: at32f435_437_edma.c:198
edma_fifo_status_get
uint8_t edma_fifo_status_get(edma_stream_type *edma_streamx)
get the fifo level status.
Definition: at32f435_437_edma.c:493
edmamux_sync_config
void edmamux_sync_config(edmamux_channel_type *edmamux_channelx, edmamux_sync_init_type *edmamux_sync_init_struct)
edmamux synchronization config.
Definition: at32f435_437_edma.c:752
edmamux_sync_flag_get
flag_status edmamux_sync_flag_get(uint32_t flag)
edmamux sync flag get.
Definition: at32f435_437_edma.c:851
edma_reset
void edma_reset(edma_stream_type *edma_streamx)
reset edma_streamx channely register.
Definition: at32f435_437_edma.c:58
edmamux_enable
void edmamux_enable(confirm_state new_state)
enable or disable the edma edmamux.
Definition: at32f435_437_edma.c:673
edmamux_sync_flag_clear
void edmamux_sync_flag_clear(uint32_t flag)
edmamux sync flag clear.
Definition: at32f435_437_edma.c:877
edmamux_generator_interrupt_enable
void edmamux_generator_interrupt_enable(edmamux_generator_type *edmamux_gen_x, confirm_state new_state)
enable or disable the edmamux request generator interrupts.
Definition: at32f435_437_edma.c:825
edma_link_list_enable
void edma_link_list_enable(edma_stream_link_list_type *edma_streamx_ll, confirm_state new_state)
enable or disable the edma stream link list mode.
Definition: at32f435_437_edma.c:652
edma_data_number_set
void edma_data_number_set(edma_stream_type *edma_streamx, uint16_t data_number)
set the number of data to be transferred.
Definition: at32f435_437_edma.c:310
edma_interrupt_enable
void edma_interrupt_enable(edma_stream_type *edma_streamx, uint32_t edma_int, confirm_state new_state)
enable or disable the edma streamx interrupts.
Definition: at32f435_437_edma.c:225
edmamux_generator_flag_get
flag_status edmamux_generator_flag_get(uint32_t flag)
edmamux request generator flag get.
Definition: at32f435_437_edma.c:892
edma_default_para_init
void edma_default_para_init(edma_init_type *edma_init_struct)
edma init struct config with its default value.
Definition: at32f435_437_edma.c:165
edmamux_sync_interrupt_enable
void edmamux_sync_interrupt_enable(edmamux_channel_type *edmamux_channelx, confirm_state new_state)
enable or disable the edmamux sync interrupts.
Definition: at32f435_437_edma.c:802
edmamux_generator_flag_clear
void edmamux_generator_flag_clear(uint32_t flag)
edmamux request generator flag clear.
Definition: at32f435_437_edma.c:914
EDMA
#define EDMA
Definition: at32f435_437_edma.h:961
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
EDMA_STREAM1_LL_BASE
#define EDMA_STREAM1_LL_BASE
Definition: at32f435_437.h:562
EDMA_STREAM3_BASE
#define EDMA_STREAM3_BASE
Definition: at32f435_437.h:544
EDMA_STREAM1_BASE
#define EDMA_STREAM1_BASE
Definition: at32f435_437.h:542
EDMA_STREAM2_BASE
#define EDMA_STREAM2_BASE
Definition: at32f435_437.h:543
EDMA_STREAM7_BASE
#define EDMA_STREAM7_BASE
Definition: at32f435_437.h:548
EDMA_STREAM1_2D_BASE
#define EDMA_STREAM1_2D_BASE
Definition: at32f435_437.h:552
EDMA_STREAM8_BASE
#define EDMA_STREAM8_BASE
Definition: at32f435_437.h:549
EDMA_STREAM6_BASE
#define EDMA_STREAM6_BASE
Definition: at32f435_437.h:547
EDMA_STREAM4_BASE
#define EDMA_STREAM4_BASE
Definition: at32f435_437.h:545
EDMA_STREAM5_BASE
#define EDMA_STREAM5_BASE
Definition: at32f435_437.h:546
edma_init_type
edma init type
Definition: at32f435_437_edma.h:440
edma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_edma.h:441
edma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_edma.h:444
edma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_edma.h:446
edma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_edma.h:445
edma_init_type::direction
edma_dir_type direction
Definition: at32f435_437_edma.h:443
edma_init_type::fifo_mode_enable
confirm_state fifo_mode_enable
Definition: at32f435_437_edma.h:451
edma_init_type::peripheral_data_width
edma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_edma.h:447
edma_init_type::fifo_threshold
edma_fifo_threshold_type fifo_threshold
Definition: at32f435_437_edma.h:452
edma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_edma.h:449
edma_init_type::priority
edma_priority_level_type priority
Definition: at32f435_437_edma.h:450
edma_init_type::memory0_base_addr
uint32_t memory0_base_addr
Definition: at32f435_437_edma.h:442
edma_init_type::peripheral_burst_mode
edma_peripheral_burst_type peripheral_burst_mode
Definition: at32f435_437_edma.h:454
edma_init_type::memory_data_width
edma_memory_data_size_type memory_data_width
Definition: at32f435_437_edma.h:448
edma_init_type::memory_burst_mode
edma_memory_burst_type memory_burst_mode
Definition: at32f435_437_edma.h:453
edma_stream_2d_type
type define edma 2d register all
Definition: at32f435_437_edma.h:878
edma_stream_2d_type::stride
__IO uint32_t stride
Definition: at32f435_437_edma.h:896
edma_stream_2d_type::s2dcnt
__IO uint32_t s2dcnt
Definition: at32f435_437_edma.h:884
edma_stream_link_list_type
type define edma stream link list pointer register
Definition: at32f435_437_edma.h:860
edma_stream_link_list_type::llp
__IO uint32_t llp
Definition: at32f435_437_edma.h:866
edma_stream_type
type define edma stream register all
Definition: at32f435_437_edma.h:761
edma_stream_type::cm
__IO uint32_t cm
Definition: at32f435_437_edma.h:785
edma_stream_type::mwidth
__IO uint32_t mwidth
Definition: at32f435_437_edma.h:781
edma_stream_type::spl
__IO uint32_t spl
Definition: at32f435_437_edma.h:783
edma_stream_type::fthsel
__IO uint32_t fthsel
Definition: at32f435_437_edma.h:846
edma_stream_type::m0addr
__IO uint32_t m0addr
Definition: at32f435_437_edma.h:821
edma_stream_type::pfctrl
__IO uint32_t pfctrl
Definition: at32f435_437_edma.h:775
edma_stream_type::ctrl
__IO uint32_t ctrl
Definition: at32f435_437_edma.h:767
edma_stream_type::pct
__IO uint32_t pct
Definition: at32f435_437_edma.h:787
edma_stream_type::mincm
__IO uint32_t mincm
Definition: at32f435_437_edma.h:779
edma_stream_type::m1addr
__IO uint32_t m1addr
Definition: at32f435_437_edma.h:832
edma_stream_type::ctrl_bit
struct edma_stream_type::@411::@423 ctrl_bit
edma_stream_type::pincm
__IO uint32_t pincm
Definition: at32f435_437_edma.h:778
edma_stream_type::lm
__IO uint32_t lm
Definition: at32f435_437_edma.h:777
edma_stream_type::fsts
__IO uint32_t fsts
Definition: at32f435_437_edma.h:848
edma_stream_type::fctrl
__IO uint32_t fctrl
Definition: at32f435_437_edma.h:843
edma_stream_type::dtd
__IO uint32_t dtd
Definition: at32f435_437_edma.h:776
edma_stream_type::paddr
__IO uint32_t paddr
Definition: at32f435_437_edma.h:810
edma_stream_type::mct
__IO uint32_t mct
Definition: at32f435_437_edma.h:788
edma_stream_type::dtcnt
__IO uint32_t dtcnt
Definition: at32f435_437_edma.h:798
edma_stream_type::pincos
__IO uint32_t pincos
Definition: at32f435_437_edma.h:782
edma_stream_type::pwidth
__IO uint32_t pwidth
Definition: at32f435_437_edma.h:780
edma_stream_type::fctrl_bit
struct edma_stream_type::@421::@428 fctrl_bit
edma_stream_type::fen
__IO uint32_t fen
Definition: at32f435_437_edma.h:847
edma_stream_type::sen
__IO uint32_t sen
Definition: at32f435_437_edma.h:770
edma_stream_type::dmm
__IO uint32_t dmm
Definition: at32f435_437_edma.h:784
edmamux_channel_type
type define edmamux muxsctrl register
Definition: at32f435_437_edma.h:909
edmamux_channel_type::syncen
__IO uint32_t syncen
Definition: at32f435_437_edma.h:923
edmamux_channel_type::reqcnt
__IO uint32_t reqcnt
Definition: at32f435_437_edma.h:925
edmamux_channel_type::muxctrl_bit
struct edmamux_channel_type::@438::@440 muxctrl_bit
edmamux_channel_type::syncsel
__IO uint32_t syncsel
Definition: at32f435_437_edma.h:926
edmamux_channel_type::evtgen
__IO uint32_t evtgen
Definition: at32f435_437_edma.h:921
edmamux_channel_type::reqsel
__IO uint32_t reqsel
Definition: at32f435_437_edma.h:918
edmamux_channel_type::syncpol
__IO uint32_t syncpol
Definition: at32f435_437_edma.h:924
edmamux_channel_type::syncovien
__IO uint32_t syncovien
Definition: at32f435_437_edma.h:920
edmamux_gen_init_type
edmamux generator init type
Definition: at32f435_437_edma.h:473
edmamux_gen_init_type::gen_enable
confirm_state gen_enable
Definition: at32f435_437_edma.h:477
edmamux_gen_init_type::gen_request_number
uint32_t gen_request_number
Definition: at32f435_437_edma.h:476
edmamux_gen_init_type::gen_signal_sel
edmamux_gen_id_sel_type gen_signal_sel
Definition: at32f435_437_edma.h:474
edmamux_gen_init_type::gen_polarity
edmamux_gen_pol_type gen_polarity
Definition: at32f435_437_edma.h:475
edmamux_generator_type
type define edmamux request generator register all
Definition: at32f435_437_edma.h:936
edmamux_generator_type::greqcnt
__IO uint32_t greqcnt
Definition: at32f435_437_edma.h:951
edmamux_generator_type::gctrl_bit
struct edmamux_generator_type::@441::@443 gctrl_bit
edmamux_generator_type::sigsel
__IO uint32_t sigsel
Definition: at32f435_437_edma.h:945
edmamux_generator_type::gen
__IO uint32_t gen
Definition: at32f435_437_edma.h:949
edmamux_generator_type::gpol
__IO uint32_t gpol
Definition: at32f435_437_edma.h:950
edmamux_generator_type::trgovien
__IO uint32_t trgovien
Definition: at32f435_437_edma.h:947
edmamux_sync_init_type
edmamux sync init type
Definition: at32f435_437_edma.h:461
edmamux_sync_init_type::sync_signal_sel
edmamux_sync_id_sel_type sync_signal_sel
Definition: at32f435_437_edma.h:462
edmamux_sync_init_type::sync_polarity
edmamux_sync_pol_type sync_polarity
Definition: at32f435_437_edma.h:463
edmamux_sync_init_type::sync_event_enable
confirm_state sync_event_enable
Definition: at32f435_437_edma.h:465
edmamux_sync_init_type::sync_enable
confirm_state sync_enable
Definition: at32f435_437_edma.h:466
edmamux_sync_init_type::sync_request_number
uint32_t sync_request_number
Definition: at32f435_437_edma.h:464
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_edma.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_edma.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_EDMA_H
29#define __AT32F435_437_EDMA_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
52#define EDMA_DMERR_INT ((uint32_t)0x00000002) /* edma direct mode error intterrupt */
53#define EDMA_DTERR_INT ((uint32_t)0x00000004) /* edma data transfer error intterrupt */
54#define EDMA_HDT_INT ((uint32_t)0x00000008) /* edma half data transfer intterrupt */
55#define EDMA_FDT_INT ((uint32_t)0x00000010) /* edma full data transfer intterrupt */
56#define EDMA_FERR_INT ((uint32_t)0x00000080) /* edma fifo error interrupt */
57
67#define EDMA_FERR1_FLAG ((uint32_t)0x10000001) /* edma stream1 fifo error flag */
68#define EDMA_DMERR1_FLAG ((uint32_t)0x10000004) /* edma stream1 direct mode error flag */
69#define EDMA_DTERR1_FLAG ((uint32_t)0x10000008) /* edma stream1 data transfer error flag */
70#define EDMA_HDT1_FLAG ((uint32_t)0x10000010) /* edma stream1 half data transfer flag */
71#define EDMA_FDT1_FLAG ((uint32_t)0x10000020) /* edma stream1 full data transfer flag */
72#define EDMA_FERR2_FLAG ((uint32_t)0x10000040) /* edma stream2 fifo error flag */
73#define EDMA_DMERR2_FLAG ((uint32_t)0x10000100) /* edma stream2 direct mode error flag */
74#define EDMA_DTERR2_FLAG ((uint32_t)0x10000200) /* edma stream2 data transfer error flag */
75#define EDMA_HDT2_FLAG ((uint32_t)0x10000400) /* edma stream2 half data transfer flag */
76#define EDMA_FDT2_FLAG ((uint32_t)0x10000800) /* edma stream2 full data transfer flag */
77#define EDMA_FERR3_FLAG ((uint32_t)0x10010000) /* edma stream3 fifo error flag */
78#define EDMA_DMERR3_FLAG ((uint32_t)0x10040000) /* edma stream3 direct mode error flag */
79#define EDMA_DTERR3_FLAG ((uint32_t)0x10080000) /* edma stream3 data transfer error flag */
80#define EDMA_HDT3_FLAG ((uint32_t)0x10100000) /* edma stream3 half data transfer flag */
81#define EDMA_FDT3_FLAG ((uint32_t)0x10200000) /* edma stream3 full data transfer flag */
82#define EDMA_FERR4_FLAG ((uint32_t)0x10400000) /* edma stream4 fifo error flag */
83#define EDMA_DMERR4_FLAG ((uint32_t)0x11000000) /* edma stream4 direct mode error flag */
84#define EDMA_DTERR4_FLAG ((uint32_t)0x12000000) /* edma stream4 data transfer error flag */
85#define EDMA_HDT4_FLAG ((uint32_t)0x14000000) /* edma stream4 half data transfer flag */
86#define EDMA_FDT4_FLAG ((uint32_t)0x18000000) /* edma stream4 full data transfer flag */
87#define EDMA_FERR5_FLAG ((uint32_t)0x20000001) /* edma stream5 fifo error flag */
88#define EDMA_DMERR5_FLAG ((uint32_t)0x20000004) /* edma stream5 direct mode error flag */
89#define EDMA_DTERR5_FLAG ((uint32_t)0x20000008) /* edma stream5 data transfer error flag */
90#define EDMA_HDT5_FLAG ((uint32_t)0x20000010) /* edma stream5 half data transfer flag */
91#define EDMA_FDT5_FLAG ((uint32_t)0x20000020) /* edma stream5 full data transfer flag */
92#define EDMA_FERR6_FLAG ((uint32_t)0x20000040) /* edma stream6 fifo error flag */
93#define EDMA_DMERR6_FLAG ((uint32_t)0x20000100) /* edma stream6 direct mode error flag */
94#define EDMA_DTERR6_FLAG ((uint32_t)0x20000200) /* edma stream6 data transfer error flag */
95#define EDMA_HDT6_FLAG ((uint32_t)0x20000400) /* edma stream6 half data transfer flag */
96#define EDMA_FDT6_FLAG ((uint32_t)0x20000800) /* edma stream6 full data transfer flag */
97#define EDMA_FERR7_FLAG ((uint32_t)0x20010000) /* edma stream7 fifo error flag */
98#define EDMA_DMERR7_FLAG ((uint32_t)0x20040000) /* edma stream7 direct mode error flag */
99#define EDMA_DTERR7_FLAG ((uint32_t)0x20080000) /* edma stream7 data transfer error flag */
100#define EDMA_HDT7_FLAG ((uint32_t)0x20100000) /* edma stream7 half data transfer flag */
101#define EDMA_FDT7_FLAG ((uint32_t)0x20200000) /* edma stream7 full data transfer flag */
102#define EDMA_FERR8_FLAG ((uint32_t)0x20400000) /* edma stream8 fifo error flag */
103#define EDMA_DMERR8_FLAG ((uint32_t)0x21000000) /* edma stream8 direct mode error flag */
104#define EDMA_DTERR8_FLAG ((uint32_t)0x22000000) /* edma stream8 data transfer error flag */
105#define EDMA_HDT8_FLAG ((uint32_t)0x24000000) /* edma stream8 half data transfer flag */
106#define EDMA_FDT8_FLAG ((uint32_t)0x28000000) /* edma stream8 full data transfer flag */
107
111#define EDMA_STREAM1_INT_MASK (uint32_t)(0x0000003D)
112#define EDMA_STREAM2_INT_MASK (uint32_t)(EDMA_STREAM1_INT_MASK << 6)
113#define EDMA_STREAM3_INT_MASK (uint32_t)(EDMA_STREAM1_INT_MASK << 16)
114#define EDMA_STREAM4_INT_MASK (uint32_t)(EDMA_STREAM1_INT_MASK << 22)
115#define EDMA_STREAM5_INT_MASK (uint32_t)(EDMA_STREAM1_INT_MASK)
116#define EDMA_STREAM6_INT_MASK (uint32_t)(EDMA_STREAM2_INT_MASK)
117#define EDMA_STREAM7_INT_MASK (uint32_t)(EDMA_STREAM3_INT_MASK)
118#define EDMA_STREAM8_INT_MASK (uint32_t)(EDMA_STREAM4_INT_MASK)
123#define EDMAMUX_SYNC_OV1_FLAG ((uint32_t)0x00000001)
124#define EDMAMUX_SYNC_OV2_FLAG ((uint32_t)0x00000002)
125#define EDMAMUX_SYNC_OV3_FLAG ((uint32_t)0x00000004)
126#define EDMAMUX_SYNC_OV4_FLAG ((uint32_t)0x00000008)
127#define EDMAMUX_SYNC_OV5_FLAG ((uint32_t)0x00000010)
128#define EDMAMUX_SYNC_OV6_FLAG ((uint32_t)0x00000020)
129#define EDMAMUX_SYNC_OV7_FLAG ((uint32_t)0x00000040)
130#define EDMAMUX_SYNC_OV8_FLAG ((uint32_t)0x00000080)
132#define EDMAMUX_GEN_TRIG_OV1_FLAG ((uint32_t)0x00000001)
133#define EDMAMUX_GEN_TRIG_OV2_FLAG ((uint32_t)0x00000002)
134#define EDMAMUX_GEN_TRIG_OV3_FLAG ((uint32_t)0x00000004)
135#define EDMAMUX_GEN_TRIG_OV4_FLAG ((uint32_t)0x00000008)
148typedef enum
149{
150 EDMA_MEMORY_0 = 0x00,
151 EDMA_MEMORY_1 = 0x01
152} edma_memory_type;
153
157typedef enum
158{
159 EDMA_DIR_PERIPHERAL_TO_MEMORY = 0x00,
160 EDMA_DIR_MEMORY_TO_PERIPHERAL = 0x01,
161 EDMA_DIR_MEMORY_TO_MEMORY = 0x02
162} edma_dir_type;
163
167typedef enum
168{
169 EDMA_PERIPHERAL_DATA_WIDTH_BYTE = 0x00,
170 EDMA_PERIPHERAL_DATA_WIDTH_HALFWORD = 0x01,
171 EDMA_PERIPHERAL_DATA_WIDTH_WORD = 0x02
172} edma_peripheral_data_size_type;
173
177typedef enum
178{
179 EDMA_MEMORY_DATA_WIDTH_BYTE = 0x00,
180 EDMA_MEMORY_DATA_WIDTH_HALFWORD = 0x01,
181 EDMA_MEMORY_DATA_WIDTH_WORD = 0x02
182} edma_memory_data_size_type;
183
187typedef enum
188{
189 EDMA_PRIORITY_LOW = 0x00,
190 EDMA_PRIORITY_MEDIUM = 0x01,
191 EDMA_PRIORITY_HIGH = 0x02,
192 EDMA_PRIORITY_VERY_HIGH = 0x03
193} edma_priority_level_type;
194
198typedef enum
199{
200 EDMA_FIFO_THRESHOLD_1QUARTER = 0x00,
201 EDMA_FIFO_THRESHOLD_HALF = 0x01,
202 EDMA_FIFO_THRESHOLD_3QUARTER = 0x02,
203 EDMA_FIFO_THRESHOLD_FULL = 0x03
204} edma_fifo_threshold_type;
205
209typedef enum
210{
211 EDMA_FIFO_STATUS_LESS_1QUARTER = 0x00,
212 EDMA_FIFO_STATUS_1QUARTER = 0x01,
213 EDMA_FIFO_STATUS_HALF = 0x02,
214 EDMA_FIFO_STATUS_3QUARTER = 0x03,
215 EDMA_FIFO_STATUS_EMPTY = 0x04,
216 EDMA_FIFO_STATUS_FULL = 0x05
217} edma_fifo_stutas_type;
218
222typedef enum
223{
224 EDMA_MEMORY_SINGLE = 0x00,
225 EDMA_MEMORY_BURST_4 = 0x01,
226 EDMA_MEMORY_BURST_8 = 0x02,
227 EDMA_MEMORY_BURST_16 = 0x03
228} edma_memory_burst_type;
229
233typedef enum
234{
235 EDMA_PERIPHERAL_SINGLE = 0x00,
236 EDMA_PERIPHERAL_BURST_4 = 0x01,
237 EDMA_PERIPHERAL_BURST_8 = 0x02,
238 EDMA_PERIPHERAL_BURST_16 = 0x03
239} edma_peripheral_burst_type;
240
244typedef enum
245{
246 EDMA_PERIPHERAL_INC_PSIZE = 0x00,
247 EDMA_PERIPHERAL_INC_4_BYTE = 0x01
248} edma_peripheral_inc_offset_type;
249
253typedef enum
254{
255 EDMAMUX_DMAREQ_ID_REQ_G1 = 0x01,
256 EDMAMUX_DMAREQ_ID_REQ_G2 = 0x02,
257 EDMAMUX_DMAREQ_ID_REQ_G3 = 0x03,
258 EDMAMUX_DMAREQ_ID_REQ_G4 = 0x04,
259 EDMAMUX_DMAREQ_ID_ADC1 = 0x05,
260 EDMAMUX_DMAREQ_ID_ADC2 = 0x24,
261 EDMAMUX_DMAREQ_ID_ADC3 = 0x25,
262 EDMAMUX_DMAREQ_ID_DAC1 = 0x06,
263 EDMAMUX_DMAREQ_ID_DAC2 = 0x29,
264 EDMAMUX_DMAREQ_ID_TMR6_OVERFLOW = 0x08,
265 EDMAMUX_DMAREQ_ID_TMR7_OVERFLOW = 0x09,
266 EDMAMUX_DMAREQ_ID_SPI1_RX = 0x0A,
267 EDMAMUX_DMAREQ_ID_SPI1_TX = 0x0B,
268 EDMAMUX_DMAREQ_ID_SPI2_RX = 0x0C,
269 EDMAMUX_DMAREQ_ID_SPI2_TX = 0x0D,
270 EDMAMUX_DMAREQ_ID_SPI3_RX = 0x0E,
271 EDMAMUX_DMAREQ_ID_SPI3_TX = 0x0F,
272 EDMAMUX_DMAREQ_ID_SPI4_RX = 0x6A,
273 EDMAMUX_DMAREQ_ID_SPI4_TX = 0x6B,
274 EDMAMUX_DMAREQ_ID_I2S2_EXT_RX = 0x6E,
275 EDMAMUX_DMAREQ_ID_I2S2_EXT_TX = 0x6F,
276 EDMAMUX_DMAREQ_ID_I2S3_EXT_RX = 0x70,
277 EDMAMUX_DMAREQ_ID_I2S3_EXT_TX = 0x71,
278 EDMAMUX_DMAREQ_ID_I2C1_RX = 0x10,
279 EDMAMUX_DMAREQ_ID_I2C1_TX = 0x11,
280 EDMAMUX_DMAREQ_ID_I2C2_RX = 0x12,
281 EDMAMUX_DMAREQ_ID_I2C2_TX = 0x13,
282 EDMAMUX_DMAREQ_ID_I2C3_RX = 0x14,
283 EDMAMUX_DMAREQ_ID_I2C3_TX = 0x15,
284 EDMAMUX_DMAREQ_ID_USART1_RX = 0x18,
285 EDMAMUX_DMAREQ_ID_USART1_TX = 0x19,
286 EDMAMUX_DMAREQ_ID_USART2_RX = 0x1A,
287 EDMAMUX_DMAREQ_ID_USART2_TX = 0x1B,
288 EDMAMUX_DMAREQ_ID_USART3_RX = 0x1C,
289 EDMAMUX_DMAREQ_ID_USART3_TX = 0x1D,
290 EDMAMUX_DMAREQ_ID_UART4_RX = 0x1E,
291 EDMAMUX_DMAREQ_ID_UART4_TX = 0x1F,
292 EDMAMUX_DMAREQ_ID_UART5_RX = 0x20,
293 EDMAMUX_DMAREQ_ID_UART5_TX = 0x21,
294 EDMAMUX_DMAREQ_ID_USART6_RX = 0x72,
295 EDMAMUX_DMAREQ_ID_USART6_TX = 0x73,
296 EDMAMUX_DMAREQ_ID_UART7_RX = 0x74,
297 EDMAMUX_DMAREQ_ID_UART7_TX = 0x75,
298 EDMAMUX_DMAREQ_ID_UART8_RX = 0x76,
299 EDMAMUX_DMAREQ_ID_UART8_TX = 0x77,
300 EDMAMUX_DMAREQ_ID_SDIO1 = 0x27,
301 EDMAMUX_DMAREQ_ID_SDIO2 = 0x67,
302 EDMAMUX_DMAREQ_ID_QSPI1 = 0x28,
303 EDMAMUX_DMAREQ_ID_QSPI2 = 0x68,
304 EDMAMUX_DMAREQ_ID_TMR1_CH1 = 0x2A,
305 EDMAMUX_DMAREQ_ID_TMR1_CH2 = 0x2B,
306 EDMAMUX_DMAREQ_ID_TMR1_CH3 = 0x2C,
307 EDMAMUX_DMAREQ_ID_TMR1_CH4 = 0x2D,
308 EDMAMUX_DMAREQ_ID_TMR1_OVERFLOW = 0x2E,
309 EDMAMUX_DMAREQ_ID_TMR1_TRIG = 0x2F,
310 EDMAMUX_DMAREQ_ID_TMR1_HALL = 0x30,
311 EDMAMUX_DMAREQ_ID_TMR8_CH1 = 0x31,
312 EDMAMUX_DMAREQ_ID_TMR8_CH2 = 0x32,
313 EDMAMUX_DMAREQ_ID_TMR8_CH3 = 0x33,
314 EDMAMUX_DMAREQ_ID_TMR8_CH4 = 0x34,
315 EDMAMUX_DMAREQ_ID_TMR8_OVERFLOW = 0x35,
316 EDMAMUX_DMAREQ_ID_TMR8_TRIG = 0x36,
317 EDMAMUX_DMAREQ_ID_TMR8_HALL = 0x37,
318 EDMAMUX_DMAREQ_ID_TMR2_CH1 = 0x38,
319 EDMAMUX_DMAREQ_ID_TMR2_CH2 = 0x39,
320 EDMAMUX_DMAREQ_ID_TMR2_CH3 = 0x3A,
321 EDMAMUX_DMAREQ_ID_TMR2_CH4 = 0x3B,
322 EDMAMUX_DMAREQ_ID_TMR2_OVERFLOW = 0x3C,
323 EDMAMUX_DMAREQ_ID_TMR2_TRIG = 0x7E,
324 EDMAMUX_DMAREQ_ID_TMR3_CH1 = 0x3D,
325 EDMAMUX_DMAREQ_ID_TMR3_CH2 = 0x3E,
326 EDMAMUX_DMAREQ_ID_TMR3_CH3 = 0x3F,
327 EDMAMUX_DMAREQ_ID_TMR3_CH4 = 0x40,
328 EDMAMUX_DMAREQ_ID_TMR3_OVERFLOW = 0x41,
329 EDMAMUX_DMAREQ_ID_TMR3_TRIG = 0x42,
330 EDMAMUX_DMAREQ_ID_TMR4_CH1 = 0x43,
331 EDMAMUX_DMAREQ_ID_TMR4_CH2 = 0x44,
332 EDMAMUX_DMAREQ_ID_TMR4_CH3 = 0x45,
333 EDMAMUX_DMAREQ_ID_TMR4_CH4 = 0x46,
334 EDMAMUX_DMAREQ_ID_TMR4_OVERFLOW = 0x47,
335 EDMAMUX_DMAREQ_ID_TMR4_TRIG = 0x7F,
336 EDMAMUX_DMAREQ_ID_TMR5_CH1 = 0x48,
337 EDMAMUX_DMAREQ_ID_TMR5_CH2 = 0x49,
338 EDMAMUX_DMAREQ_ID_TMR5_CH3 = 0x4A,
339 EDMAMUX_DMAREQ_ID_TMR5_CH4 = 0x4B,
340 EDMAMUX_DMAREQ_ID_TMR5_OVERFLOW = 0x4C,
341 EDMAMUX_DMAREQ_ID_TMR5_TRIG = 0x4D,
342 EDMAMUX_DMAREQ_ID_TMR20_CH1 = 0x56,
343 EDMAMUX_DMAREQ_ID_TMR20_CH2 = 0x57,
344 EDMAMUX_DMAREQ_ID_TMR20_CH3 = 0x58,
345 EDMAMUX_DMAREQ_ID_TMR20_CH4 = 0x59,
346 EDMAMUX_DMAREQ_ID_TMR20_OVERFLOW = 0x5A,
347 EDMAMUX_DMAREQ_ID_TMR20_TRIG = 0x5D,
348 EDMAMUX_DMAREQ_ID_TMR20_HALL = 0x5E,
349 EDMAMUX_DMAREQ_ID_DVP = 0x69
350} edmamux_requst_id_sel_type;
351
355typedef enum
356{
357 EDMAMUX_SYNC_ID_EXINT0 = 0x00,
358 EDMAMUX_SYNC_ID_EXINT1 = 0x01,
359 EDMAMUX_SYNC_ID_EXINT2 = 0x02,
360 EDMAMUX_SYNC_ID_EXINT3 = 0x03,
361 EDMAMUX_SYNC_ID_EXINT4 = 0x04,
362 EDMAMUX_SYNC_ID_EXINT5 = 0x05,
363 EDMAMUX_SYNC_ID_EXINT6 = 0x06,
364 EDMAMUX_SYNC_ID_EXINT7 = 0x07,
365 EDMAMUX_SYNC_ID_EXINT8 = 0x08,
366 EDMAMUX_SYNC_ID_EXINT9 = 0x09,
367 EDMAMUX_SYNC_ID_EXINT10 = 0x0A,
368 EDMAMUX_SYNC_ID_EXINT11 = 0x0B,
369 EDMAMUX_SYNC_ID_EXINT12 = 0x0C,
370 EDMAMUX_SYNC_ID_EXINT13 = 0x0D,
371 EDMAMUX_SYNC_ID_EXINT14 = 0x0E,
372 EDMAMUX_SYNC_ID_EXINT15 = 0x0F,
373 EDMAMUX_SYNC_ID_DMAMUX_CH1_EVT = 0x10,
374 EDMAMUX_SYNC_ID_DMAMUX_CH2_EVT = 0x11,
375 EDMAMUX_SYNC_ID_DMAMUX_CH3_EVT = 0x12,
376 EDMAMUX_SYNC_ID_DMAMUX_CH4_EVT = 0x13,
377 EDMAMUX_SYNC_ID_DMAMUX_CH5_EVT = 0x14,
378 EDMAMUX_SYNC_ID_DMAMUX_CH6_EVT = 0x15,
379 EDMAMUX_SYNC_ID_DMAMUX_CH7_EVT = 0x16,
380 EDMAMUX_SYNC_ID_DMAMUX_CH8_EVT = 0x17
381} edmamux_sync_id_sel_type;
382
386typedef enum
387{
388 EDMAMUX_SYNC_POLARITY_DISABLE = 0x00,
389 EDMAMUX_SYNC_POLARITY_RISING = 0x01,
390 EDMAMUX_SYNC_POLARITY_FALLING = 0x02,
391 EDMAMUX_SYNC_POLARITY_RISING_FALLING = 0x03
392} edmamux_sync_pol_type;
393
397typedef enum
398{
399 EDMAMUX_GEN_ID_EXINT0 = 0x00,
400 EDMAMUX_GEN_ID_EXINT1 = 0x01,
401 EDMAMUX_GEN_ID_EXINT2 = 0x02,
402 EDMAMUX_GEN_ID_EXINT3 = 0x03,
403 EDMAMUX_GEN_ID_EXINT4 = 0x04,
404 EDMAMUX_GEN_ID_EXINT5 = 0x05,
405 EDMAMUX_GEN_ID_EXINT6 = 0x06,
406 EDMAMUX_GEN_ID_EXINT7 = 0x07,
407 EDMAMUX_GEN_ID_EXINT8 = 0x08,
408 EDMAMUX_GEN_ID_EXINT9 = 0x09,
409 EDMAMUX_GEN_ID_EXINT10 = 0x0A,
410 EDMAMUX_GEN_ID_EXINT11 = 0x0B,
411 EDMAMUX_GEN_ID_EXINT12 = 0x0C,
412 EDMAMUX_GEN_ID_EXINT13 = 0x0D,
413 EDMAMUX_GEN_ID_EXINT14 = 0x0E,
414 EDMAMUX_GEN_ID_EXINT15 = 0x0F,
415 EDMAMUX_GEN_ID_DMAMUX_CH1_EVT = 0x10,
416 EDMAMUX_GEN_ID_DMAMUX_CH2_EVT = 0x11,
417 EDMAMUX_GEN_ID_DMAMUX_CH3_EVT = 0x12,
418 EDMAMUX_GEN_ID_DMAMUX_CH4_EVT = 0x13,
419 EDMAMUX_GEN_ID_DMAMUX_CH5_EVT = 0x14,
420 EDMAMUX_GEN_ID_DMAMUX_CH6_EVT = 0x15,
421 EDMAMUX_GEN_ID_DMAMUX_CH7_EVT = 0x16,
422 EDMAMUX_GEN_ID_DMAMUX_CH8_EVT = 0x17
423} edmamux_gen_id_sel_type;
424
428typedef enum
429{
430 EDMAMUX_GEN_POLARITY_DISABLE = 0x00,
431 EDMAMUX_GEN_POLARITY_RISING = 0x01,
432 EDMAMUX_GEN_POLARITY_FALLING = 0x02,
433 EDMAMUX_GEN_POLARITY_RISING_FALLING = 0x03
434} edmamux_gen_pol_type;
435
439typedef struct
440{
441 uint32_t peripheral_base_addr;
442 uint32_t memory0_base_addr;
443 edma_dir_type direction;
444 uint16_t buffer_size;
445 confirm_state peripheral_inc_enable;
446 confirm_state memory_inc_enable;
447 edma_peripheral_data_size_type peripheral_data_width;
448 edma_memory_data_size_type memory_data_width;
449 confirm_state loop_mode_enable;
450 edma_priority_level_type priority;
451 confirm_state fifo_mode_enable;
452 edma_fifo_threshold_type fifo_threshold;
453 edma_memory_burst_type memory_burst_mode;
454 edma_peripheral_burst_type peripheral_burst_mode;
455} edma_init_type;
456
460typedef struct
461{
462 edmamux_sync_id_sel_type sync_signal_sel;
463 edmamux_sync_pol_type sync_polarity;
464 uint32_t sync_request_number;
465 confirm_state sync_event_enable;
466 confirm_state sync_enable;
467} edmamux_sync_init_type;
468
472typedef struct
473{
474 edmamux_gen_id_sel_type gen_signal_sel;
475 edmamux_gen_pol_type gen_polarity;
476 uint32_t gen_request_number;
477 confirm_state gen_enable;
478} edmamux_gen_init_type;
479
483typedef struct
484{
488 union
489 {
490 __IO uint32_t sts1;
491 struct
492 {
493 __IO uint32_t ferrf1 : 1; /* [0] */
494 __IO uint32_t reserved1 : 1; /* [1] */
495 __IO uint32_t dmerrf1 : 1; /* [2] */
496 __IO uint32_t dterrf1 : 1; /* [3] */
497 __IO uint32_t hdtf1 : 1; /* [4] */
498 __IO uint32_t fdtf1 : 1; /* [5] */
499 __IO uint32_t ferrf2 : 1; /* [6] */
500 __IO uint32_t reserved2 : 1; /* [7] */
501 __IO uint32_t dmerrf2 : 1; /* [8] */
502 __IO uint32_t dterrf2 : 1; /* [9] */
503 __IO uint32_t hdtf2 : 1; /* [10] */
504 __IO uint32_t fdtf2 : 1; /* [11] */
505 __IO uint32_t reserved3 : 4; /* [15:13] */
506 __IO uint32_t ferrf3 : 1; /* [16] */
507 __IO uint32_t reserved4 : 1; /* [17] */
508 __IO uint32_t dmerrf3 : 1; /* [18] */
509 __IO uint32_t dterrf3 : 1; /* [19] */
510 __IO uint32_t hdtf3 : 1; /* [20] */
511 __IO uint32_t fdtf3 : 1; /* [21] */
512 __IO uint32_t ferrf4 : 1; /* [22] */
513 __IO uint32_t reserved5 : 1; /* [23] */
514 __IO uint32_t dmerrf4 : 1; /* [24] */
515 __IO uint32_t dterrf4 : 1; /* [25] */
516 __IO uint32_t hdtf4 : 1; /* [26] */
517 __IO uint32_t fdtf4 : 1; /* [27] */
518 __IO uint32_t reserved6 : 4; /* [31:28] */
519 } sts1_bit;
520 };
524 union
525 {
526 __IO uint32_t sts2;
527 struct
528 {
529 __IO uint32_t ferrf5 : 1; /* [0] */
530 __IO uint32_t reserved1 : 1; /* [1] */
531 __IO uint32_t dmerrf5 : 1; /* [2] */
532 __IO uint32_t dterrf5 : 1; /* [3] */
533 __IO uint32_t hdtf5 : 1; /* [4] */
534 __IO uint32_t fdtf5 : 1; /* [5] */
535 __IO uint32_t ferrf6 : 1; /* [6] */
536 __IO uint32_t reserved2 : 1; /* [7] */
537 __IO uint32_t dmerrf6 : 1; /* [8] */
538 __IO uint32_t dterrf6 : 1; /* [9] */
539 __IO uint32_t hdtf6 : 1; /* [10] */
540 __IO uint32_t fdtf6 : 1; /* [11] */
541 __IO uint32_t reserved3 : 4; /* [15:13] */
542 __IO uint32_t ferrf7 : 1; /* [16] */
543 __IO uint32_t reserved4 : 1; /* [17] */
544 __IO uint32_t dmerrf7 : 1; /* [18] */
545 __IO uint32_t dterrf7 : 1; /* [19] */
546 __IO uint32_t hdtf7 : 1; /* [20] */
547 __IO uint32_t fdtf7 : 1; /* [21] */
548 __IO uint32_t ferrf8 : 1; /* [22] */
549 __IO uint32_t reserved5 : 1; /* [23] */
550 __IO uint32_t dmerrf8 : 1; /* [24] */
551 __IO uint32_t dterrf8 : 1; /* [25] */
552 __IO uint32_t hdtf8 : 1; /* [26] */
553 __IO uint32_t fdtf8 : 1; /* [27] */
554 __IO uint32_t reserved6 : 4; /* [31:28] */
555 } sts2_bit;
556 };
560 union
561 {
562 __IO uint32_t clr1;
563 struct
564 {
565 __IO uint32_t ferrfc1 : 1; /* [0] */
566 __IO uint32_t reserved1 : 1; /* [1] */
567 __IO uint32_t dmerrfc1 : 1; /* [2] */
568 __IO uint32_t dterrfc1 : 1; /* [3] */
569 __IO uint32_t hdtfc1 : 1; /* [4] */
570 __IO uint32_t fdtfc1 : 1; /* [5] */
571 __IO uint32_t ferrfc2 : 1; /* [6] */
572 __IO uint32_t reserved2 : 1; /* [7] */
573 __IO uint32_t dmerrfc2 : 1; /* [8] */
574 __IO uint32_t dterrfc2 : 1; /* [9] */
575 __IO uint32_t hdtfc2 : 1; /* [10] */
576 __IO uint32_t fdtfc2 : 1; /* [11] */
577 __IO uint32_t reserved3 : 4; /* [15:13] */
578 __IO uint32_t ferrfc3 : 1; /* [16] */
579 __IO uint32_t reserved4 : 1; /* [17] */
580 __IO uint32_t dmerrfc3 : 1; /* [18] */
581 __IO uint32_t dterrfc3 : 1; /* [19] */
582 __IO uint32_t hdtfc3 : 1; /* [20] */
583 __IO uint32_t fdtfc3 : 1; /* [21] */
584 __IO uint32_t ferrfc4 : 1; /* [22] */
585 __IO uint32_t reserved5 : 1; /* [23] */
586 __IO uint32_t dmerrfc4 : 1; /* [24] */
587 __IO uint32_t dterrfc4 : 1; /* [25] */
588 __IO uint32_t hdtfc4 : 1; /* [26] */
589 __IO uint32_t fdtfc4 : 1; /* [27] */
590 __IO uint32_t reserved6 : 4; /* [31:28] */
591 } clr1_bit;
592 };
596 union
597 {
598 __IO uint32_t clr2;
599 struct
600 {
601 __IO uint32_t ferrfc5 : 1; /* [0] */
602 __IO uint32_t reserved1 : 1; /* [1] */
603 __IO uint32_t dmerrfc5 : 1; /* [2] */
604 __IO uint32_t dterrfc5 : 1; /* [3] */
605 __IO uint32_t hdtfc5 : 1; /* [4] */
606 __IO uint32_t fdtfc5 : 1; /* [5] */
607 __IO uint32_t ferrfc6 : 1; /* [6] */
608 __IO uint32_t reserved2 : 1; /* [7] */
609 __IO uint32_t dmerrfc6 : 1; /* [8] */
610 __IO uint32_t dterrfc6 : 1; /* [9] */
611 __IO uint32_t hdtfc6 : 1; /* [10] */
612 __IO uint32_t fdtfc6 : 1; /* [11] */
613 __IO uint32_t reserved3 : 4; /* [15:13] */
614 __IO uint32_t ferrfc7 : 1; /* [16] */
615 __IO uint32_t reserved4 : 1; /* [17] */
616 __IO uint32_t dmerrfc7 : 1; /* [18] */
617 __IO uint32_t dterrfc7 : 1; /* [19] */
618 __IO uint32_t hdtfc7 : 1; /* [20] */
619 __IO uint32_t fdtfc7 : 1; /* [21] */
620 __IO uint32_t ferrfc8 : 1; /* [22] */
621 __IO uint32_t reserved5 : 1; /* [23] */
622 __IO uint32_t dmerrfc8 : 1; /* [24] */
623 __IO uint32_t dterrfc8 : 1; /* [25] */
624 __IO uint32_t hdtfc8 : 1; /* [26] */
625 __IO uint32_t fdtfc8 : 1; /* [27] */
626 __IO uint32_t reserved6 : 4; /* [31:28] */
627 } clr2_bit;
628 };
629
633 __IO uint32_t reserved1[48];
634
638 union
639 {
640 __IO uint32_t llctrl;
641 struct
642 {
643 __IO uint32_t s1llen : 1; /* [0] */
644 __IO uint32_t s2llen : 1; /* [1] */
645 __IO uint32_t s3llen : 1; /* [2] */
646 __IO uint32_t s4llen : 1; /* [3] */
647 __IO uint32_t s5llen : 1; /* [4] */
648 __IO uint32_t s6llen : 1; /* [5] */
649 __IO uint32_t s7llen : 1; /* [6] */
650 __IO uint32_t s8llen : 1; /* [7] */
651 __IO uint32_t reserved1 : 24;/* [31:8] */
652 } llctrl_bit;
653 };
654
658 __IO uint32_t reserved2[8];
659
663 union
664 {
665 __IO uint32_t s2dctrl;
666 struct
667 {
668 __IO uint32_t s12den : 1; /* [0] */
669 __IO uint32_t s22den : 1; /* [1] */
670 __IO uint32_t s32den : 1; /* [2] */
671 __IO uint32_t s42den : 1; /* [3] */
672 __IO uint32_t s52den : 1; /* [4] */
673 __IO uint32_t s62den : 1; /* [5] */
674 __IO uint32_t s72den : 1; /* [6] */
675 __IO uint32_t s82den : 1; /* [7] */
676 __IO uint32_t reserved1 : 24;/* [31:8] */
677 } s2dctrl_bit;
678 };
679
683 __IO uint32_t reserved3[17];
684
688 union
689 {
690 __IO uint32_t muxsel;
691 struct
692 {
693 __IO uint32_t tblsel : 1; /* [0] */
694 __IO uint32_t reserved1 : 31;/* [31:1] */
695 }muxsel_bit;
696 };
697
701 __IO uint32_t reserved4[12];
702
706 union
707 {
708 __IO uint32_t muxsyncsts;
709 struct
710 {
711 __IO uint32_t syncovf : 8; /* [7:0] */
712 __IO uint32_t reserved1 : 24;/* [31:8] */
713 }muxsyncsts_bit;
714 };
715
719 union
720 {
721 __IO uint32_t muxsyncclr;
722 struct
723 {
724 __IO uint32_t syncovfc : 8; /* [7:0] */
725 __IO uint32_t reserved1 : 24;/* [31:8] */
726 }muxsyncclr_bit;
727 };
728
732 union
733 {
734 __IO uint32_t muxgsts;
735 struct
736 {
737 __IO uint32_t trgovf : 4; /* [3:0] */
738 __IO uint32_t reserved1 : 28;/* [31:4] */
739 }muxgsts_bit;
740 };
741
745 union
746 {
747 __IO uint32_t muxgclr;
748 struct
749 {
750 __IO uint32_t trgovfc : 4; /* [3:0] */
751 __IO uint32_t reserved1 : 28;/* [31:4] */
752 }muxgclr_bit;
753 };
754
755} edma_type;
756
760typedef struct
761{
765 union
766 {
767 __IO uint32_t ctrl;
768 struct
769 {
770 __IO uint32_t sen : 1; /* [0] */
771 __IO uint32_t dmerrien : 1; /* [1] */
772 __IO uint32_t dterrien : 1; /* [2] */
773 __IO uint32_t hdtien : 1; /* [3] */
774 __IO uint32_t fdtien : 1; /* [4] */
775 __IO uint32_t pfctrl : 1; /* [5] */
776 __IO uint32_t dtd : 2; /* [7:6] */
777 __IO uint32_t lm : 1; /* [8] */
778 __IO uint32_t pincm : 1; /* [9] */
779 __IO uint32_t mincm : 1; /* [10] */
780 __IO uint32_t pwidth : 2; /* [12:11] */
781 __IO uint32_t mwidth : 2; /* [14:13] */
782 __IO uint32_t pincos : 1; /* [15] */
783 __IO uint32_t spl : 2; /* [17:16] */
784 __IO uint32_t dmm : 1; /* [18] */
785 __IO uint32_t cm : 1; /* [19] */
786 __IO uint32_t reserved1 : 1; /* [20] */
787 __IO uint32_t pct : 2; /* [22:21] */
788 __IO uint32_t mct : 2; /* [24:23] */
789 __IO uint32_t reserved2 : 3; /* [27:25] */
790 __IO uint32_t reserved3 : 4; /* [31:28] */
791 } ctrl_bit;
792 };
796 union
797 {
798 __IO uint32_t dtcnt;
799 struct
800 {
801 __IO uint32_t cnt : 16;/* [15:0] */
802 __IO uint32_t reserved1 : 16; /*[31:16] */
803 } dtcnt_bit;
804 };
808 union
809 {
810 __IO uint32_t paddr;
811 struct
812 {
813 __IO uint32_t paddr : 32;/* [31:0] */
814 } paddr_bit;
815 };
819 union
820 {
821 __IO uint32_t m0addr;
822 struct
823 {
824 __IO uint32_t m0addr : 32;/* [31:0] */
825 } m0addr_bit;
826 };
830 union
831 {
832 __IO uint32_t m1addr;
833 struct
834 {
835 __IO uint32_t m1addr : 32;/* [31:0] */
836 } m1addr_bit;
837 };
841 union
842 {
843 __IO uint32_t fctrl;
844 struct
845 {
846 __IO uint32_t fthsel : 2; /* [1:0] */
847 __IO uint32_t fen : 1; /* [2] */
848 __IO uint32_t fsts : 3; /* [5:3] */
849 __IO uint32_t reserved1 : 1; /* [6] */
850 __IO uint32_t ferrien : 1; /* [7] */
851 __IO uint32_t reserved2 : 24;/* [31:8] */
852 } fctrl_bit;
853 };
854} edma_stream_type;
855
859typedef struct
860{
864 union
865 {
866 __IO uint32_t llp;
867 struct
868 {
869 __IO uint32_t llp : 32;/* [31:0] */
870 } llp_bit;
871 };
872} edma_stream_link_list_type;
873
877typedef struct
878{
882 union
883 {
884 __IO uint32_t s2dcnt;
885 struct
886 {
887 __IO uint32_t xcnt : 16;/* [15:0] */
888 __IO uint32_t ycnt : 16;/* [31:16] */
889 } s2dcnt_bit;
890 };
894 union
895 {
896 __IO uint32_t stride;
897 struct
898 {
899 __IO uint32_t srcstd : 16;/* [15:0] */
900 __IO uint32_t dststd : 16;/* [31:16] */
901 } stride_bit;
902 };
903} edma_stream_2d_type;
904
908typedef struct
909{
913 union
914 {
915 __IO uint32_t muxctrl;
916 struct
917 {
918 __IO uint32_t reqsel : 7; /* [6:0] */
919 __IO uint32_t reserved1 : 1; /* [7] */
920 __IO uint32_t syncovien : 1; /* [8] */
921 __IO uint32_t evtgen : 1; /* [9] */
922 __IO uint32_t reserved2 : 6; /* [15:10] */
923 __IO uint32_t syncen : 1; /* [16] */
924 __IO uint32_t syncpol : 2; /* [18:17] */
925 __IO uint32_t reqcnt : 5; /* [23:19] */
926 __IO uint32_t syncsel : 5; /* [28:24] */
927 __IO uint32_t reserved3 : 3; /* [31:29] */
928 }muxctrl_bit;
929 };
930} edmamux_channel_type;
931
935typedef struct
936{
940 union
941 {
942 __IO uint32_t gctrl;
943 struct
944 {
945 __IO uint32_t sigsel : 5; /* [4:0] */
946 __IO uint32_t reserved1 : 3; /* [7:5] */
947 __IO uint32_t trgovien : 1; /* [8] */
948 __IO uint32_t reserved2 : 7; /* [15:9] */
949 __IO uint32_t gen : 1; /* [16] */
950 __IO uint32_t gpol : 2; /* [18:17] */
951 __IO uint32_t greqcnt : 5; /* [23:19] */
952 __IO uint32_t reserved3 : 8; /* [31:24] */
953 }gctrl_bit;
954 };
955} edmamux_generator_type;
956
961#define EDMA ((edma_type *) EDMA_BASE)
962#define EDMA_STREAM1 ((edma_stream_type *) EDMA_STREAM1_BASE)
963#define EDMA_STREAM2 ((edma_stream_type *) EDMA_STREAM2_BASE)
964#define EDMA_STREAM3 ((edma_stream_type *) EDMA_STREAM3_BASE)
965#define EDMA_STREAM4 ((edma_stream_type *) EDMA_STREAM4_BASE)
966#define EDMA_STREAM5 ((edma_stream_type *) EDMA_STREAM5_BASE)
967#define EDMA_STREAM6 ((edma_stream_type *) EDMA_STREAM6_BASE)
968#define EDMA_STREAM7 ((edma_stream_type *) EDMA_STREAM7_BASE)
969#define EDMA_STREAM8 ((edma_stream_type *) EDMA_STREAM8_BASE)
970
971#define EDMA_STREAM1_2D ((edma_stream_2d_type *) EDMA_STREAM1_2D_BASE)
972#define EDMA_STREAM2_2D ((edma_stream_2d_type *) EDMA_STREAM2_2D_BASE)
973#define EDMA_STREAM3_2D ((edma_stream_2d_type *) EDMA_STREAM3_2D_BASE)
974#define EDMA_STREAM4_2D ((edma_stream_2d_type *) EDMA_STREAM4_2D_BASE)
975#define EDMA_STREAM5_2D ((edma_stream_2d_type *) EDMA_STREAM5_2D_BASE)
976#define EDMA_STREAM6_2D ((edma_stream_2d_type *) EDMA_STREAM6_2D_BASE)
977#define EDMA_STREAM7_2D ((edma_stream_2d_type *) EDMA_STREAM7_2D_BASE)
978#define EDMA_STREAM8_2D ((edma_stream_2d_type *) EDMA_STREAM8_2D_BASE)
979
980#define EDMA_STREAM1_LL ((edma_stream_link_list_type *) EDMA_STREAM1_LL_BASE)
981#define EDMA_STREAM2_LL ((edma_stream_link_list_type *) EDMA_STREAM2_LL_BASE)
982#define EDMA_STREAM3_LL ((edma_stream_link_list_type *) EDMA_STREAM3_LL_BASE)
983#define EDMA_STREAM4_LL ((edma_stream_link_list_type *) EDMA_STREAM4_LL_BASE)
984#define EDMA_STREAM5_LL ((edma_stream_link_list_type *) EDMA_STREAM5_LL_BASE)
985#define EDMA_STREAM6_LL ((edma_stream_link_list_type *) EDMA_STREAM6_LL_BASE)
986#define EDMA_STREAM7_LL ((edma_stream_link_list_type *) EDMA_STREAM7_LL_BASE)
987#define EDMA_STREAM8_LL ((edma_stream_link_list_type *) EDMA_STREAM8_LL_BASE)
988
989#define EDMAMUX_CHANNEL1 ((edmamux_channel_type *) EDMAMUX_CHANNEL1_BASE)
990#define EDMAMUX_CHANNEL2 ((edmamux_channel_type *) EDMAMUX_CHANNEL2_BASE)
991#define EDMAMUX_CHANNEL3 ((edmamux_channel_type *) EDMAMUX_CHANNEL3_BASE)
992#define EDMAMUX_CHANNEL4 ((edmamux_channel_type *) EDMAMUX_CHANNEL4_BASE)
993#define EDMAMUX_CHANNEL5 ((edmamux_channel_type *) EDMAMUX_CHANNEL5_BASE)
994#define EDMAMUX_CHANNEL6 ((edmamux_channel_type *) EDMAMUX_CHANNEL6_BASE)
995#define EDMAMUX_CHANNEL7 ((edmamux_channel_type *) EDMAMUX_CHANNEL7_BASE)
996#define EDMAMUX_CHANNEL8 ((edmamux_channel_type *) EDMAMUX_CHANNEL8_BASE)
997
998#define EDMAMUX_GENERATOR1 ((edmamux_generator_type *) EDMAMUX_GENERATOR1_BASE)
999#define EDMAMUX_GENERATOR2 ((edmamux_generator_type *) EDMAMUX_GENERATOR2_BASE)
1000#define EDMAMUX_GENERATOR3 ((edmamux_generator_type *) EDMAMUX_GENERATOR3_BASE)
1001#define EDMAMUX_GENERATOR4 ((edmamux_generator_type *) EDMAMUX_GENERATOR4_BASE)
1002
1007/* edma controller function */
1008void edma_reset(edma_stream_type *edma_streamx);
1009void edma_init(edma_stream_type *edma_streamx, edma_init_type *edma_init_struct);
1010void edma_default_para_init(edma_init_type *edma_init_struct);
1011void edma_stream_enable(edma_stream_type *edma_streamx, confirm_state new_state);
1012void edma_interrupt_enable(edma_stream_type *edma_streamx, uint32_t edma_int, confirm_state new_state);
1013void edma_peripheral_inc_offset_set(edma_stream_type *edma_streamx, edma_peripheral_inc_offset_type offset);
1014void edma_flow_controller_enable(edma_stream_type *edma_streamx, confirm_state new_state);
1015void edma_data_number_set(edma_stream_type *edma_streamx, uint16_t data_number);
1016uint16_t edma_data_number_get(edma_stream_type *edma_streamx);
1017void edma_double_buffer_mode_init(edma_stream_type *edma_streamx, uint32_t memory1_addr, edma_memory_type current_memory);
1018void edma_double_buffer_mode_enable(edma_stream_type *edma_streamx, confirm_state new_state);
1019void edma_memory_addr_set(edma_stream_type *edma_streamx, uint32_t memory_addr, uint32_t memory_target);
1020 edma_memory_type edma_memory_target_get(edma_stream_type *edma_streamx);
1021 flag_status edma_stream_status_get(edma_stream_type *edma_streamx);
1022uint8_t edma_fifo_status_get(edma_stream_type *edma_streamx);
1023 flag_status edma_flag_get(uint32_t edma_flag);
1024void edma_flag_clear(uint32_t edma_flag);
1025
1026/* edma 2d controller function */
1027void edma_2d_init(edma_stream_2d_type *edma_streamx_2d, int16_t src_stride, int16_t dst_stride, uint16_t xcnt, uint16_t ycnt);
1028void edma_2d_enable(edma_stream_2d_type *edma_streamx_2d, confirm_state new_state);
1029
1030/* dma link list controller function */
1031void edma_link_list_init(edma_stream_link_list_type *edma_streamx_ll, uint32_t pointer);
1032void edma_link_list_enable(edma_stream_link_list_type *edma_streamx_ll, confirm_state new_state);
1033
1034/* edma requst multiplexer function */
1035void edmamux_enable(confirm_state new_state);
1036void edmamux_init(edmamux_channel_type *edmamux_channelx, edmamux_requst_id_sel_type edmamux_req_id);
1037void edmamux_sync_default_para_init(edmamux_sync_init_type *edmamux_sync_init_struct);
1038void edmamux_sync_config(edmamux_channel_type *edmamux_channelx, edmamux_sync_init_type *edmamux_sync_init_struct);
1039void edmamux_generator_default_para_init(edmamux_gen_init_type *edmamux_gen_init_struct);
1040void edmamux_generator_config(edmamux_generator_type *edmamux_gen_x, edmamux_gen_init_type *edmamux_gen_init_struct);
1041void edmamux_sync_interrupt_enable(edmamux_channel_type *edmamux_channelx, confirm_state new_state);
1042void edmamux_generator_interrupt_enable(edmamux_generator_type *edmamux_gen_x, confirm_state new_state);
1043 flag_status edmamux_sync_flag_get(uint32_t flag);
1044void edmamux_sync_flag_clear(uint32_t flag);
1045 flag_status edmamux_generator_flag_get(uint32_t flag);
1046void edmamux_generator_flag_clear(uint32_t flag);
1047
1060#ifdef __cplusplus
1061}
1062#endif
1063
1064#endif
at32f435_437.h
at32f435_437 header file
edma_init_struct
edma_init_type edma_init_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:40
edmamux_sync_init_struct
edmamux_sync_init_type edmamux_sync_init_struct
Definition: project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c:40
edma_flag_get
flag_status edma_flag_get(uint32_t edma_flag)
get the edma flag.
Definition: at32f435_437_edma.c:512
edma_flag_clear
void edma_flag_clear(uint32_t edma_flag)
clear the edma flag.
Definition: at32f435_437_edma.c:549
edma_double_buffer_mode_init
void edma_double_buffer_mode_init(edma_stream_type *edma_streamx, uint32_t memory1_addr, edma_memory_type current_memory)
config the the double buffer mode.
Definition: at32f435_437_edma.c:354
edmamux_init
void edmamux_init(edmamux_channel_type *edmamux_channelx, edmamux_requst_id_sel_type edmamux_req_id)
edmamux init.
Definition: at32f435_437_edma.c:718
edmamux_generator_default_para_init
void edmamux_generator_default_para_init(edmamux_gen_init_type *edmamux_gen_init_struct)
edmamux request generator init struct config with its default value.
Definition: at32f435_437_edma.c:766
edma_flow_controller_enable
void edma_flow_controller_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx flow controller.
Definition: at32f435_437_edma.c:290
edma_memory_addr_set
void edma_memory_addr_set(edma_stream_type *edma_streamx, uint32_t memory_addr, uint32_t memory_target)
config the memory address in double buffer mode.
Definition: at32f435_437_edma.c:414
edma_init
void edma_init(edma_stream_type *edma_streamx, edma_init_type *edma_init_struct)
edma init.
Definition: at32f435_437_edma.c:115
edma_link_list_init
void edma_link_list_init(edma_stream_link_list_type *edma_streamx_ll, uint32_t pointer)
initialize the edma link list.
Definition: at32f435_437_edma.c:632
edma_memory_target_get
edma_memory_type edma_memory_target_get(edma_stream_type *edma_streamx)
get the current memory target.
Definition: at32f435_437_edma.c:442
edma_peripheral_inc_offset_set
void edma_peripheral_inc_offset_set(edma_stream_type *edma_streamx, edma_peripheral_inc_offset_type offset)
config the edma peripheral increment offset size mode.
Definition: at32f435_437_edma.c:270
edmamux_generator_config
void edmamux_generator_config(edmamux_generator_type *edmamux_gen_x, edmamux_gen_init_type *edmamux_gen_init_struct)
edmamux request generator init.
Definition: at32f435_437_edma.c:779
edma_2d_init
void edma_2d_init(edma_stream_2d_type *edma_streamx_2d, int16_t src_stride, int16_t dst_stride, uint16_t xcnt, uint16_t ycnt)
initialize the edma 2d mode.
Definition: at32f435_437_edma.c:579
edma_double_buffer_mode_enable
void edma_double_buffer_mode_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the double memory mode.
Definition: at32f435_437_edma.c:383
edma_data_number_get
uint16_t edma_data_number_get(edma_stream_type *edma_streamx)
get the number of data to be transferred.
Definition: at32f435_437_edma.c:330
edmamux_sync_default_para_init
void edmamux_sync_default_para_init(edmamux_sync_init_type *edmamux_sync_init_struct)
edmamux sync init struct config with its default value.
Definition: at32f435_437_edma.c:728
edma_2d_enable
void edma_2d_enable(edma_stream_2d_type *edma_streamx_2d, confirm_state new_state)
enable or disable the edma 2d mode.
Definition: at32f435_437_edma.c:601
edma_stream_status_get
flag_status edma_stream_status_get(edma_stream_type *edma_streamx)
get the enable status of edma streamx.
Definition: at32f435_437_edma.c:461
edma_stream_enable
void edma_stream_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx.
Definition: at32f435_437_edma.c:198
edma_fifo_status_get
uint8_t edma_fifo_status_get(edma_stream_type *edma_streamx)
get the fifo level status.
Definition: at32f435_437_edma.c:493
edmamux_sync_config
void edmamux_sync_config(edmamux_channel_type *edmamux_channelx, edmamux_sync_init_type *edmamux_sync_init_struct)
edmamux synchronization config.
Definition: at32f435_437_edma.c:752
edmamux_sync_flag_get
flag_status edmamux_sync_flag_get(uint32_t flag)
edmamux sync flag get.
Definition: at32f435_437_edma.c:851
edma_reset
void edma_reset(edma_stream_type *edma_streamx)
reset edma_streamx channely register.
Definition: at32f435_437_edma.c:58
edmamux_enable
void edmamux_enable(confirm_state new_state)
enable or disable the edma edmamux.
Definition: at32f435_437_edma.c:673
edmamux_sync_flag_clear
void edmamux_sync_flag_clear(uint32_t flag)
edmamux sync flag clear.
Definition: at32f435_437_edma.c:877
edmamux_generator_interrupt_enable
void edmamux_generator_interrupt_enable(edmamux_generator_type *edmamux_gen_x, confirm_state new_state)
enable or disable the edmamux request generator interrupts.
Definition: at32f435_437_edma.c:825
edma_link_list_enable
void edma_link_list_enable(edma_stream_link_list_type *edma_streamx_ll, confirm_state new_state)
enable or disable the edma stream link list mode.
Definition: at32f435_437_edma.c:652
edma_data_number_set
void edma_data_number_set(edma_stream_type *edma_streamx, uint16_t data_number)
set the number of data to be transferred.
Definition: at32f435_437_edma.c:310
edma_interrupt_enable
void edma_interrupt_enable(edma_stream_type *edma_streamx, uint32_t edma_int, confirm_state new_state)
enable or disable the edma streamx interrupts.
Definition: at32f435_437_edma.c:225
edmamux_generator_flag_get
flag_status edmamux_generator_flag_get(uint32_t flag)
edmamux request generator flag get.
Definition: at32f435_437_edma.c:892
edma_default_para_init
void edma_default_para_init(edma_init_type *edma_init_struct)
edma init struct config with its default value.
Definition: at32f435_437_edma.c:165
edmamux_sync_interrupt_enable
void edmamux_sync_interrupt_enable(edmamux_channel_type *edmamux_channelx, confirm_state new_state)
enable or disable the edmamux sync interrupts.
Definition: at32f435_437_edma.c:802
edmamux_generator_flag_clear
void edmamux_generator_flag_clear(uint32_t flag)
edmamux request generator flag clear.
Definition: at32f435_437_edma.c:914
edma_priority_level_type
edma_priority_level_type
edma priority level type
Definition: at32f435_437_edma.h:188
edmamux_sync_id_sel_type
edmamux_sync_id_sel_type
dmamux sync id select type
Definition: at32f435_437_edma.h:356
edma_peripheral_data_size_type
edma_peripheral_data_size_type
edma peripheral data size type
Definition: at32f435_437_edma.h:168
edma_memory_data_size_type
edma_memory_data_size_type
edma memory data size type
Definition: at32f435_437_edma.h:178
edma_memory_burst_type
edma_memory_burst_type
edma memory continuous mode type
Definition: at32f435_437_edma.h:223
edma_fifo_stutas_type
edma_fifo_stutas_type
edma fifo stutas level type
Definition: at32f435_437_edma.h:210
edma_peripheral_inc_offset_type
edma_peripheral_inc_offset_type
edma peripheral increment offset size type
Definition: at32f435_437_edma.h:245
edmamux_gen_id_sel_type
edmamux_gen_id_sel_type
dmamux generator id select type
Definition: at32f435_437_edma.h:398
edma_peripheral_burst_type
edma_peripheral_burst_type
edma peripheral continuous mode type
Definition: at32f435_437_edma.h:234
edma_fifo_threshold_type
edma_fifo_threshold_type
edma fifo threshold level type
Definition: at32f435_437_edma.h:199
edma_memory_type
edma_memory_type
edma memory targets define
Definition: at32f435_437_edma.h:149
edmamux_gen_pol_type
edmamux_gen_pol_type
dmamux generator polarity type
Definition: at32f435_437_edma.h:429
edma_dir_type
edma_dir_type
edma direction type
Definition: at32f435_437_edma.h:158
edmamux_sync_pol_type
edmamux_sync_pol_type
dmamux sync polarity type
Definition: at32f435_437_edma.h:387
edmamux_requst_id_sel_type
edmamux_requst_id_sel_type
edmamux request id select type
Definition: at32f435_437_edma.h:254
EDMA_PRIORITY_MEDIUM
@ EDMA_PRIORITY_MEDIUM
Definition: at32f435_437_edma.h:190
EDMA_PRIORITY_VERY_HIGH
@ EDMA_PRIORITY_VERY_HIGH
Definition: at32f435_437_edma.h:192
EDMA_PRIORITY_HIGH
@ EDMA_PRIORITY_HIGH
Definition: at32f435_437_edma.h:191
EDMA_PRIORITY_LOW
@ EDMA_PRIORITY_LOW
Definition: at32f435_437_edma.h:189
EDMAMUX_SYNC_ID_EXINT6
@ EDMAMUX_SYNC_ID_EXINT6
Definition: at32f435_437_edma.h:363
EDMAMUX_SYNC_ID_EXINT12
@ EDMAMUX_SYNC_ID_EXINT12
Definition: at32f435_437_edma.h:369
EDMAMUX_SYNC_ID_EXINT5
@ EDMAMUX_SYNC_ID_EXINT5
Definition: at32f435_437_edma.h:362
EDMAMUX_SYNC_ID_EXINT4
@ EDMAMUX_SYNC_ID_EXINT4
Definition: at32f435_437_edma.h:361
EDMAMUX_SYNC_ID_EXINT15
@ EDMAMUX_SYNC_ID_EXINT15
Definition: at32f435_437_edma.h:372
EDMAMUX_SYNC_ID_EXINT2
@ EDMAMUX_SYNC_ID_EXINT2
Definition: at32f435_437_edma.h:359
EDMAMUX_SYNC_ID_DMAMUX_CH6_EVT
@ EDMAMUX_SYNC_ID_DMAMUX_CH6_EVT
Definition: at32f435_437_edma.h:378
EDMAMUX_SYNC_ID_EXINT8
@ EDMAMUX_SYNC_ID_EXINT8
Definition: at32f435_437_edma.h:365
EDMAMUX_SYNC_ID_EXINT9
@ EDMAMUX_SYNC_ID_EXINT9
Definition: at32f435_437_edma.h:366
EDMAMUX_SYNC_ID_DMAMUX_CH4_EVT
@ EDMAMUX_SYNC_ID_DMAMUX_CH4_EVT
Definition: at32f435_437_edma.h:376
EDMAMUX_SYNC_ID_DMAMUX_CH1_EVT
@ EDMAMUX_SYNC_ID_DMAMUX_CH1_EVT
Definition: at32f435_437_edma.h:373
EDMAMUX_SYNC_ID_EXINT13
@ EDMAMUX_SYNC_ID_EXINT13
Definition: at32f435_437_edma.h:370
EDMAMUX_SYNC_ID_EXINT14
@ EDMAMUX_SYNC_ID_EXINT14
Definition: at32f435_437_edma.h:371
EDMAMUX_SYNC_ID_EXINT3
@ EDMAMUX_SYNC_ID_EXINT3
Definition: at32f435_437_edma.h:360
EDMAMUX_SYNC_ID_DMAMUX_CH3_EVT
@ EDMAMUX_SYNC_ID_DMAMUX_CH3_EVT
Definition: at32f435_437_edma.h:375
EDMAMUX_SYNC_ID_EXINT1
@ EDMAMUX_SYNC_ID_EXINT1
Definition: at32f435_437_edma.h:358
EDMAMUX_SYNC_ID_EXINT11
@ EDMAMUX_SYNC_ID_EXINT11
Definition: at32f435_437_edma.h:368
EDMAMUX_SYNC_ID_EXINT7
@ EDMAMUX_SYNC_ID_EXINT7
Definition: at32f435_437_edma.h:364
EDMAMUX_SYNC_ID_DMAMUX_CH5_EVT
@ EDMAMUX_SYNC_ID_DMAMUX_CH5_EVT
Definition: at32f435_437_edma.h:377
EDMAMUX_SYNC_ID_EXINT0
@ EDMAMUX_SYNC_ID_EXINT0
Definition: at32f435_437_edma.h:357
EDMAMUX_SYNC_ID_DMAMUX_CH7_EVT
@ EDMAMUX_SYNC_ID_DMAMUX_CH7_EVT
Definition: at32f435_437_edma.h:379
EDMAMUX_SYNC_ID_EXINT10
@ EDMAMUX_SYNC_ID_EXINT10
Definition: at32f435_437_edma.h:367
EDMAMUX_SYNC_ID_DMAMUX_CH2_EVT
@ EDMAMUX_SYNC_ID_DMAMUX_CH2_EVT
Definition: at32f435_437_edma.h:374
EDMAMUX_SYNC_ID_DMAMUX_CH8_EVT
@ EDMAMUX_SYNC_ID_DMAMUX_CH8_EVT
Definition: at32f435_437_edma.h:380
EDMA_PERIPHERAL_DATA_WIDTH_BYTE
@ EDMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f435_437_edma.h:169
EDMA_PERIPHERAL_DATA_WIDTH_WORD
@ EDMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_edma.h:171
EDMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ EDMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_edma.h:170
EDMA_MEMORY_DATA_WIDTH_HALFWORD
@ EDMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_edma.h:180
EDMA_MEMORY_DATA_WIDTH_WORD
@ EDMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f435_437_edma.h:181
EDMA_MEMORY_DATA_WIDTH_BYTE
@ EDMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f435_437_edma.h:179
EDMA_MEMORY_SINGLE
@ EDMA_MEMORY_SINGLE
Definition: at32f435_437_edma.h:224
EDMA_MEMORY_BURST_4
@ EDMA_MEMORY_BURST_4
Definition: at32f435_437_edma.h:225
EDMA_MEMORY_BURST_8
@ EDMA_MEMORY_BURST_8
Definition: at32f435_437_edma.h:226
EDMA_MEMORY_BURST_16
@ EDMA_MEMORY_BURST_16
Definition: at32f435_437_edma.h:227
EDMA_FIFO_STATUS_HALF
@ EDMA_FIFO_STATUS_HALF
Definition: at32f435_437_edma.h:213
EDMA_FIFO_STATUS_1QUARTER
@ EDMA_FIFO_STATUS_1QUARTER
Definition: at32f435_437_edma.h:212
EDMA_FIFO_STATUS_LESS_1QUARTER
@ EDMA_FIFO_STATUS_LESS_1QUARTER
Definition: at32f435_437_edma.h:211
EDMA_FIFO_STATUS_3QUARTER
@ EDMA_FIFO_STATUS_3QUARTER
Definition: at32f435_437_edma.h:214
EDMA_FIFO_STATUS_FULL
@ EDMA_FIFO_STATUS_FULL
Definition: at32f435_437_edma.h:216
EDMA_FIFO_STATUS_EMPTY
@ EDMA_FIFO_STATUS_EMPTY
Definition: at32f435_437_edma.h:215
EDMA_PERIPHERAL_INC_4_BYTE
@ EDMA_PERIPHERAL_INC_4_BYTE
Definition: at32f435_437_edma.h:247
EDMA_PERIPHERAL_INC_PSIZE
@ EDMA_PERIPHERAL_INC_PSIZE
Definition: at32f435_437_edma.h:246
EDMAMUX_GEN_ID_EXINT11
@ EDMAMUX_GEN_ID_EXINT11
Definition: at32f435_437_edma.h:410
EDMAMUX_GEN_ID_DMAMUX_CH6_EVT
@ EDMAMUX_GEN_ID_DMAMUX_CH6_EVT
Definition: at32f435_437_edma.h:420
EDMAMUX_GEN_ID_DMAMUX_CH5_EVT
@ EDMAMUX_GEN_ID_DMAMUX_CH5_EVT
Definition: at32f435_437_edma.h:419
EDMAMUX_GEN_ID_DMAMUX_CH8_EVT
@ EDMAMUX_GEN_ID_DMAMUX_CH8_EVT
Definition: at32f435_437_edma.h:422
EDMAMUX_GEN_ID_EXINT8
@ EDMAMUX_GEN_ID_EXINT8
Definition: at32f435_437_edma.h:407
EDMAMUX_GEN_ID_EXINT12
@ EDMAMUX_GEN_ID_EXINT12
Definition: at32f435_437_edma.h:411
EDMAMUX_GEN_ID_EXINT3
@ EDMAMUX_GEN_ID_EXINT3
Definition: at32f435_437_edma.h:402
EDMAMUX_GEN_ID_EXINT9
@ EDMAMUX_GEN_ID_EXINT9
Definition: at32f435_437_edma.h:408
EDMAMUX_GEN_ID_DMAMUX_CH2_EVT
@ EDMAMUX_GEN_ID_DMAMUX_CH2_EVT
Definition: at32f435_437_edma.h:416
EDMAMUX_GEN_ID_EXINT10
@ EDMAMUX_GEN_ID_EXINT10
Definition: at32f435_437_edma.h:409
EDMAMUX_GEN_ID_EXINT0
@ EDMAMUX_GEN_ID_EXINT0
Definition: at32f435_437_edma.h:399
EDMAMUX_GEN_ID_EXINT2
@ EDMAMUX_GEN_ID_EXINT2
Definition: at32f435_437_edma.h:401
EDMAMUX_GEN_ID_DMAMUX_CH3_EVT
@ EDMAMUX_GEN_ID_DMAMUX_CH3_EVT
Definition: at32f435_437_edma.h:417
EDMAMUX_GEN_ID_EXINT1
@ EDMAMUX_GEN_ID_EXINT1
Definition: at32f435_437_edma.h:400
EDMAMUX_GEN_ID_DMAMUX_CH1_EVT
@ EDMAMUX_GEN_ID_DMAMUX_CH1_EVT
Definition: at32f435_437_edma.h:415
EDMAMUX_GEN_ID_DMAMUX_CH4_EVT
@ EDMAMUX_GEN_ID_DMAMUX_CH4_EVT
Definition: at32f435_437_edma.h:418
EDMAMUX_GEN_ID_EXINT7
@ EDMAMUX_GEN_ID_EXINT7
Definition: at32f435_437_edma.h:406
EDMAMUX_GEN_ID_EXINT6
@ EDMAMUX_GEN_ID_EXINT6
Definition: at32f435_437_edma.h:405
EDMAMUX_GEN_ID_EXINT15
@ EDMAMUX_GEN_ID_EXINT15
Definition: at32f435_437_edma.h:414
EDMAMUX_GEN_ID_DMAMUX_CH7_EVT
@ EDMAMUX_GEN_ID_DMAMUX_CH7_EVT
Definition: at32f435_437_edma.h:421
EDMAMUX_GEN_ID_EXINT14
@ EDMAMUX_GEN_ID_EXINT14
Definition: at32f435_437_edma.h:413
EDMAMUX_GEN_ID_EXINT5
@ EDMAMUX_GEN_ID_EXINT5
Definition: at32f435_437_edma.h:404
EDMAMUX_GEN_ID_EXINT13
@ EDMAMUX_GEN_ID_EXINT13
Definition: at32f435_437_edma.h:412
EDMAMUX_GEN_ID_EXINT4
@ EDMAMUX_GEN_ID_EXINT4
Definition: at32f435_437_edma.h:403
EDMA_PERIPHERAL_BURST_16
@ EDMA_PERIPHERAL_BURST_16
Definition: at32f435_437_edma.h:238
EDMA_PERIPHERAL_SINGLE
@ EDMA_PERIPHERAL_SINGLE
Definition: at32f435_437_edma.h:235
EDMA_PERIPHERAL_BURST_4
@ EDMA_PERIPHERAL_BURST_4
Definition: at32f435_437_edma.h:236
EDMA_PERIPHERAL_BURST_8
@ EDMA_PERIPHERAL_BURST_8
Definition: at32f435_437_edma.h:237
EDMA_FIFO_THRESHOLD_3QUARTER
@ EDMA_FIFO_THRESHOLD_3QUARTER
Definition: at32f435_437_edma.h:202
EDMA_FIFO_THRESHOLD_HALF
@ EDMA_FIFO_THRESHOLD_HALF
Definition: at32f435_437_edma.h:201
EDMA_FIFO_THRESHOLD_FULL
@ EDMA_FIFO_THRESHOLD_FULL
Definition: at32f435_437_edma.h:203
EDMA_FIFO_THRESHOLD_1QUARTER
@ EDMA_FIFO_THRESHOLD_1QUARTER
Definition: at32f435_437_edma.h:200
EDMA_MEMORY_1
@ EDMA_MEMORY_1
Definition: at32f435_437_edma.h:151
EDMA_MEMORY_0
@ EDMA_MEMORY_0
Definition: at32f435_437_edma.h:150
EDMAMUX_GEN_POLARITY_RISING
@ EDMAMUX_GEN_POLARITY_RISING
Definition: at32f435_437_edma.h:431
EDMAMUX_GEN_POLARITY_RISING_FALLING
@ EDMAMUX_GEN_POLARITY_RISING_FALLING
Definition: at32f435_437_edma.h:433
EDMAMUX_GEN_POLARITY_DISABLE
@ EDMAMUX_GEN_POLARITY_DISABLE
Definition: at32f435_437_edma.h:430
EDMAMUX_GEN_POLARITY_FALLING
@ EDMAMUX_GEN_POLARITY_FALLING
Definition: at32f435_437_edma.h:432
EDMA_DIR_MEMORY_TO_PERIPHERAL
@ EDMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_edma.h:160
EDMA_DIR_PERIPHERAL_TO_MEMORY
@ EDMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_edma.h:159
EDMA_DIR_MEMORY_TO_MEMORY
@ EDMA_DIR_MEMORY_TO_MEMORY
Definition: at32f435_437_edma.h:161
EDMAMUX_SYNC_POLARITY_DISABLE
@ EDMAMUX_SYNC_POLARITY_DISABLE
Definition: at32f435_437_edma.h:388
EDMAMUX_SYNC_POLARITY_RISING_FALLING
@ EDMAMUX_SYNC_POLARITY_RISING_FALLING
Definition: at32f435_437_edma.h:391
EDMAMUX_SYNC_POLARITY_FALLING
@ EDMAMUX_SYNC_POLARITY_FALLING
Definition: at32f435_437_edma.h:390
EDMAMUX_SYNC_POLARITY_RISING
@ EDMAMUX_SYNC_POLARITY_RISING
Definition: at32f435_437_edma.h:389
EDMAMUX_DMAREQ_ID_SPI2_RX
@ EDMAMUX_DMAREQ_ID_SPI2_RX
Definition: at32f435_437_edma.h:268
EDMAMUX_DMAREQ_ID_TMR4_CH4
@ EDMAMUX_DMAREQ_ID_TMR4_CH4
Definition: at32f435_437_edma.h:333
EDMAMUX_DMAREQ_ID_DAC1
@ EDMAMUX_DMAREQ_ID_DAC1
Definition: at32f435_437_edma.h:262
EDMAMUX_DMAREQ_ID_TMR1_CH2
@ EDMAMUX_DMAREQ_ID_TMR1_CH2
Definition: at32f435_437_edma.h:305
EDMAMUX_DMAREQ_ID_TMR3_CH3
@ EDMAMUX_DMAREQ_ID_TMR3_CH3
Definition: at32f435_437_edma.h:326
EDMAMUX_DMAREQ_ID_SPI3_TX
@ EDMAMUX_DMAREQ_ID_SPI3_TX
Definition: at32f435_437_edma.h:271
EDMAMUX_DMAREQ_ID_QSPI2
@ EDMAMUX_DMAREQ_ID_QSPI2
Definition: at32f435_437_edma.h:303
EDMAMUX_DMAREQ_ID_TMR20_CH3
@ EDMAMUX_DMAREQ_ID_TMR20_CH3
Definition: at32f435_437_edma.h:344
EDMAMUX_DMAREQ_ID_TMR4_CH3
@ EDMAMUX_DMAREQ_ID_TMR4_CH3
Definition: at32f435_437_edma.h:332
EDMAMUX_DMAREQ_ID_TMR5_CH4
@ EDMAMUX_DMAREQ_ID_TMR5_CH4
Definition: at32f435_437_edma.h:339
EDMAMUX_DMAREQ_ID_I2S3_EXT_TX
@ EDMAMUX_DMAREQ_ID_I2S3_EXT_TX
Definition: at32f435_437_edma.h:277
EDMAMUX_DMAREQ_ID_I2C2_RX
@ EDMAMUX_DMAREQ_ID_I2C2_RX
Definition: at32f435_437_edma.h:280
EDMAMUX_DMAREQ_ID_TMR20_CH2
@ EDMAMUX_DMAREQ_ID_TMR20_CH2
Definition: at32f435_437_edma.h:343
EDMAMUX_DMAREQ_ID_TMR7_OVERFLOW
@ EDMAMUX_DMAREQ_ID_TMR7_OVERFLOW
Definition: at32f435_437_edma.h:265
EDMAMUX_DMAREQ_ID_TMR20_HALL
@ EDMAMUX_DMAREQ_ID_TMR20_HALL
Definition: at32f435_437_edma.h:348
EDMAMUX_DMAREQ_ID_UART4_RX
@ EDMAMUX_DMAREQ_ID_UART4_RX
Definition: at32f435_437_edma.h:290
EDMAMUX_DMAREQ_ID_UART8_TX
@ EDMAMUX_DMAREQ_ID_UART8_TX
Definition: at32f435_437_edma.h:299
EDMAMUX_DMAREQ_ID_TMR8_HALL
@ EDMAMUX_DMAREQ_ID_TMR8_HALL
Definition: at32f435_437_edma.h:317
EDMAMUX_DMAREQ_ID_SDIO1
@ EDMAMUX_DMAREQ_ID_SDIO1
Definition: at32f435_437_edma.h:300
EDMAMUX_DMAREQ_ID_ADC1
@ EDMAMUX_DMAREQ_ID_ADC1
Definition: at32f435_437_edma.h:259
EDMAMUX_DMAREQ_ID_TMR20_TRIG
@ EDMAMUX_DMAREQ_ID_TMR20_TRIG
Definition: at32f435_437_edma.h:347
EDMAMUX_DMAREQ_ID_USART1_TX
@ EDMAMUX_DMAREQ_ID_USART1_TX
Definition: at32f435_437_edma.h:285
EDMAMUX_DMAREQ_ID_TMR8_OVERFLOW
@ EDMAMUX_DMAREQ_ID_TMR8_OVERFLOW
Definition: at32f435_437_edma.h:315
EDMAMUX_DMAREQ_ID_TMR1_HALL
@ EDMAMUX_DMAREQ_ID_TMR1_HALL
Definition: at32f435_437_edma.h:310
EDMAMUX_DMAREQ_ID_SDIO2
@ EDMAMUX_DMAREQ_ID_SDIO2
Definition: at32f435_437_edma.h:301
EDMAMUX_DMAREQ_ID_SPI1_TX
@ EDMAMUX_DMAREQ_ID_SPI1_TX
Definition: at32f435_437_edma.h:267
EDMAMUX_DMAREQ_ID_UART8_RX
@ EDMAMUX_DMAREQ_ID_UART8_RX
Definition: at32f435_437_edma.h:298
EDMAMUX_DMAREQ_ID_I2S2_EXT_TX
@ EDMAMUX_DMAREQ_ID_I2S2_EXT_TX
Definition: at32f435_437_edma.h:275
EDMAMUX_DMAREQ_ID_TMR4_OVERFLOW
@ EDMAMUX_DMAREQ_ID_TMR4_OVERFLOW
Definition: at32f435_437_edma.h:334
EDMAMUX_DMAREQ_ID_QSPI1
@ EDMAMUX_DMAREQ_ID_QSPI1
Definition: at32f435_437_edma.h:302
EDMAMUX_DMAREQ_ID_TMR4_TRIG
@ EDMAMUX_DMAREQ_ID_TMR4_TRIG
Definition: at32f435_437_edma.h:335
EDMAMUX_DMAREQ_ID_ADC2
@ EDMAMUX_DMAREQ_ID_ADC2
Definition: at32f435_437_edma.h:260
EDMAMUX_DMAREQ_ID_USART6_RX
@ EDMAMUX_DMAREQ_ID_USART6_RX
Definition: at32f435_437_edma.h:294
EDMAMUX_DMAREQ_ID_TMR8_CH4
@ EDMAMUX_DMAREQ_ID_TMR8_CH4
Definition: at32f435_437_edma.h:314
EDMAMUX_DMAREQ_ID_TMR6_OVERFLOW
@ EDMAMUX_DMAREQ_ID_TMR6_OVERFLOW
Definition: at32f435_437_edma.h:264
EDMAMUX_DMAREQ_ID_UART7_TX
@ EDMAMUX_DMAREQ_ID_UART7_TX
Definition: at32f435_437_edma.h:297
EDMAMUX_DMAREQ_ID_I2C1_TX
@ EDMAMUX_DMAREQ_ID_I2C1_TX
Definition: at32f435_437_edma.h:279
EDMAMUX_DMAREQ_ID_UART4_TX
@ EDMAMUX_DMAREQ_ID_UART4_TX
Definition: at32f435_437_edma.h:291
EDMAMUX_DMAREQ_ID_I2C2_TX
@ EDMAMUX_DMAREQ_ID_I2C2_TX
Definition: at32f435_437_edma.h:281
EDMAMUX_DMAREQ_ID_I2C3_TX
@ EDMAMUX_DMAREQ_ID_I2C3_TX
Definition: at32f435_437_edma.h:283
EDMAMUX_DMAREQ_ID_TMR5_CH3
@ EDMAMUX_DMAREQ_ID_TMR5_CH3
Definition: at32f435_437_edma.h:338
EDMAMUX_DMAREQ_ID_REQ_G4
@ EDMAMUX_DMAREQ_ID_REQ_G4
Definition: at32f435_437_edma.h:258
EDMAMUX_DMAREQ_ID_TMR1_CH4
@ EDMAMUX_DMAREQ_ID_TMR1_CH4
Definition: at32f435_437_edma.h:307
EDMAMUX_DMAREQ_ID_TMR2_CH1
@ EDMAMUX_DMAREQ_ID_TMR2_CH1
Definition: at32f435_437_edma.h:318
EDMAMUX_DMAREQ_ID_UART5_RX
@ EDMAMUX_DMAREQ_ID_UART5_RX
Definition: at32f435_437_edma.h:292
EDMAMUX_DMAREQ_ID_USART1_RX
@ EDMAMUX_DMAREQ_ID_USART1_RX
Definition: at32f435_437_edma.h:284
EDMAMUX_DMAREQ_ID_TMR2_CH3
@ EDMAMUX_DMAREQ_ID_TMR2_CH3
Definition: at32f435_437_edma.h:320
EDMAMUX_DMAREQ_ID_SPI4_TX
@ EDMAMUX_DMAREQ_ID_SPI4_TX
Definition: at32f435_437_edma.h:273
EDMAMUX_DMAREQ_ID_I2C1_RX
@ EDMAMUX_DMAREQ_ID_I2C1_RX
Definition: at32f435_437_edma.h:278
EDMAMUX_DMAREQ_ID_TMR2_CH2
@ EDMAMUX_DMAREQ_ID_TMR2_CH2
Definition: at32f435_437_edma.h:319
EDMAMUX_DMAREQ_ID_TMR8_CH1
@ EDMAMUX_DMAREQ_ID_TMR8_CH1
Definition: at32f435_437_edma.h:311
EDMAMUX_DMAREQ_ID_TMR5_CH1
@ EDMAMUX_DMAREQ_ID_TMR5_CH1
Definition: at32f435_437_edma.h:336
EDMAMUX_DMAREQ_ID_SPI3_RX
@ EDMAMUX_DMAREQ_ID_SPI3_RX
Definition: at32f435_437_edma.h:270
EDMAMUX_DMAREQ_ID_TMR3_TRIG
@ EDMAMUX_DMAREQ_ID_TMR3_TRIG
Definition: at32f435_437_edma.h:329
EDMAMUX_DMAREQ_ID_TMR2_OVERFLOW
@ EDMAMUX_DMAREQ_ID_TMR2_OVERFLOW
Definition: at32f435_437_edma.h:322
EDMAMUX_DMAREQ_ID_USART2_TX
@ EDMAMUX_DMAREQ_ID_USART2_TX
Definition: at32f435_437_edma.h:287
EDMAMUX_DMAREQ_ID_TMR3_OVERFLOW
@ EDMAMUX_DMAREQ_ID_TMR3_OVERFLOW
Definition: at32f435_437_edma.h:328
EDMAMUX_DMAREQ_ID_UART5_TX
@ EDMAMUX_DMAREQ_ID_UART5_TX
Definition: at32f435_437_edma.h:293
EDMAMUX_DMAREQ_ID_TMR20_CH4
@ EDMAMUX_DMAREQ_ID_TMR20_CH4
Definition: at32f435_437_edma.h:345
EDMAMUX_DMAREQ_ID_TMR1_CH3
@ EDMAMUX_DMAREQ_ID_TMR1_CH3
Definition: at32f435_437_edma.h:306
EDMAMUX_DMAREQ_ID_TMR3_CH2
@ EDMAMUX_DMAREQ_ID_TMR3_CH2
Definition: at32f435_437_edma.h:325
EDMAMUX_DMAREQ_ID_TMR5_OVERFLOW
@ EDMAMUX_DMAREQ_ID_TMR5_OVERFLOW
Definition: at32f435_437_edma.h:340
EDMAMUX_DMAREQ_ID_UART7_RX
@ EDMAMUX_DMAREQ_ID_UART7_RX
Definition: at32f435_437_edma.h:296
EDMAMUX_DMAREQ_ID_USART6_TX
@ EDMAMUX_DMAREQ_ID_USART6_TX
Definition: at32f435_437_edma.h:295
EDMAMUX_DMAREQ_ID_DVP
@ EDMAMUX_DMAREQ_ID_DVP
Definition: at32f435_437_edma.h:349
EDMAMUX_DMAREQ_ID_SPI1_RX
@ EDMAMUX_DMAREQ_ID_SPI1_RX
Definition: at32f435_437_edma.h:266
EDMAMUX_DMAREQ_ID_I2C3_RX
@ EDMAMUX_DMAREQ_ID_I2C3_RX
Definition: at32f435_437_edma.h:282
EDMAMUX_DMAREQ_ID_TMR4_CH2
@ EDMAMUX_DMAREQ_ID_TMR4_CH2
Definition: at32f435_437_edma.h:331
EDMAMUX_DMAREQ_ID_I2S3_EXT_RX
@ EDMAMUX_DMAREQ_ID_I2S3_EXT_RX
Definition: at32f435_437_edma.h:276
EDMAMUX_DMAREQ_ID_REQ_G3
@ EDMAMUX_DMAREQ_ID_REQ_G3
Definition: at32f435_437_edma.h:257
EDMAMUX_DMAREQ_ID_TMR3_CH4
@ EDMAMUX_DMAREQ_ID_TMR3_CH4
Definition: at32f435_437_edma.h:327
EDMAMUX_DMAREQ_ID_TMR4_CH1
@ EDMAMUX_DMAREQ_ID_TMR4_CH1
Definition: at32f435_437_edma.h:330
EDMAMUX_DMAREQ_ID_ADC3
@ EDMAMUX_DMAREQ_ID_ADC3
Definition: at32f435_437_edma.h:261
EDMAMUX_DMAREQ_ID_TMR3_CH1
@ EDMAMUX_DMAREQ_ID_TMR3_CH1
Definition: at32f435_437_edma.h:324
EDMAMUX_DMAREQ_ID_TMR20_OVERFLOW
@ EDMAMUX_DMAREQ_ID_TMR20_OVERFLOW
Definition: at32f435_437_edma.h:346
EDMAMUX_DMAREQ_ID_TMR20_CH1
@ EDMAMUX_DMAREQ_ID_TMR20_CH1
Definition: at32f435_437_edma.h:342
EDMAMUX_DMAREQ_ID_TMR1_CH1
@ EDMAMUX_DMAREQ_ID_TMR1_CH1
Definition: at32f435_437_edma.h:304
EDMAMUX_DMAREQ_ID_TMR1_OVERFLOW
@ EDMAMUX_DMAREQ_ID_TMR1_OVERFLOW
Definition: at32f435_437_edma.h:308
EDMAMUX_DMAREQ_ID_TMR5_CH2
@ EDMAMUX_DMAREQ_ID_TMR5_CH2
Definition: at32f435_437_edma.h:337
EDMAMUX_DMAREQ_ID_TMR8_CH3
@ EDMAMUX_DMAREQ_ID_TMR8_CH3
Definition: at32f435_437_edma.h:313
EDMAMUX_DMAREQ_ID_SPI4_RX
@ EDMAMUX_DMAREQ_ID_SPI4_RX
Definition: at32f435_437_edma.h:272
EDMAMUX_DMAREQ_ID_I2S2_EXT_RX
@ EDMAMUX_DMAREQ_ID_I2S2_EXT_RX
Definition: at32f435_437_edma.h:274
EDMAMUX_DMAREQ_ID_DAC2
@ EDMAMUX_DMAREQ_ID_DAC2
Definition: at32f435_437_edma.h:263
EDMAMUX_DMAREQ_ID_USART3_TX
@ EDMAMUX_DMAREQ_ID_USART3_TX
Definition: at32f435_437_edma.h:289
EDMAMUX_DMAREQ_ID_TMR2_CH4
@ EDMAMUX_DMAREQ_ID_TMR2_CH4
Definition: at32f435_437_edma.h:321
EDMAMUX_DMAREQ_ID_USART3_RX
@ EDMAMUX_DMAREQ_ID_USART3_RX
Definition: at32f435_437_edma.h:288
EDMAMUX_DMAREQ_ID_REQ_G1
@ EDMAMUX_DMAREQ_ID_REQ_G1
Definition: at32f435_437_edma.h:255
EDMAMUX_DMAREQ_ID_USART2_RX
@ EDMAMUX_DMAREQ_ID_USART2_RX
Definition: at32f435_437_edma.h:286
EDMAMUX_DMAREQ_ID_TMR2_TRIG
@ EDMAMUX_DMAREQ_ID_TMR2_TRIG
Definition: at32f435_437_edma.h:323
EDMAMUX_DMAREQ_ID_TMR5_TRIG
@ EDMAMUX_DMAREQ_ID_TMR5_TRIG
Definition: at32f435_437_edma.h:341
EDMAMUX_DMAREQ_ID_TMR8_TRIG
@ EDMAMUX_DMAREQ_ID_TMR8_TRIG
Definition: at32f435_437_edma.h:316
EDMAMUX_DMAREQ_ID_REQ_G2
@ EDMAMUX_DMAREQ_ID_REQ_G2
Definition: at32f435_437_edma.h:256
EDMAMUX_DMAREQ_ID_TMR1_TRIG
@ EDMAMUX_DMAREQ_ID_TMR1_TRIG
Definition: at32f435_437_edma.h:309
EDMAMUX_DMAREQ_ID_SPI2_TX
@ EDMAMUX_DMAREQ_ID_SPI2_TX
Definition: at32f435_437_edma.h:269
EDMAMUX_DMAREQ_ID_TMR8_CH2
@ EDMAMUX_DMAREQ_ID_TMR8_CH2
Definition: at32f435_437_edma.h:312
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
edma_init_type
edma init type
Definition: at32f435_437_edma.h:440
edma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_edma.h:441
edma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_edma.h:444
edma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_edma.h:446
edma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_edma.h:445
edma_init_type::direction
edma_dir_type direction
Definition: at32f435_437_edma.h:443
edma_init_type::fifo_mode_enable
confirm_state fifo_mode_enable
Definition: at32f435_437_edma.h:451
edma_init_type::peripheral_data_width
edma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_edma.h:447
edma_init_type::fifo_threshold
edma_fifo_threshold_type fifo_threshold
Definition: at32f435_437_edma.h:452
edma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_edma.h:449
edma_init_type::priority
edma_priority_level_type priority
Definition: at32f435_437_edma.h:450
edma_init_type::memory0_base_addr
uint32_t memory0_base_addr
Definition: at32f435_437_edma.h:442
edma_init_type::peripheral_burst_mode
edma_peripheral_burst_type peripheral_burst_mode
Definition: at32f435_437_edma.h:454
edma_init_type::memory_data_width
edma_memory_data_size_type memory_data_width
Definition: at32f435_437_edma.h:448
edma_init_type::memory_burst_mode
edma_memory_burst_type memory_burst_mode
Definition: at32f435_437_edma.h:453
edma_stream_2d_type
type define edma 2d register all
Definition: at32f435_437_edma.h:878
edma_stream_2d_type::stride
__IO uint32_t stride
Definition: at32f435_437_edma.h:896
edma_stream_2d_type::dststd
__IO uint32_t dststd
Definition: at32f435_437_edma.h:900
edma_stream_2d_type::ycnt
__IO uint32_t ycnt
Definition: at32f435_437_edma.h:888
edma_stream_2d_type::xcnt
__IO uint32_t xcnt
Definition: at32f435_437_edma.h:887
edma_stream_2d_type::srcstd
__IO uint32_t srcstd
Definition: at32f435_437_edma.h:899
edma_stream_2d_type::s2dcnt
__IO uint32_t s2dcnt
Definition: at32f435_437_edma.h:884
edma_stream_link_list_type
type define edma stream link list pointer register
Definition: at32f435_437_edma.h:860
edma_stream_link_list_type::llp
__IO uint32_t llp
Definition: at32f435_437_edma.h:866
edma_stream_type
type define edma stream register all
Definition: at32f435_437_edma.h:761
edma_stream_type::cm
__IO uint32_t cm
Definition: at32f435_437_edma.h:785
edma_stream_type::mwidth
__IO uint32_t mwidth
Definition: at32f435_437_edma.h:781
edma_stream_type::spl
__IO uint32_t spl
Definition: at32f435_437_edma.h:783
edma_stream_type::fthsel
__IO uint32_t fthsel
Definition: at32f435_437_edma.h:846
edma_stream_type::m0addr
__IO uint32_t m0addr
Definition: at32f435_437_edma.h:821
edma_stream_type::fdtien
__IO uint32_t fdtien
Definition: at32f435_437_edma.h:774
edma_stream_type::pfctrl
__IO uint32_t pfctrl
Definition: at32f435_437_edma.h:775
edma_stream_type::ctrl
__IO uint32_t ctrl
Definition: at32f435_437_edma.h:767
edma_stream_type::pct
__IO uint32_t pct
Definition: at32f435_437_edma.h:787
edma_stream_type::mincm
__IO uint32_t mincm
Definition: at32f435_437_edma.h:779
edma_stream_type::m1addr
__IO uint32_t m1addr
Definition: at32f435_437_edma.h:832
edma_stream_type::pincm
__IO uint32_t pincm
Definition: at32f435_437_edma.h:778
edma_stream_type::lm
__IO uint32_t lm
Definition: at32f435_437_edma.h:777
edma_stream_type::fsts
__IO uint32_t fsts
Definition: at32f435_437_edma.h:848
edma_stream_type::ferrien
__IO uint32_t ferrien
Definition: at32f435_437_edma.h:850
edma_stream_type::fctrl
__IO uint32_t fctrl
Definition: at32f435_437_edma.h:843
edma_stream_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_edma.h:789
edma_stream_type::dtd
__IO uint32_t dtd
Definition: at32f435_437_edma.h:776
edma_stream_type::paddr
__IO uint32_t paddr
Definition: at32f435_437_edma.h:810
edma_stream_type::mct
__IO uint32_t mct
Definition: at32f435_437_edma.h:788
edma_stream_type::dtcnt
__IO uint32_t dtcnt
Definition: at32f435_437_edma.h:798
edma_stream_type::dterrien
__IO uint32_t dterrien
Definition: at32f435_437_edma.h:772
edma_stream_type::pincos
__IO uint32_t pincos
Definition: at32f435_437_edma.h:782
edma_stream_type::cnt
__IO uint32_t cnt
Definition: at32f435_437_edma.h:801
edma_stream_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_edma.h:790
edma_stream_type::pwidth
__IO uint32_t pwidth
Definition: at32f435_437_edma.h:780
edma_stream_type::dmerrien
__IO uint32_t dmerrien
Definition: at32f435_437_edma.h:771
edma_stream_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_edma.h:786
edma_stream_type::hdtien
__IO uint32_t hdtien
Definition: at32f435_437_edma.h:773
edma_stream_type::fen
__IO uint32_t fen
Definition: at32f435_437_edma.h:847
edma_stream_type::sen
__IO uint32_t sen
Definition: at32f435_437_edma.h:770
edma_stream_type::dmm
__IO uint32_t dmm
Definition: at32f435_437_edma.h:784
edma_type
type define edma register all
Definition: at32f435_437_edma.h:484
edma_type::dmerrfc4
__IO uint32_t dmerrfc4
Definition: at32f435_437_edma.h:586
edma_type::trgovfc
__IO uint32_t trgovfc
Definition: at32f435_437_edma.h:750
edma_type::s52den
__IO uint32_t s52den
Definition: at32f435_437_edma.h:672
edma_type::dterrfc2
__IO uint32_t dterrfc2
Definition: at32f435_437_edma.h:574
edma_type::s82den
__IO uint32_t s82den
Definition: at32f435_437_edma.h:675
edma_type::ferrfc8
__IO uint32_t ferrfc8
Definition: at32f435_437_edma.h:620
edma_type::reserved1
__IO uint32_t reserved1
reserved, offset:0x10~0xCC
Definition: at32f435_437_edma.h:494
edma_type::hdtf2
__IO uint32_t hdtf2
Definition: at32f435_437_edma.h:503
edma_type::sts1
__IO uint32_t sts1
Definition: at32f435_437_edma.h:490
edma_type::reserved5
__IO uint32_t reserved5
Definition: at32f435_437_edma.h:513
edma_type::hdtfc1
__IO uint32_t hdtfc1
Definition: at32f435_437_edma.h:569
edma_type::dterrfc3
__IO uint32_t dterrfc3
Definition: at32f435_437_edma.h:581
edma_type::ferrfc7
__IO uint32_t ferrfc7
Definition: at32f435_437_edma.h:614
edma_type::dterrfc8
__IO uint32_t dterrfc8
Definition: at32f435_437_edma.h:623
edma_type::dterrfc1
__IO uint32_t dterrfc1
Definition: at32f435_437_edma.h:568
edma_type::dmerrf4
__IO uint32_t dmerrf4
Definition: at32f435_437_edma.h:514
edma_type::s32den
__IO uint32_t s32den
Definition: at32f435_437_edma.h:670
edma_type::hdtf8
__IO uint32_t hdtf8
Definition: at32f435_437_edma.h:552
edma_type::s3llen
__IO uint32_t s3llen
Definition: at32f435_437_edma.h:645
edma_type::muxsyncsts
__IO uint32_t muxsyncsts
Definition: at32f435_437_edma.h:708
edma_type::hdtf3
__IO uint32_t hdtf3
Definition: at32f435_437_edma.h:510
edma_type::s7llen
__IO uint32_t s7llen
Definition: at32f435_437_edma.h:649
edma_type::dterrf4
__IO uint32_t dterrf4
Definition: at32f435_437_edma.h:515
edma_type::trgovf
__IO uint32_t trgovf
Definition: at32f435_437_edma.h:737
edma_type::ferrfc1
__IO uint32_t ferrfc1
Definition: at32f435_437_edma.h:565
edma_type::ferrf3
__IO uint32_t ferrf3
Definition: at32f435_437_edma.h:506
edma_type::syncovf
__IO uint32_t syncovf
Definition: at32f435_437_edma.h:711
edma_type::sts2
__IO uint32_t sts2
Definition: at32f435_437_edma.h:526
edma_type::muxgsts
__IO uint32_t muxgsts
Definition: at32f435_437_edma.h:734
edma_type::dmerrf8
__IO uint32_t dmerrf8
Definition: at32f435_437_edma.h:550
edma_type::reserved3
__IO uint32_t reserved3
reserved, offset:0xF8~0x138
Definition: at32f435_437_edma.h:505
edma_type::dterrfc4
__IO uint32_t dterrfc4
Definition: at32f435_437_edma.h:587
edma_type::s42den
__IO uint32_t s42den
Definition: at32f435_437_edma.h:671
edma_type::hdtfc2
__IO uint32_t hdtfc2
Definition: at32f435_437_edma.h:575
edma_type::ferrfc3
__IO uint32_t ferrfc3
Definition: at32f435_437_edma.h:578
edma_type::hdtfc4
__IO uint32_t hdtfc4
Definition: at32f435_437_edma.h:588
edma_type::clr1
__IO uint32_t clr1
Definition: at32f435_437_edma.h:562
edma_type::fdtfc1
__IO uint32_t fdtfc1
Definition: at32f435_437_edma.h:570
edma_type::hdtf1
__IO uint32_t hdtf1
Definition: at32f435_437_edma.h:497
edma_type::s62den
__IO uint32_t s62den
Definition: at32f435_437_edma.h:673
edma_type::s4llen
__IO uint32_t s4llen
Definition: at32f435_437_edma.h:646
edma_type::dterrf3
__IO uint32_t dterrf3
Definition: at32f435_437_edma.h:509
edma_type::reserved6
__IO uint32_t reserved6
Definition: at32f435_437_edma.h:518
edma_type::tblsel
__IO uint32_t tblsel
Definition: at32f435_437_edma.h:693
edma_type::fdtfc4
__IO uint32_t fdtfc4
Definition: at32f435_437_edma.h:589
edma_type::fdtf2
__IO uint32_t fdtf2
Definition: at32f435_437_edma.h:504
edma_type::fdtfc6
__IO uint32_t fdtfc6
Definition: at32f435_437_edma.h:612
edma_type::ferrfc6
__IO uint32_t ferrfc6
Definition: at32f435_437_edma.h:607
edma_type::dmerrfc6
__IO uint32_t dmerrfc6
Definition: at32f435_437_edma.h:609
edma_type::dmerrfc2
__IO uint32_t dmerrfc2
Definition: at32f435_437_edma.h:573
edma_type::ferrf5
__IO uint32_t ferrf5
Definition: at32f435_437_edma.h:529
edma_type::dmerrfc3
__IO uint32_t dmerrfc3
Definition: at32f435_437_edma.h:580
edma_type::fdtfc3
__IO uint32_t fdtfc3
Definition: at32f435_437_edma.h:583
edma_type::fdtfc8
__IO uint32_t fdtfc8
Definition: at32f435_437_edma.h:625
edma_type::dmerrfc8
__IO uint32_t dmerrfc8
Definition: at32f435_437_edma.h:622
edma_type::dterrf2
__IO uint32_t dterrf2
Definition: at32f435_437_edma.h:502
edma_type::hdtfc5
__IO uint32_t hdtfc5
Definition: at32f435_437_edma.h:605
edma_type::fdtf5
__IO uint32_t fdtf5
Definition: at32f435_437_edma.h:534
edma_type::dterrf6
__IO uint32_t dterrf6
Definition: at32f435_437_edma.h:538
edma_type::dmerrf6
__IO uint32_t dmerrf6
Definition: at32f435_437_edma.h:537
edma_type::ferrf4
__IO uint32_t ferrf4
Definition: at32f435_437_edma.h:512
edma_type::dmerrf3
__IO uint32_t dmerrf3
Definition: at32f435_437_edma.h:508
edma_type::s72den
__IO uint32_t s72den
Definition: at32f435_437_edma.h:674
edma_type::s22den
__IO uint32_t s22den
Definition: at32f435_437_edma.h:669
edma_type::muxsyncclr
__IO uint32_t muxsyncclr
Definition: at32f435_437_edma.h:721
edma_type::hdtfc6
__IO uint32_t hdtfc6
Definition: at32f435_437_edma.h:611
edma_type::fdtfc5
__IO uint32_t fdtfc5
Definition: at32f435_437_edma.h:606
edma_type::s1llen
__IO uint32_t s1llen
Definition: at32f435_437_edma.h:643
edma_type::dterrf5
__IO uint32_t dterrf5
Definition: at32f435_437_edma.h:532
edma_type::s2llen
__IO uint32_t s2llen
Definition: at32f435_437_edma.h:644
edma_type::llctrl
__IO uint32_t llctrl
Definition: at32f435_437_edma.h:640
edma_type::ferrf2
__IO uint32_t ferrf2
Definition: at32f435_437_edma.h:499
edma_type::hdtf4
__IO uint32_t hdtf4
Definition: at32f435_437_edma.h:516
edma_type::hdtfc3
__IO uint32_t hdtfc3
Definition: at32f435_437_edma.h:582
edma_type::reserved2
__IO uint32_t reserved2
reserved, offset:0xD4~0xF0
Definition: at32f435_437_edma.h:500
edma_type::fdtfc7
__IO uint32_t fdtfc7
Definition: at32f435_437_edma.h:619
edma_type::s5llen
__IO uint32_t s5llen
Definition: at32f435_437_edma.h:647
edma_type::s6llen
__IO uint32_t s6llen
Definition: at32f435_437_edma.h:648
edma_type::dterrf1
__IO uint32_t dterrf1
Definition: at32f435_437_edma.h:496
edma_type::dmerrfc5
__IO uint32_t dmerrfc5
Definition: at32f435_437_edma.h:603
edma_type::fdtf8
__IO uint32_t fdtf8
Definition: at32f435_437_edma.h:553
edma_type::ferrf8
__IO uint32_t ferrf8
Definition: at32f435_437_edma.h:548
edma_type::clr2
__IO uint32_t clr2
Definition: at32f435_437_edma.h:598
edma_type::muxsel
__IO uint32_t muxsel
Definition: at32f435_437_edma.h:690
edma_type::dmerrf7
__IO uint32_t dmerrf7
Definition: at32f435_437_edma.h:544
edma_type::syncovfc
__IO uint32_t syncovfc
Definition: at32f435_437_edma.h:724
edma_type::dmerrf5
__IO uint32_t dmerrf5
Definition: at32f435_437_edma.h:531
edma_type::dmerrfc1
__IO uint32_t dmerrfc1
Definition: at32f435_437_edma.h:567
edma_type::ferrfc5
__IO uint32_t ferrfc5
Definition: at32f435_437_edma.h:601
edma_type::muxgclr
__IO uint32_t muxgclr
Definition: at32f435_437_edma.h:747
edma_type::s2dctrl
__IO uint32_t s2dctrl
Definition: at32f435_437_edma.h:665
edma_type::reserved4
__IO uint32_t reserved4
reserved, offset:0x140~0x16C
Definition: at32f435_437_edma.h:507
edma_type::hdtf6
__IO uint32_t hdtf6
Definition: at32f435_437_edma.h:539
edma_type::fdtf3
__IO uint32_t fdtf3
Definition: at32f435_437_edma.h:511
edma_type::ferrf6
__IO uint32_t ferrf6
Definition: at32f435_437_edma.h:535
edma_type::dterrfc5
__IO uint32_t dterrfc5
Definition: at32f435_437_edma.h:604
edma_type::fdtfc2
__IO uint32_t fdtfc2
Definition: at32f435_437_edma.h:576
edma_type::dmerrf2
__IO uint32_t dmerrf2
Definition: at32f435_437_edma.h:501
edma_type::ferrf1
__IO uint32_t ferrf1
Definition: at32f435_437_edma.h:493
edma_type::s8llen
__IO uint32_t s8llen
Definition: at32f435_437_edma.h:650
edma_type::hdtf7
__IO uint32_t hdtf7
Definition: at32f435_437_edma.h:546
edma_type::dmerrf1
__IO uint32_t dmerrf1
Definition: at32f435_437_edma.h:495
edma_type::ferrf7
__IO uint32_t ferrf7
Definition: at32f435_437_edma.h:542
edma_type::ferrfc4
__IO uint32_t ferrfc4
Definition: at32f435_437_edma.h:584
edma_type::fdtf1
__IO uint32_t fdtf1
Definition: at32f435_437_edma.h:498
edma_type::hdtf5
__IO uint32_t hdtf5
Definition: at32f435_437_edma.h:533
edma_type::hdtfc8
__IO uint32_t hdtfc8
Definition: at32f435_437_edma.h:624
edma_type::s12den
__IO uint32_t s12den
Definition: at32f435_437_edma.h:668
edma_type::dterrfc6
__IO uint32_t dterrfc6
Definition: at32f435_437_edma.h:610
edma_type::dmerrfc7
__IO uint32_t dmerrfc7
Definition: at32f435_437_edma.h:616
edma_type::ferrfc2
__IO uint32_t ferrfc2
Definition: at32f435_437_edma.h:571
edma_type::dterrfc7
__IO uint32_t dterrfc7
Definition: at32f435_437_edma.h:617
edma_type::dterrf7
__IO uint32_t dterrf7
Definition: at32f435_437_edma.h:545
edma_type::fdtf7
__IO uint32_t fdtf7
Definition: at32f435_437_edma.h:547
edma_type::hdtfc7
__IO uint32_t hdtfc7
Definition: at32f435_437_edma.h:618
edma_type::fdtf4
__IO uint32_t fdtf4
Definition: at32f435_437_edma.h:517
edma_type::fdtf6
__IO uint32_t fdtf6
Definition: at32f435_437_edma.h:540
edma_type::dterrf8
__IO uint32_t dterrf8
Definition: at32f435_437_edma.h:551
edmamux_channel_type
type define edmamux muxsctrl register
Definition: at32f435_437_edma.h:909
edmamux_channel_type::syncen
__IO uint32_t syncen
Definition: at32f435_437_edma.h:923
edmamux_channel_type::reqcnt
__IO uint32_t reqcnt
Definition: at32f435_437_edma.h:925
edmamux_channel_type::syncsel
__IO uint32_t syncsel
Definition: at32f435_437_edma.h:926
edmamux_channel_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_edma.h:922
edmamux_channel_type::muxctrl
__IO uint32_t muxctrl
Definition: at32f435_437_edma.h:915
edmamux_channel_type::evtgen
__IO uint32_t evtgen
Definition: at32f435_437_edma.h:921
edmamux_channel_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_edma.h:927
edmamux_channel_type::reqsel
__IO uint32_t reqsel
Definition: at32f435_437_edma.h:918
edmamux_channel_type::syncpol
__IO uint32_t syncpol
Definition: at32f435_437_edma.h:924
edmamux_channel_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_edma.h:919
edmamux_channel_type::syncovien
__IO uint32_t syncovien
Definition: at32f435_437_edma.h:920
edmamux_gen_init_type
edmamux generator init type
Definition: at32f435_437_edma.h:473
edmamux_gen_init_type::gen_enable
confirm_state gen_enable
Definition: at32f435_437_edma.h:477
edmamux_gen_init_type::gen_request_number
uint32_t gen_request_number
Definition: at32f435_437_edma.h:476
edmamux_gen_init_type::gen_signal_sel
edmamux_gen_id_sel_type gen_signal_sel
Definition: at32f435_437_edma.h:474
edmamux_gen_init_type::gen_polarity
edmamux_gen_pol_type gen_polarity
Definition: at32f435_437_edma.h:475
edmamux_generator_type
type define edmamux request generator register all
Definition: at32f435_437_edma.h:936
edmamux_generator_type::greqcnt
__IO uint32_t greqcnt
Definition: at32f435_437_edma.h:951
edmamux_generator_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_edma.h:952
edmamux_generator_type::sigsel
__IO uint32_t sigsel
Definition: at32f435_437_edma.h:945
edmamux_generator_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_edma.h:946
edmamux_generator_type::gctrl
__IO uint32_t gctrl
Definition: at32f435_437_edma.h:942
edmamux_generator_type::gen
__IO uint32_t gen
Definition: at32f435_437_edma.h:949
edmamux_generator_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_edma.h:948
edmamux_generator_type::gpol
__IO uint32_t gpol
Definition: at32f435_437_edma.h:950
edmamux_generator_type::trgovien
__IO uint32_t trgovien
Definition: at32f435_437_edma.h:947
edmamux_sync_init_type
edmamux sync init type
Definition: at32f435_437_edma.h:461
edmamux_sync_init_type::sync_signal_sel
edmamux_sync_id_sel_type sync_signal_sel
Definition: at32f435_437_edma.h:462
edmamux_sync_init_type::sync_polarity
edmamux_sync_pol_type sync_polarity
Definition: at32f435_437_edma.h:463
edmamux_sync_init_type::sync_event_enable
confirm_state sync_event_enable
Definition: at32f435_437_edma.h:465
edmamux_sync_init_type::sync_enable
confirm_state sync_enable
Definition: at32f435_437_edma.h:466
edmamux_sync_init_type::sync_request_number
uint32_t sync_request_number
Definition: at32f435_437_edma.h:464


AT32F435/437 Firmwary Library: at32f435_437_emac.c Source File

  • libraries
  • drivers
  • src
at32f435_437_emac.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef EMAC_MODULE_ENABLED
39
44#if defined (EMAC_BASE)
48 emac_dma_desc_type *dma_tx_desc_to_set;
49 emac_dma_desc_type *dma_rx_desc_to_get;
50
51/* emac private function */
52static void emac_delay(uint32_t delay);
53
59void emac_reset(void)
60{
61 crm_periph_reset(CRM_EMAC_PERIPH_RESET, TRUE);
62 crm_periph_reset(CRM_EMAC_PERIPH_RESET, FALSE);
63}
64
70void emac_control_para_init(emac_control_config_type *control_para)
71{
72 control_para->auto_nego = EMAC_AUTO_NEGOTIATION_OFF;
73 control_para->auto_pad_crc_strip = FALSE;
74 control_para->back_off_limit = EMAC_BACKOFF_LIMIT_0;
75 control_para->carrier_sense_disable = FALSE;
76 control_para->deferral_check = FALSE;
77 control_para->duplex_mode = EMAC_HALF_DUPLEX;
78 control_para->fast_ethernet_speed = EMAC_SPEED_10MBPS;
79 control_para->interframe_gap = EMAC_INTERFRAME_GAP_96BIT;
80 control_para->ipv4_checksum_offload = FALSE;
81 control_para->jabber_disable = FALSE;
82 control_para->loopback_mode = FALSE;
83 control_para->receive_own_disable = FALSE;
84 control_para->retry_disable = FALSE;
85 control_para->watchdog_disable = FALSE;
86}
87
93void emac_clock_range_set(void)
94{
95 uint8_t bits_value = 0;
96 crm_clocks_freq_type clocks_freq = {0};
97
98 /* clear clock range bits */
99 EMAC->miiaddr_bit.cr = bits_value;
100
101 crm_clocks_freq_get(&clocks_freq);
102
103 if((clocks_freq.ahb_freq >= EMAC_HCLK_BORDER_20MHZ) && (clocks_freq.ahb_freq < EMAC_HCLK_BORDER_35MHZ))
104 {
105 bits_value = EMAC_CLOCK_RANGE_20_TO_35;
106 }
107 else if((clocks_freq.ahb_freq >= EMAC_HCLK_BORDER_35MHZ) && (clocks_freq.ahb_freq < EMAC_HCLK_BORDER_60MHZ))
108 {
109 bits_value = EMAC_CLOCK_RANGE_35_TO_60;
110 }
111 else if((clocks_freq.ahb_freq >= EMAC_HCLK_BORDER_60MHZ) && (clocks_freq.ahb_freq < EMAC_HCLK_BORDER_100MHZ))
112 {
113 bits_value = EMAC_CLOCK_RANGE_60_TO_100;
114 }
115 else if((clocks_freq.ahb_freq >= EMAC_HCLK_BORDER_100MHZ) && (clocks_freq.ahb_freq < EMAC_HCLK_BORDER_150MHZ))
116 {
117 bits_value = EMAC_CLOCK_RANGE_100_TO_150;
118 }
119 else if((clocks_freq.ahb_freq >= EMAC_HCLK_BORDER_150MHZ) && (clocks_freq.ahb_freq < EMAC_HCLK_BORDER_250MHZ))
120 {
121 bits_value = EMAC_CLOCK_RANGE_150_TO_250;
122 }
123 else if((clocks_freq.ahb_freq >= EMAC_HCLK_BORDER_250MHZ) && (clocks_freq.ahb_freq <= EMAC_HCLK_BORDER_288MHZ))
124 {
125 bits_value = EMAC_CLOCK_RANGE_250_TO_288;
126 }
127
128 EMAC->miiaddr_bit.cr = bits_value;
129}
130
136void emac_control_config(emac_control_config_type *control_struct)
137{
138 emac_deferral_check_set(control_struct->deferral_check);
139 emac_backoff_limit_set(control_struct->back_off_limit);
140 emac_auto_pad_crc_stripping_set(control_struct->auto_pad_crc_strip);
141 emac_retry_disable(control_struct->retry_disable);
142 emac_ipv4_checksum_offload_set(control_struct->ipv4_checksum_offload);
143 emac_loopback_mode_enable(control_struct->loopback_mode);
144 emac_receive_own_disable(control_struct->receive_own_disable);
145 emac_carrier_sense_disable(control_struct->carrier_sense_disable);
146 emac_interframe_gap_set(control_struct->interframe_gap);
147 emac_jabber_disable(control_struct->jabber_disable);
148 emac_watchdog_disable(control_struct->watchdog_disable);
149}
150
156void emac_dma_software_reset_set(void)
157{
158 EMAC_DMA->bm_bit.swr = 1;
159}
160
166 flag_status emac_dma_software_reset_get(void)
167{
168 if(EMAC_DMA->bm_bit.swr)
169 {
170 return SET;
171 }
172 else
173 {
174 return RESET;
175 }
176}
177
183void emac_start(void)
184{
185 /* enable transmit state machine of the mac for transmission on the mii */
186 emac_trasmitter_enable(TRUE);
187
188 /* flush transmit fifo */
189 emac_dma_operations_set(EMAC_DMA_OPS_FLUSH_TRANSMIT_FIFO, TRUE);
190
191 /* enable receive state machine of the mac for reception from the mii */
192 emac_receiver_enable(TRUE);
193
194 /* start dma transmission */
195 emac_dma_operations_set(EMAC_DMA_OPS_START_STOP_TRANSMIT, TRUE);
196
197 /* start dma reception */
198 emac_dma_operations_set(EMAC_DMA_OPS_START_STOP_RECEIVE, TRUE);
199}
200
206void emac_stop(void)
207{
208 /* stop dma transmission */
209 emac_dma_operations_set(EMAC_DMA_OPS_START_STOP_TRANSMIT, FALSE);
210
211 /* stop dma reception */
212 emac_dma_operations_set(EMAC_DMA_OPS_START_STOP_RECEIVE, FALSE);
213
214 /* stop receive state machine of the mac for reception from the mii */
215 emac_receiver_enable(FALSE);
216
217 /* flush transmit fifo */
218 emac_dma_operations_set(EMAC_DMA_OPS_FLUSH_TRANSMIT_FIFO, TRUE);
219
220 /* stop transmit state machine of the mac for transmission on the mii */
221 emac_trasmitter_enable(FALSE);
222}
223
224
232 error_status emac_phy_register_write(uint8_t address, uint8_t reg, uint16_t data)
233{
234 uint32_t timeout = 0;
235
236 EMAC->miidt_bit.md = data;
237
238 EMAC->miiaddr_bit.pa = address;
239 EMAC->miiaddr_bit.mii = reg;
240 EMAC->miiaddr_bit.mw = 1;
241 EMAC->miiaddr_bit.mb = 1;
242
243 do
244 {
245 timeout++;
246 } while((EMAC->miiaddr_bit.mb) && (timeout < PHY_TIMEOUT));
247
248 if(timeout == PHY_TIMEOUT)
249 {
250 return ERROR;
251 }
252 return SUCCESS;
253}
254
262 error_status emac_phy_register_read(uint8_t address, uint8_t reg, uint16_t *data)
263{
264 uint32_t timeout = 0;
265
266 EMAC->miiaddr_bit.pa = address;
267 EMAC->miiaddr_bit.mii = reg;
268 EMAC->miiaddr_bit.mw = 0;
269 EMAC->miiaddr_bit.mb = 1;
270
271 do
272 {
273 timeout++;
274 *data = EMAC->miidt_bit.md;
275 } while((EMAC->miiaddr_bit.mb) && (timeout < PHY_TIMEOUT));
276
277 if(timeout == PHY_TIMEOUT)
278 {
279 return ERROR;
280 }
281
282 *data = EMAC->miidt_bit.md;
283 return SUCCESS;
284}
285
291void emac_receiver_enable(confirm_state new_state)
292{
293 __IO uint32_t temp = 0;
294
295 EMAC->ctrl_bit.re = new_state;
296
297 temp = EMAC->ctrl;
298 emac_delay(1);
299 EMAC->ctrl = temp;
300}
301
307void emac_trasmitter_enable(confirm_state new_state)
308{
309 __IO uint32_t temp = 0;
310
311 EMAC->ctrl_bit.te = new_state;
312
313 temp = EMAC->ctrl;
314 emac_delay(1);
315 EMAC->ctrl = temp;
316}
317
323void emac_deferral_check_set(confirm_state new_state)
324{
325 EMAC->ctrl_bit.dc = new_state;
326}
327
338void emac_backoff_limit_set(emac_bol_type slot_time)
339{
340 EMAC->ctrl_bit.bl = slot_time;
341}
342
348void emac_auto_pad_crc_stripping_set(confirm_state new_state)
349{
350 EMAC->ctrl_bit.acs = new_state;
351}
352
358void emac_retry_disable(confirm_state new_state)
359{
360 EMAC->ctrl_bit.dr = new_state;
361}
362
368void emac_ipv4_checksum_offload_set(confirm_state new_state)
369{
370 EMAC->ctrl_bit.ipc = new_state;
371}
372
378void emac_loopback_mode_enable(confirm_state new_state)
379{
380 EMAC->ctrl_bit.lm = new_state;
381}
382
388void emac_receive_own_disable(confirm_state new_state)
389{
390 EMAC->ctrl_bit.dro = new_state;
391}
392
398void emac_carrier_sense_disable(confirm_state new_state)
399{
400 EMAC->ctrl_bit.dcs = new_state;
401}
402
417void emac_interframe_gap_set(emac_intergrame_gap_type number)
418{
419 EMAC->ctrl_bit.ifg = number;
420}
421
427void emac_jabber_disable(confirm_state new_state)
428{
429 EMAC->ctrl_bit.jd = new_state;
430}
431
437void emac_watchdog_disable(confirm_state new_state)
438{
439 EMAC->ctrl_bit.wd = new_state;
440}
441
450void emac_fast_speed_set(emac_speed_type speed)
451{
452 EMAC->ctrl_bit.fes = speed;
453}
454
463void emac_duplex_mode_set(emac_duplex_type duplex_mode)
464{
465 EMAC->ctrl_bit.dm = duplex_mode;
466}
467
473void emac_promiscuous_mode_set(confirm_state new_state)
474{
475 EMAC->frmf_bit.pr = new_state;
476}
477
483void emac_hash_unicast_set(confirm_state new_state)
484{
485 EMAC->frmf_bit.huc = new_state;
486}
487
493void emac_hash_multicast_set(confirm_state new_state)
494{
495 EMAC->frmf_bit.hmc = new_state;
496}
497
503void emac_dstaddr_inverse_filter_set(confirm_state new_state)
504{
505 EMAC->frmf_bit.daif = new_state;
506}
507
513void emac_pass_all_multicasting_set(confirm_state new_state)
514{
515 EMAC->frmf_bit.pmc = new_state;
516}
517
523void emac_broadcast_frames_disable(confirm_state new_state)
524{
525 EMAC->frmf_bit.dbf = new_state;
526}
527
537void emac_pass_control_frames_set(emac_control_frames_filter_type condition)
538{
539 EMAC->frmf_bit.pcf = condition;
540}
541
547void emac_srcaddr_inverse_filter_set(confirm_state new_state)
548{
549 EMAC->frmf_bit.saif = new_state;
550}
551
557void emac_srcaddr_filter_set(confirm_state new_state)
558{
559 EMAC->frmf_bit.saf = new_state;
560}
561
567void emac_hash_perfect_filter_set(confirm_state new_state)
568{
569 EMAC->frmf_bit.hpf = new_state;
570}
571
577void emac_receive_all_set(confirm_state new_state)
578{
579 EMAC->frmf_bit.ra = new_state;
580}
581
587void emac_hash_table_high32bits_set(uint32_t high32bits)
588{
589 EMAC->hth_bit.hth = high32bits;
590}
591
597void emac_hash_table_low32bits_set(uint32_t low32bits)
598{
599 EMAC->htl_bit.htl = low32bits;
600}
601
607 flag_status emac_mii_busy_get(void)
608{
609 if(EMAC->miiaddr_bit.mb) {
610 return SET;
611 }
612 else {
613 return RESET;
614 }
615}
616
622void emac_mii_write(confirm_state new_state)
623{
624 EMAC->miiaddr_bit.mw = new_state;
625}
626
632void emac_fcb_bpa_set(confirm_state new_state)
633{
634 EMAC->fctrl_bit.fcbbpa = new_state;
635}
636
642void emac_transmit_flow_control_enable(confirm_state new_state)
643{
644 EMAC->fctrl_bit.etf = new_state;
645}
646
652void emac_receive_flow_control_enable(confirm_state new_state)
653{
654 EMAC->fctrl_bit.erf = new_state;
655}
656
662void emac_unicast_pause_frame_detect(confirm_state new_state)
663{
664 EMAC->fctrl_bit.dup = new_state;
665}
666
677void emac_pause_low_threshold_set(emac_pause_slot_threshold_type pasue_threshold)
678{
679 EMAC->fctrl_bit.plt = pasue_threshold;
680}
681
687void emac_zero_quanta_pause_disable(confirm_state new_state)
688{
689 EMAC->fctrl_bit.dzqp = new_state;
690}
691
697void emac_pause_time_set(uint16_t pause_time)
698{
699 EMAC->fctrl_bit.pt = pause_time;
700}
701
707void emac_vlan_tag_identifier_set(uint16_t identifier)
708{
709 EMAC->vlt_bit.vti = identifier;
710}
711
717void emac_vlan_tag_comparison_set(confirm_state new_state)
718{
719 EMAC->vlt_bit.etv = new_state;
720}
721
727void emac_wakeup_frame_set(uint32_t value)
728{
729 EMAC->rwff = value;
730}
731
737uint32_t emac_wakeup_frame_get(void)
738{
739 return (EMAC->rwff);
740}
741
747void emac_power_down_set(confirm_state new_state)
748{
749 EMAC->pmtctrlsts_bit.pd = new_state;
750}
751
757void emac_magic_packet_enable(confirm_state new_state)
758{
759 EMAC->pmtctrlsts_bit.emp = new_state;
760}
761
767void emac_wakeup_frame_enable(confirm_state new_state)
768{
769 EMAC->pmtctrlsts_bit.erwf = new_state;
770}
771
777 flag_status emac_received_magic_packet_get(void)
778{
779 if(EMAC->pmtctrlsts_bit.rmp)
780 {
781 return SET;
782 }
783 else
784 {
785 return RESET;
786 }
787}
788
794 flag_status emac_received_wakeup_frame_get(void)
795{
796 if(EMAC->pmtctrlsts_bit.rrwf)
797 {
798 return SET;
799 }
800 else
801 {
802 return RESET;
803 }
804}
805
811void emac_global_unicast_set(confirm_state new_state)
812{
813 EMAC->pmtctrlsts_bit.guc = new_state;
814}
815
821void emac_wakeup_frame_filter_reset(confirm_state new_state)
822{
823 EMAC->pmtctrlsts_bit.rwffpr = new_state;
824}
825
837 flag_status emac_interrupt_status_read(uint32_t flag)
838{
839 if(EMAC->ists & flag)
840 {
841 return SET;
842 }
843 else
844 {
845 return RESET;
846 }
847}
848
858void emac_interrupt_mask_set(emac_interrupt_mask_type mask_type, confirm_state new_state)
859{
860 switch(mask_type)
861 {
862 case EMAC_INTERRUPT_PMT_MASK:
863 {
864 EMAC->imr_bit.pim = new_state;
865 break;
866 }
867 case EMAC_INTERRUPT_TST_MASK:
868 {
869 EMAC->imr_bit.tim = new_state;
870 break;
871 }
872 }
873}
874
880void emac_local_address_set(uint8_t *address)
881{
882 EMAC->a0h_bit.ma0h = (uint32_t)(address[5] << 8 | address[4]);
883 EMAC->a0l_bit.ma0l = (uint32_t)(address[3] << 24 | address[2] << 16 | address[1] << 8 | address[0]);
884}
885
895void emac_address_filter_set(emac_address_type mac, emac_address_filter_type filter, emac_address_mask_type mask_bit, confirm_state new_state)
896{
897 switch(mac)
898 {
899 case EMAC_ADDRESS_FILTER_1:
900 {
901 EMAC->a1h_bit.sa = filter;
902 EMAC->a1h_bit.mbc = mask_bit;
903 EMAC->a1h_bit.ae = new_state;
904 break;
905 }
906 case EMAC_ADDRESS_FILTER_2:
907 {
908 EMAC->a2h_bit.sa = filter;
909 EMAC->a2h_bit.mbc = mask_bit;
910 EMAC->a2h_bit.ae = new_state;
911 break;
912 }
913 case EMAC_ADDRESS_FILTER_3:
914 {
915 EMAC->a3h_bit.sa = filter;
916 EMAC->a3h_bit.mbc = mask_bit;
917 EMAC->a3h_bit.ae = new_state;
918 break;
919 }
920 }
921}
922
934void emac_dma_descriptor_list_address_set(emac_dma_tx_rx_type transfer_type, emac_dma_desc_type *dma_desc_tab, uint8_t *buff, uint32_t buffer_count)
935{
936 uint32_t i = 0;
937 emac_dma_desc_type *dma_descriptor;
938
939 switch(transfer_type)
940 {
941 case EMAC_DMA_TRANSMIT:
942 {
943 dma_tx_desc_to_set = dma_desc_tab;
944 for(i = 0; i < buffer_count; i++)
945 {
946 dma_descriptor = dma_desc_tab + i;
947
948 dma_descriptor->status = EMAC_DMATXDESC_TCH;
949
950 dma_descriptor->buf1addr = (uint32_t)(&buff[i * EMAC_MAX_PACKET_LENGTH]);
951
952 if(i < (buffer_count - 1))
953 {
954 dma_descriptor->buf2nextdescaddr = (uint32_t)(dma_desc_tab + i + 1);
955 }
956 else
957 {
958 dma_descriptor->buf2nextdescaddr = (uint32_t) dma_desc_tab;
959 }
960 }
961 EMAC_DMA->tdladdr_bit.stl = (uint32_t) dma_desc_tab;
962 break;
963 }
964 case EMAC_DMA_RECEIVE:
965 {
966 dma_rx_desc_to_get = dma_desc_tab;
967 for(i = 0; i < buffer_count; i++)
968 {
969 dma_descriptor = dma_desc_tab + i;
970
971 dma_descriptor->status = EMAC_DMARXDESC_OWN;
972
973 dma_descriptor->controlsize = EMAC_DMARXDESC_RCH | (uint32_t)EMAC_MAX_PACKET_LENGTH;
974
975 dma_descriptor->buf1addr = (uint32_t)(&buff[i * EMAC_MAX_PACKET_LENGTH]);
976
977 if(i < (buffer_count - 1))
978 {
979 dma_descriptor->buf2nextdescaddr = (uint32_t)(dma_desc_tab + i + 1);
980 }
981 else
982 {
983 dma_descriptor->buf2nextdescaddr = (uint32_t) dma_desc_tab;
984 }
985 }
986 EMAC_DMA->rdladdr_bit.srl = (uint32_t) dma_desc_tab;
987 break;
988 }
989 }
990}
991
1001void emac_dma_rx_desc_interrupt_config(emac_dma_desc_type *dma_rx_desc, confirm_state new_state)
1002{
1003 if (new_state != FALSE)
1004 {
1005 /* enable the dma rx desc receive interrupt */
1006 dma_rx_desc->controlsize &= (~(uint32_t)EMAC_DMARXDESC_DIC);
1007 }
1008 else
1009 {
1010 /* disable the dma rx desc receive interrupt */
1011 dma_rx_desc->controlsize |= EMAC_DMARXDESC_DIC;
1012 }
1013}
1014
1023uint32_t emac_dma_descriptor_list_address_get(emac_dma_tx_rx_type transfer_type)
1024{
1025 switch(transfer_type)
1026 {
1027 case EMAC_DMA_TRANSMIT:
1028 {
1029 return (EMAC_DMA->tdladdr_bit.stl);
1030 }
1031 case EMAC_DMA_RECEIVE:
1032 {
1033 return (EMAC_DMA->rdladdr_bit.srl);
1034 }
1035 }
1036 return 0;
1037}
1038
1044uint32_t emac_received_packet_size_get(void)
1045{
1046 uint32_t frame_length = 0;
1047 if(((dma_rx_desc_to_get->status & EMAC_DMARXDESC_OWN) == (uint32_t)RESET) &&
1048 ((dma_rx_desc_to_get->status & EMAC_DMATXDESC_ES) == (uint32_t)RESET) &&
1049 ((dma_rx_desc_to_get->status & EMAC_DMARXDESC_LS) != (uint32_t)RESET) &&
1050 ((dma_rx_desc_to_get->status & EMAC_DMARXDESC_FS) != (uint32_t)RESET))
1051 {
1052 frame_length = emac_dmarxdesc_frame_length_get(dma_rx_desc_to_get);
1053 }
1054
1055 return frame_length;
1056}
1057
1063uint32_t emac_dmarxdesc_frame_length_get(emac_dma_desc_type *dma_rx_desc)
1064{
1065 return ((dma_rx_desc->status & EMAC_DMARXDESC_FL) >> EMAC_DMARXDESC_FRAME_LENGTHSHIFT);
1066}
1067
1073void emac_dma_para_init(emac_dma_config_type *control_para)
1074{
1075 control_para->aab_enable = FALSE;
1076 control_para->da_enable = FALSE;
1077 control_para->desc_skip_length = 0;
1078 control_para->dt_disable = FALSE;
1079 control_para->fb_enable = FALSE;
1080 control_para->fef_enable = FALSE;
1081 control_para->flush_rx_disable = FALSE;
1082 control_para->fugf_enable = FALSE;
1083 control_para->osf_enable = FALSE;
1084 control_para->priority_ratio = EMAC_DMA_1_RX_1_TX;
1085 control_para->rsf_enable = FALSE;
1086 control_para->rx_dma_pal = EMAC_DMA_PBL_1;
1087 control_para->rx_threshold = EMAC_DMA_RX_THRESHOLD_64_BYTES;
1088 control_para->tsf_enable = FALSE;
1089 control_para->tx_dma_pal = EMAC_DMA_PBL_1;
1090 control_para->tx_threshold = EMAC_DMA_TX_THRESHOLD_64_BYTES;
1091 control_para->usp_enable = FALSE;
1092}
1093
1099void emac_dma_config(emac_dma_config_type *control_para)
1100{
1101 EMAC_DMA->bm_bit.aab = control_para->aab_enable;
1102 EMAC_DMA->bm_bit.dsl = control_para->desc_skip_length;
1103 EMAC_DMA->bm_bit.rdp = control_para->rx_dma_pal;
1104 EMAC_DMA->bm_bit.pbl = control_para->tx_dma_pal;
1105 EMAC_DMA->bm_bit.fb = control_para->fb_enable;
1106 EMAC_DMA->bm_bit.usp = control_para->usp_enable;
1107 EMAC_DMA->bm_bit.da = control_para->da_enable;
1108 EMAC_DMA->bm_bit.pr = control_para->priority_ratio;
1109
1110 EMAC_DMA->opm_bit.dt = control_para->dt_disable;
1111 EMAC_DMA->opm_bit.rsf = control_para->rsf_enable;
1112 EMAC_DMA->opm_bit.dfrf = control_para->flush_rx_disable;
1113 EMAC_DMA->opm_bit.tsf = control_para->tsf_enable;
1114 EMAC_DMA->opm_bit.ttc = control_para->tx_threshold;
1115 EMAC_DMA->opm_bit.fef = control_para->fef_enable;
1116 EMAC_DMA->opm_bit.fugf = control_para->fugf_enable;
1117 EMAC_DMA->opm_bit.rtc = control_para->rx_threshold;
1118 EMAC_DMA->opm_bit.osf = control_para->osf_enable;
1119}
1120
1132void emac_dma_arbitation_set(emac_dma_rx_tx_ratio_type ratio, confirm_state new_state)
1133{
1134 EMAC_DMA->bm_bit.da = new_state;
1135
1136 if(new_state)
1137 {
1138 EMAC_DMA->bm_bit.pr = ratio;
1139 }
1140}
1141
1147void emac_dma_descriptor_skip_length_set(uint8_t length)
1148{
1149 EMAC_DMA->bm_bit.dsl = length;
1150}
1151
1173void emac_dma_separate_pbl_set(emac_dma_pbl_type tx_length, emac_dma_pbl_type rx_length, confirm_state new_state)
1174{
1175 EMAC_DMA->bm_bit.usp = new_state;
1176 EMAC_DMA->bm_bit.pbl = tx_length;
1177
1178 if(new_state)
1179 {
1180 EMAC_DMA->bm_bit.pbl = rx_length;
1181 }
1182}
1183
1189void emac_dma_eight_pbl_mode_set(confirm_state new_state)
1190{
1191 EMAC_DMA->bm_bit.pblx8 = new_state;
1192}
1193
1199void emac_dma_address_aligned_beats_set(confirm_state new_state)
1200{
1201 EMAC_DMA->bm_bit.aab = new_state;
1202}
1203
1213void emac_dma_poll_demand_set(emac_dma_tx_rx_type transfer_type, uint32_t value)
1214{
1215 switch(transfer_type)
1216 {
1217 case EMAC_DMA_TRANSMIT:
1218 {
1219 EMAC_DMA->tpd_bit.tpd = value;
1220 break;
1221 }
1222 case EMAC_DMA_RECEIVE:
1223 {
1224 EMAC_DMA->rpd_bit.rpd = value;
1225 break;
1226 }
1227 }
1228}
1229
1238uint32_t emac_dma_poll_demand_get(emac_dma_tx_rx_type transfer_type)
1239{
1240 switch(transfer_type)
1241 {
1242 case EMAC_DMA_TRANSMIT:
1243 {
1244 return (EMAC_DMA->tpd_bit.tpd);
1245 }
1246 case EMAC_DMA_RECEIVE:
1247 {
1248 return (EMAC_DMA->rpd_bit.rpd);
1249 }
1250 }
1251 return 0;
1252}
1253
1266 emac_dma_receive_process_status_type emac_dma_receive_status_get(void)
1267{
1268 switch(EMAC_DMA->sts_bit.rs)
1269 {
1270 case EMAC_DMA_RX_RESET_STOP_COMMAND:
1271 {
1272 return EMAC_DMA_RX_RESET_STOP_COMMAND;
1273 }
1274
1275 case EMAC_DMA_RX_FETCH_DESCRIPTOR:
1276 {
1277 return EMAC_DMA_RX_FETCH_DESCRIPTOR;
1278 }
1279
1280 case EMAC_DMA_RX_WAITING_PACKET:
1281 {
1282 return EMAC_DMA_RX_WAITING_PACKET;
1283 }
1284
1285 case EMAC_DMA_RX_DESCRIPTOR_UNAVAILABLE:
1286 {
1287 return EMAC_DMA_RX_DESCRIPTOR_UNAVAILABLE;
1288 }
1289
1290 case EMAC_DMA_RX_CLOSE_DESCRIPTOR:
1291 {
1292 return EMAC_DMA_RX_CLOSE_DESCRIPTOR;
1293 }
1294
1295 case EMAC_DMA_RX_FIFO_TO_HOST:
1296 {
1297 return EMAC_DMA_RX_FIFO_TO_HOST;
1298 }
1299 }
1300
1301 return EMAC_DMA_RX_RESET_STOP_COMMAND;
1302}
1303
1316 emac_dma_transmit_process_status_type emac_dma_transmit_status_get(void)
1317{
1318 switch(EMAC_DMA->sts_bit.ts)
1319 {
1320 case EMAC_DMA_TX_RESET_STOP_COMMAND:
1321 {
1322 return EMAC_DMA_TX_RESET_STOP_COMMAND;
1323 }
1324
1325 case EMAC_DMA_TX_FETCH_DESCRIPTOR:
1326 {
1327 return EMAC_DMA_TX_FETCH_DESCRIPTOR;
1328 }
1329
1330 case EMAC_DMA_TX_WAITING_FOR_STATUS:
1331 {
1332 return EMAC_DMA_TX_WAITING_FOR_STATUS;
1333 }
1334
1335 case EMAC_DMA_TX_HOST_TO_FIFO:
1336 {
1337 return EMAC_DMA_TX_HOST_TO_FIFO;
1338 }
1339
1340 case EMAC_DMA_TX_DESCRIPTOR_UNAVAILABLE:
1341 {
1342 return EMAC_DMA_TX_DESCRIPTOR_UNAVAILABLE;
1343 }
1344
1345 case EMAC_DMA_TX_CLOSE_DESCRIPTOR:
1346 {
1347 return EMAC_DMA_TX_CLOSE_DESCRIPTOR;
1348 }
1349 }
1350
1351 return EMAC_DMA_TX_RESET_STOP_COMMAND;
1352}
1353
1371void emac_dma_operations_set(emac_dma_operations_type ops, confirm_state new_state)
1372{
1373 __IO uint32_t temp = 0;
1374 switch(ops)
1375 {
1376 case EMAC_DMA_OPS_START_STOP_RECEIVE:
1377 {
1378 EMAC_DMA->opm_bit.ssr = new_state;
1379 break;
1380 }
1381
1382 case EMAC_DMA_OPS_SECOND_FRAME:
1383 {
1384 EMAC_DMA->opm_bit.osf = new_state;
1385 break;
1386 }
1387
1388 case EMAC_DMA_OPS_FORWARD_UNDERSIZED:
1389 {
1390 EMAC_DMA->opm_bit.fugf = new_state;
1391 break;
1392 }
1393
1394 case EMAC_DMA_OPS_FORWARD_ERROR:
1395 {
1396 EMAC_DMA->opm_bit.fef = new_state;
1397 break;
1398 }
1399
1400 case EMAC_DMA_OPS_START_STOP_TRANSMIT:
1401 {
1402 EMAC_DMA->opm_bit.sstc = new_state;
1403 break;
1404 }
1405
1406 case EMAC_DMA_OPS_FLUSH_TRANSMIT_FIFO:
1407 {
1408 EMAC_DMA->opm_bit.ftf = new_state;
1409 temp = EMAC_DMA->opm;
1410 emac_delay(1);
1411 EMAC_DMA->opm = temp;
1412 break;
1413 }
1414
1415 case EMAC_DMA_OPS_TRANSMIT_STORE_FORWARD:
1416 {
1417 EMAC_DMA->opm_bit.tsf = new_state;
1418 break;
1419 }
1420
1421 case EMAC_DMA_OPS_RECEIVE_FLUSH_DISABLE:
1422 {
1423 EMAC_DMA->opm_bit.dfrf = new_state;
1424 break;
1425 }
1426
1427 case EMAC_DMA_OPS_RECEIVE_STORE_FORWARD:
1428 {
1429 EMAC_DMA->opm_bit.rsf = new_state;
1430 break;
1431 }
1432
1433 case EMAC_DMA_OPS_DROP_ERROR_DISABLE:
1434 {
1435 EMAC_DMA->opm_bit.dt = new_state;
1436 break;
1437 }
1438 }
1439}
1440
1451void emac_dma_receive_threshold_set(emac_dma_receive_threshold_type value)
1452{
1453 EMAC_DMA->opm_bit.rtc = value;
1454}
1455
1470void emac_dma_transmit_threshold_set(emac_dma_transmit_threshold_type value)
1471{
1472 EMAC_DMA->opm_bit.ttc = value;
1473}
1474
1497void emac_dma_interrupt_enable(emac_dma_interrupt_type it, confirm_state new_state)
1498{
1499 switch(it)
1500 {
1501 case EMAC_DMA_INTERRUPT_TX:
1502 {
1503 EMAC_DMA->ie_bit.tie = new_state;
1504 break;
1505 }
1506 case EMAC_DMA_INTERRUPT_TX_STOP:
1507 {
1508 EMAC_DMA->ie_bit.tse = new_state;
1509 break;
1510 }
1511 case EMAC_DMA_INTERRUPT_TX_UNAVAILABLE:
1512 {
1513 EMAC_DMA->ie_bit.tue = new_state;
1514 break;
1515 }
1516 case EMAC_DMA_INTERRUPT_TX_JABBER:
1517 {
1518 EMAC_DMA->ie_bit.tje = new_state;
1519 break;
1520 }
1521 case EMAC_DMA_INTERRUPT_RX_OVERFLOW:
1522 {
1523 EMAC_DMA->ie_bit.ove = new_state;
1524 break;
1525 }
1526 case EMAC_DMA_INTERRUPT_TX_UNDERFLOW:
1527 {
1528 EMAC_DMA->ie_bit.une = new_state;
1529 break;
1530 }
1531 case EMAC_DMA_INTERRUPT_RX:
1532 {
1533 EMAC_DMA->ie_bit.rie = new_state;
1534 break;
1535 }
1536 case EMAC_DMA_INTERRUPT_RX_UNAVAILABLE:
1537 {
1538 EMAC_DMA->ie_bit.rbue = new_state;
1539 break;
1540 }
1541 case EMAC_DMA_INTERRUPT_RX_STOP:
1542 {
1543 EMAC_DMA->ie_bit.rse = new_state;
1544 break;
1545 }
1546 case EMAC_DMA_INTERRUPT_RX_TIMEOUT:
1547 {
1548 EMAC_DMA->ie_bit.rwte = new_state;
1549 break;
1550 }
1551 case EMAC_DMA_INTERRUPT_TX_EARLY:
1552 {
1553 EMAC_DMA->ie_bit.eie = new_state;
1554 break;
1555 }
1556 case EMAC_DMA_INTERRUPT_FATAL_BUS_ERROR:
1557 {
1558 EMAC_DMA->ie_bit.fbee = new_state;
1559 break;
1560 }
1561 case EMAC_DMA_INTERRUPT_RX_EARLY:
1562 {
1563 EMAC_DMA->ie_bit.ere = new_state;
1564 break;
1565 }
1566 case EMAC_DMA_INTERRUPT_ABNORMAL_SUMMARY:
1567 {
1568 EMAC_DMA->ie_bit.aie = new_state;
1569 break;
1570 }
1571 case EMAC_DMA_INTERRUPT_NORMAL_SUMMARY:
1572 {
1573 EMAC_DMA->ie_bit.nie = new_state;
1574 break;
1575 }
1576 }
1577}
1578
1584uint16_t emac_dma_controller_missing_frame_get(void)
1585{
1586 uint16_t number = EMAC_DMA->mfbocnt_bit.mfc;
1587 return number;
1588}
1589
1595uint8_t emac_dma_missing_overflow_bit_get(void)
1596{
1597 uint8_t number = EMAC_DMA->mfbocnt_bit.obmfc;
1598 return number;
1599}
1600
1606uint16_t emac_dma_application_missing_frame_get(void)
1607{
1608 uint16_t number = EMAC_DMA->mfbocnt_bit.ofc;
1609 return number;
1610}
1611
1617uint8_t emac_dma_fifo_overflow_bit_get(void)
1618{
1619 uint8_t number = EMAC_DMA->mfbocnt_bit.obfoc;
1620 return number;
1621}
1622
1633uint32_t emac_dma_tansfer_address_get(emac_dma_transfer_address_type transfer_type)
1634{
1635 uint32_t address = 0;
1636
1637 switch(transfer_type)
1638 {
1639 case EMAC_DMA_TX_DESCRIPTOR:
1640 {
1641 address = EMAC_DMA->ctd_bit.htdap;
1642 break;
1643 }
1644 case EMAC_DMA_RX_DESCRIPTOR:
1645 {
1646 address = EMAC_DMA->crd_bit.hrdap;
1647 break;
1648 }
1649 case EMAC_DMA_TX_BUFFER:
1650 {
1651 address = EMAC_DMA->ctbaddr_bit.htbap;
1652 break;
1653 }
1654 case EMAC_DMA_RX_BUFFER:
1655 {
1656 address = EMAC_DMA->crbaddr_bit.hrbap;
1657 break;
1658 }
1659 }
1660 return address;
1661}
1662
1668void emac_mmc_counter_reset(void)
1669{
1670 EMAC_MMC->ctrl_bit.rc = TRUE;
1671}
1672
1678void emac_mmc_rollover_stop(confirm_state new_state)
1679{
1680 EMAC_MMC->ctrl_bit.scr = new_state;
1681}
1682
1688void emac_mmc_reset_on_read_enable(confirm_state new_state)
1689{
1690 EMAC_MMC->ctrl_bit.rr = new_state;
1691}
1692
1698void emac_mmc_counter_freeze(confirm_state new_state)
1699{
1700 EMAC_MMC->ctrl_bit.fmc = new_state;
1701}
1702
1712 flag_status emac_mmc_received_status_get(uint32_t flag)
1713{
1714 if(EMAC_MMC->ri & flag)
1715 {
1716 return SET;
1717 }
1718 else
1719 {
1720 return RESET;
1721 }
1722}
1723
1733 flag_status emac_mmc_transmit_status_get(uint32_t flag)
1734{
1735 if(EMAC_MMC->ti & flag)
1736 {
1737 return SET;
1738 }
1739 else
1740 {
1741 return RESET;
1742 }
1743}
1744
1755void emac_mmc_received_interrupt_mask_set(uint32_t flag, confirm_state new_state)
1756{
1757 switch(flag)
1758 {
1759 case MMC_RX_CRC_ERROR:
1760 {
1761 EMAC_MMC->rim_bit.rcefcim = new_state;
1762 break;
1763 }
1764 case MMC_RX_ALIGN_ERROR:
1765 {
1766 EMAC_MMC->rim_bit.raefacim = new_state;
1767 break;
1768 }
1769 case MMC_RX_GOOD_UNICAST:
1770 {
1771 EMAC_MMC->rim_bit.rugfcim = new_state;
1772 break;
1773 }
1774 }
1775}
1776
1787void emac_mmc_transmit_interrupt_mask_set(uint32_t flag, confirm_state new_state)
1788{
1789 switch(flag)
1790 {
1791 case MMC_TX_SINGLE_COL:
1792 {
1793 EMAC_MMC->tim_bit.tscgfcim = new_state;
1794 break;
1795 }
1796 case MMC_TX_MULTIPLE_COL:
1797 {
1798 EMAC_MMC->tim_bit.tmcgfcim = new_state;
1799 break;
1800 }
1801 case MMC_TX_GOOD_FRAMES:
1802 {
1803 EMAC_MMC->tim_bit.tgfcim = new_state;
1804 break;
1805 }
1806 }
1807}
1808
1818uint32_t emac_mmc_transmit_good_frames_get(uint32_t flag)
1819{
1820 uint32_t good_frames = MMC_TX_GOOD_FRAMES;
1821
1822 switch(flag)
1823 {
1824 case MMC_TX_SINGLE_COL:
1825 {
1826 good_frames = EMAC_MMC->tfscc_bit.tgfscc;
1827 break;
1828 }
1829 case MMC_TX_MULTIPLE_COL:
1830 {
1831 good_frames = EMAC_MMC->tfmscc_bit.tgfmscc;
1832 break;
1833 }
1834 case MMC_TX_GOOD_FRAMES:
1835 {
1836 good_frames = EMAC_MMC->tfcnt_bit.tgfc;
1837 break;
1838 }
1839 }
1840 return good_frames;
1841}
1842
1852uint32_t emac_mmc_received_error_frames_get(uint32_t flag)
1853{
1854 uint32_t error_frames = MMC_RX_GOOD_UNICAST;
1855
1856 switch(flag)
1857 {
1858 case MMC_RX_CRC_ERROR:
1859 {
1860 error_frames = EMAC_MMC->rfcecnt_bit.rfcec;
1861 break;
1862 }
1863 case MMC_RX_ALIGN_ERROR:
1864 {
1865 error_frames = EMAC_MMC->rfaecnt_bit.rfaec;
1866 break;
1867 }
1868 case MMC_RX_GOOD_UNICAST:
1869 {
1870 error_frames = EMAC_MMC->rgufcnt_bit.rgufc;
1871 break;
1872 }
1873 }
1874 return error_frames;
1875}
1876
1882void emac_ptp_timestamp_enable(confirm_state new_state)
1883{
1884 EMAC_PTP->tsctrl_bit.te = new_state;
1885}
1886
1892void emac_ptp_timestamp_fine_update_enable(confirm_state new_state)
1893{
1894 EMAC_PTP->tsctrl_bit.tfcu = new_state;
1895}
1896
1902void emac_ptp_timestamp_system_time_init(confirm_state new_state)
1903{
1904 EMAC_PTP->tsctrl_bit.ti = new_state;
1905}
1906
1912void emac_ptp_timestamp_system_time_update(confirm_state new_state)
1913{
1914 EMAC_PTP->tsctrl_bit.tu = new_state;
1915}
1916
1922void emac_ptp_interrupt_trigger_enable(confirm_state new_state)
1923{
1924 EMAC_PTP->tsctrl_bit.tite = new_state;
1925}
1926
1932void emac_ptp_addend_register_update(confirm_state new_state)
1933{
1934 EMAC_PTP->tsctrl_bit.aru = new_state;
1935}
1936
1942void emac_ptp_snapshot_received_frames_enable(confirm_state new_state)
1943{
1944 EMAC_PTP->tsctrl_bit.etaf = new_state;
1945}
1946
1952void emac_ptp_subsecond_rollover_enable(confirm_state new_state)
1953{
1954 EMAC_PTP->tsctrl_bit.tdbrc = new_state;
1955}
1956
1962void emac_ptp_psv2_enable(confirm_state new_state)
1963{
1964 EMAC_PTP->tsctrl_bit.eppv2f = new_state;
1965}
1966
1972void emac_ptp_snapshot_emac_frames_enable(confirm_state new_state)
1973{
1974 EMAC_PTP->tsctrl_bit.eppef = new_state;
1975}
1976
1982void emac_ptp_snapshot_ipv6_frames_enable(confirm_state new_state)
1983{
1984 EMAC_PTP->tsctrl_bit.eppfsip6u = new_state;
1985}
1986
1992void emac_ptp_snapshot_ipv4_frames_enable(confirm_state new_state)
1993{
1994 EMAC_PTP->tsctrl_bit.eppfsip4u = new_state;
1995}
1996
2002void emac_ptp_snapshot_event_message_enable(confirm_state new_state)
2003{
2004 EMAC_PTP->tsctrl_bit.etsfem = new_state;
2005}
2006
2012void emac_ptp_snapshot_master_event_enable(confirm_state new_state)
2013{
2014 EMAC_PTP->tsctrl_bit.esfmrtm = new_state;
2015}
2016
2027void emac_ptp_clock_node_set(emac_ptp_clock_node_type node)
2028{
2029 EMAC_PTP->tsctrl_bit.sppfts = node;
2030}
2031
2037void emac_ptp_mac_address_filter_enable(confirm_state new_state)
2038{
2039 EMAC_PTP->tsctrl_bit.emafpff = new_state;
2040}
2041
2047void emac_ptp_subsecond_increment_set(uint8_t value)
2048{
2049 EMAC_PTP->ssinc_bit.ssiv = value;
2050}
2051
2057uint32_t emac_ptp_system_second_get(void)
2058{
2059 uint32_t second = EMAC_PTP->tsh_bit.ts;
2060 return second;
2061}
2062
2068uint32_t emac_ptp_system_subsecond_get(void)
2069{
2070 uint32_t subsecond = EMAC_PTP->tsl_bit.tss;
2071 return subsecond;
2072}
2073
2079 confirm_state emac_ptp_system_time_sign_get(void)
2080{
2081 if(EMAC_PTP->tsl_bit.ast)
2082 {
2083 return TRUE;
2084 }
2085 else
2086 {
2087 return FALSE;
2088 }
2089}
2090
2096void emac_ptp_system_second_set(uint32_t second)
2097{
2098 EMAC_PTP->tshud_bit.ts = second;
2099}
2100
2106void emac_ptp_system_subsecond_set(uint32_t subsecond)
2107{
2108 EMAC_PTP->tslud_bit.tss = subsecond;
2109}
2110
2116void emac_ptp_system_time_sign_set(confirm_state sign)
2117{
2118 if(sign)
2119 {
2120 EMAC_PTP->tslud_bit.ast = 1;
2121 }
2122 else
2123 {
2124 EMAC_PTP->tslud_bit.ast = 0;
2125 }
2126}
2127
2133void emac_ptp_timestamp_addend_set(uint32_t value)
2134{
2135 EMAC_PTP->tsad_bit.tar = value;
2136}
2137
2143void emac_ptp_target_second_set(uint32_t value)
2144{
2145 EMAC_PTP->tth_bit.ttsr = value;
2146}
2147
2153void emac_ptp_target_nanosecond_set(uint32_t value)
2154{
2155 EMAC_PTP->ttl_bit.ttlr = value;
2156}
2157
2166 confirm_state emac_ptp_timestamp_status_get(emac_ptp_timestamp_status_type status)
2167{
2168 switch(status)
2169 {
2170 case EMAC_PTP_SECOND_OVERFLOW:
2171 {
2172 if(EMAC_PTP->tssr_bit.tso)
2173 {
2174 return TRUE;
2175 }
2176 else
2177 {
2178 return FALSE;
2179 }
2180 }
2181 case EMAC_PTP_TARGET_TIME_REACH:
2182 {
2183 if(EMAC_PTP->tssr_bit.tttr)
2184 {
2185 return TRUE;
2186 }
2187 else
2188 {
2189 return FALSE;
2190 }
2191 }
2192 }
2193 return FALSE;
2194}
2195
2218void emac_ptp_pps_frequency_set(emac_ptp_pps_control_type freq)
2219{
2220 EMAC_PTP->ppscr_bit.pofc = freq;
2221}
2222
2228static void emac_delay(uint32_t delay)
2229{
2230 __IO uint32_t delay_time = delay * (system_core_clock / 8 / 1000);
2231 do
2232 {
2233 __NOP();
2234 }
2235 while(delay_time --);
2236}
2237
2259 flag_status emac_dma_flag_get(uint32_t dma_flag)
2260{
2261 flag_status status = RESET;
2262
2263 if(EMAC_DMA->sts & dma_flag)
2264 status = SET;
2265 /* return the new state (SET or RESET) */
2266 return status;
2267}
2268
2290void emac_dma_flag_clear(uint32_t dma_flag)
2291{
2292 EMAC_DMA->sts = dma_flag;
2293}
2294
2299#endif
2300
2305#endif
2306
delay
void delay(uint32_t time)
delay function
Definition: project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c:122
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
number
uint32_t number
Definition: project/at_start_f435/examples/xmc/nor_flash/src/main.c:44
system_core_clock
unsigned int system_core_clock
Definition: system_at32f435_437.c:48
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f435_437_crm.c:251
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
EMAC_DMARXDESC_FS
#define EMAC_DMARXDESC_FS
Definition: at32f435_437_emac.h:203
EMAC_DMARXDESC_FL
#define EMAC_DMARXDESC_FL
Definition: at32f435_437_emac.h:196
EMAC_DMARXDESC_OWN
#define EMAC_DMARXDESC_OWN
Definition: at32f435_437_emac.h:194
EMAC_DMARXDESC_LS
#define EMAC_DMARXDESC_LS
Definition: at32f435_437_emac.h:204
EMAC_DMARXDESC_RCH
#define EMAC_DMARXDESC_RCH
Definition: at32f435_437_emac.h:226
EMAC_DMARXDESC_DIC
#define EMAC_DMARXDESC_DIC
Definition: at32f435_437_emac.h:223
EMAC_DMATXDESC_ES
#define EMAC_DMATXDESC_ES
Definition: at32f435_437_emac.h:137
EMAC_DMATXDESC_TCH
#define EMAC_DMATXDESC_TCH
Definition: at32f435_437_emac.h:134
emac_address_filter_type
emac_address_filter_type
address filter type
Definition: at32f435_437_emac.h:388
emac_dma_receive_threshold_type
emac_dma_receive_threshold_type
receive threshold control type
Definition: at32f435_437_emac.h:486
emac_dma_transmit_threshold_type
emac_dma_transmit_threshold_type
transmit threshold control type
Definition: at32f435_437_emac.h:497
emac_intergrame_gap_type
emac_intergrame_gap_type
emac interframe gap type
Definition: at32f435_437_emac.h:320
emac_bol_type
emac_bol_type
emac back_off limit type
Definition: at32f435_437_emac.h:291
emac_ptp_timestamp_status_type
emac_ptp_timestamp_status_type
time stamp status type
Definition: at32f435_437_emac.h:556
emac_control_frames_filter_type
emac_control_frames_filter_type
emac control frames filter type
Definition: at32f435_437_emac.h:348
emac_dma_transfer_address_type
emac_dma_transfer_address_type
dma tansfer address type
Definition: at32f435_437_emac.h:534
emac_ptp_pps_control_type
emac_ptp_pps_control_type
pps control type
Definition: at32f435_437_emac.h:565
emac_ptp_clock_node_type
emac_ptp_clock_node_type
clock node type
Definition: at32f435_437_emac.h:545
emac_duplex_type
emac_duplex_type
emac duplex type
Definition: at32f435_437_emac.h:302
emac_dma_receive_process_status_type
emac_dma_receive_process_status_type
dma receive process status type
Definition: at32f435_437_emac.h:443
emac_dma_pbl_type
emac_dma_pbl_type
programmable burst length
Definition: at32f435_437_emac.h:421
emac_speed_type
emac_speed_type
emac speed type
Definition: at32f435_437_emac.h:311
emac_address_type
emac_address_type
mac address type
Definition: at32f435_437_emac.h:378
emac_pause_slot_threshold_type
emac_pause_slot_threshold_type
pause threshold type
Definition: at32f435_437_emac.h:358
emac_interrupt_mask_type
emac_interrupt_mask_type
interrupt mask type
Definition: at32f435_437_emac.h:369
emac_dma_interrupt_type
emac_dma_interrupt_type
dma interrupt type
Definition: at32f435_437_emac.h:512
emac_dma_transmit_process_status_type
emac_dma_transmit_process_status_type
dma transmit process status type
Definition: at32f435_437_emac.h:456
emac_dma_operations_type
emac_dma_operations_type
dma operations type
Definition: at32f435_437_emac.h:469
emac_dma_rx_tx_ratio_type
emac_dma_rx_tx_ratio_type
rx tx priority ratio type
Definition: at32f435_437_emac.h:410
emac_dma_tx_rx_type
emac_dma_tx_rx_type
dma tx rx type
Definition: at32f435_437_emac.h:434
emac_address_mask_type
emac_address_mask_type
address mask type
Definition: at32f435_437_emac.h:397
EMAC_DMA_RX_THRESHOLD_64_BYTES
@ EMAC_DMA_RX_THRESHOLD_64_BYTES
Definition: at32f435_437_emac.h:487
EMAC_DMA_TX_THRESHOLD_64_BYTES
@ EMAC_DMA_TX_THRESHOLD_64_BYTES
Definition: at32f435_437_emac.h:498
EMAC_INTERFRAME_GAP_96BIT
@ EMAC_INTERFRAME_GAP_96BIT
Definition: at32f435_437_emac.h:321
EMAC_BACKOFF_LIMIT_0
@ EMAC_BACKOFF_LIMIT_0
Definition: at32f435_437_emac.h:292
EMAC_PTP_SECOND_OVERFLOW
@ EMAC_PTP_SECOND_OVERFLOW
Definition: at32f435_437_emac.h:557
EMAC_PTP_TARGET_TIME_REACH
@ EMAC_PTP_TARGET_TIME_REACH
Definition: at32f435_437_emac.h:558
EMAC_DMA_TX_DESCRIPTOR
@ EMAC_DMA_TX_DESCRIPTOR
Definition: at32f435_437_emac.h:535
EMAC_DMA_RX_DESCRIPTOR
@ EMAC_DMA_RX_DESCRIPTOR
Definition: at32f435_437_emac.h:536
EMAC_DMA_TX_BUFFER
@ EMAC_DMA_TX_BUFFER
Definition: at32f435_437_emac.h:537
EMAC_DMA_RX_BUFFER
@ EMAC_DMA_RX_BUFFER
Definition: at32f435_437_emac.h:538
EMAC_HALF_DUPLEX
@ EMAC_HALF_DUPLEX
Definition: at32f435_437_emac.h:303
EMAC_DMA_RX_FETCH_DESCRIPTOR
@ EMAC_DMA_RX_FETCH_DESCRIPTOR
Definition: at32f435_437_emac.h:445
EMAC_DMA_RX_CLOSE_DESCRIPTOR
@ EMAC_DMA_RX_CLOSE_DESCRIPTOR
Definition: at32f435_437_emac.h:448
EMAC_DMA_RX_RESET_STOP_COMMAND
@ EMAC_DMA_RX_RESET_STOP_COMMAND
Definition: at32f435_437_emac.h:444
EMAC_DMA_RX_DESCRIPTOR_UNAVAILABLE
@ EMAC_DMA_RX_DESCRIPTOR_UNAVAILABLE
Definition: at32f435_437_emac.h:447
EMAC_DMA_RX_FIFO_TO_HOST
@ EMAC_DMA_RX_FIFO_TO_HOST
Definition: at32f435_437_emac.h:449
EMAC_DMA_RX_WAITING_PACKET
@ EMAC_DMA_RX_WAITING_PACKET
Definition: at32f435_437_emac.h:446
EMAC_CLOCK_RANGE_35_TO_60
@ EMAC_CLOCK_RANGE_35_TO_60
Definition: at32f435_437_emac.h:339
EMAC_CLOCK_RANGE_60_TO_100
@ EMAC_CLOCK_RANGE_60_TO_100
Definition: at32f435_437_emac.h:336
EMAC_CLOCK_RANGE_150_TO_250
@ EMAC_CLOCK_RANGE_150_TO_250
Definition: at32f435_437_emac.h:340
EMAC_CLOCK_RANGE_20_TO_35
@ EMAC_CLOCK_RANGE_20_TO_35
Definition: at32f435_437_emac.h:338
EMAC_CLOCK_RANGE_100_TO_150
@ EMAC_CLOCK_RANGE_100_TO_150
Definition: at32f435_437_emac.h:337
EMAC_CLOCK_RANGE_250_TO_288
@ EMAC_CLOCK_RANGE_250_TO_288
Definition: at32f435_437_emac.h:341
EMAC_DMA_PBL_1
@ EMAC_DMA_PBL_1
Definition: at32f435_437_emac.h:422
EMAC_SPEED_10MBPS
@ EMAC_SPEED_10MBPS
Definition: at32f435_437_emac.h:312
EMAC_ADDRESS_FILTER_3
@ EMAC_ADDRESS_FILTER_3
Definition: at32f435_437_emac.h:381
EMAC_ADDRESS_FILTER_2
@ EMAC_ADDRESS_FILTER_2
Definition: at32f435_437_emac.h:380
EMAC_ADDRESS_FILTER_1
@ EMAC_ADDRESS_FILTER_1
Definition: at32f435_437_emac.h:379
EMAC_INTERRUPT_PMT_MASK
@ EMAC_INTERRUPT_PMT_MASK
Definition: at32f435_437_emac.h:370
EMAC_INTERRUPT_TST_MASK
@ EMAC_INTERRUPT_TST_MASK
Definition: at32f435_437_emac.h:371
EMAC_DMA_INTERRUPT_TX_UNDERFLOW
@ EMAC_DMA_INTERRUPT_TX_UNDERFLOW
Definition: at32f435_437_emac.h:518
EMAC_DMA_INTERRUPT_TX_UNAVAILABLE
@ EMAC_DMA_INTERRUPT_TX_UNAVAILABLE
Definition: at32f435_437_emac.h:515
EMAC_DMA_INTERRUPT_RX_UNAVAILABLE
@ EMAC_DMA_INTERRUPT_RX_UNAVAILABLE
Definition: at32f435_437_emac.h:520
EMAC_DMA_INTERRUPT_TX
@ EMAC_DMA_INTERRUPT_TX
Definition: at32f435_437_emac.h:513
EMAC_DMA_INTERRUPT_NORMAL_SUMMARY
@ EMAC_DMA_INTERRUPT_NORMAL_SUMMARY
Definition: at32f435_437_emac.h:527
EMAC_DMA_INTERRUPT_FATAL_BUS_ERROR
@ EMAC_DMA_INTERRUPT_FATAL_BUS_ERROR
Definition: at32f435_437_emac.h:524
EMAC_DMA_INTERRUPT_TX_JABBER
@ EMAC_DMA_INTERRUPT_TX_JABBER
Definition: at32f435_437_emac.h:516
EMAC_DMA_INTERRUPT_ABNORMAL_SUMMARY
@ EMAC_DMA_INTERRUPT_ABNORMAL_SUMMARY
Definition: at32f435_437_emac.h:526
EMAC_DMA_INTERRUPT_RX_TIMEOUT
@ EMAC_DMA_INTERRUPT_RX_TIMEOUT
Definition: at32f435_437_emac.h:522
EMAC_DMA_INTERRUPT_RX
@ EMAC_DMA_INTERRUPT_RX
Definition: at32f435_437_emac.h:519
EMAC_DMA_INTERRUPT_RX_STOP
@ EMAC_DMA_INTERRUPT_RX_STOP
Definition: at32f435_437_emac.h:521
EMAC_DMA_INTERRUPT_RX_EARLY
@ EMAC_DMA_INTERRUPT_RX_EARLY
Definition: at32f435_437_emac.h:525
EMAC_DMA_INTERRUPT_TX_EARLY
@ EMAC_DMA_INTERRUPT_TX_EARLY
Definition: at32f435_437_emac.h:523
EMAC_DMA_INTERRUPT_TX_STOP
@ EMAC_DMA_INTERRUPT_TX_STOP
Definition: at32f435_437_emac.h:514
EMAC_DMA_INTERRUPT_RX_OVERFLOW
@ EMAC_DMA_INTERRUPT_RX_OVERFLOW
Definition: at32f435_437_emac.h:517
EMAC_DMA_TX_FETCH_DESCRIPTOR
@ EMAC_DMA_TX_FETCH_DESCRIPTOR
Definition: at32f435_437_emac.h:458
EMAC_DMA_TX_CLOSE_DESCRIPTOR
@ EMAC_DMA_TX_CLOSE_DESCRIPTOR
Definition: at32f435_437_emac.h:462
EMAC_DMA_TX_HOST_TO_FIFO
@ EMAC_DMA_TX_HOST_TO_FIFO
Definition: at32f435_437_emac.h:460
EMAC_DMA_TX_WAITING_FOR_STATUS
@ EMAC_DMA_TX_WAITING_FOR_STATUS
Definition: at32f435_437_emac.h:459
EMAC_DMA_TX_RESET_STOP_COMMAND
@ EMAC_DMA_TX_RESET_STOP_COMMAND
Definition: at32f435_437_emac.h:457
EMAC_DMA_TX_DESCRIPTOR_UNAVAILABLE
@ EMAC_DMA_TX_DESCRIPTOR_UNAVAILABLE
Definition: at32f435_437_emac.h:461
EMAC_DMA_OPS_FORWARD_UNDERSIZED
@ EMAC_DMA_OPS_FORWARD_UNDERSIZED
Definition: at32f435_437_emac.h:472
EMAC_DMA_OPS_RECEIVE_FLUSH_DISABLE
@ EMAC_DMA_OPS_RECEIVE_FLUSH_DISABLE
Definition: at32f435_437_emac.h:477
EMAC_DMA_OPS_TRANSMIT_STORE_FORWARD
@ EMAC_DMA_OPS_TRANSMIT_STORE_FORWARD
Definition: at32f435_437_emac.h:476
EMAC_DMA_OPS_DROP_ERROR_DISABLE
@ EMAC_DMA_OPS_DROP_ERROR_DISABLE
Definition: at32f435_437_emac.h:479
EMAC_DMA_OPS_RECEIVE_STORE_FORWARD
@ EMAC_DMA_OPS_RECEIVE_STORE_FORWARD
Definition: at32f435_437_emac.h:478
EMAC_DMA_OPS_FLUSH_TRANSMIT_FIFO
@ EMAC_DMA_OPS_FLUSH_TRANSMIT_FIFO
Definition: at32f435_437_emac.h:475
EMAC_DMA_OPS_SECOND_FRAME
@ EMAC_DMA_OPS_SECOND_FRAME
Definition: at32f435_437_emac.h:471
EMAC_DMA_OPS_START_STOP_RECEIVE
@ EMAC_DMA_OPS_START_STOP_RECEIVE
Definition: at32f435_437_emac.h:470
EMAC_DMA_OPS_START_STOP_TRANSMIT
@ EMAC_DMA_OPS_START_STOP_TRANSMIT
Definition: at32f435_437_emac.h:474
EMAC_DMA_OPS_FORWARD_ERROR
@ EMAC_DMA_OPS_FORWARD_ERROR
Definition: at32f435_437_emac.h:473
EMAC_AUTO_NEGOTIATION_OFF
@ EMAC_AUTO_NEGOTIATION_OFF
Definition: at32f435_437_emac.h:283
EMAC_DMA_1_RX_1_TX
@ EMAC_DMA_1_RX_1_TX
Definition: at32f435_437_emac.h:411
EMAC_DMA_TRANSMIT
@ EMAC_DMA_TRANSMIT
Definition: at32f435_437_emac.h:435
EMAC_DMA_RECEIVE
@ EMAC_DMA_RECEIVE
Definition: at32f435_437_emac.h:436
MMC_RX_GOOD_UNICAST
#define MMC_RX_GOOD_UNICAST
Definition: at32f435_437_emac.h:88
MMC_TX_SINGLE_COL
#define MMC_TX_SINGLE_COL
Definition: at32f435_437_emac.h:89
MMC_RX_CRC_ERROR
#define MMC_RX_CRC_ERROR
Definition: at32f435_437_emac.h:86
MMC_TX_GOOD_FRAMES
#define MMC_TX_GOOD_FRAMES
Definition: at32f435_437_emac.h:91
MMC_TX_MULTIPLE_COL
#define MMC_TX_MULTIPLE_COL
Definition: at32f435_437_emac.h:90
MMC_RX_ALIGN_ERROR
#define MMC_RX_ALIGN_ERROR
Definition: at32f435_437_emac.h:87
EMAC_MAX_PACKET_LENGTH
#define EMAC_MAX_PACKET_LENGTH
Definition: at32f435_437_emac.h:102
EMAC_DMARXDESC_FRAME_LENGTHSHIFT
#define EMAC_DMARXDESC_FRAME_LENGTHSHIFT
Definition: at32f435_437_emac.h:110
emac_global_unicast_set
void emac_global_unicast_set(confirm_state new_state)
set unicast frame that passes DAF as wakeup frame.
Definition: at32f435_437_emac.c:811
emac_zero_quanta_pause_disable
void emac_zero_quanta_pause_disable(confirm_state new_state)
set zero-quanta pause disable.
Definition: at32f435_437_emac.c:687
emac_vlan_tag_comparison_set
void emac_vlan_tag_comparison_set(confirm_state new_state)
set 12-bit vlan identifier.
Definition: at32f435_437_emac.c:717
emac_loopback_mode_enable
void emac_loopback_mode_enable(confirm_state new_state)
enable loopback mode.
Definition: at32f435_437_emac.c:378
emac_ptp_system_second_set
void emac_ptp_system_second_set(uint32_t second)
set system time second
Definition: at32f435_437_emac.c:2096
emac_ptp_target_second_set
void emac_ptp_target_second_set(uint32_t value)
set target time stamp high
Definition: at32f435_437_emac.c:2143
emac_dma_fifo_overflow_bit_get
uint8_t emac_dma_fifo_overflow_bit_get(void)
get overflow bit for FIFO overflow counter
Definition: at32f435_437_emac.c:1617
emac_mmc_received_interrupt_mask_set
void emac_mmc_received_interrupt_mask_set(uint32_t flag, confirm_state new_state)
mask received mmc interrupt
Definition: at32f435_437_emac.c:1755
emac_dma_transmit_threshold_set
void emac_dma_transmit_threshold_set(emac_dma_transmit_threshold_type value)
set transmit dma threshold
Definition: at32f435_437_emac.c:1470
emac_hash_unicast_set
void emac_hash_unicast_set(confirm_state new_state)
hash unicast.
Definition: at32f435_437_emac.c:483
emac_auto_pad_crc_stripping_set
void emac_auto_pad_crc_stripping_set(confirm_state new_state)
set mac automatic pad/CRC stripping.
Definition: at32f435_437_emac.c:348
emac_dma_software_reset_set
void emac_dma_software_reset_set(void)
reset emac dma
Definition: at32f435_437_emac.c:156
emac_control_para_init
void emac_control_para_init(emac_control_config_type *control_para)
initialize emac control structure
Definition: at32f435_437_emac.c:70
emac_ptp_timestamp_enable
void emac_ptp_timestamp_enable(confirm_state new_state)
enable timestamp.
Definition: at32f435_437_emac.c:1882
emac_ptp_snapshot_ipv4_frames_enable
void emac_ptp_snapshot_ipv4_frames_enable(confirm_state new_state)
enable snapshot for ipv4 frames.
Definition: at32f435_437_emac.c:1992
emac_dstaddr_inverse_filter_set
void emac_dstaddr_inverse_filter_set(confirm_state new_state)
destination address inverse filtering.
Definition: at32f435_437_emac.c:503
emac_dma_receive_status_get
emac_dma_receive_process_status_type emac_dma_receive_status_get(void)
get receive dma process status
Definition: at32f435_437_emac.c:1266
emac_ptp_clock_node_set
void emac_ptp_clock_node_set(emac_ptp_clock_node_type node)
set clock node type
Definition: at32f435_437_emac.c:2027
emac_ptp_pps_frequency_set
void emac_ptp_pps_frequency_set(emac_ptp_pps_control_type freq)
set pps frequency
Definition: at32f435_437_emac.c:2218
emac_dma_rx_desc_interrupt_config
void emac_dma_rx_desc_interrupt_config(emac_dma_desc_type *dma_rx_desc, confirm_state new_state)
enable or disable the specified dma rx descriptor receive interrupt
Definition: at32f435_437_emac.c:1001
emac_ptp_system_subsecond_set
void emac_ptp_system_subsecond_set(uint32_t subsecond)
set system time subsecond
Definition: at32f435_437_emac.c:2106
emac_pass_all_multicasting_set
void emac_pass_all_multicasting_set(confirm_state new_state)
pass all multicasting frames.
Definition: at32f435_437_emac.c:513
emac_dma_operations_set
void emac_dma_operations_set(emac_dma_operations_type ops, confirm_state new_state)
set dma operations
Definition: at32f435_437_emac.c:1371
emac_interrupt_mask_set
void emac_interrupt_mask_set(emac_interrupt_mask_type mask_type, confirm_state new_state)
set interrupt mask
Definition: at32f435_437_emac.c:858
emac_receive_own_disable
void emac_receive_own_disable(confirm_state new_state)
receive own disable.
Definition: at32f435_437_emac.c:388
emac_dma_software_reset_get
flag_status emac_dma_software_reset_get(void)
get emac dma reset status
Definition: at32f435_437_emac.c:166
emac_hash_table_high32bits_set
void emac_hash_table_high32bits_set(uint32_t high32bits)
hash table high 32-bit.
Definition: at32f435_437_emac.c:587
dma_rx_desc_to_get
emac_dma_desc_type * dma_rx_desc_to_get
Definition: at32f435_437_emac.c:49
emac_dma_flag_get
flag_status emac_dma_flag_get(uint32_t dma_flag)
check whether the specified emac dma flag is set or not.
Definition: at32f435_437_emac.c:2259
emac_control_config
void emac_control_config(emac_control_config_type *control_struct)
configure emac control setting.
Definition: at32f435_437_emac.c:136
emac_srcaddr_filter_set
void emac_srcaddr_filter_set(confirm_state new_state)
source address filtering.
Definition: at32f435_437_emac.c:557
emac_ptp_subsecond_rollover_enable
void emac_ptp_subsecond_rollover_enable(confirm_state new_state)
enable digital rollover.
Definition: at32f435_437_emac.c:1952
emac_wakeup_frame_enable
void emac_wakeup_frame_enable(confirm_state new_state)
wakeup frame enable
Definition: at32f435_437_emac.c:767
emac_dma_receive_threshold_set
void emac_dma_receive_threshold_set(emac_dma_receive_threshold_type value)
set receive dma threshold
Definition: at32f435_437_emac.c:1451
emac_trasmitter_enable
void emac_trasmitter_enable(confirm_state new_state)
emac transmitter enable.
Definition: at32f435_437_emac.c:307
emac_ptp_subsecond_increment_set
void emac_ptp_subsecond_increment_set(uint8_t value)
set subsecond increment value
Definition: at32f435_437_emac.c:2047
emac_dma_application_missing_frame_get
uint16_t emac_dma_application_missing_frame_get(void)
get missed frames by the application
Definition: at32f435_437_emac.c:1606
emac_mmc_counter_reset
void emac_mmc_counter_reset(void)
reset all counter
Definition: at32f435_437_emac.c:1668
emac_power_down_set
void emac_power_down_set(confirm_state new_state)
all frame will be droppped except wakeup frame or magic packet.
Definition: at32f435_437_emac.c:747
emac_ptp_system_second_get
uint32_t emac_ptp_system_second_get(void)
get system time second
Definition: at32f435_437_emac.c:2057
emac_phy_register_read
error_status emac_phy_register_read(uint8_t address, uint8_t reg, uint16_t *data)
read phy data
Definition: at32f435_437_emac.c:262
emac_receive_flow_control_enable
void emac_receive_flow_control_enable(confirm_state new_state)
set receive flow control.
Definition: at32f435_437_emac.c:652
emac_magic_packet_enable
void emac_magic_packet_enable(confirm_state new_state)
magic packet enable
Definition: at32f435_437_emac.c:757
emac_dma_separate_pbl_set
void emac_dma_separate_pbl_set(emac_dma_pbl_type tx_length, emac_dma_pbl_type rx_length, confirm_state new_state)
set programmable burst length
Definition: at32f435_437_emac.c:1173
emac_received_magic_packet_get
flag_status emac_received_magic_packet_get(void)
received magic packet
Definition: at32f435_437_emac.c:777
emac_receive_all_set
void emac_receive_all_set(confirm_state new_state)
mac receives all frames.
Definition: at32f435_437_emac.c:577
emac_ptp_system_time_sign_get
confirm_state emac_ptp_system_time_sign_get(void)
get system time sign
Definition: at32f435_437_emac.c:2079
emac_receiver_enable
void emac_receiver_enable(confirm_state new_state)
emac receiver enable.
Definition: at32f435_437_emac.c:291
emac_dma_address_aligned_beats_set
void emac_dma_address_aligned_beats_set(confirm_state new_state)
set address-aligned beats
Definition: at32f435_437_emac.c:1199
emac_ptp_timestamp_system_time_init
void emac_ptp_timestamp_system_time_init(confirm_state new_state)
initialize timestamp time system.
Definition: at32f435_437_emac.c:1902
emac_broadcast_frames_disable
void emac_broadcast_frames_disable(confirm_state new_state)
broadcast frames disable.
Definition: at32f435_437_emac.c:523
emac_vlan_tag_identifier_set
void emac_vlan_tag_identifier_set(uint16_t identifier)
identify coming vlan frame field with setting value.
Definition: at32f435_437_emac.c:707
emac_promiscuous_mode_set
void emac_promiscuous_mode_set(confirm_state new_state)
set mac promiscuous mode.
Definition: at32f435_437_emac.c:473
emac_ptp_interrupt_trigger_enable
void emac_ptp_interrupt_trigger_enable(confirm_state new_state)
enable timestamp interrupt trigger.
Definition: at32f435_437_emac.c:1922
emac_interframe_gap_set
void emac_interframe_gap_set(emac_intergrame_gap_type number)
set minimum interframe gap between frames during transmission.
Definition: at32f435_437_emac.c:417
dma_tx_desc_to_set
emac_dma_desc_type * dma_tx_desc_to_set
global pointers on tx and rx descriptor used to track transmit and receive descriptors
Definition: at32f435_437_emac.c:48
emac_mmc_transmit_status_get
flag_status emac_mmc_transmit_status_get(uint32_t flag)
interupt status of transmit frames
Definition: at32f435_437_emac.c:1733
emac_retry_disable
void emac_retry_disable(confirm_state new_state)
transmittion retry disable.
Definition: at32f435_437_emac.c:358
emac_wakeup_frame_get
uint32_t emac_wakeup_frame_get(void)
get wakeup frame.
Definition: at32f435_437_emac.c:737
emac_reset
void emac_reset(void)
deinitialize the emac peripheral registers to their default reset values.
Definition: at32f435_437_emac.c:59
emac_start
void emac_start(void)
enable emac and dma reception/transmission
Definition: at32f435_437_emac.c:183
emac_ptp_system_time_sign_set
void emac_ptp_system_time_sign_set(confirm_state sign)
set system time sign
Definition: at32f435_437_emac.c:2116
emac_duplex_mode_set
void emac_duplex_mode_set(emac_duplex_type duplex_mode)
set duplex mode.
Definition: at32f435_437_emac.c:463
emac_transmit_flow_control_enable
void emac_transmit_flow_control_enable(confirm_state new_state)
set transmit flow control.
Definition: at32f435_437_emac.c:642
emac_dmarxdesc_frame_length_get
uint32_t emac_dmarxdesc_frame_length_get(emac_dma_desc_type *dma_rx_desc)
get the specified dma rx descsriptor frame length.
Definition: at32f435_437_emac.c:1063
emac_ptp_timestamp_system_time_update
void emac_ptp_timestamp_system_time_update(confirm_state new_state)
update timestamp time system.
Definition: at32f435_437_emac.c:1912
emac_ptp_snapshot_received_frames_enable
void emac_ptp_snapshot_received_frames_enable(confirm_state new_state)
enable timestamp snapshot for all received frames.
Definition: at32f435_437_emac.c:1942
emac_address_filter_set
void emac_address_filter_set(emac_address_type mac, emac_address_filter_type filter, emac_address_mask_type mask_bit, confirm_state new_state)
set mac filter address
Definition: at32f435_437_emac.c:895
emac_hash_table_low32bits_set
void emac_hash_table_low32bits_set(uint32_t low32bits)
hash table low 32-bit.
Definition: at32f435_437_emac.c:597
emac_hash_multicast_set
void emac_hash_multicast_set(confirm_state new_state)
hash multicast.
Definition: at32f435_437_emac.c:493
emac_ptp_psv2_enable
void emac_ptp_psv2_enable(confirm_state new_state)
enable packet snooping for version 2.
Definition: at32f435_437_emac.c:1962
emac_mmc_transmit_good_frames_get
uint32_t emac_mmc_transmit_good_frames_get(uint32_t flag)
get good frame numbers as single collision occurs.
Definition: at32f435_437_emac.c:1818
emac_dma_poll_demand_get
uint32_t emac_dma_poll_demand_get(emac_dma_tx_rx_type transfer_type)
get transmit poll demand
Definition: at32f435_437_emac.c:1238
emac_backoff_limit_set
void emac_backoff_limit_set(emac_bol_type slot_time)
emac back-off limit, only avalible in half-duplex mode.
Definition: at32f435_437_emac.c:338
emac_fast_speed_set
void emac_fast_speed_set(emac_speed_type speed)
set mac fast emac speed.
Definition: at32f435_437_emac.c:450
emac_dma_flag_clear
void emac_dma_flag_clear(uint32_t dma_flag)
clear the emac dma flag.
Definition: at32f435_437_emac.c:2290
emac_mmc_counter_freeze
void emac_mmc_counter_freeze(confirm_state new_state)
freeze mmc counter
Definition: at32f435_437_emac.c:1698
emac_clock_range_set
void emac_clock_range_set(void)
according to hclk to set mdc clock frequency.
Definition: at32f435_437_emac.c:93
emac_ptp_system_subsecond_get
uint32_t emac_ptp_system_subsecond_get(void)
get system time subsecond
Definition: at32f435_437_emac.c:2068
emac_interrupt_status_read
flag_status emac_interrupt_status_read(uint32_t flag)
read interrupt status
Definition: at32f435_437_emac.c:837
emac_dma_interrupt_enable
void emac_dma_interrupt_enable(emac_dma_interrupt_type it, confirm_state new_state)
enable dma interrupt
Definition: at32f435_437_emac.c:1497
emac_dma_poll_demand_set
void emac_dma_poll_demand_set(emac_dma_tx_rx_type transfer_type, uint32_t value)
set transmit/receive poll demand
Definition: at32f435_437_emac.c:1213
emac_pass_control_frames_set
void emac_pass_control_frames_set(emac_control_frames_filter_type condition)
set mac how to pass control frames.
Definition: at32f435_437_emac.c:537
emac_dma_para_init
void emac_dma_para_init(emac_dma_config_type *control_para)
init emac dma parameters
Definition: at32f435_437_emac.c:1073
emac_mmc_rollover_stop
void emac_mmc_rollover_stop(confirm_state new_state)
counter stop counting from zero when it reaches maximum
Definition: at32f435_437_emac.c:1678
emac_ptp_snapshot_event_message_enable
void emac_ptp_snapshot_event_message_enable(confirm_state new_state)
enable snapshot for event message.
Definition: at32f435_437_emac.c:2002
emac_wakeup_frame_filter_reset
void emac_wakeup_frame_filter_reset(confirm_state new_state)
reset wakeup frame filter resgister
Definition: at32f435_437_emac.c:821
emac_ptp_snapshot_ipv6_frames_enable
void emac_ptp_snapshot_ipv6_frames_enable(confirm_state new_state)
enable snapshot for ipv6 frames.
Definition: at32f435_437_emac.c:1982
emac_received_packet_size_get
uint32_t emac_received_packet_size_get(void)
get the size of received the received packet.
Definition: at32f435_437_emac.c:1044
emac_hash_perfect_filter_set
void emac_hash_perfect_filter_set(confirm_state new_state)
mac uses hash or perfect filter.
Definition: at32f435_437_emac.c:567
emac_phy_register_write
error_status emac_phy_register_write(uint8_t address, uint8_t reg, uint16_t data)
write phy data.
Definition: at32f435_437_emac.c:232
emac_deferral_check_set
void emac_deferral_check_set(confirm_state new_state)
emac defferal check enable, only avalible in half-duplex mode.
Definition: at32f435_437_emac.c:323
emac_pause_time_set
void emac_pause_time_set(uint16_t pause_time)
set pause time.
Definition: at32f435_437_emac.c:697
emac_delay
static void emac_delay(uint32_t delay)
this is delay function base on system clock.
Definition: at32f435_437_emac.c:2228
emac_ptp_target_nanosecond_set
void emac_ptp_target_nanosecond_set(uint32_t value)
set target time stamp low
Definition: at32f435_437_emac.c:2153
emac_mii_write
void emac_mii_write(confirm_state new_state)
tell phy that will be written.
Definition: at32f435_437_emac.c:622
emac_dma_config
void emac_dma_config(emac_dma_config_type *control_para)
configure emac dma
Definition: at32f435_437_emac.c:1099
emac_mmc_reset_on_read_enable
void emac_mmc_reset_on_read_enable(confirm_state new_state)
enable reset on read
Definition: at32f435_437_emac.c:1688
emac_watchdog_disable
void emac_watchdog_disable(confirm_state new_state)
watchdog disable.
Definition: at32f435_437_emac.c:437
emac_ptp_timestamp_fine_update_enable
void emac_ptp_timestamp_fine_update_enable(confirm_state new_state)
enable timestamp fine update.
Definition: at32f435_437_emac.c:1892
emac_dma_eight_pbl_mode_set
void emac_dma_eight_pbl_mode_set(confirm_state new_state)
set 8 times programmable burst length
Definition: at32f435_437_emac.c:1189
emac_ptp_timestamp_status_get
confirm_state emac_ptp_timestamp_status_get(emac_ptp_timestamp_status_type status)
set target time stamp low
Definition: at32f435_437_emac.c:2166
emac_fcb_bpa_set
void emac_fcb_bpa_set(confirm_state new_state)
set flow control busy in full-duplex mode, back pressure activate in half-duplex mode.
Definition: at32f435_437_emac.c:632
emac_mmc_received_error_frames_get
uint32_t emac_mmc_received_error_frames_get(uint32_t flag)
get good frame numbers as single collision occurs.
Definition: at32f435_437_emac.c:1852
emac_carrier_sense_disable
void emac_carrier_sense_disable(confirm_state new_state)
carrier sense disbale.
Definition: at32f435_437_emac.c:398
emac_unicast_pause_frame_detect
void emac_unicast_pause_frame_detect(confirm_state new_state)
set unicast pause frame detect.
Definition: at32f435_437_emac.c:662
emac_dma_controller_missing_frame_get
uint16_t emac_dma_controller_missing_frame_get(void)
get missed frames by the controller
Definition: at32f435_437_emac.c:1584
emac_ptp_timestamp_addend_set
void emac_ptp_timestamp_addend_set(uint32_t value)
set time stamp addend
Definition: at32f435_437_emac.c:2133
emac_dma_transmit_status_get
emac_dma_transmit_process_status_type emac_dma_transmit_status_get(void)
get transmit dma process status
Definition: at32f435_437_emac.c:1316
emac_received_wakeup_frame_get
flag_status emac_received_wakeup_frame_get(void)
received wakeup frame.
Definition: at32f435_437_emac.c:794
emac_dma_arbitation_set
void emac_dma_arbitation_set(emac_dma_rx_tx_ratio_type ratio, confirm_state new_state)
set rx tx priority
Definition: at32f435_437_emac.c:1132
emac_ptp_mac_address_filter_enable
void emac_ptp_mac_address_filter_enable(confirm_state new_state)
enable ptp frame filtering mac address
Definition: at32f435_437_emac.c:2037
emac_dma_missing_overflow_bit_get
uint8_t emac_dma_missing_overflow_bit_get(void)
get overflow bit for missed frame counter
Definition: at32f435_437_emac.c:1595
emac_wakeup_frame_set
void emac_wakeup_frame_set(uint32_t value)
set wakeup frame.
Definition: at32f435_437_emac.c:727
emac_mmc_received_status_get
flag_status emac_mmc_received_status_get(uint32_t flag)
interupt status of received frames
Definition: at32f435_437_emac.c:1712
emac_mmc_transmit_interrupt_mask_set
void emac_mmc_transmit_interrupt_mask_set(uint32_t flag, confirm_state new_state)
mask transmit mmc interrupt
Definition: at32f435_437_emac.c:1787
emac_dma_descriptor_list_address_set
void emac_dma_descriptor_list_address_set(emac_dma_tx_rx_type transfer_type, emac_dma_desc_type *dma_desc_tab, uint8_t *buff, uint32_t buffer_count)
set transmit/receive descriptor list address
Definition: at32f435_437_emac.c:934
emac_ptp_addend_register_update
void emac_ptp_addend_register_update(confirm_state new_state)
update timestamp addend register.
Definition: at32f435_437_emac.c:1932
emac_ipv4_checksum_offload_set
void emac_ipv4_checksum_offload_set(confirm_state new_state)
set ipv4 checksum offload.
Definition: at32f435_437_emac.c:368
emac_stop
void emac_stop(void)
stop emac and dma reception/transmission
Definition: at32f435_437_emac.c:206
emac_dma_descriptor_skip_length_set
void emac_dma_descriptor_skip_length_set(uint8_t length)
set descriptor skip mength
Definition: at32f435_437_emac.c:1147
emac_jabber_disable
void emac_jabber_disable(confirm_state new_state)
jabber disable.
Definition: at32f435_437_emac.c:427
emac_dma_tansfer_address_get
uint32_t emac_dma_tansfer_address_get(emac_dma_transfer_address_type transfer_type)
get overflow bit for FIFO overflow counter
Definition: at32f435_437_emac.c:1633
emac_ptp_snapshot_master_event_enable
void emac_ptp_snapshot_master_event_enable(confirm_state new_state)
enable snapshot for message relevant to master
Definition: at32f435_437_emac.c:2012
emac_dma_descriptor_list_address_get
uint32_t emac_dma_descriptor_list_address_get(emac_dma_tx_rx_type transfer_type)
get transmit/receive descriptor list address
Definition: at32f435_437_emac.c:1023
emac_pause_low_threshold_set
void emac_pause_low_threshold_set(emac_pause_slot_threshold_type pasue_threshold)
set pause low threshold.
Definition: at32f435_437_emac.c:677
emac_srcaddr_inverse_filter_set
void emac_srcaddr_inverse_filter_set(confirm_state new_state)
source address inverse filtering.
Definition: at32f435_437_emac.c:547
emac_mii_busy_get
flag_status emac_mii_busy_get(void)
mii busy status.
Definition: at32f435_437_emac.c:607
emac_ptp_snapshot_emac_frames_enable
void emac_ptp_snapshot_emac_frames_enable(confirm_state new_state)
enable snapshot over emac.
Definition: at32f435_437_emac.c:1972
emac_local_address_set
void emac_local_address_set(uint8_t *address)
set local mac address
Definition: at32f435_437_emac.c:880
EMAC_HCLK_BORDER_150MHZ
#define EMAC_HCLK_BORDER_150MHZ
Definition: at32f435_437_emac.h:58
EMAC_HCLK_BORDER_60MHZ
#define EMAC_HCLK_BORDER_60MHZ
Definition: at32f435_437_emac.h:56
EMAC_HCLK_BORDER_100MHZ
#define EMAC_HCLK_BORDER_100MHZ
Definition: at32f435_437_emac.h:57
EMAC_HCLK_BORDER_250MHZ
#define EMAC_HCLK_BORDER_250MHZ
Definition: at32f435_437_emac.h:59
EMAC_HCLK_BORDER_35MHZ
#define EMAC_HCLK_BORDER_35MHZ
Definition: at32f435_437_emac.h:55
EMAC_HCLK_BORDER_288MHZ
#define EMAC_HCLK_BORDER_288MHZ
Definition: at32f435_437_emac.h:60
EMAC_HCLK_BORDER_20MHZ
#define EMAC_HCLK_BORDER_20MHZ
Definition: at32f435_437_emac.h:54
EMAC_MMC
#define EMAC_MMC
Definition: at32f435_437_emac.h:1559
EMAC_PTP
#define EMAC_PTP
Definition: at32f435_437_emac.h:1560
PHY_TIMEOUT
#define PHY_TIMEOUT
Definition: at32f435_437_emac.h:47
EMAC_DMA
#define EMAC_DMA
Definition: at32f435_437_emac.h:1561
EMAC
#define EMAC
Definition: at32f435_437_emac.h:1558
error_status
error_status
Definition: at32f435_437.h:380
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::ahb_freq
uint32_t ahb_freq
Definition: at32f435_437_crm.h:790
emac_control_config_type
ethernet mac control config type
Definition: at32f435_437_emac.h:588
emac_control_config_type::auto_pad_crc_strip
confirm_state auto_pad_crc_strip
Definition: at32f435_437_emac.h:592
emac_control_config_type::jabber_disable
confirm_state jabber_disable
Definition: at32f435_437_emac.h:601
emac_control_config_type::loopback_mode
confirm_state loopback_mode
Definition: at32f435_437_emac.h:596
emac_control_config_type::back_off_limit
emac_bol_type back_off_limit
Definition: at32f435_437_emac.h:591
emac_control_config_type::auto_nego
emac_auto_negotiation_type auto_nego
Definition: at32f435_437_emac.h:589
emac_control_config_type::retry_disable
confirm_state retry_disable
Definition: at32f435_437_emac.h:593
emac_control_config_type::fast_ethernet_speed
emac_speed_type fast_ethernet_speed
Definition: at32f435_437_emac.h:598
emac_control_config_type::deferral_check
confirm_state deferral_check
Definition: at32f435_437_emac.h:590
emac_control_config_type::receive_own_disable
confirm_state receive_own_disable
Definition: at32f435_437_emac.h:597
emac_control_config_type::watchdog_disable
confirm_state watchdog_disable
Definition: at32f435_437_emac.h:602
emac_control_config_type::interframe_gap
emac_intergrame_gap_type interframe_gap
Definition: at32f435_437_emac.h:600
emac_control_config_type::duplex_mode
emac_duplex_type duplex_mode
Definition: at32f435_437_emac.h:595
emac_control_config_type::carrier_sense_disable
confirm_state carrier_sense_disable
Definition: at32f435_437_emac.h:599
emac_control_config_type::ipv4_checksum_offload
confirm_state ipv4_checksum_offload
Definition: at32f435_437_emac.h:594
emac_dma_config_type
ethernet mac dma config type
Definition: at32f435_437_emac.h:609
emac_dma_config_type::tx_dma_pal
emac_dma_pbl_type tx_dma_pal
Definition: at32f435_437_emac.h:614
emac_dma_config_type::aab_enable
confirm_state aab_enable
Definition: at32f435_437_emac.h:610
emac_dma_config_type::dt_disable
confirm_state dt_disable
Definition: at32f435_437_emac.h:618
emac_dma_config_type::rx_dma_pal
emac_dma_pbl_type rx_dma_pal
Definition: at32f435_437_emac.h:612
emac_dma_config_type::flush_rx_disable
confirm_state flush_rx_disable
Definition: at32f435_437_emac.h:620
emac_dma_config_type::rx_threshold
emac_dma_receive_threshold_type rx_threshold
Definition: at32f435_437_emac.h:625
emac_dma_config_type::priority_ratio
emac_dma_rx_tx_ratio_type priority_ratio
Definition: at32f435_437_emac.h:617
emac_dma_config_type::fugf_enable
confirm_state fugf_enable
Definition: at32f435_437_emac.h:624
emac_dma_config_type::desc_skip_length
uint8_t desc_skip_length
Definition: at32f435_437_emac.h:615
emac_dma_config_type::osf_enable
confirm_state osf_enable
Definition: at32f435_437_emac.h:626
emac_dma_config_type::usp_enable
confirm_state usp_enable
Definition: at32f435_437_emac.h:611
emac_dma_config_type::rsf_enable
confirm_state rsf_enable
Definition: at32f435_437_emac.h:619
emac_dma_config_type::tsf_enable
confirm_state tsf_enable
Definition: at32f435_437_emac.h:621
emac_dma_config_type::da_enable
confirm_state da_enable
Definition: at32f435_437_emac.h:616
emac_dma_config_type::fef_enable
confirm_state fef_enable
Definition: at32f435_437_emac.h:623
emac_dma_config_type::tx_threshold
emac_dma_transmit_threshold_type tx_threshold
Definition: at32f435_437_emac.h:622
emac_dma_config_type::fb_enable
confirm_state fb_enable
Definition: at32f435_437_emac.h:613
emac_dma_desc_type
dma desciptors data structure definition
Definition: at32f435_437_emac.h:632
emac_dma_desc_type::status
uint32_t status
Definition: at32f435_437_emac.h:633
emac_dma_desc_type::buf1addr
uint32_t buf1addr
Definition: at32f435_437_emac.h:635
emac_dma_desc_type::controlsize
uint32_t controlsize
Definition: at32f435_437_emac.h:634
emac_dma_desc_type::buf2nextdescaddr
uint32_t buf2nextdescaddr
Definition: at32f435_437_emac.h:636
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_emac.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_emac.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_EMAC_H
29#define __AT32F435_437_EMAC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
47#define PHY_TIMEOUT (0x000FFFFF)
54#define EMAC_HCLK_BORDER_20MHZ (20000000)
55#define EMAC_HCLK_BORDER_35MHZ (35000000)
56#define EMAC_HCLK_BORDER_60MHZ (60000000)
57#define EMAC_HCLK_BORDER_100MHZ (100000000)
58#define EMAC_HCLK_BORDER_150MHZ (150000000)
59#define EMAC_HCLK_BORDER_250MHZ (250000000)
60#define EMAC_HCLK_BORDER_288MHZ (288000000)
71#define EMAC_PMT_FLAG ((uint32_t)0x00000008)
72#define EMAC_MMC_FLAG ((uint32_t)0x00000010)
73#define EMAC_MMCR_FLAG ((uint32_t)0x00000020)
74#define EMAC_MMCT_FLAG ((uint32_t)0x00000040)
75#define EMAC_TST_FLAG ((uint32_t)0x00000200)
86#define MMC_RX_CRC_ERROR ((uint32_t)0x00000020)
87#define MMC_RX_ALIGN_ERROR ((uint32_t)0x00000040)
88#define MMC_RX_GOOD_UNICAST ((uint32_t)0x00020000)
89#define MMC_TX_SINGLE_COL ((uint32_t)0x00004000)
90#define MMC_TX_MULTIPLE_COL ((uint32_t)0x00008000)
91#define MMC_TX_GOOD_FRAMES ((uint32_t)0x00200000)
102#define EMAC_MAX_PACKET_LENGTH 1520
103#define EMAC_HEADER 14
104#define EMAC_CRC 4
105#define EMAC_EXTRA 2
106#define VLAN_TAG 4
107#define EMAC_MIN_PAYLOAD 46
108#define EMAC_MAX_PAYLOAD 1500
109#define JUMBO_FRAME_PAYLOAD 9000
110#define EMAC_DMARXDESC_FRAME_LENGTHSHIFT 16
111
121#define EMAC_DMATXDESC_OWN ((uint32_t)0x80000000)
122#define EMAC_DMATXDESC_IC ((uint32_t)0x40000000)
123#define EMAC_DMATXDESC_LS ((uint32_t)0x20000000)
124#define EMAC_DMATXDESC_FS ((uint32_t)0x10000000)
125#define EMAC_DMATXDESC_DC ((uint32_t)0x08000000)
126#define EMAC_DMATXDESC_DP ((uint32_t)0x04000000)
127#define EMAC_DMATXDESC_TTSE ((uint32_t)0x02000000)
128#define EMAC_DMATXDESC_CIC ((uint32_t)0x00C00000)
129#define EMAC_DMATXDESC_CIC_BYPASS ((uint32_t)0x00000000)
130#define EMAC_DMATXDESC_CIC_IPV4HEADER ((uint32_t)0x00400000)
131#define EMAC_DMATXDESC_CIC_TUI_SEG ((uint32_t)0x00800000)
132#define EMAC_DMATXDESC_CIC_TUI_FULL ((uint32_t)0x00C00000)
133#define EMAC_DMATXDESC_TER ((uint32_t)0x00200000)
134#define EMAC_DMATXDESC_TCH ((uint32_t)0x00100000)
135#define EMAC_DMATXDESC_TTSS ((uint32_t)0x00020000)
136#define EMAC_DMATXDESC_IHE ((uint32_t)0x00010000)
137#define EMAC_DMATXDESC_ES ((uint32_t)0x00008000)
138#define EMAC_DMATXDESC_JT ((uint32_t)0x00004000)
139#define EMAC_DMATXDESC_FF ((uint32_t)0x00002000)
140#define EMAC_DMATXDESC_PCE ((uint32_t)0x00001000)
141#define EMAC_DMATXDESC_LCA ((uint32_t)0x00000800)
142#define EMAC_DMATXDESC_NC ((uint32_t)0x00000400)
143#define EMAC_DMATXDESC_LCO ((uint32_t)0x00000200)
144#define EMAC_DMATXDESC_EC ((uint32_t)0x00000100)
145#define EMAC_DMATXDESC_VF ((uint32_t)0x00000080)
146#define EMAC_DMATXDESC_CC ((uint32_t)0x00000078)
147#define EMAC_DMATXDESC_ED ((uint32_t)0x00000004)
148#define EMAC_DMATXDESC_UF ((uint32_t)0x00000002)
149#define EMAC_DMATXDESC_DB ((uint32_t)0x00000001)
160#define EMAC_DMATXDESC_TBS2 ((uint32_t)0x1FFF0000)
161#define EMAC_DMATXDESC_TBS1 ((uint32_t)0x00001FFF)
172#define EMAC_DMATXDESC_B1AP ((uint32_t)0xFFFFFFFF)
183#define EMAC_DMATxDesc_B2AP ((uint32_t)0xFFFFFFFF)
194#define EMAC_DMARXDESC_OWN ((uint32_t)0x80000000)
195#define EMAC_DMARXDESC_AFM ((uint32_t)0x40000000)
196#define EMAC_DMARXDESC_FL ((uint32_t)0x3FFF0000)
197#define EMAC_DMARXDESC_ES ((uint32_t)0x00008000)
198#define EMAC_DMARXDESC_DE ((uint32_t)0x00004000)
199#define EMAC_DMARXDESC_SAF ((uint32_t)0x00002000)
200#define EMAC_DMARXDESC_LE ((uint32_t)0x00001000)
201#define EMAC_DMARXDESC_OE ((uint32_t)0x00000800)
202#define EMAC_DMARXDESC_VLAN ((uint32_t)0x00000400)
203#define EMAC_DMARXDESC_FS ((uint32_t)0x00000200)
204#define EMAC_DMARXDESC_LS ((uint32_t)0x00000100)
205#define EMAC_DMARXDESC_IPV4HCE ((uint32_t)0x00000080)
206#define EMAC_DMARXDESC_LC ((uint32_t)0x00000040)
207#define EMAC_DMARXDESC_FT ((uint32_t)0x00000020)
208#define EMAC_DMARXDESC_RWT ((uint32_t)0x00000010)
209#define EMAC_DMARXDESC_RE ((uint32_t)0x00000008)
210#define EMAC_DMARXDESC_DBE ((uint32_t)0x00000004)
211#define EMAC_DMARXDESC_CE ((uint32_t)0x00000002)
212#define EMAC_DMARXDESC_MAMPCE ((uint32_t)0x00000001)
223#define EMAC_DMARXDESC_DIC ((uint32_t)0x80000000)
224#define EMAC_DMARXDESC_RBS2 ((uint32_t)0x1FFF0000)
225#define EMAC_DMARXDESC_RER ((uint32_t)0x00008000)
226#define EMAC_DMARXDESC_RCH ((uint32_t)0x00004000)
227#define EMAC_DMARXDESC_RBS1 ((uint32_t)0x00001FFF)
238#define EMAC_DMARXDESC_B1AP ((uint32_t)0xFFFFFFFF)
249#define EMAC_DMARXDESC_B2AP ((uint32_t)0xFFFFFFFF)
258#define EMAC_DMA_TI_FLAG ((uint32_t)0x00000001)
259#define EMAC_DMA_TPS_FLAG ((uint32_t)0x00000002)
260#define EMAC_DMA_TBU_FLAG ((uint32_t)0x00000004)
261#define EMAC_DMA_TJT_FLAG ((uint32_t)0x00000008)
262#define EMAC_DMA_OVF_FLAG ((uint32_t)0x00000010)
263#define EMAC_DMA_UNF_FLAG ((uint32_t)0x00000020)
264#define EMAC_DMA_RI_FLAG ((uint32_t)0x00000040)
265#define EMAC_DMA_RBU_FLAG ((uint32_t)0x00000080)
266#define EMAC_DMA_RPS_FLAG ((uint32_t)0x00000100)
267#define EMAC_DMA_RWT_FLAG ((uint32_t)0x00000200)
268#define EMAC_DMA_ETI_FLAG ((uint32_t)0x00000400)
269#define EMAC_DMA_FBEI_FLAG ((uint32_t)0x00002000)
270#define EMAC_DMA_ERI_FLAG ((uint32_t)0x00004000)
271#define EMAC_DMA_AIS_FLAG ((uint32_t)0x00008000)
272#define EMAC_DMA_NIS_FLAG ((uint32_t)0x00010000)
281typedef enum
282{
283 EMAC_AUTO_NEGOTIATION_OFF = 0x00,
284 EMAC_AUTO_NEGOTIATION_ON = 0x01
285} emac_auto_negotiation_type;
286
290typedef enum
291{
292 EMAC_BACKOFF_LIMIT_0 = 0x00,
293 EMAC_BACKOFF_LIMIT_1 = 0x01,
294 EMAC_BACKOFF_LIMIT_2 = 0x02,
295 EMAC_BACKOFF_LIMIT_3 = 0x03
296} emac_bol_type;
297
301typedef enum
302{
303 EMAC_HALF_DUPLEX = 0x00,
304 EMAC_FULL_DUPLEX = 0x01
305} emac_duplex_type;
306
310typedef enum
311{
312 EMAC_SPEED_10MBPS = 0x00,
313 EMAC_SPEED_100MBPS = 0x01
314} emac_speed_type;
315
319typedef enum
320{
321 EMAC_INTERFRAME_GAP_96BIT = 0x00,
322 EMAC_INTERFRAME_GAP_88BIT = 0x01,
323 EMAC_INTERFRAME_GAP_80BIT = 0x02,
324 EMAC_INTERFRAME_GAP_72BIT = 0x03,
325 EMAC_INTERFRAME_GAP_64BIT = 0x04,
326 EMAC_INTERFRAME_GAP_56BIT = 0x05,
327 EMAC_INTERFRAME_GAP_48BIT = 0x06,
328 EMAC_INTERFRAME_GAP_40BIT = 0x07
329} emac_intergrame_gap_type;
330
334typedef enum
335{
336 EMAC_CLOCK_RANGE_60_TO_100 = 0x00,
337 EMAC_CLOCK_RANGE_100_TO_150 = 0x01,
338 EMAC_CLOCK_RANGE_20_TO_35 = 0x02,
339 EMAC_CLOCK_RANGE_35_TO_60 = 0x03,
340 EMAC_CLOCK_RANGE_150_TO_250 = 0x04,
341 EMAC_CLOCK_RANGE_250_TO_288 = 0x05
342} emac_clock_range_type;
343
347typedef enum
348{
349 EMAC_CONTROL_FRAME_PASSING_NO = 0x00,
350 EMAC_CONTROL_FRAME_PASSING_ALL = 0x02,
351 EMAC_CONTROL_FRAME_PASSING_MATCH = 0x03
352} emac_control_frames_filter_type;
353
357typedef enum
358{
359 EMAC_PAUSE_4_SLOT_TIME = 0x00,
360 EMAC_PAUSE_28_SLOT_TIME = 0x01,
361 EMAC_PAUSE_144_SLOT_TIME = 0x02,
362 EMAC_PAUSE_256_SLOT_TIME = 0x03
363} emac_pause_slot_threshold_type;
364
368typedef enum
369{
370 EMAC_INTERRUPT_PMT_MASK = 0x00,
371 EMAC_INTERRUPT_TST_MASK = 0x01
372} emac_interrupt_mask_type;
373
377typedef enum
378{
379 EMAC_ADDRESS_FILTER_1 = 0x01,
380 EMAC_ADDRESS_FILTER_2 = 0x02,
381 EMAC_ADDRESS_FILTER_3 = 0x03
382} emac_address_type;
383
387typedef enum
388{
389 EMAC_DESTINATION_FILTER = 0x00,
390 EMAC_SOURCE_FILTER = 0x01
391} emac_address_filter_type;
392
396typedef enum
397{
398 EMAC_ADDRESS_MASK_8L0 = 0x01,
399 EMAC_ADDRESS_MASK_15L8 = 0x02,
400 EMAC_ADDRESS_MASK_23L16 = 0x04,
401 EMAC_ADDRESS_MASK_31L24 = 0x08,
402 EMAC_ADDRESS_MASK_7H0 = 0x10,
403 EMAC_ADDRESS_MASK_15H8 = 0x20
404} emac_address_mask_type;
405
409typedef enum
410{
411 EMAC_DMA_1_RX_1_TX = 0x00,
412 EMAC_DMA_2_RX_1_TX = 0x01,
413 EMAC_DMA_3_RX_1_TX = 0x02,
414 EMAC_DMA_4_RX_1_TX = 0x03
415} emac_dma_rx_tx_ratio_type;
416
420typedef enum
421{
422 EMAC_DMA_PBL_1 = 0x01,
423 EMAC_DMA_PBL_2 = 0x02,
424 EMAC_DMA_PBL_4 = 0x04,
425 EMAC_DMA_PBL_8 = 0x08,
426 EMAC_DMA_PBL_16 = 0x10,
427 EMAC_DMA_PBL_32 = 0x20
428} emac_dma_pbl_type;
429
433typedef enum
434{
435 EMAC_DMA_TRANSMIT = 0x00,
436 EMAC_DMA_RECEIVE = 0x01
437} emac_dma_tx_rx_type;
438
442typedef enum
443{
444 EMAC_DMA_RX_RESET_STOP_COMMAND = 0x00,
445 EMAC_DMA_RX_FETCH_DESCRIPTOR = 0x01,
446 EMAC_DMA_RX_WAITING_PACKET = 0x03,
447 EMAC_DMA_RX_DESCRIPTOR_UNAVAILABLE = 0x04,
448 EMAC_DMA_RX_CLOSE_DESCRIPTOR = 0x05,
449 EMAC_DMA_RX_FIFO_TO_HOST = 0x07
450} emac_dma_receive_process_status_type;
451
455typedef enum
456{
457 EMAC_DMA_TX_RESET_STOP_COMMAND = 0x00,
458 EMAC_DMA_TX_FETCH_DESCRIPTOR = 0x01,
459 EMAC_DMA_TX_WAITING_FOR_STATUS = 0x02,
460 EMAC_DMA_TX_HOST_TO_FIFO = 0x03,
461 EMAC_DMA_TX_DESCRIPTOR_UNAVAILABLE = 0x06,
462 EMAC_DMA_TX_CLOSE_DESCRIPTOR = 0x07
463} emac_dma_transmit_process_status_type;
464
468typedef enum
469{
470 EMAC_DMA_OPS_START_STOP_RECEIVE = 0x00,
471 EMAC_DMA_OPS_SECOND_FRAME = 0x01,
472 EMAC_DMA_OPS_FORWARD_UNDERSIZED = 0x02,
473 EMAC_DMA_OPS_FORWARD_ERROR = 0x03,
474 EMAC_DMA_OPS_START_STOP_TRANSMIT = 0x04,
475 EMAC_DMA_OPS_FLUSH_TRANSMIT_FIFO = 0x05,
476 EMAC_DMA_OPS_TRANSMIT_STORE_FORWARD = 0x06,
477 EMAC_DMA_OPS_RECEIVE_FLUSH_DISABLE = 0x07,
478 EMAC_DMA_OPS_RECEIVE_STORE_FORWARD = 0x08,
479 EMAC_DMA_OPS_DROP_ERROR_DISABLE = 0x09
480} emac_dma_operations_type;
481
485typedef enum
486{
487 EMAC_DMA_RX_THRESHOLD_64_BYTES = 0x00,
488 EMAC_DMA_RX_THRESHOLD_32_BYTES = 0x01,
489 EMAC_DMA_RX_THRESHOLD_96_BYTES = 0x02,
490 EMAC_DMA_RX_THRESHOLD_128_BYTES = 0x03
491} emac_dma_receive_threshold_type;
492
496typedef enum
497{
498 EMAC_DMA_TX_THRESHOLD_64_BYTES = 0x00,
499 EMAC_DMA_TX_THRESHOLD_128_BYTES = 0x01,
500 EMAC_DMA_TX_THRESHOLD_192_BYTES = 0x02,
501 EMAC_DMA_TX_THRESHOLD_256_BYTES = 0x03,
502 EMAC_DMA_TX_THRESHOLD_40_BYTES = 0x04,
503 EMAC_DMA_TX_THRESHOLD_32_BYTES = 0x05,
504 EMAC_DMA_TX_THRESHOLD_24_BYTES = 0x06,
505 EMAC_DMA_TX_THRESHOLD_16_BYTES = 0x07
506} emac_dma_transmit_threshold_type;
507
511typedef enum
512{
513 EMAC_DMA_INTERRUPT_TX = 0x00,
514 EMAC_DMA_INTERRUPT_TX_STOP = 0x01,
515 EMAC_DMA_INTERRUPT_TX_UNAVAILABLE = 0x02,
516 EMAC_DMA_INTERRUPT_TX_JABBER = 0x03,
517 EMAC_DMA_INTERRUPT_RX_OVERFLOW = 0x04,
518 EMAC_DMA_INTERRUPT_TX_UNDERFLOW = 0x05,
519 EMAC_DMA_INTERRUPT_RX = 0x06,
520 EMAC_DMA_INTERRUPT_RX_UNAVAILABLE = 0x07,
521 EMAC_DMA_INTERRUPT_RX_STOP = 0x08,
522 EMAC_DMA_INTERRUPT_RX_TIMEOUT = 0x09,
523 EMAC_DMA_INTERRUPT_TX_EARLY = 0x0A,
524 EMAC_DMA_INTERRUPT_FATAL_BUS_ERROR = 0x0B,
525 EMAC_DMA_INTERRUPT_RX_EARLY = 0x0C,
526 EMAC_DMA_INTERRUPT_ABNORMAL_SUMMARY = 0x0D,
527 EMAC_DMA_INTERRUPT_NORMAL_SUMMARY = 0x0E
528} emac_dma_interrupt_type;
529
533typedef enum
534{
535 EMAC_DMA_TX_DESCRIPTOR = 0x00,
536 EMAC_DMA_RX_DESCRIPTOR = 0x01,
537 EMAC_DMA_TX_BUFFER = 0x02,
538 EMAC_DMA_RX_BUFFER = 0x03
539} emac_dma_transfer_address_type;
540
544typedef enum
545{
546 EMAC_PTP_NORMAL_CLOCK = 0x00,
547 EMAC_PTP_BOUNDARY_CLOCK = 0x01,
548 EMAC_PTP_END_TO_END_CLOCK = 0x02,
549 EMAC_PTP_PEER_TO_PEER_CLOCK = 0x03
550} emac_ptp_clock_node_type;
551
555typedef enum
556{
557 EMAC_PTP_SECOND_OVERFLOW = 0x00,
558 EMAC_PTP_TARGET_TIME_REACH = 0x01
559} emac_ptp_timestamp_status_type;
560
564typedef enum
565{
566 EMAC_PTP_PPS_1HZ = 0x00,
567 EMAC_PTP_PPS_2HZ = 0x01,
568 EMAC_PTP_PPS_4HZ = 0x02,
569 EMAC_PTP_PPS_8HZ = 0x03,
570 EMAC_PTP_PPS_16HZ = 0x04,
571 EMAC_PTP_PPS_32HZ = 0x05,
572 EMAC_PTP_PPS_64HZ = 0x06,
573 EMAC_PTP_PPS_128HZ = 0x07,
574 EMAC_PTP_PPS_256HZ = 0x08,
575 EMAC_PTP_PPS_512HZ = 0x09,
576 EMAC_PTP_PPS_1024HZ = 0x0A,
577 EMAC_PTP_PPS_2048HZ = 0x0B,
578 EMAC_PTP_PPS_4096HZ = 0x0C,
579 EMAC_PTP_PPS_8192HZ = 0x0D,
580 EMAC_PTP_PPS_16384HZ = 0x0E,
581 EMAC_PTP_PPS_32768HZ = 0x0F
582} emac_ptp_pps_control_type;
583
587typedef struct
588{
589 emac_auto_negotiation_type auto_nego;
590 confirm_state deferral_check;
591 emac_bol_type back_off_limit;
592 confirm_state auto_pad_crc_strip;
593 confirm_state retry_disable;
594 confirm_state ipv4_checksum_offload;
595 emac_duplex_type duplex_mode;
596 confirm_state loopback_mode;
597 confirm_state receive_own_disable;
598 emac_speed_type fast_ethernet_speed;
599 confirm_state carrier_sense_disable;
600 emac_intergrame_gap_type interframe_gap;
601 confirm_state jabber_disable;
602 confirm_state watchdog_disable;
603} emac_control_config_type;
604
608typedef struct
609{
610 confirm_state aab_enable;
611 confirm_state usp_enable;
612 emac_dma_pbl_type rx_dma_pal;
613 confirm_state fb_enable;
614 emac_dma_pbl_type tx_dma_pal;
615 uint8_t desc_skip_length;
616 confirm_state da_enable;
617 emac_dma_rx_tx_ratio_type priority_ratio;
618 confirm_state dt_disable;
619 confirm_state rsf_enable;
620 confirm_state flush_rx_disable;
621 confirm_state tsf_enable;
622 emac_dma_transmit_threshold_type tx_threshold;
623 confirm_state fef_enable;
624 confirm_state fugf_enable;
625 emac_dma_receive_threshold_type rx_threshold;
626 confirm_state osf_enable;
627} emac_dma_config_type;
628
632typedef struct {
633 uint32_t status;
634 uint32_t controlsize;
635 uint32_t buf1addr;
636 uint32_t buf2nextdescaddr;
637} emac_dma_desc_type;
638
642typedef struct
643{
647 union
648 {
649 __IO uint32_t ctrl;
650 struct
651 {
652 __IO uint32_t reserved1 : 2; /* [0:1] */
653 __IO uint32_t re : 1; /* [2] */
654 __IO uint32_t te : 1; /* [3] */
655 __IO uint32_t dc : 1; /* [4] */
656 __IO uint32_t bl : 2; /* [5:6] */
657 __IO uint32_t acs : 1; /* [7] */
658 __IO uint32_t reserved2 : 1; /* [8] */
659 __IO uint32_t dr : 1; /* [9] */
660 __IO uint32_t ipc : 1; /* [10] */
661 __IO uint32_t dm : 1; /* [11] */
662 __IO uint32_t lm : 1; /* [12] */
663 __IO uint32_t dro : 1; /* [13] */
664 __IO uint32_t fes : 1; /* [14] */
665 __IO uint32_t reserved3 : 1; /* [15] */
666 __IO uint32_t dcs : 1; /* [16] */
667 __IO uint32_t ifg : 3; /* [17:19] */
668 __IO uint32_t reserved4 : 2; /* [20:21] */
669 __IO uint32_t jd : 1; /* [22] */
670 __IO uint32_t wd : 1; /* [23] */
671 __IO uint32_t reserved5 : 8; /* [24:31] */
672 } ctrl_bit;
673 };
674
678 union
679 {
680 __IO uint32_t frmf;
681 struct
682 {
683 __IO uint32_t pr : 1; /* [0] */
684 __IO uint32_t huc : 1; /* [1] */
685 __IO uint32_t hmc : 1; /* [2] */
686 __IO uint32_t daif : 1; /* [3] */
687 __IO uint32_t pmc : 1; /* [4] */
688 __IO uint32_t dbf : 1; /* [5] */
689 __IO uint32_t pcf : 2; /* [6:7] */
690 __IO uint32_t saif : 1; /* [8] */
691 __IO uint32_t saf : 1; /* [9] */
692 __IO uint32_t hpf : 1; /* [10] */
693 __IO uint32_t reserved1 : 20;/* [11:30] */
694 __IO uint32_t ra : 1; /* [31] */
695 } frmf_bit;
696 };
697
701 union
702 {
703 __IO uint32_t hth;
704 struct
705 {
706 __IO uint32_t hth : 32; /* [0:31] */
707 } hth_bit;
708 };
709
713 union
714 {
715 __IO uint32_t htl;
716 struct
717 {
718 __IO uint32_t htl : 32; /* [0:31] */
719 } htl_bit;
720 };
721
725 union
726 {
727 __IO uint32_t miiaddr;
728 struct
729 {
730 __IO uint32_t mb : 1; /* [0] */
731 __IO uint32_t mw : 1; /* [1] */
732 __IO uint32_t cr : 4; /* [2:5] */
733 __IO uint32_t mii : 5; /* [6:10] */
734 __IO uint32_t pa : 5; /* [11:15] */
735 __IO uint32_t reserved1 : 16;/* [16:31] */
736 } miiaddr_bit;
737 };
738
742 union
743 {
744 __IO uint32_t miidt;
745 struct
746 {
747 __IO uint32_t md : 16;/* [0:15] */
748 __IO uint32_t reserved1 : 16;/* [16:31] */
749 } miidt_bit;
750 };
751
755 union
756 {
757 __IO uint32_t fctrl;
758 struct
759 {
760 __IO uint32_t fcbbpa : 1; /* [0] */
761 __IO uint32_t etf : 1; /* [1] */
762 __IO uint32_t erf : 1; /* [2] */
763 __IO uint32_t dup : 1; /* [3] */
764 __IO uint32_t plt : 2; /* [4:5] */
765 __IO uint32_t reserved1 : 1; /* [6] */
766 __IO uint32_t dzqp : 1; /* [7] */
767 __IO uint32_t reserved2 : 8; /* [8:15] */
768 __IO uint32_t pt : 16;/* [16:31] */
769 } fctrl_bit;
770 };
771
775 union
776 {
777 __IO uint32_t vlt;
778 struct
779 {
780 __IO uint32_t vti : 16;/* [0:15] */
781 __IO uint32_t etv : 1; /* [16] */
782 __IO uint32_t reserved1 : 15;/* [17:31] */
783 } vlt_bit;
784 };
785
789 __IO uint32_t reserved1[2];
790
794 __IO uint32_t rwff;
795
799 union
800 {
801 __IO uint32_t pmtctrlsts;
802 struct
803 {
804 __IO uint32_t pd : 1; /* [0] */
805 __IO uint32_t emp : 1; /* [1] */
806 __IO uint32_t erwf : 1; /* [2] */
807 __IO uint32_t reserved1 : 2; /* [3:4] */
808 __IO uint32_t rmp : 1; /* [5] */
809 __IO uint32_t rrwf : 1; /* [6] */
810 __IO uint32_t reserved2 : 2; /* [7:8] */
811 __IO uint32_t guc : 1; /* [9] */
812 __IO uint32_t reserved3 : 21;/* [10:30] */
813 __IO uint32_t rwffpr : 1; /* [31] */
814 } pmtctrlsts_bit;
815 };
816
820 __IO uint32_t reserved2[2];
821
825 union
826 {
827 __IO uint32_t ists;
828 struct
829 {
830 __IO uint32_t reserved1 : 3; /* [0:2] */
831 __IO uint32_t pis : 1; /* [3] */
832 __IO uint32_t mis : 1; /* [4] */
833 __IO uint32_t mris : 1; /* [5] */
834 __IO uint32_t mtis : 1; /* [6] */
835 __IO uint32_t reserved2 : 2; /* [7:8] */
836 __IO uint32_t tis : 1; /* [9] */
837 __IO uint32_t reserved3 : 22;/* [10:31] */
838 } ists_bit;
839 };
840
844 union
845 {
846 __IO uint32_t imr;
847 struct
848 {
849 __IO uint32_t reserved1 : 3; /* [0:2] */
850 __IO uint32_t pim : 1; /* [3] */
851 __IO uint32_t reserved2 : 5; /* [4:8] */
852 __IO uint32_t tim : 1; /* [9] */
853 __IO uint32_t reserved3 : 22;/* [10:31] */
854 } imr_bit;
855 };
856
860 union
861 {
862 __IO uint32_t a0h;
863 struct
864 {
865 __IO uint32_t ma0h : 16;/* [0:15] */
866 __IO uint32_t reserved1 : 15;/* [16:30] */
867 __IO uint32_t ae : 1; /* [31] */
868 } a0h_bit;
869 };
870
874 union
875 {
876 __IO uint32_t a0l;
877 struct
878 {
879 __IO uint32_t ma0l : 32;/* [0:31] */
880 } a0l_bit;
881 };
882
886 union
887 {
888 __IO uint32_t a1h;
889 struct
890 {
891 __IO uint32_t ma1h : 16;/* [0:15] */
892 __IO uint32_t reserved1 : 8; /* [16:23] */
893 __IO uint32_t mbc : 6; /* [24:29] */
894 __IO uint32_t sa : 1; /* [30] */
895 __IO uint32_t ae : 1; /* [31] */
896 } a1h_bit;
897 };
898
902 union
903 {
904 __IO uint32_t a1l;
905 struct
906 {
907 __IO uint32_t ma1l : 32;/* [0:31] */
908 } a1l_bit;
909 };
910
914 union
915 {
916 __IO uint32_t a2h;
917 struct
918 {
919 __IO uint32_t ma2h : 16;/* [0:15] */
920 __IO uint32_t reserved1 : 8; /* [16:23] */
921 __IO uint32_t mbc : 6; /* [24:29] */
922 __IO uint32_t sa : 1; /* [30] */
923 __IO uint32_t ae : 1; /* [31] */
924 } a2h_bit;
925 };
926
930 union
931 {
932 __IO uint32_t a2l;
933 struct
934 {
935 __IO uint32_t ma2l : 32;/* [0:31] */
936 } a2l_bit;
937 };
938
942 union
943 {
944 __IO uint32_t a3h;
945 struct
946 {
947 __IO uint32_t ma3h : 16;/* [0:15] */
948 __IO uint32_t reserved1 : 8; /* [16:23] */
949 __IO uint32_t mbc : 6; /* [24:29] */
950 __IO uint32_t sa : 1; /* [30] */
951 __IO uint32_t ae : 1; /* [31] */
952 } a3h_bit;
953 };
954
958 union
959 {
960 __IO uint32_t a3l;
961 struct
962 {
963 __IO uint32_t ma3l : 32;/* [0:31] */
964 } a3l_bit;
965 };
966} emac_type;
967
971typedef struct
972{
976 union
977 {
978 __IO uint32_t ctrl;
979 struct
980 {
981 __IO uint32_t rc : 1; /* [0] */
982 __IO uint32_t scr : 1; /* [1] */
983 __IO uint32_t rr : 1; /* [2] */
984 __IO uint32_t fmc : 1; /* [3] */
985 __IO uint32_t reserved1 : 28;/* [4:31] */
986 } ctrl_bit;
987 };
988
992 union
993 {
994 __IO uint32_t ri;
995 struct
996 {
997 __IO uint32_t reserved1 : 5; /* [0:4] */
998 __IO uint32_t rfce : 1; /* [5] */
999 __IO uint32_t rfae : 1; /* [6] */
1000 __IO uint32_t reserved2 : 10;/* [7:16] */
1001 __IO uint32_t rguf : 1; /* [17] */
1002 __IO uint32_t reserved3 : 14;/* [18:31] */
1003 } ri_bit;
1004 };
1005
1009 union
1010 {
1011 __IO uint32_t ti;
1012 struct
1013 {
1014 __IO uint32_t reserved1 : 14;/* [0:13] */
1015 __IO uint32_t tscgfci : 1; /* [14] */
1016 __IO uint32_t tgfmsc : 1; /* [15] */
1017 __IO uint32_t reserved2 : 5; /* [16:20] */
1018 __IO uint32_t tgf : 1; /* [21] */
1019 __IO uint32_t reserved3 : 10;/* [22:31] */
1020 } ti_bit;
1021 };
1022
1026 union
1027 {
1028 __IO uint32_t rim;
1029 struct
1030 {
1031 __IO uint32_t reserved1 : 5; /* [0:4] */
1032 __IO uint32_t rcefcim : 1; /* [5] */
1033 __IO uint32_t raefacim : 1; /* [6] */
1034 __IO uint32_t reserved2 : 10;/* [7:16] */
1035 __IO uint32_t rugfcim : 1; /* [17] */
1036 __IO uint32_t reserved3 : 14;/* [18:31] */
1037 } rim_bit;
1038 };
1039
1043 union
1044 {
1045 __IO uint32_t tim;
1046 struct
1047 {
1048 __IO uint32_t reserved1 : 14;/* [0:13] */
1049 __IO uint32_t tscgfcim : 1; /* [14] */
1050 __IO uint32_t tmcgfcim : 1; /* [15] */
1051 __IO uint32_t reserved2 : 5; /* [16:20] */
1052 __IO uint32_t tgfcim : 1; /* [21] */
1053 __IO uint32_t reserved3 : 10;/* [22:31] */
1054 } tim_bit;
1055 };
1056
1060 __IO uint32_t reserved1[14];
1061
1065 union
1066 {
1067 __IO uint32_t tfscc;
1068 struct
1069 {
1070 __IO uint32_t tgfscc : 32;/* [0:31] */
1071 } tfscc_bit;
1072 };
1073
1077 union
1078 {
1079 __IO uint32_t tfmscc;
1080 struct
1081 {
1082 __IO uint32_t tgfmscc : 32;/* [0:31] */
1083 } tfmscc_bit;
1084 };
1085
1089 __IO uint32_t reserved2[5];
1090
1094 union
1095 {
1096 __IO uint32_t tfcnt;
1097 struct
1098 {
1099 __IO uint32_t tgfc : 32;/* [0:31] */
1100 } tfcnt_bit;
1101 };
1102
1106 __IO uint32_t reserved3[10];
1107
1111 union
1112 {
1113 __IO uint32_t rfcecnt;
1114 struct
1115 {
1116 __IO uint32_t rfcec : 32;/* [0:31] */
1117 } rfcecnt_bit;
1118 };
1119
1123 union
1124 {
1125 __IO uint32_t rfaecnt;
1126 struct
1127 {
1128 __IO uint32_t rfaec : 32;/* [0:31] */
1129 } rfaecnt_bit;
1130 };
1131
1135 __IO uint32_t reserved4[10];
1136
1140 union
1141 {
1142 __IO uint32_t rgufcnt;
1143 struct
1144 {
1145 __IO uint32_t rgufc : 32;/* [0:31] */
1146 } rgufcnt_bit;
1147 };
1148} emac_mmc_type;
1149
1153typedef struct
1154{
1158 union
1159 {
1160 __IO uint32_t tsctrl;
1161 struct
1162 {
1163 __IO uint32_t te : 1; /* [0] */
1164 __IO uint32_t tfcu : 1; /* [1] */
1165 __IO uint32_t ti : 1; /* [2] */
1166 __IO uint32_t tu : 1; /* [3] */
1167 __IO uint32_t tite : 1; /* [4] */
1168 __IO uint32_t aru : 1; /* [5] */
1169 __IO uint32_t reserved1 : 2; /* [6:7] */
1170 __IO uint32_t etaf : 1; /* [8] */
1171 __IO uint32_t tdbrc : 1; /* [9] */
1172 __IO uint32_t eppv2f : 1; /* [10] */
1173 __IO uint32_t eppef : 1; /* [11] */
1174 __IO uint32_t eppfsip6u : 1; /* [12] */
1175 __IO uint32_t eppfsip4u : 1; /* [13] */
1176 __IO uint32_t etsfem : 1; /* [14] */
1177 __IO uint32_t esfmrtm : 1; /* [15] */
1178 __IO uint32_t sppfts : 2; /* [16:17] */
1179 __IO uint32_t emafpff : 1; /* [18] */
1180 __IO uint32_t reserved2 : 13;/* [19:31] */
1181 } tsctrl_bit;
1182 };
1183
1187 union
1188 {
1189 __IO uint32_t ssinc;
1190 struct
1191 {
1192 __IO uint32_t ssiv : 8; /* [0] */
1193 __IO uint32_t reserved1 : 24;/* [8:31] */
1194 } ssinc_bit;
1195 };
1196
1200 union
1201 {
1202 __IO uint32_t tsh;
1203 struct
1204 {
1205 __IO uint32_t ts : 32;/* [0:31] */
1206 } tsh_bit;
1207 };
1208
1212 union
1213 {
1214 __IO uint32_t tsl;
1215 struct
1216 {
1217 __IO uint32_t tss : 31;/* [0:30] */
1218 __IO uint32_t ast : 1; /* [31] */
1219 } tsl_bit;
1220 };
1221
1225 union
1226 {
1227 __IO uint32_t tshud;
1228 struct
1229 {
1230 __IO uint32_t ts : 32;/* [0:31] */
1231 } tshud_bit;
1232 };
1233
1237 union
1238 {
1239 __IO uint32_t tslud;
1240 struct
1241 {
1242 __IO uint32_t tss : 31;/* [0:30] */
1243 __IO uint32_t ast : 1; /* [31] */
1244 } tslud_bit;
1245 };
1246
1250 union
1251 {
1252 __IO uint32_t tsad;
1253 struct
1254 {
1255 __IO uint32_t tar : 32;/* [0:31] */
1256 } tsad_bit;
1257 };
1258
1262 union
1263 {
1264 __IO uint32_t tth;
1265 struct
1266 {
1267 __IO uint32_t ttsr : 32;/* [0:31] */
1268 } tth_bit;
1269 };
1270
1274 union
1275 {
1276 __IO uint32_t ttl;
1277 struct
1278 {
1279 __IO uint32_t ttlr : 32;/* [0:31] */
1280 } ttl_bit;
1281 };
1282
1286 __IO uint32_t reserved1;
1287
1291 union
1292 {
1293 __IO uint32_t tssr;
1294 struct
1295 {
1296 __IO uint32_t tso : 1; /* [0] */
1297 __IO uint32_t tttr : 1; /* [1] */
1298 __IO uint32_t reserved1 : 30;/* [2:31] */
1299 } tssr_bit;
1300 };
1301
1305 union
1306 {
1307 __IO uint32_t ppscr;
1308 struct
1309 {
1310 __IO uint32_t pofc : 4; /* [0:3] */
1311 __IO uint32_t reserved1 : 28;/* [4:31] */
1312 } ppscr_bit;
1313 };
1314} emac_ptp_type;
1315
1319typedef struct
1320{
1324 union
1325 {
1326 __IO uint32_t bm;
1327 struct
1328 {
1329 __IO uint32_t swr : 1; /* [0] */
1330 __IO uint32_t da : 1; /* [1] */
1331 __IO uint32_t dsl : 5; /* [2:6] */
1332 __IO uint32_t reserved1 : 1; /* [7] */
1333 __IO uint32_t pbl : 6; /* [8:13] */
1334 __IO uint32_t pr : 2; /* [14:15] */
1335 __IO uint32_t fb : 1; /* [16] */
1336 __IO uint32_t rdp : 6; /* [17:22] */
1337 __IO uint32_t usp : 1; /* [23] */
1338 __IO uint32_t pblx8 : 1; /* [24] */
1339 __IO uint32_t aab : 1; /* [25] */
1340 __IO uint32_t reserved2 : 6; /* [26:31] */
1341 } bm_bit;
1342 };
1343
1347 union
1348 {
1349 __IO uint32_t tpd;
1350 struct
1351 {
1352 __IO uint32_t tpd : 32; /* [0:31] */
1353 } tpd_bit;
1354 };
1355
1359 union
1360 {
1361 __IO uint32_t rpd;
1362 struct
1363 {
1364 __IO uint32_t rpd : 32; /* [0:31] */
1365 } rpd_bit;
1366 };
1367
1371 union
1372 {
1373 __IO uint32_t rdladdr;
1374 struct
1375 {
1376 __IO uint32_t srl : 32; /* [0:31] */
1377 } rdladdr_bit;
1378 };
1379
1383 union
1384 {
1385 __IO uint32_t tdladdr;
1386 struct
1387 {
1388 __IO uint32_t stl : 32; /* [0:31] */
1389 } tdladdr_bit;
1390 };
1391
1395 union
1396 {
1397 __IO uint32_t sts;
1398 struct
1399 {
1400 __IO uint32_t ti : 1; /* [0] */
1401 __IO uint32_t tps : 1; /* [1] */
1402 __IO uint32_t tbu : 1; /* [2] */
1403 __IO uint32_t tjt : 1; /* [3] */
1404 __IO uint32_t ovf : 1; /* [4] */
1405 __IO uint32_t unf : 1; /* [5] */
1406 __IO uint32_t ri : 1; /* [6] */
1407 __IO uint32_t rbu : 1; /* [7] */
1408 __IO uint32_t rps : 1; /* [8] */
1409 __IO uint32_t rwt : 1; /* [9] */
1410 __IO uint32_t eti : 1; /* [10] */
1411 __IO uint32_t reserved1 : 2; /* [11:12] */
1412 __IO uint32_t fbei : 1; /* [13] */
1413 __IO uint32_t eri : 1; /* [14] */
1414 __IO uint32_t ais : 1; /* [15] */
1415 __IO uint32_t nis : 1; /* [16] */
1416 __IO uint32_t rs : 3; /* [17:19] */
1417 __IO uint32_t ts : 3; /* [20:22] */
1418 __IO uint32_t eb : 3; /* [23:25] */
1419 __IO uint32_t reserved2 : 1; /* [26] */
1420 __IO uint32_t mmi : 1; /* [27] */
1421 __IO uint32_t mpi : 1; /* [28] */
1422 __IO uint32_t tti : 1; /* [29] */
1423 __IO uint32_t reserved3 : 2; /* [30:31] */
1424 } sts_bit;
1425 };
1426
1430 union
1431 {
1432 __IO uint32_t opm;
1433 struct
1434 {
1435 __IO uint32_t reserved1 : 1; /* [0] */
1436 __IO uint32_t ssr : 1; /* [1] */
1437 __IO uint32_t osf : 1; /* [2] */
1438 __IO uint32_t rtc : 2; /* [3:4] */
1439 __IO uint32_t reserved2 : 1; /* [5] */
1440 __IO uint32_t fugf : 1; /* [6] */
1441 __IO uint32_t fef : 1; /* [7] */
1442 __IO uint32_t reserved3 : 5; /* [8:12] */
1443 __IO uint32_t sstc : 1; /* [13] */
1444 __IO uint32_t ttc : 3; /* [14:16] */
1445 __IO uint32_t reserved4 : 3; /* [17:19] */
1446 __IO uint32_t ftf : 1; /* [20] */
1447 __IO uint32_t tsf : 1; /* [21] */
1448 __IO uint32_t reserved5 : 2; /* [22:23] */
1449 __IO uint32_t dfrf : 1; /* [24] */
1450 __IO uint32_t rsf : 1; /* [25] */
1451 __IO uint32_t dt : 1; /* [26] */
1452 __IO uint32_t reserved6 : 5; /* [27:31] */
1453 } opm_bit;
1454 };
1455
1459 union
1460 {
1461 __IO uint32_t ie;
1462 struct
1463 {
1464 __IO uint32_t tie : 1; /* [0] */
1465 __IO uint32_t tse : 1; /* [1] */
1466 __IO uint32_t tue : 1; /* [2] */
1467 __IO uint32_t tje : 1; /* [3] */
1468 __IO uint32_t ove : 1; /* [4] */
1469 __IO uint32_t une : 1; /* [5] */
1470 __IO uint32_t rie : 1; /* [6] */
1471 __IO uint32_t rbue : 1; /* [7] */
1472 __IO uint32_t rse : 1; /* [8] */
1473 __IO uint32_t rwte : 1; /* [9] */
1474 __IO uint32_t eie : 1; /* [10] */
1475 __IO uint32_t reserved1 : 2; /* [11:12] */
1476 __IO uint32_t fbee : 1; /* [13] */
1477 __IO uint32_t ere : 1; /* [14] */
1478 __IO uint32_t aie : 1; /* [15] */
1479 __IO uint32_t nie : 1; /* [16] */
1480 __IO uint32_t reserved2 : 15;/* [17:31] */
1481 } ie_bit;
1482 };
1483
1487 union
1488 {
1489 __IO uint32_t mfbocnt;
1490 struct
1491 {
1492 __IO uint32_t mfc : 16;/* [0:15] */
1493 __IO uint32_t obmfc : 1; /* [16] */
1494 __IO uint32_t ofc : 11;/* [17:27] */
1495 __IO uint32_t obfoc : 1; /* [28] */
1496 __IO uint32_t reserved1 : 3; /* [29:31] */
1497 } mfbocnt_bit;
1498 };
1499
1503 __IO uint32_t reserved1[9];
1504
1508 union
1509 {
1510 __IO uint32_t ctd;
1511 struct
1512 {
1513 __IO uint32_t htdap : 32;/* [0:31] */
1514 } ctd_bit;
1515 };
1516
1520 union
1521 {
1522 __IO uint32_t crd;
1523 struct
1524 {
1525 __IO uint32_t hrdap : 32;/* [0:31] */
1526 } crd_bit;
1527 };
1528
1532 union
1533 {
1534 __IO uint32_t ctbaddr;
1535 struct
1536 {
1537 __IO uint32_t htbap : 32;/* [0:31] */
1538 } ctbaddr_bit;
1539 };
1540
1544 union
1545 {
1546 __IO uint32_t crbaddr;
1547 struct
1548 {
1549 __IO uint32_t hrbap : 32;/* [0:31] */
1550 } crbaddr_bit;
1551 };
1552} emac_dma_type;
1553
1558#define EMAC ((emac_type *) EMAC_BASE)
1559#define EMAC_MMC ((emac_mmc_type *) EMAC_MMC_BASE)
1560#define EMAC_PTP ((emac_ptp_type *) EMAC_PTP_BASE)
1561#define EMAC_DMA ((emac_dma_type *) EMAC_DMA_BASE)
1562
1567void emac_reset(void);
1568void emac_clock_range_set(void);
1569void emac_dma_software_reset_set(void);
1570 flag_status emac_dma_software_reset_get(void);
1571void emac_start(void);
1572void emac_stop(void);
1573 error_status emac_phy_register_write(uint8_t address, uint8_t reg, uint16_t data);
1574 error_status emac_phy_register_read(uint8_t address, uint8_t reg, uint16_t *data);
1575void emac_control_para_init(emac_control_config_type *control_para);
1576void emac_control_config(emac_control_config_type *control_struct);
1577void emac_receiver_enable(confirm_state new_state);
1578void emac_trasmitter_enable(confirm_state new_state);
1579void emac_deferral_check_set(confirm_state new_state);
1580void emac_backoff_limit_set(emac_bol_type slot_time);
1581void emac_auto_pad_crc_stripping_set(confirm_state new_state);
1582void emac_retry_disable(confirm_state new_state);
1583void emac_ipv4_checksum_offload_set(confirm_state new_state);
1584void emac_loopback_mode_enable(confirm_state new_state);
1585void emac_receive_own_disable(confirm_state new_state);
1586void emac_carrier_sense_disable(confirm_state new_state);
1587void emac_interframe_gap_set(emac_intergrame_gap_type number);
1588void emac_jabber_disable(confirm_state new_state);
1589void emac_watchdog_disable(confirm_state new_state);
1590void emac_fast_speed_set(emac_speed_type speed);
1591void emac_duplex_mode_set(emac_duplex_type duplex_mode);
1592void emac_promiscuous_mode_set(confirm_state new_state);
1593void emac_hash_unicast_set(confirm_state new_state);
1594void emac_hash_multicast_set(confirm_state new_state);
1595void emac_dstaddr_inverse_filter_set(confirm_state new_state);
1596void emac_pass_all_multicasting_set(confirm_state new_state);
1597void emac_broadcast_frames_disable(confirm_state new_state);
1598void emac_pass_control_frames_set(emac_control_frames_filter_type condition);
1599void emac_srcaddr_inverse_filter_set(confirm_state new_state);
1600void emac_srcaddr_filter_set(confirm_state new_state);
1601void emac_hash_perfect_filter_set(confirm_state new_state);
1602void emac_receive_all_set(confirm_state new_state);
1603void emac_hash_table_high32bits_set(uint32_t high32bits);
1604void emac_hash_table_low32bits_set(uint32_t low32bits);
1605 flag_status emac_mii_busy_get(void);
1606void emac_mii_write(confirm_state new_state);
1607void emac_fcb_bpa_set(confirm_state new_state);
1608void emac_transmit_flow_control_enable(confirm_state new_state);
1609void emac_receive_flow_control_enable(confirm_state new_state);
1610void emac_unicast_pause_frame_detect(confirm_state new_state);
1611void emac_pause_low_threshold_set(emac_pause_slot_threshold_type pasue_threshold);
1612void emac_zero_quanta_pause_disable(confirm_state new_state);
1613void emac_pause_time_set(uint16_t pause_time);
1614void emac_vlan_tag_identifier_set(uint16_t identifier);
1615void emac_vlan_tag_comparison_set(confirm_state new_state);
1616void emac_wakeup_frame_set(uint32_t value);
1617uint32_t emac_wakeup_frame_get(void);
1618void emac_power_down_set(confirm_state new_state);
1619void emac_magic_packet_enable(confirm_state new_state);
1620void emac_wakeup_frame_enable(confirm_state new_state);
1621 flag_status emac_received_magic_packet_get(void);
1622 flag_status emac_received_wakeup_frame_get(void);
1623void emac_global_unicast_set(confirm_state new_state);
1624void emac_wakeup_frame_filter_reset(confirm_state new_state);
1625 flag_status emac_interrupt_status_read(uint32_t flag);
1626void emac_interrupt_mask_set(emac_interrupt_mask_type mask_type, confirm_state new_state);
1627void emac_local_address_set(uint8_t *address);
1628void emac_address_filter_set(emac_address_type mac, emac_address_filter_type filter, emac_address_mask_type mask_bit, confirm_state new_state);
1629uint32_t emac_received_packet_size_get(void);
1630uint32_t emac_dmarxdesc_frame_length_get(emac_dma_desc_type *dma_rx_desc);
1631void emac_dma_descriptor_list_address_set(emac_dma_tx_rx_type transfer_type, emac_dma_desc_type *dma_desc_tab, uint8_t *buff, uint32_t buffer_count);
1632uint32_t emac_dma_descriptor_list_address_get(emac_dma_tx_rx_type transfer_type);
1633void emac_dma_rx_desc_interrupt_config(emac_dma_desc_type *dma_rx_desc, confirm_state new_state);
1634void emac_dma_para_init(emac_dma_config_type *control_para);
1635void emac_dma_config(emac_dma_config_type *control_para);
1636void emac_dma_arbitation_set(emac_dma_rx_tx_ratio_type ratio, confirm_state new_state);
1637void emac_dma_descriptor_skip_length_set(uint8_t length);
1638void emac_dma_separate_pbl_set(emac_dma_pbl_type tx_length, emac_dma_pbl_type rx_length, confirm_state new_state);
1639void emac_dma_eight_pbl_mode_set(confirm_state new_state);
1640void emac_dma_address_aligned_beats_set(confirm_state new_state);
1641void emac_dma_poll_demand_set(emac_dma_tx_rx_type transfer_type, uint32_t value);
1642uint32_t emac_dma_poll_demand_get(emac_dma_tx_rx_type transfer_type);
1643 emac_dma_receive_process_status_type emac_dma_receive_status_get(void);
1644 emac_dma_transmit_process_status_type emac_dma_transmit_status_get(void);
1645void emac_dma_operations_set(emac_dma_operations_type ops, confirm_state new_state);
1646void emac_dma_receive_threshold_set(emac_dma_receive_threshold_type value);
1647void emac_dma_transmit_threshold_set(emac_dma_transmit_threshold_type value);
1648void emac_dma_interrupt_enable(emac_dma_interrupt_type it, confirm_state new_state);
1649uint16_t emac_dma_controller_missing_frame_get(void);
1650uint8_t emac_dma_missing_overflow_bit_get(void);
1651uint16_t emac_dma_application_missing_frame_get(void);
1652uint8_t emac_dma_fifo_overflow_bit_get(void);
1653uint32_t emac_dma_tansfer_address_get(emac_dma_transfer_address_type transfer_type);
1654void emac_mmc_counter_reset(void);
1655void emac_mmc_rollover_stop(confirm_state new_state);
1656void emac_mmc_reset_on_read_enable(confirm_state new_state);
1657void emac_mmc_counter_freeze(confirm_state new_state);
1658 flag_status emac_mmc_received_status_get(uint32_t flag);
1659 flag_status emac_mmc_transmit_status_get(uint32_t flag);
1660void emac_mmc_received_interrupt_mask_set(uint32_t flag, confirm_state new_state);
1661void emac_mmc_transmit_interrupt_mask_set(uint32_t flag, confirm_state new_state);
1662uint32_t emac_mmc_transmit_good_frames_get(uint32_t flag);
1663uint32_t emac_mmc_received_error_frames_get(uint32_t flag);
1664void emac_ptp_timestamp_enable(confirm_state new_state);
1665void emac_ptp_timestamp_fine_update_enable(confirm_state new_state);
1666void emac_ptp_timestamp_system_time_init(confirm_state new_state);
1667void emac_ptp_timestamp_system_time_update(confirm_state new_state);
1668void emac_ptp_interrupt_trigger_enable(confirm_state new_state);
1669void emac_ptp_addend_register_update(confirm_state new_state);
1670void emac_ptp_snapshot_received_frames_enable(confirm_state new_state);
1671void emac_ptp_subsecond_rollover_enable(confirm_state new_state);
1672void emac_ptp_psv2_enable(confirm_state new_state);
1673void emac_ptp_snapshot_emac_frames_enable(confirm_state new_state);
1674void emac_ptp_snapshot_ipv6_frames_enable(confirm_state new_state);
1675void emac_ptp_snapshot_ipv4_frames_enable(confirm_state new_state);
1676void emac_ptp_snapshot_event_message_enable(confirm_state new_state);
1677void emac_ptp_snapshot_master_event_enable(confirm_state new_state);
1678void emac_ptp_clock_node_set(emac_ptp_clock_node_type node);
1679void emac_ptp_mac_address_filter_enable(confirm_state new_state);
1680void emac_ptp_subsecond_increment_set(uint8_t value);
1681uint32_t emac_ptp_system_second_get(void);
1682uint32_t emac_ptp_system_subsecond_get(void);
1683 confirm_state emac_ptp_system_time_sign_get(void);
1684void emac_ptp_system_second_set(uint32_t second);
1685void emac_ptp_system_subsecond_set(uint32_t subsecond);
1686void emac_ptp_system_time_sign_set(confirm_state sign);
1687void emac_ptp_timestamp_addend_set(uint32_t value);
1688void emac_ptp_target_second_set(uint32_t value);
1689void emac_ptp_target_nanosecond_set(uint32_t value);
1690 confirm_state emac_ptp_timestamp_status_get(emac_ptp_timestamp_status_type status);
1691void emac_ptp_pps_frequency_set(emac_ptp_pps_control_type freq);
1692 flag_status emac_dma_flag_get(uint32_t dma_flag);
1693void emac_dma_flag_clear(uint32_t dma_flag);
1694
1707#ifdef __cplusplus
1708}
1709#endif
1710
1711#endif
at32f435_437.h
at32f435_437 header file
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
number
uint32_t number
Definition: project/at_start_f435/examples/xmc/nor_flash/src/main.c:44
emac_global_unicast_set
void emac_global_unicast_set(confirm_state new_state)
set unicast frame that passes DAF as wakeup frame.
Definition: at32f435_437_emac.c:811
emac_zero_quanta_pause_disable
void emac_zero_quanta_pause_disable(confirm_state new_state)
set zero-quanta pause disable.
Definition: at32f435_437_emac.c:687
emac_vlan_tag_comparison_set
void emac_vlan_tag_comparison_set(confirm_state new_state)
set 12-bit vlan identifier.
Definition: at32f435_437_emac.c:717
emac_loopback_mode_enable
void emac_loopback_mode_enable(confirm_state new_state)
enable loopback mode.
Definition: at32f435_437_emac.c:378
emac_ptp_system_second_set
void emac_ptp_system_second_set(uint32_t second)
set system time second
Definition: at32f435_437_emac.c:2096
emac_ptp_target_second_set
void emac_ptp_target_second_set(uint32_t value)
set target time stamp high
Definition: at32f435_437_emac.c:2143
emac_dma_fifo_overflow_bit_get
uint8_t emac_dma_fifo_overflow_bit_get(void)
get overflow bit for FIFO overflow counter
Definition: at32f435_437_emac.c:1617
emac_mmc_received_interrupt_mask_set
void emac_mmc_received_interrupt_mask_set(uint32_t flag, confirm_state new_state)
mask received mmc interrupt
Definition: at32f435_437_emac.c:1755
emac_dma_transmit_threshold_set
void emac_dma_transmit_threshold_set(emac_dma_transmit_threshold_type value)
set transmit dma threshold
Definition: at32f435_437_emac.c:1470
emac_hash_unicast_set
void emac_hash_unicast_set(confirm_state new_state)
hash unicast.
Definition: at32f435_437_emac.c:483
emac_auto_pad_crc_stripping_set
void emac_auto_pad_crc_stripping_set(confirm_state new_state)
set mac automatic pad/CRC stripping.
Definition: at32f435_437_emac.c:348
emac_dma_software_reset_set
void emac_dma_software_reset_set(void)
reset emac dma
Definition: at32f435_437_emac.c:156
emac_control_para_init
void emac_control_para_init(emac_control_config_type *control_para)
initialize emac control structure
Definition: at32f435_437_emac.c:70
emac_ptp_timestamp_enable
void emac_ptp_timestamp_enable(confirm_state new_state)
enable timestamp.
Definition: at32f435_437_emac.c:1882
emac_ptp_snapshot_ipv4_frames_enable
void emac_ptp_snapshot_ipv4_frames_enable(confirm_state new_state)
enable snapshot for ipv4 frames.
Definition: at32f435_437_emac.c:1992
emac_dstaddr_inverse_filter_set
void emac_dstaddr_inverse_filter_set(confirm_state new_state)
destination address inverse filtering.
Definition: at32f435_437_emac.c:503
emac_dma_receive_status_get
emac_dma_receive_process_status_type emac_dma_receive_status_get(void)
get receive dma process status
Definition: at32f435_437_emac.c:1266
emac_ptp_clock_node_set
void emac_ptp_clock_node_set(emac_ptp_clock_node_type node)
set clock node type
Definition: at32f435_437_emac.c:2027
emac_ptp_pps_frequency_set
void emac_ptp_pps_frequency_set(emac_ptp_pps_control_type freq)
set pps frequency
Definition: at32f435_437_emac.c:2218
emac_dma_rx_desc_interrupt_config
void emac_dma_rx_desc_interrupt_config(emac_dma_desc_type *dma_rx_desc, confirm_state new_state)
enable or disable the specified dma rx descriptor receive interrupt
Definition: at32f435_437_emac.c:1001
emac_ptp_system_subsecond_set
void emac_ptp_system_subsecond_set(uint32_t subsecond)
set system time subsecond
Definition: at32f435_437_emac.c:2106
emac_pass_all_multicasting_set
void emac_pass_all_multicasting_set(confirm_state new_state)
pass all multicasting frames.
Definition: at32f435_437_emac.c:513
emac_dma_operations_set
void emac_dma_operations_set(emac_dma_operations_type ops, confirm_state new_state)
set dma operations
Definition: at32f435_437_emac.c:1371
emac_interrupt_mask_set
void emac_interrupt_mask_set(emac_interrupt_mask_type mask_type, confirm_state new_state)
set interrupt mask
Definition: at32f435_437_emac.c:858
emac_receive_own_disable
void emac_receive_own_disable(confirm_state new_state)
receive own disable.
Definition: at32f435_437_emac.c:388
emac_dma_software_reset_get
flag_status emac_dma_software_reset_get(void)
get emac dma reset status
Definition: at32f435_437_emac.c:166
emac_hash_table_high32bits_set
void emac_hash_table_high32bits_set(uint32_t high32bits)
hash table high 32-bit.
Definition: at32f435_437_emac.c:587
emac_dma_flag_get
flag_status emac_dma_flag_get(uint32_t dma_flag)
check whether the specified emac dma flag is set or not.
Definition: at32f435_437_emac.c:2259
emac_control_config
void emac_control_config(emac_control_config_type *control_struct)
configure emac control setting.
Definition: at32f435_437_emac.c:136
emac_srcaddr_filter_set
void emac_srcaddr_filter_set(confirm_state new_state)
source address filtering.
Definition: at32f435_437_emac.c:557
emac_ptp_subsecond_rollover_enable
void emac_ptp_subsecond_rollover_enable(confirm_state new_state)
enable digital rollover.
Definition: at32f435_437_emac.c:1952
emac_wakeup_frame_enable
void emac_wakeup_frame_enable(confirm_state new_state)
wakeup frame enable
Definition: at32f435_437_emac.c:767
emac_dma_receive_threshold_set
void emac_dma_receive_threshold_set(emac_dma_receive_threshold_type value)
set receive dma threshold
Definition: at32f435_437_emac.c:1451
emac_trasmitter_enable
void emac_trasmitter_enable(confirm_state new_state)
emac transmitter enable.
Definition: at32f435_437_emac.c:307
emac_ptp_subsecond_increment_set
void emac_ptp_subsecond_increment_set(uint8_t value)
set subsecond increment value
Definition: at32f435_437_emac.c:2047
emac_dma_application_missing_frame_get
uint16_t emac_dma_application_missing_frame_get(void)
get missed frames by the application
Definition: at32f435_437_emac.c:1606
emac_mmc_counter_reset
void emac_mmc_counter_reset(void)
reset all counter
Definition: at32f435_437_emac.c:1668
emac_power_down_set
void emac_power_down_set(confirm_state new_state)
all frame will be droppped except wakeup frame or magic packet.
Definition: at32f435_437_emac.c:747
emac_ptp_system_second_get
uint32_t emac_ptp_system_second_get(void)
get system time second
Definition: at32f435_437_emac.c:2057
emac_phy_register_read
error_status emac_phy_register_read(uint8_t address, uint8_t reg, uint16_t *data)
read phy data
Definition: at32f435_437_emac.c:262
emac_receive_flow_control_enable
void emac_receive_flow_control_enable(confirm_state new_state)
set receive flow control.
Definition: at32f435_437_emac.c:652
emac_magic_packet_enable
void emac_magic_packet_enable(confirm_state new_state)
magic packet enable
Definition: at32f435_437_emac.c:757
emac_dma_separate_pbl_set
void emac_dma_separate_pbl_set(emac_dma_pbl_type tx_length, emac_dma_pbl_type rx_length, confirm_state new_state)
set programmable burst length
Definition: at32f435_437_emac.c:1173
emac_received_magic_packet_get
flag_status emac_received_magic_packet_get(void)
received magic packet
Definition: at32f435_437_emac.c:777
emac_receive_all_set
void emac_receive_all_set(confirm_state new_state)
mac receives all frames.
Definition: at32f435_437_emac.c:577
emac_ptp_system_time_sign_get
confirm_state emac_ptp_system_time_sign_get(void)
get system time sign
Definition: at32f435_437_emac.c:2079
emac_receiver_enable
void emac_receiver_enable(confirm_state new_state)
emac receiver enable.
Definition: at32f435_437_emac.c:291
emac_dma_address_aligned_beats_set
void emac_dma_address_aligned_beats_set(confirm_state new_state)
set address-aligned beats
Definition: at32f435_437_emac.c:1199
emac_ptp_timestamp_system_time_init
void emac_ptp_timestamp_system_time_init(confirm_state new_state)
initialize timestamp time system.
Definition: at32f435_437_emac.c:1902
emac_broadcast_frames_disable
void emac_broadcast_frames_disable(confirm_state new_state)
broadcast frames disable.
Definition: at32f435_437_emac.c:523
emac_vlan_tag_identifier_set
void emac_vlan_tag_identifier_set(uint16_t identifier)
identify coming vlan frame field with setting value.
Definition: at32f435_437_emac.c:707
emac_promiscuous_mode_set
void emac_promiscuous_mode_set(confirm_state new_state)
set mac promiscuous mode.
Definition: at32f435_437_emac.c:473
emac_ptp_interrupt_trigger_enable
void emac_ptp_interrupt_trigger_enable(confirm_state new_state)
enable timestamp interrupt trigger.
Definition: at32f435_437_emac.c:1922
emac_interframe_gap_set
void emac_interframe_gap_set(emac_intergrame_gap_type number)
set minimum interframe gap between frames during transmission.
Definition: at32f435_437_emac.c:417
emac_mmc_transmit_status_get
flag_status emac_mmc_transmit_status_get(uint32_t flag)
interupt status of transmit frames
Definition: at32f435_437_emac.c:1733
emac_retry_disable
void emac_retry_disable(confirm_state new_state)
transmittion retry disable.
Definition: at32f435_437_emac.c:358
emac_wakeup_frame_get
uint32_t emac_wakeup_frame_get(void)
get wakeup frame.
Definition: at32f435_437_emac.c:737
emac_reset
void emac_reset(void)
deinitialize the emac peripheral registers to their default reset values.
Definition: at32f435_437_emac.c:59
emac_start
void emac_start(void)
enable emac and dma reception/transmission
Definition: at32f435_437_emac.c:183
emac_ptp_system_time_sign_set
void emac_ptp_system_time_sign_set(confirm_state sign)
set system time sign
Definition: at32f435_437_emac.c:2116
emac_duplex_mode_set
void emac_duplex_mode_set(emac_duplex_type duplex_mode)
set duplex mode.
Definition: at32f435_437_emac.c:463
emac_transmit_flow_control_enable
void emac_transmit_flow_control_enable(confirm_state new_state)
set transmit flow control.
Definition: at32f435_437_emac.c:642
emac_dmarxdesc_frame_length_get
uint32_t emac_dmarxdesc_frame_length_get(emac_dma_desc_type *dma_rx_desc)
get the specified dma rx descsriptor frame length.
Definition: at32f435_437_emac.c:1063
emac_ptp_timestamp_system_time_update
void emac_ptp_timestamp_system_time_update(confirm_state new_state)
update timestamp time system.
Definition: at32f435_437_emac.c:1912
emac_ptp_snapshot_received_frames_enable
void emac_ptp_snapshot_received_frames_enable(confirm_state new_state)
enable timestamp snapshot for all received frames.
Definition: at32f435_437_emac.c:1942
emac_address_filter_set
void emac_address_filter_set(emac_address_type mac, emac_address_filter_type filter, emac_address_mask_type mask_bit, confirm_state new_state)
set mac filter address
Definition: at32f435_437_emac.c:895
emac_hash_table_low32bits_set
void emac_hash_table_low32bits_set(uint32_t low32bits)
hash table low 32-bit.
Definition: at32f435_437_emac.c:597
emac_hash_multicast_set
void emac_hash_multicast_set(confirm_state new_state)
hash multicast.
Definition: at32f435_437_emac.c:493
emac_ptp_psv2_enable
void emac_ptp_psv2_enable(confirm_state new_state)
enable packet snooping for version 2.
Definition: at32f435_437_emac.c:1962
emac_mmc_transmit_good_frames_get
uint32_t emac_mmc_transmit_good_frames_get(uint32_t flag)
get good frame numbers as single collision occurs.
Definition: at32f435_437_emac.c:1818
emac_dma_poll_demand_get
uint32_t emac_dma_poll_demand_get(emac_dma_tx_rx_type transfer_type)
get transmit poll demand
Definition: at32f435_437_emac.c:1238
emac_backoff_limit_set
void emac_backoff_limit_set(emac_bol_type slot_time)
emac back-off limit, only avalible in half-duplex mode.
Definition: at32f435_437_emac.c:338
emac_fast_speed_set
void emac_fast_speed_set(emac_speed_type speed)
set mac fast emac speed.
Definition: at32f435_437_emac.c:450
emac_dma_flag_clear
void emac_dma_flag_clear(uint32_t dma_flag)
clear the emac dma flag.
Definition: at32f435_437_emac.c:2290
emac_mmc_counter_freeze
void emac_mmc_counter_freeze(confirm_state new_state)
freeze mmc counter
Definition: at32f435_437_emac.c:1698
emac_clock_range_set
void emac_clock_range_set(void)
according to hclk to set mdc clock frequency.
Definition: at32f435_437_emac.c:93
emac_ptp_system_subsecond_get
uint32_t emac_ptp_system_subsecond_get(void)
get system time subsecond
Definition: at32f435_437_emac.c:2068
emac_interrupt_status_read
flag_status emac_interrupt_status_read(uint32_t flag)
read interrupt status
Definition: at32f435_437_emac.c:837
emac_dma_interrupt_enable
void emac_dma_interrupt_enable(emac_dma_interrupt_type it, confirm_state new_state)
enable dma interrupt
Definition: at32f435_437_emac.c:1497
emac_dma_poll_demand_set
void emac_dma_poll_demand_set(emac_dma_tx_rx_type transfer_type, uint32_t value)
set transmit/receive poll demand
Definition: at32f435_437_emac.c:1213
emac_pass_control_frames_set
void emac_pass_control_frames_set(emac_control_frames_filter_type condition)
set mac how to pass control frames.
Definition: at32f435_437_emac.c:537
emac_dma_para_init
void emac_dma_para_init(emac_dma_config_type *control_para)
init emac dma parameters
Definition: at32f435_437_emac.c:1073
emac_mmc_rollover_stop
void emac_mmc_rollover_stop(confirm_state new_state)
counter stop counting from zero when it reaches maximum
Definition: at32f435_437_emac.c:1678
emac_ptp_snapshot_event_message_enable
void emac_ptp_snapshot_event_message_enable(confirm_state new_state)
enable snapshot for event message.
Definition: at32f435_437_emac.c:2002
emac_wakeup_frame_filter_reset
void emac_wakeup_frame_filter_reset(confirm_state new_state)
reset wakeup frame filter resgister
Definition: at32f435_437_emac.c:821
emac_ptp_snapshot_ipv6_frames_enable
void emac_ptp_snapshot_ipv6_frames_enable(confirm_state new_state)
enable snapshot for ipv6 frames.
Definition: at32f435_437_emac.c:1982
emac_received_packet_size_get
uint32_t emac_received_packet_size_get(void)
get the size of received the received packet.
Definition: at32f435_437_emac.c:1044
emac_hash_perfect_filter_set
void emac_hash_perfect_filter_set(confirm_state new_state)
mac uses hash or perfect filter.
Definition: at32f435_437_emac.c:567
emac_phy_register_write
error_status emac_phy_register_write(uint8_t address, uint8_t reg, uint16_t data)
write phy data.
Definition: at32f435_437_emac.c:232
emac_deferral_check_set
void emac_deferral_check_set(confirm_state new_state)
emac defferal check enable, only avalible in half-duplex mode.
Definition: at32f435_437_emac.c:323
emac_pause_time_set
void emac_pause_time_set(uint16_t pause_time)
set pause time.
Definition: at32f435_437_emac.c:697
emac_ptp_target_nanosecond_set
void emac_ptp_target_nanosecond_set(uint32_t value)
set target time stamp low
Definition: at32f435_437_emac.c:2153
emac_mii_write
void emac_mii_write(confirm_state new_state)
tell phy that will be written.
Definition: at32f435_437_emac.c:622
emac_dma_config
void emac_dma_config(emac_dma_config_type *control_para)
configure emac dma
Definition: at32f435_437_emac.c:1099
emac_mmc_reset_on_read_enable
void emac_mmc_reset_on_read_enable(confirm_state new_state)
enable reset on read
Definition: at32f435_437_emac.c:1688
emac_watchdog_disable
void emac_watchdog_disable(confirm_state new_state)
watchdog disable.
Definition: at32f435_437_emac.c:437
emac_ptp_timestamp_fine_update_enable
void emac_ptp_timestamp_fine_update_enable(confirm_state new_state)
enable timestamp fine update.
Definition: at32f435_437_emac.c:1892
emac_dma_eight_pbl_mode_set
void emac_dma_eight_pbl_mode_set(confirm_state new_state)
set 8 times programmable burst length
Definition: at32f435_437_emac.c:1189
emac_ptp_timestamp_status_get
confirm_state emac_ptp_timestamp_status_get(emac_ptp_timestamp_status_type status)
set target time stamp low
Definition: at32f435_437_emac.c:2166
emac_fcb_bpa_set
void emac_fcb_bpa_set(confirm_state new_state)
set flow control busy in full-duplex mode, back pressure activate in half-duplex mode.
Definition: at32f435_437_emac.c:632
emac_mmc_received_error_frames_get
uint32_t emac_mmc_received_error_frames_get(uint32_t flag)
get good frame numbers as single collision occurs.
Definition: at32f435_437_emac.c:1852
emac_carrier_sense_disable
void emac_carrier_sense_disable(confirm_state new_state)
carrier sense disbale.
Definition: at32f435_437_emac.c:398
emac_unicast_pause_frame_detect
void emac_unicast_pause_frame_detect(confirm_state new_state)
set unicast pause frame detect.
Definition: at32f435_437_emac.c:662
emac_dma_controller_missing_frame_get
uint16_t emac_dma_controller_missing_frame_get(void)
get missed frames by the controller
Definition: at32f435_437_emac.c:1584
emac_ptp_timestamp_addend_set
void emac_ptp_timestamp_addend_set(uint32_t value)
set time stamp addend
Definition: at32f435_437_emac.c:2133
emac_dma_transmit_status_get
emac_dma_transmit_process_status_type emac_dma_transmit_status_get(void)
get transmit dma process status
Definition: at32f435_437_emac.c:1316
emac_received_wakeup_frame_get
flag_status emac_received_wakeup_frame_get(void)
received wakeup frame.
Definition: at32f435_437_emac.c:794
emac_dma_arbitation_set
void emac_dma_arbitation_set(emac_dma_rx_tx_ratio_type ratio, confirm_state new_state)
set rx tx priority
Definition: at32f435_437_emac.c:1132
emac_ptp_mac_address_filter_enable
void emac_ptp_mac_address_filter_enable(confirm_state new_state)
enable ptp frame filtering mac address
Definition: at32f435_437_emac.c:2037
emac_dma_missing_overflow_bit_get
uint8_t emac_dma_missing_overflow_bit_get(void)
get overflow bit for missed frame counter
Definition: at32f435_437_emac.c:1595
emac_wakeup_frame_set
void emac_wakeup_frame_set(uint32_t value)
set wakeup frame.
Definition: at32f435_437_emac.c:727
emac_mmc_received_status_get
flag_status emac_mmc_received_status_get(uint32_t flag)
interupt status of received frames
Definition: at32f435_437_emac.c:1712
emac_mmc_transmit_interrupt_mask_set
void emac_mmc_transmit_interrupt_mask_set(uint32_t flag, confirm_state new_state)
mask transmit mmc interrupt
Definition: at32f435_437_emac.c:1787
emac_dma_descriptor_list_address_set
void emac_dma_descriptor_list_address_set(emac_dma_tx_rx_type transfer_type, emac_dma_desc_type *dma_desc_tab, uint8_t *buff, uint32_t buffer_count)
set transmit/receive descriptor list address
Definition: at32f435_437_emac.c:934
emac_ptp_addend_register_update
void emac_ptp_addend_register_update(confirm_state new_state)
update timestamp addend register.
Definition: at32f435_437_emac.c:1932
emac_ipv4_checksum_offload_set
void emac_ipv4_checksum_offload_set(confirm_state new_state)
set ipv4 checksum offload.
Definition: at32f435_437_emac.c:368
emac_stop
void emac_stop(void)
stop emac and dma reception/transmission
Definition: at32f435_437_emac.c:206
emac_dma_descriptor_skip_length_set
void emac_dma_descriptor_skip_length_set(uint8_t length)
set descriptor skip mength
Definition: at32f435_437_emac.c:1147
emac_jabber_disable
void emac_jabber_disable(confirm_state new_state)
jabber disable.
Definition: at32f435_437_emac.c:427
emac_dma_tansfer_address_get
uint32_t emac_dma_tansfer_address_get(emac_dma_transfer_address_type transfer_type)
get overflow bit for FIFO overflow counter
Definition: at32f435_437_emac.c:1633
emac_ptp_snapshot_master_event_enable
void emac_ptp_snapshot_master_event_enable(confirm_state new_state)
enable snapshot for message relevant to master
Definition: at32f435_437_emac.c:2012
emac_dma_descriptor_list_address_get
uint32_t emac_dma_descriptor_list_address_get(emac_dma_tx_rx_type transfer_type)
get transmit/receive descriptor list address
Definition: at32f435_437_emac.c:1023
emac_pause_low_threshold_set
void emac_pause_low_threshold_set(emac_pause_slot_threshold_type pasue_threshold)
set pause low threshold.
Definition: at32f435_437_emac.c:677
emac_srcaddr_inverse_filter_set
void emac_srcaddr_inverse_filter_set(confirm_state new_state)
source address inverse filtering.
Definition: at32f435_437_emac.c:547
emac_mii_busy_get
flag_status emac_mii_busy_get(void)
mii busy status.
Definition: at32f435_437_emac.c:607
emac_ptp_snapshot_emac_frames_enable
void emac_ptp_snapshot_emac_frames_enable(confirm_state new_state)
enable snapshot over emac.
Definition: at32f435_437_emac.c:1972
emac_local_address_set
void emac_local_address_set(uint8_t *address)
set local mac address
Definition: at32f435_437_emac.c:880
emac_address_filter_type
emac_address_filter_type
address filter type
Definition: at32f435_437_emac.h:388
emac_dma_receive_threshold_type
emac_dma_receive_threshold_type
receive threshold control type
Definition: at32f435_437_emac.h:486
emac_dma_transmit_threshold_type
emac_dma_transmit_threshold_type
transmit threshold control type
Definition: at32f435_437_emac.h:497
emac_intergrame_gap_type
emac_intergrame_gap_type
emac interframe gap type
Definition: at32f435_437_emac.h:320
emac_bol_type
emac_bol_type
emac back_off limit type
Definition: at32f435_437_emac.h:291
emac_ptp_timestamp_status_type
emac_ptp_timestamp_status_type
time stamp status type
Definition: at32f435_437_emac.h:556
emac_control_frames_filter_type
emac_control_frames_filter_type
emac control frames filter type
Definition: at32f435_437_emac.h:348
emac_dma_transfer_address_type
emac_dma_transfer_address_type
dma tansfer address type
Definition: at32f435_437_emac.h:534
emac_ptp_pps_control_type
emac_ptp_pps_control_type
pps control type
Definition: at32f435_437_emac.h:565
emac_ptp_clock_node_type
emac_ptp_clock_node_type
clock node type
Definition: at32f435_437_emac.h:545
emac_duplex_type
emac_duplex_type
emac duplex type
Definition: at32f435_437_emac.h:302
emac_dma_receive_process_status_type
emac_dma_receive_process_status_type
dma receive process status type
Definition: at32f435_437_emac.h:443
emac_clock_range_type
emac_clock_range_type
mdc clock range type
Definition: at32f435_437_emac.h:335
emac_dma_pbl_type
emac_dma_pbl_type
programmable burst length
Definition: at32f435_437_emac.h:421
emac_speed_type
emac_speed_type
emac speed type
Definition: at32f435_437_emac.h:311
emac_address_type
emac_address_type
mac address type
Definition: at32f435_437_emac.h:378
emac_pause_slot_threshold_type
emac_pause_slot_threshold_type
pause threshold type
Definition: at32f435_437_emac.h:358
emac_interrupt_mask_type
emac_interrupt_mask_type
interrupt mask type
Definition: at32f435_437_emac.h:369
emac_dma_interrupt_type
emac_dma_interrupt_type
dma interrupt type
Definition: at32f435_437_emac.h:512
emac_dma_transmit_process_status_type
emac_dma_transmit_process_status_type
dma transmit process status type
Definition: at32f435_437_emac.h:456
emac_dma_operations_type
emac_dma_operations_type
dma operations type
Definition: at32f435_437_emac.h:469
emac_auto_negotiation_type
emac_auto_negotiation_type
emac auto negotiation type
Definition: at32f435_437_emac.h:282
emac_dma_rx_tx_ratio_type
emac_dma_rx_tx_ratio_type
rx tx priority ratio type
Definition: at32f435_437_emac.h:410
emac_dma_tx_rx_type
emac_dma_tx_rx_type
dma tx rx type
Definition: at32f435_437_emac.h:434
emac_address_mask_type
emac_address_mask_type
address mask type
Definition: at32f435_437_emac.h:397
EMAC_SOURCE_FILTER
@ EMAC_SOURCE_FILTER
Definition: at32f435_437_emac.h:390
EMAC_DESTINATION_FILTER
@ EMAC_DESTINATION_FILTER
Definition: at32f435_437_emac.h:389
EMAC_DMA_RX_THRESHOLD_128_BYTES
@ EMAC_DMA_RX_THRESHOLD_128_BYTES
Definition: at32f435_437_emac.h:490
EMAC_DMA_RX_THRESHOLD_32_BYTES
@ EMAC_DMA_RX_THRESHOLD_32_BYTES
Definition: at32f435_437_emac.h:488
EMAC_DMA_RX_THRESHOLD_96_BYTES
@ EMAC_DMA_RX_THRESHOLD_96_BYTES
Definition: at32f435_437_emac.h:489
EMAC_DMA_RX_THRESHOLD_64_BYTES
@ EMAC_DMA_RX_THRESHOLD_64_BYTES
Definition: at32f435_437_emac.h:487
EMAC_DMA_TX_THRESHOLD_256_BYTES
@ EMAC_DMA_TX_THRESHOLD_256_BYTES
Definition: at32f435_437_emac.h:501
EMAC_DMA_TX_THRESHOLD_192_BYTES
@ EMAC_DMA_TX_THRESHOLD_192_BYTES
Definition: at32f435_437_emac.h:500
EMAC_DMA_TX_THRESHOLD_64_BYTES
@ EMAC_DMA_TX_THRESHOLD_64_BYTES
Definition: at32f435_437_emac.h:498
EMAC_DMA_TX_THRESHOLD_24_BYTES
@ EMAC_DMA_TX_THRESHOLD_24_BYTES
Definition: at32f435_437_emac.h:504
EMAC_DMA_TX_THRESHOLD_128_BYTES
@ EMAC_DMA_TX_THRESHOLD_128_BYTES
Definition: at32f435_437_emac.h:499
EMAC_DMA_TX_THRESHOLD_16_BYTES
@ EMAC_DMA_TX_THRESHOLD_16_BYTES
Definition: at32f435_437_emac.h:505
EMAC_DMA_TX_THRESHOLD_32_BYTES
@ EMAC_DMA_TX_THRESHOLD_32_BYTES
Definition: at32f435_437_emac.h:503
EMAC_DMA_TX_THRESHOLD_40_BYTES
@ EMAC_DMA_TX_THRESHOLD_40_BYTES
Definition: at32f435_437_emac.h:502
EMAC_INTERFRAME_GAP_80BIT
@ EMAC_INTERFRAME_GAP_80BIT
Definition: at32f435_437_emac.h:323
EMAC_INTERFRAME_GAP_64BIT
@ EMAC_INTERFRAME_GAP_64BIT
Definition: at32f435_437_emac.h:325
EMAC_INTERFRAME_GAP_56BIT
@ EMAC_INTERFRAME_GAP_56BIT
Definition: at32f435_437_emac.h:326
EMAC_INTERFRAME_GAP_72BIT
@ EMAC_INTERFRAME_GAP_72BIT
Definition: at32f435_437_emac.h:324
EMAC_INTERFRAME_GAP_48BIT
@ EMAC_INTERFRAME_GAP_48BIT
Definition: at32f435_437_emac.h:327
EMAC_INTERFRAME_GAP_96BIT
@ EMAC_INTERFRAME_GAP_96BIT
Definition: at32f435_437_emac.h:321
EMAC_INTERFRAME_GAP_40BIT
@ EMAC_INTERFRAME_GAP_40BIT
Definition: at32f435_437_emac.h:328
EMAC_INTERFRAME_GAP_88BIT
@ EMAC_INTERFRAME_GAP_88BIT
Definition: at32f435_437_emac.h:322
EMAC_BACKOFF_LIMIT_3
@ EMAC_BACKOFF_LIMIT_3
Definition: at32f435_437_emac.h:295
EMAC_BACKOFF_LIMIT_1
@ EMAC_BACKOFF_LIMIT_1
Definition: at32f435_437_emac.h:293
EMAC_BACKOFF_LIMIT_2
@ EMAC_BACKOFF_LIMIT_2
Definition: at32f435_437_emac.h:294
EMAC_BACKOFF_LIMIT_0
@ EMAC_BACKOFF_LIMIT_0
Definition: at32f435_437_emac.h:292
EMAC_PTP_SECOND_OVERFLOW
@ EMAC_PTP_SECOND_OVERFLOW
Definition: at32f435_437_emac.h:557
EMAC_PTP_TARGET_TIME_REACH
@ EMAC_PTP_TARGET_TIME_REACH
Definition: at32f435_437_emac.h:558
EMAC_CONTROL_FRAME_PASSING_MATCH
@ EMAC_CONTROL_FRAME_PASSING_MATCH
Definition: at32f435_437_emac.h:351
EMAC_CONTROL_FRAME_PASSING_NO
@ EMAC_CONTROL_FRAME_PASSING_NO
Definition: at32f435_437_emac.h:349
EMAC_CONTROL_FRAME_PASSING_ALL
@ EMAC_CONTROL_FRAME_PASSING_ALL
Definition: at32f435_437_emac.h:350
EMAC_DMA_TX_DESCRIPTOR
@ EMAC_DMA_TX_DESCRIPTOR
Definition: at32f435_437_emac.h:535
EMAC_DMA_RX_DESCRIPTOR
@ EMAC_DMA_RX_DESCRIPTOR
Definition: at32f435_437_emac.h:536
EMAC_DMA_TX_BUFFER
@ EMAC_DMA_TX_BUFFER
Definition: at32f435_437_emac.h:537
EMAC_DMA_RX_BUFFER
@ EMAC_DMA_RX_BUFFER
Definition: at32f435_437_emac.h:538
EMAC_PTP_PPS_64HZ
@ EMAC_PTP_PPS_64HZ
Definition: at32f435_437_emac.h:572
EMAC_PTP_PPS_256HZ
@ EMAC_PTP_PPS_256HZ
Definition: at32f435_437_emac.h:574
EMAC_PTP_PPS_32768HZ
@ EMAC_PTP_PPS_32768HZ
Definition: at32f435_437_emac.h:581
EMAC_PTP_PPS_16384HZ
@ EMAC_PTP_PPS_16384HZ
Definition: at32f435_437_emac.h:580
EMAC_PTP_PPS_8HZ
@ EMAC_PTP_PPS_8HZ
Definition: at32f435_437_emac.h:569
EMAC_PTP_PPS_1HZ
@ EMAC_PTP_PPS_1HZ
Definition: at32f435_437_emac.h:566
EMAC_PTP_PPS_4HZ
@ EMAC_PTP_PPS_4HZ
Definition: at32f435_437_emac.h:568
EMAC_PTP_PPS_128HZ
@ EMAC_PTP_PPS_128HZ
Definition: at32f435_437_emac.h:573
EMAC_PTP_PPS_32HZ
@ EMAC_PTP_PPS_32HZ
Definition: at32f435_437_emac.h:571
EMAC_PTP_PPS_16HZ
@ EMAC_PTP_PPS_16HZ
Definition: at32f435_437_emac.h:570
EMAC_PTP_PPS_2HZ
@ EMAC_PTP_PPS_2HZ
Definition: at32f435_437_emac.h:567
EMAC_PTP_PPS_512HZ
@ EMAC_PTP_PPS_512HZ
Definition: at32f435_437_emac.h:575
EMAC_PTP_PPS_1024HZ
@ EMAC_PTP_PPS_1024HZ
Definition: at32f435_437_emac.h:576
EMAC_PTP_PPS_4096HZ
@ EMAC_PTP_PPS_4096HZ
Definition: at32f435_437_emac.h:578
EMAC_PTP_PPS_8192HZ
@ EMAC_PTP_PPS_8192HZ
Definition: at32f435_437_emac.h:579
EMAC_PTP_PPS_2048HZ
@ EMAC_PTP_PPS_2048HZ
Definition: at32f435_437_emac.h:577
EMAC_PTP_NORMAL_CLOCK
@ EMAC_PTP_NORMAL_CLOCK
Definition: at32f435_437_emac.h:546
EMAC_PTP_END_TO_END_CLOCK
@ EMAC_PTP_END_TO_END_CLOCK
Definition: at32f435_437_emac.h:548
EMAC_PTP_PEER_TO_PEER_CLOCK
@ EMAC_PTP_PEER_TO_PEER_CLOCK
Definition: at32f435_437_emac.h:549
EMAC_PTP_BOUNDARY_CLOCK
@ EMAC_PTP_BOUNDARY_CLOCK
Definition: at32f435_437_emac.h:547
EMAC_HALF_DUPLEX
@ EMAC_HALF_DUPLEX
Definition: at32f435_437_emac.h:303
EMAC_FULL_DUPLEX
@ EMAC_FULL_DUPLEX
Definition: at32f435_437_emac.h:304
EMAC_DMA_RX_FETCH_DESCRIPTOR
@ EMAC_DMA_RX_FETCH_DESCRIPTOR
Definition: at32f435_437_emac.h:445
EMAC_DMA_RX_CLOSE_DESCRIPTOR
@ EMAC_DMA_RX_CLOSE_DESCRIPTOR
Definition: at32f435_437_emac.h:448
EMAC_DMA_RX_RESET_STOP_COMMAND
@ EMAC_DMA_RX_RESET_STOP_COMMAND
Definition: at32f435_437_emac.h:444
EMAC_DMA_RX_DESCRIPTOR_UNAVAILABLE
@ EMAC_DMA_RX_DESCRIPTOR_UNAVAILABLE
Definition: at32f435_437_emac.h:447
EMAC_DMA_RX_FIFO_TO_HOST
@ EMAC_DMA_RX_FIFO_TO_HOST
Definition: at32f435_437_emac.h:449
EMAC_DMA_RX_WAITING_PACKET
@ EMAC_DMA_RX_WAITING_PACKET
Definition: at32f435_437_emac.h:446
EMAC_CLOCK_RANGE_35_TO_60
@ EMAC_CLOCK_RANGE_35_TO_60
Definition: at32f435_437_emac.h:339
EMAC_CLOCK_RANGE_60_TO_100
@ EMAC_CLOCK_RANGE_60_TO_100
Definition: at32f435_437_emac.h:336
EMAC_CLOCK_RANGE_150_TO_250
@ EMAC_CLOCK_RANGE_150_TO_250
Definition: at32f435_437_emac.h:340
EMAC_CLOCK_RANGE_20_TO_35
@ EMAC_CLOCK_RANGE_20_TO_35
Definition: at32f435_437_emac.h:338
EMAC_CLOCK_RANGE_100_TO_150
@ EMAC_CLOCK_RANGE_100_TO_150
Definition: at32f435_437_emac.h:337
EMAC_CLOCK_RANGE_250_TO_288
@ EMAC_CLOCK_RANGE_250_TO_288
Definition: at32f435_437_emac.h:341
EMAC_DMA_PBL_4
@ EMAC_DMA_PBL_4
Definition: at32f435_437_emac.h:424
EMAC_DMA_PBL_2
@ EMAC_DMA_PBL_2
Definition: at32f435_437_emac.h:423
EMAC_DMA_PBL_32
@ EMAC_DMA_PBL_32
Definition: at32f435_437_emac.h:427
EMAC_DMA_PBL_1
@ EMAC_DMA_PBL_1
Definition: at32f435_437_emac.h:422
EMAC_DMA_PBL_16
@ EMAC_DMA_PBL_16
Definition: at32f435_437_emac.h:426
EMAC_DMA_PBL_8
@ EMAC_DMA_PBL_8
Definition: at32f435_437_emac.h:425
EMAC_SPEED_10MBPS
@ EMAC_SPEED_10MBPS
Definition: at32f435_437_emac.h:312
EMAC_SPEED_100MBPS
@ EMAC_SPEED_100MBPS
Definition: at32f435_437_emac.h:313
EMAC_ADDRESS_FILTER_3
@ EMAC_ADDRESS_FILTER_3
Definition: at32f435_437_emac.h:381
EMAC_ADDRESS_FILTER_2
@ EMAC_ADDRESS_FILTER_2
Definition: at32f435_437_emac.h:380
EMAC_ADDRESS_FILTER_1
@ EMAC_ADDRESS_FILTER_1
Definition: at32f435_437_emac.h:379
EMAC_PAUSE_28_SLOT_TIME
@ EMAC_PAUSE_28_SLOT_TIME
Definition: at32f435_437_emac.h:360
EMAC_PAUSE_256_SLOT_TIME
@ EMAC_PAUSE_256_SLOT_TIME
Definition: at32f435_437_emac.h:362
EMAC_PAUSE_144_SLOT_TIME
@ EMAC_PAUSE_144_SLOT_TIME
Definition: at32f435_437_emac.h:361
EMAC_PAUSE_4_SLOT_TIME
@ EMAC_PAUSE_4_SLOT_TIME
Definition: at32f435_437_emac.h:359
EMAC_INTERRUPT_PMT_MASK
@ EMAC_INTERRUPT_PMT_MASK
Definition: at32f435_437_emac.h:370
EMAC_INTERRUPT_TST_MASK
@ EMAC_INTERRUPT_TST_MASK
Definition: at32f435_437_emac.h:371
EMAC_DMA_INTERRUPT_TX_UNDERFLOW
@ EMAC_DMA_INTERRUPT_TX_UNDERFLOW
Definition: at32f435_437_emac.h:518
EMAC_DMA_INTERRUPT_TX_UNAVAILABLE
@ EMAC_DMA_INTERRUPT_TX_UNAVAILABLE
Definition: at32f435_437_emac.h:515
EMAC_DMA_INTERRUPT_RX_UNAVAILABLE
@ EMAC_DMA_INTERRUPT_RX_UNAVAILABLE
Definition: at32f435_437_emac.h:520
EMAC_DMA_INTERRUPT_TX
@ EMAC_DMA_INTERRUPT_TX
Definition: at32f435_437_emac.h:513
EMAC_DMA_INTERRUPT_NORMAL_SUMMARY
@ EMAC_DMA_INTERRUPT_NORMAL_SUMMARY
Definition: at32f435_437_emac.h:527
EMAC_DMA_INTERRUPT_FATAL_BUS_ERROR
@ EMAC_DMA_INTERRUPT_FATAL_BUS_ERROR
Definition: at32f435_437_emac.h:524
EMAC_DMA_INTERRUPT_TX_JABBER
@ EMAC_DMA_INTERRUPT_TX_JABBER
Definition: at32f435_437_emac.h:516
EMAC_DMA_INTERRUPT_ABNORMAL_SUMMARY
@ EMAC_DMA_INTERRUPT_ABNORMAL_SUMMARY
Definition: at32f435_437_emac.h:526
EMAC_DMA_INTERRUPT_RX_TIMEOUT
@ EMAC_DMA_INTERRUPT_RX_TIMEOUT
Definition: at32f435_437_emac.h:522
EMAC_DMA_INTERRUPT_RX
@ EMAC_DMA_INTERRUPT_RX
Definition: at32f435_437_emac.h:519
EMAC_DMA_INTERRUPT_RX_STOP
@ EMAC_DMA_INTERRUPT_RX_STOP
Definition: at32f435_437_emac.h:521
EMAC_DMA_INTERRUPT_RX_EARLY
@ EMAC_DMA_INTERRUPT_RX_EARLY
Definition: at32f435_437_emac.h:525
EMAC_DMA_INTERRUPT_TX_EARLY
@ EMAC_DMA_INTERRUPT_TX_EARLY
Definition: at32f435_437_emac.h:523
EMAC_DMA_INTERRUPT_TX_STOP
@ EMAC_DMA_INTERRUPT_TX_STOP
Definition: at32f435_437_emac.h:514
EMAC_DMA_INTERRUPT_RX_OVERFLOW
@ EMAC_DMA_INTERRUPT_RX_OVERFLOW
Definition: at32f435_437_emac.h:517
EMAC_DMA_TX_FETCH_DESCRIPTOR
@ EMAC_DMA_TX_FETCH_DESCRIPTOR
Definition: at32f435_437_emac.h:458
EMAC_DMA_TX_CLOSE_DESCRIPTOR
@ EMAC_DMA_TX_CLOSE_DESCRIPTOR
Definition: at32f435_437_emac.h:462
EMAC_DMA_TX_HOST_TO_FIFO
@ EMAC_DMA_TX_HOST_TO_FIFO
Definition: at32f435_437_emac.h:460
EMAC_DMA_TX_WAITING_FOR_STATUS
@ EMAC_DMA_TX_WAITING_FOR_STATUS
Definition: at32f435_437_emac.h:459
EMAC_DMA_TX_RESET_STOP_COMMAND
@ EMAC_DMA_TX_RESET_STOP_COMMAND
Definition: at32f435_437_emac.h:457
EMAC_DMA_TX_DESCRIPTOR_UNAVAILABLE
@ EMAC_DMA_TX_DESCRIPTOR_UNAVAILABLE
Definition: at32f435_437_emac.h:461
EMAC_DMA_OPS_FORWARD_UNDERSIZED
@ EMAC_DMA_OPS_FORWARD_UNDERSIZED
Definition: at32f435_437_emac.h:472
EMAC_DMA_OPS_RECEIVE_FLUSH_DISABLE
@ EMAC_DMA_OPS_RECEIVE_FLUSH_DISABLE
Definition: at32f435_437_emac.h:477
EMAC_DMA_OPS_TRANSMIT_STORE_FORWARD
@ EMAC_DMA_OPS_TRANSMIT_STORE_FORWARD
Definition: at32f435_437_emac.h:476
EMAC_DMA_OPS_DROP_ERROR_DISABLE
@ EMAC_DMA_OPS_DROP_ERROR_DISABLE
Definition: at32f435_437_emac.h:479
EMAC_DMA_OPS_RECEIVE_STORE_FORWARD
@ EMAC_DMA_OPS_RECEIVE_STORE_FORWARD
Definition: at32f435_437_emac.h:478
EMAC_DMA_OPS_FLUSH_TRANSMIT_FIFO
@ EMAC_DMA_OPS_FLUSH_TRANSMIT_FIFO
Definition: at32f435_437_emac.h:475
EMAC_DMA_OPS_SECOND_FRAME
@ EMAC_DMA_OPS_SECOND_FRAME
Definition: at32f435_437_emac.h:471
EMAC_DMA_OPS_START_STOP_RECEIVE
@ EMAC_DMA_OPS_START_STOP_RECEIVE
Definition: at32f435_437_emac.h:470
EMAC_DMA_OPS_START_STOP_TRANSMIT
@ EMAC_DMA_OPS_START_STOP_TRANSMIT
Definition: at32f435_437_emac.h:474
EMAC_DMA_OPS_FORWARD_ERROR
@ EMAC_DMA_OPS_FORWARD_ERROR
Definition: at32f435_437_emac.h:473
EMAC_AUTO_NEGOTIATION_ON
@ EMAC_AUTO_NEGOTIATION_ON
Definition: at32f435_437_emac.h:284
EMAC_AUTO_NEGOTIATION_OFF
@ EMAC_AUTO_NEGOTIATION_OFF
Definition: at32f435_437_emac.h:283
EMAC_DMA_2_RX_1_TX
@ EMAC_DMA_2_RX_1_TX
Definition: at32f435_437_emac.h:412
EMAC_DMA_4_RX_1_TX
@ EMAC_DMA_4_RX_1_TX
Definition: at32f435_437_emac.h:414
EMAC_DMA_3_RX_1_TX
@ EMAC_DMA_3_RX_1_TX
Definition: at32f435_437_emac.h:413
EMAC_DMA_1_RX_1_TX
@ EMAC_DMA_1_RX_1_TX
Definition: at32f435_437_emac.h:411
EMAC_DMA_TRANSMIT
@ EMAC_DMA_TRANSMIT
Definition: at32f435_437_emac.h:435
EMAC_DMA_RECEIVE
@ EMAC_DMA_RECEIVE
Definition: at32f435_437_emac.h:436
EMAC_ADDRESS_MASK_15L8
@ EMAC_ADDRESS_MASK_15L8
Definition: at32f435_437_emac.h:399
EMAC_ADDRESS_MASK_15H8
@ EMAC_ADDRESS_MASK_15H8
Definition: at32f435_437_emac.h:403
EMAC_ADDRESS_MASK_7H0
@ EMAC_ADDRESS_MASK_7H0
Definition: at32f435_437_emac.h:402
EMAC_ADDRESS_MASK_31L24
@ EMAC_ADDRESS_MASK_31L24
Definition: at32f435_437_emac.h:401
EMAC_ADDRESS_MASK_23L16
@ EMAC_ADDRESS_MASK_23L16
Definition: at32f435_437_emac.h:400
EMAC_ADDRESS_MASK_8L0
@ EMAC_ADDRESS_MASK_8L0
Definition: at32f435_437_emac.h:398
error_status
error_status
Definition: at32f435_437.h:380
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
emac_control_config_type
ethernet mac control config type
Definition: at32f435_437_emac.h:588
emac_control_config_type::auto_pad_crc_strip
confirm_state auto_pad_crc_strip
Definition: at32f435_437_emac.h:592
emac_control_config_type::jabber_disable
confirm_state jabber_disable
Definition: at32f435_437_emac.h:601
emac_control_config_type::loopback_mode
confirm_state loopback_mode
Definition: at32f435_437_emac.h:596
emac_control_config_type::back_off_limit
emac_bol_type back_off_limit
Definition: at32f435_437_emac.h:591
emac_control_config_type::auto_nego
emac_auto_negotiation_type auto_nego
Definition: at32f435_437_emac.h:589
emac_control_config_type::retry_disable
confirm_state retry_disable
Definition: at32f435_437_emac.h:593
emac_control_config_type::fast_ethernet_speed
emac_speed_type fast_ethernet_speed
Definition: at32f435_437_emac.h:598
emac_control_config_type::deferral_check
confirm_state deferral_check
Definition: at32f435_437_emac.h:590
emac_control_config_type::receive_own_disable
confirm_state receive_own_disable
Definition: at32f435_437_emac.h:597
emac_control_config_type::watchdog_disable
confirm_state watchdog_disable
Definition: at32f435_437_emac.h:602
emac_control_config_type::interframe_gap
emac_intergrame_gap_type interframe_gap
Definition: at32f435_437_emac.h:600
emac_control_config_type::duplex_mode
emac_duplex_type duplex_mode
Definition: at32f435_437_emac.h:595
emac_control_config_type::carrier_sense_disable
confirm_state carrier_sense_disable
Definition: at32f435_437_emac.h:599
emac_control_config_type::ipv4_checksum_offload
confirm_state ipv4_checksum_offload
Definition: at32f435_437_emac.h:594
emac_dma_config_type
ethernet mac dma config type
Definition: at32f435_437_emac.h:609
emac_dma_config_type::tx_dma_pal
emac_dma_pbl_type tx_dma_pal
Definition: at32f435_437_emac.h:614
emac_dma_config_type::aab_enable
confirm_state aab_enable
Definition: at32f435_437_emac.h:610
emac_dma_config_type::dt_disable
confirm_state dt_disable
Definition: at32f435_437_emac.h:618
emac_dma_config_type::rx_dma_pal
emac_dma_pbl_type rx_dma_pal
Definition: at32f435_437_emac.h:612
emac_dma_config_type::flush_rx_disable
confirm_state flush_rx_disable
Definition: at32f435_437_emac.h:620
emac_dma_config_type::rx_threshold
emac_dma_receive_threshold_type rx_threshold
Definition: at32f435_437_emac.h:625
emac_dma_config_type::priority_ratio
emac_dma_rx_tx_ratio_type priority_ratio
Definition: at32f435_437_emac.h:617
emac_dma_config_type::fugf_enable
confirm_state fugf_enable
Definition: at32f435_437_emac.h:624
emac_dma_config_type::desc_skip_length
uint8_t desc_skip_length
Definition: at32f435_437_emac.h:615
emac_dma_config_type::osf_enable
confirm_state osf_enable
Definition: at32f435_437_emac.h:626
emac_dma_config_type::usp_enable
confirm_state usp_enable
Definition: at32f435_437_emac.h:611
emac_dma_config_type::rsf_enable
confirm_state rsf_enable
Definition: at32f435_437_emac.h:619
emac_dma_config_type::tsf_enable
confirm_state tsf_enable
Definition: at32f435_437_emac.h:621
emac_dma_config_type::da_enable
confirm_state da_enable
Definition: at32f435_437_emac.h:616
emac_dma_config_type::fef_enable
confirm_state fef_enable
Definition: at32f435_437_emac.h:623
emac_dma_config_type::tx_threshold
emac_dma_transmit_threshold_type tx_threshold
Definition: at32f435_437_emac.h:622
emac_dma_config_type::fb_enable
confirm_state fb_enable
Definition: at32f435_437_emac.h:613
emac_dma_desc_type
dma desciptors data structure definition
Definition: at32f435_437_emac.h:632
emac_dma_desc_type::status
uint32_t status
Definition: at32f435_437_emac.h:633
emac_dma_desc_type::buf1addr
uint32_t buf1addr
Definition: at32f435_437_emac.h:635
emac_dma_desc_type::controlsize
uint32_t controlsize
Definition: at32f435_437_emac.h:634
emac_dma_desc_type::buf2nextdescaddr
uint32_t buf2nextdescaddr
Definition: at32f435_437_emac.h:636
emac_dma_type
type define emac ptp register all
Definition: at32f435_437_emac.h:1320
emac_dma_type::fbee
__IO uint32_t fbee
Definition: at32f435_437_emac.h:1476
emac_dma_type::rpd
__IO uint32_t rpd
Definition: at32f435_437_emac.h:1361
emac_dma_type::mfc
__IO uint32_t mfc
Definition: at32f435_437_emac.h:1492
emac_dma_type::ie
__IO uint32_t ie
Definition: at32f435_437_emac.h:1461
emac_dma_type::ssr
__IO uint32_t ssr
Definition: at32f435_437_emac.h:1436
emac_dma_type::ais
__IO uint32_t ais
Definition: at32f435_437_emac.h:1414
emac_dma_type::eie
__IO uint32_t eie
Definition: at32f435_437_emac.h:1474
emac_dma_type::tsf
__IO uint32_t tsf
Definition: at32f435_437_emac.h:1447
emac_dma_type::dt
__IO uint32_t dt
Definition: at32f435_437_emac.h:1451
emac_dma_type::tje
__IO uint32_t tje
Definition: at32f435_437_emac.h:1467
emac_dma_type::usp
__IO uint32_t usp
Definition: at32f435_437_emac.h:1337
emac_dma_type::rwt
__IO uint32_t rwt
Definition: at32f435_437_emac.h:1409
emac_dma_type::reserved5
__IO uint32_t reserved5
Definition: at32f435_437_emac.h:1448
emac_dma_type::pblx8
__IO uint32_t pblx8
Definition: at32f435_437_emac.h:1338
emac_dma_type::unf
__IO uint32_t unf
Definition: at32f435_437_emac.h:1405
emac_dma_type::da
__IO uint32_t da
Definition: at32f435_437_emac.h:1330
emac_dma_type::swr
__IO uint32_t swr
Definition: at32f435_437_emac.h:1329
emac_dma_type::rdladdr
__IO uint32_t rdladdr
Definition: at32f435_437_emac.h:1373
emac_dma_type::sts
__IO uint32_t sts
Definition: at32f435_437_emac.h:1397
emac_dma_type::obfoc
__IO uint32_t obfoc
Definition: at32f435_437_emac.h:1495
emac_dma_type::hrdap
__IO uint32_t hrdap
Definition: at32f435_437_emac.h:1525
emac_dma_type::rps
__IO uint32_t rps
Definition: at32f435_437_emac.h:1408
emac_dma_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_emac.h:1423
emac_dma_type::mpi
__IO uint32_t mpi
Definition: at32f435_437_emac.h:1421
emac_dma_type::obmfc
__IO uint32_t obmfc
Definition: at32f435_437_emac.h:1493
emac_dma_type::ftf
__IO uint32_t ftf
Definition: at32f435_437_emac.h:1446
emac_dma_type::nis
__IO uint32_t nis
Definition: at32f435_437_emac.h:1415
emac_dma_type::ere
__IO uint32_t ere
Definition: at32f435_437_emac.h:1477
emac_dma_type::crbaddr
__IO uint32_t crbaddr
Definition: at32f435_437_emac.h:1546
emac_dma_type::ctbaddr
__IO uint32_t ctbaddr
Definition: at32f435_437_emac.h:1534
emac_dma_type::tpd
__IO uint32_t tpd
Definition: at32f435_437_emac.h:1349
emac_dma_type::ove
__IO uint32_t ove
Definition: at32f435_437_emac.h:1468
emac_dma_type::rie
__IO uint32_t rie
Definition: at32f435_437_emac.h:1470
emac_dma_type::tie
__IO uint32_t tie
Definition: at32f435_437_emac.h:1464
emac_dma_type::tbu
__IO uint32_t tbu
Definition: at32f435_437_emac.h:1402
emac_dma_type::osf
__IO uint32_t osf
Definition: at32f435_437_emac.h:1437
emac_dma_type::pr
__IO uint32_t pr
Definition: at32f435_437_emac.h:1334
emac_dma_type::tjt
__IO uint32_t tjt
Definition: at32f435_437_emac.h:1403
emac_dma_type::pbl
__IO uint32_t pbl
Definition: at32f435_437_emac.h:1333
emac_dma_type::crd
__IO uint32_t crd
Definition: at32f435_437_emac.h:1522
emac_dma_type::fb
__IO uint32_t fb
Definition: at32f435_437_emac.h:1335
emac_dma_type::reserved6
__IO uint32_t reserved6
Definition: at32f435_437_emac.h:1452
emac_dma_type::tse
__IO uint32_t tse
Definition: at32f435_437_emac.h:1465
emac_dma_type::ofc
__IO uint32_t ofc
Definition: at32f435_437_emac.h:1494
emac_dma_type::eti
__IO uint32_t eti
Definition: at32f435_437_emac.h:1410
emac_dma_type::rwte
__IO uint32_t rwte
Definition: at32f435_437_emac.h:1473
emac_dma_type::sstc
__IO uint32_t sstc
Definition: at32f435_437_emac.h:1443
emac_dma_type::bm
__IO uint32_t bm
Definition: at32f435_437_emac.h:1326
emac_dma_type::rse
__IO uint32_t rse
Definition: at32f435_437_emac.h:1472
emac_dma_type::aab
__IO uint32_t aab
Definition: at32f435_437_emac.h:1339
emac_dma_type::opm
__IO uint32_t opm
Definition: at32f435_437_emac.h:1432
emac_dma_type::ri
__IO uint32_t ri
Definition: at32f435_437_emac.h:1406
emac_dma_type::stl
__IO uint32_t stl
Definition: at32f435_437_emac.h:1388
emac_dma_type::fef
__IO uint32_t fef
Definition: at32f435_437_emac.h:1441
emac_dma_type::rsf
__IO uint32_t rsf
Definition: at32f435_437_emac.h:1450
emac_dma_type::ttc
__IO uint32_t ttc
Definition: at32f435_437_emac.h:1444
emac_dma_type::dsl
__IO uint32_t dsl
Definition: at32f435_437_emac.h:1331
emac_dma_type::rbue
__IO uint32_t rbue
Definition: at32f435_437_emac.h:1471
emac_dma_type::mmi
__IO uint32_t mmi
Definition: at32f435_437_emac.h:1420
emac_dma_type::mfbocnt
__IO uint32_t mfbocnt
Definition: at32f435_437_emac.h:1489
emac_dma_type::hrbap
__IO uint32_t hrbap
Definition: at32f435_437_emac.h:1549
emac_dma_type::eri
__IO uint32_t eri
Definition: at32f435_437_emac.h:1413
emac_dma_type::tdladdr
__IO uint32_t tdladdr
Definition: at32f435_437_emac.h:1385
emac_dma_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_emac.h:1340
emac_dma_type::rdp
__IO uint32_t rdp
Definition: at32f435_437_emac.h:1336
emac_dma_type::htbap
__IO uint32_t htbap
Definition: at32f435_437_emac.h:1537
emac_dma_type::htdap
__IO uint32_t htdap
Definition: at32f435_437_emac.h:1513
emac_dma_type::rtc
__IO uint32_t rtc
Definition: at32f435_437_emac.h:1438
emac_dma_type::ti
__IO uint32_t ti
Definition: at32f435_437_emac.h:1400
emac_dma_type::srl
__IO uint32_t srl
Definition: at32f435_437_emac.h:1376
emac_dma_type::aie
__IO uint32_t aie
Definition: at32f435_437_emac.h:1478
emac_dma_type::nie
__IO uint32_t nie
Definition: at32f435_437_emac.h:1479
emac_dma_type::une
__IO uint32_t une
Definition: at32f435_437_emac.h:1469
emac_dma_type::reserved1
__IO uint32_t reserved1
emac dma reserved1 register, offset:0x1024~0x1044
Definition: at32f435_437_emac.h:1332
emac_dma_type::rbu
__IO uint32_t rbu
Definition: at32f435_437_emac.h:1407
emac_dma_type::tue
__IO uint32_t tue
Definition: at32f435_437_emac.h:1466
emac_dma_type::eb
__IO uint32_t eb
Definition: at32f435_437_emac.h:1418
emac_dma_type::tps
__IO uint32_t tps
Definition: at32f435_437_emac.h:1401
emac_dma_type::dfrf
__IO uint32_t dfrf
Definition: at32f435_437_emac.h:1449
emac_dma_type::fugf
__IO uint32_t fugf
Definition: at32f435_437_emac.h:1440
emac_dma_type::tti
__IO uint32_t tti
Definition: at32f435_437_emac.h:1422
emac_dma_type::ovf
__IO uint32_t ovf
Definition: at32f435_437_emac.h:1404
emac_dma_type::fbei
__IO uint32_t fbei
Definition: at32f435_437_emac.h:1412
emac_dma_type::ctd
__IO uint32_t ctd
Definition: at32f435_437_emac.h:1510
emac_dma_type::rs
__IO uint32_t rs
Definition: at32f435_437_emac.h:1416
emac_dma_type::reserved4
__IO uint32_t reserved4
Definition: at32f435_437_emac.h:1445
emac_dma_type::ts
__IO uint32_t ts
Definition: at32f435_437_emac.h:1417
emac_mmc_type
type define emac mmc register all
Definition: at32f435_437_emac.h:972
emac_mmc_type::tscgfci
__IO uint32_t tscgfci
Definition: at32f435_437_emac.h:1015
emac_mmc_type::reserved1
__IO uint32_t reserved1
emac mmc reserved1 register, offset:0x0114~0x0148
Definition: at32f435_437_emac.h:985
emac_mmc_type::rfaecnt
__IO uint32_t rfaecnt
Definition: at32f435_437_emac.h:1125
emac_mmc_type::tim
__IO uint32_t tim
Definition: at32f435_437_emac.h:1045
emac_mmc_type::tfmscc
__IO uint32_t tfmscc
Definition: at32f435_437_emac.h:1079
emac_mmc_type::rc
__IO uint32_t rc
Definition: at32f435_437_emac.h:981
emac_mmc_type::rgufc
__IO uint32_t rgufc
Definition: at32f435_437_emac.h:1145
emac_mmc_type::ctrl
__IO uint32_t ctrl
Definition: at32f435_437_emac.h:978
emac_mmc_type::rugfcim
__IO uint32_t rugfcim
Definition: at32f435_437_emac.h:1035
emac_mmc_type::tgfc
__IO uint32_t tgfc
Definition: at32f435_437_emac.h:1099
emac_mmc_type::raefacim
__IO uint32_t raefacim
Definition: at32f435_437_emac.h:1033
emac_mmc_type::tgfscc
__IO uint32_t tgfscc
Definition: at32f435_437_emac.h:1070
emac_mmc_type::rguf
__IO uint32_t rguf
Definition: at32f435_437_emac.h:1001
emac_mmc_type::rgufcnt
__IO uint32_t rgufcnt
Definition: at32f435_437_emac.h:1142
emac_mmc_type::rfae
__IO uint32_t rfae
Definition: at32f435_437_emac.h:999
emac_mmc_type::reserved2
__IO uint32_t reserved2
emac mmc reserved2 register, offset:0x0154~0x0164
Definition: at32f435_437_emac.h:1000
emac_mmc_type::ti
__IO uint32_t ti
Definition: at32f435_437_emac.h:1011
emac_mmc_type::tgfmscc
__IO uint32_t tgfmscc
Definition: at32f435_437_emac.h:1082
emac_mmc_type::tfscc
__IO uint32_t tfscc
Definition: at32f435_437_emac.h:1067
emac_mmc_type::reserved3
__IO uint32_t reserved3
emac mmc reserved3 register, offset:0x016C~0x0190
Definition: at32f435_437_emac.h:1002
emac_mmc_type::rfcec
__IO uint32_t rfcec
Definition: at32f435_437_emac.h:1116
emac_mmc_type::tscgfcim
__IO uint32_t tscgfcim
Definition: at32f435_437_emac.h:1049
emac_mmc_type::rfce
__IO uint32_t rfce
Definition: at32f435_437_emac.h:998
emac_mmc_type::tgf
__IO uint32_t tgf
Definition: at32f435_437_emac.h:1018
emac_mmc_type::tfcnt
__IO uint32_t tfcnt
Definition: at32f435_437_emac.h:1096
emac_mmc_type::fmc
__IO uint32_t fmc
Definition: at32f435_437_emac.h:984
emac_mmc_type::rfcecnt
__IO uint32_t rfcecnt
Definition: at32f435_437_emac.h:1113
emac_mmc_type::rfaec
__IO uint32_t rfaec
Definition: at32f435_437_emac.h:1128
emac_mmc_type::rr
__IO uint32_t rr
Definition: at32f435_437_emac.h:983
emac_mmc_type::ri
__IO uint32_t ri
Definition: at32f435_437_emac.h:994
emac_mmc_type::tgfcim
__IO uint32_t tgfcim
Definition: at32f435_437_emac.h:1052
emac_mmc_type::rcefcim
__IO uint32_t rcefcim
Definition: at32f435_437_emac.h:1032
emac_mmc_type::rim
__IO uint32_t rim
Definition: at32f435_437_emac.h:1028
emac_mmc_type::tgfmsc
__IO uint32_t tgfmsc
Definition: at32f435_437_emac.h:1016
emac_mmc_type::tmcgfcim
__IO uint32_t tmcgfcim
Definition: at32f435_437_emac.h:1050
emac_mmc_type::scr
__IO uint32_t scr
Definition: at32f435_437_emac.h:982
emac_ptp_type
type define emac ptp register all
Definition: at32f435_437_emac.h:1154
emac_ptp_type::reserved1
__IO uint32_t reserved1
emac ptp reserved register, offset:0x0724
Definition: at32f435_437_emac.h:1169
emac_ptp_type::tu
__IO uint32_t tu
Definition: at32f435_437_emac.h:1166
emac_ptp_type::sppfts
__IO uint32_t sppfts
Definition: at32f435_437_emac.h:1178
emac_ptp_type::te
__IO uint32_t te
Definition: at32f435_437_emac.h:1163
emac_ptp_type::ppscr
__IO uint32_t ppscr
Definition: at32f435_437_emac.h:1307
emac_ptp_type::tsad
__IO uint32_t tsad
Definition: at32f435_437_emac.h:1252
emac_ptp_type::etsfem
__IO uint32_t etsfem
Definition: at32f435_437_emac.h:1176
emac_ptp_type::tso
__IO uint32_t tso
Definition: at32f435_437_emac.h:1296
emac_ptp_type::ssiv
__IO uint32_t ssiv
Definition: at32f435_437_emac.h:1192
emac_ptp_type::eppef
__IO uint32_t eppef
Definition: at32f435_437_emac.h:1173
emac_ptp_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_emac.h:1180
emac_ptp_type::eppv2f
__IO uint32_t eppv2f
Definition: at32f435_437_emac.h:1172
emac_ptp_type::ttl
__IO uint32_t ttl
Definition: at32f435_437_emac.h:1276
emac_ptp_type::tslud
__IO uint32_t tslud
Definition: at32f435_437_emac.h:1239
emac_ptp_type::eppfsip6u
__IO uint32_t eppfsip6u
Definition: at32f435_437_emac.h:1174
emac_ptp_type::tshud
__IO uint32_t tshud
Definition: at32f435_437_emac.h:1227
emac_ptp_type::tss
__IO uint32_t tss
Definition: at32f435_437_emac.h:1217
emac_ptp_type::tfcu
__IO uint32_t tfcu
Definition: at32f435_437_emac.h:1164
emac_ptp_type::etaf
__IO uint32_t etaf
Definition: at32f435_437_emac.h:1170
emac_ptp_type::ti
__IO uint32_t ti
Definition: at32f435_437_emac.h:1165
emac_ptp_type::ttsr
__IO uint32_t ttsr
Definition: at32f435_437_emac.h:1267
emac_ptp_type::ast
__IO uint32_t ast
Definition: at32f435_437_emac.h:1218
emac_ptp_type::tite
__IO uint32_t tite
Definition: at32f435_437_emac.h:1167
emac_ptp_type::tar
__IO uint32_t tar
Definition: at32f435_437_emac.h:1255
emac_ptp_type::pofc
__IO uint32_t pofc
Definition: at32f435_437_emac.h:1310
emac_ptp_type::aru
__IO uint32_t aru
Definition: at32f435_437_emac.h:1168
emac_ptp_type::ttlr
__IO uint32_t ttlr
Definition: at32f435_437_emac.h:1279
emac_ptp_type::ssinc
__IO uint32_t ssinc
Definition: at32f435_437_emac.h:1189
emac_ptp_type::tsl
__IO uint32_t tsl
Definition: at32f435_437_emac.h:1214
emac_ptp_type::tdbrc
__IO uint32_t tdbrc
Definition: at32f435_437_emac.h:1171
emac_ptp_type::ts
__IO uint32_t ts
Definition: at32f435_437_emac.h:1205
emac_ptp_type::tsctrl
__IO uint32_t tsctrl
Definition: at32f435_437_emac.h:1160
emac_ptp_type::tsh
__IO uint32_t tsh
Definition: at32f435_437_emac.h:1202
emac_ptp_type::tttr
__IO uint32_t tttr
Definition: at32f435_437_emac.h:1297
emac_ptp_type::eppfsip4u
__IO uint32_t eppfsip4u
Definition: at32f435_437_emac.h:1175
emac_ptp_type::tth
__IO uint32_t tth
Definition: at32f435_437_emac.h:1264
emac_ptp_type::tssr
__IO uint32_t tssr
Definition: at32f435_437_emac.h:1293
emac_ptp_type::emafpff
__IO uint32_t emafpff
Definition: at32f435_437_emac.h:1179
emac_ptp_type::esfmrtm
__IO uint32_t esfmrtm
Definition: at32f435_437_emac.h:1177
emac_type
type define emac mac register all
Definition: at32f435_437_emac.h:643
emac_type::jd
__IO uint32_t jd
Definition: at32f435_437_emac.h:669
emac_type::reserved1
__IO uint32_t reserved1
emac mac reserved1 register, offset:0x20~0x24
Definition: at32f435_437_emac.h:652
emac_type::pd
__IO uint32_t pd
Definition: at32f435_437_emac.h:804
emac_type::a2l
__IO uint32_t a2l
Definition: at32f435_437_emac.h:932
emac_type::ma1h
__IO uint32_t ma1h
Definition: at32f435_437_emac.h:891
emac_type::mis
__IO uint32_t mis
Definition: at32f435_437_emac.h:832
emac_type::pmtctrlsts
__IO uint32_t pmtctrlsts
Definition: at32f435_437_emac.h:801
emac_type::pt
__IO uint32_t pt
Definition: at32f435_437_emac.h:768
emac_type::md
__IO uint32_t md
Definition: at32f435_437_emac.h:747
emac_type::erwf
__IO uint32_t erwf
Definition: at32f435_437_emac.h:806
emac_type::lm
__IO uint32_t lm
Definition: at32f435_437_emac.h:662
emac_type::etv
__IO uint32_t etv
Definition: at32f435_437_emac.h:781
emac_type::vlt
__IO uint32_t vlt
Definition: at32f435_437_emac.h:777
emac_type::dbf
__IO uint32_t dbf
Definition: at32f435_437_emac.h:688
emac_type::mris
__IO uint32_t mris
Definition: at32f435_437_emac.h:833
emac_type::ra
__IO uint32_t ra
Definition: at32f435_437_emac.h:694
emac_type::mw
__IO uint32_t mw
Definition: at32f435_437_emac.h:731
emac_type::pim
__IO uint32_t pim
Definition: at32f435_437_emac.h:850
emac_type::hpf
__IO uint32_t hpf
Definition: at32f435_437_emac.h:692
emac_type::mb
__IO uint32_t mb
Definition: at32f435_437_emac.h:730
emac_type::erf
__IO uint32_t erf
Definition: at32f435_437_emac.h:762
emac_type::a1h
__IO uint32_t a1h
Definition: at32f435_437_emac.h:888
emac_type::miiaddr
__IO uint32_t miiaddr
Definition: at32f435_437_emac.h:727
emac_type::ipc
__IO uint32_t ipc
Definition: at32f435_437_emac.h:660
emac_type::a0h
__IO uint32_t a0h
Definition: at32f435_437_emac.h:862
emac_type::acs
__IO uint32_t acs
Definition: at32f435_437_emac.h:657
emac_type::a1l
__IO uint32_t a1l
Definition: at32f435_437_emac.h:904
emac_type::rwffpr
__IO uint32_t rwffpr
Definition: at32f435_437_emac.h:813
emac_type::dzqp
__IO uint32_t dzqp
Definition: at32f435_437_emac.h:766
emac_type::vti
__IO uint32_t vti
Definition: at32f435_437_emac.h:780
emac_type::tim
__IO uint32_t tim
Definition: at32f435_437_emac.h:852
emac_type::fctrl
__IO uint32_t fctrl
Definition: at32f435_437_emac.h:757
emac_type::ma3h
__IO uint32_t ma3h
Definition: at32f435_437_emac.h:947
emac_type::saf
__IO uint32_t saf
Definition: at32f435_437_emac.h:691
emac_type::fcbbpa
__IO uint32_t fcbbpa
Definition: at32f435_437_emac.h:760
emac_type::cr
__IO uint32_t cr
Definition: at32f435_437_emac.h:732
emac_type::pmc
__IO uint32_t pmc
Definition: at32f435_437_emac.h:687
emac_type::dm
__IO uint32_t dm
Definition: at32f435_437_emac.h:661
emac_type::sa
__IO uint32_t sa
Definition: at32f435_437_emac.h:894
emac_type::pis
__IO uint32_t pis
Definition: at32f435_437_emac.h:831
emac_type::ists
__IO uint32_t ists
Definition: at32f435_437_emac.h:827
emac_type::emp
__IO uint32_t emp
Definition: at32f435_437_emac.h:805
emac_type::plt
__IO uint32_t plt
Definition: at32f435_437_emac.h:764
emac_type::ma2l
__IO uint32_t ma2l
Definition: at32f435_437_emac.h:935
emac_type::reserved2
__IO uint32_t reserved2
emac mac reserved2 register, offset:0x30~0x34
Definition: at32f435_437_emac.h:658
emac_type::guc
__IO uint32_t guc
Definition: at32f435_437_emac.h:811
emac_type::imr
__IO uint32_t imr
Definition: at32f435_437_emac.h:846
emac_type::ma0l
__IO uint32_t ma0l
Definition: at32f435_437_emac.h:879
emac_type::mbc
__IO uint32_t mbc
Definition: at32f435_437_emac.h:893
emac_type::ctrl
__IO uint32_t ctrl
Definition: at32f435_437_emac.h:649
emac_type::miidt
__IO uint32_t miidt
Definition: at32f435_437_emac.h:744
emac_type::pcf
__IO uint32_t pcf
Definition: at32f435_437_emac.h:689
emac_type::frmf
__IO uint32_t frmf
Definition: at32f435_437_emac.h:680
emac_type::bl
__IO uint32_t bl
Definition: at32f435_437_emac.h:656
emac_type::re
__IO uint32_t re
Definition: at32f435_437_emac.h:653
emac_type::reserved5
__IO uint32_t reserved5
Definition: at32f435_437_emac.h:671
emac_type::reserved4
__IO uint32_t reserved4
Definition: at32f435_437_emac.h:668
emac_type::ma2h
__IO uint32_t ma2h
Definition: at32f435_437_emac.h:919
emac_type::hth
__IO uint32_t hth
Definition: at32f435_437_emac.h:703
emac_type::etf
__IO uint32_t etf
Definition: at32f435_437_emac.h:761
emac_type::ma3l
__IO uint32_t ma3l
Definition: at32f435_437_emac.h:963
emac_type::a3h
__IO uint32_t a3h
Definition: at32f435_437_emac.h:944
emac_type::dr
__IO uint32_t dr
Definition: at32f435_437_emac.h:659
emac_type::daif
__IO uint32_t daif
Definition: at32f435_437_emac.h:686
emac_type::huc
__IO uint32_t huc
Definition: at32f435_437_emac.h:684
emac_type::ae
__IO uint32_t ae
Definition: at32f435_437_emac.h:867
emac_type::saif
__IO uint32_t saif
Definition: at32f435_437_emac.h:690
emac_type::te
__IO uint32_t te
Definition: at32f435_437_emac.h:654
emac_type::dro
__IO uint32_t dro
Definition: at32f435_437_emac.h:663
emac_type::mtis
__IO uint32_t mtis
Definition: at32f435_437_emac.h:834
emac_type::pa
__IO uint32_t pa
Definition: at32f435_437_emac.h:734
emac_type::ifg
__IO uint32_t ifg
Definition: at32f435_437_emac.h:667
emac_type::dc
__IO uint32_t dc
Definition: at32f435_437_emac.h:655
emac_type::rrwf
__IO uint32_t rrwf
Definition: at32f435_437_emac.h:809
emac_type::a2h
__IO uint32_t a2h
Definition: at32f435_437_emac.h:916
emac_type::a3l
__IO uint32_t a3l
Definition: at32f435_437_emac.h:960
emac_type::rmp
__IO uint32_t rmp
Definition: at32f435_437_emac.h:808
emac_type::mii
__IO uint32_t mii
Definition: at32f435_437_emac.h:733
emac_type::pr
__IO uint32_t pr
Definition: at32f435_437_emac.h:683
emac_type::htl
__IO uint32_t htl
Definition: at32f435_437_emac.h:715
emac_type::hmc
__IO uint32_t hmc
Definition: at32f435_437_emac.h:685
emac_type::a0l
__IO uint32_t a0l
Definition: at32f435_437_emac.h:876
emac_type::ma0h
__IO uint32_t ma0h
Definition: at32f435_437_emac.h:865
emac_type::ma1l
__IO uint32_t ma1l
Definition: at32f435_437_emac.h:907
emac_type::dcs
__IO uint32_t dcs
Definition: at32f435_437_emac.h:666
emac_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_emac.h:665
emac_type::tis
__IO uint32_t tis
Definition: at32f435_437_emac.h:836
emac_type::wd
__IO uint32_t wd
Definition: at32f435_437_emac.h:670
emac_type::dup
__IO uint32_t dup
Definition: at32f435_437_emac.h:763
emac_type::fes
__IO uint32_t fes
Definition: at32f435_437_emac.h:664
emac_type::rwff
__IO uint32_t rwff
emac mac rwff register, offset:0x28
Definition: at32f435_437_emac.h:794


AT32F435/437 Firmwary Library: at32f435_437_ertc.c Source File

  • libraries
  • drivers
  • src
at32f435_437_ertc.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef ERTC_MODULE_ENABLED
39
44#define ERTC_TIMEOUT ((uint32_t) 0x00360000)
45
51uint8_t ertc_num_to_bcd(uint8_t num)
52{
53 uint8_t bcd_h = 0, bcd_l = 0;
54
55 bcd_h = num / 10;
56 bcd_l = num % 10;
57
58 return ((uint8_t)(bcd_h << 4) | bcd_l);
59}
60
66uint8_t ertc_bcd_to_num(uint8_t bcd)
67{
68 return ((((uint8_t)(bcd & (uint8_t)0xF0) >> 4) * 10) + (bcd & (uint8_t)0x0F));
69}
70
76void ertc_write_protect_enable(void)
77{
78 ERTC->wp = 0xFF;
79}
80
86void ertc_write_protect_disable(void)
87{
88 ERTC->wp = 0xCA;
89 ERTC->wp = 0x53;
90}
91
97 error_status ertc_wait_update(void)
98{
99 uint32_t timeout = ERTC_TIMEOUT * 2;
100
101 /* disable write protection */
102 ertc_write_protect_disable();
103
104 /* clear updf flag */
105 ERTC->sts = ~(ERTC_UPDF_FLAG | 0x00000080) | (ERTC->sts_bit.imen << 7);
106
107 /* enable write protection */
108 ertc_write_protect_enable();
109
110 while(ERTC->sts_bit.updf == 0)
111 {
112 if(timeout == 0)
113 {
114 return ERROR;
115 }
116
117 timeout--;
118 }
119
120 return SUCCESS;
121}
122
138 error_status ertc_wait_flag(uint32_t flag, flag_status status)
139{
140 uint32_t timeout = ERTC_TIMEOUT;
141
142 while(ertc_flag_get(flag) == status)
143 {
144 if(timeout == 0)
145 {
146 /* enable write protection */
147 ertc_write_protect_enable();
148
149 return ERROR;
150 }
151
152 timeout--;
153 }
154
155 return SUCCESS;
156}
157
163 error_status ertc_init_mode_enter(void)
164{
165 uint32_t timeout = ERTC_TIMEOUT * 2;
166
167 /* disable write protection */
168 ertc_write_protect_disable();
169
170 if(ERTC->sts_bit.imf == 0)
171 {
172 /* enter init mode */
173 ERTC->sts = 0xFFFFFFFF;
174
175 while(ERTC->sts_bit.imf == 0)
176 {
177 if(timeout == 0)
178 {
179 /* enable write protection */
180 ertc_write_protect_enable();
181
182 return ERROR;
183 }
184
185 timeout--;
186 }
187 }
188
189 return SUCCESS;
190}
191
197void ertc_init_mode_exit(void)
198{
199 ERTC->sts = 0xFFFFFF7F;
200}
201
207 error_status ertc_reset(void)
208{
209 /* disable write protection */
210 ertc_write_protect_disable();
211
212 ERTC->ctrl = (uint32_t)0x00000000;
213
214 /* enter init mode */
215 if(ertc_init_mode_enter() != SUCCESS)
216 {
217 return ERROR;
218 }
219
220 /* reset register */
221 ERTC->time = (uint32_t)0x00000000;
222 ERTC->date = (uint32_t)0x00002101;
223 ERTC->ctrl = (uint32_t)0x00000000;
224 ERTC->div = (uint32_t)0x007F00FF;
225 ERTC->wat = (uint32_t)0x0000FFFF;
226 ERTC->ccal = (uint32_t)0x00000000;
227 ERTC->ala = (uint32_t)0x00000000;
228 ERTC->alb = (uint32_t)0x00000000;
229 ERTC->tadj = (uint32_t)0x00000000;
230 ERTC->scal = (uint32_t)0x00000000;
231 ERTC->tamp = (uint32_t)0x00000000;
232 ERTC->alasbs = (uint32_t)0x00000000;
233 ERTC->albsbs = (uint32_t)0x00000000;
234 ERTC->sts = (uint32_t)0x00000000;
235
236 /* wait calendar update */
237 ertc_wait_update();
238
239 /* enable write protection */
240 ertc_write_protect_enable();
241
242 return SUCCESS;
243}
244
251 error_status ertc_divider_set(uint16_t div_a, uint16_t div_b)
252{
253 /* disable write protection */
254 ertc_write_protect_disable();
255
256 /* enter init mode */
257 if(ertc_init_mode_enter() != SUCCESS)
258 {
259 return ERROR;
260 }
261
262 /* config the ertc divider */
263 ERTC->div_bit.diva = div_a;
264 ERTC->div_bit.divb = div_b;
265
266 /* exit init mode */
267 ertc_init_mode_exit();
268
269 /* enable write protection */
270 ertc_write_protect_enable();
271
272 return SUCCESS;
273}
274
283 error_status ertc_hour_mode_set(ertc_hour_mode_set_type mode)
284{
285 /* disable write protection */
286 ertc_write_protect_disable();
287
288 /* enter init mode */
289 if(ertc_init_mode_enter() != SUCCESS)
290 {
291 return ERROR;
292 }
293
294 /* write register */
295 ERTC->ctrl_bit.hm = mode;
296
297 /* exit init mode */
298 ertc_init_mode_exit();
299
300 /* enable write protection */
301 ertc_write_protect_enable();
302
303 return SUCCESS;
304}
305
314 error_status ertc_date_set(uint8_t year, uint8_t month, uint8_t date, uint8_t week)
315{
316 ertc_reg_date_type reg;
317
318 reg.date = 0;
319
320 reg.date_bit.y = ertc_num_to_bcd(year);
321 reg.date_bit.m = ertc_num_to_bcd(month);
322 reg.date_bit.d = ertc_num_to_bcd(date);
323 reg.date_bit.wk = week;
324
325 /* disable write protection */
326 ertc_write_protect_disable();
327
328 /* enter init mode */
329 if(ertc_init_mode_enter() != SUCCESS)
330 {
331 return ERROR;
332 }
333
334 /* Set the ertc_DR register */
335 ERTC->date = reg.date;
336
337 /* exit init mode */
338 ertc_init_mode_exit();
339
340 if(ERTC->ctrl_bit.dren == 0)
341 {
342 ertc_wait_update();
343 }
344
345 /* enable write protection */
346 ertc_write_protect_enable();
347
348 return SUCCESS;
349}
350
363 error_status ertc_time_set(uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
364{
365 ertc_reg_time_type reg;
366
367 reg.time = 0;
368
369 reg.time_bit.h = ertc_num_to_bcd(hour);
370 reg.time_bit.m = ertc_num_to_bcd(min);
371 reg.time_bit.s = ertc_num_to_bcd(sec);
372 reg.time_bit.ampm = ampm;
373
374 /* disable write protection */
375 ertc_write_protect_disable();
376
377 /* enter init mode */
378 if(ertc_init_mode_enter() != SUCCESS)
379 {
380 return ERROR;
381 }
382
383 ERTC->time = reg.time;
384
385 /* exit init mode */
386 ertc_init_mode_exit();
387
388 if(ERTC->ctrl_bit.dren == 0)
389 {
390 ertc_wait_update();
391 }
392
393 /* enable write protection */
394 ertc_write_protect_enable();
395
396 return SUCCESS;
397}
398
404void ertc_calendar_get(ertc_time_type* time)
405{
406 ertc_reg_time_type reg_tm;
407 ertc_reg_date_type reg_dt;
408
409 UNUSED(ERTC->sts);
410
411 reg_tm.time = ERTC->time;
412 reg_dt.date = ERTC->date;
413
414 time->hour = ertc_bcd_to_num(reg_tm.time_bit.h);
415 time->min = ertc_bcd_to_num(reg_tm.time_bit.m);
416 time->sec = ertc_bcd_to_num(reg_tm.time_bit.s);
417 time->ampm = (ertc_am_pm_type)reg_tm.time_bit.ampm;
418
419 time->year = ertc_bcd_to_num(reg_dt.date_bit.y);
420 time->month = ertc_bcd_to_num(reg_dt.date_bit.m);
421 time->day = ertc_bcd_to_num(reg_dt.date_bit.d);
422 time->week = reg_dt.date_bit.wk;
423}
424
430uint32_t ertc_sub_second_get(void)
431{
432 uint32_t reg = 0;
433
434 reg = ERTC->sbs;
435
436 (void) (ERTC->date);
437
438 return (reg);
439}
440
458void ertc_alarm_mask_set(ertc_alarm_type alarm_x, uint32_t mask)
459{
460 uint32_t reg;
461
462 /* disable write protection */
463 ertc_write_protect_disable();
464
465 if(alarm_x == ERTC_ALA)
466 {
467 reg = ERTC->ala;
468
469 reg &= ~ERTC_ALARM_MASK_ALL;
470 reg |= mask;
471
472 ERTC->ala= reg;
473 }
474 else
475 {
476 reg = ERTC->alb;
477
478 reg &= ~ERTC_ALARM_MASK_ALL;
479 reg |= mask;
480
481 ERTC->alb= reg;
482 }
483
484 /* enable write protection */
485 ertc_write_protect_enable();
486}
487
500void ertc_alarm_week_date_select(ertc_alarm_type alarm_x, ertc_week_date_select_type wk)
501{
502 /* disable write protection */
503 ertc_write_protect_disable();
504
505 if(alarm_x == ERTC_ALA)
506 {
507 ERTC->ala_bit.wksel = wk;
508 }
509 else
510 {
511 ERTC->alb_bit.wksel = wk;
512 }
513
514 /* enable write protection */
515 ertc_write_protect_enable();
516}
517
538void ertc_alarm_set(ertc_alarm_type alarm_x, uint8_t week_date, uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
539{
540 ertc_reg_alarm_type reg;
541
542 if(alarm_x == ERTC_ALA)
543 {
544 reg.ala = ERTC->ala;
545 }
546 else
547 {
548 reg.ala = ERTC->alb;
549 }
550
551 reg.ala_bit.d = ertc_num_to_bcd(week_date);
552 reg.ala_bit.h = ertc_num_to_bcd(hour);
553 reg.ala_bit.m = ertc_num_to_bcd(min);
554 reg.ala_bit.s = ertc_num_to_bcd(sec);
555 reg.ala_bit.ampm = ampm;
556
557 /* disable write protection */
558 ertc_write_protect_disable();
559
560 if(alarm_x == ERTC_ALA)
561 {
562 ERTC->ala= reg.ala;
563 }
564 else
565 {
566 ERTC->alb = reg.ala;
567 }
568
569 /* enable write protection */
570 ertc_write_protect_enable();
571}
572
600void ertc_alarm_sub_second_set(ertc_alarm_type alarm_x, uint32_t value, ertc_alarm_sbs_mask_type mask)
601{
602 /* disable write protection */
603 ertc_write_protect_disable();
604
605 if(alarm_x == ERTC_ALA)
606 {
607 ERTC->alasbs_bit.sbsmsk = mask;
608 ERTC->alasbs_bit.sbs = value;
609 }
610 else
611 {
612 ERTC->albsbs_bit.sbsmsk = mask;
613 ERTC->albsbs_bit.sbs = value;
614 }
615
616 /* enable write protection */
617 ertc_write_protect_enable();
618}
619
629 error_status ertc_alarm_enable(ertc_alarm_type alarm_x, confirm_state new_state)
630{
631 /* disable write protection */
632 ertc_write_protect_disable();
633
634 if(alarm_x == ERTC_ALA)
635 {
636 ERTC->ctrl_bit.alaen = new_state;
637
638 if(new_state == FALSE)
639 {
640 if(ertc_wait_flag(ERTC_ALAWF_FLAG, RESET) != SUCCESS)
641 {
642 return ERROR;
643 }
644 }
645 }
646 else
647 {
648 ERTC->ctrl_bit.alben = new_state;
649
650 if(new_state == FALSE)
651 {
652 if(ertc_wait_flag(ERTC_ALBWF_FLAG, RESET) != SUCCESS)
653 {
654 return ERROR;
655 }
656 }
657 }
658
659 /* enable write protection */
660 ertc_write_protect_enable();
661
662 return SUCCESS;
663}
664
674void ertc_alarm_get(ertc_alarm_type alarm_x, ertc_alarm_value_type* alarm)
675{
676 ertc_reg_alarm_type reg;
677
678 reg.ala = 0;
679
680 if(alarm_x == ERTC_ALA)
681 {
682 reg.ala = ERTC->ala;
683 }
684 else
685 {
686 reg.ala = ERTC->alb;
687 }
688
689 alarm->day = ertc_bcd_to_num(reg.ala_bit.d);
690 alarm->week = ertc_bcd_to_num(reg.ala_bit.d);
691 alarm->hour = ertc_bcd_to_num(reg.ala_bit.h);
692 alarm->min = ertc_bcd_to_num(reg.ala_bit.m);
693 alarm->sec = ertc_bcd_to_num(reg.ala_bit.s);
694 alarm->ampm = (ertc_am_pm_type)reg.ala_bit.ampm;
695 alarm->week_date_sel = reg.ala_bit.wksel;
696 alarm->mask = reg.ala & ERTC_ALARM_MASK_ALL;
697}
698
707uint32_t ertc_alarm_sub_second_get(ertc_alarm_type alarm_x)
708{
709 if(alarm_x == ERTC_ALA)
710 {
711 return (ERTC->alasbs_bit.sbs);
712 }
713 else
714 {
715 return (ERTC->albsbs_bit.sbs);
716 }
717}
718
731void ertc_wakeup_clock_set(ertc_wakeup_clock_type clock)
732{
733 /* disable write protection */
734 ertc_write_protect_disable();
735
736 ERTC->ctrl_bit.watclk = clock;
737
738 /* enable write protection */
739 ertc_write_protect_enable();
740}
741
747void ertc_wakeup_counter_set(uint32_t counter)
748{
749 /* disable write protection */
750 ertc_write_protect_disable();
751
752 ERTC->wat_bit.val = counter;
753
754 /* enable write protection */
755 ertc_write_protect_enable();
756}
757
763uint16_t ertc_wakeup_counter_get(void)
764{
765 return ERTC->wat_bit.val;
766}
767
773 error_status ertc_wakeup_enable(confirm_state new_state)
774{
775 /* disable write protection */
776 ertc_write_protect_disable();
777
778 ERTC->ctrl_bit.waten = new_state;
779
780 if(new_state == FALSE)
781 {
782 if(ertc_wait_flag(ERTC_WATWF_FLAG, RESET) != SUCCESS)
783 {
784 return ERROR;
785 }
786 }
787
788 /* enable write protection */
789 ertc_write_protect_enable();
790
791 return SUCCESS;
792}
793
808 error_status ertc_smooth_calibration_config(ertc_smooth_cal_period_type period, ertc_smooth_cal_clk_add_type clk_add, uint32_t clk_dec)
809{
810 ertc_reg_scal_type reg;
811
812 /* disable write protection */
813 ertc_write_protect_disable();
814
815 if(ertc_wait_flag(ERTC_CALUPDF_FLAG, SET) != SUCCESS)
816 {
817 return ERROR;
818 }
819
820 reg.scal = 0;
821
822 switch (period)
823 {
824 case ERTC_SMOOTH_CAL_PERIOD_32:
825 break;
826 case ERTC_SMOOTH_CAL_PERIOD_16:
827 reg.scal_bit.cal16 = 1;
828 break;
829 case ERTC_SMOOTH_CAL_PERIOD_8:
830 reg.scal_bit.cal8 = 1;
831 break;
832 default:
833 break;
834 }
835
836 reg.scal_bit.add = clk_add;
837 reg.scal_bit.dec = clk_dec;
838
839 ERTC->scal = reg.scal;
840
841 /* enable write protection */
842 ertc_write_protect_enable();
843
844 return SUCCESS;
845}
846
856 error_status ertc_coarse_calibration_set(ertc_cal_direction_type dir, uint32_t value)
857{
858 /* disable write protection */
859 ertc_write_protect_disable();
860
861 /* enter init mode */
862 if(ertc_init_mode_enter() == ERROR)
863 {
864 return ERROR;
865 }
866
867 ERTC->ccal_bit.caldir = dir;
868
869 ERTC->ccal_bit.calval = value;
870
871 /* exit init mode */
872 ertc_init_mode_exit();
873
874 /* enable write protection */
875 ertc_write_protect_enable();
876
877 return SUCCESS;
878}
879
885 error_status ertc_coarse_calibration_enable(confirm_state new_state)
886{
887 /* disable write protection */
888 ertc_write_protect_disable();
889
890 /* enter init mode */
891 if(ertc_init_mode_enter() == ERROR)
892 {
893 return ERROR;
894 }
895
896 ERTC->ctrl_bit.ccalen = new_state;
897
898 /* exit init mode */
899 ertc_init_mode_exit();
900
901 /* enable write protection */
902 ertc_write_protect_enable();
903
904 return SUCCESS;
905}
906
915void ertc_cal_output_select(ertc_cal_output_select_type output)
916{
917 /* disable write protection */
918 ertc_write_protect_disable();
919
920 ERTC->ctrl_bit.calosel = output;
921
922 /* enable write protection */
923 ertc_write_protect_enable();
924}
925
931void ertc_cal_output_enable(confirm_state new_state)
932{
933 /* disable write protection */
934 ertc_write_protect_disable();
935
936 ERTC->ctrl_bit.caloen = new_state;
937
938 /* enable write protection */
939 ertc_write_protect_enable();
940}
941
951 error_status ertc_time_adjust(ertc_time_adjust_type add1s, uint32_t decsbs)
952{
953 ertc_reg_tadj_type reg;
954
955 reg.tadj = 0;
956
957 /* disable write protection */
958 ertc_write_protect_disable();
959
960 if(ertc_wait_flag(ERTC_TADJF_FLAG, SET) != SUCCESS)
961 {
962 return ERROR;
963 }
964
965 /* check if the reference clock detection is disabled */
966 if(ERTC->ctrl_bit.rcden == 0)
967 {
968 reg.tadj_bit.add1s = add1s;
969 reg.tadj_bit.decsbs = decsbs;
970
971 ERTC->tadj = reg.tadj;
972
973 if(ertc_wait_update() == ERROR)
974 {
975 return ERROR;
976 }
977 }
978 else
979 {
980 return ERROR;
981 }
982
983 /* enable write protection */
984 ertc_write_protect_enable();
985
986 return SUCCESS;
987}
988
1001void ertc_daylight_set(ertc_dst_operation_type operation, ertc_dst_save_type save)
1002{
1003 /* disable write protection */
1004 ertc_write_protect_disable();
1005
1006 if(operation == ERTC_DST_ADD_1H)
1007 {
1008 ERTC->ctrl_bit.add1h = 1;
1009 }
1010 else
1011 {
1012 ERTC->ctrl_bit.dec1h = 1;
1013 }
1014
1015 ERTC->ctrl_bit.bpr = save;
1016
1017 /* enable write protection */
1018 ertc_write_protect_enable();
1019}
1020
1026uint8_t ertc_daylight_bpr_get(void)
1027{
1028 return ERTC->ctrl_bit.bpr;
1029}
1030
1036 error_status ertc_refer_clock_detect_enable(confirm_state new_state)
1037{
1038 /* disable write protection */
1039 ertc_write_protect_disable();
1040
1041 /* enter init mode */
1042 if(ertc_init_mode_enter() != SUCCESS)
1043 {
1044 return ERROR;
1045 }
1046
1047 /* write register */
1048 ERTC->ctrl_bit.rcden = new_state;
1049
1050 /* exit init mode */
1051 ertc_init_mode_exit();
1052
1053 /* enable write protection */
1054 ertc_write_protect_enable();
1055
1056 return SUCCESS;
1057}
1058
1064void ertc_direct_read_enable(confirm_state new_state)
1065{
1066 /* disable write protection */
1067 ertc_write_protect_disable();
1068
1069 ERTC->ctrl_bit.dren = new_state;
1070
1071 /* enable write protection */
1072 ertc_write_protect_enable();
1073}
1074
1093void ertc_output_set(ertc_output_source_type source, ertc_output_polarity_type polarity, ertc_output_type type)
1094{
1095 /* disable write protection */
1096 ertc_write_protect_disable();
1097
1098 ERTC->ctrl_bit.outp = polarity;
1099
1100 ERTC->tamp_bit.outtype = type;
1101
1102 ERTC->ctrl_bit.outsel = source;
1103
1104 /* enable write protection */
1105 ertc_write_protect_enable();
1106}
1107
1116void ertc_timestamp_pin_select(ertc_pin_select_type pin)
1117{
1118 /* disable write protection */
1119 ertc_write_protect_disable();
1120
1121 ERTC->tamp_bit.tspin = pin;
1122
1123 /* enable write protection */
1124 ertc_write_protect_enable();
1125}
1126
1135void ertc_timestamp_valid_edge_set(ertc_timestamp_valid_edge_type edge)
1136{
1137 /* disable write protection */
1138 ertc_write_protect_disable();
1139
1140 ERTC->ctrl_bit.tsedg = edge;
1141
1142 /* enable write protection */
1143 ertc_write_protect_enable();
1144}
1145
1151void ertc_timestamp_enable(confirm_state new_state)
1152{
1153 /* disable write protection */
1154 ertc_write_protect_disable();
1155
1156 ERTC->ctrl_bit.tsen = new_state;
1157
1158 /* enable write protection */
1159 ertc_write_protect_enable();
1160}
1161
1168void ertc_timestamp_get(ertc_time_type* time)
1169{
1170 ertc_reg_tstm_type tmtime;
1171 ertc_reg_tsdt_type tmdate;
1172
1173 tmtime.tstm = ERTC->tstm;
1174 tmdate.tsdt = ERTC->tsdt;
1175
1176 time->year = 0;
1177 time->month = ertc_bcd_to_num(tmdate.tsdt_bit.m);
1178 time->day = ertc_bcd_to_num(tmdate.tsdt_bit.d);
1179 time->week = ertc_bcd_to_num(tmdate.tsdt_bit.wk);
1180 time->hour = ertc_bcd_to_num(tmtime.tstm_bit.h);
1181 time->min = ertc_bcd_to_num(tmtime.tstm_bit.m);
1182 time->sec = ertc_bcd_to_num(tmtime.tstm_bit.s);
1183 time->ampm = (ertc_am_pm_type)tmtime.tstm_bit.ampm;
1184}
1185
1191uint32_t ertc_timestamp_sub_second_get(void)
1192{
1193 return ERTC->tssbs_bit.sbs;
1194}
1195
1204void ertc_tamper_1_pin_select(ertc_pin_select_type pin)
1205{
1206 /* disable write protection */
1207 ertc_write_protect_disable();
1208
1209 ERTC->tamp_bit.tp1pin = pin;
1210
1211 /* enable write protection */
1212 ertc_write_protect_enable();
1213}
1214
1220void ertc_tamper_pull_up_enable(confirm_state new_state)
1221{
1222 /* disable write protection */
1223 ertc_write_protect_disable();
1224
1225 ERTC->tamp_bit.tppu = !new_state;
1226
1227 /* enable write protection */
1228 ertc_write_protect_enable();
1229}
1230
1241void ertc_tamper_precharge_set(ertc_tamper_precharge_type precharge)
1242{
1243 /* disable write protection */
1244 ertc_write_protect_disable();
1245
1246 ERTC->tamp_bit.tppr = precharge;
1247
1248 /* enable write protection */
1249 ertc_write_protect_enable();
1250}
1251
1262void ertc_tamper_filter_set(ertc_tamper_filter_type filter)
1263{
1264 /* disable write protection */
1265 ertc_write_protect_disable();
1266
1267 ERTC->tamp_bit.tpflt = filter;
1268
1269 /* enable write protection */
1270 ertc_write_protect_enable();
1271}
1272
1287void ertc_tamper_detect_freq_set(ertc_tamper_detect_freq_type freq)
1288{
1289 /* disable write protection */
1290 ertc_write_protect_disable();
1291
1292 ERTC->tamp_bit.tpfreq = freq;
1293
1294 /* enable write protection */
1295 ertc_write_protect_enable();
1296}
1297
1313void ertc_tamper_valid_edge_set(ertc_tamper_select_type tamper_x, ertc_tamper_valid_edge_type trigger)
1314{
1315 /* disable write protection */
1316 ertc_write_protect_disable();
1317
1318 if(tamper_x == ERTC_TAMPER_1)
1319 {
1320 ERTC->tamp_bit.tp1edg = trigger;
1321 }
1322 else
1323 {
1324 ERTC->tamp_bit.tp2edg = trigger;
1325 }
1326
1327 /* enable write protection */
1328 ertc_write_protect_enable();
1329}
1330
1336void ertc_tamper_timestamp_enable(confirm_state new_state)
1337{
1338 /* disable write protection */
1339 ertc_write_protect_disable();
1340
1341 ERTC->tamp_bit.tptsen = new_state;
1342
1343 /* enable write protection */
1344 ertc_write_protect_enable();
1345}
1346
1356void ertc_tamper_enable(ertc_tamper_select_type tamper_x, confirm_state new_state)
1357{
1358 /* disable write protection */
1359 ertc_write_protect_disable();
1360
1361 if(tamper_x == ERTC_TAMPER_1)
1362 {
1363 ERTC->tamp_bit.tp1en = new_state;
1364 }
1365 else
1366 {
1367 ERTC->tamp_bit.tp2en = new_state;
1368 }
1369
1370 /* enable write protection */
1371 ertc_write_protect_enable();
1372}
1373
1386void ertc_interrupt_enable(uint32_t source, confirm_state new_state)
1387{
1388 /* disable write protection */
1389 ertc_write_protect_disable();
1390
1391 if(source & ERTC_TP_INT)
1392 {
1393 if(new_state != FALSE)
1394 {
1395 ERTC->tamp |= ERTC_TP_INT;
1396 }
1397 else
1398 {
1399 ERTC->tamp &= ~ERTC_TP_INT;
1400 }
1401
1402 source &= ~ERTC_TP_INT;
1403 }
1404
1405 if(new_state != FALSE)
1406 {
1407 ERTC->ctrl |= source;
1408 }
1409 else
1410 {
1411 ERTC->ctrl &= ~source;
1412 }
1413
1414 /* enable write protection */
1415 ertc_write_protect_enable();
1416}
1417
1429 flag_status ertc_interrupt_get(uint32_t source)
1430{
1431 if(source & ERTC_TP_INT)
1432 {
1433 if((ERTC->tamp & ERTC_TP_INT) != RESET)
1434 {
1435 return SET;
1436 }
1437 else
1438 {
1439 return RESET;
1440 }
1441 }
1442
1443 if((ERTC->ctrl & source) != RESET)
1444 {
1445 return SET;
1446 }
1447 else
1448 {
1449 return RESET;
1450 }
1451}
1452
1474 flag_status ertc_flag_get(uint32_t flag)
1475{
1476 if((ERTC->sts & flag) != (uint32_t)RESET)
1477 {
1478 return SET;
1479 }
1480 else
1481 {
1482 return RESET;
1483 }
1484}
1485
1507void ertc_flag_clear(uint32_t flag)
1508{
1509 ERTC->sts = ~(flag | 0x00000080) | (ERTC->sts_bit.imen << 7);
1510}
1511
1524void ertc_bpr_data_write(ertc_dt_type dt, uint32_t data)
1525{
1526 __IO uint32_t reg = 0;
1527
1528 reg = ERTC_BASE + 0x50 + (dt * 4);
1529
1530 /* disable write protection */
1531 ertc_write_protect_disable();
1532
1533 *(__IO uint32_t *)reg = data;
1534
1535 /* enable write protection */
1536 ertc_write_protect_enable();
1537}
1538
1550uint32_t ertc_bpr_data_read(ertc_dt_type dt)
1551{
1552 __IO uint32_t reg = 0;
1553
1554 reg = ERTC_BASE + 0x50 + (dt * 4);
1555
1556 return (*(__IO uint32_t *)reg);
1557}
1558
1563#endif
1564
UNUSED
#define UNUSED(x)
Definition: at32f435_437_def.h:65
counter
uint16_t counter
Definition: project/at_start_f435/examples/debug/tmr1/src/main.c:39
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
ERTC
#define ERTC
Definition: at32f435_437_ertc.h:1130
ertc_week_date_select_type
ertc_week_date_select_type
ertc week or date select
Definition: at32f435_437_ertc.h:134
ertc_cal_direction_type
ertc_cal_direction_type
ertc calibration direction mode
Definition: at32f435_437_ertc.h:207
ertc_smooth_cal_period_type
ertc_smooth_cal_period_type
ertc smooth calibration period
Definition: at32f435_437_ertc.h:188
ertc_tamper_valid_edge_type
ertc_tamper_valid_edge_type
ertc tamper valid edge
Definition: at32f435_437_ertc.h:345
ertc_output_type
ertc_output_type
output type
Definition: at32f435_437_ertc.h:272
ertc_cal_output_select_type
ertc_cal_output_select_type
ertc calibration output mode
Definition: at32f435_437_ertc.h:216
ertc_hour_mode_set_type
ertc_hour_mode_set_type
ertc hour mode
Definition: at32f435_437_ertc.h:115
ertc_wakeup_clock_type
ertc_wakeup_clock_type
ertc wakeup timer clock select
Definition: at32f435_437_ertc.h:175
ertc_tamper_precharge_type
ertc_tamper_precharge_type
tamper detection pre-charge time
Definition: at32f435_437_ertc.h:308
ertc_smooth_cal_clk_add_type
ertc_smooth_cal_clk_add_type
ertc smooth calibration clock add mode
Definition: at32f435_437_ertc.h:198
ertc_timestamp_valid_edge_type
ertc_timestamp_valid_edge_type
ertc timestamp valid edge
Definition: at32f435_437_ertc.h:290
ertc_tamper_select_type
ertc_tamper_select_type
ertc tamper x select
Definition: at32f435_437_ertc.h:299
ertc_tamper_filter_type
ertc_tamper_filter_type
ertc tamper filter
Definition: at32f435_437_ertc.h:319
ertc_dst_operation_type
ertc_dst_operation_type
ertc daylight saving time hour adjustment mode
Definition: at32f435_437_ertc.h:234
ertc_output_polarity_type
ertc_output_polarity_type
output polarity
Definition: at32f435_437_ertc.h:263
ertc_dt_type
ertc_dt_type
ertc bpr register
Definition: at32f435_437_ertc.h:356
ertc_dst_save_type
ertc_dst_save_type
ertc daylight saving time store operation mode
Definition: at32f435_437_ertc.h:243
ertc_output_source_type
ertc_output_source_type
output source
Definition: at32f435_437_ertc.h:252
ertc_tamper_detect_freq_type
ertc_tamper_detect_freq_type
ertc tamper detection frequency
Definition: at32f435_437_ertc.h:330
ertc_pin_select_type
ertc_pin_select_type
timestamp/ tamper detection pin selection
Definition: at32f435_437_ertc.h:281
ertc_alarm_type
ertc_alarm_type
ertc alarm x select
Definition: at32f435_437_ertc.h:143
ertc_am_pm_type
ertc_am_pm_type
ertc 12-hour format am/pm
Definition: at32f435_437_ertc.h:124
ertc_time_adjust_type
ertc_time_adjust_type
time adjust add mode
Definition: at32f435_437_ertc.h:225
ertc_alarm_sbs_mask_type
ertc_alarm_sbs_mask_type
ertc alarm sub second mask
Definition: at32f435_437_ertc.h:152
ERTC_SMOOTH_CAL_PERIOD_8
@ ERTC_SMOOTH_CAL_PERIOD_8
Definition: at32f435_437_ertc.h:191
ERTC_SMOOTH_CAL_PERIOD_32
@ ERTC_SMOOTH_CAL_PERIOD_32
Definition: at32f435_437_ertc.h:189
ERTC_SMOOTH_CAL_PERIOD_16
@ ERTC_SMOOTH_CAL_PERIOD_16
Definition: at32f435_437_ertc.h:190
ERTC_TAMPER_1
@ ERTC_TAMPER_1
Definition: at32f435_437_ertc.h:300
ERTC_DST_ADD_1H
@ ERTC_DST_ADD_1H
Definition: at32f435_437_ertc.h:235
ERTC_ALA
@ ERTC_ALA
Definition: at32f435_437_ertc.h:144
ERTC_ALARM_MASK_ALL
#define ERTC_ALARM_MASK_ALL
Definition: at32f435_437_ertc.h:91
ERTC_UPDF_FLAG
#define ERTC_UPDF_FLAG
Definition: at32f435_437_ertc.h:72
ERTC_ALBWF_FLAG
#define ERTC_ALBWF_FLAG
Definition: at32f435_437_ertc.h:68
ERTC_TADJF_FLAG
#define ERTC_TADJF_FLAG
Definition: at32f435_437_ertc.h:70
ERTC_WATWF_FLAG
#define ERTC_WATWF_FLAG
Definition: at32f435_437_ertc.h:69
ERTC_CALUPDF_FLAG
#define ERTC_CALUPDF_FLAG
Definition: at32f435_437_ertc.h:81
ERTC_ALAWF_FLAG
#define ERTC_ALAWF_FLAG
Definition: at32f435_437_ertc.h:67
ERTC_TP_INT
#define ERTC_TP_INT
Definition: at32f435_437_ertc.h:52
ertc_write_protect_enable
void ertc_write_protect_enable(void)
enable write protection.
Definition: at32f435_437_ertc.c:76
ertc_direct_read_enable
void ertc_direct_read_enable(confirm_state new_state)
enable or disable direct read mode.
Definition: at32f435_437_ertc.c:1064
ertc_daylight_set
void ertc_daylight_set(ertc_dst_operation_type operation, ertc_dst_save_type save)
config the daylight saving time.
Definition: at32f435_437_ertc.c:1001
ertc_alarm_get
void ertc_alarm_get(ertc_alarm_type alarm_x, ertc_alarm_value_type *alarm)
get alarm value.
Definition: at32f435_437_ertc.c:674
ertc_hour_mode_set
error_status ertc_hour_mode_set(ertc_hour_mode_set_type mode)
ertc hour mode set.
Definition: at32f435_437_ertc.c:283
ertc_wakeup_clock_set
void ertc_wakeup_clock_set(ertc_wakeup_clock_type clock)
set wakeup timer clock.
Definition: at32f435_437_ertc.c:731
ERTC_TIMEOUT
#define ERTC_TIMEOUT
Definition: at32f435_437_ertc.c:44
ertc_wait_update
error_status ertc_wait_update(void)
ertc wait register update finish.
Definition: at32f435_437_ertc.c:97
ertc_coarse_calibration_enable
error_status ertc_coarse_calibration_enable(confirm_state new_state)
enable or disable coarse calibration.
Definition: at32f435_437_ertc.c:885
ertc_sub_second_get
uint32_t ertc_sub_second_get(void)
get current sub second.
Definition: at32f435_437_ertc.c:430
ertc_wakeup_counter_set
void ertc_wakeup_counter_set(uint32_t counter)
set wakeup counter.
Definition: at32f435_437_ertc.c:747
ertc_bcd_to_num
uint8_t ertc_bcd_to_num(uint8_t bcd)
bcd code conversion to number.
Definition: at32f435_437_ertc.c:66
ertc_timestamp_valid_edge_set
void ertc_timestamp_valid_edge_set(ertc_timestamp_valid_edge_type edge)
set the timestamp valid edge.
Definition: at32f435_437_ertc.c:1135
ertc_flag_get
flag_status ertc_flag_get(uint32_t flag)
get flag status.
Definition: at32f435_437_ertc.c:1474
ertc_interrupt_get
flag_status ertc_interrupt_get(uint32_t source)
get interrupt status
Definition: at32f435_437_ertc.c:1429
ertc_time_set
error_status ertc_time_set(uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
set time.
Definition: at32f435_437_ertc.c:363
ertc_reset
error_status ertc_reset(void)
ertc reset all register.
Definition: at32f435_437_ertc.c:207
ertc_time_adjust
error_status ertc_time_adjust(ertc_time_adjust_type add1s, uint32_t decsbs)
adjust the time.
Definition: at32f435_437_ertc.c:951
ertc_tamper_timestamp_enable
void ertc_tamper_timestamp_enable(confirm_state new_state)
enable or disable trigger timestamp when tamper event occurs.
Definition: at32f435_437_ertc.c:1336
ertc_alarm_mask_set
void ertc_alarm_mask_set(ertc_alarm_type alarm_x, uint32_t mask)
set which bits are irrelevant to the alarm match.
Definition: at32f435_437_ertc.c:458
ertc_coarse_calibration_set
error_status ertc_coarse_calibration_set(ertc_cal_direction_type dir, uint32_t value)
set the coarse digital calibration.
Definition: at32f435_437_ertc.c:856
ertc_output_set
void ertc_output_set(ertc_output_source_type source, ertc_output_polarity_type polarity, ertc_output_type type)
set the output mode.
Definition: at32f435_437_ertc.c:1093
ertc_alarm_sub_second_get
uint32_t ertc_alarm_sub_second_get(ertc_alarm_type alarm_x)
get alarm sub second.
Definition: at32f435_437_ertc.c:707
ertc_interrupt_enable
void ertc_interrupt_enable(uint32_t source, confirm_state new_state)
enable or disable interrupt.
Definition: at32f435_437_ertc.c:1386
ertc_alarm_week_date_select
void ertc_alarm_week_date_select(ertc_alarm_type alarm_x, ertc_week_date_select_type wk)
alarm week or date mode select.
Definition: at32f435_437_ertc.c:500
ertc_tamper_1_pin_select
void ertc_tamper_1_pin_select(ertc_pin_select_type pin)
tamper 1 detection pin selection.
Definition: at32f435_437_ertc.c:1204
ertc_wakeup_enable
error_status ertc_wakeup_enable(confirm_state new_state)
enable or disable wakeup timer.
Definition: at32f435_437_ertc.c:773
ertc_date_set
error_status ertc_date_set(uint8_t year, uint8_t month, uint8_t date, uint8_t week)
set date.
Definition: at32f435_437_ertc.c:314
ertc_tamper_precharge_set
void ertc_tamper_precharge_set(ertc_tamper_precharge_type precharge)
set the tamper pin pre-charge time.
Definition: at32f435_437_ertc.c:1241
ertc_tamper_enable
void ertc_tamper_enable(ertc_tamper_select_type tamper_x, confirm_state new_state)
enable or disable tamper.
Definition: at32f435_437_ertc.c:1356
ertc_smooth_calibration_config
error_status ertc_smooth_calibration_config(ertc_smooth_cal_period_type period, ertc_smooth_cal_clk_add_type clk_add, uint32_t clk_dec)
config the smooth calibration.
Definition: at32f435_437_ertc.c:808
ertc_num_to_bcd
uint8_t ertc_num_to_bcd(uint8_t num)
number conversion to bcd code.
Definition: at32f435_437_ertc.c:51
ertc_flag_clear
void ertc_flag_clear(uint32_t flag)
clear flag status
Definition: at32f435_437_ertc.c:1507
ertc_refer_clock_detect_enable
error_status ertc_refer_clock_detect_enable(confirm_state new_state)
enable or disable refer clock detect.
Definition: at32f435_437_ertc.c:1036
ertc_wakeup_counter_get
uint16_t ertc_wakeup_counter_get(void)
get wakeup counter.
Definition: at32f435_437_ertc.c:763
ertc_init_mode_enter
error_status ertc_init_mode_enter(void)
ertc enter init mode.
Definition: at32f435_437_ertc.c:163
ertc_bpr_data_read
uint32_t ertc_bpr_data_read(ertc_dt_type dt)
read data from bpr register.
Definition: at32f435_437_ertc.c:1550
ertc_timestamp_get
void ertc_timestamp_get(ertc_time_type *time)
get the timestamp.
Definition: at32f435_437_ertc.c:1168
ertc_timestamp_sub_second_get
uint32_t ertc_timestamp_sub_second_get(void)
get the timestamp sub second.
Definition: at32f435_437_ertc.c:1191
ertc_timestamp_enable
void ertc_timestamp_enable(confirm_state new_state)
enable or disable timestamp.
Definition: at32f435_437_ertc.c:1151
ertc_tamper_pull_up_enable
void ertc_tamper_pull_up_enable(confirm_state new_state)
enable or disable tamper pin pull up.
Definition: at32f435_437_ertc.c:1220
ertc_tamper_filter_set
void ertc_tamper_filter_set(ertc_tamper_filter_type filter)
set the tamper filter time.
Definition: at32f435_437_ertc.c:1262
ertc_tamper_valid_edge_set
void ertc_tamper_valid_edge_set(ertc_tamper_select_type tamper_x, ertc_tamper_valid_edge_type trigger)
set the tamper trigger.
Definition: at32f435_437_ertc.c:1313
ertc_cal_output_enable
void ertc_cal_output_enable(confirm_state new_state)
enable or disable calibration output.
Definition: at32f435_437_ertc.c:931
ertc_alarm_set
void ertc_alarm_set(ertc_alarm_type alarm_x, uint8_t week_date, uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
set alarm.
Definition: at32f435_437_ertc.c:538
ertc_alarm_sub_second_set
void ertc_alarm_sub_second_set(ertc_alarm_type alarm_x, uint32_t value, ertc_alarm_sbs_mask_type mask)
set alarm sub second.
Definition: at32f435_437_ertc.c:600
ertc_calendar_get
void ertc_calendar_get(ertc_time_type *time)
get calendar
Definition: at32f435_437_ertc.c:404
ertc_wait_flag
error_status ertc_wait_flag(uint32_t flag, flag_status status)
ertc wait flag status.
Definition: at32f435_437_ertc.c:138
ertc_tamper_detect_freq_set
void ertc_tamper_detect_freq_set(ertc_tamper_detect_freq_type freq)
set the tamper detection frequency.
Definition: at32f435_437_ertc.c:1287
ertc_divider_set
error_status ertc_divider_set(uint16_t div_a, uint16_t div_b)
ertc division set.
Definition: at32f435_437_ertc.c:251
ertc_cal_output_select
void ertc_cal_output_select(ertc_cal_output_select_type output)
calibration output source select.
Definition: at32f435_437_ertc.c:915
ertc_timestamp_pin_select
void ertc_timestamp_pin_select(ertc_pin_select_type pin)
timestamp detection pin selection.
Definition: at32f435_437_ertc.c:1116
ertc_bpr_data_write
void ertc_bpr_data_write(ertc_dt_type dt, uint32_t data)
write data to the bpr register.
Definition: at32f435_437_ertc.c:1524
ertc_daylight_bpr_get
uint8_t ertc_daylight_bpr_get(void)
get the bpr value.
Definition: at32f435_437_ertc.c:1026
ertc_write_protect_disable
void ertc_write_protect_disable(void)
disable write protection.
Definition: at32f435_437_ertc.c:86
ertc_init_mode_exit
void ertc_init_mode_exit(void)
ertc exit init mode.
Definition: at32f435_437_ertc.c:197
ertc_alarm_enable
error_status ertc_alarm_enable(ertc_alarm_type alarm_x, confirm_state new_state)
enable or disable alarm clock.
Definition: at32f435_437_ertc.c:629
error_status
error_status
Definition: at32f435_437.h:380
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
time
ertc_time_type * time
Definition: random.c:41
ERTC_BASE
#define ERTC_BASE
Definition: at32f435_437.h:453
ertc_alarm_value_type
ertc alarm
Definition: at32f435_437_ertc.h:398
ertc_alarm_value_type::min
uint8_t min
Definition: at32f435_437_ertc.h:401
ertc_alarm_value_type::mask
uint32_t mask
Definition: at32f435_437_ertc.h:404
ertc_alarm_value_type::week_date_sel
uint8_t week_date_sel
Definition: at32f435_437_ertc.h:405
ertc_alarm_value_type::sec
uint8_t sec
Definition: at32f435_437_ertc.h:402
ertc_alarm_value_type::week
uint8_t week
Definition: at32f435_437_ertc.h:406
ertc_alarm_value_type::hour
uint8_t hour
Definition: at32f435_437_ertc.h:400
ertc_alarm_value_type::ampm
ertc_am_pm_type ampm
Definition: at32f435_437_ertc.h:403
ertc_alarm_value_type::day
uint8_t day
Definition: at32f435_437_ertc.h:399
ertc_time_type
ertc time
Definition: at32f435_437_ertc.h:383
ertc_time_type::ampm
ertc_am_pm_type ampm
Definition: at32f435_437_ertc.h:391
ertc_time_type::year
uint8_t year
Definition: at32f435_437_ertc.h:384
ertc_time_type::day
uint8_t day
Definition: at32f435_437_ertc.h:386
ertc_time_type::hour
uint8_t hour
Definition: at32f435_437_ertc.h:387
ertc_time_type::min
uint8_t min
Definition: at32f435_437_ertc.h:388
ertc_time_type::month
uint8_t month
Definition: at32f435_437_ertc.h:385
ertc_time_type::week
uint8_t week
Definition: at32f435_437_ertc.h:390
ertc_time_type::sec
uint8_t sec
Definition: at32f435_437_ertc.h:389
ertc_reg_alarm_type
ertc alarm reg union
Definition: at32f435_437_ertc.h:448
ertc_reg_alarm_type::ala_bit
struct ertc_reg_alarm_type::@608 ala_bit
ertc_reg_alarm_type::d
__IO uint32_t d
Definition: at32f435_437_ertc.h:459
ertc_reg_alarm_type::h
__IO uint32_t h
Definition: at32f435_437_ertc.h:456
ertc_reg_alarm_type::wksel
__IO uint32_t wksel
Definition: at32f435_437_ertc.h:460
ertc_reg_alarm_type::ala
__IO uint32_t ala
Definition: at32f435_437_ertc.h:449
ertc_reg_alarm_type::ampm
__IO uint32_t ampm
Definition: at32f435_437_ertc.h:457
ertc_reg_alarm_type::s
__IO uint32_t s
Definition: at32f435_437_ertc.h:452
ertc_reg_alarm_type::m
__IO uint32_t m
Definition: at32f435_437_ertc.h:454
ertc_reg_date_type
ertc date reg union
Definition: at32f435_437_ertc.h:431
ertc_reg_date_type::y
__IO uint32_t y
Definition: at32f435_437_ertc.h:439
ertc_reg_date_type::m
__IO uint32_t m
Definition: at32f435_437_ertc.h:437
ertc_reg_date_type::wk
__IO uint32_t wk
Definition: at32f435_437_ertc.h:438
ertc_reg_date_type::date_bit
struct ertc_reg_date_type::@607 date_bit
ertc_reg_date_type::date
__IO uint32_t date
Definition: at32f435_437_ertc.h:432
ertc_reg_date_type::d
__IO uint32_t d
Definition: at32f435_437_ertc.h:435
ertc_reg_scal_type
ertc scal reg union
Definition: at32f435_437_ertc.h:469
ertc_reg_scal_type::dec
__IO uint32_t dec
Definition: at32f435_437_ertc.h:473
ertc_reg_scal_type::cal8
__IO uint32_t cal8
Definition: at32f435_437_ertc.h:476
ertc_reg_scal_type::cal16
__IO uint32_t cal16
Definition: at32f435_437_ertc.h:475
ertc_reg_scal_type::scal
__IO uint32_t scal
Definition: at32f435_437_ertc.h:470
ertc_reg_scal_type::scal_bit
struct ertc_reg_scal_type::@609 scal_bit
ertc_reg_scal_type::add
__IO uint32_t add
Definition: at32f435_437_ertc.h:477
ertc_reg_tadj_type
ertc tadj reg union
Definition: at32f435_437_ertc.h:486
ertc_reg_tadj_type::tadj
__IO uint32_t tadj
Definition: at32f435_437_ertc.h:487
ertc_reg_tadj_type::decsbs
__IO uint32_t decsbs
Definition: at32f435_437_ertc.h:490
ertc_reg_tadj_type::add1s
__IO uint32_t add1s
Definition: at32f435_437_ertc.h:492
ertc_reg_tadj_type::tadj_bit
struct ertc_reg_tadj_type::@610 tadj_bit
ertc_reg_time_type
ertc time reg union
Definition: at32f435_437_ertc.h:413
ertc_reg_time_type::ampm
__IO uint32_t ampm
Definition: at32f435_437_ertc.h:422
ertc_reg_time_type::s
__IO uint32_t s
Definition: at32f435_437_ertc.h:417
ertc_reg_time_type::m
__IO uint32_t m
Definition: at32f435_437_ertc.h:419
ertc_reg_time_type::time_bit
struct ertc_reg_time_type::@606 time_bit
ertc_reg_time_type::time
__IO uint32_t time
Definition: at32f435_437_ertc.h:414
ertc_reg_time_type::h
__IO uint32_t h
Definition: at32f435_437_ertc.h:421
ertc_reg_tsdt_type
ertc tsdt register, offset:0x34
Definition: at32f435_437_ertc.h:518
ertc_reg_tsdt_type::tsdt_bit
struct ertc_reg_tsdt_type::@612 tsdt_bit
ertc_reg_tsdt_type::wk
__IO uint32_t wk
Definition: at32f435_437_ertc.h:525
ertc_reg_tsdt_type::d
__IO uint32_t d
Definition: at32f435_437_ertc.h:522
ertc_reg_tsdt_type::tsdt
__IO uint32_t tsdt
Definition: at32f435_437_ertc.h:519
ertc_reg_tsdt_type::m
__IO uint32_t m
Definition: at32f435_437_ertc.h:524
ertc_reg_tstm_type
ertc tstm reg union
Definition: at32f435_437_ertc.h:500
ertc_reg_tstm_type::s
__IO uint32_t s
Definition: at32f435_437_ertc.h:504
ertc_reg_tstm_type::ampm
__IO uint32_t ampm
Definition: at32f435_437_ertc.h:509
ertc_reg_tstm_type::m
__IO uint32_t m
Definition: at32f435_437_ertc.h:506
ertc_reg_tstm_type::h
__IO uint32_t h
Definition: at32f435_437_ertc.h:508
ertc_reg_tstm_type::tstm_bit
struct ertc_reg_tstm_type::@611 tstm_bit
ertc_reg_tstm_type::tstm
__IO uint32_t tstm
Definition: at32f435_437_ertc.h:501
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_ertc.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_ertc.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_ERTC_H
29#define __AT32F435_437_ERTC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
52#define ERTC_TP_INT ((uint32_t)0x00000004)
53#define ERTC_ALA_INT ((uint32_t)0x00001000)
54#define ERTC_ALB_INT ((uint32_t)0x00002000)
55#define ERTC_WAT_INT ((uint32_t)0x00004000)
56#define ERTC_TS_INT ((uint32_t)0x00008000)
67#define ERTC_ALAWF_FLAG ((uint32_t)0x00000001)
68#define ERTC_ALBWF_FLAG ((uint32_t)0x00000002)
69#define ERTC_WATWF_FLAG ((uint32_t)0x00000004)
70#define ERTC_TADJF_FLAG ((uint32_t)0x00000008)
71#define ERTC_INITF_FLAG ((uint32_t)0x00000010)
72#define ERTC_UPDF_FLAG ((uint32_t)0x00000020)
73#define ERTC_IMF_FLAG ((uint32_t)0x00000040)
74#define ERTC_ALAF_FLAG ((uint32_t)0x00000100)
75#define ERTC_ALBF_FLAG ((uint32_t)0x00000200)
76#define ERTC_WATF_FLAG ((uint32_t)0x00000400)
77#define ERTC_TSF_FLAG ((uint32_t)0x00000800)
78#define ERTC_TSOF_FLAG ((uint32_t)0x00001000)
79#define ERTC_TP1F_FLAG ((uint32_t)0x00002000)
80#define ERTC_TP2F_FLAG ((uint32_t)0x00004000)
81#define ERTC_CALUPDF_FLAG ((uint32_t)0x00010000)
86#define ERTC_ALARM_MASK_NONE ((uint32_t)0x00000000)
87#define ERTC_ALARM_MASK_SEC ((uint32_t)0x00000080)
88#define ERTC_ALARM_MASK_MIN ((uint32_t)0x00008000)
89#define ERTC_ALARM_MASK_HOUR ((uint32_t)0x00800000)
90#define ERTC_ALARM_MASK_DATE_WEEK ((uint32_t)0x80000000)
91#define ERTC_ALARM_MASK_ALL ((uint32_t)0x80808080)
100#define ERTC_WAT_CLK_CK_A_16BITS ERTC_WAT_CLK_CK_B_16BITS
101#define ERTC_WAT_CLK_CK_A_17BITS ERTC_WAT_CLK_CK_B_17BITS
102
114typedef enum
115{
116 ERTC_HOUR_MODE_24 = 0x00,
117 ERTC_HOUR_MODE_12 = 0x01
118} ertc_hour_mode_set_type;
119
123typedef enum
124{
125 ERTC_24H = 0x00,
126 ERTC_AM = 0x00,
127 ERTC_PM = 0x01
128} ertc_am_pm_type;
129
133typedef enum
134{
135 ERTC_SLECT_DATE = 0x00,
136 ERTC_SLECT_WEEK = 0x01
137} ertc_week_date_select_type;
138
142typedef enum
143{
144 ERTC_ALA = 0x00,
145 ERTC_ALB = 0x01
146} ertc_alarm_type;
147
151typedef enum
152{
153 ERTC_ALARM_SBS_MASK_ALL = 0x00,
154 ERTC_ALARM_SBS_MASK_14_1 = 0x01,
155 ERTC_ALARM_SBS_MASK_14_2 = 0x02,
156 ERTC_ALARM_SBS_MASK_14_3 = 0x03,
157 ERTC_ALARM_SBS_MASK_14_4 = 0x04,
158 ERTC_ALARM_SBS_MASK_14_5 = 0x05,
159 ERTC_ALARM_SBS_MASK_14_6 = 0x06,
160 ERTC_ALARM_SBS_MASK_14_7 = 0x07,
161 ERTC_ALARM_SBS_MASK_14_8 = 0x08,
162 ERTC_ALARM_SBS_MASK_14_9 = 0x09,
163 ERTC_ALARM_SBS_MASK_14_10 = 0x0A,
164 ERTC_ALARM_SBS_MASK_14_11 = 0x0B,
165 ERTC_ALARM_SBS_MASK_14_12 = 0x0C,
166 ERTC_ALARM_SBS_MASK_14_13 = 0x0D,
167 ERTC_ALARM_SBS_MASK_14 = 0x0E,
168 ERTC_ALARM_SBS_MASK_NONE = 0x0F
169} ertc_alarm_sbs_mask_type;
170
174typedef enum
175{
176 ERTC_WAT_CLK_ERTCCLK_DIV16 = 0x00,
177 ERTC_WAT_CLK_ERTCCLK_DIV8 = 0x01,
178 ERTC_WAT_CLK_ERTCCLK_DIV4 = 0x02,
179 ERTC_WAT_CLK_ERTCCLK_DIV2 = 0x03,
180 ERTC_WAT_CLK_CK_B_16BITS = 0x04,
181 ERTC_WAT_CLK_CK_B_17BITS = 0x06
182} ertc_wakeup_clock_type;
183
187typedef enum
188{
189 ERTC_SMOOTH_CAL_PERIOD_32 = 0x00,
190 ERTC_SMOOTH_CAL_PERIOD_16 = 0x01,
191 ERTC_SMOOTH_CAL_PERIOD_8 = 0x02
192} ertc_smooth_cal_period_type;
193
197typedef enum
198{
199 ERTC_SMOOTH_CAL_CLK_ADD_0 = 0x00,
200 ERTC_SMOOTH_CAL_CLK_ADD_512 = 0x01
201} ertc_smooth_cal_clk_add_type;
202
206typedef enum
207{
208 ERTC_CAL_DIR_POSITIVE = 0x00,
209 ERTC_CAL_DIR_NEGATIVE = 0x01
210} ertc_cal_direction_type;
211
215typedef enum
216{
217 ERTC_CAL_OUTPUT_512HZ = 0x00,
218 ERTC_CAL_OUTPUT_1HZ = 0x01
219} ertc_cal_output_select_type;
220
224typedef enum
225{
226 ERTC_TIME_ADD_NONE = 0x00,
227 ERTC_TIME_ADD_1S = 0x01
228} ertc_time_adjust_type;
229
233typedef enum
234{
235 ERTC_DST_ADD_1H = 0x00,
236 ERTC_DST_DEC_1H = 0x01
237} ertc_dst_operation_type;
238
242typedef enum
243{
244 ERTC_DST_SAVE_0 = 0x00,
245 ERTC_DST_SAVE_1 = 0x01
246} ertc_dst_save_type;
247
251typedef enum
252{
253 ERTC_OUTPUT_DISABLE = 0x00,
254 ERTC_OUTPUT_ALARM_A = 0x01,
255 ERTC_OUTPUT_ALARM_B = 0x02,
256 ERTC_OUTPUT_WAKEUP = 0x03
257} ertc_output_source_type;
258
262typedef enum
263{
264 ERTC_OUTPUT_POLARITY_HIGH = 0x00,
265 ERTC_OUTPUT_POLARITY_LOW = 0x01
266} ertc_output_polarity_type;
267
271typedef enum
272{
273 ERTC_OUTPUT_TYPE_OPEN_DRAIN = 0x00,
274 ERTC_OUTPUT_TYPE_PUSH_PULL = 0x01
275} ertc_output_type;
276
280typedef enum
281{
282 ERTC_PIN_PC13 = 0x00,
283 ERTC_PIN_PA0 = 0x01
284} ertc_pin_select_type;
285
289typedef enum
290{
291 ERTC_TIMESTAMP_EDGE_RISING = 0x00,
292 ERTC_TIMESTAMP_EDGE_FALLING = 0x01
293} ertc_timestamp_valid_edge_type;
294
298typedef enum
299{
300 ERTC_TAMPER_1 = 0x00,
301 ERTC_TAMPER_2 = 0x01
302} ertc_tamper_select_type;
303
307typedef enum
308{
309 ERTC_TAMPER_PR_1_ERTCCLK = 0x00,
310 ERTC_TAMPER_PR_2_ERTCCLK = 0x01,
311 ERTC_TAMPER_PR_4_ERTCCLK = 0x02,
312 ERTC_TAMPER_PR_8_ERTCCLK = 0x03
313} ertc_tamper_precharge_type;
314
318typedef enum
319{
320 ERTC_TAMPER_FILTER_DISABLE = 0x00,
321 ERTC_TAMPER_FILTER_2 = 0x01,
322 ERTC_TAMPER_FILTER_4 = 0x02,
323 ERTC_TAMPER_FILTER_8 = 0x03
324} ertc_tamper_filter_type;
325
329typedef enum
330{
331 ERTC_TAMPER_FREQ_DIV_32768 = 0x00,
332 ERTC_TAMPER_FREQ_DIV_16384 = 0x01,
333 ERTC_TAMPER_FREQ_DIV_8192 = 0x02,
334 ERTC_TAMPER_FREQ_DIV_4096 = 0x03,
335 ERTC_TAMPER_FREQ_DIV_2048 = 0x04,
336 ERTC_TAMPER_FREQ_DIV_1024 = 0x05,
337 ERTC_TAMPER_FREQ_DIV_512 = 0x06,
338 ERTC_TAMPER_FREQ_DIV_256 = 0x07
339} ertc_tamper_detect_freq_type;
340
344typedef enum
345{
346 ERTC_TAMPER_EDGE_RISING = 0x00,
347 ERTC_TAMPER_EDGE_FALLING = 0x01,
348 ERTC_TAMPER_EDGE_LOW = 0x00,
349 ERTC_TAMPER_EDGE_HIGH = 0x01
350} ertc_tamper_valid_edge_type;
351
355typedef enum
356{
357 ERTC_DT1 = 0,
358 ERTC_DT2 = 1,
359 ERTC_DT3 = 2,
360 ERTC_DT4 = 3,
361 ERTC_DT5 = 4,
362 ERTC_DT6 = 5,
363 ERTC_DT7 = 6,
364 ERTC_DT8 = 7,
365 ERTC_DT9 = 8,
366 ERTC_DT10 = 9,
367 ERTC_DT11 = 10,
368 ERTC_DT12 = 11,
369 ERTC_DT13 = 12,
370 ERTC_DT14 = 13,
371 ERTC_DT15 = 14,
372 ERTC_DT16 = 15,
373 ERTC_DT17 = 16,
374 ERTC_DT18 = 17,
375 ERTC_DT19 = 18,
376 ERTC_DT20 = 19
377} ertc_dt_type;
378
382typedef struct
383{
384 uint8_t year;
385 uint8_t month;
386 uint8_t day;
387 uint8_t hour;
388 uint8_t min;
389 uint8_t sec;
390 uint8_t week;
391 ertc_am_pm_type ampm;
392} ertc_time_type;
393
397typedef struct
398{
399 uint8_t day;
400 uint8_t hour;
401 uint8_t min;
402 uint8_t sec;
403 ertc_am_pm_type ampm;
404 uint32_t mask;
405 uint8_t week_date_sel;
406 uint8_t week;
407} ertc_alarm_value_type;
408
412typedef union
413{
414 __IO uint32_t time;
415 struct
416 {
417 __IO uint32_t s : 7; /* [6:0] */
418 __IO uint32_t reserved1 : 1; /* [7] */
419 __IO uint32_t m : 7; /* [14:8] */
420 __IO uint32_t reserved2 : 1; /* [15] */
421 __IO uint32_t h : 6; /* [21:16] */
422 __IO uint32_t ampm : 1; /* [22] */
423 __IO uint32_t reserved3 : 9; /* [31:23] */
424 } time_bit;
425} ertc_reg_time_type;
426
430typedef union
431{
432 __IO uint32_t date;
433 struct
434 {
435 __IO uint32_t d :6; /* [5:0] */
436 __IO uint32_t reserved1 :2; /* [7:6] */
437 __IO uint32_t m :5; /* [12:8] */
438 __IO uint32_t wk :3; /* [15:13] */
439 __IO uint32_t y :8; /* [23:16] */
440 __IO uint32_t reserved2 :8; /* [31:24] */
441 } date_bit;
442} ertc_reg_date_type;
443
447typedef union
448{
449 __IO uint32_t ala;
450 struct
451 {
452 __IO uint32_t s :7; /* [6:0] */
453 __IO uint32_t mask1 :1; /* [7] */
454 __IO uint32_t m :7; /* [14:8] */
455 __IO uint32_t mask2 :1; /* [15] */
456 __IO uint32_t h :6; /* [21:16] */
457 __IO uint32_t ampm :1; /* [22] */
458 __IO uint32_t mask3 :1; /* [23] */
459 __IO uint32_t d :6; /* [29:24] */
460 __IO uint32_t wksel :1; /* [30] */
461 __IO uint32_t mask4 :1; /* [31] */
462 } ala_bit;
463} ertc_reg_alarm_type;
464
468typedef union
469{
470 __IO uint32_t scal;
471 struct
472 {
473 __IO uint32_t dec :9; /* [8:0] */
474 __IO uint32_t reserved1 :4; /* [12:9] */
475 __IO uint32_t cal16 :1; /* [13] */
476 __IO uint32_t cal8 :1; /* [14] */
477 __IO uint32_t add :1; /* [15] */
478 __IO uint32_t reserved2 :16;/* [31:16] */
479 } scal_bit;
480} ertc_reg_scal_type;
481
485typedef union
486{
487 __IO uint32_t tadj;
488 struct
489 {
490 __IO uint32_t decsbs :15;/* [14:0] */
491 __IO uint32_t reserved1 :16;/* [30:15] */
492 __IO uint32_t add1s :1; /* [31] */
493 } tadj_bit;
494} ertc_reg_tadj_type;
495
499typedef union
500{
501 __IO uint32_t tstm;
502 struct
503 {
504 __IO uint32_t s :7; /* [6:0] */
505 __IO uint32_t reserved1 :1; /* [7] */
506 __IO uint32_t m :7; /* [14:8] */
507 __IO uint32_t reserved2 :1; /* [15] */
508 __IO uint32_t h :6; /* [21:16] */
509 __IO uint32_t ampm :1; /* [22] */
510 __IO uint32_t reserved3 :9; /* [31:23] */
511 } tstm_bit;
512} ertc_reg_tstm_type;
513
517typedef union
518{
519 __IO uint32_t tsdt;
520 struct
521 {
522 __IO uint32_t d :6; /* [5:0] */
523 __IO uint32_t reserved1 :2; /* [7:6] */
524 __IO uint32_t m :5; /* [12:8] */
525 __IO uint32_t wk :3; /* [15:13] */
526 __IO uint32_t reserved2 :16;/* [31:16] */
527 } tsdt_bit;
528} ertc_reg_tsdt_type;
529
533typedef struct
534{
535
539 union
540 {
541 __IO uint32_t time;
542 struct
543 {
544 __IO uint32_t s : 7; /* [6:0] */
545 __IO uint32_t reserved1 : 1; /* [7] */
546 __IO uint32_t m : 7; /* [14:8] */
547 __IO uint32_t reserved2 : 1; /* [15] */
548 __IO uint32_t h : 6; /* [21:16] */
549 __IO uint32_t ampm : 1; /* [22] */
550 __IO uint32_t reserved3 : 9; /* [31:23] */
551 } time_bit;
552 };
553
557 union
558 {
559 __IO uint32_t date;
560 struct
561 {
562 __IO uint32_t d :6; /* [5:0] */
563 __IO uint32_t reserved1 :2; /* [7:6] */
564 __IO uint32_t m :5; /* [12:8] */
565 __IO uint32_t wk :3; /* [15:13] */
566 __IO uint32_t y :8; /* [23:16] */
567 __IO uint32_t reserved2 :8; /* [31:24] */
568 } date_bit;
569 };
570
574 union
575 {
576 __IO uint32_t ctrl;
577 struct
578 {
579 __IO uint32_t watclk :3; /* [2:0] */
580 __IO uint32_t tsedg :1; /* [3] */
581 __IO uint32_t rcden :1; /* [4] */
582 __IO uint32_t dren :1; /* [5] */
583 __IO uint32_t hm :1; /* [6] */
584 __IO uint32_t ccalen :1; /* [7] */
585 __IO uint32_t alaen :1; /* [8] */
586 __IO uint32_t alben :1; /* [9] */
587 __IO uint32_t waten :1; /* [10] */
588 __IO uint32_t tsen :1; /* [11] */
589 __IO uint32_t alaien :1; /* [12] */
590 __IO uint32_t albien :1; /* [13] */
591 __IO uint32_t watien :1; /* [14] */
592 __IO uint32_t tsien :1; /* [15] */
593 __IO uint32_t add1h :1; /* [16] */
594 __IO uint32_t dec1h :1; /* [17] */
595 __IO uint32_t bpr :1; /* [18] */
596 __IO uint32_t calosel :1; /* [19] */
597 __IO uint32_t outp :1; /* [20] */
598 __IO uint32_t outsel :2; /* [22:21] */
599 __IO uint32_t caloen :1; /* [23] */
600 __IO uint32_t reserved1 :8; /* [31:24] */
601 } ctrl_bit;
602 };
603
607 union
608 {
609 __IO uint32_t sts;
610 struct
611 {
612 __IO uint32_t alawf :1; /* [0] */
613 __IO uint32_t albwf :1; /* [1] */
614 __IO uint32_t watwf :1; /* [2] */
615 __IO uint32_t tadjf :1; /* [3] */
616 __IO uint32_t initf :1; /* [4] */
617 __IO uint32_t updf :1; /* [5] */
618 __IO uint32_t imf :1; /* [6] */
619 __IO uint32_t imen :1; /* [7] */
620 __IO uint32_t alaf :1; /* [8] */
621 __IO uint32_t albf :1; /* [9] */
622 __IO uint32_t watf :1; /* [10] */
623 __IO uint32_t tsf :1; /* [11] */
624 __IO uint32_t tsof :1; /* [12] */
625 __IO uint32_t tp1f :1; /* [13] */
626 __IO uint32_t tp2f :1; /* [14] */
627 __IO uint32_t reserved1 :1; /* [15] */
628 __IO uint32_t calupdf :1; /* [16] */
629 __IO uint32_t reserved2 :15;/* [31:17] */
630 } sts_bit;
631 };
632
636 union
637 {
638 __IO uint32_t div;
639 struct
640 {
641 __IO uint32_t divb :15;/* [14:0] */
642 __IO uint32_t reserved1 :1; /* [15] */
643 __IO uint32_t diva :7; /* [22:16] */
644 __IO uint32_t reserved2 :9; /* [31:23] */
645 } div_bit;
646 };
647
651 union
652 {
653 __IO uint32_t wat;
654 struct
655 {
656 __IO uint32_t val :16;/* [15:0] */
657 __IO uint32_t reserved1 :16;/* [31:16] */
658 } wat_bit;
659 };
660
664 union
665 {
666 __IO uint32_t ccal;
667 struct
668 {
669 __IO uint32_t calval :5; /* [4:0] */
670 __IO uint32_t reserved1 :2; /* [6:5] */
671 __IO uint32_t caldir :1; /* [7] */
672 __IO uint32_t reserved2 :24;/* [31:8] */
673 } ccal_bit;
674 };
675
679 union
680 {
681 __IO uint32_t ala;
682 struct
683 {
684 __IO uint32_t s :7; /* [6:0] */
685 __IO uint32_t mask1 :1; /* [7] */
686 __IO uint32_t m :7; /* [14:8] */
687 __IO uint32_t mask2 :1; /* [15] */
688 __IO uint32_t h :6; /* [21:16] */
689 __IO uint32_t ampm :1; /* [22] */
690 __IO uint32_t mask3 :1; /* [23] */
691 __IO uint32_t d :6; /* [29:24] */
692 __IO uint32_t wksel :1; /* [30] */
693 __IO uint32_t mask4 :1; /* [31] */
694 } ala_bit;
695 };
696
700 union
701 {
702 __IO uint32_t alb;
703 struct
704 {
705 __IO uint32_t s :7; /* [6:0] */
706 __IO uint32_t mask1 :1; /* [7] */
707 __IO uint32_t m :7; /* [14:8] */
708 __IO uint32_t mask2 :1; /* [15] */
709 __IO uint32_t h :6; /* [21:16] */
710 __IO uint32_t ampm :1; /* [22] */
711 __IO uint32_t mask3 :1; /* [23] */
712 __IO uint32_t d :6; /* [29:24] */
713 __IO uint32_t wksel :1; /* [30] */
714 __IO uint32_t mask4 :1; /* [31] */
715 } alb_bit;
716 };
717
721 union
722 {
723 __IO uint32_t wp;
724 struct
725 {
726 __IO uint32_t cmd :8; /* [7:0] */
727 __IO uint32_t reserved1 :24;/* [31:8] */
728 } wp_bit;
729 };
730
734 union
735 {
736 __IO uint32_t sbs;
737 struct
738 {
739 __IO uint32_t sbs :16;/* [15:0] */
740 __IO uint32_t reserved1 :16;/* [31:16] */
741 } sbs_bit;
742 };
743
747 union
748 {
749 __IO uint32_t tadj;
750 struct
751 {
752 __IO uint32_t decsbs :15;/* [14:0] */
753 __IO uint32_t reserved1 :16;/* [30:15] */
754 __IO uint32_t add1s :1; /* [31] */
755 } tadj_bit;
756 };
757
761 union
762 {
763 __IO uint32_t tstm;
764 struct
765 {
766 __IO uint32_t s :7; /* [6:0] */
767 __IO uint32_t reserved1 :1; /* [7] */
768 __IO uint32_t m :7; /* [14:8] */
769 __IO uint32_t reserved2 :1; /* [15] */
770 __IO uint32_t h :6; /* [21:16] */
771 __IO uint32_t ampm :1; /* [22] */
772 __IO uint32_t reserved3 :9; /* [31:23] */
773 } tstm_bit;
774 };
775
779 union
780 {
781 __IO uint32_t tsdt;
782 struct
783 {
784 __IO uint32_t d :6; /* [5:0] */
785 __IO uint32_t reserved1 :2; /* [7:6] */
786 __IO uint32_t m :5; /* [12:8] */
787 __IO uint32_t wk :3; /* [15:13] */
788 __IO uint32_t reserved2 :16;/* [31:16] */
789 } tsdt_bit;
790 };
791
795 union
796 {
797 __IO uint32_t tssbs;
798 struct
799 {
800 __IO uint32_t sbs :16;/* [15:0] */
801 __IO uint32_t reserved1 :16;/* [31:16] */
802 } tssbs_bit;
803 };
804
808 union
809 {
810 __IO uint32_t scal;
811 struct
812 {
813 __IO uint32_t dec :9; /* [8:0] */
814 __IO uint32_t reserved1 :4; /* [12:9] */
815 __IO uint32_t cal16 :1; /* [13] */
816 __IO uint32_t cal8 :1; /* [14] */
817 __IO uint32_t add :1; /* [15] */
818 __IO uint32_t reserved2 :16;/* [31:16] */
819 } scal_bit;
820 };
821
825 union
826 {
827 __IO uint32_t tamp;
828 struct
829 {
830 __IO uint32_t tp1en :1; /* [0] */
831 __IO uint32_t tp1edg :1; /* [1] */
832 __IO uint32_t tpien :1; /* [2] */
833 __IO uint32_t tp2en :1; /* [3] */
834 __IO uint32_t tp2edg :1; /* [4] */
835 __IO uint32_t reserved1 :2; /* [6:5] */
836 __IO uint32_t tptsen :1; /* [7] */
837 __IO uint32_t tpfreq :3; /* [10:8] */
838 __IO uint32_t tpflt :2; /* [12:11] */
839 __IO uint32_t tppr :2; /* [14:13] */
840 __IO uint32_t tppu :1; /* [15] */
841 __IO uint32_t tp1pin :1; /* [16] */
842 __IO uint32_t tspin :1; /* [17] */
843 __IO uint32_t outtype :1; /* [18] */
844 __IO uint32_t reserved2 :13;/* [31:19] */
845 } tamp_bit;
846 };
847
851 union
852 {
853 __IO uint32_t alasbs;
854 struct
855 {
856 __IO uint32_t sbs :15;/* [14:0] */
857 __IO uint32_t reserved1 :9; /* [23:15] */
858 __IO uint32_t sbsmsk :4; /* [27:24] */
859 __IO uint32_t reserved2 :4; /* [31:28] */
860 } alasbs_bit;
861 };
862
866 union
867 {
868 __IO uint32_t albsbs;
869 struct
870 {
871 __IO uint32_t sbs :15;/* [14:0] */
872 __IO uint32_t reserved1 :9; /* [23:15] */
873 __IO uint32_t sbsmsk :4; /* [27:24] */
874 __IO uint32_t reserved2 :4; /* [31:28] */
875 } albsbs_bit;
876 };
877
881 __IO uint32_t reserved1;
882
886 union
887 {
888 __IO uint32_t dt1;
889 struct
890 {
891 __IO uint32_t dt :32;/* [31:0] */
892 } dt1_bit;
893 };
894
898 union
899 {
900 __IO uint32_t dt2;
901 struct
902 {
903 __IO uint32_t dt :32;/* [31:0] */
904 } dt2_bit;
905 };
906
910 union
911 {
912 __IO uint32_t dt3;
913 struct
914 {
915 __IO uint32_t dt :32;/* [31:0] */
916 } dt3_bit;
917 };
918
922 union
923 {
924 __IO uint32_t dt4;
925 struct
926 {
927 __IO uint32_t dt :32;/* [31:0] */
928 } dt4_bit;
929 };
930
934 union
935 {
936 __IO uint32_t dt5;
937 struct
938 {
939 __IO uint32_t dt :32;/* [31:0] */
940 } dt5_bit;
941 };
942
946 union
947 {
948 __IO uint32_t dt6;
949 struct
950 {
951 __IO uint32_t dt :32;/* [31:0] */
952 } dt6_bit;
953 };
954
958 union
959 {
960 __IO uint32_t dt7;
961 struct
962 {
963 __IO uint32_t dt :32;/* [31:0] */
964 } dt7_bit;
965 };
966
970 union
971 {
972 __IO uint32_t dt8;
973 struct
974 {
975 __IO uint32_t dt :32;/* [31:0] */
976 } dt8_bit;
977 };
978
982 union
983 {
984 __IO uint32_t dt9;
985 struct
986 {
987 __IO uint32_t dt :32;/* [31:0] */
988 } dt9_bit;
989 };
990
994 union
995 {
996 __IO uint32_t dt10;
997 struct
998 {
999 __IO uint32_t dt :32;/* [31:0] */
1000 } dt10_bit;
1001 };
1002
1006 union
1007 {
1008 __IO uint32_t dt11;
1009 struct
1010 {
1011 __IO uint32_t dt :32;/* [31:0] */
1012 } dt11_bit;
1013 };
1014
1018 union
1019 {
1020 __IO uint32_t dt12;
1021 struct
1022 {
1023 __IO uint32_t dt :32;/* [31:0] */
1024 } dt12_bit;
1025 };
1026
1030 union
1031 {
1032 __IO uint32_t dt13;
1033 struct
1034 {
1035 __IO uint32_t dt :32;/* [31:0] */
1036 } dt13_bit;
1037 };
1038
1042 union
1043 {
1044 __IO uint32_t dt14;
1045 struct
1046 {
1047 __IO uint32_t dt :32;/* [31:0] */
1048 } dt14_bit;
1049 };
1050
1054 union
1055 {
1056 __IO uint32_t dt15;
1057 struct
1058 {
1059 __IO uint32_t dt :32;/* [31:0] */
1060 } dt15_bit;
1061 };
1062
1066 union
1067 {
1068 __IO uint32_t dt16;
1069 struct
1070 {
1071 __IO uint32_t dt :32;/* [31:0] */
1072 } dt16_bit;
1073 };
1074
1078 union
1079 {
1080 __IO uint32_t dt17;
1081 struct
1082 {
1083 __IO uint32_t dt :32;/* [31:0] */
1084 } dt17_bit;
1085 };
1086
1090 union
1091 {
1092 __IO uint32_t dt18;
1093 struct
1094 {
1095 __IO uint32_t dt :32;/* [31:0] */
1096 } dt18_bit;
1097 };
1098
1102 union
1103 {
1104 __IO uint32_t dt19;
1105 struct
1106 {
1107 __IO uint32_t dt :32;/* [31:0] */
1108 } dt19_bit;
1109 };
1110
1114 union
1115 {
1116 __IO uint32_t dt20;
1117 struct
1118 {
1119 __IO uint32_t dt :32;/* [31:0] */
1120 } dt20_bit;
1121 };
1122
1123
1124} ertc_type;
1125
1130#define ERTC ((ertc_type *) ERTC_BASE)
1131
1136uint8_t ertc_num_to_bcd(uint8_t num);
1137uint8_t ertc_bcd_to_num(uint8_t bcd);
1138void ertc_write_protect_enable(void);
1139void ertc_write_protect_disable(void);
1140 error_status ertc_wait_update(void);
1141 error_status ertc_wait_flag(uint32_t flag, flag_status status);
1142 error_status ertc_init_mode_enter(void);
1143void ertc_init_mode_exit(void);
1144 error_status ertc_reset(void);
1145 error_status ertc_divider_set(uint16_t div_a, uint16_t div_b);
1146 error_status ertc_hour_mode_set(ertc_hour_mode_set_type mode);
1147 error_status ertc_date_set(uint8_t year, uint8_t month, uint8_t date, uint8_t week);
1148 error_status ertc_time_set(uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm);
1149void ertc_calendar_get(ertc_time_type* time);
1150uint32_t ertc_sub_second_get(void);
1151void ertc_alarm_mask_set(ertc_alarm_type alarm_x, uint32_t mask);
1152void ertc_alarm_week_date_select(ertc_alarm_type alarm_x, ertc_week_date_select_type wk);
1153void ertc_alarm_set(ertc_alarm_type alarm_x, uint8_t week_date, uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm);
1154void ertc_alarm_sub_second_set(ertc_alarm_type alarm_x, uint32_t value, ertc_alarm_sbs_mask_type mask);
1155 error_status ertc_alarm_enable(ertc_alarm_type alarm_x, confirm_state new_state);
1156void ertc_alarm_get(ertc_alarm_type alarm_x, ertc_alarm_value_type* alarm);
1157uint32_t ertc_alarm_sub_second_get(ertc_alarm_type alarm_x);
1158void ertc_wakeup_clock_set(ertc_wakeup_clock_type clock);
1159void ertc_wakeup_counter_set(uint32_t counter);
1160uint16_t ertc_wakeup_counter_get(void);
1161 error_status ertc_wakeup_enable(confirm_state new_state);
1162 error_status ertc_smooth_calibration_config(ertc_smooth_cal_period_type period, ertc_smooth_cal_clk_add_type clk_add, uint32_t clk_dec);
1163 error_status ertc_coarse_calibration_set(ertc_cal_direction_type dir, uint32_t value);
1164 error_status ertc_coarse_calibration_enable(confirm_state new_state);
1165void ertc_cal_output_select(ertc_cal_output_select_type output);
1166void ertc_cal_output_enable(confirm_state new_state);
1167 error_status ertc_time_adjust(ertc_time_adjust_type add1s, uint32_t decsbs);
1168void ertc_daylight_set(ertc_dst_operation_type operation, ertc_dst_save_type save);
1169uint8_t ertc_daylight_bpr_get(void);
1170 error_status ertc_refer_clock_detect_enable(confirm_state new_state);
1171void ertc_direct_read_enable(confirm_state new_state);
1172void ertc_output_set(ertc_output_source_type source, ertc_output_polarity_type polarity, ertc_output_type type);
1173void ertc_timestamp_pin_select(ertc_pin_select_type pin);
1174void ertc_timestamp_valid_edge_set(ertc_timestamp_valid_edge_type edge);
1175void ertc_timestamp_enable(confirm_state new_state);
1176void ertc_timestamp_get(ertc_time_type* time);
1177uint32_t ertc_timestamp_sub_second_get(void);
1178void ertc_tamper_1_pin_select(ertc_pin_select_type pin);
1179void ertc_tamper_pull_up_enable(confirm_state new_state);
1180void ertc_tamper_precharge_set(ertc_tamper_precharge_type precharge);
1181void ertc_tamper_filter_set(ertc_tamper_filter_type filter);
1182void ertc_tamper_detect_freq_set(ertc_tamper_detect_freq_type freq);
1183void ertc_tamper_valid_edge_set(ertc_tamper_select_type tamper_x, ertc_tamper_valid_edge_type trigger);
1184void ertc_tamper_timestamp_enable(confirm_state new_state);
1185void ertc_tamper_enable(ertc_tamper_select_type tamper_x, confirm_state new_state);
1186void ertc_interrupt_enable(uint32_t source, confirm_state new_state);
1187 flag_status ertc_interrupt_get(uint32_t source);
1188 flag_status ertc_flag_get(uint32_t flag);
1189void ertc_flag_clear(uint32_t flag);
1190void ertc_bpr_data_write(ertc_dt_type dt, uint32_t data);
1191uint32_t ertc_bpr_data_read(ertc_dt_type dt);
1192
1205#ifdef __cplusplus
1206}
1207#endif
1208
1209#endif
at32f435_437.h
at32f435_437 header file
counter
uint16_t counter
Definition: project/at_start_f435/examples/debug/tmr1/src/main.c:39
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
ertc_write_protect_enable
void ertc_write_protect_enable(void)
enable write protection.
Definition: at32f435_437_ertc.c:76
ertc_direct_read_enable
void ertc_direct_read_enable(confirm_state new_state)
enable or disable direct read mode.
Definition: at32f435_437_ertc.c:1064
ertc_daylight_set
void ertc_daylight_set(ertc_dst_operation_type operation, ertc_dst_save_type save)
config the daylight saving time.
Definition: at32f435_437_ertc.c:1001
ertc_alarm_get
void ertc_alarm_get(ertc_alarm_type alarm_x, ertc_alarm_value_type *alarm)
get alarm value.
Definition: at32f435_437_ertc.c:674
ertc_hour_mode_set
error_status ertc_hour_mode_set(ertc_hour_mode_set_type mode)
ertc hour mode set.
Definition: at32f435_437_ertc.c:283
ertc_wakeup_clock_set
void ertc_wakeup_clock_set(ertc_wakeup_clock_type clock)
set wakeup timer clock.
Definition: at32f435_437_ertc.c:731
ertc_wait_update
error_status ertc_wait_update(void)
ertc wait register update finish.
Definition: at32f435_437_ertc.c:97
ertc_coarse_calibration_enable
error_status ertc_coarse_calibration_enable(confirm_state new_state)
enable or disable coarse calibration.
Definition: at32f435_437_ertc.c:885
ertc_sub_second_get
uint32_t ertc_sub_second_get(void)
get current sub second.
Definition: at32f435_437_ertc.c:430
ertc_wakeup_counter_set
void ertc_wakeup_counter_set(uint32_t counter)
set wakeup counter.
Definition: at32f435_437_ertc.c:747
ertc_bcd_to_num
uint8_t ertc_bcd_to_num(uint8_t bcd)
bcd code conversion to number.
Definition: at32f435_437_ertc.c:66
ertc_timestamp_valid_edge_set
void ertc_timestamp_valid_edge_set(ertc_timestamp_valid_edge_type edge)
set the timestamp valid edge.
Definition: at32f435_437_ertc.c:1135
ertc_flag_get
flag_status ertc_flag_get(uint32_t flag)
get flag status.
Definition: at32f435_437_ertc.c:1474
ertc_interrupt_get
flag_status ertc_interrupt_get(uint32_t source)
get interrupt status
Definition: at32f435_437_ertc.c:1429
ertc_time_set
error_status ertc_time_set(uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
set time.
Definition: at32f435_437_ertc.c:363
ertc_reset
error_status ertc_reset(void)
ertc reset all register.
Definition: at32f435_437_ertc.c:207
ertc_time_adjust
error_status ertc_time_adjust(ertc_time_adjust_type add1s, uint32_t decsbs)
adjust the time.
Definition: at32f435_437_ertc.c:951
ertc_tamper_timestamp_enable
void ertc_tamper_timestamp_enable(confirm_state new_state)
enable or disable trigger timestamp when tamper event occurs.
Definition: at32f435_437_ertc.c:1336
ertc_alarm_mask_set
void ertc_alarm_mask_set(ertc_alarm_type alarm_x, uint32_t mask)
set which bits are irrelevant to the alarm match.
Definition: at32f435_437_ertc.c:458
ertc_coarse_calibration_set
error_status ertc_coarse_calibration_set(ertc_cal_direction_type dir, uint32_t value)
set the coarse digital calibration.
Definition: at32f435_437_ertc.c:856
ertc_output_set
void ertc_output_set(ertc_output_source_type source, ertc_output_polarity_type polarity, ertc_output_type type)
set the output mode.
Definition: at32f435_437_ertc.c:1093
ertc_alarm_sub_second_get
uint32_t ertc_alarm_sub_second_get(ertc_alarm_type alarm_x)
get alarm sub second.
Definition: at32f435_437_ertc.c:707
ertc_interrupt_enable
void ertc_interrupt_enable(uint32_t source, confirm_state new_state)
enable or disable interrupt.
Definition: at32f435_437_ertc.c:1386
ertc_alarm_week_date_select
void ertc_alarm_week_date_select(ertc_alarm_type alarm_x, ertc_week_date_select_type wk)
alarm week or date mode select.
Definition: at32f435_437_ertc.c:500
ertc_tamper_1_pin_select
void ertc_tamper_1_pin_select(ertc_pin_select_type pin)
tamper 1 detection pin selection.
Definition: at32f435_437_ertc.c:1204
ertc_wakeup_enable
error_status ertc_wakeup_enable(confirm_state new_state)
enable or disable wakeup timer.
Definition: at32f435_437_ertc.c:773
ertc_date_set
error_status ertc_date_set(uint8_t year, uint8_t month, uint8_t date, uint8_t week)
set date.
Definition: at32f435_437_ertc.c:314
ertc_tamper_precharge_set
void ertc_tamper_precharge_set(ertc_tamper_precharge_type precharge)
set the tamper pin pre-charge time.
Definition: at32f435_437_ertc.c:1241
ertc_tamper_enable
void ertc_tamper_enable(ertc_tamper_select_type tamper_x, confirm_state new_state)
enable or disable tamper.
Definition: at32f435_437_ertc.c:1356
ertc_smooth_calibration_config
error_status ertc_smooth_calibration_config(ertc_smooth_cal_period_type period, ertc_smooth_cal_clk_add_type clk_add, uint32_t clk_dec)
config the smooth calibration.
Definition: at32f435_437_ertc.c:808
ertc_num_to_bcd
uint8_t ertc_num_to_bcd(uint8_t num)
number conversion to bcd code.
Definition: at32f435_437_ertc.c:51
ertc_flag_clear
void ertc_flag_clear(uint32_t flag)
clear flag status
Definition: at32f435_437_ertc.c:1507
ertc_refer_clock_detect_enable
error_status ertc_refer_clock_detect_enable(confirm_state new_state)
enable or disable refer clock detect.
Definition: at32f435_437_ertc.c:1036
ertc_wakeup_counter_get
uint16_t ertc_wakeup_counter_get(void)
get wakeup counter.
Definition: at32f435_437_ertc.c:763
ertc_init_mode_enter
error_status ertc_init_mode_enter(void)
ertc enter init mode.
Definition: at32f435_437_ertc.c:163
ertc_bpr_data_read
uint32_t ertc_bpr_data_read(ertc_dt_type dt)
read data from bpr register.
Definition: at32f435_437_ertc.c:1550
ertc_timestamp_get
void ertc_timestamp_get(ertc_time_type *time)
get the timestamp.
Definition: at32f435_437_ertc.c:1168
ertc_timestamp_sub_second_get
uint32_t ertc_timestamp_sub_second_get(void)
get the timestamp sub second.
Definition: at32f435_437_ertc.c:1191
ertc_timestamp_enable
void ertc_timestamp_enable(confirm_state new_state)
enable or disable timestamp.
Definition: at32f435_437_ertc.c:1151
ertc_tamper_pull_up_enable
void ertc_tamper_pull_up_enable(confirm_state new_state)
enable or disable tamper pin pull up.
Definition: at32f435_437_ertc.c:1220
ertc_tamper_filter_set
void ertc_tamper_filter_set(ertc_tamper_filter_type filter)
set the tamper filter time.
Definition: at32f435_437_ertc.c:1262
ertc_tamper_valid_edge_set
void ertc_tamper_valid_edge_set(ertc_tamper_select_type tamper_x, ertc_tamper_valid_edge_type trigger)
set the tamper trigger.
Definition: at32f435_437_ertc.c:1313
ertc_cal_output_enable
void ertc_cal_output_enable(confirm_state new_state)
enable or disable calibration output.
Definition: at32f435_437_ertc.c:931
ertc_alarm_set
void ertc_alarm_set(ertc_alarm_type alarm_x, uint8_t week_date, uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
set alarm.
Definition: at32f435_437_ertc.c:538
ertc_alarm_sub_second_set
void ertc_alarm_sub_second_set(ertc_alarm_type alarm_x, uint32_t value, ertc_alarm_sbs_mask_type mask)
set alarm sub second.
Definition: at32f435_437_ertc.c:600
ertc_calendar_get
void ertc_calendar_get(ertc_time_type *time)
get calendar
Definition: at32f435_437_ertc.c:404
ertc_wait_flag
error_status ertc_wait_flag(uint32_t flag, flag_status status)
ertc wait flag status.
Definition: at32f435_437_ertc.c:138
ertc_tamper_detect_freq_set
void ertc_tamper_detect_freq_set(ertc_tamper_detect_freq_type freq)
set the tamper detection frequency.
Definition: at32f435_437_ertc.c:1287
ertc_divider_set
error_status ertc_divider_set(uint16_t div_a, uint16_t div_b)
ertc division set.
Definition: at32f435_437_ertc.c:251
ertc_cal_output_select
void ertc_cal_output_select(ertc_cal_output_select_type output)
calibration output source select.
Definition: at32f435_437_ertc.c:915
ertc_timestamp_pin_select
void ertc_timestamp_pin_select(ertc_pin_select_type pin)
timestamp detection pin selection.
Definition: at32f435_437_ertc.c:1116
ertc_bpr_data_write
void ertc_bpr_data_write(ertc_dt_type dt, uint32_t data)
write data to the bpr register.
Definition: at32f435_437_ertc.c:1524
ertc_daylight_bpr_get
uint8_t ertc_daylight_bpr_get(void)
get the bpr value.
Definition: at32f435_437_ertc.c:1026
ertc_write_protect_disable
void ertc_write_protect_disable(void)
disable write protection.
Definition: at32f435_437_ertc.c:86
ertc_init_mode_exit
void ertc_init_mode_exit(void)
ertc exit init mode.
Definition: at32f435_437_ertc.c:197
ertc_alarm_enable
error_status ertc_alarm_enable(ertc_alarm_type alarm_x, confirm_state new_state)
enable or disable alarm clock.
Definition: at32f435_437_ertc.c:629
ertc_week_date_select_type
ertc_week_date_select_type
ertc week or date select
Definition: at32f435_437_ertc.h:134
ertc_cal_direction_type
ertc_cal_direction_type
ertc calibration direction mode
Definition: at32f435_437_ertc.h:207
ertc_smooth_cal_period_type
ertc_smooth_cal_period_type
ertc smooth calibration period
Definition: at32f435_437_ertc.h:188
ertc_tamper_valid_edge_type
ertc_tamper_valid_edge_type
ertc tamper valid edge
Definition: at32f435_437_ertc.h:345
ertc_output_type
ertc_output_type
output type
Definition: at32f435_437_ertc.h:272
ertc_cal_output_select_type
ertc_cal_output_select_type
ertc calibration output mode
Definition: at32f435_437_ertc.h:216
ertc_hour_mode_set_type
ertc_hour_mode_set_type
ertc hour mode
Definition: at32f435_437_ertc.h:115
ertc_wakeup_clock_type
ertc_wakeup_clock_type
ertc wakeup timer clock select
Definition: at32f435_437_ertc.h:175
ertc_tamper_precharge_type
ertc_tamper_precharge_type
tamper detection pre-charge time
Definition: at32f435_437_ertc.h:308
ertc_smooth_cal_clk_add_type
ertc_smooth_cal_clk_add_type
ertc smooth calibration clock add mode
Definition: at32f435_437_ertc.h:198
ertc_timestamp_valid_edge_type
ertc_timestamp_valid_edge_type
ertc timestamp valid edge
Definition: at32f435_437_ertc.h:290
ertc_tamper_select_type
ertc_tamper_select_type
ertc tamper x select
Definition: at32f435_437_ertc.h:299
ertc_tamper_filter_type
ertc_tamper_filter_type
ertc tamper filter
Definition: at32f435_437_ertc.h:319
ertc_dst_operation_type
ertc_dst_operation_type
ertc daylight saving time hour adjustment mode
Definition: at32f435_437_ertc.h:234
ertc_output_polarity_type
ertc_output_polarity_type
output polarity
Definition: at32f435_437_ertc.h:263
ertc_dt_type
ertc_dt_type
ertc bpr register
Definition: at32f435_437_ertc.h:356
ertc_dst_save_type
ertc_dst_save_type
ertc daylight saving time store operation mode
Definition: at32f435_437_ertc.h:243
ertc_output_source_type
ertc_output_source_type
output source
Definition: at32f435_437_ertc.h:252
ertc_tamper_detect_freq_type
ertc_tamper_detect_freq_type
ertc tamper detection frequency
Definition: at32f435_437_ertc.h:330
ertc_pin_select_type
ertc_pin_select_type
timestamp/ tamper detection pin selection
Definition: at32f435_437_ertc.h:281
ertc_alarm_type
ertc_alarm_type
ertc alarm x select
Definition: at32f435_437_ertc.h:143
ertc_am_pm_type
ertc_am_pm_type
ertc 12-hour format am/pm
Definition: at32f435_437_ertc.h:124
ertc_time_adjust_type
ertc_time_adjust_type
time adjust add mode
Definition: at32f435_437_ertc.h:225
ertc_alarm_sbs_mask_type
ertc_alarm_sbs_mask_type
ertc alarm sub second mask
Definition: at32f435_437_ertc.h:152
ERTC_SLECT_WEEK
@ ERTC_SLECT_WEEK
Definition: at32f435_437_ertc.h:136
ERTC_SLECT_DATE
@ ERTC_SLECT_DATE
Definition: at32f435_437_ertc.h:135
ERTC_CAL_DIR_NEGATIVE
@ ERTC_CAL_DIR_NEGATIVE
Definition: at32f435_437_ertc.h:209
ERTC_CAL_DIR_POSITIVE
@ ERTC_CAL_DIR_POSITIVE
Definition: at32f435_437_ertc.h:208
ERTC_SMOOTH_CAL_PERIOD_8
@ ERTC_SMOOTH_CAL_PERIOD_8
Definition: at32f435_437_ertc.h:191
ERTC_SMOOTH_CAL_PERIOD_32
@ ERTC_SMOOTH_CAL_PERIOD_32
Definition: at32f435_437_ertc.h:189
ERTC_SMOOTH_CAL_PERIOD_16
@ ERTC_SMOOTH_CAL_PERIOD_16
Definition: at32f435_437_ertc.h:190
ERTC_TAMPER_EDGE_RISING
@ ERTC_TAMPER_EDGE_RISING
Definition: at32f435_437_ertc.h:346
ERTC_TAMPER_EDGE_LOW
@ ERTC_TAMPER_EDGE_LOW
Definition: at32f435_437_ertc.h:348
ERTC_TAMPER_EDGE_FALLING
@ ERTC_TAMPER_EDGE_FALLING
Definition: at32f435_437_ertc.h:347
ERTC_TAMPER_EDGE_HIGH
@ ERTC_TAMPER_EDGE_HIGH
Definition: at32f435_437_ertc.h:349
ERTC_OUTPUT_TYPE_OPEN_DRAIN
@ ERTC_OUTPUT_TYPE_OPEN_DRAIN
Definition: at32f435_437_ertc.h:273
ERTC_OUTPUT_TYPE_PUSH_PULL
@ ERTC_OUTPUT_TYPE_PUSH_PULL
Definition: at32f435_437_ertc.h:274
ERTC_CAL_OUTPUT_512HZ
@ ERTC_CAL_OUTPUT_512HZ
Definition: at32f435_437_ertc.h:217
ERTC_CAL_OUTPUT_1HZ
@ ERTC_CAL_OUTPUT_1HZ
Definition: at32f435_437_ertc.h:218
ERTC_HOUR_MODE_24
@ ERTC_HOUR_MODE_24
Definition: at32f435_437_ertc.h:116
ERTC_HOUR_MODE_12
@ ERTC_HOUR_MODE_12
Definition: at32f435_437_ertc.h:117
ERTC_WAT_CLK_ERTCCLK_DIV16
@ ERTC_WAT_CLK_ERTCCLK_DIV16
Definition: at32f435_437_ertc.h:176
ERTC_WAT_CLK_ERTCCLK_DIV4
@ ERTC_WAT_CLK_ERTCCLK_DIV4
Definition: at32f435_437_ertc.h:178
ERTC_WAT_CLK_CK_B_16BITS
@ ERTC_WAT_CLK_CK_B_16BITS
Definition: at32f435_437_ertc.h:180
ERTC_WAT_CLK_CK_B_17BITS
@ ERTC_WAT_CLK_CK_B_17BITS
Definition: at32f435_437_ertc.h:181
ERTC_WAT_CLK_ERTCCLK_DIV8
@ ERTC_WAT_CLK_ERTCCLK_DIV8
Definition: at32f435_437_ertc.h:177
ERTC_WAT_CLK_ERTCCLK_DIV2
@ ERTC_WAT_CLK_ERTCCLK_DIV2
Definition: at32f435_437_ertc.h:179
ERTC_TAMPER_PR_8_ERTCCLK
@ ERTC_TAMPER_PR_8_ERTCCLK
Definition: at32f435_437_ertc.h:312
ERTC_TAMPER_PR_4_ERTCCLK
@ ERTC_TAMPER_PR_4_ERTCCLK
Definition: at32f435_437_ertc.h:311
ERTC_TAMPER_PR_1_ERTCCLK
@ ERTC_TAMPER_PR_1_ERTCCLK
Definition: at32f435_437_ertc.h:309
ERTC_TAMPER_PR_2_ERTCCLK
@ ERTC_TAMPER_PR_2_ERTCCLK
Definition: at32f435_437_ertc.h:310
ERTC_SMOOTH_CAL_CLK_ADD_0
@ ERTC_SMOOTH_CAL_CLK_ADD_0
Definition: at32f435_437_ertc.h:199
ERTC_SMOOTH_CAL_CLK_ADD_512
@ ERTC_SMOOTH_CAL_CLK_ADD_512
Definition: at32f435_437_ertc.h:200
ERTC_TIMESTAMP_EDGE_RISING
@ ERTC_TIMESTAMP_EDGE_RISING
Definition: at32f435_437_ertc.h:291
ERTC_TIMESTAMP_EDGE_FALLING
@ ERTC_TIMESTAMP_EDGE_FALLING
Definition: at32f435_437_ertc.h:292
ERTC_TAMPER_1
@ ERTC_TAMPER_1
Definition: at32f435_437_ertc.h:300
ERTC_TAMPER_2
@ ERTC_TAMPER_2
Definition: at32f435_437_ertc.h:301
ERTC_TAMPER_FILTER_4
@ ERTC_TAMPER_FILTER_4
Definition: at32f435_437_ertc.h:322
ERTC_TAMPER_FILTER_8
@ ERTC_TAMPER_FILTER_8
Definition: at32f435_437_ertc.h:323
ERTC_TAMPER_FILTER_2
@ ERTC_TAMPER_FILTER_2
Definition: at32f435_437_ertc.h:321
ERTC_TAMPER_FILTER_DISABLE
@ ERTC_TAMPER_FILTER_DISABLE
Definition: at32f435_437_ertc.h:320
ERTC_DST_ADD_1H
@ ERTC_DST_ADD_1H
Definition: at32f435_437_ertc.h:235
ERTC_DST_DEC_1H
@ ERTC_DST_DEC_1H
Definition: at32f435_437_ertc.h:236
ERTC_OUTPUT_POLARITY_HIGH
@ ERTC_OUTPUT_POLARITY_HIGH
Definition: at32f435_437_ertc.h:264
ERTC_OUTPUT_POLARITY_LOW
@ ERTC_OUTPUT_POLARITY_LOW
Definition: at32f435_437_ertc.h:265
ERTC_DT11
@ ERTC_DT11
Definition: at32f435_437_ertc.h:367
ERTC_DT13
@ ERTC_DT13
Definition: at32f435_437_ertc.h:369
ERTC_DT2
@ ERTC_DT2
Definition: at32f435_437_ertc.h:358
ERTC_DT1
@ ERTC_DT1
Definition: at32f435_437_ertc.h:357
ERTC_DT15
@ ERTC_DT15
Definition: at32f435_437_ertc.h:371
ERTC_DT18
@ ERTC_DT18
Definition: at32f435_437_ertc.h:374
ERTC_DT19
@ ERTC_DT19
Definition: at32f435_437_ertc.h:375
ERTC_DT6
@ ERTC_DT6
Definition: at32f435_437_ertc.h:362
ERTC_DT7
@ ERTC_DT7
Definition: at32f435_437_ertc.h:363
ERTC_DT20
@ ERTC_DT20
Definition: at32f435_437_ertc.h:376
ERTC_DT17
@ ERTC_DT17
Definition: at32f435_437_ertc.h:373
ERTC_DT3
@ ERTC_DT3
Definition: at32f435_437_ertc.h:359
ERTC_DT4
@ ERTC_DT4
Definition: at32f435_437_ertc.h:360
ERTC_DT8
@ ERTC_DT8
Definition: at32f435_437_ertc.h:364
ERTC_DT5
@ ERTC_DT5
Definition: at32f435_437_ertc.h:361
ERTC_DT10
@ ERTC_DT10
Definition: at32f435_437_ertc.h:366
ERTC_DT9
@ ERTC_DT9
Definition: at32f435_437_ertc.h:365
ERTC_DT16
@ ERTC_DT16
Definition: at32f435_437_ertc.h:372
ERTC_DT12
@ ERTC_DT12
Definition: at32f435_437_ertc.h:368
ERTC_DT14
@ ERTC_DT14
Definition: at32f435_437_ertc.h:370
ERTC_DST_SAVE_0
@ ERTC_DST_SAVE_0
Definition: at32f435_437_ertc.h:244
ERTC_DST_SAVE_1
@ ERTC_DST_SAVE_1
Definition: at32f435_437_ertc.h:245
ERTC_OUTPUT_WAKEUP
@ ERTC_OUTPUT_WAKEUP
Definition: at32f435_437_ertc.h:256
ERTC_OUTPUT_ALARM_B
@ ERTC_OUTPUT_ALARM_B
Definition: at32f435_437_ertc.h:255
ERTC_OUTPUT_ALARM_A
@ ERTC_OUTPUT_ALARM_A
Definition: at32f435_437_ertc.h:254
ERTC_OUTPUT_DISABLE
@ ERTC_OUTPUT_DISABLE
Definition: at32f435_437_ertc.h:253
ERTC_TAMPER_FREQ_DIV_1024
@ ERTC_TAMPER_FREQ_DIV_1024
Definition: at32f435_437_ertc.h:336
ERTC_TAMPER_FREQ_DIV_32768
@ ERTC_TAMPER_FREQ_DIV_32768
Definition: at32f435_437_ertc.h:331
ERTC_TAMPER_FREQ_DIV_16384
@ ERTC_TAMPER_FREQ_DIV_16384
Definition: at32f435_437_ertc.h:332
ERTC_TAMPER_FREQ_DIV_512
@ ERTC_TAMPER_FREQ_DIV_512
Definition: at32f435_437_ertc.h:337
ERTC_TAMPER_FREQ_DIV_8192
@ ERTC_TAMPER_FREQ_DIV_8192
Definition: at32f435_437_ertc.h:333
ERTC_TAMPER_FREQ_DIV_4096
@ ERTC_TAMPER_FREQ_DIV_4096
Definition: at32f435_437_ertc.h:334
ERTC_TAMPER_FREQ_DIV_2048
@ ERTC_TAMPER_FREQ_DIV_2048
Definition: at32f435_437_ertc.h:335
ERTC_TAMPER_FREQ_DIV_256
@ ERTC_TAMPER_FREQ_DIV_256
Definition: at32f435_437_ertc.h:338
ERTC_PIN_PA0
@ ERTC_PIN_PA0
Definition: at32f435_437_ertc.h:283
ERTC_PIN_PC13
@ ERTC_PIN_PC13
Definition: at32f435_437_ertc.h:282
ERTC_ALB
@ ERTC_ALB
Definition: at32f435_437_ertc.h:145
ERTC_ALA
@ ERTC_ALA
Definition: at32f435_437_ertc.h:144
ERTC_AM
@ ERTC_AM
Definition: at32f435_437_ertc.h:126
ERTC_24H
@ ERTC_24H
Definition: at32f435_437_ertc.h:125
ERTC_PM
@ ERTC_PM
Definition: at32f435_437_ertc.h:127
ERTC_TIME_ADD_1S
@ ERTC_TIME_ADD_1S
Definition: at32f435_437_ertc.h:227
ERTC_TIME_ADD_NONE
@ ERTC_TIME_ADD_NONE
Definition: at32f435_437_ertc.h:226
ERTC_ALARM_SBS_MASK_14_12
@ ERTC_ALARM_SBS_MASK_14_12
Definition: at32f435_437_ertc.h:165
ERTC_ALARM_SBS_MASK_14_6
@ ERTC_ALARM_SBS_MASK_14_6
Definition: at32f435_437_ertc.h:159
ERTC_ALARM_SBS_MASK_14
@ ERTC_ALARM_SBS_MASK_14
Definition: at32f435_437_ertc.h:167
ERTC_ALARM_SBS_MASK_14_10
@ ERTC_ALARM_SBS_MASK_14_10
Definition: at32f435_437_ertc.h:163
ERTC_ALARM_SBS_MASK_14_9
@ ERTC_ALARM_SBS_MASK_14_9
Definition: at32f435_437_ertc.h:162
ERTC_ALARM_SBS_MASK_14_7
@ ERTC_ALARM_SBS_MASK_14_7
Definition: at32f435_437_ertc.h:160
ERTC_ALARM_SBS_MASK_NONE
@ ERTC_ALARM_SBS_MASK_NONE
Definition: at32f435_437_ertc.h:168
ERTC_ALARM_SBS_MASK_14_4
@ ERTC_ALARM_SBS_MASK_14_4
Definition: at32f435_437_ertc.h:157
ERTC_ALARM_SBS_MASK_14_3
@ ERTC_ALARM_SBS_MASK_14_3
Definition: at32f435_437_ertc.h:156
ERTC_ALARM_SBS_MASK_14_13
@ ERTC_ALARM_SBS_MASK_14_13
Definition: at32f435_437_ertc.h:166
ERTC_ALARM_SBS_MASK_14_5
@ ERTC_ALARM_SBS_MASK_14_5
Definition: at32f435_437_ertc.h:158
ERTC_ALARM_SBS_MASK_14_8
@ ERTC_ALARM_SBS_MASK_14_8
Definition: at32f435_437_ertc.h:161
ERTC_ALARM_SBS_MASK_ALL
@ ERTC_ALARM_SBS_MASK_ALL
Definition: at32f435_437_ertc.h:153
ERTC_ALARM_SBS_MASK_14_2
@ ERTC_ALARM_SBS_MASK_14_2
Definition: at32f435_437_ertc.h:155
ERTC_ALARM_SBS_MASK_14_11
@ ERTC_ALARM_SBS_MASK_14_11
Definition: at32f435_437_ertc.h:164
ERTC_ALARM_SBS_MASK_14_1
@ ERTC_ALARM_SBS_MASK_14_1
Definition: at32f435_437_ertc.h:154
error_status
error_status
Definition: at32f435_437.h:380
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
time
ertc_time_type * time
Definition: random.c:41
ertc_alarm_value_type
ertc alarm
Definition: at32f435_437_ertc.h:398
ertc_alarm_value_type::min
uint8_t min
Definition: at32f435_437_ertc.h:401
ertc_alarm_value_type::mask
uint32_t mask
Definition: at32f435_437_ertc.h:404
ertc_alarm_value_type::week_date_sel
uint8_t week_date_sel
Definition: at32f435_437_ertc.h:405
ertc_alarm_value_type::sec
uint8_t sec
Definition: at32f435_437_ertc.h:402
ertc_alarm_value_type::week
uint8_t week
Definition: at32f435_437_ertc.h:406
ertc_alarm_value_type::hour
uint8_t hour
Definition: at32f435_437_ertc.h:400
ertc_alarm_value_type::ampm
ertc_am_pm_type ampm
Definition: at32f435_437_ertc.h:403
ertc_alarm_value_type::day
uint8_t day
Definition: at32f435_437_ertc.h:399
ertc_time_type
ertc time
Definition: at32f435_437_ertc.h:383
ertc_time_type::ampm
ertc_am_pm_type ampm
Definition: at32f435_437_ertc.h:391
ertc_time_type::year
uint8_t year
Definition: at32f435_437_ertc.h:384
ertc_time_type::day
uint8_t day
Definition: at32f435_437_ertc.h:386
ertc_time_type::hour
uint8_t hour
Definition: at32f435_437_ertc.h:387
ertc_time_type::min
uint8_t min
Definition: at32f435_437_ertc.h:388
ertc_time_type::month
uint8_t month
Definition: at32f435_437_ertc.h:385
ertc_time_type::week
uint8_t week
Definition: at32f435_437_ertc.h:390
ertc_time_type::sec
uint8_t sec
Definition: at32f435_437_ertc.h:389
ertc_type
type define ertc register all
Definition: at32f435_437_ertc.h:534
ertc_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_ertc.h:550
ertc_type::dt6
__IO uint32_t dt6
Definition: at32f435_437_ertc.h:948
ertc_type::tsf
__IO uint32_t tsf
Definition: at32f435_437_ertc.h:623
ertc_type::imf
__IO uint32_t imf
Definition: at32f435_437_ertc.h:618
ertc_type::alben
__IO uint32_t alben
Definition: at32f435_437_ertc.h:586
ertc_type::alb
__IO uint32_t alb
Definition: at32f435_437_ertc.h:702
ertc_type::outtype
__IO uint32_t outtype
Definition: at32f435_437_ertc.h:843
ertc_type::dt14
__IO uint32_t dt14
Definition: at32f435_437_ertc.h:1044
ertc_type::waten
__IO uint32_t waten
Definition: at32f435_437_ertc.h:587
ertc_type::m
__IO uint32_t m
Definition: at32f435_437_ertc.h:546
ertc_type::tp2en
__IO uint32_t tp2en
Definition: at32f435_437_ertc.h:833
ertc_type::mask3
__IO uint32_t mask3
Definition: at32f435_437_ertc.h:690
ertc_type::calosel
__IO uint32_t calosel
Definition: at32f435_437_ertc.h:596
ertc_type::tssbs
__IO uint32_t tssbs
Definition: at32f435_437_ertc.h:797
ertc_type::albsbs
__IO uint32_t albsbs
Definition: at32f435_437_ertc.h:868
ertc_type::tppr
__IO uint32_t tppr
Definition: at32f435_437_ertc.h:839
ertc_type::dt20
__IO uint32_t dt20
Definition: at32f435_437_ertc.h:1116
ertc_type::tadjf
__IO uint32_t tadjf
Definition: at32f435_437_ertc.h:615
ertc_type::d
__IO uint32_t d
Definition: at32f435_437_ertc.h:562
ertc_type::wk
__IO uint32_t wk
Definition: at32f435_437_ertc.h:565
ertc_type::date
__IO uint32_t date
Definition: at32f435_437_ertc.h:559
ertc_type::tadj
__IO uint32_t tadj
Definition: at32f435_437_ertc.h:749
ertc_type::bpr
__IO uint32_t bpr
Definition: at32f435_437_ertc.h:595
ertc_type::ampm
__IO uint32_t ampm
Definition: at32f435_437_ertc.h:549
ertc_type::add1s
__IO uint32_t add1s
Definition: at32f435_437_ertc.h:754
ertc_type::add1h
__IO uint32_t add1h
Definition: at32f435_437_ertc.h:593
ertc_type::cal16
__IO uint32_t cal16
Definition: at32f435_437_ertc.h:815
ertc_type::tptsen
__IO uint32_t tptsen
Definition: at32f435_437_ertc.h:836
ertc_type::rcden
__IO uint32_t rcden
Definition: at32f435_437_ertc.h:581
ertc_type::tstm
__IO uint32_t tstm
Definition: at32f435_437_ertc.h:763
ertc_type::alaien
__IO uint32_t alaien
Definition: at32f435_437_ertc.h:589
ertc_type::ala
__IO uint32_t ala
Definition: at32f435_437_ertc.h:681
ertc_type::caloen
__IO uint32_t caloen
Definition: at32f435_437_ertc.h:599
ertc_type::outp
__IO uint32_t outp
Definition: at32f435_437_ertc.h:597
ertc_type::tp2f
__IO uint32_t tp2f
Definition: at32f435_437_ertc.h:626
ertc_type::dt18
__IO uint32_t dt18
Definition: at32f435_437_ertc.h:1092
ertc_type::dt9
__IO uint32_t dt9
Definition: at32f435_437_ertc.h:984
ertc_type::time
__IO uint32_t time
Definition: at32f435_437_ertc.h:541
ertc_type::mask1
__IO uint32_t mask1
Definition: at32f435_437_ertc.h:685
ertc_type::alasbs
__IO uint32_t alasbs
Definition: at32f435_437_ertc.h:853
ertc_type::mask2
__IO uint32_t mask2
Definition: at32f435_437_ertc.h:687
ertc_type::wp
__IO uint32_t wp
Definition: at32f435_437_ertc.h:723
ertc_type::watien
__IO uint32_t watien
Definition: at32f435_437_ertc.h:591
ertc_type::dt8
__IO uint32_t dt8
Definition: at32f435_437_ertc.h:972
ertc_type::tp1en
__IO uint32_t tp1en
Definition: at32f435_437_ertc.h:830
ertc_type::initf
__IO uint32_t initf
Definition: at32f435_437_ertc.h:616
ertc_type::dt15
__IO uint32_t dt15
Definition: at32f435_437_ertc.h:1056
ertc_type::tspin
__IO uint32_t tspin
Definition: at32f435_437_ertc.h:842
ertc_type::wat
__IO uint32_t wat
Definition: at32f435_437_ertc.h:653
ertc_type::scal
__IO uint32_t scal
Definition: at32f435_437_ertc.h:810
ertc_type::reserved1
__IO uint32_t reserved1
reserved register, offset:0x4c
Definition: at32f435_437_ertc.h:545
ertc_type::tppu
__IO uint32_t tppu
Definition: at32f435_437_ertc.h:840
ertc_type::dt17
__IO uint32_t dt17
Definition: at32f435_437_ertc.h:1080
ertc_type::dt1
__IO uint32_t dt1
Definition: at32f435_437_ertc.h:888
ertc_type::tpfreq
__IO uint32_t tpfreq
Definition: at32f435_437_ertc.h:837
ertc_type::calupdf
__IO uint32_t calupdf
Definition: at32f435_437_ertc.h:628
ertc_type::alaen
__IO uint32_t alaen
Definition: at32f435_437_ertc.h:585
ertc_type::sts
__IO uint32_t sts
Definition: at32f435_437_ertc.h:609
ertc_type::divb
__IO uint32_t divb
Definition: at32f435_437_ertc.h:641
ertc_type::dec
__IO uint32_t dec
Definition: at32f435_437_ertc.h:813
ertc_type::dren
__IO uint32_t dren
Definition: at32f435_437_ertc.h:582
ertc_type::mask4
__IO uint32_t mask4
Definition: at32f435_437_ertc.h:693
ertc_type::hm
__IO uint32_t hm
Definition: at32f435_437_ertc.h:583
ertc_type::dt3
__IO uint32_t dt3
Definition: at32f435_437_ertc.h:912
ertc_type::dt2
__IO uint32_t dt2
Definition: at32f435_437_ertc.h:900
ertc_type::dt19
__IO uint32_t dt19
Definition: at32f435_437_ertc.h:1104
ertc_type::dt
__IO uint32_t dt
Definition: at32f435_437_ertc.h:891
ertc_type::tp2edg
__IO uint32_t tp2edg
Definition: at32f435_437_ertc.h:834
ertc_type::tp1pin
__IO uint32_t tp1pin
Definition: at32f435_437_ertc.h:841
ertc_type::sbs
__IO uint32_t sbs
Definition: at32f435_437_ertc.h:736
ertc_type::ctrl
__IO uint32_t ctrl
Definition: at32f435_437_ertc.h:576
ertc_type::watf
__IO uint32_t watf
Definition: at32f435_437_ertc.h:622
ertc_type::tsof
__IO uint32_t tsof
Definition: at32f435_437_ertc.h:624
ertc_type::imen
__IO uint32_t imen
Definition: at32f435_437_ertc.h:619
ertc_type::decsbs
__IO uint32_t decsbs
Definition: at32f435_437_ertc.h:752
ertc_type::dt11
__IO uint32_t dt11
Definition: at32f435_437_ertc.h:1008
ertc_type::dt7
__IO uint32_t dt7
Definition: at32f435_437_ertc.h:960
ertc_type::watclk
__IO uint32_t watclk
Definition: at32f435_437_ertc.h:579
ertc_type::dt10
__IO uint32_t dt10
Definition: at32f435_437_ertc.h:996
ertc_type::s
__IO uint32_t s
Definition: at32f435_437_ertc.h:544
ertc_type::watwf
__IO uint32_t watwf
Definition: at32f435_437_ertc.h:614
ertc_type::tsedg
__IO uint32_t tsedg
Definition: at32f435_437_ertc.h:580
ertc_type::tp1edg
__IO uint32_t tp1edg
Definition: at32f435_437_ertc.h:831
ertc_type::diva
__IO uint32_t diva
Definition: at32f435_437_ertc.h:643
ertc_type::dt16
__IO uint32_t dt16
Definition: at32f435_437_ertc.h:1068
ertc_type::dt13
__IO uint32_t dt13
Definition: at32f435_437_ertc.h:1032
ertc_type::val
__IO uint32_t val
Definition: at32f435_437_ertc.h:656
ertc_type::tsdt
__IO uint32_t tsdt
Definition: at32f435_437_ertc.h:781
ertc_type::tp1f
__IO uint32_t tp1f
Definition: at32f435_437_ertc.h:625
ertc_type::dt4
__IO uint32_t dt4
Definition: at32f435_437_ertc.h:924
ertc_type::wksel
__IO uint32_t wksel
Definition: at32f435_437_ertc.h:692
ertc_type::updf
__IO uint32_t updf
Definition: at32f435_437_ertc.h:617
ertc_type::cal8
__IO uint32_t cal8
Definition: at32f435_437_ertc.h:816
ertc_type::tsien
__IO uint32_t tsien
Definition: at32f435_437_ertc.h:592
ertc_type::tpien
__IO uint32_t tpien
Definition: at32f435_437_ertc.h:832
ertc_type::ccalen
__IO uint32_t ccalen
Definition: at32f435_437_ertc.h:584
ertc_type::dt12
__IO uint32_t dt12
Definition: at32f435_437_ertc.h:1020
ertc_type::caldir
__IO uint32_t caldir
Definition: at32f435_437_ertc.h:671
ertc_type::outsel
__IO uint32_t outsel
Definition: at32f435_437_ertc.h:598
ertc_type::calval
__IO uint32_t calval
Definition: at32f435_437_ertc.h:669
ertc_type::div
__IO uint32_t div
Definition: at32f435_437_ertc.h:638
ertc_type::dec1h
__IO uint32_t dec1h
Definition: at32f435_437_ertc.h:594
ertc_type::albwf
__IO uint32_t albwf
Definition: at32f435_437_ertc.h:613
ertc_type::alawf
__IO uint32_t alawf
Definition: at32f435_437_ertc.h:612
ertc_type::albien
__IO uint32_t albien
Definition: at32f435_437_ertc.h:590
ertc_type::sbsmsk
__IO uint32_t sbsmsk
Definition: at32f435_437_ertc.h:858
ertc_type::alaf
__IO uint32_t alaf
Definition: at32f435_437_ertc.h:620
ertc_type::tamp
__IO uint32_t tamp
Definition: at32f435_437_ertc.h:827
ertc_type::ccal
__IO uint32_t ccal
Definition: at32f435_437_ertc.h:666
ertc_type::y
__IO uint32_t y
Definition: at32f435_437_ertc.h:566
ertc_type::tsen
__IO uint32_t tsen
Definition: at32f435_437_ertc.h:588
ertc_type::dt5
__IO uint32_t dt5
Definition: at32f435_437_ertc.h:936
ertc_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_ertc.h:547
ertc_type::h
__IO uint32_t h
Definition: at32f435_437_ertc.h:548
ertc_type::cmd
__IO uint32_t cmd
Definition: at32f435_437_ertc.h:726
ertc_type::add
__IO uint32_t add
Definition: at32f435_437_ertc.h:817
ertc_type::albf
__IO uint32_t albf
Definition: at32f435_437_ertc.h:621
ertc_type::tpflt
__IO uint32_t tpflt
Definition: at32f435_437_ertc.h:838
ertc_reg_alarm_type
ertc alarm reg union
Definition: at32f435_437_ertc.h:448
ertc_reg_alarm_type::d
__IO uint32_t d
Definition: at32f435_437_ertc.h:459
ertc_reg_alarm_type::h
__IO uint32_t h
Definition: at32f435_437_ertc.h:456
ertc_reg_alarm_type::mask3
__IO uint32_t mask3
Definition: at32f435_437_ertc.h:458
ertc_reg_alarm_type::mask2
__IO uint32_t mask2
Definition: at32f435_437_ertc.h:455
ertc_reg_alarm_type::wksel
__IO uint32_t wksel
Definition: at32f435_437_ertc.h:460
ertc_reg_alarm_type::ala
__IO uint32_t ala
Definition: at32f435_437_ertc.h:449
ertc_reg_alarm_type::mask1
__IO uint32_t mask1
Definition: at32f435_437_ertc.h:453
ertc_reg_alarm_type::ampm
__IO uint32_t ampm
Definition: at32f435_437_ertc.h:457
ertc_reg_alarm_type::s
__IO uint32_t s
Definition: at32f435_437_ertc.h:452
ertc_reg_alarm_type::mask4
__IO uint32_t mask4
Definition: at32f435_437_ertc.h:461
ertc_reg_alarm_type::m
__IO uint32_t m
Definition: at32f435_437_ertc.h:454
ertc_reg_date_type
ertc date reg union
Definition: at32f435_437_ertc.h:431
ertc_reg_date_type::y
__IO uint32_t y
Definition: at32f435_437_ertc.h:439
ertc_reg_date_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_ertc.h:440
ertc_reg_date_type::m
__IO uint32_t m
Definition: at32f435_437_ertc.h:437
ertc_reg_date_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_ertc.h:436
ertc_reg_date_type::wk
__IO uint32_t wk
Definition: at32f435_437_ertc.h:438
ertc_reg_date_type::date
__IO uint32_t date
Definition: at32f435_437_ertc.h:432
ertc_reg_date_type::d
__IO uint32_t d
Definition: at32f435_437_ertc.h:435
ertc_reg_scal_type
ertc scal reg union
Definition: at32f435_437_ertc.h:469
ertc_reg_scal_type::dec
__IO uint32_t dec
Definition: at32f435_437_ertc.h:473
ertc_reg_scal_type::cal8
__IO uint32_t cal8
Definition: at32f435_437_ertc.h:476
ertc_reg_scal_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_ertc.h:478
ertc_reg_scal_type::cal16
__IO uint32_t cal16
Definition: at32f435_437_ertc.h:475
ertc_reg_scal_type::scal
__IO uint32_t scal
Definition: at32f435_437_ertc.h:470
ertc_reg_scal_type::add
__IO uint32_t add
Definition: at32f435_437_ertc.h:477
ertc_reg_scal_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_ertc.h:474
ertc_reg_tadj_type
ertc tadj reg union
Definition: at32f435_437_ertc.h:486
ertc_reg_tadj_type::tadj
__IO uint32_t tadj
Definition: at32f435_437_ertc.h:487
ertc_reg_tadj_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_ertc.h:491
ertc_reg_tadj_type::decsbs
__IO uint32_t decsbs
Definition: at32f435_437_ertc.h:490
ertc_reg_tadj_type::add1s
__IO uint32_t add1s
Definition: at32f435_437_ertc.h:492
ertc_reg_time_type
ertc time reg union
Definition: at32f435_437_ertc.h:413
ertc_reg_time_type::ampm
__IO uint32_t ampm
Definition: at32f435_437_ertc.h:422
ertc_reg_time_type::s
__IO uint32_t s
Definition: at32f435_437_ertc.h:417
ertc_reg_time_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_ertc.h:418
ertc_reg_time_type::m
__IO uint32_t m
Definition: at32f435_437_ertc.h:419
ertc_reg_time_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_ertc.h:420
ertc_reg_time_type::time
__IO uint32_t time
Definition: at32f435_437_ertc.h:414
ertc_reg_time_type::h
__IO uint32_t h
Definition: at32f435_437_ertc.h:421
ertc_reg_time_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_ertc.h:423
ertc_reg_tsdt_type
ertc tsdt register, offset:0x34
Definition: at32f435_437_ertc.h:518
ertc_reg_tsdt_type::wk
__IO uint32_t wk
Definition: at32f435_437_ertc.h:525
ertc_reg_tsdt_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_ertc.h:523
ertc_reg_tsdt_type::d
__IO uint32_t d
Definition: at32f435_437_ertc.h:522
ertc_reg_tsdt_type::tsdt
__IO uint32_t tsdt
Definition: at32f435_437_ertc.h:519
ertc_reg_tsdt_type::m
__IO uint32_t m
Definition: at32f435_437_ertc.h:524
ertc_reg_tsdt_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_ertc.h:526
ertc_reg_tstm_type
ertc tstm reg union
Definition: at32f435_437_ertc.h:500
ertc_reg_tstm_type::s
__IO uint32_t s
Definition: at32f435_437_ertc.h:504
ertc_reg_tstm_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_ertc.h:505
ertc_reg_tstm_type::ampm
__IO uint32_t ampm
Definition: at32f435_437_ertc.h:509
ertc_reg_tstm_type::m
__IO uint32_t m
Definition: at32f435_437_ertc.h:506
ertc_reg_tstm_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_ertc.h:507
ertc_reg_tstm_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_ertc.h:510
ertc_reg_tstm_type::h
__IO uint32_t h
Definition: at32f435_437_ertc.h:508
ertc_reg_tstm_type::tstm
__IO uint32_t tstm
Definition: at32f435_437_ertc.h:501


AT32F435/437 Firmwary Library: at32f435_437_exint.c Source File

  • libraries
  • drivers
  • src
at32f435_437_exint.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef EXINT_MODULE_ENABLED
39
49void exint_reset(void)
50{
51 EXINT->inten = 0x00000000;
52 EXINT->polcfg1 = 0x00000000;
53 EXINT->polcfg2 = 0x00000000;
54 EXINT->evten = 0x00000000;
55 EXINT->intsts = 0x007FFFFF;
56}
57
64void exint_default_para_init(exint_init_type *exint_struct)
65{
66 exint_struct->line_enable = FALSE;
67 exint_struct->line_select = EXINT_LINE_NONE;
68 exint_struct->line_polarity = EXINT_TRIGGER_FALLING_EDGE;
69 exint_struct->line_mode = EXINT_LINE_EVENT;
70}
71
78void exint_init(exint_init_type *exint_struct)
79{
80 uint32_t line_index = 0;
81 line_index = exint_struct->line_select;
82
83 EXINT->inten &= ~line_index;
84 EXINT->evten &= ~line_index;
85
86 if(exint_struct->line_enable != FALSE)
87 {
88 if(exint_struct->line_mode == EXINT_LINE_INTERRUPUT)
89 {
90 EXINT->inten |= line_index;
91 }
92 else
93 {
94 EXINT->evten |= line_index;
95 }
96
97 EXINT->polcfg1 &= ~line_index;
98 EXINT->polcfg2 &= ~line_index;
99 if(exint_struct->line_polarity == EXINT_TRIGGER_RISING_EDGE)
100 {
101 EXINT->polcfg1 |= line_index;
102 }
103 else if(exint_struct->line_polarity == EXINT_TRIGGER_FALLING_EDGE)
104 {
105 EXINT->polcfg2 |= line_index;
106 }
107 else
108 {
109 EXINT->polcfg1 |= line_index;
110 EXINT->polcfg2 |= line_index;
111 }
112 }
113}
114
126void exint_flag_clear(uint32_t exint_line)
127{
128 EXINT->intsts = exint_line;
129}
130
142 flag_status exint_flag_get(uint32_t exint_line)
143{
144 flag_status status = RESET;
145 uint32_t exint_flag =0;
146 exint_flag = EXINT->intsts & exint_line;
147 if((exint_flag != (uint16_t)RESET))
148 {
149 status = SET;
150 }
151 else
152 {
153 status = RESET;
154 }
155 return status;
156}
157
169void exint_software_interrupt_event_generate(uint32_t exint_line)
170{
171 EXINT->swtrg |= exint_line;
172}
173
187void exint_interrupt_enable(uint32_t exint_line, confirm_state new_state)
188{
189 if(new_state == TRUE)
190 {
191 EXINT->inten |= exint_line;
192 }
193 else
194 {
195 EXINT->inten &= ~exint_line;
196 }
197}
198
212void exint_event_enable(uint32_t exint_line, confirm_state new_state)
213{
214 if(new_state == TRUE)
215 {
216 EXINT->evten |= exint_line;
217 }
218 else
219 {
220 EXINT->evten &= ~exint_line;
221 }
222}
223
228#endif
229
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
EXINT_LINE_EVENT
@ EXINT_LINE_EVENT
Definition: at32f435_437_exint.h:90
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
EXINT_TRIGGER_FALLING_EDGE
@ EXINT_TRIGGER_FALLING_EDGE
Definition: at32f435_437_exint.h:99
EXINT_LINE_NONE
#define EXINT_LINE_NONE
Definition: at32f435_437_exint.h:51
exint_flag_get
flag_status exint_flag_get(uint32_t exint_line)
get exint flag
Definition: at32f435_437_exint.c:142
exint_interrupt_enable
void exint_interrupt_enable(uint32_t exint_line, confirm_state new_state)
enable or disable exint interrupt
Definition: at32f435_437_exint.c:187
exint_event_enable
void exint_event_enable(uint32_t exint_line, confirm_state new_state)
enable or disable exint event
Definition: at32f435_437_exint.c:212
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f435_437_exint.c:64
exint_reset
void exint_reset(void)
exint reset
Definition: at32f435_437_exint.c:49
exint_software_interrupt_event_generate
void exint_software_interrupt_event_generate(uint32_t exint_line)
generate exint software interrupt event
Definition: at32f435_437_exint.c:169
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT
#define EXINT
Definition: at32f435_437_exint.h:203
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_exint.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_exint.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_EXINT_H
29#define __AT32F435_437_EXINT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
51#define EXINT_LINE_NONE ((uint32_t)0x000000)
52#define EXINT_LINE_0 ((uint32_t)0x000001)
53#define EXINT_LINE_1 ((uint32_t)0x000002)
54#define EXINT_LINE_2 ((uint32_t)0x000004)
55#define EXINT_LINE_3 ((uint32_t)0x000008)
56#define EXINT_LINE_4 ((uint32_t)0x000010)
57#define EXINT_LINE_5 ((uint32_t)0x000020)
58#define EXINT_LINE_6 ((uint32_t)0x000040)
59#define EXINT_LINE_7 ((uint32_t)0x000080)
60#define EXINT_LINE_8 ((uint32_t)0x000100)
61#define EXINT_LINE_9 ((uint32_t)0x000200)
62#define EXINT_LINE_10 ((uint32_t)0x000400)
63#define EXINT_LINE_11 ((uint32_t)0x000800)
64#define EXINT_LINE_12 ((uint32_t)0x001000)
65#define EXINT_LINE_13 ((uint32_t)0x002000)
66#define EXINT_LINE_14 ((uint32_t)0x004000)
67#define EXINT_LINE_15 ((uint32_t)0x008000)
68#define EXINT_LINE_16 ((uint32_t)0x010000)
69#define EXINT_LINE_17 ((uint32_t)0x020000)
70#define EXINT_LINE_18 ((uint32_t)0x040000)
71#define EXINT_LINE_19 ((uint32_t)0x080000)
72#define EXINT_LINE_20 ((uint32_t)0x100000)
73#define EXINT_LINE_21 ((uint32_t)0x200000)
74#define EXINT_LINE_22 ((uint32_t)0x400000)
87typedef enum
88{
89 EXINT_LINE_INTERRUPUT = 0x00,
90 EXINT_LINE_EVENT = 0x01
91} exint_line_mode_type;
92
96typedef enum
97{
98 EXINT_TRIGGER_RISING_EDGE = 0x00,
99 EXINT_TRIGGER_FALLING_EDGE = 0x01,
100 EXINT_TRIGGER_BOTH_EDGE = 0x02
101} exint_polarity_config_type;
102
106typedef struct
107{
108 exint_line_mode_type line_mode;
109 uint32_t line_select;
110 exint_polarity_config_type line_polarity;
111 confirm_state line_enable;
112} exint_init_type;
113
117typedef struct
118{
119
123 union
124 {
125 __IO uint32_t inten;
126 struct
127 {
128 __IO uint32_t intenx : 23;/* [22:0] */
129 __IO uint32_t reserved1 : 9; /* [31:23] */
130 } inten_bit;
131 };
132
136 union
137 {
138 __IO uint32_t evten;
139 struct
140 {
141 __IO uint32_t evtenx : 23;/* [22:0] */
142 __IO uint32_t reserved1 : 9; /* [31:23] */
143 } evten_bit;
144 };
145
149 union
150 {
151 __IO uint32_t polcfg1;
152 struct
153 {
154 __IO uint32_t rpx : 23;/* [22:0] */
155 __IO uint32_t reserved1 : 9; /* [31:23] */
156 } polcfg1_bit;
157 };
158
162 union
163 {
164 __IO uint32_t polcfg2;
165 struct
166 {
167 __IO uint32_t fpx : 23;/* [22:0] */
168 __IO uint32_t reserved1 : 9; /* [31:23] */
169 } polcfg2_bit;
170 };
171
175 union
176 {
177 __IO uint32_t swtrg;
178 struct
179 {
180 __IO uint32_t swtx : 23;/* [22:0] */
181 __IO uint32_t reserved1 : 9; /* [31:23] */
182 } swtrg_bit;
183 };
184
188 union
189 {
190 __IO uint32_t intsts;
191 struct
192 {
193 __IO uint32_t linex : 23;/* [22:0] */
194 __IO uint32_t reserved1 : 9; /* [31:23] */
195 } intsts_bit;
196 };
197} exint_type;
198
203#define EXINT ((exint_type *) EXINT_BASE)
204
209void exint_reset(void);
210void exint_default_para_init(exint_init_type *exint_struct);
211void exint_init(exint_init_type *exint_struct);
212void exint_flag_clear(uint32_t exint_line);
213 flag_status exint_flag_get(uint32_t exint_line);
214void exint_software_interrupt_event_generate(uint32_t exint_line);
215void exint_interrupt_enable(uint32_t exint_line, confirm_state new_state);
216void exint_event_enable(uint32_t exint_line, confirm_state new_state);
217
230#ifdef __cplusplus
231}
232#endif
233
234#endif
at32f435_437.h
at32f435_437 header file
exint_flag_get
flag_status exint_flag_get(uint32_t exint_line)
get exint flag
Definition: at32f435_437_exint.c:142
exint_interrupt_enable
void exint_interrupt_enable(uint32_t exint_line, confirm_state new_state)
enable or disable exint interrupt
Definition: at32f435_437_exint.c:187
exint_event_enable
void exint_event_enable(uint32_t exint_line, confirm_state new_state)
enable or disable exint event
Definition: at32f435_437_exint.c:212
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f435_437_exint.c:64
exint_reset
void exint_reset(void)
exint reset
Definition: at32f435_437_exint.c:49
exint_software_interrupt_event_generate
void exint_software_interrupt_event_generate(uint32_t exint_line)
generate exint software interrupt event
Definition: at32f435_437_exint.c:169
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
exint_line_mode_type
exint_line_mode_type
exint line mode type
Definition: at32f435_437_exint.h:88
exint_polarity_config_type
exint_polarity_config_type
exint polarity configuration type
Definition: at32f435_437_exint.h:97
EXINT_LINE_EVENT
@ EXINT_LINE_EVENT
Definition: at32f435_437_exint.h:90
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
EXINT_TRIGGER_FALLING_EDGE
@ EXINT_TRIGGER_FALLING_EDGE
Definition: at32f435_437_exint.h:99
EXINT_TRIGGER_BOTH_EDGE
@ EXINT_TRIGGER_BOTH_EDGE
Definition: at32f435_437_exint.h:100
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
exint_type
type define exint register all
Definition: at32f435_437_exint.h:118
exint_type::polcfg1
__IO uint32_t polcfg1
Definition: at32f435_437_exint.h:151
exint_type::intsts
__IO uint32_t intsts
Definition: at32f435_437_exint.h:190
exint_type::polcfg2
__IO uint32_t polcfg2
Definition: at32f435_437_exint.h:164
exint_type::fpx
__IO uint32_t fpx
Definition: at32f435_437_exint.h:167
exint_type::intenx
__IO uint32_t intenx
Definition: at32f435_437_exint.h:128
exint_type::rpx
__IO uint32_t rpx
Definition: at32f435_437_exint.h:154
exint_type::evtenx
__IO uint32_t evtenx
Definition: at32f435_437_exint.h:141
exint_type::linex
__IO uint32_t linex
Definition: at32f435_437_exint.h:193
exint_type::inten
__IO uint32_t inten
Definition: at32f435_437_exint.h:125
exint_type::evten
__IO uint32_t evten
Definition: at32f435_437_exint.h:138
exint_type::swtx
__IO uint32_t swtx
Definition: at32f435_437_exint.h:180
exint_type::swtrg
__IO uint32_t swtrg
Definition: at32f435_437_exint.h:177
exint_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_exint.h:129


AT32F435/437 Firmwary Library: at32f435_437_flash.c Source File

  • libraries
  • drivers
  • src
at32f435_437_flash.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef FLASH_MODULE_ENABLED
39
63 flag_status flash_flag_get(uint32_t flash_flag)
64{
65 flag_status status = RESET;
66 uint32_t flag_position;
67 flag_position = flash_flag & 0x70000000;
68 flash_flag &= 0x8FFFFFFF;
69 switch(flag_position)
70 {
71 case 0x00000000:
72 if(FLASH->sts & flash_flag)
73 status = SET;
74 break;
75 case 0x10000000:
76 if(FLASH->sts2 & flash_flag)
77 status = SET;
78 break;
79 case 0x40000000:
80 if(FLASH->usd & flash_flag)
81 status = SET;
82 break;
83 default:
84 break;
85 }
86 /* return the new state of flash_flag (SET or RESET) */
87 return status;
88}
89
105void flash_flag_clear(uint32_t flash_flag)
106{
107 uint32_t flag_position;
108 flag_position = flash_flag & 0x70000000;
109 flash_flag &= 0x8FFFFFFF;
110 switch(flag_position)
111 {
112 case 0x00000000:
113 FLASH->sts = flash_flag;
114 break;
115 case 0x10000000:
116 FLASH->sts2 = flash_flag;
117 break;
118 default:
119 break;
120 }
121}
122
129 flash_status_type flash_operation_status_get(void)
130{
131 flash_status_type flash_status = FLASH_OPERATE_DONE;
132 if(FLASH->sts_bit.obf != RESET)
133 {
134 flash_status = FLASH_OPERATE_BUSY;
135 }
136 else if(FLASH->sts_bit.prgmerr != RESET)
137 {
138 flash_status = FLASH_PROGRAM_ERROR;
139 }
140 else if(FLASH->sts_bit.epperr != RESET)
141 {
142 flash_status = FLASH_EPP_ERROR;
143 }
144 else
145 {
146 flash_status = FLASH_OPERATE_DONE;
147 }
148 /* return the flash status */
149 return flash_status;
150}
151
158 flash_status_type flash_bank1_operation_status_get(void)
159{
160 flash_status_type flash_status = FLASH_OPERATE_DONE;
161 if(FLASH->sts_bit.obf != RESET)
162 {
163 flash_status = FLASH_OPERATE_BUSY;
164 }
165 else if(FLASH->sts_bit.prgmerr != RESET)
166 {
167 flash_status = FLASH_PROGRAM_ERROR;
168 }
169 else if(FLASH->sts_bit.epperr != RESET)
170 {
171 flash_status = FLASH_EPP_ERROR;
172 }
173 else
174 {
175 flash_status = FLASH_OPERATE_DONE;
176 }
177 /* return the flash status */
178 return flash_status;
179}
180
187 flash_status_type flash_bank2_operation_status_get(void)
188{
189 flash_status_type flash_status = FLASH_OPERATE_DONE;
190 if(FLASH->sts2_bit.obf != RESET)
191 {
192 flash_status = FLASH_OPERATE_BUSY;
193 }
194 else if(FLASH->sts2_bit.prgmerr != RESET)
195 {
196 flash_status = FLASH_PROGRAM_ERROR;
197 }
198 else if(FLASH->sts2_bit.epperr != RESET)
199 {
200 flash_status = FLASH_EPP_ERROR;
201 }
202 else
203 {
204 flash_status = FLASH_OPERATE_DONE;
205 }
206 /* return the flash status */
207 return flash_status;
208}
209
216 flash_status_type flash_operation_wait_for(uint32_t time_out)
217{
218 flash_status_type status = FLASH_OPERATE_DONE;
219 /* check for the flash status */
220 status = flash_operation_status_get();
221
222 while((status == FLASH_OPERATE_BUSY) && (time_out != 0x00))
223 {
224 status = flash_operation_status_get();
225 time_out--;
226 }
227 if(time_out == 0x00)
228 {
229 status = FLASH_OPERATE_TIMEOUT;
230 }
231 /* return the status */
232 return status;
233}
234
241 flash_status_type flash_bank1_operation_wait_for(uint32_t time_out)
242{
243 flash_status_type status = FLASH_OPERATE_DONE;
244 /* check for the flash status */
245 status = flash_bank1_operation_status_get();
246
247 while((status == FLASH_OPERATE_BUSY) && (time_out != 0x00))
248 {
249 status = flash_bank1_operation_status_get();
250 time_out--;
251 }
252 if(time_out == 0x00)
253 {
254 status = FLASH_OPERATE_TIMEOUT;
255 }
256 /* return the operation status */
257 return status;
258}
259
266 flash_status_type flash_bank2_operation_wait_for(uint32_t time_out)
267{
268 flash_status_type status = FLASH_OPERATE_DONE;
269 /* check for the flash status */
270 status = flash_bank2_operation_status_get();
271
272 while((status == FLASH_OPERATE_BUSY) && (time_out != 0x00))
273 {
274 status = flash_bank2_operation_status_get();
275 time_out--;
276 }
277 if(time_out == 0x00)
278 {
279 status = FLASH_OPERATE_TIMEOUT;
280 }
281 /* return the operation status */
282 return status;
283}
284
290void flash_unlock(void)
291{
292 FLASH->unlock = FLASH_UNLOCK_KEY1;
293 FLASH->unlock = FLASH_UNLOCK_KEY2;
294 FLASH->unlock2 = FLASH_UNLOCK_KEY1;
295 FLASH->unlock2 = FLASH_UNLOCK_KEY2;
296}
297
303void flash_bank1_unlock(void)
304{
305 FLASH->unlock = FLASH_UNLOCK_KEY1;
306 FLASH->unlock = FLASH_UNLOCK_KEY2;
307}
308
314void flash_bank2_unlock(void)
315{
316 FLASH->unlock2 = FLASH_UNLOCK_KEY1;
317 FLASH->unlock2 = FLASH_UNLOCK_KEY2;
318}
319
325void flash_lock(void)
326{
327 FLASH->ctrl_bit.oplk = TRUE;
328 FLASH->ctrl2_bit.oplk = TRUE;
329}
330
336void flash_bank1_lock(void)
337{
338 FLASH->ctrl_bit.oplk = TRUE;
339}
340
346void flash_bank2_lock(void)
347{
348 FLASH->ctrl2_bit.oplk = TRUE;
349}
350
357 flash_status_type flash_sector_erase(uint32_t sector_address)
358{
359 flash_status_type status = FLASH_OPERATE_DONE;
360 if((sector_address >= FLASH_BANK1_START_ADDR) && (sector_address <= FLASH_BANK1_END_ADDR))
361 {
362 FLASH->ctrl_bit.secers = TRUE;
363 FLASH->addr = sector_address;
364 FLASH->ctrl_bit.erstr = TRUE;
365
366 /* wait for operation to be completed */
367 status = flash_bank1_operation_wait_for(ERASE_TIMEOUT);
368
369 /* disable the secers bit */
370 FLASH->ctrl_bit.secers = FALSE;
371 }
372 else if((sector_address >= FLASH_BANK2_START_ADDR) && (sector_address <= FLASH_BANK2_END_ADDR))
373 {
374 FLASH->ctrl2_bit.secers = TRUE;
375 FLASH->addr2 = sector_address;
376 FLASH->ctrl2_bit.erstr = TRUE;
377
378 /* wait for operation to be completed */
379 status = flash_bank2_operation_wait_for(ERASE_TIMEOUT);
380
381 /* disable the secers bit */
382 FLASH->ctrl2_bit.secers = FALSE;
383 }
384
385 /* return the erase status */
386 return status;
387}
388
395 flash_status_type flash_block_erase(uint32_t block_address)
396{
397 flash_status_type status = FLASH_OPERATE_DONE;
398 if((block_address >= FLASH_BANK1_START_ADDR) && (block_address <= FLASH_BANK1_END_ADDR))
399 {
400 FLASH->ctrl_bit.blkers = TRUE;
401 FLASH->addr = block_address;
402 FLASH->ctrl_bit.erstr = TRUE;
403
404 /* wait for operation to be completed */
405 status = flash_bank1_operation_wait_for(ERASE_TIMEOUT);
406
407 /* disable the blkers bit */
408 FLASH->ctrl_bit.blkers = FALSE;
409 }
410 else if((block_address >= FLASH_BANK2_START_ADDR) && (block_address <= FLASH_BANK2_END_ADDR))
411 {
412 FLASH->ctrl2_bit.blkers = TRUE;
413 FLASH->addr2 = block_address;
414 FLASH->ctrl2_bit.erstr = TRUE;
415
416 /* wait for operation to be completed */
417 status = flash_bank2_operation_wait_for(ERASE_TIMEOUT);
418
419 /* disable the blkers bit */
420 FLASH->ctrl2_bit.blkers = FALSE;
421 }
422
423 /* return the erase status */
424 return status;
425}
426
433 flash_status_type flash_internal_all_erase(void)
434{
435 flash_status_type status = FLASH_OPERATE_DONE;
436
437 FLASH->ctrl_bit.bankers = TRUE;
438 FLASH->ctrl_bit.erstr = TRUE;
439
440 /* wait for operation to be completed */
441 status = flash_bank1_operation_wait_for(ERASE_TIMEOUT);
442
443 /* disable the bankers bit */
444 FLASH->ctrl_bit.bankers = FALSE;
445
446 if(status == FLASH_OPERATE_DONE)
447 {
448 /* if the previous operation is completed, continue to erase bank2 */
449 FLASH->ctrl2_bit.bankers = TRUE;
450 FLASH->ctrl2_bit.erstr = TRUE;
451
452 /* wait for operation to be completed */
453 status = flash_bank2_operation_wait_for(ERASE_TIMEOUT);
454
455 /* disable the bankers bit */
456 FLASH->ctrl2_bit.bankers = FALSE;
457 }
458 /* return the erase status */
459 return status;
460}
461
468 flash_status_type flash_bank1_erase(void)
469{
470 flash_status_type status = FLASH_OPERATE_DONE;
471
472 FLASH->ctrl_bit.bankers = TRUE;
473 FLASH->ctrl_bit.erstr = TRUE;
474
475 /* wait for operation to be completed */
476 status = flash_bank1_operation_wait_for(ERASE_TIMEOUT);
477
478 /* disable the bankers bit */
479 FLASH->ctrl_bit.bankers = FALSE;
480
481 /* return the erase status */
482 return status;
483}
484
491 flash_status_type flash_bank2_erase(void)
492{
493 flash_status_type status = FLASH_OPERATE_DONE;
494
495 FLASH->ctrl2_bit.bankers = TRUE;
496 FLASH->ctrl2_bit.erstr = TRUE;
497
498 /* wait for operation to be completed */
499 status = flash_bank2_operation_wait_for(ERASE_TIMEOUT);
500
501 /* disable the bankers bit */
502 FLASH->ctrl2_bit.bankers = FALSE;
503
504 /* return the erase status */
505 return status;
506}
507
516 flash_status_type flash_user_system_data_erase(void)
517{
518 flash_status_type status = FLASH_OPERATE_DONE;
519 uint16_t fap_val = FAP_RELIEVE_KEY;
520 /* get the flash access protection status */
521 if(flash_fap_status_get() != RESET)
522 {
523 fap_val = 0x0000;
524 }
525
526 /* unlock the user system data */
527 FLASH->usd_unlock = FLASH_UNLOCK_KEY1;
528 FLASH->usd_unlock = FLASH_UNLOCK_KEY2;
529 while(FLASH->ctrl_bit.usdulks==RESET);
530
531 /* erase the user system data */
532 FLASH->ctrl_bit.usders = TRUE;
533 FLASH->ctrl_bit.erstr = TRUE;
534
535 /* wait for operation to be completed */
536 status = flash_operation_wait_for(ERASE_TIMEOUT);
537
538 /* disable the usders bit */
539 FLASH->ctrl_bit.usders = FALSE;
540
541 if((status == FLASH_OPERATE_DONE) && (fap_val == FAP_RELIEVE_KEY))
542 {
543 /* enable the user system data programming operation */
544 FLASH->ctrl_bit.usdprgm = TRUE;
545
546 /* restore the last flash access protection value */
547 USD->fap = (uint16_t)fap_val;
548
549 /* wait for operation to be completed */
550 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
551
552 /*disable the usdprgm bit */
553 FLASH->ctrl_bit.usdprgm = FALSE;
554 }
555
556 /* return the status */
557 return status;
558}
559
576 flash_status_type flash_eopb0_config(flash_usd_eopb0_type data)
577{
578 flash_status_type status = FLASH_OPERATE_DONE;
579
580 /* unlock the user system data */
581 FLASH->usd_unlock = FLASH_UNLOCK_KEY1;
582 FLASH->usd_unlock = FLASH_UNLOCK_KEY2;
583 while(FLASH->ctrl_bit.usdulks==RESET);
584
585 /* enable the user system data programming operation */
586 FLASH->ctrl_bit.usdprgm = TRUE;
587
588 /* restore the default eopb0 value */
589 USD->eopb0 = (uint16_t)data;
590
591 /* wait for operation to be completed */
592 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
593
594 /*disable the usdprgm bit */
595 FLASH->ctrl_bit.usdprgm = FALSE;
596
597 /* return the status */
598 return status;
599}
600
608 flash_status_type flash_word_program(uint32_t address, uint32_t data)
609{
610 flash_status_type status = FLASH_OPERATE_DONE;
611 if((address >= FLASH_BANK1_START_ADDR) && (address <= FLASH_BANK1_END_ADDR))
612 {
613 FLASH->ctrl_bit.fprgm = TRUE;
614 *(__IO uint32_t*)address = data;
615 /* wait for operation to be completed */
616 status = flash_bank1_operation_wait_for(PROGRAMMING_TIMEOUT);
617
618 /* disable the fprgm bit */
619 FLASH->ctrl_bit.fprgm = FALSE;
620 }
621 else if((address >= FLASH_BANK2_START_ADDR) && (address <= FLASH_BANK2_END_ADDR))
622 {
623 FLASH->ctrl2_bit.fprgm = TRUE;
624 *(__IO uint32_t*)address = data;
625 /* wait for operation to be completed */
626 status = flash_bank2_operation_wait_for(PROGRAMMING_TIMEOUT);
627
628 /* disable the fprgm bit */
629 FLASH->ctrl2_bit.fprgm = FALSE;
630 }
631
632 /* return the program status */
633 return status;
634}
635
643 flash_status_type flash_halfword_program(uint32_t address, uint16_t data)
644{
645 flash_status_type status = FLASH_OPERATE_DONE;
646 if((address >= FLASH_BANK1_START_ADDR) && (address <= FLASH_BANK1_END_ADDR))
647 {
648 FLASH->ctrl_bit.fprgm = TRUE;
649 *(__IO uint16_t*)address = data;
650 /* wait for operation to be completed */
651 status = flash_bank1_operation_wait_for(PROGRAMMING_TIMEOUT);
652
653 /* disable the fprgm bit */
654 FLASH->ctrl_bit.fprgm = FALSE;
655 }
656 else if((address >= FLASH_BANK2_START_ADDR) && (address <= FLASH_BANK2_END_ADDR))
657 {
658 FLASH->ctrl2_bit.fprgm = TRUE;
659 *(__IO uint16_t*)address = data;
660 /* wait for operation to be completed */
661 status = flash_bank2_operation_wait_for(PROGRAMMING_TIMEOUT);
662
663 /* disable the fprgm bit */
664 FLASH->ctrl2_bit.fprgm = FALSE;
665 }
666
667 /* return the program status */
668 return status;
669}
670
679 flash_status_type flash_byte_program(uint32_t address, uint8_t data)
680{
681 flash_status_type status = FLASH_OPERATE_DONE;
682 if((address >= FLASH_BANK1_START_ADDR) && (address <= FLASH_BANK1_END_ADDR))
683 {
684 FLASH->ctrl_bit.fprgm = TRUE;
685 *(__IO uint8_t*)address = data;
686 /* wait for operation to be completed */
687 status = flash_bank1_operation_wait_for(PROGRAMMING_TIMEOUT);
688
689 /* disable the fprgm bit */
690 FLASH->ctrl_bit.fprgm = FALSE;
691 }
692 else if((address >= FLASH_BANK2_START_ADDR) && (address <= FLASH_BANK2_END_ADDR))
693 {
694 FLASH->ctrl2_bit.fprgm = TRUE;
695 *(__IO uint8_t*)address = data;
696 /* wait for operation to be completed */
697 status = flash_bank2_operation_wait_for(PROGRAMMING_TIMEOUT);
698
699 /* disable the fprgm bit */
700 FLASH->ctrl2_bit.fprgm = FALSE;
701 }
702 /* return the program status */
703 return status;
704}
705
713 flash_status_type flash_user_system_data_program(uint32_t address, uint8_t data)
714{
715 flash_status_type status = FLASH_OPERATE_DONE;
716
717 if(address == USD_BASE)
718 {
719 if(data != 0xA5)
720 return FLASH_OPERATE_DONE;
721 }
722
723 /* unlock the user system data */
724 FLASH->usd_unlock = FLASH_UNLOCK_KEY1;
725 FLASH->usd_unlock = FLASH_UNLOCK_KEY2;
726 while(FLASH->ctrl_bit.usdulks==RESET);
727
728 /* enable the user system data programming operation */
729 FLASH->ctrl_bit.usdprgm = TRUE;
730 *(__IO uint16_t*)address = data;
731
732 /* wait for operation to be completed */
733 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
734
735 /* disable the usdprgm bit */
736 FLASH->ctrl_bit.usdprgm = FALSE;
737
738 /* return the user system data program status */
739 return status;
740}
741
751 flash_status_type flash_epp_set(uint32_t *sector_bits)
752{
753 uint16_t epp_data[4] = {0xFFFF,0xFFFF,0xFFFF,0xFFFF};
754 flash_status_type status = FLASH_OPERATE_DONE;
755 sector_bits[0] = (uint32_t)(~sector_bits[0]);
756 epp_data[0] = (uint16_t)((sector_bits[0] >> 0) & 0xFF);
757 epp_data[1] = (uint16_t)((sector_bits[0] >> 8) & 0xFF);
758 epp_data[2] = (uint16_t)((sector_bits[0] >> 16) & 0xFF);
759 epp_data[3] = (uint16_t)((sector_bits[0] >> 24) & 0xFF);
760
761 /* unlock the user system data */
762 FLASH->usd_unlock = FLASH_UNLOCK_KEY1;
763 FLASH->usd_unlock = FLASH_UNLOCK_KEY2;
764 while(FLASH->ctrl_bit.usdulks==RESET);
765
766 FLASH->ctrl_bit.usdprgm = TRUE;
767 USD->epp0 = epp_data[0];
768 /* wait for operation to be completed */
769 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
770
771 if(status == FLASH_OPERATE_DONE)
772 {
773 USD->epp1 = epp_data[1];
774 /* wait for operation to be completed */
775 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
776 }
777 if(status == FLASH_OPERATE_DONE)
778 {
779 USD->epp2 = epp_data[2];
780 /* wait for operation to be completed */
781 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
782 }
783 if(status == FLASH_OPERATE_DONE)
784 {
785 USD->epp3 = epp_data[3];
786 /* wait for operation to be completed */
787 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
788 }
789
790 sector_bits[1] = (uint32_t)(~sector_bits[1]);
791 epp_data[0] = (uint16_t)((sector_bits[1] >> 0) & 0xFF);
792 epp_data[1] = (uint16_t)((sector_bits[1] >> 8) & 0xFF);
793 epp_data[2] = (uint16_t)((sector_bits[1] >> 16) & 0xFF);
794 epp_data[3] = (uint16_t)((sector_bits[1] >> 24) & 0xFF);
795 if(status == FLASH_OPERATE_DONE)
796 {
797 USD->epp4 = epp_data[0];
798 /* wait for operation to be completed */
799 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
800 }
801 if(status == FLASH_OPERATE_DONE)
802 {
803 USD->epp5 = epp_data[1];
804 /* wait for operation to be completed */
805 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
806 }
807 if(status == FLASH_OPERATE_DONE)
808 {
809 USD->epp6 = epp_data[2];
810 /* wait for operation to be completed */
811 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
812 }
813 if(status == FLASH_OPERATE_DONE)
814 {
815 USD->epp7 = epp_data[3];
816 /* wait for operation to be completed */
817 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
818 }
819
820 /* disable the usdprgm bit */
821 FLASH->ctrl_bit.usdprgm = FALSE;
822
823 /* return the erase/program protection operation status */
824 return status;
825}
826
832void flash_epp_status_get(uint32_t *sector_bits)
833{
834 /* return the flash erase/program protection register value */
835 sector_bits[0] = (uint32_t)(FLASH->epps0);
836 sector_bits[1] = (uint32_t)(FLASH->epps1);
837}
838
848 flash_status_type flash_fap_enable(confirm_state new_state)
849{
850 flash_status_type status = FLASH_OPERATE_DONE;
851
852 /* unlock the user system data */
853 FLASH->usd_unlock = FLASH_UNLOCK_KEY1;
854 FLASH->usd_unlock = FLASH_UNLOCK_KEY2;
855 while(FLASH->ctrl_bit.usdulks==RESET);
856
857 FLASH->ctrl_bit.usders = TRUE;
858 FLASH->ctrl_bit.erstr = TRUE;
859 /* wait for operation to be completed */
860 status = flash_operation_wait_for(ERASE_TIMEOUT);
861
862 /* disable the usders bit */
863 FLASH->ctrl_bit.usders = FALSE;
864
865 if(status == FLASH_OPERATE_DONE)
866 {
867 /* enable the user system data programming operation */
868 FLASH->ctrl_bit.usdprgm = TRUE;
869
870 /* restore the default eopb0 value */
871 USD->eopb0 = (uint16_t)0x0002;
872
873 /* Wait for operation to be completed */
874 status = flash_operation_wait_for(ERASE_TIMEOUT);
875
876 if(new_state == FALSE)
877 {
878 USD->fap = FAP_RELIEVE_KEY;
879 /* Wait for operation to be completed */
880 status = flash_operation_wait_for(ERASE_TIMEOUT);
881 }
882 /* disable the usdprgm bit */
883 FLASH->ctrl_bit.usdprgm = FALSE;
884 }
885
886 /* return the flash access protection operation status */
887 return status;
888}
889
895 flag_status flash_fap_status_get(void)
896{
897 return (flag_status)FLASH->usd_bit.fap;
898}
899
931 flash_status_type flash_ssb_set(uint8_t usd_ssb)
932{
933 flash_status_type status = FLASH_OPERATE_DONE;
934
935 /* unlock the user system data */
936 FLASH->usd_unlock = FLASH_UNLOCK_KEY1;
937 FLASH->usd_unlock = FLASH_UNLOCK_KEY2;
938 while(FLASH->ctrl_bit.usdulks==RESET);
939
940 /* enable the user system data programming operation */
941 FLASH->ctrl_bit.usdprgm = TRUE;
942
943 USD->ssb = usd_ssb;
944 /* wait for operation to be completed */
945 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
946
947 /* disable the usdprgm bit */
948 FLASH->ctrl_bit.usdprgm = FALSE;
949
950 /* return the user system data program status */
951 return status;
952}
953
960uint8_t flash_ssb_status_get(void)
961{
962 /* return the system setting byte status */
963 return (uint8_t)(FLASH->usd >> 2);
964}
965
980void flash_interrupt_enable(uint32_t flash_int, confirm_state new_state)
981{
982 if(flash_int & FLASH_BANK1_ERR_INT)
983 FLASH->ctrl_bit.errie = new_state;
984 if(flash_int & FLASH_BANK1_ODF_INT)
985 FLASH->ctrl_bit.odfie = new_state;
986 if(flash_int & FLASH_BANK2_ERR_INT)
987 FLASH->ctrl2_bit.errie = new_state;
988 if(flash_int & FLASH_BANK2_ODF_INT)
989 FLASH->ctrl2_bit.odfie = new_state;
990}
991
1001 flash_status_type flash_slib_enable(uint32_t pwd, uint16_t start_sector, uint16_t inst_start_sector, uint16_t end_sector)
1002{
1003 uint32_t slib_range;
1004 flash_status_type status = FLASH_OPERATE_DONE;
1005
1006 /*check range param limits*/
1007 if((start_sector>=inst_start_sector) || ((inst_start_sector > end_sector) && \
1008 (inst_start_sector != 0xFFFF)) || (start_sector > end_sector))
1009 return FLASH_PROGRAM_ERROR;
1010
1011 /* unlock slib cfg register */
1012 FLASH->slib_unlock = SLIB_UNLOCK_KEY;
1013 while(FLASH->slib_misc_sts_bit.slib_ulkf==RESET);
1014
1015 /* configure slib, set pwd and range */
1016 FLASH->slib_set_pwd = pwd;
1017 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
1018 if(status == FLASH_OPERATE_DONE)
1019 {
1020 slib_range = ((uint32_t)(end_sector << 16) & FLASH_SLIB_END_SECTOR) | (start_sector & FLASH_SLIB_START_SECTOR);
1021 FLASH->slib_set_range0 = slib_range;
1022 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
1023 if(status == FLASH_OPERATE_DONE)
1024 {
1025 slib_range = (inst_start_sector & FLASH_SLIB_INST_START_SECTOR) | 0x80000000;
1026 FLASH->slib_set_range1 = slib_range;
1027 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
1028 }
1029 }
1030
1031 return status;
1032}
1033
1039 error_status flash_slib_disable(uint32_t pwd)
1040{
1041 flash_status_type status = FLASH_OPERATE_DONE;
1042 /* write password to disable slib */
1043 FLASH->slib_pwd_clr = pwd;
1044
1045 status = flash_operation_wait_for(ERASE_TIMEOUT);
1046 if(status == FLASH_OPERATE_DONE)
1047 {
1048 if(FLASH->slib_misc_sts_bit.slib_pwd_ok)
1049 return SUCCESS;
1050 else
1051 return ERROR;
1052 }
1053 return ERROR;
1054}
1055
1061uint32_t flash_slib_remaining_count_get(void)
1062{
1063 return (uint32_t)FLASH->slib_misc_sts_bit.slib_rcnt;
1064}
1065
1071 flag_status flash_slib_state_get(void)
1072{
1073 if(FLASH->slib_sts0_bit.slib_enf)
1074 return SET;
1075 else
1076 return RESET;
1077}
1078
1084uint16_t flash_slib_start_sector_get(void)
1085{
1086 return (uint16_t)FLASH->slib_sts1_bit.slib_ss;
1087}
1088
1094uint16_t flash_slib_inststart_sector_get(void)
1095{
1096 return (uint16_t)FLASH->slib_sts2_bit.slib_inst_ss;
1097}
1098
1104uint16_t flash_slib_end_sector_get(void)
1105{
1106 return (uint16_t)FLASH->slib_sts1_bit.slib_es;
1107}
1108
1115uint32_t flash_crc_calibrate(uint32_t start_sector, uint32_t sector_cnt)
1116{
1117 FLASH->crc_ctrl_bit.crc_ss = start_sector;
1118 FLASH->crc_ctrl_bit.crc_sn = sector_cnt;
1119 FLASH->crc_ctrl_bit.crc_strt = TRUE;
1120 flash_operation_wait_for(OPERATION_TIMEOUT);
1121 return FLASH->crc_chkr;
1122}
1123
1130void flash_nzw_boost_enable(confirm_state new_state)
1131{
1132 FLASH->psr_bit.nzw_bst = new_state;
1133}
1134
1141void flash_continue_read_enable(confirm_state new_state)
1142{
1143 FLASH->contr_bit.fcontr_en = new_state;
1144}
1145
1150#endif
1151
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
error_status
error_status
Definition: at32f435_437.h:380
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
FAP_RELIEVE_KEY
#define FAP_RELIEVE_KEY
Definition: at32f435_437_flash.h:56
PROGRAMMING_TIMEOUT
#define PROGRAMMING_TIMEOUT
Definition: at32f435_437_flash.h:150
FLASH_BANK2_END_ADDR
#define FLASH_BANK2_END_ADDR
Definition: at32f435_437_flash.h:73
FLASH_BANK1_ERR_INT
#define FLASH_BANK1_ERR_INT
Definition: at32f435_437_flash.h:98
FLASH_BANK1_ODF_INT
#define FLASH_BANK1_ODF_INT
Definition: at32f435_437_flash.h:99
FLASH_BANK2_ERR_INT
#define FLASH_BANK2_ERR_INT
Definition: at32f435_437_flash.h:100
FLASH_UNLOCK_KEY2
#define FLASH_UNLOCK_KEY2
Definition: at32f435_437_flash.h:55
FLASH_SLIB_END_SECTOR
#define FLASH_SLIB_END_SECTOR
Definition: at32f435_437_flash.h:108
FLASH_UNLOCK_KEY1
#define FLASH_UNLOCK_KEY1
flash unlock keys
Definition: at32f435_437_flash.h:54
FLASH_BANK2_START_ADDR
#define FLASH_BANK2_START_ADDR
Definition: at32f435_437_flash.h:72
OPERATION_TIMEOUT
#define OPERATION_TIMEOUT
Definition: at32f435_437_flash.h:151
FLASH_BANK1_END_ADDR
#define FLASH_BANK1_END_ADDR
Definition: at32f435_437_flash.h:71
FLASH_BANK2_ODF_INT
#define FLASH_BANK2_ODF_INT
Definition: at32f435_437_flash.h:101
ERASE_TIMEOUT
#define ERASE_TIMEOUT
flash timeout definition
Definition: at32f435_437_flash.h:149
FLASH_BANK1_START_ADDR
#define FLASH_BANK1_START_ADDR
flash bank address
Definition: at32f435_437_flash.h:70
SLIB_UNLOCK_KEY
#define SLIB_UNLOCK_KEY
Definition: at32f435_437_flash.h:57
FLASH_SLIB_START_SECTOR
#define FLASH_SLIB_START_SECTOR
flash slib mask
Definition: at32f435_437_flash.h:106
FLASH_SLIB_INST_START_SECTOR
#define FLASH_SLIB_INST_START_SECTOR
Definition: at32f435_437_flash.h:107
flash_usd_eopb0_type
flash_usd_eopb0_type
flash usd eopb0 type
Definition: at32f435_437_flash.h:175
flash_status_type
flash_status_type
flash status type
Definition: at32f435_437_flash.h:199
FLASH_OPERATE_BUSY
@ FLASH_OPERATE_BUSY
Definition: at32f435_437_flash.h:200
FLASH_OPERATE_DONE
@ FLASH_OPERATE_DONE
Definition: at32f435_437_flash.h:203
FLASH_OPERATE_TIMEOUT
@ FLASH_OPERATE_TIMEOUT
Definition: at32f435_437_flash.h:204
FLASH_PROGRAM_ERROR
@ FLASH_PROGRAM_ERROR
Definition: at32f435_437_flash.h:201
FLASH_EPP_ERROR
@ FLASH_EPP_ERROR
Definition: at32f435_437_flash.h:202
flash_bank1_operation_status_get
flash_status_type flash_bank1_operation_status_get(void)
return the flash bank1 operation status.
Definition: at32f435_437_flash.c:158
flash_slib_state_get
flag_status flash_slib_state_get(void)
get the slib state.
Definition: at32f435_437_flash.c:1071
flash_bank1_lock
void flash_bank1_lock(void)
lock the flash bank1 controller.
Definition: at32f435_437_flash.c:336
flash_block_erase
flash_status_type flash_block_erase(uint32_t block_address)
erase a specified flash block.
Definition: at32f435_437_flash.c:395
flash_fap_status_get
flag_status flash_fap_status_get(void)
check the flash access protection status.
Definition: at32f435_437_flash.c:895
flash_slib_remaining_count_get
uint32_t flash_slib_remaining_count_get(void)
get remaining count of slib(range: 256~0).
Definition: at32f435_437_flash.c:1061
flash_slib_enable
flash_status_type flash_slib_enable(uint32_t pwd, uint16_t start_sector, uint16_t inst_start_sector, uint16_t end_sector)
enable security library function.
Definition: at32f435_437_flash.c:1001
flash_slib_disable
error_status flash_slib_disable(uint32_t pwd)
disable slib when slib enabled.
Definition: at32f435_437_flash.c:1039
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f435_437_flash.c:357
flash_bank1_erase
flash_status_type flash_bank1_erase(void)
erase flash bank1 sectors.
Definition: at32f435_437_flash.c:468
flash_halfword_program
flash_status_type flash_halfword_program(uint32_t address, uint16_t data)
program a halfword at a specified address.
Definition: at32f435_437_flash.c:643
flash_bank2_operation_status_get
flash_status_type flash_bank2_operation_status_get(void)
return the flash bank2 operation status.
Definition: at32f435_437_flash.c:187
flash_user_system_data_program
flash_status_type flash_user_system_data_program(uint32_t address, uint8_t data)
program a halfword at a specified user system data address.
Definition: at32f435_437_flash.c:713
flash_byte_program
flash_status_type flash_byte_program(uint32_t address, uint8_t data)
program a byte at a specified address.
Definition: at32f435_437_flash.c:679
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f435_437_flash.c:290
flash_operation_status_get
flash_status_type flash_operation_status_get(void)
return the flash operation status.
Definition: at32f435_437_flash.c:129
flash_epp_set
flash_status_type flash_epp_set(uint32_t *sector_bits)
config erase/program protection for the desired sectors.
Definition: at32f435_437_flash.c:751
flash_bank2_unlock
void flash_bank2_unlock(void)
unlock the flash bank2 controller.
Definition: at32f435_437_flash.c:314
flash_ssb_set
flash_status_type flash_ssb_set(uint8_t usd_ssb)
program the flash system setting byte in usd: wdt_ato_en / depslp_rst / stdby_rst / btopt.
Definition: at32f435_437_flash.c:931
flash_bank2_erase
flash_status_type flash_bank2_erase(void)
erase flash bank2 sectors.
Definition: at32f435_437_flash.c:491
flash_crc_calibrate
uint32_t flash_crc_calibrate(uint32_t start_sector, uint32_t sector_cnt)
flash crc calibration in main block.
Definition: at32f435_437_flash.c:1115
flash_slib_start_sector_get
uint16_t flash_slib_start_sector_get(void)
get the start sector of slib.
Definition: at32f435_437_flash.c:1084
flash_eopb0_config
flash_status_type flash_eopb0_config(flash_usd_eopb0_type data)
config the extend sram byte eopb0 in user system data.
Definition: at32f435_437_flash.c:576
flash_interrupt_enable
void flash_interrupt_enable(uint32_t flash_int, confirm_state new_state)
enable or disable the specified flash interrupts.
Definition: at32f435_437_flash.c:980
flash_fap_enable
flash_status_type flash_fap_enable(confirm_state new_state)
enable or disable the flash access protection.
Definition: at32f435_437_flash.c:848
flash_slib_end_sector_get
uint16_t flash_slib_end_sector_get(void)
get the end sector of slib.
Definition: at32f435_437_flash.c:1104
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f435_437_flash.c:608
flash_bank2_operation_wait_for
flash_status_type flash_bank2_operation_wait_for(uint32_t time_out)
wait for flash bank2 operation complete or timeout.
Definition: at32f435_437_flash.c:266
flash_bank1_unlock
void flash_bank1_unlock(void)
unlock the flash bank1 controller.
Definition: at32f435_437_flash.c:303
flash_continue_read_enable
void flash_continue_read_enable(confirm_state new_state)
flash continue read enable.
Definition: at32f435_437_flash.c:1141
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f435_437_flash.c:325
flash_slib_inststart_sector_get
uint16_t flash_slib_inststart_sector_get(void)
get the instruction start sector of slib.
Definition: at32f435_437_flash.c:1094
flash_flag_get
flag_status flash_flag_get(uint32_t flash_flag)
check whether the specified flash flag is set or not.
Definition: at32f435_437_flash.c:63
flash_user_system_data_erase
flash_status_type flash_user_system_data_erase(void)
erase the flash user system data.
Definition: at32f435_437_flash.c:516
flash_internal_all_erase
flash_status_type flash_internal_all_erase(void)
erase flash all internal sectors.
Definition: at32f435_437_flash.c:433
flash_operation_wait_for
flash_status_type flash_operation_wait_for(uint32_t time_out)
wait for flash operation complete or timeout.
Definition: at32f435_437_flash.c:216
flash_bank1_operation_wait_for
flash_status_type flash_bank1_operation_wait_for(uint32_t time_out)
wait for flash bank1 operation complete or timeout.
Definition: at32f435_437_flash.c:241
flash_ssb_status_get
uint8_t flash_ssb_status_get(void)
return the flash system setting byte status.
Definition: at32f435_437_flash.c:960
flash_nzw_boost_enable
void flash_nzw_boost_enable(confirm_state new_state)
flash non-zero wait area boost enable.
Definition: at32f435_437_flash.c:1130
flash_epp_status_get
void flash_epp_status_get(uint32_t *sector_bits)
return the flash erase/program protection status.
Definition: at32f435_437_flash.c:832
flash_flag_clear
void flash_flag_clear(uint32_t flash_flag)
clear the flash flag.
Definition: at32f435_437_flash.c:105
flash_bank2_lock
void flash_bank2_lock(void)
lock the flash bank2 controller.
Definition: at32f435_437_flash.c:346
USD
#define USD
Definition: at32f435_437_flash.h:659
FLASH
#define FLASH
Definition: at32f435_437_flash.h:658
USD_BASE
#define USD_BASE
Definition: at32f435_437.h:424
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_flash.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_flash.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_FLASH_H
29#define __AT32F435_437_FLASH_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
54#define FLASH_UNLOCK_KEY1 ((uint32_t)0x45670123)
55#define FLASH_UNLOCK_KEY2 ((uint32_t)0xCDEF89AB)
56#define FAP_RELIEVE_KEY ((uint16_t)0x00A5)
57#define SLIB_UNLOCK_KEY ((uint32_t)0xA35F6D24)
62#if defined (AT32F435CMU7) || defined (AT32F435CMT7) || defined (AT32F435RMT7) || \
63 defined (AT32F435VMT7) || defined (AT32F435ZMT7) || defined (AT32F437RMT7) || \
64 defined (AT32F437VMT7) || defined (AT32F437ZMT7)
65#define FLASH_BANK1_START_ADDR ((uint32_t)0x08000000)
66#define FLASH_BANK1_END_ADDR ((uint32_t)0x081FFFFF)
67#define FLASH_BANK2_START_ADDR ((uint32_t)0x08200000)
68#define FLASH_BANK2_END_ADDR ((uint32_t)0x083EFFFF)
69#else
70#define FLASH_BANK1_START_ADDR ((uint32_t)0x08000000)
71#define FLASH_BANK1_END_ADDR ((uint32_t)0x0807FFFF)
72#define FLASH_BANK2_START_ADDR ((uint32_t)0x08080000)
73#define FLASH_BANK2_END_ADDR ((uint32_t)0x080FFFFF)
74#endif
75
79#define FLASH_OBF_FLAG FLASH_BANK1_OBF_FLAG
80#define FLASH_ODF_FLAG FLASH_BANK1_ODF_FLAG
81#define FLASH_PRGMERR_FLAG FLASH_BANK1_PRGMERR_FLAG
82#define FLASH_EPPERR_FLAG FLASH_BANK1_EPPERR_FLAG
83#define FLASH_BANK1_OBF_FLAG ((uint32_t)0x00000001)
84#define FLASH_BANK1_ODF_FLAG ((uint32_t)0x00000020)
85#define FLASH_BANK1_PRGMERR_FLAG ((uint32_t)0x00000004)
86#define FLASH_BANK1_EPPERR_FLAG ((uint32_t)0x00000010)
87#define FLASH_BANK2_OBF_FLAG ((uint32_t)0x10000001)
88#define FLASH_BANK2_ODF_FLAG ((uint32_t)0x10000020)
89#define FLASH_BANK2_PRGMERR_FLAG ((uint32_t)0x10000004)
90#define FLASH_BANK2_EPPERR_FLAG ((uint32_t)0x10000010)
91#define FLASH_USDERR_FLAG ((uint32_t)0x40000001)
96#define FLASH_ERR_INT FLASH_BANK1_ERR_INT
97#define FLASH_ODF_INT FLASH_BANK1_ODF_INT
98#define FLASH_BANK1_ERR_INT ((uint32_t)0x00000001)
99#define FLASH_BANK1_ODF_INT ((uint32_t)0x00000002)
100#define FLASH_BANK2_ERR_INT ((uint32_t)0x00000004)
101#define FLASH_BANK2_ODF_INT ((uint32_t)0x00000008)
106#define FLASH_SLIB_START_SECTOR ((uint32_t)0x0000FFFF)
107#define FLASH_SLIB_INST_START_SECTOR ((uint32_t)0x0000FFFF)
108#define FLASH_SLIB_END_SECTOR ((uint32_t)0xFFFF0000)
113#define USD_WDT_ATO_DISABLE ((uint16_t)0x0001)
114#define USD_WDT_ATO_ENABLE ((uint16_t)0x0000)
119#define USD_DEPSLP_NO_RST ((uint16_t)0x0002)
120#define USD_DEPSLP_RST ((uint16_t)0x0000)
125#define USD_STDBY_NO_RST ((uint16_t)0x0004)
126#define USD_STDBY_RST ((uint16_t)0x0000)
131#define FLASH_BOOT_FROM_BANK1 ((uint16_t)0x0008)
132#define FLASH_BOOT_FROM_BANK2 ((uint16_t)0x0000)
137#define USD_WDT_DEPSLP_CONTINUE ((uint16_t)0x0020)
138#define USD_WDT_DEPSLP_STOP ((uint16_t)0x0000)
143#define USD_WDT_STDBY_CONTINUE ((uint16_t)0x0040)
144#define USD_WDT_STDBY_STOP ((uint16_t)0x0000)
149#define ERASE_TIMEOUT ((uint32_t)0x80000000)
150#define PROGRAMMING_TIMEOUT ((uint32_t)0x00100000)
151#define OPERATION_TIMEOUT ((uint32_t)0x10000000)
161#define flash_clock_divider_set(div) (FLASH->divr_bit.fdiv = div)
162
174typedef enum
175{
176 FLASH_EOPB0_SRAM_512K = 0x00,
177 FLASH_EOPB0_SRAM_448K = 0x01,
178 FLASH_EOPB0_SRAM_384K = 0x02,
179 FLASH_EOPB0_SRAM_320K = 0x03,
180 FLASH_EOPB0_SRAM_256K = 0x04,
181 FLASH_EOPB0_SRAM_192K = 0x05,
182 FLASH_EOPB0_SRAM_128K = 0x06
183} flash_usd_eopb0_type;
184
188typedef enum
189{
190 FLASH_CLOCK_DIV_2 = 0x00,
191 FLASH_CLOCK_DIV_3 = 0x01,
192 FLASH_CLOCK_DIV_4 = 0x02
193} flash_clock_divider_type;
194
198typedef enum
199{
200 FLASH_OPERATE_BUSY = 0x00,
201 FLASH_PROGRAM_ERROR = 0x01,
202 FLASH_EPP_ERROR = 0x02,
203 FLASH_OPERATE_DONE = 0x03,
204 FLASH_OPERATE_TIMEOUT = 0x04
205} flash_status_type;
206
210typedef struct
211{
215 union
216 {
217 __IO uint32_t psr;
218 struct
219 {
220 __IO uint32_t reserved1 : 12;/* [11:0] */
221 __IO uint32_t nzw_bst : 1; /* [12] */
222 __IO uint32_t nzw_bst_sts : 1; /* [13] */
223 __IO uint32_t reserved2 : 18;/* [31:14] */
224 } psr_bit;
225 };
226
230 union
231 {
232 __IO uint32_t unlock;
233 struct
234 {
235 __IO uint32_t ukval : 32;/* [31:0] */
236 } unlock_bit;
237 };
238
242 union
243 {
244 __IO uint32_t usd_unlock;
245 struct
246 {
247 __IO uint32_t usd_ukval : 32;/* [31:0] */
248 } usd_unlock_bit;
249 };
250
254 union
255 {
256 __IO uint32_t sts;
257 struct
258 {
259 __IO uint32_t obf : 1; /* [0] */
260 __IO uint32_t reserved1 : 1; /* [1] */
261 __IO uint32_t prgmerr : 1; /* [2] */
262 __IO uint32_t reserved2 : 1; /* [3] */
263 __IO uint32_t epperr : 1; /* [4] */
264 __IO uint32_t odf : 1; /* [5] */
265 __IO uint32_t reserved3 : 26;/* [31:6] */
266 } sts_bit;
267 };
268
272 union
273 {
274 __IO uint32_t ctrl;
275 struct
276 {
277 __IO uint32_t fprgm : 1; /* [0] */
278 __IO uint32_t secers : 1; /* [1] */
279 __IO uint32_t bankers : 1; /* [2] */
280 __IO uint32_t blkers : 1; /* [3] */
281 __IO uint32_t usdprgm : 1; /* [4] */
282 __IO uint32_t usders : 1; /* [5] */
283 __IO uint32_t erstr : 1; /* [6] */
284 __IO uint32_t oplk : 1; /* [7] */
285 __IO uint32_t reserved1 : 1; /* [8] */
286 __IO uint32_t usdulks : 1; /* [9] */
287 __IO uint32_t errie : 1; /* [10] */
288 __IO uint32_t reserved2 : 1; /* [11] */
289 __IO uint32_t odfie : 1; /* [12] */
290 __IO uint32_t reserved3 : 19;/* [31:13] */
291 } ctrl_bit;
292 };
293
297 union
298 {
299 __IO uint32_t addr;
300 struct
301 {
302 __IO uint32_t fa : 32;/* [31:0] */
303 } addr_bit;
304 };
305
309 __IO uint32_t reserved1;
310
314 union
315 {
316 __IO uint32_t usd;
317 struct
318 {
319 __IO uint32_t usderr : 1; /* [0] */
320 __IO uint32_t fap : 1; /* [1] */
321 __IO uint32_t wdt_ato_en : 1; /* [2] */
322 __IO uint32_t depslp_rst : 1; /* [3] */
323 __IO uint32_t stdby_rst : 1; /* [4] */
324 __IO uint32_t btopt : 1; /* [5] */
325 __IO uint32_t reserved1 : 1; /* [6] */
326 __IO uint32_t wdt_depslp : 1; /* [7] */
327 __IO uint32_t wdt_stdby : 1; /* [8] */
328 __IO uint32_t reserved2 : 1; /* [9] */
329 __IO uint32_t user_d0 : 8; /* [17:10] */
330 __IO uint32_t user_d1 : 8; /* [25:18] */
331 __IO uint32_t reserved3 : 6; /* [31:26] */
332 } usd_bit;
333 };
334
338 union
339 {
340 __IO uint32_t epps0;
341 struct
342 {
343 __IO uint32_t epps : 32;/* [31:0] */
344 } epps0_bit;
345 };
346
350 __IO uint32_t reserved2[2];
351
355 union
356 {
357 __IO uint32_t epps1;
358 struct
359 {
360 __IO uint32_t epps : 32;/* [31:0] */
361 } epps1_bit;
362 };
363
367 __IO uint32_t reserved3[5];
368
372 union
373 {
374 __IO uint32_t unlock2;
375 struct
376 {
377 __IO uint32_t ukval : 32;/* [31:0] */
378 } unlock2_bit;
379 };
380
384 __IO uint32_t reserved4;
385
389 union
390 {
391 __IO uint32_t sts2;
392 struct
393 {
394 __IO uint32_t obf : 1; /* [0] */
395 __IO uint32_t reserved1 : 1; /* [1] */
396 __IO uint32_t prgmerr : 1; /* [2] */
397 __IO uint32_t reserved2 : 1; /* [3] */
398 __IO uint32_t epperr : 1; /* [4] */
399 __IO uint32_t odf : 1; /* [5] */
400 __IO uint32_t reserved3 : 26;/* [31:6] */
401 } sts2_bit;
402 };
403
407 union
408 {
409 __IO uint32_t ctrl2;
410 struct
411 {
412 __IO uint32_t fprgm : 1; /* [0] */
413 __IO uint32_t secers : 1; /* [1] */
414 __IO uint32_t bankers : 1; /* [2] */
415 __IO uint32_t blkers : 1; /* [3] */
416 __IO uint32_t reserved1 : 2; /* [5:4] */
417 __IO uint32_t erstr : 1; /* [6] */
418 __IO uint32_t oplk : 1; /* [7] */
419 __IO uint32_t reserved2 : 2; /* [9:8] */
420 __IO uint32_t errie : 1; /* [10] */
421 __IO uint32_t reserved3 : 1; /* [11] */
422 __IO uint32_t odfie : 1; /* [12] */
423 __IO uint32_t reserved4 : 19;/* [31:13] */
424 } ctrl2_bit;
425 };
426
430 union
431 {
432 __IO uint32_t addr2;
433 struct
434 {
435 __IO uint32_t fa : 32;/* [31:0] */
436 } addr2_bit;
437 };
438
442 union
443 {
444 __IO uint32_t contr;
445 struct
446 {
447 __IO uint32_t reserved1 : 31;/* [30:0] */
448 __IO uint32_t fcontr_en : 1; /* [31] */
449 } contr_bit;
450 };
451
455 __IO uint32_t reserved5;
456
460 union
461 {
462 __IO uint32_t divr;
463 struct
464 {
465 __IO uint32_t fdiv : 2; /* [1:0] */
466 __IO uint32_t reserved1 : 2; /* [3:2] */
467 __IO uint32_t fdiv_sts : 2; /* [5:4] */
468 __IO uint32_t reserved2 : 26;/* [31:6] */
469 } divr_bit;
470 };
471
475 __IO uint32_t reserved6[25];
476
480 union
481 {
482 __IO uint32_t slib_sts2;
483 struct
484 {
485 __IO uint32_t slib_inst_ss : 16;/* [15:0] */
486 __IO uint32_t reserved1 : 16;/* [31:16] */
487 } slib_sts2_bit;
488 };
489
493 union
494 {
495 __IO uint32_t slib_sts0;
496 struct
497 {
498 __IO uint32_t reserved1 : 3; /* [2:0] */
499 __IO uint32_t slib_enf : 1; /* [3] */
500 __IO uint32_t reserved2 : 28;/* [31:4] */
501 } slib_sts0_bit;
502 };
503
507 union
508 {
509 __IO uint32_t slib_sts1;
510 struct
511 {
512 __IO uint32_t slib_ss : 16;/* [15:0] */
513 __IO uint32_t slib_es : 16;/* [31:16] */
514 } slib_sts1_bit;
515 };
516
520 union
521 {
522 __IO uint32_t slib_pwd_clr;
523 struct
524 {
525 __IO uint32_t slib_pclr_val : 32;/* [31:0] */
526 } slib_pwd_clr_bit;
527 };
528
532 union
533 {
534 __IO uint32_t slib_misc_sts;
535 struct
536 {
537 __IO uint32_t slib_pwd_err : 1; /* [0] */
538 __IO uint32_t slib_pwd_ok : 1; /* [1] */
539 __IO uint32_t slib_ulkf : 1; /* [2] */
540 __IO uint32_t reserved1 : 13;/* [15:3] */
541 __IO uint32_t slib_rcnt : 9; /* [24:16] */
542 __IO uint32_t reserved2 : 7; /* [31:25] */
543 } slib_misc_sts_bit;
544 };
545
549 union
550 {
551 __IO uint32_t slib_set_pwd;
552 struct
553 {
554 __IO uint32_t slib_pset_val : 32;/* [31:0] */
555 } slib_set_pwd_bit;
556 };
557
561 union
562 {
563 __IO uint32_t slib_set_range0;
564 struct
565 {
566 __IO uint32_t slib_ss_set : 16;/* [15:0] */
567 __IO uint32_t slib_es_set : 16;/* [31:16] */
568 } slib_set_range0_bit;
569 };
570
574 union
575 {
576 __IO uint32_t slib_set_range1;
577 struct
578 {
579 __IO uint32_t slib_iss_set : 16;/* [15:0] */
580 __IO uint32_t reserved1 : 15;/* [30:16] */
581 __IO uint32_t set_slib_strt : 1; /* [31] */
582 } slib_set_range1_bit;
583 };
584
588 __IO uint32_t reserved7[2];
589
593 union
594 {
595 __IO uint32_t slib_unlock;
596 struct
597 {
598 __IO uint32_t slib_ukval : 32;/* [31:0] */
599 } slib_unlock_bit;
600 };
601
605 union
606 {
607 __IO uint32_t crc_ctrl;
608 struct
609 {
610 __IO uint32_t crc_ss : 12;/* [11:0] */
611 __IO uint32_t crc_sn : 12;/* [23:12] */
612 __IO uint32_t reserved1 : 7; /* [30:24] */
613 __IO uint32_t crc_strt : 1; /* [31] */
614 } crc_ctrl_bit;
615 };
616
620 union
621 {
622 __IO uint32_t crc_chkr;
623 struct
624 {
625 __IO uint32_t crc_chkr : 32;/* [31:0] */
626 } crc_chkr_bit;
627 };
628
629} flash_type;
630
634typedef struct
635{
636 __IO uint16_t fap;
637 __IO uint16_t ssb;
638 __IO uint16_t data0;
639 __IO uint16_t data1;
640 __IO uint16_t epp0;
641 __IO uint16_t epp1;
642 __IO uint16_t epp2;
643 __IO uint16_t epp3;
644 __IO uint16_t eopb0;
645 __IO uint16_t reserved1;
646 __IO uint16_t epp4;
647 __IO uint16_t epp5;
648 __IO uint16_t epp6;
649 __IO uint16_t epp7;
650 __IO uint16_t reserved2[12];
651 __IO uint16_t qspikey[8];
652} usd_type;
653
658#define FLASH ((flash_type *) FLASH_REG_BASE)
659#define USD ((usd_type *) USD_BASE)
660
665 flag_status flash_flag_get(uint32_t flash_flag);
666void flash_flag_clear(uint32_t flash_flag);
667 flash_status_type flash_operation_status_get(void);
668 flash_status_type flash_bank1_operation_status_get(void);
669 flash_status_type flash_bank2_operation_status_get(void);
670 flash_status_type flash_operation_wait_for(uint32_t time_out);
671 flash_status_type flash_bank1_operation_wait_for(uint32_t time_out);
672 flash_status_type flash_bank2_operation_wait_for(uint32_t time_out);
673void flash_unlock(void);
674void flash_bank1_unlock(void);
675void flash_bank2_unlock(void);
676void flash_lock(void);
677void flash_bank1_lock(void);
678void flash_bank2_lock(void);
679 flash_status_type flash_sector_erase(uint32_t sector_address);
680 flash_status_type flash_block_erase(uint32_t block_address);
681 flash_status_type flash_internal_all_erase(void);
682 flash_status_type flash_bank1_erase(void);
683 flash_status_type flash_bank2_erase(void);
684 flash_status_type flash_user_system_data_erase(void);
685 flash_status_type flash_eopb0_config(flash_usd_eopb0_type data);
686 flash_status_type flash_word_program(uint32_t address, uint32_t data);
687 flash_status_type flash_halfword_program(uint32_t address, uint16_t data);
688 flash_status_type flash_byte_program(uint32_t address, uint8_t data);
689 flash_status_type flash_user_system_data_program(uint32_t address, uint8_t data);
690 flash_status_type flash_epp_set(uint32_t *sector_bits);
691void flash_epp_status_get(uint32_t *sector_bits);
692 flash_status_type flash_fap_enable(confirm_state new_state);
693 flag_status flash_fap_status_get(void);
694 flash_status_type flash_ssb_set(uint8_t usd_ssb);
695uint8_t flash_ssb_status_get(void);
696void flash_interrupt_enable(uint32_t flash_int, confirm_state new_state);
697 flash_status_type flash_slib_enable(uint32_t pwd, uint16_t start_sector, uint16_t inst_start_sector, uint16_t end_sector);
698 error_status flash_slib_disable(uint32_t pwd);
699uint32_t flash_slib_remaining_count_get(void);
700 flag_status flash_slib_state_get(void);
701uint16_t flash_slib_start_sector_get(void);
702uint16_t flash_slib_inststart_sector_get(void);
703uint16_t flash_slib_end_sector_get(void);
704uint32_t flash_crc_calibrate(uint32_t start_sector, uint32_t sector_cnt);
705void flash_nzw_boost_enable(confirm_state new_state);
706void flash_continue_read_enable(confirm_state new_state);
707
720#ifdef __cplusplus
721}
722#endif
723
724#endif
at32f435_437.h
at32f435_437 header file
error_status
error_status
Definition: at32f435_437.h:380
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
flash_bank1_operation_status_get
flash_status_type flash_bank1_operation_status_get(void)
return the flash bank1 operation status.
Definition: at32f435_437_flash.c:158
flash_slib_state_get
flag_status flash_slib_state_get(void)
get the slib state.
Definition: at32f435_437_flash.c:1071
flash_bank1_lock
void flash_bank1_lock(void)
lock the flash bank1 controller.
Definition: at32f435_437_flash.c:336
flash_block_erase
flash_status_type flash_block_erase(uint32_t block_address)
erase a specified flash block.
Definition: at32f435_437_flash.c:395
flash_fap_status_get
flag_status flash_fap_status_get(void)
check the flash access protection status.
Definition: at32f435_437_flash.c:895
flash_slib_remaining_count_get
uint32_t flash_slib_remaining_count_get(void)
get remaining count of slib(range: 256~0).
Definition: at32f435_437_flash.c:1061
flash_slib_enable
flash_status_type flash_slib_enable(uint32_t pwd, uint16_t start_sector, uint16_t inst_start_sector, uint16_t end_sector)
enable security library function.
Definition: at32f435_437_flash.c:1001
flash_slib_disable
error_status flash_slib_disable(uint32_t pwd)
disable slib when slib enabled.
Definition: at32f435_437_flash.c:1039
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f435_437_flash.c:357
flash_bank1_erase
flash_status_type flash_bank1_erase(void)
erase flash bank1 sectors.
Definition: at32f435_437_flash.c:468
flash_halfword_program
flash_status_type flash_halfword_program(uint32_t address, uint16_t data)
program a halfword at a specified address.
Definition: at32f435_437_flash.c:643
flash_bank2_operation_status_get
flash_status_type flash_bank2_operation_status_get(void)
return the flash bank2 operation status.
Definition: at32f435_437_flash.c:187
flash_user_system_data_program
flash_status_type flash_user_system_data_program(uint32_t address, uint8_t data)
program a halfword at a specified user system data address.
Definition: at32f435_437_flash.c:713
flash_byte_program
flash_status_type flash_byte_program(uint32_t address, uint8_t data)
program a byte at a specified address.
Definition: at32f435_437_flash.c:679
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f435_437_flash.c:290
flash_operation_status_get
flash_status_type flash_operation_status_get(void)
return the flash operation status.
Definition: at32f435_437_flash.c:129
flash_epp_set
flash_status_type flash_epp_set(uint32_t *sector_bits)
config erase/program protection for the desired sectors.
Definition: at32f435_437_flash.c:751
flash_bank2_unlock
void flash_bank2_unlock(void)
unlock the flash bank2 controller.
Definition: at32f435_437_flash.c:314
flash_ssb_set
flash_status_type flash_ssb_set(uint8_t usd_ssb)
program the flash system setting byte in usd: wdt_ato_en / depslp_rst / stdby_rst / btopt.
Definition: at32f435_437_flash.c:931
flash_bank2_erase
flash_status_type flash_bank2_erase(void)
erase flash bank2 sectors.
Definition: at32f435_437_flash.c:491
flash_crc_calibrate
uint32_t flash_crc_calibrate(uint32_t start_sector, uint32_t sector_cnt)
flash crc calibration in main block.
Definition: at32f435_437_flash.c:1115
flash_slib_start_sector_get
uint16_t flash_slib_start_sector_get(void)
get the start sector of slib.
Definition: at32f435_437_flash.c:1084
flash_eopb0_config
flash_status_type flash_eopb0_config(flash_usd_eopb0_type data)
config the extend sram byte eopb0 in user system data.
Definition: at32f435_437_flash.c:576
flash_interrupt_enable
void flash_interrupt_enable(uint32_t flash_int, confirm_state new_state)
enable or disable the specified flash interrupts.
Definition: at32f435_437_flash.c:980
flash_fap_enable
flash_status_type flash_fap_enable(confirm_state new_state)
enable or disable the flash access protection.
Definition: at32f435_437_flash.c:848
flash_slib_end_sector_get
uint16_t flash_slib_end_sector_get(void)
get the end sector of slib.
Definition: at32f435_437_flash.c:1104
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f435_437_flash.c:608
flash_bank2_operation_wait_for
flash_status_type flash_bank2_operation_wait_for(uint32_t time_out)
wait for flash bank2 operation complete or timeout.
Definition: at32f435_437_flash.c:266
flash_bank1_unlock
void flash_bank1_unlock(void)
unlock the flash bank1 controller.
Definition: at32f435_437_flash.c:303
flash_continue_read_enable
void flash_continue_read_enable(confirm_state new_state)
flash continue read enable.
Definition: at32f435_437_flash.c:1141
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f435_437_flash.c:325
flash_slib_inststart_sector_get
uint16_t flash_slib_inststart_sector_get(void)
get the instruction start sector of slib.
Definition: at32f435_437_flash.c:1094
flash_flag_get
flag_status flash_flag_get(uint32_t flash_flag)
check whether the specified flash flag is set or not.
Definition: at32f435_437_flash.c:63
flash_user_system_data_erase
flash_status_type flash_user_system_data_erase(void)
erase the flash user system data.
Definition: at32f435_437_flash.c:516
flash_internal_all_erase
flash_status_type flash_internal_all_erase(void)
erase flash all internal sectors.
Definition: at32f435_437_flash.c:433
flash_operation_wait_for
flash_status_type flash_operation_wait_for(uint32_t time_out)
wait for flash operation complete or timeout.
Definition: at32f435_437_flash.c:216
flash_bank1_operation_wait_for
flash_status_type flash_bank1_operation_wait_for(uint32_t time_out)
wait for flash bank1 operation complete or timeout.
Definition: at32f435_437_flash.c:241
flash_ssb_status_get
uint8_t flash_ssb_status_get(void)
return the flash system setting byte status.
Definition: at32f435_437_flash.c:960
flash_nzw_boost_enable
void flash_nzw_boost_enable(confirm_state new_state)
flash non-zero wait area boost enable.
Definition: at32f435_437_flash.c:1130
flash_epp_status_get
void flash_epp_status_get(uint32_t *sector_bits)
return the flash erase/program protection status.
Definition: at32f435_437_flash.c:832
flash_flag_clear
void flash_flag_clear(uint32_t flash_flag)
clear the flash flag.
Definition: at32f435_437_flash.c:105
flash_bank2_lock
void flash_bank2_lock(void)
lock the flash bank2 controller.
Definition: at32f435_437_flash.c:346
flash_usd_eopb0_type
flash_usd_eopb0_type
flash usd eopb0 type
Definition: at32f435_437_flash.h:175
flash_clock_divider_type
flash_clock_divider_type
flash clock divider type
Definition: at32f435_437_flash.h:189
flash_status_type
flash_status_type
flash status type
Definition: at32f435_437_flash.h:199
FLASH_EOPB0_SRAM_128K
@ FLASH_EOPB0_SRAM_128K
Definition: at32f435_437_flash.h:182
FLASH_EOPB0_SRAM_448K
@ FLASH_EOPB0_SRAM_448K
Definition: at32f435_437_flash.h:177
FLASH_EOPB0_SRAM_320K
@ FLASH_EOPB0_SRAM_320K
Definition: at32f435_437_flash.h:179
FLASH_EOPB0_SRAM_256K
@ FLASH_EOPB0_SRAM_256K
Definition: at32f435_437_flash.h:180
FLASH_EOPB0_SRAM_192K
@ FLASH_EOPB0_SRAM_192K
Definition: at32f435_437_flash.h:181
FLASH_EOPB0_SRAM_384K
@ FLASH_EOPB0_SRAM_384K
Definition: at32f435_437_flash.h:178
FLASH_EOPB0_SRAM_512K
@ FLASH_EOPB0_SRAM_512K
Definition: at32f435_437_flash.h:176
FLASH_CLOCK_DIV_4
@ FLASH_CLOCK_DIV_4
Definition: at32f435_437_flash.h:192
FLASH_CLOCK_DIV_2
@ FLASH_CLOCK_DIV_2
Definition: at32f435_437_flash.h:190
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
FLASH_OPERATE_BUSY
@ FLASH_OPERATE_BUSY
Definition: at32f435_437_flash.h:200
FLASH_OPERATE_DONE
@ FLASH_OPERATE_DONE
Definition: at32f435_437_flash.h:203
FLASH_OPERATE_TIMEOUT
@ FLASH_OPERATE_TIMEOUT
Definition: at32f435_437_flash.h:204
FLASH_PROGRAM_ERROR
@ FLASH_PROGRAM_ERROR
Definition: at32f435_437_flash.h:201
FLASH_EPP_ERROR
@ FLASH_EPP_ERROR
Definition: at32f435_437_flash.h:202
flash_type
type define flash register all
Definition: at32f435_437_flash.h:211
flash_type::secers
__IO uint32_t secers
Definition: at32f435_437_flash.h:278
flash_type::slib_iss_set
__IO uint32_t slib_iss_set
Definition: at32f435_437_flash.h:579
flash_type::slib_set_range0
__IO uint32_t slib_set_range0
Definition: at32f435_437_flash.h:563
flash_type::wdt_stdby
__IO uint32_t wdt_stdby
Definition: at32f435_437_flash.h:327
flash_type::unlock
__IO uint32_t unlock
Definition: at32f435_437_flash.h:232
flash_type::reserved2
__IO uint32_t reserved2
flash reserved2 register, offset:0x28~0x24
Definition: at32f435_437_flash.h:223
flash_type::crc_sn
__IO uint32_t crc_sn
Definition: at32f435_437_flash.h:611
flash_type::psr
__IO uint32_t psr
Definition: at32f435_437_flash.h:217
flash_type::user_d0
__IO uint32_t user_d0
Definition: at32f435_437_flash.h:329
flash_type::slib_set_pwd
__IO uint32_t slib_set_pwd
Definition: at32f435_437_flash.h:551
flash_type::slib_pwd_err
__IO uint32_t slib_pwd_err
Definition: at32f435_437_flash.h:537
flash_type::ukval
__IO uint32_t ukval
Definition: at32f435_437_flash.h:235
flash_type::slib_ukval
__IO uint32_t slib_ukval
Definition: at32f435_437_flash.h:598
flash_type::nzw_bst
__IO uint32_t nzw_bst
Definition: at32f435_437_flash.h:221
flash_type::fdiv
__IO uint32_t fdiv
Definition: at32f435_437_flash.h:465
flash_type::bankers
__IO uint32_t bankers
Definition: at32f435_437_flash.h:279
flash_type::usd_ukval
__IO uint32_t usd_ukval
Definition: at32f435_437_flash.h:247
flash_type::slib_sts2
__IO uint32_t slib_sts2
Definition: at32f435_437_flash.h:482
flash_type::ctrl
__IO uint32_t ctrl
Definition: at32f435_437_flash.h:274
flash_type::wdt_depslp
__IO uint32_t wdt_depslp
Definition: at32f435_437_flash.h:326
flash_type::slib_inst_ss
__IO uint32_t slib_inst_ss
Definition: at32f435_437_flash.h:485
flash_type::slib_rcnt
__IO uint32_t slib_rcnt
Definition: at32f435_437_flash.h:541
flash_type::stdby_rst
__IO uint32_t stdby_rst
Definition: at32f435_437_flash.h:323
flash_type::crc_strt
__IO uint32_t crc_strt
Definition: at32f435_437_flash.h:613
flash_type::epps
__IO uint32_t epps
Definition: at32f435_437_flash.h:343
flash_type::fprgm
__IO uint32_t fprgm
Definition: at32f435_437_flash.h:277
flash_type::reserved1
__IO uint32_t reserved1
flash reserved1 register, offset:0x18
Definition: at32f435_437_flash.h:220
flash_type::slib_sts1
__IO uint32_t slib_sts1
Definition: at32f435_437_flash.h:509
flash_type::erstr
__IO uint32_t erstr
Definition: at32f435_437_flash.h:283
flash_type::usderr
__IO uint32_t usderr
Definition: at32f435_437_flash.h:319
flash_type::crc_ss
__IO uint32_t crc_ss
Definition: at32f435_437_flash.h:610
flash_type::crc_chkr
__IO uint32_t crc_chkr
Definition: at32f435_437_flash.h:622
flash_type::slib_misc_sts
__IO uint32_t slib_misc_sts
Definition: at32f435_437_flash.h:534
flash_type::usdulks
__IO uint32_t usdulks
Definition: at32f435_437_flash.h:286
flash_type::slib_pclr_val
__IO uint32_t slib_pclr_val
Definition: at32f435_437_flash.h:525
flash_type::slib_ulkf
__IO uint32_t slib_ulkf
Definition: at32f435_437_flash.h:539
flash_type::epperr
__IO uint32_t epperr
Definition: at32f435_437_flash.h:263
flash_type::epps1
__IO uint32_t epps1
Definition: at32f435_437_flash.h:357
flash_type::odfie
__IO uint32_t odfie
Definition: at32f435_437_flash.h:289
flash_type::slib_ss
__IO uint32_t slib_ss
Definition: at32f435_437_flash.h:512
flash_type::blkers
__IO uint32_t blkers
Definition: at32f435_437_flash.h:280
flash_type::btopt
__IO uint32_t btopt
Definition: at32f435_437_flash.h:324
flash_type::fa
__IO uint32_t fa
Definition: at32f435_437_flash.h:302
flash_type::slib_es
__IO uint32_t slib_es
Definition: at32f435_437_flash.h:513
flash_type::fdiv_sts
__IO uint32_t fdiv_sts
Definition: at32f435_437_flash.h:467
flash_type::reserved5
__IO uint32_t reserved5
flash reserved5 register, offset:0x5C
Definition: at32f435_437_flash.h:455
flash_type::slib_ss_set
__IO uint32_t slib_ss_set
Definition: at32f435_437_flash.h:566
flash_type::prgmerr
__IO uint32_t prgmerr
Definition: at32f435_437_flash.h:261
flash_type::unlock2
__IO uint32_t unlock2
Definition: at32f435_437_flash.h:374
flash_type::slib_unlock
__IO uint32_t slib_unlock
Definition: at32f435_437_flash.h:595
flash_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f435_437_flash.h:409
flash_type::set_slib_strt
__IO uint32_t set_slib_strt
Definition: at32f435_437_flash.h:581
flash_type::fcontr_en
__IO uint32_t fcontr_en
Definition: at32f435_437_flash.h:448
flash_type::errie
__IO uint32_t errie
Definition: at32f435_437_flash.h:287
flash_type::user_d1
__IO uint32_t user_d1
Definition: at32f435_437_flash.h:330
flash_type::addr2
__IO uint32_t addr2
Definition: at32f435_437_flash.h:432
flash_type::usd
__IO uint32_t usd
Definition: at32f435_437_flash.h:316
flash_type::depslp_rst
__IO uint32_t depslp_rst
Definition: at32f435_437_flash.h:322
flash_type::slib_pwd_clr
__IO uint32_t slib_pwd_clr
Definition: at32f435_437_flash.h:522
flash_type::usd_unlock
__IO uint32_t usd_unlock
Definition: at32f435_437_flash.h:244
flash_type::nzw_bst_sts
__IO uint32_t nzw_bst_sts
Definition: at32f435_437_flash.h:222
flash_type::wdt_ato_en
__IO uint32_t wdt_ato_en
Definition: at32f435_437_flash.h:321
flash_type::usdprgm
__IO uint32_t usdprgm
Definition: at32f435_437_flash.h:281
flash_type::sts2
__IO uint32_t sts2
Definition: at32f435_437_flash.h:391
flash_type::slib_pwd_ok
__IO uint32_t slib_pwd_ok
Definition: at32f435_437_flash.h:538
flash_type::slib_es_set
__IO uint32_t slib_es_set
Definition: at32f435_437_flash.h:567
flash_type::divr
__IO uint32_t divr
Definition: at32f435_437_flash.h:462
flash_type::usders
__IO uint32_t usders
Definition: at32f435_437_flash.h:282
flash_type::oplk
__IO uint32_t oplk
Definition: at32f435_437_flash.h:284
flash_type::addr
__IO uint32_t addr
Definition: at32f435_437_flash.h:299
flash_type::reserved4
__IO uint32_t reserved4
flash reserved4 register, offset:0x48
Definition: at32f435_437_flash.h:384
flash_type::slib_sts0
__IO uint32_t slib_sts0
Definition: at32f435_437_flash.h:495
flash_type::odf
__IO uint32_t odf
Definition: at32f435_437_flash.h:264
flash_type::epps0
__IO uint32_t epps0
Definition: at32f435_437_flash.h:340
flash_type::fap
__IO uint32_t fap
Definition: at32f435_437_flash.h:320
flash_type::slib_set_range1
__IO uint32_t slib_set_range1
Definition: at32f435_437_flash.h:576
flash_type::crc_ctrl
__IO uint32_t crc_ctrl
Definition: at32f435_437_flash.h:607
flash_type::sts
__IO uint32_t sts
Definition: at32f435_437_flash.h:256
flash_type::slib_pset_val
__IO uint32_t slib_pset_val
Definition: at32f435_437_flash.h:554
flash_type::slib_enf
__IO uint32_t slib_enf
Definition: at32f435_437_flash.h:499
flash_type::reserved3
__IO uint32_t reserved3
flash reserved3 register, offset:0x40~0x30
Definition: at32f435_437_flash.h:265
flash_type::contr
__IO uint32_t contr
Definition: at32f435_437_flash.h:444
flash_type::obf
__IO uint32_t obf
Definition: at32f435_437_flash.h:259
usd_type
user system data
Definition: at32f435_437_flash.h:635
usd_type::eopb0
__IO uint16_t eopb0
Definition: at32f435_437_flash.h:644
usd_type::epp2
__IO uint16_t epp2
Definition: at32f435_437_flash.h:642
usd_type::epp4
__IO uint16_t epp4
Definition: at32f435_437_flash.h:646
usd_type::epp5
__IO uint16_t epp5
Definition: at32f435_437_flash.h:647
usd_type::epp7
__IO uint16_t epp7
Definition: at32f435_437_flash.h:649
usd_type::epp0
__IO uint16_t epp0
Definition: at32f435_437_flash.h:640
usd_type::epp3
__IO uint16_t epp3
Definition: at32f435_437_flash.h:643
usd_type::data1
__IO uint16_t data1
Definition: at32f435_437_flash.h:639
usd_type::reserved1
__IO uint16_t reserved1
Definition: at32f435_437_flash.h:645
usd_type::ssb
__IO uint16_t ssb
Definition: at32f435_437_flash.h:637
usd_type::epp6
__IO uint16_t epp6
Definition: at32f435_437_flash.h:648
usd_type::fap
__IO uint16_t fap
Definition: at32f435_437_flash.h:636
usd_type::epp1
__IO uint16_t epp1
Definition: at32f435_437_flash.h:641
usd_type::data0
__IO uint16_t data0
Definition: at32f435_437_flash.h:638


AT32F435/437 Firmwary Library: at32f435_437_gpio.c Source File

  • libraries
  • drivers
  • src
at32f435_437_gpio.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef GPIO_MODULE_ENABLED
39
51void gpio_reset(gpio_type *gpio_x)
52{
53 if(gpio_x == GPIOA)
54 {
55 crm_periph_reset(CRM_GPIOA_PERIPH_RESET, TRUE);
56 crm_periph_reset(CRM_GPIOA_PERIPH_RESET, FALSE);
57 }
58 else if(gpio_x == GPIOB)
59 {
60 crm_periph_reset(CRM_GPIOB_PERIPH_RESET, TRUE);
61 crm_periph_reset(CRM_GPIOB_PERIPH_RESET, FALSE);
62 }
63 else if(gpio_x == GPIOC)
64 {
65 crm_periph_reset(CRM_GPIOC_PERIPH_RESET, TRUE);
66 crm_periph_reset(CRM_GPIOC_PERIPH_RESET, FALSE);
67 }
68 else if(gpio_x == GPIOD)
69 {
70 crm_periph_reset(CRM_GPIOD_PERIPH_RESET, TRUE);
71 crm_periph_reset(CRM_GPIOD_PERIPH_RESET, FALSE);
72 }
73 else if(gpio_x == GPIOE)
74 {
75 crm_periph_reset(CRM_GPIOE_PERIPH_RESET, TRUE);
76 crm_periph_reset(CRM_GPIOE_PERIPH_RESET, FALSE);
77 }
78 else if(gpio_x == GPIOF)
79 {
80 crm_periph_reset(CRM_GPIOF_PERIPH_RESET, TRUE);
81 crm_periph_reset(CRM_GPIOF_PERIPH_RESET, FALSE);
82 }
83 else if(gpio_x == GPIOG)
84 {
85 crm_periph_reset(CRM_GPIOG_PERIPH_RESET, TRUE);
86 crm_periph_reset(CRM_GPIOG_PERIPH_RESET, FALSE);
87 }
88 else if(gpio_x == GPIOH)
89 {
90 crm_periph_reset(CRM_GPIOH_PERIPH_RESET, TRUE);
91 crm_periph_reset(CRM_GPIOH_PERIPH_RESET, FALSE);
92 }
93}
94
103void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
104{
105 uint16_t pinx_value, pin_index = 0;
106
107 pinx_value = (uint16_t)gpio_init_struct->gpio_pins;
108
109 while(pinx_value > 0)
110 {
111 if(pinx_value & 0x01)
112 {
113 gpio_x->cfgr &= (uint32_t)~(0x03 << (pin_index * 2));
114 gpio_x->cfgr |= (uint32_t)(gpio_init_struct->gpio_mode << (pin_index * 2));
115
116 gpio_x->omode &= (uint32_t)~(0x01 << (pin_index));
117 gpio_x->omode |= (uint32_t)(gpio_init_struct->gpio_out_type << (pin_index));
118
119 gpio_x->odrvr &= (uint32_t)~(0x03 << (pin_index * 2));
120 gpio_x->odrvr |= (uint32_t)(gpio_init_struct->gpio_drive_strength << (pin_index * 2));
121
122 gpio_x->pull &= (uint32_t)~(0x03 << (pin_index * 2));
123 gpio_x->pull |= (uint32_t)(gpio_init_struct->gpio_pull << (pin_index * 2));
124 }
125 pinx_value >>= 1;
126 pin_index++;
127 }
128}
129
135void gpio_default_para_init(gpio_init_type *gpio_init_struct)
136{
137 /* reset gpio init structure parameters values */
138 gpio_init_struct->gpio_pins = GPIO_PINS_ALL;
139 gpio_init_struct->gpio_mode = GPIO_MODE_INPUT;
140 gpio_init_struct->gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
141 gpio_init_struct->gpio_pull = GPIO_PULL_NONE;
142 gpio_init_struct->gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
143}
144
170 flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
171{
172 flag_status status = RESET;
173
174 if(pins != (pins & gpio_x->idt))
175 {
176 status = RESET;
177 }
178 else
179 {
180 status = SET;
181 }
182
183 return status;
184}
185
193uint16_t gpio_input_data_read(gpio_type *gpio_x)
194{
195 return ((uint16_t)(gpio_x->idt));
196}
197
223 flag_status gpio_output_data_bit_read(gpio_type *gpio_x, uint16_t pins)
224{
225 flag_status status = RESET;
226
227 if((gpio_x->odt & pins) != RESET)
228 {
229 status = SET;
230 }
231 else
232 {
233 status = RESET;
234 }
235
236 return status;
237}
238
246uint16_t gpio_output_data_read(gpio_type *gpio_x)
247{
248 return ((uint16_t)(gpio_x->odt));
249}
250
277void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
278{
279 gpio_x->scr = pins;
280}
281
308void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
309{
310 gpio_x->clr = pins;
311}
312
340void gpio_bits_write(gpio_type *gpio_x, uint16_t pins, confirm_state bit_state)
341{
342 if(bit_state != FALSE)
343 {
344 gpio_x->scr = pins;
345 }
346 else
347 {
348 gpio_x->clr = pins;
349 }
350}
351
360void gpio_port_write(gpio_type *gpio_x, uint16_t port_value)
361{
362 gpio_x->odt = port_value;
363}
364
391void gpio_pin_wp_config(gpio_type *gpio_x, uint16_t pins)
392{
393 uint32_t temp = 0x00010000;
394
395 temp |= pins;
396 /* set wpen bit */
397 gpio_x->wpr = temp;
398 /* reset wpen bit */
399 gpio_x->wpr = pins;
400 /* set wpen bit */
401 gpio_x->wpr = temp;
402 /* read wpen bit*/
403 temp = gpio_x->wpr;
404 /* read wpen bit*/
405 temp = gpio_x->wpr;
406}
407
436void gpio_pins_huge_driven_config(gpio_type *gpio_x, uint16_t pins, confirm_state new_state)
437{
438 if(new_state != FALSE)
439 {
440 gpio_x->hdrv |= pins;
441 }
442 else
443 {
444 gpio_x->hdrv &= ~pins;
445 }
446}
447
491void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
492{
493 uint32_t temp = 0x00;
494 uint32_t temp_2 = 0x00;
495
496 temp = ((uint32_t)(gpio_mux) << ((uint32_t)((uint32_t)gpio_pin_source & (uint32_t)0x07) * 4));
497 if(gpio_pin_source >> 0x03)
498 {
499 gpio_x->muxh &= ~((uint32_t)0xF << ((uint32_t)((uint32_t)gpio_pin_source & (uint32_t)0x07) * 4));
500 temp_2 = gpio_x->muxh | temp;
501 gpio_x->muxh = temp_2;
502 }
503 else
504 {
505 gpio_x->muxl &= ~((uint32_t)0xF << ((uint32_t)((uint32_t)gpio_pin_source & (uint32_t)0x07) * 4));
506 temp_2 = gpio_x->muxl | temp;
507 gpio_x->muxl = temp_2;
508 }
509}
510
515#endif
516
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f435_437_crm.c:251
CRM_GPIOH_PERIPH_RESET
@ CRM_GPIOH_PERIPH_RESET
Definition: at32f435_437_crm.h:259
CRM_GPIOE_PERIPH_RESET
@ CRM_GPIOE_PERIPH_RESET
Definition: at32f435_437_crm.h:256
CRM_GPIOF_PERIPH_RESET
@ CRM_GPIOF_PERIPH_RESET
Definition: at32f435_437_crm.h:257
CRM_GPIOD_PERIPH_RESET
@ CRM_GPIOD_PERIPH_RESET
Definition: at32f435_437_crm.h:255
CRM_GPIOC_PERIPH_RESET
@ CRM_GPIOC_PERIPH_RESET
Definition: at32f435_437_crm.h:254
CRM_GPIOG_PERIPH_RESET
@ CRM_GPIOG_PERIPH_RESET
Definition: at32f435_437_crm.h:258
CRM_GPIOA_PERIPH_RESET
@ CRM_GPIOA_PERIPH_RESET
Definition: at32f435_437_crm.h:252
CRM_GPIOB_PERIPH_RESET
@ CRM_GPIOB_PERIPH_RESET
Definition: at32f435_437_crm.h:253
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
gpio_pins_source_type
gpio_pins_source_type
gpio pins source type
Definition: at32f435_437_gpio.h:132
gpio_mux_sel_type
gpio_mux_sel_type
gpio muxing function selection type
Definition: at32f435_437_gpio.h:155
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f435_437_gpio.h:82
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_PINS_ALL
#define GPIO_PINS_ALL
Definition: at32f435_437_gpio.h:67
gpio_output_data_read
uint16_t gpio_output_data_read(gpio_type *gpio_x)
read the specified gpio ouput data port.
Definition: at32f435_437_gpio.c:246
gpio_output_data_bit_read
flag_status gpio_output_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified output port pin.
Definition: at32f435_437_gpio.c:223
gpio_bits_write
void gpio_bits_write(gpio_type *gpio_x, uint16_t pins, confirm_state bit_state)
set or clear the selected data port bit.
Definition: at32f435_437_gpio.c:340
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f435_437_gpio.c:308
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_input_data_read
uint16_t gpio_input_data_read(gpio_type *gpio_x)
read the specified gpio input data port.
Definition: at32f435_437_gpio.c:193
gpio_pin_wp_config
void gpio_pin_wp_config(gpio_type *gpio_x, uint16_t pins)
write protect gpio pins configuration registers.
Definition: at32f435_437_gpio.c:391
gpio_port_write
void gpio_port_write(gpio_type *gpio_x, uint16_t port_value)
write data to the specified gpio data port.
Definition: at32f435_437_gpio.c:360
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_input_data_bit_read
flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified input port pin.
Definition: at32f435_437_gpio.c:170
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f435_437_gpio.c:277
gpio_pins_huge_driven_config
void gpio_pins_huge_driven_config(gpio_type *gpio_x, uint16_t pins, confirm_state new_state)
enable or disable gpio pins huge driven.
Definition: at32f435_437_gpio.c:436
gpio_reset
void gpio_reset(gpio_type *gpio_x)
reset the gpio register
Definition: at32f435_437_gpio.c:51
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIOG
#define GPIOG
Definition: at32f435_437_gpio.h:527
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOF
#define GPIOF
Definition: at32f435_437_gpio.h:526
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
GPIOH
#define GPIOH
Definition: at32f435_437_gpio.h:528
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
gpio_type
type define gpio register all
Definition: at32f435_437_gpio.h:178
gpio_type::pull
__IO uint32_t pull
Definition: at32f435_437_gpio.h:266
gpio_type::hdrv
__IO uint32_t hdrv
Definition: at32f435_437_gpio.h:492
gpio_type::scr
__IO uint32_t scr
Definition: at32f435_437_gpio.h:349
gpio_type::muxh
__IO uint32_t muxh
Definition: at32f435_437_gpio.h:440
gpio_type::odt
__IO uint32_t odt
Definition: at32f435_437_gpio.h:321
gpio_type::odrvr
__IO uint32_t odrvr
Definition: at32f435_437_gpio.h:239
gpio_type::cfgr
__IO uint32_t cfgr
Definition: at32f435_437_gpio.h:184
gpio_type::clr
__IO uint32_t clr
Definition: at32f435_437_gpio.h:459
gpio_type::omode
__IO uint32_t omode
Definition: at32f435_437_gpio.h:211
gpio_type::muxl
__IO uint32_t muxl
Definition: at32f435_437_gpio.h:421
gpio_type::idt
__IO uint32_t idt
Definition: at32f435_437_gpio.h:293
gpio_type::wpr
__IO uint32_t wpr
Definition: at32f435_437_gpio.h:392
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_gpio.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_gpio.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_GPIO_H
29#define __AT32F435_437_GPIO_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
51#define GPIO_PINS_0 0x0001
52#define GPIO_PINS_1 0x0002
53#define GPIO_PINS_2 0x0004
54#define GPIO_PINS_3 0x0008
55#define GPIO_PINS_4 0x0010
56#define GPIO_PINS_5 0x0020
57#define GPIO_PINS_6 0x0040
58#define GPIO_PINS_7 0x0080
59#define GPIO_PINS_8 0x0100
60#define GPIO_PINS_9 0x0200
61#define GPIO_PINS_10 0x0400
62#define GPIO_PINS_11 0x0800
63#define GPIO_PINS_12 0x1000
64#define GPIO_PINS_13 0x2000
65#define GPIO_PINS_14 0x4000
66#define GPIO_PINS_15 0x8000
67#define GPIO_PINS_ALL 0xFFFF
80typedef enum
81{
82 GPIO_MODE_INPUT = 0x00,
83 GPIO_MODE_OUTPUT = 0x01,
84 GPIO_MODE_MUX = 0x02,
85 GPIO_MODE_ANALOG = 0x03
86} gpio_mode_type;
87
91typedef enum
92{
93 GPIO_DRIVE_STRENGTH_STRONGER = 0x01,
94 GPIO_DRIVE_STRENGTH_MODERATE = 0x02
95} gpio_drive_type;
96
100typedef enum
101{
102 GPIO_OUTPUT_PUSH_PULL = 0x00,
103 GPIO_OUTPUT_OPEN_DRAIN = 0x01
104} gpio_output_type;
105
109typedef enum
110{
111 GPIO_PULL_NONE = 0x00,
112 GPIO_PULL_UP = 0x01,
113 GPIO_PULL_DOWN = 0x02
114} gpio_pull_type;
115
119typedef struct
120{
121 uint32_t gpio_pins;
122 gpio_output_type gpio_out_type;
123 gpio_pull_type gpio_pull;
124 gpio_mode_type gpio_mode;
125 gpio_drive_type gpio_drive_strength;
126} gpio_init_type;
127
131typedef enum
132{
133 GPIO_PINS_SOURCE0 = 0x00,
134 GPIO_PINS_SOURCE1 = 0x01,
135 GPIO_PINS_SOURCE2 = 0x02,
136 GPIO_PINS_SOURCE3 = 0x03,
137 GPIO_PINS_SOURCE4 = 0x04,
138 GPIO_PINS_SOURCE5 = 0x05,
139 GPIO_PINS_SOURCE6 = 0x06,
140 GPIO_PINS_SOURCE7 = 0x07,
141 GPIO_PINS_SOURCE8 = 0x08,
142 GPIO_PINS_SOURCE9 = 0x09,
143 GPIO_PINS_SOURCE10 = 0x0A,
144 GPIO_PINS_SOURCE11 = 0x0B,
145 GPIO_PINS_SOURCE12 = 0x0C,
146 GPIO_PINS_SOURCE13 = 0x0D,
147 GPIO_PINS_SOURCE14 = 0x0E,
148 GPIO_PINS_SOURCE15 = 0x0F
149} gpio_pins_source_type;
150
154typedef enum
155{
156 GPIO_MUX_0 = 0x00,
157 GPIO_MUX_1 = 0x01,
158 GPIO_MUX_2 = 0x02,
159 GPIO_MUX_3 = 0x03,
160 GPIO_MUX_4 = 0x04,
161 GPIO_MUX_5 = 0x05,
162 GPIO_MUX_6 = 0x06,
163 GPIO_MUX_7 = 0x07,
164 GPIO_MUX_8 = 0x08,
165 GPIO_MUX_9 = 0x09,
166 GPIO_MUX_10 = 0x0A,
167 GPIO_MUX_11 = 0x0B,
168 GPIO_MUX_12 = 0x0C,
169 GPIO_MUX_13 = 0x0D,
170 GPIO_MUX_14 = 0x0E,
171 GPIO_MUX_15 = 0x0F
172} gpio_mux_sel_type;
173
177typedef struct
178{
182 union
183 {
184 __IO uint32_t cfgr;
185 struct
186 {
187 __IO uint32_t iomc0 : 2; /* [1:0] */
188 __IO uint32_t iomc1 : 2; /* [3:2] */
189 __IO uint32_t iomc2 : 2; /* [5:4] */
190 __IO uint32_t iomc3 : 2; /* [7:6] */
191 __IO uint32_t iomc4 : 2; /* [9:8] */
192 __IO uint32_t iomc5 : 2; /* [11:10] */
193 __IO uint32_t iomc6 : 2; /* [13:12] */
194 __IO uint32_t iomc7 : 2; /* [15:14] */
195 __IO uint32_t iomc8 : 2; /* [17:16] */
196 __IO uint32_t iomc9 : 2; /* [19:18] */
197 __IO uint32_t iomc10 : 2; /* [21:20] */
198 __IO uint32_t iomc11 : 2; /* [23:22] */
199 __IO uint32_t iomc12 : 2; /* [25:24] */
200 __IO uint32_t iomc13 : 2; /* [27:26] */
201 __IO uint32_t iomc14 : 2; /* [29:28] */
202 __IO uint32_t iomc15 : 2; /* [31:30] */
203 } cfgr_bit;
204 };
205
209 union
210 {
211 __IO uint32_t omode;
212 struct
213 {
214 __IO uint32_t om0 : 1; /* [0] */
215 __IO uint32_t om1 : 1; /* [1] */
216 __IO uint32_t om2 : 1; /* [2] */
217 __IO uint32_t om3 : 1; /* [3] */
218 __IO uint32_t om4 : 1; /* [4] */
219 __IO uint32_t om5 : 1; /* [5] */
220 __IO uint32_t om6 : 1; /* [6] */
221 __IO uint32_t om7 : 1; /* [7] */
222 __IO uint32_t om8 : 1; /* [8] */
223 __IO uint32_t om9 : 1; /* [9] */
224 __IO uint32_t om10 : 1; /* [10] */
225 __IO uint32_t om11 : 1; /* [11] */
226 __IO uint32_t om12 : 1; /* [12] */
227 __IO uint32_t om13 : 1; /* [13] */
228 __IO uint32_t om14 : 1; /* [14] */
229 __IO uint32_t om15 : 1; /* [15] */
230 __IO uint32_t reserved1 : 16;/* [31:16] */
231 } omode_bit;
232 };
233
237 union
238 {
239 __IO uint32_t odrvr;
240 struct
241 {
242 __IO uint32_t odrv0 : 2; /* [1:0] */
243 __IO uint32_t odrv1 : 2; /* [3:2] */
244 __IO uint32_t odrv2 : 2; /* [5:4] */
245 __IO uint32_t odrv3 : 2; /* [7:6] */
246 __IO uint32_t odrv4 : 2; /* [9:8] */
247 __IO uint32_t odrv5 : 2; /* [11:10] */
248 __IO uint32_t odrv6 : 2; /* [13:12] */
249 __IO uint32_t odrv7 : 2; /* [15:14] */
250 __IO uint32_t odrv8 : 2; /* [17:16] */
251 __IO uint32_t odrv9 : 2; /* [19:18] */
252 __IO uint32_t odrv10 : 2; /* [21:20] */
253 __IO uint32_t odrv11 : 2; /* [23:22] */
254 __IO uint32_t odrv12 : 2; /* [25:24] */
255 __IO uint32_t odrv13 : 2; /* [27:26] */
256 __IO uint32_t odrv14 : 2; /* [29:28] */
257 __IO uint32_t odrv15 : 2; /* [31:30] */
258 } odrvr_bit;
259 };
260
264 union
265 {
266 __IO uint32_t pull;
267 struct
268 {
269 __IO uint32_t pull0 : 2; /* [1:0] */
270 __IO uint32_t pull1 : 2; /* [3:2] */
271 __IO uint32_t pull2 : 2; /* [5:4] */
272 __IO uint32_t pull3 : 2; /* [7:6] */
273 __IO uint32_t pull4 : 2; /* [9:8] */
274 __IO uint32_t pull5 : 2; /* [11:10] */
275 __IO uint32_t pull6 : 2; /* [13:12] */
276 __IO uint32_t pull7 : 2; /* [15:14] */
277 __IO uint32_t pull8 : 2; /* [17:16] */
278 __IO uint32_t pull9 : 2; /* [19:18] */
279 __IO uint32_t pull10 : 2; /* [21:20] */
280 __IO uint32_t pull11 : 2; /* [23:22] */
281 __IO uint32_t pull12 : 2; /* [25:24] */
282 __IO uint32_t pull13 : 2; /* [27:26] */
283 __IO uint32_t pull14 : 2; /* [29:28] */
284 __IO uint32_t pull15 : 2; /* [31:30] */
285 } pull_bit;
286 };
287
291 union
292 {
293 __IO uint32_t idt;
294 struct
295 {
296 __IO uint32_t idt0 : 1; /* [0] */
297 __IO uint32_t idt1 : 1; /* [1] */
298 __IO uint32_t idt2 : 1; /* [2] */
299 __IO uint32_t idt3 : 1; /* [3] */
300 __IO uint32_t idt4 : 1; /* [4] */
301 __IO uint32_t idt5 : 1; /* [5] */
302 __IO uint32_t idt6 : 1; /* [6] */
303 __IO uint32_t idt7 : 1; /* [7] */
304 __IO uint32_t idt8 : 1; /* [8] */
305 __IO uint32_t idt9 : 1; /* [9] */
306 __IO uint32_t idt10 : 1; /* [10] */
307 __IO uint32_t idt11 : 1; /* [11] */
308 __IO uint32_t idt12 : 1; /* [12] */
309 __IO uint32_t idt13 : 1; /* [13] */
310 __IO uint32_t idt14 : 1; /* [14] */
311 __IO uint32_t idt15 : 1; /* [15] */
312 __IO uint32_t reserved1 : 16;/* [31:16] */
313 } idt_bit;
314 };
315
319 union
320 {
321 __IO uint32_t odt;
322 struct
323 {
324 __IO uint32_t odt0 : 1; /* [0] */
325 __IO uint32_t odt1 : 1; /* [1] */
326 __IO uint32_t odt2 : 1; /* [2] */
327 __IO uint32_t odt3 : 1; /* [3] */
328 __IO uint32_t odt4 : 1; /* [4] */
329 __IO uint32_t odt5 : 1; /* [5] */
330 __IO uint32_t odt6 : 1; /* [6] */
331 __IO uint32_t odt7 : 1; /* [7] */
332 __IO uint32_t odt8 : 1; /* [8] */
333 __IO uint32_t odt9 : 1; /* [9] */
334 __IO uint32_t odt10 : 1; /* [10] */
335 __IO uint32_t odt11 : 1; /* [11] */
336 __IO uint32_t odt12 : 1; /* [12] */
337 __IO uint32_t odt13 : 1; /* [13] */
338 __IO uint32_t odt14 : 1; /* [14] */
339 __IO uint32_t odt15 : 1; /* [15] */
340 __IO uint32_t reserved1 : 16;/* [31:16] */
341 } odt_bit;
342 };
343
347 union
348 {
349 __IO uint32_t scr;
350 struct
351 {
352 __IO uint32_t iosb0 : 1; /* [0] */
353 __IO uint32_t iosb1 : 1; /* [1] */
354 __IO uint32_t iosb2 : 1; /* [2] */
355 __IO uint32_t iosb3 : 1; /* [3] */
356 __IO uint32_t iosb4 : 1; /* [4] */
357 __IO uint32_t iosb5 : 1; /* [5] */
358 __IO uint32_t iosb6 : 1; /* [6] */
359 __IO uint32_t iosb7 : 1; /* [7] */
360 __IO uint32_t iosb8 : 1; /* [8] */
361 __IO uint32_t iosb9 : 1; /* [9] */
362 __IO uint32_t iosb10 : 1; /* [10] */
363 __IO uint32_t iosb11 : 1; /* [11] */
364 __IO uint32_t iosb12 : 1; /* [12] */
365 __IO uint32_t iosb13 : 1; /* [13] */
366 __IO uint32_t iosb14 : 1; /* [14] */
367 __IO uint32_t iosb15 : 1; /* [15] */
368 __IO uint32_t iocb0 : 1; /* [16] */
369 __IO uint32_t iocb1 : 1; /* [17] */
370 __IO uint32_t iocb2 : 1; /* [18] */
371 __IO uint32_t iocb3 : 1; /* [19] */
372 __IO uint32_t iocb4 : 1; /* [20] */
373 __IO uint32_t iocb5 : 1; /* [21] */
374 __IO uint32_t iocb6 : 1; /* [22] */
375 __IO uint32_t iocb7 : 1; /* [23] */
376 __IO uint32_t iocb8 : 1; /* [24] */
377 __IO uint32_t iocb9 : 1; /* [25] */
378 __IO uint32_t iocb10 : 1; /* [26] */
379 __IO uint32_t iocb11 : 1; /* [27] */
380 __IO uint32_t iocb12 : 1; /* [28] */
381 __IO uint32_t iocb13 : 1; /* [29] */
382 __IO uint32_t iocb14 : 1; /* [30] */
383 __IO uint32_t iocb15 : 1; /* [31] */
384 } scr_bit;
385 };
386
390 union
391 {
392 __IO uint32_t wpr;
393 struct
394 {
395 __IO uint32_t wpen0 : 1; /* [0] */
396 __IO uint32_t wpen1 : 1; /* [1] */
397 __IO uint32_t wpen2 : 1; /* [2] */
398 __IO uint32_t wpen3 : 1; /* [3] */
399 __IO uint32_t wpen4 : 1; /* [4] */
400 __IO uint32_t wpen5 : 1; /* [5] */
401 __IO uint32_t wpen6 : 1; /* [6] */
402 __IO uint32_t wpen7 : 1; /* [7] */
403 __IO uint32_t wpen8 : 1; /* [8] */
404 __IO uint32_t wpen9 : 1; /* [9] */
405 __IO uint32_t wpen10 : 1; /* [10] */
406 __IO uint32_t wpen11 : 1; /* [11] */
407 __IO uint32_t wpen12 : 1; /* [12] */
408 __IO uint32_t wpen13 : 1; /* [13] */
409 __IO uint32_t wpen14 : 1; /* [14] */
410 __IO uint32_t wpen15 : 1; /* [15] */
411 __IO uint32_t wpseq : 1; /* [16] */
412 __IO uint32_t reserved1 : 15;/* [31:17] */
413 } wpr_bit;
414 };
415
419 union
420 {
421 __IO uint32_t muxl;
422 struct
423 {
424 __IO uint32_t muxl0 : 4; /* [3:0] */
425 __IO uint32_t muxl1 : 4; /* [7:4] */
426 __IO uint32_t muxl2 : 4; /* [11:8] */
427 __IO uint32_t muxl3 : 4; /* [15:12] */
428 __IO uint32_t muxl4 : 4; /* [19:16] */
429 __IO uint32_t muxl5 : 4; /* [23:20] */
430 __IO uint32_t muxl6 : 4; /* [27:24] */
431 __IO uint32_t muxl7 : 4; /* [31:28] */
432 } muxl_bit;
433 };
434
438 union
439 {
440 __IO uint32_t muxh;
441 struct
442 {
443 __IO uint32_t muxh8 : 4; /* [3:0] */
444 __IO uint32_t muxh9 : 4; /* [7:4] */
445 __IO uint32_t muxh10 : 4; /* [11:8] */
446 __IO uint32_t muxh11 : 4; /* [15:12] */
447 __IO uint32_t muxh12 : 4; /* [19:16] */
448 __IO uint32_t muxh13 : 4; /* [23:20] */
449 __IO uint32_t muxh14 : 4; /* [27:24] */
450 __IO uint32_t muxh15 : 4; /* [31:28] */
451 } muxh_bit;
452 };
453
457 union
458 {
459 __IO uint32_t clr;
460 struct
461 {
462 __IO uint32_t iocb0 : 1; /* [0] */
463 __IO uint32_t iocb1 : 1; /* [1] */
464 __IO uint32_t iocb2 : 1; /* [2] */
465 __IO uint32_t iocb3 : 1; /* [3] */
466 __IO uint32_t iocb4 : 1; /* [4] */
467 __IO uint32_t iocb5 : 1; /* [5] */
468 __IO uint32_t iocb6 : 1; /* [6] */
469 __IO uint32_t iocb7 : 1; /* [7] */
470 __IO uint32_t iocb8 : 1; /* [8] */
471 __IO uint32_t iocb9 : 1; /* [9] */
472 __IO uint32_t iocb10 : 1; /* [10] */
473 __IO uint32_t iocb11 : 1; /* [11] */
474 __IO uint32_t iocb12 : 1; /* [12] */
475 __IO uint32_t iocb13 : 1; /* [13] */
476 __IO uint32_t iocb14 : 1; /* [14] */
477 __IO uint32_t iocb15 : 1; /* [15] */
478 __IO uint32_t reserved1 : 16;/* [31:16] */
479 } clr_bit;
480 };
481
485 __IO uint32_t reserved1[4];
486
490 union
491 {
492 __IO uint32_t hdrv;
493 struct
494 {
495 __IO uint32_t hdrv0 : 1; /* [0] */
496 __IO uint32_t hdrv1 : 1; /* [1] */
497 __IO uint32_t hdrv2 : 1; /* [2] */
498 __IO uint32_t hdrv3 : 1; /* [3] */
499 __IO uint32_t hdrv4 : 1; /* [4] */
500 __IO uint32_t hdrv5 : 1; /* [5] */
501 __IO uint32_t hdrv6 : 1; /* [6] */
502 __IO uint32_t hdrv7 : 1; /* [7] */
503 __IO uint32_t hdrv8 : 1; /* [8] */
504 __IO uint32_t hdrv9 : 1; /* [9] */
505 __IO uint32_t hdrv10 : 1; /* [10] */
506 __IO uint32_t hdrv11 : 1; /* [11] */
507 __IO uint32_t hdrv12 : 1; /* [12] */
508 __IO uint32_t hdrv13 : 1; /* [13] */
509 __IO uint32_t hdrv14 : 1; /* [14] */
510 __IO uint32_t hdrv15 : 1; /* [15] */
511 __IO uint32_t reserved1 : 16;/* [31:16] */
512 } hdrv_bit;
513 };
514
515} gpio_type;
516
521#define GPIOA ((gpio_type *) GPIOA_BASE)
522#define GPIOB ((gpio_type *) GPIOB_BASE)
523#define GPIOC ((gpio_type *) GPIOC_BASE)
524#define GPIOD ((gpio_type *) GPIOD_BASE)
525#define GPIOE ((gpio_type *) GPIOE_BASE)
526#define GPIOF ((gpio_type *) GPIOF_BASE)
527#define GPIOG ((gpio_type *) GPIOG_BASE)
528#define GPIOH ((gpio_type *) GPIOH_BASE)
529
534void gpio_reset(gpio_type *gpio_x);
535void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct);
536void gpio_default_para_init(gpio_init_type *gpio_init_struct);
537 flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins);
538uint16_t gpio_input_data_read(gpio_type *gpio_x);
539 flag_status gpio_output_data_bit_read(gpio_type *gpio_x, uint16_t pins);
540uint16_t gpio_output_data_read(gpio_type *gpio_x);
541void gpio_bits_set(gpio_type *gpio_x, uint16_t pins);
542void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins);
543void gpio_bits_write(gpio_type *gpio_x, uint16_t pins, confirm_state bit_state);
544void gpio_port_write(gpio_type *gpio_x, uint16_t port_value);
545void gpio_pin_wp_config(gpio_type *gpio_x, uint16_t pins);
546void gpio_pins_huge_driven_config(gpio_type *gpio_x, uint16_t pins, confirm_state new_state);
547void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux);
548
561#ifdef __cplusplus
562}
563#endif
564
565#endif
at32f435_437.h
at32f435_437 header file
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
gpio_output_data_read
uint16_t gpio_output_data_read(gpio_type *gpio_x)
read the specified gpio ouput data port.
Definition: at32f435_437_gpio.c:246
gpio_output_data_bit_read
flag_status gpio_output_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified output port pin.
Definition: at32f435_437_gpio.c:223
gpio_bits_write
void gpio_bits_write(gpio_type *gpio_x, uint16_t pins, confirm_state bit_state)
set or clear the selected data port bit.
Definition: at32f435_437_gpio.c:340
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f435_437_gpio.c:308
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_input_data_read
uint16_t gpio_input_data_read(gpio_type *gpio_x)
read the specified gpio input data port.
Definition: at32f435_437_gpio.c:193
gpio_pin_wp_config
void gpio_pin_wp_config(gpio_type *gpio_x, uint16_t pins)
write protect gpio pins configuration registers.
Definition: at32f435_437_gpio.c:391
gpio_port_write
void gpio_port_write(gpio_type *gpio_x, uint16_t port_value)
write data to the specified gpio data port.
Definition: at32f435_437_gpio.c:360
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_input_data_bit_read
flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified input port pin.
Definition: at32f435_437_gpio.c:170
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f435_437_gpio.c:277
gpio_pins_huge_driven_config
void gpio_pins_huge_driven_config(gpio_type *gpio_x, uint16_t pins, confirm_state new_state)
enable or disable gpio pins huge driven.
Definition: at32f435_437_gpio.c:436
gpio_reset
void gpio_reset(gpio_type *gpio_x)
reset the gpio register
Definition: at32f435_437_gpio.c:51
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
gpio_mode_type
gpio_mode_type
gpio mode select
Definition: at32f435_437_gpio.h:81
gpio_drive_type
gpio_drive_type
gpio output drive strength select
Definition: at32f435_437_gpio.h:92
gpio_pins_source_type
gpio_pins_source_type
gpio pins source type
Definition: at32f435_437_gpio.h:132
gpio_pull_type
gpio_pull_type
gpio pull type
Definition: at32f435_437_gpio.h:110
gpio_output_type
gpio_output_type
gpio output type
Definition: at32f435_437_gpio.h:101
gpio_mux_sel_type
gpio_mux_sel_type
gpio muxing function selection type
Definition: at32f435_437_gpio.h:155
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f435_437_gpio.h:85
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f435_437_gpio.h:82
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_MODERATE
@ GPIO_DRIVE_STRENGTH_MODERATE
Definition: at32f435_437_gpio.h:94
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f435_437_gpio.h:146
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f435_437_gpio.h:103
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_15
@ GPIO_MUX_15
Definition: at32f435_437_gpio.h:171
GPIO_MUX_2
@ GPIO_MUX_2
Definition: at32f435_437_gpio.h:158
GPIO_MUX_6
@ GPIO_MUX_6
Definition: at32f435_437_gpio.h:162
GPIO_MUX_4
@ GPIO_MUX_4
Definition: at32f435_437_gpio.h:160
GPIO_MUX_1
@ GPIO_MUX_1
Definition: at32f435_437_gpio.h:157
GPIO_MUX_5
@ GPIO_MUX_5
Definition: at32f435_437_gpio.h:161
GPIO_MUX_9
@ GPIO_MUX_9
Definition: at32f435_437_gpio.h:165
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_MUX_0
@ GPIO_MUX_0
Definition: at32f435_437_gpio.h:156
GPIO_MUX_8
@ GPIO_MUX_8
Definition: at32f435_437_gpio.h:164
GPIO_MUX_3
@ GPIO_MUX_3
Definition: at32f435_437_gpio.h:159
GPIO_MUX_10
@ GPIO_MUX_10
Definition: at32f435_437_gpio.h:166
GPIO_MUX_14
@ GPIO_MUX_14
Definition: at32f435_437_gpio.h:170
GPIO_MUX_13
@ GPIO_MUX_13
Definition: at32f435_437_gpio.h:169
GPIO_MUX_11
@ GPIO_MUX_11
Definition: at32f435_437_gpio.h:167
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
gpio_type
type define gpio register all
Definition: at32f435_437_gpio.h:178
gpio_type::iocb9
__IO uint32_t iocb9
Definition: at32f435_437_gpio.h:377
gpio_type::odrv4
__IO uint32_t odrv4
Definition: at32f435_437_gpio.h:246
gpio_type::pull13
__IO uint32_t pull13
Definition: at32f435_437_gpio.h:282
gpio_type::idt4
__IO uint32_t idt4
Definition: at32f435_437_gpio.h:300
gpio_type::iocb4
__IO uint32_t iocb4
Definition: at32f435_437_gpio.h:372
gpio_type::iocb6
__IO uint32_t iocb6
Definition: at32f435_437_gpio.h:374
gpio_type::iomc13
__IO uint32_t iomc13
Definition: at32f435_437_gpio.h:200
gpio_type::pull1
__IO uint32_t pull1
Definition: at32f435_437_gpio.h:270
gpio_type::pull
__IO uint32_t pull
Definition: at32f435_437_gpio.h:266
gpio_type::odt11
__IO uint32_t odt11
Definition: at32f435_437_gpio.h:335
gpio_type::hdrv
__IO uint32_t hdrv
Definition: at32f435_437_gpio.h:492
gpio_type::iocb7
__IO uint32_t iocb7
Definition: at32f435_437_gpio.h:375
gpio_type::idt3
__IO uint32_t idt3
Definition: at32f435_437_gpio.h:299
gpio_type::odrv1
__IO uint32_t odrv1
Definition: at32f435_437_gpio.h:243
gpio_type::idt7
__IO uint32_t idt7
Definition: at32f435_437_gpio.h:303
gpio_type::hdrv10
__IO uint32_t hdrv10
Definition: at32f435_437_gpio.h:505
gpio_type::pull11
__IO uint32_t pull11
Definition: at32f435_437_gpio.h:280
gpio_type::iosb12
__IO uint32_t iosb12
Definition: at32f435_437_gpio.h:364
gpio_type::pull15
__IO uint32_t pull15
Definition: at32f435_437_gpio.h:284
gpio_type::iomc5
__IO uint32_t iomc5
Definition: at32f435_437_gpio.h:192
gpio_type::iosb4
__IO uint32_t iosb4
Definition: at32f435_437_gpio.h:356
gpio_type::om6
__IO uint32_t om6
Definition: at32f435_437_gpio.h:220
gpio_type::muxh14
__IO uint32_t muxh14
Definition: at32f435_437_gpio.h:449
gpio_type::hdrv4
__IO uint32_t hdrv4
Definition: at32f435_437_gpio.h:499
gpio_type::idt1
__IO uint32_t idt1
Definition: at32f435_437_gpio.h:297
gpio_type::om8
__IO uint32_t om8
Definition: at32f435_437_gpio.h:222
gpio_type::idt14
__IO uint32_t idt14
Definition: at32f435_437_gpio.h:310
gpio_type::idt6
__IO uint32_t idt6
Definition: at32f435_437_gpio.h:302
gpio_type::pull2
__IO uint32_t pull2
Definition: at32f435_437_gpio.h:271
gpio_type::scr
__IO uint32_t scr
Definition: at32f435_437_gpio.h:349
gpio_type::muxh
__IO uint32_t muxh
Definition: at32f435_437_gpio.h:440
gpio_type::odrv11
__IO uint32_t odrv11
Definition: at32f435_437_gpio.h:253
gpio_type::om9
__IO uint32_t om9
Definition: at32f435_437_gpio.h:223
gpio_type::odt6
__IO uint32_t odt6
Definition: at32f435_437_gpio.h:330
gpio_type::hdrv3
__IO uint32_t hdrv3
Definition: at32f435_437_gpio.h:498
gpio_type::odt
__IO uint32_t odt
Definition: at32f435_437_gpio.h:321
gpio_type::wpen0
__IO uint32_t wpen0
Definition: at32f435_437_gpio.h:395
gpio_type::wpen9
__IO uint32_t wpen9
Definition: at32f435_437_gpio.h:404
gpio_type::iomc0
__IO uint32_t iomc0
Definition: at32f435_437_gpio.h:187
gpio_type::om11
__IO uint32_t om11
Definition: at32f435_437_gpio.h:225
gpio_type::odt5
__IO uint32_t odt5
Definition: at32f435_437_gpio.h:329
gpio_type::reserved1
__IO uint32_t reserved1
gpio reserved1 register, offset:0x2C~0x38
Definition: at32f435_437_gpio.h:230
gpio_type::muxl7
__IO uint32_t muxl7
Definition: at32f435_437_gpio.h:431
gpio_type::pull4
__IO uint32_t pull4
Definition: at32f435_437_gpio.h:273
gpio_type::odrvr
__IO uint32_t odrvr
Definition: at32f435_437_gpio.h:239
gpio_type::om14
__IO uint32_t om14
Definition: at32f435_437_gpio.h:228
gpio_type::odrv12
__IO uint32_t odrv12
Definition: at32f435_437_gpio.h:254
gpio_type::odt2
__IO uint32_t odt2
Definition: at32f435_437_gpio.h:326
gpio_type::muxh9
__IO uint32_t muxh9
Definition: at32f435_437_gpio.h:444
gpio_type::muxl6
__IO uint32_t muxl6
Definition: at32f435_437_gpio.h:430
gpio_type::iosb7
__IO uint32_t iosb7
Definition: at32f435_437_gpio.h:359
gpio_type::muxl5
__IO uint32_t muxl5
Definition: at32f435_437_gpio.h:429
gpio_type::hdrv0
__IO uint32_t hdrv0
Definition: at32f435_437_gpio.h:495
gpio_type::iocb15
__IO uint32_t iocb15
Definition: at32f435_437_gpio.h:383
gpio_type::cfgr
__IO uint32_t cfgr
Definition: at32f435_437_gpio.h:184
gpio_type::idt12
__IO uint32_t idt12
Definition: at32f435_437_gpio.h:308
gpio_type::idt9
__IO uint32_t idt9
Definition: at32f435_437_gpio.h:305
gpio_type::odt14
__IO uint32_t odt14
Definition: at32f435_437_gpio.h:338
gpio_type::iomc6
__IO uint32_t iomc6
Definition: at32f435_437_gpio.h:193
gpio_type::wpen14
__IO uint32_t wpen14
Definition: at32f435_437_gpio.h:409
gpio_type::idt8
__IO uint32_t idt8
Definition: at32f435_437_gpio.h:304
gpio_type::muxl0
__IO uint32_t muxl0
Definition: at32f435_437_gpio.h:424
gpio_type::pull8
__IO uint32_t pull8
Definition: at32f435_437_gpio.h:277
gpio_type::clr
__IO uint32_t clr
Definition: at32f435_437_gpio.h:459
gpio_type::iosb9
__IO uint32_t iosb9
Definition: at32f435_437_gpio.h:361
gpio_type::iomc2
__IO uint32_t iomc2
Definition: at32f435_437_gpio.h:189
gpio_type::om10
__IO uint32_t om10
Definition: at32f435_437_gpio.h:224
gpio_type::iocb14
__IO uint32_t iocb14
Definition: at32f435_437_gpio.h:382
gpio_type::muxl4
__IO uint32_t muxl4
Definition: at32f435_437_gpio.h:428
gpio_type::iosb2
__IO uint32_t iosb2
Definition: at32f435_437_gpio.h:354
gpio_type::om3
__IO uint32_t om3
Definition: at32f435_437_gpio.h:217
gpio_type::wpen8
__IO uint32_t wpen8
Definition: at32f435_437_gpio.h:403
gpio_type::wpen1
__IO uint32_t wpen1
Definition: at32f435_437_gpio.h:396
gpio_type::iocb13
__IO uint32_t iocb13
Definition: at32f435_437_gpio.h:381
gpio_type::wpen13
__IO uint32_t wpen13
Definition: at32f435_437_gpio.h:408
gpio_type::om4
__IO uint32_t om4
Definition: at32f435_437_gpio.h:218
gpio_type::odrv13
__IO uint32_t odrv13
Definition: at32f435_437_gpio.h:255
gpio_type::odt15
__IO uint32_t odt15
Definition: at32f435_437_gpio.h:339
gpio_type::muxl3
__IO uint32_t muxl3
Definition: at32f435_437_gpio.h:427
gpio_type::iocb12
__IO uint32_t iocb12
Definition: at32f435_437_gpio.h:380
gpio_type::hdrv6
__IO uint32_t hdrv6
Definition: at32f435_437_gpio.h:501
gpio_type::iocb3
__IO uint32_t iocb3
Definition: at32f435_437_gpio.h:371
gpio_type::iosb13
__IO uint32_t iosb13
Definition: at32f435_437_gpio.h:365
gpio_type::odt3
__IO uint32_t odt3
Definition: at32f435_437_gpio.h:327
gpio_type::odt9
__IO uint32_t odt9
Definition: at32f435_437_gpio.h:333
gpio_type::idt5
__IO uint32_t idt5
Definition: at32f435_437_gpio.h:301
gpio_type::muxh10
__IO uint32_t muxh10
Definition: at32f435_437_gpio.h:445
gpio_type::hdrv7
__IO uint32_t hdrv7
Definition: at32f435_437_gpio.h:502
gpio_type::odrv9
__IO uint32_t odrv9
Definition: at32f435_437_gpio.h:251
gpio_type::iosb5
__IO uint32_t iosb5
Definition: at32f435_437_gpio.h:357
gpio_type::pull5
__IO uint32_t pull5
Definition: at32f435_437_gpio.h:274
gpio_type::iosb14
__IO uint32_t iosb14
Definition: at32f435_437_gpio.h:366
gpio_type::odrv7
__IO uint32_t odrv7
Definition: at32f435_437_gpio.h:249
gpio_type::iosb1
__IO uint32_t iosb1
Definition: at32f435_437_gpio.h:353
gpio_type::om1
__IO uint32_t om1
Definition: at32f435_437_gpio.h:215
gpio_type::muxh15
__IO uint32_t muxh15
Definition: at32f435_437_gpio.h:450
gpio_type::pull9
__IO uint32_t pull9
Definition: at32f435_437_gpio.h:278
gpio_type::odt12
__IO uint32_t odt12
Definition: at32f435_437_gpio.h:336
gpio_type::muxh12
__IO uint32_t muxh12
Definition: at32f435_437_gpio.h:447
gpio_type::odrv10
__IO uint32_t odrv10
Definition: at32f435_437_gpio.h:252
gpio_type::wpen15
__IO uint32_t wpen15
Definition: at32f435_437_gpio.h:410
gpio_type::iomc8
__IO uint32_t iomc8
Definition: at32f435_437_gpio.h:195
gpio_type::muxl1
__IO uint32_t muxl1
Definition: at32f435_437_gpio.h:425
gpio_type::wpseq
__IO uint32_t wpseq
Definition: at32f435_437_gpio.h:411
gpio_type::idt10
__IO uint32_t idt10
Definition: at32f435_437_gpio.h:306
gpio_type::wpen12
__IO uint32_t wpen12
Definition: at32f435_437_gpio.h:407
gpio_type::hdrv13
__IO uint32_t hdrv13
Definition: at32f435_437_gpio.h:508
gpio_type::iomc9
__IO uint32_t iomc9
Definition: at32f435_437_gpio.h:196
gpio_type::iocb8
__IO uint32_t iocb8
Definition: at32f435_437_gpio.h:376
gpio_type::iosb6
__IO uint32_t iosb6
Definition: at32f435_437_gpio.h:358
gpio_type::muxh13
__IO uint32_t muxh13
Definition: at32f435_437_gpio.h:448
gpio_type::iocb1
__IO uint32_t iocb1
Definition: at32f435_437_gpio.h:369
gpio_type::iocb2
__IO uint32_t iocb2
Definition: at32f435_437_gpio.h:370
gpio_type::wpen2
__IO uint32_t wpen2
Definition: at32f435_437_gpio.h:397
gpio_type::om0
__IO uint32_t om0
Definition: at32f435_437_gpio.h:214
gpio_type::pull0
__IO uint32_t pull0
Definition: at32f435_437_gpio.h:269
gpio_type::iomc7
__IO uint32_t iomc7
Definition: at32f435_437_gpio.h:194
gpio_type::hdrv15
__IO uint32_t hdrv15
Definition: at32f435_437_gpio.h:510
gpio_type::idt13
__IO uint32_t idt13
Definition: at32f435_437_gpio.h:309
gpio_type::odrv3
__IO uint32_t odrv3
Definition: at32f435_437_gpio.h:245
gpio_type::om7
__IO uint32_t om7
Definition: at32f435_437_gpio.h:221
gpio_type::odt13
__IO uint32_t odt13
Definition: at32f435_437_gpio.h:337
gpio_type::iocb5
__IO uint32_t iocb5
Definition: at32f435_437_gpio.h:373
gpio_type::odt7
__IO uint32_t odt7
Definition: at32f435_437_gpio.h:331
gpio_type::om2
__IO uint32_t om2
Definition: at32f435_437_gpio.h:216
gpio_type::odrv0
__IO uint32_t odrv0
Definition: at32f435_437_gpio.h:242
gpio_type::odt4
__IO uint32_t odt4
Definition: at32f435_437_gpio.h:328
gpio_type::iosb0
__IO uint32_t iosb0
Definition: at32f435_437_gpio.h:352
gpio_type::omode
__IO uint32_t omode
Definition: at32f435_437_gpio.h:211
gpio_type::wpen6
__IO uint32_t wpen6
Definition: at32f435_437_gpio.h:401
gpio_type::wpen11
__IO uint32_t wpen11
Definition: at32f435_437_gpio.h:406
gpio_type::wpen4
__IO uint32_t wpen4
Definition: at32f435_437_gpio.h:399
gpio_type::wpen5
__IO uint32_t wpen5
Definition: at32f435_437_gpio.h:400
gpio_type::pull7
__IO uint32_t pull7
Definition: at32f435_437_gpio.h:276
gpio_type::idt11
__IO uint32_t idt11
Definition: at32f435_437_gpio.h:307
gpio_type::idt2
__IO uint32_t idt2
Definition: at32f435_437_gpio.h:298
gpio_type::odt1
__IO uint32_t odt1
Definition: at32f435_437_gpio.h:325
gpio_type::pull10
__IO uint32_t pull10
Definition: at32f435_437_gpio.h:279
gpio_type::odrv8
__IO uint32_t odrv8
Definition: at32f435_437_gpio.h:250
gpio_type::hdrv1
__IO uint32_t hdrv1
Definition: at32f435_437_gpio.h:496
gpio_type::wpen7
__IO uint32_t wpen7
Definition: at32f435_437_gpio.h:402
gpio_type::muxl
__IO uint32_t muxl
Definition: at32f435_437_gpio.h:421
gpio_type::muxl2
__IO uint32_t muxl2
Definition: at32f435_437_gpio.h:426
gpio_type::iomc11
__IO uint32_t iomc11
Definition: at32f435_437_gpio.h:198
gpio_type::iocb10
__IO uint32_t iocb10
Definition: at32f435_437_gpio.h:378
gpio_type::iomc15
__IO uint32_t iomc15
Definition: at32f435_437_gpio.h:202
gpio_type::hdrv14
__IO uint32_t hdrv14
Definition: at32f435_437_gpio.h:509
gpio_type::iomc14
__IO uint32_t iomc14
Definition: at32f435_437_gpio.h:201
gpio_type::muxh8
__IO uint32_t muxh8
Definition: at32f435_437_gpio.h:443
gpio_type::hdrv8
__IO uint32_t hdrv8
Definition: at32f435_437_gpio.h:503
gpio_type::iomc12
__IO uint32_t iomc12
Definition: at32f435_437_gpio.h:199
gpio_type::pull14
__IO uint32_t pull14
Definition: at32f435_437_gpio.h:283
gpio_type::iosb15
__IO uint32_t iosb15
Definition: at32f435_437_gpio.h:367
gpio_type::odrv2
__IO uint32_t odrv2
Definition: at32f435_437_gpio.h:244
gpio_type::odt10
__IO uint32_t odt10
Definition: at32f435_437_gpio.h:334
gpio_type::iosb3
__IO uint32_t iosb3
Definition: at32f435_437_gpio.h:355
gpio_type::odt0
__IO uint32_t odt0
Definition: at32f435_437_gpio.h:324
gpio_type::wpen3
__IO uint32_t wpen3
Definition: at32f435_437_gpio.h:398
gpio_type::idt15
__IO uint32_t idt15
Definition: at32f435_437_gpio.h:311
gpio_type::om5
__IO uint32_t om5
Definition: at32f435_437_gpio.h:219
gpio_type::hdrv12
__IO uint32_t hdrv12
Definition: at32f435_437_gpio.h:507
gpio_type::idt
__IO uint32_t idt
Definition: at32f435_437_gpio.h:293
gpio_type::pull3
__IO uint32_t pull3
Definition: at32f435_437_gpio.h:272
gpio_type::odt8
__IO uint32_t odt8
Definition: at32f435_437_gpio.h:332
gpio_type::odrv5
__IO uint32_t odrv5
Definition: at32f435_437_gpio.h:247
gpio_type::hdrv9
__IO uint32_t hdrv9
Definition: at32f435_437_gpio.h:504
gpio_type::odrv14
__IO uint32_t odrv14
Definition: at32f435_437_gpio.h:256
gpio_type::idt0
__IO uint32_t idt0
Definition: at32f435_437_gpio.h:296
gpio_type::odrv15
__IO uint32_t odrv15
Definition: at32f435_437_gpio.h:257
gpio_type::wpr
__IO uint32_t wpr
Definition: at32f435_437_gpio.h:392
gpio_type::muxh11
__IO uint32_t muxh11
Definition: at32f435_437_gpio.h:446
gpio_type::iomc3
__IO uint32_t iomc3
Definition: at32f435_437_gpio.h:190
gpio_type::om15
__IO uint32_t om15
Definition: at32f435_437_gpio.h:229
gpio_type::iocb0
__IO uint32_t iocb0
Definition: at32f435_437_gpio.h:368
gpio_type::iosb8
__IO uint32_t iosb8
Definition: at32f435_437_gpio.h:360
gpio_type::iosb11
__IO uint32_t iosb11
Definition: at32f435_437_gpio.h:363
gpio_type::iomc4
__IO uint32_t iomc4
Definition: at32f435_437_gpio.h:191
gpio_type::iomc10
__IO uint32_t iomc10
Definition: at32f435_437_gpio.h:197
gpio_type::iomc1
__IO uint32_t iomc1
Definition: at32f435_437_gpio.h:188
gpio_type::om12
__IO uint32_t om12
Definition: at32f435_437_gpio.h:226
gpio_type::pull6
__IO uint32_t pull6
Definition: at32f435_437_gpio.h:275
gpio_type::wpen10
__IO uint32_t wpen10
Definition: at32f435_437_gpio.h:405
gpio_type::om13
__IO uint32_t om13
Definition: at32f435_437_gpio.h:227
gpio_type::odrv6
__IO uint32_t odrv6
Definition: at32f435_437_gpio.h:248
gpio_type::hdrv2
__IO uint32_t hdrv2
Definition: at32f435_437_gpio.h:497
gpio_type::pull12
__IO uint32_t pull12
Definition: at32f435_437_gpio.h:281
gpio_type::hdrv5
__IO uint32_t hdrv5
Definition: at32f435_437_gpio.h:500
gpio_type::iosb10
__IO uint32_t iosb10
Definition: at32f435_437_gpio.h:362
gpio_type::iocb11
__IO uint32_t iocb11
Definition: at32f435_437_gpio.h:379
gpio_type::hdrv11
__IO uint32_t hdrv11
Definition: at32f435_437_gpio.h:506


AT32F435/437 Firmwary Library: at32f435_437_i2c.c Source File

  • libraries
  • drivers
  • src
at32f435_437_i2c.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef I2C_MODULE_ENABLED
39
51void i2c_reset(i2c_type *i2c_x)
52{
53 if(i2c_x == I2C1)
54 {
55 crm_periph_reset(CRM_I2C1_PERIPH_RESET, TRUE);
56 crm_periph_reset(CRM_I2C1_PERIPH_RESET, FALSE);
57 }
58 else if(i2c_x == I2C2)
59 {
60 crm_periph_reset(CRM_I2C2_PERIPH_RESET, TRUE);
61 crm_periph_reset(CRM_I2C2_PERIPH_RESET, FALSE);
62 }
63 else if(i2c_x == I2C3)
64 {
65 crm_periph_reset(CRM_I2C3_PERIPH_RESET, TRUE);
66 crm_periph_reset(CRM_I2C3_PERIPH_RESET, FALSE);
67 }
68}
69
79void i2c_init(i2c_type *i2c_x, uint8_t dfilters, uint32_t clk)
80{
81 /* disable i2c peripheral */
82 i2c_x->ctrl1_bit.i2cen = FALSE;
83
84 /* write clkctrl register*/
85 i2c_x->clkctrl = clk;
86
87 /* write digital filter register*/
88 i2c_x->ctrl1_bit.dflt = dfilters;
89}
90
103void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
104{
105 /* config address mode */
106 i2c_x->oaddr1_bit.addr1mode = mode;
107
108 /* config address */
109 i2c_x->oaddr1_bit.addr1 = address & 0x03FF;
110
111 /* enable address */
112 i2c_x->oaddr1_bit.addr1en = TRUE;
113}
114
133void i2c_own_address2_set(i2c_type *i2c_x, uint8_t address, i2c_addr2_mask_type mask)
134{
135 i2c_x->oaddr2_bit.addr2mask = mask;
136
137 i2c_x->oaddr2_bit.addr2 = (address >> 1) & 0x7F;
138}
139
148void i2c_own_address2_enable(i2c_type *i2c_x, confirm_state new_state)
149{
150 i2c_x->oaddr2_bit.addr2en = new_state;
151}
152
165void i2c_smbus_enable(i2c_type *i2c_x, i2c_smbus_mode_type mode, confirm_state new_state)
166{
167 switch (mode)
168 {
169 case I2C_SMBUS_MODE_DEVICE:
170 i2c_x->ctrl1_bit.devaddren = new_state;
171 break;
172 case I2C_SMBUS_MODE_HOST:
173 i2c_x->ctrl1_bit.haddren = new_state;
174 break;
175 default:
176 break;
177 }
178}
179
188void i2c_enable(i2c_type *i2c_x, confirm_state new_state)
189{
190 i2c_x->ctrl1_bit.i2cen = new_state;
191}
192
201void i2c_clock_stretch_enable(i2c_type *i2c_x, confirm_state new_state)
202{
203 i2c_x->ctrl1_bit.stretch = (!new_state);
204}
205
214void i2c_ack_enable(i2c_type *i2c_x, confirm_state new_state)
215{
216 i2c_x->ctrl2_bit.nacken = (!new_state);
217}
218
227void i2c_addr10_mode_enable(i2c_type *i2c_x, confirm_state new_state)
228{
229 i2c_x->ctrl2_bit.addr10 = new_state;
230}
231
240void i2c_transfer_addr_set(i2c_type *i2c_x, uint16_t address)
241{
242 i2c_x->ctrl2_bit.saddr = address & 0x03FF;
243}
244
252uint16_t i2c_transfer_addr_get(i2c_type *i2c_x)
253{
254 return i2c_x->ctrl2_bit.saddr;
255}
256
268void i2c_transfer_dir_set(i2c_type *i2c_x, i2c_transfer_dir_type i2c_direction)
269{
270 i2c_x->ctrl2_bit.dir = i2c_direction;
271}
272
282 i2c_transfer_dir_type i2c_transfer_dir_get(i2c_type *i2c_x)
283{
284 if (i2c_x->sts_bit.sdir == 0)
285 {
286 return I2C_DIR_TRANSMIT;
287 }
288 else
289 {
290 return I2C_DIR_RECEIVE;
291 }
292}
293
301uint8_t i2c_matched_addr_get(i2c_type *i2c_x)
302{
303 return (i2c_x->sts_bit.addr << 1);
304}
305
314void i2c_auto_stop_enable(i2c_type *i2c_x, confirm_state new_state)
315{
316 i2c_x->ctrl2_bit.astopen = new_state;
317}
318
327void i2c_reload_enable(i2c_type *i2c_x, confirm_state new_state)
328{
329 i2c_x->ctrl2_bit.rlden = new_state;
330}
331
340void i2c_cnt_set(i2c_type *i2c_x, uint8_t cnt)
341{
342 i2c_x->ctrl2_bit.cnt = cnt;
343}
344
354void i2c_addr10_header_enable(i2c_type *i2c_x, confirm_state new_state)
355{
356 i2c_x->ctrl2_bit.readh10 = new_state;
357}
358
367void i2c_general_call_enable(i2c_type *i2c_x, confirm_state new_state)
368{
369 i2c_x->ctrl1_bit.gcaen = new_state;
370}
371
383void i2c_smbus_alert_set(i2c_type *i2c_x, i2c_smbus_alert_set_type level)
384{
385 i2c_x->ctrl1_bit.smbalert = level;
386}
387
396void i2c_slave_data_ctrl_enable(i2c_type *i2c_x, confirm_state new_state)
397{
398 i2c_x->ctrl1_bit.sctrl = new_state;
399}
400
409void i2c_pec_calculate_enable(i2c_type *i2c_x, confirm_state new_state)
410{
411 i2c_x->ctrl1_bit.pecen = new_state;
412}
413
422void i2c_pec_transmit_enable(i2c_type *i2c_x, confirm_state new_state)
423{
424 i2c_x->ctrl2_bit.pecten = new_state;
425}
426
434uint8_t i2c_pec_value_get(i2c_type *i2c_x)
435{
436 return (uint8_t)(i2c_x->pec_bit.pecval);
437}
438
447void i2c_timeout_set(i2c_type *i2c_x, uint16_t timeout)
448{
449 i2c_x->timeout_bit.totime = timeout;
450}
451
463void i2c_timeout_detcet_set(i2c_type *i2c_x, i2c_timeout_detcet_type mode)
464{
465 i2c_x->timeout_bit.tomode = mode;
466}
467
476void i2c_timeout_enable(i2c_type *i2c_x, confirm_state new_state)
477{
478 i2c_x->timeout_bit.toen = new_state;
479}
480
489void i2c_ext_timeout_set(i2c_type *i2c_x, uint16_t timeout)
490{
491 i2c_x->timeout_bit.exttime = timeout;
492}
493
502void i2c_ext_timeout_enable(i2c_type *i2c_x, confirm_state new_state)
503{
504 i2c_x->timeout_bit.exten = new_state;
505}
506
524void i2c_interrupt_enable(i2c_type *i2c_x, uint32_t source, confirm_state new_state)
525{
526 if (new_state != FALSE)
527 {
528 i2c_x->ctrl1 |= source;
529 }
530 else
531 {
532 i2c_x->ctrl1 &= (uint32_t)~source;
533 }
534}
535
552 flag_status i2c_interrupt_get(i2c_type *i2c_x, uint16_t source)
553{
554 if((i2c_x->ctrl1 & source) != RESET)
555 {
556 return SET;
557 }
558 else
559 {
560 return RESET;
561 }
562}
563
576void i2c_dma_enable(i2c_type *i2c_x, i2c_dma_request_type dma_req, confirm_state new_state)
577{
578 if(dma_req == I2C_DMA_REQUEST_TX)
579 {
580 i2c_x->ctrl1_bit.dmaten = new_state;
581 }
582 else
583 {
584 i2c_x->ctrl1_bit.dmaren = new_state;
585 }
586}
587
607void i2c_transmit_set(i2c_type *i2c_x, uint16_t address, uint8_t cnt, i2c_reload_stop_mode_type rld_stop, i2c_start_mode_type start)
608{
609 uint32_t temp;
610
611 /* copy ctrl2 value to temp */
612 temp = i2c_x->ctrl2;
613
614 /* clear ctrl2_bit specific bits */
615 temp &= ~0x03FF67FF;
616
617 /* transfer mode and address set */
618 temp |= address | rld_stop | start;
619
620 /* transfer counter set */
621 temp |= (uint32_t)cnt << 16;
622
623 /* update ctrl2 value */
624 i2c_x->ctrl2 = temp;
625}
626
634void i2c_start_generate(i2c_type *i2c_x)
635{
636 i2c_x->ctrl2_bit.genstart = TRUE;
637}
638
646void i2c_stop_generate(i2c_type *i2c_x)
647{
648 i2c_x->ctrl2_bit.genstop = TRUE;
649}
650
659void i2c_data_send(i2c_type *i2c_x, uint8_t data)
660{
661 i2c_x->txdt = data;
662}
663
671uint8_t i2c_data_receive(i2c_type *i2c_x)
672{
673 return (uint8_t)i2c_x->rxdt;
674}
675
701 flag_status i2c_flag_get(i2c_type *i2c_x, uint32_t flag)
702{
703 if((i2c_x->sts & flag) != RESET)
704 {
705 return SET;
706 }
707 else
708 {
709 return RESET;
710 }
711}
712
731void i2c_flag_clear(i2c_type *i2c_x, uint32_t flag)
732{
733 i2c_x->clr = flag;
734}
735
740#endif
741
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f435_437_crm.c:251
CRM_I2C3_PERIPH_RESET
@ CRM_I2C3_PERIPH_RESET
Definition: at32f435_437_crm.h:293
CRM_I2C2_PERIPH_RESET
@ CRM_I2C2_PERIPH_RESET
Definition: at32f435_437_crm.h:292
CRM_I2C1_PERIPH_RESET
@ CRM_I2C1_PERIPH_RESET
Definition: at32f435_437_crm.h:291
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
i2c_reload_stop_mode_type
i2c_reload_stop_mode_type
i2c reload end mode
Definition: at32f435_437_i2c.h:172
i2c_timeout_detcet_type
i2c_timeout_detcet_type
i2c clock timeout detection mode
Definition: at32f435_437_i2c.h:148
i2c_start_mode_type
i2c_start_mode_type
i2c start mode
Definition: at32f435_437_i2c.h:182
i2c_addr2_mask_type
i2c_addr2_mask_type
i2c own address2 mask
Definition: at32f435_437_i2c.h:157
i2c_dma_request_type
i2c_dma_request_type
i2c dma requests direction
Definition: at32f435_437_i2c.h:130
i2c_address_mode_type
i2c_address_mode_type
i2c address mode
Definition: at32f435_437_i2c.h:112
i2c_smbus_alert_set_type
i2c_smbus_alert_set_type
i2c smbus alert pin set
Definition: at32f435_437_i2c.h:139
i2c_smbus_mode_type
i2c_smbus_mode_type
i2c smbus mode set
Definition: at32f435_437_i2c.h:103
i2c_transfer_dir_type
i2c_transfer_dir_type
i2c transfer direction
Definition: at32f435_437_i2c.h:121
I2C_DMA_REQUEST_TX
@ I2C_DMA_REQUEST_TX
Definition: at32f435_437_i2c.h:131
I2C_SMBUS_MODE_HOST
@ I2C_SMBUS_MODE_HOST
Definition: at32f435_437_i2c.h:105
I2C_SMBUS_MODE_DEVICE
@ I2C_SMBUS_MODE_DEVICE
Definition: at32f435_437_i2c.h:104
I2C_DIR_RECEIVE
@ I2C_DIR_RECEIVE
Definition: at32f435_437_i2c.h:123
I2C_DIR_TRANSMIT
@ I2C_DIR_TRANSMIT
Definition: at32f435_437_i2c.h:122
i2c_pec_transmit_enable
void i2c_pec_transmit_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable pec transfer.
Definition: at32f435_437_i2c.c:422
i2c_transfer_dir_get
i2c_transfer_dir_type i2c_transfer_dir_get(i2c_type *i2c_x)
slave get the i2c transfer direction.
Definition: at32f435_437_i2c.c:282
i2c_slave_data_ctrl_enable
void i2c_slave_data_ctrl_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable slave data control.
Definition: at32f435_437_i2c.c:396
i2c_data_receive
uint8_t i2c_data_receive(i2c_type *i2c_x)
receive a byte through the i2c periph.
Definition: at32f435_437_i2c.c:671
i2c_reset
void i2c_reset(i2c_type *i2c_x)
reset the i2c register
Definition: at32f435_437_i2c.c:51
i2c_smbus_alert_set
void i2c_smbus_alert_set(i2c_type *i2c_x, i2c_smbus_alert_set_type level)
drives the smbus alert pin high or low.
Definition: at32f435_437_i2c.c:383
i2c_own_address2_set
void i2c_own_address2_set(i2c_type *i2c_x, uint8_t address, i2c_addr2_mask_type mask)
config i2c own address 2 and mask.
Definition: at32f435_437_i2c.c:133
i2c_pec_value_get
uint8_t i2c_pec_value_get(i2c_type *i2c_x)
get the i2c pec value.
Definition: at32f435_437_i2c.c:434
i2c_transfer_dir_set
void i2c_transfer_dir_set(i2c_type *i2c_x, i2c_transfer_dir_type i2c_direction)
config the master transfer direction.
Definition: at32f435_437_i2c.c:268
i2c_timeout_enable
void i2c_timeout_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable bus timeout.
Definition: at32f435_437_i2c.c:476
i2c_general_call_enable
void i2c_general_call_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable general call mode.
Definition: at32f435_437_i2c.c:367
i2c_init
void i2c_init(i2c_type *i2c_x, uint8_t dfilters, uint32_t clk)
init i2c digit filters and clock control register.
Definition: at32f435_437_i2c.c:79
i2c_ack_enable
void i2c_ack_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable ack.
Definition: at32f435_437_i2c.c:214
i2c_interrupt_get
flag_status i2c_interrupt_get(i2c_type *i2c_x, uint16_t source)
get interrupt status
Definition: at32f435_437_i2c.c:552
i2c_timeout_set
void i2c_timeout_set(i2c_type *i2c_x, uint16_t timeout)
config the i2c bus timeout.
Definition: at32f435_437_i2c.c:447
i2c_matched_addr_get
uint8_t i2c_matched_addr_get(i2c_type *i2c_x)
get the i2c slave matched address.
Definition: at32f435_437_i2c.c:301
i2c_ext_timeout_enable
void i2c_ext_timeout_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable extend bus timeout.
Definition: at32f435_437_i2c.c:502
i2c_transfer_addr_set
void i2c_transfer_addr_set(i2c_type *i2c_x, uint16_t address)
config the slave address to be transmitted.
Definition: at32f435_437_i2c.c:240
i2c_transfer_addr_get
uint16_t i2c_transfer_addr_get(i2c_type *i2c_x)
get the slave address to be transmitted.
Definition: at32f435_437_i2c.c:252
i2c_ext_timeout_set
void i2c_ext_timeout_set(i2c_type *i2c_x, uint16_t timeout)
config the i2c extend bus timeout.
Definition: at32f435_437_i2c.c:489
i2c_cnt_set
void i2c_cnt_set(i2c_type *i2c_x, uint8_t cnt)
config the transfer cnt .
Definition: at32f435_437_i2c.c:340
i2c_own_address2_enable
void i2c_own_address2_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable own address 2.
Definition: at32f435_437_i2c.c:148
i2c_pec_calculate_enable
void i2c_pec_calculate_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable pec calculate.
Definition: at32f435_437_i2c.c:409
i2c_stop_generate
void i2c_stop_generate(i2c_type *i2c_x)
generate stop condition.
Definition: at32f435_437_i2c.c:646
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config i2c own address 1.
Definition: at32f435_437_i2c.c:103
i2c_enable
void i2c_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable peripheral.
Definition: at32f435_437_i2c.c:188
i2c_smbus_enable
void i2c_smbus_enable(i2c_type *i2c_x, i2c_smbus_mode_type mode, confirm_state new_state)
enable or disable smbus mode.
Definition: at32f435_437_i2c.c:165
i2c_timeout_detcet_set
void i2c_timeout_detcet_set(i2c_type *i2c_x, i2c_timeout_detcet_type mode)
config the bus timeout detcet level.
Definition: at32f435_437_i2c.c:463
i2c_flag_get
flag_status i2c_flag_get(i2c_type *i2c_x, uint32_t flag)
get flag status.
Definition: at32f435_437_i2c.c:701
i2c_auto_stop_enable
void i2c_auto_stop_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable auto send stop mode.
Definition: at32f435_437_i2c.c:314
i2c_flag_clear
void i2c_flag_clear(i2c_type *i2c_x, uint32_t flag)
clear flag status
Definition: at32f435_437_i2c.c:731
i2c_data_send
void i2c_data_send(i2c_type *i2c_x, uint8_t data)
send a byte through the i2c periph.
Definition: at32f435_437_i2c.c:659
i2c_clock_stretch_enable
void i2c_clock_stretch_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable clock stretch.
Definition: at32f435_437_i2c.c:201
i2c_dma_enable
void i2c_dma_enable(i2c_type *i2c_x, i2c_dma_request_type dma_req, confirm_state new_state)
enable or disable dma requests.
Definition: at32f435_437_i2c.c:576
i2c_addr10_header_enable
void i2c_addr10_header_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable read 10-bit header, this mode only used in 10-bit address mode read.
Definition: at32f435_437_i2c.c:354
i2c_transmit_set
void i2c_transmit_set(i2c_type *i2c_x, uint16_t address, uint8_t cnt, i2c_reload_stop_mode_type rld_stop, i2c_start_mode_type start)
config data transfer.
Definition: at32f435_437_i2c.c:607
i2c_interrupt_enable
void i2c_interrupt_enable(i2c_type *i2c_x, uint32_t source, confirm_state new_state)
enable or disable interrupts.
Definition: at32f435_437_i2c.c:524
i2c_start_generate
void i2c_start_generate(i2c_type *i2c_x)
generate start condition.
Definition: at32f435_437_i2c.c:634
i2c_reload_enable
void i2c_reload_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable cnt reload mode.
Definition: at32f435_437_i2c.c:327
i2c_addr10_mode_enable
void i2c_addr10_mode_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable 10-bit address mode (master transfer).
Definition: at32f435_437_i2c.c:227
I2C3
#define I2C3
Definition: at32f435_437_i2c.h:416
I2C1
#define I2C1
Definition: at32f435_437_i2c.h:414
I2C2
#define I2C2
Definition: at32f435_437_i2c.h:415
i2c_type
type define i2c register all
Definition: at32f435_437_i2c.h:192
i2c_type::dmaten
__IO uint32_t dmaten
Definition: at32f435_437_i2c.h:211
i2c_type::smbalert
__IO uint32_t smbalert
Definition: at32f435_437_i2c.h:219
i2c_type::txdt
__IO uint32_t txdt
Definition: at32f435_437_i2c.h:400
i2c_type::genstop
__IO uint32_t genstop
Definition: at32f435_437_i2c.h:238
i2c_type::addr2en
__IO uint32_t addr2en
Definition: at32f435_437_i2c.h:276
i2c_type::gcaen
__IO uint32_t gcaen
Definition: at32f435_437_i2c.h:216
i2c_type::rxdt
__IO uint32_t rxdt
Definition: at32f435_437_i2c.h:387
i2c_type::haddren
__IO uint32_t haddren
Definition: at32f435_437_i2c.h:217
i2c_type::nacken
__IO uint32_t nacken
Definition: at32f435_437_i2c.h:239
i2c_type::addr2
__IO uint32_t addr2
Definition: at32f435_437_i2c.h:273
i2c_type::timeout_bit
struct i2c_type::@872::@889 timeout_bit
i2c_type::rlden
__IO uint32_t rlden
Definition: at32f435_437_i2c.h:241
i2c_type::sts
__IO uint32_t sts
Definition: at32f435_437_i2c.h:321
i2c_type::genstart
__IO uint32_t genstart
Definition: at32f435_437_i2c.h:237
i2c_type::pecten
__IO uint32_t pecten
Definition: at32f435_437_i2c.h:243
i2c_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f435_437_i2c.h:230
i2c_type::tomode
__IO uint32_t tomode
Definition: at32f435_437_i2c.h:307
i2c_type::exten
__IO uint32_t exten
Definition: at32f435_437_i2c.h:312
i2c_type::saddr
__IO uint32_t saddr
Definition: at32f435_437_i2c.h:233
i2c_type::dir
__IO uint32_t dir
Definition: at32f435_437_i2c.h:234
i2c_type::stretch
__IO uint32_t stretch
Definition: at32f435_437_i2c.h:214
i2c_type::oaddr1_bit
struct i2c_type::@866::@886 oaddr1_bit
i2c_type::oaddr2_bit
struct i2c_type::@868::@887 oaddr2_bit
i2c_type::clr
__IO uint32_t clr
Definition: at32f435_437_i2c.h:351
i2c_type::addr1mode
__IO uint32_t addr1mode
Definition: at32f435_437_i2c.h:257
i2c_type::dflt
__IO uint32_t dflt
Definition: at32f435_437_i2c.h:209
i2c_type::totime
__IO uint32_t totime
Definition: at32f435_437_i2c.h:306
i2c_type::pec_bit
struct i2c_type::@878::@892 pec_bit
i2c_type::pecval
__IO uint32_t pecval
Definition: at32f435_437_i2c.h:377
i2c_type::sdir
__IO uint32_t sdir
Definition: at32f435_437_i2c.h:340
i2c_type::toen
__IO uint32_t toen
Definition: at32f435_437_i2c.h:309
i2c_type::sts_bit
struct i2c_type::@874::@890 sts_bit
i2c_type::cnt
__IO uint32_t cnt
Definition: at32f435_437_i2c.h:240
i2c_type::astopen
__IO uint32_t astopen
Definition: at32f435_437_i2c.h:242
i2c_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f435_437_i2c.h:198
i2c_type::addr2mask
__IO uint32_t addr2mask
Definition: at32f435_437_i2c.h:274
i2c_type::sctrl
__IO uint32_t sctrl
Definition: at32f435_437_i2c.h:213
i2c_type::addr
__IO uint32_t addr
Definition: at32f435_437_i2c.h:341
i2c_type::devaddren
__IO uint32_t devaddren
Definition: at32f435_437_i2c.h:218
i2c_type::i2cen
__IO uint32_t i2cen
Definition: at32f435_437_i2c.h:201
i2c_type::addr1
__IO uint32_t addr1
Definition: at32f435_437_i2c.h:256
i2c_type::ctrl2_bit
struct i2c_type::@864::@885 ctrl2_bit
i2c_type::dmaren
__IO uint32_t dmaren
Definition: at32f435_437_i2c.h:212
i2c_type::addr10
__IO uint32_t addr10
Definition: at32f435_437_i2c.h:235
i2c_type::ctrl1_bit
struct i2c_type::@862::@884 ctrl1_bit
i2c_type::clkctrl
__IO uint32_t clkctrl
Definition: at32f435_437_i2c.h:286
i2c_type::exttime
__IO uint32_t exttime
Definition: at32f435_437_i2c.h:310
i2c_type::pecen
__IO uint32_t pecen
Definition: at32f435_437_i2c.h:220
i2c_type::addr1en
__IO uint32_t addr1en
Definition: at32f435_437_i2c.h:259
i2c_type::readh10
__IO uint32_t readh10
Definition: at32f435_437_i2c.h:236
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_i2c.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_i2c.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_I2C_H
29#define __AT32F435_437_I2C_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
50#define MAX_TRANSFER_CNT 255
57#define I2C_TD_INT ((uint32_t)0x00000002)
58#define I2C_RD_INT ((uint32_t)0x00000004)
59#define I2C_ADDR_INT ((uint32_t)0x00000008)
60#define I2C_ACKFIAL_INT ((uint32_t)0x00000010)
61#define I2C_STOP_INT ((uint32_t)0x00000020)
62#define I2C_TDC_INT ((uint32_t)0x00000040)
63#define I2C_ERR_INT ((uint32_t)0x00000080)
74#define I2C_TDBE_FLAG ((uint32_t)0x00000001)
75#define I2C_TDIS_FLAG ((uint32_t)0x00000002)
76#define I2C_RDBF_FLAG ((uint32_t)0x00000004)
77#define I2C_ADDRF_FLAG ((uint32_t)0x00000008)
78#define I2C_ACKFAIL_FLAG ((uint32_t)0x00000010)
79#define I2C_STOPF_FLAG ((uint32_t)0x00000020)
80#define I2C_TDC_FLAG ((uint32_t)0x00000040)
81#define I2C_TCRLD_FLAG ((uint32_t)0x00000080)
82#define I2C_BUSERR_FLAG ((uint32_t)0x00000100)
83#define I2C_ARLOST_FLAG ((uint32_t)0x00000200)
84#define I2C_OUF_FLAG ((uint32_t)0x00000400)
85#define I2C_PECERR_FLAG ((uint32_t)0x00000800)
86#define I2C_TMOUT_FLAG ((uint32_t)0x00001000)
87#define I2C_ALERTF_FLAG ((uint32_t)0x00002000)
88#define I2C_BUSYF_FLAG ((uint32_t)0x00008000)
89#define I2C_SDIR_FLAG ((uint32_t)0x00010000)
102typedef enum
103{
104 I2C_SMBUS_MODE_DEVICE = 0x00,
105 I2C_SMBUS_MODE_HOST = 0x01
106} i2c_smbus_mode_type;
107
111typedef enum
112{
113 I2C_ADDRESS_MODE_7BIT = 0x00,
114 I2C_ADDRESS_MODE_10BIT = 0x01
115} i2c_address_mode_type;
116
120typedef enum
121{
122 I2C_DIR_TRANSMIT = 0x00,
123 I2C_DIR_RECEIVE = 0x01
124} i2c_transfer_dir_type;
125
129typedef enum
130{
131 I2C_DMA_REQUEST_TX = 0x00,
132 I2C_DMA_REQUEST_RX = 0x01
133} i2c_dma_request_type;
134
138typedef enum
139{
140 I2C_SMBUS_ALERT_HIGH = 0x00,
141 I2C_SMBUS_ALERT_LOW = 0x01
142} i2c_smbus_alert_set_type;
143
147typedef enum
148{
149 I2C_TIMEOUT_DETCET_LOW = 0x00,
150 I2C_TIMEOUT_DETCET_HIGH = 0x01
151} i2c_timeout_detcet_type;
152
156typedef enum
157{
158 I2C_ADDR2_NOMASK = 0x00,
159 I2C_ADDR2_MASK01 = 0x01,
160 I2C_ADDR2_MASK02 = 0x02,
161 I2C_ADDR2_MASK03 = 0x03,
162 I2C_ADDR2_MASK04 = 0x04,
163 I2C_ADDR2_MASK05 = 0x05,
164 I2C_ADDR2_MASK06 = 0x06,
165 I2C_ADDR2_MASK07 = 0x07
166} i2c_addr2_mask_type;
167
171typedef enum
172{
173 I2C_AUTO_STOP_MODE = 0x02000000,
174 I2C_SOFT_STOP_MODE = 0x00000000,
175 I2C_RELOAD_MODE = 0x01000000
176} i2c_reload_stop_mode_type;
177
181typedef enum
182{
183 I2C_WITHOUT_START = 0x00000000,
184 I2C_GEN_START_READ = 0x00002400,
185 I2C_GEN_START_WRITE = 0x00002000
186} i2c_start_mode_type;
187
191typedef struct
192{
196 union
197 {
198 __IO uint32_t ctrl1;
199 struct
200 {
201 __IO uint32_t i2cen : 1; /* [0] */
202 __IO uint32_t tdien : 1; /* [1] */
203 __IO uint32_t rdien : 1; /* [2] */
204 __IO uint32_t addrien : 1; /* [3] */
205 __IO uint32_t ackfailien : 1; /* [4] */
206 __IO uint32_t stopien : 1; /* [5] */
207 __IO uint32_t tdcien : 1; /* [6] */
208 __IO uint32_t errien : 1; /* [7] */
209 __IO uint32_t dflt : 4; /* [11:8] */
210 __IO uint32_t reserved1 : 2; /* [13:12] */
211 __IO uint32_t dmaten : 1; /* [14] */
212 __IO uint32_t dmaren : 1; /* [15] */
213 __IO uint32_t sctrl : 1; /* [16] */
214 __IO uint32_t stretch : 1; /* [17] */
215 __IO uint32_t reserved2 : 1; /* [18] */
216 __IO uint32_t gcaen : 1; /* [19] */
217 __IO uint32_t haddren : 1; /* [20] */
218 __IO uint32_t devaddren : 1; /* [21] */
219 __IO uint32_t smbalert : 1; /* [22] */
220 __IO uint32_t pecen : 1; /* [23] */
221 __IO uint32_t reserved3 : 8; /* [31:24] */
222 } ctrl1_bit;
223 };
224
228 union
229 {
230 __IO uint32_t ctrl2;
231 struct
232 {
233 __IO uint32_t saddr : 10;/* [9:0] */
234 __IO uint32_t dir : 1; /* [10] */
235 __IO uint32_t addr10 : 1; /* [11] */
236 __IO uint32_t readh10 : 1; /* [12] */
237 __IO uint32_t genstart : 1; /* [13] */
238 __IO uint32_t genstop : 1; /* [14] */
239 __IO uint32_t nacken : 1; /* [15] */
240 __IO uint32_t cnt : 8; /* [23:16] */
241 __IO uint32_t rlden : 1; /* [24] */
242 __IO uint32_t astopen : 1; /* [25] */
243 __IO uint32_t pecten : 1; /* [26] */
244 __IO uint32_t reserved1 : 5; /* [31:27] */
245 } ctrl2_bit;
246 };
247
251 union
252 {
253 __IO uint32_t oaddr1;
254 struct
255 {
256 __IO uint32_t addr1 : 10;/* [9:0] */
257 __IO uint32_t addr1mode : 1; /* [10] */
258 __IO uint32_t reserved1 : 4; /* [14:11] */
259 __IO uint32_t addr1en : 1; /* [15] */
260 __IO uint32_t reserved2 : 16;/* [31:16] */
261 } oaddr1_bit;
262 };
263
267 union
268 {
269 __IO uint32_t oaddr2;
270 struct
271 {
272 __IO uint32_t reserved1 : 1; /* [0] */
273 __IO uint32_t addr2 : 7; /* [7:1] */
274 __IO uint32_t addr2mask : 3; /* [10:8] */
275 __IO uint32_t reserved2 : 4; /* [14:11] */
276 __IO uint32_t addr2en : 1; /* [15] */
277 __IO uint32_t reserved3 : 16;/* [31:16] */
278 } oaddr2_bit;
279 };
280
284 union
285 {
286 __IO uint32_t clkctrl;
287 struct
288 {
289 __IO uint32_t scll : 8; /* [7:0] */
290 __IO uint32_t sclh : 8; /* [15:8] */
291 __IO uint32_t sdad : 4; /* [19:16] */
292 __IO uint32_t scld : 4; /* [23:20] */
293 __IO uint32_t divh : 4; /* [27:24] */
294 __IO uint32_t divl : 4; /* [31:28] */
295 } clkctrl_bit;
296 };
297
301 union
302 {
303 __IO uint32_t timeout;
304 struct
305 {
306 __IO uint32_t totime : 12;/* [11:0] */
307 __IO uint32_t tomode : 1; /* [12] */
308 __IO uint32_t reserved1 : 2; /* [14:13] */
309 __IO uint32_t toen : 1; /* [15] */
310 __IO uint32_t exttime : 12;/* [27:16] */
311 __IO uint32_t reserved2 : 3; /* [30:28] */
312 __IO uint32_t exten : 1; /* [31] */
313 } timeout_bit;
314 };
315
319 union
320 {
321 __IO uint32_t sts;
322 struct
323 {
324 __IO uint32_t tdbe : 1; /* [0] */
325 __IO uint32_t tdis : 1; /* [1] */
326 __IO uint32_t rdbf : 1; /* [2] */
327 __IO uint32_t addrf : 1; /* [3] */
328 __IO uint32_t ackfail : 1; /* [4] */
329 __IO uint32_t stopf : 1; /* [5] */
330 __IO uint32_t tdc : 1; /* [6] */
331 __IO uint32_t tcrld : 1; /* [7] */
332 __IO uint32_t buserr : 1; /* [8] */
333 __IO uint32_t arlost : 1; /* [9] */
334 __IO uint32_t ouf : 1; /* [10] */
335 __IO uint32_t pecerr : 1; /* [11] */
336 __IO uint32_t tmout : 1; /* [12] */
337 __IO uint32_t alertf : 1; /* [13] */
338 __IO uint32_t reserved1 : 1; /* [14] */
339 __IO uint32_t busyf : 1; /* [15] */
340 __IO uint32_t sdir : 1; /* [16] */
341 __IO uint32_t addr : 7; /* [23:17] */
342 __IO uint32_t reserved2 : 8; /* [31:24] */
343 } sts_bit;
344 };
345
349 union
350 {
351 __IO uint32_t clr;
352 struct
353 {
354 __IO uint32_t reserved1 : 3; /* [2:0] */
355 __IO uint32_t addrc : 1; /* [3] */
356 __IO uint32_t ackfailc : 1; /* [4] */
357 __IO uint32_t stopc : 1; /* [5] */
358 __IO uint32_t reserved2 : 2; /* [6:7] */
359 __IO uint32_t buserrc : 1; /* [8] */
360 __IO uint32_t arlostc : 1; /* [9] */
361 __IO uint32_t oufc : 1; /* [10] */
362 __IO uint32_t pecerrc : 1; /* [11] */
363 __IO uint32_t tmoutc : 1; /* [12] */
364 __IO uint32_t alertc : 1; /* [13] */
365 __IO uint32_t reserved3 : 18;/* [31:14] */
366 } clr_bit;
367 };
368
372 union
373 {
374 __IO uint32_t pec;
375 struct
376 {
377 __IO uint32_t pecval : 8; /* [7:0] */
378 __IO uint32_t reserved1 : 24;/* [31:8] */
379 } pec_bit;
380 };
381
385 union
386 {
387 __IO uint32_t rxdt;
388 struct
389 {
390 __IO uint32_t dt : 8; /* [7:0] */
391 __IO uint32_t reserved1 : 24;/* [31:8] */
392 } rxdt_bit;
393 };
394
398 union
399 {
400 __IO uint32_t txdt;
401 struct
402 {
403 __IO uint32_t dt : 8; /* [7:0] */
404 __IO uint32_t reserved1 : 24;/* [31:8] */
405 } txdt_bit;
406 };
407
408} i2c_type;
409
414#define I2C1 ((i2c_type *) I2C1_BASE)
415#define I2C2 ((i2c_type *) I2C2_BASE)
416#define I2C3 ((i2c_type *) I2C3_BASE)
417
422void i2c_reset(i2c_type *i2c_x);
423void i2c_init(i2c_type *i2c_x, uint8_t dfilters, uint32_t clk);
424void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address);
425void i2c_own_address2_set(i2c_type *i2c_x, uint8_t address, i2c_addr2_mask_type mask);
426void i2c_own_address2_enable(i2c_type *i2c_x, confirm_state new_state);
427void i2c_smbus_enable(i2c_type *i2c_x, i2c_smbus_mode_type mode, confirm_state new_state);
428void i2c_enable(i2c_type *i2c_x, confirm_state new_state);
429void i2c_clock_stretch_enable(i2c_type *i2c_x, confirm_state new_state);
430void i2c_ack_enable(i2c_type *i2c_x, confirm_state new_state);
431void i2c_addr10_mode_enable(i2c_type *i2c_x, confirm_state new_state);
432void i2c_transfer_addr_set(i2c_type *i2c_x, uint16_t address);
433uint16_t i2c_transfer_addr_get(i2c_type *i2c_x);
434void i2c_transfer_dir_set(i2c_type *i2c_x, i2c_transfer_dir_type i2c_direction);
435 i2c_transfer_dir_type i2c_transfer_dir_get(i2c_type *i2c_x);
436uint8_t i2c_matched_addr_get(i2c_type *i2c_x);
437void i2c_auto_stop_enable(i2c_type *i2c_x, confirm_state new_state);
438void i2c_reload_enable(i2c_type *i2c_x, confirm_state new_state);
439void i2c_cnt_set(i2c_type *i2c_x, uint8_t cnt);
440void i2c_addr10_header_enable(i2c_type *i2c_x, confirm_state new_state);
441void i2c_general_call_enable(i2c_type *i2c_x, confirm_state new_state);
442void i2c_smbus_alert_set(i2c_type *i2c_x, i2c_smbus_alert_set_type level);
443void i2c_slave_data_ctrl_enable(i2c_type *i2c_x, confirm_state new_state);
444void i2c_pec_calculate_enable(i2c_type *i2c_x, confirm_state new_state);
445void i2c_pec_transmit_enable(i2c_type *i2c_x, confirm_state new_state);
446uint8_t i2c_pec_value_get(i2c_type *i2c_x);
447void i2c_timeout_set(i2c_type *i2c_x, uint16_t timeout);
448void i2c_timeout_detcet_set(i2c_type *i2c_x, i2c_timeout_detcet_type mode);
449void i2c_timeout_enable(i2c_type *i2c_x, confirm_state new_state);
450void i2c_ext_timeout_set(i2c_type *i2c_x, uint16_t timeout);
451void i2c_ext_timeout_enable(i2c_type *i2c_x, confirm_state new_state);
452void i2c_interrupt_enable(i2c_type *i2c_x, uint32_t source, confirm_state new_state);
453 flag_status i2c_interrupt_get(i2c_type *i2c_x, uint16_t source);
454void i2c_dma_enable(i2c_type *i2c_x, i2c_dma_request_type dma_req, confirm_state new_state);
455void i2c_transmit_set(i2c_type *i2c_x, uint16_t address, uint8_t cnt, i2c_reload_stop_mode_type rld_stop, i2c_start_mode_type start);
456void i2c_start_generate(i2c_type *i2c_x);
457void i2c_stop_generate(i2c_type *i2c_x);
458void i2c_data_send(i2c_type *i2c_x, uint8_t data);
459uint8_t i2c_data_receive(i2c_type *i2c_x);
460 flag_status i2c_flag_get(i2c_type *i2c_x, uint32_t flag);
461void i2c_flag_clear(i2c_type *i2c_x, uint32_t flag);
462
475#ifdef __cplusplus
476}
477#endif
478
479#endif
at32f435_437.h
at32f435_437 header file
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
i2c_pec_transmit_enable
void i2c_pec_transmit_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable pec transfer.
Definition: at32f435_437_i2c.c:422
i2c_transfer_dir_get
i2c_transfer_dir_type i2c_transfer_dir_get(i2c_type *i2c_x)
slave get the i2c transfer direction.
Definition: at32f435_437_i2c.c:282
i2c_slave_data_ctrl_enable
void i2c_slave_data_ctrl_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable slave data control.
Definition: at32f435_437_i2c.c:396
i2c_data_receive
uint8_t i2c_data_receive(i2c_type *i2c_x)
receive a byte through the i2c periph.
Definition: at32f435_437_i2c.c:671
i2c_reset
void i2c_reset(i2c_type *i2c_x)
reset the i2c register
Definition: at32f435_437_i2c.c:51
i2c_smbus_alert_set
void i2c_smbus_alert_set(i2c_type *i2c_x, i2c_smbus_alert_set_type level)
drives the smbus alert pin high or low.
Definition: at32f435_437_i2c.c:383
i2c_own_address2_set
void i2c_own_address2_set(i2c_type *i2c_x, uint8_t address, i2c_addr2_mask_type mask)
config i2c own address 2 and mask.
Definition: at32f435_437_i2c.c:133
i2c_pec_value_get
uint8_t i2c_pec_value_get(i2c_type *i2c_x)
get the i2c pec value.
Definition: at32f435_437_i2c.c:434
i2c_transfer_dir_set
void i2c_transfer_dir_set(i2c_type *i2c_x, i2c_transfer_dir_type i2c_direction)
config the master transfer direction.
Definition: at32f435_437_i2c.c:268
i2c_timeout_enable
void i2c_timeout_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable bus timeout.
Definition: at32f435_437_i2c.c:476
i2c_general_call_enable
void i2c_general_call_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable general call mode.
Definition: at32f435_437_i2c.c:367
i2c_init
void i2c_init(i2c_type *i2c_x, uint8_t dfilters, uint32_t clk)
init i2c digit filters and clock control register.
Definition: at32f435_437_i2c.c:79
i2c_ack_enable
void i2c_ack_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable ack.
Definition: at32f435_437_i2c.c:214
i2c_interrupt_get
flag_status i2c_interrupt_get(i2c_type *i2c_x, uint16_t source)
get interrupt status
Definition: at32f435_437_i2c.c:552
i2c_timeout_set
void i2c_timeout_set(i2c_type *i2c_x, uint16_t timeout)
config the i2c bus timeout.
Definition: at32f435_437_i2c.c:447
i2c_matched_addr_get
uint8_t i2c_matched_addr_get(i2c_type *i2c_x)
get the i2c slave matched address.
Definition: at32f435_437_i2c.c:301
i2c_ext_timeout_enable
void i2c_ext_timeout_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable extend bus timeout.
Definition: at32f435_437_i2c.c:502
i2c_transfer_addr_set
void i2c_transfer_addr_set(i2c_type *i2c_x, uint16_t address)
config the slave address to be transmitted.
Definition: at32f435_437_i2c.c:240
i2c_transfer_addr_get
uint16_t i2c_transfer_addr_get(i2c_type *i2c_x)
get the slave address to be transmitted.
Definition: at32f435_437_i2c.c:252
i2c_ext_timeout_set
void i2c_ext_timeout_set(i2c_type *i2c_x, uint16_t timeout)
config the i2c extend bus timeout.
Definition: at32f435_437_i2c.c:489
i2c_cnt_set
void i2c_cnt_set(i2c_type *i2c_x, uint8_t cnt)
config the transfer cnt .
Definition: at32f435_437_i2c.c:340
i2c_own_address2_enable
void i2c_own_address2_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable own address 2.
Definition: at32f435_437_i2c.c:148
i2c_pec_calculate_enable
void i2c_pec_calculate_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable pec calculate.
Definition: at32f435_437_i2c.c:409
i2c_stop_generate
void i2c_stop_generate(i2c_type *i2c_x)
generate stop condition.
Definition: at32f435_437_i2c.c:646
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config i2c own address 1.
Definition: at32f435_437_i2c.c:103
i2c_enable
void i2c_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable peripheral.
Definition: at32f435_437_i2c.c:188
i2c_smbus_enable
void i2c_smbus_enable(i2c_type *i2c_x, i2c_smbus_mode_type mode, confirm_state new_state)
enable or disable smbus mode.
Definition: at32f435_437_i2c.c:165
i2c_timeout_detcet_set
void i2c_timeout_detcet_set(i2c_type *i2c_x, i2c_timeout_detcet_type mode)
config the bus timeout detcet level.
Definition: at32f435_437_i2c.c:463
i2c_flag_get
flag_status i2c_flag_get(i2c_type *i2c_x, uint32_t flag)
get flag status.
Definition: at32f435_437_i2c.c:701
i2c_auto_stop_enable
void i2c_auto_stop_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable auto send stop mode.
Definition: at32f435_437_i2c.c:314
i2c_flag_clear
void i2c_flag_clear(i2c_type *i2c_x, uint32_t flag)
clear flag status
Definition: at32f435_437_i2c.c:731
i2c_data_send
void i2c_data_send(i2c_type *i2c_x, uint8_t data)
send a byte through the i2c periph.
Definition: at32f435_437_i2c.c:659
i2c_clock_stretch_enable
void i2c_clock_stretch_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable clock stretch.
Definition: at32f435_437_i2c.c:201
i2c_dma_enable
void i2c_dma_enable(i2c_type *i2c_x, i2c_dma_request_type dma_req, confirm_state new_state)
enable or disable dma requests.
Definition: at32f435_437_i2c.c:576
i2c_addr10_header_enable
void i2c_addr10_header_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable read 10-bit header, this mode only used in 10-bit address mode read.
Definition: at32f435_437_i2c.c:354
i2c_transmit_set
void i2c_transmit_set(i2c_type *i2c_x, uint16_t address, uint8_t cnt, i2c_reload_stop_mode_type rld_stop, i2c_start_mode_type start)
config data transfer.
Definition: at32f435_437_i2c.c:607
i2c_interrupt_enable
void i2c_interrupt_enable(i2c_type *i2c_x, uint32_t source, confirm_state new_state)
enable or disable interrupts.
Definition: at32f435_437_i2c.c:524
i2c_start_generate
void i2c_start_generate(i2c_type *i2c_x)
generate start condition.
Definition: at32f435_437_i2c.c:634
i2c_reload_enable
void i2c_reload_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable cnt reload mode.
Definition: at32f435_437_i2c.c:327
i2c_addr10_mode_enable
void i2c_addr10_mode_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable 10-bit address mode (master transfer).
Definition: at32f435_437_i2c.c:227
i2c_reload_stop_mode_type
i2c_reload_stop_mode_type
i2c reload end mode
Definition: at32f435_437_i2c.h:172
i2c_timeout_detcet_type
i2c_timeout_detcet_type
i2c clock timeout detection mode
Definition: at32f435_437_i2c.h:148
i2c_start_mode_type
i2c_start_mode_type
i2c start mode
Definition: at32f435_437_i2c.h:182
i2c_addr2_mask_type
i2c_addr2_mask_type
i2c own address2 mask
Definition: at32f435_437_i2c.h:157
i2c_dma_request_type
i2c_dma_request_type
i2c dma requests direction
Definition: at32f435_437_i2c.h:130
i2c_address_mode_type
i2c_address_mode_type
i2c address mode
Definition: at32f435_437_i2c.h:112
i2c_smbus_alert_set_type
i2c_smbus_alert_set_type
i2c smbus alert pin set
Definition: at32f435_437_i2c.h:139
i2c_smbus_mode_type
i2c_smbus_mode_type
i2c smbus mode set
Definition: at32f435_437_i2c.h:103
i2c_transfer_dir_type
i2c_transfer_dir_type
i2c transfer direction
Definition: at32f435_437_i2c.h:121
I2C_AUTO_STOP_MODE
@ I2C_AUTO_STOP_MODE
Definition: at32f435_437_i2c.h:173
I2C_SOFT_STOP_MODE
@ I2C_SOFT_STOP_MODE
Definition: at32f435_437_i2c.h:174
I2C_RELOAD_MODE
@ I2C_RELOAD_MODE
Definition: at32f435_437_i2c.h:175
I2C_TIMEOUT_DETCET_HIGH
@ I2C_TIMEOUT_DETCET_HIGH
Definition: at32f435_437_i2c.h:150
I2C_TIMEOUT_DETCET_LOW
@ I2C_TIMEOUT_DETCET_LOW
Definition: at32f435_437_i2c.h:149
I2C_GEN_START_READ
@ I2C_GEN_START_READ
Definition: at32f435_437_i2c.h:184
I2C_WITHOUT_START
@ I2C_WITHOUT_START
Definition: at32f435_437_i2c.h:183
I2C_GEN_START_WRITE
@ I2C_GEN_START_WRITE
Definition: at32f435_437_i2c.h:185
I2C_ADDR2_MASK01
@ I2C_ADDR2_MASK01
Definition: at32f435_437_i2c.h:159
I2C_ADDR2_MASK07
@ I2C_ADDR2_MASK07
Definition: at32f435_437_i2c.h:165
I2C_ADDR2_MASK03
@ I2C_ADDR2_MASK03
Definition: at32f435_437_i2c.h:161
I2C_ADDR2_MASK04
@ I2C_ADDR2_MASK04
Definition: at32f435_437_i2c.h:162
I2C_ADDR2_NOMASK
@ I2C_ADDR2_NOMASK
Definition: at32f435_437_i2c.h:158
I2C_ADDR2_MASK05
@ I2C_ADDR2_MASK05
Definition: at32f435_437_i2c.h:163
I2C_ADDR2_MASK02
@ I2C_ADDR2_MASK02
Definition: at32f435_437_i2c.h:160
I2C_ADDR2_MASK06
@ I2C_ADDR2_MASK06
Definition: at32f435_437_i2c.h:164
I2C_DMA_REQUEST_TX
@ I2C_DMA_REQUEST_TX
Definition: at32f435_437_i2c.h:131
I2C_DMA_REQUEST_RX
@ I2C_DMA_REQUEST_RX
Definition: at32f435_437_i2c.h:132
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f435_437_i2c.h:113
I2C_ADDRESS_MODE_10BIT
@ I2C_ADDRESS_MODE_10BIT
Definition: at32f435_437_i2c.h:114
I2C_SMBUS_ALERT_HIGH
@ I2C_SMBUS_ALERT_HIGH
Definition: at32f435_437_i2c.h:140
I2C_SMBUS_ALERT_LOW
@ I2C_SMBUS_ALERT_LOW
Definition: at32f435_437_i2c.h:141
I2C_SMBUS_MODE_HOST
@ I2C_SMBUS_MODE_HOST
Definition: at32f435_437_i2c.h:105
I2C_SMBUS_MODE_DEVICE
@ I2C_SMBUS_MODE_DEVICE
Definition: at32f435_437_i2c.h:104
I2C_DIR_RECEIVE
@ I2C_DIR_RECEIVE
Definition: at32f435_437_i2c.h:123
I2C_DIR_TRANSMIT
@ I2C_DIR_TRANSMIT
Definition: at32f435_437_i2c.h:122
i2c_type
type define i2c register all
Definition: at32f435_437_i2c.h:192
i2c_type::tdien
__IO uint32_t tdien
Definition: at32f435_437_i2c.h:202
i2c_type::arlostc
__IO uint32_t arlostc
Definition: at32f435_437_i2c.h:360
i2c_type::dmaten
__IO uint32_t dmaten
Definition: at32f435_437_i2c.h:211
i2c_type::smbalert
__IO uint32_t smbalert
Definition: at32f435_437_i2c.h:219
i2c_type::txdt
__IO uint32_t txdt
Definition: at32f435_437_i2c.h:400
i2c_type::genstop
__IO uint32_t genstop
Definition: at32f435_437_i2c.h:238
i2c_type::tdc
__IO uint32_t tdc
Definition: at32f435_437_i2c.h:330
i2c_type::addr2en
__IO uint32_t addr2en
Definition: at32f435_437_i2c.h:276
i2c_type::pecerr
__IO uint32_t pecerr
Definition: at32f435_437_i2c.h:335
i2c_type::oufc
__IO uint32_t oufc
Definition: at32f435_437_i2c.h:361
i2c_type::gcaen
__IO uint32_t gcaen
Definition: at32f435_437_i2c.h:216
i2c_type::rxdt
__IO uint32_t rxdt
Definition: at32f435_437_i2c.h:387
i2c_type::haddren
__IO uint32_t haddren
Definition: at32f435_437_i2c.h:217
i2c_type::buserrc
__IO uint32_t buserrc
Definition: at32f435_437_i2c.h:359
i2c_type::nacken
__IO uint32_t nacken
Definition: at32f435_437_i2c.h:239
i2c_type::stopc
__IO uint32_t stopc
Definition: at32f435_437_i2c.h:357
i2c_type::addr2
__IO uint32_t addr2
Definition: at32f435_437_i2c.h:273
i2c_type::sclh
__IO uint32_t sclh
Definition: at32f435_437_i2c.h:290
i2c_type::buserr
__IO uint32_t buserr
Definition: at32f435_437_i2c.h:332
i2c_type::tmout
__IO uint32_t tmout
Definition: at32f435_437_i2c.h:336
i2c_type::tdcien
__IO uint32_t tdcien
Definition: at32f435_437_i2c.h:207
i2c_type::stopf
__IO uint32_t stopf
Definition: at32f435_437_i2c.h:329
i2c_type::tcrld
__IO uint32_t tcrld
Definition: at32f435_437_i2c.h:331
i2c_type::rlden
__IO uint32_t rlden
Definition: at32f435_437_i2c.h:241
i2c_type::sdad
__IO uint32_t sdad
Definition: at32f435_437_i2c.h:291
i2c_type::sts
__IO uint32_t sts
Definition: at32f435_437_i2c.h:321
i2c_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_i2c.h:210
i2c_type::genstart
__IO uint32_t genstart
Definition: at32f435_437_i2c.h:237
i2c_type::pecten
__IO uint32_t pecten
Definition: at32f435_437_i2c.h:243
i2c_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f435_437_i2c.h:230
i2c_type::tomode
__IO uint32_t tomode
Definition: at32f435_437_i2c.h:307
i2c_type::addrc
__IO uint32_t addrc
Definition: at32f435_437_i2c.h:355
i2c_type::exten
__IO uint32_t exten
Definition: at32f435_437_i2c.h:312
i2c_type::scld
__IO uint32_t scld
Definition: at32f435_437_i2c.h:292
i2c_type::tdis
__IO uint32_t tdis
Definition: at32f435_437_i2c.h:325
i2c_type::addrien
__IO uint32_t addrien
Definition: at32f435_437_i2c.h:204
i2c_type::saddr
__IO uint32_t saddr
Definition: at32f435_437_i2c.h:233
i2c_type::dir
__IO uint32_t dir
Definition: at32f435_437_i2c.h:234
i2c_type::ouf
__IO uint32_t ouf
Definition: at32f435_437_i2c.h:334
i2c_type::arlost
__IO uint32_t arlost
Definition: at32f435_437_i2c.h:333
i2c_type::tmoutc
__IO uint32_t tmoutc
Definition: at32f435_437_i2c.h:363
i2c_type::stretch
__IO uint32_t stretch
Definition: at32f435_437_i2c.h:214
i2c_type::stopien
__IO uint32_t stopien
Definition: at32f435_437_i2c.h:206
i2c_type::rdien
__IO uint32_t rdien
Definition: at32f435_437_i2c.h:203
i2c_type::scll
__IO uint32_t scll
Definition: at32f435_437_i2c.h:289
i2c_type::pecerrc
__IO uint32_t pecerrc
Definition: at32f435_437_i2c.h:362
i2c_type::clr
__IO uint32_t clr
Definition: at32f435_437_i2c.h:351
i2c_type::timeout
__IO uint32_t timeout
Definition: at32f435_437_i2c.h:303
i2c_type::addr1mode
__IO uint32_t addr1mode
Definition: at32f435_437_i2c.h:257
i2c_type::dflt
__IO uint32_t dflt
Definition: at32f435_437_i2c.h:209
i2c_type::tdbe
__IO uint32_t tdbe
Definition: at32f435_437_i2c.h:324
i2c_type::totime
__IO uint32_t totime
Definition: at32f435_437_i2c.h:306
i2c_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_i2c.h:215
i2c_type::ackfailien
__IO uint32_t ackfailien
Definition: at32f435_437_i2c.h:205
i2c_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_i2c.h:221
i2c_type::pecval
__IO uint32_t pecval
Definition: at32f435_437_i2c.h:377
i2c_type::sdir
__IO uint32_t sdir
Definition: at32f435_437_i2c.h:340
i2c_type::ackfailc
__IO uint32_t ackfailc
Definition: at32f435_437_i2c.h:356
i2c_type::divh
__IO uint32_t divh
Definition: at32f435_437_i2c.h:293
i2c_type::toen
__IO uint32_t toen
Definition: at32f435_437_i2c.h:309
i2c_type::divl
__IO uint32_t divl
Definition: at32f435_437_i2c.h:294
i2c_type::addrf
__IO uint32_t addrf
Definition: at32f435_437_i2c.h:327
i2c_type::cnt
__IO uint32_t cnt
Definition: at32f435_437_i2c.h:240
i2c_type::dt
__IO uint32_t dt
Definition: at32f435_437_i2c.h:390
i2c_type::astopen
__IO uint32_t astopen
Definition: at32f435_437_i2c.h:242
i2c_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f435_437_i2c.h:198
i2c_type::ackfail
__IO uint32_t ackfail
Definition: at32f435_437_i2c.h:328
i2c_type::addr2mask
__IO uint32_t addr2mask
Definition: at32f435_437_i2c.h:274
i2c_type::sctrl
__IO uint32_t sctrl
Definition: at32f435_437_i2c.h:213
i2c_type::addr
__IO uint32_t addr
Definition: at32f435_437_i2c.h:341
i2c_type::devaddren
__IO uint32_t devaddren
Definition: at32f435_437_i2c.h:218
i2c_type::i2cen
__IO uint32_t i2cen
Definition: at32f435_437_i2c.h:201
i2c_type::rdbf
__IO uint32_t rdbf
Definition: at32f435_437_i2c.h:326
i2c_type::busyf
__IO uint32_t busyf
Definition: at32f435_437_i2c.h:339
i2c_type::oaddr1
__IO uint32_t oaddr1
Definition: at32f435_437_i2c.h:253
i2c_type::errien
__IO uint32_t errien
Definition: at32f435_437_i2c.h:208
i2c_type::addr1
__IO uint32_t addr1
Definition: at32f435_437_i2c.h:256
i2c_type::dmaren
__IO uint32_t dmaren
Definition: at32f435_437_i2c.h:212
i2c_type::addr10
__IO uint32_t addr10
Definition: at32f435_437_i2c.h:235
i2c_type::clkctrl
__IO uint32_t clkctrl
Definition: at32f435_437_i2c.h:286
i2c_type::alertc
__IO uint32_t alertc
Definition: at32f435_437_i2c.h:364
i2c_type::exttime
__IO uint32_t exttime
Definition: at32f435_437_i2c.h:310
i2c_type::oaddr2
__IO uint32_t oaddr2
Definition: at32f435_437_i2c.h:269
i2c_type::pecen
__IO uint32_t pecen
Definition: at32f435_437_i2c.h:220
i2c_type::pec
__IO uint32_t pec
Definition: at32f435_437_i2c.h:374
i2c_type::addr1en
__IO uint32_t addr1en
Definition: at32f435_437_i2c.h:259
i2c_type::readh10
__IO uint32_t readh10
Definition: at32f435_437_i2c.h:236
i2c_type::alertf
__IO uint32_t alertf
Definition: at32f435_437_i2c.h:337


AT32F435/437 Firmwary Library: at32f435_437_misc.c Source File

  • libraries
  • drivers
  • src
at32f435_437_misc.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_conf.h"
29
39#ifdef MISC_MODULE_ENABLED
40
45#define AIRCR_VECTKEY_MASK ((uint32_t)0x05FA0000)
46
52void nvic_system_reset(void)
53{
54 NVIC_SystemReset();
55}
56
64void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
65{
66 uint32_t temp_priority = 0;
67
68 /* encode priority */
69 temp_priority = NVIC_EncodePriority(NVIC_GetPriorityGrouping(), preempt_priority, sub_priority);
70 /* set priority */
71 NVIC_SetPriority(irqn, temp_priority);
72 /* enable irqn */
73 NVIC_EnableIRQ(irqn);
74}
75
81void nvic_irq_disable(IRQn_Type irqn)
82{
83 NVIC_DisableIRQ(irqn);
84}
85
97void nvic_priority_group_config(nvic_priority_group_type priority_group)
98{
99 /* set the prigroup[10:8] bits according to nvic_prioritygroup value */
100 NVIC_SetPriorityGrouping(priority_group);
101}
102
112void nvic_vector_table_set(uint32_t base, uint32_t offset)
113{
114 SCB->VTOR = base | (offset & (uint32_t)0x1FFFFF80);
115}
116
127void nvic_lowpower_mode_config(nvic_lowpower_mode_type lp_mode, confirm_state new_state)
128{
129 if(new_state != FALSE)
130 {
131 SCB->SCR |= lp_mode;
132 }
133 else
134 {
135 SCB->SCR &= (uint32_t)(~(uint32_t)lp_mode);
136 }
137}
138
147void systick_clock_source_config(systick_clock_source_type source)
148{
149 if(source == SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV)
150 {
151 SysTick->CTRL |= SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV;
152 }
153 else
154 {
155 SysTick->CTRL &= ~(uint32_t)SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV;
156 }
157}
158
163#endif
164
confirm_state
confirm_state
Definition: at32f435_437.h:379
FALSE
@ FALSE
Definition: at32f435_437.h:379
nvic_lowpower_mode_type
nvic_lowpower_mode_type
nvic low power mode
Definition: at32f435_437_misc.h:78
nvic_priority_group_type
nvic_priority_group_type
nvic interrupt priority group
Definition: at32f435_437_misc.h:66
systick_clock_source_type
systick_clock_source_type
systick clock source
Definition: at32f435_437_misc.h:88
SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
@ SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
Definition: at32f435_437_misc.h:90
nvic_lowpower_mode_config
void nvic_lowpower_mode_config(nvic_lowpower_mode_type lp_mode, confirm_state new_state)
config nvic lowpower mode
Definition: at32f435_437_misc.c:127
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f435_437_misc.c:52
nvic_vector_table_set
void nvic_vector_table_set(uint32_t base, uint32_t offset)
set the vector table location and offset.
Definition: at32f435_437_misc.c:112
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_irq_disable
void nvic_irq_disable(IRQn_Type irqn)
disable nvic irq number
Definition: at32f435_437_misc.c:81
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
systick_clock_source_config
void systick_clock_source_config(systick_clock_source_type source)
config systick clock source
Definition: at32f435_437_misc.c:147
IRQn_Type
enum IRQn IRQn_Type
at32f435_437 interrupt number definition, according to the selected device in library_configuration_s...
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_misc.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_misc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_MISC_H
29#define __AT32F435_437_MISC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
51#define NVIC_VECTTAB_RAM ((uint32_t)0x20000000)
52#define NVIC_VECTTAB_FLASH ((uint32_t)0x08000000)
65typedef enum
66{
67 NVIC_PRIORITY_GROUP_0 = ((uint32_t)0x7),
68 NVIC_PRIORITY_GROUP_1 = ((uint32_t)0x6),
69 NVIC_PRIORITY_GROUP_2 = ((uint32_t)0x5),
70 NVIC_PRIORITY_GROUP_3 = ((uint32_t)0x4),
71 NVIC_PRIORITY_GROUP_4 = ((uint32_t)0x3)
72} nvic_priority_group_type;
73
77typedef enum
78{
79 NVIC_LP_SLEEPONEXIT = 0x02,
80 NVIC_LP_SLEEPDEEP = 0x04,
81 NVIC_LP_SEVONPEND = 0x10
82} nvic_lowpower_mode_type;
83
87typedef enum
88{
89 SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8 = ((uint32_t)0x00000000),
90 SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV = ((uint32_t)0x00000004)
91} systick_clock_source_type;
92
101void nvic_system_reset(void);
102void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority);
103void nvic_irq_disable(IRQn_Type irqn);
104void nvic_priority_group_config(nvic_priority_group_type priority_group);
105void nvic_vector_table_set(uint32_t base, uint32_t offset);
106void nvic_lowpower_mode_config(nvic_lowpower_mode_type lp_mode, confirm_state new_state);
107void systick_clock_source_config(systick_clock_source_type source);
108
121#ifdef __cplusplus
122}
123#endif
124
125#endif
at32f435_437.h
at32f435_437 header file
confirm_state
confirm_state
Definition: at32f435_437.h:379
nvic_lowpower_mode_config
void nvic_lowpower_mode_config(nvic_lowpower_mode_type lp_mode, confirm_state new_state)
config nvic lowpower mode
Definition: at32f435_437_misc.c:127
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f435_437_misc.c:52
nvic_vector_table_set
void nvic_vector_table_set(uint32_t base, uint32_t offset)
set the vector table location and offset.
Definition: at32f435_437_misc.c:112
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_irq_disable
void nvic_irq_disable(IRQn_Type irqn)
disable nvic irq number
Definition: at32f435_437_misc.c:81
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
systick_clock_source_config
void systick_clock_source_config(systick_clock_source_type source)
config systick clock source
Definition: at32f435_437_misc.c:147
nvic_lowpower_mode_type
nvic_lowpower_mode_type
nvic low power mode
Definition: at32f435_437_misc.h:78
nvic_priority_group_type
nvic_priority_group_type
nvic interrupt priority group
Definition: at32f435_437_misc.h:66
systick_clock_source_type
systick_clock_source_type
systick clock source
Definition: at32f435_437_misc.h:88
NVIC_LP_SEVONPEND
@ NVIC_LP_SEVONPEND
Definition: at32f435_437_misc.h:81
NVIC_LP_SLEEPONEXIT
@ NVIC_LP_SLEEPONEXIT
Definition: at32f435_437_misc.h:79
NVIC_LP_SLEEPDEEP
@ NVIC_LP_SLEEPDEEP
Definition: at32f435_437_misc.h:80
NVIC_PRIORITY_GROUP_1
@ NVIC_PRIORITY_GROUP_1
Definition: at32f435_437_misc.h:68
NVIC_PRIORITY_GROUP_3
@ NVIC_PRIORITY_GROUP_3
Definition: at32f435_437_misc.h:70
NVIC_PRIORITY_GROUP_2
@ NVIC_PRIORITY_GROUP_2
Definition: at32f435_437_misc.h:69
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
NVIC_PRIORITY_GROUP_0
@ NVIC_PRIORITY_GROUP_0
Definition: at32f435_437_misc.h:67
SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8
@ SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8
Definition: at32f435_437_misc.h:89
SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
@ SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
Definition: at32f435_437_misc.h:90
IRQn_Type
enum IRQn IRQn_Type
at32f435_437 interrupt number definition, according to the selected device in library_configuration_s...


AT32F435/437 Firmwary Library: at32f435_437_pwc.c Source File

  • libraries
  • drivers
  • src
at32f435_437_pwc.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef PWC_MODULE_ENABLED
39
49void pwc_reset(void)
50{
51 crm_periph_reset(CRM_PWC_PERIPH_RESET, TRUE);
52 crm_periph_reset(CRM_PWC_PERIPH_RESET, FALSE);
53}
54
61void pwc_battery_powered_domain_access(confirm_state new_state)
62{
63 PWC->ctrl_bit.bpwen= new_state;
64}
65
79void pwc_pvm_level_select(pwc_pvm_voltage_type pvm_voltage)
80{
81 PWC->ctrl_bit.pvmsel= pvm_voltage;
82}
83
90void pwc_power_voltage_monitor_enable(confirm_state new_state)
91{
92 PWC->ctrl_bit.pvmen= new_state;
93}
94
107void pwc_wakeup_pin_enable(uint32_t pin_num, confirm_state new_state)
108{
109 if(new_state == TRUE)
110 {
111 PWC->ctrlsts |= pin_num;
112 }
113 else
114 {
115 PWC->ctrlsts &= ~pin_num;
116 }
117}
118
128void pwc_flag_clear(uint32_t pwc_flag)
129{
130 if(pwc_flag & PWC_STANDBY_FLAG)
131 PWC->ctrl_bit.clsef = TRUE;
132 if(pwc_flag & PWC_WAKEUP_FLAG)
133 PWC->ctrl_bit.clswef = TRUE;
134}
135
145 flag_status pwc_flag_get(uint32_t pwc_flag)
146{
147 flag_status status = RESET;
148 if ((PWC->ctrlsts & pwc_flag) == RESET)
149 {
150 status = RESET;
151 }
152 else
153 {
154 status = SET;
155 }
156 return status;
157}
158
167void pwc_sleep_mode_enter(pwc_sleep_enter_type pwc_sleep_enter)
168{
169 SCB->SCR &= (uint32_t)~0x4;
170 if(pwc_sleep_enter == PWC_SLEEP_ENTER_WFE)
171 {
172 __SEV();
173 __WFE();
174 __WFE();
175 }
176 else if(pwc_sleep_enter == PWC_SLEEP_ENTER_WFI)
177 {
178 __WFI();
179 }
180}
181
190void pwc_deep_sleep_mode_enter(pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
191{
192 SCB->SCR |= 0x04;
193 if(pwc_deep_sleep_enter == PWC_DEEP_SLEEP_ENTER_WFE)
194 {
195 __SEV();
196 __WFE();
197 __WFE();
198 }
199 else if(pwc_deep_sleep_enter == PWC_DEEP_SLEEP_ENTER_WFI)
200 {
201 __WFI();
202 }
203 SCB->SCR &= (uint32_t)~0x4;
204}
205
214void pwc_voltage_regulate_set(pwc_regulator_type pwc_regulator)
215{
216 PWC->ctrl_bit.vrsel = pwc_regulator;
217}
218
224void pwc_standby_mode_enter(void)
225{
226 PWC->ctrl_bit.clswef = TRUE;
227 PWC->ctrl_bit.lpsel = TRUE;
228 SCB->SCR |= 0x04;
229#if defined (__CC_ARM)
230 __force_stores();
231#endif
232 __WFI();
233}
234
239#endif
240
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f435_437_crm.c:251
CRM_PWC_PERIPH_RESET
@ CRM_PWC_PERIPH_RESET
Definition: at32f435_437_crm.h:296
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
pwc_pvm_voltage_type
pwc_pvm_voltage_type
pwc pvm voltage type
Definition: at32f435_437_pwc.h:85
pwc_regulator_type
pwc_regulator_type
pwc regulator type
Definition: at32f435_437_pwc.h:128
pwc_deep_sleep_enter_type
pwc_deep_sleep_enter_type
pwc deep sleep enter type
Definition: at32f435_437_pwc.h:119
pwc_sleep_enter_type
pwc_sleep_enter_type
pwc sleep enter type
Definition: at32f435_437_pwc.h:110
PWC_DEEP_SLEEP_ENTER_WFI
@ PWC_DEEP_SLEEP_ENTER_WFI
Definition: at32f435_437_pwc.h:120
PWC_DEEP_SLEEP_ENTER_WFE
@ PWC_DEEP_SLEEP_ENTER_WFE
Definition: at32f435_437_pwc.h:121
PWC_SLEEP_ENTER_WFI
@ PWC_SLEEP_ENTER_WFI
Definition: at32f435_437_pwc.h:111
PWC_SLEEP_ENTER_WFE
@ PWC_SLEEP_ENTER_WFE
Definition: at32f435_437_pwc.h:112
PWC_STANDBY_FLAG
#define PWC_STANDBY_FLAG
Definition: at32f435_437_pwc.h:53
PWC_WAKEUP_FLAG
#define PWC_WAKEUP_FLAG
Definition: at32f435_437_pwc.h:52
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f435_437_pwc.c:61
pwc_voltage_regulate_set
void pwc_voltage_regulate_set(pwc_regulator_type pwc_regulator)
regulate low power consumption in the deep sleep mode
Definition: at32f435_437_pwc.c:214
pwc_standby_mode_enter
void pwc_standby_mode_enter(void)
enter pwc standby mode
Definition: at32f435_437_pwc.c:224
pwc_power_voltage_monitor_enable
void pwc_power_voltage_monitor_enable(confirm_state new_state)
enable or disable pwc power voltage monitor (pvm)
Definition: at32f435_437_pwc.c:90
pwc_sleep_mode_enter
void pwc_sleep_mode_enter(pwc_sleep_enter_type pwc_sleep_enter)
enter pwc sleep mode
Definition: at32f435_437_pwc.c:167
pwc_deep_sleep_mode_enter
void pwc_deep_sleep_mode_enter(pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode
Definition: at32f435_437_pwc.c:190
pwc_flag_get
flag_status pwc_flag_get(uint32_t pwc_flag)
get flag of pwc
Definition: at32f435_437_pwc.c:145
pwc_flag_clear
void pwc_flag_clear(uint32_t pwc_flag)
clear flag of pwc
Definition: at32f435_437_pwc.c:128
pwc_pvm_level_select
void pwc_pvm_level_select(pwc_pvm_voltage_type pvm_voltage)
select the voltage threshold detected by the power voltage detector.
Definition: at32f435_437_pwc.c:79
pwc_reset
void pwc_reset(void)
deinitialize the pwc peripheral registers to their default reset values.
Definition: at32f435_437_pwc.c:49
pwc_wakeup_pin_enable
void pwc_wakeup_pin_enable(uint32_t pin_num, confirm_state new_state)
enable or disable pwc standby wakeup pin
Definition: at32f435_437_pwc.c:107
PWC
#define PWC
Definition: at32f435_437_pwc.h:196
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_pwc.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_pwc.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_PWC_H
29#define __AT32F435_437_PWC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
52#define PWC_WAKEUP_FLAG ((uint32_t)0x00000001)
53#define PWC_STANDBY_FLAG ((uint32_t)0x00000002)
54#define PWC_PVM_OUTPUT_FLAG ((uint32_t)0x00000004)
63#define PWC_WAKEUP_PIN_1 ((uint32_t)0x00000100)
64#define PWC_WAKEUP_PIN_2 ((uint32_t)0x00000200)
75#define pwc_ldo_output_voltage_set(val) (PWC->ldoov_bit.ldoovsel = val)
76
84typedef enum
85{
86 PWC_PVM_VOLTAGE_2V3 = 0x01,
87 PWC_PVM_VOLTAGE_2V4 = 0x02,
88 PWC_PVM_VOLTAGE_2V5 = 0x03,
89 PWC_PVM_VOLTAGE_2V6 = 0x04,
90 PWC_PVM_VOLTAGE_2V7 = 0x05,
91 PWC_PVM_VOLTAGE_2V8 = 0x06,
92 PWC_PVM_VOLTAGE_2V9 = 0x07
93} pwc_pvm_voltage_type;
94
98typedef enum
99{
100 PWC_LDO_OUTPUT_1V2 = 0x00,
101 PWC_LDO_OUTPUT_1V3 = 0x01,
102 PWC_LDO_OUTPUT_1V1 = 0x04,
103 PWC_LDO_OUTPUT_1V0 = 0x05,
104} pwc_ldo_output_voltage_type;
105
109typedef enum
110{
111 PWC_SLEEP_ENTER_WFI = 0x00,
112 PWC_SLEEP_ENTER_WFE = 0x01
113} pwc_sleep_enter_type ;
114
118typedef enum
119{
120 PWC_DEEP_SLEEP_ENTER_WFI = 0x00,
121 PWC_DEEP_SLEEP_ENTER_WFE = 0x01
122} pwc_deep_sleep_enter_type ;
123
127typedef enum
128{
129 PWC_REGULATOR_ON = 0x00,
130 PWC_REGULATOR_LOW_POWER = 0x01
131} pwc_regulator_type ;
132
136typedef struct
137{
141 union
142 {
143 __IO uint32_t ctrl;
144 struct
145 {
146 __IO uint32_t vrsel : 1; /* [0] */
147 __IO uint32_t lpsel : 1; /* [1] */
148 __IO uint32_t clswef : 1; /* [2] */
149 __IO uint32_t clsef : 1; /* [3] */
150 __IO uint32_t pvmen : 1; /* [4] */
151 __IO uint32_t pvmsel : 3; /* [7:5] */
152 __IO uint32_t bpwen : 1; /* [8] */
153 __IO uint32_t reserved1 : 23;/* [31:9] */
154 } ctrl_bit;
155 };
156
160 union
161 {
162 __IO uint32_t ctrlsts;
163 struct
164 {
165 __IO uint32_t swef : 1; /* [0] */
166 __IO uint32_t sef : 1; /* [1] */
167 __IO uint32_t pvmof : 1; /* [2] */
168 __IO uint32_t reserved1 : 5; /* [7:3] */
169 __IO uint32_t swpen1 : 1; /* [8] */
170 __IO uint32_t swpen2 : 1; /* [9] */
171 __IO uint32_t reserved2 : 22;/* [31:10] */
172 } ctrlsts_bit;
173 };
174
175 __IO uint32_t reserved1[2];
176
180 union
181 {
182 __IO uint32_t ldoov;
183 struct
184 {
185 __IO uint32_t ldoovsel : 3; /* [2:0] */
186 __IO uint32_t reserved1 : 29;/* [31:3] */
187 } ldoov_bit;
188 };
189
190} pwc_type;
191
196#define PWC ((pwc_type *) PWC_BASE)
197
202void pwc_reset(void);
203void pwc_battery_powered_domain_access(confirm_state new_state);
204void pwc_pvm_level_select(pwc_pvm_voltage_type pvm_voltage);
205void pwc_power_voltage_monitor_enable(confirm_state new_state);
206void pwc_wakeup_pin_enable(uint32_t pin_num, confirm_state new_state);
207void pwc_flag_clear(uint32_t pwc_flag);
208 flag_status pwc_flag_get(uint32_t pwc_flag);
209void pwc_sleep_mode_enter(pwc_sleep_enter_type pwc_sleep_enter);
210void pwc_deep_sleep_mode_enter(pwc_deep_sleep_enter_type pwc_deep_sleep_enter);
211void pwc_voltage_regulate_set(pwc_regulator_type pwc_regulator);
212void pwc_standby_mode_enter(void);
213
226#ifdef __cplusplus
227}
228#endif
229
230#endif
at32f435_437.h
at32f435_437 header file
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f435_437_pwc.c:61
pwc_voltage_regulate_set
void pwc_voltage_regulate_set(pwc_regulator_type pwc_regulator)
regulate low power consumption in the deep sleep mode
Definition: at32f435_437_pwc.c:214
pwc_standby_mode_enter
void pwc_standby_mode_enter(void)
enter pwc standby mode
Definition: at32f435_437_pwc.c:224
pwc_power_voltage_monitor_enable
void pwc_power_voltage_monitor_enable(confirm_state new_state)
enable or disable pwc power voltage monitor (pvm)
Definition: at32f435_437_pwc.c:90
pwc_sleep_mode_enter
void pwc_sleep_mode_enter(pwc_sleep_enter_type pwc_sleep_enter)
enter pwc sleep mode
Definition: at32f435_437_pwc.c:167
pwc_deep_sleep_mode_enter
void pwc_deep_sleep_mode_enter(pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode
Definition: at32f435_437_pwc.c:190
pwc_flag_get
flag_status pwc_flag_get(uint32_t pwc_flag)
get flag of pwc
Definition: at32f435_437_pwc.c:145
pwc_flag_clear
void pwc_flag_clear(uint32_t pwc_flag)
clear flag of pwc
Definition: at32f435_437_pwc.c:128
pwc_pvm_level_select
void pwc_pvm_level_select(pwc_pvm_voltage_type pvm_voltage)
select the voltage threshold detected by the power voltage detector.
Definition: at32f435_437_pwc.c:79
pwc_reset
void pwc_reset(void)
deinitialize the pwc peripheral registers to their default reset values.
Definition: at32f435_437_pwc.c:49
pwc_wakeup_pin_enable
void pwc_wakeup_pin_enable(uint32_t pin_num, confirm_state new_state)
enable or disable pwc standby wakeup pin
Definition: at32f435_437_pwc.c:107
pwc_pvm_voltage_type
pwc_pvm_voltage_type
pwc pvm voltage type
Definition: at32f435_437_pwc.h:85
pwc_regulator_type
pwc_regulator_type
pwc regulator type
Definition: at32f435_437_pwc.h:128
pwc_deep_sleep_enter_type
pwc_deep_sleep_enter_type
pwc deep sleep enter type
Definition: at32f435_437_pwc.h:119
pwc_sleep_enter_type
pwc_sleep_enter_type
pwc sleep enter type
Definition: at32f435_437_pwc.h:110
pwc_ldo_output_voltage_type
pwc_ldo_output_voltage_type
pwc ldo output voltage type
Definition: at32f435_437_pwc.h:99
PWC_PVM_VOLTAGE_2V7
@ PWC_PVM_VOLTAGE_2V7
Definition: at32f435_437_pwc.h:90
PWC_PVM_VOLTAGE_2V3
@ PWC_PVM_VOLTAGE_2V3
Definition: at32f435_437_pwc.h:86
PWC_PVM_VOLTAGE_2V8
@ PWC_PVM_VOLTAGE_2V8
Definition: at32f435_437_pwc.h:91
PWC_PVM_VOLTAGE_2V4
@ PWC_PVM_VOLTAGE_2V4
Definition: at32f435_437_pwc.h:87
PWC_PVM_VOLTAGE_2V5
@ PWC_PVM_VOLTAGE_2V5
Definition: at32f435_437_pwc.h:88
PWC_PVM_VOLTAGE_2V6
@ PWC_PVM_VOLTAGE_2V6
Definition: at32f435_437_pwc.h:89
PWC_PVM_VOLTAGE_2V9
@ PWC_PVM_VOLTAGE_2V9
Definition: at32f435_437_pwc.h:92
PWC_REGULATOR_LOW_POWER
@ PWC_REGULATOR_LOW_POWER
Definition: at32f435_437_pwc.h:130
PWC_REGULATOR_ON
@ PWC_REGULATOR_ON
Definition: at32f435_437_pwc.h:129
PWC_DEEP_SLEEP_ENTER_WFI
@ PWC_DEEP_SLEEP_ENTER_WFI
Definition: at32f435_437_pwc.h:120
PWC_DEEP_SLEEP_ENTER_WFE
@ PWC_DEEP_SLEEP_ENTER_WFE
Definition: at32f435_437_pwc.h:121
PWC_SLEEP_ENTER_WFI
@ PWC_SLEEP_ENTER_WFI
Definition: at32f435_437_pwc.h:111
PWC_SLEEP_ENTER_WFE
@ PWC_SLEEP_ENTER_WFE
Definition: at32f435_437_pwc.h:112
PWC_LDO_OUTPUT_1V2
@ PWC_LDO_OUTPUT_1V2
Definition: at32f435_437_pwc.h:100
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
PWC_LDO_OUTPUT_1V0
@ PWC_LDO_OUTPUT_1V0
Definition: at32f435_437_pwc.h:103
PWC_LDO_OUTPUT_1V1
@ PWC_LDO_OUTPUT_1V1
Definition: at32f435_437_pwc.h:102
pwc_type
type define pwc register all
Definition: at32f435_437_pwc.h:137
pwc_type::bpwen
__IO uint32_t bpwen
Definition: at32f435_437_pwc.h:152
pwc_type::clswef
__IO uint32_t clswef
Definition: at32f435_437_pwc.h:148
pwc_type::pvmof
__IO uint32_t pvmof
Definition: at32f435_437_pwc.h:167
pwc_type::lpsel
__IO uint32_t lpsel
Definition: at32f435_437_pwc.h:147
pwc_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_pwc.h:153
pwc_type::vrsel
__IO uint32_t vrsel
Definition: at32f435_437_pwc.h:146
pwc_type::pvmen
__IO uint32_t pvmen
Definition: at32f435_437_pwc.h:150
pwc_type::ctrl
__IO uint32_t ctrl
Definition: at32f435_437_pwc.h:143
pwc_type::ldoovsel
__IO uint32_t ldoovsel
Definition: at32f435_437_pwc.h:185
pwc_type::ldoov
__IO uint32_t ldoov
Definition: at32f435_437_pwc.h:182
pwc_type::swpen1
__IO uint32_t swpen1
Definition: at32f435_437_pwc.h:169
pwc_type::swpen2
__IO uint32_t swpen2
Definition: at32f435_437_pwc.h:170
pwc_type::swef
__IO uint32_t swef
Definition: at32f435_437_pwc.h:165
pwc_type::clsef
__IO uint32_t clsef
Definition: at32f435_437_pwc.h:149
pwc_type::ctrlsts
__IO uint32_t ctrlsts
Definition: at32f435_437_pwc.h:162
pwc_type::sef
__IO uint32_t sef
Definition: at32f435_437_pwc.h:166
pwc_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_pwc.h:171
pwc_type::pvmsel
__IO uint32_t pvmsel
Definition: at32f435_437_pwc.h:151


AT32F435/437 Firmwary Library: at32f435_437_qspi.c Source File

  • libraries
  • drivers
  • src
at32f435_437_qspi.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef QSPI_MODULE_ENABLED
39
53void qspi_encryption_enable(qspi_type* qspi_x, confirm_state new_state)
54{
55 qspi_x->ctrl_bit.keyen = new_state;
56}
57
70void qspi_sck_mode_set(qspi_type* qspi_x, qspi_clk_mode_type new_mode)
71{
72 qspi_x->ctrl_bit.sckmode = new_mode;
73}
74
93void qspi_clk_division_set(qspi_type* qspi_x, qspi_clk_div_type new_clkdiv)
94{
95 qspi_x->ctrl_bit.clkdiv = new_clkdiv;
96}
97
107void qspi_xip_cache_bypass_set(qspi_type* qspi_x, confirm_state new_state)
108{
109 qspi_x->xip_cmd_w3_bit.bypassc = new_state;
110}
111
121void qspi_interrupt_enable(qspi_type* qspi_x, confirm_state new_state)
122{
123 qspi_x->ctrl2_bit.cmdie = new_state;
124}
125
138 flag_status qspi_flag_get(qspi_type* qspi_x, uint32_t flag)
139{
140 flag_status bit_status = RESET;
141 switch(flag)
142 {
143 case QSPI_RXFIFORDY_FLAG:
144 bit_status = (flag_status)qspi_x->fifosts_bit.rxfifordy;
145 break;
146 case QSPI_TXFIFORDY_FLAG:
147 bit_status = (flag_status)qspi_x->fifosts_bit.txfifordy;
148 break;
149 case QSPI_CMDSTS_FLAG:
150 bit_status = (flag_status)qspi_x->cmdsts_bit.cmdsts;
151 break;
152 default:
153 break;
154 }
155 return bit_status;
156}
157
168void qspi_flag_clear(qspi_type* qspi_x, uint32_t flag)
169{
170 qspi_x->cmdsts = QSPI_CMDSTS_FLAG;
171}
172
186void qspi_dma_rx_threshold_set(qspi_type* qspi_x, qspi_dma_fifo_thod_type new_threshold)
187{
188 qspi_x->ctrl2_bit.rxfifo_thod = new_threshold;
189}
190
204void qspi_dma_tx_threshold_set(qspi_type* qspi_x, qspi_dma_fifo_thod_type new_threshold)
205{
206 qspi_x->ctrl2_bit.txfifo_thod = new_threshold;
207}
208
218void qspi_dma_enable(qspi_type* qspi_x, confirm_state new_state)
219{
220 qspi_x->ctrl2_bit.dmaen = new_state;
221}
222
241void qspi_busy_config(qspi_type* qspi_x, qspi_busy_pos_type busy_pos)
242{
243 qspi_x->ctrl_bit.busy = busy_pos;
244}
245
254void qspi_xip_enable(qspi_type* qspi_x, confirm_state new_state)
255{
256 /* skip if state is no change */
257 if(new_state == (confirm_state)(qspi_x->ctrl_bit.xipsel))
258 {
259 return;
260 }
261
262 /* wait until tx fifo emoty*/
263 while(qspi_x->fifosts_bit.txfifordy == 0);
264
265 /* flush and reset qspi state */
266 qspi_x->ctrl_bit.xiprcmdf = 1;
267
268 /* wait until action is finished */
269 while(qspi_x->ctrl_bit.abort);
270
271 /* set xip mode to new state */
272 qspi_x->ctrl_bit.xipsel = new_state;
273
274 /* wait until abort is not set */
275 while(qspi_x->ctrl_bit.abort);
276
277 /* wait until cache status valid*/
278 if(new_state == TRUE)
279 {
280 while( qspi_x->xip_cmd_w3_bit.csts );
281 }
282}
283
292void qspi_cmd_operation_kick(qspi_type* qspi_x, qspi_cmd_type* qspi_cmd_struct)
293{
294 uint32_t w1_val = 0, w3_val = 0;
295
296 /* config analyse cmd_w0 register */
297 qspi_x->cmd_w0 = (uint32_t)qspi_cmd_struct->address_code;
298
299 /* config analyse cmd_w1 register */
300 w1_val = (uint32_t)qspi_cmd_struct->address_length;
301 w1_val |= (uint32_t)(qspi_cmd_struct->second_dummy_cycle_num << 16);
302 w1_val |= (uint32_t)(qspi_cmd_struct->instruction_length << 24);
303 w1_val |= (uint32_t)(qspi_cmd_struct->pe_mode_enable << 28);
304 qspi_x->cmd_w1 = w1_val;
305
306 /* config analyse cmd_w2 register */
307 qspi_x->cmd_w2 = (uint32_t)qspi_cmd_struct->data_counter;
308
309 /* config analyse cmd_w3 register */
310 w3_val = (uint32_t)(qspi_cmd_struct->write_data_enable << 1);
311 w3_val |= (uint32_t)(qspi_cmd_struct->read_status_enable << 2);
312 w3_val |= (uint32_t)(qspi_cmd_struct->read_status_config << 3);
313 w3_val |= (uint32_t)(qspi_cmd_struct->operation_mode << 5);
314 w3_val |= (uint32_t)(qspi_cmd_struct->pe_mode_operate_code << 16);
315 w3_val |= (uint32_t)(qspi_cmd_struct->instruction_code << 24);
316 qspi_x->cmd_w3 = w3_val;
317}
318
327void qspi_xip_init(qspi_type* qspi_x, qspi_xip_type* xip_init_struct)
328{
329 uint32_t xc0_val = 0, xc1_val = 0, xc2_val = 0;
330 /* config analyse xip_cmd_w0 register */
331 xc0_val = (uint32_t)xip_init_struct->read_second_dummy_cycle_num;
332 xc0_val |= (uint32_t)(xip_init_struct->read_operation_mode << 8);
333 xc0_val |= (uint32_t)(xip_init_struct->read_address_length << 11);
334 xc0_val |= (uint32_t)(xip_init_struct->read_instruction_code << 12);
335 qspi_x->xip_cmd_w0 = xc0_val;
336
337 /* config analyse xip_cmd_w1 register */
338 xc1_val = (uint32_t)xip_init_struct->write_second_dummy_cycle_num;
339 xc1_val |= (uint32_t)(xip_init_struct->write_operation_mode << 8);
340 xc1_val |= (uint32_t)(xip_init_struct->write_address_length << 11);
341 xc1_val |= (uint32_t)(xip_init_struct->write_instruction_code << 12);
342 qspi_x->xip_cmd_w1 = xc1_val;
343
344 /* config analyse xip_cmd_w2 register */
345 xc2_val = (uint32_t)xip_init_struct->read_data_counter;
346 xc2_val |= (uint32_t)(xip_init_struct->read_time_counter << 8);
347 xc2_val |= (uint32_t)(xip_init_struct->read_select_mode << 15);
348 xc2_val |= (uint32_t)(xip_init_struct->write_data_counter << 16);
349 xc2_val |= (uint32_t)(xip_init_struct->write_time_counter << 24);
350 xc2_val |= (uint32_t)(xip_init_struct->write_select_mode << 31);
351 qspi_x->xip_cmd_w2 = xc2_val;
352}
353
359uint8_t qspi_byte_read(qspi_type* qspi_x)
360{
361 return qspi_x->dt_u8;
362}
363
369uint16_t qspi_half_word_read(qspi_type* qspi_x)
370{
371 return qspi_x->dt_u16;
372}
373
379uint32_t qspi_word_read(qspi_type* qspi_x)
380{
381 return qspi_x->dt;
382}
383
390void qspi_byte_write(qspi_type* qspi_x, uint8_t value)
391{
392 qspi_x->dt_u8 = value;
393}
394
401void qspi_half_word_write(qspi_type* qspi_x, uint16_t value)
402{
403 qspi_x->dt_u16 = value;
404}
405
412void qspi_word_write(qspi_type* qspi_x, uint32_t value)
413{
414 qspi_x->dt = value;
415}
416
421#endif
422
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
qspi_dma_fifo_thod_type
qspi_dma_fifo_thod_type
qspi dma tx/rx fifo threshold type
Definition: at32f435_437_qspi.h:179
qspi_busy_pos_type
qspi_busy_pos_type
qspi busy bit offset position in status register type
Definition: at32f435_437_qspi.h:86
qspi_clk_mode_type
qspi_clk_mode_type
qspi sckout mode type
Definition: at32f435_437_qspi.h:170
qspi_clk_div_type
qspi_clk_div_type
qspi clock division type
Definition: at32f435_437_qspi.h:124
QSPI_CMDSTS_FLAG
#define QSPI_CMDSTS_FLAG
Definition: at32f435_437_qspi.h:52
QSPI_RXFIFORDY_FLAG
#define QSPI_RXFIFORDY_FLAG
Definition: at32f435_437_qspi.h:53
QSPI_TXFIFORDY_FLAG
#define QSPI_TXFIFORDY_FLAG
Definition: at32f435_437_qspi.h:54
qspi_flag_clear
void qspi_flag_clear(qspi_type *qspi_x, uint32_t flag)
clear flags
Definition: at32f435_437_qspi.c:168
qspi_sck_mode_set
void qspi_sck_mode_set(qspi_type *qspi_x, qspi_clk_mode_type new_mode)
set qspi sck mode.
Definition: at32f435_437_qspi.c:70
qspi_byte_read
uint8_t qspi_byte_read(qspi_type *qspi_x)
read one byte from qspi device in command mode
Definition: at32f435_437_qspi.c:359
qspi_half_word_write
void qspi_half_word_write(qspi_type *qspi_x, uint16_t value)
write one half-word to qspi device in command mode
Definition: at32f435_437_qspi.c:401
qspi_word_read
uint32_t qspi_word_read(qspi_type *qspi_x)
read one word from qspi device in command mode
Definition: at32f435_437_qspi.c:379
qspi_dma_enable
void qspi_dma_enable(qspi_type *qspi_x, confirm_state new_state)
enable/disable dma transfer
Definition: at32f435_437_qspi.c:218
qspi_dma_tx_threshold_set
void qspi_dma_tx_threshold_set(qspi_type *qspi_x, qspi_dma_fifo_thod_type new_threshold)
set dma threshold for dma tx
Definition: at32f435_437_qspi.c:204
qspi_word_write
void qspi_word_write(qspi_type *qspi_x, uint32_t value)
write one word to qspi device in command mode
Definition: at32f435_437_qspi.c:412
qspi_interrupt_enable
void qspi_interrupt_enable(qspi_type *qspi_x, confirm_state new_state)
enable/disable interrupt when command is completed
Definition: at32f435_437_qspi.c:121
qspi_dma_rx_threshold_set
void qspi_dma_rx_threshold_set(qspi_type *qspi_x, qspi_dma_fifo_thod_type new_threshold)
set dma threshold for dma rx
Definition: at32f435_437_qspi.c:186
qspi_xip_enable
void qspi_xip_enable(qspi_type *qspi_x, confirm_state new_state)
enable xip mode or command-port mode.
Definition: at32f435_437_qspi.c:254
qspi_busy_config
void qspi_busy_config(qspi_type *qspi_x, qspi_busy_pos_type busy_pos)
set wip position in status register of flash
Definition: at32f435_437_qspi.c:241
qspi_byte_write
void qspi_byte_write(qspi_type *qspi_x, uint8_t value)
write one byte to qspi device in command mode
Definition: at32f435_437_qspi.c:390
qspi_cmd_operation_kick
void qspi_cmd_operation_kick(qspi_type *qspi_x, qspi_cmd_type *qspi_cmd_struct)
set command-port and qspi_x will start to work
Definition: at32f435_437_qspi.c:292
qspi_xip_init
void qspi_xip_init(qspi_type *qspi_x, qspi_xip_type *xip_init_struct)
initial xip mode for qspi_x
Definition: at32f435_437_qspi.c:327
qspi_flag_get
flag_status qspi_flag_get(qspi_type *qspi_x, uint32_t flag)
get status flags.
Definition: at32f435_437_qspi.c:138
qspi_encryption_enable
void qspi_encryption_enable(qspi_type *qspi_x, confirm_state new_state)
enable/disable encryption for qspi.
Definition: at32f435_437_qspi.c:53
qspi_xip_cache_bypass_set
void qspi_xip_cache_bypass_set(qspi_type *qspi_x, confirm_state new_state)
enable/disable cache in xip mode
Definition: at32f435_437_qspi.c:107
qspi_half_word_read
uint16_t qspi_half_word_read(qspi_type *qspi_x)
read one half-word from qspi device in command mode
Definition: at32f435_437_qspi.c:369
qspi_clk_division_set
void qspi_clk_division_set(qspi_type *qspi_x, qspi_clk_div_type new_clkdiv)
set qspi clock division
Definition: at32f435_437_qspi.c:93
qspi_cmd_type
qspi cmd type
Definition: at32f435_437_qspi.h:189
qspi_cmd_type::instruction_length
qspi_cmd_inslen_type instruction_length
Definition: at32f435_437_qspi.h:193
qspi_cmd_type::write_data_enable
confirm_state write_data_enable
Definition: at32f435_437_qspi.h:201
qspi_cmd_type::operation_mode
qspi_operate_mode_type operation_mode
Definition: at32f435_437_qspi.h:198
qspi_cmd_type::instruction_code
uint8_t instruction_code
Definition: at32f435_437_qspi.h:192
qspi_cmd_type::read_status_config
qspi_read_status_conf_type read_status_config
Definition: at32f435_437_qspi.h:199
qspi_cmd_type::pe_mode_enable
confirm_state pe_mode_enable
Definition: at32f435_437_qspi.h:190
qspi_cmd_type::read_status_enable
confirm_state read_status_enable
Definition: at32f435_437_qspi.h:200
qspi_cmd_type::data_counter
uint32_t data_counter
Definition: at32f435_437_qspi.h:196
qspi_cmd_type::address_code
uint32_t address_code
Definition: at32f435_437_qspi.h:194
qspi_cmd_type::pe_mode_operate_code
uint8_t pe_mode_operate_code
Definition: at32f435_437_qspi.h:191
qspi_cmd_type::address_length
qspi_cmd_adrlen_type address_length
Definition: at32f435_437_qspi.h:195
qspi_cmd_type::second_dummy_cycle_num
uint8_t second_dummy_cycle_num
Definition: at32f435_437_qspi.h:197
qspi_type
type define qspi register all
Definition: at32f435_437_qspi.h:229
qspi_type::xip_cmd_w1
__IO uint32_t xip_cmd_w1
Definition: at32f435_437_qspi.h:425
qspi_type::xiprcmdf
__IO uint32_t xiprcmdf
Definition: at32f435_437_qspi.h:309
qspi_type::clkdiv
__IO uint32_t clkdiv
Definition: at32f435_437_qspi.h:301
qspi_type::dt
__IO uint32_t dt
Definition: at32f435_437_qspi.h:499
qspi_type::ctrl2_bit
struct qspi_type::@918::@945 ctrl2_bit
qspi_type::dmaen
__IO uint32_t dmaen
Definition: at32f435_437_qspi.h:356
qspi_type::cmd_w0
__IO uint32_t cmd_w0
Definition: at32f435_437_qspi.h:235
qspi_type::keyen
__IO uint32_t keyen
Definition: at32f435_437_qspi.h:311
qspi_type::xip_cmd_w2
__IO uint32_t xip_cmd_w2
Definition: at32f435_437_qspi.h:441
qspi_type::fifosts_bit
struct qspi_type::@916::@944 fifosts_bit
qspi_type::txfifordy
__IO uint32_t txfifordy
Definition: at32f435_437_qspi.h:337
qspi_type::xipsel
__IO uint32_t xipsel
Definition: at32f435_437_qspi.h:310
qspi_type::rxfifordy
__IO uint32_t rxfifordy
Definition: at32f435_437_qspi.h:338
qspi_type::cmdsts
__IO uint32_t cmdsts
Definition: at32f435_437_qspi.h:371
qspi_type::cmd_w2
__IO uint32_t cmd_w2
Definition: at32f435_437_qspi.h:266
qspi_type::csts
__IO uint32_t csts
Definition: at32f435_437_qspi.h:465
qspi_type::busy
__IO uint32_t busy
Definition: at32f435_437_qspi.h:308
qspi_type::xip_cmd_w0
__IO uint32_t xip_cmd_w0
Definition: at32f435_437_qspi.h:409
qspi_type::cmdsts_bit
struct qspi_type::@920::@946 cmdsts_bit
qspi_type::rxfifo_thod
__IO uint32_t rxfifo_thod
Definition: at32f435_437_qspi.h:361
qspi_type::dt_u16
__IO uint16_t dt_u16
Definition: at32f435_437_qspi.h:498
qspi_type::xip_cmd_w3_bit
struct qspi_type::@932::@952 xip_cmd_w3_bit
qspi_type::cmdie
__IO uint32_t cmdie
Definition: at32f435_437_qspi.h:357
qspi_type::sckmode
__IO uint32_t sckmode
Definition: at32f435_437_qspi.h:303
qspi_type::cmd_w1
__IO uint32_t cmd_w1
Definition: at32f435_437_qspi.h:248
qspi_type::abort
__IO uint32_t abort
Definition: at32f435_437_qspi.h:306
qspi_type::ctrl_bit
struct qspi_type::@912::@942 ctrl_bit
qspi_type::txfifo_thod
__IO uint32_t txfifo_thod
Definition: at32f435_437_qspi.h:359
qspi_type::cmd_w3
__IO uint32_t cmd_w3
Definition: at32f435_437_qspi.h:278
qspi_type::bypassc
__IO uint32_t bypassc
Definition: at32f435_437_qspi.h:463
qspi_type::dt_u8
__IO uint8_t dt_u8
Definition: at32f435_437_qspi.h:497
qspi_xip_type
qspi xip type
Definition: at32f435_437_qspi.h:208
qspi_xip_type::write_operation_mode
qspi_operate_mode_type write_operation_mode
Definition: at32f435_437_qspi.h:215
qspi_xip_type::read_second_dummy_cycle_num
uint8_t read_second_dummy_cycle_num
Definition: at32f435_437_qspi.h:212
qspi_xip_type::write_address_length
qspi_xip_addrlen_type write_address_length
Definition: at32f435_437_qspi.h:214
qspi_xip_type::write_instruction_code
uint8_t write_instruction_code
Definition: at32f435_437_qspi.h:213
qspi_xip_type::write_data_counter
uint8_t write_data_counter
Definition: at32f435_437_qspi.h:219
qspi_xip_type::read_select_mode
qspi_xip_read_sel_type read_select_mode
Definition: at32f435_437_qspi.h:220
qspi_xip_type::write_time_counter
uint8_t write_time_counter
Definition: at32f435_437_qspi.h:218
qspi_xip_type::read_operation_mode
qspi_operate_mode_type read_operation_mode
Definition: at32f435_437_qspi.h:211
qspi_xip_type::read_address_length
qspi_xip_addrlen_type read_address_length
Definition: at32f435_437_qspi.h:210
qspi_xip_type::read_data_counter
uint8_t read_data_counter
Definition: at32f435_437_qspi.h:222
qspi_xip_type::read_time_counter
uint8_t read_time_counter
Definition: at32f435_437_qspi.h:221
qspi_xip_type::write_select_mode
qspi_xip_write_sel_type write_select_mode
Definition: at32f435_437_qspi.h:217
qspi_xip_type::write_second_dummy_cycle_num
uint8_t write_second_dummy_cycle_num
Definition: at32f435_437_qspi.h:216
qspi_xip_type::read_instruction_code
uint8_t read_instruction_code
Definition: at32f435_437_qspi.h:209
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_qspi.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_qspi.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_QSPI_H
29#define __AT32F435_437_QSPI_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
52#define QSPI_CMDSTS_FLAG ((uint32_t)0x00000001)
53#define QSPI_RXFIFORDY_FLAG ((uint32_t)0x00000002)
54#define QSPI_TXFIFORDY_FLAG ((uint32_t)0x00000004)
67typedef enum
68{
69 QSPI_XIPR_SEL_MODED = 0x00,
70 QSPI_XIPR_SEL_MODET = 0x01
71} qspi_xip_read_sel_type;
72
76typedef enum
77{
78 QSPI_XIPW_SEL_MODED = 0x00,
79 QSPI_XIPW_SEL_MODET = 0x01
80} qspi_xip_write_sel_type;
81
85typedef enum
86{
87 QSPI_BUSY_OFFSET_0 = 0x00,
88 QSPI_BUSY_OFFSET_1 = 0x01,
89 QSPI_BUSY_OFFSET_2 = 0x02,
90 QSPI_BUSY_OFFSET_3 = 0x03,
91 QSPI_BUSY_OFFSET_4 = 0x04,
92 QSPI_BUSY_OFFSET_5 = 0x05,
93 QSPI_BUSY_OFFSET_6 = 0x06,
94 QSPI_BUSY_OFFSET_7 = 0x07
95} qspi_busy_pos_type;
96
100typedef enum
101{
102 QSPI_RSTSC_HW_AUTO = 0x00,
103 QSPI_RSTSC_SW_ONCE = 0x01
104} qspi_read_status_conf_type;
105
109typedef enum
110{
111 QSPI_OPERATE_MODE_111 = 0x00,
112 QSPI_OPERATE_MODE_112 = 0x01,
113 QSPI_OPERATE_MODE_114 = 0x02,
114 QSPI_OPERATE_MODE_122 = 0x03,
115 QSPI_OPERATE_MODE_144 = 0x04,
116 QSPI_OPERATE_MODE_222 = 0x05,
117 QSPI_OPERATE_MODE_444 = 0x06
118} qspi_operate_mode_type;
119
123typedef enum
124{
125 QSPI_CLK_DIV_2 = 0x00,
126 QSPI_CLK_DIV_4 = 0x01,
127 QSPI_CLK_DIV_6 = 0x02,
128 QSPI_CLK_DIV_8 = 0x03,
129 QSPI_CLK_DIV_3 = 0x04,
130 QSPI_CLK_DIV_5 = 0x05,
131 QSPI_CLK_DIV_10 = 0x06,
132 QSPI_CLK_DIV_12 = 0x07
133} qspi_clk_div_type;
134
138typedef enum
139{
140 QSPI_CMD_ADRLEN_0_BYTE = 0x00,
141 QSPI_CMD_ADRLEN_1_BYTE = 0x01,
142 QSPI_CMD_ADRLEN_2_BYTE = 0x02,
143 QSPI_CMD_ADRLEN_3_BYTE = 0x03,
144 QSPI_CMD_ADRLEN_4_BYTE = 0x04
145} qspi_cmd_adrlen_type;
146
150typedef enum
151{
152 QSPI_CMD_INSLEN_0_BYTE = 0x00,
153 QSPI_CMD_INSLEN_1_BYTE = 0x01,
154 QSPI_CMD_INSLEN_2_BYTE = 0x02
155} qspi_cmd_inslen_type;
156
160typedef enum
161{
162 QSPI_XIP_ADDRLEN_3_BYTE = 0x00,
163 QSPI_XIP_ADDRLEN_4_BYTE = 0x01
164} qspi_xip_addrlen_type;
165
169typedef enum
170{
171 QSPI_SCK_MODE_0 = 0x00,
172 QSPI_SCK_MODE_3 = 0x01
173} qspi_clk_mode_type;
174
178typedef enum
179{
180 QSPI_DMA_FIFO_THOD_WORD08 = 0x00,
181 QSPI_DMA_FIFO_THOD_WORD16 = 0x01,
182 QSPI_DMA_FIFO_THOD_WORD32 = 0x02
183} qspi_dma_fifo_thod_type;
184
188typedef struct
189{
190 confirm_state pe_mode_enable;
191 uint8_t pe_mode_operate_code;
192 uint8_t instruction_code;
193 qspi_cmd_inslen_type instruction_length;
194 uint32_t address_code;
195 qspi_cmd_adrlen_type address_length;
196 uint32_t data_counter;
197 uint8_t second_dummy_cycle_num;
198 qspi_operate_mode_type operation_mode;
199 qspi_read_status_conf_type read_status_config;
200 confirm_state read_status_enable;
201 confirm_state write_data_enable;
202} qspi_cmd_type;
203
207typedef struct
208{
209 uint8_t read_instruction_code;
210 qspi_xip_addrlen_type read_address_length;
211 qspi_operate_mode_type read_operation_mode;
212 uint8_t read_second_dummy_cycle_num;
213 uint8_t write_instruction_code;
214 qspi_xip_addrlen_type write_address_length;
215 qspi_operate_mode_type write_operation_mode;
216 uint8_t write_second_dummy_cycle_num;
217 qspi_xip_write_sel_type write_select_mode;
218 uint8_t write_time_counter;
219 uint8_t write_data_counter;
220 qspi_xip_read_sel_type read_select_mode;
221 uint8_t read_time_counter;
222 uint8_t read_data_counter;
223} qspi_xip_type;
224
228typedef struct
229{
233 union
234 {
235 __IO uint32_t cmd_w0;
236 struct
237 {
238
239 __IO uint32_t spiadr : 32;/* [31:0] */
240 } cmd_w0_bit;
241 };
242
246 union
247 {
248 __IO uint32_t cmd_w1;
249 struct
250 {
251 __IO uint32_t adrlen : 3; /* [2:0] */
252 __IO uint32_t reserved1 : 13;/* [15:3] */
253 __IO uint32_t dum2 : 8; /* [23:16] */
254 __IO uint32_t inslen : 2; /* [25:24] */
255 __IO uint32_t reserved2 : 2; /* [27:26] */
256 __IO uint32_t pemen : 1; /* [28] */
257 __IO uint32_t reserved3 : 3; /* [31:29] */
258 } cmd_w1_bit;
259 };
260
264 union
265 {
266 __IO uint32_t cmd_w2;
267 struct
268 {
269 __IO uint32_t dcnt : 32;/* [31:0] */
270 } cmd_w2_bit;
271 };
272
276 union
277 {
278 __IO uint32_t cmd_w3;
279 struct
280 {
281 __IO uint32_t reserved1 : 1; /* [0] */
282 __IO uint32_t wen : 1; /* [1] */
283 __IO uint32_t rstsen : 1; /* [2] */
284 __IO uint32_t rstsc : 1; /* [3] */
285 __IO uint32_t reserved2 : 1; /* [4] */
286 __IO uint32_t opmode : 3; /* [7:5] */
287 __IO uint32_t reserved3 : 8; /* [15:8] */
288 __IO uint32_t pemopc : 8; /* [23:16] */
289 __IO uint32_t insc : 8; /* [31:24] */
290 } cmd_w3_bit;
291 };
292
296 union
297 {
298 __IO uint32_t ctrl;
299 struct
300 {
301 __IO uint32_t clkdiv : 3; /* [2:0] */
302 __IO uint32_t reserved1 : 1; /* [3] */
303 __IO uint32_t sckmode : 1; /* [4] */
304 __IO uint32_t reserved2 : 2; /* [6:5] */
305 __IO uint32_t xipidle : 1; /* [7] */
306 __IO uint32_t abort : 1; /* [8] */
307 __IO uint32_t reserved3 : 7; /* [15:9] */
308 __IO uint32_t busy : 3; /* [18:16] */
309 __IO uint32_t xiprcmdf : 1; /* [19] */
310 __IO uint32_t xipsel : 1; /* [20] */
311 __IO uint32_t keyen : 1; /* [21] */
312 __IO uint32_t reserved4 : 10;/* [31:22] */
313 } ctrl_bit;
314 };
315
319 union
320 {
321 __IO uint32_t actr;
322 struct
323 {
324 __IO uint32_t csdly : 4; /* [3:0] */
325 __IO uint32_t reserved1 : 28;/* [31:4] */
326 } actr_bit;
327 };
328
332 union
333 {
334 __IO uint32_t fifosts;
335 struct
336 {
337 __IO uint32_t txfifordy : 1; /* [0] */
338 __IO uint32_t rxfifordy : 1; /* [1] */
339 __IO uint32_t reserved1 : 30;/* [31:2] */
340 } fifosts_bit;
341 };
342
346 __IO uint32_t reserved1;
347
351 union
352 {
353 __IO uint32_t ctrl2;
354 struct
355 {
356 __IO uint32_t dmaen : 1; /* [0] */
357 __IO uint32_t cmdie : 1; /* [1] */
358 __IO uint32_t reserved1 : 6; /* [7:2] */
359 __IO uint32_t txfifo_thod : 2; /* [9:8] */
360 __IO uint32_t reserved2 : 2; /* [11:10] */
361 __IO uint32_t rxfifo_thod : 2; /* [13:12] */
362 __IO uint32_t reserved3 : 18;/* [31:14] */
363 } ctrl2_bit;
364 };
365
369 union
370 {
371 __IO uint32_t cmdsts;
372 struct
373 {
374 __IO uint32_t cmdsts : 1; /* [0] */
375 __IO uint32_t reserved1 : 31;/* [31:1] */
376 } cmdsts_bit;
377 };
378
382 union
383 {
384 __IO uint32_t rsts;
385 struct
386 {
387 __IO uint32_t spists : 8; /* [7:0] */
388 __IO uint32_t reserved1 : 24;/* [31:8] */
389 } rsts_bit;
390 };
391
395 union
396 {
397 __IO uint32_t fsize;
398 struct
399 {
400 __IO uint32_t spifsize : 32;/* [31:0] */
401 } fsize_bit;
402 };
403
407 union
408 {
409 __IO uint32_t xip_cmd_w0;
410 struct
411 {
412 __IO uint32_t xipr_dum2 : 8; /* [7:0] */
413 __IO uint32_t xipr_opmode : 3; /* [10:8] */
414 __IO uint32_t xipr_adrlen : 1; /* [11] */
415 __IO uint32_t xipr_insc : 8; /* [19:12] */
416 __IO uint32_t reserved1 : 12;/* [31:20] */
417 } xip_cmd_w0_bit;
418 };
419
423 union
424 {
425 __IO uint32_t xip_cmd_w1;
426 struct
427 {
428 __IO uint32_t xipr_dum2 : 8; /* [7:0] */
429 __IO uint32_t xipr_opmode : 3; /* [10:8] */
430 __IO uint32_t xipr_adrlen : 1; /* [11] */
431 __IO uint32_t xipr_insc : 8; /* [19:12] */
432 __IO uint32_t reserved1 : 12;/* [31:20] */
433 } xip_cmd_w1_bit;
434 };
435
439 union
440 {
441 __IO uint32_t xip_cmd_w2;
442 struct
443 {
444 __IO uint32_t xipr_dcnt : 6; /* [5:0] */
445 __IO uint32_t reserved1 : 2; /* [7:6] */
446 __IO uint32_t xipr_tcnt : 7; /* [14:8] */
447 __IO uint32_t xipr_sel : 1; /* [15] */
448 __IO uint32_t xipw_dcnt : 6; /* [21:16] */
449 __IO uint32_t reserved2 : 2; /* [23:22] */
450 __IO uint32_t xipw_tcnt : 7; /* [30:24] */
451 __IO uint32_t xipw_sel : 1; /* [31] */
452 } xip_cmd_w2_bit;
453 };
454
458 union
459 {
460 __IO uint32_t xip_cmd_w3;
461 struct
462 {
463 __IO uint32_t bypassc : 1; /* [0] */
464 __IO uint32_t reserved1 : 2; /* [2:1] */
465 __IO uint32_t csts : 1; /* [3] */
466 __IO uint32_t reserved2 : 28;/* [31:4] */
467 } xip_cmd_w3_bit;
468 };
469
473 __IO uint32_t reserved2[4];
474
478 union
479 {
480 __IO uint32_t rev;
481 struct
482 {
483 __IO uint32_t rev : 32;/* [31:0] */
484 } rev_bit;
485 };
486
490 __IO uint32_t reserved3[43];
491
495 union
496 {
497 __IO uint8_t dt_u8;
498 __IO uint16_t dt_u16;
499 __IO uint32_t dt;
500 struct
501 {
502 __IO uint32_t dt : 32;/* [31:0] */
503 } dt_bit;
504 };
505
506} qspi_type;
507
512#define QSPI1 ((qspi_type*)QSPI1_REG_BASE)
513#define QSPI2 ((qspi_type*)QSPI2_REG_BASE)
514
519void qspi_encryption_enable(qspi_type* qspi_x, confirm_state new_state);
520void qspi_sck_mode_set(qspi_type* qspi_x, qspi_clk_mode_type new_mode);
521void qspi_clk_division_set(qspi_type* qspi_x, qspi_clk_div_type new_clkdiv);
522void qspi_xip_cache_bypass_set(qspi_type* qspi_x, confirm_state new_state);
523void qspi_interrupt_enable(qspi_type* qspi_x, confirm_state new_state);
524 flag_status qspi_flag_get(qspi_type* qspi_x, uint32_t flag);
525void qspi_flag_clear(qspi_type* qspi_x, uint32_t flag);
526void qspi_dma_rx_threshold_set(qspi_type* qspi_x, qspi_dma_fifo_thod_type new_threshold);
527void qspi_dma_tx_threshold_set(qspi_type* qspi_x, qspi_dma_fifo_thod_type new_threshold);
528void qspi_dma_enable(qspi_type* qspi_x, confirm_state new_state);
529void qspi_busy_config(qspi_type* qspi_x, qspi_busy_pos_type busy_pos);
530void qspi_xip_enable(qspi_type* qspi_x, confirm_state new_state);
531void qspi_cmd_operation_kick(qspi_type* qspi_x, qspi_cmd_type* qspi_cmd_struct);
532void qspi_xip_init(qspi_type* qspi_x, qspi_xip_type* xip_init_struct);
533uint8_t qspi_byte_read(qspi_type* qspi_x);
534uint16_t qspi_half_word_read(qspi_type* qspi_x);
535uint32_t qspi_word_read(qspi_type* qspi_x);
536void qspi_word_write(qspi_type* qspi_x, uint32_t value);
537void qspi_half_word_write(qspi_type* qspi_x, uint16_t value);
538void qspi_byte_write(qspi_type* qspi_x, uint8_t value);
551#ifdef __cplusplus
552}
553#endif
554
555#endif
at32f435_437.h
at32f435_437 header file
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
qspi_flag_clear
void qspi_flag_clear(qspi_type *qspi_x, uint32_t flag)
clear flags
Definition: at32f435_437_qspi.c:168
qspi_sck_mode_set
void qspi_sck_mode_set(qspi_type *qspi_x, qspi_clk_mode_type new_mode)
set qspi sck mode.
Definition: at32f435_437_qspi.c:70
qspi_byte_read
uint8_t qspi_byte_read(qspi_type *qspi_x)
read one byte from qspi device in command mode
Definition: at32f435_437_qspi.c:359
qspi_half_word_write
void qspi_half_word_write(qspi_type *qspi_x, uint16_t value)
write one half-word to qspi device in command mode
Definition: at32f435_437_qspi.c:401
qspi_word_read
uint32_t qspi_word_read(qspi_type *qspi_x)
read one word from qspi device in command mode
Definition: at32f435_437_qspi.c:379
qspi_dma_enable
void qspi_dma_enable(qspi_type *qspi_x, confirm_state new_state)
enable/disable dma transfer
Definition: at32f435_437_qspi.c:218
qspi_dma_tx_threshold_set
void qspi_dma_tx_threshold_set(qspi_type *qspi_x, qspi_dma_fifo_thod_type new_threshold)
set dma threshold for dma tx
Definition: at32f435_437_qspi.c:204
qspi_word_write
void qspi_word_write(qspi_type *qspi_x, uint32_t value)
write one word to qspi device in command mode
Definition: at32f435_437_qspi.c:412
qspi_interrupt_enable
void qspi_interrupt_enable(qspi_type *qspi_x, confirm_state new_state)
enable/disable interrupt when command is completed
Definition: at32f435_437_qspi.c:121
qspi_dma_rx_threshold_set
void qspi_dma_rx_threshold_set(qspi_type *qspi_x, qspi_dma_fifo_thod_type new_threshold)
set dma threshold for dma rx
Definition: at32f435_437_qspi.c:186
qspi_xip_enable
void qspi_xip_enable(qspi_type *qspi_x, confirm_state new_state)
enable xip mode or command-port mode.
Definition: at32f435_437_qspi.c:254
qspi_busy_config
void qspi_busy_config(qspi_type *qspi_x, qspi_busy_pos_type busy_pos)
set wip position in status register of flash
Definition: at32f435_437_qspi.c:241
qspi_byte_write
void qspi_byte_write(qspi_type *qspi_x, uint8_t value)
write one byte to qspi device in command mode
Definition: at32f435_437_qspi.c:390
qspi_cmd_operation_kick
void qspi_cmd_operation_kick(qspi_type *qspi_x, qspi_cmd_type *qspi_cmd_struct)
set command-port and qspi_x will start to work
Definition: at32f435_437_qspi.c:292
qspi_xip_init
void qspi_xip_init(qspi_type *qspi_x, qspi_xip_type *xip_init_struct)
initial xip mode for qspi_x
Definition: at32f435_437_qspi.c:327
qspi_flag_get
flag_status qspi_flag_get(qspi_type *qspi_x, uint32_t flag)
get status flags.
Definition: at32f435_437_qspi.c:138
qspi_encryption_enable
void qspi_encryption_enable(qspi_type *qspi_x, confirm_state new_state)
enable/disable encryption for qspi.
Definition: at32f435_437_qspi.c:53
qspi_xip_cache_bypass_set
void qspi_xip_cache_bypass_set(qspi_type *qspi_x, confirm_state new_state)
enable/disable cache in xip mode
Definition: at32f435_437_qspi.c:107
qspi_half_word_read
uint16_t qspi_half_word_read(qspi_type *qspi_x)
read one half-word from qspi device in command mode
Definition: at32f435_437_qspi.c:369
qspi_clk_division_set
void qspi_clk_division_set(qspi_type *qspi_x, qspi_clk_div_type new_clkdiv)
set qspi clock division
Definition: at32f435_437_qspi.c:93
qspi_read_status_conf_type
qspi_read_status_conf_type
qspi read status configure type
Definition: at32f435_437_qspi.h:101
qspi_cmd_inslen_type
qspi_cmd_inslen_type
qspi command port instruction length type
Definition: at32f435_437_qspi.h:151
qspi_xip_addrlen_type
qspi_xip_addrlen_type
qspi xip r/w address length type
Definition: at32f435_437_qspi.h:161
qspi_dma_fifo_thod_type
qspi_dma_fifo_thod_type
qspi dma tx/rx fifo threshold type
Definition: at32f435_437_qspi.h:179
qspi_busy_pos_type
qspi_busy_pos_type
qspi busy bit offset position in status register type
Definition: at32f435_437_qspi.h:86
qspi_clk_mode_type
qspi_clk_mode_type
qspi sckout mode type
Definition: at32f435_437_qspi.h:170
qspi_operate_mode_type
qspi_operate_mode_type
qspi operate mode type
Definition: at32f435_437_qspi.h:110
qspi_clk_div_type
qspi_clk_div_type
qspi clock division type
Definition: at32f435_437_qspi.h:124
qspi_cmd_adrlen_type
qspi_cmd_adrlen_type
qspi command port address length type
Definition: at32f435_437_qspi.h:139
qspi_xip_read_sel_type
qspi_xip_read_sel_type
qspi xip read access mode type
Definition: at32f435_437_qspi.h:68
qspi_xip_write_sel_type
qspi_xip_write_sel_type
qspi xip write access mode type
Definition: at32f435_437_qspi.h:77
QSPI_RSTSC_SW_ONCE
@ QSPI_RSTSC_SW_ONCE
Definition: at32f435_437_qspi.h:103
QSPI_RSTSC_HW_AUTO
@ QSPI_RSTSC_HW_AUTO
Definition: at32f435_437_qspi.h:102
QSPI_CMD_INSLEN_1_BYTE
@ QSPI_CMD_INSLEN_1_BYTE
Definition: at32f435_437_qspi.h:153
QSPI_CMD_INSLEN_0_BYTE
@ QSPI_CMD_INSLEN_0_BYTE
Definition: at32f435_437_qspi.h:152
QSPI_CMD_INSLEN_2_BYTE
@ QSPI_CMD_INSLEN_2_BYTE
Definition: at32f435_437_qspi.h:154
QSPI_XIP_ADDRLEN_4_BYTE
@ QSPI_XIP_ADDRLEN_4_BYTE
Definition: at32f435_437_qspi.h:163
QSPI_XIP_ADDRLEN_3_BYTE
@ QSPI_XIP_ADDRLEN_3_BYTE
Definition: at32f435_437_qspi.h:162
QSPI_DMA_FIFO_THOD_WORD16
@ QSPI_DMA_FIFO_THOD_WORD16
Definition: at32f435_437_qspi.h:181
QSPI_DMA_FIFO_THOD_WORD32
@ QSPI_DMA_FIFO_THOD_WORD32
Definition: at32f435_437_qspi.h:182
QSPI_DMA_FIFO_THOD_WORD08
@ QSPI_DMA_FIFO_THOD_WORD08
Definition: at32f435_437_qspi.h:180
QSPI_BUSY_OFFSET_4
@ QSPI_BUSY_OFFSET_4
Definition: at32f435_437_qspi.h:91
QSPI_BUSY_OFFSET_6
@ QSPI_BUSY_OFFSET_6
Definition: at32f435_437_qspi.h:93
QSPI_BUSY_OFFSET_3
@ QSPI_BUSY_OFFSET_3
Definition: at32f435_437_qspi.h:90
QSPI_BUSY_OFFSET_5
@ QSPI_BUSY_OFFSET_5
Definition: at32f435_437_qspi.h:92
QSPI_BUSY_OFFSET_0
@ QSPI_BUSY_OFFSET_0
Definition: at32f435_437_qspi.h:87
QSPI_BUSY_OFFSET_1
@ QSPI_BUSY_OFFSET_1
Definition: at32f435_437_qspi.h:88
QSPI_BUSY_OFFSET_2
@ QSPI_BUSY_OFFSET_2
Definition: at32f435_437_qspi.h:89
QSPI_BUSY_OFFSET_7
@ QSPI_BUSY_OFFSET_7
Definition: at32f435_437_qspi.h:94
QSPI_SCK_MODE_3
@ QSPI_SCK_MODE_3
Definition: at32f435_437_qspi.h:172
QSPI_SCK_MODE_0
@ QSPI_SCK_MODE_0
Definition: at32f435_437_qspi.h:171
QSPI_OPERATE_MODE_122
@ QSPI_OPERATE_MODE_122
Definition: at32f435_437_qspi.h:114
QSPI_OPERATE_MODE_144
@ QSPI_OPERATE_MODE_144
Definition: at32f435_437_qspi.h:115
QSPI_OPERATE_MODE_111
@ QSPI_OPERATE_MODE_111
Definition: at32f435_437_qspi.h:111
QSPI_OPERATE_MODE_222
@ QSPI_OPERATE_MODE_222
Definition: at32f435_437_qspi.h:116
QSPI_OPERATE_MODE_112
@ QSPI_OPERATE_MODE_112
Definition: at32f435_437_qspi.h:112
QSPI_OPERATE_MODE_114
@ QSPI_OPERATE_MODE_114
Definition: at32f435_437_qspi.h:113
QSPI_OPERATE_MODE_444
@ QSPI_OPERATE_MODE_444
Definition: at32f435_437_qspi.h:117
QSPI_CLK_DIV_2
@ QSPI_CLK_DIV_2
Definition: at32f435_437_qspi.h:125
QSPI_CLK_DIV_8
@ QSPI_CLK_DIV_8
Definition: at32f435_437_qspi.h:128
QSPI_CLK_DIV_5
@ QSPI_CLK_DIV_5
Definition: at32f435_437_qspi.h:130
QSPI_CLK_DIV_10
@ QSPI_CLK_DIV_10
Definition: at32f435_437_qspi.h:131
QSPI_CLK_DIV_3
@ QSPI_CLK_DIV_3
Definition: at32f435_437_qspi.h:129
QSPI_CLK_DIV_4
@ QSPI_CLK_DIV_4
Definition: at32f435_437_qspi.h:126
QSPI_CLK_DIV_6
@ QSPI_CLK_DIV_6
Definition: at32f435_437_qspi.h:127
QSPI_CLK_DIV_12
@ QSPI_CLK_DIV_12
Definition: at32f435_437_qspi.h:132
QSPI_CMD_ADRLEN_0_BYTE
@ QSPI_CMD_ADRLEN_0_BYTE
Definition: at32f435_437_qspi.h:140
QSPI_CMD_ADRLEN_2_BYTE
@ QSPI_CMD_ADRLEN_2_BYTE
Definition: at32f435_437_qspi.h:142
QSPI_CMD_ADRLEN_3_BYTE
@ QSPI_CMD_ADRLEN_3_BYTE
Definition: at32f435_437_qspi.h:143
QSPI_CMD_ADRLEN_1_BYTE
@ QSPI_CMD_ADRLEN_1_BYTE
Definition: at32f435_437_qspi.h:141
QSPI_CMD_ADRLEN_4_BYTE
@ QSPI_CMD_ADRLEN_4_BYTE
Definition: at32f435_437_qspi.h:144
QSPI_XIPR_SEL_MODED
@ QSPI_XIPR_SEL_MODED
Definition: at32f435_437_qspi.h:69
QSPI_XIPR_SEL_MODET
@ QSPI_XIPR_SEL_MODET
Definition: at32f435_437_qspi.h:70
QSPI_XIPW_SEL_MODET
@ QSPI_XIPW_SEL_MODET
Definition: at32f435_437_qspi.h:79
QSPI_XIPW_SEL_MODED
@ QSPI_XIPW_SEL_MODED
Definition: at32f435_437_qspi.h:78
qspi_cmd_type
qspi cmd type
Definition: at32f435_437_qspi.h:189
qspi_cmd_type::instruction_length
qspi_cmd_inslen_type instruction_length
Definition: at32f435_437_qspi.h:193
qspi_cmd_type::write_data_enable
confirm_state write_data_enable
Definition: at32f435_437_qspi.h:201
qspi_cmd_type::operation_mode
qspi_operate_mode_type operation_mode
Definition: at32f435_437_qspi.h:198
qspi_cmd_type::instruction_code
uint8_t instruction_code
Definition: at32f435_437_qspi.h:192
qspi_cmd_type::read_status_config
qspi_read_status_conf_type read_status_config
Definition: at32f435_437_qspi.h:199
qspi_cmd_type::pe_mode_enable
confirm_state pe_mode_enable
Definition: at32f435_437_qspi.h:190
qspi_cmd_type::read_status_enable
confirm_state read_status_enable
Definition: at32f435_437_qspi.h:200
qspi_cmd_type::data_counter
uint32_t data_counter
Definition: at32f435_437_qspi.h:196
qspi_cmd_type::address_code
uint32_t address_code
Definition: at32f435_437_qspi.h:194
qspi_cmd_type::pe_mode_operate_code
uint8_t pe_mode_operate_code
Definition: at32f435_437_qspi.h:191
qspi_cmd_type::address_length
qspi_cmd_adrlen_type address_length
Definition: at32f435_437_qspi.h:195
qspi_cmd_type::second_dummy_cycle_num
uint8_t second_dummy_cycle_num
Definition: at32f435_437_qspi.h:197
qspi_type
type define qspi register all
Definition: at32f435_437_qspi.h:229
qspi_type::pemen
__IO uint32_t pemen
Definition: at32f435_437_qspi.h:256
qspi_type::xip_cmd_w1
__IO uint32_t xip_cmd_w1
Definition: at32f435_437_qspi.h:425
qspi_type::xiprcmdf
__IO uint32_t xiprcmdf
Definition: at32f435_437_qspi.h:309
qspi_type::xipr_dcnt
__IO uint32_t xipr_dcnt
Definition: at32f435_437_qspi.h:444
qspi_type::opmode
__IO uint32_t opmode
Definition: at32f435_437_qspi.h:286
qspi_type::clkdiv
__IO uint32_t clkdiv
Definition: at32f435_437_qspi.h:301
qspi_type::dum2
__IO uint32_t dum2
Definition: at32f435_437_qspi.h:253
qspi_type::dt
__IO uint32_t dt
Definition: at32f435_437_qspi.h:499
qspi_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f435_437_qspi.h:353
qspi_type::xipr_opmode
__IO uint32_t xipr_opmode
Definition: at32f435_437_qspi.h:413
qspi_type::xipw_sel
__IO uint32_t xipw_sel
Definition: at32f435_437_qspi.h:451
qspi_type::dmaen
__IO uint32_t dmaen
Definition: at32f435_437_qspi.h:356
qspi_type::cmd_w0
__IO uint32_t cmd_w0
Definition: at32f435_437_qspi.h:235
qspi_type::xipr_insc
__IO uint32_t xipr_insc
Definition: at32f435_437_qspi.h:415
qspi_type::keyen
__IO uint32_t keyen
Definition: at32f435_437_qspi.h:311
qspi_type::xip_cmd_w2
__IO uint32_t xip_cmd_w2
Definition: at32f435_437_qspi.h:441
qspi_type::fifosts
__IO uint32_t fifosts
Definition: at32f435_437_qspi.h:334
qspi_type::spists
__IO uint32_t spists
Definition: at32f435_437_qspi.h:387
qspi_type::dcnt
__IO uint32_t dcnt
Definition: at32f435_437_qspi.h:269
qspi_type::txfifordy
__IO uint32_t txfifordy
Definition: at32f435_437_qspi.h:337
qspi_type::xipsel
__IO uint32_t xipsel
Definition: at32f435_437_qspi.h:310
qspi_type::xipr_tcnt
__IO uint32_t xipr_tcnt
Definition: at32f435_437_qspi.h:446
qspi_type::rxfifordy
__IO uint32_t rxfifordy
Definition: at32f435_437_qspi.h:338
qspi_type::xipr_sel
__IO uint32_t xipr_sel
Definition: at32f435_437_qspi.h:447
qspi_type::xip_cmd_w3
__IO uint32_t xip_cmd_w3
Definition: at32f435_437_qspi.h:460
qspi_type::rstsc
__IO uint32_t rstsc
Definition: at32f435_437_qspi.h:284
qspi_type::csdly
__IO uint32_t csdly
Definition: at32f435_437_qspi.h:324
qspi_type::cmdsts
__IO uint32_t cmdsts
Definition: at32f435_437_qspi.h:371
qspi_type::xipidle
__IO uint32_t xipidle
Definition: at32f435_437_qspi.h:305
qspi_type::wen
__IO uint32_t wen
Definition: at32f435_437_qspi.h:282
qspi_type::cmd_w2
__IO uint32_t cmd_w2
Definition: at32f435_437_qspi.h:266
qspi_type::pemopc
__IO uint32_t pemopc
Definition: at32f435_437_qspi.h:288
qspi_type::csts
__IO uint32_t csts
Definition: at32f435_437_qspi.h:465
qspi_type::busy
__IO uint32_t busy
Definition: at32f435_437_qspi.h:308
qspi_type::xip_cmd_w0
__IO uint32_t xip_cmd_w0
Definition: at32f435_437_qspi.h:409
qspi_type::rsts
__IO uint32_t rsts
Definition: at32f435_437_qspi.h:384
qspi_type::rxfifo_thod
__IO uint32_t rxfifo_thod
Definition: at32f435_437_qspi.h:361
qspi_type::dt_u16
__IO uint16_t dt_u16
Definition: at32f435_437_qspi.h:498
qspi_type::cmdie
__IO uint32_t cmdie
Definition: at32f435_437_qspi.h:357
qspi_type::adrlen
__IO uint32_t adrlen
Definition: at32f435_437_qspi.h:251
qspi_type::fsize
__IO uint32_t fsize
Definition: at32f435_437_qspi.h:397
qspi_type::reserved4
__IO uint32_t reserved4
Definition: at32f435_437_qspi.h:312
qspi_type::rstsen
__IO uint32_t rstsen
Definition: at32f435_437_qspi.h:283
qspi_type::actr
__IO uint32_t actr
Definition: at32f435_437_qspi.h:321
qspi_type::reserved1
__IO uint32_t reserved1
qspi reserved register, offset:0x1C
Definition: at32f435_437_qspi.h:252
qspi_type::spiadr
__IO uint32_t spiadr
Definition: at32f435_437_qspi.h:239
qspi_type::spifsize
__IO uint32_t spifsize
Definition: at32f435_437_qspi.h:400
qspi_type::reserved2
__IO uint32_t reserved2
qspi reserved register, offset:0x40~4C
Definition: at32f435_437_qspi.h:255
qspi_type::ctrl
__IO uint32_t ctrl
Definition: at32f435_437_qspi.h:298
qspi_type::insc
__IO uint32_t insc
Definition: at32f435_437_qspi.h:289
qspi_type::xipw_tcnt
__IO uint32_t xipw_tcnt
Definition: at32f435_437_qspi.h:450
qspi_type::xipr_dum2
__IO uint32_t xipr_dum2
Definition: at32f435_437_qspi.h:412
qspi_type::sckmode
__IO uint32_t sckmode
Definition: at32f435_437_qspi.h:303
qspi_type::xipw_dcnt
__IO uint32_t xipw_dcnt
Definition: at32f435_437_qspi.h:448
qspi_type::cmd_w1
__IO uint32_t cmd_w1
Definition: at32f435_437_qspi.h:248
qspi_type::abort
__IO uint32_t abort
Definition: at32f435_437_qspi.h:306
qspi_type::reserved3
__IO uint32_t reserved3
qspi reserved register, offset:0x54~FC
Definition: at32f435_437_qspi.h:257
qspi_type::txfifo_thod
__IO uint32_t txfifo_thod
Definition: at32f435_437_qspi.h:359
qspi_type::rev
__IO uint32_t rev
Definition: at32f435_437_qspi.h:480
qspi_type::xipr_adrlen
__IO uint32_t xipr_adrlen
Definition: at32f435_437_qspi.h:414
qspi_type::inslen
__IO uint32_t inslen
Definition: at32f435_437_qspi.h:254
qspi_type::cmd_w3
__IO uint32_t cmd_w3
Definition: at32f435_437_qspi.h:278
qspi_type::bypassc
__IO uint32_t bypassc
Definition: at32f435_437_qspi.h:463
qspi_type::dt_u8
__IO uint8_t dt_u8
Definition: at32f435_437_qspi.h:497
qspi_xip_type
qspi xip type
Definition: at32f435_437_qspi.h:208
qspi_xip_type::write_operation_mode
qspi_operate_mode_type write_operation_mode
Definition: at32f435_437_qspi.h:215
qspi_xip_type::read_second_dummy_cycle_num
uint8_t read_second_dummy_cycle_num
Definition: at32f435_437_qspi.h:212
qspi_xip_type::write_address_length
qspi_xip_addrlen_type write_address_length
Definition: at32f435_437_qspi.h:214
qspi_xip_type::write_instruction_code
uint8_t write_instruction_code
Definition: at32f435_437_qspi.h:213
qspi_xip_type::write_data_counter
uint8_t write_data_counter
Definition: at32f435_437_qspi.h:219
qspi_xip_type::read_select_mode
qspi_xip_read_sel_type read_select_mode
Definition: at32f435_437_qspi.h:220
qspi_xip_type::write_time_counter
uint8_t write_time_counter
Definition: at32f435_437_qspi.h:218
qspi_xip_type::read_operation_mode
qspi_operate_mode_type read_operation_mode
Definition: at32f435_437_qspi.h:211
qspi_xip_type::read_address_length
qspi_xip_addrlen_type read_address_length
Definition: at32f435_437_qspi.h:210
qspi_xip_type::read_data_counter
uint8_t read_data_counter
Definition: at32f435_437_qspi.h:222
qspi_xip_type::read_time_counter
uint8_t read_time_counter
Definition: at32f435_437_qspi.h:221
qspi_xip_type::write_select_mode
qspi_xip_write_sel_type write_select_mode
Definition: at32f435_437_qspi.h:217
qspi_xip_type::write_second_dummy_cycle_num
uint8_t write_second_dummy_cycle_num
Definition: at32f435_437_qspi.h:216
qspi_xip_type::read_instruction_code
uint8_t read_instruction_code
Definition: at32f435_437_qspi.h:209


AT32F435/437 Firmwary Library: at32f435_437_scfg.c Source File

  • libraries
  • drivers
  • src
at32f435_437_scfg.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef SCFG_MODULE_ENABLED
39
49void scfg_reset(void)
50{
51 crm_periph_reset(CRM_SCFG_PERIPH_RESET, TRUE);
52 crm_periph_reset(CRM_SCFG_PERIPH_RESET, FALSE);
53}
54
65void scfg_xmc_mapping_swap_set(scfg_xmc_swap_type xmc_swap)
66{
67 SCFG->cfg1_bit.swap_xmc = xmc_swap;
68}
69
83void scfg_infrared_config(scfg_ir_source_type source, scfg_ir_polarity_type polarity)
84{
85 SCFG->cfg1_bit.ir_src_sel = source;
86 SCFG->cfg1_bit.ir_pol = polarity;
87}
88
100void scfg_mem_map_set(scfg_mem_map_type mem_map)
101{
102 SCFG->cfg1_bit.mem_map_sel = mem_map;
103}
104
113void scfg_emac_interface_set(scfg_emac_interface_type mode)
114{
115 SCFG->cfg2_bit.mii_rmii_sel = mode;
116}
117
152void scfg_exint_line_config(scfg_port_source_type port_source, scfg_pins_source_type pin_source)
153{
154 uint32_t tmp = 0x00;
155 tmp = ((uint32_t)0x0F) << (0x04 * (pin_source & (uint8_t)0x03));
156
157 switch (pin_source >> 0x02)
158 {
159 case 0:
160 SCFG->exintc1 &= ~tmp;
161 SCFG->exintc1 |= (((uint32_t)port_source) << (0x04 * (pin_source & (uint8_t)0x03)));
162 break;
163 case 1:
164 SCFG->exintc2 &= ~tmp;
165 SCFG->exintc2 |= (((uint32_t)port_source) << (0x04 * (pin_source & (uint8_t)0x03)));
166 break;
167 case 2:
168 SCFG->exintc3 &= ~tmp;
169 SCFG->exintc3 |= (((uint32_t)port_source) << (0x04 * (pin_source & (uint8_t)0x03)));
170 break;
171 case 3:
172 SCFG->exintc4 &= ~tmp;
173 SCFG->exintc4 |= (((uint32_t)port_source) << (0x04 * (pin_source & (uint8_t)0x03)));
174 break;
175 default:
176 break;
177 }
178}
179
196void scfg_pins_ultra_driven_enable(scfg_ultra_driven_pins_type value, confirm_state new_state)
197{
198 if(TRUE == new_state)
199 {
200 SCFG_REG(value) |= SCFG_REG_BIT(value);
201 }
202 else
203 {
204 SCFG_REG(value) &= ~(SCFG_REG_BIT(value));
205 }
206}
207
212#endif
213
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f435_437_crm.c:251
CRM_SCFG_PERIPH_RESET
@ CRM_SCFG_PERIPH_RESET
Definition: at32f435_437_crm.h:308
confirm_state
confirm_state
Definition: at32f435_437.h:379
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
scfg_xmc_swap_type
scfg_xmc_swap_type
scfg xmc addres mapping swap type
Definition: at32f435_437_scfg.h:58
scfg_ir_source_type
scfg_ir_source_type
scfg infrared modulation signal source selecting type
Definition: at32f435_437_scfg.h:69
scfg_ir_polarity_type
scfg_ir_polarity_type
scfg infrared output polarity selecting type
Definition: at32f435_437_scfg.h:79
scfg_ultra_driven_pins_type
scfg_ultra_driven_pins_type
scfg ultra high sourcing/sinking strength pins type
Definition: at32f435_437_scfg.h:147
scfg_pins_source_type
scfg_pins_source_type
scfg pin source type
Definition: at32f435_437_scfg.h:100
scfg_emac_interface_type
scfg_emac_interface_type
scfg emac interface selecting type
Definition: at32f435_437_scfg.h:138
scfg_mem_map_type
scfg_mem_map_type
scfg memory address mapping selecting type
Definition: at32f435_437_scfg.h:88
scfg_port_source_type
scfg_port_source_type
gpio port source type
Definition: at32f435_437_scfg.h:123
scfg_xmc_mapping_swap_set
void scfg_xmc_mapping_swap_set(scfg_xmc_swap_type xmc_swap)
scfg xmc address mapping swap set
Definition: at32f435_437_scfg.c:65
scfg_infrared_config
void scfg_infrared_config(scfg_ir_source_type source, scfg_ir_polarity_type polarity)
scfg infrared config
Definition: at32f435_437_scfg.c:83
scfg_exint_line_config
void scfg_exint_line_config(scfg_port_source_type port_source, scfg_pins_source_type pin_source)
select the gpio pin used as exint line.
Definition: at32f435_437_scfg.c:152
scfg_mem_map_set
void scfg_mem_map_set(scfg_mem_map_type mem_map)
scfg memory address mapping set
Definition: at32f435_437_scfg.c:100
scfg_emac_interface_set
void scfg_emac_interface_set(scfg_emac_interface_type mode)
scfg emac interface set
Definition: at32f435_437_scfg.c:113
scfg_reset
void scfg_reset(void)
scfg reset
Definition: at32f435_437_scfg.c:49
scfg_pins_ultra_driven_enable
void scfg_pins_ultra_driven_enable(scfg_ultra_driven_pins_type value, confirm_state new_state)
enable or disable gpio pins ultra driven.
Definition: at32f435_437_scfg.c:196
SCFG
#define SCFG
Definition: at32f435_437_scfg.h:293
SCFG_REG
#define SCFG_REG(value)
Definition: at32f435_437_scfg.h:47
SCFG_REG_BIT
#define SCFG_REG_BIT(value)
Definition: at32f435_437_scfg.h:48
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_scfg.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_scfg.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_SCFG_H
29#define __AT32F435_437_SCFG_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
47#define SCFG_REG(value) PERIPH_REG(SCFG_BASE, value)
48#define SCFG_REG_BIT(value) PERIPH_REG_BIT(value)
49
57typedef enum
58{
59 SCFG_XMC_SWAP_NONE = 0x00, /* no swap */
60 SCFG_XMC_SWAP_MODE1 = 0x01, /* sdram 0x60000000 and 0x70000000, nor psram sram nand2 0xC00000000 and 0xD0000000 */
61 SCFG_XMC_SWAP_MODE2 = 0x02, /* qspi2 0x80000000, nand3 0xB0000000 */
62 SCFG_XMC_SWAP_MODE3 = 0x03 /* sdram 0x60000000 and 0x70000000, nor psram sram nand2 0xC00000000 and 0xD0000000, qspi2 0x80000000, nand3 0xB0000000 */
63} scfg_xmc_swap_type;
64
68typedef enum
69{
70 SCFG_IR_SOURCE_TMR10 = 0x00, /* infrared signal source select tmr10 */
71 SCFG_IR_SOURCE_USART1 = 0x01, /* infrared signal source select usart1 */
72 SCFG_IR_SOURCE_USART2 = 0x02 /* infrared signal source select usart2 */
73} scfg_ir_source_type;
74
78typedef enum
79{
80 SCFG_IR_POLARITY_NO_AFFECTE = 0x00, /* infrared output polarity no affecte */
81 SCFG_IR_POLARITY_REVERSE = 0x01 /* infrared output polarity reverse */
82} scfg_ir_polarity_type;
83
87typedef enum
88{
89 SCFG_MEM_MAP_MAIN_MEMORY = 0x00, /* 0x00000000 address mapping from main memory */
90 SCFG_MEM_MAP_BOOT_MEMORY = 0x01, /* 0x00000000 address mapping from boot memory */
91 SCFG_MEM_MAP_XMC_BANK1 = 0x02, /* 0x00000000 address mapping from xmc bank1 */
92 SCFG_MEM_MAP_INTERNAL_SRAM = 0x03, /* 0x00000000 address mapping from internal sram */
93 SCFG_MEM_MAP_XMC_SDRAM_BANK1 = 0x04 /* 0x00000000 address mapping from xmc sdram bank1 */
94} scfg_mem_map_type;
95
99typedef enum
100{
101 SCFG_PINS_SOURCE0 = 0x00,
102 SCFG_PINS_SOURCE1 = 0x01,
103 SCFG_PINS_SOURCE2 = 0x02,
104 SCFG_PINS_SOURCE3 = 0x03,
105 SCFG_PINS_SOURCE4 = 0x04,
106 SCFG_PINS_SOURCE5 = 0x05,
107 SCFG_PINS_SOURCE6 = 0x06,
108 SCFG_PINS_SOURCE7 = 0x07,
109 SCFG_PINS_SOURCE8 = 0x08,
110 SCFG_PINS_SOURCE9 = 0x09,
111 SCFG_PINS_SOURCE10 = 0x0A,
112 SCFG_PINS_SOURCE11 = 0x0B,
113 SCFG_PINS_SOURCE12 = 0x0C,
114 SCFG_PINS_SOURCE13 = 0x0D,
115 SCFG_PINS_SOURCE14 = 0x0E,
116 SCFG_PINS_SOURCE15 = 0x0F
117} scfg_pins_source_type;
118
122typedef enum
123{
124 SCFG_PORT_SOURCE_GPIOA = 0x00,
125 SCFG_PORT_SOURCE_GPIOB = 0x01,
126 SCFG_PORT_SOURCE_GPIOC = 0x02,
127 SCFG_PORT_SOURCE_GPIOD = 0x03,
128 SCFG_PORT_SOURCE_GPIOE = 0x04,
129 SCFG_PORT_SOURCE_GPIOF = 0x05,
130 SCFG_PORT_SOURCE_GPIOG = 0x06,
131 SCFG_PORT_SOURCE_GPIOH = 0x07
132} scfg_port_source_type;
133
137typedef enum
138{
139 SCFG_EMAC_SELECT_MII = 0x00, /* emac interface select mii mode */
140 SCFG_EMAC_SELECT_RMII = 0x01 /* emac interface select rmii mode */
141} scfg_emac_interface_type;
142
146typedef enum
147{
148 SCFG_ULTRA_DRIVEN_PB3 = MAKE_VALUE(0x2C, 0),
149 SCFG_ULTRA_DRIVEN_PB9 = MAKE_VALUE(0x2C, 1),
150 SCFG_ULTRA_DRIVEN_PB10 = MAKE_VALUE(0x2C, 2),
151 SCFG_ULTRA_DRIVEN_PD12 = MAKE_VALUE(0x2C, 5),
152 SCFG_ULTRA_DRIVEN_PD13 = MAKE_VALUE(0x2C, 6),
153 SCFG_ULTRA_DRIVEN_PD14 = MAKE_VALUE(0x2C, 7),
154 SCFG_ULTRA_DRIVEN_PD15 = MAKE_VALUE(0x2C, 8),
155 SCFG_ULTRA_DRIVEN_PF14 = MAKE_VALUE(0x2C, 9),
156 SCFG_ULTRA_DRIVEN_PF15 = MAKE_VALUE(0x2C, 10)
157} scfg_ultra_driven_pins_type;
158
162typedef struct
163{
167 union
168 {
169 __IO uint32_t cfg1;
170 struct
171 {
172 __IO uint32_t mem_map_sel : 3; /* [2:0] */
173 __IO uint32_t reserved1 : 2; /* [4:3] */
174 __IO uint32_t ir_pol : 1; /* [5] */
175 __IO uint32_t ir_src_sel : 2; /* [7:6] */
176 __IO uint32_t reserved2 : 2; /* [9:8] */
177 __IO uint32_t swap_xmc : 2; /* [11:10] */
178 __IO uint32_t reserved3 : 20;/* [31:12] */
179 } cfg1_bit;
180 };
181
185 union
186 {
187 __IO uint32_t cfg2;
188 struct
189 {
190 __IO uint32_t reserved1 : 23;/* [22:0] */
191 __IO uint32_t mii_rmii_sel : 1; /* [23] */
192 __IO uint32_t reserved2 : 8; /* [31:24] */
193 } cfg2_bit;
194 };
195
199 union
200 {
201 __IO uint32_t exintc1;
202 struct
203 {
204 __IO uint32_t exint0 : 4; /* [3:0] */
205 __IO uint32_t exint1 : 4; /* [7:4] */
206 __IO uint32_t exint2 : 4; /* [11:8] */
207 __IO uint32_t exint3 : 4; /* [15:12] */
208 __IO uint32_t reserved1 : 16;/* [31:16] */
209 } exintc1_bit;
210 };
211
215 union
216 {
217 __IO uint32_t exintc2;
218 struct
219 {
220 __IO uint32_t exint4 : 4; /* [3:0] */
221 __IO uint32_t exint5 : 4; /* [7:4] */
222 __IO uint32_t exint6 : 4; /* [11:8] */
223 __IO uint32_t exint7 : 4; /* [15:12] */
224 __IO uint32_t reserved1 : 16;/* [31:16] */
225 } exintc2_bit;
226 };
227
231 union
232 {
233 __IO uint32_t exintc3;
234 struct
235 {
236 __IO uint32_t exint8 : 4; /* [3:0] */
237 __IO uint32_t exint9 : 4; /* [7:4] */
238 __IO uint32_t exint10 : 4; /* [11:8] */
239 __IO uint32_t exint11 : 4; /* [15:12] */
240 __IO uint32_t reserved1 : 16;/* [31:16] */
241 } exintc3_bit;
242 };
243
247 union
248 {
249 __IO uint32_t exintc4;
250 struct
251 {
252 __IO uint32_t exint12 : 4; /* [3:0] */
253 __IO uint32_t exint13 : 4; /* [7:4] */
254 __IO uint32_t exint14 : 4; /* [11:8] */
255 __IO uint32_t exint15 : 4; /* [15:12] */
256 __IO uint32_t reserved1 : 16;/* [31:16] */
257 } exintc4_bit;
258 };
259
263 __IO uint32_t reserved1[5];
264
268 union
269 {
270 __IO uint32_t uhdrv;
271 struct
272 {
273 __IO uint32_t pb3_uh : 1; /* [0] */
274 __IO uint32_t pb9_uh : 1; /* [1] */
275 __IO uint32_t pb10_uh : 1; /* [2] */
276 __IO uint32_t reserved1 : 2; /* [4:3] */
277 __IO uint32_t pd12_uh : 1; /* [5] */
278 __IO uint32_t pd13_uh : 1; /* [6] */
279 __IO uint32_t pd14_uh : 1; /* [7] */
280 __IO uint32_t pd15_uh : 1; /* [8] */
281 __IO uint32_t pf14_uh : 1; /* [9] */
282 __IO uint32_t pf15_uh : 1; /* [10] */
283 __IO uint32_t reserved2 : 21;/* [31:11] */
284 } uhdrv_bit;
285 };
286
287} scfg_type;
288
293#define SCFG ((scfg_type *) SCFG_BASE)
294
299void scfg_reset(void);
300void scfg_xmc_mapping_swap_set(scfg_xmc_swap_type xmc_swap);
301void scfg_infrared_config(scfg_ir_source_type source, scfg_ir_polarity_type polarity);
302void scfg_mem_map_set(scfg_mem_map_type mem_map);
303void scfg_emac_interface_set(scfg_emac_interface_type mode);
304void scfg_exint_line_config(scfg_port_source_type port_source, scfg_pins_source_type pin_source);
305void scfg_pins_ultra_driven_enable(scfg_ultra_driven_pins_type value, confirm_state new_state);
306
319#ifdef __cplusplus
320}
321#endif
322
323#endif
at32f435_437.h
at32f435_437 header file
MAKE_VALUE
#define MAKE_VALUE(reg_offset, bit_num)
Definition: at32f435_437.h:394
confirm_state
confirm_state
Definition: at32f435_437.h:379
scfg_xmc_mapping_swap_set
void scfg_xmc_mapping_swap_set(scfg_xmc_swap_type xmc_swap)
scfg xmc address mapping swap set
Definition: at32f435_437_scfg.c:65
scfg_infrared_config
void scfg_infrared_config(scfg_ir_source_type source, scfg_ir_polarity_type polarity)
scfg infrared config
Definition: at32f435_437_scfg.c:83
scfg_exint_line_config
void scfg_exint_line_config(scfg_port_source_type port_source, scfg_pins_source_type pin_source)
select the gpio pin used as exint line.
Definition: at32f435_437_scfg.c:152
scfg_mem_map_set
void scfg_mem_map_set(scfg_mem_map_type mem_map)
scfg memory address mapping set
Definition: at32f435_437_scfg.c:100
scfg_emac_interface_set
void scfg_emac_interface_set(scfg_emac_interface_type mode)
scfg emac interface set
Definition: at32f435_437_scfg.c:113
scfg_reset
void scfg_reset(void)
scfg reset
Definition: at32f435_437_scfg.c:49
scfg_pins_ultra_driven_enable
void scfg_pins_ultra_driven_enable(scfg_ultra_driven_pins_type value, confirm_state new_state)
enable or disable gpio pins ultra driven.
Definition: at32f435_437_scfg.c:196
scfg_xmc_swap_type
scfg_xmc_swap_type
scfg xmc addres mapping swap type
Definition: at32f435_437_scfg.h:58
scfg_ir_source_type
scfg_ir_source_type
scfg infrared modulation signal source selecting type
Definition: at32f435_437_scfg.h:69
scfg_ir_polarity_type
scfg_ir_polarity_type
scfg infrared output polarity selecting type
Definition: at32f435_437_scfg.h:79
scfg_ultra_driven_pins_type
scfg_ultra_driven_pins_type
scfg ultra high sourcing/sinking strength pins type
Definition: at32f435_437_scfg.h:147
scfg_pins_source_type
scfg_pins_source_type
scfg pin source type
Definition: at32f435_437_scfg.h:100
scfg_emac_interface_type
scfg_emac_interface_type
scfg emac interface selecting type
Definition: at32f435_437_scfg.h:138
scfg_mem_map_type
scfg_mem_map_type
scfg memory address mapping selecting type
Definition: at32f435_437_scfg.h:88
scfg_port_source_type
scfg_port_source_type
gpio port source type
Definition: at32f435_437_scfg.h:123
SCFG_XMC_SWAP_MODE2
@ SCFG_XMC_SWAP_MODE2
Definition: at32f435_437_scfg.h:61
SCFG_XMC_SWAP_MODE1
@ SCFG_XMC_SWAP_MODE1
Definition: at32f435_437_scfg.h:60
SCFG_XMC_SWAP_MODE3
@ SCFG_XMC_SWAP_MODE3
Definition: at32f435_437_scfg.h:62
SCFG_XMC_SWAP_NONE
@ SCFG_XMC_SWAP_NONE
Definition: at32f435_437_scfg.h:59
SCFG_IR_SOURCE_USART2
@ SCFG_IR_SOURCE_USART2
Definition: at32f435_437_scfg.h:72
SCFG_IR_SOURCE_USART1
@ SCFG_IR_SOURCE_USART1
Definition: at32f435_437_scfg.h:71
SCFG_IR_SOURCE_TMR10
@ SCFG_IR_SOURCE_TMR10
Definition: at32f435_437_scfg.h:70
SCFG_IR_POLARITY_REVERSE
@ SCFG_IR_POLARITY_REVERSE
Definition: at32f435_437_scfg.h:81
SCFG_IR_POLARITY_NO_AFFECTE
@ SCFG_IR_POLARITY_NO_AFFECTE
Definition: at32f435_437_scfg.h:80
SCFG_ULTRA_DRIVEN_PD12
@ SCFG_ULTRA_DRIVEN_PD12
Definition: at32f435_437_scfg.h:151
SCFG_ULTRA_DRIVEN_PB3
@ SCFG_ULTRA_DRIVEN_PB3
Definition: at32f435_437_scfg.h:148
SCFG_ULTRA_DRIVEN_PF14
@ SCFG_ULTRA_DRIVEN_PF14
Definition: at32f435_437_scfg.h:155
SCFG_ULTRA_DRIVEN_PB10
@ SCFG_ULTRA_DRIVEN_PB10
Definition: at32f435_437_scfg.h:150
SCFG_ULTRA_DRIVEN_PD15
@ SCFG_ULTRA_DRIVEN_PD15
Definition: at32f435_437_scfg.h:154
SCFG_ULTRA_DRIVEN_PF15
@ SCFG_ULTRA_DRIVEN_PF15
Definition: at32f435_437_scfg.h:156
SCFG_ULTRA_DRIVEN_PD13
@ SCFG_ULTRA_DRIVEN_PD13
Definition: at32f435_437_scfg.h:152
SCFG_ULTRA_DRIVEN_PD14
@ SCFG_ULTRA_DRIVEN_PD14
Definition: at32f435_437_scfg.h:153
SCFG_ULTRA_DRIVEN_PB9
@ SCFG_ULTRA_DRIVEN_PB9
Definition: at32f435_437_scfg.h:149
SCFG_PINS_SOURCE10
@ SCFG_PINS_SOURCE10
Definition: at32f435_437_scfg.h:111
SCFG_PINS_SOURCE5
@ SCFG_PINS_SOURCE5
Definition: at32f435_437_scfg.h:106
SCFG_PINS_SOURCE8
@ SCFG_PINS_SOURCE8
Definition: at32f435_437_scfg.h:109
SCFG_PINS_SOURCE6
@ SCFG_PINS_SOURCE6
Definition: at32f435_437_scfg.h:107
SCFG_PINS_SOURCE13
@ SCFG_PINS_SOURCE13
Definition: at32f435_437_scfg.h:114
SCFG_PINS_SOURCE15
@ SCFG_PINS_SOURCE15
Definition: at32f435_437_scfg.h:116
SCFG_PINS_SOURCE1
@ SCFG_PINS_SOURCE1
Definition: at32f435_437_scfg.h:102
SCFG_PINS_SOURCE11
@ SCFG_PINS_SOURCE11
Definition: at32f435_437_scfg.h:112
SCFG_PINS_SOURCE2
@ SCFG_PINS_SOURCE2
Definition: at32f435_437_scfg.h:103
SCFG_PINS_SOURCE7
@ SCFG_PINS_SOURCE7
Definition: at32f435_437_scfg.h:108
SCFG_PINS_SOURCE0
@ SCFG_PINS_SOURCE0
Definition: at32f435_437_scfg.h:101
SCFG_PINS_SOURCE3
@ SCFG_PINS_SOURCE3
Definition: at32f435_437_scfg.h:104
SCFG_PINS_SOURCE4
@ SCFG_PINS_SOURCE4
Definition: at32f435_437_scfg.h:105
SCFG_PINS_SOURCE14
@ SCFG_PINS_SOURCE14
Definition: at32f435_437_scfg.h:115
SCFG_PINS_SOURCE12
@ SCFG_PINS_SOURCE12
Definition: at32f435_437_scfg.h:113
SCFG_PINS_SOURCE9
@ SCFG_PINS_SOURCE9
Definition: at32f435_437_scfg.h:110
SCFG_EMAC_SELECT_MII
@ SCFG_EMAC_SELECT_MII
Definition: at32f435_437_scfg.h:139
SCFG_EMAC_SELECT_RMII
@ SCFG_EMAC_SELECT_RMII
Definition: at32f435_437_scfg.h:140
SCFG_MEM_MAP_XMC_BANK1
@ SCFG_MEM_MAP_XMC_BANK1
Definition: at32f435_437_scfg.h:91
SCFG_MEM_MAP_BOOT_MEMORY
@ SCFG_MEM_MAP_BOOT_MEMORY
Definition: at32f435_437_scfg.h:90
SCFG_MEM_MAP_MAIN_MEMORY
@ SCFG_MEM_MAP_MAIN_MEMORY
Definition: at32f435_437_scfg.h:89
SCFG_MEM_MAP_XMC_SDRAM_BANK1
@ SCFG_MEM_MAP_XMC_SDRAM_BANK1
Definition: at32f435_437_scfg.h:93
SCFG_MEM_MAP_INTERNAL_SRAM
@ SCFG_MEM_MAP_INTERNAL_SRAM
Definition: at32f435_437_scfg.h:92
SCFG_PORT_SOURCE_GPIOH
@ SCFG_PORT_SOURCE_GPIOH
Definition: at32f435_437_scfg.h:131
SCFG_PORT_SOURCE_GPIOE
@ SCFG_PORT_SOURCE_GPIOE
Definition: at32f435_437_scfg.h:128
SCFG_PORT_SOURCE_GPIOD
@ SCFG_PORT_SOURCE_GPIOD
Definition: at32f435_437_scfg.h:127
SCFG_PORT_SOURCE_GPIOC
@ SCFG_PORT_SOURCE_GPIOC
Definition: at32f435_437_scfg.h:126
SCFG_PORT_SOURCE_GPIOG
@ SCFG_PORT_SOURCE_GPIOG
Definition: at32f435_437_scfg.h:130
SCFG_PORT_SOURCE_GPIOB
@ SCFG_PORT_SOURCE_GPIOB
Definition: at32f435_437_scfg.h:125
SCFG_PORT_SOURCE_GPIOA
@ SCFG_PORT_SOURCE_GPIOA
Definition: at32f435_437_scfg.h:124
SCFG_PORT_SOURCE_GPIOF
@ SCFG_PORT_SOURCE_GPIOF
Definition: at32f435_437_scfg.h:129
scfg_type
type define system config register all
Definition: at32f435_437_scfg.h:163
scfg_type::exint15
__IO uint32_t exint15
Definition: at32f435_437_scfg.h:255
scfg_type::exint13
__IO uint32_t exint13
Definition: at32f435_437_scfg.h:253
scfg_type::exint4
__IO uint32_t exint4
Definition: at32f435_437_scfg.h:220
scfg_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_scfg.h:176
scfg_type::cfg2
__IO uint32_t cfg2
Definition: at32f435_437_scfg.h:187
scfg_type::pd12_uh
__IO uint32_t pd12_uh
Definition: at32f435_437_scfg.h:277
scfg_type::reserved1
__IO uint32_t reserved1
crm reserved1 register, offset:0x18~0x28
Definition: at32f435_437_scfg.h:173
scfg_type::exint0
__IO uint32_t exint0
Definition: at32f435_437_scfg.h:204
scfg_type::uhdrv
__IO uint32_t uhdrv
Definition: at32f435_437_scfg.h:270
scfg_type::exint6
__IO uint32_t exint6
Definition: at32f435_437_scfg.h:222
scfg_type::exintc2
__IO uint32_t exintc2
Definition: at32f435_437_scfg.h:217
scfg_type::exint11
__IO uint32_t exint11
Definition: at32f435_437_scfg.h:239
scfg_type::exint1
__IO uint32_t exint1
Definition: at32f435_437_scfg.h:205
scfg_type::cfg1
__IO uint32_t cfg1
Definition: at32f435_437_scfg.h:169
scfg_type::pb10_uh
__IO uint32_t pb10_uh
Definition: at32f435_437_scfg.h:275
scfg_type::exint7
__IO uint32_t exint7
Definition: at32f435_437_scfg.h:223
scfg_type::exint3
__IO uint32_t exint3
Definition: at32f435_437_scfg.h:207
scfg_type::exint10
__IO uint32_t exint10
Definition: at32f435_437_scfg.h:238
scfg_type::swap_xmc
__IO uint32_t swap_xmc
Definition: at32f435_437_scfg.h:177
scfg_type::pd15_uh
__IO uint32_t pd15_uh
Definition: at32f435_437_scfg.h:280
scfg_type::pb3_uh
__IO uint32_t pb3_uh
Definition: at32f435_437_scfg.h:273
scfg_type::ir_src_sel
__IO uint32_t ir_src_sel
Definition: at32f435_437_scfg.h:175
scfg_type::pd14_uh
__IO uint32_t pd14_uh
Definition: at32f435_437_scfg.h:279
scfg_type::exintc1
__IO uint32_t exintc1
Definition: at32f435_437_scfg.h:201
scfg_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_scfg.h:178
scfg_type::ir_pol
__IO uint32_t ir_pol
Definition: at32f435_437_scfg.h:174
scfg_type::exint12
__IO uint32_t exint12
Definition: at32f435_437_scfg.h:252
scfg_type::exint8
__IO uint32_t exint8
Definition: at32f435_437_scfg.h:236
scfg_type::pf14_uh
__IO uint32_t pf14_uh
Definition: at32f435_437_scfg.h:281
scfg_type::mii_rmii_sel
__IO uint32_t mii_rmii_sel
Definition: at32f435_437_scfg.h:191
scfg_type::exint2
__IO uint32_t exint2
Definition: at32f435_437_scfg.h:206
scfg_type::mem_map_sel
__IO uint32_t mem_map_sel
Definition: at32f435_437_scfg.h:172
scfg_type::pf15_uh
__IO uint32_t pf15_uh
Definition: at32f435_437_scfg.h:282
scfg_type::pb9_uh
__IO uint32_t pb9_uh
Definition: at32f435_437_scfg.h:274
scfg_type::pd13_uh
__IO uint32_t pd13_uh
Definition: at32f435_437_scfg.h:278
scfg_type::exint9
__IO uint32_t exint9
Definition: at32f435_437_scfg.h:237
scfg_type::exint14
__IO uint32_t exint14
Definition: at32f435_437_scfg.h:254
scfg_type::exintc3
__IO uint32_t exintc3
Definition: at32f435_437_scfg.h:233
scfg_type::exintc4
__IO uint32_t exintc4
Definition: at32f435_437_scfg.h:249
scfg_type::exint5
__IO uint32_t exint5
Definition: at32f435_437_scfg.h:221


AT32F435/437 Firmwary Library: at32f435_437_sdio.c Source File

  • libraries
  • drivers
  • src
at32f435_437_sdio.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef SDIO_MODULE_ENABLED
39
51void sdio_reset(sdio_type *sdio_x)
52{
53 sdio_x->pwrctrl = 0x0;
54 sdio_x->clkctrl = 0x0;
55 sdio_x->argu = 0x0;
56 sdio_x->cmdctrl = 0x0;
57 sdio_x->dttmr = 0x0;
58 sdio_x->dtlen = 0x0;
59 sdio_x->dtctrl = 0x0;
60 sdio_x->inten = 0x0;
61 sdio_x->intclr = 0x004007FF;
62}
63
75void sdio_power_set(sdio_type *sdio_x, sdio_power_state_type power_state)
76{
77 sdio_x->pwrctrl_bit.ps = power_state;
78}
79
87 sdio_power_state_type sdio_power_status_get(sdio_type *sdio_x)
88{
89 return (sdio_power_state_type)(sdio_x->pwrctrl_bit.ps);
90}
91
104void sdio_clock_config(sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
105{
106 /* config clock edge */
107 sdio_x->clkctrl_bit.clkegs = clk_edg;
108
109 /* config clock divide [7:0] */
110 sdio_x->clkctrl_bit.clkdiv_l = (clk_div & 0xFF);
111
112 /* config clock divide [9:8] */
113 sdio_x->clkctrl_bit.clkdiv_h = ((clk_div & 0x300) >> 8);
114}
115
128void sdio_bus_width_config(sdio_type *sdio_x, sdio_bus_width_type width)
129{
130 sdio_x->clkctrl_bit.busws = width;
131}
132
141void sdio_clock_bypass(sdio_type *sdio_x, confirm_state new_state)
142{
143 sdio_x->clkctrl_bit.bypsen = new_state;
144}
145
155void sdio_power_saving_mode_enable(sdio_type *sdio_x, confirm_state new_state)
156{
157 sdio_x->clkctrl_bit.pwrsven = new_state;
158}
159
168void sdio_flow_control_enable(sdio_type *sdio_x, confirm_state new_state)
169{
170 sdio_x->clkctrl_bit.hfcen = new_state;
171}
172
181void sdio_clock_enable(sdio_type *sdio_x, confirm_state new_state)
182{
183 sdio_x->clkctrl_bit.clkoen = new_state;
184}
185
194void sdio_dma_enable(sdio_type *sdio_x, confirm_state new_state)
195{
196 sdio_x->dtctrl_bit.dmaen = new_state;
197}
198
232void sdio_interrupt_enable(sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
233{
234 /* enable interrupt */
235 if(TRUE == new_state)
236 {
237 sdio_x->inten |= int_opt;
238 }
239 /* disable interrupt */
240 else
241 {
242 sdio_x->inten &= ~(int_opt);
243 }
244}
245
278 flag_status sdio_flag_get(sdio_type *sdio_x, uint32_t flag)
279{
280 flag_status status = RESET;
281
282 if((sdio_x->sts & flag) == flag)
283 {
284 status = SET;
285 }
286 else
287 {
288 status = RESET;
289 }
290
291 return status;
292}
293
315void sdio_flag_clear(sdio_type *sdio_x, uint32_t flag)
316{
317 sdio_x->intclr = flag;
318}
319
329void sdio_command_config(sdio_type *sdio_x, sdio_command_struct_type *command_struct)
330{
331 /* disable command path state machine */
332 sdio_x->cmdctrl_bit.ccsmen = FALSE;
333
334 /* config command argument */
335 sdio_x->argu = command_struct->argument;
336
337 /* config command register */
338 sdio_x->cmdctrl_bit.cmdidx = command_struct->cmd_index;
339 sdio_x->cmdctrl_bit.rspwt = command_struct->rsp_type;
340 sdio_x->cmdctrl_bit.intwt = (command_struct->wait_type & 0x1); /* [1:0] -> [0] */
341 sdio_x->cmdctrl_bit.pndwt = (command_struct->wait_type & 0x2)>>1; /* [1:0] -> [1] */
342}
343
352void sdio_command_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
353{
354 sdio_x->cmdctrl_bit.ccsmen = new_state;
355}
356
365uint8_t sdio_command_response_get(sdio_type *sdio_x)
366{
367 return sdio_x->rspcmd_bit.rspcmd;
368}
369
383uint32_t sdio_response_get(sdio_type *sdio_x, sdio_rsp_index_type reg_index)
384{
385 uint32_t response_value = 0;
386
387 switch(reg_index)
388 {
389 case SDIO_RSP1_INDEX:
390 response_value = sdio_x->rsp1;
391 break;
392 case SDIO_RSP2_INDEX:
393 response_value = sdio_x->rsp2;
394 break;
395 case SDIO_RSP3_INDEX:
396 response_value = sdio_x->rsp3;
397 break;
398 case SDIO_RSP4_INDEX:
399 response_value = sdio_x->rsp4;
400 break;
401 default: break;
402 }
403
404 return response_value;
405}
406
416void sdio_data_config(sdio_type *sdio_x, sdio_data_struct_type *data_struct)
417{
418 /* disable data path state machine */
419 sdio_x->dtctrl_bit.tfren = FALSE;
420
421 /* config data block, transfer mode and transfer direction */
422 sdio_x->dtctrl_bit.blksize = data_struct->block_size;
423 sdio_x->dtctrl_bit.tfrdir = data_struct->transfer_direction;
424 sdio_x->dtctrl_bit.tfrmode = data_struct->transfer_mode;
425
426 /* config data length */
427 sdio_x->dtlen_bit.dtlen = data_struct->data_length;
428
429 /* config data transfer timeout */
430 sdio_x->dttmr_bit.timeout = data_struct->timeout;
431}
432
441void sdio_data_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
442{
443 sdio_x->dtctrl_bit.tfren = new_state;
444}
445
453uint32_t sdio_data_counter_get(sdio_type *sdio_x)
454{
455 return sdio_x->dtcnt;
456}
457
465uint32_t sdio_data_read(sdio_type *sdio_x)
466{
467 return sdio_x->buf;
468}
469
477uint32_t sdio_buffer_counter_get(sdio_type *sdio_x)
478{
479 return sdio_x->bufcnt;
480}
481
490void sdio_data_write(sdio_type *sdio_x, uint32_t data)
491{
492 sdio_x->buf = data;
493}
494
506void sdio_read_wait_mode_set(sdio_type *sdio_x, sdio_read_wait_mode_type mode)
507{
508 sdio_x->dtctrl_bit.rdwtmode = mode;
509}
510
519void sdio_read_wait_start(sdio_type *sdio_x, confirm_state new_state)
520{
521 sdio_x->dtctrl_bit.rdwtstart = new_state;
522}
523
532void sdio_read_wait_stop(sdio_type *sdio_x, confirm_state new_state)
533{
534 sdio_x->dtctrl_bit.rdwtstop = new_state;
535}
536
545void sdio_io_function_enable(sdio_type *sdio_x, confirm_state new_state)
546{
547 sdio_x->dtctrl_bit.ioen = new_state;
548}
549
558void sdio_io_suspend_command_set(sdio_type *sdio_x, confirm_state new_state)
559{
560 sdio_x->cmdctrl_bit.iosusp = new_state;
561}
562
567#endif
568
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
sdio_read_wait_mode_type
sdio_read_wait_mode_type
sdio read wait mode
Definition: at32f435_437_sdio.h:220
sdio_edge_phase_type
sdio_edge_phase_type
sdio edge phase
Definition: at32f435_437_sdio.h:130
sdio_power_state_type
sdio_power_state_type
sdio power state
Definition: at32f435_437_sdio.h:121
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f435_437_sdio.h:139
sdio_rsp_index_type
sdio_rsp_index_type
sdio response register index
Definition: at32f435_437_sdio.h:169
SDIO_RSP3_INDEX
@ SDIO_RSP3_INDEX
Definition: at32f435_437_sdio.h:172
SDIO_RSP2_INDEX
@ SDIO_RSP2_INDEX
Definition: at32f435_437_sdio.h:171
SDIO_RSP4_INDEX
@ SDIO_RSP4_INDEX
Definition: at32f435_437_sdio.h:173
SDIO_RSP1_INDEX
@ SDIO_RSP1_INDEX
Definition: at32f435_437_sdio.h:170
sdio_command_config
void sdio_command_config(sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command.
Definition: at32f435_437_sdio.c:329
sdio_data_write
void sdio_data_write(sdio_type *sdio_x, uint32_t data)
write one word data to fifo.
Definition: at32f435_437_sdio.c:490
sdio_io_suspend_command_set
void sdio_io_suspend_command_set(sdio_type *sdio_x, confirm_state new_state)
enable or disable sd i/o suspend command sending.
Definition: at32f435_437_sdio.c:558
sdio_data_config
void sdio_data_config(sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data.
Definition: at32f435_437_sdio.c:416
sdio_data_read
uint32_t sdio_data_read(sdio_type *sdio_x)
read a word data from sdio fifo.
Definition: at32f435_437_sdio.c:465
sdio_io_function_enable
void sdio_io_function_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable the sd i/o function.
Definition: at32f435_437_sdio.c:545
sdio_command_state_machine_enable
void sdio_command_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM).
Definition: at32f435_437_sdio.c:352
sdio_clock_bypass
void sdio_clock_bypass(sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss
Definition: at32f435_437_sdio.c:141
sdio_flow_control_enable
void sdio_flow_control_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control.
Definition: at32f435_437_sdio.c:168
sdio_power_set
void sdio_power_set(sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller
Definition: at32f435_437_sdio.c:75
sdio_clock_config
void sdio_clock_config(sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock
Definition: at32f435_437_sdio.c:104
sdio_bus_width_config
void sdio_bus_width_config(sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width
Definition: at32f435_437_sdio.c:128
sdio_read_wait_stop
void sdio_read_wait_stop(sdio_type *sdio_x, confirm_state new_state)
enable or disable to stop sd i/o read wait operation.
Definition: at32f435_437_sdio.c:532
sdio_interrupt_enable
void sdio_interrupt_enable(sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt.
Definition: at32f435_437_sdio.c:232
sdio_flag_clear
void sdio_flag_clear(sdio_type *sdio_x, uint32_t flag)
clear sdio flag.
Definition: at32f435_437_sdio.c:315
sdio_power_status_get
sdio_power_state_type sdio_power_status_get(sdio_type *sdio_x)
get power status.
Definition: at32f435_437_sdio.c:87
sdio_response_get
uint32_t sdio_response_get(sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command.
Definition: at32f435_437_sdio.c:383
sdio_data_state_machine_enable
void sdio_data_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM).
Definition: at32f435_437_sdio.c:441
sdio_power_saving_mode_enable
void sdio_power_saving_mode_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle.
Definition: at32f435_437_sdio.c:155
sdio_flag_get
flag_status sdio_flag_get(sdio_type *sdio_x, uint32_t flag)
get sdio flag.
Definition: at32f435_437_sdio.c:278
sdio_dma_enable
void sdio_dma_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable dma.
Definition: at32f435_437_sdio.c:194
sdio_data_counter_get
uint32_t sdio_data_counter_get(sdio_type *sdio_x)
get the number of remaining data bytes to be transferred.
Definition: at32f435_437_sdio.c:453
sdio_buffer_counter_get
uint32_t sdio_buffer_counter_get(sdio_type *sdio_x)
get the number of words left to be written to or read from fifo..
Definition: at32f435_437_sdio.c:477
sdio_read_wait_start
void sdio_read_wait_start(sdio_type *sdio_x, confirm_state new_state)
enable or disable to start sd i/o read wait operation.
Definition: at32f435_437_sdio.c:519
sdio_reset
void sdio_reset(sdio_type *sdio_x)
reset the sdio register
Definition: at32f435_437_sdio.c:51
sdio_read_wait_mode_set
void sdio_read_wait_mode_set(sdio_type *sdio_x, sdio_read_wait_mode_type mode)
set the read wait mode.
Definition: at32f435_437_sdio.c:506
sdio_clock_enable
void sdio_clock_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output.
Definition: at32f435_437_sdio.c:181
sdio_command_response_get
uint8_t sdio_command_response_get(sdio_type *sdio_x)
get command index of last command for which response received.
Definition: at32f435_437_sdio.c:365
sdio_command_struct_type
sdio command structure
Definition: at32f435_437_sdio.h:229
sdio_command_struct_type::cmd_index
uint8_t cmd_index
Definition: at32f435_437_sdio.h:231
sdio_command_struct_type::argument
uint32_t argument
Definition: at32f435_437_sdio.h:230
sdio_command_struct_type::wait_type
sdio_wait_type wait_type
Definition: at32f435_437_sdio.h:233
sdio_command_struct_type::rsp_type
sdio_reponse_type rsp_type
Definition: at32f435_437_sdio.h:232
sdio_data_struct_type
sdio data structure
Definition: at32f435_437_sdio.h:240
sdio_data_struct_type::block_size
sdio_block_size_type block_size
Definition: at32f435_437_sdio.h:243
sdio_data_struct_type::transfer_direction
sdio_transfer_direction_type transfer_direction
Definition: at32f435_437_sdio.h:245
sdio_data_struct_type::timeout
uint32_t timeout
Definition: at32f435_437_sdio.h:241
sdio_data_struct_type::transfer_mode
sdio_transfer_mode_type transfer_mode
Definition: at32f435_437_sdio.h:244
sdio_data_struct_type::data_length
uint32_t data_length
Definition: at32f435_437_sdio.h:242
sdio_type
type define sdio register all
Definition: at32f435_437_sdio.h:252
sdio_type::ps
__IO uint32_t ps
Definition: at32f435_437_sdio.h:261
sdio_type::dtlen
__IO uint32_t dtlen
Definition: at32f435_437_sdio.h:394
sdio_type::intclr
__IO uint32_t intclr
Definition: at32f435_437_sdio.h:476
sdio_type::rdwtstart
__IO uint32_t rdwtstart
Definition: at32f435_437_sdio.h:415
sdio_type::rdwtstop
__IO uint32_t rdwtstop
Definition: at32f435_437_sdio.h:416
sdio_type::rspwt
__IO uint32_t rspwt
Definition: at32f435_437_sdio.h:307
sdio_type::hfcen
__IO uint32_t hfcen
Definition: at32f435_437_sdio.h:280
sdio_type::tfrmode
__IO uint32_t tfrmode
Definition: at32f435_437_sdio.h:412
sdio_type::clkegs
__IO uint32_t clkegs
Definition: at32f435_437_sdio.h:279
sdio_type::tfrdir
__IO uint32_t tfrdir
Definition: at32f435_437_sdio.h:411
sdio_type::tfren
__IO uint32_t tfren
Definition: at32f435_437_sdio.h:410
sdio_type::dttmr
__IO uint32_t dttmr
Definition: at32f435_437_sdio.h:382
sdio_type::pwrctrl_bit
struct sdio_type::@976::@1012 pwrctrl_bit
sdio_type::inten
__IO uint32_t inten
Definition: at32f435_437_sdio.h:501
sdio_type::clkctrl_bit
struct sdio_type::@978::@1013 clkctrl_bit
sdio_type::pndwt
__IO uint32_t pndwt
Definition: at32f435_437_sdio.h:309
sdio_type::rspcmd_bit
struct sdio_type::@984::@1016 rspcmd_bit
sdio_type::cmdctrl
__IO uint32_t cmdctrl
Definition: at32f435_437_sdio.h:303
sdio_type::clkoen
__IO uint32_t clkoen
Definition: at32f435_437_sdio.h:275
sdio_type::ioen
__IO uint32_t ioen
Definition: at32f435_437_sdio.h:418
sdio_type::bufcnt
__IO uint32_t bufcnt
Definition: at32f435_437_sdio.h:541
sdio_type::intwt
__IO uint32_t intwt
Definition: at32f435_437_sdio.h:308
sdio_type::rsp2
__IO uint32_t rsp2
Definition: at32f435_437_sdio.h:346
sdio_type::dtctrl
__IO uint32_t dtctrl
Definition: at32f435_437_sdio.h:407
sdio_type::dtctrl_bit
struct sdio_type::@998::@1023 dtctrl_bit
sdio_type::ccsmen
__IO uint32_t ccsmen
Definition: at32f435_437_sdio.h:310
sdio_type::pwrsven
__IO uint32_t pwrsven
Definition: at32f435_437_sdio.h:276
sdio_type::cmdidx
__IO uint32_t cmdidx
Definition: at32f435_437_sdio.h:306
sdio_type::dtlen_bit
struct sdio_type::@996::@1022 dtlen_bit
sdio_type::pwrctrl
__IO uint32_t pwrctrl
Definition: at32f435_437_sdio.h:258
sdio_type::dmaen
__IO uint32_t dmaen
Definition: at32f435_437_sdio.h:413
sdio_type::sts
__IO uint32_t sts
Definition: at32f435_437_sdio.h:441
sdio_type::blksize
__IO uint32_t blksize
Definition: at32f435_437_sdio.h:414
sdio_type::rdwtmode
__IO uint32_t rdwtmode
Definition: at32f435_437_sdio.h:417
sdio_type::rsp1
__IO uint32_t rsp1
Definition: at32f435_437_sdio.h:334
sdio_type::rsp4
__IO uint32_t rsp4
Definition: at32f435_437_sdio.h:370
sdio_type::bypsen
__IO uint32_t bypsen
Definition: at32f435_437_sdio.h:277
sdio_type::dttmr_bit
struct sdio_type::@994::@1021 dttmr_bit
sdio_type::cmdctrl_bit
struct sdio_type::@982::@1015 cmdctrl_bit
sdio_type::buf
__IO uint32_t buf
Definition: at32f435_437_sdio.h:559
sdio_type::clkdiv_l
__IO uint32_t clkdiv_l
Definition: at32f435_437_sdio.h:274
sdio_type::rspcmd
__IO uint32_t rspcmd
Definition: at32f435_437_sdio.h:321
sdio_type::argu
__IO uint32_t argu
Definition: at32f435_437_sdio.h:291
sdio_type::timeout
__IO uint32_t timeout
Definition: at32f435_437_sdio.h:385
sdio_type::busws
__IO uint32_t busws
Definition: at32f435_437_sdio.h:278
sdio_type::dtcnt
__IO uint32_t dtcnt
Definition: at32f435_437_sdio.h:428
sdio_type::clkdiv_h
__IO uint32_t clkdiv_h
Definition: at32f435_437_sdio.h:281
sdio_type::iosusp
__IO uint32_t iosusp
Definition: at32f435_437_sdio.h:311
sdio_type::clkctrl
__IO uint32_t clkctrl
Definition: at32f435_437_sdio.h:271
sdio_type::rsp3
__IO uint32_t rsp3
Definition: at32f435_437_sdio.h:358
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_sdio.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_sdio.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_SDIO_H
29#define __AT32F435_437_SDIO_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
52#define SDIO_CMDFAIL_INT ((uint32_t)0x00000001)
53#define SDIO_DTFAIL_INT ((uint32_t)0x00000002)
54#define SDIO_CMDTIMEOUT_INT ((uint32_t)0x00000004)
55#define SDIO_DTTIMEOUT_INT ((uint32_t)0x00000008)
56#define SDIO_TXERRU_INT ((uint32_t)0x00000010)
57#define SDIO_RXERRO_INT ((uint32_t)0x00000020)
58#define SDIO_CMDRSPCMPL_INT ((uint32_t)0x00000040)
59#define SDIO_CMDCMPL_INT ((uint32_t)0x00000080)
60#define SDIO_DTCMP_INT ((uint32_t)0x00000100)
61#define SDIO_SBITERR_INT ((uint32_t)0x00000200)
62#define SDIO_DTBLKCMPL_INT ((uint32_t)0x00000400)
63#define SDIO_DOCMD_INT ((uint32_t)0x00000800)
64#define SDIO_DOTX_INT ((uint32_t)0x00001000)
65#define SDIO_DORX_INT ((uint32_t)0x00002000)
66#define SDIO_TXBUFH_INT ((uint32_t)0x00004000)
67#define SDIO_RXBUFH_INT ((uint32_t)0x00008000)
68#define SDIO_TXBUFF_INT ((uint32_t)0x00010000)
69#define SDIO_RXBUFF_INT ((uint32_t)0x00020000)
70#define SDIO_TXBUFE_INT ((uint32_t)0x00040000)
71#define SDIO_RXBUFE_INT ((uint32_t)0x00080000)
72#define SDIO_TXBUF_INT ((uint32_t)0x00100000)
73#define SDIO_RXBUF_INT ((uint32_t)0x00200000)
74#define SDIO_SDIOIF_INT ((uint32_t)0x00400000)
85#define SDIO_CMDFAIL_FLAG ((uint32_t)0x00000001)
86#define SDIO_DTFAIL_FLAG ((uint32_t)0x00000002)
87#define SDIO_CMDTIMEOUT_FLAG ((uint32_t)0x00000004)
88#define SDIO_DTTIMEOUT_FLAG ((uint32_t)0x00000008)
89#define SDIO_TXERRU_FLAG ((uint32_t)0x00000010)
90#define SDIO_RXERRO_FLAG ((uint32_t)0x00000020)
91#define SDIO_CMDRSPCMPL_FLAG ((uint32_t)0x00000040)
92#define SDIO_CMDCMPL_FLAG ((uint32_t)0x00000080)
93#define SDIO_DTCMPL_FLAG ((uint32_t)0x00000100)
94#define SDIO_SBITERR_FLAG ((uint32_t)0x00000200)
95#define SDIO_DTBLKCMPL_FLAG ((uint32_t)0x00000400)
96#define SDIO_DOCMD_FLAG ((uint32_t)0x00000800)
97#define SDIO_DOTX_FLAG ((uint32_t)0x00001000)
98#define SDIO_DORX_FLAG ((uint32_t)0x00002000)
99#define SDIO_TXBUFH_FLAG ((uint32_t)0x00004000)
100#define SDIO_RXBUFH_FLAG ((uint32_t)0x00008000)
101#define SDIO_TXBUFF_FLAG ((uint32_t)0x00010000)
102#define SDIO_RXBUFF_FLAG ((uint32_t)0x00020000)
103#define SDIO_TXBUFE_FLAG ((uint32_t)0x00040000)
104#define SDIO_RXBUFE_FLAG ((uint32_t)0x00080000)
105#define SDIO_TXBUF_FLAG ((uint32_t)0x00100000)
106#define SDIO_RXBUF_FLAG ((uint32_t)0x00200000)
107#define SDIO_SDIOIF_FLAG ((uint32_t)0x00400000)
120typedef enum
121{
122 SDIO_POWER_OFF = 0x00,
123 SDIO_POWER_ON = 0x03
124} sdio_power_state_type;
125
129typedef enum
130{
131 SDIO_CLOCK_EDGE_RISING = 0x00,
132 SDIO_CLOCK_EDGE_FALLING = 0x01
133} sdio_edge_phase_type;
134
138typedef enum
139{
140 SDIO_BUS_WIDTH_D1 = 0x00,
141 SDIO_BUS_WIDTH_D4 = 0x01,
142 SDIO_BUS_WIDTH_D8 = 0x02
143} sdio_bus_width_type;
144
148typedef enum
149{
150 SDIO_RESPONSE_NO = 0x00,
151 SDIO_RESPONSE_SHORT = 0x01,
152 SDIO_RESPONSE_LONG = 0x03
153} sdio_reponse_type;
154
158typedef enum
159{
160 SDIO_WAIT_FOR_NO = 0x00,
161 SDIO_WAIT_FOR_INT = 0x01,
162 SDIO_WAIT_FOR_PEND = 0x02
163} sdio_wait_type;
164
168typedef enum
169{
170 SDIO_RSP1_INDEX = 0x00,
171 SDIO_RSP2_INDEX = 0x01,
172 SDIO_RSP3_INDEX = 0x02,
173 SDIO_RSP4_INDEX = 0x03
174} sdio_rsp_index_type;
175
179typedef enum
180{
181 SDIO_DATA_BLOCK_SIZE_1B = 0x00,
182 SDIO_DATA_BLOCK_SIZE_2B = 0x01,
183 SDIO_DATA_BLOCK_SIZE_4B = 0x02,
184 SDIO_DATA_BLOCK_SIZE_8B = 0x03,
185 SDIO_DATA_BLOCK_SIZE_16B = 0x04,
186 SDIO_DATA_BLOCK_SIZE_32B = 0x05,
187 SDIO_DATA_BLOCK_SIZE_64B = 0x06,
188 SDIO_DATA_BLOCK_SIZE_128B = 0x07,
189 SDIO_DATA_BLOCK_SIZE_256B = 0x08,
190 SDIO_DATA_BLOCK_SIZE_512B = 0x09,
191 SDIO_DATA_BLOCK_SIZE_1024B = 0x0A,
192 SDIO_DATA_BLOCK_SIZE_2048B = 0x0B,
193 SDIO_DATA_BLOCK_SIZE_4096B = 0x0C,
194 SDIO_DATA_BLOCK_SIZE_8192B = 0x0D,
195 SDIO_DATA_BLOCK_SIZE_16384B = 0x0E
196} sdio_block_size_type;
197
201typedef enum
202{
203 SDIO_DATA_BLOCK_TRANSFER = 0x00,
204 SDIO_DATA_STREAM_TRANSFER = 0x01
205} sdio_transfer_mode_type;
206
210typedef enum
211{
212 SDIO_DATA_TRANSFER_TO_CARD = 0x00,
213 SDIO_DATA_TRANSFER_TO_CONTROLLER = 0x01
214} sdio_transfer_direction_type;
215
219typedef enum
220{
221 SDIO_READ_WAIT_CONTROLLED_BY_D2 = 0x00,
222 SDIO_READ_WAIT_CONTROLLED_BY_CK = 0x01
223} sdio_read_wait_mode_type;
224
228typedef struct
229{
230 uint32_t argument;
231 uint8_t cmd_index;
232 sdio_reponse_type rsp_type;
233 sdio_wait_type wait_type;
234} sdio_command_struct_type;
235
239typedef struct
240{
241 uint32_t timeout;
242 uint32_t data_length;
243 sdio_block_size_type block_size;
244 sdio_transfer_mode_type transfer_mode;
245 sdio_transfer_direction_type transfer_direction;
246} sdio_data_struct_type;
247
251typedef struct
252{
256 union
257 {
258 __IO uint32_t pwrctrl;
259 struct
260 {
261 __IO uint32_t ps : 2; /* [1:0] */
262 __IO uint32_t reserved1 : 30;/* [31:2] */
263 } pwrctrl_bit;
264 };
265
269 union
270 {
271 __IO uint32_t clkctrl;
272 struct
273 {
274 __IO uint32_t clkdiv_l : 8; /* [7:0] */
275 __IO uint32_t clkoen : 1; /* [8] */
276 __IO uint32_t pwrsven : 1; /* [9] */
277 __IO uint32_t bypsen : 1; /* [10] */
278 __IO uint32_t busws : 2; /* [12:11] */
279 __IO uint32_t clkegs : 1; /* [13] */
280 __IO uint32_t hfcen : 1; /* [14] */
281 __IO uint32_t clkdiv_h : 2; /* [16:15] */
282 __IO uint32_t reserved1 : 15;/* [31:17] */
283 } clkctrl_bit;
284 };
285
289 union
290 {
291 __IO uint32_t argu;
292 struct
293 {
294 __IO uint32_t argu : 32;/* [31:0] */
295 } argu_bit;
296 };
297
301 union
302 {
303 __IO uint32_t cmdctrl;
304 struct
305 {
306 __IO uint32_t cmdidx : 6; /* [5:0] */
307 __IO uint32_t rspwt : 2; /* [7:6] */
308 __IO uint32_t intwt : 1; /* [8] */
309 __IO uint32_t pndwt : 1; /* [9] */
310 __IO uint32_t ccsmen : 1; /* [10] */
311 __IO uint32_t iosusp : 1; /* [11] */
312 __IO uint32_t reserved1 : 20;/* [31:12] */
313 } cmdctrl_bit;
314 };
315
319 union
320 {
321 __IO uint32_t rspcmd;
322 struct
323 {
324 __IO uint32_t rspcmd : 6; /* [5:0] */
325 __IO uint32_t reserved1 : 26;/* [31:6] */
326 } rspcmd_bit;
327 };
328
332 union
333 {
334 __IO uint32_t rsp1;
335 struct
336 {
337 __IO uint32_t cardsts1 : 32;/* [31:0] */
338 } rsp1_bit;
339 };
340
344 union
345 {
346 __IO uint32_t rsp2;
347 struct
348 {
349 __IO uint32_t cardsts2 : 32;/* [31:0] */
350 } rsp2_bit;
351 };
352
356 union
357 {
358 __IO uint32_t rsp3;
359 struct
360 {
361 __IO uint32_t cardsts3 : 32;/* [31:0] */
362 } rsp3_bit;
363 };
364
368 union
369 {
370 __IO uint32_t rsp4;
371 struct
372 {
373 __IO uint32_t cardsts4 : 32;/* [31:0] */
374 } rsp4_bit;
375 };
376
380 union
381 {
382 __IO uint32_t dttmr;
383 struct
384 {
385 __IO uint32_t timeout : 32;/* [31:0] */
386 } dttmr_bit;
387 };
388
392 union
393 {
394 __IO uint32_t dtlen;
395 struct
396 {
397 __IO uint32_t dtlen : 25;/* [24:0] */
398 __IO uint32_t reserved1 : 7; /* [31:25] */
399 } dtlen_bit;
400 };
401
405 union
406 {
407 __IO uint32_t dtctrl;
408 struct
409 {
410 __IO uint32_t tfren : 1; /* [0] */
411 __IO uint32_t tfrdir : 1; /* [1] */
412 __IO uint32_t tfrmode : 1; /* [2] */
413 __IO uint32_t dmaen : 1; /* [3] */
414 __IO uint32_t blksize : 4; /* [7:4] */
415 __IO uint32_t rdwtstart : 1; /* [8] */
416 __IO uint32_t rdwtstop : 1; /* [9] */
417 __IO uint32_t rdwtmode : 1; /* [10] */
418 __IO uint32_t ioen : 1; /* [11] */
419 __IO uint32_t reserved1 : 20;/* [31:12] */
420 } dtctrl_bit;
421 };
422
426 union
427 {
428 __IO uint32_t dtcnt;
429 struct
430 {
431 __IO uint32_t cnt : 25;/* [24:0] */
432 __IO uint32_t reserved1 : 7; /* [31:25] */
433 } dtcnt_bit;
434 };
435
439 union
440 {
441 __IO uint32_t sts;
442 struct
443 {
444 __IO uint32_t cmdfail : 1; /* [0] */
445 __IO uint32_t dtfail : 1; /* [1] */
446 __IO uint32_t cmdtimeout : 1; /* [2] */
447 __IO uint32_t dttimeout : 1; /* [3] */
448 __IO uint32_t txerru : 1; /* [4] */
449 __IO uint32_t rxerro : 1; /* [5] */
450 __IO uint32_t cmdrspcmpl : 1; /* [6] */
451 __IO uint32_t cmdcmpl : 1; /* [7] */
452 __IO uint32_t dtcmpl : 1; /* [8] */
453 __IO uint32_t sbiterr : 1; /* [9] */
454 __IO uint32_t dtblkcmpl : 1; /* [10] */
455 __IO uint32_t docmd : 1; /* [11] */
456 __IO uint32_t dotx : 1; /* [12] */
457 __IO uint32_t dorx : 1; /* [13] */
458 __IO uint32_t txbufh : 1; /* [14] */
459 __IO uint32_t rxbufh : 1; /* [15] */
460 __IO uint32_t txbuff : 1; /* [16] */
461 __IO uint32_t rxbuff : 1; /* [17] */
462 __IO uint32_t txbufe : 1; /* [18] */
463 __IO uint32_t rxbufe : 1; /* [19] */
464 __IO uint32_t txbuf : 1; /* [20] */
465 __IO uint32_t rxbuf : 1; /* [21] */
466 __IO uint32_t ioif : 1; /* [22] */
467 __IO uint32_t reserved1 : 9; /* [31:23] */
468 } sts_bit;
469 };
470
474 union
475 {
476 __IO uint32_t intclr;
477 struct
478 {
479 __IO uint32_t cmdfail : 1; /* [0] */
480 __IO uint32_t dtfail : 1; /* [1] */
481 __IO uint32_t cmdtimeout : 1; /* [2] */
482 __IO uint32_t dttimeout : 1; /* [3] */
483 __IO uint32_t txerru : 1; /* [4] */
484 __IO uint32_t rxerro : 1; /* [5] */
485 __IO uint32_t cmdrspcmpl : 1; /* [6] */
486 __IO uint32_t cmdcmpl : 1; /* [7] */
487 __IO uint32_t dtcmpl : 1; /* [8] */
488 __IO uint32_t sbiterr : 1; /* [9] */
489 __IO uint32_t dtblkcmpl : 1; /* [10] */
490 __IO uint32_t reserved1 : 11;/* [21:11] */
491 __IO uint32_t ioif : 1; /* [22] */
492 __IO uint32_t reserved2 : 9; /* [31:23] */
493 } intclr_bit;
494 };
495
499 union
500 {
501 __IO uint32_t inten;
502 struct
503 {
504 __IO uint32_t cmdfailien : 1; /* [0] */
505 __IO uint32_t dtfailien : 1; /* [1] */
506 __IO uint32_t cmdtimeoutien : 1; /* [2] */
507 __IO uint32_t dttimeoutien : 1; /* [3] */
508 __IO uint32_t txerruien : 1; /* [4] */
509 __IO uint32_t rxerroien : 1; /* [5] */
510 __IO uint32_t cmdrspcmplien : 1; /* [6] */
511 __IO uint32_t cmdcmplien : 1; /* [7] */
512 __IO uint32_t dtcmplien : 1; /* [8] */
513 __IO uint32_t sbiterrien : 1; /* [9] */
514 __IO uint32_t dtblkcmplien : 1; /* [10] */
515 __IO uint32_t docmdien : 1; /* [11] */
516 __IO uint32_t dotxien : 1; /* [12] */
517 __IO uint32_t dorxien : 1; /* [13] */
518 __IO uint32_t txbufhien : 1; /* [14] */
519 __IO uint32_t rxbufhien : 1; /* [15] */
520 __IO uint32_t txbuffien : 1; /* [16] */
521 __IO uint32_t rxbuffien : 1; /* [17] */
522 __IO uint32_t txbufeien : 1; /* [18] */
523 __IO uint32_t rxbufeien : 1; /* [19] */
524 __IO uint32_t txbufien : 1; /* [20] */
525 __IO uint32_t rxbufien : 1; /* [21] */
526 __IO uint32_t ioifien : 1; /* [22] */
527 __IO uint32_t reserved1 : 9; /* [31:23] */
528 } inten_bit;
529 };
530
534 __IO uint32_t reserved1[2];
535
539 union
540 {
541 __IO uint32_t bufcnt;
542 struct
543 {
544 __IO uint32_t cnt : 24;/* [23:0] */
545 __IO uint32_t reserved1 : 8; /* [31:24] */
546 } bufcnt_bit;
547 };
548
552 __IO uint32_t reserved2[13];
553
557 union
558 {
559 __IO uint32_t buf;
560 struct
561 {
562 __IO uint32_t dt : 32;/* [31:0] */
563 } buf_bit;
564 };
565
566} sdio_type;
567
572#define SDIO1 ((sdio_type *) SDIO1_BASE)
573#define SDIO2 ((sdio_type *) SDIO2_BASE)
574
579void sdio_reset(sdio_type *sdio_x);
580void sdio_power_set(sdio_type *sdio_x, sdio_power_state_type power_state);
581 sdio_power_state_type sdio_power_status_get(sdio_type *sdio_x);
582void sdio_clock_config(sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg);
583void sdio_bus_width_config(sdio_type *sdio_x, sdio_bus_width_type width);
584void sdio_clock_bypass(sdio_type *sdio_x, confirm_state new_state);
585void sdio_power_saving_mode_enable(sdio_type *sdio_x, confirm_state new_state);
586void sdio_flow_control_enable(sdio_type *sdio_x, confirm_state new_state);
587void sdio_clock_enable(sdio_type *sdio_x, confirm_state new_state);
588void sdio_dma_enable(sdio_type *sdio_x, confirm_state new_state);
589void sdio_interrupt_enable(sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state);
590 flag_status sdio_flag_get(sdio_type *sdio_x, uint32_t flag);
591void sdio_flag_clear(sdio_type *sdio_x, uint32_t flag);
592void sdio_command_config(sdio_type *sdio_x, sdio_command_struct_type *command_struct);
593void sdio_command_state_machine_enable(sdio_type *sdio_x, confirm_state new_state);
594uint8_t sdio_command_response_get(sdio_type *sdio_x);
595uint32_t sdio_response_get(sdio_type *sdio_x, sdio_rsp_index_type reg_index);
596void sdio_data_config(sdio_type *sdio_x, sdio_data_struct_type *data_struct);
597void sdio_data_state_machine_enable(sdio_type *sdio_x, confirm_state new_state);
598uint32_t sdio_data_counter_get(sdio_type *sdio_x);
599uint32_t sdio_data_read(sdio_type *sdio_x);
600uint32_t sdio_buffer_counter_get(sdio_type *sdio_x);
601void sdio_data_write(sdio_type *sdio_x, uint32_t data);
602void sdio_read_wait_mode_set(sdio_type *sdio_x, sdio_read_wait_mode_type mode);
603void sdio_read_wait_start(sdio_type *sdio_x, confirm_state new_state);
604void sdio_read_wait_stop(sdio_type *sdio_x, confirm_state new_state);
605void sdio_io_function_enable(sdio_type *sdio_x, confirm_state new_state);
606void sdio_io_suspend_command_set(sdio_type *sdio_x, confirm_state new_state);
607
620#ifdef __cplusplus
621}
622#endif
623
624#endif
at32f435_437.h
at32f435_437 header file
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
sdio_command_config
void sdio_command_config(sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command.
Definition: at32f435_437_sdio.c:329
sdio_data_write
void sdio_data_write(sdio_type *sdio_x, uint32_t data)
write one word data to fifo.
Definition: at32f435_437_sdio.c:490
sdio_io_suspend_command_set
void sdio_io_suspend_command_set(sdio_type *sdio_x, confirm_state new_state)
enable or disable sd i/o suspend command sending.
Definition: at32f435_437_sdio.c:558
sdio_data_config
void sdio_data_config(sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data.
Definition: at32f435_437_sdio.c:416
sdio_data_read
uint32_t sdio_data_read(sdio_type *sdio_x)
read a word data from sdio fifo.
Definition: at32f435_437_sdio.c:465
sdio_io_function_enable
void sdio_io_function_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable the sd i/o function.
Definition: at32f435_437_sdio.c:545
sdio_command_state_machine_enable
void sdio_command_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM).
Definition: at32f435_437_sdio.c:352
sdio_clock_bypass
void sdio_clock_bypass(sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss
Definition: at32f435_437_sdio.c:141
sdio_flow_control_enable
void sdio_flow_control_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control.
Definition: at32f435_437_sdio.c:168
sdio_power_set
void sdio_power_set(sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller
Definition: at32f435_437_sdio.c:75
sdio_clock_config
void sdio_clock_config(sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock
Definition: at32f435_437_sdio.c:104
sdio_bus_width_config
void sdio_bus_width_config(sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width
Definition: at32f435_437_sdio.c:128
sdio_read_wait_stop
void sdio_read_wait_stop(sdio_type *sdio_x, confirm_state new_state)
enable or disable to stop sd i/o read wait operation.
Definition: at32f435_437_sdio.c:532
sdio_interrupt_enable
void sdio_interrupt_enable(sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt.
Definition: at32f435_437_sdio.c:232
sdio_flag_clear
void sdio_flag_clear(sdio_type *sdio_x, uint32_t flag)
clear sdio flag.
Definition: at32f435_437_sdio.c:315
sdio_power_status_get
sdio_power_state_type sdio_power_status_get(sdio_type *sdio_x)
get power status.
Definition: at32f435_437_sdio.c:87
sdio_response_get
uint32_t sdio_response_get(sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command.
Definition: at32f435_437_sdio.c:383
sdio_data_state_machine_enable
void sdio_data_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM).
Definition: at32f435_437_sdio.c:441
sdio_power_saving_mode_enable
void sdio_power_saving_mode_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle.
Definition: at32f435_437_sdio.c:155
sdio_flag_get
flag_status sdio_flag_get(sdio_type *sdio_x, uint32_t flag)
get sdio flag.
Definition: at32f435_437_sdio.c:278
sdio_dma_enable
void sdio_dma_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable dma.
Definition: at32f435_437_sdio.c:194
sdio_data_counter_get
uint32_t sdio_data_counter_get(sdio_type *sdio_x)
get the number of remaining data bytes to be transferred.
Definition: at32f435_437_sdio.c:453
sdio_buffer_counter_get
uint32_t sdio_buffer_counter_get(sdio_type *sdio_x)
get the number of words left to be written to or read from fifo..
Definition: at32f435_437_sdio.c:477
sdio_read_wait_start
void sdio_read_wait_start(sdio_type *sdio_x, confirm_state new_state)
enable or disable to start sd i/o read wait operation.
Definition: at32f435_437_sdio.c:519
sdio_reset
void sdio_reset(sdio_type *sdio_x)
reset the sdio register
Definition: at32f435_437_sdio.c:51
sdio_read_wait_mode_set
void sdio_read_wait_mode_set(sdio_type *sdio_x, sdio_read_wait_mode_type mode)
set the read wait mode.
Definition: at32f435_437_sdio.c:506
sdio_clock_enable
void sdio_clock_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output.
Definition: at32f435_437_sdio.c:181
sdio_command_response_get
uint8_t sdio_command_response_get(sdio_type *sdio_x)
get command index of last command for which response received.
Definition: at32f435_437_sdio.c:365
sdio_wait_type
sdio_wait_type
sdio wait type
Definition: at32f435_437_sdio.h:159
sdio_reponse_type
sdio_reponse_type
sdio response type
Definition: at32f435_437_sdio.h:149
sdio_read_wait_mode_type
sdio_read_wait_mode_type
sdio read wait mode
Definition: at32f435_437_sdio.h:220
sdio_edge_phase_type
sdio_edge_phase_type
sdio edge phase
Definition: at32f435_437_sdio.h:130
sdio_transfer_direction_type
sdio_transfer_direction_type
sdio data transfer direction
Definition: at32f435_437_sdio.h:211
sdio_power_state_type
sdio_power_state_type
sdio power state
Definition: at32f435_437_sdio.h:121
sdio_transfer_mode_type
sdio_transfer_mode_type
sdio data transfer mode
Definition: at32f435_437_sdio.h:202
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f435_437_sdio.h:139
sdio_rsp_index_type
sdio_rsp_index_type
sdio response register index
Definition: at32f435_437_sdio.h:169
sdio_block_size_type
sdio_block_size_type
sdio data block size
Definition: at32f435_437_sdio.h:180
SDIO_WAIT_FOR_NO
@ SDIO_WAIT_FOR_NO
Definition: at32f435_437_sdio.h:160
SDIO_WAIT_FOR_PEND
@ SDIO_WAIT_FOR_PEND
Definition: at32f435_437_sdio.h:162
SDIO_WAIT_FOR_INT
@ SDIO_WAIT_FOR_INT
Definition: at32f435_437_sdio.h:161
SDIO_RESPONSE_LONG
@ SDIO_RESPONSE_LONG
Definition: at32f435_437_sdio.h:152
SDIO_RESPONSE_SHORT
@ SDIO_RESPONSE_SHORT
Definition: at32f435_437_sdio.h:151
SDIO_RESPONSE_NO
@ SDIO_RESPONSE_NO
Definition: at32f435_437_sdio.h:150
SDIO_READ_WAIT_CONTROLLED_BY_CK
@ SDIO_READ_WAIT_CONTROLLED_BY_CK
Definition: at32f435_437_sdio.h:222
SDIO_READ_WAIT_CONTROLLED_BY_D2
@ SDIO_READ_WAIT_CONTROLLED_BY_D2
Definition: at32f435_437_sdio.h:221
SDIO_CLOCK_EDGE_FALLING
@ SDIO_CLOCK_EDGE_FALLING
Definition: at32f435_437_sdio.h:132
SDIO_CLOCK_EDGE_RISING
@ SDIO_CLOCK_EDGE_RISING
Definition: at32f435_437_sdio.h:131
SDIO_DATA_TRANSFER_TO_CARD
@ SDIO_DATA_TRANSFER_TO_CARD
Definition: at32f435_437_sdio.h:212
SDIO_DATA_TRANSFER_TO_CONTROLLER
@ SDIO_DATA_TRANSFER_TO_CONTROLLER
Definition: at32f435_437_sdio.h:213
SDIO_POWER_OFF
@ SDIO_POWER_OFF
Definition: at32f435_437_sdio.h:122
SDIO_POWER_ON
@ SDIO_POWER_ON
Definition: at32f435_437_sdio.h:123
SDIO_DATA_BLOCK_TRANSFER
@ SDIO_DATA_BLOCK_TRANSFER
Definition: at32f435_437_sdio.h:203
SDIO_DATA_STREAM_TRANSFER
@ SDIO_DATA_STREAM_TRANSFER
Definition: at32f435_437_sdio.h:204
SDIO_BUS_WIDTH_D8
@ SDIO_BUS_WIDTH_D8
Definition: at32f435_437_sdio.h:142
SDIO_BUS_WIDTH_D1
@ SDIO_BUS_WIDTH_D1
Definition: at32f435_437_sdio.h:140
SDIO_BUS_WIDTH_D4
@ SDIO_BUS_WIDTH_D4
Definition: at32f435_437_sdio.h:141
SDIO_RSP3_INDEX
@ SDIO_RSP3_INDEX
Definition: at32f435_437_sdio.h:172
SDIO_RSP2_INDEX
@ SDIO_RSP2_INDEX
Definition: at32f435_437_sdio.h:171
SDIO_RSP4_INDEX
@ SDIO_RSP4_INDEX
Definition: at32f435_437_sdio.h:173
SDIO_RSP1_INDEX
@ SDIO_RSP1_INDEX
Definition: at32f435_437_sdio.h:170
SDIO_DATA_BLOCK_SIZE_8B
@ SDIO_DATA_BLOCK_SIZE_8B
Definition: at32f435_437_sdio.h:184
SDIO_DATA_BLOCK_SIZE_128B
@ SDIO_DATA_BLOCK_SIZE_128B
Definition: at32f435_437_sdio.h:188
SDIO_DATA_BLOCK_SIZE_2048B
@ SDIO_DATA_BLOCK_SIZE_2048B
Definition: at32f435_437_sdio.h:192
SDIO_DATA_BLOCK_SIZE_4096B
@ SDIO_DATA_BLOCK_SIZE_4096B
Definition: at32f435_437_sdio.h:193
SDIO_DATA_BLOCK_SIZE_16B
@ SDIO_DATA_BLOCK_SIZE_16B
Definition: at32f435_437_sdio.h:185
SDIO_DATA_BLOCK_SIZE_1024B
@ SDIO_DATA_BLOCK_SIZE_1024B
Definition: at32f435_437_sdio.h:191
SDIO_DATA_BLOCK_SIZE_64B
@ SDIO_DATA_BLOCK_SIZE_64B
Definition: at32f435_437_sdio.h:187
SDIO_DATA_BLOCK_SIZE_32B
@ SDIO_DATA_BLOCK_SIZE_32B
Definition: at32f435_437_sdio.h:186
SDIO_DATA_BLOCK_SIZE_8192B
@ SDIO_DATA_BLOCK_SIZE_8192B
Definition: at32f435_437_sdio.h:194
SDIO_DATA_BLOCK_SIZE_1B
@ SDIO_DATA_BLOCK_SIZE_1B
Definition: at32f435_437_sdio.h:181
SDIO_DATA_BLOCK_SIZE_512B
@ SDIO_DATA_BLOCK_SIZE_512B
Definition: at32f435_437_sdio.h:190
SDIO_DATA_BLOCK_SIZE_2B
@ SDIO_DATA_BLOCK_SIZE_2B
Definition: at32f435_437_sdio.h:182
SDIO_DATA_BLOCK_SIZE_256B
@ SDIO_DATA_BLOCK_SIZE_256B
Definition: at32f435_437_sdio.h:189
SDIO_DATA_BLOCK_SIZE_4B
@ SDIO_DATA_BLOCK_SIZE_4B
Definition: at32f435_437_sdio.h:183
SDIO_DATA_BLOCK_SIZE_16384B
@ SDIO_DATA_BLOCK_SIZE_16384B
Definition: at32f435_437_sdio.h:195
sdio_command_struct_type
sdio command structure
Definition: at32f435_437_sdio.h:229
sdio_command_struct_type::cmd_index
uint8_t cmd_index
Definition: at32f435_437_sdio.h:231
sdio_command_struct_type::argument
uint32_t argument
Definition: at32f435_437_sdio.h:230
sdio_command_struct_type::wait_type
sdio_wait_type wait_type
Definition: at32f435_437_sdio.h:233
sdio_command_struct_type::rsp_type
sdio_reponse_type rsp_type
Definition: at32f435_437_sdio.h:232
sdio_data_struct_type
sdio data structure
Definition: at32f435_437_sdio.h:240
sdio_data_struct_type::block_size
sdio_block_size_type block_size
Definition: at32f435_437_sdio.h:243
sdio_data_struct_type::transfer_direction
sdio_transfer_direction_type transfer_direction
Definition: at32f435_437_sdio.h:245
sdio_data_struct_type::timeout
uint32_t timeout
Definition: at32f435_437_sdio.h:241
sdio_data_struct_type::transfer_mode
sdio_transfer_mode_type transfer_mode
Definition: at32f435_437_sdio.h:244
sdio_data_struct_type::data_length
uint32_t data_length
Definition: at32f435_437_sdio.h:242
sdio_type
type define sdio register all
Definition: at32f435_437_sdio.h:252
sdio_type::ps
__IO uint32_t ps
Definition: at32f435_437_sdio.h:261
sdio_type::dorx
__IO uint32_t dorx
Definition: at32f435_437_sdio.h:457
sdio_type::sbiterr
__IO uint32_t sbiterr
Definition: at32f435_437_sdio.h:453
sdio_type::dtlen
__IO uint32_t dtlen
Definition: at32f435_437_sdio.h:394
sdio_type::intclr
__IO uint32_t intclr
Definition: at32f435_437_sdio.h:476
sdio_type::rdwtstart
__IO uint32_t rdwtstart
Definition: at32f435_437_sdio.h:415
sdio_type::rdwtstop
__IO uint32_t rdwtstop
Definition: at32f435_437_sdio.h:416
sdio_type::rspwt
__IO uint32_t rspwt
Definition: at32f435_437_sdio.h:307
sdio_type::rxbuf
__IO uint32_t rxbuf
Definition: at32f435_437_sdio.h:465
sdio_type::hfcen
__IO uint32_t hfcen
Definition: at32f435_437_sdio.h:280
sdio_type::rxbufeien
__IO uint32_t rxbufeien
Definition: at32f435_437_sdio.h:523
sdio_type::tfrmode
__IO uint32_t tfrmode
Definition: at32f435_437_sdio.h:412
sdio_type::cmdtimeout
__IO uint32_t cmdtimeout
Definition: at32f435_437_sdio.h:446
sdio_type::clkegs
__IO uint32_t clkegs
Definition: at32f435_437_sdio.h:279
sdio_type::cmdcmplien
__IO uint32_t cmdcmplien
Definition: at32f435_437_sdio.h:511
sdio_type::cmdcmpl
__IO uint32_t cmdcmpl
Definition: at32f435_437_sdio.h:451
sdio_type::dtfailien
__IO uint32_t dtfailien
Definition: at32f435_437_sdio.h:505
sdio_type::rxbufhien
__IO uint32_t rxbufhien
Definition: at32f435_437_sdio.h:519
sdio_type::tfrdir
__IO uint32_t tfrdir
Definition: at32f435_437_sdio.h:411
sdio_type::tfren
__IO uint32_t tfren
Definition: at32f435_437_sdio.h:410
sdio_type::dttmr
__IO uint32_t dttmr
Definition: at32f435_437_sdio.h:382
sdio_type::reserved1
__IO uint32_t reserved1
sdio reserved1 register, offset:0x40~0x44
Definition: at32f435_437_sdio.h:262
sdio_type::cnt
__IO uint32_t cnt
Definition: at32f435_437_sdio.h:431
sdio_type::cardsts4
__IO uint32_t cardsts4
Definition: at32f435_437_sdio.h:373
sdio_type::cmdfail
__IO uint32_t cmdfail
Definition: at32f435_437_sdio.h:444
sdio_type::txbufhien
__IO uint32_t txbufhien
Definition: at32f435_437_sdio.h:518
sdio_type::txbuffien
__IO uint32_t txbuffien
Definition: at32f435_437_sdio.h:520
sdio_type::rxbufe
__IO uint32_t rxbufe
Definition: at32f435_437_sdio.h:463
sdio_type::dtblkcmpl
__IO uint32_t dtblkcmpl
Definition: at32f435_437_sdio.h:454
sdio_type::inten
__IO uint32_t inten
Definition: at32f435_437_sdio.h:501
sdio_type::dtcmpl
__IO uint32_t dtcmpl
Definition: at32f435_437_sdio.h:452
sdio_type::docmd
__IO uint32_t docmd
Definition: at32f435_437_sdio.h:455
sdio_type::pndwt
__IO uint32_t pndwt
Definition: at32f435_437_sdio.h:309
sdio_type::cmdctrl
__IO uint32_t cmdctrl
Definition: at32f435_437_sdio.h:303
sdio_type::dtcmplien
__IO uint32_t dtcmplien
Definition: at32f435_437_sdio.h:512
sdio_type::clkoen
__IO uint32_t clkoen
Definition: at32f435_437_sdio.h:275
sdio_type::ioen
__IO uint32_t ioen
Definition: at32f435_437_sdio.h:418
sdio_type::bufcnt
__IO uint32_t bufcnt
Definition: at32f435_437_sdio.h:541
sdio_type::intwt
__IO uint32_t intwt
Definition: at32f435_437_sdio.h:308
sdio_type::rsp2
__IO uint32_t rsp2
Definition: at32f435_437_sdio.h:346
sdio_type::dtctrl
__IO uint32_t dtctrl
Definition: at32f435_437_sdio.h:407
sdio_type::dtfail
__IO uint32_t dtfail
Definition: at32f435_437_sdio.h:445
sdio_type::docmdien
__IO uint32_t docmdien
Definition: at32f435_437_sdio.h:515
sdio_type::dotxien
__IO uint32_t dotxien
Definition: at32f435_437_sdio.h:516
sdio_type::dotx
__IO uint32_t dotx
Definition: at32f435_437_sdio.h:456
sdio_type::rxerroien
__IO uint32_t rxerroien
Definition: at32f435_437_sdio.h:509
sdio_type::ccsmen
__IO uint32_t ccsmen
Definition: at32f435_437_sdio.h:310
sdio_type::txerruien
__IO uint32_t txerruien
Definition: at32f435_437_sdio.h:508
sdio_type::dttimeoutien
__IO uint32_t dttimeoutien
Definition: at32f435_437_sdio.h:507
sdio_type::pwrsven
__IO uint32_t pwrsven
Definition: at32f435_437_sdio.h:276
sdio_type::cmdidx
__IO uint32_t cmdidx
Definition: at32f435_437_sdio.h:306
sdio_type::cardsts3
__IO uint32_t cardsts3
Definition: at32f435_437_sdio.h:361
sdio_type::cardsts1
__IO uint32_t cardsts1
Definition: at32f435_437_sdio.h:337
sdio_type::pwrctrl
__IO uint32_t pwrctrl
Definition: at32f435_437_sdio.h:258
sdio_type::ioifien
__IO uint32_t ioifien
Definition: at32f435_437_sdio.h:526
sdio_type::dmaen
__IO uint32_t dmaen
Definition: at32f435_437_sdio.h:413
sdio_type::reserved2
__IO uint32_t reserved2
sdio reserved2 register, offset:0x4C~0x7C
Definition: at32f435_437_sdio.h:492
sdio_type::dtblkcmplien
__IO uint32_t dtblkcmplien
Definition: at32f435_437_sdio.h:514
sdio_type::rxbuffien
__IO uint32_t rxbuffien
Definition: at32f435_437_sdio.h:521
sdio_type::txbufh
__IO uint32_t txbufh
Definition: at32f435_437_sdio.h:458
sdio_type::sts
__IO uint32_t sts
Definition: at32f435_437_sdio.h:441
sdio_type::blksize
__IO uint32_t blksize
Definition: at32f435_437_sdio.h:414
sdio_type::cardsts2
__IO uint32_t cardsts2
Definition: at32f435_437_sdio.h:349
sdio_type::rdwtmode
__IO uint32_t rdwtmode
Definition: at32f435_437_sdio.h:417
sdio_type::txbufeien
__IO uint32_t txbufeien
Definition: at32f435_437_sdio.h:522
sdio_type::ioif
__IO uint32_t ioif
Definition: at32f435_437_sdio.h:466
sdio_type::cmdrspcmplien
__IO uint32_t cmdrspcmplien
Definition: at32f435_437_sdio.h:510
sdio_type::rxbufien
__IO uint32_t rxbufien
Definition: at32f435_437_sdio.h:525
sdio_type::dttimeout
__IO uint32_t dttimeout
Definition: at32f435_437_sdio.h:447
sdio_type::rxbufh
__IO uint32_t rxbufh
Definition: at32f435_437_sdio.h:459
sdio_type::txbufien
__IO uint32_t txbufien
Definition: at32f435_437_sdio.h:524
sdio_type::rsp1
__IO uint32_t rsp1
Definition: at32f435_437_sdio.h:334
sdio_type::rxbuff
__IO uint32_t rxbuff
Definition: at32f435_437_sdio.h:461
sdio_type::rsp4
__IO uint32_t rsp4
Definition: at32f435_437_sdio.h:370
sdio_type::bypsen
__IO uint32_t bypsen
Definition: at32f435_437_sdio.h:277
sdio_type::txbufe
__IO uint32_t txbufe
Definition: at32f435_437_sdio.h:462
sdio_type::cmdfailien
__IO uint32_t cmdfailien
Definition: at32f435_437_sdio.h:504
sdio_type::buf
__IO uint32_t buf
Definition: at32f435_437_sdio.h:559
sdio_type::clkdiv_l
__IO uint32_t clkdiv_l
Definition: at32f435_437_sdio.h:274
sdio_type::txerru
__IO uint32_t txerru
Definition: at32f435_437_sdio.h:448
sdio_type::dorxien
__IO uint32_t dorxien
Definition: at32f435_437_sdio.h:517
sdio_type::dt
__IO uint32_t dt
Definition: at32f435_437_sdio.h:562
sdio_type::rspcmd
__IO uint32_t rspcmd
Definition: at32f435_437_sdio.h:321
sdio_type::argu
__IO uint32_t argu
Definition: at32f435_437_sdio.h:291
sdio_type::timeout
__IO uint32_t timeout
Definition: at32f435_437_sdio.h:385
sdio_type::cmdtimeoutien
__IO uint32_t cmdtimeoutien
Definition: at32f435_437_sdio.h:506
sdio_type::busws
__IO uint32_t busws
Definition: at32f435_437_sdio.h:278
sdio_type::dtcnt
__IO uint32_t dtcnt
Definition: at32f435_437_sdio.h:428
sdio_type::clkdiv_h
__IO uint32_t clkdiv_h
Definition: at32f435_437_sdio.h:281
sdio_type::iosusp
__IO uint32_t iosusp
Definition: at32f435_437_sdio.h:311
sdio_type::txbuff
__IO uint32_t txbuff
Definition: at32f435_437_sdio.h:460
sdio_type::cmdrspcmpl
__IO uint32_t cmdrspcmpl
Definition: at32f435_437_sdio.h:450
sdio_type::txbuf
__IO uint32_t txbuf
Definition: at32f435_437_sdio.h:464
sdio_type::clkctrl
__IO uint32_t clkctrl
Definition: at32f435_437_sdio.h:271
sdio_type::sbiterrien
__IO uint32_t sbiterrien
Definition: at32f435_437_sdio.h:513
sdio_type::rsp3
__IO uint32_t rsp3
Definition: at32f435_437_sdio.h:358
sdio_type::rxerro
__IO uint32_t rxerro
Definition: at32f435_437_sdio.h:449


AT32F435/437 Firmwary Library: at32f435_437_spi.c Source File

  • libraries
  • drivers
  • src
at32f435_437_spi.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef SPI_MODULE_ENABLED
39
51void spi_i2s_reset(spi_type *spi_x)
52{
53 if(spi_x == SPI1)
54 {
55 crm_periph_reset(CRM_SPI1_PERIPH_RESET, TRUE);
56 crm_periph_reset(CRM_SPI1_PERIPH_RESET, FALSE);
57 }
58 else if(spi_x == SPI2)
59 {
60 crm_periph_reset(CRM_SPI2_PERIPH_RESET, TRUE);
61 crm_periph_reset(CRM_SPI2_PERIPH_RESET, FALSE);
62 }
63 else if(spi_x == SPI3)
64 {
65 crm_periph_reset(CRM_SPI3_PERIPH_RESET, TRUE);
66 crm_periph_reset(CRM_SPI3_PERIPH_RESET, FALSE);
67 }
68 else if(spi_x == SPI4)
69 {
70 crm_periph_reset(CRM_SPI4_PERIPH_RESET, TRUE);
71 crm_periph_reset(CRM_SPI4_PERIPH_RESET, FALSE);
72 }
73}
74
81void spi_default_para_init(spi_init_type* spi_init_struct)
82{
83 spi_init_struct->transmission_mode = SPI_TRANSMIT_FULL_DUPLEX;
84 spi_init_struct->master_slave_mode = SPI_MODE_SLAVE;
85 spi_init_struct->mclk_freq_division = SPI_MCLK_DIV_2;
86 spi_init_struct->first_bit_transmission = SPI_FIRST_BIT_MSB;
87 spi_init_struct->frame_bit_num = SPI_FRAME_8BIT;
88 spi_init_struct->clock_polarity = SPI_CLOCK_POLARITY_LOW;
89 spi_init_struct->clock_phase = SPI_CLOCK_PHASE_1EDGE;
90 spi_init_struct->cs_mode_selection = SPI_CS_SOFTWARE_MODE;
91}
92
101void spi_init(spi_type* spi_x, spi_init_type* spi_init_struct)
102{
103 spi_x->i2sctrl_bit.i2smsel = FALSE;
104 if(spi_init_struct->transmission_mode == SPI_TRANSMIT_FULL_DUPLEX)
105 {
106 spi_x->ctrl1_bit.slben = FALSE;
107 spi_x->ctrl1_bit.slbtd = FALSE;
108 spi_x->ctrl1_bit.ora = FALSE;
109 }
110 else if(spi_init_struct->transmission_mode == SPI_TRANSMIT_SIMPLEX_RX)
111 {
112 spi_x->ctrl1_bit.slben = FALSE;
113 spi_x->ctrl1_bit.slbtd = FALSE;
114 spi_x->ctrl1_bit.ora = TRUE;
115 }
116 else if(spi_init_struct->transmission_mode == SPI_TRANSMIT_HALF_DUPLEX_RX)
117 {
118 spi_x->ctrl1_bit.slben = TRUE;
119 spi_x->ctrl1_bit.slbtd = FALSE;
120 spi_x->ctrl1_bit.ora = FALSE;
121 }
122 else if(spi_init_struct->transmission_mode == SPI_TRANSMIT_HALF_DUPLEX_TX)
123 {
124 spi_x->ctrl1_bit.slben = TRUE;
125 spi_x->ctrl1_bit.slbtd = TRUE;
126 spi_x->ctrl1_bit.ora = FALSE;
127 }
128
129 spi_x->ctrl1_bit.swcsen = spi_init_struct->cs_mode_selection;
130 if((spi_init_struct->master_slave_mode == SPI_MODE_MASTER) && (spi_init_struct->cs_mode_selection == SPI_CS_SOFTWARE_MODE))
131 {
132 spi_x->ctrl1_bit.swcsil = TRUE;
133 }
134 else
135 {
136 spi_x->ctrl1_bit.swcsil = FALSE;
137 }
138 spi_x->ctrl1_bit.msten = spi_init_struct->master_slave_mode;
139
140 if(spi_init_struct->mclk_freq_division <= SPI_MCLK_DIV_256)
141 {
142 spi_x->ctrl2_bit.mdiv3en = FALSE;
143 spi_x->ctrl2_bit.mdiv_h = FALSE;
144 spi_x->ctrl1_bit.mdiv_l = spi_init_struct->mclk_freq_division;
145 }
146 else if(spi_init_struct->mclk_freq_division == SPI_MCLK_DIV_3)
147 {
148 spi_x->ctrl2_bit.mdiv3en = TRUE;
149 spi_x->ctrl2_bit.mdiv_h = FALSE;
150 spi_x->ctrl1_bit.mdiv_l = 0;
151 }
152 else
153 {
154 spi_x->ctrl2_bit.mdiv3en = FALSE;
155 spi_x->ctrl2_bit.mdiv_h = TRUE;
156 spi_x->ctrl1_bit.mdiv_l = spi_init_struct->mclk_freq_division & 0x7;
157 }
158
159 spi_x->ctrl1_bit.ltf = spi_init_struct->first_bit_transmission;
160 spi_x->ctrl1_bit.fbn = spi_init_struct->frame_bit_num;
161 spi_x->ctrl1_bit.clkpol = spi_init_struct->clock_polarity;
162 spi_x->ctrl1_bit.clkpha = spi_init_struct->clock_phase;
163}
164
174void spi_ti_mode_enable(spi_type* spi_x, confirm_state new_state)
175{
176 spi_x->ctrl2_bit.tien = new_state;
177}
178
186void spi_crc_next_transmit(spi_type* spi_x)
187{
188 spi_x->ctrl1_bit.ntc = TRUE;
189}
190
199void spi_crc_polynomial_set(spi_type* spi_x, uint16_t crc_poly)
200{
201 spi_x->cpoly_bit.cpoly = crc_poly;
202}
203
211uint16_t spi_crc_polynomial_get(spi_type* spi_x)
212{
213 return spi_x->cpoly_bit.cpoly;
214}
215
225void spi_crc_enable(spi_type* spi_x, confirm_state new_state)
226{
227 spi_x->ctrl1_bit.ccen = new_state;
228}
229
240uint16_t spi_crc_value_get(spi_type* spi_x, spi_crc_direction_type crc_direction)
241{
242 if(crc_direction == SPI_CRC_RX)
243 return spi_x->rcrc_bit.rcrc;
244 else
245 return spi_x->tcrc_bit.tcrc;
246}
247
258void spi_hardware_cs_output_enable(spi_type* spi_x, confirm_state new_state)
259{
260 spi_x->ctrl2_bit.hwcsoe = new_state;
261}
262
276void spi_software_cs_internal_level_set(spi_type* spi_x, spi_software_cs_level_type level)
277{
278 spi_x->ctrl1_bit.swcsil = level;
279}
280
291void spi_frame_bit_num_set(spi_type* spi_x, spi_frame_bit_num_type bit_num)
292{
293 spi_x->ctrl1_bit.fbn = bit_num;
294}
295
307void spi_half_duplex_direction_set(spi_type* spi_x, spi_half_duplex_direction_type direction)
308{
309 spi_x->ctrl1_bit.slbtd = direction;
310}
311
321void spi_enable(spi_type* spi_x, confirm_state new_state)
322{
323 spi_x->ctrl1_bit.spien = new_state;
324}
325
332void i2s_default_para_init(i2s_init_type* i2s_init_struct)
333{
334 i2s_init_struct->operation_mode = I2S_MODE_SLAVE_TX;
335 i2s_init_struct->audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
336 i2s_init_struct->audio_sampling_freq = I2S_AUDIO_FREQUENCY_DEFAULT;
337 i2s_init_struct->data_channel_format = I2S_DATA_16BIT_CHANNEL_16BIT;
338 i2s_init_struct->clock_polarity = I2S_CLOCK_POLARITY_LOW;
339 i2s_init_struct->mclk_output_enable = FALSE;
340}
341
350void i2s_init(spi_type* spi_x, i2s_init_type* i2s_init_struct)
351{
352 crm_clocks_freq_type clocks_freq;
353 uint32_t i2s_sclk_index = 0;
354 uint32_t i2sdiv_index = 2, i2sodd_index = 0, frequency_index = 0;
355
356 /* i2s audio frequency config */
357 if(i2s_init_struct->audio_sampling_freq == I2S_AUDIO_FREQUENCY_DEFAULT)
358 {
359 i2sodd_index = 0;
360 i2sdiv_index = 2;
361 }
362 else
363 {
364 crm_clocks_freq_get(&clocks_freq);
365 i2s_sclk_index = clocks_freq.sclk_freq;
366 if((i2s_init_struct->audio_protocol == I2S_AUDIO_PROTOCOL_PCM_SHORT) || (i2s_init_struct->audio_protocol == I2S_AUDIO_PROTOCOL_PCM_LONG))
367 {
368 if(i2s_init_struct->mclk_output_enable == TRUE)
369 {
370 frequency_index = (((i2s_sclk_index / 128) * 10) / i2s_init_struct->audio_sampling_freq) + 5;
371 }
372 else
373 {
374 if(i2s_init_struct->data_channel_format == I2S_DATA_16BIT_CHANNEL_16BIT)
375 frequency_index = (((i2s_sclk_index / 16) * 10) / i2s_init_struct->audio_sampling_freq) + 5;
376 else
377 frequency_index = (((i2s_sclk_index / 32) * 10) / i2s_init_struct->audio_sampling_freq) + 5;
378 }
379 }
380 else
381 {
382 if(i2s_init_struct->mclk_output_enable == TRUE)
383 {
384 frequency_index = (((i2s_sclk_index / 256) * 10) / i2s_init_struct->audio_sampling_freq) + 5;
385 }
386 else
387 {
388 if(i2s_init_struct->data_channel_format == I2S_DATA_16BIT_CHANNEL_16BIT)
389 frequency_index = (((i2s_sclk_index / 32) * 10) / i2s_init_struct->audio_sampling_freq) + 5;
390 else
391 frequency_index = (((i2s_sclk_index / 64) * 10) / i2s_init_struct->audio_sampling_freq) + 5;
392 }
393 }
394 }
395 frequency_index = frequency_index / 10;
396 i2sodd_index = frequency_index & (uint16_t)0x0001;
397 i2sdiv_index = (frequency_index - i2sodd_index) / 2;
398 if((i2sdiv_index < 2) || (i2sdiv_index > 0x03FF))
399 {
400 i2sodd_index = 0;
401 i2sdiv_index = 2;
402 }
403 spi_x->i2sclk_bit.i2sodd = i2sodd_index;
404 if(i2sdiv_index > 0x00FF)
405 {
406 spi_x->i2sclk_bit.i2sdiv_h = (i2sdiv_index >> 8) & 0x0003;
407 spi_x->i2sclk_bit.i2sdiv_l = i2sdiv_index & 0x00FF;
408 }
409 else
410 {
411 spi_x->i2sclk_bit.i2sdiv_h = 0;
412 spi_x->i2sclk_bit.i2sdiv_l = i2sdiv_index;
413 }
414
415 /* i2s audio_protocol set*/
416 if(i2s_init_struct->audio_protocol == I2S_AUDIO_PROTOCOL_PCM_LONG)
417 {
418 spi_x->i2sctrl_bit.pcmfssel = 1;
419 spi_x->i2sctrl_bit.stdsel = 3;
420 }
421 else if(i2s_init_struct->audio_protocol == I2S_AUDIO_PROTOCOL_PCM_SHORT)
422 {
423 spi_x->i2sctrl_bit.pcmfssel = 0;
424 spi_x->i2sctrl_bit.stdsel = 3;
425 }
426 else if(i2s_init_struct->audio_protocol == I2S_AUDIO_PROTOCOL_LSB)
427 {
428 spi_x->i2sctrl_bit.pcmfssel = 0;
429 spi_x->i2sctrl_bit.stdsel = 2;
430 }
431 else if(i2s_init_struct->audio_protocol == I2S_AUDIO_PROTOCOL_MSB)
432 {
433 spi_x->i2sctrl_bit.pcmfssel = 0;
434 spi_x->i2sctrl_bit.stdsel = 1;
435 }
436 else if(i2s_init_struct->audio_protocol == I2S_AUDIO_PROTOCOL_PHILLIPS)
437 {
438 spi_x->i2sctrl_bit.pcmfssel = 0;
439 spi_x->i2sctrl_bit.stdsel = 0;
440 }
441
442 /* i2s data_channel_format set*/
443 if(i2s_init_struct->data_channel_format == I2S_DATA_16BIT_CHANNEL_16BIT)
444 {
445 spi_x->i2sctrl_bit.i2scbn = 0;
446 spi_x->i2sctrl_bit.i2sdbn = 0;
447 }
448 else if(i2s_init_struct->data_channel_format == I2S_DATA_16BIT_CHANNEL_32BIT)
449 {
450 spi_x->i2sctrl_bit.i2scbn = 1;
451 spi_x->i2sctrl_bit.i2sdbn = 0;
452 }
453 else if(i2s_init_struct->data_channel_format == I2S_DATA_24BIT_CHANNEL_32BIT)
454 {
455 spi_x->i2sctrl_bit.i2scbn = 1;
456 spi_x->i2sctrl_bit.i2sdbn = 1;
457 }
458 else if(i2s_init_struct->data_channel_format == I2S_DATA_32BIT_CHANNEL_32BIT)
459 {
460 spi_x->i2sctrl_bit.i2scbn = 1;
461 spi_x->i2sctrl_bit.i2sdbn = 2;
462 }
463
464 spi_x->i2sctrl_bit.i2sclkpol = i2s_init_struct->clock_polarity;
465 spi_x->i2sclk_bit.i2smclkoe = i2s_init_struct->mclk_output_enable;
466 spi_x->i2sctrl_bit.opersel = i2s_init_struct->operation_mode;
467 spi_x->i2sctrl_bit.i2smsel = TRUE;
468}
469
479void i2s_enable(spi_type* spi_x, confirm_state new_state)
480{
481 spi_x->i2sctrl_bit.i2sen = new_state;
482}
483
498void spi_i2s_interrupt_enable(spi_type* spi_x, uint32_t spi_i2s_int, confirm_state new_state)
499{
500 if(new_state != FALSE)
501 {
502 spi_x->ctrl2 |= spi_i2s_int;
503 }
504 else
505 {
506 spi_x->ctrl2 &= ~spi_i2s_int;
507 }
508}
509
519void spi_i2s_dma_transmitter_enable(spi_type* spi_x, confirm_state new_state)
520{
521 spi_x->ctrl2_bit.dmaten = new_state;
522}
523
533void spi_i2s_dma_receiver_enable(spi_type* spi_x, confirm_state new_state)
534{
535 spi_x->ctrl2_bit.dmaren = new_state;
536}
537
548void spi_i2s_data_transmit(spi_type* spi_x, uint16_t tx_data)
549{
550 spi_x->dt = tx_data;
551}
552
560uint16_t spi_i2s_data_receive(spi_type* spi_x)
561{
562 return (uint16_t)spi_x->dt;
563}
564
583 flag_status spi_i2s_flag_get(spi_type* spi_x, uint32_t spi_i2s_flag)
584{
585 flag_status status = RESET;
586 if ((spi_x->sts & spi_i2s_flag) == RESET)
587 {
588 status = RESET;
589 }
590 else
591 {
592 status = SET;
593 }
594 return status;
595}
596
616void spi_i2s_flag_clear(spi_type* spi_x, uint32_t spi_i2s_flag)
617{
618 if(spi_i2s_flag == SPI_CCERR_FLAG)
619 spi_x->sts = ~SPI_CCERR_FLAG;
620 else if(spi_i2s_flag == SPI_I2S_RDBF_FLAG)
621 UNUSED(spi_x->dt);
622 else if(spi_i2s_flag == I2S_TUERR_FLAG)
623 UNUSED(spi_x->sts);
624 else if(spi_i2s_flag == SPI_CSPAS_FLAG)
625 UNUSED(spi_x->sts);
626 else if(spi_i2s_flag == SPI_MMERR_FLAG)
627 {
628 UNUSED(spi_x->sts);
629 spi_x->ctrl1 = spi_x->ctrl1;
630 }
631 else if(spi_i2s_flag == SPI_I2S_ROERR_FLAG)
632 {
633 UNUSED(spi_x->dt);
634 UNUSED(spi_x->sts);
635 }
636}
637
642#endif
643
UNUSED
#define UNUSED(x)
Definition: at32f435_437_def.h:65
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:40
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f435_437_crm.c:251
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_SPI1_PERIPH_RESET
@ CRM_SPI1_PERIPH_RESET
Definition: at32f435_437_crm.h:306
CRM_SPI3_PERIPH_RESET
@ CRM_SPI3_PERIPH_RESET
Definition: at32f435_437_crm.h:286
CRM_SPI4_PERIPH_RESET
@ CRM_SPI4_PERIPH_RESET
Definition: at32f435_437_crm.h:307
CRM_SPI2_PERIPH_RESET
@ CRM_SPI2_PERIPH_RESET
Definition: at32f435_437_crm.h:285
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
I2S_TUERR_FLAG
#define I2S_TUERR_FLAG
Definition: at32f435_437_spi.h:56
SPI_CCERR_FLAG
#define SPI_CCERR_FLAG
Definition: at32f435_437_spi.h:57
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f435_437_spi.h:53
SPI_CSPAS_FLAG
#define SPI_CSPAS_FLAG
Definition: at32f435_437_spi.h:61
SPI_MMERR_FLAG
#define SPI_MMERR_FLAG
Definition: at32f435_437_spi.h:58
SPI_I2S_ROERR_FLAG
#define SPI_I2S_ROERR_FLAG
Definition: at32f435_437_spi.h:59
spi_software_cs_level_type
spi_software_cs_level_type
spi software cs internal level type
Definition: at32f435_437_spi.h:190
spi_half_duplex_direction_type
spi_half_duplex_direction_type
spi single line bidirectional direction type
Definition: at32f435_437_spi.h:181
spi_frame_bit_num_type
spi_frame_bit_num_type
spi frame bit num type
Definition: at32f435_437_spi.h:89
spi_crc_direction_type
spi_crc_direction_type
spi crc direction type
Definition: at32f435_437_spi.h:172
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f435_437_spi.h:251
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f435_437_spi.h:99
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f435_437_spi.h:100
I2S_DATA_16BIT_CHANNEL_16BIT
@ I2S_DATA_16BIT_CHANNEL_16BIT
Definition: at32f435_437_spi.h:229
I2S_DATA_24BIT_CHANNEL_32BIT
@ I2S_DATA_24BIT_CHANNEL_32BIT
Definition: at32f435_437_spi.h:231
I2S_DATA_32BIT_CHANNEL_32BIT
@ I2S_DATA_32BIT_CHANNEL_32BIT
Definition: at32f435_437_spi.h:232
I2S_DATA_16BIT_CHANNEL_32BIT
@ I2S_DATA_16BIT_CHANNEL_32BIT
Definition: at32f435_437_spi.h:230
SPI_CLOCK_PHASE_1EDGE
@ SPI_CLOCK_PHASE_1EDGE
Definition: at32f435_437_spi.h:117
I2S_AUDIO_FREQUENCY_DEFAULT
@ I2S_AUDIO_FREQUENCY_DEFAULT
Definition: at32f435_437_spi.h:212
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f435_437_spi.h:127
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f435_437_spi.h:153
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f435_437_spi.h:108
SPI_TRANSMIT_HALF_DUPLEX_RX
@ SPI_TRANSMIT_HALF_DUPLEX_RX
Definition: at32f435_437_spi.h:164
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f435_437_spi.h:162
SPI_TRANSMIT_HALF_DUPLEX_TX
@ SPI_TRANSMIT_HALF_DUPLEX_TX
Definition: at32f435_437_spi.h:165
SPI_TRANSMIT_SIMPLEX_RX
@ SPI_TRANSMIT_SIMPLEX_RX
Definition: at32f435_437_spi.h:163
I2S_AUDIO_PROTOCOL_PCM_LONG
@ I2S_AUDIO_PROTOCOL_PCM_LONG
Definition: at32f435_437_spi.h:204
I2S_AUDIO_PROTOCOL_LSB
@ I2S_AUDIO_PROTOCOL_LSB
Definition: at32f435_437_spi.h:202
I2S_AUDIO_PROTOCOL_MSB
@ I2S_AUDIO_PROTOCOL_MSB
Definition: at32f435_437_spi.h:201
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f435_437_spi.h:200
I2S_AUDIO_PROTOCOL_PCM_SHORT
@ I2S_AUDIO_PROTOCOL_PCM_SHORT
Definition: at32f435_437_spi.h:203
SPI_MCLK_DIV_3
@ SPI_MCLK_DIV_3
Definition: at32f435_437_spi.h:136
SPI_MCLK_DIV_2
@ SPI_MCLK_DIV_2
Definition: at32f435_437_spi.h:135
SPI_MCLK_DIV_256
@ SPI_MCLK_DIV_256
Definition: at32f435_437_spi.h:143
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f435_437_spi.h:90
SPI_CRC_RX
@ SPI_CRC_RX
Definition: at32f435_437_spi.h:173
I2S_MODE_SLAVE_TX
@ I2S_MODE_SLAVE_TX
Definition: at32f435_437_spi.h:240
spi_i2s_interrupt_enable
void spi_i2s_interrupt_enable(spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts.
Definition: at32f435_437_spi.c:498
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f435_437_spi.c:350
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f435_437_spi.c:548
spi_crc_enable
void spi_crc_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the hardware crc calculation for the spi peripheral.
Definition: at32f435_437_spi.c:225
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f435_437_spi.c:533
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f435_437_spi.c:583
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f435_437_spi.c:479
spi_crc_polynomial_get
uint16_t spi_crc_polynomial_get(spi_type *spi_x)
return the crc polynomial register value for the spi peripheral.
Definition: at32f435_437_spi.c:211
spi_crc_next_transmit
void spi_crc_next_transmit(spi_type *spi_x)
spi next transmit crc for the spi peripheral.
Definition: at32f435_437_spi.c:186
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f435_437_spi.c:101
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f435_437_spi.c:81
spi_crc_polynomial_set
void spi_crc_polynomial_set(spi_type *spi_x, uint16_t crc_poly)
set the crc polynomial value for the spi peripheral.
Definition: at32f435_437_spi.c:199
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f435_437_spi.c:560
spi_crc_value_get
uint16_t spi_crc_value_get(spi_type *spi_x, spi_crc_direction_type crc_direction)
return the transmit or the receive crc value for the spi peripheral.
Definition: at32f435_437_spi.c:240
spi_i2s_reset
void spi_i2s_reset(spi_type *spi_x)
spi reset by crm reset register
Definition: at32f435_437_spi.c:51
spi_ti_mode_enable
void spi_ti_mode_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the ti mode for the spi peripheral.
Definition: at32f435_437_spi.c:174
spi_half_duplex_direction_set
void spi_half_duplex_direction_set(spi_type *spi_x, spi_half_duplex_direction_type direction)
set the data transmission direction in single line bidirectiona half duplex mode of the spi periphera...
Definition: at32f435_437_spi.c:307
spi_hardware_cs_output_enable
void spi_hardware_cs_output_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the hardware cs output for the spi peripheral.
Definition: at32f435_437_spi.c:258
spi_i2s_flag_clear
void spi_i2s_flag_clear(spi_type *spi_x, uint32_t spi_i2s_flag)
clear flag of the specified spi/i2s peripheral.
Definition: at32f435_437_spi.c:616
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f435_437_spi.c:332
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f435_437_spi.c:321
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f435_437_spi.c:519
spi_frame_bit_num_set
void spi_frame_bit_num_set(spi_type *spi_x, spi_frame_bit_num_type bit_num)
set the data frame bit num for the spi peripheral.
Definition: at32f435_437_spi.c:291
spi_software_cs_internal_level_set
void spi_software_cs_internal_level_set(spi_type *spi_x, spi_software_cs_level_type level)
set the software cs internal level for the spi peripheral.
Definition: at32f435_437_spi.c:276
SPI4
#define SPI4
Definition: at32f435_437_spi.h:456
SPI3
#define SPI3
Definition: at32f435_437_spi.h:455
SPI1
#define SPI1
Definition: at32f435_437_spi.h:453
SPI2
#define SPI2
Definition: at32f435_437_spi.h:454
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f435_437_crm.h:789
i2s_init_type
i2s init type
Definition: at32f435_437_spi.h:274
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f435_437_spi.h:277
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f435_437_spi.h:278
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f435_437_spi.h:280
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f435_437_spi.h:276
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f435_437_spi.h:275
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:279
spi_init_type
spi init type
Definition: at32f435_437_spi.h:259
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f435_437_spi.h:261
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f435_437_spi.h:263
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f435_437_spi.h:264
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:265
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f435_437_spi.h:267
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f435_437_spi.h:262
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f435_437_spi.h:260
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f435_437_spi.h:266
spi_type
type define spi register all
Definition: at32f435_437_spi.h:287
spi_type::clkpha
__IO uint32_t clkpha
Definition: at32f435_437_spi.h:297
spi_type::cpoly_bit
struct spi_type::@1038::@1052 cpoly_bit
spi_type::hwcsoe
__IO uint32_t hwcsoe
Definition: at32f435_437_spi.h:325
spi_type::slben
__IO uint32_t slben
Definition: at32f435_437_spi.h:310
spi_type::ntc
__IO uint32_t ntc
Definition: at32f435_437_spi.h:307
spi_type::mdiv_h
__IO uint32_t mdiv_h
Definition: at32f435_437_spi.h:331
spi_type::dmaren
__IO uint32_t dmaren
Definition: at32f435_437_spi.h:323
spi_type::i2sdbn
__IO uint32_t i2sdbn
Definition: at32f435_437_spi.h:419
spi_type::rcrc
__IO uint32_t rcrc
Definition: at32f435_437_spi.h:389
spi_type::i2scbn
__IO uint32_t i2scbn
Definition: at32f435_437_spi.h:418
spi_type::i2sclkpol
__IO uint32_t i2sclkpol
Definition: at32f435_437_spi.h:420
spi_type::cpoly
__IO uint32_t cpoly
Definition: at32f435_437_spi.h:376
spi_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f435_437_spi.h:294
spi_type::ctrl1_bit
struct spi_type::@1030::@1048 ctrl1_bit
spi_type::i2sodd
__IO uint32_t i2sodd
Definition: at32f435_437_spi.h:440
spi_type::swcsil
__IO uint32_t swcsil
Definition: at32f435_437_spi.h:303
spi_type::tcrc
__IO uint32_t tcrc
Definition: at32f435_437_spi.h:402
spi_type::i2sclk_bit
struct spi_type::@1046::@1056 i2sclk_bit
spi_type::i2smclkoe
__IO uint32_t i2smclkoe
Definition: at32f435_437_spi.h:441
spi_type::ltf
__IO uint32_t ltf
Definition: at32f435_437_spi.h:302
spi_type::clkpol
__IO uint32_t clkpol
Definition: at32f435_437_spi.h:298
spi_type::tcrc_bit
struct spi_type::@1042::@1054 tcrc_bit
spi_type::slbtd
__IO uint32_t slbtd
Definition: at32f435_437_spi.h:309
spi_type::dmaten
__IO uint32_t dmaten
Definition: at32f435_437_spi.h:324
spi_type::ccen
__IO uint32_t ccen
Definition: at32f435_437_spi.h:308
spi_type::fbn
__IO uint32_t fbn
Definition: at32f435_437_spi.h:306
spi_type::dt
__IO uint32_t dt
Definition: at32f435_437_spi.h:363
spi_type::msten
__IO uint32_t msten
Definition: at32f435_437_spi.h:299
spi_type::sts
__IO uint32_t sts
Definition: at32f435_437_spi.h:342
spi_type::i2sdiv_h
__IO uint32_t i2sdiv_h
Definition: at32f435_437_spi.h:442
spi_type::tien
__IO uint32_t tien
Definition: at32f435_437_spi.h:327
spi_type::opersel
__IO uint32_t opersel
Definition: at32f435_437_spi.h:424
spi_type::i2sdiv_l
__IO uint32_t i2sdiv_l
Definition: at32f435_437_spi.h:439
spi_type::rcrc_bit
struct spi_type::@1040::@1053 rcrc_bit
spi_type::i2smsel
__IO uint32_t i2smsel
Definition: at32f435_437_spi.h:426
spi_type::mdiv3en
__IO uint32_t mdiv3en
Definition: at32f435_437_spi.h:332
spi_type::pcmfssel
__IO uint32_t pcmfssel
Definition: at32f435_437_spi.h:423
spi_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f435_437_spi.h:320
spi_type::i2sctrl_bit
struct spi_type::@1044::@1055 i2sctrl_bit
spi_type::stdsel
__IO uint32_t stdsel
Definition: at32f435_437_spi.h:421
spi_type::mdiv_l
__IO uint32_t mdiv_l
Definition: at32f435_437_spi.h:300
spi_type::ctrl2_bit
struct spi_type::@1032::@1049 ctrl2_bit
spi_type::spien
__IO uint32_t spien
Definition: at32f435_437_spi.h:301
spi_type::swcsen
__IO uint32_t swcsen
Definition: at32f435_437_spi.h:304
spi_type::ora
__IO uint32_t ora
Definition: at32f435_437_spi.h:305
spi_type::i2sen
__IO uint32_t i2sen
Definition: at32f435_437_spi.h:425
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_spi.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_spi.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_SPI_H
29#define __AT32F435_437_SPI_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
53#define SPI_I2S_RDBF_FLAG 0x0001
54#define SPI_I2S_TDBE_FLAG 0x0002
55#define I2S_ACS_FLAG 0x0004
56#define I2S_TUERR_FLAG 0x0008
57#define SPI_CCERR_FLAG 0x0010
58#define SPI_MMERR_FLAG 0x0020
59#define SPI_I2S_ROERR_FLAG 0x0040
60#define SPI_I2S_BF_FLAG 0x0080
61#define SPI_CSPAS_FLAG 0x0100
73#define SPI_I2S_ERROR_INT 0x0020
74#define SPI_I2S_RDBF_INT 0x0040
75#define SPI_I2S_TDBE_INT 0x0080
88typedef enum
89{
90 SPI_FRAME_8BIT = 0x00,
91 SPI_FRAME_16BIT = 0x01
92} spi_frame_bit_num_type;
93
97typedef enum
98{
99 SPI_MODE_SLAVE = 0x00,
100 SPI_MODE_MASTER = 0x01
101} spi_master_slave_mode_type;
102
106typedef enum
107{
108 SPI_CLOCK_POLARITY_LOW = 0x00,
109 SPI_CLOCK_POLARITY_HIGH = 0x01
110} spi_clock_polarity_type;
111
115typedef enum
116{
117 SPI_CLOCK_PHASE_1EDGE = 0x00,
118 SPI_CLOCK_PHASE_2EDGE = 0x01
119} spi_clock_phase_type;
120
124typedef enum
125{
126 SPI_CS_HARDWARE_MODE = 0x00,
127 SPI_CS_SOFTWARE_MODE = 0x01
128} spi_cs_mode_type;
129
133typedef enum
134{
135 SPI_MCLK_DIV_2 = 0x00,
136 SPI_MCLK_DIV_3 = 0x0A,
137 SPI_MCLK_DIV_4 = 0x01,
138 SPI_MCLK_DIV_8 = 0x02,
139 SPI_MCLK_DIV_16 = 0x03,
140 SPI_MCLK_DIV_32 = 0x04,
141 SPI_MCLK_DIV_64 = 0x05,
142 SPI_MCLK_DIV_128 = 0x06,
143 SPI_MCLK_DIV_256 = 0x07,
144 SPI_MCLK_DIV_512 = 0x08,
145 SPI_MCLK_DIV_1024 = 0x09
146} spi_mclk_freq_div_type;
147
151typedef enum
152{
153 SPI_FIRST_BIT_MSB = 0x00,
154 SPI_FIRST_BIT_LSB = 0x01
155} spi_first_bit_type;
156
160typedef enum
161{
162 SPI_TRANSMIT_FULL_DUPLEX = 0x00,
163 SPI_TRANSMIT_SIMPLEX_RX = 0x01,
164 SPI_TRANSMIT_HALF_DUPLEX_RX = 0x02,
165 SPI_TRANSMIT_HALF_DUPLEX_TX = 0x03
166} spi_transmission_mode_type;
167
171typedef enum
172{
173 SPI_CRC_RX = 0x0014,
174 SPI_CRC_TX = 0x0018
175} spi_crc_direction_type;
176
180typedef enum
181{
182 SPI_HALF_DUPLEX_DIRECTION_RX = 0x00,
183 SPI_HALF_DUPLEX_DIRECTION_TX = 0x01
184} spi_half_duplex_direction_type;
185
189typedef enum
190{
191 SPI_SWCS_INTERNAL_LEVEL_LOW = 0x00,
192 SPI_SWCS_INTERNAL_LEVEL_HIGHT = 0x01
193} spi_software_cs_level_type;
194
198typedef enum
199{
200 I2S_AUDIO_PROTOCOL_PHILLIPS = 0x00,
201 I2S_AUDIO_PROTOCOL_MSB = 0x01,
202 I2S_AUDIO_PROTOCOL_LSB = 0x02,
203 I2S_AUDIO_PROTOCOL_PCM_SHORT = 0x03,
204 I2S_AUDIO_PROTOCOL_PCM_LONG = 0x04
205} i2s_audio_protocol_type;
206
210typedef enum
211{
212 I2S_AUDIO_FREQUENCY_DEFAULT = 2,
213 I2S_AUDIO_FREQUENCY_8K = 8000,
214 I2S_AUDIO_FREQUENCY_11_025K = 11025,
215 I2S_AUDIO_FREQUENCY_16K = 16000,
216 I2S_AUDIO_FREQUENCY_22_05K = 22050,
217 I2S_AUDIO_FREQUENCY_32K = 32000,
218 I2S_AUDIO_FREQUENCY_44_1K = 44100,
219 I2S_AUDIO_FREQUENCY_48K = 48000,
220 I2S_AUDIO_FREQUENCY_96K = 96000,
221 I2S_AUDIO_FREQUENCY_192K = 192000
222} i2s_audio_sampling_freq_type;
223
227typedef enum
228{
229 I2S_DATA_16BIT_CHANNEL_16BIT = 0x01,
230 I2S_DATA_16BIT_CHANNEL_32BIT = 0x02,
231 I2S_DATA_24BIT_CHANNEL_32BIT = 0x03,
232 I2S_DATA_32BIT_CHANNEL_32BIT = 0x04
233} i2s_data_channel_format_type;
234
238typedef enum
239{
240 I2S_MODE_SLAVE_TX = 0x00,
241 I2S_MODE_SLAVE_RX = 0x01,
242 I2S_MODE_MASTER_TX = 0x02,
243 I2S_MODE_MASTER_RX = 0x03
244} i2s_operation_mode_type;
245
249typedef enum
250{
251 I2S_CLOCK_POLARITY_LOW = 0x00,
252 I2S_CLOCK_POLARITY_HIGH = 0x01
253} i2s_clock_polarity_type;
254
258typedef struct
259{
260 spi_transmission_mode_type transmission_mode;
261 spi_master_slave_mode_type master_slave_mode;
262 spi_mclk_freq_div_type mclk_freq_division;
263 spi_first_bit_type first_bit_transmission;
264 spi_frame_bit_num_type frame_bit_num;
265 spi_clock_polarity_type clock_polarity;
266 spi_clock_phase_type clock_phase;
267 spi_cs_mode_type cs_mode_selection;
268} spi_init_type;
269
273typedef struct
274{
275 i2s_operation_mode_type operation_mode;
276 i2s_audio_protocol_type audio_protocol;
277 i2s_audio_sampling_freq_type audio_sampling_freq;
278 i2s_data_channel_format_type data_channel_format;
279 i2s_clock_polarity_type clock_polarity;
280 confirm_state mclk_output_enable;
281} i2s_init_type;
282
286typedef struct
287{
288
292 union
293 {
294 __IO uint32_t ctrl1;
295 struct
296 {
297 __IO uint32_t clkpha : 1; /* [0] */
298 __IO uint32_t clkpol : 1; /* [1] */
299 __IO uint32_t msten : 1; /* [2] */
300 __IO uint32_t mdiv_l : 3; /* [5:3] */
301 __IO uint32_t spien : 1; /* [6] */
302 __IO uint32_t ltf : 1; /* [7] */
303 __IO uint32_t swcsil : 1; /* [8] */
304 __IO uint32_t swcsen : 1; /* [9] */
305 __IO uint32_t ora : 1; /* [10] */
306 __IO uint32_t fbn : 1; /* [11] */
307 __IO uint32_t ntc : 1; /* [12] */
308 __IO uint32_t ccen : 1; /* [13] */
309 __IO uint32_t slbtd : 1; /* [14] */
310 __IO uint32_t slben : 1; /* [15] */
311 __IO uint32_t reserved1 : 16;/* [31:16] */
312 } ctrl1_bit;
313 };
314
318 union
319 {
320 __IO uint32_t ctrl2;
321 struct
322 {
323 __IO uint32_t dmaren : 1; /* [0] */
324 __IO uint32_t dmaten : 1; /* [1] */
325 __IO uint32_t hwcsoe : 1; /* [2] */
326 __IO uint32_t reserved1 : 1; /* [3] */
327 __IO uint32_t tien : 1; /* [4] */
328 __IO uint32_t errie : 1; /* [5] */
329 __IO uint32_t rdbfie : 1; /* [6] */
330 __IO uint32_t tdbeie : 1; /* [7] */
331 __IO uint32_t mdiv_h : 1; /* [8] */
332 __IO uint32_t mdiv3en : 1; /* [9] */
333 __IO uint32_t reserved2 : 22;/* [31:10] */
334 } ctrl2_bit;
335 };
336
340 union
341 {
342 __IO uint32_t sts;
343 struct
344 {
345 __IO uint32_t rdbf : 1; /* [0] */
346 __IO uint32_t tdbe : 1; /* [1] */
347 __IO uint32_t acs : 1; /* [2] */
348 __IO uint32_t tuerr : 1; /* [3] */
349 __IO uint32_t ccerr : 1; /* [4] */
350 __IO uint32_t mmerr : 1; /* [5] */
351 __IO uint32_t roerr : 1; /* [6] */
352 __IO uint32_t bf : 1; /* [7] */
353 __IO uint32_t cspas : 1; /* [8] */
354 __IO uint32_t reserved1 : 23;/* [31:9] */
355 } sts_bit;
356 };
357
361 union
362 {
363 __IO uint32_t dt;
364 struct
365 {
366 __IO uint32_t dt : 16;/* [15:0] */
367 __IO uint32_t reserved1 : 16;/* [31:16] */
368 } dt_bit;
369 };
370
374 union
375 {
376 __IO uint32_t cpoly;
377 struct
378 {
379 __IO uint32_t cpoly : 16;/* [15:0] */
380 __IO uint32_t reserved1 : 16;/* [31:16] */
381 } cpoly_bit;
382 };
383
387 union
388 {
389 __IO uint32_t rcrc;
390 struct
391 {
392 __IO uint32_t rcrc : 16;/* [15:0] */
393 __IO uint32_t reserved1 : 16;/* [31:16] */
394 } rcrc_bit;
395 };
396
400 union
401 {
402 __IO uint32_t tcrc;
403 struct
404 {
405 __IO uint32_t tcrc : 16;/* [15:0] */
406 __IO uint32_t reserved1 : 16;/* [31:16] */
407 } tcrc_bit;
408 };
409
413 union
414 {
415 __IO uint32_t i2sctrl;
416 struct
417 {
418 __IO uint32_t i2scbn : 1; /* [0] */
419 __IO uint32_t i2sdbn : 2; /* [2:1] */
420 __IO uint32_t i2sclkpol : 1; /* [3] */
421 __IO uint32_t stdsel : 2; /* [5:4] */
422 __IO uint32_t reserved1 : 1; /* [6] */
423 __IO uint32_t pcmfssel : 1; /* [7] */
424 __IO uint32_t opersel : 2; /* [9:8] */
425 __IO uint32_t i2sen : 1; /* [10] */
426 __IO uint32_t i2smsel : 1; /* [11] */
427 __IO uint32_t reserved2 : 20;/* [31:12] */
428 } i2sctrl_bit;
429 };
430
434 union
435 {
436 __IO uint32_t i2sclk;
437 struct
438 {
439 __IO uint32_t i2sdiv_l : 8; /* [7:0] */
440 __IO uint32_t i2sodd : 1; /* [8] */
441 __IO uint32_t i2smclkoe : 1; /* [9] */
442 __IO uint32_t i2sdiv_h : 2; /* [11:10] */
443 __IO uint32_t reserved1 : 20;/* [31:12] */
444 } i2sclk_bit;
445 };
446
447} spi_type;
448
453#define SPI1 ((spi_type *) SPI1_BASE)
454#define SPI2 ((spi_type *) SPI2_BASE)
455#define SPI3 ((spi_type *) SPI3_BASE)
456#define SPI4 ((spi_type *) SPI4_BASE)
457#define I2S2EXT ((spi_type *) I2S2EXT_BASE)
458#define I2S3EXT ((spi_type *) I2S3EXT_BASE)
459
464void spi_i2s_reset(spi_type *spi_x);
465void spi_default_para_init(spi_init_type* spi_init_struct);
466void spi_init(spi_type* spi_x, spi_init_type* spi_init_struct);
467void spi_ti_mode_enable(spi_type* spi_x, confirm_state new_state);
468void spi_crc_next_transmit(spi_type* spi_x);
469void spi_crc_polynomial_set(spi_type* spi_x, uint16_t crc_poly);
470uint16_t spi_crc_polynomial_get(spi_type* spi_x);
471void spi_crc_enable(spi_type* spi_x, confirm_state new_state);
472uint16_t spi_crc_value_get(spi_type* spi_x, spi_crc_direction_type crc_direction);
473void spi_hardware_cs_output_enable(spi_type* spi_x, confirm_state new_state);
474void spi_software_cs_internal_level_set(spi_type* spi_x, spi_software_cs_level_type level);
475void spi_frame_bit_num_set(spi_type* spi_x, spi_frame_bit_num_type bit_num);
476void spi_half_duplex_direction_set(spi_type* spi_x, spi_half_duplex_direction_type direction);
477void spi_enable(spi_type* spi_x, confirm_state new_state);
478void i2s_default_para_init(i2s_init_type* i2s_init_struct);
479void i2s_init(spi_type* spi_x, i2s_init_type* i2s_init_struct);
480void i2s_enable(spi_type* spi_x, confirm_state new_state);
481void spi_i2s_interrupt_enable(spi_type* spi_x, uint32_t spi_i2s_int, confirm_state new_state);
482void spi_i2s_dma_transmitter_enable(spi_type* spi_x, confirm_state new_state);
483void spi_i2s_dma_receiver_enable(spi_type* spi_x, confirm_state new_state);
484void spi_i2s_data_transmit(spi_type* spi_x, uint16_t tx_data);
485uint16_t spi_i2s_data_receive(spi_type* spi_x);
486 flag_status spi_i2s_flag_get(spi_type* spi_x, uint32_t spi_i2s_flag);
487void spi_i2s_flag_clear(spi_type* spi_x, uint32_t spi_i2s_flag);
488
501#ifdef __cplusplus
502}
503#endif
504
505#endif
at32f435_437.h
at32f435_437 header file
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:40
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
spi_i2s_interrupt_enable
void spi_i2s_interrupt_enable(spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts.
Definition: at32f435_437_spi.c:498
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f435_437_spi.c:350
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f435_437_spi.c:548
spi_crc_enable
void spi_crc_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the hardware crc calculation for the spi peripheral.
Definition: at32f435_437_spi.c:225
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f435_437_spi.c:533
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f435_437_spi.c:583
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f435_437_spi.c:479
spi_crc_polynomial_get
uint16_t spi_crc_polynomial_get(spi_type *spi_x)
return the crc polynomial register value for the spi peripheral.
Definition: at32f435_437_spi.c:211
spi_crc_next_transmit
void spi_crc_next_transmit(spi_type *spi_x)
spi next transmit crc for the spi peripheral.
Definition: at32f435_437_spi.c:186
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f435_437_spi.c:101
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f435_437_spi.c:81
spi_crc_polynomial_set
void spi_crc_polynomial_set(spi_type *spi_x, uint16_t crc_poly)
set the crc polynomial value for the spi peripheral.
Definition: at32f435_437_spi.c:199
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f435_437_spi.c:560
spi_crc_value_get
uint16_t spi_crc_value_get(spi_type *spi_x, spi_crc_direction_type crc_direction)
return the transmit or the receive crc value for the spi peripheral.
Definition: at32f435_437_spi.c:240
spi_i2s_reset
void spi_i2s_reset(spi_type *spi_x)
spi reset by crm reset register
Definition: at32f435_437_spi.c:51
spi_ti_mode_enable
void spi_ti_mode_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the ti mode for the spi peripheral.
Definition: at32f435_437_spi.c:174
spi_half_duplex_direction_set
void spi_half_duplex_direction_set(spi_type *spi_x, spi_half_duplex_direction_type direction)
set the data transmission direction in single line bidirectiona half duplex mode of the spi periphera...
Definition: at32f435_437_spi.c:307
spi_hardware_cs_output_enable
void spi_hardware_cs_output_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the hardware cs output for the spi peripheral.
Definition: at32f435_437_spi.c:258
spi_i2s_flag_clear
void spi_i2s_flag_clear(spi_type *spi_x, uint32_t spi_i2s_flag)
clear flag of the specified spi/i2s peripheral.
Definition: at32f435_437_spi.c:616
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f435_437_spi.c:332
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f435_437_spi.c:321
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f435_437_spi.c:519
spi_frame_bit_num_set
void spi_frame_bit_num_set(spi_type *spi_x, spi_frame_bit_num_type bit_num)
set the data frame bit num for the spi peripheral.
Definition: at32f435_437_spi.c:291
spi_software_cs_internal_level_set
void spi_software_cs_internal_level_set(spi_type *spi_x, spi_software_cs_level_type level)
set the software cs internal level for the spi peripheral.
Definition: at32f435_437_spi.c:276
i2s_clock_polarity_type
i2s_clock_polarity_type
i2s clock polarity type
Definition: at32f435_437_spi.h:250
spi_master_slave_mode_type
spi_master_slave_mode_type
spi master/slave mode type
Definition: at32f435_437_spi.h:98
spi_software_cs_level_type
spi_software_cs_level_type
spi software cs internal level type
Definition: at32f435_437_spi.h:190
i2s_data_channel_format_type
i2s_data_channel_format_type
i2s data bit num and channel bit num type
Definition: at32f435_437_spi.h:228
spi_clock_phase_type
spi_clock_phase_type
spi clock phase (clkpha) type
Definition: at32f435_437_spi.h:116
i2s_audio_sampling_freq_type
i2s_audio_sampling_freq_type
i2s audio frequency type
Definition: at32f435_437_spi.h:211
spi_cs_mode_type
spi_cs_mode_type
spi cs mode type
Definition: at32f435_437_spi.h:125
spi_first_bit_type
spi_first_bit_type
spi transmit first bit (lsb/msb) type
Definition: at32f435_437_spi.h:152
spi_clock_polarity_type
spi_clock_polarity_type
spi clock polarity (clkpol) type
Definition: at32f435_437_spi.h:107
spi_half_duplex_direction_type
spi_half_duplex_direction_type
spi single line bidirectional direction type
Definition: at32f435_437_spi.h:181
spi_transmission_mode_type
spi_transmission_mode_type
spi transmission mode type
Definition: at32f435_437_spi.h:161
i2s_audio_protocol_type
i2s_audio_protocol_type
i2s audio protocol type
Definition: at32f435_437_spi.h:199
spi_mclk_freq_div_type
spi_mclk_freq_div_type
spi master clock frequency division type
Definition: at32f435_437_spi.h:134
spi_frame_bit_num_type
spi_frame_bit_num_type
spi frame bit num type
Definition: at32f435_437_spi.h:89
spi_crc_direction_type
spi_crc_direction_type
spi crc direction type
Definition: at32f435_437_spi.h:172
i2s_operation_mode_type
i2s_operation_mode_type
i2s operation mode type
Definition: at32f435_437_spi.h:239
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f435_437_spi.h:251
I2S_CLOCK_POLARITY_HIGH
@ I2S_CLOCK_POLARITY_HIGH
Definition: at32f435_437_spi.h:252
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f435_437_spi.h:99
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f435_437_spi.h:100
SPI_SWCS_INTERNAL_LEVEL_LOW
@ SPI_SWCS_INTERNAL_LEVEL_LOW
Definition: at32f435_437_spi.h:191
SPI_SWCS_INTERNAL_LEVEL_HIGHT
@ SPI_SWCS_INTERNAL_LEVEL_HIGHT
Definition: at32f435_437_spi.h:192
I2S_DATA_16BIT_CHANNEL_16BIT
@ I2S_DATA_16BIT_CHANNEL_16BIT
Definition: at32f435_437_spi.h:229
I2S_DATA_24BIT_CHANNEL_32BIT
@ I2S_DATA_24BIT_CHANNEL_32BIT
Definition: at32f435_437_spi.h:231
I2S_DATA_32BIT_CHANNEL_32BIT
@ I2S_DATA_32BIT_CHANNEL_32BIT
Definition: at32f435_437_spi.h:232
I2S_DATA_16BIT_CHANNEL_32BIT
@ I2S_DATA_16BIT_CHANNEL_32BIT
Definition: at32f435_437_spi.h:230
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f435_437_spi.h:118
SPI_CLOCK_PHASE_1EDGE
@ SPI_CLOCK_PHASE_1EDGE
Definition: at32f435_437_spi.h:117
I2S_AUDIO_FREQUENCY_44_1K
@ I2S_AUDIO_FREQUENCY_44_1K
Definition: at32f435_437_spi.h:218
I2S_AUDIO_FREQUENCY_11_025K
@ I2S_AUDIO_FREQUENCY_11_025K
Definition: at32f435_437_spi.h:214
I2S_AUDIO_FREQUENCY_48K
@ I2S_AUDIO_FREQUENCY_48K
Definition: at32f435_437_spi.h:219
I2S_AUDIO_FREQUENCY_DEFAULT
@ I2S_AUDIO_FREQUENCY_DEFAULT
Definition: at32f435_437_spi.h:212
I2S_AUDIO_FREQUENCY_8K
@ I2S_AUDIO_FREQUENCY_8K
Definition: at32f435_437_spi.h:213
I2S_AUDIO_FREQUENCY_32K
@ I2S_AUDIO_FREQUENCY_32K
Definition: at32f435_437_spi.h:217
I2S_AUDIO_FREQUENCY_192K
@ I2S_AUDIO_FREQUENCY_192K
Definition: at32f435_437_spi.h:221
I2S_AUDIO_FREQUENCY_96K
@ I2S_AUDIO_FREQUENCY_96K
Definition: at32f435_437_spi.h:220
I2S_AUDIO_FREQUENCY_22_05K
@ I2S_AUDIO_FREQUENCY_22_05K
Definition: at32f435_437_spi.h:216
I2S_AUDIO_FREQUENCY_16K
@ I2S_AUDIO_FREQUENCY_16K
Definition: at32f435_437_spi.h:215
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f435_437_spi.h:127
SPI_CS_HARDWARE_MODE
@ SPI_CS_HARDWARE_MODE
Definition: at32f435_437_spi.h:126
SPI_FIRST_BIT_LSB
@ SPI_FIRST_BIT_LSB
Definition: at32f435_437_spi.h:154
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f435_437_spi.h:153
SPI_CLOCK_POLARITY_HIGH
@ SPI_CLOCK_POLARITY_HIGH
Definition: at32f435_437_spi.h:109
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f435_437_spi.h:108
SPI_HALF_DUPLEX_DIRECTION_TX
@ SPI_HALF_DUPLEX_DIRECTION_TX
Definition: at32f435_437_spi.h:183
SPI_HALF_DUPLEX_DIRECTION_RX
@ SPI_HALF_DUPLEX_DIRECTION_RX
Definition: at32f435_437_spi.h:182
SPI_TRANSMIT_HALF_DUPLEX_RX
@ SPI_TRANSMIT_HALF_DUPLEX_RX
Definition: at32f435_437_spi.h:164
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f435_437_spi.h:162
SPI_TRANSMIT_HALF_DUPLEX_TX
@ SPI_TRANSMIT_HALF_DUPLEX_TX
Definition: at32f435_437_spi.h:165
SPI_TRANSMIT_SIMPLEX_RX
@ SPI_TRANSMIT_SIMPLEX_RX
Definition: at32f435_437_spi.h:163
I2S_AUDIO_PROTOCOL_PCM_LONG
@ I2S_AUDIO_PROTOCOL_PCM_LONG
Definition: at32f435_437_spi.h:204
I2S_AUDIO_PROTOCOL_LSB
@ I2S_AUDIO_PROTOCOL_LSB
Definition: at32f435_437_spi.h:202
I2S_AUDIO_PROTOCOL_MSB
@ I2S_AUDIO_PROTOCOL_MSB
Definition: at32f435_437_spi.h:201
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f435_437_spi.h:200
I2S_AUDIO_PROTOCOL_PCM_SHORT
@ I2S_AUDIO_PROTOCOL_PCM_SHORT
Definition: at32f435_437_spi.h:203
SPI_MCLK_DIV_16
@ SPI_MCLK_DIV_16
Definition: at32f435_437_spi.h:139
SPI_MCLK_DIV_64
@ SPI_MCLK_DIV_64
Definition: at32f435_437_spi.h:141
SPI_MCLK_DIV_128
@ SPI_MCLK_DIV_128
Definition: at32f435_437_spi.h:142
SPI_MCLK_DIV_4
@ SPI_MCLK_DIV_4
Definition: at32f435_437_spi.h:137
SPI_MCLK_DIV_3
@ SPI_MCLK_DIV_3
Definition: at32f435_437_spi.h:136
SPI_MCLK_DIV_512
@ SPI_MCLK_DIV_512
Definition: at32f435_437_spi.h:144
SPI_MCLK_DIV_32
@ SPI_MCLK_DIV_32
Definition: at32f435_437_spi.h:140
SPI_MCLK_DIV_2
@ SPI_MCLK_DIV_2
Definition: at32f435_437_spi.h:135
SPI_MCLK_DIV_1024
@ SPI_MCLK_DIV_1024
Definition: at32f435_437_spi.h:145
SPI_MCLK_DIV_256
@ SPI_MCLK_DIV_256
Definition: at32f435_437_spi.h:143
SPI_MCLK_DIV_8
@ SPI_MCLK_DIV_8
Definition: at32f435_437_spi.h:138
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f435_437_spi.h:90
SPI_FRAME_16BIT
@ SPI_FRAME_16BIT
Definition: at32f435_437_spi.h:91
SPI_CRC_RX
@ SPI_CRC_RX
Definition: at32f435_437_spi.h:173
SPI_CRC_TX
@ SPI_CRC_TX
Definition: at32f435_437_spi.h:174
I2S_MODE_MASTER_TX
@ I2S_MODE_MASTER_TX
Definition: at32f435_437_spi.h:242
I2S_MODE_MASTER_RX
@ I2S_MODE_MASTER_RX
Definition: at32f435_437_spi.h:243
I2S_MODE_SLAVE_RX
@ I2S_MODE_SLAVE_RX
Definition: at32f435_437_spi.h:241
I2S_MODE_SLAVE_TX
@ I2S_MODE_SLAVE_TX
Definition: at32f435_437_spi.h:240
i2s_init_type
i2s init type
Definition: at32f435_437_spi.h:274
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f435_437_spi.h:277
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f435_437_spi.h:278
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f435_437_spi.h:280
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f435_437_spi.h:276
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f435_437_spi.h:275
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:279
spi_init_type
spi init type
Definition: at32f435_437_spi.h:259
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f435_437_spi.h:261
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f435_437_spi.h:263
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f435_437_spi.h:264
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:265
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f435_437_spi.h:267
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f435_437_spi.h:262
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f435_437_spi.h:260
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f435_437_spi.h:266
spi_type
type define spi register all
Definition: at32f435_437_spi.h:287
spi_type::tdbe
__IO uint32_t tdbe
Definition: at32f435_437_spi.h:346
spi_type::clkpha
__IO uint32_t clkpha
Definition: at32f435_437_spi.h:297
spi_type::hwcsoe
__IO uint32_t hwcsoe
Definition: at32f435_437_spi.h:325
spi_type::slben
__IO uint32_t slben
Definition: at32f435_437_spi.h:310
spi_type::ntc
__IO uint32_t ntc
Definition: at32f435_437_spi.h:307
spi_type::mdiv_h
__IO uint32_t mdiv_h
Definition: at32f435_437_spi.h:331
spi_type::rdbfie
__IO uint32_t rdbfie
Definition: at32f435_437_spi.h:329
spi_type::mmerr
__IO uint32_t mmerr
Definition: at32f435_437_spi.h:350
spi_type::dmaren
__IO uint32_t dmaren
Definition: at32f435_437_spi.h:323
spi_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_spi.h:333
spi_type::bf
__IO uint32_t bf
Definition: at32f435_437_spi.h:352
spi_type::i2sdbn
__IO uint32_t i2sdbn
Definition: at32f435_437_spi.h:419
spi_type::rcrc
__IO uint32_t rcrc
Definition: at32f435_437_spi.h:389
spi_type::errie
__IO uint32_t errie
Definition: at32f435_437_spi.h:328
spi_type::i2scbn
__IO uint32_t i2scbn
Definition: at32f435_437_spi.h:418
spi_type::i2sclkpol
__IO uint32_t i2sclkpol
Definition: at32f435_437_spi.h:420
spi_type::cpoly
__IO uint32_t cpoly
Definition: at32f435_437_spi.h:376
spi_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f435_437_spi.h:294
spi_type::i2sodd
__IO uint32_t i2sodd
Definition: at32f435_437_spi.h:440
spi_type::swcsil
__IO uint32_t swcsil
Definition: at32f435_437_spi.h:303
spi_type::i2sclk
__IO uint32_t i2sclk
Definition: at32f435_437_spi.h:436
spi_type::tcrc
__IO uint32_t tcrc
Definition: at32f435_437_spi.h:402
spi_type::acs
__IO uint32_t acs
Definition: at32f435_437_spi.h:347
spi_type::i2smclkoe
__IO uint32_t i2smclkoe
Definition: at32f435_437_spi.h:441
spi_type::ltf
__IO uint32_t ltf
Definition: at32f435_437_spi.h:302
spi_type::clkpol
__IO uint32_t clkpol
Definition: at32f435_437_spi.h:298
spi_type::slbtd
__IO uint32_t slbtd
Definition: at32f435_437_spi.h:309
spi_type::dmaten
__IO uint32_t dmaten
Definition: at32f435_437_spi.h:324
spi_type::ccen
__IO uint32_t ccen
Definition: at32f435_437_spi.h:308
spi_type::fbn
__IO uint32_t fbn
Definition: at32f435_437_spi.h:306
spi_type::dt
__IO uint32_t dt
Definition: at32f435_437_spi.h:363
spi_type::msten
__IO uint32_t msten
Definition: at32f435_437_spi.h:299
spi_type::ccerr
__IO uint32_t ccerr
Definition: at32f435_437_spi.h:349
spi_type::sts
__IO uint32_t sts
Definition: at32f435_437_spi.h:342
spi_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_spi.h:311
spi_type::i2sdiv_h
__IO uint32_t i2sdiv_h
Definition: at32f435_437_spi.h:442
spi_type::tien
__IO uint32_t tien
Definition: at32f435_437_spi.h:327
spi_type::opersel
__IO uint32_t opersel
Definition: at32f435_437_spi.h:424
spi_type::i2sdiv_l
__IO uint32_t i2sdiv_l
Definition: at32f435_437_spi.h:439
spi_type::cspas
__IO uint32_t cspas
Definition: at32f435_437_spi.h:353
spi_type::i2smsel
__IO uint32_t i2smsel
Definition: at32f435_437_spi.h:426
spi_type::mdiv3en
__IO uint32_t mdiv3en
Definition: at32f435_437_spi.h:332
spi_type::pcmfssel
__IO uint32_t pcmfssel
Definition: at32f435_437_spi.h:423
spi_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f435_437_spi.h:320
spi_type::roerr
__IO uint32_t roerr
Definition: at32f435_437_spi.h:351
spi_type::i2sctrl
__IO uint32_t i2sctrl
Definition: at32f435_437_spi.h:415
spi_type::stdsel
__IO uint32_t stdsel
Definition: at32f435_437_spi.h:421
spi_type::rdbf
__IO uint32_t rdbf
Definition: at32f435_437_spi.h:345
spi_type::tuerr
__IO uint32_t tuerr
Definition: at32f435_437_spi.h:348
spi_type::mdiv_l
__IO uint32_t mdiv_l
Definition: at32f435_437_spi.h:300
spi_type::spien
__IO uint32_t spien
Definition: at32f435_437_spi.h:301
spi_type::swcsen
__IO uint32_t swcsen
Definition: at32f435_437_spi.h:304
spi_type::ora
__IO uint32_t ora
Definition: at32f435_437_spi.h:305
spi_type::i2sen
__IO uint32_t i2sen
Definition: at32f435_437_spi.h:425
spi_type::tdbeie
__IO uint32_t tdbeie
Definition: at32f435_437_spi.h:330


AT32F435/437 Firmwary Library: at32f435_437_tmr.c Source File

  • libraries
  • drivers
  • src
at32f435_437_tmr.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef TMR_MODULE_ENABLED
39
52void tmr_reset(tmr_type *tmr_x)
53{
54 if(tmr_x == TMR1)
55 {
56 crm_periph_reset(CRM_TMR1_PERIPH_RESET, TRUE);
57 crm_periph_reset(CRM_TMR1_PERIPH_RESET, FALSE);
58 }
59 else if(tmr_x == TMR2)
60 {
61 crm_periph_reset(CRM_TMR2_PERIPH_RESET, TRUE);
62 crm_periph_reset(CRM_TMR2_PERIPH_RESET, FALSE);
63 }
64 else if(tmr_x == TMR3)
65 {
66 crm_periph_reset(CRM_TMR3_PERIPH_RESET, TRUE);
67 crm_periph_reset(CRM_TMR3_PERIPH_RESET, FALSE);
68 }
69 else if(tmr_x == TMR4)
70 {
71 crm_periph_reset(CRM_TMR4_PERIPH_RESET, TRUE);
72 crm_periph_reset(CRM_TMR4_PERIPH_RESET, FALSE);
73 }
74 else if(tmr_x == TMR5)
75 {
76 crm_periph_reset(CRM_TMR5_PERIPH_RESET, TRUE);
77 crm_periph_reset(CRM_TMR5_PERIPH_RESET, FALSE);
78 }
79 else if(tmr_x == TMR6)
80 {
81 crm_periph_reset(CRM_TMR6_PERIPH_RESET, TRUE);
82 crm_periph_reset(CRM_TMR6_PERIPH_RESET, FALSE);
83 }
84 else if(tmr_x == TMR7)
85 {
86 crm_periph_reset(CRM_TMR7_PERIPH_RESET, TRUE);
87 crm_periph_reset(CRM_TMR7_PERIPH_RESET, FALSE);
88 }
89 else if(tmr_x == TMR8)
90 {
91 crm_periph_reset(CRM_TMR8_PERIPH_RESET, TRUE);
92 crm_periph_reset(CRM_TMR8_PERIPH_RESET, FALSE);
93 }
94 else if(tmr_x == TMR9)
95 {
96 crm_periph_reset(CRM_TMR9_PERIPH_RESET, TRUE);
97 crm_periph_reset(CRM_TMR9_PERIPH_RESET, FALSE);
98 }
99 else if(tmr_x == TMR10)
100 {
101 crm_periph_reset(CRM_TMR10_PERIPH_RESET, TRUE);
102 crm_periph_reset(CRM_TMR10_PERIPH_RESET, FALSE);
103 }
104 else if(tmr_x == TMR11)
105 {
106 crm_periph_reset(CRM_TMR11_PERIPH_RESET, TRUE);
107 crm_periph_reset(CRM_TMR11_PERIPH_RESET, FALSE);
108 }
109 else if(tmr_x == TMR12)
110 {
111 crm_periph_reset(CRM_TMR12_PERIPH_RESET, TRUE);
112 crm_periph_reset(CRM_TMR12_PERIPH_RESET, FALSE);
113 }
114 else if(tmr_x == TMR13)
115 {
116 crm_periph_reset(CRM_TMR13_PERIPH_RESET, TRUE);
117 crm_periph_reset(CRM_TMR13_PERIPH_RESET, FALSE);
118 }
119 else if(tmr_x == TMR14)
120 {
121 crm_periph_reset(CRM_TMR14_PERIPH_RESET, TRUE);
122 crm_periph_reset(CRM_TMR14_PERIPH_RESET, FALSE);
123 }
124 else if(tmr_x == TMR20)
125 {
126 crm_periph_reset(CRM_TMR20_PERIPH_RESET, TRUE);
127 crm_periph_reset(CRM_TMR20_PERIPH_RESET, FALSE);
128 }
129}
130
140void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
141{
142 /* tmr counter enable */
143 tmr_x->ctrl1_bit.tmren = new_state;
144}
145
152void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
153{
154 tmr_output_struct->oc_mode = TMR_OUTPUT_CONTROL_OFF;
155 tmr_output_struct->oc_idle_state = FALSE;
156 tmr_output_struct->occ_idle_state = FALSE;
157 tmr_output_struct->oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
158 tmr_output_struct->occ_polarity = TMR_OUTPUT_ACTIVE_HIGH;
159 tmr_output_struct->oc_output_state = FALSE;
160 tmr_output_struct->occ_output_state = FALSE;
161}
162
169void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct)
170{
171 tmr_input_struct->input_channel_select = TMR_SELECT_CHANNEL_1;
172 tmr_input_struct->input_polarity_select = TMR_INPUT_RISING_EDGE;
173 tmr_input_struct->input_mapped_select = TMR_CC_CHANNEL_MAPPED_DIRECT;
174 tmr_input_struct->input_filter_value = 0x0;
175}
176
183void tmr_brkdt_default_para_init(tmr_brkdt_config_type *tmr_brkdt_struct)
184{
185 tmr_brkdt_struct->deadtime = 0x0;
186 tmr_brkdt_struct->brk_polarity = TMR_BRK_INPUT_ACTIVE_LOW;
187 tmr_brkdt_struct->wp_level = TMR_WP_OFF;
188 tmr_brkdt_struct->auto_output_enable = FALSE ;
189 tmr_brkdt_struct->fcsoen_state = FALSE ;
190 tmr_brkdt_struct->fcsodis_state = FALSE ;
191 tmr_brkdt_struct->brk_enable = FALSE ;
192}
193
205void tmr_base_init(tmr_type* tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
206{
207 /* set the pr value */
208 tmr_x->pr = tmr_pr;
209
210 /* set the div value */
211 tmr_x->div = tmr_div;
212
213 /* trigger the overflow event to immediately reload pr value and div value */
214 tmr_x->swevt_bit.ovfswtr = TRUE;
215}
216
230void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
231{
232 /* set tmr clock source division */
233 tmr_x->ctrl1_bit.clkdiv = tmr_clock_div;
234}
235
251void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
252{
253 /* set the cnt direct */
254 tmr_x->ctrl1_bit.cnt_dir = tmr_cnt_dir;
255}
256
265void tmr_repetition_counter_set(tmr_type *tmr_x, uint8_t tmr_rpr_value)
266{
267 /* set the repetition counter value */
268 if((tmr_x == TMR1) || (tmr_x == TMR8))
269
270 {
271 tmr_x->rpr_bit.rpr = tmr_rpr_value;
272 }
273}
274
285void tmr_counter_value_set(tmr_type *tmr_x, uint32_t tmr_cnt_value)
286{
287 /* set the tmr counter value */
288 tmr_x->cval = tmr_cnt_value;
289}
290
299uint32_t tmr_counter_value_get(tmr_type *tmr_x)
300{
301 return tmr_x->cval;
302}
303
314void tmr_div_value_set(tmr_type *tmr_x, uint32_t tmr_div_value)
315{
316 /* set the tmr div value */
317 tmr_x->div = tmr_div_value;
318}
319
328uint32_t tmr_div_value_get(tmr_type *tmr_x)
329{
330 return tmr_x->div;
331}
332
350void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
351 tmr_output_config_type *tmr_output_struct)
352{
353 uint16_t channel_index = 0, channel_c_index = 0, channel = 0;
354
355 /* get channel idle state bit position in ctrl2 register */
356 channel_index = (uint16_t)(tmr_output_struct->oc_idle_state << (8 + tmr_channel));
357
358 /* get channel complementary idle state bit position in ctrl2 register */
359 channel_c_index = (uint16_t)(tmr_output_struct->occ_idle_state << (9 + tmr_channel));
360
361 if((tmr_x == TMR1) || (tmr_x == TMR8))
362 {
363 /* set output channel complementary idle state */
364 tmr_x->ctrl2 &= ~channel_c_index;
365 tmr_x->ctrl2 |= channel_c_index;
366 }
367
368 /* set output channel idle state */
369 tmr_x->ctrl2 &= ~channel_index;
370 tmr_x->ctrl2 |= channel_index;
371
372 /* set channel output mode */
373 channel = tmr_channel;
374
375 switch(channel)
376 {
377 case TMR_SELECT_CHANNEL_1:
378 tmr_x->cm1_output_bit.c1octrl = tmr_output_struct->oc_mode;
379 break;
380
381 case TMR_SELECT_CHANNEL_2:
382 tmr_x->cm1_output_bit.c2octrl = tmr_output_struct->oc_mode;
383 break;
384
385 case TMR_SELECT_CHANNEL_3:
386 tmr_x->cm2_output_bit.c3octrl = tmr_output_struct->oc_mode;
387 break;
388
389 case TMR_SELECT_CHANNEL_4:
390 tmr_x->cm2_output_bit.c4octrl = tmr_output_struct->oc_mode;
391 break;
392
393 case TMR_SELECT_CHANNEL_5:
394 tmr_x->cm3_output_bit.c5octrl = tmr_output_struct->oc_mode;
395 break;
396
397 default:
398 break;
399 }
400
401 /* get channel polarity bit position in cctrl register */
402 channel_index = (uint16_t)(tmr_output_struct->oc_polarity << ((tmr_channel * 2) + 1));
403
404 /* get channel complementary polarity bit position in cctrl register */
405 channel_c_index = (uint16_t)(tmr_output_struct->occ_polarity << ((tmr_channel * 2) + 3));
406
407 if((tmr_x == TMR1) || (tmr_x == TMR8))
408 {
409 /* set output channel complementary polarity */
410 tmr_x->cctrl &= ~channel_c_index;
411 tmr_x->cctrl |= channel_c_index;
412 }
413
414 /* set output channel polarity */
415 tmr_x->cctrl &= ~channel_index;
416 tmr_x->cctrl |= channel_index;
417
418 /* get channel enable bit position in cctrl register */
419 channel_index = (uint16_t)(tmr_output_struct->oc_output_state << (tmr_channel * 2));
420
421 /* get channel complementary enable bit position in cctrl register */
422 channel_c_index = (uint16_t)(tmr_output_struct->occ_output_state << ((tmr_channel * 2) + 2));
423
424 if((tmr_x == TMR1) || (tmr_x == TMR8))
425 {
426 /* set output channel complementary enable bit */
427 tmr_x->cctrl &= ~channel_c_index;
428 tmr_x->cctrl |= channel_c_index;
429 }
430
431 /* set output channel enable bit */
432 tmr_x->cctrl &= ~channel_index;
433 tmr_x->cctrl |= channel_index;
434}
435
461void tmr_output_channel_mode_select(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
462 tmr_output_control_mode_type oc_mode)
463{
464 uint16_t channel;
465
466 channel = tmr_channel;
467
468 switch(channel)
469 {
470 case TMR_SELECT_CHANNEL_1:
471 tmr_x->cm1_output_bit.c1octrl = oc_mode;
472 break;
473
474 case TMR_SELECT_CHANNEL_2:
475 tmr_x->cm1_output_bit.c2octrl = oc_mode;
476 break;
477
478 case TMR_SELECT_CHANNEL_3:
479 tmr_x->cm2_output_bit.c3octrl = oc_mode;
480 break;
481
482 case TMR_SELECT_CHANNEL_4:
483 tmr_x->cm2_output_bit.c4octrl = oc_mode;
484 break;
485
486 case TMR_SELECT_CHANNEL_5:
487 tmr_x->cm3_output_bit.c5octrl = oc_mode;
488 break;
489
490 default:
491 break;
492 }
493}
505void tmr_period_value_set(tmr_type *tmr_x, uint32_t tmr_pr_value)
506{
507 /* set tmr period value */
508 tmr_x->pr = tmr_pr_value;
509}
510
521uint32_t tmr_period_value_get(tmr_type *tmr_x)
522{
523 return tmr_x->pr;
524}
525
543void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
544 uint32_t tmr_channel_value)
545{
546 uint16_t channel;
547
548 channel = tmr_channel;
549
550 /* set tmr channel value */
551 switch(channel)
552 {
553 case TMR_SELECT_CHANNEL_1:
554 tmr_x->c1dt = tmr_channel_value;
555 break;
556
557 case TMR_SELECT_CHANNEL_2:
558 tmr_x->c2dt = tmr_channel_value;
559 break;
560
561 case TMR_SELECT_CHANNEL_3:
562 tmr_x->c3dt = tmr_channel_value;
563 break;
564
565 case TMR_SELECT_CHANNEL_4:
566 tmr_x->c4dt = tmr_channel_value;
567 break;
568
569 case TMR_SELECT_CHANNEL_5:
570 tmr_x->c5dt = tmr_channel_value;
571 break;
572
573 default:
574 break;
575 }
576}
577
593uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
594{
595 uint32_t cc_value_get = 0;
596 uint16_t channel;
597
598 channel = tmr_channel;
599
600 /* get tmr channel value */
601 switch(channel)
602 {
603 case TMR_SELECT_CHANNEL_1:
604 cc_value_get = tmr_x->c1dt;
605 break;
606
607 case TMR_SELECT_CHANNEL_2:
608 cc_value_get = tmr_x->c2dt;
609 break;
610
611 case TMR_SELECT_CHANNEL_3:
612 cc_value_get = tmr_x->c3dt;
613 break;
614
615 case TMR_SELECT_CHANNEL_4:
616 cc_value_get = tmr_x->c4dt;
617 break;
618
619 case TMR_SELECT_CHANNEL_5:
620 cc_value_get = tmr_x->c5dt;
621 break;
622
623 default:
624 break;
625 }
626
627 return cc_value_get;
628}
638void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
639{
640 /* tmr period buffer set */
641 tmr_x->ctrl1_bit.prben = new_state;
642}
643
660void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
661 confirm_state new_state)
662{
663 uint16_t channel;
664
665 channel = tmr_channel;
666
667 /* get tmr channel value */
668 switch(channel)
669 {
670 case TMR_SELECT_CHANNEL_1:
671 tmr_x->cm1_output_bit.c1oben = new_state;
672 break;
673
674 case TMR_SELECT_CHANNEL_2:
675 tmr_x->cm1_output_bit.c2oben = new_state;
676 break;
677
678 case TMR_SELECT_CHANNEL_3:
679 tmr_x->cm2_output_bit.c3oben = new_state;
680 break;
681
682 case TMR_SELECT_CHANNEL_4:
683 tmr_x->cm2_output_bit.c4oben = new_state;
684 break;
685
686 case TMR_SELECT_CHANNEL_5:
687 tmr_x->cm3_output_bit.c5oben = new_state;
688 break;
689
690 default:
691 break;
692 }
693}
694
711void tmr_output_channel_immediately_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
712 confirm_state new_state)
713{
714 uint16_t channel;
715
716 channel = tmr_channel;
717
718 /* get tmr channel value */
719 switch(channel)
720 {
721 case TMR_SELECT_CHANNEL_1:
722 tmr_x->cm1_output_bit.c1oien = new_state;
723 break;
724
725 case TMR_SELECT_CHANNEL_2:
726 tmr_x->cm1_output_bit.c2oien = new_state;
727 break;
728
729 case TMR_SELECT_CHANNEL_3:
730 tmr_x->cm2_output_bit.c3oien = new_state;
731 break;
732
733 case TMR_SELECT_CHANNEL_4:
734 tmr_x->cm2_output_bit.c4oien = new_state;
735 break;
736
737 case TMR_SELECT_CHANNEL_5:
738 tmr_x->cm3_output_bit.c5oien = new_state;
739 break;
740
741 default:
742 break;
743 }
744}
745
762void tmr_output_channel_switch_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
763 confirm_state new_state)
764{
765 uint16_t channel;
766
767 channel = tmr_channel;
768
769 /* get tmr channel value */
770 switch(channel)
771 {
772 case TMR_SELECT_CHANNEL_1:
773 tmr_x->cm1_output_bit.c1osen = new_state;
774 break;
775
776 case TMR_SELECT_CHANNEL_2:
777 tmr_x->cm1_output_bit.c2osen = new_state;
778 break;
779
780 case TMR_SELECT_CHANNEL_3:
781 tmr_x->cm2_output_bit.c3osen = new_state;
782 break;
783
784 case TMR_SELECT_CHANNEL_4:
785 tmr_x->cm2_output_bit.c4osen = new_state;
786 break;
787
788 case TMR_SELECT_CHANNEL_5:
789 tmr_x->cm3_output_bit.c5osen = new_state;
790 break;
791
792 default:
793 break;
794 }
795}
796
805void tmr_one_cycle_mode_enable(tmr_type *tmr_x, confirm_state new_state)
806{
807 /* tmr one cycle mode enable */
808 tmr_x->ctrl1_bit.ocmen = new_state;
809}
810
819void tmr_32_bit_function_enable (tmr_type *tmr_x, confirm_state new_state)
820{
821 /* tmr 32 bit function(plus mode) enable,only for TMR2/TMR5 */
822 if((tmr_x == TMR2) || (tmr_x == TMR5))
823 {
824 tmr_x->ctrl1_bit.pmen = new_state;
825 }
826}
827
837void tmr_overflow_request_source_set(tmr_type *tmr_x, confirm_state new_state)
838{
839 tmr_x->ctrl1_bit.ovfs = new_state;
840}
841
851void tmr_overflow_event_disable(tmr_type *tmr_x, confirm_state new_state)
852{
853 tmr_x->ctrl1_bit.ovfen = new_state;
854}
855
872void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, \
873 tmr_channel_input_divider_type divider_factor)
874{
875 uint16_t channel = 0;
876
877 /* get channel selected */
878 channel = input_struct->input_channel_select;
879
880 switch(channel)
881 {
882 case TMR_SELECT_CHANNEL_1:
883 tmr_x->cctrl_bit.c1p = (uint32_t)input_struct->input_polarity_select;
884 tmr_x->cctrl_bit.c1cp = (input_struct->input_polarity_select & 0x2) >> 1;
885 tmr_x->cm1_input_bit.c1c = input_struct->input_mapped_select;
886 tmr_x->cm1_input_bit.c1df = input_struct->input_filter_value;
887 tmr_x->cm1_input_bit.c1idiv = divider_factor;
888 tmr_x->cctrl_bit.c1en = TRUE;
889 break;
890
891 case TMR_SELECT_CHANNEL_2:
892 tmr_x->cctrl_bit.c2p = (uint32_t)input_struct->input_polarity_select;
893 tmr_x->cctrl_bit.c2cp = (input_struct->input_polarity_select & 0x2) >> 1;
894 tmr_x->cm1_input_bit.c2c = input_struct->input_mapped_select;
895 tmr_x->cm1_input_bit.c2df = input_struct->input_filter_value;
896 tmr_x->cm1_input_bit.c2idiv = divider_factor;
897 tmr_x->cctrl_bit.c2en = TRUE;
898 break;
899
900 case TMR_SELECT_CHANNEL_3:
901 tmr_x->cctrl_bit.c3p = (uint32_t)input_struct->input_polarity_select;
902 tmr_x->cctrl_bit.c3cp = (input_struct->input_polarity_select & 0x2) >> 1;
903 tmr_x->cm2_input_bit.c3c = input_struct->input_mapped_select;
904 tmr_x->cm2_input_bit.c3df = input_struct->input_filter_value;
905 tmr_x->cm2_input_bit.c3idiv = divider_factor;
906 tmr_x->cctrl_bit.c3en = TRUE;
907 break;
908
909 case TMR_SELECT_CHANNEL_4:
910 tmr_x->cctrl_bit.c4p = (uint32_t)input_struct->input_polarity_select;
911 tmr_x->cm2_input_bit.c4c = input_struct->input_mapped_select;
912 tmr_x->cm2_input_bit.c4df = input_struct->input_filter_value;
913 tmr_x->cm2_input_bit.c4idiv = divider_factor;
914 tmr_x->cctrl_bit.c4en = TRUE;
915 break;
916
917 default:
918 break;
919 }
920}
921
940void tmr_channel_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
941{
942 uint16_t channel;
943
944 channel = tmr_channel;
945
946 switch(channel)
947 {
948 case TMR_SELECT_CHANNEL_1:
949 tmr_x->cctrl_bit.c1en = new_state;
950 break;
951
952 case TMR_SELECT_CHANNEL_1C:
953 tmr_x->cctrl_bit.c1cen = new_state;
954 break;
955
956 case TMR_SELECT_CHANNEL_2:
957 tmr_x->cctrl_bit.c2en = new_state;
958 break;
959
960 case TMR_SELECT_CHANNEL_2C:
961 tmr_x->cctrl_bit.c2cen = new_state;
962 break;
963
964 case TMR_SELECT_CHANNEL_3:
965 tmr_x->cctrl_bit.c3en = new_state;
966 break;
967
968 case TMR_SELECT_CHANNEL_3C:
969 tmr_x->cctrl_bit.c3cen = new_state;
970 break;
971
972 case TMR_SELECT_CHANNEL_4:
973 tmr_x->cctrl_bit.c4en = new_state;
974 break;
975
976 default:
977 break;
978 }
979}
980
996void tmr_input_channel_filter_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
997 uint16_t filter_value)
998{
999 uint16_t channel;
1000
1001 channel = tmr_channel;
1002
1003 switch(channel)
1004 {
1005 case TMR_SELECT_CHANNEL_1:
1006 tmr_x->cm1_input_bit.c1df = filter_value;
1007 break;
1008
1009 case TMR_SELECT_CHANNEL_2:
1010 tmr_x->cm1_input_bit.c2df = filter_value;
1011 break;
1012
1013 case TMR_SELECT_CHANNEL_3:
1014 tmr_x->cm2_input_bit.c3df = filter_value;
1015 break;
1016
1017 case TMR_SELECT_CHANNEL_4:
1018 tmr_x->cm2_input_bit.c4df = filter_value;
1019 break;
1020
1021 default:
1022 break;
1023 }
1024}
1025
1042void tmr_pwm_input_config(tmr_type *tmr_x, tmr_input_config_type *input_struct, \
1043 tmr_channel_input_divider_type divider_factor)
1044{
1045 uint16_t channel = 0;
1046
1047 /* get channel selected */
1048 channel = input_struct->input_channel_select;
1049
1050 switch(channel)
1051 {
1052 case TMR_SELECT_CHANNEL_1:
1053 if(input_struct->input_polarity_select == TMR_INPUT_RISING_EDGE)
1054 {
1055 /* set channel polarity */
1056 tmr_x->cctrl_bit.c1p = TMR_INPUT_RISING_EDGE;
1057 tmr_x->cctrl_bit.c2p = TMR_INPUT_FALLING_EDGE;
1058 }
1059 else if(input_struct->input_polarity_select == TMR_INPUT_FALLING_EDGE)
1060 {
1061 /* set channel polarity */
1062 tmr_x->cctrl_bit.c1p = TMR_INPUT_FALLING_EDGE;
1063 tmr_x->cctrl_bit.c2p = TMR_INPUT_RISING_EDGE;
1064 }
1065
1066 if(input_struct->input_mapped_select == TMR_CC_CHANNEL_MAPPED_DIRECT)
1067 {
1068 /* ic1 is mapped on ti1 */
1069 tmr_x->cm1_input_bit.c1c = TMR_CC_CHANNEL_MAPPED_DIRECT;
1070
1071 /* ic1 is mapped on ti2 */
1072 tmr_x->cm1_input_bit.c2c = TMR_CC_CHANNEL_MAPPED_INDIRECT;
1073 }
1074 else if(input_struct->input_mapped_select == TMR_CC_CHANNEL_MAPPED_INDIRECT)
1075 {
1076 /* ic1 is mapped on ti1 */
1077 tmr_x->cm1_input_bit.c1c = TMR_CC_CHANNEL_MAPPED_INDIRECT;
1078
1079 /* ic1 is mapped on ti2 */
1080 tmr_x->cm1_input_bit.c2c = TMR_CC_CHANNEL_MAPPED_DIRECT;
1081 }
1082
1083 /* set input ch1 and ch2 filter value*/
1084 tmr_x->cm1_input_bit.c1df = input_struct->input_filter_value;
1085 tmr_x->cm1_input_bit.c2df = input_struct->input_filter_value;
1086
1087 /*set input ch1 and ch2 divider value*/
1088 tmr_x->cm1_input_bit.c1idiv = divider_factor;
1089 tmr_x->cm1_input_bit.c2idiv = divider_factor;
1090
1091 tmr_x->cctrl_bit.c1en = TRUE;
1092 tmr_x->cctrl_bit.c2en = TRUE;
1093 break;
1094
1095 case TMR_SELECT_CHANNEL_2:
1096 if(input_struct->input_polarity_select == TMR_INPUT_RISING_EDGE)
1097 {
1098 /* set channel polarity */
1099 tmr_x->cctrl_bit.c2p = TMR_INPUT_RISING_EDGE;
1100 tmr_x->cctrl_bit.c1p = TMR_INPUT_FALLING_EDGE;
1101 }
1102 else if(input_struct->input_polarity_select == TMR_INPUT_FALLING_EDGE)
1103 {
1104 /* set channel polarity */
1105 tmr_x->cctrl_bit.c2p = TMR_INPUT_FALLING_EDGE;
1106 tmr_x->cctrl_bit.c1p = TMR_INPUT_RISING_EDGE;
1107 }
1108
1109 if(input_struct->input_mapped_select == TMR_CC_CHANNEL_MAPPED_DIRECT)
1110 {
1111 /* set mapped direct */
1112 tmr_x->cm1_input_bit.c2c = TMR_CC_CHANNEL_MAPPED_DIRECT;
1113 tmr_x->cm1_input_bit.c1c = TMR_CC_CHANNEL_MAPPED_INDIRECT;
1114 }
1115 else if(input_struct->input_mapped_select == TMR_CC_CHANNEL_MAPPED_INDIRECT)
1116 {
1117 /* set mapped direct */
1118 tmr_x->cm1_input_bit.c2c = TMR_CC_CHANNEL_MAPPED_INDIRECT;
1119 tmr_x->cm1_input_bit.c1c = TMR_CC_CHANNEL_MAPPED_DIRECT;
1120 }
1121
1122 /* set input ch1 and ch2 filter value*/
1123 tmr_x->cm1_input_bit.c1df = input_struct->input_filter_value;
1124 tmr_x->cm1_input_bit.c2df = input_struct->input_filter_value;
1125
1126 /*set input ch1 and ch2 divider value*/
1127 tmr_x->cm1_input_bit.c1idiv = divider_factor;
1128 tmr_x->cm1_input_bit.c2idiv = divider_factor;
1129
1130 tmr_x->cctrl_bit.c1en = TRUE;
1131 tmr_x->cctrl_bit.c2en = TRUE;
1132 break;
1133
1134 default:
1135 break;
1136 }
1137}
1138
1150void tmr_channel1_input_select(tmr_type *tmr_x, tmr_channel1_input_connected_type ch1_connect)
1151{
1152 tmr_x->ctrl2_bit.c1insel = ch1_connect;
1153}
1154
1175void tmr_input_channel_divider_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
1176 tmr_channel_input_divider_type divider_factor)
1177{
1178 uint16_t channel;
1179
1180 channel = tmr_channel;
1181
1182 switch(channel)
1183 {
1184 case TMR_SELECT_CHANNEL_1:
1185 tmr_x->cm1_input_bit.c1idiv = divider_factor;
1186 break;
1187
1188 case TMR_SELECT_CHANNEL_2:
1189 tmr_x->cm1_input_bit.c2idiv = divider_factor;
1190 break;
1191
1192 case TMR_SELECT_CHANNEL_3:
1193 tmr_x->cm2_input_bit.c3idiv = divider_factor;
1194 break;
1195
1196 case TMR_SELECT_CHANNEL_4:
1197 tmr_x->cm2_input_bit.c4idiv = divider_factor;
1198 break;
1199
1200 default:
1201 break;
1202 }
1203}
1204
1222void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode)
1223{
1224 tmr_x->ctrl2_bit.ptos = primary_mode;
1225}
1226
1245void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
1246{
1247 tmr_x->stctrl_bit.smsel = sub_mode;
1248}
1249
1261void tmr_channel_dma_select(tmr_type *tmr_x, tmr_dma_request_source_type cc_dma_select)
1262{
1263 tmr_x->ctrl2_bit.drs = cc_dma_select;
1264}
1265
1274void tmr_hall_select(tmr_type *tmr_x, confirm_state new_state)
1275{
1276 tmr_x->ctrl2_bit.ccfs = new_state;
1277}
1278
1287void tmr_channel_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
1288{
1289 tmr_x->ctrl2_bit.cbctrl = new_state;
1290}
1291
1300void tmr_trgout2_enable(tmr_type *tmr_x, confirm_state new_state)
1301{
1302 tmr_x->ctrl2_bit.trgout2en = new_state;
1303}
1304
1322void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
1323{
1324 tmr_x->stctrl_bit.stis = trigger_select;
1325}
1326
1335void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state)
1336{
1337 tmr_x->stctrl_bit.sts = new_state;
1338}
1339
1358void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
1359{
1360 if(new_state == TRUE)
1361 {
1362 tmr_x->iden |= dma_request;
1363 }
1364 else if(new_state == FALSE)
1365 {
1366 tmr_x->iden &= ~dma_request;
1367 }
1368}
1369
1389void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
1390{
1391 if(new_state == TRUE)
1392 {
1393 tmr_x->iden |= tmr_interrupt;
1394 }
1395 else if(new_state == FALSE)
1396 {
1397 tmr_x->iden &= ~tmr_interrupt;
1398 }
1399}
1400
1424 flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
1425{
1426 flag_status status = RESET;
1427
1428 if((tmr_x->ists & tmr_flag) != RESET)
1429 {
1430 status = SET;
1431 }
1432 else
1433 {
1434 status = RESET;
1435 }
1436
1437 return status;
1438}
1439
1463void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
1464{
1465 tmr_x->ists = ~tmr_flag;
1466}
1467
1486void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
1487{
1488 tmr_x->swevt |= tmr_event;
1489}
1490
1499void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
1500{
1501 tmr_x->brk_bit.oen = new_state;
1502}
1503
1511void tmr_internal_clock_set(tmr_type *tmr_x)
1512{
1513 tmr_x->stctrl_bit.smsel = TMR_SUB_MODE_DIABLE;
1514}
1515
1537void tmr_output_channel_polarity_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
1538 tmr_polarity_active_type oc_polarity)
1539{
1540 uint16_t channel;
1541
1542 channel = tmr_channel;
1543
1544 switch(channel)
1545 {
1546 case TMR_SELECT_CHANNEL_1:
1547 tmr_x->cctrl_bit.c1p = (uint32_t)oc_polarity;
1548 break;
1549
1550 case TMR_SELECT_CHANNEL_2:
1551 tmr_x->cctrl_bit.c2p = (uint32_t)oc_polarity;
1552 break;
1553
1554 case TMR_SELECT_CHANNEL_3:
1555 tmr_x->cctrl_bit.c3p = (uint32_t)oc_polarity;
1556 break;
1557
1558 case TMR_SELECT_CHANNEL_4:
1559 tmr_x->cctrl_bit.c4p = (uint32_t)oc_polarity;
1560 break;
1561
1562 case TMR_SELECT_CHANNEL_1C:
1563 tmr_x->cctrl_bit.c1cp = (uint32_t)oc_polarity;
1564 break;
1565
1566 case TMR_SELECT_CHANNEL_2C:
1567 tmr_x->cctrl_bit.c2cp = (uint32_t)oc_polarity;
1568 break;
1569
1570 case TMR_SELECT_CHANNEL_3C:
1571 tmr_x->cctrl_bit.c3cp = (uint32_t)oc_polarity;
1572 break;
1573
1574 default:
1575 break;
1576 }
1577}
1578
1597void tmr_external_clock_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, \
1598 tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
1599{
1600 tmr_x->stctrl_bit.esdiv = es_divide;
1601 tmr_x->stctrl_bit.esp = es_polarity;
1602 tmr_x->stctrl_bit.esf = es_filter;
1603}
1604
1623void tmr_external_clock_mode1_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, \
1624 tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
1625{
1626 tmr_external_clock_config(tmr_x, es_divide, es_polarity, es_filter);
1627 tmr_x->stctrl_bit.smsel = TMR_SUB_EXTERNAL_CLOCK_MODE_A;
1628 tmr_x->stctrl_bit.stis = TMR_SUB_INPUT_SEL_EXTIN;
1629}
1630
1649void tmr_external_clock_mode2_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, \
1650 tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
1651{
1652 tmr_external_clock_config(tmr_x, es_divide, es_polarity, es_filter);
1653 tmr_x->stctrl_bit.ecmben = TRUE;
1654}
1655
1678void tmr_encoder_mode_config(tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type \
1679 ic1_polarity, tmr_input_polarity_type ic2_polarity)
1680{
1681 tmr_x->stctrl_bit.smsel = encoder_mode;
1682
1683 /* set ic1 polarity */
1684 tmr_x->cctrl_bit.c1p = (ic1_polarity & 0x1);
1685 tmr_x->cctrl_bit.c1cp = (ic1_polarity >> 1);
1686 /* set ic1 as input channel */
1687 tmr_x->cm1_input_bit.c1c = TMR_CC_CHANNEL_MAPPED_DIRECT;
1688
1689 /* set ic2 polarity */
1690 tmr_x->cctrl_bit.c2p = (ic2_polarity & 0x1);
1691 tmr_x->cctrl_bit.c2cp = (ic2_polarity >> 1);
1692 /* set ic2 as input channel */
1693 tmr_x->cm1_input_bit.c2c = TMR_CC_CHANNEL_MAPPED_DIRECT;
1694}
1695
1715void tmr_force_output_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
1716 tmr_force_output_type force_output)
1717{
1718 uint16_t channel;
1719
1720 channel = tmr_channel;
1721
1722 switch(channel)
1723 {
1724 case TMR_SELECT_CHANNEL_1:
1725 tmr_x->cm1_output_bit.c1octrl = force_output;
1726 break;
1727
1728 case TMR_SELECT_CHANNEL_2:
1729 tmr_x->cm1_output_bit.c2octrl = force_output;
1730 break;
1731
1732 case TMR_SELECT_CHANNEL_3:
1733 tmr_x->cm2_output_bit.c3octrl = force_output;
1734 break;
1735
1736 case TMR_SELECT_CHANNEL_4:
1737 tmr_x->cm2_output_bit.c4octrl = force_output;
1738 break;
1739
1740 case TMR_SELECT_CHANNEL_5:
1741 tmr_x->cm3_output_bit.c5octrl = force_output;
1742 break;
1743
1744 default:
1745 break;
1746 }
1747}
1748
1785void tmr_dma_control_config(tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, \
1786 tmr_dma_address_type dma_base_address)
1787{
1788 tmr_x->dmactrl_bit.dtb = dma_length;
1789 tmr_x->dmactrl_bit.addr = dma_base_address;
1790}
1791
1801void tmr_brkdt_config(tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
1802{
1803 tmr_x->brk_bit.brken = brkdt_struct->brk_enable;
1804 tmr_x->brk_bit.dtc = brkdt_struct->deadtime;
1805 tmr_x->brk_bit.fcsodis = brkdt_struct->fcsodis_state;
1806 tmr_x->brk_bit.fcsoen = brkdt_struct->fcsoen_state;
1807 tmr_x->brk_bit.brkv = brkdt_struct->brk_polarity;
1808 tmr_x->brk_bit.aoen = brkdt_struct->auto_output_enable;
1809 tmr_x->brk_bit.wpc = brkdt_struct->wp_level;
1810}
1811
1824void tmr_iremap_config(tmr_type *tmr_x, tmr_input_remap_type input_remap)
1825{
1826 if(tmr_x == TMR2)
1827 {
1828 tmr_x->rmp_bit.tmr2_ch1_irmp = input_remap;
1829 }
1830 else if(tmr_x == TMR5)
1831 {
1832 tmr_x->rmp_bit.tmr5_ch4_irmp = input_remap;
1833 }
1834}
1835
1840#endif
1841
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f435/examples/edma/burst_mode/src/main.c:39
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f435_437_crm.c:251
CRM_TMR2_PERIPH_RESET
@ CRM_TMR2_PERIPH_RESET
Definition: at32f435_437_crm.h:275
CRM_TMR4_PERIPH_RESET
@ CRM_TMR4_PERIPH_RESET
Definition: at32f435_437_crm.h:277
CRM_TMR10_PERIPH_RESET
@ CRM_TMR10_PERIPH_RESET
Definition: at32f435_437_crm.h:310
CRM_TMR13_PERIPH_RESET
@ CRM_TMR13_PERIPH_RESET
Definition: at32f435_437_crm.h:282
CRM_TMR20_PERIPH_RESET
@ CRM_TMR20_PERIPH_RESET
Definition: at32f435_437_crm.h:312
CRM_TMR14_PERIPH_RESET
@ CRM_TMR14_PERIPH_RESET
Definition: at32f435_437_crm.h:283
CRM_TMR5_PERIPH_RESET
@ CRM_TMR5_PERIPH_RESET
Definition: at32f435_437_crm.h:278
CRM_TMR9_PERIPH_RESET
@ CRM_TMR9_PERIPH_RESET
Definition: at32f435_437_crm.h:309
CRM_TMR1_PERIPH_RESET
@ CRM_TMR1_PERIPH_RESET
Definition: at32f435_437_crm.h:301
CRM_TMR8_PERIPH_RESET
@ CRM_TMR8_PERIPH_RESET
Definition: at32f435_437_crm.h:302
CRM_TMR3_PERIPH_RESET
@ CRM_TMR3_PERIPH_RESET
Definition: at32f435_437_crm.h:276
CRM_TMR7_PERIPH_RESET
@ CRM_TMR7_PERIPH_RESET
Definition: at32f435_437_crm.h:280
CRM_TMR12_PERIPH_RESET
@ CRM_TMR12_PERIPH_RESET
Definition: at32f435_437_crm.h:281
CRM_TMR11_PERIPH_RESET
@ CRM_TMR11_PERIPH_RESET
Definition: at32f435_437_crm.h:311
CRM_TMR6_PERIPH_RESET
@ CRM_TMR6_PERIPH_RESET
Definition: at32f435_437_crm.h:279
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
tmr_dma_request_type
tmr_dma_request_type
tmr dma request type
Definition: at32f435_437_tmr.h:270
tmr_external_signal_divider_type
tmr_external_signal_divider_type
tmr external signal divider type
Definition: at32f435_437_tmr.h:309
tmr_polarity_active_type
tmr_polarity_active_type
tmr polarity active type
Definition: at32f435_437_tmr.h:299
tmr_count_mode_type
tmr_count_mode_type
tmr counter mode type
Definition: at32f435_437_tmr.h:106
tmr_input_polarity_type
tmr_input_polarity_type
tmr input channel polarity type
Definition: at32f435_437_tmr.h:206
tmr_dma_request_source_type
tmr_dma_request_source_type
tmr dma request source select type
Definition: at32f435_437_tmr.h:261
tmr_channel_select_type
tmr_channel_select_type
tmr channel select type
Definition: at32f435_437_tmr.h:216
tmr_external_signal_polarity_type
tmr_external_signal_polarity_type
tmr external signal polarity type
Definition: at32f435_437_tmr.h:320
tmr_dma_address_type
tmr_dma_address_type
tmr dma base address type
Definition: at32f435_437_tmr.h:354
tmr_channel1_input_connected_type
tmr_channel1_input_connected_type
tmr channel1 input connected type
Definition: at32f435_437_tmr.h:231
tmr_clock_division_type
tmr_clock_division_type
tmr clock division type
Definition: at32f435_437_tmr.h:96
tmr_event_trigger_type
tmr_event_trigger_type
tmr event triggered by software type
Definition: at32f435_437_tmr.h:284
tmr_output_control_mode_type
tmr_output_control_mode_type
tmr output control mode type
Definition: at32f435_437_tmr.h:173
tmr_dma_transfer_length_type
tmr_dma_transfer_length_type
tmr dma transfer length type
Definition: at32f435_437_tmr.h:329
sub_tmr_input_sel_type
sub_tmr_input_sel_type
tmr subordinate mode input select type
Definition: at32f435_437_tmr.h:133
tmr_force_output_type
tmr_force_output_type
tmr force output type
Definition: at32f435_437_tmr.h:188
tmr_input_remap_type
tmr_input_remap_type
tmr input remap type
Definition: at32f435_437_tmr.h:400
tmr_sub_mode_select_type
tmr_sub_mode_select_type
tmr subordinate mode select type
Definition: at32f435_437_tmr.h:148
tmr_primary_select_type
tmr_primary_select_type
tmr primary mode select type
Definition: at32f435_437_tmr.h:118
tmr_encoder_mode_type
tmr_encoder_mode_type
tmr encoder mode type
Definition: at32f435_437_tmr.h:163
tmr_channel_input_divider_type
tmr_channel_input_divider_type
tmr input divider type
Definition: at32f435_437_tmr.h:250
TMR_INPUT_FALLING_EDGE
@ TMR_INPUT_FALLING_EDGE
Definition: at32f435_437_tmr.h:208
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f435_437_tmr.h:207
TMR_SELECT_CHANNEL_1C
@ TMR_SELECT_CHANNEL_1C
Definition: at32f435_437_tmr.h:218
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f435_437_tmr.h:221
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_SELECT_CHANNEL_2C
@ TMR_SELECT_CHANNEL_2C
Definition: at32f435_437_tmr.h:220
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f435_437_tmr.h:223
TMR_SELECT_CHANNEL_5
@ TMR_SELECT_CHANNEL_5
Definition: at32f435_437_tmr.h:224
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f435_437_tmr.h:219
TMR_SELECT_CHANNEL_3C
@ TMR_SELECT_CHANNEL_3C
Definition: at32f435_437_tmr.h:222
TMR_WP_OFF
@ TMR_WP_OFF
Definition: at32f435_437_tmr.h:390
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f435_437_tmr.h:241
TMR_CC_CHANNEL_MAPPED_INDIRECT
@ TMR_CC_CHANNEL_MAPPED_INDIRECT
Definition: at32f435_437_tmr.h:242
TMR_BRK_INPUT_ACTIVE_LOW
@ TMR_BRK_INPUT_ACTIVE_LOW
Definition: at32f435_437_tmr.h:381
TMR_OUTPUT_CONTROL_OFF
@ TMR_OUTPUT_CONTROL_OFF
Definition: at32f435_437_tmr.h:174
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:198
TMR_SUB_INPUT_SEL_EXTIN
@ TMR_SUB_INPUT_SEL_EXTIN
Definition: at32f435_437_tmr.h:141
TMR_SUB_EXTERNAL_CLOCK_MODE_A
@ TMR_SUB_EXTERNAL_CLOCK_MODE_A
Definition: at32f435_437_tmr.h:156
TMR_SUB_MODE_DIABLE
@ TMR_SUB_MODE_DIABLE
Definition: at32f435_437_tmr.h:149
tmr_dma_control_config
void tmr_dma_control_config(tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, tmr_dma_address_type dma_base_address)
config tmr dma control
Definition: at32f435_437_tmr.c:1785
tmr_channel_value_get
uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value
Definition: at32f435_437_tmr.c:593
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f435_437_tmr.c:1463
tmr_period_value_get
uint32_t tmr_period_value_get(tmr_type *tmr_x)
get tmr period value
Definition: at32f435_437_tmr.c:521
tmr_channel_buffer_enable
void tmr_channel_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
select tmr channel buffer
Definition: at32f435_437_tmr.c:1287
tmr_overflow_request_source_set
void tmr_overflow_request_source_set(tmr_type *tmr_x, confirm_state new_state)
select tmr the overflow event sources
Definition: at32f435_437_tmr.c:837
tmr_output_channel_mode_select
void tmr_output_channel_mode_select(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_control_mode_type oc_mode)
select tmr output channel mode
Definition: at32f435_437_tmr.c:461
tmr_input_channel_divider_set
void tmr_input_channel_divider_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_channel_input_divider_type divider_factor)
set tmr input channel divider
Definition: at32f435_437_tmr.c:1175
tmr_dma_request_enable
void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request
Definition: at32f435_437_tmr.c:1358
tmr_external_clock_config
void tmr_external_clock_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock
Definition: at32f435_437_tmr.c:1597
tmr_repetition_counter_set
void tmr_repetition_counter_set(tmr_type *tmr_x, uint8_t tmr_rpr_value)
set the repetition counter register(rpr) value
Definition: at32f435_437_tmr.c:265
tmr_period_buffer_enable
void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
set tmr period buffer
Definition: at32f435_437_tmr.c:638
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_internal_clock_set
void tmr_internal_clock_set(tmr_type *tmr_x)
set tmr select internal clock
Definition: at32f435_437_tmr.c:1511
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_brkdt_default_para_init
void tmr_brkdt_default_para_init(tmr_brkdt_config_type *tmr_brkdt_struct)
init tmr brkdt default para
Definition: at32f435_437_tmr.c:183
tmr_force_output_set
void tmr_force_output_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_force_output_type force_output)
set tmr force output
Definition: at32f435_437_tmr.c:1715
tmr_counter_value_set
void tmr_counter_value_set(tmr_type *tmr_x, uint32_t tmr_cnt_value)
set tmr counter value
Definition: at32f435_437_tmr.c:285
tmr_div_value_get
uint32_t tmr_div_value_get(tmr_type *tmr_x)
get tmr div value
Definition: at32f435_437_tmr.c:328
tmr_input_channel_init
void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel
Definition: at32f435_437_tmr.c:872
tmr_input_channel_filter_set
void tmr_input_channel_filter_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint16_t filter_value)
set tmr input channel filter
Definition: at32f435_437_tmr.c:996
tmr_period_value_set
void tmr_period_value_set(tmr_type *tmr_x, uint32_t tmr_pr_value)
set tmr period value
Definition: at32f435_437_tmr.c:505
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f435_437_tmr.c:1245
tmr_counter_value_get
uint32_t tmr_counter_value_get(tmr_type *tmr_x)
get tmr counter value
Definition: at32f435_437_tmr.c:299
tmr_brkdt_config
void tmr_brkdt_config(tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
config tmr break mode and dead-time
Definition: at32f435_437_tmr.c:1801
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f435_437_tmr.c:1424
tmr_external_clock_mode2_config
void tmr_external_clock_mode2_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode2
Definition: at32f435_437_tmr.c:1649
tmr_input_default_para_init
void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct)
init tmr input default para
Definition: at32f435_437_tmr.c:169
tmr_div_value_set
void tmr_div_value_set(tmr_type *tmr_x, uint32_t tmr_div_value)
set tmr div value
Definition: at32f435_437_tmr.c:314
tmr_iremap_config
void tmr_iremap_config(tmr_type *tmr_x, tmr_input_remap_type input_remap)
set tmr2/tmr5 input channel remap
Definition: at32f435_437_tmr.c:1824
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f435_437_tmr.c:1486
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f435_437_tmr.c:1499
tmr_sub_sync_mode_set
void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode
Definition: at32f435_437_tmr.c:1335
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_hall_select
void tmr_hall_select(tmr_type *tmr_x, confirm_state new_state)
select tmr hall
Definition: at32f435_437_tmr.c:1274
tmr_channel1_input_select
void tmr_channel1_input_select(tmr_type *tmr_x, tmr_channel1_input_connected_type ch1_connect)
select tmr channel1 input
Definition: at32f435_437_tmr.c:1150
tmr_32_bit_function_enable
void tmr_32_bit_function_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode)
Definition: at32f435_437_tmr.c:819
tmr_external_clock_mode1_config
void tmr_external_clock_mode1_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode1
Definition: at32f435_437_tmr.c:1623
tmr_pwm_input_config
void tmr_pwm_input_config(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
config tmr pwm input
Definition: at32f435_437_tmr.c:1042
tmr_trgout2_enable
void tmr_trgout2_enable(tmr_type *tmr_x, confirm_state new_state)
select tmr trgout2
Definition: at32f435_437_tmr.c:1300
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f435_437_tmr.c:1322
tmr_output_channel_buffer_enable
void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel buffer
Definition: at32f435_437_tmr.c:660
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f435_437_tmr.c:1389
tmr_primary_mode_select
void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode
Definition: at32f435_437_tmr.c:1222
tmr_overflow_event_disable
void tmr_overflow_event_disable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr overflow event generation
Definition: at32f435_437_tmr.c:851
tmr_channel_dma_select
void tmr_channel_dma_select(tmr_type *tmr_x, tmr_dma_request_source_type cc_dma_select)
select tmr channel dma
Definition: at32f435_437_tmr.c:1261
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_output_channel_immediately_set
void tmr_output_channel_immediately_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel immediately
Definition: at32f435_437_tmr.c:711
tmr_encoder_mode_config
void tmr_encoder_mode_config(tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type ic1_polarity, tmr_input_polarity_type ic2_polarity)
config tmr encoder mode
Definition: at32f435_437_tmr.c:1678
tmr_channel_enable
void tmr_channel_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable
Definition: at32f435_437_tmr.c:940
tmr_output_channel_switch_set
void tmr_output_channel_switch_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel switch
Definition: at32f435_437_tmr.c:762
tmr_reset
void tmr_reset(tmr_type *tmr_x)
tmr reset by crm reset register
Definition: at32f435_437_tmr.c:52
tmr_output_channel_polarity_set
void tmr_output_channel_polarity_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_polarity_active_type oc_polarity)
set tmr output channel polarity
Definition: at32f435_437_tmr.c:1537
tmr_one_cycle_mode_enable
void tmr_one_cycle_mode_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr one cycle mode
Definition: at32f435_437_tmr.c:805
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR20
#define TMR20
Definition: at32f435_437_tmr.h:909
TMR13
#define TMR13
Definition: at32f435_437_tmr.h:907
TMR3
#define TMR3
Definition: at32f435_437_tmr.h:897
TMR14
#define TMR14
Definition: at32f435_437_tmr.h:908
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
TMR10
#define TMR10
Definition: at32f435_437_tmr.h:904
TMR11
#define TMR11
Definition: at32f435_437_tmr.h:905
TMR8
#define TMR8
Definition: at32f435_437_tmr.h:902
TMR2
#define TMR2
Definition: at32f435_437_tmr.h:896
TMR4
#define TMR4
Definition: at32f435_437_tmr.h:898
TMR5
#define TMR5
Definition: at32f435_437_tmr.h:899
TMR6
#define TMR6
Definition: at32f435_437_tmr.h:900
TMR7
#define TMR7
Definition: at32f435_437_tmr.h:901
TMR12
#define TMR12
Definition: at32f435_437_tmr.h:906
TMR9
#define TMR9
Definition: at32f435_437_tmr.h:903
tmr_brkdt_config_type
tmr brkdt config type
Definition: at32f435_437_tmr.h:436
tmr_brkdt_config_type::brk_enable
confirm_state brk_enable
Definition: at32f435_437_tmr.h:443
tmr_brkdt_config_type::deadtime
uint8_t deadtime
Definition: at32f435_437_tmr.h:437
tmr_brkdt_config_type::auto_output_enable
confirm_state auto_output_enable
Definition: at32f435_437_tmr.h:440
tmr_brkdt_config_type::wp_level
tmr_wp_level_type wp_level
Definition: at32f435_437_tmr.h:439
tmr_brkdt_config_type::fcsoen_state
confirm_state fcsoen_state
Definition: at32f435_437_tmr.h:441
tmr_brkdt_config_type::fcsodis_state
confirm_state fcsodis_state
Definition: at32f435_437_tmr.h:442
tmr_brkdt_config_type::brk_polarity
tmr_brk_polarity_type brk_polarity
Definition: at32f435_437_tmr.h:438
tmr_input_config_type
tmr input capture config type
Definition: at32f435_437_tmr.h:425
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f435_437_tmr.h:428
tmr_input_config_type::input_filter_value
uint8_t input_filter_value
Definition: at32f435_437_tmr.h:429
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f435_437_tmr.h:427
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f435_437_tmr.h:426
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f435_437_tmr.h:418
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f435_437_tmr.h:416
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f435_437_tmr.h:414
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
tmr_type
type define tmr register all
Definition: at32f435_437_tmr.h:450
tmr_type::cm2_input_bit
struct tmr_type::@1071::@1112 cm2_input_bit
input capture mode
tmr_type::c1cen
__IO uint32_t c1cen
Definition: at32f435_437_tmr.h:679
tmr_type::pmen
__IO uint32_t pmen
Definition: at32f435_437_tmr.h:466
tmr_type::brken
__IO uint32_t brken
Definition: at32f435_437_tmr.h:805
tmr_type::c1idiv
__IO uint32_t c1idiv
Definition: at32f435_437_tmr.h:620
tmr_type::dtc
__IO uint32_t dtc
Definition: at32f435_437_tmr.h:801
tmr_type::c1en
__IO uint32_t c1en
Definition: at32f435_437_tmr.h:677
tmr_type::cm2_output_bit
struct tmr_type::@1071::@1111 cm2_output_bit
channel mode
tmr_type::c5dt
__IO uint32_t c5dt
Definition: at32f435_437_tmr.h:883
tmr_type::c5octrl
__IO uint32_t c5octrl
Definition: at32f435_437_tmr.h:872
tmr_type::swevt_bit
struct tmr_type::@1067::@1108 swevt_bit
tmr_type::c4df
__IO uint32_t c4df
Definition: at32f435_437_tmr.h:664
tmr_type::c3octrl
__IO uint32_t c3octrl
Definition: at32f435_437_tmr.h:644
tmr_type::c2osen
__IO uint32_t c2osen
Definition: at32f435_437_tmr.h:610
tmr_type::swevt
__IO uint32_t swevt
Definition: at32f435_437_tmr.h:574
tmr_type::c2en
__IO uint32_t c2en
Definition: at32f435_437_tmr.h:681
tmr_type::c3df
__IO uint32_t c3df
Definition: at32f435_437_tmr.h:661
tmr_type::wpc
__IO uint32_t wpc
Definition: at32f435_437_tmr.h:802
tmr_type::c3oben
__IO uint32_t c3oben
Definition: at32f435_437_tmr.h:643
tmr_type::cnt_dir
__IO uint32_t cnt_dir
Definition: at32f435_437_tmr.h:463
tmr_type::cm1_output_bit
struct tmr_type::@1069::@1109 cm1_output_bit
channel mode
tmr_type::dmactrl_bit
struct tmr_type::@1093::@1123 dmactrl_bit
tmr_type::c4octrl
__IO uint32_t c4octrl
Definition: at32f435_437_tmr.h:649
tmr_type::c1insel
__IO uint32_t c1insel
Definition: at32f435_437_tmr.h:484
tmr_type::tmr5_ch4_irmp
__IO uint32_t tmr5_ch4_irmp
Definition: at32f435_437_tmr.h:849
tmr_type::rpr_bit
struct tmr_type::@1081::@1117 rpr_bit
tmr_type::div
__IO uint32_t div
Definition: at32f435_437_tmr.h:712
tmr_type::esf
__IO uint32_t esf
Definition: at32f435_437_tmr.h:509
tmr_type::c1osen
__IO uint32_t c1osen
Definition: at32f435_437_tmr.h:605
tmr_type::c2cen
__IO uint32_t c2cen
Definition: at32f435_437_tmr.h:683
tmr_type::drs
__IO uint32_t drs
Definition: at32f435_437_tmr.h:482
tmr_type::iden
__IO uint32_t iden
Definition: at32f435_437_tmr.h:522
tmr_type::c1oben
__IO uint32_t c1oben
Definition: at32f435_437_tmr.h:603
tmr_type::ists
__IO uint32_t ists
Definition: at32f435_437_tmr.h:549
tmr_type::cm1_input_bit
struct tmr_type::@1069::@1110 cm1_input_bit
input capture mode
tmr_type::c1c
__IO uint32_t c1c
Definition: at32f435_437_tmr.h:601
tmr_type::c3cen
__IO uint32_t c3cen
Definition: at32f435_437_tmr.h:687
tmr_type::c4p
__IO uint32_t c4p
Definition: at32f435_437_tmr.h:690
tmr_type::brkv
__IO uint32_t brkv
Definition: at32f435_437_tmr.h:806
tmr_type::stis
__IO uint32_t stis
Definition: at32f435_437_tmr.h:507
tmr_type::ovfswtr
__IO uint32_t ovfswtr
Definition: at32f435_437_tmr.h:577
tmr_type::c3idiv
__IO uint32_t c3idiv
Definition: at32f435_437_tmr.h:660
tmr_type::brk_bit
struct tmr_type::@1091::@1122 brk_bit
tmr_type::c4osen
__IO uint32_t c4osen
Definition: at32f435_437_tmr.h:650
tmr_type::rmp_bit
struct tmr_type::@1097::@1125 rmp_bit
tmr_type::c1octrl
__IO uint32_t c1octrl
Definition: at32f435_437_tmr.h:604
tmr_type::tmren
__IO uint32_t tmren
Definition: at32f435_437_tmr.h:459
tmr_type::oen
__IO uint32_t oen
Definition: at32f435_437_tmr.h:808
tmr_type::sts
__IO uint32_t sts
Definition: at32f435_437_tmr.h:508
tmr_type::c2idiv
__IO uint32_t c2idiv
Definition: at32f435_437_tmr.h:623
tmr_type::c1p
__IO uint32_t c1p
Definition: at32f435_437_tmr.h:678
tmr_type::c1oien
__IO uint32_t c1oien
Definition: at32f435_437_tmr.h:602
tmr_type::pr
__IO uint32_t pr
Definition: at32f435_437_tmr.h:725
tmr_type::c3oien
__IO uint32_t c3oien
Definition: at32f435_437_tmr.h:642
tmr_type::c1dt
uint32_t c1dt
Definition: at32f435_437_tmr.h:750
tmr_type::c2oben
__IO uint32_t c2oben
Definition: at32f435_437_tmr.h:608
tmr_type::cctrl_bit
struct tmr_type::@1073::@1113 cctrl_bit
tmr_type::c2octrl
__IO uint32_t c2octrl
Definition: at32f435_437_tmr.h:609
tmr_type::smsel
__IO uint32_t smsel
Definition: at32f435_437_tmr.h:505
tmr_type::c3p
__IO uint32_t c3p
Definition: at32f435_437_tmr.h:686
tmr_type::c1cp
__IO uint32_t c1cp
Definition: at32f435_437_tmr.h:680
tmr_type::c3c
__IO uint32_t c3c
Definition: at32f435_437_tmr.h:641
tmr_type::clkdiv
__IO uint32_t clkdiv
Definition: at32f435_437_tmr.h:465
tmr_type::ovfs
__IO uint32_t ovfs
Definition: at32f435_437_tmr.h:461
tmr_type::trgout2en
__IO uint32_t trgout2en
Definition: at32f435_437_tmr.h:493
tmr_type::stctrl_bit
struct tmr_type::@1061::@1105 stctrl_bit
tmr_type::cbctrl
__IO uint32_t cbctrl
Definition: at32f435_437_tmr.h:479
tmr_type::dtb
__IO uint32_t dtb
Definition: at32f435_437_tmr.h:822
tmr_type::prben
__IO uint32_t prben
Definition: at32f435_437_tmr.h:464
tmr_type::c5oien
__IO uint32_t c5oien
Definition: at32f435_437_tmr.h:870
tmr_type::ccfs
__IO uint32_t ccfs
Definition: at32f435_437_tmr.h:481
tmr_type::ecmben
__IO uint32_t ecmben
Definition: at32f435_437_tmr.h:511
tmr_type::ovfen
__IO uint32_t ovfen
Definition: at32f435_437_tmr.h:460
tmr_type::ctrl2_bit
struct tmr_type::@1059::@1104 ctrl2_bit
tmr_type::c4en
__IO uint32_t c4en
Definition: at32f435_437_tmr.h:689
tmr_type::fcsoen
__IO uint32_t fcsoen
Definition: at32f435_437_tmr.h:804
tmr_type::esdiv
__IO uint32_t esdiv
Definition: at32f435_437_tmr.h:510
tmr_type::c3en
__IO uint32_t c3en
Definition: at32f435_437_tmr.h:685
tmr_type::c2p
__IO uint32_t c2p
Definition: at32f435_437_tmr.h:682
tmr_type::c5oben
__IO uint32_t c5oben
Definition: at32f435_437_tmr.h:871
tmr_type::ocmen
__IO uint32_t ocmen
Definition: at32f435_437_tmr.h:462
tmr_type::c4oien
__IO uint32_t c4oien
Definition: at32f435_437_tmr.h:647
tmr_type::c2dt
uint32_t c2dt
Definition: at32f435_437_tmr.h:762
tmr_type::addr
__IO uint32_t addr
Definition: at32f435_437_tmr.h:820
tmr_type::c3cp
__IO uint32_t c3cp
Definition: at32f435_437_tmr.h:688
tmr_type::c2df
__IO uint32_t c2df
Definition: at32f435_437_tmr.h:624
tmr_type::c4idiv
__IO uint32_t c4idiv
Definition: at32f435_437_tmr.h:663
tmr_type::c3osen
__IO uint32_t c3osen
Definition: at32f435_437_tmr.h:645
tmr_type::rpr
__IO uint32_t rpr
Definition: at32f435_437_tmr.h:737
tmr_type::c2c
__IO uint32_t c2c
Definition: at32f435_437_tmr.h:606
tmr_type::cm3_output_bit
struct tmr_type::@1099::@1126 cm3_output_bit
tmr_type::c5osen
__IO uint32_t c5osen
Definition: at32f435_437_tmr.h:873
tmr_type::c1df
__IO uint32_t c1df
Definition: at32f435_437_tmr.h:621
tmr_type::c2oien
__IO uint32_t c2oien
Definition: at32f435_437_tmr.h:607
tmr_type::c4dt
__IO uint32_t c4dt
Definition: at32f435_437_tmr.h:786
tmr_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f435_437_tmr.h:476
tmr_type::c3dt
__IO uint32_t c3dt
Definition: at32f435_437_tmr.h:774
tmr_type::c2cp
__IO uint32_t c2cp
Definition: at32f435_437_tmr.h:684
tmr_type::tmr2_ch1_irmp
__IO uint32_t tmr2_ch1_irmp
Definition: at32f435_437_tmr.h:851
tmr_type::cctrl
uint32_t cctrl
Definition: at32f435_437_tmr.h:674
tmr_type::c4c
__IO uint32_t c4c
Definition: at32f435_437_tmr.h:646
tmr_type::c4oben
__IO uint32_t c4oben
Definition: at32f435_437_tmr.h:648
tmr_type::fcsodis
__IO uint32_t fcsodis
Definition: at32f435_437_tmr.h:803
tmr_type::cval
__IO uint32_t cval
Definition: at32f435_437_tmr.h:700
tmr_type::esp
__IO uint32_t esp
Definition: at32f435_437_tmr.h:512
tmr_type::ptos
__IO uint32_t ptos
Definition: at32f435_437_tmr.h:483
tmr_type::aoen
__IO uint32_t aoen
Definition: at32f435_437_tmr.h:807
tmr_type::ctrl1_bit
struct tmr_type::@1057::@1103 ctrl1_bit
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_tmr.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_tmr.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_TMR_H
29#define __AT32F435_437_TMR_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
52#define TMR_OVF_FLAG ((uint32_t)0x000001)
53#define TMR_C1_FLAG ((uint32_t)0x000002)
54#define TMR_C2_FLAG ((uint32_t)0x000004)
55#define TMR_C3_FLAG ((uint32_t)0x000008)
56#define TMR_C4_FLAG ((uint32_t)0x000010)
57#define TMR_C5_FLAG ((uint32_t)0x010000)
58#define TMR_HALL_FLAG ((uint32_t)0x000020)
59#define TMR_TRIGGER_FLAG ((uint32_t)0x000040)
60#define TMR_BRK_FLAG ((uint32_t)0x000080)
61#define TMR_C1_RECAPTURE_FLAG ((uint32_t)0x000200)
62#define TMR_C2_RECAPTURE_FLAG ((uint32_t)0x000400)
63#define TMR_C3_RECAPTURE_FLAG ((uint32_t)0x000800)
64#define TMR_C4_RECAPTURE_FLAG ((uint32_t)0x001000)
75#define TMR_OVF_INT ((uint32_t)0x000001)
76#define TMR_C1_INT ((uint32_t)0x000002)
77#define TMR_C2_INT ((uint32_t)0x000004)
78#define TMR_C3_INT ((uint32_t)0x000008)
79#define TMR_C4_INT ((uint32_t)0x000010)
80#define TMR_HALL_INT ((uint32_t)0x000020)
81#define TMR_TRIGGER_INT ((uint32_t)0x000040)
82#define TMR_BRK_INT ((uint32_t)0x000080)
95typedef enum
96{
97 TMR_CLOCK_DIV1 = 0x00,
98 TMR_CLOCK_DIV2 = 0x01,
99 TMR_CLOCK_DIV4 = 0x02
100} tmr_clock_division_type;
101
105typedef enum
106{
107 TMR_COUNT_UP = 0x00,
108 TMR_COUNT_DOWN = 0x01,
109 TMR_COUNT_TWO_WAY_1 = 0x02,
110 TMR_COUNT_TWO_WAY_2 = 0x04,
111 TMR_COUNT_TWO_WAY_3 = 0x06
112} tmr_count_mode_type;
113
117typedef enum
118{
119 TMR_PRIMARY_SEL_RESET = 0x00,
120 TMR_PRIMARY_SEL_ENABLE = 0x01,
121 TMR_PRIMARY_SEL_OVERFLOW = 0x02,
122 TMR_PRIMARY_SEL_COMPARE = 0x03,
123 TMR_PRIMARY_SEL_C1ORAW = 0x04,
124 TMR_PRIMARY_SEL_C2ORAW = 0x05,
125 TMR_PRIMARY_SEL_C3ORAW = 0x06,
126 TMR_PRIMARY_SEL_C4ORAW = 0x07
127} tmr_primary_select_type;
128
132typedef enum
133{
134 TMR_SUB_INPUT_SEL_IS0 = 0x00,
135 TMR_SUB_INPUT_SEL_IS1 = 0x01,
136 TMR_SUB_INPUT_SEL_IS2 = 0x02,
137 TMR_SUB_INPUT_SEL_IS3 = 0x03,
138 TMR_SUB_INPUT_SEL_C1INC = 0x04,
139 TMR_SUB_INPUT_SEL_C1DF1 = 0x05,
140 TMR_SUB_INPUT_SEL_C2DF2 = 0x06,
141 TMR_SUB_INPUT_SEL_EXTIN = 0x07
142} sub_tmr_input_sel_type;
143
147typedef enum
148{
149 TMR_SUB_MODE_DIABLE = 0x00,
150 TMR_SUB_ENCODER_MODE_A = 0x01,
151 TMR_SUB_ENCODER_MODE_B = 0x02,
152 TMR_SUB_ENCODER_MODE_C = 0x03,
153 TMR_SUB_RESET_MODE = 0x04,
154 TMR_SUB_HANG_MODE = 0x05,
155 TMR_SUB_TRIGGER_MODE = 0x06,
156 TMR_SUB_EXTERNAL_CLOCK_MODE_A = 0x07
157} tmr_sub_mode_select_type;
158
162typedef enum
163{
164 TMR_ENCODER_MODE_A = TMR_SUB_ENCODER_MODE_A,
165 TMR_ENCODER_MODE_B = TMR_SUB_ENCODER_MODE_B,
166 TMR_ENCODER_MODE_C = TMR_SUB_ENCODER_MODE_C
167} tmr_encoder_mode_type;
168
172typedef enum
173{
174 TMR_OUTPUT_CONTROL_OFF = 0x00,
175 TMR_OUTPUT_CONTROL_HIGH = 0x01,
176 TMR_OUTPUT_CONTROL_LOW = 0x02,
177 TMR_OUTPUT_CONTROL_SWITCH = 0x03,
178 TMR_OUTPUT_CONTROL_FORCE_LOW = 0x04,
179 TMR_OUTPUT_CONTROL_FORCE_HIGH = 0x05,
180 TMR_OUTPUT_CONTROL_PWM_MODE_A = 0x06,
181 TMR_OUTPUT_CONTROL_PWM_MODE_B = 0x07
182} tmr_output_control_mode_type;
183
187typedef enum
188{
189 TMR_FORCE_OUTPUT_HIGH = TMR_OUTPUT_CONTROL_FORCE_HIGH,
190 TMR_FORCE_OUTPUT_LOW = TMR_OUTPUT_CONTROL_FORCE_LOW
191} tmr_force_output_type;
192
196typedef enum
197{
198 TMR_OUTPUT_ACTIVE_HIGH = 0x00,
199 TMR_OUTPUT_ACTIVE_LOW = 0x01
200} tmr_output_polarity_type;
201
205typedef enum
206{
207 TMR_INPUT_RISING_EDGE = 0x00,
208 TMR_INPUT_FALLING_EDGE = 0x01,
209 TMR_INPUT_BOTH_EDGE = 0x03
210} tmr_input_polarity_type;
211
215typedef enum
216{
217 TMR_SELECT_CHANNEL_1 = 0x00,
218 TMR_SELECT_CHANNEL_1C = 0x01,
219 TMR_SELECT_CHANNEL_2 = 0x02,
220 TMR_SELECT_CHANNEL_2C = 0x03,
221 TMR_SELECT_CHANNEL_3 = 0x04,
222 TMR_SELECT_CHANNEL_3C = 0x05,
223 TMR_SELECT_CHANNEL_4 = 0x06,
224 TMR_SELECT_CHANNEL_5 = 0x07
225} tmr_channel_select_type;
226
230typedef enum
231{
232 TMR_CHANEL1_CONNECTED_C1IRAW = 0x00,
233 TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR = 0x01
234} tmr_channel1_input_connected_type;
235
239typedef enum
240{
241 TMR_CC_CHANNEL_MAPPED_DIRECT = 0x01,
242 TMR_CC_CHANNEL_MAPPED_INDIRECT = 0x02,
243 TMR_CC_CHANNEL_MAPPED_STI = 0x03
244} tmr_input_direction_mapped_type;
245
249typedef enum
250{
251 TMR_CHANNEL_INPUT_DIV_1 = 0x00,
252 TMR_CHANNEL_INPUT_DIV_2 = 0x01,
253 TMR_CHANNEL_INPUT_DIV_4 = 0x02,
254 TMR_CHANNEL_INPUT_DIV_8 = 0x03
255} tmr_channel_input_divider_type;
256
260typedef enum
261{
262 TMR_DMA_REQUEST_BY_CHANNEL = 0x00,
263 TMR_DMA_REQUEST_BY_OVERFLOW = 0x01
264} tmr_dma_request_source_type;
265
269typedef enum
270{
271 TMR_OVERFLOW_DMA_REQUEST = 0x00000100,
272 TMR_C1_DMA_REQUEST = 0x00000200,
273 TMR_C2_DMA_REQUEST = 0x00000400,
274 TMR_C3_DMA_REQUEST = 0x00000800,
275 TMR_C4_DMA_REQUEST = 0x00001000,
276 TMR_HALL_DMA_REQUEST = 0x00002000,
277 TMR_TRIGGER_DMA_REQUEST = 0x00004000
278} tmr_dma_request_type;
279
283typedef enum
284{
285 TMR_OVERFLOW_SWTRIG = 0x00000001,
286 TMR_C1_SWTRIG = 0x00000002,
287 TMR_C2_SWTRIG = 0x00000004,
288 TMR_C3_SWTRIG = 0x00000008,
289 TMR_C4_SWTRIG = 0x00000010,
290 TMR_HALL_SWTRIG = 0x00000020,
291 TMR_TRIGGER_SWTRIG = 0x00000040,
292 TMR_BRK_SWTRIG = 0x00000080
293}tmr_event_trigger_type;
294
298typedef enum
299{
300 TMR_POLARITY_ACTIVE_HIGH = 0x00,
301 TMR_POLARITY_ACTIVE_LOW = 0x01,
302 TMR_POLARITY_ACTIVE_BOTH = 0x02
303}tmr_polarity_active_type;
304
308typedef enum
309{
310 TMR_ES_FREQUENCY_DIV_1 = 0x00,
311 TMR_ES_FREQUENCY_DIV_2 = 0x01,
312 TMR_ES_FREQUENCY_DIV_4 = 0x02,
313 TMR_ES_FREQUENCY_DIV_8 = 0x03
314}tmr_external_signal_divider_type;
315
319typedef enum
320{
321 TMR_ES_POLARITY_NON_INVERTED = 0x00,
322 TMR_ES_POLARITY_INVERTED = 0x01
323}tmr_external_signal_polarity_type;
324
328typedef enum
329{
330 TMR_DMA_TRANSFER_1BYTE = 0x00,
331 TMR_DMA_TRANSFER_2BYTES = 0x01,
332 TMR_DMA_TRANSFER_3BYTES = 0x02,
333 TMR_DMA_TRANSFER_4BYTES = 0x03,
334 TMR_DMA_TRANSFER_5BYTES = 0x04,
335 TMR_DMA_TRANSFER_6BYTES = 0x05,
336 TMR_DMA_TRANSFER_7BYTES = 0x06,
337 TMR_DMA_TRANSFER_8BYTES = 0x07,
338 TMR_DMA_TRANSFER_9BYTES = 0x08,
339 TMR_DMA_TRANSFER_10BYTES = 0x09,
340 TMR_DMA_TRANSFER_11BYTES = 0x0A,
341 TMR_DMA_TRANSFER_12BYTES = 0x0B,
342 TMR_DMA_TRANSFER_13BYTES = 0x0C,
343 TMR_DMA_TRANSFER_14BYTES = 0x0D,
344 TMR_DMA_TRANSFER_15BYTES = 0x0E,
345 TMR_DMA_TRANSFER_16BYTES = 0x0F,
346 TMR_DMA_TRANSFER_17BYTES = 0x10,
347 TMR_DMA_TRANSFER_18BYTES = 0x11
348}tmr_dma_transfer_length_type;
349
353typedef enum
354{
355 TMR_CTRL1_ADDRESS = 0x0000,
356 TMR_CTRL2_ADDRESS = 0x0001,
357 TMR_STCTRL_ADDRESS = 0x0002,
358 TMR_IDEN_ADDRESS = 0x0003,
359 TMR_ISTS_ADDRESS = 0x0004,
360 TMR_SWEVT_ADDRESS = 0x0005,
361 TMR_CM1_ADDRESS = 0x0006,
362 TMR_CM2_ADDRESS = 0x0007,
363 TMR_CCTRL_ADDRESS = 0x0008,
364 TMR_CVAL_ADDRESS = 0x0009,
365 TMR_DIV_ADDRESS = 0x000A,
366 TMR_PR_ADDRESS = 0x000B,
367 TMR_RPR_ADDRESS = 0x000C,
368 TMR_C1DT_ADDRESS = 0x000D,
369 TMR_C2DT_ADDRESS = 0x000E,
370 TMR_C3DT_ADDRESS = 0x000F,
371 TMR_C4DT_ADDRESS = 0x0010,
372 TMR_BRK_ADDRESS = 0x0011,
373 TMR_DMACTRL_ADDRESS = 0x0012
374}tmr_dma_address_type;
375
379typedef enum
380{
381 TMR_BRK_INPUT_ACTIVE_LOW = 0x00,
382 TMR_BRK_INPUT_ACTIVE_HIGH = 0x01
383}tmr_brk_polarity_type;
384
388typedef enum
389{
390 TMR_WP_OFF = 0x00,
391 TMR_WP_LEVEL_3 = 0x01,
392 TMR_WP_LEVEL_2 = 0x02,
393 TMR_WP_LEVEL_1 = 0x03
394}tmr_wp_level_type;
395
399typedef enum
400{
401 TMR2_TMR8TRGOUT_TMR5_GPIO = 0x00,
402 TMR2_PTP_TMR5_LICK = 0x01,
403 TMR2_OTG1FS_TMR5_LEXT = 0x02,
404 TMR2_OTG2FS_TMR5_ERTC = 0x03
405}tmr_input_remap_type ;
410typedef struct
411{
412 tmr_output_control_mode_type oc_mode;
413 confirm_state oc_idle_state;
414 confirm_state occ_idle_state;
415 tmr_output_polarity_type oc_polarity;
416 tmr_output_polarity_type occ_polarity;
417 confirm_state oc_output_state;
418 confirm_state occ_output_state;
419} tmr_output_config_type;
420
424typedef struct
425{
426 tmr_channel_select_type input_channel_select;
427 tmr_input_polarity_type input_polarity_select;
428 tmr_input_direction_mapped_type input_mapped_select;
429 uint8_t input_filter_value;
430} tmr_input_config_type;
431
435typedef struct
436{
437 uint8_t deadtime;
438 tmr_brk_polarity_type brk_polarity;
439 tmr_wp_level_type wp_level;
440 confirm_state auto_output_enable;
441 confirm_state fcsoen_state;
442 confirm_state fcsodis_state;
443 confirm_state brk_enable;
444} tmr_brkdt_config_type;
445
449typedef struct
450{
454 union
455 {
456 __IO uint32_t ctrl1;
457 struct
458 {
459 __IO uint32_t tmren : 1; /* [0] */
460 __IO uint32_t ovfen : 1; /* [1] */
461 __IO uint32_t ovfs : 1; /* [2] */
462 __IO uint32_t ocmen : 1; /* [3] */
463 __IO uint32_t cnt_dir : 3; /* [6:4] */
464 __IO uint32_t prben : 1; /* [7] */
465 __IO uint32_t clkdiv : 2; /* [9:8] */
466 __IO uint32_t pmen : 1; /* [10] */
467 __IO uint32_t reserved1 : 21;/* [31:11] */
468 } ctrl1_bit;
469 };
470
474 union
475 {
476 __IO uint32_t ctrl2;
477 struct
478 {
479 __IO uint32_t cbctrl : 1; /* [0] */
480 __IO uint32_t reserved1 : 1; /* [1] */
481 __IO uint32_t ccfs : 1; /* [2] */
482 __IO uint32_t drs : 1; /* [3] */
483 __IO uint32_t ptos : 3; /* [6:4] */
484 __IO uint32_t c1insel : 1; /* [7] */
485 __IO uint32_t c1ios : 1; /* [8] */
486 __IO uint32_t c1cios : 1; /* [9] */
487 __IO uint32_t c2ios : 1; /* [10] */
488 __IO uint32_t c2cios : 1; /* [11] */
489 __IO uint32_t c3ios : 1; /* [12] */
490 __IO uint32_t c3cios : 1; /* [13] */
491 __IO uint32_t c4ios : 1; /* [14] */
492 __IO uint32_t reserved2 : 16;/* [30:15] */
493 __IO uint32_t trgout2en : 1; /* [31] */
494 } ctrl2_bit;
495 };
496
500 union
501 {
502 __IO uint32_t stctrl;
503 struct
504 {
505 __IO uint32_t smsel : 3; /* [2:0] */
506 __IO uint32_t reserved1 : 1; /* [3] */
507 __IO uint32_t stis : 3; /* [6:4] */
508 __IO uint32_t sts : 1; /* [7] */
509 __IO uint32_t esf : 4; /* [11:8] */
510 __IO uint32_t esdiv : 2; /* [13:12] */
511 __IO uint32_t ecmben : 1; /* [14] */
512 __IO uint32_t esp : 1; /* [15] */
513 __IO uint32_t reserved2 : 16;/* [31:16] */
514 } stctrl_bit;
515 };
516
520 union
521 {
522 __IO uint32_t iden;
523 struct
524 {
525 __IO uint32_t ovfien : 1; /* [0] */
526 __IO uint32_t c1ien : 1; /* [1] */
527 __IO uint32_t c2ien : 1; /* [2] */
528 __IO uint32_t c3ien : 1; /* [3] */
529 __IO uint32_t c4ien : 1; /* [4] */
530 __IO uint32_t hallien : 1; /* [5] */
531 __IO uint32_t tien : 1; /* [6] */
532 __IO uint32_t brkie : 1; /* [7] */
533 __IO uint32_t ovfden : 1; /* [8] */
534 __IO uint32_t c1den : 1; /* [9] */
535 __IO uint32_t c2den : 1; /* [10] */
536 __IO uint32_t c3den : 1; /* [11] */
537 __IO uint32_t c4den : 1; /* [12] */
538 __IO uint32_t hallde : 1; /* [13] */
539 __IO uint32_t tden : 1; /* [14] */
540 __IO uint32_t reserved1 : 17;/* [31:15] */
541 } iden_bit;
542 };
543
547 union
548 {
549 __IO uint32_t ists;
550 struct
551 {
552 __IO uint32_t ovfif : 1; /* [0] */
553 __IO uint32_t c1if : 1; /* [1] */
554 __IO uint32_t c2if : 1; /* [2] */
555 __IO uint32_t c3if : 1; /* [3] */
556 __IO uint32_t c4if : 1; /* [4] */
557 __IO uint32_t hallif : 1; /* [5] */
558 __IO uint32_t trgif : 1; /* [6] */
559 __IO uint32_t brkif : 1; /* [7] */
560 __IO uint32_t reserved1 : 1; /* [8] */
561 __IO uint32_t c1rf : 1; /* [9] */
562 __IO uint32_t c2rf : 1; /* [10] */
563 __IO uint32_t c3rf : 1; /* [11] */
564 __IO uint32_t c4rf : 1; /* [12] */
565 __IO uint32_t reserved2 : 19;/* [31:13] */
566 } ists_bit;
567 };
568
572 union
573 {
574 __IO uint32_t swevt;
575 struct
576 {
577 __IO uint32_t ovfswtr : 1; /* [0] */
578 __IO uint32_t c1swtr : 1; /* [1] */
579 __IO uint32_t c2swtr : 1; /* [2] */
580 __IO uint32_t c3swtr : 1; /* [3] */
581 __IO uint32_t c4swtr : 1; /* [4] */
582 __IO uint32_t hallswtr : 1; /* [5] */
583 __IO uint32_t trgswtr : 1; /* [6] */
584 __IO uint32_t brkswtr : 1; /* [7] */
585 __IO uint32_t reserved : 24;/* [31:8] */
586 } swevt_bit;
587 };
588
592 union
593 {
594 __IO uint32_t cm1;
595
599 struct
600 {
601 __IO uint32_t c1c : 2; /* [1:0] */
602 __IO uint32_t c1oien : 1; /* [2] */
603 __IO uint32_t c1oben : 1; /* [3] */
604 __IO uint32_t c1octrl : 3; /* [6:4] */
605 __IO uint32_t c1osen : 1; /* [7] */
606 __IO uint32_t c2c : 2; /* [9:8] */
607 __IO uint32_t c2oien : 1; /* [10] */
608 __IO uint32_t c2oben : 1; /* [11] */
609 __IO uint32_t c2octrl : 3; /* [14:12] */
610 __IO uint32_t c2osen : 1; /* [15] */
611 __IO uint32_t reserved1 : 16;/* [31:16] */
612 } cm1_output_bit;
613
617 struct
618 {
619 __IO uint32_t c1c : 2; /* [1:0] */
620 __IO uint32_t c1idiv : 2; /* [3:2] */
621 __IO uint32_t c1df : 4; /* [7:4] */
622 __IO uint32_t c2c : 2; /* [9:8] */
623 __IO uint32_t c2idiv : 2; /* [11:10] */
624 __IO uint32_t c2df : 4; /* [15:12] */
625 __IO uint32_t reserved1 : 16;/* [31:16] */
626 } cm1_input_bit;
627 };
628
632 union
633 {
634 __IO uint32_t cm2;
635
639 struct
640 {
641 __IO uint32_t c3c : 2; /* [1:0] */
642 __IO uint32_t c3oien : 1; /* [2] */
643 __IO uint32_t c3oben : 1; /* [3] */
644 __IO uint32_t c3octrl : 3; /* [6:4] */
645 __IO uint32_t c3osen : 1; /* [7] */
646 __IO uint32_t c4c : 2; /* [9:8] */
647 __IO uint32_t c4oien : 1; /* [10] */
648 __IO uint32_t c4oben : 1; /* [11] */
649 __IO uint32_t c4octrl : 3; /* [14:12] */
650 __IO uint32_t c4osen : 1; /* [15] */
651 __IO uint32_t reserved1 : 16;/* [31:16] */
652 } cm2_output_bit;
653
657 struct
658 {
659 __IO uint32_t c3c : 2; /* [1:0] */
660 __IO uint32_t c3idiv : 2; /* [3:2] */
661 __IO uint32_t c3df : 4; /* [7:4] */
662 __IO uint32_t c4c : 2; /* [9:8] */
663 __IO uint32_t c4idiv : 2; /* [11:10] */
664 __IO uint32_t c4df : 4; /* [15:12] */
665 __IO uint32_t reserved1 : 16;/* [31:16] */
666 } cm2_input_bit;
667 };
668
672 union
673 {
674 uint32_t cctrl;
675 struct
676 {
677 __IO uint32_t c1en : 1; /* [0] */
678 __IO uint32_t c1p : 1; /* [1] */
679 __IO uint32_t c1cen : 1; /* [2] */
680 __IO uint32_t c1cp : 1; /* [3] */
681 __IO uint32_t c2en : 1; /* [4] */
682 __IO uint32_t c2p : 1; /* [5] */
683 __IO uint32_t c2cen : 1; /* [6] */
684 __IO uint32_t c2cp : 1; /* [7] */
685 __IO uint32_t c3en : 1; /* [8] */
686 __IO uint32_t c3p : 1; /* [9] */
687 __IO uint32_t c3cen : 1; /* [10] */
688 __IO uint32_t c3cp : 1; /* [11] */
689 __IO uint32_t c4en : 1; /* [12] */
690 __IO uint32_t c4p : 1; /* [13] */
691 __IO uint32_t reserved1 : 18;/* [31:14] */
692 } cctrl_bit;
693 };
694
698 union
699 {
700 __IO uint32_t cval;
701 struct
702 {
703 __IO uint32_t cval : 32;/* [31:0] */
704 } cval_bit;
705 };
706
710 union
711 {
712 __IO uint32_t div;
713 struct
714 {
715 __IO uint32_t div : 16;/* [15:0] */
716 __IO uint32_t reserved1 : 16;/* [31:16] */
717 } div_bit;
718 };
719
723 union
724 {
725 __IO uint32_t pr;
726 struct
727 {
728 __IO uint32_t pr : 32;/* [31:0] */
729 } pr_bit;
730 };
731
735 union
736 {
737 __IO uint32_t rpr;
738 struct
739 {
740 __IO uint32_t rpr : 16;/* [15:0] */
741 __IO uint32_t reserved1 : 16;/* [31:16] */
742 } rpr_bit;
743 };
744
748 union
749 {
750 uint32_t c1dt;
751 struct
752 {
753 __IO uint32_t c1dt : 32;/* [31:0] */
754 } c1dt_bit;
755 };
756
760 union
761 {
762 uint32_t c2dt;
763 struct
764 {
765 __IO uint32_t c2dt : 32;/* [31:0] */
766 } c2dt_bit;
767 };
768
772 union
773 {
774 __IO uint32_t c3dt;
775 struct
776 {
777 __IO uint32_t c3dt : 32;/* [31:0] */
778 } c3dt_bit;
779 };
780
784 union
785 {
786 __IO uint32_t c4dt;
787 struct
788 {
789 __IO uint32_t c4dt : 32;/* [31:0] */
790 } c4dt_bit;
791 };
792
796 union
797 {
798 __IO uint32_t brk;
799 struct
800 {
801 __IO uint32_t dtc : 8; /* [7:0] */
802 __IO uint32_t wpc : 2; /* [9:8] */
803 __IO uint32_t fcsodis : 1; /* [10] */
804 __IO uint32_t fcsoen : 1; /* [11] */
805 __IO uint32_t brken : 1; /* [12] */
806 __IO uint32_t brkv : 1; /* [13] */
807 __IO uint32_t aoen : 1; /* [14] */
808 __IO uint32_t oen : 1; /* [15] */
809 __IO uint32_t reserved1 : 16; /* [31:16] */
810 } brk_bit;
811 };
815 union
816 {
817 __IO uint32_t dmactrl;
818 struct
819 {
820 __IO uint32_t addr : 5; /* [4:0] */
821 __IO uint32_t reserved1 : 3; /* [7:5] */
822 __IO uint32_t dtb : 5; /* [12:8] */
823 __IO uint32_t reserved2 : 19;/* [31:13] */
824 } dmactrl_bit;
825 };
826
830 union
831 {
832 __IO uint32_t dmadt;
833 struct
834 {
835 __IO uint32_t dmadt : 16;/* [15:0] */
836 __IO uint32_t reserved1 : 16;/* [31:16] */
837 } dmadt_bit;
838 };
839
843 union
844 {
845 __IO uint32_t rmp;
846 struct
847 {
848 __IO uint32_t reserved1 : 6; /* [5:0] */
849 __IO uint32_t tmr5_ch4_irmp : 2; /* [7:6] */
850 __IO uint32_t reserved2 : 2; /* [9:8] */
851 __IO uint32_t tmr2_ch1_irmp : 2; /* [11:10] */
852 __IO uint32_t reserved3 : 20;/* [31:16] */
853 } rmp_bit;
854 };
855
859 __IO uint32_t reserved1[7];
860
864 union
865 {
866 __IO uint32_t cm3;
867 struct
868 {
869 __IO uint32_t reserved1 : 2; /* [1:0] */
870 __IO uint32_t c5oien : 1; /* [2] */
871 __IO uint32_t c5oben : 1; /* [3] */
872 __IO uint32_t c5octrl : 3; /* [6:4] */
873 __IO uint32_t c5osen : 1; /* [7] */
874 __IO uint32_t reserved2 : 24;/* [31:8] */
875 } cm3_output_bit;
876 };
877
881 union
882 {
883 __IO uint32_t c5dt;
884 struct
885 {
886 __IO uint32_t c5dt : 32;/* [31:0] */
887 } c5dt_bit;
888 };
889} tmr_type;
890
895#define TMR1 ((tmr_type *) TMR1_BASE)
896#define TMR2 ((tmr_type *) TMR2_BASE)
897#define TMR3 ((tmr_type *) TMR3_BASE)
898#define TMR4 ((tmr_type *) TMR4_BASE)
899#define TMR5 ((tmr_type *) TMR5_BASE)
900#define TMR6 ((tmr_type *) TMR6_BASE)
901#define TMR7 ((tmr_type *) TMR7_BASE)
902#define TMR8 ((tmr_type *) TMR8_BASE)
903#define TMR9 ((tmr_type *) TMR9_BASE)
904#define TMR10 ((tmr_type *) TMR10_BASE)
905#define TMR11 ((tmr_type *) TMR11_BASE)
906#define TMR12 ((tmr_type *) TMR12_BASE)
907#define TMR13 ((tmr_type *) TMR13_BASE)
908#define TMR14 ((tmr_type *) TMR14_BASE)
909#define TMR20 ((tmr_type *) TMR20_BASE)
910
915void tmr_reset(tmr_type *tmr_x);
916void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state);
917void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct);
918void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct);
919void tmr_brkdt_default_para_init(tmr_brkdt_config_type *tmr_brkdt_struct);
920void tmr_base_init(tmr_type* tmr_x, uint32_t tmr_pr, uint32_t tmr_div);
921void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div);
922void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir);
923void tmr_repetition_counter_set(tmr_type *tmr_x, uint8_t tmr_rpr_value);
924void tmr_counter_value_set(tmr_type *tmr_x, uint32_t tmr_cnt_value);
925uint32_t tmr_counter_value_get(tmr_type *tmr_x);
926void tmr_div_value_set(tmr_type *tmr_x, uint32_t tmr_div_value);
927uint32_t tmr_div_value_get(tmr_type *tmr_x);
928void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
929 tmr_output_config_type *tmr_output_struct);
930void tmr_output_channel_mode_select(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
931 tmr_output_control_mode_type oc_mode);
932void tmr_period_value_set(tmr_type *tmr_x, uint32_t tmr_pr_value);
933uint32_t tmr_period_value_get(tmr_type *tmr_x);
934void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
935 uint32_t tmr_channel_value);
936uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel);
937void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state);
938void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
939 confirm_state new_state);
940void tmr_output_channel_immediately_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
941 confirm_state new_state);
942void tmr_output_channel_switch_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
943 confirm_state new_state);
944void tmr_one_cycle_mode_enable(tmr_type *tmr_x, confirm_state new_state);
945void tmr_32_bit_function_enable (tmr_type *tmr_x, confirm_state new_state);
946void tmr_overflow_request_source_set(tmr_type *tmr_x, confirm_state new_state);
947void tmr_overflow_event_disable(tmr_type *tmr_x, confirm_state new_state);
948void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, \
949 tmr_channel_input_divider_type divider_factor);
950void tmr_channel_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state);
951void tmr_input_channel_filter_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
952 uint16_t filter_value);
953void tmr_pwm_input_config(tmr_type *tmr_x, tmr_input_config_type *input_struct, \
954 tmr_channel_input_divider_type divider_factor);
955void tmr_channel1_input_select(tmr_type *tmr_x, tmr_channel1_input_connected_type ch1_connect);
956void tmr_input_channel_divider_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
957 tmr_channel_input_divider_type divider_factor);
958void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode);
959void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode);
960void tmr_channel_dma_select(tmr_type *tmr_x, tmr_dma_request_source_type cc_dma_select);
961void tmr_hall_select(tmr_type *tmr_x, confirm_state new_state);
962void tmr_channel_buffer_enable(tmr_type *tmr_x, confirm_state new_state);
963void tmr_trgout2_enable(tmr_type *tmr_x, confirm_state new_state);
964void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select);
965void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state);
966void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state);
967void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state);
968 flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag);
969void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag);
970void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event);
971void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state);
972void tmr_internal_clock_set(tmr_type *tmr_x);
973void tmr_output_channel_polarity_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
974 tmr_polarity_active_type oc_polarity);
975void tmr_external_clock_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, \
976 tmr_external_signal_polarity_type es_polarity, uint16_t es_filter);
977void tmr_external_clock_mode1_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, \
978 tmr_external_signal_polarity_type es_polarity, uint16_t es_filter);
979void tmr_external_clock_mode2_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, \
980 tmr_external_signal_polarity_type es_polarity, uint16_t es_filter);
981void tmr_encoder_mode_config(tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type \
982 ic1_polarity, tmr_input_polarity_type ic2_polarity);
983void tmr_force_output_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
984 tmr_force_output_type force_output);
985void tmr_dma_control_config(tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, \
986 tmr_dma_address_type dma_base_address);
987void tmr_brkdt_config(tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct);
988void tmr_iremap_config(tmr_type *tmr_x, tmr_input_remap_type input_remap);
989
1002#ifdef __cplusplus
1003}
1004#endif
1005
1006#endif
at32f435_437.h
at32f435_437 header file
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f435/examples/edma/burst_mode/src/main.c:39
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
tmr_dma_control_config
void tmr_dma_control_config(tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, tmr_dma_address_type dma_base_address)
config tmr dma control
Definition: at32f435_437_tmr.c:1785
tmr_channel_value_get
uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value
Definition: at32f435_437_tmr.c:593
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f435_437_tmr.c:1463
tmr_period_value_get
uint32_t tmr_period_value_get(tmr_type *tmr_x)
get tmr period value
Definition: at32f435_437_tmr.c:521
tmr_channel_buffer_enable
void tmr_channel_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
select tmr channel buffer
Definition: at32f435_437_tmr.c:1287
tmr_overflow_request_source_set
void tmr_overflow_request_source_set(tmr_type *tmr_x, confirm_state new_state)
select tmr the overflow event sources
Definition: at32f435_437_tmr.c:837
tmr_output_channel_mode_select
void tmr_output_channel_mode_select(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_control_mode_type oc_mode)
select tmr output channel mode
Definition: at32f435_437_tmr.c:461
tmr_input_channel_divider_set
void tmr_input_channel_divider_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_channel_input_divider_type divider_factor)
set tmr input channel divider
Definition: at32f435_437_tmr.c:1175
tmr_dma_request_enable
void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request
Definition: at32f435_437_tmr.c:1358
tmr_external_clock_config
void tmr_external_clock_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock
Definition: at32f435_437_tmr.c:1597
tmr_repetition_counter_set
void tmr_repetition_counter_set(tmr_type *tmr_x, uint8_t tmr_rpr_value)
set the repetition counter register(rpr) value
Definition: at32f435_437_tmr.c:265
tmr_period_buffer_enable
void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
set tmr period buffer
Definition: at32f435_437_tmr.c:638
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_internal_clock_set
void tmr_internal_clock_set(tmr_type *tmr_x)
set tmr select internal clock
Definition: at32f435_437_tmr.c:1511
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_brkdt_default_para_init
void tmr_brkdt_default_para_init(tmr_brkdt_config_type *tmr_brkdt_struct)
init tmr brkdt default para
Definition: at32f435_437_tmr.c:183
tmr_force_output_set
void tmr_force_output_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_force_output_type force_output)
set tmr force output
Definition: at32f435_437_tmr.c:1715
tmr_counter_value_set
void tmr_counter_value_set(tmr_type *tmr_x, uint32_t tmr_cnt_value)
set tmr counter value
Definition: at32f435_437_tmr.c:285
tmr_div_value_get
uint32_t tmr_div_value_get(tmr_type *tmr_x)
get tmr div value
Definition: at32f435_437_tmr.c:328
tmr_input_channel_init
void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel
Definition: at32f435_437_tmr.c:872
tmr_input_channel_filter_set
void tmr_input_channel_filter_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint16_t filter_value)
set tmr input channel filter
Definition: at32f435_437_tmr.c:996
tmr_period_value_set
void tmr_period_value_set(tmr_type *tmr_x, uint32_t tmr_pr_value)
set tmr period value
Definition: at32f435_437_tmr.c:505
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f435_437_tmr.c:1245
tmr_counter_value_get
uint32_t tmr_counter_value_get(tmr_type *tmr_x)
get tmr counter value
Definition: at32f435_437_tmr.c:299
tmr_brkdt_config
void tmr_brkdt_config(tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
config tmr break mode and dead-time
Definition: at32f435_437_tmr.c:1801
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f435_437_tmr.c:1424
tmr_external_clock_mode2_config
void tmr_external_clock_mode2_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode2
Definition: at32f435_437_tmr.c:1649
tmr_input_default_para_init
void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct)
init tmr input default para
Definition: at32f435_437_tmr.c:169
tmr_div_value_set
void tmr_div_value_set(tmr_type *tmr_x, uint32_t tmr_div_value)
set tmr div value
Definition: at32f435_437_tmr.c:314
tmr_iremap_config
void tmr_iremap_config(tmr_type *tmr_x, tmr_input_remap_type input_remap)
set tmr2/tmr5 input channel remap
Definition: at32f435_437_tmr.c:1824
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f435_437_tmr.c:1486
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f435_437_tmr.c:1499
tmr_sub_sync_mode_set
void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode
Definition: at32f435_437_tmr.c:1335
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_hall_select
void tmr_hall_select(tmr_type *tmr_x, confirm_state new_state)
select tmr hall
Definition: at32f435_437_tmr.c:1274
tmr_channel1_input_select
void tmr_channel1_input_select(tmr_type *tmr_x, tmr_channel1_input_connected_type ch1_connect)
select tmr channel1 input
Definition: at32f435_437_tmr.c:1150
tmr_32_bit_function_enable
void tmr_32_bit_function_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode)
Definition: at32f435_437_tmr.c:819
tmr_external_clock_mode1_config
void tmr_external_clock_mode1_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode1
Definition: at32f435_437_tmr.c:1623
tmr_pwm_input_config
void tmr_pwm_input_config(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
config tmr pwm input
Definition: at32f435_437_tmr.c:1042
tmr_trgout2_enable
void tmr_trgout2_enable(tmr_type *tmr_x, confirm_state new_state)
select tmr trgout2
Definition: at32f435_437_tmr.c:1300
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f435_437_tmr.c:1322
tmr_output_channel_buffer_enable
void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel buffer
Definition: at32f435_437_tmr.c:660
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f435_437_tmr.c:1389
tmr_primary_mode_select
void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode
Definition: at32f435_437_tmr.c:1222
tmr_overflow_event_disable
void tmr_overflow_event_disable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr overflow event generation
Definition: at32f435_437_tmr.c:851
tmr_channel_dma_select
void tmr_channel_dma_select(tmr_type *tmr_x, tmr_dma_request_source_type cc_dma_select)
select tmr channel dma
Definition: at32f435_437_tmr.c:1261
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_output_channel_immediately_set
void tmr_output_channel_immediately_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel immediately
Definition: at32f435_437_tmr.c:711
tmr_encoder_mode_config
void tmr_encoder_mode_config(tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type ic1_polarity, tmr_input_polarity_type ic2_polarity)
config tmr encoder mode
Definition: at32f435_437_tmr.c:1678
tmr_channel_enable
void tmr_channel_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable
Definition: at32f435_437_tmr.c:940
tmr_output_channel_switch_set
void tmr_output_channel_switch_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel switch
Definition: at32f435_437_tmr.c:762
tmr_reset
void tmr_reset(tmr_type *tmr_x)
tmr reset by crm reset register
Definition: at32f435_437_tmr.c:52
tmr_output_channel_polarity_set
void tmr_output_channel_polarity_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_polarity_active_type oc_polarity)
set tmr output channel polarity
Definition: at32f435_437_tmr.c:1537
tmr_one_cycle_mode_enable
void tmr_one_cycle_mode_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr one cycle mode
Definition: at32f435_437_tmr.c:805
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
tmr_dma_request_type
tmr_dma_request_type
tmr dma request type
Definition: at32f435_437_tmr.h:270
tmr_external_signal_divider_type
tmr_external_signal_divider_type
tmr external signal divider type
Definition: at32f435_437_tmr.h:309
tmr_polarity_active_type
tmr_polarity_active_type
tmr polarity active type
Definition: at32f435_437_tmr.h:299
tmr_count_mode_type
tmr_count_mode_type
tmr counter mode type
Definition: at32f435_437_tmr.h:106
tmr_input_polarity_type
tmr_input_polarity_type
tmr input channel polarity type
Definition: at32f435_437_tmr.h:206
tmr_dma_request_source_type
tmr_dma_request_source_type
tmr dma request source select type
Definition: at32f435_437_tmr.h:261
tmr_channel_select_type
tmr_channel_select_type
tmr channel select type
Definition: at32f435_437_tmr.h:216
tmr_external_signal_polarity_type
tmr_external_signal_polarity_type
tmr external signal polarity type
Definition: at32f435_437_tmr.h:320
tmr_dma_address_type
tmr_dma_address_type
tmr dma base address type
Definition: at32f435_437_tmr.h:354
tmr_wp_level_type
tmr_wp_level_type
tmr write protect level type
Definition: at32f435_437_tmr.h:389
tmr_channel1_input_connected_type
tmr_channel1_input_connected_type
tmr channel1 input connected type
Definition: at32f435_437_tmr.h:231
tmr_input_direction_mapped_type
tmr_input_direction_mapped_type
tmr input channel mapped type channel direction
Definition: at32f435_437_tmr.h:240
tmr_clock_division_type
tmr_clock_division_type
tmr clock division type
Definition: at32f435_437_tmr.h:96
tmr_event_trigger_type
tmr_event_trigger_type
tmr event triggered by software type
Definition: at32f435_437_tmr.h:284
tmr_brk_polarity_type
tmr_brk_polarity_type
tmr brk polarity type
Definition: at32f435_437_tmr.h:380
tmr_output_control_mode_type
tmr_output_control_mode_type
tmr output control mode type
Definition: at32f435_437_tmr.h:173
tmr_output_polarity_type
tmr_output_polarity_type
tmr output channel polarity type
Definition: at32f435_437_tmr.h:197
tmr_dma_transfer_length_type
tmr_dma_transfer_length_type
tmr dma transfer length type
Definition: at32f435_437_tmr.h:329
sub_tmr_input_sel_type
sub_tmr_input_sel_type
tmr subordinate mode input select type
Definition: at32f435_437_tmr.h:133
tmr_force_output_type
tmr_force_output_type
tmr force output type
Definition: at32f435_437_tmr.h:188
tmr_input_remap_type
tmr_input_remap_type
tmr input remap type
Definition: at32f435_437_tmr.h:400
tmr_sub_mode_select_type
tmr_sub_mode_select_type
tmr subordinate mode select type
Definition: at32f435_437_tmr.h:148
tmr_primary_select_type
tmr_primary_select_type
tmr primary mode select type
Definition: at32f435_437_tmr.h:118
tmr_encoder_mode_type
tmr_encoder_mode_type
tmr encoder mode type
Definition: at32f435_437_tmr.h:163
tmr_channel_input_divider_type
tmr_channel_input_divider_type
tmr input divider type
Definition: at32f435_437_tmr.h:250
TMR_OVERFLOW_DMA_REQUEST
@ TMR_OVERFLOW_DMA_REQUEST
Definition: at32f435_437_tmr.h:271
TMR_HALL_DMA_REQUEST
@ TMR_HALL_DMA_REQUEST
Definition: at32f435_437_tmr.h:276
TMR_C1_DMA_REQUEST
@ TMR_C1_DMA_REQUEST
Definition: at32f435_437_tmr.h:272
TMR_C2_DMA_REQUEST
@ TMR_C2_DMA_REQUEST
Definition: at32f435_437_tmr.h:273
TMR_C3_DMA_REQUEST
@ TMR_C3_DMA_REQUEST
Definition: at32f435_437_tmr.h:274
TMR_TRIGGER_DMA_REQUEST
@ TMR_TRIGGER_DMA_REQUEST
Definition: at32f435_437_tmr.h:277
TMR_C4_DMA_REQUEST
@ TMR_C4_DMA_REQUEST
Definition: at32f435_437_tmr.h:275
TMR_ES_FREQUENCY_DIV_1
@ TMR_ES_FREQUENCY_DIV_1
Definition: at32f435_437_tmr.h:310
TMR_ES_FREQUENCY_DIV_8
@ TMR_ES_FREQUENCY_DIV_8
Definition: at32f435_437_tmr.h:313
TMR_ES_FREQUENCY_DIV_4
@ TMR_ES_FREQUENCY_DIV_4
Definition: at32f435_437_tmr.h:312
TMR_ES_FREQUENCY_DIV_2
@ TMR_ES_FREQUENCY_DIV_2
Definition: at32f435_437_tmr.h:311
TMR_POLARITY_ACTIVE_HIGH
@ TMR_POLARITY_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:300
TMR_POLARITY_ACTIVE_LOW
@ TMR_POLARITY_ACTIVE_LOW
Definition: at32f435_437_tmr.h:301
TMR_POLARITY_ACTIVE_BOTH
@ TMR_POLARITY_ACTIVE_BOTH
Definition: at32f435_437_tmr.h:302
TMR_COUNT_DOWN
@ TMR_COUNT_DOWN
Definition: at32f435_437_tmr.h:108
TMR_COUNT_TWO_WAY_2
@ TMR_COUNT_TWO_WAY_2
Definition: at32f435_437_tmr.h:110
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_COUNT_TWO_WAY_3
@ TMR_COUNT_TWO_WAY_3
Definition: at32f435_437_tmr.h:111
TMR_COUNT_TWO_WAY_1
@ TMR_COUNT_TWO_WAY_1
Definition: at32f435_437_tmr.h:109
TMR_INPUT_BOTH_EDGE
@ TMR_INPUT_BOTH_EDGE
Definition: at32f435_437_tmr.h:209
TMR_INPUT_FALLING_EDGE
@ TMR_INPUT_FALLING_EDGE
Definition: at32f435_437_tmr.h:208
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f435_437_tmr.h:207
TMR_DMA_REQUEST_BY_CHANNEL
@ TMR_DMA_REQUEST_BY_CHANNEL
Definition: at32f435_437_tmr.h:262
TMR_DMA_REQUEST_BY_OVERFLOW
@ TMR_DMA_REQUEST_BY_OVERFLOW
Definition: at32f435_437_tmr.h:263
TMR_SELECT_CHANNEL_1C
@ TMR_SELECT_CHANNEL_1C
Definition: at32f435_437_tmr.h:218
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f435_437_tmr.h:221
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_SELECT_CHANNEL_2C
@ TMR_SELECT_CHANNEL_2C
Definition: at32f435_437_tmr.h:220
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f435_437_tmr.h:223
TMR_SELECT_CHANNEL_5
@ TMR_SELECT_CHANNEL_5
Definition: at32f435_437_tmr.h:224
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f435_437_tmr.h:219
TMR_SELECT_CHANNEL_3C
@ TMR_SELECT_CHANNEL_3C
Definition: at32f435_437_tmr.h:222
TMR_ES_POLARITY_INVERTED
@ TMR_ES_POLARITY_INVERTED
Definition: at32f435_437_tmr.h:322
TMR_ES_POLARITY_NON_INVERTED
@ TMR_ES_POLARITY_NON_INVERTED
Definition: at32f435_437_tmr.h:321
TMR_C2DT_ADDRESS
@ TMR_C2DT_ADDRESS
Definition: at32f435_437_tmr.h:369
TMR_C1DT_ADDRESS
@ TMR_C1DT_ADDRESS
Definition: at32f435_437_tmr.h:368
TMR_STCTRL_ADDRESS
@ TMR_STCTRL_ADDRESS
Definition: at32f435_437_tmr.h:357
TMR_BRK_ADDRESS
@ TMR_BRK_ADDRESS
Definition: at32f435_437_tmr.h:372
TMR_CTRL2_ADDRESS
@ TMR_CTRL2_ADDRESS
Definition: at32f435_437_tmr.h:356
TMR_PR_ADDRESS
@ TMR_PR_ADDRESS
Definition: at32f435_437_tmr.h:366
TMR_CVAL_ADDRESS
@ TMR_CVAL_ADDRESS
Definition: at32f435_437_tmr.h:364
TMR_CM1_ADDRESS
@ TMR_CM1_ADDRESS
Definition: at32f435_437_tmr.h:361
TMR_IDEN_ADDRESS
@ TMR_IDEN_ADDRESS
Definition: at32f435_437_tmr.h:358
TMR_DMACTRL_ADDRESS
@ TMR_DMACTRL_ADDRESS
Definition: at32f435_437_tmr.h:373
TMR_CCTRL_ADDRESS
@ TMR_CCTRL_ADDRESS
Definition: at32f435_437_tmr.h:363
TMR_RPR_ADDRESS
@ TMR_RPR_ADDRESS
Definition: at32f435_437_tmr.h:367
TMR_ISTS_ADDRESS
@ TMR_ISTS_ADDRESS
Definition: at32f435_437_tmr.h:359
TMR_C4DT_ADDRESS
@ TMR_C4DT_ADDRESS
Definition: at32f435_437_tmr.h:371
TMR_DIV_ADDRESS
@ TMR_DIV_ADDRESS
Definition: at32f435_437_tmr.h:365
TMR_SWEVT_ADDRESS
@ TMR_SWEVT_ADDRESS
Definition: at32f435_437_tmr.h:360
TMR_CM2_ADDRESS
@ TMR_CM2_ADDRESS
Definition: at32f435_437_tmr.h:362
TMR_C3DT_ADDRESS
@ TMR_C3DT_ADDRESS
Definition: at32f435_437_tmr.h:370
TMR_CTRL1_ADDRESS
@ TMR_CTRL1_ADDRESS
Definition: at32f435_437_tmr.h:355
TMR_WP_LEVEL_3
@ TMR_WP_LEVEL_3
Definition: at32f435_437_tmr.h:391
TMR_WP_LEVEL_2
@ TMR_WP_LEVEL_2
Definition: at32f435_437_tmr.h:392
TMR_WP_OFF
@ TMR_WP_OFF
Definition: at32f435_437_tmr.h:390
TMR_WP_LEVEL_1
@ TMR_WP_LEVEL_1
Definition: at32f435_437_tmr.h:393
TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR
@ TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR
Definition: at32f435_437_tmr.h:233
TMR_CHANEL1_CONNECTED_C1IRAW
@ TMR_CHANEL1_CONNECTED_C1IRAW
Definition: at32f435_437_tmr.h:232
TMR_CC_CHANNEL_MAPPED_STI
@ TMR_CC_CHANNEL_MAPPED_STI
Definition: at32f435_437_tmr.h:243
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f435_437_tmr.h:241
TMR_CC_CHANNEL_MAPPED_INDIRECT
@ TMR_CC_CHANNEL_MAPPED_INDIRECT
Definition: at32f435_437_tmr.h:242
TMR_CLOCK_DIV2
@ TMR_CLOCK_DIV2
Definition: at32f435_437_tmr.h:98
TMR_CLOCK_DIV4
@ TMR_CLOCK_DIV4
Definition: at32f435_437_tmr.h:99
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f435_437_tmr.h:97
TMR_C1_SWTRIG
@ TMR_C1_SWTRIG
Definition: at32f435_437_tmr.h:286
TMR_C3_SWTRIG
@ TMR_C3_SWTRIG
Definition: at32f435_437_tmr.h:288
TMR_C2_SWTRIG
@ TMR_C2_SWTRIG
Definition: at32f435_437_tmr.h:287
TMR_C4_SWTRIG
@ TMR_C4_SWTRIG
Definition: at32f435_437_tmr.h:289
TMR_BRK_SWTRIG
@ TMR_BRK_SWTRIG
Definition: at32f435_437_tmr.h:292
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f435_437_tmr.h:290
TMR_TRIGGER_SWTRIG
@ TMR_TRIGGER_SWTRIG
Definition: at32f435_437_tmr.h:291
TMR_OVERFLOW_SWTRIG
@ TMR_OVERFLOW_SWTRIG
Definition: at32f435_437_tmr.h:285
TMR_BRK_INPUT_ACTIVE_HIGH
@ TMR_BRK_INPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:382
TMR_BRK_INPUT_ACTIVE_LOW
@ TMR_BRK_INPUT_ACTIVE_LOW
Definition: at32f435_437_tmr.h:381
TMR_OUTPUT_CONTROL_PWM_MODE_B
@ TMR_OUTPUT_CONTROL_PWM_MODE_B
Definition: at32f435_437_tmr.h:181
TMR_OUTPUT_CONTROL_FORCE_HIGH
@ TMR_OUTPUT_CONTROL_FORCE_HIGH
Definition: at32f435_437_tmr.h:179
TMR_OUTPUT_CONTROL_SWITCH
@ TMR_OUTPUT_CONTROL_SWITCH
Definition: at32f435_437_tmr.h:177
TMR_OUTPUT_CONTROL_OFF
@ TMR_OUTPUT_CONTROL_OFF
Definition: at32f435_437_tmr.h:174
TMR_OUTPUT_CONTROL_LOW
@ TMR_OUTPUT_CONTROL_LOW
Definition: at32f435_437_tmr.h:176
TMR_OUTPUT_CONTROL_FORCE_LOW
@ TMR_OUTPUT_CONTROL_FORCE_LOW
Definition: at32f435_437_tmr.h:178
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f435_437_tmr.h:180
TMR_OUTPUT_CONTROL_HIGH
@ TMR_OUTPUT_CONTROL_HIGH
Definition: at32f435_437_tmr.h:175
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:198
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f435_437_tmr.h:199
TMR_DMA_TRANSFER_15BYTES
@ TMR_DMA_TRANSFER_15BYTES
Definition: at32f435_437_tmr.h:344
TMR_DMA_TRANSFER_11BYTES
@ TMR_DMA_TRANSFER_11BYTES
Definition: at32f435_437_tmr.h:340
TMR_DMA_TRANSFER_13BYTES
@ TMR_DMA_TRANSFER_13BYTES
Definition: at32f435_437_tmr.h:342
TMR_DMA_TRANSFER_14BYTES
@ TMR_DMA_TRANSFER_14BYTES
Definition: at32f435_437_tmr.h:343
TMR_DMA_TRANSFER_2BYTES
@ TMR_DMA_TRANSFER_2BYTES
Definition: at32f435_437_tmr.h:331
TMR_DMA_TRANSFER_18BYTES
@ TMR_DMA_TRANSFER_18BYTES
Definition: at32f435_437_tmr.h:347
TMR_DMA_TRANSFER_9BYTES
@ TMR_DMA_TRANSFER_9BYTES
Definition: at32f435_437_tmr.h:338
TMR_DMA_TRANSFER_12BYTES
@ TMR_DMA_TRANSFER_12BYTES
Definition: at32f435_437_tmr.h:341
TMR_DMA_TRANSFER_7BYTES
@ TMR_DMA_TRANSFER_7BYTES
Definition: at32f435_437_tmr.h:336
TMR_DMA_TRANSFER_17BYTES
@ TMR_DMA_TRANSFER_17BYTES
Definition: at32f435_437_tmr.h:346
TMR_DMA_TRANSFER_16BYTES
@ TMR_DMA_TRANSFER_16BYTES
Definition: at32f435_437_tmr.h:345
TMR_DMA_TRANSFER_5BYTES
@ TMR_DMA_TRANSFER_5BYTES
Definition: at32f435_437_tmr.h:334
TMR_DMA_TRANSFER_10BYTES
@ TMR_DMA_TRANSFER_10BYTES
Definition: at32f435_437_tmr.h:339
TMR_DMA_TRANSFER_1BYTE
@ TMR_DMA_TRANSFER_1BYTE
Definition: at32f435_437_tmr.h:330
TMR_DMA_TRANSFER_6BYTES
@ TMR_DMA_TRANSFER_6BYTES
Definition: at32f435_437_tmr.h:335
TMR_DMA_TRANSFER_4BYTES
@ TMR_DMA_TRANSFER_4BYTES
Definition: at32f435_437_tmr.h:333
TMR_DMA_TRANSFER_8BYTES
@ TMR_DMA_TRANSFER_8BYTES
Definition: at32f435_437_tmr.h:337
TMR_DMA_TRANSFER_3BYTES
@ TMR_DMA_TRANSFER_3BYTES
Definition: at32f435_437_tmr.h:332
TMR_SUB_INPUT_SEL_IS2
@ TMR_SUB_INPUT_SEL_IS2
Definition: at32f435_437_tmr.h:136
TMR_SUB_INPUT_SEL_IS0
@ TMR_SUB_INPUT_SEL_IS0
Definition: at32f435_437_tmr.h:134
TMR_SUB_INPUT_SEL_C2DF2
@ TMR_SUB_INPUT_SEL_C2DF2
Definition: at32f435_437_tmr.h:140
TMR_SUB_INPUT_SEL_EXTIN
@ TMR_SUB_INPUT_SEL_EXTIN
Definition: at32f435_437_tmr.h:141
TMR_SUB_INPUT_SEL_IS3
@ TMR_SUB_INPUT_SEL_IS3
Definition: at32f435_437_tmr.h:137
TMR_SUB_INPUT_SEL_C1DF1
@ TMR_SUB_INPUT_SEL_C1DF1
Definition: at32f435_437_tmr.h:139
TMR_SUB_INPUT_SEL_C1INC
@ TMR_SUB_INPUT_SEL_C1INC
Definition: at32f435_437_tmr.h:138
TMR_SUB_INPUT_SEL_IS1
@ TMR_SUB_INPUT_SEL_IS1
Definition: at32f435_437_tmr.h:135
TMR_FORCE_OUTPUT_HIGH
@ TMR_FORCE_OUTPUT_HIGH
Definition: at32f435_437_tmr.h:189
TMR_FORCE_OUTPUT_LOW
@ TMR_FORCE_OUTPUT_LOW
Definition: at32f435_437_tmr.h:190
TMR2_OTG2FS_TMR5_ERTC
@ TMR2_OTG2FS_TMR5_ERTC
Definition: at32f435_437_tmr.h:404
TMR2_OTG1FS_TMR5_LEXT
@ TMR2_OTG1FS_TMR5_LEXT
Definition: at32f435_437_tmr.h:403
TMR2_TMR8TRGOUT_TMR5_GPIO
@ TMR2_TMR8TRGOUT_TMR5_GPIO
Definition: at32f435_437_tmr.h:401
TMR2_PTP_TMR5_LICK
@ TMR2_PTP_TMR5_LICK
Definition: at32f435_437_tmr.h:402
TMR_SUB_ENCODER_MODE_A
@ TMR_SUB_ENCODER_MODE_A
Definition: at32f435_437_tmr.h:150
TMR_SUB_EXTERNAL_CLOCK_MODE_A
@ TMR_SUB_EXTERNAL_CLOCK_MODE_A
Definition: at32f435_437_tmr.h:156
TMR_SUB_ENCODER_MODE_C
@ TMR_SUB_ENCODER_MODE_C
Definition: at32f435_437_tmr.h:152
TMR_SUB_MODE_DIABLE
@ TMR_SUB_MODE_DIABLE
Definition: at32f435_437_tmr.h:149
TMR_SUB_RESET_MODE
@ TMR_SUB_RESET_MODE
Definition: at32f435_437_tmr.h:153
TMR_SUB_ENCODER_MODE_B
@ TMR_SUB_ENCODER_MODE_B
Definition: at32f435_437_tmr.h:151
TMR_SUB_HANG_MODE
@ TMR_SUB_HANG_MODE
Definition: at32f435_437_tmr.h:154
TMR_SUB_TRIGGER_MODE
@ TMR_SUB_TRIGGER_MODE
Definition: at32f435_437_tmr.h:155
TMR_PRIMARY_SEL_RESET
@ TMR_PRIMARY_SEL_RESET
Definition: at32f435_437_tmr.h:119
TMR_PRIMARY_SEL_C2ORAW
@ TMR_PRIMARY_SEL_C2ORAW
Definition: at32f435_437_tmr.h:124
TMR_PRIMARY_SEL_C1ORAW
@ TMR_PRIMARY_SEL_C1ORAW
Definition: at32f435_437_tmr.h:123
TMR_PRIMARY_SEL_C4ORAW
@ TMR_PRIMARY_SEL_C4ORAW
Definition: at32f435_437_tmr.h:126
TMR_PRIMARY_SEL_COMPARE
@ TMR_PRIMARY_SEL_COMPARE
Definition: at32f435_437_tmr.h:122
TMR_PRIMARY_SEL_ENABLE
@ TMR_PRIMARY_SEL_ENABLE
Definition: at32f435_437_tmr.h:120
TMR_PRIMARY_SEL_OVERFLOW
@ TMR_PRIMARY_SEL_OVERFLOW
Definition: at32f435_437_tmr.h:121
TMR_PRIMARY_SEL_C3ORAW
@ TMR_PRIMARY_SEL_C3ORAW
Definition: at32f435_437_tmr.h:125
TMR_ENCODER_MODE_C
@ TMR_ENCODER_MODE_C
Definition: at32f435_437_tmr.h:166
TMR_ENCODER_MODE_A
@ TMR_ENCODER_MODE_A
Definition: at32f435_437_tmr.h:164
TMR_ENCODER_MODE_B
@ TMR_ENCODER_MODE_B
Definition: at32f435_437_tmr.h:165
TMR_CHANNEL_INPUT_DIV_4
@ TMR_CHANNEL_INPUT_DIV_4
Definition: at32f435_437_tmr.h:253
TMR_CHANNEL_INPUT_DIV_2
@ TMR_CHANNEL_INPUT_DIV_2
Definition: at32f435_437_tmr.h:252
TMR_CHANNEL_INPUT_DIV_8
@ TMR_CHANNEL_INPUT_DIV_8
Definition: at32f435_437_tmr.h:254
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f435_437_tmr.h:251
tmr_brkdt_config_type
tmr brkdt config type
Definition: at32f435_437_tmr.h:436
tmr_brkdt_config_type::brk_enable
confirm_state brk_enable
Definition: at32f435_437_tmr.h:443
tmr_brkdt_config_type::deadtime
uint8_t deadtime
Definition: at32f435_437_tmr.h:437
tmr_brkdt_config_type::auto_output_enable
confirm_state auto_output_enable
Definition: at32f435_437_tmr.h:440
tmr_brkdt_config_type::wp_level
tmr_wp_level_type wp_level
Definition: at32f435_437_tmr.h:439
tmr_brkdt_config_type::fcsoen_state
confirm_state fcsoen_state
Definition: at32f435_437_tmr.h:441
tmr_brkdt_config_type::fcsodis_state
confirm_state fcsodis_state
Definition: at32f435_437_tmr.h:442
tmr_brkdt_config_type::brk_polarity
tmr_brk_polarity_type brk_polarity
Definition: at32f435_437_tmr.h:438
tmr_input_config_type
tmr input capture config type
Definition: at32f435_437_tmr.h:425
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f435_437_tmr.h:428
tmr_input_config_type::input_filter_value
uint8_t input_filter_value
Definition: at32f435_437_tmr.h:429
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f435_437_tmr.h:427
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f435_437_tmr.h:426
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f435_437_tmr.h:418
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f435_437_tmr.h:416
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f435_437_tmr.h:414
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
tmr_type
type define tmr register all
Definition: at32f435_437_tmr.h:450
tmr_type::ovfif
__IO uint32_t ovfif
Definition: at32f435_437_tmr.h:552
tmr_type::c1cen
__IO uint32_t c1cen
Definition: at32f435_437_tmr.h:679
tmr_type::pmen
__IO uint32_t pmen
Definition: at32f435_437_tmr.h:466
tmr_type::trgif
__IO uint32_t trgif
Definition: at32f435_437_tmr.h:558
tmr_type::brken
__IO uint32_t brken
Definition: at32f435_437_tmr.h:805
tmr_type::c1idiv
__IO uint32_t c1idiv
Definition: at32f435_437_tmr.h:620
tmr_type::dmactrl
__IO uint32_t dmactrl
Definition: at32f435_437_tmr.h:817
tmr_type::dtc
__IO uint32_t dtc
Definition: at32f435_437_tmr.h:801
tmr_type::c1en
__IO uint32_t c1en
Definition: at32f435_437_tmr.h:677
tmr_type::c5dt
__IO uint32_t c5dt
Definition: at32f435_437_tmr.h:883
tmr_type::c5octrl
__IO uint32_t c5octrl
Definition: at32f435_437_tmr.h:872
tmr_type::c4df
__IO uint32_t c4df
Definition: at32f435_437_tmr.h:664
tmr_type::c3octrl
__IO uint32_t c3octrl
Definition: at32f435_437_tmr.h:644
tmr_type::brkif
__IO uint32_t brkif
Definition: at32f435_437_tmr.h:559
tmr_type::c2osen
__IO uint32_t c2osen
Definition: at32f435_437_tmr.h:610
tmr_type::swevt
__IO uint32_t swevt
Definition: at32f435_437_tmr.h:574
tmr_type::ovfden
__IO uint32_t ovfden
Definition: at32f435_437_tmr.h:533
tmr_type::c2en
__IO uint32_t c2en
Definition: at32f435_437_tmr.h:681
tmr_type::stctrl
__IO uint32_t stctrl
Definition: at32f435_437_tmr.h:502
tmr_type::c3df
__IO uint32_t c3df
Definition: at32f435_437_tmr.h:661
tmr_type::wpc
__IO uint32_t wpc
Definition: at32f435_437_tmr.h:802
tmr_type::c3oben
__IO uint32_t c3oben
Definition: at32f435_437_tmr.h:643
tmr_type::cnt_dir
__IO uint32_t cnt_dir
Definition: at32f435_437_tmr.h:463
tmr_type::c2if
__IO uint32_t c2if
Definition: at32f435_437_tmr.h:554
tmr_type::c3if
__IO uint32_t c3if
Definition: at32f435_437_tmr.h:555
tmr_type::c4octrl
__IO uint32_t c4octrl
Definition: at32f435_437_tmr.h:649
tmr_type::hallif
__IO uint32_t hallif
Definition: at32f435_437_tmr.h:557
tmr_type::c1insel
__IO uint32_t c1insel
Definition: at32f435_437_tmr.h:484
tmr_type::tmr5_ch4_irmp
__IO uint32_t tmr5_ch4_irmp
Definition: at32f435_437_tmr.h:849
tmr_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_tmr.h:852
tmr_type::c2cios
__IO uint32_t c2cios
Definition: at32f435_437_tmr.h:488
tmr_type::div
__IO uint32_t div
Definition: at32f435_437_tmr.h:712
tmr_type::hallswtr
__IO uint32_t hallswtr
Definition: at32f435_437_tmr.h:582
tmr_type::esf
__IO uint32_t esf
Definition: at32f435_437_tmr.h:509
tmr_type::c1osen
__IO uint32_t c1osen
Definition: at32f435_437_tmr.h:605
tmr_type::c2cen
__IO uint32_t c2cen
Definition: at32f435_437_tmr.h:683
tmr_type::c2ien
__IO uint32_t c2ien
Definition: at32f435_437_tmr.h:527
tmr_type::drs
__IO uint32_t drs
Definition: at32f435_437_tmr.h:482
tmr_type::iden
__IO uint32_t iden
Definition: at32f435_437_tmr.h:522
tmr_type::c1oben
__IO uint32_t c1oben
Definition: at32f435_437_tmr.h:603
tmr_type::ists
__IO uint32_t ists
Definition: at32f435_437_tmr.h:549
tmr_type::cm3
__IO uint32_t cm3
Definition: at32f435_437_tmr.h:866
tmr_type::c1c
__IO uint32_t c1c
Definition: at32f435_437_tmr.h:601
tmr_type::c3cen
__IO uint32_t c3cen
Definition: at32f435_437_tmr.h:687
tmr_type::c4p
__IO uint32_t c4p
Definition: at32f435_437_tmr.h:690
tmr_type::brkv
__IO uint32_t brkv
Definition: at32f435_437_tmr.h:806
tmr_type::brk
__IO uint32_t brk
Definition: at32f435_437_tmr.h:798
tmr_type::rmp
__IO uint32_t rmp
Definition: at32f435_437_tmr.h:845
tmr_type::stis
__IO uint32_t stis
Definition: at32f435_437_tmr.h:507
tmr_type::ovfswtr
__IO uint32_t ovfswtr
Definition: at32f435_437_tmr.h:577
tmr_type::c3idiv
__IO uint32_t c3idiv
Definition: at32f435_437_tmr.h:660
tmr_type::c4osen
__IO uint32_t c4osen
Definition: at32f435_437_tmr.h:650
tmr_type::c1ien
__IO uint32_t c1ien
Definition: at32f435_437_tmr.h:526
tmr_type::c1octrl
__IO uint32_t c1octrl
Definition: at32f435_437_tmr.h:604
tmr_type::hallien
__IO uint32_t hallien
Definition: at32f435_437_tmr.h:530
tmr_type::tmren
__IO uint32_t tmren
Definition: at32f435_437_tmr.h:459
tmr_type::oen
__IO uint32_t oen
Definition: at32f435_437_tmr.h:808
tmr_type::sts
__IO uint32_t sts
Definition: at32f435_437_tmr.h:508
tmr_type::brkie
__IO uint32_t brkie
Definition: at32f435_437_tmr.h:532
tmr_type::c2idiv
__IO uint32_t c2idiv
Definition: at32f435_437_tmr.h:623
tmr_type::c1p
__IO uint32_t c1p
Definition: at32f435_437_tmr.h:678
tmr_type::brkswtr
__IO uint32_t brkswtr
Definition: at32f435_437_tmr.h:584
tmr_type::c1rf
__IO uint32_t c1rf
Definition: at32f435_437_tmr.h:561
tmr_type::ovfien
__IO uint32_t ovfien
Definition: at32f435_437_tmr.h:525
tmr_type::c1oien
__IO uint32_t c1oien
Definition: at32f435_437_tmr.h:602
tmr_type::pr
__IO uint32_t pr
Definition: at32f435_437_tmr.h:725
tmr_type::c3oien
__IO uint32_t c3oien
Definition: at32f435_437_tmr.h:642
tmr_type::c2swtr
__IO uint32_t c2swtr
Definition: at32f435_437_tmr.h:579
tmr_type::c1dt
uint32_t c1dt
Definition: at32f435_437_tmr.h:750
tmr_type::c2oben
__IO uint32_t c2oben
Definition: at32f435_437_tmr.h:608
tmr_type::c1den
__IO uint32_t c1den
Definition: at32f435_437_tmr.h:534
tmr_type::cm2
__IO uint32_t cm2
Definition: at32f435_437_tmr.h:634
tmr_type::c2octrl
__IO uint32_t c2octrl
Definition: at32f435_437_tmr.h:609
tmr_type::smsel
__IO uint32_t smsel
Definition: at32f435_437_tmr.h:505
tmr_type::c3p
__IO uint32_t c3p
Definition: at32f435_437_tmr.h:686
tmr_type::c2dt
__IO uint32_t c2dt
Definition: at32f435_437_tmr.h:765
tmr_type::dmadt
__IO uint32_t dmadt
Definition: at32f435_437_tmr.h:832
tmr_type::c1if
__IO uint32_t c1if
Definition: at32f435_437_tmr.h:553
tmr_type::c1cp
__IO uint32_t c1cp
Definition: at32f435_437_tmr.h:680
tmr_type::c3c
__IO uint32_t c3c
Definition: at32f435_437_tmr.h:641
tmr_type::c4rf
__IO uint32_t c4rf
Definition: at32f435_437_tmr.h:564
tmr_type::c3cios
__IO uint32_t c3cios
Definition: at32f435_437_tmr.h:490
tmr_type::clkdiv
__IO uint32_t clkdiv
Definition: at32f435_437_tmr.h:465
tmr_type::tden
__IO uint32_t tden
Definition: at32f435_437_tmr.h:539
tmr_type::ovfs
__IO uint32_t ovfs
Definition: at32f435_437_tmr.h:461
tmr_type::c1dt
__IO uint32_t c1dt
Definition: at32f435_437_tmr.h:753
tmr_type::trgout2en
__IO uint32_t trgout2en
Definition: at32f435_437_tmr.h:493
tmr_type::c3swtr
__IO uint32_t c3swtr
Definition: at32f435_437_tmr.h:580
tmr_type::cbctrl
__IO uint32_t cbctrl
Definition: at32f435_437_tmr.h:479
tmr_type::dtb
__IO uint32_t dtb
Definition: at32f435_437_tmr.h:822
tmr_type::c4ios
__IO uint32_t c4ios
Definition: at32f435_437_tmr.h:491
tmr_type::c4swtr
__IO uint32_t c4swtr
Definition: at32f435_437_tmr.h:581
tmr_type::prben
__IO uint32_t prben
Definition: at32f435_437_tmr.h:464
tmr_type::tien
__IO uint32_t tien
Definition: at32f435_437_tmr.h:531
tmr_type::c5oien
__IO uint32_t c5oien
Definition: at32f435_437_tmr.h:870
tmr_type::ccfs
__IO uint32_t ccfs
Definition: at32f435_437_tmr.h:481
tmr_type::ecmben
__IO uint32_t ecmben
Definition: at32f435_437_tmr.h:511
tmr_type::ovfen
__IO uint32_t ovfen
Definition: at32f435_437_tmr.h:460
tmr_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_tmr.h:492
tmr_type::cm1
__IO uint32_t cm1
Definition: at32f435_437_tmr.h:594
tmr_type::c2den
__IO uint32_t c2den
Definition: at32f435_437_tmr.h:535
tmr_type::c4en
__IO uint32_t c4en
Definition: at32f435_437_tmr.h:689
tmr_type::reserved
__IO uint32_t reserved
Definition: at32f435_437_tmr.h:585
tmr_type::trgswtr
__IO uint32_t trgswtr
Definition: at32f435_437_tmr.h:583
tmr_type::fcsoen
__IO uint32_t fcsoen
Definition: at32f435_437_tmr.h:804
tmr_type::esdiv
__IO uint32_t esdiv
Definition: at32f435_437_tmr.h:510
tmr_type::c3en
__IO uint32_t c3en
Definition: at32f435_437_tmr.h:685
tmr_type::c2p
__IO uint32_t c2p
Definition: at32f435_437_tmr.h:682
tmr_type::c5oben
__IO uint32_t c5oben
Definition: at32f435_437_tmr.h:871
tmr_type::c3ios
__IO uint32_t c3ios
Definition: at32f435_437_tmr.h:489
tmr_type::ocmen
__IO uint32_t ocmen
Definition: at32f435_437_tmr.h:462
tmr_type::hallde
__IO uint32_t hallde
Definition: at32f435_437_tmr.h:538
tmr_type::c1swtr
__IO uint32_t c1swtr
Definition: at32f435_437_tmr.h:578
tmr_type::c3rf
__IO uint32_t c3rf
Definition: at32f435_437_tmr.h:563
tmr_type::c3den
__IO uint32_t c3den
Definition: at32f435_437_tmr.h:536
tmr_type::c4oien
__IO uint32_t c4oien
Definition: at32f435_437_tmr.h:647
tmr_type::c2dt
uint32_t c2dt
Definition: at32f435_437_tmr.h:762
tmr_type::addr
__IO uint32_t addr
Definition: at32f435_437_tmr.h:820
tmr_type::c3cp
__IO uint32_t c3cp
Definition: at32f435_437_tmr.h:688
tmr_type::c2df
__IO uint32_t c2df
Definition: at32f435_437_tmr.h:624
tmr_type::c4idiv
__IO uint32_t c4idiv
Definition: at32f435_437_tmr.h:663
tmr_type::c2ios
__IO uint32_t c2ios
Definition: at32f435_437_tmr.h:487
tmr_type::c3osen
__IO uint32_t c3osen
Definition: at32f435_437_tmr.h:645
tmr_type::reserved1
__IO uint32_t reserved1
tmr reserved0 register, offset:0x54-0x6C
Definition: at32f435_437_tmr.h:467
tmr_type::rpr
__IO uint32_t rpr
Definition: at32f435_437_tmr.h:737
tmr_type::c2c
__IO uint32_t c2c
Definition: at32f435_437_tmr.h:606
tmr_type::c1ios
__IO uint32_t c1ios
Definition: at32f435_437_tmr.h:485
tmr_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f435_437_tmr.h:456
tmr_type::c5osen
__IO uint32_t c5osen
Definition: at32f435_437_tmr.h:873
tmr_type::c4den
__IO uint32_t c4den
Definition: at32f435_437_tmr.h:537
tmr_type::c1df
__IO uint32_t c1df
Definition: at32f435_437_tmr.h:621
tmr_type::c2oien
__IO uint32_t c2oien
Definition: at32f435_437_tmr.h:607
tmr_type::c4dt
__IO uint32_t c4dt
Definition: at32f435_437_tmr.h:786
tmr_type::c4if
__IO uint32_t c4if
Definition: at32f435_437_tmr.h:556
tmr_type::c3ien
__IO uint32_t c3ien
Definition: at32f435_437_tmr.h:528
tmr_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f435_437_tmr.h:476
tmr_type::c3dt
__IO uint32_t c3dt
Definition: at32f435_437_tmr.h:774
tmr_type::c2cp
__IO uint32_t c2cp
Definition: at32f435_437_tmr.h:684
tmr_type::tmr2_ch1_irmp
__IO uint32_t tmr2_ch1_irmp
Definition: at32f435_437_tmr.h:851
tmr_type::cctrl
uint32_t cctrl
Definition: at32f435_437_tmr.h:674
tmr_type::c4c
__IO uint32_t c4c
Definition: at32f435_437_tmr.h:646
tmr_type::c4oben
__IO uint32_t c4oben
Definition: at32f435_437_tmr.h:648
tmr_type::fcsodis
__IO uint32_t fcsodis
Definition: at32f435_437_tmr.h:803
tmr_type::cval
__IO uint32_t cval
Definition: at32f435_437_tmr.h:700
tmr_type::c4ien
__IO uint32_t c4ien
Definition: at32f435_437_tmr.h:529
tmr_type::esp
__IO uint32_t esp
Definition: at32f435_437_tmr.h:512
tmr_type::ptos
__IO uint32_t ptos
Definition: at32f435_437_tmr.h:483
tmr_type::c1cios
__IO uint32_t c1cios
Definition: at32f435_437_tmr.h:486
tmr_type::aoen
__IO uint32_t aoen
Definition: at32f435_437_tmr.h:807
tmr_type::c2rf
__IO uint32_t c2rf
Definition: at32f435_437_tmr.h:562


AT32F435/437 Firmwary Library: at32f435_437_usart.c Source File

  • libraries
  • drivers
  • src
at32f435_437_usart.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_conf.h"
29
39#ifdef USART_MODULE_ENABLED
40
52void usart_reset(usart_type* usart_x)
53{
54 if(usart_x == USART1)
55 {
56 crm_periph_reset(CRM_USART1_PERIPH_RESET, TRUE);
57 crm_periph_reset(CRM_USART1_PERIPH_RESET, FALSE);
58 }
59 else if(usart_x == USART2)
60 {
61 crm_periph_reset(CRM_USART2_PERIPH_RESET, TRUE);
62 crm_periph_reset(CRM_USART2_PERIPH_RESET, FALSE);
63 }
64 else if(usart_x == USART3)
65 {
66 crm_periph_reset(CRM_USART3_PERIPH_RESET, TRUE);
67 crm_periph_reset(CRM_USART3_PERIPH_RESET, FALSE);
68 }
69 else if(usart_x == UART4)
70 {
71 crm_periph_reset(CRM_UART4_PERIPH_RESET, TRUE);
72 crm_periph_reset(CRM_UART4_PERIPH_RESET, FALSE);
73 }
74 else if(usart_x == UART5)
75 {
76 crm_periph_reset(CRM_UART5_PERIPH_RESET, TRUE);
77 crm_periph_reset(CRM_UART5_PERIPH_RESET, FALSE);
78 }
79 else if(usart_x == USART6)
80 {
81 crm_periph_reset(CRM_USART6_PERIPH_RESET, TRUE);
82 crm_periph_reset(CRM_USART6_PERIPH_RESET, FALSE);
83 }
84 else if(usart_x == UART7)
85 {
86 crm_periph_reset(CRM_UART7_PERIPH_RESET, TRUE);
87 crm_periph_reset(CRM_UART7_PERIPH_RESET, FALSE);
88 }
89 else if(usart_x == UART8)
90 {
91 crm_periph_reset(CRM_UART8_PERIPH_RESET, TRUE);
92 crm_periph_reset(CRM_UART8_PERIPH_RESET, FALSE);
93 }
94}
95
115void usart_init(usart_type* usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
116{
117 crm_clocks_freq_type clocks_freq;
118 uint32_t apb_clock, temp_val;
119 crm_clocks_freq_get(&clocks_freq);
120 if((usart_x == USART1) || (usart_x == USART6))
121 {
122 apb_clock = clocks_freq.apb2_freq;
123 }
124 else
125 {
126 apb_clock = clocks_freq.apb1_freq;
127 }
128 temp_val = (apb_clock * 10 / baud_rate);
129 if((temp_val % 10) < 5)
130 {
131 temp_val = (temp_val / 10);
132 }
133 else
134 {
135 temp_val = (temp_val / 10) + 1;
136 }
137 usart_x->baudr_bit.div = temp_val;
138 if(data_bit == USART_DATA_7BITS)
139 {
140 usart_x->ctrl1_bit.dbn_h = 1;
141 usart_x->ctrl1_bit.dbn_l = 0;
142 }
143 else if(data_bit == USART_DATA_8BITS)
144 {
145 usart_x->ctrl1_bit.dbn_h = 0;
146 usart_x->ctrl1_bit.dbn_l = 0;
147 }
148 else
149 {
150 usart_x->ctrl1_bit.dbn_h = 0;
151 usart_x->ctrl1_bit.dbn_l = 1;
152 }
153 usart_x->ctrl2_bit.stopbn = stop_bit;
154}
155
168void usart_parity_selection_config(usart_type* usart_x, usart_parity_selection_type parity)
169{
170 if(parity == USART_PARITY_NONE)
171 {
172 usart_x->ctrl1_bit.psel = FALSE;
173 usart_x->ctrl1_bit.pen = FALSE;
174 }
175 else if(parity == USART_PARITY_EVEN)
176 {
177 usart_x->ctrl1_bit.psel = FALSE;
178 usart_x->ctrl1_bit.pen = TRUE;
179 }
180 else if(parity == USART_PARITY_ODD)
181 {
182 usart_x->ctrl1_bit.psel = TRUE;
183 usart_x->ctrl1_bit.pen = TRUE;
184 }
185}
186
196void usart_enable(usart_type* usart_x, confirm_state new_state)
197{
198 usart_x->ctrl1_bit.uen = new_state;
199}
200
209void usart_transmitter_enable(usart_type* usart_x, confirm_state new_state)
210{
211 usart_x->ctrl1_bit.ten = new_state;
212}
213
222void usart_receiver_enable(usart_type* usart_x, confirm_state new_state)
223{
224 usart_x->ctrl1_bit.ren = new_state;
225}
226
247void usart_clock_config(usart_type* usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
248{
249 usart_x->ctrl2_bit.clkpol = clk_pol;
250 usart_x->ctrl2_bit.clkpha = clk_pha;
251 usart_x->ctrl2_bit.lbcp = clk_lb;
252}
253
263void usart_clock_enable(usart_type* usart_x, confirm_state new_state)
264{
265 usart_x->ctrl2_bit.clken = new_state;
266}
267
287void usart_interrupt_enable(usart_type* usart_x, uint32_t usart_int, confirm_state new_state)
288{
289 if(new_state == TRUE)
290 PERIPH_REG((uint32_t)usart_x, usart_int) |= PERIPH_REG_BIT(usart_int);
291 else
292 PERIPH_REG((uint32_t)usart_x, usart_int) &= ~PERIPH_REG_BIT(usart_int);
293}
294
304void usart_dma_transmitter_enable(usart_type* usart_x, confirm_state new_state)
305{
306 usart_x->ctrl3_bit.dmaten = new_state;
307}
308
318void usart_dma_receiver_enable(usart_type* usart_x, confirm_state new_state)
319{
320 usart_x->ctrl3_bit.dmaren = new_state;
321}
322
331void usart_wakeup_id_set(usart_type* usart_x, uint8_t usart_id)
332{
333 if(usart_x->ctrl2_bit.idbn == USART_ID_FIXED_4_BIT)
334 {
335 usart_x->ctrl2_bit.id_l = (usart_id & 0x0F);
336 usart_x->ctrl2_bit.id_h = 0;
337 }
338 else
339 {
340 usart_x->ctrl2_bit.id_l = (usart_id & 0x0F);
341 usart_x->ctrl2_bit.id_h = ((usart_id & 0xF0) >> 4);
342 }
343}
344
356void usart_wakeup_mode_set(usart_type* usart_x, usart_wakeup_mode_type wakeup_mode)
357{
358 usart_x->ctrl1_bit.wum = wakeup_mode;
359}
360
370void usart_receiver_mute_enable(usart_type* usart_x, confirm_state new_state)
371{
372 usart_x->ctrl1_bit.rm = new_state;
373}
374
386void usart_break_bit_num_set(usart_type* usart_x, usart_break_bit_num_type break_bit)
387{
388 usart_x->ctrl2_bit.bfbn = break_bit;
389}
390
400void usart_lin_mode_enable(usart_type* usart_x, confirm_state new_state)
401{
402 usart_x->ctrl2_bit.linen = new_state;
403}
404
413void usart_data_transmit(usart_type* usart_x, uint16_t data)
414{
415 usart_x->dt = (data & 0x01FF);
416}
417
425uint16_t usart_data_receive(usart_type* usart_x)
426{
427 return (uint16_t)(usart_x->dt);
428}
429
437void usart_break_send(usart_type* usart_x)
438{
439 usart_x->ctrl1_bit.sbf = TRUE;
440}
441
451void usart_smartcard_guard_time_set(usart_type* usart_x, uint8_t guard_time_val)
452{
453 usart_x->gdiv_bit.scgt = guard_time_val;
454}
455
465void usart_irda_smartcard_division_set(usart_type* usart_x, uint8_t div_val)
466{
467 usart_x->gdiv_bit.isdiv = div_val;
468}
469
480void usart_smartcard_mode_enable(usart_type* usart_x, confirm_state new_state)
481{
482 usart_x->ctrl3_bit.scmen = new_state;
483}
484
495void usart_smartcard_nack_set(usart_type* usart_x, confirm_state new_state)
496{
497 usart_x->ctrl3_bit.scnacken = new_state;
498}
499
509void usart_single_line_halfduplex_select(usart_type* usart_x, confirm_state new_state)
510{
511 usart_x->ctrl3_bit.slben = new_state;
512}
513
523void usart_irda_mode_enable(usart_type* usart_x, confirm_state new_state)
524{
525 usart_x->ctrl3_bit.irdaen = new_state;
526}
527
537void usart_irda_low_power_enable(usart_type* usart_x, confirm_state new_state)
538{
539 usart_x->ctrl3_bit.irdalp = new_state;
540}
541
555void usart_hardware_flow_control_set(usart_type* usart_x,usart_hardware_flow_control_type flow_state)
556{
557 if(flow_state == USART_HARDWARE_FLOW_NONE)
558 {
559 usart_x->ctrl3_bit.rtsen = FALSE;
560 usart_x->ctrl3_bit.ctsen = FALSE;
561 }
562 else if(flow_state == USART_HARDWARE_FLOW_RTS)
563 {
564 usart_x->ctrl3_bit.rtsen = TRUE;
565 usart_x->ctrl3_bit.ctsen = FALSE;
566 }
567 else if(flow_state == USART_HARDWARE_FLOW_CTS)
568 {
569 usart_x->ctrl3_bit.rtsen = FALSE;
570 usart_x->ctrl3_bit.ctsen = TRUE;
571 }
572 else if(flow_state == USART_HARDWARE_FLOW_RTS_CTS)
573 {
574 usart_x->ctrl3_bit.rtsen = TRUE;
575 usart_x->ctrl3_bit.ctsen = TRUE;
576 }
577}
578
598 flag_status usart_flag_get(usart_type* usart_x, uint32_t flag)
599{
600 if(usart_x->sts & flag)
601 {
602 return SET;
603 }
604 else
605 {
606 return RESET;
607 }
608}
609
636void usart_flag_clear(usart_type* usart_x, uint32_t flag)
637{
638 if(flag & (USART_PERR_FLAG | USART_FERR_FLAG | USART_NERR_FLAG | USART_ROERR_FLAG | USART_IDLEF_FLAG))
639 {
640 UNUSED(usart_x->sts);
641 UNUSED(usart_x->dt);
642 }
643 else
644 {
645 usart_x->sts = ~flag;
646 }
647}
648
658void usart_rs485_delay_time_config(usart_type* usart_x, uint8_t start_delay_time, uint8_t complete_delay_time)
659{
660 usart_x->ctrl1_bit.tsdt = start_delay_time;
661 usart_x->ctrl1_bit.tcdt = complete_delay_time;
662}
663
673void usart_transmit_receive_pin_swap(usart_type* usart_x, confirm_state new_state)
674{
675 usart_x->ctrl2_bit.trpswap = new_state;
676}
677
687void usart_id_bit_num_set(usart_type* usart_x, usart_identification_bit_num_type id_bit_num)
688{
689 usart_x->ctrl2_bit.idbn = (uint8_t)id_bit_num;
690}
691
701void usart_de_polarity_set(usart_type* usart_x, usart_de_polarity_type de_polarity)
702{
703 usart_x->ctrl3_bit.dep = (uint8_t)de_polarity;
704}
705
715void usart_rs485_mode_enable(usart_type* usart_x, confirm_state new_state)
716{
717 usart_x->ctrl3_bit.rs485en = new_state;
718}
719
724#endif
725
UNUSED
#define UNUSED(x)
Definition: at32f435_437_def.h:65
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f435_437_crm.c:251
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_UART4_PERIPH_RESET
@ CRM_UART4_PERIPH_RESET
Definition: at32f435_437_crm.h:289
CRM_USART1_PERIPH_RESET
@ CRM_USART1_PERIPH_RESET
Definition: at32f435_437_crm.h:303
CRM_UART7_PERIPH_RESET
@ CRM_UART7_PERIPH_RESET
Definition: at32f435_437_crm.h:298
CRM_UART8_PERIPH_RESET
@ CRM_UART8_PERIPH_RESET
Definition: at32f435_437_crm.h:299
CRM_USART2_PERIPH_RESET
@ CRM_USART2_PERIPH_RESET
Definition: at32f435_437_crm.h:287
CRM_UART5_PERIPH_RESET
@ CRM_UART5_PERIPH_RESET
Definition: at32f435_437_crm.h:290
CRM_USART6_PERIPH_RESET
@ CRM_USART6_PERIPH_RESET
Definition: at32f435_437_crm.h:304
CRM_USART3_PERIPH_RESET
@ CRM_USART3_PERIPH_RESET
Definition: at32f435_437_crm.h:288
PERIPH_REG
#define PERIPH_REG(periph_base, value)
Definition: at32f435_437.h:396
PERIPH_REG_BIT
#define PERIPH_REG_BIT(value)
Definition: at32f435_437.h:397
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
usart_break_bit_num_type
usart_break_bit_num_type
usart break frame bit num type
Definition: at32f435_437_usart.h:122
usart_clock_polarity_type
usart_clock_polarity_type
usart polarity of the clock type
Definition: at32f435_437_usart.h:140
usart_hardware_flow_control_type
usart_hardware_flow_control_type
usart hardware flow control type
Definition: at32f435_437_usart.h:169
usart_stop_bit_num_type
usart_stop_bit_num_type
usart stop bit num type
Definition: at32f435_437_usart.h:158
usart_data_bit_num_type
usart_data_bit_num_type
usart data bit num type
Definition: at32f435_437_usart.h:112
usart_parity_selection_type
usart_parity_selection_type
usart parity selection type
Definition: at32f435_437_usart.h:93
usart_lbcp_type
usart_lbcp_type
usart last bit clock pulse type
Definition: at32f435_437_usart.h:149
usart_de_polarity_type
usart_de_polarity_type
usart de polarity type
Definition: at32f435_437_usart.h:189
usart_wakeup_mode_type
usart_wakeup_mode_type
usart wakeup mode type
Definition: at32f435_437_usart.h:103
usart_clock_phase_type
usart_clock_phase_type
usart phase of the clock type
Definition: at32f435_437_usart.h:131
usart_identification_bit_num_type
usart_identification_bit_num_type
usart identification bit num type
Definition: at32f435_437_usart.h:180
USART_HARDWARE_FLOW_CTS
@ USART_HARDWARE_FLOW_CTS
Definition: at32f435_437_usart.h:172
USART_HARDWARE_FLOW_RTS
@ USART_HARDWARE_FLOW_RTS
Definition: at32f435_437_usart.h:171
USART_HARDWARE_FLOW_NONE
@ USART_HARDWARE_FLOW_NONE
Definition: at32f435_437_usart.h:170
USART_HARDWARE_FLOW_RTS_CTS
@ USART_HARDWARE_FLOW_RTS_CTS
Definition: at32f435_437_usart.h:173
USART_DATA_7BITS
@ USART_DATA_7BITS
Definition: at32f435_437_usart.h:113
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f435_437_usart.h:114
USART_PARITY_ODD
@ USART_PARITY_ODD
Definition: at32f435_437_usart.h:96
USART_PARITY_EVEN
@ USART_PARITY_EVEN
Definition: at32f435_437_usart.h:95
USART_PARITY_NONE
@ USART_PARITY_NONE
Definition: at32f435_437_usart.h:94
USART_ID_FIXED_4_BIT
@ USART_ID_FIXED_4_BIT
Definition: at32f435_437_usart.h:181
USART_NERR_FLAG
#define USART_NERR_FLAG
Definition: at32f435_437_usart.h:54
USART_FERR_FLAG
#define USART_FERR_FLAG
Definition: at32f435_437_usart.h:53
USART_IDLEF_FLAG
#define USART_IDLEF_FLAG
Definition: at32f435_437_usart.h:56
USART_ROERR_FLAG
#define USART_ROERR_FLAG
Definition: at32f435_437_usart.h:55
USART_PERR_FLAG
#define USART_PERR_FLAG
Definition: at32f435_437_usart.h:52
usart_clock_enable
void usart_clock_enable(usart_type *usart_x, confirm_state new_state)
usart enable the ck pin.
Definition: at32f435_437_usart.c:263
usart_transmit_receive_pin_swap
void usart_transmit_receive_pin_swap(usart_type *usart_x, confirm_state new_state)
swap the usart's transmit receive pin.
Definition: at32f435_437_usart.c:673
usart_rs485_mode_enable
void usart_rs485_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's rs485 mode.
Definition: at32f435_437_usart.c:715
usart_smartcard_nack_set
void usart_smartcard_nack_set(usart_type *usart_x, confirm_state new_state)
enable or disable nack transmission in smartcard mode.
Definition: at32f435_437_usart.c:495
usart_clock_config
void usart_clock_config(usart_type *usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
usart clock config.
Definition: at32f435_437_usart.c:247
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f435_437_usart.c:413
usart_parity_selection_config
void usart_parity_selection_config(usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config.
Definition: at32f435_437_usart.c:168
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f435_437_usart.c:598
usart_id_bit_num_set
void usart_id_bit_num_set(usart_type *usart_x, usart_identification_bit_num_type id_bit_num)
set the usart's identification bit num.
Definition: at32f435_437_usart.c:687
usart_wakeup_id_set
void usart_wakeup_id_set(usart_type *usart_x, uint8_t usart_id)
set the wakeup id of the usart.
Definition: at32f435_437_usart.c:331
usart_de_polarity_set
void usart_de_polarity_set(usart_type *usart_x, usart_de_polarity_type de_polarity)
set the usart's de polarity.
Definition: at32f435_437_usart.c:701
usart_reset
void usart_reset(usart_type *usart_x)
deinitialize the usart peripheral registers to their default reset values.
Definition: at32f435_437_usart.c:52
usart_lin_mode_enable
void usart_lin_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart lin mode.
Definition: at32f435_437_usart.c:400
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f435_437_usart.c:209
usart_dma_receiver_enable
void usart_dma_receiver_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma receiver interface.
Definition: at32f435_437_usart.c:318
usart_irda_low_power_enable
void usart_irda_low_power_enable(usart_type *usart_x, confirm_state new_state)
configure the usart's irda low power.
Definition: at32f435_437_usart.c:537
usart_break_send
void usart_break_send(usart_type *usart_x)
transmit break characters.
Definition: at32f435_437_usart.c:437
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f435_437_usart.c:115
usart_irda_smartcard_division_set
void usart_irda_smartcard_division_set(usart_type *usart_x, uint8_t div_val)
config the irda/smartcard division.
Definition: at32f435_437_usart.c:465
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f435_437_usart.c:196
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f435_437_usart.c:222
usart_smartcard_guard_time_set
void usart_smartcard_guard_time_set(usart_type *usart_x, uint8_t guard_time_val)
config the specified usart smartcard guard time.
Definition: at32f435_437_usart.c:451
usart_flag_clear
void usart_flag_clear(usart_type *usart_x, uint32_t flag)
clear the usart's pending flags.
Definition: at32f435_437_usart.c:636
usart_wakeup_mode_set
void usart_wakeup_mode_set(usart_type *usart_x, usart_wakeup_mode_type wakeup_mode)
select the usart wakeup method in multi-processor communication.
Definition: at32f435_437_usart.c:356
usart_irda_mode_enable
void usart_irda_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's irda interface.
Definition: at32f435_437_usart.c:523
usart_break_bit_num_set
void usart_break_bit_num_set(usart_type *usart_x, usart_break_bit_num_type break_bit)
set the usart break frame bit num.
Definition: at32f435_437_usart.c:386
usart_hardware_flow_control_set
void usart_hardware_flow_control_set(usart_type *usart_x, usart_hardware_flow_control_type flow_state)
configure the usart's hardware flow control.
Definition: at32f435_437_usart.c:555
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f435_437_usart.c:287
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f435_437_usart.c:425
usart_single_line_halfduplex_select
void usart_single_line_halfduplex_select(usart_type *usart_x, confirm_state new_state)
enable or disable the usart single line bidirectional half-duplex communication.
Definition: at32f435_437_usart.c:509
usart_dma_transmitter_enable
void usart_dma_transmitter_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface.
Definition: at32f435_437_usart.c:304
usart_rs485_delay_time_config
void usart_rs485_delay_time_config(usart_type *usart_x, uint8_t start_delay_time, uint8_t complete_delay_time)
configure the usart's rs485 transmit delay time.
Definition: at32f435_437_usart.c:658
usart_smartcard_mode_enable
void usart_smartcard_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart smart card mode.
Definition: at32f435_437_usart.c:480
usart_receiver_mute_enable
void usart_receiver_mute_enable(usart_type *usart_x, confirm_state new_state)
config the usart in mute mode in multi-processor communication.
Definition: at32f435_437_usart.c:370
UART7
#define UART7
Definition: at32f435_437_usart.h:354
USART3
#define USART3
Definition: at32f435_437_usart.h:350
USART6
#define USART6
Definition: at32f435_437_usart.h:353
UART8
#define UART8
Definition: at32f435_437_usart.h:355
UART4
#define UART4
Definition: at32f435_437_usart.h:351
UART5
#define UART5
Definition: at32f435_437_usart.h:352
USART1
#define USART1
Definition: at32f435_437_usart.h:348
USART2
#define USART2
Definition: at32f435_437_usart.h:349
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f435_437_crm.h:792
crm_clocks_freq_type::apb2_freq
uint32_t apb2_freq
Definition: at32f435_437_crm.h:791
usart_type
type define usart register all
Definition: at32f435_437_usart.h:198
usart_type::scmen
__IO uint32_t scmen
Definition: at32f435_437_usart.h:316
usart_type::baudr_bit
struct usart_type::@1132::@1144 baudr_bit
usart_type::scgt
__IO uint32_t scgt
Definition: at32f435_437_usart.h:338
usart_type::clken
__IO uint32_t clken
Definition: at32f435_437_usart.h:294
usart_type::linen
__IO uint32_t linen
Definition: at32f435_437_usart.h:296
usart_type::ctrl2_bit
struct usart_type::@1136::@1146 ctrl2_bit
usart_type::psel
__IO uint32_t psel
Definition: at32f435_437_usart.h:264
usart_type::sbf
__IO uint32_t sbf
Definition: at32f435_437_usart.h:255
usart_type::slben
__IO uint32_t slben
Definition: at32f435_437_usart.h:314
usart_type::id_l
__IO uint32_t id_l
Definition: at32f435_437_usart.h:286
usart_type::gdiv_bit
struct usart_type::@1140::@1148 gdiv_bit
usart_type::isdiv
__IO uint32_t isdiv
Definition: at32f435_437_usart.h:337
usart_type::tcdt
__IO uint32_t tcdt
Definition: at32f435_437_usart.h:270
usart_type::dep
__IO uint32_t dep
Definition: at32f435_437_usart.h:324
usart_type::wum
__IO uint32_t wum
Definition: at32f435_437_usart.h:266
usart_type::pen
__IO uint32_t pen
Definition: at32f435_437_usart.h:265
usart_type::scnacken
__IO uint32_t scnacken
Definition: at32f435_437_usart.h:315
usart_type::tsdt
__IO uint32_t tsdt
Definition: at32f435_437_usart.h:271
usart_type::trpswap
__IO uint32_t trpswap
Definition: at32f435_437_usart.h:297
usart_type::ctsen
__IO uint32_t ctsen
Definition: at32f435_437_usart.h:320
usart_type::uen
__IO uint32_t uen
Definition: at32f435_437_usart.h:268
usart_type::idbn
__IO uint32_t idbn
Definition: at32f435_437_usart.h:287
usart_type::ctrl1_bit
struct usart_type::@1134::@1145 ctrl1_bit
usart_type::rm
__IO uint32_t rm
Definition: at32f435_437_usart.h:256
usart_type::clkpha
__IO uint32_t clkpha
Definition: at32f435_437_usart.h:292
usart_type::clkpol
__IO uint32_t clkpol
Definition: at32f435_437_usart.h:293
usart_type::rtsen
__IO uint32_t rtsen
Definition: at32f435_437_usart.h:319
usart_type::dbn_h
__IO uint32_t dbn_h
Definition: at32f435_437_usart.h:273
usart_type::dmaren
__IO uint32_t dmaren
Definition: at32f435_437_usart.h:317
usart_type::lbcp
__IO uint32_t lbcp
Definition: at32f435_437_usart.h:291
usart_type::dmaten
__IO uint32_t dmaten
Definition: at32f435_437_usart.h:318
usart_type::id_h
__IO uint32_t id_h
Definition: at32f435_437_usart.h:299
usart_type::sts
__IO uint32_t sts
Definition: at32f435_437_usart.h:204
usart_type::ren
__IO uint32_t ren
Definition: at32f435_437_usart.h:257
usart_type::rs485en
__IO uint32_t rs485en
Definition: at32f435_437_usart.h:323
usart_type::dbn_l
__IO uint32_t dbn_l
Definition: at32f435_437_usart.h:267
usart_type::irdaen
__IO uint32_t irdaen
Definition: at32f435_437_usart.h:312
usart_type::ten
__IO uint32_t ten
Definition: at32f435_437_usart.h:258
usart_type::div
__IO uint32_t div
Definition: at32f435_437_usart.h:242
usart_type::stopbn
__IO uint32_t stopbn
Definition: at32f435_437_usart.h:295
usart_type::irdalp
__IO uint32_t irdalp
Definition: at32f435_437_usart.h:313
usart_type::dt
__IO uint32_t dt
Definition: at32f435_437_usart.h:226
usart_type::bfbn
__IO uint32_t bfbn
Definition: at32f435_437_usart.h:288
usart_type::ctrl3_bit
struct usart_type::@1138::@1147 ctrl3_bit
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_usart.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_usart.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_USART_H
29#define __AT32F435_437_USART_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
52#define USART_PERR_FLAG ((uint32_t)0x00000001)
53#define USART_FERR_FLAG ((uint32_t)0x00000002)
54#define USART_NERR_FLAG ((uint32_t)0x00000004)
55#define USART_ROERR_FLAG ((uint32_t)0x00000008)
56#define USART_IDLEF_FLAG ((uint32_t)0x00000010)
57#define USART_RDBF_FLAG ((uint32_t)0x00000020)
58#define USART_TDC_FLAG ((uint32_t)0x00000040)
59#define USART_TDBE_FLAG ((uint32_t)0x00000080)
60#define USART_BFF_FLAG ((uint32_t)0x00000100)
61#define USART_CTSCF_FLAG ((uint32_t)0x00000200)
72#define USART_IDLE_INT MAKE_VALUE(0x0C,0x04)
73#define USART_RDBF_INT MAKE_VALUE(0x0C,0x05)
74#define USART_TDC_INT MAKE_VALUE(0x0C,0x06)
75#define USART_TDBE_INT MAKE_VALUE(0x0C,0x07)
76#define USART_PERR_INT MAKE_VALUE(0x0C,0x08)
77#define USART_BF_INT MAKE_VALUE(0x10,0x06)
78#define USART_ERR_INT MAKE_VALUE(0x14,0x00)
79#define USART_CTSCF_INT MAKE_VALUE(0x14,0x0A)
92typedef enum
93{
94 USART_PARITY_NONE = 0x00,
95 USART_PARITY_EVEN = 0x01,
96 USART_PARITY_ODD = 0x02
97} usart_parity_selection_type;
98
102typedef enum
103{
104 USART_WAKEUP_BY_IDLE_FRAME = 0x00,
105 USART_WAKEUP_BY_MATCHING_ID = 0x01
106} usart_wakeup_mode_type;
107
111typedef enum
112{
113 USART_DATA_7BITS = 0x00,
114 USART_DATA_8BITS = 0x01,
115 USART_DATA_9BITS = 0x02
116} usart_data_bit_num_type;
117
121typedef enum
122{
123 USART_BREAK_10BITS = 0x00,
124 USART_BREAK_11BITS = 0x01
125} usart_break_bit_num_type;
126
130typedef enum
131{
132 USART_CLOCK_PHASE_1EDGE = 0x00,
133 USART_CLOCK_PHASE_2EDGE = 0x01
134} usart_clock_phase_type;
135
139typedef enum
140{
141 USART_CLOCK_POLARITY_LOW = 0x00,
142 USART_CLOCK_POLARITY_HIGH = 0x01
143} usart_clock_polarity_type;
144
148typedef enum
149{
150 USART_CLOCK_LAST_BIT_NONE = 0x00,
151 USART_CLOCK_LAST_BIT_OUTPUT = 0x01
152} usart_lbcp_type;
153
157typedef enum
158{
159 USART_STOP_1_BIT = 0x00,
160 USART_STOP_0_5_BIT = 0x01,
161 USART_STOP_2_BIT = 0x02,
162 USART_STOP_1_5_BIT = 0x03
163} usart_stop_bit_num_type;
164
168typedef enum
169{
170 USART_HARDWARE_FLOW_NONE = 0x00,
171 USART_HARDWARE_FLOW_RTS = 0x01,
172 USART_HARDWARE_FLOW_CTS = 0x02,
173 USART_HARDWARE_FLOW_RTS_CTS = 0x03
174} usart_hardware_flow_control_type;
175
179typedef enum
180{
181 USART_ID_FIXED_4_BIT = 0x00,
182 USART_ID_RELATED_DATA_BIT = 0x01
183} usart_identification_bit_num_type;
184
188typedef enum
189{
190 USART_DE_POLARITY_HIGH = 0x00,
191 USART_DE_POLARITY_LOW = 0x01
192} usart_de_polarity_type;
193
197typedef struct
198{
202 union
203 {
204 __IO uint32_t sts;
205 struct
206 {
207 __IO uint32_t perr : 1; /* [0] */
208 __IO uint32_t ferr : 1; /* [1] */
209 __IO uint32_t nerr : 1; /* [2] */
210 __IO uint32_t roerr : 1; /* [3] */
211 __IO uint32_t idlef : 1; /* [4] */
212 __IO uint32_t rdbf : 1; /* [5] */
213 __IO uint32_t tdc : 1; /* [6] */
214 __IO uint32_t tdbe : 1; /* [7] */
215 __IO uint32_t bff : 1; /* [8] */
216 __IO uint32_t ctscf : 1; /* [9] */
217 __IO uint32_t reserved1 : 22;/* [31:10] */
218 } sts_bit;
219 };
220
224 union
225 {
226 __IO uint32_t dt;
227 struct
228 {
229 __IO uint32_t dt : 9; /* [8:0] */
230 __IO uint32_t reserved1 : 23;/* [31:9] */
231 } dt_bit;
232 };
233
237 union
238 {
239 __IO uint32_t baudr;
240 struct
241 {
242 __IO uint32_t div : 16;/* [15:0] */
243 __IO uint32_t reserved1 : 16;/* [31:16] */
244 } baudr_bit;
245 };
246
250 union
251 {
252 __IO uint32_t ctrl1;
253 struct
254 {
255 __IO uint32_t sbf : 1; /* [0] */
256 __IO uint32_t rm : 1; /* [1] */
257 __IO uint32_t ren : 1; /* [2] */
258 __IO uint32_t ten : 1; /* [3] */
259 __IO uint32_t idleien : 1; /* [4] */
260 __IO uint32_t rdbfien : 1; /* [5] */
261 __IO uint32_t tdcien : 1; /* [6] */
262 __IO uint32_t tdbeien : 1; /* [7] */
263 __IO uint32_t perrien : 1; /* [8] */
264 __IO uint32_t psel : 1; /* [9] */
265 __IO uint32_t pen : 1; /* [10] */
266 __IO uint32_t wum : 1; /* [11] */
267 __IO uint32_t dbn_l : 1; /* [12] */
268 __IO uint32_t uen : 1; /* [13] */
269 __IO uint32_t reserved1 : 2; /* [15:14] */
270 __IO uint32_t tcdt : 5; /* [20:16] */
271 __IO uint32_t tsdt : 5; /* [25:21] */
272 __IO uint32_t reserved2 : 2; /* [27:26] */
273 __IO uint32_t dbn_h : 1; /* [28] */
274 __IO uint32_t reserved3 : 3; /* [31:29] */
275 } ctrl1_bit;
276 };
277
281 union
282 {
283 __IO uint32_t ctrl2;
284 struct
285 {
286 __IO uint32_t id_l : 4; /* [3:0] */
287 __IO uint32_t idbn : 1; /* [4] */
288 __IO uint32_t bfbn : 1; /* [5] */
289 __IO uint32_t bfien : 1; /* [6] */
290 __IO uint32_t reserved1 : 1; /* [7] */
291 __IO uint32_t lbcp : 1; /* [8] */
292 __IO uint32_t clkpha : 1; /* [9] */
293 __IO uint32_t clkpol : 1; /* [10] */
294 __IO uint32_t clken : 1; /* [11] */
295 __IO uint32_t stopbn : 2; /* [13:12] */
296 __IO uint32_t linen : 1; /* [14] */
297 __IO uint32_t trpswap : 1; /* [15] */
298 __IO uint32_t reserved2 : 12;/* [27:16] */
299 __IO uint32_t id_h : 4; /* [31:28] */
300 } ctrl2_bit;
301 };
302
306 union
307 {
308 __IO uint32_t ctrl3;
309 struct
310 {
311 __IO uint32_t errien : 1; /* [0] */
312 __IO uint32_t irdaen : 1; /* [1] */
313 __IO uint32_t irdalp : 1; /* [2] */
314 __IO uint32_t slben : 1; /* [3] */
315 __IO uint32_t scnacken : 1; /* [4] */
316 __IO uint32_t scmen : 1; /* [5] */
317 __IO uint32_t dmaren : 1; /* [6] */
318 __IO uint32_t dmaten : 1; /* [7] */
319 __IO uint32_t rtsen : 1; /* [8] */
320 __IO uint32_t ctsen : 1; /* [9] */
321 __IO uint32_t ctscfien : 1; /* [10] */
322 __IO uint32_t reserved1 : 3; /* [13:11] */
323 __IO uint32_t rs485en : 1; /* [14] */
324 __IO uint32_t dep : 1; /* [15] */
325 __IO uint32_t reserved2 : 16;/* [31:16] */
326 } ctrl3_bit;
327 };
328
332 union
333 {
334 __IO uint32_t gdiv;
335 struct
336 {
337 __IO uint32_t isdiv : 8; /* [7:0] */
338 __IO uint32_t scgt : 8; /* [15:8] */
339 __IO uint32_t reserved1 : 16;/* [31:16] */
340 } gdiv_bit;
341 };
342} usart_type;
343
348#define USART1 ((usart_type *) USART1_BASE)
349#define USART2 ((usart_type *) USART2_BASE)
350#define USART3 ((usart_type *) USART3_BASE)
351#define UART4 ((usart_type *) UART4_BASE)
352#define UART5 ((usart_type *) UART5_BASE)
353#define USART6 ((usart_type *) USART6_BASE)
354#define UART7 ((usart_type *) UART7_BASE)
355#define UART8 ((usart_type *) UART8_BASE)
356
361void usart_reset(usart_type* usart_x);
362void usart_init(usart_type* usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit);
363void usart_parity_selection_config(usart_type* usart_x, usart_parity_selection_type parity);
364void usart_enable(usart_type* usart_x, confirm_state new_state);
365void usart_transmitter_enable(usart_type* usart_x, confirm_state new_state);
366void usart_receiver_enable(usart_type* usart_x, confirm_state new_state);
367void usart_clock_config(usart_type* usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb);
368void usart_clock_enable(usart_type* usart_x, confirm_state new_state);
369void usart_interrupt_enable(usart_type* usart_x, uint32_t usart_int, confirm_state new_state);
370void usart_dma_transmitter_enable(usart_type* usart_x, confirm_state new_state);
371void usart_dma_receiver_enable(usart_type* usart_x, confirm_state new_state);
372void usart_wakeup_id_set(usart_type* usart_x, uint8_t usart_id);
373void usart_wakeup_mode_set(usart_type* usart_x, usart_wakeup_mode_type wakeup_mode);
374void usart_receiver_mute_enable(usart_type* usart_x, confirm_state new_state);
375void usart_break_bit_num_set(usart_type* usart_x, usart_break_bit_num_type break_bit);
376void usart_lin_mode_enable(usart_type* usart_x, confirm_state new_state);
377void usart_data_transmit(usart_type* usart_x, uint16_t data);
378uint16_t usart_data_receive(usart_type* usart_x);
379void usart_break_send(usart_type* usart_x);
380void usart_smartcard_guard_time_set(usart_type* usart_x, uint8_t guard_time_val);
381void usart_irda_smartcard_division_set(usart_type* usart_x, uint8_t div_val);
382void usart_smartcard_mode_enable(usart_type* usart_x, confirm_state new_state);
383void usart_smartcard_nack_set(usart_type* usart_x, confirm_state new_state);
384void usart_single_line_halfduplex_select(usart_type* usart_x, confirm_state new_state);
385void usart_irda_mode_enable(usart_type* usart_x, confirm_state new_state);
386void usart_irda_low_power_enable(usart_type* usart_x, confirm_state new_state);
387void usart_hardware_flow_control_set(usart_type* usart_x,usart_hardware_flow_control_type flow_state);
388 flag_status usart_flag_get(usart_type* usart_x, uint32_t flag);
389void usart_flag_clear(usart_type* usart_x, uint32_t flag);
390void usart_rs485_delay_time_config(usart_type* usart_x, uint8_t start_delay_time, uint8_t complete_delay_time);
391void usart_transmit_receive_pin_swap(usart_type* usart_x, confirm_state new_state);
392void usart_id_bit_num_set(usart_type* usart_x, usart_identification_bit_num_type id_bit_num);
393void usart_de_polarity_set(usart_type* usart_x, usart_de_polarity_type de_polarity);
394void usart_rs485_mode_enable(usart_type* usart_x, confirm_state new_state);
395
408#ifdef __cplusplus
409}
410#endif
411
412#endif
at32f435_437.h
at32f435_437 header file
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
usart_clock_enable
void usart_clock_enable(usart_type *usart_x, confirm_state new_state)
usart enable the ck pin.
Definition: at32f435_437_usart.c:263
usart_transmit_receive_pin_swap
void usart_transmit_receive_pin_swap(usart_type *usart_x, confirm_state new_state)
swap the usart's transmit receive pin.
Definition: at32f435_437_usart.c:673
usart_rs485_mode_enable
void usart_rs485_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's rs485 mode.
Definition: at32f435_437_usart.c:715
usart_smartcard_nack_set
void usart_smartcard_nack_set(usart_type *usart_x, confirm_state new_state)
enable or disable nack transmission in smartcard mode.
Definition: at32f435_437_usart.c:495
usart_clock_config
void usart_clock_config(usart_type *usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
usart clock config.
Definition: at32f435_437_usart.c:247
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f435_437_usart.c:413
usart_parity_selection_config
void usart_parity_selection_config(usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config.
Definition: at32f435_437_usart.c:168
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f435_437_usart.c:598
usart_id_bit_num_set
void usart_id_bit_num_set(usart_type *usart_x, usart_identification_bit_num_type id_bit_num)
set the usart's identification bit num.
Definition: at32f435_437_usart.c:687
usart_wakeup_id_set
void usart_wakeup_id_set(usart_type *usart_x, uint8_t usart_id)
set the wakeup id of the usart.
Definition: at32f435_437_usart.c:331
usart_de_polarity_set
void usart_de_polarity_set(usart_type *usart_x, usart_de_polarity_type de_polarity)
set the usart's de polarity.
Definition: at32f435_437_usart.c:701
usart_reset
void usart_reset(usart_type *usart_x)
deinitialize the usart peripheral registers to their default reset values.
Definition: at32f435_437_usart.c:52
usart_lin_mode_enable
void usart_lin_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart lin mode.
Definition: at32f435_437_usart.c:400
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f435_437_usart.c:209
usart_dma_receiver_enable
void usart_dma_receiver_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma receiver interface.
Definition: at32f435_437_usart.c:318
usart_irda_low_power_enable
void usart_irda_low_power_enable(usart_type *usart_x, confirm_state new_state)
configure the usart's irda low power.
Definition: at32f435_437_usart.c:537
usart_break_send
void usart_break_send(usart_type *usart_x)
transmit break characters.
Definition: at32f435_437_usart.c:437
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f435_437_usart.c:115
usart_irda_smartcard_division_set
void usart_irda_smartcard_division_set(usart_type *usart_x, uint8_t div_val)
config the irda/smartcard division.
Definition: at32f435_437_usart.c:465
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f435_437_usart.c:196
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f435_437_usart.c:222
usart_smartcard_guard_time_set
void usart_smartcard_guard_time_set(usart_type *usart_x, uint8_t guard_time_val)
config the specified usart smartcard guard time.
Definition: at32f435_437_usart.c:451
usart_flag_clear
void usart_flag_clear(usart_type *usart_x, uint32_t flag)
clear the usart's pending flags.
Definition: at32f435_437_usart.c:636
usart_wakeup_mode_set
void usart_wakeup_mode_set(usart_type *usart_x, usart_wakeup_mode_type wakeup_mode)
select the usart wakeup method in multi-processor communication.
Definition: at32f435_437_usart.c:356
usart_irda_mode_enable
void usart_irda_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's irda interface.
Definition: at32f435_437_usart.c:523
usart_break_bit_num_set
void usart_break_bit_num_set(usart_type *usart_x, usart_break_bit_num_type break_bit)
set the usart break frame bit num.
Definition: at32f435_437_usart.c:386
usart_hardware_flow_control_set
void usart_hardware_flow_control_set(usart_type *usart_x, usart_hardware_flow_control_type flow_state)
configure the usart's hardware flow control.
Definition: at32f435_437_usart.c:555
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f435_437_usart.c:287
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f435_437_usart.c:425
usart_single_line_halfduplex_select
void usart_single_line_halfduplex_select(usart_type *usart_x, confirm_state new_state)
enable or disable the usart single line bidirectional half-duplex communication.
Definition: at32f435_437_usart.c:509
usart_dma_transmitter_enable
void usart_dma_transmitter_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface.
Definition: at32f435_437_usart.c:304
usart_rs485_delay_time_config
void usart_rs485_delay_time_config(usart_type *usart_x, uint8_t start_delay_time, uint8_t complete_delay_time)
configure the usart's rs485 transmit delay time.
Definition: at32f435_437_usart.c:658
usart_smartcard_mode_enable
void usart_smartcard_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart smart card mode.
Definition: at32f435_437_usart.c:480
usart_receiver_mute_enable
void usart_receiver_mute_enable(usart_type *usart_x, confirm_state new_state)
config the usart in mute mode in multi-processor communication.
Definition: at32f435_437_usart.c:370
usart_break_bit_num_type
usart_break_bit_num_type
usart break frame bit num type
Definition: at32f435_437_usart.h:122
usart_clock_polarity_type
usart_clock_polarity_type
usart polarity of the clock type
Definition: at32f435_437_usart.h:140
usart_hardware_flow_control_type
usart_hardware_flow_control_type
usart hardware flow control type
Definition: at32f435_437_usart.h:169
usart_stop_bit_num_type
usart_stop_bit_num_type
usart stop bit num type
Definition: at32f435_437_usart.h:158
usart_data_bit_num_type
usart_data_bit_num_type
usart data bit num type
Definition: at32f435_437_usart.h:112
usart_parity_selection_type
usart_parity_selection_type
usart parity selection type
Definition: at32f435_437_usart.h:93
usart_lbcp_type
usart_lbcp_type
usart last bit clock pulse type
Definition: at32f435_437_usart.h:149
usart_de_polarity_type
usart_de_polarity_type
usart de polarity type
Definition: at32f435_437_usart.h:189
usart_wakeup_mode_type
usart_wakeup_mode_type
usart wakeup mode type
Definition: at32f435_437_usart.h:103
usart_clock_phase_type
usart_clock_phase_type
usart phase of the clock type
Definition: at32f435_437_usart.h:131
usart_identification_bit_num_type
usart_identification_bit_num_type
usart identification bit num type
Definition: at32f435_437_usart.h:180
USART_BREAK_11BITS
@ USART_BREAK_11BITS
Definition: at32f435_437_usart.h:124
USART_BREAK_10BITS
@ USART_BREAK_10BITS
Definition: at32f435_437_usart.h:123
USART_CLOCK_POLARITY_HIGH
@ USART_CLOCK_POLARITY_HIGH
Definition: at32f435_437_usart.h:142
USART_CLOCK_POLARITY_LOW
@ USART_CLOCK_POLARITY_LOW
Definition: at32f435_437_usart.h:141
USART_HARDWARE_FLOW_CTS
@ USART_HARDWARE_FLOW_CTS
Definition: at32f435_437_usart.h:172
USART_HARDWARE_FLOW_RTS
@ USART_HARDWARE_FLOW_RTS
Definition: at32f435_437_usart.h:171
USART_HARDWARE_FLOW_NONE
@ USART_HARDWARE_FLOW_NONE
Definition: at32f435_437_usart.h:170
USART_HARDWARE_FLOW_RTS_CTS
@ USART_HARDWARE_FLOW_RTS_CTS
Definition: at32f435_437_usart.h:173
USART_STOP_1_5_BIT
@ USART_STOP_1_5_BIT
Definition: at32f435_437_usart.h:162
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f435_437_usart.h:159
USART_STOP_0_5_BIT
@ USART_STOP_0_5_BIT
Definition: at32f435_437_usart.h:160
USART_STOP_2_BIT
@ USART_STOP_2_BIT
Definition: at32f435_437_usart.h:161
USART_DATA_7BITS
@ USART_DATA_7BITS
Definition: at32f435_437_usart.h:113
USART_DATA_9BITS
@ USART_DATA_9BITS
Definition: at32f435_437_usart.h:115
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f435_437_usart.h:114
USART_PARITY_ODD
@ USART_PARITY_ODD
Definition: at32f435_437_usart.h:96
USART_PARITY_EVEN
@ USART_PARITY_EVEN
Definition: at32f435_437_usart.h:95
USART_PARITY_NONE
@ USART_PARITY_NONE
Definition: at32f435_437_usart.h:94
USART_CLOCK_LAST_BIT_OUTPUT
@ USART_CLOCK_LAST_BIT_OUTPUT
Definition: at32f435_437_usart.h:151
USART_CLOCK_LAST_BIT_NONE
@ USART_CLOCK_LAST_BIT_NONE
Definition: at32f435_437_usart.h:150
USART_DE_POLARITY_HIGH
@ USART_DE_POLARITY_HIGH
Definition: at32f435_437_usart.h:190
USART_DE_POLARITY_LOW
@ USART_DE_POLARITY_LOW
Definition: at32f435_437_usart.h:191
USART_WAKEUP_BY_MATCHING_ID
@ USART_WAKEUP_BY_MATCHING_ID
Definition: at32f435_437_usart.h:105
USART_WAKEUP_BY_IDLE_FRAME
@ USART_WAKEUP_BY_IDLE_FRAME
Definition: at32f435_437_usart.h:104
USART_CLOCK_PHASE_1EDGE
@ USART_CLOCK_PHASE_1EDGE
Definition: at32f435_437_usart.h:132
USART_CLOCK_PHASE_2EDGE
@ USART_CLOCK_PHASE_2EDGE
Definition: at32f435_437_usart.h:133
USART_ID_RELATED_DATA_BIT
@ USART_ID_RELATED_DATA_BIT
Definition: at32f435_437_usart.h:182
USART_ID_FIXED_4_BIT
@ USART_ID_FIXED_4_BIT
Definition: at32f435_437_usart.h:181
usart_type
type define usart register all
Definition: at32f435_437_usart.h:198
usart_type::scmen
__IO uint32_t scmen
Definition: at32f435_437_usart.h:316
usart_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f435_437_usart.h:283
usart_type::tdcien
__IO uint32_t tdcien
Definition: at32f435_437_usart.h:261
usart_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_usart.h:217
usart_type::ctrl3
__IO uint32_t ctrl3
Definition: at32f435_437_usart.h:308
usart_type::scgt
__IO uint32_t scgt
Definition: at32f435_437_usart.h:338
usart_type::clken
__IO uint32_t clken
Definition: at32f435_437_usart.h:294
usart_type::linen
__IO uint32_t linen
Definition: at32f435_437_usart.h:296
usart_type::rdbf
__IO uint32_t rdbf
Definition: at32f435_437_usart.h:212
usart_type::psel
__IO uint32_t psel
Definition: at32f435_437_usart.h:264
usart_type::rdbfien
__IO uint32_t rdbfien
Definition: at32f435_437_usart.h:260
usart_type::sbf
__IO uint32_t sbf
Definition: at32f435_437_usart.h:255
usart_type::slben
__IO uint32_t slben
Definition: at32f435_437_usart.h:314
usart_type::id_l
__IO uint32_t id_l
Definition: at32f435_437_usart.h:286
usart_type::tdbeien
__IO uint32_t tdbeien
Definition: at32f435_437_usart.h:262
usart_type::isdiv
__IO uint32_t isdiv
Definition: at32f435_437_usart.h:337
usart_type::baudr
__IO uint32_t baudr
Definition: at32f435_437_usart.h:239
usart_type::ferr
__IO uint32_t ferr
Definition: at32f435_437_usart.h:208
usart_type::tcdt
__IO uint32_t tcdt
Definition: at32f435_437_usart.h:270
usart_type::dep
__IO uint32_t dep
Definition: at32f435_437_usart.h:324
usart_type::wum
__IO uint32_t wum
Definition: at32f435_437_usart.h:266
usart_type::pen
__IO uint32_t pen
Definition: at32f435_437_usart.h:265
usart_type::scnacken
__IO uint32_t scnacken
Definition: at32f435_437_usart.h:315
usart_type::roerr
__IO uint32_t roerr
Definition: at32f435_437_usart.h:210
usart_type::tsdt
__IO uint32_t tsdt
Definition: at32f435_437_usart.h:271
usart_type::ctscfien
__IO uint32_t ctscfien
Definition: at32f435_437_usart.h:321
usart_type::gdiv
__IO uint32_t gdiv
Definition: at32f435_437_usart.h:334
usart_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f435_437_usart.h:252
usart_type::trpswap
__IO uint32_t trpswap
Definition: at32f435_437_usart.h:297
usart_type::ctsen
__IO uint32_t ctsen
Definition: at32f435_437_usart.h:320
usart_type::uen
__IO uint32_t uen
Definition: at32f435_437_usart.h:268
usart_type::idbn
__IO uint32_t idbn
Definition: at32f435_437_usart.h:287
usart_type::idlef
__IO uint32_t idlef
Definition: at32f435_437_usart.h:211
usart_type::rm
__IO uint32_t rm
Definition: at32f435_437_usart.h:256
usart_type::tdbe
__IO uint32_t tdbe
Definition: at32f435_437_usart.h:214
usart_type::clkpha
__IO uint32_t clkpha
Definition: at32f435_437_usart.h:292
usart_type::clkpol
__IO uint32_t clkpol
Definition: at32f435_437_usart.h:293
usart_type::perr
__IO uint32_t perr
Definition: at32f435_437_usart.h:207
usart_type::rtsen
__IO uint32_t rtsen
Definition: at32f435_437_usart.h:319
usart_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_usart.h:274
usart_type::dbn_h
__IO uint32_t dbn_h
Definition: at32f435_437_usart.h:273
usart_type::dmaren
__IO uint32_t dmaren
Definition: at32f435_437_usart.h:317
usart_type::tdc
__IO uint32_t tdc
Definition: at32f435_437_usart.h:213
usart_type::lbcp
__IO uint32_t lbcp
Definition: at32f435_437_usart.h:291
usart_type::dmaten
__IO uint32_t dmaten
Definition: at32f435_437_usart.h:318
usart_type::id_h
__IO uint32_t id_h
Definition: at32f435_437_usart.h:299
usart_type::sts
__IO uint32_t sts
Definition: at32f435_437_usart.h:204
usart_type::ren
__IO uint32_t ren
Definition: at32f435_437_usart.h:257
usart_type::rs485en
__IO uint32_t rs485en
Definition: at32f435_437_usart.h:323
usart_type::errien
__IO uint32_t errien
Definition: at32f435_437_usart.h:311
usart_type::bff
__IO uint32_t bff
Definition: at32f435_437_usart.h:215
usart_type::dbn_l
__IO uint32_t dbn_l
Definition: at32f435_437_usart.h:267
usart_type::irdaen
__IO uint32_t irdaen
Definition: at32f435_437_usart.h:312
usart_type::ten
__IO uint32_t ten
Definition: at32f435_437_usart.h:258
usart_type::div
__IO uint32_t div
Definition: at32f435_437_usart.h:242
usart_type::ctscf
__IO uint32_t ctscf
Definition: at32f435_437_usart.h:216
usart_type::nerr
__IO uint32_t nerr
Definition: at32f435_437_usart.h:209
usart_type::stopbn
__IO uint32_t stopbn
Definition: at32f435_437_usart.h:295
usart_type::irdalp
__IO uint32_t irdalp
Definition: at32f435_437_usart.h:313
usart_type::dt
__IO uint32_t dt
Definition: at32f435_437_usart.h:226
usart_type::perrien
__IO uint32_t perrien
Definition: at32f435_437_usart.h:263
usart_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_usart.h:272
usart_type::bfien
__IO uint32_t bfien
Definition: at32f435_437_usart.h:289
usart_type::bfbn
__IO uint32_t bfbn
Definition: at32f435_437_usart.h:288
usart_type::idleien
__IO uint32_t idleien
Definition: at32f435_437_usart.h:259


AT32F435/437 Firmwary Library: iap.h File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Macros | Functions
at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h File Reference

iap header file More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | APP_START_ADDR 0x08004000
#define | IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x1000)
#define | IAP_UPGRADE_FLAG 0x41544B38

Functions

void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...

Detailed Description

iap header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h.


AT32F435/437 Firmwary Library: iap.h Source File

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h
Go to the documentation of this file.
1
27#ifndef __IAP_H__
28#define __IAP_H__
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "at32f435_437_board.h"
35
48/* app starting address */
49#define APP_START_ADDR 0x08004000
50
51/* the previous sector of app starting address is iap upgrade flag */
52#define IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x1000)
53
62/* when app received cmd 0x5aa5 from pc-tool, will set up the flag,
63indicates that an app upgrade will follow, see iap application note for more details */
64#define IAP_UPGRADE_FLAG 0x41544B38
65
74void iap_command_handle(void);
75void iap_init(void);
76
89#ifdef __cplusplus
90}
91#endif
92
93#endif
at32f435_437_board.h
iap_init
void iap_init(void)
iap init.
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c:61
iap_command_handle
void iap_command_handle(void)
iap command handle handle.
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c:44


AT32F435/437 Firmwary Library: tmr.h File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Functions
at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/tmr.h File Reference

tmr header file More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void tmr_init (void)
init tmr. More...

Detailed Description

tmr header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/tmr.h.


AT32F435/437 Firmwary Library: tmr.h Source File

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/tmr.h
Go to the documentation of this file.
1
27#ifndef __TMR_H
28#define __TMR_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "at32f435_437_board.h"
35
48void tmr_init(void);
49
62#ifdef __cplusplus
63}
64#endif
65
66#endif
at32f435_437_board.h
tmr_init
void tmr_init(void)
init tmr.
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/tmr.c:44


AT32F435/437 Firmwary Library: iap.c File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions
at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c File Reference

iap program More...

#include "iap.h"
#include "usart.h"
#include "tmr.h"

Go to the source code of this file.

Functions

void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...

Detailed Description

iap program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c.


AT32F435/437 Firmwary Library: iap.c Source File

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c
Go to the documentation of this file.
1
27#include "iap.h"
28#include "usart.h"
29#include "tmr.h"
30
44void iap_command_handle(void)
45{
46 if(iap_flag==IAP_REV_FLAG_DONE)
47 {
48 flash_unlock();
49 flash_sector_erase(IAP_UPGRADE_FLAG_ADDR);
50 flash_word_program(IAP_UPGRADE_FLAG_ADDR, IAP_UPGRADE_FLAG);
51 flash_lock();
52 nvic_system_reset();
53 }
54}
55
61void iap_init(void)
62{
63 if((*(uint32_t*)IAP_UPGRADE_FLAG_ADDR) == IAP_UPGRADE_FLAG)
64 {
65 flash_unlock();
66 flash_sector_erase(IAP_UPGRADE_FLAG_ADDR);
67 flash_lock();
68 }
69}
70
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f435_437_flash.c:357
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f435_437_flash.c:290
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f435_437_flash.c:608
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f435_437_flash.c:325
IAP_UPGRADE_FLAG_ADDR
#define IAP_UPGRADE_FLAG_ADDR
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h:52
IAP_REV_FLAG_DONE
#define IAP_REV_FLAG_DONE
Definition: app_led3_toggle/inc/usart.h:52
IAP_UPGRADE_FLAG
#define IAP_UPGRADE_FLAG
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h:64
iap_init
void iap_init(void)
iap init.
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c:61
iap_command_handle
void iap_command_handle(void)
iap command handle handle.
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c:44
iap_flag
uint8_t iap_flag
Definition: app_led3_toggle/src/usart.c:38
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f435_437_misc.c:52


AT32F435/437 Firmwary Library: tmr.c File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions
at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/tmr.c File Reference

tmr program More...

#include "at32f435_437_board.h"
#include "tmr.h"
#include "iap.h"

Go to the source code of this file.

Functions

void | tmr_init (void)
init tmr. More...
void | TMR3_GLOBAL_IRQHandler (void)
tmr3 global interrupt handler. More...

Detailed Description

tmr program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/tmr.c.


AT32F435/437 Firmwary Library: tmr.c Source File

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/tmr.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "tmr.h"
29#include "iap.h"
30
44void tmr_init(void)
45{
46 crm_clocks_freq_type crm_clocks_freq_struct = {0};
47
48 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
49
50 /* enable the tmr3 global interrupt */
51 nvic_irq_enable(TMR3_GLOBAL_IRQn, 1, 0);
52
53 /* get system clock */
54 crm_clocks_freq_get(&crm_clocks_freq_struct);
55
56 /* time base configuration */
57 tmr_base_init(TMR3, 10000, crm_clocks_freq_struct.ahb_freq / 10000);
58 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
59
60 /* overflow interrupt enable */
61 tmr_interrupt_enable(TMR3, TMR_OVF_INT, TRUE);
62
63 /* enable tmr */
64 tmr_counter_enable(TMR3, TRUE);
65}
66
72void TMR3_GLOBAL_IRQHandler(void)
73{
74 if(tmr_flag_get(TMR3, TMR_OVF_FLAG) == SET)
75 {
76 tmr_flag_clear(TMR3, TMR_OVF_FLAG);
77 at32_led_toggle(LED3);
78 }
79}
80
at32f435_437_board.h
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:40
LED3
@ LED3
Definition: at32f435_437_board.h:66
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:129
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
TMR3_GLOBAL_IRQHandler
void TMR3_GLOBAL_IRQHandler(void)
tmr3 global interrupt handler.
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/tmr.c:72
tmr_init
void tmr_init(void)
init tmr.
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/tmr.c:44
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f435_437_tmr.c:1463
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f435_437_tmr.c:1424
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f435_437_tmr.c:1389
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_OVF_FLAG
#define TMR_OVF_FLAG
Definition: at32f435_437_tmr.h:52
TMR_OVF_INT
#define TMR_OVF_INT
Definition: at32f435_437_tmr.h:75
TMR3
#define TMR3
Definition: at32f435_437_tmr.h:897
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f435_437.h:177
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::ahb_freq
uint32_t ahb_freq
Definition: at32f435_437_crm.h:790


AT32F435/437 Firmwary Library: iap.h File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Macros | Functions
at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/iap.h File Reference

iap header file More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | APP_START_ADDR 0x08004000
#define | IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x1000)
#define | IAP_UPGRADE_FLAG 0x41544B38

Functions

void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...

Detailed Description

iap header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/iap.h.


AT32F435/437 Firmwary Library: iap.h Source File

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/iap.h
Go to the documentation of this file.
1
27#ifndef __IAP_H__
28#define __IAP_H__
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "at32f435_437_board.h"
35
48/* app starting address */
49#define APP_START_ADDR 0x08004000
50
51/* the previous sector of app starting address is iap upgrade flag */
52#define IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x1000)
53
62/* when app received cmd 0x5aa5 from pc-tool, will set up the flag,
63indicates that an app upgrade will follow, see iap application note for more details */
64#define IAP_UPGRADE_FLAG 0x41544B38
65
74void iap_command_handle(void);
75void iap_init(void);
76
89#ifdef __cplusplus
90}
91#endif
92
93#endif
at32f435_437_board.h
iap_init
void iap_init(void)
iap init.
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c:61
iap_command_handle
void iap_command_handle(void)
iap command handle handle.
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c:44


AT32F435/437 Firmwary Library: tmr.h File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Functions
at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/tmr.h File Reference

tmr header file More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void tmr_init (void)
init tmr. More...

Detailed Description

tmr header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/tmr.h.


AT32F435/437 Firmwary Library: tmr.h Source File

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/tmr.h
Go to the documentation of this file.
1
27#ifndef __TMR_H
28#define __TMR_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "at32f435_437_board.h"
35
48void tmr_init(void);
49
62#ifdef __cplusplus
63}
64#endif
65
66#endif
at32f435_437_board.h
tmr_init
void tmr_init(void)
init tmr.
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/tmr.c:44


AT32F435/437 Firmwary Library: iap.c File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
Functions
at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/iap.c File Reference

iap program More...

#include "iap.h"
#include "usart.h"
#include "tmr.h"

Go to the source code of this file.

Functions

void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...

Detailed Description

iap program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/iap.c.


AT32F435/437 Firmwary Library: iap.c Source File

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/iap.c
Go to the documentation of this file.
1
27#include "iap.h"
28#include "usart.h"
29#include "tmr.h"
30
44void iap_command_handle(void)
45{
46 if(iap_flag==IAP_REV_FLAG_DONE)
47 {
48 flash_unlock();
49 flash_sector_erase(IAP_UPGRADE_FLAG_ADDR);
50 flash_word_program(IAP_UPGRADE_FLAG_ADDR, IAP_UPGRADE_FLAG);
51 flash_lock();
52 nvic_system_reset();
53 }
54}
55
61void iap_init(void)
62{
63 if((*(uint32_t*)IAP_UPGRADE_FLAG_ADDR) == IAP_UPGRADE_FLAG)
64 {
65 flash_unlock();
66 flash_sector_erase(IAP_UPGRADE_FLAG_ADDR);
67 flash_lock();
68 }
69}
70
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f435_437_flash.c:357
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f435_437_flash.c:290
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f435_437_flash.c:608
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f435_437_flash.c:325
IAP_UPGRADE_FLAG_ADDR
#define IAP_UPGRADE_FLAG_ADDR
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h:52
IAP_REV_FLAG_DONE
#define IAP_REV_FLAG_DONE
Definition: app_led3_toggle/inc/usart.h:52
IAP_UPGRADE_FLAG
#define IAP_UPGRADE_FLAG
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h:64
iap_flag
uint8_t iap_flag
Definition: app_led3_toggle/src/usart.c:38
iap_init
void iap_init(void)
iap init.
Definition: at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/iap.c:61
iap_command_handle
void iap_command_handle(void)
iap command handle handle.
Definition: at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/iap.c:44
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f435_437_misc.c:52


AT32F435/437 Firmwary Library: tmr.c File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
Functions
at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/tmr.c File Reference

tmr program More...

#include "at32f435_437_board.h"
#include "tmr.h"
#include "iap.h"

Go to the source code of this file.

Functions

void | tmr_init (void)
init tmr. More...
void | TMR3_GLOBAL_IRQHandler (void)
tmr3 global interrupt handler. More...

Detailed Description

tmr program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/tmr.c.


AT32F435/437 Firmwary Library: tmr.c Source File

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/tmr.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "tmr.h"
29#include "iap.h"
30
44void tmr_init(void)
45{
46 crm_clocks_freq_type crm_clocks_freq_struct = {0};
47
48 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
49
50 /* enable the tmr3 global interrupt */
51 nvic_irq_enable(TMR3_GLOBAL_IRQn, 1, 0);
52
53 /* get system clock */
54 crm_clocks_freq_get(&crm_clocks_freq_struct);
55
56 /* time base configuration */
57 tmr_base_init(TMR3, 10000, crm_clocks_freq_struct.ahb_freq / 10000);
58 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
59
60 /* overflow interrupt enable */
61 tmr_interrupt_enable(TMR3, TMR_OVF_INT, TRUE);
62
63 /* enable tmr */
64 tmr_counter_enable(TMR3, TRUE);
65}
66
72void TMR3_GLOBAL_IRQHandler(void)
73{
74 if(tmr_flag_get(TMR3, TMR_OVF_FLAG) == SET)
75 {
76 tmr_flag_clear(TMR3, TMR_OVF_FLAG);
77 at32_led_toggle(LED4);
78 }
79}
80
at32f435_437_board.h
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:40
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:129
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
TMR3_GLOBAL_IRQHandler
void TMR3_GLOBAL_IRQHandler(void)
tmr3 global interrupt handler.
Definition: at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/tmr.c:72
tmr_init
void tmr_init(void)
init tmr.
Definition: at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/tmr.c:44
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f435_437_tmr.c:1463
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f435_437_tmr.c:1424
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f435_437_tmr.c:1389
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_OVF_FLAG
#define TMR_OVF_FLAG
Definition: at32f435_437_tmr.h:52
TMR_OVF_INT
#define TMR_OVF_INT
Definition: at32f435_437_tmr.h:75
TMR3
#define TMR3
Definition: at32f435_437_tmr.h:897
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f435_437.h:177
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::ahb_freq
uint32_t ahb_freq
Definition: at32f435_437_crm.h:790


AT32F435/437 Firmwary Library: iap.h File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • bootloader
  • inc
Data Structures | Macros | Typedefs | Enumerations | Functions | Variables
at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h File Reference

iap header file More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Data Structures

struct cmd_data_group_type
cmd data group type More...

Macros

#define | APP_START_ADDR 0x08004000
#define | IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x1000)
#define | IAP_UPGRADE_FLAG 0x41544B38

Typedefs

typedef void(* iapfun) (void)

Enumerations

enum cmd_data_step_type {
CMD_DATA_IDLE , CMD_DATA_ADDR , CMD_DATA_BUF , CMD_DATA_CHACK ,
CMD_DATA_DONE , CMD_DATA_ERR
}
cmd data step type More...
enum cmd_ctr_step_type {
CMD_CTR_IDLE , CMD_CTR_INIT , CMD_CTR_DONE , CMD_CTR_ERR ,
CMD_CTR_APP
}
cmd ctr step type More...
enum update_status_type { UPDATE_PRE , UPDATE_CLEAR_FLAG , UPDATE_ING , UPDATE_DONE }
update status type More...

Functions

void | command_handle (void)
command analysis handle. More...
void | back_err (void)
command response error. More...
void | back_ok (void)
command response ok. More...
void | iap_upgrade_app_handle (void)
iap upgrade app handle. More...
void | app_load (uint32_t appxaddr)
app load. More...

Variables

cmd_data_group_type cmd_data_group_type_struct
cmd_data_step_type cmd_data_step
cmd_ctr_step_type cmd_ctr_step
update_status_type update_status

Detailed Description

iap header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h.


AT32F435/437 Firmwary Library: iap.h Source File

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • bootloader
  • inc
at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
Go to the documentation of this file.
1
27#ifndef __IAP_H__
28#define __IAP_H__
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "at32f435_437_board.h"
35
48/* app starting address */
49#define APP_START_ADDR 0x08004000
50
51/* the previous sector of app starting address is iap upgrade flag */
52#define IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x1000)
53
62/* when app received cmd 0x5aa5 from pc-tool, will set up the flag,
63indicates that an app upgrade will follow, see iap application note for more details */
64#define IAP_UPGRADE_FLAG 0x41544B38
65
77typedef struct
78{
79 uint8_t cmd_head;
80 uint8_t cmd_addr[4];
81 uint8_t cmd_buf[0x800];
82 uint8_t cmd_check;
83} cmd_data_group_type;
84
88typedef enum
89{
90 CMD_DATA_IDLE,
91 CMD_DATA_ADDR,
92 CMD_DATA_BUF,
93 CMD_DATA_CHACK,
94 CMD_DATA_DONE,
95 CMD_DATA_ERR,
96} cmd_data_step_type;
97
101typedef enum
102{
103 CMD_CTR_IDLE,
104 CMD_CTR_INIT,
105 CMD_CTR_DONE,
106 CMD_CTR_ERR,
107 CMD_CTR_APP,
108} cmd_ctr_step_type;
109
113typedef enum
114{
115 UPDATE_PRE,
116 UPDATE_CLEAR_FLAG,
117 UPDATE_ING,
118 UPDATE_DONE,
119} update_status_type;
120
121typedef void (*iapfun)(void);
122
127extern cmd_data_group_type cmd_data_group_type_struct;
128extern cmd_data_step_type cmd_data_step;
129extern cmd_ctr_step_type cmd_ctr_step;
130extern update_status_type update_status;
131
136void command_handle(void);
137void back_err(void);
138void back_ok(void);
139void iap_upgrade_app_handle(void);
140void app_load(uint32_t appxaddr);
141
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f435_437_board.h
command_handle
void command_handle(void)
command analysis handle.
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c:106
iap_upgrade_app_handle
void iap_upgrade_app_handle(void)
iap upgrade app handle.
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c:344
app_load
void app_load(uint32_t appxaddr)
app load.
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c:60
back_err
void back_err(void)
command response error.
Definition: app_led3_toggle/src/usart.c:114
back_ok
void back_ok(void)
command response ok.
Definition: app_led3_toggle/src/usart.c:101
iapfun
void(* iapfun)(void)
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:121
update_status_type
update_status_type
update status type
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:114
cmd_ctr_step_type
cmd_ctr_step_type
cmd ctr step type
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:102
cmd_data_step_type
cmd_data_step_type
cmd data step type
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:89
UPDATE_PRE
@ UPDATE_PRE
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:115
UPDATE_DONE
@ UPDATE_DONE
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:118
UPDATE_ING
@ UPDATE_ING
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:117
UPDATE_CLEAR_FLAG
@ UPDATE_CLEAR_FLAG
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:116
CMD_CTR_ERR
@ CMD_CTR_ERR
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:106
CMD_CTR_DONE
@ CMD_CTR_DONE
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:105
CMD_CTR_INIT
@ CMD_CTR_INIT
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:104
CMD_CTR_APP
@ CMD_CTR_APP
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:107
CMD_CTR_IDLE
@ CMD_CTR_IDLE
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:103
CMD_DATA_DONE
@ CMD_DATA_DONE
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:94
CMD_DATA_ERR
@ CMD_DATA_ERR
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:95
CMD_DATA_BUF
@ CMD_DATA_BUF
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:92
CMD_DATA_IDLE
@ CMD_DATA_IDLE
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:90
CMD_DATA_CHACK
@ CMD_DATA_CHACK
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:93
CMD_DATA_ADDR
@ CMD_DATA_ADDR
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:91
update_status
update_status_type update_status
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c:43
cmd_data_group_type_struct
cmd_data_group_type cmd_data_group_type_struct
cmd_data_step
cmd_data_step_type cmd_data_step
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c:40
cmd_ctr_step
cmd_ctr_step_type cmd_ctr_step
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c:41
cmd_data_group_type
cmd data group type
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:78
cmd_data_group_type::cmd_head
uint8_t cmd_head
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:79
cmd_data_group_type::cmd_check
uint8_t cmd_check
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:82


AT32F435/437 Firmwary Library: tmr.h File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • bootloader
  • inc
Functions | Variables
at32f435_437_usart_iap_demo/source_code/bootloader/inc/tmr.h File Reference

tmr header file More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void tmr_init (void)
init tmr. More...

Variables

uint8_t | time_ira_cnt
uint8_t | get_data_from_usart_flag

Detailed Description

tmr header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_usart_iap_demo/source_code/bootloader/inc/tmr.h.


AT32F435/437 Firmwary Library: tmr.h Source File

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • bootloader
  • inc
at32f435_437_usart_iap_demo/source_code/bootloader/inc/tmr.h
Go to the documentation of this file.
1
27#ifndef __TMR_H
28#define __TMR_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "at32f435_437_board.h"
35
36extern uint8_t time_ira_cnt;
37extern uint8_t get_data_from_usart_flag;
38
51void tmr_init(void);
52
65#ifdef __cplusplus
66}
67#endif
68
69#endif
at32f435_437_board.h
tmr_init
void tmr_init(void)
init tmr.
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/tmr.c:44
time_ira_cnt
uint8_t time_ira_cnt
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c:39
get_data_from_usart_flag
uint8_t get_data_from_usart_flag
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c:40


AT32F435/437 Firmwary Library: iap.c File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • bootloader
  • src
Functions | Variables
at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c File Reference

iap program More...

#include "iap.h"
#include "usart.h"
#include "flash.h"
#include "tmr.h"

Go to the source code of this file.

Functions

void | app_load (uint32_t app_addr)
app load. More...
uint8_t | data_take (void)
take data from usart buf. More...
void | command_handle (void)
command analysis handle. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...
void | app_update_handle (void)
app update flow handle. More...
void | iap_upgrade_app_handle (void)
iap upgrade app handle. More...

Variables

cmd_data_step_type cmd_data_step = CMD_DATA_IDLE
cmd_ctr_step_type cmd_ctr_step = CMD_CTR_IDLE
cmd_data_group_type cmd_data_group_struct
update_status_type update_status = UPDATE_PRE
static uint8_t | cmd_addr_cnt = 0
static uint32_t | cmd_data_cnt = 0
iapfun jump_to_app
jump to app More...

Detailed Description

iap program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c.


AT32F435/437 Firmwary Library: iap.c Source File

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • bootloader
  • src
at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
Go to the documentation of this file.
1
27#include "iap.h"
28#include "usart.h"
29#include "flash.h"
30#include "tmr.h"
31
40 cmd_data_step_type cmd_data_step = CMD_DATA_IDLE;
41 cmd_ctr_step_type cmd_ctr_step = CMD_CTR_IDLE;
42 cmd_data_group_type cmd_data_group_struct;
43 update_status_type update_status = UPDATE_PRE;
44static uint8_t cmd_addr_cnt = 0;
45static uint32_t cmd_data_cnt = 0;
46 iapfun jump_to_app;
47
48/* app_load don't optimize */
49#if defined (__CC_ARM)
50 #pragma O0
51#elif defined (__ICCARM__)
52 #pragma optimize=s none
53#endif
60void app_load(uint32_t app_addr)
61{
62 /* check the address of stack */
63 if(((*(uint32_t*)app_addr) - 0x20000000) < (SRAM_SIZE * 1024))
64 {
65 /* disable periph clock */
66 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, FALSE);
67 crm_periph_clock_enable(CRM_USART1_PERIPH_CLOCK, FALSE);
68 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, FALSE);
69
70 /* disable nvic irq and clear pending */
71 nvic_irq_disable(USART1_IRQn);
72 nvic_irq_disable(TMR3_GLOBAL_IRQn);
73 __NVIC_ClearPendingIRQ(USART1_IRQn);
74 __NVIC_ClearPendingIRQ(TMR3_GLOBAL_IRQn);
75
76 jump_to_app = (iapfun)*(uint32_t*)(app_addr + 4); /* code second word is reset address */
77 __set_MSP(*(uint32_t*)app_addr); /* init app stack pointer(code first word is stack address) */
78 jump_to_app(); /* jump to user app */
79 }
80}
81
89uint8_t data_take(void)
90{
91 uint8_t val;
92 usart_interrupt_enable(USART1, USART_RDBF_INT, FALSE);
93 usart_group_struct.count--;
94 usart_interrupt_enable(USART1, USART_RDBF_INT, TRUE);
95 val = usart_group_struct.buf[usart_group_struct.tail++];
96 if(usart_group_struct.tail > (USART_REC_LEN-1))
97 usart_group_struct.tail = 0;
98 return val;
99}
100
106void command_handle(void)
107{
108 uint8_t val, checksum;
109 uint16_t index;
110 /* check whether received usart data */
111 if(usart_group_struct.count > 0)
112 val = data_take();
113 else
114 return;
115
116 if(update_status == UPDATE_PRE)
117 {
118 if(cmd_ctr_step == CMD_CTR_IDLE)
119 {
120 if(val == 0x5A)
121 cmd_ctr_step = CMD_CTR_INIT;
122 }
123 else if(cmd_ctr_step == CMD_CTR_INIT)
124 {
125 if(val == 0x01)
126 {
127 cmd_ctr_step = CMD_CTR_DONE;
128 }
129 else if(val == 0xA5)
130 {
131 cmd_ctr_step = CMD_CTR_APP;
132 }
133 else
134 {
135 cmd_ctr_step = CMD_CTR_ERR;
136 }
137 }
138 }
139 else if(update_status == UPDATE_ING)
140 {
141 switch(cmd_data_step)
142 {
143 case CMD_DATA_IDLE:
144 if(val == 0x31)
145 {
146 cmd_data_step = CMD_DATA_ADDR;
147 cmd_addr_cnt = 0;
148 cmd_data_cnt = 0;
149 }
150 if(val == 0x5A)
151 {
152 if(cmd_ctr_step == CMD_CTR_IDLE)
153 {
154 cmd_ctr_step = CMD_CTR_INIT;
155 update_status = UPDATE_DONE;
156 }
157 }
158 break;
159 case CMD_DATA_ADDR:
160 cmd_data_group_struct.cmd_addr[cmd_addr_cnt] = val;
161 cmd_addr_cnt++;
162 if(cmd_addr_cnt >= 4)
163 {
164 cmd_addr_cnt = 0;
165 cmd_data_step = CMD_DATA_BUF;
166 }
167 break;
168 case CMD_DATA_BUF:
169 cmd_data_group_struct.cmd_buf[cmd_data_cnt] = val;
170 cmd_data_cnt++;
171 if(cmd_data_cnt >= 0x800)
172 {
173 cmd_data_cnt = 0;
174 cmd_data_step = CMD_DATA_CHACK;
175 }
176 break;
177 case CMD_DATA_CHACK:
178 checksum = 0;
179 for(index = 0;index < 4;index++)
180 {
181 checksum += cmd_data_group_struct.cmd_addr[index];
182 }
183 for(index = 0;index < 0x800; index++)
184 {
185 checksum += cmd_data_group_struct.cmd_buf[index];
186 }
187 if(checksum == val)
188 {
189 cmd_data_step = CMD_DATA_DONE;
190 }
191 else
192 {
193 cmd_data_step = CMD_DATA_ERR;
194 }
195 break;
196 default:
197 break;
198 }
199 }
200 else if(update_status == UPDATE_DONE)
201 {
202 if(cmd_ctr_step == CMD_CTR_IDLE)
203 {
204 if(val == 0x5A)
205 {
206 cmd_ctr_step = CMD_CTR_INIT;
207 }
208 }
209 else if(cmd_ctr_step == CMD_CTR_INIT)
210 {
211 if(val == 0x02)
212 {
213 cmd_ctr_step = CMD_CTR_DONE;
214 }
215 else
216 {
217 cmd_ctr_step = CMD_CTR_ERR;
218 }
219 }
220 }
221}
222
228void back_ok(void)
229{
230 usart_data_transmit(USART1, 0xCC);
231 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
232 usart_data_transmit(USART1, 0xDD);
233 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
234}
235
241void back_err(void)
242{
243 usart_data_transmit(USART1, 0xEE);
244 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
245 usart_data_transmit(USART1, 0xFF);
246 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
247 /* reset state machine of udgrade flow */
248 cmd_data_step = CMD_DATA_IDLE;
249 cmd_ctr_step = CMD_CTR_IDLE;
250 update_status = UPDATE_PRE;
251 cmd_addr_cnt = 0;
252 cmd_data_cnt = 0;
253 time_ira_cnt = 0;
254 get_data_from_usart_flag = 0;
255}
256
262void app_update_handle(void)
263{
264 uint32_t write_addr=0;
265 if(update_status == UPDATE_PRE)
266 {
267 if(cmd_ctr_step == CMD_CTR_DONE)
268 {
269 cmd_ctr_step = CMD_CTR_IDLE;
270 update_status = UPDATE_CLEAR_FLAG;
271 }
272 else if(cmd_ctr_step == CMD_CTR_APP)
273 {
274 cmd_ctr_step = CMD_CTR_IDLE;
275 back_ok();
276 }
277 else if(cmd_ctr_step == CMD_CTR_ERR)
278 {
279 cmd_ctr_step = CMD_CTR_IDLE;
280 back_err();
281 }
282 }
283 else if(update_status == UPDATE_CLEAR_FLAG)
284 {
285 get_data_from_usart_flag = 1;
286 update_status = UPDATE_ING;
287 back_ok();
288 }
289 else if(update_status == UPDATE_ING)
290 {
291 if(cmd_data_step == CMD_DATA_DONE)
292 {
293 write_addr = (cmd_data_group_struct.cmd_addr[0] << 24) + (cmd_data_group_struct.cmd_addr[1] << 16) + \
294 (cmd_data_group_struct.cmd_addr[2] << 8) + cmd_data_group_struct.cmd_addr[3];
295 if((write_addr >= APP_START_ADDR) && (write_addr < FLASH_BASE + 1024 * FLASH_SIZE))
296 {
297 flash_2kb_write(write_addr, cmd_data_group_struct.cmd_buf);
298 cmd_data_step = CMD_DATA_IDLE;
299 back_ok();
300 }
301 else
302 {
303 cmd_data_step = CMD_DATA_IDLE;
304 back_err();
305 }
306 }
307 else if(cmd_data_step == CMD_DATA_ERR)
308 {
309 cmd_data_step = CMD_DATA_IDLE;
310 back_err();
311 }
312 }
313 else if(update_status == UPDATE_DONE)
314 {
315 if(cmd_ctr_step == CMD_CTR_DONE)
316 {
317 cmd_ctr_step = CMD_CTR_IDLE;
318 back_ok();
319 /* check app starting address whether 0x08xxxxxx */
320 if(((*(uint32_t*)(APP_START_ADDR + 4)) & 0xFF000000) == 0x08000000)
321 {
322 crm_reset();
323 /* jump and run in app */
324 app_load(APP_START_ADDR);
325 }
326 else
327 {
328 cmd_ctr_step = CMD_CTR_ERR;
329 }
330 }
331 else if(cmd_ctr_step == CMD_CTR_ERR)
332 {
333 cmd_ctr_step = CMD_CTR_IDLE;
334 back_err();
335 }
336 }
337}
338
344void iap_upgrade_app_handle(void)
345{
346 command_handle();
347 app_update_handle();
348}
349
jump_to_app
iapfun jump_to_app
jump to app
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c:46
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:129
CRM_USART1_PERIPH_CLOCK
@ CRM_USART1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:156
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
APP_START_ADDR
#define APP_START_ADDR
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h:49
nvic_irq_disable
void nvic_irq_disable(IRQn_Type irqn)
disable nvic irq number
Definition: at32f435_437_misc.c:81
FLASH_BASE
#define FLASH_BASE
Definition: at32f435_437.h:425
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f435_437_usart.c:413
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f435_437_usart.c:598
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f435_437_usart.c:287
USART_TDC_FLAG
#define USART_TDC_FLAG
Definition: at32f435_437_usart.h:58
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f435_437_usart.h:73
USART1
#define USART1
Definition: at32f435_437_usart.h:348
SRAM_SIZE
#define SRAM_SIZE
Definition: utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/flash.h:50
FLASH_SIZE
#define FLASH_SIZE
Definition: utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/flash.h:49
USART_REC_LEN
#define USART_REC_LEN
Definition: bootloader/inc/usart.h:48
flash_2kb_write
void flash_2kb_write(uint32_t write_addr, uint8_t *pbuffer)
flash erase/program operation.
Definition: utilities/at32f435_437_usart_iap_demo/source_code/bootloader/src/flash.c:45
iapfun
void(* iapfun)(void)
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:121
update_status_type
update_status_type
update status type
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:114
cmd_ctr_step_type
cmd_ctr_step_type
cmd ctr step type
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:102
cmd_data_step_type
cmd_data_step_type
cmd data step type
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:89
UPDATE_PRE
@ UPDATE_PRE
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:115
UPDATE_DONE
@ UPDATE_DONE
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:118
UPDATE_ING
@ UPDATE_ING
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:117
UPDATE_CLEAR_FLAG
@ UPDATE_CLEAR_FLAG
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:116
CMD_CTR_ERR
@ CMD_CTR_ERR
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:106
CMD_CTR_DONE
@ CMD_CTR_DONE
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:105
CMD_CTR_INIT
@ CMD_CTR_INIT
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:104
CMD_CTR_APP
@ CMD_CTR_APP
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:107
CMD_CTR_IDLE
@ CMD_CTR_IDLE
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:103
CMD_DATA_DONE
@ CMD_DATA_DONE
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:94
CMD_DATA_ERR
@ CMD_DATA_ERR
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:95
CMD_DATA_BUF
@ CMD_DATA_BUF
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:92
CMD_DATA_IDLE
@ CMD_DATA_IDLE
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:90
CMD_DATA_CHACK
@ CMD_DATA_CHACK
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:93
CMD_DATA_ADDR
@ CMD_DATA_ADDR
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:91
cmd_addr_cnt
static uint8_t cmd_addr_cnt
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c:44
app_update_handle
void app_update_handle(void)
app update flow handle.
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c:262
data_take
uint8_t data_take(void)
take data from usart buf.
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c:89
command_handle
void command_handle(void)
command analysis handle.
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c:106
update_status
update_status_type update_status
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c:43
iap_upgrade_app_handle
void iap_upgrade_app_handle(void)
iap upgrade app handle.
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c:344
cmd_data_group_struct
cmd_data_group_type cmd_data_group_struct
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c:42
time_ira_cnt
uint8_t time_ira_cnt
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c:39
cmd_data_cnt
static uint32_t cmd_data_cnt
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c:45
get_data_from_usart_flag
uint8_t get_data_from_usart_flag
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c:40
cmd_data_step
cmd_data_step_type cmd_data_step
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c:40
app_load
void app_load(uint32_t app_addr)
app load.
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c:60
cmd_ctr_step
cmd_ctr_step_type cmd_ctr_step
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c:41
back_err
void back_err(void)
command response error.
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c:241
usart_group_struct
usart_group_type usart_group_struct
Definition: bootloader/src/usart.c:38
back_ok
void back_ok(void)
command response ok.
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c:228
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f435_437.h:177
USART1_IRQn
@ USART1_IRQn
Definition: at32f435_437.h:185
cmd_data_group_type
cmd data group type
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:78
cmd_data_group_type::cmd_addr
uint8_t cmd_addr[4]
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:80
cmd_data_group_type::cmd_buf
uint8_t cmd_buf[0x800]
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:81
usart_group_type::tail
uint16_t tail
Definition: bootloader/inc/usart.h:65
usart_group_type::buf
uint16_t buf[1024]
Definition: bootloader/inc/usart.h:63
usart_group_type::count
uint16_t count
Definition: bootloader/inc/usart.h:66


AT32F435/437 Firmwary Library: tmr.c File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • bootloader
  • src
Functions | Variables
at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c File Reference

tmr program More...

#include "at32f435_437_board.h"
#include "tmr.h"
#include "iap.h"

Go to the source code of this file.

Functions

void | tmr_init (void)
init tmr. More...
void | TMR3_GLOBAL_IRQHandler (void)
tmr3 global interrupt handler. More...

Variables

uint8_t | time_ira_cnt =0
uint8_t | get_data_from_usart_flag = 0

Detailed Description

tmr program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c.


AT32F435/437 Firmwary Library: tmr.c Source File

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • bootloader
  • src
at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "tmr.h"
29#include "iap.h"
30
39uint8_t time_ira_cnt=0;
40uint8_t get_data_from_usart_flag = 0; /* flag for timer out in upgrade flow */
41
47void tmr_init(void)
48{
49 crm_clocks_freq_type crm_clocks_freq_struct = {0};
50
51 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
52
53 /* enable the tmr3 global interrupt */
54 nvic_irq_enable(TMR3_GLOBAL_IRQn, 1, 0);
55
56 /* get system clock */
57 crm_clocks_freq_get(&crm_clocks_freq_struct);
58
59 /* time base configuration */
60 tmr_base_init(TMR3, 10000, crm_clocks_freq_struct.ahb_freq / 10000);
61 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
62
63 /* overflow interrupt enable */
64 tmr_interrupt_enable(TMR3, TMR_OVF_INT, TRUE);
65
66 /* enable tmr */
67 tmr_counter_enable(TMR3, TRUE);
68}
69
75void TMR3_GLOBAL_IRQHandler(void)
76{
77 if(tmr_flag_get(TMR3, TMR_OVF_FLAG) == SET)
78 {
79 tmr_flag_clear(TMR3, TMR_OVF_FLAG);
80 at32_led_toggle(LED2);
81 if(get_data_from_usart_flag)
82 {
83 if((++time_ira_cnt) == 0x00)
84 time_ira_cnt = 0xFF;
85 if(time_ira_cnt > 2)
86 back_err();
87 if(time_ira_cnt > 5)
88 crm_periph_clock_enable(LED2_GPIO_CRM_CLK, FALSE);
89 }
90 }
91}
92
at32f435_437_board.h
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:40
LED2
@ LED2
Definition: at32f435_437_board.h:65
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:129
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
back_err
void back_err(void)
command response error.
Definition: app_led3_toggle/src/usart.c:114
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f435_437_tmr.c:1463
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f435_437_tmr.c:1424
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f435_437_tmr.c:1389
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_OVF_FLAG
#define TMR_OVF_FLAG
Definition: at32f435_437_tmr.h:52
TMR_OVF_INT
#define TMR_OVF_INT
Definition: at32f435_437_tmr.h:75
TMR3
#define TMR3
Definition: at32f435_437_tmr.h:897
time_ira_cnt
uint8_t time_ira_cnt
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c:39
TMR3_GLOBAL_IRQHandler
void TMR3_GLOBAL_IRQHandler(void)
tmr3 global interrupt handler.
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c:75
tmr_init
void tmr_init(void)
init tmr.
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c:47
get_data_from_usart_flag
uint8_t get_data_from_usart_flag
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c:40
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f435_437.h:177
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::ahb_freq
uint32_t ahb_freq
Definition: at32f435_437_crm.h:790


AT32F435/437 Firmwary Library: at32f435_437_usb.c Source File

  • libraries
  • drivers
  • src
at32f435_437_usb.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef USB_MODULE_ENABLED
39
44#ifdef OTGFS_USB_GLOBAL
53 error_status usb_global_reset(otg_global_type *usbx)
54{
55 uint32_t timeout = 0;
56 while(usbx->grstctl_bit.ahbidle == RESET)
57 {
58 if(timeout ++ > 200000)
59 {
60 break;
61 }
62 }
63 timeout = 0;
64 usbx->grstctl_bit.csftrst = TRUE;
65 while(usbx->grstctl_bit.csftrst == SET)
66 {
67 if(timeout ++ > 200000)
68 {
69 break;
70 }
71 }
72 return SUCCESS;
73}
74
83void usb_global_init(otg_global_type *usbx)
84{
85 /* reset otg moudle */
86 usb_global_reset(usbx);
87
88 /* exit power down mode */
89 usbx->gccfg_bit.pwrdown = TRUE;
90}
91
100 otg_global_type *usb_global_select_core(uint8_t usb_id)
101{
102 if(usb_id == USB_OTG1_ID)
103 {
104 /* use otg1 */
105 return OTG1_GLOBAL;
106 }
107 else
108 {
109 /* use otg2 */
110 return OTG2_GLOBAL;
111 }
112}
113
124void usb_flush_tx_fifo(otg_global_type *usbx, uint32_t fifo_num)
125{
126 uint32_t timeout = 0;
127 /* set flush fifo number */
128 usbx->grstctl_bit.txfnum = fifo_num;
129
130 /* start flush fifo */
131 usbx->grstctl_bit.txfflsh = TRUE;
132
133 while(usbx->grstctl_bit.txfflsh == TRUE)
134 {
135 if(timeout ++ > 200000)
136 {
137 break;
138 }
139 }
140}
141
150void usb_flush_rx_fifo(otg_global_type *usbx)
151{
152 uint32_t timeout = 0;
153 usbx->grstctl_bit.rxfflsh = TRUE;
154 while(usbx->grstctl_bit.rxfflsh == TRUE)
155 {
156 if(timeout ++ > 200000)
157 {
158 break;
159 }
160 }
161}
162
196void usb_global_interrupt_enable(otg_global_type *usbx, uint16_t interrupt, confirm_state new_state)
197{
198 if(new_state == TRUE)
199 {
200 usbx->gintmsk |= interrupt;
201 }
202 else
203 {
204 usbx->gintmsk &= ~interrupt;
205 }
206}
207
216uint32_t usb_global_get_all_interrupt(otg_global_type *usbx)
217{
218 uint32_t intsts = usbx->gintsts;
219 return intsts & usbx->gintmsk;
220}
221
255void usb_global_clear_interrupt(otg_global_type *usbx, uint32_t flag)
256{
257 usbx->gintsts = flag;
258}
259
267void usb_interrupt_enable(otg_global_type *usbx)
268{
269 usbx->gahbcfg_bit.glbintmsk = TRUE;
270}
271
280void usb_interrupt_disable(otg_global_type *usbx)
281{
282 usbx->gahbcfg_bit.glbintmsk = FALSE;
283}
284
294void usb_set_rx_fifo(otg_global_type *usbx, uint16_t size)
295{
296 usbx->grxfsiz = size;
297}
298
309void usb_set_tx_fifo(otg_global_type *usbx, uint8_t txfifo, uint16_t size)
310{
311 uint8_t i_index = 0;
312 uint32_t offset = 0;
313
314 offset = usbx->grxfsiz;
315 if(txfifo == 0)
316 {
317 usbx->gnptxfsiz_ept0tx = offset | (size << 16);
318 }
319 else
320 {
321 offset += usbx->gnptxfsiz_ept0tx_bit.nptxfdep;
322 for(i_index = 0; i_index < (txfifo - 1); i_index ++)
323 {
324 offset += usbx->dieptxfn_bit[i_index].ineptxfdep;
325 }
326 usbx->dieptxfn[txfifo - 1] = offset | (size << 16);
327 }
328}
329
330
344void usb_global_set_mode(otg_global_type *usbx, uint32_t mode)
345{
346 /* set otg to device mode */
347 if(mode == OTG_DEVICE_MODE)
348 {
349 usbx->gusbcfg_bit.fhstmode = FALSE;
350 usbx->gusbcfg_bit.fdevmode = TRUE;
351 }
352
353 /* set otg to host mode */
354 if(mode == OTG_HOST_MODE)
355 {
356 usbx->gusbcfg_bit.fdevmode = FALSE;
357 usbx->gusbcfg_bit.fhstmode = TRUE;
358 }
359
360 /* set otg to default mode */
361 if(mode == OTG_DRD_MODE)
362 {
363 usbx->gusbcfg_bit.fdevmode = FALSE;
364 usbx->gusbcfg_bit.fhstmode = FALSE;
365 }
366}
367
368
377void usb_global_power_on(otg_global_type *usbx)
378{
379 /* core soft reset */
380 usbx->grstctl_bit.csftrst = TRUE;
381 while(usbx->grstctl_bit.csftrst);
382
383 /* disable power down mode */
384 usbx->gccfg_bit.pwrdown = TRUE;
385
386}
387
396void usb_stop_phy_clk(otg_global_type *usbx)
397{
398 OTG_PCGCCTL(usbx)->pcgcctl_bit.stoppclk = TRUE;
399}
400
409void usb_open_phy_clk(otg_global_type *usbx)
410{
411 OTG_PCGCCTL(usbx)->pcgcctl_bit.stoppclk = FALSE;
412}
413
414
422void usb_write_packet(otg_global_type *usbx, uint8_t *pusr_buf, uint16_t num, uint16_t nbytes)
423{
424 uint32_t n_index;
425 uint32_t nhbytes = (nbytes + 3) / 4;
426 uint32_t *pbuf = (uint32_t *)pusr_buf;
427 for(n_index = 0; n_index < nhbytes; n_index ++)
428 {
429#if defined (__ICCARM__) && (__VER__ < 7000000)
430 USB_FIFO(usbx, num) = *(__packed uint32_t *)pbuf;
431#else
432 USB_FIFO(usbx, num) = __UNALIGNED_UINT32_READ(pbuf);
433#endif
434 pbuf ++;
435 }
436}
437
445void usb_read_packet(otg_global_type *usbx, uint8_t *pusr_buf, uint16_t num, uint16_t nbytes)
446{
447 uint32_t n_index;
448 uint32_t nhbytes = (nbytes + 3) / 4;
449 uint32_t *pbuf = (uint32_t *)pusr_buf;
450 for(n_index = 0; n_index < nhbytes; n_index ++)
451 {
452#if defined (__ICCARM__) && (__VER__ < 7000000)
453 *(__packed uint32_t *)pbuf = USB_FIFO(usbx, 0);
454#else
455 __UNALIGNED_UINT32_WRITE(pbuf, (USB_FIFO(usbx, 0)));
456#endif
457 pbuf ++;
458 }
459}
460#endif
461
462
463#ifdef OTGFS_USB_DEVICE
473void usb_ept_open(otg_global_type *usbx, usb_ept_info *ept_info)
474{
475 uint8_t mps = USB_EPT0_MPS_64;
476 if(ept_info->eptn == USB_EPT0)
477 {
478 if(ept_info->maxpacket == 0x40)
479 {
480 mps = USB_EPT0_MPS_64;
481 }
482 else if(ept_info->maxpacket == 0x20)
483 {
484 mps = USB_EPT0_MPS_32;
485 }
486 else if(ept_info->maxpacket == 0x10)
487 {
488 mps = USB_EPT0_MPS_16;
489 }
490 else if(ept_info->maxpacket == 0x08)
491 {
492 mps = USB_EPT0_MPS_8;
493 }
494 }
495 /* endpoint direction is in */
496 if(ept_info->inout == EPT_DIR_IN)
497 {
498 OTG_DEVICE(usbx)->daintmsk |= 1 << ept_info->eptn;
499 if(ept_info->eptn == USB_EPT0)
500 {
501 USB_INEPT(usbx, ept_info->eptn)->diepctl_bit.mps = mps;
502 }
503 else
504 {
505 USB_INEPT(usbx, ept_info->eptn)->diepctl_bit.mps = ept_info->maxpacket;
506 }
507 USB_INEPT(usbx, ept_info->eptn)->diepctl_bit.eptype = ept_info->trans_type;
508 USB_INEPT(usbx, ept_info->eptn)->diepctl_bit.txfnum = ept_info->eptn;
509 USB_INEPT(usbx, ept_info->eptn)->diepctl_bit.setd0pid = TRUE;
510 USB_INEPT(usbx, ept_info->eptn)->diepctl_bit.usbacept = TRUE;
511 }
512 /* endpoint direction is out */
513 else
514 {
515 OTG_DEVICE(usbx)->daintmsk |= (1 << ept_info->eptn) << 16;
516 if(ept_info->eptn == USB_EPT0)
517 {
518 USB_OUTEPT(usbx, ept_info->eptn)->doepctl_bit.mps = mps;
519 }
520 else
521 {
522 USB_OUTEPT(usbx, ept_info->eptn)->doepctl_bit.mps = ept_info->maxpacket;
523 }
524 USB_OUTEPT(usbx, ept_info->eptn)->doepctl_bit.eptype = ept_info->trans_type;
525 USB_OUTEPT(usbx, ept_info->eptn)->doepctl_bit.setd0pid = TRUE;
526 USB_OUTEPT(usbx, ept_info->eptn)->doepctl_bit.usbacept = TRUE;
527 }
528}
529
539void usb_ept_close(otg_global_type *usbx, usb_ept_info *ept_info)
540{
541 if(ept_info->inout == EPT_DIR_IN)
542 {
543 OTG_DEVICE(usbx)->daintmsk &= ~(1 << ept_info->eptn);
544 USB_INEPT(usbx, ept_info->eptn)->diepctl_bit.usbacept = FALSE;
545 }
546 else
547 {
548 OTG_DEVICE(usbx)->daintmsk &= ~((1 << ept_info->eptn) << 16);
549 USB_OUTEPT(usbx, ept_info->eptn)->doepctl_bit.usbacept = FALSE;
550 }
551}
552
553
563void usb_ept_stall(otg_global_type *usbx, usb_ept_info *ept_info)
564{
565 if(ept_info->inout == EPT_DIR_IN)
566 {
567 if(USB_INEPT(usbx, ept_info->eptn)->diepctl_bit.eptena == RESET)
568 {
569 USB_INEPT(usbx, ept_info->eptn)->diepctl_bit.eptdis = FALSE;
570 }
571 USB_INEPT(usbx, ept_info->eptn)->diepctl_bit.stall = SET;
572 }
573 else
574 {
575 if(USB_OUTEPT(usbx, ept_info->eptn)->doepctl_bit.eptena == RESET)
576 {
577 USB_OUTEPT(usbx, ept_info->eptn)->doepctl_bit.eptdis = FALSE;
578 }
579 USB_OUTEPT(usbx, ept_info->eptn)->doepctl_bit.stall = TRUE;
580 }
581}
582
592void usb_ept_clear_stall(otg_global_type *usbx, usb_ept_info *ept_info)
593{
594 if(ept_info->inout == EPT_DIR_IN)
595 {
596 USB_INEPT(usbx, ept_info->eptn)->diepctl_bit.stall = FALSE;
597 if(ept_info->trans_type == EPT_INT_TYPE || ept_info->trans_type == EPT_BULK_TYPE)
598 {
599 USB_INEPT(usbx, ept_info->eptn)->diepctl_bit.setd0pid = TRUE;
600 }
601 }
602 else
603 {
604 USB_OUTEPT(usbx, ept_info->eptn)->doepctl_bit.stall = FALSE;
605 if(ept_info->trans_type == EPT_INT_TYPE || ept_info->trans_type == EPT_BULK_TYPE)
606 {
607 USB_OUTEPT(usbx, ept_info->eptn)->doepctl_bit.setd0pid = TRUE;
608 }
609 }
610}
611
620uint32_t usb_get_all_out_interrupt(otg_global_type *usbx)
621{
622 uint32_t intsts = OTG_DEVICE(usbx)->daint;
623 return ((intsts & (OTG_DEVICE(usbx)->daintmsk)) >> 16);
624}
625
634uint32_t usb_get_all_in_interrupt(otg_global_type *usbx)
635{
636 uint32_t intsts = OTG_DEVICE(usbx)->daint;
637 return ((intsts & (OTG_DEVICE(usbx)->daintmsk)) & 0xFFFF);
638}
639
640
650uint32_t usb_ept_out_interrupt(otg_global_type *usbx, uint32_t eptn)
651{
652 uint32_t intsts = USB_OUTEPT(usbx, eptn)->doepint;
653 return (intsts & (OTG_DEVICE(usbx)->doepmsk));
654}
655
665uint32_t usb_ept_in_interrupt(otg_global_type *usbx, uint32_t eptn)
666{
667 uint32_t intsts, mask1, mask2;
668 mask1 = OTG_DEVICE(usbx)->diepmsk;
669 mask2 = OTG_DEVICE(usbx)->diepempmsk;
670 mask1 |= ((mask2 >> eptn) & 0x1) << 7;
671 intsts = USB_INEPT(usbx, eptn)->diepint & mask1;
672 return intsts;
673}
674
690void usb_ept_out_clear(otg_global_type *usbx, uint32_t eptn, uint32_t flag)
691{
692 USB_OUTEPT(usbx, eptn)->doepint = flag;
693}
694
711void usb_ept_in_clear(otg_global_type *usbx, uint32_t eptn, uint32_t flag)
712{
713 USB_INEPT(usbx, eptn)->diepint = flag;
714}
715
716
726void usb_set_address(otg_global_type *usbx, uint8_t address)
727{
728 OTG_DEVICE(usbx)->dcfg_bit.devaddr = address;
729}
730
739void usb_ept0_start(otg_global_type *usbx)
740{
741 otg_eptout_type *usb_outept = USB_OUTEPT(usbx, 0);
742 usb_outept->doeptsiz = 0;
743 usb_outept->doeptsiz_bit.pktcnt = 1;
744 usb_outept->doeptsiz_bit.xfersize = 24;
745 usb_outept->doeptsiz_bit.rxdpid_setupcnt = 3;
746}
747
748
757void usb_ept0_setup(otg_global_type *usbx)
758{
759 USB_INEPT(usbx, 0)->diepctl_bit.mps = 0;
760 OTG_DEVICE(usbx)->dctl_bit.cgnpinak = FALSE;
761}
762
771void usb_connect(otg_global_type *usbx)
772{
773 /* D+ 1.5k pull-up enable */
774 OTG_DEVICE(usbx)->dctl_bit.sftdiscon = FALSE;
775}
776
785void usb_disconnect(otg_global_type *usbx)
786{
787 /* D+ 1.5k pull-up disable */
788 OTG_DEVICE(usbx)->dctl_bit.sftdiscon = TRUE;
789}
790
791
800void usb_remote_wkup_set(otg_global_type *usbx)
801{
802 OTG_DEVICE(usbx)->dctl_bit.rwkupsig = TRUE;
803}
804
813void usb_remote_wkup_clear(otg_global_type *usbx)
814{
815 OTG_DEVICE(usbx)->dctl_bit.rwkupsig = FALSE;
816}
817
826uint8_t usb_suspend_status_get(otg_global_type *usbx)
827{
828 return OTG_DEVICE(usbx)->dsts_bit.suspsts;
829}
830#endif
831
832#ifdef OTGFS_USB_HOST
842void usb_port_power_on(otg_global_type *usbx, confirm_state state)
843{
844 otg_host_type *usb_host = OTG_HOST(usbx);
845 uint32_t hprt_val = usb_host->hprt;
846
847 hprt_val &= ~(USB_OTG_HPRT_PRTENA | USB_OTG_HPRT_PRTENCHNG |
848 USB_OTG_HPRT_PRTOVRCACT | USB_OTG_HPRT_PRTCONDET);
849
850 if(state == TRUE)
851 {
852 usb_host->hprt = hprt_val | USB_OTG_HPRT_PRTPWR;
853 }
854 else
855 {
856 usb_host->hprt = hprt_val & (~USB_OTG_HPRT_PRTPWR);
857 }
858}
859
868uint32_t usbh_get_frame(otg_global_type *usbx)
869{
870 otg_host_type *usb_host = OTG_HOST(usbx);
871 return usb_host->hfnum & 0xFFFF;
872}
873
896void usb_hc_enable(otg_global_type *usbx,
897 uint8_t chn,
898 uint8_t ept_num,
899 uint8_t dev_address,
900 uint8_t type,
901 uint16_t maxpacket,
902 uint8_t speed)
903{
904 otg_hchannel_type *hch = USB_CHL(usbx, chn);
905 otg_host_type *usb_host = OTG_HOST(usbx);
906
907 switch(type)
908 {
909 case EPT_CONTROL_TYPE:
910 case EPT_BULK_TYPE:
911 hch->hcintmsk |= USB_OTG_HC_XFERCM_INT | USB_OTG_HC_STALLM_INT |
912 USB_OTG_HC_XACTERRM_INT | USB_OTG_HC_NAKM_INT |
913 USB_OTG_HC_DTGLERRM_INT;
914 if(ept_num & 0x80)
915 {
916 hch->hcintmsk_bit.bblerrmsk = TRUE;
917 }
918 break;
919 case EPT_INT_TYPE:
920 hch->hcintmsk |= USB_OTG_HC_XFERCM_INT | USB_OTG_HC_STALLM_INT |
921 USB_OTG_HC_XACTERRM_INT | USB_OTG_HC_NAKM_INT |
922 USB_OTG_HC_DTGLERRM_INT | USB_OTG_HC_FRMOVRRUN_INT;
923 break;
924 case EPT_ISO_TYPE:
925
926 hch->hcintmsk |= USB_OTG_HC_XFERCM_INT | USB_OTG_HC_ACKM_INT |
927 USB_OTG_HC_FRMOVRRUN_INT;
928 break;
929 }
930 usb_host->haintmsk |= 1 << chn;
931 usbx->gintmsk_bit.hchintmsk = TRUE;
932
933 hch->hcchar_bit.devaddr = dev_address;
934 hch->hcchar_bit.eptnum = ept_num & 0x7F;
935 hch->hcchar_bit.eptdir = (ept_num & 0x80)?1:0;
936 hch->hcchar_bit.lspddev = (speed == USB_PRTSPD_LOW_SPEED)?1:0;
937 hch->hcchar_bit.eptype = type;
938 hch->hcchar_bit.mps = maxpacket;
939
940 if(type == EPT_INT_TYPE)
941 {
942 hch->hcchar_bit.oddfrm = TRUE;
943 }
944}
945
954uint32_t usb_hch_read_interrupt(otg_global_type *usbx)
955{
956 otg_host_type *usb_host = OTG_HOST(usbx);
957 return usb_host->haint & 0xFFFF;
958}
959
968void usb_host_disable(otg_global_type *usbx)
969{
970 uint32_t i_index = 0, count = 0;
971 otg_hchannel_type *hch;
972 otg_host_type *usb_host = OTG_HOST(usbx);
973
974 usbx->gahbcfg_bit.glbintmsk = FALSE;
975 usb_flush_rx_fifo(usbx);
976 usb_flush_tx_fifo(usbx, 0x10);
977
978 for(i_index = 0; i_index < 16; i_index ++)
979 {
980 hch = USB_CHL(usbx, i_index);
981 hch->hcchar_bit.chdis = TRUE;
982 hch->hcchar_bit.chena = FALSE;
983 hch->hcchar_bit.eptdir = 0;
984 }
985
986 for(i_index = 0; i_index < 16; i_index ++)
987 {
988 hch = USB_CHL(usbx, i_index);
989 hch->hcchar_bit.chdis = TRUE;
990 hch->hcchar_bit.chena = TRUE;
991 hch->hcchar_bit.eptdir = 0;
992 do
993 {
994 if(count ++ > 1000)
995 break;
996 }while(hch->hcchar_bit.chena);
997 }
998 usb_host->haint = 0xFFFFFFFF;
999 usbx->gintsts = 0xFFFFFFFF;
1000 usbx->gahbcfg_bit.glbintmsk = TRUE;
1001}
1002
1012void usb_hch_halt(otg_global_type *usbx, uint8_t chn)
1013{
1014 uint32_t count = 0;
1015 otg_hchannel_type *usb_chh = USB_CHL(usbx, chn);
1016 otg_host_type *usb_host = OTG_HOST(usbx);
1017
1018 /* endpoint type is control or bulk */
1019 if(usb_chh->hcchar_bit.eptype == EPT_CONTROL_TYPE ||
1020 usb_chh->hcchar_bit.eptype == EPT_BULK_TYPE)
1021 {
1022 usb_chh->hcchar_bit.chdis = TRUE;
1023 if((usbx->gnptxsts & 0xFFFF) == 0)
1024 {
1025 usb_chh->hcchar_bit.chena = FALSE;
1026 usb_chh->hcchar_bit.chena = TRUE;
1027 usb_chh->hcchar_bit.eptdir = 0;
1028 do
1029 {
1030 if(count ++ > 1000)
1031 break;
1032 }while(usb_chh->hcchar_bit.chena == SET);
1033 }
1034 else
1035 {
1036 usb_chh->hcchar_bit.chena = TRUE;
1037 }
1038 }
1039 else
1040 {
1041 usb_chh->hcchar_bit.chdis = TRUE;
1042 if((usb_host->hptxsts & 0xFFFF) == 0)
1043 {
1044 usb_chh->hcchar_bit.chena = FALSE;
1045 usb_chh->hcchar_bit.chena = TRUE;
1046 usb_chh->hcchar_bit.eptdir = 0;
1047 do
1048 {
1049 if(count ++ > 1000)
1050 break;
1051 }while(usb_chh->hcchar_bit.chena == SET);
1052 }
1053 else
1054 {
1055 usb_chh->hcchar_bit.chena = TRUE;
1056 }
1057 }
1058}
1068void usbh_fsls_clksel(otg_global_type *usbx, uint8_t clk)
1069{
1070 otg_host_type *usb_host = OTG_HOST(usbx);
1071
1072 usb_host->hcfg_bit.fslspclksel = clk;
1073 if(clk == USB_HCFG_CLK_6M)
1074 {
1075 usb_host->hfir = 6000;
1076 }
1077 else
1078 {
1079 usb_host->hfir = 48000;
1080 }
1081}
1082#endif
1083
1084
1089#endif
1090
error_status
error_status
Definition: at32f435_437.h:380
confirm_state
confirm_state
Definition: at32f435_437.h:379
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
USB_EPT0_MPS_16
#define USB_EPT0_MPS_16
Definition: at32f435_437_usb.h:306
USB_EPT0_MPS_64
#define USB_EPT0_MPS_64
endpoint0 maximum packet size
Definition: at32f435_437_usb.h:304
USB_EPT0_MPS_8
#define USB_EPT0_MPS_8
Definition: at32f435_437_usb.h:307
USB_EPT0_MPS_32
#define USB_EPT0_MPS_32
Definition: at32f435_437_usb.h:305
EPT_ISO_TYPE
@ EPT_ISO_TYPE
Definition: at32f435_437_usb.h:347
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f435_437_usb.h:349
EPT_CONTROL_TYPE
@ EPT_CONTROL_TYPE
Definition: at32f435_437_usb.h:346
EPT_BULK_TYPE
@ EPT_BULK_TYPE
Definition: at32f435_437_usb.h:348
USB_EPT0
@ USB_EPT0
Definition: at32f435_437_usb.h:357
OTG_HOST_MODE
@ OTG_HOST_MODE
Definition: at32f435_437_usb.h:337
OTG_DRD_MODE
@ OTG_DRD_MODE
Definition: at32f435_437_usb.h:338
OTG_DEVICE_MODE
@ OTG_DEVICE_MODE
Definition: at32f435_437_usb.h:336
EPT_DIR_IN
@ EPT_DIR_IN
Definition: at32f435_437_usb.h:385
USB_OTG1_ID
@ USB_OTG1_ID
Definition: at32f435_437_usb.h:394
OTG_HOST
#define OTG_HOST(usbx)
Definition: at32f435_437_usb.h:1332
USB_FIFO
#define USB_FIFO(usbx, eptn)
Definition: at32f435_437_usb.h:1336
USB_CHL
#define USB_CHL(usbx, n)
Definition: at32f435_437_usb.h:1333
OTG_PCGCCTL
#define OTG_PCGCCTL(usbx)
Definition: at32f435_437_usb.h:1330
OTG_DEVICE
#define OTG_DEVICE(usbx)
Definition: at32f435_437_usb.h:1331
OTG2_GLOBAL
#define OTG2_GLOBAL
Definition: at32f435_437_usb.h:1329
USB_OUTEPT
#define USB_OUTEPT(usbx, eptn)
Definition: at32f435_437_usb.h:1335
OTG1_GLOBAL
#define OTG1_GLOBAL
usb host and device register define
Definition: at32f435_437_usb.h:1328
USB_INEPT
#define USB_INEPT(usbx, eptn)
Definition: at32f435_437_usb.h:1334
USB_OTG_HC_STALLM_INT
#define USB_OTG_HC_STALLM_INT
Definition: at32f435_437_usb.h:216
USB_OTG_HC_FRMOVRRUN_INT
#define USB_OTG_HC_FRMOVRRUN_INT
Definition: at32f435_437_usb.h:222
USB_OTG_HPRT_PRTENA
#define USB_OTG_HPRT_PRTENA
Definition: at32f435_437_usb.h:172
USB_OTG_HC_DTGLERRM_INT
#define USB_OTG_HC_DTGLERRM_INT
Definition: at32f435_437_usb.h:223
USB_OTG_HC_ACKM_INT
#define USB_OTG_HC_ACKM_INT
Definition: at32f435_437_usb.h:218
USB_OTG_HPRT_PRTPWR
#define USB_OTG_HPRT_PRTPWR
Definition: at32f435_437_usb.h:180
USB_OTG_HC_NAKM_INT
#define USB_OTG_HC_NAKM_INT
Definition: at32f435_437_usb.h:217
USB_HCFG_CLK_6M
#define USB_HCFG_CLK_6M
Definition: at32f435_437_usb.h:165
USB_PRTSPD_LOW_SPEED
#define USB_PRTSPD_LOW_SPEED
Definition: at32f435_437_usb.h:188
USB_OTG_HPRT_PRTOVRCACT
#define USB_OTG_HPRT_PRTOVRCACT
Definition: at32f435_437_usb.h:174
USB_OTG_HC_XACTERRM_INT
#define USB_OTG_HC_XACTERRM_INT
Definition: at32f435_437_usb.h:220
USB_OTG_HPRT_PRTENCHNG
#define USB_OTG_HPRT_PRTENCHNG
Definition: at32f435_437_usb.h:173
USB_OTG_HC_XFERCM_INT
#define USB_OTG_HC_XFERCM_INT
usb host channel interrupt mask
Definition: at32f435_437_usb.h:214
USB_OTG_HPRT_PRTCONDET
#define USB_OTG_HPRT_PRTCONDET
Definition: at32f435_437_usb.h:171
usbh_get_frame
uint32_t usbh_get_frame(otg_global_type *usbx)
get current frame number
Definition: at32f435_437_usb.c:868
usb_ept_open
void usb_ept_open(otg_global_type *usbx, usb_ept_info *ept_info)
open usb endpoint
Definition: at32f435_437_usb.c:473
usb_connect
void usb_connect(otg_global_type *usbx)
connect usb device by enable pull-up
Definition: at32f435_437_usb.c:771
usb_ept_out_clear
void usb_ept_out_clear(otg_global_type *usbx, uint32_t eptn, uint32_t flag)
clear out endpoint interrupt flag
Definition: at32f435_437_usb.c:690
usb_ept0_setup
void usb_ept0_setup(otg_global_type *usbx)
endpoint 0 start setup
Definition: at32f435_437_usb.c:757
usb_ept_in_clear
void usb_ept_in_clear(otg_global_type *usbx, uint32_t eptn, uint32_t flag)
clear in endpoint interrupt flag
Definition: at32f435_437_usb.c:711
usb_remote_wkup_clear
void usb_remote_wkup_clear(otg_global_type *usbx)
usb remote wakeup clear
Definition: at32f435_437_usb.c:813
usb_port_power_on
void usb_port_power_on(otg_global_type *usbx, confirm_state state)
usb port power on
Definition: at32f435_437_usb.c:842
usb_set_rx_fifo
void usb_set_rx_fifo(otg_global_type *usbx, uint16_t size)
usb set rx fifo size
Definition: at32f435_437_usb.c:294
usb_write_packet
void usb_write_packet(otg_global_type *usbx, uint8_t *pusr_buf, uint16_t num, uint16_t nbytes)
write data from user memory to usb buffer
Definition: at32f435_437_usb.c:422
usb_disconnect
void usb_disconnect(otg_global_type *usbx)
disconnect usb device by disable pull-up
Definition: at32f435_437_usb.c:785
usb_remote_wkup_set
void usb_remote_wkup_set(otg_global_type *usbx)
usb remote wakeup set
Definition: at32f435_437_usb.c:800
usb_global_set_mode
void usb_global_set_mode(otg_global_type *usbx, uint32_t mode)
set otg mode(device or host mode)
Definition: at32f435_437_usb.c:344
usb_set_tx_fifo
void usb_set_tx_fifo(otg_global_type *usbx, uint8_t txfifo, uint16_t size)
usb set tx fifo size
Definition: at32f435_437_usb.c:309
usb_flush_rx_fifo
void usb_flush_rx_fifo(otg_global_type *usbx)
flush rx fifo
Definition: at32f435_437_usb.c:150
usb_global_interrupt_enable
void usb_global_interrupt_enable(otg_global_type *usbx, uint16_t interrupt, confirm_state new_state)
usb interrupt mask enable
Definition: at32f435_437_usb.c:196
usb_global_clear_interrupt
void usb_global_clear_interrupt(otg_global_type *usbx, uint32_t flag)
clear the global interrupt flag
Definition: at32f435_437_usb.c:255
usb_suspend_status_get
uint8_t usb_suspend_status_get(otg_global_type *usbx)
usb suspend status get
Definition: at32f435_437_usb.c:826
usb_ept_clear_stall
void usb_ept_clear_stall(otg_global_type *usbx, usb_ept_info *ept_info)
clear endpoint tx or rx status to stall
Definition: at32f435_437_usb.c:592
usb_ept0_start
void usb_ept0_start(otg_global_type *usbx)
enable endpoint 0 out
Definition: at32f435_437_usb.c:739
usb_set_address
void usb_set_address(otg_global_type *usbx, uint8_t address)
set the host assignment address
Definition: at32f435_437_usb.c:726
usb_flush_tx_fifo
void usb_flush_tx_fifo(otg_global_type *usbx, uint32_t fifo_num)
flush tx fifo
Definition: at32f435_437_usb.c:124
usbh_fsls_clksel
void usbh_fsls_clksel(otg_global_type *usbx, uint8_t clk)
select full or low speed clock
Definition: at32f435_437_usb.c:1068
usb_ept_out_interrupt
uint32_t usb_ept_out_interrupt(otg_global_type *usbx, uint32_t eptn)
get out endpoint interrupt flag
Definition: at32f435_437_usb.c:650
usb_interrupt_disable
void usb_interrupt_disable(otg_global_type *usbx)
usb global interrupt disable
Definition: at32f435_437_usb.c:280
usb_hch_read_interrupt
uint32_t usb_hch_read_interrupt(otg_global_type *usbx)
host read channel interrupt
Definition: at32f435_437_usb.c:954
usb_ept_close
void usb_ept_close(otg_global_type *usbx, usb_ept_info *ept_info)
close usb endpoint
Definition: at32f435_437_usb.c:539
usb_hc_enable
void usb_hc_enable(otg_global_type *usbx, uint8_t chn, uint8_t ept_num, uint8_t dev_address, uint8_t type, uint16_t maxpacket, uint8_t speed)
enable one host channel
Definition: at32f435_437_usb.c:896
usb_stop_phy_clk
void usb_stop_phy_clk(otg_global_type *usbx)
usb stop phy clock
Definition: at32f435_437_usb.c:396
usb_global_get_all_interrupt
uint32_t usb_global_get_all_interrupt(otg_global_type *usbx)
get all global core interrupt flag
Definition: at32f435_437_usb.c:216
usb_interrupt_enable
void usb_interrupt_enable(otg_global_type *usbx)
usb global interrupt enable
Definition: at32f435_437_usb.c:267
usb_get_all_out_interrupt
uint32_t usb_get_all_out_interrupt(otg_global_type *usbx)
get all out endpoint interrupt bits
Definition: at32f435_437_usb.c:620
usb_ept_in_interrupt
uint32_t usb_ept_in_interrupt(otg_global_type *usbx, uint32_t eptn)
get in endpoint interrupt flag
Definition: at32f435_437_usb.c:665
usb_get_all_in_interrupt
uint32_t usb_get_all_in_interrupt(otg_global_type *usbx)
get all in endpoint interrupt bits
Definition: at32f435_437_usb.c:634
usb_global_power_on
void usb_global_power_on(otg_global_type *usbx)
disable the transceiver power down mode
Definition: at32f435_437_usb.c:377
usb_open_phy_clk
void usb_open_phy_clk(otg_global_type *usbx)
usb open phy clock
Definition: at32f435_437_usb.c:409
usb_global_reset
error_status usb_global_reset(otg_global_type *usbx)
usb global core soft reset
Definition: at32f435_437_usb.c:53
usb_ept_stall
void usb_ept_stall(otg_global_type *usbx, usb_ept_info *ept_info)
set endpoint tx or rx status to stall
Definition: at32f435_437_usb.c:563
usb_hch_halt
void usb_hch_halt(otg_global_type *usbx, uint8_t chn)
halt channel
Definition: at32f435_437_usb.c:1012
usb_read_packet
void usb_read_packet(otg_global_type *usbx, uint8_t *pusr_buf, uint16_t num, uint16_t nbytes)
read data from usb buffer to user buffer
Definition: at32f435_437_usb.c:445
usb_global_select_core
otg_global_type * usb_global_select_core(uint8_t usb_id)
usb global select usb core (otg1 or otg2).
Definition: at32f435_437_usb.c:100
usb_global_init
void usb_global_init(otg_global_type *usbx)
usb global initialization
Definition: at32f435_437_usb.c:83
usb_host_disable
void usb_host_disable(otg_global_type *usbx)
disable host
Definition: at32f435_437_usb.c:968
otg_eptout_type
Definition: at32f435_437_usb.h:1224
otg_eptout_type::rxdpid_setupcnt
__IO uint32_t rxdpid_setupcnt
Definition: at32f435_437_usb.h:1282
otg_eptout_type::doeptsiz_bit
struct otg_eptout_type::@1273::@1277 doeptsiz_bit
otg_eptout_type::pktcnt
__IO uint32_t pktcnt
Definition: at32f435_437_usb.h:1281
otg_eptout_type::doeptsiz
__IO uint32_t doeptsiz
Definition: at32f435_437_usb.h:1277
otg_eptout_type::xfersize
__IO uint32_t xfersize
Definition: at32f435_437_usb.h:1280
otg_global_type
Definition: at32f435_437_usb.h:474
otg_global_type::hchintmsk
__IO uint32_t hchintmsk
Definition: at32f435_437_usb.h:630
otg_global_type::txfnum
__IO uint32_t txfnum
Definition: at32f435_437_usb.h:554
otg_global_type::fhstmode
__IO uint32_t fhstmode
Definition: at32f435_437_usb.h:534
otg_global_type::dieptxfn
__IO uint32_t dieptxfn[7]
Definition: at32f435_437_usb.h:765
otg_global_type::csftrst
__IO uint32_t csftrst
Definition: at32f435_437_usb.h:548
otg_global_type::pwrdown
__IO uint32_t pwrdown
Definition: at32f435_437_usb.h:724
otg_global_type::nptxfdep
__IO uint32_t nptxfdep
Definition: at32f435_437_usb.h:695
otg_global_type::glbintmsk
__IO uint32_t glbintmsk
Definition: at32f435_437_usb.h:514
otg_global_type::dieptxfn_bit
struct otg_global_type::@1179::@1196 dieptxfn_bit[7]
otg_global_type::gccfg_bit
struct otg_global_type::@1173::@1193 gccfg_bit
otg_global_type::txfflsh
__IO uint32_t txfflsh
Definition: at32f435_437_usb.h:553
otg_global_type::gnptxfsiz_ept0tx
__IO uint32_t gnptxfsiz_ept0tx
Definition: at32f435_437_usb.h:691
otg_global_type::fdevmode
__IO uint32_t fdevmode
Definition: at32f435_437_usb.h:535
otg_global_type::grxfsiz
__IO uint32_t grxfsiz
Definition: at32f435_437_usb.h:678
otg_global_type::ineptxfdep
__IO uint32_t ineptxfdep
Definition: at32f435_437_usb.h:769
otg_global_type::ahbidle
__IO uint32_t ahbidle
Definition: at32f435_437_usb.h:556
otg_global_type::gintsts
__IO uint32_t gintsts
Definition: at32f435_437_usb.h:565
otg_global_type::rxfflsh
__IO uint32_t rxfflsh
Definition: at32f435_437_usb.h:552
otg_global_type::gahbcfg_bit
struct otg_global_type::@1153::@1183 gahbcfg_bit
otg_global_type::gusbcfg_bit
struct otg_global_type::@1155::@1184 gusbcfg_bit
otg_global_type::gnptxfsiz_ept0tx_bit
struct otg_global_type::@1169::@1191 gnptxfsiz_ept0tx_bit
otg_global_type::gintmsk_bit
struct otg_global_type::@1161::@1187 gintmsk_bit
otg_global_type::gintmsk
__IO uint32_t gintmsk
Definition: at32f435_437_usb.h:605
otg_global_type::gnptxsts
__IO uint32_t gnptxsts
Definition: at32f435_437_usb.h:704
otg_global_type::grstctl_bit
struct otg_global_type::@1157::@1185 grstctl_bit
otg_hchannel_type
Definition: at32f435_437_usb.h:890
otg_hchannel_type::devaddr
__IO uint32_t devaddr
Definition: at32f435_437_usb.h:906
otg_hchannel_type::eptnum
__IO uint32_t eptnum
Definition: at32f435_437_usb.h:900
otg_hchannel_type::eptdir
__IO uint32_t eptdir
Definition: at32f435_437_usb.h:901
otg_hchannel_type::oddfrm
__IO uint32_t oddfrm
Definition: at32f435_437_usb.h:907
otg_hchannel_type::chena
__IO uint32_t chena
Definition: at32f435_437_usb.h:909
otg_hchannel_type::chdis
__IO uint32_t chdis
Definition: at32f435_437_usb.h:908
otg_hchannel_type::hcintmsk
__IO uint32_t hcintmsk
Definition: at32f435_437_usb.h:958
otg_hchannel_type::hcchar_bit
struct otg_hchannel_type::@1218::@1228 hcchar_bit
otg_hchannel_type::hcintmsk_bit
struct otg_hchannel_type::@1224::@1231 hcintmsk_bit
otg_hchannel_type::mps
__IO uint32_t mps
Definition: at32f435_437_usb.h:899
otg_hchannel_type::bblerrmsk
__IO uint32_t bblerrmsk
Definition: at32f435_437_usb.h:969
otg_hchannel_type::eptype
__IO uint32_t eptype
Definition: at32f435_437_usb.h:904
otg_hchannel_type::lspddev
__IO uint32_t lspddev
Definition: at32f435_437_usb.h:903
otg_host_type
Definition: at32f435_437_usb.h:776
otg_host_type::hprt
__IO uint32_t hprt
Definition: at32f435_437_usb.h:866
otg_host_type::haintmsk
__IO uint32_t haintmsk
Definition: at32f435_437_usb.h:851
otg_host_type::hcfg_bit
struct otg_host_type::@1197::@1211 hcfg_bit
otg_host_type::haint
__IO uint32_t haint
Definition: at32f435_437_usb.h:838
otg_host_type::fslspclksel
__IO uint32_t fslspclksel
Definition: at32f435_437_usb.h:785
otg_host_type::hfnum
__IO uint32_t hfnum
Definition: at32f435_437_usb.h:809
otg_host_type::hfir
__IO uint32_t hfir
Definition: at32f435_437_usb.h:796
otg_host_type::hptxsts
__IO uint32_t hptxsts
Definition: at32f435_437_usb.h:824
usb_ept_info
usb endpoint infomation structure definition
Definition: at32f435_437_usb.h:421
usb_ept_info::inout
uint8_t inout
Definition: at32f435_437_usb.h:424
usb_ept_info::maxpacket
uint32_t maxpacket
Definition: at32f435_437_usb.h:429
usb_ept_info::eptn
uint8_t eptn
Definition: at32f435_437_usb.h:422
usb_ept_info::trans_type
uint8_t trans_type
Definition: at32f435_437_usb.h:425
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_usb.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_usb.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_USB_H
29#define __AT32F435_437_USB_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
52#define USB_OTG_MODEMIS_INT ((uint32_t)0x00000002)
53#define USB_OTG_OTGINT_INT ((uint32_t)0x00000004)
54#define USB_OTG_SOF_INT ((uint32_t)0x00000008)
55#define USB_OTG_RXFLVL_INT ((uint32_t)0x00000010)
56#define USB_OTG_NPTXFEMP_INT ((uint32_t)0x00000020)
57#define USB_OTG_GINNAKEFF_INT ((uint32_t)0x00000040)
58#define USB_OTG_GOUTNAKEFF_INT ((uint32_t)0x00000080)
59#define USB_OTG_ERLYSUSP_INT ((uint32_t)0x00000400)
60#define USB_OTG_USBSUSP_INT ((uint32_t)0x00000800)
61#define USB_OTG_USBRST_INT ((uint32_t)0x00001000)
62#define USB_OTG_ENUMDONE_INT ((uint32_t)0x00002000)
63#define USB_OTG_ISOOUTDROP_INT ((uint32_t)0x00004000)
64#define USB_OTG_EOPF_INT ((uint32_t)0x00008000)
65#define USB_OTG_IEPT_INT ((uint32_t)0x00040000)
66#define USB_OTG_OEPT_INT ((uint32_t)0x00080000)
67#define USB_OTG_INCOMISOIN_INT ((uint32_t)0x00100000)
68#define USB_OTG_INCOMPIP_INCOMPISOOUT_INT ((uint32_t)0x00200000)
69#define USB_OTG_PRT_INT ((uint32_t)0x01000000)
70#define USB_OTG_HCH_INT ((uint32_t)0x02000000)
71#define USB_OTG_PTXFEMP_INT ((uint32_t)0x04000000)
72#define USB_OTG_CONIDSCHG_INT ((uint32_t)0x10000000)
73#define USB_OTG_DISCON_INT ((uint32_t)0x20000000)
74#define USB_OTG_WKUP_INT ((uint32_t)0x80000000)
85#define USB_OTG_CURMODE ((uint32_t)0x00000001)
86#define USB_OTG_MODEMIS_FLAG ((uint32_t)0x00000002)
87#define USB_OTG_OTGINT_FLAG ((uint32_t)0x00000004)
88#define USB_OTG_SOF_FLAG ((uint32_t)0x00000008)
89#define USB_OTG_RXFLVL_FLAG ((uint32_t)0x00000010)
90#define USB_OTG_NPTXFEMP_FLAG ((uint32_t)0x00000020)
91#define USB_OTG_GINNAKEFF_FLAG ((uint32_t)0x00000040)
92#define USB_OTG_GOUTNAKEFF_FLAG ((uint32_t)0x00000080)
93#define USB_OTG_ERLYSUSP_FLAG ((uint32_t)0x00000400)
94#define USB_OTG_USBSUSP_FLAG ((uint32_t)0x00000800)
95#define USB_OTG_USBRST_FLAG ((uint32_t)0x00001000)
96#define USB_OTG_ENUMDONE_FLAG ((uint32_t)0x00002000)
97#define USB_OTG_ISOOUTDROP_FLAG ((uint32_t)0x00004000)
98#define USB_OTG_EOPF_FLAG ((uint32_t)0x00008000)
99#define USB_OTG_IEPT_FLAG ((uint32_t)0x00040000)
100#define USB_OTG_OEPT_FLAG ((uint32_t)0x00080000)
101#define USB_OTG_INCOMISOIN_FLAG ((uint32_t)0x00100000)
102#define USB_OTG_INCOMPIP_INCOMPISOOUT_FLAG ((uint32_t)0x00200000)
103#define USB_OTG_PRT_FLAG ((uint32_t)0x01000000)
104#define USB_OTG_HCH_FLAG ((uint32_t)0x02000000)
105#define USB_OTG_PTXFEMP_FLAG ((uint32_t)0x04000000)
106#define USB_OTG_CONIDSCHG_FLAG ((uint32_t)0x10000000)
107#define USB_OTG_DISCON_FLAG ((uint32_t)0x20000000)
108#define USB_OTG_WKUP_FLAG ((uint32_t)0x80000000)
123#define USB_TRDTIM_8 0x9
124#define USB_TRDTIM_16 0x5
129#define USB_OTG_GRXSTSP_EPTNUM ((uint32_t)0x0000000F)
130#define USB_OTG_GRXSTSP_CHNUM ((uint32_t)0x0000000F)
131#define USB_OTG_GRXSTSP_BCNT ((uint32_t)0x00007FF0)
132#define USB_OTG_GRXSTSP_DPID ((uint32_t)0x00018000)
133#define USB_OTG_GRXSTSP_PKTSTS ((uint32_t)0x001E0000)
138#define PKTSTS_IN_DATA_PACKET_RECV 0x2
139#define PKTSTS_IN_TRANSFER_COMPLETE 0x3
140#define PKTSTS_DATA_BIT_ERROR 0x5
141#define PKTSTS_CHANNEL_STOP 0x7
146#define USB_OUT_STS_NAK 0x1
147#define USB_OUT_STS_DATA 0x2
148#define USB_OUT_STS_COMP 0x3
149#define USB_SETUP_STS_COMP 0x4
150#define USB_SETUP_STS_DATA 0x6
163#define USB_HCFG_CLK_60M 0
164#define USB_HCFG_CLK_48M 1
165#define USB_HCFG_CLK_6M 2
170#define USB_OTG_HPRT_PRTCONSTS ((uint32_t)0x00000001)
171#define USB_OTG_HPRT_PRTCONDET ((uint32_t)0x00000002)
172#define USB_OTG_HPRT_PRTENA ((uint32_t)0x00000004)
173#define USB_OTG_HPRT_PRTENCHNG ((uint32_t)0x00000008)
174#define USB_OTG_HPRT_PRTOVRCACT ((uint32_t)0x00000010)
175#define USB_OTG_HPRT_PRTOVRCCHNG ((uint32_t)0x00000020)
176#define USB_OTG_HPRT_PRTRES ((uint32_t)0x00000040)
177#define USB_OTG_HPRT_PRTSUSP ((uint32_t)0x00000080)
178#define USB_OTG_HPRT_PRTRST ((uint32_t)0x00000100)
179#define USB_OTG_HPRT_PRTLNSTS ((uint32_t)0x00000C00)
180#define USB_OTG_HPRT_PRTPWR ((uint32_t)0x00001000)
181#define USB_OTG_HPRT_PRTSPD ((uint32_t)0x00060000)
186#define USB_PRTSPD_HIGH_SPEED 0
187#define USB_PRTSPD_FULL_SPEED 1
188#define USB_PRTSPD_LOW_SPEED 2
193#define USB_OTG_HCCHAR_MPS ((uint32_t)0x000007FF)
194#define USB_OTG_HCCHAR_EPTNUM ((uint32_t)0x00007800)
195#define USB_OTG_HCCHAR_EPTDIR ((uint32_t)0x00008000)
196#define USB_OTG_HCCHAR_LSPDDEV ((uint32_t)0x00020000)
197#define USB_OTG_HCCHAR_EPTYPE ((uint32_t)0x000C0000)
198#define USB_OTG_HCCHAR_MC ((uint32_t)0x00300000)
199#define USB_OTG_HCCHAR_DEVADDR ((uint32_t)0x1FC00000)
200#define USB_OTG_HCCHAR_ODDFRM ((uint32_t)0x20000000)
201#define USB_OTG_HCCHAR_CHDIS ((uint32_t)0x40000000)
202#define USB_OTG_HCCHAR_CHENA ((uint32_t)0x80000000)
207#define USB_OTG_HCTSIZ_XFERSIZE ((uint32_t)0x0007FFFF)
208#define USB_OTG_HCTSIZ_PKTCNT ((uint32_t)0x1FF80000)
209#define USB_OTG_HCTSIZ_PID ((uint32_t)0x60000000)
214#define USB_OTG_HC_XFERCM_INT ((uint32_t)0x00000001)
215#define USB_OTG_HC_CHHLTDM_INT ((uint32_t)0x00000002)
216#define USB_OTG_HC_STALLM_INT ((uint32_t)0x00000008)
217#define USB_OTG_HC_NAKM_INT ((uint32_t)0x00000010)
218#define USB_OTG_HC_ACKM_INT ((uint32_t)0x00000020)
219#define USB_OTG_HC_NYETM_INT ((uint32_t)0x00000040)
220#define USB_OTG_HC_XACTERRM_INT ((uint32_t)0x00000080)
221#define USB_OTG_HC_BBLERRM_INT ((uint32_t)0x00000100)
222#define USB_OTG_HC_FRMOVRRUN_INT ((uint32_t)0x00000200)
223#define USB_OTG_HC_DTGLERRM_INT ((uint32_t)0x00000400)
228#define USB_OTG_HC_XFERC_FLAG ((uint32_t)0x00000001)
229#define USB_OTG_HC_CHHLTD_FLAG ((uint32_t)0x00000002)
230#define USB_OTG_HC_STALL_FLAG ((uint32_t)0x00000008)
231#define USB_OTG_HC_NAK_FLAG ((uint32_t)0x00000010)
232#define USB_OTG_HC_ACK_FLAG ((uint32_t)0x00000020)
233#define USB_OTG_HC_NYET_FLAG ((uint32_t)0x00000040)
234#define USB_OTG_HC_XACTERR_FLAG ((uint32_t)0x00000080)
235#define USB_OTG_HC_BBLERR_FLAG ((uint32_t)0x00000100)
236#define USB_OTG_HC_FRMOVRRUN_FLAG ((uint32_t)0x00000200)
237#define USB_OTG_HC_DTGLERR_FLAG ((uint32_t)0x00000400)
250typedef enum
251{
252 DCFG_PERFRINT_80 = 0x00,
253 DCFG_PERFRINT_85 = 0x01,
254 DCFG_PERFRINT_90 = 0x02,
255 DCFG_PERFRINT_95 = 0x03
256} dcfg_perfrint_type;
257
258
262#define USB_DCFG_FULL_SPEED 3
267#define USB_OTG_DCTL_RWKUPSIG ((uint32_t)0x00000001)
268#define USB_OTG_DCTL_SFTDISCON ((uint32_t)0x00000002)
269#define USB_OTG_DCTL_GNPINNAKSTS ((uint32_t)0x00000004)
270#define USB_OTG_DCTL_GOUTNAKSTS ((uint32_t)0x00000008)
271#define USB_OTG_DCTL_SGNPINNAK ((uint32_t)0x00000080)
272#define USB_OTG_DCTL_CGNPINNAK ((uint32_t)0x00000100)
273#define USB_OTG_DCTL_SGOUTNAK ((uint32_t)0x00000200)
274#define USB_OTG_DCTL_CGOUTNAK ((uint32_t)0x00000400)
275#define USB_OTG_DCTL_PWROPRGDNE ((uint32_t)0x00000800)
280#define USB_OTG_DIEPINT_XFERC_FLAG ((uint32_t)0x00000001)
281#define USB_OTG_DIEPINT_EPTDISD_FLAG ((uint32_t)0x00000002)
282#define USB_OTG_DIEPINT_TIMEOUT_FLAG ((uint32_t)0x00000008)
283#define USB_OTG_DIEPINT_INTKNTXFEMP_FLAG ((uint32_t)0x00000010)
284#define USB_OTG_DIEPINT_INEPTNAK_FLAG ((uint32_t)0x00000040)
285#define USB_OTG_DIEPINT_TXFEMP_FLAG ((uint32_t)0x00000080)
290#define USB_OTG_DOEPINT_XFERC_FLAG ((uint32_t)0x00000001)
291#define USB_OTG_DOEPINT_EPTDISD_FLAG ((uint32_t)0x00000002)
292#define USB_OTG_DOEPINT_SETUP_FLAG ((uint32_t)0x00000008)
293#define USB_OTG_DOEPINT_OUTTEPD_FLAG ((uint32_t)0x00000010)
294#define USB_OTG_DOEPINT_B2BSTUP_FLAG ((uint32_t)0x00000040)
299#define USB_OTG_DTXFSTS_INEPTFSAV ((uint32_t)0x0000FFFF)
304#define USB_EPT0_MPS_64 0
305#define USB_EPT0_MPS_32 1
306#define USB_EPT0_MPS_16 2
307#define USB_EPT0_MPS_8 3
316#define OTG_FIFO_SIZE 320
321#define USB_MAX_DATA_LENGTH 0x200
323#define OTGFS_USB_GLOBAL
324#define OTGFS_USB_DEVICE
325#define OTGFS_USB_HOST
326
334typedef enum
335{
336 OTG_DEVICE_MODE,
337 OTG_HOST_MODE,
338 OTG_DRD_MODE
339} otg_mode_type;
340
344typedef enum
345{
346 EPT_CONTROL_TYPE = 0x00,
347 EPT_ISO_TYPE = 0x01,
348 EPT_BULK_TYPE = 0x02,
349 EPT_INT_TYPE = 0x03
350} endpoint_trans_type;
351
355typedef enum
356{
357 USB_EPT0 = 0x00,
358 USB_EPT1 = 0x01,
359 USB_EPT2 = 0x02,
360 USB_EPT3 = 0x03,
361 USB_EPT4 = 0x04,
362 USB_EPT5 = 0x05,
363 USB_EPT6 = 0x06,
364 USB_EPT7 = 0x07
365} usb_endpoint_number_type;
366
370#ifndef USB_EPT_MAX_NUM
371#define USB_EPT_MAX_NUM 8
372#endif
376#ifndef USB_HOST_CHANNEL_NUM
377#define USB_HOST_CHANNEL_NUM 16
378#endif
379
383typedef enum
384{
385 EPT_DIR_IN = 0x00,
386 EPT_DIR_OUT = 0x01
387} endpoint_dir_type;
388
392typedef enum
393{
394 USB_OTG1_ID,
395 USB_OTG2_ID
396} otg_id_type;
397
401typedef enum
402{
403 USB_CLK_HICK,
404 USB_CLK_HEXT
405}usb_clk48_s;
406
420typedef struct
421{
422 uint8_t eptn;
423 uint8_t ept_address;
424 uint8_t inout;
425 uint8_t trans_type;
427 uint16_t tx_addr;
428 uint16_t rx_addr;
429 uint32_t maxpacket;
430 uint8_t is_double_buffer;
431 uint8_t stall;
432 uint32_t status;
433
434 /* transmission buffer and count */
435 uint8_t *trans_buf;
436 uint32_t total_len;
437 uint32_t trans_len;
439 uint32_t last_len;
440 uint32_t rem0_len;
441 uint32_t ept0_slen;
442} usb_ept_info;
443
444
448typedef struct
449{
450 uint8_t ch_num;
451 uint8_t address;
452 uint8_t dir;
453 uint8_t ept_num;
454 uint8_t ept_type;
455 uint32_t maxpacket;
456 uint8_t data_pid;
457 uint8_t speed;
458 uint8_t stall;
459 uint32_t status;
460 uint32_t state;
461 uint32_t urb_sts;
463 uint8_t toggle_in;
464 uint8_t toggle_out;
466 /* transmission buffer and count */
467 uint8_t *trans_buf; /* host channel buffer */
468 uint32_t trans_len; /* host channel transmission len */
469 uint32_t trans_count; /* host channel transmission count*/
470} usb_hch_type;
471
472
473typedef struct
474{
478 union
479 {
480 __IO uint32_t gotgctrl;
481 struct
482 {
483 __IO uint32_t reserved1 : 16; /* [15:0] */
484 __IO uint32_t cidsts : 1; /* [16] */
485 __IO uint32_t reserved2 : 4; /* [20:17] */
486 __IO uint32_t curmod : 1; /* [21] */
487 __IO uint32_t reserved3 : 10; /* [31:22] */
488 } gotgctrl_bit;
489 };
490
494 union
495 {
496 __IO uint32_t gotgint;
497 struct
498 {
499 __IO uint32_t reserved1 : 2; /* [1:0] */
500 __IO uint32_t sesenddet : 1; /* [2] */
501 __IO uint32_t reserved2 : 29; /* [31:3] */
502
503 } gotgint_bit;
504 };
505
509 union
510 {
511 __IO uint32_t gahbcfg;
512 struct
513 {
514 __IO uint32_t glbintmsk : 1; /* [0] */
515 __IO uint32_t reserved1 : 6; /* [6:1] */
516 __IO uint32_t nptxfemplvl : 1; /* [7] */
517 __IO uint32_t ptxfemplvl : 1; /* [8] */
518 __IO uint32_t reserved2 : 23; /* [31:9] */
519 } gahbcfg_bit;
520 };
521
525 union
526 {
527 __IO uint32_t gusbcfg;
528 struct
529 {
530 __IO uint32_t toutcal : 3; /* [2:0] */
531 __IO uint32_t reserved1 : 7; /* [9:3] */
532 __IO uint32_t usbtrdtim : 4; /* [13:10] */
533 __IO uint32_t reserved2 : 15; /* [28:14] */
534 __IO uint32_t fhstmode : 1; /* [29] */
535 __IO uint32_t fdevmode : 1; /* [30] */
536 __IO uint32_t cotxpkt : 1; /* [31] */
537 } gusbcfg_bit;
538 };
539
543 union
544 {
545 __IO uint32_t grstctl;
546 struct
547 {
548 __IO uint32_t csftrst : 1; /* [0] */
549 __IO uint32_t piusftrst : 1; /* [1] */
550 __IO uint32_t frmcntrst : 1; /* [2] */
551 __IO uint32_t reserved1 : 1; /* [3] */
552 __IO uint32_t rxfflsh : 1; /* [4] */
553 __IO uint32_t txfflsh : 1; /* [5] */
554 __IO uint32_t txfnum : 5; /* [10:6] */
555 __IO uint32_t reserved2 : 20; /* [30:11] */
556 __IO uint32_t ahbidle : 1; /* [31] */
557 } grstctl_bit;
558 };
559
563 union
564 {
565 __IO uint32_t gintsts;
566 struct
567 {
568 __IO uint32_t curmode : 1; /* [0] */
569 __IO uint32_t modemis : 1; /* [1] */
570 __IO uint32_t otgint : 1; /* [2] */
571 __IO uint32_t sof : 1; /* [3] */
572 __IO uint32_t rxflvl : 1; /* [4] */
573 __IO uint32_t nptxfemp : 1; /* [5] */
574 __IO uint32_t ginnakeff : 1; /* [6] */
575 __IO uint32_t goutnakeff : 1; /* [7] */
576 __IO uint32_t reserved1 : 2; /* [9:8]] */
577 __IO uint32_t erlysusp : 1; /* [10] */
578 __IO uint32_t usbsusp : 1; /* [11] */
579 __IO uint32_t usbrst : 1; /* [12] */
580 __IO uint32_t enumdone : 1; /* [13] */
581 __IO uint32_t isooutdrop : 1; /* [14] */
582 __IO uint32_t eopf : 1; /* [15] */
583 __IO uint32_t reserved2 : 2; /* [17:16]] */
584 __IO uint32_t ieptint : 1; /* [18] */
585 __IO uint32_t oeptint : 1; /* [19] */
586 __IO uint32_t incompisoin : 1; /* [20] */
587 __IO uint32_t incompip_incompisoout : 1; /* [21] */
588 __IO uint32_t reserved3 : 2; /* [23:22] */
589 __IO uint32_t prtint : 1; /* [24] */
590 __IO uint32_t hchint : 1; /* [25] */
591 __IO uint32_t ptxfemp : 1; /* [26] */
592 __IO uint32_t reserved4 : 1; /* [27] */
593 __IO uint32_t conidschg : 1; /* [28] */
594 __IO uint32_t disconint : 1; /* [29] */
595 __IO uint32_t reserved5 : 1; /* [30] */
596 __IO uint32_t wkupint : 1; /* [31] */
597 } gintsts_bit;
598 };
599
603 union
604 {
605 __IO uint32_t gintmsk;
606 struct
607 {
608 __IO uint32_t reserved1 : 1; /* [0] */
609 __IO uint32_t modemismsk : 1; /* [1] */
610 __IO uint32_t otgintmsk : 1; /* [2] */
611 __IO uint32_t sofmsk : 1; /* [3] */
612 __IO uint32_t rxflvlmsk : 1; /* [4] */
613 __IO uint32_t nptxfempmsk : 1; /* [5] */
614 __IO uint32_t ginnakeffmsk : 1; /* [6] */
615 __IO uint32_t goutnakeffmsk : 1; /* [7] */
616 __IO uint32_t reserved2 : 2; /* [9:8]] */
617 __IO uint32_t erlysuspmsk : 1; /* [10] */
618 __IO uint32_t usbsuspmsk : 1; /* [11] */
619 __IO uint32_t usbrstmsk : 1; /* [12] */
620 __IO uint32_t enumdonemsk : 1; /* [13] */
621 __IO uint32_t isooutdropmsk : 1; /* [14] */
622 __IO uint32_t eopfmsk : 1; /* [15] */
623 __IO uint32_t reserved3 : 2; /* [17:16]] */
624 __IO uint32_t ieptintmsk : 1; /* [18] */
625 __IO uint32_t oeptintmsk : 1; /* [19] */
626 __IO uint32_t incompisoinmsk : 1; /* [20] */
627 __IO uint32_t incompip_incompisooutmsk : 1; /* [21] */
628 __IO uint32_t reserved4 : 2; /* [23:22] */
629 __IO uint32_t prtintmsk : 1; /* [24] */
630 __IO uint32_t hchintmsk : 1; /* [25] */
631 __IO uint32_t ptxfempmsk : 1; /* [26] */
632 __IO uint32_t reserved5 : 1; /* [27] */
633 __IO uint32_t conidschgmsk : 1; /* [28] */
634 __IO uint32_t disconintmsk : 1; /* [29] */
635 __IO uint32_t reserved6 : 1; /* [30] */
636 __IO uint32_t wkupintmsk : 1; /* [31] */
637 } gintmsk_bit;
638 };
639
643 union
644 {
645 __IO uint32_t grxstsr;
646 struct
647 {
648 __IO uint32_t eptnum : 4; /* [3:0] */
649 __IO uint32_t bcnt : 11; /* [14:4] */
650 __IO uint32_t dpid : 2; /* [16:15] */
651 __IO uint32_t pktsts : 4; /* [20:17] */
652 __IO uint32_t fn : 4; /* [24:21] */
653 __IO uint32_t reserved1 : 7; /* [31:25] */
654 } grxstsr_bit;
655 };
656
660 union
661 {
662 __IO uint32_t grxstsp;
663 struct
664 {
665 __IO uint32_t chnum : 4; /* [3:0] */
666 __IO uint32_t bcnt : 11; /* [14:4] */
667 __IO uint32_t dpid : 2; /* [16:15] */
668 __IO uint32_t pktsts : 4; /* [20:17] */
669 __IO uint32_t reserved1 : 11; /* [31:21] */
670 } grxstsp_bit;
671 };
672
676 union
677 {
678 __IO uint32_t grxfsiz;
679 struct
680 {
681 __IO uint32_t rxfdep : 16; /* [15:0] */
682 __IO uint32_t reserved1 : 16; /* [31:16] */
683 } grxfsiz_bit;
684 };
685
689 union
690 {
691 __IO uint32_t gnptxfsiz_ept0tx;
692 struct
693 {
694 __IO uint32_t nptxfstaddr : 16; /* [15:0] */
695 __IO uint32_t nptxfdep : 16; /* [31:16] */
696 } gnptxfsiz_ept0tx_bit;
697 };
698
702 union
703 {
704 __IO uint32_t gnptxsts;
705 struct
706 {
707 __IO uint32_t nptxfspcavail : 16; /* [15:0] */
708 __IO uint32_t nptxqspcavail : 8; /* [23:16] */
709 __IO uint32_t nptxqtop : 7; /* [30:24] */
710 } gnptxsts_bit;
711 };
712
713 __IO uint32_t reserved2[2];
714
718 union
719 {
720 __IO uint32_t gccfg;
721 struct
722 {
723 __IO uint32_t reserved1 : 16; /* [15:0] */
724 __IO uint32_t pwrdown : 1; /* [16] */
725 __IO uint32_t lp_mode : 1; /* [17] */
726 __IO uint32_t reserved2 : 2; /* [19:18] */
727 __IO uint32_t sofouten : 1; /* [20] */
728 __IO uint32_t vbusig : 1; /* [21] */
729 __IO uint32_t reserved3 : 10; /* [31:22] */
730 } gccfg_bit;
731 };
732
736 union
737 {
738 __IO uint32_t guid;
739 struct
740 {
741 __IO uint32_t userid : 32; /* [31:0] */
742 } guid_bit;
743 };
744
745 __IO uint32_t reserved3[48];
746
750 union
751 {
752 __IO uint32_t hptxfsiz;
753 struct
754 {
755 __IO uint32_t ptxfstaddr : 16; /* [15:0] */
756 __IO uint32_t ptxfsize : 16; /* [31:16] */
757 } hptxfsiz_bit;
758 };
759
763 union
764 {
765 __IO uint32_t dieptxfn[7];
766 struct
767 {
768 __IO uint32_t ineptxfstaddr : 16; /* [15:0] */
769 __IO uint32_t ineptxfdep : 16; /* [31:16] */
770 } dieptxfn_bit[7];
771 };
772} otg_global_type;
773
774
775typedef struct
776{
780 union
781 {
782 __IO uint32_t hcfg;
783 struct
784 {
785 __IO uint32_t fslspclksel : 2; /* [1:0] */
786 __IO uint32_t fslssupp : 1; /* [2] */
787 __IO uint32_t reserved1 : 29; /* [31:3] */
788 } hcfg_bit;
789 };
790
794 union
795 {
796 __IO uint32_t hfir;
797 struct
798 {
799 __IO uint32_t frint : 16; /* [15:0] */
800 __IO uint32_t reserved1 : 16; /* [31:15] */
801 } hfir_bit;
802 };
803
807 union
808 {
809 __IO uint32_t hfnum;
810 struct
811 {
812 __IO uint32_t frnum : 16; /* [15:0] */
813 __IO uint32_t ftrem : 16; /* [31:15] */
814 } hfnum_bit;
815 };
816
817 __IO uint32_t reserved1;
818
822 union
823 {
824 __IO uint32_t hptxsts;
825 struct
826 {
827 __IO uint32_t ptxfspcavil : 16; /* [15:0] */
828 __IO uint32_t ptxqspcavil : 8; /* [23:16] */
829 __IO uint32_t ptxqtop : 8; /* [31:24] */
830 } hptxsts_bit;
831 };
832
836 union
837 {
838 __IO uint32_t haint;
839 struct
840 {
841 __IO uint32_t haint : 16; /* [15:0] */
842 __IO uint32_t reserved1 : 16; /* [32:16] */
843 } haint_bit;
844 };
845
849 union
850 {
851 __IO uint32_t haintmsk;
852 struct
853 {
854 __IO uint32_t haintmsk : 16; /* [15:0] */
855 __IO uint32_t reserved1 : 16; /* [32:16] */
856 } haintmsk_bit;
857 };
858
859 __IO uint32_t reserved2[9];
860
864 union
865 {
866 __IO uint32_t hprt;
867 struct
868 {
869 __IO uint32_t prtconsts : 1; /* [0] */
870 __IO uint32_t prtcondet : 1; /* [1] */
871 __IO uint32_t prtena : 1; /* [2] */
872 __IO uint32_t prtenchng : 1; /* [3] */
873 __IO uint32_t prtovrcact : 1; /* [4] */
874 __IO uint32_t prtovrcchng : 1; /* [5] */
875 __IO uint32_t prtres : 1; /* [6] */
876 __IO uint32_t prtsusp : 1; /* [7] */
877 __IO uint32_t prtrst : 1; /* [8] */
878 __IO uint32_t reserved1 : 1; /* [9] */
879 __IO uint32_t prtlnsts : 2; /* [11:10] */
880 __IO uint32_t prtpwr : 1; /* [12] */
881 __IO uint32_t prttsctl : 4; /* [16:13] */
882 __IO uint32_t prtspd : 2; /* [18:17] */
883 __IO uint32_t reserved2 : 13; /* [31:19] */
884
885 } hprt_bit;
886 };
887} otg_host_type;
888
889typedef struct
890{
894 union
895 {
896 __IO uint32_t hcchar;
897 struct
898 {
899 __IO uint32_t mps : 11; /* [10:0] */
900 __IO uint32_t eptnum : 4; /* [14:11] */
901 __IO uint32_t eptdir : 1; /* [15] */
902 __IO uint32_t reserved1 : 1; /* [16] */
903 __IO uint32_t lspddev : 1; /* [17] */
904 __IO uint32_t eptype : 2; /* [19:18] */
905 __IO uint32_t mc : 2; /* [21:20] */
906 __IO uint32_t devaddr : 7; /* [28:22] */
907 __IO uint32_t oddfrm : 1; /* [29] */
908 __IO uint32_t chdis : 1; /* [30] */
909 __IO uint32_t chena : 1; /* [31] */
910 } hcchar_bit;
911 };
912
916 union
917 {
918 __IO uint32_t hcsplt;
919 struct
920 {
921 __IO uint32_t prtaddr : 7; /* [6:0] */
922 __IO uint32_t hubaddr : 7; /* [13:7] */
923 __IO uint32_t xactpos : 2; /* [15:14] */
924 __IO uint32_t compsplt : 1; /* [16] */
925 __IO uint32_t reserved1 : 14; /* [30:17] */
926 __IO uint32_t spltena : 1; /* [31] */
927 } hcsplt_bit;
928 };
929
933 union
934 {
935 __IO uint32_t hcint;
936 struct
937 {
938 __IO uint32_t xferc : 1; /* [0] */
939 __IO uint32_t chhltd : 1; /* [1] */
940 __IO uint32_t reserved1 : 1; /* [2] */
941 __IO uint32_t stall : 1; /* [3] */
942 __IO uint32_t nak : 1; /* [4] */
943 __IO uint32_t ack : 1; /* [5] */
944 __IO uint32_t reserved2 : 1; /* [6] */
945 __IO uint32_t xacterr : 1; /* [7] */
946 __IO uint32_t bblerr : 1; /* [8] */
947 __IO uint32_t frmovrun : 1; /* [9] */
948 __IO uint32_t dtglerr : 1; /* [10] */
949 __IO uint32_t reserved3 : 21; /* [31:11] */
950 } hcint_bit;
951 };
952
956 union
957 {
958 __IO uint32_t hcintmsk;
959 struct
960 {
961 __IO uint32_t xfercmsk : 1; /* [0] */
962 __IO uint32_t chhltdmsk : 1; /* [1] */
963 __IO uint32_t reserved1 : 1; /* [2] */
964 __IO uint32_t stallmsk : 1; /* [3] */
965 __IO uint32_t nakmsk : 1; /* [4] */
966 __IO uint32_t ackmsk : 1; /* [5] */
967 __IO uint32_t reserved2 : 1; /* [6] */
968 __IO uint32_t xacterrmsk : 1; /* [7] */
969 __IO uint32_t bblerrmsk : 1; /* [8] */
970 __IO uint32_t frmovrunmsk : 1; /* [9] */
971 __IO uint32_t dtglerrmsk : 1; /* [10] */
972 __IO uint32_t reserved3 : 21; /* [31:11] */
973 } hcintmsk_bit;
974 };
975
979 union
980 {
981 __IO uint32_t hctsiz;
982 struct
983 {
984 __IO uint32_t xfersize : 19; /* [18:0] */
985 __IO uint32_t pktcnt : 10; /* [28:19] */
986 __IO uint32_t pid : 2; /* [30:29] */
987 __IO uint32_t reserved1 : 1; /* [31] */
988 } hctsiz_bit;
989 };
990 __IO uint32_t reserved3[3];
991
992}otg_hchannel_type;
993
994
995typedef struct
996{
1000 union
1001 {
1002 __IO uint32_t dcfg;
1003 struct
1004 {
1005 __IO uint32_t devspd : 2; /* [1:0] */
1006 __IO uint32_t nzstsouthshk : 1; /* [2] */
1007 __IO uint32_t reserved1 : 1; /* [3] */
1008 __IO uint32_t devaddr : 7; /* [10:4] */
1009 __IO uint32_t perfrint : 2; /* [12:11] */
1010 __IO uint32_t reserved2 : 19; /* [31:13] */
1011 } dcfg_bit;
1012 };
1013
1017 union
1018 {
1019 __IO uint32_t dctl;
1020 struct
1021 {
1022 __IO uint32_t rwkupsig : 1; /* [0] */
1023 __IO uint32_t sftdiscon : 1; /* [1] */
1024 __IO uint32_t gnpinnaksts : 1; /* [2] */
1025 __IO uint32_t goutnaksts : 1; /* [3] */
1026 __IO uint32_t tstctl : 3; /* [6:4] */
1027 __IO uint32_t sgnpinak : 1; /* [7] */
1028 __IO uint32_t cgnpinak : 1; /* [8] */
1029 __IO uint32_t sgoutnak : 1; /* [9] */
1030 __IO uint32_t cgoutnak : 1; /* [10] */
1031 __IO uint32_t pwroprgdne : 1; /* [11] */
1032 __IO uint32_t reserved1 : 20; /* [31:12] */
1033 } dctl_bit;
1034 };
1035
1039 union
1040 {
1041 __IO uint32_t dsts;
1042 struct
1043 {
1044 __IO uint32_t suspsts : 1; /* [0] */
1045 __IO uint32_t enumspd : 2; /* [2:1] */
1046 __IO uint32_t eticerr : 1; /* [3] */
1047 __IO uint32_t reserved1 : 4; /* [7:4] */
1048 __IO uint32_t soffn : 14; /* [21:8] */
1049 __IO uint32_t reserved2 : 10; /* [31:22] */
1050 } dsts_bit;
1051 };
1052
1053 __IO uint32_t reserved1;
1057 union
1058 {
1059 __IO uint32_t diepmsk;
1060 struct
1061 {
1062 __IO uint32_t xfercmsk : 1; /* [0] */
1063 __IO uint32_t eptdismsk : 1; /* [1] */
1064 __IO uint32_t reserved1 : 1; /* [2] */
1065 __IO uint32_t timeoutmsk : 1; /* [3] */
1066 __IO uint32_t intkntxfempmsk : 1; /* [4] */
1067 __IO uint32_t intkneptmismsk : 1; /* [5] */
1068 __IO uint32_t ineptnakmsk : 1; /* [6] */
1069 __IO uint32_t reserved2 : 1; /* [7] */
1070 __IO uint32_t txfifoudrmsk : 1; /* [8] */
1071 __IO uint32_t bnainmsk : 1; /* [9] */
1072 __IO uint32_t reserved3 : 22; /* [31:10] */
1073 } diepmsk_bit;
1074 };
1075
1079 union
1080 {
1081 __IO uint32_t doepmsk;
1082 struct
1083 {
1084 __IO uint32_t xfercmsk : 1; /* [0] */
1085 __IO uint32_t eptdismsk : 1; /* [1] */
1086 __IO uint32_t reserved1 : 1; /* [2] */
1087 __IO uint32_t setupmsk : 1; /* [3] */
1088 __IO uint32_t outtepdmsk : 1; /* [4] */
1089 __IO uint32_t reserved2 : 1; /* [5] */
1090 __IO uint32_t b2bsetupmsk : 1; /* [6] */
1091 __IO uint32_t reserved3 : 1; /* [7] */
1092 __IO uint32_t outperrmsk : 1; /* [8] */
1093 __IO uint32_t bnaoutmsk : 1; /* [9] */
1094 __IO uint32_t reserved4 : 22; /* [31:10] */
1095 } doepmsk_bit;
1096 };
1097
1101 union
1102 {
1103 __IO uint32_t daint;
1104 struct
1105 {
1106 __IO uint32_t ineptint : 16; /* [15:0] */
1107 __IO uint32_t outeptint : 16; /* [31:16] */
1108 } daint_bit;
1109 };
1110
1114 union
1115 {
1116 __IO uint32_t daintmsk;
1117 struct
1118 {
1119 __IO uint32_t ineptmsk : 16; /* [15:0] */
1120 __IO uint32_t outeptmsk : 16; /* [31:16] */
1121 } daintmsk_bit;
1122 };
1123
1124 __IO uint32_t reserved2[5];
1125
1129 union
1130 {
1131 __IO uint32_t diepempmsk;
1132 struct
1133 {
1134 __IO uint32_t ineptxfemsk : 16; /* [15:0] */
1135 __IO uint32_t reserved1 : 16; /* [31:16] */
1136 } diepempmsk_bit;
1137 };
1138
1139} otg_device_type;
1140
1141typedef struct
1142{
1146 union
1147 {
1148 __IO uint32_t diepctl;
1149 struct
1150 {
1151 __IO uint32_t mps : 11; /* [10:0] */
1152 __IO uint32_t reserved1 : 4; /* [14:11] */
1153 __IO uint32_t usbacept : 1; /* [15] */
1154 __IO uint32_t dpid : 1; /* [16] */
1155 __IO uint32_t naksts : 1; /* [17] */
1156 __IO uint32_t eptype : 2; /* [19:18] */
1157 __IO uint32_t reserved2 : 1; /* [20] */
1158 __IO uint32_t stall : 1; /* [21] */
1159 __IO uint32_t txfnum : 4; /* [25:22] */
1160 __IO uint32_t cnak : 1; /* [26] */
1161 __IO uint32_t snak : 1; /* [27] */
1162 __IO uint32_t setd0pid : 1; /* [28] */
1163 __IO uint32_t setd1pid : 1; /* [29] */
1164 __IO uint32_t eptdis : 1; /* [30] */
1165 __IO uint32_t eptena : 1; /* [31] */
1166 } diepctl_bit;
1167 };
1168 __IO uint32_t reserved1;
1169
1173 union
1174 {
1175 __IO uint32_t diepint;
1176 struct
1177 {
1178 __IO uint32_t xferc : 1; /* [0] */
1179 __IO uint32_t epdisd : 1; /* [1] */
1180 __IO uint32_t reserved1 : 1; /* [2] */
1181 __IO uint32_t timeout : 1; /* [3] */
1182 __IO uint32_t intkntxfemp : 1; /* [4] */
1183 __IO uint32_t reserved2 : 1; /* [5] */
1184 __IO uint32_t ineptnak : 1; /* [6] */
1185 __IO uint32_t txfemp : 1; /* [7] */
1186 __IO uint32_t reserved3 : 24; /* [31:8] */
1187 } diepint_bit;
1188 };
1189 __IO uint32_t reserved2;
1190
1194 union
1195 {
1196 __IO uint32_t dieptsiz;
1197 struct
1198 {
1199 __IO uint32_t xfersize : 19; /* [18:0] */
1200 __IO uint32_t pktcnt : 10; /* [28:19] */
1201 __IO uint32_t mc : 2; /* [30:29] */
1202 __IO uint32_t reserved1 : 1; /* [31] */
1203 } dieptsiz_bit;
1204 };
1205
1206 __IO uint32_t reserved3;
1207
1211 union
1212 {
1213 __IO uint32_t dtxfsts;
1214 struct
1215 {
1216 __IO uint32_t ineptxfsav : 16; /* [15:0] */
1217 __IO uint32_t reserved1 : 16; /* [31:16] */
1218 } dtxfsts_bit;
1219 };
1220
1221} otg_eptin_type;
1222
1223typedef struct
1224{
1228 union
1229 {
1230 __IO uint32_t doepctl;
1231 struct
1232 {
1233 __IO uint32_t mps : 11; /* [10:0] */
1234 __IO uint32_t reserved1 : 4; /* [14:11] */
1235 __IO uint32_t usbacept : 1; /* [15] */
1236 __IO uint32_t dpid : 1; /* [16] */
1237 __IO uint32_t naksts : 1; /* [17] */
1238 __IO uint32_t eptype : 2; /* [19:18] */
1239 __IO uint32_t snpm : 1; /* [20] */
1240 __IO uint32_t stall : 1; /* [21] */
1241 __IO uint32_t reserved2 : 4; /* [25:22] */
1242 __IO uint32_t cnak : 1; /* [26] */
1243 __IO uint32_t snak : 1; /* [27] */
1244 __IO uint32_t setd0pid : 1; /* [28] */
1245 __IO uint32_t setd1pid : 1; /* [29] */
1246 __IO uint32_t eptdis : 1; /* [30] */
1247 __IO uint32_t eptena : 1; /* [31] */
1248 } doepctl_bit;
1249 };
1250 __IO uint32_t reserved1;
1251
1255 union
1256 {
1257 __IO uint32_t doepint;
1258 struct
1259 {
1260 __IO uint32_t xferc : 1; /* [0] */
1261 __IO uint32_t epdisd : 1; /* [1] */
1262 __IO uint32_t reserved1 : 1; /* [2] */
1263 __IO uint32_t setup : 1; /* [3] */
1264 __IO uint32_t outtepd : 1; /* [4] */
1265 __IO uint32_t reserved2 : 1; /* [5] */
1266 __IO uint32_t b2pstup : 1; /* [6] */
1267 __IO uint32_t reserved3 : 25; /* [31:7] */
1268 } doepint_bit;
1269 };
1270 __IO uint32_t reserved2;
1271
1275 union
1276 {
1277 __IO uint32_t doeptsiz;
1278 struct
1279 {
1280 __IO uint32_t xfersize : 19; /* [18:0] */
1281 __IO uint32_t pktcnt : 10; /* [28:19] */
1282 __IO uint32_t rxdpid_setupcnt : 2; /* [30:29] */
1283 __IO uint32_t reserved1 : 1; /* [31] */
1284 } doeptsiz_bit;
1285 };
1286} otg_eptout_type;
1287
1288typedef struct
1289{
1293 union
1294 {
1295 __IO uint32_t pcgcctl;
1296 struct
1297 {
1298 __IO uint32_t stoppclk : 1; /* [0] */
1299 __IO uint32_t reserved1 : 3; /* [3:1] */
1300 __IO uint32_t suspendm : 1; /* [4] */
1301 __IO uint32_t reserved2 : 27; /* [31:5] */
1302 } pcgcctl_bit;
1303 };
1304} otg_pcgcctl_type;
1305
1317#define OTG_HOST_ADDR_OFFSET 0x400
1318#define OTG_HOST_CHANNEL_ADDR_OFFSET 0x500
1319#define OTG_DEVICE_ADDR_OFFSET 0x800
1320#define OTG_DEVICE_EPTIN_ADDR_OFFSET 0x900
1321#define OTG_DEVICE_EPTOUT_ADDR_OFFSET 0xB00
1322#define OTG_PCGCCTL_ADDR_OFFSET 0xE00
1323#define OTG_FIFO_ADDR_OFFSET 0x1000
1328#define OTG1_GLOBAL ((otg_global_type *)(OTGFS1_BASE))
1329#define OTG2_GLOBAL ((otg_global_type *)(OTGFS2_BASE))
1330#define OTG_PCGCCTL(usbx) ((otg_pcgcctl_type *)((uint32_t)usbx + OTG_PCGCCTL_ADDR_OFFSET))
1331#define OTG_DEVICE(usbx) ((otg_device_type *)((uint32_t)usbx + OTG_DEVICE_ADDR_OFFSET))
1332#define OTG_HOST(usbx) ((otg_host_type *)((uint32_t)usbx + OTG_HOST_ADDR_OFFSET))
1333#define USB_CHL(usbx, n) ((otg_hchannel_type *)((uint32_t)usbx + OTG_HOST_CHANNEL_ADDR_OFFSET + n * 0x20))
1334#define USB_INEPT(usbx, eptn) ((otg_eptin_type *)((uint32_t)usbx + OTG_DEVICE_EPTIN_ADDR_OFFSET + eptn * 0x20))
1335#define USB_OUTEPT(usbx, eptn) ((otg_eptout_type *)((uint32_t)usbx + OTG_DEVICE_EPTOUT_ADDR_OFFSET + eptn * 0x20))
1336#define USB_FIFO(usbx, eptn) *(__IO uint32_t *)((uint32_t)usbx + OTG_FIFO_ADDR_OFFSET + eptn * 0x1000)
1340typedef otg_global_type usb_reg_type;
1341
1346#ifdef OTGFS_USB_GLOBAL
1347 error_status usb_global_reset(otg_global_type *usbx);
1348void usb_global_init(otg_global_type *usbx);
1349 otg_global_type *usb_global_select_core(uint8_t usb_id);
1350void usb_flush_tx_fifo(otg_global_type *usbx, uint32_t fifo_num);
1351void usb_flush_rx_fifo(otg_global_type *usbx);
1352void usb_global_interrupt_enable(otg_global_type *usbx, uint16_t interrupt, confirm_state new_state);
1353uint32_t usb_global_get_all_interrupt(otg_global_type *usbx);
1354void usb_global_clear_interrupt(otg_global_type *usbx, uint32_t flag);
1355void usb_interrupt_enable(otg_global_type *usbx);
1356void usb_interrupt_disable(otg_global_type *usbx);
1357void usb_set_rx_fifo(otg_global_type *usbx, uint16_t size);
1358void usb_set_tx_fifo(otg_global_type *usbx, uint8_t txfifo, uint16_t size);
1359void usb_global_set_mode(otg_global_type *usbx, uint32_t mode);
1360void usb_global_power_on(otg_global_type *usbx);
1361void usb_write_packet(otg_global_type *usbx, uint8_t *pusr_buf, uint16_t num, uint16_t nbytes);
1362void usb_read_packet(otg_global_type *usbx, uint8_t *pusr_buf, uint16_t num, uint16_t nbytes);
1363void usb_stop_phy_clk(otg_global_type *usbx);
1364void usb_open_phy_clk(otg_global_type *usbx);
1365#endif
1366
1367#ifdef OTGFS_USB_DEVICE
1368void usb_ept_open(otg_global_type *usbx, usb_ept_info *ept_info);
1369void usb_ept_close(otg_global_type *usbx, usb_ept_info *ept_info);
1370void usb_ept_stall(otg_global_type *usbx, usb_ept_info *ept_info);
1371void usb_ept_clear_stall(otg_global_type *usbx, usb_ept_info *ept_info);
1372uint32_t usb_get_all_out_interrupt(otg_global_type *usbx);
1373uint32_t usb_get_all_in_interrupt(otg_global_type *usbx);
1374uint32_t usb_ept_out_interrupt(otg_global_type *usbx, uint32_t eptn);
1375uint32_t usb_ept_in_interrupt(otg_global_type *usbx, uint32_t eptn);
1376void usb_ept_out_clear(otg_global_type *usbx, uint32_t eptn, uint32_t flag);
1377void usb_ept_in_clear(otg_global_type *usbx, uint32_t eptn, uint32_t flag);
1378void usb_set_address(otg_global_type *usbx, uint8_t address);
1379void usb_ept0_start(otg_global_type *usbx);
1380void usb_ept0_setup(otg_global_type *usbx);
1381void usb_connect(otg_global_type *usbx);
1382void usb_disconnect(otg_global_type *usbx);
1383void usb_remote_wkup_set(otg_global_type *usbx);
1384void usb_remote_wkup_clear(otg_global_type *usbx);
1385uint8_t usb_suspend_status_get(otg_global_type *usbx);
1386#endif
1387
1388#ifdef OTGFS_USB_HOST
1389void usb_port_power_on(otg_global_type *usbx, confirm_state state);
1390uint32_t usbh_get_frame(otg_global_type *usbx);
1391void usb_hc_enable(otg_global_type *usbx,
1392 uint8_t chn,
1393 uint8_t ept_num,
1394 uint8_t dev_address,
1395 uint8_t type,
1396 uint16_t maxpacket,
1397 uint8_t speed);
1398uint32_t usb_hch_read_interrupt(otg_global_type *usbx);
1399void usb_host_disable(otg_global_type *usbx);
1400void usb_hch_halt(otg_global_type *usbx, uint8_t chn);
1401void usbh_fsls_clksel(otg_global_type *usbx, uint8_t clk);
1402#endif
1419#ifdef __cplusplus
1420}
1421#endif
1422
1423#endif
at32f435_437.h
at32f435_437 header file
error_status
error_status
Definition: at32f435_437.h:380
confirm_state
confirm_state
Definition: at32f435_437.h:379
dcfg_perfrint_type
dcfg_perfrint_type
usb device periodic frame interval
Definition: at32f435_437_usb.h:251
DCFG_PERFRINT_85
@ DCFG_PERFRINT_85
Definition: at32f435_437_usb.h:253
DCFG_PERFRINT_90
@ DCFG_PERFRINT_90
Definition: at32f435_437_usb.h:254
DCFG_PERFRINT_80
@ DCFG_PERFRINT_80
Definition: at32f435_437_usb.h:252
DCFG_PERFRINT_95
@ DCFG_PERFRINT_95
Definition: at32f435_437_usb.h:255
endpoint_trans_type
endpoint_trans_type
endpoint type define
Definition: at32f435_437_usb.h:345
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f435_437_usb.h:402
usb_endpoint_number_type
usb_endpoint_number_type
usb endpoint number define type
Definition: at32f435_437_usb.h:356
otg_mode_type
otg_mode_type
usb mode define(device, host, drd)
Definition: at32f435_437_usb.h:335
endpoint_dir_type
endpoint_dir_type
usb endpoint max num define
Definition: at32f435_437_usb.h:384
otg_id_type
otg_id_type
otgfs1 and otgfs2 select type
Definition: at32f435_437_usb.h:393
EPT_ISO_TYPE
@ EPT_ISO_TYPE
Definition: at32f435_437_usb.h:347
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f435_437_usb.h:349
EPT_CONTROL_TYPE
@ EPT_CONTROL_TYPE
Definition: at32f435_437_usb.h:346
EPT_BULK_TYPE
@ EPT_BULK_TYPE
Definition: at32f435_437_usb.h:348
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f435_437_usb.h:404
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f435_437_usb.h:403
USB_EPT4
@ USB_EPT4
Definition: at32f435_437_usb.h:361
USB_EPT6
@ USB_EPT6
Definition: at32f435_437_usb.h:363
USB_EPT5
@ USB_EPT5
Definition: at32f435_437_usb.h:362
USB_EPT7
@ USB_EPT7
Definition: at32f435_437_usb.h:364
USB_EPT0
@ USB_EPT0
Definition: at32f435_437_usb.h:357
USB_EPT2
@ USB_EPT2
Definition: at32f435_437_usb.h:359
USB_EPT1
@ USB_EPT1
Definition: at32f435_437_usb.h:358
USB_EPT3
@ USB_EPT3
Definition: at32f435_437_usb.h:360
OTG_HOST_MODE
@ OTG_HOST_MODE
Definition: at32f435_437_usb.h:337
OTG_DRD_MODE
@ OTG_DRD_MODE
Definition: at32f435_437_usb.h:338
OTG_DEVICE_MODE
@ OTG_DEVICE_MODE
Definition: at32f435_437_usb.h:336
EPT_DIR_IN
@ EPT_DIR_IN
Definition: at32f435_437_usb.h:385
EPT_DIR_OUT
@ EPT_DIR_OUT
Definition: at32f435_437_usb.h:386
USB_OTG2_ID
@ USB_OTG2_ID
Definition: at32f435_437_usb.h:395
USB_OTG1_ID
@ USB_OTG1_ID
Definition: at32f435_437_usb.h:394
usbh_get_frame
uint32_t usbh_get_frame(otg_global_type *usbx)
get current frame number
Definition: at32f435_437_usb.c:868
usb_ept_open
void usb_ept_open(otg_global_type *usbx, usb_ept_info *ept_info)
open usb endpoint
Definition: at32f435_437_usb.c:473
usb_connect
void usb_connect(otg_global_type *usbx)
connect usb device by enable pull-up
Definition: at32f435_437_usb.c:771
usb_ept_out_clear
void usb_ept_out_clear(otg_global_type *usbx, uint32_t eptn, uint32_t flag)
clear out endpoint interrupt flag
Definition: at32f435_437_usb.c:690
usb_ept0_setup
void usb_ept0_setup(otg_global_type *usbx)
endpoint 0 start setup
Definition: at32f435_437_usb.c:757
usb_ept_in_clear
void usb_ept_in_clear(otg_global_type *usbx, uint32_t eptn, uint32_t flag)
clear in endpoint interrupt flag
Definition: at32f435_437_usb.c:711
usb_remote_wkup_clear
void usb_remote_wkup_clear(otg_global_type *usbx)
usb remote wakeup clear
Definition: at32f435_437_usb.c:813
usb_port_power_on
void usb_port_power_on(otg_global_type *usbx, confirm_state state)
usb port power on
Definition: at32f435_437_usb.c:842
usb_set_rx_fifo
void usb_set_rx_fifo(otg_global_type *usbx, uint16_t size)
usb set rx fifo size
Definition: at32f435_437_usb.c:294
usb_write_packet
void usb_write_packet(otg_global_type *usbx, uint8_t *pusr_buf, uint16_t num, uint16_t nbytes)
write data from user memory to usb buffer
Definition: at32f435_437_usb.c:422
usb_disconnect
void usb_disconnect(otg_global_type *usbx)
disconnect usb device by disable pull-up
Definition: at32f435_437_usb.c:785
usb_remote_wkup_set
void usb_remote_wkup_set(otg_global_type *usbx)
usb remote wakeup set
Definition: at32f435_437_usb.c:800
usb_global_set_mode
void usb_global_set_mode(otg_global_type *usbx, uint32_t mode)
set otg mode(device or host mode)
Definition: at32f435_437_usb.c:344
usb_set_tx_fifo
void usb_set_tx_fifo(otg_global_type *usbx, uint8_t txfifo, uint16_t size)
usb set tx fifo size
Definition: at32f435_437_usb.c:309
usb_flush_rx_fifo
void usb_flush_rx_fifo(otg_global_type *usbx)
flush rx fifo
Definition: at32f435_437_usb.c:150
usb_global_interrupt_enable
void usb_global_interrupt_enable(otg_global_type *usbx, uint16_t interrupt, confirm_state new_state)
usb interrupt mask enable
Definition: at32f435_437_usb.c:196
usb_global_clear_interrupt
void usb_global_clear_interrupt(otg_global_type *usbx, uint32_t flag)
clear the global interrupt flag
Definition: at32f435_437_usb.c:255
usb_suspend_status_get
uint8_t usb_suspend_status_get(otg_global_type *usbx)
usb suspend status get
Definition: at32f435_437_usb.c:826
usb_ept_clear_stall
void usb_ept_clear_stall(otg_global_type *usbx, usb_ept_info *ept_info)
clear endpoint tx or rx status to stall
Definition: at32f435_437_usb.c:592
usb_ept0_start
void usb_ept0_start(otg_global_type *usbx)
enable endpoint 0 out
Definition: at32f435_437_usb.c:739
usb_set_address
void usb_set_address(otg_global_type *usbx, uint8_t address)
set the host assignment address
Definition: at32f435_437_usb.c:726
usb_flush_tx_fifo
void usb_flush_tx_fifo(otg_global_type *usbx, uint32_t fifo_num)
flush tx fifo
Definition: at32f435_437_usb.c:124
usbh_fsls_clksel
void usbh_fsls_clksel(otg_global_type *usbx, uint8_t clk)
select full or low speed clock
Definition: at32f435_437_usb.c:1068
usb_ept_out_interrupt
uint32_t usb_ept_out_interrupt(otg_global_type *usbx, uint32_t eptn)
get out endpoint interrupt flag
Definition: at32f435_437_usb.c:650
usb_interrupt_disable
void usb_interrupt_disable(otg_global_type *usbx)
usb global interrupt disable
Definition: at32f435_437_usb.c:280
usb_hch_read_interrupt
uint32_t usb_hch_read_interrupt(otg_global_type *usbx)
host read channel interrupt
Definition: at32f435_437_usb.c:954
usb_ept_close
void usb_ept_close(otg_global_type *usbx, usb_ept_info *ept_info)
close usb endpoint
Definition: at32f435_437_usb.c:539
usb_hc_enable
void usb_hc_enable(otg_global_type *usbx, uint8_t chn, uint8_t ept_num, uint8_t dev_address, uint8_t type, uint16_t maxpacket, uint8_t speed)
enable one host channel
Definition: at32f435_437_usb.c:896
usb_stop_phy_clk
void usb_stop_phy_clk(otg_global_type *usbx)
usb stop phy clock
Definition: at32f435_437_usb.c:396
usb_global_get_all_interrupt
uint32_t usb_global_get_all_interrupt(otg_global_type *usbx)
get all global core interrupt flag
Definition: at32f435_437_usb.c:216
usb_reg_type
otg_global_type usb_reg_type
Definition: at32f435_437_usb.h:1340
usb_interrupt_enable
void usb_interrupt_enable(otg_global_type *usbx)
usb global interrupt enable
Definition: at32f435_437_usb.c:267
usb_get_all_out_interrupt
uint32_t usb_get_all_out_interrupt(otg_global_type *usbx)
get all out endpoint interrupt bits
Definition: at32f435_437_usb.c:620
usb_ept_in_interrupt
uint32_t usb_ept_in_interrupt(otg_global_type *usbx, uint32_t eptn)
get in endpoint interrupt flag
Definition: at32f435_437_usb.c:665
usb_get_all_in_interrupt
uint32_t usb_get_all_in_interrupt(otg_global_type *usbx)
get all in endpoint interrupt bits
Definition: at32f435_437_usb.c:634
usb_global_power_on
void usb_global_power_on(otg_global_type *usbx)
disable the transceiver power down mode
Definition: at32f435_437_usb.c:377
usb_open_phy_clk
void usb_open_phy_clk(otg_global_type *usbx)
usb open phy clock
Definition: at32f435_437_usb.c:409
usb_global_reset
error_status usb_global_reset(otg_global_type *usbx)
usb global core soft reset
Definition: at32f435_437_usb.c:53
usb_ept_stall
void usb_ept_stall(otg_global_type *usbx, usb_ept_info *ept_info)
set endpoint tx or rx status to stall
Definition: at32f435_437_usb.c:563
usb_hch_halt
void usb_hch_halt(otg_global_type *usbx, uint8_t chn)
halt channel
Definition: at32f435_437_usb.c:1012
usb_read_packet
void usb_read_packet(otg_global_type *usbx, uint8_t *pusr_buf, uint16_t num, uint16_t nbytes)
read data from usb buffer to user buffer
Definition: at32f435_437_usb.c:445
usb_global_select_core
otg_global_type * usb_global_select_core(uint8_t usb_id)
usb global select usb core (otg1 or otg2).
Definition: at32f435_437_usb.c:100
usb_global_init
void usb_global_init(otg_global_type *usbx)
usb global initialization
Definition: at32f435_437_usb.c:83
usb_host_disable
void usb_host_disable(otg_global_type *usbx)
disable host
Definition: at32f435_437_usb.c:968
otg_device_type
Definition: at32f435_437_usb.h:996
otg_device_type::diepempmsk
__IO uint32_t diepempmsk
Definition: at32f435_437_usb.h:1131
otg_device_type::outperrmsk
__IO uint32_t outperrmsk
Definition: at32f435_437_usb.h:1092
otg_device_type::pwroprgdne
__IO uint32_t pwroprgdne
Definition: at32f435_437_usb.h:1031
otg_device_type::outtepdmsk
__IO uint32_t outtepdmsk
Definition: at32f435_437_usb.h:1088
otg_device_type::tstctl
__IO uint32_t tstctl
Definition: at32f435_437_usb.h:1026
otg_device_type::sftdiscon
__IO uint32_t sftdiscon
Definition: at32f435_437_usb.h:1023
otg_device_type::txfifoudrmsk
__IO uint32_t txfifoudrmsk
Definition: at32f435_437_usb.h:1070
otg_device_type::outeptmsk
__IO uint32_t outeptmsk
Definition: at32f435_437_usb.h:1120
otg_device_type::timeoutmsk
__IO uint32_t timeoutmsk
Definition: at32f435_437_usb.h:1065
otg_device_type::devspd
__IO uint32_t devspd
Definition: at32f435_437_usb.h:1005
otg_device_type::eptdismsk
__IO uint32_t eptdismsk
Definition: at32f435_437_usb.h:1063
otg_device_type::eticerr
__IO uint32_t eticerr
Definition: at32f435_437_usb.h:1046
otg_device_type::ineptint
__IO uint32_t ineptint
Definition: at32f435_437_usb.h:1106
otg_device_type::dctl
__IO uint32_t dctl
Definition: at32f435_437_usb.h:1019
otg_device_type::bnaoutmsk
__IO uint32_t bnaoutmsk
Definition: at32f435_437_usb.h:1093
otg_device_type::cgnpinak
__IO uint32_t cgnpinak
Definition: at32f435_437_usb.h:1028
otg_device_type::perfrint
__IO uint32_t perfrint
Definition: at32f435_437_usb.h:1009
otg_device_type::xfercmsk
__IO uint32_t xfercmsk
Definition: at32f435_437_usb.h:1062
otg_device_type::sgnpinak
__IO uint32_t sgnpinak
Definition: at32f435_437_usb.h:1027
otg_device_type::intkneptmismsk
__IO uint32_t intkneptmismsk
Definition: at32f435_437_usb.h:1067
otg_device_type::reserved4
__IO uint32_t reserved4
Definition: at32f435_437_usb.h:1094
otg_device_type::devaddr
__IO uint32_t devaddr
Definition: at32f435_437_usb.h:1008
otg_device_type::suspsts
__IO uint32_t suspsts
Definition: at32f435_437_usb.h:1044
otg_device_type::rwkupsig
__IO uint32_t rwkupsig
Definition: at32f435_437_usb.h:1022
otg_device_type::intkntxfempmsk
__IO uint32_t intkntxfempmsk
Definition: at32f435_437_usb.h:1066
otg_device_type::dsts
__IO uint32_t dsts
Definition: at32f435_437_usb.h:1041
otg_device_type::ineptmsk
__IO uint32_t ineptmsk
Definition: at32f435_437_usb.h:1119
otg_device_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_usb.h:1010
otg_device_type::bnainmsk
__IO uint32_t bnainmsk
Definition: at32f435_437_usb.h:1071
otg_device_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_usb.h:1007
otg_device_type::ineptnakmsk
__IO uint32_t ineptnakmsk
Definition: at32f435_437_usb.h:1068
otg_device_type::nzstsouthshk
__IO uint32_t nzstsouthshk
Definition: at32f435_437_usb.h:1006
otg_device_type::goutnaksts
__IO uint32_t goutnaksts
Definition: at32f435_437_usb.h:1025
otg_device_type::enumspd
__IO uint32_t enumspd
Definition: at32f435_437_usb.h:1045
otg_device_type::gnpinnaksts
__IO uint32_t gnpinnaksts
Definition: at32f435_437_usb.h:1024
otg_device_type::setupmsk
__IO uint32_t setupmsk
Definition: at32f435_437_usb.h:1087
otg_device_type::b2bsetupmsk
__IO uint32_t b2bsetupmsk
Definition: at32f435_437_usb.h:1090
otg_device_type::dcfg
__IO uint32_t dcfg
Definition: at32f435_437_usb.h:1002
otg_device_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_usb.h:1072
otg_device_type::soffn
__IO uint32_t soffn
Definition: at32f435_437_usb.h:1048
otg_device_type::doepmsk
__IO uint32_t doepmsk
Definition: at32f435_437_usb.h:1081
otg_device_type::cgoutnak
__IO uint32_t cgoutnak
Definition: at32f435_437_usb.h:1030
otg_device_type::daintmsk
__IO uint32_t daintmsk
Definition: at32f435_437_usb.h:1116
otg_device_type::diepmsk
__IO uint32_t diepmsk
Definition: at32f435_437_usb.h:1059
otg_device_type::sgoutnak
__IO uint32_t sgoutnak
Definition: at32f435_437_usb.h:1029
otg_device_type::daint
__IO uint32_t daint
Definition: at32f435_437_usb.h:1103
otg_device_type::outeptint
__IO uint32_t outeptint
Definition: at32f435_437_usb.h:1107
otg_device_type::ineptxfemsk
__IO uint32_t ineptxfemsk
Definition: at32f435_437_usb.h:1134
otg_eptin_type
Definition: at32f435_437_usb.h:1142
otg_eptin_type::txfnum
__IO uint32_t txfnum
Definition: at32f435_437_usb.h:1159
otg_eptin_type::xfersize
__IO uint32_t xfersize
Definition: at32f435_437_usb.h:1199
otg_eptin_type::snak
__IO uint32_t snak
Definition: at32f435_437_usb.h:1161
otg_eptin_type::eptena
__IO uint32_t eptena
Definition: at32f435_437_usb.h:1165
otg_eptin_type::setd1pid
__IO uint32_t setd1pid
Definition: at32f435_437_usb.h:1163
otg_eptin_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_usb.h:1152
otg_eptin_type::mps
__IO uint32_t mps
Definition: at32f435_437_usb.h:1151
otg_eptin_type::txfemp
__IO uint32_t txfemp
Definition: at32f435_437_usb.h:1185
otg_eptin_type::dpid
__IO uint32_t dpid
Definition: at32f435_437_usb.h:1154
otg_eptin_type::ineptnak
__IO uint32_t ineptnak
Definition: at32f435_437_usb.h:1184
otg_eptin_type::dieptsiz
__IO uint32_t dieptsiz
Definition: at32f435_437_usb.h:1196
otg_eptin_type::epdisd
__IO uint32_t epdisd
Definition: at32f435_437_usb.h:1179
otg_eptin_type::diepint
__IO uint32_t diepint
Definition: at32f435_437_usb.h:1175
otg_eptin_type::intkntxfemp
__IO uint32_t intkntxfemp
Definition: at32f435_437_usb.h:1182
otg_eptin_type::setd0pid
__IO uint32_t setd0pid
Definition: at32f435_437_usb.h:1162
otg_eptin_type::dtxfsts
__IO uint32_t dtxfsts
Definition: at32f435_437_usb.h:1213
otg_eptin_type::naksts
__IO uint32_t naksts
Definition: at32f435_437_usb.h:1155
otg_eptin_type::diepctl
__IO uint32_t diepctl
Definition: at32f435_437_usb.h:1148
otg_eptin_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_usb.h:1186
otg_eptin_type::xferc
__IO uint32_t xferc
Definition: at32f435_437_usb.h:1178
otg_eptin_type::cnak
__IO uint32_t cnak
Definition: at32f435_437_usb.h:1160
otg_eptin_type::eptype
__IO uint32_t eptype
Definition: at32f435_437_usb.h:1156
otg_eptin_type::pktcnt
__IO uint32_t pktcnt
Definition: at32f435_437_usb.h:1200
otg_eptin_type::stall
__IO uint32_t stall
Definition: at32f435_437_usb.h:1158
otg_eptin_type::eptdis
__IO uint32_t eptdis
Definition: at32f435_437_usb.h:1164
otg_eptin_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_usb.h:1157
otg_eptin_type::mc
__IO uint32_t mc
Definition: at32f435_437_usb.h:1201
otg_eptin_type::usbacept
__IO uint32_t usbacept
Definition: at32f435_437_usb.h:1153
otg_eptin_type::timeout
__IO uint32_t timeout
Definition: at32f435_437_usb.h:1181
otg_eptin_type::ineptxfsav
__IO uint32_t ineptxfsav
Definition: at32f435_437_usb.h:1216
otg_eptout_type
Definition: at32f435_437_usb.h:1224
otg_eptout_type::eptype
__IO uint32_t eptype
Definition: at32f435_437_usb.h:1238
otg_eptout_type::rxdpid_setupcnt
__IO uint32_t rxdpid_setupcnt
Definition: at32f435_437_usb.h:1282
otg_eptout_type::epdisd
__IO uint32_t epdisd
Definition: at32f435_437_usb.h:1261
otg_eptout_type::xferc
__IO uint32_t xferc
Definition: at32f435_437_usb.h:1260
otg_eptout_type::setup
__IO uint32_t setup
Definition: at32f435_437_usb.h:1263
otg_eptout_type::dpid
__IO uint32_t dpid
Definition: at32f435_437_usb.h:1236
otg_eptout_type::naksts
__IO uint32_t naksts
Definition: at32f435_437_usb.h:1237
otg_eptout_type::eptdis
__IO uint32_t eptdis
Definition: at32f435_437_usb.h:1246
otg_eptout_type::pktcnt
__IO uint32_t pktcnt
Definition: at32f435_437_usb.h:1281
otg_eptout_type::setd1pid
__IO uint32_t setd1pid
Definition: at32f435_437_usb.h:1245
otg_eptout_type::eptena
__IO uint32_t eptena
Definition: at32f435_437_usb.h:1247
otg_eptout_type::setd0pid
__IO uint32_t setd0pid
Definition: at32f435_437_usb.h:1244
otg_eptout_type::cnak
__IO uint32_t cnak
Definition: at32f435_437_usb.h:1242
otg_eptout_type::mps
__IO uint32_t mps
Definition: at32f435_437_usb.h:1233
otg_eptout_type::outtepd
__IO uint32_t outtepd
Definition: at32f435_437_usb.h:1264
otg_eptout_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_usb.h:1241
otg_eptout_type::doeptsiz
__IO uint32_t doeptsiz
Definition: at32f435_437_usb.h:1277
otg_eptout_type::stall
__IO uint32_t stall
Definition: at32f435_437_usb.h:1240
otg_eptout_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_usb.h:1234
otg_eptout_type::snak
__IO uint32_t snak
Definition: at32f435_437_usb.h:1243
otg_eptout_type::doepint
__IO uint32_t doepint
Definition: at32f435_437_usb.h:1257
otg_eptout_type::usbacept
__IO uint32_t usbacept
Definition: at32f435_437_usb.h:1235
otg_eptout_type::snpm
__IO uint32_t snpm
Definition: at32f435_437_usb.h:1239
otg_eptout_type::b2pstup
__IO uint32_t b2pstup
Definition: at32f435_437_usb.h:1266
otg_eptout_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_usb.h:1267
otg_eptout_type::doepctl
__IO uint32_t doepctl
Definition: at32f435_437_usb.h:1230
otg_eptout_type::xfersize
__IO uint32_t xfersize
Definition: at32f435_437_usb.h:1280
otg_global_type
Definition: at32f435_437_usb.h:474
otg_global_type::hchintmsk
__IO uint32_t hchintmsk
Definition: at32f435_437_usb.h:630
otg_global_type::otgintmsk
__IO uint32_t otgintmsk
Definition: at32f435_437_usb.h:610
otg_global_type::incompisoin
__IO uint32_t incompisoin
Definition: at32f435_437_usb.h:586
otg_global_type::gotgctrl
__IO uint32_t gotgctrl
Definition: at32f435_437_usb.h:480
otg_global_type::gahbcfg
__IO uint32_t gahbcfg
Definition: at32f435_437_usb.h:511
otg_global_type::curmod
__IO uint32_t curmod
Definition: at32f435_437_usb.h:486
otg_global_type::txfnum
__IO uint32_t txfnum
Definition: at32f435_437_usb.h:554
otg_global_type::incompip_incompisoout
__IO uint32_t incompip_incompisoout
Definition: at32f435_437_usb.h:587
otg_global_type::usbrst
__IO uint32_t usbrst
Definition: at32f435_437_usb.h:579
otg_global_type::cotxpkt
__IO uint32_t cotxpkt
Definition: at32f435_437_usb.h:536
otg_global_type::reserved4
__IO uint32_t reserved4
Definition: at32f435_437_usb.h:592
otg_global_type::conidschgmsk
__IO uint32_t conidschgmsk
Definition: at32f435_437_usb.h:633
otg_global_type::erlysuspmsk
__IO uint32_t erlysuspmsk
Definition: at32f435_437_usb.h:617
otg_global_type::fhstmode
__IO uint32_t fhstmode
Definition: at32f435_437_usb.h:534
otg_global_type::oeptintmsk
__IO uint32_t oeptintmsk
Definition: at32f435_437_usb.h:625
otg_global_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_usb.h:485
otg_global_type::pktsts
__IO uint32_t pktsts
Definition: at32f435_437_usb.h:651
otg_global_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_usb.h:483
otg_global_type::isooutdrop
__IO uint32_t isooutdrop
Definition: at32f435_437_usb.h:581
otg_global_type::incompip_incompisooutmsk
__IO uint32_t incompip_incompisooutmsk
Definition: at32f435_437_usb.h:627
otg_global_type::piusftrst
__IO uint32_t piusftrst
Definition: at32f435_437_usb.h:549
otg_global_type::guid
__IO uint32_t guid
Definition: at32f435_437_usb.h:738
otg_global_type::csftrst
__IO uint32_t csftrst
Definition: at32f435_437_usb.h:548
otg_global_type::rxflvl
__IO uint32_t rxflvl
Definition: at32f435_437_usb.h:572
otg_global_type::vbusig
__IO uint32_t vbusig
Definition: at32f435_437_usb.h:728
otg_global_type::curmode
__IO uint32_t curmode
Definition: at32f435_437_usb.h:568
otg_global_type::ptxfsize
__IO uint32_t ptxfsize
Definition: at32f435_437_usb.h:756
otg_global_type::modemismsk
__IO uint32_t modemismsk
Definition: at32f435_437_usb.h:609
otg_global_type::hptxfsiz
__IO uint32_t hptxfsiz
Definition: at32f435_437_usb.h:752
otg_global_type::fn
__IO uint32_t fn
Definition: at32f435_437_usb.h:652
otg_global_type::eptnum
__IO uint32_t eptnum
Definition: at32f435_437_usb.h:648
otg_global_type::pwrdown
__IO uint32_t pwrdown
Definition: at32f435_437_usb.h:724
otg_global_type::goutnakeffmsk
__IO uint32_t goutnakeffmsk
Definition: at32f435_437_usb.h:615
otg_global_type::prtint
__IO uint32_t prtint
Definition: at32f435_437_usb.h:589
otg_global_type::gusbcfg
__IO uint32_t gusbcfg
Definition: at32f435_437_usb.h:527
otg_global_type::rxfdep
__IO uint32_t rxfdep
Definition: at32f435_437_usb.h:681
otg_global_type::conidschg
__IO uint32_t conidschg
Definition: at32f435_437_usb.h:593
otg_global_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_usb.h:487
otg_global_type::disconint
__IO uint32_t disconint
Definition: at32f435_437_usb.h:594
otg_global_type::nptxfempmsk
__IO uint32_t nptxfempmsk
Definition: at32f435_437_usb.h:613
otg_global_type::modemis
__IO uint32_t modemis
Definition: at32f435_437_usb.h:569
otg_global_type::nptxfdep
__IO uint32_t nptxfdep
Definition: at32f435_437_usb.h:695
otg_global_type::gccfg
__IO uint32_t gccfg
Definition: at32f435_437_usb.h:720
otg_global_type::sofouten
__IO uint32_t sofouten
Definition: at32f435_437_usb.h:727
otg_global_type::glbintmsk
__IO uint32_t glbintmsk
Definition: at32f435_437_usb.h:514
otg_global_type::usbsuspmsk
__IO uint32_t usbsuspmsk
Definition: at32f435_437_usb.h:618
otg_global_type::ptxfemplvl
__IO uint32_t ptxfemplvl
Definition: at32f435_437_usb.h:517
otg_global_type::nptxqtop
__IO uint32_t nptxqtop
Definition: at32f435_437_usb.h:709
otg_global_type::txfflsh
__IO uint32_t txfflsh
Definition: at32f435_437_usb.h:553
otg_global_type::nptxfspcavail
__IO uint32_t nptxfspcavail
Definition: at32f435_437_usb.h:707
otg_global_type::dpid
__IO uint32_t dpid
Definition: at32f435_437_usb.h:650
otg_global_type::ptxfempmsk
__IO uint32_t ptxfempmsk
Definition: at32f435_437_usb.h:631
otg_global_type::gnptxfsiz_ept0tx
__IO uint32_t gnptxfsiz_ept0tx
Definition: at32f435_437_usb.h:691
otg_global_type::ieptintmsk
__IO uint32_t ieptintmsk
Definition: at32f435_437_usb.h:624
otg_global_type::sofmsk
__IO uint32_t sofmsk
Definition: at32f435_437_usb.h:611
otg_global_type::usbsusp
__IO uint32_t usbsusp
Definition: at32f435_437_usb.h:578
otg_global_type::fdevmode
__IO uint32_t fdevmode
Definition: at32f435_437_usb.h:535
otg_global_type::grxfsiz
__IO uint32_t grxfsiz
Definition: at32f435_437_usb.h:678
otg_global_type::toutcal
__IO uint32_t toutcal
Definition: at32f435_437_usb.h:530
otg_global_type::oeptint
__IO uint32_t oeptint
Definition: at32f435_437_usb.h:585
otg_global_type::ineptxfdep
__IO uint32_t ineptxfdep
Definition: at32f435_437_usb.h:769
otg_global_type::rxflvlmsk
__IO uint32_t rxflvlmsk
Definition: at32f435_437_usb.h:612
otg_global_type::eopfmsk
__IO uint32_t eopfmsk
Definition: at32f435_437_usb.h:622
otg_global_type::gotgint
__IO uint32_t gotgint
Definition: at32f435_437_usb.h:496
otg_global_type::ieptint
__IO uint32_t ieptint
Definition: at32f435_437_usb.h:584
otg_global_type::enumdone
__IO uint32_t enumdone
Definition: at32f435_437_usb.h:580
otg_global_type::grxstsr
__IO uint32_t grxstsr
Definition: at32f435_437_usb.h:645
otg_global_type::nptxfemp
__IO uint32_t nptxfemp
Definition: at32f435_437_usb.h:573
otg_global_type::chnum
__IO uint32_t chnum
Definition: at32f435_437_usb.h:665
otg_global_type::nptxfstaddr
__IO uint32_t nptxfstaddr
Definition: at32f435_437_usb.h:694
otg_global_type::ptxfemp
__IO uint32_t ptxfemp
Definition: at32f435_437_usb.h:591
otg_global_type::ptxfstaddr
__IO uint32_t ptxfstaddr
Definition: at32f435_437_usb.h:755
otg_global_type::usbrstmsk
__IO uint32_t usbrstmsk
Definition: at32f435_437_usb.h:619
otg_global_type::enumdonemsk
__IO uint32_t enumdonemsk
Definition: at32f435_437_usb.h:620
otg_global_type::erlysusp
__IO uint32_t erlysusp
Definition: at32f435_437_usb.h:577
otg_global_type::sesenddet
__IO uint32_t sesenddet
Definition: at32f435_437_usb.h:500
otg_global_type::disconintmsk
__IO uint32_t disconintmsk
Definition: at32f435_437_usb.h:634
otg_global_type::reserved6
__IO uint32_t reserved6
Definition: at32f435_437_usb.h:635
otg_global_type::incompisoinmsk
__IO uint32_t incompisoinmsk
Definition: at32f435_437_usb.h:626
otg_global_type::grstctl
__IO uint32_t grstctl
Definition: at32f435_437_usb.h:545
otg_global_type::ahbidle
__IO uint32_t ahbidle
Definition: at32f435_437_usb.h:556
otg_global_type::otgint
__IO uint32_t otgint
Definition: at32f435_437_usb.h:570
otg_global_type::hchint
__IO uint32_t hchint
Definition: at32f435_437_usb.h:590
otg_global_type::usbtrdtim
__IO uint32_t usbtrdtim
Definition: at32f435_437_usb.h:532
otg_global_type::nptxfemplvl
__IO uint32_t nptxfemplvl
Definition: at32f435_437_usb.h:516
otg_global_type::wkupintmsk
__IO uint32_t wkupintmsk
Definition: at32f435_437_usb.h:636
otg_global_type::gintsts
__IO uint32_t gintsts
Definition: at32f435_437_usb.h:565
otg_global_type::frmcntrst
__IO uint32_t frmcntrst
Definition: at32f435_437_usb.h:550
otg_global_type::rxfflsh
__IO uint32_t rxfflsh
Definition: at32f435_437_usb.h:552
otg_global_type::ineptxfstaddr
__IO uint32_t ineptxfstaddr
Definition: at32f435_437_usb.h:768
otg_global_type::ginnakeffmsk
__IO uint32_t ginnakeffmsk
Definition: at32f435_437_usb.h:614
otg_global_type::prtintmsk
__IO uint32_t prtintmsk
Definition: at32f435_437_usb.h:629
otg_global_type::bcnt
__IO uint32_t bcnt
Definition: at32f435_437_usb.h:649
otg_global_type::grxstsp
__IO uint32_t grxstsp
Definition: at32f435_437_usb.h:662
otg_global_type::sof
__IO uint32_t sof
Definition: at32f435_437_usb.h:571
otg_global_type::isooutdropmsk
__IO uint32_t isooutdropmsk
Definition: at32f435_437_usb.h:621
otg_global_type::goutnakeff
__IO uint32_t goutnakeff
Definition: at32f435_437_usb.h:575
otg_global_type::lp_mode
__IO uint32_t lp_mode
Definition: at32f435_437_usb.h:725
otg_global_type::eopf
__IO uint32_t eopf
Definition: at32f435_437_usb.h:582
otg_global_type::gintmsk
__IO uint32_t gintmsk
Definition: at32f435_437_usb.h:605
otg_global_type::nptxqspcavail
__IO uint32_t nptxqspcavail
Definition: at32f435_437_usb.h:708
otg_global_type::gnptxsts
__IO uint32_t gnptxsts
Definition: at32f435_437_usb.h:704
otg_global_type::wkupint
__IO uint32_t wkupint
Definition: at32f435_437_usb.h:596
otg_global_type::ginnakeff
__IO uint32_t ginnakeff
Definition: at32f435_437_usb.h:574
otg_global_type::reserved5
__IO uint32_t reserved5
Definition: at32f435_437_usb.h:595
otg_global_type::cidsts
__IO uint32_t cidsts
Definition: at32f435_437_usb.h:484
otg_global_type::userid
__IO uint32_t userid
Definition: at32f435_437_usb.h:741
otg_hchannel_type
Definition: at32f435_437_usb.h:890
otg_hchannel_type::bblerr
__IO uint32_t bblerr
Definition: at32f435_437_usb.h:946
otg_hchannel_type::xfersize
__IO uint32_t xfersize
Definition: at32f435_437_usb.h:984
otg_hchannel_type::frmovrun
__IO uint32_t frmovrun
Definition: at32f435_437_usb.h:947
otg_hchannel_type::xacterrmsk
__IO uint32_t xacterrmsk
Definition: at32f435_437_usb.h:968
otg_hchannel_type::ackmsk
__IO uint32_t ackmsk
Definition: at32f435_437_usb.h:966
otg_hchannel_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_usb.h:944
otg_hchannel_type::prtaddr
__IO uint32_t prtaddr
Definition: at32f435_437_usb.h:921
otg_hchannel_type::hcint
__IO uint32_t hcint
Definition: at32f435_437_usb.h:935
otg_hchannel_type::devaddr
__IO uint32_t devaddr
Definition: at32f435_437_usb.h:906
otg_hchannel_type::eptnum
__IO uint32_t eptnum
Definition: at32f435_437_usb.h:900
otg_hchannel_type::nakmsk
__IO uint32_t nakmsk
Definition: at32f435_437_usb.h:965
otg_hchannel_type::stallmsk
__IO uint32_t stallmsk
Definition: at32f435_437_usb.h:964
otg_hchannel_type::eptdir
__IO uint32_t eptdir
Definition: at32f435_437_usb.h:901
otg_hchannel_type::mc
__IO uint32_t mc
Definition: at32f435_437_usb.h:905
otg_hchannel_type::chhltdmsk
__IO uint32_t chhltdmsk
Definition: at32f435_437_usb.h:962
otg_hchannel_type::oddfrm
__IO uint32_t oddfrm
Definition: at32f435_437_usb.h:907
otg_hchannel_type::chena
__IO uint32_t chena
Definition: at32f435_437_usb.h:909
otg_hchannel_type::xacterr
__IO uint32_t xacterr
Definition: at32f435_437_usb.h:945
otg_hchannel_type::hctsiz
__IO uint32_t hctsiz
Definition: at32f435_437_usb.h:981
otg_hchannel_type::hcchar
__IO uint32_t hcchar
Definition: at32f435_437_usb.h:896
otg_hchannel_type::chhltd
__IO uint32_t chhltd
Definition: at32f435_437_usb.h:939
otg_hchannel_type::xfercmsk
__IO uint32_t xfercmsk
Definition: at32f435_437_usb.h:961
otg_hchannel_type::chdis
__IO uint32_t chdis
Definition: at32f435_437_usb.h:908
otg_hchannel_type::hcintmsk
__IO uint32_t hcintmsk
Definition: at32f435_437_usb.h:958
otg_hchannel_type::dtglerrmsk
__IO uint32_t dtglerrmsk
Definition: at32f435_437_usb.h:971
otg_hchannel_type::compsplt
__IO uint32_t compsplt
Definition: at32f435_437_usb.h:924
otg_hchannel_type::dtglerr
__IO uint32_t dtglerr
Definition: at32f435_437_usb.h:948
otg_hchannel_type::mps
__IO uint32_t mps
Definition: at32f435_437_usb.h:899
otg_hchannel_type::bblerrmsk
__IO uint32_t bblerrmsk
Definition: at32f435_437_usb.h:969
otg_hchannel_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_usb.h:902
otg_hchannel_type::eptype
__IO uint32_t eptype
Definition: at32f435_437_usb.h:904
otg_hchannel_type::xactpos
__IO uint32_t xactpos
Definition: at32f435_437_usb.h:923
otg_hchannel_type::nak
__IO uint32_t nak
Definition: at32f435_437_usb.h:942
otg_hchannel_type::pktcnt
__IO uint32_t pktcnt
Definition: at32f435_437_usb.h:985
otg_hchannel_type::lspddev
__IO uint32_t lspddev
Definition: at32f435_437_usb.h:903
otg_hchannel_type::stall
__IO uint32_t stall
Definition: at32f435_437_usb.h:941
otg_hchannel_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_usb.h:949
otg_hchannel_type::frmovrunmsk
__IO uint32_t frmovrunmsk
Definition: at32f435_437_usb.h:970
otg_hchannel_type::pid
__IO uint32_t pid
Definition: at32f435_437_usb.h:986
otg_hchannel_type::xferc
__IO uint32_t xferc
Definition: at32f435_437_usb.h:938
otg_hchannel_type::hcsplt
__IO uint32_t hcsplt
Definition: at32f435_437_usb.h:918
otg_hchannel_type::hubaddr
__IO uint32_t hubaddr
Definition: at32f435_437_usb.h:922
otg_hchannel_type::spltena
__IO uint32_t spltena
Definition: at32f435_437_usb.h:926
otg_hchannel_type::ack
__IO uint32_t ack
Definition: at32f435_437_usb.h:943
otg_host_type
Definition: at32f435_437_usb.h:776
otg_host_type::hprt
__IO uint32_t hprt
Definition: at32f435_437_usb.h:866
otg_host_type::haintmsk
__IO uint32_t haintmsk
Definition: at32f435_437_usb.h:851
otg_host_type::prtlnsts
__IO uint32_t prtlnsts
Definition: at32f435_437_usb.h:879
otg_host_type::prtsusp
__IO uint32_t prtsusp
Definition: at32f435_437_usb.h:876
otg_host_type::haint
__IO uint32_t haint
Definition: at32f435_437_usb.h:838
otg_host_type::fslspclksel
__IO uint32_t fslspclksel
Definition: at32f435_437_usb.h:785
otg_host_type::prttsctl
__IO uint32_t prttsctl
Definition: at32f435_437_usb.h:881
otg_host_type::prtenchng
__IO uint32_t prtenchng
Definition: at32f435_437_usb.h:872
otg_host_type::prtovrcchng
__IO uint32_t prtovrcchng
Definition: at32f435_437_usb.h:874
otg_host_type::fslssupp
__IO uint32_t fslssupp
Definition: at32f435_437_usb.h:786
otg_host_type::prtena
__IO uint32_t prtena
Definition: at32f435_437_usb.h:871
otg_host_type::prtspd
__IO uint32_t prtspd
Definition: at32f435_437_usb.h:882
otg_host_type::ptxqtop
__IO uint32_t ptxqtop
Definition: at32f435_437_usb.h:829
otg_host_type::ptxfspcavil
__IO uint32_t ptxfspcavil
Definition: at32f435_437_usb.h:827
otg_host_type::hfnum
__IO uint32_t hfnum
Definition: at32f435_437_usb.h:809
otg_host_type::prtovrcact
__IO uint32_t prtovrcact
Definition: at32f435_437_usb.h:873
otg_host_type::prtpwr
__IO uint32_t prtpwr
Definition: at32f435_437_usb.h:880
otg_host_type::ptxqspcavil
__IO uint32_t ptxqspcavil
Definition: at32f435_437_usb.h:828
otg_host_type::hcfg
__IO uint32_t hcfg
Definition: at32f435_437_usb.h:782
otg_host_type::hfir
__IO uint32_t hfir
Definition: at32f435_437_usb.h:796
otg_host_type::ftrem
__IO uint32_t ftrem
Definition: at32f435_437_usb.h:813
otg_host_type::frint
__IO uint32_t frint
Definition: at32f435_437_usb.h:799
otg_host_type::prtrst
__IO uint32_t prtrst
Definition: at32f435_437_usb.h:877
otg_host_type::prtcondet
__IO uint32_t prtcondet
Definition: at32f435_437_usb.h:870
otg_host_type::prtconsts
__IO uint32_t prtconsts
Definition: at32f435_437_usb.h:869
otg_host_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_usb.h:787
otg_host_type::hptxsts
__IO uint32_t hptxsts
Definition: at32f435_437_usb.h:824
otg_host_type::prtres
__IO uint32_t prtres
Definition: at32f435_437_usb.h:875
otg_host_type::frnum
__IO uint32_t frnum
Definition: at32f435_437_usb.h:812
otg_pcgcctl_type
Definition: at32f435_437_usb.h:1289
otg_pcgcctl_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_usb.h:1301
otg_pcgcctl_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_usb.h:1299
otg_pcgcctl_type::suspendm
__IO uint32_t suspendm
Definition: at32f435_437_usb.h:1300
otg_pcgcctl_type::pcgcctl
__IO uint32_t pcgcctl
Definition: at32f435_437_usb.h:1295
otg_pcgcctl_type::stoppclk
__IO uint32_t stoppclk
Definition: at32f435_437_usb.h:1298
usb_ept_info
usb endpoint infomation structure definition
Definition: at32f435_437_usb.h:421
usb_ept_info::ept0_slen
uint32_t ept0_slen
Definition: at32f435_437_usb.h:441
usb_ept_info::ept_address
uint8_t ept_address
Definition: at32f435_437_usb.h:423
usb_ept_info::inout
uint8_t inout
Definition: at32f435_437_usb.h:424
usb_ept_info::maxpacket
uint32_t maxpacket
Definition: at32f435_437_usb.h:429
usb_ept_info::rx_addr
uint16_t rx_addr
Definition: at32f435_437_usb.h:428
usb_ept_info::total_len
uint32_t total_len
Definition: at32f435_437_usb.h:436
usb_ept_info::trans_buf
uint8_t * trans_buf
Definition: at32f435_437_usb.h:435
usb_ept_info::stall
uint8_t stall
Definition: at32f435_437_usb.h:431
usb_ept_info::rem0_len
uint32_t rem0_len
Definition: at32f435_437_usb.h:440
usb_ept_info::trans_len
uint32_t trans_len
Definition: at32f435_437_usb.h:437
usb_ept_info::is_double_buffer
uint8_t is_double_buffer
Definition: at32f435_437_usb.h:430
usb_ept_info::status
uint32_t status
Definition: at32f435_437_usb.h:432
usb_ept_info::last_len
uint32_t last_len
Definition: at32f435_437_usb.h:439
usb_ept_info::tx_addr
uint16_t tx_addr
Definition: at32f435_437_usb.h:427
usb_ept_info::eptn
uint8_t eptn
Definition: at32f435_437_usb.h:422
usb_ept_info::trans_type
uint8_t trans_type
Definition: at32f435_437_usb.h:425
usb_hch_type
usb host channel infomation structure definition
Definition: at32f435_437_usb.h:449
usb_hch_type::ept_type
uint8_t ept_type
Definition: at32f435_437_usb.h:454
usb_hch_type::speed
uint8_t speed
Definition: at32f435_437_usb.h:457
usb_hch_type::state
uint32_t state
Definition: at32f435_437_usb.h:460
usb_hch_type::address
uint8_t address
Definition: at32f435_437_usb.h:451
usb_hch_type::ch_num
uint8_t ch_num
Definition: at32f435_437_usb.h:450
usb_hch_type::status
uint32_t status
Definition: at32f435_437_usb.h:459
usb_hch_type::ept_num
uint8_t ept_num
Definition: at32f435_437_usb.h:453
usb_hch_type::trans_count
uint32_t trans_count
Definition: at32f435_437_usb.h:469
usb_hch_type::trans_buf
uint8_t * trans_buf
Definition: at32f435_437_usb.h:467
usb_hch_type::maxpacket
uint32_t maxpacket
Definition: at32f435_437_usb.h:455
usb_hch_type::toggle_out
uint8_t toggle_out
Definition: at32f435_437_usb.h:464
usb_hch_type::urb_sts
uint32_t urb_sts
Definition: at32f435_437_usb.h:461
usb_hch_type::trans_len
uint32_t trans_len
Definition: at32f435_437_usb.h:468
usb_hch_type::toggle_in
uint8_t toggle_in
Definition: at32f435_437_usb.h:463
usb_hch_type::dir
uint8_t dir
Definition: at32f435_437_usb.h:452
usb_hch_type::stall
uint8_t stall
Definition: at32f435_437_usb.h:458
usb_hch_type::data_pid
uint8_t data_pid
Definition: at32f435_437_usb.h:456


AT32F435/437 Firmwary Library: at32f435_437_wdt.c Source File

  • libraries
  • drivers
  • src
at32f435_437_wdt.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef WDT_MODULE_ENABLED
39
49void wdt_enable(void)
50{
51 WDT->cmd = WDT_CMD_ENABLE;
52}
53
59void wdt_counter_reload(void)
60{
61 WDT->cmd = WDT_CMD_RELOAD;
62}
63
69void wdt_reload_value_set(uint16_t reload_value)
70{
71 WDT->rld = reload_value;
72}
73
87void wdt_divider_set(wdt_division_type division)
88{
89 WDT->div_bit.div = division;
90}
91
97void wdt_register_write_enable( confirm_state new_state)
98{
99 if(new_state == FALSE)
100 {
101 WDT->cmd = WDT_CMD_LOCK;
102 }
103 else
104 {
105 WDT->cmd = WDT_CMD_UNLOCK;
106 }
107}
108
118 flag_status wdt_flag_get(uint16_t wdt_flag)
119{
120 flag_status status = RESET;
121
122 if ((WDT->sts & wdt_flag) != (uint16_t)RESET)
123 {
124 status = SET;
125 }
126 else
127 {
128 status = RESET;
129 }
130
131 return status;
132}
133
139void wdt_window_counter_set(uint16_t window_cnt)
140{
141 WDT->win_bit.win = window_cnt;
142}
143
148#endif
149
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
FALSE
@ FALSE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
wdt_division_type
wdt_division_type
wdt division value type
Definition: at32f435_437_wdt.h:69
WDT_CMD_ENABLE
@ WDT_CMD_ENABLE
Definition: at32f435_437_wdt.h:86
WDT_CMD_UNLOCK
@ WDT_CMD_UNLOCK
Definition: at32f435_437_wdt.h:85
WDT_CMD_RELOAD
@ WDT_CMD_RELOAD
Definition: at32f435_437_wdt.h:87
WDT_CMD_LOCK
@ WDT_CMD_LOCK
Definition: at32f435_437_wdt.h:84
wdt_register_write_enable
void wdt_register_write_enable(confirm_state new_state)
enable or disable wdt cmd register write
Definition: at32f435_437_wdt.c:97
wdt_enable
void wdt_enable(void)
wdt enable ,the reload value will be sent to the counter
Definition: at32f435_437_wdt.c:49
wdt_flag_get
flag_status wdt_flag_get(uint16_t wdt_flag)
get wdt flag
Definition: at32f435_437_wdt.c:118
wdt_counter_reload
void wdt_counter_reload(void)
reload wdt counter
Definition: at32f435_437_wdt.c:59
wdt_reload_value_set
void wdt_reload_value_set(uint16_t reload_value)
set wdt counter reload value
Definition: at32f435_437_wdt.c:69
wdt_window_counter_set
void wdt_window_counter_set(uint16_t window_cnt)
wdt window counter value set
Definition: at32f435_437_wdt.c:139
wdt_divider_set
void wdt_divider_set(wdt_division_type division)
set wdt division divider
Definition: at32f435_437_wdt.c:87
WDT
#define WDT
Definition: at32f435_437_wdt.h:167
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_wdt.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_wdt.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_WDT_H
29#define __AT32F435_437_WDT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
53#define WDT_DIVF_UPDATE_FLAG ((uint16_t)0x0001)
54#define WDT_RLDF_UPDATE_FLAG ((uint16_t)0x0002)
55#define WDT_WINF_UPDATE_FLAG ((uint16_t)0x0004)
68typedef enum
69{
70 WDT_CLK_DIV_4 = 0x00,
71 WDT_CLK_DIV_8 = 0x01,
72 WDT_CLK_DIV_16 = 0x02,
73 WDT_CLK_DIV_32 = 0x03,
74 WDT_CLK_DIV_64 = 0x04,
75 WDT_CLK_DIV_128 = 0x05,
76 WDT_CLK_DIV_256 = 0x06
77} wdt_division_type;
78
82typedef enum
83{
84 WDT_CMD_LOCK = 0x0000,
85 WDT_CMD_UNLOCK = 0x5555,
86 WDT_CMD_ENABLE = 0xCCCC,
87 WDT_CMD_RELOAD = 0xAAAA
88} wdt_cmd_value_type;
89
93typedef struct
94{
95
99 union
100 {
101 __IO uint32_t cmd;
102 struct
103 {
104 __IO uint32_t cmd : 16;/* [15:0] */
105 __IO uint32_t reserved1 : 16;/* [31:16] */
106 } cmd_bit;
107 };
108
112 union
113 {
114 __IO uint32_t div;
115 struct
116 {
117 __IO uint32_t div : 3; /* [2:0] */
118 __IO uint32_t reserved1 : 29;/* [31:3] */
119 } div_bit;
120 };
121
125 union
126 {
127 __IO uint32_t rld;
128 struct
129 {
130 __IO uint32_t rld : 12;/* [11:0] */
131 __IO uint32_t reserved1 : 20;/* [31:12] */
132 } rld_bit;
133 };
134
138 union
139 {
140 __IO uint32_t sts;
141 struct
142 {
143 __IO uint32_t divf : 1; /* [0] */
144 __IO uint32_t rldf : 1; /* [1] */
145 __IO uint32_t reserved1 : 30;/* [31:2] */
146 } sts_bit;
147 };
148
152 union
153 {
154 __IO uint32_t win;
155 struct
156 {
157 __IO uint32_t win : 12;/* [11:0] */
158 __IO uint32_t reserved1 : 20;/* [31:12] */
159 } win_bit;
160 };
161} wdt_type;
162
167#define WDT ((wdt_type *) WDT_BASE)
168
173void wdt_enable(void);
174void wdt_counter_reload(void);
175void wdt_reload_value_set(uint16_t reload_value);
176void wdt_divider_set(wdt_division_type division);
177void wdt_register_write_enable( confirm_state new_state);
178 flag_status wdt_flag_get(uint16_t wdt_flag);
179void wdt_window_counter_set(uint16_t window_cnt);
180
193#ifdef __cplusplus
194}
195#endif
196
197#endif
at32f435_437.h
at32f435_437 header file
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
wdt_register_write_enable
void wdt_register_write_enable(confirm_state new_state)
enable or disable wdt cmd register write
Definition: at32f435_437_wdt.c:97
wdt_enable
void wdt_enable(void)
wdt enable ,the reload value will be sent to the counter
Definition: at32f435_437_wdt.c:49
wdt_flag_get
flag_status wdt_flag_get(uint16_t wdt_flag)
get wdt flag
Definition: at32f435_437_wdt.c:118
wdt_counter_reload
void wdt_counter_reload(void)
reload wdt counter
Definition: at32f435_437_wdt.c:59
wdt_reload_value_set
void wdt_reload_value_set(uint16_t reload_value)
set wdt counter reload value
Definition: at32f435_437_wdt.c:69
wdt_window_counter_set
void wdt_window_counter_set(uint16_t window_cnt)
wdt window counter value set
Definition: at32f435_437_wdt.c:139
wdt_divider_set
void wdt_divider_set(wdt_division_type division)
set wdt division divider
Definition: at32f435_437_wdt.c:87
wdt_cmd_value_type
wdt_cmd_value_type
wdt cmd value type
Definition: at32f435_437_wdt.h:83
wdt_division_type
wdt_division_type
wdt division value type
Definition: at32f435_437_wdt.h:69
WDT_CMD_ENABLE
@ WDT_CMD_ENABLE
Definition: at32f435_437_wdt.h:86
WDT_CMD_UNLOCK
@ WDT_CMD_UNLOCK
Definition: at32f435_437_wdt.h:85
WDT_CMD_RELOAD
@ WDT_CMD_RELOAD
Definition: at32f435_437_wdt.h:87
WDT_CMD_LOCK
@ WDT_CMD_LOCK
Definition: at32f435_437_wdt.h:84
WDT_CLK_DIV_64
@ WDT_CLK_DIV_64
Definition: at32f435_437_wdt.h:74
WDT_CLK_DIV_8
@ WDT_CLK_DIV_8
Definition: at32f435_437_wdt.h:71
WDT_CLK_DIV_256
@ WDT_CLK_DIV_256
Definition: at32f435_437_wdt.h:76
WDT_CLK_DIV_4
@ WDT_CLK_DIV_4
Definition: at32f435_437_wdt.h:70
WDT_CLK_DIV_16
@ WDT_CLK_DIV_16
Definition: at32f435_437_wdt.h:72
WDT_CLK_DIV_32
@ WDT_CLK_DIV_32
Definition: at32f435_437_wdt.h:73
WDT_CLK_DIV_128
@ WDT_CLK_DIV_128
Definition: at32f435_437_wdt.h:75
wdt_type
type define wdt register all
Definition: at32f435_437_wdt.h:94
wdt_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_wdt.h:105
wdt_type::div
__IO uint32_t div
Definition: at32f435_437_wdt.h:114
wdt_type::divf
__IO uint32_t divf
Definition: at32f435_437_wdt.h:143
wdt_type::rld
__IO uint32_t rld
Definition: at32f435_437_wdt.h:127
wdt_type::rldf
__IO uint32_t rldf
Definition: at32f435_437_wdt.h:144
wdt_type::sts
__IO uint32_t sts
Definition: at32f435_437_wdt.h:140
wdt_type::win
__IO uint32_t win
Definition: at32f435_437_wdt.h:154
wdt_type::cmd
__IO uint32_t cmd
Definition: at32f435_437_wdt.h:101


AT32F435/437 Firmwary Library: at32f435_437_wwdt.c Source File

  • libraries
  • drivers
  • src
at32f435_437_wwdt.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef WWDT_MODULE_ENABLED
39
48void wwdt_reset(void)
49{
50 crm_periph_reset(CRM_WWDT_PERIPH_RESET, TRUE);
51 crm_periph_reset(CRM_WWDT_PERIPH_RESET, FALSE);
52}
53
64void wwdt_divider_set(wwdt_division_type division)
65{
66 WWDT->cfg_bit.div = division;
67}
68
74void wwdt_flag_clear(void)
75{
76 WWDT->sts = 0;
77}
78
84void wwdt_enable(uint8_t wwdt_cnt)
85{
86 WWDT->ctrl = wwdt_cnt | WWDT_EN_BIT;
87}
88
94void wwdt_interrupt_enable(void)
95{
96 WWDT->cfg_bit.rldien = TRUE;
97}
98
104 flag_status wwdt_flag_get(void)
105{
106 return (flag_status)WWDT->sts_bit.rldf;
107}
108
114void wwdt_counter_set(uint8_t wwdt_cnt)
115{
116 WWDT->ctrl_bit.cnt = wwdt_cnt;
117}
118
124void wwdt_window_counter_set(uint8_t window_cnt)
125{
126 WWDT->cfg_bit.win = window_cnt;
127}
128
133#endif
134
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f435_437_crm.c:251
CRM_WWDT_PERIPH_RESET
@ CRM_WWDT_PERIPH_RESET
Definition: at32f435_437_crm.h:284
flag_status
flag_status
Definition: at32f435_437.h:378
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
WWDT_EN_BIT
#define WWDT_EN_BIT
Definition: at32f435_437_wwdt.h:52
wwdt_division_type
wwdt_division_type
wwdt division type
Definition: at32f435_437_wwdt.h:66
wwdt_counter_set
void wwdt_counter_set(uint8_t wwdt_cnt)
wwdt counter value set
Definition: at32f435_437_wwdt.c:114
wwdt_flag_clear
void wwdt_flag_clear(void)
wwdt reload counter interrupt flag clear
Definition: at32f435_437_wwdt.c:74
wwdt_interrupt_enable
void wwdt_interrupt_enable(void)
wwdt reload counter interrupt enable
Definition: at32f435_437_wwdt.c:94
wwdt_divider_set
void wwdt_divider_set(wwdt_division_type division)
wwdt division set
Definition: at32f435_437_wwdt.c:64
wwdt_reset
void wwdt_reset(void)
wwdt reset by crm reset register
Definition: at32f435_437_wwdt.c:48
wwdt_window_counter_set
void wwdt_window_counter_set(uint8_t window_cnt)
wwdt window counter value set
Definition: at32f435_437_wwdt.c:124
wwdt_flag_get
flag_status wwdt_flag_get(void)
wwdt reload counter interrupt flag get
Definition: at32f435_437_wwdt.c:104
wwdt_enable
void wwdt_enable(uint8_t wwdt_cnt)
wwdt enable and the counter value load
Definition: at32f435_437_wwdt.c:84
WWDT
#define WWDT
Definition: at32f435_437_wwdt.h:127
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_wwdt.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_wwdt.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_WWDT_H
29#define __AT32F435_437_WWDT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
52#define WWDT_EN_BIT ((uint32_t)0x00000080)
65typedef enum
66{
67 WWDT_PCLK1_DIV_4096 = 0x00,
68 WWDT_PCLK1_DIV_8192 = 0x01,
69 WWDT_PCLK1_DIV_16384 = 0x02,
70 WWDT_PCLK1_DIV_32768 = 0x03
71} wwdt_division_type;
72
76typedef struct
77{
78
82 union
83 {
84 __IO uint32_t ctrl;
85 struct
86 {
87 __IO uint32_t cnt : 7; /* [6:0] */
88 __IO uint32_t wwdten : 1; /* [7] */
89 __IO uint32_t reserved1 : 24;/* [31:8] */
90 } ctrl_bit;
91 };
92
96 union
97 {
98 __IO uint32_t cfg;
99 struct
100 {
101 __IO uint32_t win : 7; /* [6:0] */
102 __IO uint32_t div : 2; /* [8:7] */
103 __IO uint32_t rldien : 1; /* [9] */
104 __IO uint32_t reserved1 : 22;/* [31:10] */
105 } cfg_bit;
106 };
107
111 union
112 {
113 __IO uint32_t sts;
114 struct
115 {
116 __IO uint32_t rldf : 1; /* [0] */
117 __IO uint32_t reserved1 : 31;/* [31:1] */
118 } sts_bit;
119 };
120
121} wwdt_type;
122
127#define WWDT ((wwdt_type *) WWDT_BASE)
128
133void wwdt_reset(void);
134void wwdt_divider_set(wwdt_division_type division);
135void wwdt_flag_clear(void);
136void wwdt_enable(uint8_t wwdt_cnt);
137void wwdt_interrupt_enable(void);
138 flag_status wwdt_flag_get(void);
139void wwdt_counter_set(uint8_t wwdt_cnt);
140void wwdt_window_counter_set(uint8_t window_cnt);
141
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f435_437.h
at32f435_437 header file
flag_status
flag_status
Definition: at32f435_437.h:378
wwdt_counter_set
void wwdt_counter_set(uint8_t wwdt_cnt)
wwdt counter value set
Definition: at32f435_437_wwdt.c:114
wwdt_flag_clear
void wwdt_flag_clear(void)
wwdt reload counter interrupt flag clear
Definition: at32f435_437_wwdt.c:74
wwdt_interrupt_enable
void wwdt_interrupt_enable(void)
wwdt reload counter interrupt enable
Definition: at32f435_437_wwdt.c:94
wwdt_divider_set
void wwdt_divider_set(wwdt_division_type division)
wwdt division set
Definition: at32f435_437_wwdt.c:64
wwdt_reset
void wwdt_reset(void)
wwdt reset by crm reset register
Definition: at32f435_437_wwdt.c:48
wwdt_window_counter_set
void wwdt_window_counter_set(uint8_t window_cnt)
wwdt window counter value set
Definition: at32f435_437_wwdt.c:124
wwdt_flag_get
flag_status wwdt_flag_get(void)
wwdt reload counter interrupt flag get
Definition: at32f435_437_wwdt.c:104
wwdt_enable
void wwdt_enable(uint8_t wwdt_cnt)
wwdt enable and the counter value load
Definition: at32f435_437_wwdt.c:84
wwdt_division_type
wwdt_division_type
wwdt division type
Definition: at32f435_437_wwdt.h:66
WWDT_PCLK1_DIV_16384
@ WWDT_PCLK1_DIV_16384
Definition: at32f435_437_wwdt.h:69
WWDT_PCLK1_DIV_8192
@ WWDT_PCLK1_DIV_8192
Definition: at32f435_437_wwdt.h:68
WWDT_PCLK1_DIV_32768
@ WWDT_PCLK1_DIV_32768
Definition: at32f435_437_wwdt.h:70
WWDT_PCLK1_DIV_4096
@ WWDT_PCLK1_DIV_4096
Definition: at32f435_437_wwdt.h:67
wwdt_type
type define wwdt register all
Definition: at32f435_437_wwdt.h:77
wwdt_type::div
__IO uint32_t div
Definition: at32f435_437_wwdt.h:102
wwdt_type::win
__IO uint32_t win
Definition: at32f435_437_wwdt.h:101
wwdt_type::cfg
__IO uint32_t cfg
Definition: at32f435_437_wwdt.h:98
wwdt_type::cnt
__IO uint32_t cnt
Definition: at32f435_437_wwdt.h:87
wwdt_type::wwdten
__IO uint32_t wwdten
Definition: at32f435_437_wwdt.h:88
wwdt_type::sts
__IO uint32_t sts
Definition: at32f435_437_wwdt.h:113
wwdt_type::ctrl
__IO uint32_t ctrl
Definition: at32f435_437_wwdt.h:84
wwdt_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_wwdt.h:89
wwdt_type::rldien
__IO uint32_t rldien
Definition: at32f435_437_wwdt.h:103
wwdt_type::rldf
__IO uint32_t rldf
Definition: at32f435_437_wwdt.h:116


AT32F435/437 Firmwary Library: at32f435_437_xmc.c Source File

  • libraries
  • drivers
  • src
at32f435_437_xmc.c
Go to the documentation of this file.
1
27#include "at32f435_437_conf.h"
28
38#ifdef XMC_MODULE_ENABLED
39
54void xmc_nor_sram_reset(xmc_nor_sram_subbank_type xmc_subbank)
55{
56 /* XMC_BANK1_NORSRAM1 */
57 if(xmc_subbank == XMC_BANK1_NOR_SRAM1)
58 {
59 XMC_BANK1->ctrl_tmg_group[xmc_subbank].bk1ctrl = 0x000030DB;
60 }
61 /* XMC_BANK1_NORSRAM2, XMC_BANK1_NORSRAM3 or XMC_BANK1_NORSRAM4 */
62 else
63 {
64 XMC_BANK1->ctrl_tmg_group[xmc_subbank].bk1ctrl = 0x000030D2;
65 }
66 XMC_BANK1->ctrl_tmg_group[xmc_subbank].bk1tmg = 0x0FFFFFFF;
67 XMC_BANK1->tmgwr_group[xmc_subbank].bk1tmgwr = 0x0FFFFFFF;
68}
69
78void xmc_nor_sram_init(xmc_norsram_init_type* xmc_norsram_init_struct)
79{
80 /* bank1 nor/sram control register configuration */
81 XMC_BANK1->ctrl_tmg_group[xmc_norsram_init_struct->subbank].bk1ctrl =
82 (uint32_t)xmc_norsram_init_struct->data_addr_multiplex |
83 xmc_norsram_init_struct->device |
84 xmc_norsram_init_struct->bus_type |
85 xmc_norsram_init_struct->burst_mode_enable |
86 xmc_norsram_init_struct->asynwait_enable |
87 xmc_norsram_init_struct->wait_signal_lv |
88 xmc_norsram_init_struct->wrapped_mode_enable |
89 xmc_norsram_init_struct->wait_signal_config |
90 xmc_norsram_init_struct->write_enable |
91 xmc_norsram_init_struct->wait_signal_enable |
92 xmc_norsram_init_struct->write_timing_enable |
93 xmc_norsram_init_struct->write_burst_syn;
94
95 /* if nor flash device */
96 if(xmc_norsram_init_struct->device == XMC_DEVICE_NOR)
97 {
98 XMC_BANK1->ctrl_tmg_group[xmc_norsram_init_struct->subbank].bk1ctrl_bit.noren = 0x1;
99 }
100}
101
113void xmc_nor_sram_timing_config(xmc_norsram_timing_init_type* xmc_rw_timing_struct,
114 xmc_norsram_timing_init_type* xmc_w_timing_struct)
115{
116 /* bank1 nor/sram timing register configuration */
117 XMC_BANK1->ctrl_tmg_group[xmc_rw_timing_struct->subbank].bk1tmg =
118 (uint32_t)xmc_rw_timing_struct->addr_setup_time |
119 (xmc_rw_timing_struct->addr_hold_time << 4) |
120 (xmc_rw_timing_struct->data_setup_time << 8) |
121 (xmc_rw_timing_struct->bus_latency_time <<16) |
122 (xmc_rw_timing_struct->clk_psc << 20) |
123 (xmc_rw_timing_struct->data_latency_time << 24) |
124 xmc_rw_timing_struct->mode;
125
126 /* bank1 nor/sram timing register for write configuration, if extended mode is used */
127 if(xmc_rw_timing_struct->write_timing_enable == XMC_WRITE_TIMING_ENABLE)
128 {
129 XMC_BANK1->tmgwr_group[xmc_w_timing_struct->subbank].bk1tmgwr =
130 (uint32_t)xmc_w_timing_struct->addr_setup_time |
131 (xmc_w_timing_struct->addr_hold_time << 4) |
132 (xmc_w_timing_struct->data_setup_time << 8) |
133 (xmc_w_timing_struct->bus_latency_time << 16) |
134 (xmc_w_timing_struct->clk_psc << 20) |
135 (xmc_w_timing_struct->data_latency_time << 24) |
136 xmc_w_timing_struct->mode;
137 }
138 else
139 {
140 XMC_BANK1->tmgwr_group[xmc_w_timing_struct->subbank].bk1tmgwr = 0x0FFFFFFF;
141 }
142}
143
150void xmc_norsram_default_para_init(xmc_norsram_init_type* xmc_nor_sram_init_struct)
151{
152 /* reset nor/sram init structure parameters values */
153 xmc_nor_sram_init_struct->subbank = XMC_BANK1_NOR_SRAM1;
154 xmc_nor_sram_init_struct->data_addr_multiplex = XMC_DATA_ADDR_MUX_ENABLE;
155 xmc_nor_sram_init_struct->device = XMC_DEVICE_SRAM;
156 xmc_nor_sram_init_struct->bus_type = XMC_BUSTYPE_8_BITS;
157 xmc_nor_sram_init_struct->burst_mode_enable = XMC_BURST_MODE_DISABLE;
158 xmc_nor_sram_init_struct->asynwait_enable = XMC_ASYN_WAIT_DISABLE;
159 xmc_nor_sram_init_struct->wait_signal_lv = XMC_WAIT_SIGNAL_LEVEL_LOW;
160 xmc_nor_sram_init_struct->wrapped_mode_enable = XMC_WRAPPED_MODE_DISABLE;
161 xmc_nor_sram_init_struct->wait_signal_config = XMC_WAIT_SIGNAL_SYN_BEFORE;
162 xmc_nor_sram_init_struct->write_enable = XMC_WRITE_OPERATION_ENABLE;
163 xmc_nor_sram_init_struct->wait_signal_enable = XMC_WAIT_SIGNAL_ENABLE;
164 xmc_nor_sram_init_struct->write_timing_enable = XMC_WRITE_TIMING_DISABLE;
165 xmc_nor_sram_init_struct->write_burst_syn = XMC_WRITE_BURST_SYN_DISABLE;
166}
167
176void xmc_norsram_timing_default_para_init(xmc_norsram_timing_init_type* xmc_rw_timing_struct,
177 xmc_norsram_timing_init_type* xmc_w_timing_struct)
178{
179 xmc_rw_timing_struct->subbank = XMC_BANK1_NOR_SRAM1;
180 xmc_rw_timing_struct->write_timing_enable = XMC_WRITE_TIMING_DISABLE;
181 xmc_rw_timing_struct->addr_setup_time = 0xF;
182 xmc_rw_timing_struct->addr_hold_time = 0xF;
183 xmc_rw_timing_struct->data_setup_time = 0xFF;
184 xmc_rw_timing_struct->bus_latency_time = 0xF;
185 xmc_rw_timing_struct->clk_psc = 0xF;
186 xmc_rw_timing_struct->data_latency_time = 0xF;
187 xmc_rw_timing_struct->mode = XMC_ACCESS_MODE_A;
188 xmc_w_timing_struct->subbank = XMC_BANK1_NOR_SRAM1;
189 xmc_w_timing_struct->write_timing_enable = XMC_WRITE_TIMING_DISABLE;
190 xmc_w_timing_struct->addr_setup_time = 0xF;
191 xmc_w_timing_struct->addr_hold_time = 0xF;
192 xmc_w_timing_struct->data_setup_time = 0xFF;
193 xmc_w_timing_struct->bus_latency_time = 0xF;
194 xmc_w_timing_struct->clk_psc = 0xF;
195 xmc_w_timing_struct->data_latency_time = 0xF;
196 xmc_w_timing_struct->mode = XMC_ACCESS_MODE_A;
197}
198
210void xmc_nor_sram_enable(xmc_nor_sram_subbank_type xmc_subbank, confirm_state new_state)
211{
212 XMC_BANK1->ctrl_tmg_group[xmc_subbank].bk1ctrl_bit.en = new_state;
213}
214
227void xmc_ext_timing_config(xmc_nor_sram_subbank_type xmc_sub_bank, uint16_t w2w_timing, uint16_t r2r_timing)
228{
229 XMC_BANK1->ext_bit[xmc_sub_bank].buslatr2r = r2r_timing<<8;
230 XMC_BANK1->ext_bit[xmc_sub_bank].buslatw2w = w2w_timing;
231}
232
241void xmc_nand_reset(xmc_class_bank_type xmc_bank)
242{
243 /* set the xmc_bank2_nand registers to their reset values */
244 if(xmc_bank == XMC_BANK2_NAND)
245 {
246 XMC_BANK2->bk2ctrl = 0x00000018;
247 XMC_BANK2->bk2is = 0x00000040;
248 XMC_BANK2->bk2tmgatt = 0xFCFCFCFC;
249 XMC_BANK2->bk2tmgmem = 0xFCFCFCFC;
250 }
251 /* set the xmc_bank3_nand registers to their reset values */
252 else
253 {
254 XMC_BANK3->bk3ctrl = 0x00000018;
255 XMC_BANK3->bk3is = 0x00000040;
256 XMC_BANK3->bk3tmgatt = 0xFCFCFCFC;
257 XMC_BANK3->bk3tmgmem = 0xFCFCFCFC;
258 }
259}
260
269void xmc_nand_init(xmc_nand_init_type* xmc_nand_init_struct)
270{
271 uint32_t tempctrl = 0x0;
272
273 /* Set the tempctrl value according to xmc_nand_init_struct parameters */
274 tempctrl = (uint32_t)xmc_nand_init_struct->wait_enable |
275 xmc_nand_init_struct->bus_type |
276 xmc_nand_init_struct->ecc_enable |
277 xmc_nand_init_struct->ecc_pagesize |
278 (xmc_nand_init_struct->delay_time_cycle << 9) |
279 (xmc_nand_init_struct->delay_time_ar << 13) |
280 0x00000008;
281
282 /* xmc_bank2_nand registers configuration */
283 if(xmc_nand_init_struct->nand_bank == XMC_BANK2_NAND)
284 {
285 XMC_BANK2->bk2ctrl = tempctrl;
286 }
287 /* xmc_bank3_nand registers configuration */
288 else
289 {
290 XMC_BANK3->bk3ctrl = tempctrl;
291 }
292}
293
305void xmc_nand_timing_config(xmc_nand_pccard_timinginit_type* xmc_regular_spacetiming_struct,
306 xmc_nand_pccard_timinginit_type* xmc_special_spacetiming_struct)
307{
308 uint32_t tempmem = 0x0, tempatt = 0x0;
309
310 /* set the tempmem value according to xmc_nand_init_struct parameters */
311 tempmem = (uint32_t)xmc_regular_spacetiming_struct->mem_setup_time |
312 (xmc_regular_spacetiming_struct->mem_waite_time << 8) |
313 (xmc_regular_spacetiming_struct->mem_hold_time << 16) |
314 (xmc_regular_spacetiming_struct->mem_hiz_time << 24);
315
316 /* set the tempatt value according to xmc_nand_init_struct parameters */
317 tempatt = (uint32_t)xmc_special_spacetiming_struct->mem_setup_time |
318 (xmc_special_spacetiming_struct->mem_waite_time << 8) |
319 (xmc_special_spacetiming_struct->mem_hold_time << 16) |
320 (xmc_special_spacetiming_struct->mem_hiz_time << 24);
321 /* xmc_bank2_nand registers configuration */
322 if(xmc_regular_spacetiming_struct->class_bank == XMC_BANK2_NAND)
323 {
324 XMC_BANK2->bk2tmgatt = tempatt;
325 XMC_BANK2->bk2tmgmem = tempmem;
326 }
327 else
328 {
329 XMC_BANK3->bk3tmgatt = tempatt;
330 XMC_BANK3->bk3tmgmem = tempmem;
331 }
332}
333
340void xmc_nand_default_para_init(xmc_nand_init_type* xmc_nand_init_struct)
341{
342 /* reset nand init structure parameters values */
343 xmc_nand_init_struct->nand_bank = XMC_BANK2_NAND;
344 xmc_nand_init_struct->wait_enable = XMC_WAIT_OPERATION_DISABLE;
345 xmc_nand_init_struct->bus_type = XMC_BUSTYPE_8_BITS;
346 xmc_nand_init_struct->ecc_enable = XMC_ECC_OPERATION_DISABLE;
347 xmc_nand_init_struct->ecc_pagesize = XMC_ECC_PAGESIZE_256_BYTES;
348 xmc_nand_init_struct->delay_time_cycle = 0x0;
349 xmc_nand_init_struct->delay_time_ar = 0x0;
350}
351
360void xmc_nand_timing_default_para_init(xmc_nand_pccard_timinginit_type* xmc_regular_spacetiming_struct,
361 xmc_nand_pccard_timinginit_type* xmc_special_spacetiming_struct)
362{
363 xmc_regular_spacetiming_struct->class_bank = XMC_BANK2_NAND;
364 xmc_regular_spacetiming_struct->mem_hold_time = 0xFC;
365 xmc_regular_spacetiming_struct->mem_waite_time = 0xFC;
366 xmc_regular_spacetiming_struct->mem_setup_time = 0xFC;
367 xmc_regular_spacetiming_struct->mem_hiz_time = 0xFC;
368 xmc_special_spacetiming_struct->class_bank = XMC_BANK2_NAND;
369 xmc_special_spacetiming_struct->mem_hold_time = 0xFC;
370 xmc_special_spacetiming_struct->mem_waite_time = 0xFC;
371 xmc_special_spacetiming_struct->mem_setup_time = 0xFC;
372 xmc_special_spacetiming_struct->mem_hiz_time = 0xFC;
373}
374
384void xmc_nand_enable(xmc_class_bank_type xmc_bank, confirm_state new_state)
385{
386 /* enable or disable the nand bank2 by setting the en bit in the bk2ctrl register */
387 if(xmc_bank == XMC_BANK2_NAND)
388 {
389 XMC_BANK2->bk2ctrl_bit.en = new_state;
390 }
391 /* enable or disable the nand bank3 by setting the en bit in the bk3ctrl register */
392 else
393 {
394 XMC_BANK3->bk3ctrl_bit.en = new_state;
395 }
396}
397
407void xmc_nand_ecc_enable(xmc_class_bank_type xmc_bank, confirm_state new_state)
408{
409 /* enable the selected nand bank2 ecc function by setting the eccen bit in the bk2ctrl register */
410 if(xmc_bank == XMC_BANK2_NAND)
411 {
412 XMC_BANK2->bk2ctrl_bit.eccen = new_state;
413 }
414 /* enable the selected nand bank3 ecc function by setting the eccen bit in the bk3ctrl register */
415 else
416 {
417 XMC_BANK3->bk3ctrl_bit.eccen = new_state;
418 }
419}
420
429uint32_t xmc_ecc_get(xmc_class_bank_type xmc_bank)
430{
431 uint32_t eccvaule = 0x0;
432
433 /* get the bk2ecc register value */
434 if(xmc_bank == XMC_BANK2_NAND)
435 {
436 eccvaule = XMC_BANK2->bk2ecc;
437 }
438 /* get the bk3ecc register value */
439 else
440 {
441 eccvaule = XMC_BANK3->bk3ecc;
442 }
443 /* return the error correction code value */
444 return eccvaule;
445}
446
455void xmc_sdram_reset(xmc_sdram_bank_type xmc_bank)
456{
457 XMC_SDRAM->ctrl[xmc_bank] = 0x000002D0;
458 XMC_SDRAM->tm[xmc_bank] = 0x0FFFFFFF;
459 XMC_SDRAM->cmd = 0x00000000;
460 XMC_SDRAM->rcnt = 0x00000000;
461 XMC_SDRAM->sts = 0x00000000;
462}
463
475void xmc_sdram_init(xmc_sdram_init_type *xmc_sdram_init_struct, xmc_sdram_timing_type *xmc_sdram_timing_struct)
476{
477 if(xmc_sdram_init_struct->sdram_bank == XMC_SDRAM_BANK1)
478 {
479 XMC_SDRAM->ctrl_bit[XMC_SDRAM_BANK1].ca = xmc_sdram_init_struct->column_address;
480 XMC_SDRAM->ctrl_bit[XMC_SDRAM_BANK1].ra = xmc_sdram_init_struct->row_address;
481 XMC_SDRAM->ctrl_bit[XMC_SDRAM_BANK1].db = xmc_sdram_init_struct->width;
482 XMC_SDRAM->ctrl_bit[XMC_SDRAM_BANK1].inbk = xmc_sdram_init_struct->internel_banks;
483 XMC_SDRAM->ctrl_bit[XMC_SDRAM_BANK1].cas = xmc_sdram_init_struct->cas;
484 XMC_SDRAM->ctrl_bit[XMC_SDRAM_BANK1].wrp = xmc_sdram_init_struct->write_protection;
485 XMC_SDRAM->ctrl_bit[XMC_SDRAM_BANK1].bstr = xmc_sdram_init_struct->burst_read;
486 XMC_SDRAM->ctrl_bit[XMC_SDRAM_BANK1].rd = xmc_sdram_init_struct->read_delay;
487 XMC_SDRAM->ctrl_bit[XMC_SDRAM_BANK1].clkdiv = xmc_sdram_init_struct->clkdiv;
488
489 XMC_SDRAM->tm_bit[XMC_SDRAM_BANK1].tmrd = xmc_sdram_timing_struct->tmrd;
490 XMC_SDRAM->tm_bit[XMC_SDRAM_BANK1].txsr = xmc_sdram_timing_struct->txsr;
491 XMC_SDRAM->tm_bit[XMC_SDRAM_BANK1].tras = xmc_sdram_timing_struct->tras;
492 XMC_SDRAM->tm_bit[XMC_SDRAM_BANK1].trc = xmc_sdram_timing_struct->trc;
493 XMC_SDRAM->tm_bit[XMC_SDRAM_BANK1].twr = xmc_sdram_timing_struct->twr;
494 XMC_SDRAM->tm_bit[XMC_SDRAM_BANK1].trp = xmc_sdram_timing_struct->trp;
495 XMC_SDRAM->tm_bit[XMC_SDRAM_BANK1].trcd = xmc_sdram_timing_struct->trcd;
496 }
497
498 if(xmc_sdram_init_struct->sdram_bank == XMC_SDRAM_BANK2)
499 {
500 XMC_SDRAM->ctrl_bit[XMC_SDRAM_BANK2].ca = xmc_sdram_init_struct->column_address;
501 XMC_SDRAM->ctrl_bit[XMC_SDRAM_BANK2].ra = xmc_sdram_init_struct->row_address;
502 XMC_SDRAM->ctrl_bit[XMC_SDRAM_BANK2].db = xmc_sdram_init_struct->width;
503 XMC_SDRAM->ctrl_bit[XMC_SDRAM_BANK2].inbk = xmc_sdram_init_struct->internel_banks;
504 XMC_SDRAM->ctrl_bit[XMC_SDRAM_BANK2].cas = xmc_sdram_init_struct->cas;
505 XMC_SDRAM->ctrl_bit[XMC_SDRAM_BANK2].wrp = xmc_sdram_init_struct->write_protection;
506 /* sdctrl2 bstr is not care */
507 XMC_SDRAM->ctrl_bit[XMC_SDRAM_BANK1].bstr = xmc_sdram_init_struct->burst_read;
508 XMC_SDRAM->ctrl_bit[XMC_SDRAM_BANK1].rd = xmc_sdram_init_struct->read_delay;
509 /* sdctrl2 clkdiv is not care */
510 XMC_SDRAM->ctrl_bit[XMC_SDRAM_BANK1].clkdiv = xmc_sdram_init_struct->clkdiv;
511
512 XMC_SDRAM->tm_bit[XMC_SDRAM_BANK2].tmrd = xmc_sdram_timing_struct->tmrd;
513 XMC_SDRAM->tm_bit[XMC_SDRAM_BANK2].txsr = xmc_sdram_timing_struct->txsr;
514 XMC_SDRAM->tm_bit[XMC_SDRAM_BANK2].tras = xmc_sdram_timing_struct->tras;
515 /* sdtm2 trc is not care */
516 XMC_SDRAM->tm_bit[XMC_SDRAM_BANK1].trc = xmc_sdram_timing_struct->trc;
517 XMC_SDRAM->tm_bit[XMC_SDRAM_BANK2].twr = xmc_sdram_timing_struct->twr;
518 /* sdtm2 trp is not care */
519 XMC_SDRAM->tm_bit[XMC_SDRAM_BANK1].trp = xmc_sdram_timing_struct->trp;
520 XMC_SDRAM->tm_bit[XMC_SDRAM_BANK2].trcd = xmc_sdram_timing_struct->trcd;
521 }
522}
523
532void xmc_sdram_default_para_init(xmc_sdram_init_type *xmc_sdram_init_struct, xmc_sdram_timing_type *xmc_sdram_timing_struct)
533{
534 /* reset sdram init structure parameters values */
535 xmc_sdram_init_struct->sdram_bank = XMC_SDRAM_BANK1;
536 xmc_sdram_init_struct->internel_banks = XMC_INBK_4;
537 xmc_sdram_init_struct->clkdiv = XMC_NO_CLK;
538 xmc_sdram_init_struct->write_protection = FALSE;
539 xmc_sdram_init_struct->burst_read = FALSE;
540 xmc_sdram_init_struct->column_address = XMC_COLUMN_8;
541 xmc_sdram_init_struct->row_address = XMC_ROW_11;
542 xmc_sdram_init_struct->cas = XMC_CAS_1;
543 xmc_sdram_init_struct->width = XMC_MEM_WIDTH_8;
544 xmc_sdram_init_struct->read_delay = XMC_READ_DELAY_1;
545
546 xmc_sdram_timing_struct->tmrd = XMC_DELAY_CYCLE_16;
547 xmc_sdram_timing_struct->txsr = XMC_DELAY_CYCLE_16;
548 xmc_sdram_timing_struct->tras = XMC_DELAY_CYCLE_16;
549 xmc_sdram_timing_struct->trc = XMC_DELAY_CYCLE_16;
550 xmc_sdram_timing_struct->twr = XMC_DELAY_CYCLE_16;
551 xmc_sdram_timing_struct->trp = XMC_DELAY_CYCLE_16;
552 xmc_sdram_timing_struct->trcd = XMC_DELAY_CYCLE_16;
553}
554
561void xmc_sdram_cmd(xmc_sdram_cmd_type *xmc_sdram_cmd_struct)
562{
563 XMC_SDRAM->cmd = (xmc_sdram_cmd_struct->auto_refresh << 5) |
564 (xmc_sdram_cmd_struct->data << 9) |
565 xmc_sdram_cmd_struct->cmd |
566 xmc_sdram_cmd_struct->cmd_banks;
567}
568
569
578uint32_t xmc_sdram_status_get(xmc_sdram_bank_type xmc_bank)
579{
580 if(xmc_bank == XMC_SDRAM_BANK1)
581 {
582 return ((XMC_SDRAM->sts >> 1) & XMC_STATUS_MASK);
583 }
584 else
585 {
586 return ((XMC_SDRAM->sts >> 3) & XMC_STATUS_MASK);
587 }
588}
589
595void xmc_sdram_refresh_counter_set(uint32_t counter)
596{
597 XMC_SDRAM->rcnt_bit.rc = counter;
598}
599
605void xmc_sdram_auto_refresh_set(uint32_t number)
606{
607 XMC_SDRAM->cmd_bit.art = number;
608}
609
627void xmc_interrupt_enable(xmc_class_bank_type xmc_bank, xmc_interrupt_sources_type xmc_int, confirm_state new_state)
628{
629 if(new_state != FALSE)
630 {
631 /* enable the selected xmc_bank2 interrupts */
632 if(xmc_bank == XMC_BANK2_NAND)
633 {
634 XMC_BANK2->bk2is |= xmc_int;
635 }
636 /* enable the selected xmc_bank3 interrupts */
637 else if(xmc_bank == XMC_BANK3_NAND)
638 {
639 XMC_BANK3->bk3is |= xmc_int;
640 }
641 /* enable the selected xmc_bank4 interrupts */
642 else if(xmc_bank == XMC_BANK4_PCCARD)
643 {
644 XMC_BANK4->bk4is |= xmc_int;
645 }
646 /* enable the selected xmc_sdram interrupts */
647 else
648 {
649 XMC_SDRAM->rcnt |= xmc_int;
650 }
651 }
652 else
653 {
654 /* disable the selected xmc_bank2 interrupts */
655 if(xmc_bank == XMC_BANK2_NAND)
656 {
657 XMC_BANK2->bk2is &= ~xmc_int;
658 }
659 /* disable the selected xmc_bank3 interrupts */
660 else if(xmc_bank == XMC_BANK3_NAND)
661 {
662 XMC_BANK3->bk3is &= ~xmc_int;
663 }
664 /* disable the selected xmc_bank4 interrupts */
665 else if(xmc_bank == XMC_BANK4_PCCARD)
666 {
667 XMC_BANK4->bk4is &= ~xmc_int;
668 }
669 /* disable the selected xmc_sdram interrupts */
670 else
671 {
672 XMC_SDRAM->rcnt &= ~xmc_int;
673 }
674 }
675}
676
695 flag_status xmc_flag_status_get(xmc_class_bank_type xmc_bank, xmc_interrupt_flag_type xmc_flag)
696{
697 flag_status status = RESET;
698 uint32_t temp = 0;
699
700 if(xmc_bank == XMC_BANK2_NAND)
701 {
702 temp = XMC_BANK2->bk2is;
703 }
704 else if(xmc_bank == XMC_BANK3_NAND)
705 {
706 temp = XMC_BANK3->bk3is;
707 }
708 else if(xmc_bank == XMC_BANK4_PCCARD)
709 {
710 temp = XMC_BANK4->bk4is;
711 }
712 else
713 {
714 temp = XMC_SDRAM->sts;
715 }
716 /* get the flag status */
717 if((temp & xmc_flag) == RESET)
718 {
719 status = RESET;
720 }
721 else
722 {
723 status = SET;
724 }
725 /* return the flag status */
726 return status;
727}
728
745void xmc_flag_clear(xmc_class_bank_type xmc_bank, xmc_interrupt_flag_type xmc_flag)
746{
747 __IO uint32_t int_state;
748 if(xmc_bank == XMC_BANK2_NAND)
749 {
750 int_state = XMC_BANK2->bk2is & 0x38; /* keep interrupt state */
751 XMC_BANK2->bk2is = (~(xmc_flag | 0x38) | int_state);
752 }
753 else if(xmc_bank == XMC_BANK3_NAND)
754 {
755 int_state = XMC_BANK3->bk3is & 0x38; /* keep interrupt state */
756 XMC_BANK3->bk3is = (~(xmc_flag | 0x38) | int_state);
757 }
758 else if(xmc_bank == XMC_BANK4_PCCARD)
759 {
760 int_state = XMC_BANK4->bk4is & 0x38; /* keep interrupt state */
761 XMC_BANK4->bk4is = (~(xmc_flag | 0x38) | int_state);
762 }
763 else
764 {
765 XMC_SDRAM->rcnt |= xmc_flag;
766 }
767}
768
774void xmc_pccard_reset(void)
775{
776 /* Set the XMC_Bank4 registers to their reset values */
777 XMC_BANK4->bk4ctrl = 0x00000018;
778 XMC_BANK4->bk4is = 0x00000000;
779 XMC_BANK4->bk4tmgatt = 0xFCFCFCFC;
780 XMC_BANK4->bk4tmgio = 0xFCFCFCFC;
781 XMC_BANK4->bk4tmgmem = 0xFCFCFCFC;
782}
783
792void xmc_pccard_init(xmc_pccard_init_type* xmc_pccard_init_struct)
793{
794 /* set the bk4ctrl register value according to xmc_pccard_init_struct parameters */
795 XMC_BANK4->bk4ctrl = (uint32_t)xmc_pccard_init_struct->enable_wait |
796 XMC_BUSTYPE_16_BITS |
797 (xmc_pccard_init_struct->delay_time_cr << 9) |
798 (xmc_pccard_init_struct->delay_time_ar << 13);
799}
800
816void xmc_pccard_timing_config(xmc_nand_pccard_timinginit_type* xmc_regular_spacetiming_struct,
817 xmc_nand_pccard_timinginit_type* xmc_special_spacetiming_struct,
818 xmc_nand_pccard_timinginit_type* xmc_iospace_timing_struct)
819{
820 /* set bk4tmgmem register value according to xmc_regular_spacetiming_struct parameters */
821 XMC_BANK4->bk4tmgmem = (uint32_t)xmc_regular_spacetiming_struct->mem_setup_time |
822 (xmc_regular_spacetiming_struct->mem_waite_time << 8) |
823 (xmc_regular_spacetiming_struct->mem_hold_time << 16) |
824 (xmc_regular_spacetiming_struct->mem_hiz_time << 24);
825
826 /* Set bk4tmgatt register value according to xmc_special_spacetiming_struct parameters */
827 XMC_BANK4->bk4tmgatt = (uint32_t)xmc_special_spacetiming_struct->mem_setup_time |
828 (xmc_special_spacetiming_struct->mem_waite_time << 8) |
829 (xmc_special_spacetiming_struct->mem_hold_time << 16) |
830 (xmc_special_spacetiming_struct->mem_hiz_time << 24);
831
832 /* Set bk4tmgio register value according to xmc_iospace_timing_struct parameters */
833 XMC_BANK4->bk4tmgio = (uint32_t)xmc_iospace_timing_struct->mem_setup_time |
834 (xmc_iospace_timing_struct->mem_waite_time << 8) |
835 (xmc_iospace_timing_struct->mem_hold_time << 16) |
836 (xmc_iospace_timing_struct->mem_hiz_time << 24);
837}
844void xmc_pccard_default_para_init(xmc_pccard_init_type* xmc_pccard_init_struct)
845{
846 /* reset pccard init structure parameters values */
847 xmc_pccard_init_struct->enable_wait = XMC_WAIT_OPERATION_DISABLE;
848 xmc_pccard_init_struct->delay_time_ar = 0x0;
849 xmc_pccard_init_struct->delay_time_cr = 0x0;
850
851}
866void xmc_pccard_timing_default_para_init(xmc_nand_pccard_timinginit_type* xmc_regular_spacetiming_struct,
867 xmc_nand_pccard_timinginit_type* xmc_special_spacetiming_struct,
868 xmc_nand_pccard_timinginit_type* xmc_iospace_timing_struct)
869{
870 xmc_regular_spacetiming_struct->class_bank = XMC_BANK4_PCCARD;
871 xmc_regular_spacetiming_struct->mem_hold_time = 0xFC;
872 xmc_regular_spacetiming_struct->mem_waite_time = 0xFC;
873 xmc_regular_spacetiming_struct->mem_setup_time = 0xFC;
874 xmc_regular_spacetiming_struct->mem_hiz_time = 0xFC;
875 xmc_special_spacetiming_struct->class_bank = XMC_BANK4_PCCARD;
876 xmc_special_spacetiming_struct->mem_hold_time = 0xFC;
877 xmc_special_spacetiming_struct->mem_waite_time = 0xFC;
878 xmc_special_spacetiming_struct->mem_setup_time = 0xFC;
879 xmc_special_spacetiming_struct->mem_hiz_time = 0xFC;
880 xmc_iospace_timing_struct->class_bank = XMC_BANK4_PCCARD;
881 xmc_iospace_timing_struct->mem_hold_time = 0xFC;
882 xmc_iospace_timing_struct->mem_waite_time = 0xFC;
883 xmc_iospace_timing_struct->mem_setup_time = 0xFC;
884 xmc_iospace_timing_struct->mem_hiz_time = 0xFC;
885}
891void xmc_pccard_enable(confirm_state new_state)
892{
893 /* enable the pccard bank4 by setting the en bit in the bk4ctrl register */
894 XMC_BANK4->bk4ctrl_bit.en = new_state;
895}
896
901#endif
902
counter
uint16_t counter
Definition: project/at_start_f435/examples/debug/tmr1/src/main.c:39
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
number
uint32_t number
Definition: project/at_start_f435/examples/xmc/nor_flash/src/main.c:44
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
FALSE
@ FALSE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
xmc_class_bank_type
xmc_class_bank_type
xmc class bank type
Definition: at32f435_437_xmc.h:156
xmc_interrupt_sources_type
xmc_interrupt_sources_type
xmc interrupt sources type
Definition: at32f435_437_xmc.h:228
xmc_sdram_bank_type
xmc_sdram_bank_type
xmc sdram bank type
Definition: at32f435_437_xmc.h:322
xmc_nor_sram_subbank_type
xmc_nor_sram_subbank_type
xmc nor/sram subbank type
Definition: at32f435_437_xmc.h:145
xmc_interrupt_flag_type
xmc_interrupt_flag_type
xmc interrupt flag type
Definition: at32f435_437_xmc.h:239
XMC_WAIT_SIGNAL_ENABLE
@ XMC_WAIT_SIGNAL_ENABLE
Definition: at32f435_437_xmc.h:102
XMC_DELAY_CYCLE_16
@ XMC_DELAY_CYCLE_16
Definition: at32f435_437_xmc.h:348
XMC_WAIT_SIGNAL_SYN_BEFORE
@ XMC_WAIT_SIGNAL_SYN_BEFORE
Definition: at32f435_437_xmc.h:196
XMC_WRITE_OPERATION_ENABLE
@ XMC_WRITE_OPERATION_ENABLE
Definition: at32f435_437_xmc.h:93
XMC_WRITE_BURST_SYN_DISABLE
@ XMC_WRITE_BURST_SYN_DISABLE
Definition: at32f435_437_xmc.h:110
XMC_BURST_MODE_DISABLE
@ XMC_BURST_MODE_DISABLE
Definition: at32f435_437_xmc.h:65
XMC_BANK4_PCCARD
@ XMC_BANK4_PCCARD
Definition: at32f435_437_xmc.h:159
XMC_BANK3_NAND
@ XMC_BANK3_NAND
Definition: at32f435_437_xmc.h:158
XMC_BANK2_NAND
@ XMC_BANK2_NAND
Definition: at32f435_437_xmc.h:157
XMC_NO_CLK
@ XMC_NO_CLK
Definition: at32f435_437_xmc.h:302
XMC_DATA_ADDR_MUX_ENABLE
@ XMC_DATA_ADDR_MUX_ENABLE
Definition: at32f435_437_xmc.h:57
XMC_STATUS_MASK
@ XMC_STATUS_MASK
Definition: at32f435_437_xmc.h:385
XMC_BUSTYPE_16_BITS
@ XMC_BUSTYPE_16_BITS
Definition: at32f435_437_xmc.h:179
XMC_BUSTYPE_8_BITS
@ XMC_BUSTYPE_8_BITS
Definition: at32f435_437_xmc.h:178
XMC_SDRAM_BANK1
@ XMC_SDRAM_BANK1
Definition: at32f435_437_xmc.h:323
XMC_SDRAM_BANK2
@ XMC_SDRAM_BANK2
Definition: at32f435_437_xmc.h:324
XMC_WRITE_TIMING_ENABLE
@ XMC_WRITE_TIMING_ENABLE
Definition: at32f435_437_xmc.h:120
XMC_WRITE_TIMING_DISABLE
@ XMC_WRITE_TIMING_DISABLE
Definition: at32f435_437_xmc.h:119
XMC_BANK1_NOR_SRAM1
@ XMC_BANK1_NOR_SRAM1
Definition: at32f435_437_xmc.h:146
XMC_ROW_11
@ XMC_ROW_11
Definition: at32f435_437_xmc.h:264
XMC_READ_DELAY_1
@ XMC_READ_DELAY_1
Definition: at32f435_437_xmc.h:314
XMC_INBK_4
@ XMC_INBK_4
Definition: at32f435_437_xmc.h:284
XMC_ASYN_WAIT_DISABLE
@ XMC_ASYN_WAIT_DISABLE
Definition: at32f435_437_xmc.h:74
XMC_WAIT_OPERATION_DISABLE
@ XMC_WAIT_OPERATION_DISABLE
Definition: at32f435_437_xmc.h:128
XMC_CAS_1
@ XMC_CAS_1
Definition: at32f435_437_xmc.h:292
XMC_WRAPPED_MODE_DISABLE
@ XMC_WRAPPED_MODE_DISABLE
Definition: at32f435_437_xmc.h:83
XMC_ECC_PAGESIZE_256_BYTES
@ XMC_ECC_PAGESIZE_256_BYTES
Definition: at32f435_437_xmc.h:216
XMC_ACCESS_MODE_A
@ XMC_ACCESS_MODE_A
Definition: at32f435_437_xmc.h:205
XMC_ECC_OPERATION_DISABLE
@ XMC_ECC_OPERATION_DISABLE
Definition: at32f435_437_xmc.h:137
XMC_WAIT_SIGNAL_LEVEL_LOW
@ XMC_WAIT_SIGNAL_LEVEL_LOW
Definition: at32f435_437_xmc.h:187
XMC_MEM_WIDTH_8
@ XMC_MEM_WIDTH_8
Definition: at32f435_437_xmc.h:274
XMC_DEVICE_NOR
@ XMC_DEVICE_NOR
Definition: at32f435_437_xmc.h:170
XMC_DEVICE_SRAM
@ XMC_DEVICE_SRAM
Definition: at32f435_437_xmc.h:168
XMC_COLUMN_8
@ XMC_COLUMN_8
Definition: at32f435_437_xmc.h:253
xmc_ecc_get
uint32_t xmc_ecc_get(xmc_class_bank_type xmc_bank)
return the error correction code register value.
Definition: at32f435_437_xmc.c:429
xmc_sdram_auto_refresh_set
void xmc_sdram_auto_refresh_set(uint32_t number)
set sdram auto refresh number
Definition: at32f435_437_xmc.c:605
xmc_pccard_enable
void xmc_pccard_enable(confirm_state new_state)
enable or disable the pccard memory bank.
Definition: at32f435_437_xmc.c:891
xmc_pccard_timing_config
void xmc_pccard_timing_config(xmc_nand_pccard_timinginit_type *xmc_regular_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_special_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_iospace_timing_struct)
initialize the xmc pccard bank according to the specified parameters in the xmc_common_spacetiming_st...
Definition: at32f435_437_xmc.c:816
xmc_nand_init
void xmc_nand_init(xmc_nand_init_type *xmc_nand_init_struct)
initialize the xmc nand banks according to the specified parameters in the xmc_nandinitstruct.
Definition: at32f435_437_xmc.c:269
xmc_pccard_init
void xmc_pccard_init(xmc_pccard_init_type *xmc_pccard_init_struct)
initialize the xmc pccard bank according to the specified parameters in the xmc_pccard_init_struct.
Definition: at32f435_437_xmc.c:792
xmc_flag_clear
void xmc_flag_clear(xmc_class_bank_type xmc_bank, xmc_interrupt_flag_type xmc_flag)
clear the xmc's pending flags.
Definition: at32f435_437_xmc.c:745
xmc_interrupt_enable
void xmc_interrupt_enable(xmc_class_bank_type xmc_bank, xmc_interrupt_sources_type xmc_int, confirm_state new_state)
enable or disable the specified xmc interrupts.
Definition: at32f435_437_xmc.c:627
xmc_nor_sram_reset
void xmc_nor_sram_reset(xmc_nor_sram_subbank_type xmc_subbank)
xmc nor or sram registers reset
Definition: at32f435_437_xmc.c:54
xmc_sdram_cmd
void xmc_sdram_cmd(xmc_sdram_cmd_type *xmc_sdram_cmd_struct)
sdram command confg
Definition: at32f435_437_xmc.c:561
xmc_nand_timing_default_para_init
void xmc_nand_timing_default_para_init(xmc_nand_pccard_timinginit_type *xmc_regular_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_special_spacetiming_struct)
fill each xmc_common_spacetiming_struct and xmc_attribute_spacetiming_struct member with its default ...
Definition: at32f435_437_xmc.c:360
xmc_sdram_status_get
uint32_t xmc_sdram_status_get(xmc_sdram_bank_type xmc_bank)
get sdram bank status
Definition: at32f435_437_xmc.c:578
xmc_nor_sram_init
void xmc_nor_sram_init(xmc_norsram_init_type *xmc_norsram_init_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_norsraminitstruct.
Definition: at32f435_437_xmc.c:78
xmc_nand_ecc_enable
void xmc_nand_ecc_enable(xmc_class_bank_type xmc_bank, confirm_state new_state)
enable or disable the xmc nand ecc feature.
Definition: at32f435_437_xmc.c:407
xmc_sdram_reset
void xmc_sdram_reset(xmc_sdram_bank_type xmc_bank)
xmc sdram registers reset
Definition: at32f435_437_xmc.c:455
xmc_nand_default_para_init
void xmc_nand_default_para_init(xmc_nand_init_type *xmc_nand_init_struct)
fill each xmc_nand_init_struct member with its default value.
Definition: at32f435_437_xmc.c:340
xmc_norsram_timing_default_para_init
void xmc_norsram_timing_default_para_init(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
fill each xmc_rw_timing_struct and xmc_w_timing_struct member with its default value.
Definition: at32f435_437_xmc.c:176
xmc_pccard_default_para_init
void xmc_pccard_default_para_init(xmc_pccard_init_type *xmc_pccard_init_struct)
fill each xmc_pccard_init_struct member with its default value.
Definition: at32f435_437_xmc.c:844
xmc_pccard_reset
void xmc_pccard_reset(void)
xmc pc card registers reset
Definition: at32f435_437_xmc.c:774
xmc_sdram_refresh_counter_set
void xmc_sdram_refresh_counter_set(uint32_t counter)
set sdram refresh counter
Definition: at32f435_437_xmc.c:595
xmc_nor_sram_timing_config
void xmc_nor_sram_timing_config(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_rw_timing_struct a...
Definition: at32f435_437_xmc.c:113
xmc_ext_timing_config
void xmc_ext_timing_config(xmc_nor_sram_subbank_type xmc_sub_bank, uint16_t w2w_timing, uint16_t r2r_timing)
config the bus turnaround phase.
Definition: at32f435_437_xmc.c:227
xmc_sdram_init
void xmc_sdram_init(xmc_sdram_init_type *xmc_sdram_init_struct, xmc_sdram_timing_type *xmc_sdram_timing_struct)
initialize the xmc sdram banks according to the specified parameters in the xmc_sdram_init_struct and...
Definition: at32f435_437_xmc.c:475
xmc_pccard_timing_default_para_init
void xmc_pccard_timing_default_para_init(xmc_nand_pccard_timinginit_type *xmc_regular_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_special_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_iospace_timing_struct)
fill each xmc_common_spacetiming_struct/xmc_attribute_spacetiming_struct and xmc_iospace_timing_struc...
Definition: at32f435_437_xmc.c:866
xmc_sdram_default_para_init
void xmc_sdram_default_para_init(xmc_sdram_init_type *xmc_sdram_init_struct, xmc_sdram_timing_type *xmc_sdram_timing_struct)
fill each xmc_sdram_init_struct member with its default value.
Definition: at32f435_437_xmc.c:532
xmc_nand_enable
void xmc_nand_enable(xmc_class_bank_type xmc_bank, confirm_state new_state)
enable or disable the specified nand memory bank.
Definition: at32f435_437_xmc.c:384
xmc_nand_reset
void xmc_nand_reset(xmc_class_bank_type xmc_bank)
xmc nand flash registers reset
Definition: at32f435_437_xmc.c:241
xmc_nand_timing_config
void xmc_nand_timing_config(xmc_nand_pccard_timinginit_type *xmc_regular_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_special_spacetiming_struct)
initialize the xmc nand banks according to the specified parameters in the xmc_nandinitstruct.
Definition: at32f435_437_xmc.c:305
xmc_norsram_default_para_init
void xmc_norsram_default_para_init(xmc_norsram_init_type *xmc_nor_sram_init_struct)
fill each xmc_nor_sram_init_struct member with its default value.
Definition: at32f435_437_xmc.c:150
xmc_nor_sram_enable
void xmc_nor_sram_enable(xmc_nor_sram_subbank_type xmc_subbank, confirm_state new_state)
enable or disable the specified nor/sram memory bank.
Definition: at32f435_437_xmc.c:210
xmc_flag_status_get
flag_status xmc_flag_status_get(xmc_class_bank_type xmc_bank, xmc_interrupt_flag_type xmc_flag)
check whether the specified xmc flag is set or not.
Definition: at32f435_437_xmc.c:695
XMC_BANK1
#define XMC_BANK1
Definition: at32f435_437_xmc.h:1009
XMC_BANK3
#define XMC_BANK3
Definition: at32f435_437_xmc.h:1011
XMC_SDRAM
#define XMC_SDRAM
Definition: at32f435_437_xmc.h:1013
XMC_BANK2
#define XMC_BANK2
Definition: at32f435_437_xmc.h:1010
XMC_BANK4
#define XMC_BANK4
Definition: at32f435_437_xmc.h:1012
xmc_nand_init_type
xmc nand init structure definition
Definition: at32f435_437_xmc.h:443
xmc_nand_init_type::ecc_enable
xmc_ecc_enable_type ecc_enable
Definition: at32f435_437_xmc.h:447
xmc_nand_init_type::delay_time_cycle
uint32_t delay_time_cycle
Definition: at32f435_437_xmc.h:449
xmc_nand_init_type::nand_bank
xmc_class_bank_type nand_bank
Definition: at32f435_437_xmc.h:444
xmc_nand_init_type::wait_enable
xmc_nand_pccard_wait_type wait_enable
Definition: at32f435_437_xmc.h:445
xmc_nand_init_type::ecc_pagesize
xmc_ecc_pagesize_type ecc_pagesize
Definition: at32f435_437_xmc.h:448
xmc_nand_init_type::delay_time_ar
uint32_t delay_time_ar
Definition: at32f435_437_xmc.h:450
xmc_nand_init_type::bus_type
xmc_data_width_type bus_type
Definition: at32f435_437_xmc.h:446
xmc_nand_pccard_timinginit_type
nand and pccard timing parameters xmc
Definition: at32f435_437_xmc.h:430
xmc_nand_pccard_timinginit_type::class_bank
xmc_class_bank_type class_bank
Definition: at32f435_437_xmc.h:431
xmc_nand_pccard_timinginit_type::mem_waite_time
uint32_t mem_waite_time
Definition: at32f435_437_xmc.h:433
xmc_nand_pccard_timinginit_type::mem_hold_time
uint32_t mem_hold_time
Definition: at32f435_437_xmc.h:434
xmc_nand_pccard_timinginit_type::mem_hiz_time
uint32_t mem_hiz_time
Definition: at32f435_437_xmc.h:435
xmc_nand_pccard_timinginit_type::mem_setup_time
uint32_t mem_setup_time
Definition: at32f435_437_xmc.h:432
xmc_norsram_init_type
xmc nor/sram init structure definition
Definition: at32f435_437_xmc.h:409
xmc_norsram_init_type::wait_signal_enable
xmc_wait_signal_type wait_signal_enable
Definition: at32f435_437_xmc.h:420
xmc_norsram_init_type::data_addr_multiplex
xmc_data_addr_mux_type data_addr_multiplex
Definition: at32f435_437_xmc.h:411
xmc_norsram_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:421
xmc_norsram_init_type::burst_mode_enable
xmc_burst_access_mode_type burst_mode_enable
Definition: at32f435_437_xmc.h:414
xmc_norsram_init_type::bus_type
xmc_data_width_type bus_type
Definition: at32f435_437_xmc.h:413
xmc_norsram_init_type::device
xmc_memory_type device
Definition: at32f435_437_xmc.h:412
xmc_norsram_init_type::wait_signal_lv
xmc_wait_signal_polarity_type wait_signal_lv
Definition: at32f435_437_xmc.h:416
xmc_norsram_init_type::wrapped_mode_enable
xmc_wrap_mode_type wrapped_mode_enable
Definition: at32f435_437_xmc.h:417
xmc_norsram_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:410
xmc_norsram_init_type::write_burst_syn
xmc_write_burst_type write_burst_syn
Definition: at32f435_437_xmc.h:422
xmc_norsram_init_type::asynwait_enable
xmc_asyn_wait_type asynwait_enable
Definition: at32f435_437_xmc.h:415
xmc_norsram_init_type::wait_signal_config
xmc_wait_timing_type wait_signal_config
Definition: at32f435_437_xmc.h:418
xmc_norsram_init_type::write_enable
xmc_write_operation_type write_enable
Definition: at32f435_437_xmc.h:419
xmc_norsram_timing_init_type
nor/sram banks timing parameters
Definition: at32f435_437_xmc.h:393
xmc_norsram_timing_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:395
xmc_norsram_timing_init_type::data_latency_time
uint32_t data_latency_time
Definition: at32f435_437_xmc.h:401
xmc_norsram_timing_init_type::addr_hold_time
uint32_t addr_hold_time
Definition: at32f435_437_xmc.h:397
xmc_norsram_timing_init_type::bus_latency_time
uint32_t bus_latency_time
Definition: at32f435_437_xmc.h:399
xmc_norsram_timing_init_type::addr_setup_time
uint32_t addr_setup_time
Definition: at32f435_437_xmc.h:396
xmc_norsram_timing_init_type::mode
xmc_access_mode_type mode
Definition: at32f435_437_xmc.h:402
xmc_norsram_timing_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:394
xmc_norsram_timing_init_type::clk_psc
uint32_t clk_psc
Definition: at32f435_437_xmc.h:400
xmc_norsram_timing_init_type::data_setup_time
uint32_t data_setup_time
Definition: at32f435_437_xmc.h:398
xmc_pccard_init_type
xmc pccard init structure definition
Definition: at32f435_437_xmc.h:458
xmc_pccard_init_type::delay_time_ar
uint32_t delay_time_ar
Definition: at32f435_437_xmc.h:461
xmc_pccard_init_type::enable_wait
xmc_nand_pccard_wait_type enable_wait
Definition: at32f435_437_xmc.h:459
xmc_pccard_init_type::delay_time_cr
uint32_t delay_time_cr
Definition: at32f435_437_xmc.h:460
xmc_sdram_cmd_type
xmc sdram command structure definition
Definition: at32f435_437_xmc.h:502
xmc_sdram_cmd_type::cmd_banks
xmc_cmd_bank1_2_type cmd_banks
Definition: at32f435_437_xmc.h:504
xmc_sdram_cmd_type::auto_refresh
uint32_t auto_refresh
Definition: at32f435_437_xmc.h:505
xmc_sdram_cmd_type::data
uint32_t data
Definition: at32f435_437_xmc.h:506
xmc_sdram_cmd_type::cmd
xmc_command_type cmd
Definition: at32f435_437_xmc.h:503
xmc_sdram_init_type
xmc sdram init structure definition
Definition: at32f435_437_xmc.h:469
xmc_sdram_init_type::row_address
xmc_sdram_row_type row_address
Definition: at32f435_437_xmc.h:477
xmc_sdram_init_type::burst_read
uint8_t burst_read
Definition: at32f435_437_xmc.h:474
xmc_sdram_init_type::clkdiv
xmc_sdram_clkdiv_type clkdiv
Definition: at32f435_437_xmc.h:472
xmc_sdram_init_type::write_protection
uint8_t write_protection
Definition: at32f435_437_xmc.h:473
xmc_sdram_init_type::column_address
xmc_sdram_column_type column_address
Definition: at32f435_437_xmc.h:476
xmc_sdram_init_type::read_delay
uint8_t read_delay
Definition: at32f435_437_xmc.h:475
xmc_sdram_init_type::width
xmc_sdram_width_type width
Definition: at32f435_437_xmc.h:479
xmc_sdram_init_type::cas
xmc_sdram_cas_type cas
Definition: at32f435_437_xmc.h:478
xmc_sdram_init_type::sdram_bank
xmc_sdram_bank_type sdram_bank
Definition: at32f435_437_xmc.h:470
xmc_sdram_init_type::internel_banks
xmc_sdram_inbk_type internel_banks
Definition: at32f435_437_xmc.h:471
xmc_sdram_timing_type
xmc sdram timing structure definition
Definition: at32f435_437_xmc.h:487
xmc_sdram_timing_type::trcd
xmc_sdram_delay_type trcd
Definition: at32f435_437_xmc.h:494
xmc_sdram_timing_type::trc
xmc_sdram_delay_type trc
Definition: at32f435_437_xmc.h:491
xmc_sdram_timing_type::tmrd
xmc_sdram_delay_type tmrd
Definition: at32f435_437_xmc.h:488
xmc_sdram_timing_type::twr
xmc_sdram_delay_type twr
Definition: at32f435_437_xmc.h:492
xmc_sdram_timing_type::tras
xmc_sdram_delay_type tras
Definition: at32f435_437_xmc.h:490
xmc_sdram_timing_type::txsr
xmc_sdram_delay_type txsr
Definition: at32f435_437_xmc.h:489
xmc_sdram_timing_type::trp
xmc_sdram_delay_type trp
Definition: at32f435_437_xmc.h:493
at32f435_437_conf.h
at32f435_437 config header file


AT32F435/437 Firmwary Library: at32f435_437_xmc.h Source File

  • libraries
  • drivers
  • inc
at32f435_437_xmc.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_XMC_H
29#define __AT32F435_437_XMC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
54typedef enum
55{
56 XMC_DATA_ADDR_MUX_DISABLE = 0x00000000,
57 XMC_DATA_ADDR_MUX_ENABLE = 0x00000002
58} xmc_data_addr_mux_type;
59
63typedef enum
64{
65 XMC_BURST_MODE_DISABLE = 0x00000000,
66 XMC_BURST_MODE_ENABLE = 0x00000100
67} xmc_burst_access_mode_type;
68
72typedef enum
73{
74 XMC_ASYN_WAIT_DISABLE = 0x00000000,
75 XMC_ASYN_WAIT_ENABLE = 0x00008000
76} xmc_asyn_wait_type;
77
81typedef enum
82{
83 XMC_WRAPPED_MODE_DISABLE = 0x00000000,
84 XMC_WRAPPED_MODE_ENABLE = 0x00000400
85} xmc_wrap_mode_type;
86
90typedef enum
91{
92 XMC_WRITE_OPERATION_DISABLE = 0x00000000,
93 XMC_WRITE_OPERATION_ENABLE = 0x00001000
94} xmc_write_operation_type;
95
99typedef enum
100{
101 XMC_WAIT_SIGNAL_DISABLE = 0x00000000,
102 XMC_WAIT_SIGNAL_ENABLE = 0x00002000
103} xmc_wait_signal_type;
104
108typedef enum
109{
110 XMC_WRITE_BURST_SYN_DISABLE = 0x00000000,
111 XMC_WRITE_BURST_SYN_ENABLE = 0x00080000
112} xmc_write_burst_type;
113
117typedef enum
118{
119 XMC_WRITE_TIMING_DISABLE = 0x00000000,
120 XMC_WRITE_TIMING_ENABLE = 0x00004000
121} xmc_extended_mode_type;
122
126typedef enum
127{
128 XMC_WAIT_OPERATION_DISABLE = 0x00000000,
129 XMC_WAIT_OPERATION_ENABLE = 0x00000002
130} xmc_nand_pccard_wait_type;
131
135typedef enum
136{
137 XMC_ECC_OPERATION_DISABLE = 0x00000000,
138 XMC_ECC_OPERATION_ENABLE = 0x00000040
139} xmc_ecc_enable_type;
140
144typedef enum
145{
146 XMC_BANK1_NOR_SRAM1 = 0x00000000,
147 XMC_BANK1_NOR_SRAM2 = 0x00000001,
148 XMC_BANK1_NOR_SRAM3 = 0x00000002,
149 XMC_BANK1_NOR_SRAM4 = 0x00000003
150} xmc_nor_sram_subbank_type;
151
155typedef enum
156{
157 XMC_BANK2_NAND = 0x00000000,
158 XMC_BANK3_NAND = 0x00000001,
159 XMC_BANK4_PCCARD = 0x00000002,
160 XMC_BANK5_6_SDRAM = 0x00000003
161} xmc_class_bank_type;
162
166typedef enum
167{
168 XMC_DEVICE_SRAM = 0x00000000,
169 XMC_DEVICE_PSRAM = 0x00000004,
170 XMC_DEVICE_NOR = 0x00000008
171} xmc_memory_type;
172
176typedef enum
177{
178 XMC_BUSTYPE_8_BITS = 0x00000000,
179 XMC_BUSTYPE_16_BITS = 0x00000010
180} xmc_data_width_type;
181
185typedef enum
186{
187 XMC_WAIT_SIGNAL_LEVEL_LOW = 0x00000000,
188 XMC_WAIT_SIGNAL_LEVEL_HIGH = 0x00000200
189} xmc_wait_signal_polarity_type;
190
194typedef enum
195{
196 XMC_WAIT_SIGNAL_SYN_BEFORE = 0x00000000,
197 XMC_WAIT_SIGNAL_SYN_DURING = 0x00000800
198} xmc_wait_timing_type;
199
203typedef enum
204{
205 XMC_ACCESS_MODE_A = 0x00000000,
206 XMC_ACCESS_MODE_B = 0x10000000,
207 XMC_ACCESS_MODE_C = 0x20000000,
208 XMC_ACCESS_MODE_D = 0x30000000
209} xmc_access_mode_type;
210
214typedef enum
215{
216 XMC_ECC_PAGESIZE_256_BYTES = 0x00000000,
217 XMC_ECC_PAGESIZE_512_BYTES = 0x00020000,
218 XMC_ECC_PAGESIZE_1024_BYTES = 0x00040000,
219 XMC_ECC_PAGESIZE_2048_BYTES = 0x00060000,
220 XMC_ECC_PAGESIZE_4096_BYTES = 0x00080000,
221 XMC_ECC_PAGESIZE_8192_BYTES = 0x000A0000
222} xmc_ecc_pagesize_type;
223
227typedef enum
228{
229 XMC_INT_RISING_EDGE = 0x00000008,
230 XMC_INT_LEVEL = 0x00000010,
231 XMC_INT_FALLING_EDGE = 0x00000020,
232 XMC_INT_ERR = 0x00004000
233} xmc_interrupt_sources_type;
234
238typedef enum
239{
240 XMC_RISINGEDGE_FLAG = 0x00000001,
241 XMC_LEVEL_FLAG = 0x00000002,
242 XMC_FALLINGEDGE_FLAG = 0x00000004,
243 XMC_FEMPT_FLAG = 0x00000040,
244 XMC_ERR_FLAG = 0x00000001,
245 XMC_BUSY_FLAG = 0x00000020
246} xmc_interrupt_flag_type;
247
251typedef enum
252{
253 XMC_COLUMN_8 = 0x00000000,
254 XMC_COLUMN_9 = 0x00000001,
255 XMC_COLUMN_10 = 0x00000002,
256 XMC_COLUMN_11 = 0x00000003
257}xmc_sdram_column_type;
258
262typedef enum
263{
264 XMC_ROW_11 = 0x00000000,
265 XMC_ROW_12 = 0x00000001,
266 XMC_ROW_13 = 0x00000002
267}xmc_sdram_row_type;
268
272typedef enum
273{
274 XMC_MEM_WIDTH_8 = 0x00000000,
275 XMC_MEM_WIDTH_16 = 0x00000001
276}xmc_sdram_width_type;
277
281typedef enum
282{
283 XMC_INBK_2 = 0x00000000,
284 XMC_INBK_4 = 0x00000001
285}xmc_sdram_inbk_type;
286
290typedef enum
291{
292 XMC_CAS_1 = 0x00000001,
293 XMC_CAS_2 = 0x00000002,
294 XMC_CAS_3 = 0x00000003
295}xmc_sdram_cas_type;
296
300typedef enum
301{
302 XMC_NO_CLK = 0x00000000,
303 XMC_CLKDIV_2 = 0x00000002,
304 XMC_CLKDIV_3 = 0x00000003,
305 XMC_CLKDIV_4 = 0x00000001
306}xmc_sdram_clkdiv_type;
307
311typedef enum
312{
313 XMC_READ_DELAY_0 = 0x00000000,
314 XMC_READ_DELAY_1 = 0x00000001,
315 XMC_READ_DELAY_2 = 0x00000002,
316}xmc_sdram_rd_delay_type;
317
321typedef enum
322{
323 XMC_SDRAM_BANK1 = 0x00000000,
324 XMC_SDRAM_BANK2 = 0x00000001
325}xmc_sdram_bank_type;
326
327
331typedef enum
332{
333 XMC_DELAY_CYCLE_1 = 0x00000000,
334 XMC_DELAY_CYCLE_2 = 0x00000001,
335 XMC_DELAY_CYCLE_3 = 0x00000002,
336 XMC_DELAY_CYCLE_4 = 0x00000003,
337 XMC_DELAY_CYCLE_5 = 0x00000004,
338 XMC_DELAY_CYCLE_6 = 0x00000005,
339 XMC_DELAY_CYCLE_7 = 0x00000006,
340 XMC_DELAY_CYCLE_8 = 0x00000007,
341 XMC_DELAY_CYCLE_9 = 0x00000008,
342 XMC_DELAY_CYCLE_10 = 0x00000009,
343 XMC_DELAY_CYCLE_11 = 0x0000000A,
344 XMC_DELAY_CYCLE_12 = 0x0000000B,
345 XMC_DELAY_CYCLE_13 = 0x0000000C,
346 XMC_DELAY_CYCLE_14 = 0x0000000D,
347 XMC_DELAY_CYCLE_15 = 0x0000000E,
348 XMC_DELAY_CYCLE_16 = 0x0000000F
349}xmc_sdram_delay_type;
350
351
355typedef enum
356{
357 XMC_CMD_NORMAL = 0x00000000,
358 XMC_CMD_CLK = 0x00000001,
359 XMC_CMD_PRECHARG_ALL = 0x00000002,
360 XMC_CMD_AUTO_REFRESH = 0x00000003,
361 XMC_CMD_LOAD_MODE = 0x00000004,
362 XMC_CMD_SELF_REFRESH = 0x00000005,
363 XMC_CMD_POWER_DOWN = 0x00000006
364}xmc_command_type;
365
369typedef enum
370{
371 XMC_CMD_BANK1 = 0x00000010,
372 XMC_CMD_BANK2 = 0x00000008,
373 XMC_CMD_BANK1_2 = 0x00000018
374}xmc_cmd_bank1_2_type;
375
376
380typedef enum
381{
382 XMC_STATUS_NORMAL = 0x00000000,
383 XMC_STATUS_SELF_REFRESH = 0x00000001,
384 XMC_STATUS_POWER_DOWN = 0x00000002,
385 XMC_STATUS_MASK = 0x00000003
386}xmc_bank_status_type;
387
388
392typedef struct
393{
394 xmc_nor_sram_subbank_type subbank;
395 xmc_extended_mode_type write_timing_enable;
396 uint32_t addr_setup_time;
397 uint32_t addr_hold_time;
398 uint32_t data_setup_time;
399 uint32_t bus_latency_time;
400 uint32_t clk_psc;
401 uint32_t data_latency_time;
402 xmc_access_mode_type mode;
403} xmc_norsram_timing_init_type;
404
408typedef struct
409{
410 xmc_nor_sram_subbank_type subbank;
411 xmc_data_addr_mux_type data_addr_multiplex;
412 xmc_memory_type device;
413 xmc_data_width_type bus_type;
414 xmc_burst_access_mode_type burst_mode_enable;
415 xmc_asyn_wait_type asynwait_enable;
416 xmc_wait_signal_polarity_type wait_signal_lv;
417 xmc_wrap_mode_type wrapped_mode_enable;
418 xmc_wait_timing_type wait_signal_config;
419 xmc_write_operation_type write_enable;
420 xmc_wait_signal_type wait_signal_enable;
421 xmc_extended_mode_type write_timing_enable;
422 xmc_write_burst_type write_burst_syn;
423} xmc_norsram_init_type;
424
429typedef struct
430{
431 xmc_class_bank_type class_bank;
432 uint32_t mem_setup_time;
433 uint32_t mem_waite_time;
434 uint32_t mem_hold_time;
435 uint32_t mem_hiz_time;
436} xmc_nand_pccard_timinginit_type;
437
442typedef struct
443{
444 xmc_class_bank_type nand_bank;
445 xmc_nand_pccard_wait_type wait_enable;
446 xmc_data_width_type bus_type;
447 xmc_ecc_enable_type ecc_enable;
448 xmc_ecc_pagesize_type ecc_pagesize;
449 uint32_t delay_time_cycle;
450 uint32_t delay_time_ar;
451} xmc_nand_init_type;
452
457typedef struct
458{
459 xmc_nand_pccard_wait_type enable_wait;
460 uint32_t delay_time_cr;
461 uint32_t delay_time_ar;
462} xmc_pccard_init_type;
463
468typedef struct
469{
470 xmc_sdram_bank_type sdram_bank;
471 xmc_sdram_inbk_type internel_banks;
472 xmc_sdram_clkdiv_type clkdiv;
473 uint8_t write_protection;
474 uint8_t burst_read;
475 uint8_t read_delay;
476 xmc_sdram_column_type column_address;
477 xmc_sdram_row_type row_address;
478 xmc_sdram_cas_type cas;
479 xmc_sdram_width_type width;
480} xmc_sdram_init_type;
481
486typedef struct
487{
488 xmc_sdram_delay_type tmrd;
489 xmc_sdram_delay_type txsr;
490 xmc_sdram_delay_type tras;
491 xmc_sdram_delay_type trc;
492 xmc_sdram_delay_type twr;
493 xmc_sdram_delay_type trp;
494 xmc_sdram_delay_type trcd;
495} xmc_sdram_timing_type;
496
501typedef struct
502{
503 xmc_command_type cmd;
504 xmc_cmd_bank1_2_type cmd_banks;
505 uint32_t auto_refresh;
506 uint32_t data;
507} xmc_sdram_cmd_type;
508
509typedef struct
510{
514 union
515 {
516 __IO uint32_t bk1ctrl;
517 struct
518 {
519 __IO uint32_t en : 1; /* [0] */
520 __IO uint32_t admuxen : 1; /* [1] */
521 __IO uint32_t dev : 2; /* [3:2] */
522 __IO uint32_t extmdbw : 2; /* [5:4] */
523 __IO uint32_t noren : 1; /* [6] */
524 __IO uint32_t reserved1 : 1; /* [7] */
525 __IO uint32_t syncben : 1; /* [8] */
526 __IO uint32_t nwpol : 1; /* [9] */
527 __IO uint32_t wrapen : 1; /* [10] */
528 __IO uint32_t nwtcfg : 1; /* [11] */
529 __IO uint32_t wen : 1; /* [12] */
530 __IO uint32_t nwsen : 1; /* [13] */
531 __IO uint32_t rwtd : 1; /* [14] */
532 __IO uint32_t nwasen : 1; /* [15] */
533 __IO uint32_t crpgs : 3; /* [18:16] */
534 __IO uint32_t mwmc : 1; /* [19] */
535 __IO uint32_t reserved2 : 12;/* [31:20] */
536 } bk1ctrl_bit;
537 };
538
542 union
543 {
544 __IO uint32_t bk1tmg;
545 struct
546 {
547 __IO uint32_t addrst : 4; /* [3:0] */
548 __IO uint32_t addrht : 4; /* [7:4] */
549 __IO uint32_t dtst : 8; /* [15:8] */
550 __IO uint32_t buslat : 4; /* [19:16] */
551 __IO uint32_t clkpsc : 4; /* [23:20] */
552 __IO uint32_t dtlat : 4; /* [27:24] */
553 __IO uint32_t asyncm : 2; /* [29:28] */
554 __IO uint32_t reserved1 : 2; /* [31:30] */
555 } bk1tmg_bit;
556 };
557
558} xmc_bank1_ctrl_tmg_reg_type;
559
560typedef struct
561{
565 union
566 {
567 __IO uint32_t bk1tmgwr;
568 struct
569 {
570 __IO uint32_t addrst : 4; /* [3:0] */
571 __IO uint32_t addrht : 4; /* [7:4] */
572 __IO uint32_t dtst : 8; /* [15:8] */
573 __IO uint32_t buslat : 4; /* [19:16] */
574 __IO uint32_t reserved1 : 8; /* [27:20] */
575 __IO uint32_t asyncm : 2; /* [29:28] */
576 __IO uint32_t reserved2 : 2; /* [31:30] */
577 } bk1tmgwr_bit;
578 };
579
583 __IO uint32_t reserved1;
584
585} xmc_bank1_tmgwr_reg_type;
586
590typedef struct
591{
595 xmc_bank1_ctrl_tmg_reg_type ctrl_tmg_group[4];
596
600 __IO uint32_t reserved1[57];
601
605 xmc_bank1_tmgwr_reg_type tmgwr_group[4];
606
610 __IO uint32_t reserved2[63];
611
615 union
616 {
617 __IO uint32_t ext[4];
618 struct
619 {
620 __IO uint32_t buslatw2w : 8; /* [7:0] */
621 __IO uint32_t buslatr2r : 8; /* [15:8] */
622 __IO uint32_t reserved1 : 16;/* [31:16] */
623 } ext_bit[4];
624 };
625
626} xmc_bank1_type;
627
631typedef struct
632{
636 union
637 {
638 __IO uint32_t bk2ctrl;
639 struct
640 {
641 __IO uint32_t reserved1 : 1; /* [0] */
642 __IO uint32_t nwen : 1; /* [1] */
643 __IO uint32_t en : 1; /* [2] */
644 __IO uint32_t dev : 1; /* [3] */
645 __IO uint32_t extmdbw : 2; /* [5:4] */
646 __IO uint32_t eccen : 1; /* [6] */
647 __IO uint32_t reserved2 : 2; /* [8:7] */
648 __IO uint32_t tcr : 4; /* [12:9] */
649 __IO uint32_t tar : 4; /* [16:13] */
650 __IO uint32_t eccpgs : 3; /* [19:17] */
651 __IO uint32_t reserved3 : 12;/* [31:20] */
652 } bk2ctrl_bit;
653 };
654
658 union
659 {
660 __IO uint32_t bk2is;
661 struct
662 {
663 __IO uint32_t res : 1; /* [0] */
664 __IO uint32_t hls : 1; /* [1] */
665 __IO uint32_t fes : 1; /* [2] */
666 __IO uint32_t reien : 1; /* [3] */
667 __IO uint32_t hlien : 1; /* [4] */
668 __IO uint32_t feien : 1; /* [5] */
669 __IO uint32_t fifoe : 1; /* [6] */
670 __IO uint32_t reserved1 : 25;/* [31:7] */
671 } bk2is_bit;
672 };
673
677 union
678 {
679 __IO uint32_t bk2tmgmem;
680 struct
681 {
682 __IO uint32_t cmst : 8; /* [7:0] */
683 __IO uint32_t cmwt : 8; /* [15:8] */
684 __IO uint32_t cmht : 8; /* [23:16] */
685 __IO uint32_t cmdhizt : 8; /* [31:24] */
686 } bk2tmgmem_bit;
687 };
688
692 union
693 {
694 __IO uint32_t bk2tmgatt;
695 struct
696 {
697 __IO uint32_t amst : 8; /* [7:0] */
698 __IO uint32_t amwt : 8; /* [15:8] */
699 __IO uint32_t amht : 8; /* [23:16] */
700 __IO uint32_t amdhizt : 8; /* [31:24] */
701 } bk2tmgatt_bit;
702 };
703
707 __IO uint32_t reserved1;
708
712 union
713 {
714 __IO uint32_t bk2ecc;
715 struct
716 {
717 __IO uint32_t ecc : 32; /* [31:0] */
718 } bk2ecc_bit;
719 };
720
721} xmc_bank2_type;
722
726typedef struct
727{
731 union
732 {
733 __IO uint32_t bk3ctrl;
734 struct
735 {
736 __IO uint32_t reserved1 : 1; /* [0] */
737 __IO uint32_t nwen : 1; /* [1] */
738 __IO uint32_t en : 1; /* [2] */
739 __IO uint32_t dev : 1; /* [3] */
740 __IO uint32_t extmdbw : 2; /* [5:4] */
741 __IO uint32_t eccen : 1; /* [6] */
742 __IO uint32_t reserved2 : 2; /* [8:7] */
743 __IO uint32_t tcr : 4; /* [12:9] */
744 __IO uint32_t tar : 4; /* [16:13] */
745 __IO uint32_t eccpgs : 3; /* [19:17] */
746 __IO uint32_t reserved3 : 12;/* [31:20] */
747 } bk3ctrl_bit;
748 };
749
753 union
754 {
755 __IO uint32_t bk3is;
756 struct
757 {
758 __IO uint32_t res : 1; /* [0] */
759 __IO uint32_t hls : 1; /* [1] */
760 __IO uint32_t fes : 1; /* [2] */
761 __IO uint32_t reien : 1; /* [3] */
762 __IO uint32_t hlien : 1; /* [4] */
763 __IO uint32_t feien : 1; /* [5] */
764 __IO uint32_t fifoe : 1; /* [6] */
765 __IO uint32_t reserved1 : 25;/* [31:7] */
766 } bk3is_bit;
767 };
768
772 union
773 {
774 __IO uint32_t bk3tmgmem;
775 struct
776 {
777 __IO uint32_t cmst : 8; /* [7:0] */
778 __IO uint32_t cmwt : 8; /* [15:8] */
779 __IO uint32_t cmht : 8; /* [23:16] */
780 __IO uint32_t cmdhizt : 8; /* [31:24] */
781 } bk3tmgmem_bit;
782 };
783
787 union
788 {
789 __IO uint32_t bk3tmgatt;
790 struct
791 {
792 __IO uint32_t amst : 8; /* [7:0] */
793 __IO uint32_t amwt : 8; /* [15:8] */
794 __IO uint32_t amht : 8; /* [23:16] */
795 __IO uint32_t amdhizt : 8; /* [31:24] */
796 } bk3tmgatt_bit;
797 };
798
802 __IO uint32_t reserved1;
803
807 union
808 {
809 __IO uint32_t bk3ecc;
810 struct
811 {
812 __IO uint32_t ecc : 32; /* [31:0] */
813 } bk3ecc_bit;
814 };
815} xmc_bank3_type;
816
820typedef struct
821{
822
826 union
827 {
828 __IO uint32_t bk4ctrl;
829 struct
830 {
831 __IO uint32_t reserved1 : 1; /* [0] */
832 __IO uint32_t nwen : 1; /* [1] */
833 __IO uint32_t en : 1; /* [2] */
834 __IO uint32_t dev : 1; /* [3] */
835 __IO uint32_t extmdbw : 2; /* [5:4] */
836 __IO uint32_t eccen : 1; /* [6] */
837 __IO uint32_t reserved2 : 2; /* [8:7] */
838 __IO uint32_t tcr : 4; /* [12:9] */
839 __IO uint32_t tar : 4; /* [16:13] */
840 __IO uint32_t eccpgs : 3; /* [19:17] */
841 __IO uint32_t reserved3 : 12;/* [31:20] */
842 } bk4ctrl_bit;
843 };
844
848 union
849 {
850 __IO uint32_t bk4is;
851 struct
852 {
853 __IO uint32_t res : 1; /* [0] */
854 __IO uint32_t hls : 1; /* [1] */
855 __IO uint32_t fes : 1; /* [2] */
856 __IO uint32_t reien : 1; /* [3] */
857 __IO uint32_t hlien : 1; /* [4] */
858 __IO uint32_t feien : 1; /* [5] */
859 __IO uint32_t fifoe : 1; /* [6] */
860 __IO uint32_t reserved1 : 25;/* [31:7] */
861 } bk4is_bit;
862 };
863
867 union
868 {
869 __IO uint32_t bk4tmgmem;
870 struct
871 {
872 __IO uint32_t cmst : 8; /* [7:0] */
873 __IO uint32_t cmwt : 8; /* [15:8] */
874 __IO uint32_t cmht : 8; /* [23:16] */
875 __IO uint32_t cmdhizt : 8; /* [31:24] */
876 } bk4tmgmem_bit;
877 };
878
882 union
883 {
884 __IO uint32_t bk4tmgatt;
885 struct
886 {
887 __IO uint32_t amst : 8; /* [7:0] */
888 __IO uint32_t amwt : 8; /* [15:8] */
889 __IO uint32_t amht : 8; /* [23:16] */
890 __IO uint32_t amdhizt : 8; /* [31:24] */
891 } bk4tmgatt_bit;
892 };
893
897 union
898 {
899 __IO uint32_t bk4tmgio;
900 struct
901 {
902 __IO uint32_t iost : 8; /* [7:0] */
903 __IO uint32_t iowt : 8; /* [15:8] */
904 __IO uint32_t ioht : 8; /* [23:16] */
905 __IO uint32_t iohizt : 8; /* [31:24] */
906 } bk4tmgio_bit;
907 };
908} xmc_bank4_type;
909
913typedef struct
914{
918 union
919 {
920 __IO uint32_t ctrl[2];
921 struct
922 {
923 __IO uint32_t ca : 2; /* [1:0] */
924 __IO uint32_t ra : 2; /* [3:2] */
925 __IO uint32_t db : 2; /* [5:4] */
926 __IO uint32_t inbk : 1; /* [6] */
927 __IO uint32_t cas : 2; /* [8:7] */
928 __IO uint32_t wrp : 1; /* [9] */
929 __IO uint32_t clkdiv : 2; /* [11:10] */
930 __IO uint32_t bstr : 1; /* [12] */
931 __IO uint32_t rd : 2; /* [14:13] */
932 __IO uint32_t reserved1 : 17;/* [31:15] */
933 } ctrl_bit[2];
934 };
935
939 union
940 {
941 __IO uint32_t tm[2];
942 struct
943 {
944 __IO uint32_t tmrd : 4; /* [3:0] */
945 __IO uint32_t txsr : 4; /* [7:4] */
946 __IO uint32_t tras : 4; /* [11:8] */
947 __IO uint32_t trc : 4; /* [15:12] */
948 __IO uint32_t twr : 4; /* [19:16] */
949 __IO uint32_t trp : 4; /* [23:20] */
950 __IO uint32_t trcd : 4; /* [27:24] */
951 __IO uint32_t reserved1 : 4; /* [31:28] */
952 } tm_bit[2];
953
954 };
955
959 union
960 {
961 __IO uint32_t cmd;
962 struct
963 {
964 __IO uint32_t cmd : 3; /* [2:0] */
965 __IO uint32_t bk2 : 1; /* [3] */
966 __IO uint32_t bk1 : 1; /* [4] */
967 __IO uint32_t art : 4; /* [8:5] */
968 __IO uint32_t mrd : 13;/* [21:9] */
969 __IO uint32_t reserved1 : 10;/* [31:22] */
970 } cmd_bit;
971 };
972
976 union
977 {
978 __IO uint32_t rcnt;
979 struct
980 {
981 __IO uint32_t errc : 1; /* [0] */
982 __IO uint32_t rc : 13;/* [13:1] */
983 __IO uint32_t erien : 1; /* [14] */
984 __IO uint32_t reserved1 : 17;/* [31:15] */
985 } rcnt_bit;
986 };
987
991 union
992 {
993 __IO uint32_t sts;
994 struct
995 {
996 __IO uint32_t err : 1; /* [0] */
997 __IO uint32_t bk1sts : 2; /* [2:1] */
998 __IO uint32_t bk2sts : 2; /* [4:3] */
999 __IO uint32_t busy : 1; /* [5] */
1000 __IO uint32_t reserved1 : 26;/* [31:6] */
1001 } sts_bit;
1002 };
1003}xmc_sdram_type;
1004
1009#define XMC_BANK1 ((xmc_bank1_type *) XMC_BANK1_REG_BASE)
1010#define XMC_BANK2 ((xmc_bank2_type *) XMC_BANK2_REG_BASE)
1011#define XMC_BANK3 ((xmc_bank3_type *) XMC_BANK3_REG_BASE)
1012#define XMC_BANK4 ((xmc_bank4_type *) XMC_BANK4_REG_BASE)
1013#define XMC_SDRAM ((xmc_sdram_type *) XMC_SDRAM_REG_BASE)
1014
1019void xmc_nor_sram_reset(xmc_nor_sram_subbank_type xmc_subbank);
1020void xmc_nor_sram_init(xmc_norsram_init_type* xmc_norsram_init_struct);
1021void xmc_nor_sram_timing_config(xmc_norsram_timing_init_type* xmc_rw_timing_struct,
1022 xmc_norsram_timing_init_type* xmc_w_timing_struct);
1023void xmc_norsram_default_para_init(xmc_norsram_init_type* xmc_nor_sram_init_struct);
1024void xmc_norsram_timing_default_para_init(xmc_norsram_timing_init_type* xmc_rw_timing_struct,
1025 xmc_norsram_timing_init_type* xmc_w_timing_struct);
1026void xmc_nor_sram_enable(xmc_nor_sram_subbank_type xmc_subbank, confirm_state new_state);
1027void xmc_ext_timing_config(xmc_nor_sram_subbank_type xmc_sub_bank, uint16_t w2w_timing, uint16_t r2r_timing);
1028void xmc_nand_reset(xmc_class_bank_type xmc_bank);
1029void xmc_nand_init(xmc_nand_init_type* xmc_nand_init_struct);
1030void xmc_nand_timing_config(xmc_nand_pccard_timinginit_type* xmc_common_spacetiming_struct,
1031 xmc_nand_pccard_timinginit_type* xmc_attribute_spacetiming_struct);
1032void xmc_nand_default_para_init(xmc_nand_init_type* xmc_nand_init_struct);
1033void xmc_nand_timing_default_para_init(xmc_nand_pccard_timinginit_type* xmc_common_spacetiming_struct,
1034 xmc_nand_pccard_timinginit_type* xmc_attribute_spacetiming_struct);
1035void xmc_nand_enable(xmc_class_bank_type xmc_bank, confirm_state new_state);
1036void xmc_nand_ecc_enable(xmc_class_bank_type xmc_bank, confirm_state new_state);
1037uint32_t xmc_ecc_get(xmc_class_bank_type xmc_bank);
1038void xmc_interrupt_enable(xmc_class_bank_type xmc_bank, xmc_interrupt_sources_type xmc_int, confirm_state new_state);
1039 flag_status xmc_flag_status_get(xmc_class_bank_type xmc_bank, xmc_interrupt_flag_type xmc_flag);
1040void xmc_flag_clear(xmc_class_bank_type xmc_bank, xmc_interrupt_flag_type xmc_flag);
1041void xmc_pccard_reset(void);
1042void xmc_pccard_init(xmc_pccard_init_type* xmc_pccard_init_struct);
1043void xmc_pccard_timing_config(xmc_nand_pccard_timinginit_type* xmc_common_spacetiming_struct,
1044 xmc_nand_pccard_timinginit_type* xmc_attribute_spacetiming_struct,
1045 xmc_nand_pccard_timinginit_type* xmc_iospace_timing_struct);
1046void xmc_pccard_default_para_init(xmc_pccard_init_type* xmc_pccard_init_struct);
1047void xmc_pccard_timing_default_para_init(xmc_nand_pccard_timinginit_type* xmc_common_spacetiming_struct,
1048 xmc_nand_pccard_timinginit_type* xmc_attribute_spacetiming_struct,
1049 xmc_nand_pccard_timinginit_type* xmc_iospace_timing_struct);
1050void xmc_pccard_enable(confirm_state new_state);
1051void xmc_sdram_reset(xmc_sdram_bank_type xmc_bank);
1052void xmc_sdram_init(xmc_sdram_init_type *xmc_sdram_init_struct, xmc_sdram_timing_type *xmc_sdram_timing_struct);
1053void xmc_sdram_default_para_init(xmc_sdram_init_type *xmc_sdram_init_struct, xmc_sdram_timing_type *xmc_sdram_timing_struct);
1054void xmc_sdram_cmd(xmc_sdram_cmd_type *xmc_sdram_cmd_struct);
1055uint32_t xmc_sdram_status_get(xmc_sdram_bank_type xmc_bank);
1056void xmc_sdram_refresh_counter_set(uint32_t counter);
1057void xmc_sdram_auto_refresh_set(uint32_t number);
1058
1071#ifdef __cplusplus
1072}
1073#endif
1074
1075#endif
at32f435_437.h
at32f435_437 header file
counter
uint16_t counter
Definition: project/at_start_f435/examples/debug/tmr1/src/main.c:39
number
uint32_t number
Definition: project/at_start_f435/examples/xmc/nor_flash/src/main.c:44
confirm_state
confirm_state
Definition: at32f435_437.h:379
flag_status
flag_status
Definition: at32f435_437.h:378
xmc_ecc_get
uint32_t xmc_ecc_get(xmc_class_bank_type xmc_bank)
return the error correction code register value.
Definition: at32f435_437_xmc.c:429
xmc_sdram_auto_refresh_set
void xmc_sdram_auto_refresh_set(uint32_t number)
set sdram auto refresh number
Definition: at32f435_437_xmc.c:605
xmc_pccard_enable
void xmc_pccard_enable(confirm_state new_state)
enable or disable the pccard memory bank.
Definition: at32f435_437_xmc.c:891
xmc_pccard_timing_default_para_init
void xmc_pccard_timing_default_para_init(xmc_nand_pccard_timinginit_type *xmc_common_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_attribute_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_iospace_timing_struct)
fill each xmc_common_spacetiming_struct/xmc_attribute_spacetiming_struct and xmc_iospace_timing_struc...
Definition: at32f435_437_xmc.c:866
xmc_nand_init
void xmc_nand_init(xmc_nand_init_type *xmc_nand_init_struct)
initialize the xmc nand banks according to the specified parameters in the xmc_nandinitstruct.
Definition: at32f435_437_xmc.c:269
xmc_pccard_init
void xmc_pccard_init(xmc_pccard_init_type *xmc_pccard_init_struct)
initialize the xmc pccard bank according to the specified parameters in the xmc_pccard_init_struct.
Definition: at32f435_437_xmc.c:792
xmc_flag_clear
void xmc_flag_clear(xmc_class_bank_type xmc_bank, xmc_interrupt_flag_type xmc_flag)
clear the xmc's pending flags.
Definition: at32f435_437_xmc.c:745
xmc_nand_timing_default_para_init
void xmc_nand_timing_default_para_init(xmc_nand_pccard_timinginit_type *xmc_common_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_attribute_spacetiming_struct)
fill each xmc_common_spacetiming_struct and xmc_attribute_spacetiming_struct member with its default ...
Definition: at32f435_437_xmc.c:360
xmc_interrupt_enable
void xmc_interrupt_enable(xmc_class_bank_type xmc_bank, xmc_interrupt_sources_type xmc_int, confirm_state new_state)
enable or disable the specified xmc interrupts.
Definition: at32f435_437_xmc.c:627
xmc_nor_sram_reset
void xmc_nor_sram_reset(xmc_nor_sram_subbank_type xmc_subbank)
xmc nor or sram registers reset
Definition: at32f435_437_xmc.c:54
xmc_sdram_cmd
void xmc_sdram_cmd(xmc_sdram_cmd_type *xmc_sdram_cmd_struct)
sdram command confg
Definition: at32f435_437_xmc.c:561
xmc_sdram_status_get
uint32_t xmc_sdram_status_get(xmc_sdram_bank_type xmc_bank)
get sdram bank status
Definition: at32f435_437_xmc.c:578
xmc_nor_sram_init
void xmc_nor_sram_init(xmc_norsram_init_type *xmc_norsram_init_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_norsraminitstruct.
Definition: at32f435_437_xmc.c:78
xmc_nand_ecc_enable
void xmc_nand_ecc_enable(xmc_class_bank_type xmc_bank, confirm_state new_state)
enable or disable the xmc nand ecc feature.
Definition: at32f435_437_xmc.c:407
xmc_sdram_reset
void xmc_sdram_reset(xmc_sdram_bank_type xmc_bank)
xmc sdram registers reset
Definition: at32f435_437_xmc.c:455
xmc_nand_default_para_init
void xmc_nand_default_para_init(xmc_nand_init_type *xmc_nand_init_struct)
fill each xmc_nand_init_struct member with its default value.
Definition: at32f435_437_xmc.c:340
xmc_norsram_timing_default_para_init
void xmc_norsram_timing_default_para_init(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
fill each xmc_rw_timing_struct and xmc_w_timing_struct member with its default value.
Definition: at32f435_437_xmc.c:176
xmc_pccard_default_para_init
void xmc_pccard_default_para_init(xmc_pccard_init_type *xmc_pccard_init_struct)
fill each xmc_pccard_init_struct member with its default value.
Definition: at32f435_437_xmc.c:844
xmc_pccard_timing_config
void xmc_pccard_timing_config(xmc_nand_pccard_timinginit_type *xmc_common_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_attribute_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_iospace_timing_struct)
initialize the xmc pccard bank according to the specified parameters in the xmc_common_spacetiming_st...
Definition: at32f435_437_xmc.c:816
xmc_pccard_reset
void xmc_pccard_reset(void)
xmc pc card registers reset
Definition: at32f435_437_xmc.c:774
xmc_sdram_refresh_counter_set
void xmc_sdram_refresh_counter_set(uint32_t counter)
set sdram refresh counter
Definition: at32f435_437_xmc.c:595
xmc_nor_sram_timing_config
void xmc_nor_sram_timing_config(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_rw_timing_struct a...
Definition: at32f435_437_xmc.c:113
xmc_nand_timing_config
void xmc_nand_timing_config(xmc_nand_pccard_timinginit_type *xmc_common_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_attribute_spacetiming_struct)
initialize the xmc nand banks according to the specified parameters in the xmc_nandinitstruct.
Definition: at32f435_437_xmc.c:305
xmc_ext_timing_config
void xmc_ext_timing_config(xmc_nor_sram_subbank_type xmc_sub_bank, uint16_t w2w_timing, uint16_t r2r_timing)
config the bus turnaround phase.
Definition: at32f435_437_xmc.c:227
xmc_sdram_init
void xmc_sdram_init(xmc_sdram_init_type *xmc_sdram_init_struct, xmc_sdram_timing_type *xmc_sdram_timing_struct)
initialize the xmc sdram banks according to the specified parameters in the xmc_sdram_init_struct and...
Definition: at32f435_437_xmc.c:475
xmc_sdram_default_para_init
void xmc_sdram_default_para_init(xmc_sdram_init_type *xmc_sdram_init_struct, xmc_sdram_timing_type *xmc_sdram_timing_struct)
fill each xmc_sdram_init_struct member with its default value.
Definition: at32f435_437_xmc.c:532
xmc_nand_enable
void xmc_nand_enable(xmc_class_bank_type xmc_bank, confirm_state new_state)
enable or disable the specified nand memory bank.
Definition: at32f435_437_xmc.c:384
xmc_nand_reset
void xmc_nand_reset(xmc_class_bank_type xmc_bank)
xmc nand flash registers reset
Definition: at32f435_437_xmc.c:241
xmc_norsram_default_para_init
void xmc_norsram_default_para_init(xmc_norsram_init_type *xmc_nor_sram_init_struct)
fill each xmc_nor_sram_init_struct member with its default value.
Definition: at32f435_437_xmc.c:150
xmc_nor_sram_enable
void xmc_nor_sram_enable(xmc_nor_sram_subbank_type xmc_subbank, confirm_state new_state)
enable or disable the specified nor/sram memory bank.
Definition: at32f435_437_xmc.c:210
xmc_flag_status_get
flag_status xmc_flag_status_get(xmc_class_bank_type xmc_bank, xmc_interrupt_flag_type xmc_flag)
check whether the specified xmc flag is set or not.
Definition: at32f435_437_xmc.c:695
xmc_command_type
xmc_command_type
xmc sdram command type
Definition: at32f435_437_xmc.h:356
xmc_wait_signal_type
xmc_wait_signal_type
xmc wait signal type
Definition: at32f435_437_xmc.h:100
xmc_sdram_delay_type
xmc_sdram_delay_type
xmc sdram timing delay cycle type
Definition: at32f435_437_xmc.h:332
xmc_wait_timing_type
xmc_wait_timing_type
xmc wait timing type
Definition: at32f435_437_xmc.h:195
xmc_write_operation_type
xmc_write_operation_type
xmc write operation type
Definition: at32f435_437_xmc.h:91
xmc_write_burst_type
xmc_write_burst_type
xmc write burst type
Definition: at32f435_437_xmc.h:109
xmc_burst_access_mode_type
xmc_burst_access_mode_type
xmc burst access mode type
Definition: at32f435_437_xmc.h:64
xmc_class_bank_type
xmc_class_bank_type
xmc class bank type
Definition: at32f435_437_xmc.h:156
xmc_sdram_clkdiv_type
xmc_sdram_clkdiv_type
xmc sdram clock div type
Definition: at32f435_437_xmc.h:301
xmc_data_addr_mux_type
xmc_data_addr_mux_type
xmc data address bus multiplexing type
Definition: at32f435_437_xmc.h:55
xmc_bank_status_type
xmc_bank_status_type
xmc sdram bank status type
Definition: at32f435_437_xmc.h:381
xmc_interrupt_sources_type
xmc_interrupt_sources_type
xmc interrupt sources type
Definition: at32f435_437_xmc.h:228
xmc_data_width_type
xmc_data_width_type
xmc data width type
Definition: at32f435_437_xmc.h:177
xmc_sdram_bank_type
xmc_sdram_bank_type
xmc sdram bank type
Definition: at32f435_437_xmc.h:322
xmc_extended_mode_type
xmc_extended_mode_type
xmc extended mode type
Definition: at32f435_437_xmc.h:118
xmc_nor_sram_subbank_type
xmc_nor_sram_subbank_type
xmc nor/sram subbank type
Definition: at32f435_437_xmc.h:145
xmc_interrupt_flag_type
xmc_interrupt_flag_type
xmc interrupt flag type
Definition: at32f435_437_xmc.h:239
xmc_sdram_row_type
xmc_sdram_row_type
xmc sdram number of row address type
Definition: at32f435_437_xmc.h:263
xmc_sdram_rd_delay_type
xmc_sdram_rd_delay_type
xmc sdram read delay
Definition: at32f435_437_xmc.h:312
xmc_sdram_inbk_type
xmc_sdram_inbk_type
xmc sdram number of internal banks type
Definition: at32f435_437_xmc.h:282
xmc_asyn_wait_type
xmc_asyn_wait_type
xmc asynchronous wait type
Definition: at32f435_437_xmc.h:73
xmc_nand_pccard_wait_type
xmc_nand_pccard_wait_type
xmc pccard wait type
Definition: at32f435_437_xmc.h:127
xmc_sdram_cas_type
xmc_sdram_cas_type
xmc sdram cas latency type
Definition: at32f435_437_xmc.h:291
xmc_wrap_mode_type
xmc_wrap_mode_type
xmc wrapped mode type
Definition: at32f435_437_xmc.h:82
xmc_ecc_pagesize_type
xmc_ecc_pagesize_type
xmc ecc page size type
Definition: at32f435_437_xmc.h:215
xmc_access_mode_type
xmc_access_mode_type
xmc access mode type
Definition: at32f435_437_xmc.h:204
xmc_cmd_bank1_2_type
xmc_cmd_bank1_2_type
xmc sdram command bank select type
Definition: at32f435_437_xmc.h:370
xmc_ecc_enable_type
xmc_ecc_enable_type
xmc ecc enable type
Definition: at32f435_437_xmc.h:136
xmc_wait_signal_polarity_type
xmc_wait_signal_polarity_type
xmc wait signal polarity type
Definition: at32f435_437_xmc.h:186
xmc_sdram_width_type
xmc_sdram_width_type
xmc sdram memory data bus width type
Definition: at32f435_437_xmc.h:273
xmc_memory_type
xmc_memory_type
xmc memory type
Definition: at32f435_437_xmc.h:167
xmc_sdram_column_type
xmc_sdram_column_type
xmc sdram number of column address type
Definition: at32f435_437_xmc.h:252
XMC_CMD_LOAD_MODE
@ XMC_CMD_LOAD_MODE
Definition: at32f435_437_xmc.h:361
XMC_CMD_NORMAL
@ XMC_CMD_NORMAL
Definition: at32f435_437_xmc.h:357
XMC_CMD_SELF_REFRESH
@ XMC_CMD_SELF_REFRESH
Definition: at32f435_437_xmc.h:362
XMC_CMD_CLK
@ XMC_CMD_CLK
Definition: at32f435_437_xmc.h:358
XMC_CMD_AUTO_REFRESH
@ XMC_CMD_AUTO_REFRESH
Definition: at32f435_437_xmc.h:360
XMC_CMD_PRECHARG_ALL
@ XMC_CMD_PRECHARG_ALL
Definition: at32f435_437_xmc.h:359
XMC_CMD_POWER_DOWN
@ XMC_CMD_POWER_DOWN
Definition: at32f435_437_xmc.h:363
XMC_WAIT_SIGNAL_DISABLE
@ XMC_WAIT_SIGNAL_DISABLE
Definition: at32f435_437_xmc.h:101
XMC_WAIT_SIGNAL_ENABLE
@ XMC_WAIT_SIGNAL_ENABLE
Definition: at32f435_437_xmc.h:102
XMC_DELAY_CYCLE_5
@ XMC_DELAY_CYCLE_5
Definition: at32f435_437_xmc.h:337
XMC_DELAY_CYCLE_9
@ XMC_DELAY_CYCLE_9
Definition: at32f435_437_xmc.h:341
XMC_DELAY_CYCLE_11
@ XMC_DELAY_CYCLE_11
Definition: at32f435_437_xmc.h:343
XMC_DELAY_CYCLE_16
@ XMC_DELAY_CYCLE_16
Definition: at32f435_437_xmc.h:348
XMC_DELAY_CYCLE_13
@ XMC_DELAY_CYCLE_13
Definition: at32f435_437_xmc.h:345
XMC_DELAY_CYCLE_10
@ XMC_DELAY_CYCLE_10
Definition: at32f435_437_xmc.h:342
XMC_DELAY_CYCLE_7
@ XMC_DELAY_CYCLE_7
Definition: at32f435_437_xmc.h:339
XMC_DELAY_CYCLE_4
@ XMC_DELAY_CYCLE_4
Definition: at32f435_437_xmc.h:336
XMC_DELAY_CYCLE_12
@ XMC_DELAY_CYCLE_12
Definition: at32f435_437_xmc.h:344
XMC_DELAY_CYCLE_6
@ XMC_DELAY_CYCLE_6
Definition: at32f435_437_xmc.h:338
XMC_DELAY_CYCLE_3
@ XMC_DELAY_CYCLE_3
Definition: at32f435_437_xmc.h:335
XMC_DELAY_CYCLE_15
@ XMC_DELAY_CYCLE_15
Definition: at32f435_437_xmc.h:347
XMC_DELAY_CYCLE_8
@ XMC_DELAY_CYCLE_8
Definition: at32f435_437_xmc.h:340
XMC_DELAY_CYCLE_1
@ XMC_DELAY_CYCLE_1
Definition: at32f435_437_xmc.h:333
XMC_DELAY_CYCLE_14
@ XMC_DELAY_CYCLE_14
Definition: at32f435_437_xmc.h:346
XMC_DELAY_CYCLE_2
@ XMC_DELAY_CYCLE_2
Definition: at32f435_437_xmc.h:334
XMC_WAIT_SIGNAL_SYN_DURING
@ XMC_WAIT_SIGNAL_SYN_DURING
Definition: at32f435_437_xmc.h:197
XMC_WAIT_SIGNAL_SYN_BEFORE
@ XMC_WAIT_SIGNAL_SYN_BEFORE
Definition: at32f435_437_xmc.h:196
XMC_WRITE_OPERATION_DISABLE
@ XMC_WRITE_OPERATION_DISABLE
Definition: at32f435_437_xmc.h:92
XMC_WRITE_OPERATION_ENABLE
@ XMC_WRITE_OPERATION_ENABLE
Definition: at32f435_437_xmc.h:93
XMC_WRITE_BURST_SYN_ENABLE
@ XMC_WRITE_BURST_SYN_ENABLE
Definition: at32f435_437_xmc.h:111
XMC_WRITE_BURST_SYN_DISABLE
@ XMC_WRITE_BURST_SYN_DISABLE
Definition: at32f435_437_xmc.h:110
XMC_BURST_MODE_DISABLE
@ XMC_BURST_MODE_DISABLE
Definition: at32f435_437_xmc.h:65
XMC_BURST_MODE_ENABLE
@ XMC_BURST_MODE_ENABLE
Definition: at32f435_437_xmc.h:66
XMC_BANK4_PCCARD
@ XMC_BANK4_PCCARD
Definition: at32f435_437_xmc.h:159
XMC_BANK3_NAND
@ XMC_BANK3_NAND
Definition: at32f435_437_xmc.h:158
XMC_BANK5_6_SDRAM
@ XMC_BANK5_6_SDRAM
Definition: at32f435_437_xmc.h:160
XMC_BANK2_NAND
@ XMC_BANK2_NAND
Definition: at32f435_437_xmc.h:157
XMC_CLKDIV_2
@ XMC_CLKDIV_2
Definition: at32f435_437_xmc.h:303
XMC_CLKDIV_3
@ XMC_CLKDIV_3
Definition: at32f435_437_xmc.h:304
XMC_CLKDIV_4
@ XMC_CLKDIV_4
Definition: at32f435_437_xmc.h:305
XMC_NO_CLK
@ XMC_NO_CLK
Definition: at32f435_437_xmc.h:302
XMC_DATA_ADDR_MUX_DISABLE
@ XMC_DATA_ADDR_MUX_DISABLE
Definition: at32f435_437_xmc.h:56
XMC_DATA_ADDR_MUX_ENABLE
@ XMC_DATA_ADDR_MUX_ENABLE
Definition: at32f435_437_xmc.h:57
XMC_STATUS_SELF_REFRESH
@ XMC_STATUS_SELF_REFRESH
Definition: at32f435_437_xmc.h:383
XMC_STATUS_MASK
@ XMC_STATUS_MASK
Definition: at32f435_437_xmc.h:385
XMC_STATUS_POWER_DOWN
@ XMC_STATUS_POWER_DOWN
Definition: at32f435_437_xmc.h:384
XMC_STATUS_NORMAL
@ XMC_STATUS_NORMAL
Definition: at32f435_437_xmc.h:382
XMC_INT_ERR
@ XMC_INT_ERR
Definition: at32f435_437_xmc.h:232
XMC_INT_LEVEL
@ XMC_INT_LEVEL
Definition: at32f435_437_xmc.h:230
XMC_INT_RISING_EDGE
@ XMC_INT_RISING_EDGE
Definition: at32f435_437_xmc.h:229
XMC_INT_FALLING_EDGE
@ XMC_INT_FALLING_EDGE
Definition: at32f435_437_xmc.h:231
XMC_BUSTYPE_16_BITS
@ XMC_BUSTYPE_16_BITS
Definition: at32f435_437_xmc.h:179
XMC_BUSTYPE_8_BITS
@ XMC_BUSTYPE_8_BITS
Definition: at32f435_437_xmc.h:178
XMC_SDRAM_BANK1
@ XMC_SDRAM_BANK1
Definition: at32f435_437_xmc.h:323
XMC_SDRAM_BANK2
@ XMC_SDRAM_BANK2
Definition: at32f435_437_xmc.h:324
XMC_WRITE_TIMING_ENABLE
@ XMC_WRITE_TIMING_ENABLE
Definition: at32f435_437_xmc.h:120
XMC_WRITE_TIMING_DISABLE
@ XMC_WRITE_TIMING_DISABLE
Definition: at32f435_437_xmc.h:119
XMC_BANK1_NOR_SRAM1
@ XMC_BANK1_NOR_SRAM1
Definition: at32f435_437_xmc.h:146
XMC_BANK1_NOR_SRAM4
@ XMC_BANK1_NOR_SRAM4
Definition: at32f435_437_xmc.h:149
XMC_BANK1_NOR_SRAM3
@ XMC_BANK1_NOR_SRAM3
Definition: at32f435_437_xmc.h:148
XMC_BANK1_NOR_SRAM2
@ XMC_BANK1_NOR_SRAM2
Definition: at32f435_437_xmc.h:147
XMC_RISINGEDGE_FLAG
@ XMC_RISINGEDGE_FLAG
Definition: at32f435_437_xmc.h:240
XMC_BUSY_FLAG
@ XMC_BUSY_FLAG
Definition: at32f435_437_xmc.h:245
XMC_FALLINGEDGE_FLAG
@ XMC_FALLINGEDGE_FLAG
Definition: at32f435_437_xmc.h:242
XMC_LEVEL_FLAG
@ XMC_LEVEL_FLAG
Definition: at32f435_437_xmc.h:241
XMC_ERR_FLAG
@ XMC_ERR_FLAG
Definition: at32f435_437_xmc.h:244
XMC_FEMPT_FLAG
@ XMC_FEMPT_FLAG
Definition: at32f435_437_xmc.h:243
XMC_ROW_12
@ XMC_ROW_12
Definition: at32f435_437_xmc.h:265
XMC_ROW_13
@ XMC_ROW_13
Definition: at32f435_437_xmc.h:266
XMC_ROW_11
@ XMC_ROW_11
Definition: at32f435_437_xmc.h:264
XMC_READ_DELAY_2
@ XMC_READ_DELAY_2
Definition: at32f435_437_xmc.h:315
XMC_READ_DELAY_1
@ XMC_READ_DELAY_1
Definition: at32f435_437_xmc.h:314
XMC_READ_DELAY_0
@ XMC_READ_DELAY_0
Definition: at32f435_437_xmc.h:313
XMC_INBK_2
@ XMC_INBK_2
Definition: at32f435_437_xmc.h:283
XMC_INBK_4
@ XMC_INBK_4
Definition: at32f435_437_xmc.h:284
XMC_ASYN_WAIT_ENABLE
@ XMC_ASYN_WAIT_ENABLE
Definition: at32f435_437_xmc.h:75
XMC_ASYN_WAIT_DISABLE
@ XMC_ASYN_WAIT_DISABLE
Definition: at32f435_437_xmc.h:74
XMC_WAIT_OPERATION_DISABLE
@ XMC_WAIT_OPERATION_DISABLE
Definition: at32f435_437_xmc.h:128
XMC_WAIT_OPERATION_ENABLE
@ XMC_WAIT_OPERATION_ENABLE
Definition: at32f435_437_xmc.h:129
XMC_CAS_1
@ XMC_CAS_1
Definition: at32f435_437_xmc.h:292
XMC_CAS_2
@ XMC_CAS_2
Definition: at32f435_437_xmc.h:293
XMC_CAS_3
@ XMC_CAS_3
Definition: at32f435_437_xmc.h:294
XMC_WRAPPED_MODE_DISABLE
@ XMC_WRAPPED_MODE_DISABLE
Definition: at32f435_437_xmc.h:83
XMC_WRAPPED_MODE_ENABLE
@ XMC_WRAPPED_MODE_ENABLE
Definition: at32f435_437_xmc.h:84
XMC_ECC_PAGESIZE_1024_BYTES
@ XMC_ECC_PAGESIZE_1024_BYTES
Definition: at32f435_437_xmc.h:218
XMC_ECC_PAGESIZE_8192_BYTES
@ XMC_ECC_PAGESIZE_8192_BYTES
Definition: at32f435_437_xmc.h:221
XMC_ECC_PAGESIZE_4096_BYTES
@ XMC_ECC_PAGESIZE_4096_BYTES
Definition: at32f435_437_xmc.h:220
XMC_ECC_PAGESIZE_256_BYTES
@ XMC_ECC_PAGESIZE_256_BYTES
Definition: at32f435_437_xmc.h:216
XMC_ECC_PAGESIZE_2048_BYTES
@ XMC_ECC_PAGESIZE_2048_BYTES
Definition: at32f435_437_xmc.h:219
XMC_ECC_PAGESIZE_512_BYTES
@ XMC_ECC_PAGESIZE_512_BYTES
Definition: at32f435_437_xmc.h:217
XMC_ACCESS_MODE_C
@ XMC_ACCESS_MODE_C
Definition: at32f435_437_xmc.h:207
XMC_ACCESS_MODE_B
@ XMC_ACCESS_MODE_B
Definition: at32f435_437_xmc.h:206
XMC_ACCESS_MODE_A
@ XMC_ACCESS_MODE_A
Definition: at32f435_437_xmc.h:205
XMC_ACCESS_MODE_D
@ XMC_ACCESS_MODE_D
Definition: at32f435_437_xmc.h:208
XMC_CMD_BANK2
@ XMC_CMD_BANK2
Definition: at32f435_437_xmc.h:372
XMC_CMD_BANK1
@ XMC_CMD_BANK1
Definition: at32f435_437_xmc.h:371
XMC_CMD_BANK1_2
@ XMC_CMD_BANK1_2
Definition: at32f435_437_xmc.h:373
XMC_ECC_OPERATION_DISABLE
@ XMC_ECC_OPERATION_DISABLE
Definition: at32f435_437_xmc.h:137
XMC_ECC_OPERATION_ENABLE
@ XMC_ECC_OPERATION_ENABLE
Definition: at32f435_437_xmc.h:138
XMC_WAIT_SIGNAL_LEVEL_LOW
@ XMC_WAIT_SIGNAL_LEVEL_LOW
Definition: at32f435_437_xmc.h:187
XMC_WAIT_SIGNAL_LEVEL_HIGH
@ XMC_WAIT_SIGNAL_LEVEL_HIGH
Definition: at32f435_437_xmc.h:188
XMC_MEM_WIDTH_16
@ XMC_MEM_WIDTH_16
Definition: at32f435_437_xmc.h:275
XMC_MEM_WIDTH_8
@ XMC_MEM_WIDTH_8
Definition: at32f435_437_xmc.h:274
XMC_DEVICE_NOR
@ XMC_DEVICE_NOR
Definition: at32f435_437_xmc.h:170
XMC_DEVICE_PSRAM
@ XMC_DEVICE_PSRAM
Definition: at32f435_437_xmc.h:169
XMC_DEVICE_SRAM
@ XMC_DEVICE_SRAM
Definition: at32f435_437_xmc.h:168
XMC_COLUMN_10
@ XMC_COLUMN_10
Definition: at32f435_437_xmc.h:255
XMC_COLUMN_8
@ XMC_COLUMN_8
Definition: at32f435_437_xmc.h:253
XMC_COLUMN_11
@ XMC_COLUMN_11
Definition: at32f435_437_xmc.h:256
XMC_COLUMN_9
@ XMC_COLUMN_9
Definition: at32f435_437_xmc.h:254
xmc_bank1_ctrl_tmg_reg_type
Definition: at32f435_437_xmc.h:510
xmc_bank1_ctrl_tmg_reg_type::noren
__IO uint32_t noren
Definition: at32f435_437_xmc.h:523
xmc_bank1_ctrl_tmg_reg_type::en
__IO uint32_t en
Definition: at32f435_437_xmc.h:519
xmc_bank1_ctrl_tmg_reg_type::nwtcfg
__IO uint32_t nwtcfg
Definition: at32f435_437_xmc.h:528
xmc_bank1_ctrl_tmg_reg_type::extmdbw
__IO uint32_t extmdbw
Definition: at32f435_437_xmc.h:522
xmc_bank1_ctrl_tmg_reg_type::addrht
__IO uint32_t addrht
Definition: at32f435_437_xmc.h:548
xmc_bank1_ctrl_tmg_reg_type::clkpsc
__IO uint32_t clkpsc
Definition: at32f435_437_xmc.h:551
xmc_bank1_ctrl_tmg_reg_type::wrapen
__IO uint32_t wrapen
Definition: at32f435_437_xmc.h:527
xmc_bank1_ctrl_tmg_reg_type::buslat
__IO uint32_t buslat
Definition: at32f435_437_xmc.h:550
xmc_bank1_ctrl_tmg_reg_type::crpgs
__IO uint32_t crpgs
Definition: at32f435_437_xmc.h:533
xmc_bank1_ctrl_tmg_reg_type::wen
__IO uint32_t wen
Definition: at32f435_437_xmc.h:529
xmc_bank1_ctrl_tmg_reg_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_xmc.h:535
xmc_bank1_ctrl_tmg_reg_type::admuxen
__IO uint32_t admuxen
Definition: at32f435_437_xmc.h:520
xmc_bank1_ctrl_tmg_reg_type::syncben
__IO uint32_t syncben
Definition: at32f435_437_xmc.h:525
xmc_bank1_ctrl_tmg_reg_type::nwsen
__IO uint32_t nwsen
Definition: at32f435_437_xmc.h:530
xmc_bank1_ctrl_tmg_reg_type::nwpol
__IO uint32_t nwpol
Definition: at32f435_437_xmc.h:526
xmc_bank1_ctrl_tmg_reg_type::bk1ctrl
__IO uint32_t bk1ctrl
Definition: at32f435_437_xmc.h:516
xmc_bank1_ctrl_tmg_reg_type::addrst
__IO uint32_t addrst
Definition: at32f435_437_xmc.h:547
xmc_bank1_ctrl_tmg_reg_type::rwtd
__IO uint32_t rwtd
Definition: at32f435_437_xmc.h:531
xmc_bank1_ctrl_tmg_reg_type::nwasen
__IO uint32_t nwasen
Definition: at32f435_437_xmc.h:532
xmc_bank1_ctrl_tmg_reg_type::dev
__IO uint32_t dev
Definition: at32f435_437_xmc.h:521
xmc_bank1_ctrl_tmg_reg_type::bk1tmg
__IO uint32_t bk1tmg
Definition: at32f435_437_xmc.h:544
xmc_bank1_ctrl_tmg_reg_type::asyncm
__IO uint32_t asyncm
Definition: at32f435_437_xmc.h:553
xmc_bank1_ctrl_tmg_reg_type::dtst
__IO uint32_t dtst
Definition: at32f435_437_xmc.h:549
xmc_bank1_ctrl_tmg_reg_type::dtlat
__IO uint32_t dtlat
Definition: at32f435_437_xmc.h:552
xmc_bank1_ctrl_tmg_reg_type::mwmc
__IO uint32_t mwmc
Definition: at32f435_437_xmc.h:534
xmc_bank1_ctrl_tmg_reg_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_xmc.h:524
xmc_bank1_tmgwr_reg_type
Definition: at32f435_437_xmc.h:561
xmc_bank1_tmgwr_reg_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_xmc.h:576
xmc_bank1_tmgwr_reg_type::buslat
__IO uint32_t buslat
Definition: at32f435_437_xmc.h:573
xmc_bank1_tmgwr_reg_type::asyncm
__IO uint32_t asyncm
Definition: at32f435_437_xmc.h:575
xmc_bank1_tmgwr_reg_type::bk1tmgwr
__IO uint32_t bk1tmgwr
Definition: at32f435_437_xmc.h:567
xmc_bank1_tmgwr_reg_type::addrst
__IO uint32_t addrst
Definition: at32f435_437_xmc.h:570
xmc_bank1_tmgwr_reg_type::dtst
__IO uint32_t dtst
Definition: at32f435_437_xmc.h:572
xmc_bank1_tmgwr_reg_type::reserved1
__IO uint32_t reserved1
xmc bank1 reserved register
Definition: at32f435_437_xmc.h:574
xmc_bank1_tmgwr_reg_type::addrht
__IO uint32_t addrht
Definition: at32f435_437_xmc.h:571
xmc_bank1_type
xmc bank1 registers
Definition: at32f435_437_xmc.h:591
xmc_bank1_type::buslatw2w
__IO uint32_t buslatw2w
Definition: at32f435_437_xmc.h:620
xmc_bank1_type::buslatr2r
__IO uint32_t buslatr2r
Definition: at32f435_437_xmc.h:621
xmc_bank2_type
xmc bank2 registers
Definition: at32f435_437_xmc.h:632
xmc_bank2_type::eccen
__IO uint32_t eccen
Definition: at32f435_437_xmc.h:646
xmc_bank2_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_xmc.h:651
xmc_bank2_type::cmst
__IO uint32_t cmst
Definition: at32f435_437_xmc.h:682
xmc_bank2_type::ecc
__IO uint32_t ecc
Definition: at32f435_437_xmc.h:717
xmc_bank2_type::bk2ctrl
__IO uint32_t bk2ctrl
Definition: at32f435_437_xmc.h:638
xmc_bank2_type::bk2tmgmem
__IO uint32_t bk2tmgmem
Definition: at32f435_437_xmc.h:679
xmc_bank2_type::eccpgs
__IO uint32_t eccpgs
Definition: at32f435_437_xmc.h:650
xmc_bank2_type::fes
__IO uint32_t fes
Definition: at32f435_437_xmc.h:665
xmc_bank2_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_xmc.h:647
xmc_bank2_type::bk2tmgatt
__IO uint32_t bk2tmgatt
Definition: at32f435_437_xmc.h:694
xmc_bank2_type::amst
__IO uint32_t amst
Definition: at32f435_437_xmc.h:697
xmc_bank2_type::res
__IO uint32_t res
Definition: at32f435_437_xmc.h:663
xmc_bank2_type::tar
__IO uint32_t tar
Definition: at32f435_437_xmc.h:649
xmc_bank2_type::reien
__IO uint32_t reien
Definition: at32f435_437_xmc.h:666
xmc_bank2_type::cmwt
__IO uint32_t cmwt
Definition: at32f435_437_xmc.h:683
xmc_bank2_type::hlien
__IO uint32_t hlien
Definition: at32f435_437_xmc.h:667
xmc_bank2_type::cmdhizt
__IO uint32_t cmdhizt
Definition: at32f435_437_xmc.h:685
xmc_bank2_type::nwen
__IO uint32_t nwen
Definition: at32f435_437_xmc.h:642
xmc_bank2_type::amwt
__IO uint32_t amwt
Definition: at32f435_437_xmc.h:698
xmc_bank2_type::bk2is
__IO uint32_t bk2is
Definition: at32f435_437_xmc.h:660
xmc_bank2_type::amht
__IO uint32_t amht
Definition: at32f435_437_xmc.h:699
xmc_bank2_type::bk2ecc
__IO uint32_t bk2ecc
Definition: at32f435_437_xmc.h:714
xmc_bank2_type::feien
__IO uint32_t feien
Definition: at32f435_437_xmc.h:668
xmc_bank2_type::amdhizt
__IO uint32_t amdhizt
Definition: at32f435_437_xmc.h:700
xmc_bank2_type::fifoe
__IO uint32_t fifoe
Definition: at32f435_437_xmc.h:669
xmc_bank2_type::en
__IO uint32_t en
Definition: at32f435_437_xmc.h:643
xmc_bank2_type::hls
__IO uint32_t hls
Definition: at32f435_437_xmc.h:664
xmc_bank2_type::cmht
__IO uint32_t cmht
Definition: at32f435_437_xmc.h:684
xmc_bank2_type::reserved1
__IO uint32_t reserved1
xmc reserved register, offset:0x70
Definition: at32f435_437_xmc.h:641
xmc_bank2_type::extmdbw
__IO uint32_t extmdbw
Definition: at32f435_437_xmc.h:645
xmc_bank2_type::dev
__IO uint32_t dev
Definition: at32f435_437_xmc.h:644
xmc_bank2_type::tcr
__IO uint32_t tcr
Definition: at32f435_437_xmc.h:648
xmc_bank3_type
xmc bank3 registers
Definition: at32f435_437_xmc.h:727
xmc_bank3_type::tcr
__IO uint32_t tcr
Definition: at32f435_437_xmc.h:743
xmc_bank3_type::feien
__IO uint32_t feien
Definition: at32f435_437_xmc.h:763
xmc_bank3_type::bk3ecc
__IO uint32_t bk3ecc
Definition: at32f435_437_xmc.h:809
xmc_bank3_type::cmwt
__IO uint32_t cmwt
Definition: at32f435_437_xmc.h:778
xmc_bank3_type::fes
__IO uint32_t fes
Definition: at32f435_437_xmc.h:760
xmc_bank3_type::bk3tmgatt
__IO uint32_t bk3tmgatt
Definition: at32f435_437_xmc.h:789
xmc_bank3_type::bk3ctrl
__IO uint32_t bk3ctrl
Definition: at32f435_437_xmc.h:733
xmc_bank3_type::eccen
__IO uint32_t eccen
Definition: at32f435_437_xmc.h:741
xmc_bank3_type::hls
__IO uint32_t hls
Definition: at32f435_437_xmc.h:759
xmc_bank3_type::nwen
__IO uint32_t nwen
Definition: at32f435_437_xmc.h:737
xmc_bank3_type::ecc
__IO uint32_t ecc
Definition: at32f435_437_xmc.h:812
xmc_bank3_type::tar
__IO uint32_t tar
Definition: at32f435_437_xmc.h:744
xmc_bank3_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_xmc.h:742
xmc_bank3_type::bk3tmgmem
__IO uint32_t bk3tmgmem
Definition: at32f435_437_xmc.h:774
xmc_bank3_type::amwt
__IO uint32_t amwt
Definition: at32f435_437_xmc.h:793
xmc_bank3_type::hlien
__IO uint32_t hlien
Definition: at32f435_437_xmc.h:762
xmc_bank3_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_xmc.h:746
xmc_bank3_type::reserved1
__IO uint32_t reserved1
xmc reserved register, offset:0x90
Definition: at32f435_437_xmc.h:736
xmc_bank3_type::en
__IO uint32_t en
Definition: at32f435_437_xmc.h:738
xmc_bank3_type::res
__IO uint32_t res
Definition: at32f435_437_xmc.h:758
xmc_bank3_type::cmdhizt
__IO uint32_t cmdhizt
Definition: at32f435_437_xmc.h:780
xmc_bank3_type::fifoe
__IO uint32_t fifoe
Definition: at32f435_437_xmc.h:764
xmc_bank3_type::reien
__IO uint32_t reien
Definition: at32f435_437_xmc.h:761
xmc_bank3_type::dev
__IO uint32_t dev
Definition: at32f435_437_xmc.h:739
xmc_bank3_type::cmst
__IO uint32_t cmst
Definition: at32f435_437_xmc.h:777
xmc_bank3_type::amst
__IO uint32_t amst
Definition: at32f435_437_xmc.h:792
xmc_bank3_type::amht
__IO uint32_t amht
Definition: at32f435_437_xmc.h:794
xmc_bank3_type::cmht
__IO uint32_t cmht
Definition: at32f435_437_xmc.h:779
xmc_bank3_type::amdhizt
__IO uint32_t amdhizt
Definition: at32f435_437_xmc.h:795
xmc_bank3_type::eccpgs
__IO uint32_t eccpgs
Definition: at32f435_437_xmc.h:745
xmc_bank3_type::extmdbw
__IO uint32_t extmdbw
Definition: at32f435_437_xmc.h:740
xmc_bank3_type::bk3is
__IO uint32_t bk3is
Definition: at32f435_437_xmc.h:755
xmc_bank4_type
xmc bank4 registers
Definition: at32f435_437_xmc.h:821
xmc_bank4_type::tcr
__IO uint32_t tcr
Definition: at32f435_437_xmc.h:838
xmc_bank4_type::dev
__IO uint32_t dev
Definition: at32f435_437_xmc.h:834
xmc_bank4_type::nwen
__IO uint32_t nwen
Definition: at32f435_437_xmc.h:832
xmc_bank4_type::reien
__IO uint32_t reien
Definition: at32f435_437_xmc.h:856
xmc_bank4_type::hls
__IO uint32_t hls
Definition: at32f435_437_xmc.h:854
xmc_bank4_type::feien
__IO uint32_t feien
Definition: at32f435_437_xmc.h:858
xmc_bank4_type::amht
__IO uint32_t amht
Definition: at32f435_437_xmc.h:889
xmc_bank4_type::cmht
__IO uint32_t cmht
Definition: at32f435_437_xmc.h:874
xmc_bank4_type::bk4tmgatt
__IO uint32_t bk4tmgatt
Definition: at32f435_437_xmc.h:884
xmc_bank4_type::cmst
__IO uint32_t cmst
Definition: at32f435_437_xmc.h:872
xmc_bank4_type::en
__IO uint32_t en
Definition: at32f435_437_xmc.h:833
xmc_bank4_type::ioht
__IO uint32_t ioht
Definition: at32f435_437_xmc.h:904
xmc_bank4_type::bk4tmgio
__IO uint32_t bk4tmgio
Definition: at32f435_437_xmc.h:899
xmc_bank4_type::iowt
__IO uint32_t iowt
Definition: at32f435_437_xmc.h:903
xmc_bank4_type::cmdhizt
__IO uint32_t cmdhizt
Definition: at32f435_437_xmc.h:875
xmc_bank4_type::reserved3
__IO uint32_t reserved3
Definition: at32f435_437_xmc.h:841
xmc_bank4_type::iost
__IO uint32_t iost
Definition: at32f435_437_xmc.h:902
xmc_bank4_type::bk4ctrl
__IO uint32_t bk4ctrl
Definition: at32f435_437_xmc.h:828
xmc_bank4_type::res
__IO uint32_t res
Definition: at32f435_437_xmc.h:853
xmc_bank4_type::fifoe
__IO uint32_t fifoe
Definition: at32f435_437_xmc.h:859
xmc_bank4_type::eccen
__IO uint32_t eccen
Definition: at32f435_437_xmc.h:836
xmc_bank4_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_xmc.h:831
xmc_bank4_type::amwt
__IO uint32_t amwt
Definition: at32f435_437_xmc.h:888
xmc_bank4_type::reserved2
__IO uint32_t reserved2
Definition: at32f435_437_xmc.h:837
xmc_bank4_type::tar
__IO uint32_t tar
Definition: at32f435_437_xmc.h:839
xmc_bank4_type::cmwt
__IO uint32_t cmwt
Definition: at32f435_437_xmc.h:873
xmc_bank4_type::hlien
__IO uint32_t hlien
Definition: at32f435_437_xmc.h:857
xmc_bank4_type::amdhizt
__IO uint32_t amdhizt
Definition: at32f435_437_xmc.h:890
xmc_bank4_type::amst
__IO uint32_t amst
Definition: at32f435_437_xmc.h:887
xmc_bank4_type::fes
__IO uint32_t fes
Definition: at32f435_437_xmc.h:855
xmc_bank4_type::bk4is
__IO uint32_t bk4is
Definition: at32f435_437_xmc.h:850
xmc_bank4_type::iohizt
__IO uint32_t iohizt
Definition: at32f435_437_xmc.h:905
xmc_bank4_type::extmdbw
__IO uint32_t extmdbw
Definition: at32f435_437_xmc.h:835
xmc_bank4_type::eccpgs
__IO uint32_t eccpgs
Definition: at32f435_437_xmc.h:840
xmc_bank4_type::bk4tmgmem
__IO uint32_t bk4tmgmem
Definition: at32f435_437_xmc.h:869
xmc_nand_init_type
xmc nand init structure definition
Definition: at32f435_437_xmc.h:443
xmc_nand_init_type::ecc_enable
xmc_ecc_enable_type ecc_enable
Definition: at32f435_437_xmc.h:447
xmc_nand_init_type::delay_time_cycle
uint32_t delay_time_cycle
Definition: at32f435_437_xmc.h:449
xmc_nand_init_type::nand_bank
xmc_class_bank_type nand_bank
Definition: at32f435_437_xmc.h:444
xmc_nand_init_type::wait_enable
xmc_nand_pccard_wait_type wait_enable
Definition: at32f435_437_xmc.h:445
xmc_nand_init_type::ecc_pagesize
xmc_ecc_pagesize_type ecc_pagesize
Definition: at32f435_437_xmc.h:448
xmc_nand_init_type::delay_time_ar
uint32_t delay_time_ar
Definition: at32f435_437_xmc.h:450
xmc_nand_init_type::bus_type
xmc_data_width_type bus_type
Definition: at32f435_437_xmc.h:446
xmc_nand_pccard_timinginit_type
nand and pccard timing parameters xmc
Definition: at32f435_437_xmc.h:430
xmc_nand_pccard_timinginit_type::class_bank
xmc_class_bank_type class_bank
Definition: at32f435_437_xmc.h:431
xmc_nand_pccard_timinginit_type::mem_waite_time
uint32_t mem_waite_time
Definition: at32f435_437_xmc.h:433
xmc_nand_pccard_timinginit_type::mem_hold_time
uint32_t mem_hold_time
Definition: at32f435_437_xmc.h:434
xmc_nand_pccard_timinginit_type::mem_hiz_time
uint32_t mem_hiz_time
Definition: at32f435_437_xmc.h:435
xmc_nand_pccard_timinginit_type::mem_setup_time
uint32_t mem_setup_time
Definition: at32f435_437_xmc.h:432
xmc_norsram_init_type
xmc nor/sram init structure definition
Definition: at32f435_437_xmc.h:409
xmc_norsram_init_type::wait_signal_enable
xmc_wait_signal_type wait_signal_enable
Definition: at32f435_437_xmc.h:420
xmc_norsram_init_type::data_addr_multiplex
xmc_data_addr_mux_type data_addr_multiplex
Definition: at32f435_437_xmc.h:411
xmc_norsram_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:421
xmc_norsram_init_type::burst_mode_enable
xmc_burst_access_mode_type burst_mode_enable
Definition: at32f435_437_xmc.h:414
xmc_norsram_init_type::bus_type
xmc_data_width_type bus_type
Definition: at32f435_437_xmc.h:413
xmc_norsram_init_type::device
xmc_memory_type device
Definition: at32f435_437_xmc.h:412
xmc_norsram_init_type::wait_signal_lv
xmc_wait_signal_polarity_type wait_signal_lv
Definition: at32f435_437_xmc.h:416
xmc_norsram_init_type::wrapped_mode_enable
xmc_wrap_mode_type wrapped_mode_enable
Definition: at32f435_437_xmc.h:417
xmc_norsram_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:410
xmc_norsram_init_type::write_burst_syn
xmc_write_burst_type write_burst_syn
Definition: at32f435_437_xmc.h:422
xmc_norsram_init_type::asynwait_enable
xmc_asyn_wait_type asynwait_enable
Definition: at32f435_437_xmc.h:415
xmc_norsram_init_type::wait_signal_config
xmc_wait_timing_type wait_signal_config
Definition: at32f435_437_xmc.h:418
xmc_norsram_init_type::write_enable
xmc_write_operation_type write_enable
Definition: at32f435_437_xmc.h:419
xmc_norsram_timing_init_type
nor/sram banks timing parameters
Definition: at32f435_437_xmc.h:393
xmc_norsram_timing_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:395
xmc_norsram_timing_init_type::data_latency_time
uint32_t data_latency_time
Definition: at32f435_437_xmc.h:401
xmc_norsram_timing_init_type::addr_hold_time
uint32_t addr_hold_time
Definition: at32f435_437_xmc.h:397
xmc_norsram_timing_init_type::bus_latency_time
uint32_t bus_latency_time
Definition: at32f435_437_xmc.h:399
xmc_norsram_timing_init_type::addr_setup_time
uint32_t addr_setup_time
Definition: at32f435_437_xmc.h:396
xmc_norsram_timing_init_type::mode
xmc_access_mode_type mode
Definition: at32f435_437_xmc.h:402
xmc_norsram_timing_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:394
xmc_norsram_timing_init_type::clk_psc
uint32_t clk_psc
Definition: at32f435_437_xmc.h:400
xmc_norsram_timing_init_type::data_setup_time
uint32_t data_setup_time
Definition: at32f435_437_xmc.h:398
xmc_pccard_init_type
xmc pccard init structure definition
Definition: at32f435_437_xmc.h:458
xmc_pccard_init_type::delay_time_ar
uint32_t delay_time_ar
Definition: at32f435_437_xmc.h:461
xmc_pccard_init_type::enable_wait
xmc_nand_pccard_wait_type enable_wait
Definition: at32f435_437_xmc.h:459
xmc_pccard_init_type::delay_time_cr
uint32_t delay_time_cr
Definition: at32f435_437_xmc.h:460
xmc_sdram_cmd_type
xmc sdram command structure definition
Definition: at32f435_437_xmc.h:502
xmc_sdram_cmd_type::cmd_banks
xmc_cmd_bank1_2_type cmd_banks
Definition: at32f435_437_xmc.h:504
xmc_sdram_cmd_type::auto_refresh
uint32_t auto_refresh
Definition: at32f435_437_xmc.h:505
xmc_sdram_cmd_type::data
uint32_t data
Definition: at32f435_437_xmc.h:506
xmc_sdram_cmd_type::cmd
xmc_command_type cmd
Definition: at32f435_437_xmc.h:503
xmc_sdram_init_type
xmc sdram init structure definition
Definition: at32f435_437_xmc.h:469
xmc_sdram_init_type::row_address
xmc_sdram_row_type row_address
Definition: at32f435_437_xmc.h:477
xmc_sdram_init_type::burst_read
uint8_t burst_read
Definition: at32f435_437_xmc.h:474
xmc_sdram_init_type::clkdiv
xmc_sdram_clkdiv_type clkdiv
Definition: at32f435_437_xmc.h:472
xmc_sdram_init_type::write_protection
uint8_t write_protection
Definition: at32f435_437_xmc.h:473
xmc_sdram_init_type::column_address
xmc_sdram_column_type column_address
Definition: at32f435_437_xmc.h:476
xmc_sdram_init_type::read_delay
uint8_t read_delay
Definition: at32f435_437_xmc.h:475
xmc_sdram_init_type::width
xmc_sdram_width_type width
Definition: at32f435_437_xmc.h:479
xmc_sdram_init_type::cas
xmc_sdram_cas_type cas
Definition: at32f435_437_xmc.h:478
xmc_sdram_init_type::sdram_bank
xmc_sdram_bank_type sdram_bank
Definition: at32f435_437_xmc.h:470
xmc_sdram_init_type::internel_banks
xmc_sdram_inbk_type internel_banks
Definition: at32f435_437_xmc.h:471
xmc_sdram_timing_type
xmc sdram timing structure definition
Definition: at32f435_437_xmc.h:487
xmc_sdram_timing_type::trcd
xmc_sdram_delay_type trcd
Definition: at32f435_437_xmc.h:494
xmc_sdram_timing_type::trc
xmc_sdram_delay_type trc
Definition: at32f435_437_xmc.h:491
xmc_sdram_timing_type::tmrd
xmc_sdram_delay_type tmrd
Definition: at32f435_437_xmc.h:488
xmc_sdram_timing_type::twr
xmc_sdram_delay_type twr
Definition: at32f435_437_xmc.h:492
xmc_sdram_timing_type::tras
xmc_sdram_delay_type tras
Definition: at32f435_437_xmc.h:490
xmc_sdram_timing_type::txsr
xmc_sdram_delay_type txsr
Definition: at32f435_437_xmc.h:489
xmc_sdram_timing_type::trp
xmc_sdram_delay_type trp
Definition: at32f435_437_xmc.h:493
xmc_sdram_type
xmc sdram type
Definition: at32f435_437_xmc.h:914
xmc_sdram_type::rc
__IO uint32_t rc
Definition: at32f435_437_xmc.h:982
xmc_sdram_type::db
__IO uint32_t db
Definition: at32f435_437_xmc.h:925
xmc_sdram_type::trc
__IO uint32_t trc
Definition: at32f435_437_xmc.h:947
xmc_sdram_type::rd
__IO uint32_t rd
Definition: at32f435_437_xmc.h:931
xmc_sdram_type::art
__IO uint32_t art
Definition: at32f435_437_xmc.h:967
xmc_sdram_type::sts
__IO uint32_t sts
Definition: at32f435_437_xmc.h:993
xmc_sdram_type::bk1
__IO uint32_t bk1
Definition: at32f435_437_xmc.h:966
xmc_sdram_type::txsr
__IO uint32_t txsr
Definition: at32f435_437_xmc.h:945
xmc_sdram_type::bk2sts
__IO uint32_t bk2sts
Definition: at32f435_437_xmc.h:998
xmc_sdram_type::cas
__IO uint32_t cas
Definition: at32f435_437_xmc.h:927
xmc_sdram_type::busy
__IO uint32_t busy
Definition: at32f435_437_xmc.h:999
xmc_sdram_type::tmrd
__IO uint32_t tmrd
Definition: at32f435_437_xmc.h:944
xmc_sdram_type::mrd
__IO uint32_t mrd
Definition: at32f435_437_xmc.h:968
xmc_sdram_type::clkdiv
__IO uint32_t clkdiv
Definition: at32f435_437_xmc.h:929
xmc_sdram_type::tras
__IO uint32_t tras
Definition: at32f435_437_xmc.h:946
xmc_sdram_type::ca
__IO uint32_t ca
Definition: at32f435_437_xmc.h:923
xmc_sdram_type::ra
__IO uint32_t ra
Definition: at32f435_437_xmc.h:924
xmc_sdram_type::bk2
__IO uint32_t bk2
Definition: at32f435_437_xmc.h:965
xmc_sdram_type::bstr
__IO uint32_t bstr
Definition: at32f435_437_xmc.h:930
xmc_sdram_type::erien
__IO uint32_t erien
Definition: at32f435_437_xmc.h:983
xmc_sdram_type::inbk
__IO uint32_t inbk
Definition: at32f435_437_xmc.h:926
xmc_sdram_type::rcnt
__IO uint32_t rcnt
Definition: at32f435_437_xmc.h:978
xmc_sdram_type::trp
__IO uint32_t trp
Definition: at32f435_437_xmc.h:949
xmc_sdram_type::trcd
__IO uint32_t trcd
Definition: at32f435_437_xmc.h:950
xmc_sdram_type::reserved1
__IO uint32_t reserved1
Definition: at32f435_437_xmc.h:932
xmc_sdram_type::wrp
__IO uint32_t wrp
Definition: at32f435_437_xmc.h:928
xmc_sdram_type::bk1sts
__IO uint32_t bk1sts
Definition: at32f435_437_xmc.h:997
xmc_sdram_type::cmd
__IO uint32_t cmd
Definition: at32f435_437_xmc.h:961
xmc_sdram_type::errc
__IO uint32_t errc
Definition: at32f435_437_xmc.h:981
xmc_sdram_type::twr
__IO uint32_t twr
Definition: at32f435_437_xmc.h:948
xmc_sdram_type::err
__IO uint32_t err
Definition: at32f435_437_xmc.h:996


AT32F435/437 Firmwary Library: iap.h File Reference

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Macros | Functions
at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/iap.h File Reference

iap header file More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | APP_START_ADDR 0x08010000
#define | IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x1000)
#define | IAP_UPGRADE_FLAG 0x41544B38

Functions

void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...

Detailed Description

iap header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/iap.h.


AT32F435/437 Firmwary Library: iap.h Source File

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • app_led3_toggle
  • inc
at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/iap.h
Go to the documentation of this file.
1
27#ifndef __IAP_H__
28#define __IAP_H__
29
30#ifdef __cplusplus
31 extern "C" {
32#endif
33
34#include "at32f435_437_board.h"
35
48/* app starting address */
49#define APP_START_ADDR 0x08010000
50
51/* the previous sector of app starting address is iap upgrade flag */
52#define IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x1000)
53
54/* when app received cmd 0x5aa5 from pc-tool, will set up the flag,
55indicates that an app upgrade will follow, see iap application note for more details */
56#define IAP_UPGRADE_FLAG 0x41544B38
57
66void iap_command_handle(void);
67void iap_init(void);
68
81#ifdef __cplusplus
82}
83#endif
84
85#endif
at32f435_437_board.h
iap_init
void iap_init(void)
iap init.
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c:61
iap_command_handle
void iap_command_handle(void)
iap command handle handle.
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c:44


AT32F435/437 Firmwary Library: tmr.h File Reference

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Functions
at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/tmr.h File Reference

tmr header file More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void tmr_init (void)
init tmr. More...

Detailed Description

tmr header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/tmr.h.


AT32F435/437 Firmwary Library: tmr.h Source File

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • app_led3_toggle
  • inc
at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/tmr.h
Go to the documentation of this file.
1
27#ifndef __TMR_H
28#define __TMR_H
29
30#ifdef __cplusplus
31 extern "C" {
32#endif
33
34#include "at32f435_437_board.h"
35
48void tmr_init(void);
49
62#ifdef __cplusplus
63}
64#endif
65
66#endif
at32f435_437_board.h
tmr_init
void tmr_init(void)
init tmr.
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/tmr.c:44


AT32F435/437 Firmwary Library: iap.c File Reference

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions
at32f437_emac_iap_demo/source_code/app_led3_toggle/src/iap.c File Reference

iap program More...

#include "iap.h"
#include "tmr.h"

Go to the source code of this file.

Functions

void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...

Detailed Description

iap program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f437_emac_iap_demo/source_code/app_led3_toggle/src/iap.c.


AT32F435/437 Firmwary Library: iap.c Source File

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • app_led3_toggle
  • src
at32f437_emac_iap_demo/source_code/app_led3_toggle/src/iap.c
Go to the documentation of this file.
1
27#include "iap.h"
28#include "tmr.h"
29
43void iap_command_handle(void)
44{
45 flash_unlock();
46 flash_sector_erase(IAP_UPGRADE_FLAG_ADDR);
47 flash_word_program(IAP_UPGRADE_FLAG_ADDR, IAP_UPGRADE_FLAG);
48 flash_lock();
49 nvic_system_reset();
50}
51
57void iap_init(void)
58{
59 if((*(uint32_t*)IAP_UPGRADE_FLAG_ADDR) == IAP_UPGRADE_FLAG)
60 {
61 flash_unlock();
62 flash_sector_erase(IAP_UPGRADE_FLAG_ADDR);
63 flash_lock();
64 }
65}
66
iap_init
void iap_init(void)
iap init.
Definition: at32f437_emac_iap_demo/source_code/app_led3_toggle/src/iap.c:57
iap_command_handle
void iap_command_handle(void)
iap command handle handle.
Definition: at32f437_emac_iap_demo/source_code/app_led3_toggle/src/iap.c:43
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f435_437_flash.c:357
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f435_437_flash.c:290
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f435_437_flash.c:608
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f435_437_flash.c:325
IAP_UPGRADE_FLAG_ADDR
#define IAP_UPGRADE_FLAG_ADDR
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h:52
IAP_UPGRADE_FLAG
#define IAP_UPGRADE_FLAG
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h:64
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f435_437_misc.c:52


AT32F435/437 Firmwary Library: tmr.c File Reference

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions
at32f437_emac_iap_demo/source_code/app_led3_toggle/src/tmr.c File Reference

tmr program More...

#include "at32f435_437_board.h"
#include "tmr.h"
#include "iap.h"

Go to the source code of this file.

Functions

void | tmr_init (void)
init tmr. More...
void | TMR3_GLOBAL_IRQHandler (void)
tmr3 global interrupt handler. More...

Detailed Description

tmr program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f437_emac_iap_demo/source_code/app_led3_toggle/src/tmr.c.


AT32F435/437 Firmwary Library: tmr.c Source File

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • app_led3_toggle
  • src
at32f437_emac_iap_demo/source_code/app_led3_toggle/src/tmr.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "tmr.h"
29#include "iap.h"
30
44void tmr_init(void)
45{
46 crm_clocks_freq_type crm_clocks_freq_struct = {0};
47
48 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
49
50 /* enable the tmr3 global interrupt */
51 nvic_irq_enable(TMR3_GLOBAL_IRQn, 0, 0);
52
53 /* get system clock */
54 crm_clocks_freq_get(&crm_clocks_freq_struct);
55
56 /* time base configuration */
57 tmr_base_init(TMR3, 10000, crm_clocks_freq_struct.ahb_freq / 10000);
58 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
59
60 /* overflow interrupt enable */
61 tmr_interrupt_enable(TMR3, TMR_OVF_INT, TRUE);
62
63 /* enable tmr */
64 tmr_counter_enable(TMR3, TRUE);
65
66}
67
73void TMR3_GLOBAL_IRQHandler(void)
74{
75 if(tmr_flag_get(TMR3, TMR_OVF_FLAG) == SET)
76 {
77 tmr_flag_clear(TMR3, TMR_OVF_FLAG);
78 at32_led_toggle(LED3);
79 }
80}
81
at32f435_437_board.h
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:40
LED3
@ LED3
Definition: at32f435_437_board.h:66
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:129
TMR3_GLOBAL_IRQHandler
void TMR3_GLOBAL_IRQHandler(void)
tmr3 global interrupt handler.
Definition: at32f437_emac_iap_demo/source_code/app_led3_toggle/src/tmr.c:73
tmr_init
void tmr_init(void)
init tmr.
Definition: at32f437_emac_iap_demo/source_code/app_led3_toggle/src/tmr.c:44
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f435_437_tmr.c:1463
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f435_437_tmr.c:1424
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f435_437_tmr.c:1389
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_OVF_FLAG
#define TMR_OVF_FLAG
Definition: at32f435_437_tmr.h:52
TMR_OVF_INT
#define TMR_OVF_INT
Definition: at32f435_437_tmr.h:75
TMR3
#define TMR3
Definition: at32f435_437_tmr.h:897
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f435_437.h:177
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::ahb_freq
uint32_t ahb_freq
Definition: at32f435_437_crm.h:790


AT32F435/437 Firmwary Library: iap.h File Reference

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • bootloader
  • inc
Macros | Typedefs | Functions
at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h File Reference

iap header file More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | USE_IAP_TFTP
#define | USE_IAP_HTTP
#define | APP_START_SECTOR_ADDR 0x08010000
#define | APP_LAST_SECTOR_ADDR 0x080FF800
#define | APP_END_ADDR 0x080FFFFF
#define | IAP_UPGRADE_FLAG_ADDR (APP_START_SECTOR_ADDR - 0x1000)
#define | IAP_UPGRADE_FLAG 0x41544B38

Typedefs

typedef void(* iapfun) (void)

Functions

void | app_load (uint32_t appxaddr)
app load. More...
void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...

Detailed Description

iap header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h.


AT32F435/437 Firmwary Library: iap.h Source File

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • bootloader
  • inc
at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h
Go to the documentation of this file.
1
27#ifndef __IAP_H__
28#define __IAP_H__
29
30#ifdef __cplusplus
31 extern "C" {
32#endif
33
34#include "at32f435_437_board.h"
35
48#define USE_IAP_TFTP
49#define USE_IAP_HTTP
51/* app starting address */
52#define APP_START_SECTOR_ADDR 0x08010000
53#define APP_LAST_SECTOR_ADDR 0x080FF800
54#define APP_END_ADDR 0x080FFFFF
55
56/* the previous sector of app starting address is iap upgrade flag */
57#define IAP_UPGRADE_FLAG_ADDR (APP_START_SECTOR_ADDR - 0x1000)
58
59/* when app need upgrade, will set up the flag,
60indicates that an app upgrade will follow, see iap application note for more details */
61#define IAP_UPGRADE_FLAG 0x41544B38
62
71typedef void (*iapfun)(void);
72
73void app_load(uint32_t appxaddr);
74void iap_command_handle(void);
75void iap_init(void);
76
89#ifdef __cplusplus
90}
91#endif
92
93#endif
at32f435_437_board.h
iap_init
void iap_init(void)
iap init.
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c:61
iapfun
void(* iapfun)(void)
Definition: at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h:71
iap_command_handle
void iap_command_handle(void)
iap command handle handle.
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c:44
app_load
void app_load(uint32_t appxaddr)
app load.
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c:60


AT32F435/437 Firmwary Library: tmr.h File Reference

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • bootloader
  • inc
Functions
at32f437_emac_iap_demo/source_code/bootloader/inc/tmr.h File Reference

tmr header file More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void tmr_init (void)
init tmr. More...

Detailed Description

tmr header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f437_emac_iap_demo/source_code/bootloader/inc/tmr.h.


AT32F435/437 Firmwary Library: tmr.h Source File

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • bootloader
  • inc
at32f437_emac_iap_demo/source_code/bootloader/inc/tmr.h
Go to the documentation of this file.
1
27#ifndef __TMR_H
28#define __TMR_H
29
30#ifdef __cplusplus
31 extern "C" {
32#endif
33
34#include "at32f435_437_board.h"
35
48void tmr_init(void);
49
62#ifdef __cplusplus
63}
64#endif
65
66#endif
at32f435_437_board.h
tmr_init
void tmr_init(void)
init tmr.
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/tmr.c:44


AT32F435/437 Firmwary Library: iap.c File Reference

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • bootloader
  • src
Functions | Variables
at32f437_emac_iap_demo/source_code/bootloader/src/iap.c File Reference

iap program More...

#include "stdlib.h"
#include "string.h"
#include "iap.h"
#include "flash.h"
#include "tmr.h"

Go to the source code of this file.

Functions

void | app_load (uint32_t app_addr)
app load. More...
void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...

Variables

iapfun jump_to_app

Detailed Description

iap program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f437_emac_iap_demo/source_code/bootloader/src/iap.c.


AT32F435/437 Firmwary Library: iap.c Source File

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • bootloader
  • src
at32f437_emac_iap_demo/source_code/bootloader/src/iap.c
Go to the documentation of this file.
1
27#include "stdlib.h"
28#include "string.h"
29#include "iap.h"
30#include "flash.h"
31#include "tmr.h"
32
41 iapfun jump_to_app;
42
43/* app_load don't optimize */
44#if defined (__CC_ARM)
45 #pragma O0
46#elif defined (__ICCARM__)
47 #pragma optimize=s none
48#endif
55void app_load(uint32_t app_addr)
56{
57 /* check the address of stack */
58 if(((*(uint32_t*)app_addr) - 0x20000000) < (SRAM_SIZE * 1024))
59 {
60 /* disable periph clock */
61 crm_periph_clock_enable(CRM_EMAC_PERIPH_CLOCK, FALSE);
62 crm_periph_clock_enable(CRM_EMACTX_PERIPH_CLOCK, FALSE);
63 crm_periph_clock_enable(CRM_EMACRX_PERIPH_CLOCK, FALSE);
64 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, FALSE);
65
66 /* disable nvic irq and clear pending */
67 nvic_irq_disable(EMAC_IRQn);
68 nvic_irq_disable(TMR3_GLOBAL_IRQn);
69 __NVIC_ClearPendingIRQ(EMAC_IRQn);
70 __NVIC_ClearPendingIRQ(TMR3_GLOBAL_IRQn);
71
72 jump_to_app = (iapfun)*(uint32_t*)(app_addr + 4); /* code second word is reset address */
73 __set_MSP(*(uint32_t*)app_addr); /* init app stack pointer(code first word is stack address) */
74 jump_to_app(); /* jump to user app */
75 }
76}
77
83void iap_command_handle(void)
84{
85 flash_unlock();
86 flash_sector_erase(IAP_UPGRADE_FLAG_ADDR);
87 flash_word_program(IAP_UPGRADE_FLAG_ADDR, IAP_UPGRADE_FLAG);
88 flash_lock();
89}
90
96void iap_init(void)
97{
98 if((*(uint32_t*)IAP_UPGRADE_FLAG_ADDR) == IAP_UPGRADE_FLAG)
99 {
100 flash_unlock();
101 flash_sector_erase(IAP_UPGRADE_FLAG_ADDR);
102 flash_lock();
103 }
104}
105
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:129
iap_init
void iap_init(void)
iap init.
Definition: at32f437_emac_iap_demo/source_code/bootloader/src/iap.c:96
jump_to_app
iapfun jump_to_app
Definition: at32f437_emac_iap_demo/source_code/bootloader/src/iap.c:41
iap_command_handle
void iap_command_handle(void)
iap command handle handle.
Definition: at32f437_emac_iap_demo/source_code/bootloader/src/iap.c:83
app_load
void app_load(uint32_t app_addr)
app load.
Definition: at32f437_emac_iap_demo/source_code/bootloader/src/iap.c:55
FALSE
@ FALSE
Definition: at32f435_437.h:379
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f435_437_flash.c:357
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f435_437_flash.c:290
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f435_437_flash.c:608
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f435_437_flash.c:325
IAP_UPGRADE_FLAG_ADDR
#define IAP_UPGRADE_FLAG_ADDR
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h:52
IAP_UPGRADE_FLAG
#define IAP_UPGRADE_FLAG
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h:64
nvic_irq_disable
void nvic_irq_disable(IRQn_Type irqn)
disable nvic irq number
Definition: at32f435_437_misc.c:81
SRAM_SIZE
#define SRAM_SIZE
Definition: utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/flash.h:50
iapfun
void(* iapfun)(void)
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h:121
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f435_437.h:177


AT32F435/437 Firmwary Library: tmr.c File Reference

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • bootloader
  • src
Functions
at32f437_emac_iap_demo/source_code/bootloader/src/tmr.c File Reference

tmr program More...

#include "at32f435_437_board.h"
#include "tmr.h"
#include "iap.h"

Go to the source code of this file.

Functions

void | tmr_init (void)
init tmr. More...
void | TMR3_GLOBAL_IRQHandler (void)
tmr3 global interrupt handler. More...

Detailed Description

tmr program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f437_emac_iap_demo/source_code/bootloader/src/tmr.c.


AT32F435/437 Firmwary Library: tmr.c Source File

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • bootloader
  • src
at32f437_emac_iap_demo/source_code/bootloader/src/tmr.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "tmr.h"
29#include "iap.h"
30
44void tmr_init(void)
45{
46 crm_clocks_freq_type crm_clocks_freq_struct = {0};
47
48 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
49
50 /* enable the tmr3 global interrupt */
51 nvic_irq_enable(TMR3_GLOBAL_IRQn, 0, 0);
52
53 /* get system clock */
54 crm_clocks_freq_get(&crm_clocks_freq_struct);
55
56 /* time base configuration */
57 tmr_base_init(TMR3, 5000, crm_clocks_freq_struct.ahb_freq / 5000);
58 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
59
60 /* overflow interrupt enable */
61 tmr_interrupt_enable(TMR3, TMR_OVF_INT, TRUE);
62
63 /* enable tmr */
64 tmr_counter_enable(TMR3, TRUE);
65
66}
67
73void TMR3_GLOBAL_IRQHandler(void)
74{
75 if(tmr_flag_get(TMR3, TMR_OVF_FLAG) == SET)
76 {
77 tmr_flag_clear(TMR3, TMR_OVF_FLAG);
78 at32_led_toggle(LED2);
79 }
80}
81
at32f435_437_board.h
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:40
LED2
@ LED2
Definition: at32f435_437_board.h:65
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:129
TMR3_GLOBAL_IRQHandler
void TMR3_GLOBAL_IRQHandler(void)
tmr3 global interrupt handler.
Definition: at32f437_emac_iap_demo/source_code/bootloader/src/tmr.c:73
tmr_init
void tmr_init(void)
init tmr.
Definition: at32f437_emac_iap_demo/source_code/bootloader/src/tmr.c:44
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f435_437_tmr.c:1463
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f435_437_tmr.c:1424
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f435_437_tmr.c:1389
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_OVF_FLAG
#define TMR_OVF_FLAG
Definition: at32f435_437_tmr.h:52
TMR_OVF_INT
#define TMR_OVF_INT
Definition: at32f435_437_tmr.h:75
TMR3
#define TMR3
Definition: at32f435_437_tmr.h:897
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f435_437.h:177
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::ahb_freq
uint32_t ahb_freq
Definition: at32f435_437_crm.h:790


AT32F435/437 Firmwary Library: at32f435_437_board.d File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_board.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: at32f435_437_board.d Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_board.d
Go to the documentation of this file.
1./objects/at32f435_437_board.o: \
2 ..\..\..\..\..\at32f435_437_board\at32f435_437_board.c \
3 ..\..\..\..\..\at32f435_437_board\at32f435_437_board.h \
4 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdio.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\at32f435_437.h \
6 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\core_cm4.h \
7 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
8 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_version.h \
9 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
10 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
13 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\mpu_armv7.h \
14 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\system_at32f435_437.h \
15 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_def.h \
16 ..\inc\at32f435_437_conf.h \
17 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crm.h \
18 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_tmr.h \
19 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_ertc.h \
20 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_gpio.h \
21 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_i2c.h \
22 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usart.h \
23 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_pwc.h \
24 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_can.h \
25 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_adc.h \
26 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dac.h \
27 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_spi.h \
28 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dma.h \
29 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_debug.h \
30 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_flash.h \
31 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crc.h \
32 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wwdt.h \
33 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wdt.h \
34 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_exint.h \
35 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_sdio.h \
36 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_xmc.h \
37 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_acc.h \
38 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_misc.h \
39 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_edma.h \
40 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_qspi.h \
41 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_scfg.h \
42 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_emac.h \
43 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dvp.h \
44 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usb.h


AT32F435/437 Firmwary Library: at32f435_437_clock.d File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_clock.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: at32f435_437_clock.d Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_clock.d
Go to the documentation of this file.
1./objects/at32f435_437_clock.o: ..\src\at32f435_437_clock.c \
2 ..\inc\at32f435_437_clock.h \
3 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\at32f435_437.h \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\core_cm4.h \
5 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
6 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_version.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
8 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
11 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\mpu_armv7.h \
12 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\system_at32f435_437.h \
13 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_def.h \
14 ..\inc\at32f435_437_conf.h \
15 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crm.h \
16 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_tmr.h \
17 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_ertc.h \
18 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_gpio.h \
19 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_i2c.h \
20 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usart.h \
21 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_pwc.h \
22 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_can.h \
23 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_adc.h \
24 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dac.h \
25 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_spi.h \
26 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dma.h \
27 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_debug.h \
28 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_flash.h \
29 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crc.h \
30 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wwdt.h \
31 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wdt.h \
32 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_exint.h \
33 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_sdio.h \
34 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_xmc.h \
35 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_acc.h \
36 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_misc.h \
37 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_edma.h \
38 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_qspi.h \
39 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_scfg.h \
40 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_emac.h \
41 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dvp.h \
42 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usb.h


AT32F435/437 Firmwary Library: at32f435_437_crm.d File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_crm.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: at32f435_437_crm.d Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_crm.d
Go to the documentation of this file.
1./objects/at32f435_437_crm.o: \
2 ..\..\..\..\..\..\libraries\drivers\src\at32f435_437_crm.c \
3 ..\inc\at32f435_437_conf.h \
4 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crm.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\at32f435_437.h \
6 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\core_cm4.h \
7 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
8 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_version.h \
9 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
10 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
13 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\mpu_armv7.h \
14 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\system_at32f435_437.h \
15 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_def.h \
16 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_tmr.h \
17 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_ertc.h \
18 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_gpio.h \
19 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_i2c.h \
20 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usart.h \
21 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_pwc.h \
22 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_can.h \
23 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_adc.h \
24 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dac.h \
25 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_spi.h \
26 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dma.h \
27 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_debug.h \
28 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_flash.h \
29 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crc.h \
30 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wwdt.h \
31 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wdt.h \
32 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_exint.h \
33 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_sdio.h \
34 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_xmc.h \
35 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_acc.h \
36 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_misc.h \
37 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_edma.h \
38 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_qspi.h \
39 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_scfg.h \
40 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_emac.h \
41 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dvp.h \
42 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usb.h


AT32F435/437 Firmwary Library: at32f435_437_gpio.d File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_gpio.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: at32f435_437_gpio.d Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_gpio.d
Go to the documentation of this file.
1./objects/at32f435_437_gpio.o: \
2 ..\..\..\..\..\..\libraries\drivers\src\at32f435_437_gpio.c \
3 ..\inc\at32f435_437_conf.h \
4 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crm.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\at32f435_437.h \
6 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\core_cm4.h \
7 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
8 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_version.h \
9 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
10 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
13 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\mpu_armv7.h \
14 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\system_at32f435_437.h \
15 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_def.h \
16 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_tmr.h \
17 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_ertc.h \
18 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_gpio.h \
19 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_i2c.h \
20 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usart.h \
21 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_pwc.h \
22 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_can.h \
23 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_adc.h \
24 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dac.h \
25 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_spi.h \
26 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dma.h \
27 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_debug.h \
28 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_flash.h \
29 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crc.h \
30 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wwdt.h \
31 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wdt.h \
32 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_exint.h \
33 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_sdio.h \
34 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_xmc.h \
35 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_acc.h \
36 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_misc.h \
37 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_edma.h \
38 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_qspi.h \
39 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_scfg.h \
40 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_emac.h \
41 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dvp.h \
42 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usb.h


AT32F435/437 Firmwary Library: at32f435_437_int.d File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_int.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: at32f435_437_int.d Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_int.d
Go to the documentation of this file.
1./objects/at32f435_437_int.o: ..\src\at32f435_437_int.c \
2 ..\inc\at32f435_437_int.h \
3 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\at32f435_437.h \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\core_cm4.h \
5 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
6 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_version.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
8 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
11 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\mpu_armv7.h \
12 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\system_at32f435_437.h \
13 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_def.h \
14 ..\inc\at32f435_437_conf.h \
15 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crm.h \
16 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_tmr.h \
17 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_ertc.h \
18 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_gpio.h \
19 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_i2c.h \
20 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usart.h \
21 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_pwc.h \
22 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_can.h \
23 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_adc.h \
24 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dac.h \
25 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_spi.h \
26 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dma.h \
27 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_debug.h \
28 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_flash.h \
29 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crc.h \
30 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wwdt.h \
31 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wdt.h \
32 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_exint.h \
33 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_sdio.h \
34 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_xmc.h \
35 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_acc.h \
36 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_misc.h \
37 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_edma.h \
38 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_qspi.h \
39 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_scfg.h \
40 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_emac.h \
41 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dvp.h \
42 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usb.h


AT32F435/437 Firmwary Library: at32f435_437_misc.d File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_misc.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: at32f435_437_misc.d Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_misc.d
Go to the documentation of this file.
1./objects/at32f435_437_misc.o: \
2 ..\..\..\..\..\..\libraries\drivers\src\at32f435_437_misc.c \
3 ..\inc\at32f435_437_conf.h \
4 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crm.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\at32f435_437.h \
6 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\core_cm4.h \
7 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
8 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_version.h \
9 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
10 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
13 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\mpu_armv7.h \
14 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\system_at32f435_437.h \
15 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_def.h \
16 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_tmr.h \
17 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_ertc.h \
18 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_gpio.h \
19 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_i2c.h \
20 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usart.h \
21 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_pwc.h \
22 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_can.h \
23 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_adc.h \
24 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dac.h \
25 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_spi.h \
26 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dma.h \
27 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_debug.h \
28 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_flash.h \
29 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crc.h \
30 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wwdt.h \
31 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wdt.h \
32 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_exint.h \
33 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_sdio.h \
34 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_xmc.h \
35 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_acc.h \
36 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_misc.h \
37 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_edma.h \
38 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_qspi.h \
39 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_scfg.h \
40 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_emac.h \
41 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dvp.h \
42 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usb.h


AT32F435/437 Firmwary Library: at32f435_437_usart.d File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_usart.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: at32f435_437_usart.d Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_usart.d
Go to the documentation of this file.
1./objects/at32f435_437_usart.o: \
2 ..\..\..\..\..\..\libraries\drivers\src\at32f435_437_usart.c \
3 ..\inc\at32f435_437_conf.h \
4 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crm.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\at32f435_437.h \
6 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\core_cm4.h \
7 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
8 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_version.h \
9 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
10 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
13 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\mpu_armv7.h \
14 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\system_at32f435_437.h \
15 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_def.h \
16 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_tmr.h \
17 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_ertc.h \
18 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_gpio.h \
19 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_i2c.h \
20 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usart.h \
21 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_pwc.h \
22 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_can.h \
23 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_adc.h \
24 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dac.h \
25 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_spi.h \
26 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dma.h \
27 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_debug.h \
28 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_flash.h \
29 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crc.h \
30 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wwdt.h \
31 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wdt.h \
32 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_exint.h \
33 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_sdio.h \
34 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_xmc.h \
35 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_acc.h \
36 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_misc.h \
37 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_edma.h \
38 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_qspi.h \
39 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_scfg.h \
40 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_emac.h \
41 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dvp.h \
42 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usb.h


AT32F435/437 Firmwary Library: basicmathfunctions.d File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/basicmathfunctions.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: basicmathfunctions.d Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/basicmathfunctions.d
Go to the documentation of this file.
1./objects/basicmathfunctions.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\BasicMathFunctions.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_abs_f32.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h \
14 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_abs_q15.c \
15 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_abs_q31.c \
16 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_abs_q7.c \
17 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_add_f32.c \
18 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_add_q15.c \
19 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_add_q31.c \
20 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_add_q7.c \
21 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_and_u16.c \
22 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_and_u32.c \
23 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_and_u8.c \
24 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_dot_prod_f32.c \
25 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_dot_prod_q15.c \
26 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_dot_prod_q31.c \
27 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_dot_prod_q7.c \
28 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_mult_f32.c \
29 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_mult_q15.c \
30 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_mult_q31.c \
31 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_mult_q7.c \
32 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_negate_f32.c \
33 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_negate_q15.c \
34 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_negate_q31.c \
35 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_negate_q7.c \
36 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_not_u16.c \
37 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_not_u32.c \
38 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_not_u8.c \
39 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_offset_f32.c \
40 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_offset_q15.c \
41 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_offset_q31.c \
42 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_offset_q7.c \
43 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_or_u16.c \
44 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_or_u32.c \
45 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_or_u8.c \
46 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_scale_f32.c \
47 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_scale_q15.c \
48 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_scale_q31.c \
49 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_scale_q7.c \
50 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_shift_q15.c \
51 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_shift_q31.c \
52 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_shift_q7.c \
53 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_sub_f32.c \
54 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_sub_q15.c \
55 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_sub_q31.c \
56 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_sub_q7.c \
57 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_xor_u16.c \
58 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_xor_u32.c \
59 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_xor_u8.c


AT32F435/437 Firmwary Library: bayesfunctions.d File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/bayesfunctions.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: bayesfunctions.d Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/bayesfunctions.d
Go to the documentation of this file.
1./objects/bayesfunctions.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BayesFunctions\BayesFunctions.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BayesFunctions\arm_gaussian_naive_bayes_predict_f32.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h


AT32F435/437 Firmwary Library: commontables.d File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/commontables.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: commontables.d Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/commontables.d
Go to the documentation of this file.
1./objects/commontables.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\CommonTables\CommonTables.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\CommonTables\arm_common_tables.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h \
14 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_common_tables.h \
15 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
16 ..\..\..\..\..\..\libraries\cmsis\dsp\source\CommonTables\arm_const_structs.c \
17 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_const_structs.h \
18 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_common_tables.h \
19 ..\..\..\..\..\..\libraries\cmsis\dsp\source\CommonTables\arm_mve_tables.c


AT32F435/437 Firmwary Library: complexmathfunctions.d File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/complexmathfunctions.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: complexmathfunctions.d Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/complexmathfunctions.d
Go to the documentation of this file.
1./objects/complexmathfunctions.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\ComplexMathFunctions.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_conj_f32.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h \
14 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_conj_q15.c \
15 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_conj_q31.c \
16 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_dot_prod_f32.c \
17 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_dot_prod_q15.c \
18 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_dot_prod_q31.c \
19 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_mag_f32.c \
20 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_mag_q15.c \
21 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_mag_q31.c \
22 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_mag_squared_f32.c \
23 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_mag_squared_q15.c \
24 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_mag_squared_q31.c \
25 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_mult_cmplx_f32.c \
26 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_mult_cmplx_q15.c \
27 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_mult_cmplx_q31.c \
28 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_mult_real_f32.c \
29 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_mult_real_q15.c \
30 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_mult_real_q31.c


AT32F435/437 Firmwary Library: controllerfunctions.d File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/controllerfunctions.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: controllerfunctions.d Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/controllerfunctions.d
Go to the documentation of this file.
1./objects/controllerfunctions.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ControllerFunctions\ControllerFunctions.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ControllerFunctions\arm_pid_init_f32.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h \
14 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ControllerFunctions\arm_pid_init_q15.c \
15 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ControllerFunctions\arm_pid_init_q31.c \
16 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ControllerFunctions\arm_pid_reset_f32.c \
17 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ControllerFunctions\arm_pid_reset_q15.c \
18 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ControllerFunctions\arm_pid_reset_q31.c \
19 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ControllerFunctions\arm_sin_cos_f32.c \
20 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_common_tables.h \
21 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
22 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ControllerFunctions\arm_sin_cos_q31.c


AT32F435/437 Firmwary Library: distancefunctions.d File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/distancefunctions.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: distancefunctions.d Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/distancefunctions.d
Go to the documentation of this file.
1./objects/distancefunctions.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\DistanceFunctions.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_boolean_distance.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h \
14 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_boolean_distance_template.h \
15 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_braycurtis_distance_f32.c \
16 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_canberra_distance_f32.c \
17 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_chebyshev_distance_f32.c \
18 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_cityblock_distance_f32.c \
19 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_correlation_distance_f32.c \
20 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_cosine_distance_f32.c \
21 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_dice_distance.c \
22 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_euclidean_distance_f32.c \
23 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_hamming_distance.c \
24 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_jaccard_distance.c \
25 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_jensenshannon_distance_f32.c \
26 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_kulsinski_distance.c \
27 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_minkowski_distance_f32.c \
28 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_rogerstanimoto_distance.c \
29 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_russellrao_distance.c \
30 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_sokalmichener_distance.c \
31 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_sokalsneath_distance.c \
32 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_yule_distance.c


AT32F435/437 Firmwary Library: fastmathfunctions.d File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/fastmathfunctions.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: fastmathfunctions.d Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/fastmathfunctions.d
Go to the documentation of this file.
1./objects/fastmathfunctions.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FastMathFunctions\FastMathFunctions.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FastMathFunctions\arm_cos_f32.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h \
14 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_common_tables.h \
15 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
16 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FastMathFunctions\arm_cos_q15.c \
17 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FastMathFunctions\arm_cos_q31.c \
18 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FastMathFunctions\arm_sin_f32.c \
19 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FastMathFunctions\arm_sin_q15.c \
20 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FastMathFunctions\arm_sin_q31.c \
21 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FastMathFunctions\arm_sqrt_q15.c \
22 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FastMathFunctions\arm_sqrt_q31.c \
23 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FastMathFunctions\arm_vexp_f32.c \
24 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FastMathFunctions\arm_vlog_f32.c


AT32F435/437 Firmwary Library: filteringfunctions.d File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/filteringfunctions.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: filteringfunctions.d Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/filteringfunctions.d
Go to the documentation of this file.
1./objects/filteringfunctions.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\FilteringFunctions.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df1_32x64_init_q31.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h \
14 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df1_32x64_q31.c \
15 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df1_f32.c \
16 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df1_fast_q15.c \
17 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df1_fast_q31.c \
18 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df1_init_f32.c \
19 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df1_init_q15.c \
20 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df1_init_q31.c \
21 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df1_q15.c \
22 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df1_q31.c \
23 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df2T_f32.c \
24 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df2T_f64.c \
25 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df2T_init_f32.c \
26 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df2T_init_f64.c \
27 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_stereo_df2T_f32.c \
28 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_stereo_df2T_init_f32.c \
29 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_f32.c \
30 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_fast_opt_q15.c \
31 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_fast_q15.c \
32 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_fast_q31.c \
33 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_opt_q15.c \
34 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_opt_q7.c \
35 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_partial_f32.c \
36 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_partial_fast_opt_q15.c \
37 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_partial_fast_q15.c \
38 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_partial_fast_q31.c \
39 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_partial_opt_q15.c \
40 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_partial_opt_q7.c \
41 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_partial_q15.c \
42 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_partial_q31.c \
43 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_partial_q7.c \
44 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_q15.c \
45 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_q31.c \
46 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_q7.c \
47 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_correlate_f32.c \
48 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_correlate_fast_opt_q15.c \
49 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_correlate_fast_q15.c \
50 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_correlate_fast_q31.c \
51 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_correlate_opt_q15.c \
52 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_correlate_opt_q7.c \
53 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_correlate_q15.c \
54 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_correlate_q31.c \
55 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_correlate_q7.c \
56 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_decimate_f32.c \
57 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_decimate_fast_q15.c \
58 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_decimate_fast_q31.c \
59 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_decimate_init_f32.c \
60 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_decimate_init_q15.c \
61 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_decimate_init_q31.c \
62 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_decimate_q15.c \
63 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_decimate_q31.c \
64 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_f32.c \
65 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_fast_q15.c \
66 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_fast_q31.c \
67 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_init_f32.c \
68 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_init_q15.c \
69 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_init_q31.c \
70 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_init_q7.c \
71 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_interpolate_f32.c \
72 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_interpolate_init_f32.c \
73 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_interpolate_init_q15.c \
74 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_interpolate_init_q31.c \
75 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_interpolate_q15.c \
76 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_interpolate_q31.c \
77 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_lattice_f32.c \
78 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_lattice_init_f32.c \
79 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_lattice_init_q15.c \
80 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_lattice_init_q31.c \
81 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_lattice_q15.c \
82 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_lattice_q31.c \
83 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_q15.c \
84 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_q31.c \
85 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_q7.c \
86 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_sparse_f32.c \
87 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_sparse_init_f32.c \
88 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_sparse_init_q15.c \
89 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_sparse_init_q31.c \
90 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_sparse_init_q7.c \
91 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_sparse_q15.c \
92 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_sparse_q31.c \
93 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_sparse_q7.c \
94 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_iir_lattice_f32.c \
95 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_iir_lattice_init_f32.c \
96 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_iir_lattice_init_q15.c \
97 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_iir_lattice_init_q31.c \
98 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_iir_lattice_q15.c \
99 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_iir_lattice_q31.c \
100 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_lms_f32.c \
101 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_lms_init_f32.c \
102 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_lms_init_q15.c \
103 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_lms_init_q31.c \
104 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_lms_norm_f32.c \
105 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_lms_norm_init_f32.c \
106 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_lms_norm_init_q15.c \
107 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_common_tables.h \
108 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
109 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_lms_norm_init_q31.c \
110 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_lms_norm_q15.c \
111 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_lms_norm_q31.c \
112 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_lms_q15.c \
113 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_lms_q31.c
arm_fir_f32
void arm_fir_f32(const arm_fir_instance_f32 *S, const float32_t *pSrc, float32_t *pDst, uint32_t blockSize)
arm_fir_init_f32
void arm_fir_init_f32(arm_fir_instance_f32 *S, uint16_t numTaps, const float32_t *pCoeffs, float32_t *pState, uint32_t blockSize)
Initialization function for the floating-point FIR filter.
Definition: arm_fir_init_f32.c:59


AT32F435/437 Firmwary Library: main.d File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/main.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: main.d Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/main.d
Go to the documentation of this file.
1./objects/main.o: ..\src\main.c \
2 ..\..\..\..\..\at32f435_437_board\at32f435_437_board.h \
3 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdio.h \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\at32f435_437.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\core_cm4.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_version.h \
8 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
9 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
12 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\mpu_armv7.h \
13 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\system_at32f435_437.h \
14 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_def.h \
15 ..\inc\at32f435_437_conf.h \
16 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crm.h \
17 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_tmr.h \
18 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_ertc.h \
19 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_gpio.h \
20 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_i2c.h \
21 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usart.h \
22 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_pwc.h \
23 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_can.h \
24 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_adc.h \
25 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dac.h \
26 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_spi.h \
27 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dma.h \
28 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_debug.h \
29 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_flash.h \
30 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crc.h \
31 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wwdt.h \
32 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wdt.h \
33 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_exint.h \
34 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_sdio.h \
35 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_xmc.h \
36 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_acc.h \
37 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_misc.h \
38 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_edma.h \
39 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_qspi.h \
40 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_scfg.h \
41 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_emac.h \
42 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dvp.h \
43 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usb.h \
44 ..\inc\at32f435_437_clock.h \
45 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
46 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
47 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
48 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
49 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h
main
int main(void)
main function.
Definition: project/at_start_f435/examples/acc/calibration/src/main.c:167


AT32F435/437 Firmwary Library: matrixfunctions.d File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/matrixfunctions.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: matrixfunctions.d Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/matrixfunctions.d
Go to the documentation of this file.
1./objects/matrixfunctions.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\MatrixFunctions.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_add_f32.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h \
14 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_add_q15.c \
15 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_add_q31.c \
16 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_cmplx_mult_f32.c \
17 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_cmplx_mult_q15.c \
18 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_cmplx_mult_q31.c \
19 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_init_f32.c \
20 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_init_q15.c \
21 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_init_q31.c \
22 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_inverse_f32.c \
23 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_inverse_f64.c \
24 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_mult_f32.c \
25 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_mult_fast_q15.c \
26 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_mult_fast_q31.c \
27 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_mult_q15.c \
28 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_mult_q31.c \
29 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_scale_f32.c \
30 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_scale_q15.c \
31 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_scale_q31.c \
32 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_sub_f32.c \
33 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_sub_q15.c \
34 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_sub_q31.c \
35 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_trans_f32.c \
36 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_trans_q15.c \
37 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_trans_q31.c


AT32F435/437 Firmwary Library: startup_at32f435_437.d File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/startup_at32f435_437.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: startup_at32f435_437.d Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/startup_at32f435_437.d
Go to the documentation of this file.
1.\objects\startup_at32f435_437.o: ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\startup\mdk\startup_at32f435_437.s


AT32F435/437 Firmwary Library: statisticsfunctions.d File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/statisticsfunctions.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: statisticsfunctions.d Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/statisticsfunctions.d
Go to the documentation of this file.
1./objects/statisticsfunctions.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\StatisticsFunctions.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_entropy_f32.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h \
14 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_entropy_f64.c \
15 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_kullback_leibler_f32.c \
16 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_kullback_leibler_f64.c \
17 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_logsumexp_dot_prod_f32.c \
18 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_logsumexp_f32.c \
19 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_max_f32.c \
20 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_max_q15.c \
21 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_max_q31.c \
22 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_max_q7.c \
23 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_max_no_idx_f32.c \
24 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_mean_f32.c \
25 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_mean_q15.c \
26 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_mean_q31.c \
27 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_mean_q7.c \
28 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_min_f32.c \
29 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_min_q15.c \
30 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_min_q31.c \
31 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_min_q7.c \
32 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_power_f32.c \
33 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_power_q15.c \
34 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_power_q31.c \
35 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_power_q7.c \
36 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_rms_f32.c \
37 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_rms_q15.c \
38 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_rms_q31.c \
39 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_std_f32.c \
40 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_std_q15.c \
41 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_std_q31.c \
42 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_var_f32.c \
43 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_var_q15.c \
44 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_var_q31.c


AT32F435/437 Firmwary Library: supportfunctions.d File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/supportfunctions.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: supportfunctions.d Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/supportfunctions.d
Go to the documentation of this file.
1./objects/supportfunctions.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\SupportFunctions.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_barycenter_f32.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h \
14 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_bitonic_sort_f32.c \
15 ..\..\..\..\..\..\libraries\cmsis\dsp\PrivateInclude\arm_sorting.h \
16 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_bubble_sort_f32.c \
17 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_copy_f32.c \
18 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_copy_q15.c \
19 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_copy_q31.c \
20 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_copy_q7.c \
21 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_fill_f32.c \
22 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_fill_q15.c \
23 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_fill_q31.c \
24 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_fill_q7.c \
25 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_heap_sort_f32.c \
26 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_insertion_sort_f32.c \
27 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_merge_sort_f32.c \
28 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_merge_sort_init_f32.c \
29 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_quick_sort_f32.c \
30 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_selection_sort_f32.c \
31 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_sort_f32.c \
32 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_sort_init_f32.c \
33 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_spline_interp_f32.c \
34 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_spline_interp_init_f32.c \
35 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_weighted_sum_f32.c \
36 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_float_to_q15.c \
37 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_float_to_q31.c \
38 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_float_to_q7.c \
39 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_q15_to_float.c \
40 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_q15_to_q31.c \
41 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_q15_to_q7.c \
42 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_q31_to_float.c \
43 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_q31_to_q15.c \
44 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_q31_to_q7.c \
45 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_q7_to_float.c \
46 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_q7_to_q15.c \
47 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_q7_to_q31.c


AT32F435/437 Firmwary Library: svmfunctions.d File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/svmfunctions.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: svmfunctions.d Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/svmfunctions.d
Go to the documentation of this file.
1./objects/svmfunctions.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SVMFunctions\SVMFunctions.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SVMFunctions\arm_svm_linear_init_f32.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h \
14 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SVMFunctions\arm_svm_linear_predict_f32.c \
15 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SVMFunctions\arm_svm_polynomial_init_f32.c \
16 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SVMFunctions\arm_svm_polynomial_predict_f32.c \
17 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SVMFunctions\arm_svm_rbf_init_f32.c \
18 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SVMFunctions\arm_svm_rbf_predict_f32.c \
19 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SVMFunctions\arm_svm_sigmoid_init_f32.c \
20 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SVMFunctions\arm_svm_sigmoid_predict_f32.c


AT32F435/437 Firmwary Library: system_at32f435_437.d File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/system_at32f435_437.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: system_at32f435_437.d Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/system_at32f435_437.d
Go to the documentation of this file.
1./objects/system_at32f435_437.o: \
2 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\system_at32f435_437.c \
3 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\at32f435_437.h \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\core_cm4.h \
5 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
6 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_version.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
8 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
11 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\mpu_armv7.h \
12 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\system_at32f435_437.h \
13 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_def.h \
14 ..\inc\at32f435_437_conf.h \
15 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crm.h \
16 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\at32f435_437.h \
17 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_tmr.h \
18 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_ertc.h \
19 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_gpio.h \
20 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_i2c.h \
21 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usart.h \
22 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_pwc.h \
23 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_can.h \
24 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_adc.h \
25 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dac.h \
26 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_spi.h \
27 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dma.h \
28 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_debug.h \
29 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_flash.h \
30 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crc.h \
31 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wwdt.h \
32 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wdt.h \
33 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_exint.h \
34 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_sdio.h \
35 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_xmc.h \
36 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_acc.h \
37 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_misc.h \
38 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_edma.h \
39 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_qspi.h \
40 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_scfg.h \
41 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_emac.h \
42 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dvp.h \
43 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usb.h


AT32F435/437 Firmwary Library: transformfunctions.d File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/transformfunctions.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: transformfunctions.d Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/transformfunctions.d
Go to the documentation of this file.
1./objects/transformfunctions.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\TransformFunctions.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_bitreversal.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h \
14 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_common_tables.h \
15 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
16 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_bitreversal2.c \
17 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_f32.c \
18 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_f64.c \
19 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_q15.c \
20 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_q31.c \
21 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_init_f32.c \
22 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_const_structs.h \
23 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_common_tables.h \
24 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_init_f64.c \
25 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_init_q15.c \
26 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_init_q31.c \
27 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix2_f32.c \
28 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix2_init_f32.c \
29 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix2_init_q15.c \
30 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix2_init_q31.c \
31 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix2_q15.c \
32 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix2_q31.c \
33 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix4_f32.c \
34 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix4_init_f32.c \
35 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix4_init_q15.c \
36 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix4_init_q31.c \
37 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix4_q15.c \
38 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix4_q31.c \
39 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix8_f32.c \
40 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_dct4_f32.c \
41 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_dct4_init_f32.c \
42 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_dct4_init_q15.c \
43 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_dct4_init_q31.c \
44 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_dct4_q15.c \
45 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_dct4_q31.c \
46 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_rfft_f32.c \
47 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_rfft_fast_f32.c \
48 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_rfft_fast_f64.c \
49 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_rfft_fast_init_f32.c \
50 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_rfft_fast_init_f64.c \
51 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_rfft_init_f32.c \
52 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_rfft_init_q15.c \
53 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_rfft_init_q31.c \
54 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_rfft_q15.c \
55 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_rfft_q31.c


AT32F435/437 Firmwary Library: julia_fpu.h File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • fpu
  • inc
Macros | Functions
at_start_f435/examples/cortex_m4/fpu/inc/julia_fpu.h File Reference

julia_fpu header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Macros

#define | ITERATION 200
#define | REAL_CONSTANT (0.285f)
#define | IMG_CONSTANT (0.01f)

Functions

void generate_julia_fpu (uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable More...

Detailed Description

julia_fpu header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/cortex_m4/fpu/inc/julia_fpu.h.


AT32F435/437 Firmwary Library: julia_fpu.h Source File

  • at_start_f435
  • examples
  • cortex_m4
  • fpu
  • inc
at_start_f435/examples/cortex_m4/fpu/inc/julia_fpu.h
Go to the documentation of this file.
1
27#ifndef __JULIA_FPU_H
28#define __JULIA_FPU_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
46#define ITERATION 200
47#define REAL_CONSTANT (0.285f)
48#define IMG_CONSTANT (0.01f)
49
54void generate_julia_fpu(uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t * buffer);
55
68#ifdef __cplusplus
69}
70#endif
71
72#endif
73
at32f435_437.h
at32f435_437 header file
buffer
uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:43
generate_julia_fpu
void generate_julia_fpu(uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable
Definition: at_start_f437/examples/cortex_m4/fpu/src/julia_fpu.c:48


AT32F435/437 Firmwary Library: julia_fpu.c File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • fpu
  • src
Functions
at_start_f435/examples/cortex_m4/fpu/src/julia_fpu.c File Reference

julia_fpu source file More...

#include "julia_fpu.h"

Go to the source code of this file.

Functions

void generate_julia_fpu (uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable More...

Detailed Description

julia_fpu source file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/cortex_m4/fpu/src/julia_fpu.c.


AT32F435/437 Firmwary Library: julia_fpu.c Source File

  • at_start_f435
  • examples
  • cortex_m4
  • fpu
  • src
at_start_f435/examples/cortex_m4/fpu/src/julia_fpu.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "julia_fpu.h"
29
48void generate_julia_fpu(uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t * buffer)
49{
50 float tmp1, tmp2;
51 float num_real, num_img;
52 float rayon;
53 uint16_t i;
54 uint16_t x, y;
55 for (y = 0; y < size_y; y++)
56 {
57 for (x = 0; x < size_x; x++)
58 {
59 num_real = y - offset_y;
60 num_real = num_real / zoom;
61 num_img = x - offset_x;
62 num_img = num_img / zoom;
63 i = 0;
64 rayon = 0;
65 while((i < ITERATION - 1) && (rayon < 4))
66 {
67 tmp1 = num_real * num_real;
68 tmp2 = num_img * num_img;
69 num_img = 2 * num_real * num_img + IMG_CONSTANT;
70 num_real = tmp1 - tmp2 + REAL_CONSTANT;
71 rayon = tmp1 + tmp2;
72 i++;
73 }
74 /* store the value in the buffer */
75 buffer[x + y * size_x] = i;
76 }
77 }
78}
79
IMG_CONSTANT
#define IMG_CONSTANT
Definition: at_start_f435/examples/cortex_m4/fpu/inc/julia_fpu.h:48
generate_julia_fpu
void generate_julia_fpu(uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable
Definition: at_start_f435/examples/cortex_m4/fpu/src/julia_fpu.c:48
REAL_CONSTANT
#define REAL_CONSTANT
Definition: at_start_f435/examples/cortex_m4/fpu/inc/julia_fpu.h:47
ITERATION
#define ITERATION
Definition: at_start_f435/examples/cortex_m4/fpu/inc/julia_fpu.h:46
buffer
uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:43


AT32F435/437 Firmwary Library: dvp.c File Reference

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • dvp
Data Structures | Functions | Variables
at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c File Reference

dvp program More...

#include "at32f435_437.h"
#include "dvp.h"
#include "xmc_lcd.h"
#include "ov2640.h"

Go to the source code of this file.

Data Structures

struct Descriptors_Format_def

Functions

void | jpeg_data_process (void)
void | dvp_int_handler (void)
handles dvp interrupt request. More...
void | dvp_config (void)
configure dvp More...
void | dvp_io_init (void)
initialize gpio for dvp More...
void | dvp_dma_init (uint32_t mem0addr, uint32_t mem1addr, uint16_t memsize)
initialize dma for dvp More...
void | dvp_start (void)
start dvp transmission More...
void | dvp_stop (void)
stop dvp transmission More...
void | DVP_IRQHandler (void)
dvp irq handler More...
void | dvp_frame_done (void)
dvp frame transmit done More...
void | EDMA_Stream4_IRQHandler (void)
edma stream4 irq handler More...

Variables

edma_init_type edma_init_struct
uint8_t ov_frame = 0

Detailed Description

dvp program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c.


AT32F435/437 Firmwary Library: dvp.c Source File

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • dvp
at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c
Go to the documentation of this file.
1
27#include "at32f435_437.h"
28#include "dvp.h"
29#include "xmc_lcd.h"
30#include "ov2640.h"
31
40 edma_init_type edma_init_struct;
41uint8_t ov_frame = 0;
42
43extern void jpeg_data_process(void);
44void dvp_int_handler(void);
45
46typedef struct
47{
48 uint32_t CR_NDT;
49 uint32_t PA;
50 uint32_t M0A;
51 uint32_t LLP;
52
53}Descriptors_Format_def;
54
60void dvp_config(void)
61{
62 dvp_io_init();
63
64 nvic_irq_enable(DVP_IRQn, 0, 0);
65
66 dvp_capture_mode_set(DVP_CAP_FUNC_MODE_CONTINUOUS);
67 dvp_hsync_polarity_set(DVP_HSYNC_POLARITY_HIGH);
68 dvp_vsync_polarity_set(DVP_VSYNC_POLARITY_LOW);
69 dvp_pclk_polarity_set(DVP_CLK_POLARITY_RISING);
70 dvp_pixel_data_length_set(DVP_PIXEL_DATA_LENGTH_8);
71 dvp_sync_mode_set(DVP_SYNC_MODE_HARDWARE);
72
73 /* enable the interrupts */
74 dvp_interrupt_enable(DVP_CFD_INT | DVP_OVR_INT | DVP_ESE_INT | DVP_VS_INT | DVP_HS_INT, TRUE);
75
76 /* enable dvp by setting dvpen bit */
77 dvp_enable(TRUE);
78}
79
85void dvp_io_init(void)
86{
87 gpio_init_type gpio_initure;
88
89 crm_periph_clock_enable(CRM_DVP_PERIPH_CLOCK, TRUE);
90 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
91 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
92 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
93
94 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE4, GPIO_MUX_13);//HS
95 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE6, GPIO_MUX_13);//PCLK
96 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE9, GPIO_MUX_13);//D0
97 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE10, GPIO_MUX_13);//D1
98 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE11, GPIO_MUX_13);//D2
99 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE12, GPIO_MUX_13);//D3
100 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE4, GPIO_MUX_13);//D5
101 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE7, GPIO_MUX_13);//VS
102 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE9, GPIO_MUX_13);//D7
103 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE4, GPIO_MUX_13);//D4
104 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE5, GPIO_MUX_13);//D6
105
106 gpio_initure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_6 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11 | GPIO_PINS_12;
107 gpio_initure.gpio_mode = GPIO_MODE_MUX;
108 gpio_initure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
109 gpio_initure.gpio_pull = GPIO_PULL_UP;
110 gpio_initure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
111 gpio_init(GPIOA, &gpio_initure);
112
113 gpio_initure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_7 | GPIO_PINS_9;
114 gpio_init(GPIOB, &gpio_initure);
115
116 gpio_initure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5;
117 gpio_init(GPIOE, &gpio_initure);
118}
119
129void dvp_dma_init(uint32_t mem0addr, uint32_t mem1addr, uint16_t memsize)
130{
131 crm_periph_clock_enable(CRM_EDMA_PERIPH_CLOCK, TRUE);
132
133 edma_init_struct.peripheral_base_addr = (uint32_t)&DVP->dt;
134 edma_init_struct.memory0_base_addr = (uint32_t)mem0addr;
135 edma_init_struct.buffer_size = memsize;
136 edma_init_struct.direction = EDMA_DIR_PERIPHERAL_TO_MEMORY;
137 edma_init_struct.peripheral_inc_enable = FALSE;
138 edma_init_struct.memory_inc_enable = FALSE;
139 edma_init_struct.peripheral_data_width = EDMA_PERIPHERAL_DATA_WIDTH_WORD;
140 edma_init_struct.memory_data_width = EDMA_MEMORY_DATA_WIDTH_HALFWORD;
141 edma_init_struct.loop_mode_enable = TRUE;
142 edma_init_struct.priority = EDMA_PRIORITY_HIGH;
143 edma_init_struct.fifo_mode_enable = TRUE;
144 edma_init_struct.fifo_threshold = EDMA_FIFO_THRESHOLD_FULL;
145 edma_init_struct.memory_burst_mode = EDMA_MEMORY_SINGLE;
146 edma_init_struct.peripheral_burst_mode = EDMA_PERIPHERAL_SINGLE;
147
148 edma_reset(EDMA_STREAM4);
149 edma_init(EDMA_STREAM4, &edma_init_struct);
150
151 edmamux_enable(TRUE);
152 edmamux_init(EDMAMUX_CHANNEL4, EDMAMUX_DMAREQ_ID_DVP);
153
154 if(mem1addr != 0)
155 {
156 edma_double_buffer_mode_init(EDMA_STREAM4, mem1addr, EDMA_MEMORY_0);
157 edma_double_buffer_mode_enable(EDMA_STREAM4, TRUE);
158 }
159
160 edma_interrupt_enable(EDMA_STREAM4, EDMA_FDT_INT, TRUE);
161 nvic_irq_enable(EDMA_Stream4_IRQn, 0, 0);
162}
163
169void dvp_start(void)
170{
171 lcd_struct->lcd_setblock(0, 0, LCD_W, LCD_H);
172 edma_stream_enable(EDMA_STREAM4, TRUE);
173 dvp_capture_enable(TRUE);
174}
175
181void dvp_stop(void)
182{
183 dvp_capture_enable(FALSE);
184
185 while(DVP->ctrl & 0x01);
186
187 edma_stream_enable(EDMA_STREAM4, FALSE);
188}
189
195void DVP_IRQHandler(void)
196{
197 dvp_int_handler();
198}
199
205void dvp_frame_done(void)
206{
207 lcd_struct->lcd_setblock(0, 0, LCD_W, LCD_H);
208 ov_frame++;
209}
210
216void EDMA_Stream4_IRQHandler(void)
217{
218 if(edma_flag_get(EDMA_FDT4_FLAG) != RESET)
219 {
220 edma_flag_clear(EDMA_FDT4_FLAG);
221 }
222}
223
229void dvp_int_handler(void)
230{
231 /* synchronization error interrupt management */
232 if(dvp_flag_get(DVP_ESE_INT_FLAG) != RESET)
233 {
234 /* clear the synchronization error flag */
235 dvp_flag_clear(DVP_ESE_INT_FLAG);
236 }
237
238 /* overflow interrupt management */
239 if(dvp_flag_get(DVP_OVR_INT_FLAG) != RESET)
240 {
241 /* clear the overflow flag */
242 dvp_flag_clear(DVP_OVR_INT_FLAG);
243 }
244
245 /* line interrupt management */
246 if(dvp_flag_get(DVP_HS_INT_FLAG) != RESET)
247 {
248 /* clear the line interrupt flag */
249 dvp_flag_clear(DVP_HS_INT_FLAG);
250 }
251
252 /* vsync interrupt management */
253 if(dvp_flag_get(DVP_VS_INT_FLAG) != RESET)
254 {
255 /* clear the vsync flag */
256 dvp_flag_clear(DVP_VS_INT_FLAG);
257 }
258
259 /* end of frame interrupt management */
260 if(dvp_flag_get(DVP_CFD_INT_FLAG) != RESET)
261 {
262 /* clear the end of frame flag */
263 dvp_flag_clear(DVP_CFD_INT_FLAG);
264
265 dvp_frame_done();
266 }
267}
268
at32f435_437.h
at32f435_437 header file
dvp.h
header file of dvp program
LCD_H
#define LCD_H
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:79
dvp_stop
void dvp_stop(void)
stop dvp transmission
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:181
dvp_io_init
void dvp_io_init(void)
initialize gpio for dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:85
edma_init_struct
edma_init_type edma_init_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:40
dvp_frame_done
void dvp_frame_done(void)
dvp frame transmit done
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:205
dvp_start
void dvp_start(void)
start dvp transmission
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:169
DVP_IRQHandler
void DVP_IRQHandler(void)
dvp irq handler
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:195
ov_frame
uint8_t ov_frame
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:41
dvp_int_handler
void dvp_int_handler(void)
handles dvp interrupt request.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:229
LCD_W
#define LCD_W
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:78
dvp_dma_init
void dvp_dma_init(uint32_t mem0addr, uint32_t mem1addr, uint16_t memsize)
initialize dma for dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:129
lcd_struct
lcd_dev_type * lcd_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:48
dvp_config
void dvp_config(void)
configure dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:60
EDMA_Stream4_IRQHandler
void EDMA_Stream4_IRQHandler(void)
edma stream4 irq handler
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:216
jpeg_data_process
void jpeg_data_process(void)
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_EDMA_PERIPH_CLOCK
@ CRM_EDMA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:114
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_DVP_PERIPH_CLOCK
@ CRM_DVP_PERIPH_CLOCK
Definition: at32f435_437_crm.h:119
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
dvp_capture_mode_set
void dvp_capture_mode_set(dvp_cfm_type cap_mode)
set dvp capture mode
Definition: at32f435_437_dvp.c:73
dvp_capture_enable
void dvp_capture_enable(confirm_state new_state)
enable or disable dvp capture
Definition: at32f435_437_dvp.c:60
dvp_flag_get
flag_status dvp_flag_get(uint32_t flag)
get dvp event/interrupt flag status
Definition: at32f435_437_dvp.c:342
dvp_pixel_data_length_set
void dvp_pixel_data_length_set(dvp_pdl_type dvp_pdl)
config dvp pixel data length
Definition: at32f435_437_dvp.c:217
dvp_hsync_polarity_set
void dvp_hsync_polarity_set(dvp_hsp_type hsync_pol)
set dvp horizontal synchronization polarity
Definition: at32f435_437_dvp.c:174
dvp_sync_mode_set
void dvp_sync_mode_set(dvp_sm_type sync_mode)
set dvp synchronization mode
Definition: at32f435_437_dvp.c:122
dvp_vsync_polarity_set
void dvp_vsync_polarity_set(dvp_vsp_type vsync_pol)
set dvp vertical synchronization polarity
Definition: at32f435_437_dvp.c:187
dvp_interrupt_enable
void dvp_interrupt_enable(uint32_t dvp_int, confirm_state new_state)
enable or disable dvp interrupt
Definition: at32f435_437_dvp.c:312
dvp_enable
void dvp_enable(confirm_state new_state)
enable or disable dvp function
Definition: at32f435_437_dvp.c:227
dvp_pclk_polarity_set
void dvp_pclk_polarity_set(dvp_ckp_type eage)
set dvp pixel clock polarity
Definition: at32f435_437_dvp.c:161
dvp_flag_clear
void dvp_flag_clear(uint32_t flag)
clear dvp's pending flags
Definition: at32f435_437_dvp.c:388
DVP_VSYNC_POLARITY_LOW
@ DVP_VSYNC_POLARITY_LOW
Definition: at32f435_437_dvp.h:137
DVP_PIXEL_DATA_LENGTH_8
@ DVP_PIXEL_DATA_LENGTH_8
Definition: at32f435_437_dvp.h:156
DVP_SYNC_MODE_HARDWARE
@ DVP_SYNC_MODE_HARDWARE
Definition: at32f435_437_dvp.h:110
DVP_HSYNC_POLARITY_HIGH
@ DVP_HSYNC_POLARITY_HIGH
Definition: at32f435_437_dvp.h:128
DVP_CAP_FUNC_MODE_CONTINUOUS
@ DVP_CAP_FUNC_MODE_CONTINUOUS
Definition: at32f435_437_dvp.h:101
DVP_CLK_POLARITY_RISING
@ DVP_CLK_POLARITY_RISING
Definition: at32f435_437_dvp.h:119
DVP_VS_INT_FLAG
#define DVP_VS_INT_FLAG
Definition: at32f435_437_dvp.h:70
DVP_HS_INT_FLAG
#define DVP_HS_INT_FLAG
Definition: at32f435_437_dvp.h:71
DVP_CFD_INT_FLAG
#define DVP_CFD_INT_FLAG
Definition: at32f435_437_dvp.h:67
DVP_ESE_INT_FLAG
#define DVP_ESE_INT_FLAG
Definition: at32f435_437_dvp.h:69
DVP_OVR_INT_FLAG
#define DVP_OVR_INT_FLAG
Definition: at32f435_437_dvp.h:68
DVP_ESE_INT
#define DVP_ESE_INT
Definition: at32f435_437_dvp.h:84
DVP_VS_INT
#define DVP_VS_INT
Definition: at32f435_437_dvp.h:85
DVP_HS_INT
#define DVP_HS_INT
Definition: at32f435_437_dvp.h:86
DVP_OVR_INT
#define DVP_OVR_INT
Definition: at32f435_437_dvp.h:83
DVP_CFD_INT
#define DVP_CFD_INT
Definition: at32f435_437_dvp.h:82
DVP
#define DVP
Definition: at32f435_437_dvp.h:569
edma_flag_get
flag_status edma_flag_get(uint32_t edma_flag)
get the edma flag.
Definition: at32f435_437_edma.c:512
edma_flag_clear
void edma_flag_clear(uint32_t edma_flag)
clear the edma flag.
Definition: at32f435_437_edma.c:549
edma_double_buffer_mode_init
void edma_double_buffer_mode_init(edma_stream_type *edma_streamx, uint32_t memory1_addr, edma_memory_type current_memory)
config the the double buffer mode.
Definition: at32f435_437_edma.c:354
edmamux_init
void edmamux_init(edmamux_channel_type *edmamux_channelx, edmamux_requst_id_sel_type edmamux_req_id)
edmamux init.
Definition: at32f435_437_edma.c:718
edma_init
void edma_init(edma_stream_type *edma_streamx, edma_init_type *edma_init_struct)
edma init.
Definition: at32f435_437_edma.c:115
edma_double_buffer_mode_enable
void edma_double_buffer_mode_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the double memory mode.
Definition: at32f435_437_edma.c:383
edma_stream_enable
void edma_stream_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx.
Definition: at32f435_437_edma.c:198
edma_reset
void edma_reset(edma_stream_type *edma_streamx)
reset edma_streamx channely register.
Definition: at32f435_437_edma.c:58
edmamux_enable
void edmamux_enable(confirm_state new_state)
enable or disable the edma edmamux.
Definition: at32f435_437_edma.c:673
edma_interrupt_enable
void edma_interrupt_enable(edma_stream_type *edma_streamx, uint32_t edma_int, confirm_state new_state)
enable or disable the edma streamx interrupts.
Definition: at32f435_437_edma.c:225
EDMA_PRIORITY_HIGH
@ EDMA_PRIORITY_HIGH
Definition: at32f435_437_edma.h:191
EDMA_PERIPHERAL_DATA_WIDTH_WORD
@ EDMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_edma.h:171
EDMA_MEMORY_DATA_WIDTH_HALFWORD
@ EDMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_edma.h:180
EDMA_MEMORY_SINGLE
@ EDMA_MEMORY_SINGLE
Definition: at32f435_437_edma.h:224
EDMA_PERIPHERAL_SINGLE
@ EDMA_PERIPHERAL_SINGLE
Definition: at32f435_437_edma.h:235
EDMA_FIFO_THRESHOLD_FULL
@ EDMA_FIFO_THRESHOLD_FULL
Definition: at32f435_437_edma.h:203
EDMA_MEMORY_0
@ EDMA_MEMORY_0
Definition: at32f435_437_edma.h:150
EDMA_DIR_PERIPHERAL_TO_MEMORY
@ EDMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_edma.h:159
EDMAMUX_DMAREQ_ID_DVP
@ EDMAMUX_DMAREQ_ID_DVP
Definition: at32f435_437_edma.h:349
EDMA_FDT4_FLAG
#define EDMA_FDT4_FLAG
Definition: at32f435_437_edma.h:86
EDMA_FDT_INT
#define EDMA_FDT_INT
Definition: at32f435_437_edma.h:55
EDMA_STREAM4
#define EDMA_STREAM4
Definition: at32f435_437_edma.h:965
EDMAMUX_CHANNEL4
#define EDMAMUX_CHANNEL4
Definition: at32f435_437_edma.h:992
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_13
@ GPIO_MUX_13
Definition: at32f435_437_gpio.h:169
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
DVP_IRQn
@ DVP_IRQn
Definition: at32f435_437.h:221
EDMA_Stream4_IRQn
@ EDMA_Stream4_IRQn
Definition: at32f435_437.h:160
Descriptors_Format_def
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:47
Descriptors_Format_def::M0A
uint32_t M0A
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:50
Descriptors_Format_def::CR_NDT
uint32_t CR_NDT
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:48
Descriptors_Format_def::LLP
uint32_t LLP
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:51
Descriptors_Format_def::PA
uint32_t PA
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:49
edma_init_type
edma init type
Definition: at32f435_437_edma.h:440
edma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_edma.h:441
edma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_edma.h:444
edma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_edma.h:446
edma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_edma.h:445
edma_init_type::direction
edma_dir_type direction
Definition: at32f435_437_edma.h:443
edma_init_type::fifo_mode_enable
confirm_state fifo_mode_enable
Definition: at32f435_437_edma.h:451
edma_init_type::peripheral_data_width
edma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_edma.h:447
edma_init_type::fifo_threshold
edma_fifo_threshold_type fifo_threshold
Definition: at32f435_437_edma.h:452
edma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_edma.h:449
edma_init_type::priority
edma_priority_level_type priority
Definition: at32f435_437_edma.h:450
edma_init_type::memory0_base_addr
uint32_t memory0_base_addr
Definition: at32f435_437_edma.h:442
edma_init_type::peripheral_burst_mode
edma_peripheral_burst_type peripheral_burst_mode
Definition: at32f435_437_edma.h:454
edma_init_type::memory_data_width
edma_memory_data_size_type memory_data_width
Definition: at32f435_437_edma.h:448
edma_init_type::memory_burst_mode
edma_memory_burst_type memory_burst_mode
Definition: at32f435_437_edma.h:453
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
lcd_dev_type::lcd_setblock
void(* lcd_setblock)(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:48


AT32F435/437 Firmwary Library: dvp.h File Reference

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • dvp
Functions | Variables
at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.h File Reference

header file of dvp program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | dvp_config (void)
configure dvp More...
void | dvp_dma_init (uint32_t mem0addr, uint32_t mem1addr, uint16_t memsize)
initialize dma for dvp More...
void | dvp_start (void)
start dvp transmission More...
void | dvp_stop (void)
stop dvp transmission More...
void | dvp_io_init (void)
initialize gpio for dvp More...

Variables

edma_init_type edma_init_struct

Detailed Description

header file of dvp program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.h.


AT32F435/437 Firmwary Library: dvp.h Source File

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • dvp
at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __DVP_H
29#define __DVP_H
30
31#ifdef __cplusplus
32 extern "C" {
33#endif
34
35/* Includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
46extern edma_init_type edma_init_struct;
47void dvp_config(void);
48void dvp_dma_init(uint32_t mem0addr,uint32_t mem1addr,uint16_t memsize);
49void dvp_start(void);
50void dvp_stop(void);
51void dvp_io_init(void);
52
61#ifdef __cplusplus
62}
63#endif
64
65#endif /*__DVP_H */
at32f435_437.h
at32f435_437 header file
dvp_stop
void dvp_stop(void)
stop dvp transmission
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:181
dvp_io_init
void dvp_io_init(void)
initialize gpio for dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:85
edma_init_struct
edma_init_type edma_init_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:40
dvp_start
void dvp_start(void)
start dvp transmission
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:169
dvp_dma_init
void dvp_dma_init(uint32_t mem0addr, uint32_t mem1addr, uint16_t memsize)
initialize dma for dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:129
dvp_config
void dvp_config(void)
configure dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:60
edma_init_type
edma init type
Definition: at32f435_437_edma.h:440


AT32F435/437 Firmwary Library: font.h File Reference

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • lcd
Variables
at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h File Reference

Go to the source code of this file.

Variables

const unsigned char | asc2_1206 [95][12]
const unsigned char | asc2_1608 [95][16]
const unsigned char | asc2_2412 [95][36]
const unsigned char | asc2_3216 [95][128]


AT32F435/437 Firmwary Library: font.h Source File

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • lcd
at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h
Go to the documentation of this file.
1/* *
2 **************************************************************************
3 * @file font.h
4 * @version v2.0.9
5 * @date 2022-06-28
6 * @brief header file of font
7 **************************************************************************
8 * Copyright notice & Disclaimer
9 *
10 * The software Board Support Package (BSP) that is made available to
11 * download from Artery official website is the copyrighted work of Artery.
12 * Artery authorizes customers to use, copy, and distribute the BSP
13 * software and its related documentation for the purpose of design and
14 * development in conjunction with Artery microcontrollers. Use of the
15 * software is governed by this copyright notice and the following disclaimer.
16 *
17 * THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES,
18 * GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS,
19 * TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR
20 * STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS,
21 * INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY,
22 * FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.
23 *
24 **************************************************************************
25 */
26
27#ifndef __FONT_H
28#define __FONT_H
29
38const unsigned char asc2_1206[95][12]={
39{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
40{0x00,0x00,0x00,0x00,0x3F,0x40,0x00,0x00,0x00,0x00,0x00,0x00},
41{0x00,0x00,0x30,0x00,0x40,0x00,0x30,0x00,0x40,0x00,0x00,0x00},
42{0x09,0x00,0x0B,0xC0,0x3D,0x00,0x0B,0xC0,0x3D,0x00,0x09,0x00},
43{0x18,0xC0,0x24,0x40,0x7F,0xE0,0x22,0x40,0x31,0x80,0x00,0x00},
44{0x18,0x00,0x24,0xC0,0x1B,0x00,0x0D,0x80,0x32,0x40,0x01,0x80},
45{0x03,0x80,0x1C,0x40,0x27,0x40,0x1C,0x80,0x07,0x40,0x00,0x40},
46{0x10,0x00,0x60,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
47{0x00,0x00,0x00,0x00,0x00,0x00,0x1F,0x80,0x20,0x40,0x40,0x20},
48{0x00,0x00,0x40,0x20,0x20,0x40,0x1F,0x80,0x00,0x00,0x00,0x00},
49{0x09,0x00,0x06,0x00,0x1F,0x80,0x06,0x00,0x09,0x00,0x00,0x00},
50{0x04,0x00,0x04,0x00,0x3F,0x80,0x04,0x00,0x04,0x00,0x00,0x00},
51{0x00,0x10,0x00,0x60,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
52{0x04,0x00,0x04,0x00,0x04,0x00,0x04,0x00,0x04,0x00,0x00,0x00},
53{0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
54{0x00,0x20,0x01,0xC0,0x06,0x00,0x38,0x00,0x40,0x00,0x00,0x00},
55{0x1F,0x80,0x20,0x40,0x20,0x40,0x20,0x40,0x1F,0x80,0x00,0x00},
56{0x00,0x00,0x10,0x40,0x3F,0xC0,0x00,0x40,0x00,0x00,0x00,0x00},
57{0x18,0xC0,0x21,0x40,0x22,0x40,0x24,0x40,0x18,0x40,0x00,0x00},
58{0x10,0x80,0x20,0x40,0x24,0x40,0x24,0x40,0x1B,0x80,0x00,0x00},
59{0x02,0x00,0x0D,0x00,0x11,0x00,0x3F,0xC0,0x01,0x40,0x00,0x00},
60{0x3C,0x80,0x24,0x40,0x24,0x40,0x24,0x40,0x23,0x80,0x00,0x00},
61{0x1F,0x80,0x24,0x40,0x24,0x40,0x34,0x40,0x03,0x80,0x00,0x00},
62{0x30,0x00,0x20,0x00,0x27,0xC0,0x38,0x00,0x20,0x00,0x00,0x00},
63{0x1B,0x80,0x24,0x40,0x24,0x40,0x24,0x40,0x1B,0x80,0x00,0x00},
64{0x1C,0x00,0x22,0xC0,0x22,0x40,0x22,0x40,0x1F,0x80,0x00,0x00},
65{0x00,0x00,0x00,0x00,0x08,0x40,0x00,0x00,0x00,0x00,0x00,0x00},
66{0x00,0x00,0x00,0x00,0x04,0x60,0x00,0x00,0x00,0x00,0x00,0x00},
67{0x00,0x00,0x04,0x00,0x0A,0x00,0x11,0x00,0x20,0x80,0x40,0x40},
68{0x09,0x00,0x09,0x00,0x09,0x00,0x09,0x00,0x09,0x00,0x00,0x00},
69{0x00,0x00,0x40,0x40,0x20,0x80,0x11,0x00,0x0A,0x00,0x04,0x00},
70{0x18,0x00,0x20,0x00,0x23,0x40,0x24,0x00,0x18,0x00,0x00,0x00},
71{0x1F,0x80,0x20,0x40,0x27,0x40,0x29,0x40,0x1F,0x40,0x00,0x00},
72{0x00,0x40,0x07,0xC0,0x39,0x00,0x0F,0x00,0x01,0xC0,0x00,0x40},
73{0x20,0x40,0x3F,0xC0,0x24,0x40,0x24,0x40,0x1B,0x80,0x00,0x00},
74{0x1F,0x80,0x20,0x40,0x20,0x40,0x20,0x40,0x30,0x80,0x00,0x00},
75{0x20,0x40,0x3F,0xC0,0x20,0x40,0x20,0x40,0x1F,0x80,0x00,0x00},
76{0x20,0x40,0x3F,0xC0,0x24,0x40,0x2E,0x40,0x30,0xC0,0x00,0x00},
77{0x20,0x40,0x3F,0xC0,0x24,0x40,0x2E,0x00,0x30,0x00,0x00,0x00},
78{0x0F,0x00,0x10,0x80,0x20,0x40,0x22,0x40,0x33,0x80,0x02,0x00},
79{0x20,0x40,0x3F,0xC0,0x04,0x00,0x04,0x00,0x3F,0xC0,0x20,0x40},
80{0x20,0x40,0x20,0x40,0x3F,0xC0,0x20,0x40,0x20,0x40,0x00,0x00},
81{0x00,0x60,0x20,0x20,0x20,0x20,0x3F,0xC0,0x20,0x00,0x20,0x00},
82{0x20,0x40,0x3F,0xC0,0x24,0x40,0x0B,0x00,0x30,0xC0,0x20,0x40},
83{0x20,0x40,0x3F,0xC0,0x20,0x40,0x00,0x40,0x00,0x40,0x00,0xC0},
84{0x3F,0xC0,0x3C,0x00,0x03,0xC0,0x3C,0x00,0x3F,0xC0,0x00,0x00},
85{0x20,0x40,0x3F,0xC0,0x0C,0x40,0x23,0x00,0x3F,0xC0,0x20,0x00},
86{0x1F,0x80,0x20,0x40,0x20,0x40,0x20,0x40,0x1F,0x80,0x00,0x00},
87{0x20,0x40,0x3F,0xC0,0x24,0x40,0x24,0x00,0x18,0x00,0x00,0x00},
88{0x1F,0x80,0x21,0x40,0x21,0x40,0x20,0xE0,0x1F,0xA0,0x00,0x00},
89{0x20,0x40,0x3F,0xC0,0x24,0x40,0x26,0x00,0x19,0xC0,0x00,0x40},
90{0x18,0xC0,0x24,0x40,0x24,0x40,0x22,0x40,0x31,0x80,0x00,0x00},
91{0x30,0x00,0x20,0x40,0x3F,0xC0,0x20,0x40,0x30,0x00,0x00,0x00},
92{0x20,0x00,0x3F,0x80,0x00,0x40,0x00,0x40,0x3F,0x80,0x20,0x00},
93{0x20,0x00,0x3E,0x00,0x01,0xC0,0x07,0x00,0x38,0x00,0x20,0x00},
94{0x38,0x00,0x07,0xC0,0x3C,0x00,0x07,0xC0,0x38,0x00,0x00,0x00},
95{0x20,0x40,0x39,0xC0,0x06,0x00,0x39,0xC0,0x20,0x40,0x00,0x00},
96{0x20,0x00,0x38,0x40,0x07,0xC0,0x38,0x40,0x20,0x00,0x00,0x00},
97{0x30,0x40,0x21,0xC0,0x26,0x40,0x38,0x40,0x20,0xC0,0x00,0x00},
98{0x00,0x00,0x00,0x00,0x7F,0xE0,0x40,0x20,0x40,0x20,0x00,0x00},
99{0x00,0x00,0x70,0x00,0x0C,0x00,0x03,0x80,0x00,0x40,0x00,0x00},
100{0x00,0x00,0x40,0x20,0x40,0x20,0x7F,0xE0,0x00,0x00,0x00,0x00},
101{0x00,0x00,0x20,0x00,0x40,0x00,0x20,0x00,0x00,0x00,0x00,0x00},
102{0x00,0x10,0x00,0x10,0x00,0x10,0x00,0x10,0x00,0x10,0x00,0x10},
103{0x00,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
104{0x00,0x00,0x02,0x80,0x05,0x40,0x05,0x40,0x03,0xC0,0x00,0x40},
105{0x20,0x00,0x3F,0xC0,0x04,0x40,0x04,0x40,0x03,0x80,0x00,0x00},
106{0x00,0x00,0x03,0x80,0x04,0x40,0x04,0x40,0x06,0x40,0x00,0x00},
107{0x00,0x00,0x03,0x80,0x04,0x40,0x24,0x40,0x3F,0xC0,0x00,0x40},
108{0x00,0x00,0x03,0x80,0x05,0x40,0x05,0x40,0x03,0x40,0x00,0x00},
109{0x00,0x00,0x04,0x40,0x1F,0xC0,0x24,0x40,0x24,0x40,0x20,0x00},
110{0x00,0x00,0x02,0xE0,0x05,0x50,0x05,0x50,0x06,0x50,0x04,0x20},
111{0x20,0x40,0x3F,0xC0,0x04,0x40,0x04,0x00,0x03,0xC0,0x00,0x40},
112{0x00,0x00,0x04,0x40,0x27,0xC0,0x00,0x40,0x00,0x00,0x00,0x00},
113{0x00,0x10,0x00,0x10,0x04,0x10,0x27,0xE0,0x00,0x00,0x00,0x00},
114{0x20,0x40,0x3F,0xC0,0x01,0x40,0x07,0x00,0x04,0xC0,0x04,0x40},
115{0x20,0x40,0x20,0x40,0x3F,0xC0,0x00,0x40,0x00,0x40,0x00,0x00},
116{0x07,0xC0,0x04,0x00,0x07,0xC0,0x04,0x00,0x03,0xC0,0x00,0x00},
117{0x04,0x40,0x07,0xC0,0x04,0x40,0x04,0x00,0x03,0xC0,0x00,0x40},
118{0x00,0x00,0x03,0x80,0x04,0x40,0x04,0x40,0x03,0x80,0x00,0x00},
119{0x04,0x10,0x07,0xF0,0x04,0x50,0x04,0x40,0x03,0x80,0x00,0x00},
120{0x00,0x00,0x03,0x80,0x04,0x40,0x04,0x50,0x07,0xF0,0x00,0x10},
121{0x04,0x40,0x07,0xC0,0x02,0x40,0x04,0x00,0x04,0x00,0x00,0x00},
122{0x00,0x00,0x06,0x40,0x05,0x40,0x05,0x40,0x04,0xC0,0x00,0x00},
123{0x00,0x00,0x04,0x00,0x1F,0x80,0x04,0x40,0x00,0x40,0x00,0x00},
124{0x04,0x00,0x07,0x80,0x00,0x40,0x04,0x40,0x07,0xC0,0x00,0x40},
125{0x04,0x00,0x07,0x00,0x04,0xC0,0x01,0x80,0x06,0x00,0x04,0x00},
126{0x06,0x00,0x01,0xC0,0x07,0x00,0x01,0xC0,0x06,0x00,0x00,0x00},
127{0x04,0x40,0x06,0xC0,0x01,0x00,0x06,0xC0,0x04,0x40,0x00,0x00},
128{0x04,0x10,0x07,0x10,0x04,0xE0,0x01,0x80,0x06,0x00,0x04,0x00},
129{0x00,0x00,0x04,0x40,0x05,0xC0,0x06,0x40,0x04,0x40,0x00,0x00},
130{0x00,0x00,0x00,0x00,0x04,0x00,0x7B,0xE0,0x40,0x20,0x00,0x00},
131{0x00,0x00,0x00,0x00,0x00,0x00,0xFF,0xF0,0x00,0x00,0x00,0x00},
132{0x00,0x00,0x40,0x20,0x7B,0xE0,0x04,0x00,0x00,0x00,0x00,0x00},
133{0x40,0x00,0x80,0x00,0x40,0x00,0x20,0x00,0x20,0x00,0x40,0x00},
134};
135
136const unsigned char asc2_1608[95][16]={
137{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
138{0x00,0x00,0x00,0x00,0x00,0x00,0x1F,0xCC,0x00,0x0C,0x00,0x00,0x00,0x00,0x00,0x00},
139{0x00,0x00,0x08,0x00,0x30,0x00,0x60,0x00,0x08,0x00,0x30,0x00,0x60,0x00,0x00,0x00},
140{0x02,0x20,0x03,0xFC,0x1E,0x20,0x02,0x20,0x03,0xFC,0x1E,0x20,0x02,0x20,0x00,0x00},
141{0x00,0x00,0x0E,0x18,0x11,0x04,0x3F,0xFF,0x10,0x84,0x0C,0x78,0x00,0x00,0x00,0x00},
142{0x0F,0x00,0x10,0x84,0x0F,0x38,0x00,0xC0,0x07,0x78,0x18,0x84,0x00,0x78,0x00,0x00},
143{0x00,0x78,0x0F,0x84,0x10,0xC4,0x11,0x24,0x0E,0x98,0x00,0xE4,0x00,0x84,0x00,0x08},
144{0x08,0x00,0x68,0x00,0x70,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
145{0x00,0x00,0x00,0x00,0x00,0x00,0x07,0xE0,0x18,0x18,0x20,0x04,0x40,0x02,0x00,0x00},
146{0x00,0x00,0x40,0x02,0x20,0x04,0x18,0x18,0x07,0xE0,0x00,0x00,0x00,0x00,0x00,0x00},
147{0x02,0x40,0x02,0x40,0x01,0x80,0x0F,0xF0,0x01,0x80,0x02,0x40,0x02,0x40,0x00,0x00},
148{0x00,0x80,0x00,0x80,0x00,0x80,0x0F,0xF8,0x00,0x80,0x00,0x80,0x00,0x80,0x00,0x00},
149{0x00,0x01,0x00,0x0D,0x00,0x0E,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
150{0x00,0x00,0x00,0x80,0x00,0x80,0x00,0x80,0x00,0x80,0x00,0x80,0x00,0x80,0x00,0x80},
151{0x00,0x00,0x00,0x0C,0x00,0x0C,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
152{0x00,0x00,0x00,0x06,0x00,0x18,0x00,0x60,0x01,0x80,0x06,0x00,0x18,0x00,0x20,0x00},
153{0x00,0x00,0x07,0xF0,0x08,0x08,0x10,0x04,0x10,0x04,0x08,0x08,0x07,0xF0,0x00,0x00},
154{0x00,0x00,0x08,0x04,0x08,0x04,0x1F,0xFC,0x00,0x04,0x00,0x04,0x00,0x00,0x00,0x00},
155{0x00,0x00,0x0E,0x0C,0x10,0x14,0x10,0x24,0x10,0x44,0x11,0x84,0x0E,0x0C,0x00,0x00},
156{0x00,0x00,0x0C,0x18,0x10,0x04,0x11,0x04,0x11,0x04,0x12,0x88,0x0C,0x70,0x00,0x00},
157{0x00,0x00,0x00,0xE0,0x03,0x20,0x04,0x24,0x08,0x24,0x1F,0xFC,0x00,0x24,0x00,0x00},
158{0x00,0x00,0x1F,0x98,0x10,0x84,0x11,0x04,0x11,0x04,0x10,0x88,0x10,0x70,0x00,0x00},
159{0x00,0x00,0x07,0xF0,0x08,0x88,0x11,0x04,0x11,0x04,0x18,0x88,0x00,0x70,0x00,0x00},
160{0x00,0x00,0x1C,0x00,0x10,0x00,0x10,0xFC,0x13,0x00,0x1C,0x00,0x10,0x00,0x00,0x00},
161{0x00,0x00,0x0E,0x38,0x11,0x44,0x10,0x84,0x10,0x84,0x11,0x44,0x0E,0x38,0x00,0x00},
162{0x00,0x00,0x07,0x00,0x08,0x8C,0x10,0x44,0x10,0x44,0x08,0x88,0x07,0xF0,0x00,0x00},
163{0x00,0x00,0x00,0x00,0x00,0x00,0x03,0x0C,0x03,0x0C,0x00,0x00,0x00,0x00,0x00,0x00},
164{0x00,0x00,0x00,0x00,0x00,0x01,0x01,0x06,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
165{0x00,0x00,0x00,0x80,0x01,0x40,0x02,0x20,0x04,0x10,0x08,0x08,0x10,0x04,0x00,0x00},
166{0x02,0x20,0x02,0x20,0x02,0x20,0x02,0x20,0x02,0x20,0x02,0x20,0x02,0x20,0x00,0x00},
167{0x00,0x00,0x10,0x04,0x08,0x08,0x04,0x10,0x02,0x20,0x01,0x40,0x00,0x80,0x00,0x00},
168{0x00,0x00,0x0E,0x00,0x12,0x00,0x10,0x0C,0x10,0x6C,0x10,0x80,0x0F,0x00,0x00,0x00},
169{0x03,0xE0,0x0C,0x18,0x13,0xE4,0x14,0x24,0x17,0xC4,0x08,0x28,0x07,0xD0,0x00,0x00},
170{0x00,0x04,0x00,0x3C,0x03,0xC4,0x1C,0x40,0x07,0x40,0x00,0xE4,0x00,0x1C,0x00,0x04},
171{0x10,0x04,0x1F,0xFC,0x11,0x04,0x11,0x04,0x11,0x04,0x0E,0x88,0x00,0x70,0x00,0x00},
172{0x03,0xE0,0x0C,0x18,0x10,0x04,0x10,0x04,0x10,0x04,0x10,0x08,0x1C,0x10,0x00,0x00},
173{0x10,0x04,0x1F,0xFC,0x10,0x04,0x10,0x04,0x10,0x04,0x08,0x08,0x07,0xF0,0x00,0x00},
174{0x10,0x04,0x1F,0xFC,0x11,0x04,0x11,0x04,0x17,0xC4,0x10,0x04,0x08,0x18,0x00,0x00},
175{0x10,0x04,0x1F,0xFC,0x11,0x04,0x11,0x00,0x17,0xC0,0x10,0x00,0x08,0x00,0x00,0x00},
176{0x03,0xE0,0x0C,0x18,0x10,0x04,0x10,0x04,0x10,0x44,0x1C,0x78,0x00,0x40,0x00,0x00},
177{0x10,0x04,0x1F,0xFC,0x10,0x84,0x00,0x80,0x00,0x80,0x10,0x84,0x1F,0xFC,0x10,0x04},
178{0x00,0x00,0x10,0x04,0x10,0x04,0x1F,0xFC,0x10,0x04,0x10,0x04,0x00,0x00,0x00,0x00},
179{0x00,0x03,0x00,0x01,0x10,0x01,0x10,0x01,0x1F,0xFE,0x10,0x00,0x10,0x00,0x00,0x00},
180{0x10,0x04,0x1F,0xFC,0x11,0x04,0x03,0x80,0x14,0x64,0x18,0x1C,0x10,0x04,0x00,0x00},
181{0x10,0x04,0x1F,0xFC,0x10,0x04,0x00,0x04,0x00,0x04,0x00,0x04,0x00,0x0C,0x00,0x00},
182{0x10,0x04,0x1F,0xFC,0x1F,0x00,0x00,0xFC,0x1F,0x00,0x1F,0xFC,0x10,0x04,0x00,0x00},
183{0x10,0x04,0x1F,0xFC,0x0C,0x04,0x03,0x00,0x00,0xE0,0x10,0x18,0x1F,0xFC,0x10,0x00},
184{0x07,0xF0,0x08,0x08,0x10,0x04,0x10,0x04,0x10,0x04,0x08,0x08,0x07,0xF0,0x00,0x00},
185{0x10,0x04,0x1F,0xFC,0x10,0x84,0x10,0x80,0x10,0x80,0x10,0x80,0x0F,0x00,0x00,0x00},
186{0x07,0xF0,0x08,0x18,0x10,0x24,0x10,0x24,0x10,0x1C,0x08,0x0A,0x07,0xF2,0x00,0x00},
187{0x10,0x04,0x1F,0xFC,0x11,0x04,0x11,0x00,0x11,0xC0,0x11,0x30,0x0E,0x0C,0x00,0x04},
188{0x00,0x00,0x0E,0x1C,0x11,0x04,0x10,0x84,0x10,0x84,0x10,0x44,0x1C,0x38,0x00,0x00},
189{0x18,0x00,0x10,0x00,0x10,0x04,0x1F,0xFC,0x10,0x04,0x10,0x00,0x18,0x00,0x00,0x00},
190{0x10,0x00,0x1F,0xF8,0x10,0x04,0x00,0x04,0x00,0x04,0x10,0x04,0x1F,0xF8,0x10,0x00},
191{0x10,0x00,0x1E,0x00,0x11,0xE0,0x00,0x1C,0x00,0x70,0x13,0x80,0x1C,0x00,0x10,0x00},
192{0x1F,0xC0,0x10,0x3C,0x00,0xE0,0x1F,0x00,0x00,0xE0,0x10,0x3C,0x1F,0xC0,0x00,0x00},
193{0x10,0x04,0x18,0x0C,0x16,0x34,0x01,0xC0,0x01,0xC0,0x16,0x34,0x18,0x0C,0x10,0x04},
194{0x10,0x00,0x1C,0x00,0x13,0x04,0x00,0xFC,0x13,0x04,0x1C,0x00,0x10,0x00,0x00,0x00},
195{0x08,0x04,0x10,0x1C,0x10,0x64,0x10,0x84,0x13,0x04,0x1C,0x04,0x10,0x18,0x00,0x00},
196{0x00,0x00,0x00,0x00,0x00,0x00,0x7F,0xFE,0x40,0x02,0x40,0x02,0x40,0x02,0x00,0x00},
197{0x00,0x00,0x30,0x00,0x0C,0x00,0x03,0x80,0x00,0x60,0x00,0x1C,0x00,0x03,0x00,0x00},
198{0x00,0x00,0x40,0x02,0x40,0x02,0x40,0x02,0x7F,0xFE,0x00,0x00,0x00,0x00,0x00,0x00},
199{0x00,0x00,0x00,0x00,0x20,0x00,0x40,0x00,0x40,0x00,0x40,0x00,0x20,0x00,0x00,0x00},
200{0x00,0x01,0x00,0x01,0x00,0x01,0x00,0x01,0x00,0x01,0x00,0x01,0x00,0x01,0x00,0x01},
201{0x00,0x00,0x40,0x00,0x40,0x00,0x20,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
202{0x00,0x00,0x00,0x98,0x01,0x24,0x01,0x44,0x01,0x44,0x01,0x44,0x00,0xFC,0x00,0x04},
203{0x10,0x00,0x1F,0xFC,0x00,0x88,0x01,0x04,0x01,0x04,0x00,0x88,0x00,0x70,0x00,0x00},
204{0x00,0x00,0x00,0x70,0x00,0x88,0x01,0x04,0x01,0x04,0x01,0x04,0x00,0x88,0x00,0x00},
205{0x00,0x00,0x00,0x70,0x00,0x88,0x01,0x04,0x01,0x04,0x11,0x08,0x1F,0xFC,0x00,0x04},
206{0x00,0x00,0x00,0xF8,0x01,0x44,0x01,0x44,0x01,0x44,0x01,0x44,0x00,0xC8,0x00,0x00},
207{0x00,0x00,0x01,0x04,0x01,0x04,0x0F,0xFC,0x11,0x04,0x11,0x04,0x11,0x00,0x18,0x00},
208{0x00,0x00,0x00,0xD6,0x01,0x29,0x01,0x29,0x01,0x29,0x01,0xC9,0x01,0x06,0x00,0x00},
209{0x10,0x04,0x1F,0xFC,0x00,0x84,0x01,0x00,0x01,0x00,0x01,0x04,0x00,0xFC,0x00,0x04},
210{0x00,0x00,0x01,0x04,0x19,0x04,0x19,0xFC,0x00,0x04,0x00,0x04,0x00,0x00,0x00,0x00},
211{0x00,0x00,0x00,0x03,0x00,0x01,0x01,0x01,0x19,0x01,0x19,0xFE,0x00,0x00,0x00,0x00},
212{0x10,0x04,0x1F,0xFC,0x00,0x24,0x00,0x40,0x01,0xB4,0x01,0x0C,0x01,0x04,0x00,0x00},
213{0x00,0x00,0x10,0x04,0x10,0x04,0x1F,0xFC,0x00,0x04,0x00,0x04,0x00,0x00,0x00,0x00},
214{0x01,0x04,0x01,0xFC,0x01,0x04,0x01,0x00,0x01,0xFC,0x01,0x04,0x01,0x00,0x00,0xFC},
215{0x01,0x04,0x01,0xFC,0x00,0x84,0x01,0x00,0x01,0x00,0x01,0x04,0x00,0xFC,0x00,0x04},
216{0x00,0x00,0x00,0xF8,0x01,0x04,0x01,0x04,0x01,0x04,0x01,0x04,0x00,0xF8,0x00,0x00},
217{0x01,0x01,0x01,0xFF,0x00,0x85,0x01,0x04,0x01,0x04,0x00,0x88,0x00,0x70,0x00,0x00},
218{0x00,0x00,0x00,0x70,0x00,0x88,0x01,0x04,0x01,0x04,0x01,0x05,0x01,0xFF,0x00,0x01},
219{0x01,0x04,0x01,0x04,0x01,0xFC,0x00,0x84,0x01,0x04,0x01,0x00,0x01,0x80,0x00,0x00},
220{0x00,0x00,0x00,0xCC,0x01,0x24,0x01,0x24,0x01,0x24,0x01,0x24,0x01,0x98,0x00,0x00},
221{0x00,0x00,0x01,0x00,0x01,0x00,0x07,0xF8,0x01,0x04,0x01,0x04,0x00,0x00,0x00,0x00},
222{0x01,0x00,0x01,0xF8,0x00,0x04,0x00,0x04,0x00,0x04,0x01,0x08,0x01,0xFC,0x00,0x04},
223{0x01,0x00,0x01,0x80,0x01,0x70,0x00,0x0C,0x00,0x10,0x01,0x60,0x01,0x80,0x01,0x00},
224{0x01,0xF0,0x01,0x0C,0x00,0x30,0x01,0xC0,0x00,0x30,0x01,0x0C,0x01,0xF0,0x01,0x00},
225{0x00,0x00,0x01,0x04,0x01,0x8C,0x00,0x74,0x01,0x70,0x01,0x8C,0x01,0x04,0x00,0x00},
226{0x01,0x01,0x01,0x81,0x01,0x71,0x00,0x0E,0x00,0x18,0x01,0x60,0x01,0x80,0x01,0x00},
227{0x00,0x00,0x01,0x84,0x01,0x0C,0x01,0x34,0x01,0x44,0x01,0x84,0x01,0x0C,0x00,0x00},
228{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x01,0x00,0x3E,0xFC,0x40,0x02,0x40,0x02},
229{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0xFF,0xFF,0x00,0x00,0x00,0x00,0x00,0x00},
230{0x00,0x00,0x40,0x02,0x40,0x02,0x3E,0xFC,0x01,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
231{0x00,0x00,0x60,0x00,0x80,0x00,0x80,0x00,0x40,0x00,0x40,0x00,0x20,0x00,0x20,0x00},
232};
233
234const unsigned char asc2_2412[95][36]={
235{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
236{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x0F,0x80,0x38,0x0F,0xFE,0x38,0x0F,0x80,0x38,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
237{0x00,0x00,0x00,0x00,0x00,0x00,0x01,0x00,0x00,0x06,0x00,0x00,0x0C,0x00,0x00,0x38,0x00,0x00,0x31,0x00,0x00,0x06,0x00,0x00,0x0C,0x00,0x00,0x38,0x00,0x00,0x30,0x00,0x00,0x00,0x00,0x00},
238{0x00,0x00,0x00,0x00,0x61,0x80,0x00,0x67,0xF8,0x07,0xF9,0x80,0x00,0x61,0x80,0x00,0x61,0x80,0x00,0x61,0x80,0x00,0x61,0x80,0x00,0x67,0xF8,0x07,0xF9,0x80,0x00,0x61,0x80,0x00,0x00,0x00},
239{0x00,0x00,0x00,0x00,0x00,0x00,0x01,0xC0,0xE0,0x03,0xE0,0xF0,0x06,0x30,0x08,0x04,0x18,0x08,0x1F,0xFF,0xFE,0x04,0x0E,0x08,0x07,0x87,0xF0,0x03,0x81,0xE0,0x00,0x00,0x00,0x00,0x00,0x00},
240{0x01,0xF0,0x00,0x06,0x0C,0x00,0x04,0x04,0x08,0x06,0x0C,0x70,0x01,0xF9,0xC0,0x00,0x0E,0x00,0x00,0x3B,0xE0,0x00,0xEC,0x18,0x07,0x08,0x08,0x04,0x0C,0x18,0x00,0x03,0xE0,0x00,0x00,0x00},
241{0x00,0x01,0xE0,0x00,0x07,0xF0,0x03,0xF8,0x18,0x04,0x1C,0x08,0x04,0x17,0x08,0x07,0xE1,0xD0,0x03,0xC0,0xE0,0x00,0x23,0xB0,0x00,0x3C,0x08,0x00,0x20,0x08,0x00,0x00,0x10,0x00,0x00,0x00},
242{0x00,0x00,0x00,0x01,0x00,0x00,0x31,0x00,0x00,0x32,0x00,0x00,0x1C,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
243{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7F,0x00,0x01,0xFF,0xC0,0x07,0x80,0xF0,0x0C,0x00,0x18,0x10,0x00,0x04,0x20,0x00,0x02,0x00,0x00,0x00},
244{0x00,0x00,0x00,0x20,0x00,0x02,0x10,0x00,0x04,0x0C,0x00,0x18,0x07,0x80,0xF0,0x01,0xFF,0xC0,0x00,0x7F,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
245{0x00,0x00,0x00,0x00,0x42,0x00,0x00,0x66,0x00,0x00,0x66,0x00,0x00,0x3C,0x00,0x00,0x18,0x00,0x03,0xFF,0xC0,0x00,0x18,0x00,0x00,0x3C,0x00,0x00,0x66,0x00,0x00,0x66,0x00,0x00,0x42,0x00},
246{0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x01,0xFF,0xC0,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00},
247{0x00,0x00,0x00,0x00,0x00,0x01,0x00,0x00,0x31,0x00,0x00,0x32,0x00,0x00,0x1C,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
248{0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x00,0x00},
249{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x38,0x00,0x00,0x38,0x00,0x00,0x38,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
250{0x00,0x00,0x00,0x00,0x00,0x06,0x00,0x00,0x1C,0x00,0x00,0x70,0x00,0x01,0x80,0x00,0x0E,0x00,0x00,0x38,0x00,0x00,0xC0,0x00,0x07,0x00,0x00,0x1C,0x00,0x00,0x30,0x00,0x00,0x00,0x00,0x00},
251{0x00,0x00,0x00,0x00,0x7F,0x80,0x01,0xFF,0xE0,0x03,0x80,0x70,0x06,0x00,0x18,0x04,0x00,0x08,0x04,0x00,0x08,0x06,0x00,0x18,0x03,0x80,0x70,0x01,0xFF,0xE0,0x00,0x7F,0x80,0x00,0x00,0x00},
252{0x00,0x00,0x00,0x00,0x00,0x00,0x01,0x00,0x08,0x01,0x00,0x08,0x01,0x00,0x08,0x03,0xFF,0xF8,0x07,0xFF,0xF8,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x00,0x00,0x00,0x00},
253{0x00,0x00,0x00,0x01,0xC0,0x38,0x02,0xC0,0x58,0x04,0x00,0x98,0x04,0x01,0x18,0x04,0x02,0x18,0x04,0x04,0x18,0x06,0x1C,0x18,0x03,0xF8,0x18,0x01,0xE0,0xF8,0x00,0x00,0x00,0x00,0x00,0x00},
254{0x00,0x00,0x00,0x01,0xC0,0xE0,0x03,0xC0,0xF0,0x04,0x00,0x08,0x04,0x08,0x08,0x04,0x08,0x08,0x06,0x18,0x08,0x03,0xF4,0x18,0x01,0xE7,0xF0,0x00,0x01,0xE0,0x00,0x00,0x00,0x00,0x00,0x00},
255{0x00,0x00,0x00,0x00,0x03,0x00,0x00,0x0D,0x00,0x00,0x11,0x00,0x00,0x61,0x00,0x00,0x81,0x08,0x03,0x01,0x08,0x07,0xFF,0xF8,0x0F,0xFF,0xF8,0x00,0x01,0x08,0x00,0x01,0x08,0x00,0x00,0x00},
256{0x00,0x00,0x00,0x00,0x00,0xE0,0x07,0xFC,0xD0,0x06,0x08,0x08,0x06,0x10,0x08,0x06,0x10,0x08,0x06,0x10,0x08,0x06,0x18,0x38,0x06,0x0F,0xF0,0x06,0x07,0xC0,0x00,0x00,0x00,0x00,0x00,0x00},
257{0x00,0x00,0x00,0x00,0x3F,0x80,0x01,0xFF,0xE0,0x03,0x84,0x30,0x02,0x08,0x18,0x04,0x10,0x08,0x04,0x10,0x08,0x04,0x10,0x08,0x07,0x18,0x10,0x03,0x0F,0xF0,0x00,0x07,0xC0,0x00,0x00,0x00},
258{0x00,0x00,0x00,0x00,0x00,0x00,0x03,0xC0,0x00,0x07,0x00,0x00,0x06,0x00,0x00,0x06,0x00,0xF8,0x06,0x07,0xF8,0x06,0x18,0x00,0x06,0xE0,0x00,0x07,0x00,0x00,0x06,0x00,0x00,0x00,0x00,0x00},
259{0x00,0x00,0x00,0x01,0xE1,0xE0,0x03,0xF7,0xF0,0x06,0x34,0x10,0x04,0x18,0x08,0x04,0x18,0x08,0x04,0x0C,0x08,0x04,0x0C,0x08,0x06,0x16,0x18,0x03,0xF3,0xF0,0x01,0xC1,0xE0,0x00,0x00,0x00},
260{0x00,0x00,0x00,0x00,0xF8,0x00,0x03,0xFC,0x30,0x03,0x06,0x38,0x04,0x02,0x08,0x04,0x02,0x08,0x04,0x02,0x08,0x04,0x04,0x10,0x03,0x08,0xF0,0x01,0xFF,0xC0,0x00,0x7F,0x00,0x00,0x00,0x00},
261{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x70,0x38,0x00,0x70,0x38,0x00,0x70,0x38,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
262{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x30,0x1A,0x00,0x30,0x1C,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
263{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x14,0x00,0x00,0x22,0x00,0x00,0x41,0x00,0x00,0x80,0x80,0x01,0x00,0x40,0x02,0x00,0x20,0x04,0x00,0x10,0x08,0x00,0x08,0x00,0x00,0x00},
264{0x00,0x00,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x00,0x00},
265{0x00,0x00,0x00,0x00,0x00,0x00,0x08,0x00,0x08,0x04,0x00,0x10,0x02,0x00,0x20,0x01,0x00,0x40,0x00,0x80,0x80,0x00,0x41,0x00,0x00,0x22,0x00,0x00,0x14,0x00,0x00,0x08,0x00,0x00,0x00,0x00},
266{0x00,0x00,0x00,0x03,0xC0,0x00,0x04,0xC0,0x00,0x04,0x00,0x00,0x08,0x00,0x38,0x08,0x0F,0x38,0x08,0x08,0x38,0x08,0x10,0x00,0x0C,0x30,0x00,0x07,0xE0,0x00,0x03,0xC0,0x00,0x00,0x00,0x00},
267{0x00,0x00,0x00,0x00,0x3F,0x80,0x00,0xFF,0xE0,0x03,0x80,0x70,0x02,0x0F,0x10,0x06,0x70,0x88,0x04,0xC0,0x88,0x04,0x83,0x08,0x04,0x7F,0x88,0x02,0xC0,0x90,0x03,0x01,0x20,0x00,0xFE,0x40},
268{0x00,0x00,0x08,0x00,0x00,0x18,0x00,0x01,0xF8,0x00,0x3E,0x08,0x01,0xC2,0x00,0x07,0x02,0x00,0x07,0xE2,0x00,0x00,0xFE,0x00,0x00,0x1F,0xC8,0x00,0x01,0xF8,0x00,0x00,0x38,0x00,0x00,0x08},
269{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x08,0x08,0x04,0x08,0x08,0x04,0x08,0x08,0x04,0x08,0x08,0x06,0x18,0x08,0x03,0xF4,0x18,0x01,0xE7,0xF0,0x00,0x01,0xE0,0x00,0x00,0x00},
270{0x00,0x00,0x00,0x00,0x3F,0x80,0x01,0xFF,0xE0,0x03,0x80,0x70,0x02,0x00,0x18,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x10,0x06,0x00,0x20,0x07,0x80,0xC0,0x00,0x00,0x00},
271{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x18,0x02,0x00,0x10,0x03,0x80,0x70,0x01,0xFF,0xE0,0x00,0x7F,0x80,0x00,0x00,0x00},
272{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x08,0x08,0x04,0x08,0x08,0x04,0x08,0x08,0x04,0x08,0x08,0x04,0x3E,0x08,0x04,0x00,0x08,0x06,0x00,0x18,0x01,0x00,0x60,0x00,0x00,0x00},
273{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x08,0x08,0x04,0x08,0x00,0x04,0x08,0x00,0x04,0x08,0x00,0x04,0x3E,0x00,0x06,0x00,0x00,0x06,0x00,0x00,0x01,0x80,0x00,0x00,0x00,0x00},
274{0x00,0x00,0x00,0x00,0x3F,0x80,0x01,0xFF,0xE0,0x03,0x80,0x70,0x06,0x00,0x18,0x04,0x00,0x08,0x04,0x02,0x08,0x04,0x02,0x08,0x02,0x03,0xF0,0x07,0x83,0xF0,0x00,0x02,0x00,0x00,0x02,0x00},
275{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x08,0x08,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x04,0x08,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x00,0x08},
276{0x00,0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x08,0x00,0x00,0x00,0x00,0x00,0x00},
277{0x00,0x00,0x00,0x00,0x00,0x06,0x00,0x00,0x07,0x00,0x00,0x01,0x04,0x00,0x01,0x04,0x00,0x01,0x04,0x00,0x03,0x07,0xFF,0xFE,0x07,0xFF,0xFC,0x04,0x00,0x00,0x04,0x00,0x00,0x04,0x00,0x00},
278{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x0C,0x08,0x00,0x18,0x00,0x00,0x3E,0x00,0x04,0xC7,0x80,0x05,0x03,0xC8,0x06,0x00,0xF8,0x04,0x00,0x38,0x04,0x00,0x18,0x00,0x00,0x08},
279{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x18,0x00,0x00,0x60,0x00,0x00,0x00},
280{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0x80,0x08,0x07,0xFC,0x00,0x00,0x7F,0xC0,0x00,0x03,0xF8,0x00,0x07,0xC0,0x00,0x78,0x00,0x07,0x80,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x00,0x08},
281{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0x00,0x08,0x03,0xC0,0x00,0x00,0xE0,0x00,0x00,0x38,0x00,0x00,0x1E,0x00,0x00,0x07,0x00,0x00,0x01,0xC0,0x04,0x00,0xF0,0x07,0xFF,0xF8,0x04,0x00,0x00},
282{0x00,0x00,0x00,0x00,0x7F,0x80,0x01,0xFF,0xE0,0x03,0x80,0x70,0x06,0x00,0x18,0x04,0x00,0x08,0x04,0x00,0x08,0x06,0x00,0x18,0x03,0x00,0x30,0x01,0xFF,0xE0,0x00,0x7F,0x80,0x00,0x00,0x00},
283{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x04,0x08,0x04,0x04,0x00,0x04,0x04,0x00,0x04,0x04,0x00,0x04,0x04,0x00,0x06,0x0C,0x00,0x03,0xF8,0x00,0x01,0xF0,0x00,0x00,0x00,0x00},
284{0x00,0x00,0x00,0x00,0x7F,0x80,0x01,0xFF,0xE0,0x03,0x80,0x70,0x06,0x00,0x88,0x04,0x00,0x88,0x04,0x00,0xC8,0x06,0x00,0x3C,0x03,0x00,0x3E,0x01,0xFF,0xE6,0x00,0x7F,0x84,0x00,0x00,0x00},
285{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x08,0x08,0x04,0x08,0x00,0x04,0x0C,0x00,0x04,0x0F,0x00,0x04,0x0B,0xC0,0x06,0x10,0xF0,0x03,0xF0,0x38,0x01,0xE0,0x08,0x00,0x00,0x08},
286{0x00,0x00,0x00,0x01,0xE0,0xF8,0x03,0xF0,0x30,0x06,0x30,0x10,0x04,0x18,0x08,0x04,0x18,0x08,0x04,0x0C,0x08,0x04,0x0C,0x08,0x02,0x06,0x18,0x02,0x07,0xF0,0x07,0x81,0xE0,0x00,0x00,0x00},
287{0x01,0x80,0x00,0x06,0x00,0x00,0x04,0x00,0x00,0x04,0x00,0x00,0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x00,0x08,0x04,0x00,0x00,0x04,0x00,0x00,0x06,0x00,0x00,0x01,0x80,0x00},
288{0x04,0x00,0x00,0x07,0xFF,0xE0,0x07,0xFF,0xF0,0x04,0x00,0x18,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x04,0x00,0x10,0x07,0xFF,0xE0,0x04,0x00,0x00},
289{0x04,0x00,0x00,0x06,0x00,0x00,0x07,0xE0,0x00,0x07,0xFE,0x00,0x04,0x1F,0xE0,0x00,0x01,0xF8,0x00,0x00,0x38,0x00,0x01,0xE0,0x04,0x3E,0x00,0x07,0xC0,0x00,0x06,0x00,0x00,0x04,0x00,0x00},
290{0x04,0x00,0x00,0x07,0xE0,0x00,0x07,0xFF,0xC0,0x04,0x1F,0xF8,0x00,0x07,0xC0,0x07,0xF8,0x00,0x07,0xFF,0x80,0x04,0x3F,0xF8,0x00,0x07,0xC0,0x04,0xF8,0x00,0x07,0x00,0x00,0x04,0x00,0x00},
291{0x00,0x00,0x00,0x04,0x00,0x08,0x06,0x00,0x18,0x07,0xC0,0x78,0x05,0xF1,0xC8,0x00,0x3E,0x00,0x00,0x1F,0x80,0x04,0x63,0xE8,0x07,0x80,0xF8,0x06,0x00,0x18,0x04,0x00,0x08,0x00,0x00,0x00},
292{0x04,0x00,0x00,0x06,0x00,0x00,0x07,0x80,0x00,0x07,0xE0,0x08,0x04,0x7C,0x08,0x00,0x1F,0xF8,0x00,0x07,0xF8,0x00,0x18,0x08,0x04,0xE0,0x08,0x07,0x00,0x00,0x06,0x00,0x00,0x04,0x00,0x00},
293{0x00,0x00,0x00,0x01,0x00,0x08,0x06,0x00,0x38,0x04,0x00,0xF8,0x04,0x03,0xE8,0x04,0x0F,0x08,0x04,0x7C,0x08,0x05,0xF0,0x08,0x07,0xC0,0x08,0x07,0x00,0x18,0x04,0x00,0x60,0x00,0x00,0x00},
294{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x3F,0xFF,0xFE,0x20,0x00,0x02,0x20,0x00,0x02,0x20,0x00,0x02,0x20,0x00,0x02,0x20,0x00,0x02,0x00,0x00,0x00},
295{0x00,0x00,0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x07,0x00,0x00,0x00,0xC0,0x00,0x00,0x38,0x00,0x00,0x06,0x00,0x00,0x01,0xC0,0x00,0x00,0x30,0x00,0x00,0x0E,0x00,0x00,0x01,0x00,0x00,0x00},
296{0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x02,0x20,0x00,0x02,0x20,0x00,0x02,0x20,0x00,0x02,0x20,0x00,0x02,0x3F,0xFF,0xFE,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
297{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x10,0x00,0x00,0x30,0x00,0x00,0x20,0x00,0x00,0x30,0x00,0x00,0x10,0x00,0x00,0x08,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
298{0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01},
299{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x20,0x00,0x00,0x10,0x00,0x00,0x10,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
300{0x00,0x00,0x00,0x00,0x00,0xF0,0x00,0x19,0xF8,0x00,0x1B,0x18,0x00,0x22,0x08,0x00,0x26,0x08,0x00,0x24,0x08,0x00,0x24,0x10,0x00,0x3F,0xF8,0x00,0x1F,0xF8,0x00,0x00,0x08,0x00,0x00,0x18},
301{0x00,0x00,0x00,0x04,0x00,0x00,0x07,0xFF,0xF8,0x0F,0xFF,0xF0,0x00,0x18,0x18,0x00,0x10,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x30,0x18,0x00,0x1F,0xF0,0x00,0x0F,0xC0,0x00,0x00,0x00},
302{0x00,0x00,0x00,0x00,0x07,0xC0,0x00,0x1F,0xF0,0x00,0x18,0x30,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x3C,0x08,0x00,0x1C,0x10,0x00,0x00,0x60,0x00,0x00,0x00,0x00,0x00,0x00},
303{0x00,0x00,0x00,0x00,0x07,0xC0,0x00,0x1F,0xF0,0x00,0x38,0x18,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x04,0x10,0x10,0x07,0xFF,0xF8,0x0F,0xFF,0xF0,0x00,0x00,0x10,0x00,0x00,0x00},
304{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0xC0,0x00,0x1F,0xF0,0x00,0x12,0x30,0x00,0x22,0x18,0x00,0x22,0x08,0x00,0x22,0x08,0x00,0x32,0x08,0x00,0x1E,0x10,0x00,0x0E,0x20,0x00,0x00,0x00},
305{0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x20,0x08,0x00,0x20,0x08,0x01,0xFF,0xF8,0x03,0xFF,0xF8,0x06,0x20,0x08,0x04,0x20,0x08,0x04,0x20,0x08,0x07,0x20,0x00,0x03,0x00,0x00,0x00,0x00,0x00},
306{0x00,0x00,0x00,0x00,0x00,0x0E,0x00,0x0E,0x6E,0x00,0x1F,0xF3,0x00,0x31,0xB1,0x00,0x20,0xB1,0x00,0x20,0xB1,0x00,0x31,0x91,0x00,0x1F,0x13,0x00,0x2E,0x1E,0x00,0x20,0x0E,0x00,0x30,0x00},
307{0x00,0x00,0x00,0x04,0x00,0x08,0x07,0xFF,0xF8,0x0F,0xFF,0xF8,0x00,0x10,0x08,0x00,0x20,0x00,0x00,0x20,0x00,0x00,0x20,0x08,0x00,0x3F,0xF8,0x00,0x1F,0xF8,0x00,0x00,0x08,0x00,0x00,0x00},
308{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x06,0x3F,0xF8,0x06,0x3F,0xF8,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x00,0x00,0x00,0x00},
309{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x03,0x00,0x00,0x03,0x00,0x20,0x01,0x00,0x20,0x01,0x00,0x20,0x03,0x06,0x3F,0xFE,0x06,0x3F,0xFC,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
310{0x00,0x00,0x00,0x04,0x00,0x08,0x07,0xFF,0xF8,0x0F,0xFF,0xF8,0x00,0x01,0x88,0x00,0x03,0x00,0x00,0x2F,0xC0,0x00,0x38,0xF8,0x00,0x20,0x38,0x00,0x20,0x08,0x00,0x00,0x08,0x00,0x00,0x00},
311{0x00,0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x08,0x07,0xFF,0xF8,0x0F,0xFF,0xF8,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x00,0x00,0x00,0x00},
312{0x00,0x20,0x08,0x00,0x3F,0xF8,0x00,0x3F,0xF8,0x00,0x10,0x08,0x00,0x20,0x00,0x00,0x3F,0xF8,0x00,0x3F,0xF8,0x00,0x10,0x08,0x00,0x20,0x00,0x00,0x3F,0xF8,0x00,0x3F,0xF8,0x00,0x00,0x08},
313{0x00,0x00,0x00,0x00,0x20,0x08,0x00,0x3F,0xF8,0x00,0x3F,0xF8,0x00,0x10,0x08,0x00,0x10,0x00,0x00,0x20,0x00,0x00,0x20,0x08,0x00,0x3F,0xF8,0x00,0x1F,0xF8,0x00,0x00,0x08,0x00,0x00,0x00},
314{0x00,0x00,0x00,0x00,0x07,0xC0,0x00,0x0F,0xF0,0x00,0x18,0x30,0x00,0x30,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x30,0x08,0x00,0x18,0x30,0x00,0x0F,0xF0,0x00,0x07,0xC0,0x00,0x00,0x00},
315{0x00,0x00,0x00,0x00,0x20,0x01,0x00,0x3F,0xFF,0x00,0x3F,0xFF,0x00,0x10,0x11,0x00,0x20,0x09,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x30,0x38,0x00,0x1F,0xF0,0x00,0x0F,0xC0,0x00,0x00,0x00},
316{0x00,0x00,0x00,0x00,0x07,0xC0,0x00,0x1F,0xF0,0x00,0x38,0x18,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x20,0x09,0x00,0x10,0x11,0x00,0x1F,0xFF,0x00,0x3F,0xFF,0x00,0x00,0x01,0x00,0x00,0x00},
317{0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x3F,0xF8,0x00,0x3F,0xF8,0x00,0x08,0x08,0x00,0x10,0x08,0x00,0x20,0x08,0x00,0x20,0x00,0x00,0x30,0x00,0x00,0x30,0x00,0x00,0x00,0x00},
318{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x0C,0x78,0x00,0x1E,0x18,0x00,0x33,0x08,0x00,0x23,0x08,0x00,0x21,0x08,0x00,0x21,0x88,0x00,0x21,0x98,0x00,0x30,0xF0,0x00,0x38,0x60,0x00,0x00,0x00},
319{0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x20,0x00,0x00,0x20,0x00,0x00,0xFF,0xF0,0x03,0xFF,0xF8,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x00,0x30,0x00,0x00,0x00,0x00,0x00,0x00},
320{0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x3F,0xF0,0x00,0x7F,0xF8,0x00,0x00,0x18,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x20,0x10,0x00,0x3F,0xF8,0x00,0x7F,0xF0,0x00,0x00,0x10,0x00,0x00,0x00},
321{0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x30,0x00,0x00,0x3C,0x00,0x00,0x3F,0x80,0x00,0x23,0xF0,0x00,0x00,0x78,0x00,0x00,0x70,0x00,0x23,0x80,0x00,0x3C,0x00,0x00,0x30,0x00,0x00,0x20,0x00},
322{0x00,0x20,0x00,0x00,0x3C,0x00,0x00,0x3F,0xE0,0x00,0x23,0xF8,0x00,0x00,0xE0,0x00,0x27,0x00,0x00,0x3E,0x00,0x00,0x3F,0xE0,0x00,0x21,0xF8,0x00,0x01,0xE0,0x00,0x3E,0x00,0x00,0x20,0x00},
323{0x00,0x00,0x00,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x38,0x38,0x00,0x3E,0x68,0x00,0x27,0x80,0x00,0x03,0xC8,0x00,0x2C,0xF8,0x00,0x38,0x38,0x00,0x20,0x18,0x00,0x20,0x08,0x00,0x00,0x00},
324{0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x30,0x03,0x00,0x3C,0x01,0x00,0x3F,0x83,0x00,0x23,0xEC,0x00,0x00,0x70,0x00,0x23,0x80,0x00,0x3C,0x00,0x00,0x20,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
325{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x38,0x08,0x00,0x20,0x38,0x00,0x20,0xF8,0x00,0x23,0xE8,0x00,0x2F,0x88,0x00,0x3E,0x08,0x00,0x38,0x08,0x00,0x20,0x18,0x00,0x00,0x70,0x00,0x00,0x00},
326{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x14,0x00,0x1F,0xF7,0xFC,0x30,0x00,0x06,0x20,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00},
327{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0xFF,0xFF,0xFF,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
328{0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x02,0x30,0x00,0x06,0x1F,0xF7,0xFC,0x00,0x14,0x00,0x00,0x08,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
329{0x00,0x00,0x00,0x18,0x00,0x00,0x60,0x00,0x00,0x40,0x00,0x00,0x40,0x00,0x00,0x20,0x00,0x00,0x10,0x00,0x00,0x08,0x00,0x00,0x04,0x00,0x00,0x04,0x00,0x00,0x0C,0x00,0x00,0x10,0x00,0x00},
330};
331
332const unsigned char asc2_3216[95][128]={
333{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
334{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0xF0,0x00,0xC0,0x07,0xFF,0xE1,0xE0,0x07,0xF0,0x01,0xE0,0x00,0x00,0x00,0xC0,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
335{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x01,0xC0,0x00,0x00,0x07,0x80,0x00,0x00,0x1F,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0x1C,0x20,0x00,0x00,0x01,0xC0,0x00,0x00,0x07,0x80,0x00,0x00,0x1F,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0x1C,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
336{0x00,0x00,0x00,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0F,0xE0,0x00,0x1F,0xFC,0x00,0x03,0xF8,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0F,0xE0,0x00,0x1F,0xFC,0x00,0x03,0xF8,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x00,0x00,0x00},
337{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0x80,0x00,0x78,0x07,0xC0,0x00,0xFC,0x06,0x40,0x01,0x0E,0x00,0x20,0x03,0x07,0x00,0x20,0x02,0x03,0x80,0x20,0x0F,0xFF,0xFF,0xFC,0x02,0x01,0xC0,0x20,0x02,0x00,0xE0,0x60,0x01,0x30,0x70,0x40,0x01,0xF0,0x3F,0x80,0x00,0xF0,0x1F,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
338{0x00,0xFE,0x00,0x00,0x01,0xFF,0x00,0x00,0x03,0x01,0x80,0x00,0x02,0x00,0x80,0x60,0x03,0x01,0x81,0xC0,0x01,0xFF,0x07,0x00,0x00,0xFE,0x18,0x00,0x00,0x00,0xE0,0x00,0x00,0x03,0xBF,0x00,0x00,0x0C,0xFF,0xC0,0x00,0x71,0x80,0x60,0x01,0xC1,0x00,0x20,0x03,0x01,0x80,0x60,0x00,0x00,0xFF,0xC0,0x00,0x00,0x3F,0x00,0x00,0x00,0x00,0x00},
339{0x00,0x00,0x1F,0x00,0x00,0x00,0x7F,0xC0,0x00,0xFC,0xC0,0xC0,0x01,0xFF,0x80,0x60,0x03,0x03,0xE0,0x20,0x02,0x02,0x78,0x20,0x02,0x06,0x1E,0x20,0x03,0xFC,0x07,0x40,0x01,0xF0,0x03,0x80,0x00,0x01,0x03,0xC0,0x00,0x01,0x1C,0x60,0x00,0x01,0xE0,0x20,0x00,0x01,0x00,0x20,0x00,0x01,0x00,0x40,0x00,0x00,0x01,0x80,0x00,0x00,0x00,0x00},
340{0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x1C,0x60,0x00,0x00,0x1C,0x40,0x00,0x00,0x1F,0x80,0x00,0x00,0x0F,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
341{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0xF8,0x00,0x00,0x3F,0xFF,0x00,0x00,0x78,0x07,0xC0,0x01,0xC0,0x00,0xE0,0x03,0x00,0x00,0x30,0x04,0x00,0x00,0x08,0x08,0x00,0x00,0x04,0x10,0x00,0x00,0x02,0x00,0x00,0x00,0x00},
342{0x00,0x00,0x00,0x00,0x10,0x00,0x00,0x02,0x08,0x00,0x00,0x04,0x04,0x00,0x00,0x08,0x03,0x00,0x00,0x30,0x01,0xC0,0x00,0xE0,0x00,0x78,0x07,0xC0,0x00,0x3F,0xFF,0x00,0x00,0x07,0xF8,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
343{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x0C,0x18,0x00,0x00,0x0E,0x38,0x00,0x00,0x0E,0x38,0x00,0x00,0x06,0x30,0x00,0x00,0x03,0x60,0x00,0x00,0x61,0x43,0x80,0x00,0xFF,0xFF,0x80,0x00,0x61,0x43,0x00,0x00,0x03,0x60,0x00,0x00,0x06,0x30,0x00,0x00,0x0E,0x38,0x00,0x00,0x0E,0x38,0x00,0x00,0x0C,0x18,0x00,0x00,0x00,0x00,0x00},
344{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x7F,0xFF,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x00,0x00},
345{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0xE3,0x00,0x00,0x00,0xE2,0x00,0x00,0x00,0xFC,0x00,0x00,0x00,0x78,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
346{0x00,0x00,0x00,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x00,0x00},
347{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0xC0,0x00,0x00,0x01,0xE0,0x00,0x00,0x01,0xE0,0x00,0x00,0x00,0xC0,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
348{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x0C,0x00,0x00,0x00,0x38,0x00,0x00,0x00,0xE0,0x00,0x00,0x03,0x80,0x00,0x00,0x0E,0x00,0x00,0x00,0x38,0x00,0x00,0x00,0xE0,0x00,0x00,0x03,0x80,0x00,0x00,0x0E,0x00,0x00,0x00,0x38,0x00,0x00,0x00,0xE0,0x00,0x00,0x03,0x80,0x00,0x00,0x0E,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
349{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x0F,0xF8,0x00,0x00,0x7F,0xFF,0x00,0x00,0xF0,0x07,0x80,0x01,0x80,0x00,0xC0,0x03,0x00,0x00,0x60,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0x00,0x00,0x60,0x01,0x80,0x00,0xC0,0x00,0xE0,0x03,0x80,0x00,0x7F,0xFF,0x00,0x00,0x0F,0xF8,0x00,0x00,0x00,0x00,0x00},
350{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x80,0x00,0x20,0x00,0x80,0x00,0x20,0x00,0x80,0x00,0x20,0x00,0x80,0x00,0x60,0x01,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x00,0x00,0x00,0x60,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
351{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x78,0x00,0xE0,0x00,0x98,0x01,0x60,0x01,0x00,0x02,0x60,0x02,0x00,0x04,0x60,0x02,0x00,0x08,0x60,0x02,0x00,0x10,0x60,0x02,0x00,0x20,0x60,0x02,0x00,0x40,0x60,0x03,0x00,0x80,0x60,0x01,0x83,0x00,0x60,0x01,0xFE,0x00,0xE0,0x00,0x7C,0x07,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
352{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0xF0,0x07,0x80,0x01,0xF0,0x07,0xC0,0x01,0x00,0x00,0x40,0x02,0x00,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x03,0x03,0x80,0x20,0x01,0x86,0x80,0x40,0x01,0xFC,0xC0,0xC0,0x00,0x78,0x7F,0x80,0x00,0x00,0x1E,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
353{0x00,0x00,0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x00,0x38,0x00,0x00,0x00,0x48,0x00,0x00,0x01,0x88,0x00,0x00,0x06,0x08,0x00,0x00,0x0C,0x08,0x10,0x00,0x30,0x08,0x10,0x00,0x40,0x08,0x10,0x01,0xFF,0xFF,0xF0,0x03,0xFF,0xFF,0xF0,0x03,0xFF,0xFF,0xF0,0x00,0x00,0x08,0x10,0x00,0x00,0x08,0x10,0x00,0x00,0x08,0x10,0x00,0x00,0x00,0x00},
354{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0x80,0x00,0x1F,0x86,0x40,0x03,0xE1,0x00,0x20,0x03,0x02,0x00,0x20,0x03,0x04,0x00,0x20,0x03,0x04,0x00,0x20,0x03,0x04,0x00,0x20,0x03,0x04,0x00,0x20,0x03,0x06,0x00,0x40,0x03,0x03,0x01,0xC0,0x03,0x01,0xFF,0x80,0x03,0x00,0x7E,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
355{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0xFC,0x00,0x00,0x3F,0xFF,0x00,0x00,0x70,0xC3,0x80,0x00,0x81,0x80,0xC0,0x01,0x01,0x00,0x60,0x03,0x02,0x00,0x20,0x02,0x02,0x00,0x20,0x02,0x02,0x00,0x20,0x02,0x02,0x00,0x20,0x02,0x03,0x00,0x40,0x01,0xC1,0x80,0xC0,0x00,0xC0,0xFF,0x80,0x00,0x00,0x7E,0x00,0x00,0x00,0x00,0x00},
356{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0xF0,0x00,0x00,0x03,0xC0,0x00,0x00,0x03,0x80,0x00,0x00,0x03,0x00,0x00,0x00,0x03,0x00,0x07,0xE0,0x03,0x00,0x3F,0xE0,0x03,0x01,0xC0,0x00,0x03,0x06,0x00,0x00,0x03,0x18,0x00,0x00,0x03,0x60,0x00,0x00,0x03,0x80,0x00,0x00,0x03,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
357{0x00,0x00,0x00,0x00,0x00,0x00,0x1F,0x00,0x00,0x78,0x3F,0x80,0x00,0xFC,0x60,0xC0,0x01,0x8E,0xC0,0x40,0x03,0x07,0x80,0x20,0x02,0x03,0x00,0x20,0x02,0x01,0x80,0x20,0x02,0x01,0x80,0x20,0x02,0x01,0xC0,0x20,0x03,0x01,0xE0,0x40,0x01,0x86,0x70,0xC0,0x00,0xFC,0x3F,0x80,0x00,0x78,0x1F,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
358{0x00,0x00,0x00,0x00,0x00,0x3F,0x00,0x00,0x00,0xFF,0x81,0xC0,0x01,0xC0,0xC1,0xC0,0x01,0x00,0x60,0x20,0x02,0x00,0x20,0x20,0x02,0x00,0x20,0x20,0x02,0x00,0x20,0x20,0x02,0x00,0x20,0x60,0x02,0x00,0x40,0xC0,0x01,0x00,0xC1,0x80,0x00,0xC1,0x8F,0x00,0x00,0x7F,0xFE,0x00,0x00,0x1F,0xF0,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
359{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x03,0x00,0xC0,0x00,0x07,0x81,0xE0,0x00,0x07,0x81,0xE0,0x00,0x03,0x00,0xC0,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
360{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x06,0x00,0x66,0x00,0x06,0x00,0x78,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
361{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x80,0x00,0x00,0x01,0xC0,0x00,0x00,0x03,0x60,0x00,0x00,0x06,0x30,0x00,0x00,0x0C,0x18,0x00,0x00,0x18,0x0C,0x00,0x00,0x30,0x06,0x00,0x00,0x60,0x03,0x00,0x00,0xC0,0x01,0x80,0x01,0x00,0x00,0x40,0x02,0x00,0x00,0x20,0x04,0x00,0x00,0x10,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
362{0x00,0x00,0x00,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x00,0x00,0x00},
363{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x00,0x10,0x02,0x00,0x00,0x20,0x01,0x00,0x00,0x40,0x00,0xC0,0x01,0x80,0x00,0x60,0x03,0x00,0x00,0x30,0x06,0x00,0x00,0x18,0x0C,0x00,0x00,0x0C,0x18,0x00,0x00,0x06,0x30,0x00,0x00,0x03,0x60,0x00,0x00,0x01,0xC0,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
364{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x78,0x00,0x00,0x01,0xF8,0x00,0x00,0x02,0x38,0x00,0x00,0x02,0x00,0x00,0x00,0x04,0x00,0x00,0xC0,0x04,0x00,0x79,0xE0,0x04,0x00,0x81,0xE0,0x04,0x01,0x00,0xC0,0x04,0x03,0x00,0x00,0x02,0x02,0x00,0x00,0x03,0x06,0x00,0x00,0x01,0xFC,0x00,0x00,0x00,0xF8,0x00,0x00,0x00,0x00,0x00,0x00},
365{0x00,0x00,0x00,0x00,0x00,0x0F,0xF8,0x00,0x00,0x3F,0xFE,0x00,0x00,0x70,0x07,0x80,0x00,0xC0,0x00,0xC0,0x01,0x01,0xF8,0x40,0x03,0x07,0xFC,0x20,0x02,0x1E,0x04,0x20,0x02,0x30,0x08,0x20,0x02,0x20,0x30,0x20,0x02,0x3F,0xFC,0x20,0x01,0x3F,0x04,0x40,0x01,0x80,0x0C,0xC0,0x00,0xE0,0x31,0x80,0x00,0x1F,0xC2,0x00,0x00,0x00,0x00,0x00},
366{0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x60,0x00,0x00,0x03,0xE0,0x00,0x00,0x3E,0x20,0x00,0x03,0xE0,0x20,0x00,0x3E,0x20,0x00,0x03,0xE0,0x20,0x00,0x03,0x80,0x20,0x00,0x07,0xFC,0x20,0x00,0x00,0x3F,0xE0,0x00,0x00,0x03,0xFE,0x20,0x00,0x00,0x3F,0xE0,0x00,0x00,0x01,0xE0,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
367{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x03,0x03,0x00,0x20,0x01,0x86,0x80,0x60,0x01,0xFC,0xC0,0xC0,0x00,0xF8,0x7F,0x80,0x00,0x00,0x1F,0x00,0x00,0x00,0x00,0x00},
368{0x00,0x00,0x00,0x00,0x00,0x07,0xF8,0x00,0x00,0x3F,0xFF,0x00,0x00,0x70,0x07,0x80,0x00,0xC0,0x00,0xC0,0x01,0x00,0x00,0x40,0x03,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x01,0x00,0x00,0x40,0x01,0x80,0x00,0xC0,0x03,0xC0,0x01,0x80,0x00,0x30,0x06,0x00,0x00,0x00,0x00,0x00},
369{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0x00,0x00,0x60,0x01,0x00,0x00,0x40,0x01,0x80,0x00,0xC0,0x00,0xF0,0x07,0x80,0x00,0x7F,0xFE,0x00,0x00,0x0F,0xF8,0x00,0x00,0x00,0x00,0x00},
370{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x03,0x80,0x20,0x02,0x0F,0xE0,0x20,0x03,0x00,0x00,0x60,0x03,0xC0,0x00,0xE0,0x00,0x60,0x03,0x00,0x00,0x00,0x00,0x00},
371{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x00,0x02,0x01,0x00,0x00,0x02,0x01,0x00,0x00,0x02,0x01,0x00,0x00,0x02,0x03,0x80,0x00,0x03,0x0F,0xE0,0x00,0x03,0x00,0x00,0x00,0x03,0xC0,0x00,0x00,0x00,0x60,0x00,0x00},
372{0x00,0x00,0x00,0x00,0x00,0x07,0xF8,0x00,0x00,0x3F,0xFE,0x00,0x00,0x70,0x07,0x80,0x01,0xC0,0x01,0xC0,0x01,0x00,0x00,0x40,0x03,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x01,0x00,0x20,0x20,0x01,0x00,0x20,0x40,0x03,0xC0,0x3F,0x80,0x00,0x30,0x3F,0x80,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00},
373{0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x80,0x20,0x02,0x00,0x80,0x20,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x02,0x00,0x80,0x20,0x02,0x00,0x80,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
374{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
375{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x0E,0x00,0x00,0x00,0x0F,0x00,0x00,0x00,0x0F,0x00,0x00,0x00,0x01,0x02,0x00,0x00,0x01,0x02,0x00,0x00,0x01,0x02,0x00,0x00,0x03,0x02,0x00,0x00,0x06,0x03,0xFF,0xFF,0xFC,0x03,0xFF,0xFF,0xF8,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
376{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0xC0,0x20,0x02,0x01,0x00,0x20,0x00,0x07,0x80,0x00,0x00,0x0F,0xE0,0x00,0x00,0x30,0xF8,0x00,0x02,0x60,0x3E,0x20,0x03,0x80,0x0F,0x20,0x03,0x00,0x03,0xE0,0x02,0x00,0x00,0xE0,0x02,0x00,0x00,0x20,0x00,0x00,0x00,0x20},
377{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x60,0x00,0x00,0x00,0xE0,0x00,0x00,0x03,0x00,0x00,0x00,0x00,0x00},
378{0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xE0,0x00,0x20,0x03,0xFF,0x00,0x20,0x00,0x1F,0xF0,0x00,0x00,0x01,0xFF,0x80,0x00,0x00,0x0F,0xE0,0x00,0x00,0x1E,0x00,0x00,0x03,0xE0,0x00,0x00,0x3E,0x00,0x20,0x03,0xE0,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20},
379{0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0x80,0x00,0x20,0x03,0xF0,0x00,0x20,0x00,0xFC,0x00,0x00,0x00,0x1F,0x00,0x00,0x00,0x07,0xC0,0x00,0x00,0x01,0xF0,0x00,0x00,0x00,0x7C,0x00,0x02,0x00,0x1F,0x80,0x02,0x00,0x07,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
380{0x00,0x00,0x00,0x00,0x00,0x0F,0xF8,0x00,0x00,0x3F,0xFE,0x00,0x00,0xF0,0x07,0x80,0x01,0x80,0x00,0xC0,0x01,0x00,0x00,0x40,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x01,0x00,0x00,0x40,0x01,0x80,0x00,0xC0,0x00,0xF0,0x03,0x80,0x00,0x3F,0xFE,0x00,0x00,0x0F,0xF8,0x00,0x00,0x00,0x00,0x00},
381{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x80,0x20,0x02,0x00,0x80,0x20,0x02,0x00,0x80,0x00,0x02,0x00,0x80,0x00,0x02,0x00,0x80,0x00,0x02,0x00,0x80,0x00,0x03,0x01,0x80,0x00,0x01,0x83,0x00,0x00,0x00,0xFE,0x00,0x00,0x00,0x7C,0x00,0x00,0x00,0x00,0x00,0x00},
382{0x00,0x00,0x00,0x00,0x00,0x0F,0xF8,0x00,0x00,0x7F,0xFF,0x00,0x00,0xF0,0x03,0x80,0x01,0x80,0x01,0xC0,0x01,0x00,0x06,0x40,0x02,0x00,0x04,0x20,0x02,0x00,0x04,0x20,0x02,0x00,0x06,0x20,0x02,0x00,0x03,0xE0,0x01,0x00,0x00,0xF8,0x01,0x80,0x00,0x5C,0x00,0xE0,0x03,0x8C,0x00,0x3F,0xFF,0x0C,0x00,0x0F,0xFC,0x18,0x00,0x00,0x00,0x00},
383{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x80,0x00,0x02,0x01,0xE0,0x00,0x02,0x01,0xFC,0x00,0x03,0x03,0x3F,0x80,0x01,0x86,0x07,0xE0,0x01,0xFC,0x00,0xE0,0x00,0xF8,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
384{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x78,0x06,0x00,0x00,0xFE,0x01,0xE0,0x01,0x86,0x00,0xC0,0x03,0x03,0x00,0x40,0x02,0x03,0x00,0x20,0x02,0x01,0x80,0x20,0x02,0x01,0x80,0x20,0x02,0x01,0xC0,0x20,0x02,0x00,0xC0,0x20,0x01,0x00,0xE0,0x60,0x01,0x80,0x70,0xC0,0x03,0xE0,0x3F,0x80,0x00,0x00,0x1F,0x00,0x00,0x00,0x00,0x00},
385{0x00,0x00,0x00,0x00,0x00,0x60,0x00,0x00,0x03,0x80,0x00,0x00,0x03,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x03,0x80,0x00,0x00,0x00,0xE0,0x00,0x00,0x00,0x00,0x00,0x00},
386{0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x03,0xFF,0xFF,0x00,0x03,0xFF,0xFF,0xC0,0x02,0x00,0x00,0x40,0x02,0x00,0x00,0x60,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x02,0x00,0x00,0x40,0x02,0x00,0x00,0x80,0x03,0xFF,0xFF,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
387{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x03,0xC0,0x00,0x00,0x03,0xFC,0x00,0x00,0x02,0x3F,0xC0,0x00,0x00,0x03,0xF8,0x00,0x00,0x00,0x7F,0x80,0x00,0x00,0x07,0xE0,0x00,0x00,0x07,0x80,0x00,0x00,0x78,0x00,0x02,0x03,0xC0,0x00,0x02,0x3C,0x00,0x00,0x03,0xC0,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00},
388{0x02,0x00,0x00,0x00,0x03,0xC0,0x00,0x00,0x03,0xFF,0x80,0x00,0x02,0x3F,0xFE,0x00,0x02,0x00,0x7F,0xE0,0x00,0x00,0x0F,0x00,0x02,0x00,0xF0,0x00,0x03,0xEF,0x00,0x00,0x03,0xFF,0x80,0x00,0x02,0x0F,0xFE,0x00,0x00,0x00,0x3F,0xE0,0x00,0x00,0x1F,0x00,0x02,0x07,0xE0,0x00,0x03,0xF8,0x00,0x00,0x03,0x00,0x00,0x00,0x02,0x00,0x00,0x00},
389{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0x80,0x00,0xE0,0x03,0xF0,0x03,0x20,0x02,0xFC,0x0C,0x20,0x02,0x1F,0x30,0x00,0x00,0x07,0xC0,0x00,0x00,0x07,0xF0,0x00,0x02,0x18,0x7C,0x00,0x02,0x60,0x1F,0x20,0x03,0x80,0x03,0xE0,0x02,0x00,0x00,0xE0,0x02,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
390{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x03,0x00,0x00,0x00,0x03,0xC0,0x00,0x00,0x03,0xF8,0x00,0x00,0x02,0x3E,0x00,0x20,0x02,0x0F,0xC0,0x20,0x00,0x01,0xFF,0xE0,0x00,0x00,0x7F,0xE0,0x00,0x03,0x80,0x20,0x02,0x1C,0x00,0x20,0x02,0x70,0x00,0x00,0x03,0x80,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
391{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x60,0x00,0xE0,0x03,0x80,0x03,0xE0,0x03,0x00,0x0F,0xA0,0x02,0x00,0x3E,0x20,0x02,0x00,0xF8,0x20,0x02,0x03,0xE0,0x20,0x02,0x0F,0x80,0x20,0x02,0x3E,0x00,0x20,0x02,0x78,0x00,0x20,0x03,0xE0,0x00,0x60,0x03,0x80,0x00,0xE0,0x02,0x00,0x03,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
392{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x1F,0xFF,0xFF,0xFC,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
393{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0x00,0x00,0x00,0x03,0xC0,0x00,0x00,0x00,0x78,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0x03,0xC0,0x00,0x00,0x00,0xF0,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0x07,0x80,0x00,0x00,0x00,0xF0,0x00,0x00,0x00,0x3C,0x00,0x00,0x00,0x06,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
394{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x1F,0xFF,0xFF,0xFC,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
395{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x08,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x10,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
396{0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01},
397{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x10,0x00,0x00,0x00,0x10,0x00,0x00,0x00,0x10,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x08,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
398{0x00,0x00,0x00,0x00,0x00,0x00,0x03,0x80,0x00,0x01,0x8F,0xC0,0x00,0x03,0x8C,0x60,0x00,0x06,0x18,0x20,0x00,0x04,0x10,0x20,0x00,0x04,0x10,0x20,0x00,0x04,0x20,0x20,0x00,0x04,0x20,0x40,0x00,0x06,0x20,0x40,0x00,0x03,0xFF,0xC0,0x00,0x01,0xFF,0xE0,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0xC0,0x00,0x00,0x00,0x00},
399{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x03,0xFF,0xFF,0xE0,0x07,0xFF,0xFF,0xC0,0x00,0x01,0x80,0xC0,0x00,0x02,0x00,0x60,0x00,0x02,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x06,0x00,0x40,0x00,0x03,0x00,0xC0,0x00,0x01,0xFF,0x80,0x00,0x00,0xFE,0x00,0x00,0x00,0x00,0x00},
400{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7E,0x00,0x00,0x01,0xFF,0x80,0x00,0x03,0x81,0xC0,0x00,0x02,0x00,0x40,0x00,0x06,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x06,0x00,0x20,0x00,0x03,0xC0,0x40,0x00,0x01,0xC0,0x80,0x00,0x00,0x03,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
401{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7E,0x00,0x00,0x01,0xFF,0x80,0x00,0x03,0x80,0xC0,0x00,0x06,0x00,0x60,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x02,0x04,0x00,0x40,0x02,0x02,0x00,0x80,0x03,0xFF,0xFF,0xE0,0x07,0xFF,0xFF,0xC0,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x00},
402{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7E,0x00,0x00,0x01,0xFF,0x80,0x00,0x03,0x11,0xC0,0x00,0x02,0x10,0x40,0x00,0x04,0x10,0x60,0x00,0x04,0x10,0x20,0x00,0x04,0x10,0x20,0x00,0x04,0x10,0x20,0x00,0x06,0x10,0x20,0x00,0x03,0x10,0x40,0x00,0x01,0xF0,0xC0,0x00,0x00,0x71,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
403{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x7F,0xFF,0xE0,0x01,0xFF,0xFF,0xE0,0x01,0x04,0x00,0x20,0x03,0x04,0x00,0x20,0x02,0x04,0x00,0x20,0x02,0x04,0x00,0x20,0x02,0x04,0x00,0x00,0x02,0x00,0x00,0x00,0x01,0xC0,0x00,0x00,0x01,0xC0,0x00,0x00},
404{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x1C,0x00,0x00,0xE3,0x3E,0x00,0x03,0xFF,0xC2,0x00,0x02,0x0C,0xC3,0x00,0x04,0x04,0xC1,0x00,0x04,0x04,0xC1,0x00,0x04,0x04,0xC1,0x00,0x04,0x04,0xC1,0x00,0x06,0x0C,0xC1,0x00,0x03,0xF8,0xC3,0x00,0x05,0xF0,0x62,0x00,0x06,0x00,0x7E,0x00,0x06,0x00,0x3C,0x00,0x00,0x00,0x00},
405{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x07,0xFF,0xFF,0xE0,0x00,0x01,0x00,0x20,0x00,0x02,0x00,0x20,0x00,0x06,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x06,0x00,0x20,0x00,0x03,0xFF,0xE0,0x00,0x01,0xFF,0xE0,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20},
406{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x03,0x87,0xFF,0xE0,0x03,0x8F,0xFF,0xE0,0x03,0x80,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
407{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x06,0x00,0x00,0x00,0x07,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x04,0x00,0x01,0x00,0x04,0x00,0x01,0x00,0x04,0x00,0x03,0x00,0x04,0x00,0x06,0x03,0x87,0xFF,0xFC,0x03,0x8F,0xFF,0xF8,0x03,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
408{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x07,0xFF,0xFF,0xE0,0x00,0x00,0x08,0x20,0x00,0x00,0x10,0x20,0x00,0x00,0x30,0x00,0x00,0x00,0xFC,0x00,0x00,0x05,0x8E,0x00,0x00,0x07,0x07,0xA0,0x00,0x06,0x01,0xE0,0x00,0x04,0x00,0xE0,0x00,0x04,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
409{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x07,0xFF,0xFF,0xE0,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
410{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x07,0xFF,0xE0,0x00,0x0F,0xFF,0xE0,0x00,0x02,0x00,0x20,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x07,0xFF,0xE0,0x00,0x03,0xFF,0xE0,0x00,0x02,0x00,0x20,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x07,0xFF,0xE0,0x00,0x03,0xFF,0xE0,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
411{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x07,0xFF,0xE0,0x00,0x0F,0xFF,0xE0,0x00,0x01,0x00,0x20,0x00,0x02,0x00,0x20,0x00,0x02,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x06,0x00,0x20,0x00,0x03,0xFF,0xE0,0x00,0x01,0xFF,0xE0,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20},
412{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7E,0x00,0x00,0x00,0xFF,0x80,0x00,0x03,0x81,0xC0,0x00,0x02,0x00,0x40,0x00,0x06,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x06,0x00,0x20,0x00,0x02,0x00,0x40,0x00,0x03,0x81,0xC0,0x00,0x01,0xFF,0x80,0x00,0x00,0x7E,0x00,0x00,0x00,0x00,0x00},
413{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x01,0x00,0x04,0x00,0x01,0x00,0x07,0xFF,0xFF,0x00,0x0F,0xFF,0xFF,0x00,0x01,0x00,0xC1,0x00,0x02,0x00,0x41,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x06,0x00,0x40,0x00,0x03,0x01,0xC0,0x00,0x01,0xFF,0x80,0x00,0x00,0x7E,0x00,0x00,0x00,0x00,0x00},
414{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7E,0x00,0x00,0x01,0xFF,0x80,0x00,0x03,0x80,0xC0,0x00,0x02,0x00,0x60,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x02,0x00,0x41,0x00,0x03,0x00,0xC1,0x00,0x03,0xFF,0xFF,0x00,0x07,0xFF,0xFF,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01},
415{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x0F,0xFF,0xE0,0x00,0x0F,0xFF,0xE0,0x00,0x00,0xC0,0x20,0x00,0x01,0x00,0x20,0x00,0x02,0x00,0x20,0x00,0x06,0x00,0x20,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x07,0x00,0x00,0x00,0x03,0x00,0x00,0x00,0x00,0x00,0x00},
416{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x03,0xE0,0x00,0x01,0xC0,0xE0,0x00,0x03,0xE0,0x40,0x00,0x06,0x30,0x20,0x00,0x04,0x30,0x20,0x00,0x04,0x18,0x20,0x00,0x04,0x18,0x20,0x00,0x04,0x18,0x20,0x00,0x04,0x0C,0x20,0x00,0x02,0x0C,0x60,0x00,0x03,0x07,0xC0,0x00,0x07,0x83,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
417{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x0C,0x00,0x00,0x00,0x1F,0xFF,0x80,0x00,0xFF,0xFF,0xC0,0x00,0x04,0x00,0x60,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x40,0x00,0x00,0x01,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
418{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x07,0xFF,0x80,0x00,0x0F,0xFF,0xC0,0x00,0x00,0x00,0x60,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x04,0x00,0x40,0x00,0x04,0x00,0x80,0x00,0x07,0xFF,0xE0,0x00,0x0F,0xFF,0xC0,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x40},
419{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x07,0x80,0x00,0x00,0x07,0xF0,0x00,0x00,0x04,0xFE,0x00,0x00,0x04,0x1F,0xC0,0x00,0x00,0x03,0xE0,0x00,0x00,0x03,0x80,0x00,0x00,0x1C,0x00,0x00,0x04,0x60,0x00,0x00,0x07,0x80,0x00,0x00,0x06,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
420{0x00,0x04,0x00,0x00,0x00,0x06,0x00,0x00,0x00,0x07,0xC0,0x00,0x00,0x07,0xFC,0x00,0x00,0x04,0x3F,0x80,0x00,0x00,0x03,0xE0,0x00,0x04,0x0F,0x80,0x00,0x06,0xF0,0x00,0x00,0x07,0xF0,0x00,0x00,0x07,0xFF,0x80,0x00,0x04,0x0F,0xE0,0x00,0x00,0x03,0x80,0x00,0x04,0x3C,0x00,0x00,0x07,0xC0,0x00,0x00,0x06,0x00,0x00,0x00,0x04,0x00,0x00},
421{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x60,0x00,0x07,0x00,0xE0,0x00,0x07,0x83,0x20,0x00,0x07,0xE6,0x00,0x00,0x04,0xF8,0x00,0x00,0x00,0x3C,0x00,0x00,0x04,0x5E,0x20,0x00,0x05,0x87,0xA0,0x00,0x06,0x01,0xE0,0x00,0x04,0x00,0x60,0x00,0x04,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
422{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x03,0x00,0x07,0x00,0x03,0x00,0x07,0xE0,0x01,0x00,0x04,0xF8,0x01,0x00,0x04,0x1F,0x02,0x00,0x00,0x07,0xFC,0x00,0x00,0x00,0xE0,0x00,0x00,0x07,0x00,0x00,0x04,0x38,0x00,0x00,0x07,0xC0,0x00,0x00,0x06,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x00,0x00,0x00},
423{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0x80,0x60,0x00,0x06,0x00,0xE0,0x00,0x04,0x03,0xE0,0x00,0x04,0x07,0xA0,0x00,0x04,0x0E,0x20,0x00,0x04,0x3C,0x20,0x00,0x04,0x70,0x20,0x00,0x05,0xE0,0x20,0x00,0x07,0x80,0x20,0x00,0x07,0x00,0x60,0x00,0x04,0x00,0xE0,0x00,0x00,0x03,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
424{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x01,0x40,0x00,0x07,0xFE,0x3F,0xF8,0x08,0x00,0x00,0x04,0x10,0x00,0x00,0x02,0x10,0x00,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
425{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0xFF,0xFF,0xFF,0xFF,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
426{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x10,0x00,0x00,0x02,0x10,0x00,0x00,0x02,0x08,0x00,0x00,0x04,0x07,0xFE,0x3F,0xF8,0x00,0x01,0x40,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
427{0x00,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x30,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x30,0x00,0x00,0x00,0x08,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x0C,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
428};
429
438#endif
asc2_2412
const unsigned char asc2_2412[95][36]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h:234
asc2_3216
const unsigned char asc2_3216[95][128]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h:332
asc2_1206
const unsigned char asc2_1206[95][12]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h:38
asc2_1608
const unsigned char asc2_1608[95][16]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h:136


AT32F435/437 Firmwary Library: xmc_lcd.c File Reference

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • lcd
Functions | Variables
at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c File Reference

xmc_lcd program file More...

#include "xmc_lcd.h"
#include "font.h"

Go to the source code of this file.

Functions

void | xmc_init (void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_init (void)
configures the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_wr_command (uint16_t command)
this function is write command to lcd. More...
void | lcd_wr_data (uint16_t data)
this function is write data to lcd. More...
uint16_t | lcd_rd_data (void)
void | lcd_setblock (uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd. More...
void | lcd_writeonepoint (uint16_t color)
this function is write one point to lcd. More...
void | lcd_drawpoint (uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd. More...
void | lcd_clear (uint16_t color)
this function is clear the lcd. More...
void | lcd_char_show (uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode)
this function is show char to lcd More...
void | lcd_string_show (uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p)
this function is show string to lcd More...
void | lcd_fill (uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color)
this function is fill in lcd with concolorous More...
void | lcd_color_fill (uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color)
this function is fill in lcd with color-pointer More...

Variables

lcd_dev_type lcd_dev_struct
lcd_dev_type * lcd_struct

Detailed Description

xmc_lcd program file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.


AT32F435/437 Firmwary Library: xmc_lcd.c Source File

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • lcd
at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c
Go to the documentation of this file.
1
27#include "xmc_lcd.h"
28#include "font.h"
29
38 lcd_dev_type lcd_dev_struct =
39{
40 0,
41 xmc_init,
42 lcd_init,
43 lcd_setblock,
44 lcd_drawpoint,
45 lcd_clear,
46};
47
48 lcd_dev_type *lcd_struct;
49
57void xmc_init(void)
58{
59 gpio_init_type gpio_init_struct = {0};
60 xmc_norsram_init_type xmc_norsram_init_struct;
61 xmc_norsram_timing_init_type rw_timing_struct, w_timing_struct;
62
63 /* enable the gpio clock */
64 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
65 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
67 /* enable the xmc clock */
68 crm_periph_clock_enable(CRM_XMC_PERIPH_CLOCK, TRUE);
69
70 /*-- gpio configuration ------------------------------------------------------*/
71 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE2, GPIO_MUX_14);
72 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE4, GPIO_MUX_14);
73 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE5, GPIO_MUX_14);
74 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE11, GPIO_MUX_14);
75 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE12, GPIO_MUX_14);
76 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE5, GPIO_MUX_10);
77 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE8, GPIO_MUX_12);
78 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE9, GPIO_MUX_12);
79 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE10, GPIO_MUX_12);
80 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE14, GPIO_MUX_12);
81 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE15, GPIO_MUX_12);
82
83 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE7, GPIO_MUX_12);
84 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE8, GPIO_MUX_12);
85 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE9, GPIO_MUX_12);
86 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE10, GPIO_MUX_12);
87 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE11, GPIO_MUX_12);
88 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE12, GPIO_MUX_12);
89 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE13, GPIO_MUX_12);
90 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE14, GPIO_MUX_12);
91 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE15, GPIO_MUX_12);
92
93 /* lcd data lines configuration */
94 gpio_init_struct.gpio_pins = GPIO_PINS_2 | GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_11| GPIO_PINS_12;
95 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
96 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
97 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
98 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
99 gpio_init(GPIOC, &gpio_init_struct);
100
101
102 gpio_init_struct.gpio_pins = GPIO_PINS_5 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_14 | GPIO_PINS_15;
103 gpio_init(GPIOD, &gpio_init_struct);
104
105 gpio_init_struct.gpio_pins = GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11 | GPIO_PINS_12 | GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
106 gpio_init(GPIOE, &gpio_init_struct);
107
108 /*-- xmc configuration ------------------------------------------------------*/
109 xmc_norsram_default_para_init(&xmc_norsram_init_struct);
110 xmc_norsram_init_struct.subbank = XMC_BANK1_NOR_SRAM4;
111 xmc_norsram_init_struct.data_addr_multiplex = XMC_DATA_ADDR_MUX_DISABLE;
112 xmc_norsram_init_struct.device = XMC_DEVICE_SRAM;
113 xmc_norsram_init_struct.bus_type = XMC_BUSTYPE_16_BITS;
114 xmc_norsram_init_struct.burst_mode_enable = XMC_BURST_MODE_DISABLE;
115 xmc_norsram_init_struct.asynwait_enable = XMC_ASYN_WAIT_DISABLE;
116 xmc_norsram_init_struct.wait_signal_lv = XMC_WAIT_SIGNAL_LEVEL_LOW;
117 xmc_norsram_init_struct.wrapped_mode_enable = XMC_WRAPPED_MODE_DISABLE;
118 xmc_norsram_init_struct.wait_signal_config = XMC_WAIT_SIGNAL_SYN_BEFORE;
119 xmc_norsram_init_struct.write_enable = XMC_WRITE_OPERATION_ENABLE;
120 xmc_norsram_init_struct.wait_signal_enable = XMC_WAIT_SIGNAL_DISABLE;
121 xmc_norsram_init_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
122 xmc_norsram_init_struct.write_burst_syn = XMC_WRITE_BURST_SYN_DISABLE;
123 xmc_nor_sram_init(&xmc_norsram_init_struct);
124
125 /* timing configuration */
126 xmc_norsram_timing_default_para_init(&rw_timing_struct, &w_timing_struct);
127 rw_timing_struct.subbank = XMC_BANK1_NOR_SRAM4;
128 rw_timing_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
129 rw_timing_struct.addr_setup_time = 0x2;
130 rw_timing_struct.addr_hold_time = 0x0;
131 rw_timing_struct.data_setup_time = 0x2;
132 rw_timing_struct.bus_latency_time = 0x0;
133 rw_timing_struct.clk_psc = 0x0;
134 rw_timing_struct.data_latency_time = 0x0;
135 rw_timing_struct.mode = XMC_ACCESS_MODE_A;
136 w_timing_struct.subbank = XMC_BANK1_NOR_SRAM4;
137 w_timing_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
138 w_timing_struct.addr_setup_time = 0x2;
139 w_timing_struct.addr_hold_time = 0x0;
140 w_timing_struct.data_setup_time = 0x2;
141 w_timing_struct.bus_latency_time = 0x0;
142 w_timing_struct.clk_psc = 0x0;
143 w_timing_struct.data_latency_time = 0x0;
144 w_timing_struct.mode = XMC_ACCESS_MODE_A;
145 xmc_nor_sram_timing_config(&rw_timing_struct, &w_timing_struct);
146
147 /* enable xmc_bank1_nor_sram4 */
148 xmc_nor_sram_enable(XMC_BANK1_NOR_SRAM4, TRUE);
149
150 gpio_init_struct.gpio_pins = GPIO_PINS_0;
151 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
152 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
153 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
154 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
155 gpio_init(GPIOC, &gpio_init_struct);
156}
157
165void lcd_init(void)
166{
167 /* init xmc */
168 lcd_struct->xmc_init();
169
170 delay_ms(50);
171
172 /* read id */
173 lcd_wr_command(0x0000);
174 delay_ms(5);
175
176 lcd_struct->lcd_id = lcd_rd_data();
177 lcd_wr_command(0xd3);
178
179 lcd_struct->lcd_id = lcd_rd_data();
180 lcd_struct->lcd_id = lcd_rd_data();
181 lcd_struct->lcd_id = lcd_rd_data();
182 lcd_struct->lcd_id = lcd_rd_data();
183 lcd_struct->lcd_id = lcd_struct->lcd_id << 8;
184 lcd_struct->lcd_id |= lcd_rd_data();
185
186 lcd_wr_command(0xcf);
187 lcd_wr_data(0x00);
188 lcd_wr_data(0xc1);
189 lcd_wr_data(0x30);
190 lcd_wr_command(0xed);
191 lcd_wr_data(0x64);
192 lcd_wr_data(0x03);
193 lcd_wr_data(0x12);
194 lcd_wr_data(0x81);
195 lcd_wr_command(0xe8);
196 lcd_wr_data(0x85);
197 lcd_wr_data(0x10);
198 lcd_wr_data(0x7a);
199 lcd_wr_command(0xcb);
200 lcd_wr_data(0x39);
201 lcd_wr_data(0x2c);
202 lcd_wr_data(0x00);
203 lcd_wr_data(0x34);
204 lcd_wr_data(0x02);
205 lcd_wr_command(0xf7);
206 lcd_wr_data(0x20);
207 lcd_wr_command(0xea);
208 lcd_wr_data(0x00);
209 lcd_wr_data(0x00);
210 lcd_wr_command(0xc0);
211 lcd_wr_data(0x1b);
212 lcd_wr_command(0xc1);
213 lcd_wr_data(0x01);
214 lcd_wr_command(0xc5);
215 lcd_wr_data(0x30);
216 lcd_wr_data(0x30);
217 lcd_wr_command(0xc7);
218 lcd_wr_data(0xb7);
219 lcd_wr_command(0x36);
220 lcd_wr_data(0x48);
221 lcd_wr_command(0x3a);
222 lcd_wr_data(0x55);
223 lcd_wr_command(0xb1);
224 lcd_wr_data(0x00);
225 lcd_wr_data(0x1a);
226 lcd_wr_command(0xb6);
227 lcd_wr_data(0x0a);
228 lcd_wr_data(0xa2);
229 lcd_wr_command(0xf2);
230 lcd_wr_data(0x00);
231 lcd_wr_command(0x26);
232 lcd_wr_data(0x01);
233 lcd_wr_command(0xe0);
234 lcd_wr_data(0x0f);
235 lcd_wr_data(0x2a);
236 lcd_wr_data(0x28);
237 lcd_wr_data(0x08);
238 lcd_wr_data(0x0e);
239 lcd_wr_data(0x08);
240 lcd_wr_data(0x54);
241 lcd_wr_data(0xa9);
242 lcd_wr_data(0x43);
243 lcd_wr_data(0x0a);
244 lcd_wr_data(0x0f);
245 lcd_wr_data(0x00);
246 lcd_wr_data(0x00);
247 lcd_wr_data(0x00);
248 lcd_wr_data(0x00);
249 lcd_wr_command(0xe1);
250 lcd_wr_data(0x00);
251 lcd_wr_data(0x15);
252 lcd_wr_data(0x17);
253 lcd_wr_data(0x07);
254 lcd_wr_data(0x11);
255 lcd_wr_data(0x06);
256 lcd_wr_data(0x2b);
257 lcd_wr_data(0x56);
258 lcd_wr_data(0x3c);
259 lcd_wr_data(0x05);
260 lcd_wr_data(0x10);
261 lcd_wr_data(0x0f);
262 lcd_wr_data(0x3f);
263 lcd_wr_data(0x3f);
264 lcd_wr_data(0x0f);
265 lcd_wr_command(0x2b);
266 lcd_wr_data(0x00);
267 lcd_wr_data(0x00);
268 lcd_wr_data(0x01);
269 lcd_wr_data(0x3f);
270 lcd_wr_command(0x2a);
271 lcd_wr_data(0x00);
272 lcd_wr_data(0x00);
273 lcd_wr_data(0x00);
274 lcd_wr_data(0xef);
275 lcd_wr_command(0x11);
276 delay_ms(120);
277 lcd_wr_command(0x29);
278 lcd_wr_command(0x36);
279 lcd_wr_data(0x08);
280 lcd_wr_command(0x2a);
281 lcd_wr_data(0x00);
282 lcd_wr_data(0x00);
283 lcd_wr_data(0xef >> 8);
284 lcd_wr_data(0xef & 0xff);
285 lcd_wr_command(0x2b);
286 lcd_wr_data(0x00);
287 lcd_wr_data(0x00);
288 lcd_wr_data(0x13f >> 8);
289 lcd_wr_data(0x13f & 0xff);
290 lcd_wr_command(0x36); //setting the display direction
291 lcd_wr_data(0x68); //90 degree
292 LCD_BL_HIGH;
293}
294
300void lcd_wr_command(uint16_t command)
301{
302 *(uint16_t*) XMC_LCD_COMMAND = command;
303}
304
310void lcd_wr_data(uint16_t data)
311{
312 *(uint16_t*) XMC_LCD_DATA = data;
313}
314
315uint16_t lcd_rd_data(void)
316{
317 uint16_t data;
318
319 data = *(uint16_t*)XMC_LCD_DATA;
320
321 return data;
322}
323
332void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
333{
334 /* set row coordinates */
335 lcd_wr_command(0x2a);
336 lcd_wr_data(xstart >> 8);
337 lcd_wr_data(xstart);
338 lcd_wr_data(xend >> 8);
339 lcd_wr_data(xend);
340
341 /* set column coordinates */
342 lcd_wr_command(0x2b);
343 lcd_wr_data(ystart >> 8);
344 lcd_wr_data(ystart);
345 lcd_wr_data(yend >> 8);
346 lcd_wr_data(yend);
347
348 /* enable write menory */
349 lcd_wr_command(0x2c);
350}
351
357void lcd_writeonepoint(uint16_t color)
358{
359 lcd_wr_data(color);
360}
361
367void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
368{
369 lcd_struct->lcd_setblock(x, y ,x ,y);
370
371 lcd_writeonepoint(color);
372}
373
379void lcd_clear(uint16_t color)
380{
381 uint32_t i;
382
383 lcd_struct->lcd_setblock(0, 0, LCD_W, LCD_H);
384
385 for(i = 0; i < 76800; i++)
386 {
387 lcd_writeonepoint(color);
388 }
389}
390
400void lcd_char_show(uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode)
401{
402 uint8_t temp, t1, t;
403 uint16_t y0 = y;
404 uint8_t csize = (size / 8 + ((size % 8) ? 1 : 0)) * (size / 2);
405 num = num - ' ';
406
407 for(t = 0; t < csize; t++)
408 {
409 if(size == 12)
410 {
411 temp = asc2_1206[num][t];
412 }
413 else if(size == 16)
414 {
415 temp = asc2_1608[num][t];
416 }
417 else if(size == 24)
418 {
419 temp = asc2_2412[num][t];
420 }
421 else if(size == 32)
422 {
423 temp = asc2_3216[num][t];
424 }
425 else
426 {
427 return;
428 }
429
430 for(t1 = 0; t1 < 8; t1++)
431 {
432 if(temp & 0x80)
433 {
434 lcd_drawpoint(x, y, RED);
435 }
436 else if(mode == 0)
437 {
438 lcd_drawpoint(x, y, WHITE);
439 }
440
441 temp <<= 1;
442 y++;
443
444 if(y >= LCD_H)
445 {
446 return;
447 }
448
449 if((y - y0) == size)
450 {
451 y = y0;
452 x++;
453
454 if(x >= LCD_W)
455 {
456 return;
457 }
458
459 break;
460 }
461 }
462 }
463}
464
474void lcd_string_show(uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p)
475{
476 uint8_t x0 = x;
477 width += x;
478 height += y;
479
480 while((*p <= '~') && (*p >= ' '))
481 {
482 if(x >= width)
483 {
484 x = x0;
485 y += size;
486 }
487
488 if(y >= height)
489 {
490 break;
491 }
492
493 lcd_char_show(x, y, *p, size, 0);
494 x += size / 2;
495 p++;
496 }
497}
498
508void lcd_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color)
509{
510 uint32_t i, num;
511 num = (ex - sx) * (ey - sy);
512 lcd_struct->lcd_setblock(sx, sy, ex, ey);
513
514 for(i = 0; i < num; i++)
515 {
516 lcd_writeonepoint(color);
517 }
518}
519
529void lcd_color_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color)
530{
531 uint16_t height, width;
532 uint16_t i, j;
533
534 width = ex - sx + 1;
535 height = ey - sy + 1;
536 lcd_struct->lcd_setblock(sx, sy, ex, ey);
537
538 for(i = 0; i < height; i++)
539 {
540 for(j = 0; j < width; j++)
541 {
542 lcd_writeonepoint(color[i * width + j]);
543 }
544 }
545}
font.h
xmc_lcd.h
xmc_lcd program header
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
lcd_color_fill
void lcd_color_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color)
this function is fill in lcd with color-pointer
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:529
lcd_setblock
void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:332
LCD_H
#define LCD_H
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:79
lcd_char_show
void lcd_char_show(uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode)
this function is show char to lcd
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:400
lcd_dev_struct
lcd_dev_type lcd_dev_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:38
lcd_init
void lcd_init(void)
configures the lcd. this function must be called before any write/read operation on the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:165
lcd_string_show
void lcd_string_show(uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p)
this function is show string to lcd
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:474
lcd_fill
void lcd_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color)
this function is fill in lcd with concolorous
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:508
lcd_drawpoint
void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:367
WHITE
#define WHITE
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:84
lcd_wr_command
void lcd_wr_command(uint16_t command)
this function is write command to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:300
RED
#define RED
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:90
lcd_rd_data
uint16_t lcd_rd_data(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:315
LCD_W
#define LCD_W
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:78
asc2_2412
const unsigned char asc2_2412[95][36]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h:234
asc2_3216
const unsigned char asc2_3216[95][128]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h:332
asc2_1206
const unsigned char asc2_1206[95][12]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h:38
lcd_clear
void lcd_clear(uint16_t color)
this function is clear the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:379
asc2_1608
const unsigned char asc2_1608[95][16]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h:136
lcd_struct
lcd_dev_type * lcd_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:48
lcd_writeonepoint
void lcd_writeonepoint(uint16_t color)
this function is write one point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:357
lcd_wr_data
void lcd_wr_data(uint16_t data)
this function is write data to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:310
LCD_BL_HIGH
#define LCD_BL_HIGH
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:81
xmc_init
void xmc_init(void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write...
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:57
j
uint32_t j
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:44
XMC_LCD_COMMAND
#define XMC_LCD_COMMAND
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:65
XMC_LCD_DATA
#define XMC_LCD_DATA
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:66
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_XMC_PERIPH_CLOCK
@ CRM_XMC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:123
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f435_437_gpio.h:146
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_10
@ GPIO_MUX_10
Definition: at32f435_437_gpio.h:166
GPIO_MUX_14
@ GPIO_MUX_14
Definition: at32f435_437_gpio.h:170
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f435_437_gpio.h:64
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
xmc_nor_sram_init
void xmc_nor_sram_init(xmc_norsram_init_type *xmc_norsram_init_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_norsraminitstruct.
Definition: at32f435_437_xmc.c:78
xmc_norsram_timing_default_para_init
void xmc_norsram_timing_default_para_init(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
fill each xmc_rw_timing_struct and xmc_w_timing_struct member with its default value.
Definition: at32f435_437_xmc.c:176
xmc_nor_sram_timing_config
void xmc_nor_sram_timing_config(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_rw_timing_struct a...
Definition: at32f435_437_xmc.c:113
xmc_norsram_default_para_init
void xmc_norsram_default_para_init(xmc_norsram_init_type *xmc_nor_sram_init_struct)
fill each xmc_nor_sram_init_struct member with its default value.
Definition: at32f435_437_xmc.c:150
xmc_nor_sram_enable
void xmc_nor_sram_enable(xmc_nor_sram_subbank_type xmc_subbank, confirm_state new_state)
enable or disable the specified nor/sram memory bank.
Definition: at32f435_437_xmc.c:210
XMC_WAIT_SIGNAL_DISABLE
@ XMC_WAIT_SIGNAL_DISABLE
Definition: at32f435_437_xmc.h:101
XMC_WAIT_SIGNAL_SYN_BEFORE
@ XMC_WAIT_SIGNAL_SYN_BEFORE
Definition: at32f435_437_xmc.h:196
XMC_WRITE_OPERATION_ENABLE
@ XMC_WRITE_OPERATION_ENABLE
Definition: at32f435_437_xmc.h:93
XMC_WRITE_BURST_SYN_DISABLE
@ XMC_WRITE_BURST_SYN_DISABLE
Definition: at32f435_437_xmc.h:110
XMC_BURST_MODE_DISABLE
@ XMC_BURST_MODE_DISABLE
Definition: at32f435_437_xmc.h:65
XMC_DATA_ADDR_MUX_DISABLE
@ XMC_DATA_ADDR_MUX_DISABLE
Definition: at32f435_437_xmc.h:56
XMC_BUSTYPE_16_BITS
@ XMC_BUSTYPE_16_BITS
Definition: at32f435_437_xmc.h:179
XMC_WRITE_TIMING_ENABLE
@ XMC_WRITE_TIMING_ENABLE
Definition: at32f435_437_xmc.h:120
XMC_BANK1_NOR_SRAM4
@ XMC_BANK1_NOR_SRAM4
Definition: at32f435_437_xmc.h:149
XMC_ASYN_WAIT_DISABLE
@ XMC_ASYN_WAIT_DISABLE
Definition: at32f435_437_xmc.h:74
XMC_WRAPPED_MODE_DISABLE
@ XMC_WRAPPED_MODE_DISABLE
Definition: at32f435_437_xmc.h:83
XMC_ACCESS_MODE_A
@ XMC_ACCESS_MODE_A
Definition: at32f435_437_xmc.h:205
XMC_WAIT_SIGNAL_LEVEL_LOW
@ XMC_WAIT_SIGNAL_LEVEL_LOW
Definition: at32f435_437_xmc.h:187
XMC_DEVICE_SRAM
@ XMC_DEVICE_SRAM
Definition: at32f435_437_xmc.h:168
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
lcd_dev_type
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:44
lcd_dev_type::lcd_setblock
void(* lcd_setblock)(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:48
lcd_dev_type::lcd_id
uint16_t lcd_id
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:45
lcd_dev_type::xmc_init
void(* xmc_init)(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:46
xmc_norsram_init_type
xmc nor/sram init structure definition
Definition: at32f435_437_xmc.h:409
xmc_norsram_init_type::wait_signal_enable
xmc_wait_signal_type wait_signal_enable
Definition: at32f435_437_xmc.h:420
xmc_norsram_init_type::data_addr_multiplex
xmc_data_addr_mux_type data_addr_multiplex
Definition: at32f435_437_xmc.h:411
xmc_norsram_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:421
xmc_norsram_init_type::burst_mode_enable
xmc_burst_access_mode_type burst_mode_enable
Definition: at32f435_437_xmc.h:414
xmc_norsram_init_type::bus_type
xmc_data_width_type bus_type
Definition: at32f435_437_xmc.h:413
xmc_norsram_init_type::device
xmc_memory_type device
Definition: at32f435_437_xmc.h:412
xmc_norsram_init_type::wait_signal_lv
xmc_wait_signal_polarity_type wait_signal_lv
Definition: at32f435_437_xmc.h:416
xmc_norsram_init_type::wrapped_mode_enable
xmc_wrap_mode_type wrapped_mode_enable
Definition: at32f435_437_xmc.h:417
xmc_norsram_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:410
xmc_norsram_init_type::write_burst_syn
xmc_write_burst_type write_burst_syn
Definition: at32f435_437_xmc.h:422
xmc_norsram_init_type::asynwait_enable
xmc_asyn_wait_type asynwait_enable
Definition: at32f435_437_xmc.h:415
xmc_norsram_init_type::wait_signal_config
xmc_wait_timing_type wait_signal_config
Definition: at32f435_437_xmc.h:418
xmc_norsram_init_type::write_enable
xmc_write_operation_type write_enable
Definition: at32f435_437_xmc.h:419
xmc_norsram_timing_init_type
nor/sram banks timing parameters
Definition: at32f435_437_xmc.h:393
xmc_norsram_timing_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:395
xmc_norsram_timing_init_type::data_latency_time
uint32_t data_latency_time
Definition: at32f435_437_xmc.h:401
xmc_norsram_timing_init_type::addr_hold_time
uint32_t addr_hold_time
Definition: at32f435_437_xmc.h:397
xmc_norsram_timing_init_type::bus_latency_time
uint32_t bus_latency_time
Definition: at32f435_437_xmc.h:399
xmc_norsram_timing_init_type::addr_setup_time
uint32_t addr_setup_time
Definition: at32f435_437_xmc.h:396
xmc_norsram_timing_init_type::mode
xmc_access_mode_type mode
Definition: at32f435_437_xmc.h:402
xmc_norsram_timing_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:394
xmc_norsram_timing_init_type::clk_psc
uint32_t clk_psc
Definition: at32f435_437_xmc.h:400
xmc_norsram_timing_init_type::data_setup_time
uint32_t data_setup_time
Definition: at32f435_437_xmc.h:398


AT32F435/437 Firmwary Library: xmc_lcd.h File Reference

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • lcd
Data Structures | Macros | Functions | Variables
at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h File Reference

xmc_lcd program header More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Data Structures

struct lcd_dev_type

Macros

#define | XMC_LCD_COMMAND (0x6C000000)
#define | XMC_LCD_DATA (0x6C000800)
#define | LCD_W 320
#define | LCD_H 240
#define | LCD_BL_HIGH gpio_bits_set(GPIOC,GPIO_PINS_0)
#define | LCD_BL_LOW gpio_bits_reset(GPIOC,GPIO_PINS_0)
#define | WHITE 0xFFFF
#define | BLACK 0x0000
#define | BLUE 0x001F
#define | BRED 0xF81F
#define | GRED 0xFFE0
#define | GBLUE 0x07FF
#define | RED 0xF800
#define | MAGENTA 0xF81F
#define | GREEN 0x07E0
#define | CYAN 0x7FFF
#define | YELLOW 0xFFE0
#define | BROWN 0xBC40
#define | BRRED 0xFC07
#define | GRAY 0x8430

Functions

void | xmc_init (void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_init (void)
configures the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_wr_command (uint16_t command)
this function is write command to lcd. More...
void | lcd_wr_data (uint16_t data)
this function is write data to lcd. More...
uint16_t | lcd_rd_data (void)
void | lcd_setblock (uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd. More...
void | lcd_writeonepoint (uint16_t color)
this function is write one point to lcd. More...
void | lcd_drawpoint (uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd. More...
void | lcd_clear (uint16_t color)
this function is clear the lcd. More...
void | lcd_char_show (uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode)
this function is show char to lcd More...
void | lcd_string_show (uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p)
this function is show string to lcd More...
void | lcd_fill (uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color)
this function is fill in lcd with concolorous More...
void | lcd_color_fill (uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color)
this function is fill in lcd with color-pointer More...

Variables

lcd_dev_type lcd_dev_struct
lcd_dev_type * lcd_struct
static uint16_t LCD_ID

Detailed Description

xmc_lcd program header

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.


AT32F435/437 Firmwary Library: xmc_lcd.h Source File

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • lcd
at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h
Go to the documentation of this file.
1
26#ifndef __XMC_LCD_H
27#define __XMC_LCD_H
28
29#include "at32f435_437_board.h"
30
43typedef struct
44{
45 uint16_t lcd_id;
46 void (*xmc_init)(void);
47 void (*lcd_init)(void);
48 void (*lcd_setblock)(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend);
49 void (*draw_point)(uint16_t x, uint16_t y, uint16_t color);
50 void (*lcd_clear)(uint16_t color);
51} lcd_dev_type;
52
57extern lcd_dev_type lcd_dev_struct;
58extern lcd_dev_type *lcd_struct;
59
64/* the address of write data & command (xmc_a0) */
65#define XMC_LCD_COMMAND (0x6C000000)
66#define XMC_LCD_DATA (0x6C000800)
78#define LCD_W 320
79#define LCD_H 240
80
81#define LCD_BL_HIGH gpio_bits_set(GPIOC,GPIO_PINS_0)
82#define LCD_BL_LOW gpio_bits_reset(GPIOC,GPIO_PINS_0)
83static uint16_t LCD_ID;
84#define WHITE 0xFFFF
85#define BLACK 0x0000
86#define BLUE 0x001F
87#define BRED 0xF81F
88#define GRED 0xFFE0
89#define GBLUE 0x07FF
90#define RED 0xF800
91#define MAGENTA 0xF81F
92#define GREEN 0x07E0
93#define CYAN 0x7FFF
94#define YELLOW 0xFFE0
95#define BROWN 0xBC40
96#define BRRED 0xFC07
97#define GRAY 0x8430
98
103void xmc_init(void);
104void lcd_init(void);
105void lcd_wr_command(uint16_t command);
106void lcd_wr_data(uint16_t data);
107uint16_t lcd_rd_data(void);
108void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend);
109void lcd_writeonepoint(uint16_t color);
110void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color);
111void lcd_clear(uint16_t color);
112void lcd_char_show(uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode);
113void lcd_string_show(uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p);
114void lcd_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color);
115void lcd_color_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color);
116
129#endif
130
131
at32f435_437_board.h
lcd_dev_struct
lcd_dev_type lcd_dev_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:38
LCD_ID
static uint16_t LCD_ID
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:83
lcd_struct
lcd_dev_type * lcd_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:48
lcd_color_fill
void lcd_color_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color)
this function is fill in lcd with color-pointer
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:529
lcd_setblock
void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:332
lcd_char_show
void lcd_char_show(uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode)
this function is show char to lcd
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:400
lcd_init
void lcd_init(void)
configures the lcd. this function must be called before any write/read operation on the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:165
lcd_string_show
void lcd_string_show(uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p)
this function is show string to lcd
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:474
lcd_fill
void lcd_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color)
this function is fill in lcd with concolorous
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:508
lcd_drawpoint
void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:367
lcd_wr_command
void lcd_wr_command(uint16_t command)
this function is write command to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:300
lcd_rd_data
uint16_t lcd_rd_data(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:315
lcd_clear
void lcd_clear(uint16_t color)
this function is clear the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:379
lcd_writeonepoint
void lcd_writeonepoint(uint16_t color)
this function is write one point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:357
lcd_wr_data
void lcd_wr_data(uint16_t data)
this function is write data to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:310
xmc_init
void xmc_init(void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write...
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:57
lcd_dev_type
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:44
lcd_dev_type::lcd_id
uint16_t lcd_id
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:45


AT32F435/437 Firmwary Library: ov2640.c File Reference

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • ov2640
Macros | Functions | Variables
at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c File Reference
#include "ov2640.h"
#include "ov2640cfg.h"
#include "at32f435_437.h"
#include "i2c_application.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0x2FFFFFF
#define | I2Cx_CLKCTRL 0x30F05292
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_DMA DMA1
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_AF GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_AF GPIO_MUX_4

Functions

error_status | ov2640_reg_write (uint8_t reg, uint8_t data)
write register to ov2640 More...
error_status | ov2640_reg_read (uint8_t reg, uint8_t *data)
read register from ov2640 More...
error_status | ov2640_init (void)
void | ov2640_jpeg_mode (void)
void | ov2640_rgb565_mode (void)
void | ov2640_auto_exposure (u8 level)
void | ov2640_light_mode (u8 mode)
void | ov2640_color_saturation (u8 sat)
void | ov2640_brightness (u8 bright)
void | ov2640_contrast (u8 contrast)
void | ov2640_special_effects (u8 eft)
void | ov2640_color_bar (u8 sw)
void | ov2640_window_set (u16 sx, u16 sy, u16 width, u16 height)
u8 | ov2640_outsize_set (u16 width, u16 height)
u8 | ov2640_imagewin_set (u16 offx, u16 offy, u16 width, u16 height)
u8 | ov2640_imagesize_set (u16 width, u16 height)
void | ov2640_i2c_init (void)
ov2640 i2c initialize More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...

Variables

i2c_handle_type hi2cx
i2c_status_type STA
static const u8 OV2640_AUTOEXPOSURE_LEVEL [5][8]


AT32F435/437 Firmwary Library: ov2640.c Source File

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • ov2640
at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c
Go to the documentation of this file.
1#include "ov2640.h"
2#include "ov2640cfg.h"
3#include "at32f435_437.h"
4#include "i2c_application.h"
5#include "at32f435_437_board.h"
6
15#define I2C_TIMEOUT 0x2FFFFFF
16
17#define I2Cx_CLKCTRL 0x30F05292
18#define I2Cx_ADDRESS 0xA0
19
20#define I2Cx_PORT I2C1
21#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
22#define I2Cx_DMA DMA1
23#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
24
25#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
26#define I2Cx_SCL_GPIO_PIN GPIO_PINS_6
27#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
28#define I2Cx_SCL_GPIO_PORT GPIOB
29#define I2Cx_SCL_GPIO_AF GPIO_MUX_4
30
31#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
32#define I2Cx_SDA_GPIO_PIN GPIO_PINS_7
33#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
34#define I2Cx_SDA_GPIO_PORT GPIOB
35#define I2Cx_SDA_GPIO_AF GPIO_MUX_4
36
37 i2c_handle_type hi2cx;
38 i2c_status_type STA;
39
46 error_status ov2640_reg_write(uint8_t reg, uint8_t data)
47{
48 uint8_t temp_data[2];
49 temp_data[0] = reg;
50 temp_data[1] = data;
51
52 if((STA = i2c_master_transmit(&hi2cx, (uint16_t)OV2640_ADDR, (uint8_t*)temp_data, 2, 1000000)) != I2C_OK)
53 {
54 return ERROR;
55 }
56
57 return SUCCESS;
58}
59
66 error_status ov2640_reg_read(uint8_t reg, uint8_t *data)
67{
68 uint8_t temp_data[1];
69 temp_data[0] = reg;
70
71 if(i2c_master_transmit(&hi2cx, (uint16_t)OV2640_ADDR, (uint8_t*)temp_data, 1, 10000) != I2C_OK)
72 {
73 return ERROR;
74 }
75
76 if(i2c_master_receive(&hi2cx, (uint16_t)OV2640_ADDR, data, 1, 10000) != I2C_OK)
77 {
78 return ERROR;
79 }
80
81 return SUCCESS;
82}
83
84 error_status ov2640_init(void)
85{
86 u16 i=0;
87 uint16_t reg;
88 uint8_t temp;
89 gpio_init_type gpio_initure;
90
91 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
92 gpio_default_para_init(&gpio_initure);
93 /* DVP_RST Pin-PD6 */
94 gpio_initure.gpio_pins = GPIO_PINS_3 | GPIO_PINS_1;
95 gpio_initure.gpio_mode = GPIO_MODE_OUTPUT;
96 gpio_initure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
97 gpio_initure.gpio_pull = GPIO_PULL_UP;
98 gpio_initure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
99 gpio_init(GPIOC, &gpio_initure);
100
101 OV2640_RST_LOW; //POWER ON;
102 delay_ms(10);
103 OV2640_PWRON_LOW;
104 delay_ms(10);
105 OV2640_RST_HIGH;
106 delay_ms(10);
107
108 ov2640_i2c_init();
109 ov2640_reg_write(OV2640_DSP_RA_DLMT, 0x01);
110 ov2640_reg_write(OV2640_SENSOR_COM7, 0x80);
111 delay_ms(50);
112 ov2640_reg_read(OV2640_SENSOR_MIDH, &temp);
113 reg = (uint16_t)temp << 8;
114 ov2640_reg_read(OV2640_SENSOR_MIDL, &temp);
115 reg |= temp;
116 if(reg!=OV2640_MID)
117 {
118 return ERROR;
119 }
120 ov2640_reg_read(OV2640_SENSOR_PIDH, &temp);
121 reg = (uint16_t)temp << 8;
122 ov2640_reg_read(OV2640_SENSOR_PIDL, &temp);
123 reg |= temp;
124 if(reg!=OV2640_PID)
125 {
126 return ERROR;
127 }
128 for(i=0;i<sizeof(ov2640_svga_init_reg_tbl)/2;i++)
129 {
130 ov2640_reg_write(ov2640_svga_init_reg_tbl[i][0],ov2640_svga_init_reg_tbl[i][1]);
131 }
132 return SUCCESS; //ok
133}
134
135//OV2640 jpeg mode
136void ov2640_jpeg_mode(void)
137{
138 u16 i=0;
139
140 for(i=0;i<(sizeof(ov2640_yuv422_reg_tbl)/2);i++)
141 {
142 ov2640_reg_write(ov2640_yuv422_reg_tbl[i][0],ov2640_yuv422_reg_tbl[i][1]);
143 }
144
145 for(i=0;i<(sizeof(ov2640_jpeg_reg_tbl)/2);i++)
146 {
147 ov2640_reg_write(ov2640_jpeg_reg_tbl[i][0],ov2640_jpeg_reg_tbl[i][1]);
148 }
149}
150//OV2640 RGB565 mode
151void ov2640_rgb565_mode(void)
152{
153 u16 i=0;
154 for(i=0;i<(sizeof(ov2640_rgb565_reg_tbl)/2);i++)
155 {
156 ov2640_reg_write(ov2640_rgb565_reg_tbl[i][0],ov2640_rgb565_reg_tbl[i][1]);
157 }
158}
159
160const static u8 OV2640_AUTOEXPOSURE_LEVEL[5][8]=
161{
162 {
163 0xFF,0x01,
164 0x24,0x20,
165 0x25,0x18,
166 0x26,0x60,
167 },
168 {
169 0xFF,0x01,
170 0x24,0x34,
171 0x25,0x1c,
172 0x26,0x00,
173 },
174 {
175 0xFF,0x01,
176 0x24,0x3e,
177 0x25,0x38,
178 0x26,0x81,
179 },
180 {
181 0xFF,0x01,
182 0x24,0x48,
183 0x25,0x40,
184 0x26,0x81,
185 },
186 {
187 0xFF,0x01,
188 0x24,0x58,
189 0x25,0x50,
190 0x26,0x92,
191 },
192};
193
194//level:0~4
195void ov2640_auto_exposure(u8 level)
196{
197 u8 i;
198 u8 *p=(u8*)OV2640_AUTOEXPOSURE_LEVEL[level];
199 for(i=0;i<4;i++)
200 {
201 ov2640_reg_write(p[i*2],p[i*2+1]);
202 }
203}
204
205//0:auto
206//1:sunny
207//2:cloudy
208//3:office
209//4:home
210void ov2640_light_mode(u8 mode)
211{
212 u8 regccval=0X5E;//Sunny
213 u8 regcdval=0X41;
214 u8 regceval=0X54;
215 switch(mode)
216 {
217 case 0://auto
218 ov2640_reg_write(0XFF,0X00);
219 ov2640_reg_write(0XC7,0X10);//AWB ON
220 return;
221 case 2://cloudy
222 regccval=0X65;
223 regcdval=0X41;
224 regceval=0X4F;
225 break;
226 case 3://office
227 regccval=0X52;
228 regcdval=0X41;
229 regceval=0X66;
230 break;
231 case 4://home
232 regccval=0X42;
233 regcdval=0X3F;
234 regceval=0X71;
235 break;
236 }
237 ov2640_reg_write(0XFF,0X00);
238 ov2640_reg_write(0XC7,0X40); //AWB OFF
239 ov2640_reg_write(0XCC,regccval);
240 ov2640_reg_write(0XCD,regcdval);
241 ov2640_reg_write(0XCE,regceval);
242}
243
244//0:-2
245//1:-1
246//2,0
247//3,+1
248//4,+2
249void ov2640_color_saturation(u8 sat)
250{
251 u8 reg7dval=((sat+2)<<4)|0X08;
252 ov2640_reg_write(0XFF,0X00);
253 ov2640_reg_write(0X7C,0X00);
254 ov2640_reg_write(0X7D,0X02);
255 ov2640_reg_write(0X7C,0X03);
256 ov2640_reg_write(0X7D,reg7dval);
257 ov2640_reg_write(0X7D,reg7dval);
258}
259
260//0:(0X00)-2
261//1:(0X10)-1
262//2,(0X20) 0
263//3,(0X30)+1
264//4,(0X40)+2
265void ov2640_brightness(u8 bright)
266{
267 ov2640_reg_write(0xff, 0x00);
268 ov2640_reg_write(0x7c, 0x00);
269 ov2640_reg_write(0x7d, 0x04);
270 ov2640_reg_write(0x7c, 0x09);
271 ov2640_reg_write(0x7d, bright<<4);
272 ov2640_reg_write(0x7d, 0x00);
273}
274
275//0:-2
276//1:-1
277//2,0
278//3,+1
279//4,+2
280void ov2640_contrast(u8 contrast)
281{
282 u8 reg7d0val=0X20;
283 u8 reg7d1val=0X20;
284 switch(contrast)
285 {
286 case 0://-2
287 reg7d0val=0X18;
288 reg7d1val=0X34;
289 break;
290 case 1://-1
291 reg7d0val=0X1C;
292 reg7d1val=0X2A;
293 break;
294 case 3://1
295 reg7d0val=0X24;
296 reg7d1val=0X16;
297 break;
298 case 4://2
299 reg7d0val=0X28;
300 reg7d1val=0X0C;
301 break;
302 }
303 ov2640_reg_write(0xff,0x00);
304 ov2640_reg_write(0x7c,0x00);
305 ov2640_reg_write(0x7d,0x04);
306 ov2640_reg_write(0x7c,0x07);
307 ov2640_reg_write(0x7d,0x20);
308 ov2640_reg_write(0x7d,reg7d0val);
309 ov2640_reg_write(0x7d,reg7d1val);
310 ov2640_reg_write(0x7d,0x06);
311}
312
313void ov2640_special_effects(u8 eft)
314{
315 u8 reg7d0val=0X00;
316 u8 reg7d1val=0X80;
317 u8 reg7d2val=0X80;
318 switch(eft)
319 {
320 case 1://negative film
321 reg7d0val=0X40;
322 break;
323 case 2://black and white
324 reg7d0val=0X18;
325 break;
326 case 3://red
327 reg7d0val=0X18;
328 reg7d1val=0X40;
329 reg7d2val=0XC0;
330 break;
331 case 4://green
332 reg7d0val=0X18;
333 reg7d1val=0X40;
334 reg7d2val=0X40;
335 break;
336 case 5://blue
337 reg7d0val=0X18;
338 reg7d1val=0XA0;
339 reg7d2val=0X40;
340 break;
341 case 6://retro
342 reg7d0val=0X18;
343 reg7d1val=0X40;
344 reg7d2val=0XA6;
345 break;
346 }
347 ov2640_reg_write(0xff,0x00);
348 ov2640_reg_write(0x7c,0x00);
349 ov2640_reg_write(0x7d,reg7d0val);
350 ov2640_reg_write(0x7c,0x05);
351 ov2640_reg_write(0x7d,reg7d1val);
352 ov2640_reg_write(0x7d,reg7d2val);
353}
354
355void ov2640_color_bar(u8 sw)
356{
357 u8 reg;
358 ov2640_reg_write(0XFF,0X01);
359 ov2640_reg_read(0X12, &reg);
360 reg&=~(1<<1);
361 if(sw)reg|=1<<1;
362 ov2640_reg_write(0X12,reg);
363}
364
365void ov2640_window_set(u16 sx,u16 sy,u16 width,u16 height)
366{
367 u16 endx;
368 u16 endy;
369 u8 temp;
370 endx=sx+width/2; //V*2
371 endy=sy+height/2;
372
373 ov2640_reg_write(0XFF,0X01);
374 ov2640_reg_read(0X03, &temp);
375 temp&=0XF0;
376 temp|=((endy&0X03)<<2)|(sy&0X03);
377 ov2640_reg_write(0X03,temp);
378 ov2640_reg_write(0X19,sy>>2);
379 ov2640_reg_write(0X1A,endy>>2);
380
381 ov2640_reg_read(0X32, &temp);
382 temp&=0XC0;
383 temp|=((endx&0X07)<<3)|(sx&0X07);
384 ov2640_reg_write(0X32,temp);
385 ov2640_reg_write(0X17,sx>>3);
386 ov2640_reg_write(0X18,endx>>3);
387}
388
389 u8 ov2640_outsize_set(u16 width,u16 height)
390{
391 u16 outh;
392 u16 outw;
393 u8 temp;
394 if(width%4)return 1;
395 if(height%4)return 2;
396 outw=width/4;
397 outh=height/4;
398 ov2640_reg_write(0XFF,0X00);
399 ov2640_reg_write(0XE0,0X04);
400 ov2640_reg_write(0X5A,outw&0XFF);
401 ov2640_reg_write(0X5B,outh&0XFF);
402 temp=(outw>>8)&0X03;
403 temp|=(outh>>6)&0X04;
404 ov2640_reg_write(0X5C,temp);
405 ov2640_reg_write(0XE0,0X00);
406 return 0;
407}
408
409 u8 ov2640_imagewin_set(u16 offx,u16 offy,u16 width,u16 height)
410{
411 u16 hsize;
412 u16 vsize;
413 u8 temp;
414 if(width%4)return 1;
415 if(height%4)return 2;
416 hsize=width/4;
417 vsize=height/4;
418 ov2640_reg_write(0XFF,0X00);
419 ov2640_reg_write(0XE0,0X04);
420 ov2640_reg_write(0X51,hsize&0XFF);
421 ov2640_reg_write(0X52,vsize&0XFF);
422 ov2640_reg_write(0X53,offx&0XFF);
423 ov2640_reg_write(0X54,offy&0XFF);
424 temp=(vsize>>1)&0X80;
425 temp|=(offy>>4)&0X70;
426 temp|=(hsize>>5)&0X08;
427 temp|=(offx>>8)&0X07;
428 ov2640_reg_write(0X55,temp);
429 ov2640_reg_write(0X57,(hsize>>2)&0X80);
430 ov2640_reg_write(0XE0,0X00);
431 return 0;
432}
433
434 u8 ov2640_imagesize_set(u16 width,u16 height)
435{
436 u8 temp;
437 ov2640_reg_write(0XFF,0X00);
438 ov2640_reg_write(0XE0,0X04);
439 ov2640_reg_write(0XC0,(width)>>3&0XFF);
440 ov2640_reg_write(0XC1,(height)>>3&0XFF);
441 temp=(width&0X07)<<3;
442 temp|=height&0X07;
443 temp|=(width>>4)&0X80;
444 ov2640_reg_write(0X8C,temp);
445 ov2640_reg_write(0XE0,0X00);
446 return 0;
447}
448
454void ov2640_i2c_init(void)
455{
456 hi2cx.i2cx = I2C2;
457 i2c_config(&hi2cx);
458}
459
465void i2c_lowlevel_init(i2c_handle_type* hi2c)
466{
467 gpio_init_type gpio_init_structure;
468
469 /* i2c periph clock enable */
470 crm_periph_clock_enable(CRM_I2C2_PERIPH_CLOCK, TRUE);
471 crm_periph_clock_enable(CRM_GPIOH_PERIPH_CLOCK, TRUE);
472 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
473
474 /* gpio configuration */
475 gpio_pin_mux_config(GPIOH, GPIO_PINS_SOURCE2, GPIO_MUX_4);
476
477 gpio_pin_mux_config(GPIOH, GPIO_PINS_SOURCE3, GPIO_MUX_4);
478
479 gpio_default_para_init(&gpio_init_structure);
480 /* configure i2c pins: scl */
481 gpio_init_structure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
482 gpio_init_structure.gpio_mode = GPIO_MODE_MUX;
483 gpio_init_structure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
484 gpio_init_structure.gpio_pull = GPIO_PULL_UP;
485 gpio_init_structure.gpio_pins = GPIO_PINS_2;
486 gpio_init(GPIOH, &gpio_init_structure);
487
488 gpio_init_structure.gpio_pins = GPIO_PINS_3;
489 gpio_init(GPIOH, &gpio_init_structure);
490
491 /* configure and enable i2c interrupt */
492 nvic_irq_enable(I2C2_EVT_IRQn, 0, 0);
493 nvic_irq_enable(I2C2_ERR_IRQn, 0, 0);
494
495 /* configure and enable i2c dma channel interrupt */
496 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
497 nvic_irq_enable(DMA1_Channel2_IRQn, 0, 0);
498
499 /* i2c dma tx and rx channels configuration */
500 /* enable the dma clock */
501
502 /* i2c dma channel configuration */
503 dma_reset(hi2c->dma_tx_channel);
504 dma_reset(hi2c->dma_rx_channel);
505
506 hi2c->dma_tx_channel = DMA1_CHANNEL1;
507 hi2c->dma_rx_channel = DMA1_CHANNEL2;
508
509 hi2c->dma_init_struct.peripheral_base_addr = (uint32_t)&hi2c->i2cx->txdt;
510 hi2c->dma_init_struct.memory_base_addr = 0;
511 hi2c->dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
512 hi2c->dma_init_struct.buffer_size = 0xFFFF;
513 hi2c->dma_init_struct.peripheral_inc_enable = FALSE;
514 hi2c->dma_init_struct.memory_inc_enable = TRUE;
515 hi2c->dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
516 hi2c->dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
517 hi2c->dma_init_struct.loop_mode_enable = FALSE;
518 hi2c->dma_init_struct.priority = DMA_PRIORITY_LOW;
519
520 dma_init(hi2c->dma_tx_channel, &hi2c->dma_init_struct);
521 dma_init(hi2c->dma_rx_channel, &hi2c->dma_init_struct);
522
523 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_I2C1_TX);
524 dmamux_init(DMA1MUX_CHANNEL2, DMAMUX_DMAREQ_ID_I2C1_RX);
525
526 dmamux_enable(DMA1, TRUE);
527
528 /* config i2c */
529 i2c_init(hi2c->i2cx, 0x0F, I2Cx_CLKCTRL);
530
531 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
532}
533
at32f435_437.h
at32f435_437 header file
at32f435_437_board.h
OV2640_SENSOR_COM7
#define OV2640_SENSOR_COM7
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h:60
OV2640_SENSOR_MIDH
#define OV2640_SENSOR_MIDH
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h:68
OV2640_DSP_RA_DLMT
#define OV2640_DSP_RA_DLMT
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h:47
OV2640_ADDR
#define OV2640_ADDR
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h:10
OV2640_SENSOR_MIDL
#define OV2640_SENSOR_MIDL
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h:69
OV2640_MID
#define OV2640_MID
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h:11
OV2640_RST_LOW
#define OV2640_RST_LOW
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h:6
OV2640_RST_HIGH
#define OV2640_RST_HIGH
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h:5
OV2640_SENSOR_PIDL
#define OV2640_SENSOR_PIDL
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h:55
OV2640_SENSOR_PIDH
#define OV2640_SENSOR_PIDH
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h:54
OV2640_PWRON_LOW
#define OV2640_PWRON_LOW
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h:8
OV2640_PID
#define OV2640_PID
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h:12
ov2640_jpeg_reg_tbl
const u8 ov2640_jpeg_reg_tbl[][2]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h:416
ov2640_svga_init_reg_tbl
const u8 ov2640_svga_init_reg_tbl[][2]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h:213
ov2640_yuv422_reg_tbl
const u8 ov2640_yuv422_reg_tbl[][2]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h:444
ov2640_rgb565_reg_tbl
const u8 ov2640_rgb565_reg_tbl[][2]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h:426
ov2640.h
ov2640cfg.h
STA
i2c_status_type STA
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:38
ov2640_reg_read
error_status ov2640_reg_read(uint8_t reg, uint8_t *data)
read register from ov2640
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:66
ov2640_init
error_status ov2640_init(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:84
ov2640_reg_write
error_status ov2640_reg_write(uint8_t reg, uint8_t data)
write register to ov2640
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:46
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:18
I2Cx_CLKCTRL
#define I2Cx_CLKCTRL
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:17
ov2640_i2c_init
void ov2640_i2c_init(void)
ov2640 i2c initialize
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:454
ov2640_light_mode
void ov2640_light_mode(u8 mode)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:210
ov2640_color_bar
void ov2640_color_bar(u8 sw)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:355
ov2640_auto_exposure
void ov2640_auto_exposure(u8 level)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:195
ov2640_window_set
void ov2640_window_set(u16 sx, u16 sy, u16 width, u16 height)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:365
ov2640_brightness
void ov2640_brightness(u8 bright)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:265
ov2640_special_effects
void ov2640_special_effects(u8 eft)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:313
hi2cx
i2c_handle_type hi2cx
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:37
ov2640_outsize_set
u8 ov2640_outsize_set(u16 width, u16 height)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:389
ov2640_rgb565_mode
void ov2640_rgb565_mode(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:151
i2c_lowlevel_init
void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:465
ov2640_imagesize_set
u8 ov2640_imagesize_set(u16 width, u16 height)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:434
ov2640_jpeg_mode
void ov2640_jpeg_mode(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:136
ov2640_contrast
void ov2640_contrast(u8 contrast)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:280
OV2640_AUTOEXPOSURE_LEVEL
static const u8 OV2640_AUTOEXPOSURE_LEVEL[5][8]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:160
ov2640_imagewin_set
u8 ov2640_imagewin_set(u16 offx, u16 offy, u16 width, u16 height)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:409
ov2640_color_saturation
void ov2640_color_saturation(u8 sat)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:249
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_GPIOH_PERIPH_CLOCK
@ CRM_GPIOH_PERIPH_CLOCK
Definition: at32f435_437_crm.h:112
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
CRM_I2C2_PERIPH_CLOCK
@ CRM_I2C2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:145
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:162
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:172
DMA_PRIORITY_LOW
@ DMA_PRIORITY_LOW
Definition: at32f435_437_dma.h:182
DMAMUX_DMAREQ_ID_I2C1_RX
@ DMAMUX_DMAREQ_ID_I2C1_RX
Definition: at32f435_437_dma.h:216
DMAMUX_DMAREQ_ID_I2C1_TX
@ DMAMUX_DMAREQ_ID_I2C1_TX
Definition: at32f435_437_dma.h:217
DMA1MUX_CHANNEL2
#define DMA1MUX_CHANNEL2
Definition: at32f435_437_dma.h:705
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f435_437_dma.h:697
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
error_status
error_status
Definition: at32f435_437.h:380
u8
uint8_t u8
Definition: at32f435_437.h:364
u16
uint16_t u16
Definition: at32f435_437.h:363
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f435_437_gpio.h:103
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_4
@ GPIO_MUX_4
Definition: at32f435_437_gpio.h:160
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOH
#define GPIOH
Definition: at32f435_437_gpio.h:528
i2c_init
void i2c_init(i2c_type *i2c_x, uint8_t dfilters, uint32_t clk)
init i2c digit filters and clock control register.
Definition: at32f435_437_i2c.c:79
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config i2c own address 1.
Definition: at32f435_437_i2c.c:103
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f435_437_i2c.h:113
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:113
i2c_master_receive
i2c_status_type i2c_master_receive(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through polling mode.
Definition: i2c_application.c:524
i2c_master_transmit
i2c_status_type i2c_master_transmit(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode.
Definition: i2c_application.c:375
i2c_status_type
i2c_status_type
Definition: i2c_application.h:80
I2C_OK
@ I2C_OK
Definition: i2c_application.h:81
I2C2
#define I2C2
Definition: at32f435_437_i2c.h:415
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
DMA1_Channel2_IRQn
@ DMA1_Channel2_IRQn
Definition: at32f435_437.h:205
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f435_437.h:204
I2C2_ERR_IRQn
@ I2C2_ERR_IRQn
Definition: at32f435_437.h:182
I2C2_EVT_IRQn
@ I2C2_EVT_IRQn
Definition: at32f435_437.h:181
i2c_application.h
i2c application libray header file
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
i2c_handle_type
Definition: i2c_application.h:112
i2c_handle_type::dma_rx_channel
dma_channel_type * dma_rx_channel
Definition: i2c_application.h:121
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:113
i2c_handle_type::dma_init_struct
dma_init_type dma_init_struct
Definition: i2c_application.h:122
i2c_handle_type::dma_tx_channel
dma_channel_type * dma_tx_channel
Definition: i2c_application.h:120
i2c_type::txdt
__IO uint32_t txdt
Definition: at32f435_437_i2c.h:400


AT32F435/437 Firmwary Library: ov2640.h File Reference

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • ov2640
Macros | Functions
at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h File Reference
#include "at32f435_437.h"

Go to the source code of this file.

Macros

#define | OV2640_RST_HIGH gpio_bits_set(GPIOC, GPIO_PINS_3);
#define | OV2640_RST_LOW gpio_bits_reset(GPIOC, GPIO_PINS_3);
#define | OV2640_PWRON_HIGH gpio_bits_set(GPIOC, GPIO_PINS_1);
#define | OV2640_PWRON_LOW gpio_bits_reset(GPIOC, GPIO_PINS_1);
#define | OV2640_ADDR 0X60
#define | OV2640_MID 0X7FA2
#define | OV2640_PID 0X2642
#define | OV2640_DSP_R_BYPASS 0x05
#define | OV2640_DSP_Qs 0x44
#define | OV2640_DSP_CTRL 0x50
#define | OV2640_DSP_HSIZE1 0x51
#define | OV2640_DSP_VSIZE1 0x52
#define | OV2640_DSP_XOFFL 0x53
#define | OV2640_DSP_YOFFL 0x54
#define | OV2640_DSP_VHYX 0x55
#define | OV2640_DSP_DPRP 0x56
#define | OV2640_DSP_TEST 0x57
#define | OV2640_DSP_ZMOW 0x5A
#define | OV2640_DSP_ZMOH 0x5B
#define | OV2640_DSP_ZMHH 0x5C
#define | OV2640_DSP_BPADDR 0x7C
#define | OV2640_DSP_BPDATA 0x7D
#define | OV2640_DSP_CTRL2 0x86
#define | OV2640_DSP_CTRL3 0x87
#define | OV2640_DSP_SIZEL 0x8C
#define | OV2640_DSP_HSIZE2 0xC0
#define | OV2640_DSP_VSIZE2 0xC1
#define | OV2640_DSP_CTRL0 0xC2
#define | OV2640_DSP_CTRL1 0xC3
#define | OV2640_DSP_R_DVP_SP 0xD3
#define | OV2640_DSP_IMAGE_MODE 0xDA
#define | OV2640_DSP_RESET 0xE0
#define | OV2640_DSP_MS_SP 0xF0
#define | OV2640_DSP_SS_ID 0x7F
#define | OV2640_DSP_SS_CTRL 0xF8
#define | OV2640_DSP_MC_BIST 0xF9
#define | OV2640_DSP_MC_AL 0xFA
#define | OV2640_DSP_MC_AH 0xFB
#define | OV2640_DSP_MC_D 0xFC
#define | OV2640_DSP_P_STATUS 0xFE
#define | OV2640_DSP_RA_DLMT 0xFF
#define | OV2640_SENSOR_GAIN 0x00
#define | OV2640_SENSOR_COM1 0x03
#define | OV2640_SENSOR_REG04 0x04
#define | OV2640_SENSOR_REG08 0x08
#define | OV2640_SENSOR_COM2 0x09
#define | OV2640_SENSOR_PIDH 0x0A
#define | OV2640_SENSOR_PIDL 0x0B
#define | OV2640_SENSOR_COM3 0x0C
#define | OV2640_SENSOR_COM4 0x0D
#define | OV2640_SENSOR_AEC 0x10
#define | OV2640_SENSOR_CLKRC 0x11
#define | OV2640_SENSOR_COM7 0x12
#define | OV2640_SENSOR_COM8 0x13
#define | OV2640_SENSOR_COM9 0x14
#define | OV2640_SENSOR_COM10 0x15
#define | OV2640_SENSOR_HREFST 0x17
#define | OV2640_SENSOR_HREFEND 0x18
#define | OV2640_SENSOR_VSTART 0x19
#define | OV2640_SENSOR_VEND 0x1A
#define | OV2640_SENSOR_MIDH 0x1C
#define | OV2640_SENSOR_MIDL 0x1D
#define | OV2640_SENSOR_AEW 0x24
#define | OV2640_SENSOR_AEB 0x25
#define | OV2640_SENSOR_W 0x26
#define | OV2640_SENSOR_REG2A 0x2A
#define | OV2640_SENSOR_FRARL 0x2B
#define | OV2640_SENSOR_ADDVSL 0x2D
#define | OV2640_SENSOR_ADDVHS 0x2E
#define | OV2640_SENSOR_YAVG 0x2F
#define | OV2640_SENSOR_REG32 0x32
#define | OV2640_SENSOR_ARCOM2 0x34
#define | OV2640_SENSOR_REG45 0x45
#define | OV2640_SENSOR_FLL 0x46
#define | OV2640_SENSOR_FLH 0x47
#define | OV2640_SENSOR_COM19 0x48
#define | OV2640_SENSOR_ZOOMS 0x49
#define | OV2640_SENSOR_COM22 0x4B
#define | OV2640_SENSOR_COM25 0x4E
#define | OV2640_SENSOR_BD50 0x4F
#define | OV2640_SENSOR_BD60 0x50
#define | OV2640_SENSOR_REG5D 0x5D
#define | OV2640_SENSOR_REG5E 0x5E
#define | OV2640_SENSOR_REG5F 0x5F
#define | OV2640_SENSOR_REG60 0x60
#define | OV2640_SENSOR_HISTO_LOW 0x61
#define | OV2640_SENSOR_HISTO_HIGH 0x62

Functions

error_status | ov2640_reg_write (uint8_t reg, uint8_t data)
write register to ov2640 More...
error_status | ov2640_reg_read (uint8_t reg, uint8_t *data)
read register from ov2640 More...
error_status | ov2640_init (void)
void | ov2640_jpeg_mode (void)
void | ov2640_rgb565_mode (void)
void | ov2640_auto_exposure (u8 level)
void | ov2640_light_mode (u8 mode)
void | ov2640_color_saturation (u8 sat)
void | ov2640_brightness (u8 bright)
void | ov2640_contrast (u8 contrast)
void | ov2640_special_effects (u8 eft)
void | ov2640_color_bar (u8 sw)
void | ov2640_window_set (u16 sx, u16 sy, u16 width, u16 height)
u8 | ov2640_outsize_set (u16 width, u16 height)
u8 | ov2640_imagewin_set (u16 offx, u16 offy, u16 width, u16 height)
u8 | ov2640_imagesize_set (u16 width, u16 height)
void | ov2640_i2c_init (void)
ov2640 i2c initialize More...

Macro Definition Documentation

◆ OV2640_ADDR

#define OV2640_ADDR 0X60

Definition at line 10 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_BPADDR

#define OV2640_DSP_BPADDR 0x7C

Definition at line 27 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_BPDATA

#define OV2640_DSP_BPDATA 0x7D

Definition at line 28 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_CTRL

#define OV2640_DSP_CTRL 0x50

Definition at line 16 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_CTRL0

#define OV2640_DSP_CTRL0 0xC2

Definition at line 34 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_CTRL1

#define OV2640_DSP_CTRL1 0xC3

Definition at line 35 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_CTRL2

#define OV2640_DSP_CTRL2 0x86

Definition at line 29 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_CTRL3

#define OV2640_DSP_CTRL3 0x87

Definition at line 30 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_DPRP

#define OV2640_DSP_DPRP 0x56

Definition at line 22 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_HSIZE1

#define OV2640_DSP_HSIZE1 0x51

Definition at line 17 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_HSIZE2

#define OV2640_DSP_HSIZE2 0xC0

Definition at line 32 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_IMAGE_MODE

#define OV2640_DSP_IMAGE_MODE 0xDA

Definition at line 37 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_MC_AH

#define OV2640_DSP_MC_AH 0xFB

Definition at line 44 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_MC_AL

#define OV2640_DSP_MC_AL 0xFA

Definition at line 43 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_MC_BIST

#define OV2640_DSP_MC_BIST 0xF9

Definition at line 42 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_MC_D

#define OV2640_DSP_MC_D 0xFC

Definition at line 45 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_MS_SP

#define OV2640_DSP_MS_SP 0xF0

Definition at line 39 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_P_STATUS

#define OV2640_DSP_P_STATUS 0xFE

Definition at line 46 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_Qs

#define OV2640_DSP_Qs 0x44

Definition at line 15 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_R_BYPASS

#define OV2640_DSP_R_BYPASS 0x05

Definition at line 14 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_R_DVP_SP

#define OV2640_DSP_R_DVP_SP 0xD3

Definition at line 36 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_RA_DLMT

#define OV2640_DSP_RA_DLMT 0xFF

Definition at line 47 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_RESET

#define OV2640_DSP_RESET 0xE0

Definition at line 38 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_SIZEL

#define OV2640_DSP_SIZEL 0x8C

Definition at line 31 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_SS_CTRL

#define OV2640_DSP_SS_CTRL 0xF8

Definition at line 41 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_SS_ID

#define OV2640_DSP_SS_ID 0x7F

Definition at line 40 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_TEST

#define OV2640_DSP_TEST 0x57

Definition at line 23 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_VHYX

#define OV2640_DSP_VHYX 0x55

Definition at line 21 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_VSIZE1

#define OV2640_DSP_VSIZE1 0x52

Definition at line 18 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_VSIZE2

#define OV2640_DSP_VSIZE2 0xC1

Definition at line 33 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_XOFFL

#define OV2640_DSP_XOFFL 0x53

Definition at line 19 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_YOFFL

#define OV2640_DSP_YOFFL 0x54

Definition at line 20 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_ZMHH

#define OV2640_DSP_ZMHH 0x5C

Definition at line 26 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_ZMOH

#define OV2640_DSP_ZMOH 0x5B

Definition at line 25 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_ZMOW

#define OV2640_DSP_ZMOW 0x5A

Definition at line 24 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_MID

#define OV2640_MID 0X7FA2

Definition at line 11 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_PID

#define OV2640_PID 0X2642

Definition at line 12 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_PWRON_HIGH

#define OV2640_PWRON_HIGH gpio_bits_set(GPIOC, GPIO_PINS_1);

Definition at line 7 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_PWRON_LOW

#define OV2640_PWRON_LOW gpio_bits_reset(GPIOC, GPIO_PINS_1);

Definition at line 8 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_RST_HIGH

#define OV2640_RST_HIGH gpio_bits_set(GPIOC, GPIO_PINS_3);

Definition at line 5 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_RST_LOW

#define OV2640_RST_LOW gpio_bits_reset(GPIOC, GPIO_PINS_3);

Definition at line 6 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_ADDVHS

#define OV2640_SENSOR_ADDVHS 0x2E

Definition at line 76 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_ADDVSL

#define OV2640_SENSOR_ADDVSL 0x2D

Definition at line 75 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_AEB

#define OV2640_SENSOR_AEB 0x25

Definition at line 71 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_AEC

#define OV2640_SENSOR_AEC 0x10

Definition at line 58 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_AEW

#define OV2640_SENSOR_AEW 0x24

Definition at line 70 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_ARCOM2

#define OV2640_SENSOR_ARCOM2 0x34

Definition at line 79 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_BD50

#define OV2640_SENSOR_BD50 0x4F

Definition at line 87 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_BD60

#define OV2640_SENSOR_BD60 0x50

Definition at line 88 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_CLKRC

#define OV2640_SENSOR_CLKRC 0x11

Definition at line 59 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_COM1

#define OV2640_SENSOR_COM1 0x03

Definition at line 50 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_COM10

#define OV2640_SENSOR_COM10 0x15

Definition at line 63 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_COM19

#define OV2640_SENSOR_COM19 0x48

Definition at line 83 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_COM2

#define OV2640_SENSOR_COM2 0x09

Definition at line 53 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_COM22

#define OV2640_SENSOR_COM22 0x4B

Definition at line 85 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_COM25

#define OV2640_SENSOR_COM25 0x4E

Definition at line 86 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_COM3

#define OV2640_SENSOR_COM3 0x0C

Definition at line 56 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_COM4

#define OV2640_SENSOR_COM4 0x0D

Definition at line 57 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_COM7

#define OV2640_SENSOR_COM7 0x12

Definition at line 60 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_COM8

#define OV2640_SENSOR_COM8 0x13

Definition at line 61 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_COM9

#define OV2640_SENSOR_COM9 0x14

Definition at line 62 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_FLH

#define OV2640_SENSOR_FLH 0x47

Definition at line 82 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_FLL

#define OV2640_SENSOR_FLL 0x46

Definition at line 81 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_FRARL

#define OV2640_SENSOR_FRARL 0x2B

Definition at line 74 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_GAIN

#define OV2640_SENSOR_GAIN 0x00

Definition at line 49 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_HISTO_HIGH

#define OV2640_SENSOR_HISTO_HIGH 0x62

Definition at line 94 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_HISTO_LOW

#define OV2640_SENSOR_HISTO_LOW 0x61

Definition at line 93 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_HREFEND

#define OV2640_SENSOR_HREFEND 0x18

Definition at line 65 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_HREFST

#define OV2640_SENSOR_HREFST 0x17

Definition at line 64 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_MIDH

#define OV2640_SENSOR_MIDH 0x1C

Definition at line 68 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_MIDL

#define OV2640_SENSOR_MIDL 0x1D

Definition at line 69 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_PIDH

#define OV2640_SENSOR_PIDH 0x0A

Definition at line 54 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_PIDL

#define OV2640_SENSOR_PIDL 0x0B

Definition at line 55 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_REG04

#define OV2640_SENSOR_REG04 0x04

Definition at line 51 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_REG08

#define OV2640_SENSOR_REG08 0x08

Definition at line 52 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_REG2A

#define OV2640_SENSOR_REG2A 0x2A

Definition at line 73 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_REG32

#define OV2640_SENSOR_REG32 0x32

Definition at line 78 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_REG45

#define OV2640_SENSOR_REG45 0x45

Definition at line 80 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_REG5D

#define OV2640_SENSOR_REG5D 0x5D

Definition at line 89 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_REG5E

#define OV2640_SENSOR_REG5E 0x5E

Definition at line 90 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_REG5F

#define OV2640_SENSOR_REG5F 0x5F

Definition at line 91 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_REG60

#define OV2640_SENSOR_REG60 0x60

Definition at line 92 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_VEND

#define OV2640_SENSOR_VEND 0x1A

Definition at line 67 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_VSTART

#define OV2640_SENSOR_VSTART 0x19

Definition at line 66 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_W

#define OV2640_SENSOR_W 0x26

Definition at line 72 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_YAVG

#define OV2640_SENSOR_YAVG 0x2F

Definition at line 77 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_ZOOMS

#define OV2640_SENSOR_ZOOMS 0x49

Definition at line 84 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.


AT32F435/437 Firmwary Library: ov2640.h Source File

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • ov2640
at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
Go to the documentation of this file.
1#ifndef _OV2640_H
2#define _OV2640_H
3#include "at32f435_437.h"
4
5#define OV2640_RST_HIGH gpio_bits_set(GPIOC, GPIO_PINS_3);
6#define OV2640_RST_LOW gpio_bits_reset(GPIOC, GPIO_PINS_3);
7#define OV2640_PWRON_HIGH gpio_bits_set(GPIOC, GPIO_PINS_1);
8#define OV2640_PWRON_LOW gpio_bits_reset(GPIOC, GPIO_PINS_1);
9
10#define OV2640_ADDR 0X60 //OV2640 ID
11#define OV2640_MID 0X7FA2
12#define OV2640_PID 0X2642
13
14#define OV2640_DSP_R_BYPASS 0x05
15#define OV2640_DSP_Qs 0x44
16#define OV2640_DSP_CTRL 0x50
17#define OV2640_DSP_HSIZE1 0x51
18#define OV2640_DSP_VSIZE1 0x52
19#define OV2640_DSP_XOFFL 0x53
20#define OV2640_DSP_YOFFL 0x54
21#define OV2640_DSP_VHYX 0x55
22#define OV2640_DSP_DPRP 0x56
23#define OV2640_DSP_TEST 0x57
24#define OV2640_DSP_ZMOW 0x5A
25#define OV2640_DSP_ZMOH 0x5B
26#define OV2640_DSP_ZMHH 0x5C
27#define OV2640_DSP_BPADDR 0x7C
28#define OV2640_DSP_BPDATA 0x7D
29#define OV2640_DSP_CTRL2 0x86
30#define OV2640_DSP_CTRL3 0x87
31#define OV2640_DSP_SIZEL 0x8C
32#define OV2640_DSP_HSIZE2 0xC0
33#define OV2640_DSP_VSIZE2 0xC1
34#define OV2640_DSP_CTRL0 0xC2
35#define OV2640_DSP_CTRL1 0xC3
36#define OV2640_DSP_R_DVP_SP 0xD3
37#define OV2640_DSP_IMAGE_MODE 0xDA
38#define OV2640_DSP_RESET 0xE0
39#define OV2640_DSP_MS_SP 0xF0
40#define OV2640_DSP_SS_ID 0x7F
41#define OV2640_DSP_SS_CTRL 0xF8
42#define OV2640_DSP_MC_BIST 0xF9
43#define OV2640_DSP_MC_AL 0xFA
44#define OV2640_DSP_MC_AH 0xFB
45#define OV2640_DSP_MC_D 0xFC
46#define OV2640_DSP_P_STATUS 0xFE
47#define OV2640_DSP_RA_DLMT 0xFF
48
49#define OV2640_SENSOR_GAIN 0x00
50#define OV2640_SENSOR_COM1 0x03
51#define OV2640_SENSOR_REG04 0x04
52#define OV2640_SENSOR_REG08 0x08
53#define OV2640_SENSOR_COM2 0x09
54#define OV2640_SENSOR_PIDH 0x0A
55#define OV2640_SENSOR_PIDL 0x0B
56#define OV2640_SENSOR_COM3 0x0C
57#define OV2640_SENSOR_COM4 0x0D
58#define OV2640_SENSOR_AEC 0x10
59#define OV2640_SENSOR_CLKRC 0x11
60#define OV2640_SENSOR_COM7 0x12
61#define OV2640_SENSOR_COM8 0x13
62#define OV2640_SENSOR_COM9 0x14
63#define OV2640_SENSOR_COM10 0x15
64#define OV2640_SENSOR_HREFST 0x17
65#define OV2640_SENSOR_HREFEND 0x18
66#define OV2640_SENSOR_VSTART 0x19
67#define OV2640_SENSOR_VEND 0x1A
68#define OV2640_SENSOR_MIDH 0x1C
69#define OV2640_SENSOR_MIDL 0x1D
70#define OV2640_SENSOR_AEW 0x24
71#define OV2640_SENSOR_AEB 0x25
72#define OV2640_SENSOR_W 0x26
73#define OV2640_SENSOR_REG2A 0x2A
74#define OV2640_SENSOR_FRARL 0x2B
75#define OV2640_SENSOR_ADDVSL 0x2D
76#define OV2640_SENSOR_ADDVHS 0x2E
77#define OV2640_SENSOR_YAVG 0x2F
78#define OV2640_SENSOR_REG32 0x32
79#define OV2640_SENSOR_ARCOM2 0x34
80#define OV2640_SENSOR_REG45 0x45
81#define OV2640_SENSOR_FLL 0x46
82#define OV2640_SENSOR_FLH 0x47
83#define OV2640_SENSOR_COM19 0x48
84#define OV2640_SENSOR_ZOOMS 0x49
85#define OV2640_SENSOR_COM22 0x4B
86#define OV2640_SENSOR_COM25 0x4E
87#define OV2640_SENSOR_BD50 0x4F
88#define OV2640_SENSOR_BD60 0x50
89#define OV2640_SENSOR_REG5D 0x5D
90#define OV2640_SENSOR_REG5E 0x5E
91#define OV2640_SENSOR_REG5F 0x5F
92#define OV2640_SENSOR_REG60 0x60
93#define OV2640_SENSOR_HISTO_LOW 0x61
94#define OV2640_SENSOR_HISTO_HIGH 0x62
95
96 error_status ov2640_reg_write(uint8_t reg, uint8_t data);
97 error_status ov2640_reg_read(uint8_t reg, uint8_t *data);
98 error_status ov2640_init(void);
99void ov2640_jpeg_mode(void);
100void ov2640_rgb565_mode(void);
101void ov2640_auto_exposure(u8 level);
102void ov2640_light_mode(u8 mode);
103void ov2640_color_saturation(u8 sat);
104void ov2640_brightness(u8 bright);
105void ov2640_contrast(u8 contrast);
106void ov2640_special_effects(u8 eft);
107void ov2640_color_bar(u8 sw);
108void ov2640_window_set(u16 sx,u16 sy,u16 width,u16 height);
109 u8 ov2640_outsize_set(u16 width,u16 height);
110 u8 ov2640_imagewin_set(u16 offx,u16 offy,u16 width,u16 height);
111 u8 ov2640_imagesize_set(u16 width,u16 height);
112void ov2640_i2c_init(void);
113
114#endif
at32f435_437.h
at32f435_437 header file
ov2640_reg_read
error_status ov2640_reg_read(uint8_t reg, uint8_t *data)
read register from ov2640
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:66
ov2640_init
error_status ov2640_init(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:84
ov2640_reg_write
error_status ov2640_reg_write(uint8_t reg, uint8_t data)
write register to ov2640
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:46
ov2640_i2c_init
void ov2640_i2c_init(void)
ov2640 i2c initialize
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:454
ov2640_light_mode
void ov2640_light_mode(u8 mode)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:210
ov2640_color_bar
void ov2640_color_bar(u8 sw)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:355
ov2640_auto_exposure
void ov2640_auto_exposure(u8 level)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:195
ov2640_window_set
void ov2640_window_set(u16 sx, u16 sy, u16 width, u16 height)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:365
ov2640_brightness
void ov2640_brightness(u8 bright)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:265
ov2640_special_effects
void ov2640_special_effects(u8 eft)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:313
ov2640_outsize_set
u8 ov2640_outsize_set(u16 width, u16 height)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:389
ov2640_rgb565_mode
void ov2640_rgb565_mode(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:151
ov2640_imagesize_set
u8 ov2640_imagesize_set(u16 width, u16 height)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:434
ov2640_jpeg_mode
void ov2640_jpeg_mode(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:136
ov2640_contrast
void ov2640_contrast(u8 contrast)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:280
ov2640_imagewin_set
u8 ov2640_imagewin_set(u16 offx, u16 offy, u16 width, u16 height)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:409
ov2640_color_saturation
void ov2640_color_saturation(u8 sat)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:249
error_status
error_status
Definition: at32f435_437.h:380
u8
uint8_t u8
Definition: at32f435_437.h:364
u16
uint16_t u16
Definition: at32f435_437.h:363


AT32F435/437 Firmwary Library: ov2640cfg.h File Reference

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • ov2640
Variables
at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h File Reference
#include "ov2640.h"

Go to the source code of this file.

Variables

const u8 | ov2640_sxga_init_reg_tbl [][2]
const u8 | ov2640_svga_init_reg_tbl [][2]
const u8 | ov2640_jpeg_reg_tbl [][2]
const u8 | ov2640_rgb565_reg_tbl [][2]
const u8 | ov2640_yuv422_reg_tbl [][2]

Variable Documentation

◆ ov2640_jpeg_reg_tbl

const u8 ov2640_jpeg_reg_tbl[][2]
Initial value:
=
{
0xff, 0x01,
0xe0, 0x14,
0xe1, 0x77,
0xe5, 0x1f,
0xd7, 0x03,
0xda, 0x10,
0xe0, 0x00,
}

Definition at line 416 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h.

Referenced by ov2640_jpeg_mode().

◆ ov2640_rgb565_reg_tbl

const u8 ov2640_rgb565_reg_tbl[][2]
Initial value:
=
{
0xFF, 0x00,
0xDA, 0x09,
0xD7, 0x03,
0xDF, 0x02,
0x33, 0xa0,
0x3C, 0x00,
0xe1, 0x67,
0xff, 0x01,
0xe0, 0x00,
0xe1, 0x00,
0xe5, 0x00,
0xd7, 0x00,
0xda, 0x00,
0xe0, 0x00,
}

Definition at line 426 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h.

Referenced by ov2640_rgb565_mode().

◆ ov2640_svga_init_reg_tbl

const u8 ov2640_svga_init_reg_tbl[][2]

Definition at line 213 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h.

Referenced by ov2640_init().

◆ ov2640_sxga_init_reg_tbl

const u8 ov2640_sxga_init_reg_tbl[][2]

Definition at line 5 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h.

◆ ov2640_yuv422_reg_tbl

const u8 ov2640_yuv422_reg_tbl[][2]
Initial value:
=
{
0xFF, 0x00,
0xDA, 0x10,
0xD7, 0x03,
0xDF, 0x00,
0x33, 0x80,
0x3C, 0x40,
0xe1, 0x77,
0x00, 0x00,
}

Definition at line 444 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h.

Referenced by ov2640_jpeg_mode().


AT32F435/437 Firmwary Library: ov2640cfg.h Source File

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • ov2640
at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h
Go to the documentation of this file.
1#ifndef _OV2640CFG_H
2#define _OV2640CFG_H
3#include "ov2640.h"
4
5const u8 ov2640_sxga_init_reg_tbl[][2]=
6{
7 0xff, 0x00,
8 0x2c, 0xff,
9 0x2e, 0xdf,
10 0xff, 0x01,
11 0x3c, 0x32,
12 //
13 0x11, 0x00,
14 0x09, 0x02,
15 0x04, 0xD8,
16 0x13, 0xe5,
17 0x14, 0x48,
18 0x2c, 0x0c,
19 0x33, 0x78,
20 0x3a, 0x33,
21 0x3b, 0xfB,
22 //
23 0x3e, 0x00,
24 0x43, 0x11,
25 0x16, 0x10,
26 //
27 0x39, 0x92,
28 //
29 0x35, 0xda,
30 0x22, 0x1a,
31 0x37, 0xc3,
32 0x23, 0x00,
33 0x34, 0xc0,
34 0x36, 0x1a,
35 0x06, 0x88,
36 0x07, 0xc0,
37 0x0d, 0x87,
38 0x0e, 0x41,
39 0x4c, 0x00,
40
41 0x48, 0x00,
42 0x5B, 0x00,
43 0x42, 0x03,
44 //
45 0x4a, 0x81,
46 0x21, 0x99,
47 //
48 0x24, 0x40,
49 0x25, 0x38,
50 0x26, 0x82,
51 0x5c, 0x00,
52 0x63, 0x00,
53 0x46, 0x00,
54 0x0c, 0x3c,
55 //
56 0x61, 0x70,
57 0x62, 0x80,
58 0x7c, 0x05,
59 //
60 0x20, 0x80,
61 0x28, 0x30,
62 0x6c, 0x00,
63 0x6d, 0x80,
64 0x6e, 0x00,
65 0x70, 0x02,
66 0x71, 0x94,
67 0x73, 0xc1,
68 0x3d, 0x34,
69 0x5a, 0x57,
70 //
71 0x12, 0x00,//UXGA 1600*1200
72
73 0x17, 0x11,
74 0x18, 0x75,
75 0x19, 0x01,
76 0x1a, 0x97,
77 0x32, 0x36,
78 0x03, 0x0f,
79 0x37, 0x40,
80 //
81 0x4f, 0xca,
82 0x50, 0xa8,
83 0x5a, 0x23,
84 0x6d, 0x00,
85 0x6d, 0x38,
86 //
87 0xff, 0x00,
88 0xe5, 0x7f,
89 0xf9, 0xc0,
90 0x41, 0x24,
91 0xe0, 0x14,
92 0x76, 0xff,
93 0x33, 0xa0,
94 0x42, 0x20,
95 0x43, 0x18,
96 0x4c, 0x00,
97 0x87, 0xd5,
98 0x88, 0x3f,
99 0xd7, 0x03,
100 0xd9, 0x10,
101 0xd3, 0x82,
102 //
103 0xc8, 0x08,
104 0xc9, 0x80,
105 //
106 0x7c, 0x00,
107 0x7d, 0x00,
108 0x7c, 0x03,
109 0x7d, 0x48,
110 0x7d, 0x48,
111 0x7c, 0x08,
112 0x7d, 0x20,
113 0x7d, 0x10,
114 0x7d, 0x0e,
115 //
116 0x90, 0x00,
117 0x91, 0x0e,
118 0x91, 0x1a,
119 0x91, 0x31,
120 0x91, 0x5a,
121 0x91, 0x69,
122 0x91, 0x75,
123 0x91, 0x7e,
124 0x91, 0x88,
125 0x91, 0x8f,
126 0x91, 0x96,
127 0x91, 0xa3,
128 0x91, 0xaf,
129 0x91, 0xc4,
130 0x91, 0xd7,
131 0x91, 0xe8,
132 0x91, 0x20,
133 //
134 0x92, 0x00,
135 0x93, 0x06,
136 0x93, 0xe3,
137 0x93, 0x05,
138 0x93, 0x05,
139 0x93, 0x00,
140 0x93, 0x04,
141 0x93, 0x00,
142 0x93, 0x00,
143 0x93, 0x00,
144 0x93, 0x00,
145 0x93, 0x00,
146 0x93, 0x00,
147 0x93, 0x00,
148 //
149 0x96, 0x00,
150 0x97, 0x08,
151 0x97, 0x19,
152 0x97, 0x02,
153 0x97, 0x0c,
154 0x97, 0x24,
155 0x97, 0x30,
156 0x97, 0x28,
157 0x97, 0x26,
158 0x97, 0x02,
159 0x97, 0x98,
160 0x97, 0x80,
161 0x97, 0x00,
162 0x97, 0x00,
163 //
164 0xc3, 0xef,
165
166 0xa4, 0x00,
167 0xa8, 0x00,
168 0xc5, 0x11,
169 0xc6, 0x51,
170 0xbf, 0x80,
171 0xc7, 0x10,
172 0xb6, 0x66,
173 0xb8, 0xA5,
174 0xb7, 0x64,
175 0xb9, 0x7C,
176 0xb3, 0xaf,
177 0xb4, 0x97,
178 0xb5, 0xFF,
179 0xb0, 0xC5,
180 0xb1, 0x94,
181 0xb2, 0x0f,
182 0xc4, 0x5c,
183 //
184 0xc0, 0xc8,
185 0xc1, 0x96,
186 0x8c, 0x00,
187 0x86, 0x3d,
188 0x50, 0x00,
189 0x51, 0x90,
190 0x52, 0x2c,
191 0x53, 0x00,
192 0x54, 0x00,
193 0x55, 0x88,
194
195 0x5a, 0x90,
196 0x5b, 0x2C,
197 0x5c, 0x05,
198
199 0xd3, 0x02,//auto
200 //
201 0xc3, 0xed,
202 0x7f, 0x00,
203
204 0xda, 0x09,
205
206 0xe5, 0x1f,
207 0xe1, 0x67,
208 0xe0, 0x00,
209 0xdd, 0x7f,
210 0x05, 0x00,
211};
212
213const u8 ov2640_svga_init_reg_tbl[][2]=
214{
215 0xff, 0x00,
216 0x2c, 0xff,
217 0x2e, 0xdf,
218 0xff, 0x01,
219 0x3c, 0x32,
220 //
221 0x11, 0x00,
222 0x09, 0x02,
223 0x04, 0xD8,
224 0x13, 0xe5,
225 0x14, 0x48,
226 0x2c, 0x0c,
227 0x33, 0x78,
228 0x3a, 0x33,
229 0x3b, 0xfB,
230 //
231 0x3e, 0x00,
232 0x43, 0x11,
233 0x16, 0x10,
234 //
235 0x39, 0x92,
236 //
237 0x35, 0xda,
238 0x22, 0x1a,
239 0x37, 0xc3,
240 0x23, 0x00,
241 0x34, 0xc0,
242 0x36, 0x1a,
243 0x06, 0x88,
244 0x07, 0xc0,
245 0x0d, 0x87,
246 0x0e, 0x41,
247 0x4c, 0x00,
248 0x48, 0x00,
249 0x5B, 0x00,
250 0x42, 0x03,
251 //
252 0x4a, 0x81,
253 0x21, 0x99,
254 //
255 0x24, 0x40,
256 0x25, 0x38,
257 0x26, 0x82,
258 0x5c, 0x00,
259 0x63, 0x00,
260 0x46, 0x22,
261 0x0c, 0x3c,
262 //
263 0x61, 0x70,
264 0x62, 0x80,
265 0x7c, 0x05,
266 //
267 0x20, 0x80,
268 0x28, 0x30,
269 0x6c, 0x00,
270 0x6d, 0x80,
271 0x6e, 0x00,
272 0x70, 0x02,
273 0x71, 0x94,
274 0x73, 0xc1,
275
276 0x3d, 0x34,
277 0x5a, 0x57,
278
279 0x12, 0x40,//SVGA 800*600
280 0x17, 0x11,
281 0x18, 0x43,
282 0x19, 0x00,
283 0x1a, 0x4b,
284 0x32, 0x09,
285 0x37, 0xc0,
286 //
287 0x4f, 0xca,
288 0x50, 0xa8,
289 0x5a, 0x23,
290 0x6d, 0x00,
291 0x3d, 0x38,
292 //
293 0xff, 0x00,
294 0xe5, 0x7f,
295 0xf9, 0xc0,
296 0x41, 0x24,
297 0xe0, 0x14,
298 0x76, 0xff,
299 0x33, 0xa0,
300 0x42, 0x20,
301 0x43, 0x18,
302 0x4c, 0x00,
303 0x87, 0xd5,
304 0x88, 0x3f,
305 0xd7, 0x03,
306 0xd9, 0x10,
307 0xd3, 0x82,
308 //
309 0xc8, 0x08,
310 0xc9, 0x80,
311 //
312 0x7c, 0x00,
313 0x7d, 0x00,
314 0x7c, 0x03,
315 0x7d, 0x48,
316 0x7d, 0x48,
317 0x7c, 0x08,
318 0x7d, 0x20,
319 0x7d, 0x10,
320 0x7d, 0x0e,
321 //
322 0x90, 0x00,
323 0x91, 0x0e,
324 0x91, 0x1a,
325 0x91, 0x31,
326 0x91, 0x5a,
327 0x91, 0x69,
328 0x91, 0x75,
329 0x91, 0x7e,
330 0x91, 0x88,
331 0x91, 0x8f,
332 0x91, 0x96,
333 0x91, 0xa3,
334 0x91, 0xaf,
335 0x91, 0xc4,
336 0x91, 0xd7,
337 0x91, 0xe8,
338 0x91, 0x20,
339 //
340 0x92, 0x00,
341 0x93, 0x06,
342 0x93, 0xe3,
343 0x93, 0x05,
344 0x93, 0x05,
345 0x93, 0x00,
346 0x93, 0x04,
347 0x93, 0x00,
348 0x93, 0x00,
349 0x93, 0x00,
350 0x93, 0x00,
351 0x93, 0x00,
352 0x93, 0x00,
353 0x93, 0x00,
354 //
355 0x96, 0x00,
356 0x97, 0x08,
357 0x97, 0x19,
358 0x97, 0x02,
359 0x97, 0x0c,
360 0x97, 0x24,
361 0x97, 0x30,
362 0x97, 0x28,
363 0x97, 0x26,
364 0x97, 0x02,
365 0x97, 0x98,
366 0x97, 0x80,
367 0x97, 0x00,
368 0x97, 0x00,
369 //
370 0xc3, 0xed,
371 0xa4, 0x00,
372 0xa8, 0x00,
373 0xc5, 0x11,
374 0xc6, 0x51,
375 0xbf, 0x80,
376 0xc7, 0x10,
377 0xb6, 0x66,
378 0xb8, 0xA5,
379 0xb7, 0x64,
380 0xb9, 0x7C,
381 0xb3, 0xaf,
382 0xb4, 0x97,
383 0xb5, 0xFF,
384 0xb0, 0xC5,
385 0xb1, 0x94,
386 0xb2, 0x0f,
387 0xc4, 0x5c,
388
389 0xc0, 0x64,
390 0xc1, 0x4B,
391 0x8c, 0x00,
392 0x86, 0x3D,
393 0x50, 0x00,
394 0x51, 0xC8,
395 0x52, 0x96,
396 0x53, 0x00,
397 0x54, 0x00,
398 0x55, 0x00,
399 0x5a, 0xC8,
400 0x5b, 0x96,
401 0x5c, 0x00,
402
403 0xd3, 0x02,//auto
404 //
405 0xc3, 0xed,
406 0x7f, 0x00,
407
408 0xda, 0x09,
409
410 0xe5, 0x1f,
411 0xe1, 0x67,
412 0xe0, 0x00,
413 0xdd, 0x7f,
414 0x05, 0x00,
415};
416const u8 ov2640_jpeg_reg_tbl[][2]=
417{
418 0xff, 0x01,
419 0xe0, 0x14,
420 0xe1, 0x77,
421 0xe5, 0x1f,
422 0xd7, 0x03,
423 0xda, 0x10,
424 0xe0, 0x00,
425};
426const u8 ov2640_rgb565_reg_tbl[][2]=
427{
428 0xFF, 0x00,
429 0xDA, 0x09,
430 0xD7, 0x03,
431 0xDF, 0x02,
432 0x33, 0xa0,
433 0x3C, 0x00,
434 0xe1, 0x67,
435
436 0xff, 0x01,
437 0xe0, 0x00,
438 0xe1, 0x00,
439 0xe5, 0x00,
440 0xd7, 0x00,
441 0xda, 0x00,
442 0xe0, 0x00,
443};
444const u8 ov2640_yuv422_reg_tbl[][2]=
445{
446 0xFF, 0x00,
447 0xDA, 0x10,
448 0xD7, 0x03,
449 0xDF, 0x00,
450 0x33, 0x80,
451 0x3C, 0x40,
452 0xe1, 0x77,
453 0x00, 0x00,
454};
455
456#endif
ov2640_jpeg_reg_tbl
const u8 ov2640_jpeg_reg_tbl[][2]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h:416
ov2640_sxga_init_reg_tbl
const u8 ov2640_sxga_init_reg_tbl[][2]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h:5
ov2640_svga_init_reg_tbl
const u8 ov2640_svga_init_reg_tbl[][2]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h:213
ov2640_yuv422_reg_tbl
const u8 ov2640_yuv422_reg_tbl[][2]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h:444
ov2640_rgb565_reg_tbl
const u8 ov2640_rgb565_reg_tbl[][2]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h:426
ov2640.h
u8
uint8_t u8
Definition: at32f435_437.h:364


AT32F435/437 Firmwary Library: sccb.c File Reference

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • ov2640
Functions
at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c File Reference
#include "sys.h"
#include "sccb.h"
#include "delay.h"

Go to the source code of this file.

Functions

void | SCCB_Init (void)
void | SCCB_Start (void)
void | SCCB_Stop (void)
void | SCCB_No_Ack (void)
u8 | SCCB_WR_Byte (u8 dat)
u8 | SCCB_RD_Byte (void)
u8 | SCCB_WR_Reg (u8 reg, u8 data)
u8 | SCCB_RD_Reg (u8 reg)

Function Documentation

◆ SCCB_Init()

void SCCB_Init ( void )

Definition at line 18 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

◆ SCCB_No_Ack()

void SCCB_No_Ack ( void )

Definition at line 58 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

Referenced by SCCB_RD_Reg().

◆ SCCB_RD_Byte()

u8 SCCB_RD_Byte ( void )

Definition at line 97 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

Referenced by SCCB_RD_Reg().

◆ SCCB_RD_Reg()

u8 SCCB_RD_Reg ( u8 reg )

Definition at line 129 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

◆ SCCB_Start()

void SCCB_Start ( void )

Definition at line 35 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

Referenced by SCCB_RD_Reg(), and SCCB_WR_Reg().

◆ SCCB_Stop()

void SCCB_Stop ( void )

Definition at line 48 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

Referenced by SCCB_RD_Reg(), and SCCB_WR_Reg().

◆ SCCB_WR_Byte()

u8 SCCB_WR_Byte ( u8 dat )

Definition at line 71 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

Referenced by SCCB_RD_Reg(), and SCCB_WR_Reg().

◆ SCCB_WR_Reg()

u8 SCCB_WR_Reg | ( | u8 | reg,
 |  | u8 | data
 | ) |  |

Definition at line 115 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.


AT32F435/437 Firmwary Library: sccb.c Source File

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • ov2640
at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c
Go to the documentation of this file.
1#include "sys.h"
2#include "sccb.h"
3#include "delay.h"
5//本程序只供学习使用，未经作者许可，不得用于其它任何用途
6//ALIENTEK STM32F407开发板
7//OV系列摄像头 SCCB 驱动代码
8//正点原子@ALIENTEK
9//技术论坛:www.openedv.com
10//创建日期:2014/5/14
11//版本：V1.0
12//版权所有，盗版必究。
13//Copyright(C) 广州市星翼电子科技有限公司 2014-2024
14//All rights reserved
16
17//初始化SCCB接口
18void SCCB_Init(void)
19{
20 GPIO_InitTypeDef GPIO_Initure;
21 __HAL_RCC_GPIOB_CLK_ENABLE(); //使能GPIOB时钟
22
23 //PB3.4初始化设置
24 GPIO_Initure.Pin=GPIO_PIN_3|GPIO_PIN_4;
25 GPIO_Initure.Mode=GPIO_MODE_OUTPUT_PP; //推挽输出
26 GPIO_Initure.Pull=GPIO_PULLUP; //上拉
27 GPIO_Initure.Speed=GPIO_SPEED_FAST; //快速
28 HAL_GPIO_Init(GPIOB,&GPIO_Initure);
29 SCCB_SDA_OUT();
30}
31
32//SCCB起始信号
33//当时钟为高的时候,数据线的高到低,为SCCB起始信号
34//在激活状态下,SDA和SCL均为低电平
35void SCCB_Start(void)
36{
37 SCCB_SDA=1; //数据线高电平
38 SCCB_SCL=1; //在时钟线高的时候数据线由高至低
39 delay_us(50);
40 SCCB_SDA=0;
41 delay_us(50);
42 SCCB_SCL=0; //数据线恢复低电平，单操作函数必要
43}
44
45//SCCB停止信号
46//当时钟为高的时候,数据线的低到高,为SCCB停止信号
47//空闲状况下,SDA,SCL均为高电平
48void SCCB_Stop(void)
49{
50 SCCB_SDA=0;
51 delay_us(50);
52 SCCB_SCL=1;
53 delay_us(50);
54 SCCB_SDA=1;
55 delay_us(50);
56}
57//产生NA信号
58void SCCB_No_Ack(void)
59{
60 delay_us(50);
61 SCCB_SDA=1;
62 SCCB_SCL=1;
63 delay_us(50);
64 SCCB_SCL=0;
65 delay_us(50);
66 SCCB_SDA=0;
67 delay_us(50);
68}
69//SCCB,写入一个字节
70//返回值:0,成功;1,失败.
71 u8 SCCB_WR_Byte(u8 dat)
72{
73 u8 j,res;
74 for(j=0;j<8;j++) //循环8次发送数据
75 {
76 if(dat&0x80)SCCB_SDA=1;
77 else SCCB_SDA=0;
78 dat<<=1;
79 delay_us(50);
80 SCCB_SCL=1;
81 delay_us(50);
82 SCCB_SCL=0;
83 }
84 SCCB_SDA_IN(); //设置SDA为输入
85 delay_us(50);
86 SCCB_SCL=1; //接收第九位,以判断是否发送成功
87 delay_us(50);
88 if(SCCB_READ_SDA)res=1; //SDA=1发送失败，返回1
89 else res=0; //SDA=0发送成功，返回0
90 SCCB_SCL=0;
91 SCCB_SDA_OUT(); //设置SDA为输出
92 return res;
93}
94//SCCB 读取一个字节
95//在SCL的上升沿,数据锁存
96//返回值:读到的数据
97 u8 SCCB_RD_Byte(void)
98{
99 u8 temp=0,j;
100 SCCB_SDA_IN(); //设置SDA为输入
101 for(j=8;j>0;j--) //循环8次接收数据
102 {
103 delay_us(50);
104 SCCB_SCL=1;
105 temp=temp<<1;
106 if(SCCB_READ_SDA)temp++;
107 delay_us(50);
108 SCCB_SCL=0;
109 }
110 SCCB_SDA_OUT(); //设置SDA为输出
111 return temp;
112}
113//写寄存器
114//返回值:0,成功;1,失败.
115 u8 SCCB_WR_Reg(u8 reg,u8 data)
116{
117 u8 res=0;
118 SCCB_Start(); //启动SCCB传输
119 if(SCCB_WR_Byte(SCCB_ID))res=1; //写器件ID
120 delay_us(100);
121 if(SCCB_WR_Byte(reg))res=1; //写寄存器地址
122 delay_us(100);
123 if(SCCB_WR_Byte(data))res=1; //写数据
124 SCCB_Stop();
125 return res;
126}
127//读寄存器
128//返回值:读到的寄存器值
129 u8 SCCB_RD_Reg(u8 reg)
130{
131 u8 val=0;
132 SCCB_Start(); //启动SCCB传输
133 SCCB_WR_Byte(SCCB_ID); //写器件ID
134 delay_us(100);
135 SCCB_WR_Byte(reg); //写寄存器地址
136 delay_us(100);
137 SCCB_Stop();
138 delay_us(100);
139 //设置寄存器地址后，才是读
140 SCCB_Start();
141 SCCB_WR_Byte(SCCB_ID|0X01); //发送读命令
142 delay_us(100);
143 val=SCCB_RD_Byte(); //读取数据
144 SCCB_No_Ack();
145 SCCB_Stop();
146 return val;
147}
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
SCCB_No_Ack
void SCCB_No_Ack(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:58
SCCB_Init
void SCCB_Init(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:18
SCCB_RD_Byte
u8 SCCB_RD_Byte(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:97
SCCB_WR_Reg
u8 SCCB_WR_Reg(u8 reg, u8 data)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:115
SCCB_Stop
void SCCB_Stop(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:48
SCCB_Start
void SCCB_Start(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:35
SCCB_RD_Reg
u8 SCCB_RD_Reg(u8 reg)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:129
SCCB_WR_Byte
u8 SCCB_WR_Byte(u8 dat)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:71
SCCB_READ_SDA
#define SCCB_READ_SDA
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h:23
SCCB_ID
#define SCCB_ID
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h:25
SCCB_SDA_IN
#define SCCB_SDA_IN()
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h:17
SCCB_SDA_OUT
#define SCCB_SDA_OUT()
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h:18
SCCB_SCL
#define SCCB_SCL
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h:21
SCCB_SDA
#define SCCB_SDA
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h:22
sccb.h
j
uint32_t j
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:44
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f435_437_board.c:306
u8
uint8_t u8
Definition: at32f435_437.h:364
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522


AT32F435/437 Firmwary Library: sccb.h File Reference

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • ov2640
Macros | Functions
at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h File Reference
#include "sys.h"

Go to the source code of this file.

Macros

#define | SCCB_SDA_IN() {GPIOB->MODER&=~(3<<(3*2));GPIOB->MODER|=0<<3*2;}
#define | SCCB_SDA_OUT() {GPIOB->MODER&=~(3<<(3*2));GPIOB->MODER|=1<<3*2;}
#define | SCCB_SCL PBout(4)
#define | SCCB_SDA PBout(3)
#define | SCCB_READ_SDA PBin(3)
#define | SCCB_ID 0X60

Functions

void | SCCB_Init (void)
void | SCCB_Start (void)
void | SCCB_Stop (void)
void | SCCB_No_Ack (void)
u8 | SCCB_WR_Byte (u8 dat)
u8 | SCCB_RD_Byte (void)
u8 | SCCB_WR_Reg (u8 reg, u8 data)
u8 | SCCB_RD_Reg (u8 reg)

Macro Definition Documentation

◆ SCCB_ID

#define SCCB_ID 0X60

Definition at line 25 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h.

◆ SCCB_READ_SDA

#define SCCB_READ_SDA PBin(3)

Definition at line 23 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h.

◆ SCCB_SCL

#define SCCB_SCL PBout(4)

Definition at line 21 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h.

◆ SCCB_SDA

#define SCCB_SDA PBout(3)

Definition at line 22 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h.

◆ SCCB_SDA_IN

#define SCCB_SDA_IN ( ) {GPIOB->MODER&=~(3<<(3*2));GPIOB->MODER|=0<<3*2;}

Definition at line 17 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h.

◆ SCCB_SDA_OUT

#define SCCB_SDA_OUT ( ) {GPIOB->MODER&=~(3<<(3*2));GPIOB->MODER|=1<<3*2;}

Definition at line 18 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h.

Function Documentation

◆ SCCB_Init()

void SCCB_Init ( void )

Definition at line 18 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

◆ SCCB_No_Ack()

void SCCB_No_Ack ( void )

Definition at line 58 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

◆ SCCB_RD_Byte()

u8 SCCB_RD_Byte ( void )

Definition at line 97 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

◆ SCCB_RD_Reg()

u8 SCCB_RD_Reg ( u8 reg )

Definition at line 129 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

◆ SCCB_Start()

void SCCB_Start ( void )

Definition at line 35 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

◆ SCCB_Stop()

void SCCB_Stop ( void )

Definition at line 48 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

◆ SCCB_WR_Byte()

u8 SCCB_WR_Byte ( u8 dat )

Definition at line 71 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

◆ SCCB_WR_Reg()

u8 SCCB_WR_Reg | ( | u8 | reg,
 |  | u8 | data
 | ) |  |

Definition at line 115 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.


AT32F435/437 Firmwary Library: sccb.h Source File

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • ov2640
at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
Go to the documentation of this file.
1#ifndef __SCCB_H
2#define __SCCB_H
3#include "sys.h"
5//本程序只供学习使用，未经作者许可，不得用于其它任何用途
6//ALIENTEK STM32F407开发板
7//OV系列摄像头 SCCB 驱动代码
8//正点原子@ALIENTEK
9//技术论坛:www.openedv.com
10//创建日期:2014/5/14
11//版本：V1.0
12//版权所有，盗版必究。
13//Copyright(C) 广州市星翼电子科技有限公司 2014-2024
14//All rights reserved
16//IO方向设置
17#define SCCB_SDA_IN() {GPIOB->MODER&=~(3<<(3*2));GPIOB->MODER|=0<<3*2;} //PB3输入模式
18#define SCCB_SDA_OUT() {GPIOB->MODER&=~(3<<(3*2));GPIOB->MODER|=1<<3*2;} //PB3输出模式
19
20//IO操作
21#define SCCB_SCL PBout(4) //SCL
22#define SCCB_SDA PBout(3) //SDA
23#define SCCB_READ_SDA PBin(3) //输入SDA
24
25#define SCCB_ID 0X60 //OV2640的ID
26
28void SCCB_Init(void);
29void SCCB_Start(void);
30void SCCB_Stop(void);
31void SCCB_No_Ack(void);
32 u8 SCCB_WR_Byte(u8 dat);
33 u8 SCCB_RD_Byte(void);
34 u8 SCCB_WR_Reg(u8 reg,u8 data);
35 u8 SCCB_RD_Reg(u8 reg);
36#endif
37
38
39
40
41
42
43
44
45
46
47
48
49
SCCB_No_Ack
void SCCB_No_Ack(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:58
SCCB_Init
void SCCB_Init(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:18
SCCB_RD_Byte
u8 SCCB_RD_Byte(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:97
SCCB_WR_Reg
u8 SCCB_WR_Reg(u8 reg, u8 data)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:115
SCCB_Stop
void SCCB_Stop(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:48
SCCB_Start
void SCCB_Start(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:35
SCCB_RD_Reg
u8 SCCB_RD_Reg(u8 reg)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:129
SCCB_WR_Byte
u8 SCCB_WR_Byte(u8 dat)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:71
u8
uint8_t u8
Definition: at32f435_437.h:364


AT32F435/437 Firmwary Library: dvp.c File Reference

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • dvp
Data Structures | Functions | Variables
at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c File Reference

dvp program More...

#include "at32f435_437.h"
#include "dvp.h"
#include "xmc_lcd.h"
#include "ov5640.h"

Go to the source code of this file.

Data Structures

struct Descriptors_Format_def

Functions

void | jpeg_data_process (void)
void | dvp_int_handler (void)
handles dvp interrupt request. More...
void | dvp_config (void)
configure dvp More...
void | dvp_io_init (void)
initialize gpio for dvp More...
void | dvp_dma_init (uint32_t mem0addr, uint32_t mem1addr, uint16_t memsize)
initialize dma for dvp More...
void | dvp_start (void)
start dvp transmission More...
void | dvp_stop (void)
stop dvp transmission More...
void | DVP_IRQHandler (void)
dvp irq handler More...
void | dvp_frame_done (void)
dvp frame transmit done More...
void | EDMA_Stream4_IRQHandler (void)
edma stream4 irq handler More...

Variables

edma_init_type edma_init_struct
uint8_t ov_frame = 0

Detailed Description

dvp program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c.


AT32F435/437 Firmwary Library: dvp.c Source File

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • dvp
at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c
Go to the documentation of this file.
1
27#include "at32f435_437.h"
28#include "dvp.h"
29#include "xmc_lcd.h"
30#include "ov5640.h"
31
40 edma_init_type edma_init_struct;
41uint8_t ov_frame = 0;
42
43extern void jpeg_data_process(void);
44void dvp_int_handler(void);
45
46typedef struct
47{
48 uint32_t CR_NDT;
49 uint32_t PA;
50 uint32_t M0A;
51 uint32_t LLP;
52
53}Descriptors_Format_def;
54
60void dvp_config(void)
61{
62 dvp_io_init();
63
64 nvic_irq_enable(DVP_IRQn, 0, 0);
65
66 dvp_capture_mode_set(DVP_CAP_FUNC_MODE_CONTINUOUS);
67 dvp_hsync_polarity_set(DVP_HSYNC_POLARITY_LOW);
68 dvp_vsync_polarity_set(DVP_VSYNC_POLARITY_LOW);
69 dvp_pclk_polarity_set(DVP_CLK_POLARITY_RISING);
70 dvp_zoomout_set(DVP_PCDC_ALL, DVP_PCDS_CAP_FIRST, DVP_LCDC_ALL, DVP_LCDS_CAP_FIRST);
71 dvp_zoomout_select(DVP_PCDES_CAP_FIRST);
72 dvp_pixel_data_length_set(DVP_PIXEL_DATA_LENGTH_8);
73#ifdef HARDWARE_MODE
74 dvp_sync_mode_set(DVP_SYNC_MODE_HARDWARE);
75#else
76 dvp_sync_mode_set(DVP_SYNC_MODE_EMBEDDED);
77 dvp_sync_code_set(0xFF, 0xFF, 0xC7, 0xDA);
78#endif
79
80 /* enable the interrupts */
81 dvp_interrupt_enable(DVP_CFD_INT | DVP_OVR_INT | DVP_ESE_INT | DVP_VS_INT | DVP_HS_INT, TRUE);
82
83 /* enable dvp by setting dvpen bit */
84 dvp_enable(TRUE);
85}
86
92void dvp_io_init(void)
93{
94 gpio_init_type gpio_initure;
95
96 crm_periph_clock_enable(CRM_DVP_PERIPH_CLOCK, TRUE);
97 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
98 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
99 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
100
101 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE4, GPIO_MUX_13);//HS
102 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE6, GPIO_MUX_13);//PCLK
103 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE9, GPIO_MUX_13);//D0
104 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE10, GPIO_MUX_13);//D1
105 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE11, GPIO_MUX_13);//D2
106 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE12, GPIO_MUX_13);//D3
107 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE4, GPIO_MUX_13);//D5
108 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE7, GPIO_MUX_13);//VS
109 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE9, GPIO_MUX_13);//D7
110 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE4, GPIO_MUX_13);//D4
111 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE5, GPIO_MUX_13);//D6
112
113 gpio_initure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_6 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11 | GPIO_PINS_12;
114 gpio_initure.gpio_mode = GPIO_MODE_MUX;
115 gpio_initure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
116 gpio_initure.gpio_pull = GPIO_PULL_UP;
117 gpio_initure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
118 gpio_init(GPIOA, &gpio_initure);
119
120 gpio_initure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_7 | GPIO_PINS_9;
121 gpio_init(GPIOB, &gpio_initure);
122
123 gpio_initure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5;
124 gpio_init(GPIOE, &gpio_initure);
125}
126
136void dvp_dma_init(uint32_t mem0addr, uint32_t mem1addr, uint16_t memsize)
137{
138 crm_periph_clock_enable(CRM_EDMA_PERIPH_CLOCK, TRUE);
139
140 edma_init_struct.peripheral_base_addr = (uint32_t)&DVP->dt;
141 edma_init_struct.memory0_base_addr = (uint32_t)mem0addr;
142 edma_init_struct.buffer_size = memsize;
143 edma_init_struct.direction = EDMA_DIR_PERIPHERAL_TO_MEMORY;
144 edma_init_struct.peripheral_inc_enable = FALSE;
145 edma_init_struct.memory_inc_enable = FALSE;
146 edma_init_struct.peripheral_data_width = EDMA_PERIPHERAL_DATA_WIDTH_WORD;
147 edma_init_struct.memory_data_width = EDMA_MEMORY_DATA_WIDTH_HALFWORD;
148 edma_init_struct.loop_mode_enable = TRUE;
149 edma_init_struct.priority = EDMA_PRIORITY_HIGH;
150 edma_init_struct.fifo_mode_enable = TRUE;
151 edma_init_struct.fifo_threshold = EDMA_FIFO_THRESHOLD_FULL;
152 edma_init_struct.memory_burst_mode = EDMA_MEMORY_SINGLE;
153 edma_init_struct.peripheral_burst_mode = EDMA_PERIPHERAL_SINGLE;
154
155 edma_reset(EDMA_STREAM4);
156 edma_init(EDMA_STREAM4, &edma_init_struct);
157
158 edmamux_enable(TRUE);
159 edmamux_init(EDMAMUX_CHANNEL4, EDMAMUX_DMAREQ_ID_DVP);
160
161 if(mem1addr != 0)
162 {
163 edma_double_buffer_mode_init(EDMA_STREAM4, mem1addr, EDMA_MEMORY_0);
164 edma_double_buffer_mode_enable(EDMA_STREAM4, TRUE);
165 }
166
167 edma_interrupt_enable(EDMA_STREAM4, EDMA_FDT_INT, TRUE);
168 nvic_irq_enable(EDMA_Stream4_IRQn, 0, 0);
169}
170
176void dvp_start(void)
177{
178 lcd_struct->lcd_setblock(0, 0, LCD_W, LCD_H);
179 edma_stream_enable(EDMA_STREAM4, TRUE);
180 dvp_capture_enable(TRUE);
181}
182
188void dvp_stop(void)
189{
190 dvp_capture_enable(FALSE);
191
192 while(DVP->ctrl & 0x01);
193
194 edma_stream_enable(EDMA_STREAM4, FALSE);
195}
196
202void DVP_IRQHandler(void)
203{
204 dvp_int_handler();
205}
206
212void dvp_frame_done(void)
213{
214 lcd_struct->lcd_setblock(0, 0, LCD_W, LCD_H);
215 ov_frame++;
216}
217
223void EDMA_Stream4_IRQHandler(void)
224{
225 if(edma_flag_get(EDMA_FDT4_FLAG) != RESET)
226 {
227 edma_flag_clear(EDMA_FDT4_FLAG);
228 }
229}
230
236void dvp_int_handler(void)
237{
238 /* synchronization error interrupt management */
239 if(dvp_flag_get(DVP_ESE_INT_FLAG) != RESET)
240 {
241 /* clear the synchronization error flag */
242 dvp_flag_clear(DVP_ESE_INT_FLAG);
243 }
244
245 /* overflow interrupt management */
246 if(dvp_flag_get(DVP_OVR_INT_FLAG) != RESET)
247 {
248 /* clear the overflow flag */
249 dvp_flag_clear(DVP_OVR_INT_FLAG);
250 }
251
252 /* line interrupt management */
253 if(dvp_flag_get(DVP_HS_INT_FLAG) != RESET)
254 {
255 /* clear the line interrupt flag */
256 dvp_flag_clear(DVP_HS_INT_FLAG);
257 }
258
259 /* vsync interrupt management */
260 if(dvp_flag_get(DVP_VS_INT_FLAG) != RESET)
261 {
262 /* clear the vsync flag */
263 dvp_flag_clear(DVP_VS_INT_FLAG);
264 }
265
266 /* end of frame interrupt management */
267 if(dvp_flag_get(DVP_CFD_INT_FLAG) != RESET)
268 {
269 /* clear the end of frame flag */
270 dvp_flag_clear(DVP_CFD_INT_FLAG);
271
272 dvp_frame_done();
273 }
274}
275
at32f435_437.h
at32f435_437 header file
dvp.h
header file of dvp program
LCD_H
#define LCD_H
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:79
LCD_W
#define LCD_W
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:78
lcd_struct
lcd_dev_type * lcd_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:48
dvp_stop
void dvp_stop(void)
stop dvp transmission
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c:188
dvp_io_init
void dvp_io_init(void)
initialize gpio for dvp
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c:92
edma_init_struct
edma_init_type edma_init_struct
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c:40
dvp_frame_done
void dvp_frame_done(void)
dvp frame transmit done
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c:212
dvp_start
void dvp_start(void)
start dvp transmission
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c:176
DVP_IRQHandler
void DVP_IRQHandler(void)
dvp irq handler
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c:202
ov_frame
uint8_t ov_frame
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c:41
dvp_int_handler
void dvp_int_handler(void)
handles dvp interrupt request.
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c:236
dvp_dma_init
void dvp_dma_init(uint32_t mem0addr, uint32_t mem1addr, uint16_t memsize)
initialize dma for dvp
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c:136
dvp_config
void dvp_config(void)
configure dvp
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c:60
EDMA_Stream4_IRQHandler
void EDMA_Stream4_IRQHandler(void)
edma stream4 irq handler
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c:223
jpeg_data_process
void jpeg_data_process(void)
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_EDMA_PERIPH_CLOCK
@ CRM_EDMA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:114
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_DVP_PERIPH_CLOCK
@ CRM_DVP_PERIPH_CLOCK
Definition: at32f435_437_crm.h:119
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
dvp_capture_mode_set
void dvp_capture_mode_set(dvp_cfm_type cap_mode)
set dvp capture mode
Definition: at32f435_437_dvp.c:73
dvp_capture_enable
void dvp_capture_enable(confirm_state new_state)
enable or disable dvp capture
Definition: at32f435_437_dvp.c:60
dvp_flag_get
flag_status dvp_flag_get(uint32_t flag)
get dvp event/interrupt flag status
Definition: at32f435_437_dvp.c:342
dvp_sync_code_set
void dvp_sync_code_set(uint8_t fmsc, uint8_t fmec, uint8_t lnsc, uint8_t lnec)
set dvp synchronization code configuration
Definition: at32f435_437_dvp.c:135
dvp_pixel_data_length_set
void dvp_pixel_data_length_set(dvp_pdl_type dvp_pdl)
config dvp pixel data length
Definition: at32f435_437_dvp.c:217
dvp_hsync_polarity_set
void dvp_hsync_polarity_set(dvp_hsp_type hsync_pol)
set dvp horizontal synchronization polarity
Definition: at32f435_437_dvp.c:174
dvp_zoomout_select
void dvp_zoomout_select(dvp_pcdes_type dvp_pcdes)
set dvp zoomout select
Definition: at32f435_437_dvp.c:240
dvp_sync_mode_set
void dvp_sync_mode_set(dvp_sm_type sync_mode)
set dvp synchronization mode
Definition: at32f435_437_dvp.c:122
dvp_vsync_polarity_set
void dvp_vsync_polarity_set(dvp_vsp_type vsync_pol)
set dvp vertical synchronization polarity
Definition: at32f435_437_dvp.c:187
dvp_zoomout_set
void dvp_zoomout_set(dvp_pcdc_type dvp_pcdc, dvp_pcds_type dvp_pcds, dvp_lcdc_type dvp_lcdc, dvp_lcds_type dvp_lcds)
set dvp zoomout configuration
Definition: at32f435_437_dvp.c:267
dvp_interrupt_enable
void dvp_interrupt_enable(uint32_t dvp_int, confirm_state new_state)
enable or disable dvp interrupt
Definition: at32f435_437_dvp.c:312
dvp_enable
void dvp_enable(confirm_state new_state)
enable or disable dvp function
Definition: at32f435_437_dvp.c:227
dvp_pclk_polarity_set
void dvp_pclk_polarity_set(dvp_ckp_type eage)
set dvp pixel clock polarity
Definition: at32f435_437_dvp.c:161
dvp_flag_clear
void dvp_flag_clear(uint32_t flag)
clear dvp's pending flags
Definition: at32f435_437_dvp.c:388
DVP_VSYNC_POLARITY_LOW
@ DVP_VSYNC_POLARITY_LOW
Definition: at32f435_437_dvp.h:137
DVP_PIXEL_DATA_LENGTH_8
@ DVP_PIXEL_DATA_LENGTH_8
Definition: at32f435_437_dvp.h:156
DVP_SYNC_MODE_EMBEDDED
@ DVP_SYNC_MODE_EMBEDDED
Definition: at32f435_437_dvp.h:111
DVP_SYNC_MODE_HARDWARE
@ DVP_SYNC_MODE_HARDWARE
Definition: at32f435_437_dvp.h:110
DVP_HSYNC_POLARITY_LOW
@ DVP_HSYNC_POLARITY_LOW
Definition: at32f435_437_dvp.h:129
DVP_CAP_FUNC_MODE_CONTINUOUS
@ DVP_CAP_FUNC_MODE_CONTINUOUS
Definition: at32f435_437_dvp.h:101
DVP_PCDES_CAP_FIRST
@ DVP_PCDES_CAP_FIRST
Definition: at32f435_437_dvp.h:215
DVP_CLK_POLARITY_RISING
@ DVP_CLK_POLARITY_RISING
Definition: at32f435_437_dvp.h:119
DVP_LCDS_CAP_FIRST
@ DVP_LCDS_CAP_FIRST
Definition: at32f435_437_dvp.h:196
DVP_LCDC_ALL
@ DVP_LCDC_ALL
Definition: at32f435_437_dvp.h:187
DVP_PCDC_ALL
@ DVP_PCDC_ALL
Definition: at32f435_437_dvp.h:167
DVP_PCDS_CAP_FIRST
@ DVP_PCDS_CAP_FIRST
Definition: at32f435_437_dvp.h:178
DVP_VS_INT_FLAG
#define DVP_VS_INT_FLAG
Definition: at32f435_437_dvp.h:70
DVP_HS_INT_FLAG
#define DVP_HS_INT_FLAG
Definition: at32f435_437_dvp.h:71
DVP_CFD_INT_FLAG
#define DVP_CFD_INT_FLAG
Definition: at32f435_437_dvp.h:67
DVP_ESE_INT_FLAG
#define DVP_ESE_INT_FLAG
Definition: at32f435_437_dvp.h:69
DVP_OVR_INT_FLAG
#define DVP_OVR_INT_FLAG
Definition: at32f435_437_dvp.h:68
DVP_ESE_INT
#define DVP_ESE_INT
Definition: at32f435_437_dvp.h:84
DVP_VS_INT
#define DVP_VS_INT
Definition: at32f435_437_dvp.h:85
DVP_HS_INT
#define DVP_HS_INT
Definition: at32f435_437_dvp.h:86
DVP_OVR_INT
#define DVP_OVR_INT
Definition: at32f435_437_dvp.h:83
DVP_CFD_INT
#define DVP_CFD_INT
Definition: at32f435_437_dvp.h:82
DVP
#define DVP
Definition: at32f435_437_dvp.h:569
edma_flag_get
flag_status edma_flag_get(uint32_t edma_flag)
get the edma flag.
Definition: at32f435_437_edma.c:512
edma_flag_clear
void edma_flag_clear(uint32_t edma_flag)
clear the edma flag.
Definition: at32f435_437_edma.c:549
edma_double_buffer_mode_init
void edma_double_buffer_mode_init(edma_stream_type *edma_streamx, uint32_t memory1_addr, edma_memory_type current_memory)
config the the double buffer mode.
Definition: at32f435_437_edma.c:354
edmamux_init
void edmamux_init(edmamux_channel_type *edmamux_channelx, edmamux_requst_id_sel_type edmamux_req_id)
edmamux init.
Definition: at32f435_437_edma.c:718
edma_init
void edma_init(edma_stream_type *edma_streamx, edma_init_type *edma_init_struct)
edma init.
Definition: at32f435_437_edma.c:115
edma_double_buffer_mode_enable
void edma_double_buffer_mode_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the double memory mode.
Definition: at32f435_437_edma.c:383
edma_stream_enable
void edma_stream_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx.
Definition: at32f435_437_edma.c:198
edma_reset
void edma_reset(edma_stream_type *edma_streamx)
reset edma_streamx channely register.
Definition: at32f435_437_edma.c:58
edmamux_enable
void edmamux_enable(confirm_state new_state)
enable or disable the edma edmamux.
Definition: at32f435_437_edma.c:673
edma_interrupt_enable
void edma_interrupt_enable(edma_stream_type *edma_streamx, uint32_t edma_int, confirm_state new_state)
enable or disable the edma streamx interrupts.
Definition: at32f435_437_edma.c:225
EDMA_PRIORITY_HIGH
@ EDMA_PRIORITY_HIGH
Definition: at32f435_437_edma.h:191
EDMA_PERIPHERAL_DATA_WIDTH_WORD
@ EDMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_edma.h:171
EDMA_MEMORY_DATA_WIDTH_HALFWORD
@ EDMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_edma.h:180
EDMA_MEMORY_SINGLE
@ EDMA_MEMORY_SINGLE
Definition: at32f435_437_edma.h:224
EDMA_PERIPHERAL_SINGLE
@ EDMA_PERIPHERAL_SINGLE
Definition: at32f435_437_edma.h:235
EDMA_FIFO_THRESHOLD_FULL
@ EDMA_FIFO_THRESHOLD_FULL
Definition: at32f435_437_edma.h:203
EDMA_MEMORY_0
@ EDMA_MEMORY_0
Definition: at32f435_437_edma.h:150
EDMA_DIR_PERIPHERAL_TO_MEMORY
@ EDMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_edma.h:159
EDMAMUX_DMAREQ_ID_DVP
@ EDMAMUX_DMAREQ_ID_DVP
Definition: at32f435_437_edma.h:349
EDMA_FDT4_FLAG
#define EDMA_FDT4_FLAG
Definition: at32f435_437_edma.h:86
EDMA_FDT_INT
#define EDMA_FDT_INT
Definition: at32f435_437_edma.h:55
EDMA_STREAM4
#define EDMA_STREAM4
Definition: at32f435_437_edma.h:965
EDMAMUX_CHANNEL4
#define EDMAMUX_CHANNEL4
Definition: at32f435_437_edma.h:992
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_13
@ GPIO_MUX_13
Definition: at32f435_437_gpio.h:169
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
DVP_IRQn
@ DVP_IRQn
Definition: at32f435_437.h:221
EDMA_Stream4_IRQn
@ EDMA_Stream4_IRQn
Definition: at32f435_437.h:160
Descriptors_Format_def
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:47
edma_init_type
edma init type
Definition: at32f435_437_edma.h:440
edma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_edma.h:441
edma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_edma.h:444
edma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_edma.h:446
edma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_edma.h:445
edma_init_type::direction
edma_dir_type direction
Definition: at32f435_437_edma.h:443
edma_init_type::fifo_mode_enable
confirm_state fifo_mode_enable
Definition: at32f435_437_edma.h:451
edma_init_type::peripheral_data_width
edma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_edma.h:447
edma_init_type::fifo_threshold
edma_fifo_threshold_type fifo_threshold
Definition: at32f435_437_edma.h:452
edma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_edma.h:449
edma_init_type::priority
edma_priority_level_type priority
Definition: at32f435_437_edma.h:450
edma_init_type::memory0_base_addr
uint32_t memory0_base_addr
Definition: at32f435_437_edma.h:442
edma_init_type::peripheral_burst_mode
edma_peripheral_burst_type peripheral_burst_mode
Definition: at32f435_437_edma.h:454
edma_init_type::memory_data_width
edma_memory_data_size_type memory_data_width
Definition: at32f435_437_edma.h:448
edma_init_type::memory_burst_mode
edma_memory_burst_type memory_burst_mode
Definition: at32f435_437_edma.h:453
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
lcd_dev_type::lcd_setblock
void(* lcd_setblock)(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:48


AT32F435/437 Firmwary Library: dvp.h File Reference

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • dvp
Functions | Variables
at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.h File Reference

header file of dvp program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | dvp_config (void)
configure dvp More...
void | dvp_dma_init (uint32_t mem0addr, uint32_t mem1addr, uint16_t memsize)
initialize dma for dvp More...
void | dvp_start (void)
start dvp transmission More...
void | dvp_stop (void)
stop dvp transmission More...
void | dvp_io_init (void)
initialize gpio for dvp More...

Variables

edma_init_type edma_init_struct

Detailed Description

header file of dvp program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.h.


AT32F435/437 Firmwary Library: dvp.h Source File

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • dvp
at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __DVP_H
29#define __DVP_H
30
31#ifdef __cplusplus
32 extern "C" {
33#endif
34
35/* Includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
46extern edma_init_type edma_init_struct;
47void dvp_config(void);
48void dvp_dma_init(uint32_t mem0addr,uint32_t mem1addr,uint16_t memsize);
49void dvp_start(void);
50void dvp_stop(void);
51void dvp_io_init(void);
52
61#ifdef __cplusplus
62}
63#endif
64
65#endif /*__DVP_H */
at32f435_437.h
at32f435_437 header file
dvp_stop
void dvp_stop(void)
stop dvp transmission
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:181
dvp_io_init
void dvp_io_init(void)
initialize gpio for dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:85
dvp_start
void dvp_start(void)
start dvp transmission
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:169
dvp_dma_init
void dvp_dma_init(uint32_t mem0addr, uint32_t mem1addr, uint16_t memsize)
initialize dma for dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:129
dvp_config
void dvp_config(void)
configure dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:60
edma_init_struct
edma_init_type edma_init_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:40
edma_init_type
edma init type
Definition: at32f435_437_edma.h:440


AT32F435/437 Firmwary Library: font.h File Reference

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • lcd
Variables
at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/font.h File Reference

Go to the source code of this file.

Variables

const unsigned char | asc2_1206 [95][12]
const unsigned char | asc2_1608 [95][16]
const unsigned char | asc2_2412 [95][36]
const unsigned char | asc2_3216 [95][128]


AT32F435/437 Firmwary Library: font.h Source File

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • lcd
at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/font.h
Go to the documentation of this file.
1/* *
2 **************************************************************************
3 * @file font.h
4 * @version v2.0.9
5 * @date 2022-06-28
6 * @brief header file of font
7 **************************************************************************
8 * Copyright notice & Disclaimer
9 *
10 * The software Board Support Package (BSP) that is made available to
11 * download from Artery official website is the copyrighted work of Artery.
12 * Artery authorizes customers to use, copy, and distribute the BSP
13 * software and its related documentation for the purpose of design and
14 * development in conjunction with Artery microcontrollers. Use of the
15 * software is governed by this copyright notice and the following disclaimer.
16 *
17 * THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES,
18 * GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS,
19 * TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR
20 * STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS,
21 * INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY,
22 * FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.
23 *
24 **************************************************************************
25 */
26
27#ifndef __FONT_H
28#define __FONT_H
29
38const unsigned char asc2_1206[95][12]={
39{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
40{0x00,0x00,0x00,0x00,0x3F,0x40,0x00,0x00,0x00,0x00,0x00,0x00},
41{0x00,0x00,0x30,0x00,0x40,0x00,0x30,0x00,0x40,0x00,0x00,0x00},
42{0x09,0x00,0x0B,0xC0,0x3D,0x00,0x0B,0xC0,0x3D,0x00,0x09,0x00},
43{0x18,0xC0,0x24,0x40,0x7F,0xE0,0x22,0x40,0x31,0x80,0x00,0x00},
44{0x18,0x00,0x24,0xC0,0x1B,0x00,0x0D,0x80,0x32,0x40,0x01,0x80},
45{0x03,0x80,0x1C,0x40,0x27,0x40,0x1C,0x80,0x07,0x40,0x00,0x40},
46{0x10,0x00,0x60,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
47{0x00,0x00,0x00,0x00,0x00,0x00,0x1F,0x80,0x20,0x40,0x40,0x20},
48{0x00,0x00,0x40,0x20,0x20,0x40,0x1F,0x80,0x00,0x00,0x00,0x00},
49{0x09,0x00,0x06,0x00,0x1F,0x80,0x06,0x00,0x09,0x00,0x00,0x00},
50{0x04,0x00,0x04,0x00,0x3F,0x80,0x04,0x00,0x04,0x00,0x00,0x00},
51{0x00,0x10,0x00,0x60,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
52{0x04,0x00,0x04,0x00,0x04,0x00,0x04,0x00,0x04,0x00,0x00,0x00},
53{0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
54{0x00,0x20,0x01,0xC0,0x06,0x00,0x38,0x00,0x40,0x00,0x00,0x00},
55{0x1F,0x80,0x20,0x40,0x20,0x40,0x20,0x40,0x1F,0x80,0x00,0x00},
56{0x00,0x00,0x10,0x40,0x3F,0xC0,0x00,0x40,0x00,0x00,0x00,0x00},
57{0x18,0xC0,0x21,0x40,0x22,0x40,0x24,0x40,0x18,0x40,0x00,0x00},
58{0x10,0x80,0x20,0x40,0x24,0x40,0x24,0x40,0x1B,0x80,0x00,0x00},
59{0x02,0x00,0x0D,0x00,0x11,0x00,0x3F,0xC0,0x01,0x40,0x00,0x00},
60{0x3C,0x80,0x24,0x40,0x24,0x40,0x24,0x40,0x23,0x80,0x00,0x00},
61{0x1F,0x80,0x24,0x40,0x24,0x40,0x34,0x40,0x03,0x80,0x00,0x00},
62{0x30,0x00,0x20,0x00,0x27,0xC0,0x38,0x00,0x20,0x00,0x00,0x00},
63{0x1B,0x80,0x24,0x40,0x24,0x40,0x24,0x40,0x1B,0x80,0x00,0x00},
64{0x1C,0x00,0x22,0xC0,0x22,0x40,0x22,0x40,0x1F,0x80,0x00,0x00},
65{0x00,0x00,0x00,0x00,0x08,0x40,0x00,0x00,0x00,0x00,0x00,0x00},
66{0x00,0x00,0x00,0x00,0x04,0x60,0x00,0x00,0x00,0x00,0x00,0x00},
67{0x00,0x00,0x04,0x00,0x0A,0x00,0x11,0x00,0x20,0x80,0x40,0x40},
68{0x09,0x00,0x09,0x00,0x09,0x00,0x09,0x00,0x09,0x00,0x00,0x00},
69{0x00,0x00,0x40,0x40,0x20,0x80,0x11,0x00,0x0A,0x00,0x04,0x00},
70{0x18,0x00,0x20,0x00,0x23,0x40,0x24,0x00,0x18,0x00,0x00,0x00},
71{0x1F,0x80,0x20,0x40,0x27,0x40,0x29,0x40,0x1F,0x40,0x00,0x00},
72{0x00,0x40,0x07,0xC0,0x39,0x00,0x0F,0x00,0x01,0xC0,0x00,0x40},
73{0x20,0x40,0x3F,0xC0,0x24,0x40,0x24,0x40,0x1B,0x80,0x00,0x00},
74{0x1F,0x80,0x20,0x40,0x20,0x40,0x20,0x40,0x30,0x80,0x00,0x00},
75{0x20,0x40,0x3F,0xC0,0x20,0x40,0x20,0x40,0x1F,0x80,0x00,0x00},
76{0x20,0x40,0x3F,0xC0,0x24,0x40,0x2E,0x40,0x30,0xC0,0x00,0x00},
77{0x20,0x40,0x3F,0xC0,0x24,0x40,0x2E,0x00,0x30,0x00,0x00,0x00},
78{0x0F,0x00,0x10,0x80,0x20,0x40,0x22,0x40,0x33,0x80,0x02,0x00},
79{0x20,0x40,0x3F,0xC0,0x04,0x00,0x04,0x00,0x3F,0xC0,0x20,0x40},
80{0x20,0x40,0x20,0x40,0x3F,0xC0,0x20,0x40,0x20,0x40,0x00,0x00},
81{0x00,0x60,0x20,0x20,0x20,0x20,0x3F,0xC0,0x20,0x00,0x20,0x00},
82{0x20,0x40,0x3F,0xC0,0x24,0x40,0x0B,0x00,0x30,0xC0,0x20,0x40},
83{0x20,0x40,0x3F,0xC0,0x20,0x40,0x00,0x40,0x00,0x40,0x00,0xC0},
84{0x3F,0xC0,0x3C,0x00,0x03,0xC0,0x3C,0x00,0x3F,0xC0,0x00,0x00},
85{0x20,0x40,0x3F,0xC0,0x0C,0x40,0x23,0x00,0x3F,0xC0,0x20,0x00},
86{0x1F,0x80,0x20,0x40,0x20,0x40,0x20,0x40,0x1F,0x80,0x00,0x00},
87{0x20,0x40,0x3F,0xC0,0x24,0x40,0x24,0x00,0x18,0x00,0x00,0x00},
88{0x1F,0x80,0x21,0x40,0x21,0x40,0x20,0xE0,0x1F,0xA0,0x00,0x00},
89{0x20,0x40,0x3F,0xC0,0x24,0x40,0x26,0x00,0x19,0xC0,0x00,0x40},
90{0x18,0xC0,0x24,0x40,0x24,0x40,0x22,0x40,0x31,0x80,0x00,0x00},
91{0x30,0x00,0x20,0x40,0x3F,0xC0,0x20,0x40,0x30,0x00,0x00,0x00},
92{0x20,0x00,0x3F,0x80,0x00,0x40,0x00,0x40,0x3F,0x80,0x20,0x00},
93{0x20,0x00,0x3E,0x00,0x01,0xC0,0x07,0x00,0x38,0x00,0x20,0x00},
94{0x38,0x00,0x07,0xC0,0x3C,0x00,0x07,0xC0,0x38,0x00,0x00,0x00},
95{0x20,0x40,0x39,0xC0,0x06,0x00,0x39,0xC0,0x20,0x40,0x00,0x00},
96{0x20,0x00,0x38,0x40,0x07,0xC0,0x38,0x40,0x20,0x00,0x00,0x00},
97{0x30,0x40,0x21,0xC0,0x26,0x40,0x38,0x40,0x20,0xC0,0x00,0x00},
98{0x00,0x00,0x00,0x00,0x7F,0xE0,0x40,0x20,0x40,0x20,0x00,0x00},
99{0x00,0x00,0x70,0x00,0x0C,0x00,0x03,0x80,0x00,0x40,0x00,0x00},
100{0x00,0x00,0x40,0x20,0x40,0x20,0x7F,0xE0,0x00,0x00,0x00,0x00},
101{0x00,0x00,0x20,0x00,0x40,0x00,0x20,0x00,0x00,0x00,0x00,0x00},
102{0x00,0x10,0x00,0x10,0x00,0x10,0x00,0x10,0x00,0x10,0x00,0x10},
103{0x00,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
104{0x00,0x00,0x02,0x80,0x05,0x40,0x05,0x40,0x03,0xC0,0x00,0x40},
105{0x20,0x00,0x3F,0xC0,0x04,0x40,0x04,0x40,0x03,0x80,0x00,0x00},
106{0x00,0x00,0x03,0x80,0x04,0x40,0x04,0x40,0x06,0x40,0x00,0x00},
107{0x00,0x00,0x03,0x80,0x04,0x40,0x24,0x40,0x3F,0xC0,0x00,0x40},
108{0x00,0x00,0x03,0x80,0x05,0x40,0x05,0x40,0x03,0x40,0x00,0x00},
109{0x00,0x00,0x04,0x40,0x1F,0xC0,0x24,0x40,0x24,0x40,0x20,0x00},
110{0x00,0x00,0x02,0xE0,0x05,0x50,0x05,0x50,0x06,0x50,0x04,0x20},
111{0x20,0x40,0x3F,0xC0,0x04,0x40,0x04,0x00,0x03,0xC0,0x00,0x40},
112{0x00,0x00,0x04,0x40,0x27,0xC0,0x00,0x40,0x00,0x00,0x00,0x00},
113{0x00,0x10,0x00,0x10,0x04,0x10,0x27,0xE0,0x00,0x00,0x00,0x00},
114{0x20,0x40,0x3F,0xC0,0x01,0x40,0x07,0x00,0x04,0xC0,0x04,0x40},
115{0x20,0x40,0x20,0x40,0x3F,0xC0,0x00,0x40,0x00,0x40,0x00,0x00},
116{0x07,0xC0,0x04,0x00,0x07,0xC0,0x04,0x00,0x03,0xC0,0x00,0x00},
117{0x04,0x40,0x07,0xC0,0x04,0x40,0x04,0x00,0x03,0xC0,0x00,0x40},
118{0x00,0x00,0x03,0x80,0x04,0x40,0x04,0x40,0x03,0x80,0x00,0x00},
119{0x04,0x10,0x07,0xF0,0x04,0x50,0x04,0x40,0x03,0x80,0x00,0x00},
120{0x00,0x00,0x03,0x80,0x04,0x40,0x04,0x50,0x07,0xF0,0x00,0x10},
121{0x04,0x40,0x07,0xC0,0x02,0x40,0x04,0x00,0x04,0x00,0x00,0x00},
122{0x00,0x00,0x06,0x40,0x05,0x40,0x05,0x40,0x04,0xC0,0x00,0x00},
123{0x00,0x00,0x04,0x00,0x1F,0x80,0x04,0x40,0x00,0x40,0x00,0x00},
124{0x04,0x00,0x07,0x80,0x00,0x40,0x04,0x40,0x07,0xC0,0x00,0x40},
125{0x04,0x00,0x07,0x00,0x04,0xC0,0x01,0x80,0x06,0x00,0x04,0x00},
126{0x06,0x00,0x01,0xC0,0x07,0x00,0x01,0xC0,0x06,0x00,0x00,0x00},
127{0x04,0x40,0x06,0xC0,0x01,0x00,0x06,0xC0,0x04,0x40,0x00,0x00},
128{0x04,0x10,0x07,0x10,0x04,0xE0,0x01,0x80,0x06,0x00,0x04,0x00},
129{0x00,0x00,0x04,0x40,0x05,0xC0,0x06,0x40,0x04,0x40,0x00,0x00},
130{0x00,0x00,0x00,0x00,0x04,0x00,0x7B,0xE0,0x40,0x20,0x00,0x00},
131{0x00,0x00,0x00,0x00,0x00,0x00,0xFF,0xF0,0x00,0x00,0x00,0x00},
132{0x00,0x00,0x40,0x20,0x7B,0xE0,0x04,0x00,0x00,0x00,0x00,0x00},
133{0x40,0x00,0x80,0x00,0x40,0x00,0x20,0x00,0x20,0x00,0x40,0x00},
134};
135
136const unsigned char asc2_1608[95][16]={
137{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
138{0x00,0x00,0x00,0x00,0x00,0x00,0x1F,0xCC,0x00,0x0C,0x00,0x00,0x00,0x00,0x00,0x00},
139{0x00,0x00,0x08,0x00,0x30,0x00,0x60,0x00,0x08,0x00,0x30,0x00,0x60,0x00,0x00,0x00},
140{0x02,0x20,0x03,0xFC,0x1E,0x20,0x02,0x20,0x03,0xFC,0x1E,0x20,0x02,0x20,0x00,0x00},
141{0x00,0x00,0x0E,0x18,0x11,0x04,0x3F,0xFF,0x10,0x84,0x0C,0x78,0x00,0x00,0x00,0x00},
142{0x0F,0x00,0x10,0x84,0x0F,0x38,0x00,0xC0,0x07,0x78,0x18,0x84,0x00,0x78,0x00,0x00},
143{0x00,0x78,0x0F,0x84,0x10,0xC4,0x11,0x24,0x0E,0x98,0x00,0xE4,0x00,0x84,0x00,0x08},
144{0x08,0x00,0x68,0x00,0x70,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
145{0x00,0x00,0x00,0x00,0x00,0x00,0x07,0xE0,0x18,0x18,0x20,0x04,0x40,0x02,0x00,0x00},
146{0x00,0x00,0x40,0x02,0x20,0x04,0x18,0x18,0x07,0xE0,0x00,0x00,0x00,0x00,0x00,0x00},
147{0x02,0x40,0x02,0x40,0x01,0x80,0x0F,0xF0,0x01,0x80,0x02,0x40,0x02,0x40,0x00,0x00},
148{0x00,0x80,0x00,0x80,0x00,0x80,0x0F,0xF8,0x00,0x80,0x00,0x80,0x00,0x80,0x00,0x00},
149{0x00,0x01,0x00,0x0D,0x00,0x0E,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
150{0x00,0x00,0x00,0x80,0x00,0x80,0x00,0x80,0x00,0x80,0x00,0x80,0x00,0x80,0x00,0x80},
151{0x00,0x00,0x00,0x0C,0x00,0x0C,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
152{0x00,0x00,0x00,0x06,0x00,0x18,0x00,0x60,0x01,0x80,0x06,0x00,0x18,0x00,0x20,0x00},
153{0x00,0x00,0x07,0xF0,0x08,0x08,0x10,0x04,0x10,0x04,0x08,0x08,0x07,0xF0,0x00,0x00},
154{0x00,0x00,0x08,0x04,0x08,0x04,0x1F,0xFC,0x00,0x04,0x00,0x04,0x00,0x00,0x00,0x00},
155{0x00,0x00,0x0E,0x0C,0x10,0x14,0x10,0x24,0x10,0x44,0x11,0x84,0x0E,0x0C,0x00,0x00},
156{0x00,0x00,0x0C,0x18,0x10,0x04,0x11,0x04,0x11,0x04,0x12,0x88,0x0C,0x70,0x00,0x00},
157{0x00,0x00,0x00,0xE0,0x03,0x20,0x04,0x24,0x08,0x24,0x1F,0xFC,0x00,0x24,0x00,0x00},
158{0x00,0x00,0x1F,0x98,0x10,0x84,0x11,0x04,0x11,0x04,0x10,0x88,0x10,0x70,0x00,0x00},
159{0x00,0x00,0x07,0xF0,0x08,0x88,0x11,0x04,0x11,0x04,0x18,0x88,0x00,0x70,0x00,0x00},
160{0x00,0x00,0x1C,0x00,0x10,0x00,0x10,0xFC,0x13,0x00,0x1C,0x00,0x10,0x00,0x00,0x00},
161{0x00,0x00,0x0E,0x38,0x11,0x44,0x10,0x84,0x10,0x84,0x11,0x44,0x0E,0x38,0x00,0x00},
162{0x00,0x00,0x07,0x00,0x08,0x8C,0x10,0x44,0x10,0x44,0x08,0x88,0x07,0xF0,0x00,0x00},
163{0x00,0x00,0x00,0x00,0x00,0x00,0x03,0x0C,0x03,0x0C,0x00,0x00,0x00,0x00,0x00,0x00},
164{0x00,0x00,0x00,0x00,0x00,0x01,0x01,0x06,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
165{0x00,0x00,0x00,0x80,0x01,0x40,0x02,0x20,0x04,0x10,0x08,0x08,0x10,0x04,0x00,0x00},
166{0x02,0x20,0x02,0x20,0x02,0x20,0x02,0x20,0x02,0x20,0x02,0x20,0x02,0x20,0x00,0x00},
167{0x00,0x00,0x10,0x04,0x08,0x08,0x04,0x10,0x02,0x20,0x01,0x40,0x00,0x80,0x00,0x00},
168{0x00,0x00,0x0E,0x00,0x12,0x00,0x10,0x0C,0x10,0x6C,0x10,0x80,0x0F,0x00,0x00,0x00},
169{0x03,0xE0,0x0C,0x18,0x13,0xE4,0x14,0x24,0x17,0xC4,0x08,0x28,0x07,0xD0,0x00,0x00},
170{0x00,0x04,0x00,0x3C,0x03,0xC4,0x1C,0x40,0x07,0x40,0x00,0xE4,0x00,0x1C,0x00,0x04},
171{0x10,0x04,0x1F,0xFC,0x11,0x04,0x11,0x04,0x11,0x04,0x0E,0x88,0x00,0x70,0x00,0x00},
172{0x03,0xE0,0x0C,0x18,0x10,0x04,0x10,0x04,0x10,0x04,0x10,0x08,0x1C,0x10,0x00,0x00},
173{0x10,0x04,0x1F,0xFC,0x10,0x04,0x10,0x04,0x10,0x04,0x08,0x08,0x07,0xF0,0x00,0x00},
174{0x10,0x04,0x1F,0xFC,0x11,0x04,0x11,0x04,0x17,0xC4,0x10,0x04,0x08,0x18,0x00,0x00},
175{0x10,0x04,0x1F,0xFC,0x11,0x04,0x11,0x00,0x17,0xC0,0x10,0x00,0x08,0x00,0x00,0x00},
176{0x03,0xE0,0x0C,0x18,0x10,0x04,0x10,0x04,0x10,0x44,0x1C,0x78,0x00,0x40,0x00,0x00},
177{0x10,0x04,0x1F,0xFC,0x10,0x84,0x00,0x80,0x00,0x80,0x10,0x84,0x1F,0xFC,0x10,0x04},
178{0x00,0x00,0x10,0x04,0x10,0x04,0x1F,0xFC,0x10,0x04,0x10,0x04,0x00,0x00,0x00,0x00},
179{0x00,0x03,0x00,0x01,0x10,0x01,0x10,0x01,0x1F,0xFE,0x10,0x00,0x10,0x00,0x00,0x00},
180{0x10,0x04,0x1F,0xFC,0x11,0x04,0x03,0x80,0x14,0x64,0x18,0x1C,0x10,0x04,0x00,0x00},
181{0x10,0x04,0x1F,0xFC,0x10,0x04,0x00,0x04,0x00,0x04,0x00,0x04,0x00,0x0C,0x00,0x00},
182{0x10,0x04,0x1F,0xFC,0x1F,0x00,0x00,0xFC,0x1F,0x00,0x1F,0xFC,0x10,0x04,0x00,0x00},
183{0x10,0x04,0x1F,0xFC,0x0C,0x04,0x03,0x00,0x00,0xE0,0x10,0x18,0x1F,0xFC,0x10,0x00},
184{0x07,0xF0,0x08,0x08,0x10,0x04,0x10,0x04,0x10,0x04,0x08,0x08,0x07,0xF0,0x00,0x00},
185{0x10,0x04,0x1F,0xFC,0x10,0x84,0x10,0x80,0x10,0x80,0x10,0x80,0x0F,0x00,0x00,0x00},
186{0x07,0xF0,0x08,0x18,0x10,0x24,0x10,0x24,0x10,0x1C,0x08,0x0A,0x07,0xF2,0x00,0x00},
187{0x10,0x04,0x1F,0xFC,0x11,0x04,0x11,0x00,0x11,0xC0,0x11,0x30,0x0E,0x0C,0x00,0x04},
188{0x00,0x00,0x0E,0x1C,0x11,0x04,0x10,0x84,0x10,0x84,0x10,0x44,0x1C,0x38,0x00,0x00},
189{0x18,0x00,0x10,0x00,0x10,0x04,0x1F,0xFC,0x10,0x04,0x10,0x00,0x18,0x00,0x00,0x00},
190{0x10,0x00,0x1F,0xF8,0x10,0x04,0x00,0x04,0x00,0x04,0x10,0x04,0x1F,0xF8,0x10,0x00},
191{0x10,0x00,0x1E,0x00,0x11,0xE0,0x00,0x1C,0x00,0x70,0x13,0x80,0x1C,0x00,0x10,0x00},
192{0x1F,0xC0,0x10,0x3C,0x00,0xE0,0x1F,0x00,0x00,0xE0,0x10,0x3C,0x1F,0xC0,0x00,0x00},
193{0x10,0x04,0x18,0x0C,0x16,0x34,0x01,0xC0,0x01,0xC0,0x16,0x34,0x18,0x0C,0x10,0x04},
194{0x10,0x00,0x1C,0x00,0x13,0x04,0x00,0xFC,0x13,0x04,0x1C,0x00,0x10,0x00,0x00,0x00},
195{0x08,0x04,0x10,0x1C,0x10,0x64,0x10,0x84,0x13,0x04,0x1C,0x04,0x10,0x18,0x00,0x00},
196{0x00,0x00,0x00,0x00,0x00,0x00,0x7F,0xFE,0x40,0x02,0x40,0x02,0x40,0x02,0x00,0x00},
197{0x00,0x00,0x30,0x00,0x0C,0x00,0x03,0x80,0x00,0x60,0x00,0x1C,0x00,0x03,0x00,0x00},
198{0x00,0x00,0x40,0x02,0x40,0x02,0x40,0x02,0x7F,0xFE,0x00,0x00,0x00,0x00,0x00,0x00},
199{0x00,0x00,0x00,0x00,0x20,0x00,0x40,0x00,0x40,0x00,0x40,0x00,0x20,0x00,0x00,0x00},
200{0x00,0x01,0x00,0x01,0x00,0x01,0x00,0x01,0x00,0x01,0x00,0x01,0x00,0x01,0x00,0x01},
201{0x00,0x00,0x40,0x00,0x40,0x00,0x20,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
202{0x00,0x00,0x00,0x98,0x01,0x24,0x01,0x44,0x01,0x44,0x01,0x44,0x00,0xFC,0x00,0x04},
203{0x10,0x00,0x1F,0xFC,0x00,0x88,0x01,0x04,0x01,0x04,0x00,0x88,0x00,0x70,0x00,0x00},
204{0x00,0x00,0x00,0x70,0x00,0x88,0x01,0x04,0x01,0x04,0x01,0x04,0x00,0x88,0x00,0x00},
205{0x00,0x00,0x00,0x70,0x00,0x88,0x01,0x04,0x01,0x04,0x11,0x08,0x1F,0xFC,0x00,0x04},
206{0x00,0x00,0x00,0xF8,0x01,0x44,0x01,0x44,0x01,0x44,0x01,0x44,0x00,0xC8,0x00,0x00},
207{0x00,0x00,0x01,0x04,0x01,0x04,0x0F,0xFC,0x11,0x04,0x11,0x04,0x11,0x00,0x18,0x00},
208{0x00,0x00,0x00,0xD6,0x01,0x29,0x01,0x29,0x01,0x29,0x01,0xC9,0x01,0x06,0x00,0x00},
209{0x10,0x04,0x1F,0xFC,0x00,0x84,0x01,0x00,0x01,0x00,0x01,0x04,0x00,0xFC,0x00,0x04},
210{0x00,0x00,0x01,0x04,0x19,0x04,0x19,0xFC,0x00,0x04,0x00,0x04,0x00,0x00,0x00,0x00},
211{0x00,0x00,0x00,0x03,0x00,0x01,0x01,0x01,0x19,0x01,0x19,0xFE,0x00,0x00,0x00,0x00},
212{0x10,0x04,0x1F,0xFC,0x00,0x24,0x00,0x40,0x01,0xB4,0x01,0x0C,0x01,0x04,0x00,0x00},
213{0x00,0x00,0x10,0x04,0x10,0x04,0x1F,0xFC,0x00,0x04,0x00,0x04,0x00,0x00,0x00,0x00},
214{0x01,0x04,0x01,0xFC,0x01,0x04,0x01,0x00,0x01,0xFC,0x01,0x04,0x01,0x00,0x00,0xFC},
215{0x01,0x04,0x01,0xFC,0x00,0x84,0x01,0x00,0x01,0x00,0x01,0x04,0x00,0xFC,0x00,0x04},
216{0x00,0x00,0x00,0xF8,0x01,0x04,0x01,0x04,0x01,0x04,0x01,0x04,0x00,0xF8,0x00,0x00},
217{0x01,0x01,0x01,0xFF,0x00,0x85,0x01,0x04,0x01,0x04,0x00,0x88,0x00,0x70,0x00,0x00},
218{0x00,0x00,0x00,0x70,0x00,0x88,0x01,0x04,0x01,0x04,0x01,0x05,0x01,0xFF,0x00,0x01},
219{0x01,0x04,0x01,0x04,0x01,0xFC,0x00,0x84,0x01,0x04,0x01,0x00,0x01,0x80,0x00,0x00},
220{0x00,0x00,0x00,0xCC,0x01,0x24,0x01,0x24,0x01,0x24,0x01,0x24,0x01,0x98,0x00,0x00},
221{0x00,0x00,0x01,0x00,0x01,0x00,0x07,0xF8,0x01,0x04,0x01,0x04,0x00,0x00,0x00,0x00},
222{0x01,0x00,0x01,0xF8,0x00,0x04,0x00,0x04,0x00,0x04,0x01,0x08,0x01,0xFC,0x00,0x04},
223{0x01,0x00,0x01,0x80,0x01,0x70,0x00,0x0C,0x00,0x10,0x01,0x60,0x01,0x80,0x01,0x00},
224{0x01,0xF0,0x01,0x0C,0x00,0x30,0x01,0xC0,0x00,0x30,0x01,0x0C,0x01,0xF0,0x01,0x00},
225{0x00,0x00,0x01,0x04,0x01,0x8C,0x00,0x74,0x01,0x70,0x01,0x8C,0x01,0x04,0x00,0x00},
226{0x01,0x01,0x01,0x81,0x01,0x71,0x00,0x0E,0x00,0x18,0x01,0x60,0x01,0x80,0x01,0x00},
227{0x00,0x00,0x01,0x84,0x01,0x0C,0x01,0x34,0x01,0x44,0x01,0x84,0x01,0x0C,0x00,0x00},
228{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x01,0x00,0x3E,0xFC,0x40,0x02,0x40,0x02},
229{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0xFF,0xFF,0x00,0x00,0x00,0x00,0x00,0x00},
230{0x00,0x00,0x40,0x02,0x40,0x02,0x3E,0xFC,0x01,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
231{0x00,0x00,0x60,0x00,0x80,0x00,0x80,0x00,0x40,0x00,0x40,0x00,0x20,0x00,0x20,0x00},
232};
233
234const unsigned char asc2_2412[95][36]={
235{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
236{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x0F,0x80,0x38,0x0F,0xFE,0x38,0x0F,0x80,0x38,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
237{0x00,0x00,0x00,0x00,0x00,0x00,0x01,0x00,0x00,0x06,0x00,0x00,0x0C,0x00,0x00,0x38,0x00,0x00,0x31,0x00,0x00,0x06,0x00,0x00,0x0C,0x00,0x00,0x38,0x00,0x00,0x30,0x00,0x00,0x00,0x00,0x00},
238{0x00,0x00,0x00,0x00,0x61,0x80,0x00,0x67,0xF8,0x07,0xF9,0x80,0x00,0x61,0x80,0x00,0x61,0x80,0x00,0x61,0x80,0x00,0x61,0x80,0x00,0x67,0xF8,0x07,0xF9,0x80,0x00,0x61,0x80,0x00,0x00,0x00},
239{0x00,0x00,0x00,0x00,0x00,0x00,0x01,0xC0,0xE0,0x03,0xE0,0xF0,0x06,0x30,0x08,0x04,0x18,0x08,0x1F,0xFF,0xFE,0x04,0x0E,0x08,0x07,0x87,0xF0,0x03,0x81,0xE0,0x00,0x00,0x00,0x00,0x00,0x00},
240{0x01,0xF0,0x00,0x06,0x0C,0x00,0x04,0x04,0x08,0x06,0x0C,0x70,0x01,0xF9,0xC0,0x00,0x0E,0x00,0x00,0x3B,0xE0,0x00,0xEC,0x18,0x07,0x08,0x08,0x04,0x0C,0x18,0x00,0x03,0xE0,0x00,0x00,0x00},
241{0x00,0x01,0xE0,0x00,0x07,0xF0,0x03,0xF8,0x18,0x04,0x1C,0x08,0x04,0x17,0x08,0x07,0xE1,0xD0,0x03,0xC0,0xE0,0x00,0x23,0xB0,0x00,0x3C,0x08,0x00,0x20,0x08,0x00,0x00,0x10,0x00,0x00,0x00},
242{0x00,0x00,0x00,0x01,0x00,0x00,0x31,0x00,0x00,0x32,0x00,0x00,0x1C,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
243{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7F,0x00,0x01,0xFF,0xC0,0x07,0x80,0xF0,0x0C,0x00,0x18,0x10,0x00,0x04,0x20,0x00,0x02,0x00,0x00,0x00},
244{0x00,0x00,0x00,0x20,0x00,0x02,0x10,0x00,0x04,0x0C,0x00,0x18,0x07,0x80,0xF0,0x01,0xFF,0xC0,0x00,0x7F,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
245{0x00,0x00,0x00,0x00,0x42,0x00,0x00,0x66,0x00,0x00,0x66,0x00,0x00,0x3C,0x00,0x00,0x18,0x00,0x03,0xFF,0xC0,0x00,0x18,0x00,0x00,0x3C,0x00,0x00,0x66,0x00,0x00,0x66,0x00,0x00,0x42,0x00},
246{0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x01,0xFF,0xC0,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00},
247{0x00,0x00,0x00,0x00,0x00,0x01,0x00,0x00,0x31,0x00,0x00,0x32,0x00,0x00,0x1C,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
248{0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x00,0x00},
249{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x38,0x00,0x00,0x38,0x00,0x00,0x38,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
250{0x00,0x00,0x00,0x00,0x00,0x06,0x00,0x00,0x1C,0x00,0x00,0x70,0x00,0x01,0x80,0x00,0x0E,0x00,0x00,0x38,0x00,0x00,0xC0,0x00,0x07,0x00,0x00,0x1C,0x00,0x00,0x30,0x00,0x00,0x00,0x00,0x00},
251{0x00,0x00,0x00,0x00,0x7F,0x80,0x01,0xFF,0xE0,0x03,0x80,0x70,0x06,0x00,0x18,0x04,0x00,0x08,0x04,0x00,0x08,0x06,0x00,0x18,0x03,0x80,0x70,0x01,0xFF,0xE0,0x00,0x7F,0x80,0x00,0x00,0x00},
252{0x00,0x00,0x00,0x00,0x00,0x00,0x01,0x00,0x08,0x01,0x00,0x08,0x01,0x00,0x08,0x03,0xFF,0xF8,0x07,0xFF,0xF8,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x00,0x00,0x00,0x00},
253{0x00,0x00,0x00,0x01,0xC0,0x38,0x02,0xC0,0x58,0x04,0x00,0x98,0x04,0x01,0x18,0x04,0x02,0x18,0x04,0x04,0x18,0x06,0x1C,0x18,0x03,0xF8,0x18,0x01,0xE0,0xF8,0x00,0x00,0x00,0x00,0x00,0x00},
254{0x00,0x00,0x00,0x01,0xC0,0xE0,0x03,0xC0,0xF0,0x04,0x00,0x08,0x04,0x08,0x08,0x04,0x08,0x08,0x06,0x18,0x08,0x03,0xF4,0x18,0x01,0xE7,0xF0,0x00,0x01,0xE0,0x00,0x00,0x00,0x00,0x00,0x00},
255{0x00,0x00,0x00,0x00,0x03,0x00,0x00,0x0D,0x00,0x00,0x11,0x00,0x00,0x61,0x00,0x00,0x81,0x08,0x03,0x01,0x08,0x07,0xFF,0xF8,0x0F,0xFF,0xF8,0x00,0x01,0x08,0x00,0x01,0x08,0x00,0x00,0x00},
256{0x00,0x00,0x00,0x00,0x00,0xE0,0x07,0xFC,0xD0,0x06,0x08,0x08,0x06,0x10,0x08,0x06,0x10,0x08,0x06,0x10,0x08,0x06,0x18,0x38,0x06,0x0F,0xF0,0x06,0x07,0xC0,0x00,0x00,0x00,0x00,0x00,0x00},
257{0x00,0x00,0x00,0x00,0x3F,0x80,0x01,0xFF,0xE0,0x03,0x84,0x30,0x02,0x08,0x18,0x04,0x10,0x08,0x04,0x10,0x08,0x04,0x10,0x08,0x07,0x18,0x10,0x03,0x0F,0xF0,0x00,0x07,0xC0,0x00,0x00,0x00},
258{0x00,0x00,0x00,0x00,0x00,0x00,0x03,0xC0,0x00,0x07,0x00,0x00,0x06,0x00,0x00,0x06,0x00,0xF8,0x06,0x07,0xF8,0x06,0x18,0x00,0x06,0xE0,0x00,0x07,0x00,0x00,0x06,0x00,0x00,0x00,0x00,0x00},
259{0x00,0x00,0x00,0x01,0xE1,0xE0,0x03,0xF7,0xF0,0x06,0x34,0x10,0x04,0x18,0x08,0x04,0x18,0x08,0x04,0x0C,0x08,0x04,0x0C,0x08,0x06,0x16,0x18,0x03,0xF3,0xF0,0x01,0xC1,0xE0,0x00,0x00,0x00},
260{0x00,0x00,0x00,0x00,0xF8,0x00,0x03,0xFC,0x30,0x03,0x06,0x38,0x04,0x02,0x08,0x04,0x02,0x08,0x04,0x02,0x08,0x04,0x04,0x10,0x03,0x08,0xF0,0x01,0xFF,0xC0,0x00,0x7F,0x00,0x00,0x00,0x00},
261{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x70,0x38,0x00,0x70,0x38,0x00,0x70,0x38,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
262{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x30,0x1A,0x00,0x30,0x1C,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
263{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x14,0x00,0x00,0x22,0x00,0x00,0x41,0x00,0x00,0x80,0x80,0x01,0x00,0x40,0x02,0x00,0x20,0x04,0x00,0x10,0x08,0x00,0x08,0x00,0x00,0x00},
264{0x00,0x00,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x00,0x00},
265{0x00,0x00,0x00,0x00,0x00,0x00,0x08,0x00,0x08,0x04,0x00,0x10,0x02,0x00,0x20,0x01,0x00,0x40,0x00,0x80,0x80,0x00,0x41,0x00,0x00,0x22,0x00,0x00,0x14,0x00,0x00,0x08,0x00,0x00,0x00,0x00},
266{0x00,0x00,0x00,0x03,0xC0,0x00,0x04,0xC0,0x00,0x04,0x00,0x00,0x08,0x00,0x38,0x08,0x0F,0x38,0x08,0x08,0x38,0x08,0x10,0x00,0x0C,0x30,0x00,0x07,0xE0,0x00,0x03,0xC0,0x00,0x00,0x00,0x00},
267{0x00,0x00,0x00,0x00,0x3F,0x80,0x00,0xFF,0xE0,0x03,0x80,0x70,0x02,0x0F,0x10,0x06,0x70,0x88,0x04,0xC0,0x88,0x04,0x83,0x08,0x04,0x7F,0x88,0x02,0xC0,0x90,0x03,0x01,0x20,0x00,0xFE,0x40},
268{0x00,0x00,0x08,0x00,0x00,0x18,0x00,0x01,0xF8,0x00,0x3E,0x08,0x01,0xC2,0x00,0x07,0x02,0x00,0x07,0xE2,0x00,0x00,0xFE,0x00,0x00,0x1F,0xC8,0x00,0x01,0xF8,0x00,0x00,0x38,0x00,0x00,0x08},
269{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x08,0x08,0x04,0x08,0x08,0x04,0x08,0x08,0x04,0x08,0x08,0x06,0x18,0x08,0x03,0xF4,0x18,0x01,0xE7,0xF0,0x00,0x01,0xE0,0x00,0x00,0x00},
270{0x00,0x00,0x00,0x00,0x3F,0x80,0x01,0xFF,0xE0,0x03,0x80,0x70,0x02,0x00,0x18,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x10,0x06,0x00,0x20,0x07,0x80,0xC0,0x00,0x00,0x00},
271{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x18,0x02,0x00,0x10,0x03,0x80,0x70,0x01,0xFF,0xE0,0x00,0x7F,0x80,0x00,0x00,0x00},
272{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x08,0x08,0x04,0x08,0x08,0x04,0x08,0x08,0x04,0x08,0x08,0x04,0x3E,0x08,0x04,0x00,0x08,0x06,0x00,0x18,0x01,0x00,0x60,0x00,0x00,0x00},
273{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x08,0x08,0x04,0x08,0x00,0x04,0x08,0x00,0x04,0x08,0x00,0x04,0x3E,0x00,0x06,0x00,0x00,0x06,0x00,0x00,0x01,0x80,0x00,0x00,0x00,0x00},
274{0x00,0x00,0x00,0x00,0x3F,0x80,0x01,0xFF,0xE0,0x03,0x80,0x70,0x06,0x00,0x18,0x04,0x00,0x08,0x04,0x02,0x08,0x04,0x02,0x08,0x02,0x03,0xF0,0x07,0x83,0xF0,0x00,0x02,0x00,0x00,0x02,0x00},
275{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x08,0x08,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x04,0x08,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x00,0x08},
276{0x00,0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x08,0x00,0x00,0x00,0x00,0x00,0x00},
277{0x00,0x00,0x00,0x00,0x00,0x06,0x00,0x00,0x07,0x00,0x00,0x01,0x04,0x00,0x01,0x04,0x00,0x01,0x04,0x00,0x03,0x07,0xFF,0xFE,0x07,0xFF,0xFC,0x04,0x00,0x00,0x04,0x00,0x00,0x04,0x00,0x00},
278{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x0C,0x08,0x00,0x18,0x00,0x00,0x3E,0x00,0x04,0xC7,0x80,0x05,0x03,0xC8,0x06,0x00,0xF8,0x04,0x00,0x38,0x04,0x00,0x18,0x00,0x00,0x08},
279{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x18,0x00,0x00,0x60,0x00,0x00,0x00},
280{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0x80,0x08,0x07,0xFC,0x00,0x00,0x7F,0xC0,0x00,0x03,0xF8,0x00,0x07,0xC0,0x00,0x78,0x00,0x07,0x80,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x00,0x08},
281{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0x00,0x08,0x03,0xC0,0x00,0x00,0xE0,0x00,0x00,0x38,0x00,0x00,0x1E,0x00,0x00,0x07,0x00,0x00,0x01,0xC0,0x04,0x00,0xF0,0x07,0xFF,0xF8,0x04,0x00,0x00},
282{0x00,0x00,0x00,0x00,0x7F,0x80,0x01,0xFF,0xE0,0x03,0x80,0x70,0x06,0x00,0x18,0x04,0x00,0x08,0x04,0x00,0x08,0x06,0x00,0x18,0x03,0x00,0x30,0x01,0xFF,0xE0,0x00,0x7F,0x80,0x00,0x00,0x00},
283{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x04,0x08,0x04,0x04,0x00,0x04,0x04,0x00,0x04,0x04,0x00,0x04,0x04,0x00,0x06,0x0C,0x00,0x03,0xF8,0x00,0x01,0xF0,0x00,0x00,0x00,0x00},
284{0x00,0x00,0x00,0x00,0x7F,0x80,0x01,0xFF,0xE0,0x03,0x80,0x70,0x06,0x00,0x88,0x04,0x00,0x88,0x04,0x00,0xC8,0x06,0x00,0x3C,0x03,0x00,0x3E,0x01,0xFF,0xE6,0x00,0x7F,0x84,0x00,0x00,0x00},
285{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x08,0x08,0x04,0x08,0x00,0x04,0x0C,0x00,0x04,0x0F,0x00,0x04,0x0B,0xC0,0x06,0x10,0xF0,0x03,0xF0,0x38,0x01,0xE0,0x08,0x00,0x00,0x08},
286{0x00,0x00,0x00,0x01,0xE0,0xF8,0x03,0xF0,0x30,0x06,0x30,0x10,0x04,0x18,0x08,0x04,0x18,0x08,0x04,0x0C,0x08,0x04,0x0C,0x08,0x02,0x06,0x18,0x02,0x07,0xF0,0x07,0x81,0xE0,0x00,0x00,0x00},
287{0x01,0x80,0x00,0x06,0x00,0x00,0x04,0x00,0x00,0x04,0x00,0x00,0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x00,0x08,0x04,0x00,0x00,0x04,0x00,0x00,0x06,0x00,0x00,0x01,0x80,0x00},
288{0x04,0x00,0x00,0x07,0xFF,0xE0,0x07,0xFF,0xF0,0x04,0x00,0x18,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x04,0x00,0x10,0x07,0xFF,0xE0,0x04,0x00,0x00},
289{0x04,0x00,0x00,0x06,0x00,0x00,0x07,0xE0,0x00,0x07,0xFE,0x00,0x04,0x1F,0xE0,0x00,0x01,0xF8,0x00,0x00,0x38,0x00,0x01,0xE0,0x04,0x3E,0x00,0x07,0xC0,0x00,0x06,0x00,0x00,0x04,0x00,0x00},
290{0x04,0x00,0x00,0x07,0xE0,0x00,0x07,0xFF,0xC0,0x04,0x1F,0xF8,0x00,0x07,0xC0,0x07,0xF8,0x00,0x07,0xFF,0x80,0x04,0x3F,0xF8,0x00,0x07,0xC0,0x04,0xF8,0x00,0x07,0x00,0x00,0x04,0x00,0x00},
291{0x00,0x00,0x00,0x04,0x00,0x08,0x06,0x00,0x18,0x07,0xC0,0x78,0x05,0xF1,0xC8,0x00,0x3E,0x00,0x00,0x1F,0x80,0x04,0x63,0xE8,0x07,0x80,0xF8,0x06,0x00,0x18,0x04,0x00,0x08,0x00,0x00,0x00},
292{0x04,0x00,0x00,0x06,0x00,0x00,0x07,0x80,0x00,0x07,0xE0,0x08,0x04,0x7C,0x08,0x00,0x1F,0xF8,0x00,0x07,0xF8,0x00,0x18,0x08,0x04,0xE0,0x08,0x07,0x00,0x00,0x06,0x00,0x00,0x04,0x00,0x00},
293{0x00,0x00,0x00,0x01,0x00,0x08,0x06,0x00,0x38,0x04,0x00,0xF8,0x04,0x03,0xE8,0x04,0x0F,0x08,0x04,0x7C,0x08,0x05,0xF0,0x08,0x07,0xC0,0x08,0x07,0x00,0x18,0x04,0x00,0x60,0x00,0x00,0x00},
294{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x3F,0xFF,0xFE,0x20,0x00,0x02,0x20,0x00,0x02,0x20,0x00,0x02,0x20,0x00,0x02,0x20,0x00,0x02,0x00,0x00,0x00},
295{0x00,0x00,0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x07,0x00,0x00,0x00,0xC0,0x00,0x00,0x38,0x00,0x00,0x06,0x00,0x00,0x01,0xC0,0x00,0x00,0x30,0x00,0x00,0x0E,0x00,0x00,0x01,0x00,0x00,0x00},
296{0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x02,0x20,0x00,0x02,0x20,0x00,0x02,0x20,0x00,0x02,0x20,0x00,0x02,0x3F,0xFF,0xFE,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
297{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x10,0x00,0x00,0x30,0x00,0x00,0x20,0x00,0x00,0x30,0x00,0x00,0x10,0x00,0x00,0x08,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
298{0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01},
299{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x20,0x00,0x00,0x10,0x00,0x00,0x10,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
300{0x00,0x00,0x00,0x00,0x00,0xF0,0x00,0x19,0xF8,0x00,0x1B,0x18,0x00,0x22,0x08,0x00,0x26,0x08,0x00,0x24,0x08,0x00,0x24,0x10,0x00,0x3F,0xF8,0x00,0x1F,0xF8,0x00,0x00,0x08,0x00,0x00,0x18},
301{0x00,0x00,0x00,0x04,0x00,0x00,0x07,0xFF,0xF8,0x0F,0xFF,0xF0,0x00,0x18,0x18,0x00,0x10,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x30,0x18,0x00,0x1F,0xF0,0x00,0x0F,0xC0,0x00,0x00,0x00},
302{0x00,0x00,0x00,0x00,0x07,0xC0,0x00,0x1F,0xF0,0x00,0x18,0x30,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x3C,0x08,0x00,0x1C,0x10,0x00,0x00,0x60,0x00,0x00,0x00,0x00,0x00,0x00},
303{0x00,0x00,0x00,0x00,0x07,0xC0,0x00,0x1F,0xF0,0x00,0x38,0x18,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x04,0x10,0x10,0x07,0xFF,0xF8,0x0F,0xFF,0xF0,0x00,0x00,0x10,0x00,0x00,0x00},
304{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0xC0,0x00,0x1F,0xF0,0x00,0x12,0x30,0x00,0x22,0x18,0x00,0x22,0x08,0x00,0x22,0x08,0x00,0x32,0x08,0x00,0x1E,0x10,0x00,0x0E,0x20,0x00,0x00,0x00},
305{0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x20,0x08,0x00,0x20,0x08,0x01,0xFF,0xF8,0x03,0xFF,0xF8,0x06,0x20,0x08,0x04,0x20,0x08,0x04,0x20,0x08,0x07,0x20,0x00,0x03,0x00,0x00,0x00,0x00,0x00},
306{0x00,0x00,0x00,0x00,0x00,0x0E,0x00,0x0E,0x6E,0x00,0x1F,0xF3,0x00,0x31,0xB1,0x00,0x20,0xB1,0x00,0x20,0xB1,0x00,0x31,0x91,0x00,0x1F,0x13,0x00,0x2E,0x1E,0x00,0x20,0x0E,0x00,0x30,0x00},
307{0x00,0x00,0x00,0x04,0x00,0x08,0x07,0xFF,0xF8,0x0F,0xFF,0xF8,0x00,0x10,0x08,0x00,0x20,0x00,0x00,0x20,0x00,0x00,0x20,0x08,0x00,0x3F,0xF8,0x00,0x1F,0xF8,0x00,0x00,0x08,0x00,0x00,0x00},
308{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x06,0x3F,0xF8,0x06,0x3F,0xF8,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x00,0x00,0x00,0x00},
309{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x03,0x00,0x00,0x03,0x00,0x20,0x01,0x00,0x20,0x01,0x00,0x20,0x03,0x06,0x3F,0xFE,0x06,0x3F,0xFC,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
310{0x00,0x00,0x00,0x04,0x00,0x08,0x07,0xFF,0xF8,0x0F,0xFF,0xF8,0x00,0x01,0x88,0x00,0x03,0x00,0x00,0x2F,0xC0,0x00,0x38,0xF8,0x00,0x20,0x38,0x00,0x20,0x08,0x00,0x00,0x08,0x00,0x00,0x00},
311{0x00,0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x08,0x07,0xFF,0xF8,0x0F,0xFF,0xF8,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x00,0x00,0x00,0x00},
312{0x00,0x20,0x08,0x00,0x3F,0xF8,0x00,0x3F,0xF8,0x00,0x10,0x08,0x00,0x20,0x00,0x00,0x3F,0xF8,0x00,0x3F,0xF8,0x00,0x10,0x08,0x00,0x20,0x00,0x00,0x3F,0xF8,0x00,0x3F,0xF8,0x00,0x00,0x08},
313{0x00,0x00,0x00,0x00,0x20,0x08,0x00,0x3F,0xF8,0x00,0x3F,0xF8,0x00,0x10,0x08,0x00,0x10,0x00,0x00,0x20,0x00,0x00,0x20,0x08,0x00,0x3F,0xF8,0x00,0x1F,0xF8,0x00,0x00,0x08,0x00,0x00,0x00},
314{0x00,0x00,0x00,0x00,0x07,0xC0,0x00,0x0F,0xF0,0x00,0x18,0x30,0x00,0x30,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x30,0x08,0x00,0x18,0x30,0x00,0x0F,0xF0,0x00,0x07,0xC0,0x00,0x00,0x00},
315{0x00,0x00,0x00,0x00,0x20,0x01,0x00,0x3F,0xFF,0x00,0x3F,0xFF,0x00,0x10,0x11,0x00,0x20,0x09,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x30,0x38,0x00,0x1F,0xF0,0x00,0x0F,0xC0,0x00,0x00,0x00},
316{0x00,0x00,0x00,0x00,0x07,0xC0,0x00,0x1F,0xF0,0x00,0x38,0x18,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x20,0x09,0x00,0x10,0x11,0x00,0x1F,0xFF,0x00,0x3F,0xFF,0x00,0x00,0x01,0x00,0x00,0x00},
317{0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x3F,0xF8,0x00,0x3F,0xF8,0x00,0x08,0x08,0x00,0x10,0x08,0x00,0x20,0x08,0x00,0x20,0x00,0x00,0x30,0x00,0x00,0x30,0x00,0x00,0x00,0x00},
318{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x0C,0x78,0x00,0x1E,0x18,0x00,0x33,0x08,0x00,0x23,0x08,0x00,0x21,0x08,0x00,0x21,0x88,0x00,0x21,0x98,0x00,0x30,0xF0,0x00,0x38,0x60,0x00,0x00,0x00},
319{0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x20,0x00,0x00,0x20,0x00,0x00,0xFF,0xF0,0x03,0xFF,0xF8,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x00,0x30,0x00,0x00,0x00,0x00,0x00,0x00},
320{0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x3F,0xF0,0x00,0x7F,0xF8,0x00,0x00,0x18,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x20,0x10,0x00,0x3F,0xF8,0x00,0x7F,0xF0,0x00,0x00,0x10,0x00,0x00,0x00},
321{0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x30,0x00,0x00,0x3C,0x00,0x00,0x3F,0x80,0x00,0x23,0xF0,0x00,0x00,0x78,0x00,0x00,0x70,0x00,0x23,0x80,0x00,0x3C,0x00,0x00,0x30,0x00,0x00,0x20,0x00},
322{0x00,0x20,0x00,0x00,0x3C,0x00,0x00,0x3F,0xE0,0x00,0x23,0xF8,0x00,0x00,0xE0,0x00,0x27,0x00,0x00,0x3E,0x00,0x00,0x3F,0xE0,0x00,0x21,0xF8,0x00,0x01,0xE0,0x00,0x3E,0x00,0x00,0x20,0x00},
323{0x00,0x00,0x00,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x38,0x38,0x00,0x3E,0x68,0x00,0x27,0x80,0x00,0x03,0xC8,0x00,0x2C,0xF8,0x00,0x38,0x38,0x00,0x20,0x18,0x00,0x20,0x08,0x00,0x00,0x00},
324{0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x30,0x03,0x00,0x3C,0x01,0x00,0x3F,0x83,0x00,0x23,0xEC,0x00,0x00,0x70,0x00,0x23,0x80,0x00,0x3C,0x00,0x00,0x20,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
325{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x38,0x08,0x00,0x20,0x38,0x00,0x20,0xF8,0x00,0x23,0xE8,0x00,0x2F,0x88,0x00,0x3E,0x08,0x00,0x38,0x08,0x00,0x20,0x18,0x00,0x00,0x70,0x00,0x00,0x00},
326{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x14,0x00,0x1F,0xF7,0xFC,0x30,0x00,0x06,0x20,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00},
327{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0xFF,0xFF,0xFF,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
328{0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x02,0x30,0x00,0x06,0x1F,0xF7,0xFC,0x00,0x14,0x00,0x00,0x08,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
329{0x00,0x00,0x00,0x18,0x00,0x00,0x60,0x00,0x00,0x40,0x00,0x00,0x40,0x00,0x00,0x20,0x00,0x00,0x10,0x00,0x00,0x08,0x00,0x00,0x04,0x00,0x00,0x04,0x00,0x00,0x0C,0x00,0x00,0x10,0x00,0x00},
330};
331
332const unsigned char asc2_3216[95][128]={
333{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
334{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0xF0,0x00,0xC0,0x07,0xFF,0xE1,0xE0,0x07,0xF0,0x01,0xE0,0x00,0x00,0x00,0xC0,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
335{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x01,0xC0,0x00,0x00,0x07,0x80,0x00,0x00,0x1F,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0x1C,0x20,0x00,0x00,0x01,0xC0,0x00,0x00,0x07,0x80,0x00,0x00,0x1F,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0x1C,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
336{0x00,0x00,0x00,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0F,0xE0,0x00,0x1F,0xFC,0x00,0x03,0xF8,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0F,0xE0,0x00,0x1F,0xFC,0x00,0x03,0xF8,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x00,0x00,0x00},
337{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0x80,0x00,0x78,0x07,0xC0,0x00,0xFC,0x06,0x40,0x01,0x0E,0x00,0x20,0x03,0x07,0x00,0x20,0x02,0x03,0x80,0x20,0x0F,0xFF,0xFF,0xFC,0x02,0x01,0xC0,0x20,0x02,0x00,0xE0,0x60,0x01,0x30,0x70,0x40,0x01,0xF0,0x3F,0x80,0x00,0xF0,0x1F,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
338{0x00,0xFE,0x00,0x00,0x01,0xFF,0x00,0x00,0x03,0x01,0x80,0x00,0x02,0x00,0x80,0x60,0x03,0x01,0x81,0xC0,0x01,0xFF,0x07,0x00,0x00,0xFE,0x18,0x00,0x00,0x00,0xE0,0x00,0x00,0x03,0xBF,0x00,0x00,0x0C,0xFF,0xC0,0x00,0x71,0x80,0x60,0x01,0xC1,0x00,0x20,0x03,0x01,0x80,0x60,0x00,0x00,0xFF,0xC0,0x00,0x00,0x3F,0x00,0x00,0x00,0x00,0x00},
339{0x00,0x00,0x1F,0x00,0x00,0x00,0x7F,0xC0,0x00,0xFC,0xC0,0xC0,0x01,0xFF,0x80,0x60,0x03,0x03,0xE0,0x20,0x02,0x02,0x78,0x20,0x02,0x06,0x1E,0x20,0x03,0xFC,0x07,0x40,0x01,0xF0,0x03,0x80,0x00,0x01,0x03,0xC0,0x00,0x01,0x1C,0x60,0x00,0x01,0xE0,0x20,0x00,0x01,0x00,0x20,0x00,0x01,0x00,0x40,0x00,0x00,0x01,0x80,0x00,0x00,0x00,0x00},
340{0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x1C,0x60,0x00,0x00,0x1C,0x40,0x00,0x00,0x1F,0x80,0x00,0x00,0x0F,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
341{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0xF8,0x00,0x00,0x3F,0xFF,0x00,0x00,0x78,0x07,0xC0,0x01,0xC0,0x00,0xE0,0x03,0x00,0x00,0x30,0x04,0x00,0x00,0x08,0x08,0x00,0x00,0x04,0x10,0x00,0x00,0x02,0x00,0x00,0x00,0x00},
342{0x00,0x00,0x00,0x00,0x10,0x00,0x00,0x02,0x08,0x00,0x00,0x04,0x04,0x00,0x00,0x08,0x03,0x00,0x00,0x30,0x01,0xC0,0x00,0xE0,0x00,0x78,0x07,0xC0,0x00,0x3F,0xFF,0x00,0x00,0x07,0xF8,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
343{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x0C,0x18,0x00,0x00,0x0E,0x38,0x00,0x00,0x0E,0x38,0x00,0x00,0x06,0x30,0x00,0x00,0x03,0x60,0x00,0x00,0x61,0x43,0x80,0x00,0xFF,0xFF,0x80,0x00,0x61,0x43,0x00,0x00,0x03,0x60,0x00,0x00,0x06,0x30,0x00,0x00,0x0E,0x38,0x00,0x00,0x0E,0x38,0x00,0x00,0x0C,0x18,0x00,0x00,0x00,0x00,0x00},
344{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x7F,0xFF,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x00,0x00},
345{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0xE3,0x00,0x00,0x00,0xE2,0x00,0x00,0x00,0xFC,0x00,0x00,0x00,0x78,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
346{0x00,0x00,0x00,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x00,0x00},
347{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0xC0,0x00,0x00,0x01,0xE0,0x00,0x00,0x01,0xE0,0x00,0x00,0x00,0xC0,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
348{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x0C,0x00,0x00,0x00,0x38,0x00,0x00,0x00,0xE0,0x00,0x00,0x03,0x80,0x00,0x00,0x0E,0x00,0x00,0x00,0x38,0x00,0x00,0x00,0xE0,0x00,0x00,0x03,0x80,0x00,0x00,0x0E,0x00,0x00,0x00,0x38,0x00,0x00,0x00,0xE0,0x00,0x00,0x03,0x80,0x00,0x00,0x0E,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
349{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x0F,0xF8,0x00,0x00,0x7F,0xFF,0x00,0x00,0xF0,0x07,0x80,0x01,0x80,0x00,0xC0,0x03,0x00,0x00,0x60,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0x00,0x00,0x60,0x01,0x80,0x00,0xC0,0x00,0xE0,0x03,0x80,0x00,0x7F,0xFF,0x00,0x00,0x0F,0xF8,0x00,0x00,0x00,0x00,0x00},
350{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x80,0x00,0x20,0x00,0x80,0x00,0x20,0x00,0x80,0x00,0x20,0x00,0x80,0x00,0x60,0x01,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x00,0x00,0x00,0x60,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
351{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x78,0x00,0xE0,0x00,0x98,0x01,0x60,0x01,0x00,0x02,0x60,0x02,0x00,0x04,0x60,0x02,0x00,0x08,0x60,0x02,0x00,0x10,0x60,0x02,0x00,0x20,0x60,0x02,0x00,0x40,0x60,0x03,0x00,0x80,0x60,0x01,0x83,0x00,0x60,0x01,0xFE,0x00,0xE0,0x00,0x7C,0x07,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
352{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0xF0,0x07,0x80,0x01,0xF0,0x07,0xC0,0x01,0x00,0x00,0x40,0x02,0x00,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x03,0x03,0x80,0x20,0x01,0x86,0x80,0x40,0x01,0xFC,0xC0,0xC0,0x00,0x78,0x7F,0x80,0x00,0x00,0x1E,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
353{0x00,0x00,0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x00,0x38,0x00,0x00,0x00,0x48,0x00,0x00,0x01,0x88,0x00,0x00,0x06,0x08,0x00,0x00,0x0C,0x08,0x10,0x00,0x30,0x08,0x10,0x00,0x40,0x08,0x10,0x01,0xFF,0xFF,0xF0,0x03,0xFF,0xFF,0xF0,0x03,0xFF,0xFF,0xF0,0x00,0x00,0x08,0x10,0x00,0x00,0x08,0x10,0x00,0x00,0x08,0x10,0x00,0x00,0x00,0x00},
354{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0x80,0x00,0x1F,0x86,0x40,0x03,0xE1,0x00,0x20,0x03,0x02,0x00,0x20,0x03,0x04,0x00,0x20,0x03,0x04,0x00,0x20,0x03,0x04,0x00,0x20,0x03,0x04,0x00,0x20,0x03,0x06,0x00,0x40,0x03,0x03,0x01,0xC0,0x03,0x01,0xFF,0x80,0x03,0x00,0x7E,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
355{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0xFC,0x00,0x00,0x3F,0xFF,0x00,0x00,0x70,0xC3,0x80,0x00,0x81,0x80,0xC0,0x01,0x01,0x00,0x60,0x03,0x02,0x00,0x20,0x02,0x02,0x00,0x20,0x02,0x02,0x00,0x20,0x02,0x02,0x00,0x20,0x02,0x03,0x00,0x40,0x01,0xC1,0x80,0xC0,0x00,0xC0,0xFF,0x80,0x00,0x00,0x7E,0x00,0x00,0x00,0x00,0x00},
356{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0xF0,0x00,0x00,0x03,0xC0,0x00,0x00,0x03,0x80,0x00,0x00,0x03,0x00,0x00,0x00,0x03,0x00,0x07,0xE0,0x03,0x00,0x3F,0xE0,0x03,0x01,0xC0,0x00,0x03,0x06,0x00,0x00,0x03,0x18,0x00,0x00,0x03,0x60,0x00,0x00,0x03,0x80,0x00,0x00,0x03,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
357{0x00,0x00,0x00,0x00,0x00,0x00,0x1F,0x00,0x00,0x78,0x3F,0x80,0x00,0xFC,0x60,0xC0,0x01,0x8E,0xC0,0x40,0x03,0x07,0x80,0x20,0x02,0x03,0x00,0x20,0x02,0x01,0x80,0x20,0x02,0x01,0x80,0x20,0x02,0x01,0xC0,0x20,0x03,0x01,0xE0,0x40,0x01,0x86,0x70,0xC0,0x00,0xFC,0x3F,0x80,0x00,0x78,0x1F,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
358{0x00,0x00,0x00,0x00,0x00,0x3F,0x00,0x00,0x00,0xFF,0x81,0xC0,0x01,0xC0,0xC1,0xC0,0x01,0x00,0x60,0x20,0x02,0x00,0x20,0x20,0x02,0x00,0x20,0x20,0x02,0x00,0x20,0x20,0x02,0x00,0x20,0x60,0x02,0x00,0x40,0xC0,0x01,0x00,0xC1,0x80,0x00,0xC1,0x8F,0x00,0x00,0x7F,0xFE,0x00,0x00,0x1F,0xF0,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
359{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x03,0x00,0xC0,0x00,0x07,0x81,0xE0,0x00,0x07,0x81,0xE0,0x00,0x03,0x00,0xC0,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
360{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x06,0x00,0x66,0x00,0x06,0x00,0x78,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
361{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x80,0x00,0x00,0x01,0xC0,0x00,0x00,0x03,0x60,0x00,0x00,0x06,0x30,0x00,0x00,0x0C,0x18,0x00,0x00,0x18,0x0C,0x00,0x00,0x30,0x06,0x00,0x00,0x60,0x03,0x00,0x00,0xC0,0x01,0x80,0x01,0x00,0x00,0x40,0x02,0x00,0x00,0x20,0x04,0x00,0x00,0x10,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
362{0x00,0x00,0x00,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x00,0x00,0x00},
363{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x00,0x10,0x02,0x00,0x00,0x20,0x01,0x00,0x00,0x40,0x00,0xC0,0x01,0x80,0x00,0x60,0x03,0x00,0x00,0x30,0x06,0x00,0x00,0x18,0x0C,0x00,0x00,0x0C,0x18,0x00,0x00,0x06,0x30,0x00,0x00,0x03,0x60,0x00,0x00,0x01,0xC0,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
364{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x78,0x00,0x00,0x01,0xF8,0x00,0x00,0x02,0x38,0x00,0x00,0x02,0x00,0x00,0x00,0x04,0x00,0x00,0xC0,0x04,0x00,0x79,0xE0,0x04,0x00,0x81,0xE0,0x04,0x01,0x00,0xC0,0x04,0x03,0x00,0x00,0x02,0x02,0x00,0x00,0x03,0x06,0x00,0x00,0x01,0xFC,0x00,0x00,0x00,0xF8,0x00,0x00,0x00,0x00,0x00,0x00},
365{0x00,0x00,0x00,0x00,0x00,0x0F,0xF8,0x00,0x00,0x3F,0xFE,0x00,0x00,0x70,0x07,0x80,0x00,0xC0,0x00,0xC0,0x01,0x01,0xF8,0x40,0x03,0x07,0xFC,0x20,0x02,0x1E,0x04,0x20,0x02,0x30,0x08,0x20,0x02,0x20,0x30,0x20,0x02,0x3F,0xFC,0x20,0x01,0x3F,0x04,0x40,0x01,0x80,0x0C,0xC0,0x00,0xE0,0x31,0x80,0x00,0x1F,0xC2,0x00,0x00,0x00,0x00,0x00},
366{0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x60,0x00,0x00,0x03,0xE0,0x00,0x00,0x3E,0x20,0x00,0x03,0xE0,0x20,0x00,0x3E,0x20,0x00,0x03,0xE0,0x20,0x00,0x03,0x80,0x20,0x00,0x07,0xFC,0x20,0x00,0x00,0x3F,0xE0,0x00,0x00,0x03,0xFE,0x20,0x00,0x00,0x3F,0xE0,0x00,0x00,0x01,0xE0,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
367{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x03,0x03,0x00,0x20,0x01,0x86,0x80,0x60,0x01,0xFC,0xC0,0xC0,0x00,0xF8,0x7F,0x80,0x00,0x00,0x1F,0x00,0x00,0x00,0x00,0x00},
368{0x00,0x00,0x00,0x00,0x00,0x07,0xF8,0x00,0x00,0x3F,0xFF,0x00,0x00,0x70,0x07,0x80,0x00,0xC0,0x00,0xC0,0x01,0x00,0x00,0x40,0x03,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x01,0x00,0x00,0x40,0x01,0x80,0x00,0xC0,0x03,0xC0,0x01,0x80,0x00,0x30,0x06,0x00,0x00,0x00,0x00,0x00},
369{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0x00,0x00,0x60,0x01,0x00,0x00,0x40,0x01,0x80,0x00,0xC0,0x00,0xF0,0x07,0x80,0x00,0x7F,0xFE,0x00,0x00,0x0F,0xF8,0x00,0x00,0x00,0x00,0x00},
370{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x03,0x80,0x20,0x02,0x0F,0xE0,0x20,0x03,0x00,0x00,0x60,0x03,0xC0,0x00,0xE0,0x00,0x60,0x03,0x00,0x00,0x00,0x00,0x00},
371{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x00,0x02,0x01,0x00,0x00,0x02,0x01,0x00,0x00,0x02,0x01,0x00,0x00,0x02,0x03,0x80,0x00,0x03,0x0F,0xE0,0x00,0x03,0x00,0x00,0x00,0x03,0xC0,0x00,0x00,0x00,0x60,0x00,0x00},
372{0x00,0x00,0x00,0x00,0x00,0x07,0xF8,0x00,0x00,0x3F,0xFE,0x00,0x00,0x70,0x07,0x80,0x01,0xC0,0x01,0xC0,0x01,0x00,0x00,0x40,0x03,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x01,0x00,0x20,0x20,0x01,0x00,0x20,0x40,0x03,0xC0,0x3F,0x80,0x00,0x30,0x3F,0x80,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00},
373{0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x80,0x20,0x02,0x00,0x80,0x20,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x02,0x00,0x80,0x20,0x02,0x00,0x80,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
374{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
375{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x0E,0x00,0x00,0x00,0x0F,0x00,0x00,0x00,0x0F,0x00,0x00,0x00,0x01,0x02,0x00,0x00,0x01,0x02,0x00,0x00,0x01,0x02,0x00,0x00,0x03,0x02,0x00,0x00,0x06,0x03,0xFF,0xFF,0xFC,0x03,0xFF,0xFF,0xF8,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
376{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0xC0,0x20,0x02,0x01,0x00,0x20,0x00,0x07,0x80,0x00,0x00,0x0F,0xE0,0x00,0x00,0x30,0xF8,0x00,0x02,0x60,0x3E,0x20,0x03,0x80,0x0F,0x20,0x03,0x00,0x03,0xE0,0x02,0x00,0x00,0xE0,0x02,0x00,0x00,0x20,0x00,0x00,0x00,0x20},
377{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x60,0x00,0x00,0x00,0xE0,0x00,0x00,0x03,0x00,0x00,0x00,0x00,0x00},
378{0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xE0,0x00,0x20,0x03,0xFF,0x00,0x20,0x00,0x1F,0xF0,0x00,0x00,0x01,0xFF,0x80,0x00,0x00,0x0F,0xE0,0x00,0x00,0x1E,0x00,0x00,0x03,0xE0,0x00,0x00,0x3E,0x00,0x20,0x03,0xE0,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20},
379{0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0x80,0x00,0x20,0x03,0xF0,0x00,0x20,0x00,0xFC,0x00,0x00,0x00,0x1F,0x00,0x00,0x00,0x07,0xC0,0x00,0x00,0x01,0xF0,0x00,0x00,0x00,0x7C,0x00,0x02,0x00,0x1F,0x80,0x02,0x00,0x07,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
380{0x00,0x00,0x00,0x00,0x00,0x0F,0xF8,0x00,0x00,0x3F,0xFE,0x00,0x00,0xF0,0x07,0x80,0x01,0x80,0x00,0xC0,0x01,0x00,0x00,0x40,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x01,0x00,0x00,0x40,0x01,0x80,0x00,0xC0,0x00,0xF0,0x03,0x80,0x00,0x3F,0xFE,0x00,0x00,0x0F,0xF8,0x00,0x00,0x00,0x00,0x00},
381{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x80,0x20,0x02,0x00,0x80,0x20,0x02,0x00,0x80,0x00,0x02,0x00,0x80,0x00,0x02,0x00,0x80,0x00,0x02,0x00,0x80,0x00,0x03,0x01,0x80,0x00,0x01,0x83,0x00,0x00,0x00,0xFE,0x00,0x00,0x00,0x7C,0x00,0x00,0x00,0x00,0x00,0x00},
382{0x00,0x00,0x00,0x00,0x00,0x0F,0xF8,0x00,0x00,0x7F,0xFF,0x00,0x00,0xF0,0x03,0x80,0x01,0x80,0x01,0xC0,0x01,0x00,0x06,0x40,0x02,0x00,0x04,0x20,0x02,0x00,0x04,0x20,0x02,0x00,0x06,0x20,0x02,0x00,0x03,0xE0,0x01,0x00,0x00,0xF8,0x01,0x80,0x00,0x5C,0x00,0xE0,0x03,0x8C,0x00,0x3F,0xFF,0x0C,0x00,0x0F,0xFC,0x18,0x00,0x00,0x00,0x00},
383{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x80,0x00,0x02,0x01,0xE0,0x00,0x02,0x01,0xFC,0x00,0x03,0x03,0x3F,0x80,0x01,0x86,0x07,0xE0,0x01,0xFC,0x00,0xE0,0x00,0xF8,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
384{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x78,0x06,0x00,0x00,0xFE,0x01,0xE0,0x01,0x86,0x00,0xC0,0x03,0x03,0x00,0x40,0x02,0x03,0x00,0x20,0x02,0x01,0x80,0x20,0x02,0x01,0x80,0x20,0x02,0x01,0xC0,0x20,0x02,0x00,0xC0,0x20,0x01,0x00,0xE0,0x60,0x01,0x80,0x70,0xC0,0x03,0xE0,0x3F,0x80,0x00,0x00,0x1F,0x00,0x00,0x00,0x00,0x00},
385{0x00,0x00,0x00,0x00,0x00,0x60,0x00,0x00,0x03,0x80,0x00,0x00,0x03,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x03,0x80,0x00,0x00,0x00,0xE0,0x00,0x00,0x00,0x00,0x00,0x00},
386{0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x03,0xFF,0xFF,0x00,0x03,0xFF,0xFF,0xC0,0x02,0x00,0x00,0x40,0x02,0x00,0x00,0x60,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x02,0x00,0x00,0x40,0x02,0x00,0x00,0x80,0x03,0xFF,0xFF,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
387{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x03,0xC0,0x00,0x00,0x03,0xFC,0x00,0x00,0x02,0x3F,0xC0,0x00,0x00,0x03,0xF8,0x00,0x00,0x00,0x7F,0x80,0x00,0x00,0x07,0xE0,0x00,0x00,0x07,0x80,0x00,0x00,0x78,0x00,0x02,0x03,0xC0,0x00,0x02,0x3C,0x00,0x00,0x03,0xC0,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00},
388{0x02,0x00,0x00,0x00,0x03,0xC0,0x00,0x00,0x03,0xFF,0x80,0x00,0x02,0x3F,0xFE,0x00,0x02,0x00,0x7F,0xE0,0x00,0x00,0x0F,0x00,0x02,0x00,0xF0,0x00,0x03,0xEF,0x00,0x00,0x03,0xFF,0x80,0x00,0x02,0x0F,0xFE,0x00,0x00,0x00,0x3F,0xE0,0x00,0x00,0x1F,0x00,0x02,0x07,0xE0,0x00,0x03,0xF8,0x00,0x00,0x03,0x00,0x00,0x00,0x02,0x00,0x00,0x00},
389{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0x80,0x00,0xE0,0x03,0xF0,0x03,0x20,0x02,0xFC,0x0C,0x20,0x02,0x1F,0x30,0x00,0x00,0x07,0xC0,0x00,0x00,0x07,0xF0,0x00,0x02,0x18,0x7C,0x00,0x02,0x60,0x1F,0x20,0x03,0x80,0x03,0xE0,0x02,0x00,0x00,0xE0,0x02,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
390{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x03,0x00,0x00,0x00,0x03,0xC0,0x00,0x00,0x03,0xF8,0x00,0x00,0x02,0x3E,0x00,0x20,0x02,0x0F,0xC0,0x20,0x00,0x01,0xFF,0xE0,0x00,0x00,0x7F,0xE0,0x00,0x03,0x80,0x20,0x02,0x1C,0x00,0x20,0x02,0x70,0x00,0x00,0x03,0x80,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
391{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x60,0x00,0xE0,0x03,0x80,0x03,0xE0,0x03,0x00,0x0F,0xA0,0x02,0x00,0x3E,0x20,0x02,0x00,0xF8,0x20,0x02,0x03,0xE0,0x20,0x02,0x0F,0x80,0x20,0x02,0x3E,0x00,0x20,0x02,0x78,0x00,0x20,0x03,0xE0,0x00,0x60,0x03,0x80,0x00,0xE0,0x02,0x00,0x03,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
392{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x1F,0xFF,0xFF,0xFC,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
393{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0x00,0x00,0x00,0x03,0xC0,0x00,0x00,0x00,0x78,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0x03,0xC0,0x00,0x00,0x00,0xF0,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0x07,0x80,0x00,0x00,0x00,0xF0,0x00,0x00,0x00,0x3C,0x00,0x00,0x00,0x06,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
394{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x1F,0xFF,0xFF,0xFC,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
395{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x08,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x10,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
396{0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01},
397{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x10,0x00,0x00,0x00,0x10,0x00,0x00,0x00,0x10,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x08,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
398{0x00,0x00,0x00,0x00,0x00,0x00,0x03,0x80,0x00,0x01,0x8F,0xC0,0x00,0x03,0x8C,0x60,0x00,0x06,0x18,0x20,0x00,0x04,0x10,0x20,0x00,0x04,0x10,0x20,0x00,0x04,0x20,0x20,0x00,0x04,0x20,0x40,0x00,0x06,0x20,0x40,0x00,0x03,0xFF,0xC0,0x00,0x01,0xFF,0xE0,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0xC0,0x00,0x00,0x00,0x00},
399{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x03,0xFF,0xFF,0xE0,0x07,0xFF,0xFF,0xC0,0x00,0x01,0x80,0xC0,0x00,0x02,0x00,0x60,0x00,0x02,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x06,0x00,0x40,0x00,0x03,0x00,0xC0,0x00,0x01,0xFF,0x80,0x00,0x00,0xFE,0x00,0x00,0x00,0x00,0x00},
400{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7E,0x00,0x00,0x01,0xFF,0x80,0x00,0x03,0x81,0xC0,0x00,0x02,0x00,0x40,0x00,0x06,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x06,0x00,0x20,0x00,0x03,0xC0,0x40,0x00,0x01,0xC0,0x80,0x00,0x00,0x03,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
401{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7E,0x00,0x00,0x01,0xFF,0x80,0x00,0x03,0x80,0xC0,0x00,0x06,0x00,0x60,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x02,0x04,0x00,0x40,0x02,0x02,0x00,0x80,0x03,0xFF,0xFF,0xE0,0x07,0xFF,0xFF,0xC0,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x00},
402{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7E,0x00,0x00,0x01,0xFF,0x80,0x00,0x03,0x11,0xC0,0x00,0x02,0x10,0x40,0x00,0x04,0x10,0x60,0x00,0x04,0x10,0x20,0x00,0x04,0x10,0x20,0x00,0x04,0x10,0x20,0x00,0x06,0x10,0x20,0x00,0x03,0x10,0x40,0x00,0x01,0xF0,0xC0,0x00,0x00,0x71,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
403{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x7F,0xFF,0xE0,0x01,0xFF,0xFF,0xE0,0x01,0x04,0x00,0x20,0x03,0x04,0x00,0x20,0x02,0x04,0x00,0x20,0x02,0x04,0x00,0x20,0x02,0x04,0x00,0x00,0x02,0x00,0x00,0x00,0x01,0xC0,0x00,0x00,0x01,0xC0,0x00,0x00},
404{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x1C,0x00,0x00,0xE3,0x3E,0x00,0x03,0xFF,0xC2,0x00,0x02,0x0C,0xC3,0x00,0x04,0x04,0xC1,0x00,0x04,0x04,0xC1,0x00,0x04,0x04,0xC1,0x00,0x04,0x04,0xC1,0x00,0x06,0x0C,0xC1,0x00,0x03,0xF8,0xC3,0x00,0x05,0xF0,0x62,0x00,0x06,0x00,0x7E,0x00,0x06,0x00,0x3C,0x00,0x00,0x00,0x00},
405{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x07,0xFF,0xFF,0xE0,0x00,0x01,0x00,0x20,0x00,0x02,0x00,0x20,0x00,0x06,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x06,0x00,0x20,0x00,0x03,0xFF,0xE0,0x00,0x01,0xFF,0xE0,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20},
406{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x03,0x87,0xFF,0xE0,0x03,0x8F,0xFF,0xE0,0x03,0x80,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
407{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x06,0x00,0x00,0x00,0x07,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x04,0x00,0x01,0x00,0x04,0x00,0x01,0x00,0x04,0x00,0x03,0x00,0x04,0x00,0x06,0x03,0x87,0xFF,0xFC,0x03,0x8F,0xFF,0xF8,0x03,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
408{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x07,0xFF,0xFF,0xE0,0x00,0x00,0x08,0x20,0x00,0x00,0x10,0x20,0x00,0x00,0x30,0x00,0x00,0x00,0xFC,0x00,0x00,0x05,0x8E,0x00,0x00,0x07,0x07,0xA0,0x00,0x06,0x01,0xE0,0x00,0x04,0x00,0xE0,0x00,0x04,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
409{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x07,0xFF,0xFF,0xE0,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
410{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x07,0xFF,0xE0,0x00,0x0F,0xFF,0xE0,0x00,0x02,0x00,0x20,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x07,0xFF,0xE0,0x00,0x03,0xFF,0xE0,0x00,0x02,0x00,0x20,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x07,0xFF,0xE0,0x00,0x03,0xFF,0xE0,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
411{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x07,0xFF,0xE0,0x00,0x0F,0xFF,0xE0,0x00,0x01,0x00,0x20,0x00,0x02,0x00,0x20,0x00,0x02,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x06,0x00,0x20,0x00,0x03,0xFF,0xE0,0x00,0x01,0xFF,0xE0,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20},
412{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7E,0x00,0x00,0x00,0xFF,0x80,0x00,0x03,0x81,0xC0,0x00,0x02,0x00,0x40,0x00,0x06,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x06,0x00,0x20,0x00,0x02,0x00,0x40,0x00,0x03,0x81,0xC0,0x00,0x01,0xFF,0x80,0x00,0x00,0x7E,0x00,0x00,0x00,0x00,0x00},
413{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x01,0x00,0x04,0x00,0x01,0x00,0x07,0xFF,0xFF,0x00,0x0F,0xFF,0xFF,0x00,0x01,0x00,0xC1,0x00,0x02,0x00,0x41,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x06,0x00,0x40,0x00,0x03,0x01,0xC0,0x00,0x01,0xFF,0x80,0x00,0x00,0x7E,0x00,0x00,0x00,0x00,0x00},
414{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7E,0x00,0x00,0x01,0xFF,0x80,0x00,0x03,0x80,0xC0,0x00,0x02,0x00,0x60,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x02,0x00,0x41,0x00,0x03,0x00,0xC1,0x00,0x03,0xFF,0xFF,0x00,0x07,0xFF,0xFF,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01},
415{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x0F,0xFF,0xE0,0x00,0x0F,0xFF,0xE0,0x00,0x00,0xC0,0x20,0x00,0x01,0x00,0x20,0x00,0x02,0x00,0x20,0x00,0x06,0x00,0x20,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x07,0x00,0x00,0x00,0x03,0x00,0x00,0x00,0x00,0x00,0x00},
416{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x03,0xE0,0x00,0x01,0xC0,0xE0,0x00,0x03,0xE0,0x40,0x00,0x06,0x30,0x20,0x00,0x04,0x30,0x20,0x00,0x04,0x18,0x20,0x00,0x04,0x18,0x20,0x00,0x04,0x18,0x20,0x00,0x04,0x0C,0x20,0x00,0x02,0x0C,0x60,0x00,0x03,0x07,0xC0,0x00,0x07,0x83,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
417{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x0C,0x00,0x00,0x00,0x1F,0xFF,0x80,0x00,0xFF,0xFF,0xC0,0x00,0x04,0x00,0x60,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x40,0x00,0x00,0x01,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
418{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x07,0xFF,0x80,0x00,0x0F,0xFF,0xC0,0x00,0x00,0x00,0x60,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x04,0x00,0x40,0x00,0x04,0x00,0x80,0x00,0x07,0xFF,0xE0,0x00,0x0F,0xFF,0xC0,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x40},
419{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x07,0x80,0x00,0x00,0x07,0xF0,0x00,0x00,0x04,0xFE,0x00,0x00,0x04,0x1F,0xC0,0x00,0x00,0x03,0xE0,0x00,0x00,0x03,0x80,0x00,0x00,0x1C,0x00,0x00,0x04,0x60,0x00,0x00,0x07,0x80,0x00,0x00,0x06,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
420{0x00,0x04,0x00,0x00,0x00,0x06,0x00,0x00,0x00,0x07,0xC0,0x00,0x00,0x07,0xFC,0x00,0x00,0x04,0x3F,0x80,0x00,0x00,0x03,0xE0,0x00,0x04,0x0F,0x80,0x00,0x06,0xF0,0x00,0x00,0x07,0xF0,0x00,0x00,0x07,0xFF,0x80,0x00,0x04,0x0F,0xE0,0x00,0x00,0x03,0x80,0x00,0x04,0x3C,0x00,0x00,0x07,0xC0,0x00,0x00,0x06,0x00,0x00,0x00,0x04,0x00,0x00},
421{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x60,0x00,0x07,0x00,0xE0,0x00,0x07,0x83,0x20,0x00,0x07,0xE6,0x00,0x00,0x04,0xF8,0x00,0x00,0x00,0x3C,0x00,0x00,0x04,0x5E,0x20,0x00,0x05,0x87,0xA0,0x00,0x06,0x01,0xE0,0x00,0x04,0x00,0x60,0x00,0x04,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
422{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x03,0x00,0x07,0x00,0x03,0x00,0x07,0xE0,0x01,0x00,0x04,0xF8,0x01,0x00,0x04,0x1F,0x02,0x00,0x00,0x07,0xFC,0x00,0x00,0x00,0xE0,0x00,0x00,0x07,0x00,0x00,0x04,0x38,0x00,0x00,0x07,0xC0,0x00,0x00,0x06,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x00,0x00,0x00},
423{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0x80,0x60,0x00,0x06,0x00,0xE0,0x00,0x04,0x03,0xE0,0x00,0x04,0x07,0xA0,0x00,0x04,0x0E,0x20,0x00,0x04,0x3C,0x20,0x00,0x04,0x70,0x20,0x00,0x05,0xE0,0x20,0x00,0x07,0x80,0x20,0x00,0x07,0x00,0x60,0x00,0x04,0x00,0xE0,0x00,0x00,0x03,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
424{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x01,0x40,0x00,0x07,0xFE,0x3F,0xF8,0x08,0x00,0x00,0x04,0x10,0x00,0x00,0x02,0x10,0x00,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
425{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0xFF,0xFF,0xFF,0xFF,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
426{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x10,0x00,0x00,0x02,0x10,0x00,0x00,0x02,0x08,0x00,0x00,0x04,0x07,0xFE,0x3F,0xF8,0x00,0x01,0x40,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
427{0x00,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x30,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x30,0x00,0x00,0x00,0x08,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x0C,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
428};
429
438#endif
asc2_2412
const unsigned char asc2_2412[95][36]
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/font.h:234
asc2_3216
const unsigned char asc2_3216[95][128]
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/font.h:332
asc2_1206
const unsigned char asc2_1206[95][12]
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/font.h:38
asc2_1608
const unsigned char asc2_1608[95][16]
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/font.h:136


AT32F435/437 Firmwary Library: xmc_lcd.c File Reference

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • lcd
Functions | Variables
at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c File Reference

xmc_lcd program file More...

#include "xmc_lcd.h"
#include "font.h"

Go to the source code of this file.

Functions

void | xmc_init (void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_init (void)
configures the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_wr_command (uint16_t command)
this function is write command to lcd. More...
void | lcd_wr_data (uint16_t data)
this function is write data to lcd. More...
uint16_t | lcd_rd_data (void)
void | lcd_setblock (uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd. More...
void | lcd_writeonepoint (uint16_t color)
this function is write one point to lcd. More...
void | lcd_drawpoint (uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd. More...
void | lcd_clear (uint16_t color)
this function is clear the lcd. More...
void | lcd_char_show (uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode)
this function is show char to lcd More...
void | lcd_string_show (uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p)
this function is show string to lcd More...
void | lcd_fill (uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color)
this function is fill in lcd with concolorous More...
void | lcd_color_fill (uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color)
this function is fill in lcd with color-pointer More...

Variables

lcd_dev_type lcd_dev_struct
lcd_dev_type * lcd_struct

Detailed Description

xmc_lcd program file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c.


AT32F435/437 Firmwary Library: xmc_lcd.c Source File

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • lcd
at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c
Go to the documentation of this file.
1
27#include "xmc_lcd.h"
28#include "font.h"
29
38 lcd_dev_type lcd_dev_struct =
39{
40 0,
41 xmc_init,
42 lcd_init,
43 lcd_setblock,
44 lcd_drawpoint,
45 lcd_clear,
46};
47
48 lcd_dev_type *lcd_struct;
49
57void xmc_init(void)
58{
59 gpio_init_type gpio_init_struct = {0};
60 xmc_norsram_init_type xmc_norsram_init_struct;
61 xmc_norsram_timing_init_type rw_timing_struct, w_timing_struct;
62
63 /* enable the gpio clock */
64 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
65 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
67 /* enable the xmc clock */
68 crm_periph_clock_enable(CRM_XMC_PERIPH_CLOCK, TRUE);
69
70 /*-- gpio configuration ------------------------------------------------------*/
71 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE2, GPIO_MUX_14);
72 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE4, GPIO_MUX_14);
73 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE5, GPIO_MUX_14);
74 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE11, GPIO_MUX_14);
75 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE12, GPIO_MUX_14);
76 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE5, GPIO_MUX_10);
77 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE8, GPIO_MUX_12);
78 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE9, GPIO_MUX_12);
79 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE10, GPIO_MUX_12);
80 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE14, GPIO_MUX_12);
81 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE15, GPIO_MUX_12);
82
83 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE7, GPIO_MUX_12);
84 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE8, GPIO_MUX_12);
85 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE9, GPIO_MUX_12);
86 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE10, GPIO_MUX_12);
87 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE11, GPIO_MUX_12);
88 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE12, GPIO_MUX_12);
89 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE13, GPIO_MUX_12);
90 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE14, GPIO_MUX_12);
91 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE15, GPIO_MUX_12);
92
93 /* lcd data lines configuration */
94 gpio_init_struct.gpio_pins = GPIO_PINS_2 | GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_11| GPIO_PINS_12;
95 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
96 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
97 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
98 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
99 gpio_init(GPIOC, &gpio_init_struct);
100
101
102 gpio_init_struct.gpio_pins = GPIO_PINS_5 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_14 | GPIO_PINS_15;
103 gpio_init(GPIOD, &gpio_init_struct);
104
105 gpio_init_struct.gpio_pins = GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11 | GPIO_PINS_12 | GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
106 gpio_init(GPIOE, &gpio_init_struct);
107
108 /*-- xmc configuration ------------------------------------------------------*/
109 xmc_norsram_default_para_init(&xmc_norsram_init_struct);
110 xmc_norsram_init_struct.subbank = XMC_BANK1_NOR_SRAM4;
111 xmc_norsram_init_struct.data_addr_multiplex = XMC_DATA_ADDR_MUX_DISABLE;
112 xmc_norsram_init_struct.device = XMC_DEVICE_SRAM;
113 xmc_norsram_init_struct.bus_type = XMC_BUSTYPE_16_BITS;
114 xmc_norsram_init_struct.burst_mode_enable = XMC_BURST_MODE_DISABLE;
115 xmc_norsram_init_struct.asynwait_enable = XMC_ASYN_WAIT_DISABLE;
116 xmc_norsram_init_struct.wait_signal_lv = XMC_WAIT_SIGNAL_LEVEL_LOW;
117 xmc_norsram_init_struct.wrapped_mode_enable = XMC_WRAPPED_MODE_DISABLE;
118 xmc_norsram_init_struct.wait_signal_config = XMC_WAIT_SIGNAL_SYN_BEFORE;
119 xmc_norsram_init_struct.write_enable = XMC_WRITE_OPERATION_ENABLE;
120 xmc_norsram_init_struct.wait_signal_enable = XMC_WAIT_SIGNAL_DISABLE;
121 xmc_norsram_init_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
122 xmc_norsram_init_struct.write_burst_syn = XMC_WRITE_BURST_SYN_DISABLE;
123 xmc_nor_sram_init(&xmc_norsram_init_struct);
124
125 /* timing configuration */
126 xmc_norsram_timing_default_para_init(&rw_timing_struct, &w_timing_struct);
127 rw_timing_struct.subbank = XMC_BANK1_NOR_SRAM4;
128 rw_timing_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
129 rw_timing_struct.addr_setup_time = 0x2;
130 rw_timing_struct.addr_hold_time = 0x0;
131 rw_timing_struct.data_setup_time = 0x2;
132 rw_timing_struct.bus_latency_time = 0x0;
133 rw_timing_struct.clk_psc = 0x0;
134 rw_timing_struct.data_latency_time = 0x0;
135 rw_timing_struct.mode = XMC_ACCESS_MODE_A;
136 w_timing_struct.subbank = XMC_BANK1_NOR_SRAM4;
137 w_timing_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
138 w_timing_struct.addr_setup_time = 0x2;
139 w_timing_struct.addr_hold_time = 0x0;
140 w_timing_struct.data_setup_time = 0x2;
141 w_timing_struct.bus_latency_time = 0x0;
142 w_timing_struct.clk_psc = 0x0;
143 w_timing_struct.data_latency_time = 0x0;
144 w_timing_struct.mode = XMC_ACCESS_MODE_A;
145 xmc_nor_sram_timing_config(&rw_timing_struct, &w_timing_struct);
146
147 /* enable xmc_bank1_nor_sram4 */
148 xmc_nor_sram_enable(XMC_BANK1_NOR_SRAM4, TRUE);
149
150 gpio_init_struct.gpio_pins = GPIO_PINS_0;
151 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
152 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
153 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
154 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
155 gpio_init(GPIOC, &gpio_init_struct);
156}
157
165void lcd_init(void)
166{
167 /* init xmc */
168 lcd_struct->xmc_init();
169
170 delay_ms(50);
171
172 /* read id */
173 lcd_wr_command(0x0000);
174 delay_ms(5);
175
176 lcd_struct->lcd_id = lcd_rd_data();
177 lcd_wr_command(0xd3);
178
179 lcd_struct->lcd_id = lcd_rd_data();
180 lcd_struct->lcd_id = lcd_rd_data();
181 lcd_struct->lcd_id = lcd_rd_data();
182 lcd_struct->lcd_id = lcd_rd_data();
183 lcd_struct->lcd_id = lcd_struct->lcd_id << 8;
184 lcd_struct->lcd_id |= lcd_rd_data();
185
186 lcd_wr_command(0xcf);
187 lcd_wr_data(0x00);
188 lcd_wr_data(0xc1);
189 lcd_wr_data(0x30);
190 lcd_wr_command(0xed);
191 lcd_wr_data(0x64);
192 lcd_wr_data(0x03);
193 lcd_wr_data(0x12);
194 lcd_wr_data(0x81);
195 lcd_wr_command(0xe8);
196 lcd_wr_data(0x85);
197 lcd_wr_data(0x10);
198 lcd_wr_data(0x7a);
199 lcd_wr_command(0xcb);
200 lcd_wr_data(0x39);
201 lcd_wr_data(0x2c);
202 lcd_wr_data(0x00);
203 lcd_wr_data(0x34);
204 lcd_wr_data(0x02);
205 lcd_wr_command(0xf7);
206 lcd_wr_data(0x20);
207 lcd_wr_command(0xea);
208 lcd_wr_data(0x00);
209 lcd_wr_data(0x00);
210 lcd_wr_command(0xc0);
211 lcd_wr_data(0x1b);
212 lcd_wr_command(0xc1);
213 lcd_wr_data(0x01);
214 lcd_wr_command(0xc5);
215 lcd_wr_data(0x30);
216 lcd_wr_data(0x30);
217 lcd_wr_command(0xc7);
218 lcd_wr_data(0xb7);
219 lcd_wr_command(0x36);
220 lcd_wr_data(0x48);
221 lcd_wr_command(0x3a);
222 lcd_wr_data(0x55);
223 lcd_wr_command(0xb1);
224 lcd_wr_data(0x00);
225 lcd_wr_data(0x1a);
226 lcd_wr_command(0xb6);
227 lcd_wr_data(0x0a);
228 lcd_wr_data(0xa2);
229 lcd_wr_command(0xf2);
230 lcd_wr_data(0x00);
231 lcd_wr_command(0x26);
232 lcd_wr_data(0x01);
233 lcd_wr_command(0xe0);
234 lcd_wr_data(0x0f);
235 lcd_wr_data(0x2a);
236 lcd_wr_data(0x28);
237 lcd_wr_data(0x08);
238 lcd_wr_data(0x0e);
239 lcd_wr_data(0x08);
240 lcd_wr_data(0x54);
241 lcd_wr_data(0xa9);
242 lcd_wr_data(0x43);
243 lcd_wr_data(0x0a);
244 lcd_wr_data(0x0f);
245 lcd_wr_data(0x00);
246 lcd_wr_data(0x00);
247 lcd_wr_data(0x00);
248 lcd_wr_data(0x00);
249 lcd_wr_command(0xe1);
250 lcd_wr_data(0x00);
251 lcd_wr_data(0x15);
252 lcd_wr_data(0x17);
253 lcd_wr_data(0x07);
254 lcd_wr_data(0x11);
255 lcd_wr_data(0x06);
256 lcd_wr_data(0x2b);
257 lcd_wr_data(0x56);
258 lcd_wr_data(0x3c);
259 lcd_wr_data(0x05);
260 lcd_wr_data(0x10);
261 lcd_wr_data(0x0f);
262 lcd_wr_data(0x3f);
263 lcd_wr_data(0x3f);
264 lcd_wr_data(0x0f);
265 lcd_wr_command(0x2b);
266 lcd_wr_data(0x00);
267 lcd_wr_data(0x00);
268 lcd_wr_data(0x01);
269 lcd_wr_data(0x3f);
270 lcd_wr_command(0x2a);
271 lcd_wr_data(0x00);
272 lcd_wr_data(0x00);
273 lcd_wr_data(0x00);
274 lcd_wr_data(0xef);
275 lcd_wr_command(0x11);
276 delay_ms(120);
277 lcd_wr_command(0x29);
278 lcd_wr_command(0x36);
279 lcd_wr_data(0x08);
280 lcd_wr_command(0x2a);
281 lcd_wr_data(0x00);
282 lcd_wr_data(0x00);
283 lcd_wr_data(0xef >> 8);
284 lcd_wr_data(0xef & 0xff);
285 lcd_wr_command(0x2b);
286 lcd_wr_data(0x00);
287 lcd_wr_data(0x00);
288 lcd_wr_data(0x13f >> 8);
289 lcd_wr_data(0x13f & 0xff);
290 lcd_wr_command(0x36); //setting the display direction
291 lcd_wr_data(0x68); //90 degree
292 LCD_BL_HIGH;
293}
294
300void lcd_wr_command(uint16_t command)
301{
302 *(uint16_t*) XMC_LCD_COMMAND = command;
303}
304
310void lcd_wr_data(uint16_t data)
311{
312 *(uint16_t*) XMC_LCD_DATA = data;
313}
314
315uint16_t lcd_rd_data(void)
316{
317 uint16_t data;
318
319 data = *(uint16_t*)XMC_LCD_DATA;
320
321 return data;
322}
323
332void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
333{
334 /* set row coordinates */
335 lcd_wr_command(0x2a);
336 lcd_wr_data(xstart >> 8);
337 lcd_wr_data(xstart);
338 lcd_wr_data(xend >> 8);
339 lcd_wr_data(xend);
340
341 /* set column coordinates */
342 lcd_wr_command(0x2b);
343 lcd_wr_data(ystart >> 8);
344 lcd_wr_data(ystart);
345 lcd_wr_data(yend >> 8);
346 lcd_wr_data(yend);
347
348 /* enable write menory */
349 lcd_wr_command(0x2c);
350}
351
357void lcd_writeonepoint(uint16_t color)
358{
359 lcd_wr_data(color);
360}
361
367void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
368{
369 lcd_struct->lcd_setblock(x, y ,x ,y);
370
371 lcd_writeonepoint(color);
372}
373
379void lcd_clear(uint16_t color)
380{
381 uint32_t i;
382
383 lcd_struct->lcd_setblock(0, 0, LCD_W, LCD_H);
384
385 for(i = 0; i < 76800; i++)
386 {
387 lcd_writeonepoint(color);
388 }
389}
390
400void lcd_char_show(uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode)
401{
402 uint8_t temp, t1, t;
403 uint16_t y0 = y;
404 uint8_t csize = (size / 8 + ((size % 8) ? 1 : 0)) * (size / 2);
405 num = num - ' ';
406
407 for(t = 0; t < csize; t++)
408 {
409 if(size == 12)
410 {
411 temp = asc2_1206[num][t];
412 }
413 else if(size == 16)
414 {
415 temp = asc2_1608[num][t];
416 }
417 else if(size == 24)
418 {
419 temp = asc2_2412[num][t];
420 }
421 else if(size == 32)
422 {
423 temp = asc2_3216[num][t];
424 }
425 else
426 {
427 return;
428 }
429
430 for(t1 = 0; t1 < 8; t1++)
431 {
432 if(temp & 0x80)
433 {
434 lcd_drawpoint(x, y, RED);
435 }
436 else if(mode == 0)
437 {
438 lcd_drawpoint(x, y, WHITE);
439 }
440
441 temp <<= 1;
442 y++;
443
444 if(y >= LCD_H)
445 {
446 return;
447 }
448
449 if((y - y0) == size)
450 {
451 y = y0;
452 x++;
453
454 if(x >= LCD_W)
455 {
456 return;
457 }
458
459 break;
460 }
461 }
462 }
463}
464
474void lcd_string_show(uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p)
475{
476 uint8_t x0 = x;
477 width += x;
478 height += y;
479
480 while((*p <= '~') && (*p >= ' '))
481 {
482 if(x >= width)
483 {
484 x = x0;
485 y += size;
486 }
487
488 if(y >= height)
489 {
490 break;
491 }
492
493 lcd_char_show(x, y, *p, size, 0);
494 x += size / 2;
495 p++;
496 }
497}
498
508void lcd_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color)
509{
510 uint32_t i, num;
511 num = (ex - sx) * (ey - sy);
512 lcd_struct->lcd_setblock(sx, sy, ex, ey);
513
514 for(i = 0; i < num; i++)
515 {
516 lcd_writeonepoint(color);
517 }
518}
519
529void lcd_color_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color)
530{
531 uint16_t height, width;
532 uint16_t i, j;
533
534 width = ex - sx + 1;
535 height = ey - sy + 1;
536 lcd_struct->lcd_setblock(sx, sy, ex, ey);
537
538 for(i = 0; i < height; i++)
539 {
540 for(j = 0; j < width; j++)
541 {
542 lcd_writeonepoint(color[i * width + j]);
543 }
544 }
545}
font.h
xmc_lcd.h
xmc_lcd program header
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
LCD_H
#define LCD_H
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:79
WHITE
#define WHITE
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:84
RED
#define RED
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:90
LCD_W
#define LCD_W
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:78
asc2_2412
const unsigned char asc2_2412[95][36]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h:234
asc2_3216
const unsigned char asc2_3216[95][128]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h:332
asc2_1206
const unsigned char asc2_1206[95][12]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h:38
asc2_1608
const unsigned char asc2_1608[95][16]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h:136
LCD_BL_HIGH
#define LCD_BL_HIGH
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:81
lcd_color_fill
void lcd_color_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color)
this function is fill in lcd with color-pointer
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c:529
lcd_setblock
void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd.
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c:332
lcd_char_show
void lcd_char_show(uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode)
this function is show char to lcd
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c:400
lcd_dev_struct
lcd_dev_type lcd_dev_struct
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c:38
lcd_init
void lcd_init(void)
configures the lcd. this function must be called before any write/read operation on the lcd.
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c:165
lcd_string_show
void lcd_string_show(uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p)
this function is show string to lcd
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c:474
lcd_fill
void lcd_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color)
this function is fill in lcd with concolorous
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c:508
lcd_drawpoint
void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd.
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c:367
lcd_wr_command
void lcd_wr_command(uint16_t command)
this function is write command to lcd.
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c:300
lcd_rd_data
uint16_t lcd_rd_data(void)
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c:315
lcd_clear
void lcd_clear(uint16_t color)
this function is clear the lcd.
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c:379
lcd_struct
lcd_dev_type * lcd_struct
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c:48
lcd_writeonepoint
void lcd_writeonepoint(uint16_t color)
this function is write one point to lcd.
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c:357
lcd_wr_data
void lcd_wr_data(uint16_t data)
this function is write data to lcd.
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c:310
xmc_init
void xmc_init(void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write...
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c:57
j
uint32_t j
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:44
XMC_LCD_COMMAND
#define XMC_LCD_COMMAND
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:65
XMC_LCD_DATA
#define XMC_LCD_DATA
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:66
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_XMC_PERIPH_CLOCK
@ CRM_XMC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:123
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f435_437_gpio.h:146
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_10
@ GPIO_MUX_10
Definition: at32f435_437_gpio.h:166
GPIO_MUX_14
@ GPIO_MUX_14
Definition: at32f435_437_gpio.h:170
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f435_437_gpio.h:64
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
xmc_nor_sram_init
void xmc_nor_sram_init(xmc_norsram_init_type *xmc_norsram_init_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_norsraminitstruct.
Definition: at32f435_437_xmc.c:78
xmc_norsram_timing_default_para_init
void xmc_norsram_timing_default_para_init(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
fill each xmc_rw_timing_struct and xmc_w_timing_struct member with its default value.
Definition: at32f435_437_xmc.c:176
xmc_nor_sram_timing_config
void xmc_nor_sram_timing_config(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_rw_timing_struct a...
Definition: at32f435_437_xmc.c:113
xmc_norsram_default_para_init
void xmc_norsram_default_para_init(xmc_norsram_init_type *xmc_nor_sram_init_struct)
fill each xmc_nor_sram_init_struct member with its default value.
Definition: at32f435_437_xmc.c:150
xmc_nor_sram_enable
void xmc_nor_sram_enable(xmc_nor_sram_subbank_type xmc_subbank, confirm_state new_state)
enable or disable the specified nor/sram memory bank.
Definition: at32f435_437_xmc.c:210
XMC_WAIT_SIGNAL_DISABLE
@ XMC_WAIT_SIGNAL_DISABLE
Definition: at32f435_437_xmc.h:101
XMC_WAIT_SIGNAL_SYN_BEFORE
@ XMC_WAIT_SIGNAL_SYN_BEFORE
Definition: at32f435_437_xmc.h:196
XMC_WRITE_OPERATION_ENABLE
@ XMC_WRITE_OPERATION_ENABLE
Definition: at32f435_437_xmc.h:93
XMC_WRITE_BURST_SYN_DISABLE
@ XMC_WRITE_BURST_SYN_DISABLE
Definition: at32f435_437_xmc.h:110
XMC_BURST_MODE_DISABLE
@ XMC_BURST_MODE_DISABLE
Definition: at32f435_437_xmc.h:65
XMC_DATA_ADDR_MUX_DISABLE
@ XMC_DATA_ADDR_MUX_DISABLE
Definition: at32f435_437_xmc.h:56
XMC_BUSTYPE_16_BITS
@ XMC_BUSTYPE_16_BITS
Definition: at32f435_437_xmc.h:179
XMC_WRITE_TIMING_ENABLE
@ XMC_WRITE_TIMING_ENABLE
Definition: at32f435_437_xmc.h:120
XMC_BANK1_NOR_SRAM4
@ XMC_BANK1_NOR_SRAM4
Definition: at32f435_437_xmc.h:149
XMC_ASYN_WAIT_DISABLE
@ XMC_ASYN_WAIT_DISABLE
Definition: at32f435_437_xmc.h:74
XMC_WRAPPED_MODE_DISABLE
@ XMC_WRAPPED_MODE_DISABLE
Definition: at32f435_437_xmc.h:83
XMC_ACCESS_MODE_A
@ XMC_ACCESS_MODE_A
Definition: at32f435_437_xmc.h:205
XMC_WAIT_SIGNAL_LEVEL_LOW
@ XMC_WAIT_SIGNAL_LEVEL_LOW
Definition: at32f435_437_xmc.h:187
XMC_DEVICE_SRAM
@ XMC_DEVICE_SRAM
Definition: at32f435_437_xmc.h:168
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
lcd_dev_type
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:44
lcd_dev_type::lcd_setblock
void(* lcd_setblock)(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:48
lcd_dev_type::lcd_id
uint16_t lcd_id
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:45
lcd_dev_type::xmc_init
void(* xmc_init)(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:46
xmc_norsram_init_type
xmc nor/sram init structure definition
Definition: at32f435_437_xmc.h:409
xmc_norsram_init_type::wait_signal_enable
xmc_wait_signal_type wait_signal_enable
Definition: at32f435_437_xmc.h:420
xmc_norsram_init_type::data_addr_multiplex
xmc_data_addr_mux_type data_addr_multiplex
Definition: at32f435_437_xmc.h:411
xmc_norsram_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:421
xmc_norsram_init_type::burst_mode_enable
xmc_burst_access_mode_type burst_mode_enable
Definition: at32f435_437_xmc.h:414
xmc_norsram_init_type::bus_type
xmc_data_width_type bus_type
Definition: at32f435_437_xmc.h:413
xmc_norsram_init_type::device
xmc_memory_type device
Definition: at32f435_437_xmc.h:412
xmc_norsram_init_type::wait_signal_lv
xmc_wait_signal_polarity_type wait_signal_lv
Definition: at32f435_437_xmc.h:416
xmc_norsram_init_type::wrapped_mode_enable
xmc_wrap_mode_type wrapped_mode_enable
Definition: at32f435_437_xmc.h:417
xmc_norsram_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:410
xmc_norsram_init_type::write_burst_syn
xmc_write_burst_type write_burst_syn
Definition: at32f435_437_xmc.h:422
xmc_norsram_init_type::asynwait_enable
xmc_asyn_wait_type asynwait_enable
Definition: at32f435_437_xmc.h:415
xmc_norsram_init_type::wait_signal_config
xmc_wait_timing_type wait_signal_config
Definition: at32f435_437_xmc.h:418
xmc_norsram_init_type::write_enable
xmc_write_operation_type write_enable
Definition: at32f435_437_xmc.h:419
xmc_norsram_timing_init_type
nor/sram banks timing parameters
Definition: at32f435_437_xmc.h:393
xmc_norsram_timing_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:395
xmc_norsram_timing_init_type::data_latency_time
uint32_t data_latency_time
Definition: at32f435_437_xmc.h:401
xmc_norsram_timing_init_type::addr_hold_time
uint32_t addr_hold_time
Definition: at32f435_437_xmc.h:397
xmc_norsram_timing_init_type::bus_latency_time
uint32_t bus_latency_time
Definition: at32f435_437_xmc.h:399
xmc_norsram_timing_init_type::addr_setup_time
uint32_t addr_setup_time
Definition: at32f435_437_xmc.h:396
xmc_norsram_timing_init_type::mode
xmc_access_mode_type mode
Definition: at32f435_437_xmc.h:402
xmc_norsram_timing_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:394
xmc_norsram_timing_init_type::clk_psc
uint32_t clk_psc
Definition: at32f435_437_xmc.h:400
xmc_norsram_timing_init_type::data_setup_time
uint32_t data_setup_time
Definition: at32f435_437_xmc.h:398


AT32F435/437 Firmwary Library: xmc_lcd.h File Reference

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • lcd
Data Structures | Macros | Functions | Variables
at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h File Reference

xmc_lcd program header More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Data Structures

struct lcd_dev_type

Macros

#define | XMC_LCD_COMMAND (0x6C000000)
#define | XMC_LCD_DATA (0x6C000800)
#define | LCD_W 320
#define | LCD_H 240
#define | LCD_BL_HIGH gpio_bits_set(GPIOC,GPIO_PINS_0)
#define | LCD_BL_LOW gpio_bits_reset(GPIOC,GPIO_PINS_0)
#define | WHITE 0xFFFF
#define | BLACK 0x0000
#define | BLUE 0x001F
#define | BRED 0xF81F
#define | GRED 0xFFE0
#define | GBLUE 0x07FF
#define | RED 0xF800
#define | MAGENTA 0xF81F
#define | GREEN 0x07E0
#define | CYAN 0x7FFF
#define | YELLOW 0xFFE0
#define | BROWN 0xBC40
#define | BRRED 0xFC07
#define | GRAY 0x8430

Functions

void | xmc_init (void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_init (void)
configures the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_wr_command (uint16_t command)
this function is write command to lcd. More...
void | lcd_wr_data (uint16_t data)
this function is write data to lcd. More...
uint16_t | lcd_rd_data (void)
void | lcd_setblock (uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd. More...
void | lcd_writeonepoint (uint16_t color)
this function is write one point to lcd. More...
void | lcd_drawpoint (uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd. More...
void | lcd_clear (uint16_t color)
this function is clear the lcd. More...
void | lcd_char_show (uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode)
this function is show char to lcd More...
void | lcd_string_show (uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p)
this function is show string to lcd More...
void | lcd_fill (uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color)
this function is fill in lcd with concolorous More...
void | lcd_color_fill (uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color)
this function is fill in lcd with color-pointer More...

Variables

lcd_dev_type lcd_dev_struct
lcd_dev_type * lcd_struct
static uint16_t LCD_ID

Detailed Description

xmc_lcd program header

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.


AT32F435/437 Firmwary Library: xmc_lcd.h Source File

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • lcd
at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h
Go to the documentation of this file.
1
26#ifndef __XMC_LCD_H
27#define __XMC_LCD_H
28
29#include "at32f435_437_board.h"
30
43typedef struct
44{
45 uint16_t lcd_id;
46 void (*xmc_init)(void);
47 void (*lcd_init)(void);
48 void (*lcd_setblock)(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend);
49 void (*draw_point)(uint16_t x, uint16_t y, uint16_t color);
50 void (*lcd_clear)(uint16_t color);
51} lcd_dev_type;
52
57extern lcd_dev_type lcd_dev_struct;
58extern lcd_dev_type *lcd_struct;
59
64/* the address of write data & command (xmc_a0) */
65#define XMC_LCD_COMMAND (0x6C000000)
66#define XMC_LCD_DATA (0x6C000800)
78#define LCD_W 320
79#define LCD_H 240
80
81#define LCD_BL_HIGH gpio_bits_set(GPIOC,GPIO_PINS_0)
82#define LCD_BL_LOW gpio_bits_reset(GPIOC,GPIO_PINS_0)
83static uint16_t LCD_ID;
84#define WHITE 0xFFFF
85#define BLACK 0x0000
86#define BLUE 0x001F
87#define BRED 0xF81F
88#define GRED 0xFFE0
89#define GBLUE 0x07FF
90#define RED 0xF800
91#define MAGENTA 0xF81F
92#define GREEN 0x07E0
93#define CYAN 0x7FFF
94#define YELLOW 0xFFE0
95#define BROWN 0xBC40
96#define BRRED 0xFC07
97#define GRAY 0x8430
98
103void xmc_init(void);
104void lcd_init(void);
105void lcd_wr_command(uint16_t command);
106void lcd_wr_data(uint16_t data);
107uint16_t lcd_rd_data(void);
108void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend);
109void lcd_writeonepoint(uint16_t color);
110void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color);
111void lcd_clear(uint16_t color);
112void lcd_char_show(uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode);
113void lcd_string_show(uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p);
114void lcd_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color);
115void lcd_color_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color);
116
129#endif
130
131
at32f435_437_board.h
lcd_color_fill
void lcd_color_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color)
this function is fill in lcd with color-pointer
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:529
lcd_setblock
void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:332
lcd_char_show
void lcd_char_show(uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode)
this function is show char to lcd
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:400
lcd_init
void lcd_init(void)
configures the lcd. this function must be called before any write/read operation on the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:165
lcd_string_show
void lcd_string_show(uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p)
this function is show string to lcd
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:474
lcd_fill
void lcd_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color)
this function is fill in lcd with concolorous
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:508
lcd_drawpoint
void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:367
lcd_wr_command
void lcd_wr_command(uint16_t command)
this function is write command to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:300
lcd_rd_data
uint16_t lcd_rd_data(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:315
lcd_clear
void lcd_clear(uint16_t color)
this function is clear the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:379
lcd_writeonepoint
void lcd_writeonepoint(uint16_t color)
this function is write one point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:357
lcd_wr_data
void lcd_wr_data(uint16_t data)
this function is write data to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:310
xmc_init
void xmc_init(void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write...
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:57
lcd_dev_struct
lcd_dev_type lcd_dev_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:38
LCD_ID
static uint16_t LCD_ID
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h:83
lcd_struct
lcd_dev_type * lcd_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:48
lcd_dev_type
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:44


AT32F435/437 Firmwary Library: ov5640.c File Reference

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • ov5640
Macros | Functions | Variables
at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c File Reference

ov5640 program More...

#include "at32f435_437.h"
#include "at32f435_437_board.h"
#include "ov5640.h"
#include "ov5640cfg.h"
#include "ov5640af.h"
#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0x2FFFFFF
#define | I2Cx_CLKCTRL 0x30F05292
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_DMA DMA1
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_AF GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_AF GPIO_MUX_4

Functions

error_status | ov5640_reg_write (uint16_t reg, uint8_t data)
write register to ov5640 More...
error_status | ov5640_reg_read (uint16_t reg, uint8_t *data)
read register from ov5640 More...
error_status | ov5640_init (void)
initialize ov5640 More...
void | ov5640_jpeg_mode (void)
ov5640 jpeg mode configure More...
void | ov5640_rgb565_mode (void)
ov5640 rgb565 mode configure More...
void | ov5640_exposure (uint8_t exposure)
ov5640 exposure configure More...
void | ov5640_light_mode (uint8_t mode)
this function is draw point to lcd More...
void | ov5640_color_saturation (uint8_t sat)
ov5640 color saturation configure More...
void | ov5640_brightness (uint8_t bright)
ov5640 brightness configure More...
void | ov5640_contrast (uint8_t contrast)
ov5640 contrast configure More...
void | ov5640_sharpness (uint8_t sharp)
ov5640 sharpness configure More...
void | ov5640_special_effects (uint8_t eft)
ov5640 special effects configure More...
void | ov5640_flash_ctrl (uint8_t sw)
ov5640 flash control More...
void | ov5640_outsize_set (uint16_t offx, uint16_t offy, uint16_t width, uint16_t height)
ov5640 output size set More...
void | ov5640_imagewin_set (uint16_t offx, uint16_t offy, uint16_t width, uint16_t height)
ov5640 image window set More...
error_status | ov5640_focus_init (void)
initialize ov5640 focus function More...
error_status | ov5640_focus_single (void)
ov5640 focus single More...
error_status | ov5640_focus_constant (void)
ov5640 focus constant More...
void | ov5640_i2c_init (void)
ov5640 i2c initialize More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...

Variables

i2c_handle_type hi2cx
i2c_status_type STA
const uint8_t | OV5640_EXPOSURE_TBL [7][6]
const uint8_t | OV5640_LIGHTMODE_TBL [5][7]
const uint8_t | OV5640_SATURATION_TBL [7][6]
const uint8_t | OV5640_EFFECTS_TBL [7][3]

Detailed Description

ov5640 program

header file of ov5640 program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.


AT32F435/437 Firmwary Library: ov5640.c Source File

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • ov5640
at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c
Go to the documentation of this file.
1
27#include "at32f435_437.h"
28#include "at32f435_437_board.h"
29#include "ov5640.h"
30#include "ov5640cfg.h"
31#include "ov5640af.h"
32#include "i2c_application.h"
33
42#define I2C_TIMEOUT 0x2FFFFFF
43
44#define I2Cx_CLKCTRL 0x30F05292
45#define I2Cx_ADDRESS 0xA0
46
47#define I2Cx_PORT I2C1
48#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
49#define I2Cx_DMA DMA1
50#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
51
52#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
53#define I2Cx_SCL_GPIO_PIN GPIO_PINS_6
54#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
55#define I2Cx_SCL_GPIO_PORT GPIOB
56#define I2Cx_SCL_GPIO_AF GPIO_MUX_4
57
58#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
59#define I2Cx_SDA_GPIO_PIN GPIO_PINS_7
60#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
61#define I2Cx_SDA_GPIO_PORT GPIOB
62#define I2Cx_SDA_GPIO_AF GPIO_MUX_4
63
64 i2c_handle_type hi2cx;
65 i2c_status_type STA;
66
67const uint8_t OV5640_EXPOSURE_TBL[7][6] =
68{
69 0x10, 0x08, 0x10, 0x08, 0x20, 0x10, /* -3 */
70 0x20, 0x18, 0x41, 0x20, 0x18, 0x10, /* -2 */
71 0x30, 0x28, 0x61, 0x30, 0x28, 0x10, /* -1 */
72 0x38, 0x30, 0x61, 0x38, 0x30, 0x10, /* 0 */
73 0x40, 0x38, 0x71, 0x40, 0x38, 0x10, /* +1 */
74 0x50, 0x48, 0x90, 0x50, 0x48, 0x20, /* +2 */
75 0x60, 0x58, 0xa0, 0x60, 0x58, 0x20, /* +3 */
76};
77
78const uint8_t OV5640_LIGHTMODE_TBL[5][7] =
79{
80 0x04, 0x00, 0x04, 0x00, 0x04, 0x00, 0x00, /* auto */
81 0x06, 0x1C, 0x04, 0x00, 0x04, 0xF3, 0x01, /* sunny */
82 0x05, 0x48, 0x04, 0x00, 0x07, 0xCF, 0x01, /* office */
83 0x06, 0x48, 0x04, 0x00, 0x04, 0xD3, 0x01, /* cloudy */
84 0x04, 0x10, 0x04, 0x00, 0x08, 0x40, 0x01, /* home */
85};
86
87const uint8_t OV5640_SATURATION_TBL[7][6] =
88{
89 0x0C, 0x30, 0x3D, 0x3E, 0x3D, 0x01, /* -3 */
90 0x10, 0x3D, 0x4D, 0x4E, 0x4D, 0x01, /* -2 */
91 0x15, 0x52, 0x66, 0x68, 0x66, 0x02, /* -1 */
92 0x1A, 0x66, 0x80, 0x82, 0x80, 0x02, /* +0 */
93 0x1F, 0x7A, 0x9A, 0x9C, 0x9A, 0x02, /* +1 */
94 0x24, 0x8F, 0xB3, 0xB6, 0xB3, 0x03, /* +2 */
95 0x2B, 0xAB, 0xD6, 0xDA, 0xD6, 0x04, /* +3 */
96};
97
98const uint8_t OV5640_EFFECTS_TBL[7][3] =
99{
100 0x06, 0x40, 0x10,
101 0x1E, 0xA0, 0x40,
102 0x1E, 0x80, 0xC0,
103 0x1E, 0x80, 0x80,
104 0x1E, 0x40, 0xA0,
105 0x40, 0x40, 0x10,
106 0x1E, 0x60, 0x60,
107};
108
115 error_status ov5640_reg_write(uint16_t reg, uint8_t data)
116{
117 uint8_t temp_data[3];
118 temp_data[0] = reg >> 8;
119 temp_data[1] = reg;
120 temp_data[2] = data;
121
122 if((STA = i2c_master_transmit(&hi2cx, (uint16_t)OV5640_ADDR, (uint8_t*)temp_data, 3, 1000000)) != I2C_OK)
123 {
124 return ERROR;
125 }
126
127 return SUCCESS;
128}
129
136 error_status ov5640_reg_read(uint16_t reg, uint8_t *data)
137{
138 uint8_t temp_data[2];
139 temp_data[0] = reg >> 8;
140 temp_data[1] = reg;
141
142 if(i2c_master_transmit(&hi2cx, (uint16_t)OV5640_ADDR, (uint8_t*)temp_data, 2, 10000) != I2C_OK)
143 {
144 return ERROR;
145 }
146
147 if(i2c_master_receive(&hi2cx, (uint16_t)OV5640_ADDR, data, 1, 10000) != I2C_OK)
148 {
149 return ERROR;
150 }
151
152 return SUCCESS;
153}
154
160 error_status ov5640_init(void)
161{
162 uint16_t i = 0;
163 uint8_t temp = 0;
164 uint16_t reg;
165 gpio_init_type gpio_initure;
166
167 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
168 gpio_default_para_init(&gpio_initure);
169 /* DVP_RST Pin-PD6 */
170 gpio_initure.gpio_pins = GPIO_PINS_3;
171 gpio_initure.gpio_mode = GPIO_MODE_OUTPUT;
172 gpio_initure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
173 gpio_initure.gpio_pull = GPIO_PULL_UP;
174 gpio_initure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
175 gpio_init(GPIOC, &gpio_initure);
176
177 OV5640_RST_LOW;
178 delay_ms(100);
179 OV5640_RST_HIGH;
180 delay_ms(20);
181 ov5640_i2c_init();
182 delay_ms(5);
183 ov5640_reg_read(OV5640_CHIPIDH, &temp);
184 reg = (uint16_t)temp << 8;
185 ov5640_reg_read(OV5640_CHIPIDL, &temp);
186 reg |= temp;
187
188 if(reg != OV5640_ID)
189 {
190 return ERROR;
191 }
192
193 ov5640_reg_write(0x3103, 0x11);
194 ov5640_reg_write(0x3008, 0x82);
195 delay_ms(10);
196
197 for(i = 0; i < sizeof(ov5640_uxga_init_reg_tbl) / 4; i++)
198 {
199 ov5640_reg_write(ov5640_uxga_init_reg_tbl[i][0], ov5640_uxga_init_reg_tbl[i][1]);
200 }
201
202#if LIGHT_SWITCH
203 ov5640_flash_ctrl(1);
204 delay_ms(500);
205 ov5640_flash_ctrl(0);
206#endif
207
208 return SUCCESS;
209}
210
216void ov5640_jpeg_mode(void)
217{
218 uint16_t i = 0;
219
220 for(i = 0; i < (sizeof(OV5640_jpeg_reg_tbl) / 4); i++)
221 {
222 ov5640_reg_write(OV5640_jpeg_reg_tbl[i][0], OV5640_jpeg_reg_tbl[i][1]);
223 }
224}
225
231void ov5640_rgb565_mode(void)
232{
233 uint16_t i = 0;
234
235 for(i = 0; i < (sizeof(ov5640_rgb565_reg_tbl) / 4); i++)
236 {
237 ov5640_reg_write(ov5640_rgb565_reg_tbl[i][0], ov5640_rgb565_reg_tbl[i][1]);
238 }
239}
240
246void ov5640_exposure(uint8_t exposure)
247{
248 ov5640_reg_write(0x3212, 0x03);
249 ov5640_reg_write(0x3a0f, OV5640_EXPOSURE_TBL[exposure][0]);
250 ov5640_reg_write(0x3a10, OV5640_EXPOSURE_TBL[exposure][1]);
251 ov5640_reg_write(0x3a1b, OV5640_EXPOSURE_TBL[exposure][2]);
252 ov5640_reg_write(0x3a1e, OV5640_EXPOSURE_TBL[exposure][3]);
253 ov5640_reg_write(0x3a11, OV5640_EXPOSURE_TBL[exposure][4]);
254 ov5640_reg_write(0x3a1f, OV5640_EXPOSURE_TBL[exposure][5]);
255 ov5640_reg_write(0x3212, 0x13);
256 ov5640_reg_write(0x3212, 0xa3);
257}
258
269void ov5640_light_mode(uint8_t mode)
270{
271 uint8_t i;
272 ov5640_reg_write(0x3212, 0x03);
273
274 for(i = 0; i < 7; i++)
275 {
276 ov5640_reg_write(0x3400 + i, OV5640_LIGHTMODE_TBL[mode][i]);
277 }
278
279 ov5640_reg_write(0x3212, 0x13);
280 ov5640_reg_write(0x3212, 0xa3);
281}
282
288void ov5640_color_saturation(uint8_t sat)
289{
290 uint8_t i;
291 ov5640_reg_write(0x3212, 0x03);
292 ov5640_reg_write(0x5381, 0x1c);
293 ov5640_reg_write(0x5382, 0x5a);
294 ov5640_reg_write(0x5383, 0x06);
295
296 for(i = 0; i < 6; i++)
297 {
298 ov5640_reg_write(0x5384 + i, OV5640_SATURATION_TBL[sat][i]);
299 }
300
301 ov5640_reg_write(0x538b, 0x98);
302 ov5640_reg_write(0x538a, 0x01);
303 ov5640_reg_write(0x3212, 0x13);
304 ov5640_reg_write(0x3212, 0xa3);
305}
306
312void ov5640_brightness(uint8_t bright)
313{
314 uint8_t brtval;
315
316 if(bright < 4)
317 {
318 brtval = 4 - bright;
319 }
320 else
321 {
322 brtval = bright - 4;
323 }
324
325 ov5640_reg_write(0x3212, 0x03);
326 ov5640_reg_write(0x5587, brtval << 4);
327
328 if(bright < 4)
329 {
330 ov5640_reg_write(0x5588, 0x09);
331 }
332 else
333 {
334 ov5640_reg_write(0x5588, 0x01);
335 }
336
337 ov5640_reg_write(0x3212, 0x13);
338 ov5640_reg_write(0x3212, 0xa3);
339}
340
346void ov5640_contrast(uint8_t contrast)
347{
348 uint8_t reg0val = 0x00;
349 uint8_t reg1val = 0x20;
350
351 switch(contrast)
352 {
353 case 0:
354 reg1val = reg0val = 0x14;
355 break;
356
357 case 1:
358 reg1val = reg0val = 0x18;
359 break;
360
361 case 2:
362 reg1val = reg0val = 0x1C;
363 break;
364
365 case 4:
366 reg0val = 0x10;
367 reg1val = 0x24;
368 break;
369
370 case 5:
371 reg0val = 0x18;
372 reg1val = 0x28;
373 break;
374
375 case 6:
376 reg0val = 0x1C;
377 reg1val = 0x2C;
378 break;
379 }
380
381 ov5640_reg_write(0x3212, 0x03);
382 ov5640_reg_write(0x5585, reg0val);
383 ov5640_reg_write(0x5586, reg1val);
384 ov5640_reg_write(0x3212, 0x13);
385 ov5640_reg_write(0x3212, 0xa3);
386}
387
393void ov5640_sharpness(uint8_t sharp)
394{
395 if(sharp < 33)
396 {
397 ov5640_reg_write(0x5308, 0x65);
398 ov5640_reg_write(0x5302, sharp);
399 }
400 else
401 {
402 ov5640_reg_write(0x5308, 0x25);
403 ov5640_reg_write(0x5300, 0x08);
404 ov5640_reg_write(0x5301, 0x30);
405 ov5640_reg_write(0x5302, 0x10);
406 ov5640_reg_write(0x5303, 0x00);
407 ov5640_reg_write(0x5309, 0x08);
408 ov5640_reg_write(0x530a, 0x30);
409 ov5640_reg_write(0x530b, 0x04);
410 ov5640_reg_write(0x530c, 0x06);
411 }
412
413}
414
420void ov5640_special_effects(uint8_t eft)
421{
422 ov5640_reg_write(0x3212, 0x03);
423 ov5640_reg_write(0x5580, OV5640_EFFECTS_TBL[eft][0]);
424 ov5640_reg_write(0x5583, OV5640_EFFECTS_TBL[eft][1]);
425 ov5640_reg_write(0x5584, OV5640_EFFECTS_TBL[eft][2]);
426 ov5640_reg_write(0x5003, 0x08);
427 ov5640_reg_write(0x3212, 0x13);
428 ov5640_reg_write(0x3212, 0xa3);
429}
430
436void ov5640_flash_ctrl(uint8_t sw)
437{
438 ov5640_reg_write(0x3016, 0x02);
439 ov5640_reg_write(0x301C, 0x02);
440
441 if(sw)
442 {
443 ov5640_reg_write(0x3019, 0x02);
444 }
445 else
446 {
447 ov5640_reg_write(0x3019, 0x00);
448 }
449}
450
459void ov5640_outsize_set(uint16_t offx, uint16_t offy, uint16_t width, uint16_t height)
460{
461 ov5640_reg_write(0x3212, 0x03);
462 ov5640_reg_write(0x3808, width >> 8);
463 ov5640_reg_write(0x3809, width & 0xFF);
464 ov5640_reg_write(0x380a, height >> 8);
465 ov5640_reg_write(0x380b, height & 0xFF);
466
467 ov5640_reg_write(0x3810, offx >> 8);
468 ov5640_reg_write(0x3811, offx & 0xFF);
469
470 ov5640_reg_write(0x3812, offy >> 8);
471 ov5640_reg_write(0x3813, offy & 0xFF);
472
473 ov5640_reg_write(0x3212, 0x13);
474 ov5640_reg_write(0x3212, 0xA3);
475}
476
485void ov5640_imagewin_set(uint16_t offx, uint16_t offy, uint16_t width, uint16_t height)
486{
487 uint16_t xst, yst, xend, yend;
488 xst = offx;
489 yst = offy;
490 xend = offx + width - 1;
491 yend = offy + height - 1;
492 ov5640_reg_write(0x3212, 0x03);
493 ov5640_reg_write(0x3800, xst >> 8);
494 ov5640_reg_write(0x3801, xst & 0xFF);
495 ov5640_reg_write(0x3802, yst >> 8);
496 ov5640_reg_write(0x3803, yst & 0xFF);
497 ov5640_reg_write(0x3804, xend >> 8);
498 ov5640_reg_write(0x3805, xend & 0xFF);
499 ov5640_reg_write(0x3806, yend >> 8);
500 ov5640_reg_write(0x3807, yend & 0xFF);
501 ov5640_reg_write(0x3212, 0x13);
502 ov5640_reg_write(0x3212, 0xA3);
503}
504
510 error_status ov5640_focus_init(void)
511{
512 uint16_t i;
513 uint16_t addr = 0x8000;
514 uint8_t state = 0x8F;
515 ov5640_reg_write(0x3000, 0x20);
516
517 for(i = 0; i < sizeof(OV5640_AF_Config); i++)
518 {
519 ov5640_reg_write(addr, OV5640_AF_Config[i]);
520 addr++;
521 }
522
523 ov5640_reg_write(0x3022, 0x00);
524 ov5640_reg_write(0x3023, 0x00);
525 ov5640_reg_write(0x3024, 0x00);
526 ov5640_reg_write(0x3025, 0x00);
527 ov5640_reg_write(0x3026, 0x00);
528 ov5640_reg_write(0x3027, 0x00);
529 ov5640_reg_write(0x3028, 0x00);
530 ov5640_reg_write(0x3029, 0x7f);
531 ov5640_reg_write(0x3000, 0x00);
532 i = 0;
533
534 do
535 {
536 ov5640_reg_read(0x3029, &state);
537 delay_ms(5);
538 i++;
539
540 if(i > 1000)
541 {
542 return ERROR;
543 }
544 }
545 while(state != 0x70);
546
547 return SUCCESS;
548}
549
555 error_status ov5640_focus_single(void)
556{
557 uint8_t temp;
558 uint16_t retry = 0;
559 ov5640_reg_write(0x3022, 0x03);
560
561 while(1)
562 {
563 retry++;
564 ov5640_reg_read(0x3029, &temp);
565
566 if(temp == 0x10)
567 {
568 break;
569 }
570
571 delay_ms(5);
572
573 if(retry > 1000)
574 {
575 return SUCCESS;
576 }
577 }
578
579 return ERROR;
580}
581
587 error_status ov5640_focus_constant(void)
588{
589 uint8_t temp = 0;
590 uint16_t retry = 0;
591 ov5640_reg_write(0x3023, 0x01);
592 ov5640_reg_write(0x3022, 0x08);
593
594 do
595 {
596 ov5640_reg_read(0x3023, &temp);
597 retry++;
598
599 if(retry > 1000)
600 {
601 return ERROR;
602 }
603
604 delay_ms(5);
605 }
606 while(temp != 0x00);
607
608 ov5640_reg_write(0x3023, 0x01);
609 ov5640_reg_write(0x3022, 0x04);
610 retry = 0;
611
612 do
613 {
614 ov5640_reg_read(0x3023, &temp);
615 retry++;
616
617 if(retry > 1000)
618 {
619 return ERROR;
620 }
621
622 delay_ms(5);
623 }
624 while(temp != 0x00);
625
626 return SUCCESS;
627}
628
634void ov5640_i2c_init(void)
635{
636 hi2cx.i2cx = I2C2;
637 i2c_config(&hi2cx);
638}
639
645void i2c_lowlevel_init(i2c_handle_type* hi2c)
646{
647 gpio_init_type gpio_init_structure;
648
649 /* i2c periph clock enable */
650 crm_periph_clock_enable(CRM_I2C2_PERIPH_CLOCK, TRUE);
651 crm_periph_clock_enable(CRM_GPIOH_PERIPH_CLOCK, TRUE);
652 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
653
654 /* gpio configuration */
655 gpio_pin_mux_config(GPIOH, GPIO_PINS_SOURCE2, GPIO_MUX_4);
656
657 gpio_pin_mux_config(GPIOH, GPIO_PINS_SOURCE3, GPIO_MUX_4);
658
659 gpio_default_para_init(&gpio_init_structure);
660 /* configure i2c pins: scl */
661 gpio_init_structure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
662 gpio_init_structure.gpio_mode = GPIO_MODE_MUX;
663 gpio_init_structure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
664 gpio_init_structure.gpio_pull = GPIO_PULL_UP;
665 gpio_init_structure.gpio_pins = GPIO_PINS_2;
666 gpio_init(GPIOH, &gpio_init_structure);
667
668 gpio_init_structure.gpio_pins = GPIO_PINS_3;
669 gpio_init(GPIOH, &gpio_init_structure);
670
671 /* configure and enable i2c interrupt */
672 nvic_irq_enable(I2C2_EVT_IRQn, 0, 0);
673 nvic_irq_enable(I2C2_ERR_IRQn, 0, 0);
674
675 /* configure and enable i2c dma channel interrupt */
676 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
677 nvic_irq_enable(DMA1_Channel2_IRQn, 0, 0);
678
679 /* i2c dma tx and rx channels configuration */
680 /* enable the dma clock */
681
682 /* i2c dma channel configuration */
683 dma_reset(hi2c->dma_tx_channel);
684 dma_reset(hi2c->dma_rx_channel);
685
686 hi2c->dma_tx_channel = DMA1_CHANNEL1;
687 hi2c->dma_rx_channel = DMA1_CHANNEL2;
688
689 hi2c->dma_init_struct.peripheral_base_addr = (uint32_t)&hi2c->i2cx->txdt;
690 hi2c->dma_init_struct.memory_base_addr = 0;
691 hi2c->dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
692 hi2c->dma_init_struct.buffer_size = 0xFFFF;
693 hi2c->dma_init_struct.peripheral_inc_enable = FALSE;
694 hi2c->dma_init_struct.memory_inc_enable = TRUE;
695 hi2c->dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
696 hi2c->dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
697 hi2c->dma_init_struct.loop_mode_enable = FALSE;
698 hi2c->dma_init_struct.priority = DMA_PRIORITY_LOW;
699
700 dma_init(hi2c->dma_tx_channel, &hi2c->dma_init_struct);
701 dma_init(hi2c->dma_rx_channel, &hi2c->dma_init_struct);
702
703 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_I2C1_TX);
704 dmamux_init(DMA1MUX_CHANNEL2, DMAMUX_DMAREQ_ID_I2C1_RX);
705
706 dmamux_enable(DMA1, TRUE);
707
708 /* config i2c */
709 i2c_init(hi2c->i2cx, 0x0F, I2Cx_CLKCTRL);
710
711 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
712}
713
at32f435_437.h
at32f435_437 header file
at32f435_437_board.h
ov5640.h
ov5640af.h
header file of ov5640af program
ov5640cfg.h
header file of ov5640cfg program
STA
i2c_status_type STA
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:65
ov5640_init
error_status ov5640_init(void)
initialize ov5640
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:160
OV5640_EXPOSURE_TBL
const uint8_t OV5640_EXPOSURE_TBL[7][6]
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:67
ov5640_outsize_set
void ov5640_outsize_set(uint16_t offx, uint16_t offy, uint16_t width, uint16_t height)
ov5640 output size set
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:459
ov5640_light_mode
void ov5640_light_mode(uint8_t mode)
this function is draw point to lcd
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:269
ov5640_focus_constant
error_status ov5640_focus_constant(void)
ov5640 focus constant
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:587
ov5640_brightness
void ov5640_brightness(uint8_t bright)
ov5640 brightness configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:312
ov5640_reg_read
error_status ov5640_reg_read(uint16_t reg, uint8_t *data)
read register from ov5640
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:136
ov5640_focus_single
error_status ov5640_focus_single(void)
ov5640 focus single
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:555
ov5640_color_saturation
void ov5640_color_saturation(uint8_t sat)
ov5640 color saturation configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:288
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:45
ov5640_rgb565_reg_tbl
const uint16_t ov5640_rgb565_reg_tbl[][2]
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h:89
ov5640_flash_ctrl
void ov5640_flash_ctrl(uint8_t sw)
ov5640 flash control
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:436
OV5640_LIGHTMODE_TBL
const uint8_t OV5640_LIGHTMODE_TBL[5][7]
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:78
ov5640_i2c_init
void ov5640_i2c_init(void)
ov5640 i2c initialize
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:634
I2Cx_CLKCTRL
#define I2Cx_CLKCTRL
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:44
ov5640_rgb565_mode
void ov5640_rgb565_mode(void)
ov5640 rgb565 mode configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:231
ov5640_uxga_init_reg_tbl
const uint16_t ov5640_uxga_init_reg_tbl[][2]
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h:154
OV5640_jpeg_reg_tbl
const uint16_t OV5640_jpeg_reg_tbl[][2]
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h:39
ov5640_jpeg_mode
void ov5640_jpeg_mode(void)
ov5640 jpeg mode configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:216
ov5640_sharpness
void ov5640_sharpness(uint8_t sharp)
ov5640 sharpness configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:393
OV5640_EFFECTS_TBL
const uint8_t OV5640_EFFECTS_TBL[7][3]
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:98
hi2cx
i2c_handle_type hi2cx
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:64
ov5640_special_effects
void ov5640_special_effects(uint8_t eft)
ov5640 special effects configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:420
OV5640_SATURATION_TBL
const uint8_t OV5640_SATURATION_TBL[7][6]
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:87
OV5640_AF_Config
const unsigned char OV5640_AF_Config[]
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640af.h:38
i2c_lowlevel_init
void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:645
ov5640_reg_write
error_status ov5640_reg_write(uint16_t reg, uint8_t data)
write register to ov5640
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:115
ov5640_exposure
void ov5640_exposure(uint8_t exposure)
ov5640 exposure configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:246
ov5640_imagewin_set
void ov5640_imagewin_set(uint16_t offx, uint16_t offy, uint16_t width, uint16_t height)
ov5640 image window set
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:485
ov5640_focus_init
error_status ov5640_focus_init(void)
initialize ov5640 focus function
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:510
ov5640_contrast
void ov5640_contrast(uint8_t contrast)
ov5640 contrast configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:346
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_GPIOH_PERIPH_CLOCK
@ CRM_GPIOH_PERIPH_CLOCK
Definition: at32f435_437_crm.h:112
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
CRM_I2C2_PERIPH_CLOCK
@ CRM_I2C2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:145
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:162
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:172
DMA_PRIORITY_LOW
@ DMA_PRIORITY_LOW
Definition: at32f435_437_dma.h:182
DMAMUX_DMAREQ_ID_I2C1_RX
@ DMAMUX_DMAREQ_ID_I2C1_RX
Definition: at32f435_437_dma.h:216
DMAMUX_DMAREQ_ID_I2C1_TX
@ DMAMUX_DMAREQ_ID_I2C1_TX
Definition: at32f435_437_dma.h:217
DMA1MUX_CHANNEL2
#define DMA1MUX_CHANNEL2
Definition: at32f435_437_dma.h:705
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f435_437_dma.h:697
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f435_437_gpio.h:103
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_4
@ GPIO_MUX_4
Definition: at32f435_437_gpio.h:160
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOH
#define GPIOH
Definition: at32f435_437_gpio.h:528
i2c_init
void i2c_init(i2c_type *i2c_x, uint8_t dfilters, uint32_t clk)
init i2c digit filters and clock control register.
Definition: at32f435_437_i2c.c:79
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config i2c own address 1.
Definition: at32f435_437_i2c.c:103
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f435_437_i2c.h:113
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:113
i2c_master_receive
i2c_status_type i2c_master_receive(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through polling mode.
Definition: i2c_application.c:524
i2c_master_transmit
i2c_status_type i2c_master_transmit(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode.
Definition: i2c_application.c:375
i2c_status_type
i2c_status_type
Definition: i2c_application.h:80
I2C_OK
@ I2C_OK
Definition: i2c_application.h:81
I2C2
#define I2C2
Definition: at32f435_437_i2c.h:415
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
DMA1_Channel2_IRQn
@ DMA1_Channel2_IRQn
Definition: at32f435_437.h:205
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f435_437.h:204
I2C2_ERR_IRQn
@ I2C2_ERR_IRQn
Definition: at32f435_437.h:182
I2C2_EVT_IRQn
@ I2C2_EVT_IRQn
Definition: at32f435_437.h:181
OV5640_RST_LOW
#define OV5640_RST_LOW
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h:47
OV5640_CHIPIDH
#define OV5640_CHIPIDH
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h:51
OV5640_RST_HIGH
#define OV5640_RST_HIGH
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h:46
OV5640_ADDR
#define OV5640_ADDR
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h:50
OV5640_CHIPIDL
#define OV5640_CHIPIDL
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h:52
OV5640_ID
#define OV5640_ID
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h:49
i2c_application.h
i2c application libray header file
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
i2c_handle_type
Definition: i2c_application.h:112
i2c_handle_type::dma_rx_channel
dma_channel_type * dma_rx_channel
Definition: i2c_application.h:121
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:113
i2c_handle_type::dma_init_struct
dma_init_type dma_init_struct
Definition: i2c_application.h:122
i2c_handle_type::dma_tx_channel
dma_channel_type * dma_tx_channel
Definition: i2c_application.h:120
i2c_type::txdt
__IO uint32_t txdt
Definition: at32f435_437_i2c.h:400


AT32F435/437 Firmwary Library: ov5640.h File Reference

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • ov5640
Macros | Functions
at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h File Reference
#include "at32f435_437.h"

Go to the source code of this file.

Macros

#define | LIGHT_SWITCH 0
#define | OV5640_RST_HIGH gpio_bits_set(GPIOC, GPIO_PINS_3);
#define | OV5640_RST_LOW gpio_bits_reset(GPIOC, GPIO_PINS_3);
#define | OV5640_ID ((uint16_t)0x5640)
#define | OV5640_ADDR ((uint16_t)0x0078)
#define | OV5640_CHIPIDH ((uint16_t)0x300A)
#define | OV5640_CHIPIDL ((uint16_t)0x300B)
#define | HARDWARE_MODE

Functions

error_status | ov5640_reg_write (uint16_t reg, uint8_t data)
write register to ov5640 More...
error_status | ov5640_reg_read (uint16_t reg, uint8_t *val)
read register from ov5640 More...
error_status | ov5640_init (void)
initialize ov5640 More...
void | ov5640_jpeg_mode (void)
ov5640 jpeg mode configure More...
void | ov5640_rgb565_mode (void)
ov5640 rgb565 mode configure More...
void | ov5640_exposure (uint8_t exposure)
ov5640 exposure configure More...
void | ov5640_light_mode (uint8_t mode)
this function is draw point to lcd More...
void | ov5640_color_saturation (uint8_t sat)
ov5640 color saturation configure More...
void | ov5640_brightness (uint8_t bright)
ov5640 brightness configure More...
void | ov5640_contrast (uint8_t contrast)
ov5640 contrast configure More...
void | ov5640_sharpness (uint8_t sharp)
ov5640 sharpness configure More...
void | ov5640_special_effects (uint8_t eft)
ov5640 special effects configure More...
void | ov5640_flash_ctrl (uint8_t sw)
ov5640 flash control More...
void | ov5640_outsize_set (uint16_t offx, uint16_t offy, uint16_t width, uint16_t height)
ov5640 output size set More...
void | ov5640_imagewin_set (uint16_t offx, uint16_t offy, uint16_t width, uint16_t height)
ov5640 image window set More...
error_status | ov5640_focus_init (void)
initialize ov5640 focus function More...
error_status | ov5640_focus_single (void)
ov5640 focus single More...
error_status | ov5640_focus_constant (void)
ov5640 focus constant More...
void | ov5640_i2c_init (void)
ov5640 i2c initialize More...


AT32F435/437 Firmwary Library: ov5640.h Source File

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • ov5640
at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
Go to the documentation of this file.
1
27#ifndef _OV5640_H
28#define _OV5640_H
29
30#include "at32f435_437.h"
31
44#define LIGHT_SWITCH 0
45
46#define OV5640_RST_HIGH gpio_bits_set(GPIOC, GPIO_PINS_3);
47#define OV5640_RST_LOW gpio_bits_reset(GPIOC, GPIO_PINS_3);
48
49#define OV5640_ID ((uint16_t)0x5640)
50#define OV5640_ADDR ((uint16_t)0x0078)
51#define OV5640_CHIPIDH ((uint16_t)0x300A)
52#define OV5640_CHIPIDL ((uint16_t)0x300B)
54#define HARDWARE_MODE
55//#define EMBEDDED_MODE
56
65 error_status ov5640_reg_write(uint16_t reg, uint8_t data);
66 error_status ov5640_reg_read(uint16_t reg, uint8_t *val);
67 error_status ov5640_init(void);
68void ov5640_jpeg_mode(void);
69void ov5640_rgb565_mode(void);
70void ov5640_exposure(uint8_t exposure);
71void ov5640_light_mode(uint8_t mode);
72void ov5640_color_saturation(uint8_t sat);
73void ov5640_brightness(uint8_t bright);
74void ov5640_contrast(uint8_t contrast);
75void ov5640_sharpness(uint8_t sharp);
76void ov5640_special_effects(uint8_t eft);
77void ov5640_flash_ctrl(uint8_t sw);
78void ov5640_outsize_set(uint16_t offx, uint16_t offy, uint16_t width, uint16_t height);
79void ov5640_imagewin_set(uint16_t offx, uint16_t offy, uint16_t width, uint16_t height);
80 error_status ov5640_focus_init(void);
81 error_status ov5640_focus_single(void);
82 error_status ov5640_focus_constant(void);
83void ov5640_i2c_init(void);
84
97#endif
at32f435_437.h
at32f435_437 header file
error_status
error_status
Definition: at32f435_437.h:380
ov5640_init
error_status ov5640_init(void)
initialize ov5640
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:160
ov5640_outsize_set
void ov5640_outsize_set(uint16_t offx, uint16_t offy, uint16_t width, uint16_t height)
ov5640 output size set
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:459
ov5640_light_mode
void ov5640_light_mode(uint8_t mode)
this function is draw point to lcd
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:269
ov5640_focus_constant
error_status ov5640_focus_constant(void)
ov5640 focus constant
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:587
ov5640_brightness
void ov5640_brightness(uint8_t bright)
ov5640 brightness configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:312
ov5640_reg_read
error_status ov5640_reg_read(uint16_t reg, uint8_t *val)
read register from ov5640
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:136
ov5640_focus_single
error_status ov5640_focus_single(void)
ov5640 focus single
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:555
ov5640_color_saturation
void ov5640_color_saturation(uint8_t sat)
ov5640 color saturation configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:288
ov5640_flash_ctrl
void ov5640_flash_ctrl(uint8_t sw)
ov5640 flash control
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:436
ov5640_i2c_init
void ov5640_i2c_init(void)
ov5640 i2c initialize
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:634
ov5640_rgb565_mode
void ov5640_rgb565_mode(void)
ov5640 rgb565 mode configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:231
ov5640_jpeg_mode
void ov5640_jpeg_mode(void)
ov5640 jpeg mode configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:216
ov5640_sharpness
void ov5640_sharpness(uint8_t sharp)
ov5640 sharpness configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:393
ov5640_special_effects
void ov5640_special_effects(uint8_t eft)
ov5640 special effects configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:420
ov5640_reg_write
error_status ov5640_reg_write(uint16_t reg, uint8_t data)
write register to ov5640
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:115
ov5640_exposure
void ov5640_exposure(uint8_t exposure)
ov5640 exposure configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:246
ov5640_imagewin_set
void ov5640_imagewin_set(uint16_t offx, uint16_t offy, uint16_t width, uint16_t height)
ov5640 image window set
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:485
ov5640_focus_init
error_status ov5640_focus_init(void)
initialize ov5640 focus function
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:510
ov5640_contrast
void ov5640_contrast(uint8_t contrast)
ov5640 contrast configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:346


AT32F435/437 Firmwary Library: ov5640af.h File Reference

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • ov5640
Variables
at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640af.h File Reference

header file of ov5640af program More...

Go to the source code of this file.

Variables

const unsigned char OV5640_AF_Config []

Detailed Description

header file of ov5640af program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640af.h.


AT32F435/437 Firmwary Library: ov5640af.h Source File

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • ov5640
at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640af.h
Go to the documentation of this file.
1
27#ifndef _OV5640AF_H
28#define _OV5640AF_H
29
38const unsigned char OV5640_AF_Config[] =
39{
40 0x02, 0x0F, 0xD6, 0x02, 0x0A, 0x39, 0xC2, 0x01, 0x22, 0x22, 0x00, 0x02, 0x0F, 0xB2, 0xE5, 0x1F,
41
42 0x70, 0x72, 0xF5, 0x1E, 0xD2, 0x35, 0xFF, 0xEF, 0x25, 0xE0, 0x24, 0x4E, 0xF8, 0xE4, 0xF6, 0x08,
43
44 0xF6, 0x0F, 0xBF, 0x34, 0xF2, 0x90, 0x0E, 0x93, 0xE4, 0x93, 0xFF, 0xE5, 0x4B, 0xC3, 0x9F, 0x50,
45
46 0x04, 0x7F, 0x05, 0x80, 0x02, 0x7F, 0xFB, 0x78, 0xBD, 0xA6, 0x07, 0x12, 0x0F, 0x04, 0x40, 0x04,
47
48 0x7F, 0x03, 0x80, 0x02, 0x7F, 0x30, 0x78, 0xBC, 0xA6, 0x07, 0xE6, 0x18, 0xF6, 0x08, 0xE6, 0x78,
49
50 0xB9, 0xF6, 0x78, 0xBC, 0xE6, 0x78, 0xBA, 0xF6, 0x78, 0xBF, 0x76, 0x33, 0xE4, 0x08, 0xF6, 0x78,
51
52 0xB8, 0x76, 0x01, 0x75, 0x4A, 0x02, 0x78, 0xB6, 0xF6, 0x08, 0xF6, 0x74, 0xFF, 0x78, 0xC1, 0xF6,
53
54 0x08, 0xF6, 0x75, 0x1F, 0x01, 0x78, 0xBC, 0xE6, 0x75, 0xF0, 0x05, 0xA4, 0xF5, 0x4B, 0x12, 0x0A,
55
56 0xFF, 0xC2, 0x37, 0x22, 0x78, 0xB8, 0xE6, 0xD3, 0x94, 0x00, 0x40, 0x02, 0x16, 0x22, 0xE5, 0x1F,
57
58 0xB4, 0x05, 0x23, 0xE4, 0xF5, 0x1F, 0xC2, 0x01, 0x78, 0xB6, 0xE6, 0xFE, 0x08, 0xE6, 0xFF, 0x78,
59
60 0x4E, 0xA6, 0x06, 0x08, 0xA6, 0x07, 0xA2, 0x37, 0xE4, 0x33, 0xF5, 0x3C, 0x90, 0x30, 0x28, 0xF0,
61
62 0x75, 0x1E, 0x10, 0xD2, 0x35, 0x22, 0xE5, 0x4B, 0x75, 0xF0, 0x05, 0x84, 0x78, 0xBC, 0xF6, 0x90,
63
64 0x0E, 0x8C, 0xE4, 0x93, 0xFF, 0x25, 0xE0, 0x24, 0x0A, 0xF8, 0xE6, 0xFC, 0x08, 0xE6, 0xFD, 0x78,
65
66 0xBC, 0xE6, 0x25, 0xE0, 0x24, 0x4E, 0xF8, 0xA6, 0x04, 0x08, 0xA6, 0x05, 0xEF, 0x12, 0x0F, 0x0B,
67
68 0xD3, 0x78, 0xB7, 0x96, 0xEE, 0x18, 0x96, 0x40, 0x0D, 0x78, 0xBC, 0xE6, 0x78, 0xB9, 0xF6, 0x78,
69
70 0xB6, 0xA6, 0x06, 0x08, 0xA6, 0x07, 0x90, 0x0E, 0x8C, 0xE4, 0x93, 0x12, 0x0F, 0x0B, 0xC3, 0x78,
71
72 0xC2, 0x96, 0xEE, 0x18, 0x96, 0x50, 0x0D, 0x78, 0xBC, 0xE6, 0x78, 0xBA, 0xF6, 0x78, 0xC1, 0xA6,
73
74 0x06, 0x08, 0xA6, 0x07, 0x78, 0xB6, 0xE6, 0xFE, 0x08, 0xE6, 0xC3, 0x78, 0xC2, 0x96, 0xFF, 0xEE,
75
76 0x18, 0x96, 0x78, 0xC3, 0xF6, 0x08, 0xA6, 0x07, 0x90, 0x0E, 0x95, 0xE4, 0x18, 0x12, 0x0E, 0xE9,
77
78 0x40, 0x02, 0xD2, 0x37, 0x78, 0xBC, 0xE6, 0x08, 0x26, 0x08, 0xF6, 0xE5, 0x1F, 0x64, 0x01, 0x70,
79
80 0x4A, 0xE6, 0xC3, 0x78, 0xC0, 0x12, 0x0E, 0xDF, 0x40, 0x05, 0x12, 0x0E, 0xDA, 0x40, 0x39, 0x12,
81
82 0x0F, 0x02, 0x40, 0x04, 0x7F, 0xFE, 0x80, 0x02, 0x7F, 0x02, 0x78, 0xBD, 0xA6, 0x07, 0x78, 0xB9,
83
84 0xE6, 0x24, 0x03, 0x78, 0xBF, 0xF6, 0x78, 0xB9, 0xE6, 0x24, 0xFD, 0x78, 0xC0, 0xF6, 0x12, 0x0F,
85
86 0x02, 0x40, 0x06, 0x78, 0xC0, 0xE6, 0xFF, 0x80, 0x04, 0x78, 0xBF, 0xE6, 0xFF, 0x78, 0xBE, 0xA6,
87
88 0x07, 0x75, 0x1F, 0x02, 0x78, 0xB8, 0x76, 0x01, 0x02, 0x02, 0x4A, 0xE5, 0x1F, 0x64, 0x02, 0x60,
89
90 0x03, 0x02, 0x02, 0x2A, 0x78, 0xBE, 0xE6, 0xFF, 0xC3, 0x78, 0xC0, 0x12, 0x0E, 0xE0, 0x40, 0x08,
91
92 0x12, 0x0E, 0xDA, 0x50, 0x03, 0x02, 0x02, 0x28, 0x12, 0x0F, 0x02, 0x40, 0x04, 0x7F, 0xFF, 0x80,
93
94 0x02, 0x7F, 0x01, 0x78, 0xBD, 0xA6, 0x07, 0x78, 0xB9, 0xE6, 0x04, 0x78, 0xBF, 0xF6, 0x78, 0xB9,
95
96 0xE6, 0x14, 0x78, 0xC0, 0xF6, 0x18, 0x12, 0x0F, 0x04, 0x40, 0x04, 0xE6, 0xFF, 0x80, 0x02, 0x7F,
97
98 0x00, 0x78, 0xBF, 0xA6, 0x07, 0xD3, 0x08, 0xE6, 0x64, 0x80, 0x94, 0x80, 0x40, 0x04, 0xE6, 0xFF,
99
100 0x80, 0x02, 0x7F, 0x00, 0x78, 0xC0, 0xA6, 0x07, 0xC3, 0x18, 0xE6, 0x64, 0x80, 0x94, 0xB3, 0x50,
101
102 0x04, 0xE6, 0xFF, 0x80, 0x02, 0x7F, 0x33, 0x78, 0xBF, 0xA6, 0x07, 0xC3, 0x08, 0xE6, 0x64, 0x80,
103
104 0x94, 0xB3, 0x50, 0x04, 0xE6, 0xFF, 0x80, 0x02, 0x7F, 0x33, 0x78, 0xC0, 0xA6, 0x07, 0x12, 0x0F,
105
106 0x02, 0x40, 0x06, 0x78, 0xC0, 0xE6, 0xFF, 0x80, 0x04, 0x78, 0xBF, 0xE6, 0xFF, 0x78, 0xBE, 0xA6,
107
108 0x07, 0x75, 0x1F, 0x03, 0x78, 0xB8, 0x76, 0x01, 0x80, 0x20, 0xE5, 0x1F, 0x64, 0x03, 0x70, 0x26,
109
110 0x78, 0xBE, 0xE6, 0xFF, 0xC3, 0x78, 0xC0, 0x12, 0x0E, 0xE0, 0x40, 0x05, 0x12, 0x0E, 0xDA, 0x40,
111
112 0x09, 0x78, 0xB9, 0xE6, 0x78, 0xBE, 0xF6, 0x75, 0x1F, 0x04, 0x78, 0xBE, 0xE6, 0x75, 0xF0, 0x05,
113
114 0xA4, 0xF5, 0x4B, 0x02, 0x0A, 0xFF, 0xE5, 0x1F, 0xB4, 0x04, 0x10, 0x90, 0x0E, 0x94, 0xE4, 0x78,
115
116 0xC3, 0x12, 0x0E, 0xE9, 0x40, 0x02, 0xD2, 0x37, 0x75, 0x1F, 0x05, 0x22, 0x30, 0x01, 0x03, 0x02,
117
118 0x04, 0xC0, 0x30, 0x02, 0x03, 0x02, 0x04, 0xC0, 0x90, 0x51, 0xA5, 0xE0, 0x78, 0x93, 0xF6, 0xA3,
119
120 0xE0, 0x08, 0xF6, 0xA3, 0xE0, 0x08, 0xF6, 0xE5, 0x1F, 0x70, 0x3C, 0x75, 0x1E, 0x20, 0xD2, 0x35,
121
122 0x12, 0x0C, 0x7A, 0x78, 0x7E, 0xA6, 0x06, 0x08, 0xA6, 0x07, 0x78, 0x8B, 0xA6, 0x09, 0x18, 0x76,
123
124 0x01, 0x12, 0x0C, 0x5B, 0x78, 0x4E, 0xA6, 0x06, 0x08, 0xA6, 0x07, 0x78, 0x8B, 0xE6, 0x78, 0x6E,
125
126 0xF6, 0x75, 0x1F, 0x01, 0x78, 0x93, 0xE6, 0x78, 0x90, 0xF6, 0x78, 0x94, 0xE6, 0x78, 0x91, 0xF6,
127
128 0x78, 0x95, 0xE6, 0x78, 0x92, 0xF6, 0x22, 0x79, 0x90, 0xE7, 0xD3, 0x78, 0x93, 0x96, 0x40, 0x05,
129
130 0xE7, 0x96, 0xFF, 0x80, 0x08, 0xC3, 0x79, 0x93, 0xE7, 0x78, 0x90, 0x96, 0xFF, 0x78, 0x88, 0x76,
131
132 0x00, 0x08, 0xA6, 0x07, 0x79, 0x91, 0xE7, 0xD3, 0x78, 0x94, 0x96, 0x40, 0x05, 0xE7, 0x96, 0xFF,
133
134 0x80, 0x08, 0xC3, 0x79, 0x94, 0xE7, 0x78, 0x91, 0x96, 0xFF, 0x12, 0x0C, 0x8E, 0x79, 0x92, 0xE7,
135
136 0xD3, 0x78, 0x95, 0x96, 0x40, 0x05, 0xE7, 0x96, 0xFF, 0x80, 0x08, 0xC3, 0x79, 0x95, 0xE7, 0x78,
137
138 0x92, 0x96, 0xFF, 0x12, 0x0C, 0x8E, 0x12, 0x0C, 0x5B, 0x78, 0x8A, 0xE6, 0x25, 0xE0, 0x24, 0x4E,
139
140 0xF8, 0xA6, 0x06, 0x08, 0xA6, 0x07, 0x78, 0x8A, 0xE6, 0x24, 0x6E, 0xF8, 0xA6, 0x09, 0x78, 0x8A,
141
142 0xE6, 0x24, 0x01, 0xFF, 0xE4, 0x33, 0xFE, 0xD3, 0xEF, 0x94, 0x0F, 0xEE, 0x64, 0x80, 0x94, 0x80,
143
144 0x40, 0x04, 0x7F, 0x00, 0x80, 0x05, 0x78, 0x8A, 0xE6, 0x04, 0xFF, 0x78, 0x8A, 0xA6, 0x07, 0xE5,
145
146 0x1F, 0xB4, 0x01, 0x0A, 0xE6, 0x60, 0x03, 0x02, 0x04, 0xC0, 0x75, 0x1F, 0x02, 0x22, 0x12, 0x0C,
147
148 0x7A, 0x78, 0x80, 0xA6, 0x06, 0x08, 0xA6, 0x07, 0x12, 0x0C, 0x7A, 0x78, 0x82, 0xA6, 0x06, 0x08,
149
150 0xA6, 0x07, 0x78, 0x6E, 0xE6, 0x78, 0x8C, 0xF6, 0x78, 0x6E, 0xE6, 0x78, 0x8D, 0xF6, 0x7F, 0x01,
151
152 0xEF, 0x25, 0xE0, 0x24, 0x4F, 0xF9, 0xC3, 0x78, 0x81, 0xE6, 0x97, 0x18, 0xE6, 0x19, 0x97, 0x50,
153
154 0x0A, 0x12, 0x0C, 0x82, 0x78, 0x80, 0xA6, 0x04, 0x08, 0xA6, 0x05, 0x74, 0x6E, 0x2F, 0xF9, 0x78,
155
156 0x8C, 0xE6, 0xC3, 0x97, 0x50, 0x08, 0x74, 0x6E, 0x2F, 0xF8, 0xE6, 0x78, 0x8C, 0xF6, 0xEF, 0x25,
157
158 0xE0, 0x24, 0x4F, 0xF9, 0xD3, 0x78, 0x83, 0xE6, 0x97, 0x18, 0xE6, 0x19, 0x97, 0x40, 0x0A, 0x12,
159
160 0x0C, 0x82, 0x78, 0x82, 0xA6, 0x04, 0x08, 0xA6, 0x05, 0x74, 0x6E, 0x2F, 0xF9, 0x78, 0x8D, 0xE6,
161
162 0xD3, 0x97, 0x40, 0x08, 0x74, 0x6E, 0x2F, 0xF8, 0xE6, 0x78, 0x8D, 0xF6, 0x0F, 0xEF, 0x64, 0x10,
163
164 0x70, 0x9E, 0xC3, 0x79, 0x81, 0xE7, 0x78, 0x83, 0x96, 0xFF, 0x19, 0xE7, 0x18, 0x96, 0x78, 0x84,
165
166 0xF6, 0x08, 0xA6, 0x07, 0xC3, 0x79, 0x8C, 0xE7, 0x78, 0x8D, 0x96, 0x08, 0xF6, 0xD3, 0x79, 0x81,
167
168 0xE7, 0x78, 0x7F, 0x96, 0x19, 0xE7, 0x18, 0x96, 0x40, 0x05, 0x09, 0xE7, 0x08, 0x80, 0x06, 0xC3,
169
170 0x79, 0x7F, 0xE7, 0x78, 0x81, 0x96, 0xFF, 0x19, 0xE7, 0x18, 0x96, 0xFE, 0x78, 0x86, 0xA6, 0x06,
171
172 0x08, 0xA6, 0x07, 0x79, 0x8C, 0xE7, 0xD3, 0x78, 0x8B, 0x96, 0x40, 0x05, 0xE7, 0x96, 0xFF, 0x80,
173
174 0x08, 0xC3, 0x79, 0x8B, 0xE7, 0x78, 0x8C, 0x96, 0xFF, 0x78, 0x8F, 0xA6, 0x07, 0xE5, 0x1F, 0x64,
175
176 0x02, 0x70, 0x69, 0x90, 0x0E, 0x91, 0x93, 0xFF, 0x18, 0xE6, 0xC3, 0x9F, 0x50, 0x72, 0x12, 0x0C,
177
178 0x4A, 0x12, 0x0C, 0x2F, 0x90, 0x0E, 0x8E, 0x12, 0x0C, 0x38, 0x78, 0x80, 0x12, 0x0C, 0x6B, 0x7B,
179
180 0x04, 0x12, 0x0C, 0x1D, 0xC3, 0x12, 0x06, 0x45, 0x50, 0x56, 0x90, 0x0E, 0x92, 0xE4, 0x93, 0xFF,
181
182 0x78, 0x8F, 0xE6, 0x9F, 0x40, 0x02, 0x80, 0x11, 0x90, 0x0E, 0x90, 0xE4, 0x93, 0xFF, 0xD3, 0x78,
183
184 0x89, 0xE6, 0x9F, 0x18, 0xE6, 0x94, 0x00, 0x40, 0x03, 0x75, 0x1F, 0x05, 0x12, 0x0C, 0x4A, 0x12,
185
186 0x0C, 0x2F, 0x90, 0x0E, 0x8F, 0x12, 0x0C, 0x38, 0x78, 0x7E, 0x12, 0x0C, 0x6B, 0x7B, 0x40, 0x12,
187
188 0x0C, 0x1D, 0xD3, 0x12, 0x06, 0x45, 0x40, 0x18, 0x75, 0x1F, 0x05, 0x22, 0xE5, 0x1F, 0xB4, 0x05,
189
190 0x0F, 0xD2, 0x01, 0xC2, 0x02, 0xE4, 0xF5, 0x1F, 0xF5, 0x1E, 0xD2, 0x35, 0xD2, 0x33, 0xD2, 0x36,
191
192 0x22, 0xEF, 0x8D, 0xF0, 0xA4, 0xA8, 0xF0, 0xCF, 0x8C, 0xF0, 0xA4, 0x28, 0xCE, 0x8D, 0xF0, 0xA4,
193
194 0x2E, 0xFE, 0x22, 0xBC, 0x00, 0x0B, 0xBE, 0x00, 0x29, 0xEF, 0x8D, 0xF0, 0x84, 0xFF, 0xAD, 0xF0,
195
196 0x22, 0xE4, 0xCC, 0xF8, 0x75, 0xF0, 0x08, 0xEF, 0x2F, 0xFF, 0xEE, 0x33, 0xFE, 0xEC, 0x33, 0xFC,
197
198 0xEE, 0x9D, 0xEC, 0x98, 0x40, 0x05, 0xFC, 0xEE, 0x9D, 0xFE, 0x0F, 0xD5, 0xF0, 0xE9, 0xE4, 0xCE,
199
200 0xFD, 0x22, 0xED, 0xF8, 0xF5, 0xF0, 0xEE, 0x84, 0x20, 0xD2, 0x1C, 0xFE, 0xAD, 0xF0, 0x75, 0xF0,
201
202 0x08, 0xEF, 0x2F, 0xFF, 0xED, 0x33, 0xFD, 0x40, 0x07, 0x98, 0x50, 0x06, 0xD5, 0xF0, 0xF2, 0x22,
203
204 0xC3, 0x98, 0xFD, 0x0F, 0xD5, 0xF0, 0xEA, 0x22, 0xE8, 0x8F, 0xF0, 0xA4, 0xCC, 0x8B, 0xF0, 0xA4,
205
206 0x2C, 0xFC, 0xE9, 0x8E, 0xF0, 0xA4, 0x2C, 0xFC, 0x8A, 0xF0, 0xED, 0xA4, 0x2C, 0xFC, 0xEA, 0x8E,
207
208 0xF0, 0xA4, 0xCD, 0xA8, 0xF0, 0x8B, 0xF0, 0xA4, 0x2D, 0xCC, 0x38, 0x25, 0xF0, 0xFD, 0xE9, 0x8F,
209
210 0xF0, 0xA4, 0x2C, 0xCD, 0x35, 0xF0, 0xFC, 0xEB, 0x8E, 0xF0, 0xA4, 0xFE, 0xA9, 0xF0, 0xEB, 0x8F,
211
212 0xF0, 0xA4, 0xCF, 0xC5, 0xF0, 0x2E, 0xCD, 0x39, 0xFE, 0xE4, 0x3C, 0xFC, 0xEA, 0xA4, 0x2D, 0xCE,
213
214 0x35, 0xF0, 0xFD, 0xE4, 0x3C, 0xFC, 0x22, 0x75, 0xF0, 0x08, 0x75, 0x82, 0x00, 0xEF, 0x2F, 0xFF,
215
216 0xEE, 0x33, 0xFE, 0xCD, 0x33, 0xCD, 0xCC, 0x33, 0xCC, 0xC5, 0x82, 0x33, 0xC5, 0x82, 0x9B, 0xED,
217
218 0x9A, 0xEC, 0x99, 0xE5, 0x82, 0x98, 0x40, 0x0C, 0xF5, 0x82, 0xEE, 0x9B, 0xFE, 0xED, 0x9A, 0xFD,
219
220 0xEC, 0x99, 0xFC, 0x0F, 0xD5, 0xF0, 0xD6, 0xE4, 0xCE, 0xFB, 0xE4, 0xCD, 0xFA, 0xE4, 0xCC, 0xF9,
221
222 0xA8, 0x82, 0x22, 0xB8, 0x00, 0xC1, 0xB9, 0x00, 0x59, 0xBA, 0x00, 0x2D, 0xEC, 0x8B, 0xF0, 0x84,
223
224 0xCF, 0xCE, 0xCD, 0xFC, 0xE5, 0xF0, 0xCB, 0xF9, 0x78, 0x18, 0xEF, 0x2F, 0xFF, 0xEE, 0x33, 0xFE,
225
226 0xED, 0x33, 0xFD, 0xEC, 0x33, 0xFC, 0xEB, 0x33, 0xFB, 0x10, 0xD7, 0x03, 0x99, 0x40, 0x04, 0xEB,
227
228 0x99, 0xFB, 0x0F, 0xD8, 0xE5, 0xE4, 0xF9, 0xFA, 0x22, 0x78, 0x18, 0xEF, 0x2F, 0xFF, 0xEE, 0x33,
229
230 0xFE, 0xED, 0x33, 0xFD, 0xEC, 0x33, 0xFC, 0xC9, 0x33, 0xC9, 0x10, 0xD7, 0x05, 0x9B, 0xE9, 0x9A,
231
232 0x40, 0x07, 0xEC, 0x9B, 0xFC, 0xE9, 0x9A, 0xF9, 0x0F, 0xD8, 0xE0, 0xE4, 0xC9, 0xFA, 0xE4, 0xCC,
233
234 0xFB, 0x22, 0x75, 0xF0, 0x10, 0xEF, 0x2F, 0xFF, 0xEE, 0x33, 0xFE, 0xED, 0x33, 0xFD, 0xCC, 0x33,
235
236 0xCC, 0xC8, 0x33, 0xC8, 0x10, 0xD7, 0x07, 0x9B, 0xEC, 0x9A, 0xE8, 0x99, 0x40, 0x0A, 0xED, 0x9B,
237
238 0xFD, 0xEC, 0x9A, 0xFC, 0xE8, 0x99, 0xF8, 0x0F, 0xD5, 0xF0, 0xDA, 0xE4, 0xCD, 0xFB, 0xE4, 0xCC,
239
240 0xFA, 0xE4, 0xC8, 0xF9, 0x22, 0xEB, 0x9F, 0xF5, 0xF0, 0xEA, 0x9E, 0x42, 0xF0, 0xE9, 0x9D, 0x42,
241
242 0xF0, 0xE8, 0x9C, 0x45, 0xF0, 0x22, 0xE8, 0x60, 0x0F, 0xEC, 0xC3, 0x13, 0xFC, 0xED, 0x13, 0xFD,
243
244 0xEE, 0x13, 0xFE, 0xEF, 0x13, 0xFF, 0xD8, 0xF1, 0x22, 0xE8, 0x60, 0x0F, 0xEF, 0xC3, 0x33, 0xFF,
245
246 0xEE, 0x33, 0xFE, 0xED, 0x33, 0xFD, 0xEC, 0x33, 0xFC, 0xD8, 0xF1, 0x22, 0xE4, 0x93, 0xFC, 0x74,
247
248 0x01, 0x93, 0xFD, 0x74, 0x02, 0x93, 0xFE, 0x74, 0x03, 0x93, 0xFF, 0x22, 0xE6, 0xFB, 0x08, 0xE6,
249
250 0xF9, 0x08, 0xE6, 0xFA, 0x08, 0xE6, 0xCB, 0xF8, 0x22, 0xEC, 0xF6, 0x08, 0xED, 0xF6, 0x08, 0xEE,
251
252 0xF6, 0x08, 0xEF, 0xF6, 0x22, 0xA4, 0x25, 0x82, 0xF5, 0x82, 0xE5, 0xF0, 0x35, 0x83, 0xF5, 0x83,
253
254 0x22, 0xD0, 0x83, 0xD0, 0x82, 0xF8, 0xE4, 0x93, 0x70, 0x12, 0x74, 0x01, 0x93, 0x70, 0x0D, 0xA3,
255
256 0xA3, 0x93, 0xF8, 0x74, 0x01, 0x93, 0xF5, 0x82, 0x88, 0x83, 0xE4, 0x73, 0x74, 0x02, 0x93, 0x68,
257
258 0x60, 0xEF, 0xA3, 0xA3, 0xA3, 0x80, 0xDF, 0x90, 0x38, 0x04, 0x78, 0x52, 0x12, 0x0B, 0xFD, 0x90,
259
260 0x38, 0x00, 0xE0, 0xFE, 0xA3, 0xE0, 0xFD, 0xED, 0xFF, 0xC3, 0x12, 0x0B, 0x9E, 0x90, 0x38, 0x10,
261
262 0x12, 0x0B, 0x92, 0x90, 0x38, 0x06, 0x78, 0x54, 0x12, 0x0B, 0xFD, 0x90, 0x38, 0x02, 0xE0, 0xFE,
263
264 0xA3, 0xE0, 0xFD, 0xED, 0xFF, 0xC3, 0x12, 0x0B, 0x9E, 0x90, 0x38, 0x12, 0x12, 0x0B, 0x92, 0xA3,
265
266 0xE0, 0xB4, 0x31, 0x07, 0x78, 0x52, 0x79, 0x52, 0x12, 0x0C, 0x13, 0x90, 0x38, 0x14, 0xE0, 0xB4,
267
268 0x71, 0x15, 0x78, 0x52, 0xE6, 0xFE, 0x08, 0xE6, 0x78, 0x02, 0xCE, 0xC3, 0x13, 0xCE, 0x13, 0xD8,
269
270 0xF9, 0x79, 0x53, 0xF7, 0xEE, 0x19, 0xF7, 0x90, 0x38, 0x15, 0xE0, 0xB4, 0x31, 0x07, 0x78, 0x54,
271
272 0x79, 0x54, 0x12, 0x0C, 0x13, 0x90, 0x38, 0x15, 0xE0, 0xB4, 0x71, 0x15, 0x78, 0x54, 0xE6, 0xFE,
273
274 0x08, 0xE6, 0x78, 0x02, 0xCE, 0xC3, 0x13, 0xCE, 0x13, 0xD8, 0xF9, 0x79, 0x55, 0xF7, 0xEE, 0x19,
275
276 0xF7, 0x79, 0x52, 0x12, 0x0B, 0xD9, 0x09, 0x12, 0x0B, 0xD9, 0xAF, 0x47, 0x12, 0x0B, 0xB2, 0xE5,
277
278 0x44, 0xFB, 0x7A, 0x00, 0xFD, 0x7C, 0x00, 0x12, 0x04, 0xD3, 0x78, 0x5A, 0xA6, 0x06, 0x08, 0xA6,
279
280 0x07, 0xAF, 0x45, 0x12, 0x0B, 0xB2, 0xAD, 0x03, 0x7C, 0x00, 0x12, 0x04, 0xD3, 0x78, 0x56, 0xA6,
281
282 0x06, 0x08, 0xA6, 0x07, 0xAF, 0x48, 0x78, 0x54, 0x12, 0x0B, 0xB4, 0xE5, 0x43, 0xFB, 0xFD, 0x7C,
283
284 0x00, 0x12, 0x04, 0xD3, 0x78, 0x5C, 0xA6, 0x06, 0x08, 0xA6, 0x07, 0xAF, 0x46, 0x7E, 0x00, 0x78,
285
286 0x54, 0x12, 0x0B, 0xB6, 0xAD, 0x03, 0x7C, 0x00, 0x12, 0x04, 0xD3, 0x78, 0x58, 0xA6, 0x06, 0x08,
287
288 0xA6, 0x07, 0xC3, 0x78, 0x5B, 0xE6, 0x94, 0x08, 0x18, 0xE6, 0x94, 0x00, 0x50, 0x05, 0x76, 0x00,
289
290 0x08, 0x76, 0x08, 0xC3, 0x78, 0x5D, 0xE6, 0x94, 0x08, 0x18, 0xE6, 0x94, 0x00, 0x50, 0x05, 0x76,
291
292 0x00, 0x08, 0x76, 0x08, 0x78, 0x5A, 0x12, 0x0B, 0xC6, 0xFF, 0xD3, 0x78, 0x57, 0xE6, 0x9F, 0x18,
293
294 0xE6, 0x9E, 0x40, 0x0E, 0x78, 0x5A, 0xE6, 0x13, 0xFE, 0x08, 0xE6, 0x78, 0x57, 0x12, 0x0C, 0x08,
295
296 0x80, 0x04, 0x7E, 0x00, 0x7F, 0x00, 0x78, 0x5E, 0x12, 0x0B, 0xBE, 0xFF, 0xD3, 0x78, 0x59, 0xE6,
297
298 0x9F, 0x18, 0xE6, 0x9E, 0x40, 0x0E, 0x78, 0x5C, 0xE6, 0x13, 0xFE, 0x08, 0xE6, 0x78, 0x59, 0x12,
299
300 0x0C, 0x08, 0x80, 0x04, 0x7E, 0x00, 0x7F, 0x00, 0xE4, 0xFC, 0xFD, 0x78, 0x62, 0x12, 0x06, 0x99,
301
302 0x78, 0x5A, 0x12, 0x0B, 0xC6, 0x78, 0x57, 0x26, 0xFF, 0xEE, 0x18, 0x36, 0xFE, 0x78, 0x66, 0x12,
303
304 0x0B, 0xBE, 0x78, 0x59, 0x26, 0xFF, 0xEE, 0x18, 0x36, 0xFE, 0xE4, 0xFC, 0xFD, 0x78, 0x6A, 0x12,
305
306 0x06, 0x99, 0x12, 0x0B, 0xCE, 0x78, 0x66, 0x12, 0x06, 0x8C, 0xD3, 0x12, 0x06, 0x45, 0x40, 0x08,
307
308 0x12, 0x0B, 0xCE, 0x78, 0x66, 0x12, 0x06, 0x99, 0x78, 0x54, 0x12, 0x0B, 0xD0, 0x78, 0x6A, 0x12,
309
310 0x06, 0x8C, 0xD3, 0x12, 0x06, 0x45, 0x40, 0x0A, 0x78, 0x54, 0x12, 0x0B, 0xD0, 0x78, 0x6A, 0x12,
311
312 0x06, 0x99, 0x78, 0x61, 0xE6, 0x90, 0x60, 0x01, 0xF0, 0x78, 0x65, 0xE6, 0xA3, 0xF0, 0x78, 0x69,
313
314 0xE6, 0xA3, 0xF0, 0x78, 0x55, 0xE6, 0xA3, 0xF0, 0x7D, 0x01, 0x78, 0x61, 0x12, 0x0B, 0xE9, 0x24,
315
316 0x01, 0x12, 0x0B, 0xA6, 0x78, 0x65, 0x12, 0x0B, 0xE9, 0x24, 0x02, 0x12, 0x0B, 0xA6, 0x78, 0x69,
317
318 0x12, 0x0B, 0xE9, 0x24, 0x03, 0x12, 0x0B, 0xA6, 0x78, 0x6D, 0x12, 0x0B, 0xE9, 0x24, 0x04, 0x12,
319
320 0x0B, 0xA6, 0x0D, 0xBD, 0x05, 0xD4, 0xC2, 0x0E, 0xC2, 0x06, 0x22, 0x85, 0x08, 0x41, 0x90, 0x30,
321
322 0x24, 0xE0, 0xF5, 0x3D, 0xA3, 0xE0, 0xF5, 0x3E, 0xA3, 0xE0, 0xF5, 0x3F, 0xA3, 0xE0, 0xF5, 0x40,
323
324 0xA3, 0xE0, 0xF5, 0x3C, 0xD2, 0x34, 0xE5, 0x41, 0x12, 0x06, 0xB1, 0x09, 0x31, 0x03, 0x09, 0x35,
325
326 0x04, 0x09, 0x3B, 0x05, 0x09, 0x3E, 0x06, 0x09, 0x41, 0x07, 0x09, 0x4A, 0x08, 0x09, 0x5B, 0x12,
327
328 0x09, 0x73, 0x18, 0x09, 0x89, 0x19, 0x09, 0x5E, 0x1A, 0x09, 0x6A, 0x1B, 0x09, 0xAD, 0x80, 0x09,
329
330 0xB2, 0x81, 0x0A, 0x1D, 0x8F, 0x0A, 0x09, 0x90, 0x0A, 0x1D, 0x91, 0x0A, 0x1D, 0x92, 0x0A, 0x1D,
331
332 0x93, 0x0A, 0x1D, 0x94, 0x0A, 0x1D, 0x98, 0x0A, 0x17, 0x9F, 0x0A, 0x1A, 0xEC, 0x00, 0x00, 0x0A,
333
334 0x38, 0x12, 0x0F, 0x74, 0x22, 0x12, 0x0F, 0x74, 0xD2, 0x03, 0x22, 0xD2, 0x03, 0x22, 0xC2, 0x03,
335
336 0x22, 0xA2, 0x37, 0xE4, 0x33, 0xF5, 0x3C, 0x02, 0x0A, 0x1D, 0xC2, 0x01, 0xC2, 0x02, 0xC2, 0x03,
337
338 0x12, 0x0D, 0x0D, 0x75, 0x1E, 0x70, 0xD2, 0x35, 0x02, 0x0A, 0x1D, 0x02, 0x0A, 0x04, 0x85, 0x40,
339
340 0x4A, 0x85, 0x3C, 0x4B, 0x12, 0x0A, 0xFF, 0x02, 0x0A, 0x1D, 0x85, 0x4A, 0x40, 0x85, 0x4B, 0x3C,
341
342 0x02, 0x0A, 0x1D, 0xE4, 0xF5, 0x22, 0xF5, 0x23, 0x85, 0x40, 0x31, 0x85, 0x3F, 0x30, 0x85, 0x3E,
343
344 0x2F, 0x85, 0x3D, 0x2E, 0x12, 0x0F, 0x46, 0x80, 0x1F, 0x75, 0x22, 0x00, 0x75, 0x23, 0x01, 0x74,
345
346 0xFF, 0xF5, 0x2D, 0xF5, 0x2C, 0xF5, 0x2B, 0xF5, 0x2A, 0x12, 0x0F, 0x46, 0x85, 0x2D, 0x40, 0x85,
347
348 0x2C, 0x3F, 0x85, 0x2B, 0x3E, 0x85, 0x2A, 0x3D, 0xE4, 0xF5, 0x3C, 0x80, 0x70, 0x12, 0x0F, 0x16,
349
350 0x80, 0x6B, 0x85, 0x3D, 0x45, 0x85, 0x3E, 0x46, 0xE5, 0x47, 0xC3, 0x13, 0xFF, 0xE5, 0x45, 0xC3,
351
352 0x9F, 0x50, 0x02, 0x8F, 0x45, 0xE5, 0x48, 0xC3, 0x13, 0xFF, 0xE5, 0x46, 0xC3, 0x9F, 0x50, 0x02,
353
354 0x8F, 0x46, 0xE5, 0x47, 0xC3, 0x13, 0xFF, 0xFD, 0xE5, 0x45, 0x2D, 0xFD, 0xE4, 0x33, 0xFC, 0xE5,
355
356 0x44, 0x12, 0x0F, 0x90, 0x40, 0x05, 0xE5, 0x44, 0x9F, 0xF5, 0x45, 0xE5, 0x48, 0xC3, 0x13, 0xFF,
357
358 0xFD, 0xE5, 0x46, 0x2D, 0xFD, 0xE4, 0x33, 0xFC, 0xE5, 0x43, 0x12, 0x0F, 0x90, 0x40, 0x05, 0xE5,
359
360 0x43, 0x9F, 0xF5, 0x46, 0x12, 0x06, 0xD7, 0x80, 0x14, 0x85, 0x40, 0x48, 0x85, 0x3F, 0x47, 0x85,
361
362 0x3E, 0x46, 0x85, 0x3D, 0x45, 0x80, 0x06, 0x02, 0x06, 0xD7, 0x12, 0x0D, 0x7E, 0x90, 0x30, 0x24,
363
364 0xE5, 0x3D, 0xF0, 0xA3, 0xE5, 0x3E, 0xF0, 0xA3, 0xE5, 0x3F, 0xF0, 0xA3, 0xE5, 0x40, 0xF0, 0xA3,
365
366 0xE5, 0x3C, 0xF0, 0x90, 0x30, 0x23, 0xE4, 0xF0, 0x22, 0xC0, 0xE0, 0xC0, 0x83, 0xC0, 0x82, 0xC0,
367
368 0xD0, 0x90, 0x3F, 0x0C, 0xE0, 0xF5, 0x32, 0xE5, 0x32, 0x30, 0xE3, 0x74, 0x30, 0x36, 0x66, 0x90,
369
370 0x60, 0x19, 0xE0, 0xF5, 0x0A, 0xA3, 0xE0, 0xF5, 0x0B, 0x90, 0x60, 0x1D, 0xE0, 0xF5, 0x14, 0xA3,
371
372 0xE0, 0xF5, 0x15, 0x90, 0x60, 0x21, 0xE0, 0xF5, 0x0C, 0xA3, 0xE0, 0xF5, 0x0D, 0x90, 0x60, 0x29,
373
374 0xE0, 0xF5, 0x0E, 0xA3, 0xE0, 0xF5, 0x0F, 0x90, 0x60, 0x31, 0xE0, 0xF5, 0x10, 0xA3, 0xE0, 0xF5,
375
376 0x11, 0x90, 0x60, 0x39, 0xE0, 0xF5, 0x12, 0xA3, 0xE0, 0xF5, 0x13, 0x30, 0x01, 0x06, 0x30, 0x33,
377
378 0x03, 0xD3, 0x80, 0x01, 0xC3, 0x92, 0x09, 0x30, 0x02, 0x06, 0x30, 0x33, 0x03, 0xD3, 0x80, 0x01,
379
380 0xC3, 0x92, 0x0A, 0x30, 0x33, 0x0C, 0x30, 0x03, 0x09, 0x20, 0x02, 0x06, 0x20, 0x01, 0x03, 0xD3,
381
382 0x80, 0x01, 0xC3, 0x92, 0x0B, 0x90, 0x30, 0x01, 0xE0, 0x44, 0x40, 0xF0, 0xE0, 0x54, 0xBF, 0xF0,
383
384 0xE5, 0x32, 0x30, 0xE1, 0x14, 0x30, 0x34, 0x11, 0x90, 0x30, 0x22, 0xE0, 0xF5, 0x08, 0xE4, 0xF0,
385
386 0x30, 0x00, 0x03, 0xD3, 0x80, 0x01, 0xC3, 0x92, 0x08, 0xE5, 0x32, 0x30, 0xE5, 0x12, 0x90, 0x56,
387
388 0xA1, 0xE0, 0xF5, 0x09, 0x30, 0x31, 0x09, 0x30, 0x05, 0x03, 0xD3, 0x80, 0x01, 0xC3, 0x92, 0x0D,
389
390 0x90, 0x3F, 0x0C, 0xE5, 0x32, 0xF0, 0xD0, 0xD0, 0xD0, 0x82, 0xD0, 0x83, 0xD0, 0xE0, 0x32, 0x90,
391
392 0x0E, 0x7E, 0xE4, 0x93, 0xFE, 0x74, 0x01, 0x93, 0xFF, 0xC3, 0x90, 0x0E, 0x7C, 0x74, 0x01, 0x93,
393
394 0x9F, 0xFF, 0xE4, 0x93, 0x9E, 0xFE, 0xE4, 0x8F, 0x3B, 0x8E, 0x3A, 0xF5, 0x39, 0xF5, 0x38, 0xAB,
395
396 0x3B, 0xAA, 0x3A, 0xA9, 0x39, 0xA8, 0x38, 0xAF, 0x4B, 0xFC, 0xFD, 0xFE, 0x12, 0x05, 0x28, 0x12,
397
398 0x0D, 0xE1, 0xE4, 0x7B, 0xFF, 0xFA, 0xF9, 0xF8, 0x12, 0x05, 0xB3, 0x12, 0x0D, 0xE1, 0x90, 0x0E,
399
400 0x69, 0xE4, 0x12, 0x0D, 0xF6, 0x12, 0x0D, 0xE1, 0xE4, 0x85, 0x4A, 0x37, 0xF5, 0x36, 0xF5, 0x35,
401
402 0xF5, 0x34, 0xAF, 0x37, 0xAE, 0x36, 0xAD, 0x35, 0xAC, 0x34, 0xA3, 0x12, 0x0D, 0xF6, 0x8F, 0x37,
403
404 0x8E, 0x36, 0x8D, 0x35, 0x8C, 0x34, 0xE5, 0x3B, 0x45, 0x37, 0xF5, 0x3B, 0xE5, 0x3A, 0x45, 0x36,
405
406 0xF5, 0x3A, 0xE5, 0x39, 0x45, 0x35, 0xF5, 0x39, 0xE5, 0x38, 0x45, 0x34, 0xF5, 0x38, 0xE4, 0xF5,
407
408 0x22, 0xF5, 0x23, 0x85, 0x3B, 0x31, 0x85, 0x3A, 0x30, 0x85, 0x39, 0x2F, 0x85, 0x38, 0x2E, 0x02,
409
410 0x0F, 0x46, 0xE0, 0xA3, 0xE0, 0x75, 0xF0, 0x02, 0xA4, 0xFF, 0xAE, 0xF0, 0xC3, 0x08, 0xE6, 0x9F,
411
412 0xF6, 0x18, 0xE6, 0x9E, 0xF6, 0x22, 0xFF, 0xE5, 0xF0, 0x34, 0x60, 0x8F, 0x82, 0xF5, 0x83, 0xEC,
413
414 0xF0, 0x22, 0x78, 0x52, 0x7E, 0x00, 0xE6, 0xFC, 0x08, 0xE6, 0xFD, 0x02, 0x04, 0xC1, 0xE4, 0xFC,
415
416 0xFD, 0x12, 0x06, 0x99, 0x78, 0x5C, 0xE6, 0xC3, 0x13, 0xFE, 0x08, 0xE6, 0x13, 0x22, 0x78, 0x52,
417
418 0xE6, 0xFE, 0x08, 0xE6, 0xFF, 0xE4, 0xFC, 0xFD, 0x22, 0xE7, 0xC4, 0xF8, 0x54, 0xF0, 0xC8, 0x68,
419
420 0xF7, 0x09, 0xE7, 0xC4, 0x54, 0x0F, 0x48, 0xF7, 0x22, 0xE6, 0xFC, 0xED, 0x75, 0xF0, 0x04, 0xA4,
421
422 0x22, 0x12, 0x06, 0x7C, 0x8F, 0x48, 0x8E, 0x47, 0x8D, 0x46, 0x8C, 0x45, 0x22, 0xE0, 0xFE, 0xA3,
423
424 0xE0, 0xFD, 0xEE, 0xF6, 0xED, 0x08, 0xF6, 0x22, 0x13, 0xFF, 0xC3, 0xE6, 0x9F, 0xFF, 0x18, 0xE6,
425
426 0x9E, 0xFE, 0x22, 0xE6, 0xC3, 0x13, 0xF7, 0x08, 0xE6, 0x13, 0x09, 0xF7, 0x22, 0xAD, 0x39, 0xAC,
427
428 0x38, 0xFA, 0xF9, 0xF8, 0x12, 0x05, 0x28, 0x8F, 0x3B, 0x8E, 0x3A, 0x8D, 0x39, 0x8C, 0x38, 0xAB,
429
430 0x37, 0xAA, 0x36, 0xA9, 0x35, 0xA8, 0x34, 0x22, 0x93, 0xFF, 0xE4, 0xFC, 0xFD, 0xFE, 0x12, 0x05,
431
432 0x28, 0x8F, 0x37, 0x8E, 0x36, 0x8D, 0x35, 0x8C, 0x34, 0x22, 0x78, 0x84, 0xE6, 0xFE, 0x08, 0xE6,
433
434 0xFF, 0xE4, 0x8F, 0x37, 0x8E, 0x36, 0xF5, 0x35, 0xF5, 0x34, 0x22, 0x90, 0x0E, 0x8C, 0xE4, 0x93,
435
436 0x25, 0xE0, 0x24, 0x0A, 0xF8, 0xE6, 0xFE, 0x08, 0xE6, 0xFF, 0x22, 0xE6, 0xFE, 0x08, 0xE6, 0xFF,
437
438 0xE4, 0x8F, 0x3B, 0x8E, 0x3A, 0xF5, 0x39, 0xF5, 0x38, 0x22, 0x78, 0x4E, 0xE6, 0xFE, 0x08, 0xE6,
439
440 0xFF, 0x22, 0xEF, 0x25, 0xE0, 0x24, 0x4E, 0xF8, 0xE6, 0xFC, 0x08, 0xE6, 0xFD, 0x22, 0x78, 0x89,
441
442 0xEF, 0x26, 0xF6, 0x18, 0xE4, 0x36, 0xF6, 0x22, 0x75, 0x89, 0x03, 0x75, 0xA8, 0x01, 0x75, 0xB8,
443
444 0x04, 0x75, 0x34, 0xFF, 0x75, 0x35, 0x0E, 0x75, 0x36, 0x15, 0x75, 0x37, 0x0D, 0x12, 0x0E, 0x9A,
445
446 0x12, 0x00, 0x09, 0x12, 0x0F, 0x16, 0x12, 0x00, 0x06, 0xD2, 0x00, 0xD2, 0x34, 0xD2, 0xAF, 0x75,
447
448 0x34, 0xFF, 0x75, 0x35, 0x0E, 0x75, 0x36, 0x49, 0x75, 0x37, 0x03, 0x12, 0x0E, 0x9A, 0x30, 0x08,
449
450 0x09, 0xC2, 0x34, 0x12, 0x08, 0xCB, 0xC2, 0x08, 0xD2, 0x34, 0x30, 0x0B, 0x09, 0xC2, 0x36, 0x12,
451
452 0x02, 0x6C, 0xC2, 0x0B, 0xD2, 0x36, 0x30, 0x09, 0x09, 0xC2, 0x36, 0x12, 0x00, 0x0E, 0xC2, 0x09,
453
454 0xD2, 0x36, 0x30, 0x0E, 0x03, 0x12, 0x06, 0xD7, 0x30, 0x35, 0xD3, 0x90, 0x30, 0x29, 0xE5, 0x1E,
455
456 0xF0, 0xB4, 0x10, 0x05, 0x90, 0x30, 0x23, 0xE4, 0xF0, 0xC2, 0x35, 0x80, 0xC1, 0xE4, 0xF5, 0x4B,
457
458 0x90, 0x0E, 0x7A, 0x93, 0xFF, 0xE4, 0x8F, 0x37, 0xF5, 0x36, 0xF5, 0x35, 0xF5, 0x34, 0xAF, 0x37,
459
460 0xAE, 0x36, 0xAD, 0x35, 0xAC, 0x34, 0x90, 0x0E, 0x6A, 0x12, 0x0D, 0xF6, 0x8F, 0x37, 0x8E, 0x36,
461
462 0x8D, 0x35, 0x8C, 0x34, 0x90, 0x0E, 0x72, 0x12, 0x06, 0x7C, 0xEF, 0x45, 0x37, 0xF5, 0x37, 0xEE,
463
464 0x45, 0x36, 0xF5, 0x36, 0xED, 0x45, 0x35, 0xF5, 0x35, 0xEC, 0x45, 0x34, 0xF5, 0x34, 0xE4, 0xF5,
465
466 0x22, 0xF5, 0x23, 0x85, 0x37, 0x31, 0x85, 0x36, 0x30, 0x85, 0x35, 0x2F, 0x85, 0x34, 0x2E, 0x12,
467
468 0x0F, 0x46, 0xE4, 0xF5, 0x22, 0xF5, 0x23, 0x90, 0x0E, 0x72, 0x12, 0x0D, 0xEA, 0x12, 0x0F, 0x46,
469
470 0xE4, 0xF5, 0x22, 0xF5, 0x23, 0x90, 0x0E, 0x6E, 0x12, 0x0D, 0xEA, 0x02, 0x0F, 0x46, 0xE5, 0x40,
471
472 0x24, 0xF2, 0xF5, 0x37, 0xE5, 0x3F, 0x34, 0x43, 0xF5, 0x36, 0xE5, 0x3E, 0x34, 0xA2, 0xF5, 0x35,
473
474 0xE5, 0x3D, 0x34, 0x28, 0xF5, 0x34, 0xE5, 0x37, 0xFF, 0xE4, 0xFE, 0xFD, 0xFC, 0x78, 0x18, 0x12,
475
476 0x06, 0x69, 0x8F, 0x40, 0x8E, 0x3F, 0x8D, 0x3E, 0x8C, 0x3D, 0xE5, 0x37, 0x54, 0xA0, 0xFF, 0xE5,
477
478 0x36, 0xFE, 0xE4, 0xFD, 0xFC, 0x78, 0x07, 0x12, 0x06, 0x56, 0x78, 0x10, 0x12, 0x0F, 0x9A, 0xE4,
479
480 0xFF, 0xFE, 0xE5, 0x35, 0xFD, 0xE4, 0xFC, 0x78, 0x0E, 0x12, 0x06, 0x56, 0x12, 0x0F, 0x9D, 0xE4,
481
482 0xFF, 0xFE, 0xFD, 0xE5, 0x34, 0xFC, 0x78, 0x18, 0x12, 0x06, 0x56, 0x78, 0x08, 0x12, 0x0F, 0x9A,
483
484 0x22, 0x8F, 0x3B, 0x8E, 0x3A, 0x8D, 0x39, 0x8C, 0x38, 0x22, 0x12, 0x06, 0x7C, 0x8F, 0x31, 0x8E,
485
486 0x30, 0x8D, 0x2F, 0x8C, 0x2E, 0x22, 0x93, 0xF9, 0xF8, 0x02, 0x06, 0x69, 0x00, 0x00, 0x00, 0x00,
487
488 0x12, 0x01, 0x17, 0x08, 0x31, 0x15, 0x53, 0x54, 0x44, 0x20, 0x20, 0x20, 0x20, 0x20, 0x13, 0x01,
489
490 0x10, 0x01, 0x56, 0x40, 0x1A, 0x30, 0x29, 0x7E, 0x00, 0x30, 0x04, 0x20, 0xDF, 0x30, 0x05, 0x40,
491
492 0xBF, 0x50, 0x03, 0x00, 0xFD, 0x50, 0x27, 0x01, 0xFE, 0x60, 0x00, 0x11, 0x00, 0x3F, 0x05, 0x30,
493
494 0x00, 0x3F, 0x06, 0x22, 0x00, 0x3F, 0x01, 0x2A, 0x00, 0x3F, 0x02, 0x00, 0x00, 0x36, 0x06, 0x07,
495
496 0x00, 0x3F, 0x0B, 0x0F, 0xF0, 0x00, 0x00, 0x00, 0x00, 0x30, 0x01, 0x40, 0xBF, 0x30, 0x01, 0x00,
497
498 0xBF, 0x30, 0x29, 0x70, 0x00, 0x3A, 0x00, 0x00, 0xFF, 0x3A, 0x00, 0x00, 0xFF, 0x36, 0x03, 0x36,
499
500 0x02, 0x41, 0x44, 0x58, 0x20, 0x18, 0x10, 0x0A, 0x04, 0x04, 0x00, 0x03, 0xFF, 0x64, 0x00, 0x00,
501
502 0x80, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x02, 0x04, 0x06, 0x06, 0x00, 0x03, 0x51, 0x00, 0x7A,
503
504 0x50, 0x3C, 0x28, 0x1E, 0x10, 0x10, 0x50, 0x2D, 0x28, 0x16, 0x10, 0x10, 0x02, 0x00, 0x10, 0x0C,
505
506 0x10, 0x04, 0x0C, 0x6E, 0x06, 0x05, 0x00, 0xA5, 0x5A, 0x00, 0xAE, 0x35, 0xAF, 0x36, 0xE4, 0xFD,
507
508 0xED, 0xC3, 0x95, 0x37, 0x50, 0x33, 0x12, 0x0F, 0xE2, 0xE4, 0x93, 0xF5, 0x38, 0x74, 0x01, 0x93,
509
510 0xF5, 0x39, 0x45, 0x38, 0x60, 0x23, 0x85, 0x39, 0x82, 0x85, 0x38, 0x83, 0xE0, 0xFC, 0x12, 0x0F,
511
512 0xE2, 0x74, 0x03, 0x93, 0x52, 0x04, 0x12, 0x0F, 0xE2, 0x74, 0x02, 0x93, 0x42, 0x04, 0x85, 0x39,
513
514 0x82, 0x85, 0x38, 0x83, 0xEC, 0xF0, 0x0D, 0x80, 0xC7, 0x22, 0x78, 0xBE, 0xE6, 0xD3, 0x08, 0xFF,
515
516 0xE6, 0x64, 0x80, 0xF8, 0xEF, 0x64, 0x80, 0x98, 0x22, 0x93, 0xFF, 0x7E, 0x00, 0xE6, 0xFC, 0x08,
517
518 0xE6, 0xFD, 0x12, 0x04, 0xC1, 0x78, 0xC1, 0xE6, 0xFC, 0x08, 0xE6, 0xFD, 0xD3, 0xEF, 0x9D, 0xEE,
519
520 0x9C, 0x22, 0x78, 0xBD, 0xD3, 0xE6, 0x64, 0x80, 0x94, 0x80, 0x22, 0x25, 0xE0, 0x24, 0x0A, 0xF8,
521
522 0xE6, 0xFE, 0x08, 0xE6, 0xFF, 0x22, 0xE5, 0x3C, 0xD3, 0x94, 0x00, 0x40, 0x0B, 0x90, 0x0E, 0x88,
523
524 0x12, 0x0B, 0xF1, 0x90, 0x0E, 0x86, 0x80, 0x09, 0x90, 0x0E, 0x82, 0x12, 0x0B, 0xF1, 0x90, 0x0E,
525
526 0x80, 0xE4, 0x93, 0xF5, 0x44, 0xA3, 0xE4, 0x93, 0xF5, 0x43, 0xD2, 0x06, 0x30, 0x06, 0x03, 0xD3,
527
528 0x80, 0x01, 0xC3, 0x92, 0x0E, 0x22, 0xA2, 0xAF, 0x92, 0x32, 0xC2, 0xAF, 0xE5, 0x23, 0x45, 0x22,
529
530 0x90, 0x0E, 0x5D, 0x60, 0x0E, 0x12, 0x0F, 0xCB, 0xE0, 0xF5, 0x2C, 0x12, 0x0F, 0xC8, 0xE0, 0xF5,
531
532 0x2D, 0x80, 0x0C, 0x12, 0x0F, 0xCB, 0xE5, 0x30, 0xF0, 0x12, 0x0F, 0xC8, 0xE5, 0x31, 0xF0, 0xA2,
533
534 0x32, 0x92, 0xAF, 0x22, 0xD2, 0x01, 0xC2, 0x02, 0xE4, 0xF5, 0x1F, 0xF5, 0x1E, 0xD2, 0x35, 0xD2,
535
536 0x33, 0xD2, 0x36, 0xD2, 0x01, 0xC2, 0x02, 0xF5, 0x1F, 0xF5, 0x1E, 0xD2, 0x35, 0xD2, 0x33, 0x22,
537
538 0xFB, 0xD3, 0xED, 0x9B, 0x74, 0x80, 0xF8, 0x6C, 0x98, 0x22, 0x12, 0x06, 0x69, 0xE5, 0x40, 0x2F,
539
540 0xF5, 0x40, 0xE5, 0x3F, 0x3E, 0xF5, 0x3F, 0xE5, 0x3E, 0x3D, 0xF5, 0x3E, 0xE5, 0x3D, 0x3C, 0xF5,
541
542 0x3D, 0x22, 0xC0, 0xE0, 0xC0, 0x83, 0xC0, 0x82, 0x90, 0x3F, 0x0D, 0xE0, 0xF5, 0x33, 0xE5, 0x33,
543
544 0xF0, 0xD0, 0x82, 0xD0, 0x83, 0xD0, 0xE0, 0x32, 0x90, 0x0E, 0x5F, 0xE4, 0x93, 0xFE, 0x74, 0x01,
545
546 0x93, 0xF5, 0x82, 0x8E, 0x83, 0x22, 0x78, 0x7F, 0xE4, 0xF6, 0xD8, 0xFD, 0x75, 0x81, 0xCD, 0x02,
547
548 0x0C, 0x98, 0x8F, 0x82, 0x8E, 0x83, 0x75, 0xF0, 0x04, 0xED, 0x02, 0x06, 0xA5,
549
550};
551
560#endif
OV5640_AF_Config
const unsigned char OV5640_AF_Config[]
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640af.h:38


AT32F435/437 Firmwary Library: ov5640cfg.h File Reference

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • ov5640
Variables
at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h File Reference

header file of ov5640cfg program More...

#include "ov5640.h"

Go to the source code of this file.

Variables

const uint16_t | OV5640_jpeg_reg_tbl [][2]
const uint16_t | ov5640_rgb565_reg_tbl [][2]
const uint16_t | ov5640_uxga_init_reg_tbl [][2]

Detailed Description

header file of ov5640cfg program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h.


AT32F435/437 Firmwary Library: ov5640cfg.h Source File

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • ov5640
at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h
Go to the documentation of this file.
1
27#ifndef _OV5640CFG_H
28#define _OV5640CFG_H
29#include "ov5640.h"
30
39const uint16_t OV5640_jpeg_reg_tbl[][2] =
40{
41 0x4300, 0x30, /* yuv 422, yuyv */
42 0x501f, 0x00, /* yuv 422 */
43
44 /* input clock = 24mhz */
45 0x3035, 0x81, /* pll */
46 0x3036, 0x69, /* pll */
47 0x3c07, 0x07, /* lightmeter 1 threshold[7:0] */
48 0x3820, 0x46, /* flip */
49 0x3821, 0x20, /* mirror */
50 0x3814, 0x11, /* timing x inc */
51 0x3815, 0x11, /* timing y inc */
52 0x3800, 0x00, /* hs */
53 0x3801, 0x00, /* hs */
54 0x3802, 0x00, /* vs */
55 0x3803, 0x00, /* vs */
56 0x3804, 0x0a, /* hw (he) */
57 0x3805, 0x3f, /* hw (he) */
58 0x3806, 0x07, /* vh (ve) */
59 0x3807, 0x9f, /* vh (ve) */
60
61 0x3808, 0x02, /* dvpho */
62 0x3809, 0x80, /* dvpho */
63 0x380a, 0x01, /* dvpvo */
64 0x380b, 0xe0, /* dvpvo */
65
66 0x380c, 0x0b, /* hts */
67 0x380d, 0x1c, /* hts */
68 0x380e, 0x07, /* vts */
69 0x380f, 0xb0, /* vts */
70 0x3813, 0x04, /* timing v offset 04 */
71 0x3618, 0x04,
72 0x3612, 0x2b,
73 0x3709, 0x12,
74 0x370c, 0x00,
75
76 0x4004, 0x06, /* blc line number */
77 0x3002, 0x00, /* enable jfifo, sfifo, jpg */
78 0x3006, 0xff, /* enable clock of jpeg2x, jpeg */
79 0x4713, 0x03, /* jpeg mode 3 */
80 0x4407, 0x01, /* quantization sacle */
81 0x460b, 0x35,
82 0x460c, 0x22,
83 0x4837, 0x16, /* mipi global timing */
84 0x3824, 0x02, /* pclk manual divider */
85 0x5001, 0xA3, /* sde on, scaling on, cmx on, awb on */
86 0x3503, 0x00, /* aec/agc on */
87};
88
89const uint16_t ov5640_rgb565_reg_tbl[][2] =
90{
91 0x4300, 0x6F,
92 0x501F, 0x01,
93 /* 1280x800, 15fps */
94 /* input clock 24mhz, pclk 42mhz */
95 0x3035, 0x21, /* pll */
96 0x3036, 0x69, /* pll */
97 0x3c07, 0x07, /* lightmeter 1 threshold[7:0] */
98 0x3820, 0x46, /* flip */
99 0x3821, 0x00, /* mirror */
100 0x3814, 0x31, /* timing x inc */
101 0x3815, 0x31, /* timing y inc */
102 0x3800, 0x00, /* hs */
103 0x3801, 0x00, /* hs */
104 0x3802, 0x00, /* vs */
105 0x3803, 0x00, /* vs */
106 0x3804, 0x0a, /* hw (he) */
107 0x3805, 0x3f, /* hw (he) */
108 0x3806, 0x06, /* vh (ve) */
109 0x3807, 0xa9, /* vh (ve) */
110 0x3808, 0x05, /* dvpho */
111 0x3809, 0x00, /* dvpho */
112 0x380a, 0x02, /* dvpvo */
113 0x380b, 0xd0, /* dvpvo */
114 0x380c, 0x05, /* hts */
115 0x380d, 0xF8, /* hts */
116 0x380e, 0x03, /* vts */
117 0x380f, 0x84, /* vts */
118 0x3813, 0x04, /* timing v offset */
119 0x3618, 0x00,
120 0x3612, 0x29,
121 0x3709, 0x52,
122 0x370c, 0x03,
123 0x3a02, 0x02, /* 60hz max exposure */
124 0x3a03, 0xe0, /* 60hz max exposure */
125
126 0x3a14, 0x02, /* 50hz max exposure */
127 0x3a15, 0xe0, /* 50hz max exposure */
128 0x4004, 0x02, /* blc line number */
129 0x3002, 0x1c, /* reset jfifo, sfifo, jpg */
130 0x3006, 0xc3, /* disable clock of jpeg2x, jpeg */
131 0x4713, 0x03, /* jpeg mode 3 */
132 0x4407, 0x04, /* quantization scale */
133 0x460b, 0x37,
134 0x460c, 0x20,
135 0x4837, 0x16, /* mipi global timing */
136 0x3824, 0x04, /* pclk manual divider */
137 0x5001, 0xA3, /* sde on, scale on, uv average off, color matrix on, awb on */
138 0x3503, 0x00, /* aec/agc on */
139
140#ifdef EMBEDDED_MODE
141 /* embedded code configer */
142 0x471b, 0x00, /* hsync mode enable */
143 0x4719, 0x01, /* ccir656 eav/sav option */
144 0x4715, 0x00, /* 0x0f ccir656 dummy line number at beginning of the frame */
145 0x4730, 0x61, /* ccir656 mode */
146
147 0x4732, 0x01, /* sync code frame start */
148 0x4733, 0x0F, /* sync code frame end */
149 0x4734, 0x10, /* sync code line start */
150 0x4735, 0xF0, /* sync code line end */
151#endif
152};
153
154const uint16_t ov5640_uxga_init_reg_tbl[][2] =
155{
156 /* 24MHz input clock, 24MHz PCLK */
157 0x3008, 0x42, /* software power down, bit[6] */
158 0x3103, 0x03, /* system clock from pll, bit[1] */
159 0x3017, 0xff, /* frex, vsync, href, pclk, d[9:6] output enable */
160 0x3018, 0xff, /* d[5:0], gpio[1:0] output enable */
161 0x3034, 0x1a, /* mipi 10-bit */
162 0x3037, 0x13, /* pll root divider, bit[4], pll pre-divider, bit[3:0] */
163 0x3108, 0x01, /* pclk root divider, bit[5:4], sclk2x root divider, bit[3:2] */
164
165 /* sclk root divider, bit[1:0] */
166 0x3630, 0x36,
167 0x3631, 0x0e,
168 0x3632, 0xe2,
169 0x3633, 0x12,
170 0x3621, 0xe0,
171 0x3704, 0xa0,
172 0x3703, 0x5a,
173 0x3715, 0x78,
174 0x3717, 0x01,
175 0x370b, 0x60,
176 0x3705, 0x1a,
177 0x3905, 0x02,
178 0x3906, 0x10,
179 0x3901, 0x0a,
180 0x3731, 0x12,
181 0x3600, 0x08, /* vcm control */
182 0x3601, 0x33, /* vcm control */
183 0x302d, 0x60, /* system control */
184 0x3620, 0x52,
185 0x371b, 0x20,
186 0x471c, 0x50,
187 0x3a13, 0x43, /* pre-gain = 1.047x */
188 0x3a18, 0x00, /* gain ceiling */
189 0x3a19, 0xf8, /* gain ceiling = 15.5x */
190 0x3635, 0x13,
191 0x3636, 0x03,
192 0x3634, 0x40,
193 0x3622, 0x01,
194 0x3c01, 0x34, /* band auto, bit[7] */
195 0x3c04, 0x28, /* threshold low sum */
196 0x3c05, 0x98, /* threshold high sum */
197 0x3c06, 0x00, /* light meter 1 threshold[15:8] */
198 0x3c07, 0x08, /* light meter 1 threshold[7:0] */
199 0x3c08, 0x00, /* light meter 2 threshold[15:8] */
200 0x3c09, 0x1c, /* light meter 2 threshold[7:0] */
201 0x3c0a, 0x9c, /* sample number[15:8] */
202 0x3c0b, 0x40, /* sample number[7:0] */
203 0x3810, 0x00, /* timing hoffset[11:8] */
204 0x3811, 0x10, /* timing hoffset[7:0] */
205 0x3812, 0x00, /* timing voffset[10:8] */
206 0x3708, 0x64,
207 0x4001, 0x02, /* blc start from line 2 */
208 0x4005, 0x1a, /* blc always update */
209 0x3000, 0x00, /* enable blocks */
210 0x3004, 0xff, /* enable clocks */
211 0x300e, 0x58, /* mipi power down, dvp enable */
212 0x302e, 0x00,
213 0x4300, 0x30, /* yuv 422, yuyv */
214 0x501f, 0x00, /* yuv 422 */
215 0x440e, 0x00,
216 0x5000, 0xa7, /* lenc on, raw gamma on, bpc on, wpc on, cip on */
217
218 0x3a0f, 0x30, /* stable range in high */
219 0x3a10, 0x28, /* stable range in low */
220 0x3a1b, 0x30, /* stable range out high */
221 0x3a1e, 0x26, /* stable range out low */
222 0x3a11, 0x60, /* fast zone high */
223 0x3a1f, 0x14, /* fast zone low */
224
225 0x5800, 0x23,
226 0x5801, 0x14,
227 0x5802, 0x0f,
228 0x5803, 0x0f,
229 0x5804, 0x12,
230 0x5805, 0x26,
231 0x5806, 0x0c,
232 0x5807, 0x08,
233 0x5808, 0x05,
234 0x5809, 0x05,
235 0x580a, 0x08,
236
237 0x580b, 0x0d,
238 0x580c, 0x08,
239 0x580d, 0x03,
240 0x580e, 0x00,
241 0x580f, 0x00,
242 0x5810, 0x03,
243 0x5811, 0x09,
244 0x5812, 0x07,
245 0x5813, 0x03,
246 0x5814, 0x00,
247 0x5815, 0x01,
248 0x5816, 0x03,
249 0x5817, 0x08,
250 0x5818, 0x0d,
251 0x5819, 0x08,
252 0x581a, 0x05,
253 0x581b, 0x06,
254 0x581c, 0x08,
255 0x581d, 0x0e,
256 0x581e, 0x29,
257 0x581f, 0x17,
258 0x5820, 0x11,
259 0x5821, 0x11,
260 0x5822, 0x15,
261 0x5823, 0x28,
262 0x5824, 0x46,
263 0x5825, 0x26,
264 0x5826, 0x08,
265 0x5827, 0x26,
266 0x5828, 0x64,
267 0x5829, 0x26,
268 0x582a, 0x24,
269 0x582b, 0x22,
270 0x582c, 0x24,
271 0x582d, 0x24,
272 0x582e, 0x06,
273 0x582f, 0x22,
274 0x5830, 0x40,
275 0x5831, 0x42,
276 0x5832, 0x24,
277 0x5833, 0x26,
278 0x5834, 0x24,
279 0x5835, 0x22,
280 0x5836, 0x22,
281 0x5837, 0x26,
282 0x5838, 0x44,
283 0x5839, 0x24,
284 0x583a, 0x26,
285 0x583b, 0x28,
286 0x583c, 0x42,
287 0x583d, 0xce, /* lenc br offset */
288
289 0x5180, 0xff, /* awb b block */
290 0x5181, 0xf2, /* awb control */
291 0x5182, 0x00, /* [7:4] max local counter, [3:0] max fast counter */
292 0x5183, 0x14, /* awb advanced */
293 0x5184, 0x25,
294 0x5185, 0x24,
295 0x5186, 0x09,
296 0x5187, 0x09,
297 0x5188, 0x09,
298 0x5189, 0x75,
299 0x518a, 0x54,
300 0x518b, 0xe0,
301 0x518c, 0xb2,
302 0x518d, 0x42,
303 0x518e, 0x3d,
304 0x518f, 0x56,
305 0x5190, 0x46,
306 0x5191, 0xf8, /* awb top limit */
307 0x5192, 0x04, /* awb bottom limit */
308 0x5193, 0x70, /* red limit */
309 0x5194, 0xf0, /* green limit */
310 0x5195, 0xf0, /* blue limit */
311 0x5196, 0x03, /* awb control */
312 0x5197, 0x01, /* local limit */
313 0x5198, 0x04,
314 0x5199, 0x12,
315 0x519a, 0x04,
316 0x519b, 0x00,
317 0x519c, 0x06,
318 0x519d, 0x82,
319 0x519e, 0x38, /* awb control */
320
321 0x5480, 0x01, /* gamma bias plus on, bit[0] */
322 0x5481, 0x08,
323 0x5482, 0x14,
324 0x5483, 0x28,
325 0x5484, 0x51,
326 0x5485, 0x65,
327 0x5486, 0x71,
328 0x5487, 0x7d,
329 0x5488, 0x87,
330 0x5489, 0x91,
331 0x548a, 0x9a,
332 0x548b, 0xaa,
333 0x548c, 0xb8,
334 0x548d, 0xcd,
335 0x548e, 0xdd,
336 0x548f, 0xea,
337 0x5490, 0x1d,
338
339 0x5381, 0x1e, /* cmx1 for y */
340 0x5382, 0x5b, /* cmx2 for y */
341 0x5383, 0x08, /* cmx3 for y */
342 0x5384, 0x0a, /* cmx4 for u */
343 0x5385, 0x7e, /* cmx5 for u */
344 0x5386, 0x88, /* cmx6 for u */
345 0x5387, 0x7c, /* cmx7 for v */
346 0x5388, 0x6c, /* cmx8 for v */
347 0x5389, 0x10, /* cmx9 for v */
348 0x538a, 0x01, /* sign[9] */
349 0x538b, 0x98, /* sign[8:1] */
350
351 0x5580, 0x06, /* saturation on, bit[1] */
352 0x5583, 0x40,
353 0x5584, 0x10,
354 0x5589, 0x10,
355 0x558a, 0x00,
356 0x558b, 0xf8,
357 0x501d, 0x40, /* enable manual offset of contrast */
358
359 0x5300, 0x08, /* cip sharpen mt threshold 1 */
360 0x5301, 0x30, /* cip sharpen mt threshold 2 */
361 0x5302, 0x10, /* cip sharpen mt offset 1 */
362 0x5303, 0x00, /* cip sharpen mt offset 2 */
363 0x5304, 0x08, /* cip dns threshold 1 */
364 0x5305, 0x30, /* cip dns threshold 2 */
365 0x5306, 0x08, /* cip dns offset 1 */
366 0x5307, 0x16, /* cip dns offset 2 */
367 0x5309, 0x08, /* cip sharpen th threshold 1 */
368 0x530a, 0x30, /* cip sharpen th threshold 2 */
369 0x530b, 0x04, /* cip sharpen th offset 1 */
370 0x530c, 0x06, /* cip sharpen th offset 2 */
371 0x5025, 0x00,
372 0x4740, 0x23, /* vsync high */
373 0x3008, 0x02, /* wake up from standby, bit[6] */
374
375};
376
385#endif
ov5640.h
ov5640_rgb565_reg_tbl
const uint16_t ov5640_rgb565_reg_tbl[][2]
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h:89
ov5640_uxga_init_reg_tbl
const uint16_t ov5640_uxga_init_reg_tbl[][2]
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h:154
OV5640_jpeg_reg_tbl
const uint16_t OV5640_jpeg_reg_tbl[][2]
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h:39


AT32F435/437 Firmwary Library: qspi_cmd_esmt32m.c File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma
  • src
Macros | Functions | Variables
at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c File Reference

qspi_cmd_esmt32m program More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define FLASH_PAGE_PROGRAM_SIZE 256

Functions

void | qspi_busy_check (void)
qspi check busy More...
void | qspi_write_enable (void)
qspi write enable More...
void | esmt32m_cmd_read_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config More...
void | esmt32m_cmd_write_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config More...
void | esmt32m_cmd_erase_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config More...
void | esmt32m_cmd_wren_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config More...
void | esmt32m_cmd_rdsr_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config More...
void | qspi_dma_set (dma_dir_type dir, uint8_t *buf, uint32_t length)
qspi dma set More...
void | qspi_data_read (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data More...
static void | qspi_data_once_write (uint32_t addr, uint32_t sz, uint8_t *buf)
qspi write data for one time More...
void | qspi_data_write (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data More...
void | qspi_erase (uint32_t sec_addr)
qspi erase data More...

Variables

qspi_cmd_type esmt32m_cmd_config

Detailed Description

qspi_cmd_esmt32m program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c.


AT32F435/437 Firmwary Library: qspi_cmd_esmt32m.c Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma
  • src
at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28
37#define FLASH_PAGE_PROGRAM_SIZE 256
38
39 qspi_cmd_type esmt32m_cmd_config;
40
41void qspi_busy_check(void);
42void qspi_write_enable(void);
43
51void esmt32m_cmd_read_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
52{
53 qspi_cmd_struct->pe_mode_enable = FALSE;
54 qspi_cmd_struct->pe_mode_operate_code = 0;
55 qspi_cmd_struct->instruction_code = 0xEB;
56 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
57 qspi_cmd_struct->address_code = addr;
58 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
59 qspi_cmd_struct->data_counter = counter;
60 qspi_cmd_struct->second_dummy_cycle_num = 6;
61 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_144;
62 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
63 qspi_cmd_struct->read_status_enable = FALSE;
64 qspi_cmd_struct->write_data_enable = FALSE;
65}
66
74void esmt32m_cmd_write_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
75{
76 qspi_cmd_struct->pe_mode_enable = FALSE;
77 qspi_cmd_struct->pe_mode_operate_code = 0;
78 qspi_cmd_struct->instruction_code = 0x32;
79 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
80 qspi_cmd_struct->address_code = addr;
81 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
82 qspi_cmd_struct->data_counter = counter;
83 qspi_cmd_struct->second_dummy_cycle_num = 0;
84 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_114;
85 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
86 qspi_cmd_struct->read_status_enable = FALSE;
87 qspi_cmd_struct->write_data_enable = TRUE;
88}
89
96void esmt32m_cmd_erase_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
97{
98 qspi_cmd_struct->pe_mode_enable = FALSE;
99 qspi_cmd_struct->pe_mode_operate_code = 0;
100 qspi_cmd_struct->instruction_code = 0x20;
101 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
102 qspi_cmd_struct->address_code = addr;
103 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
104 qspi_cmd_struct->data_counter = 0;
105 qspi_cmd_struct->second_dummy_cycle_num = 0;
106 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
107 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
108 qspi_cmd_struct->read_status_enable = FALSE;
109 qspi_cmd_struct->write_data_enable = TRUE;
110}
111
117void esmt32m_cmd_wren_config(qspi_cmd_type *qspi_cmd_struct)
118{
119 qspi_cmd_struct->pe_mode_enable = FALSE;
120 qspi_cmd_struct->pe_mode_operate_code = 0;
121 qspi_cmd_struct->instruction_code = 0x06;
122 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
123 qspi_cmd_struct->address_code = 0;
124 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
125 qspi_cmd_struct->data_counter = 0;
126 qspi_cmd_struct->second_dummy_cycle_num = 0;
127 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
128 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
129 qspi_cmd_struct->read_status_enable = FALSE;
130 qspi_cmd_struct->write_data_enable = TRUE;
131}
132
138void esmt32m_cmd_rdsr_config(qspi_cmd_type *qspi_cmd_struct)
139{
140 qspi_cmd_struct->pe_mode_enable = FALSE;
141 qspi_cmd_struct->pe_mode_operate_code = 0;
142 qspi_cmd_struct->instruction_code = 0x05;
143 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
144 qspi_cmd_struct->address_code = 0;
145 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
146 qspi_cmd_struct->data_counter = 0;
147 qspi_cmd_struct->second_dummy_cycle_num = 0;
148 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
149 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
150 qspi_cmd_struct->read_status_enable = TRUE;
151 qspi_cmd_struct->write_data_enable = FALSE;
152}
153
161void qspi_dma_set(dma_dir_type dir, uint8_t* buf, uint32_t length)
162{
163 dma_init_type dma_init_struct;
164 dma_reset(DMA2_CHANNEL1);
165 dma_default_para_init(&dma_init_struct);
166 dma_init_struct.buffer_size = length / 4; /* using word unit */
167 dma_init_struct.loop_mode_enable = FALSE;
168 dma_init_struct.direction = dir;
169 dma_init_struct.memory_base_addr = (uint32_t)buf;
170 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_WORD;
171 dma_init_struct.memory_inc_enable = TRUE;
172 dma_init_struct.peripheral_base_addr = (uint32_t)(&(QSPI1->dt));
173 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_WORD;
174 dma_init_struct.peripheral_inc_enable = FALSE;
175 dma_init_struct.priority = DMA_PRIORITY_HIGH;
176
177 dma_init(DMA2_CHANNEL1, &dma_init_struct);
178
179 dmamux_init(DMA2MUX_CHANNEL1, DMAMUX_DMAREQ_ID_QSPI1);
180 dmamux_enable(DMA2, TRUE);
181
182 dma_channel_enable(DMA2_CHANNEL1, TRUE);
183}
184
192void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t* buf)
193{
194 /* config qspi's dma mode */
195 qspi_dma_enable(QSPI1, TRUE);
196 qspi_dma_rx_threshold_set(QSPI1, QSPI_DMA_FIFO_THOD_WORD08);
197
198 /* config and enable dma */
199 qspi_dma_set(DMA_DIR_PERIPHERAL_TO_MEMORY, buf, total_len);
200
201 /* kick command */
202 esmt32m_cmd_read_config(&esmt32m_cmd_config, addr, total_len);
203 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
204
205 /* wait command completed */
206 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
207 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
208
209 /* wait dma completed */
210 while(dma_flag_get(DMA2_FDT1_FLAG) == RESET);
211 dma_flag_clear(DMA2_FDT1_FLAG);
212 qspi_dma_enable(QSPI1, FALSE);
213}
214
222static void qspi_data_once_write(uint32_t addr, uint32_t sz, uint8_t* buf)
223{
224 qspi_write_enable();
225
226 /* config qspi's dma mode */
227 qspi_dma_enable(QSPI1, TRUE);
228 qspi_dma_tx_threshold_set(QSPI1, QSPI_DMA_FIFO_THOD_WORD08);
229
230 /* config and enable dma */
231 qspi_dma_set(DMA_DIR_MEMORY_TO_PERIPHERAL, buf, sz);
232
233 /* kick command */
234 esmt32m_cmd_write_config(&esmt32m_cmd_config, addr, sz);
235 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
236
237 /* wait command completed */
238 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
239 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
240
241 /* wait dma completed */
242 while(dma_flag_get(DMA2_FDT1_FLAG) == RESET);
243 dma_flag_clear(DMA2_FDT1_FLAG);
244 qspi_dma_enable(QSPI1, FALSE);
245
246 qspi_busy_check();
247}
248
256void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t* buf)
257{
258 uint32_t blk_sz;
259 do
260 { /* send up to 256 bytes at one time */
261 if(total_len > FLASH_PAGE_PROGRAM_SIZE)
262 {
263 blk_sz = FLASH_PAGE_PROGRAM_SIZE;
264 }
265 else
266 {
267 blk_sz = total_len;
268 }
269 qspi_data_once_write(addr, blk_sz, buf);
270 addr += blk_sz;
271 buf += blk_sz;
272 total_len -= blk_sz;
273 }while(total_len > 0);
274}
275
281void qspi_erase(uint32_t sec_addr)
282{
283 qspi_write_enable();
284
285 esmt32m_cmd_erase_config(&esmt32m_cmd_config, sec_addr);
286 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
287
288 /* wait command completed */
289 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
290 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
291
292 qspi_busy_check();
293}
294
300void qspi_busy_check(void)
301{
302 esmt32m_cmd_rdsr_config(&esmt32m_cmd_config);
303 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
304
305 /* wait command completed */
306 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
307 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
308}
309
315void qspi_write_enable(void)
316{
317 esmt32m_cmd_wren_config(&esmt32m_cmd_config);
318 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
319
320 /* wait command completed */
321 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
322 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
323}
324
at32f435_437_board.h
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
counter
uint16_t counter
Definition: project/at_start_f435/examples/debug/tmr1/src/main.c:39
qspi_dma_set
void qspi_dma_set(dma_dir_type dir, uint8_t *buf, uint32_t length)
qspi dma set
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:161
qspi_busy_check
void qspi_busy_check(void)
qspi check busy
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:300
esmt32m_cmd_wren_config
void esmt32m_cmd_wren_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:117
qspi_erase
void qspi_erase(uint32_t sec_addr)
qspi erase data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:281
esmt32m_cmd_erase_config
void esmt32m_cmd_erase_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:96
FLASH_PAGE_PROGRAM_SIZE
#define FLASH_PAGE_PROGRAM_SIZE
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:37
qspi_write_enable
void qspi_write_enable(void)
qspi write enable
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:315
qspi_data_read
void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:192
qspi_data_once_write
static void qspi_data_once_write(uint32_t addr, uint32_t sz, uint8_t *buf)
qspi write data for one time
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:222
qspi_data_write
void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:256
esmt32m_cmd_config
qspi_cmd_type esmt32m_cmd_config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:39
esmt32m_cmd_read_config
void esmt32m_cmd_read_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:51
esmt32m_cmd_write_config
void esmt32m_cmd_write_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:74
esmt32m_cmd_rdsr_config
void esmt32m_cmd_rdsr_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:138
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f435_437_dma.h:151
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:164
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:174
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_QSPI1
@ DMAMUX_DMAREQ_ID_QSPI1
Definition: at32f435_437_dma.h:240
DMA2_FDT1_FLAG
#define DMA2_FDT1_FLAG
Definition: at32f435_437_dma.h:95
DMA2MUX_CHANNEL1
#define DMA2MUX_CHANNEL1
Definition: at32f435_437_dma.h:726
DMA2
#define DMA2
Definition: at32f435_437_dma.h:717
DMA2_CHANNEL1
#define DMA2_CHANNEL1
Definition: at32f435_437_dma.h:718
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
qspi_flag_clear
void qspi_flag_clear(qspi_type *qspi_x, uint32_t flag)
clear flags
Definition: at32f435_437_qspi.c:168
qspi_dma_enable
void qspi_dma_enable(qspi_type *qspi_x, confirm_state new_state)
enable/disable dma transfer
Definition: at32f435_437_qspi.c:218
qspi_dma_tx_threshold_set
void qspi_dma_tx_threshold_set(qspi_type *qspi_x, qspi_dma_fifo_thod_type new_threshold)
set dma threshold for dma tx
Definition: at32f435_437_qspi.c:204
qspi_dma_rx_threshold_set
void qspi_dma_rx_threshold_set(qspi_type *qspi_x, qspi_dma_fifo_thod_type new_threshold)
set dma threshold for dma rx
Definition: at32f435_437_qspi.c:186
qspi_cmd_operation_kick
void qspi_cmd_operation_kick(qspi_type *qspi_x, qspi_cmd_type *qspi_cmd_struct)
set command-port and qspi_x will start to work
Definition: at32f435_437_qspi.c:292
qspi_flag_get
flag_status qspi_flag_get(qspi_type *qspi_x, uint32_t flag)
get status flags.
Definition: at32f435_437_qspi.c:138
QSPI_RSTSC_HW_AUTO
@ QSPI_RSTSC_HW_AUTO
Definition: at32f435_437_qspi.h:102
QSPI_CMD_INSLEN_1_BYTE
@ QSPI_CMD_INSLEN_1_BYTE
Definition: at32f435_437_qspi.h:153
QSPI_DMA_FIFO_THOD_WORD08
@ QSPI_DMA_FIFO_THOD_WORD08
Definition: at32f435_437_qspi.h:180
QSPI_OPERATE_MODE_144
@ QSPI_OPERATE_MODE_144
Definition: at32f435_437_qspi.h:115
QSPI_OPERATE_MODE_111
@ QSPI_OPERATE_MODE_111
Definition: at32f435_437_qspi.h:111
QSPI_OPERATE_MODE_114
@ QSPI_OPERATE_MODE_114
Definition: at32f435_437_qspi.h:113
QSPI_CMD_ADRLEN_0_BYTE
@ QSPI_CMD_ADRLEN_0_BYTE
Definition: at32f435_437_qspi.h:140
QSPI_CMD_ADRLEN_3_BYTE
@ QSPI_CMD_ADRLEN_3_BYTE
Definition: at32f435_437_qspi.h:143
QSPI_CMDSTS_FLAG
#define QSPI_CMDSTS_FLAG
Definition: at32f435_437_qspi.h:52
QSPI1
#define QSPI1
Definition: at32f435_437_qspi.h:512
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
qspi_cmd_type
qspi cmd type
Definition: at32f435_437_qspi.h:189
qspi_cmd_type::instruction_length
qspi_cmd_inslen_type instruction_length
Definition: at32f435_437_qspi.h:193
qspi_cmd_type::write_data_enable
confirm_state write_data_enable
Definition: at32f435_437_qspi.h:201
qspi_cmd_type::operation_mode
qspi_operate_mode_type operation_mode
Definition: at32f435_437_qspi.h:198
qspi_cmd_type::instruction_code
uint8_t instruction_code
Definition: at32f435_437_qspi.h:192
qspi_cmd_type::read_status_config
qspi_read_status_conf_type read_status_config
Definition: at32f435_437_qspi.h:199
qspi_cmd_type::pe_mode_enable
confirm_state pe_mode_enable
Definition: at32f435_437_qspi.h:190
qspi_cmd_type::read_status_enable
confirm_state read_status_enable
Definition: at32f435_437_qspi.h:200
qspi_cmd_type::data_counter
uint32_t data_counter
Definition: at32f435_437_qspi.h:196
qspi_cmd_type::address_code
uint32_t address_code
Definition: at32f435_437_qspi.h:194
qspi_cmd_type::pe_mode_operate_code
uint8_t pe_mode_operate_code
Definition: at32f435_437_qspi.h:191
qspi_cmd_type::address_length
qspi_cmd_adrlen_type address_length
Definition: at32f435_437_qspi.h:195
qspi_cmd_type::second_dummy_cycle_num
uint8_t second_dummy_cycle_num
Definition: at32f435_437_qspi.h:197


AT32F435/437 Firmwary Library: qspi_cmd_esmt32m.c File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_and_pem
  • src
Macros | Enumerations | Functions | Variables
at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c File Reference

qspi_cmd_esmt32m program More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | FLASH_PAGE_PROGRAM_SIZE 256
#define | PEMOPC_SET 0xA5
#define | PEMOPC_RESET 0xFF

Enumerations

enum pem_step_type {
PEM_STEP_BEGIN , PEM_STEP_KEEP , PEM_STEP_END , PEM_STEP_BEGIN ,
PEM_STEP_KEEP , PEM_STEP_END
}

Functions

void | qspi_busy_check (void)
qspi check busy More...
void | qspi_write_enable (void)
qspi write enable More...
void | esmt32m_cmd_read_pem_begin_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read pem begin config More...
void | esmt32m_cmd_read_pem_keep_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read pem keep config More...
void | esmt32m_cmd_read_pem_end_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read pem end config More...
void | esmt32m_cmd_write_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config More...
void | esmt32m_cmd_erase_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config More...
void | esmt32m_cmd_wren_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config More...
void | esmt32m_cmd_rdsr_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config More...
void | qspi_dma_set (dma_dir_type dir, uint8_t *buf, uint32_t length)
qspi dma set More...
void | qspi_read_data_using_pem (pem_step_type pem_step, uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data using pem More...
void | qspi_data_read (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data More...
static void | qspi_data_once_write (uint32_t addr, uint32_t sz, uint8_t *buf)
qspi write data for one time More...
void | qspi_data_write (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data More...
void | qspi_erase (uint32_t sec_addr)
qspi erase data More...

Variables

qspi_cmd_type esmt32m_cmd_config

Detailed Description

qspi_cmd_esmt32m program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.


AT32F435/437 Firmwary Library: qspi_cmd_esmt32m.c Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_and_pem
  • src
at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28
37#define FLASH_PAGE_PROGRAM_SIZE 256
38#define PEMOPC_SET 0xA5
39#define PEMOPC_RESET 0xFF
40
41typedef enum
42{
43 PEM_STEP_BEGIN,
44 PEM_STEP_KEEP,
45 PEM_STEP_END
46}pem_step_type;
47
48 qspi_cmd_type esmt32m_cmd_config;
49
50void qspi_busy_check(void);
51void qspi_write_enable(void);
52
60void esmt32m_cmd_read_pem_begin_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
61{
62 qspi_cmd_struct->pe_mode_enable = TRUE;
63 qspi_cmd_struct->pe_mode_operate_code = PEMOPC_SET;
64 qspi_cmd_struct->instruction_code = 0xEB;
65 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
66 qspi_cmd_struct->address_code = addr;
67 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
68 qspi_cmd_struct->data_counter = counter;
69 qspi_cmd_struct->second_dummy_cycle_num = 4;
70 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_144;
71 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
72 qspi_cmd_struct->read_status_enable = FALSE;
73 qspi_cmd_struct->write_data_enable = FALSE;
74}
75
83void esmt32m_cmd_read_pem_keep_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
84{
85 qspi_cmd_struct->pe_mode_enable = TRUE;
86 qspi_cmd_struct->pe_mode_operate_code = PEMOPC_SET;
87 qspi_cmd_struct->instruction_code = 0xEB;
88 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_0_BYTE;
89 qspi_cmd_struct->address_code = addr;
90 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
91 qspi_cmd_struct->data_counter = counter;
92 qspi_cmd_struct->second_dummy_cycle_num = 4;
93 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_144;
94 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
95 qspi_cmd_struct->read_status_enable = FALSE;
96 qspi_cmd_struct->write_data_enable = FALSE;
97}
98
106void esmt32m_cmd_read_pem_end_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
107{
108 qspi_cmd_struct->pe_mode_enable = TRUE;
109 qspi_cmd_struct->pe_mode_operate_code = PEMOPC_RESET;
110 qspi_cmd_struct->instruction_code = 0xEB;
111 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_0_BYTE;
112 qspi_cmd_struct->address_code = addr;
113 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
114 qspi_cmd_struct->data_counter = counter;
115 qspi_cmd_struct->second_dummy_cycle_num = 4;
116 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_144;
117 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
118 qspi_cmd_struct->read_status_enable = FALSE;
119 qspi_cmd_struct->write_data_enable = FALSE;
120}
121
129void esmt32m_cmd_write_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
130{
131 qspi_cmd_struct->pe_mode_enable = FALSE;
132 qspi_cmd_struct->pe_mode_operate_code = 0;
133 qspi_cmd_struct->instruction_code = 0x32;
134 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
135 qspi_cmd_struct->address_code = addr;
136 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
137 qspi_cmd_struct->data_counter = counter;
138 qspi_cmd_struct->second_dummy_cycle_num = 0;
139 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_114;
140 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
141 qspi_cmd_struct->read_status_enable = FALSE;
142 qspi_cmd_struct->write_data_enable = TRUE;
143}
144
151void esmt32m_cmd_erase_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
152{
153 qspi_cmd_struct->pe_mode_enable = FALSE;
154 qspi_cmd_struct->pe_mode_operate_code = 0;
155 qspi_cmd_struct->instruction_code = 0x20;
156 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
157 qspi_cmd_struct->address_code = addr;
158 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
159 qspi_cmd_struct->data_counter = 0;
160 qspi_cmd_struct->second_dummy_cycle_num = 0;
161 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
162 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
163 qspi_cmd_struct->read_status_enable = FALSE;
164 qspi_cmd_struct->write_data_enable = TRUE;
165}
166
172void esmt32m_cmd_wren_config(qspi_cmd_type *qspi_cmd_struct)
173{
174 qspi_cmd_struct->pe_mode_enable = FALSE;
175 qspi_cmd_struct->pe_mode_operate_code = 0;
176 qspi_cmd_struct->instruction_code = 0x06;
177 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
178 qspi_cmd_struct->address_code = 0;
179 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
180 qspi_cmd_struct->data_counter = 0;
181 qspi_cmd_struct->second_dummy_cycle_num = 0;
182 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
183 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
184 qspi_cmd_struct->read_status_enable = FALSE;
185 qspi_cmd_struct->write_data_enable = TRUE;
186}
187
193void esmt32m_cmd_rdsr_config(qspi_cmd_type *qspi_cmd_struct)
194{
195 qspi_cmd_struct->pe_mode_enable = FALSE;
196 qspi_cmd_struct->pe_mode_operate_code = 0;
197 qspi_cmd_struct->instruction_code = 0x05;
198 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
199 qspi_cmd_struct->address_code = 0;
200 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
201 qspi_cmd_struct->data_counter = 0;
202 qspi_cmd_struct->second_dummy_cycle_num = 0;
203 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
204 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
205 qspi_cmd_struct->read_status_enable = TRUE;
206 qspi_cmd_struct->write_data_enable = FALSE;
207}
208
216void qspi_dma_set(dma_dir_type dir, uint8_t* buf, uint32_t length)
217{
218 dma_init_type dma_init_struct;
219 dma_reset(DMA2_CHANNEL1);
220 dma_default_para_init(&dma_init_struct);
221 dma_init_struct.buffer_size = length / 4; /* using word unit */
222 dma_init_struct.loop_mode_enable = FALSE;
223 dma_init_struct.direction = dir;
224 dma_init_struct.memory_base_addr = (uint32_t)buf;
225 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_WORD;
226 dma_init_struct.memory_inc_enable = TRUE;
227 dma_init_struct.peripheral_base_addr = (uint32_t)(&(QSPI1->dt));
228 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_WORD;
229 dma_init_struct.peripheral_inc_enable = FALSE;
230 dma_init_struct.priority = DMA_PRIORITY_HIGH;
231
232 dma_init(DMA2_CHANNEL1, &dma_init_struct);
233
234 dmamux_init(DMA2MUX_CHANNEL1, DMAMUX_DMAREQ_ID_QSPI1);
235 dmamux_enable(DMA2, TRUE);
236
237 dma_channel_enable(DMA2_CHANNEL1, TRUE);
238}
239
248void qspi_read_data_using_pem(pem_step_type pem_step, uint32_t addr, uint32_t total_len, uint8_t* buf)
249{
250 qspi_dma_enable(QSPI1, TRUE);
251 qspi_dma_rx_threshold_set(QSPI1, QSPI_DMA_FIFO_THOD_WORD08);
252 /* config dma */
253 qspi_dma_set(DMA_DIR_PERIPHERAL_TO_MEMORY, buf, total_len);
254 /* kick command */
255 if(pem_step == PEM_STEP_BEGIN)
256 {
257 esmt32m_cmd_read_pem_begin_config(&esmt32m_cmd_config, addr, total_len);
258 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
259 }
260 else if(pem_step == PEM_STEP_KEEP)
261 {
262 esmt32m_cmd_read_pem_keep_config(&esmt32m_cmd_config, addr, total_len);
263 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
264 }
265 else if(pem_step == PEM_STEP_END)
266 {
267 esmt32m_cmd_read_pem_end_config(&esmt32m_cmd_config, addr, total_len);
268 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
269 }
270
271 /* wait command completed */
272 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
273 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
274
275 /* wait dma completed */
276 while(dma_flag_get(DMA2_FDT1_FLAG) == RESET);
277 dma_flag_clear(DMA2_FDT1_FLAG);
278 qspi_dma_enable(QSPI1, FALSE);
279}
280
288void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t* buf)
289{
290 uint32_t rdsz = sizeof(uint32_t); /* dma transfer must word aligning */
291 /* fist phase */
292 qspi_read_data_using_pem(PEM_STEP_BEGIN, addr, rdsz, buf);
293 addr += rdsz;
294 buf += rdsz;
295 total_len -= rdsz;
296
297 /* keep phase */
298 qspi_read_data_using_pem(PEM_STEP_KEEP, addr, rdsz, buf);
299 addr += rdsz;
300 buf += rdsz;
301 total_len -= rdsz;
302
303 /* last phase */
304 qspi_read_data_using_pem(PEM_STEP_END, addr, total_len, buf);
305}
306
314static void qspi_data_once_write(uint32_t addr, uint32_t sz, uint8_t* buf)
315{
316 qspi_write_enable();
317
318 /* config qspi's dma mode */
319 qspi_dma_enable(QSPI1, TRUE);
320 qspi_dma_tx_threshold_set(QSPI1, QSPI_DMA_FIFO_THOD_WORD08);
321
322 /* config and enable dma */
323 qspi_dma_set(DMA_DIR_MEMORY_TO_PERIPHERAL, buf, sz);
324
325 /* kick command */
326 esmt32m_cmd_write_config(&esmt32m_cmd_config, addr, sz);
327 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
328
329 /* wait command completed */
330 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
331 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
332
333 /* wait dma completed */
334 while(dma_flag_get(DMA2_FDT1_FLAG) == RESET);
335 dma_flag_clear(DMA2_FDT1_FLAG);
336 qspi_dma_enable(QSPI1, FALSE);
337
338 qspi_busy_check();
339}
340
348void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t* buf)
349{
350 uint32_t blk_sz;
351 do
352 { /* send up to 256 bytes at one time */
353 if(total_len > FLASH_PAGE_PROGRAM_SIZE)
354 {
355 blk_sz = FLASH_PAGE_PROGRAM_SIZE;
356 }
357 else
358 {
359 blk_sz = total_len;
360 }
361 qspi_data_once_write(addr, blk_sz, buf);
362 addr += blk_sz;
363 buf += blk_sz;
364 total_len -= blk_sz;
365 }while(total_len > 0);
366}
367
373void qspi_erase(uint32_t sec_addr)
374{
375 qspi_write_enable();
376
377 esmt32m_cmd_erase_config(&esmt32m_cmd_config, sec_addr);
378 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
379
380 /* wait command completed */
381 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
382 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
383
384 qspi_busy_check();
385}
386
392void qspi_busy_check(void)
393{
394 esmt32m_cmd_rdsr_config(&esmt32m_cmd_config);
395 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
396
397 /* wait command completed */
398 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
399 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
400}
401
407void qspi_write_enable(void)
408{
409 esmt32m_cmd_wren_config(&esmt32m_cmd_config);
410 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
411
412 /* wait command completed */
413 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
414 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
415}
416
at32f435_437_board.h
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
counter
uint16_t counter
Definition: project/at_start_f435/examples/debug/tmr1/src/main.c:39
PEMOPC_SET
#define PEMOPC_SET
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:38
pem_step_type
pem_step_type
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:42
qspi_dma_set
void qspi_dma_set(dma_dir_type dir, uint8_t *buf, uint32_t length)
qspi dma set
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:216
esmt32m_cmd_read_pem_keep_config
void esmt32m_cmd_read_pem_keep_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read pem keep config
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:83
qspi_busy_check
void qspi_busy_check(void)
qspi check busy
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:392
esmt32m_cmd_wren_config
void esmt32m_cmd_wren_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:172
esmt32m_cmd_read_pem_end_config
void esmt32m_cmd_read_pem_end_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read pem end config
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:106
esmt32m_cmd_erase_config
void esmt32m_cmd_erase_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:151
qspi_read_data_using_pem
void qspi_read_data_using_pem(pem_step_type pem_step, uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data using pem
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:248
FLASH_PAGE_PROGRAM_SIZE
#define FLASH_PAGE_PROGRAM_SIZE
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:37
qspi_write_enable
void qspi_write_enable(void)
qspi write enable
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:407
qspi_data_once_write
static void qspi_data_once_write(uint32_t addr, uint32_t sz, uint8_t *buf)
qspi write data for one time
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:314
esmt32m_cmd_read_pem_begin_config
void esmt32m_cmd_read_pem_begin_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read pem begin config
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:60
esmt32m_cmd_config
qspi_cmd_type esmt32m_cmd_config
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:48
PEMOPC_RESET
#define PEMOPC_RESET
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:39
esmt32m_cmd_write_config
void esmt32m_cmd_write_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:129
esmt32m_cmd_rdsr_config
void esmt32m_cmd_rdsr_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:193
PEM_STEP_BEGIN
@ PEM_STEP_BEGIN
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:43
PEM_STEP_KEEP
@ PEM_STEP_KEEP
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:44
PEM_STEP_END
@ PEM_STEP_END
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:45
qspi_erase
void qspi_erase(uint32_t sec_addr)
qspi erase data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:281
qspi_data_read
void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:192
qspi_data_write
void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:256
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f435_437_dma.h:151
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:164
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:174
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_QSPI1
@ DMAMUX_DMAREQ_ID_QSPI1
Definition: at32f435_437_dma.h:240
DMA2_FDT1_FLAG
#define DMA2_FDT1_FLAG
Definition: at32f435_437_dma.h:95
DMA2MUX_CHANNEL1
#define DMA2MUX_CHANNEL1
Definition: at32f435_437_dma.h:726
DMA2
#define DMA2
Definition: at32f435_437_dma.h:717
DMA2_CHANNEL1
#define DMA2_CHANNEL1
Definition: at32f435_437_dma.h:718
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
qspi_flag_clear
void qspi_flag_clear(qspi_type *qspi_x, uint32_t flag)
clear flags
Definition: at32f435_437_qspi.c:168
qspi_dma_enable
void qspi_dma_enable(qspi_type *qspi_x, confirm_state new_state)
enable/disable dma transfer
Definition: at32f435_437_qspi.c:218
qspi_dma_tx_threshold_set
void qspi_dma_tx_threshold_set(qspi_type *qspi_x, qspi_dma_fifo_thod_type new_threshold)
set dma threshold for dma tx
Definition: at32f435_437_qspi.c:204
qspi_dma_rx_threshold_set
void qspi_dma_rx_threshold_set(qspi_type *qspi_x, qspi_dma_fifo_thod_type new_threshold)
set dma threshold for dma rx
Definition: at32f435_437_qspi.c:186
qspi_cmd_operation_kick
void qspi_cmd_operation_kick(qspi_type *qspi_x, qspi_cmd_type *qspi_cmd_struct)
set command-port and qspi_x will start to work
Definition: at32f435_437_qspi.c:292
qspi_flag_get
flag_status qspi_flag_get(qspi_type *qspi_x, uint32_t flag)
get status flags.
Definition: at32f435_437_qspi.c:138
QSPI_RSTSC_HW_AUTO
@ QSPI_RSTSC_HW_AUTO
Definition: at32f435_437_qspi.h:102
QSPI_CMD_INSLEN_1_BYTE
@ QSPI_CMD_INSLEN_1_BYTE
Definition: at32f435_437_qspi.h:153
QSPI_CMD_INSLEN_0_BYTE
@ QSPI_CMD_INSLEN_0_BYTE
Definition: at32f435_437_qspi.h:152
QSPI_DMA_FIFO_THOD_WORD08
@ QSPI_DMA_FIFO_THOD_WORD08
Definition: at32f435_437_qspi.h:180
QSPI_OPERATE_MODE_144
@ QSPI_OPERATE_MODE_144
Definition: at32f435_437_qspi.h:115
QSPI_OPERATE_MODE_111
@ QSPI_OPERATE_MODE_111
Definition: at32f435_437_qspi.h:111
QSPI_OPERATE_MODE_114
@ QSPI_OPERATE_MODE_114
Definition: at32f435_437_qspi.h:113
QSPI_CMD_ADRLEN_0_BYTE
@ QSPI_CMD_ADRLEN_0_BYTE
Definition: at32f435_437_qspi.h:140
QSPI_CMD_ADRLEN_3_BYTE
@ QSPI_CMD_ADRLEN_3_BYTE
Definition: at32f435_437_qspi.h:143
QSPI_CMDSTS_FLAG
#define QSPI_CMDSTS_FLAG
Definition: at32f435_437_qspi.h:52
QSPI1
#define QSPI1
Definition: at32f435_437_qspi.h:512
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
qspi_cmd_type
qspi cmd type
Definition: at32f435_437_qspi.h:189
qspi_cmd_type::instruction_length
qspi_cmd_inslen_type instruction_length
Definition: at32f435_437_qspi.h:193
qspi_cmd_type::write_data_enable
confirm_state write_data_enable
Definition: at32f435_437_qspi.h:201
qspi_cmd_type::operation_mode
qspi_operate_mode_type operation_mode
Definition: at32f435_437_qspi.h:198
qspi_cmd_type::instruction_code
uint8_t instruction_code
Definition: at32f435_437_qspi.h:192
qspi_cmd_type::read_status_config
qspi_read_status_conf_type read_status_config
Definition: at32f435_437_qspi.h:199
qspi_cmd_type::pe_mode_enable
confirm_state pe_mode_enable
Definition: at32f435_437_qspi.h:190
qspi_cmd_type::read_status_enable
confirm_state read_status_enable
Definition: at32f435_437_qspi.h:200
qspi_cmd_type::data_counter
uint32_t data_counter
Definition: at32f435_437_qspi.h:196
qspi_cmd_type::address_code
uint32_t address_code
Definition: at32f435_437_qspi.h:194
qspi_cmd_type::pe_mode_operate_code
uint8_t pe_mode_operate_code
Definition: at32f435_437_qspi.h:191
qspi_cmd_type::address_length
qspi_cmd_adrlen_type address_length
Definition: at32f435_437_qspi.h:195
qspi_cmd_type::second_dummy_cycle_num
uint8_t second_dummy_cycle_num
Definition: at32f435_437_qspi.h:197


AT32F435/437 Firmwary Library: qspi_cmd_esmt32m.c File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
  • src
Macros | Functions | Variables
at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c File Reference

qspi_cmd_esmt32m program More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define FLASH_PAGE_PROGRAM_SIZE 256

Functions

void | qspi_busy_check (void)
qspi check busy More...
void | qspi_write_enable (void)
qspi write enable More...
void | esmt32m_cmd_read_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config More...
void | esmt32m_cmd_write_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config More...
void | esmt32m_cmd_erase_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config More...
void | esmt32m_cmd_wren_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config More...
void | esmt32m_cmd_rdsr_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config More...
void | qspi_dma_set (dma_dir_type dir, uint8_t *buf, uint32_t length)
qspi dma set More...
void | qspi_data_read (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data More...
static void | qspi_data_once_write (uint32_t addr, uint32_t sz, uint8_t *buf)
qspi write data for one time More...
void | qspi_data_write (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data More...
void | qspi_erase (uint32_t sec_addr)
qspi erase data More...
void | esmt32m_cmd_qpien_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd qpi enter config More...
void | esmt32m_cmd_rstqpi_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rstqpi config More...
void | esmt32m_cmd_rsten_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rst config More...
void | esmt32m_cmd_rst_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rst config More...
void | esmt32m_cmd_send (qspi_cmd_type *cmd)
esmt32m cmd kick and wait completed More...
void | esmt32m_qpi_mode_init (void)
switch QSPI to cmd port and setup to qpi mode More...

Variables

qspi_cmd_type esmt32m_cmd_config

Detailed Description

qspi_cmd_esmt32m program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.


AT32F435/437 Firmwary Library: qspi_cmd_esmt32m.c Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
  • src
at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28
37#define FLASH_PAGE_PROGRAM_SIZE 256
38
39 qspi_cmd_type esmt32m_cmd_config;
40
41void qspi_busy_check(void);
42void qspi_write_enable(void);
43
51void esmt32m_cmd_read_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
52{
53 qspi_cmd_struct->pe_mode_enable = FALSE;
54 qspi_cmd_struct->pe_mode_operate_code = 0;
55 qspi_cmd_struct->instruction_code = 0xEB;
56 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
57 qspi_cmd_struct->address_code = addr;
58 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
59 qspi_cmd_struct->data_counter = counter;
60 qspi_cmd_struct->second_dummy_cycle_num = 6;
61 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_444;
62 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
63 qspi_cmd_struct->read_status_enable = FALSE;
64 qspi_cmd_struct->write_data_enable = FALSE;
65}
66
74void esmt32m_cmd_write_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
75{
76 qspi_cmd_struct->pe_mode_enable = FALSE;
77 qspi_cmd_struct->pe_mode_operate_code = 0;
78 qspi_cmd_struct->instruction_code = 0x2;
79 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
80 qspi_cmd_struct->address_code = addr;
81 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
82 qspi_cmd_struct->data_counter = counter;
83 qspi_cmd_struct->second_dummy_cycle_num = 0;
84 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_444;
85 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
86 qspi_cmd_struct->read_status_enable = FALSE;
87 qspi_cmd_struct->write_data_enable = TRUE;
88}
89
96void esmt32m_cmd_erase_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
97{
98 qspi_cmd_struct->pe_mode_enable = FALSE;
99 qspi_cmd_struct->pe_mode_operate_code = 0;
100 qspi_cmd_struct->instruction_code = 0x20;
101 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
102 qspi_cmd_struct->address_code = addr;
103 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
104 qspi_cmd_struct->data_counter = 0;
105 qspi_cmd_struct->second_dummy_cycle_num = 0;
106 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_444;
107 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
108 qspi_cmd_struct->read_status_enable = FALSE;
109 qspi_cmd_struct->write_data_enable = TRUE;
110}
111
117void esmt32m_cmd_wren_config(qspi_cmd_type *qspi_cmd_struct)
118{
119 qspi_cmd_struct->pe_mode_enable = FALSE;
120 qspi_cmd_struct->pe_mode_operate_code = 0;
121 qspi_cmd_struct->instruction_code = 0x06;
122 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
123 qspi_cmd_struct->address_code = 0;
124 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
125 qspi_cmd_struct->data_counter = 0;
126 qspi_cmd_struct->second_dummy_cycle_num = 0;
127 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_444;
128 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
129 qspi_cmd_struct->read_status_enable = FALSE;
130 qspi_cmd_struct->write_data_enable = TRUE;
131}
132
138void esmt32m_cmd_rdsr_config(qspi_cmd_type *qspi_cmd_struct)
139{
140 qspi_cmd_struct->pe_mode_enable = FALSE;
141 qspi_cmd_struct->pe_mode_operate_code = 0;
142 qspi_cmd_struct->instruction_code = 0x05;
143 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
144 qspi_cmd_struct->address_code = 0;
145 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
146 qspi_cmd_struct->data_counter = 0;
147 qspi_cmd_struct->second_dummy_cycle_num = 0;
148 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_444;
149 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
150 qspi_cmd_struct->read_status_enable = TRUE;
151 qspi_cmd_struct->write_data_enable = FALSE;
152}
153
161void qspi_dma_set(dma_dir_type dir, uint8_t* buf, uint32_t length)
162{
163 dma_init_type dma_init_struct;
164 dma_reset(DMA2_CHANNEL1);
165 dma_default_para_init(&dma_init_struct);
166 dma_init_struct.buffer_size = length / 4; /* using word unit */
167 dma_init_struct.loop_mode_enable = FALSE;
168 dma_init_struct.direction = dir;
169 dma_init_struct.memory_base_addr = (uint32_t)buf;
170 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_WORD;
171 dma_init_struct.memory_inc_enable = TRUE;
172 dma_init_struct.peripheral_base_addr = (uint32_t)(&(QSPI1->dt));
173 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_WORD;
174 dma_init_struct.peripheral_inc_enable = FALSE;
175 dma_init_struct.priority = DMA_PRIORITY_HIGH;
176
177 dma_init(DMA2_CHANNEL1, &dma_init_struct);
178
179 dmamux_init(DMA2MUX_CHANNEL1, DMAMUX_DMAREQ_ID_QSPI1);
180 dmamux_enable(DMA2, TRUE);
181
182 dma_channel_enable(DMA2_CHANNEL1, TRUE);
183}
184
192void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t* buf)
193{
194 /* config qspi's dma mode */
195 qspi_dma_enable(QSPI1, TRUE);
196 qspi_dma_rx_threshold_set(QSPI1, QSPI_DMA_FIFO_THOD_WORD08);
197
198 /* config and enable dma */
199 qspi_dma_set(DMA_DIR_PERIPHERAL_TO_MEMORY, buf, total_len);
200
201 /* kick command */
202 esmt32m_cmd_read_config(&esmt32m_cmd_config, addr, total_len);
203 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
204
205 /* wait command completed */
206 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
207 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
208
209 /* wait dma completed */
210 while(dma_flag_get(DMA2_FDT1_FLAG) == RESET);
211 dma_flag_clear(DMA2_FDT1_FLAG);
212 qspi_dma_enable(QSPI1, FALSE);
213}
214
222static void qspi_data_once_write(uint32_t addr, uint32_t sz, uint8_t* buf)
223{
224 qspi_write_enable();
225
226 /* config qspi's dma mode */
227 qspi_dma_enable(QSPI1, TRUE);
228 qspi_dma_tx_threshold_set(QSPI1, QSPI_DMA_FIFO_THOD_WORD08);
229
230 /* config and enable dma */
231 qspi_dma_set(DMA_DIR_MEMORY_TO_PERIPHERAL, buf, sz);
232
233 /* kick command */
234 esmt32m_cmd_write_config(&esmt32m_cmd_config, addr, sz);
235 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
236
237 /* wait command completed */
238 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
239 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
240
241 /* wait dma completed */
242 while(dma_flag_get(DMA2_FDT1_FLAG) == RESET);
243 dma_flag_clear(DMA2_FDT1_FLAG);
244 qspi_dma_enable(QSPI1, FALSE);
245
246 qspi_busy_check();
247}
248
256void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t* buf)
257{
258 uint32_t blk_sz;
259 do
260 { /* send up to 256 bytes at one time */
261 if(total_len > FLASH_PAGE_PROGRAM_SIZE)
262 {
263 blk_sz = FLASH_PAGE_PROGRAM_SIZE;
264 }
265 else
266 {
267 blk_sz = total_len;
268 }
269 qspi_data_once_write(addr, blk_sz, buf);
270 addr += blk_sz;
271 buf += blk_sz;
272 total_len -= blk_sz;
273 }while(total_len > 0);
274}
275
281void qspi_erase(uint32_t sec_addr)
282{
283 qspi_write_enable();
284
285 esmt32m_cmd_erase_config(&esmt32m_cmd_config, sec_addr);
286 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
287
288 /* wait command completed */
289 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
290 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
291
292 qspi_busy_check();
293}
294
300void qspi_busy_check(void)
301{
302 esmt32m_cmd_rdsr_config(&esmt32m_cmd_config);
303 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
304
305 /* wait command completed */
306 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
307 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
308}
309
315void qspi_write_enable(void)
316{
317 esmt32m_cmd_wren_config(&esmt32m_cmd_config);
318 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
319
320 /* wait command completed */
321 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
322 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
323}
324
330void esmt32m_cmd_qpien_config(qspi_cmd_type *qspi_cmd_struct)
331{
332 qspi_cmd_struct->pe_mode_enable = FALSE;
333 qspi_cmd_struct->pe_mode_operate_code = 0;
334 qspi_cmd_struct->instruction_code = 0x38;
335 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
336 qspi_cmd_struct->address_code = 0;
337 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
338 qspi_cmd_struct->data_counter = 0;
339 qspi_cmd_struct->second_dummy_cycle_num = 0;
340 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
341 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
342 qspi_cmd_struct->read_status_enable = FALSE;
343 qspi_cmd_struct->write_data_enable = TRUE;
344}
345
351void esmt32m_cmd_rstqpi_config(qspi_cmd_type *qspi_cmd_struct)
352{
353 qspi_cmd_struct->pe_mode_enable = FALSE;
354 qspi_cmd_struct->pe_mode_operate_code = 0;
355 qspi_cmd_struct->instruction_code = 0xFF;
356 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
357 qspi_cmd_struct->address_code = 0;
358 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
359 qspi_cmd_struct->data_counter = 0;
360 qspi_cmd_struct->second_dummy_cycle_num = 0;
361 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_444;
362 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
363 qspi_cmd_struct->read_status_enable = FALSE;
364 qspi_cmd_struct->write_data_enable = TRUE;
365}
366
372void esmt32m_cmd_rsten_config(qspi_cmd_type *qspi_cmd_struct)
373{
374 qspi_cmd_struct->pe_mode_enable = FALSE;
375 qspi_cmd_struct->pe_mode_operate_code = 0;
376 qspi_cmd_struct->instruction_code = 0x66;
377 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
378 qspi_cmd_struct->address_code = 0;
379 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
380 qspi_cmd_struct->data_counter = 0;
381 qspi_cmd_struct->second_dummy_cycle_num = 0;
382 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
383 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
384 qspi_cmd_struct->read_status_enable = FALSE;
385 qspi_cmd_struct->write_data_enable = TRUE;
386}
387
393void esmt32m_cmd_rst_config(qspi_cmd_type *qspi_cmd_struct)
394{
395 qspi_cmd_struct->pe_mode_enable = FALSE;
396 qspi_cmd_struct->pe_mode_operate_code = 0;
397 qspi_cmd_struct->instruction_code = 0x99;
398 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
399 qspi_cmd_struct->address_code = 0;
400 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
401 qspi_cmd_struct->data_counter = 0;
402 qspi_cmd_struct->second_dummy_cycle_num = 0;
403 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
404 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
405 qspi_cmd_struct->read_status_enable = FALSE;
406 qspi_cmd_struct->write_data_enable = TRUE;
407}
408
414void esmt32m_cmd_send(qspi_cmd_type* cmd)
415{
416 qspi_cmd_operation_kick(QSPI1, cmd);
417 /* wait command completed */
418 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
419 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
420}
421
427void esmt32m_qpi_mode_init(void)
428{
429 /* reset qpi */
430 esmt32m_cmd_rstqpi_config(&esmt32m_cmd_config);
431 esmt32m_cmd_send(&esmt32m_cmd_config);
432
433 /* system reset */
434 esmt32m_cmd_rsten_config(&esmt32m_cmd_config);
435 esmt32m_cmd_send(&esmt32m_cmd_config);
436 esmt32m_cmd_rst_config(&esmt32m_cmd_config);
437 esmt32m_cmd_send(&esmt32m_cmd_config);
438
439 /* once the reset command is accepted by the device, the device will
440 take some time to reset. esmt32m will take about 28us in worst case.
441 user can set delay or check wip status */
442 delay_us(30);
443
444 esmt32m_cmd_qpien_config(&esmt32m_cmd_config);
445 esmt32m_cmd_send(&esmt32m_cmd_config);
446}
447
at32f435_437_board.h
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
counter
uint16_t counter
Definition: project/at_start_f435/examples/debug/tmr1/src/main.c:39
esmt32m_cmd_qpien_config
void esmt32m_cmd_qpien_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd qpi enter config
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:330
qspi_dma_set
void qspi_dma_set(dma_dir_type dir, uint8_t *buf, uint32_t length)
qspi dma set
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:161
qspi_busy_check
void qspi_busy_check(void)
qspi check busy
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:300
esmt32m_cmd_wren_config
void esmt32m_cmd_wren_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:117
esmt32m_cmd_rst_config
void esmt32m_cmd_rst_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rst config
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:393
esmt32m_cmd_send
void esmt32m_cmd_send(qspi_cmd_type *cmd)
esmt32m cmd kick and wait completed
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:414
esmt32m_cmd_erase_config
void esmt32m_cmd_erase_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:96
esmt32m_cmd_rstqpi_config
void esmt32m_cmd_rstqpi_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rstqpi config
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:351
FLASH_PAGE_PROGRAM_SIZE
#define FLASH_PAGE_PROGRAM_SIZE
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:37
qspi_write_enable
void qspi_write_enable(void)
qspi write enable
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:315
qspi_data_once_write
static void qspi_data_once_write(uint32_t addr, uint32_t sz, uint8_t *buf)
qspi write data for one time
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:222
esmt32m_cmd_config
qspi_cmd_type esmt32m_cmd_config
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:39
esmt32m_cmd_read_config
void esmt32m_cmd_read_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:51
esmt32m_cmd_rsten_config
void esmt32m_cmd_rsten_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rst config
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:372
esmt32m_cmd_write_config
void esmt32m_cmd_write_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:74
esmt32m_qpi_mode_init
void esmt32m_qpi_mode_init(void)
switch QSPI to cmd port and setup to qpi mode
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:427
esmt32m_cmd_rdsr_config
void esmt32m_cmd_rdsr_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:138
qspi_erase
void qspi_erase(uint32_t sec_addr)
qspi erase data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:281
qspi_data_read
void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:192
qspi_data_write
void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:256
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f435_437_board.c:306
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f435_437_dma.h:151
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:164
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:174
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_QSPI1
@ DMAMUX_DMAREQ_ID_QSPI1
Definition: at32f435_437_dma.h:240
DMA2_FDT1_FLAG
#define DMA2_FDT1_FLAG
Definition: at32f435_437_dma.h:95
DMA2MUX_CHANNEL1
#define DMA2MUX_CHANNEL1
Definition: at32f435_437_dma.h:726
DMA2
#define DMA2
Definition: at32f435_437_dma.h:717
DMA2_CHANNEL1
#define DMA2_CHANNEL1
Definition: at32f435_437_dma.h:718
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
qspi_flag_clear
void qspi_flag_clear(qspi_type *qspi_x, uint32_t flag)
clear flags
Definition: at32f435_437_qspi.c:168
qspi_dma_enable
void qspi_dma_enable(qspi_type *qspi_x, confirm_state new_state)
enable/disable dma transfer
Definition: at32f435_437_qspi.c:218
qspi_dma_tx_threshold_set
void qspi_dma_tx_threshold_set(qspi_type *qspi_x, qspi_dma_fifo_thod_type new_threshold)
set dma threshold for dma tx
Definition: at32f435_437_qspi.c:204
qspi_dma_rx_threshold_set
void qspi_dma_rx_threshold_set(qspi_type *qspi_x, qspi_dma_fifo_thod_type new_threshold)
set dma threshold for dma rx
Definition: at32f435_437_qspi.c:186
qspi_cmd_operation_kick
void qspi_cmd_operation_kick(qspi_type *qspi_x, qspi_cmd_type *qspi_cmd_struct)
set command-port and qspi_x will start to work
Definition: at32f435_437_qspi.c:292
qspi_flag_get
flag_status qspi_flag_get(qspi_type *qspi_x, uint32_t flag)
get status flags.
Definition: at32f435_437_qspi.c:138
QSPI_RSTSC_HW_AUTO
@ QSPI_RSTSC_HW_AUTO
Definition: at32f435_437_qspi.h:102
QSPI_CMD_INSLEN_1_BYTE
@ QSPI_CMD_INSLEN_1_BYTE
Definition: at32f435_437_qspi.h:153
QSPI_DMA_FIFO_THOD_WORD08
@ QSPI_DMA_FIFO_THOD_WORD08
Definition: at32f435_437_qspi.h:180
QSPI_OPERATE_MODE_111
@ QSPI_OPERATE_MODE_111
Definition: at32f435_437_qspi.h:111
QSPI_OPERATE_MODE_444
@ QSPI_OPERATE_MODE_444
Definition: at32f435_437_qspi.h:117
QSPI_CMD_ADRLEN_0_BYTE
@ QSPI_CMD_ADRLEN_0_BYTE
Definition: at32f435_437_qspi.h:140
QSPI_CMD_ADRLEN_3_BYTE
@ QSPI_CMD_ADRLEN_3_BYTE
Definition: at32f435_437_qspi.h:143
QSPI_CMDSTS_FLAG
#define QSPI_CMDSTS_FLAG
Definition: at32f435_437_qspi.h:52
QSPI1
#define QSPI1
Definition: at32f435_437_qspi.h:512
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
qspi_cmd_type
qspi cmd type
Definition: at32f435_437_qspi.h:189
qspi_cmd_type::instruction_length
qspi_cmd_inslen_type instruction_length
Definition: at32f435_437_qspi.h:193
qspi_cmd_type::write_data_enable
confirm_state write_data_enable
Definition: at32f435_437_qspi.h:201
qspi_cmd_type::operation_mode
qspi_operate_mode_type operation_mode
Definition: at32f435_437_qspi.h:198
qspi_cmd_type::instruction_code
uint8_t instruction_code
Definition: at32f435_437_qspi.h:192
qspi_cmd_type::read_status_config
qspi_read_status_conf_type read_status_config
Definition: at32f435_437_qspi.h:199
qspi_cmd_type::pe_mode_enable
confirm_state pe_mode_enable
Definition: at32f435_437_qspi.h:190
qspi_cmd_type::read_status_enable
confirm_state read_status_enable
Definition: at32f435_437_qspi.h:200
qspi_cmd_type::data_counter
uint32_t data_counter
Definition: at32f435_437_qspi.h:196
qspi_cmd_type::address_code
uint32_t address_code
Definition: at32f435_437_qspi.h:194
qspi_cmd_type::pe_mode_operate_code
uint8_t pe_mode_operate_code
Definition: at32f435_437_qspi.h:191
qspi_cmd_type::address_length
qspi_cmd_adrlen_type address_length
Definition: at32f435_437_qspi.h:195
qspi_cmd_type::second_dummy_cycle_num
uint8_t second_dummy_cycle_num
Definition: at32f435_437_qspi.h:197


AT32F435/437 Firmwary Library: qspi_cmd_esmt32m.c File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_interrupt
  • src
Macros | Functions | Variables
at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c File Reference

qspi_cmd_esmt32m program More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | QSPI_FIFO_DEPTH (32*4)
#define | FLASH_PAGE_PROGRAM_SIZE 256

Functions

void | qspi_busy_check (void)
qspi check busy More...
void | qspi_write_enable (void)
qspi write enable More...
void | esmt32m_cmd_read_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config More...
void | esmt32m_cmd_write_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config More...
void | esmt32m_cmd_erase_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config More...
void | esmt32m_cmd_wren_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config More...
void | esmt32m_cmd_rdsr_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config More...
void | qspi_command_set_busy ()
set qspi_state_is_busy More...
void | qspi_command_not_busy ()
reset qspi_state_is_busy More...
flag_status | qspi_command_is_busy (void)
return qspi_state_is_busy More...
void | QSPI1_IRQHandler (void)
this function handles qspi1 handler. More...
void | qspi_data_read (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data More...
void | qspi_data_write (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data More...
void | qspi_erase (uint32_t sec_addr)
qspi erase data More...

Variables

qspi_cmd_type esmt32m_cmd_config
volatile flag_status qspi_state_is_busy = RESET

Detailed Description

qspi_cmd_esmt32m program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c.


AT32F435/437 Firmwary Library: qspi_cmd_esmt32m.c Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_interrupt
  • src
at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28
37#define QSPI_FIFO_DEPTH (32*4)
38#define FLASH_PAGE_PROGRAM_SIZE 256
39
40 qspi_cmd_type esmt32m_cmd_config;
41volatile flag_status qspi_state_is_busy = RESET;
42
43void qspi_busy_check(void);
44void qspi_write_enable(void);
45
53void esmt32m_cmd_read_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
54{
55 qspi_cmd_struct->pe_mode_enable = FALSE;
56 qspi_cmd_struct->pe_mode_operate_code = 0;
57 qspi_cmd_struct->instruction_code = 0xEB;
58 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
59 qspi_cmd_struct->address_code = addr;
60 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
61 qspi_cmd_struct->data_counter = counter;
62 qspi_cmd_struct->second_dummy_cycle_num = 6;
63 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_144;
64 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
65 qspi_cmd_struct->read_status_enable = FALSE;
66 qspi_cmd_struct->write_data_enable = FALSE;
67}
68
76void esmt32m_cmd_write_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
77{
78 qspi_cmd_struct->pe_mode_enable = FALSE;
79 qspi_cmd_struct->pe_mode_operate_code = 0;
80 qspi_cmd_struct->instruction_code = 0x32;
81 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
82 qspi_cmd_struct->address_code = addr;
83 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
84 qspi_cmd_struct->data_counter = counter;
85 qspi_cmd_struct->second_dummy_cycle_num = 0;
86 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_114;
87 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
88 qspi_cmd_struct->read_status_enable = FALSE;
89 qspi_cmd_struct->write_data_enable = TRUE;
90}
91
98void esmt32m_cmd_erase_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
99{
100 qspi_cmd_struct->pe_mode_enable = FALSE;
101 qspi_cmd_struct->pe_mode_operate_code = 0;
102 qspi_cmd_struct->instruction_code = 0x20;
103 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
104 qspi_cmd_struct->address_code = addr;
105 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
106 qspi_cmd_struct->data_counter = 0;
107 qspi_cmd_struct->second_dummy_cycle_num = 0;
108 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
109 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
110 qspi_cmd_struct->read_status_enable = FALSE;
111 qspi_cmd_struct->write_data_enable = TRUE;
112}
113
119void esmt32m_cmd_wren_config(qspi_cmd_type *qspi_cmd_struct)
120{
121 qspi_cmd_struct->pe_mode_enable = FALSE;
122 qspi_cmd_struct->pe_mode_operate_code = 0;
123 qspi_cmd_struct->instruction_code = 0x06;
124 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
125 qspi_cmd_struct->address_code = 0;
126 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
127 qspi_cmd_struct->data_counter = 0;
128 qspi_cmd_struct->second_dummy_cycle_num = 0;
129 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
130 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
131 qspi_cmd_struct->read_status_enable = FALSE;
132 qspi_cmd_struct->write_data_enable = TRUE;
133}
134
140void esmt32m_cmd_rdsr_config(qspi_cmd_type *qspi_cmd_struct)
141{
142 qspi_cmd_struct->pe_mode_enable = FALSE;
143 qspi_cmd_struct->pe_mode_operate_code = 0;
144 qspi_cmd_struct->instruction_code = 0x05;
145 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
146 qspi_cmd_struct->address_code = 0;
147 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
148 qspi_cmd_struct->data_counter = 0;
149 qspi_cmd_struct->second_dummy_cycle_num = 0;
150 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
151 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
152 qspi_cmd_struct->read_status_enable = TRUE;
153 qspi_cmd_struct->write_data_enable = FALSE;
154}
155
161void qspi_command_set_busy()
162{
163 qspi_state_is_busy = SET;
164}
165
171void qspi_command_not_busy()
172{
173 qspi_state_is_busy = RESET;
174}
175
181 flag_status qspi_command_is_busy(void)
182{
183 return qspi_state_is_busy;
184}
185
191void QSPI1_IRQHandler(void)
192{
193 if(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) != RESET)
194 {
195 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
196 qspi_command_not_busy();
197 }
198}
199
207void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t* buf)
208{
209 uint32_t i, len = total_len;
210 /* set busy state */
211 qspi_command_set_busy();
212
213 esmt32m_cmd_read_config(&esmt32m_cmd_config, addr, total_len);
214 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
215
216 /* read data */
217 do
218 {
219 if(total_len >= QSPI_FIFO_DEPTH)
220 {
221 len = QSPI_FIFO_DEPTH;
222 }
223 else
224 {
225 len = total_len;
226 }
227 while(qspi_flag_get(QSPI1, QSPI_RXFIFORDY_FLAG) == RESET);
228
229 for(i = 0; i < len; ++i)
230 {
231 *buf++ = qspi_byte_read(QSPI1);
232 }
233 total_len -= len;
234 }while(total_len);
235
236 /* wait command completed */
237 while(qspi_command_is_busy() != RESET);
238}
239
247void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t* buf)
248{
249 uint32_t i, len = total_len;
250
251 do
252 {
253 qspi_write_enable();
254 if(total_len >= FLASH_PAGE_PROGRAM_SIZE)
255 {
256 len = FLASH_PAGE_PROGRAM_SIZE;
257 }
258 else
259 {
260 len = total_len;
261 }
262 /* set busy state */
263 qspi_command_set_busy();
264
265 esmt32m_cmd_write_config(&esmt32m_cmd_config, addr, len);
266 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
267
268 for(i = 0; i < len; ++i)
269 {
270 while(qspi_flag_get(QSPI1, QSPI_TXFIFORDY_FLAG) == RESET);
271 qspi_byte_write(QSPI1, *buf++);
272 }
273 total_len -= len;
274 addr += len;
275
276 /* wait command completed */
277 while(qspi_command_is_busy() != RESET);
278
279 qspi_busy_check();
280
281 }while(total_len);
282}
283
289void qspi_erase(uint32_t sec_addr)
290{
291 qspi_write_enable();
292
293 /* set busy state */
294 qspi_command_set_busy();
295
296 esmt32m_cmd_erase_config(&esmt32m_cmd_config, sec_addr);
297 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
298
299 /* wait command completed */
300 while(qspi_command_is_busy() != RESET);
301
302 qspi_busy_check();
303}
304
310void qspi_busy_check(void)
311{
312 /* set busy state */
313 qspi_command_set_busy();
314
315 esmt32m_cmd_rdsr_config(&esmt32m_cmd_config);
316 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
317
318 /* wait command completed */
319 while(qspi_command_is_busy() != RESET);
320}
321
327void qspi_write_enable(void)
328{
329 /* set busy state */
330 qspi_command_set_busy();
331
332 esmt32m_cmd_wren_config(&esmt32m_cmd_config);
333 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
334
335 /* wait command completed */
336 while(qspi_command_is_busy() != RESET);
337}
338
at32f435_437_board.h
counter
uint16_t counter
Definition: project/at_start_f435/examples/debug/tmr1/src/main.c:39
qspi_erase
void qspi_erase(uint32_t sec_addr)
qspi erase data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:281
qspi_data_read
void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:192
qspi_data_write
void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:256
qspi_command_not_busy
void qspi_command_not_busy()
reset qspi_state_is_busy
Definition: at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:171
qspi_busy_check
void qspi_busy_check(void)
qspi check busy
Definition: at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:310
esmt32m_cmd_wren_config
void esmt32m_cmd_wren_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config
Definition: at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:119
qspi_command_set_busy
void qspi_command_set_busy()
set qspi_state_is_busy
Definition: at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:161
esmt32m_cmd_erase_config
void esmt32m_cmd_erase_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config
Definition: at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:98
FLASH_PAGE_PROGRAM_SIZE
#define FLASH_PAGE_PROGRAM_SIZE
Definition: at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:38
qspi_write_enable
void qspi_write_enable(void)
qspi write enable
Definition: at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:327
qspi_state_is_busy
volatile flag_status qspi_state_is_busy
Definition: at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:41
QSPI1_IRQHandler
void QSPI1_IRQHandler(void)
this function handles qspi1 handler.
Definition: at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:191
esmt32m_cmd_config
qspi_cmd_type esmt32m_cmd_config
Definition: at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:40
esmt32m_cmd_read_config
void esmt32m_cmd_read_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config
Definition: at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:53
qspi_command_is_busy
flag_status qspi_command_is_busy(void)
return qspi_state_is_busy
Definition: at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:181
esmt32m_cmd_write_config
void esmt32m_cmd_write_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config
Definition: at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:76
esmt32m_cmd_rdsr_config
void esmt32m_cmd_rdsr_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config
Definition: at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:140
QSPI_FIFO_DEPTH
#define QSPI_FIFO_DEPTH
Definition: at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:37
flag_status
flag_status
Definition: at32f435_437.h:378
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
qspi_flag_clear
void qspi_flag_clear(qspi_type *qspi_x, uint32_t flag)
clear flags
Definition: at32f435_437_qspi.c:168
qspi_byte_read
uint8_t qspi_byte_read(qspi_type *qspi_x)
read one byte from qspi device in command mode
Definition: at32f435_437_qspi.c:359
qspi_byte_write
void qspi_byte_write(qspi_type *qspi_x, uint8_t value)
write one byte to qspi device in command mode
Definition: at32f435_437_qspi.c:390
qspi_cmd_operation_kick
void qspi_cmd_operation_kick(qspi_type *qspi_x, qspi_cmd_type *qspi_cmd_struct)
set command-port and qspi_x will start to work
Definition: at32f435_437_qspi.c:292
qspi_flag_get
flag_status qspi_flag_get(qspi_type *qspi_x, uint32_t flag)
get status flags.
Definition: at32f435_437_qspi.c:138
QSPI_RSTSC_HW_AUTO
@ QSPI_RSTSC_HW_AUTO
Definition: at32f435_437_qspi.h:102
QSPI_CMD_INSLEN_1_BYTE
@ QSPI_CMD_INSLEN_1_BYTE
Definition: at32f435_437_qspi.h:153
QSPI_OPERATE_MODE_144
@ QSPI_OPERATE_MODE_144
Definition: at32f435_437_qspi.h:115
QSPI_OPERATE_MODE_111
@ QSPI_OPERATE_MODE_111
Definition: at32f435_437_qspi.h:111
QSPI_OPERATE_MODE_114
@ QSPI_OPERATE_MODE_114
Definition: at32f435_437_qspi.h:113
QSPI_CMD_ADRLEN_0_BYTE
@ QSPI_CMD_ADRLEN_0_BYTE
Definition: at32f435_437_qspi.h:140
QSPI_CMD_ADRLEN_3_BYTE
@ QSPI_CMD_ADRLEN_3_BYTE
Definition: at32f435_437_qspi.h:143
QSPI_CMDSTS_FLAG
#define QSPI_CMDSTS_FLAG
Definition: at32f435_437_qspi.h:52
QSPI_RXFIFORDY_FLAG
#define QSPI_RXFIFORDY_FLAG
Definition: at32f435_437_qspi.h:53
QSPI_TXFIFORDY_FLAG
#define QSPI_TXFIFORDY_FLAG
Definition: at32f435_437_qspi.h:54
QSPI1
#define QSPI1
Definition: at32f435_437_qspi.h:512
qspi_cmd_type
qspi cmd type
Definition: at32f435_437_qspi.h:189
qspi_cmd_type::instruction_length
qspi_cmd_inslen_type instruction_length
Definition: at32f435_437_qspi.h:193
qspi_cmd_type::write_data_enable
confirm_state write_data_enable
Definition: at32f435_437_qspi.h:201
qspi_cmd_type::operation_mode
qspi_operate_mode_type operation_mode
Definition: at32f435_437_qspi.h:198
qspi_cmd_type::instruction_code
uint8_t instruction_code
Definition: at32f435_437_qspi.h:192
qspi_cmd_type::read_status_config
qspi_read_status_conf_type read_status_config
Definition: at32f435_437_qspi.h:199
qspi_cmd_type::pe_mode_enable
confirm_state pe_mode_enable
Definition: at32f435_437_qspi.h:190
qspi_cmd_type::read_status_enable
confirm_state read_status_enable
Definition: at32f435_437_qspi.h:200
qspi_cmd_type::data_counter
uint32_t data_counter
Definition: at32f435_437_qspi.h:196
qspi_cmd_type::address_code
uint32_t address_code
Definition: at32f435_437_qspi.h:194
qspi_cmd_type::pe_mode_operate_code
uint8_t pe_mode_operate_code
Definition: at32f435_437_qspi.h:191
qspi_cmd_type::address_length
qspi_cmd_adrlen_type address_length
Definition: at32f435_437_qspi.h:195
qspi_cmd_type::second_dummy_cycle_num
uint8_t second_dummy_cycle_num
Definition: at32f435_437_qspi.h:197


AT32F435/437 Firmwary Library: qspi_cmd_esmt32m.c File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_polling
  • src
Macros | Functions | Variables
at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c File Reference

qspi_cmd_esmt32m program More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | QSPI_FIFO_DEPTH (32*4)
#define | FLASH_PAGE_PROGRAM_SIZE 256

Functions

void | qspi_busy_check (void)
qspi check busy More...
void | qspi_write_enable (void)
qspi write enable More...
void | esmt32m_cmd_read_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config More...
void | esmt32m_cmd_write_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config More...
void | esmt32m_cmd_erase_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config More...
void | esmt32m_cmd_wren_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config More...
void | esmt32m_cmd_rdsr_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config More...
void | qspi_data_read (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data More...
void | qspi_data_write (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data More...
void | qspi_erase (uint32_t sec_addr)
qspi erase data More...

Variables

qspi_cmd_type esmt32m_cmd_config

Detailed Description

qspi_cmd_esmt32m program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c.


AT32F435/437 Firmwary Library: qspi_cmd_esmt32m.c Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_polling
  • src
at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28
37#define QSPI_FIFO_DEPTH (32*4)
38#define FLASH_PAGE_PROGRAM_SIZE 256
39
40 qspi_cmd_type esmt32m_cmd_config;
41
42void qspi_busy_check(void);
43void qspi_write_enable(void);
44
52void esmt32m_cmd_read_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
53{
54 qspi_cmd_struct->pe_mode_enable = FALSE;
55 qspi_cmd_struct->pe_mode_operate_code = 0;
56 qspi_cmd_struct->instruction_code = 0xEB;
57 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
58 qspi_cmd_struct->address_code = addr;
59 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
60 qspi_cmd_struct->data_counter = counter;
61 qspi_cmd_struct->second_dummy_cycle_num = 6;
62 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_144;
63 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
64 qspi_cmd_struct->read_status_enable = FALSE;
65 qspi_cmd_struct->write_data_enable = FALSE;
66}
67
75void esmt32m_cmd_write_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
76{
77 qspi_cmd_struct->pe_mode_enable = FALSE;
78 qspi_cmd_struct->pe_mode_operate_code = 0;
79 qspi_cmd_struct->instruction_code = 0x32;
80 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
81 qspi_cmd_struct->address_code = addr;
82 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
83 qspi_cmd_struct->data_counter = counter;
84 qspi_cmd_struct->second_dummy_cycle_num = 0;
85 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_114;
86 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
87 qspi_cmd_struct->read_status_enable = FALSE;
88 qspi_cmd_struct->write_data_enable = TRUE;
89}
90
97void esmt32m_cmd_erase_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
98{
99 qspi_cmd_struct->pe_mode_enable = FALSE;
100 qspi_cmd_struct->pe_mode_operate_code = 0;
101 qspi_cmd_struct->instruction_code = 0x20;
102 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
103 qspi_cmd_struct->address_code = addr;
104 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
105 qspi_cmd_struct->data_counter = 0;
106 qspi_cmd_struct->second_dummy_cycle_num = 0;
107 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
108 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
109 qspi_cmd_struct->read_status_enable = FALSE;
110 qspi_cmd_struct->write_data_enable = TRUE;
111}
112
118void esmt32m_cmd_wren_config(qspi_cmd_type *qspi_cmd_struct)
119{
120 qspi_cmd_struct->pe_mode_enable = FALSE;
121 qspi_cmd_struct->pe_mode_operate_code = 0;
122 qspi_cmd_struct->instruction_code = 0x06;
123 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
124 qspi_cmd_struct->address_code = 0;
125 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
126 qspi_cmd_struct->data_counter = 0;
127 qspi_cmd_struct->second_dummy_cycle_num = 0;
128 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
129 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
130 qspi_cmd_struct->read_status_enable = FALSE;
131 qspi_cmd_struct->write_data_enable = TRUE;
132}
133
139void esmt32m_cmd_rdsr_config(qspi_cmd_type *qspi_cmd_struct)
140{
141 qspi_cmd_struct->pe_mode_enable = FALSE;
142 qspi_cmd_struct->pe_mode_operate_code = 0;
143 qspi_cmd_struct->instruction_code = 0x05;
144 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
145 qspi_cmd_struct->address_code = 0;
146 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
147 qspi_cmd_struct->data_counter = 0;
148 qspi_cmd_struct->second_dummy_cycle_num = 0;
149 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
150 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
151 qspi_cmd_struct->read_status_enable = TRUE;
152 qspi_cmd_struct->write_data_enable = FALSE;
153}
154
162void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t* buf)
163{
164 uint32_t i, len = total_len;
165
166 esmt32m_cmd_read_config(&esmt32m_cmd_config, addr, total_len);
167 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
168
169 /* read data */
170 do
171 {
172 if(total_len >= QSPI_FIFO_DEPTH)
173 {
174 len = QSPI_FIFO_DEPTH;
175 }
176 else
177 {
178 len = total_len;
179 }
180 while(qspi_flag_get(QSPI1, QSPI_RXFIFORDY_FLAG) == RESET);
181 for(i = 0; i < len; ++i)
182 {
183 *buf++ = qspi_byte_read(QSPI1);
184 }
185 total_len -= len;
186 }while(total_len);
187
188 /* wait command completed */
189 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
190 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
191}
192
200void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t* buf)
201{
202 uint32_t i, len = total_len;
203
204 do
205 {
206 qspi_write_enable();
207 if(total_len >= FLASH_PAGE_PROGRAM_SIZE)
208 {
209 len = FLASH_PAGE_PROGRAM_SIZE;
210 }
211 else
212 {
213 len = total_len;
214 }
215 esmt32m_cmd_write_config(&esmt32m_cmd_config, addr, len);
216 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
217
218 for(i = 0; i < len; ++i)
219 {
220 while(qspi_flag_get(QSPI1, QSPI_TXFIFORDY_FLAG) == RESET);
221 qspi_byte_write(QSPI1, *buf++);
222 }
223 total_len -= len;
224 addr += len;
225
226 /* wait command completed */
227 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
228 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
229
230 qspi_busy_check();
231
232 }while(total_len);
233}
234
240void qspi_erase(uint32_t sec_addr)
241{
242 qspi_write_enable();
243
244 esmt32m_cmd_erase_config(&esmt32m_cmd_config, sec_addr);
245 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
246
247 /* wait command completed */
248 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
249 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
250
251 qspi_busy_check();
252}
253
259void qspi_busy_check(void)
260{
261 esmt32m_cmd_rdsr_config(&esmt32m_cmd_config);
262 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
263
264 /* wait command completed */
265 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
266 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
267}
268
274void qspi_write_enable(void)
275{
276 esmt32m_cmd_wren_config(&esmt32m_cmd_config);
277 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
278
279 /* wait command completed */
280 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
281 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
282}
283
at32f435_437_board.h
counter
uint16_t counter
Definition: project/at_start_f435/examples/debug/tmr1/src/main.c:39
qspi_erase
void qspi_erase(uint32_t sec_addr)
qspi erase data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:281
qspi_data_read
void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:192
qspi_data_write
void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:256
qspi_busy_check
void qspi_busy_check(void)
qspi check busy
Definition: at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c:259
esmt32m_cmd_wren_config
void esmt32m_cmd_wren_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config
Definition: at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c:118
esmt32m_cmd_erase_config
void esmt32m_cmd_erase_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config
Definition: at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c:97
FLASH_PAGE_PROGRAM_SIZE
#define FLASH_PAGE_PROGRAM_SIZE
Definition: at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c:38
qspi_write_enable
void qspi_write_enable(void)
qspi write enable
Definition: at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c:274
esmt32m_cmd_config
qspi_cmd_type esmt32m_cmd_config
Definition: at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c:40
esmt32m_cmd_read_config
void esmt32m_cmd_read_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config
Definition: at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c:52
esmt32m_cmd_write_config
void esmt32m_cmd_write_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config
Definition: at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c:75
esmt32m_cmd_rdsr_config
void esmt32m_cmd_rdsr_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config
Definition: at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c:139
QSPI_FIFO_DEPTH
#define QSPI_FIFO_DEPTH
Definition: at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c:37
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
qspi_flag_clear
void qspi_flag_clear(qspi_type *qspi_x, uint32_t flag)
clear flags
Definition: at32f435_437_qspi.c:168
qspi_byte_read
uint8_t qspi_byte_read(qspi_type *qspi_x)
read one byte from qspi device in command mode
Definition: at32f435_437_qspi.c:359
qspi_byte_write
void qspi_byte_write(qspi_type *qspi_x, uint8_t value)
write one byte to qspi device in command mode
Definition: at32f435_437_qspi.c:390
qspi_cmd_operation_kick
void qspi_cmd_operation_kick(qspi_type *qspi_x, qspi_cmd_type *qspi_cmd_struct)
set command-port and qspi_x will start to work
Definition: at32f435_437_qspi.c:292
qspi_flag_get
flag_status qspi_flag_get(qspi_type *qspi_x, uint32_t flag)
get status flags.
Definition: at32f435_437_qspi.c:138
QSPI_RSTSC_HW_AUTO
@ QSPI_RSTSC_HW_AUTO
Definition: at32f435_437_qspi.h:102
QSPI_CMD_INSLEN_1_BYTE
@ QSPI_CMD_INSLEN_1_BYTE
Definition: at32f435_437_qspi.h:153
QSPI_OPERATE_MODE_144
@ QSPI_OPERATE_MODE_144
Definition: at32f435_437_qspi.h:115
QSPI_OPERATE_MODE_111
@ QSPI_OPERATE_MODE_111
Definition: at32f435_437_qspi.h:111
QSPI_OPERATE_MODE_114
@ QSPI_OPERATE_MODE_114
Definition: at32f435_437_qspi.h:113
QSPI_CMD_ADRLEN_0_BYTE
@ QSPI_CMD_ADRLEN_0_BYTE
Definition: at32f435_437_qspi.h:140
QSPI_CMD_ADRLEN_3_BYTE
@ QSPI_CMD_ADRLEN_3_BYTE
Definition: at32f435_437_qspi.h:143
QSPI_CMDSTS_FLAG
#define QSPI_CMDSTS_FLAG
Definition: at32f435_437_qspi.h:52
QSPI_RXFIFORDY_FLAG
#define QSPI_RXFIFORDY_FLAG
Definition: at32f435_437_qspi.h:53
QSPI_TXFIFORDY_FLAG
#define QSPI_TXFIFORDY_FLAG
Definition: at32f435_437_qspi.h:54
QSPI1
#define QSPI1
Definition: at32f435_437_qspi.h:512
qspi_cmd_type
qspi cmd type
Definition: at32f435_437_qspi.h:189
qspi_cmd_type::instruction_length
qspi_cmd_inslen_type instruction_length
Definition: at32f435_437_qspi.h:193
qspi_cmd_type::write_data_enable
confirm_state write_data_enable
Definition: at32f435_437_qspi.h:201
qspi_cmd_type::operation_mode
qspi_operate_mode_type operation_mode
Definition: at32f435_437_qspi.h:198
qspi_cmd_type::instruction_code
uint8_t instruction_code
Definition: at32f435_437_qspi.h:192
qspi_cmd_type::read_status_config
qspi_read_status_conf_type read_status_config
Definition: at32f435_437_qspi.h:199
qspi_cmd_type::pe_mode_enable
confirm_state pe_mode_enable
Definition: at32f435_437_qspi.h:190
qspi_cmd_type::read_status_enable
confirm_state read_status_enable
Definition: at32f435_437_qspi.h:200
qspi_cmd_type::data_counter
uint32_t data_counter
Definition: at32f435_437_qspi.h:196
qspi_cmd_type::address_code
uint32_t address_code
Definition: at32f435_437_qspi.h:194
qspi_cmd_type::pe_mode_operate_code
uint8_t pe_mode_operate_code
Definition: at32f435_437_qspi.h:191
qspi_cmd_type::address_length
qspi_cmd_adrlen_type address_length
Definition: at32f435_437_qspi.h:195
qspi_cmd_type::second_dummy_cycle_num
uint8_t second_dummy_cycle_num
Definition: at32f435_437_qspi.h:197


AT32F435/437 Firmwary Library: qspi_cmd_esmt32m.c File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_rdsr_sw
  • src
Macros | Functions | Variables
at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c File Reference

qspi_cmd_esmt32m program More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | QSPI_FIFO_DEPTH (32*4)
#define | FLASH_PAGE_PROGRAM_SIZE 256

Functions

void | qspi_busy_check (void)
qspi check busy More...
void | qspi_write_enable (void)
qspi write enable More...
void | esmt32m_cmd_read_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config More...
void | esmt32m_cmd_write_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config More...
void | esmt32m_cmd_erase_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config More...
void | esmt32m_cmd_wren_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config More...
void | esmt32m_cmd_rdsr_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config More...
void | qspi_data_read (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data More...
void | qspi_data_write (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data More...
void | qspi_erase (uint32_t sec_addr)
qspi erase data More...

Variables

qspi_cmd_type esmt32m_cmd_config

Detailed Description

qspi_cmd_esmt32m program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c.


AT32F435/437 Firmwary Library: qspi_cmd_esmt32m.c Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_rdsr_sw
  • src
at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28
37#define QSPI_FIFO_DEPTH (32*4)
38#define FLASH_PAGE_PROGRAM_SIZE 256
39
40 qspi_cmd_type esmt32m_cmd_config;
41
42void qspi_busy_check(void);
43void qspi_write_enable(void);
44
52void esmt32m_cmd_read_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
53{
54 qspi_cmd_struct->pe_mode_enable = FALSE;
55 qspi_cmd_struct->pe_mode_operate_code = 0;
56 qspi_cmd_struct->instruction_code = 0xEB;
57 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
58 qspi_cmd_struct->address_code = addr;
59 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
60 qspi_cmd_struct->data_counter = counter;
61 qspi_cmd_struct->second_dummy_cycle_num = 6;
62 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_144;
63 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
64 qspi_cmd_struct->read_status_enable = FALSE;
65 qspi_cmd_struct->write_data_enable = FALSE;
66}
67
75void esmt32m_cmd_write_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
76{
77 qspi_cmd_struct->pe_mode_enable = FALSE;
78 qspi_cmd_struct->pe_mode_operate_code = 0;
79 qspi_cmd_struct->instruction_code = 0x32;
80 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
81 qspi_cmd_struct->address_code = addr;
82 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
83 qspi_cmd_struct->data_counter = counter;
84 qspi_cmd_struct->second_dummy_cycle_num = 0;
85 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_114;
86 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
87 qspi_cmd_struct->read_status_enable = FALSE;
88 qspi_cmd_struct->write_data_enable = TRUE;
89}
90
97void esmt32m_cmd_erase_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
98{
99 qspi_cmd_struct->pe_mode_enable = FALSE;
100 qspi_cmd_struct->pe_mode_operate_code = 0;
101 qspi_cmd_struct->instruction_code = 0x20;
102 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
103 qspi_cmd_struct->address_code = addr;
104 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
105 qspi_cmd_struct->data_counter = 0;
106 qspi_cmd_struct->second_dummy_cycle_num = 0;
107 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
108 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
109 qspi_cmd_struct->read_status_enable = FALSE;
110 qspi_cmd_struct->write_data_enable = TRUE;
111}
112
118void esmt32m_cmd_wren_config(qspi_cmd_type *qspi_cmd_struct)
119{
120 qspi_cmd_struct->pe_mode_enable = FALSE;
121 qspi_cmd_struct->pe_mode_operate_code = 0;
122 qspi_cmd_struct->instruction_code = 0x06;
123 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
124 qspi_cmd_struct->address_code = 0;
125 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
126 qspi_cmd_struct->data_counter = 0;
127 qspi_cmd_struct->second_dummy_cycle_num = 0;
128 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
129 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
130 qspi_cmd_struct->read_status_enable = FALSE;
131 qspi_cmd_struct->write_data_enable = TRUE;
132}
133
139void esmt32m_cmd_rdsr_config(qspi_cmd_type *qspi_cmd_struct)
140{
141 qspi_cmd_struct->pe_mode_enable = FALSE;
142 qspi_cmd_struct->pe_mode_operate_code = 0;
143 qspi_cmd_struct->instruction_code = 0x05;
144 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
145 qspi_cmd_struct->address_code = 0;
146 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
147 qspi_cmd_struct->data_counter = 0;
148 qspi_cmd_struct->second_dummy_cycle_num = 0;
149 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
150 qspi_cmd_struct->read_status_config = QSPI_RSTSC_SW_ONCE;
151 qspi_cmd_struct->read_status_enable = TRUE;
152 qspi_cmd_struct->write_data_enable = FALSE;
153}
154
162void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t* buf)
163{
164 uint32_t i, len = total_len;
165
166 esmt32m_cmd_read_config(&esmt32m_cmd_config, addr, total_len);
167 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
168
169 /* read data */
170 do
171 {
172 if(total_len >= QSPI_FIFO_DEPTH)
173 {
174 len = QSPI_FIFO_DEPTH;
175 }
176 else
177 {
178 len = total_len;
179 }
180 while(qspi_flag_get(QSPI1, QSPI_RXFIFORDY_FLAG) == RESET);
181 for(i = 0; i < len; ++i)
182 {
183 *buf++ = qspi_byte_read(QSPI1);
184 }
185 total_len -= len;
186 }while(total_len);
187
188 /* wait command completed */
189 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
190 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
191}
192
200void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t* buf)
201{
202 uint32_t i, len = total_len;
203
204 do
205 {
206 qspi_write_enable();
207 if(total_len >= FLASH_PAGE_PROGRAM_SIZE)
208 {
209 len = FLASH_PAGE_PROGRAM_SIZE;
210 }
211 else
212 {
213 len = total_len;
214 }
215 esmt32m_cmd_write_config(&esmt32m_cmd_config, addr, len);
216 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
217
218 for(i = 0; i < len; ++i)
219 {
220 while(qspi_flag_get(QSPI1, QSPI_TXFIFORDY_FLAG) == RESET);
221 qspi_byte_write(QSPI1, *buf++);
222 }
223 total_len -= len;
224 addr += len;
225
226 /* wait command completed */
227 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
228 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
229
230 qspi_busy_check();
231
232 }while(total_len);
233}
234
240void qspi_erase(uint32_t sec_addr)
241{
242 qspi_write_enable();
243
244 esmt32m_cmd_erase_config(&esmt32m_cmd_config, sec_addr);
245 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
246
247 /* wait command completed */
248 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
249 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
250
251 qspi_busy_check();
252}
253
259void qspi_busy_check(void)
260{
261 do
262 {
263 esmt32m_cmd_rdsr_config(&esmt32m_cmd_config);
264 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
265
266 /* wait command completed */
267 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
268 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
269 /* check wip status */
270 }while(QSPI1->rsts & (1 << QSPI_BUSY_OFFSET_0));
271}
272
278void qspi_write_enable(void)
279{
280 esmt32m_cmd_wren_config(&esmt32m_cmd_config);
281 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
282
283 /* wait command completed */
284 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
285 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
286}
287
at32f435_437_board.h
counter
uint16_t counter
Definition: project/at_start_f435/examples/debug/tmr1/src/main.c:39
qspi_erase
void qspi_erase(uint32_t sec_addr)
qspi erase data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:281
qspi_data_read
void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:192
qspi_data_write
void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:256
qspi_busy_check
void qspi_busy_check(void)
qspi check busy
Definition: at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c:259
esmt32m_cmd_wren_config
void esmt32m_cmd_wren_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config
Definition: at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c:118
esmt32m_cmd_erase_config
void esmt32m_cmd_erase_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config
Definition: at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c:97
FLASH_PAGE_PROGRAM_SIZE
#define FLASH_PAGE_PROGRAM_SIZE
Definition: at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c:38
qspi_write_enable
void qspi_write_enable(void)
qspi write enable
Definition: at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c:278
esmt32m_cmd_config
qspi_cmd_type esmt32m_cmd_config
Definition: at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c:40
esmt32m_cmd_read_config
void esmt32m_cmd_read_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config
Definition: at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c:52
esmt32m_cmd_write_config
void esmt32m_cmd_write_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config
Definition: at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c:75
esmt32m_cmd_rdsr_config
void esmt32m_cmd_rdsr_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config
Definition: at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c:139
QSPI_FIFO_DEPTH
#define QSPI_FIFO_DEPTH
Definition: at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c:37
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
qspi_flag_clear
void qspi_flag_clear(qspi_type *qspi_x, uint32_t flag)
clear flags
Definition: at32f435_437_qspi.c:168
qspi_byte_read
uint8_t qspi_byte_read(qspi_type *qspi_x)
read one byte from qspi device in command mode
Definition: at32f435_437_qspi.c:359
qspi_byte_write
void qspi_byte_write(qspi_type *qspi_x, uint8_t value)
write one byte to qspi device in command mode
Definition: at32f435_437_qspi.c:390
qspi_cmd_operation_kick
void qspi_cmd_operation_kick(qspi_type *qspi_x, qspi_cmd_type *qspi_cmd_struct)
set command-port and qspi_x will start to work
Definition: at32f435_437_qspi.c:292
qspi_flag_get
flag_status qspi_flag_get(qspi_type *qspi_x, uint32_t flag)
get status flags.
Definition: at32f435_437_qspi.c:138
QSPI_RSTSC_SW_ONCE
@ QSPI_RSTSC_SW_ONCE
Definition: at32f435_437_qspi.h:103
QSPI_RSTSC_HW_AUTO
@ QSPI_RSTSC_HW_AUTO
Definition: at32f435_437_qspi.h:102
QSPI_CMD_INSLEN_1_BYTE
@ QSPI_CMD_INSLEN_1_BYTE
Definition: at32f435_437_qspi.h:153
QSPI_BUSY_OFFSET_0
@ QSPI_BUSY_OFFSET_0
Definition: at32f435_437_qspi.h:87
QSPI_OPERATE_MODE_144
@ QSPI_OPERATE_MODE_144
Definition: at32f435_437_qspi.h:115
QSPI_OPERATE_MODE_111
@ QSPI_OPERATE_MODE_111
Definition: at32f435_437_qspi.h:111
QSPI_OPERATE_MODE_114
@ QSPI_OPERATE_MODE_114
Definition: at32f435_437_qspi.h:113
QSPI_CMD_ADRLEN_0_BYTE
@ QSPI_CMD_ADRLEN_0_BYTE
Definition: at32f435_437_qspi.h:140
QSPI_CMD_ADRLEN_3_BYTE
@ QSPI_CMD_ADRLEN_3_BYTE
Definition: at32f435_437_qspi.h:143
QSPI_CMDSTS_FLAG
#define QSPI_CMDSTS_FLAG
Definition: at32f435_437_qspi.h:52
QSPI_RXFIFORDY_FLAG
#define QSPI_RXFIFORDY_FLAG
Definition: at32f435_437_qspi.h:53
QSPI_TXFIFORDY_FLAG
#define QSPI_TXFIFORDY_FLAG
Definition: at32f435_437_qspi.h:54
QSPI1
#define QSPI1
Definition: at32f435_437_qspi.h:512
qspi_cmd_type
qspi cmd type
Definition: at32f435_437_qspi.h:189
qspi_cmd_type::instruction_length
qspi_cmd_inslen_type instruction_length
Definition: at32f435_437_qspi.h:193
qspi_cmd_type::write_data_enable
confirm_state write_data_enable
Definition: at32f435_437_qspi.h:201
qspi_cmd_type::operation_mode
qspi_operate_mode_type operation_mode
Definition: at32f435_437_qspi.h:198
qspi_cmd_type::instruction_code
uint8_t instruction_code
Definition: at32f435_437_qspi.h:192
qspi_cmd_type::read_status_config
qspi_read_status_conf_type read_status_config
Definition: at32f435_437_qspi.h:199
qspi_cmd_type::pe_mode_enable
confirm_state pe_mode_enable
Definition: at32f435_437_qspi.h:190
qspi_cmd_type::read_status_enable
confirm_state read_status_enable
Definition: at32f435_437_qspi.h:200
qspi_cmd_type::data_counter
uint32_t data_counter
Definition: at32f435_437_qspi.h:196
qspi_cmd_type::address_code
uint32_t address_code
Definition: at32f435_437_qspi.h:194
qspi_cmd_type::pe_mode_operate_code
uint8_t pe_mode_operate_code
Definition: at32f435_437_qspi.h:191
qspi_cmd_type::address_length
qspi_cmd_adrlen_type address_length
Definition: at32f435_437_qspi.h:195
qspi_cmd_type::second_dummy_cycle_num
uint8_t second_dummy_cycle_num
Definition: at32f435_437_qspi.h:197


AT32F435/437 Firmwary Library: qspi_xip_ly68l6400.c File Reference

  • at_start_f435
  • examples
  • qspi
  • xip_port_write_read
  • src
Functions | Variables
at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c File Reference
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void | xip_init_ly68l6400_config (qspi_xip_type *qspi_xip_struct)
xip init ly68l6400 config More...
void | cmd_rsten_ly68l6400_config (qspi_cmd_type *qspi_cmd_struct)
cmd rsten ly68l6400 config More...
void | cmd_rst_ly68l6400_config (qspi_cmd_type *qspi_cmd_struct)
cmd rst ly68l6400 config More...
void | qspi_cmd_ly68l6400_send (qspi_cmd_type *cmd)
void | qspi_xip_init_ly68l6400 (void)

Variables

qspi_xip_type ly68l6400_xip_init
qspi_cmd_type ly68l6400_cmd_config


AT32F435/437 Firmwary Library: qspi_xip_ly68l6400.c Source File

  • at_start_f435
  • examples
  • qspi
  • xip_port_write_read
  • src
at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28
37 qspi_xip_type ly68l6400_xip_init;
38 qspi_cmd_type ly68l6400_cmd_config;
39
45void xip_init_ly68l6400_config(qspi_xip_type *qspi_xip_struct)
46{
47 qspi_xip_struct->read_instruction_code = 0xEB;
48 qspi_xip_struct->read_address_length = QSPI_XIP_ADDRLEN_3_BYTE;
49 qspi_xip_struct->read_operation_mode = QSPI_OPERATE_MODE_144;
50 qspi_xip_struct->read_second_dummy_cycle_num = 6;
51 qspi_xip_struct->write_instruction_code = 0x38;
52 qspi_xip_struct->write_address_length = QSPI_XIP_ADDRLEN_3_BYTE;
53 qspi_xip_struct->write_operation_mode = QSPI_OPERATE_MODE_144;
54 qspi_xip_struct->write_second_dummy_cycle_num = 0;
55 qspi_xip_struct->write_select_mode = QSPI_XIPW_SEL_MODED;
56 qspi_xip_struct->write_time_counter = 0x7F;
57 qspi_xip_struct->write_data_counter = 0x1F;
58 qspi_xip_struct->read_select_mode = QSPI_XIPR_SEL_MODED;
59 qspi_xip_struct->read_time_counter = 0x7F;
60 qspi_xip_struct->read_data_counter = 0x1F;
61}
62
68void cmd_rsten_ly68l6400_config(qspi_cmd_type *qspi_cmd_struct)
69{
70 qspi_cmd_struct->pe_mode_enable = FALSE;
71 qspi_cmd_struct->pe_mode_operate_code = 0;
72 qspi_cmd_struct->instruction_code = 0x66;
73 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
74 qspi_cmd_struct->address_code = 0;
75 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
76 qspi_cmd_struct->data_counter = 0;
77 qspi_cmd_struct->second_dummy_cycle_num = 0;
78 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
79 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
80 qspi_cmd_struct->read_status_enable = FALSE;
81 qspi_cmd_struct->write_data_enable = TRUE;
82}
83
89void cmd_rst_ly68l6400_config(qspi_cmd_type *qspi_cmd_struct)
90{
91 qspi_cmd_struct->pe_mode_enable = FALSE;
92 qspi_cmd_struct->pe_mode_operate_code = 0;
93 qspi_cmd_struct->instruction_code = 0x99;
94 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
95 qspi_cmd_struct->address_code = 0;
96 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
97 qspi_cmd_struct->data_counter = 0;
98 qspi_cmd_struct->second_dummy_cycle_num = 0;
99 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
100 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
101 qspi_cmd_struct->read_status_enable = FALSE;
102 qspi_cmd_struct->write_data_enable = TRUE;
103}
104
105void qspi_cmd_ly68l6400_send(qspi_cmd_type* cmd)
106{
107 qspi_cmd_operation_kick(QSPI1, cmd);
108 /* wait command completed */
109 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
110 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
111}
112
113
114void qspi_xip_init_ly68l6400(void)
115{
116 /* switch to command-port mode */
117 qspi_xip_enable(QSPI1, FALSE);
118
119 /* issue reset command */
120 cmd_rsten_ly68l6400_config(&ly68l6400_cmd_config);
121 qspi_cmd_ly68l6400_send(&ly68l6400_cmd_config);
122 cmd_rst_ly68l6400_config(&ly68l6400_cmd_config);
123 qspi_cmd_ly68l6400_send(&ly68l6400_cmd_config);
124
125 /* initial xip */
126 xip_init_ly68l6400_config(&ly68l6400_xip_init);
127 qspi_xip_init(QSPI1, &ly68l6400_xip_init);
128 qspi_xip_cache_bypass_set(QSPI1,TRUE);
129 qspi_xip_enable(QSPI1, TRUE);
130}
131
at32f435_437_board.h
cmd_rst_ly68l6400_config
void cmd_rst_ly68l6400_config(qspi_cmd_type *qspi_cmd_struct)
cmd rst ly68l6400 config
Definition: at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c:89
qspi_cmd_ly68l6400_send
void qspi_cmd_ly68l6400_send(qspi_cmd_type *cmd)
Definition: at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c:105
ly68l6400_cmd_config
qspi_cmd_type ly68l6400_cmd_config
Definition: at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c:38
qspi_xip_init_ly68l6400
void qspi_xip_init_ly68l6400(void)
Definition: at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c:114
xip_init_ly68l6400_config
void xip_init_ly68l6400_config(qspi_xip_type *qspi_xip_struct)
xip init ly68l6400 config
Definition: at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c:45
cmd_rsten_ly68l6400_config
void cmd_rsten_ly68l6400_config(qspi_cmd_type *qspi_cmd_struct)
cmd rsten ly68l6400 config
Definition: at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c:68
ly68l6400_xip_init
qspi_xip_type ly68l6400_xip_init
Definition: at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c:37
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
qspi_flag_clear
void qspi_flag_clear(qspi_type *qspi_x, uint32_t flag)
clear flags
Definition: at32f435_437_qspi.c:168
qspi_xip_enable
void qspi_xip_enable(qspi_type *qspi_x, confirm_state new_state)
enable xip mode or command-port mode.
Definition: at32f435_437_qspi.c:254
qspi_cmd_operation_kick
void qspi_cmd_operation_kick(qspi_type *qspi_x, qspi_cmd_type *qspi_cmd_struct)
set command-port and qspi_x will start to work
Definition: at32f435_437_qspi.c:292
qspi_xip_init
void qspi_xip_init(qspi_type *qspi_x, qspi_xip_type *xip_init_struct)
initial xip mode for qspi_x
Definition: at32f435_437_qspi.c:327
qspi_flag_get
flag_status qspi_flag_get(qspi_type *qspi_x, uint32_t flag)
get status flags.
Definition: at32f435_437_qspi.c:138
qspi_xip_cache_bypass_set
void qspi_xip_cache_bypass_set(qspi_type *qspi_x, confirm_state new_state)
enable/disable cache in xip mode
Definition: at32f435_437_qspi.c:107
QSPI_RSTSC_HW_AUTO
@ QSPI_RSTSC_HW_AUTO
Definition: at32f435_437_qspi.h:102
QSPI_CMD_INSLEN_1_BYTE
@ QSPI_CMD_INSLEN_1_BYTE
Definition: at32f435_437_qspi.h:153
QSPI_XIP_ADDRLEN_3_BYTE
@ QSPI_XIP_ADDRLEN_3_BYTE
Definition: at32f435_437_qspi.h:162
QSPI_OPERATE_MODE_144
@ QSPI_OPERATE_MODE_144
Definition: at32f435_437_qspi.h:115
QSPI_OPERATE_MODE_111
@ QSPI_OPERATE_MODE_111
Definition: at32f435_437_qspi.h:111
QSPI_CMD_ADRLEN_0_BYTE
@ QSPI_CMD_ADRLEN_0_BYTE
Definition: at32f435_437_qspi.h:140
QSPI_XIPR_SEL_MODED
@ QSPI_XIPR_SEL_MODED
Definition: at32f435_437_qspi.h:69
QSPI_XIPW_SEL_MODED
@ QSPI_XIPW_SEL_MODED
Definition: at32f435_437_qspi.h:78
QSPI_CMDSTS_FLAG
#define QSPI_CMDSTS_FLAG
Definition: at32f435_437_qspi.h:52
QSPI1
#define QSPI1
Definition: at32f435_437_qspi.h:512
qspi_cmd_type
qspi cmd type
Definition: at32f435_437_qspi.h:189
qspi_cmd_type::instruction_length
qspi_cmd_inslen_type instruction_length
Definition: at32f435_437_qspi.h:193
qspi_cmd_type::write_data_enable
confirm_state write_data_enable
Definition: at32f435_437_qspi.h:201
qspi_cmd_type::operation_mode
qspi_operate_mode_type operation_mode
Definition: at32f435_437_qspi.h:198
qspi_cmd_type::instruction_code
uint8_t instruction_code
Definition: at32f435_437_qspi.h:192
qspi_cmd_type::read_status_config
qspi_read_status_conf_type read_status_config
Definition: at32f435_437_qspi.h:199
qspi_cmd_type::pe_mode_enable
confirm_state pe_mode_enable
Definition: at32f435_437_qspi.h:190
qspi_cmd_type::read_status_enable
confirm_state read_status_enable
Definition: at32f435_437_qspi.h:200
qspi_cmd_type::data_counter
uint32_t data_counter
Definition: at32f435_437_qspi.h:196
qspi_cmd_type::address_code
uint32_t address_code
Definition: at32f435_437_qspi.h:194
qspi_cmd_type::pe_mode_operate_code
uint8_t pe_mode_operate_code
Definition: at32f435_437_qspi.h:191
qspi_cmd_type::address_length
qspi_cmd_adrlen_type address_length
Definition: at32f435_437_qspi.h:195
qspi_cmd_type::second_dummy_cycle_num
uint8_t second_dummy_cycle_num
Definition: at32f435_437_qspi.h:197
qspi_xip_type
qspi xip type
Definition: at32f435_437_qspi.h:208
qspi_xip_type::write_operation_mode
qspi_operate_mode_type write_operation_mode
Definition: at32f435_437_qspi.h:215
qspi_xip_type::read_second_dummy_cycle_num
uint8_t read_second_dummy_cycle_num
Definition: at32f435_437_qspi.h:212
qspi_xip_type::write_address_length
qspi_xip_addrlen_type write_address_length
Definition: at32f435_437_qspi.h:214
qspi_xip_type::write_instruction_code
uint8_t write_instruction_code
Definition: at32f435_437_qspi.h:213
qspi_xip_type::write_data_counter
uint8_t write_data_counter
Definition: at32f435_437_qspi.h:219
qspi_xip_type::read_select_mode
qspi_xip_read_sel_type read_select_mode
Definition: at32f435_437_qspi.h:220
qspi_xip_type::write_time_counter
uint8_t write_time_counter
Definition: at32f435_437_qspi.h:218
qspi_xip_type::read_operation_mode
qspi_operate_mode_type read_operation_mode
Definition: at32f435_437_qspi.h:211
qspi_xip_type::read_address_length
qspi_xip_addrlen_type read_address_length
Definition: at32f435_437_qspi.h:210
qspi_xip_type::read_data_counter
uint8_t read_data_counter
Definition: at32f435_437_qspi.h:222
qspi_xip_type::read_time_counter
uint8_t read_time_counter
Definition: at32f435_437_qspi.h:221
qspi_xip_type::write_select_mode
qspi_xip_write_sel_type write_select_mode
Definition: at32f435_437_qspi.h:217
qspi_xip_type::write_second_dummy_cycle_num
uint8_t write_second_dummy_cycle_num
Definition: at32f435_437_qspi.h:216
qspi_xip_type::read_instruction_code
uint8_t read_instruction_code
Definition: at32f435_437_qspi.h:209


AT32F435/437 Firmwary Library: at32_sdio.h File Reference

  • at_start_f435
  • examples
  • sdio
  • sd_mmc_card
  • inc
Data Structures | Macros | Enumerations | Functions | Variables
at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h File Reference

this file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library. More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct | sd_csd_struct_type
struct | sd_cid_struct_type
struct | sd_scr_struct_type
struct | sd_card_info_struct_type

Macros

#define | SDIOx SDIO1
#define | DMAMUX_SDIOx DMAMUX_DMAREQ_ID_SDIO1
#define | SD_CMD_GO_IDLE_STATE ((uint8_t)0)
#define | SD_CMD_SEND_OP_COND ((uint8_t)1)
#define | SD_CMD_ALL_SEND_CID ((uint8_t)2)
#define | SD_CMD_SET_REL_ADDR ((uint8_t)3)
#define | SD_CMD_SET_DSR ((uint8_t)4)
#define | SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)
#define | SD_CMD_HS_SWITCH ((uint8_t)6)
#define | SD_CMD_SEL_DESEL_CARD ((uint8_t)7)
#define | SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)
#define | SD_CMD_SEND_CSD ((uint8_t)9)
#define | SD_CMD_SEND_CID ((uint8_t)10)
#define | SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)
#define | SD_CMD_STOP_TRANSMISSION ((uint8_t)12)
#define | SD_CMD_SEND_STATUS ((uint8_t)13)
#define | SD_CMD_HS_BUSTEST_READ ((uint8_t)14)
#define | SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)
#define | SD_CMD_SET_BLOCKLEN ((uint8_t)16)
#define | SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)
#define | SD_CMD_READ_MULT_BLOCK ((uint8_t)18)
#define | SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)
#define | SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)
#define | SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)
#define | SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)
#define | SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)
#define | SD_CMD_PROG_CID ((uint8_t)26)
#define | SD_CMD_PROG_CSD ((uint8_t)27)
#define | SD_CMD_SET_WRITE_PROT ((uint8_t)28)
#define | SD_CMD_CLR_WRITE_PROT ((uint8_t)29)
#define | SD_CMD_SEND_WRITE_PROT ((uint8_t)30)
#define | SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)
#define | SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)
#define | SD_CMD_ERASE_GRP_START ((uint8_t)35)
#define | SD_CMD_ERASE_GRP_END ((uint8_t)36)
#define | SD_CMD_ERASE ((uint8_t)38)
#define | SD_CMD_FAST_IO ((uint8_t)39)
#define | SD_CMD_GO_IRQ_STATE ((uint8_t)40)
#define | SD_CMD_LOCK_UNLOCK ((uint8_t)42)
#define | SD_CMD_APP_CMD ((uint8_t)55)
#define | SD_CMD_GEN_CMD ((uint8_t)56)
#define | SD_CMD_NO_CMD ((uint8_t)64)
#define | SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)
#define | SD_CMD_SD_APP_STAUS ((uint8_t)13)
#define | SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)
#define | SD_CMD_SD_APP_OP_COND ((uint8_t)41)
#define | SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)
#define | SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)
#define | SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)
#define | SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)
#define | SD_CMD_SD_APP_GET_MKB ((uint8_t)43)
#define | SD_CMD_SD_APP_GET_MID ((uint8_t)44)
#define | SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)
#define | SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)
#define | SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)
#define | SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)
#define | SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)
#define | SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)
#define | SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)
#define | SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)
#define | SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)
#define | NULL 0
#define | SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)
#define | SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)
#define | SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SDIO_FIFO_Address ((uint32_t)0x40018080)
#define | SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)
#define | SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)
#define | SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)
#define | SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)
#define | SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)
#define | SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)
#define | SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)
#define | SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)
#define | SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)
#define | SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)
#define | SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)
#define | SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)
#define | SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)
#define | SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)
#define | SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)
#define | SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)
#define | SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)
#define | SD_OCR_ERASE_RESET ((uint32_t)0x00002000)
#define | MMC_SWITCH_ERROR ((uint32_t)0x00000080)
#define | SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)
#define | SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)
#define | SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)
#define | SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)
#define | SD_R5_ERROR ((uint32_t)0x00000800)
#define | SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)
#define | SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)
#define | SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)
#define | SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)
#define | SD_HIGH_CAPACITY ((uint32_t)0x40000000)
#define | SD_STD_CAPACITY ((uint32_t)0x00000000)
#define | SD_CHECK_PATTERN ((uint32_t)0x000001AA)
#define | SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)
#define | SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)
#define | SD_ALLZERO ((uint32_t)0x00000000)
#define | SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)
#define | SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)
#define | SD_CARD_LOCKED ((uint32_t)0x02000000)
#define | SD_CARD_PROGRAMMING ((uint32_t)0x00000007)
#define | SD_CARD_RECEIVING ((uint32_t)0x00000006)
#define | SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SD_0TO7BITS ((uint32_t)0x000000FF)
#define | SD_8TO15BITS ((uint32_t)0x0000FF00)
#define | SD_16TO23BITS ((uint32_t)0x00FF0000)
#define | SD_24TO31BITS ((uint32_t)0xFF000000)
#define | SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)
#define | SD_HALFFIFO ((uint32_t)0x00000008)
#define | SD_HALFFIFOBYTES ((uint32_t)0x00000020)
#define | SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)
#define | SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)
#define | SD_CCCC_ERASE ((uint32_t)0x00000020)
#define | SDIO_SEND_IF_COND ((uint32_t)0x00000008)
#define | EXT_CSD_Command_set 0x0
#define | EXT_CSD_Set_bit 0x1
#define | EXT_CSD_Clear_byte 0x2
#define | EXT_CSD_Write_byte 0x3
#define | EXT_CSD_CMD_SET_NORMAL (1<<0)
#define | EXT_CSD_CMD_SET_SECURE (1<<1)
#define | EXT_CSD_CMD_SET_CPSECURE (1<<2)
#define | EXT_CSD_BUS_WIDTH 183
#define | EXT_CSD_HS_TIMING 185
#define | SDIO_INTR_STS_WRITE_MASK
#define | SDIO_INTR_STS_READ_MASK

Enumerations

enum sd_data_transfer_mode_type {
SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 , SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 ,
SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 , SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1
}
enum sd_error_status_type {
SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 , SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 ,
SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 , SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 ,
SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 , SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 ,
SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 , SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 ,
SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 , SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 ,
SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 , SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 ,
SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 , SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 ,
SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 , SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 ,
SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR , SD_NOT_CONFIGURED , SD_REQ_PENDING ,
SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER , SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW ,
SD_ERROR , SD_OK = 0 , SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 ,
SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 , SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 ,
SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 , SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 ,
SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 , SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 ,
SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 , SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 ,
SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 , SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 ,
SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 , SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 ,
SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 , SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 ,
SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 , SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR ,
SD_NOT_CONFIGURED , SD_REQ_PENDING , SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER ,
SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW , SD_ERROR , SD_OK = 0 ,
SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 , SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 ,
SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 , SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 ,
SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 , SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 ,
SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 , SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 ,
SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 , SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 ,
SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 , SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 ,
SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 , SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 ,
SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 , SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 ,
SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR , SD_NOT_CONFIGURED , SD_REQ_PENDING ,
SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER , SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW ,
SD_ERROR , SD_OK = 0 , SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 ,
SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 , SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 ,
SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 , SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 ,
SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 , SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 ,
SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 , SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 ,
SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 , SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 ,
SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 , SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 ,
SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 , SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 ,
SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 , SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR ,
SD_NOT_CONFIGURED , SD_REQ_PENDING , SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER ,
SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW , SD_ERROR , SD_OK = 0
}
enum sd_card_state_type {
SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) ,
SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) ,
SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) ,
SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) ,
SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) ,
SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) ,
SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) ,
SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) ,
SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF)
}
enum sd_memory_card_type {
SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 ,
SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 ,
SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 ,
SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 ,
SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 ,
SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 ,
SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 ,
SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 ,
SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8
}

Functions

sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clkdiv)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...

Variables

sd_card_info_struct_type sd_card_info

Detailed Description

this file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library.

Version
v2.0.9
Date
2022-06-28
        Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h.


AT32F435/437 Firmwary Library: at32_sdio.h Source File

  • at_start_f435
  • examples
  • sdio
  • sd_mmc_card
  • inc
at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h
Go to the documentation of this file.
1
28/* define to prevent recursive inclusion -------------------------------------*/
29#ifndef __AT32_SDIO_H
30#define __AT32_SDIO_H
31
32#ifdef __cplusplus
33extern "C" {
34#endif
35
36/* includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
51#define SDIOx SDIO1
52#define DMAMUX_SDIOx DMAMUX_DMAREQ_ID_SDIO1
53
65typedef enum
66{
67 SD_TRANSFER_POLLING_MODE = 0,
68 SD_TRANSFER_DMA_MODE = 1
69} sd_data_transfer_mode_type;
70
74typedef enum
75{
76 /* sdio specific error defines ------------------------------------------*/
77 SD_CMD_FAIL = 1,
78 SD_DATA_FAIL = 2,
79 SD_CMD_RSP_TIMEOUT = 3,
80 SD_DATA_TIMEOUT = 4,
81 SD_TX_UNDERRUN = 5,
82 SD_RX_OVERRUN = 6,
83 SD_START_BIT_ERR = 7,
84 SD_CMD_OUT_OF_RANGE = 8,
85 SD_ADDR_MISALIGNED = 9,
86 SD_BLK_LEN_ERR = 10,
87 SD_ERASE_SEQ_ERR = 11,
88 SD_INVALID_ERASE_PARAM = 12,
89 SD_WR_PROTECT_VIOLATION = 13,
90 SD_LOCK_UNLOCK_ERROR = 14,
91 SD_CMD_CRC_ERROR = 15,
92 SD_ILLEGAL_CMD = 16,
93 SD_CARD_ECC_ERROR = 17,
94 SD_CARD_CONTROLLER_ERR = 18,
95 SD_GENERAL_UNKNOWN_ERROR = 19,
96 SD_STREAM_RD_UNDERRUN = 20,
97 SD_STREAM_WR_OVERRUN = 21,
98 SD_CID_CSD_OVERWRITE = 22,
99 SD_WP_ERASE_SKIP = 23,
100 SD_CARD_ECC_DISABLED = 24,
101 SD_ERASE_RESET = 25,
102 SD_AKE_SEQ_ERROR = 26,
103 SD_INVALID_VOLTRANGE = 27,
104 SD_ADDR_OUT_OF_RANGE = 28,
105 SD_SWITCH_ERROR = 29,
106 SD_SDIO_DISABLED = 30,
107 SD_SDIO_FUNC_BUSY = 31,
108 SD_SDIO_FUNC_ERROR = 32,
109 SD_SDIO_UNKNOWN_FUNC = 33,
111 /* standard error defines --------------------------------------------*/
112 SD_INTERNAL_ERROR,
113 SD_NOT_CONFIGURED,
114 SD_REQ_PENDING,
115 SD_REQ_NOT_APPLICABLE,
116 SD_INVALID_PARAMETER,
117 SD_UNSUPPORTED_FEATURE,
118 SD_UNSUPPORTED_HW,
119 SD_ERROR,
120 SD_OK = 0
121} sd_error_status_type;
122
126typedef struct
127{
128 uint8_t csd_struct;
129 uint8_t spec_version;
130 uint8_t reserved1;
131 uint8_t taac;
132 uint8_t nsac;
133 uint8_t max_bus_clk_freq;
134 uint16_t card_cmd_classes;
135 uint8_t max_read_blk_length;
136 uint8_t part_blk_read;
137 uint8_t write_blk_misalign;
138 uint8_t read_blk_misalign;
139 uint8_t dsr_implemented;
140 uint8_t reserved2;
141 uint32_t device_size;
142 uint8_t max_read_current_vdd_min;
143 uint8_t max_read_current_vdd_max;
144 uint8_t max_write_current_vdd_min;
145 uint8_t max_write_current_vdd_max;
146 uint8_t device_size_mult;
147 uint8_t erase_group_size;
148 uint8_t erase_group_size_mult;
149 uint8_t write_protect_group_size;
150 uint8_t write_protect_group_enable;
151 uint8_t manufacturer_default_ecc;
152 uint8_t write_speed_factor;
153 uint8_t max_write_blk_length;
154 uint8_t part_blk_write;
155 uint8_t reserved3;
156 uint8_t content_protect_app;
157 uint8_t file_format_group;
158 uint8_t copy_flag;
159 uint8_t permanent_write_protect;
160 uint8_t temp_write_protect;
161 uint8_t file_formart;
162 uint8_t ecc_code;
163 uint8_t csd_crc;
164 uint8_t reserved4;
165} sd_csd_struct_type;
166
170typedef struct
171{
172 uint8_t manufacturer_id;
173 uint16_t oem_app_id;
174 uint32_t product_name1;
175 uint8_t product_name2;
176 uint8_t product_reversion;
177 uint32_t product_sn;
178 uint8_t reserved1;
179 uint16_t manufact_date;
180 uint8_t cid_crc;
181 uint8_t reserved2;
182} sd_cid_struct_type;
183
187typedef enum
188{
189 SD_CARD_READY = ((uint32_t)0x00000001),
190 SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002),
191 SD_CARD_STANDBY = ((uint32_t)0x00000003),
192 SD_CARD_TRANSFER = ((uint32_t)0x00000004),
193 SD_CARD_SENDING = ((uint32_t)0x00000005),
194 SD_CARD_RECEIVING = ((uint32_t)0x00000006),
195 SD_CARD_PROGRAMMING = ((uint32_t)0x00000007),
196 SD_CARD_DISCONNECTED = ((uint32_t)0x00000008),
197 SD_CARD_ERROR = ((uint32_t)0x000000FF)
198} sd_card_state_type;
199
203typedef enum
204{
205 SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0,
206 SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1,
207 SDIO_HIGH_CAPACITY_SD_CARD = 2,
208 SDIO_MULTIMEDIA_CARD = 3,
209 SDIO_SECURE_DIGITAL_IO_CARD = 4,
210 SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5,
211 SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6,
212 SDIO_HIGH_CAPACITY_MMC_CARD = 7,
213 SDIO_SDIO_CARD = 8
214} sd_memory_card_type;
215
219typedef struct
220{
221 uint32_t sd_spec :4; /* [59:56] */
222 uint32_t scr_structure :4; /* [60:63] */
223 uint32_t sd_bus_width :4; /* [51:48] */
224 uint32_t sd_security :3; /* [52:54] */
225 uint32_t data_stat_after_erase :1; /* [55:55] */
226 uint32_t reserved1 :7; /* [46:40] */
227 uint32_t sd_spec3 :1; /* [47:47] */
228 uint32_t cmd20_support :1; /* [32:32] */
229 uint32_t cmd23_support :1; /* [33:33] */
230 uint32_t reserverd2 :6; /* [34:39] */
231 uint32_t reserverd3; /* [31:0] */
232} sd_scr_struct_type;
233
237typedef struct
238{
239 sd_csd_struct_type sd_csd_reg;
240 sd_cid_struct_type sd_cid_reg;
241 sd_scr_struct_type sd_scr_reg;
242 long long card_capacity;
243 uint32_t card_blk_size;
244 uint16_t rca;
245 uint8_t card_type;
246} sd_card_info_struct_type;
247
248extern sd_card_info_struct_type sd_card_info;
249
261#define SD_CMD_GO_IDLE_STATE ((uint8_t)0)
262#define SD_CMD_SEND_OP_COND ((uint8_t)1)
263#define SD_CMD_ALL_SEND_CID ((uint8_t)2)
264#define SD_CMD_SET_REL_ADDR ((uint8_t)3)
265#define SD_CMD_SET_DSR ((uint8_t)4)
266#define SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)
267#define SD_CMD_HS_SWITCH ((uint8_t)6)
268#define SD_CMD_SEL_DESEL_CARD ((uint8_t)7)
269#define SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)
270#define SD_CMD_SEND_CSD ((uint8_t)9)
271#define SD_CMD_SEND_CID ((uint8_t)10)
272#define SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)
273#define SD_CMD_STOP_TRANSMISSION ((uint8_t)12)
274#define SD_CMD_SEND_STATUS ((uint8_t)13)
275#define SD_CMD_HS_BUSTEST_READ ((uint8_t)14)
276#define SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)
277#define SD_CMD_SET_BLOCKLEN ((uint8_t)16)
278#define SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)
279#define SD_CMD_READ_MULT_BLOCK ((uint8_t)18)
280#define SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)
281#define SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)
282#define SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)
283#define SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)
284#define SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)
285#define SD_CMD_PROG_CID ((uint8_t)26)
286#define SD_CMD_PROG_CSD ((uint8_t)27)
287#define SD_CMD_SET_WRITE_PROT ((uint8_t)28)
288#define SD_CMD_CLR_WRITE_PROT ((uint8_t)29)
289#define SD_CMD_SEND_WRITE_PROT ((uint8_t)30)
290#define SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)
291#define SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)
292#define SD_CMD_ERASE_GRP_START ((uint8_t)35)
293#define SD_CMD_ERASE_GRP_END ((uint8_t)36)
294#define SD_CMD_ERASE ((uint8_t)38)
295#define SD_CMD_FAST_IO ((uint8_t)39)
296#define SD_CMD_GO_IRQ_STATE ((uint8_t)40)
297#define SD_CMD_LOCK_UNLOCK ((uint8_t)42)
298#define SD_CMD_APP_CMD ((uint8_t)55)
299#define SD_CMD_GEN_CMD ((uint8_t)56)
300#define SD_CMD_NO_CMD ((uint8_t)64)
301
306#define SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)
307#define SD_CMD_SD_APP_STAUS ((uint8_t)13)
308#define SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)
309#define SD_CMD_SD_APP_OP_COND ((uint8_t)41)
310#define SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)
311#define SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)
312#define SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)
313#define SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)
314
319#define SD_CMD_SD_APP_GET_MKB ((uint8_t)43)
320#define SD_CMD_SD_APP_GET_MID ((uint8_t)44)
321#define SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)
322#define SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)
323#define SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)
324#define SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)
325#define SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)
326#define SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)
327#define SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)
328#define SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)
329#define SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)
330
342#define NULL 0
343#define SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)
344#define SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)
345#define SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
346#define SDIO_FIFO_Address ((uint32_t)0x40018080)
347
359#define SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)
360#define SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)
361#define SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)
362#define SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)
363#define SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)
364#define SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)
365#define SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)
366#define SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)
367#define SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)
368#define SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)
369#define SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)
370#define SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)
371#define SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)
372#define SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)
373#define SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)
374#define SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)
375#define SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)
376#define SD_OCR_ERASE_RESET ((uint32_t)0x00002000)
377#define MMC_SWITCH_ERROR ((uint32_t)0x00000080)
378#define SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)
379#define SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)
380
384#define SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)
385#define SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)
386#define SD_R5_ERROR ((uint32_t)0x00000800)
387
391#define SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)
392#define SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)
393#define SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)
394#define SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)
395#define SD_HIGH_CAPACITY ((uint32_t)0x40000000)
396#define SD_STD_CAPACITY ((uint32_t)0x00000000)
397#define SD_CHECK_PATTERN ((uint32_t)0x000001AA)
398#define SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)
399#define SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)
400#define SD_ALLZERO ((uint32_t)0x00000000)
401#define SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)
402#define SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)
403#define SD_CARD_LOCKED ((uint32_t)0x02000000)
404#define SD_CARD_PROGRAMMING ((uint32_t)0x00000007)
405#define SD_CARD_RECEIVING ((uint32_t)0x00000006)
406#define SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
407#define SD_0TO7BITS ((uint32_t)0x000000FF)
408#define SD_8TO15BITS ((uint32_t)0x0000FF00)
409#define SD_16TO23BITS ((uint32_t)0x00FF0000)
410#define SD_24TO31BITS ((uint32_t)0xFF000000)
411#define SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)
412#define SD_HALFFIFO ((uint32_t)0x00000008)
413#define SD_HALFFIFOBYTES ((uint32_t)0x00000020)
414
426#define SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)
427#define SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)
428#define SD_CCCC_ERASE ((uint32_t)0x00000020)
429
441#define SDIO_SEND_IF_COND ((uint32_t)0x00000008)
442
454#define EXT_CSD_Command_set 0x0
455#define EXT_CSD_Set_bit 0x1
456#define EXT_CSD_Clear_byte 0x2
457#define EXT_CSD_Write_byte 0x3
458
459#define EXT_CSD_CMD_SET_NORMAL (1<<0)
460#define EXT_CSD_CMD_SET_SECURE (1<<1)
461#define EXT_CSD_CMD_SET_CPSECURE (1<<2)
462
466#define EXT_CSD_BUS_WIDTH 183
467#define EXT_CSD_HS_TIMING 185
468
477#define SDIO_INTR_STS_WRITE_MASK (SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_TXERRU_FLAG | \
478 SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
479#define SDIO_INTR_STS_READ_MASK (SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_RXERRO_FLAG | \
480 SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
489/* sd exported functions ----------------------------------------*/
490 sd_error_status_type sd_init(void);
491void sdio_clock_set(uint32_t clkdiv);
492 sd_error_status_type sd_power_on(void);
493 sd_error_status_type sd_power_off(void);
494 sd_error_status_type sd_card_init(void);
495 sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info);
496 sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode);
497 sd_error_status_type sd_device_mode_set(uint32_t mode);
498 sd_error_status_type sd_deselect_select(uint32_t addr);
499 sd_error_status_type sd_status_send(uint32_t *p_card_status);
500 sd_card_state_type sd_state_get(void);
501 sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks);
502 sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size);
503 sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks);
504 sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size);
505 sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks);
506 sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len);
507 sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len);
508 sd_error_status_type sd_irq_service(void);
509void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir);
510
523#ifdef __cplusplus
524}
525#endif
526
527#endif /* __AT32_SDIO_H */
528
at32f435_437.h
at32f435_437 header file
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f435_437_dma.h:151
sd_power_off
sd_error_status_type sd_power_off(void)
turns the sdio output signals off.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:403
sd_irq_service
sd_error_status_type sd_irq_service(void)
allows to process all the interrupts that are high.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1789
sd_device_mode_set
sd_error_status_type sd_device_mode_set(uint32_t mode)
set sdio work mode.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:786
sd_card_info_get
sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info)
returns information about specific card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:532
mmc_stream_write
sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1700
sd_card_init
sd_error_status_type sd_card_init(void)
intialises all cards or single card as the case may be card(s) come into standby state.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:417
sd_block_read
sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma ...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1188
sd_deselect_select
sd_error_status_type sd_deselect_select(uint32_t addr)
selects od deselects the corresponding card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:807
sdio_clock_set
void sdio_clock_set(uint32_t clkdiv)
set sdio clock devision factor.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:188
sd_blocks_erase
sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks)
erase continuous data block
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1030
sd_mult_blocks_write
sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed ...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1489
sd_state_get
sd_card_state_type sd_state_get(void)
returns information about sd card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:2489
sd_dma_config
void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:2706
sd_block_write
sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be manag...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1367
sd_status_send
sd_error_status_type sd_status_send(uint32_t *p_card_status)
read current card status.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:2452
sd_init
sd_error_status_type sd_init(void)
initializes the sd card and put it into standby state (ready for data transfer).
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:72
mmc_stream_read
sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1653
sd_power_on
sd_error_status_type sd_power_on(void)
enquires cards about their operating voltage and configures clock controls.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:203
sd_mult_blocks_read
sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mod...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1277
sd_wide_bus_operation_config
sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:743
sd_card_info
sd_card_info_struct_type sd_card_info
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:48
sd_data_transfer_mode_type
sd_data_transfer_mode_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:66
sd_error_status_type
sd_error_status_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:75
sd_card_state_type
sd_card_state_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:188
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f435_437_sdio.h:139
sd_memory_card_type
sd_memory_card_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:204
SD_TRANSFER_DMA_MODE
@ SD_TRANSFER_DMA_MODE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:68
SD_TRANSFER_POLLING_MODE
@ SD_TRANSFER_POLLING_MODE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:67
SD_ERROR
@ SD_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:119
SD_WP_ERASE_SKIP
@ SD_WP_ERASE_SKIP
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:99
SD_SDIO_UNKNOWN_FUNC
@ SD_SDIO_UNKNOWN_FUNC
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:109
SD_DATA_FAIL
@ SD_DATA_FAIL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:78
SD_STREAM_WR_OVERRUN
@ SD_STREAM_WR_OVERRUN
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:97
SD_INVALID_PARAMETER
@ SD_INVALID_PARAMETER
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:116
SD_CMD_FAIL
@ SD_CMD_FAIL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:77
SD_CMD_OUT_OF_RANGE
@ SD_CMD_OUT_OF_RANGE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:84
SD_UNSUPPORTED_HW
@ SD_UNSUPPORTED_HW
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:118
SD_SDIO_FUNC_ERROR
@ SD_SDIO_FUNC_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:108
SD_INTERNAL_ERROR
@ SD_INTERNAL_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:112
SD_INVALID_ERASE_PARAM
@ SD_INVALID_ERASE_PARAM
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:88
SD_GENERAL_UNKNOWN_ERROR
@ SD_GENERAL_UNKNOWN_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:95
SD_CARD_ECC_DISABLED
@ SD_CARD_ECC_DISABLED
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:100
SD_CARD_CONTROLLER_ERR
@ SD_CARD_CONTROLLER_ERR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:94
SD_ERASE_RESET
@ SD_ERASE_RESET
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:101
SD_CARD_ECC_ERROR
@ SD_CARD_ECC_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:93
SD_STREAM_RD_UNDERRUN
@ SD_STREAM_RD_UNDERRUN
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:96
SD_UNSUPPORTED_FEATURE
@ SD_UNSUPPORTED_FEATURE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:117
SD_TX_UNDERRUN
@ SD_TX_UNDERRUN
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:81
SD_ILLEGAL_CMD
@ SD_ILLEGAL_CMD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:92
SD_SDIO_FUNC_BUSY
@ SD_SDIO_FUNC_BUSY
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:107
SD_CMD_CRC_ERROR
@ SD_CMD_CRC_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:91
SD_ADDR_OUT_OF_RANGE
@ SD_ADDR_OUT_OF_RANGE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:104
SD_RX_OVERRUN
@ SD_RX_OVERRUN
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:82
SD_REQ_PENDING
@ SD_REQ_PENDING
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:114
SD_REQ_NOT_APPLICABLE
@ SD_REQ_NOT_APPLICABLE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:115
SD_SWITCH_ERROR
@ SD_SWITCH_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:105
SD_INVALID_VOLTRANGE
@ SD_INVALID_VOLTRANGE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:103
SD_SDIO_DISABLED
@ SD_SDIO_DISABLED
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:106
SD_DATA_TIMEOUT
@ SD_DATA_TIMEOUT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:80
SD_ADDR_MISALIGNED
@ SD_ADDR_MISALIGNED
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:85
SD_START_BIT_ERR
@ SD_START_BIT_ERR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:83
SD_LOCK_UNLOCK_ERROR
@ SD_LOCK_UNLOCK_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:90
SD_NOT_CONFIGURED
@ SD_NOT_CONFIGURED
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:113
SD_CID_CSD_OVERWRITE
@ SD_CID_CSD_OVERWRITE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:98
SD_WR_PROTECT_VIOLATION
@ SD_WR_PROTECT_VIOLATION
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:89
SD_CMD_RSP_TIMEOUT
@ SD_CMD_RSP_TIMEOUT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:79
SD_BLK_LEN_ERR
@ SD_BLK_LEN_ERR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:86
SD_OK
@ SD_OK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:120
SD_ERASE_SEQ_ERR
@ SD_ERASE_SEQ_ERR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:87
SD_AKE_SEQ_ERROR
@ SD_AKE_SEQ_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:102
SD_CARD_TRANSFER
@ SD_CARD_TRANSFER
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:192
SD_CARD_IDENTIFICATION
@ SD_CARD_IDENTIFICATION
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:190
SD_CARD_SENDING
@ SD_CARD_SENDING
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:193
SD_CARD_STANDBY
@ SD_CARD_STANDBY
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:191
SD_CARD_READY
@ SD_CARD_READY
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:189
SD_CARD_DISCONNECTED
@ SD_CARD_DISCONNECTED
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:196
SD_CARD_ERROR
@ SD_CARD_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:197
SDIO_SDIO_CARD
@ SDIO_SDIO_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:213
SDIO_HIGH_CAPACITY_SD_CARD
@ SDIO_HIGH_CAPACITY_SD_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:207
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
@ SDIO_SECURE_DIGITAL_IO_COMBO_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:211
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
@ SDIO_HIGH_SPEED_MULTIMEDIA_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:210
SDIO_STD_CAPACITY_SD_CARD_V1_1
@ SDIO_STD_CAPACITY_SD_CARD_V1_1
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:205
SDIO_SECURE_DIGITAL_IO_CARD
@ SDIO_SECURE_DIGITAL_IO_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:209
SDIO_STD_CAPACITY_SD_CARD_V2_0
@ SDIO_STD_CAPACITY_SD_CARD_V2_0
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:206
SDIO_MULTIMEDIA_CARD
@ SDIO_MULTIMEDIA_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:208
SDIO_HIGH_CAPACITY_MMC_CARD
@ SDIO_HIGH_CAPACITY_MMC_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:212
SD_CARD_RECEIVING
#define SD_CARD_RECEIVING
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:405
SD_CARD_PROGRAMMING
#define SD_CARD_PROGRAMMING
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:404
sd_card_info_struct_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:238
sd_card_info_struct_type::sd_scr_reg
sd_scr_struct_type sd_scr_reg
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:241
sd_card_info_struct_type::card_capacity
long long card_capacity
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:242
sd_card_info_struct_type::sd_cid_reg
sd_cid_struct_type sd_cid_reg
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:240
sd_card_info_struct_type::sd_csd_reg
sd_csd_struct_type sd_csd_reg
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:239
sd_card_info_struct_type::card_blk_size
uint32_t card_blk_size
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:243
sd_card_info_struct_type::rca
uint16_t rca
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:244
sd_card_info_struct_type::card_type
uint8_t card_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:245
sd_cid_struct_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:171
sd_cid_struct_type::reserved1
uint8_t reserved1
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:178
sd_cid_struct_type::product_name2
uint8_t product_name2
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:175
sd_cid_struct_type::manufact_date
uint16_t manufact_date
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:179
sd_cid_struct_type::cid_crc
uint8_t cid_crc
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:180
sd_cid_struct_type::product_reversion
uint8_t product_reversion
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:176
sd_cid_struct_type::manufacturer_id
uint8_t manufacturer_id
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:172
sd_cid_struct_type::product_sn
uint32_t product_sn
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:177
sd_cid_struct_type::product_name1
uint32_t product_name1
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:174
sd_cid_struct_type::reserved2
uint8_t reserved2
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:181
sd_cid_struct_type::oem_app_id
uint16_t oem_app_id
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:173
sd_csd_struct_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:127
sd_csd_struct_type::spec_version
uint8_t spec_version
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:129
sd_csd_struct_type::max_write_current_vdd_max
uint8_t max_write_current_vdd_max
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:145
sd_csd_struct_type::nsac
uint8_t nsac
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:132
sd_csd_struct_type::card_cmd_classes
uint16_t card_cmd_classes
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:134
sd_csd_struct_type::part_blk_read
uint8_t part_blk_read
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:136
sd_csd_struct_type::read_blk_misalign
uint8_t read_blk_misalign
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:138
sd_csd_struct_type::content_protect_app
uint8_t content_protect_app
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:156
sd_csd_struct_type::write_speed_factor
uint8_t write_speed_factor
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:152
sd_csd_struct_type::max_read_blk_length
uint8_t max_read_blk_length
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:135
sd_csd_struct_type::max_bus_clk_freq
uint8_t max_bus_clk_freq
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:133
sd_csd_struct_type::ecc_code
uint8_t ecc_code
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:162
sd_csd_struct_type::reserved4
uint8_t reserved4
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:164
sd_csd_struct_type::dsr_implemented
uint8_t dsr_implemented
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:139
sd_csd_struct_type::max_read_current_vdd_min
uint8_t max_read_current_vdd_min
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:142
sd_csd_struct_type::reserved2
uint8_t reserved2
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:140
sd_csd_struct_type::erase_group_size_mult
uint8_t erase_group_size_mult
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:148
sd_csd_struct_type::file_formart
uint8_t file_formart
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:161
sd_csd_struct_type::temp_write_protect
uint8_t temp_write_protect
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:160
sd_csd_struct_type::permanent_write_protect
uint8_t permanent_write_protect
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:159
sd_csd_struct_type::max_read_current_vdd_max
uint8_t max_read_current_vdd_max
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:143
sd_csd_struct_type::file_format_group
uint8_t file_format_group
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:157
sd_csd_struct_type::device_size
uint32_t device_size
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:141
sd_csd_struct_type::write_blk_misalign
uint8_t write_blk_misalign
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:137
sd_csd_struct_type::csd_struct
uint8_t csd_struct
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:128
sd_csd_struct_type::write_protect_group_enable
uint8_t write_protect_group_enable
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:150
sd_csd_struct_type::max_write_current_vdd_min
uint8_t max_write_current_vdd_min
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:144
sd_csd_struct_type::reserved1
uint8_t reserved1
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:130
sd_csd_struct_type::max_write_blk_length
uint8_t max_write_blk_length
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:153
sd_csd_struct_type::csd_crc
uint8_t csd_crc
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:163
sd_csd_struct_type::write_protect_group_size
uint8_t write_protect_group_size
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:149
sd_csd_struct_type::reserved3
uint8_t reserved3
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:155
sd_csd_struct_type::taac
uint8_t taac
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:131
sd_csd_struct_type::manufacturer_default_ecc
uint8_t manufacturer_default_ecc
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:151
sd_csd_struct_type::part_blk_write
uint8_t part_blk_write
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:154
sd_csd_struct_type::copy_flag
uint8_t copy_flag
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:158
sd_csd_struct_type::erase_group_size
uint8_t erase_group_size
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:147
sd_csd_struct_type::device_size_mult
uint8_t device_size_mult
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:146
sd_scr_struct_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:220
sd_scr_struct_type::cmd20_support
uint32_t cmd20_support
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:228
sd_scr_struct_type::sd_bus_width
uint32_t sd_bus_width
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:223
sd_scr_struct_type::reserverd3
uint32_t reserverd3
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:231
sd_scr_struct_type::cmd23_support
uint32_t cmd23_support
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:229
sd_scr_struct_type::sd_spec3
uint32_t sd_spec3
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:227
sd_scr_struct_type::data_stat_after_erase
uint32_t data_stat_after_erase
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:225
sd_scr_struct_type::reserved1
uint32_t reserved1
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:226
sd_scr_struct_type::scr_structure
uint32_t scr_structure
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:222
sd_scr_struct_type::sd_security
uint32_t sd_security
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:224
sd_scr_struct_type::sd_spec
uint32_t sd_spec
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:221
sd_scr_struct_type::reserverd2
uint32_t reserverd2
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:230


AT32F435/437 Firmwary Library: at32_sdio.c File Reference

  • at_start_f435
  • examples
  • sdio
  • sd_mmc_card
  • src
Functions | Variables
at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c File Reference

this file provides a set of functions needed to manage the sdio/mmc card memory. More...

#include "at32_sdio.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

sd_error_status_type | command_error (void)
checks for error conditions for cmd0. More...
sd_error_status_type | command_rsp1_error (uint8_t cmd)
checks for error conditions for R1 response. More...
sd_error_status_type | command_rsp2_error (void)
checks for error conditions for R2 (cid or csd) response. More...
sd_error_status_type | command_rsp3_error (void)
checks for error conditions for R3 (ocr) response. More...
sd_error_status_type | command_rsp4_error (uint8_t cmd)
checks for error conditions for r4 response. More...
sd_error_status_type | command_rsp5_error (uint8_t cmd)
checks for error conditions for r5 response. More...
sd_error_status_type | command_rsp6_error (uint8_t cmd, uint16_t *prca)
checks for error conditions for r6 (rca) response. More...
sd_error_status_type | command_rsp7_error (void)
checks for error conditions for R7 response. More...
sd_error_status_type | sd_bus_wide_enable (confirm_state new_state)
enable or disable the sdio wide bus mode. More...
sd_error_status_type | mmc_switch (uint8_t set, uint8_t index, uint8_t value)
switch mmc card speed to high speed More...
sd_error_status_type | sd_switch (uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
switch sd card speed to high speed More...
sd_error_status_type | check_card_programming (uint8_t *p_status)
checks if the sd card is in programming state. More...
sd_error_status_type | speed_change (uint8_t speed)
set bus speed More...
sd_error_status_type | scr_find (void)
find the sd card scr register value. More...
uint8_t | convert_from_bytes_to_power_of_two (uint16_t number_of_bytes)
converts the number of bytes in power of two and returns the power. More...
sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clk_div)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sdio_command_data_send (sdio_command_struct_type *sdio_cmd_init_t, sdio_data_struct_type *sdio_data_init_t, uint32_t *buf)
read data from or write data to sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
void | SDIO1_IRQHandler (void)
sdio1 isr. More...
void | SDIO2_IRQHandler (void)
sdio2 isr. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...

Variables

sdio_command_struct_type sdio_command_init_struct
sdio_data_struct_type sdio_data_init_struct
static sd_memory_card_type | card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1
static uint32_t | csd_table [4]
static uint32_t | cid_table [4]
static uint32_t | rca = 0
static sd_data_transfer_mode_type | device_mode = SD_TRANSFER_POLLING_MODE
static uint8_t | stop_flag = 0
volatile sd_error_status_type | transfer_error = SD_OK
volatile uint8_t | transfer_end = 0
sd_card_info_struct_type sd_card_info

Detailed Description

this file provides a set of functions needed to manage the sdio/mmc card memory.

Version
v2.0.9
Date
2022-06-28
        Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c.


AT32F435/437 Firmwary Library: at32_sdio.c Source File

  • at_start_f435
  • examples
  • sdio
  • sd_mmc_card
  • src
at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c
Go to the documentation of this file.
1
28#include "at32_sdio.h"
29#include "at32f435_437_board.h"
30
39 sdio_command_struct_type sdio_command_init_struct;
40 sdio_data_struct_type sdio_data_init_struct;
41
42static sd_memory_card_type card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1; /* sd card type */
43static uint32_t csd_table[4], cid_table[4], rca = 0; /* csd, sid, rca */
44static sd_data_transfer_mode_type device_mode = SD_TRANSFER_POLLING_MODE; /* working mode */
45static uint8_t stop_flag = 0; /* transmit stop flag */
46volatile sd_error_status_type transfer_error = SD_OK; /* transmit error flag */
47volatile uint8_t transfer_end = 0; /* transmit end flag */
48 sd_card_info_struct_type sd_card_info; /* sd card information */
49
50 sd_error_status_type command_error(void);
51 sd_error_status_type command_rsp1_error(uint8_t cmd);
52 sd_error_status_type command_rsp2_error(void);
53 sd_error_status_type command_rsp3_error(void);
54 sd_error_status_type command_rsp4_error(uint8_t cmd);
55 sd_error_status_type command_rsp5_error(uint8_t cmd);
56 sd_error_status_type command_rsp6_error(uint8_t cmd, uint16_t *p_rca);
57 sd_error_status_type command_rsp7_error(void);
58 sd_error_status_type sd_bus_wide_enable(confirm_state new_state);
59 sd_error_status_type mmc_switch(uint8_t set, uint8_t index, uint8_t value);
60 sd_error_status_type sd_switch(uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp);
61 sd_error_status_type check_card_programming(uint8_t *p_status);
62 sd_error_status_type speed_change(uint8_t speed);
63 sd_error_status_type scr_find(void);
64uint8_t convert_from_bytes_to_power_of_two(uint16_t number_of_bytes);
65
72 sd_error_status_type sd_init(void)
73{
74 uint16_t clkdiv = 0;
75 sd_error_status_type status = SD_OK;
76 gpio_init_type gpio_init_struct = {0};
77 uint8_t retry = 0;
78
79 /* gpioc and gpiod periph clock enable */
80 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
81 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
82
83 /* sdio periph clock enable */
84 crm_periph_clock_enable(CRM_SDIO1_PERIPH_CLOCK, TRUE);
85
86 /* configure pc.08, pc.09, pc.10, pc.11, pc.12 pin: d0, d1, d2, d3, clk pin */
87 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
88 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
89 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
90 gpio_init_struct.gpio_pins = GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11 | GPIO_PINS_12;
91 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
92 gpio_init(GPIOC, &gpio_init_struct);
93
94 /* configure pd.02 cmd line */
95 gpio_init_struct.gpio_pins = GPIO_PINS_2;
96 gpio_init(GPIOD, &gpio_init_struct);
97
98 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE8, GPIO_MUX_12);
99 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE9, GPIO_MUX_12);
100 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE10, GPIO_MUX_12);
101 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE11, GPIO_MUX_12);
102 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE12, GPIO_MUX_12);
103 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE2, GPIO_MUX_12);
104
105 retry = 3;
106 while(retry--){
107 /* reset sdio */
108 sdio_reset(SDIOx);
109 /* power on */
110 status = sd_power_on();
111
112 if(status == SD_OK)
113 break;
114 }
115
116 if(status == SD_OK)
117 {
118 /* sdio card initialize */
119 status = sd_card_init();
120 }
121
122 if(status == SD_OK)
123 {
124 /* get card information*/
125 status = sd_card_info_get(&sd_card_info);
126 }
127
128 if((SDIO_MULTIMEDIA_CARD == card_type) && (sd_card_info.sd_csd_reg.spec_version >= 4))
129 {
130 card_type = SDIO_HIGH_SPEED_MULTIMEDIA_CARD;
131 }
132
133 if(status == SD_OK)
134 {
135 /* select card */
136 status = sd_deselect_select((uint32_t)(sd_card_info.rca << 16));
137 }
138
139 if(status == SD_OK && ((SDIO_STD_CAPACITY_SD_CARD_V1_1 == card_type) || (SDIO_STD_CAPACITY_SD_CARD_V2_0 == card_type) || \
140 (SDIO_SECURE_DIGITAL_IO_COMBO_CARD == card_type) || (SDIO_HIGH_CAPACITY_SD_CARD == card_type)))
141 {
142 status = scr_find();
143 }
144
145 if(status == SD_OK)
146 {
147 /* set normal speed */
148 status = speed_change(0);
149 }
150
151 if((status == SD_OK) || (card_type == SDIO_MULTIMEDIA_CARD))
152 {
153 if(sd_card_info.card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1 || sd_card_info.card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0)
154 {
155 /* set sdio_ck to 12mhz */
156 clkdiv = system_core_clock / 12000000;
157
158 if(clkdiv >= 2)
159 {
160 clkdiv -= 2;
161 }
162 }
163 else
164 {
165 /* set sdio_ck to 48mhz */
166 clkdiv = system_core_clock / 48000000;
167
168 if(clkdiv >= 2)
169 {
170 clkdiv -= 2;
171 }
172 }
173 /* set sdio clock divider */
174 sdio_clock_set(clkdiv);
175
176 /* set transfer mode */
177 status = sd_device_mode_set(SD_TRANSFER_DMA_MODE);
178 }
179
180 return status;
181}
182
188void sdio_clock_set(uint32_t clk_div)
189{
190 /* config clock divide [7:0] */
191 SDIOx->clkctrl_bit.clkdiv_l = (clk_div & 0xFF);
192
193 /* config clock divide [9:8] */
194 SDIOx->clkctrl_bit.clkdiv_h = ((clk_div & 0x300) >> 8);
195}
196
203 sd_error_status_type sd_power_on(void)
204{
205 uint8_t retry = 0;
206 sd_error_status_type status = SD_OK;
207 uint32_t response = 0, count = 0, valid_voltage = 0, clk_psc;
208 uint32_t sd_type = SD_STD_CAPACITY;
209
210 /* sdio_ck is less than 400KHz in initialization stage, set to 200KHz */
211 clk_psc = (system_core_clock / 200000) - 2;
212
213 if(clk_psc > 0x3FF)
214 {
215 clk_psc = 0x3FF;
216 }
217
218 /* config sdio clock divide and edge phase */
219 sdio_clock_config(SDIOx, clk_psc, SDIO_CLOCK_EDGE_FALLING);
220 /* config sdio bus width */
221 sdio_bus_width_config(SDIOx, SDIO_BUS_WIDTH_D1);
222 /* disable flow control */
223 sdio_flow_control_enable(SDIOx, FALSE);
224 /* disable clock bypass */
225 sdio_clock_bypass(SDIOx, FALSE);
226 /* disable power saving mode */
227 sdio_power_saving_mode_enable(SDIOx, FALSE);
228
229 /* sdio power on */
230 sdio_power_set(SDIOx, SDIO_POWER_ON);
231 /* enable to output sdio_ck */
232 sdio_clock_enable(SDIOx, TRUE);
233
234 for(retry = 0; retry < 5; retry++)
235 {
236 /* send cmd0, get in idle stage */
237 sdio_command_init_struct.argument = 0x0;
238 sdio_command_init_struct.cmd_index = SD_CMD_GO_IDLE_STATE;
239 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_NO;
240 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
241
242 /* sdio command config */
243 sdio_command_config(SDIOx, &sdio_command_init_struct);
244 /* enable ccsm */
245 sdio_command_state_machine_enable(SDIOx, TRUE);
246
247 /* get command status */
248 status = command_error();
249 }
250
251 /* send cmd8, check card interface feature */
252 sdio_command_init_struct.argument = SD_CHECK_PATTERN;
253 sdio_command_init_struct.cmd_index = SDIO_SEND_IF_COND;
254 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
255 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
256
257 /* sdio command config */
258 sdio_command_config(SDIOx, &sdio_command_init_struct);
259 /* enable ccsm */
260 sdio_command_state_machine_enable(SDIOx, TRUE);
261
262 /* waiting R7 */
263 status = command_rsp7_error();
264
265 if(status == SD_OK)
266 {
267 /* set card type and sd type */
268 card_type = SDIO_STD_CAPACITY_SD_CARD_V2_0;
269 sd_type = SD_HIGH_CAPACITY;
270 }
271
272 /* send cmd55, check sd version */
273 sdio_command_init_struct.argument = 0x00;
274 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
275 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
276 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
277
278 /* sdio command config */
279 sdio_command_config(SDIOx, &sdio_command_init_struct);
280 /* enable ccsm */
281 sdio_command_state_machine_enable(SDIOx, TRUE);
282
283 /* waiting R1 */
284 status = command_rsp1_error(SD_CMD_APP_CMD);
285
286 /* check sd card or mmc card */
287 if(SD_OK == status)
288 {
289 /* send acmd41, check voltage operation range */
290 while((!valid_voltage) && (count < SD_MAX_VOLT_TRIAL))
291 {
292 delay_ms(10);
293
294 /* send cmd55 before acmd41 */
295 sdio_command_init_struct.argument = 0x00;
296 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
297 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
298 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
299
300 /* sdio command config */
301 sdio_command_config(SDIOx, &sdio_command_init_struct);
302 /* enable ccsm */
303 sdio_command_state_machine_enable(SDIOx, TRUE);
304
305 /* waiting R1 */
306 status = command_rsp1_error(SD_CMD_APP_CMD);
307
308 /* if any errors occured, return status */
309 if(status != SD_OK)
310 {
311 return status;
312 }
313
314 /* send acmd41 */
315 sdio_command_init_struct.argument = SD_VOLTAGE_WINDOW_SD | sd_type;
316 sdio_command_init_struct.cmd_index = SD_CMD_SD_APP_OP_COND;
317 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
318 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
319
320 /* sdio command config */
321 sdio_command_config(SDIOx, &sdio_command_init_struct);
322 /* enable ccsm */
323 sdio_command_state_machine_enable(SDIOx, TRUE);
324
325 /* waiting R3 */
326 status = command_rsp3_error();
327
328 /* if any errors occured, return status */
329 if(status != SD_OK)
330 {
331 return status;
332 }
333
334 /* get response1 */
335 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
336
337 /* check sd card power on stage is success or not */
338 valid_voltage = (((response >> 31) == 1) ? 1 : 0);
339 count++;
340 }
341
342 if(count >= SD_MAX_VOLT_TRIAL)
343 {
344 status = SD_INVALID_VOLTRANGE;
345 return status;
346 }
347
348 if(response &= SD_HIGH_CAPACITY)
349 {
350 card_type = SDIO_HIGH_CAPACITY_SD_CARD;
351 }
352 }
353 /* mmc card */
354 else
355 {
356 /* send cmd1 */
357 while((!valid_voltage) && (count < SD_MAX_VOLT_TRIAL))
358 {
359 delay_ms(10);
360
361 sdio_command_init_struct.argument = SD_VOLTAGE_WINDOW_MMC;
362 sdio_command_init_struct.cmd_index = SD_CMD_SEND_OP_COND;
363 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
364 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
365
366 /* sdio command config */
367 sdio_command_config(SDIOx, &sdio_command_init_struct);
368 /* enable ccsm */
369 sdio_command_state_machine_enable(SDIOx, TRUE);
370
371 /* waiting R3 */
372 status = command_rsp3_error();
373
374 if(status != SD_OK)
375 {
376 return status;
377 }
378
379 /* get response1 */
380 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
381
382 valid_voltage = (((response >> 31) == 1) ? 1 : 0);
383 count++;
384 }
385
386 if(count >= SD_MAX_VOLT_TRIAL)
387 {
388 status = SD_INVALID_VOLTRANGE;
389 return status;
390 }
391
392 card_type = SDIO_MULTIMEDIA_CARD;
393 }
394
395 return(status);
396}
397
403 sd_error_status_type sd_power_off(void)
404{
405 /* sdio power off */
406 sdio_power_set(SDIOx, SDIO_POWER_OFF);
407
408 return SD_OK;
409}
410
417 sd_error_status_type sd_card_init(void)
418{
419 sd_error_status_type status = SD_OK;
420 uint16_t rca_temp = 0x01;
421
422 /* check power status */
423 if(SDIO_POWER_OFF == sdio_power_status_get(SDIOx))
424 {
425 return SD_REQ_NOT_APPLICABLE;
426 }
427
428 /* check is secure_digital_io_card or not */
429 if(SDIO_SECURE_DIGITAL_IO_CARD != card_type)
430 {
431 /* send cmd2, get cid register */
432 sdio_command_init_struct.argument = 0x0;
433 sdio_command_init_struct.cmd_index = SD_CMD_ALL_SEND_CID;
434 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_LONG;
435 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
436
437 /* sdio command config */
438 sdio_command_config(SDIOx, &sdio_command_init_struct);
439 /* enable ccsm */
440 sdio_command_state_machine_enable(SDIOx, TRUE);
441
442 status = command_rsp2_error();
443 if(status != SD_OK)
444 {
445 return status;
446 }
447
448 cid_table[0] = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
449 cid_table[1] = sdio_response_get(SDIOx, SDIO_RSP2_INDEX);
450 cid_table[2] = sdio_response_get(SDIOx, SDIO_RSP3_INDEX);
451 cid_table[3] = sdio_response_get(SDIOx, SDIO_RSP4_INDEX);
452 }
453
454 /* check card type */
455 if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || \
456 (card_type == SDIO_SECURE_DIGITAL_IO_COMBO_CARD) || (card_type == SDIO_HIGH_CAPACITY_SD_CARD))
457 {
458 /* send cmd3, get rca */
459 sdio_command_init_struct.argument = 0x00;
460 sdio_command_init_struct.cmd_index = SD_CMD_SET_REL_ADDR;
461 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
462 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
463
464 /* sdio command config */
465 sdio_command_config(SDIOx, &sdio_command_init_struct);
466 /* enable ccsm */
467 sdio_command_state_machine_enable(SDIOx, TRUE);
468
469 status = command_rsp6_error(SD_CMD_SET_REL_ADDR, &rca_temp);
470 if(status != SD_OK)
471 {
472 return status;
473 }
474 }
475
476 /* mmc card */
477 if(card_type == SDIO_MULTIMEDIA_CARD)
478 {
479 /* send cmd3 */
480 sdio_command_init_struct.argument = (uint32_t)(rca_temp << 16);
481 sdio_command_init_struct.cmd_index = SD_CMD_SET_REL_ADDR;
482 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
483 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
484
485 /* sdio command config */
486 sdio_command_config(SDIOx, &sdio_command_init_struct);
487 /* enable ccsm */
488 sdio_command_state_machine_enable(SDIOx, TRUE);
489
490 status = command_rsp2_error();
491 if(status != SD_OK)
492 {
493 return status;
494 }
495 }
496
497 /* check is secure_digital_io_card or not */
498 if(card_type != SDIO_SECURE_DIGITAL_IO_CARD)
499 {
500 rca = rca_temp;
501 sdio_command_init_struct.argument = (uint32_t)(rca << 16);
502 sdio_command_init_struct.cmd_index = SD_CMD_SEND_CSD;
503 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_LONG;
504 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
505
506 /* sdio command config */
507 sdio_command_config(SDIOx, &sdio_command_init_struct);
508 /* enable ccsm */
509 sdio_command_state_machine_enable(SDIOx, TRUE);
510
511 status = command_rsp2_error();
512 if(status != SD_OK)
513 {
514 return status;
515 }
516
517 csd_table[0] = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
518 csd_table[1] = sdio_response_get(SDIOx, SDIO_RSP2_INDEX);
519 csd_table[2] = sdio_response_get(SDIOx, SDIO_RSP3_INDEX);
520 csd_table[3] = sdio_response_get(SDIOx, SDIO_RSP4_INDEX);
521 }
522
523 return SD_OK;
524}
525
532 sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info)
533{
534 sd_error_status_type status = SD_OK;
535 uint8_t tmp = 0;
536
537 card_info->card_type = (uint8_t)card_type;
538 card_info->rca = (uint16_t)rca;
539
540 /* byte 0 */
541 tmp = (uint8_t)((csd_table[0] & 0xFF000000) >> 24);
542 card_info->sd_csd_reg.csd_struct = (tmp & 0xC0) >> 6;
543 card_info->sd_csd_reg.spec_version = (tmp & 0x3C) >> 2;
544 card_info->sd_csd_reg.reserved1 = tmp & 0x03;
545
546 /* byte 1 */
547 tmp = (uint8_t)((csd_table[0] & 0x00FF0000) >> 16);
548 card_info->sd_csd_reg.taac = tmp;
549
550 /* byte 2 */
551 tmp = (uint8_t)((csd_table[0] & 0x0000FF00) >> 8);
552 card_info->sd_csd_reg.nsac = tmp;
553
554 /* byte 3 */
555 tmp = (uint8_t)(csd_table[0] & 0x000000FF);
556 card_info->sd_csd_reg.max_bus_clk_freq = tmp;
557
558 /* byte 4 */
559 tmp = (uint8_t)((csd_table[1] & 0xFF000000) >> 24);
560 card_info->sd_csd_reg.card_cmd_classes = tmp << 4;
561
562 /* byte 5 */
563 tmp = (uint8_t)((csd_table[1] & 0x00FF0000) >> 16);
564 card_info->sd_csd_reg.card_cmd_classes |= (tmp & 0xF0) >> 4;
565 card_info->sd_csd_reg.max_read_blk_length = tmp & 0x0F;
566
567 /* byte 6 */
568 tmp = (uint8_t)((csd_table[1] & 0x0000FF00) >> 8);
569 card_info->sd_csd_reg.part_blk_read = (tmp & 0x80) >> 7;
570 card_info->sd_csd_reg.write_blk_misalign = (tmp & 0x40) >> 6;
571 card_info->sd_csd_reg.read_blk_misalign = (tmp & 0x20) >> 5;
572 card_info->sd_csd_reg.dsr_implemented = (tmp & 0x10) >> 4;
573 card_info->sd_csd_reg.reserved2 = 0; /* reserved */
574
575 if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || (card_type == SDIO_MULTIMEDIA_CARD))
576 {
577 card_info->sd_csd_reg.device_size = (tmp & 0x03) << 10;
578
579 /* byte 7 */
580 tmp = (uint8_t)(csd_table[1] & 0x000000FF);
581 card_info->sd_csd_reg.device_size |= (tmp) << 2;
582
583 /* byte 8 */
584 tmp = (uint8_t)((csd_table[2] & 0xFF000000) >> 24);
585 card_info->sd_csd_reg.device_size |= (tmp & 0xC0) >> 6;
586
587 card_info->sd_csd_reg.max_read_current_vdd_min = (tmp & 0x38) >> 3;
588 card_info->sd_csd_reg.max_read_current_vdd_max = (tmp & 0x07);
589
590 /* byte 9 */
591 tmp = (uint8_t)((csd_table[2] & 0x00FF0000) >> 16);
592 card_info->sd_csd_reg.max_write_current_vdd_min = (tmp & 0xE0) >> 5;
593 card_info->sd_csd_reg.max_write_current_vdd_max = (tmp & 0x1C) >> 2;
594 card_info->sd_csd_reg.device_size_mult = (tmp & 0x03) << 1;
595 /* byte 10 */
596 tmp = (uint8_t)((csd_table[2] & 0x0000FF00) >> 8);
597 card_info->sd_csd_reg.device_size_mult |= (tmp & 0x80) >> 7;
598
599 card_info->card_capacity = (card_info->sd_csd_reg.device_size + 1) ;
600 card_info->card_capacity *= (1 << (card_info->sd_csd_reg.device_size_mult + 2));
601 card_info->card_blk_size = 1 << (card_info->sd_csd_reg.max_read_blk_length);
602 card_info->card_capacity *= card_info->card_blk_size;
603 }
604 else if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
605 {
606 /* byte 7 */
607 tmp = (uint8_t)(csd_table[1] & 0x000000FF);
608 card_info->sd_csd_reg.device_size = (tmp & 0x3F) << 16;
609
610 /* byte 8 */
611 tmp = (uint8_t)((csd_table[2] & 0xFF000000) >> 24);
612
613 card_info->sd_csd_reg.device_size |= (tmp << 8);
614
615 /* byte 9 */
616 tmp = (uint8_t)((csd_table[2] & 0x00FF0000) >> 16);
617
618 card_info->sd_csd_reg.device_size |= (tmp);
619
620 /* byte 10 */
621 tmp = (uint8_t)((csd_table[2] & 0x0000FF00) >> 8);
622
623 card_info->card_capacity = (uint64_t)(card_info->sd_csd_reg.device_size + 1) * 512 * 1024;
624 card_info->card_blk_size = 512;
625 }
626
627
628 card_info->sd_csd_reg.erase_group_size = (tmp & 0x40) >> 6;
629 card_info->sd_csd_reg.erase_group_size_mult = (tmp & 0x3F) << 1;
630
631 /* byte 11 */
632 tmp = (uint8_t)(csd_table[2] & 0x000000FF);
633 card_info->sd_csd_reg.erase_group_size_mult |= (tmp & 0x80) >> 7;
634 card_info->sd_csd_reg.write_protect_group_size = (tmp & 0x7F);
635
636 /* byte 12 */
637 tmp = (uint8_t)((csd_table[3] & 0xFF000000) >> 24);
638 card_info->sd_csd_reg.write_protect_group_enable = (tmp & 0x80) >> 7;
639 card_info->sd_csd_reg.manufacturer_default_ecc = (tmp & 0x60) >> 5;
640 card_info->sd_csd_reg.write_speed_factor = (tmp & 0x1C) >> 2;
641 card_info->sd_csd_reg.max_write_blk_length = (tmp & 0x03) << 2;
642
643 /* byte 13 */
644 tmp = (uint8_t)((csd_table[3] & 0x00FF0000) >> 16);
645 card_info->sd_csd_reg.max_write_blk_length |= (tmp & 0xC0) >> 6;
646 card_info->sd_csd_reg.part_blk_write = (tmp & 0x20) >> 5;
647 card_info->sd_csd_reg.reserved3 = 0;
648 card_info->sd_csd_reg.content_protect_app = (tmp & 0x01);
649
650 /* byte 14 */
651 tmp = (uint8_t)((csd_table[3] & 0x0000FF00) >> 8);
652 card_info->sd_csd_reg.file_format_group = (tmp & 0x80) >> 7;
653 card_info->sd_csd_reg.copy_flag = (tmp & 0x40) >> 6;
654 card_info->sd_csd_reg.permanent_write_protect = (tmp & 0x20) >> 5;
655 card_info->sd_csd_reg.temp_write_protect = (tmp & 0x10) >> 4;
656 card_info->sd_csd_reg.file_formart = (tmp & 0x0C) >> 2;
657 card_info->sd_csd_reg.ecc_code = (tmp & 0x03);
658
659 /* byte 15 */
660 tmp = (uint8_t)(csd_table[3] & 0x000000FF);
661 card_info->sd_csd_reg.csd_crc = (tmp & 0xFE) >> 1;
662 card_info->sd_csd_reg.reserved4 = 1;
663
664 /* byte 0 */
665 tmp = (uint8_t)((cid_table[0] & 0xFF000000) >> 24);
666 card_info->sd_cid_reg.manufacturer_id = tmp;
667
668 /* byte 1 */
669 tmp = (uint8_t)((cid_table[0] & 0x00FF0000) >> 16);
670 card_info->sd_cid_reg.oem_app_id = tmp << 8;
671
672 /* byte 2 */
673 tmp = (uint8_t)((cid_table[0] & 0x000000FF00) >> 8);
674 card_info->sd_cid_reg.oem_app_id |= tmp;
675
676 /* byte 3 */
677 tmp = (uint8_t)(cid_table[0] & 0x000000FF);
678 card_info->sd_cid_reg.product_name1 = tmp << 24;
679
680 /* byte 4 */
681 tmp = (uint8_t)((cid_table[1] & 0xFF000000) >> 24);
682 card_info->sd_cid_reg.product_name1 |= tmp << 16;
683
684 /* byte 5 */
685 tmp = (uint8_t)((cid_table[1] & 0x00FF0000) >> 16);
686 card_info->sd_cid_reg.product_name1 |= tmp << 8;
687
688 /* byte 6 */
689 tmp = (uint8_t)((cid_table[1] & 0x0000FF00) >> 8);
690 card_info->sd_cid_reg.product_name1 |= tmp;
691
692 /* byte 7 */
693 tmp = (uint8_t)(cid_table[1] & 0x000000FF);
694 card_info->sd_cid_reg.product_name2 = tmp;
695
696 /* byte 8 */
697 tmp = (uint8_t)((cid_table[2] & 0xFF000000) >> 24);
698 card_info->sd_cid_reg.product_reversion = tmp;
699
700 /* byte 9 */
701 tmp = (uint8_t)((cid_table[2] & 0x00FF0000) >> 16);
702 card_info->sd_cid_reg.product_sn = tmp << 24;
703
704 /* byte 10 */
705 tmp = (uint8_t)((cid_table[2] & 0x0000FF00) >> 8);
706 card_info->sd_cid_reg.product_sn |= tmp << 16;
707
708 /* byte 11 */
709 tmp = (uint8_t)(cid_table[2] & 0x000000FF);
710 card_info->sd_cid_reg.product_sn |= tmp << 8;
711
712 /* byte 12 */
713 tmp = (uint8_t)((cid_table[3] & 0xFF000000) >> 24);
714 card_info->sd_cid_reg.product_sn |= tmp;
715
716 /* byte 13 */
717 tmp = (uint8_t)((cid_table[3] & 0x00FF0000) >> 16);
718 card_info->sd_cid_reg.reserved1 |= (tmp & 0xF0) >> 4;
719 card_info->sd_cid_reg.manufact_date = (tmp & 0x0F) << 8;
720
721 /* byte 14 */
722 tmp = (uint8_t)((cid_table[3] & 0x0000FF00) >> 8);
723 card_info->sd_cid_reg.manufact_date |= tmp;
724
725 /* byte 15 */
726 tmp = (uint8_t)(cid_table[3] & 0x000000FF);
727 card_info->sd_cid_reg.cid_crc = (tmp & 0xFE) >> 1;
728 card_info->sd_cid_reg.reserved2 = 1;
729
730 return(status);
731}
732
743 sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
744{
745 sd_error_status_type status = SD_OK;
746
747 if((card_type == SDIO_MULTIMEDIA_CARD) || (card_type == SDIO_HIGH_SPEED_MULTIMEDIA_CARD))
748 {
749 status = mmc_switch(EXT_CSD_CMD_SET_NORMAL, EXT_CSD_BUS_WIDTH, (uint8_t)mode);
750 }
751 else if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || \
752 (card_type == SDIO_HIGH_CAPACITY_SD_CARD))
753 {
754 if(mode >= 2)
755 {
756 /* not support D8 mode */
757 return SD_UNSUPPORTED_FEATURE;
758 }
759
760 if(SDIO_BUS_WIDTH_D4 == mode)
761 {
762 status = sd_bus_wide_enable(TRUE);
763 }
764 else
765 {
766 status = sd_bus_wide_enable(FALSE);
767 }
768 }
769
770 if(status == SD_OK)
771 {
772 sdio_bus_width_config(SDIOx, mode);
773 }
774
775 return status;
776}
777
786 sd_error_status_type sd_device_mode_set(uint32_t mode)
787{
788 sd_error_status_type status = SD_OK;
789
790 if((mode == SD_TRANSFER_DMA_MODE) || (mode == SD_TRANSFER_POLLING_MODE))
791 {
792 device_mode = (sd_data_transfer_mode_type)mode;
793 }
794 else
795 {
796 status = SD_INVALID_PARAMETER;
797 }
798
799 return status;
800}
801
807 sd_error_status_type sd_deselect_select(uint32_t addr)
808{
809 /* send cmd7, select card */
810 sdio_command_init_struct.argument = addr;
811 sdio_command_init_struct.cmd_index = SD_CMD_SEL_DESEL_CARD;
812 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
813 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_INT;
814
815 /* sdio command config */
816 sdio_command_config(SDIOx, &sdio_command_init_struct);
817 /* enable ccsm */
818 sdio_command_state_machine_enable(SDIOx, TRUE);
819
820 return command_rsp1_error(SD_CMD_SEL_DESEL_CARD);
821}
822
830 sd_error_status_type sdio_command_data_send(sdio_command_struct_type *sdio_cmd_init_t, \
831 sdio_data_struct_type* sdio_data_init_t, uint32_t *buf)
832{
833 sd_error_status_type status = SD_OK;
834 uint32_t count = 0;
835 uint32_t timeout = SDIO_DATATIMEOUT;
836 uint32_t length = 0;
837
838 if(buf == NULL)
839 {
840 return SD_INVALID_PARAMETER;
841 }
842 /* clear dtctrl register */
843 SDIOx->dtcnt = 0x0;
844
845 /* sdio command config */
846 sdio_data_config(SDIOx, sdio_data_init_t);
847 /* enable dcsm */
848 sdio_data_state_machine_enable(SDIOx, TRUE);
849
850 length = sdio_data_init_t->data_length;
851
852 if(device_mode == SD_TRANSFER_DMA_MODE)
853 {
854 if(sdio_data_init_t->transfer_direction == SDIO_DATA_TRANSFER_TO_CONTROLLER)
855 {
856 sd_dma_config(buf, length, DMA_DIR_PERIPHERAL_TO_MEMORY);
857 SDIOx->inten |= SDIO_INTR_STS_READ_MASK;
858 transfer_error = SD_OK;
859 transfer_end = 0;
860 sdio_dma_enable(SDIOx, TRUE);
861 }
862 }
863
864 /* sdio command config */
865 sdio_command_config(SDIOx, sdio_cmd_init_t);
866 /* enable ccsm */
867 sdio_command_state_machine_enable(SDIOx, TRUE);
868
869 status = command_rsp1_error(sdio_cmd_init_t->cmd_index);
870 if(status != SD_OK)
871 {
872 return status;
873 }
874
875 /* polling mode */
876 if(device_mode == SD_TRANSFER_POLLING_MODE)
877 {
878 if(SDIO_DATA_TRANSFER_TO_CONTROLLER == sdio_data_init_t->transfer_direction)
879 {
880 while(!(SDIOx->sts & (SDIO_INTR_STS_READ_MASK)))
881 {
882 if(sdio_flag_get(SDIOx, SDIO_RXBUFH_FLAG) != RESET)
883 {
884 for(count = 0; count < 8; count++, buf++)
885 {
886 *buf = sdio_data_read(SDIOx);
887 }
888
889 timeout = 0x7FFFFF;
890 }
891 else
892 {
893 if(0 == timeout)
894 {
895 sd_init();
896 return SD_DATA_TIMEOUT;
897 }
898
899 timeout--;
900 }
901 }
902
903 while(sdio_flag_get(SDIOx, SDIO_RXBUF_FLAG) != RESET)
904 {
905 *buf = sdio_data_read(SDIOx);
906 buf++;
907 }
908 }
909 else
910 {
911 while(!(SDIOx->sts & SDIO_INTR_STS_WRITE_MASK))
912 {
913 if(sdio_flag_get(SDIOx, SDIO_TXBUFH_FLAG) != RESET)
914 {
915 for(count = 0; count < 8 && length > 0; count++, buf++, length -= 4)
916 {
917 sdio_data_write(SDIOx, *buf);
918 }
919
920 timeout = 0x3FFFFFFF;
921 }
922 else
923 {
924 if(timeout == 0)
925 {
926 sd_init();
927 return SD_DATA_TIMEOUT;
928 }
929
930 timeout--;
931 }
932 }
933 }
934 /* data timeout */
935 if(sdio_flag_get(SDIOx, SDIO_DTTIMEOUT_FLAG) != RESET)
936 {
937 sdio_flag_clear(SDIOx, SDIO_DTTIMEOUT_FLAG);
938 return SD_DATA_TIMEOUT;
939 }
940 /* crc error */
941 else if(sdio_flag_get(SDIOx, SDIO_DTFAIL_FLAG) != RESET)
942 {
943 sdio_flag_clear(SDIOx, SDIO_DTFAIL_FLAG);
944 return SD_DATA_FAIL;
945 }
946 /* over run error */
947 else if(sdio_flag_get(SDIOx, SDIO_RXERRO_FLAG) != RESET)
948 {
949 sdio_flag_clear(SDIOx, SDIO_RXERRO_FLAG);
950 return SD_RX_OVERRUN;
951 }
952 /* under run error */
953 else if(sdio_flag_get(SDIOx, SDIO_TXERRU_FLAG) != RESET)
954 {
955 sdio_flag_clear(SDIOx, SDIO_TXERRU_FLAG);
956 return SD_TX_UNDERRUN;
957 }
958 /* start bit error */
959 else if(sdio_flag_get(SDIOx, SDIO_SBITERR_FLAG) != RESET)
960 {
961 sdio_flag_clear(SDIOx, SDIO_SBITERR_FLAG);
962 return SD_START_BIT_ERR;
963 }
964 /* data transfer complete */
965 if((stop_flag == 1) && (sdio_flag_get(SDIOx, SDIO_DTCMPL_FLAG) != RESET))
966 {
967 /* send cmd12, stop transmission */
968 sdio_cmd_init_t->argument = 0;
969 sdio_cmd_init_t->cmd_index = SD_CMD_STOP_TRANSMISSION;
970 sdio_cmd_init_t->rsp_type = SDIO_RESPONSE_SHORT;
971 sdio_cmd_init_t->wait_type = SDIO_WAIT_FOR_NO;
972
973 /* sdio command config */
974 sdio_command_config(SDIOx, sdio_cmd_init_t);
975 /* enable ccsm */
976 sdio_command_state_machine_enable(SDIOx, TRUE);
977
978 status = command_rsp1_error(SD_CMD_STOP_TRANSMISSION);
979
980 if(status != SD_OK)
981 {
982 return status;
983 }
984 }
985
986 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
987 }
988 else if(device_mode == SD_TRANSFER_DMA_MODE)
989 {
990 if(sdio_data_init_t->transfer_direction == SDIO_DATA_TRANSFER_TO_CARD)
991 {
992 sd_dma_config(buf, length, DMA_DIR_MEMORY_TO_PERIPHERAL);
993 SDIOx->inten |= SDIO_INTR_STS_WRITE_MASK;
994 transfer_error = SD_OK;
995 transfer_end = 0;
996 sdio_dma_enable(SDIOx, TRUE);
997 }
998
999 while(!(SDIOx->sts & SDIOx->inten) && timeout)
1000 {
1001 timeout--;
1002
1003 if(transfer_end)
1004 {
1005 break;
1006 }
1007 }
1008
1009 if(timeout == 0)
1010 {
1011 sd_init();
1012 return SD_DATA_TIMEOUT;
1013 }
1014
1015 if(transfer_error != SD_OK)
1016 {
1017 status = transfer_error;
1018 }
1019 }
1020
1021 return status;
1022}
1023
1030 sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks)
1031{
1032 sd_error_status_type status = SD_OK;
1033 uint32_t start_addr = 0, end_addr = 0, response = 0;
1034 uint8_t card_state;
1035
1036 /* high capacity sd card */
1037 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1038 {
1039 start_addr = addr >> 9;
1040 end_addr = start_addr + nblks - 1;
1041 }
1042 else
1043 {
1044 start_addr = addr;
1045 end_addr = start_addr + (nblks - 1) * 512;
1046 }
1047
1048 /* clear dcsm configuration */
1049 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1050 sdio_data_init_struct.data_length = 0 ;
1051 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1052 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1053 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1054
1055 sdio_data_config(SDIOx, &sdio_data_init_struct);
1056 sdio_data_state_machine_enable(SDIOx, FALSE);
1057
1058 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1059
1060 /* check card locked */
1061 if(response & SD_CARD_LOCKED)
1062 {
1063 return SD_LOCK_UNLOCK_ERROR;
1064 }
1065
1066 if(card_type == SDIO_MULTIMEDIA_CARD || card_type == SDIO_HIGH_SPEED_MULTIMEDIA_CARD)
1067 {
1068 /* send cmd35, set erase group start */
1069 sdio_command_init_struct.argument = start_addr;
1070 sdio_command_init_struct.cmd_index = SD_CMD_ERASE_GRP_START;
1071 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1072 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1073
1074 /* sdio command config */
1075 sdio_command_config(SDIOx, &sdio_command_init_struct);
1076 /* enable ccsm */
1077 sdio_command_state_machine_enable(SDIOx, TRUE);
1078
1079 status = command_rsp1_error(SD_CMD_ERASE_GRP_START);
1080
1081 if(status != SD_OK)
1082 {
1083 return status;
1084 }
1085
1086 /* send cmd36, set erase group end */
1087 sdio_command_init_struct.argument = end_addr;
1088 sdio_command_init_struct.cmd_index = SD_CMD_ERASE_GRP_END;
1089
1090 /* sdio command config */
1091 sdio_command_config(SDIOx, &sdio_command_init_struct);
1092 /* enable ccsm */
1093 sdio_command_state_machine_enable(SDIOx, TRUE);
1094
1095 status = command_rsp1_error(SD_CMD_ERASE_GRP_END);
1096
1097 if(status != SD_OK)
1098 {
1099 return status;
1100 }
1101
1102 /* send cmd38, start erase gourp */
1103 sdio_command_init_struct.argument = 0;
1104 sdio_command_init_struct.cmd_index = SD_CMD_ERASE;
1105
1106 /* sdio command config */
1107 sdio_command_config(SDIOx, &sdio_command_init_struct);
1108 /* enable ccsm */
1109 sdio_command_state_machine_enable(SDIOx, TRUE);
1110
1111 status = command_rsp1_error(SD_CMD_ERASE);
1112
1113 if(status != SD_OK)
1114 {
1115 return status;
1116 }
1117 }
1118 else
1119 {
1120 /* send cmd32, set erase block start */
1121 sdio_command_init_struct.argument = start_addr;
1122 sdio_command_init_struct.cmd_index = SD_CMD_SD_ERASE_GRP_START;
1123 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1124 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1125
1126 /* sdio command config */
1127 sdio_command_config(SDIOx, &sdio_command_init_struct);
1128 /* enable ccsm */
1129 sdio_command_state_machine_enable(SDIOx, TRUE);
1130
1131 status = command_rsp1_error(SD_CMD_SD_ERASE_GRP_START);
1132
1133 if(status != SD_OK)
1134 {
1135 return status;
1136 }
1137
1138 /* send cmd33, set erase block end */
1139 sdio_command_init_struct.argument = end_addr;
1140 sdio_command_init_struct.cmd_index = SD_CMD_SD_ERASE_GRP_END;
1141
1142 /* sdio command config */
1143 sdio_command_config(SDIOx, &sdio_command_init_struct);
1144 /* enable ccsm */
1145 sdio_command_state_machine_enable(SDIOx, TRUE);
1146
1147 if(status != SD_OK)
1148 {
1149 return status;
1150 }
1151
1152 /* send cmd38, start erase block */
1153 sdio_command_init_struct.argument = 0;
1154 sdio_command_init_struct.cmd_index = SD_CMD_ERASE;
1155
1156 /* sdio command config */
1157 sdio_command_config(SDIOx, &sdio_command_init_struct);
1158 /* enable ccsm */
1159 sdio_command_state_machine_enable(SDIOx, TRUE);
1160
1161 status = command_rsp1_error(SD_CMD_ERASE);
1162
1163 if(status != SD_OK)
1164 {
1165 return status;
1166 }
1167 }
1168
1169 status = check_card_programming(&card_state);
1170
1171 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || \
1172 (card_state == SD_CARD_RECEIVING)))
1173 {
1174 status = check_card_programming(&card_state);
1175 }
1176
1177 return status;
1178}
1179
1188 sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
1189{
1190 sd_error_status_type status = SD_OK;
1191 uint32_t response = 0;
1192 uint8_t power;
1193
1194 if(NULL == buf)
1195 {
1196 return SD_INVALID_PARAMETER;
1197 }
1198
1199 SDIOx->dtctrl = 0x0;
1200
1201 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1202 {
1203 blk_size = 512;
1204 addr >>= 9;
1205 }
1206
1207 /* clear dcsm configuration */
1208 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1209 sdio_data_init_struct.data_length = 0;
1210 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1211 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1212 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1213
1214 sdio_data_config(SDIOx, &sdio_data_init_struct);
1215 sdio_data_state_machine_enable(SDIOx, FALSE);
1216
1217 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1218
1219 /* check card locked */
1220 if(response & SD_CARD_LOCKED)
1221 {
1222 return SD_LOCK_UNLOCK_ERROR;
1223 }
1224
1225 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1226 {
1227 power = convert_from_bytes_to_power_of_two(blk_size);
1228
1229 /* send cmd16, set block size */
1230 sdio_command_init_struct.argument = blk_size;
1231 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1232 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1233 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1234
1235 /* sdio command config */
1236 sdio_command_config(SDIOx, &sdio_command_init_struct);
1237 /* enable ccsm */
1238 sdio_command_state_machine_enable(SDIOx, TRUE);
1239
1240 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1241
1242 if(status != SD_OK)
1243 {
1244 return status;
1245 }
1246 }
1247 else
1248 {
1249 return SD_INVALID_PARAMETER;
1250 }
1251
1252 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1253 sdio_data_init_struct.data_length = blk_size ;
1254 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1255 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
1256 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1257
1258 sdio_command_init_struct.argument = addr;
1259 sdio_command_init_struct.cmd_index = SD_CMD_READ_SINGLE_BLOCK;
1260 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1261 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1262
1263 stop_flag = 0;
1264
1265 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1266}
1267
1277 sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
1278{
1279 sd_error_status_type status = SD_OK;
1280 uint32_t response = 0;
1281 uint8_t power;
1282
1283 SDIOx->dtctrl = 0x0;
1284
1285 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1286 {
1287 blk_size = 512;
1288 addr >>= 9;
1289 }
1290
1291 /* clear dcsm configuration */
1292 sdio_data_init_struct.block_size = (sdio_block_size_type)0;
1293 sdio_data_init_struct.data_length = 0;
1294 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1295 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1296 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1297
1298 sdio_data_config(SDIOx, &sdio_data_init_struct);
1299 sdio_data_state_machine_enable(SDIOx, FALSE);
1300
1301 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1302
1303 /* check card locked */
1304 if(response & SD_CARD_LOCKED)
1305 {
1306 return SD_LOCK_UNLOCK_ERROR;
1307 }
1308
1309 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1310 {
1311 power = convert_from_bytes_to_power_of_two(blk_size);
1312
1313 /* send cmd16, set block size */
1314 sdio_command_init_struct.argument = blk_size;
1315 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1316 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1317 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1318
1319 /* sdio command config */
1320 sdio_command_config(SDIOx, &sdio_command_init_struct);
1321 /* enable ccsm */
1322 sdio_command_state_machine_enable(SDIOx, TRUE);
1323
1324 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1325
1326 if(status != SD_OK)
1327 {
1328 return status;
1329 }
1330 }
1331 else
1332 {
1333 return SD_INVALID_PARAMETER;
1334 }
1335
1336 /* check max receive length */
1337 if(nblks * blk_size > SD_MAX_DATA_LENGTH)
1338 {
1339 return SD_INVALID_PARAMETER;
1340 }
1341
1342 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1343 sdio_data_init_struct.data_length = nblks * blk_size ;
1344 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1345 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
1346 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1347
1348 /* send cmd18, read block data */
1349 sdio_command_init_struct.argument = addr;
1350 sdio_command_init_struct.cmd_index = SD_CMD_READ_MULT_BLOCK;
1351 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1352 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1353
1354 stop_flag = 1;
1355
1356 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1357}
1358
1367 sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
1368{
1369 sd_error_status_type status = SD_OK;
1370 uint8_t power = 0, card_state = 0;
1371 uint32_t timeout = 0, card_status = 0, response = 0;
1372
1373 if(buf == NULL)
1374 {
1375 return SD_INVALID_PARAMETER;
1376 }
1377
1378 SDIOx->dtctrl = 0x0;
1379
1380 /* clear dcsm configuration */
1381 sdio_data_init_struct.block_size = (sdio_block_size_type)0;
1382 sdio_data_init_struct.data_length = 0;
1383 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1384 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1385 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1386
1387 sdio_data_config(SDIOx, &sdio_data_init_struct);
1388 sdio_data_state_machine_enable(SDIOx, FALSE);
1389
1390 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1391
1392 /* check card locked */
1393 if(response & SD_CARD_LOCKED)
1394 {
1395 return SD_LOCK_UNLOCK_ERROR;
1396 }
1397
1398 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1399 {
1400 blk_size = 512;
1401 addr >>= 9;
1402 }
1403
1404 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1405 {
1406 power = convert_from_bytes_to_power_of_two(blk_size);
1407
1408 /* send cmd16, set block size */
1409 sdio_command_init_struct.argument = blk_size;
1410 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1411 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1412 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1413
1414 /* sdio command config */
1415 sdio_command_config(SDIOx, &sdio_command_init_struct);
1416 /* enable ccsm */
1417 sdio_command_state_machine_enable(SDIOx, TRUE);
1418
1419 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1420
1421 if(status != SD_OK)
1422 {
1423 return status;
1424 }
1425 }
1426 else
1427 {
1428 return SD_INVALID_PARAMETER;
1429 }
1430
1431 timeout = SD_DATATIMEOUT;
1432
1433 do
1434 {
1435 timeout--;
1436 status = sd_status_send(&card_status);
1437 }
1438 /* check ready_for_data flag */
1439 while(((card_status & 0x00000100) == 0) && (timeout > 0));
1440
1441 if(timeout == 0)
1442 {
1443 return SD_ERROR;
1444 }
1445
1446 /* send cmd24, write single block */
1447 sdio_command_init_struct.argument = addr;
1448 sdio_command_init_struct.cmd_index = SD_CMD_WRITE_SINGLE_BLOCK;
1449 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1450 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1451
1452 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1453 sdio_data_init_struct.data_length = blk_size;
1454 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1455 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1456 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1457
1458 stop_flag = 0;
1459
1460 /* single block, stop command is unnecessary */
1461 status = sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1462
1463 if(status != SD_OK)
1464 {
1465 return status;
1466 }
1467
1468 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1469
1470 status = check_card_programming(&card_state);
1471
1472 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || (card_state == SD_CARD_RECEIVING)))
1473 {
1474 status = check_card_programming(&card_state);
1475 }
1476
1477 return status;
1478}
1479
1489 sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
1490{
1491 sd_error_status_type status = SD_OK;
1492 uint8_t power = 0, card_state = 0;
1493 uint32_t timeout = 0, card_status = 0, response = 0;;
1494
1495 if(buf == NULL)
1496 {
1497 return SD_INVALID_PARAMETER;
1498 }
1499
1500 SDIOx->dtctrl = 0x0;
1501
1502 /* clear dcsm configuration */
1503 sdio_data_init_struct.block_size = (sdio_block_size_type)0;
1504 sdio_data_init_struct.data_length = 0;
1505 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1506 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1507 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1508
1509 sdio_data_config(SDIOx, &sdio_data_init_struct);
1510 sdio_data_state_machine_enable(SDIOx, FALSE);
1511
1512 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1513
1514 /* check card locked */
1515 if(response & SD_CARD_LOCKED)
1516 {
1517 return SD_LOCK_UNLOCK_ERROR;
1518 }
1519
1520 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1521 {
1522 blk_size = 512;
1523 addr >>= 9;
1524 }
1525
1526 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1527 {
1528 power = convert_from_bytes_to_power_of_two(blk_size);
1529
1530 /* send cmd16, set block size */
1531 sdio_command_init_struct.argument = blk_size;
1532 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1533 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1534 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1535
1536 /* sdio command config */
1537 sdio_command_config(SDIOx, &sdio_command_init_struct);
1538 /* enable ccsm */
1539 sdio_command_state_machine_enable(SDIOx, TRUE);
1540
1541 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1542
1543 if(status != SD_OK)
1544 {
1545 return status;
1546 }
1547 }
1548 else
1549 {
1550 return SD_INVALID_PARAMETER;
1551 }
1552
1553 if((nblks * blk_size) > SD_MAX_DATA_LENGTH)
1554 {
1555 return SD_INVALID_PARAMETER;
1556 }
1557
1558 timeout = SD_DATATIMEOUT;
1559
1560 do
1561 {
1562 timeout--;
1563 status = sd_status_send(&card_status);
1564 }
1565 /* check ready_for_data flag */
1566 while(((card_status & 0x00000100) == 0) && (timeout > 0));
1567
1568 if(timeout == 0)
1569 {
1570 return SD_ERROR;
1571 }
1572
1573 if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || \
1574 (card_type == SDIO_HIGH_CAPACITY_SD_CARD))
1575 {
1576 /* send cmd55 */
1577 sdio_command_init_struct.argument = (uint32_t)rca << 16;
1578 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
1579 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1580 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1581
1582 /* sdio command config */
1583 sdio_command_config(SDIOx, &sdio_command_init_struct);
1584 /* enable ccsm */
1585 sdio_command_state_machine_enable(SDIOx, TRUE);
1586
1587 status = command_rsp1_error(SD_CMD_APP_CMD);
1588
1589 if(status != SD_OK)
1590 {
1591 return status;
1592 }
1593
1594 /* send cmd23, set block count */
1595 sdio_command_init_struct.argument = blk_size;
1596 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCK_COUNT;
1597 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1598 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1599
1600 /* sdio command config */
1601 sdio_command_config(SDIOx, &sdio_command_init_struct);
1602 /* enable ccsm */
1603 sdio_command_state_machine_enable(SDIOx, TRUE);
1604
1605 status = command_rsp1_error(SD_CMD_SET_BLOCK_COUNT);
1606
1607 if(status != SD_OK)
1608 {
1609 return status;
1610 }
1611 }
1612
1613 /* send cmd25, write mult blocks */
1614 sdio_command_init_struct.argument = addr;
1615 sdio_command_init_struct.cmd_index = SD_CMD_WRITE_MULT_BLOCK;
1616 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1617 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1618
1619 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1620 sdio_data_init_struct.data_length = nblks * blk_size ;
1621 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1622 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1623 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1624
1625 stop_flag = 1;
1626 /* cmd12 is needed */
1627 status = sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1628
1629 if(status != SD_OK)
1630 {
1631 return status;
1632 }
1633
1634 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1635
1636 status = check_card_programming(&card_state);
1637
1638 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || (card_state == SD_CARD_RECEIVING)))
1639 {
1640 status = check_card_programming(&card_state);
1641 }
1642
1643 return status;
1644}
1645
1653 sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
1654{
1655 uint32_t response = 0;
1656
1657 SDIOx->dtctrl = 0x0;
1658
1659 /* clear dcsm configuration */
1660 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1661 sdio_data_init_struct.data_length = 0 ;
1662 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1663 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1664 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1665
1666 sdio_data_config(SDIOx, &sdio_data_init_struct);
1667 sdio_data_state_machine_enable(SDIOx, FALSE);
1668
1669 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1670
1671 /* check card locked */
1672 if(response & SD_CARD_LOCKED)
1673 {
1674 return SD_LOCK_UNLOCK_ERROR;
1675 }
1676 /* send cmd11, read data */
1677 sdio_command_init_struct.argument = addr;
1678 sdio_command_init_struct.cmd_index = SD_CMD_READ_DAT_UNTIL_STOP;
1679 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1680 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1681
1682 sdio_data_init_struct.block_size = (sdio_block_size_type)(5 << 4);
1683 sdio_data_init_struct.data_length = len;
1684 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1685 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
1686 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1687
1688 stop_flag = 1;
1689 /* cmd12 is needed */
1690 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1691}
1692
1700 sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
1701{
1702 sd_error_status_type status = SD_OK;
1703 uint32_t response = 0;
1704 uint8_t card_state = 0;
1705
1706 if(buf == NULL)
1707 {
1708 return SD_INVALID_PARAMETER;
1709 }
1710
1711 SDIOx->dtctrl = 0x0;
1712
1713 /* clear dcsm configuration */
1714 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1715 sdio_data_init_struct.data_length = 0;
1716 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1717 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1718 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1719
1720 sdio_data_config(SDIOx, &sdio_data_init_struct);
1721 sdio_data_state_machine_enable(SDIOx, FALSE);
1722
1723 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1724
1725 /* check card locked */
1726 if(response & SD_CARD_LOCKED)
1727 {
1728 return SD_LOCK_UNLOCK_ERROR;
1729 }
1730 /* send cmd20, write data */
1731 sdio_command_init_struct.argument = addr;
1732 sdio_command_init_struct.cmd_index = SD_CMD_WRITE_DAT_UNTIL_STOP;
1733 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1734 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1735
1736
1737 sdio_data_init_struct.block_size = (sdio_block_size_type)(15 << 4);
1738 sdio_data_init_struct.data_length = len;
1739 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1740 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1741 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1742
1743 stop_flag = 1;
1744 /* cmd12 is needed */
1745 status = sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1746
1747 if(status != SD_OK)
1748 {
1749 return status;
1750 }
1751
1752 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1753
1754 status = check_card_programming(&card_state);
1755
1756 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || (card_state == SD_CARD_RECEIVING)))
1757 {
1758 status = check_card_programming(&card_state);
1759 }
1760
1761 return status;
1762}
1763
1769void SDIO1_IRQHandler(void)
1770{
1771 sd_irq_service();
1772}
1773
1779void SDIO2_IRQHandler(void)
1780{
1781 sd_irq_service();
1782}
1783
1789 sd_error_status_type sd_irq_service(void)
1790{
1791 if(sdio_flag_get(SDIOx, SDIO_DTCMPL_FLAG) != RESET)
1792 {
1793 if(stop_flag == 1)
1794 {
1795 /* send cmd12, stop transmission */
1796 sdio_command_init_struct.argument = 0;
1797 sdio_command_init_struct.cmd_index = SD_CMD_STOP_TRANSMISSION;
1798 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1799 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1800 /* sdio command config */
1801 sdio_command_config(SDIOx, &sdio_command_init_struct);
1802 /* enable ccsm */
1803 sdio_command_state_machine_enable(SDIOx, TRUE);
1804 transfer_error = command_rsp1_error(SD_CMD_STOP_TRANSMISSION);
1805 }
1806 else
1807 {
1808 transfer_error = SD_OK;
1809 }
1810 /* clear flag */
1811 sdio_flag_clear(SDIOx, SDIO_DTCMPL_FLAG);
1812 transfer_end = 1;
1813 return transfer_error;
1814 }
1815
1816 if(sdio_flag_get(SDIOx, SDIO_DTFAIL_FLAG) != RESET)
1817 {
1818 /* clear flag */
1819 sdio_flag_clear(SDIOx, SDIO_DTFAIL_FLAG);
1820 transfer_error = SD_DATA_FAIL;
1821 transfer_end = 1;
1822 return transfer_error;
1823 }
1824
1825 if(sdio_flag_get(SDIOx, SDIO_DTTIMEOUT_FLAG) != RESET)
1826 {
1827 /* clear flag */
1828 sdio_flag_clear(SDIOx, SDIO_DTTIMEOUT_FLAG);
1829 transfer_error = SD_DATA_TIMEOUT;
1830 transfer_end = 1;
1831 return transfer_error;
1832 }
1833
1834 if(sdio_flag_get(SDIOx, SDIO_RXERRO_FLAG) != RESET)
1835 {
1836 /* clear flag */
1837 sdio_flag_clear(SDIOx, SDIO_RXERRO_FLAG);
1838 transfer_error = SD_RX_OVERRUN;
1839 transfer_end = 1;
1840 return(SD_RX_OVERRUN);
1841 }
1842
1843 if(sdio_flag_get(SDIOx, SDIO_TXERRU_FLAG) != RESET)
1844 {
1845 /* clear flag */
1846 sdio_flag_clear(SDIOx, SDIO_TXERRU_FLAG);
1847 transfer_error = SD_TX_UNDERRUN;
1848 transfer_end = 1;
1849 return(SD_TX_UNDERRUN);
1850 }
1851
1852 if(sdio_flag_get(SDIOx, SDIO_SBITERR_FLAG) != RESET)
1853 {
1854 /* clear flag */
1855 sdio_flag_clear(SDIOx, SDIO_SBITERR_FLAG);
1856 transfer_error = SD_START_BIT_ERR;
1857 transfer_end = 1;
1858 return(SD_START_BIT_ERR);
1859 }
1860
1861 /* disable interrupt */
1862 sdio_interrupt_enable(SDIOx, (SDIO_DTFAIL_INT | SDIO_DTTIMEOUT_INT | \
1863 SDIO_DTCMP_INT | SDIO_TXBUFH_INT | SDIO_RXBUFH_INT | \
1864 SDIO_TXERRU_INT| SDIO_RXERRO_INT | SDIO_SBITERR_INT), FALSE);
1865 return(SD_OK);
1866}
1867
1873 sd_error_status_type command_error(void)
1874{
1875 sd_error_status_type status = SD_OK;
1876 uint32_t timeout = SDIO_CMD0TIMEOUT;
1877
1878 while(timeout--)
1879 {
1880 if(sdio_flag_get(SDIOx, SDIO_CMDCMPL_FLAG) != RESET)
1881 {
1882 break;
1883 }
1884 }
1885
1886 if(timeout == 0)
1887 {
1888 return SD_CMD_RSP_TIMEOUT;
1889 }
1890
1891 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1892 return status;
1893}
1894
1900 sd_error_status_type command_rsp7_error(void)
1901{
1902 sd_error_status_type status = SD_OK;
1903 uint32_t sts_reg = 0;
1904 uint32_t timeout = SDIO_CMD0TIMEOUT;
1905
1906 while(timeout--)
1907 {
1908 sts_reg = SDIOx->sts;
1909
1910 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
1911 {
1912 break;
1913 }
1914 }
1915
1916 if((timeout == 0) || (sts_reg & SDIO_CMDTIMEOUT_FLAG))
1917 {
1918 status = SD_CMD_RSP_TIMEOUT;
1919 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
1920 return status;
1921 }
1922
1923 if(sts_reg & SDIO_CMDRSPCMPL_FLAG)
1924 {
1925 status = SD_OK;
1926 sdio_flag_clear(SDIOx, SDIO_CMDRSPCMPL_FLAG);
1927 }
1928
1929 return status;
1930}
1931
1937 sd_error_status_type command_rsp1_error(uint8_t cmd)
1938{
1939 uint32_t sts_reg = 0;
1940 uint32_t rsp_cmd = 0;
1941
1942 while(1)
1943 {
1944 sts_reg = SDIOx->sts;
1945
1946 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
1947 {
1948 break;
1949 }
1950 }
1951
1952 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
1953 {
1954 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
1955 return SD_CMD_RSP_TIMEOUT;
1956 }
1957
1958 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
1959 {
1960 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
1961 return SD_CMD_FAIL;
1962 }
1963
1964 rsp_cmd = sdio_command_response_get(SDIOx);
1965 if(rsp_cmd != cmd)
1966 {
1967 return SD_ILLEGAL_CMD;
1968 }
1969
1970 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1971
1972 return (sd_error_status_type)(sdio_response_get(SDIOx, SDIO_RSP1_INDEX) & SD_OCR_ERRORBITS);
1973}
1974
1980 sd_error_status_type command_rsp3_error(void)
1981{
1982 uint32_t sts_reg = 0;;
1983
1984 while(1)
1985 {
1986 sts_reg = SDIOx->sts;
1987
1988 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
1989 {
1990 break;
1991 }
1992 }
1993
1994 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
1995 {
1996 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
1997 return SD_CMD_RSP_TIMEOUT;
1998 }
1999
2000 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2001
2002 return SD_OK;
2003}
2004
2010 sd_error_status_type command_rsp2_error(void)
2011{
2012 sd_error_status_type status = SD_OK;
2013 uint32_t sts_reg;
2014 uint32_t timeout = SDIO_CMD0TIMEOUT;
2015
2016 while(timeout--)
2017 {
2018 sts_reg = SDIOx->sts;
2019
2020 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2021 {
2022 break;
2023 }
2024 }
2025
2026 if((timeout == 0) || sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2027 {
2028 status = SD_CMD_RSP_TIMEOUT;
2029 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2030
2031 return status;
2032 }
2033
2034 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2035 {
2036 status = SD_CMD_FAIL;
2037 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2038 }
2039
2040 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2041
2042 return status;
2043}
2044
2050 sd_error_status_type command_rsp4_error(uint8_t cmd)
2051{
2052 uint32_t sts_reg = 0, rsp_cmd = 0;
2053
2054 while(1)
2055 {
2056 sts_reg = SDIOx->sts;
2057
2058 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2059 {
2060 break;
2061 }
2062 }
2063
2064 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2065 {
2066 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2067 return SD_CMD_RSP_TIMEOUT;
2068 }
2069
2070 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2071 {
2072 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2073
2074 return SD_CMD_FAIL;
2075 }
2076
2077 rsp_cmd = sdio_command_response_get(SDIOx);
2078 if(rsp_cmd != cmd)
2079 {
2080 return SD_ILLEGAL_CMD;
2081 }
2082
2083 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2084
2085 return SD_OK;
2086}
2087
2093 sd_error_status_type command_rsp5_error(uint8_t cmd)
2094{
2095 uint32_t sts_reg = 0, rsp_cmd = 0, response = 0;
2096
2097 while(1)
2098 {
2099 sts_reg = SDIOx->sts;
2100
2101 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2102 {
2103 break;
2104 }
2105 }
2106
2107 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2108 {
2109 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2110
2111 return SD_CMD_RSP_TIMEOUT;
2112 }
2113
2114 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2115 {
2116 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2117
2118 return SD_CMD_FAIL;
2119 }
2120
2121 rsp_cmd = sdio_command_response_get(SDIOx);
2122 if(rsp_cmd != cmd)
2123 {
2124 return SD_ILLEGAL_CMD;
2125 }
2126
2127 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2128
2129 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2130
2131 if(response & SD_R5_OUT_OF_RANGE)
2132 {
2133 return SD_CMD_OUT_OF_RANGE;
2134 }
2135
2136 if(response & SD_R5_FUNCTION_NUMBER)
2137 {
2138 return SD_SDIO_UNKNOWN_FUNC;
2139 }
2140
2141 if(response & SD_R5_ERROR)
2142 {
2143 return SD_GENERAL_UNKNOWN_ERROR;
2144 }
2145
2146 return SD_OK;
2147}
2148
2156 sd_error_status_type command_rsp6_error(uint8_t cmd, uint16_t *prca)
2157{
2158 sd_error_status_type status = SD_OK;
2159 uint32_t sts_reg, rsp_cmd = 0, response = 0;
2160
2161 while(1)
2162 {
2163 sts_reg = SDIOx->sts;
2164
2165 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2166 {
2167 break;
2168 }
2169 }
2170
2171 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2172 {
2173 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2174 return SD_CMD_RSP_TIMEOUT;
2175 }
2176
2177 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2178 {
2179 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2180 return SD_CMD_FAIL;
2181 }
2182
2183 rsp_cmd = sdio_command_response_get(SDIOx);
2184 if(rsp_cmd != cmd)
2185 {
2186 return SD_ILLEGAL_CMD;
2187 }
2188
2189 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2190
2191 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2192
2193 if(SD_ALLZERO == (response & (SD_R6_GENERAL_UNKNOWN_ERROR | SD_R6_ILLEGAL_CMD | SD_R6_CMD_CRC_ERROR)))
2194 {
2195 *prca = (uint16_t)(response >> 16);
2196 return status;
2197 }
2198
2199 if(response & SD_R6_GENERAL_UNKNOWN_ERROR)
2200 {
2201 return SD_GENERAL_UNKNOWN_ERROR;
2202 }
2203
2204 if(response & SD_R6_ILLEGAL_CMD)
2205 {
2206 return SD_ILLEGAL_CMD;
2207 }
2208
2209 if(response & SD_R6_CMD_CRC_ERROR)
2210 {
2211 return SD_CMD_CRC_ERROR;
2212 }
2213
2214 return status;
2215}
2216
2222 sd_error_status_type sd_bus_wide_enable(confirm_state new_state)
2223{
2224 sd_error_status_type status = SD_OK;
2225 uint32_t response = 0;
2226 uint8_t arg = 0x00;
2227
2228 if(new_state == TRUE)
2229 {
2230 arg = 0x02;
2231 }
2232 else
2233 {
2234 arg = 0x00;
2235 }
2236
2237 /* get response1 */
2238 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2239
2240 /* check card locked or not */
2241 if(response & SD_CARD_LOCKED)
2242 {
2243 return SD_LOCK_UNLOCK_ERROR;
2244 }
2245
2246 if(sd_card_info.sd_scr_reg.sd_bus_width)
2247 {
2248 sdio_command_init_struct.argument = (uint32_t)(sd_card_info.rca << 16);
2249 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
2250 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2251 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2252
2253 /* sdio command config */
2254 sdio_command_config(SDIOx, &sdio_command_init_struct);
2255 /* enable ccsm */
2256 sdio_command_state_machine_enable(SDIOx, TRUE);
2257
2258 status = command_rsp1_error(SD_CMD_APP_CMD);
2259
2260 if(status != SD_OK)
2261 {
2262 return status;
2263 }
2264
2265 sdio_command_init_struct.argument = arg;
2266 sdio_command_init_struct.cmd_index = SD_CMD_APP_SD_SET_BUSWIDTH;
2267 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2268 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2269
2270 /* sdio command config */
2271 sdio_command_config(SDIOx, &sdio_command_init_struct);
2272 /* enable ccsm */
2273 sdio_command_state_machine_enable(SDIOx, TRUE);
2274
2275 status = command_rsp1_error(SD_CMD_APP_SD_SET_BUSWIDTH);
2276 return status;
2277 }
2278 else
2279 {
2280 return SD_REQ_NOT_APPLICABLE;
2281 }
2282}
2283
2291 sd_error_status_type mmc_switch(uint8_t set, uint8_t index, uint8_t value)
2292{
2293 sd_error_status_type status = SD_OK;
2294 uint32_t card_status = 0, timeout = 0;
2295
2296 sdio_command_init_struct.argument = (EXT_CSD_Write_byte << 24) | (index << 16) | (value << 8) | set;
2297 sdio_command_init_struct.cmd_index = SD_CMD_HS_SWITCH;
2298 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2299 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2300
2301 /* sdio command config */
2302 sdio_command_config(SDIOx, &sdio_command_init_struct);
2303 /* enable ccsm */
2304 sdio_command_state_machine_enable(SDIOx, TRUE);
2305
2306 status = command_rsp1_error(SD_CMD_HS_SWITCH);
2307 if(status != SD_OK)
2308 {
2309 return status;
2310 }
2311
2312 card_status = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2313 if(card_status & MMC_SWITCH_ERROR)
2314 {
2315 return SD_SWITCH_ERROR;
2316 }
2317
2318 timeout = SD_DATATIMEOUT;
2319 do
2320 {
2321 timeout--;
2322 status = sd_status_send(&card_status);
2323 } /* check ready_for_data flag */
2324 while(((card_status & 0x00000100) == 0) && (timeout > 0));
2325
2326 if(timeout == 0)
2327 {
2328 return SD_ERROR;
2329 }
2330
2331 return status;
2332}
2333
2342 sd_error_status_type sd_switch(uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
2343{
2344 sd_error_status_type status = SD_OK;
2345 uint8_t power;
2346 uint16_t blk_size;
2347
2348 if(rsp == NULL)
2349 {
2350 return SD_INVALID_PARAMETER;
2351 }
2352
2353 SDIOx->dtctrl = 0x0;
2354
2355 blk_size = 64;
2356 power = convert_from_bytes_to_power_of_two(blk_size);
2357
2358 sdio_command_init_struct.argument = blk_size;
2359 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
2360 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2361 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2362
2363 /* sdio command config */
2364 sdio_command_config(SDIOx, &sdio_command_init_struct);
2365 /* enable ccsm */
2366 sdio_command_state_machine_enable(SDIOx, TRUE);
2367
2368 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
2369
2370 if(status != SD_OK)
2371 {
2372 return status;
2373 }
2374
2375 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
2376 sdio_data_init_struct.data_length = blk_size ;
2377 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
2378 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
2379 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
2380
2381 sdio_command_init_struct.argument = (mode << 31) | 0x00FFFFFF;
2382 sdio_command_init_struct.argument &= ~(0xF << (group * 4));
2383 sdio_command_init_struct.argument |= value << (group * 4);
2384 sdio_command_init_struct.cmd_index = SD_CMD_HS_SWITCH;
2385 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2386 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2387
2388 stop_flag = 0;
2389
2390 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)rsp);
2391}
2392
2398 sd_error_status_type check_card_programming(uint8_t *p_status)
2399{
2400 volatile uint32_t response = 0, sts_reg = 0, rsp_cmd = 0;
2401
2402 /* send cmd13 */
2403 sdio_command_init_struct.argument = (uint32_t)(rca << 16);
2404 sdio_command_init_struct.cmd_index = SD_CMD_SEND_STATUS;
2405 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2406 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2407
2408 /* sdio command config */
2409 sdio_command_config(SDIOx, &sdio_command_init_struct);
2410 /* enable ccsm */
2411 sdio_command_state_machine_enable(SDIOx, TRUE);
2412
2413 sts_reg = SDIOx->sts;
2414
2415 while(!(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG)))
2416 {
2417 sts_reg = SDIOx->sts;
2418 }
2419
2420 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2421 {
2422 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2423 return SD_CMD_FAIL;
2424 }
2425
2426 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2427 {
2428 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2429 return SD_CMD_RSP_TIMEOUT;
2430 }
2431
2432 rsp_cmd = sdio_command_response_get(SDIOx);
2433 if(rsp_cmd!= SD_CMD_SEND_STATUS)
2434 {
2435 return SD_ILLEGAL_CMD;
2436 }
2437
2438 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2439
2440 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2441
2442 *p_status = (uint8_t)((response >> 9) & 0x0000000F);
2443
2444 return SD_OK;
2445}
2446
2452 sd_error_status_type sd_status_send(uint32_t *p_card_status)
2453{
2454 sd_error_status_type status = SD_OK;
2455
2456 if(p_card_status == NULL)
2457 {
2458 status = SD_INVALID_PARAMETER;
2459 return status;
2460 }
2461
2462 sdio_command_init_struct.argument = (uint32_t)(rca << 16);
2463 sdio_command_init_struct.cmd_index = SD_CMD_SEND_STATUS;
2464 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2465 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2466
2467 /* sdio command config */
2468 sdio_command_config(SDIOx, &sdio_command_init_struct);
2469 /* enable ccsm */
2470 sdio_command_state_machine_enable(SDIOx, TRUE);
2471
2472 status = command_rsp1_error(SD_CMD_SEND_STATUS);
2473
2474 if(status != SD_OK)
2475 {
2476 return status;
2477 }
2478
2479 *p_card_status = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2480
2481 return status;
2482}
2483
2489 sd_card_state_type sd_state_get(void)
2490{
2491 uint32_t response = 0;
2492
2493 if(sd_status_send(&response) != SD_OK)
2494 {
2495 return SD_CARD_ERROR;
2496 }
2497 else
2498 {
2499 return (sd_card_state_type)((response >> 9) & 0x0F);
2500 }
2501}
2502
2507 sd_error_status_type scr_find(void)
2508{
2509 uint32_t index = 0, sts_reg = 0;
2510 sd_error_status_type status = SD_OK;
2511 uint32_t *tempscr;
2512
2513 tempscr = (uint32_t *) &(sd_card_info.sd_scr_reg);
2514
2515 /* send cmd16, set block length */
2516 sdio_command_init_struct.argument = (uint32_t)8;
2517 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
2518 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2519 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2520
2521 /* sdio command config */
2522 sdio_command_config(SDIOx, &sdio_command_init_struct);
2523 /* enable ccsm */
2524 sdio_command_state_machine_enable(SDIOx, TRUE);
2525
2526 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
2527
2528 if(status != SD_OK)
2529 {
2530 return status;
2531 }
2532
2533 /* send cmd55 */
2534 sdio_command_init_struct.argument = (uint32_t)(sd_card_info.rca << 16);
2535 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
2536 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2537 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2538
2539 /* sdio command config */
2540 sdio_command_config(SDIOx, &sdio_command_init_struct);
2541 /* enable ccsm */
2542 sdio_command_state_machine_enable(SDIOx, TRUE);
2543
2544 status = command_rsp1_error(SD_CMD_APP_CMD);
2545
2546 if(status != SD_OK)
2547 {
2548 return status;
2549 }
2550
2551 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_8B;
2552 sdio_data_init_struct.data_length = 8;
2553 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
2554 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
2555 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
2556
2557 sdio_data_config(SDIOx, &sdio_data_init_struct);
2558 sdio_data_state_machine_enable(SDIOx, TRUE);
2559
2560 /* send cmd51 */
2561 sdio_command_init_struct.argument = 0x0;
2562 sdio_command_init_struct.cmd_index = SD_CMD_SD_APP_SEND_SCR;
2563 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2564 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2565
2566 /* sdio command config */
2567 sdio_command_config(SDIOx, &sdio_command_init_struct);
2568 /* enable ccsm */
2569 sdio_command_state_machine_enable(SDIOx, TRUE);
2570
2571 status = command_rsp1_error(SD_CMD_SD_APP_SEND_SCR);
2572
2573 if(status != SD_OK)
2574 {
2575 return status;
2576 }
2577
2578 sts_reg = SDIOx->sts;
2579
2580 while(!(sts_reg & (SDIO_RXERRO_FLAG | SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_DTBLKCMPL_FLAG | SDIO_SBITERR_FLAG)))
2581 {
2582 if(sdio_flag_get(SDIOx, SDIO_RXBUF_FLAG) != RESET)
2583 {
2584 *(tempscr + index) = sdio_data_read(SDIOx);
2585 index++;
2586 }
2587 sts_reg = SDIOx->sts;
2588 }
2589
2590 if(sdio_flag_get(SDIOx, SDIO_DTTIMEOUT_FLAG) != RESET)
2591 {
2592 sdio_flag_clear(SDIOx, SDIO_DTTIMEOUT_FLAG);
2593 return SD_DATA_TIMEOUT;
2594 }
2595 else if(sdio_flag_get(SDIOx, SDIO_DTFAIL_FLAG) != RESET)
2596 {
2597 sdio_flag_clear(SDIOx, SDIO_DTFAIL_FLAG);
2598 return SD_DATA_FAIL;
2599 }
2600 else if(sdio_flag_get(SDIOx, SDIO_RXERRO_FLAG) != RESET)
2601 {
2602 sdio_flag_clear(SDIOx, SDIO_RXERRO_FLAG);
2603 return SD_RX_OVERRUN;
2604 }
2605 else if(sdio_flag_get(SDIOx, SDIO_SBITERR_FLAG) != RESET)
2606 {
2607 sdio_flag_clear(SDIOx, SDIO_SBITERR_FLAG);
2608 return SD_START_BIT_ERR;
2609 }
2610
2611 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2612
2613 return status;
2614}
2615
2621 sd_error_status_type speed_change(uint8_t speed)
2622{
2623 sd_error_status_type status = SD_OK;
2624 uint8_t switch_sts[64];
2625
2626 if(speed > 1)
2627 {
2628 return SD_ERROR;
2629 }
2630
2631 /* check card type */
2632 if((SDIO_STD_CAPACITY_SD_CARD_V1_1 == card_type) || (SDIO_STD_CAPACITY_SD_CARD_V2_0 == card_type) || \
2633 (SDIO_HIGH_CAPACITY_SD_CARD == card_type))
2634 {
2635 /* version 1.01 card does not support cmd6 */
2636 if(sd_card_info.sd_scr_reg.sd_spec == 0)
2637 {
2638 return SD_ERROR;
2639 }
2640
2641 /* check group 1 function support speed */
2642 status = sd_switch(0, 0, speed, switch_sts);
2643
2644 if(status != 0)
2645 {
2646 return status;
2647 }
2648
2649 if((switch_sts[13] & (1 << speed)) == 0)
2650 {
2651 return SD_ERROR;
2652 }
2653
2654 status = sd_switch(1, 0, speed, switch_sts);
2655
2656 if(status != 0)
2657 {
2658 return status;
2659 }
2660
2661 /* read it back for confirmation */
2662 if((switch_sts[16] & 0xF) != speed)
2663 {
2664 return SD_ERROR;
2665 }
2666 }
2667 else if(card_type == SDIO_HIGH_SPEED_MULTIMEDIA_CARD)
2668 {
2669 status = mmc_switch(EXT_CSD_CMD_SET_NORMAL, EXT_CSD_BUS_WIDTH, (uint8_t)speed);
2670
2671 if(status != 0)
2672 {
2673 return status;
2674 }
2675 }
2676
2677 return status;
2678}
2679
2685uint8_t convert_from_bytes_to_power_of_two(uint16_t number_of_bytes)
2686{
2687 uint8_t count = 0;
2688
2689 while(number_of_bytes != 1)
2690 {
2691 number_of_bytes >>= 1;
2692 count++;
2693 }
2694
2695 return count;
2696}
2697
2706void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
2707{
2708 dma_init_type dma_init_struct;
2709 dma_default_para_init(&dma_init_struct);
2710
2711 crm_periph_clock_enable(CRM_DMA2_PERIPH_CLOCK, TRUE);
2712
2713 dma_reset(DMA2_CHANNEL4);
2714 dma_channel_enable(DMA2_CHANNEL4, FALSE);
2715
2716 dma_init_struct.peripheral_base_addr = (uint32_t)&SDIOx->buf;
2717 dma_init_struct.memory_base_addr = (uint32_t)mbuf;
2718 dma_init_struct.direction = dir;
2719 dma_init_struct.buffer_size = buf_size / 4;
2720 dma_init_struct.peripheral_inc_enable = FALSE;
2721 dma_init_struct.memory_inc_enable = TRUE;
2722 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_WORD;
2723 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_WORD;
2724 dma_init_struct.loop_mode_enable = FALSE;
2725 dma_init_struct.priority = DMA_PRIORITY_HIGH;
2726 dma_init(DMA2_CHANNEL4, &dma_init_struct);
2727
2728 dmamux_init(DMA2MUX_CHANNEL4, DMAMUX_SDIOx);
2729 dmamux_enable(DMA2, TRUE);
2730 dma_channel_enable(DMA2_CHANNEL4, TRUE);
2731}
2732
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
sd_card_info
sd_card_info_struct_type sd_card_info
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:48
sd_switch
sd_error_status_type sd_switch(uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
switch sd card speed to high speed
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2342
command_rsp5_error
sd_error_status_type command_rsp5_error(uint8_t cmd)
checks for error conditions for r5 response.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2093
speed_change
sd_error_status_type speed_change(uint8_t speed)
set bus speed
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2621
sd_power_off
sd_error_status_type sd_power_off(void)
turns the sdio output signals off.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:403
sdio_data_init_struct
sdio_data_struct_type sdio_data_init_struct
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:40
sd_irq_service
sd_error_status_type sd_irq_service(void)
allows to process all the interrupts that are high.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1789
transfer_end
volatile uint8_t transfer_end
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:47
command_rsp7_error
sd_error_status_type command_rsp7_error(void)
checks for error conditions for R7 response.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1900
sd_device_mode_set
sd_error_status_type sd_device_mode_set(uint32_t mode)
set sdio work mode.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:786
card_type
static sd_memory_card_type card_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:42
convert_from_bytes_to_power_of_two
uint8_t convert_from_bytes_to_power_of_two(uint16_t number_of_bytes)
converts the number of bytes in power of two and returns the power.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2685
sd_card_info_get
sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info)
returns information about specific card.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:532
sdio_command_init_struct
sdio_command_struct_type sdio_command_init_struct
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:39
mmc_stream_write
sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1700
sd_card_init
sd_error_status_type sd_card_init(void)
intialises all cards or single card as the case may be card(s) come into standby state.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:417
sd_block_read
sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma ...
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1188
sd_deselect_select
sd_error_status_type sd_deselect_select(uint32_t addr)
selects od deselects the corresponding card.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:807
command_rsp6_error
sd_error_status_type command_rsp6_error(uint8_t cmd, uint16_t *p_rca)
checks for error conditions for r6 (rca) response.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2156
SDIO1_IRQHandler
void SDIO1_IRQHandler(void)
sdio1 isr.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1769
stop_flag
static uint8_t stop_flag
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:45
mmc_switch
sd_error_status_type mmc_switch(uint8_t set, uint8_t index, uint8_t value)
switch mmc card speed to high speed
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2291
sd_blocks_erase
sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks)
erase continuous data block
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1030
check_card_programming
sd_error_status_type check_card_programming(uint8_t *p_status)
checks if the sd card is in programming state.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2398
transfer_error
volatile sd_error_status_type transfer_error
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:46
sd_bus_wide_enable
sd_error_status_type sd_bus_wide_enable(confirm_state new_state)
enable or disable the sdio wide bus mode.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2222
command_rsp1_error
sd_error_status_type command_rsp1_error(uint8_t cmd)
checks for error conditions for R1 response.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1937
SDIO2_IRQHandler
void SDIO2_IRQHandler(void)
sdio2 isr.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1779
sd_mult_blocks_write
sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed ...
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1489
csd_table
static uint32_t csd_table[4]
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:43
sdio_clock_set
void sdio_clock_set(uint32_t clk_div)
set sdio clock devision factor.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:188
sd_state_get
sd_card_state_type sd_state_get(void)
returns information about sd card.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2489
cid_table
static uint32_t cid_table[4]
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:43
sd_dma_config
void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2706
sd_block_write
sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be manag...
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1367
device_mode
static sd_data_transfer_mode_type device_mode
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:44
sd_status_send
sd_error_status_type sd_status_send(uint32_t *p_card_status)
read current card status.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2452
sdio_command_data_send
sd_error_status_type sdio_command_data_send(sdio_command_struct_type *sdio_cmd_init_t, sdio_data_struct_type *sdio_data_init_t, uint32_t *buf)
read data from or write data to sd card.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:830
command_rsp2_error
sd_error_status_type command_rsp2_error(void)
checks for error conditions for R2 (cid or csd) response.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2010
sd_init
sd_error_status_type sd_init(void)
initializes the sd card and put it into standby state (ready for data transfer).
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:72
mmc_stream_read
sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1653
scr_find
sd_error_status_type scr_find(void)
find the sd card scr register value.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2507
sd_power_on
sd_error_status_type sd_power_on(void)
enquires cards about their operating voltage and configures clock controls.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:203
command_rsp4_error
sd_error_status_type command_rsp4_error(uint8_t cmd)
checks for error conditions for r4 response.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2050
sd_mult_blocks_read
sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mod...
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1277
sd_wide_bus_operation_config
sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:743
rca
static uint32_t rca
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:43
command_rsp3_error
sd_error_status_type command_rsp3_error(void)
checks for error conditions for R3 (ocr) response.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1980
command_error
sd_error_status_type command_error(void)
checks for error conditions for cmd0.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1873
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
system_core_clock
unsigned int system_core_clock
Definition: system_at32f435_437.c:48
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_SDIO1_PERIPH_CLOCK
@ CRM_SDIO1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:121
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_DMA2_PERIPH_CLOCK
@ CRM_DMA2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:116
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f435_437_dma.h:151
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:164
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:174
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMA2MUX_CHANNEL4
#define DMA2MUX_CHANNEL4
Definition: at32f435_437_dma.h:729
DMA2
#define DMA2
Definition: at32f435_437_dma.h:717
DMA2_CHANNEL4
#define DMA2_CHANNEL4
Definition: at32f435_437_dma.h:721
confirm_state
confirm_state
Definition: at32f435_437.h:379
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
SDIO_SEND_IF_COND
#define SDIO_SEND_IF_COND
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:441
SD_CMD_SD_APP_SEND_SCR
#define SD_CMD_SD_APP_SEND_SCR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:311
SD_CMD_ERASE
#define SD_CMD_ERASE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:294
SD_CMD_APP_SD_SET_BUSWIDTH
#define SD_CMD_APP_SD_SET_BUSWIDTH
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:306
SD_CMD_WRITE_SINGLE_BLOCK
#define SD_CMD_WRITE_SINGLE_BLOCK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:283
SD_CMD_SD_ERASE_GRP_START
#define SD_CMD_SD_ERASE_GRP_START
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:290
SD_CMD_APP_CMD
#define SD_CMD_APP_CMD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:298
SD_CMD_ALL_SEND_CID
#define SD_CMD_ALL_SEND_CID
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:263
SD_CMD_STOP_TRANSMISSION
#define SD_CMD_STOP_TRANSMISSION
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:273
SD_CMD_SEND_STATUS
#define SD_CMD_SEND_STATUS
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:274
SD_CMD_SET_BLOCK_COUNT
#define SD_CMD_SET_BLOCK_COUNT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:282
SD_CMD_WRITE_DAT_UNTIL_STOP
#define SD_CMD_WRITE_DAT_UNTIL_STOP
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:281
SD_CMD_SEND_OP_COND
#define SD_CMD_SEND_OP_COND
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:262
SD_CMD_SET_BLOCKLEN
#define SD_CMD_SET_BLOCKLEN
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:277
SD_CMD_HS_SWITCH
#define SD_CMD_HS_SWITCH
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:267
SD_CMD_READ_SINGLE_BLOCK
#define SD_CMD_READ_SINGLE_BLOCK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:278
SD_CMD_SD_APP_OP_COND
#define SD_CMD_SD_APP_OP_COND
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:309
SD_CMD_GO_IDLE_STATE
#define SD_CMD_GO_IDLE_STATE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:261
SD_CMD_SET_REL_ADDR
#define SD_CMD_SET_REL_ADDR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:264
SD_CMD_ERASE_GRP_END
#define SD_CMD_ERASE_GRP_END
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:293
SD_CMD_READ_DAT_UNTIL_STOP
#define SD_CMD_READ_DAT_UNTIL_STOP
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:272
SD_CMD_SD_ERASE_GRP_END
#define SD_CMD_SD_ERASE_GRP_END
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:291
SD_CMD_ERASE_GRP_START
#define SD_CMD_ERASE_GRP_START
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:292
SD_CMD_SEL_DESEL_CARD
#define SD_CMD_SEL_DESEL_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:268
SD_CMD_WRITE_MULT_BLOCK
#define SD_CMD_WRITE_MULT_BLOCK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:284
SD_CMD_READ_MULT_BLOCK
#define SD_CMD_READ_MULT_BLOCK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:279
SD_CMD_SEND_CSD
#define SD_CMD_SEND_CSD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:270
sdio_command_config
void sdio_command_config(sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command.
Definition: at32f435_437_sdio.c:329
sdio_data_write
void sdio_data_write(sdio_type *sdio_x, uint32_t data)
write one word data to fifo.
Definition: at32f435_437_sdio.c:490
sdio_data_config
void sdio_data_config(sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data.
Definition: at32f435_437_sdio.c:416
sdio_data_read
uint32_t sdio_data_read(sdio_type *sdio_x)
read a word data from sdio fifo.
Definition: at32f435_437_sdio.c:465
sdio_command_state_machine_enable
void sdio_command_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM).
Definition: at32f435_437_sdio.c:352
sdio_clock_bypass
void sdio_clock_bypass(sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss
Definition: at32f435_437_sdio.c:141
sdio_flow_control_enable
void sdio_flow_control_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control.
Definition: at32f435_437_sdio.c:168
sdio_power_set
void sdio_power_set(sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller
Definition: at32f435_437_sdio.c:75
sdio_clock_config
void sdio_clock_config(sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock
Definition: at32f435_437_sdio.c:104
sdio_bus_width_config
void sdio_bus_width_config(sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width
Definition: at32f435_437_sdio.c:128
sdio_interrupt_enable
void sdio_interrupt_enable(sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt.
Definition: at32f435_437_sdio.c:232
sdio_flag_clear
void sdio_flag_clear(sdio_type *sdio_x, uint32_t flag)
clear sdio flag.
Definition: at32f435_437_sdio.c:315
sdio_power_status_get
sdio_power_state_type sdio_power_status_get(sdio_type *sdio_x)
get power status.
Definition: at32f435_437_sdio.c:87
sdio_response_get
uint32_t sdio_response_get(sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command.
Definition: at32f435_437_sdio.c:383
sdio_data_state_machine_enable
void sdio_data_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM).
Definition: at32f435_437_sdio.c:441
sdio_power_saving_mode_enable
void sdio_power_saving_mode_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle.
Definition: at32f435_437_sdio.c:155
sdio_flag_get
flag_status sdio_flag_get(sdio_type *sdio_x, uint32_t flag)
get sdio flag.
Definition: at32f435_437_sdio.c:278
sdio_dma_enable
void sdio_dma_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable dma.
Definition: at32f435_437_sdio.c:194
sdio_reset
void sdio_reset(sdio_type *sdio_x)
reset the sdio register
Definition: at32f435_437_sdio.c:51
sdio_clock_enable
void sdio_clock_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output.
Definition: at32f435_437_sdio.c:181
sdio_command_response_get
uint8_t sdio_command_response_get(sdio_type *sdio_x)
get command index of last command for which response received.
Definition: at32f435_437_sdio.c:365
sd_data_transfer_mode_type
sd_data_transfer_mode_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:66
sd_error_status_type
sd_error_status_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:75
sd_card_state_type
sd_card_state_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:188
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f435_437_sdio.h:139
sd_memory_card_type
sd_memory_card_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:204
sdio_block_size_type
sdio_block_size_type
sdio data block size
Definition: at32f435_437_sdio.h:180
SDIO_WAIT_FOR_NO
@ SDIO_WAIT_FOR_NO
Definition: at32f435_437_sdio.h:160
SDIO_WAIT_FOR_INT
@ SDIO_WAIT_FOR_INT
Definition: at32f435_437_sdio.h:161
SDIO_RESPONSE_LONG
@ SDIO_RESPONSE_LONG
Definition: at32f435_437_sdio.h:152
SDIO_RESPONSE_SHORT
@ SDIO_RESPONSE_SHORT
Definition: at32f435_437_sdio.h:151
SDIO_RESPONSE_NO
@ SDIO_RESPONSE_NO
Definition: at32f435_437_sdio.h:150
SD_TRANSFER_DMA_MODE
@ SD_TRANSFER_DMA_MODE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:68
SD_TRANSFER_POLLING_MODE
@ SD_TRANSFER_POLLING_MODE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:67
SD_ERROR
@ SD_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:119
SD_SDIO_UNKNOWN_FUNC
@ SD_SDIO_UNKNOWN_FUNC
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:109
SD_DATA_FAIL
@ SD_DATA_FAIL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:78
SD_INVALID_PARAMETER
@ SD_INVALID_PARAMETER
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:116
SD_CMD_FAIL
@ SD_CMD_FAIL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:77
SD_CMD_OUT_OF_RANGE
@ SD_CMD_OUT_OF_RANGE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:84
SD_GENERAL_UNKNOWN_ERROR
@ SD_GENERAL_UNKNOWN_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:95
SD_UNSUPPORTED_FEATURE
@ SD_UNSUPPORTED_FEATURE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:117
SD_TX_UNDERRUN
@ SD_TX_UNDERRUN
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:81
SD_ILLEGAL_CMD
@ SD_ILLEGAL_CMD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:92
SD_CMD_CRC_ERROR
@ SD_CMD_CRC_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:91
SD_RX_OVERRUN
@ SD_RX_OVERRUN
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:82
SD_REQ_NOT_APPLICABLE
@ SD_REQ_NOT_APPLICABLE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:115
SD_SWITCH_ERROR
@ SD_SWITCH_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:105
SD_INVALID_VOLTRANGE
@ SD_INVALID_VOLTRANGE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:103
SD_DATA_TIMEOUT
@ SD_DATA_TIMEOUT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:80
SD_START_BIT_ERR
@ SD_START_BIT_ERR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:83
SD_LOCK_UNLOCK_ERROR
@ SD_LOCK_UNLOCK_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:90
SD_CMD_RSP_TIMEOUT
@ SD_CMD_RSP_TIMEOUT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:79
SD_OK
@ SD_OK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:120
SDIO_CLOCK_EDGE_FALLING
@ SDIO_CLOCK_EDGE_FALLING
Definition: at32f435_437_sdio.h:132
SDIO_DATA_TRANSFER_TO_CARD
@ SDIO_DATA_TRANSFER_TO_CARD
Definition: at32f435_437_sdio.h:212
SDIO_DATA_TRANSFER_TO_CONTROLLER
@ SDIO_DATA_TRANSFER_TO_CONTROLLER
Definition: at32f435_437_sdio.h:213
SDIO_POWER_OFF
@ SDIO_POWER_OFF
Definition: at32f435_437_sdio.h:122
SDIO_POWER_ON
@ SDIO_POWER_ON
Definition: at32f435_437_sdio.h:123
SD_CARD_ERROR
@ SD_CARD_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:197
SDIO_DATA_BLOCK_TRANSFER
@ SDIO_DATA_BLOCK_TRANSFER
Definition: at32f435_437_sdio.h:203
SDIO_DATA_STREAM_TRANSFER
@ SDIO_DATA_STREAM_TRANSFER
Definition: at32f435_437_sdio.h:204
SDIO_BUS_WIDTH_D1
@ SDIO_BUS_WIDTH_D1
Definition: at32f435_437_sdio.h:140
SDIO_BUS_WIDTH_D4
@ SDIO_BUS_WIDTH_D4
Definition: at32f435_437_sdio.h:141
SDIO_RSP3_INDEX
@ SDIO_RSP3_INDEX
Definition: at32f435_437_sdio.h:172
SDIO_RSP2_INDEX
@ SDIO_RSP2_INDEX
Definition: at32f435_437_sdio.h:171
SDIO_RSP4_INDEX
@ SDIO_RSP4_INDEX
Definition: at32f435_437_sdio.h:173
SDIO_RSP1_INDEX
@ SDIO_RSP1_INDEX
Definition: at32f435_437_sdio.h:170
SDIO_HIGH_CAPACITY_SD_CARD
@ SDIO_HIGH_CAPACITY_SD_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:207
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
@ SDIO_SECURE_DIGITAL_IO_COMBO_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:211
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
@ SDIO_HIGH_SPEED_MULTIMEDIA_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:210
SDIO_STD_CAPACITY_SD_CARD_V1_1
@ SDIO_STD_CAPACITY_SD_CARD_V1_1
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:205
SDIO_SECURE_DIGITAL_IO_CARD
@ SDIO_SECURE_DIGITAL_IO_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:209
SDIO_STD_CAPACITY_SD_CARD_V2_0
@ SDIO_STD_CAPACITY_SD_CARD_V2_0
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:206
SDIO_MULTIMEDIA_CARD
@ SDIO_MULTIMEDIA_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:208
SDIO_DATA_BLOCK_SIZE_8B
@ SDIO_DATA_BLOCK_SIZE_8B
Definition: at32f435_437_sdio.h:184
SDIO_DATA_BLOCK_SIZE_1B
@ SDIO_DATA_BLOCK_SIZE_1B
Definition: at32f435_437_sdio.h:181
SDIO_CMDTIMEOUT_FLAG
#define SDIO_CMDTIMEOUT_FLAG
Definition: at32f435_437_sdio.h:87
SDIO_TXBUFH_FLAG
#define SDIO_TXBUFH_FLAG
Definition: at32f435_437_sdio.h:99
SDIO_CMDCMPL_FLAG
#define SDIO_CMDCMPL_FLAG
Definition: at32f435_437_sdio.h:92
SDIO_DTFAIL_FLAG
#define SDIO_DTFAIL_FLAG
Definition: at32f435_437_sdio.h:86
SDIO_RXERRO_FLAG
#define SDIO_RXERRO_FLAG
Definition: at32f435_437_sdio.h:90
SDIO_RXBUFH_FLAG
#define SDIO_RXBUFH_FLAG
Definition: at32f435_437_sdio.h:100
SDIO_RXBUF_FLAG
#define SDIO_RXBUF_FLAG
Definition: at32f435_437_sdio.h:106
SDIO_CMDFAIL_FLAG
#define SDIO_CMDFAIL_FLAG
Definition: at32f435_437_sdio.h:85
SDIO_CMDRSPCMPL_FLAG
#define SDIO_CMDRSPCMPL_FLAG
Definition: at32f435_437_sdio.h:91
SDIO_DTBLKCMPL_FLAG
#define SDIO_DTBLKCMPL_FLAG
Definition: at32f435_437_sdio.h:95
SDIO_DTTIMEOUT_FLAG
#define SDIO_DTTIMEOUT_FLAG
Definition: at32f435_437_sdio.h:88
SDIO_SBITERR_FLAG
#define SDIO_SBITERR_FLAG
Definition: at32f435_437_sdio.h:94
SDIO_DTCMPL_FLAG
#define SDIO_DTCMPL_FLAG
Definition: at32f435_437_sdio.h:93
SDIO_TXERRU_FLAG
#define SDIO_TXERRU_FLAG
Definition: at32f435_437_sdio.h:89
DMAMUX_SDIOx
#define DMAMUX_SDIOx
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:52
SDIOx
#define SDIOx
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:51
SDIO_INTR_STS_WRITE_MASK
#define SDIO_INTR_STS_WRITE_MASK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:477
SDIO_INTR_STS_READ_MASK
#define SDIO_INTR_STS_READ_MASK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:479
SDIO_SBITERR_INT
#define SDIO_SBITERR_INT
Definition: at32f435_437_sdio.h:61
SDIO_RXBUFH_INT
#define SDIO_RXBUFH_INT
Definition: at32f435_437_sdio.h:67
SDIO_DTTIMEOUT_INT
#define SDIO_DTTIMEOUT_INT
Definition: at32f435_437_sdio.h:55
SDIO_TXERRU_INT
#define SDIO_TXERRU_INT
Definition: at32f435_437_sdio.h:56
SDIO_RXERRO_INT
#define SDIO_RXERRO_INT
Definition: at32f435_437_sdio.h:57
SDIO_DTFAIL_INT
#define SDIO_DTFAIL_INT
Definition: at32f435_437_sdio.h:53
SDIO_TXBUFH_INT
#define SDIO_TXBUFH_INT
Definition: at32f435_437_sdio.h:66
SDIO_DTCMP_INT
#define SDIO_DTCMP_INT
Definition: at32f435_437_sdio.h:60
EXT_CSD_BUS_WIDTH
#define EXT_CSD_BUS_WIDTH
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:466
EXT_CSD_CMD_SET_NORMAL
#define EXT_CSD_CMD_SET_NORMAL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:459
EXT_CSD_Write_byte
#define EXT_CSD_Write_byte
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:457
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
SDIO_DATATIMEOUT
#define SDIO_DATATIMEOUT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:345
SDIO_CMD0TIMEOUT
#define SDIO_CMD0TIMEOUT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:344
SDIO_STATIC_FLAGS
#define SDIO_STATIC_FLAGS
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:343
SD_CARD_LOCKED
#define SD_CARD_LOCKED
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:403
SD_VOLTAGE_WINDOW_SD
#define SD_VOLTAGE_WINDOW_SD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:394
SD_R5_ERROR
#define SD_R5_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:386
SD_CARD_RECEIVING
#define SD_CARD_RECEIVING
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:405
SD_R5_OUT_OF_RANGE
#define SD_R5_OUT_OF_RANGE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:384
SD_MAX_DATA_LENGTH
#define SD_MAX_DATA_LENGTH
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:411
SD_STD_CAPACITY
#define SD_STD_CAPACITY
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:396
SD_R5_FUNCTION_NUMBER
#define SD_R5_FUNCTION_NUMBER
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:385
SD_R6_ILLEGAL_CMD
#define SD_R6_ILLEGAL_CMD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:392
SD_R6_GENERAL_UNKNOWN_ERROR
#define SD_R6_GENERAL_UNKNOWN_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:391
SD_MAX_VOLT_TRIAL
#define SD_MAX_VOLT_TRIAL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:399
SD_DATATIMEOUT
#define SD_DATATIMEOUT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:406
SD_ALLZERO
#define SD_ALLZERO
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:400
SD_R6_CMD_CRC_ERROR
#define SD_R6_CMD_CRC_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:393
MMC_SWITCH_ERROR
#define MMC_SWITCH_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:377
SD_VOLTAGE_WINDOW_MMC
#define SD_VOLTAGE_WINDOW_MMC
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:398
SD_CHECK_PATTERN
#define SD_CHECK_PATTERN
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:397
SD_OCR_ERRORBITS
#define SD_OCR_ERRORBITS
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:379
SD_CARD_PROGRAMMING
#define SD_CARD_PROGRAMMING
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:404
SD_HIGH_CAPACITY
#define SD_HIGH_CAPACITY
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:395
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
sd_card_info_struct_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:238
sd_card_info_struct_type::sd_scr_reg
sd_scr_struct_type sd_scr_reg
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:241
sd_card_info_struct_type::card_capacity
long long card_capacity
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:242
sd_card_info_struct_type::sd_cid_reg
sd_cid_struct_type sd_cid_reg
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:240
sd_card_info_struct_type::sd_csd_reg
sd_csd_struct_type sd_csd_reg
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:239
sd_card_info_struct_type::card_blk_size
uint32_t card_blk_size
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:243
sd_card_info_struct_type::rca
uint16_t rca
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:244
sd_card_info_struct_type::card_type
uint8_t card_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:245
sd_cid_struct_type::reserved1
uint8_t reserved1
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:178
sd_cid_struct_type::product_name2
uint8_t product_name2
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:175
sd_cid_struct_type::manufact_date
uint16_t manufact_date
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:179
sd_cid_struct_type::cid_crc
uint8_t cid_crc
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:180
sd_cid_struct_type::product_reversion
uint8_t product_reversion
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:176
sd_cid_struct_type::manufacturer_id
uint8_t manufacturer_id
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:172
sd_cid_struct_type::product_sn
uint32_t product_sn
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:177
sd_cid_struct_type::product_name1
uint32_t product_name1
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:174
sd_cid_struct_type::reserved2
uint8_t reserved2
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:181
sd_cid_struct_type::oem_app_id
uint16_t oem_app_id
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:173
sd_csd_struct_type::spec_version
uint8_t spec_version
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:129
sd_csd_struct_type::max_write_current_vdd_max
uint8_t max_write_current_vdd_max
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:145
sd_csd_struct_type::nsac
uint8_t nsac
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:132
sd_csd_struct_type::card_cmd_classes
uint16_t card_cmd_classes
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:134
sd_csd_struct_type::part_blk_read
uint8_t part_blk_read
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:136
sd_csd_struct_type::read_blk_misalign
uint8_t read_blk_misalign
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:138
sd_csd_struct_type::content_protect_app
uint8_t content_protect_app
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:156
sd_csd_struct_type::write_speed_factor
uint8_t write_speed_factor
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:152
sd_csd_struct_type::max_read_blk_length
uint8_t max_read_blk_length
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:135
sd_csd_struct_type::max_bus_clk_freq
uint8_t max_bus_clk_freq
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:133
sd_csd_struct_type::ecc_code
uint8_t ecc_code
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:162
sd_csd_struct_type::reserved4
uint8_t reserved4
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:164
sd_csd_struct_type::dsr_implemented
uint8_t dsr_implemented
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:139
sd_csd_struct_type::max_read_current_vdd_min
uint8_t max_read_current_vdd_min
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:142
sd_csd_struct_type::reserved2
uint8_t reserved2
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:140
sd_csd_struct_type::erase_group_size_mult
uint8_t erase_group_size_mult
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:148
sd_csd_struct_type::file_formart
uint8_t file_formart
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:161
sd_csd_struct_type::temp_write_protect
uint8_t temp_write_protect
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:160
sd_csd_struct_type::permanent_write_protect
uint8_t permanent_write_protect
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:159
sd_csd_struct_type::max_read_current_vdd_max
uint8_t max_read_current_vdd_max
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:143
sd_csd_struct_type::file_format_group
uint8_t file_format_group
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:157
sd_csd_struct_type::device_size
uint32_t device_size
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:141
sd_csd_struct_type::write_blk_misalign
uint8_t write_blk_misalign
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:137
sd_csd_struct_type::csd_struct
uint8_t csd_struct
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:128
sd_csd_struct_type::write_protect_group_enable
uint8_t write_protect_group_enable
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:150
sd_csd_struct_type::max_write_current_vdd_min
uint8_t max_write_current_vdd_min
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:144
sd_csd_struct_type::reserved1
uint8_t reserved1
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:130
sd_csd_struct_type::max_write_blk_length
uint8_t max_write_blk_length
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:153
sd_csd_struct_type::csd_crc
uint8_t csd_crc
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:163
sd_csd_struct_type::write_protect_group_size
uint8_t write_protect_group_size
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:149
sd_csd_struct_type::reserved3
uint8_t reserved3
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:155
sd_csd_struct_type::taac
uint8_t taac
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:131
sd_csd_struct_type::manufacturer_default_ecc
uint8_t manufacturer_default_ecc
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:151
sd_csd_struct_type::part_blk_write
uint8_t part_blk_write
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:154
sd_csd_struct_type::copy_flag
uint8_t copy_flag
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:158
sd_csd_struct_type::erase_group_size
uint8_t erase_group_size
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:147
sd_csd_struct_type::device_size_mult
uint8_t device_size_mult
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:146
sd_scr_struct_type::sd_bus_width
uint32_t sd_bus_width
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:223
sd_scr_struct_type::sd_spec
uint32_t sd_spec
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:221
sdio_command_struct_type
sdio command structure
Definition: at32f435_437_sdio.h:229
sdio_command_struct_type::cmd_index
uint8_t cmd_index
Definition: at32f435_437_sdio.h:231
sdio_command_struct_type::argument
uint32_t argument
Definition: at32f435_437_sdio.h:230
sdio_command_struct_type::wait_type
sdio_wait_type wait_type
Definition: at32f435_437_sdio.h:233
sdio_command_struct_type::rsp_type
sdio_reponse_type rsp_type
Definition: at32f435_437_sdio.h:232
sdio_data_struct_type
sdio data structure
Definition: at32f435_437_sdio.h:240
sdio_data_struct_type::block_size
sdio_block_size_type block_size
Definition: at32f435_437_sdio.h:243
sdio_data_struct_type::transfer_direction
sdio_transfer_direction_type transfer_direction
Definition: at32f435_437_sdio.h:245
sdio_data_struct_type::timeout
uint32_t timeout
Definition: at32f435_437_sdio.h:241
sdio_data_struct_type::transfer_mode
sdio_transfer_mode_type transfer_mode
Definition: at32f435_437_sdio.h:244
sdio_data_struct_type::data_length
uint32_t data_length
Definition: at32f435_437_sdio.h:242


AT32F435/437 Firmwary Library: at32_sdio.h File Reference

  • at_start_f435
  • examples
  • sdio
  • sdio_fatfs
  • inc
Data Structures | Macros | Enumerations | Functions | Variables
at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h File Reference

this file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library. More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct | sd_csd_struct_type
struct | sd_cid_struct_type
struct | sd_scr_struct_type
struct | sd_card_info_struct_type

Macros

#define | SDIOx SDIO1
#define | DMAMUX_SDIOx DMAMUX_DMAREQ_ID_SDIO1
#define | SD_CMD_GO_IDLE_STATE ((uint8_t)0)
#define | SD_CMD_SEND_OP_COND ((uint8_t)1)
#define | SD_CMD_ALL_SEND_CID ((uint8_t)2)
#define | SD_CMD_SET_REL_ADDR ((uint8_t)3)
#define | SD_CMD_SET_DSR ((uint8_t)4)
#define | SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)
#define | SD_CMD_HS_SWITCH ((uint8_t)6)
#define | SD_CMD_SEL_DESEL_CARD ((uint8_t)7)
#define | SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)
#define | SD_CMD_SEND_CSD ((uint8_t)9)
#define | SD_CMD_SEND_CID ((uint8_t)10)
#define | SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)
#define | SD_CMD_STOP_TRANSMISSION ((uint8_t)12)
#define | SD_CMD_SEND_STATUS ((uint8_t)13)
#define | SD_CMD_HS_BUSTEST_READ ((uint8_t)14)
#define | SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)
#define | SD_CMD_SET_BLOCKLEN ((uint8_t)16)
#define | SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)
#define | SD_CMD_READ_MULT_BLOCK ((uint8_t)18)
#define | SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)
#define | SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)
#define | SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)
#define | SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)
#define | SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)
#define | SD_CMD_PROG_CID ((uint8_t)26)
#define | SD_CMD_PROG_CSD ((uint8_t)27)
#define | SD_CMD_SET_WRITE_PROT ((uint8_t)28)
#define | SD_CMD_CLR_WRITE_PROT ((uint8_t)29)
#define | SD_CMD_SEND_WRITE_PROT ((uint8_t)30)
#define | SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)
#define | SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)
#define | SD_CMD_ERASE_GRP_START ((uint8_t)35)
#define | SD_CMD_ERASE_GRP_END ((uint8_t)36)
#define | SD_CMD_ERASE ((uint8_t)38)
#define | SD_CMD_FAST_IO ((uint8_t)39)
#define | SD_CMD_GO_IRQ_STATE ((uint8_t)40)
#define | SD_CMD_LOCK_UNLOCK ((uint8_t)42)
#define | SD_CMD_APP_CMD ((uint8_t)55)
#define | SD_CMD_GEN_CMD ((uint8_t)56)
#define | SD_CMD_NO_CMD ((uint8_t)64)
#define | SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)
#define | SD_CMD_SD_APP_STAUS ((uint8_t)13)
#define | SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)
#define | SD_CMD_SD_APP_OP_COND ((uint8_t)41)
#define | SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)
#define | SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)
#define | SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)
#define | SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)
#define | SD_CMD_SD_APP_GET_MKB ((uint8_t)43)
#define | SD_CMD_SD_APP_GET_MID ((uint8_t)44)
#define | SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)
#define | SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)
#define | SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)
#define | SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)
#define | SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)
#define | SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)
#define | SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)
#define | SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)
#define | SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)
#define | NULL 0
#define | SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)
#define | SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)
#define | SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SDIO_FIFO_Address ((uint32_t)0x40018080)
#define | SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)
#define | SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)
#define | SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)
#define | SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)
#define | SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)
#define | SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)
#define | SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)
#define | SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)
#define | SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)
#define | SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)
#define | SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)
#define | SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)
#define | SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)
#define | SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)
#define | SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)
#define | SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)
#define | SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)
#define | SD_OCR_ERASE_RESET ((uint32_t)0x00002000)
#define | MMC_SWITCH_ERROR ((uint32_t)0x00000080)
#define | SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)
#define | SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)
#define | SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)
#define | SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)
#define | SD_R5_ERROR ((uint32_t)0x00000800)
#define | SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)
#define | SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)
#define | SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)
#define | SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)
#define | SD_HIGH_CAPACITY ((uint32_t)0x40000000)
#define | SD_STD_CAPACITY ((uint32_t)0x00000000)
#define | SD_CHECK_PATTERN ((uint32_t)0x000001AA)
#define | SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)
#define | SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)
#define | SD_ALLZERO ((uint32_t)0x00000000)
#define | SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)
#define | SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)
#define | SD_CARD_LOCKED ((uint32_t)0x02000000)
#define | SD_CARD_PROGRAMMING ((uint32_t)0x00000007)
#define | SD_CARD_RECEIVING ((uint32_t)0x00000006)
#define | SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SD_0TO7BITS ((uint32_t)0x000000FF)
#define | SD_8TO15BITS ((uint32_t)0x0000FF00)
#define | SD_16TO23BITS ((uint32_t)0x00FF0000)
#define | SD_24TO31BITS ((uint32_t)0xFF000000)
#define | SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)
#define | SD_HALFFIFO ((uint32_t)0x00000008)
#define | SD_HALFFIFOBYTES ((uint32_t)0x00000020)
#define | SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)
#define | SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)
#define | SD_CCCC_ERASE ((uint32_t)0x00000020)
#define | SDIO_SEND_IF_COND ((uint32_t)0x00000008)
#define | EXT_CSD_Command_set 0x0
#define | EXT_CSD_Set_bit 0x1
#define | EXT_CSD_Clear_byte 0x2
#define | EXT_CSD_Write_byte 0x3
#define | EXT_CSD_CMD_SET_NORMAL (1<<0)
#define | EXT_CSD_CMD_SET_SECURE (1<<1)
#define | EXT_CSD_CMD_SET_CPSECURE (1<<2)
#define | EXT_CSD_BUS_WIDTH 183
#define | EXT_CSD_HS_TIMING 185
#define | SDIO_INTR_STS_WRITE_MASK
#define | SDIO_INTR_STS_READ_MASK

Enumerations

enum sd_data_transfer_mode_type {
SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 , SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 ,
SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 , SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1
}
enum sd_error_status_type {
SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 , SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 ,
SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 , SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 ,
SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 , SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 ,
SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 , SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 ,
SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 , SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 ,
SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 , SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 ,
SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 , SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 ,
SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 , SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 ,
SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR , SD_NOT_CONFIGURED , SD_REQ_PENDING ,
SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER , SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW ,
SD_ERROR , SD_OK = 0 , SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 ,
SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 , SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 ,
SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 , SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 ,
SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 , SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 ,
SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 , SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 ,
SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 , SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 ,
SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 , SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 ,
SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 , SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 ,
SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 , SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR ,
SD_NOT_CONFIGURED , SD_REQ_PENDING , SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER ,
SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW , SD_ERROR , SD_OK = 0 ,
SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 , SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 ,
SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 , SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 ,
SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 , SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 ,
SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 , SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 ,
SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 , SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 ,
SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 , SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 ,
SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 , SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 ,
SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 , SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 ,
SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR , SD_NOT_CONFIGURED , SD_REQ_PENDING ,
SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER , SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW ,
SD_ERROR , SD_OK = 0 , SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 ,
SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 , SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 ,
SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 , SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 ,
SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 , SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 ,
SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 , SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 ,
SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 , SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 ,
SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 , SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 ,
SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 , SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 ,
SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 , SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR ,
SD_NOT_CONFIGURED , SD_REQ_PENDING , SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER ,
SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW , SD_ERROR , SD_OK = 0
}
enum sd_card_state_type {
SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) ,
SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) ,
SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) ,
SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) ,
SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) ,
SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) ,
SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) ,
SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) ,
SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF)
}
enum sd_memory_card_type {
SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 ,
SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 ,
SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 ,
SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 ,
SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 ,
SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 ,
SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 ,
SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 ,
SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8
}

Functions

sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clkdiv)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...

Variables

sd_card_info_struct_type sd_card_info

Detailed Description

this file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library.

Version
v2.0.9
Date
2022-06-28
        Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h.


AT32F435/437 Firmwary Library: at32_sdio.h Source File

  • at_start_f435
  • examples
  • sdio
  • sdio_fatfs
  • inc
at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h
Go to the documentation of this file.
1
28/* define to prevent recursive inclusion -------------------------------------*/
29#ifndef __AT32_SDIO_H
30#define __AT32_SDIO_H
31
32#ifdef __cplusplus
33extern "C" {
34#endif
35
36/* includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
51#define SDIOx SDIO1
52#define DMAMUX_SDIOx DMAMUX_DMAREQ_ID_SDIO1
53
65typedef enum
66{
67 SD_TRANSFER_POLLING_MODE = 0,
68 SD_TRANSFER_DMA_MODE = 1
69} sd_data_transfer_mode_type;
70
74typedef enum
75{
76 /* sdio specific error defines ------------------------------------------*/
77 SD_CMD_FAIL = 1,
78 SD_DATA_FAIL = 2,
79 SD_CMD_RSP_TIMEOUT = 3,
80 SD_DATA_TIMEOUT = 4,
81 SD_TX_UNDERRUN = 5,
82 SD_RX_OVERRUN = 6,
83 SD_START_BIT_ERR = 7,
84 SD_CMD_OUT_OF_RANGE = 8,
85 SD_ADDR_MISALIGNED = 9,
86 SD_BLK_LEN_ERR = 10,
87 SD_ERASE_SEQ_ERR = 11,
88 SD_INVALID_ERASE_PARAM = 12,
89 SD_WR_PROTECT_VIOLATION = 13,
90 SD_LOCK_UNLOCK_ERROR = 14,
91 SD_CMD_CRC_ERROR = 15,
92 SD_ILLEGAL_CMD = 16,
93 SD_CARD_ECC_ERROR = 17,
94 SD_CARD_CONTROLLER_ERR = 18,
95 SD_GENERAL_UNKNOWN_ERROR = 19,
96 SD_STREAM_RD_UNDERRUN = 20,
97 SD_STREAM_WR_OVERRUN = 21,
98 SD_CID_CSD_OVERWRITE = 22,
99 SD_WP_ERASE_SKIP = 23,
100 SD_CARD_ECC_DISABLED = 24,
101 SD_ERASE_RESET = 25,
102 SD_AKE_SEQ_ERROR = 26,
103 SD_INVALID_VOLTRANGE = 27,
104 SD_ADDR_OUT_OF_RANGE = 28,
105 SD_SWITCH_ERROR = 29,
106 SD_SDIO_DISABLED = 30,
107 SD_SDIO_FUNC_BUSY = 31,
108 SD_SDIO_FUNC_ERROR = 32,
109 SD_SDIO_UNKNOWN_FUNC = 33,
111 /* standard error defines --------------------------------------------*/
112 SD_INTERNAL_ERROR,
113 SD_NOT_CONFIGURED,
114 SD_REQ_PENDING,
115 SD_REQ_NOT_APPLICABLE,
116 SD_INVALID_PARAMETER,
117 SD_UNSUPPORTED_FEATURE,
118 SD_UNSUPPORTED_HW,
119 SD_ERROR,
120 SD_OK = 0
121} sd_error_status_type;
122
126typedef struct
127{
128 uint8_t csd_struct;
129 uint8_t spec_version;
130 uint8_t reserved1;
131 uint8_t taac;
132 uint8_t nsac;
133 uint8_t max_bus_clk_freq;
134 uint16_t card_cmd_classes;
135 uint8_t max_read_blk_length;
136 uint8_t part_blk_read;
137 uint8_t write_blk_misalign;
138 uint8_t read_blk_misalign;
139 uint8_t dsr_implemented;
140 uint8_t reserved2;
141 uint32_t device_size;
142 uint8_t max_read_current_vdd_min;
143 uint8_t max_read_current_vdd_max;
144 uint8_t max_write_current_vdd_min;
145 uint8_t max_write_current_vdd_max;
146 uint8_t device_size_mult;
147 uint8_t erase_group_size;
148 uint8_t erase_group_size_mult;
149 uint8_t write_protect_group_size;
150 uint8_t write_protect_group_enable;
151 uint8_t manufacturer_default_ecc;
152 uint8_t write_speed_factor;
153 uint8_t max_write_blk_length;
154 uint8_t part_blk_write;
155 uint8_t reserved3;
156 uint8_t content_protect_app;
157 uint8_t file_format_group;
158 uint8_t copy_flag;
159 uint8_t permanent_write_protect;
160 uint8_t temp_write_protect;
161 uint8_t file_formart;
162 uint8_t ecc_code;
163 uint8_t csd_crc;
164 uint8_t reserved4;
165} sd_csd_struct_type;
166
170typedef struct
171{
172 uint8_t manufacturer_id;
173 uint16_t oem_app_id;
174 uint32_t product_name1;
175 uint8_t product_name2;
176 uint8_t product_reversion;
177 uint32_t product_sn;
178 uint8_t reserved1;
179 uint16_t manufact_date;
180 uint8_t cid_crc;
181 uint8_t reserved2;
182} sd_cid_struct_type;
183
187typedef enum
188{
189 SD_CARD_READY = ((uint32_t)0x00000001),
190 SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002),
191 SD_CARD_STANDBY = ((uint32_t)0x00000003),
192 SD_CARD_TRANSFER = ((uint32_t)0x00000004),
193 SD_CARD_SENDING = ((uint32_t)0x00000005),
194 SD_CARD_RECEIVING = ((uint32_t)0x00000006),
195 SD_CARD_PROGRAMMING = ((uint32_t)0x00000007),
196 SD_CARD_DISCONNECTED = ((uint32_t)0x00000008),
197 SD_CARD_ERROR = ((uint32_t)0x000000FF)
198} sd_card_state_type;
199
203typedef enum
204{
205 SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0,
206 SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1,
207 SDIO_HIGH_CAPACITY_SD_CARD = 2,
208 SDIO_MULTIMEDIA_CARD = 3,
209 SDIO_SECURE_DIGITAL_IO_CARD = 4,
210 SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5,
211 SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6,
212 SDIO_HIGH_CAPACITY_MMC_CARD = 7,
213 SDIO_SDIO_CARD = 8
214} sd_memory_card_type;
215
219typedef struct
220{
221 uint32_t sd_spec :4; /* [59:56] */
222 uint32_t scr_structure :4; /* [60:63] */
223 uint32_t sd_bus_width :4; /* [51:48] */
224 uint32_t sd_security :3; /* [52:54] */
225 uint32_t data_stat_after_erase :1; /* [55:55] */
226 uint32_t reserved1 :7; /* [46:40] */
227 uint32_t sd_spec3 :1; /* [47:47] */
228 uint32_t cmd20_support :1; /* [32:32] */
229 uint32_t cmd23_support :1; /* [33:33] */
230 uint32_t reserverd2 :6; /* [34:39] */
231 uint32_t reserverd3; /* [31:0] */
232} sd_scr_struct_type;
233
237typedef struct
238{
239 sd_csd_struct_type sd_csd_reg;
240 sd_cid_struct_type sd_cid_reg;
241 sd_scr_struct_type sd_scr_reg;
242 long long card_capacity;
243 uint32_t card_blk_size;
244 uint16_t rca;
245 uint8_t card_type;
246} sd_card_info_struct_type;
247
248extern sd_card_info_struct_type sd_card_info;
249
261#define SD_CMD_GO_IDLE_STATE ((uint8_t)0)
262#define SD_CMD_SEND_OP_COND ((uint8_t)1)
263#define SD_CMD_ALL_SEND_CID ((uint8_t)2)
264#define SD_CMD_SET_REL_ADDR ((uint8_t)3)
265#define SD_CMD_SET_DSR ((uint8_t)4)
266#define SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)
267#define SD_CMD_HS_SWITCH ((uint8_t)6)
268#define SD_CMD_SEL_DESEL_CARD ((uint8_t)7)
269#define SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)
270#define SD_CMD_SEND_CSD ((uint8_t)9)
271#define SD_CMD_SEND_CID ((uint8_t)10)
272#define SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)
273#define SD_CMD_STOP_TRANSMISSION ((uint8_t)12)
274#define SD_CMD_SEND_STATUS ((uint8_t)13)
275#define SD_CMD_HS_BUSTEST_READ ((uint8_t)14)
276#define SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)
277#define SD_CMD_SET_BLOCKLEN ((uint8_t)16)
278#define SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)
279#define SD_CMD_READ_MULT_BLOCK ((uint8_t)18)
280#define SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)
281#define SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)
282#define SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)
283#define SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)
284#define SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)
285#define SD_CMD_PROG_CID ((uint8_t)26)
286#define SD_CMD_PROG_CSD ((uint8_t)27)
287#define SD_CMD_SET_WRITE_PROT ((uint8_t)28)
288#define SD_CMD_CLR_WRITE_PROT ((uint8_t)29)
289#define SD_CMD_SEND_WRITE_PROT ((uint8_t)30)
290#define SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)
291#define SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)
292#define SD_CMD_ERASE_GRP_START ((uint8_t)35)
293#define SD_CMD_ERASE_GRP_END ((uint8_t)36)
294#define SD_CMD_ERASE ((uint8_t)38)
295#define SD_CMD_FAST_IO ((uint8_t)39)
296#define SD_CMD_GO_IRQ_STATE ((uint8_t)40)
297#define SD_CMD_LOCK_UNLOCK ((uint8_t)42)
298#define SD_CMD_APP_CMD ((uint8_t)55)
299#define SD_CMD_GEN_CMD ((uint8_t)56)
300#define SD_CMD_NO_CMD ((uint8_t)64)
301
306#define SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)
307#define SD_CMD_SD_APP_STAUS ((uint8_t)13)
308#define SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)
309#define SD_CMD_SD_APP_OP_COND ((uint8_t)41)
310#define SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)
311#define SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)
312#define SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)
313#define SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)
314
319#define SD_CMD_SD_APP_GET_MKB ((uint8_t)43)
320#define SD_CMD_SD_APP_GET_MID ((uint8_t)44)
321#define SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)
322#define SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)
323#define SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)
324#define SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)
325#define SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)
326#define SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)
327#define SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)
328#define SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)
329#define SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)
330
342#define NULL 0
343#define SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)
344#define SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)
345#define SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
346#define SDIO_FIFO_Address ((uint32_t)0x40018080)
347
359#define SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)
360#define SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)
361#define SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)
362#define SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)
363#define SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)
364#define SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)
365#define SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)
366#define SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)
367#define SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)
368#define SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)
369#define SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)
370#define SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)
371#define SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)
372#define SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)
373#define SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)
374#define SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)
375#define SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)
376#define SD_OCR_ERASE_RESET ((uint32_t)0x00002000)
377#define MMC_SWITCH_ERROR ((uint32_t)0x00000080)
378#define SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)
379#define SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)
380
384#define SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)
385#define SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)
386#define SD_R5_ERROR ((uint32_t)0x00000800)
387
391#define SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)
392#define SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)
393#define SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)
394#define SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)
395#define SD_HIGH_CAPACITY ((uint32_t)0x40000000)
396#define SD_STD_CAPACITY ((uint32_t)0x00000000)
397#define SD_CHECK_PATTERN ((uint32_t)0x000001AA)
398#define SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)
399#define SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)
400#define SD_ALLZERO ((uint32_t)0x00000000)
401#define SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)
402#define SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)
403#define SD_CARD_LOCKED ((uint32_t)0x02000000)
404#define SD_CARD_PROGRAMMING ((uint32_t)0x00000007)
405#define SD_CARD_RECEIVING ((uint32_t)0x00000006)
406#define SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
407#define SD_0TO7BITS ((uint32_t)0x000000FF)
408#define SD_8TO15BITS ((uint32_t)0x0000FF00)
409#define SD_16TO23BITS ((uint32_t)0x00FF0000)
410#define SD_24TO31BITS ((uint32_t)0xFF000000)
411#define SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)
412#define SD_HALFFIFO ((uint32_t)0x00000008)
413#define SD_HALFFIFOBYTES ((uint32_t)0x00000020)
414
426#define SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)
427#define SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)
428#define SD_CCCC_ERASE ((uint32_t)0x00000020)
429
441#define SDIO_SEND_IF_COND ((uint32_t)0x00000008)
442
454#define EXT_CSD_Command_set 0x0
455#define EXT_CSD_Set_bit 0x1
456#define EXT_CSD_Clear_byte 0x2
457#define EXT_CSD_Write_byte 0x3
458
459#define EXT_CSD_CMD_SET_NORMAL (1<<0)
460#define EXT_CSD_CMD_SET_SECURE (1<<1)
461#define EXT_CSD_CMD_SET_CPSECURE (1<<2)
462
466#define EXT_CSD_BUS_WIDTH 183
467#define EXT_CSD_HS_TIMING 185
468
477#define SDIO_INTR_STS_WRITE_MASK (SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_TXERRU_FLAG | \
478 SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
479#define SDIO_INTR_STS_READ_MASK (SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_RXERRO_FLAG | \
480 SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
489/* sd exported functions ----------------------------------------*/
490 sd_error_status_type sd_init(void);
491void sdio_clock_set(uint32_t clkdiv);
492 sd_error_status_type sd_power_on(void);
493 sd_error_status_type sd_power_off(void);
494 sd_error_status_type sd_card_init(void);
495 sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info);
496 sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode);
497 sd_error_status_type sd_device_mode_set(uint32_t mode);
498 sd_error_status_type sd_deselect_select(uint32_t addr);
499 sd_error_status_type sd_status_send(uint32_t *p_card_status);
500 sd_card_state_type sd_state_get(void);
501 sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks);
502 sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size);
503 sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks);
504 sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size);
505 sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks);
506 sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len);
507 sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len);
508 sd_error_status_type sd_irq_service(void);
509void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir);
510
523#ifdef __cplusplus
524}
525#endif
526
527#endif /* __AT32_SDIO_H */
528
at32f435_437.h
at32f435_437 header file
card_type
static sd_memory_card_type card_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:42
rca
static uint32_t rca
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:43
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f435_437_dma.h:151
sd_power_off
sd_error_status_type sd_power_off(void)
turns the sdio output signals off.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:403
sd_irq_service
sd_error_status_type sd_irq_service(void)
allows to process all the interrupts that are high.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1789
sd_device_mode_set
sd_error_status_type sd_device_mode_set(uint32_t mode)
set sdio work mode.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:786
sd_card_info_get
sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info)
returns information about specific card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:532
mmc_stream_write
sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1700
sd_card_init
sd_error_status_type sd_card_init(void)
intialises all cards or single card as the case may be card(s) come into standby state.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:417
sd_block_read
sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma ...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1188
sd_deselect_select
sd_error_status_type sd_deselect_select(uint32_t addr)
selects od deselects the corresponding card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:807
sdio_clock_set
void sdio_clock_set(uint32_t clkdiv)
set sdio clock devision factor.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:188
sd_blocks_erase
sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks)
erase continuous data block
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1030
sd_mult_blocks_write
sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed ...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1489
sd_state_get
sd_card_state_type sd_state_get(void)
returns information about sd card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:2489
sd_dma_config
void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:2706
sd_block_write
sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be manag...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1367
sd_status_send
sd_error_status_type sd_status_send(uint32_t *p_card_status)
read current card status.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:2452
sd_init
sd_error_status_type sd_init(void)
initializes the sd card and put it into standby state (ready for data transfer).
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:72
mmc_stream_read
sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1653
sd_power_on
sd_error_status_type sd_power_on(void)
enquires cards about their operating voltage and configures clock controls.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:203
sd_mult_blocks_read
sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mod...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1277
sd_wide_bus_operation_config
sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:743
sd_card_info
sd_card_info_struct_type sd_card_info
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:48
sd_data_transfer_mode_type
sd_data_transfer_mode_type
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:66
sd_error_status_type
sd_error_status_type
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:75
sd_card_state_type
sd_card_state_type
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:188
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f435_437_sdio.h:139
sd_memory_card_type
sd_memory_card_type
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:204
SD_TRANSFER_DMA_MODE
@ SD_TRANSFER_DMA_MODE
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:68
SD_TRANSFER_POLLING_MODE
@ SD_TRANSFER_POLLING_MODE
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:67
SD_ERROR
@ SD_ERROR
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:119
SD_WP_ERASE_SKIP
@ SD_WP_ERASE_SKIP
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:99
SD_SDIO_UNKNOWN_FUNC
@ SD_SDIO_UNKNOWN_FUNC
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:109
SD_DATA_FAIL
@ SD_DATA_FAIL
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:78
SD_STREAM_WR_OVERRUN
@ SD_STREAM_WR_OVERRUN
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:97
SD_INVALID_PARAMETER
@ SD_INVALID_PARAMETER
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:116
SD_CMD_FAIL
@ SD_CMD_FAIL
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:77
SD_CMD_OUT_OF_RANGE
@ SD_CMD_OUT_OF_RANGE
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:84
SD_UNSUPPORTED_HW
@ SD_UNSUPPORTED_HW
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:118
SD_SDIO_FUNC_ERROR
@ SD_SDIO_FUNC_ERROR
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:108
SD_INTERNAL_ERROR
@ SD_INTERNAL_ERROR
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:112
SD_INVALID_ERASE_PARAM
@ SD_INVALID_ERASE_PARAM
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:88
SD_GENERAL_UNKNOWN_ERROR
@ SD_GENERAL_UNKNOWN_ERROR
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:95
SD_CARD_ECC_DISABLED
@ SD_CARD_ECC_DISABLED
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:100
SD_CARD_CONTROLLER_ERR
@ SD_CARD_CONTROLLER_ERR
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:94
SD_ERASE_RESET
@ SD_ERASE_RESET
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:101
SD_CARD_ECC_ERROR
@ SD_CARD_ECC_ERROR
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:93
SD_STREAM_RD_UNDERRUN
@ SD_STREAM_RD_UNDERRUN
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:96
SD_UNSUPPORTED_FEATURE
@ SD_UNSUPPORTED_FEATURE
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:117
SD_TX_UNDERRUN
@ SD_TX_UNDERRUN
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:81
SD_ILLEGAL_CMD
@ SD_ILLEGAL_CMD
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:92
SD_SDIO_FUNC_BUSY
@ SD_SDIO_FUNC_BUSY
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:107
SD_CMD_CRC_ERROR
@ SD_CMD_CRC_ERROR
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:91
SD_ADDR_OUT_OF_RANGE
@ SD_ADDR_OUT_OF_RANGE
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:104
SD_RX_OVERRUN
@ SD_RX_OVERRUN
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:82
SD_REQ_PENDING
@ SD_REQ_PENDING
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:114
SD_REQ_NOT_APPLICABLE
@ SD_REQ_NOT_APPLICABLE
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:115
SD_SWITCH_ERROR
@ SD_SWITCH_ERROR
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:105
SD_INVALID_VOLTRANGE
@ SD_INVALID_VOLTRANGE
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:103
SD_SDIO_DISABLED
@ SD_SDIO_DISABLED
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:106
SD_DATA_TIMEOUT
@ SD_DATA_TIMEOUT
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:80
SD_ADDR_MISALIGNED
@ SD_ADDR_MISALIGNED
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:85
SD_START_BIT_ERR
@ SD_START_BIT_ERR
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:83
SD_LOCK_UNLOCK_ERROR
@ SD_LOCK_UNLOCK_ERROR
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:90
SD_NOT_CONFIGURED
@ SD_NOT_CONFIGURED
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:113
SD_CID_CSD_OVERWRITE
@ SD_CID_CSD_OVERWRITE
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:98
SD_WR_PROTECT_VIOLATION
@ SD_WR_PROTECT_VIOLATION
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:89
SD_CMD_RSP_TIMEOUT
@ SD_CMD_RSP_TIMEOUT
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:79
SD_BLK_LEN_ERR
@ SD_BLK_LEN_ERR
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:86
SD_OK
@ SD_OK
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:120
SD_ERASE_SEQ_ERR
@ SD_ERASE_SEQ_ERR
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:87
SD_AKE_SEQ_ERROR
@ SD_AKE_SEQ_ERROR
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:102
SD_CARD_TRANSFER
@ SD_CARD_TRANSFER
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:192
SD_CARD_IDENTIFICATION
@ SD_CARD_IDENTIFICATION
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:190
SD_CARD_SENDING
@ SD_CARD_SENDING
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:193
SD_CARD_STANDBY
@ SD_CARD_STANDBY
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:191
SD_CARD_READY
@ SD_CARD_READY
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:189
SD_CARD_DISCONNECTED
@ SD_CARD_DISCONNECTED
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:196
SD_CARD_ERROR
@ SD_CARD_ERROR
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:197
SDIO_SDIO_CARD
@ SDIO_SDIO_CARD
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:213
SDIO_HIGH_CAPACITY_SD_CARD
@ SDIO_HIGH_CAPACITY_SD_CARD
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:207
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
@ SDIO_SECURE_DIGITAL_IO_COMBO_CARD
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:211
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
@ SDIO_HIGH_SPEED_MULTIMEDIA_CARD
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:210
SDIO_STD_CAPACITY_SD_CARD_V1_1
@ SDIO_STD_CAPACITY_SD_CARD_V1_1
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:205
SDIO_SECURE_DIGITAL_IO_CARD
@ SDIO_SECURE_DIGITAL_IO_CARD
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:209
SDIO_STD_CAPACITY_SD_CARD_V2_0
@ SDIO_STD_CAPACITY_SD_CARD_V2_0
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:206
SDIO_MULTIMEDIA_CARD
@ SDIO_MULTIMEDIA_CARD
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:208
SDIO_HIGH_CAPACITY_MMC_CARD
@ SDIO_HIGH_CAPACITY_MMC_CARD
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:212
SD_CARD_RECEIVING
#define SD_CARD_RECEIVING
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:405
SD_CARD_PROGRAMMING
#define SD_CARD_PROGRAMMING
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h:404
sd_card_info_struct_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:238
sd_cid_struct_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:171
sd_csd_struct_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:127
sd_scr_struct_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:220


AT32F435/437 Firmwary Library: ffconf.h File Reference

  • at_start_f435
  • examples
  • sdio
  • sdio_fatfs
  • inc
Macros
at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h File Reference

Go to the source code of this file.

Macros

#define | FFCONF_DEF 86631 /* Revision ID */
#define | FF_FS_READONLY 0
#define | FF_FS_MINIMIZE 0
#define | FF_USE_FIND 0
#define | FF_USE_MKFS 1
#define | FF_USE_FASTSEEK 1
#define | FF_USE_EXPAND 0
#define | FF_USE_CHMOD 0
#define | FF_USE_LABEL 0
#define | FF_USE_FORWARD 0
#define | FF_USE_STRFUNC 0
#define | FF_PRINT_LLI 0
#define | FF_PRINT_FLOAT 0
#define | FF_STRF_ENCODE 0
#define | FF_CODE_PAGE 932
#define | FF_USE_LFN 0
#define | FF_MAX_LFN 255
#define | FF_LFN_UNICODE 0
#define | FF_LFN_BUF 255
#define | FF_SFN_BUF 12
#define | FF_FS_RPATH 0
#define | FF_VOLUMES 3
#define | FF_STR_VOLUME_ID 0
#define | FF_VOLUME_STRS "RAM","NAND","CF","SD","SD2","USB","USB2","USB3"
#define | FF_MULTI_PARTITION 0
#define | FF_MIN_SS 512
#define | FF_MAX_SS 512
#define | FF_LBA64 0
#define | FF_MIN_GPT 0x10000000
#define | FF_USE_TRIM 0
#define | FF_FS_TINY 0
#define | FF_FS_EXFAT 0
#define | FF_FS_NORTC 1
#define | FF_NORTC_MON 1
#define | FF_NORTC_MDAY 1
#define | FF_NORTC_YEAR 2020
#define | FF_FS_NOFSINFO 0
#define | FF_FS_LOCK 0
#define | FF_FS_REENTRANT 0
#define | FF_FS_TIMEOUT 1000
#define | FF_SYNC_t HANDLE

Macro Definition Documentation

◆ FF_CODE_PAGE

#define FF_CODE_PAGE 932

Definition at line 87 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_FS_EXFAT

#define FF_FS_EXFAT 0

Definition at line 234 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_FS_LOCK

#define FF_FS_LOCK 0

Definition at line 266 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_FS_MINIMIZE

#define FF_FS_MINIMIZE 0

Definition at line 18 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_FS_NOFSINFO

#define FF_FS_NOFSINFO 0

Definition at line 254 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_FS_NORTC

#define FF_FS_NORTC 1

Definition at line 240 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_FS_READONLY

#define FF_FS_READONLY 0

Definition at line 11 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_FS_REENTRANT

#define FF_FS_REENTRANT 0

Definition at line 279 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_FS_RPATH

#define FF_FS_RPATH 0

Definition at line 156 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_FS_TIMEOUT

#define FF_FS_TIMEOUT 1000

Definition at line 280 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_FS_TINY

#define FF_FS_TINY 0

Definition at line 227 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_LBA64

#define FF_LBA64 0

Definition at line 206 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_LFN_BUF

#define FF_LFN_BUF 255

Definition at line 148 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_LFN_UNICODE

#define FF_LFN_UNICODE 0

Definition at line 136 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_MAX_LFN

#define FF_MAX_LFN 255

Definition at line 117 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_MAX_SS

#define FF_MAX_SS 512

Definition at line 197 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_MIN_GPT

#define FF_MIN_GPT 0x10000000

Definition at line 211 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_MIN_SS

#define FF_MIN_SS 512

Definition at line 196 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_MULTI_PARTITION

#define FF_MULTI_PARTITION 0

Definition at line 187 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_NORTC_MDAY

#define FF_NORTC_MDAY 1

Definition at line 242 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_NORTC_MON

#define FF_NORTC_MON 1

Definition at line 241 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_NORTC_YEAR

#define FF_NORTC_YEAR 2020

Definition at line 243 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_PRINT_FLOAT

#define FF_PRINT_FLOAT 0

Definition at line 61 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_PRINT_LLI

#define FF_PRINT_LLI 0

Definition at line 60 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_SFN_BUF

#define FF_SFN_BUF 12

Definition at line 149 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_STR_VOLUME_ID

#define FF_STR_VOLUME_ID 0

Definition at line 173 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_STRF_ENCODE

#define FF_STRF_ENCODE 0

Definition at line 62 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_SYNC_t

#define FF_SYNC_t HANDLE

Definition at line 281 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_USE_CHMOD

#define FF_USE_CHMOD 0

Definition at line 45 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_USE_EXPAND

#define FF_USE_EXPAND 0

Definition at line 41 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_USE_FASTSEEK

#define FF_USE_FASTSEEK 1

Definition at line 37 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_USE_FIND

#define FF_USE_FIND 0

Definition at line 28 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_USE_FORWARD

#define FF_USE_FORWARD 0

Definition at line 55 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_USE_LABEL

#define FF_USE_LABEL 0

Definition at line 50 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_USE_LFN

#define FF_USE_LFN 0

Definition at line 116 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_USE_MKFS

#define FF_USE_MKFS 1

Definition at line 33 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_USE_STRFUNC

#define FF_USE_STRFUNC 0

Definition at line 59 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_USE_TRIM

#define FF_USE_TRIM 0

Definition at line 216 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_VOLUME_STRS

#define FF_VOLUME_STRS "RAM","NAND","CF","SD","SD2","USB","USB2","USB3"

Definition at line 174 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_VOLUMES

#define FF_VOLUMES 3

Definition at line 169 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FFCONF_DEF

#define FFCONF_DEF 86631 /* Revision ID */

Definition at line 5 of file at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h.


AT32F435/437 Firmwary Library: ffconf.h Source File

  • at_start_f435
  • examples
  • sdio
  • sdio_fatfs
  • inc
at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h
Go to the documentation of this file.
1/*---------------------------------------------------------------------------/
2/ FatFs Functional Configurations
3/---------------------------------------------------------------------------*/
4
5#define FFCONF_DEF 86631 /* Revision ID */
6
7/*---------------------------------------------------------------------------/
8/ Function Configurations
9/---------------------------------------------------------------------------*/
10
11#define FF_FS_READONLY 0
12/* This option switches read-only configuration. (0:Read/Write or 1:Read-only)
13/ Read-only configuration removes writing API functions, f_write(), f_sync(),
14/ f_unlink(), f_mkdir(), f_chmod(), f_rename(), f_truncate(), f_getfree()
15/ and optional writing functions as well. */
16
17
18#define FF_FS_MINIMIZE 0
19/* This option defines minimization level to remove some basic API functions.
20/
21/ 0: Basic functions are fully enabled.
22/ 1: f_stat(), f_getfree(), f_unlink(), f_mkdir(), f_truncate() and f_rename()
23/ are removed.
24/ 2: f_opendir(), f_readdir() and f_closedir() are removed in addition to 1.
25/ 3: f_lseek() function is removed in addition to 2. */
26
27
28#define FF_USE_FIND 0
29/* This option switches filtered directory read functions, f_findfirst() and
30/ f_findnext(). (0:Disable, 1:Enable 2:Enable with matching altname[] too) */
31
32
33#define FF_USE_MKFS 1//0
34/* This option switches f_mkfs() function. (0:Disable or 1:Enable) */
35
36
37#define FF_USE_FASTSEEK 1//0
38/* This option switches fast seek function. (0:Disable or 1:Enable) */
39
40
41#define FF_USE_EXPAND 0
42/* This option switches f_expand function. (0:Disable or 1:Enable) */
43
44
45#define FF_USE_CHMOD 0
46/* This option switches attribute manipulation functions, f_chmod() and f_utime().
47/ (0:Disable or 1:Enable) Also FF_FS_READONLY needs to be 0 to enable this option. */
48
49
50#define FF_USE_LABEL 0
51/* This option switches volume label functions, f_getlabel() and f_setlabel().
52/ (0:Disable or 1:Enable) */
53
54
55#define FF_USE_FORWARD 0
56/* This option switches f_forward() function. (0:Disable or 1:Enable) */
57
58
59#define FF_USE_STRFUNC 0
60#define FF_PRINT_LLI 0
61#define FF_PRINT_FLOAT 0
62#define FF_STRF_ENCODE 0
63/* FF_USE_STRFUNC switches string functions, f_gets(), f_putc(), f_puts() and
64/ f_printf().
65/
66/ 0: Disable. FF_PRINT_LLI, FF_PRINT_FLOAT and FF_STRF_ENCODE have no effect.
67/ 1: Enable without LF-CRLF conversion.
68/ 2: Enable with LF-CRLF conversion.
69/
70/ FF_PRINT_LLI = 1 makes f_printf() support long long argument and FF_PRINT_FLOAT = 1/2
71 makes f_printf() support floating point argument. These features want C99 or later.
72/ When FF_LFN_UNICODE >= 1 with LFN enabled, string functions convert the character
73/ encoding in it. FF_STRF_ENCODE selects assumption of character encoding ON THE FILE
74/ to be read/written via those functions.
75/
76/ 0: ANSI/OEM in current CP
77/ 1: Unicode in UTF-16LE
78/ 2: Unicode in UTF-16BE
79/ 3: Unicode in UTF-8
80*/
81
82
83/*---------------------------------------------------------------------------/
84/ Locale and Namespace Configurations
85/---------------------------------------------------------------------------*/
86
87#define FF_CODE_PAGE 932
88/* This option specifies the OEM code page to be used on the target system.
89/ Incorrect code page setting can cause a file open failure.
90/
91/ 437 - U.S.
92/ 720 - Arabic
93/ 737 - Greek
94/ 771 - KBL
95/ 775 - Baltic
96/ 850 - Latin 1
97/ 852 - Latin 2
98/ 855 - Cyrillic
99/ 857 - Turkish
100/ 860 - Portuguese
101/ 861 - Icelandic
102/ 862 - Hebrew
103/ 863 - Canadian French
104/ 864 - Arabic
105/ 865 - Nordic
106/ 866 - Russian
107/ 869 - Greek 2
108/ 932 - Japanese (DBCS)
109/ 936 - Simplified Chinese (DBCS)
110/ 949 - Korean (DBCS)
111/ 950 - Traditional Chinese (DBCS)
112/ 0 - Include all code pages above and configured by f_setcp()
113*/
114
115
116#define FF_USE_LFN 0
117#define FF_MAX_LFN 255
118/* The FF_USE_LFN switches the support for LFN (long file name).
119/
120/ 0: Disable LFN. FF_MAX_LFN has no effect.
121/ 1: Enable LFN with static working buffer on the BSS. Always NOT thread-safe.
122/ 2: Enable LFN with dynamic working buffer on the STACK.
123/ 3: Enable LFN with dynamic working buffer on the HEAP.
124/
125/ To enable the LFN, ffunicode.c needs to be added to the project. The LFN function
126/ requiers certain internal working buffer occupies (FF_MAX_LFN + 1) * 2 bytes and
127/ additional (FF_MAX_LFN + 44) / 15 * 32 bytes when exFAT is enabled.
128/ The FF_MAX_LFN defines size of the working buffer in UTF-16 code unit and it can
129/ be in range of 12 to 255. It is recommended to be set it 255 to fully support LFN
130/ specification.
131/ When use stack for the working buffer, take care on stack overflow. When use heap
132/ memory for the working buffer, memory management functions, ff_memalloc() and
133/ ff_memfree() exemplified in ffsystem.c, need to be added to the project. */
134
135
136#define FF_LFN_UNICODE 0
137/* This option switches the character encoding on the API when LFN is enabled.
138/
139/ 0: ANSI/OEM in current CP (TCHAR = char)
140/ 1: Unicode in UTF-16 (TCHAR = WCHAR)
141/ 2: Unicode in UTF-8 (TCHAR = char)
142/ 3: Unicode in UTF-32 (TCHAR = DWORD)
143/
144/ Also behavior of string I/O functions will be affected by this option.
145/ When LFN is not enabled, this option has no effect. */
146
147
148#define FF_LFN_BUF 255
149#define FF_SFN_BUF 12
150/* This set of options defines size of file name members in the FILINFO structure
151/ which is used to read out directory items. These values should be suffcient for
152/ the file names to read. The maximum possible length of the read file name depends
153/ on character encoding. When LFN is not enabled, these options have no effect. */
154
155
156#define FF_FS_RPATH 0
157/* This option configures support for relative path.
158/
159/ 0: Disable relative path and remove related functions.
160/ 1: Enable relative path. f_chdir() and f_chdrive() are available.
161/ 2: f_getcwd() function is available in addition to 1.
162*/
163
164
165/*---------------------------------------------------------------------------/
166/ Drive/Volume Configurations
167/---------------------------------------------------------------------------*/
168
169#define FF_VOLUMES 3//1
170/* Number of volumes (logical drives) to be used. (1-10) */
171
172
173#define FF_STR_VOLUME_ID 0
174#define FF_VOLUME_STRS "RAM","NAND","CF","SD","SD2","USB","USB2","USB3"
175/* FF_STR_VOLUME_ID switches support for volume ID in arbitrary strings.
176/ When FF_STR_VOLUME_ID is set to 1 or 2, arbitrary strings can be used as drive
177/ number in the path name. FF_VOLUME_STRS defines the volume ID strings for each
178/ logical drives. Number of items must not be less than FF_VOLUMES. Valid
179/ characters for the volume ID strings are A-Z, a-z and 0-9, however, they are
180/ compared in case-insensitive. If FF_STR_VOLUME_ID >= 1 and FF_VOLUME_STRS is
181/ not defined, a user defined volume string table needs to be defined as:
182/
183/ const char* VolumeStr[FF_VOLUMES] = {"ram","flash","sd","usb",...
184*/
185
186
187#define FF_MULTI_PARTITION 0
188/* This option switches support for multiple volumes on the physical drive.
189/ By default (0), each logical drive number is bound to the same physical drive
190/ number and only an FAT volume found on the physical drive will be mounted.
191/ When this function is enabled (1), each logical drive number can be bound to
192/ arbitrary physical drive and partition listed in the VolToPart[]. Also f_fdisk()
193/ funciton will be available. */
194
195
196#define FF_MIN_SS 512
197#define FF_MAX_SS 512
198/* This set of options configures the range of sector size to be supported. (512,
199/ 1024, 2048 or 4096) Always set both 512 for most systems, generic memory card and
200/ harddisk, but a larger value may be required for on-board flash memory and some
201/ type of optical media. When FF_MAX_SS is larger than FF_MIN_SS, FatFs is configured
202/ for variable sector size mode and disk_ioctl() function needs to implement
203/ GET_SECTOR_SIZE command. */
204
205
206#define FF_LBA64 0
207/* This option switches support for 64-bit LBA. (0:Disable or 1:Enable)
208/ To enable the 64-bit LBA, also exFAT needs to be enabled. (FF_FS_EXFAT == 1) */
209
210
211#define FF_MIN_GPT 0x10000000
212/* Minimum number of sectors to switch GPT as partitioning format in f_mkfs and
213/ f_fdisk function. 0x100000000 max. This option has no effect when FF_LBA64 == 0. */
214
215
216#define FF_USE_TRIM 0
217/* This option switches support for ATA-TRIM. (0:Disable or 1:Enable)
218/ To enable Trim function, also CTRL_TRIM command should be implemented to the
219/ disk_ioctl() function. */
220
221
222
223/*---------------------------------------------------------------------------/
224/ System Configurations
225/---------------------------------------------------------------------------*/
226
227#define FF_FS_TINY 0
228/* This option switches tiny buffer configuration. (0:Normal or 1:Tiny)
229/ At the tiny configuration, size of file object (FIL) is shrinked FF_MAX_SS bytes.
230/ Instead of private sector buffer eliminated from the file object, common sector
231/ buffer in the filesystem object (FATFS) is used for the file data transfer. */
232
233
234#define FF_FS_EXFAT 0
235/* This option switches support for exFAT filesystem. (0:Disable or 1:Enable)
236/ To enable exFAT, also LFN needs to be enabled. (FF_USE_LFN >= 1)
237/ Note that enabling exFAT discards ANSI C (C89) compatibility. */
238
239
240#define FF_FS_NORTC 1//0
241#define FF_NORTC_MON 1
242#define FF_NORTC_MDAY 1
243#define FF_NORTC_YEAR 2020
244/* The option FF_FS_NORTC switches timestamp functiton. If the system does not have
245/ any RTC function or valid timestamp is not needed, set FF_FS_NORTC = 1 to disable
246/ the timestamp function. Every object modified by FatFs will have a fixed timestamp
247/ defined by FF_NORTC_MON, FF_NORTC_MDAY and FF_NORTC_YEAR in local time.
248/ To enable timestamp function (FF_FS_NORTC = 0), get_fattime() function need to be
249/ added to the project to read current time form real-time clock. FF_NORTC_MON,
250/ FF_NORTC_MDAY and FF_NORTC_YEAR have no effect.
251/ These options have no effect in read-only configuration (FF_FS_READONLY = 1). */
252
253
254#define FF_FS_NOFSINFO 0
255/* If you need to know correct free space on the FAT32 volume, set bit 0 of this
256/ option, and f_getfree() function at first time after volume mount will force
257/ a full FAT scan. Bit 1 controls the use of last allocated cluster number.
258/
259/ bit0=0: Use free cluster count in the FSINFO if available.
260/ bit0=1: Do not trust free cluster count in the FSINFO.
261/ bit1=0: Use last allocated cluster number in the FSINFO if available.
262/ bit1=1: Do not trust last allocated cluster number in the FSINFO.
263*/
264
265
266#define FF_FS_LOCK 0
267/* The option FF_FS_LOCK switches file lock function to control duplicated file open
268/ and illegal operation to open objects. This option must be 0 when FF_FS_READONLY
269/ is 1.
270/
271/ 0: Disable file lock function. To avoid volume corruption, application program
272/ should avoid illegal open, remove and rename to the open objects.
273/ >0: Enable file lock function. The value defines how many files/sub-directories
274/ can be opened simultaneously under file lock control. Note that the file
275/ lock control is independent of re-entrancy. */
276
277
278/* #include <somertos.h> // O/S definitions */
279#define FF_FS_REENTRANT 0
280#define FF_FS_TIMEOUT 1000
281#define FF_SYNC_t HANDLE
282/* The option FF_FS_REENTRANT switches the re-entrancy (thread safe) of the FatFs
283/ module itself. Note that regardless of this option, file access to different
284/ volume is always re-entrant and volume control functions, f_mount(), f_mkfs()
285/ and f_fdisk() function, are always not re-entrant. Only file/directory access
286/ to the same volume is under control of this function.
287/
288/ 0: Disable re-entrancy. FF_FS_TIMEOUT and FF_SYNC_t have no effect.
289/ 1: Enable re-entrancy. Also user provided synchronization handlers,
290/ ff_req_grant(), ff_rel_grant(), ff_del_syncobj() and ff_cre_syncobj()
291/ function, must be added to the project. Samples are available in
292/ option/syscall.c.
293/
294/ The FF_FS_TIMEOUT defines timeout period in unit of time tick.
295/ The FF_SYNC_t defines O/S dependent sync object type. e.g. HANDLE, ID, OS_EVENT*,
296/ SemaphoreHandle_t and etc. A header file for O/S definitions needs to be
297/ included somewhere in the scope of ff.h. */
298
299
300
301/*--- End of configuration options ---*/


AT32F435/437 Firmwary Library: at32_sdio.c File Reference

  • at_start_f435
  • examples
  • sdio
  • sdio_fatfs
  • src
Functions | Variables
at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c File Reference

this file provides a set of functions needed to manage the sdio/mmc card memory. More...

#include <string.h>
#include "at32_sdio.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

sd_error_status_type | command_error (void)
checks for error conditions for cmd0. More...
sd_error_status_type | command_rsp1_error (uint8_t cmd)
checks for error conditions for R1 response. More...
sd_error_status_type | command_rsp2_error (void)
checks for error conditions for R2 (cid or csd) response. More...
sd_error_status_type | command_rsp3_error (void)
checks for error conditions for R3 (ocr) response. More...
sd_error_status_type | command_rsp4_error (uint8_t cmd)
checks for error conditions for r4 response. More...
sd_error_status_type | command_rsp5_error (uint8_t cmd)
checks for error conditions for r5 response. More...
sd_error_status_type | command_rsp6_error (uint8_t cmd, uint16_t *prca)
checks for error conditions for r6 (rca) response. More...
sd_error_status_type | command_rsp7_error (void)
checks for error conditions for R7 response. More...
sd_error_status_type | sd_bus_wide_enable (confirm_state new_state)
enable or disable the sdio wide bus mode. More...
sd_error_status_type | mmc_switch (uint8_t set, uint8_t index, uint8_t value)
switch mmc card speed to high speed More...
sd_error_status_type | sd_switch (uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
switch sd card speed to high speed More...
sd_error_status_type | check_card_programming (uint8_t *p_status)
checks if the sd card is in programming state. More...
sd_error_status_type | speed_change (uint8_t speed)
set bus speed More...
sd_error_status_type | scr_find (void)
find the sd card scr register value. More...
uint8_t | convert_from_bytes_to_power_of_two (uint16_t number_of_bytes)
converts the number of bytes in power of two and returns the power. More...
sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clk_div)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sdio_command_data_send (sdio_command_struct_type *sdio_cmd_init_t, sdio_data_struct_type *sdio_data_init_t, uint32_t *buf)
read data from or write data to sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
void | SDIO1_IRQHandler (void)
sdio1 isr. More...
void | SDIO2_IRQHandler (void)
sdio2 isr. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...

Variables

sdio_command_struct_type sdio_command_init_struct
sdio_data_struct_type sdio_data_init_struct
static sd_memory_card_type | card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1
static uint32_t | csd_table [4]
static uint32_t | cid_table [4]
static uint32_t | rca = 0
static sd_data_transfer_mode_type | device_mode = SD_TRANSFER_POLLING_MODE
static uint8_t | stop_flag = 0
volatile sd_error_status_type | transfer_error = SD_OK
volatile uint8_t | transfer_end = 0
sd_card_info_struct_type sd_card_info

Detailed Description

this file provides a set of functions needed to manage the sdio/mmc card memory.

Version
v2.0.9
Date
2022-06-28
        Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c.


AT32F435/437 Firmwary Library: at32_sdio.c Source File

  • at_start_f435
  • examples
  • sdio
  • sdio_fatfs
  • src
at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
Go to the documentation of this file.
1
28#include <string.h>
29#include "at32_sdio.h"
30#include "at32f435_437_board.h"
31
40 sdio_command_struct_type sdio_command_init_struct;
41 sdio_data_struct_type sdio_data_init_struct;
42
43static sd_memory_card_type card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1; /* sd card type */
44static uint32_t csd_table[4], cid_table[4], rca = 0; /* csd, sid, rca */
45static sd_data_transfer_mode_type device_mode = SD_TRANSFER_POLLING_MODE; /* working mode */
46static uint8_t stop_flag = 0; /* transmit stop flag */
47volatile sd_error_status_type transfer_error = SD_OK; /* transmit error flag */
48volatile uint8_t transfer_end = 0; /* transmit end flag */
49 sd_card_info_struct_type sd_card_info; /* sd card information */
50
51 sd_error_status_type command_error(void);
52 sd_error_status_type command_rsp1_error(uint8_t cmd);
53 sd_error_status_type command_rsp2_error(void);
54 sd_error_status_type command_rsp3_error(void);
55 sd_error_status_type command_rsp4_error(uint8_t cmd);
56 sd_error_status_type command_rsp5_error(uint8_t cmd);
57 sd_error_status_type command_rsp6_error(uint8_t cmd, uint16_t *p_rca);
58 sd_error_status_type command_rsp7_error(void);
59 sd_error_status_type sd_bus_wide_enable(confirm_state new_state);
60 sd_error_status_type mmc_switch(uint8_t set, uint8_t index, uint8_t value);
61 sd_error_status_type sd_switch(uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp);
62 sd_error_status_type check_card_programming(uint8_t *p_status);
63 sd_error_status_type speed_change(uint8_t speed);
64 sd_error_status_type scr_find(void);
65uint8_t convert_from_bytes_to_power_of_two(uint16_t number_of_bytes);
66
73 sd_error_status_type sd_init(void)
74{
75 uint16_t clkdiv = 0;
76 sd_error_status_type status = SD_OK;
77 gpio_init_type gpio_init_struct = {0};
78 uint8_t retry = 0;
79
80 /* gpioc and gpiod periph clock enable */
81 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
82 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
83
84 /* sdio periph clock enable */
85 crm_periph_clock_enable(CRM_SDIO1_PERIPH_CLOCK, TRUE);
86
87 /* configure pc.08, pc.09, pc.10, pc.11, pc.12 pin: d0, d1, d2, d3, clk pin */
88 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
89 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
90 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
91 gpio_init_struct.gpio_pins = GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11 | GPIO_PINS_12;
92 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
93 gpio_init(GPIOC, &gpio_init_struct);
94
95 /* configure pd.02 cmd line */
96 gpio_init_struct.gpio_pins = GPIO_PINS_2;
97 gpio_init(GPIOD, &gpio_init_struct);
98
99 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE8, GPIO_MUX_12);
100 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE9, GPIO_MUX_12);
101 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE10, GPIO_MUX_12);
102 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE11, GPIO_MUX_12);
103 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE12, GPIO_MUX_12);
104 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE2, GPIO_MUX_12);
105
106 retry = 3;
107 while(retry--){
108 /* reset sdio */
109 sdio_reset(SDIOx);
110 /* power on */
111 status = sd_power_on();
112
113 if(status == SD_OK)
114 break;
115 }
116
117 if(status == SD_OK)
118 {
119 /* sdio card initialize */
120 status = sd_card_init();
121 }
122
123 if(status == SD_OK)
124 {
125 /* get card information*/
126 status = sd_card_info_get(&sd_card_info);
127 }
128
129 if((SDIO_MULTIMEDIA_CARD == card_type) && (sd_card_info.sd_csd_reg.spec_version >= 4))
130 {
131 card_type = SDIO_HIGH_SPEED_MULTIMEDIA_CARD;
132 }
133
134 if(status == SD_OK)
135 {
136 /* select card */
137 status = sd_deselect_select((uint32_t)(sd_card_info.rca << 16));
138 }
139
140 if(status == SD_OK && ((SDIO_STD_CAPACITY_SD_CARD_V1_1 == card_type) || (SDIO_STD_CAPACITY_SD_CARD_V2_0 == card_type) || \
141 (SDIO_SECURE_DIGITAL_IO_COMBO_CARD == card_type) || (SDIO_HIGH_CAPACITY_SD_CARD == card_type)))
142 {
143 status = scr_find();
144 }
145
146 if(status == SD_OK)
147 {
148 /* set normal speed */
149 status = speed_change(0);
150 }
151
152 if((status == SD_OK) || (card_type == SDIO_MULTIMEDIA_CARD))
153 {
154 if(sd_card_info.card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1 || sd_card_info.card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0)
155 {
156 /* set sdio_ck to 12mhz */
157 clkdiv = system_core_clock / 12000000;
158
159 if(clkdiv >= 2)
160 {
161 clkdiv -= 2;
162 }
163 }
164 else
165 {
166 /* set sdio_ck to 48mhz */
167 clkdiv = system_core_clock / 48000000;
168
169 if(clkdiv >= 2)
170 {
171 clkdiv -= 2;
172 }
173 }
174 /* set sdio clock divider */
175 sdio_clock_set(clkdiv);
176
177 /* set transfer mode */
178 status = sd_device_mode_set(SD_TRANSFER_DMA_MODE);
179 }
180
181 if(status == SD_OK)
182 {
183 /* Set data width */
184 status = sd_wide_bus_operation_config(SDIO_BUS_WIDTH_D4);
185 }
186
187 return status;
188}
189
195void sdio_clock_set(uint32_t clk_div)
196{
197 /* config clock divide [7:0] */
198 SDIOx->clkctrl_bit.clkdiv_l = (clk_div & 0xFF);
199
200 /* config clock divide [9:8] */
201 SDIOx->clkctrl_bit.clkdiv_h = ((clk_div & 0x300) >> 8);
202}
203
210 sd_error_status_type sd_power_on(void)
211{
212 uint8_t retry = 0;
213 sd_error_status_type status = SD_OK;
214 uint32_t response = 0, count = 0, valid_voltage = 0, clk_psc;
215 uint32_t sd_type = SD_STD_CAPACITY;
216
217 /* sdio_ck is less than 400KHz in initialization stage, set to 200KHz */
218 clk_psc = (system_core_clock / 200000) - 2;
219
220 if(clk_psc > 0x3FF)
221 {
222 clk_psc = 0x3FF;
223 }
224
225 /* config sdio clock divide and edge phase */
226 sdio_clock_config(SDIOx, clk_psc, SDIO_CLOCK_EDGE_FALLING);
227 /* config sdio bus width */
228 sdio_bus_width_config(SDIOx, SDIO_BUS_WIDTH_D1);
229 /* disable flow control */
230 sdio_flow_control_enable(SDIOx, FALSE);
231 /* disable clock bypass */
232 sdio_clock_bypass(SDIOx, FALSE);
233 /* disable power saving mode */
234 sdio_power_saving_mode_enable(SDIOx, FALSE);
235
236 /* sdio power on */
237 sdio_power_set(SDIOx, SDIO_POWER_ON);
238 /* enable to output sdio_ck */
239 sdio_clock_enable(SDIOx, TRUE);
240
241 for(retry = 0; retry < 5; retry++)
242 {
243 /* send cmd0, get in idle stage */
244 sdio_command_init_struct.argument = 0x0;
245 sdio_command_init_struct.cmd_index = SD_CMD_GO_IDLE_STATE;
246 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_NO;
247 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
248
249 /* sdio command config */
250 sdio_command_config(SDIOx, &sdio_command_init_struct);
251 /* enable ccsm */
252 sdio_command_state_machine_enable(SDIOx, TRUE);
253
254 /* get command status */
255 status = command_error();
256 }
257
258 /* send cmd8, check card interface feature */
259 sdio_command_init_struct.argument = SD_CHECK_PATTERN;
260 sdio_command_init_struct.cmd_index = SDIO_SEND_IF_COND;
261 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
262 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
263
264 /* sdio command config */
265 sdio_command_config(SDIOx, &sdio_command_init_struct);
266 /* enable ccsm */
267 sdio_command_state_machine_enable(SDIOx, TRUE);
268
269 /* waiting R7 */
270 status = command_rsp7_error();
271
272 if(status == SD_OK)
273 {
274 /* set card type and sd type */
275 card_type = SDIO_STD_CAPACITY_SD_CARD_V2_0;
276 sd_type = SD_HIGH_CAPACITY;
277 }
278
279 /* send cmd55, check sd version */
280 sdio_command_init_struct.argument = 0x00;
281 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
282 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
283 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
284
285 /* sdio command config */
286 sdio_command_config(SDIOx, &sdio_command_init_struct);
287 /* enable ccsm */
288 sdio_command_state_machine_enable(SDIOx, TRUE);
289
290 /* waiting R1 */
291 status = command_rsp1_error(SD_CMD_APP_CMD);
292
293 /* check sd card or mmc card */
294 if(SD_OK == status)
295 {
296 /* send acmd41, check voltage operation range */
297 while((!valid_voltage) && (count < SD_MAX_VOLT_TRIAL))
298 {
299 delay_ms(10);
300
301 /* send cmd55 before acmd41 */
302 sdio_command_init_struct.argument = 0x00;
303 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
304 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
305 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
306
307 /* sdio command config */
308 sdio_command_config(SDIOx, &sdio_command_init_struct);
309 /* enable ccsm */
310 sdio_command_state_machine_enable(SDIOx, TRUE);
311
312 /* waiting R1 */
313 status = command_rsp1_error(SD_CMD_APP_CMD);
314
315 /* if any errors occured, return status */
316 if(status != SD_OK)
317 {
318 return status;
319 }
320
321 /* send acmd41 */
322 sdio_command_init_struct.argument = SD_VOLTAGE_WINDOW_SD | sd_type;
323 sdio_command_init_struct.cmd_index = SD_CMD_SD_APP_OP_COND;
324 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
325 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
326
327 /* sdio command config */
328 sdio_command_config(SDIOx, &sdio_command_init_struct);
329 /* enable ccsm */
330 sdio_command_state_machine_enable(SDIOx, TRUE);
331
332 /* waiting R3 */
333 status = command_rsp3_error();
334
335 /* if any errors occured, return status */
336 if(status != SD_OK)
337 {
338 return status;
339 }
340
341 /* get response1 */
342 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
343
344 /* check sd card power on stage is success or not */
345 valid_voltage = (((response >> 31) == 1) ? 1 : 0);
346 count++;
347 }
348
349 if(count >= SD_MAX_VOLT_TRIAL)
350 {
351 status = SD_INVALID_VOLTRANGE;
352 return status;
353 }
354
355 if(response &= SD_HIGH_CAPACITY)
356 {
357 card_type = SDIO_HIGH_CAPACITY_SD_CARD;
358 }
359 }
360 /* mmc card */
361 else
362 {
363 /* send cmd1 */
364 while((!valid_voltage) && (count < SD_MAX_VOLT_TRIAL))
365 {
366 delay_ms(10);
367
368 sdio_command_init_struct.argument = SD_VOLTAGE_WINDOW_MMC;
369 sdio_command_init_struct.cmd_index = SD_CMD_SEND_OP_COND;
370 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
371 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
372
373 /* sdio command config */
374 sdio_command_config(SDIOx, &sdio_command_init_struct);
375 /* enable ccsm */
376 sdio_command_state_machine_enable(SDIOx, TRUE);
377
378 /* waiting R3 */
379 status = command_rsp3_error();
380
381 if(status != SD_OK)
382 {
383 return status;
384 }
385
386 /* get response1 */
387 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
388
389 valid_voltage = (((response >> 31) == 1) ? 1 : 0);
390 count++;
391 }
392
393 if(count >= SD_MAX_VOLT_TRIAL)
394 {
395 status = SD_INVALID_VOLTRANGE;
396 return status;
397 }
398
399 card_type = SDIO_MULTIMEDIA_CARD;
400 }
401
402 return(status);
403}
404
410 sd_error_status_type sd_power_off(void)
411{
412 /* sdio power off */
413 sdio_power_set(SDIOx, SDIO_POWER_OFF);
414
415 return SD_OK;
416}
417
424 sd_error_status_type sd_card_init(void)
425{
426 sd_error_status_type status = SD_OK;
427 uint16_t rca_temp = 0x01;
428
429 /* check power status */
430 if(SDIO_POWER_OFF == sdio_power_status_get(SDIOx))
431 {
432 return SD_REQ_NOT_APPLICABLE;
433 }
434
435 /* check is secure_digital_io_card or not */
436 if(SDIO_SECURE_DIGITAL_IO_CARD != card_type)
437 {
438 /* send cmd2, get cid register */
439 sdio_command_init_struct.argument = 0x0;
440 sdio_command_init_struct.cmd_index = SD_CMD_ALL_SEND_CID;
441 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_LONG;
442 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
443
444 /* sdio command config */
445 sdio_command_config(SDIOx, &sdio_command_init_struct);
446 /* enable ccsm */
447 sdio_command_state_machine_enable(SDIOx, TRUE);
448
449 status = command_rsp2_error();
450 if(status != SD_OK)
451 {
452 return status;
453 }
454
455 cid_table[0] = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
456 cid_table[1] = sdio_response_get(SDIOx, SDIO_RSP2_INDEX);
457 cid_table[2] = sdio_response_get(SDIOx, SDIO_RSP3_INDEX);
458 cid_table[3] = sdio_response_get(SDIOx, SDIO_RSP4_INDEX);
459 }
460
461 /* check card type */
462 if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || \
463 (card_type == SDIO_SECURE_DIGITAL_IO_COMBO_CARD) || (card_type == SDIO_HIGH_CAPACITY_SD_CARD))
464 {
465 /* send cmd3, get rca */
466 sdio_command_init_struct.argument = 0x00;
467 sdio_command_init_struct.cmd_index = SD_CMD_SET_REL_ADDR;
468 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
469 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
470
471 /* sdio command config */
472 sdio_command_config(SDIOx, &sdio_command_init_struct);
473 /* enable ccsm */
474 sdio_command_state_machine_enable(SDIOx, TRUE);
475
476 status = command_rsp6_error(SD_CMD_SET_REL_ADDR, &rca_temp);
477 if(status != SD_OK)
478 {
479 return status;
480 }
481 }
482
483 /* mmc card */
484 if(card_type == SDIO_MULTIMEDIA_CARD)
485 {
486 /* send cmd3 */
487 sdio_command_init_struct.argument = (uint32_t)(rca_temp << 16);
488 sdio_command_init_struct.cmd_index = SD_CMD_SET_REL_ADDR;
489 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
490 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
491
492 /* sdio command config */
493 sdio_command_config(SDIOx, &sdio_command_init_struct);
494 /* enable ccsm */
495 sdio_command_state_machine_enable(SDIOx, TRUE);
496
497 status = command_rsp2_error();
498 if(status != SD_OK)
499 {
500 return status;
501 }
502 }
503
504 /* check is secure_digital_io_card or not */
505 if(card_type != SDIO_SECURE_DIGITAL_IO_CARD)
506 {
507 rca = rca_temp;
508 sdio_command_init_struct.argument = (uint32_t)(rca << 16);
509 sdio_command_init_struct.cmd_index = SD_CMD_SEND_CSD;
510 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_LONG;
511 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
512
513 /* sdio command config */
514 sdio_command_config(SDIOx, &sdio_command_init_struct);
515 /* enable ccsm */
516 sdio_command_state_machine_enable(SDIOx, TRUE);
517
518 status = command_rsp2_error();
519 if(status != SD_OK)
520 {
521 return status;
522 }
523
524 csd_table[0] = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
525 csd_table[1] = sdio_response_get(SDIOx, SDIO_RSP2_INDEX);
526 csd_table[2] = sdio_response_get(SDIOx, SDIO_RSP3_INDEX);
527 csd_table[3] = sdio_response_get(SDIOx, SDIO_RSP4_INDEX);
528 }
529
530 return SD_OK;
531}
532
539 sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info)
540{
541 sd_error_status_type status = SD_OK;
542 uint8_t tmp = 0;
543
544 card_info->card_type = (uint8_t)card_type;
545 card_info->rca = (uint16_t)rca;
546
547 /* byte 0 */
548 tmp = (uint8_t)((csd_table[0] & 0xFF000000) >> 24);
549 card_info->sd_csd_reg.csd_struct = (tmp & 0xC0) >> 6;
550 card_info->sd_csd_reg.spec_version = (tmp & 0x3C) >> 2;
551 card_info->sd_csd_reg.reserved1 = tmp & 0x03;
552
553 /* byte 1 */
554 tmp = (uint8_t)((csd_table[0] & 0x00FF0000) >> 16);
555 card_info->sd_csd_reg.taac = tmp;
556
557 /* byte 2 */
558 tmp = (uint8_t)((csd_table[0] & 0x0000FF00) >> 8);
559 card_info->sd_csd_reg.nsac = tmp;
560
561 /* byte 3 */
562 tmp = (uint8_t)(csd_table[0] & 0x000000FF);
563 card_info->sd_csd_reg.max_bus_clk_freq = tmp;
564
565 /* byte 4 */
566 tmp = (uint8_t)((csd_table[1] & 0xFF000000) >> 24);
567 card_info->sd_csd_reg.card_cmd_classes = tmp << 4;
568
569 /* byte 5 */
570 tmp = (uint8_t)((csd_table[1] & 0x00FF0000) >> 16);
571 card_info->sd_csd_reg.card_cmd_classes |= (tmp & 0xF0) >> 4;
572 card_info->sd_csd_reg.max_read_blk_length = tmp & 0x0F;
573
574 /* byte 6 */
575 tmp = (uint8_t)((csd_table[1] & 0x0000FF00) >> 8);
576 card_info->sd_csd_reg.part_blk_read = (tmp & 0x80) >> 7;
577 card_info->sd_csd_reg.write_blk_misalign = (tmp & 0x40) >> 6;
578 card_info->sd_csd_reg.read_blk_misalign = (tmp & 0x20) >> 5;
579 card_info->sd_csd_reg.dsr_implemented = (tmp & 0x10) >> 4;
580 card_info->sd_csd_reg.reserved2 = 0; /* reserved */
581
582 if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || (card_type == SDIO_MULTIMEDIA_CARD))
583 {
584 card_info->sd_csd_reg.device_size = (tmp & 0x03) << 10;
585
586 /* byte 7 */
587 tmp = (uint8_t)(csd_table[1] & 0x000000FF);
588 card_info->sd_csd_reg.device_size |= (tmp) << 2;
589
590 /* byte 8 */
591 tmp = (uint8_t)((csd_table[2] & 0xFF000000) >> 24);
592 card_info->sd_csd_reg.device_size |= (tmp & 0xC0) >> 6;
593
594 card_info->sd_csd_reg.max_read_current_vdd_min = (tmp & 0x38) >> 3;
595 card_info->sd_csd_reg.max_read_current_vdd_max = (tmp & 0x07);
596
597 /* byte 9 */
598 tmp = (uint8_t)((csd_table[2] & 0x00FF0000) >> 16);
599 card_info->sd_csd_reg.max_write_current_vdd_min = (tmp & 0xE0) >> 5;
600 card_info->sd_csd_reg.max_write_current_vdd_max = (tmp & 0x1C) >> 2;
601 card_info->sd_csd_reg.device_size_mult = (tmp & 0x03) << 1;
602 /* byte 10 */
603 tmp = (uint8_t)((csd_table[2] & 0x0000FF00) >> 8);
604 card_info->sd_csd_reg.device_size_mult |= (tmp & 0x80) >> 7;
605
606 card_info->card_capacity = (card_info->sd_csd_reg.device_size + 1) ;
607 card_info->card_capacity *= (1 << (card_info->sd_csd_reg.device_size_mult + 2));
608 card_info->card_blk_size = 1 << (card_info->sd_csd_reg.max_read_blk_length);
609 card_info->card_capacity *= card_info->card_blk_size;
610 }
611 else if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
612 {
613 /* byte 7 */
614 tmp = (uint8_t)(csd_table[1] & 0x000000FF);
615 card_info->sd_csd_reg.device_size = (tmp & 0x3F) << 16;
616
617 /* byte 8 */
618 tmp = (uint8_t)((csd_table[2] & 0xFF000000) >> 24);
619
620 card_info->sd_csd_reg.device_size |= (tmp << 8);
621
622 /* byte 9 */
623 tmp = (uint8_t)((csd_table[2] & 0x00FF0000) >> 16);
624
625 card_info->sd_csd_reg.device_size |= (tmp);
626
627 /* byte 10 */
628 tmp = (uint8_t)((csd_table[2] & 0x0000FF00) >> 8);
629
630 card_info->card_capacity = (uint64_t)(card_info->sd_csd_reg.device_size + 1) * 512 * 1024;
631 card_info->card_blk_size = 512;
632 }
633
634
635 card_info->sd_csd_reg.erase_group_size = (tmp & 0x40) >> 6;
636 card_info->sd_csd_reg.erase_group_size_mult = (tmp & 0x3F) << 1;
637
638 /* byte 11 */
639 tmp = (uint8_t)(csd_table[2] & 0x000000FF);
640 card_info->sd_csd_reg.erase_group_size_mult |= (tmp & 0x80) >> 7;
641 card_info->sd_csd_reg.write_protect_group_size = (tmp & 0x7F);
642
643 /* byte 12 */
644 tmp = (uint8_t)((csd_table[3] & 0xFF000000) >> 24);
645 card_info->sd_csd_reg.write_protect_group_enable = (tmp & 0x80) >> 7;
646 card_info->sd_csd_reg.manufacturer_default_ecc = (tmp & 0x60) >> 5;
647 card_info->sd_csd_reg.write_speed_factor = (tmp & 0x1C) >> 2;
648 card_info->sd_csd_reg.max_write_blk_length = (tmp & 0x03) << 2;
649
650 /* byte 13 */
651 tmp = (uint8_t)((csd_table[3] & 0x00FF0000) >> 16);
652 card_info->sd_csd_reg.max_write_blk_length |= (tmp & 0xC0) >> 6;
653 card_info->sd_csd_reg.part_blk_write = (tmp & 0x20) >> 5;
654 card_info->sd_csd_reg.reserved3 = 0;
655 card_info->sd_csd_reg.content_protect_app = (tmp & 0x01);
656
657 /* byte 14 */
658 tmp = (uint8_t)((csd_table[3] & 0x0000FF00) >> 8);
659 card_info->sd_csd_reg.file_format_group = (tmp & 0x80) >> 7;
660 card_info->sd_csd_reg.copy_flag = (tmp & 0x40) >> 6;
661 card_info->sd_csd_reg.permanent_write_protect = (tmp & 0x20) >> 5;
662 card_info->sd_csd_reg.temp_write_protect = (tmp & 0x10) >> 4;
663 card_info->sd_csd_reg.file_formart = (tmp & 0x0C) >> 2;
664 card_info->sd_csd_reg.ecc_code = (tmp & 0x03);
665
666 /* byte 15 */
667 tmp = (uint8_t)(csd_table[3] & 0x000000FF);
668 card_info->sd_csd_reg.csd_crc = (tmp & 0xFE) >> 1;
669 card_info->sd_csd_reg.reserved4 = 1;
670
671 /* byte 0 */
672 tmp = (uint8_t)((cid_table[0] & 0xFF000000) >> 24);
673 card_info->sd_cid_reg.manufacturer_id = tmp;
674
675 /* byte 1 */
676 tmp = (uint8_t)((cid_table[0] & 0x00FF0000) >> 16);
677 card_info->sd_cid_reg.oem_app_id = tmp << 8;
678
679 /* byte 2 */
680 tmp = (uint8_t)((cid_table[0] & 0x000000FF00) >> 8);
681 card_info->sd_cid_reg.oem_app_id |= tmp;
682
683 /* byte 3 */
684 tmp = (uint8_t)(cid_table[0] & 0x000000FF);
685 card_info->sd_cid_reg.product_name1 = tmp << 24;
686
687 /* byte 4 */
688 tmp = (uint8_t)((cid_table[1] & 0xFF000000) >> 24);
689 card_info->sd_cid_reg.product_name1 |= tmp << 16;
690
691 /* byte 5 */
692 tmp = (uint8_t)((cid_table[1] & 0x00FF0000) >> 16);
693 card_info->sd_cid_reg.product_name1 |= tmp << 8;
694
695 /* byte 6 */
696 tmp = (uint8_t)((cid_table[1] & 0x0000FF00) >> 8);
697 card_info->sd_cid_reg.product_name1 |= tmp;
698
699 /* byte 7 */
700 tmp = (uint8_t)(cid_table[1] & 0x000000FF);
701 card_info->sd_cid_reg.product_name2 = tmp;
702
703 /* byte 8 */
704 tmp = (uint8_t)((cid_table[2] & 0xFF000000) >> 24);
705 card_info->sd_cid_reg.product_reversion = tmp;
706
707 /* byte 9 */
708 tmp = (uint8_t)((cid_table[2] & 0x00FF0000) >> 16);
709 card_info->sd_cid_reg.product_sn = tmp << 24;
710
711 /* byte 10 */
712 tmp = (uint8_t)((cid_table[2] & 0x0000FF00) >> 8);
713 card_info->sd_cid_reg.product_sn |= tmp << 16;
714
715 /* byte 11 */
716 tmp = (uint8_t)(cid_table[2] & 0x000000FF);
717 card_info->sd_cid_reg.product_sn |= tmp << 8;
718
719 /* byte 12 */
720 tmp = (uint8_t)((cid_table[3] & 0xFF000000) >> 24);
721 card_info->sd_cid_reg.product_sn |= tmp;
722
723 /* byte 13 */
724 tmp = (uint8_t)((cid_table[3] & 0x00FF0000) >> 16);
725 card_info->sd_cid_reg.reserved1 |= (tmp & 0xF0) >> 4;
726 card_info->sd_cid_reg.manufact_date = (tmp & 0x0F) << 8;
727
728 /* byte 14 */
729 tmp = (uint8_t)((cid_table[3] & 0x0000FF00) >> 8);
730 card_info->sd_cid_reg.manufact_date |= tmp;
731
732 /* byte 15 */
733 tmp = (uint8_t)(cid_table[3] & 0x000000FF);
734 card_info->sd_cid_reg.cid_crc = (tmp & 0xFE) >> 1;
735 card_info->sd_cid_reg.reserved2 = 1;
736
737 return(status);
738}
739
750 sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
751{
752 sd_error_status_type status = SD_OK;
753
754 if((card_type == SDIO_MULTIMEDIA_CARD) || (card_type == SDIO_HIGH_SPEED_MULTIMEDIA_CARD))
755 {
756 status = mmc_switch(EXT_CSD_CMD_SET_NORMAL, EXT_CSD_BUS_WIDTH, (uint8_t)mode);
757 }
758 else if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || \
759 (card_type == SDIO_HIGH_CAPACITY_SD_CARD))
760 {
761 if(mode >= 2)
762 {
763 /* not support D8 mode */
764 return SD_UNSUPPORTED_FEATURE;
765 }
766
767 if(SDIO_BUS_WIDTH_D4 == mode)
768 {
769 status = sd_bus_wide_enable(TRUE);
770 }
771 else
772 {
773 status = sd_bus_wide_enable(FALSE);
774 }
775 }
776
777 if(status == SD_OK)
778 {
779 sdio_bus_width_config(SDIOx, mode);
780 }
781
782 return status;
783}
784
793 sd_error_status_type sd_device_mode_set(uint32_t mode)
794{
795 sd_error_status_type status = SD_OK;
796
797 if((mode == SD_TRANSFER_DMA_MODE) || (mode == SD_TRANSFER_POLLING_MODE))
798 {
799 device_mode = (sd_data_transfer_mode_type)mode;
800 }
801 else
802 {
803 status = SD_INVALID_PARAMETER;
804 }
805
806 return status;
807}
808
814 sd_error_status_type sd_deselect_select(uint32_t addr)
815{
816 /* send cmd7, select card */
817 sdio_command_init_struct.argument = addr;
818 sdio_command_init_struct.cmd_index = SD_CMD_SEL_DESEL_CARD;
819 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
820 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_INT;
821
822 /* sdio command config */
823 sdio_command_config(SDIOx, &sdio_command_init_struct);
824 /* enable ccsm */
825 sdio_command_state_machine_enable(SDIOx, TRUE);
826
827 return command_rsp1_error(SD_CMD_SEL_DESEL_CARD);
828}
829
837 sd_error_status_type sdio_command_data_send(sdio_command_struct_type *sdio_cmd_init_t, \
838 sdio_data_struct_type* sdio_data_init_t, uint32_t *buf)
839{
840 sd_error_status_type status = SD_OK;
841 uint32_t count = 0;
842 uint32_t timeout = SDIO_DATATIMEOUT;
843 uint32_t length = 0;
844
845 if(buf == NULL)
846 {
847 return SD_INVALID_PARAMETER;
848 }
849 /* clear dtctrl register */
850 SDIOx->dtcnt = 0x0;
851
852 /* sdio command config */
853 sdio_data_config(SDIOx, sdio_data_init_t);
854 /* enable dcsm */
855 sdio_data_state_machine_enable(SDIOx, TRUE);
856
857 length = sdio_data_init_t->data_length;
858
859 if(device_mode == SD_TRANSFER_DMA_MODE)
860 {
861 if(sdio_data_init_t->transfer_direction == SDIO_DATA_TRANSFER_TO_CONTROLLER)
862 {
863 sd_dma_config(buf, length, DMA_DIR_PERIPHERAL_TO_MEMORY);
864 SDIOx->inten |= SDIO_INTR_STS_READ_MASK;
865 transfer_error = SD_OK;
866 transfer_end = 0;
867 sdio_dma_enable(SDIOx, TRUE);
868 }
869 }
870
871 /* sdio command config */
872 sdio_command_config(SDIOx, sdio_cmd_init_t);
873 /* enable ccsm */
874 sdio_command_state_machine_enable(SDIOx, TRUE);
875
876 status = command_rsp1_error(sdio_cmd_init_t->cmd_index);
877 if(status != SD_OK)
878 {
879 return status;
880 }
881
882 /* polling mode */
883 if(device_mode == SD_TRANSFER_POLLING_MODE)
884 {
885 if(SDIO_DATA_TRANSFER_TO_CONTROLLER == sdio_data_init_t->transfer_direction)
886 {
887 while(!(SDIOx->sts & (SDIO_INTR_STS_READ_MASK)))
888 {
889 if(sdio_flag_get(SDIOx, SDIO_RXBUFH_FLAG) != RESET)
890 {
891 for(count = 0; count < 8; count++, buf++)
892 {
893 *buf = sdio_data_read(SDIOx);
894 }
895
896 timeout = 0x7FFFFF;
897 }
898 else
899 {
900 if(0 == timeout)
901 {
902 sd_init();
903 return SD_DATA_TIMEOUT;
904 }
905
906 timeout--;
907 }
908 }
909
910 while(sdio_flag_get(SDIOx, SDIO_RXBUF_FLAG) != RESET)
911 {
912 *buf = sdio_data_read(SDIOx);
913 buf++;
914 }
915 }
916 else
917 {
918 while(!(SDIOx->sts & SDIO_INTR_STS_WRITE_MASK))
919 {
920 if(sdio_flag_get(SDIOx, SDIO_TXBUFH_FLAG) != RESET)
921 {
922 for(count = 0; count < 8 && length > 0; count++, buf++, length -= 4)
923 {
924 sdio_data_write(SDIOx, *buf);
925 }
926
927 timeout = 0x3FFFFFFF;
928 }
929 else
930 {
931 if(timeout == 0)
932 {
933 sd_init();
934 return SD_DATA_TIMEOUT;
935 }
936
937 timeout--;
938 }
939 }
940 }
941 /* data timeout */
942 if(sdio_flag_get(SDIOx, SDIO_DTTIMEOUT_FLAG) != RESET)
943 {
944 sdio_flag_clear(SDIOx, SDIO_DTTIMEOUT_FLAG);
945 return SD_DATA_TIMEOUT;
946 }
947 /* crc error */
948 else if(sdio_flag_get(SDIOx, SDIO_DTFAIL_FLAG) != RESET)
949 {
950 sdio_flag_clear(SDIOx, SDIO_DTFAIL_FLAG);
951 return SD_DATA_FAIL;
952 }
953 /* over run error */
954 else if(sdio_flag_get(SDIOx, SDIO_RXERRO_FLAG) != RESET)
955 {
956 sdio_flag_clear(SDIOx, SDIO_RXERRO_FLAG);
957 return SD_RX_OVERRUN;
958 }
959 /* under run error */
960 else if(sdio_flag_get(SDIOx, SDIO_TXERRU_FLAG) != RESET)
961 {
962 sdio_flag_clear(SDIOx, SDIO_TXERRU_FLAG);
963 return SD_TX_UNDERRUN;
964 }
965 /* start bit error */
966 else if(sdio_flag_get(SDIOx, SDIO_SBITERR_FLAG) != RESET)
967 {
968 sdio_flag_clear(SDIOx, SDIO_SBITERR_FLAG);
969 return SD_START_BIT_ERR;
970 }
971 /* data transfer complete */
972 if((stop_flag == 1) && (sdio_flag_get(SDIOx, SDIO_DTCMPL_FLAG) != RESET))
973 {
974 /* send cmd12, stop transmission */
975 sdio_cmd_init_t->argument = 0;
976 sdio_cmd_init_t->cmd_index = SD_CMD_STOP_TRANSMISSION;
977 sdio_cmd_init_t->rsp_type = SDIO_RESPONSE_SHORT;
978 sdio_cmd_init_t->wait_type = SDIO_WAIT_FOR_NO;
979
980 /* sdio command config */
981 sdio_command_config(SDIOx, sdio_cmd_init_t);
982 /* enable ccsm */
983 sdio_command_state_machine_enable(SDIOx, TRUE);
984
985 status = command_rsp1_error(SD_CMD_STOP_TRANSMISSION);
986
987 if(status != SD_OK)
988 {
989 return status;
990 }
991 }
992
993 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
994 }
995 else if(device_mode == SD_TRANSFER_DMA_MODE)
996 {
997 if(sdio_data_init_t->transfer_direction == SDIO_DATA_TRANSFER_TO_CARD)
998 {
999 sd_dma_config(buf, length, DMA_DIR_MEMORY_TO_PERIPHERAL);
1000 SDIOx->inten |= SDIO_INTR_STS_WRITE_MASK;
1001 transfer_error = SD_OK;
1002 transfer_end = 0;
1003 sdio_dma_enable(SDIOx, TRUE);
1004 }
1005
1006 while(!(SDIOx->sts & SDIOx->inten) && timeout)
1007 {
1008 timeout--;
1009
1010 if(transfer_end)
1011 {
1012 break;
1013 }
1014 }
1015
1016 if(timeout == 0)
1017 {
1018 sd_init();
1019 return SD_DATA_TIMEOUT;
1020 }
1021
1022 if(transfer_error != SD_OK)
1023 {
1024 status = transfer_error;
1025 }
1026 }
1027
1028 return status;
1029}
1030
1037 sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks)
1038{
1039 sd_error_status_type status = SD_OK;
1040 uint32_t start_addr = 0, end_addr = 0, response = 0;
1041 uint8_t card_state;
1042
1043 /* high capacity sd card */
1044 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1045 {
1046 start_addr = addr >> 9;
1047 end_addr = start_addr + nblks - 1;
1048 }
1049 else
1050 {
1051 start_addr = addr;
1052 end_addr = start_addr + (nblks - 1) * 512;
1053 }
1054
1055 /* clear dcsm configuration */
1056 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1057 sdio_data_init_struct.data_length = 0 ;
1058 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1059 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1060 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1061
1062 sdio_data_config(SDIOx, &sdio_data_init_struct);
1063 sdio_data_state_machine_enable(SDIOx, FALSE);
1064
1065 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1066
1067 /* check card locked */
1068 if(response & SD_CARD_LOCKED)
1069 {
1070 return SD_LOCK_UNLOCK_ERROR;
1071 }
1072
1073 if(card_type == SDIO_MULTIMEDIA_CARD || card_type == SDIO_HIGH_SPEED_MULTIMEDIA_CARD)
1074 {
1075 /* send cmd35, set erase group start */
1076 sdio_command_init_struct.argument = start_addr;
1077 sdio_command_init_struct.cmd_index = SD_CMD_ERASE_GRP_START;
1078 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1079 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1080
1081 /* sdio command config */
1082 sdio_command_config(SDIOx, &sdio_command_init_struct);
1083 /* enable ccsm */
1084 sdio_command_state_machine_enable(SDIOx, TRUE);
1085
1086 status = command_rsp1_error(SD_CMD_ERASE_GRP_START);
1087
1088 if(status != SD_OK)
1089 {
1090 return status;
1091 }
1092
1093 /* send cmd36, set erase group end */
1094 sdio_command_init_struct.argument = end_addr;
1095 sdio_command_init_struct.cmd_index = SD_CMD_ERASE_GRP_END;
1096
1097 /* sdio command config */
1098 sdio_command_config(SDIOx, &sdio_command_init_struct);
1099 /* enable ccsm */
1100 sdio_command_state_machine_enable(SDIOx, TRUE);
1101
1102 status = command_rsp1_error(SD_CMD_ERASE_GRP_END);
1103
1104 if(status != SD_OK)
1105 {
1106 return status;
1107 }
1108
1109 /* send cmd38, start erase gourp */
1110 sdio_command_init_struct.argument = 0;
1111 sdio_command_init_struct.cmd_index = SD_CMD_ERASE;
1112
1113 /* sdio command config */
1114 sdio_command_config(SDIOx, &sdio_command_init_struct);
1115 /* enable ccsm */
1116 sdio_command_state_machine_enable(SDIOx, TRUE);
1117
1118 status = command_rsp1_error(SD_CMD_ERASE);
1119
1120 if(status != SD_OK)
1121 {
1122 return status;
1123 }
1124 }
1125 else
1126 {
1127 /* send cmd32, set erase block start */
1128 sdio_command_init_struct.argument = start_addr;
1129 sdio_command_init_struct.cmd_index = SD_CMD_SD_ERASE_GRP_START;
1130 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1131 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1132
1133 /* sdio command config */
1134 sdio_command_config(SDIOx, &sdio_command_init_struct);
1135 /* enable ccsm */
1136 sdio_command_state_machine_enable(SDIOx, TRUE);
1137
1138 status = command_rsp1_error(SD_CMD_SD_ERASE_GRP_START);
1139
1140 if(status != SD_OK)
1141 {
1142 return status;
1143 }
1144
1145 /* send cmd33, set erase block end */
1146 sdio_command_init_struct.argument = end_addr;
1147 sdio_command_init_struct.cmd_index = SD_CMD_SD_ERASE_GRP_END;
1148
1149 /* sdio command config */
1150 sdio_command_config(SDIOx, &sdio_command_init_struct);
1151 /* enable ccsm */
1152 sdio_command_state_machine_enable(SDIOx, TRUE);
1153
1154 if(status != SD_OK)
1155 {
1156 return status;
1157 }
1158
1159 /* send cmd38, start erase block */
1160 sdio_command_init_struct.argument = 0;
1161 sdio_command_init_struct.cmd_index = SD_CMD_ERASE;
1162
1163 /* sdio command config */
1164 sdio_command_config(SDIOx, &sdio_command_init_struct);
1165 /* enable ccsm */
1166 sdio_command_state_machine_enable(SDIOx, TRUE);
1167
1168 status = command_rsp1_error(SD_CMD_ERASE);
1169
1170 if(status != SD_OK)
1171 {
1172 return status;
1173 }
1174 }
1175
1176 status = check_card_programming(&card_state);
1177
1178 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || \
1179 (card_state == SD_CARD_RECEIVING)))
1180 {
1181 status = check_card_programming(&card_state);
1182 }
1183
1184 return status;
1185}
1186
1195 sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
1196{
1197 sd_error_status_type status = SD_OK;
1198 uint32_t response = 0;
1199 uint8_t power;
1200
1201 if(NULL == buf)
1202 {
1203 return SD_INVALID_PARAMETER;
1204 }
1205
1206 SDIOx->dtctrl = 0x0;
1207
1208 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1209 {
1210 blk_size = 512;
1211 addr >>= 9;
1212 }
1213
1214 /* clear dcsm configuration */
1215 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1216 sdio_data_init_struct.data_length = 0;
1217 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1218 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1219 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1220
1221 sdio_data_config(SDIOx, &sdio_data_init_struct);
1222 sdio_data_state_machine_enable(SDIOx, FALSE);
1223
1224 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1225
1226 /* check card locked */
1227 if(response & SD_CARD_LOCKED)
1228 {
1229 return SD_LOCK_UNLOCK_ERROR;
1230 }
1231
1232 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1233 {
1234 power = convert_from_bytes_to_power_of_two(blk_size);
1235
1236 /* send cmd16, set block size */
1237 sdio_command_init_struct.argument = blk_size;
1238 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1239 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1240 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1241
1242 /* sdio command config */
1243 sdio_command_config(SDIOx, &sdio_command_init_struct);
1244 /* enable ccsm */
1245 sdio_command_state_machine_enable(SDIOx, TRUE);
1246
1247 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1248
1249 if(status != SD_OK)
1250 {
1251 return status;
1252 }
1253 }
1254 else
1255 {
1256 return SD_INVALID_PARAMETER;
1257 }
1258
1259 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1260 sdio_data_init_struct.data_length = blk_size ;
1261 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1262 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
1263 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1264
1265 sdio_command_init_struct.argument = addr;
1266 sdio_command_init_struct.cmd_index = SD_CMD_READ_SINGLE_BLOCK;
1267 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1268 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1269
1270 stop_flag = 0;
1271
1272 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1273}
1274
1284 sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
1285{
1286 sd_error_status_type status = SD_OK;
1287 uint32_t response = 0;
1288 uint8_t power;
1289
1290 SDIOx->dtctrl = 0x0;
1291
1292 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1293 {
1294 blk_size = 512;
1295 addr >>= 9;
1296 }
1297
1298 /* clear dcsm configuration */
1299 sdio_data_init_struct.block_size = (sdio_block_size_type)0;
1300 sdio_data_init_struct.data_length = 0;
1301 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1302 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1303 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1304
1305 sdio_data_config(SDIOx, &sdio_data_init_struct);
1306 sdio_data_state_machine_enable(SDIOx, FALSE);
1307
1308 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1309
1310 /* check card locked */
1311 if(response & SD_CARD_LOCKED)
1312 {
1313 return SD_LOCK_UNLOCK_ERROR;
1314 }
1315
1316 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1317 {
1318 power = convert_from_bytes_to_power_of_two(blk_size);
1319
1320 /* send cmd16, set block size */
1321 sdio_command_init_struct.argument = blk_size;
1322 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1323 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1324 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1325
1326 /* sdio command config */
1327 sdio_command_config(SDIOx, &sdio_command_init_struct);
1328 /* enable ccsm */
1329 sdio_command_state_machine_enable(SDIOx, TRUE);
1330
1331 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1332
1333 if(status != SD_OK)
1334 {
1335 return status;
1336 }
1337 }
1338 else
1339 {
1340 return SD_INVALID_PARAMETER;
1341 }
1342
1343 /* check max receive length */
1344 if(nblks * blk_size > SD_MAX_DATA_LENGTH)
1345 {
1346 return SD_INVALID_PARAMETER;
1347 }
1348
1349 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1350 sdio_data_init_struct.data_length = nblks * blk_size ;
1351 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1352 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
1353 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1354
1355 /* send cmd18, read block data */
1356 sdio_command_init_struct.argument = addr;
1357 sdio_command_init_struct.cmd_index = SD_CMD_READ_MULT_BLOCK;
1358 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1359 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1360
1361 stop_flag = 1;
1362
1363 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1364}
1365
1374 sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
1375{
1376 sd_error_status_type status = SD_OK;
1377 uint8_t power = 0, card_state = 0;
1378 uint32_t timeout = 0, card_status = 0, response = 0;
1379
1380 if(buf == NULL)
1381 {
1382 return SD_INVALID_PARAMETER;
1383 }
1384
1385 SDIOx->dtctrl = 0x0;
1386
1387 /* clear dcsm configuration */
1388 sdio_data_init_struct.block_size = (sdio_block_size_type)0;
1389 sdio_data_init_struct.data_length = 0;
1390 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1391 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1392 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1393
1394 sdio_data_config(SDIOx, &sdio_data_init_struct);
1395 sdio_data_state_machine_enable(SDIOx, FALSE);
1396
1397 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1398
1399 /* check card locked */
1400 if(response & SD_CARD_LOCKED)
1401 {
1402 return SD_LOCK_UNLOCK_ERROR;
1403 }
1404
1405 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1406 {
1407 blk_size = 512;
1408 addr >>= 9;
1409 }
1410
1411 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1412 {
1413 power = convert_from_bytes_to_power_of_two(blk_size);
1414
1415 /* send cmd16, set block size */
1416 sdio_command_init_struct.argument = blk_size;
1417 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1418 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1419 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1420
1421 /* sdio command config */
1422 sdio_command_config(SDIOx, &sdio_command_init_struct);
1423 /* enable ccsm */
1424 sdio_command_state_machine_enable(SDIOx, TRUE);
1425
1426 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1427
1428 if(status != SD_OK)
1429 {
1430 return status;
1431 }
1432 }
1433 else
1434 {
1435 return SD_INVALID_PARAMETER;
1436 }
1437
1438 timeout = SD_DATATIMEOUT;
1439
1440 do
1441 {
1442 timeout--;
1443 status = sd_status_send(&card_status);
1444 }
1445 /* check ready_for_data flag */
1446 while(((card_status & 0x00000100) == 0) && (timeout > 0));
1447
1448 if(timeout == 0)
1449 {
1450 return SD_ERROR;
1451 }
1452
1453 /* send cmd24, write single block */
1454 sdio_command_init_struct.argument = addr;
1455 sdio_command_init_struct.cmd_index = SD_CMD_WRITE_SINGLE_BLOCK;
1456 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1457 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1458
1459 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1460 sdio_data_init_struct.data_length = blk_size;
1461 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1462 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1463 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1464
1465 stop_flag = 0;
1466
1467 /* single block, stop command is unnecessary */
1468 status = sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1469
1470 if(status != SD_OK)
1471 {
1472 return status;
1473 }
1474
1475 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1476
1477 status = check_card_programming(&card_state);
1478
1479 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || (card_state == SD_CARD_RECEIVING)))
1480 {
1481 status = check_card_programming(&card_state);
1482 }
1483
1484 return status;
1485}
1486
1496 sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
1497{
1498 sd_error_status_type status = SD_OK;
1499 uint8_t power = 0, card_state = 0;
1500 uint32_t timeout = 0, card_status = 0, response = 0;;
1501
1502 if(buf == NULL)
1503 {
1504 return SD_INVALID_PARAMETER;
1505 }
1506
1507 SDIOx->dtctrl = 0x0;
1508
1509 /* clear dcsm configuration */
1510 sdio_data_init_struct.block_size = (sdio_block_size_type)0;
1511 sdio_data_init_struct.data_length = 0;
1512 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1513 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1514 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1515
1516 sdio_data_config(SDIOx, &sdio_data_init_struct);
1517 sdio_data_state_machine_enable(SDIOx, FALSE);
1518
1519 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1520
1521 /* check card locked */
1522 if(response & SD_CARD_LOCKED)
1523 {
1524 return SD_LOCK_UNLOCK_ERROR;
1525 }
1526
1527 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1528 {
1529 blk_size = 512;
1530 addr >>= 9;
1531 }
1532
1533 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1534 {
1535 power = convert_from_bytes_to_power_of_two(blk_size);
1536
1537 /* send cmd16, set block size */
1538 sdio_command_init_struct.argument = blk_size;
1539 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1540 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1541 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1542
1543 /* sdio command config */
1544 sdio_command_config(SDIOx, &sdio_command_init_struct);
1545 /* enable ccsm */
1546 sdio_command_state_machine_enable(SDIOx, TRUE);
1547
1548 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1549
1550 if(status != SD_OK)
1551 {
1552 return status;
1553 }
1554 }
1555 else
1556 {
1557 return SD_INVALID_PARAMETER;
1558 }
1559
1560 if((nblks * blk_size) > SD_MAX_DATA_LENGTH)
1561 {
1562 return SD_INVALID_PARAMETER;
1563 }
1564
1565 timeout = SD_DATATIMEOUT;
1566
1567 do
1568 {
1569 timeout--;
1570 status = sd_status_send(&card_status);
1571 }
1572 /* check ready_for_data flag */
1573 while(((card_status & 0x00000100) == 0) && (timeout > 0));
1574
1575 if(timeout == 0)
1576 {
1577 return SD_ERROR;
1578 }
1579
1580 if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || \
1581 (card_type == SDIO_HIGH_CAPACITY_SD_CARD))
1582 {
1583 /* send cmd55 */
1584 sdio_command_init_struct.argument = (uint32_t)rca << 16;
1585 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
1586 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1587 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1588
1589 /* sdio command config */
1590 sdio_command_config(SDIOx, &sdio_command_init_struct);
1591 /* enable ccsm */
1592 sdio_command_state_machine_enable(SDIOx, TRUE);
1593
1594 status = command_rsp1_error(SD_CMD_APP_CMD);
1595
1596 if(status != SD_OK)
1597 {
1598 return status;
1599 }
1600
1601 /* send cmd23, set block count */
1602 sdio_command_init_struct.argument = blk_size;
1603 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCK_COUNT;
1604 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1605 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1606
1607 /* sdio command config */
1608 sdio_command_config(SDIOx, &sdio_command_init_struct);
1609 /* enable ccsm */
1610 sdio_command_state_machine_enable(SDIOx, TRUE);
1611
1612 status = command_rsp1_error(SD_CMD_SET_BLOCK_COUNT);
1613
1614 if(status != SD_OK)
1615 {
1616 return status;
1617 }
1618 }
1619
1620 /* send cmd25, write mult blocks */
1621 sdio_command_init_struct.argument = addr;
1622 sdio_command_init_struct.cmd_index = SD_CMD_WRITE_MULT_BLOCK;
1623 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1624 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1625
1626 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1627 sdio_data_init_struct.data_length = nblks * blk_size ;
1628 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1629 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1630 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1631
1632 stop_flag = 1;
1633 /* cmd12 is needed */
1634 status = sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1635
1636 if(status != SD_OK)
1637 {
1638 return status;
1639 }
1640
1641 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1642
1643 status = check_card_programming(&card_state);
1644
1645 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || (card_state == SD_CARD_RECEIVING)))
1646 {
1647 status = check_card_programming(&card_state);
1648 }
1649
1650 return status;
1651}
1652
1660 sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
1661{
1662 uint32_t response = 0;
1663
1664 SDIOx->dtctrl = 0x0;
1665
1666 /* clear dcsm configuration */
1667 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1668 sdio_data_init_struct.data_length = 0 ;
1669 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1670 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1671 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1672
1673 sdio_data_config(SDIOx, &sdio_data_init_struct);
1674 sdio_data_state_machine_enable(SDIOx, FALSE);
1675
1676 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1677
1678 /* check card locked */
1679 if(response & SD_CARD_LOCKED)
1680 {
1681 return SD_LOCK_UNLOCK_ERROR;
1682 }
1683 /* send cmd11, read data */
1684 sdio_command_init_struct.argument = addr;
1685 sdio_command_init_struct.cmd_index = SD_CMD_READ_DAT_UNTIL_STOP;
1686 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1687 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1688
1689 sdio_data_init_struct.block_size = (sdio_block_size_type)(5 << 4);
1690 sdio_data_init_struct.data_length = len;
1691 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1692 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
1693 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1694
1695 stop_flag = 1;
1696 /* cmd12 is needed */
1697 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1698}
1699
1707 sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
1708{
1709 sd_error_status_type status = SD_OK;
1710 uint32_t response = 0;
1711 uint8_t card_state = 0;
1712
1713 if(buf == NULL)
1714 {
1715 return SD_INVALID_PARAMETER;
1716 }
1717
1718 SDIOx->dtctrl = 0x0;
1719
1720 /* clear dcsm configuration */
1721 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1722 sdio_data_init_struct.data_length = 0;
1723 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1724 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1725 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1726
1727 sdio_data_config(SDIOx, &sdio_data_init_struct);
1728 sdio_data_state_machine_enable(SDIOx, FALSE);
1729
1730 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1731
1732 /* check card locked */
1733 if(response & SD_CARD_LOCKED)
1734 {
1735 return SD_LOCK_UNLOCK_ERROR;
1736 }
1737 /* send cmd20, write data */
1738 sdio_command_init_struct.argument = addr;
1739 sdio_command_init_struct.cmd_index = SD_CMD_WRITE_DAT_UNTIL_STOP;
1740 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1741 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1742
1743
1744 sdio_data_init_struct.block_size = (sdio_block_size_type)(15 << 4);
1745 sdio_data_init_struct.data_length = len;
1746 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1747 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1748 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1749
1750 stop_flag = 1;
1751 /* cmd12 is needed */
1752 status = sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1753
1754 if(status != SD_OK)
1755 {
1756 return status;
1757 }
1758
1759 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1760
1761 status = check_card_programming(&card_state);
1762
1763 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || (card_state == SD_CARD_RECEIVING)))
1764 {
1765 status = check_card_programming(&card_state);
1766 }
1767
1768 return status;
1769}
1770
1776void SDIO1_IRQHandler(void)
1777{
1778 sd_irq_service();
1779}
1780
1786void SDIO2_IRQHandler(void)
1787{
1788 sd_irq_service();
1789}
1790
1796 sd_error_status_type sd_irq_service(void)
1797{
1798 if(sdio_flag_get(SDIOx, SDIO_DTCMPL_FLAG) != RESET)
1799 {
1800 if(stop_flag == 1)
1801 {
1802 /* send cmd12, stop transmission */
1803 sdio_command_init_struct.argument = 0;
1804 sdio_command_init_struct.cmd_index = SD_CMD_STOP_TRANSMISSION;
1805 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1806 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1807 /* sdio command config */
1808 sdio_command_config(SDIOx, &sdio_command_init_struct);
1809 /* enable ccsm */
1810 sdio_command_state_machine_enable(SDIOx, TRUE);
1811 transfer_error = command_rsp1_error(SD_CMD_STOP_TRANSMISSION);
1812 }
1813 else
1814 {
1815 transfer_error = SD_OK;
1816 }
1817 /* clear flag */
1818 sdio_flag_clear(SDIOx, SDIO_DTCMPL_FLAG);
1819 transfer_end = 1;
1820 return transfer_error;
1821 }
1822
1823 if(sdio_flag_get(SDIOx, SDIO_DTFAIL_FLAG) != RESET)
1824 {
1825 /* clear flag */
1826 sdio_flag_clear(SDIOx, SDIO_DTFAIL_FLAG);
1827 transfer_error = SD_DATA_FAIL;
1828 transfer_end = 1;
1829 return transfer_error;
1830 }
1831
1832 if(sdio_flag_get(SDIOx, SDIO_DTTIMEOUT_FLAG) != RESET)
1833 {
1834 /* clear flag */
1835 sdio_flag_clear(SDIOx, SDIO_DTTIMEOUT_FLAG);
1836 transfer_error = SD_DATA_TIMEOUT;
1837 transfer_end = 1;
1838 return transfer_error;
1839 }
1840
1841 if(sdio_flag_get(SDIOx, SDIO_RXERRO_FLAG) != RESET)
1842 {
1843 /* clear flag */
1844 sdio_flag_clear(SDIOx, SDIO_RXERRO_FLAG);
1845 transfer_error = SD_RX_OVERRUN;
1846 transfer_end = 1;
1847 return(SD_RX_OVERRUN);
1848 }
1849
1850 if(sdio_flag_get(SDIOx, SDIO_TXERRU_FLAG) != RESET)
1851 {
1852 /* clear flag */
1853 sdio_flag_clear(SDIOx, SDIO_TXERRU_FLAG);
1854 transfer_error = SD_TX_UNDERRUN;
1855 transfer_end = 1;
1856 return(SD_TX_UNDERRUN);
1857 }
1858
1859 if(sdio_flag_get(SDIOx, SDIO_SBITERR_FLAG) != RESET)
1860 {
1861 /* clear flag */
1862 sdio_flag_clear(SDIOx, SDIO_SBITERR_FLAG);
1863 transfer_error = SD_START_BIT_ERR;
1864 transfer_end = 1;
1865 return(SD_START_BIT_ERR);
1866 }
1867
1868 /* disable interrupt */
1869 sdio_interrupt_enable(SDIOx, (SDIO_DTFAIL_INT | SDIO_DTTIMEOUT_INT | \
1870 SDIO_DTCMP_INT | SDIO_TXBUFH_INT | SDIO_RXBUFH_INT | \
1871 SDIO_TXERRU_INT| SDIO_RXERRO_INT | SDIO_SBITERR_INT), FALSE);
1872 return(SD_OK);
1873}
1874
1880 sd_error_status_type command_error(void)
1881{
1882 sd_error_status_type status = SD_OK;
1883 uint32_t timeout = SDIO_CMD0TIMEOUT;
1884
1885 while(timeout--)
1886 {
1887 if(sdio_flag_get(SDIOx, SDIO_CMDCMPL_FLAG) != RESET)
1888 {
1889 break;
1890 }
1891 }
1892
1893 if(timeout == 0)
1894 {
1895 return SD_CMD_RSP_TIMEOUT;
1896 }
1897
1898 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1899 return status;
1900}
1901
1907 sd_error_status_type command_rsp7_error(void)
1908{
1909 sd_error_status_type status = SD_OK;
1910 uint32_t sts_reg = 0;
1911 uint32_t timeout = SDIO_CMD0TIMEOUT;
1912
1913 while(timeout--)
1914 {
1915 sts_reg = SDIOx->sts;
1916
1917 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
1918 {
1919 break;
1920 }
1921 }
1922
1923 if((timeout == 0) || (sts_reg & SDIO_CMDTIMEOUT_FLAG))
1924 {
1925 status = SD_CMD_RSP_TIMEOUT;
1926 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
1927 return status;
1928 }
1929
1930 if(sts_reg & SDIO_CMDRSPCMPL_FLAG)
1931 {
1932 status = SD_OK;
1933 sdio_flag_clear(SDIOx, SDIO_CMDRSPCMPL_FLAG);
1934 }
1935
1936 return status;
1937}
1938
1944 sd_error_status_type command_rsp1_error(uint8_t cmd)
1945{
1946 uint32_t sts_reg = 0;
1947 uint32_t rsp_cmd = 0;
1948
1949 while(1)
1950 {
1951 sts_reg = SDIOx->sts;
1952
1953 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
1954 {
1955 break;
1956 }
1957 }
1958
1959 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
1960 {
1961 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
1962 return SD_CMD_RSP_TIMEOUT;
1963 }
1964
1965 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
1966 {
1967 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
1968 return SD_CMD_FAIL;
1969 }
1970
1971 rsp_cmd = sdio_command_response_get(SDIOx);
1972 if(rsp_cmd != cmd)
1973 {
1974 return SD_ILLEGAL_CMD;
1975 }
1976
1977 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1978
1979 return (sd_error_status_type)(sdio_response_get(SDIOx, SDIO_RSP1_INDEX) & SD_OCR_ERRORBITS);
1980}
1981
1987 sd_error_status_type command_rsp3_error(void)
1988{
1989 uint32_t sts_reg = 0;;
1990
1991 while(1)
1992 {
1993 sts_reg = SDIOx->sts;
1994
1995 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
1996 {
1997 break;
1998 }
1999 }
2000
2001 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2002 {
2003 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2004 return SD_CMD_RSP_TIMEOUT;
2005 }
2006
2007 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2008
2009 return SD_OK;
2010}
2011
2017 sd_error_status_type command_rsp2_error(void)
2018{
2019 sd_error_status_type status = SD_OK;
2020 uint32_t sts_reg;
2021 uint32_t timeout = SDIO_CMD0TIMEOUT;
2022
2023 while(timeout--)
2024 {
2025 sts_reg = SDIOx->sts;
2026
2027 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2028 {
2029 break;
2030 }
2031 }
2032
2033 if((timeout == 0) || sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2034 {
2035 status = SD_CMD_RSP_TIMEOUT;
2036 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2037
2038 return status;
2039 }
2040
2041 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2042 {
2043 status = SD_CMD_FAIL;
2044 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2045 }
2046
2047 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2048
2049 return status;
2050}
2051
2057 sd_error_status_type command_rsp4_error(uint8_t cmd)
2058{
2059 uint32_t sts_reg = 0, rsp_cmd = 0;
2060
2061 while(1)
2062 {
2063 sts_reg = SDIOx->sts;
2064
2065 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2066 {
2067 break;
2068 }
2069 }
2070
2071 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2072 {
2073 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2074 return SD_CMD_RSP_TIMEOUT;
2075 }
2076
2077 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2078 {
2079 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2080
2081 return SD_CMD_FAIL;
2082 }
2083
2084 rsp_cmd = sdio_command_response_get(SDIOx);
2085 if(rsp_cmd != cmd)
2086 {
2087 return SD_ILLEGAL_CMD;
2088 }
2089
2090 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2091
2092 return SD_OK;
2093}
2094
2100 sd_error_status_type command_rsp5_error(uint8_t cmd)
2101{
2102 uint32_t sts_reg = 0, rsp_cmd = 0, response = 0;
2103
2104 while(1)
2105 {
2106 sts_reg = SDIOx->sts;
2107
2108 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2109 {
2110 break;
2111 }
2112 }
2113
2114 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2115 {
2116 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2117
2118 return SD_CMD_RSP_TIMEOUT;
2119 }
2120
2121 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2122 {
2123 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2124
2125 return SD_CMD_FAIL;
2126 }
2127
2128 rsp_cmd = sdio_command_response_get(SDIOx);
2129 if(rsp_cmd != cmd)
2130 {
2131 return SD_ILLEGAL_CMD;
2132 }
2133
2134 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2135
2136 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2137
2138 if(response & SD_R5_OUT_OF_RANGE)
2139 {
2140 return SD_CMD_OUT_OF_RANGE;
2141 }
2142
2143 if(response & SD_R5_FUNCTION_NUMBER)
2144 {
2145 return SD_SDIO_UNKNOWN_FUNC;
2146 }
2147
2148 if(response & SD_R5_ERROR)
2149 {
2150 return SD_GENERAL_UNKNOWN_ERROR;
2151 }
2152
2153 return SD_OK;
2154}
2155
2163 sd_error_status_type command_rsp6_error(uint8_t cmd, uint16_t *prca)
2164{
2165 sd_error_status_type status = SD_OK;
2166 uint32_t sts_reg, rsp_cmd = 0, response = 0;
2167
2168 while(1)
2169 {
2170 sts_reg = SDIOx->sts;
2171
2172 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2173 {
2174 break;
2175 }
2176 }
2177
2178 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2179 {
2180 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2181 return SD_CMD_RSP_TIMEOUT;
2182 }
2183
2184 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2185 {
2186 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2187 return SD_CMD_FAIL;
2188 }
2189
2190 rsp_cmd = sdio_command_response_get(SDIOx);
2191 if(rsp_cmd != cmd)
2192 {
2193 return SD_ILLEGAL_CMD;
2194 }
2195
2196 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2197
2198 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2199
2200 if(SD_ALLZERO == (response & (SD_R6_GENERAL_UNKNOWN_ERROR | SD_R6_ILLEGAL_CMD | SD_R6_CMD_CRC_ERROR)))
2201 {
2202 *prca = (uint16_t)(response >> 16);
2203 return status;
2204 }
2205
2206 if(response & SD_R6_GENERAL_UNKNOWN_ERROR)
2207 {
2208 return SD_GENERAL_UNKNOWN_ERROR;
2209 }
2210
2211 if(response & SD_R6_ILLEGAL_CMD)
2212 {
2213 return SD_ILLEGAL_CMD;
2214 }
2215
2216 if(response & SD_R6_CMD_CRC_ERROR)
2217 {
2218 return SD_CMD_CRC_ERROR;
2219 }
2220
2221 return status;
2222}
2223
2229 sd_error_status_type sd_bus_wide_enable(confirm_state new_state)
2230{
2231 sd_error_status_type status = SD_OK;
2232 uint32_t response = 0;
2233 uint8_t arg = 0x00;
2234
2235 if(new_state == TRUE)
2236 {
2237 arg = 0x02;
2238 }
2239 else
2240 {
2241 arg = 0x00;
2242 }
2243
2244 /* get response1 */
2245 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2246
2247 /* check card locked or not */
2248 if(response & SD_CARD_LOCKED)
2249 {
2250 return SD_LOCK_UNLOCK_ERROR;
2251 }
2252
2253 if(sd_card_info.sd_scr_reg.sd_bus_width)
2254 {
2255 sdio_command_init_struct.argument = (uint32_t)(sd_card_info.rca << 16);
2256 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
2257 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2258 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2259
2260 /* sdio command config */
2261 sdio_command_config(SDIOx, &sdio_command_init_struct);
2262 /* enable ccsm */
2263 sdio_command_state_machine_enable(SDIOx, TRUE);
2264
2265 status = command_rsp1_error(SD_CMD_APP_CMD);
2266
2267 if(status != SD_OK)
2268 {
2269 return status;
2270 }
2271
2272 sdio_command_init_struct.argument = arg;
2273 sdio_command_init_struct.cmd_index = SD_CMD_APP_SD_SET_BUSWIDTH;
2274 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2275 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2276
2277 /* sdio command config */
2278 sdio_command_config(SDIOx, &sdio_command_init_struct);
2279 /* enable ccsm */
2280 sdio_command_state_machine_enable(SDIOx, TRUE);
2281
2282 status = command_rsp1_error(SD_CMD_APP_SD_SET_BUSWIDTH);
2283 return status;
2284 }
2285 else
2286 {
2287 return SD_REQ_NOT_APPLICABLE;
2288 }
2289}
2290
2298 sd_error_status_type mmc_switch(uint8_t set, uint8_t index, uint8_t value)
2299{
2300 sd_error_status_type status = SD_OK;
2301 uint32_t card_status = 0, timeout = 0;
2302
2303 sdio_command_init_struct.argument = (EXT_CSD_Write_byte << 24) | (index << 16) | (value << 8) | set;
2304 sdio_command_init_struct.cmd_index = SD_CMD_HS_SWITCH;
2305 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2306 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2307
2308 /* sdio command config */
2309 sdio_command_config(SDIOx, &sdio_command_init_struct);
2310 /* enable ccsm */
2311 sdio_command_state_machine_enable(SDIOx, TRUE);
2312
2313 status = command_rsp1_error(SD_CMD_HS_SWITCH);
2314 if(status != SD_OK)
2315 {
2316 return status;
2317 }
2318
2319 card_status = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2320 if(card_status & MMC_SWITCH_ERROR)
2321 {
2322 return SD_SWITCH_ERROR;
2323 }
2324
2325 timeout = SD_DATATIMEOUT;
2326 do
2327 {
2328 timeout--;
2329 status = sd_status_send(&card_status);
2330 } /* check ready_for_data flag */
2331 while(((card_status & 0x00000100) == 0) && (timeout > 0));
2332
2333 if(timeout == 0)
2334 {
2335 return SD_ERROR;
2336 }
2337
2338 return status;
2339}
2340
2349 sd_error_status_type sd_switch(uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
2350{
2351 sd_error_status_type status = SD_OK;
2352 uint8_t power;
2353 uint16_t blk_size;
2354
2355 if(rsp == NULL)
2356 {
2357 return SD_INVALID_PARAMETER;
2358 }
2359
2360 SDIOx->dtctrl = 0x0;
2361
2362 blk_size = 64;
2363 power = convert_from_bytes_to_power_of_two(blk_size);
2364
2365 sdio_command_init_struct.argument = blk_size;
2366 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
2367 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2368 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2369
2370 /* sdio command config */
2371 sdio_command_config(SDIOx, &sdio_command_init_struct);
2372 /* enable ccsm */
2373 sdio_command_state_machine_enable(SDIOx, TRUE);
2374
2375 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
2376
2377 if(status != SD_OK)
2378 {
2379 return status;
2380 }
2381
2382 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
2383 sdio_data_init_struct.data_length = blk_size ;
2384 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
2385 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
2386 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
2387
2388 sdio_command_init_struct.argument = (mode << 31) | 0x00FFFFFF;
2389 sdio_command_init_struct.argument &= ~(0xF << (group * 4));
2390 sdio_command_init_struct.argument |= value << (group * 4);
2391 sdio_command_init_struct.cmd_index = SD_CMD_HS_SWITCH;
2392 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2393 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2394
2395 stop_flag = 0;
2396
2397 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)rsp);
2398}
2399
2405 sd_error_status_type check_card_programming(uint8_t *p_status)
2406{
2407 volatile uint32_t response = 0, sts_reg = 0, rsp_cmd = 0;
2408
2409 /* send cmd13 */
2410 sdio_command_init_struct.argument = (uint32_t)(rca << 16);
2411 sdio_command_init_struct.cmd_index = SD_CMD_SEND_STATUS;
2412 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2413 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2414
2415 /* sdio command config */
2416 sdio_command_config(SDIOx, &sdio_command_init_struct);
2417 /* enable ccsm */
2418 sdio_command_state_machine_enable(SDIOx, TRUE);
2419
2420 sts_reg = SDIOx->sts;
2421
2422 while(!(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG)))
2423 {
2424 sts_reg = SDIOx->sts;
2425 }
2426
2427 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2428 {
2429 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2430 return SD_CMD_FAIL;
2431 }
2432
2433 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2434 {
2435 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2436 return SD_CMD_RSP_TIMEOUT;
2437 }
2438
2439 rsp_cmd = sdio_command_response_get(SDIOx);
2440 if(rsp_cmd!= SD_CMD_SEND_STATUS)
2441 {
2442 return SD_ILLEGAL_CMD;
2443 }
2444
2445 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2446
2447 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2448
2449 *p_status = (uint8_t)((response >> 9) & 0x0000000F);
2450
2451 return SD_OK;
2452}
2453
2459 sd_error_status_type sd_status_send(uint32_t *p_card_status)
2460{
2461 sd_error_status_type status = SD_OK;
2462
2463 if(p_card_status == NULL)
2464 {
2465 status = SD_INVALID_PARAMETER;
2466 return status;
2467 }
2468
2469 sdio_command_init_struct.argument = (uint32_t)(rca << 16);
2470 sdio_command_init_struct.cmd_index = SD_CMD_SEND_STATUS;
2471 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2472 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2473
2474 /* sdio command config */
2475 sdio_command_config(SDIOx, &sdio_command_init_struct);
2476 /* enable ccsm */
2477 sdio_command_state_machine_enable(SDIOx, TRUE);
2478
2479 status = command_rsp1_error(SD_CMD_SEND_STATUS);
2480
2481 if(status != SD_OK)
2482 {
2483 return status;
2484 }
2485
2486 *p_card_status = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2487
2488 return status;
2489}
2490
2496 sd_card_state_type sd_state_get(void)
2497{
2498 uint32_t response = 0;
2499
2500 if(sd_status_send(&response) != SD_OK)
2501 {
2502 return SD_CARD_ERROR;
2503 }
2504 else
2505 {
2506 return (sd_card_state_type)((response >> 9) & 0x0F);
2507 }
2508}
2509
2514 sd_error_status_type scr_find(void)
2515{
2516 uint32_t index = 0, sts_reg = 0;
2517 sd_error_status_type status = SD_OK;
2518 uint32_t *tempscr;
2519
2520 tempscr = (uint32_t *) &(sd_card_info.sd_scr_reg);
2521
2522 /* send cmd16, set block length */
2523 sdio_command_init_struct.argument = (uint32_t)8;
2524 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
2525 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2526 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2527
2528 /* sdio command config */
2529 sdio_command_config(SDIOx, &sdio_command_init_struct);
2530 /* enable ccsm */
2531 sdio_command_state_machine_enable(SDIOx, TRUE);
2532
2533 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
2534
2535 if(status != SD_OK)
2536 {
2537 return status;
2538 }
2539
2540 /* send cmd55 */
2541 sdio_command_init_struct.argument = (uint32_t)(sd_card_info.rca << 16);
2542 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
2543 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2544 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2545
2546 /* sdio command config */
2547 sdio_command_config(SDIOx, &sdio_command_init_struct);
2548 /* enable ccsm */
2549 sdio_command_state_machine_enable(SDIOx, TRUE);
2550
2551 status = command_rsp1_error(SD_CMD_APP_CMD);
2552
2553 if(status != SD_OK)
2554 {
2555 return status;
2556 }
2557
2558 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_8B;
2559 sdio_data_init_struct.data_length = 8;
2560 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
2561 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
2562 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
2563
2564 sdio_data_config(SDIOx, &sdio_data_init_struct);
2565 sdio_data_state_machine_enable(SDIOx, TRUE);
2566
2567 /* send cmd51 */
2568 sdio_command_init_struct.argument = 0x0;
2569 sdio_command_init_struct.cmd_index = SD_CMD_SD_APP_SEND_SCR;
2570 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2571 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2572
2573 /* sdio command config */
2574 sdio_command_config(SDIOx, &sdio_command_init_struct);
2575 /* enable ccsm */
2576 sdio_command_state_machine_enable(SDIOx, TRUE);
2577
2578 status = command_rsp1_error(SD_CMD_SD_APP_SEND_SCR);
2579
2580 if(status != SD_OK)
2581 {
2582 return status;
2583 }
2584
2585 sts_reg = SDIOx->sts;
2586
2587 while(!(sts_reg & (SDIO_RXERRO_FLAG | SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_DTBLKCMPL_FLAG | SDIO_SBITERR_FLAG)))
2588 {
2589 if(sdio_flag_get(SDIOx, SDIO_RXBUF_FLAG) != RESET)
2590 {
2591 *(tempscr + index) = sdio_data_read(SDIOx);
2592 index++;
2593 }
2594 sts_reg = SDIOx->sts;
2595 }
2596
2597 if(sdio_flag_get(SDIOx, SDIO_DTTIMEOUT_FLAG) != RESET)
2598 {
2599 sdio_flag_clear(SDIOx, SDIO_DTTIMEOUT_FLAG);
2600 return SD_DATA_TIMEOUT;
2601 }
2602 else if(sdio_flag_get(SDIOx, SDIO_DTFAIL_FLAG) != RESET)
2603 {
2604 sdio_flag_clear(SDIOx, SDIO_DTFAIL_FLAG);
2605 return SD_DATA_FAIL;
2606 }
2607 else if(sdio_flag_get(SDIOx, SDIO_RXERRO_FLAG) != RESET)
2608 {
2609 sdio_flag_clear(SDIOx, SDIO_RXERRO_FLAG);
2610 return SD_RX_OVERRUN;
2611 }
2612 else if(sdio_flag_get(SDIOx, SDIO_SBITERR_FLAG) != RESET)
2613 {
2614 sdio_flag_clear(SDIOx, SDIO_SBITERR_FLAG);
2615 return SD_START_BIT_ERR;
2616 }
2617
2618 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2619
2620 return status;
2621}
2622
2628 sd_error_status_type speed_change(uint8_t speed)
2629{
2630 sd_error_status_type status = SD_OK;
2631 uint8_t switch_sts[64];
2632
2633 if(speed > 1)
2634 {
2635 return SD_ERROR;
2636 }
2637
2638 /* check card type */
2639 if((SDIO_STD_CAPACITY_SD_CARD_V1_1 == card_type) || (SDIO_STD_CAPACITY_SD_CARD_V2_0 == card_type) || \
2640 (SDIO_HIGH_CAPACITY_SD_CARD == card_type))
2641 {
2642 /* version 1.01 card does not support cmd6 */
2643 if(sd_card_info.sd_scr_reg.sd_spec == 0)
2644 {
2645 return SD_ERROR;
2646 }
2647
2648 /* check group 1 function support speed */
2649 status = sd_switch(0, 0, speed, switch_sts);
2650
2651 if(status != 0)
2652 {
2653 return status;
2654 }
2655
2656 if((switch_sts[13] & (1 << speed)) == 0)
2657 {
2658 return SD_ERROR;
2659 }
2660
2661 status = sd_switch(1, 0, speed, switch_sts);
2662
2663 if(status != 0)
2664 {
2665 return status;
2666 }
2667
2668 /* read it back for confirmation */
2669 if((switch_sts[16] & 0xF) != speed)
2670 {
2671 return SD_ERROR;
2672 }
2673 }
2674 else if(card_type == SDIO_HIGH_SPEED_MULTIMEDIA_CARD)
2675 {
2676 status = mmc_switch(EXT_CSD_CMD_SET_NORMAL, EXT_CSD_BUS_WIDTH, (uint8_t)speed);
2677
2678 if(status != 0)
2679 {
2680 return status;
2681 }
2682 }
2683
2684 return status;
2685}
2686
2692uint8_t convert_from_bytes_to_power_of_two(uint16_t number_of_bytes)
2693{
2694 uint8_t count = 0;
2695
2696 while(number_of_bytes != 1)
2697 {
2698 number_of_bytes >>= 1;
2699 count++;
2700 }
2701
2702 return count;
2703}
2704
2713void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
2714{
2715 dma_init_type dma_init_struct;
2716 dma_default_para_init(&dma_init_struct);
2717
2718 crm_periph_clock_enable(CRM_DMA2_PERIPH_CLOCK, TRUE);
2719
2720 dma_reset(DMA2_CHANNEL4);
2721 dma_channel_enable(DMA2_CHANNEL4, FALSE);
2722
2723 dma_init_struct.peripheral_base_addr = (uint32_t)&SDIOx->buf;
2724 dma_init_struct.memory_base_addr = (uint32_t)mbuf;
2725 dma_init_struct.direction = dir;
2726 dma_init_struct.buffer_size = buf_size / 4;
2727 dma_init_struct.peripheral_inc_enable = FALSE;
2728 dma_init_struct.memory_inc_enable = TRUE;
2729 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_WORD;
2730 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_WORD;
2731 dma_init_struct.loop_mode_enable = FALSE;
2732 dma_init_struct.priority = DMA_PRIORITY_HIGH;
2733 dma_init(DMA2_CHANNEL4, &dma_init_struct);
2734
2735 dmamux_init(DMA2MUX_CHANNEL4, DMAMUX_SDIOx);
2736 dmamux_enable(DMA2, TRUE);
2737 dma_channel_enable(DMA2_CHANNEL4, TRUE);
2738}
2739
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
sd_card_info
sd_card_info_struct_type sd_card_info
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:49
sd_switch
sd_error_status_type sd_switch(uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
switch sd card speed to high speed
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:2349
command_rsp5_error
sd_error_status_type command_rsp5_error(uint8_t cmd)
checks for error conditions for r5 response.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:2100
speed_change
sd_error_status_type speed_change(uint8_t speed)
set bus speed
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:2628
sd_power_off
sd_error_status_type sd_power_off(void)
turns the sdio output signals off.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:410
sdio_data_init_struct
sdio_data_struct_type sdio_data_init_struct
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:41
sd_irq_service
sd_error_status_type sd_irq_service(void)
allows to process all the interrupts that are high.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:1796
transfer_end
volatile uint8_t transfer_end
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:48
command_rsp7_error
sd_error_status_type command_rsp7_error(void)
checks for error conditions for R7 response.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:1907
sd_device_mode_set
sd_error_status_type sd_device_mode_set(uint32_t mode)
set sdio work mode.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:793
card_type
static sd_memory_card_type card_type
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:43
convert_from_bytes_to_power_of_two
uint8_t convert_from_bytes_to_power_of_two(uint16_t number_of_bytes)
converts the number of bytes in power of two and returns the power.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:2692
sd_card_info_get
sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info)
returns information about specific card.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:539
sdio_command_init_struct
sdio_command_struct_type sdio_command_init_struct
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:40
mmc_stream_write
sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:1707
sd_card_init
sd_error_status_type sd_card_init(void)
intialises all cards or single card as the case may be card(s) come into standby state.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:424
sd_block_read
sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma ...
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:1195
sd_deselect_select
sd_error_status_type sd_deselect_select(uint32_t addr)
selects od deselects the corresponding card.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:814
command_rsp6_error
sd_error_status_type command_rsp6_error(uint8_t cmd, uint16_t *p_rca)
checks for error conditions for r6 (rca) response.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:2163
SDIO1_IRQHandler
void SDIO1_IRQHandler(void)
sdio1 isr.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:1776
stop_flag
static uint8_t stop_flag
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:46
mmc_switch
sd_error_status_type mmc_switch(uint8_t set, uint8_t index, uint8_t value)
switch mmc card speed to high speed
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:2298
sd_blocks_erase
sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks)
erase continuous data block
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:1037
check_card_programming
sd_error_status_type check_card_programming(uint8_t *p_status)
checks if the sd card is in programming state.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:2405
transfer_error
volatile sd_error_status_type transfer_error
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:47
sd_bus_wide_enable
sd_error_status_type sd_bus_wide_enable(confirm_state new_state)
enable or disable the sdio wide bus mode.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:2229
command_rsp1_error
sd_error_status_type command_rsp1_error(uint8_t cmd)
checks for error conditions for R1 response.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:1944
SDIO2_IRQHandler
void SDIO2_IRQHandler(void)
sdio2 isr.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:1786
sd_mult_blocks_write
sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed ...
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:1496
csd_table
static uint32_t csd_table[4]
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:44
sdio_clock_set
void sdio_clock_set(uint32_t clk_div)
set sdio clock devision factor.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:195
sd_state_get
sd_card_state_type sd_state_get(void)
returns information about sd card.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:2496
cid_table
static uint32_t cid_table[4]
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:44
sd_dma_config
void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:2713
sd_block_write
sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be manag...
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:1374
device_mode
static sd_data_transfer_mode_type device_mode
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:45
sd_status_send
sd_error_status_type sd_status_send(uint32_t *p_card_status)
read current card status.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:2459
sdio_command_data_send
sd_error_status_type sdio_command_data_send(sdio_command_struct_type *sdio_cmd_init_t, sdio_data_struct_type *sdio_data_init_t, uint32_t *buf)
read data from or write data to sd card.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:837
command_rsp2_error
sd_error_status_type command_rsp2_error(void)
checks for error conditions for R2 (cid or csd) response.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:2017
sd_init
sd_error_status_type sd_init(void)
initializes the sd card and put it into standby state (ready for data transfer).
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:73
mmc_stream_read
sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:1660
scr_find
sd_error_status_type scr_find(void)
find the sd card scr register value.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:2514
sd_power_on
sd_error_status_type sd_power_on(void)
enquires cards about their operating voltage and configures clock controls.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:210
command_rsp4_error
sd_error_status_type command_rsp4_error(uint8_t cmd)
checks for error conditions for r4 response.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:2057
sd_mult_blocks_read
sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mod...
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:1284
sd_wide_bus_operation_config
sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:750
rca
static uint32_t rca
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:44
command_rsp3_error
sd_error_status_type command_rsp3_error(void)
checks for error conditions for R3 (ocr) response.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:1987
command_error
sd_error_status_type command_error(void)
checks for error conditions for cmd0.
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c:1880
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
system_core_clock
unsigned int system_core_clock
Definition: system_at32f435_437.c:48
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_SDIO1_PERIPH_CLOCK
@ CRM_SDIO1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:121
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_DMA2_PERIPH_CLOCK
@ CRM_DMA2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:116
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f435_437_dma.h:151
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:164
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:174
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMA2MUX_CHANNEL4
#define DMA2MUX_CHANNEL4
Definition: at32f435_437_dma.h:729
DMA2
#define DMA2
Definition: at32f435_437_dma.h:717
DMA2_CHANNEL4
#define DMA2_CHANNEL4
Definition: at32f435_437_dma.h:721
confirm_state
confirm_state
Definition: at32f435_437.h:379
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
SDIO_SEND_IF_COND
#define SDIO_SEND_IF_COND
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:441
SD_CMD_SD_APP_SEND_SCR
#define SD_CMD_SD_APP_SEND_SCR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:311
SD_CMD_ERASE
#define SD_CMD_ERASE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:294
SD_CMD_APP_SD_SET_BUSWIDTH
#define SD_CMD_APP_SD_SET_BUSWIDTH
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:306
SD_CMD_WRITE_SINGLE_BLOCK
#define SD_CMD_WRITE_SINGLE_BLOCK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:283
SD_CMD_SD_ERASE_GRP_START
#define SD_CMD_SD_ERASE_GRP_START
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:290
SD_CMD_APP_CMD
#define SD_CMD_APP_CMD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:298
SD_CMD_ALL_SEND_CID
#define SD_CMD_ALL_SEND_CID
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:263
SD_CMD_STOP_TRANSMISSION
#define SD_CMD_STOP_TRANSMISSION
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:273
SD_CMD_SEND_STATUS
#define SD_CMD_SEND_STATUS
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:274
SD_CMD_SET_BLOCK_COUNT
#define SD_CMD_SET_BLOCK_COUNT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:282
SD_CMD_WRITE_DAT_UNTIL_STOP
#define SD_CMD_WRITE_DAT_UNTIL_STOP
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:281
SD_CMD_SEND_OP_COND
#define SD_CMD_SEND_OP_COND
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:262
SD_CMD_SET_BLOCKLEN
#define SD_CMD_SET_BLOCKLEN
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:277
SD_CMD_HS_SWITCH
#define SD_CMD_HS_SWITCH
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:267
SD_CMD_READ_SINGLE_BLOCK
#define SD_CMD_READ_SINGLE_BLOCK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:278
SD_CMD_SD_APP_OP_COND
#define SD_CMD_SD_APP_OP_COND
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:309
SD_CMD_GO_IDLE_STATE
#define SD_CMD_GO_IDLE_STATE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:261
SD_CMD_SET_REL_ADDR
#define SD_CMD_SET_REL_ADDR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:264
SD_CMD_ERASE_GRP_END
#define SD_CMD_ERASE_GRP_END
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:293
SD_CMD_READ_DAT_UNTIL_STOP
#define SD_CMD_READ_DAT_UNTIL_STOP
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:272
SD_CMD_SD_ERASE_GRP_END
#define SD_CMD_SD_ERASE_GRP_END
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:291
SD_CMD_ERASE_GRP_START
#define SD_CMD_ERASE_GRP_START
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:292
SD_CMD_SEL_DESEL_CARD
#define SD_CMD_SEL_DESEL_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:268
SD_CMD_WRITE_MULT_BLOCK
#define SD_CMD_WRITE_MULT_BLOCK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:284
SD_CMD_READ_MULT_BLOCK
#define SD_CMD_READ_MULT_BLOCK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:279
SD_CMD_SEND_CSD
#define SD_CMD_SEND_CSD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:270
sdio_command_config
void sdio_command_config(sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command.
Definition: at32f435_437_sdio.c:329
sdio_data_write
void sdio_data_write(sdio_type *sdio_x, uint32_t data)
write one word data to fifo.
Definition: at32f435_437_sdio.c:490
sdio_data_config
void sdio_data_config(sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data.
Definition: at32f435_437_sdio.c:416
sdio_data_read
uint32_t sdio_data_read(sdio_type *sdio_x)
read a word data from sdio fifo.
Definition: at32f435_437_sdio.c:465
sdio_command_state_machine_enable
void sdio_command_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM).
Definition: at32f435_437_sdio.c:352
sdio_clock_bypass
void sdio_clock_bypass(sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss
Definition: at32f435_437_sdio.c:141
sdio_flow_control_enable
void sdio_flow_control_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control.
Definition: at32f435_437_sdio.c:168
sdio_power_set
void sdio_power_set(sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller
Definition: at32f435_437_sdio.c:75
sdio_clock_config
void sdio_clock_config(sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock
Definition: at32f435_437_sdio.c:104
sdio_bus_width_config
void sdio_bus_width_config(sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width
Definition: at32f435_437_sdio.c:128
sdio_interrupt_enable
void sdio_interrupt_enable(sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt.
Definition: at32f435_437_sdio.c:232
sdio_flag_clear
void sdio_flag_clear(sdio_type *sdio_x, uint32_t flag)
clear sdio flag.
Definition: at32f435_437_sdio.c:315
sdio_power_status_get
sdio_power_state_type sdio_power_status_get(sdio_type *sdio_x)
get power status.
Definition: at32f435_437_sdio.c:87
sdio_response_get
uint32_t sdio_response_get(sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command.
Definition: at32f435_437_sdio.c:383
sdio_data_state_machine_enable
void sdio_data_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM).
Definition: at32f435_437_sdio.c:441
sdio_power_saving_mode_enable
void sdio_power_saving_mode_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle.
Definition: at32f435_437_sdio.c:155
sdio_flag_get
flag_status sdio_flag_get(sdio_type *sdio_x, uint32_t flag)
get sdio flag.
Definition: at32f435_437_sdio.c:278
sdio_dma_enable
void sdio_dma_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable dma.
Definition: at32f435_437_sdio.c:194
sdio_reset
void sdio_reset(sdio_type *sdio_x)
reset the sdio register
Definition: at32f435_437_sdio.c:51
sdio_clock_enable
void sdio_clock_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output.
Definition: at32f435_437_sdio.c:181
sdio_command_response_get
uint8_t sdio_command_response_get(sdio_type *sdio_x)
get command index of last command for which response received.
Definition: at32f435_437_sdio.c:365
sd_data_transfer_mode_type
sd_data_transfer_mode_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:66
sd_error_status_type
sd_error_status_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:75
sd_card_state_type
sd_card_state_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:188
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f435_437_sdio.h:139
sd_memory_card_type
sd_memory_card_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:204
sdio_block_size_type
sdio_block_size_type
sdio data block size
Definition: at32f435_437_sdio.h:180
SDIO_WAIT_FOR_NO
@ SDIO_WAIT_FOR_NO
Definition: at32f435_437_sdio.h:160
SDIO_WAIT_FOR_INT
@ SDIO_WAIT_FOR_INT
Definition: at32f435_437_sdio.h:161
SDIO_RESPONSE_LONG
@ SDIO_RESPONSE_LONG
Definition: at32f435_437_sdio.h:152
SDIO_RESPONSE_SHORT
@ SDIO_RESPONSE_SHORT
Definition: at32f435_437_sdio.h:151
SDIO_RESPONSE_NO
@ SDIO_RESPONSE_NO
Definition: at32f435_437_sdio.h:150
SD_TRANSFER_DMA_MODE
@ SD_TRANSFER_DMA_MODE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:68
SD_TRANSFER_POLLING_MODE
@ SD_TRANSFER_POLLING_MODE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:67
SD_ERROR
@ SD_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:119
SD_SDIO_UNKNOWN_FUNC
@ SD_SDIO_UNKNOWN_FUNC
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:109
SD_DATA_FAIL
@ SD_DATA_FAIL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:78
SD_INVALID_PARAMETER
@ SD_INVALID_PARAMETER
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:116
SD_CMD_FAIL
@ SD_CMD_FAIL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:77
SD_CMD_OUT_OF_RANGE
@ SD_CMD_OUT_OF_RANGE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:84
SD_GENERAL_UNKNOWN_ERROR
@ SD_GENERAL_UNKNOWN_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:95
SD_UNSUPPORTED_FEATURE
@ SD_UNSUPPORTED_FEATURE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:117
SD_TX_UNDERRUN
@ SD_TX_UNDERRUN
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:81
SD_ILLEGAL_CMD
@ SD_ILLEGAL_CMD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:92
SD_CMD_CRC_ERROR
@ SD_CMD_CRC_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:91
SD_RX_OVERRUN
@ SD_RX_OVERRUN
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:82
SD_REQ_NOT_APPLICABLE
@ SD_REQ_NOT_APPLICABLE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:115
SD_SWITCH_ERROR
@ SD_SWITCH_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:105
SD_INVALID_VOLTRANGE
@ SD_INVALID_VOLTRANGE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:103
SD_DATA_TIMEOUT
@ SD_DATA_TIMEOUT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:80
SD_START_BIT_ERR
@ SD_START_BIT_ERR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:83
SD_LOCK_UNLOCK_ERROR
@ SD_LOCK_UNLOCK_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:90
SD_CMD_RSP_TIMEOUT
@ SD_CMD_RSP_TIMEOUT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:79
SD_OK
@ SD_OK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:120
SDIO_CLOCK_EDGE_FALLING
@ SDIO_CLOCK_EDGE_FALLING
Definition: at32f435_437_sdio.h:132
SDIO_DATA_TRANSFER_TO_CARD
@ SDIO_DATA_TRANSFER_TO_CARD
Definition: at32f435_437_sdio.h:212
SDIO_DATA_TRANSFER_TO_CONTROLLER
@ SDIO_DATA_TRANSFER_TO_CONTROLLER
Definition: at32f435_437_sdio.h:213
SDIO_POWER_OFF
@ SDIO_POWER_OFF
Definition: at32f435_437_sdio.h:122
SDIO_POWER_ON
@ SDIO_POWER_ON
Definition: at32f435_437_sdio.h:123
SD_CARD_ERROR
@ SD_CARD_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:197
SDIO_DATA_BLOCK_TRANSFER
@ SDIO_DATA_BLOCK_TRANSFER
Definition: at32f435_437_sdio.h:203
SDIO_DATA_STREAM_TRANSFER
@ SDIO_DATA_STREAM_TRANSFER
Definition: at32f435_437_sdio.h:204
SDIO_BUS_WIDTH_D1
@ SDIO_BUS_WIDTH_D1
Definition: at32f435_437_sdio.h:140
SDIO_BUS_WIDTH_D4
@ SDIO_BUS_WIDTH_D4
Definition: at32f435_437_sdio.h:141
SDIO_RSP3_INDEX
@ SDIO_RSP3_INDEX
Definition: at32f435_437_sdio.h:172
SDIO_RSP2_INDEX
@ SDIO_RSP2_INDEX
Definition: at32f435_437_sdio.h:171
SDIO_RSP4_INDEX
@ SDIO_RSP4_INDEX
Definition: at32f435_437_sdio.h:173
SDIO_RSP1_INDEX
@ SDIO_RSP1_INDEX
Definition: at32f435_437_sdio.h:170
SDIO_HIGH_CAPACITY_SD_CARD
@ SDIO_HIGH_CAPACITY_SD_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:207
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
@ SDIO_SECURE_DIGITAL_IO_COMBO_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:211
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
@ SDIO_HIGH_SPEED_MULTIMEDIA_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:210
SDIO_STD_CAPACITY_SD_CARD_V1_1
@ SDIO_STD_CAPACITY_SD_CARD_V1_1
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:205
SDIO_SECURE_DIGITAL_IO_CARD
@ SDIO_SECURE_DIGITAL_IO_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:209
SDIO_STD_CAPACITY_SD_CARD_V2_0
@ SDIO_STD_CAPACITY_SD_CARD_V2_0
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:206
SDIO_MULTIMEDIA_CARD
@ SDIO_MULTIMEDIA_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:208
SDIO_DATA_BLOCK_SIZE_8B
@ SDIO_DATA_BLOCK_SIZE_8B
Definition: at32f435_437_sdio.h:184
SDIO_DATA_BLOCK_SIZE_1B
@ SDIO_DATA_BLOCK_SIZE_1B
Definition: at32f435_437_sdio.h:181
SDIO_CMDTIMEOUT_FLAG
#define SDIO_CMDTIMEOUT_FLAG
Definition: at32f435_437_sdio.h:87
SDIO_TXBUFH_FLAG
#define SDIO_TXBUFH_FLAG
Definition: at32f435_437_sdio.h:99
SDIO_CMDCMPL_FLAG
#define SDIO_CMDCMPL_FLAG
Definition: at32f435_437_sdio.h:92
SDIO_DTFAIL_FLAG
#define SDIO_DTFAIL_FLAG
Definition: at32f435_437_sdio.h:86
SDIO_RXERRO_FLAG
#define SDIO_RXERRO_FLAG
Definition: at32f435_437_sdio.h:90
SDIO_RXBUFH_FLAG
#define SDIO_RXBUFH_FLAG
Definition: at32f435_437_sdio.h:100
SDIO_RXBUF_FLAG
#define SDIO_RXBUF_FLAG
Definition: at32f435_437_sdio.h:106
SDIO_CMDFAIL_FLAG
#define SDIO_CMDFAIL_FLAG
Definition: at32f435_437_sdio.h:85
SDIO_CMDRSPCMPL_FLAG
#define SDIO_CMDRSPCMPL_FLAG
Definition: at32f435_437_sdio.h:91
SDIO_DTBLKCMPL_FLAG
#define SDIO_DTBLKCMPL_FLAG
Definition: at32f435_437_sdio.h:95
SDIO_DTTIMEOUT_FLAG
#define SDIO_DTTIMEOUT_FLAG
Definition: at32f435_437_sdio.h:88
SDIO_SBITERR_FLAG
#define SDIO_SBITERR_FLAG
Definition: at32f435_437_sdio.h:94
SDIO_DTCMPL_FLAG
#define SDIO_DTCMPL_FLAG
Definition: at32f435_437_sdio.h:93
SDIO_TXERRU_FLAG
#define SDIO_TXERRU_FLAG
Definition: at32f435_437_sdio.h:89
DMAMUX_SDIOx
#define DMAMUX_SDIOx
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:52
SDIOx
#define SDIOx
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:51
SDIO_INTR_STS_WRITE_MASK
#define SDIO_INTR_STS_WRITE_MASK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:477
SDIO_INTR_STS_READ_MASK
#define SDIO_INTR_STS_READ_MASK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:479
SDIO_SBITERR_INT
#define SDIO_SBITERR_INT
Definition: at32f435_437_sdio.h:61
SDIO_RXBUFH_INT
#define SDIO_RXBUFH_INT
Definition: at32f435_437_sdio.h:67
SDIO_DTTIMEOUT_INT
#define SDIO_DTTIMEOUT_INT
Definition: at32f435_437_sdio.h:55
SDIO_TXERRU_INT
#define SDIO_TXERRU_INT
Definition: at32f435_437_sdio.h:56
SDIO_RXERRO_INT
#define SDIO_RXERRO_INT
Definition: at32f435_437_sdio.h:57
SDIO_DTFAIL_INT
#define SDIO_DTFAIL_INT
Definition: at32f435_437_sdio.h:53
SDIO_TXBUFH_INT
#define SDIO_TXBUFH_INT
Definition: at32f435_437_sdio.h:66
SDIO_DTCMP_INT
#define SDIO_DTCMP_INT
Definition: at32f435_437_sdio.h:60
EXT_CSD_BUS_WIDTH
#define EXT_CSD_BUS_WIDTH
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:466
EXT_CSD_CMD_SET_NORMAL
#define EXT_CSD_CMD_SET_NORMAL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:459
EXT_CSD_Write_byte
#define EXT_CSD_Write_byte
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:457
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
SDIO_DATATIMEOUT
#define SDIO_DATATIMEOUT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:345
SDIO_CMD0TIMEOUT
#define SDIO_CMD0TIMEOUT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:344
SDIO_STATIC_FLAGS
#define SDIO_STATIC_FLAGS
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:343
SD_CARD_LOCKED
#define SD_CARD_LOCKED
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:403
SD_VOLTAGE_WINDOW_SD
#define SD_VOLTAGE_WINDOW_SD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:394
SD_R5_ERROR
#define SD_R5_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:386
SD_CARD_RECEIVING
#define SD_CARD_RECEIVING
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:405
SD_R5_OUT_OF_RANGE
#define SD_R5_OUT_OF_RANGE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:384
SD_MAX_DATA_LENGTH
#define SD_MAX_DATA_LENGTH
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:411
SD_STD_CAPACITY
#define SD_STD_CAPACITY
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:396
SD_R5_FUNCTION_NUMBER
#define SD_R5_FUNCTION_NUMBER
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:385
SD_R6_ILLEGAL_CMD
#define SD_R6_ILLEGAL_CMD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:392
SD_R6_GENERAL_UNKNOWN_ERROR
#define SD_R6_GENERAL_UNKNOWN_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:391
SD_MAX_VOLT_TRIAL
#define SD_MAX_VOLT_TRIAL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:399
SD_DATATIMEOUT
#define SD_DATATIMEOUT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:406
SD_ALLZERO
#define SD_ALLZERO
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:400
SD_R6_CMD_CRC_ERROR
#define SD_R6_CMD_CRC_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:393
MMC_SWITCH_ERROR
#define MMC_SWITCH_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:377
SD_VOLTAGE_WINDOW_MMC
#define SD_VOLTAGE_WINDOW_MMC
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:398
SD_CHECK_PATTERN
#define SD_CHECK_PATTERN
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:397
SD_OCR_ERRORBITS
#define SD_OCR_ERRORBITS
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:379
SD_CARD_PROGRAMMING
#define SD_CARD_PROGRAMMING
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:404
SD_HIGH_CAPACITY
#define SD_HIGH_CAPACITY
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:395
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
sd_card_info_struct_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:238
sd_card_info_struct_type::sd_scr_reg
sd_scr_struct_type sd_scr_reg
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:241
sd_card_info_struct_type::card_capacity
long long card_capacity
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:242
sd_card_info_struct_type::sd_cid_reg
sd_cid_struct_type sd_cid_reg
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:240
sd_card_info_struct_type::sd_csd_reg
sd_csd_struct_type sd_csd_reg
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:239
sd_card_info_struct_type::card_blk_size
uint32_t card_blk_size
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:243
sd_card_info_struct_type::rca
uint16_t rca
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:244
sd_card_info_struct_type::card_type
uint8_t card_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:245
sd_cid_struct_type::reserved1
uint8_t reserved1
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:178
sd_cid_struct_type::product_name2
uint8_t product_name2
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:175
sd_cid_struct_type::manufact_date
uint16_t manufact_date
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:179
sd_cid_struct_type::cid_crc
uint8_t cid_crc
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:180
sd_cid_struct_type::product_reversion
uint8_t product_reversion
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:176
sd_cid_struct_type::manufacturer_id
uint8_t manufacturer_id
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:172
sd_cid_struct_type::product_sn
uint32_t product_sn
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:177
sd_cid_struct_type::product_name1
uint32_t product_name1
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:174
sd_cid_struct_type::reserved2
uint8_t reserved2
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:181
sd_cid_struct_type::oem_app_id
uint16_t oem_app_id
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:173
sd_csd_struct_type::spec_version
uint8_t spec_version
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:129
sd_csd_struct_type::max_write_current_vdd_max
uint8_t max_write_current_vdd_max
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:145
sd_csd_struct_type::nsac
uint8_t nsac
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:132
sd_csd_struct_type::card_cmd_classes
uint16_t card_cmd_classes
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:134
sd_csd_struct_type::part_blk_read
uint8_t part_blk_read
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:136
sd_csd_struct_type::read_blk_misalign
uint8_t read_blk_misalign
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:138
sd_csd_struct_type::content_protect_app
uint8_t content_protect_app
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:156
sd_csd_struct_type::write_speed_factor
uint8_t write_speed_factor
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:152
sd_csd_struct_type::max_read_blk_length
uint8_t max_read_blk_length
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:135
sd_csd_struct_type::max_bus_clk_freq
uint8_t max_bus_clk_freq
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:133
sd_csd_struct_type::ecc_code
uint8_t ecc_code
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:162
sd_csd_struct_type::reserved4
uint8_t reserved4
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:164
sd_csd_struct_type::dsr_implemented
uint8_t dsr_implemented
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:139
sd_csd_struct_type::max_read_current_vdd_min
uint8_t max_read_current_vdd_min
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:142
sd_csd_struct_type::reserved2
uint8_t reserved2
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:140
sd_csd_struct_type::erase_group_size_mult
uint8_t erase_group_size_mult
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:148
sd_csd_struct_type::file_formart
uint8_t file_formart
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:161
sd_csd_struct_type::temp_write_protect
uint8_t temp_write_protect
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:160
sd_csd_struct_type::permanent_write_protect
uint8_t permanent_write_protect
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:159
sd_csd_struct_type::max_read_current_vdd_max
uint8_t max_read_current_vdd_max
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:143
sd_csd_struct_type::file_format_group
uint8_t file_format_group
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:157
sd_csd_struct_type::device_size
uint32_t device_size
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:141
sd_csd_struct_type::write_blk_misalign
uint8_t write_blk_misalign
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:137
sd_csd_struct_type::csd_struct
uint8_t csd_struct
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:128
sd_csd_struct_type::write_protect_group_enable
uint8_t write_protect_group_enable
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:150
sd_csd_struct_type::max_write_current_vdd_min
uint8_t max_write_current_vdd_min
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:144
sd_csd_struct_type::reserved1
uint8_t reserved1
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:130
sd_csd_struct_type::max_write_blk_length
uint8_t max_write_blk_length
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:153
sd_csd_struct_type::csd_crc
uint8_t csd_crc
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:163
sd_csd_struct_type::write_protect_group_size
uint8_t write_protect_group_size
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:149
sd_csd_struct_type::reserved3
uint8_t reserved3
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:155
sd_csd_struct_type::taac
uint8_t taac
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:131
sd_csd_struct_type::manufacturer_default_ecc
uint8_t manufacturer_default_ecc
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:151
sd_csd_struct_type::part_blk_write
uint8_t part_blk_write
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:154
sd_csd_struct_type::copy_flag
uint8_t copy_flag
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:158
sd_csd_struct_type::erase_group_size
uint8_t erase_group_size
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:147
sd_csd_struct_type::device_size_mult
uint8_t device_size_mult
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:146
sd_scr_struct_type::sd_bus_width
uint32_t sd_bus_width
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:223
sd_scr_struct_type::sd_spec
uint32_t sd_spec
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:221
sdio_command_struct_type
sdio command structure
Definition: at32f435_437_sdio.h:229
sdio_command_struct_type::cmd_index
uint8_t cmd_index
Definition: at32f435_437_sdio.h:231
sdio_command_struct_type::argument
uint32_t argument
Definition: at32f435_437_sdio.h:230
sdio_command_struct_type::wait_type
sdio_wait_type wait_type
Definition: at32f435_437_sdio.h:233
sdio_command_struct_type::rsp_type
sdio_reponse_type rsp_type
Definition: at32f435_437_sdio.h:232
sdio_data_struct_type
sdio data structure
Definition: at32f435_437_sdio.h:240
sdio_data_struct_type::block_size
sdio_block_size_type block_size
Definition: at32f435_437_sdio.h:243
sdio_data_struct_type::transfer_direction
sdio_transfer_direction_type transfer_direction
Definition: at32f435_437_sdio.h:245
sdio_data_struct_type::timeout
uint32_t timeout
Definition: at32f435_437_sdio.h:241
sdio_data_struct_type::transfer_mode
sdio_transfer_mode_type transfer_mode
Definition: at32f435_437_sdio.h:244
sdio_data_struct_type::data_length
uint32_t data_length
Definition: at32f435_437_sdio.h:242


AT32F435/437 Firmwary Library: diskio.c File Reference

  • at_start_f435
  • examples
  • sdio
  • sdio_fatfs
  • src
Macros | Functions | Variables
at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c File Reference
#include "ff.h"
#include "diskio.h"
#include <string.h>
#include "at32_sdio.h"

Go to the source code of this file.

Macros

#define | DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */
#define | DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */
#define | DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */

Functions

sd_error_status_type | sd_read_disk (uint8_t *buf, uint32_t sector, uint8_t cnt)
read sd card sector More...
sd_error_status_type | sd_write_disk (const uint8_t *buf, uint32_t sector, uint8_t cnt)
write sd card sector More...
DSTATUS | disk_status (BYTE pdrv)
DSTATUS | disk_initialize (BYTE pdrv)
DRESULT | disk_read (BYTE pdrv, BYTE *buff, LBA_t sector, UINT count)
DRESULT | disk_write (BYTE pdrv, const BYTE *buff, LBA_t sector, UINT count)
DRESULT | disk_ioctl (BYTE pdrv, BYTE cmd, void *buff)

Variables

uint8_t sdio_data_buffer [512]

Macro Definition Documentation

◆ DEV_MMC

#define DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */

Definition at line 19 of file at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c.

◆ DEV_RAM

#define DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */

Definition at line 18 of file at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c.

◆ DEV_USB

#define DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */

Definition at line 20 of file at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c.

Function Documentation

◆ disk_initialize()

DSTATUS disk_initialize ( BYTE pdrv )

Definition at line 141 of file at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c.

◆ disk_ioctl()

DRESULT disk_ioctl | ( | BYTE | pdrv,
 |  | BYTE | cmd,
 |  | void * | buff
 | ) |  |

Definition at line 245 of file at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c.

◆ disk_read()

DRESULT disk_read | ( | BYTE | pdrv,
 |  | BYTE * | buff,
 |  | LBA_t | sector,
 |  | UINT | count
 | ) |  |

Definition at line 172 of file at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c.

◆ disk_status()

DSTATUS disk_status ( BYTE pdrv )

Definition at line 110 of file at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c.

◆ disk_write()

DRESULT disk_write | ( | BYTE | pdrv,
 |  | const BYTE * | buff,
 |  | LBA_t | sector,
 |  | UINT | count
 | ) |  |

Definition at line 209 of file at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c.

◆ sd_read_disk()

sd_error_status_type sd_read_disk | ( | uint8_t * | buf,
 |  | uint32_t | sector,
 |  | uint8_t | cnt
 | ) |  |

read sd card sector

Parameters
buf | read data buf
sector | sector address
cnt | sector count
Return values
sd_error_status_type sd card error code.

Definition at line 34 of file at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c.

Referenced by disk_read().

◆ sd_write_disk()

sd_error_status_type sd_write_disk | ( | const uint8_t * | buf,
 |  | uint32_t | sector,
 |  | uint8_t | cnt
 | ) |  |

write sd card sector

Parameters
buf | write data buf
sector | sector address
cnt | sector count
Return values
sd_error_status_type sd card error code.

Definition at line 74 of file at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c.

Referenced by disk_write().

Variable Documentation

◆ sdio_data_buffer

uint8_t sdio_data_buffer[512]

Definition at line 22 of file at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c.

Referenced by sd_read_disk(), and sd_write_disk().


AT32F435/437 Firmwary Library: diskio.c Source File

  • at_start_f435
  • examples
  • sdio
  • sdio_fatfs
  • src
at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c
Go to the documentation of this file.
1/*-----------------------------------------------------------------------*/
2/* Low level disk I/O module SKELETON for FatFs (C)ChaN, 2019 */
3/*-----------------------------------------------------------------------*/
4/* If a working storage control module is available, it should be */
5/* attached to the FatFs via a glue function rather than modifying it. */
6/* This is an example of glue functions to attach various exsisting */
7/* storage control modules to the FatFs module with a defined API. */
8/*-----------------------------------------------------------------------*/
9
10
11#include "ff.h" /* Obtains integer types */
12#include "diskio.h" /* Declarations of disk functions */
13
14#include <string.h>
15#include "at32_sdio.h" /* Example: Header file of existing MMC/SDC contorl module */
16
17/* Definitions of physical drive number for each drive */
18#define DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */
19#define DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */
20#define DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */
21
22uint8_t sdio_data_buffer[512]; /* buf for sd_read_disk/sd_write_disk function used. */
23
24 sd_error_status_type sd_read_disk(uint8_t *buf, uint32_t sector, uint8_t cnt);
25 sd_error_status_type sd_write_disk(const uint8_t *buf, uint32_t sector, uint8_t cnt);
26
34 sd_error_status_type sd_read_disk(uint8_t *buf, uint32_t sector, uint8_t cnt)
35{
36 sd_error_status_type sta = SD_OK;
37 long long lsector = sector;
38 uint8_t n;
39
40 /* data address is in block (512 byte) units. */
41 lsector <<= 9;
42
43 if((uint32_t)buf % 4 != 0)
44 {
45 for(n = 0; n < cnt; n++)
46 {
47 sta = sd_block_read(sdio_data_buffer, lsector + 512 * n, 512);
48 memcpy(buf, sdio_data_buffer, 512);
49 buf += 512;
50 }
51 }
52 else
53 {
54 if(cnt == 1)
55 {
56 sta = sd_block_read(buf, lsector, 512);
57 }
58 else
59 {
60 sta = sd_mult_blocks_read(buf, lsector, 512, cnt);
61 }
62 }
63
64 return sta;
65}
66
74 sd_error_status_type sd_write_disk(const uint8_t *buf, uint32_t sector, uint8_t cnt)
75{
76 sd_error_status_type sta = SD_OK;
77 uint8_t n;
78 long long lsector = sector;
79
80 /* data address is in block (512 byte) units. */
81 lsector <<= 9;
82
83 if((uint32_t)buf % 4 != 0)
84 {
85 for(n = 0; n < cnt; n++)
86 {
87 memcpy(sdio_data_buffer, buf, 512);
88 sta = sd_block_write(sdio_data_buffer, lsector + 512*n, 512);
89 buf += 512;
90 }
91 }
92 else
93 {
94 if(cnt == 1)
95 {
96 sta = sd_block_write(buf, lsector, 512);
97 }
98 else
99 {
100 sta = sd_mult_blocks_write(buf, lsector, 512, cnt);
101 }
102 }
103
104 return sta;
105}
106
107/*-----------------------------------------------------------------------*/
108/* Get Drive Status */
109/*-----------------------------------------------------------------------*/
110DSTATUS disk_status (
111 BYTE pdrv /* Physical drive nmuber to identify the drive */
112)
113{
114 DSTATUS stat;
115 int result;
116
117 switch (pdrv) {
118 case DEV_RAM :
119 result = 1;
120 stat = (DSTATUS)result;
121 return stat;
122
123 case DEV_MMC :
124 result = 0;
125 stat = (DSTATUS)result;
126 return stat;
127
128 case DEV_USB :
129 result = 1;
130 stat = (DSTATUS)result;
131 return stat;
132 }
133 return STA_NOINIT;
134}
135
136
137
138/*-----------------------------------------------------------------------*/
139/* Inidialize a Drive */
140/*-----------------------------------------------------------------------*/
141DSTATUS disk_initialize (
142 BYTE pdrv /* Physical drive nmuber to identify the drive */
143)
144{
145 DSTATUS stat;
146 int result;
147
148 switch (pdrv) {
149 case DEV_RAM :
150 result = 1;
151 stat = (DSTATUS)result;
152 return stat;
153
154 case DEV_MMC :
155 result = sd_init();
156 stat = (DSTATUS)result;
157 return stat;
158
159 case DEV_USB :
160 result = 1;
161 stat = (DSTATUS)result;
162 return stat;
163 }
164 return STA_NOINIT;
165}
166
167
168
169/*-----------------------------------------------------------------------*/
170/* Read Sector(s) */
171/*-----------------------------------------------------------------------*/
172DRESULT disk_read (
173 BYTE pdrv, /* Physical drive nmuber to identify the drive */
174 BYTE *buff, /* Data buffer to store read data */
175 LBA_t sector, /* Start sector in LBA */
176 UINT count /* Number of sectors to read */
177)
178{
179 DRESULT res;
180 int result;
181
182 switch (pdrv) {
183 case DEV_RAM :
184 result = 1;
185 res = (DRESULT)result;
186 return res;
187
188 case DEV_MMC :
189 result = sd_read_disk(buff, sector, count);
190 res = (DRESULT)result;
191 return res;
192
193 case DEV_USB :
194 result = 1;
195 res = (DRESULT)result;
196 return res;
197 }
198
199 return RES_PARERR;
200}
201
202
203
204/*-----------------------------------------------------------------------*/
205/* Write Sector(s) */
206/*-----------------------------------------------------------------------*/
207#if FF_FS_READONLY == 0
208
209DRESULT disk_write (
210 BYTE pdrv, /* Physical drive nmuber to identify the drive */
211 const BYTE *buff, /* Data to be written */
212 LBA_t sector, /* Start sector in LBA */
213 UINT count /* Number of sectors to write */
214)
215{
216 DRESULT res;
217 int result;
218
219 switch (pdrv) {
220 case DEV_RAM :
221 result = 1;
222 res = (DRESULT)result;
223 return res;
224
225 case DEV_MMC :
226 result = sd_write_disk(buff, sector, count);
227 res = (DRESULT)result;
228 return res;
229
230 case DEV_USB :
231 result = 1;
232 res = (DRESULT)result;
233 return res;
234 }
235
236 return RES_PARERR;
237}
238
239#endif
240
241
242/*-----------------------------------------------------------------------*/
243/* Miscellaneous Functions */
244/*-----------------------------------------------------------------------*/
245DRESULT disk_ioctl (
246 BYTE pdrv, /* Physical drive nmuber (0..) */
247 BYTE cmd, /* Control code */
248 void *buff /* Buffer to send/receive control data */
249)
250{
251 DRESULT res;
252 int result;
253
254 switch (pdrv) {
255 case DEV_RAM :
256 result = 1;
257 res = (DRESULT)result;
258 return res;
259
260 case DEV_MMC :
261 switch(cmd){
262 case CTRL_SYNC:
263 result = RES_OK;
264 break;
265 case GET_SECTOR_SIZE:
266 *(DWORD*)buff = 512;
267 result = RES_OK;
268 break;
269 case GET_SECTOR_COUNT:
270 *(DWORD*)buff = sd_card_info.card_capacity/512;
271 result = RES_OK;
272 break;
273 case GET_BLOCK_SIZE:
274 *(DWORD*)buff = sd_card_info.card_blk_size;
275 result = RES_OK;
276 break;
277 default:
278 result = RES_PARERR;
279 break;
280 }
281 res = (DRESULT)result;
282 return res;
283
284 case DEV_USB :
285 result = 1;
286 res = (DRESULT)result;
287 return res;
288 }
289
290 return RES_PARERR;
291}
DEV_USB
#define DEV_USB
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c:20
DEV_RAM
#define DEV_RAM
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c:18
sdio_data_buffer
uint8_t sdio_data_buffer[512]
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c:22
sd_read_disk
sd_error_status_type sd_read_disk(uint8_t *buf, uint32_t sector, uint8_t cnt)
read sd card sector
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c:34
DEV_MMC
#define DEV_MMC
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c:19
sd_write_disk
sd_error_status_type sd_write_disk(const uint8_t *buf, uint32_t sector, uint8_t cnt)
write sd card sector
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c:74
disk_read
DRESULT disk_read(BYTE pdrv, BYTE *buff, LBA_t sector, UINT count)
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c:172
disk_initialize
DSTATUS disk_initialize(BYTE pdrv)
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c:141
disk_status
DSTATUS disk_status(BYTE pdrv)
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c:110
disk_ioctl
DRESULT disk_ioctl(BYTE pdrv, BYTE cmd, void *buff)
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c:245
disk_write
DRESULT disk_write(BYTE pdrv, const BYTE *buff, LBA_t sector, UINT count)
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c:209
sd_block_read
sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma ...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1188
sd_mult_blocks_write
sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed ...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1489
sd_block_write
sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be manag...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1367
sd_init
sd_error_status_type sd_init(void)
initializes the sd card and put it into standby state (ready for data transfer).
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:72
sd_mult_blocks_read
sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mod...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1277
sd_card_info
sd_card_info_struct_type sd_card_info
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:48
sd_error_status_type
sd_error_status_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:75
SD_OK
@ SD_OK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:120
sd_card_info_struct_type::card_capacity
long long card_capacity
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:242
sd_card_info_struct_type::card_blk_size
uint32_t card_blk_size
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:243


AT32F435/437 Firmwary Library: spi_flash.h File Reference

  • at_start_f435
  • examples
  • spi
  • w25q_flash
  • inc
Macros | Functions
at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h File Reference

header file of spi_flash More...

#include "at32f435_437.h"

Go to the source code of this file.

Macros

#define | SPI_TRANS_DMA
#define | FLASH_CS_HIGH() gpio_bits_set(GPIOD, GPIO_PINS_0)
#define | FLASH_CS_LOW() gpio_bits_reset(GPIOD, GPIO_PINS_0)
#define | W25Q80 0xEF13
#define | W25Q16 0xEF14
#define | W25Q32 0xEF15
#define | W25Q64 0xEF16
#define | W25Q128 0xEF17
#define | SPIF_CHIP_SIZE 0x1000000
#define | SPIF_SECTOR_SIZE 4096
#define | SPIF_PAGE_SIZE 256
#define | SPIF_WRITEENABLE 0x06
#define | SPIF_WRITEDISABLE 0x04
#define | SPIF_READSTATUSREG1 0x05
#define | SPIF_WRITESTATUSREG1 0x01
#define | SPIF_READSTATUSREG2 0x35
#define | SPIF_WRITESTATUSREG2 0x31
#define | SPIF_READSTATUSREG3 0x15
#define | SPIF_WRITESTATUSREG3 0x11
#define | SPIF_READDATA 0x03
#define | SPIF_FASTREADDATA 0x0B
#define | SPIF_FASTREADDUAL 0x3B
#define | SPIF_PAGEPROGRAM 0x02
#define | SPIF_BLOCKERASE 0xD8
#define | SPIF_SECTORERASE 0x20
#define | SPIF_CHIPERASE 0xC7
#define | SPIF_POWERDOWN 0xB9
#define | SPIF_RELEASEPOWERDOWN 0xAB
#define | SPIF_DEVICEID 0xAB
#define | SPIF_MANUFACTDEVICEID 0x90
#define | SPIF_JEDECDEVICEID 0x9F
#define | FLASH_SPI_DUMMY_BYTE 0xA5

Functions

void | spiflash_init (void)
spi configuration. More...
void | spiflash_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash More...
void | spiflash_read (uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash More...
void | spiflash_sector_erase (uint32_t erase_addr)
erase a sector data More...
void | spiflash_write_nocheck (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data without check More...
void | spiflash_page_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write a page data More...
void | spi_bytes_write (uint8_t *pbuffer, uint32_t length)
write data continuously More...
void | spi_bytes_read (uint8_t *pbuffer, uint32_t length)
read data continuously More...
void | spiflash_wait_busy (void)
wait program done More...
uint8_t | spiflash_read_sr1 (void)
read sr1 register More...
void | spiflash_write_enable (void)
enable write operation More...
uint16_t | spiflash_read_id (void)
read device id More...
uint8_t | spi_byte_write (uint8_t data)
write a byte to flash More...
uint8_t | spi_byte_read (void)
read a byte to flash More...

Detailed Description

header file of spi_flash

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h.


AT32F435/437 Firmwary Library: spi_flash.h Source File

  • at_start_f435
  • examples
  • spi
  • w25q_flash
  • inc
at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h
Go to the documentation of this file.
1
27#ifndef __SPI_FLASH_H
28#define __SPI_FLASH_H
29
30#include "at32f435_437.h"
31
41 /* use dma transfer spi data */
42#define SPI_TRANS_DMA
43
48#define FLASH_CS_HIGH() gpio_bits_set(GPIOD, GPIO_PINS_0)
49#define FLASH_CS_LOW() gpio_bits_reset(GPIOD, GPIO_PINS_0)
50
59/*
60 * flash define
61 */
62#define W25Q80 0xEF13
63#define W25Q16 0xEF14
64#define W25Q32 0xEF15
65#define W25Q64 0xEF16
66/* 16mb, the range of address:0~0xFFFFFF */
67#define W25Q128 0xEF17
68
77#define SPIF_CHIP_SIZE 0x1000000
78#define SPIF_SECTOR_SIZE 4096
79#define SPIF_PAGE_SIZE 256
80
81#define SPIF_WRITEENABLE 0x06
82#define SPIF_WRITEDISABLE 0x04
83/* s7-s0 */
84#define SPIF_READSTATUSREG1 0x05
85#define SPIF_WRITESTATUSREG1 0x01
86/* s15-s8 */
87#define SPIF_READSTATUSREG2 0x35
88#define SPIF_WRITESTATUSREG2 0x31
89/* s23-s16 */
90#define SPIF_READSTATUSREG3 0x15
91#define SPIF_WRITESTATUSREG3 0x11
92#define SPIF_READDATA 0x03
93#define SPIF_FASTREADDATA 0x0B
94#define SPIF_FASTREADDUAL 0x3B
95#define SPIF_PAGEPROGRAM 0x02
96/* block size:64kb */
97#define SPIF_BLOCKERASE 0xD8
98#define SPIF_SECTORERASE 0x20
99#define SPIF_CHIPERASE 0xC7
100#define SPIF_POWERDOWN 0xB9
101#define SPIF_RELEASEPOWERDOWN 0xAB
102#define SPIF_DEVICEID 0xAB
103#define SPIF_MANUFACTDEVICEID 0x90
104#define SPIF_JEDECDEVICEID 0x9F
105#define FLASH_SPI_DUMMY_BYTE 0xA5
106
115void spiflash_init(void);
116void spiflash_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length);
117void spiflash_read(uint8_t *pbuffer, uint32_t read_addr, uint32_t length);
118void spiflash_sector_erase(uint32_t erase_addr);
119void spiflash_write_nocheck(uint8_t *pbuffer, uint32_t write_addr, uint32_t length);
120void spiflash_page_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length);
121void spi_bytes_write(uint8_t *pbuffer, uint32_t length);
122void spi_bytes_read(uint8_t *pbuffer, uint32_t length);
123void spiflash_wait_busy(void);
124uint8_t spiflash_read_sr1(void);
125void spiflash_write_enable(void);
126uint16_t spiflash_read_id(void);
127uint8_t spi_byte_write(uint8_t data);
128uint8_t spi_byte_read(void);
129
142#endif
143
at32f435_437.h
at32f435_437 header file
spiflash_init
void spiflash_init(void)
spi configuration.
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:45
spiflash_write
void spiflash_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:103
spiflash_wait_busy
void spiflash_wait_busy(void)
wait program done
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:441
spiflash_write_enable
void spiflash_write_enable(void)
enable write operation
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:466
spiflash_read_sr1
uint8_t spiflash_read_sr1(void)
read sr1 register
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:451
spiflash_write_nocheck
void spiflash_write_nocheck(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data without check
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:228
spiflash_sector_erase
void spiflash_sector_erase(uint32_t erase_addr)
erase a sector data
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:207
spi_byte_write
uint8_t spi_byte_write(uint8_t data)
write a byte to flash
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:497
spiflash_read
void spiflash_read(uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:191
spiflash_read_id
uint16_t spiflash_read_id(void)
read device id
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:478
spi_bytes_read
void spi_bytes_read(uint8_t *pbuffer, uint32_t length)
read data continuously
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:375
spi_bytes_write
void spi_bytes_write(uint8_t *pbuffer, uint32_t length)
write data continuously
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:307
spiflash_page_write
void spiflash_page_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write a page data
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:276
spi_byte_read
uint8_t spi_byte_read(void)
read a byte to flash
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:514


AT32F435/437 Firmwary Library: spi_flash.c File Reference

  • at_start_f435
  • examples
  • spi
  • w25q_flash
  • src
Functions | Variables
at_start_f435/examples/spi/w25q_flash/src/spi_flash.c File Reference

spi_flash source code More...

#include "spi_flash.h"

Go to the source code of this file.

Functions

void | spiflash_init (void)
spi configuration. More...
void | spiflash_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash More...
void | spiflash_read (uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash More...
void | spiflash_sector_erase (uint32_t erase_addr)
erase a sector data More...
void | spiflash_write_nocheck (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data without check More...
void | spiflash_page_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write a page data More...
void | spi_bytes_write (uint8_t *pbuffer, uint32_t length)
write data continuously More...
void | spi_bytes_read (uint8_t *pbuffer, uint32_t length)
read data continuously More...
void | spiflash_wait_busy (void)
wait program done More...
uint8_t | spiflash_read_sr1 (void)
read sr1 register More...
void | spiflash_write_enable (void)
enable write operation More...
uint16_t | spiflash_read_id (void)
read device id More...
uint8_t | spi_byte_write (uint8_t data)
write a byte to flash More...
uint8_t | spi_byte_read (void)
read a byte to flash More...

Variables

uint8_t spiflash_sector_buf [SPIF_SECTOR_SIZE]

Detailed Description

spi_flash source code

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/spi/w25q_flash/src/spi_flash.c.


AT32F435/437 Firmwary Library: spi_flash.c Source File

  • at_start_f435
  • examples
  • spi
  • w25q_flash
  • src
at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
Go to the documentation of this file.
1
27#include "spi_flash.h"
28
29
38uint8_t spiflash_sector_buf[SPIF_SECTOR_SIZE];
39
45void spiflash_init(void)
46{
47 gpio_init_type gpio_initstructure;
48 spi_init_type spi_init_struct;
49
50 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
51 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
52 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
53 /* software cs, pd0 as a general io to control flash cs */
54 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
55 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
56 gpio_initstructure.gpio_mode = GPIO_MODE_OUTPUT;
57 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
58 gpio_initstructure.gpio_pins = GPIO_PINS_0;
59 gpio_init(GPIOD, &gpio_initstructure);
60
61 /* sck */
62 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
63 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
64 gpio_initstructure.gpio_pins = GPIO_PINS_1;
65 gpio_init(GPIOD, &gpio_initstructure);
66 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_6);
67
68 /* miso */
69 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
70 gpio_initstructure.gpio_pins = GPIO_PINS_2;
71 gpio_init(GPIOC, &gpio_initstructure);
72 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE2, GPIO_MUX_5);
73
74 /* mosi */
75 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
76 gpio_initstructure.gpio_pins = GPIO_PINS_4;
77 gpio_init(GPIOD, &gpio_initstructure);
78 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_6);
79
80 FLASH_CS_HIGH();
81 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
82 spi_default_para_init(&spi_init_struct);
83 spi_init_struct.transmission_mode = SPI_TRANSMIT_FULL_DUPLEX;
84 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
85 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_32;
86 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_MSB;
87 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
88 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_HIGH;
89 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
90 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
91 spi_init(SPI2, &spi_init_struct);
92 spi_enable(SPI2, TRUE);
93
94}
95
103void spiflash_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
104{
105 uint32_t sector_pos;
106 uint16_t sector_offset;
107 uint16_t sector_remain;
108 uint16_t index;
109 uint8_t *spiflash_buf;
110 spiflash_buf = spiflash_sector_buf;
111
112 /* sector address */
113 sector_pos = write_addr / SPIF_SECTOR_SIZE;
114
115 /* address offset in a sector */
116 sector_offset = write_addr % SPIF_SECTOR_SIZE;
117
118 /* the remain in a sector */
119 sector_remain = SPIF_SECTOR_SIZE - sector_offset;
120 if(length <= sector_remain)
121 {
122 /* smaller than a sector size */
123 sector_remain = length;
124 }
125 while(1)
126 {
127 /* read a sector */
128 spiflash_read(spiflash_buf, sector_pos * SPIF_SECTOR_SIZE, SPIF_SECTOR_SIZE);
129
130 /* validate the read erea */
131 for(index = 0; index < sector_remain; index++)
132 {
133 if(spiflash_buf[sector_offset + index] != 0xFF)
134 {
135 /* there are some data not equal 0xff, so this secotr needs erased */
136 break;
137 }
138 }
139 if(index < sector_remain)
140 {
141 /* erase the sector */
142 spiflash_sector_erase(sector_pos);
143
144 /* copy the write data */
145 for(index = 0; index < sector_remain; index++)
146 {
147 spiflash_buf[index + sector_offset] = pbuffer[index];
148 }
149 spiflash_write_nocheck(spiflash_buf, sector_pos * SPIF_SECTOR_SIZE, SPIF_SECTOR_SIZE); /* program the sector */
150 }
151 else
152 {
153 /* write directly in the erased area */
154 spiflash_write_nocheck(pbuffer, write_addr, sector_remain);
155 }
156 if(length == sector_remain)
157 {
158 /* write end */
159 break;
160 }
161 else
162 {
163 /* go on writing */
164 sector_pos++;
165 sector_offset = 0;
166
167 pbuffer += sector_remain;
168 write_addr += sector_remain;
169 length -= sector_remain;
170 if(length > SPIF_SECTOR_SIZE)
171 {
172 /* could not write the remain data in the next sector */
173 sector_remain = SPIF_SECTOR_SIZE;
174 }
175 else
176 {
177 /* could write the remain data in the next sector */
178 sector_remain = length;
179 }
180 }
181 }
182}
183
191void spiflash_read(uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
192{
193 FLASH_CS_LOW();
194 spi_byte_write(SPIF_READDATA); /* send instruction */
195 spi_byte_write((uint8_t)((read_addr) >> 16)); /* send 24-bit address */
196 spi_byte_write((uint8_t)((read_addr) >> 8));
197 spi_byte_write((uint8_t)read_addr);
198 spi_bytes_read(pbuffer, length);
199 FLASH_CS_HIGH();
200}
201
207void spiflash_sector_erase(uint32_t erase_addr)
208{
209 erase_addr *= SPIF_SECTOR_SIZE; /* translate sector address to byte address */
210 spiflash_write_enable();
211 spiflash_wait_busy();
212 FLASH_CS_LOW();
213 spi_byte_write(SPIF_SECTORERASE);
214 spi_byte_write((uint8_t)((erase_addr) >> 16));
215 spi_byte_write((uint8_t)((erase_addr) >> 8));
216 spi_byte_write((uint8_t)erase_addr);
217 FLASH_CS_HIGH();
218 spiflash_wait_busy();
219}
220
228void spiflash_write_nocheck(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
229{
230 uint16_t page_remain;
231
232 /* remain bytes in a page */
233 page_remain = SPIF_PAGE_SIZE - write_addr % SPIF_PAGE_SIZE;
234 if(length <= page_remain)
235 {
236 /* smaller than a page size */
237 page_remain = length;
238 }
239 while(1)
240 {
241 spiflash_page_write(pbuffer, write_addr, page_remain);
242 if(length == page_remain)
243 {
244 /* all data are programmed */
245 break;
246 }
247 else
248 {
249 /* length > page_remain */
250 pbuffer += page_remain;
251 write_addr += page_remain;
252
253 /* the remain bytes to be prorammed */
254 length -= page_remain;
255 if(length > SPIF_PAGE_SIZE)
256 {
257 /* can be progrmmed a page at a time */
258 page_remain = SPIF_PAGE_SIZE;
259 }
260 else
261 {
262 /* smaller than a page size */
263 page_remain = length;
264 }
265 }
266 }
267}
268
276void spiflash_page_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
277{
278 if((0 < length) && (length <= SPIF_PAGE_SIZE))
279 {
280 /* set write enable */
281 spiflash_write_enable();
282
283 FLASH_CS_LOW();
284
285 /* send instruction */
286 spi_byte_write(SPIF_PAGEPROGRAM);
287
288 /* send 24-bit address */
289 spi_byte_write((uint8_t)((write_addr) >> 16));
290 spi_byte_write((uint8_t)((write_addr) >> 8));
291 spi_byte_write((uint8_t)write_addr);
292 spi_bytes_write(pbuffer,length);
293
294 FLASH_CS_HIGH();
295
296 /* wait for program end */
297 spiflash_wait_busy();
298 }
299}
300
307void spi_bytes_write(uint8_t *pbuffer, uint32_t length)
308{
309 volatile uint8_t dummy_data;
310
311#if defined(SPI_TRANS_DMA)
312 dma_init_type dma_init_struct;
313 dma_reset(DMA1_CHANNEL2);
314 dma_reset(DMA1_CHANNEL3);
315 dma_default_para_init(&dma_init_struct);
316 dma_init_struct.buffer_size = length;
317 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
318 dma_init_struct.memory_base_addr = (uint32_t)&dummy_data;
319 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
320 dma_init_struct.memory_inc_enable = FALSE;
321 dma_init_struct.peripheral_base_addr = (uint32_t)(&SPI2->dt);
322 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
323 dma_init_struct.peripheral_inc_enable = FALSE;
324 dma_init_struct.priority = DMA_PRIORITY_VERY_HIGH;
325 dma_init_struct.loop_mode_enable = FALSE;
326 dma_init(DMA1_CHANNEL2, &dma_init_struct);
327 dmamux_enable(DMA1, TRUE);
328 dmamux_init(DMA1MUX_CHANNEL2, DMAMUX_DMAREQ_ID_SPI2_RX);
329
330 dma_init_struct.buffer_size = length;
331 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
332 dma_init_struct.memory_base_addr = (uint32_t)pbuffer;
333 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
334 dma_init_struct.memory_inc_enable = TRUE;
335 dma_init_struct.peripheral_base_addr = (uint32_t)(&SPI2->dt);
336 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
337 dma_init_struct.peripheral_inc_enable = FALSE;
338 dma_init_struct.priority = DMA_PRIORITY_VERY_HIGH;
339 dma_init_struct.loop_mode_enable = FALSE;
340 dma_init(DMA1_CHANNEL3, &dma_init_struct);
341 dmamux_init(DMA1MUX_CHANNEL3, DMAMUX_DMAREQ_ID_SPI2_TX);
342
343 spi_i2s_dma_transmitter_enable(SPI2, TRUE);
344 spi_i2s_dma_receiver_enable(SPI2, TRUE);
345
346 dma_channel_enable(DMA1_CHANNEL2, TRUE);
347 dma_channel_enable(DMA1_CHANNEL3, TRUE);
348
349 while(dma_flag_get(DMA1_FDT2_FLAG) == RESET);
350 dma_flag_clear(DMA1_FDT2_FLAG);
351
352 dma_channel_enable(DMA1_CHANNEL2, FALSE);
353 dma_channel_enable(DMA1_CHANNEL3, FALSE);
354
355 spi_i2s_dma_transmitter_enable(SPI2, FALSE);
356 spi_i2s_dma_receiver_enable(SPI2, FALSE);
357#else
358 while(length--)
359 {
360 while(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) == RESET);
361 spi_i2s_data_transmit(SPI2, *pbuffer);
362 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
363 dummy_data = spi_i2s_data_receive(SPI2);
364 pbuffer++;
365 }
366#endif
367}
368
375void spi_bytes_read(uint8_t *pbuffer, uint32_t length)
376{
377 uint8_t write_value = FLASH_SPI_DUMMY_BYTE;
378
379#if defined(SPI_TRANS_DMA)
380 dma_init_type dma_init_struct;
381 dma_reset(DMA1_CHANNEL2);
382 dma_reset(DMA1_CHANNEL3);
383 dma_default_para_init(&dma_init_struct);
384 dma_init_struct.buffer_size = length;
385 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
386 dma_init_struct.memory_base_addr = (uint32_t)&write_value;
387 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
388 dma_init_struct.memory_inc_enable = FALSE;
389 dma_init_struct.peripheral_base_addr = (uint32_t)(&SPI2->dt);
390 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
391 dma_init_struct.peripheral_inc_enable = FALSE;
392 dma_init_struct.priority = DMA_PRIORITY_VERY_HIGH;
393 dma_init_struct.loop_mode_enable = FALSE;
394 dma_init(DMA1_CHANNEL3, &dma_init_struct);
395 dmamux_enable(DMA1, TRUE);
396 dmamux_init(DMA1MUX_CHANNEL3, DMAMUX_DMAREQ_ID_SPI2_TX);
397
398 dma_init_struct.buffer_size = length;
399 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
400 dma_init_struct.memory_base_addr = (uint32_t)pbuffer;
401 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
402 dma_init_struct.memory_inc_enable = TRUE;
403 dma_init_struct.peripheral_base_addr = (uint32_t)(&SPI2->dt);
404 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
405 dma_init_struct.peripheral_inc_enable = FALSE;
406 dma_init_struct.priority = DMA_PRIORITY_VERY_HIGH;
407 dma_init_struct.loop_mode_enable = FALSE;
408 dma_init(DMA1_CHANNEL2, &dma_init_struct);
409 dmamux_init(DMA1MUX_CHANNEL2, DMAMUX_DMAREQ_ID_SPI2_RX);
410
411 spi_i2s_dma_transmitter_enable(SPI2, TRUE);
412 spi_i2s_dma_receiver_enable(SPI2, TRUE);
413 dma_channel_enable(DMA1_CHANNEL2, TRUE);
414 dma_channel_enable(DMA1_CHANNEL3, TRUE);
415
416 while(dma_flag_get(DMA1_FDT2_FLAG) == RESET);
417 dma_flag_clear(DMA1_FDT2_FLAG);
418
419 dma_channel_enable(DMA1_CHANNEL2, FALSE);
420 dma_channel_enable(DMA1_CHANNEL3, FALSE);
421
422 spi_i2s_dma_transmitter_enable(SPI2, FALSE);
423 spi_i2s_dma_receiver_enable(SPI2, FALSE);
424#else
425 while(length--)
426 {
427 while(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) == RESET);
428 spi_i2s_data_transmit(SPI2, write_value);
429 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
430 *pbuffer = spi_i2s_data_receive(SPI2);
431 pbuffer++;
432 }
433#endif
434}
435
441void spiflash_wait_busy(void)
442{
443 while((spiflash_read_sr1() & 0x01) == 0x01);
444}
445
451uint8_t spiflash_read_sr1(void)
452{
453 uint8_t breadbyte = 0;
454 FLASH_CS_LOW();
455 spi_byte_write(SPIF_READSTATUSREG1);
456 breadbyte = (uint8_t)spi_byte_read();
457 FLASH_CS_HIGH();
458 return (breadbyte);
459}
460
466void spiflash_write_enable(void)
467{
468 FLASH_CS_LOW();
469 spi_byte_write(SPIF_WRITEENABLE);
470 FLASH_CS_HIGH();
471}
472
478uint16_t spiflash_read_id(void)
479{
480 uint16_t wreceivedata = 0;
481 FLASH_CS_LOW();
482 spi_byte_write(SPIF_MANUFACTDEVICEID);
483 spi_byte_write(0x00);
484 spi_byte_write(0x00);
485 spi_byte_write(0x00);
486 wreceivedata |= spi_byte_read() << 8;
487 wreceivedata |= spi_byte_read();
488 FLASH_CS_HIGH();
489 return wreceivedata;
490}
491
497uint8_t spi_byte_write(uint8_t data)
498{
499 uint8_t brxbuff;
500 spi_i2s_dma_transmitter_enable(SPI2, FALSE);
501 spi_i2s_dma_receiver_enable(SPI2, FALSE);
502 spi_i2s_data_transmit(SPI2, data);
503 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
504 brxbuff = spi_i2s_data_receive(SPI2);
505 while(spi_i2s_flag_get(SPI2, SPI_I2S_BF_FLAG) != RESET);
506 return brxbuff;
507}
508
514uint8_t spi_byte_read(void)
515{
516 return (spi_byte_write(FLASH_SPI_DUMMY_BYTE));
517}
518
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:40
spiflash_init
void spiflash_init(void)
spi configuration.
Definition: at_start_f435/examples/spi/w25q_flash/src/spi_flash.c:45
spiflash_write
void spiflash_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash
Definition: at_start_f435/examples/spi/w25q_flash/src/spi_flash.c:103
spiflash_wait_busy
void spiflash_wait_busy(void)
wait program done
Definition: at_start_f435/examples/spi/w25q_flash/src/spi_flash.c:441
spiflash_write_enable
void spiflash_write_enable(void)
enable write operation
Definition: at_start_f435/examples/spi/w25q_flash/src/spi_flash.c:466
spiflash_read_sr1
uint8_t spiflash_read_sr1(void)
read sr1 register
Definition: at_start_f435/examples/spi/w25q_flash/src/spi_flash.c:451
spiflash_write_nocheck
void spiflash_write_nocheck(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data without check
Definition: at_start_f435/examples/spi/w25q_flash/src/spi_flash.c:228
spiflash_sector_erase
void spiflash_sector_erase(uint32_t erase_addr)
erase a sector data
Definition: at_start_f435/examples/spi/w25q_flash/src/spi_flash.c:207
spi_byte_write
uint8_t spi_byte_write(uint8_t data)
write a byte to flash
Definition: at_start_f435/examples/spi/w25q_flash/src/spi_flash.c:497
spiflash_read
void spiflash_read(uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash
Definition: at_start_f435/examples/spi/w25q_flash/src/spi_flash.c:191
spiflash_read_id
uint16_t spiflash_read_id(void)
read device id
Definition: at_start_f435/examples/spi/w25q_flash/src/spi_flash.c:478
spi_bytes_read
void spi_bytes_read(uint8_t *pbuffer, uint32_t length)
read data continuously
Definition: at_start_f435/examples/spi/w25q_flash/src/spi_flash.c:375
spi_bytes_write
void spi_bytes_write(uint8_t *pbuffer, uint32_t length)
write data continuously
Definition: at_start_f435/examples/spi/w25q_flash/src/spi_flash.c:307
spiflash_sector_buf
uint8_t spiflash_sector_buf[SPIF_SECTOR_SIZE]
Definition: at_start_f435/examples/spi/w25q_flash/src/spi_flash.c:38
spiflash_page_write
void spiflash_page_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write a page data
Definition: at_start_f435/examples/spi/w25q_flash/src/spi_flash.c:276
spi_byte_read
uint8_t spi_byte_read(void)
read a byte to flash
Definition: at_start_f435/examples/spi/w25q_flash/src/spi_flash.c:514
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:138
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:162
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:172
DMA_PRIORITY_VERY_HIGH
@ DMA_PRIORITY_VERY_HIGH
Definition: at32f435_437_dma.h:185
DMAMUX_DMAREQ_ID_SPI2_TX
@ DMAMUX_DMAREQ_ID_SPI2_TX
Definition: at32f435_437_dma.h:207
DMAMUX_DMAREQ_ID_SPI2_RX
@ DMAMUX_DMAREQ_ID_SPI2_RX
Definition: at32f435_437_dma.h:206
DMA1_FDT2_FLAG
#define DMA1_FDT2_FLAG
Definition: at32f435_437_dma.h:70
DMA1MUX_CHANNEL2
#define DMA1MUX_CHANNEL2
Definition: at32f435_437_dma.h:705
DMA1MUX_CHANNEL3
#define DMA1MUX_CHANNEL3
Definition: at32f435_437_dma.h:706
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f435_437_dma.h:698
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f435_437_dma.h:697
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_6
@ GPIO_MUX_6
Definition: at32f435_437_gpio.h:162
GPIO_MUX_5
@ GPIO_MUX_5
Definition: at32f435_437_gpio.h:161
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f435_437_spi.h:54
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f435_437_spi.h:53
SPI_I2S_BF_FLAG
#define SPI_I2S_BF_FLAG
Definition: at32f435_437_spi.h:60
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f435_437_spi.c:548
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f435_437_spi.c:533
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f435_437_spi.c:583
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f435_437_spi.c:101
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f435_437_spi.c:81
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f435_437_spi.c:560
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f435_437_spi.c:321
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f435_437_spi.c:519
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f435_437_spi.h:100
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f435_437_spi.h:118
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f435_437_spi.h:127
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f435_437_spi.h:153
SPI_CLOCK_POLARITY_HIGH
@ SPI_CLOCK_POLARITY_HIGH
Definition: at32f435_437_spi.h:109
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f435_437_spi.h:162
SPI_MCLK_DIV_32
@ SPI_MCLK_DIV_32
Definition: at32f435_437_spi.h:140
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f435_437_spi.h:90
FLASH_CS_LOW
#define FLASH_CS_LOW()
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:49
FLASH_CS_HIGH
#define FLASH_CS_HIGH()
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:48
SPIF_READDATA
#define SPIF_READDATA
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:92
SPIF_PAGE_SIZE
#define SPIF_PAGE_SIZE
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:79
SPIF_SECTORERASE
#define SPIF_SECTORERASE
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:98
SPIF_MANUFACTDEVICEID
#define SPIF_MANUFACTDEVICEID
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:103
FLASH_SPI_DUMMY_BYTE
#define FLASH_SPI_DUMMY_BYTE
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:105
SPIF_SECTOR_SIZE
#define SPIF_SECTOR_SIZE
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:78
SPIF_READSTATUSREG1
#define SPIF_READSTATUSREG1
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:84
SPIF_PAGEPROGRAM
#define SPIF_PAGEPROGRAM
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:95
SPIF_WRITEENABLE
#define SPIF_WRITEENABLE
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:81
SPI2
#define SPI2
Definition: at32f435_437_spi.h:454
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
spi_init_type
spi init type
Definition: at32f435_437_spi.h:259
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f435_437_spi.h:261
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f435_437_spi.h:263
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f435_437_spi.h:264
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:265
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f435_437_spi.h:267
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f435_437_spi.h:262
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f435_437_spi.h:260
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f435_437_spi.h:266


AT32F435/437 Firmwary Library: smartcard_config.h File Reference

  • at_start_f435
  • examples
  • usart
  • smartcard
  • inc
Macros
at_start_f435/examples/usart/smartcard/inc/smartcard_config.h File Reference

header file of clock program More...

Go to the source code of this file.

Macros

#define | SC_USART USART2
#define | SC_USART_CLK CRM_USART2_PERIPH_CLOCK
#define | SC_USART_GPIO_CLK CRM_GPIOA_PERIPH_CLOCK
#define | SC_USART_TX_PIN GPIO_PINS_2
#define | SC_USART_TX_PORT GPIOA
#define | SC_USART_CLK_PIN GPIO_PINS_4
#define | SC_USART_CLK_PORT GPIOA
#define | SC_USART_IRQn USART2_IRQn
#define | SC_USART_IRQHandler USART2_IRQHandler
this function handles sc_usart global interrupt request. More...
#define | SC_3_5V_PIN GPIO_PINS_5
#define | SC_RESET_PIN GPIO_PINS_6
#define | SC_CMDVCC_PIN GPIO_PINS_7
#define | SC_OFF_PIN GPIO_PINS_8
#define | SC_3_5V_PORT GPIOA
#define | SC_RESET_PORT GPIOA
#define | SC_CMDVCC_PORT GPIOA
#define | SC_OFF_PORT GPIOA
#define | SC_3_5V_CLK CRM_GPIOA_PERIPH_CLOCK
#define | SC_RESET_CLK CRM_GPIOA_PERIPH_CLOCK
#define | SC_CMDVCC_CLK CRM_GPIOA_PERIPH_CLOCK
#define | SC_OFF_CLK CRM_GPIOA_PERIPH_CLOCK
#define | SC_OFF_EXINT EXINT_LINE_8
#define | SC_OFF_PORTSOURCE SCFG_PORT_SOURCE_GPIOA
#define | SC_OFF_PINSOURCE SCFG_PINS_SOURCE8
#define | SC_OFF_EXINT_IRQ EXINT9_5_IRQn

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

Macro Definition Documentation

◆ SC_3_5V_CLK

#define SC_3_5V_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 51 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_3_5V_PIN

#define SC_3_5V_PIN GPIO_PINS_5

Definition at line 43 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_3_5V_PORT

#define SC_3_5V_PORT GPIOA

Definition at line 47 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_CMDVCC_CLK

#define SC_CMDVCC_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 53 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_CMDVCC_PIN

#define SC_CMDVCC_PIN GPIO_PINS_7

Definition at line 45 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_CMDVCC_PORT

#define SC_CMDVCC_PORT GPIOA

Definition at line 49 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_OFF_CLK

#define SC_OFF_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 54 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_OFF_EXINT

#define SC_OFF_EXINT EXINT_LINE_8

Definition at line 55 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_OFF_EXINT_IRQ

#define SC_OFF_EXINT_IRQ EXINT9_5_IRQn

Definition at line 58 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_OFF_PIN

#define SC_OFF_PIN GPIO_PINS_8

Definition at line 46 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_OFF_PINSOURCE

#define SC_OFF_PINSOURCE SCFG_PINS_SOURCE8

Definition at line 57 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_OFF_PORT

#define SC_OFF_PORT GPIOA

Definition at line 50 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_OFF_PORTSOURCE

#define SC_OFF_PORTSOURCE SCFG_PORT_SOURCE_GPIOA

Definition at line 56 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_RESET_CLK

#define SC_RESET_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 52 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_RESET_PIN

#define SC_RESET_PIN GPIO_PINS_6

Definition at line 44 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_RESET_PORT

#define SC_RESET_PORT GPIOA

Definition at line 48 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_USART

#define SC_USART USART2

Definition at line 32 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_USART_CLK

#define SC_USART_CLK CRM_USART2_PERIPH_CLOCK

Definition at line 33 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_USART_CLK_PIN

#define SC_USART_CLK_PIN GPIO_PINS_4

Definition at line 37 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_USART_CLK_PORT

#define SC_USART_CLK_PORT GPIOA

Definition at line 38 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_USART_GPIO_CLK

#define SC_USART_GPIO_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 34 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_USART_IRQn

#define SC_USART_IRQn USART2_IRQn

Definition at line 39 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_USART_TX_PIN

#define SC_USART_TX_PIN GPIO_PINS_2

Definition at line 35 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_USART_TX_PORT

#define SC_USART_TX_PORT GPIOA

Definition at line 36 of file at_start_f435/examples/usart/smartcard/inc/smartcard_config.h.


AT32F435/437 Firmwary Library: smartcard_config.h Source File

  • at_start_f435
  • examples
  • usart
  • smartcard
  • inc
at_start_f435/examples/usart/smartcard/inc/smartcard_config.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __SMARTCARD_CONFIG_H
29#define __SMARTCARD_CONFIG_H
30
31/* smartcard inteface usart pins */
32#define SC_USART USART2
33#define SC_USART_CLK CRM_USART2_PERIPH_CLOCK
34#define SC_USART_GPIO_CLK CRM_GPIOA_PERIPH_CLOCK
35#define SC_USART_TX_PIN GPIO_PINS_2
36#define SC_USART_TX_PORT GPIOA
37#define SC_USART_CLK_PIN GPIO_PINS_4
38#define SC_USART_CLK_PORT GPIOA
39#define SC_USART_IRQn USART2_IRQn
40#define SC_USART_IRQHandler USART2_IRQHandler
41
42/* smartcard inteface gpio pins */
43#define SC_3_5V_PIN GPIO_PINS_5
44#define SC_RESET_PIN GPIO_PINS_6
45#define SC_CMDVCC_PIN GPIO_PINS_7
46#define SC_OFF_PIN GPIO_PINS_8
47#define SC_3_5V_PORT GPIOA
48#define SC_RESET_PORT GPIOA
49#define SC_CMDVCC_PORT GPIOA
50#define SC_OFF_PORT GPIOA
51#define SC_3_5V_CLK CRM_GPIOA_PERIPH_CLOCK
52#define SC_RESET_CLK CRM_GPIOA_PERIPH_CLOCK
53#define SC_CMDVCC_CLK CRM_GPIOA_PERIPH_CLOCK
54#define SC_OFF_CLK CRM_GPIOA_PERIPH_CLOCK
55#define SC_OFF_EXINT EXINT_LINE_8
56#define SC_OFF_PORTSOURCE SCFG_PORT_SOURCE_GPIOA
57#define SC_OFF_PINSOURCE SCFG_PINS_SOURCE8
58#define SC_OFF_EXINT_IRQ EXINT9_5_IRQn
59
60#endif /* __SMARTCARD_CONFIG_H */
61


AT32F435/437 Firmwary Library: audio_codec.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • audio
  • inc
Data Structures | Macros | Functions
at_start_f435/examples/usb_device/audio/inc/audio_codec.h File Reference

audio codec header file More...

#include "usb_conf.h"

Go to the source code of this file.

Data Structures

struct audio_codec_type

Macros

#define | WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/
#define | WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/
#define | WM8988_R2_LOUT1_VOLUME 0x02
#define | WM8988_R3_ROUT1_VOLUME 0x03
#define | WM8988_R4_RESERVED 0x04
#define | WM8988_R5_ADC_DAC_CONTROL 0x05
#define | WM8988_R6_RESERVED 0x06
#define | WM8988_R7_AUDIO_INTERFACE 0x07
#define | WM8988_R8_SAMPLE_RATE 0x08
#define | WM8988_R9_RESERVED 0x09
#define | WM8988_R10_LEFT_DAC_VOLUME 0x0A
#define | WM8988_R11_RIGHT_DAC_VOLUME 0x0B
#define | WM8988_R12_BASS_CONTROL 0x0C
#define | WM8988_R13_TREBLE_CONTROL 0x0D
#define | WM8988_R14_
#define | WM8988_R15_RESET 0x0F
#define | WM8988_R16_3D_CONTROL 0x10
#define | WM8988_R17_ALC1 0x11
#define | WM8988_R18_ALC2 0x12
#define | WM8988_R19_ALC3 0x13
#define | WM8988_R20_NOISE_GATE 0x14
#define | WM8988_R21_LEFT_ADC_VOLUME 0x15
#define | WM8988_R22_RIGHT_ADC_VOLUME 0x16
#define | WM8988_R23_ADDITIONAL_1_CONTROL 0x17
#define | WM8988_R24_ADDITIONAL_2_CONTROL 0x18
#define | WM8988_R25_PWR_1_MGMT 0x19
#define | WM8988_R26_PWR_2_MGMT 0x1A
#define | WM8988_R27_ADDITIONAL_3_CONTROL 0x1B
#define | WM8988_R31_ADC_INPUT_MODE 0x1F
#define | WM8988_R32_ADC_L_SIGNAL_PATH 0x20
#define | WM8988_R33_ADC_R_SIGNAL_PATH 0x21
#define | WM8988_R34_LEFT_OUT_MIX_1 0x22
#define | WM8988_R35_LEFT_OUT_MIX_2 0x23
#define | WM8988_R36_RIGHT_OUT_MIX_1 0x24
#define | WM8988_R37_RIGHT_OUT_MIX_2 0x25
#define | WM8988_R38_RESERVED
#define | WM8988_R39_RESERVED
#define | WM8988_R40_LOUT2_VOLUME 0x28
#define | WM8988_R41_ROUT2_VOLUME 0x29
#define | WM8988_R42_RESERVED
#define | WM8988_R43_LOW_POWER_PALYBACK 0x43
#define | WM8988_I2C_ADDR_CSB_LOW 0x34
#define | WM8988_I2C_ADDR_CSB_HIGH 0x36
#define | I2S1_WS_PIN GPIO_PINS_4
#define | I2S1_WS_PIN_SOURCE GPIO_PINS_SOURCE4
#define | I2S1_WS_GPIO_MUX GPIO_MUX_5
#define | I2S1_CK_PIN GPIO_PINS_5
#define | I2S1_CK_PIN_SOURCE GPIO_PINS_SOURCE5
#define | I2S1_CK_GPIO_MUX GPIO_MUX_5
#define | I2S1_SD_PIN GPIO_PINS_7
#define | I2S1_SD_PIN_SOURCE GPIO_PINS_SOURCE7
#define | I2S1_SD_GPIO_MUX GPIO_MUX_5
#define | I2S1_GPIO GPIOA
#define | I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
#define | I2S1_DT_ADDRESS (&(SPI1->dt))
#define | I2S2_WS_PIN GPIO_PINS_0
#define | I2S2_WS_PIN_SOURCE GPIO_PINS_SOURCE0
#define | I2S2_WS_GPIO_MUX GPIO_MUX_7
#define | I2S2_CK_PIN GPIO_PINS_1
#define | I2S2_CK_PIN_SOURCE GPIO_PINS_SOURCE1
#define | I2S2_CK_GPIO_MUX GPIO_MUX_6
#define | I2S2_SD_PIN GPIO_PINS_4
#define | I2S2_SD_PIN_SOURCE GPIO_PINS_SOURCE4
#define | I2S2_SD_GPIO_MUX GPIO_MUX_6
#define | I2S2_GPIO GPIOD
#define | I2S2_GPIO_CRM_CLK CRM_GPIOD_PERIPH_CLOCK
#define | I2S2_DT_ADDRESS (&(SPI2->dt))
#define | SPK_TX_FIFO_SIZE (1024 * 4)
#define | MIC_BUFFER_SIZE 1024
#define | SPK_BUFFER_SIZE 4096
#define | DMA_BUFFER_SIZE 288

Functions

error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
audio codec interface More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...

Detailed Description

audio codec header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/usb_device/audio/inc/audio_codec.h.


AT32F435/437 Firmwary Library: audio_codec.h Source File

  • at_start_f435
  • examples
  • usb_device
  • audio
  • inc
at_start_f435/examples/usb_device/audio/inc/audio_codec.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AUDIO_CODEC_H
29#define __AUDIO_CODEC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
44/* includes ------------------------------------------------------------------*/
45#include "usb_conf.h"
46
50#define WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/
51#define WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/
52#define WM8988_R2_LOUT1_VOLUME 0x02
53#define WM8988_R3_ROUT1_VOLUME 0x03
54#define WM8988_R4_RESERVED 0x04
55#define WM8988_R5_ADC_DAC_CONTROL 0x05
56#define WM8988_R6_RESERVED 0x06
57#define WM8988_R7_AUDIO_INTERFACE 0x07
58#define WM8988_R8_SAMPLE_RATE 0x08
59#define WM8988_R9_RESERVED 0x09
60#define WM8988_R10_LEFT_DAC_VOLUME 0x0A
61#define WM8988_R11_RIGHT_DAC_VOLUME 0x0B
62#define WM8988_R12_BASS_CONTROL 0x0C
63#define WM8988_R13_TREBLE_CONTROL 0x0D
64#define WM8988_R14_
65#define WM8988_R15_RESET 0x0F
66#define WM8988_R16_3D_CONTROL 0x10
67#define WM8988_R17_ALC1 0x11
68#define WM8988_R18_ALC2 0x12
69#define WM8988_R19_ALC3 0x13
70#define WM8988_R20_NOISE_GATE 0x14
71#define WM8988_R21_LEFT_ADC_VOLUME 0x15
72#define WM8988_R22_RIGHT_ADC_VOLUME 0x16
73#define WM8988_R23_ADDITIONAL_1_CONTROL 0x17
74#define WM8988_R24_ADDITIONAL_2_CONTROL 0x18
75#define WM8988_R25_PWR_1_MGMT 0x19
76#define WM8988_R26_PWR_2_MGMT 0x1A
77#define WM8988_R27_ADDITIONAL_3_CONTROL 0x1B
78
79#define WM8988_R31_ADC_INPUT_MODE 0x1F
80#define WM8988_R32_ADC_L_SIGNAL_PATH 0x20
81#define WM8988_R33_ADC_R_SIGNAL_PATH 0x21
82#define WM8988_R34_LEFT_OUT_MIX_1 0x22
83#define WM8988_R35_LEFT_OUT_MIX_2 0x23
84#define WM8988_R36_RIGHT_OUT_MIX_1 0x24
85#define WM8988_R37_RIGHT_OUT_MIX_2 0x25
86#define WM8988_R38_RESERVED
87#define WM8988_R39_RESERVED
88#define WM8988_R40_LOUT2_VOLUME 0x28
89#define WM8988_R41_ROUT2_VOLUME 0x29
90#define WM8988_R42_RESERVED
91#define WM8988_R43_LOW_POWER_PALYBACK 0x43
92
93#define WM8988_I2C_ADDR_CSB_LOW 0x34
94#define WM8988_I2C_ADDR_CSB_HIGH 0x36
95
103#define I2S1_WS_PIN GPIO_PINS_4
104#define I2S1_WS_PIN_SOURCE GPIO_PINS_SOURCE4
105#define I2S1_WS_GPIO_MUX GPIO_MUX_5
106
107#define I2S1_CK_PIN GPIO_PINS_5
108#define I2S1_CK_PIN_SOURCE GPIO_PINS_SOURCE5
109#define I2S1_CK_GPIO_MUX GPIO_MUX_5
110
111#define I2S1_SD_PIN GPIO_PINS_7
112#define I2S1_SD_PIN_SOURCE GPIO_PINS_SOURCE7
113#define I2S1_SD_GPIO_MUX GPIO_MUX_5
114
115#define I2S1_GPIO GPIOA
116#define I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
117#define I2S1_DT_ADDRESS (&(SPI1->dt))
118
119/*I2S2 Pin*/
120#define I2S2_WS_PIN GPIO_PINS_0
121#define I2S2_WS_PIN_SOURCE GPIO_PINS_SOURCE0
122#define I2S2_WS_GPIO_MUX GPIO_MUX_7
123
124#define I2S2_CK_PIN GPIO_PINS_1
125#define I2S2_CK_PIN_SOURCE GPIO_PINS_SOURCE1
126#define I2S2_CK_GPIO_MUX GPIO_MUX_6
127
128#define I2S2_SD_PIN GPIO_PINS_4
129#define I2S2_SD_PIN_SOURCE GPIO_PINS_SOURCE4
130#define I2S2_SD_GPIO_MUX GPIO_MUX_6
131
132#define I2S2_GPIO GPIOD
133#define I2S2_GPIO_CRM_CLK CRM_GPIOD_PERIPH_CLOCK
134#define I2S2_DT_ADDRESS (&(SPI2->dt))
135
136#define SPK_TX_FIFO_SIZE (1024 * 4)
137
145#define MIC_BUFFER_SIZE 1024
146#define SPK_BUFFER_SIZE 4096
147#define DMA_BUFFER_SIZE 288
148
149typedef struct
150{
151 uint32_t audio_freq;
152 uint32_t audio_bitw;
153 //spk part
154 uint16_t spk_buffer[SPK_BUFFER_SIZE];
155 uint16_t *spk_roff;
156 uint16_t *spk_woff;
157 uint16_t *spk_rend;
158 uint32_t spk_freq;
159 uint32_t spk_wtotal;
160 uint32_t spk_rtotal;
161 uint16_t spk_threshold;
162 uint16_t spk_calc;
163 uint8_t spk_stage;
164
165 //mic part
166 uint16_t mic_buffer[MIC_BUFFER_SIZE];
167 uint16_t *mic_roff;
168 uint16_t *mic_woff;
169 uint16_t *mic_wend;
170 uint32_t mic_wtotal;
171 uint32_t mic_rtotal;
172 uint32_t mic_delta;
173 uint16_t mic_calc;
174 uint16_t mic_adj_count;
175 uint8_t mic_adj_stage;
176 uint8_t mic_stage;
177
178 uint8_t mic_mute;
179 uint8_t spk_mute;
180
181 uint16_t mic_volume;
182 uint16_t spk_volume;
183
184 uint32_t spk_tx_size;
185 uint32_t mic_rx_size;
186
187 uint32_t spk_enable;
188 uint32_t mic_enable;
189
190}audio_codec_type;
191
192 error_status audio_codec_init(void);
193 error_status audio_codec_loop(void);
194void audio_codec_modify_freq(uint32_t freq);
195
199void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len);
200uint32_t audio_codec_mic_get_data(uint8_t *buffer);
201uint8_t audio_codec_spk_feedback(uint8_t *feedback);
202void audio_codec_spk_alt_setting(uint32_t alt_seting);
203void audio_codec_mic_alt_setting(uint32_t alt_seting);
204void audio_codec_set_mic_mute(uint8_t mute);
205void audio_codec_set_spk_mute(uint8_t mute);
206void audio_codec_set_mic_volume(uint16_t volume);
207void audio_codec_set_spk_volume(uint16_t volume);
208void audio_codec_set_mic_freq(uint32_t freq);
209void audio_codec_set_spk_freq(uint32_t freq);
210
222#ifdef __cplusplus
223}
224#endif
225
226#endif
227
buffer
uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:43
error_status
error_status
Definition: at32f435_437.h:380
audio_codec_mic_alt_setting
void audio_codec_mic_alt_setting(uint32_t alt_seting)
audio codec microphone alt setting config
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:173
audio_codec_set_spk_volume
void audio_codec_set_spk_volume(uint16_t volume)
audio codec set speaker volume
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:221
audio_codec_set_spk_mute
void audio_codec_set_spk_mute(uint8_t mute)
audio codec set speaker mute
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:199
MIC_BUFFER_SIZE
#define MIC_BUFFER_SIZE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:145
audio_codec_set_mic_freq
void audio_codec_set_mic_freq(uint32_t freq)
audio codec set microphone freq
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:125
audio_codec_mic_get_data
uint32_t audio_codec_mic_get_data(uint8_t *buffer)
codec microphone get data
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:286
audio_codec_loop
error_status audio_codec_loop(void)
audio codec loop
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:870
SPK_BUFFER_SIZE
#define SPK_BUFFER_SIZE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:146
audio_codec_set_mic_mute
void audio_codec_set_mic_mute(uint8_t mute)
audio codec set microphone mute
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:188
audio_codec_spk_fifo_write
void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
audio codec interface
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:248
audio_codec_spk_feedback
uint8_t audio_codec_spk_feedback(uint8_t *feedback)
codec speaker feedback
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:232
audio_codec_modify_freq
void audio_codec_modify_freq(uint32_t freq)
audio codec modify freq
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:346
audio_codec_set_mic_volume
void audio_codec_set_mic_volume(uint16_t volume)
audio codec set microphone volume
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:210
audio_codec_spk_alt_setting
void audio_codec_spk_alt_setting(uint32_t alt_seting)
audio codec speaker alt setting config
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:158
audio_codec_init
error_status audio_codec_init(void)
audio codec init
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:811
audio_codec_set_spk_freq
void audio_codec_set_spk_freq(uint32_t freq)
audio codec set speaker freq
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:141
audio_codec_type
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:150
audio_codec_type::spk_mute
uint8_t spk_mute
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:179
audio_codec_type::spk_threshold
uint16_t spk_threshold
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:161
audio_codec_type::mic_enable
uint32_t mic_enable
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:188
audio_codec_type::spk_stage
uint8_t spk_stage
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:163
audio_codec_type::mic_roff
uint16_t * mic_roff
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:167
audio_codec_type::mic_volume
uint16_t mic_volume
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:181
audio_codec_type::spk_roff
uint16_t * spk_roff
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:155
audio_codec_type::spk_rtotal
uint32_t spk_rtotal
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:160
audio_codec_type::mic_delta
uint32_t mic_delta
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:172
audio_codec_type::spk_calc
uint16_t spk_calc
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:162
audio_codec_type::mic_woff
uint16_t * mic_woff
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:168
audio_codec_type::mic_stage
uint8_t mic_stage
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:176
audio_codec_type::mic_adj_count
uint16_t mic_adj_count
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:174
audio_codec_type::spk_freq
uint32_t spk_freq
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:158
audio_codec_type::audio_bitw
uint32_t audio_bitw
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:152
audio_codec_type::mic_wend
uint16_t * mic_wend
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:169
audio_codec_type::spk_rend
uint16_t * spk_rend
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:157
audio_codec_type::mic_wtotal
uint32_t mic_wtotal
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:170
audio_codec_type::spk_enable
uint32_t spk_enable
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:187
audio_codec_type::mic_rtotal
uint32_t mic_rtotal
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:171
audio_codec_type::audio_freq
uint32_t audio_freq
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:151
audio_codec_type::mic_mute
uint8_t mic_mute
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:178
audio_codec_type::spk_volume
uint16_t spk_volume
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:182
audio_codec_type::mic_calc
uint16_t mic_calc
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:173
audio_codec_type::spk_wtotal
uint32_t spk_wtotal
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:159
audio_codec_type::mic_adj_stage
uint8_t mic_adj_stage
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:175
audio_codec_type::spk_tx_size
uint32_t spk_tx_size
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:184
audio_codec_type::mic_rx_size
uint32_t mic_rx_size
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:185
audio_codec_type::spk_woff
uint16_t * spk_woff
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:156
usb_conf.h
usb config header file


AT32F435/437 Firmwary Library: audio_codec.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • audio
  • src
Macros | Functions | Variables
at_start_f435/examples/usb_device/audio/src/audio_codec.c File Reference

audio codec function More...

#include "audio_codec.h"
#include "i2c_application.h"
#include "audio_conf.h"
#include <string.h>

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_CLKCTRL 0x80504C4E
#define | I2Cx_ADDRESS 0x00
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_8
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE8
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_MUX GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_9
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE9
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_MUX GPIO_MUX_4
#define | WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)
wm8988 freq More...
#define | WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)
#define | WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)
wm8988 bit width More...

Functions

void | memset16_buffer (uint16_t *buffer, uint32_t set, uint32_t len)
buffer memset More...
void | codec_i2s_reset (void)
audio codec i2s reset More...
void | codec_i2s_init (audio_codec_type *param)
audio codec i2s init More...
void | mclk_tmr1_init (void)
mclk clock conifg More...
void | copy_buff (uint16_t *dest, uint16_t *src, uint32_t len)
copy buffer More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
codec speaker write fifo More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | DMA1_Channel3_IRQHandler (void)
this function handles dma1 channel3 interrupt. More...
void | DMA1_Channel4_IRQHandler (void)
this function handles dma1 channel4 interrupt. More...
error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...

Variables

uint16_t | reg_addr_data []
wm8988 register default value More...
i2c_handle_type hi2cx
audio_codec_type audio_codec
uint16_t | spk_dma_buffer [DMA_BUFFER_SIZE]
uint16_t | mic_dma_buffer [DMA_BUFFER_SIZE]

Detailed Description

audio codec function

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/usb_device/audio/src/audio_codec.c.


AT32F435/437 Firmwary Library: audio_codec.c Source File

  • at_start_f435
  • examples
  • usb_device
  • audio
  • src
at_start_f435/examples/usb_device/audio/src/audio_codec.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "audio_codec.h"
29#include "i2c_application.h"
30#include "audio_conf.h"
31#include <string.h>
32
41#define I2C_TIMEOUT 0xFFFFFFFF
42
43#define I2Cx_CLKCTRL 0x80504C4E
44#define I2Cx_ADDRESS 0x00
45
46#define I2Cx_PORT I2C1
47#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
48
49#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
50#define I2Cx_SCL_GPIO_PIN GPIO_PINS_8
51#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE8
52#define I2Cx_SCL_GPIO_PORT GPIOB
53#define I2Cx_SCL_GPIO_MUX GPIO_MUX_4
54
55#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
56#define I2Cx_SDA_GPIO_PIN GPIO_PINS_9
57#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE9
58#define I2Cx_SDA_GPIO_PORT GPIOB
59#define I2Cx_SDA_GPIO_MUX GPIO_MUX_4
60
64#define WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)
65#define WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)
66
70#define WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)
71
75uint16_t reg_addr_data[] =
76{
77 (WM8988_R0_LEFT_INPUT_VOLUME << 9) | 0x012F, /*Left Input Channel Volume*/
78 (WM8988_R1_RIGHT_INPUT_VOLUME << 9) | 0x012F, /*Right Input Channel Volume*/
79 (WM8988_R2_LOUT1_VOLUME << 9) | 0x0179, /*Left Output Channel Volume*/
80 (WM8988_R3_ROUT1_VOLUME << 9) | 0x0179, /*Right Output Channel Volume*/
81 (WM8988_R5_ADC_DAC_CONTROL << 9) | 0x0006, /*De-emphasis Control and Digital soft mute*/
82 (WM8988_REG_BITW16),
83 (WM8988_REG_FREQ16K),
84 (WM8988_R10_LEFT_DAC_VOLUME << 9) | 0x01FF, /*Left Digital DAC Volume Control*/
85 (WM8988_R11_RIGHT_DAC_VOLUME << 9) | 0x01FF, /*Right Digital DAC Volume Control*/
86 (WM8988_R12_BASS_CONTROL << 9) | 0x000F, /*Bass Control*/
87 (WM8988_R13_TREBLE_CONTROL << 9) | 0x000F, /*Treble Control*/
88 (WM8988_R16_3D_CONTROL << 9) | 0x0000, /*3D stereo Enhancment*/
89 (WM8988_R21_LEFT_ADC_VOLUME << 9) | 0x01C3, /*Left ADC Digital Volume*/
90 (WM8988_R22_RIGHT_ADC_VOLUME << 9) | 0x01C3, /*Right ADC Digital Volume*/
91 (WM8988_R23_ADDITIONAL_1_CONTROL << 9) | 0x00C2, /*Additional Control 1*/
92 (WM8988_R24_ADDITIONAL_2_CONTROL << 9) | 0x0000, /*Additional Control 2*/
93 (WM8988_R27_ADDITIONAL_3_CONTROL << 9) | 0x0000, /*Additional Control 3*/
94 (WM8988_R31_ADC_INPUT_MODE << 9) | 0x0000, /*ADC input mode*/
95 (WM8988_R32_ADC_L_SIGNAL_PATH << 9) | 0x0000, /*ADC Signal Path Control left*/
96 (WM8988_R33_ADC_R_SIGNAL_PATH << 9) | 0x0000, /*ADC Signal Path Control right*/
97 (WM8988_R34_LEFT_OUT_MIX_1 << 9) | 0x0152, /*Left DAC mixer Control*/
98 (WM8988_R35_LEFT_OUT_MIX_2 << 9) | 0x0050, /*Left DAC mixer Control*/
99 (WM8988_R36_RIGHT_OUT_MIX_1 << 9) | 0x0052, /*Right DAC mixer Control*/
100 (WM8988_R37_RIGHT_OUT_MIX_2 << 9) | 0x0150, /*Right DAC mixer Control*/
101 (WM8988_R40_LOUT2_VOLUME << 9) | 0x01FF, /*Output left channel volume*/
102 (WM8988_R41_ROUT2_VOLUME << 9) | 0x01FF, /*Output left channel volume*/
103 (WM8988_R43_LOW_POWER_PALYBACK << 9) | 0x0008, /*Output left channel volume*/
104 (WM8988_R25_PWR_1_MGMT << 9) | 0x017C, /*Power Management1*/
105 (WM8988_R26_PWR_2_MGMT << 9) | 0x01F8, /*Power Management2*/
106};
107
108 i2c_handle_type hi2cx;
109
110 audio_codec_type audio_codec;
111uint16_t spk_dma_buffer[DMA_BUFFER_SIZE];
112uint16_t mic_dma_buffer[DMA_BUFFER_SIZE];
113
114void memset16_buffer(uint16_t *buffer, uint32_t set, uint32_t len);
115void codec_i2s_reset(void);
116void codec_i2s_init(audio_codec_type *param);
117void mclk_tmr1_init(void);
118void copy_buff(uint16_t *dest, uint16_t *src, uint32_t len);
119
125void audio_codec_set_mic_freq(uint32_t freq)
126{
127 if(audio_codec.audio_freq != freq)
128 {
129 audio_codec.audio_freq = freq;
130 codec_i2s_reset();
131 audio_codec_modify_freq(freq);
132 codec_i2s_init(&audio_codec);
133 }
134}
135
141void audio_codec_set_spk_freq(uint32_t freq)
142{
143 if(audio_codec.audio_freq != freq)
144 {
145 audio_codec.audio_freq = freq;
146 codec_i2s_reset();
147 audio_codec_modify_freq(freq);
148 codec_i2s_init(&audio_codec);
149 }
150}
151
152
158void audio_codec_spk_alt_setting(uint32_t alt_seting)
159{
160 if(alt_seting == 0)
161 {
162 }
163 else
164 {
165 }
166}
167
173void audio_codec_mic_alt_setting(uint32_t alt_seting)
174{
175 if(alt_seting == 0)
176 {
177 }
178 else
179 {
180 }
181}
182
188void audio_codec_set_mic_mute(uint8_t mute)
189{
190 audio_codec.mic_mute = mute;
191}
192
193
199void audio_codec_set_spk_mute(uint8_t mute)
200{
201 audio_codec.spk_mute = mute;
202}
203
204
210void audio_codec_set_mic_volume(uint16_t volume)
211{
212 /* wm8988 adc have 256 steps */
213 audio_codec.mic_volume = volume;
214}
215
221void audio_codec_set_spk_volume(uint16_t volume)
222{
223 /* wm8988 dac have 80 steps */
224 audio_codec.spk_volume = (volume * 0x50) / 0x64 + 0x30 - 1;
225}
226
232uint8_t audio_codec_spk_feedback(uint8_t *feedback)
233{
234 uint32_t feedback_value = (audio_codec.spk_freq);
235 feedback_value = ((feedback_value/1000)<<14)|((feedback_value%1000)<<4);
236 feedback[0] = (uint8_t)(feedback_value);
237 feedback[1] = (uint8_t)(feedback_value >> 8);
238 feedback[2] = (uint8_t)(feedback_value >> 16);
239 return 3;
240}
241
248void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
249{
250 uint16_t ulen = len / 2, i;
251 uint16_t *u16data = (uint16_t *)data;
252
253 switch(audio_codec.spk_stage)
254 {
255 case 0:
256 audio_codec.spk_woff = audio_codec.spk_roff = audio_codec.spk_buffer;
257 audio_codec.spk_wtotal = audio_codec.spk_rtotal = 0;
258 audio_codec.spk_stage = 1;
259 audio_codec.spk_threshold = SPK_BUFFER_SIZE/2;
260 break;
261 case 1:
262 if( audio_codec.spk_wtotal >= SPK_BUFFER_SIZE/2 )
263 {
264 audio_codec.spk_stage = 2;
265 }
266 break;
267 case 2:
268 break;
269 }
270 for( i = 0; i < ulen; ++i )
271 {
272 *audio_codec.spk_woff++ = *u16data++;
273 if( audio_codec.spk_woff >= audio_codec.spk_rend )
274 {
275 audio_codec.spk_woff = audio_codec.spk_buffer;
276 }
277 }
278 audio_codec.spk_wtotal += ulen;
279}
280
286uint32_t audio_codec_mic_get_data(uint8_t *buffer)
287{
288 //copy_buff((uint16_t *)buffer, audio_codec.mic_buffer + audio_codec.mic_hf_status, audio_codec.mic_rx_size);
289 uint16_t len = audio_codec.mic_rx_size << 1;
290 uint16_t i;
291 uint16_t* u16buf = (uint16_t*)buffer;
292 switch(audio_codec.mic_stage)
293 {
294 case 0:
295 audio_codec.mic_stage = 1;
296 memset( buffer, 0, len );
297 return len;
298 case 1:
299 if( audio_codec.mic_wtotal - audio_codec.mic_rtotal >= MIC_BUFFER_SIZE/2 )
300 {
301 audio_codec.mic_stage = 2;
302 }
303 return len;
304 }
305 switch( audio_codec.mic_adj_stage )
306 {
307 case 0:
308 break;
309 case 1:
310 if( audio_codec.mic_adj_count >= 4 ){
311 len += 4;
312 audio_codec.mic_adj_count -= 4;
313 }
314 break;
315 case 2:
316 if( audio_codec.mic_adj_count >= 4 ){
317 len -= 4;
318 audio_codec.mic_adj_count -= 4;
319 }
320 break;
321 }
322
323 for( i = 0; i < len/2; ++i )
324 {
325 *u16buf++ = *audio_codec.mic_roff++;
326 if( audio_codec.mic_roff >= audio_codec.mic_wend )
327 {
328 audio_codec.mic_roff = audio_codec.mic_buffer;
329 }
330 }
331 if( audio_codec.mic_wtotal <= audio_codec.mic_rtotal )
332 { //should not happen
333 while(1);
334 }
335
336 audio_codec.mic_rtotal += len/2;
337 audio_codec.mic_delta += len/2;
338 return len;
339}
340
346void audio_codec_modify_freq(uint32_t freq)
347{
348 uint16_t codec_cmd;
349 uint8_t i2c_cmd[2];
350 if(freq == AUDIO_FREQ_16K)
351 {
352 codec_cmd = WM8988_REG_FREQ16K;
353 }
354 else if(freq == AUDIO_FREQ_48K)
355 {
356 codec_cmd = WM8988_REG_FREQ48K;
357 }
358 i2c_cmd[0] = (uint8_t)(codec_cmd >> 8);
359 i2c_cmd[1] = (uint8_t)codec_cmd & 0xFF;
360 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
361 {
362 while(1);
363 }
364}
365
373void memset16_buffer(uint16_t *buffer, uint32_t set, uint32_t len)
374{
375 uint32_t i_index = 0;
376 for(i_index = 0; i_index < len; i_index ++)
377 {
378 buffer[i_index] = (uint16_t)set;
379 }
380}
381
389void copy_buff(uint16_t *dest, uint16_t *src, uint32_t len)
390{
391 uint16_t i_index;
392 for(i_index = 0; i_index < len; i_index ++)
393 {
394 dest[i_index] = src[i_index];
395 }
396}
397
403void i2c_lowlevel_init(i2c_handle_type* hi2c)
404{
405 gpio_init_type gpio_init_structure;
406
407 if(hi2c->i2cx == I2Cx_PORT)
408 {
409 /* i2c periph clock enable */
410 crm_periph_clock_enable(I2Cx_CLK, TRUE);
411 crm_periph_clock_enable(I2Cx_SCL_GPIO_CLK, TRUE);
412 crm_periph_clock_enable(I2Cx_SDA_GPIO_CLK, TRUE);
413
414 /* gpio configuration */
415 gpio_pin_mux_config(I2Cx_SCL_GPIO_PORT, I2Cx_SCL_GPIO_PinsSource, I2Cx_SCL_GPIO_MUX);
416
417 gpio_pin_mux_config(I2Cx_SDA_GPIO_PORT, I2Cx_SDA_GPIO_PinsSource, I2Cx_SDA_GPIO_MUX);
418
419 /* configure i2c pins: scl */
420 gpio_init_structure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
421 gpio_init_structure.gpio_mode = GPIO_MODE_MUX;
422 gpio_init_structure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
423 gpio_init_structure.gpio_pull = GPIO_PULL_UP;
424
425 gpio_init_structure.gpio_pins = I2Cx_SCL_GPIO_PIN;
426 gpio_init(I2Cx_SCL_GPIO_PORT, &gpio_init_structure);
427
428 /* configure i2c pins: sda */
429 gpio_init_structure.gpio_pins = I2Cx_SDA_GPIO_PIN;
430 gpio_init(I2Cx_SDA_GPIO_PORT, &gpio_init_structure);
431
432 /* config i2c */
433 i2c_init(hi2c->i2cx, 0x0F, I2Cx_CLKCTRL);
434
435 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
436 }
437}
438
444void mclk_tmr1_init(void)
445{
446 gpio_init_type gpio_init_struct;
447 tmr_output_config_type tmr_oc_init_structure;
448 uint16_t prescaler_value = (uint16_t)(system_core_clock / 24000000) - 1;
449
450 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
451 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
452
453 gpio_default_para_init(&gpio_init_struct);
454
455 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE8, GPIO_MUX_1);
456
457 gpio_init_struct.gpio_pins = GPIO_PINS_8;
458 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
459 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
460 gpio_init(GPIOA, &gpio_init_struct);
461
462 tmr_base_init(TMR1, 1, prescaler_value);
463 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
464 tmr_clock_source_div_set(TMR1, TMR_CLOCK_DIV1);
465
466 tmr_output_default_para_init(&tmr_oc_init_structure);
467 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
468 tmr_oc_init_structure.oc_idle_state = FALSE;
469 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
470 tmr_oc_init_structure.oc_output_state = TRUE;
471 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
472 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, 1);
473 tmr_output_channel_buffer_enable(TMR1, TMR_SELECT_CHANNEL_1, TRUE);
474
475 /* tmr enable counter */
476 tmr_counter_enable(TMR1, TRUE);
477 tmr_output_enable(TMR1, TRUE);
478}
479
480
486void codec_i2s_reset(void)
487{
488 i2s_enable(SPI1, FALSE);
489 i2s_enable(SPI2, FALSE);
490 dma_channel_enable(DMA1_CHANNEL3, FALSE);
491 dma_channel_enable(DMA1_CHANNEL4, FALSE);
492}
493
500void codec_i2s_init(audio_codec_type *param)
501{
502 gpio_init_type gpio_init_struct;
503 dma_init_type dma_init_struct;
504 i2s_init_type i2s_init_struct;
505 i2s_data_channel_format_type format = I2S_DATA_16BIT_CHANNEL_16BIT;
506
507 crm_periph_clock_enable(I2S1_GPIO_CRM_CLK, TRUE);
508 crm_periph_clock_enable(I2S2_GPIO_CRM_CLK, TRUE);
509 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
510 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
511 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
512
513 param->spk_freq = param->audio_freq;
514
515 param->spk_tx_size = (param->audio_freq / 1000) * (param->audio_bitw / 8) * AUDIO_SPK_CHANEL_NUM / 2;
516 param->mic_rx_size = (param->audio_freq / 1000) * (param->audio_bitw / 8) * AUDIO_MIC_CHANEL_NUM / 2;
517
518 memset(param->spk_buffer, 0, SPK_BUFFER_SIZE*sizeof(uint16_t));
519 memset(param->mic_buffer, 0, MIC_BUFFER_SIZE*sizeof(uint16_t));
520
521 param->mic_wend = param->mic_woff = param->mic_roff = param->mic_buffer;
522 param->spk_rend = param->spk_woff = param->spk_roff = param->spk_buffer;
523
524 while(param->mic_wend < param->mic_buffer+MIC_BUFFER_SIZE)
525 {
526 param->mic_wend += param->mic_rx_size;
527 }
528 param->mic_wend -= param->mic_rx_size;
529 while(param->spk_rend < param->spk_buffer+SPK_BUFFER_SIZE)
530 {
531 param->spk_rend += param->spk_tx_size;
532 }
533 param->spk_rend -= param->spk_tx_size;
534 if(param->audio_bitw == 16)
535 {
536 format = I2S_DATA_16BIT_CHANNEL_16BIT;
537 }
538 else
539 {
540 format = I2S_DATA_24BIT_CHANNEL_32BIT;
541 }
542
543 gpio_default_para_init(&gpio_init_struct);
544
545 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
546 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
547 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
548 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
549
550
551 /* i2s1 ws pins */
552 gpio_init_struct.gpio_pins = I2S1_WS_PIN;
553 gpio_init(I2S1_GPIO, &gpio_init_struct);
554 gpio_pin_mux_config(I2S1_GPIO, I2S1_WS_PIN_SOURCE, I2S1_WS_GPIO_MUX);
555
556 /* i2s1 ck pins */
557 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
558 gpio_init_struct.gpio_pins = I2S1_CK_PIN;
559 gpio_init(I2S1_GPIO, &gpio_init_struct);
560 gpio_pin_mux_config(I2S1_GPIO, I2S1_CK_PIN_SOURCE, I2S1_CK_GPIO_MUX);
561
562 /* i2s1 sd pins slave tx */
563 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
564 gpio_init_struct.gpio_pins = I2S1_SD_PIN;
565 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
566 gpio_init(I2S1_GPIO, &gpio_init_struct);
567 gpio_pin_mux_config(I2S1_GPIO, I2S1_SD_PIN_SOURCE, I2S1_SD_GPIO_MUX);
568
569 /* i2s2 ws pins */
570 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
571 gpio_init_struct.gpio_pins = I2S2_WS_PIN;
572 gpio_init(I2S2_GPIO, &gpio_init_struct);
573 gpio_pin_mux_config(I2S2_GPIO, I2S2_WS_PIN_SOURCE, I2S2_WS_GPIO_MUX);
574
575 /* i2s2 ck pins */
576 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
577 gpio_init_struct.gpio_pins = I2S2_CK_PIN;
578 gpio_init(I2S2_GPIO, &gpio_init_struct);
579 gpio_pin_mux_config(I2S2_GPIO, I2S2_CK_PIN_SOURCE, I2S2_CK_GPIO_MUX);
580
581 /* i2s2 sd pins slave rx */
582 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
583 gpio_init_struct.gpio_pins = I2S2_SD_PIN;
584 gpio_init(I2S2_GPIO, &gpio_init_struct);
585 gpio_pin_mux_config(I2S2_GPIO, I2S2_SD_PIN_SOURCE, I2S2_SD_GPIO_MUX);
586
587 /* dma config */
588 dma_reset(DMA1_CHANNEL3);
589 dma_reset(DMA1_CHANNEL4);
590
591 /* dma1 channel3: speaker i2s1 tx */
592 dma_default_para_init(&dma_init_struct);
593 dma_init_struct.buffer_size = param->spk_tx_size << 1;
594 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
595 dma_init_struct.memory_base_addr = (uint32_t)spk_dma_buffer;
596 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
597 dma_init_struct.memory_inc_enable = TRUE;
598 dma_init_struct.peripheral_base_addr = (uint32_t)I2S1_DT_ADDRESS;
599 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
600 dma_init_struct.peripheral_inc_enable = FALSE;
601 dma_init_struct.priority = DMA_PRIORITY_HIGH;
602 dma_init_struct.loop_mode_enable = TRUE;
603 dma_init(DMA1_CHANNEL3, &dma_init_struct);
604 dma_interrupt_enable(DMA1_CHANNEL3, DMA_FDT_INT, TRUE);
605 dma_interrupt_enable(DMA1_CHANNEL3, DMA_HDT_INT, TRUE);
606 nvic_irq_enable(DMA1_Channel3_IRQn, 1, 0);
607
608 /* dma1 channel4: microphone i2s2 rx */
609 dma_default_para_init(&dma_init_struct);
610 dma_init_struct.buffer_size = param->mic_rx_size << 1;
611 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
612 dma_init_struct.memory_base_addr = (uint32_t)mic_dma_buffer;
613 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
614 dma_init_struct.memory_inc_enable = TRUE;
615 dma_init_struct.peripheral_base_addr = (uint32_t)I2S2_DT_ADDRESS;
616 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
617 dma_init_struct.peripheral_inc_enable = FALSE;
618 dma_init_struct.priority = DMA_PRIORITY_HIGH;
619 dma_init_struct.loop_mode_enable = TRUE;
620 dma_init(DMA1_CHANNEL4, &dma_init_struct);
621 dma_interrupt_enable(DMA1_CHANNEL4, DMA_FDT_INT, TRUE);
622 dma_interrupt_enable(DMA1_CHANNEL4, DMA_HDT_INT, TRUE);
623 nvic_irq_enable(DMA1_Channel4_IRQn, 2, 0);
624
625 /* i2s1 tx init */
626 spi_i2s_reset(SPI1);
627 i2s_default_para_init(&i2s_init_struct);
628 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
629 i2s_init_struct.data_channel_format = format;
630 i2s_init_struct.mclk_output_enable = FALSE;
631 i2s_init_struct.audio_sampling_freq = (i2s_audio_sampling_freq_type)param->audio_freq;
632 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
633 i2s_init_struct.operation_mode = I2S_MODE_SLAVE_TX;
634 i2s_init(SPI1, &i2s_init_struct);
635
636 /* i2s2 rx init */
637 spi_i2s_reset(SPI2);
638 i2s_default_para_init(&i2s_init_struct);
639 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
640 i2s_init_struct.data_channel_format = format;
641 i2s_init_struct.mclk_output_enable = FALSE;
642 i2s_init_struct.audio_sampling_freq = (i2s_audio_sampling_freq_type)param->audio_freq;
643 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
644 i2s_init_struct.operation_mode = I2S_MODE_SLAVE_RX;
645 i2s_init(SPI2, &i2s_init_struct);
646
647
648 spi_i2s_dma_transmitter_enable(SPI1, TRUE);
649 spi_i2s_dma_receiver_enable(SPI2, TRUE);
650 i2s_enable(SPI1, TRUE);
651 i2s_enable(SPI2, TRUE);
652
653 dmamux_enable(DMA1, TRUE);
654 dmamux_init(DMA1MUX_CHANNEL3, DMAMUX_DMAREQ_ID_SPI1_TX);
655 dmamux_init(DMA1MUX_CHANNEL4, DMAMUX_DMAREQ_ID_SPI2_RX);
656 dma_channel_enable(DMA1_CHANNEL3, TRUE);
657 dma_channel_enable(DMA1_CHANNEL4, TRUE);
658
659}
660
666void DMA1_Channel3_IRQHandler(void)
667{
668 uint16_t half_size = audio_codec.spk_tx_size;
669 uint16_t *pdst;
670
671 if(dma_flag_get(DMA1_HDT3_FLAG) == SET)
672 {
673 //copy_buff(audio_codec.spk_buffer, audio_codec.spk_tx_fifo + audio_codec.r_pos, half_size);
674 pdst = spk_dma_buffer;
675 dma_flag_clear(DMA1_HDT3_FLAG);
676 }
677 else if(dma_flag_get(DMA1_FDT3_FLAG) == SET)
678 {
679 //copy_buff(&audio_codec.spk_buffer[half_size], audio_codec.spk_tx_fifo + audio_codec.r_pos, half_size);
680 pdst = spk_dma_buffer + half_size;
681 dma_flag_clear(DMA1_FDT3_FLAG);
682 }
683
684 switch( audio_codec.spk_stage )
685 {
686 case 0:
687 case 1:
688 memset( pdst, 0, half_size << 1);
689 break;
690 case 2:
691 if( audio_codec.spk_wtotal >= audio_codec.spk_rtotal + SPK_BUFFER_SIZE )
692 {
693 while(1);//should not happen;
694 }
695 if( audio_codec.spk_rtotal >= audio_codec.spk_wtotal )
696 {
697 audio_codec.spk_stage = 0;
698 audio_codec.spk_woff = audio_codec.spk_roff = audio_codec.spk_buffer;
699 audio_codec.spk_rtotal = audio_codec.spk_wtotal = 0;
700 }
701 else
702 {
703 memcpy( pdst, audio_codec.spk_roff, half_size << 1 );
704 audio_codec.spk_roff += half_size;
705 audio_codec.spk_rtotal += half_size;
706 if( audio_codec.spk_roff >= audio_codec.spk_rend )
707 {
708 audio_codec.spk_roff = audio_codec.spk_buffer;
709 }
710 if( ++audio_codec.spk_calc == 256 )
711 {
712 uint16_t delta = audio_codec.spk_wtotal - audio_codec.spk_rtotal;
713 audio_codec.spk_calc = 0;
714 if( delta < audio_codec.spk_threshold - half_size )
715 {
716 audio_codec.spk_threshold -= half_size;
717 audio_codec.spk_freq += audio_codec.audio_freq/1024;
718 }
719 else if( delta > audio_codec.spk_threshold + half_size )
720 {
721 audio_codec.spk_threshold += half_size;
722 audio_codec.spk_freq -= audio_codec.audio_freq/1024;
723 }
724 if(audio_codec.spk_rtotal > 0x20000000)
725 {
726 audio_codec.spk_rtotal -= 0x10000000;
727 audio_codec.spk_wtotal -= 0x10000000;
728 }
729 }
730 }
731 break;
732 }
733
734}
735
741void DMA1_Channel4_IRQHandler(void)
742{
743 uint16_t *psrc;
744 uint16_t len = audio_codec.mic_rx_size << 1;
745
746 if(dma_flag_get(DMA1_HDT4_FLAG) == SET)
747 {
748 dma_flag_clear(DMA1_HDT4_FLAG);
749 psrc = mic_dma_buffer;
750 }
751 else if(dma_flag_get(DMA1_FDT4_FLAG) == SET)
752 {
753 psrc = mic_dma_buffer + audio_codec.mic_rx_size;
754 dma_flag_clear(DMA1_FDT4_FLAG);
755 }
756 if( audio_codec.mic_stage )
757 {
758 memcpy( audio_codec.mic_woff, psrc, len );
759 audio_codec.mic_woff += len/2;
760 audio_codec.mic_wtotal += len/2;
761 if( audio_codec.mic_woff >= audio_codec.mic_wend )
762 {
763 audio_codec.mic_woff = audio_codec.mic_buffer;
764 }
765 if( audio_codec.mic_stage == 2 )
766 {
767 if( 1024 == ++audio_codec.mic_calc )
768 {
769 uint32_t size_estimate = 1024*audio_codec.mic_rx_size;
770 audio_codec.mic_calc = 0;
771 if( audio_codec.mic_delta > size_estimate )
772 {
773 audio_codec.mic_adj_count = audio_codec.mic_delta - size_estimate;
774 audio_codec.mic_adj_stage = 2;
775 }
776 else if( audio_codec.mic_delta < size_estimate )
777 {
778 audio_codec.mic_adj_count = size_estimate - audio_codec.mic_delta;
779 audio_codec.mic_adj_stage = 1;
780 }
781 else
782 {
783 audio_codec.mic_adj_count = 0;
784 audio_codec.mic_adj_stage = 0;
785 }
786 audio_codec.mic_delta = 0;
787 if( audio_codec.mic_rtotal >= 0x80000000 )
788 {
789 audio_codec.mic_rtotal -= 0x80000000;
790 audio_codec.mic_wtotal -= 0x80000000;
791 }
792 }
793 if( audio_codec.mic_wtotal >= audio_codec.mic_rtotal + MIC_BUFFER_SIZE )
794 {
795 audio_codec.mic_delta = audio_codec.mic_wtotal = audio_codec.mic_rtotal = 0;
796 audio_codec.mic_woff = audio_codec.mic_roff = audio_codec.mic_buffer;
797 audio_codec.mic_stage = 0;
798 audio_codec.mic_adj_stage = 0;
799 audio_codec.mic_adj_count = 0;
800 audio_codec.mic_calc = 0;
801 }
802 }
803 }
804}
805
811 error_status audio_codec_init(void)
812{
813 uint32_t reg_len = sizeof(reg_addr_data) / sizeof(uint16_t);
814 uint32_t i_index = 0;
815 uint8_t i2c_cmd[2];
816
817 if(AUDIO_DEFAULT_FREQ == AUDIO_FREQ_16K)
818 {
819 reg_addr_data[6] = WM8988_REG_FREQ16K;
820 audio_codec.audio_freq = AUDIO_FREQ_16K;
821 }
822 else if(AUDIO_DEFAULT_FREQ == AUDIO_FREQ_48K)
823 {
824 reg_addr_data[6] = WM8988_REG_FREQ48K;
825 audio_codec.audio_freq = AUDIO_FREQ_48K;
826 }
827 else
828 {
829 return ERROR;
830 }
831
832 if(AUDIO_DEFAULT_BITW == AUDIO_BITW_16)
833 {
834 reg_addr_data[5] = WM8988_REG_BITW16;
835 audio_codec.audio_bitw = AUDIO_BITW_16;
836 }
837 else
838 {
839 return ERROR;
840 }
841
842 /* i2c init */
843 hi2cx.i2cx = I2Cx_PORT;
844
845 i2c_config(&hi2cx);
846
847 for(i_index = 0; i_index < reg_len; i_index ++)
848 {
849 i2c_cmd[0] = (uint8_t)(reg_addr_data[i_index] >> 8);
850 i2c_cmd[1] = (uint8_t)reg_addr_data[i_index] & 0xFF;
851 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
852 {
853 return ERROR;
854 }
855 }
856
857 /* timer init */
858 mclk_tmr1_init();
859
860 codec_i2s_init(&audio_codec);
861
862 return SUCCESS;
863}
864
870 error_status audio_codec_loop(void)
871{
872 static uint8_t mic_mute = 0;
873 static uint16_t mic_volume = 0;
874 static uint8_t spk_mute = 0;
875 static uint16_t spk_volume = 0;
876 uint16_t audio_ctrl_l;
877 uint16_t audio_ctrl_r;
878 uint8_t i2c_cmd[2];
879
880 if(mic_mute != audio_codec.mic_mute)
881 {
882 mic_mute = audio_codec.mic_mute;
883 audio_ctrl_l = WM8988_R21_LEFT_ADC_VOLUME << 9 | 0x100;
884 audio_ctrl_r = WM8988_R22_RIGHT_ADC_VOLUME << 9 | 0x100;
885 if(audio_codec.mic_mute == 0)
886 {
887 audio_ctrl_l |= audio_codec.mic_volume;
888 audio_ctrl_r |= audio_codec.mic_volume;
889 }
890 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
891 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
892 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
893 {
894 return ERROR;
895 }
896 i2c_cmd[0] = (uint8_t)(audio_ctrl_r >> 8);
897 i2c_cmd[1] = (uint8_t)audio_ctrl_r & 0xFF;
898 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
899 {
900 return ERROR;
901 }
902 }
903
904 if(mic_volume != audio_codec.mic_volume)
905 {
906 mic_volume = audio_codec.mic_volume;
907 audio_ctrl_l = WM8988_R21_LEFT_ADC_VOLUME << 9 | 0x100;
908 audio_ctrl_r = WM8988_R22_RIGHT_ADC_VOLUME << 9 | 0x100;
909 audio_ctrl_l |= audio_codec.mic_volume;
910 audio_ctrl_r |= audio_codec.mic_volume;
911 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
912 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
913 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
914 {
915 return ERROR;
916 }
917 i2c_cmd[0] = (uint8_t)(audio_ctrl_r >> 8);
918 i2c_cmd[1] = (uint8_t)audio_ctrl_r & 0xFF;
919 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
920 {
921 return ERROR;
922 }
923 }
924
925 if(spk_mute != audio_codec.spk_mute)
926 {
927 spk_mute = audio_codec.spk_mute;
928 audio_ctrl_l = (WM8988_R5_ADC_DAC_CONTROL << 9) | 0x0006 | (audio_codec.spk_mute << 3);
929 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
930 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
931 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
932 {
933 return ERROR;
934 }
935 }
936
937 if(spk_volume != audio_codec.spk_volume)
938 {
939 spk_volume = audio_codec.spk_volume;
940 audio_ctrl_l = WM8988_R2_LOUT1_VOLUME << 9 | 0x100;
941 audio_ctrl_r = WM8988_R3_ROUT1_VOLUME << 9 | 0x100;
942 audio_ctrl_l |= audio_codec.spk_volume;
943 audio_ctrl_r |= audio_codec.spk_volume;
944
945 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
946 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
947
948 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
949 {
950 return ERROR;
951 }
952 i2c_cmd[0] = (uint8_t)(audio_ctrl_r >> 8);
953 i2c_cmd[1] = (uint8_t)audio_ctrl_r & 0xFF;
954 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
955 {
956 return ERROR;
957 }
958 }
959 return SUCCESS;
960}
961
buffer
uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:43
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/main.c:38
reg_addr_data
uint16_t reg_addr_data[]
wm8988 register default value
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:75
audio_codec_mic_alt_setting
void audio_codec_mic_alt_setting(uint32_t alt_seting)
audio codec microphone alt setting config
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:173
codec_i2s_reset
void codec_i2s_reset(void)
audio codec i2s reset
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:486
spk_dma_buffer
uint16_t spk_dma_buffer[DMA_BUFFER_SIZE]
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:111
audio_codec_set_spk_volume
void audio_codec_set_spk_volume(uint16_t volume)
audio codec set speaker volume
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:221
audio_codec_set_spk_mute
void audio_codec_set_spk_mute(uint8_t mute)
audio codec set speaker mute
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:199
WM8988_REG_FREQ48K
#define WM8988_REG_FREQ48K
wm8988 freq
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:64
audio_codec_set_mic_freq
void audio_codec_set_mic_freq(uint32_t freq)
audio codec set microphone freq
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:125
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:44
I2Cx_SDA_GPIO_PIN
#define I2Cx_SDA_GPIO_PIN
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:56
I2Cx_SDA_GPIO_MUX
#define I2Cx_SDA_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:59
I2Cx_CLKCTRL
#define I2Cx_CLKCTRL
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:43
I2Cx_CLK
#define I2Cx_CLK
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:47
audio_codec_mic_get_data
uint32_t audio_codec_mic_get_data(uint8_t *buffer)
codec microphone get data
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:286
WM8988_REG_BITW16
#define WM8988_REG_BITW16
wm8988 bit width
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:70
audio_codec_loop
error_status audio_codec_loop(void)
audio codec loop
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:870
codec_i2s_init
void codec_i2s_init(audio_codec_type *param)
audio codec i2s init
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:500
audio_codec_set_mic_mute
void audio_codec_set_mic_mute(uint8_t mute)
audio codec set microphone mute
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:188
audio_codec_spk_fifo_write
void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
codec speaker write fifo
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:248
I2Cx_SCL_GPIO_PinsSource
#define I2Cx_SCL_GPIO_PinsSource
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:51
mic_dma_buffer
uint16_t mic_dma_buffer[DMA_BUFFER_SIZE]
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:112
audio_codec_spk_feedback
uint8_t audio_codec_spk_feedback(uint8_t *feedback)
codec speaker feedback
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:232
hi2cx
i2c_handle_type hi2cx
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:108
I2Cx_SCL_GPIO_MUX
#define I2Cx_SCL_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:53
DMA1_Channel4_IRQHandler
void DMA1_Channel4_IRQHandler(void)
this function handles dma1 channel4 interrupt.
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:741
audio_codec_modify_freq
void audio_codec_modify_freq(uint32_t freq)
audio codec modify freq
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:346
I2Cx_SDA_GPIO_PORT
#define I2Cx_SDA_GPIO_PORT
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:58
audio_codec_set_mic_volume
void audio_codec_set_mic_volume(uint16_t volume)
audio codec set microphone volume
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:210
mclk_tmr1_init
void mclk_tmr1_init(void)
mclk clock conifg
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:444
I2Cx_SDA_GPIO_PinsSource
#define I2Cx_SDA_GPIO_PinsSource
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:57
DMA1_Channel3_IRQHandler
void DMA1_Channel3_IRQHandler(void)
this function handles dma1 channel3 interrupt.
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:666
I2Cx_SDA_GPIO_CLK
#define I2Cx_SDA_GPIO_CLK
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:55
audio_codec
audio_codec_type audio_codec
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:110
audio_codec_spk_alt_setting
void audio_codec_spk_alt_setting(uint32_t alt_seting)
audio codec speaker alt setting config
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:158
i2c_lowlevel_init
void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:403
audio_codec_init
error_status audio_codec_init(void)
audio codec init
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:811
WM8988_REG_FREQ16K
#define WM8988_REG_FREQ16K
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:65
copy_buff
void copy_buff(uint16_t *dest, uint16_t *src, uint32_t len)
copy buffer
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:389
memset16_buffer
void memset16_buffer(uint16_t *buffer, uint32_t set, uint32_t len)
buffer memset
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:373
I2Cx_PORT
#define I2Cx_PORT
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:46
audio_codec_set_spk_freq
void audio_codec_set_spk_freq(uint32_t freq)
audio codec set speaker freq
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:141
I2Cx_SCL_GPIO_PIN
#define I2Cx_SCL_GPIO_PIN
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:50
I2Cx_SCL_GPIO_CLK
#define I2Cx_SCL_GPIO_CLK
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:49
I2Cx_SCL_GPIO_PORT
#define I2Cx_SCL_GPIO_PORT
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:52
system_core_clock
unsigned int system_core_clock
Definition: system_at32f435_437.c:48
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:138
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:161
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:154
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_SPI2_RX
@ DMAMUX_DMAREQ_ID_SPI2_RX
Definition: at32f435_437_dma.h:206
DMAMUX_DMAREQ_ID_SPI1_TX
@ DMAMUX_DMAREQ_ID_SPI1_TX
Definition: at32f435_437_dma.h:205
DMA1_HDT4_FLAG
#define DMA1_HDT4_FLAG
Definition: at32f435_437_dma.h:79
DMA1_HDT3_FLAG
#define DMA1_HDT3_FLAG
Definition: at32f435_437_dma.h:75
DMA1_FDT4_FLAG
#define DMA1_FDT4_FLAG
Definition: at32f435_437_dma.h:78
DMA1_FDT3_FLAG
#define DMA1_FDT3_FLAG
Definition: at32f435_437_dma.h:74
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA_HDT_INT
#define DMA_HDT_INT
Definition: at32f435_437_dma.h:53
DMA1MUX_CHANNEL3
#define DMA1MUX_CHANNEL3
Definition: at32f435_437_dma.h:706
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f435_437_dma.h:698
DMA1MUX_CHANNEL4
#define DMA1MUX_CHANNEL4
Definition: at32f435_437_dma.h:707
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f435_437_dma.h:699
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_MODERATE
@ GPIO_DRIVE_STRENGTH_MODERATE
Definition: at32f435_437_gpio.h:94
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f435_437_gpio.h:103
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_1
@ GPIO_MUX_1
Definition: at32f435_437_gpio.h:157
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
i2c_init
void i2c_init(i2c_type *i2c_x, uint8_t dfilters, uint32_t clk)
init i2c digit filters and clock control register.
Definition: at32f435_437_i2c.c:79
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config i2c own address 1.
Definition: at32f435_437_i2c.c:103
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f435_437_i2c.h:113
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:113
i2c_master_transmit
i2c_status_type i2c_master_transmit(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode.
Definition: i2c_application.c:375
I2C_OK
@ I2C_OK
Definition: i2c_application.h:81
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f435_437_spi.c:350
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f435_437_spi.c:533
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f435_437_spi.c:479
spi_i2s_reset
void spi_i2s_reset(spi_type *spi_x)
spi reset by crm reset register
Definition: at32f435_437_spi.c:51
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f435_437_spi.c:332
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f435_437_spi.c:519
i2s_data_channel_format_type
i2s_data_channel_format_type
i2s data bit num and channel bit num type
Definition: at32f435_437_spi.h:228
i2s_audio_sampling_freq_type
i2s_audio_sampling_freq_type
i2s audio frequency type
Definition: at32f435_437_spi.h:211
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f435_437_spi.h:251
I2S_DATA_16BIT_CHANNEL_16BIT
@ I2S_DATA_16BIT_CHANNEL_16BIT
Definition: at32f435_437_spi.h:229
I2S_DATA_24BIT_CHANNEL_32BIT
@ I2S_DATA_24BIT_CHANNEL_32BIT
Definition: at32f435_437_spi.h:231
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f435_437_spi.h:200
I2S_MODE_SLAVE_RX
@ I2S_MODE_SLAVE_RX
Definition: at32f435_437_spi.h:241
I2S_MODE_SLAVE_TX
@ I2S_MODE_SLAVE_TX
Definition: at32f435_437_spi.h:240
SPI1
#define SPI1
Definition: at32f435_437_spi.h:453
SPI2
#define SPI2
Definition: at32f435_437_spi.h:454
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f435_437_tmr.c:1499
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_output_channel_buffer_enable
void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel buffer
Definition: at32f435_437_tmr.c:660
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f435_437_tmr.h:97
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f435_437_tmr.h:180
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:198
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
MIC_BUFFER_SIZE
#define MIC_BUFFER_SIZE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:145
SPK_BUFFER_SIZE
#define SPK_BUFFER_SIZE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:146
DMA_BUFFER_SIZE
#define DMA_BUFFER_SIZE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:147
I2S1_SD_PIN_SOURCE
#define I2S1_SD_PIN_SOURCE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:112
I2S1_WS_PIN_SOURCE
#define I2S1_WS_PIN_SOURCE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:104
I2S2_DT_ADDRESS
#define I2S2_DT_ADDRESS
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:134
I2S1_SD_PIN
#define I2S1_SD_PIN
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:111
I2S1_CK_PIN_SOURCE
#define I2S1_CK_PIN_SOURCE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:108
I2S1_CK_PIN
#define I2S1_CK_PIN
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:107
I2S2_GPIO
#define I2S2_GPIO
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:132
I2S2_WS_GPIO_MUX
#define I2S2_WS_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:122
I2S2_SD_PIN
#define I2S2_SD_PIN
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:128
I2S2_SD_GPIO_MUX
#define I2S2_SD_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:130
I2S1_CK_GPIO_MUX
#define I2S1_CK_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:109
I2S2_CK_PIN_SOURCE
#define I2S2_CK_PIN_SOURCE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:125
I2S2_WS_PIN
#define I2S2_WS_PIN
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:120
I2S2_GPIO_CRM_CLK
#define I2S2_GPIO_CRM_CLK
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:133
I2S2_CK_GPIO_MUX
#define I2S2_CK_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:126
I2S1_SD_GPIO_MUX
#define I2S1_SD_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:113
I2S2_SD_PIN_SOURCE
#define I2S2_SD_PIN_SOURCE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:129
I2S1_DT_ADDRESS
#define I2S1_DT_ADDRESS
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:117
I2S1_GPIO_CRM_CLK
#define I2S1_GPIO_CRM_CLK
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:116
I2S1_WS_GPIO_MUX
#define I2S1_WS_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:105
I2S1_WS_PIN
#define I2S1_WS_PIN
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:103
I2S2_WS_PIN_SOURCE
#define I2S2_WS_PIN_SOURCE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:121
I2S1_GPIO
#define I2S1_GPIO
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:115
I2S2_CK_PIN
#define I2S2_CK_PIN
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:124
WM8988_R27_ADDITIONAL_3_CONTROL
#define WM8988_R27_ADDITIONAL_3_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:77
WM8988_I2C_ADDR_CSB_LOW
#define WM8988_I2C_ADDR_CSB_LOW
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:93
WM8988_R10_LEFT_DAC_VOLUME
#define WM8988_R10_LEFT_DAC_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:60
WM8988_R1_RIGHT_INPUT_VOLUME
#define WM8988_R1_RIGHT_INPUT_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:51
WM8988_R3_ROUT1_VOLUME
#define WM8988_R3_ROUT1_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:53
WM8988_R36_RIGHT_OUT_MIX_1
#define WM8988_R36_RIGHT_OUT_MIX_1
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:84
WM8988_R21_LEFT_ADC_VOLUME
#define WM8988_R21_LEFT_ADC_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:71
WM8988_R31_ADC_INPUT_MODE
#define WM8988_R31_ADC_INPUT_MODE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:79
WM8988_R13_TREBLE_CONTROL
#define WM8988_R13_TREBLE_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:63
WM8988_R16_3D_CONTROL
#define WM8988_R16_3D_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:66
WM8988_R22_RIGHT_ADC_VOLUME
#define WM8988_R22_RIGHT_ADC_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:72
WM8988_R0_LEFT_INPUT_VOLUME
#define WM8988_R0_LEFT_INPUT_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:50
WM8988_R23_ADDITIONAL_1_CONTROL
#define WM8988_R23_ADDITIONAL_1_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:73
WM8988_R35_LEFT_OUT_MIX_2
#define WM8988_R35_LEFT_OUT_MIX_2
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:83
WM8988_R43_LOW_POWER_PALYBACK
#define WM8988_R43_LOW_POWER_PALYBACK
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:91
WM8988_R32_ADC_L_SIGNAL_PATH
#define WM8988_R32_ADC_L_SIGNAL_PATH
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:80
WM8988_R26_PWR_2_MGMT
#define WM8988_R26_PWR_2_MGMT
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:76
WM8988_R11_RIGHT_DAC_VOLUME
#define WM8988_R11_RIGHT_DAC_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:61
WM8988_R24_ADDITIONAL_2_CONTROL
#define WM8988_R24_ADDITIONAL_2_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:74
WM8988_R40_LOUT2_VOLUME
#define WM8988_R40_LOUT2_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:88
WM8988_R34_LEFT_OUT_MIX_1
#define WM8988_R34_LEFT_OUT_MIX_1
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:82
WM8988_R5_ADC_DAC_CONTROL
#define WM8988_R5_ADC_DAC_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:55
WM8988_R25_PWR_1_MGMT
#define WM8988_R25_PWR_1_MGMT
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:75
WM8988_R41_ROUT2_VOLUME
#define WM8988_R41_ROUT2_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:89
WM8988_R2_LOUT1_VOLUME
#define WM8988_R2_LOUT1_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:52
WM8988_R37_RIGHT_OUT_MIX_2
#define WM8988_R37_RIGHT_OUT_MIX_2
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:85
WM8988_R33_ADC_R_SIGNAL_PATH
#define WM8988_R33_ADC_R_SIGNAL_PATH
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:81
WM8988_R12_BASS_CONTROL
#define WM8988_R12_BASS_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:62
AUDIO_BITW_16
#define AUDIO_BITW_16
Definition: audio/audio_conf.h:61
AUDIO_MIC_CHANEL_NUM
#define AUDIO_MIC_CHANEL_NUM
Definition: audio/audio_conf.h:63
AUDIO_DEFAULT_FREQ
#define AUDIO_DEFAULT_FREQ
Definition: audio/audio_conf.h:71
AUDIO_FREQ_16K
#define AUDIO_FREQ_16K
Definition: audio/audio_conf.h:59
AUDIO_SPK_CHANEL_NUM
#define AUDIO_SPK_CHANEL_NUM
Definition: audio/audio_conf.h:66
AUDIO_DEFAULT_BITW
#define AUDIO_DEFAULT_BITW
Definition: audio/audio_conf.h:72
AUDIO_FREQ_48K
#define AUDIO_FREQ_48K
Definition: audio/audio_conf.h:60
DMA1_Channel3_IRQn
@ DMA1_Channel3_IRQn
Definition: at32f435_437.h:206
DMA1_Channel4_IRQn
@ DMA1_Channel4_IRQn
Definition: at32f435_437.h:207
i2c_application.h
i2c application libray header file
audio_codec_type
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:150
audio_codec_type::spk_mute
uint8_t spk_mute
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:179
audio_codec_type::spk_threshold
uint16_t spk_threshold
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:161
audio_codec_type::spk_stage
uint8_t spk_stage
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:163
audio_codec_type::mic_roff
uint16_t * mic_roff
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:167
audio_codec_type::spk_buffer
uint16_t spk_buffer[4096]
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:154
audio_codec_type::mic_volume
uint16_t mic_volume
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:181
audio_codec_type::spk_roff
uint16_t * spk_roff
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:155
audio_codec_type::spk_rtotal
uint32_t spk_rtotal
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:160
audio_codec_type::mic_delta
uint32_t mic_delta
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:172
audio_codec_type::spk_calc
uint16_t spk_calc
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:162
audio_codec_type::mic_woff
uint16_t * mic_woff
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:168
audio_codec_type::mic_stage
uint8_t mic_stage
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:176
audio_codec_type::mic_adj_count
uint16_t mic_adj_count
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:174
audio_codec_type::spk_freq
uint32_t spk_freq
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:158
audio_codec_type::audio_bitw
uint32_t audio_bitw
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:152
audio_codec_type::mic_wend
uint16_t * mic_wend
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:169
audio_codec_type::spk_rend
uint16_t * spk_rend
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:157
audio_codec_type::mic_wtotal
uint32_t mic_wtotal
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:170
audio_codec_type::mic_rtotal
uint32_t mic_rtotal
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:171
audio_codec_type::audio_freq
uint32_t audio_freq
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:151
audio_codec_type::mic_mute
uint8_t mic_mute
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:178
audio_codec_type::spk_volume
uint16_t spk_volume
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:182
audio_codec_type::mic_calc
uint16_t mic_calc
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:173
audio_codec_type::spk_wtotal
uint32_t spk_wtotal
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:159
audio_codec_type::mic_adj_stage
uint8_t mic_adj_stage
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:175
audio_codec_type::spk_tx_size
uint32_t spk_tx_size
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:184
audio_codec_type::mic_rx_size
uint32_t mic_rx_size
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:185
audio_codec_type::spk_woff
uint16_t * spk_woff
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:156
audio_codec_type::mic_buffer
uint16_t mic_buffer[1024]
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:166
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
i2c_handle_type
Definition: i2c_application.h:112
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:113
i2s_init_type
i2s init type
Definition: at32f435_437_spi.h:274
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f435_437_spi.h:277
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f435_437_spi.h:278
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f435_437_spi.h:280
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f435_437_spi.h:276
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f435_437_spi.h:275
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:279
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415


AT32F435/437 Firmwary Library: audio_codec.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_audio_hid
  • inc
Data Structures | Macros | Functions
at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h File Reference

audio codec header file More...

#include "usb_conf.h"

Go to the source code of this file.

Data Structures

struct audio_codec_type

Macros

#define | WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/
#define | WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/
#define | WM8988_R2_LOUT1_VOLUME 0x02
#define | WM8988_R3_ROUT1_VOLUME 0x03
#define | WM8988_R4_RESERVED 0x04
#define | WM8988_R5_ADC_DAC_CONTROL 0x05
#define | WM8988_R6_RESERVED 0x06
#define | WM8988_R7_AUDIO_INTERFACE 0x07
#define | WM8988_R8_SAMPLE_RATE 0x08
#define | WM8988_R9_RESERVED 0x09
#define | WM8988_R10_LEFT_DAC_VOLUME 0x0A
#define | WM8988_R11_RIGHT_DAC_VOLUME 0x0B
#define | WM8988_R12_BASS_CONTROL 0x0C
#define | WM8988_R13_TREBLE_CONTROL 0x0D
#define | WM8988_R14_
#define | WM8988_R15_RESET 0x0F
#define | WM8988_R16_3D_CONTROL 0x10
#define | WM8988_R17_ALC1 0x11
#define | WM8988_R18_ALC2 0x12
#define | WM8988_R19_ALC3 0x13
#define | WM8988_R20_NOISE_GATE 0x14
#define | WM8988_R21_LEFT_ADC_VOLUME 0x15
#define | WM8988_R22_RIGHT_ADC_VOLUME 0x16
#define | WM8988_R23_ADDITIONAL_1_CONTROL 0x17
#define | WM8988_R24_ADDITIONAL_2_CONTROL 0x18
#define | WM8988_R25_PWR_1_MGMT 0x19
#define | WM8988_R26_PWR_2_MGMT 0x1A
#define | WM8988_R27_ADDITIONAL_3_CONTROL 0x1B
#define | WM8988_R31_ADC_INPUT_MODE 0x1F
#define | WM8988_R32_ADC_L_SIGNAL_PATH 0x20
#define | WM8988_R33_ADC_R_SIGNAL_PATH 0x21
#define | WM8988_R34_LEFT_OUT_MIX_1 0x22
#define | WM8988_R35_LEFT_OUT_MIX_2 0x23
#define | WM8988_R36_RIGHT_OUT_MIX_1 0x24
#define | WM8988_R37_RIGHT_OUT_MIX_2 0x25
#define | WM8988_R38_RESERVED
#define | WM8988_R39_RESERVED
#define | WM8988_R40_LOUT2_VOLUME 0x28
#define | WM8988_R41_ROUT2_VOLUME 0x29
#define | WM8988_R42_RESERVED
#define | WM8988_R43_LOW_POWER_PALYBACK 0x43
#define | WM8988_I2C_ADDR_CSB_LOW 0x34
#define | WM8988_I2C_ADDR_CSB_HIGH 0x36
#define | I2S1_WS_PIN GPIO_PINS_4
#define | I2S1_WS_PIN_SOURCE GPIO_PINS_SOURCE4
#define | I2S1_WS_GPIO_MUX GPIO_MUX_5
#define | I2S1_CK_PIN GPIO_PINS_5
#define | I2S1_CK_PIN_SOURCE GPIO_PINS_SOURCE5
#define | I2S1_CK_GPIO_MUX GPIO_MUX_5
#define | I2S1_SD_PIN GPIO_PINS_7
#define | I2S1_SD_PIN_SOURCE GPIO_PINS_SOURCE7
#define | I2S1_SD_GPIO_MUX GPIO_MUX_5
#define | I2S1_GPIO GPIOA
#define | I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
#define | I2S1_DT_ADDRESS (&(SPI1->dt))
#define | I2S2_WS_PIN GPIO_PINS_0
#define | I2S2_WS_PIN_SOURCE GPIO_PINS_SOURCE0
#define | I2S2_WS_GPIO_MUX GPIO_MUX_7
#define | I2S2_CK_PIN GPIO_PINS_1
#define | I2S2_CK_PIN_SOURCE GPIO_PINS_SOURCE1
#define | I2S2_CK_GPIO_MUX GPIO_MUX_6
#define | I2S2_SD_PIN GPIO_PINS_4
#define | I2S2_SD_PIN_SOURCE GPIO_PINS_SOURCE4
#define | I2S2_SD_GPIO_MUX GPIO_MUX_6
#define | I2S2_GPIO GPIOD
#define | I2S2_GPIO_CRM_CLK CRM_GPIOD_PERIPH_CLOCK
#define | I2S2_DT_ADDRESS (&(SPI2->dt))
#define | SPK_TX_FIFO_SIZE (1024 * 4)
#define | MIC_BUFFER_SIZE 1024
#define | SPK_BUFFER_SIZE 4096
#define | DMA_BUFFER_SIZE 288

Functions

error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
audio codec interface More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...

Detailed Description

audio codec header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h.


AT32F435/437 Firmwary Library: audio_codec.h Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_audio_hid
  • inc
at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AUDIO_CODEC_H
29#define __AUDIO_CODEC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
44/* includes ------------------------------------------------------------------*/
45#include "usb_conf.h"
46
50#define WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/
51#define WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/
52#define WM8988_R2_LOUT1_VOLUME 0x02
53#define WM8988_R3_ROUT1_VOLUME 0x03
54#define WM8988_R4_RESERVED 0x04
55#define WM8988_R5_ADC_DAC_CONTROL 0x05
56#define WM8988_R6_RESERVED 0x06
57#define WM8988_R7_AUDIO_INTERFACE 0x07
58#define WM8988_R8_SAMPLE_RATE 0x08
59#define WM8988_R9_RESERVED 0x09
60#define WM8988_R10_LEFT_DAC_VOLUME 0x0A
61#define WM8988_R11_RIGHT_DAC_VOLUME 0x0B
62#define WM8988_R12_BASS_CONTROL 0x0C
63#define WM8988_R13_TREBLE_CONTROL 0x0D
64#define WM8988_R14_
65#define WM8988_R15_RESET 0x0F
66#define WM8988_R16_3D_CONTROL 0x10
67#define WM8988_R17_ALC1 0x11
68#define WM8988_R18_ALC2 0x12
69#define WM8988_R19_ALC3 0x13
70#define WM8988_R20_NOISE_GATE 0x14
71#define WM8988_R21_LEFT_ADC_VOLUME 0x15
72#define WM8988_R22_RIGHT_ADC_VOLUME 0x16
73#define WM8988_R23_ADDITIONAL_1_CONTROL 0x17
74#define WM8988_R24_ADDITIONAL_2_CONTROL 0x18
75#define WM8988_R25_PWR_1_MGMT 0x19
76#define WM8988_R26_PWR_2_MGMT 0x1A
77#define WM8988_R27_ADDITIONAL_3_CONTROL 0x1B
78
79#define WM8988_R31_ADC_INPUT_MODE 0x1F
80#define WM8988_R32_ADC_L_SIGNAL_PATH 0x20
81#define WM8988_R33_ADC_R_SIGNAL_PATH 0x21
82#define WM8988_R34_LEFT_OUT_MIX_1 0x22
83#define WM8988_R35_LEFT_OUT_MIX_2 0x23
84#define WM8988_R36_RIGHT_OUT_MIX_1 0x24
85#define WM8988_R37_RIGHT_OUT_MIX_2 0x25
86#define WM8988_R38_RESERVED
87#define WM8988_R39_RESERVED
88#define WM8988_R40_LOUT2_VOLUME 0x28
89#define WM8988_R41_ROUT2_VOLUME 0x29
90#define WM8988_R42_RESERVED
91#define WM8988_R43_LOW_POWER_PALYBACK 0x43
92
93#define WM8988_I2C_ADDR_CSB_LOW 0x34
94#define WM8988_I2C_ADDR_CSB_HIGH 0x36
95
103#define I2S1_WS_PIN GPIO_PINS_4
104#define I2S1_WS_PIN_SOURCE GPIO_PINS_SOURCE4
105#define I2S1_WS_GPIO_MUX GPIO_MUX_5
106
107#define I2S1_CK_PIN GPIO_PINS_5
108#define I2S1_CK_PIN_SOURCE GPIO_PINS_SOURCE5
109#define I2S1_CK_GPIO_MUX GPIO_MUX_5
110
111#define I2S1_SD_PIN GPIO_PINS_7
112#define I2S1_SD_PIN_SOURCE GPIO_PINS_SOURCE7
113#define I2S1_SD_GPIO_MUX GPIO_MUX_5
114
115#define I2S1_GPIO GPIOA
116#define I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
117#define I2S1_DT_ADDRESS (&(SPI1->dt))
118
119/*I2S2 Pin*/
120#define I2S2_WS_PIN GPIO_PINS_0
121#define I2S2_WS_PIN_SOURCE GPIO_PINS_SOURCE0
122#define I2S2_WS_GPIO_MUX GPIO_MUX_7
123
124#define I2S2_CK_PIN GPIO_PINS_1
125#define I2S2_CK_PIN_SOURCE GPIO_PINS_SOURCE1
126#define I2S2_CK_GPIO_MUX GPIO_MUX_6
127
128#define I2S2_SD_PIN GPIO_PINS_4
129#define I2S2_SD_PIN_SOURCE GPIO_PINS_SOURCE4
130#define I2S2_SD_GPIO_MUX GPIO_MUX_6
131
132#define I2S2_GPIO GPIOD
133#define I2S2_GPIO_CRM_CLK CRM_GPIOD_PERIPH_CLOCK
134#define I2S2_DT_ADDRESS (&(SPI2->dt))
135
136#define SPK_TX_FIFO_SIZE (1024 * 4)
137
145#define MIC_BUFFER_SIZE 1024
146#define SPK_BUFFER_SIZE 4096
147#define DMA_BUFFER_SIZE 288
148
149typedef struct
150{
151 uint32_t audio_freq;
152 uint32_t audio_bitw;
153 //spk part
154 uint16_t spk_buffer[SPK_BUFFER_SIZE];
155 uint16_t *spk_roff;
156 uint16_t *spk_woff;
157 uint16_t *spk_rend;
158 uint32_t spk_freq;
159 uint32_t spk_wtotal;
160 uint32_t spk_rtotal;
161 uint16_t spk_threshold;
162 uint16_t spk_calc;
163 uint8_t spk_stage;
164
165 //mic part
166 uint16_t mic_buffer[MIC_BUFFER_SIZE];
167 uint16_t *mic_roff;
168 uint16_t *mic_woff;
169 uint16_t *mic_wend;
170 uint32_t mic_wtotal;
171 uint32_t mic_rtotal;
172 uint32_t mic_delta;
173 uint16_t mic_calc;
174 uint16_t mic_adj_count;
175 uint8_t mic_adj_stage;
176 uint8_t mic_stage;
177
178 uint8_t mic_mute;
179 uint8_t spk_mute;
180
181 uint16_t mic_volume;
182 uint16_t spk_volume;
183
184 uint32_t spk_tx_size;
185 uint32_t mic_rx_size;
186
187 uint32_t spk_enable;
188 uint32_t mic_enable;
189
190}audio_codec_type;
191
192 error_status audio_codec_init(void);
193 error_status audio_codec_loop(void);
194void audio_codec_modify_freq(uint32_t freq);
195
199void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len);
200uint32_t audio_codec_mic_get_data(uint8_t *buffer);
201uint8_t audio_codec_spk_feedback(uint8_t *feedback);
202void audio_codec_spk_alt_setting(uint32_t alt_seting);
203void audio_codec_mic_alt_setting(uint32_t alt_seting);
204void audio_codec_set_mic_mute(uint8_t mute);
205void audio_codec_set_spk_mute(uint8_t mute);
206void audio_codec_set_mic_volume(uint16_t volume);
207void audio_codec_set_spk_volume(uint16_t volume);
208void audio_codec_set_mic_freq(uint32_t freq);
209void audio_codec_set_spk_freq(uint32_t freq);
210
222#ifdef __cplusplus
223}
224#endif
225
226#endif
227
buffer
uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:43
error_status
error_status
Definition: at32f435_437.h:380
audio_codec_mic_alt_setting
void audio_codec_mic_alt_setting(uint32_t alt_seting)
audio codec microphone alt setting config
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:173
audio_codec_set_spk_volume
void audio_codec_set_spk_volume(uint16_t volume)
audio codec set speaker volume
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:221
audio_codec_set_spk_mute
void audio_codec_set_spk_mute(uint8_t mute)
audio codec set speaker mute
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:199
MIC_BUFFER_SIZE
#define MIC_BUFFER_SIZE
Definition: at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h:145
audio_codec_set_mic_freq
void audio_codec_set_mic_freq(uint32_t freq)
audio codec set microphone freq
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:125
audio_codec_mic_get_data
uint32_t audio_codec_mic_get_data(uint8_t *buffer)
codec microphone get data
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:286
audio_codec_loop
error_status audio_codec_loop(void)
audio codec loop
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:870
SPK_BUFFER_SIZE
#define SPK_BUFFER_SIZE
Definition: at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h:146
audio_codec_set_mic_mute
void audio_codec_set_mic_mute(uint8_t mute)
audio codec set microphone mute
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:188
audio_codec_spk_fifo_write
void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
audio codec interface
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:248
audio_codec_spk_feedback
uint8_t audio_codec_spk_feedback(uint8_t *feedback)
codec speaker feedback
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:232
audio_codec_modify_freq
void audio_codec_modify_freq(uint32_t freq)
audio codec modify freq
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:346
audio_codec_set_mic_volume
void audio_codec_set_mic_volume(uint16_t volume)
audio codec set microphone volume
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:210
audio_codec_spk_alt_setting
void audio_codec_spk_alt_setting(uint32_t alt_seting)
audio codec speaker alt setting config
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:158
audio_codec_init
error_status audio_codec_init(void)
audio codec init
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:811
audio_codec_set_spk_freq
void audio_codec_set_spk_freq(uint32_t freq)
audio codec set speaker freq
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:141
audio_codec_type
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:150
usb_conf.h
usb config header file


AT32F435/437 Firmwary Library: audio_codec.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_audio_hid
  • src
Macros | Functions | Variables
at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c File Reference

audio codec function More...

#include "audio_codec.h"
#include "i2c_application.h"
#include "audio_conf.h"
#include <string.h>

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_CLKCTRL 0x80504C4E
#define | I2Cx_ADDRESS 0x00
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_8
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE8
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_MUX GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_9
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE9
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_MUX GPIO_MUX_4
#define | WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)
wm8988 freq More...
#define | WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)
#define | WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)
wm8988 bit width More...

Functions

void | memset16_buffer (uint16_t *buffer, uint32_t set, uint32_t len)
buffer memset More...
void | codec_i2s_reset (void)
audio codec i2s reset More...
void | codec_i2s_init (audio_codec_type *param)
audio codec i2s init More...
void | mclk_tmr1_init (void)
mclk clock conifg More...
void | copy_buff (uint16_t *dest, uint16_t *src, uint32_t len)
copy buffer More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
codec speaker write fifo More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | DMA1_Channel3_IRQHandler (void)
this function handles dma1 channel3 interrupt. More...
void | DMA1_Channel4_IRQHandler (void)
this function handles dma1 channel4 interrupt. More...
error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...

Variables

uint16_t | reg_addr_data []
wm8988 register default value More...
i2c_handle_type hi2cx
audio_codec_type audio_codec
uint16_t | spk_dma_buffer [DMA_BUFFER_SIZE]
uint16_t | mic_dma_buffer [DMA_BUFFER_SIZE]

Detailed Description

audio codec function

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c.


AT32F435/437 Firmwary Library: audio_codec.c Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_audio_hid
  • src
at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "audio_codec.h"
29#include "i2c_application.h"
30#include "audio_conf.h"
31#include <string.h>
32
41#define I2C_TIMEOUT 0xFFFFFFFF
42
43#define I2Cx_CLKCTRL 0x80504C4E
44#define I2Cx_ADDRESS 0x00
45
46#define I2Cx_PORT I2C1
47#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
48
49#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
50#define I2Cx_SCL_GPIO_PIN GPIO_PINS_8
51#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE8
52#define I2Cx_SCL_GPIO_PORT GPIOB
53#define I2Cx_SCL_GPIO_MUX GPIO_MUX_4
54
55#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
56#define I2Cx_SDA_GPIO_PIN GPIO_PINS_9
57#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE9
58#define I2Cx_SDA_GPIO_PORT GPIOB
59#define I2Cx_SDA_GPIO_MUX GPIO_MUX_4
60
64#define WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)
65#define WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)
66
70#define WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)
71
75uint16_t reg_addr_data[] =
76{
77 (WM8988_R0_LEFT_INPUT_VOLUME << 9) | 0x012F, /*Left Input Channel Volume*/
78 (WM8988_R1_RIGHT_INPUT_VOLUME << 9) | 0x012F, /*Right Input Channel Volume*/
79 (WM8988_R2_LOUT1_VOLUME << 9) | 0x0179, /*Left Output Channel Volume*/
80 (WM8988_R3_ROUT1_VOLUME << 9) | 0x0179, /*Right Output Channel Volume*/
81 (WM8988_R5_ADC_DAC_CONTROL << 9) | 0x0006, /*De-emphasis Control and Digital soft mute*/
82 (WM8988_REG_BITW16),
83 (WM8988_REG_FREQ16K),
84 (WM8988_R10_LEFT_DAC_VOLUME << 9) | 0x01FF, /*Left Digital DAC Volume Control*/
85 (WM8988_R11_RIGHT_DAC_VOLUME << 9) | 0x01FF, /*Right Digital DAC Volume Control*/
86 (WM8988_R12_BASS_CONTROL << 9) | 0x000F, /*Bass Control*/
87 (WM8988_R13_TREBLE_CONTROL << 9) | 0x000F, /*Treble Control*/
88 (WM8988_R16_3D_CONTROL << 9) | 0x0000, /*3D stereo Enhancment*/
89 (WM8988_R21_LEFT_ADC_VOLUME << 9) | 0x01C3, /*Left ADC Digital Volume*/
90 (WM8988_R22_RIGHT_ADC_VOLUME << 9) | 0x01C3, /*Right ADC Digital Volume*/
91 (WM8988_R23_ADDITIONAL_1_CONTROL << 9) | 0x00C2, /*Additional Control 1*/
92 (WM8988_R24_ADDITIONAL_2_CONTROL << 9) | 0x0000, /*Additional Control 2*/
93 (WM8988_R27_ADDITIONAL_3_CONTROL << 9) | 0x0000, /*Additional Control 3*/
94 (WM8988_R31_ADC_INPUT_MODE << 9) | 0x0000, /*ADC input mode*/
95 (WM8988_R32_ADC_L_SIGNAL_PATH << 9) | 0x0000, /*ADC Signal Path Control left*/
96 (WM8988_R33_ADC_R_SIGNAL_PATH << 9) | 0x0000, /*ADC Signal Path Control right*/
97 (WM8988_R34_LEFT_OUT_MIX_1 << 9) | 0x0152, /*Left DAC mixer Control*/
98 (WM8988_R35_LEFT_OUT_MIX_2 << 9) | 0x0050, /*Left DAC mixer Control*/
99 (WM8988_R36_RIGHT_OUT_MIX_1 << 9) | 0x0052, /*Right DAC mixer Control*/
100 (WM8988_R37_RIGHT_OUT_MIX_2 << 9) | 0x0150, /*Right DAC mixer Control*/
101 (WM8988_R40_LOUT2_VOLUME << 9) | 0x01FF, /*Output left channel volume*/
102 (WM8988_R41_ROUT2_VOLUME << 9) | 0x01FF, /*Output left channel volume*/
103 (WM8988_R43_LOW_POWER_PALYBACK << 9) | 0x0008, /*Output left channel volume*/
104 (WM8988_R25_PWR_1_MGMT << 9) | 0x017C, /*Power Management1*/
105 (WM8988_R26_PWR_2_MGMT << 9) | 0x01F8, /*Power Management2*/
106};
107
108 i2c_handle_type hi2cx;
109
110 audio_codec_type audio_codec;
111uint16_t spk_dma_buffer[DMA_BUFFER_SIZE];
112uint16_t mic_dma_buffer[DMA_BUFFER_SIZE];
113
114void memset16_buffer(uint16_t *buffer, uint32_t set, uint32_t len);
115void codec_i2s_reset(void);
116void codec_i2s_init(audio_codec_type *param);
117void mclk_tmr1_init(void);
118void copy_buff(uint16_t *dest, uint16_t *src, uint32_t len);
119
125void audio_codec_set_mic_freq(uint32_t freq)
126{
127 if(audio_codec.audio_freq != freq)
128 {
129 audio_codec.audio_freq = freq;
130 codec_i2s_reset();
131 audio_codec_modify_freq(freq);
132 codec_i2s_init(&audio_codec);
133 }
134}
135
141void audio_codec_set_spk_freq(uint32_t freq)
142{
143 if(audio_codec.audio_freq != freq)
144 {
145 audio_codec.audio_freq = freq;
146 codec_i2s_reset();
147 audio_codec_modify_freq(freq);
148 codec_i2s_init(&audio_codec);
149 }
150}
151
152
158void audio_codec_spk_alt_setting(uint32_t alt_seting)
159{
160 if(alt_seting == 0)
161 {
162 }
163 else
164 {
165 }
166}
167
173void audio_codec_mic_alt_setting(uint32_t alt_seting)
174{
175 if(alt_seting == 0)
176 {
177 }
178 else
179 {
180 }
181}
182
188void audio_codec_set_mic_mute(uint8_t mute)
189{
190 audio_codec.mic_mute = mute;
191}
192
193
199void audio_codec_set_spk_mute(uint8_t mute)
200{
201 audio_codec.spk_mute = mute;
202}
203
204
210void audio_codec_set_mic_volume(uint16_t volume)
211{
212 /* wm8988 adc have 256 steps */
213 audio_codec.mic_volume = volume;
214}
215
221void audio_codec_set_spk_volume(uint16_t volume)
222{
223 /* wm8988 dac have 80 steps */
224 audio_codec.spk_volume = (volume * 0x50) / 0x64 + 0x30 - 1;
225}
226
232uint8_t audio_codec_spk_feedback(uint8_t *feedback)
233{
234 uint32_t feedback_value = (audio_codec.spk_freq);
235 feedback_value = ((feedback_value/1000)<<14)|((feedback_value%1000)<<4);
236 feedback[0] = (uint8_t)(feedback_value);
237 feedback[1] = (uint8_t)(feedback_value >> 8);
238 feedback[2] = (uint8_t)(feedback_value >> 16);
239 return 3;
240}
241
248void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
249{
250 uint16_t ulen = len / 2, i;
251 uint16_t *u16data = (uint16_t *)data;
252
253 switch(audio_codec.spk_stage)
254 {
255 case 0:
256 audio_codec.spk_woff = audio_codec.spk_roff = audio_codec.spk_buffer;
257 audio_codec.spk_wtotal = audio_codec.spk_rtotal = 0;
258 audio_codec.spk_stage = 1;
259 audio_codec.spk_threshold = SPK_BUFFER_SIZE/2;
260 break;
261 case 1:
262 if( audio_codec.spk_wtotal >= SPK_BUFFER_SIZE/2 )
263 {
264 audio_codec.spk_stage = 2;
265 }
266 break;
267 case 2:
268 break;
269 }
270 for( i = 0; i < ulen; ++i )
271 {
272 *audio_codec.spk_woff++ = *u16data++;
273 if( audio_codec.spk_woff >= audio_codec.spk_rend )
274 {
275 audio_codec.spk_woff = audio_codec.spk_buffer;
276 }
277 }
278 audio_codec.spk_wtotal += ulen;
279}
280
286uint32_t audio_codec_mic_get_data(uint8_t *buffer)
287{
288 //copy_buff((uint16_t *)buffer, audio_codec.mic_buffer + audio_codec.mic_hf_status, audio_codec.mic_rx_size);
289 uint16_t len = audio_codec.mic_rx_size << 1;
290 uint16_t i;
291 uint16_t* u16buf = (uint16_t*)buffer;
292 switch(audio_codec.mic_stage)
293 {
294 case 0:
295 audio_codec.mic_stage = 1;
296 memset( buffer, 0, len );
297 return len;
298 case 1:
299 if( audio_codec.mic_wtotal - audio_codec.mic_rtotal >= MIC_BUFFER_SIZE/2 )
300 {
301 audio_codec.mic_stage = 2;
302 }
303 return len;
304 }
305 switch( audio_codec.mic_adj_stage )
306 {
307 case 0:
308 break;
309 case 1:
310 if( audio_codec.mic_adj_count >= 4 ){
311 len += 4;
312 audio_codec.mic_adj_count -= 4;
313 }
314 break;
315 case 2:
316 if( audio_codec.mic_adj_count >= 4 ){
317 len -= 4;
318 audio_codec.mic_adj_count -= 4;
319 }
320 break;
321 }
322
323 for( i = 0; i < len/2; ++i )
324 {
325 *u16buf++ = *audio_codec.mic_roff++;
326 if( audio_codec.mic_roff >= audio_codec.mic_wend )
327 {
328 audio_codec.mic_roff = audio_codec.mic_buffer;
329 }
330 }
331 if( audio_codec.mic_wtotal <= audio_codec.mic_rtotal )
332 { //should not happen
333 while(1);
334 }
335
336 audio_codec.mic_rtotal += len/2;
337 audio_codec.mic_delta += len/2;
338 return len;
339}
340
346void audio_codec_modify_freq(uint32_t freq)
347{
348 uint16_t codec_cmd;
349 uint8_t i2c_cmd[2];
350 if(freq == AUDIO_FREQ_16K)
351 {
352 codec_cmd = WM8988_REG_FREQ16K;
353 }
354 else if(freq == AUDIO_FREQ_48K)
355 {
356 codec_cmd = WM8988_REG_FREQ48K;
357 }
358 i2c_cmd[0] = (uint8_t)(codec_cmd >> 8);
359 i2c_cmd[1] = (uint8_t)codec_cmd & 0xFF;
360 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
361 {
362 while(1);
363 }
364}
365
373void memset16_buffer(uint16_t *buffer, uint32_t set, uint32_t len)
374{
375 uint32_t i_index = 0;
376 for(i_index = 0; i_index < len; i_index ++)
377 {
378 buffer[i_index] = (uint16_t)set;
379 }
380}
381
389void copy_buff(uint16_t *dest, uint16_t *src, uint32_t len)
390{
391 uint16_t i_index;
392 for(i_index = 0; i_index < len; i_index ++)
393 {
394 dest[i_index] = src[i_index];
395 }
396}
397
403void i2c_lowlevel_init(i2c_handle_type* hi2c)
404{
405 gpio_init_type gpio_init_structure;
406
407 if(hi2c->i2cx == I2Cx_PORT)
408 {
409 /* i2c periph clock enable */
410 crm_periph_clock_enable(I2Cx_CLK, TRUE);
411 crm_periph_clock_enable(I2Cx_SCL_GPIO_CLK, TRUE);
412 crm_periph_clock_enable(I2Cx_SDA_GPIO_CLK, TRUE);
413
414 /* gpio configuration */
415 gpio_pin_mux_config(I2Cx_SCL_GPIO_PORT, I2Cx_SCL_GPIO_PinsSource, I2Cx_SCL_GPIO_MUX);
416
417 gpio_pin_mux_config(I2Cx_SDA_GPIO_PORT, I2Cx_SDA_GPIO_PinsSource, I2Cx_SDA_GPIO_MUX);
418
419 /* configure i2c pins: scl */
420 gpio_init_structure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
421 gpio_init_structure.gpio_mode = GPIO_MODE_MUX;
422 gpio_init_structure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
423 gpio_init_structure.gpio_pull = GPIO_PULL_UP;
424
425 gpio_init_structure.gpio_pins = I2Cx_SCL_GPIO_PIN;
426 gpio_init(I2Cx_SCL_GPIO_PORT, &gpio_init_structure);
427
428 /* configure i2c pins: sda */
429 gpio_init_structure.gpio_pins = I2Cx_SDA_GPIO_PIN;
430 gpio_init(I2Cx_SDA_GPIO_PORT, &gpio_init_structure);
431
432 /* config i2c */
433 i2c_init(hi2c->i2cx, 0x0F, I2Cx_CLKCTRL);
434
435 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
436 }
437}
438
444void mclk_tmr1_init(void)
445{
446 gpio_init_type gpio_init_struct;
447 tmr_output_config_type tmr_oc_init_structure;
448 uint16_t prescaler_value = (uint16_t)(system_core_clock / 24000000) - 1;
449
450 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
451 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
452
453 gpio_default_para_init(&gpio_init_struct);
454
455 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE8, GPIO_MUX_1);
456
457 gpio_init_struct.gpio_pins = GPIO_PINS_8;
458 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
459 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
460 gpio_init(GPIOA, &gpio_init_struct);
461
462 tmr_base_init(TMR1, 1, prescaler_value);
463 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
464 tmr_clock_source_div_set(TMR1, TMR_CLOCK_DIV1);
465
466 tmr_output_default_para_init(&tmr_oc_init_structure);
467 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
468 tmr_oc_init_structure.oc_idle_state = FALSE;
469 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
470 tmr_oc_init_structure.oc_output_state = TRUE;
471 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
472 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, 1);
473 tmr_output_channel_buffer_enable(TMR1, TMR_SELECT_CHANNEL_1, TRUE);
474
475 /* tmr enable counter */
476 tmr_counter_enable(TMR1, TRUE);
477 tmr_output_enable(TMR1, TRUE);
478}
479
480
486void codec_i2s_reset(void)
487{
488 i2s_enable(SPI1, FALSE);
489 i2s_enable(SPI2, FALSE);
490 dma_channel_enable(DMA1_CHANNEL3, FALSE);
491 dma_channel_enable(DMA1_CHANNEL4, FALSE);
492}
493
500void codec_i2s_init(audio_codec_type *param)
501{
502 gpio_init_type gpio_init_struct;
503 dma_init_type dma_init_struct;
504 i2s_init_type i2s_init_struct;
505 i2s_data_channel_format_type format = I2S_DATA_16BIT_CHANNEL_16BIT;
506
507 crm_periph_clock_enable(I2S1_GPIO_CRM_CLK, TRUE);
508 crm_periph_clock_enable(I2S2_GPIO_CRM_CLK, TRUE);
509 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
510 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
511 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
512
513 param->spk_freq = param->audio_freq;
514
515 param->spk_tx_size = (param->audio_freq / 1000) * (param->audio_bitw / 8) * AUDIO_SPK_CHANEL_NUM / 2;
516 param->mic_rx_size = (param->audio_freq / 1000) * (param->audio_bitw / 8) * AUDIO_MIC_CHANEL_NUM / 2;
517
518 memset(param->spk_buffer, 0, SPK_BUFFER_SIZE*sizeof(uint16_t));
519 memset(param->mic_buffer, 0, MIC_BUFFER_SIZE*sizeof(uint16_t));
520
521 param->mic_wend = param->mic_woff = param->mic_roff = param->mic_buffer;
522 param->spk_rend = param->spk_woff = param->spk_roff = param->spk_buffer;
523
524 while(param->mic_wend < param->mic_buffer+MIC_BUFFER_SIZE)
525 {
526 param->mic_wend += param->mic_rx_size;
527 }
528 param->mic_wend -= param->mic_rx_size;
529 while(param->spk_rend < param->spk_buffer+SPK_BUFFER_SIZE)
530 {
531 param->spk_rend += param->spk_tx_size;
532 }
533 param->spk_rend -= param->spk_tx_size;
534 if(param->audio_bitw == 16)
535 {
536 format = I2S_DATA_16BIT_CHANNEL_16BIT;
537 }
538 else
539 {
540 format = I2S_DATA_24BIT_CHANNEL_32BIT;
541 }
542
543 gpio_default_para_init(&gpio_init_struct);
544
545 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
546 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
547 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
548 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
549
550
551 /* i2s1 ws pins */
552 gpio_init_struct.gpio_pins = I2S1_WS_PIN;
553 gpio_init(I2S1_GPIO, &gpio_init_struct);
554 gpio_pin_mux_config(I2S1_GPIO, I2S1_WS_PIN_SOURCE, I2S1_WS_GPIO_MUX);
555
556 /* i2s1 ck pins */
557 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
558 gpio_init_struct.gpio_pins = I2S1_CK_PIN;
559 gpio_init(I2S1_GPIO, &gpio_init_struct);
560 gpio_pin_mux_config(I2S1_GPIO, I2S1_CK_PIN_SOURCE, I2S1_CK_GPIO_MUX);
561
562 /* i2s1 sd pins slave tx */
563 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
564 gpio_init_struct.gpio_pins = I2S1_SD_PIN;
565 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
566 gpio_init(I2S1_GPIO, &gpio_init_struct);
567 gpio_pin_mux_config(I2S1_GPIO, I2S1_SD_PIN_SOURCE, I2S1_SD_GPIO_MUX);
568
569 /* i2s2 ws pins */
570 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
571 gpio_init_struct.gpio_pins = I2S2_WS_PIN;
572 gpio_init(I2S2_GPIO, &gpio_init_struct);
573 gpio_pin_mux_config(I2S2_GPIO, I2S2_WS_PIN_SOURCE, I2S2_WS_GPIO_MUX);
574
575 /* i2s2 ck pins */
576 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
577 gpio_init_struct.gpio_pins = I2S2_CK_PIN;
578 gpio_init(I2S2_GPIO, &gpio_init_struct);
579 gpio_pin_mux_config(I2S2_GPIO, I2S2_CK_PIN_SOURCE, I2S2_CK_GPIO_MUX);
580
581 /* i2s2 sd pins slave rx */
582 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
583 gpio_init_struct.gpio_pins = I2S2_SD_PIN;
584 gpio_init(I2S2_GPIO, &gpio_init_struct);
585 gpio_pin_mux_config(I2S2_GPIO, I2S2_SD_PIN_SOURCE, I2S2_SD_GPIO_MUX);
586
587 /* dma config */
588 dma_reset(DMA1_CHANNEL3);
589 dma_reset(DMA1_CHANNEL4);
590
591 /* dma1 channel3: speaker i2s1 tx */
592 dma_default_para_init(&dma_init_struct);
593 dma_init_struct.buffer_size = param->spk_tx_size << 1;
594 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
595 dma_init_struct.memory_base_addr = (uint32_t)spk_dma_buffer;
596 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
597 dma_init_struct.memory_inc_enable = TRUE;
598 dma_init_struct.peripheral_base_addr = (uint32_t)I2S1_DT_ADDRESS;
599 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
600 dma_init_struct.peripheral_inc_enable = FALSE;
601 dma_init_struct.priority = DMA_PRIORITY_HIGH;
602 dma_init_struct.loop_mode_enable = TRUE;
603 dma_init(DMA1_CHANNEL3, &dma_init_struct);
604 dma_interrupt_enable(DMA1_CHANNEL3, DMA_FDT_INT, TRUE);
605 dma_interrupt_enable(DMA1_CHANNEL3, DMA_HDT_INT, TRUE);
606 nvic_irq_enable(DMA1_Channel3_IRQn, 1, 0);
607
608 /* dma1 channel4: microphone i2s2 rx */
609 dma_default_para_init(&dma_init_struct);
610 dma_init_struct.buffer_size = param->mic_rx_size << 1;
611 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
612 dma_init_struct.memory_base_addr = (uint32_t)mic_dma_buffer;
613 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
614 dma_init_struct.memory_inc_enable = TRUE;
615 dma_init_struct.peripheral_base_addr = (uint32_t)I2S2_DT_ADDRESS;
616 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
617 dma_init_struct.peripheral_inc_enable = FALSE;
618 dma_init_struct.priority = DMA_PRIORITY_HIGH;
619 dma_init_struct.loop_mode_enable = TRUE;
620 dma_init(DMA1_CHANNEL4, &dma_init_struct);
621 dma_interrupt_enable(DMA1_CHANNEL4, DMA_FDT_INT, TRUE);
622 dma_interrupt_enable(DMA1_CHANNEL4, DMA_HDT_INT, TRUE);
623 nvic_irq_enable(DMA1_Channel4_IRQn, 2, 0);
624
625 /* i2s1 tx init */
626 spi_i2s_reset(SPI1);
627 i2s_default_para_init(&i2s_init_struct);
628 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
629 i2s_init_struct.data_channel_format = format;
630 i2s_init_struct.mclk_output_enable = FALSE;
631 i2s_init_struct.audio_sampling_freq = (i2s_audio_sampling_freq_type)param->audio_freq;
632 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
633 i2s_init_struct.operation_mode = I2S_MODE_SLAVE_TX;
634 i2s_init(SPI1, &i2s_init_struct);
635
636 /* i2s2 rx init */
637 spi_i2s_reset(SPI2);
638 i2s_default_para_init(&i2s_init_struct);
639 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
640 i2s_init_struct.data_channel_format = format;
641 i2s_init_struct.mclk_output_enable = FALSE;
642 i2s_init_struct.audio_sampling_freq = (i2s_audio_sampling_freq_type)param->audio_freq;
643 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
644 i2s_init_struct.operation_mode = I2S_MODE_SLAVE_RX;
645 i2s_init(SPI2, &i2s_init_struct);
646
647
648 spi_i2s_dma_transmitter_enable(SPI1, TRUE);
649 spi_i2s_dma_receiver_enable(SPI2, TRUE);
650 i2s_enable(SPI1, TRUE);
651 i2s_enable(SPI2, TRUE);
652
653 dmamux_enable(DMA1, TRUE);
654 dmamux_init(DMA1MUX_CHANNEL3, DMAMUX_DMAREQ_ID_SPI1_TX);
655 dmamux_init(DMA1MUX_CHANNEL4, DMAMUX_DMAREQ_ID_SPI2_RX);
656 dma_channel_enable(DMA1_CHANNEL3, TRUE);
657 dma_channel_enable(DMA1_CHANNEL4, TRUE);
658
659}
660
666void DMA1_Channel3_IRQHandler(void)
667{
668 uint16_t half_size = audio_codec.spk_tx_size;
669 uint16_t *pdst;
670
671 if(dma_flag_get(DMA1_HDT3_FLAG) == SET)
672 {
673 //copy_buff(audio_codec.spk_buffer, audio_codec.spk_tx_fifo + audio_codec.r_pos, half_size);
674 pdst = spk_dma_buffer;
675 dma_flag_clear(DMA1_HDT3_FLAG);
676 }
677 else if(dma_flag_get(DMA1_FDT3_FLAG) == SET)
678 {
679 //copy_buff(&audio_codec.spk_buffer[half_size], audio_codec.spk_tx_fifo + audio_codec.r_pos, half_size);
680 pdst = spk_dma_buffer + half_size;
681 dma_flag_clear(DMA1_FDT3_FLAG);
682 }
683
684 switch( audio_codec.spk_stage )
685 {
686 case 0:
687 case 1:
688 memset( pdst, 0, half_size << 1);
689 break;
690 case 2:
691 if( audio_codec.spk_wtotal >= audio_codec.spk_rtotal + SPK_BUFFER_SIZE )
692 {
693 while(1);//should not happen;
694 }
695 if( audio_codec.spk_rtotal >= audio_codec.spk_wtotal )
696 {
697 audio_codec.spk_stage = 0;
698 audio_codec.spk_woff = audio_codec.spk_roff = audio_codec.spk_buffer;
699 audio_codec.spk_rtotal = audio_codec.spk_wtotal = 0;
700 }
701 else
702 {
703 memcpy( pdst, audio_codec.spk_roff, half_size << 1 );
704 audio_codec.spk_roff += half_size;
705 audio_codec.spk_rtotal += half_size;
706 if( audio_codec.spk_roff >= audio_codec.spk_rend )
707 {
708 audio_codec.spk_roff = audio_codec.spk_buffer;
709 }
710 if( ++audio_codec.spk_calc == 256 )
711 {
712 uint16_t delta = audio_codec.spk_wtotal - audio_codec.spk_rtotal;
713 audio_codec.spk_calc = 0;
714 if( delta < audio_codec.spk_threshold - half_size )
715 {
716 audio_codec.spk_threshold -= half_size;
717 audio_codec.spk_freq += audio_codec.audio_freq/1024;
718 }
719 else if( delta > audio_codec.spk_threshold + half_size )
720 {
721 audio_codec.spk_threshold += half_size;
722 audio_codec.spk_freq -= audio_codec.audio_freq/1024;
723 }
724 if(audio_codec.spk_rtotal > 0x20000000)
725 {
726 audio_codec.spk_rtotal -= 0x10000000;
727 audio_codec.spk_wtotal -= 0x10000000;
728 }
729 }
730 }
731 break;
732 }
733
734}
735
741void DMA1_Channel4_IRQHandler(void)
742{
743 uint16_t *psrc;
744 uint16_t len = audio_codec.mic_rx_size << 1;
745
746 if(dma_flag_get(DMA1_HDT4_FLAG) == SET)
747 {
748 dma_flag_clear(DMA1_HDT4_FLAG);
749 psrc = mic_dma_buffer;
750 }
751 else if(dma_flag_get(DMA1_FDT4_FLAG) == SET)
752 {
753 psrc = mic_dma_buffer + audio_codec.mic_rx_size;
754 dma_flag_clear(DMA1_FDT4_FLAG);
755 }
756 if( audio_codec.mic_stage )
757 {
758 memcpy( audio_codec.mic_woff, psrc, len );
759 audio_codec.mic_woff += len/2;
760 audio_codec.mic_wtotal += len/2;
761 if( audio_codec.mic_woff >= audio_codec.mic_wend )
762 {
763 audio_codec.mic_woff = audio_codec.mic_buffer;
764 }
765 if( audio_codec.mic_stage == 2 )
766 {
767 if( 1024 == ++audio_codec.mic_calc )
768 {
769 uint32_t size_estimate = 1024*audio_codec.mic_rx_size;
770 audio_codec.mic_calc = 0;
771 if( audio_codec.mic_delta > size_estimate )
772 {
773 audio_codec.mic_adj_count = audio_codec.mic_delta - size_estimate;
774 audio_codec.mic_adj_stage = 2;
775 }
776 else if( audio_codec.mic_delta < size_estimate )
777 {
778 audio_codec.mic_adj_count = size_estimate - audio_codec.mic_delta;
779 audio_codec.mic_adj_stage = 1;
780 }
781 else
782 {
783 audio_codec.mic_adj_count = 0;
784 audio_codec.mic_adj_stage = 0;
785 }
786 audio_codec.mic_delta = 0;
787 if( audio_codec.mic_rtotal >= 0x80000000 )
788 {
789 audio_codec.mic_rtotal -= 0x80000000;
790 audio_codec.mic_wtotal -= 0x80000000;
791 }
792 }
793 if( audio_codec.mic_wtotal >= audio_codec.mic_rtotal + MIC_BUFFER_SIZE )
794 {
795 audio_codec.mic_delta = audio_codec.mic_wtotal = audio_codec.mic_rtotal = 0;
796 audio_codec.mic_woff = audio_codec.mic_roff = audio_codec.mic_buffer;
797 audio_codec.mic_stage = 0;
798 audio_codec.mic_adj_stage = 0;
799 audio_codec.mic_adj_count = 0;
800 audio_codec.mic_calc = 0;
801 }
802 }
803 }
804}
805
811 error_status audio_codec_init(void)
812{
813 uint32_t reg_len = sizeof(reg_addr_data) / sizeof(uint16_t);
814 uint32_t i_index = 0;
815 uint8_t i2c_cmd[2];
816
817 if(AUDIO_DEFAULT_FREQ == AUDIO_FREQ_16K)
818 {
819 reg_addr_data[6] = WM8988_REG_FREQ16K;
820 audio_codec.audio_freq = AUDIO_FREQ_16K;
821 }
822 else if(AUDIO_DEFAULT_FREQ == AUDIO_FREQ_48K)
823 {
824 reg_addr_data[6] = WM8988_REG_FREQ48K;
825 audio_codec.audio_freq = AUDIO_FREQ_48K;
826 }
827 else
828 {
829 return ERROR;
830 }
831
832 if(AUDIO_DEFAULT_BITW == AUDIO_BITW_16)
833 {
834 reg_addr_data[5] = WM8988_REG_BITW16;
835 audio_codec.audio_bitw = AUDIO_BITW_16;
836 }
837 else
838 {
839 return ERROR;
840 }
841
842 /* i2c init */
843 hi2cx.i2cx = I2Cx_PORT;
844
845 i2c_config(&hi2cx);
846
847 for(i_index = 0; i_index < reg_len; i_index ++)
848 {
849 i2c_cmd[0] = (uint8_t)(reg_addr_data[i_index] >> 8);
850 i2c_cmd[1] = (uint8_t)reg_addr_data[i_index] & 0xFF;
851 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
852 {
853 return ERROR;
854 }
855 }
856
857 /* timer init */
858 mclk_tmr1_init();
859
860 codec_i2s_init(&audio_codec);
861
862 return SUCCESS;
863}
864
870 error_status audio_codec_loop(void)
871{
872 static uint8_t mic_mute = 0;
873 static uint16_t mic_volume = 0;
874 static uint8_t spk_mute = 0;
875 static uint16_t spk_volume = 0;
876 uint16_t audio_ctrl_l;
877 uint16_t audio_ctrl_r;
878 uint8_t i2c_cmd[2];
879
880 if(mic_mute != audio_codec.mic_mute)
881 {
882 mic_mute = audio_codec.mic_mute;
883 audio_ctrl_l = WM8988_R21_LEFT_ADC_VOLUME << 9 | 0x100;
884 audio_ctrl_r = WM8988_R22_RIGHT_ADC_VOLUME << 9 | 0x100;
885 if(audio_codec.mic_mute == 0)
886 {
887 audio_ctrl_l |= audio_codec.mic_volume;
888 audio_ctrl_r |= audio_codec.mic_volume;
889 }
890 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
891 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
892 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
893 {
894 return ERROR;
895 }
896 i2c_cmd[0] = (uint8_t)(audio_ctrl_r >> 8);
897 i2c_cmd[1] = (uint8_t)audio_ctrl_r & 0xFF;
898 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
899 {
900 return ERROR;
901 }
902 }
903
904 if(mic_volume != audio_codec.mic_volume)
905 {
906 mic_volume = audio_codec.mic_volume;
907 audio_ctrl_l = WM8988_R21_LEFT_ADC_VOLUME << 9 | 0x100;
908 audio_ctrl_r = WM8988_R22_RIGHT_ADC_VOLUME << 9 | 0x100;
909 audio_ctrl_l |= audio_codec.mic_volume;
910 audio_ctrl_r |= audio_codec.mic_volume;
911 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
912 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
913 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
914 {
915 return ERROR;
916 }
917 i2c_cmd[0] = (uint8_t)(audio_ctrl_r >> 8);
918 i2c_cmd[1] = (uint8_t)audio_ctrl_r & 0xFF;
919 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
920 {
921 return ERROR;
922 }
923 }
924
925 if(spk_mute != audio_codec.spk_mute)
926 {
927 spk_mute = audio_codec.spk_mute;
928 audio_ctrl_l = (WM8988_R5_ADC_DAC_CONTROL << 9) | 0x0006 | (audio_codec.spk_mute << 3);
929 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
930 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
931 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
932 {
933 return ERROR;
934 }
935 }
936
937 if(spk_volume != audio_codec.spk_volume)
938 {
939 spk_volume = audio_codec.spk_volume;
940 audio_ctrl_l = WM8988_R2_LOUT1_VOLUME << 9 | 0x100;
941 audio_ctrl_r = WM8988_R3_ROUT1_VOLUME << 9 | 0x100;
942 audio_ctrl_l |= audio_codec.spk_volume;
943 audio_ctrl_r |= audio_codec.spk_volume;
944
945 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
946 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
947
948 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
949 {
950 return ERROR;
951 }
952 i2c_cmd[0] = (uint8_t)(audio_ctrl_r >> 8);
953 i2c_cmd[1] = (uint8_t)audio_ctrl_r & 0xFF;
954 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
955 {
956 return ERROR;
957 }
958 }
959 return SUCCESS;
960}
961
buffer
uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:43
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/main.c:38
reg_addr_data
uint16_t reg_addr_data[]
wm8988 register default value
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:75
audio_codec_mic_alt_setting
void audio_codec_mic_alt_setting(uint32_t alt_seting)
audio codec microphone alt setting config
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:173
codec_i2s_reset
void codec_i2s_reset(void)
audio codec i2s reset
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:486
spk_dma_buffer
uint16_t spk_dma_buffer[DMA_BUFFER_SIZE]
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:111
audio_codec_set_spk_volume
void audio_codec_set_spk_volume(uint16_t volume)
audio codec set speaker volume
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:221
audio_codec_set_spk_mute
void audio_codec_set_spk_mute(uint8_t mute)
audio codec set speaker mute
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:199
WM8988_REG_FREQ48K
#define WM8988_REG_FREQ48K
wm8988 freq
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:64
audio_codec_set_mic_freq
void audio_codec_set_mic_freq(uint32_t freq)
audio codec set microphone freq
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:125
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:44
I2Cx_SDA_GPIO_PIN
#define I2Cx_SDA_GPIO_PIN
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:56
I2Cx_SDA_GPIO_MUX
#define I2Cx_SDA_GPIO_MUX
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:59
I2Cx_CLKCTRL
#define I2Cx_CLKCTRL
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:43
I2Cx_CLK
#define I2Cx_CLK
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:47
audio_codec_mic_get_data
uint32_t audio_codec_mic_get_data(uint8_t *buffer)
codec microphone get data
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:286
WM8988_REG_BITW16
#define WM8988_REG_BITW16
wm8988 bit width
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:70
audio_codec_loop
error_status audio_codec_loop(void)
audio codec loop
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:870
codec_i2s_init
void codec_i2s_init(audio_codec_type *param)
audio codec i2s init
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:500
audio_codec_set_mic_mute
void audio_codec_set_mic_mute(uint8_t mute)
audio codec set microphone mute
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:188
audio_codec_spk_fifo_write
void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
codec speaker write fifo
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:248
I2Cx_SCL_GPIO_PinsSource
#define I2Cx_SCL_GPIO_PinsSource
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:51
mic_dma_buffer
uint16_t mic_dma_buffer[DMA_BUFFER_SIZE]
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:112
audio_codec_spk_feedback
uint8_t audio_codec_spk_feedback(uint8_t *feedback)
codec speaker feedback
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:232
hi2cx
i2c_handle_type hi2cx
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:108
I2Cx_SCL_GPIO_MUX
#define I2Cx_SCL_GPIO_MUX
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:53
DMA1_Channel4_IRQHandler
void DMA1_Channel4_IRQHandler(void)
this function handles dma1 channel4 interrupt.
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:741
audio_codec_modify_freq
void audio_codec_modify_freq(uint32_t freq)
audio codec modify freq
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:346
I2Cx_SDA_GPIO_PORT
#define I2Cx_SDA_GPIO_PORT
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:58
audio_codec_set_mic_volume
void audio_codec_set_mic_volume(uint16_t volume)
audio codec set microphone volume
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:210
mclk_tmr1_init
void mclk_tmr1_init(void)
mclk clock conifg
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:444
I2Cx_SDA_GPIO_PinsSource
#define I2Cx_SDA_GPIO_PinsSource
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:57
DMA1_Channel3_IRQHandler
void DMA1_Channel3_IRQHandler(void)
this function handles dma1 channel3 interrupt.
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:666
I2Cx_SDA_GPIO_CLK
#define I2Cx_SDA_GPIO_CLK
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:55
audio_codec
audio_codec_type audio_codec
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:110
audio_codec_spk_alt_setting
void audio_codec_spk_alt_setting(uint32_t alt_seting)
audio codec speaker alt setting config
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:158
i2c_lowlevel_init
void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:403
audio_codec_init
error_status audio_codec_init(void)
audio codec init
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:811
WM8988_REG_FREQ16K
#define WM8988_REG_FREQ16K
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:65
copy_buff
void copy_buff(uint16_t *dest, uint16_t *src, uint32_t len)
copy buffer
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:389
memset16_buffer
void memset16_buffer(uint16_t *buffer, uint32_t set, uint32_t len)
buffer memset
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:373
I2Cx_PORT
#define I2Cx_PORT
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:46
audio_codec_set_spk_freq
void audio_codec_set_spk_freq(uint32_t freq)
audio codec set speaker freq
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:141
I2Cx_SCL_GPIO_PIN
#define I2Cx_SCL_GPIO_PIN
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:50
I2Cx_SCL_GPIO_CLK
#define I2Cx_SCL_GPIO_CLK
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:49
I2Cx_SCL_GPIO_PORT
#define I2Cx_SCL_GPIO_PORT
Definition: at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c:52
system_core_clock
unsigned int system_core_clock
Definition: system_at32f435_437.c:48
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:138
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:161
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:154
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_SPI2_RX
@ DMAMUX_DMAREQ_ID_SPI2_RX
Definition: at32f435_437_dma.h:206
DMAMUX_DMAREQ_ID_SPI1_TX
@ DMAMUX_DMAREQ_ID_SPI1_TX
Definition: at32f435_437_dma.h:205
DMA1_HDT4_FLAG
#define DMA1_HDT4_FLAG
Definition: at32f435_437_dma.h:79
DMA1_HDT3_FLAG
#define DMA1_HDT3_FLAG
Definition: at32f435_437_dma.h:75
DMA1_FDT4_FLAG
#define DMA1_FDT4_FLAG
Definition: at32f435_437_dma.h:78
DMA1_FDT3_FLAG
#define DMA1_FDT3_FLAG
Definition: at32f435_437_dma.h:74
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA_HDT_INT
#define DMA_HDT_INT
Definition: at32f435_437_dma.h:53
DMA1MUX_CHANNEL3
#define DMA1MUX_CHANNEL3
Definition: at32f435_437_dma.h:706
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f435_437_dma.h:698
DMA1MUX_CHANNEL4
#define DMA1MUX_CHANNEL4
Definition: at32f435_437_dma.h:707
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f435_437_dma.h:699
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_MODERATE
@ GPIO_DRIVE_STRENGTH_MODERATE
Definition: at32f435_437_gpio.h:94
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f435_437_gpio.h:103
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_1
@ GPIO_MUX_1
Definition: at32f435_437_gpio.h:157
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
i2c_init
void i2c_init(i2c_type *i2c_x, uint8_t dfilters, uint32_t clk)
init i2c digit filters and clock control register.
Definition: at32f435_437_i2c.c:79
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config i2c own address 1.
Definition: at32f435_437_i2c.c:103
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f435_437_i2c.h:113
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:113
i2c_master_transmit
i2c_status_type i2c_master_transmit(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode.
Definition: i2c_application.c:375
I2C_OK
@ I2C_OK
Definition: i2c_application.h:81
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f435_437_spi.c:350
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f435_437_spi.c:533
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f435_437_spi.c:479
spi_i2s_reset
void spi_i2s_reset(spi_type *spi_x)
spi reset by crm reset register
Definition: at32f435_437_spi.c:51
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f435_437_spi.c:332
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f435_437_spi.c:519
i2s_data_channel_format_type
i2s_data_channel_format_type
i2s data bit num and channel bit num type
Definition: at32f435_437_spi.h:228
i2s_audio_sampling_freq_type
i2s_audio_sampling_freq_type
i2s audio frequency type
Definition: at32f435_437_spi.h:211
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f435_437_spi.h:251
I2S_DATA_16BIT_CHANNEL_16BIT
@ I2S_DATA_16BIT_CHANNEL_16BIT
Definition: at32f435_437_spi.h:229
I2S_DATA_24BIT_CHANNEL_32BIT
@ I2S_DATA_24BIT_CHANNEL_32BIT
Definition: at32f435_437_spi.h:231
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f435_437_spi.h:200
I2S_MODE_SLAVE_RX
@ I2S_MODE_SLAVE_RX
Definition: at32f435_437_spi.h:241
I2S_MODE_SLAVE_TX
@ I2S_MODE_SLAVE_TX
Definition: at32f435_437_spi.h:240
SPI1
#define SPI1
Definition: at32f435_437_spi.h:453
SPI2
#define SPI2
Definition: at32f435_437_spi.h:454
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f435_437_tmr.c:1499
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_output_channel_buffer_enable
void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel buffer
Definition: at32f435_437_tmr.c:660
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f435_437_tmr.h:97
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f435_437_tmr.h:180
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:198
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
MIC_BUFFER_SIZE
#define MIC_BUFFER_SIZE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:145
SPK_BUFFER_SIZE
#define SPK_BUFFER_SIZE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:146
DMA_BUFFER_SIZE
#define DMA_BUFFER_SIZE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:147
I2S1_SD_PIN_SOURCE
#define I2S1_SD_PIN_SOURCE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:112
I2S1_WS_PIN_SOURCE
#define I2S1_WS_PIN_SOURCE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:104
I2S2_DT_ADDRESS
#define I2S2_DT_ADDRESS
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:134
I2S1_SD_PIN
#define I2S1_SD_PIN
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:111
I2S1_CK_PIN_SOURCE
#define I2S1_CK_PIN_SOURCE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:108
I2S1_CK_PIN
#define I2S1_CK_PIN
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:107
I2S2_GPIO
#define I2S2_GPIO
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:132
I2S2_WS_GPIO_MUX
#define I2S2_WS_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:122
I2S2_SD_PIN
#define I2S2_SD_PIN
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:128
I2S2_SD_GPIO_MUX
#define I2S2_SD_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:130
I2S1_CK_GPIO_MUX
#define I2S1_CK_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:109
I2S2_CK_PIN_SOURCE
#define I2S2_CK_PIN_SOURCE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:125
I2S2_WS_PIN
#define I2S2_WS_PIN
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:120
I2S2_GPIO_CRM_CLK
#define I2S2_GPIO_CRM_CLK
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:133
I2S2_CK_GPIO_MUX
#define I2S2_CK_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:126
I2S1_SD_GPIO_MUX
#define I2S1_SD_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:113
I2S2_SD_PIN_SOURCE
#define I2S2_SD_PIN_SOURCE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:129
I2S1_DT_ADDRESS
#define I2S1_DT_ADDRESS
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:117
I2S1_GPIO_CRM_CLK
#define I2S1_GPIO_CRM_CLK
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:116
I2S1_WS_GPIO_MUX
#define I2S1_WS_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:105
I2S1_WS_PIN
#define I2S1_WS_PIN
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:103
I2S2_WS_PIN_SOURCE
#define I2S2_WS_PIN_SOURCE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:121
I2S1_GPIO
#define I2S1_GPIO
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:115
I2S2_CK_PIN
#define I2S2_CK_PIN
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:124
WM8988_R27_ADDITIONAL_3_CONTROL
#define WM8988_R27_ADDITIONAL_3_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:77
WM8988_I2C_ADDR_CSB_LOW
#define WM8988_I2C_ADDR_CSB_LOW
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:93
WM8988_R10_LEFT_DAC_VOLUME
#define WM8988_R10_LEFT_DAC_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:60
WM8988_R1_RIGHT_INPUT_VOLUME
#define WM8988_R1_RIGHT_INPUT_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:51
WM8988_R3_ROUT1_VOLUME
#define WM8988_R3_ROUT1_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:53
WM8988_R36_RIGHT_OUT_MIX_1
#define WM8988_R36_RIGHT_OUT_MIX_1
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:84
WM8988_R21_LEFT_ADC_VOLUME
#define WM8988_R21_LEFT_ADC_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:71
WM8988_R31_ADC_INPUT_MODE
#define WM8988_R31_ADC_INPUT_MODE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:79
WM8988_R13_TREBLE_CONTROL
#define WM8988_R13_TREBLE_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:63
WM8988_R16_3D_CONTROL
#define WM8988_R16_3D_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:66
WM8988_R22_RIGHT_ADC_VOLUME
#define WM8988_R22_RIGHT_ADC_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:72
WM8988_R0_LEFT_INPUT_VOLUME
#define WM8988_R0_LEFT_INPUT_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:50
WM8988_R23_ADDITIONAL_1_CONTROL
#define WM8988_R23_ADDITIONAL_1_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:73
WM8988_R35_LEFT_OUT_MIX_2
#define WM8988_R35_LEFT_OUT_MIX_2
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:83
WM8988_R43_LOW_POWER_PALYBACK
#define WM8988_R43_LOW_POWER_PALYBACK
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:91
WM8988_R32_ADC_L_SIGNAL_PATH
#define WM8988_R32_ADC_L_SIGNAL_PATH
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:80
WM8988_R26_PWR_2_MGMT
#define WM8988_R26_PWR_2_MGMT
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:76
WM8988_R11_RIGHT_DAC_VOLUME
#define WM8988_R11_RIGHT_DAC_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:61
WM8988_R24_ADDITIONAL_2_CONTROL
#define WM8988_R24_ADDITIONAL_2_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:74
WM8988_R40_LOUT2_VOLUME
#define WM8988_R40_LOUT2_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:88
WM8988_R34_LEFT_OUT_MIX_1
#define WM8988_R34_LEFT_OUT_MIX_1
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:82
WM8988_R5_ADC_DAC_CONTROL
#define WM8988_R5_ADC_DAC_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:55
WM8988_R25_PWR_1_MGMT
#define WM8988_R25_PWR_1_MGMT
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:75
WM8988_R41_ROUT2_VOLUME
#define WM8988_R41_ROUT2_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:89
WM8988_R2_LOUT1_VOLUME
#define WM8988_R2_LOUT1_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:52
WM8988_R37_RIGHT_OUT_MIX_2
#define WM8988_R37_RIGHT_OUT_MIX_2
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:85
WM8988_R33_ADC_R_SIGNAL_PATH
#define WM8988_R33_ADC_R_SIGNAL_PATH
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:81
WM8988_R12_BASS_CONTROL
#define WM8988_R12_BASS_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:62
AUDIO_BITW_16
#define AUDIO_BITW_16
Definition: audio/audio_conf.h:61
AUDIO_MIC_CHANEL_NUM
#define AUDIO_MIC_CHANEL_NUM
Definition: audio/audio_conf.h:63
AUDIO_DEFAULT_FREQ
#define AUDIO_DEFAULT_FREQ
Definition: audio/audio_conf.h:71
AUDIO_FREQ_16K
#define AUDIO_FREQ_16K
Definition: audio/audio_conf.h:59
AUDIO_SPK_CHANEL_NUM
#define AUDIO_SPK_CHANEL_NUM
Definition: audio/audio_conf.h:66
AUDIO_DEFAULT_BITW
#define AUDIO_DEFAULT_BITW
Definition: audio/audio_conf.h:72
AUDIO_FREQ_48K
#define AUDIO_FREQ_48K
Definition: audio/audio_conf.h:60
DMA1_Channel3_IRQn
@ DMA1_Channel3_IRQn
Definition: at32f435_437.h:206
DMA1_Channel4_IRQn
@ DMA1_Channel4_IRQn
Definition: at32f435_437.h:207
i2c_application.h
i2c application libray header file
audio_codec_type
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:150
audio_codec_type::spk_mute
uint8_t spk_mute
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:179
audio_codec_type::spk_threshold
uint16_t spk_threshold
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:161
audio_codec_type::spk_stage
uint8_t spk_stage
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:163
audio_codec_type::mic_roff
uint16_t * mic_roff
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:167
audio_codec_type::spk_buffer
uint16_t spk_buffer[4096]
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:154
audio_codec_type::mic_volume
uint16_t mic_volume
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:181
audio_codec_type::spk_roff
uint16_t * spk_roff
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:155
audio_codec_type::spk_rtotal
uint32_t spk_rtotal
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:160
audio_codec_type::mic_delta
uint32_t mic_delta
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:172
audio_codec_type::spk_calc
uint16_t spk_calc
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:162
audio_codec_type::mic_woff
uint16_t * mic_woff
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:168
audio_codec_type::mic_stage
uint8_t mic_stage
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:176
audio_codec_type::mic_adj_count
uint16_t mic_adj_count
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:174
audio_codec_type::spk_freq
uint32_t spk_freq
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:158
audio_codec_type::audio_bitw
uint32_t audio_bitw
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:152
audio_codec_type::mic_wend
uint16_t * mic_wend
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:169
audio_codec_type::spk_rend
uint16_t * spk_rend
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:157
audio_codec_type::mic_wtotal
uint32_t mic_wtotal
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:170
audio_codec_type::mic_rtotal
uint32_t mic_rtotal
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:171
audio_codec_type::audio_freq
uint32_t audio_freq
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:151
audio_codec_type::mic_mute
uint8_t mic_mute
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:178
audio_codec_type::spk_volume
uint16_t spk_volume
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:182
audio_codec_type::mic_calc
uint16_t mic_calc
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:173
audio_codec_type::spk_wtotal
uint32_t spk_wtotal
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:159
audio_codec_type::mic_adj_stage
uint8_t mic_adj_stage
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:175
audio_codec_type::spk_tx_size
uint32_t spk_tx_size
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:184
audio_codec_type::mic_rx_size
uint32_t mic_rx_size
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:185
audio_codec_type::spk_woff
uint16_t * spk_woff
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:156
audio_codec_type::mic_buffer
uint16_t mic_buffer[1024]
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:166
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
i2c_handle_type
Definition: i2c_application.h:112
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:113
i2s_init_type
i2s init type
Definition: at32f435_437_spi.h:274
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f435_437_spi.h:277
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f435_437_spi.h:278
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f435_437_spi.h:280
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f435_437_spi.h:276
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f435_437_spi.h:275
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:279
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415


AT32F435/437 Firmwary Library: msc_diskio.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_msc
  • inc
Macros | Functions
at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h File Reference

usb mass storage disk interface header file More...

#include "usb_conf.h"
#include "usb_std.h"

Go to the source code of this file.

Macros

#define | INTERNAL_FLASH_LUN 0
#define | SPI_FLASH_LUN 1
#define | SD_LUN 2
#define | USB_FLASH_ADDR_OFFSET 0x08005000
#define | SECTOR_SIZE_1K 1024
#define | SECTOR_SIZE_2K 2048
#define | SECTOR_SIZE_4K 4096

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Detailed Description

usb mass storage disk interface header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h.


AT32F435/437 Firmwary Library: msc_diskio.h Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_msc
  • inc
at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h
Go to the documentation of this file.
1
26/* Define to prevent recursive inclusion -------------------------------------*/
27#ifndef __MSC_DISKIO_H
28#define __MSC_DISKIO_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34
35#include "usb_conf.h"
36#include "usb_std.h"
37
45#define INTERNAL_FLASH_LUN 0
46#define SPI_FLASH_LUN 1
47#define SD_LUN 2
48
49#define USB_FLASH_ADDR_OFFSET 0x08005000
50
51#define SECTOR_SIZE_1K 1024
52#define SECTOR_SIZE_2K 2048
53#define SECTOR_SIZE_4K 4096
54
55uint8_t *get_inquiry(uint8_t lun);
56 usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len);
57 usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len);
58 usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size);
59
68#ifdef __cplusplus
69}
70#endif
71
72#endif
73
74
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:106
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:75
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:144
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:59
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
usb_std.h
usb standard header file
usb_conf.h
usb config header file


AT32F435/437 Firmwary Library: msc_diskio.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_msc
  • src
Functions | Variables
at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c File Reference

usb mass storage disk function More...

#include "msc_diskio.h"
#include "cdc_msc_class.h"

Go to the source code of this file.

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Variables

uint32_t | sector_size = 2048
uint32_t | msc_flash_size
uint8_t | scsi_inquiry [MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]

Detailed Description

usb mass storage disk function

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c.


AT32F435/437 Firmwary Library: msc_diskio.c Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_msc
  • src
at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c
Go to the documentation of this file.
1
26#include "msc_diskio.h"
27#include "cdc_msc_class.h"
28
36uint32_t sector_size = 2048;
37uint32_t msc_flash_size;
38uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH] =
39{
40 /* lun = 0 */
41 {
42 0x00, /* peripheral device type (direct-access device) */
43 0x80, /* removable media bit */
44 0x00, /* ansi version, ecma version, iso version */
45 0x01, /* respond data format */
46 SCSI_INQUIRY_DATA_LENGTH - 5, /* additional length */
47 0x00, 0x00, 0x00, /* reserved */
48 'A', 'T', '3', '2', ' ', ' ', ' ', ' ', /* vendor information "AT32" */
49 'D', 'i', 's', 'k', '0', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', /* Product identification "Disk" */
50 '2', '.', '0', '0' /* product revision level */
51 }
52};
53
59uint8_t *get_inquiry(uint8_t lun)
60{
61 if(lun < MSC_SUPPORT_MAX_LUN)
62 return (uint8_t *)scsi_inquiry[lun];
63 else
64 return NULL;
65}
66
75 usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
76{
77 uint32_t i = 0;
78 uint32_t flash_addr = addr + USB_FLASH_ADDR_OFFSET;
79 switch(lun)
80 {
81 case INTERNAL_FLASH_LUN:
82 for(i = 0; i < len; i ++)
83 {
84 read_buf[i] = *((uint8_t *)flash_addr);
85 flash_addr += 1;
86 }
87 break;
88 case SPI_FLASH_LUN:
89 break;
90 case SD_LUN:
91 break;
92 default:
93 break;
94 }
95 return USB_OK;
96}
97
106 usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
107{
108 uint32_t flash_addr = addr + USB_FLASH_ADDR_OFFSET;
109 uint32_t i = 0, tolen = len;
110 uint32_t erase_addr = flash_addr;
111 switch(lun)
112 {
113 case INTERNAL_FLASH_LUN:
114 flash_unlock();
115 while(tolen >= sector_size)
116 {
117 flash_sector_erase(erase_addr);
118 tolen -= sector_size;
119 erase_addr += sector_size;
120 }
121 for(i = 0; i < len; i ++)
122 {
123 flash_byte_program(flash_addr+i, buf[i]);
124 }
125 flash_lock();
126 break;
127 case SPI_FLASH_LUN:
128 break;
129 case SD_LUN:
130 break;
131 default:
132 break;;
133 }
134 return USB_OK;
135}
136
144 usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
145{
146 uint32_t devid = (*((uint32_t *)DEBUG_BASE) & 0x00007000) >> 12;
147 msc_flash_size = (*((uint32_t *)0x1FFFF7E0) << 10) - (USB_FLASH_ADDR_OFFSET - FLASH_BASE);
148 switch(devid)
149 {
150 case 2:
151 sector_size = SECTOR_SIZE_1K;
152 break;
153 case 3:
154 sector_size = SECTOR_SIZE_2K;
155 break;
156 case 4:
157 sector_size = SECTOR_SIZE_4K;
158 break;
159 default:
160 sector_size = SECTOR_SIZE_2K;
161 break;
162 }
163 switch(lun)
164 {
165 case INTERNAL_FLASH_LUN:
166 *blk_nbr = msc_flash_size / sector_size;
167 *blk_size = sector_size;
168 break;
169 case SPI_FLASH_LUN:
170 break;
171 case SD_LUN:
172 break;
173 default:
174 break;
175 }
176 return USB_OK;
177}
178
cdc_msc_class.h
usb cdc class file
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c:106
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c:75
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c:144
msc_flash_size
uint32_t msc_flash_size
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c:37
sector_size
uint32_t sector_size
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c:36
scsi_inquiry
uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c:38
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c:59
USB_FLASH_ADDR_OFFSET
#define USB_FLASH_ADDR_OFFSET
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h:49
INTERNAL_FLASH_LUN
#define INTERNAL_FLASH_LUN
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h:45
SD_LUN
#define SD_LUN
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h:47
SPI_FLASH_LUN
#define SPI_FLASH_LUN
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h:46
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f435_437_flash.c:357
flash_byte_program
flash_status_type flash_byte_program(uint32_t address, uint8_t data)
program a byte at a specified address.
Definition: at32f435_437_flash.c:679
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f435_437_flash.c:290
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f435_437_flash.c:325
DEBUG_BASE
#define DEBUG_BASE
Definition: at32f435_437.h:427
FLASH_BASE
#define FLASH_BASE
Definition: at32f435_437.h:425
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
SECTOR_SIZE_1K
#define SECTOR_SIZE_1K
Definition: hid_iap_class.h:61
SECTOR_SIZE_2K
#define SECTOR_SIZE_2K
Definition: hid_iap_class.h:62
SECTOR_SIZE_4K
#define SECTOR_SIZE_4K
Definition: hid_iap_class.h:63
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:157
MSC_SUPPORT_MAX_LUN
#define MSC_SUPPORT_MAX_LUN
Definition: cdc_msc_class.h:83
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_OK
@ USB_OK
Definition: usb_std.h:268


AT32F435/437 Firmwary Library: msc_diskio.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • msc
  • inc
Macros | Functions
at_start_f435/examples/usb_device/msc/inc/msc_diskio.h File Reference

usb mass storage disk interface header file More...

#include "usb_conf.h"
#include "usb_std.h"

Go to the source code of this file.

Macros

#define | INTERNAL_FLASH_LUN 0
#define | SPI_FLASH_LUN 1
#define | SD_LUN 2
#define | USB_FLASH_ADDR_OFFSET 0x08005000
#define | SECTOR_SIZE_1K 1024
#define | SECTOR_SIZE_2K 2048
#define | SECTOR_SIZE_4K 4096

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Detailed Description

usb mass storage disk interface header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/usb_device/msc/inc/msc_diskio.h.


AT32F435/437 Firmwary Library: msc_diskio.h Source File

  • at_start_f435
  • examples
  • usb_device
  • msc
  • inc
at_start_f435/examples/usb_device/msc/inc/msc_diskio.h
Go to the documentation of this file.
1
26/* Define to prevent recursive inclusion -------------------------------------*/
27#ifndef __MSC_DISKIO_H
28#define __MSC_DISKIO_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34
35#include "usb_conf.h"
36#include "usb_std.h"
37
45#define INTERNAL_FLASH_LUN 0
46#define SPI_FLASH_LUN 1
47#define SD_LUN 2
48
49#define USB_FLASH_ADDR_OFFSET 0x08005000
50
51#define SECTOR_SIZE_1K 1024
52#define SECTOR_SIZE_2K 2048
53#define SECTOR_SIZE_4K 4096
54
55uint8_t *get_inquiry(uint8_t lun);
56 usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len);
57 usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len);
58 usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size);
59
68#ifdef __cplusplus
69}
70#endif
71
72#endif
73
74
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:106
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:75
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:144
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:59
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
usb_std.h
usb standard header file
usb_conf.h
usb config header file


AT32F435/437 Firmwary Library: msc_diskio.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • msc
  • src
Functions | Variables
at_start_f435/examples/usb_device/msc/src/msc_diskio.c File Reference

usb mass storage disk function More...

#include "msc_diskio.h"
#include "msc_bot_scsi.h"

Go to the source code of this file.

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Variables

uint32_t | sector_size = 2048
uint32_t | msc_flash_size
uint8_t | scsi_inquiry [MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]

Detailed Description

usb mass storage disk function

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/usb_device/msc/src/msc_diskio.c.


AT32F435/437 Firmwary Library: msc_diskio.c Source File

  • at_start_f435
  • examples
  • usb_device
  • msc
  • src
at_start_f435/examples/usb_device/msc/src/msc_diskio.c
Go to the documentation of this file.
1
26#include "msc_diskio.h"
27#include "msc_bot_scsi.h"
28
36uint32_t sector_size = 2048;
37uint32_t msc_flash_size;
38uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH] =
39{
40 /* lun = 0 */
41 {
42 0x00, /* peripheral device type (direct-access device) */
43 0x80, /* removable media bit */
44 0x00, /* ansi version, ecma version, iso version */
45 0x01, /* respond data format */
46 SCSI_INQUIRY_DATA_LENGTH - 5, /* additional length */
47 0x00, 0x00, 0x00, /* reserved */
48 'A', 'T', '3', '2', ' ', ' ', ' ', ' ', /* vendor information "AT32" */
49 'D', 'i', 's', 'k', '0', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', /* Product identification "Disk" */
50 '2', '.', '0', '0' /* product revision level */
51 }
52};
53
59uint8_t *get_inquiry(uint8_t lun)
60{
61 if(lun < MSC_SUPPORT_MAX_LUN)
62 return (uint8_t *)scsi_inquiry[lun];
63 else
64 return NULL;
65}
66
75 usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
76{
77 uint32_t i = 0;
78 uint32_t flash_addr = addr + USB_FLASH_ADDR_OFFSET;
79 switch(lun)
80 {
81 case INTERNAL_FLASH_LUN:
82 for(i = 0; i < len; i ++)
83 {
84 read_buf[i] = *((uint8_t *)flash_addr);
85 flash_addr += 1;
86 }
87 break;
88 case SPI_FLASH_LUN:
89 break;
90 case SD_LUN:
91 break;
92 default:
93 break;
94 }
95 return USB_OK;
96}
97
106 usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
107{
108 uint32_t flash_addr = addr + USB_FLASH_ADDR_OFFSET;
109 uint32_t i = 0, tolen = len;
110 uint32_t erase_addr = flash_addr;
111 switch(lun)
112 {
113 case INTERNAL_FLASH_LUN:
114 flash_unlock();
115 while(tolen >= sector_size)
116 {
117 flash_sector_erase(erase_addr);
118 tolen -= sector_size;
119 erase_addr += sector_size;
120 }
121 for(i = 0; i < len; i ++)
122 {
123 flash_byte_program(flash_addr+i, buf[i]);
124 }
125 flash_lock();
126 break;
127 case SPI_FLASH_LUN:
128 break;
129 case SD_LUN:
130 break;
131 default:
132 break;;
133 }
134 return USB_OK;
135}
136
144 usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
145{
146 uint32_t devid = (*((uint32_t *)DEBUG_BASE) & 0x00007000) >> 12;
147 msc_flash_size = (*((uint32_t *)0x1FFFF7E0) << 10) - (USB_FLASH_ADDR_OFFSET - FLASH_BASE);
148 switch(devid)
149 {
150 case 2:
151 sector_size = SECTOR_SIZE_1K;
152 break;
153 case 3:
154 sector_size = SECTOR_SIZE_2K;
155 break;
156 case 4:
157 sector_size = SECTOR_SIZE_4K;
158 break;
159 default:
160 sector_size = SECTOR_SIZE_2K;
161 break;
162 }
163 switch(lun)
164 {
165 case INTERNAL_FLASH_LUN:
166 *blk_nbr = msc_flash_size / sector_size;
167 *blk_size = sector_size;
168 break;
169 case SPI_FLASH_LUN:
170 break;
171 case SD_LUN:
172 break;
173 default:
174 break;
175 }
176 return USB_OK;
177}
178
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:106
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:75
USB_FLASH_ADDR_OFFSET
#define USB_FLASH_ADDR_OFFSET
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h:49
INTERNAL_FLASH_LUN
#define INTERNAL_FLASH_LUN
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h:45
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:144
msc_flash_size
uint32_t msc_flash_size
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:37
sector_size
uint32_t sector_size
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:36
SD_LUN
#define SD_LUN
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h:47
scsi_inquiry
uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:38
SPI_FLASH_LUN
#define SPI_FLASH_LUN
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h:46
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:59
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f435_437_flash.c:357
flash_byte_program
flash_status_type flash_byte_program(uint32_t address, uint8_t data)
program a byte at a specified address.
Definition: at32f435_437_flash.c:679
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f435_437_flash.c:290
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f435_437_flash.c:325
DEBUG_BASE
#define DEBUG_BASE
Definition: at32f435_437.h:427
FLASH_BASE
#define FLASH_BASE
Definition: at32f435_437.h:425
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
SECTOR_SIZE_1K
#define SECTOR_SIZE_1K
Definition: hid_iap_class.h:61
SECTOR_SIZE_2K
#define SECTOR_SIZE_2K
Definition: hid_iap_class.h:62
SECTOR_SIZE_4K
#define SECTOR_SIZE_4K
Definition: hid_iap_class.h:63
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:157
MSC_SUPPORT_MAX_LUN
#define MSC_SUPPORT_MAX_LUN
Definition: cdc_msc_class.h:83
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_OK
@ USB_OK
Definition: usb_std.h:268
msc_bot_scsi.h
usb mass storage bulk-only transport and scsi command header file


AT32F435/437 Firmwary Library: usbh_user.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
  • src
Functions | Variables
at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c File Reference

usb user function More...

#include "usbh_user.h"

Go to the source code of this file.

Functions

static usb_sts_type | usbh_user_init (void)
usb host init user handler More...
static usb_sts_type | usbh_user_reset (void)
usb host reset user handler More...
static usb_sts_type | usbh_user_attached (void)
usb host check device attached More...
static usb_sts_type | usbh_user_disconnect (void)
usb host discconet user handler More...
static usb_sts_type | usbh_user_speed (uint8_t speed)
usb host speed user handler More...
static usb_sts_type | usbh_user_mfc_string (void *string)
usb host manufacturer string user handler More...
static usb_sts_type | usbh_user_product_string (void *string)
usb host product string user handler More...
static usb_sts_type | usbh_user_serial_string (void *string)
usb host serial string user handler More...
static usb_sts_type | usbh_user_enumeration_done (void)
usb host enumeration done user handler More...
static usb_sts_type | usbh_user_application (void)
usb host application user handler More...
static usb_sts_type | usbh_user_active_vbus (void *uhost, confirm_state state)
usb host active vbus user handler More...
static usb_sts_type | usbh_user_not_support (void)
usb host not support user handler More...

Variables

usbh_user_handler_type usbh_user_handle

Detailed Description

usb user function

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.


AT32F435/437 Firmwary Library: usbh_user.c Source File

  • at_start_f435
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
  • src
at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c
Go to the documentation of this file.
1
26#include "usbh_user.h"
27
36static usb_sts_type usbh_user_init(void);
37static usb_sts_type usbh_user_reset(void);
38static usb_sts_type usbh_user_attached(void);
39static usb_sts_type usbh_user_disconnect(void);
40static usb_sts_type usbh_user_speed(uint8_t speed);
41static usb_sts_type usbh_user_mfc_string(void *string);
42static usb_sts_type usbh_user_product_string(void *string);
43static usb_sts_type usbh_user_serial_string(void *string);
44static usb_sts_type usbh_user_enumeration_done(void);
45static usb_sts_type usbh_user_application(void);
46static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state);
47static usb_sts_type usbh_user_not_support(void);
48
49
50usbh_user_handler_type usbh_user_handle =
51{
52 usbh_user_init,
53 usbh_user_reset,
54 usbh_user_attached,
55 usbh_user_disconnect,
56 usbh_user_speed,
57 usbh_user_mfc_string,
58 usbh_user_product_string,
59 usbh_user_serial_string,
60 usbh_user_enumeration_done,
61 usbh_user_application,
62 usbh_user_active_vbus,
63 usbh_user_not_support,
64};
65
71static usb_sts_type usbh_user_init(void)
72{
73 usb_sts_type status = USB_OK;
74
75 return status;
76}
77
83static usb_sts_type usbh_user_reset(void)
84{
85 usb_sts_type status = USB_OK;
86
87 return status;
88}
89
95static usb_sts_type usbh_user_attached(void)
96{
97 usb_sts_type status = USB_OK;
98 USBH_DEBUG("USB Device Attached");
99 return status;
100}
101
107static usb_sts_type usbh_user_disconnect(void)
108{
109 usb_sts_type status = USB_OK;
110 USBH_DEBUG("Device Disconnect");
111 return status;
112}
113
119static usb_sts_type usbh_user_speed(uint8_t speed)
120{
121 usb_sts_type status = USB_OK;
122 if(speed == USB_PRTSPD_FULL_SPEED)
123 {
124 USBH_DEBUG("This is a Full-Speed device");
125 }
126 else if(speed == USB_PRTSPD_LOW_SPEED)
127 {
128 USBH_DEBUG("This is a Low-Speed device");
129 }
130 return status;
131}
132
138static usb_sts_type usbh_user_mfc_string(void *string)
139{
140 usb_sts_type status = USB_OK;
141 USBH_DEBUG("Manufacturer: %s", (uint8_t *)string);
142 return status;
143}
144
150static usb_sts_type usbh_user_product_string(void *string)
151{
152 usb_sts_type status = USB_OK;
153 USBH_DEBUG("Product: %s", (uint8_t *)string);
154 return status;
155}
156
162static usb_sts_type usbh_user_serial_string(void *string)
163{
164 usb_sts_type status = USB_OK;
165 USBH_DEBUG("Serial: %s", (uint8_t *)string);
166 return status;
167}
168
174static usb_sts_type usbh_user_enumeration_done(void)
175{
176 usb_sts_type status = USB_OK;
177 USBH_DEBUG("Enumeration done");
178 return status;
179}
180
186static usb_sts_type usbh_user_application(void)
187{
188 usb_sts_type status = USB_OK;
189
190
191 return status;
192}
193
202static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state)
203{
204 usb_sts_type status = USB_OK;
205 usbh_core_type *puhost = (usbh_core_type *)uhost;
206#ifdef USBH_5V_POWER_SWITCH
207 if(state == TRUE)
208 {
209 /* active vbus */
210 if(puhost->usb_reg == OTG1_GLOBAL)
211 {
212 gpio_bits_reset(OTG_PIN_POWER_SWITCH_GPIO, OTG_PIN_POWER_SWITCH);
213 }
214
215 }
216 else
217 {
218 /* deactive vubs */
219 if(puhost->usb_reg == OTG1_GLOBAL)
220 {
221 gpio_bits_set(OTG_PIN_POWER_SWITCH_GPIO, OTG_PIN_POWER_SWITCH);
222 }
223 }
224#endif
225 return status;
226}
227
233static usb_sts_type usbh_user_not_support(void)
234{
235 usb_sts_type status = USB_OK;
236
237 return status;
238}
239
usbh_user.h
usb host user header file
usbh_user_init
static usb_sts_type usbh_user_init(void)
usb host init user handler
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:71
OTG_PIN_POWER_SWITCH_GPIO
#define OTG_PIN_POWER_SWITCH_GPIO
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h:91
OTG_PIN_POWER_SWITCH
#define OTG_PIN_POWER_SWITCH
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h:93
usbh_user_disconnect
static usb_sts_type usbh_user_disconnect(void)
usb host discconet user handler
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:107
usbh_user_not_support
static usb_sts_type usbh_user_not_support(void)
usb host not support user handler
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:233
usbh_user_application
static usb_sts_type usbh_user_application(void)
usb host application user handler
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:186
usbh_user_speed
static usb_sts_type usbh_user_speed(uint8_t speed)
usb host speed user handler
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:119
usbh_user_active_vbus
static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state)
usb host active vbus user handler
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:202
usbh_user_handle
usbh_user_handler_type usbh_user_handle
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:50
usbh_user_serial_string
static usb_sts_type usbh_user_serial_string(void *string)
usb host serial string user handler
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:162
usbh_user_reset
static usb_sts_type usbh_user_reset(void)
usb host reset user handler
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:83
usbh_user_mfc_string
static usb_sts_type usbh_user_mfc_string(void *string)
usb host manufacturer string user handler
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:138
usbh_user_enumeration_done
static usb_sts_type usbh_user_enumeration_done(void)
usb host enumeration done user handler
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:174
usbh_user_attached
static usb_sts_type usbh_user_attached(void)
usb host check device attached
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:95
USBH_DEBUG
#define USBH_DEBUG(...)
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h:206
usbh_user_product_string
static usb_sts_type usbh_user_product_string(void *string)
usb host product string user handler
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:150
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
confirm_state
confirm_state
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f435_437_gpio.c:308
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f435_437_gpio.c:277
OTG1_GLOBAL
#define OTG1_GLOBAL
usb host and device register define
Definition: at32f435_437_usb.h:1328
USB_PRTSPD_LOW_SPEED
#define USB_PRTSPD_LOW_SPEED
Definition: at32f435_437_usb.h:188
USB_PRTSPD_FULL_SPEED
#define USB_PRTSPD_FULL_SPEED
Definition: at32f435_437_usb.h:187
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_OK
@ USB_OK
Definition: usb_std.h:268


AT32F435/437 Firmwary Library: usbh_user.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
  • src
Variables
at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.h File Reference

usb host user header file More...

#include "usbh_core.h"

Go to the source code of this file.

Variables

usbh_user_handler_type usbh_user_handle

Detailed Description

usb host user header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.h.


AT32F435/437 Firmwary Library: usbh_user.h Source File

  • at_start_f435
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
  • src
at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.h
Go to the documentation of this file.
1
26/* define to prevent recursive inclusion -------------------------------------*/
27#ifndef __USBH_USER_H
28#define __USBH_USER_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "usbh_core.h"
35
36extern usbh_user_handler_type usbh_user_handle;
37#ifdef __cplusplus
38}
39#endif
40
41#endif
42
43
usbh_user_handle
usbh_user_handler_type usbh_user_handle
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:50
usbh_core.h
usb host core header file


AT32F435/437 Firmwary Library: flash_fat16.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • virtual_msc_iap
  • inc
Data Structures | Macros | Enumerations | Functions | Variables
at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h File Reference

fat16 file system header file More...

#include "usb_conf.h"

Go to the source code of this file.

Data Structures

struct | fat_dir_type
struct | flash_iap_type

Macros

#define | FAT16_SECTOR_SIZE 62
#define | FAT16_TABLE_SIZE 4
#define | FAT16_BYTE_PER_SIZE 2048
#define | FAT16_FILENAME_SIZE 11
#define | FAT16_DIR_SIZE 47
#define | FLASH_FAT16_BOOT_SECTOR_ADDR 0x00
#define | FLASH_FAT16_1_ADDR 0x3000
#define | FLASH_FAT16_2_ADDR 0x3800
#define | FLASH_FAT16_ROOT_ADDR 0x4000
#define | FLASH_FAT16_FILE_START_ADDR 0x8800
#define | FLASH_APP_START_ADDR 0x08006000
#define | FLASH_SECTOR_1K_SIZE 0x400
#define | FLASH_SECTOR_2K_SIZE 0x800
#define | FLASH_SECTOR_4K_SIZE 0x1000
#define | FLASH_SECTOR_1K_ALLGNED 0x3FF
#define | FLASH_SECTOR_2K_ALLGNED 0x7FF
#define | FLASH_SECTOR_4K_ALLGNED 0xFFF
#define | FILE_SUFFIX1_LEN 3
#define | FILE_SUFFIX2_LEN 3
#define | FILE_SUFFIX1_NAME "BIN"
#define | FILE_SUFFIX2_NAME "bin"
#define | INVAILD_OFFSET_ADDR 0xFFFFFFFF
#define | IAP_UPGRADE_COMPLETE_FLAG 0x41544B38
#define | IAP_SUCCESS 0
#define | IAP_FAILED 1

Enumerations

enum upgrade_status_type {
UPGRADE_READY = 0 , UPGRAGE_ONGOING , UPGRADE_SUCCESS , UPGRADE_FAILED ,
UPGRADE_LARGE , UPGRADE_UNKNOWN , UPGRADE_DONE , UPGRADE_JUMP ,
UPGRADE_READY = 0 , UPGRAGE_ONGOING , UPGRADE_SUCCESS , UPGRADE_FAILED ,
UPGRADE_LARGE , UPGRADE_UNKNOWN , UPGRADE_DONE , UPGRADE_JUMP
}

Functions

uint32_t | flash_fat16_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address More...
uint32_t | flash_fat16_read (uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address More...
void | flash_fat16_init (void)
flash fat16 iap init More...
void | flash_fat16_loop_status (void)
loop status More...
uint32_t | flash_fat16_set_name (const uint8_t *file_name, uint8_t len)
set file name More...
uint8_t | flash_fat16_get_upgrade_flag (void)
get iap upgrade complete flag More...

Variables

flash_iap_type flash_iap

Detailed Description

fat16 file system header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.


AT32F435/437 Firmwary Library: flash_fat16.h Source File

  • at_start_f435
  • examples
  • usb_device
  • virtual_msc_iap
  • inc
at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
Go to the documentation of this file.
1
26/* Define to prevent recursive inclusion -------------------------------------*/
27#ifndef __FLASH_FAT16_H
28#define __FLASH_FAT16_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34
35#include "usb_conf.h"
36
48#define FAT16_SECTOR_SIZE 62
49#define FAT16_TABLE_SIZE 4
50#define FAT16_BYTE_PER_SIZE 2048
51#define FAT16_FILENAME_SIZE 11
52#define FAT16_DIR_SIZE 47
53
54#define FLASH_FAT16_BOOT_SECTOR_ADDR 0x00
55#define FLASH_FAT16_1_ADDR 0x3000
56#define FLASH_FAT16_2_ADDR 0x3800
57#define FLASH_FAT16_ROOT_ADDR 0x4000
58#define FLASH_FAT16_FILE_START_ADDR 0x8800
59
60#define FLASH_APP_START_ADDR 0x08006000
61
62#define FLASH_SECTOR_1K_SIZE 0x400
63#define FLASH_SECTOR_2K_SIZE 0x800
64#define FLASH_SECTOR_4K_SIZE 0x1000
65
66#define FLASH_SECTOR_1K_ALLGNED 0x3FF
67#define FLASH_SECTOR_2K_ALLGNED 0x7FF
68#define FLASH_SECTOR_4K_ALLGNED 0xFFF
69
70#define FILE_SUFFIX1_LEN 3
71#define FILE_SUFFIX2_LEN 3
72#define FILE_SUFFIX1_NAME "BIN"
73#define FILE_SUFFIX2_NAME "bin"
74
75#define INVAILD_OFFSET_ADDR 0xFFFFFFFF
76#define IAP_UPGRADE_COMPLETE_FLAG 0x41544B38
77#define IAP_SUCCESS 0
78#define IAP_FAILED 1
79
80typedef enum
81{
82 UPGRADE_READY = 0,
83 UPGRAGE_ONGOING,
84 UPGRADE_SUCCESS,
85 UPGRADE_FAILED,
86 UPGRADE_LARGE,
87 UPGRADE_UNKNOWN,
88 UPGRADE_DONE,
89 UPGRADE_JUMP
90}upgrade_status_type;
91
92typedef struct
93{
94 uint8_t file_name[11];
95 uint8_t attr;
96 uint8_t res;
97 uint8_t create_time_tenth;
98 uint16_t create_time;
99 uint16_t create_data;
100 uint16_t last_access_data;
101 uint16_t clus_high;
102 uint16_t write_time;
103 uint16_t write_data;
104 uint16_t clus_low;
105 uint32_t file_size;
106}fat_dir_type;
107
108typedef struct
109{
110 uint32_t flash_base_addr;
111 uint32_t flash_app_addr;
112 uint32_t flash_size;
113 uint32_t flash_app_size;
114 uint32_t sector_size;
115 uint32_t sector_mask;
116 uint32_t firmware_length;
117 uint32_t write_crc;
118 uint32_t read_crc;
119
120 uint32_t write_addr;
121 uint32_t file_write_nr;
122 upgrade_status_type msc_up_status;
123}flash_iap_type;
124
125
126extern flash_iap_type flash_iap;
127
128uint32_t flash_fat16_write(uint32_t fat_lbk, uint8_t *data, uint32_t len);
129uint32_t flash_fat16_read(uint32_t fat_lbk, uint8_t *data, uint32_t len);
130
131void flash_fat16_init(void);
132void flash_fat16_loop_status(void);
133uint32_t flash_fat16_set_name(const uint8_t *file_name, uint8_t len);
134uint8_t flash_fat16_get_upgrade_flag(void);
135
148#ifdef __cplusplus
149}
150#endif
151
152#endif
153
154
upgrade_status_type
upgrade_status_type
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:81
flash_fat16_set_name
uint32_t flash_fat16_set_name(const uint8_t *file_name, uint8_t len)
set file name
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:360
flash_fat16_get_upgrade_flag
uint8_t flash_fat16_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:270
flash_fat16_loop_status
void flash_fat16_loop_status(void)
loop status
Definition: project/at_start_f437/examples/usb_device/virtual_msc_iap/src/main.c:294
flash_iap
flash_iap_type flash_iap
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:173
flash_fat16_write
uint32_t flash_fat16_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:332
flash_fat16_init
void flash_fat16_init(void)
flash fat16 iap init
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:712
flash_fat16_read
uint32_t flash_fat16_read(uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:291
UPGRADE_LARGE
@ UPGRADE_LARGE
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:86
UPGRADE_UNKNOWN
@ UPGRADE_UNKNOWN
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:87
UPGRADE_JUMP
@ UPGRADE_JUMP
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:89
UPGRADE_FAILED
@ UPGRADE_FAILED
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:85
UPGRADE_SUCCESS
@ UPGRADE_SUCCESS
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:84
UPGRADE_READY
@ UPGRADE_READY
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:82
UPGRAGE_ONGOING
@ UPGRAGE_ONGOING
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:83
UPGRADE_DONE
@ UPGRADE_DONE
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:88
fat_dir_type
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:93
fat_dir_type::clus_low
uint16_t clus_low
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:104
fat_dir_type::write_data
uint16_t write_data
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:103
fat_dir_type::file_size
uint32_t file_size
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:105
fat_dir_type::last_access_data
uint16_t last_access_data
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:100
fat_dir_type::write_time
uint16_t write_time
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:102
fat_dir_type::create_time
uint16_t create_time
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:98
fat_dir_type::create_time_tenth
uint8_t create_time_tenth
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:97
fat_dir_type::create_data
uint16_t create_data
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:99
fat_dir_type::clus_high
uint16_t clus_high
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:101
fat_dir_type::res
uint8_t res
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:96
fat_dir_type::attr
uint8_t attr
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:95
flash_iap_type
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:109
flash_iap_type::flash_size
uint32_t flash_size
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:112
flash_iap_type::read_crc
uint32_t read_crc
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:118
flash_iap_type::msc_up_status
upgrade_status_type msc_up_status
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:122
flash_iap_type::flash_base_addr
uint32_t flash_base_addr
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:110
flash_iap_type::write_crc
uint32_t write_crc
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:117
flash_iap_type::sector_size
uint32_t sector_size
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:114
flash_iap_type::firmware_length
uint32_t firmware_length
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:116
flash_iap_type::sector_mask
uint32_t sector_mask
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:115
flash_iap_type::file_write_nr
uint32_t file_write_nr
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:121
flash_iap_type::flash_app_size
uint32_t flash_app_size
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:113
flash_iap_type::write_addr
uint32_t write_addr
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:120
flash_iap_type::flash_app_addr
uint32_t flash_app_addr
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:111
usb_conf.h
usb config header file


AT32F435/437 Firmwary Library: msc_diskio.h File Reference

  • at_start_f435
  • examples
  • usb_device
  • virtual_msc_iap
  • inc
Macros | Functions
at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h File Reference

usb mass storage disk interface header file More...

#include "usb_conf.h"
#include "usb_std.h"

Go to the source code of this file.

Macros

#define | INTERNAL_FLASH_LUN 0
#define | SPI_FLASH_LUN 1
#define | SD_LUN 2
#define | USB_FLASH_ADDR_OFFSET 0x08004000

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Detailed Description

usb mass storage disk interface header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h.


AT32F435/437 Firmwary Library: msc_diskio.h Source File

  • at_start_f435
  • examples
  • usb_device
  • virtual_msc_iap
  • inc
at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h
Go to the documentation of this file.
1
26/* Define to prevent recursive inclusion -------------------------------------*/
27#ifndef __MSC_DISKIO_H
28#define __MSC_DISKIO_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34
35#include "usb_conf.h"
36#include "usb_std.h"
37
45#define INTERNAL_FLASH_LUN 0
46#define SPI_FLASH_LUN 1
47#define SD_LUN 2
48
49#define USB_FLASH_ADDR_OFFSET 0x08004000
50
51uint8_t *get_inquiry(uint8_t lun);
52 usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len);
53 usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len);
54 usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size);
55
64#ifdef __cplusplus
65}
66#endif
67
68#endif
69
70
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/msc_diskio.c:97
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/msc_diskio.c:75
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/msc_diskio.c:117
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/msc_diskio.c:59
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
usb_std.h
usb standard header file
usb_conf.h
usb config header file


AT32F435/437 Firmwary Library: flash_fat16.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • virtual_msc_iap
  • src
Macros | Functions | Variables
at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c File Reference

fat16 file system More...

#include "flash_fat16.h"
#include "usb_conf.h"

Go to the source code of this file.

Macros

#define FAT16_SECTOR_SIZE 62

Functions

uint32_t | flash_fat16_boot_dir_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
boot dir write More...
uint32_t | flash_fat16_sector_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
write sector More...
uint32_t | fat16_memory_copy (uint8_t *dst, const uint8_t *src, uint32_t len)
memory copy function More...
uint32_t | fat16_memory_memset (uint8_t *dst, uint32_t set, uint32_t len)
memset function More...
uint32_t | flash_write_data (uint32_t address, uint8_t *data, uint32_t len)
write data to flash More...
uint32_t | flash_read_data (uint32_t address, uint8_t *data, uint32_t len)
read data from flash More...
uint32_t | fat16_memory_cmp (uint8_t *dst, uint8_t *src, uint32_t len)
memory compare function More...
uint32_t | flash_crc_check (uint32_t address, uint8_t *data, uint32_t len)
crc check More...
void | flash_fat16_clear_upgrade_flag (void)
clear iap upgrade flag More...
void | flash_fat16_set_upgrade_flag (void)
set iap upgrade complete flag More...
uint8_t | flash_fat16_get_upgrade_flag (void)
get iap upgrade complete flag More...
uint32_t | flash_fat16_read (uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address More...
uint32_t | flash_fat16_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address More...
uint32_t | flash_fat16_set_name (const uint8_t *file_name, uint8_t len)
set file name More...
uint32_t | flash_fat16_addr_offset (uint8_t *file_name)
get offset address More...
void | flash_fat16_init (void)
flash fat16 iap init More...

Variables

static uint8_t | fat16_sector [62]
const uint8_t | fat16_root_dir_sector [FAT16_DIR_SIZE]
const uint8_t | fat16_table_sector0 [FAT16_TABLE_SIZE]
uint8_t | fat16_file_name [FAT16_FILENAME_SIZE]
fat_dir_type g_file_attr
flash_iap_type flash_iap
uint32_t | file_write_nr = 0
uint8_t | file_match = 0

Detailed Description

fat16 file system

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.


AT32F435/437 Firmwary Library: flash_fat16.c Source File

  • at_start_f435
  • examples
  • usb_device
  • virtual_msc_iap
  • src
at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
Go to the documentation of this file.
1
26#include "flash_fat16.h"
27#include "usb_conf.h"
28
36#define FAT16_SECTOR_SIZE 62
37static uint8_t fat16_sector[FAT16_SECTOR_SIZE] =
38{
39 0xEB, /*0*/
40 0x3C, /*1*/
41 0x90, /*2*/
42 0x4D, /*3*/
43 0x53, /*4*/
44 0x44, /*5*/
45 0x4F, /*6*/
46 0x53, /*7*/
47 0x35, /*8*/
48 0x2E, /*9*/
49 0x30, /*10*/
50 0x00, /*11*/
51 0x08, /*12*/ //2K
52 0x04, /*13*/
53 0x06, /*14*/
54 0x00, /*15*/
55
56 0x02, /*16*/
57 0x00, /*17*/
58 0x02, /*18*/
59 0xFF, /*19*/
60 0x0F, /*20*/
61 0xF8, /*21*/
62 0x01, /*22*/
63 0x00, /*23*/
64 0x01, /*24*/
65 0x00, /*25*/
66 0x01, /*26*/
67 0x00, /*27*/
68 0x00, /*28*/
69 0x00, /*29*/
70 0x00, /*30*/
71 0x00, /*31*/
72
73 0x00, /*32*/
74 0x00, /*33*/
75 0x00, /*34*/
76 0x00, /*35*/
77 0x00, /*36*/
78 0x00, /*37*/
79 0x29, /*38*/
80 0x96, /*39*/
81 0x16, /*40*/
82 0x66, /*41*/
83 0xD3, /*42*/
84 0x20, /*43*/
85 0x20, /*44*/
86 0x20, /*45*/
87 0x20, /*46*/
88 0x20, /*47*/
89
90 0x20, /*48*/
91 0x20, /*49*/
92 0x20, /*50*/
93 0x20, /*51*/
94 0x20, /*52*/
95 0x20, /*53*/
96 0x46, /*54*/
97 0x41, /*55*/
98 0x54, /*56*/
99 0x31, /*57*/
100 0x36, /*58*/
101 0x20, /*59*/
102 0x20, /*60*/
103 0x20 /*61*/
104};
105
106
107
108const uint8_t fat16_root_dir_sector[FAT16_DIR_SIZE]=
109{
110 0x20, /*11 - Archive Attribute set */
111 0x00, /*12 - Reserved */
112 0x4B, /*13 - Create Time Tenth */
113 0x9C, /*14 - Create Time */
114 0x42, /*15 - Create Time */
115 0x92, /*16 - Create Date */
116 0x38, /*17 - Create Date */
117 0x92, /*18 - Last Access Date */
118 0x38, /*19 - Last Access Date */
119 0x00, /*20 - Not used in FAT16 */
120 0x00, /*21 - Not used in FAT16 */
121 0x9D, /*22 - Write Time */
122 0x42, /*23 - Write Time */
123 0x92, /*24 - Write Date */
124 0x38, /*25 - Write Date */
125 0x00, /*26 - First Cluster (none, because file is empty) */
126 0x00, /*27 - First Cluster (none, because file is empty) */
127 0x00, /*28 - File Size */
128 0x00, /*29 - File Size */
129 0x00, /*30 - File Size */
130 0x00, /*31 - File Size */
131 'A','T','3','2',' ','I','A','P',' ',' ',' ', /*32-42 - Volume label */
132 0x08, /*43 - File attribute = Volume label */
133 0x00, /*44 - Reserved */
134 0x00, /*45 - Create Time Tenth */
135 0x00, /*46 - Create Time */
136 0x00, /*47 - Create Time */
137 0x00, /*48 - Create Date */
138 0x00, /*49 - Create Date */
139 0x00, /*50 - Last Access Date */
140 0x00, /*51 - Last Access Date */
141 0x00, /*52 - Not used in FAT16 */
142 0x00, /*53 - Not used in FAT16 */
143 0x9D, /*54 - Write Time */
144 0x42, /*55 - Write Time */
145 0x92, /*56 - Write Date */
146 0x38, /*57 - Write Date */
147};
148
149const uint8_t fat16_table_sector0[FAT16_TABLE_SIZE] =
150{
151 0xF8,
152 0xFF,
153 0xFF,
154 0xFF
155};
156
157uint8_t fat16_file_name[FAT16_FILENAME_SIZE] =
158{
159 'R',
160 'e',
161 'a',
162 'd',
163 'y',
164 ' ',
165 ' ',
166 ' ',
167 'T',
168 'X',
169 'T'
170};
171
172 fat_dir_type g_file_attr;
173 flash_iap_type flash_iap;
174uint32_t file_write_nr = 0;
175uint8_t file_match = 0;
176
177uint32_t flash_fat16_boot_dir_write(uint32_t fat_lbk, uint8_t *data, uint32_t len);
178uint32_t flash_fat16_sector_write(uint32_t fat_lbk, uint8_t *data, uint32_t len);
179uint32_t fat16_memory_copy(uint8_t *dst, const uint8_t *src, uint32_t len);
180uint32_t fat16_memory_memset(uint8_t *dst, uint32_t set, uint32_t len);
181uint32_t flash_write_data(uint32_t address, uint8_t *data, uint32_t len);
182uint32_t flash_read_data(uint32_t address, uint8_t *data, uint32_t len);
183uint32_t fat16_memory_cmp(uint8_t *dst, uint8_t *src, uint32_t len);
184uint32_t flash_crc_check(uint32_t address, uint8_t *data, uint32_t len);
185void flash_fat16_clear_upgrade_flag(void);
186void flash_fat16_set_upgrade_flag(void);
187
195uint32_t fat16_memory_copy(uint8_t *dst, const uint8_t *src, uint32_t len)
196{
197 uint32_t i_index;
198 for(i_index = 0; i_index < len; i_index ++)
199 {
200 dst[i_index] = src[i_index];
201 }
202 return i_index;
203}
204
212uint32_t fat16_memory_memset(uint8_t *dst, uint32_t set, uint32_t len)
213{
214 uint32_t i_index;
215 for(i_index = 0; i_index < len; i_index ++)
216 {
217 dst[i_index] = (uint8_t)set;
218 }
219 return i_index;
220}
221
229uint32_t fat16_memory_cmp(uint8_t *dst, uint8_t *src, uint32_t len)
230{
231 uint32_t i_index;
232 for(i_index = 0; i_index < len; i_index ++)
233 {
234 if(dst[i_index] != src[i_index])
235 return 1;
236 }
237 return 0;
238}
239
245void flash_fat16_clear_upgrade_flag(void)
246{
247 flash_unlock();
248 flash_sector_erase(flash_iap.flash_app_addr - flash_iap.sector_size);
249 flash_lock();
250}
251
257void flash_fat16_set_upgrade_flag(void)
258{
259 flash_unlock();
260 flash_word_program(flash_iap.flash_app_addr - flash_iap.sector_size,
261 IAP_UPGRADE_COMPLETE_FLAG);
262 flash_lock();
263}
264
270uint8_t flash_fat16_get_upgrade_flag(void)
271{
272 uint32_t flag_address = flash_iap.flash_app_addr - flash_iap.sector_size;
273 if(*((uint32_t *)flag_address) == IAP_UPGRADE_COMPLETE_FLAG)
274 {
275 return IAP_SUCCESS;
276 }
277 else
278 {
279 return IAP_FAILED;
280 }
281}
282
283
291uint32_t flash_fat16_read(uint32_t fat_lbk, uint8_t *data, uint32_t len)
292{
293 uint32_t i_index = 0;
294 switch(fat_lbk)
295 {
296 case FLASH_FAT16_BOOT_SECTOR_ADDR:
297 i_index += fat16_memory_copy(data, fat16_sector, FAT16_SECTOR_SIZE);
298 i_index += 2;
299
300 fat16_memory_memset(data+i_index, 0, FAT16_BYTE_PER_SIZE-i_index);
301 data[510] = 0x55;
302 data[511] = 0xAA;
303
304 break;
305 case FLASH_FAT16_1_ADDR:
306 case FLASH_FAT16_2_ADDR:
307 i_index += fat16_memory_copy(data, fat16_table_sector0, FAT16_TABLE_SIZE);
308
309 fat16_memory_memset(data+i_index, 0, FAT16_BYTE_PER_SIZE-i_index);
310 break;
311 case FLASH_FAT16_ROOT_ADDR:
312 i_index += fat16_memory_copy(data, fat16_file_name, FAT16_FILENAME_SIZE);
313 i_index += fat16_memory_copy(data + i_index, fat16_root_dir_sector, FAT16_DIR_SIZE);
314
315 fat16_memory_memset(data+i_index, 0, FAT16_BYTE_PER_SIZE-i_index);
316 break;
317 default:
318 i_index = 0;
319 fat16_memory_memset(data+i_index, 0, FAT16_BYTE_PER_SIZE-i_index);
320 break;
321 }
322 return FAT16_BYTE_PER_SIZE;
323}
324
332uint32_t flash_fat16_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
333{
334 switch(fat_lbk)
335 {
336 case FLASH_FAT16_BOOT_SECTOR_ADDR:
337 case FLASH_FAT16_1_ADDR:
338 case FLASH_FAT16_2_ADDR:
339 break;
340 case FLASH_FAT16_ROOT_ADDR:
341 flash_fat16_boot_dir_write(fat_lbk, data, len);
342 break;
343 default:
344 if(fat_lbk >= FLASH_FAT16_FILE_START_ADDR)
345 {
346 flash_fat16_sector_write(fat_lbk, data, len);
347 }
348 break;
349
350 }
351 return len;
352}
353
360uint32_t flash_fat16_set_name(const uint8_t *file_name, uint8_t len)
361{
362 uint8_t i_index = 0;
363 for(i_index = 0; i_index < len && i_index < 8; i_index ++)
364 {
365 fat16_file_name[i_index] = file_name[i_index];
366 }
367
368 for(; i_index < 8; i_index ++)
369 {
370 fat16_file_name[i_index] = ' ';
371 }
372 return i_index;
373}
374
382uint32_t flash_fat16_boot_dir_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
383{
384 fat_dir_type *pdir = (fat_dir_type *)data;
385 uint32_t i_index = 2, loop_len = 0;
386
387 pdir ++;
388 pdir ++;
389 loop_len += 64;
390
391 while(i_index ++ < 512 && loop_len < len)
392 {
393 if((pdir->attr == 0x20) && ((pdir + 1)->attr == 0x00))
394 {
395 break;
396 }
397 else
398 {
399 pdir ++;
400 }
401 loop_len += 32;
402 }
403
404 if(i_index <= 512 && loop_len < len)
405 {
406 fat16_memory_copy((uint8_t *)&g_file_attr, (const uint8_t *)pdir, 32);
407
408 if(file_match == 1)
409 {
410 file_match = 0;
411 if(g_file_attr.file_size > 0)
412 {
413 if(flash_iap.file_write_nr >= g_file_attr.file_size)
414 {
415 /* upgrade finish */
416 flash_iap.file_write_nr = 0;
417 flash_iap.msc_up_status = UPGRADE_SUCCESS;
418
419 /* set the upgrade done flag to flash */
420 flash_fat16_set_upgrade_flag();
421 }
422 }
423 }
424 g_file_attr.write_data = 0;
425 g_file_attr.write_time = 0;
426 flash_iap.file_write_nr = 0;
427 }
428 else
429 {
430 fat16_memory_memset((uint8_t *)&g_file_attr, 0, 32);
431 }
432 return len;
433}
434
440uint32_t flash_fat16_addr_offset(uint8_t *file_name)
441{
442 uint8_t i_index = 0, offset_shift = 20;
443 uint32_t offset = 0;
444 uint8_t *pfile = file_name;
445
446 if(*pfile != 'A')
447 {
448 return INVAILD_OFFSET_ADDR;
449 }
450 pfile += 1;
451
452 for(i_index = 0; i_index < 6; i_index ++)
453 {
454 if(*pfile >= '0' && *pfile <= '9')
455 {
456 offset |= (*pfile - '0') << offset_shift;
457 }
458 else if(*pfile >= 'A' && *pfile <= 'F')
459 {
460 offset |= (*pfile - 'A' + 0xA) << offset_shift;
461 }
462 else if(*pfile >= 'a' && *pfile <= 'f')
463 {
464 offset |= (*pfile - 'a' + 0xA) << offset_shift;
465 }
466 else
467 {
468 return INVAILD_OFFSET_ADDR;
469 }
470 pfile ++;
471 offset_shift -= 4;
472 }
473
474 if((offset < (flash_iap.flash_app_addr - flash_iap.flash_base_addr)) ||
475 (offset > flash_iap.flash_size ))
476 {
477 return INVAILD_OFFSET_ADDR;
478 }
479 return offset;
480}
481
489uint32_t flash_fat16_sector_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
490{
491 uint32_t file_size = g_file_attr.file_size;
492 uint32_t flash_offset = 0;
493 uint32_t status;
494
495 /* check the suffix is .bin or .BIN*/
496 if((fat16_memory_cmp((uint8_t *)&g_file_attr.file_name[8],
497 (uint8_t *)FILE_SUFFIX1_NAME, FILE_SUFFIX1_LEN) == 0) ||
498 (fat16_memory_cmp((uint8_t *)&g_file_attr.file_name[8],
499 (uint8_t *)FILE_SUFFIX2_NAME, FILE_SUFFIX2_LEN) == 0))
500 {
501 /* check the upgrade status */
502 if(flash_iap.msc_up_status == UPGRADE_DONE || flash_iap.msc_up_status == UPGRADE_SUCCESS)
503 {
504 return 0;
505 }
506
507 if(g_file_attr.file_size == 0)
508 {
509 g_file_attr.file_size = flash_iap.flash_app_size;
510 file_match = 1;
511 }
512
513 file_size = g_file_attr.file_size;
514
515 if(flash_iap.msc_up_status == UPGRADE_READY)
516 {
517 /* get offset address from filename */
518 flash_offset = flash_fat16_addr_offset(g_file_attr.file_name);
519
520 if(flash_offset == INVAILD_OFFSET_ADDR)
521 {
522 /* use default app address */
523 flash_iap.write_addr = FLASH_APP_START_ADDR;
524 }
525 else
526 {
527 flash_iap.write_addr = flash_offset + flash_iap.flash_base_addr;
528 }
529 /* clear upgrade flag */
530 flash_fat16_clear_upgrade_flag();
531
532 flash_iap.msc_up_status = UPGRAGE_ONGOING;
533 }
534
535 if(flash_iap.flash_app_size >= g_file_attr.file_size)
536 {
537 if((flash_iap.file_write_nr + len) >= file_size)
538 {
539 len = file_size - flash_iap.file_write_nr;
540 }
541 /* write data to flash and check crc */
542 status = flash_write_data(flash_iap.write_addr + flash_iap.file_write_nr, data, len);
543
544 flash_iap.file_write_nr += len;
545
546 if(status == 0)
547 {
548 if(flash_iap.file_write_nr >= file_size)
549 {
550 /* upgrade finish */
551 flash_iap.file_write_nr = 0;
552 flash_iap.msc_up_status = UPGRADE_SUCCESS;
553
554 /* set the upgrade done flag to flash */
555 flash_fat16_set_upgrade_flag();
556 }
557 }
558 else
559 {
560 /* upgrade error */
561 flash_iap.file_write_nr = 0;
562 flash_iap.msc_up_status = UPGRADE_FAILED;
563 }
564 }
565 else
566 {
567 /* upgrade file is large than flash size */
568 flash_iap.msc_up_status = UPGRADE_LARGE;
569 }
570
571 }
572 else if((fat16_memory_cmp((uint8_t *)&g_file_attr.file_name[0],
573 (uint8_t *)"JUMP", 4) == 0))
574 {
575 /* receive jump command file */
576 flash_iap.msc_up_status = UPGRADE_JUMP;
577 }
578 else
579 {
580 /* unkonw upgrade status */
581 }
582
583 return len;
584}
585
593uint32_t flash_crc_check(uint32_t address, uint8_t *data, uint32_t len)
594{
595 uint32_t flash_crc = 0;
596 uint32_t data_crc = 0;
597 uint32_t i_index = 0;
598 uint32_t wlen = len / sizeof(uint32_t);
599 uint32_t remain_len = len % sizeof(uint32_t);
600 uint32_t *u32data = (uint32_t *)data;
601 uint32_t *flash_addr = (uint32_t *)address;
602
603 /* enable crc clock */
604 crm_periph_clock_enable(CRM_CRC_PERIPH_CLOCK, TRUE);
605
606 if(remain_len)
607 {
608 wlen += 1;
609 for(i_index = 0; i_index < (4 - remain_len); i_index ++)
610 {
611 data[len+i_index] = 0xFF;
612 }
613 }
614
615 /* calculate write buffer */
616 crc_data_reset();
617 for(i_index = 0; i_index < wlen; i_index ++)
618 {
619 data_crc = crc_one_word_calculate(u32data[i_index]);
620 }
621
622 /* calculate flash data */
623 crc_data_reset();
624 for(i_index = 0; i_index < wlen; i_index ++)
625 {
626 flash_crc = crc_one_word_calculate(*flash_addr++);
627 }
628 crm_periph_clock_enable(CRM_CRC_PERIPH_CLOCK, FALSE);
629
630 if(data_crc != flash_crc)
631 return 1;
632
633 return 0;
634
635}
636
644uint32_t flash_read_data(uint32_t address, uint8_t *data, uint32_t len)
645{
646 uint32_t i_index;
647 for(i_index = 0; i_index < len; i_index ++)
648 {
649 data[i_index] = *(uint8_t *)address;
650 address += 1;
651 }
652 return i_index;
653}
654
655
663uint32_t flash_write_data(uint32_t address, uint8_t *data, uint32_t len)
664{
665 uint32_t waddr = address;
666 uint32_t wlength = len;
667 uint32_t i_index = 0;
668 if((address + len) > flash_iap.flash_base_addr + flash_iap.flash_size)
669 {
670 return 1;
671 }
672
673 if((waddr & flash_iap.sector_mask) == 0)
674 {
675 flash_unlock();
676 if(len > flash_iap.sector_size)
677 {
678 for(; wlength >= flash_iap.sector_size; wlength -= flash_iap.sector_size)
679 {
680 flash_sector_erase(waddr);
681 waddr += flash_iap.sector_size;
682 }
683 if(wlength > 0)
684 {
685 flash_sector_erase(waddr);
686 }
687 }
688 else
689 {
690 flash_sector_erase(waddr);
691 }
692
693 flash_lock();
694 }
695
696 waddr = address;
697 flash_unlock();
698 for(i_index = 0; i_index < len; i_index ++)
699 {
700 flash_byte_program(waddr+i_index, data[i_index]);
701 }
702 flash_lock();
703
704 return flash_crc_check(address, data, len);
705}
706
712void flash_fat16_init(void)
713{
714 uint32_t flash_size = *(uint32_t *)0x1FFFF7E0;
715 uint32_t devid = (*((uint32_t *)DEBUG_BASE) & 0x00007000) >> 12;
716
717 switch(devid)
718 {
719 case 2:
720 flash_iap.sector_size = FLASH_SECTOR_1K_SIZE;
721 flash_iap.sector_mask = FLASH_SECTOR_1K_ALLGNED;
722 break;
723 case 3:
724 flash_iap.sector_size = FLASH_SECTOR_2K_SIZE;
725 flash_iap.sector_mask = FLASH_SECTOR_2K_ALLGNED;
726 break;
727 case 4:
728 flash_iap.sector_size = FLASH_SECTOR_4K_SIZE;
729 flash_iap.sector_mask = FLASH_SECTOR_4K_ALLGNED;
730 break;
731 default:
732 flash_iap.sector_size = FLASH_SECTOR_2K_SIZE;
733 flash_iap.sector_mask = FLASH_SECTOR_2K_ALLGNED;
734 break;
735 }
736
737 flash_iap.flash_base_addr = FLASH_BASE;
738 flash_iap.flash_app_addr = FLASH_APP_START_ADDR;
739 flash_iap.write_addr = FLASH_APP_START_ADDR;
740 flash_iap.flash_size = flash_size << 10;
741
742 flash_iap.flash_app_size = flash_iap.flash_size -
743 (flash_iap.flash_app_addr -
744 flash_iap.flash_base_addr);
745}
746
747
748
flash_fat16_set_name
uint32_t flash_fat16_set_name(const uint8_t *file_name, uint8_t len)
set file name
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:360
FAT16_SECTOR_SIZE
#define FAT16_SECTOR_SIZE
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:36
g_file_attr
fat_dir_type g_file_attr
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:172
fat16_sector
static uint8_t fat16_sector[62]
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:37
flash_read_data
uint32_t flash_read_data(uint32_t address, uint8_t *data, uint32_t len)
read data from flash
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:644
file_match
uint8_t file_match
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:175
fat16_root_dir_sector
const uint8_t fat16_root_dir_sector[FAT16_DIR_SIZE]
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:108
file_write_nr
uint32_t file_write_nr
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:174
flash_fat16_addr_offset
uint32_t flash_fat16_addr_offset(uint8_t *file_name)
get offset address
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:440
fat16_table_sector0
const uint8_t fat16_table_sector0[FAT16_TABLE_SIZE]
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:149
flash_fat16_clear_upgrade_flag
void flash_fat16_clear_upgrade_flag(void)
clear iap upgrade flag
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:245
flash_fat16_get_upgrade_flag
uint8_t flash_fat16_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:270
fat16_memory_memset
uint32_t fat16_memory_memset(uint8_t *dst, uint32_t set, uint32_t len)
memset function
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:212
flash_iap
flash_iap_type flash_iap
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:173
flash_crc_check
uint32_t flash_crc_check(uint32_t address, uint8_t *data, uint32_t len)
crc check
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:593
flash_fat16_write
uint32_t flash_fat16_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:332
fat16_memory_cmp
uint32_t fat16_memory_cmp(uint8_t *dst, uint8_t *src, uint32_t len)
memory compare function
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:229
flash_fat16_sector_write
uint32_t flash_fat16_sector_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
write sector
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:489
flash_fat16_set_upgrade_flag
void flash_fat16_set_upgrade_flag(void)
set iap upgrade complete flag
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:257
flash_write_data
uint32_t flash_write_data(uint32_t address, uint8_t *data, uint32_t len)
write data to flash
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:663
fat16_memory_copy
uint32_t fat16_memory_copy(uint8_t *dst, const uint8_t *src, uint32_t len)
memory copy function
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:195
flash_fat16_init
void flash_fat16_init(void)
flash fat16 iap init
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:712
flash_fat16_boot_dir_write
uint32_t flash_fat16_boot_dir_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
boot dir write
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:382
flash_fat16_read
uint32_t flash_fat16_read(uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:291
fat16_file_name
uint8_t fat16_file_name[FAT16_FILENAME_SIZE]
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:157
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
crc_data_reset
void crc_data_reset(void)
reset the crc data register.
Definition: at32f435_437_crc.c:49
crc_one_word_calculate
uint32_t crc_one_word_calculate(uint32_t data)
compute the 32-bit crc of a given data word(32-bit).
Definition: at32f435_437_crc.c:60
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_CRC_PERIPH_CLOCK
@ CRM_CRC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:113
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f435_437_flash.c:357
flash_byte_program
flash_status_type flash_byte_program(uint32_t address, uint8_t data)
program a byte at a specified address.
Definition: at32f435_437_flash.c:679
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f435_437_flash.c:290
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f435_437_flash.c:608
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f435_437_flash.c:325
DEBUG_BASE
#define DEBUG_BASE
Definition: at32f435_437.h:427
FLASH_BASE
#define FLASH_BASE
Definition: at32f435_437.h:425
FLASH_APP_START_ADDR
#define FLASH_APP_START_ADDR
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:60
FLASH_SECTOR_1K_ALLGNED
#define FLASH_SECTOR_1K_ALLGNED
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:66
FAT16_TABLE_SIZE
#define FAT16_TABLE_SIZE
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:49
INVAILD_OFFSET_ADDR
#define INVAILD_OFFSET_ADDR
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:75
FLASH_FAT16_2_ADDR
#define FLASH_FAT16_2_ADDR
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:56
FLASH_FAT16_1_ADDR
#define FLASH_FAT16_1_ADDR
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:55
FLASH_FAT16_ROOT_ADDR
#define FLASH_FAT16_ROOT_ADDR
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:57
FAT16_DIR_SIZE
#define FAT16_DIR_SIZE
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:52
FLASH_SECTOR_2K_SIZE
#define FLASH_SECTOR_2K_SIZE
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:63
FILE_SUFFIX1_NAME
#define FILE_SUFFIX1_NAME
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:72
FLASH_SECTOR_4K_ALLGNED
#define FLASH_SECTOR_4K_ALLGNED
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:68
FLASH_FAT16_FILE_START_ADDR
#define FLASH_FAT16_FILE_START_ADDR
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:58
FILE_SUFFIX2_LEN
#define FILE_SUFFIX2_LEN
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:71
FLASH_SECTOR_2K_ALLGNED
#define FLASH_SECTOR_2K_ALLGNED
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:67
FLASH_FAT16_BOOT_SECTOR_ADDR
#define FLASH_FAT16_BOOT_SECTOR_ADDR
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:54
FILE_SUFFIX1_LEN
#define FILE_SUFFIX1_LEN
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:70
FAT16_BYTE_PER_SIZE
#define FAT16_BYTE_PER_SIZE
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:50
FLASH_SECTOR_4K_SIZE
#define FLASH_SECTOR_4K_SIZE
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:64
FILE_SUFFIX2_NAME
#define FILE_SUFFIX2_NAME
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:73
FAT16_FILENAME_SIZE
#define FAT16_FILENAME_SIZE
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:51
FLASH_SECTOR_1K_SIZE
#define FLASH_SECTOR_1K_SIZE
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:62
UPGRADE_LARGE
@ UPGRADE_LARGE
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:86
UPGRADE_JUMP
@ UPGRADE_JUMP
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:89
UPGRADE_FAILED
@ UPGRADE_FAILED
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:85
UPGRADE_SUCCESS
@ UPGRADE_SUCCESS
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:84
UPGRADE_READY
@ UPGRADE_READY
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:82
UPGRAGE_ONGOING
@ UPGRAGE_ONGOING
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:83
UPGRADE_DONE
@ UPGRADE_DONE
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:88
IAP_UPGRADE_COMPLETE_FLAG
#define IAP_UPGRADE_COMPLETE_FLAG
Definition: hid_iap_class.h:78
IAP_FAILED
@ IAP_FAILED
Definition: hid_iap_class.h:89
IAP_SUCCESS
@ IAP_SUCCESS
Definition: hid_iap_class.h:87
fat_dir_type
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:93
fat_dir_type::write_data
uint16_t write_data
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:103
fat_dir_type::file_size
uint32_t file_size
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:105
fat_dir_type::write_time
uint16_t write_time
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:102
fat_dir_type::file_name
uint8_t file_name[11]
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:94
fat_dir_type::attr
uint8_t attr
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:95
flash_iap_type
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:109
flash_iap_type::flash_size
uint32_t flash_size
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:112
flash_iap_type::msc_up_status
upgrade_status_type msc_up_status
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:122
flash_iap_type::flash_base_addr
uint32_t flash_base_addr
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:110
flash_iap_type::sector_size
uint32_t sector_size
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:114
flash_iap_type::sector_mask
uint32_t sector_mask
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:115
flash_iap_type::file_write_nr
uint32_t file_write_nr
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:121
flash_iap_type::flash_app_size
uint32_t flash_app_size
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:113
flash_iap_type::write_addr
uint32_t write_addr
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:120
flash_iap_type::flash_app_addr
uint32_t flash_app_addr
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:111


AT32F435/437 Firmwary Library: msc_diskio.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • virtual_msc_iap
  • src
Functions | Variables
at_start_f435/examples/usb_device/virtual_msc_iap/src/msc_diskio.c File Reference

usb mass storage disk function More...

#include "msc_diskio.h"
#include "msc_bot_scsi.h"
#include "flash_fat16.h"

Go to the source code of this file.

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Variables

uint8_t scsi_inquiry [MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]

Detailed Description

usb mass storage disk function

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/usb_device/virtual_msc_iap/src/msc_diskio.c.


AT32F435/437 Firmwary Library: msc_diskio.c Source File

  • at_start_f435
  • examples
  • usb_device
  • virtual_msc_iap
  • src
at_start_f435/examples/usb_device/virtual_msc_iap/src/msc_diskio.c
Go to the documentation of this file.
1
26#include "msc_diskio.h"
27#include "msc_bot_scsi.h"
28#include "flash_fat16.h"
29
38uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH] =
39{
40 /* lun = 0 */
41 {
42 0x00, /* peripheral device type (direct-access device) */
43 0x80, /* removable media bit */
44 0x00, /* ansi version, ecma version, iso version */
45 0x01, /* respond data format */
46 SCSI_INQUIRY_DATA_LENGTH - 5, /* additional length */
47 0x00, 0x00, 0x00, /* reserved */
48 'A', 'T', '3', '2', ' ', ' ', ' ', ' ', /* vendor information "AT32" */
49 'M', 's', 'c', ' ', 'i', 'a', 'p', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', /* Product identification "Disk" */
50 '2', '.', '0', '0' /* product revision level */
51 },
52};
53
59uint8_t *get_inquiry(uint8_t lun)
60{
61 if(lun < MSC_SUPPORT_MAX_LUN)
62 return (uint8_t *)scsi_inquiry[lun];
63 else
64 return NULL;
65}
66
75 usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
76{
77
78 switch(lun)
79 {
80 case 0:
81 flash_fat16_read(addr, read_buf, len);
82 break;
83 case 1:
84 break;
85 }
86 return USB_OK;
87}
88
97 usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
98{
99 switch(lun)
100 {
101 case 0:
102 flash_fat16_write(addr, buf, len);
103 break;
104 case 1:
105 break;
106 }
107 return USB_OK;
108}
109
117 usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
118{
119 switch(lun)
120 {
121 case INTERNAL_FLASH_LUN:
122 *blk_nbr = 0x0FFF;
123 *blk_size = FLASH_SECTOR_2K_SIZE;
124 break;
125 case SPI_FLASH_LUN:
126 break;
127 case SD_LUN:
128 break;
129 default:
130 break;
131 }
132 return USB_OK;
133}
134
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:106
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:75
INTERNAL_FLASH_LUN
#define INTERNAL_FLASH_LUN
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h:45
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:144
SD_LUN
#define SD_LUN
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h:47
SPI_FLASH_LUN
#define SPI_FLASH_LUN
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h:46
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:59
scsi_inquiry
uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/msc_diskio.c:38
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
FLASH_SECTOR_2K_SIZE
#define FLASH_SECTOR_2K_SIZE
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:63
flash_fat16_write
uint32_t flash_fat16_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:332
flash_fat16_read
uint32_t flash_fat16_read(uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:291
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:157
MSC_SUPPORT_MAX_LUN
#define MSC_SUPPORT_MAX_LUN
Definition: cdc_msc_class.h:83
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_OK
@ USB_OK
Definition: usb_std.h:268
msc_bot_scsi.h
usb mass storage bulk-only transport and scsi command header file


AT32F435/437 Firmwary Library: usbh_user.h File Reference

  • at_start_f435
  • examples
  • usb_host
  • hid_demo
  • inc
Variables
at_start_f435/examples/usb_host/hid_demo/inc/usbh_user.h File Reference

usb host user header file More...

#include "usbh_core.h"

Go to the source code of this file.

Variables

usbh_user_handler_type usbh_user_handle

Detailed Description

usb host user header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/usb_host/hid_demo/inc/usbh_user.h.


AT32F435/437 Firmwary Library: usbh_user.h Source File

  • at_start_f435
  • examples
  • usb_host
  • hid_demo
  • inc
at_start_f435/examples/usb_host/hid_demo/inc/usbh_user.h
Go to the documentation of this file.
1
26/* define to prevent recursive inclusion -------------------------------------*/
27#ifndef __USBH_USER_H
28#define __USBH_USER_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "usbh_core.h"
35
36extern usbh_user_handler_type usbh_user_handle;
37#ifdef __cplusplus
38}
39#endif
40
41#endif
42
43
usbh_user_handle
usbh_user_handler_type usbh_user_handle
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:50
usbh_core.h
usb host core header file


AT32F435/437 Firmwary Library: usbh_user.c File Reference

  • at_start_f435
  • examples
  • usb_host
  • hid_demo
  • src
Functions | Variables
at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c File Reference

usb user function More...

#include "usbh_user.h"

Go to the source code of this file.

Functions

static usb_sts_type | usbh_user_init (void)
usb host init user handler More...
static usb_sts_type | usbh_user_reset (void)
usb host reset user handler More...
static usb_sts_type | usbh_user_attached (void)
usb host check device attached More...
static usb_sts_type | usbh_user_disconnect (void)
usb host discconet user handler More...
static usb_sts_type | usbh_user_speed (uint8_t speed)
usb host speed user handler More...
static usb_sts_type | usbh_user_mfc_string (void *string)
usb host manufacturer string user handler More...
static usb_sts_type | usbh_user_product_string (void *string)
usb host product string user handler More...
static usb_sts_type | usbh_user_serial_string (void *string)
usb host serial string user handler More...
static usb_sts_type | usbh_user_enumeration_done (void)
usb host enumeration done user handler More...
static usb_sts_type | usbh_user_application (void)
usb host application user handler More...
static usb_sts_type | usbh_user_active_vbus (void *uhost, confirm_state state)
usb host active vbus user handler More...
static usb_sts_type | usbh_user_not_support (void)
usb host not support user handler More...

Variables

usbh_user_handler_type usbh_user_handle

Detailed Description

usb user function

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c.


AT32F435/437 Firmwary Library: usbh_user.c Source File

  • at_start_f435
  • examples
  • usb_host
  • hid_demo
  • src
at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c
Go to the documentation of this file.
1
26#include "usbh_user.h"
27
36static usb_sts_type usbh_user_init(void);
37static usb_sts_type usbh_user_reset(void);
38static usb_sts_type usbh_user_attached(void);
39static usb_sts_type usbh_user_disconnect(void);
40static usb_sts_type usbh_user_speed(uint8_t speed);
41static usb_sts_type usbh_user_mfc_string(void *string);
42static usb_sts_type usbh_user_product_string(void *string);
43static usb_sts_type usbh_user_serial_string(void *string);
44static usb_sts_type usbh_user_enumeration_done(void);
45static usb_sts_type usbh_user_application(void);
46static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state);
47static usb_sts_type usbh_user_not_support(void);
48
49
50usbh_user_handler_type usbh_user_handle =
51{
52 usbh_user_init,
53 usbh_user_reset,
54 usbh_user_attached,
55 usbh_user_disconnect,
56 usbh_user_speed,
57 usbh_user_mfc_string,
58 usbh_user_product_string,
59 usbh_user_serial_string,
60 usbh_user_enumeration_done,
61 usbh_user_application,
62 usbh_user_active_vbus,
63 usbh_user_not_support,
64};
65
71static usb_sts_type usbh_user_init(void)
72{
73 usb_sts_type status = USB_OK;
74
75 return status;
76}
77
83static usb_sts_type usbh_user_reset(void)
84{
85 usb_sts_type status = USB_OK;
86
87 return status;
88}
89
95static usb_sts_type usbh_user_attached(void)
96{
97 usb_sts_type status = USB_OK;
98 USBH_DEBUG("USB Device Attached");
99 return status;
100}
101
107static usb_sts_type usbh_user_disconnect(void)
108{
109 usb_sts_type status = USB_OK;
110 USBH_DEBUG("Device Disconnect");
111 return status;
112}
113
119static usb_sts_type usbh_user_speed(uint8_t speed)
120{
121 usb_sts_type status = USB_OK;
122 if(speed == USB_PRTSPD_FULL_SPEED)
123 {
124 USBH_DEBUG("This is a Full-Speed device");
125 }
126 else if(speed == USB_PRTSPD_LOW_SPEED)
127 {
128 USBH_DEBUG("This is a Low-Speed device");
129 }
130 return status;
131}
132
138static usb_sts_type usbh_user_mfc_string(void *string)
139{
140 usb_sts_type status = USB_OK;
141 USBH_DEBUG("Manufacturer: %s", (uint8_t *)string);
142 return status;
143}
144
150static usb_sts_type usbh_user_product_string(void *string)
151{
152 usb_sts_type status = USB_OK;
153 USBH_DEBUG("Product: %s", (uint8_t *)string);
154 return status;
155}
156
162static usb_sts_type usbh_user_serial_string(void *string)
163{
164 usb_sts_type status = USB_OK;
165 USBH_DEBUG("Serial: %s", (uint8_t *)string);
166 return status;
167}
168
174static usb_sts_type usbh_user_enumeration_done(void)
175{
176 usb_sts_type status = USB_OK;
177 USBH_DEBUG("Enumeration done");
178 return status;
179}
180
186static usb_sts_type usbh_user_application(void)
187{
188 usb_sts_type status = USB_OK;
189
190 return status;
191}
192
193
202static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state)
203{
204 usb_sts_type status = USB_OK;
205#ifdef USBH_5V_POWER_SWITCH
206 if(state == TRUE)
207 {
208 /* active vbus */
209 gpio_bits_reset(OTG_PIN_POWER_SWITCH_GPIO, OTG_PIN_POWER_SWITCH);
210 }
211 else
212 {
213 /* deactive vubs */
214 gpio_bits_set(OTG_PIN_POWER_SWITCH_GPIO, OTG_PIN_POWER_SWITCH);
215 }
216#endif
217 return status;
218}
219
225static usb_sts_type usbh_user_not_support(void)
226{
227 usb_sts_type status = USB_OK;
228
229 return status;
230}
231
OTG_PIN_POWER_SWITCH_GPIO
#define OTG_PIN_POWER_SWITCH_GPIO
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h:91
OTG_PIN_POWER_SWITCH
#define OTG_PIN_POWER_SWITCH
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h:93
USBH_DEBUG
#define USBH_DEBUG(...)
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h:206
usbh_user_init
static usb_sts_type usbh_user_init(void)
usb host init user handler
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:71
usbh_user_disconnect
static usb_sts_type usbh_user_disconnect(void)
usb host discconet user handler
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:107
usbh_user_not_support
static usb_sts_type usbh_user_not_support(void)
usb host not support user handler
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:225
usbh_user_application
static usb_sts_type usbh_user_application(void)
usb host application user handler
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:186
usbh_user_speed
static usb_sts_type usbh_user_speed(uint8_t speed)
usb host speed user handler
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:119
usbh_user_active_vbus
static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state)
usb host active vbus user handler
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:202
usbh_user_handle
usbh_user_handler_type usbh_user_handle
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:50
usbh_user_serial_string
static usb_sts_type usbh_user_serial_string(void *string)
usb host serial string user handler
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:162
usbh_user_reset
static usb_sts_type usbh_user_reset(void)
usb host reset user handler
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:83
usbh_user_mfc_string
static usb_sts_type usbh_user_mfc_string(void *string)
usb host manufacturer string user handler
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:138
usbh_user_enumeration_done
static usb_sts_type usbh_user_enumeration_done(void)
usb host enumeration done user handler
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:174
usbh_user_attached
static usb_sts_type usbh_user_attached(void)
usb host check device attached
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:95
usbh_user_product_string
static usb_sts_type usbh_user_product_string(void *string)
usb host product string user handler
Definition: at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c:150
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
confirm_state
confirm_state
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f435_437_gpio.c:308
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f435_437_gpio.c:277
USB_PRTSPD_LOW_SPEED
#define USB_PRTSPD_LOW_SPEED
Definition: at32f435_437_usb.h:188
USB_PRTSPD_FULL_SPEED
#define USB_PRTSPD_FULL_SPEED
Definition: at32f435_437_usb.h:187
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_OK
@ USB_OK
Definition: usb_std.h:268


AT32F435/437 Firmwary Library: ffconf.h File Reference

  • at_start_f435
  • examples
  • usb_host
  • msc_only_fat32
  • inc
Macros
at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h File Reference

Go to the source code of this file.

Macros

#define | FFCONF_DEF 86631 /* Revision ID */
#define | FF_FS_READONLY 0
#define | FF_FS_MINIMIZE 0
#define | FF_USE_FIND 0
#define | FF_USE_MKFS 0
#define | FF_USE_FASTSEEK 0
#define | FF_USE_EXPAND 0
#define | FF_USE_CHMOD 0
#define | FF_USE_LABEL 0
#define | FF_USE_FORWARD 0
#define | FF_USE_STRFUNC 0
#define | FF_PRINT_LLI 0
#define | FF_PRINT_FLOAT 0
#define | FF_STRF_ENCODE 0
#define | FF_CODE_PAGE 932
#define | FF_USE_LFN 0
#define | FF_MAX_LFN 255
#define | FF_LFN_UNICODE 0
#define | FF_LFN_BUF 255
#define | FF_SFN_BUF 12
#define | FF_FS_RPATH 0
#define | FF_VOLUMES 1
#define | FF_STR_VOLUME_ID 0
#define | FF_VOLUME_STRS "RAM","NAND","CF","SD","SD2","USB","USB2","USB3"
#define | FF_MULTI_PARTITION 0
#define | FF_MIN_SS 512
#define | FF_MAX_SS 512
#define | FF_LBA64 0
#define | FF_MIN_GPT 0x10000000
#define | FF_USE_TRIM 0
#define | FF_FS_TINY 0
#define | FF_FS_EXFAT 0
#define | FF_FS_NORTC 0
#define | FF_NORTC_MON 1
#define | FF_NORTC_MDAY 1
#define | FF_NORTC_YEAR 2020
#define | FF_FS_NOFSINFO 0
#define | FF_FS_LOCK 0
#define | FF_FS_REENTRANT 0
#define | FF_FS_TIMEOUT 1000
#define | FF_SYNC_t HANDLE

Macro Definition Documentation

◆ FF_CODE_PAGE

#define FF_CODE_PAGE 932

Definition at line 87 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_FS_EXFAT

#define FF_FS_EXFAT 0

Definition at line 234 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_FS_LOCK

#define FF_FS_LOCK 0

Definition at line 266 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_FS_MINIMIZE

#define FF_FS_MINIMIZE 0

Definition at line 18 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_FS_NOFSINFO

#define FF_FS_NOFSINFO 0

Definition at line 254 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_FS_NORTC

#define FF_FS_NORTC 0

Definition at line 240 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_FS_READONLY

#define FF_FS_READONLY 0

Definition at line 11 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_FS_REENTRANT

#define FF_FS_REENTRANT 0

Definition at line 279 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_FS_RPATH

#define FF_FS_RPATH 0

Definition at line 156 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_FS_TIMEOUT

#define FF_FS_TIMEOUT 1000

Definition at line 280 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_FS_TINY

#define FF_FS_TINY 0

Definition at line 227 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_LBA64

#define FF_LBA64 0

Definition at line 206 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_LFN_BUF

#define FF_LFN_BUF 255

Definition at line 148 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_LFN_UNICODE

#define FF_LFN_UNICODE 0

Definition at line 136 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_MAX_LFN

#define FF_MAX_LFN 255

Definition at line 117 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_MAX_SS

#define FF_MAX_SS 512

Definition at line 197 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_MIN_GPT

#define FF_MIN_GPT 0x10000000

Definition at line 211 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_MIN_SS

#define FF_MIN_SS 512

Definition at line 196 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_MULTI_PARTITION

#define FF_MULTI_PARTITION 0

Definition at line 187 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_NORTC_MDAY

#define FF_NORTC_MDAY 1

Definition at line 242 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_NORTC_MON

#define FF_NORTC_MON 1

Definition at line 241 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_NORTC_YEAR

#define FF_NORTC_YEAR 2020

Definition at line 243 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_PRINT_FLOAT

#define FF_PRINT_FLOAT 0

Definition at line 61 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_PRINT_LLI

#define FF_PRINT_LLI 0

Definition at line 60 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_SFN_BUF

#define FF_SFN_BUF 12

Definition at line 149 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_STR_VOLUME_ID

#define FF_STR_VOLUME_ID 0

Definition at line 173 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_STRF_ENCODE

#define FF_STRF_ENCODE 0

Definition at line 62 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_SYNC_t

#define FF_SYNC_t HANDLE

Definition at line 281 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_USE_CHMOD

#define FF_USE_CHMOD 0

Definition at line 45 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_USE_EXPAND

#define FF_USE_EXPAND 0

Definition at line 41 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_USE_FASTSEEK

#define FF_USE_FASTSEEK 0

Definition at line 37 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_USE_FIND

#define FF_USE_FIND 0

Definition at line 28 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_USE_FORWARD

#define FF_USE_FORWARD 0

Definition at line 55 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_USE_LABEL

#define FF_USE_LABEL 0

Definition at line 50 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_USE_LFN

#define FF_USE_LFN 0

Definition at line 116 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_USE_MKFS

#define FF_USE_MKFS 0

Definition at line 33 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_USE_STRFUNC

#define FF_USE_STRFUNC 0

Definition at line 59 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_USE_TRIM

#define FF_USE_TRIM 0

Definition at line 216 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_VOLUME_STRS

#define FF_VOLUME_STRS "RAM","NAND","CF","SD","SD2","USB","USB2","USB3"

Definition at line 174 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_VOLUMES

#define FF_VOLUMES 1

Definition at line 169 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FFCONF_DEF

#define FFCONF_DEF 86631 /* Revision ID */

Definition at line 5 of file at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h.


AT32F435/437 Firmwary Library: ffconf.h Source File

  • at_start_f435
  • examples
  • usb_host
  • msc_only_fat32
  • inc
at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h
Go to the documentation of this file.
1/*---------------------------------------------------------------------------/
2/ FatFs Functional Configurations
3/---------------------------------------------------------------------------*/
4
5#define FFCONF_DEF 86631 /* Revision ID */
6
7/*---------------------------------------------------------------------------/
8/ Function Configurations
9/---------------------------------------------------------------------------*/
10
11#define FF_FS_READONLY 0
12/* This option switches read-only configuration. (0:Read/Write or 1:Read-only)
13/ Read-only configuration removes writing API functions, f_write(), f_sync(),
14/ f_unlink(), f_mkdir(), f_chmod(), f_rename(), f_truncate(), f_getfree()
15/ and optional writing functions as well. */
16
17
18#define FF_FS_MINIMIZE 0
19/* This option defines minimization level to remove some basic API functions.
20/
21/ 0: Basic functions are fully enabled.
22/ 1: f_stat(), f_getfree(), f_unlink(), f_mkdir(), f_truncate() and f_rename()
23/ are removed.
24/ 2: f_opendir(), f_readdir() and f_closedir() are removed in addition to 1.
25/ 3: f_lseek() function is removed in addition to 2. */
26
27
28#define FF_USE_FIND 0
29/* This option switches filtered directory read functions, f_findfirst() and
30/ f_findnext(). (0:Disable, 1:Enable 2:Enable with matching altname[] too) */
31
32
33#define FF_USE_MKFS 0
34/* This option switches f_mkfs() function. (0:Disable or 1:Enable) */
35
36
37#define FF_USE_FASTSEEK 0
38/* This option switches fast seek function. (0:Disable or 1:Enable) */
39
40
41#define FF_USE_EXPAND 0
42/* This option switches f_expand function. (0:Disable or 1:Enable) */
43
44
45#define FF_USE_CHMOD 0
46/* This option switches attribute manipulation functions, f_chmod() and f_utime().
47/ (0:Disable or 1:Enable) Also FF_FS_READONLY needs to be 0 to enable this option. */
48
49
50#define FF_USE_LABEL 0
51/* This option switches volume label functions, f_getlabel() and f_setlabel().
52/ (0:Disable or 1:Enable) */
53
54
55#define FF_USE_FORWARD 0
56/* This option switches f_forward() function. (0:Disable or 1:Enable) */
57
58
59#define FF_USE_STRFUNC 0
60#define FF_PRINT_LLI 0
61#define FF_PRINT_FLOAT 0
62#define FF_STRF_ENCODE 0
63/* FF_USE_STRFUNC switches string functions, f_gets(), f_putc(), f_puts() and
64/ f_printf().
65/
66/ 0: Disable. FF_PRINT_LLI, FF_PRINT_FLOAT and FF_STRF_ENCODE have no effect.
67/ 1: Enable without LF-CRLF conversion.
68/ 2: Enable with LF-CRLF conversion.
69/
70/ FF_PRINT_LLI = 1 makes f_printf() support long long argument and FF_PRINT_FLOAT = 1/2
71 makes f_printf() support floating point argument. These features want C99 or later.
72/ When FF_LFN_UNICODE >= 1 with LFN enabled, string functions convert the character
73/ encoding in it. FF_STRF_ENCODE selects assumption of character encoding ON THE FILE
74/ to be read/written via those functions.
75/
76/ 0: ANSI/OEM in current CP
77/ 1: Unicode in UTF-16LE
78/ 2: Unicode in UTF-16BE
79/ 3: Unicode in UTF-8
80*/
81
82
83/*---------------------------------------------------------------------------/
84/ Locale and Namespace Configurations
85/---------------------------------------------------------------------------*/
86
87#define FF_CODE_PAGE 932
88/* This option specifies the OEM code page to be used on the target system.
89/ Incorrect code page setting can cause a file open failure.
90/
91/ 437 - U.S.
92/ 720 - Arabic
93/ 737 - Greek
94/ 771 - KBL
95/ 775 - Baltic
96/ 850 - Latin 1
97/ 852 - Latin 2
98/ 855 - Cyrillic
99/ 857 - Turkish
100/ 860 - Portuguese
101/ 861 - Icelandic
102/ 862 - Hebrew
103/ 863 - Canadian French
104/ 864 - Arabic
105/ 865 - Nordic
106/ 866 - Russian
107/ 869 - Greek 2
108/ 932 - Japanese (DBCS)
109/ 936 - Simplified Chinese (DBCS)
110/ 949 - Korean (DBCS)
111/ 950 - Traditional Chinese (DBCS)
112/ 0 - Include all code pages above and configured by f_setcp()
113*/
114
115
116#define FF_USE_LFN 0
117#define FF_MAX_LFN 255
118/* The FF_USE_LFN switches the support for LFN (long file name).
119/
120/ 0: Disable LFN. FF_MAX_LFN has no effect.
121/ 1: Enable LFN with static working buffer on the BSS. Always NOT thread-safe.
122/ 2: Enable LFN with dynamic working buffer on the STACK.
123/ 3: Enable LFN with dynamic working buffer on the HEAP.
124/
125/ To enable the LFN, ffunicode.c needs to be added to the project. The LFN function
126/ requiers certain internal working buffer occupies (FF_MAX_LFN + 1) * 2 bytes and
127/ additional (FF_MAX_LFN + 44) / 15 * 32 bytes when exFAT is enabled.
128/ The FF_MAX_LFN defines size of the working buffer in UTF-16 code unit and it can
129/ be in range of 12 to 255. It is recommended to be set it 255 to fully support LFN
130/ specification.
131/ When use stack for the working buffer, take care on stack overflow. When use heap
132/ memory for the working buffer, memory management functions, ff_memalloc() and
133/ ff_memfree() exemplified in ffsystem.c, need to be added to the project. */
134
135
136#define FF_LFN_UNICODE 0
137/* This option switches the character encoding on the API when LFN is enabled.
138/
139/ 0: ANSI/OEM in current CP (TCHAR = char)
140/ 1: Unicode in UTF-16 (TCHAR = WCHAR)
141/ 2: Unicode in UTF-8 (TCHAR = char)
142/ 3: Unicode in UTF-32 (TCHAR = DWORD)
143/
144/ Also behavior of string I/O functions will be affected by this option.
145/ When LFN is not enabled, this option has no effect. */
146
147
148#define FF_LFN_BUF 255
149#define FF_SFN_BUF 12
150/* This set of options defines size of file name members in the FILINFO structure
151/ which is used to read out directory items. These values should be suffcient for
152/ the file names to read. The maximum possible length of the read file name depends
153/ on character encoding. When LFN is not enabled, these options have no effect. */
154
155
156#define FF_FS_RPATH 0
157/* This option configures support for relative path.
158/
159/ 0: Disable relative path and remove related functions.
160/ 1: Enable relative path. f_chdir() and f_chdrive() are available.
161/ 2: f_getcwd() function is available in addition to 1.
162*/
163
164
165/*---------------------------------------------------------------------------/
166/ Drive/Volume Configurations
167/---------------------------------------------------------------------------*/
168
169#define FF_VOLUMES 1
170/* Number of volumes (logical drives) to be used. (1-10) */
171
172
173#define FF_STR_VOLUME_ID 0
174#define FF_VOLUME_STRS "RAM","NAND","CF","SD","SD2","USB","USB2","USB3"
175/* FF_STR_VOLUME_ID switches support for volume ID in arbitrary strings.
176/ When FF_STR_VOLUME_ID is set to 1 or 2, arbitrary strings can be used as drive
177/ number in the path name. FF_VOLUME_STRS defines the volume ID strings for each
178/ logical drives. Number of items must not be less than FF_VOLUMES. Valid
179/ characters for the volume ID strings are A-Z, a-z and 0-9, however, they are
180/ compared in case-insensitive. If FF_STR_VOLUME_ID >= 1 and FF_VOLUME_STRS is
181/ not defined, a user defined volume string table needs to be defined as:
182/
183/ const char* VolumeStr[FF_VOLUMES] = {"ram","flash","sd","usb",...
184*/
185
186
187#define FF_MULTI_PARTITION 0
188/* This option switches support for multiple volumes on the physical drive.
189/ By default (0), each logical drive number is bound to the same physical drive
190/ number and only an FAT volume found on the physical drive will be mounted.
191/ When this function is enabled (1), each logical drive number can be bound to
192/ arbitrary physical drive and partition listed in the VolToPart[]. Also f_fdisk()
193/ funciton will be available. */
194
195
196#define FF_MIN_SS 512
197#define FF_MAX_SS 512
198/* This set of options configures the range of sector size to be supported. (512,
199/ 1024, 2048 or 4096) Always set both 512 for most systems, generic memory card and
200/ harddisk, but a larger value may be required for on-board flash memory and some
201/ type of optical media. When FF_MAX_SS is larger than FF_MIN_SS, FatFs is configured
202/ for variable sector size mode and disk_ioctl() function needs to implement
203/ GET_SECTOR_SIZE command. */
204
205
206#define FF_LBA64 0
207/* This option switches support for 64-bit LBA. (0:Disable or 1:Enable)
208/ To enable the 64-bit LBA, also exFAT needs to be enabled. (FF_FS_EXFAT == 1) */
209
210
211#define FF_MIN_GPT 0x10000000
212/* Minimum number of sectors to switch GPT as partitioning format in f_mkfs and
213/ f_fdisk function. 0x100000000 max. This option has no effect when FF_LBA64 == 0. */
214
215
216#define FF_USE_TRIM 0
217/* This option switches support for ATA-TRIM. (0:Disable or 1:Enable)
218/ To enable Trim function, also CTRL_TRIM command should be implemented to the
219/ disk_ioctl() function. */
220
221
222
223/*---------------------------------------------------------------------------/
224/ System Configurations
225/---------------------------------------------------------------------------*/
226
227#define FF_FS_TINY 0
228/* This option switches tiny buffer configuration. (0:Normal or 1:Tiny)
229/ At the tiny configuration, size of file object (FIL) is shrinked FF_MAX_SS bytes.
230/ Instead of private sector buffer eliminated from the file object, common sector
231/ buffer in the filesystem object (FATFS) is used for the file data transfer. */
232
233
234#define FF_FS_EXFAT 0
235/* This option switches support for exFAT filesystem. (0:Disable or 1:Enable)
236/ To enable exFAT, also LFN needs to be enabled. (FF_USE_LFN >= 1)
237/ Note that enabling exFAT discards ANSI C (C89) compatibility. */
238
239
240#define FF_FS_NORTC 0
241#define FF_NORTC_MON 1
242#define FF_NORTC_MDAY 1
243#define FF_NORTC_YEAR 2020
244/* The option FF_FS_NORTC switches timestamp functiton. If the system does not have
245/ any RTC function or valid timestamp is not needed, set FF_FS_NORTC = 1 to disable
246/ the timestamp function. Every object modified by FatFs will have a fixed timestamp
247/ defined by FF_NORTC_MON, FF_NORTC_MDAY and FF_NORTC_YEAR in local time.
248/ To enable timestamp function (FF_FS_NORTC = 0), get_fattime() function need to be
249/ added to the project to read current time form real-time clock. FF_NORTC_MON,
250/ FF_NORTC_MDAY and FF_NORTC_YEAR have no effect.
251/ These options have no effect in read-only configuration (FF_FS_READONLY = 1). */
252
253
254#define FF_FS_NOFSINFO 0
255/* If you need to know correct free space on the FAT32 volume, set bit 0 of this
256/ option, and f_getfree() function at first time after volume mount will force
257/ a full FAT scan. Bit 1 controls the use of last allocated cluster number.
258/
259/ bit0=0: Use free cluster count in the FSINFO if available.
260/ bit0=1: Do not trust free cluster count in the FSINFO.
261/ bit1=0: Use last allocated cluster number in the FSINFO if available.
262/ bit1=1: Do not trust last allocated cluster number in the FSINFO.
263*/
264
265
266#define FF_FS_LOCK 0
267/* The option FF_FS_LOCK switches file lock function to control duplicated file open
268/ and illegal operation to open objects. This option must be 0 when FF_FS_READONLY
269/ is 1.
270/
271/ 0: Disable file lock function. To avoid volume corruption, application program
272/ should avoid illegal open, remove and rename to the open objects.
273/ >0: Enable file lock function. The value defines how many files/sub-directories
274/ can be opened simultaneously under file lock control. Note that the file
275/ lock control is independent of re-entrancy. */
276
277
278/* #include <somertos.h> // O/S definitions */
279#define FF_FS_REENTRANT 0
280#define FF_FS_TIMEOUT 1000
281#define FF_SYNC_t HANDLE
282/* The option FF_FS_REENTRANT switches the re-entrancy (thread safe) of the FatFs
283/ module itself. Note that regardless of this option, file access to different
284/ volume is always re-entrant and volume control functions, f_mount(), f_mkfs()
285/ and f_fdisk() function, are always not re-entrant. Only file/directory access
286/ to the same volume is under control of this function.
287/
288/ 0: Disable re-entrancy. FF_FS_TIMEOUT and FF_SYNC_t have no effect.
289/ 1: Enable re-entrancy. Also user provided synchronization handlers,
290/ ff_req_grant(), ff_rel_grant(), ff_del_syncobj() and ff_cre_syncobj()
291/ function, must be added to the project. Samples are available in
292/ option/syscall.c.
293/
294/ The FF_FS_TIMEOUT defines timeout period in unit of time tick.
295/ The FF_SYNC_t defines O/S dependent sync object type. e.g. HANDLE, ID, OS_EVENT*,
296/ SemaphoreHandle_t and etc. A header file for O/S definitions needs to be
297/ included somewhere in the scope of ff.h. */
298
299
300
301/*--- End of configuration options ---*/


AT32F435/437 Firmwary Library: usbh_user.h File Reference

  • at_start_f435
  • examples
  • usb_host
  • msc_only_fat32
  • inc
Variables
at_start_f435/examples/usb_host/msc_only_fat32/inc/usbh_user.h File Reference

usb host user header file More...

#include "usbh_core.h"

Go to the source code of this file.

Variables

usbh_user_handler_type usbh_user_handle

Detailed Description

usb host user header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/usb_host/msc_only_fat32/inc/usbh_user.h.


AT32F435/437 Firmwary Library: usbh_user.h Source File

  • at_start_f435
  • examples
  • usb_host
  • msc_only_fat32
  • inc
at_start_f435/examples/usb_host/msc_only_fat32/inc/usbh_user.h
Go to the documentation of this file.
1
26/* define to prevent recursive inclusion -------------------------------------*/
27#ifndef __USBH_USER_H
28#define __USBH_USER_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "usbh_core.h"
35
36extern usbh_user_handler_type usbh_user_handle;
37#ifdef __cplusplus
38}
39#endif
40
41#endif
42
43
usbh_user_handle
usbh_user_handler_type usbh_user_handle
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:50
usbh_core.h
usb host core header file


AT32F435/437 Firmwary Library: usbh_msc_diskio.c File Reference

  • at_start_f435
  • examples
  • usb_host
  • msc_only_fat32
  • src
Macros | Functions | Variables
at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c File Reference

usb mass storage disk io More...

#include "ff.h"
#include "diskio.h"
#include "usb_core.h"
#include "usbh_msc_class.h"

Go to the source code of this file.

Macros

#define | DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */
#define | DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */
#define | DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */

Functions

DSTATUS | disk_status (BYTE pdrv)
DSTATUS | disk_initialize (BYTE pdrv)
DRESULT | disk_read (BYTE pdrv, BYTE *buff, LBA_t sector, UINT count)
DRESULT | disk_write (BYTE pdrv, const BYTE *buff, LBA_t sector, UINT count)
DRESULT | disk_ioctl (BYTE pdrv, BYTE cmd, void *buff)
DWORD | get_fattime (void)

Variables

otg_core_type otg_core_struct

Detailed Description

usb mass storage disk io

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c.


AT32F435/437 Firmwary Library: usbh_msc_diskio.c Source File

  • at_start_f435
  • examples
  • usb_host
  • msc_only_fat32
  • src
at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c
Go to the documentation of this file.
1
26#include "ff.h" /* Obtains integer types */
27#include "diskio.h" /* Declarations of disk functions */
28#include "usb_core.h"
29#include "usbh_msc_class.h"
38extern otg_core_type otg_core_struct;
39
40/* Definitions of physical drive number for each drive */
41#define DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */
42#define DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */
43#define DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */
44
45
46/*-----------------------------------------------------------------------*/
47/* Get Drive Status */
48/*-----------------------------------------------------------------------*/
49
50DSTATUS disk_status (
51 BYTE pdrv /* Physical drive nmuber to identify the drive */
52)
53{
54 if(usbh_msc_is_ready(&otg_core_struct.host, pdrv) == MSC_OK)
55 {
56 return RES_OK;
57 }
58
59 return RES_ERROR;
60}
61
62
63
64/*-----------------------------------------------------------------------*/
65/* Inidialize a Drive */
66/*-----------------------------------------------------------------------*/
67
68DSTATUS disk_initialize (
69 BYTE pdrv /* Physical drive nmuber to identify the drive */
70)
71{
72 return RES_OK;
73}
74
75
76
77/*-----------------------------------------------------------------------*/
78/* Read Sector(s) */
79/*-----------------------------------------------------------------------*/
80DRESULT disk_read (
81 BYTE pdrv, /* Physical drive nmuber to identify the drive */
82 BYTE *buff, /* Data buffer to store read data */
83 LBA_t sector, /* Start sector in LBA */
84 UINT count /* Number of sectors to read */
85)
86{
87 usb_sts_type status;
88
89 status = usbh_msc_read(&otg_core_struct.host, sector, count, buff, pdrv);
90
91 if(status == USB_OK)
92 return RES_OK;
93
94 return RES_ERROR;
95}
96
97
98
99/*-----------------------------------------------------------------------*/
100/* Write Sector(s) */
101/*-----------------------------------------------------------------------*/
102
103#if FF_FS_READONLY == 0
104
105DRESULT disk_write (
106 BYTE pdrv, /* Physical drive nmuber to identify the drive */
107 const BYTE *buff, /* Data to be written */
108 LBA_t sector, /* Start sector in LBA */
109 UINT count /* Number of sectors to write */
110)
111{
112 usb_sts_type status;
113
114 status = usbh_msc_write(&otg_core_struct.host, sector, count, (uint8_t *)buff, pdrv);
115
116 if(status == USB_OK)
117 return RES_OK;
118
119 return RES_ERROR;
120
121
122}
123
124#endif
125
126
127/*-----------------------------------------------------------------------*/
128/* Miscellaneous Functions */
129/*-----------------------------------------------------------------------*/
130
131DRESULT disk_ioctl (
132 BYTE pdrv, /* Physical drive nmuber (0..) */
133 BYTE cmd, /* Control code */
134 void *buff /* Buffer to send/receive control data */
135)
136{
137 usbh_core_type *host = (usbh_core_type *)&otg_core_struct.host;
138 usbh_msc_type *pmsc = (usbh_msc_type *)host->class_handler->pdata;
139 DRESULT res = RES_OK;
140 switch(cmd)
141 {
142 case CTRL_SYNC:
143 res = RES_OK;
144 break;
145 case GET_SECTOR_COUNT:
146 *(DWORD*)buff = pmsc->l_unit_n[pdrv].capacity.blk_nbr;
147 break;
148 case GET_SECTOR_SIZE:
149 *(DWORD*)buff = pmsc->l_unit_n[pdrv].capacity.blk_size;
150 break;
151 case GET_BLOCK_SIZE:
152 *(DWORD*)buff = pmsc->l_unit_n[pdrv].capacity.blk_size;
153 break;
154 default:
155 res = RES_PARERR;
156 }
157 return res;
158}
159
160/*-----------------------------------------------------------------------*/
161/* get_fattime */
162/*-----------------------------------------------------------------------*/
163DWORD get_fattime (void)
164{
165 return 0;
166}
167
disk_read
DRESULT disk_read(BYTE pdrv, BYTE *buff, LBA_t sector, UINT count)
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c:80
disk_initialize
DSTATUS disk_initialize(BYTE pdrv)
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c:68
disk_status
DSTATUS disk_status(BYTE pdrv)
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c:50
disk_ioctl
DRESULT disk_ioctl(BYTE pdrv, BYTE cmd, void *buff)
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c:131
disk_write
DRESULT disk_write(BYTE pdrv, const BYTE *buff, LBA_t sector, UINT count)
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c:105
otg_core_struct
otg_core_type otg_core_struct
Definition: project/at_start_f435/examples/acc/calibration/src/main.c:45
get_fattime
DWORD get_fattime(void)
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c:163
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_OK
@ USB_OK
Definition: usb_std.h:268
MSC_OK
@ MSC_OK
Definition: usbh_msc_bot_scsi.h:117
usbh_msc_write
usb_sts_type usbh_msc_write(void *uhost, uint32_t address, uint32_t len, uint8_t *buffer, uint8_t lun)
usb host msc write
Definition: usbh_msc_class.c:486
usbh_msc_read
usb_sts_type usbh_msc_read(void *uhost, uint32_t address, uint32_t len, uint8_t *buffer, uint8_t lun)
usb host msc read
Definition: usbh_msc_class.c:450
usbh_msc_is_ready
msc_error_type usbh_msc_is_ready(void *uhost, uint8_t lun)
usb host msc clear feature
Definition: usbh_msc_class.c:375
msc_scsi_data_capacity::blk_nbr
uint32_t blk_nbr
Definition: usbh_msc_bot_scsi.h:145
otg_core_type
usb otg core struct type
Definition: usb_core.h:92
usbh_msc_type
usb msc struct
Definition: usbh_msc_class.h:94
usbh_msc_type::l_unit_n
usbh_msc_unit_type l_unit_n[0x2]
Definition: usbh_msc_class.h:115
usbh_msc_unit_type::capacity
msc_scsi_data_capacity capacity
Definition: usbh_msc_bot_scsi.h:194
usb_core.h
usb core header file
usbh_msc_class.h
usb host msc class header file


AT32F435/437 Firmwary Library: usbh_user.c File Reference

  • at_start_f435
  • examples
  • usb_host
  • msc_only_fat32
  • src
Enumerations | Functions | Variables
at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c File Reference

usb user function More...

#include "usbh_user.h"
#include "ff.h"

Go to the source code of this file.

Enumerations

enum msc_usr_state {
USR_IDLE , USR_APP , USR_FINISH , USR_IDLE ,
USR_APP , USR_FINISH , USR_IDLE , USR_APP ,
USR_FINISH , USR_IDLE , USR_APP , USR_FINISH
}

Functions

static usb_sts_type | usbh_user_init (void)
usb host init user handler More...
static usb_sts_type | usbh_user_reset (void)
usb host reset user handler More...
static usb_sts_type | usbh_user_attached (void)
usb host check device attached More...
static usb_sts_type | usbh_user_disconnect (void)
usb host discconet user handler More...
static usb_sts_type | usbh_user_speed (uint8_t speed)
usb host speed user handler More...
static usb_sts_type | usbh_user_mfc_string (void *string)
usb host manufacturer string user handler More...
static usb_sts_type | usbh_user_product_string (void *string)
usb host product string user handler More...
static usb_sts_type | usbh_user_serial_string (void *string)
usb host serial string user handler More...
static usb_sts_type | usbh_user_enumeration_done (void)
usb host enumeration done user handler More...
static usb_sts_type | usbh_user_application (void)
static usb_sts_type | usbh_user_active_vbus (void *uhost, confirm_state state)
usb host active vbus user handler More...
static usb_sts_type | usbh_user_not_support (void)
usb host not support user handler More...

Variables

usbh_user_handler_type | usbh_user_handle
msc_usr_state usr_state = USR_IDLE
FIL | file
usb host application user handler More...
FATFS | fs

Detailed Description

usb user function

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c.


AT32F435/437 Firmwary Library: usbh_user.c Source File

  • at_start_f435
  • examples
  • usb_host
  • msc_only_fat32
  • src
at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c
Go to the documentation of this file.
1
26#include "usbh_user.h"
27#include "ff.h"
28
37static usb_sts_type usbh_user_init(void);
38static usb_sts_type usbh_user_reset(void);
39static usb_sts_type usbh_user_attached(void);
40static usb_sts_type usbh_user_disconnect(void);
41static usb_sts_type usbh_user_speed(uint8_t speed);
42static usb_sts_type usbh_user_mfc_string(void *string);
43static usb_sts_type usbh_user_product_string(void *string);
44static usb_sts_type usbh_user_serial_string(void *string);
45static usb_sts_type usbh_user_enumeration_done(void);
46static usb_sts_type usbh_user_application(void);
47static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state);
48static usb_sts_type usbh_user_not_support(void);
49
50
51usbh_user_handler_type usbh_user_handle =
52{
53 usbh_user_init,
54 usbh_user_reset,
55 usbh_user_attached,
56 usbh_user_disconnect,
57 usbh_user_speed,
58 usbh_user_mfc_string,
59 usbh_user_product_string,
60 usbh_user_serial_string,
61 usbh_user_enumeration_done,
62 usbh_user_application,
63 usbh_user_active_vbus,
64 usbh_user_not_support,
65};
66
67typedef enum
68{
69 USR_IDLE,
70 USR_APP,
71 USR_FINISH
72}msc_usr_state;
73
74 msc_usr_state usr_state = USR_IDLE;
75
81static usb_sts_type usbh_user_init(void)
82{
83 usb_sts_type status = USB_OK;
84
85 return status;
86}
87
93static usb_sts_type usbh_user_reset(void)
94{
95 usb_sts_type status = USB_OK;
96
97 return status;
98}
99
105static usb_sts_type usbh_user_attached(void)
106{
107 usb_sts_type status = USB_OK;
108 USBH_DEBUG("USB Device Attached");
109 return status;
110}
111
117static usb_sts_type usbh_user_disconnect(void)
118{
119 usb_sts_type status = USB_OK;
120 usr_state = USR_IDLE;
121 USBH_DEBUG("Device Disconnect");
122 return status;
123}
124
130static usb_sts_type usbh_user_speed(uint8_t speed)
131{
132 usb_sts_type status = USB_OK;
133 if(speed == USB_PRTSPD_FULL_SPEED)
134 {
135 USBH_DEBUG("This is a Full-Speed device");
136 }
137 else if(speed == USB_PRTSPD_LOW_SPEED)
138 {
139 USBH_DEBUG("This is a Low-Speed device");
140 }
141 return status;
142}
143
149static usb_sts_type usbh_user_mfc_string(void *string)
150{
151 usb_sts_type status = USB_OK;
152 USBH_DEBUG("Manufacturer: %s", (uint8_t *)string);
153 return status;
154}
155
161static usb_sts_type usbh_user_product_string(void *string)
162{
163 usb_sts_type status = USB_OK;
164 USBH_DEBUG("Product: %s", (uint8_t *)string);
165 return status;
166}
167
173static usb_sts_type usbh_user_serial_string(void *string)
174{
175 usb_sts_type status = USB_OK;
176 USBH_DEBUG("Serial: %s", (uint8_t *)string);
177 return status;
178}
179
185static usb_sts_type usbh_user_enumeration_done(void)
186{
187 usb_sts_type status = USB_OK;
188 USBH_DEBUG("Enumeration done");
189 return status;
190}
191
197FIL file;
198FATFS fs;
199static usb_sts_type usbh_user_application(void)
200{
201 usb_sts_type status = USB_OK;
202 FRESULT res;
203
204 uint32_t len;
205 uint8_t write_data[] = "usb host msc demo";
206 uint8_t read_data[32] = {0};
207
208 switch(usr_state)
209 {
210 case USR_IDLE:
211 usr_state = USR_APP;
212 break;
213 case USR_APP:
214 res = f_mount(&fs, "", 0);
215 if(res == FR_OK)
216 {
217 /* start write data */
218 if(f_open(&file, "0:AT32.txt", FA_CREATE_ALWAYS | FA_WRITE) != FR_OK)
219 {
220 // error
221 USBH_DEBUG("Open AT32.txt failed");
222 }
223 else
224 {
225 res = f_write(&file, write_data, sizeof(write_data), &len);
226 if(res != FR_OK || len == 0)
227 {
228 //write error
229 USBH_DEBUG("Write AT32.txt failed");
230 }
231 else
232 {
233 //write success
234 USBH_DEBUG("Write AT32.txt Success");
235 }
236 f_close(&file);
237 }
238
239 /* start read file */
240 if(f_open(&file, "0:AT32.txt", FA_READ) != FR_OK)
241 {
242 // error
243 USBH_DEBUG("Open AT32.txt failed");
244 }
245 else
246 {
247 res = f_read(&file, read_data, sizeof(read_data), &len);
248 if(res != FR_OK || len == 0)
249 {
250 //read error
251 USBH_DEBUG("Read AT32.txt failed");
252 }
253 else
254 {
255 //read success
256 USBH_DEBUG("Read AT32.txt Success");
257 }
258 f_close(&file);
259 }
260 f_mount(NULL, "", 0);
261 }
262 usr_state = USR_FINISH;
263 break;
264 case USR_FINISH:
265 break;
266 }
267 return status;
268}
269
278static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state)
279{
280 usb_sts_type status = USB_OK;
281#ifdef USBH_5V_POWER_SWITCH
282 if(state == TRUE)
283 {
284 /* active vbus */
285 gpio_bits_reset(OTG_PIN_POWER_SWITCH_GPIO, OTG_PIN_POWER_SWITCH);
286 }
287 else
288 {
289 /* deactive vubs */
290 gpio_bits_set(OTG_PIN_POWER_SWITCH_GPIO, OTG_PIN_POWER_SWITCH);
291 }
292#endif
293 return status;
294}
295
301static usb_sts_type usbh_user_not_support(void)
302{
303 usb_sts_type status = USB_OK;
304
305 return status;
306}
307
OTG_PIN_POWER_SWITCH_GPIO
#define OTG_PIN_POWER_SWITCH_GPIO
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h:91
OTG_PIN_POWER_SWITCH
#define OTG_PIN_POWER_SWITCH
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h:93
USBH_DEBUG
#define USBH_DEBUG(...)
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h:206
usbh_user_init
static usb_sts_type usbh_user_init(void)
usb host init user handler
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:81
file
FIL file
usb host application user handler
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:197
usbh_user_disconnect
static usb_sts_type usbh_user_disconnect(void)
usb host discconet user handler
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:117
usbh_user_not_support
static usb_sts_type usbh_user_not_support(void)
usb host not support user handler
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:301
usbh_user_application
static usb_sts_type usbh_user_application(void)
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:199
usbh_user_speed
static usb_sts_type usbh_user_speed(uint8_t speed)
usb host speed user handler
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:130
usbh_user_active_vbus
static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state)
usb host active vbus user handler
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:278
usbh_user_handle
usbh_user_handler_type usbh_user_handle
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:51
usbh_user_serial_string
static usb_sts_type usbh_user_serial_string(void *string)
usb host serial string user handler
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:173
usbh_user_reset
static usb_sts_type usbh_user_reset(void)
usb host reset user handler
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:93
msc_usr_state
msc_usr_state
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:68
usr_state
msc_usr_state usr_state
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:74
usbh_user_mfc_string
static usb_sts_type usbh_user_mfc_string(void *string)
usb host manufacturer string user handler
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:149
usbh_user_enumeration_done
static usb_sts_type usbh_user_enumeration_done(void)
usb host enumeration done user handler
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:185
usbh_user_attached
static usb_sts_type usbh_user_attached(void)
usb host check device attached
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:105
fs
FATFS fs
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:198
usbh_user_product_string
static usb_sts_type usbh_user_product_string(void *string)
usb host product string user handler
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:161
USR_APP
@ USR_APP
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:70
USR_FINISH
@ USR_FINISH
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:71
USR_IDLE
@ USR_IDLE
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:69
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
confirm_state
confirm_state
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f435_437_gpio.c:308
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f435_437_gpio.c:277
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
USB_PRTSPD_LOW_SPEED
#define USB_PRTSPD_LOW_SPEED
Definition: at32f435_437_usb.h:188
USB_PRTSPD_FULL_SPEED
#define USB_PRTSPD_FULL_SPEED
Definition: at32f435_437_usb.h:187
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_OK
@ USB_OK
Definition: usb_std.h:268


AT32F435/437 Firmwary Library: ffconf.h File Reference

  • at_start_f435
  • examples
  • usb_host
  • two_otg_host_demo
  • inc
Macros
at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h File Reference

Go to the source code of this file.

Macros

#define | FFCONF_DEF 86631 /* Revision ID */
#define | FF_FS_READONLY 0
#define | FF_FS_MINIMIZE 0
#define | FF_USE_FIND 0
#define | FF_USE_MKFS 0
#define | FF_USE_FASTSEEK 0
#define | FF_USE_EXPAND 0
#define | FF_USE_CHMOD 0
#define | FF_USE_LABEL 0
#define | FF_USE_FORWARD 0
#define | FF_USE_STRFUNC 0
#define | FF_PRINT_LLI 0
#define | FF_PRINT_FLOAT 0
#define | FF_STRF_ENCODE 0
#define | FF_CODE_PAGE 932
#define | FF_USE_LFN 0
#define | FF_MAX_LFN 255
#define | FF_LFN_UNICODE 0
#define | FF_LFN_BUF 255
#define | FF_SFN_BUF 12
#define | FF_FS_RPATH 0
#define | FF_VOLUMES 1
#define | FF_STR_VOLUME_ID 0
#define | FF_VOLUME_STRS "RAM","NAND","CF","SD","SD2","USB","USB2","USB3"
#define | FF_MULTI_PARTITION 0
#define | FF_MIN_SS 512
#define | FF_MAX_SS 512
#define | FF_LBA64 0
#define | FF_MIN_GPT 0x10000000
#define | FF_USE_TRIM 0
#define | FF_FS_TINY 0
#define | FF_FS_EXFAT 0
#define | FF_FS_NORTC 0
#define | FF_NORTC_MON 1
#define | FF_NORTC_MDAY 1
#define | FF_NORTC_YEAR 2020
#define | FF_FS_NOFSINFO 0
#define | FF_FS_LOCK 0
#define | FF_FS_REENTRANT 0
#define | FF_FS_TIMEOUT 1000
#define | FF_SYNC_t HANDLE

Macro Definition Documentation

◆ FF_CODE_PAGE

#define FF_CODE_PAGE 932

Definition at line 87 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_FS_EXFAT

#define FF_FS_EXFAT 0

Definition at line 234 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_FS_LOCK

#define FF_FS_LOCK 0

Definition at line 266 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_FS_MINIMIZE

#define FF_FS_MINIMIZE 0

Definition at line 18 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_FS_NOFSINFO

#define FF_FS_NOFSINFO 0

Definition at line 254 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_FS_NORTC

#define FF_FS_NORTC 0

Definition at line 240 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_FS_READONLY

#define FF_FS_READONLY 0

Definition at line 11 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_FS_REENTRANT

#define FF_FS_REENTRANT 0

Definition at line 279 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_FS_RPATH

#define FF_FS_RPATH 0

Definition at line 156 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_FS_TIMEOUT

#define FF_FS_TIMEOUT 1000

Definition at line 280 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_FS_TINY

#define FF_FS_TINY 0

Definition at line 227 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_LBA64

#define FF_LBA64 0

Definition at line 206 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_LFN_BUF

#define FF_LFN_BUF 255

Definition at line 148 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_LFN_UNICODE

#define FF_LFN_UNICODE 0

Definition at line 136 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_MAX_LFN

#define FF_MAX_LFN 255

Definition at line 117 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_MAX_SS

#define FF_MAX_SS 512

Definition at line 197 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_MIN_GPT

#define FF_MIN_GPT 0x10000000

Definition at line 211 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_MIN_SS

#define FF_MIN_SS 512

Definition at line 196 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_MULTI_PARTITION

#define FF_MULTI_PARTITION 0

Definition at line 187 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_NORTC_MDAY

#define FF_NORTC_MDAY 1

Definition at line 242 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_NORTC_MON

#define FF_NORTC_MON 1

Definition at line 241 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_NORTC_YEAR

#define FF_NORTC_YEAR 2020

Definition at line 243 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_PRINT_FLOAT

#define FF_PRINT_FLOAT 0

Definition at line 61 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_PRINT_LLI

#define FF_PRINT_LLI 0

Definition at line 60 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_SFN_BUF

#define FF_SFN_BUF 12

Definition at line 149 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_STR_VOLUME_ID

#define FF_STR_VOLUME_ID 0

Definition at line 173 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_STRF_ENCODE

#define FF_STRF_ENCODE 0

Definition at line 62 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_SYNC_t

#define FF_SYNC_t HANDLE

Definition at line 281 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_USE_CHMOD

#define FF_USE_CHMOD 0

Definition at line 45 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_USE_EXPAND

#define FF_USE_EXPAND 0

Definition at line 41 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_USE_FASTSEEK

#define FF_USE_FASTSEEK 0

Definition at line 37 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_USE_FIND

#define FF_USE_FIND 0

Definition at line 28 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_USE_FORWARD

#define FF_USE_FORWARD 0

Definition at line 55 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_USE_LABEL

#define FF_USE_LABEL 0

Definition at line 50 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_USE_LFN

#define FF_USE_LFN 0

Definition at line 116 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_USE_MKFS

#define FF_USE_MKFS 0

Definition at line 33 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_USE_STRFUNC

#define FF_USE_STRFUNC 0

Definition at line 59 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_USE_TRIM

#define FF_USE_TRIM 0

Definition at line 216 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_VOLUME_STRS

#define FF_VOLUME_STRS "RAM","NAND","CF","SD","SD2","USB","USB2","USB3"

Definition at line 174 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_VOLUMES

#define FF_VOLUMES 1

Definition at line 169 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FFCONF_DEF

#define FFCONF_DEF 86631 /* Revision ID */

Definition at line 5 of file at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h.


AT32F435/437 Firmwary Library: ffconf.h Source File

  • at_start_f435
  • examples
  • usb_host
  • two_otg_host_demo
  • inc
at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h
Go to the documentation of this file.
1/*---------------------------------------------------------------------------/
2/ FatFs Functional Configurations
3/---------------------------------------------------------------------------*/
4
5#define FFCONF_DEF 86631 /* Revision ID */
6
7/*---------------------------------------------------------------------------/
8/ Function Configurations
9/---------------------------------------------------------------------------*/
10
11#define FF_FS_READONLY 0
12/* This option switches read-only configuration. (0:Read/Write or 1:Read-only)
13/ Read-only configuration removes writing API functions, f_write(), f_sync(),
14/ f_unlink(), f_mkdir(), f_chmod(), f_rename(), f_truncate(), f_getfree()
15/ and optional writing functions as well. */
16
17
18#define FF_FS_MINIMIZE 0
19/* This option defines minimization level to remove some basic API functions.
20/
21/ 0: Basic functions are fully enabled.
22/ 1: f_stat(), f_getfree(), f_unlink(), f_mkdir(), f_truncate() and f_rename()
23/ are removed.
24/ 2: f_opendir(), f_readdir() and f_closedir() are removed in addition to 1.
25/ 3: f_lseek() function is removed in addition to 2. */
26
27
28#define FF_USE_FIND 0
29/* This option switches filtered directory read functions, f_findfirst() and
30/ f_findnext(). (0:Disable, 1:Enable 2:Enable with matching altname[] too) */
31
32
33#define FF_USE_MKFS 0
34/* This option switches f_mkfs() function. (0:Disable or 1:Enable) */
35
36
37#define FF_USE_FASTSEEK 0
38/* This option switches fast seek function. (0:Disable or 1:Enable) */
39
40
41#define FF_USE_EXPAND 0
42/* This option switches f_expand function. (0:Disable or 1:Enable) */
43
44
45#define FF_USE_CHMOD 0
46/* This option switches attribute manipulation functions, f_chmod() and f_utime().
47/ (0:Disable or 1:Enable) Also FF_FS_READONLY needs to be 0 to enable this option. */
48
49
50#define FF_USE_LABEL 0
51/* This option switches volume label functions, f_getlabel() and f_setlabel().
52/ (0:Disable or 1:Enable) */
53
54
55#define FF_USE_FORWARD 0
56/* This option switches f_forward() function. (0:Disable or 1:Enable) */
57
58
59#define FF_USE_STRFUNC 0
60#define FF_PRINT_LLI 0
61#define FF_PRINT_FLOAT 0
62#define FF_STRF_ENCODE 0
63/* FF_USE_STRFUNC switches string functions, f_gets(), f_putc(), f_puts() and
64/ f_printf().
65/
66/ 0: Disable. FF_PRINT_LLI, FF_PRINT_FLOAT and FF_STRF_ENCODE have no effect.
67/ 1: Enable without LF-CRLF conversion.
68/ 2: Enable with LF-CRLF conversion.
69/
70/ FF_PRINT_LLI = 1 makes f_printf() support long long argument and FF_PRINT_FLOAT = 1/2
71 makes f_printf() support floating point argument. These features want C99 or later.
72/ When FF_LFN_UNICODE >= 1 with LFN enabled, string functions convert the character
73/ encoding in it. FF_STRF_ENCODE selects assumption of character encoding ON THE FILE
74/ to be read/written via those functions.
75/
76/ 0: ANSI/OEM in current CP
77/ 1: Unicode in UTF-16LE
78/ 2: Unicode in UTF-16BE
79/ 3: Unicode in UTF-8
80*/
81
82
83/*---------------------------------------------------------------------------/
84/ Locale and Namespace Configurations
85/---------------------------------------------------------------------------*/
86
87#define FF_CODE_PAGE 932
88/* This option specifies the OEM code page to be used on the target system.
89/ Incorrect code page setting can cause a file open failure.
90/
91/ 437 - U.S.
92/ 720 - Arabic
93/ 737 - Greek
94/ 771 - KBL
95/ 775 - Baltic
96/ 850 - Latin 1
97/ 852 - Latin 2
98/ 855 - Cyrillic
99/ 857 - Turkish
100/ 860 - Portuguese
101/ 861 - Icelandic
102/ 862 - Hebrew
103/ 863 - Canadian French
104/ 864 - Arabic
105/ 865 - Nordic
106/ 866 - Russian
107/ 869 - Greek 2
108/ 932 - Japanese (DBCS)
109/ 936 - Simplified Chinese (DBCS)
110/ 949 - Korean (DBCS)
111/ 950 - Traditional Chinese (DBCS)
112/ 0 - Include all code pages above and configured by f_setcp()
113*/
114
115
116#define FF_USE_LFN 0
117#define FF_MAX_LFN 255
118/* The FF_USE_LFN switches the support for LFN (long file name).
119/
120/ 0: Disable LFN. FF_MAX_LFN has no effect.
121/ 1: Enable LFN with static working buffer on the BSS. Always NOT thread-safe.
122/ 2: Enable LFN with dynamic working buffer on the STACK.
123/ 3: Enable LFN with dynamic working buffer on the HEAP.
124/
125/ To enable the LFN, ffunicode.c needs to be added to the project. The LFN function
126/ requiers certain internal working buffer occupies (FF_MAX_LFN + 1) * 2 bytes and
127/ additional (FF_MAX_LFN + 44) / 15 * 32 bytes when exFAT is enabled.
128/ The FF_MAX_LFN defines size of the working buffer in UTF-16 code unit and it can
129/ be in range of 12 to 255. It is recommended to be set it 255 to fully support LFN
130/ specification.
131/ When use stack for the working buffer, take care on stack overflow. When use heap
132/ memory for the working buffer, memory management functions, ff_memalloc() and
133/ ff_memfree() exemplified in ffsystem.c, need to be added to the project. */
134
135
136#define FF_LFN_UNICODE 0
137/* This option switches the character encoding on the API when LFN is enabled.
138/
139/ 0: ANSI/OEM in current CP (TCHAR = char)
140/ 1: Unicode in UTF-16 (TCHAR = WCHAR)
141/ 2: Unicode in UTF-8 (TCHAR = char)
142/ 3: Unicode in UTF-32 (TCHAR = DWORD)
143/
144/ Also behavior of string I/O functions will be affected by this option.
145/ When LFN is not enabled, this option has no effect. */
146
147
148#define FF_LFN_BUF 255
149#define FF_SFN_BUF 12
150/* This set of options defines size of file name members in the FILINFO structure
151/ which is used to read out directory items. These values should be suffcient for
152/ the file names to read. The maximum possible length of the read file name depends
153/ on character encoding. When LFN is not enabled, these options have no effect. */
154
155
156#define FF_FS_RPATH 0
157/* This option configures support for relative path.
158/
159/ 0: Disable relative path and remove related functions.
160/ 1: Enable relative path. f_chdir() and f_chdrive() are available.
161/ 2: f_getcwd() function is available in addition to 1.
162*/
163
164
165/*---------------------------------------------------------------------------/
166/ Drive/Volume Configurations
167/---------------------------------------------------------------------------*/
168
169#define FF_VOLUMES 1
170/* Number of volumes (logical drives) to be used. (1-10) */
171
172
173#define FF_STR_VOLUME_ID 0
174#define FF_VOLUME_STRS "RAM","NAND","CF","SD","SD2","USB","USB2","USB3"
175/* FF_STR_VOLUME_ID switches support for volume ID in arbitrary strings.
176/ When FF_STR_VOLUME_ID is set to 1 or 2, arbitrary strings can be used as drive
177/ number in the path name. FF_VOLUME_STRS defines the volume ID strings for each
178/ logical drives. Number of items must not be less than FF_VOLUMES. Valid
179/ characters for the volume ID strings are A-Z, a-z and 0-9, however, they are
180/ compared in case-insensitive. If FF_STR_VOLUME_ID >= 1 and FF_VOLUME_STRS is
181/ not defined, a user defined volume string table needs to be defined as:
182/
183/ const char* VolumeStr[FF_VOLUMES] = {"ram","flash","sd","usb",...
184*/
185
186
187#define FF_MULTI_PARTITION 0
188/* This option switches support for multiple volumes on the physical drive.
189/ By default (0), each logical drive number is bound to the same physical drive
190/ number and only an FAT volume found on the physical drive will be mounted.
191/ When this function is enabled (1), each logical drive number can be bound to
192/ arbitrary physical drive and partition listed in the VolToPart[]. Also f_fdisk()
193/ funciton will be available. */
194
195
196#define FF_MIN_SS 512
197#define FF_MAX_SS 512
198/* This set of options configures the range of sector size to be supported. (512,
199/ 1024, 2048 or 4096) Always set both 512 for most systems, generic memory card and
200/ harddisk, but a larger value may be required for on-board flash memory and some
201/ type of optical media. When FF_MAX_SS is larger than FF_MIN_SS, FatFs is configured
202/ for variable sector size mode and disk_ioctl() function needs to implement
203/ GET_SECTOR_SIZE command. */
204
205
206#define FF_LBA64 0
207/* This option switches support for 64-bit LBA. (0:Disable or 1:Enable)
208/ To enable the 64-bit LBA, also exFAT needs to be enabled. (FF_FS_EXFAT == 1) */
209
210
211#define FF_MIN_GPT 0x10000000
212/* Minimum number of sectors to switch GPT as partitioning format in f_mkfs and
213/ f_fdisk function. 0x100000000 max. This option has no effect when FF_LBA64 == 0. */
214
215
216#define FF_USE_TRIM 0
217/* This option switches support for ATA-TRIM. (0:Disable or 1:Enable)
218/ To enable Trim function, also CTRL_TRIM command should be implemented to the
219/ disk_ioctl() function. */
220
221
222
223/*---------------------------------------------------------------------------/
224/ System Configurations
225/---------------------------------------------------------------------------*/
226
227#define FF_FS_TINY 0
228/* This option switches tiny buffer configuration. (0:Normal or 1:Tiny)
229/ At the tiny configuration, size of file object (FIL) is shrinked FF_MAX_SS bytes.
230/ Instead of private sector buffer eliminated from the file object, common sector
231/ buffer in the filesystem object (FATFS) is used for the file data transfer. */
232
233
234#define FF_FS_EXFAT 0
235/* This option switches support for exFAT filesystem. (0:Disable or 1:Enable)
236/ To enable exFAT, also LFN needs to be enabled. (FF_USE_LFN >= 1)
237/ Note that enabling exFAT discards ANSI C (C89) compatibility. */
238
239
240#define FF_FS_NORTC 0
241#define FF_NORTC_MON 1
242#define FF_NORTC_MDAY 1
243#define FF_NORTC_YEAR 2020
244/* The option FF_FS_NORTC switches timestamp functiton. If the system does not have
245/ any RTC function or valid timestamp is not needed, set FF_FS_NORTC = 1 to disable
246/ the timestamp function. Every object modified by FatFs will have a fixed timestamp
247/ defined by FF_NORTC_MON, FF_NORTC_MDAY and FF_NORTC_YEAR in local time.
248/ To enable timestamp function (FF_FS_NORTC = 0), get_fattime() function need to be
249/ added to the project to read current time form real-time clock. FF_NORTC_MON,
250/ FF_NORTC_MDAY and FF_NORTC_YEAR have no effect.
251/ These options have no effect in read-only configuration (FF_FS_READONLY = 1). */
252
253
254#define FF_FS_NOFSINFO 0
255/* If you need to know correct free space on the FAT32 volume, set bit 0 of this
256/ option, and f_getfree() function at first time after volume mount will force
257/ a full FAT scan. Bit 1 controls the use of last allocated cluster number.
258/
259/ bit0=0: Use free cluster count in the FSINFO if available.
260/ bit0=1: Do not trust free cluster count in the FSINFO.
261/ bit1=0: Use last allocated cluster number in the FSINFO if available.
262/ bit1=1: Do not trust last allocated cluster number in the FSINFO.
263*/
264
265
266#define FF_FS_LOCK 0
267/* The option FF_FS_LOCK switches file lock function to control duplicated file open
268/ and illegal operation to open objects. This option must be 0 when FF_FS_READONLY
269/ is 1.
270/
271/ 0: Disable file lock function. To avoid volume corruption, application program
272/ should avoid illegal open, remove and rename to the open objects.
273/ >0: Enable file lock function. The value defines how many files/sub-directories
274/ can be opened simultaneously under file lock control. Note that the file
275/ lock control is independent of re-entrancy. */
276
277
278/* #include <somertos.h> // O/S definitions */
279#define FF_FS_REENTRANT 0
280#define FF_FS_TIMEOUT 1000
281#define FF_SYNC_t HANDLE
282/* The option FF_FS_REENTRANT switches the re-entrancy (thread safe) of the FatFs
283/ module itself. Note that regardless of this option, file access to different
284/ volume is always re-entrant and volume control functions, f_mount(), f_mkfs()
285/ and f_fdisk() function, are always not re-entrant. Only file/directory access
286/ to the same volume is under control of this function.
287/
288/ 0: Disable re-entrancy. FF_FS_TIMEOUT and FF_SYNC_t have no effect.
289/ 1: Enable re-entrancy. Also user provided synchronization handlers,
290/ ff_req_grant(), ff_rel_grant(), ff_del_syncobj() and ff_cre_syncobj()
291/ function, must be added to the project. Samples are available in
292/ option/syscall.c.
293/
294/ The FF_FS_TIMEOUT defines timeout period in unit of time tick.
295/ The FF_SYNC_t defines O/S dependent sync object type. e.g. HANDLE, ID, OS_EVENT*,
296/ SemaphoreHandle_t and etc. A header file for O/S definitions needs to be
297/ included somewhere in the scope of ff.h. */
298
299
300
301/*--- End of configuration options ---*/


AT32F435/437 Firmwary Library: usbh_user.h File Reference

  • at_start_f435
  • examples
  • usb_host
  • two_otg_host_demo
  • inc
Variables
at_start_f435/examples/usb_host/two_otg_host_demo/inc/usbh_user.h File Reference

usb host user header file More...

#include "usbh_core.h"

Go to the source code of this file.

Variables

usbh_user_handler_type usbh_user_handle

Detailed Description

usb host user header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/usb_host/two_otg_host_demo/inc/usbh_user.h.


AT32F435/437 Firmwary Library: usbh_user.h Source File

  • at_start_f435
  • examples
  • usb_host
  • two_otg_host_demo
  • inc
at_start_f435/examples/usb_host/two_otg_host_demo/inc/usbh_user.h
Go to the documentation of this file.
1
26/* define to prevent recursive inclusion -------------------------------------*/
27#ifndef __USBH_USER_H
28#define __USBH_USER_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "usbh_core.h"
35
36extern usbh_user_handler_type usbh_user_handle;
37#ifdef __cplusplus
38}
39#endif
40
41#endif
42
43
usbh_user_handle
usbh_user_handler_type usbh_user_handle
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:50
usbh_core.h
usb host core header file


AT32F435/437 Firmwary Library: usbh_msc_diskio.c File Reference

  • at_start_f435
  • examples
  • usb_host
  • two_otg_host_demo
  • src
Macros | Functions | Variables
at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c File Reference

usb mass storage disk io More...

#include "ff.h"
#include "diskio.h"
#include "usb_core.h"
#include "usbh_msc_class.h"

Go to the source code of this file.

Macros

#define | DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */
#define | DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */
#define | DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */

Functions

DSTATUS | disk_status (BYTE pdrv)
DSTATUS | disk_initialize (BYTE pdrv)
DRESULT | disk_read (BYTE pdrv, BYTE *buff, LBA_t sector, UINT count)
DRESULT | disk_write (BYTE pdrv, const BYTE *buff, LBA_t sector, UINT count)
DRESULT | disk_ioctl (BYTE pdrv, BYTE cmd, void *buff)
DWORD | get_fattime (void)

Variables

otg_core_type otg_core_struct

Detailed Description

usb mass storage disk io

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c.


AT32F435/437 Firmwary Library: usbh_msc_diskio.c Source File

  • at_start_f435
  • examples
  • usb_host
  • two_otg_host_demo
  • src
at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c
Go to the documentation of this file.
1
26#include "ff.h" /* Obtains integer types */
27#include "diskio.h" /* Declarations of disk functions */
28#include "usb_core.h"
29#include "usbh_msc_class.h"
38extern otg_core_type otg_core_struct;
39
40/* Definitions of physical drive number for each drive */
41#define DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */
42#define DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */
43#define DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */
44
45
46/*-----------------------------------------------------------------------*/
47/* Get Drive Status */
48/*-----------------------------------------------------------------------*/
49
50DSTATUS disk_status (
51 BYTE pdrv /* Physical drive nmuber to identify the drive */
52)
53{
54 if(usbh_msc_is_ready(&otg_core_struct.host, pdrv) == MSC_OK)
55 {
56 return RES_OK;
57 }
58
59 return RES_ERROR;
60}
61
62
63
64/*-----------------------------------------------------------------------*/
65/* Inidialize a Drive */
66/*-----------------------------------------------------------------------*/
67
68DSTATUS disk_initialize (
69 BYTE pdrv /* Physical drive nmuber to identify the drive */
70)
71{
72 return RES_OK;
73}
74
75
76
77/*-----------------------------------------------------------------------*/
78/* Read Sector(s) */
79/*-----------------------------------------------------------------------*/
80DRESULT disk_read (
81 BYTE pdrv, /* Physical drive nmuber to identify the drive */
82 BYTE *buff, /* Data buffer to store read data */
83 LBA_t sector, /* Start sector in LBA */
84 UINT count /* Number of sectors to read */
85)
86{
87 usb_sts_type status;
88
89 status = usbh_msc_read(&otg_core_struct.host, sector, count, buff, pdrv);
90
91 if(status == USB_OK)
92 return RES_OK;
93
94 return RES_ERROR;
95}
96
97
98
99/*-----------------------------------------------------------------------*/
100/* Write Sector(s) */
101/*-----------------------------------------------------------------------*/
102
103#if FF_FS_READONLY == 0
104
105DRESULT disk_write (
106 BYTE pdrv, /* Physical drive nmuber to identify the drive */
107 const BYTE *buff, /* Data to be written */
108 LBA_t sector, /* Start sector in LBA */
109 UINT count /* Number of sectors to write */
110)
111{
112 usb_sts_type status;
113
114 status = usbh_msc_write(&otg_core_struct.host, sector, count, (uint8_t *)buff, pdrv);
115
116 if(status == USB_OK)
117 return RES_OK;
118
119 return RES_ERROR;
120
121
122}
123
124#endif
125
126
127/*-----------------------------------------------------------------------*/
128/* Miscellaneous Functions */
129/*-----------------------------------------------------------------------*/
130
131DRESULT disk_ioctl (
132 BYTE pdrv, /* Physical drive nmuber (0..) */
133 BYTE cmd, /* Control code */
134 void *buff /* Buffer to send/receive control data */
135)
136{
137 usbh_core_type *host = (usbh_core_type *)&otg_core_struct.host;
138 usbh_msc_type *pmsc = (usbh_msc_type *)host->class_handler->pdata;
139 DRESULT res = RES_OK;
140 switch(cmd)
141 {
142 case CTRL_SYNC:
143 res = RES_OK;
144 break;
145 case GET_SECTOR_COUNT:
146 *(DWORD*)buff = pmsc->l_unit_n[pdrv].capacity.blk_nbr;
147 break;
148 case GET_SECTOR_SIZE:
149 *(DWORD*)buff = pmsc->l_unit_n[pdrv].capacity.blk_size;
150 break;
151 case GET_BLOCK_SIZE:
152 *(DWORD*)buff = pmsc->l_unit_n[pdrv].capacity.blk_size;
153 break;
154 default:
155 res = RES_PARERR;
156 }
157 return res;
158}
159
160/*-----------------------------------------------------------------------*/
161/* get_fattime */
162/*-----------------------------------------------------------------------*/
163DWORD get_fattime (void)
164{
165 return 0;
166}
167
disk_read
DRESULT disk_read(BYTE pdrv, BYTE *buff, LBA_t sector, UINT count)
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c:80
disk_initialize
DSTATUS disk_initialize(BYTE pdrv)
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c:68
disk_status
DSTATUS disk_status(BYTE pdrv)
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c:50
disk_ioctl
DRESULT disk_ioctl(BYTE pdrv, BYTE cmd, void *buff)
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c:131
disk_write
DRESULT disk_write(BYTE pdrv, const BYTE *buff, LBA_t sector, UINT count)
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c:105
otg_core_struct
otg_core_type otg_core_struct
Definition: project/at_start_f435/examples/acc/calibration/src/main.c:45
get_fattime
DWORD get_fattime(void)
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c:163
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_OK
@ USB_OK
Definition: usb_std.h:268
MSC_OK
@ MSC_OK
Definition: usbh_msc_bot_scsi.h:117
usbh_msc_write
usb_sts_type usbh_msc_write(void *uhost, uint32_t address, uint32_t len, uint8_t *buffer, uint8_t lun)
usb host msc write
Definition: usbh_msc_class.c:486
usbh_msc_read
usb_sts_type usbh_msc_read(void *uhost, uint32_t address, uint32_t len, uint8_t *buffer, uint8_t lun)
usb host msc read
Definition: usbh_msc_class.c:450
usbh_msc_is_ready
msc_error_type usbh_msc_is_ready(void *uhost, uint8_t lun)
usb host msc clear feature
Definition: usbh_msc_class.c:375
msc_scsi_data_capacity::blk_nbr
uint32_t blk_nbr
Definition: usbh_msc_bot_scsi.h:145
otg_core_type
usb otg core struct type
Definition: usb_core.h:92
usbh_msc_type
usb msc struct
Definition: usbh_msc_class.h:94
usbh_msc_type::l_unit_n
usbh_msc_unit_type l_unit_n[0x2]
Definition: usbh_msc_class.h:115
usbh_msc_unit_type::capacity
msc_scsi_data_capacity capacity
Definition: usbh_msc_bot_scsi.h:194
usb_core.h
usb core header file
usbh_msc_class.h
usb host msc class header file


AT32F435/437 Firmwary Library: usbh_user.c File Reference

  • at_start_f435
  • examples
  • usb_host
  • two_otg_host_demo
  • src
Enumerations | Functions | Variables
at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c File Reference

usb user function More...

#include "usbh_user.h"
#include "ff.h"

Go to the source code of this file.

Enumerations

enum msc_usr_state {
USR_IDLE , USR_APP , USR_FINISH , USR_IDLE ,
USR_APP , USR_FINISH , USR_IDLE , USR_APP ,
USR_FINISH , USR_IDLE , USR_APP , USR_FINISH
}

Functions

static usb_sts_type | usbh_user_init (void)
usb host init user handler More...
static usb_sts_type | usbh_user_reset (void)
usb host reset user handler More...
static usb_sts_type | usbh_user_attached (void)
usb host check device attached More...
static usb_sts_type | usbh_user_disconnect (void)
usb host discconet user handler More...
static usb_sts_type | usbh_user_speed (uint8_t speed)
usb host speed user handler More...
static usb_sts_type | usbh_user_mfc_string (void *string)
usb host manufacturer string user handler More...
static usb_sts_type | usbh_user_product_string (void *string)
usb host product string user handler More...
static usb_sts_type | usbh_user_serial_string (void *string)
usb host serial string user handler More...
static usb_sts_type | usbh_user_enumeration_done (void)
usb host enumeration done user handler More...
static usb_sts_type | usbh_user_application (void)
static usb_sts_type | usbh_user_active_vbus (void *uhost, confirm_state state)
usb host active vbus user handler More...
static usb_sts_type | usbh_user_not_support (void)
usb host not support user handler More...

Variables

usbh_user_handler_type | usbh_user_handle
msc_usr_state usr_state = USR_IDLE
FIL | file
usb host application user handler More...
FATFS | fs

Detailed Description

usb user function

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c.


AT32F435/437 Firmwary Library: usbh_user.c Source File

  • at_start_f435
  • examples
  • usb_host
  • two_otg_host_demo
  • src
at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c
Go to the documentation of this file.
1
26#include "usbh_user.h"
27#include "ff.h"
28
37static usb_sts_type usbh_user_init(void);
38static usb_sts_type usbh_user_reset(void);
39static usb_sts_type usbh_user_attached(void);
40static usb_sts_type usbh_user_disconnect(void);
41static usb_sts_type usbh_user_speed(uint8_t speed);
42static usb_sts_type usbh_user_mfc_string(void *string);
43static usb_sts_type usbh_user_product_string(void *string);
44static usb_sts_type usbh_user_serial_string(void *string);
45static usb_sts_type usbh_user_enumeration_done(void);
46static usb_sts_type usbh_user_application(void);
47static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state);
48static usb_sts_type usbh_user_not_support(void);
49
50
51usbh_user_handler_type usbh_user_handle =
52{
53 usbh_user_init,
54 usbh_user_reset,
55 usbh_user_attached,
56 usbh_user_disconnect,
57 usbh_user_speed,
58 usbh_user_mfc_string,
59 usbh_user_product_string,
60 usbh_user_serial_string,
61 usbh_user_enumeration_done,
62 usbh_user_application,
63 usbh_user_active_vbus,
64 usbh_user_not_support,
65};
66
67typedef enum
68{
69 USR_IDLE,
70 USR_APP,
71 USR_FINISH
72}msc_usr_state;
73
74 msc_usr_state usr_state = USR_IDLE;
75
81static usb_sts_type usbh_user_init(void)
82{
83 usb_sts_type status = USB_OK;
84
85 return status;
86}
87
93static usb_sts_type usbh_user_reset(void)
94{
95 usb_sts_type status = USB_OK;
96
97 return status;
98}
99
105static usb_sts_type usbh_user_attached(void)
106{
107 usb_sts_type status = USB_OK;
108 USBH_DEBUG("USB Device Attached");
109 return status;
110}
111
117static usb_sts_type usbh_user_disconnect(void)
118{
119 usb_sts_type status = USB_OK;
120 usr_state = USR_IDLE;
121 USBH_DEBUG("Device Disconnect");
122 return status;
123}
124
130static usb_sts_type usbh_user_speed(uint8_t speed)
131{
132 usb_sts_type status = USB_OK;
133 if(speed == USB_PRTSPD_FULL_SPEED)
134 {
135 USBH_DEBUG("This is a Full-Speed device");
136 }
137 else if(speed == USB_PRTSPD_LOW_SPEED)
138 {
139 USBH_DEBUG("This is a Low-Speed device");
140 }
141 return status;
142}
143
149static usb_sts_type usbh_user_mfc_string(void *string)
150{
151 usb_sts_type status = USB_OK;
152 USBH_DEBUG("Manufacturer: %s", (uint8_t *)string);
153 return status;
154}
155
161static usb_sts_type usbh_user_product_string(void *string)
162{
163 usb_sts_type status = USB_OK;
164 USBH_DEBUG("Product: %s", (uint8_t *)string);
165 return status;
166}
167
173static usb_sts_type usbh_user_serial_string(void *string)
174{
175 usb_sts_type status = USB_OK;
176 USBH_DEBUG("Serial: %s", (uint8_t *)string);
177 return status;
178}
179
185static usb_sts_type usbh_user_enumeration_done(void)
186{
187 usb_sts_type status = USB_OK;
188 USBH_DEBUG("Enumeration done");
189 return status;
190}
191
197FIL file;
198FATFS fs;
199static usb_sts_type usbh_user_application(void)
200{
201 usb_sts_type status = USB_OK;
202 FRESULT res;
203
204 uint32_t len;
205 uint8_t write_data[] = "usb host msc demo";
206 uint8_t read_data[32] = {0};
207
208 switch(usr_state)
209 {
210 case USR_IDLE:
211 usr_state = USR_APP;
212 break;
213 case USR_APP:
214 res = f_mount(&fs, "", 0);
215 if(res == FR_OK)
216 {
217 /* start write data */
218 if(f_open(&file, "0:AT32.txt", FA_CREATE_ALWAYS | FA_WRITE) != FR_OK)
219 {
220 // error
221 USBH_DEBUG("Open AT32.txt failed");
222 }
223 else
224 {
225 res = f_write(&file, write_data, sizeof(write_data), &len);
226 if(res != FR_OK || len == 0)
227 {
228 //write error
229 USBH_DEBUG("Write AT32.txt failed");
230 }
231 else
232 {
233 //write success
234 USBH_DEBUG("Write AT32.txt Success");
235 }
236 f_close(&file);
237 }
238
239 /* start read file */
240 if(f_open(&file, "0:AT32.txt", FA_READ) != FR_OK)
241 {
242 // error
243 USBH_DEBUG("Open AT32.txt failed");
244 }
245 else
246 {
247 res = f_read(&file, read_data, sizeof(read_data), &len);
248 if(res != FR_OK || len == 0)
249 {
250 //read error
251 USBH_DEBUG("Read AT32.txt failed");
252 }
253 else
254 {
255 //read success
256 USBH_DEBUG("Read AT32.txt Success");
257 }
258 f_close(&file);
259 }
260 f_mount(NULL, "", 0);
261 }
262 usr_state = USR_FINISH;
263 break;
264 case USR_FINISH:
265 break;
266 }
267 return status;
268}
269
278static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state)
279{
280 usb_sts_type status = USB_OK;
281 usbh_core_type *puhost = (usbh_core_type *)uhost;
282#ifdef USBH_5V_POWER_SWITCH
283 if(state == TRUE)
284 {
285 /* active vbus */
286 if(puhost->usb_reg == OTG1_GLOBAL)
287 {
288 gpio_bits_reset(OTG_PIN_POWER_SWITCH_GPIO, OTG_PIN_POWER_SWITCH);
289 }
290 else if(puhost->usb_reg == OTG2_GLOBAL)
291 {
292 gpio_bits_reset(OTG2_PIN_POWER_SWITCH_GPIO, OTG2_PIN_POWER_SWITCH);
293 }
294 }
295 else
296 {
297 /* deactive vubs */
298 if(puhost->usb_reg == OTG1_GLOBAL)
299 {
300 gpio_bits_set(OTG_PIN_POWER_SWITCH_GPIO, OTG_PIN_POWER_SWITCH);
301 }
302 else if(puhost->usb_reg == OTG2_GLOBAL)
303 {
304 gpio_bits_set(OTG2_PIN_POWER_SWITCH_GPIO, OTG2_PIN_POWER_SWITCH);
305 }
306 }
307#endif
308 return status;
309}
310
316static usb_sts_type usbh_user_not_support(void)
317{
318 usb_sts_type status = USB_OK;
319
320 return status;
321}
322
OTG_PIN_POWER_SWITCH_GPIO
#define OTG_PIN_POWER_SWITCH_GPIO
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h:91
OTG_PIN_POWER_SWITCH
#define OTG_PIN_POWER_SWITCH
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h:93
USBH_DEBUG
#define USBH_DEBUG(...)
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h:206
msc_usr_state
msc_usr_state
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:68
usbh_user_init
static usb_sts_type usbh_user_init(void)
usb host init user handler
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:81
file
FIL file
usb host application user handler
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:197
usbh_user_disconnect
static usb_sts_type usbh_user_disconnect(void)
usb host discconet user handler
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:117
usbh_user_not_support
static usb_sts_type usbh_user_not_support(void)
usb host not support user handler
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:316
OTG2_PIN_POWER_SWITCH
#define OTG2_PIN_POWER_SWITCH
Definition: project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h:129
OTG2_PIN_POWER_SWITCH_GPIO
#define OTG2_PIN_POWER_SWITCH_GPIO
Definition: project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h:127
usbh_user_application
static usb_sts_type usbh_user_application(void)
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:199
usbh_user_speed
static usb_sts_type usbh_user_speed(uint8_t speed)
usb host speed user handler
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:130
usbh_user_active_vbus
static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state)
usb host active vbus user handler
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:278
usbh_user_handle
usbh_user_handler_type usbh_user_handle
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:51
usbh_user_serial_string
static usb_sts_type usbh_user_serial_string(void *string)
usb host serial string user handler
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:173
usbh_user_reset
static usb_sts_type usbh_user_reset(void)
usb host reset user handler
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:93
msc_usr_state
msc_usr_state
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:68
usr_state
msc_usr_state usr_state
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:74
usbh_user_mfc_string
static usb_sts_type usbh_user_mfc_string(void *string)
usb host manufacturer string user handler
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:149
usbh_user_enumeration_done
static usb_sts_type usbh_user_enumeration_done(void)
usb host enumeration done user handler
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:185
usbh_user_attached
static usb_sts_type usbh_user_attached(void)
usb host check device attached
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:105
fs
FATFS fs
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:198
usbh_user_product_string
static usb_sts_type usbh_user_product_string(void *string)
usb host product string user handler
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:161
USR_APP
@ USR_APP
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:70
USR_FINISH
@ USR_FINISH
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:71
USR_IDLE
@ USR_IDLE
Definition: at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c:69
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
confirm_state
confirm_state
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f435_437_gpio.c:308
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f435_437_gpio.c:277
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
OTG2_GLOBAL
#define OTG2_GLOBAL
Definition: at32f435_437_usb.h:1329
OTG1_GLOBAL
#define OTG1_GLOBAL
usb host and device register define
Definition: at32f435_437_usb.h:1328
USB_PRTSPD_LOW_SPEED
#define USB_PRTSPD_LOW_SPEED
Definition: at32f435_437_usb.h:188
USB_PRTSPD_FULL_SPEED
#define USB_PRTSPD_FULL_SPEED
Definition: at32f435_437_usb.h:187
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_OK
@ USB_OK
Definition: usb_std.h:268


AT32F435/437 Firmwary Library: picture.h File Reference

  • at_start_f435
  • examples
  • xmc
  • lcd_8bit
  • inc
Variables
at_start_f435/examples/xmc/lcd_8bit/inc/picture.h File Reference

this file contains all the picture used for lcd display. More...

Go to the source code of this file.

Variables

const unsigned char | gimage_3 [51000]
const unsigned char | gimage_8 [51000]
const unsigned char | gimage_5 [51000]
const unsigned char | gimage_9 [51000]
const unsigned char | gimage_0 [51000]

Detailed Description

this file contains all the picture used for lcd display.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/xmc/lcd_8bit/inc/picture.h.

Variable Documentation

◆ gimage_0

const unsigned char gimage_0[51000]

Definition at line 12790 of file at_start_f435/examples/xmc/lcd_8bit/inc/picture.h.

Referenced by lcd_display_number().

◆ gimage_3

const unsigned char gimage_3[51000]

Definition at line 29 of file at_start_f435/examples/xmc/lcd_8bit/inc/picture.h.

Referenced by lcd_display_number().

◆ gimage_5

const unsigned char gimage_5[51000]

Definition at line 6410 of file at_start_f435/examples/xmc/lcd_8bit/inc/picture.h.

Referenced by lcd_display_number().

◆ gimage_8

const unsigned char gimage_8[51000]

Definition at line 3220 of file at_start_f435/examples/xmc/lcd_8bit/inc/picture.h.

Referenced by lcd_display_number().

◆ gimage_9

const unsigned char gimage_9[51000]

Definition at line 9600 of file at_start_f435/examples/xmc/lcd_8bit/inc/picture.h.

Referenced by lcd_display_number().


AT32F435/437 Firmwary Library: picture.h Source File

AT32F435_437_Firmware_Library_V2.0.9

project

at_start_f435

examples

xmc

lcd_8bit

inc

at_start_f435/examples/xmc/lcd_8bit/inc/picture.h

Go to the documentation of this file.

1

26#ifndef __PICTURE_H

27#define __PICTURE_H

28

29const unsigned char gimage_3[51000] = { /* 0X10,0X10,0X00,0X96,0X00,0XAA,0X01,0X1B, */

300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

940XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1130XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

1150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1320XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,

1330XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

1340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1500XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,

1510XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XDB,0XFF,0XDC,0XFF,0XDC,0XFF,0XDC,

1520XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

1530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1690XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,

1700XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFD,0XFF,0XFD,

1710XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

1720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1880XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,

1890XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,

1900XFF,0XFB,0XFF,0XFB,0XFF,0XFC,0XFF,0XFC,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,

1910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

1920XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2070XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFB,0XFF,0XFB,

2080XFF,0XFA,0XFF,0XFA,0XFF,0XF9,0XFF,0XF9,0XFF,0XF9,0XFF,0XF8,0XFF,0XF8,0XFF,0XF8,

2090XFF,0XF9,0XFF,0XF9,0XFF,0XFA,0XFF,0XFA,0XFF,0XFB,0XFF,0XFC,0XFF,0XFC,0XFF,0XFD,

2100XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2250XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,

2260XFF,0XFC,0XFF,0XFB,0XFF,0XFA,0XFF,0XF9,0XFF,0XF8,0XFF,0XF7,0XFF,0XF6,0XFF,0XF6,

2270XFF,0XF5,0XFF,0XF5,0XFF,0XF4,0XFF,0XF4,0XFF,0XF4,0XFF,0XF5,0XFF,0XF5,0XFF,0XF5,

2280XFF,0XF6,0XFF,0XF6,0XFF,0XF7,0XFF,0XF7,0XFF,0XF8,0XFF,0XF9,0XFF,0XFA,0XFF,0XFB,

2290XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

2310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2440XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFA,0XFF,0XF9,0XFF,0XD8,

2450XFF,0XD6,0XFF,0XD5,0XFF,0XF5,0XFF,0XF4,0XFF,0XF3,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,

2460XF7,0XF2,0XF7,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF3,

2470XFF,0XF3,0XFF,0XF4,0XFF,0XF5,0XFF,0XF6,0XFF,0XF7,0XFF,0XF8,0XFF,0XF9,0XFF,0XFB,

2480XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2490XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,

2630XFF,0XFA,0XFF,0XF9,0XFF,0XF8,0XFF,0XF6,0XFF,0XD5,0XF7,0XD4,0XFF,0XD2,0XF7,0XD2,

2640XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,

2650XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,

2660XFF,0XF2,0XFF,0XF3,0XFF,0XF3,0XFF,0XF5,0XFF,0XF6,0XFF,0XF7,0XFF,0XF8,0XFF,0XFA,

2670XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2680XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2810XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,0XFF,0XFA,0XFF,0XF8,0XFF,0XD6,0XFF,0XF5,

2820XFF,0XF4,0XFF,0XF3,0XFF,0XF2,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

2830XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

2840XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,

2850XFF,0XF2,0XFF,0XF2,0XFF,0XD3,0XFF,0XD4,0XFF,0XF5,0XFF,0XF7,0XFF,0XF9,0XFF,0XFB,

2860XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,

3000XFF,0XF9,0XFF,0XF8,0XF7,0XD7,0XF7,0XF5,0XF7,0XD2,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,

3010XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

3020XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

3030XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF1,

3040XFF,0XF2,0XFF,0XD2,0XFF,0XF3,0XFF,0XF5,0XFF,0XF7,0XFF,0XF9,0XFF,0XFB,0XFF,0XFD,

3050XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3180XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFA,0XFF,0XF8,0XFF,0XF6,0XFF,0XD5,

3190XF7,0XF4,0XF7,0XF2,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

3200XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

3210XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

3220XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF1,

3230XFF,0XF1,0XFF,0XF2,0XFF,0XF3,0XFF,0XF6,0XFF,0XF8,0XFF,0XFA,0XFF,0XFD,0XFF,0XFF,

3240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3360XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,

3370XFF,0XFB,0XFF,0XF9,0XFF,0XF6,0XFF,0XF4,0XFF,0XF3,0XFF,0XF2,0XFF,0XF1,0XFF,0XF0,

3380XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,

3390XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

3400XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

3410XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

3420XFF,0XF1,0XFF,0XF3,0XFF,0XD5,0XFF,0XD7,0XFF,0XFB,0XFF,0XFD,0XFF,0XFF,0XFF,0XDF,

3430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,

3550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFC,0XFF,0XFA,0XFF,0XF8,0XFF,0XD6,

3560XFF,0XD3,0XFF,0XF2,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

3570XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,

3580XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,

3590XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,

3600XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF1,

3610XFF,0XD3,0XFF,0XB5,0XFF,0XF8,0XFF,0XDB,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

3620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3740XFF,0XFE,0XFF,0XFC,0XFF,0XF9,0XFF,0XF7,0XFF,0XD4,0XFF,0XD3,0XFF,0XD1,0XFF,0XF0,

3750XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

3760XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

3770XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

3780XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

3790XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF1,0XFF,0XF2,0XF7,0XB3,

3800XFF,0XD6,0XFF,0XB8,0XFF,0XDB,0XFF,0XFD,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

3810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XFF,0XF9,

3930XFF,0XF6,0XFF,0XD4,0XFF,0XF2,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

3940XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

3950XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

3960XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

3970XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

3980XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XD1,0XFF,0XD3,0XF7,0XB5,

3990XFF,0XD8,0XFF,0XFB,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4110XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0XD9,0XFF,0XD6,0XFF,0XD3,0XFF,0XF1,

4120XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,

4130XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4140XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4150XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4160XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,

4170XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XD0,0XFF,0XF1,0XF7,0XB2,0XF7,0XB5,0XFF,0XD8,

4180XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFC,

4300XFF,0XFA,0XFF,0XF7,0XFF,0XD5,0XFF,0XD3,0XFF,0XF1,0XFF,0XEF,0XFF,0XEE,0XFF,0XED,

4310XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4320XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4330XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4340XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4350XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4360XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XF7,0XAF,0XF7,0X91,0XF7,0X95,0XFF,0XDB,0XFF,0XFD,

4370XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4480XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XD9,0XFF,0XF6,0XFF,0XD3,

4490XFF,0XF1,0XFF,0XF0,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

4500XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4510XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4520XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4530XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,

4540XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XCC,

4550XFF,0XED,0XFF,0XEE,0XF7,0X8F,0XEF,0X31,0XF7,0X98,0XFF,0XFC,0XFF,0XFE,0XFF,0XFE,

4560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

4670XFF,0XFD,0XFF,0XFC,0XFF,0XFA,0XFF,0XD6,0XFF,0XD2,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,

4680XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

4690XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4700XFF,0XEF,0XFF,0XEE,0XFF,0XEF,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4710XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,

4720XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,

4730XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XED,0XF7,0XCB,0XFF,0XEC,0XFF,0XED,

4740XF7,0XAE,0XE7,0X0F,0XEF,0X55,0XFF,0XFA,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,

4750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XFB,0XFF,0XF9,

4860XFF,0XD6,0XFF,0XD3,0XFF,0XF0,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,

4870XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

4880XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

4890XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

4900XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

4910XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,

4920XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XCE,0XE7,0X0E,

4930XDE,0XB0,0XFF,0XB8,0XFF,0XFC,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5040XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0XF9,0XFF,0XF6,0XFF,0XD3,0XFF,0XD1,

5050XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

5060XFF,0XEE,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

5070XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

5080XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

5090XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

5100XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,

5110XFF,0XED,0XFF,0XCC,0XFF,0XEC,0XFF,0XCC,0XFF,0XCE,0XEF,0X2E,0XCE,0X4D,0XDE,0XD2,

5120XFF,0XFB,0XFF,0XFE,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

5130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

5230XFF,0XFC,0XFF,0XF9,0XFF,0XF6,0XFF,0XF3,0XFF,0XF0,0XFF,0XEF,0XFF,0XEE,0XFF,0XED,

5240XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,

5250XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XCD,0XFF,0XCE,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,

5260XFF,0XEE,0XFF,0XED,0XFF,0XEE,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

5270XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

5280XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

5290XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCC,

5300XFF,0XCC,0XFF,0XED,0XFF,0XCE,0XF7,0X4E,0XCE,0X0B,0XC5,0XCD,0XFF,0X78,0XFF,0XFD,

5310XFF,0XBE,0XFF,0XDF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFA,0XFF,0XF7,

5420XFF,0XF3,0XFF,0XF0,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

5430XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,

5440XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

5450XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

5460XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

5470XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

5480XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,

5490XFF,0XCE,0XFF,0X6E,0XCE,0X0A,0XB5,0X6A,0XDE,0X73,0XFF,0XFC,0XFF,0XDD,0XFF,0XFF,

5500XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5600XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XF8,0XF7,0XD4,0XF7,0XD0,0XFF,0XEE,

5610XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,

5620XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCD,

5630XFF,0XED,0XFF,0XED,0XFF,0XCD,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

5640XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

5650XFF,0XCD,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCD,0XFF,0XED,

5660XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

5670XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCD,0XFF,0XCC,0XFF,0XCD,0XFF,0XAD,0XFF,0X8E,

5680XD6,0X2A,0XB5,0X29,0XB5,0X0D,0XFF,0X58,0XFF,0XFD,0XFF,0XDE,0XFF,0XFE,0XFF,0XDE,

5690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

5790XFF,0XFC,0XFF,0XF9,0XFF,0XD5,0XF7,0XB2,0XF7,0XAF,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,

5800XFF,0XEE,0XFF,0XEE,0XFF,0XCE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

5810XFF,0XEC,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCD,0XFF,0XCD,0XFF,0XED,0XFF,0XED,

5820XFF,0XCD,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

5830XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XCD,0XFF,0XCD,

5840XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XED,0XFF,0XCD,

5850XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

5860XFF,0XCD,0XFF,0XCD,0XFF,0XCC,0XFF,0XCD,0XFF,0XAD,0XFF,0XAE,0XDE,0X2A,0XB5,0X08,

5870XA4,0X69,0XDE,0X53,0XFF,0XDB,0XFF,0XDD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

5880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XFA,0XF7,0XD6,

5980XF7,0XB3,0XF7,0XD0,0XFF,0XCE,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XCE,

5990XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XF7,0XCC,0XFF,0XCD,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,

6000XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XAC,0XFF,0XAC,0XFF,0XCC,0XFF,0XCD,

6010XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCD,

6020XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCC,0XFF,0XCC,

6030XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

6040XFF,0XCD,0XFF,0XCD,0XFF,0XCC,0XFF,0XCC,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

6050XFF,0XCC,0XFF,0XEC,0XFF,0XAC,0XFF,0XAD,0XDE,0X2A,0XAC,0XC7,0X9C,0X47,0XBD,0X4E,

6060XF7,0X37,0XFF,0XDC,0XFF,0XFD,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6160XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0XF7,0XF7,0XB3,0XF7,0XB0,0XFF,0XCF,

6170XFF,0XEE,0XFF,0XCD,0XFF,0XEC,0XFF,0XEC,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

6180XFF,0XCD,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0X6B,0XF7,0X4A,0XF7,0X4A,0XF7,0X4B,

6190XF7,0X2B,0XF7,0X4B,0XF7,0X6B,0XF7,0X8B,0XFF,0XAC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,

6200XFF,0XCC,0XFF,0XCC,0XFF,0XED,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

6210XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAC,0XFF,0XAD,0XFF,0XAD,

6220XFF,0XAD,0XFF,0XAD,0XFF,0XCD,0XFF,0XCC,0XFF,0XCD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAD,

6230XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAC,0XFF,0XCC,

6240XFF,0X8B,0XFF,0X8D,0XD6,0X0A,0XAC,0X66,0XA4,0X47,0XAC,0XAA,0XD6,0X53,0XFF,0XDA,

6250XFF,0XFC,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

6350XFF,0XFC,0XFF,0XF8,0XF7,0XD4,0XF7,0XB0,0XF7,0XAF,0XFF,0XAE,0XFF,0X8E,0XFF,0XAD,

6360XFF,0XAC,0XFF,0XAB,0XFF,0XAC,0XFF,0XAD,0XFF,0X8D,0XFF,0X6C,0XF7,0X4B,0XF7,0X0A,

6370XEE,0XE9,0XEE,0XC8,0XEE,0X88,0XE6,0X87,0XE6,0X68,0XE6,0X47,0XE6,0X47,0XE6,0X47,

6380XDE,0X46,0XE6,0X87,0XEE,0XE9,0XF7,0X4A,0XFF,0X8B,0XFF,0X8C,0XFF,0XCD,0XFF,0X8C,

6390XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0X8C,0XFF,0XAD,0XFF,0XCD,0XFF,0X8C,0XFF,0X8C,

6400XFF,0XAC,0XFF,0XAC,0XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAC,0XFF,0XAC,

6410XFF,0XAC,0XFF,0XAC,0XFF,0XAD,0XFF,0XAD,0XFF,0X8D,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,

6420XFF,0X8C,0XFF,0X8C,0XFF,0XAD,0XFF,0X8C,0XFF,0XAC,0XFF,0XAB,0XF7,0X6B,0XFF,0X8D,

6430XCD,0XC9,0X9C,0X25,0X9C,0X47,0X9C,0X48,0XB5,0X4D,0XF7,0X78,0XFF,0XDC,0XFF,0XFE,

6440XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFA,0XF7,0XD6,

6540XF7,0XB1,0XF7,0XAF,0XFF,0XAD,0XFF,0XAD,0XFF,0X8D,0XFF,0X8D,0XFF,0X8C,0XFF,0X8C,

6550XFF,0X6C,0XFF,0X4C,0XF7,0X0B,0XF6,0XCA,0XEE,0XA9,0XEE,0X88,0XEE,0X88,0XEE,0X88,

6560XEE,0X68,0XF6,0X88,0XF6,0X68,0XF6,0X68,0XEE,0X47,0XEE,0X26,0XE6,0X45,0XE6,0X25,

6570XDE,0X05,0XD6,0X05,0XDE,0X68,0XF7,0X2B,0XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0X8D,

6580XFF,0X8D,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0XAC,0XFF,0X8C,0XFF,0X8C,

6590XFF,0X8C,0XFF,0X8D,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0XAC,0XFF,0X8C,0XFF,0X8C,

6600XFF,0X8D,0XFF,0X8D,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8B,0XFF,0X8B,0XFF,0X8C,

6610XFF,0X8D,0XFF,0X8D,0XFF,0X8B,0XFF,0XCC,0XFF,0X6B,0XFF,0X8D,0XCD,0XC9,0X8B,0XA3,

6620X8B,0XA5,0X9C,0X27,0X9C,0X89,0XD6,0X72,0XFF,0XFB,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

6630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6720XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XD8,0XF7,0X93,0XF7,0X6F,0XF7,0X8D,

6730XFF,0XAC,0XFF,0X8C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X2B,0XFE,0XEB,0XF6,0XCA,

6740XF6,0X89,0XEE,0X68,0XEE,0X68,0XF6,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,

6750XFE,0X68,0XF6,0X47,0XEE,0X06,0XE5,0XE6,0XD5,0X63,0XD5,0X83,0XD5,0XA4,0XD5,0XC5,

6760XD5,0XE6,0XD6,0X07,0XE6,0X69,0XFF,0X4D,0XFF,0X8D,0XFF,0X8D,0XFF,0X8D,0XFF,0X8C,

6770XFF,0X8C,0XFF,0X8C,0XFF,0XCC,0XFF,0X8B,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,

6780XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X6D,

6790XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6B,0XFF,0X6B,0XFF,0X8C,0XFF,0X6C,0XFF,0X6C,

6800XFF,0X8B,0XFF,0XAC,0XFF,0X6B,0XFF,0X6D,0XC5,0X69,0X73,0X01,0X83,0X84,0X94,0X07,

6810X8C,0X27,0XAD,0X2E,0XEF,0X18,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

6820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

6910XFF,0XFD,0XFF,0XD9,0XFF,0X95,0XF7,0X71,0XF7,0X6E,0XFF,0X6C,0XFF,0X8B,0XFF,0X8B,

6920XFF,0X6B,0XFF,0X4C,0XFF,0X0C,0XFE,0XAA,0XEE,0X69,0XEE,0X48,0XF6,0X68,0XF6,0X89,

6930XFE,0XA9,0XFE,0XA9,0XFE,0X89,0XFE,0XA9,0XFE,0XA8,0XFE,0X88,0XFE,0X88,0XF6,0X67,

6940XF6,0X27,0XEE,0X27,0XEE,0X06,0XDD,0X63,0XBC,0XC1,0XAC,0X60,0XA4,0X40,0XB4,0XE3,

6950XD5,0XA8,0XEE,0XCC,0XF7,0X0D,0XFF,0X6E,0XFF,0X8D,0XFF,0X6C,0XFF,0X6B,0XFF,0X8B,

6960XFF,0XAB,0XFF,0X6B,0XFF,0X8B,0XFF,0X8C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,

6970XFF,0X6C,0XFF,0X6C,0XFF,0X8C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,

6980XFF,0X6B,0XFF,0X6B,0XFF,0X6B,0XFF,0X4C,0XFF,0X6C,0XF7,0X2B,0XFF,0X8B,0XFF,0X6B,

6990XFF,0X6C,0XF7,0X4D,0XBD,0X27,0X6A,0XC0,0X83,0X63,0X94,0X27,0X94,0X27,0X94,0X49,

7000XDE,0X95,0XFF,0XBB,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XFF,0XDA,0XFF,0XB6,

7100XF7,0X51,0XF7,0X6E,0XF7,0X4C,0XFF,0X6B,0XFF,0X8B,0XFF,0X6A,0XFF,0X4A,0XFF,0X0B,

7110XF6,0X8A,0XF6,0X4A,0XEE,0X48,0XF6,0X68,0XFE,0XA9,0XFE,0XC9,0XFE,0XA9,0XFE,0XA9,

7120XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA8,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,

7130XF6,0X46,0XED,0XC4,0XE5,0XA4,0XCD,0X02,0X9B,0XA0,0X93,0X60,0XA4,0X01,0XBC,0XE6,

7140XDE,0X0A,0XFF,0X0D,0XFF,0X4D,0XFF,0X6C,0XFF,0X6B,0XFF,0X6A,0XFF,0X6A,0XFF,0X6B,

7150XFF,0X6B,0XFF,0X6B,0XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X6C,0XFF,0X6B,0XFF,0X6B,

7160XFF,0X6C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4B,0XFF,0X4B,

7170XFF,0X4B,0XFF,0X2B,0XFF,0X4C,0XF7,0X0B,0XFF,0X6B,0XFF,0X2B,0XFF,0X4C,0XF7,0X2D,

7180X9C,0X45,0X62,0X80,0X73,0X02,0X7B,0X64,0X8C,0X07,0X8C,0X08,0XAC,0XEE,0XF7,0X59,

7190XFF,0XFC,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7280XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XFF,0XB8,0XF7,0X73,0XF7,0X2F,0XFF,0X4D,

7290XFF,0X4C,0XFF,0X4B,0XFF,0X4A,0XFF,0X49,0XFF,0X09,0XF6,0XA9,0XF6,0X6A,0XF6,0X6A,

7300XF6,0X89,0XFE,0XA9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XCA,0XFE,0XCA,

7310XFE,0XC9,0XFE,0XA9,0XFE,0XA8,0XFE,0XA8,0XF6,0X88,0XFE,0X88,0XFE,0X46,0XFE,0X26,

7320XF6,0X05,0XE5,0XA5,0XBC,0XA2,0X9B,0X80,0X83,0X00,0X93,0X81,0XB4,0XA5,0XEE,0X4B,

7330XFF,0X2E,0XFF,0X4C,0XFF,0X4B,0XFF,0X4B,0XFF,0X6B,0XFF,0X6B,0XFF,0X6B,0XFF,0X4C,

7340XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4C,0XFF,0X4C,

7350XFF,0X2C,0XFF,0X2C,0XFF,0X4C,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,

7360XFF,0X2C,0XFF,0X4C,0XFF,0X0B,0XFF,0X4B,0XFF,0X2C,0XEE,0XED,0X8B,0XC3,0X62,0X80,

7370X62,0XA1,0X7B,0X64,0X8B,0XC6,0X8C,0X08,0X9C,0X4B,0XDE,0X75,0XFF,0XDC,0XFF,0XFD,

7380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

7470XFF,0XFC,0XFF,0XD9,0XFF,0X95,0XF7,0X51,0XF7,0X2D,0XFF,0X2C,0XFF,0X2B,0XFF,0X2A,

7480XFF,0X09,0XFE,0XE9,0XF6,0XA8,0XF6,0X88,0XF6,0X8A,0XFE,0XAA,0XFE,0XAA,0XFE,0XC9,

7490XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XA9,0XFE,0XA9,0XFE,0XC9,0XFE,0XC9,

7500XFE,0XC8,0XFE,0XC8,0XFE,0XC8,0XFE,0XA8,0XF6,0X26,0XFE,0X88,0XFE,0X67,0XEE,0X06,

7510XE5,0XE6,0XC4,0XC3,0X93,0X60,0X7A,0X80,0X8B,0X41,0XC4,0XE7,0XF6,0X8C,0XFE,0XEC,

7520XFF,0X0B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4A,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,

7530XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X2B,0XFF,0X2C,0XFF,0X2C,0XFF,0X2C,

7540XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X0B,0XFF,0X2C,

7550XF6,0XEA,0XFF,0X2C,0XF7,0X0C,0XDE,0X4B,0X7B,0X41,0X5A,0X40,0X62,0XA1,0X73,0X23,

7560X7B,0X85,0X94,0X07,0X83,0X87,0XBD,0X50,0XFF,0XBB,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

7570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFA,0XFF,0XD7,

7660XF7,0X73,0XEF,0X0F,0XF7,0X0C,0XFF,0X0B,0XFF,0X0A,0XFF,0X09,0XFE,0XE9,0XFE,0XC8,

7670XF6,0XA8,0XF6,0XA8,0XFE,0XA9,0XFE,0XCA,0XFE,0XCA,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,

7680XFE,0XC9,0XFE,0XA9,0XFE,0XCA,0XFE,0XCA,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,

7690XFE,0XC9,0XFE,0XA9,0XFE,0XA9,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XF6,0X68,0XDD,0XC6,

7700XBC,0XC4,0X8B,0X20,0X72,0X80,0X93,0X82,0XD5,0X89,0XFE,0XEC,0XFF,0X2C,0XFF,0X2B,

7710XFF,0X0A,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,

7720XFF,0X2B,0XFF,0X2B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,

7730XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XF6,0XCA,0XFF,0X0C,

7740XF6,0XEC,0XCD,0XC9,0X7B,0X22,0X52,0X00,0X5A,0X81,0X6A,0XE3,0X73,0X23,0X83,0XA6,

7750X8B,0X87,0X9C,0X6C,0XF7,0X99,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7840XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XF8,0XFF,0XB4,0XF7,0X10,0XF7,0X0E,

7850XFF,0X0C,0XFE,0XEA,0XFF,0X09,0XFE,0XA7,0XF6,0XA8,0XF6,0X88,0XF6,0XA8,0XFE,0XA9,

7860XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,

7870XFE,0XCA,0XFE,0XCA,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XA9,0XFE,0XA9,0XFE,0XAA,

7880XFE,0XAA,0XFE,0X89,0XFE,0X89,0XFE,0X88,0XF6,0X67,0XE6,0X27,0XDD,0XE7,0XB4,0X84,

7890X83,0X00,0X72,0XC0,0XAC,0X44,0XEE,0X6B,0XFF,0X4D,0XFE,0XEA,0XFF,0X2B,0XFF,0X0B,

7900XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,

7910XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,

7920XFE,0XEA,0XFF,0X0B,0XFE,0XEB,0XFE,0XAA,0XFF,0X0B,0XFE,0XEB,0XEE,0XAC,0XBD,0X27,

7930X7B,0X43,0X49,0XE0,0X5A,0X41,0X5A,0X81,0X6A,0XE3,0X7B,0X45,0X8B,0X87,0X8B,0XE9,

7940XDE,0X96,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8030XFF,0XFE,0XFF,0XFB,0XFF,0XB6,0XF7,0X51,0XEE,0XCE,0XF6,0XED,0XFF,0X2C,0XFF,0X0A,

8040XF6,0XA7,0XFE,0XA7,0XF6,0X88,0XF6,0X89,0XFE,0XA9,0XFE,0XC9,0XFE,0XC8,0XFE,0XC8,

8050XFE,0XC9,0XFE,0XCA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,

8060XFE,0XCA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XA9,0XFE,0XAA,0XFE,0X8A,0XFE,0X6A,

8070XFE,0X89,0XF6,0X88,0XF6,0X87,0XEE,0X88,0XEE,0X89,0XCD,0XA7,0XA4,0X23,0X7A,0XE0,

8080X93,0XA1,0XD5,0XC8,0XFE,0XEB,0XFE,0XEB,0XFE,0XEB,0XFE,0XEB,0XFE,0XEB,0XFF,0X0B,

8090XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFE,0XEB,0XFE,0XEA,0XFE,0XEB,0XFE,0XEB,

8100XFE,0XEB,0XFE,0XEB,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

8110XFE,0XCA,0XFE,0XCA,0XFE,0XCB,0XFE,0XEB,0XEE,0X6B,0XAC,0XC7,0X73,0X02,0X49,0XE0,

8120X52,0X20,0X52,0X41,0X62,0XC2,0X73,0X04,0X7B,0X25,0X83,0X88,0XC5,0XF3,0XFF,0XFD,

8130XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFA,

8220XFF,0X73,0XF7,0X0F,0XF6,0XCD,0XFF,0X0D,0XFE,0XEB,0XFE,0XC9,0XF6,0X86,0XFE,0XC7,

8230XFE,0XA8,0XFE,0X89,0XFE,0XAA,0XFE,0XCA,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XCA,

8240XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,

8250XFE,0XAA,0XFE,0XAA,0XFE,0XA9,0XFE,0XA9,0XFE,0X8A,0XFE,0X8A,0XFE,0XA9,0XFE,0XA8,

8260XF6,0XA7,0XF6,0X87,0XEE,0XA8,0XDE,0X08,0XC5,0X68,0X93,0XC2,0X83,0X40,0XBC,0XE5,

8270XF6,0XAB,0XFE,0XEB,0XFE,0XEC,0XFE,0XEB,0XFE,0XEB,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

8280XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XCA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

8290XFE,0XEA,0XFE,0XEA,0XFE,0XCA,0XFE,0XCA,0XFE,0XEA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,

8300XFE,0XCB,0XFE,0XEC,0XDD,0XEA,0XAC,0XC7,0X6A,0XA1,0X49,0XE0,0X49,0XE0,0X4A,0X01,

8310X62,0X82,0X6A,0XC3,0X72,0XE4,0X7B,0X47,0XAD,0X10,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,

8320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8400XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XFC,0XFF,0XB8,0XEE,0XF0,0XF6,0XCD,

8410XF6,0XAC,0XFE,0XCB,0XF6,0XA9,0XF6,0X88,0XFE,0XC7,0XF6,0XA6,0XFE,0XA9,0XFE,0XAA,

8420XFE,0XAA,0XFE,0XCA,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,

8430XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XAB,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,

8440XFE,0XAA,0XFE,0X8A,0XFE,0X8A,0XFE,0X8A,0XFE,0X8A,0XFE,0XA9,0XFE,0XC9,0XF6,0XC9,

8450XF6,0XCA,0XE6,0X8B,0XDE,0X2C,0XC5,0X29,0X9C,0X04,0XAC,0X84,0XF6,0X8B,0XF6,0XAB,

8460XFE,0XCB,0XFE,0XCB,0XFE,0XCB,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XE9,0XFE,0XEA,

8470XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,

8480XFE,0XC9,0XFE,0XCA,0XFE,0XCA,0XFE,0XA9,0XFE,0XCA,0XFE,0XAA,0XFE,0XEB,0XF6,0XAB,

8490XCD,0X89,0XB4,0XE8,0X5A,0X40,0X49,0XE1,0X49,0XE1,0X49,0XC1,0X5A,0X42,0X62,0X83,

8500X6A,0XA4,0X73,0X26,0X9C,0X8E,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

8590XFF,0XFE,0XFF,0XFD,0XFF,0XDA,0XFF,0X54,0XEE,0XAE,0XFE,0XCC,0XFE,0XCB,0XFE,0XAA,

8600XFE,0XA9,0XF6,0X88,0XFE,0XC7,0XF6,0X87,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XCA,

8610XFE,0XAA,0XFE,0XCA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,

8620XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,

8630XFE,0XAB,0XFE,0XAB,0XF6,0X6B,0XEE,0X6B,0XEE,0X8B,0XEE,0X8B,0XE6,0X6C,0XE6,0X6E,

8640XDE,0X2E,0XDE,0X0E,0XBD,0X2A,0XAC,0XA6,0XE6,0X0A,0XF6,0XAA,0XFE,0XCA,0XFE,0XAA,

8650XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XCA,0XFE,0XCA,

8660XFE,0XAA,0XFE,0XAA,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

8670XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XF6,0X89,0XFE,0XCA,0XE6,0X29,0XCD,0XA9,0XA4,0X46,

8680X52,0X00,0X51,0XE1,0X49,0XC2,0X41,0XA1,0X52,0X02,0X5A,0X42,0X62,0X83,0X6A,0XC6,

8690X8C,0X2C,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,

8780XFF,0X97,0XEE,0XD1,0XEE,0X8C,0XF6,0XAA,0XFE,0XA9,0XF6,0X68,0XFE,0XA9,0XFE,0XA9,

8790XF6,0X67,0XFE,0XA8,0XFE,0XAA,0XFE,0XAA,0XFE,0XCA,0XFE,0XCA,0XFE,0XAA,0XFE,0XAA,

8800XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XCA,0XFE,0XCA,0XFE,0XC9,

8810XFE,0XC9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XAB,0XFE,0XAB,0XEE,0X8B,0XF6,0XAD,

8820XF6,0XAE,0XF6,0XCF,0XF6,0XF0,0XF7,0X11,0XF7,0X13,0XFF,0X75,0XFF,0X77,0XFF,0X56,

8830XF7,0X13,0XD5,0XCC,0XD5,0XE9,0XFF,0X0B,0XFE,0XCA,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,

8840XFE,0XA9,0XFE,0XC9,0XFE,0XC9,0XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,

8850XFE,0XA9,0XFE,0XA9,0XFE,0XA8,0XFE,0XA8,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

8860XFE,0X89,0XFE,0XA9,0XF6,0XAA,0XDE,0X09,0XD5,0XEB,0X83,0X63,0X51,0XE0,0X51,0XE2,

8870X49,0XC2,0X41,0XA1,0X49,0XC1,0X52,0X02,0X5A,0X43,0X62,0XA5,0X83,0XCB,0XFF,0XFD,

8880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

8890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XF9,0XF7,0X74,0XE6,0X8E,

8970XF6,0XAA,0XFE,0XA8,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XF6,0X68,0XFE,0XCA,

8980XFE,0XCB,0XFE,0XAB,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,

8990XFE,0XAB,0XFE,0XAB,0XFE,0XAA,0XFE,0XAA,0XFE,0XC9,0XFE,0XC8,0XFE,0XE8,0XFE,0XC9,

9000XFE,0XC9,0XF6,0XAA,0XFE,0XAC,0XF6,0XCD,0XEE,0XAE,0XEF,0X10,0XF7,0X13,0XFF,0X55,

9010XFF,0X77,0XFF,0XB9,0XFF,0X9A,0XFF,0XDB,0XFF,0XDC,0XFF,0XDB,0XFF,0XD8,0XE6,0X90,

9020XD5,0XC9,0XF6,0XEA,0XFE,0XC9,0XFE,0XA8,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

9030XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA8,

9040XFE,0XA8,0XFE,0XA8,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0X89,0XF6,0X88,0XF6,0XA9,

9050XEE,0X68,0XE6,0X4A,0XCD,0X69,0X7B,0X02,0X62,0X42,0X52,0X02,0X49,0XA2,0X49,0XC2,

9060X49,0XC2,0X49,0XE2,0X52,0X23,0X52,0X64,0X7B,0XCB,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,

9070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9150XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XFF,0XB8,0XEF,0X12,0XDE,0X4C,0XF6,0XAA,0XF6,0X67,

9160XF6,0X46,0XFE,0X88,0XFE,0X88,0XF6,0X69,0XFE,0XCA,0XFE,0XAA,0XFE,0XAB,0XFE,0XAA,

9170XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAB,0XFE,0XAB,0XFE,0XAB,

9180XFE,0XAB,0XFE,0XAA,0XFE,0XA9,0XFE,0XC8,0XFE,0XE8,0XFE,0XE9,0XF6,0XCA,0XF6,0XAB,

9190XF6,0XAE,0XEE,0XD0,0XFF,0X94,0XFF,0XB6,0XFF,0XB8,0XFF,0XDB,0XFF,0XDC,0XFF,0XFE,

9200XFF,0XDE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFD,0XFF,0XB9,0XE6,0XB2,0XD6,0X0A,0XE6,0X69,

9210XF6,0XA9,0XFE,0XA8,0XFE,0X89,0XFE,0X89,0XFE,0XA9,0XFE,0XA8,0XFE,0XA8,0XFE,0X88,

9220XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,

9230XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0X88,0XF6,0X89,0XF6,0X68,0XE6,0X08,0XE6,0X4A,

9240XAC,0X85,0X7A,0XE2,0X72,0XA4,0X5A,0X23,0X51,0XC2,0X51,0XE3,0X49,0XC2,0X41,0XC1,

9250X49,0XE2,0X4A,0X03,0X83,0XCC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

9340XFF,0XDB,0XF7,0X56,0XCD,0XEE,0XCD,0XEA,0XE6,0X49,0XEE,0X48,0XFE,0X89,0XFE,0X88,

9350XF6,0X68,0XFE,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0XCA,0XFE,0X89,0XFE,0XAA,0XFE,0XAA,

9360XFE,0XA9,0XFE,0XCA,0XFE,0XCA,0XFE,0XCB,0XFE,0XAB,0XFE,0XAB,0XFE,0X8A,0XFE,0XAA,

9370XFE,0XA8,0XFE,0XA8,0XFE,0XC8,0XF6,0XC9,0XF6,0XAC,0XEE,0XCE,0XF7,0X12,0XFF,0X77,

9380XFF,0XFB,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

9390XFF,0XDF,0XFF,0XFE,0XFF,0XDB,0XEE,0XD3,0XDE,0X2C,0XEE,0X8A,0XF6,0XAA,0XF6,0X89,

9400XF6,0X89,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X69,0XF6,0X69,

9410XFE,0X89,0XF6,0X68,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,

9420XF6,0X68,0XF6,0X68,0XF6,0X88,0XEE,0X48,0XE6,0X49,0XD5,0XC9,0X93,0XE4,0X83,0X44,

9430X7A,0XE5,0X62,0X64,0X5A,0X03,0X51,0XE2,0X49,0XC1,0X49,0XC2,0X39,0XA2,0X41,0XC4,

9440X84,0X0E,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XEF,0X16,

9530XCD,0XEF,0XD6,0X0D,0XD5,0XC9,0XEE,0X6A,0XF6,0X8A,0XF6,0X6A,0XF6,0X89,0XFE,0X89,

9540XF6,0X88,0XFE,0XA8,0XFE,0XA8,0XFE,0XA9,0XFE,0X89,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,

9550XF6,0XAA,0XFE,0XAA,0XFE,0XCA,0XFE,0XAA,0XFE,0XAA,0XFE,0X89,0XFE,0X89,0XFE,0XC9,

9560XFE,0XCA,0XEE,0XAB,0XEE,0XAE,0XF7,0X13,0XFF,0X98,0XFF,0XFB,0XFF,0XFE,0XFF,0XFF,

9570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XF7,0XDF,0XFF,0XDE,

9580XFF,0XDB,0XEE,0XB3,0XDE,0X2C,0XEE,0X6A,0XF6,0X6A,0XF6,0X69,0XF6,0X88,0XF6,0X88,

9590XF6,0X88,0XF6,0X88,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

9600XF6,0X88,0XF6,0X88,0XF6,0X68,0XF6,0X68,0XF6,0X88,0XF6,0X68,0XF6,0X68,0XF6,0X88,

9610XF6,0X68,0XE6,0X07,0XFE,0XCC,0XBC,0XE6,0X93,0XE4,0X8B,0XA5,0X72,0XC4,0X72,0XC5,

9620X5A,0X23,0X5A,0X43,0X49,0XE1,0X49,0XC2,0X41,0XC3,0X39,0XA4,0X94,0X91,0XFF,0XFE,

9630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9710XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFD,0XFF,0X9A,0XCE,0X11,0X94,0X08,

9720XAC,0XA8,0XD5,0X8A,0XE6,0X2C,0XF6,0X6C,0XF6,0XAB,0XFE,0XCA,0XF6,0X88,0XF6,0X87,

9730XFE,0XC8,0XFE,0XC9,0XFE,0X89,0XFE,0X89,0XFE,0XAA,0XF6,0X89,0XF6,0X89,0XFE,0XC9,

9740XFE,0XC9,0XFE,0XC9,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XF6,0XAA,0XF6,0X8B,0XEE,0XAE,

9750XFF,0X33,0XFF,0XD9,0XFF,0XFC,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XDB,0XE6,0X93,

9770XDE,0X2C,0XEE,0X6A,0XEE,0X69,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

9780XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

9790XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XFE,0X89,0XEE,0X28,0XEE,0X07,0XFF,0X0C,

9800XDD,0XC7,0XB4,0XC5,0XA4,0X65,0X93,0XC5,0X83,0X45,0X72,0XE5,0X62,0X43,0X62,0X63,

9810X52,0X02,0X49,0XE3,0X41,0XA3,0X31,0X83,0XBD,0XD6,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9900XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0X9A,0XE6,0X95,0X9C,0X29,0X72,0XC3,

9910X7B,0X02,0XB4,0XC7,0XEE,0X4C,0XEE,0X6A,0XF6,0XCA,0XF6,0XC9,0XF6,0X88,0XF6,0X88,

9920XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XA9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC8,0XFE,0XA9,

9930XFE,0XAA,0XFE,0XAA,0XF6,0XAB,0XEE,0X8C,0XF6,0XCF,0XFF,0X53,0XFF,0XB8,0XFF,0XFC,

9940XFF,0XFE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9950XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XDD,0XFF,0XDA,0XE6,0X92,0XE6,0X4C,0XEE,0X6A,

9960XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

9970XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X48,0XF6,0X68,0XF6,0X68,

9980XF6,0X68,0XF6,0X48,0XEE,0X28,0XF6,0X48,0XFE,0X8A,0XEE,0X29,0XDD,0XA7,0XBC,0XC4,

9990XAC,0XA6,0XA4,0X46,0X8B,0XA6,0X7B,0X25,0X72,0XC4,0X62,0X83,0X52,0X02,0X49,0XC2,

10000X41,0XC3,0X4A,0X06,0XE6,0XFA,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10090XFF,0XFE,0XFF,0XFE,0XFF,0XDD,0XFF,0XDC,0XFF,0XBB,0XC5,0X91,0X83,0X47,0X62,0X82,

10100X8B,0XA4,0XCD,0XAA,0XEE,0X8B,0XEE,0X8A,0XF6,0XA9,0XFE,0XC9,0XF6,0X88,0XFE,0X88,

10110XFE,0XA8,0XFE,0XA8,0XFE,0XC8,0XFE,0XC8,0XFE,0XA8,0XFE,0XA9,0XFE,0XAA,0XF6,0XAB,

10120XF6,0XAD,0XF6,0XD0,0XF7,0X34,0XFF,0X98,0XFF,0XDB,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,

10130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

10140XFF,0XFE,0XFF,0XDC,0XFF,0XB9,0XE6,0X91,0XE6,0X4B,0XEE,0X69,0XF6,0X48,0XF6,0X68,

10150XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

10160XF6,0X48,0XF6,0X68,0XF6,0X48,0XEE,0X48,0XF6,0X48,0XF6,0X48,0XEE,0X48,0XEE,0X48,

10170XEE,0X27,0XF6,0X69,0XFE,0XAA,0XE5,0XE7,0XD5,0X66,0XC5,0X26,0XBC,0XE6,0XAC,0X86,

10180X93,0XC5,0X8B,0XA6,0X7B,0X04,0X6A,0X83,0X5A,0X42,0X49,0XE2,0X41,0XC3,0X6B,0X2A,

10190XF7,0X7C,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XDE,

10280XFF,0XFF,0XFF,0XFF,0XFF,0X9D,0XFF,0X5B,0XEE,0XD7,0XAC,0XEE,0X73,0X05,0X72,0XE2,

10290X9C,0X45,0XDE,0X4C,0XE6,0X6A,0XF6,0XCB,0XFE,0XCA,0XF6,0X68,0XF6,0X88,0XFE,0XA8,

10300XFE,0XA8,0XFE,0X88,0XFE,0XA9,0XFE,0XCA,0XFE,0XAB,0XF6,0XAC,0XEE,0XAF,0XF7,0X34,

10310XFF,0X98,0XFF,0XDB,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDC,

10330XFF,0X98,0XE6,0X90,0XE6,0X4A,0XEE,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X28,0XF6,0X28,

10340XF6,0X28,0XF6,0X28,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XF6,0X48,

10350XEE,0X28,0XEE,0X48,0XF6,0X68,0XEE,0X48,0XEE,0X28,0XEE,0X48,0XF6,0X89,0XFE,0X89,

10360XF6,0X68,0XE5,0XE7,0XDD,0XA7,0XCD,0X46,0XC5,0X07,0XB4,0XC7,0XA4,0X46,0X93,0XC5,

10370X83,0X64,0X72,0XC3,0X6A,0XA3,0X5A,0X64,0X39,0X82,0XA4,0XD1,0XFF,0XBD,0XFF,0XFF,

10380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10470XFF,0XFF,0XFF,0XDE,0XFF,0XDD,0XF7,0X7B,0XD6,0X75,0X9C,0X6C,0X62,0XA3,0X73,0X23,

10480XB4,0XE8,0XE6,0X4C,0XEE,0X8B,0XF6,0XAA,0XFE,0XA9,0XFE,0XE9,0XFE,0XA8,0XF6,0X88,

10490XFE,0XA9,0XF6,0XAA,0XEE,0X8B,0XEE,0X8E,0XEE,0XF2,0XFF,0XB8,0XFF,0XFC,0XFF,0XFD,

10500XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XFF,0X56,0XE6,0X6E,

10520XE6,0X49,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

10530XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X28,

10540XF6,0X48,0XEE,0X28,0XEE,0X28,0XF6,0X68,0XFE,0XA9,0XFE,0X88,0XF6,0X47,0XF6,0X28,

10550XE5,0XE8,0XDD,0X88,0XCD,0X27,0XC5,0X08,0XB4,0XA7,0X9C,0X05,0X9C,0X06,0X83,0X44,

10560X6A,0XC4,0X5A,0X84,0X52,0X45,0XDE,0X97,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10650XFF,0XFF,0XFF,0XDF,0XF7,0XFE,0XF7,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0X9E,

10660XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XEF,0X3A,0XD6,0X35,0X8B,0XC9,0X62,0X82,0X83,0X63,

10670XD5,0XCB,0XEE,0X8C,0XEE,0X8A,0XF6,0XCA,0XF6,0XA9,0XF6,0X89,0XF6,0XAA,0XF6,0X8B,

10680XEE,0X8D,0XF6,0XD1,0XFF,0X97,0XFF,0XFB,0XFF,0XFD,0XF7,0XDE,0XFF,0XFF,0XFF,0XFF,

10690XF7,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

10700XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XFF,0XBB,0XF7,0X14,0XE6,0X4D,0XE6,0X28,0XEE,0X47,

10710XF6,0X27,0XF6,0X07,0XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

10720XEE,0X27,0XEE,0X27,0XEE,0X28,0XF6,0X28,0XEE,0X27,0XEE,0X27,0XF6,0X48,0XEE,0X27,

10730XF6,0X48,0XFE,0XA9,0XF6,0X87,0XF6,0X46,0XFE,0X68,0XF6,0X28,0XF6,0X09,0XE5,0XA9,

10740XD5,0X48,0XCD,0X28,0XBC,0XC7,0XAC,0X86,0X9C,0X25,0X83,0X84,0X72,0XE4,0X5A,0X84,

10750X8C,0X0C,0XEF,0X3A,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10840XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XF7,0XDF,0XF7,0XDF,0XFF,0XDF,0XFF,0XDF,

10850XFF,0XFF,0XFF,0XDE,0XFF,0X9D,0XFF,0X7B,0XB5,0X10,0X62,0X83,0X62,0XA1,0XAC,0XA7,

10860XEE,0X8E,0XF6,0XCE,0XEE,0XAB,0XEE,0XAB,0XEE,0XAB,0XE6,0X6C,0XE6,0X6F,0XF7,0X14,

10870XFF,0XDA,0XFF,0XFC,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XF7,0XFE,0XFF,0XFE,

10880XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

10890XFF,0XDD,0XFF,0XBA,0XEE,0XD2,0XE6,0X0C,0XEE,0X28,0XEE,0X46,0XF6,0X27,0XF6,0X27,

10900XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X28,0XEE,0X28,0XF6,0X48,

10910XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XE5,0XE6,0XFE,0X88,0XFE,0XC9,0XFE,0X88,

10920XF6,0X46,0XF6,0X67,0XF6,0X47,0XF6,0X08,0XF6,0X09,0XED,0XC9,0XDD,0XA9,0XCD,0X48,

10930XC5,0X07,0XB4,0XC6,0X9C,0X24,0X93,0XE5,0X7B,0X45,0X6A,0XE6,0XCD,0XF5,0XFF,0XBD,

10940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11040XFF,0XFF,0XFF,0X9E,0XFF,0XBC,0XE6,0XB7,0X94,0X2A,0X52,0X21,0X7B,0X24,0XCD,0XAC,

11050XEE,0X8E,0XEE,0X8D,0XEE,0XAD,0XE6,0X8E,0XEE,0XD2,0XFF,0XD9,0XFF,0XFB,0XFF,0XFD,

11060XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11070XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDC,0XFF,0X78,

11080XEE,0X90,0XE6,0X0B,0XEE,0X28,0XEE,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X47,

11090XEE,0X27,0XEE,0X27,0XEE,0X48,0XE5,0XE7,0XEE,0X28,0XE5,0XE7,0XEE,0X28,0XF6,0X48,

11100XEE,0X08,0XEE,0X27,0XFE,0X68,0XF6,0X68,0XEE,0X06,0XE5,0XE5,0XF6,0X46,0XF6,0X66,

11110XFE,0X67,0XF6,0X28,0XF6,0X29,0XF5,0XE9,0XED,0XEA,0XDD,0XA8,0XCD,0X67,0XBD,0X06,

11120XAC,0XA6,0X9C,0X46,0X7B,0X66,0X94,0X2C,0XEE,0XF9,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

11130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

11230XFF,0XDE,0XFF,0XDD,0XF7,0X5A,0XBD,0XB2,0X83,0X88,0X73,0X05,0XA4,0X89,0XD6,0X0E,

11240XDE,0X8F,0XDE,0X70,0XF7,0X56,0XFF,0XDA,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

11250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

11260XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDD,0XFF,0XD9,0XF7,0X34,0XE6,0X4D,0XE6,0X0A,

11270XEE,0X08,0XEE,0X07,0XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X48,

11280XEE,0X27,0XF6,0X69,0XE6,0X07,0XEE,0X28,0XF6,0X49,0XE5,0XE7,0XEE,0X07,0XF6,0X69,

11290XF6,0X68,0XDD,0XA5,0XD5,0X23,0XD5,0X64,0XE5,0XE4,0XEE,0X25,0XFE,0X67,0XFE,0X68,

11300XFE,0X49,0XF6,0X08,0XEE,0X08,0XDD,0XC7,0XCD,0X86,0XBD,0X25,0XBD,0X27,0XA4,0X66,

11310X94,0X09,0XD6,0X13,0XFF,0X9C,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XBF,0XFF,0XDF,

11420XFF,0XDE,0XFF,0XDD,0XF7,0X59,0XDE,0X75,0XBD,0X6F,0XC5,0XAF,0XD6,0X31,0XEF,0X36,

11430XFF,0XFB,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

11450XFF,0XFD,0XFF,0XFB,0XFF,0XB6,0XEE,0XD0,0XE6,0X2B,0XE6,0X29,0XEE,0X08,0XEE,0X07,

11460XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XE6,0X07,

11470XEE,0X28,0XEE,0X08,0XE5,0XE7,0XF6,0X49,0XEE,0X28,0XE5,0XC6,0XAC,0X40,0XB4,0X61,

11480XC4,0XC2,0XD5,0X64,0XDD,0XC4,0XEE,0X25,0XF6,0X46,0XFE,0X47,0XFE,0X48,0XF6,0X28,

11490XEE,0X28,0XE6,0X07,0XD5,0XC6,0XC5,0X86,0XBD,0X47,0XA4,0XA7,0XBD,0X8F,0XF7,0X59,

11500XFF,0XBD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11600XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0X9F,0XFF,0XBF,0XFF,0XDE,0XFF,0XFE,

11610XFF,0XFD,0XFF,0XBB,0XFF,0XDB,0XF7,0X9A,0XFF,0XBA,0XFF,0XBB,0XFF,0XDC,0XFF,0XDD,

11620XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11630XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XFF,0XDF,0XFF,0XDE,0XFF,0XFC,0XFF,0XF8,

11640XF7,0X52,0XE6,0X8B,0XDE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X28,

11650XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XE6,0X27,0XE6,0X07,0XEE,0X28,0XEE,0X28,

11660XF6,0X69,0XE5,0XE7,0XBC,0XC3,0X8B,0X40,0X93,0X60,0X9B,0XC0,0XB4,0X62,0XBC,0XC2,

11670XD5,0X84,0XDD,0XE5,0XEE,0X25,0XF6,0X67,0XFE,0X67,0XF6,0X47,0XF6,0X47,0XE6,0X47,

11680XD5,0XE6,0XD5,0XE7,0XB5,0X27,0XBD,0X4B,0XE6,0XD5,0XFF,0XBB,0XFF,0XBD,0XFF,0XFF,

11690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11790XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XBF,0XFF,0XFF,0XF7,0XBE,0XFF,0XDD,0XFF,0XFE,

11800XFF,0XBC,0XFF,0XFE,0XFF,0XDD,0XFF,0XDD,0XFF,0XDE,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,

11810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,

11820XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFD,0XFF,0XFA,0XFF,0XB4,0XEE,0XED,0XDE,0X49,

11830XE6,0X27,0XEE,0X47,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XE6,0X07,

11840XEE,0X27,0XEE,0X48,0XE5,0XE7,0XEE,0X48,0XE6,0X27,0XF6,0X69,0XFE,0XEB,0XFE,0XAA,

11850XD5,0X86,0XAC,0X21,0X83,0X20,0X9B,0XA0,0XAC,0X21,0XAC,0X62,0XBD,0X03,0XD5,0X84,

11860XE6,0X05,0XF6,0X67,0XFE,0X67,0XFE,0X88,0XF6,0X68,0XE6,0X47,0XDE,0X08,0XD6,0X09,

11870XB5,0X29,0XDE,0X92,0XFF,0XB9,0XFF,0XDC,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

11880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XF7,0X7E,

11980XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDE,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XF7,0X9D,

11990XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

12010XFF,0XDF,0XFF,0XFC,0XFF,0XF7,0XEF,0X50,0XDE,0X8A,0XDE,0X27,0XE6,0X27,0XEE,0X47,

12020XEE,0X06,0XEE,0X07,0XEE,0X28,0XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X07,0XEE,0X07,

12030XEE,0X27,0XDD,0XC6,0XE6,0X27,0XE6,0X07,0XEE,0X48,0XFF,0X2C,0XFF,0X0C,0XF6,0XAB,

12040XDD,0XC8,0XAC,0X43,0X8B,0X20,0X9B,0XE1,0XAC,0X82,0XC5,0X44,0XDD,0XA5,0XEE,0X47,

12050XF6,0X67,0XFE,0X88,0XF6,0X69,0XEE,0X69,0XE6,0X4A,0XD6,0X0C,0XDE,0X4F,0XFF,0X97,

12060XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XF7,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XBE,0XFF,0XDE,

12170XFF,0XFF,0XFF,0XDE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,

12180XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12190XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDD,0XFF,0XFA,

12200XFF,0XD4,0XE6,0XCC,0XD6,0X48,0XDE,0X07,0XE6,0X47,0XEE,0X27,0XE6,0X06,0XEE,0X27,

12210XEE,0X28,0XEE,0X08,0XEE,0X08,0XE6,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X27,0XEE,0X27,

12220XE6,0X07,0XE6,0X27,0XEE,0X48,0XDE,0X07,0XE6,0X08,0XFE,0XCB,0XFF,0X4E,0XFE,0XCD,

12230XCD,0X67,0X9C,0X01,0X93,0XE0,0XB4,0XC2,0XD5,0X65,0XEE,0X27,0XF6,0X48,0XF6,0X69,

12240XEE,0X6A,0XE6,0X4B,0XDE,0X2C,0XD6,0X0E,0XFF,0XB7,0XFF,0XBA,0XFF,0X9C,0XFF,0XDE,

12250XF7,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12360XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12370XF7,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

12380XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDE,0XFF,0XDB,0XFF,0XB6,0XEF,0X0F,0XDE,0X4A,

12390XDE,0X49,0XDE,0X28,0XE6,0X28,0XE6,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

12400XEE,0X27,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

12410XE6,0X28,0XE5,0XE7,0XE6,0X28,0XE6,0X08,0XDE,0X08,0XF6,0XAB,0XFF,0X4D,0XFE,0XEC,

12420XBD,0X24,0XA4,0X61,0XCD,0X24,0XE5,0XE8,0XEE,0X29,0XF6,0X8B,0XEE,0X6B,0XDE,0X2C,

12430XE6,0X90,0XFF,0XB7,0XFF,0XDB,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

12560XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12570XFF,0XDE,0XFF,0XDB,0XFF,0XB7,0XF7,0X12,0XE6,0X6C,0XDE,0X29,0XDE,0X29,0XE6,0X29,

12580XE6,0X08,0XE6,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

12590XE6,0X07,0XE6,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X28,

12600XE6,0X28,0XE6,0X28,0XE6,0X08,0XDD,0XE7,0XE6,0X49,0XF6,0XEB,0XFF,0X6D,0XEE,0XAA,

12610XCD,0X45,0XD5,0X86,0XF6,0X8B,0XEE,0X6B,0XE6,0X4D,0XEE,0XB0,0XF7,0X35,0XFF,0XB9,

12620XFF,0XFD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

12740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12750XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XDA,0XFF,0X97,

12760XFF,0X53,0XE6,0XAD,0XDE,0X09,0XE6,0X09,0XE6,0X09,0XE6,0X09,0XEE,0X08,0XEE,0X08,

12770XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XE6,0X07,0XE6,0X07,

12780XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X27,0XE6,0X07,0XDE,0X07,

12790XE6,0X48,0XE6,0X49,0XDE,0X08,0XDD,0XE7,0XE6,0X49,0XFF,0X4C,0XFF,0X2C,0XF6,0XAA,

12800XEE,0X8A,0XE6,0X6B,0XEE,0XAF,0XFF,0X95,0XFF,0XD9,0XFF,0XBB,0XFF,0XFE,0XFF,0XFE,

12810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12920XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

12940XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0XB6,0XF7,0X31,0XEE,0XCD,0XDE,0X4A,

12950XDE,0X08,0XE6,0X09,0XE6,0X09,0XEE,0X09,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,

12960XEE,0X27,0XEE,0X27,0XEE,0X27,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,

12970XE6,0X07,0XE6,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X28,0XE6,0X08,0XDD,0XE7,

12980XE6,0X08,0XE6,0X48,0XE6,0X28,0XE6,0X48,0XEE,0X89,0XFF,0X4C,0XFF,0X2C,0XEE,0XCD,

12990XFF,0X32,0XFF,0XB7,0XFF,0XDA,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13110XFF,0XFE,0XF7,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,

13130XFF,0XFA,0XFF,0XB7,0XFF,0X71,0XEE,0XCC,0XDE,0X28,0XDE,0X07,0XE6,0X08,0XEE,0X08,

13140XEE,0X09,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

13150XEE,0X27,0XEE,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,

13160XE6,0X07,0XEE,0X28,0XE6,0X07,0XE5,0XE7,0XE6,0X07,0XE6,0X28,0XE6,0X07,0XE6,0X08,

13170XDD,0XE7,0XD5,0XC6,0XE6,0X47,0XEE,0XA9,0XF6,0XEB,0XFF,0X6F,0XFF,0X73,0XFF,0XB7,

13180XFF,0X99,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

13310XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XFB,0XFF,0XF9,0XFF,0X96,0XEE,0XF1,

13320XE6,0XAC,0XE6,0X68,0XDE,0X06,0XE6,0X06,0XEE,0X28,0XEE,0X08,0XEE,0X08,0XEE,0X07,

13330XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,

13340XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE5,0XE7,

13350XE6,0X07,0XEE,0X28,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XDD,0XE7,0XF6,0X69,0XEE,0X48,

13360XD5,0XA5,0XDE,0X07,0XE6,0X69,0XEE,0XCC,0XFF,0X72,0XFF,0X34,0XF7,0X77,0XFF,0XFC,

13370XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

13500XFF,0XFC,0XFF,0XFA,0XFF,0XB7,0XFF,0X94,0XEE,0XCF,0XDE,0X4B,0XDE,0X07,0XDE,0X26,

13510XE6,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

13520XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,

13530XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X07,0XEE,0X27,0XE6,0X07,

13540XDD,0XC6,0XEE,0X28,0XEE,0X68,0XDD,0XC6,0XE5,0XC6,0XE6,0X07,0XEE,0X47,0XE6,0X27,

13550XDE,0X07,0XDE,0X29,0XEE,0XAD,0XFF,0X51,0XFF,0X54,0XFF,0XB8,0XFF,0XFB,0XFF,0XFD,

13560XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

13680XF7,0XDF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFA,0XFF,0XB8,0XFF,0X75,

13690XF7,0X11,0XE6,0X8E,0XDE,0X2A,0XE6,0X29,0XE6,0X27,0XE6,0X46,0XEE,0X26,0XEE,0X06,

13700XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

13710XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,

13720XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X28,0XE6,0X27,

13730XE6,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XE6,0X27,0XDE,0X07,0XE6,0X28,0XE6,0X28,

13740XDD,0XE8,0XEE,0X8C,0XF7,0X10,0XF7,0X33,0XFF,0XD8,0XFF,0XFA,0XFF,0XDD,0XFF,0XFE,

13750XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XFF,0XDD,0XFF,0XFD,0XFF,0XFC,

13870XFF,0XFA,0XFF,0XF8,0XFF,0XB6,0XFF,0X95,0XF7,0X11,0XEE,0X8E,0XE6,0X2B,0XDE,0X09,

13880XE6,0X28,0XE6,0X28,0XE6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,

13890XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X08,0XEE,0X08,

13900XEE,0X08,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

13910XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

13920XEE,0X07,0XEE,0X07,0XE6,0X28,0XE6,0X27,0XDE,0X07,0XE6,0X07,0XE6,0X28,0XE6,0X29,

13930XEE,0X8B,0XFF,0X0F,0XEE,0XD1,0XFF,0X76,0XFF,0XBA,0XFF,0XDD,0XFF,0XBE,0XFF,0XDF,

13940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14050XFF,0XBE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFA,0XFF,0XD8,0XFF,0XB5,0XF7,0X73,

14060XEF,0X30,0XE6,0XAE,0XDE,0X2B,0XDE,0X09,0XE6,0X08,0XE6,0X07,0XEE,0X07,0XEE,0X07,

14070XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

14080XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X27,

14090XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

14100XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,

14110XE6,0X28,0XE6,0X28,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X08,0XF6,0X8C,

14120XEE,0XCF,0XDE,0X70,0XF7,0X57,0XFF,0XDC,0XFF,0XDD,0XFF,0XDE,0XFF,0XDE,0XFF,0XFF,

14130XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,

14240XFF,0XDA,0XFF,0XB7,0XFF,0XB4,0XFF,0X92,0XF7,0X2F,0XE6,0XAC,0XDE,0X4A,0XDE,0X29,

14250XE6,0X28,0XE6,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

14260XEE,0X27,0XEE,0X27,0XEE,0X27,0XE6,0X27,0XEE,0X28,0XE6,0X28,0XE6,0X47,0XEE,0X27,

14270XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X27,

14280XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

14290XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XE6,0X27,0XE6,0X27,0XE6,0X27,

14300XE6,0X27,0XE6,0X07,0XE5,0XE7,0XE6,0X07,0XE5,0XE7,0XEE,0X49,0XEE,0X6B,0XE6,0X4E,

14310XD6,0X10,0XEF,0X16,0XFF,0XDC,0XFF,0XBD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0X7B,0XFF,0X77,0XFF,0X52,

14430XEE,0XEE,0XEE,0XAB,0XDE,0X2A,0XDE,0X09,0XDE,0X08,0XE6,0X28,0XE6,0X27,0XE6,0X26,

14440XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

14450XEE,0X27,0XEE,0X28,0XEE,0X28,0XE6,0X28,0XE6,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

14460XEE,0X07,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,

14470XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

14480XEE,0X07,0XEE,0X27,0XE6,0X07,0XEE,0X28,0XE6,0X27,0XE6,0X27,0XEE,0X28,0XEE,0X07,

14490XE5,0XE7,0XEE,0X07,0XF6,0X48,0XE5,0XE7,0XE6,0X29,0XE6,0X4B,0XCD,0XCC,0XC5,0XAE,

14500XEE,0XF6,0XFF,0XDC,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

14510XFF,0XFF,0XF7,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14610XFF,0XFF,0XFF,0XFF,0XFF,0XBD,0XDE,0X75,0XDE,0X30,0XE6,0X6D,0XE6,0X29,0XE6,0X28,

14620XDD,0XC8,0XE5,0XE9,0XEE,0X09,0XE6,0X08,0XE6,0X06,0XEE,0X26,0XEE,0X26,0XE6,0X06,

14630XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,

14640XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,

14650XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,

14660XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

14670XE6,0X07,0XE6,0X28,0XE6,0X07,0XE6,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X08,0XEE,0X08,

14680XEE,0X08,0XE5,0XE7,0XEE,0X28,0XE6,0X08,0XDE,0X0B,0XB5,0X0A,0XAC,0XCC,0XF7,0X38,

14690XFF,0XBC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

14700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14800XFF,0XDC,0XBD,0X90,0XBD,0X4A,0XDD,0XE9,0XE6,0X07,0XF6,0X27,0XF6,0X09,0XED,0XE9,

14810XED,0XE9,0XEE,0X09,0XEE,0X28,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X27,

14820XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,

14830XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

14840XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

14850XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X28,

14860XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X08,0XEE,0X08,0XE5,0XC7,0XF6,0X27,

14870XEE,0X06,0XEE,0X27,0XE6,0X09,0XCD,0X6A,0X9C,0X28,0X9C,0X6B,0XFF,0X9A,0XFF,0XFD,

14880XFF,0XDE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0X9A,0XC5,0X8F,

14990XC5,0X6A,0XE6,0X29,0XEE,0X06,0XEE,0X06,0XF6,0X07,0XED,0XC8,0XED,0XE9,0XF6,0X29,

15000XEE,0X28,0XEE,0X07,0XEE,0X27,0XF6,0X68,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

15010XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

15020XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

15030XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,

15040XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,

15050XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XF6,0X07,0XEE,0X05,0XED,0XE6,

15060XEE,0X28,0XDD,0XEA,0XC5,0X4A,0X6A,0XA3,0XA4,0XCE,0XFF,0XFC,0XFF,0XDD,0XFF,0XDE,

15070XFF,0XFF,0XEF,0X7D,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XF7,0X79,0XC5,0XAF,0XC5,0X6A,0XDE,0X09,

15180XE6,0X06,0XF6,0X47,0XF6,0X07,0XF6,0X07,0XED,0XE8,0XED,0XE8,0XEE,0X08,0XF6,0X48,

15190XEE,0X48,0XE6,0X07,0XEE,0X27,0XEE,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

15200XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

15210XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X27,

15220XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

15230XEE,0X07,0XEE,0X07,0XEE,0X08,0XED,0XE7,0XEE,0X07,0XEE,0X07,0XEE,0X06,0XEE,0X27,

15240XEE,0X28,0XEE,0X07,0XEE,0X07,0XF6,0X07,0XF6,0X26,0XF6,0X27,0XED,0XE7,0XE5,0XC8,

15250XDD,0XEB,0X9C,0X06,0X62,0X83,0X94,0X6D,0XF7,0X7B,0XFF,0XDD,0XFF,0XDE,0XFF,0XDF,

15260XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15360XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XC5,0XF0,0XC5,0XAC,0XE6,0X4B,0XDE,0X07,0XE6,0X26,

15370XEE,0X26,0XEE,0X26,0XEE,0X27,0XF6,0X48,0XEE,0X28,0XEE,0X08,0XEE,0X08,0XF6,0X49,

15380XEE,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X27,

15390XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XE6,0X28,

15400XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X08,0XEE,0X27,

15410XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,

15420XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

15430XEE,0X07,0XEE,0X06,0XEE,0X06,0XEE,0X07,0XEE,0X28,0XE6,0X28,0XD5,0XC8,0XC5,0X48,

15440X6A,0X81,0X5A,0X43,0XB5,0X30,0XFF,0X9C,0XFF,0XBE,0XFF,0XFF,0XFF,0XBF,0XFF,0XFF,

15450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

15550XF7,0XBB,0XE6,0XF6,0XD6,0X51,0XCD,0XED,0XD6,0X0A,0XE6,0X6A,0XEE,0X69,0XE6,0X48,

15560XE6,0X28,0XE6,0X08,0XE5,0XE7,0XEE,0X29,0XEE,0X49,0XE6,0X08,0XEE,0X28,0XEE,0X27,

15570XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X27,0XEE,0X27,

15580XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

15590XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

15600XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,

15610XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XF6,0X27,0XEE,0X07,

15620XF6,0X48,0XEE,0X07,0XEE,0X28,0XEE,0X49,0XDD,0XE7,0XCD,0X67,0XA4,0X05,0X5A,0X21,

15630X62,0XA5,0XCD,0XF5,0XFF,0XBD,0XFF,0XDE,0XFF,0XBE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

15640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XBB,

15740XEE,0XF7,0XC5,0XD0,0XAC,0XCA,0XA4,0XA8,0XC5,0X69,0XD5,0XCA,0XE6,0X2C,0XEE,0X6C,

15750XEE,0X6B,0XE6,0X09,0XE6,0X08,0XEE,0X69,0XEE,0X28,0XEE,0X07,0XEE,0X27,0XEE,0X48,

15760XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

15770XEE,0X28,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

15780XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

15790XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X28,

15800XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XF6,0X27,0XEE,0X07,

15810XEE,0X28,0XEE,0X69,0XE6,0X08,0XD5,0XA8,0XB4,0XA7,0X5A,0X20,0X52,0X02,0X7B,0X8A,

15820XE6,0XD9,0XFF,0XDE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0X7C,0XFF,0XFE,0XFF,0XBC,0XF7,0X59,

15930XEE,0XF7,0XC5,0X90,0X8B,0XC7,0X7B,0X24,0X7B,0X44,0XA4,0X87,0XCD,0XAB,0XEE,0X8C,

15940XEE,0X8B,0XDD,0XE8,0XEE,0X29,0XEE,0X29,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X28,

15950XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X28,

15960XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

15970XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X08,

15980XEE,0X27,0XEE,0X27,0XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

15990XEE,0X27,0XEE,0X27,0XEE,0X07,0XF6,0X47,0XED,0XE6,0XEE,0X47,0XEE,0X48,0XE6,0X07,

16000XEE,0X48,0XDD,0XE8,0XC5,0X07,0X7B,0X02,0X62,0X83,0X4A,0X03,0XA4,0XD0,0XF7,0X9C,

16010XFF,0XBD,0XFF,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBE,0XFF,0XDE,0XFF,0XBC,0XFF,0XDC,

16120XFF,0X9A,0XDE,0X95,0X9C,0X6C,0X62,0X83,0X51,0XE0,0X73,0X02,0XB4,0XE8,0XE6,0X6D,

16130XE6,0X0B,0XEE,0X0A,0XEE,0X29,0XEE,0X08,0XEE,0X27,0XEE,0X07,0XEE,0X08,0XF6,0X48,

16140XEE,0X28,0XEE,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X28,0XEE,0X28,

16150XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

16160XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

16170XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

16180XF6,0X47,0XEE,0X06,0XF6,0X68,0XEE,0X27,0XEE,0X27,0XF6,0X48,0XE6,0X07,0XE6,0X29,

16190XC5,0X07,0X9B,0XE5,0X52,0X00,0X52,0X43,0X5A,0XA7,0XCE,0X16,0XFF,0XBD,0XFF,0XFE,

16200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16300XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XDC,

16310XFF,0XFC,0XF7,0X79,0XB5,0X2F,0X62,0XC4,0X49,0XC0,0X49,0XC0,0XAC,0X87,0XE6,0X0C,

16320XEE,0X4B,0XDD,0XC8,0XEE,0X28,0XF6,0X48,0XEE,0X07,0XEE,0X28,0XEE,0X27,0XEE,0X47,

16330XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

16340XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

16350XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XF6,0X27,0XF6,0X27,

16360XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XF6,0X48,

16370XEE,0X27,0XEE,0X47,0XEE,0X27,0XEE,0X28,0XF6,0X69,0XE6,0X29,0XCD,0X67,0XAC,0X66,

16380X5A,0X40,0X52,0X43,0X41,0XC2,0X83,0XEC,0XF7,0X5B,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,

16390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

16490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XDC,

16500XFF,0XFD,0XF7,0X7A,0XC5,0XD3,0X94,0X2B,0X62,0X83,0X72,0XC2,0XAC,0X87,0XDD,0XEB,

16510XE6,0X09,0XE6,0X08,0XF6,0X49,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X47,

16520XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

16530XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

16540XEE,0X28,0XEE,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

16550XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X06,0XF6,0X47,0XEE,0X27,0XEE,0X47,

16560XEE,0X28,0XEE,0X28,0XF6,0X69,0XEE,0X29,0XD5,0X88,0XA4,0X44,0X6A,0XC1,0X41,0XC0,

16570X4A,0X24,0X5A,0X87,0XCE,0X16,0XFF,0XBD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

16690XFF,0XDD,0XFF,0XBC,0XE6,0XF7,0XBD,0X6F,0X9C,0X8A,0XB5,0X0B,0XDE,0X0C,0XE6,0X6C,

16700XE6,0X2A,0XE6,0X09,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X27,

16710XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X47,0XEE,0X27,0XEE,0X27,0XF6,0X27,0XF6,0X27,

16720XF6,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

16730XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

16740XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XF6,0X47,0XEE,0X48,0XEE,0X48,

16750XF6,0X48,0XEE,0X49,0XE5,0XE9,0XB4,0XA5,0X72,0XE1,0X49,0XC0,0X52,0X44,0X39,0X82,

16760X8C,0X0D,0XFF,0XBD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16870XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDD,

16880XFF,0XBC,0XFF,0XFC,0XFF,0XDB,0XFF,0X98,0XF7,0X56,0XFF,0X34,0XEE,0XB0,0XE6,0X0B,

16890XE6,0X0A,0XEE,0X09,0XEE,0X28,0XFE,0X69,0XF6,0X27,0XED,0XE7,0XF6,0X47,0XF6,0X27,

16900XEE,0X27,0XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X27,

16910XEE,0X28,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,

16920XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X27,

16930XEE,0X47,0XEE,0X27,0XEE,0X27,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X49,

16940XF6,0X6A,0XB4,0XA5,0X73,0X02,0X52,0X21,0X4A,0X03,0X39,0X82,0X5A,0X87,0XE6,0XF9,

16950XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

16960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17060XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDE,0XFF,0XFE,

17070XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XDA,0XFF,0X76,0XF6,0XD2,0XE6,0X4E,0XE5,0XEA,

17080XE5,0XE9,0XEE,0X08,0XF6,0X28,0XF6,0X47,0XF6,0X27,0XEE,0X26,0XEE,0X47,0XEE,0X47,

17090XEE,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X47,0XEE,0X47,

17100XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

17110XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X27,

17120XEE,0X27,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X49,0XF6,0X6A,0XBC,0XE6,

17130X7B,0X22,0X52,0X00,0X49,0XE2,0X49,0XE4,0X49,0XE4,0XAD,0X32,0XFF,0XFE,0XFF,0XFF,

17140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,

17250XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XF7,0XDE,0XFF,0XDF,0XFF,0XDE,0XF7,0XDE,

17260XFF,0XDE,0XFF,0XFE,0XFF,0XDC,0XFF,0X99,0XF7,0X14,0XE6,0X4E,0XE6,0X0A,0XE6,0X08,

17270XEE,0X27,0XF6,0X47,0XEE,0X26,0XF6,0X26,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X27,

17280XF6,0X28,0XF6,0X28,0XF6,0X48,0XF6,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

17290XEE,0X47,0XEE,0X47,0XF6,0X28,0XF6,0X28,0XF6,0X27,0XEE,0X47,0XF6,0X27,0XF6,0X27,

17300XF6,0X27,0XF6,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,

17310XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X49,0XF6,0X6A,0XCD,0X47,0X83,0X84,0X49,0XC0,

17320X4A,0X02,0X4A,0X04,0X39,0X83,0X6B,0X0A,0XFF,0XBD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

17330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

17440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XF7,0XDF,0XFF,0XFF,

17450XFF,0XFF,0XFF,0XFE,0XFF,0XBA,0XFF,0X35,0XEE,0XAF,0XDE,0X09,0XE5,0XE7,0XEE,0X47,

17460XF6,0X47,0XEE,0X26,0XEE,0X47,0XEE,0X47,0XEE,0X28,0XEE,0X27,0XF6,0X28,0XF6,0X28,

17470XF6,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

17480XF6,0X28,0XF6,0X28,0XF6,0X27,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

17490XF6,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X48,0XF6,0X48,

17500XF6,0X48,0XF6,0X49,0XF6,0X4A,0XE5,0XEA,0X83,0X63,0X52,0X00,0X49,0XC1,0X4A,0X04,

17510X41,0XA3,0X41,0XC4,0XF7,0X7B,0XF7,0XBD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17630XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XFF,0XDF,0XFF,0XFF,

17640XFF,0XFD,0XFF,0XDA,0XFF,0X54,0XE6,0X8D,0XD5,0XE8,0XE6,0X48,0XF6,0XA8,0XEE,0X27,

17650XEE,0X47,0XEE,0X48,0XEE,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X47,0XEE,0X47,

17660XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X27,

17670XF6,0X27,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,

17680XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X49,

17690XEE,0X29,0XE6,0X2B,0X8B,0XA3,0X49,0XE0,0X4A,0X02,0X41,0XC2,0X49,0XE4,0X31,0X62,

17700XAD,0X52,0XFF,0XFE,0XFF,0XFE,0XF7,0X9D,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

17820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFC,

17830XFF,0XD8,0XFF,0X74,0XE6,0X8D,0XDE,0X09,0XE6,0X69,0XE6,0X48,0XEE,0X48,0XEE,0X48,

17840XEE,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,

17850XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,

17860XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,

17870XEE,0X47,0XEE,0X47,0XF6,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X29,0XEE,0X29,0XEE,0X4B,

17880X8B,0XA3,0X52,0X00,0X49,0XC1,0X49,0XE3,0X49,0XE3,0X39,0X62,0X8C,0X2E,0XFF,0XBD,

17890XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBF,0XFF,0XDE,0XFF,0XDE,

18010XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDD,0XFF,0XFC,0XFF,0XFA,

18020XFF,0X74,0XDE,0X6E,0XDE,0X2A,0XE6,0X49,0XE6,0X28,0XEE,0X28,0XEE,0X28,0XF6,0X28,

18030XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

18040XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,0XF6,0X27,0XF6,0X27,

18050XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

18060XF6,0X48,0XF6,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X49,0XE6,0X4B,0X9C,0X05,0X52,0X00,

18070X49,0XE1,0X49,0XE2,0X49,0XE3,0X39,0XA3,0X62,0XC8,0XEF,0X7B,0XFF,0XFE,0XFF,0XFF,

18080XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18190XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,

18200XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XFF,0XF9,0XFF,0X54,

18210XDE,0X6D,0XDE,0X2A,0XE6,0X29,0XEE,0X29,0XEE,0X48,0XEE,0X47,0XF6,0X27,0XF6,0X27,

18220XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X48,0XEE,0X47,

18230XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X28,0XF6,0X28,

18240XF6,0X48,0XF6,0X48,0XF6,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X28,

18250XFE,0X28,0XF6,0X48,0XF6,0X49,0XEE,0X8B,0X9C,0X45,0X5A,0X20,0X49,0XE1,0X49,0XE2,

18260X49,0XE3,0X41,0XC3,0X42,0X04,0XDE,0XF9,0XFF,0XDD,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,

18270XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18380XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

18390XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFC,0XFF,0XF9,0XEF,0X31,0XD6,0X4C,

18400XD5,0XE9,0XEE,0X4A,0XEE,0X48,0XEE,0X27,0XF6,0X67,0XF6,0X26,0XF6,0X26,0XF6,0X47,

18410XF6,0X46,0XEE,0X47,0XEE,0X47,0XEE,0X48,0XEE,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,

18420XF6,0X27,0XF6,0X27,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

18430XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

18440XEE,0X69,0XEE,0X6B,0XAC,0XA6,0X62,0X40,0X51,0XE1,0X49,0XE2,0X49,0XE2,0X41,0XE3,

18450X39,0XC3,0XC6,0X35,0XFF,0XFD,0XFF,0XFF,0XF7,0XDE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

18460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

18580XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFB,0XFF,0XB6,0XE6,0XF0,0XDE,0X2C,0XDE,0X2A,

18590XEE,0X28,0XEE,0X47,0XF6,0X47,0XF6,0X26,0XF6,0X26,0XF6,0X46,0XF6,0X46,0XEE,0X47,

18600XEE,0X47,0XEE,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

18610XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

18620XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X69,0XEE,0X8B,

18630XB4,0XC6,0X62,0X60,0X51,0XE1,0X52,0X03,0X49,0XE2,0X4A,0X03,0X39,0XA2,0XB5,0X92,

18640XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

18770XFF,0XDE,0XFF,0XFD,0XFF,0XFA,0XFF,0X95,0XE6,0XB0,0XDE,0X0B,0XE6,0X28,0XEE,0X68,

18780XF6,0X26,0XF6,0X46,0XF6,0X26,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X48,

18790XF6,0X48,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X47,

18800XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

18810XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XEE,0X69,0XF6,0X8B,0XB4,0XC7,0X6A,0X80,

18820X5A,0X01,0X52,0X02,0X49,0XE2,0X4A,0X03,0X39,0XC2,0X94,0XAF,0XFF,0XFE,0XFF,0XFF,

18830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,

18960XFF,0XFC,0XFF,0XD9,0XF7,0X54,0XDE,0X4D,0XDE,0X09,0XEE,0X68,0XEE,0X46,0XF6,0X47,

18970XF6,0X47,0XF6,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,

18980XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

18990XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X48,0XF6,0X48,

19000XF6,0X48,0XF6,0X68,0XF6,0X48,0XF6,0X8B,0XBC,0XE7,0X6A,0XA1,0X5A,0X21,0X52,0X23,

19010X49,0XE2,0X52,0X23,0X41,0XE2,0X8C,0X2D,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XFF,0XFC,

19150XFF,0XB8,0XEE,0XD2,0XDE,0X0A,0XE6,0X48,0XEE,0X47,0XF6,0X46,0XF6,0X47,0XF6,0X47,

19160XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,

19170XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

19180XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X68,

19190XF6,0X69,0XF6,0X8B,0XBC,0XE7,0X72,0XE1,0X62,0X42,0X5A,0X43,0X52,0X02,0X52,0X23,

19200X41,0XE3,0X84,0X0C,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XDB,0XFF,0X76,

19340XE6,0X4D,0XDE,0X29,0XEE,0X47,0XEE,0X46,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XF6,0X48,

19350XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,

19360XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

19370XF6,0X67,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X89,0XF6,0X8B,

19380XBD,0X07,0X7B,0X01,0X62,0X62,0X5A,0X43,0X52,0X02,0X52,0X23,0X49,0XE3,0X8C,0X0C,

19390XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19520XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDD,0XFF,0XDA,0XEE,0XF2,0XDE,0X0B,

19530XE6,0X28,0XEE,0X46,0XEE,0X46,0XEE,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,

19540XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

19550XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X47,

19560XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X8A,0XC5,0X07,0X83,0X42,

19570X62,0X62,0X62,0X63,0X52,0X22,0X52,0X43,0X4A,0X03,0X8C,0X0C,0XFF,0XFD,0XFF,0XFE,

19580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19710XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFC,0XFF,0X77,0XDE,0X0D,0XDE,0X09,0XEE,0X67,

19720XEE,0X46,0XEE,0X46,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,

19730XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

19740XF6,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X48,0XF6,0X48,

19750XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X8A,0XC5,0X27,0X8B,0X83,0X6A,0X82,0X62,0X83,

19760X5A,0X42,0X5A,0X63,0X52,0X43,0X8C,0X2C,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

19900XFF,0XFF,0XFF,0XDD,0XFF,0XDB,0XF6,0XF3,0XDE,0X0B,0XE6,0X48,0XEE,0X46,0XEE,0X46,

19910XF6,0X47,0XF6,0X48,0XF6,0X47,0XFE,0X48,0XF6,0X27,0XF6,0X47,0XEE,0X47,0XF6,0X47,

19920XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

19930XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,

19940XF6,0X68,0XF6,0X69,0XCD,0X67,0X93,0XC3,0X72,0XC2,0X6A,0XA3,0X6A,0XA3,0X5A,0X63,

19950X5A,0X64,0X8C,0X2C,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,

20090XFF,0X7B,0XFF,0X98,0XDE,0X0C,0XE6,0X49,0XE6,0X27,0XF6,0X66,0XF6,0X47,0XF6,0X47,

20100XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

20110XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,

20120XF6,0X67,0XF6,0X67,0XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XEE,0X69,

20130XCD,0X67,0X9B,0XE4,0X72,0XC2,0X72,0XC3,0X6A,0XC4,0X62,0XA4,0X5A,0X84,0X8C,0X2C,

20140XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20270XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0X9A,

20280XF7,0X13,0XCD,0XA8,0XEE,0X68,0XEE,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X47,0XF6,0X27,

20290XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

20300XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

20310XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X69,0XD5,0X67,0XA4,0X04,

20320X7A,0XE2,0X72,0XE4,0X72,0XE4,0X6A,0XC4,0X62,0XA5,0X94,0X4D,0XFF,0XFD,0XFF,0XFF,

20330XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

20460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFD,0XFF,0X76,0XD5,0XCC,

20470XDD,0XE9,0XEE,0X48,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X27,0XF6,0X48,0XF6,0X48,

20480XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,

20490XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X48,0XF6,0X48,

20500XF6,0X48,0XFE,0X68,0XFE,0X68,0XF6,0X69,0XD5,0X87,0XA4,0X24,0X7B,0X03,0X7B,0X04,

20510X7B,0X04,0X72,0XE4,0X6A,0XC5,0X9C,0X8E,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

20520XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20650XFF,0XFF,0XF7,0XDE,0XFF,0XFF,0XFF,0XFD,0XFF,0XBA,0XE6,0X50,0XD5,0X89,0XEE,0X29,

20660XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XF6,0X68,0XF6,0X48,0XF6,0X48,

20670XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,

20680XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XFE,0X68,

20690XFE,0X68,0XF6,0X69,0XD5,0X88,0XA4,0X24,0X83,0X23,0X7B,0X04,0X7B,0X25,0X73,0X05,

20700X6A,0XE6,0XAD,0X10,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

20710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFE,

20840XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XF7,0X15,0XD5,0X6B,0XEE,0X2A,0XF6,0X48,0XF6,0X67,

20850XF6,0X47,0XF6,0X67,0XEE,0X67,0XF6,0X68,0XF6,0X47,0XF6,0X28,0XF6,0X47,0XF6,0X47,

20860XF6,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X67,0XF6,0X67,

20870XF6,0X67,0XF6,0X67,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XFE,0X68,0XFE,0X88,0XF6,0X89,

20880XDD,0XA8,0XA4,0X04,0X8B,0X64,0X83,0X45,0X83,0X65,0X73,0X05,0X6A,0XC5,0XBD,0X92,

20890XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21020XFF,0XFF,0XFF,0XDF,0XFF,0XBF,0XFF,0XDF,0XFF,0XFF,0XF7,0XFE,0XFF,0XFE,0XFF,0XFE,

21030XFF,0XFD,0XFF,0X58,0XDD,0XCE,0XE5,0XEA,0XF6,0X49,0XF6,0X67,0XF6,0X67,0XEE,0X67,

21040XEE,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,

21050XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

21060XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XFE,0X68,0XF6,0X89,0XDD,0XC8,0XA4,0X03,

21070X93,0XA5,0X8B,0X85,0X8B,0XA6,0X7B,0X46,0X73,0X06,0XD6,0X55,0XFF,0XDD,0XFF,0XFF,

21080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

21210XFF,0XBF,0XFF,0XDF,0XFF,0XFE,0XF7,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0X7A,

21220XE6,0X31,0XDD,0XAB,0XEE,0X49,0XF6,0X47,0XF6,0X68,0XEE,0X47,0XF6,0X67,0XEE,0X47,

21230XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X48,0XF6,0X48,

21240XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X48,0XF6,0X68,

21250XF6,0X68,0XF6,0X68,0XF6,0X68,0XFE,0X89,0XDD,0XC8,0X9B,0XE3,0X9B,0XE5,0X93,0XA6,

21260X93,0XE7,0X83,0X86,0X83,0X88,0XEE,0XF8,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

21400XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XBB,0XEE,0XD3,0XCD,0X8A,

21410XE6,0X29,0XF6,0X47,0XF6,0X28,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

21420XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

21430XFE,0X48,0XF6,0X47,0XFE,0X88,0XF6,0X67,0XF6,0X47,0XFE,0X68,0XF6,0X68,0XF6,0X68,

21440XF6,0X68,0XFE,0X8A,0XDD,0XA8,0XA4,0X04,0X9B,0XE5,0X93,0XE6,0X94,0X26,0X83,0XA6,

21450X8C,0X0B,0XFF,0X9B,0XFF,0XFD,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XEE,0XF5,0XCD,0XAB,0XE6,0X29,0XEE,0X48,

21600XF6,0X28,0XFE,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,

21610XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XFE,0X48,0XFE,0X48,0XFE,0X48,0XFE,0X47,

21620XFE,0X68,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XFE,0XA9,0XFE,0X8A,

21630XCD,0X47,0XA4,0X24,0XA4,0X26,0X94,0X06,0X94,0X26,0X83,0XC6,0XAD,0X0F,0XFF,0XDD,

21640XFF,0XFE,0XFF,0XFE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21780XFF,0XFF,0XFF,0XFC,0XF7,0X36,0XCD,0XCC,0XDE,0X09,0XEE,0X48,0XF6,0X28,0XFE,0X48,

21790XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X48,0XF6,0X48,

21800XF6,0X48,0XF6,0X48,0XFE,0X48,0XFE,0X48,0XFE,0X48,0XFE,0X48,0XFE,0X68,0XF6,0X47,

21810XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X88,0XFE,0XAA,0XFE,0XAA,0XC4,0XE6,0XAC,0X45,

21820XAC,0X67,0X9C,0X26,0X94,0X26,0X8B,0XE7,0XC5,0XF3,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,

21830XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,

21970XF7,0X57,0XCD,0XCD,0XDD,0XE9,0XEE,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

21980XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

21990XFE,0X48,0XFE,0X48,0XFE,0X48,0XFE,0X67,0XFE,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,

22000XF6,0X67,0XF6,0X89,0XFE,0XCA,0XF6,0X8A,0XC4,0XC5,0XB4,0X86,0XAC,0X87,0XA4,0X67,

22010X9C,0X67,0X94,0X28,0XDE,0XB6,0XFF,0XFD,0XFF,0XDD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

22020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

22120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0X78,0XD5,0XEE,

22160XD5,0XA9,0XEE,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,

22170XF6,0X48,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

22180XFE,0X48,0XFE,0X68,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XFE,0XA9,

22190XFE,0XCB,0XEE,0X09,0XC4,0XC5,0XC4,0XE7,0XBC,0XC8,0XAC,0X87,0XA4,0XA8,0XA4,0XCB,

22200XFF,0X7A,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0X9A,0XDE,0X30,0XCD,0X89,0XEE,0X49,

22350XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X47,

22360XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XFE,0X47,0XFE,0X68,

22370XF6,0X47,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X88,0XFE,0XA9,0XFE,0XCB,0XDD,0X87,

22380XC4,0XC5,0XCD,0X07,0XC5,0X08,0XB4,0XC8,0XAC,0XC9,0XBD,0X8F,0XFF,0XFB,0XFF,0XFE,

22390XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22530XFF,0XFF,0XFF,0XFE,0XFF,0XBA,0XE6,0X92,0XCD,0X89,0XEE,0X29,0XF6,0X48,0XF6,0X48,

22540XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X47,

22550XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

22560XF6,0X68,0XF6,0X68,0XFE,0XA9,0XFE,0XA9,0XFE,0X8A,0XD5,0X46,0XC4,0XE5,0XCD,0X27,

22570XC5,0X28,0XBD,0X0A,0XAC,0XCA,0XE6,0XB4,0XFF,0XDC,0XFF,0XDD,0XFF,0XFE,0XFF,0XFE,

22580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

22720XFF,0XDB,0XEE,0XB3,0XCD,0X69,0XEE,0X29,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X67,

22730XF6,0X47,0XF6,0X47,0XFE,0X67,0XFE,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,

22740XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X68,

22750XFE,0XC9,0XFE,0XAA,0XF6,0X49,0XD5,0X66,0XD5,0X46,0XCD,0X27,0XC5,0X28,0XC5,0X4B,

22760XB4,0XEB,0XFF,0X78,0XFF,0XFD,0XFF,0XDE,0XFF,0XFF,0XF7,0XFE,0XFF,0XFF,0XFF,0XFF,

22770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBF,0XFF,0XDF,

22840XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

22850XF7,0XFF,0XF7,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

22860XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22870XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XF7,0XFE,0XF7,0XFE,

22880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDC,0XE6,0XB3,

22910XC5,0X69,0XEE,0X4A,0XF6,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XFE,0X67,

22920XFE,0X67,0XFE,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

22930XF6,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X88,0XF6,0X47,0XF6,0X88,0XFE,0XEA,0XFE,0XAA,

22940XDD,0XC6,0XDD,0X86,0XCD,0X05,0XCD,0X68,0XC5,0X08,0XBD,0X2B,0XCD,0XF0,0XFF,0XB9,

22950XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBE,0XFF,0XDE,

23030XFF,0XDE,0XFF,0XFE,0XFF,0XDD,0XFF,0XDC,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,

23040XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XFE,0XFF,0XDD,0XFF,0XDE,

23050XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBD,

23060XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XF7,0XFE,0XFF,0XFF,0XFF,0XFF,

23070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDD,0XE6,0XB4,0XC5,0X6A,0XEE,0X29,

23100XF6,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XFE,0X67,0XFE,0X67,0XFE,0X47,

23110XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

23120XF6,0X67,0XF6,0X67,0XF6,0X68,0XFE,0XA9,0XFE,0XCA,0XF6,0X89,0XDD,0XA6,0XDD,0X86,

23130XD5,0X87,0XCD,0X68,0XC5,0X6A,0XBD,0X2B,0XE6,0XB4,0XFF,0XDB,0XFF,0XFE,0XFF,0XFF,

23140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23210XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XFC,0XFF,0X9A,0XFF,0XDA,

23220XFF,0XDA,0XFF,0XDA,0XFF,0XDA,0XF7,0X79,0XEF,0X38,0XE7,0X18,0XDE,0XF8,0XE6,0XF8,

23230XE7,0X19,0XEF,0X39,0XEF,0X18,0XEF,0X18,0XEE,0XF7,0XEF,0X38,0XEF,0X39,0XEF,0X39,

23240XEF,0X19,0XEF,0X19,0XF7,0X5A,0XFF,0X9B,0XFF,0XDC,0XFF,0XDD,0XFF,0XBC,0XFF,0XBD,

23250XFF,0XFE,0XFF,0XFE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23280XFF,0XFF,0XFF,0XDE,0XFF,0XDD,0XE6,0XB4,0XC5,0X69,0XEE,0X29,0XF6,0X48,0XF6,0X67,

23290XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XF6,0X67,0XF6,0X67,

23300XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XF6,0X67,0XFE,0X67,0XF6,0X67,

23310XF6,0X68,0XFE,0XCA,0XFE,0XAA,0XEE,0X48,0XDD,0XC6,0XDD,0X86,0XDD,0XC8,0XCD,0X68,

23320XC5,0X6B,0XCD,0XAE,0XF7,0X57,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

23400XFF,0X9D,0XFF,0XDC,0XFF,0XDA,0XFF,0XB9,0XFF,0X77,0XFF,0X76,0XFF,0X55,0XFF,0X55,

23410XFF,0X55,0XF7,0X55,0XDE,0X93,0XBD,0XAF,0XAD,0X0D,0X94,0X6B,0X8C,0X2A,0X8C,0X2A,

23420X9C,0X4A,0X8C,0X09,0X94,0X29,0X94,0X29,0X94,0X29,0X94,0X09,0X94,0X0A,0X94,0X0B,

23430XA4,0X8D,0XB5,0X2F,0XCD,0XD2,0XEE,0XD7,0XFF,0XBB,0XFF,0XDC,0XFF,0XDD,0XFF,0XFE,

23440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

23470XFF,0XDD,0XE6,0X94,0XC5,0X49,0XE6,0X29,0XF6,0X48,0XFE,0X68,0XF6,0X47,0XF6,0X47,

23480XFE,0X67,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

23490XF6,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XFE,0X67,0XF6,0X47,0XFE,0X88,0XFE,0XCA,

23500XFE,0X89,0XEE,0X07,0XE5,0XC6,0XE5,0XC7,0XD5,0XA8,0XCD,0X89,0XC5,0X6C,0XE6,0X93,

23510XFF,0XBA,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XBC,0XFF,0XFB,0XFF,0XD9,

23590XEE,0XF4,0XE6,0XB0,0XE6,0X90,0XE6,0X8F,0XEE,0X8E,0XE6,0X6D,0XE6,0X8E,0XF6,0XF0,

23600XF7,0X32,0XEE,0XF1,0XE6,0X90,0XC5,0XAD,0XA4,0XA9,0X9C,0X47,0XA4,0X88,0X9C,0X67,

23610X9C,0X26,0X9C,0X46,0XA4,0X66,0XA4,0X67,0X9C,0X27,0X93,0XE6,0X93,0XC6,0X93,0XE7,

23620X9C,0X29,0XB4,0XED,0XD6,0X12,0XF7,0X38,0XFF,0XBB,0XFF,0XDD,0XFF,0XDE,0XFF,0XFF,

23630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23650XFF,0XFF,0XF7,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBC,0XDE,0X74,

23660XC5,0X49,0XE6,0X29,0XF6,0X68,0XFE,0X67,0XF6,0X47,0XF6,0X47,0XFE,0X67,0XFE,0X47,

23670XFE,0X47,0XFE,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,

23680XFE,0X67,0XFE,0X67,0XFE,0X88,0XF6,0X68,0XFE,0X89,0XFE,0XCA,0XF6,0X69,0XEE,0X08,

23690XE5,0XE7,0XEE,0X28,0XD5,0X88,0XD5,0XCB,0XD6,0X0F,0XF7,0X37,0XFF,0XFC,0XFF,0XFE,

23700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

23770XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFC,0XFF,0X98,0XDE,0XB1,0XCD,0XEC,0XD5,0XCA,

23780XDE,0X0B,0XD5,0XE9,0XDE,0X09,0XDE,0X09,0XDE,0X09,0XDE,0X2A,0XE6,0X4B,0XF6,0XEF,

23790XFF,0X50,0XFF,0X71,0XEE,0XCF,0XDE,0X4C,0XCD,0X89,0XCD,0XC9,0XCD,0XA9,0XCD,0X68,

23800XC5,0X48,0XC5,0X48,0XC5,0X28,0XC5,0X08,0XBC,0XE8,0XC4,0XE9,0XBC,0XC9,0XB4,0XA9,

23810XAC,0X8A,0XC5,0X90,0XF7,0X38,0XFF,0XFC,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

23840XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDE,0XFF,0XBC,0XE6,0X94,0XC5,0X49,0XEE,0X29,

23850XF6,0X68,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,

23860XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

23870XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0XAA,0XF6,0X69,0XEE,0X28,0XEE,0X07,0XE5,0XE8,

23880XE6,0X0B,0XD5,0XCC,0XE6,0XD3,0XFF,0XB9,0XFF,0XDC,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23950XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23960XFF,0XFD,0XFF,0XDA,0XCE,0X50,0XAD,0X29,0XCD,0XA9,0XDE,0X09,0XE6,0X49,0XE6,0X08,

23970XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X28,0XDE,0X09,0XDE,0X09,0XF6,0XED,

23980XFF,0X8F,0XFF,0X2D,0XDE,0X29,0XDE,0X09,0XE5,0XE9,0XDD,0XA8,0XD5,0X87,0XD5,0X88,

23990XDD,0X87,0XD5,0X67,0XD5,0X47,0XCD,0X27,0XCD,0X27,0XC4,0XE8,0XBC,0XC8,0XB4,0XAA,

24000XC5,0X6F,0XEE,0XF6,0XFF,0XDB,0XFF,0XBC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,

24030XFF,0XFF,0XFF,0XFF,0XFF,0XBC,0XDE,0X53,0XC5,0X49,0XEE,0X49,0XF6,0X68,0XF6,0X47,

24040XF6,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XF6,0X67,0XF6,0X67,

24050XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X89,

24060XFE,0XA9,0XFE,0X69,0XF6,0X49,0XF6,0X29,0XEE,0X28,0XE5,0XE8,0XEE,0X4C,0XDE,0X2E,

24070XF7,0X56,0XFF,0XFB,0XF7,0XBD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24140XFF,0XFE,0XFF,0XFE,0XF7,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0X9D,0XFF,0XDB,0XCE,0X31,

24150XBD,0X8A,0XC5,0XA8,0XE6,0X4A,0XE6,0X29,0XDD,0XC6,0XE6,0X06,0XEE,0X26,0XEE,0X26,

24160XEE,0X26,0XEE,0X27,0XEE,0X28,0XE6,0X28,0XDE,0X08,0XDD,0XE8,0XFE,0XEC,0XFF,0X8E,

24170XFF,0X4D,0XEE,0X69,0XDD,0XC7,0XD5,0XA7,0XDD,0XA7,0XDD,0XA7,0XDD,0X87,0XDD,0X66,

24180XD5,0X46,0XD5,0X26,0XCD,0X06,0XCD,0X27,0XC5,0X28,0XB4,0XE8,0XAC,0XAA,0XBD,0X2D,

24190XDE,0X74,0XFF,0XDB,0XFF,0XBD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

24200XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,

24220XF7,0X3A,0XBD,0X6F,0XC5,0X69,0XEE,0X4A,0XF6,0X48,0XF6,0X47,0XFE,0X67,0XFE,0X68,

24230XFE,0X47,0XFE,0X47,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

24240XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0XA9,0XFE,0XAA,0XF6,0X69,

24250XF6,0X49,0XF6,0X49,0XEE,0X28,0XEE,0X4A,0XDD,0XEC,0XEE,0XD2,0XFF,0XB9,0XFF,0XDC,

24260XFF,0XDE,0XF7,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

24330XFF,0XFF,0XFF,0XFF,0XFF,0XBF,0XFF,0XDD,0XEE,0XD5,0XAC,0XA9,0XD5,0XE9,0XE6,0X08,

24340XE6,0X08,0XEE,0X28,0XEE,0X48,0XEE,0X27,0XEE,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X27,

24350XEE,0X28,0XE6,0X07,0XE6,0X28,0XEE,0X48,0XE6,0X08,0XEE,0X8A,0XFF,0X6D,0XFF,0X2C,

24360XE6,0X49,0XDD,0XE8,0XDD,0XC7,0XDD,0XA7,0XDD,0X87,0XDD,0X87,0XD5,0X26,0XD5,0X26,

24370XD5,0X47,0XCD,0X47,0XBC,0XE6,0XB4,0XC7,0XB4,0XE8,0XAC,0XA9,0XBD,0X4C,0XDE,0X73,

24380XFF,0XBB,0XFF,0XDD,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,

24390XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

24400XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XBD,0XF7,0X58,0XB5,0X0C,

24410XD5,0XAA,0XEE,0X29,0XFE,0X69,0XF6,0X27,0XFE,0X47,0XFE,0X47,0XFE,0X68,0XF6,0X67,

24420XFE,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

24430XFE,0X67,0XFE,0X68,0XFE,0X89,0XFE,0XAA,0XFE,0X8A,0XF6,0X69,0XF6,0X49,0XF6,0X69,

24440XEE,0X49,0XE6,0X0B,0XEE,0XB1,0XFF,0X57,0XFF,0XDC,0XFF,0XFF,0XF7,0XDF,0XFF,0XFF,

24450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,

24520XFF,0XDE,0XFF,0X7A,0XBD,0X2D,0XC5,0X29,0XEE,0X29,0XEE,0X48,0XE5,0XE7,0XEE,0X07,

24530XEE,0X27,0XEE,0X26,0XEE,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X48,

24540XEE,0X28,0XE5,0XE7,0XE6,0X28,0XEE,0X69,0XEE,0X8A,0XFF,0X6D,0XFF,0X6D,0XE6,0X69,

24550XDD,0XC7,0XD5,0XA7,0XDD,0X87,0XDD,0XA8,0XDD,0X87,0XD5,0X26,0XD5,0X67,0XCD,0X26,

24560XC5,0X06,0XC5,0X27,0XBD,0X08,0XAC,0X86,0XAC,0X87,0XB5,0X0B,0XDE,0X73,0XFF,0XBB,

24570XFF,0XFD,0XFF,0XBD,0XFF,0XDE,0XFF,0XFF,0XF7,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24590XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDC,0XEF,0X16,0XB4,0XEA,0XDE,0X0A,0XEE,0X28,

24600XFE,0X68,0XFE,0X27,0XFE,0X47,0XFE,0X47,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,

24610XFE,0X68,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X66,0XFE,0X67,0XFE,0X67,0XFE,0X68,

24620XFE,0XA9,0XFE,0XAA,0XF6,0X89,0XF6,0X69,0XF6,0X69,0XEE,0X49,0XEE,0X4B,0XE6,0X6E,

24630XFF,0X15,0XFF,0XBA,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDE,0XFF,0XDD,0XDE,0X75,

24710XB4,0XEA,0XE6,0X2B,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X26,

24720XEE,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

24730XF6,0X68,0XEE,0X68,0XE6,0X28,0XF6,0XAA,0XFF,0X4D,0XFF,0X2C,0XF6,0XAB,0XDD,0XC8,

24740XD5,0X87,0XDD,0XA7,0XDD,0X87,0XD5,0X66,0XD5,0X66,0XCD,0X06,0XCD,0X47,0XCD,0X47,

24750XBC,0XC6,0XBC,0XE8,0XBD,0X09,0XA4,0X67,0XAC,0XAA,0XD6,0X31,0XFF,0X78,0XFF,0XFC,

24760XFF,0XDD,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24780XFF,0XFE,0XFF,0XDB,0XD6,0X71,0XB4,0XE7,0XE6,0X49,0XF6,0X67,0XF6,0X47,0XFE,0X47,

24790XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X47,0XFE,0X68,0XF6,0X67,

24800XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X88,0XFE,0X68,0XFE,0X89,0XFE,0XA9,

24810XFE,0X88,0XF6,0X88,0XF6,0X88,0XEE,0X6A,0XE6,0X4D,0XF6,0XD2,0XFF,0X98,0XFF,0XFC,

24820XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XF7,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDC,0XBD,0X6F,0XCD,0XAB,0XE6,0X2A,

24900XE6,0X07,0XF6,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X46,0XF6,0X46,0XEE,0X26,

24910XEE,0X27,0XF6,0X27,0XEE,0X07,0XF6,0X27,0XEE,0X47,0XF6,0X47,0XEE,0X27,0XE6,0X27,

24920XEE,0X68,0XE6,0X48,0XF6,0XAA,0XFF,0X4D,0XFF,0X4D,0XEE,0X8A,0XDD,0XC7,0XD5,0XA7,

24930XD5,0X87,0XD5,0X86,0XD5,0X66,0XD5,0X66,0XC5,0X05,0XC4,0XE6,0XC5,0X27,0XBD,0X07,

24940XB4,0XC7,0XB4,0XC8,0XA4,0X67,0XAC,0XC9,0XCD,0XF0,0XF7,0X58,0XFF,0XDC,0XFF,0XFE,

24950XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24960XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XD9,

24970XBD,0X6B,0XC5,0X67,0XEE,0X68,0XF6,0X87,0XF6,0X26,0XFE,0X67,0XFE,0X46,0XFE,0X67,

24980XFE,0X67,0XFE,0X67,0XFE,0X47,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XFE,0X67,

24990XFE,0X87,0XF6,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0XA8,0XFE,0XA8,0XF6,0XA8,

25000XEE,0X89,0XEE,0X8C,0XEE,0XB1,0XFF,0X97,0XFF,0XDB,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,

25010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

25080XFF,0XFF,0XFF,0XDD,0XFF,0X99,0XBD,0X4C,0XDE,0X0B,0XE6,0X08,0XF6,0X47,0XF6,0X47,

25090XEE,0X07,0XEE,0X07,0XEE,0X06,0XEE,0X26,0XF6,0X46,0XF6,0X26,0XF6,0X26,0XF6,0X47,

25100XF6,0X27,0XF6,0X48,0XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XF6,0X68,0XEE,0X48,

25110XEE,0X68,0XF6,0XAA,0XFF,0X2C,0XFF,0X4D,0XEE,0X8A,0XD5,0XC7,0XD5,0XA7,0XD5,0X86,

25120XD5,0X66,0XD5,0X66,0XCD,0X05,0XC5,0X05,0XCD,0X27,0XBC,0XE7,0XB4,0XA6,0XBC,0XE7,

25130XB4,0XC7,0XAC,0XA7,0XAC,0X89,0XC5,0XB0,0XF7,0X59,0XFF,0XFE,0XF7,0XBD,0XFF,0XFF,

25140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFC,0XEE,0XD4,0XB5,0X07,0XDE,0X28,

25160XEE,0X67,0XF6,0X86,0XFE,0X67,0XFE,0X47,0XFE,0X46,0XFE,0X67,0XFE,0X67,0XFE,0X67,

25170XFE,0X67,0XFE,0X66,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X88,0XFE,0X88,

25180XFE,0X89,0XFE,0XC9,0XFE,0XA8,0XF6,0X87,0XF6,0X88,0XEE,0X89,0XEE,0X8B,0XEE,0XD0,

25190XF7,0X56,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBF,0XFF,0XFF,0XFF,0XDC,

25270XE6,0XB4,0XCD,0XCD,0XE6,0X4A,0XEE,0X68,0XF6,0X26,0XEE,0X05,0XF6,0X27,0XF6,0X27,

25280XF6,0X27,0XF6,0X47,0XF6,0X46,0XF6,0X46,0XF6,0X26,0XF6,0X47,0XF6,0X47,0XF6,0X27,

25290XF6,0X27,0XF6,0X27,0XF6,0X67,0XFE,0X88,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X48,

25300XF6,0XAA,0XFF,0X4D,0XFF,0X2C,0XE6,0X69,0XD5,0XE7,0XCD,0X86,0XCD,0X86,0XCD,0X45,

25310XD5,0X66,0XD5,0X67,0XC5,0X06,0XC4,0XE6,0XC5,0X07,0XBC,0XC6,0XBC,0XC6,0XB4,0X86,

25320XA4,0X47,0XA4,0X8A,0XC5,0XB1,0XF7,0X39,0XFF,0XDC,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

25330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XDE,

25340XFF,0XFF,0XFF,0XFE,0XFF,0XBA,0XD5,0XEE,0XAC,0XA4,0XF6,0XA9,0XF6,0X67,0XF6,0X46,

25350XFE,0XA8,0XF6,0X26,0XFE,0X67,0XFE,0X67,0XF6,0X47,0XFE,0X67,0XFE,0X66,0XFE,0X66,

25360XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XF6,0X88,0XF6,0X89,0XFE,0XA9,0XFE,0XA9,

25370XFE,0XA8,0XF6,0X88,0XEE,0X89,0XE6,0X4A,0XE6,0X8E,0XF7,0X54,0XFF,0XDB,0XFF,0XDD,

25380XFF,0XDE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

25390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XFF,0XFC,0XDE,0X72,0XD6,0X0C,

25460XE6,0X28,0XF6,0X47,0XF6,0X06,0XF6,0X26,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

25470XF6,0X47,0XF6,0X46,0XF6,0X46,0XF6,0X46,0XF6,0X47,0XF6,0X06,0XFE,0X47,0XFE,0X47,

25480XF6,0X26,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XEE,0X47,0XEE,0X48,0XE6,0X28,0XF6,0XA9,

25490XFF,0X4C,0XFF,0X4C,0XEE,0X89,0XD5,0XA6,0XD5,0XA6,0XCD,0X66,0XCD,0X46,0XCD,0X46,

25500XC5,0X26,0XBC,0XE6,0XBC,0XC6,0XBC,0XE6,0XC4,0XC7,0XB4,0X86,0XB4,0X88,0XA4,0X48,

25510X9C,0X29,0XC5,0X90,0XEF,0X17,0XFF,0XFB,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

25520XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XFF,0XDC,

25530XFF,0X77,0XAC,0X67,0XD5,0XE8,0XEE,0X68,0XF6,0X67,0XF6,0X67,0XFE,0X88,0XF6,0X26,

25540XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X66,0XF6,0X66,0XF6,0X66,0XF6,0X67,

25550XF6,0X67,0XF6,0X88,0XF6,0X69,0XFE,0X89,0XFE,0XAA,0XF6,0X89,0XF6,0X89,0XF6,0XAA,

25560XEE,0X8B,0XE6,0X6D,0XEF,0X13,0XFF,0XB9,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25570XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25640XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XDB,0XE6,0XB1,0XD6,0X2B,0XE6,0X48,0XEE,0X26,

25650XFE,0X27,0XFE,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X46,

25660XF6,0X46,0XF6,0X46,0XF6,0X27,0XFE,0X47,0XF6,0X26,0XF6,0X47,0XF6,0X47,0XF6,0X27,

25670XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XEE,0X47,0XEE,0X68,0XF6,0XA9,0XFF,0X2B,

25680XFF,0X4C,0XE6,0X69,0XCD,0X86,0XCD,0X86,0XCD,0X66,0XC5,0X26,0XC5,0X06,0XC5,0X27,

25690XC5,0X27,0XBC,0XC6,0XBC,0XA6,0XBC,0X87,0XB4,0X87,0XAC,0X67,0X9C,0X06,0X94,0X27,

25700XAD,0X2C,0XEF,0X15,0XFF,0XBA,0XFF,0XFC,0XFF,0XDE,0XFF,0XFF,0XFF,0XDF,0XF7,0XBF,

25710XFF,0XDF,0XFF,0XDE,0XFF,0XDE,0XFF,0XFE,0XFF,0XDD,0XFF,0X99,0XC5,0X6D,0XC5,0X49,

25720XDD,0XE8,0XF6,0X88,0XF6,0X68,0XFE,0X88,0XF6,0X47,0XF6,0X67,0XFE,0X67,0XFE,0X47,

25730XFE,0X88,0XFE,0X67,0XFE,0X67,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X88,0XFE,0X89,

25740XFE,0X89,0XFE,0X8A,0XFE,0X8A,0XF6,0X89,0XF6,0XAA,0XF6,0X8B,0XE6,0X6D,0XEE,0XF2,

25750XFF,0XB8,0XFF,0XDC,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

25760XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

25830XFF,0XFE,0XFF,0XFB,0XE6,0XD1,0XD6,0X2B,0XEE,0X68,0XEE,0X47,0XF6,0X07,0XFE,0X07,

25840XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

25850XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

25860XF6,0X67,0XF6,0X67,0XF6,0X68,0XEE,0X47,0XEE,0X68,0XF6,0XCA,0XFF,0X4C,0XFF,0X6C,

25870XE6,0X89,0XCD,0XA6,0XC5,0X66,0XC5,0X46,0XBD,0X05,0XC5,0X06,0XC5,0X06,0XBC,0XE6,

25880XBC,0XA6,0XBC,0XA7,0XB4,0X87,0XAC,0X86,0XA4,0X66,0X9C,0X25,0X94,0X05,0X94,0X48,

25890XC5,0XF1,0XEF,0X38,0XFF,0XFD,0XFF,0XBD,0XFF,0XDE,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,

25900XFF,0XDE,0XFF,0X9C,0XFF,0XDA,0XE6,0X92,0XAC,0XA7,0XE6,0X0A,0XEE,0X49,0XF6,0X68,

25910XF6,0X48,0XF6,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

25920XFE,0X68,0XF6,0X67,0XF6,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X89,0XFE,0X8A,0XFE,0XAA,

25930XFE,0X8A,0XFE,0X8B,0XF6,0X6B,0XE6,0X6D,0XEE,0XD1,0XFF,0X97,0XFF,0XFC,0XFF,0XFE,

25940XF7,0XFE,0XF7,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFD,0XFF,0XFA,

26020XEF,0X12,0XDE,0X6C,0XE6,0X28,0XEE,0X47,0XFE,0X28,0XFE,0X07,0XF6,0X47,0XF6,0X47,

26030XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X47,

26040XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X47,

26050XF6,0X67,0XF6,0X88,0XF6,0X88,0XEE,0X68,0XF6,0XA9,0XFF,0X2B,0XFF,0X8D,0XEE,0XCA,

26060XD5,0XE8,0XC5,0X66,0XC5,0X46,0XBD,0X26,0XBC,0XC5,0XBC,0XC6,0XBC,0XA7,0XB4,0XA7,

26070XB4,0X86,0XAC,0X65,0XAC,0X85,0XA4,0X65,0X9C,0X24,0X8B,0XE5,0X94,0X28,0XAD,0X0E,

26080XD6,0X35,0XF7,0X7B,0XFF,0XFD,0XFF,0XDD,0XF7,0XBC,0XFF,0XFD,0XFF,0XBD,0XFF,0XBB,

26090XE6,0X93,0XBD,0X29,0XD5,0XA8,0XEE,0X48,0XF6,0X69,0XFE,0X68,0XF6,0X48,0XF6,0X68,

26100XF6,0X68,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,

26110XFE,0XA7,0XFE,0XA8,0XFE,0XA8,0XFE,0X89,0XFE,0X8A,0XFE,0X8B,0XFE,0X8B,0XF6,0X6B,

26120XEE,0X8D,0XF6,0XF1,0XFF,0X77,0XFF,0XBA,0XFF,0XFD,0XFF,0XFE,0XF7,0XFE,0XF7,0XFF,

26130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFA,0XF7,0X53,0XDE,0X4C,

26210XE6,0X29,0XF6,0X48,0XFE,0X48,0XFE,0X27,0XFE,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

26220XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X47,0XF6,0X67,0XFE,0X47,0XFE,0X67,0XFE,0X48,

26230XFE,0X48,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X68,

26240XFE,0X88,0XF6,0X68,0XEE,0X68,0XF6,0XA9,0XFF,0X2C,0XFF,0X6D,0XFF,0X2C,0XDE,0X49,

26250XBD,0X25,0XAC,0XC4,0XB4,0XC5,0XBC,0XE6,0XB4,0XC6,0XB4,0XA6,0XAC,0X65,0XA4,0X24,

26260XA4,0X24,0XA4,0X24,0X9C,0X04,0X8B,0XC4,0X83,0X84,0X83,0XA7,0X8C,0X0A,0XAD,0X0F,

26270XDE,0X75,0XF7,0X7A,0XFF,0XFB,0XFF,0XFB,0XFF,0X9A,0XF7,0X36,0XD5,0XED,0XC5,0X68,

26280XEE,0X89,0XF6,0X87,0XF6,0X67,0XF6,0X47,0XF6,0X68,0XFE,0X68,0XFE,0X87,0XF6,0X67,

26290XF6,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0XA7,0XF6,0XA7,

26300XFE,0XA8,0XFE,0XCA,0XFE,0XAB,0XFE,0X8C,0XF6,0X6C,0XEE,0X6D,0XEE,0XB1,0XFF,0X77,

26310XFF,0XFB,0XFF,0XDD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

26320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26390XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFB,0XFF,0X95,0XDE,0X4D,0XEE,0X8B,0XF6,0X49,

26400XFE,0X48,0XFE,0X27,0XFE,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,

26410XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,

26420XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X87,0XFE,0X67,0XF6,0X47,0XFE,0X67,0XF6,0X88,

26430XF6,0X68,0XEE,0X68,0XEE,0X89,0XF7,0X0B,0XFF,0X6D,0XFF,0X6D,0XDE,0X4A,0XC5,0X46,

26440XBC,0XE5,0XB4,0XC5,0XA4,0X65,0XA4,0X65,0XAC,0X65,0XA4,0X45,0X9C,0X04,0X9C,0X04,

26450X9B,0XE4,0X93,0XC4,0X8B,0XA5,0X7B,0X24,0X73,0X25,0X6A,0XC5,0X73,0X26,0X9C,0X4B,

26460XCD,0XF1,0XE6,0X93,0XFF,0X15,0XC5,0X6D,0XC5,0X69,0XEE,0X8A,0XF6,0X87,0XF6,0X86,

26470XFE,0X87,0XFE,0X67,0XFE,0X88,0XF6,0X88,0XF6,0X87,0XF6,0X86,0XF6,0X67,0XF6,0X67,

26480XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XF6,0XA7,0XF6,0XA7,0XFE,0XC9,0XFE,0XCA,

26490XFE,0XAC,0XF6,0X8D,0XEE,0X6E,0XF6,0XD1,0XFF,0X56,0XFF,0XDB,0XFF,0XFD,0XFF,0XDE,

26500XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

26580XFF,0XFE,0XFF,0XFB,0XFF,0XB6,0XDE,0X6F,0XEE,0X6C,0XEE,0X49,0XF6,0X28,0XFE,0X47,

26590XFE,0X66,0XFE,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X67,

26600XF6,0X67,0XF6,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,

26610XFE,0X67,0XFE,0X47,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X88,0XF6,0XA8,

26620XEE,0X68,0XEE,0XA9,0XEE,0XAA,0XFF,0X4D,0XFF,0XCF,0XF6,0XEC,0XCD,0X87,0XAC,0X83,

26630XAC,0XA5,0XA4,0X64,0X9C,0X24,0X9C,0X24,0X93,0XE4,0X93,0XA3,0X8B,0XA3,0X8B,0X83,

26640X7B,0X22,0X73,0X02,0X73,0X03,0X6A,0XC2,0X62,0X81,0X5A,0X60,0X49,0XC0,0X8B,0X84,

26650XC5,0X4A,0XD5,0XCB,0XEE,0X6B,0XEE,0X68,0XF6,0XA7,0XFE,0X86,0XF6,0X46,0XFE,0X88,

26660XFE,0X68,0XF6,0X87,0XF6,0X87,0XF6,0X86,0XF6,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X88,

26670XFE,0X87,0XFE,0X87,0XFE,0XA7,0XFE,0XC8,0XFE,0XCA,0XF6,0X8B,0XEE,0X6D,0XEE,0X6F,

26680XF6,0XF3,0XFF,0X77,0XFF,0XDB,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26690XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,

26770XFF,0XB8,0XF7,0X12,0XE6,0X2C,0XEE,0X2A,0XFE,0X48,0XFE,0X67,0XFE,0X66,0XFE,0X66,

26780XFE,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

26790XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X47,

26800XFE,0X67,0XFE,0X87,0XF6,0X67,0XF6,0X67,0XFE,0XA8,0XF6,0X88,0XF6,0X88,0XF6,0X89,

26810XEE,0X69,0XEE,0X89,0XFF,0X0C,0XFF,0X8E,0XFF,0X6E,0XF6,0XEC,0XB5,0X26,0XA4,0X84,

26820X93,0XE2,0X93,0XC2,0X8B,0XA3,0X83,0X62,0X7B,0X22,0X7B,0X01,0X72,0XE1,0X6A,0XA0,

26830X6A,0XA0,0X62,0X80,0X62,0X60,0X62,0X80,0XB4,0XC7,0XCD,0XA9,0XEE,0X4B,0XEE,0X4A,

26840XF6,0X69,0XF6,0X67,0XFE,0XA7,0XF6,0X86,0XFE,0X87,0XFE,0X88,0XF6,0X68,0XF6,0X88,

26850XF6,0X87,0XF6,0X87,0XF6,0X87,0XF6,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X87,0XFE,0XA7,

26860XFE,0XA8,0XFE,0XA9,0XF6,0X8B,0XEE,0X6D,0XEE,0XB0,0XF6,0XF4,0XFF,0X98,0XFF,0XDB,

26870XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XFF,0XD9,0XFF,0X54,

26960XE6,0X6E,0XEE,0X2A,0XF6,0X48,0XFE,0X66,0XFE,0X66,0XFE,0X66,0XFE,0X67,0XF6,0X67,

26970XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,

26980XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X47,0XFE,0X67,0XFE,0X67,

26990XFE,0X67,0XFE,0X87,0XFE,0X87,0XF6,0X67,0XF6,0X68,0XEE,0X48,0XF6,0XA9,0XF6,0X8A,

27000XE6,0X28,0XE6,0X8A,0XFF,0X2D,0XFF,0X8E,0XFF,0XAE,0XEE,0XCC,0XC5,0XA8,0XAC,0XA5,

27010X94,0X04,0X83,0X82,0X7B,0X21,0X7B,0X21,0X7B,0X21,0X83,0X62,0X7B,0X21,0X8B,0X82,

27020XB4,0XA6,0XE6,0X2B,0XE6,0X09,0XF6,0X6A,0XF6,0X89,0XF6,0X68,0XF6,0X68,0XFE,0X88,

27030XFE,0X87,0XFE,0X67,0XFE,0X88,0XF6,0X68,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X87,

27040XF6,0X68,0XF6,0X88,0XFE,0X88,0XFE,0XA7,0XFE,0XA7,0XFE,0XA8,0XFE,0X89,0XFE,0X8A,

27050XF6,0X8D,0XF6,0XD0,0XFF,0X35,0XFF,0X99,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

27060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFB,0XFF,0X56,0XFE,0XF2,0XEE,0X4C,

27150XF6,0X68,0XF6,0X66,0XFE,0X66,0XFE,0X66,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,

27160XFE,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,

27170XFE,0X68,0XFE,0X67,0XFE,0X47,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XF6,0X67,

27180XF6,0X67,0XFE,0X87,0XFE,0X88,0XF6,0X68,0XF6,0X89,0XF6,0X69,0XEE,0X69,0XEE,0X8A,

27190XEE,0X8A,0XEE,0XAA,0XF7,0X2C,0XFF,0X6D,0XFF,0X8F,0XFF,0X4E,0XEE,0XCD,0XDE,0X4C,

27200XD5,0XCA,0XCD,0XCA,0XC5,0X89,0XC5,0X69,0XE6,0X8D,0XFF,0X0E,0XFE,0XED,0XF6,0XAB,

27210XF6,0XAA,0XF6,0X88,0XF6,0X67,0XF6,0X46,0XFE,0XA8,0XFE,0X87,0XFE,0X67,0XFE,0X67,

27220XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XF6,0X68,0XF6,0X68,0XFE,0X88,

27230XFE,0XA8,0XFE,0XC9,0XFE,0XA9,0XF6,0X8A,0XF6,0X8B,0XF6,0X8E,0XFE,0XD2,0XFF,0X56,

27240XFF,0XBA,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27330XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XBB,0XFF,0X76,0XE6,0X6E,0XEE,0X69,0XEE,0X67,

27340XF6,0X86,0XFE,0XA6,0XFE,0X67,0XF6,0X47,0XFE,0X88,0XFE,0X68,0XF6,0X67,0XFE,0X87,

27350XF6,0X86,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XF6,0X67,0XF6,0X67,0XFE,0X87,0XFE,0X87,

27360XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,

27370XFE,0X88,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XFE,0X89,0XFE,0X89,0XF6,0X69,0XEE,0X69,

27380XEE,0X69,0XEE,0XA9,0XF6,0XCA,0XF6,0XEB,0XFF,0X0C,0XFF,0X2D,0XFF,0X2E,0XFF,0X4E,

27390XFF,0X2E,0XFE,0XED,0XF6,0XCC,0XF6,0X8A,0XEE,0X69,0XEE,0X68,0XEE,0X68,0XF6,0X88,

27400XF6,0X87,0XF6,0X87,0XF6,0X67,0XF6,0X67,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X68,

27410XFE,0X68,0XFE,0X48,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0XA9,0XFE,0XA9,0XF6,0X89,

27420XF6,0XAB,0XEE,0XAD,0XEE,0XB0,0XF7,0X14,0XFF,0X99,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,

27430XF7,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27520XFF,0XDF,0XFF,0XBD,0XFF,0XB9,0XEE,0XF2,0XEE,0XAD,0XE6,0X68,0XF6,0X67,0XF6,0X67,

27530XFE,0X88,0XFE,0X68,0XF6,0X48,0XFE,0X68,0XFE,0X88,0XF6,0X67,0XFE,0X87,0XFE,0X87,

27540XF6,0X67,0XF6,0X67,0XF6,0X87,0XFE,0X88,0XFE,0X88,0XF6,0X67,0XFE,0X87,0XFE,0X87,

27550XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,

27560XFE,0X88,0XFE,0X68,0XF6,0X67,0XF6,0X68,0XFE,0X68,0XFE,0X88,0XF6,0X88,0XF6,0X88,

27570XEE,0X68,0XEE,0X89,0XF6,0X89,0XF6,0X89,0XEE,0X89,0XEE,0X69,0XF6,0X89,0XF6,0X69,

27580XF6,0X69,0XF6,0X68,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XFE,0X88,0XF6,0X87,0XFE,0X87,

27590XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X47,0XFE,0X68,

27600XFE,0X68,0XFE,0X68,0XFE,0X8A,0XFE,0X8A,0XF6,0X6A,0XF6,0X8C,0XF6,0XCF,0XF7,0X12,

27610XFF,0X77,0XFF,0XBA,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFE,0XFF,0XFE,

27620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

27710XFF,0XFB,0XFF,0X96,0XF7,0X32,0XE6,0X6C,0XF6,0X6A,0XF6,0X68,0XFE,0X69,0XFE,0X89,

27720XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X88,

27730XF6,0X68,0XF6,0X68,0XF6,0X68,0XFE,0X88,0XFE,0X69,0XFE,0X69,0XFE,0X68,0XFE,0X68,

27740XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0XA7,0XFE,0X67,0XF6,0X67,0XFE,0X87,

27750XFE,0XA8,0XFE,0X88,0XFE,0X87,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,

27760XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XF6,0XA8,0XF6,0X88,0XF6,0X67,0XF6,0X67,0XFE,0X67,

27770XFE,0X87,0XFE,0X67,0XFE,0X48,0XFE,0X47,0XFE,0X88,0XFE,0X67,0XFE,0X67,0XFE,0X87,

27780XFE,0XA8,0XFE,0X67,0XF6,0X67,0XFE,0XA7,0XFE,0XA7,0XFE,0XA7,0XF6,0X87,0XF6,0X88,

27790XF6,0XAA,0XF6,0XAD,0XF6,0XCF,0XF6,0XD1,0XFF,0X35,0XFF,0X99,0XFF,0XDC,0XFF,0XFE,

27800XFF,0XDF,0XFF,0XDF,0XF7,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDE,0XFF,0XFC,0XFF,0XB9,

27900XFF,0X96,0XEE,0XD0,0XEE,0X4C,0XFE,0X6B,0XFE,0X6A,0XF6,0X48,0XFE,0X68,0XFE,0X88,

27910XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,

27920XFE,0X68,0XF6,0X49,0XFE,0X69,0XFE,0X69,0XFE,0X69,0XFE,0X68,0XFE,0X87,0XFE,0X87,

27930XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,

27940XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X68,0XF6,0X68,

27950XF6,0X67,0XF6,0X67,0XFE,0X87,0XFE,0X66,0XFE,0X66,0XFE,0X66,0XFE,0X67,0XFE,0X67,

27960XFE,0X68,0XFE,0X68,0XFE,0X47,0XFE,0X88,0XFE,0X87,0XF6,0X67,0XF6,0X67,0XFE,0XA8,

27970XFE,0XA8,0XF6,0X88,0XF6,0XA8,0XF6,0XA9,0XF6,0XCA,0XEE,0XCB,0XE6,0X8D,0XEE,0XD0,

27980XFF,0X75,0XFF,0XD9,0XFF,0XDB,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

27990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

28040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0X97,

28090XF6,0XD1,0XEE,0X2C,0XEE,0X2A,0XFE,0X89,0XF6,0X88,0XF6,0X67,0XFE,0X87,0XFE,0X87,

28100XFE,0XA8,0XFE,0X87,0XFE,0X67,0XF6,0X66,0XF6,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X69,

28110XFE,0X69,0XFE,0X69,0XFE,0X69,0XFE,0X68,0XFE,0X88,0XFE,0X87,0XFE,0X87,0XFE,0X87,

28120XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0XA7,

28130XF6,0X88,0XFE,0X88,0XFE,0XA8,0XFE,0X88,0XFE,0X68,0XFE,0X67,0XFE,0X87,0XFE,0X87,

28140XFE,0X67,0XFE,0X66,0XFE,0X46,0XFE,0X46,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X67,

28150XFE,0X47,0XFE,0X87,0XFE,0X87,0XF6,0X67,0XF6,0X67,0XF6,0XA8,0XF6,0XA9,0XEE,0X8A,

28160XEE,0X6B,0XEE,0XAD,0XEE,0XF0,0XF7,0X33,0XFF,0XB6,0XFF,0XF9,0XFF,0XDA,0XFF,0XDB,

28170XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

28180XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

28230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XDF,

28270XF7,0XDF,0XFF,0XDF,0XFF,0XDE,0XFF,0XBD,0XFF,0XDD,0XFF,0XBB,0XFF,0X56,0XFE,0XF2,

28280XF6,0XAE,0XEE,0X8B,0XF6,0X89,0XFE,0XA8,0XFE,0XA8,0XF6,0X87,0XF6,0X67,0XFE,0X87,

28290XFE,0XA7,0XFE,0XA7,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X48,0XFE,0X68,0XFE,0X68,

28300XFE,0X68,0XFE,0X68,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X67,

28310XFE,0X67,0XFE,0X88,0XFE,0XA8,0XFE,0X87,0XFE,0X87,0XF6,0X67,0XFE,0X88,0XF6,0X88,

28320XF6,0X88,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,

28330XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X87,0XF6,0X67,

28340XF6,0X68,0XFE,0X89,0XFE,0XAB,0XF6,0XAB,0XF6,0XAD,0XF7,0X10,0XFF,0X12,0XFF,0X55,

28350XFF,0X97,0XFF,0XBA,0XFF,0XDB,0XFF,0XDC,0XFF,0XFD,0XFF,0XFE,0XF7,0XFE,0XF7,0XDF,

28360XF7,0XDF,0XF7,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,

28370XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28410XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

28450XFF,0XDF,0XFF,0XBF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XEF,0XBE,0XEF,0X9E,

28460XEF,0X9E,0XEF,0X7D,0XEF,0X5D,0XF7,0X7C,0XFF,0X59,0XFF,0X35,0XEE,0XB0,0XE6,0X8D,

28470XEE,0XCC,0XEE,0XAA,0XEE,0X69,0XFE,0XA9,0XFE,0XA9,0XFE,0X87,0XF6,0X66,0XF6,0X65,

28480XFE,0X85,0XFE,0X86,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X86,0XFE,0X87,0XFE,0X87,

28490XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X87,

28500XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0XA8,0XFE,0X88,0XF6,0X88,0XFE,0X67,0XFE,0X87,

28510XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X68,0XFE,0X88,0XFE,0X88,

28520XFE,0X88,0XFE,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0XA9,0XF6,0X8B,0XF6,0X8C,

28530XF6,0XAF,0XF6,0XD1,0XF6,0XF3,0XF7,0X35,0XFF,0X98,0XFF,0X7A,0XFF,0X9C,0XFF,0XBE,

28540XF7,0X9E,0XF7,0XBE,0XF7,0XDE,0XEF,0XBD,0XEF,0XDD,0XEF,0XDD,0XF7,0XDE,0XF7,0XDF,

28550XF7,0XBF,0XF7,0XBF,0XFF,0XDE,0XFF,0XDE,0XFF,0XBE,0XFF,0XBE,0XFF,0XBF,0XFF,0XDF,

28560XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28600XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

28630XFF,0XDF,0XFF,0XDF,0XF7,0XDE,0XF7,0XDE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,

28640XF7,0X9E,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XE7,0X5D,0XE7,0X3C,0XE7,0X3D,0XE7,0X1C,

28650XDE,0XDB,0XDE,0XDA,0XDE,0XB8,0XDE,0X96,0XDE,0X93,0XDE,0X70,0XDE,0X6E,0XE6,0X8D,

28660XEE,0XAD,0XF6,0X8C,0XEE,0X6A,0XF6,0X89,0XF6,0XA8,0XFE,0XA7,0XFE,0XA6,0XFE,0X86,

28670XFE,0X87,0XFE,0X86,0XFE,0X86,0XFE,0X86,0XFE,0X86,0XFE,0X86,0XFE,0X87,0XFE,0X87,

28680XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,

28690XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0XA8,0XFE,0X88,0XFE,0X67,0XFE,0X67,

28700XFE,0X87,0XFE,0X87,0XFE,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X89,0XF6,0X89,0XF6,0X8A,

28710XF6,0X8A,0XF6,0XAB,0XF6,0XCB,0XF6,0XCC,0XEE,0XAE,0XEE,0X90,0XE6,0X93,0XE6,0X94,

28720XEE,0XD6,0XEF,0X18,0XEE,0XF9,0XEF,0X1B,0XE7,0X1C,0XE6,0XFD,0XE7,0X3E,0XE7,0X5E,

28730XE7,0X5D,0XE7,0X9D,0XE7,0X9C,0XE7,0X9C,0XEF,0X9D,0XEF,0X9D,0XEF,0X9E,0XEF,0X7E,

28740XF7,0X9D,0XF7,0X9D,0XF7,0X9D,0XF7,0X9D,0XFF,0X9E,0XFF,0XBE,0XF7,0XBE,0XF7,0XBE,

28750XF7,0XDE,0XF7,0XDE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

28760XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,

28790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28810XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

28820XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9D,0XF7,0X7D,0XEF,0X7D,0XEF,0X3C,0XE7,0X1C,

28830XE7,0X1C,0XDF,0X1C,0XDE,0XFB,0XD6,0XBB,0XD6,0X9A,0XCE,0X7A,0XC6,0X39,0XC6,0X18,

28840XBD,0XD6,0XB5,0X94,0XAD,0X52,0XAD,0X30,0XAC,0XED,0XB4,0XEC,0XC5,0X6D,0XDD,0XEE,

28850XEE,0X8F,0XF6,0X8D,0XF6,0X8B,0XF6,0XCA,0XF6,0X88,0XF6,0X87,0XF6,0X67,0XFE,0XA7,

28860XFE,0XA6,0XFE,0X86,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X68,

28870XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,

28880XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X87,0XF6,0X87,

28890XF6,0X67,0XF6,0X88,0XF6,0XA9,0XF6,0XAA,0XEE,0XAB,0XF6,0XAD,0XF6,0XCD,0XE6,0X4D,

28900XC5,0X8A,0XAC,0XA9,0X9C,0X2A,0X9C,0X4C,0XA4,0X8F,0XAC,0XD1,0XAD,0X13,0XB5,0X54,

28910XBD,0X96,0XBD,0XD7,0XC5,0XF8,0XC6,0X19,0XCE,0X5A,0XCE,0X7A,0XCE,0X99,0XCE,0XB9,

28920XD6,0XDA,0XD6,0XFA,0XDF,0X1B,0XDF,0X1C,0XDF,0X1C,0XE7,0X1C,0XE7,0X1C,0XEF,0X3C,

28930XEF,0X5C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9D,0XF7,0X9D,

28940XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,

28950XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

28960XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,

28980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

29000XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,

29010XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XEF,0X3C,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XDE,0XDB,

29020XD6,0X9A,0XCE,0X79,0XCE,0X59,0XC6,0X18,0XB5,0XB7,0XAD,0X76,0XA5,0X35,0X9C,0XD3,

29030X94,0X71,0X8C,0X0E,0X83,0XAC,0X7B,0X6A,0X7B,0X49,0X83,0X68,0X9C,0X29,0XBD,0X2C,

29040XE6,0X4E,0XEE,0XAE,0XF6,0XAC,0XFF,0X0C,0XFE,0XCB,0XF6,0XAA,0XF6,0XA9,0XF6,0X88,

29050XF6,0X88,0XFE,0X89,0XFE,0X89,0XF6,0X69,0XF6,0X69,0XFE,0X89,0XF6,0X89,0XF6,0X89,

29060XF6,0X89,0XF6,0X89,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X68,

29070XF6,0X68,0XF6,0X89,0XF6,0X89,0XF6,0X69,0XF6,0X89,0XEE,0X89,0XF6,0XAA,0XF6,0XAB,

29080XFF,0X0D,0XF6,0XCD,0XE6,0X8E,0XD6,0X2D,0XA4,0XA8,0X73,0X24,0X49,0XC0,0X39,0X80,

29090X41,0X82,0X41,0XC5,0X4A,0X07,0X52,0X49,0X5A,0X8A,0X62,0XCB,0X6B,0X2C,0X73,0X8E,

29100X7B,0XF0,0X8C,0X31,0X94,0X92,0X94,0XD2,0XA5,0X33,0XAD,0X74,0XAD,0X95,0XB5,0XB6,

29110XBD,0XF7,0XC6,0X18,0XC6,0X39,0XCE,0X59,0XCE,0X79,0XD6,0XBA,0XD6,0XBA,0XDE,0XBB,

29120XDE,0XDB,0XDE,0XFB,0XE6,0XFC,0XE7,0X1B,0XE7,0X3C,0XE7,0X5C,0XEF,0X5C,0XEF,0X5D,

29130XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,

29140XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,

29150XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

29160XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

29170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

29180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,

29190XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XEF,0X9E,0XEF,0X7D,0XEF,0X7D,

29200XEF,0X5C,0XE7,0X3C,0XE7,0X3C,0XE7,0X1C,0XE7,0X1C,0XDE,0XDB,0XD6,0X9A,0XCE,0X79,

29210XCE,0X59,0XC6,0X38,0XBD,0XD6,0XB5,0X96,0XA5,0X35,0X9C,0XD4,0X94,0X72,0X83,0XF0,

29220X7B,0X8D,0X6B,0X0B,0X5A,0X88,0X52,0X26,0X52,0X04,0X49,0XE2,0X51,0XE0,0X7B,0X44,

29230XAC,0XC9,0XCD,0XCC,0XE6,0X8F,0XEE,0XAE,0XF6,0XCD,0XFE,0XCD,0XF6,0XAC,0XEE,0X8B,

29240XF6,0X8B,0XF6,0XAB,0XF6,0X8A,0XEE,0X69,0XEE,0X8A,0XF6,0X8A,0XF6,0X8A,0XF6,0X8A,

29250XF6,0XA9,0XF6,0XA9,0XF6,0XA9,0XF6,0XA9,0XF6,0X8A,0XEE,0X6A,0XF6,0X8B,0XF6,0X8B,

29260XF6,0X8B,0XF6,0XAC,0XFE,0XEE,0XFF,0X0F,0XF6,0XEF,0XE6,0X8E,0XC5,0X8B,0X9C,0X88,

29270X62,0XC3,0X39,0X80,0X39,0X80,0X39,0XA1,0X41,0XE4,0X41,0XE4,0X41,0XE5,0X39,0XC5,

29280X39,0XA5,0X41,0XE7,0X42,0X28,0X4A,0X49,0X4A,0X69,0X52,0XAA,0X62,0XEB,0X63,0X0B,

29290X6B,0X4C,0X6B,0X6C,0X73,0XAD,0X7B,0XEE,0X8C,0X30,0X8C,0X72,0X94,0XB3,0X9C,0XF3,

29300XA5,0X34,0XAD,0X54,0XB5,0X95,0XBD,0XD6,0XBE,0X17,0XC6,0X38,0XCE,0X59,0XCE,0X7A,

29310XD6,0X9A,0XD6,0XBA,0XDE,0XDA,0XDE,0XFA,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X3C,

29320XE7,0X3C,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,

29330XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,

29340XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

29350XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

29360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

29370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,

29380XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XEF,0X9E,0XEF,0X9D,0XEF,0X7D,0XEF,0X5D,

29390XE7,0X3C,0XE7,0X3C,0XE7,0X1C,0XE6,0XFC,0XDE,0XFB,0XDE,0XDB,0XDE,0XBA,0XD6,0X99,

29400XCE,0X79,0XCE,0X59,0XC6,0X19,0XBD,0XF8,0XB5,0X97,0XB5,0X76,0XAD,0X35,0XA4,0XD3,

29410X94,0X51,0X8C,0X0F,0X83,0XCD,0X73,0X2A,0X62,0XC7,0X52,0X44,0X41,0XC1,0X49,0XE1,

29420X5A,0X42,0X7B,0X25,0X9C,0X27,0XBC,0XEA,0XD5,0XAC,0XDE,0X0C,0XE6,0X2D,0XEE,0X8D,

29430XEE,0XAE,0XEE,0XAD,0XEE,0X8D,0XEE,0XAD,0XEE,0XAD,0XEE,0XAD,0XEE,0XCD,0XEE,0XCC,

29440XEE,0XCC,0XEE,0XCC,0XF6,0XCE,0XEE,0X8E,0XEE,0X8E,0XEE,0X8E,0XDE,0X4D,0XC5,0X8B,

29450XA4,0X87,0X83,0XA5,0X6B,0X03,0X4A,0X00,0X31,0X40,0X29,0X20,0X31,0X60,0X39,0XC3,

29460X41,0XE4,0X42,0X05,0X42,0X06,0X4A,0X27,0X52,0X88,0X52,0X88,0X52,0X88,0X52,0XA9,

29470X52,0X89,0X4A,0X69,0X52,0XAA,0X5A,0XAA,0X5A,0XCA,0X62,0XEA,0X6B,0X2B,0X73,0X6C,

29480X73,0XAD,0X7B,0XEE,0X7B,0XCF,0X84,0X10,0X8C,0X51,0X94,0X91,0X94,0XD2,0X9C,0XF2,

29490XA5,0X33,0XAD,0X74,0XAD,0X95,0XB5,0XB6,0XBD,0XD7,0XBE,0X18,0XC6,0X18,0XCE,0X38,

29500XD6,0X79,0XD6,0X99,0XD6,0XBA,0XD6,0XBA,0XDE,0XDB,0XDE,0XDB,0XDE,0XFB,0XE7,0X1C,

29510XE7,0X1C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

29520XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

29530XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XFF,0XDF,

29540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

29550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

29560XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

29570XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XEF,0X7E,0XEF,0X7D,0XEF,0X7D,0XEF,0X5D,

29580XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X1C,0XE7,0X1B,0XDE,0XFB,0XDE,0XFA,0XDE,0XFA,

29590XD6,0XBA,0XD6,0X9A,0XCE,0X79,0XCE,0X59,0XCE,0X59,0XCE,0X18,0XC5,0XF7,0XC5,0XD6,

29600XBD,0XB5,0XBD,0XD5,0XB5,0X93,0XBD,0X93,0XBD,0X93,0XB5,0X52,0XB5,0X11,0XA4,0X8F,

29610X9C,0X2D,0X9C,0X0C,0X93,0XEA,0X93,0XEA,0X94,0X09,0X9C,0X29,0XA4,0X69,0XAC,0XAA,

29620XAC,0XCA,0XAC,0XAA,0XA4,0X8A,0XA4,0X69,0X9C,0X48,0X9C,0X47,0X94,0X26,0X94,0X06,

29630X83,0X65,0X73,0X04,0X62,0X82,0X52,0X20,0X49,0XC0,0X41,0XA0,0X39,0X80,0X39,0X80,

29640X39,0XA2,0X39,0XC3,0X42,0X05,0X42,0X05,0X42,0X26,0X4A,0X67,0X4A,0X47,0X42,0X47,

29650X52,0X88,0X52,0X88,0X5A,0XC9,0X5A,0XE9,0X63,0X2A,0X6B,0X6C,0X73,0X8D,0X73,0X8D,

29660X73,0X6D,0X73,0X6C,0X73,0X6C,0X73,0X6C,0X73,0X8C,0X7B,0XAE,0X83,0XEF,0X84,0X10,

29670X8C,0X51,0X8C,0X71,0X94,0XB2,0X9C,0XD2,0X9C,0XF2,0XA5,0X13,0XA5,0X54,0XAD,0X74,

29680XAD,0X95,0XB5,0XB6,0XB5,0XD7,0XBD,0XF7,0XBD,0XF8,0XC6,0X18,0XCE,0X38,0XCE,0X79,

29690XD6,0X7A,0XD6,0X9A,0XD6,0XBA,0XD6,0XBA,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,

29700XE7,0X3C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,

29710XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

29720XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

29730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

29740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

29750XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

29760XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XEF,0X9E,0XEF,0X9E,0XEF,0X9D,0XEF,0X7D,0XEF,0X7D,

29770XEF,0X5D,0XEF,0X5D,0XEF,0X3D,0XE7,0X3C,0XE7,0X3C,0XE7,0X1C,0XE7,0X3C,0XE7,0X1C,

29780XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1B,0XE7,0X1B,0XDE,0XFA,

29790XE7,0X3B,0XE6,0XFA,0XE7,0X1A,0XEE,0XFA,0XE6,0XD9,0XE6,0XDA,0XE6,0X99,0XE6,0X98,

29800XE6,0X98,0XDE,0X77,0XD6,0X35,0XCD,0XF4,0XCD,0XD3,0XCD,0XD2,0XC5,0XB2,0XBD,0X91,

29810XBD,0X50,0XB5,0X2F,0XAD,0X0E,0XA4,0XCD,0X9C,0XAC,0X9C,0X8C,0X9C,0X4C,0X94,0X2B,

29820X8C,0X0B,0X8B,0XEB,0X8B,0XEB,0X83,0XEB,0X7B,0XCB,0X73,0X8B,0X73,0X8B,0X73,0XAC,

29830X73,0X6C,0X73,0X8C,0X73,0X8D,0X6B,0X6C,0X73,0XAD,0X73,0XCD,0X7B,0XEE,0X7B,0XED,

29840X84,0X0E,0X84,0X0E,0X84,0X2E,0X84,0X2F,0X8C,0X50,0X8C,0X50,0X94,0X70,0X94,0X90,

29850X94,0X70,0X94,0X70,0X94,0X70,0X94,0X71,0X94,0X92,0X9C,0XB3,0X9C,0XD3,0X9C,0XF3,

29860XA5,0X13,0XA5,0X34,0XAD,0X54,0XAD,0X74,0XAD,0X95,0XB5,0XB6,0XB5,0XD6,0XBD,0XF7,

29870XBE,0X17,0XBE,0X18,0XC6,0X38,0XCE,0X59,0XCE,0X79,0XD6,0X7A,0XD6,0X9A,0XD6,0X9A,

29880XD6,0XBA,0XD6,0XBA,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XE7,0X3C,0XE7,0X1C,

29890XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

29900XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

29910XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

29920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

29930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

29940XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XF7,0XBF,0XF7,0XBF,

29950XF7,0XBF,0XF7,0XBF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBD,0XF7,0X9D,0XF7,0X9E,

29960XF7,0X9E,0XEF,0X7E,0XEF,0X7D,0XEF,0X7D,0XE7,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7C,

29970XEF,0X7D,0XF7,0X9E,0XF7,0XBE,0XF7,0XDE,0XF7,0XBE,0XFF,0XDE,0XF7,0XBD,0XF7,0X9C,

29980XF7,0X9C,0XF7,0X5B,0XFF,0X7C,0XF7,0X3B,0XF7,0X5C,0XF7,0X5B,0XEF,0X3B,0XEF,0X1A,

29990XEF,0X3B,0XF7,0X7B,0XF7,0X3B,0XEE,0XF9,0XEF,0X19,0XEF,0X19,0XE7,0X19,0XE7,0X19,

30000XE6,0XF8,0XE6,0XF8,0XE6,0XD8,0XE6,0XD8,0XE6,0XB8,0XE6,0XB8,0XE6,0XB8,0XDE,0X98,

30010XD6,0X77,0XD6,0X77,0XD6,0X77,0XD6,0X77,0XCE,0X56,0XCE,0X36,0XCE,0X56,0XC6,0X16,

30020XC6,0X16,0XC6,0X36,0XBD,0XD5,0XBD,0XD5,0XBD,0XB6,0XBD,0XB5,0XBD,0XD6,0XBD,0XD6,

30030XBD,0XB5,0XBD,0XD6,0XBD,0XD6,0XBD,0XD6,0XC5,0XF6,0XC6,0X16,0XC6,0X16,0XC5,0XF5,

30040XBD,0XD5,0XB5,0XB5,0XB5,0X95,0XB5,0X96,0XB5,0XB5,0XB5,0XB6,0XB5,0XD6,0XBD,0XD7,

30050XBD,0XD7,0XBD,0XF8,0XC6,0X18,0XC6,0X39,0XC6,0X38,0XC6,0X38,0XC6,0X58,0XCE,0X79,

30060XCE,0X79,0XD6,0X9A,0XD6,0X9B,0XDE,0XBB,0XDE,0XDB,0XDE,0XDB,0XDE,0XDB,0XDE,0XFB,

30070XDE,0XFB,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,

30080XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

30090XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,

30100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

30130XFF,0XDF,0XFF,0XDF,0XFF,0XDE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XDF,

30140XF7,0XDF,0XF7,0XDE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,

30150XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XDE,0XF7,0XBE,0XFF,0XDE,0XFF,0XFF,

30160XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XDE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XBD,

30170XFF,0XBD,0XFF,0XBE,0XFF,0XBD,0XF7,0XBD,0XF7,0XBD,0XFF,0XBD,0XFF,0XDE,0XFF,0XDE,

30180XFF,0XBD,0XFF,0XBD,0XF7,0X9D,0XF7,0X9C,0XF7,0XBD,0XF7,0XBC,0XF7,0X9C,0XF7,0X9C,

30190XF7,0XBD,0XFF,0XBD,0XF7,0X7C,0XF7,0X7C,0XF7,0X5C,0XF7,0X5C,0XF7,0X7C,0XF7,0X9C,

30200XF7,0X9C,0XEF,0X7B,0XEF,0X5B,0XF7,0X7B,0XEF,0X5A,0XEF,0X5A,0XEF,0X3B,0XE7,0X3B,

30210XEF,0X5B,0XEF,0X5C,0XEF,0X3C,0XEF,0X1C,0XEF,0X3C,0XE7,0X1B,0XE7,0X1B,0XE7,0X3B,

30220XE7,0X1B,0XE7,0X1B,0XE7,0X1A,0XE7,0X1A,0XE7,0X1A,0XE7,0X1A,0XE7,0X3B,0XDF,0X1B,

30230XD6,0XBA,0XD6,0X99,0XCE,0X99,0XCE,0X99,0XCE,0X99,0XD6,0X9A,0XD6,0X9A,0XD6,0X9B,

30240XD6,0XBB,0XD6,0XBB,0XD6,0XBA,0XD6,0XBA,0XDE,0XDA,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,

30250XDE,0XFC,0XDE,0XFC,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

30260XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,

30270XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

30280XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XF7,0XBE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

30290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

30330XFF,0XDE,0XFF,0XDE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

30340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30350XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XFE,

30360XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

30370XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

30380XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XFE,

30390XFF,0XDE,0XFF,0XDE,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XF7,0XBD,

30400XF7,0XBD,0XF7,0XBD,0XF7,0XBD,0XF7,0XBD,0XF7,0XBD,0XF7,0XBD,0XF7,0XBD,0XF7,0XBD,

30410XF7,0X9D,0XF7,0XBD,0XF7,0XBD,0XFF,0XDE,0XF7,0XDE,0XF7,0XBE,0XF7,0X9D,0XF7,0X9D,

30420XEF,0X7D,0XE7,0X3C,0XE7,0X1B,0XE7,0X1B,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,

30430XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3D,0XE7,0X3D,0XE7,0X3D,

30440XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,

30450XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

30460XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

30470XF7,0XBE,0XFF,0XDF,0XF7,0XBE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30550XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

30560XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30580XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

30590XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

30600XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDE,0XF7,0X9E,

30610XEF,0X7D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

30620XEF,0X7D,0XEF,0X7D,0XEF,0X7E,0XEF,0X7E,0XEF,0X7E,0XEF,0X7E,0XEF,0X7D,0XEF,0X7D,

30630XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

30640XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

30650XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

30660XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30770XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XF7,0XBE,

30800XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

30810XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

30820XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

30830XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

30840XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

30850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XFF,0XDE,

30990XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

31000XF7,0XBE,0XF7,0XBF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

31010XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

31020XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

31030XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,

31180XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

31190XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

31200XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

31210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,

31370XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

31380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,};

3218

3219

3220const unsigned char gimage_8[51000] = { /* 0X10,0X10,0X00,0X96,0X00,0XAA,0X01,0X1B, */

32210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33610XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

33620XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

33630XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,

33800XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,

33810XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,

33820XFF,0XFC,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

33980XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFB,0XFF,0XFA,0XFF,0XFA,

33990XFF,0XFA,0XFF,0XF9,0XFF,0XF9,0XFF,0XD9,0XFF,0XD9,0XFF,0XD9,0XFF,0XF8,0XFF,0XF8,

34000XFF,0XF8,0XFF,0XF8,0XFF,0XF8,0XFF,0XF8,0XFF,0XF8,0XFF,0XF8,0XFF,0XF9,0XFF,0XFA,

34010XFF,0XFA,0XFF,0XFB,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34160XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFB,0XFF,0XFA,

34170XFF,0XFA,0XFF,0XF9,0XFF,0XF8,0XFF,0XF7,0XFF,0XF7,0XFF,0XF6,0XFF,0XF6,0XFF,0XF5,

34180XFF,0XD5,0XFF,0XD4,0XFF,0XD4,0XFF,0XD4,0XFF,0XF4,0XFF,0XF4,0XFF,0XF4,0XFF,0XF4,

34190XFF,0XF4,0XFF,0XD4,0XFF,0XF5,0XFF,0XD5,0XFF,0XF6,0XFF,0XF6,0XFF,0XF7,0XFF,0XF8,

34200XFF,0XFA,0XFF,0XFB,0XFF,0XFC,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XFB,

34350XFF,0XFA,0XFF,0XF9,0XFF,0XF9,0XFF,0XF8,0XFF,0XF8,0XFF,0XF7,0XFF,0XF7,0XFF,0XF6,

34360XFF,0XD5,0XFF,0XD4,0XFF,0XF4,0XFF,0XF3,0XFF,0XF3,0XFF,0XF2,0XFF,0XF1,0XFF,0XF1,

34370XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,

34380XFF,0XF2,0XFF,0XF3,0XFF,0XF3,0XFF,0XF4,0XFF,0XF5,0XFF,0XD6,0XFF,0XD7,0XFF,0XF8,

34390XFF,0XF9,0XFF,0XFA,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

34530XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,0XFF,0XF9,0XFF,0XF8,0XFF,0XF7,0XFF,0XF6,

34540XFF,0XF5,0XFF,0XF4,0XFF,0XF4,0XFF,0XF4,0XFF,0XF3,0XFF,0XF3,0XFF,0XF2,0XFF,0XF2,

34550XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,

34560XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF2,

34570XFF,0XF2,0XFF,0XF2,0XFF,0XF3,0XFF,0XD4,0XFF,0XD5,0XFF,0XF5,0XFF,0XF6,0XFF,0XD7,

34580XFF,0XFA,0XFF,0XFB,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

34590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34710XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,0XFF,0XFA,

34720XFF,0XF9,0XFF,0XF7,0XFF,0XF6,0XFF,0XF5,0XFF,0XF4,0XFF,0XF3,0XFF,0XF2,0XFF,0XF2,

34730XFF,0XF2,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,

34740XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

34750XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF1,

34760XFF,0XF1,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF3,0XFF,0XF4,0XFF,0XD7,0XFF,0XD8,

34770XFF,0XD9,0XFF,0XFB,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

34900XFF,0XFE,0XFF,0XFC,0XFF,0XFB,0XFF,0XF9,0XFF,0XF7,0XFF,0XF5,0XFF,0XF4,0XFF,0XF3,

34910XF7,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

34920XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

34930XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

34940XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

34950XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF3,0XFF,0XF5,0XFF,0XD6,0XFF,0XF8,

34960XFF,0XFA,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFA,

35090XFF,0XF8,0XFF,0XF6,0XF7,0XF4,0XF7,0XF2,0XF7,0XF1,0XF7,0XF0,0XFF,0XF0,0XFF,0XF0,

35100XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XCF,0XFF,0XCF,

35110XFF,0XCF,0XFF,0XD0,0XFF,0XD0,0XFF,0XD0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

35120XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

35130XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

35140XFF,0XEE,0XFF,0XEF,0XFF,0XF1,0XFF,0XD2,0XFF,0XD3,0XFF,0XD5,0XFF,0XF7,0XFF,0XF9,

35150XFF,0XFB,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

35270XFF,0XFD,0XFF,0XFD,0XFF,0XFB,0XFF,0XFA,0XFF,0XF8,0XFF,0XD6,0XFF,0XD5,0XFF,0XF3,

35280XFF,0XF2,0XF7,0XF0,0XF7,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,

35290XFF,0XB0,0XFF,0XD0,0XFF,0XAF,0XFF,0XAE,0XFF,0XAE,0XFF,0XAE,0XFF,0X6E,0XFF,0X6E,

35300XFF,0X6F,0XFF,0XAF,0XFF,0XD0,0XFF,0XF0,0XF7,0XAF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

35310XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XCE,0XFF,0XEF,0XFF,0XCE,0XFF,0XCF,0XFF,0XEF,

35320XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,

35330XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF2,0XFF,0XF3,0XFF,0XF5,0XFF,0XF8,0XFF,0XFB,

35340XFF,0XFD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XFB,0XFF,0XFA,

35460XFF,0XF8,0XFF,0XD6,0XFF,0XD5,0XFF,0XD3,0XFF,0XD2,0XFF,0XF1,0XF7,0XF0,0XFF,0XEF,

35470XFF,0XEF,0XFF,0XEE,0XFF,0XCE,0XFF,0XCE,0XFF,0XCE,0XFF,0X8E,0XFF,0X8E,0XFF,0X2D,

35480XEE,0XEA,0XE6,0XA9,0XDE,0X68,0XDE,0X47,0XDE,0X28,0XDE,0X08,0XE6,0X29,0XE6,0X6A,

35490XE6,0XAB,0XF7,0X4E,0XFF,0XF0,0XFF,0XD0,0XF7,0XAF,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,

35500XFF,0XEF,0XFF,0XCE,0XFF,0XEF,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

35510XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

35520XFF,0XEF,0XFF,0XF0,0XFF,0XF1,0XF7,0XF2,0XFF,0XD5,0XFF,0XD8,0XFF,0XDB,0XFF,0XFE,

35530XFF,0XDE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35640XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XFB,0XFF,0XF9,0XFF,0XF7,0XFF,0XD5,0XFF,0XD3,

35650XFF,0XD1,0XFF,0XD0,0XFF,0XF0,0XFF,0XF0,0XF7,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XCF,

35660XFF,0XAE,0XFF,0XAE,0XFF,0X8D,0XF7,0X4B,0XEE,0X88,0XE6,0X46,0XDE,0X26,0XDE,0X05,

35670XD5,0XC4,0XD5,0X83,0XCD,0X62,0XCD,0X22,0XCD,0X23,0XC5,0X03,0XC5,0X45,0XD6,0X08,

35680XF7,0X0C,0XFF,0X8F,0XFF,0XD0,0XFF,0XD0,0XFF,0XD0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,

35690XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

35700XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,

35710XFF,0XEF,0XFF,0XD0,0XF7,0XD2,0XF7,0XB5,0XFF,0XD9,0XFF,0XFD,0XFF,0XBD,0XFF,0XFF,

35720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFC,

35830XFF,0XFA,0XFF,0XF8,0XFF,0XF6,0XFF,0XF5,0XFF,0XD2,0XFF,0XD1,0XFF,0XEF,0XFF,0XEF,

35840XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XAF,0XFF,0X8D,0XFF,0X2C,

35850XEE,0XC9,0XE6,0X47,0XD5,0XC3,0XCD,0X82,0XCD,0X62,0XD5,0X62,0XD5,0X61,0XD5,0X81,

35860XDD,0X81,0XDD,0X81,0XD5,0X21,0XC4,0XE2,0XBC,0XA1,0XAC,0X61,0XBD,0X04,0XE6,0X6A,

35870XFF,0XB0,0XFF,0XD0,0XFF,0XCF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,

35880XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

35890XFF,0XEF,0XFF,0XEF,0XFF,0XCF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,

35900XFF,0XD1,0XFF,0XD3,0XFF,0XB6,0XFF,0XB9,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

35910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36010XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0XF9,0XFF,0XF7,0XFF,0XF5,

36020XFF,0XF3,0XFF,0XF1,0XFF,0XF0,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,

36030XFF,0XEF,0XFF,0XEF,0XFF,0XCF,0XFF,0X8E,0XFF,0X0B,0XEE,0X68,0XE6,0X06,0XDD,0XC5,

36040XDD,0XC3,0XE5,0XE3,0XE5,0XC3,0XE5,0XC3,0XED,0XE2,0XEE,0X02,0XED,0XE1,0XED,0XE1,

36050XDD,0X61,0XDD,0X42,0XC4,0XA1,0XA3,0XC0,0X9B,0XC0,0XB4,0XE4,0XE6,0X8B,0XFF,0XAF,

36060XFF,0XCF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

36070XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

36080XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEF,0XFF,0XF1,

36090XF7,0X93,0XF7,0X95,0XFF,0XFA,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

36100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

36200XFF,0XFD,0XFF,0XFA,0XFF,0XF8,0XFF,0XD6,0XFF,0XD4,0XFF,0XD2,0XFF,0XF0,0XFF,0XEF,

36210XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XCE,

36220XFF,0X8D,0XF7,0X0B,0XE6,0X48,0XE5,0XE6,0XE6,0X06,0XEE,0X26,0XEE,0X25,0XF6,0X65,

36230XF6,0X66,0XFE,0X45,0XFE,0X65,0XFE,0X43,0XED,0XE1,0XED,0XC1,0XED,0XE2,0XE5,0X82,

36240XD5,0X42,0XBC,0X81,0X93,0X60,0X8B,0X60,0XB4,0XC4,0XF7,0X0D,0XFF,0XCF,0XFF,0XF0,

36250XFF,0XCF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

36260XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

36270XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEF,0XFF,0XB0,0XF7,0X93,

36280XF7,0X55,0XFF,0XFB,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

36380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFA,0XFF,0XF7,

36390XFF,0XD5,0XFF,0XF2,0XFF,0XF1,0XFF,0XF0,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

36400XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XAD,0XF7,0X2A,0XE6,0X67,

36410XDD,0XE6,0XEE,0X06,0XF6,0X48,0XF6,0X68,0XFE,0XC9,0XFE,0XA8,0XFE,0X67,0XFE,0X46,

36420XFE,0X46,0XFE,0X45,0XFE,0X44,0XFE,0X44,0XFE,0X44,0XED,0XE3,0XED,0XC4,0XDD,0X44,

36430XA3,0XC0,0X83,0X00,0X8B,0X60,0XD5,0XE8,0XF7,0X4D,0XFF,0XF0,0XFF,0XCF,0XFF,0XCF,

36440XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,

36450XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,

36460XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEF,0XF7,0XB0,0XE6,0XF1,0XFF,0XF8,

36470XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

36570XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XFF,0XF8,0XFF,0XF4,0XFF,0XF1,0XFF,0XF0,

36580XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,

36590XFF,0XEF,0XFF,0XEE,0XFF,0X6C,0XF7,0X2A,0XEE,0X87,0XDD,0XE4,0XE6,0X05,0XFE,0X88,

36600XFE,0XA9,0XF6,0X48,0XFE,0XC9,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X87,

36610XFE,0X87,0XFE,0X86,0XF6,0X44,0XF6,0X24,0XED,0XE4,0XE5,0XC5,0XD5,0X45,0XAC,0X21,

36620X72,0X80,0X94,0X01,0XE6,0XAB,0XFF,0XCF,0XFF,0XCF,0XFF,0XCF,0XFF,0XCF,0XFF,0XEE,

36630XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

36640XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,

36650XFF,0XEE,0XFF,0XCD,0XFF,0XED,0XF7,0X8E,0XEF,0X2F,0XEF,0X33,0XFF,0XF9,0XFF,0XFC,

36660XFF,0XFE,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

36760XFF,0XFB,0XFF,0XD8,0XFF,0XD4,0XFF,0XF2,0XFF,0XEF,0XFF,0XEE,0XFF,0XCE,0XFF,0XEE,

36770XFF,0XEE,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XCD,

36780XFF,0X4B,0XF6,0XC8,0XD5,0XA3,0XEE,0X05,0XF6,0X67,0XFE,0XC8,0XFE,0XC9,0XFE,0X89,

36790XF6,0X88,0XFE,0XA8,0XFE,0XA9,0XFE,0X89,0XFE,0X69,0XFE,0X89,0XFE,0X88,0XFE,0XA8,

36800XF6,0X86,0XFE,0XA6,0XFE,0X66,0XEE,0X06,0XE5,0XC7,0XC4,0XC4,0X93,0X80,0X83,0X20,

36810XBD,0X46,0XF7,0X4D,0XFF,0XCF,0XFF,0XEF,0XFF,0XCE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,

36820XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,

36830XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCE,0XFF,0XEE,0XFF,0XCE,0XFF,0XCD,

36840XFF,0XCD,0XFF,0XCE,0XEF,0X4E,0XD6,0X8E,0XFF,0XB6,0XFF,0XFB,0XFF,0XFD,0XFF,0XFF,

36850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFC,0XFF,0XF8,0XFF,0XD5,

36950XFF,0XD2,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,

36960XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0X8C,0XF6,0XA8,0XDD,0XE5,

36970XDD,0XA4,0XEE,0X25,0XF6,0X67,0XFE,0X87,0XFE,0XA9,0XFE,0XEA,0XFE,0X88,0XFE,0XA9,

36980XFE,0XA9,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0XA8,0XFE,0X87,

36990XFE,0X86,0XFE,0X67,0XF6,0X27,0XE5,0XA7,0XBC,0X84,0X8B,0X20,0X9C,0X21,0XEE,0XEB,

37000XFF,0X8E,0XFF,0XEF,0XFF,0XCE,0XFF,0XEE,0XF7,0XCC,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,

37010XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

37020XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XCE,0XFF,0XCD,0XFF,0XED,0XFF,0XCD,

37030XFF,0XAE,0XCE,0X4C,0XE6,0XF2,0XFF,0XF9,0XFF,0XDD,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,

37040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37130XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XF9,0XFF,0XD4,0XFF,0XD1,0XFF,0XCF,0XFF,0XEE,

37140XFF,0XED,0XFF,0XEE,0XFF,0XCF,0XFF,0XEF,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,

37150XFF,0XED,0XFF,0XED,0XFF,0XCD,0XF7,0X0A,0XE6,0X06,0XD5,0X43,0XE5,0XE5,0XF6,0X66,

37160XFE,0X87,0XF6,0X67,0XFE,0X88,0XFE,0XA9,0XFE,0X89,0XFE,0XAA,0XFE,0XAA,0XFE,0XA9,

37170XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA8,0XFE,0X88,0XFE,0XA8,0XFE,0XA8,

37180XFE,0X67,0XF6,0X48,0XDD,0X87,0XAC,0X01,0X83,0X60,0XD6,0X28,0XFF,0XAE,0XFF,0XCE,

37190XFF,0XEE,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XED,

37200XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,

37210XFF,0XED,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCE,0XFF,0XAD,0XFF,0XCF,0XCE,0X4B,

37220XCE,0X4F,0XF7,0X77,0XFF,0XFC,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,

37320XFF,0XF9,0XFF,0XF5,0XFF,0XD1,0XFF,0XCF,0XFF,0XCD,0XFF,0XED,0XFF,0XED,0XFF,0XEE,

37330XFF,0XCF,0XFF,0XCF,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XED,0XFF,0XCD,

37340XFF,0X8C,0XE6,0X68,0XD5,0XA5,0XCD,0X43,0XEE,0X06,0XF6,0X46,0XF6,0X67,0XFE,0X67,

37350XFE,0X88,0XF6,0X69,0XFE,0X8A,0XFE,0X8A,0XFE,0X8A,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

37360XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X68,

37370XEE,0X08,0XCD,0X24,0X93,0XA0,0XBD,0X65,0XFF,0X4C,0XFF,0XCD,0XFF,0XED,0XFF,0XED,

37380XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

37390XFF,0XCD,0XFF,0XCD,0XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XCC,

37400XFF,0XCD,0XFF,0XCD,0XFF,0XAD,0XFF,0XCE,0XFF,0XAE,0XE6,0XED,0XC5,0XCC,0XDE,0XB2,

37410XFF,0XBA,0XFF,0XFD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFA,0XFF,0XD5,0XFF,0XB2,

37510XFF,0XCF,0XFF,0XCE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCD,0XFF,0XCE,0XFF,0XCE,

37520XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCD,0XF7,0X0A,0XD5,0XA5,

37530XC5,0X03,0XCD,0X44,0XE5,0XC5,0XEE,0X06,0XF6,0X47,0XFE,0X88,0XFE,0X89,0XFE,0X69,

37540XFE,0X6A,0XFE,0X6A,0XFE,0X89,0XFE,0X89,0XFE,0XA9,0XFE,0XA8,0XFE,0XA8,0XFE,0XA8,

37550XFE,0X89,0XFE,0XCA,0XFE,0X89,0XFE,0X88,0XFE,0XA9,0XFE,0X88,0XF6,0X68,0XE5,0XE7,

37560XB4,0XA3,0XAC,0XC3,0XEE,0XEB,0XFF,0XAD,0XFF,0XCD,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,

37570XFF,0XEC,0XFF,0XED,0XFF,0XCC,0XFF,0XCC,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

37580XFF,0XCD,0XFF,0XCD,0XFF,0XCC,0XFF,0XEC,0XFF,0XEC,0XFF,0XCC,0XFF,0XCD,0XFF,0XCD,

37590XFF,0XAD,0XFF,0XAE,0XFF,0XCE,0XEF,0X0D,0XBD,0XAA,0XBD,0XAD,0XF7,0X57,0XFF,0XFC,

37600XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37690XFF,0XFF,0XFF,0XFD,0XFF,0XFB,0XFF,0XD7,0XFF,0XB2,0XF7,0XAF,0XFF,0XCE,0XFF,0XCD,

37700XFF,0XCC,0XFF,0XCC,0XFF,0XEC,0XFF,0XCD,0XFF,0XCE,0XFF,0XCE,0XFF,0XCE,0XFF,0XED,

37710XFF,0XCD,0XFF,0XED,0XFF,0XED,0XFF,0X8C,0XDE,0X28,0XB4,0XA3,0XAC,0X61,0XC5,0X03,

37720XD5,0X64,0XE5,0XE6,0XEE,0X47,0XF6,0X68,0XFE,0X68,0XFE,0X69,0XFE,0X69,0XFE,0X69,

37730XFE,0X89,0XFE,0X89,0XFE,0XA9,0XFE,0XA8,0XFE,0XA8,0XFE,0XA9,0XFE,0X88,0XFE,0XA9,

37740XFE,0XAA,0XFE,0XAA,0XFE,0X89,0XFE,0X89,0XFE,0XAA,0XF6,0X69,0XD5,0XC7,0XAC,0XA3,

37750XE6,0XAA,0XFF,0XAD,0XFF,0XCD,0XF7,0XCC,0XFF,0XED,0XFF,0XEC,0XFF,0XED,0XFF,0XCC,

37760XFF,0XCC,0XFF,0XCC,0XFF,0XAC,0XFF,0XCC,0XFF,0XAD,0XFF,0XCD,0XFF,0XAD,0XFF,0XAD,

37770XFF,0XAC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XAC,0XFF,0XAD,0XFF,0XAD,0XFF,0X8D,

37780XFF,0XCE,0XEF,0X0C,0XB5,0X68,0XAD,0X09,0XE6,0X93,0XFF,0XDB,0XFF,0XDD,0XFF,0XFF,

37790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFB,

37880XFF,0XF7,0XF7,0XB3,0XF7,0X90,0XF7,0XAE,0XFF,0XAD,0XFF,0XCD,0XFF,0XCC,0XFF,0XCC,

37890XFF,0XCC,0XFF,0XCC,0XFF,0XCD,0XFF,0XCD,0XFF,0XCE,0XFF,0XCE,0XFF,0XCD,0XFF,0XCD,

37900XFF,0XAD,0XFF,0X2C,0XC5,0X25,0X9B,0XE0,0X9B,0XC0,0XAC,0X42,0XBC,0XA3,0XD5,0X85,

37910XE5,0XE7,0XF6,0X27,0XFE,0X27,0XFE,0X48,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0XA9,

37920XFE,0XA9,0XFE,0X89,0XFE,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0X89,0XFE,0X89,0XFE,0X8A,

37930XF6,0X8B,0XFE,0X8C,0XFE,0X8C,0XF6,0X6B,0XE6,0X2A,0XC5,0X46,0XD6,0X08,0XFF,0XAE,

37940XF7,0X6C,0XFF,0XED,0XF7,0XCC,0XF7,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,

37950XFF,0XAC,0XFF,0XAC,0XFF,0XCC,0XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAC,

37960XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0X8C,0XFF,0XAC,0XFF,0X8C,0XFF,0X8D,

37970XAD,0X05,0XAD,0X08,0XC5,0X8E,0XFF,0X79,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFC,0XFF,0XF9,0XFF,0XD4,0XF7,0X90,

38070XF7,0X8E,0XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAC,0XFF,0XCC,0XFF,0XCB,0XFF,0XCB,

38080XFF,0XCC,0XFF,0XCD,0XFF,0XAE,0XFF,0XAE,0XFF,0XAE,0XFF,0XAE,0XFF,0X8D,0XF6,0XEB,

38090XB4,0X83,0X8B,0X40,0X8B,0X40,0X93,0X60,0X9B,0XE1,0XB4,0XA3,0XCD,0X66,0XE5,0XE7,

38100XF6,0X28,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0XA9,0XFE,0X89,0XFE,0X89,

38110XFE,0X69,0XFE,0X8A,0XFE,0X69,0XFE,0X69,0XFE,0XAB,0XFE,0XAD,0XF6,0XAE,0XEE,0X6E,

38120XEE,0X4D,0XF6,0X6E,0XEE,0X6E,0XD5,0XEA,0XD6,0X09,0XFF,0X8D,0XF7,0X8C,0XFF,0XCD,

38130XFF,0XCD,0XFF,0XCC,0XFF,0XCD,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAB,0XFF,0XAC,

38140XFF,0XAC,0XFF,0XAD,0XFF,0X8D,0XFF,0XAD,0XFF,0XAD,0XFF,0X8C,0XFF,0X8C,0XFF,0XAC,

38150XFF,0XAC,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8D,0XBD,0X46,0XA4,0X86,

38160XAC,0XEA,0XE6,0XB4,0XFF,0XFC,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

38250XFF,0XFD,0XFF,0XFC,0XFF,0XFA,0XFF,0XB6,0XF7,0X70,0XFF,0X8E,0XFF,0X8D,0XFF,0X8C,

38260XFF,0X8C,0XFF,0XAC,0XFF,0XAC,0XFF,0XCB,0XFF,0XCA,0XFF,0XCB,0XFF,0XAC,0XFF,0XAC,

38270XFF,0X8D,0XFF,0XAE,0XFF,0XAE,0XFF,0X8E,0XFF,0X6E,0XEE,0X6B,0XAC,0X03,0X8B,0X00,

38280X8B,0X00,0X7A,0XC0,0X7B,0X00,0X93,0XC2,0XAC,0X84,0XC5,0X46,0XE5,0XC8,0XF6,0X48,

38290XF6,0X67,0XFE,0X88,0XFE,0X88,0XF6,0X68,0XFE,0X89,0XFE,0X69,0XFE,0X8A,0XFE,0X6A,

38300XFE,0X8B,0XF6,0X8C,0XF6,0X8D,0XEE,0X8F,0XF6,0XB1,0XFE,0XF3,0XFF,0X34,0XFF,0X34,

38310XFF,0X75,0XEE,0XF1,0XD6,0X2B,0XFF,0X4D,0XFF,0X6C,0XFF,0X8C,0XFF,0X8C,0XFF,0XAD,

38320XFF,0XAC,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0XAC,0XFF,0X8C,

38330XFF,0X8D,0XFF,0X8C,0XFF,0X6C,0XFF,0X6C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,

38340XFF,0X6C,0XFF,0X8C,0XFF,0X6C,0XFF,0X2C,0XC5,0X67,0X9C,0X45,0X94,0X26,0XC5,0XAF,

38350XF7,0X99,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

38360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XFA,

38440XFF,0XD7,0XFF,0X93,0XFF,0X4F,0XFF,0X6D,0XFF,0X4C,0XFF,0X6C,0XFF,0X8C,0XFF,0X8C,

38450XFF,0XAB,0XFF,0XAB,0XFF,0XAB,0XFF,0XAB,0XFF,0XAC,0XFF,0X8D,0XFF,0X8C,0XFF,0X8D,

38460XFF,0X8D,0XFF,0X8E,0XFF,0X6E,0XEE,0X4A,0XAB,0XE2,0X8B,0X00,0X8A,0XE0,0X72,0X80,

38470X6A,0X80,0X72,0XE1,0X83,0X82,0XA4,0X44,0XC5,0X27,0XDD,0XC8,0XEE,0X28,0XF6,0X47,

38480XF6,0X48,0XFE,0X68,0XFE,0X69,0XFE,0X89,0XFE,0X8A,0XFE,0X8B,0XEE,0X4C,0XEE,0X8E,

38490XF6,0XD1,0XF7,0X14,0XFF,0X56,0XFF,0X98,0XFF,0XB9,0XFF,0XDA,0XFF,0XD9,0XEF,0X34,

38500XD6,0X4C,0XF7,0X4D,0XFF,0X6C,0XFF,0X8C,0XFF,0X6C,0XFF,0X6C,0XFF,0X8C,0XFF,0X8C,

38510XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X6C,

38520XFF,0X4C,0XFF,0X4C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X4C,

38530XFF,0X2C,0XFF,0X0C,0XC5,0X47,0X9C,0X24,0X94,0X05,0XA4,0XAB,0XEF,0X17,0XFF,0XFC,

38540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XB8,0XFF,0X94,0XFF,0X50,

38630XF7,0X2E,0XFF,0X4D,0XFF,0X4C,0XFF,0X6C,0XFF,0X6B,0XFF,0X8B,0XFF,0X8B,0XFF,0X8B,

38640XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X6C,0XFF,0X8C,

38650XFF,0X6C,0XE6,0X49,0XAC,0X22,0X93,0X60,0X8B,0X00,0X72,0XA0,0X62,0X40,0X5A,0X40,

38660X6A,0XA1,0X83,0X42,0XA4,0X25,0XC5,0X28,0XE5,0XC8,0XF6,0X28,0XF6,0X48,0XFE,0X88,

38670XFE,0X68,0XFE,0X89,0XF6,0X6A,0XEE,0X6C,0XE6,0X6E,0XF6,0XF3,0XFF,0X77,0XFF,0XDA,

38680XFF,0XFB,0XFF,0XFC,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,0XF7,0X76,0XDE,0X6E,0XEE,0XED,

38690XFF,0X4D,0XFF,0X6C,0XFF,0X4C,0XFF,0X4C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,

38700XFF,0X6B,0XFF,0X6B,0XFF,0X6B,0XFF,0X6C,0XFF,0X6C,0XFF,0X4C,0XFF,0X4B,0XFF,0X4B,

38710XFF,0X4C,0XFF,0X4B,0XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X2C,0XFF,0X2C,0XFF,0X0D,

38720XBD,0X06,0X93,0XC3,0X93,0XE5,0X8B,0XE7,0XCE,0X12,0XFF,0XDB,0XFF,0XFE,0XFF,0XFF,

38730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38810XFF,0XDF,0XFF,0XDE,0XFF,0XDB,0XFF,0X96,0XFF,0X51,0XF7,0X2E,0XFF,0X2D,0XFF,0X4D,

38820XFF,0X2C,0XFF,0X4C,0XFF,0X6B,0XFF,0X6B,0XFF,0X6B,0XFF,0X8C,0XFF,0X6C,0XFF,0X6D,

38830XFF,0X6D,0XFF,0X6C,0XFF,0X8C,0XFF,0X6B,0XFF,0X8B,0XFF,0X6B,0XFF,0X6C,0XE6,0X68,

38840XB4,0XA2,0XA3,0XC1,0X8B,0X20,0X7A,0XC0,0X62,0X60,0X52,0X00,0X52,0X00,0X62,0X61,

38850X7B,0X23,0XA4,0X26,0XC4,0XE7,0XDD,0XA8,0XE6,0X07,0XF6,0X47,0XF6,0X88,0XF6,0XA9,

38860XEE,0X8B,0XEE,0XAF,0XFF,0X34,0XFF,0X78,0XFF,0XDB,0XFF,0XFD,0XFF,0XFD,0XF7,0XFE,

38870XF7,0XFE,0XFF,0XFE,0XFF,0XFC,0XFF,0X97,0XDE,0X6F,0XE6,0XAD,0XFF,0X2D,0XFF,0X4C,

38880XFF,0X4C,0XFF,0X4B,0XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4B,0XFF,0X6B,0XFF,0X6B,

38890XFF,0X6B,0XFF,0X4B,0XFF,0X4C,0XFF,0X4B,0XFF,0X2B,0XFF,0X4B,0XFF,0X2B,0XFF,0X2B,

38900XFF,0X2B,0XFF,0X4B,0XFF,0X4B,0XFF,0X2C,0XFF,0X2C,0XFF,0X0D,0XB4,0XA5,0X83,0X41,

38910X8B,0XC5,0X8B,0XC7,0X9C,0XAC,0XEF,0X38,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

38920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDD,

39000XFF,0XB9,0XFF,0X54,0XF7,0X2F,0XF7,0X0C,0XFF,0X2C,0XFF,0X2D,0XFF,0X2C,0XFF,0X4C,

39010XFF,0X4B,0XFF,0X6B,0XFF,0X6C,0XFF,0X6C,0XFF,0X4D,0XFF,0X4D,0XFF,0X4D,0XFF,0X4C,

39020XFF,0X4B,0XFF,0X6B,0XFF,0X6B,0XFF,0X6B,0XFF,0X4B,0XEE,0XA9,0XC5,0X03,0XA3,0XE1,

39030X8B,0X40,0X83,0X00,0X6A,0XA1,0X5A,0X20,0X49,0XC0,0X49,0XC0,0X62,0X41,0X83,0X24,

39040XA4,0X27,0XC5,0X08,0XD5,0XA8,0XDE,0X08,0XEE,0X89,0XE6,0X69,0XE6,0X6D,0XEE,0XD2,

39050XFF,0XB9,0XFF,0XDC,0XFF,0XFD,0XFF,0XFE,0XF7,0XFE,0XF7,0XFF,0XF7,0XFF,0XFF,0XFF,

39060XFF,0XFD,0XFF,0XB9,0XDE,0X70,0XE6,0X8D,0XFF,0X2D,0XFF,0X2C,0XFF,0X2C,0XFF,0X2B,

39070XFF,0X4C,0XFF,0X4C,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,

39080XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,

39090XFF,0X0B,0XFF,0X0B,0XFF,0X0C,0XF6,0XCD,0XA4,0X44,0X72,0XC0,0X8B,0XA5,0X8B,0XE7,

39100X83,0XC8,0XBD,0XB1,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDC,0XFF,0X77,0XF7,0X32,

39190XF7,0X0D,0XF7,0X0B,0XFF,0X0C,0XFF,0X0C,0XFF,0X0C,0XFF,0X2B,0XFF,0X2A,0XFF,0X4A,

39200XFF,0X4B,0XFF,0X4C,0XFF,0X2C,0XFF,0X2C,0XFF,0X2C,0XFF,0X2C,0XFF,0X2B,0XFF,0X6B,

39210XFF,0X4B,0XFF,0X4B,0XF7,0X2A,0XFF,0X0B,0XCD,0X65,0X9B,0XE0,0X93,0XA1,0X8B,0X61,

39220X7B,0X02,0X62,0X81,0X52,0X00,0X49,0XA0,0X49,0XC0,0X62,0X42,0X7A,0XE4,0X9B,0XE6,

39230XBD,0X07,0XCD,0XA8,0XDE,0X4A,0XDE,0X4B,0XEE,0XF1,0XFF,0XB8,0XFF,0XDB,0XFF,0XDE,

39240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XBA,

39250XDE,0X70,0XE6,0X8D,0XFF,0X2D,0XFF,0X0C,0XFF,0X2C,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,

39260XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,

39270XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFE,0XEB,0XFE,0XEB,

39280XFE,0XEC,0XF6,0XAC,0X9B,0XE4,0X6A,0XA0,0X83,0X64,0X8B,0XC7,0X83,0XC7,0X94,0X4B,

39290XFF,0X9A,0XFF,0XFD,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XF7,0XDF,0XFF,0XFF,0XFF,0XFF,

39300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39370XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XBB,0XF7,0X14,0XF6,0XF0,0XF7,0X0D,0XF6,0XEB,

39380XFF,0X0C,0XFE,0XEC,0XFF,0X0B,0XFF,0X0B,0XFF,0X2A,0XFF,0X2A,0XFF,0X2B,0XFF,0X2C,

39390XFF,0X2C,0XFF,0X2C,0XFF,0X2C,0XFF,0X2C,0XFF,0X0B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,

39400XF7,0X0B,0XFF,0X4D,0XDD,0XE7,0XA4,0X01,0X93,0XC0,0X8B,0X81,0X83,0X62,0X73,0X02,

39410X5A,0X61,0X52,0X00,0X49,0XC0,0X49,0XC1,0X5A,0X22,0X73,0X04,0X94,0X26,0XAC,0XE8,

39420XC5,0X8A,0XD6,0X6F,0XF7,0X56,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

39430XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XB9,0XD6,0X50,0XE6,0X8D,

39440XFF,0X0D,0XFE,0XEB,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,

39450XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0A,0XFF,0X0A,

39460XFE,0XEB,0XFE,0XEA,0XFE,0XEA,0XFF,0X0B,0XFE,0XEA,0XFE,0XEB,0XFE,0XEC,0XEE,0X6C,

39470X8B,0X62,0X6A,0X60,0X7B,0X24,0X7B,0X65,0X83,0XC7,0X83,0XC8,0XD6,0X34,0XFF,0XDC,

39480XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XF7,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,

39560XFF,0XDD,0XFF,0X99,0XF6,0XF2,0XF6,0XCE,0XFF,0X0C,0XFE,0XEB,0XFF,0X0C,0XFE,0XEC,

39570XFE,0XEB,0XFF,0X0B,0XFF,0X0A,0XFF,0X2A,0XFF,0X0B,0XFF,0X2C,0XFF,0X2B,0XFF,0X2B,

39580XFF,0X2B,0XFF,0X0B,0XFF,0X2B,0XFF,0X0B,0XFF,0X2C,0XF7,0X0B,0XFF,0X4C,0XFF,0X6D,

39590XE6,0X69,0XA4,0X42,0X93,0XC0,0X93,0XA1,0X8B,0XA2,0X83,0X63,0X72,0XE2,0X62,0X82,

39600X52,0X01,0X49,0XC1,0X49,0XA0,0X5A,0X21,0X73,0X03,0X8B,0XE7,0XAC,0XEB,0XE6,0XB4,

39610XFF,0XDB,0XFF,0X9D,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

39620XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBA,0XD6,0X4F,0XEE,0X8D,0XFF,0X0D,0XFE,0XEB,

39630XFE,0XEB,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,

39640XFE,0XEB,0XFE,0XEB,0XFE,0XEB,0XFE,0XEB,0XFF,0X0A,0XFF,0X0A,0XFE,0XEA,0XFE,0XCA,

39650XFE,0XEA,0XFE,0XEA,0XFE,0XCA,0XFE,0XCB,0XFF,0X0D,0XE6,0X2B,0X72,0XC0,0X5A,0X20,

39660X72,0XE3,0X73,0X04,0X7B,0X65,0X8B,0XE8,0XA4,0XCD,0XFF,0XBA,0XFF,0XFD,0XFF,0XFE,

39670XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XFF,0X57,

39750XEE,0XB0,0XF6,0XCD,0XFE,0XEB,0XFE,0XEB,0XFE,0XEB,0XFE,0XEB,0XFE,0XEB,0XFE,0XEA,

39760XFF,0X0A,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0A,0XFF,0X0B,0XFF,0X0B,

39770XFF,0X0A,0XFF,0X0A,0XFF,0X2B,0XFF,0X2B,0XF7,0X2B,0XFF,0X4D,0XF6,0XEC,0XB4,0XC4,

39780X8B,0X80,0X93,0XA1,0X93,0XA2,0X8B,0XA3,0X83,0X84,0X7B,0X24,0X62,0X83,0X5A,0X22,

39790X49,0XA0,0X49,0XA0,0X5A,0X21,0X6A,0XC4,0XAC,0XCD,0XFF,0X59,0XFF,0XBD,0XFF,0XDF,

39800XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

39810XFF,0XFE,0XF7,0X79,0XDE,0X50,0XEE,0XAD,0XFF,0X0C,0XFE,0XCA,0XFE,0XEA,0XFE,0XEA,

39820XFE,0XEA,0XFF,0X0B,0XFF,0X0B,0XFE,0XEB,0XFE,0XEA,0XFE,0XEA,0XFE,0XCA,0XFE,0XCA,

39830XFE,0XCA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XC9,0XFE,0XEA,0XFE,0XCA,0XFE,0XEA,

39840XFE,0XCA,0XFE,0XCB,0XFE,0XED,0XCD,0X89,0X62,0X60,0X5A,0X20,0X6A,0XC3,0X72,0XE4,

39850X83,0X85,0X83,0X86,0X83,0XC9,0XEF,0X38,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

39860XF7,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBB,0XF6,0XF4,0XEE,0XAE,0XF6,0XCB,

39940XFE,0XEA,0XFE,0XEA,0XFE,0XEB,0XFE,0XEB,0XFE,0XEA,0XFE,0XEA,0XFF,0X0A,0XFF,0X0A,

39950XFE,0XEB,0XFF,0X0B,0XFF,0X0A,0XFF,0X0A,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

39960XFF,0X0A,0XF7,0X0A,0XF7,0X0B,0XFF,0X2C,0XFF,0X2C,0XCD,0X87,0X93,0XA0,0X8B,0X80,

39970X93,0XC2,0X9B,0XE4,0X93,0XE5,0X8B,0X85,0X7B,0X25,0X62,0X83,0X5A,0X01,0X51,0XC1,

39980X49,0XA0,0X5A,0X44,0XC5,0X93,0XFF,0XBC,0XFF,0XBE,0XFF,0XBF,0XFF,0XDF,0XFF,0XFF,

39990XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XF7,0X79,

40000XDE,0X50,0XEE,0X8D,0XFE,0XCC,0XFE,0XAA,0XFE,0XCA,0XFE,0XC9,0XFE,0XEA,0XFE,0XEA,

40010XFE,0XEA,0XFE,0XEA,0XFE,0XCA,0XFE,0XC9,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XC9,

40020XFE,0XC9,0XFE,0XE9,0XFE,0XC9,0XFE,0XEA,0XFE,0XC9,0XFE,0XCA,0XFE,0XCA,0XFE,0XAA,

40030XF6,0XAC,0XB4,0XE7,0X62,0X20,0X52,0X00,0X62,0X83,0X62,0X83,0X7B,0X24,0X7B,0X65,

40040X7B,0X87,0XD6,0X75,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XFF,0XFF,

40050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40120XFF,0XFF,0XFF,0XFE,0XFF,0X99,0XE6,0X91,0XEE,0X8C,0XF6,0XAA,0XF6,0XC9,0XFE,0XE9,

40130XFE,0XEA,0XFE,0XCA,0XFE,0XCA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEB,0XFE,0XEB,

40140XFE,0XEB,0XFE,0XEA,0XFE,0XEB,0XFE,0XEA,0XFE,0XEA,0XFE,0XCA,0XFF,0X0A,0XF6,0XEA,

40150XF7,0X0A,0XF6,0XEA,0XFF,0X6D,0XEE,0X8B,0XA4,0X02,0X8B,0X60,0X93,0XA2,0X9C,0X04,

40160X9C,0X05,0X9C,0X26,0X8B,0XA5,0X83,0X44,0X6A,0X82,0X5A,0X22,0X49,0XA1,0X62,0XA7,

40170XE6,0X98,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XF7,0X79,0XDE,0X4F,0XEE,0XAD,

40190XFE,0XCB,0XFE,0XA9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

40200XFE,0XC9,0XFE,0XC9,0XFE,0XA9,0XFE,0XA9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC8,

40210XFE,0XA9,0XFE,0XC9,0XFE,0XA9,0XFE,0XA9,0XFE,0XCA,0XF6,0X8A,0XEE,0X8C,0XA4,0X25,

40220X62,0X81,0X52,0X01,0X5A,0X42,0X62,0X83,0X6A,0XE4,0X73,0X45,0X73,0X46,0XB5,0X71,

40230XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFD,

40310XFF,0X78,0XE6,0X70,0XEE,0X8B,0XF6,0XA9,0XF6,0XC8,0XFE,0XC8,0XFE,0XCA,0XFE,0XCA,

40320XFE,0XCA,0XFE,0XCA,0XFE,0XEA,0XFE,0XEA,0XFE,0XCB,0XFE,0XEB,0XFE,0XCB,0XFE,0XEA,

40330XFE,0XEA,0XFE,0XEA,0XFE,0XEB,0XFE,0XEA,0XFE,0XEA,0XFF,0X0A,0XF6,0XE9,0XF6,0XEA,

40340XFF,0X4C,0XFF,0X2D,0XBC,0XE5,0X8B,0X60,0X93,0XA2,0XA4,0X04,0XA4,0X24,0XA4,0X46,

40350XA4,0X45,0X93,0XC5,0X83,0X45,0X6A,0X84,0X5A,0X24,0X8B,0XEC,0XFF,0X7C,0XFF,0XDE,

40360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40370XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XF7,0X58,0XDE,0X2F,0XEE,0XAD,0XFE,0XAB,0XFE,0XA9,

40380XFE,0XA9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC8,

40390XFE,0XA8,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XC8,0XFE,0XA8,0XFE,0XA8,0XFE,0X88,

40400XFE,0X88,0XFE,0X89,0XFE,0XA9,0XF6,0X8A,0XE6,0X0A,0X9C,0X05,0X72,0XC3,0X51,0XE0,

40410X52,0X01,0X5A,0X63,0X6A,0XC3,0X73,0X25,0X73,0X26,0X9C,0XAE,0XFF,0XDD,0XFF,0XDE,

40420XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFC,0XF7,0X36,0XE6,0X4E,

40500XF6,0X8B,0XF6,0XA8,0XF6,0XC8,0XFE,0XA8,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XCA,

40510XFE,0XC9,0XFE,0XC9,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,

40520XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFF,0X0A,0XF6,0XC9,0XF6,0XC9,0XFE,0XEB,0XFF,0X4E,

40530XEE,0X6B,0X8B,0X60,0X93,0XA1,0X9B,0XC2,0XAC,0X64,0XBC,0XE6,0XAC,0X85,0X9C,0X25,

40540X93,0XE6,0X7B,0X25,0X62,0XC5,0XA4,0XCF,0XFF,0XFD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

40550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

40560XFF,0XFD,0XF7,0X58,0XD6,0X2E,0XEE,0XAC,0XF6,0XAA,0XFE,0XA9,0XFE,0XA8,0XFE,0XA8,

40570XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA8,0XFE,0XA8,0XFE,0XA8,0XFE,0XA8,

40580XFE,0X88,0XFE,0X88,0XFE,0XA8,0XFE,0XA8,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0X89,

40590XF6,0X48,0XFE,0XAB,0XBC,0XE6,0XB4,0XC8,0X52,0X00,0X51,0XE1,0X49,0XC0,0X52,0X43,

40600X5A,0X63,0X6A,0XE4,0X6B,0X06,0X94,0X4C,0XFF,0X9C,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

40610XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40680XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFC,0XE6,0X93,0XDE,0X0D,0XF6,0XAA,0XFE,0XA8,

40690XFE,0XA8,0XFE,0XA8,0XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XA9,0XFE,0XC9,0XFE,0XC9,

40700XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XCA,

40710XFE,0XA9,0XFE,0XEA,0XF6,0XA9,0XFE,0XC9,0XF6,0XCA,0XFF,0X2D,0XFE,0XED,0XCD,0X67,

40720X8B,0X80,0XA4,0X02,0XAC,0X63,0XAC,0X43,0XBC,0XC5,0XB4,0XC6,0X9C,0X45,0X8B,0XE6,

40730X7B,0X46,0XAD,0X30,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XEF,0X37,

40750XDE,0X2E,0XEE,0X8C,0XFE,0XAA,0XFE,0XA8,0XFE,0XA8,0XFE,0XA8,0XFE,0XA9,0XF6,0XA9,

40760XF6,0XA9,0XF6,0XA9,0XFE,0XA9,0XFE,0XA8,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0X88,

40770XF6,0X87,0XF6,0X87,0XFE,0XA8,0XF6,0X88,0XFE,0X89,0XFE,0X68,0XFE,0X89,0XE5,0XE8,

40780XCD,0X69,0XA4,0X47,0X51,0XC0,0X49,0XA1,0X49,0XC1,0X52,0X02,0X52,0X42,0X62,0XA4,

40790X62,0XE6,0X84,0X0B,0XF7,0X7B,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,

40800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

40870XFF,0XFE,0XFF,0XDB,0XD6,0X10,0XDE,0X0C,0XF6,0X8A,0XF6,0X88,0XF6,0X88,0XF6,0X88,

40880XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

40890XFE,0XAA,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0X89,0XFE,0XAA,0XFE,0XA9,0XFE,0XC9,

40900XF6,0X88,0XFE,0XCA,0XF6,0X89,0XFE,0XEB,0XFF,0X4E,0XFF,0X0D,0XA4,0X21,0X9C,0X01,

40910XAC,0X42,0XB4,0XA4,0XBC,0XC5,0XB4,0XC6,0XAC,0X85,0XA4,0X66,0X94,0X07,0XBD,0X8F,

40920XFF,0XDB,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XEF,0X36,0XDE,0X4D,0XEE,0X8B,

40940XFE,0X89,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XF6,0X89,0XF6,0X89,0XF6,0X89,

40950XFE,0X89,0XFE,0X88,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X88,0XF6,0X87,0XF6,0X87,

40960XFE,0X88,0XF6,0X68,0XFE,0X68,0XF6,0X48,0XFE,0X69,0XD5,0X87,0XDE,0X0B,0X83,0X63,

40970X49,0XC0,0X49,0XC2,0X41,0XC1,0X4A,0X02,0X52,0X02,0X5A,0X64,0X62,0XC5,0X7B,0XAA,

40980XF7,0X5B,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

40990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41050XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XBB,

41060XCD,0XAE,0XE6,0X2B,0XF6,0X89,0XF6,0X88,0XF6,0X68,0XF6,0X69,0XFE,0X89,0XFE,0X89,

41070XFE,0X89,0XF6,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,

41080XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X88,0XF6,0X68,0XFE,0XA9,

41090XEE,0X69,0XF6,0X8A,0XFF,0X2C,0XFF,0X4D,0XE6,0X29,0XAC,0X62,0X9B,0XE0,0XB4,0XA3,

41100XBC,0XC5,0XB4,0XC5,0XBD,0X05,0XAC,0XA5,0XA4,0X68,0XCD,0XD0,0XFF,0XDB,0XFF,0XFE,

41110XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41120XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XEF,0X15,0XDE,0X4D,0XEE,0X8A,0XF6,0X88,0XFE,0X67,

41130XFE,0X67,0XFE,0X68,0XF6,0X88,0XF6,0X89,0XF6,0X89,0XF6,0X89,0XF6,0X89,0XF6,0X89,

41140XFE,0X69,0XFE,0X69,0XFE,0X68,0XFE,0X68,0XF6,0X87,0XF6,0X87,0XF6,0X88,0XEE,0X47,

41150XFE,0X68,0XFE,0X69,0XE5,0XE7,0XE5,0XE8,0XD5,0XCA,0X72,0XC1,0X49,0XA0,0X49,0XC2,

41160X41,0XC2,0X49,0XE2,0X49,0XE2,0X52,0X43,0X5A,0X85,0X73,0X49,0XEF,0X5B,0XFF,0XFF,

41170XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XBD,0XFF,0XDB,0XCD,0X8D,0XE6,0X4B,

41250XEE,0X68,0XF6,0X67,0XF6,0X48,0XF6,0X49,0XFE,0X69,0XF6,0X69,0XF6,0X68,0XF6,0X88,

41260XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X89,0XF6,0X89,0XFE,0X89,0XFE,0X89,

41270XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XF6,0X89,0XF6,0X89,0XF6,0X89,

41280XF6,0XCA,0XFF,0X0C,0XFF,0X4D,0XCD,0X86,0XA4,0X20,0XAC,0X61,0XB4,0XA3,0XBC,0XE4,

41290XC5,0X25,0XB4,0XA5,0XB4,0XC9,0XCD,0XB0,0XFF,0XBB,0XFF,0XFE,0XFF,0XFF,0XFF,0XDE,

41300XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,

41310XFF,0XDB,0XE6,0XB2,0XDE,0X6C,0XEE,0X89,0XEE,0X67,0XF6,0X66,0XFE,0X67,0XFE,0X48,

41320XFE,0X69,0XF6,0X69,0XF6,0X69,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X69,0XF6,0X69,

41330XF6,0X48,0XF6,0X68,0XF6,0X67,0XEE,0X47,0XEE,0X47,0XF6,0X88,0XFE,0X69,0XEE,0X28,

41340XE5,0XE8,0XF6,0X8C,0XAC,0X86,0X62,0X60,0X52,0X01,0X49,0XE2,0X49,0XC2,0X49,0XC2,

41350X41,0XC1,0X4A,0X23,0X4A,0X24,0X73,0X8B,0XEF,0X5C,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

41360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41430XFF,0XFF,0XFF,0XFF,0XFF,0XBE,0XFF,0XBB,0XC5,0X6C,0XE6,0X4B,0XEE,0X47,0XF6,0X67,

41440XF6,0X49,0XF6,0X29,0XF6,0X69,0XF6,0X49,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X88,

41450XF6,0X88,0XF6,0X88,0XF6,0X89,0XF6,0X89,0XF6,0X69,0XFE,0X69,0XFE,0X68,0XFE,0X88,

41460XF6,0X88,0XF6,0X88,0XF6,0X89,0XF6,0X89,0XF6,0X89,0XF6,0X89,0XEE,0X48,0XF6,0XAA,

41470XFF,0X4C,0XFE,0XEB,0XCD,0X65,0XAC,0X41,0XAC,0X61,0XBC,0XE3,0XBC,0XC3,0XBC,0XE6,

41480XAC,0X88,0XCD,0X8F,0XFF,0X9B,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

41490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XB9,0XE6,0X91,

41500XDE,0X4C,0XEE,0X89,0XEE,0X66,0XF6,0X66,0XFE,0X67,0XFE,0X48,0XFE,0X49,0XF6,0X49,

41510XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X69,0XF6,0X49,0XF6,0X49,0XF6,0X48,

41520XEE,0X67,0XEE,0X67,0XEE,0X47,0XF6,0X68,0XF6,0X48,0XED,0XE8,0XF6,0X4A,0XDD,0XC9,

41530X93,0XA3,0X6A,0XA1,0X62,0X83,0X4A,0X02,0X49,0XE2,0X41,0XA1,0X41,0XC1,0X4A,0X02,

41540X41,0XE3,0X7B,0XAC,0XF7,0X9D,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

41620XFF,0XBE,0XFF,0XBA,0XBD,0X2B,0XE6,0X4B,0XEE,0X27,0XF6,0X67,0XF6,0X49,0XF6,0X29,

41630XF6,0X49,0XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

41640XF6,0X68,0XF6,0X69,0XF6,0X69,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

41650XF6,0X68,0XF6,0X68,0XF6,0X69,0XF6,0X69,0XEE,0X68,0XEE,0X69,0XF6,0XA9,0XFF,0X4C,

41660XF6,0XCA,0XC5,0X24,0XA4,0X20,0XB4,0X82,0XBC,0XE3,0XBD,0X06,0XBC,0XE8,0XC5,0X6E,

41670XFF,0X5A,0XFF,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

41680XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XFF,0X78,0XE6,0X70,0XDE,0X4B,0XEE,0X69,

41690XEE,0X66,0XF6,0X66,0XF6,0X47,0XFE,0X48,0XF6,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X68,

41700XF6,0X68,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X28,0XEE,0X47,0XF6,0X67,

41710XEE,0X67,0XEE,0X47,0XEE,0X28,0XEE,0X08,0XF6,0X6B,0XC5,0X06,0X83,0X21,0X72,0XE2,

41720X6A,0XE4,0X52,0X22,0X49,0XE2,0X41,0XE1,0X41,0XC1,0X41,0XC1,0X41,0XC3,0X83,0XCD,

41730XFF,0XBD,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XBA,

41810XBD,0X0A,0XE6,0X4B,0XE6,0X27,0XF6,0X47,0XF6,0X48,0XF6,0X29,0XF6,0X28,0XF6,0X48,

41820XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X69,

41830XF6,0X69,0XF6,0X68,0XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X48,0XF6,0X48,0XF6,0X48,

41840XF6,0X68,0XEE,0X68,0XEE,0X68,0XEE,0X48,0XE6,0X48,0XF6,0XCA,0XFF,0X4C,0XF6,0XCA,

41850XBD,0X04,0XA4,0X20,0XAC,0X82,0XB4,0XA4,0XC5,0X69,0XBD,0X2B,0XE6,0XB6,0XFF,0XDD,

41860XFF,0XDE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41870XFF,0XFE,0XFF,0XDB,0XF7,0X35,0XDE,0X6F,0XE6,0X4B,0XEE,0X69,0XEE,0X47,0XF6,0X67,

41880XF6,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

41890XF6,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X68,0XEE,0X47,0XF6,0X88,0XE6,0X07,

41900XEE,0X28,0XF6,0X6A,0XE6,0X09,0XB4,0X85,0X8B,0XA3,0X7B,0X63,0X6A,0XE4,0X5A,0X83,

41910X4A,0X02,0X4A,0X22,0X4A,0X02,0X39,0XA1,0X39,0XA3,0X8C,0X0E,0XFF,0XDE,0XFF,0XFF,

41920XFF,0XBF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41990XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XBA,0XB5,0X0A,0XE6,0X4B,

42000XE6,0X07,0XEE,0X26,0XEE,0X28,0XEE,0X08,0XEE,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X48,

42010XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

42020XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X68,

42030XEE,0X68,0XEE,0X48,0XEE,0X89,0XE6,0X48,0XEE,0X89,0XFF,0X4C,0XF6,0XCB,0XC5,0X24,

42040XA4,0X20,0XAC,0XA3,0XA4,0X43,0XB5,0X09,0XDE,0X53,0XFF,0X9B,0XFF,0XDE,0XF7,0XBE,

42050XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XBA,

42060XF6,0XF3,0XE6,0X4E,0XE6,0X4A,0XEE,0X48,0XEE,0X47,0XF6,0X47,0XF6,0X28,0XF6,0X28,

42070XF6,0X28,0XF6,0X28,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X28,0XF6,0X28,

42080XF6,0X28,0XF6,0X28,0XF6,0X48,0XEE,0X47,0XEE,0X27,0XEE,0X27,0XF6,0X49,0XF6,0X6A,

42090XD5,0X67,0XAC,0X65,0XA4,0X46,0X8B,0XC5,0X73,0X24,0X62,0XC3,0X5A,0X62,0X4A,0X22,

42100X41,0XE1,0X41,0XE2,0X39,0XA3,0XAD,0X12,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

42110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

42180XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XDA,0XBD,0X2B,0XDE,0X0A,0XE6,0X07,0XEE,0X26,

42190XEE,0X27,0XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X48,0XEE,0X28,0XF6,0X48,0XF6,0X48,

42200XEE,0X48,0XF6,0X68,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

42210XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X68,0XEE,0X48,

42220XEE,0X68,0XE6,0X48,0XE6,0X27,0XEE,0X89,0XFF,0X4D,0XF6,0XCB,0XCD,0XA6,0XA4,0X62,

42230XA4,0X43,0XAC,0XC7,0XBD,0X4D,0XEE,0XF7,0XFF,0XDD,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,

42240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0X98,0XEE,0XD1,0XE6,0X4C,

42250XE6,0X49,0XEE,0X48,0XEE,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,

42260XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X28,0XF6,0X28,0XF6,0X08,

42270XEE,0X27,0XEE,0X47,0XE5,0XE6,0XF6,0X89,0XF6,0X89,0XE6,0X08,0XCD,0X47,0XBC,0XC6,

42280XAC,0X66,0X9C,0X06,0X83,0X64,0X73,0X04,0X6A,0XC3,0X52,0X42,0X41,0XC1,0X4A,0X03,

42290X41,0XE4,0XD6,0X57,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

42370XFF,0XDD,0XFF,0XDB,0XBD,0X2C,0XCD,0XAA,0XE6,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X28,

42380XEE,0X08,0XF6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,

42390XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XF6,0X48,0XF6,0X48,

42400XF6,0X48,0XF6,0X48,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X48,0XEE,0X28,0XEE,0X48,

42410XEE,0X69,0XE6,0X28,0XEE,0X89,0XFE,0XEB,0XFF,0X4D,0XDE,0X08,0XB4,0XE4,0X93,0XE2,

42420XAC,0XE8,0XD6,0X51,0XF7,0X9A,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42430XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XF7,0X35,0XE6,0X8F,0XE6,0X2A,0XE6,0X49,0XEE,0X27,

42440XEE,0X26,0XF6,0X27,0XF6,0X07,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X47,

42450XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X28,0XF6,0X28,0XEE,0X08,0XEE,0X07,0XEE,0X47,

42460XEE,0X27,0XFE,0XA9,0XF6,0X69,0XDD,0XA7,0XD5,0X67,0XC5,0X07,0XB4,0XA6,0XA4,0X46,

42470X8B,0XC5,0X7B,0X64,0X73,0X03,0X62,0X83,0X4A,0X22,0X41,0XC3,0X62,0XC8,0XEF,0X5B,

42480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XDB,

42560XBD,0X2D,0XC5,0X69,0XE6,0X29,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X07,0XEE,0X07,

42570XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,

42580XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X47,0XEE,0X47,

42590XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X48,0XE6,0X27,0XE6,0X48,0XEE,0X89,

42600XE6,0X28,0XE6,0X49,0XFE,0XEB,0XFF,0X0C,0XF6,0XAB,0XBD,0X06,0X9C,0X23,0XB5,0X2A,

42610XF7,0X56,0XFF,0XDB,0XFF,0XFE,0XFF,0XFF,0XF7,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,

42620XFF,0XDA,0XEE,0XF3,0XE6,0X4C,0XDE,0X09,0XE6,0X28,0XEE,0X27,0XEE,0X26,0XF6,0X26,

42630XF6,0X07,0XF6,0X08,0XF6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X47,

42640XEE,0X47,0XEE,0X28,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XFE,0XC9,0XF6,0X89,

42650XEE,0X07,0XDD,0XA7,0XD5,0X47,0XC5,0X27,0XC4,0XE7,0XAC,0X66,0X9C,0X06,0X8B,0XA5,

42660X73,0X03,0X6A,0XC3,0X52,0X43,0X39,0XA2,0X94,0X6E,0XFF,0XFE,0XFF,0XDE,0XFF,0XDE,

42670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XBD,0X4E,0XC5,0X6A,

42750XE6,0X09,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X28,

42760XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

42770XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

42780XEE,0X27,0XEE,0X27,0XEE,0X27,0XE6,0X27,0XE6,0X27,0XE6,0X28,0XE6,0X48,0XEE,0X69,

42790XE6,0X29,0XF6,0X8B,0XFF,0X2D,0XFE,0XCC,0XCD,0XC8,0XA4,0XA5,0XBD,0XAD,0XFF,0XD9,

42800XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFB,0XFF,0XB7,0XEE,0XB0,

42810XE6,0X2B,0XE6,0X08,0XEE,0X27,0XEE,0X26,0XEE,0X26,0XEE,0X26,0XEE,0X07,0XEE,0X08,

42820XEE,0X08,0XEE,0X09,0XEE,0X08,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

42830XEE,0X07,0XEE,0X07,0XF6,0X27,0XFE,0X88,0XFE,0X88,0XF6,0X68,0XEE,0X07,0XE5,0XE8,

42840XDD,0X87,0XCD,0X27,0XC5,0X27,0XBC,0XA7,0XAC,0X66,0X9B,0XE5,0X83,0X64,0X72,0XE4,

42850X5A,0X64,0X52,0X66,0XCE,0X36,0XFF,0XFE,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

42860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42930XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XCD,0XD1,0XBD,0X2B,0XE6,0X2A,0XE5,0XE7,

42940XE5,0XE7,0XEE,0X48,0XEE,0X07,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X28,

42950XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

42960XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

42970XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X28,0XE6,0X28,0XE6,0X28,0XEE,0X49,0XE6,0X09,

42980XEE,0X29,0XFE,0XCC,0XFF,0XAE,0XEE,0XCC,0XB5,0X29,0XD6,0X71,0XFF,0XFC,0XFF,0XFE,

42990XFF,0XDE,0XFF,0XDE,0XFF,0XFD,0XFF,0XD9,0XF7,0X54,0XE6,0X8D,0XE6,0X29,0XE6,0X07,

43000XEE,0X27,0XEE,0X26,0XEE,0X25,0XEE,0X26,0XEE,0X06,0XEE,0X07,0XEE,0X08,0XEE,0X09,

43010XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XE6,0X06,0XEE,0X06,0XEE,0X07,0XEE,0X07,

43020XFE,0X68,0XFE,0X88,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XE5,0XE7,0XE5,0XA8,0XDD,0X87,

43030XD5,0X48,0XC4,0XE7,0XB4,0X86,0XA4,0X26,0X93,0XC6,0X73,0X04,0X6A,0XE6,0X6B,0X4A,

43040XFF,0XDD,0XFF,0XFE,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43120XFF,0XFF,0XFF,0XFD,0XDE,0X95,0XAC,0XCA,0XDE,0X0B,0XDD,0XE8,0XDD,0XE7,0XEE,0X68,

43130XEE,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X28,

43140XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,

43150XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X48,

43160XEE,0X48,0XEE,0X48,0XEE,0X28,0XE6,0X28,0XE6,0X08,0XEE,0X29,0XEE,0X09,0XEE,0X49,

43170XEE,0X6A,0XFF,0X4D,0XFF,0X4F,0XCE,0X2D,0XF7,0X76,0XFF,0X9A,0XFF,0XBC,0XFF,0XFD,

43180XFF,0XFB,0XFF,0XB6,0XEE,0XF0,0XDE,0X4B,0XE6,0X29,0XE6,0X07,0XEE,0X27,0XEE,0X26,

43190XEE,0X26,0XEE,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,

43200XEE,0X28,0XEE,0X27,0XEE,0X06,0XE6,0X06,0XEE,0X28,0XF6,0X69,0XFE,0XA9,0XFE,0X88,

43210XF6,0X67,0XF6,0X68,0XF6,0X48,0XEE,0X28,0XE5,0XE8,0XDD,0XA7,0XD5,0X67,0XCD,0X27,

43220XBC,0XA6,0XAC,0X46,0X9C,0X07,0X7B,0X26,0X6A,0XE7,0XD6,0X77,0XFF,0XDD,0XFF,0XDE,

43230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,

43310XF7,0X38,0XA4,0X8B,0XD5,0XCB,0XDE,0X09,0XDE,0X07,0XE6,0X27,0XE6,0X07,0XE5,0XE7,

43320XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X28,

43330XEE,0X28,0XEE,0X28,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

43340XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

43350XEE,0X48,0XEE,0X48,0XEE,0X28,0XE5,0XC7,0XF6,0X49,0XE5,0XE8,0XDD,0XE7,0XE6,0X69,

43360XEE,0XEB,0XFF,0X6F,0XEE,0XD1,0XFF,0X56,0XFF,0X99,0XFF,0XBA,0XFF,0XB7,0XF7,0X73,

43370XE6,0XAD,0XDE,0X29,0XE6,0X28,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X26,0XEE,0X26,

43380XEE,0X26,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X06,

43390XEE,0X26,0XF6,0X47,0XF6,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0X88,0XFE,0X68,0XF6,0X47,

43400XF6,0X27,0XF6,0X48,0XEE,0X08,0XE5,0XC7,0XDD,0X87,0XCD,0X47,0XC5,0X07,0XB4,0XA7,

43410XA4,0X28,0X83,0X67,0XAC,0XF0,0XF7,0X5B,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

43420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0X9B,0XB4,0XED,

43500XC5,0X4A,0XDE,0X0A,0XDD,0XE8,0XDD,0XE6,0XE6,0X08,0XE6,0X07,0XEE,0X08,0XE5,0XE7,

43510XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X28,

43520XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

43530XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

43540XEE,0X28,0XEE,0X08,0XF6,0X28,0XEE,0X28,0XEE,0X28,0XE6,0X08,0XE6,0X69,0XE6,0X6A,

43550XFF,0X0F,0XF6,0XF1,0XF6,0XD4,0XFF,0X35,0XFF,0X73,0XF6,0XEF,0XDE,0X2A,0XDE,0X28,

43560XE6,0X27,0XE6,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

43570XEE,0X07,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XE6,0X06,0XE6,0X06,0XF6,0X27,0XFE,0X88,

43580XFE,0XA9,0XF6,0X69,0XFE,0X89,0XFE,0X89,0XFE,0X68,0XF6,0X47,0XF6,0X68,0XF6,0X48,

43590XEE,0X28,0XE6,0X08,0XDD,0XC7,0XCD,0X46,0XCD,0X28,0XC5,0X09,0XA4,0X69,0X94,0X2B,

43600XE6,0XD7,0XFF,0XDD,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XCD,0XD2,0XB4,0XC9,0XDD,0XEA,

43690XDE,0X08,0XE6,0X07,0XE5,0XE7,0XE6,0X08,0XE5,0XE7,0XEE,0X07,0XEE,0X07,0XEE,0X07,

43700XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,

43710XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

43720XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XF6,0X69,

43730XEE,0X07,0XED,0XE7,0XEE,0X28,0XEE,0X48,0XDE,0X07,0XDE,0X07,0XDE,0X09,0XF6,0XAD,

43740XFF,0X11,0XFE,0XF1,0XEE,0XAE,0XEE,0X8C,0XDE,0X28,0XE6,0X27,0XE6,0X07,0XEE,0X27,

43750XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X06,0XEE,0X27,0XEE,0X07,

43760XE6,0X06,0XEE,0X06,0XEE,0X47,0XF6,0X47,0XF6,0X67,0XFE,0X88,0XF6,0X68,0XF6,0X69,

43770XFE,0X69,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X48,0XEE,0X28,

43780XE6,0X08,0XDD,0XA7,0XCD,0X68,0XBD,0X09,0XAC,0XAB,0XC5,0XB2,0XF7,0X7B,0XFF,0XFE,

43790XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43870XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XEE,0XB6,0XB4,0XC9,0XD5,0XA9,0XE6,0X09,0XE6,0X28,

43880XDD,0XC7,0XE5,0XE7,0XE5,0XE7,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,

43890XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,

43900XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X07,

43910XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XF6,0X48,0XEE,0X07,0XEE,0X07,

43920XEE,0X07,0XEE,0X27,0XE6,0X06,0XEE,0X68,0XE6,0X28,0XE6,0X08,0XEE,0X4A,0XF6,0XAC,

43930XFE,0XCC,0XEE,0X69,0XDD,0XE7,0XE6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X09,

43940XEE,0X08,0XEE,0X08,0XEE,0X27,0XE6,0X06,0XEE,0X27,0XEE,0X06,0XEE,0X06,0XEE,0X46,

43950XF6,0X67,0XF6,0X47,0XEE,0X26,0XEE,0X27,0XEE,0X27,0XFE,0X89,0XFE,0X69,0XFE,0X48,

43960XFE,0X69,0XFE,0X68,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XEE,0X28,0XE6,0X28,0XE6,0X08,

43970XCD,0X88,0XBD,0X2A,0XC5,0X8F,0XF7,0X38,0XFF,0XDC,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

43980XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44060XFF,0XBE,0XFF,0X5A,0XC5,0X4D,0XCD,0X6A,0XDD,0XE9,0XDE,0X08,0XE5,0XE7,0XE6,0X07,

44070XEE,0X08,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XEE,0X08,0XE6,0X07,0XEE,0X07,0XEE,0X07,

44080XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X28,

44090XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,

44100XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XF6,0X48,0XEE,0X27,

44110XEE,0X27,0XDD,0XE6,0XF6,0X89,0XEE,0X27,0XE6,0X08,0XDD,0XE7,0XE6,0X28,0XEE,0X28,

44120XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X08,0XEE,0X09,0XEE,0X08,0XEE,0X08,

44130XEE,0X28,0XE6,0X06,0XE5,0XE6,0XEE,0X27,0XF6,0X67,0XF6,0X67,0XF6,0X46,0XE5,0XC5,

44140XDD,0XA5,0XE5,0XC5,0XEE,0X27,0XF6,0X48,0XFE,0X69,0XFE,0X69,0XFE,0X68,0XFE,0X68,

44150XFE,0X68,0XF6,0X88,0XF6,0X68,0XEE,0X48,0XE6,0X08,0XDD,0XE9,0XCD,0XA9,0XCD,0XED,

44160XDE,0XB3,0XFF,0XDB,0XFF,0XFD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

44170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBC,

44250XDE,0X32,0XB4,0XC9,0XD5,0XCA,0XD5,0XC7,0XE6,0X07,0XE6,0X07,0XE5,0XE7,0XE5,0XE8,

44260XE5,0XE8,0XE6,0X08,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,

44270XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,

44280XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,

44290XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

44300XE5,0XE6,0XE6,0X07,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X07,0XEE,0X07,

44310XEE,0X27,0XE6,0X07,0XEE,0X28,0XE5,0XE7,0XEE,0X28,0XE6,0X08,0XEE,0X28,0XEE,0X07,

44320XEE,0X28,0XF6,0X48,0XFE,0X88,0XE5,0XC6,0XCD,0X02,0XCC,0XE2,0XCD,0X03,0XDD,0X85,

44330XEE,0X07,0XF6,0X48,0XF6,0X69,0XF6,0X88,0XFE,0XA8,0XF6,0X88,0XF6,0X68,0XF6,0X88,

44340XF6,0X48,0XEE,0X29,0XEE,0X4A,0XDE,0X0A,0XD6,0X2D,0XDE,0XB2,0XFF,0XD9,0XFF,0XFC,

44350XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBD,0XF7,0X17,0XBD,0X4D,

44440XC5,0X6A,0XD5,0XC8,0XDE,0X07,0XE6,0X27,0XE5,0XE7,0XEE,0X08,0XE5,0XC8,0XE6,0X09,

44450XE6,0X08,0XE6,0X27,0XEE,0X26,0XE6,0X06,0XE6,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,

44460XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X27,

44470XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X07,

44480XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,

44490XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,

44500XEE,0X28,0XEE,0X07,0XE5,0XE7,0XE5,0XE7,0XEE,0X28,0XE6,0X08,0XF6,0X49,0XEE,0X48,

44510XCD,0X24,0XAC,0X20,0XB4,0X40,0XBC,0X81,0XCD,0X03,0XDD,0X65,0XE5,0XC6,0XEE,0X28,

44520XFE,0X89,0XFE,0XA9,0XF6,0X88,0XFE,0XA9,0XFE,0XC9,0XF6,0X68,0XF6,0X69,0XF6,0X8A,

44530XE6,0X2B,0XD5,0XEC,0XEF,0X13,0XFF,0XD8,0XFF,0XFB,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

44540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44620XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDD,0XFF,0X9B,0XDE,0X32,0XAC,0XC9,0XDE,0X2B,

44630XD5,0XC7,0XE5,0XE6,0XE5,0XE6,0XE5,0XE7,0XEE,0X08,0XED,0XE9,0XE5,0XE8,0XE5,0XE7,

44640XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X08,

44650XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

44660XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X28,

44670XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

44680XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XE6,0X07,

44690XEE,0X27,0XEE,0X27,0XE6,0X07,0XF6,0XAA,0XDD,0XA7,0XAC,0X41,0X93,0X60,0X9B,0XC0,

44700XA3,0XE0,0XAC,0X21,0XC4,0XC2,0XCD,0X03,0XDD,0X85,0XEE,0X07,0XFE,0X68,0XFE,0X88,

44710XFE,0X88,0XFE,0X88,0XF6,0X88,0XF6,0X89,0XF6,0X69,0XE6,0X4A,0XE6,0X4D,0XE6,0X91,

44720XFF,0X98,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44810XFF,0XFF,0XFF,0XDE,0XFF,0XDC,0XF7,0X37,0XBD,0X6D,0XC5,0X8A,0XD5,0XC8,0XDE,0X07,

44820XE5,0XE6,0XE5,0XE7,0XEE,0X08,0XEE,0X09,0XE5,0XE8,0XE5,0XC8,0XE6,0X08,0XE6,0X08,

44830XE6,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

44840XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

44850XEE,0X28,0XEE,0X27,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

44860XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,

44870XEE,0X28,0XEE,0X28,0XED,0XE8,0XEE,0X08,0XEE,0X07,0XE6,0X07,0XEE,0X47,0XF6,0X88,

44880XFF,0X0B,0XD5,0XA6,0XA4,0X21,0X83,0X20,0X82,0XE0,0X8B,0X40,0X9B,0XC0,0XA3,0XE1,

44890XB4,0X41,0XC4,0XC3,0XDD,0X65,0XEE,0X07,0XF6,0X48,0XFE,0X48,0XFE,0X89,0XFE,0X69,

44900XF6,0X69,0XF6,0XAA,0XEE,0X6B,0XE6,0X4C,0XEE,0XF2,0XFF,0XB8,0XFF,0XBB,0XFF,0XDD,

44910XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45000XFF,0XFE,0XFF,0XBB,0XEF,0X16,0XB4,0XEA,0XCD,0XA9,0XE6,0X09,0XE5,0XE7,0XEE,0X07,

45010XE5,0XE7,0XED,0XE8,0XEE,0X08,0XED,0XE8,0XEE,0X08,0XE6,0X08,0XE6,0X07,0XEE,0X07,

45020XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

45030XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

45040XEE,0X28,0XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

45050XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X08,

45060XF6,0X09,0XED,0XE8,0XE5,0XE7,0XEE,0X48,0XEE,0X47,0XE6,0X26,0XFF,0X2B,0XF6,0XEB,

45070XD5,0XA7,0X9B,0XE1,0X83,0X00,0X83,0X00,0X8B,0X40,0X9B,0XC1,0XA3,0XE1,0XBC,0XA3,

45080XD5,0X44,0XED,0XE6,0XFE,0X68,0XFE,0X68,0XFE,0X48,0XFE,0X8A,0XFE,0X8B,0XEE,0X6C,

45090XEE,0X8F,0XF7,0X33,0XFF,0X97,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,

45100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,

45190XFF,0XDA,0XDE,0X72,0XB4,0XE9,0XD5,0XAA,0XDD,0XC8,0XEE,0X08,0XE5,0XE7,0XED,0XE7,

45200XED,0XE7,0XE5,0XE8,0XE5,0XE8,0XE6,0X08,0XE5,0XE8,0XE6,0X08,0XEE,0X07,0XEE,0X07,

45210XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

45220XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X07,

45230XEE,0X27,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

45240XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XED,0XE8,

45250XEE,0X08,0XE6,0X07,0XE6,0X27,0XE6,0X27,0XDE,0X06,0XEE,0X8A,0XFF,0X4D,0XE6,0X6B,

45260XB4,0XC5,0X8B,0X60,0X83,0X20,0X7A,0XE0,0X9B,0XC1,0XAC,0X42,0XCD,0X03,0XE5,0XE6,

45270XFE,0X69,0XFE,0X69,0XFE,0X6A,0XF6,0X6B,0XEE,0X6C,0XEE,0X6F,0XF7,0X14,0XFF,0XD9,

45280XFF,0XBB,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XDE,0XFF,0XFE,0XFF,0XBB,0XFF,0XDA,

45380XCD,0XAF,0XC5,0X4B,0XD5,0X89,0XDD,0XC8,0XE6,0X07,0XE5,0XE6,0XE5,0XE6,0XE5,0XE6,

45390XE6,0X07,0XEE,0X08,0XE5,0XE8,0XE5,0XE8,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,

45400XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

45410XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X27,0XEE,0X28,

45420XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

45430XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XED,0XE7,0XEE,0X08,0XEE,0X07,0XEE,0X27,

45440XE5,0XE6,0XDE,0X07,0XE6,0X48,0XE6,0X48,0XE6,0X6A,0XFF,0X0D,0XFF,0X4E,0XCD,0X88,

45450X83,0X20,0X8B,0X40,0X83,0X40,0X9B,0XC0,0XBC,0XA3,0XDD,0XC6,0XF6,0X69,0XF6,0X8A,

45460XFE,0X8C,0XF6,0X6D,0XEE,0X90,0XFF,0X35,0XFF,0XBA,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,

45470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0X7B,0XFF,0XBA,0XC5,0X8E,

45570XCD,0X8C,0XD5,0XA9,0XDD,0XE8,0XE6,0X06,0XE6,0X26,0XE6,0X06,0XEE,0X07,0XE6,0X07,

45580XE5,0XE8,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

45590XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

45600XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X27,

45610XEE,0X27,0XEE,0X07,0XEE,0X28,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X28,

45620XEE,0X28,0XEE,0X27,0XEE,0X07,0XED,0XE7,0XEE,0X07,0XE6,0X07,0XEE,0X48,0XE6,0X27,

45630XE6,0X48,0XE6,0X28,0XDE,0X07,0XDE,0X29,0XF6,0XAB,0XFF,0X2D,0XF6,0XCD,0X83,0X40,

45640X83,0X20,0X83,0X40,0XAC,0X83,0XD5,0XA7,0XF6,0X8A,0XF6,0XAB,0XEE,0X6D,0XF6,0XD0,

45650XFF,0X56,0XFF,0XFB,0XFF,0XFD,0XFF,0XDE,0XFF,0XFF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,

45660XFF,0XDE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFD,0XFF,0X9A,0XD6,0X11,0XBD,0X2A,

45760XD5,0XC9,0XDE,0X27,0XDD,0XE5,0XE6,0X25,0XDD,0XE5,0XEE,0X27,0XE5,0XE8,0XE5,0XE8,

45770XEE,0X28,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X28,

45780XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

45790XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

45800XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,

45810XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XE6,0X27,0XE6,0X07,0XE6,0X07,

45820XE6,0X28,0XDE,0X07,0XDD,0XE7,0XEE,0X8A,0XFF,0X2D,0XFF,0X4E,0XA4,0X63,0X83,0X40,

45830X9C,0X22,0XCD,0XA8,0XE6,0X6C,0XEE,0XCF,0XEE,0XD1,0XFF,0X76,0XFF,0XFB,0XFF,0XFD,

45840XFF,0XFE,0XF7,0XDF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45940XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XBC,0XF7,0X37,0XDE,0X50,0XC5,0XAA,0XCD,0XC8,

45950XDE,0X27,0XE6,0X46,0XDD,0XE5,0XE6,0X07,0XEE,0X08,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,

45960XE5,0XE7,0XE6,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

45970XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

45980XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

45990XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X26,0XEE,0X26,

46000XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XE6,0X27,0XE6,0X27,

46010XDE,0X07,0XE6,0X48,0XE6,0X49,0XEE,0XAB,0XFF,0X4E,0XBD,0X46,0XA4,0X84,0XD6,0X0B,

46020XF6,0XF0,0XE6,0X91,0XFF,0XF8,0XFF,0XFB,0XFF,0XDC,0XFF,0XDE,0XFF,0XFF,0XF7,0XFF,

46030XF7,0XFF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

46130XFF,0XFF,0XFF,0XDE,0XFF,0XFC,0XF7,0X57,0XD6,0X4F,0XC5,0XCA,0XCD,0XE8,0XDE,0X27,

46140XE6,0X27,0XE5,0XE6,0XE6,0X07,0XE5,0XE7,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

46150XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

46160XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

46170XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

46180XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XE6,0X27,0XEE,0X27,0XEE,0X27,

46190XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XE6,0X07,0XEE,0X47,0XE6,0X27,

46200XDE,0X07,0XE6,0X48,0XF7,0X0C,0XFF,0X2D,0XDE,0X29,0XDE,0X4C,0XFF,0X93,0XFF,0XD7,

46210XFF,0XBA,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XF7,0XDF,0XF7,0XFF,0XFF,0XFF,

46220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46320XFF,0XFD,0XFF,0XDB,0XF7,0X77,0XDE,0X91,0XCD,0XCB,0XCD,0XA8,0XDE,0X28,0XDE,0X07,

46330XE5,0XE7,0XEE,0X08,0XE6,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,

46340XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

46350XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

46360XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

46370XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,

46380XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X07,0XE6,0X48,

46390XDE,0X27,0XEE,0X89,0XFF,0X2C,0XF7,0X4E,0XEE,0XF1,0XFF,0X96,0XFF,0XFC,0XFF,0XDD,

46400XFF,0XDF,0XFF,0XFF,0XF7,0XDF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XDE,0XFF,0XFD,

46510XFF,0XFC,0XFF,0X98,0XDE,0X91,0XCD,0XEC,0XD5,0XCA,0XDE,0X09,0XE6,0X08,0XEE,0X28,

46520XE5,0XE8,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X28,0XEE,0X28,

46530XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

46540XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

46550XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

46560XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

46570XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X28,0XEE,0X48,0XDE,0X07,

46580XEE,0XA9,0XFF,0X4D,0XF7,0X0F,0XEE,0XF2,0XF7,0X77,0XFF,0XFD,0XFF,0XDE,0XF7,0XBE,

46590XF7,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XDF,0XFF,0XFF,0XFF,0XDD,0XFF,0XDC,

46700XFF,0X78,0XEE,0XD2,0XD5,0XCC,0XCD,0XA9,0XDD,0XC8,0XE6,0X08,0XEE,0X28,0XEE,0X28,

46710XEE,0X28,0XEE,0X28,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,

46720XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

46730XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

46740XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,

46750XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

46760XEE,0X08,0XED,0XE7,0XEE,0X08,0XEE,0X28,0XE5,0XE7,0XEE,0X48,0XE6,0X27,0XDE,0X49,

46770XF7,0X2E,0XFF,0X72,0XDE,0X92,0XF7,0X58,0XFF,0XFC,0XFF,0XFE,0XFF,0XDD,0XFF,0XDE,

46780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,

46880XFF,0XFF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDE,0XFF,0XDB,0XFF,0XB8,

46890XEE,0XB2,0XDE,0X2C,0XD5,0XC9,0XDD,0XE8,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,

46900XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

46910XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

46920XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

46930XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

46940XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XF6,0X28,0XED,0XE7,0XF6,0X28,

46950XED,0XE7,0XF6,0X08,0XEE,0X07,0XE5,0XC6,0XE6,0X27,0XDE,0X07,0XDE,0X29,0XF6,0XEE,

46960XFF,0X52,0XD6,0X50,0XE6,0XD4,0XFF,0XBA,0XFF,0XDC,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,

46970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XDB,0XFF,0XD8,0XF7,0X33,

47080XDE,0X2C,0XD5,0XC9,0XE6,0X29,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

47090XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

47100XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

47110XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

47120XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X07,0XEE,0X07,

47130XEE,0X07,0XEE,0X07,0XEE,0X07,0XF6,0X28,0XEE,0X07,0XEE,0X08,0XEE,0X07,0XF6,0X08,

47140XF5,0XE7,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X48,0XE6,0X29,0XEE,0XCD,0XF7,0X30,

47150XCD,0XEE,0XDE,0X93,0XFF,0XBA,0XFF,0XDC,0XFF,0XDD,0XFF,0XDE,0XFF,0XDE,0XFF,0XDF,

47160XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47260XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XD9,0XF7,0X54,0XE6,0X8E,

47270XDD,0XC8,0XDD,0XA6,0XEE,0X48,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XF6,0X48,0XEE,0X28,

47280XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X27,

47290XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XF6,0X28,0XEE,0X27,0XEE,0X27,

47300XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

47310XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,

47320XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

47330XEE,0X07,0XEE,0X07,0XE6,0X07,0XEE,0X28,0XE6,0X48,0XEE,0XAB,0XF7,0X0F,0XB5,0X2B,

47340XCD,0XF1,0XF7,0X9A,0XFF,0XDC,0XFF,0XDD,0XFF,0XDE,0XFF,0XBF,0XFF,0XDF,0XFF,0XDF,

47350XF7,0X9E,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47450XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XFC,0XFF,0XD8,0XFF,0X53,0XEE,0X4B,0XE5,0XC7,

47460XE6,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

47470XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X27,

47480XEE,0X27,0XEE,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

47490XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,

47500XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

47510XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XED,0XE7,0XED,0XE7,

47520XEE,0X07,0XEE,0X27,0XE6,0X05,0XEE,0X68,0XF6,0XCC,0XE6,0X8E,0XA4,0XCA,0XB5,0X2E,

47530XEF,0X38,0XFF,0XFD,0XFF,0XFE,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47540XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47640XFF,0XDD,0XFF,0XBB,0XFF,0XB9,0XFF,0X94,0XFE,0XEE,0XEE,0X49,0XE5,0XE7,0XEE,0X08,

47650XEE,0X07,0XEE,0X08,0XEE,0X27,0XF6,0X48,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,

47660XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X27,0XEE,0X27,0XF6,0X28,0XF6,0X28,

47670XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

47680XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

47690XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

47700XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,

47710XE6,0X05,0XE6,0X26,0XEE,0X68,0XF6,0XEC,0XD6,0X0C,0X94,0X27,0X94,0X29,0XE6,0XD6,

47720XFF,0XDC,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XBF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

47730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XBD,0XFF,0XBC,0XFF,0XDB,

47830XFF,0X77,0XEE,0XB1,0XEE,0X6B,0XEE,0X48,0XE6,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X28,

47840XEE,0X07,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

47850XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XF6,0X28,0XF6,0X48,0XF6,0X28,0XF6,0X28,

47860XF6,0X28,0XF6,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

47870XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X27,

47880XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

47890XEE,0X27,0XEE,0X27,0XEE,0X08,0XF6,0X28,0XEE,0X07,0XEE,0X07,0XF6,0X66,0XEE,0X25,

47900XE6,0X46,0XE6,0X48,0XEE,0X8B,0XDE,0X2C,0X7B,0X63,0X83,0XA7,0XDE,0X95,0XFF,0XFC,

47910XFF,0XDD,0XFF,0XDE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48010XFF,0XFF,0XFF,0XDD,0XFF,0XDD,0XFF,0XFB,0XFF,0XB9,0XFF,0X55,0XEE,0XB1,0XDE,0X2C,

48020XDD,0XE8,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X28,0XEE,0X08,0XEE,0X28,0XEE,0X28,

48030XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

48040XEE,0X28,0XEE,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X48,

48050XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

48060XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X27,0XEE,0X27,

48070XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

48080XEE,0X07,0XEE,0X28,0XEE,0X08,0XEE,0X07,0XF6,0X46,0XEE,0X25,0XEE,0X45,0XEE,0X26,

48090XEE,0X68,0XE6,0X29,0XE6,0X6D,0X5A,0X60,0X83,0XA8,0XDE,0XB6,0XFF,0XFC,0XFF,0XDD,

48100XFF,0XFF,0XF7,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,

48200XFF,0XFA,0XFF,0XB7,0XF7,0X12,0XDE,0X2D,0XD5,0XEB,0XDE,0X2A,0XE6,0X08,0XEE,0X07,

48210XE6,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X07,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

48220XEE,0X48,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X28,0XEE,0X28,

48230XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X28,

48240XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,

48250XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

48260XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X07,

48270XEE,0X28,0XF6,0X08,0XEE,0X06,0XF6,0X46,0XEE,0X25,0XF6,0X46,0XF6,0X47,0XEE,0X48,

48280XDE,0X0A,0XBD,0X49,0X52,0X20,0X73,0X46,0XE6,0XF7,0XFF,0XFD,0XFF,0XDE,0XFF,0XFF,

48290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XD9,0XF7,0X54,0XDE,0X8E,

48390XD6,0X0B,0XDE,0X09,0XDE,0X28,0XDE,0X07,0XE6,0X07,0XEE,0X27,0XE6,0X07,0XEE,0X48,

48400XEE,0X28,0XEE,0X27,0XEE,0X07,0XE6,0X07,0XEE,0X48,0XEE,0X48,0XEE,0X27,0XEE,0X27,

48410XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XF6,0X48,0XEE,0X28,0XF6,0X28,0XF6,0X28,

48420XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X48,

48430XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

48440XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

48450XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XF6,0X28,

48460XF6,0X07,0XF6,0X27,0XEE,0X05,0XF6,0X26,0XEE,0X07,0XEE,0X48,0XE6,0X09,0XDE,0X0B,

48470X94,0X26,0X4A,0X00,0X7B,0X67,0XE6,0XD7,0XFF,0XDD,0XFF,0XFF,0XFF,0XFE,0XF7,0XBE,

48480XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48560XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48570XFF,0XDE,0XFF,0XDC,0XFF,0X97,0XF7,0X12,0XE6,0X8D,0XDE,0X2A,0XDE,0X28,0XDE,0X07,

48580XDE,0X07,0XE6,0X47,0XE6,0X07,0XEE,0X48,0XE6,0X07,0XEE,0X27,0XE5,0XE7,0XEE,0X28,

48590XEE,0X48,0XEE,0X28,0XF6,0X68,0XEE,0X27,0XE6,0X07,0XE6,0X06,0XEE,0X27,0XEE,0X47,

48600XEE,0X47,0XEE,0X27,0XF6,0X48,0XF6,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,

48610XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X28,

48620XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

48630XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

48640XEE,0X27,0XEE,0X27,0XEE,0X27,0XF6,0X48,0XEE,0X28,0XEE,0X08,0XF6,0X28,0XEE,0X06,

48650XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X28,0XEE,0X49,0XDD,0XE9,0XCD,0XAA,0X6A,0XA1,

48660X52,0X01,0X8C,0X2B,0XE6,0XF9,0XFF,0XDE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

48670XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48750XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XBD,0XFF,0XDC,0XFF,0X57,

48760XEE,0XD0,0XDE,0X4B,0XD5,0XE7,0XDD,0XE6,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X27,

48770XEE,0X27,0XEE,0X27,0XE6,0X07,0XEE,0X48,0XE6,0X07,0XEE,0X48,0XEE,0X48,0XF6,0X48,

48780XF6,0X68,0XE5,0XE7,0XE5,0XE6,0XE5,0XE6,0XE6,0X07,0XEE,0X27,0XEE,0X47,0XEE,0X47,

48790XEE,0X47,0XEE,0X28,0XF6,0X28,0XF6,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,

48800XEE,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X28,

48810XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

48820XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

48830XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XF6,0X27,0XF6,0X07,0XF6,0X28,

48840XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X6A,0XCD,0XA9,0XA4,0X66,0X62,0X61,0X49,0XE2,

48850X9C,0XAF,0XF7,0X7C,0XFF,0XFE,0XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,

48860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,

48940XFF,0XFD,0XFF,0XFC,0XFF,0XFD,0XFF,0XDB,0XF7,0X36,0XE6,0X91,0XDE,0X0A,0XDE,0X07,

48950XDE,0X06,0XE6,0X06,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,

48960XE6,0X07,0XEE,0X27,0XF6,0X69,0XEE,0X07,0XEE,0X48,0XF6,0X89,0XEE,0X07,0XE6,0X07,

48970XF6,0X68,0XEE,0X47,0XE5,0XE6,0XE6,0X06,0XEE,0X27,0XF6,0X47,0XEE,0X27,0XF6,0X48,

48980XF6,0X48,0XEE,0X27,0XF6,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X28,

48990XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X28,

49000XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

49010XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

49020XEE,0X27,0XEE,0X27,0XEE,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X29,0XEE,0X28,

49030XEE,0X28,0XEE,0X48,0XD5,0XC8,0XD5,0XEA,0X7B,0X22,0X52,0X01,0X52,0X44,0XAD,0X11,

49040XF7,0XBC,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,

49050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,

49130XFF,0XFB,0XEE,0XD4,0XE6,0X6F,0XD5,0XEA,0XD5,0XE8,0XDE,0X06,0XE6,0X06,0XE6,0X06,

49140XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

49150XEE,0X48,0XE6,0X07,0XFE,0X89,0XF6,0X68,0XDD,0XA5,0XFE,0X89,0XFE,0XA9,0XFE,0XA9,

49160XF6,0X68,0XEE,0X06,0XE6,0X06,0XEE,0X07,0XF6,0X68,0XEE,0X47,0XF6,0X27,0XF6,0X48,

49170XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

49180XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

49190XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

49200XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XEE,0X47,0XEE,0X47,

49210XEE,0X47,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XF6,0X48,0XF6,0X48,0XEE,0X48,

49220XE6,0X28,0XDD,0XE9,0XA4,0X45,0X6A,0XA2,0X49,0XC1,0X52,0X66,0XC6,0X15,0XFF,0XFD,

49230XFF,0XFE,0XFF,0XFE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49310XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XDA,0XEE,0XF4,0XD6,0X0D,

49320XD5,0XEA,0XDD,0XC8,0XDE,0X07,0XE6,0X07,0XE6,0X07,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,

49330XEE,0X08,0XE6,0X07,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XE5,0XC6,0XEE,0X47,

49340XFE,0X88,0XE6,0X06,0XE5,0XE6,0XFE,0XC9,0XFE,0XA9,0XFE,0XC9,0XFE,0XC9,0XF6,0X68,

49350XEE,0X27,0XE5,0XE6,0XEE,0X27,0XEE,0X27,0XF6,0X27,0XF6,0X48,0XF6,0X27,0XF6,0X27,

49360XF6,0X27,0XF6,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

49370XF6,0X27,0XF6,0X27,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

49380XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

49390XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

49400XEE,0X48,0XEE,0X48,0XEE,0X28,0XF6,0X48,0XEE,0X27,0XEE,0X27,0XF6,0X89,0XD5,0XA7,

49410XCD,0X48,0X7B,0X02,0X5A,0X22,0X41,0XC2,0X73,0X49,0XE6,0XF8,0XFF,0XFD,0XFF,0XDE,

49420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49500XFF,0XFE,0XFF,0XBC,0XFF,0XFB,0XEE,0XD4,0XD5,0XED,0XD5,0XC9,0XDD,0XE8,0XDE,0X07,

49510XDD,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

49520XE6,0X07,0XEE,0X48,0XEE,0X27,0XE6,0X07,0XEE,0X27,0XFE,0XA9,0XE6,0X06,0XE5,0XC5,

49530XFE,0X88,0XF6,0X47,0XFE,0XA9,0XFE,0X88,0XFE,0X88,0XFE,0XC9,0XF6,0X68,0XEE,0X27,

49540XDD,0X85,0XEE,0X47,0XF6,0X27,0XEE,0X07,0XF6,0X27,0XFE,0X68,0XEE,0X27,0XEE,0X27,

49550XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X27,

49560XF6,0X48,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X27,0XF6,0X27,0XF6,0X27,

49570XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

49580XF6,0X27,0XF6,0X27,0XF6,0X47,0XEE,0X46,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

49590XF6,0X48,0XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X47,0XE6,0X28,0XDD,0XC9,0X93,0XC4,

49600X51,0XE0,0X5A,0X43,0X31,0X40,0XAD,0X31,0XFF,0XBC,0XFF,0XFE,0XFF,0XFF,0XEF,0X7D,

49610XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFD,0XFF,0XBA,

49690XEE,0XD4,0XCD,0XED,0XCD,0XA9,0XD5,0XC8,0XDE,0X07,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

49700XE5,0XE7,0XE5,0XE8,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,

49710XEE,0X07,0XE5,0XE6,0XF6,0X68,0XFE,0XC9,0XDD,0XC5,0XEE,0X26,0XFE,0X88,0XF6,0X47,

49720XFE,0XA8,0XFE,0X88,0XFE,0X88,0XFE,0XA9,0XFE,0XA9,0XFE,0X88,0XFE,0X88,0XD5,0X64,

49730XE5,0XC6,0XF6,0X27,0XFE,0X69,0XED,0XE6,0XF6,0X48,0XF6,0X27,0XEE,0X47,0XEE,0X47,

49740XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

49750XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

49760XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X27,

49770XEE,0X47,0XEE,0X46,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X28,

49780XFE,0X68,0XF6,0X47,0XEE,0X27,0XEE,0X48,0XE6,0X08,0XB4,0X86,0X7B,0X03,0X41,0XA0,

49790X49,0XE2,0X5A,0X86,0XD6,0X56,0XFF,0XDD,0XFF,0XBE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

49800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49870XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBE,0XFF,0X9B,0XF7,0X16,0XC5,0X8C,0XD5,0XCA,

49880XD5,0XA7,0XDE,0X07,0XDD,0XC7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

49890XE5,0XE7,0XE5,0XE8,0XE5,0XE8,0XEE,0X08,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X27,

49900XF6,0X68,0XF6,0X68,0XE5,0XE5,0XF6,0X67,0XF6,0X47,0XFE,0X88,0XFE,0X67,0XFE,0X88,

49910XFE,0X88,0XFE,0X68,0XFE,0XA9,0XFE,0X89,0XFE,0X89,0XFE,0X88,0XDD,0X85,0XE5,0XE6,

49920XEE,0X06,0XFE,0X88,0XED,0XE6,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

49930XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

49940XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

49950XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X47,0XEE,0X47,

49960XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X48,0XF6,0X28,0XF6,0X27,0XF6,0X47,

49970XF6,0X88,0XEE,0X47,0XEE,0X29,0XBD,0X07,0X83,0X44,0X51,0XE0,0X52,0X02,0X52,0X04,

49980X8C,0X0D,0XF7,0X7C,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50060XFF,0XDE,0XFF,0XBC,0XF7,0X38,0XCD,0XAF,0XD5,0XCB,0XCD,0X67,0XE6,0X08,0XE5,0XE7,

50070XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE6,0XE6,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X08,

50080XEE,0X08,0XED,0XE7,0XEE,0X07,0XEE,0X28,0XEE,0X27,0XF6,0X68,0XF6,0X68,0XEE,0X47,

50090XE5,0XC5,0XF6,0X67,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XFE,0X88,

50100XFE,0X88,0XF6,0X68,0XFE,0X89,0XF6,0X68,0XF6,0X48,0XDD,0XA6,0XE5,0XC7,0XE6,0X08,

50110XF6,0X69,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X28,0XEE,0X47,0XEE,0X47,

50120XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

50130XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

50140XF6,0X27,0XF6,0X27,0XF6,0X28,0XEE,0X28,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,

50150XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X28,0XF6,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X88,

50160XEE,0X48,0XD5,0X88,0X93,0XA5,0X5A,0X01,0X5A,0X22,0X41,0XC2,0X5A,0X66,0XCE,0X16,

50170XFF,0XDE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBC,0XFF,0X9A,

50250XD6,0X10,0XC5,0X4B,0XDE,0X0A,0XD5,0XC7,0XDD,0XE8,0XE5,0XE7,0XE5,0XC7,0XE5,0XC7,

50260XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

50270XEE,0X07,0XEE,0X27,0XEE,0X27,0XF6,0X68,0XF6,0XA8,0XDD,0XA4,0XEE,0X26,0XEE,0X26,

50280XF6,0X46,0XF6,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X68,

50290XF6,0X69,0XF6,0X69,0XEE,0X4A,0XF6,0X6C,0XDD,0XCA,0XDD,0XEA,0XDE,0X29,0XEE,0X89,

50300XEE,0X27,0XF6,0X47,0XF6,0X08,0XF6,0X49,0XEE,0X28,0XEE,0X27,0XF6,0X67,0XEE,0X46,

50310XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,

50320XEE,0X27,0XEE,0X47,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

50330XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

50340XF6,0X48,0XF6,0X47,0XF6,0X48,0XEE,0X47,0XF6,0X47,0XF6,0X68,0XEE,0X48,0XDD,0XE9,

50350XA4,0X06,0X62,0X42,0X49,0XC1,0X49,0XE3,0X49,0XE4,0X8C,0X2E,0XE7,0X1A,0XFF,0XFF,

50360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBB,0XE6,0X93,0XC5,0X4B,0XD5,0XCA,

50440XD5,0X87,0XE6,0X28,0XD5,0X87,0XE5,0XE8,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

50450XE5,0XE8,0XE5,0XE8,0XE6,0X07,0XE6,0X06,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X27,

50460XEE,0X27,0XF6,0X67,0XFE,0XA8,0XD5,0X63,0XEE,0X46,0XEE,0X26,0XEE,0X26,0XF6,0X27,

50470XF6,0X07,0XF6,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X48,0XF6,0X6A,

50480XEE,0X4B,0XEE,0X6D,0XFF,0X12,0XDE,0X6F,0XD5,0XEB,0XDE,0X29,0XEE,0X48,0XEE,0X07,

50490XF6,0X28,0XED,0XE8,0XF6,0X28,0XF6,0X68,0XEE,0X66,0XF6,0X66,0XF6,0X47,0XF6,0X47,

50500XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

50510XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

50520XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

50530XF6,0X68,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XEE,0X29,0XB4,0XA8,0X6A,0X82,

50540X49,0XA1,0X52,0X03,0X41,0XA3,0X62,0XC8,0XD6,0X98,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

50550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50620XFF,0XDE,0XFF,0XDC,0XFF,0X99,0XBD,0X4D,0XC5,0X69,0XDD,0XE9,0XD5,0X87,0XDD,0XA7,

50630XE6,0X08,0XDD,0XA7,0XE5,0XE8,0XDD,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE8,0XE6,0X08,

50640XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XFE,0XA9,

50650XEE,0X46,0XDD,0XA4,0XEE,0X26,0XEE,0X06,0XED,0XE6,0XED,0XE7,0XED,0XE7,0XED,0XE7,

50660XED,0XE7,0XE5,0XE7,0XE5,0XE7,0XEE,0X08,0XE6,0X07,0XEE,0X4A,0XDD,0XCA,0XFE,0XF1,

50670XFF,0XD7,0XFF,0X96,0XD6,0X2E,0XD6,0X0B,0XE6,0X28,0XF6,0X48,0XF6,0X28,0XF6,0X08,

50680XF6,0X49,0XEE,0X48,0XE6,0X46,0XEE,0X87,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

50690XF6,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

50700XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

50710XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X68,0XF6,0X48,

50720XF6,0X88,0XF6,0X68,0XF6,0X68,0XEE,0X6A,0XC5,0X09,0X7B,0X04,0X51,0XC1,0X51,0XE3,

50730X49,0XE3,0X41,0XC4,0XAD,0X11,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,

50810XC5,0XD0,0XBD,0X6B,0XD5,0XA8,0XDD,0XE8,0XE5,0XE7,0XDD,0XA6,0XE5,0XE8,0XDD,0XA8,

50820XE5,0XC8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X08,0XE6,0X08,0XE6,0X07,0XE6,0X07,

50830XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XFE,0XEA,0XDD,0XC5,0XE5,0XE5,

50840XE5,0XE5,0XEE,0X06,0XE5,0XA5,0XE5,0XC6,0XE5,0XC7,0XE5,0XA7,0XDD,0XA7,0XDD,0XA7,

50850XDD,0XA7,0XE5,0XC7,0XE5,0XC7,0XDD,0XA8,0XDE,0X2C,0XEE,0XF2,0XFF,0XB8,0XFF,0XDA,

50860XF7,0X76,0XCE,0X0E,0XE6,0X4B,0XE6,0X08,0XF6,0X29,0XF6,0X08,0XF6,0X28,0XF6,0X48,

50870XEE,0X87,0XEE,0X67,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

50880XF6,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,

50890XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

50900XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X48,0XF6,0X88,0XF6,0X47,

50910XEE,0X47,0XEE,0X6A,0XC5,0X29,0X83,0X44,0X51,0XE1,0X49,0XC2,0X52,0X24,0X39,0XC3,

50920X73,0X4A,0XEF,0X3B,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50990XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDD,0XFF,0XDD,0XFF,0X79,0XAC,0XCB,0XCD,0XAA,

51000XDD,0XE7,0XDD,0XE6,0XDD,0XE6,0XE5,0XE7,0XDD,0XA7,0XE5,0XE9,0XE5,0XC7,0XE5,0XE7,

51010XE5,0XE7,0XE6,0X07,0XE5,0XE7,0XE6,0X08,0XE6,0X08,0XE6,0X07,0XE6,0X07,0XEE,0X07,

51020XEE,0X27,0XE6,0X06,0XEE,0X47,0XFE,0XC9,0XDD,0XA4,0XE5,0XC5,0XE5,0XC5,0XE5,0XE6,

51030XDD,0X85,0XDD,0X86,0XDD,0X87,0XD5,0X67,0XD5,0X67,0XD5,0X67,0XD5,0X67,0XDD,0X87,

51040XDD,0X67,0XD5,0X88,0XD5,0XED,0XFF,0X96,0XFF,0XFC,0XFF,0XFD,0XFF,0XBB,0XFF,0XF9,

51050XC5,0X8B,0XE6,0X2B,0XF6,0X2A,0XF6,0X28,0XFE,0X89,0XE5,0XE6,0XEE,0X88,0XE6,0X47,

51060XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X27,

51070XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

51080XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

51090XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X47,0XF6,0X88,0XF6,0X47,0XF6,0X47,0XF6,0X69,

51100XD5,0XAA,0X8B,0X64,0X5A,0X01,0X51,0XE2,0X49,0XE3,0X41,0XE3,0X52,0X45,0XD6,0X77,

51110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

51180XFF,0XFE,0XFF,0XDD,0XFF,0X9A,0XC5,0XB0,0XBD,0X6B,0XCD,0XA9,0XDE,0X06,0XDD,0XC4,

51190XDD,0XC5,0XE5,0XC6,0XE5,0XE8,0XE5,0XC8,0XE5,0XE8,0XDD,0XC7,0XE5,0XE7,0XE6,0X07,

51200XE5,0XE7,0XE6,0X08,0XE6,0X08,0XE6,0X08,0XE6,0X08,0XEE,0X07,0XE6,0X07,0XEE,0X27,

51210XF6,0X68,0XFE,0X88,0XDD,0XA4,0XDD,0X84,0XE5,0XA5,0XDD,0X85,0XD5,0X45,0XD5,0X67,

51220XD5,0X67,0XCD,0X47,0XCD,0X47,0XD5,0X47,0XD5,0X47,0XD5,0X47,0XD5,0X47,0XCD,0X49,

51230XDE,0X70,0XFF,0XD8,0XF7,0XDC,0XFF,0XFE,0XFF,0XFE,0XFF,0XDB,0XF7,0X35,0XCD,0XCC,

51240XDD,0XC9,0XEE,0X49,0XE6,0X07,0XF6,0X68,0XEE,0X68,0XEE,0X47,0XEE,0X47,0XF6,0X47,

51250XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X27,0XEE,0X47,0XEE,0X47,

51260XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

51270XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X48,

51280XF6,0X68,0XF6,0X47,0XF6,0X88,0XF6,0X67,0XF6,0X68,0XF6,0X69,0XE6,0X0A,0X93,0XA4,

51290X5A,0X01,0X52,0X03,0X49,0XE2,0X41,0XE2,0X41,0XE3,0XAD,0X11,0XFF,0XBE,0XFF,0XFF,

51300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XDC,

51370XF7,0X38,0XA4,0X8A,0XCD,0XAB,0XDE,0X09,0XDD,0XC5,0XE5,0XE5,0XE5,0XE5,0XEE,0X07,

51380XE5,0XA7,0XE5,0XC8,0XE5,0XC8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

51390XE6,0X07,0XE6,0X08,0XEE,0X08,0XEE,0X07,0XE6,0X07,0XEE,0X48,0XF6,0X88,0XF6,0X68,

51400XDD,0X84,0XDD,0X64,0XDD,0X65,0XD5,0X65,0XCD,0X26,0XCD,0X47,0XCD,0X47,0XCD,0X27,

51410XCD,0X47,0XCD,0X47,0XCD,0X26,0XCD,0X27,0XCD,0X28,0XC5,0X29,0XE6,0XB2,0XFF,0XFA,

51420XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XDA,0XE6,0XB2,0XD5,0XCC,0XEE,0X6C,

51430XE6,0X08,0XF6,0X68,0XEE,0X27,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

51440XF6,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,

51450XEE,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

51460XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X47,0XF6,0X68,0XF6,0X68,

51470XF6,0X68,0XF6,0X67,0XF6,0X88,0XF6,0X89,0XE6,0X2A,0XA4,0X46,0X62,0X21,0X52,0X02,

51480X52,0X02,0X4A,0X02,0X41,0XC2,0X7B,0XAB,0XF7,0X7D,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

51490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XFF,0XDB,0XCD,0XD1,0XBD,0X4B,

51560XD5,0XEA,0XD5,0XC7,0XE5,0XE6,0XE5,0XC5,0XE5,0XE6,0XE5,0XC6,0XE5,0XC7,0XE5,0XC8,

51570XE5,0XC8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

51580XEE,0X08,0XEE,0X07,0XE6,0X07,0XEE,0X48,0XFE,0XCA,0XEE,0X27,0XD5,0X64,0XD5,0X65,

51590XCD,0X24,0XCD,0X25,0XCD,0X26,0XCD,0X47,0XCD,0X47,0XC5,0X27,0XCD,0X27,0XCD,0X47,

51600XCD,0X26,0XCD,0X27,0XC5,0X08,0XBD,0X2B,0XF7,0X35,0XFF,0XFC,0XFF,0XDE,0XFF,0XBF,

51610XFF,0XFF,0XFF,0XFE,0XF7,0XBB,0XFF,0XB9,0XDE,0X91,0XCD,0XCB,0XE6,0X4A,0XEE,0X49,

51620XEE,0X07,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

51630XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X28,0XF6,0X48,

51640XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

51650XF6,0X47,0XF6,0X48,0XF6,0X68,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X67,

51660XF6,0X88,0XF6,0X89,0XF6,0X8B,0XB4,0XA6,0X6A,0X62,0X49,0XC1,0X52,0X22,0X52,0X22,

51670X41,0XE2,0X5A,0XA7,0XF7,0X5C,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51740XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XFF,0X78,0XAC,0XEB,0XD5,0XCC,0XD5,0XC9,0XD5,0XA6,

51750XE5,0XC6,0XE5,0XC7,0XE5,0XE7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE8,

51760XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XE6,0X07,0XE5,0XE7,0XE6,0X07,

51770XEE,0X07,0XEE,0X48,0XFE,0XAA,0XE5,0XE7,0XCD,0X24,0XD5,0X45,0XCD,0X25,0XCD,0X26,

51780XCD,0X26,0XCD,0X47,0XC5,0X27,0XC5,0X27,0XC5,0X27,0XCD,0X47,0XC5,0X06,0XC5,0X07,

51790XBD,0X08,0XC5,0X6C,0XFF,0XB9,0XFF,0XFD,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

51800XFF,0XDD,0XFF,0XFC,0XF7,0X77,0XCD,0XEF,0XDD,0XEB,0XEE,0X4A,0XF6,0X48,0XF6,0X47,

51810XF6,0X47,0XEE,0X27,0XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

51820XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

51830XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

51840XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X87,0XF6,0X89,

51850XF6,0X8A,0XC5,0X48,0X6A,0X61,0X51,0XE1,0X52,0X22,0X52,0X22,0X4A,0X02,0X4A,0X04,

51860XD6,0X58,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XFF,0XFE,

51930XFF,0XBB,0XDE,0X73,0XBD,0X0A,0XD5,0XCA,0XD5,0XA8,0XDD,0XA7,0XE5,0XC7,0XE5,0XC8,

51940XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE7,

51950XE5,0XE6,0XE6,0X06,0XE6,0X07,0XE6,0X07,0XE5,0XE7,0XEE,0X07,0XEE,0X27,0XF6,0X68,

51960XFE,0X89,0XDD,0X86,0XCC,0XE4,0XCD,0X05,0XCD,0X05,0XC5,0X06,0XC5,0X06,0XC5,0X07,

51970XBD,0X07,0XBD,0X07,0XBD,0X07,0XC5,0X27,0XC4,0XE6,0XBD,0X07,0XB4,0XE8,0XCD,0XCE,

51980XFF,0XBA,0XFF,0XDE,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XFF,0XDD,

51990XFF,0XDB,0XEF,0X15,0XD5,0XED,0XDD,0XCA,0XF6,0X6A,0XF6,0X48,0XF6,0X48,0XF6,0X47,

52000XF6,0X47,0XF6,0X26,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

52010XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

52020XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X68,

52030XF6,0X67,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X88,0XFE,0XCB,0XCD,0X48,

52040X6A,0X61,0X5A,0X01,0X52,0X01,0X52,0X22,0X4A,0X02,0X39,0XA2,0XB5,0X74,0XFF,0XDE,

52050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

52060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XFF,0XFE,0XFF,0XBA,0XBD,0X4D,

52120XCD,0XAB,0XD5,0X88,0XE5,0XE8,0XDD,0XA7,0XE5,0XC8,0XE5,0XC8,0XE5,0XC8,0XE5,0XC7,

52130XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE7,0XE6,0X07,0XE6,0X06,

52140XE6,0X06,0XE6,0X06,0XE6,0X07,0XEE,0X07,0XEE,0X48,0XF6,0X68,0XF6,0X48,0XCD,0X25,

52150XC4,0XC4,0XC4,0XE5,0XBC,0XC5,0XBC,0XC6,0XBC,0XE6,0XBC,0XE7,0XBC,0XE7,0XBD,0X07,

52160XBD,0X07,0XBD,0X07,0XBC,0XE6,0XBC,0XE7,0XAC,0XC8,0XDE,0X51,0XFF,0XBB,0XFF,0XDE,

52170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XFC,0XFF,0XD9,

52180XE6,0X71,0XCD,0X8B,0XEE,0X4B,0XEE,0X29,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XEE,0X26,

52190XF6,0X68,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

52200XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

52210XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X68,

52220XF6,0X87,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XFE,0XAA,0XD5,0XA9,0X72,0XA1,0X5A,0X21,

52230X52,0X21,0X52,0X42,0X52,0X43,0X41,0XC2,0X9C,0X6F,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XEE,0XF6,0XC5,0X8D,0XC5,0X49,0XDD,0XE9,

52310XDD,0XC7,0XE5,0XC7,0XE5,0XC8,0XE5,0XC8,0XE5,0XA8,0XE5,0XC8,0XE5,0XE7,0XE5,0XE7,

52320XE5,0XE7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE6,0X06,0XE6,0X06,0XE6,0X06,

52330XE6,0X07,0XEE,0X07,0XEE,0X48,0XF6,0X68,0XEE,0X08,0XBC,0XC4,0XBC,0XA4,0XBC,0XA5,

52340XB4,0X85,0XB4,0XA6,0XB4,0XA6,0XB4,0XA6,0XB4,0XC6,0XB4,0XC6,0XB4,0XC6,0XB4,0XC6,

52350XB4,0XA6,0XB4,0XC7,0XAC,0X88,0XEE,0XD4,0XFF,0XBC,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

52360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDD,0XFF,0XFB,0XFF,0X76,0XD6,0X0E,

52370XDD,0XEB,0XE6,0X0A,0XEE,0X49,0XEE,0X47,0XF6,0X47,0XEE,0X26,0XFE,0X68,0XF6,0X27,

52380XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

52390XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

52400XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

52410XF6,0X67,0XF6,0X68,0XF6,0X69,0XE6,0X2B,0X7B,0X02,0X62,0X41,0X5A,0X62,0X5A,0X62,

52420X52,0X42,0X52,0X44,0X6B,0X2A,0XFF,0XBD,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

52430XFF,0XDF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52490XFF,0XFF,0XFF,0XDC,0XE6,0XB4,0XC5,0X6B,0XCD,0X89,0XDD,0XC8,0XDD,0XC7,0XE5,0XC7,

52500XE5,0XC8,0XE5,0XC8,0XE5,0XC8,0XE5,0XC8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

52510XE5,0XE8,0XE5,0XE8,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

52520XEE,0X47,0XF6,0X68,0XDD,0XA7,0XB4,0X83,0XB4,0X84,0XAC,0X65,0XAC,0X65,0XAC,0X46,

52530XAC,0X66,0XAC,0X66,0XAC,0X66,0XAC,0X85,0XAC,0X86,0XAC,0X66,0XA4,0X66,0XA4,0X67,

52540XA4,0X69,0XF7,0X57,0XFF,0XDC,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52550XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFB,0XFF,0XF9,0XEE,0XD3,0XCD,0X8C,0XE6,0X0C,

52560XF6,0X6A,0XEE,0X27,0XF6,0X67,0XF6,0X47,0XF6,0X68,0XEE,0X27,0XF6,0X48,0XF6,0X48,

52570XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

52580XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

52590XF6,0X68,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,

52600XEE,0X49,0XF6,0X6B,0X8B,0X62,0X62,0X60,0X62,0X82,0X5A,0X83,0X52,0X42,0X52,0X44,

52610X5A,0XA7,0XFF,0XBC,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

52620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,

52680XDE,0X72,0XBD,0X4A,0XD5,0XA9,0XDD,0XC8,0XDD,0XC7,0XDD,0XC7,0XDD,0XC7,0XE5,0XC7,

52690XE5,0XC8,0XE5,0XC8,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE8,

52700XE5,0XE7,0XE6,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X07,0XE6,0X06,0XEE,0X47,0XEE,0X47,

52710XCD,0X65,0XAC,0X42,0XAC,0X64,0XAC,0X25,0XA4,0X25,0XA4,0X25,0XA4,0X25,0XA4,0X25,

52720XA4,0X45,0XA4,0X45,0XA4,0X46,0XA4,0X45,0X9C,0X26,0X9C,0X27,0X9C,0X6B,0XFF,0X9A,

52730XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

52740XFF,0XDD,0XFF,0XFC,0XFF,0XFB,0XFF,0X98,0XD5,0XCF,0XD5,0XAC,0XF6,0X6A,0XEE,0X27,

52750XF6,0X67,0XF6,0X47,0XF6,0X47,0XEE,0X27,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

52760XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

52770XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

52780XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X69,0XEE,0X6B,

52790X93,0XC3,0X6A,0X81,0X62,0X82,0X62,0XA3,0X5A,0X83,0X52,0X43,0X5A,0X86,0XF7,0X7B,

52800XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

52810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBB,0XCD,0XF0,0XBD,0X6A,

52870XD5,0XC9,0XDD,0XC8,0XDD,0XC7,0XDD,0XC7,0XDD,0XC6,0XDD,0XC7,0XE5,0XC8,0XE5,0XC8,

52880XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,

52890XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X06,0XF6,0X47,0XEE,0X27,0XC5,0X04,0XA4,0X22,

52900XA4,0X24,0XA4,0X25,0XA4,0X05,0XA4,0X05,0XA4,0X05,0XA4,0X05,0XA4,0X25,0XA4,0X05,

52910XA4,0X26,0X9C,0X05,0X9C,0X06,0X93,0XE7,0XA4,0XAD,0XFF,0XFB,0XFF,0XDE,0XFF,0XFF,

52920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XFD,

52930XFF,0XDC,0XFF,0XFB,0XEE,0XB3,0XD5,0X8B,0XE6,0X2A,0XEE,0X27,0XF6,0X67,0XF6,0X46,

52940XEE,0X47,0XEE,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

52950XF6,0X28,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

52960XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X67,

52970XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X89,0XEE,0X6A,0XA4,0X24,0X72,0XE2,

52980X6A,0XA2,0X6A,0XC4,0X6A,0XC4,0X5A,0X64,0X5A,0X65,0XE7,0X19,0XFF,0XFE,0XFF,0XFF,

52990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53050XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XF7,0X79,0XC5,0X8D,0XCD,0X8A,0XD5,0XA8,0XDD,0XA7,

53060XE5,0XC7,0XDD,0XC6,0XDD,0XE6,0XDD,0XE6,0XE5,0XC7,0XE5,0XC8,0XE5,0XC7,0XE5,0XE7,

53070XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X08,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

53080XE6,0X06,0XEE,0X06,0XF6,0X47,0XE6,0X07,0XBC,0XC3,0XA4,0X02,0X9C,0X04,0X9B,0XE5,

53090X9B,0XE5,0X9B,0XE5,0X9B,0XE5,0X9B,0XE5,0X9C,0X05,0X9B,0XE4,0X9C,0X05,0X93,0XE5,

53100X93,0XC5,0X8B,0XA6,0XAD,0X0E,0XFF,0XFD,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

53110XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDD,0XFF,0XFC,

53120XFF,0X98,0XCD,0XAE,0XDD,0XCA,0XEE,0X48,0XF6,0X67,0XEE,0X47,0XF6,0X47,0XF6,0X68,

53130XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X46,0XF6,0X47,0XF6,0X47,0XF6,0X28,0XF6,0X48,

53140XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,

53150XF6,0X68,0XF6,0X68,0XF6,0X47,0XF6,0X68,0XF6,0X67,0XF6,0X68,0XF6,0X67,0XF6,0X67,

53160XF6,0X67,0XF6,0X68,0XF6,0X69,0XF6,0X6A,0XAC,0X85,0X7B,0X22,0X72,0XE3,0X6A,0XE4,

53170X72,0XE4,0X62,0XA4,0X62,0XA5,0XDE,0XB8,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53180XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53240XFF,0XFD,0XEF,0X38,0XC5,0X8D,0XCD,0XAA,0XD5,0X88,0XE5,0XC7,0XE5,0XC6,0XDD,0XC6,

53250XE5,0XE6,0XE5,0XE6,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

53260XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE5,0XE7,0XE6,0X06,0XEE,0X07,0XEE,0X07,0XED,0XE7,

53270XF6,0X48,0XE5,0XE7,0XAC,0X42,0X9B,0XE2,0X9B,0XE4,0X93,0XC4,0X93,0XC5,0X93,0XC5,

53280X93,0XC5,0X93,0XC5,0X9B,0XE5,0X8B,0XA4,0X93,0XE5,0X8B,0XC5,0X8B,0XA6,0X83,0X66,

53290XBD,0X50,0XFF,0XFC,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

53300XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XBD,0XFF,0XDC,0XEE,0XB4,

53310XCD,0X6B,0XEE,0X2A,0XEE,0X48,0XEE,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,

53320XF6,0X66,0XF6,0X66,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

53330XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

53340XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X88,

53350XFE,0X68,0XF6,0X6A,0XBC,0XE7,0X83,0X63,0X73,0X03,0X72,0XE3,0X73,0X04,0X6A,0XC4,

53360X62,0XA5,0XDE,0X76,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,

53370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XEF,0X17,

53430XC5,0X6C,0XD5,0XAA,0XDD,0XA8,0XE5,0XE7,0XE5,0XE6,0XDD,0XE5,0XE5,0XE6,0XE5,0XE6,

53440XE5,0XC7,0XE5,0XE7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,

53450XE6,0X07,0XE6,0X06,0XE6,0X06,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XF6,0X48,0XDD,0XA6,

53460XAC,0X22,0X93,0XC2,0X93,0XA4,0X93,0XA4,0X93,0XA5,0X93,0XA5,0X93,0XA6,0X93,0XC5,

53470X93,0XC5,0X8B,0XA4,0X8B,0XC5,0X8B,0XA5,0X8B,0XA6,0X83,0X67,0XC5,0X91,0XFF,0XFD,

53480XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

53490XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XBE,0XFF,0XFE,0XFF,0X79,0XD5,0XCD,0XDD,0XEA,

53500XEE,0X49,0XEE,0X27,0XF6,0X48,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X66,0XF6,0X66,

53510XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

53520XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

53530XF6,0X67,0XF6,0X87,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X89,0XF6,0X8A,

53540XC5,0X07,0X8B,0XA3,0X7B,0X43,0X73,0X03,0X7B,0X24,0X72,0XE4,0X6A,0XA5,0XDE,0X96,

53550XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XE6,0XF7,0XBD,0X4C,0XD5,0XAA,

53620XDD,0XA8,0XE5,0XC7,0XE5,0XE6,0XDD,0XE6,0XDD,0XE6,0XE5,0XE6,0XE5,0XE7,0XE5,0XE7,

53630XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X06,

53640XE6,0X06,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XF6,0X49,0XD5,0X46,0XA3,0XE2,0X8B,0X82,

53650X8B,0X63,0X8B,0X84,0X8B,0X65,0X8B,0X65,0X8B,0X65,0X8B,0X65,0X8B,0X85,0X83,0X64,

53660X83,0X64,0X83,0X65,0X83,0X66,0X7B,0X26,0XCD,0XF3,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,

53670XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

53680XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XDB,0XE6,0X71,0XD5,0XAA,0XEE,0X49,0XEE,0X47,

53690XFE,0X68,0XF6,0X27,0XF6,0X48,0XF6,0X47,0XF6,0X66,0XF6,0X66,0XF6,0X47,0XF6,0X48,

53700XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,

53710XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

53720XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XF6,0X6A,0XCD,0X47,0X9B,0XE4,

53730X83,0X64,0X7B,0X44,0X7B,0X44,0X73,0X25,0X6A,0XC5,0XDE,0X96,0XFF,0XFE,0XFF,0XFF,

53740XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53800XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XE6,0XD6,0XBD,0X4B,0XD5,0XAA,0XDD,0XA8,0XE5,0XC7,

53810XE5,0XC6,0XE5,0XE6,0XE5,0XE6,0XE5,0XE6,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

53820XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X06,0XEE,0X06,0XEE,0X27,

53830XEE,0X08,0XEE,0X08,0XF6,0X4A,0XCD,0X06,0X9B,0XC2,0X83,0X42,0X83,0X43,0X83,0X44,

53840X83,0X45,0X83,0X25,0X83,0X45,0X83,0X45,0X83,0X44,0X83,0X64,0X7B,0X24,0X7B,0X45,

53850X7B,0X26,0X72,0XE6,0XD6,0X14,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53860XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53870XFF,0XFE,0XFF,0XDB,0XF6,0XF4,0XCD,0X8A,0XE6,0X29,0XF6,0X68,0XF6,0X68,0XF6,0X27,

53880XF6,0X48,0XF6,0X47,0XF6,0X46,0XF6,0X66,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,

53890XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

53900XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,

53910XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X69,0XD5,0X88,0XA4,0X45,0X8B,0XA5,0X8B,0X85,

53920X8B,0X85,0X7B,0X45,0X73,0X05,0XDE,0XB6,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53930XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

53990XFF,0XDD,0XE6,0XD5,0XC5,0X4B,0XDD,0XCA,0XDD,0XA8,0XE5,0XC7,0XE5,0XC6,0XE5,0XE6,

54000XE5,0XE6,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

54010XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X09,

54020XF6,0X4A,0XC4,0XE5,0X93,0X82,0X83,0X02,0X7B,0X03,0X7B,0X04,0X7B,0X04,0X7B,0X04,

54030X7B,0X05,0X7B,0X04,0X7B,0X24,0X7B,0X44,0X73,0X04,0X7B,0X25,0X73,0X05,0X6A,0XC6,

54040XD6,0X35,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,

54060XFF,0X56,0XCD,0XAC,0XDD,0XE9,0XEE,0X68,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

54070XF6,0X47,0XF6,0X46,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X67,

54080XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X68,

54090XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X87,

54100XFE,0X88,0XF6,0X89,0XDD,0XC9,0XAC,0X66,0X93,0XC5,0X93,0XC6,0X93,0XC6,0X8B,0X86,

54110X83,0X87,0XEF,0X17,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XE6,0XD5,

54180XC5,0X6B,0XDD,0XC9,0XE5,0XA7,0XE5,0XC6,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

54190XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,

54200XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X09,0XF6,0X2A,0XBC,0XC5,

54210X8B,0X41,0X7B,0X02,0X7B,0X03,0X72,0XE4,0X7B,0X04,0X7B,0X05,0X7A,0XE4,0X72,0XE4,

54220X73,0X04,0X73,0X24,0X72,0XE3,0X73,0X04,0X72,0XC5,0X6A,0XA6,0XD6,0X35,0XFF,0XFE,

54230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0X78,0XD5,0XEE,

54250XCD,0XA8,0XEE,0X68,0XEE,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

54260XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

54270XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XF6,0X68,

54280XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X66,0XFE,0X87,0XFE,0X87,0XFE,0X89,

54290XE6,0X09,0XAC,0X65,0X9B,0XE5,0X93,0XC6,0X9B,0XE6,0X8B,0XA6,0X8B,0XC8,0XF7,0X38,

54300XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XE6,0XD5,0XC5,0X6B,0XDD,0XE9,

54370XDD,0XA7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

54380XE5,0XE8,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

54390XE6,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X09,0XF6,0X2A,0XBC,0XC5,0X83,0X00,0X7A,0XE1,

54400X7B,0X03,0X72,0XE4,0X72,0XE4,0X73,0X04,0X7A,0XE4,0X73,0X04,0X73,0X04,0X73,0X03,

54410X6B,0X03,0X6A,0XE4,0X6A,0XC5,0X62,0XA6,0XCE,0X35,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

54420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBA,0XDE,0X71,0XCD,0X89,0XEE,0X69,

54440XEE,0X47,0XF6,0X67,0XFE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

54450XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

54460XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X67,

54470XF6,0X67,0XF6,0X66,0XFE,0X66,0XFE,0X86,0XFE,0X87,0XFE,0X89,0XEE,0X4A,0XAC,0X45,

54480XA4,0X05,0X9B,0XE6,0X9C,0X06,0X8B,0XC6,0X94,0X09,0XFF,0X99,0XFF,0XDD,0XFF,0XFF,

54490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54550XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XEE,0XF5,0XCD,0X8B,0XDD,0XC9,0XDD,0XA7,0XED,0XE7,

54560XE6,0X07,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

54570XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X07,

54580XEE,0X08,0XEE,0X29,0XEE,0X4A,0XBC,0XC5,0X7A,0XE0,0X7A,0XE1,0X72,0XE3,0X72,0XE3,

54590X72,0XC4,0X72,0XE4,0X72,0XE4,0X72,0XE4,0X6A,0XE3,0X6A,0XE3,0X6A,0XE3,0X6A,0XC3,

54600X62,0XA4,0X62,0X85,0XCE,0X15,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54610XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54620XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XE6,0XB3,0XC5,0X69,0XEE,0X69,0XF6,0X67,0XF6,0X67,

54630XF6,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

54640XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

54650XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XF6,0X67,0XFE,0X67,0XFE,0X87,0XF6,0X66,

54660XF6,0X66,0XFE,0X86,0XFE,0XA7,0XFE,0XA9,0XF6,0X6A,0XAC,0X64,0XAC,0X46,0XA4,0X26,

54670XA4,0X26,0X93,0XC6,0XA4,0X8B,0XFF,0XFA,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

54740XFF,0XDC,0XEE,0XF5,0XCD,0X8B,0XDD,0XC8,0XE5,0XA7,0XED,0XE7,0XE5,0XE7,0XE5,0XE7,

54750XE5,0XE6,0XE6,0X07,0XE5,0XE7,0XE5,0XE8,0XED,0XE7,0XEE,0X07,0XEE,0X07,0XE6,0X06,

54760XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X06,0XEE,0X28,0XEE,0X08,0XEE,0X29,

54770XF6,0X4A,0XBC,0XA5,0X7B,0X00,0X72,0XC1,0X72,0XC2,0X6A,0XC3,0X6A,0XC4,0X6A,0XC4,

54780X6A,0XA4,0X6A,0XC3,0X6A,0XC3,0X62,0XA3,0X62,0XA3,0X6A,0XC4,0X62,0XA4,0X5A,0X45,

54790XC5,0XD4,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54800XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54810XFF,0XFD,0XE6,0XD5,0XC5,0X69,0XDE,0X29,0XEE,0X47,0XF6,0X46,0XF6,0X47,0XFE,0X47,

54820XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

54830XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,

54840XF6,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X87,0XF6,0X67,0XF6,0X66,0XFE,0X87,

54850XFE,0X87,0XFE,0XCA,0XEE,0X09,0XB4,0X84,0XB4,0X87,0XAC,0X47,0XAC,0X67,0X9C,0X27,

54860XC5,0X8F,0XFF,0XDB,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

54870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XEE,0XF5,

54930XCD,0X8B,0XDD,0XA9,0XE5,0XA7,0XED,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X06,0XE6,0X07,

54940XE5,0XE7,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

54950XEE,0X27,0XEE,0X27,0XE6,0X07,0XEE,0X27,0XEE,0X08,0XEE,0X09,0XF6,0X4A,0XBC,0X85,

54960X7B,0X00,0X6A,0X80,0X6A,0XA2,0X62,0X83,0X6A,0XA3,0X6A,0XA4,0X62,0X84,0X62,0XA3,

54970X62,0XA3,0X62,0XA3,0X62,0XA3,0X62,0XA3,0X62,0X64,0X52,0X24,0XB5,0X73,0XFF,0XDE,

54980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

54990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XEE,0XF6,

55000XC5,0X8A,0XDE,0X09,0XEE,0X47,0XF6,0X46,0XF6,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X47,

55010XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X46,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,

55020XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XFE,0X68,

55030XFE,0X68,0XFE,0X67,0XFE,0X87,0XF6,0X67,0XF6,0X86,0XFE,0X87,0XFE,0XA8,0XFE,0XCA,

55040XE5,0XE8,0XBC,0XA5,0XBC,0XC7,0XB4,0X87,0XAC,0XA8,0XA4,0X89,0XD6,0X32,0XFF,0XFB,

55050XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XEF,0X16,0XD5,0XAC,0XDD,0XC9,

55120XE5,0XC8,0XED,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X06,0XE6,0X06,0XE6,0X07,0XE6,0X07,

55130XEE,0X07,0XED,0XE7,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

55140XE6,0X06,0XEE,0X48,0XEE,0X08,0XEE,0X09,0XF6,0X6B,0XBC,0XA5,0X83,0X01,0X6A,0X60,

55150X62,0X82,0X5A,0X42,0X62,0X63,0X62,0X64,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X83,

55160X5A,0X83,0X5A,0X63,0X52,0X43,0X4A,0X04,0XA4,0XF1,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

55170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XF7,0X37,0XC5,0X8B,0XDD,0XE9,

55190XF6,0X48,0XF6,0X47,0XF6,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

55200XF6,0X46,0XF6,0X66,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,

55210XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X67,

55220XFE,0X87,0XF6,0X67,0XF6,0X87,0XFE,0XA7,0XFE,0XC9,0XFE,0XCA,0XE5,0XC7,0XC4,0XE6,

55230XC4,0XE7,0XBC,0XE8,0XB4,0XC9,0XB4,0XEB,0XEE,0XF6,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,

55240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55300XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XF7,0X57,0XD5,0XED,0XDD,0XCA,0XE5,0XE8,0XED,0XE7,

55310XE5,0XE7,0XE6,0X07,0XE6,0X06,0XE6,0X06,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

55320XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X06,0XEE,0X47,

55330XEE,0X28,0XEE,0X29,0XF6,0X6B,0XBC,0XC6,0X83,0X01,0X62,0X60,0X5A,0X41,0X5A,0X42,

55340X5A,0X43,0X5A,0X43,0X5A,0X23,0X5A,0X23,0X5A,0X43,0X5A,0X63,0X52,0X42,0X52,0X43,

55350X52,0X03,0X49,0XE4,0X94,0X4E,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

55360XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55370XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0X78,0XCD,0XAC,0XDD,0XE9,0XF6,0X48,0XF6,0X67,

55380XFE,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X66,0XF6,0X66,

55390XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

55400XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XF6,0X67,

55410XF6,0X87,0XFE,0XA8,0XFE,0XA9,0XFE,0XAA,0XDD,0X67,0XCD,0X06,0XC5,0X27,0XC5,0X28,

55420XB4,0XC9,0XBD,0X6E,0XFF,0X79,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

55490XFF,0XFD,0XF7,0X78,0XDE,0X0E,0XDD,0XCA,0XED,0XE9,0XED,0XE7,0XE5,0XE7,0XE6,0X06,

55500XE6,0X26,0XE6,0X26,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

55510XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X26,0XEE,0X47,0XEE,0X27,0XEE,0X29,

55520XF6,0X6A,0XC5,0X07,0X7B,0X00,0X62,0X40,0X5A,0X21,0X5A,0X22,0X52,0X03,0X52,0X23,

55530X52,0X23,0X52,0X23,0X52,0X23,0X52,0X42,0X52,0X42,0X52,0X23,0X52,0X03,0X49,0XE4,

55540X7B,0XAC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

55550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55560XFF,0XFE,0XFF,0X99,0XCD,0XCD,0XD5,0XC9,0XF6,0X49,0XF6,0X47,0XFE,0X47,0XFE,0X47,

55570XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X66,0XF6,0X66,0XF6,0X67,0XF6,0X67,

55580XFE,0X47,0XFE,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,

55590XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X88,0XFE,0X87,0XF6,0X87,0XFE,0XA8,

55600XFE,0XAA,0XFE,0X8A,0XD5,0X46,0XCD,0X26,0XCD,0X47,0XC5,0X48,0XB4,0XE9,0XCE,0X11,

55610XFF,0XDB,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0X99,

55680XDE,0X70,0XDD,0XCA,0XED,0XE9,0XED,0XC7,0XEE,0X07,0XE6,0X06,0XEE,0X26,0XEE,0X26,

55690XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

55700XEE,0X27,0XEE,0X27,0XEE,0X26,0XEE,0X47,0XEE,0X27,0XEE,0X28,0XF6,0X4A,0XCD,0X68,

55710X83,0X01,0X62,0X40,0X5A,0X21,0X52,0X22,0X52,0X02,0X52,0X03,0X52,0X03,0X52,0X03,

55720X52,0X02,0X52,0X22,0X4A,0X22,0X4A,0X22,0X4A,0X03,0X49,0XE3,0X62,0XC8,0XFF,0XDD,

55730XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0X79,

55750XCD,0XAD,0XD5,0XC9,0XF6,0X69,0XF6,0X27,0XFE,0X47,0XFE,0X67,0XF6,0X67,0XF6,0X67,

55760XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,

55770XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

55780XFE,0X67,0XFE,0X67,0XFE,0X88,0XF6,0X87,0XFE,0X88,0XFE,0XC9,0XFE,0X8A,0XF6,0X4A,

55790XD5,0X46,0XD5,0X67,0XCD,0X67,0XC5,0X68,0XBD,0X2B,0XE6,0XB4,0XFF,0XDC,0XFF,0XFE,

55800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDA,0XEE,0XB1,0XDD,0XEB,

55870XE5,0XE9,0XE5,0XC7,0XEE,0X27,0XEE,0X26,0XEE,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X27,

55880XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

55890XEE,0X26,0XEE,0X47,0XEE,0X27,0XEE,0X28,0XF6,0X4A,0XDD,0XC9,0X83,0X41,0X62,0X40,

55900X5A,0X21,0X52,0X02,0X52,0X02,0X52,0X03,0X52,0X03,0X4A,0X03,0X4A,0X02,0X4A,0X02,

55910X4A,0X01,0X4A,0X02,0X4A,0X02,0X49,0XC3,0X4A,0X05,0XEF,0X1A,0XFF,0XBE,0XFF,0XFF,

55920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0X78,0XCD,0XAD,0XDD,0XCA,

55940XF6,0X49,0XF6,0X27,0XFE,0X47,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

55950XF6,0X66,0XF6,0X66,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X67,

55960XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

55970XFE,0X68,0XF6,0X87,0XFE,0X88,0XFE,0XC9,0XFE,0X8A,0XED,0XE8,0XD5,0X47,0XDD,0X88,

55980XD5,0X86,0XC5,0X68,0XCD,0XAD,0XF7,0X37,0XFF,0XDC,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56050XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XEE,0XF3,0XDD,0XEC,0XE5,0XE9,0XE5,0XC7,

56060XEE,0X27,0XEE,0X26,0XEE,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,

56070XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X26,0XF6,0X47,

56080XEE,0X47,0XF6,0X48,0XF6,0X69,0XE6,0X2A,0X8B,0X82,0X62,0X40,0X5A,0X21,0X51,0XE1,

56090X52,0X02,0X49,0XE3,0X52,0X03,0X52,0X03,0X52,0X22,0X4A,0X22,0X4A,0X01,0X4A,0X22,

56100X4A,0X02,0X49,0XC3,0X39,0X83,0XD6,0X57,0XF7,0X7D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56120XFF,0XFF,0XFF,0XFF,0XFF,0XBD,0XFF,0X58,0XCD,0XAD,0XDD,0XC9,0XF6,0X69,0XF6,0X07,

56130XFE,0X47,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X66,0XF6,0X66,

56140XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

56150XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,

56160XFE,0X88,0XFE,0XCA,0XFE,0X8A,0XE5,0XA8,0XDD,0X67,0XDD,0XC9,0XD5,0X87,0XC5,0X89,

56170XD6,0X30,0XFF,0X99,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56240XFF,0XFD,0XFF,0XFB,0XF7,0X55,0XDE,0X4E,0XDD,0XEA,0XE6,0X08,0XEE,0X27,0XEE,0X06,

56250XF6,0X06,0XF6,0X06,0XEE,0X07,0XEE,0X27,0XEE,0X26,0XEE,0X26,0XEE,0X26,0XF6,0X26,

56260XF6,0X27,0XF6,0X28,0XEE,0X28,0XEE,0X47,0XEE,0X47,0XEE,0X46,0XEE,0X46,0XEE,0X47,

56270XEE,0X48,0XEE,0X6A,0XAC,0X65,0X62,0X60,0X52,0X00,0X52,0X01,0X52,0X23,0X49,0XE2,

56280X4A,0X03,0X4A,0X03,0X4A,0X02,0X4A,0X01,0X4A,0X02,0X49,0XE1,0X49,0XC2,0X41,0XC2,

56290X41,0XA2,0XA4,0XB0,0XFF,0XFF,0XFF,0XDF,0XF7,0XBF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

56310XFF,0XDE,0XF7,0X17,0XCD,0X8B,0XE6,0X0A,0XEE,0X28,0XFE,0X47,0XFE,0X67,0XF6,0X46,

56320XF6,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X66,0XF6,0X66,0XF6,0X67,0XF6,0X67,

56330XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

56340XFE,0X87,0XFE,0X67,0XFE,0X87,0XFE,0X88,0XFE,0X67,0XFE,0X88,0XFE,0XA9,0XFE,0XAA,

56350XF6,0X2A,0XE5,0XC9,0XDD,0X88,0XDD,0XC9,0XD5,0XA8,0XCD,0XAB,0XEE,0XF4,0XFF,0XDB,

56360XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFC,

56430XFF,0X98,0XE6,0XB1,0XDE,0X0B,0XDD,0XE8,0XEE,0X47,0XEE,0X06,0XF6,0X06,0XF6,0X06,

56440XEE,0X27,0XEE,0X27,0XEE,0X46,0XEE,0X26,0XF6,0X26,0XF6,0X26,0XF6,0X27,0XF6,0X28,

56450XEE,0X28,0XEE,0X47,0XEE,0X47,0XEE,0X46,0XEE,0X46,0XEE,0X47,0XEE,0X48,0XF6,0X8A,

56460XBC,0XE6,0X72,0XC0,0X5A,0X20,0X51,0XE1,0X52,0X22,0X4A,0X03,0X4A,0X03,0X4A,0X02,

56470X4A,0X02,0X4A,0X01,0X4A,0X01,0X4A,0X02,0X49,0XE2,0X49,0XC2,0X41,0XA2,0X7B,0X4A,

56480XFF,0XBD,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDE,0XEE,0XF7,

56500XC5,0X6A,0XE6,0X09,0XF6,0X48,0XFE,0X47,0XFE,0X47,0XFE,0X46,0XF6,0X66,0XF6,0X66,

56510XF6,0X67,0XF6,0X67,0XF6,0X66,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XFE,0X68,0XFE,0X67,

56520XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

56530XFE,0X87,0XFE,0X87,0XFE,0X68,0XFE,0X88,0XFE,0XAA,0XFE,0X8A,0XF6,0X4A,0XE5,0XC9,

56540XE5,0XE9,0XDD,0XEA,0XD5,0XCA,0XDE,0X4F,0XFF,0X77,0XFF,0XFC,0XFF,0XFF,0XFF,0XFF,

56550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XDA,0XF7,0X14,

56620XDE,0X2C,0XE6,0X28,0XEE,0X47,0XEE,0X26,0XF6,0X26,0XF6,0X26,0XEE,0X27,0XEE,0X27,

56630XEE,0X46,0XEE,0X46,0XF6,0X26,0XF6,0X26,0XF6,0X27,0XF6,0X28,0XF6,0X28,0XEE,0X47,

56640XEE,0X47,0XEE,0X46,0XEE,0X46,0XEE,0X47,0XF6,0X48,0XF6,0X8A,0XD5,0XA8,0X8B,0X61,

56650X62,0X40,0X52,0X00,0X5A,0X42,0X52,0X22,0X52,0X23,0X4A,0X22,0X4A,0X22,0X4A,0X22,

56660X52,0X22,0X52,0X22,0X52,0X02,0X51,0XE2,0X49,0XE3,0X52,0X25,0XE6,0XF9,0XFF,0XDE,

56670XFF,0XFE,0XFF,0XFE,0XFF,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XBD,0XEE,0XD6,0XC5,0X49,0XE6,0X08,

56690XFE,0X68,0XFE,0X67,0XF6,0X26,0XFE,0X67,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X67,

56700XF6,0X66,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

56710XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X88,

56720XFE,0X88,0XFE,0XA9,0XFE,0XAA,0XFE,0X8A,0XF6,0X49,0XEE,0X29,0XE6,0X09,0XE6,0X2B,

56730XDE,0X0C,0XF6,0XF3,0XFF,0XFA,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56800XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XDE,0XFF,0XFC,0XFF,0X56,0XDE,0X4D,0XE6,0X49,

56810XEE,0X26,0XF6,0X46,0XF6,0X26,0XF6,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X46,0XEE,0X46,

56820XF6,0X26,0XF6,0X26,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,0XF6,0X67,0XF6,0X47,

56830XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X89,0XE6,0X09,0XA4,0X03,0X72,0XA0,0X5A,0X20,

56840X5A,0X62,0X52,0X42,0X5A,0X63,0X5A,0X63,0X52,0X42,0X52,0X42,0X52,0X42,0X5A,0X42,

56850X52,0X22,0X52,0X22,0X52,0X23,0X4A,0X04,0XB5,0X93,0XFF,0XFD,0XFF,0XDD,0XFF,0XDD,

56860XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56870XFF,0XFF,0XFF,0XFE,0XFF,0X7B,0XE6,0X94,0XC5,0X69,0XE6,0X28,0XFE,0X88,0XFE,0X47,

56880XFE,0X46,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X66,

56890XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

56900XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X88,0XFE,0XA9,0XFE,0XCA,

56910XFE,0XAA,0XF6,0X69,0XF6,0X68,0XEE,0X48,0XEE,0X29,0XE6,0X2B,0XE6,0X90,0XFF,0X97,

56920XFF,0XFC,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

56990XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0X99,0XEE,0XCF,0XE6,0X49,0XE6,0X26,0XF6,0X46,

57000XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,0XEE,0X46,0XF6,0X46,0XF6,0X46,0XF6,0X46,

57010XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

57020XF6,0X47,0XF6,0X89,0XF6,0X6A,0XBC,0XC5,0X83,0X41,0X62,0X60,0X62,0X61,0X62,0X82,

57030X62,0X83,0X5A,0X83,0X5A,0X83,0X5A,0X83,0X5A,0X63,0X62,0X62,0X62,0X42,0X5A,0X42,

57040X52,0X43,0X52,0X64,0X83,0XEC,0XFF,0XBC,0XFF,0XDC,0XFF,0XFE,0XFF,0XFE,0XFF,0XDF,

57050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

57060XFF,0X9A,0XD6,0X11,0XCD,0X69,0XEE,0X48,0XFE,0X88,0XFE,0X46,0XFE,0X67,0XFE,0X67,

57070XFE,0X67,0XFE,0X67,0XF6,0X68,0XF6,0X68,0XFE,0X67,0XFE,0X66,0XFE,0X67,0XFE,0X67,

57080XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X67,

57090XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0XA9,0XFE,0XCA,0XF6,0X8A,0XEE,0X49,

57100XF6,0X68,0XEE,0X47,0XEE,0X6A,0XDE,0X2C,0XFF,0X55,0XFF,0XDB,0XFF,0XDD,0XFF,0XFF,

57110XF7,0XFF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

57180XFF,0XFF,0XFF,0XDB,0XFF,0X53,0XDE,0X2A,0XEE,0X48,0XEE,0X26,0XF6,0X27,0XF6,0X27,

57190XF6,0X27,0XEE,0X47,0XF6,0X46,0XF6,0X46,0XF6,0X46,0XF6,0X46,0XF6,0X47,0XF6,0X47,

57200XF6,0X67,0XF6,0X66,0XF6,0X66,0XF6,0X46,0XF6,0X47,0XF6,0X47,0XFE,0X68,0XEE,0X28,

57210XFE,0XAB,0XDD,0XC8,0X93,0XC2,0X72,0XC0,0X72,0XE2,0X6A,0XA2,0X6A,0XC3,0X6A,0XC3,

57220X6A,0XA3,0X62,0XA3,0X6A,0XA3,0X6A,0XA3,0X6A,0XA3,0X6A,0XA3,0X62,0X84,0X5A,0X84,

57230X6B,0X28,0XD6,0X96,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

57240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0X99,0XC5,0X8D,

57250XCD,0X88,0XEE,0X48,0XFE,0X87,0XF6,0X45,0XFE,0X66,0XFE,0X67,0XFE,0X67,0XFE,0X67,

57260XF6,0X68,0XF6,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

57270XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X87,0XFE,0X87,

57280XFE,0X87,0XFE,0X87,0XFE,0XC9,0XFE,0XAA,0XF6,0X8A,0XEE,0X69,0XEE,0X67,0XEE,0X89,

57290XE6,0X4A,0XEE,0XF1,0XFF,0XB9,0XFF,0XDD,0XF7,0XDE,0XF7,0XFF,0XF7,0XFE,0XF7,0XFF,

57300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57360XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,

57370XFF,0XB6,0XEE,0XAE,0XE6,0X49,0XEE,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X47,

57380XF6,0X46,0XF6,0X46,0XF6,0X46,0XF6,0X46,0XF6,0X46,0XF6,0X66,0XF6,0X66,0XF6,0X66,

57390XF6,0X66,0XF6,0X66,0XF6,0X47,0XF6,0X47,0XFE,0X88,0XEE,0X07,0XFE,0XAA,0XF6,0X6B,

57400XB4,0X84,0X8B,0X61,0X83,0X42,0X73,0X02,0X73,0X24,0X73,0X24,0X73,0X05,0X73,0X05,

57410X73,0X04,0X7A,0XE4,0X7A,0XE4,0X7A,0XE4,0X73,0X05,0X72,0XE5,0X6A,0XE6,0XA4,0XCE,

57420XFF,0XBB,0XFF,0XFD,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57430XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XF7,0X16,0XBD,0X2A,0XDD,0XE9,0XEE,0X68,

57440XFE,0XA7,0XF6,0X45,0XFE,0X66,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XF6,0X68,0XF6,0X68,

57450XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

57460XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0XA7,

57470XFE,0XA8,0XFE,0XA9,0XF6,0X89,0XEE,0X89,0XE6,0X68,0XEE,0XAB,0XE6,0X8D,0XFF,0XB6,

57480XFF,0XBB,0XFF,0XDE,0XFF,0XFF,0XF7,0XFF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57550XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDD,0XFF,0XB9,0XFF,0X53,

57560XDE,0X2B,0XEE,0X49,0XEE,0X28,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X46,

57570XF6,0X46,0XF6,0X46,0XF6,0X46,0XF6,0X46,0XF6,0X66,0XF6,0X66,0XF6,0X66,0XF6,0X66,

57580XF6,0X66,0XF6,0X67,0XF6,0X47,0XF6,0X68,0XF6,0X69,0XF6,0X6A,0XD5,0X67,0XA4,0X03,

57590X83,0X21,0X83,0X63,0X83,0X64,0X83,0X65,0X83,0X65,0X83,0X45,0X83,0X45,0X83,0X45,

57600X83,0X25,0X83,0X24,0X83,0X25,0X8B,0X87,0X62,0XA4,0X8B,0XC9,0XDE,0X95,0XFF,0XFC,

57610XFF,0XDE,0XFF,0XFF,0XF7,0XBF,0XFF,0XDF,0XF7,0XDF,0XF7,0XDF,0XFF,0XFF,0XFF,0XFE,

57620XFF,0XFD,0XFF,0XD9,0XE6,0X72,0XBD,0X08,0XEE,0X4A,0XF6,0X67,0XFE,0X87,0XF6,0X45,

57630XFE,0X66,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X87,

57640XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

57650XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X87,0XFE,0X87,0XFE,0XA8,0XF6,0X88,

57660XEE,0X69,0XEE,0X8A,0XEE,0XAB,0XD6,0X0B,0XFF,0X74,0XFF,0XD9,0XFF,0XDD,0XFF,0XFF,

57670XF7,0XDF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XFF,0X97,0XEE,0XD0,0XE6,0X2B,

57750XEE,0X28,0XF6,0X68,0XF6,0X47,0XF6,0X26,0XF6,0X46,0XF6,0X46,0XF6,0X26,0XFE,0X47,

57760XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X66,0XF6,0X66,0XF6,0X66,0XF6,0X67,

57770XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X69,0XEE,0X29,0XC5,0X05,0X9B,0XC2,0X93,0XC3,

57780X93,0XE5,0X8B,0X84,0X93,0XE6,0X8B,0XA5,0X8B,0XA5,0X93,0XA6,0X93,0X85,0X93,0X85,

57790X93,0XA5,0X83,0X24,0X8B,0XA6,0X83,0X87,0XAD,0X0E,0XEF,0X58,0XFF,0XDD,0XFF,0XFE,

57800XFF,0XFF,0XFF,0XFF,0XF7,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBA,0XFF,0X97,

57810XBD,0X2B,0XCD,0X89,0XEE,0X69,0XF6,0X67,0XF6,0X66,0XFE,0X86,0XFE,0X66,0XFE,0X67,

57820XFE,0X68,0XFE,0X68,0XFE,0X68,0XF6,0X68,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,

57830XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X66,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,

57840XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0XA8,0XF6,0XA8,0XF6,0XA9,0XF6,0X88,0XE6,0X69,

57850XE6,0X6C,0XF7,0X32,0XFF,0XB8,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XFF,0XFF,

57930XFF,0XFF,0XFF,0XDD,0XFF,0XDD,0XFF,0XDA,0XFF,0X55,0XEE,0XAE,0XE6,0X29,0XF6,0X68,

57940XF6,0X47,0XF6,0X26,0XF6,0X46,0XFE,0X46,0XF6,0X27,0XF6,0X48,0XF6,0X48,0XF6,0X48,

57950XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X47,

57960XF6,0X47,0XF6,0X68,0XF6,0X89,0XDD,0XE8,0XBC,0XC4,0X9C,0X02,0XA4,0X25,0X9C,0X25,

57970X9C,0X05,0XA4,0X47,0X9C,0X06,0X9C,0X06,0X9C,0X05,0XA4,0X05,0XA3,0XC5,0X9B,0XC5,

57980XA4,0X27,0X8B,0XA6,0X8B,0XE8,0XC5,0XD1,0XF7,0X79,0XFF,0XDD,0XFF,0XFF,0XF7,0XBE,

57990XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFD,0XFF,0XFA,0XDE,0X50,0XAC,0XA7,0XE6,0X2A,

58000XF6,0XA9,0XF6,0X87,0XF6,0X66,0XFE,0X66,0XFE,0X67,0XFE,0X47,0XFE,0X68,0XFE,0X68,

58010XFE,0X68,0XF6,0X88,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

58020XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X87,0XFE,0X67,0XFE,0X68,0XFE,0X88,0XFE,0X88,

58030XFE,0X88,0XF6,0X88,0XF6,0XA9,0XF6,0XCA,0XF6,0XAA,0XE6,0X4B,0XF7,0X11,0XFF,0X97,

58040XFF,0XDB,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,

58120XFF,0XDE,0XFF,0XFD,0XFF,0XB9,0XF7,0X33,0XE6,0X6B,0XEE,0X68,0XEE,0X67,0XF6,0X87,

58130XF6,0X46,0XFE,0X46,0XFE,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X68,

58140XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X87,0XF6,0X67,0XF6,0X67,0XF6,0X87,0XF6,0X88,

58150XF6,0X68,0XEE,0X48,0XDD,0XC7,0XBC,0XC4,0XAC,0X64,0XB4,0XA6,0XAC,0X85,0XAC,0X86,

58160XAC,0X66,0XAC,0X66,0XAC,0X45,0XAC,0X45,0XAC,0X45,0XAC,0X25,0XA4,0X25,0X9C,0X46,

58170X94,0X06,0X94,0X69,0XCE,0X12,0XF7,0X9A,0XFF,0XFE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDE,

58180XFF,0XDD,0XFF,0XFB,0XF7,0X55,0XB5,0X09,0XCD,0X68,0XF6,0X6A,0XEE,0X47,0XF6,0X87,

58190XFE,0XA6,0XF6,0X45,0XFE,0X46,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XF6,0X68,0XF6,0X87,

58200XF6,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,

58210XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0XA8,0XF6,0XA9,

58220XF6,0X8A,0XEE,0X6B,0XEE,0X8D,0XF6,0XF0,0XFF,0X96,0XFF,0XDB,0XFF,0XFE,0XFF,0XFF,

58230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDF,0XFF,0XFE,

58310XFF,0XDB,0XFF,0XB7,0XEE,0XCF,0XE6,0X49,0XEE,0X68,0XF6,0XA8,0XF6,0X26,0XF6,0X26,

58320XFE,0X68,0XF6,0X28,0XF6,0X49,0XF6,0X49,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XF6,0X68,

58330XF6,0X67,0XF6,0X67,0XF6,0X87,0XF6,0X87,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X88,

58340XF6,0XA9,0XDD,0XE7,0XBC,0XE4,0XB4,0XC4,0XB4,0XE6,0XAC,0XA5,0XB4,0XA5,0XB4,0XA6,

58350XB4,0X85,0XB4,0X65,0XB4,0X85,0XB4,0X45,0XAC,0X45,0XA4,0X45,0X9C,0X25,0X94,0X46,

58360X9C,0X69,0XB5,0X6F,0XE6,0XF8,0XFF,0XDD,0XFF,0XFD,0XFF,0XBC,0XFF,0XDB,0XFF,0X97,

58370XCD,0XAD,0XB4,0XE7,0XF6,0X6B,0XF6,0X69,0XEE,0X47,0XF6,0X66,0XF6,0X66,0XFE,0X87,

58380XFE,0X67,0XFE,0X48,0XFE,0X68,0XFE,0X68,0XF6,0X88,0XF6,0X87,0XF6,0X87,0XFE,0X87,

58390XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X88,0XFE,0X87,

58400XFE,0X87,0XFE,0X87,0XFE,0XA7,0XFE,0XA7,0XF6,0XA8,0XF6,0XAA,0XEE,0XAC,0XE6,0X8D,

58410XEE,0XD1,0XFF,0X76,0XFF,0XBA,0XFF,0XDD,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

58420XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58490XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFA,

58500XFF,0X74,0XEE,0XAE,0XE6,0X6A,0XF6,0X89,0XF6,0X67,0XFE,0X47,0XFE,0X68,0XFE,0X48,

58510XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XF6,0X68,0XF6,0X67,

58520XF6,0X87,0XF6,0X87,0XF6,0X66,0XF6,0X87,0XF6,0X67,0XFE,0XA8,0XFF,0X0A,0XFE,0XEA,

58530XDE,0X07,0XBD,0X04,0XB5,0X04,0XBD,0X05,0XBC,0XE5,0XB4,0XC5,0XBC,0XC5,0XB4,0X84,

58540XB4,0X64,0XBC,0XC5,0XA4,0X03,0XAC,0X65,0X9C,0X44,0X8B,0XE4,0X94,0X27,0X7B,0X66,

58550X94,0X0A,0XCD,0XF3,0XF7,0X58,0XFF,0XB9,0XFF,0X97,0XDE,0X30,0XA4,0X65,0XE6,0X0A,

58560XFE,0X8A,0XF6,0X47,0XFE,0X87,0XF6,0X66,0XF6,0X46,0XFE,0X87,0XFE,0X88,0XFE,0X48,

58570XFE,0X68,0XFE,0X68,0XF6,0X87,0XF6,0X87,0XF6,0X87,0XF6,0X87,0XFE,0X67,0XFE,0X67,

58580XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X88,

58590XF6,0X87,0XFE,0XC9,0XF6,0XCA,0XEE,0XAB,0XE6,0XAE,0XEE,0XF2,0XFF,0X56,0XFF,0XBB,

58600XFF,0XDD,0XFF,0XDE,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

58610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

58680XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XD9,0XF7,0X33,

58690XE6,0X6C,0XE6,0X29,0XF6,0X88,0XFE,0X87,0XFE,0X47,0XFE,0X87,0XFE,0X67,0XFE,0X68,

58700XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XF6,0X67,0XF6,0X66,0XF6,0X87,

58710XF6,0X87,0XF6,0X87,0XF6,0X87,0XF6,0X87,0XFE,0XA8,0XFF,0X0A,0XFE,0XEA,0XE6,0X48,

58720XBD,0X24,0XBD,0X04,0XBC,0XE4,0XB4,0XC4,0XB4,0XA4,0XB4,0X84,0XB4,0X64,0XB4,0X64,

58730XA4,0X24,0XA4,0X24,0X9C,0X03,0X93,0XC3,0X8B,0XA4,0X8B,0X85,0X83,0X66,0X72,0XE4,

58740X7B,0X25,0XBD,0X2C,0XC5,0X8C,0XBD,0X29,0XE6,0X0A,0XEE,0X49,0XF6,0X88,0XF6,0X47,

58750XF6,0X67,0XFE,0X87,0XFE,0XA7,0XF6,0X46,0XFE,0X48,0XFE,0X69,0XFE,0X68,0XFE,0X68,

58760XF6,0X87,0XF6,0X87,0XF6,0X87,0XF6,0X87,0XFE,0X67,0XFE,0X68,0XFE,0X67,0XFE,0X67,

58770XFE,0X67,0XFE,0X67,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0XA8,0XF6,0XC9,0XF6,0XCA,

58780XEE,0XAB,0XE6,0XAD,0XEE,0XF1,0XF7,0X56,0XFF,0XBA,0XFF,0XFE,0XFF,0XBE,0XFF,0XDF,

58790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

58800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58870XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XF7,0XFD,0XFF,0XDC,0XFF,0X98,0XEE,0XD0,0XE6,0X4B,

58880XF6,0X69,0XF6,0X67,0XF6,0X46,0XFE,0X66,0XFE,0X66,0XFE,0X66,0XFE,0X67,0XFE,0X67,

58890XFE,0X48,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0XA8,0XF6,0X87,0XF6,0X66,0XF6,0X67,

58900XFE,0X87,0XFE,0X87,0XF6,0X67,0XF6,0X88,0XFF,0X0A,0XFF,0X4C,0XDE,0X28,0XCD,0X86,

58910XBD,0X05,0XB4,0XC4,0XB4,0XA3,0XB4,0X83,0XAC,0X42,0XB4,0X44,0XA4,0X24,0X93,0XA3,

58920X93,0X82,0X8B,0X41,0X83,0X21,0X83,0X22,0X72,0XC2,0X62,0X40,0X6A,0X80,0X83,0X62,

58930XBC,0XE7,0XE6,0X0A,0XF6,0X6A,0XF6,0X69,0XF6,0X67,0XFE,0X87,0XF6,0X66,0XFE,0X87,

58940XFE,0X87,0XFE,0X47,0XFE,0X48,0XFE,0X48,0XFE,0X68,0XFE,0X68,0XF6,0X87,0XF6,0X87,

58950XF6,0X87,0XF6,0X87,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,

58960XFE,0X87,0XFE,0X88,0XFE,0X88,0XF6,0XA9,0XFE,0XEC,0XEE,0X8C,0XE6,0X8D,0XEE,0XF1,

58970XFF,0X96,0XFF,0XFA,0XFF,0XFC,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

58980XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59050XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59060XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XFF,0X76,0XF6,0XD0,0XEE,0X6B,0XF6,0X89,

59070XFE,0XA8,0XFE,0X87,0XFE,0X66,0XFE,0X66,0XFE,0X66,0XFE,0X67,0XFE,0X48,0XFE,0X48,

59080XFE,0X68,0XFE,0X68,0XF6,0X87,0XF6,0X87,0XF6,0X87,0XF6,0X67,0XFE,0X88,0XFE,0X88,

59090XF6,0X68,0XFE,0XA9,0XFE,0XEA,0XFF,0X0B,0XFF,0X6D,0XEE,0XAA,0XCD,0X86,0XBD,0X04,

59100XBC,0XE4,0XAC,0X63,0XAC,0X42,0X9B,0XE1,0X9B,0XC3,0X9B,0XA3,0X93,0X81,0X83,0X00,

59110X7A,0XE0,0X72,0X80,0X72,0XA0,0X8B,0X81,0XAC,0X84,0XCD,0X67,0XE6,0X29,0XEE,0X49,

59120XFE,0X89,0XFE,0X88,0XFE,0X67,0XFE,0X87,0XF6,0X67,0XFE,0X87,0XFE,0X67,0XFE,0X67,

59130XFE,0X68,0XFE,0X48,0XFE,0X68,0XFE,0X68,0XF6,0X87,0XF6,0X87,0XF6,0X87,0XFE,0X68,

59140XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X87,0XFE,0X87,0XFE,0XA7,0XFE,0XA7,0XF6,0XA8,

59150XF6,0X8A,0XF6,0X8B,0XE6,0X4C,0XEE,0X8F,0XF7,0X33,0XFF,0XB7,0XFF,0XDA,0XFF,0XFC,

59160XFF,0XFE,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

59170XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59250XFF,0XFE,0XFF,0XDC,0XFF,0XDA,0XFF,0X95,0XF6,0XF0,0XE6,0X6B,0XEE,0X69,0XF6,0X88,

59260XF6,0X67,0XFE,0X66,0XFE,0X46,0XFE,0X67,0XFE,0X88,0XFE,0X68,0XFE,0X48,0XFE,0X68,

59270XF6,0X67,0XF6,0X67,0XF6,0X87,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XF6,0X88,

59280XF6,0X89,0XF6,0XA9,0XFE,0XEB,0XFF,0X2C,0XFF,0X2C,0XEE,0X8A,0XCD,0X87,0XBC,0XC4,

59290XAC,0X83,0XAC,0X42,0XA4,0X02,0X93,0XC1,0X93,0X81,0X93,0X81,0X9B,0XC2,0XA4,0X02,

59300XC5,0X05,0XD5,0XA7,0XEE,0X48,0XEE,0X68,0XF6,0X68,0XF6,0X68,0XFE,0X68,0XFE,0X68,

59310XFE,0X88,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,

59320XFE,0X68,0XFE,0X67,0XF6,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X69,0XFE,0X49,0XFE,0X49,

59330XFE,0X67,0XFE,0X66,0XFE,0X86,0XF6,0XA7,0XFE,0XA8,0XF6,0XAA,0XEE,0XAC,0XEE,0X8E,

59340XEE,0XB2,0XF7,0X36,0XFF,0XB9,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

59350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDD,

59440XFF,0XFC,0XFF,0XD9,0XFF,0X55,0XEE,0XD0,0XEE,0X8C,0XEE,0X6A,0XF6,0X68,0XFE,0X87,

59450XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X48,0XFE,0X48,0XFE,0X69,0XFE,0X88,0XFE,0X88,

59460XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

59470XF6,0X68,0XF6,0XA9,0XFF,0X0B,0XFF,0X4C,0XFF,0X2C,0XFE,0XEB,0XEE,0X6A,0XE6,0X29,

59480XDD,0XE8,0XD5,0XA8,0XD5,0XC8,0XE5,0XE9,0XEE,0X4A,0XF6,0X8A,0XF6,0X8A,0XF6,0X68,

59490XF6,0X47,0XF6,0X67,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X87,0XFE,0X87,

59500XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X67,

59510XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X69,0XFE,0X6A,0XFE,0X69,0XFE,0X68,0XFE,0X88,

59520XFE,0XA8,0XF6,0XA9,0XEE,0X8A,0XEE,0X8C,0XEE,0XCF,0XF7,0X13,0XFF,0X98,0XFF,0XBB,

59530XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFC,

59630XFF,0XDA,0XFF,0X76,0XF6,0XF1,0XEE,0X8D,0XEE,0X69,0XEE,0X68,0XF6,0X87,0XFE,0X87,

59640XFE,0X87,0XFE,0X88,0XFE,0X69,0XFE,0X49,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X88,

59650XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0XA7,0XFE,0XA7,0XF6,0X87,0XF6,0X87,0XF6,0X88,

59660XF6,0X88,0XEE,0X68,0XF6,0X88,0XFE,0XCA,0XFF,0X2C,0XFF,0X2C,0XFF,0X0C,0XFF,0X0C,

59670XFE,0XEB,0XFE,0XCA,0XF6,0X89,0XEE,0X48,0XEE,0X27,0XF6,0X68,0XFE,0X88,0XFE,0X88,

59680XFE,0X87,0XFE,0X87,0XFE,0X66,0XFE,0X66,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,

59690XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,

59700XFE,0X68,0XFE,0X68,0XF6,0X88,0XF6,0X89,0XFE,0X89,0XF6,0X89,0XEE,0X8A,0XEE,0XAC,

59710XEE,0XAE,0XF6,0XF1,0XFF,0X55,0XFF,0XB9,0XFF,0XDB,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,

59720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

59730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59800XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

59810XFF,0XDF,0XFF,0XDE,0XFF,0XFF,0XFF,0XDE,0XFF,0XBE,0XFF,0XDE,0XFF,0XDD,0XFF,0XBA,

59820XFF,0X76,0XF7,0X12,0XEE,0XCD,0XEE,0X8A,0XF6,0XA8,0XFE,0XA8,0XFE,0X88,0XFE,0X68,

59830XFE,0X69,0XFE,0X69,0XFE,0X68,0XFE,0X87,0XFE,0X88,0XFE,0X87,0XFE,0X87,0XFE,0X87,

59840XFE,0X87,0XFE,0XA7,0XF6,0X86,0XFE,0XA7,0XF6,0X87,0XF6,0X66,0XF6,0X67,0XFE,0XA8,

59850XFE,0XC9,0XF6,0XA9,0XEE,0X48,0XEE,0X48,0XEE,0X68,0XEE,0X68,0XF6,0X88,0XF6,0X88,

59860XF6,0X88,0XF6,0XA8,0XF6,0X88,0XFE,0XA9,0XFE,0XA9,0XF6,0X67,0XF6,0X46,0XFE,0X86,

59870XFE,0XA6,0XFE,0X86,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X67,

59880XFE,0X67,0XFE,0X67,0XFE,0X66,0XFE,0X66,0XFE,0X67,0XFE,0X68,0XFE,0X88,0XF6,0X89,

59890XF6,0XA9,0XF6,0XCA,0XEE,0X8B,0XEE,0X8C,0XEE,0XAE,0XF7,0X11,0XFF,0X55,0XFF,0X98,

59900XFF,0XDA,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59910XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

59990XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,

60000XF7,0X9D,0XF7,0X9D,0XFF,0XBE,0XF7,0X9E,0XF7,0X7E,0XFF,0X7C,0XFF,0X7A,0XFF,0X77,

60010XF7,0X33,0XEE,0XAE,0XE6,0X8B,0XEE,0X69,0XF6,0X69,0XFE,0X89,0XFE,0X89,0XFE,0X69,

60020XFE,0X87,0XFE,0X86,0XFE,0X67,0XFE,0X87,0XFE,0XA7,0XFE,0XA7,0XFE,0X87,0XF6,0X66,

60030XF6,0X86,0XF6,0X86,0XF6,0X87,0XFE,0XC8,0XFE,0XA9,0XF6,0X68,0XF6,0X28,0XF6,0X49,

60040XF6,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0XA8,0XF6,0XA7,0XF6,0X87,0XF6,0X87,0XF6,0X87,

60050XF6,0X68,0XF6,0X47,0XF6,0X47,0XFE,0X68,0XFE,0X87,0XFE,0X86,0XFE,0X66,0XFE,0X66,

60060XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X87,0XFE,0X87,

60070XFE,0X87,0XFE,0X67,0XFE,0X67,0XF6,0X68,0XF6,0X68,0XEE,0X69,0XEE,0X8A,0XEE,0XAC,

60080XEE,0XCE,0XF7,0X11,0XFF,0X75,0XFF,0XB8,0XFF,0XDA,0XFF,0XDC,0XFF,0XDD,0XFF,0XDE,

60090XFF,0XFE,0XFF,0XDE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBF,

60100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

60170XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,

60180XF7,0X9E,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X5C,0XEF,0X3C,0XEF,0X5C,

60190XEF,0X5D,0XEF,0X3D,0XE7,0X1D,0XE7,0X1C,0XEF,0X1B,0XEF,0X19,0XEE,0XF6,0XEE,0XF3,

60200XF6,0XF0,0XEE,0XAD,0XEE,0X6B,0XF6,0X6A,0XF6,0X6A,0XFE,0X69,0XFE,0X87,0XFE,0X86,

60210XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XF6,0X87,0XF6,0X87,0XF6,0X86,0XFE,0XA7,

60220XFE,0XA7,0XF6,0X87,0XF6,0X47,0XFE,0X68,0XFE,0X69,0XFE,0X69,0XF6,0X88,0XF6,0X68,

60230XF6,0X67,0XF6,0X87,0XF6,0X87,0XF6,0X87,0XFE,0X87,0XFE,0X87,0XFE,0XA8,0XFE,0X88,

60240XFE,0X88,0XFE,0X88,0XFE,0X87,0XFE,0X66,0XFE,0X66,0XFE,0X66,0XFE,0X67,0XFE,0X68,

60250XFE,0X68,0XF6,0X68,0XF6,0X88,0XF6,0X87,0XF6,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X88,

60260XFE,0X89,0XFE,0X8A,0XF6,0XAB,0XEE,0XAC,0XEE,0XCE,0XEE,0XF0,0XFF,0X74,0XFF,0XB7,

60270XFF,0XDA,0XFF,0XDB,0XFF,0XBD,0XFF,0XBE,0XFF,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

60280XF7,0XBE,0XF7,0XBE,0XF7,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

60290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,

60360XF7,0X9E,0XF7,0X9E,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XE7,0X3C,

60370XE7,0X3C,0XE7,0X3C,0XE7,0X1C,0XDE,0XFB,0XDE,0XFA,0XDE,0XDA,0XD6,0XBA,0XD6,0X9A,

60380XCE,0X7A,0XCE,0X5A,0XCE,0X59,0XC6,0X17,0XCE,0X15,0XCD,0XD3,0XC5,0XB0,0XCD,0XCE,

60390XE6,0X4E,0XF6,0X8E,0XF6,0X8D,0XF6,0X8B,0XF6,0X89,0XFE,0XA7,0XFE,0XA7,0XFE,0XA7,

60400XF6,0X87,0XF6,0X86,0XFE,0XA6,0XFE,0XA7,0XF6,0X86,0XF6,0X66,0XF6,0X66,0XFE,0X87,

60410XFE,0XA8,0XFE,0XA8,0XFE,0X88,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,

60420XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

60430XFE,0X87,0XFE,0XA8,0XFE,0XA8,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,

60440XF6,0X87,0XF6,0X87,0XF6,0X88,0XF6,0X89,0XFE,0X8A,0XF6,0X8B,0XF6,0X8C,0XF6,0X8E,

60450XEE,0X8F,0XEE,0XB1,0XEE,0XF3,0XEF,0X15,0XEF,0X57,0XEF,0X59,0XEF,0X5A,0XE7,0X3B,

60460XE7,0X3C,0XEF,0X3D,0XEF,0X5D,0XEF,0X5D,0XEF,0X9D,0XEF,0X9D,0XEF,0X9E,0XEF,0X9D,

60470XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,

60480XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

60490XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60540XFF,0XFF,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XEF,0X7D,0XEF,0X7D,

60550XEF,0X5D,0XEF,0X5D,0XE7,0X3C,0XE7,0X3C,0XE7,0X1C,0XDE,0XFB,0XDE,0XDB,0XDE,0XDB,

60560XD6,0XBA,0XD6,0X9A,0XCE,0X79,0XCE,0X58,0XC6,0X38,0XBD,0XF8,0XB5,0XD7,0XB5,0X97,

60570XAD,0X76,0XAD,0X55,0XAD,0X14,0XAC,0XF2,0XA4,0X8F,0XA4,0X8D,0XAC,0XAB,0XBD,0X0B,

60580XD5,0XCC,0XEE,0X6D,0XFE,0XCD,0XF6,0XAB,0XEE,0X89,0XEE,0X89,0XF6,0XA8,0XFE,0XC8,

60590XFE,0XA7,0XF6,0X87,0XF6,0X87,0XFE,0X87,0XFE,0XA7,0XFE,0X87,0XFE,0X87,0XFE,0X87,

60600XF6,0X86,0XF6,0X66,0XF6,0X66,0XFE,0X66,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XF6,0X67,

60610XFE,0X67,0XFE,0X87,0XFE,0X88,0XFE,0X87,0XFE,0X67,0XFE,0X87,0XFE,0X67,0XFE,0X67,

60620XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X87,0XF6,0X87,0XF6,0X88,0XF6,0XA9,

60630XF6,0XAA,0XF6,0XAC,0XF6,0XAD,0XEE,0X4E,0XDE,0X0E,0XD5,0XAE,0XC5,0X8F,0XC5,0X91,

60640XCD,0XD3,0XCE,0X35,0XC6,0X56,0XCE,0X77,0XCE,0X79,0XD6,0X9A,0XD6,0XBB,0XDE,0XDB,

60650XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XDF,0X1B,0XE7,0X3C,0XE7,0X3C,0XE7,0X3D,0XEF,0X5D,

60660XEF,0X5C,0XE7,0X5C,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,

60670XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

60680XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

60690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0X9E,

60730XF7,0X9E,0XF7,0X9E,0XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XE7,0X3C,

60740XE7,0X1C,0XE7,0X1C,0XDE,0XFB,0XDE,0XDB,0XD6,0XBA,0XD6,0XBA,0XD6,0X9A,0XCE,0X59,

60750XC6,0X38,0XBE,0X18,0XB5,0XD7,0XAD,0X96,0XAD,0X75,0XA5,0X34,0X9C,0XF3,0X9C,0XB3,

60760X94,0X52,0X8C,0X30,0X83,0XCE,0X83,0XCD,0X7B,0X49,0X73,0X47,0X83,0XA8,0X9C,0X49,

60770XC5,0X4B,0XD5,0XEC,0XEE,0X8D,0XF6,0XCD,0XEE,0XAB,0XEE,0X89,0XF6,0X89,0XFE,0XA9,

60780XF6,0X88,0XF6,0X67,0XFE,0X88,0XFE,0X88,0XF6,0X67,0XF6,0X87,0XFE,0XC7,0XF6,0X86,

60790XFE,0X86,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,

60800XF6,0X47,0XF6,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X88,0XFE,0X68,0XF6,0X48,0XFE,0X89,

60810XFE,0X88,0XF6,0X67,0XF6,0X67,0XF6,0X89,0XF6,0XAA,0XF6,0XCB,0XF6,0XAD,0XEE,0X8E,

60820XC5,0X4C,0X93,0XE8,0X6A,0XA5,0X5A,0X66,0X6A,0XC9,0X73,0X2B,0X7B,0X8C,0X83,0XCD,

60830X84,0X30,0X8C,0X91,0X9C,0XD3,0XA5,0X14,0XA5,0X35,0XAD,0X76,0XB5,0XB6,0XBD,0XD7,

60840XC6,0X17,0XCE,0X58,0XCE,0X79,0XD6,0X9A,0XD6,0XBA,0XD6,0XDA,0XDE,0XFA,0XDE,0XFB,

60850XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,

60860XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

60870XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

60880XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0X9E,0XEF,0X7D,

60920XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XEF,0X5D,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

60930XE7,0X1C,0XDE,0XFB,0XDE,0XDB,0XDE,0XDB,0XD6,0XBA,0XCE,0X9A,0XCE,0X59,0XC6,0X39,

60940XBE,0X17,0XB5,0XD6,0XB5,0X95,0XAD,0X55,0XA5,0X14,0X9C,0XF4,0X94,0X72,0X8C,0X31,

60950X7B,0XAF,0X73,0X6D,0X6B,0X2B,0X6B,0X09,0X5A,0X86,0X52,0X24,0X5A,0X44,0X73,0X26,

60960X9C,0X49,0XBD,0X4C,0XDE,0X2D,0XEE,0XAE,0XF6,0XAD,0XEE,0X6B,0XF6,0X6B,0XF6,0X8B,

60970XF6,0XAA,0XF6,0X89,0XF6,0X88,0XEE,0X67,0XEE,0X86,0XF6,0X86,0XF6,0XA7,0XF6,0X87,

60980XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XFE,0X89,0XFE,0XA9,

60990XF6,0X88,0XF6,0X68,0XF6,0X69,0XF6,0X6A,0XFE,0X8B,0XF6,0X6A,0XF6,0X8A,0XFE,0XAA,

61000XFE,0XCB,0XF6,0XAC,0XEE,0X6C,0XD5,0XEB,0XAC,0XA8,0X83,0X85,0X5A,0X42,0X49,0XC2,

61010X39,0X63,0X39,0X85,0X39,0XA6,0X41,0XA7,0X49,0XE7,0X4A,0X28,0X52,0X8A,0X5A,0XCB,

61020X63,0X2D,0X6B,0X6E,0X73,0XAF,0X84,0X10,0X8C,0X71,0X94,0XB2,0X9D,0X13,0XA5,0X34,

61030XAD,0X75,0XB5,0X96,0XBD,0XD7,0XBD,0XF7,0XC6,0X38,0XCE,0X58,0XCE,0X79,0XD6,0X9A,

61040XD6,0XBB,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,

61050XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

61060XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,

61070XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0X9E,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

61110XEF,0X7D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XE7,0X3C,0XE7,0X1C,

61120XE7,0X1C,0XDE,0XFB,0XDE,0XFB,0XD6,0XDB,0XD6,0XBA,0XD6,0XBA,0XCE,0X7A,0XCE,0X59,

61130XC6,0X39,0XC6,0X18,0XBD,0XD8,0XBD,0XB7,0XB5,0X56,0XAD,0X15,0X9C,0XD3,0X9C,0XB2,

61140X8C,0X50,0X83,0XEE,0X73,0X6C,0X6B,0X2B,0X62,0XEA,0X52,0X26,0X41,0XA3,0X41,0XA3,

61150X5A,0X44,0X83,0X47,0XAC,0X8B,0XCD,0X8D,0XE6,0X0E,0XEE,0X4E,0XEE,0X6D,0XEE,0X8C,

61160XF6,0XEC,0XF6,0XEB,0XEE,0XA9,0XEE,0XC9,0XEE,0XA8,0XF6,0X88,0XF6,0X89,0XF6,0X89,

61170XF6,0X89,0XF6,0XA9,0XF6,0X89,0XF6,0X89,0XEE,0X48,0XEE,0X68,0XF6,0X89,0XF6,0XAA,

61180XF6,0XCB,0XFE,0XCC,0XF6,0XAB,0XFE,0XED,0XF6,0XAD,0XE6,0X2D,0XCD,0X6A,0XA4,0X47,

61190X7B,0X23,0X62,0X61,0X51,0XE0,0X41,0XA1,0X41,0XE3,0X4A,0X05,0X4A,0X47,0X4A,0X68,

61200X4A,0X49,0X4A,0X49,0X52,0X49,0X52,0X6A,0X5A,0XAA,0X5A,0XCB,0X62,0XEC,0X63,0X2D,

61210X6B,0X4E,0X73,0X8E,0X73,0XAF,0X7B,0XEF,0X84,0X30,0X8C,0X71,0X94,0XB2,0X9C,0XF3,

61220XA5,0X14,0XAD,0X55,0XB5,0X95,0XB5,0XB6,0XBD,0XF7,0XC6,0X18,0XCE,0X59,0XCE,0X79,

61230XCE,0X79,0XD6,0X9A,0XD6,0XBA,0XDE,0XFB,0XDE,0XDB,0XDE,0XFB,0XE7,0X1C,0XE7,0X3C,

61240XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,

61250XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,

61260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61290XFF,0XFF,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XEF,0X7D,

61300XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

61310XE7,0X1C,0XE7,0X1C,0XDF,0X1B,0XDE,0XFB,0XDE,0XFB,0XDE,0XDB,0XDE,0XDB,0XD6,0XBB,

61320XD6,0X9A,0XD6,0X7A,0XD6,0X5A,0XCE,0X59,0XCE,0X18,0XC5,0XF7,0XBD,0XD7,0XBD,0XD7,

61330XB5,0X96,0XAD,0X55,0XA4,0XF4,0XA4,0XF3,0XA4,0XD2,0X94,0X50,0X8B,0XED,0X83,0X6A,

61340X7B,0X28,0X73,0X06,0X8B,0XA8,0XA4,0X49,0XB4,0XEA,0XC5,0X6B,0XD6,0X0C,0XDE,0X2C,

61350XDE,0X2B,0XE6,0X6C,0XEE,0XCD,0XEE,0XAC,0XEE,0XAC,0XEE,0X8C,0XEE,0X8C,0XEE,0X8C,

61360XEE,0X8C,0XEE,0X8C,0XF6,0XEE,0XF6,0XEE,0XF6,0XCE,0XEE,0XAE,0XDE,0X0B,0XC5,0X69,

61370XB4,0XE8,0X8B,0XA4,0X72,0XE2,0X5A,0X20,0X41,0X80,0X41,0X60,0X41,0X80,0X41,0XA1,

61380X49,0XE3,0X4A,0X25,0X4A,0X25,0X4A,0X46,0X52,0X87,0X52,0XA9,0X5A,0XCA,0X62,0XEB,

61390X63,0X0C,0X6B,0X2C,0X62,0XEB,0X62,0XEB,0X6B,0X2C,0X73,0X4D,0X73,0X8E,0X7B,0XCF,

61400X84,0X10,0X84,0X51,0X84,0X51,0X8C,0X92,0X94,0XD2,0X9C,0XF3,0XA4,0XF4,0XA5,0X34,

61410XAD,0X55,0XB5,0X96,0XB5,0XB6,0XBD,0XD7,0XC6,0X18,0XC6,0X38,0XC6,0X38,0XCE,0X59,

61420XCE,0X79,0XD6,0X9A,0XD6,0XBA,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,

61430XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,

61440XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,

61450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

61480XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

61490XF7,0X9E,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,

61500XE7,0X5C,0XE7,0X5C,0XE7,0X3C,0XE7,0X3C,0XE7,0X1C,0XE6,0XFC,0XE6,0XDC,0XE6,0XDC,

61510XDE,0XDB,0XDE,0XBB,0XDE,0X9A,0XD6,0X9A,0XD6,0X9A,0XD6,0XBA,0XD6,0X99,0XCE,0X79,

61520XD6,0X79,0XD6,0X99,0XD6,0X99,0XD6,0X78,0XDE,0XB8,0XDE,0XB7,0XDE,0XB6,0XDE,0X75,

61530XD6,0X54,0XCE,0X13,0XC5,0XB1,0XBD,0X70,0XC5,0X70,0XBD,0X4F,0XB5,0X2E,0XB5,0X0D,

61540XB5,0X0D,0XBD,0X2D,0XBD,0X4D,0XC5,0X6D,0XBD,0X4D,0XB5,0X0C,0XAC,0XAB,0XA4,0X6A,

61550X94,0X08,0X83,0X87,0X7B,0X05,0X62,0X43,0X51,0XE1,0X49,0XA0,0X41,0X60,0X49,0XA1,

61560X41,0XA2,0X41,0XA3,0X49,0XE4,0X52,0X25,0X52,0X45,0X52,0X66,0X5A,0X87,0X5A,0XA8,

61570X62,0XE9,0X63,0X09,0X6B,0X4A,0X6B,0X6A,0X6B,0X6B,0X73,0X8C,0X73,0XAD,0X7B,0XEE,

61580X8C,0X0F,0X84,0X0F,0X83,0XEF,0X83,0XEF,0X84,0X0F,0X84,0X30,0X8C,0X72,0X94,0XB3,

61590X9C,0XD3,0X9C,0XF4,0XA5,0X14,0XA5,0X34,0XAD,0X55,0XAD,0X75,0XB5,0X96,0XBD,0XB7,

61600XC5,0XF7,0XC6,0X18,0XC6,0X38,0XCE,0X59,0XCE,0X79,0XCE,0X79,0XD6,0XBA,0XD6,0XBA,

61610XDE,0XDB,0XDE,0XDB,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,

61620XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,

61630XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

61670XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,

61680XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XEF,0X7D,0XF7,0X9E,0XEF,0X7D,

61690XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XEF,0X5D,0XEF,0X3D,0XEF,0X3D,0XEF,0X3D,0XE6,0XFC,

61700XE7,0X1C,0XEF,0X3C,0XE7,0X3C,0XDE,0XFB,0XE7,0X1C,0XEF,0X7C,0XEF,0X7C,0XEF,0X7C,

61710XEF,0X7B,0XEF,0X7B,0XEF,0X9B,0XEF,0X7B,0XEF,0X7A,0XEF,0X5A,0XE7,0X39,0XE7,0X18,

61720XEF,0X19,0XEE,0XF8,0XE6,0XD8,0XE6,0XB8,0XE6,0XB8,0XE6,0XB7,0XDE,0X76,0XDE,0X75,

61730XDE,0X55,0XD6,0X54,0XD6,0X34,0XCD,0XF3,0XCD,0XF3,0XCD,0XD3,0XC5,0XD3,0XC5,0XB3,

61740XBD,0X72,0XBD,0X52,0XB5,0X12,0XB5,0X32,0XB5,0X32,0XA4,0XB0,0XA4,0XD1,0XA4,0XD1,

61750X9C,0XB1,0X9C,0XB0,0X94,0X90,0X94,0XB0,0X94,0XB1,0X94,0X90,0X94,0X90,0X94,0X90,

61760X94,0XB0,0X9C,0XD0,0X9C,0XF1,0X9C,0XF1,0XA5,0X12,0XA5,0X33,0XAD,0X33,0XAD,0X33,

61770XAD,0X33,0XAD,0X33,0XA5,0X13,0XA5,0X13,0XA5,0X14,0XA5,0X35,0XAD,0X56,0XAD,0X76,

61780XB5,0X96,0XB5,0XB6,0XB5,0XB6,0XBD,0XD7,0XBD,0XF8,0XC6,0X18,0XC6,0X38,0XC6,0X38,

61790XCE,0X59,0XCE,0X59,0XCE,0X79,0XD6,0X9A,0XD6,0XBA,0XD6,0XBA,0XDE,0XDB,0XDE,0XDB,

61800XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,

61810XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

61820XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

61860XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

61870XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9F,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

61880XF7,0X9D,0XF7,0X7D,0XF7,0X7D,0XF7,0X7D,0XF7,0X7E,0XF7,0X7E,0XF7,0X9E,0XF7,0X7E,

61890XF7,0X9E,0XFF,0XDE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XDE,

61900XF7,0XDE,0XF7,0XFE,0XF7,0XDE,0XEF,0XBC,0XF7,0XDC,0XF7,0XBB,0XF7,0XBB,0XF7,0X9B,

61910XF7,0X9B,0XF7,0X7B,0XF7,0X5B,0XF7,0X3B,0XF7,0X5B,0XF7,0X7A,0XF7,0X7A,0XEF,0X5A,

61920XEF,0X39,0XEF,0X19,0XEF,0X19,0XEF,0X19,0XEF,0X19,0XEF,0X19,0XEF,0X3A,0XEF,0X1A,

61930XEF,0X1A,0XE6,0XFA,0XDE,0XB9,0XE7,0X1A,0XDE,0XFA,0XDE,0XDA,0XDE,0XD9,0XDE,0XF9,

61940XD6,0XD9,0XD6,0XB9,0XD6,0XB8,0XD6,0X98,0XDE,0XBA,0XDE,0X99,0XDE,0X79,0XDE,0X99,

61950XD6,0X98,0XD6,0X98,0XD6,0XB7,0XCE,0X97,0XD6,0X98,0XD6,0XB8,0XD6,0XD8,0XDE,0XB8,

61960XD6,0X98,0XD6,0X78,0XCE,0X38,0XC6,0X18,0XCE,0X39,0XCE,0X19,0XCE,0X39,0XCE,0X59,

61970XCE,0X59,0XCE,0X79,0XCE,0X7A,0XCE,0X9A,0XD6,0XBA,0XD6,0XBA,0XD6,0XBA,0XDE,0XDA,

61980XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,

61990XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

62000XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,

62010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62040XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

62050XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

62060XFF,0XDF,0XFF,0XDF,0XFF,0XBF,0XFF,0XBF,0XF7,0XBF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBD,

62070XF7,0XBD,0XF7,0XBE,0XFF,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,

62080XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XF7,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62090XF7,0XDF,0XF7,0XFE,0XF7,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XDD,0XFF,0XDD,

62100XFF,0XBE,0XFF,0XDE,0XFF,0XBD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XBC,0XFF,0XBC,

62110XF7,0XBC,0XFF,0XBC,0XF7,0X9C,0XF7,0XBC,0XF7,0X9C,0XF7,0X7C,0XF7,0X7D,0XF7,0X7D,

62120XEF,0X7D,0XF7,0X7D,0XEF,0X9D,0XEF,0X9D,0XEF,0X9D,0XEF,0X9C,0XEF,0X9C,0XEF,0X9C,

62130XEF,0X7C,0XEF,0X5C,0XEF,0X3C,0XEF,0X3C,0XF7,0X5D,0XF7,0X5D,0XEF,0X5C,0XEF,0X7C,

62140XEF,0X9B,0XEF,0X7B,0XEF,0X7B,0XEF,0X7B,0XEF,0X9C,0XEF,0X9B,0XF7,0X7C,0XF7,0X7C,

62150XEF,0X5C,0XE7,0X1C,0XE6,0XFB,0XDE,0XDB,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFC,

62160XDE,0XFC,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

62170XE7,0X3C,0XEF,0X5D,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,

62180XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

62190XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,

62200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62240XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

62250XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

62260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

62270XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62280XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,

62290XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,

62300XFF,0XDE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,

62310XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XF7,0XDE,0XF7,0XDD,0XF7,0XDD,0XFF,0XDE,0XFF,0XDE,

62320XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,

62330XFF,0XDD,0XFF,0XDD,0XF7,0XBD,0XFF,0XDD,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XF7,0XBE,

62340XF7,0X7D,0XEF,0X5D,0XEF,0X3C,0XE7,0X3C,0XEF,0X3C,0XEF,0X5D,0XEF,0X5D,0XE7,0X3C,

62350XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

62360XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

62370XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

62380XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62490XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

62500XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

62510XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

62520XFF,0XDE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDE,0XFF,0XDE,0XF7,0XBE,

62530XF7,0X9D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X7D,0XEF,0X7D,0XEF,0X7D,

62540XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

62550XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

62560XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,

62570XF7,0XBE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBE,

62720XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

62730XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,

62740XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

62750XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

62760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBF,

62910XFF,0XBE,0XFF,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

62920XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

62930XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

62940XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

63100XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

63110XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

63120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

63290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,};

6409

6410const unsigned char gimage_5[51000] = { /* 0X10,0X10,0X00,0X96,0X00,0XAA,0X01,0X1B, */

64110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64630XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65000XFF,0XFF,0XFF,0XDE,0XFF,0XDE,0XFF,0XFF,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

65010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XFE,0XFF,0XDD,

65190XFF,0XDD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

65370XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XDB,0XFF,0XDC,0XEF,0X5A,0XEF,0X3A,0XFF,0XDD,

65380XFF,0XDD,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

65550XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFB,0XFF,0XFA,

65560XFF,0XF9,0XFF,0XD9,0XC6,0X13,0X7B,0XCB,0X9C,0XAF,0XF7,0X9C,0XFF,0XFE,0XFF,0XDE,

65570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65730XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFB,

65740XFF,0XFB,0XFF,0XFA,0XFF,0XF9,0XFF,0XF8,0XFF,0XF8,0XFF,0XF7,0XFF,0XF6,0XE7,0X34,

65750X9C,0XCC,0X42,0X02,0X63,0X08,0XDE,0XD8,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,

65920XFF,0XFD,0XFF,0XFC,0XFF,0XFB,0XFF,0XFA,0XFF,0XF9,0XFF,0XF8,0XFF,0XF7,0XFF,0XF6,

65930XFF,0XF6,0XFF,0XF5,0XF7,0XD4,0XFF,0XF4,0XFF,0XD4,0XDE,0XF1,0X7B,0X86,0X4A,0X21,

65940X52,0X64,0XBD,0XB3,0XFF,0XBD,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

65950XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

66090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,

66100XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFB,0XFF,0XFA,0XFF,0XF9,

66110XFF,0XF8,0XFF,0XF7,0XFF,0XF5,0XFF,0XF5,0XF7,0XD3,0XFF,0XF3,0XFF,0XF2,0XFF,0XF2,

66120XF7,0XD2,0XFF,0XF2,0XFF,0XD2,0XBD,0XEC,0X5A,0XC1,0X52,0X41,0X4A,0X22,0X8C,0X2D,

66130XFF,0X9D,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

66140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66270XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

66280XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,0XFF,0XFA,0XFF,0XF9,

66290XFF,0XF9,0XFF,0XF8,0XFF,0XD8,0XFF,0XD8,0XFF,0XD7,0XFF,0XF6,0XFF,0XF5,0XFF,0XF4,

66300XFF,0XF3,0XFF,0XF2,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XD0,0XFF,0XF2,

66310XF7,0X91,0X9C,0XA7,0X5A,0X80,0X52,0X61,0X52,0X42,0X62,0XC7,0XE6,0XD9,0XFF,0XDE,

66320XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

66460XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,

66470XFF,0XFA,0XFF,0XF9,0XFF,0XF8,0XFF,0XF7,0XFF,0XF5,0XFF,0XF5,0XFF,0XF4,0XFF,0XF4,

66480XFF,0XD4,0XFF,0XD4,0XFF,0XD4,0XFF,0XF3,0XFF,0XF2,0XFF,0XF2,0XFF,0XF1,0XFF,0XF1,

66490XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XD0,0XFF,0XF1,0XE7,0X0F,0X73,0X62,

66500X5A,0X80,0X52,0X41,0X52,0X43,0X4A,0X03,0XAD,0X11,0XFF,0XFE,0XFF,0XDE,0XFF,0XDF,

66510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66640XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,

66650XFF,0XFC,0XFF,0XFB,0XFF,0XFB,0XFF,0XFA,0XFF,0XF9,0XFF,0XF8,0XFF,0XF7,0XFF,0XF6,

66660XFF,0XF5,0XFF,0XF4,0XFF,0XF3,0XFF,0XF2,0XFF,0XF1,0XFF,0XF1,0XFF,0XF2,0XFF,0XF2,

66670XFF,0XF2,0XFF,0XF2,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,

66680XFF,0XEF,0XFF,0XEF,0XFF,0XD0,0XFF,0XD1,0XC5,0XCB,0X62,0XA0,0X5A,0X40,0X5A,0X42,

66690X5A,0X42,0X52,0X23,0X73,0X49,0XFF,0XBC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,

66830XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFA,0XFF,0XF9,0XFF,0XF8,0XFF,0XF7,

66840XFF,0XF6,0XFF,0XF5,0XFF,0XF5,0XFF,0XF4,0XFF,0XF3,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,

66850XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

66860XFF,0XF0,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XCF,0XFF,0XEF,0XFF,0XF0,

66870XFF,0XD1,0XFF,0X71,0X94,0X25,0X62,0X80,0X52,0X00,0X5A,0X42,0X5A,0X42,0X52,0X43,

66880X52,0X44,0XCE,0X55,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

67010XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFB,0XFF,0XFB,0XFF,0XFA,0XFF,0XFA,

67020XFF,0XF9,0XFF,0XF8,0XFF,0XF7,0XFF,0XD6,0XFF,0XD5,0XFF,0XD4,0XF7,0XD3,0XF7,0XF2,

67030XFF,0XF2,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,

67040XFF,0XF2,0XFF,0XF1,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,

67050XFF,0XF1,0XFF,0XF0,0XFF,0XF1,0XFF,0XD0,0XFF,0XF0,0XFF,0XF0,0XFF,0X90,0XEF,0X30,

67060X6B,0X02,0X62,0XA2,0X52,0X00,0X5A,0X42,0X52,0X43,0X52,0X43,0X4A,0X03,0X9C,0XCF,

67070XFF,0XDC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67170XFF,0XFF,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XFF,0XDF,0XFF,0XDF,

67190XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,0XFF,0XFA,

67200XFF,0XD9,0XFF,0XF8,0XFF,0XF7,0XFF,0XF6,0XFF,0XF5,0XFF,0XF4,0XFF,0XF3,0XFF,0XF3,

67210XFF,0XF3,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,

67220XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,

67230XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

67240XFF,0XF0,0XFF,0XCF,0XFF,0XF0,0XFF,0XF0,0XFF,0XD1,0XAD,0X29,0X62,0XA1,0X52,0X21,

67250X52,0X22,0X52,0X43,0X52,0X23,0X52,0X43,0X4A,0X24,0X62,0XE7,0XF7,0X7A,0XFF,0XDD,

67260XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67360XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

67370XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,

67380XFF,0XFB,0XFF,0XFA,0XFF,0XDA,0XFF,0XD8,0XFF,0XD7,0XFF,0XD6,0XFF,0XD6,0XFF,0XF4,

67390XFF,0XF3,0XFF,0XF3,0XFF,0XF2,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,

67400XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

67410XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,

67420XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XD0,

67430XFF,0XCF,0XFF,0XF1,0XEF,0X2F,0X9C,0X86,0X5A,0X81,0X52,0X22,0X52,0X22,0X52,0X23,

67440X52,0X23,0X52,0X43,0X52,0X24,0X52,0X45,0XC5,0XD4,0XFF,0XFD,0XFF,0XDE,0XFF,0XFF,

67450XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

67550XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,

67560XFF,0XFB,0XFF,0XFA,0XFF,0XF9,0XFF,0XF8,0XFF,0XF8,0XFF,0XF7,0XFF,0XF6,0XFF,0XF6,

67570XFF,0XD5,0XFF,0XD4,0XFF,0XD4,0XFF,0XF3,0XFF,0XF3,0XFF,0XF2,0XFF,0XF2,0XFF,0XF1,

67580XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

67590XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

67600XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,

67610XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XAF,0XFF,0XF0,

67620XC5,0XEA,0X7B,0X63,0X52,0X41,0X52,0X22,0X52,0X22,0X52,0X22,0X52,0X23,0X52,0X43,

67630X52,0X44,0X4A,0X04,0X8C,0X0D,0XFF,0XDC,0XFF,0XDD,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

67640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,

67740XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFB,0XFF,0XFB,0XFF,0XF9,0XFF,0XF8,0XFF,0XF7,

67750XFF,0XF6,0XFF,0XF4,0XFF,0XF3,0XFF,0XF3,0XFF,0XF2,0XFF,0XF2,0XFF,0XF1,0XFF,0XF1,

67760XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,

67770XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

67780XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

67790XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

67800XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XD0,0XFF,0XD1,0XAD,0X07,0X62,0XE1,

67810X52,0X01,0X52,0X22,0X52,0X23,0X52,0X23,0X52,0X23,0X52,0X23,0X52,0X44,0X4A,0X24,

67820X6B,0X08,0XE6,0XF9,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67920XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XFA,0XFF,0XF9,0XFF,0XF8,0XFF,0XF8,

67930XFF,0XF8,0XFF,0XF7,0XFF,0XD6,0XFF,0XF5,0XFF,0XF4,0XFF,0XF3,0XFF,0XF2,0XFF,0XF1,

67940XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

67950XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

67960XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

67970XFF,0XF0,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,

67980XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

67990XFF,0XF0,0XFF,0XF0,0XFF,0XD0,0XE7,0X0E,0X8C,0X25,0X62,0X80,0X52,0X01,0X52,0X02,

68000X52,0X22,0X52,0X22,0X52,0X23,0X52,0X23,0X52,0X23,0X52,0X44,0X52,0X86,0XB5,0X93,

68010XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

68110XFF,0XFC,0XFF,0XF9,0XFF,0XD7,0XFF,0XD5,0XFF,0XF4,0XFF,0XF4,0XFF,0XF3,0XFF,0XF3,

68120XFF,0XF2,0XFF,0XF2,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,

68130XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

68140XFF,0XEE,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

68150XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68160XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68170XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XCF,0XFF,0XD0,

68180XFF,0XB0,0XCE,0X0B,0X7B,0X62,0X52,0X20,0X51,0XE1,0X52,0X23,0X52,0X22,0X52,0X02,

68190X52,0X23,0X52,0X43,0X52,0X03,0X52,0X24,0X4A,0X25,0X84,0X0D,0XF7,0X9C,0XFF,0XFE,

68200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFA,0XFF,0XD7,

68300XF7,0XD4,0XFF,0XD2,0XFF,0XD1,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XF0,0XFF,0XEF,

68310XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68320XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68330XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68340XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68350XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68360XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0X8E,0XFF,0XD0,0XFF,0X90,0XAD,0X28,

68370X73,0X22,0X52,0X00,0X51,0XE1,0X52,0X03,0X52,0X23,0X52,0X02,0X52,0X23,0X52,0X23,

68380X52,0X03,0X52,0X24,0X42,0X04,0X63,0X08,0XD6,0XB8,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,

68390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68480XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFC,0XFF,0XF8,0XF7,0XD5,0XFF,0XD2,0XFF,0XF0,

68490XFF,0XEF,0XFF,0XEE,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68500XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68510XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68520XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68530XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68540XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,

68550XFF,0XEE,0XFF,0XEF,0XFF,0XF0,0XFF,0XD0,0XE6,0XCE,0X8B,0XE4,0X62,0XA1,0X49,0XC0,

68560X52,0X02,0X52,0X02,0X52,0X02,0X52,0X02,0X52,0X23,0X4A,0X02,0X52,0X23,0X52,0X44,

68570X41,0XE3,0X52,0X66,0XBD,0XF5,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68670XFF,0XFD,0XFF,0XFB,0XFF,0XD7,0XF7,0XB3,0XFF,0XD1,0XFF,0XF0,0XFF,0XEF,0XFF,0XEE,

68680XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68690XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XEF,

68700XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

68710XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEF,0XFF,0XEE,

68720XFF,0XEF,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68730XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XCE,

68740XFF,0XF0,0XFF,0X90,0XCD,0XEB,0X7B,0X84,0X5A,0X41,0X49,0XE1,0X51,0XE2,0X52,0X03,

68750X52,0X02,0X52,0X02,0X52,0X03,0X52,0X23,0X4A,0X02,0X4A,0X03,0X4A,0X04,0X73,0X6A,

68760XE7,0X19,0XFF,0XFE,0XFF,0XFF,0XF7,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

68770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFA,

68860XFF,0XD6,0XF7,0XD2,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

68870XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,

68880XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68890XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

68900XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

68910XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,

68920XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XCF,0XFF,0XD0,0XF7,0X4F,

68930XAD,0X08,0X6A,0XE2,0X49,0XE0,0X49,0XE1,0X51,0XE2,0X52,0X03,0X52,0X02,0X52,0X23,

68940X49,0XE2,0X52,0X23,0X4A,0X03,0X52,0X24,0X41,0XE4,0X9C,0XD0,0XF7,0X9C,0XFF,0XFE,

68950XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XD9,0XFF,0XD5,0XF7,0XD2,

69050XFF,0XF0,0XFF,0XEF,0XFF,0XEE,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,

69060XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

69070XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

69080XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

69090XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

69100XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

69110XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XCF,0XFF,0XAF,0XE6,0XCE,0X94,0X25,0X5A,0X81,

69120X49,0XE1,0X52,0X02,0X49,0XE2,0X51,0XE3,0X52,0X03,0X4A,0X02,0X4A,0X02,0X49,0XE2,

69130X4A,0X03,0X52,0X44,0X4A,0X25,0XCE,0X56,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

69140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69230XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XD8,0XF7,0XB4,0XFF,0XD1,0XFF,0XEF,0XFF,0XEE,

69240XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,

69250XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

69260XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,

69270XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

69280XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,

69290XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

69300XFF,0XCE,0XFF,0XCF,0XF7,0X6F,0XCE,0X0B,0X7B,0X84,0X5A,0X41,0X49,0XE1,0X51,0XE2,

69310X49,0XC2,0X49,0XE2,0X52,0X03,0X4A,0X02,0X52,0X23,0X49,0XE2,0X4A,0X03,0X4A,0X04,

69320X6B,0X29,0XEF,0X5A,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69330XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,

69420XFF,0XDA,0XFF,0XB6,0XF7,0XB2,0XFF,0XF0,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,

69430XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,

69440XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

69450XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

69460XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

69470XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

69480XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XCD,0XFF,0XCE,0XFF,0XCF,

69490XF7,0X4E,0XAD,0X07,0X6B,0X22,0X52,0X00,0X49,0XC1,0X49,0XC2,0X49,0XC2,0X49,0XE3,

69500X49,0XE2,0X4A,0X03,0X4A,0X03,0X4A,0X03,0X49,0XE3,0X41,0XC3,0XA4,0XF1,0XFF,0XFD,

69510XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XD9,0XFF,0XB5,

69610XFF,0XB1,0XFF,0XEF,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

69620XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

69630XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

69640XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,

69650XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

69660XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,

69670XFF,0XEE,0XFF,0XED,0XFF,0XCD,0XFF,0XCD,0XFF,0XCE,0XFF,0XCF,0XE6,0XED,0X8C,0X24,

69680X62,0XA1,0X49,0XE0,0X49,0XC2,0X49,0XE3,0X49,0XC2,0X49,0XE3,0X49,0XE2,0X4A,0X03,

69690X49,0XE3,0X49,0XE3,0X41,0XE3,0X41,0XC3,0XDE,0XB8,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

69700XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69790XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFC,0XFF,0XB7,0XFF,0XB3,0XFF,0XD0,0XFF,0XEE,

69800XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,

69810XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,

69820XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

69830XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCD,

69840XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

69850XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,

69860XFF,0XCD,0XFF,0XCD,0XFF,0XCE,0XFF,0XAF,0XC5,0XE9,0X7B,0X82,0X5A,0X60,0X49,0XC0,

69870X49,0XE2,0X49,0XE3,0X49,0XE2,0X49,0XE2,0X4A,0X03,0X49,0XE2,0X4A,0X03,0X41,0XC3,

69880X41,0XC3,0X6B,0X29,0XFF,0XBC,0XFF,0XDD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

69980XFF,0XFE,0XFF,0XFB,0XFF,0XB6,0XFF,0XB2,0XFF,0XCF,0XFF,0XED,0XFF,0XED,0XFF,0XED,

69990XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XED,0XFF,0XED,

70000XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,

70010XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

70020XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

70030XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

70040XFF,0XED,0XFF,0XED,0XFF,0XCE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCD,

70050XFF,0XAE,0XF7,0X8F,0XAD,0X07,0X6B,0X21,0X4A,0X00,0X41,0XA0,0X49,0XC2,0X41,0XC2,

70060X49,0XC2,0X49,0XE2,0X4A,0X03,0X49,0XE2,0X4A,0X03,0X4A,0X04,0X31,0X62,0XA5,0X11,

70070XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XF9,

70170XFF,0X94,0XFF,0XB1,0XFF,0XCE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEC,

70180XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

70190XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,

70200XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

70210XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XED,

70220XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

70230XFF,0XEE,0XFF,0XCD,0XFF,0XCC,0XFF,0XEC,0XFF,0XCC,0XFF,0XAD,0XFF,0XAF,0XDE,0X8C,

70240X8C,0X05,0X6A,0XE2,0X41,0XA0,0X49,0XE2,0X41,0XC2,0X49,0XC2,0X41,0XC1,0X4A,0X01,

70250X4A,0X02,0X41,0XC2,0X41,0XE3,0X41,0XE4,0X41,0XE4,0XDE,0XB9,0XFF,0XDE,0XFF,0XFF,

70260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XFF,0XB8,0XFF,0X93,0XFF,0XB0,

70360XFF,0XCD,0XFF,0XEC,0XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,

70370XFF,0XCD,0XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

70380XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,

70390XFF,0XCD,0XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,

70400XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,

70410XFF,0XED,0XFF,0XCD,0XFF,0XCD,0XFF,0XCE,0XFF,0XCE,0XFF,0XCE,0XFF,0XCE,0XFF,0XCD,

70420XFF,0XCC,0XFF,0XCB,0XFF,0XCC,0XFF,0XAD,0XFF,0X6E,0XC5,0XAA,0X83,0XA4,0X5A,0X42,

70430X49,0XE1,0X41,0XC2,0X49,0XE2,0X41,0XC2,0X49,0XE1,0X4A,0X01,0X4A,0X02,0X41,0XC2,

70440X49,0XE4,0X39,0X83,0X7B,0XAC,0XFF,0XDD,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

70450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70540XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XF7,0X95,0XFF,0X91,0XFF,0XAF,0XFF,0XCD,0XFF,0XEC,

70550XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

70560XFF,0XCD,0XFF,0XED,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCC,

70570XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XAC,0XFF,0XAC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCD,

70580XFF,0XCC,0XFF,0XEC,0XFF,0XCC,0XFF,0XEC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,

70590XFF,0XEC,0XFF,0XEC,0XFF,0XCC,0XFF,0XEC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XAD,

70600XFF,0XAD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCE,0XFF,0X8D,0XFF,0XCD,0XFF,0XCC,0XFF,0XAB,

70610XFF,0XAB,0XFF,0X8D,0XF6,0XED,0XA4,0XA6,0X73,0X03,0X49,0XC0,0X49,0XE2,0X41,0XC2,

70620X4A,0X02,0X41,0XE1,0X49,0XE1,0X49,0XE1,0X4A,0X02,0X41,0XC2,0X41,0XE3,0X31,0X83,

70630XBD,0X94,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,

70730XFF,0XFA,0XF7,0X74,0XFF,0X90,0XFF,0XAE,0XFF,0XAD,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,

70740XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

70750XFF,0XCC,0XFF,0XCC,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCC,0XFF,0XCC,

70760XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XAD,0XFF,0XAD,0XFF,0XCC,0XFF,0XCC,

70770XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,

70780XFF,0XCC,0XFF,0XCC,0XFF,0XCD,0XFF,0XCC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAD,0XFF,0XAD,

70790XFF,0X8D,0XFF,0X8D,0XFF,0X8D,0XFF,0X6C,0XFF,0X6B,0XFF,0X6A,0XFF,0X6A,0XF6,0XCA,

70800XDE,0X4A,0X9C,0X25,0X62,0X82,0X49,0XA0,0X41,0XA1,0X49,0XE2,0X41,0XE1,0X41,0XE1,

70810X41,0XC1,0X41,0XE2,0X49,0XE2,0X41,0XE2,0X41,0XC3,0X5A,0XC8,0XF7,0X7B,0XFF,0XFE,

70820XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XD8,0XF7,0X52,

70920XFF,0X8F,0XFF,0X8D,0XFF,0XAC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XAD,0XFF,0XAD,

70930XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

70940XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

70950XFF,0XCD,0XFF,0XCD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,

70960XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,

70970XFF,0XAC,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X6C,

70980XF6,0XCA,0XFE,0XEB,0XF6,0XC9,0XEE,0X67,0XEE,0X87,0XF6,0XA9,0XDE,0X0A,0X93,0XE4,

70990X5A,0X01,0X49,0XC1,0X41,0XC1,0X41,0XC2,0X41,0XC1,0X41,0XE1,0X41,0XC1,0X41,0XE2,

71000X41,0XE2,0X4A,0X03,0X31,0X62,0X8C,0X4E,0XFF,0XBC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

71010XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

71100XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFA,0XF7,0X95,0XF7,0X51,0XFF,0X8E,0XFF,0X8C,

71110XFF,0X8C,0XFF,0XAC,0XFF,0XAC,0XFF,0XAB,0XFF,0XAC,0XFF,0XAC,0XFF,0X8C,0XFF,0XAC,

71120XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0XAC,0XFF,0XAC,

71130XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,

71140XFF,0XAD,0XFF,0X8D,0XFF,0X8D,0XFF,0XAC,0XFF,0XAD,0XFF,0XAD,0XFF,0X8C,0XFF,0X8C,

71150XFF,0X8C,0XFF,0X8C,0XFF,0X6C,0XFF,0X6B,0XFF,0X6B,0XFF,0X6B,0XFF,0X4B,0XFF,0X4B,

71160XFF,0X0A,0XFE,0XE9,0XF6,0XC8,0XEE,0X88,0XEE,0X67,0XEE,0X47,0XEE,0X48,0XEE,0X68,

71170XEE,0X47,0XEE,0X46,0XDD,0XE4,0XCD,0X44,0XBC,0XE5,0X9C,0X04,0X51,0XC0,0X49,0X80,

71180X49,0XC1,0X41,0XA1,0X41,0XE1,0X41,0XE1,0X41,0XE2,0X41,0XC2,0X39,0XA2,0X41,0XE3,

71190X41,0XE4,0XCE,0X56,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,

71290XFF,0XFD,0XFF,0XD9,0XF7,0X53,0XF7,0X6F,0XFF,0X6D,0XFF,0X6C,0XFF,0X6C,0XFF,0X8B,

71300XFF,0X8B,0XFF,0X8B,0XFF,0X8C,0XFF,0X8C,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,

71310XFF,0XAC,0XFF,0X8D,0XFF,0X8D,0XFF,0X8C,0XFF,0X8C,0XFF,0X8B,0XFF,0X8B,0XFF,0X8B,

71320XFF,0X8B,0XFF,0X8B,0XFF,0X8B,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,

71330XFF,0X6C,0XFF,0X8C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X4C,0XFF,0X2B,0XFF,0X0B,

71340XFF,0X0A,0XFE,0XEA,0XFE,0XC9,0XFE,0XA9,0XF6,0X88,0XF6,0X68,0XF6,0X67,0XEE,0X46,

71350XEE,0X26,0XE6,0X05,0XE6,0X05,0XE6,0X05,0XDD,0XA5,0XD5,0X64,0XCD,0X22,0XCD,0X43,

71360XD5,0X83,0XDD,0XE6,0XE6,0X29,0XE6,0X0C,0X7A,0XE2,0X49,0XA0,0X49,0XA1,0X41,0XA1,

71370X49,0XE2,0X41,0XC2,0X41,0XE2,0X41,0XC2,0X41,0XE3,0X39,0XA2,0X62,0XE8,0XE6,0XF9,

71380XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XB7,

71480XEF,0X31,0XFF,0X6E,0XFF,0X6C,0XFF,0X6B,0XFF,0X6B,0XFF,0X6C,0XFF,0X6B,0XFF,0X8C,

71490XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8B,0XFF,0X8C,0XFF,0X6C,0XFF,0X6C,

71500XFF,0X6C,0XFF,0X6C,0XFF,0X8C,0XFF,0X8B,0XFF,0X8B,0XFF,0X8B,0XFF,0X8B,0XFF,0X8B,

71510XFF,0X8B,0XFF,0X8B,0XFF,0X6B,0XFF,0X8B,0XFF,0X6C,0XFF,0X4B,0XFF,0X4B,0XFF,0X2B,

71520XFF,0X0A,0XFF,0X0A,0XFE,0XE9,0XF6,0XA9,0XF6,0X88,0XF6,0X88,0XF6,0X68,0XF6,0X47,

71530XEE,0X26,0XEE,0X06,0XEE,0X06,0XEE,0X05,0XED,0XE5,0XE5,0XC4,0XE5,0XA3,0XDD,0X83,

71540XDD,0X83,0XDD,0X83,0XE5,0XC5,0XEE,0X06,0XF6,0X27,0XF6,0X88,0XF6,0X68,0XFE,0XA9,

71550XF6,0X8A,0XFE,0XCD,0XBD,0X09,0X62,0X40,0X49,0XA0,0X49,0XC2,0X49,0XC2,0X41,0XC2,

71560X41,0XC2,0X41,0XE3,0X39,0XC3,0X39,0XA3,0X9C,0XD0,0XEF,0X5A,0XFF,0XFE,0XFF,0XFF,

71570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71660XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XFF,0X96,0XEF,0X2F,0XFF,0X6D,

71670XFF,0X6B,0XFF,0X4B,0XFF,0X4B,0XFF,0X6B,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X4C,

71680XFF,0X6C,0XFF,0X4C,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X6B,0XFF,0X6C,

71690XFF,0X6C,0XFF,0X4B,0XFF,0X6B,0XFF,0X6B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4A,0XFF,0X2A,

71700XF7,0X09,0XF6,0XE9,0XF6,0XC9,0XF6,0XA8,0XF6,0XA8,0XF6,0X87,0XEE,0X67,0XEE,0X67,

71710XEE,0X46,0XEE,0X25,0XEE,0X05,0XE5,0XE4,0XE5,0XC4,0XE5,0XA4,0XE5,0X83,0XDD,0X62,

71720XDD,0X62,0XE5,0X83,0XE5,0X83,0XE5,0X83,0XE5,0XC3,0XEE,0X04,0XF6,0X25,0XF6,0X46,

71730XF6,0X67,0XF6,0X67,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0XA9,0XF6,0XA9,0XF6,0X8A,

71740XF6,0XAD,0X93,0XC4,0X51,0XC0,0X51,0XC2,0X49,0XC3,0X41,0XA2,0X41,0XA2,0X41,0XE2,

71750X39,0XA3,0X4A,0X25,0XC5,0XF5,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

71850XFF,0XFF,0XFF,0XFE,0XFF,0XB9,0XF7,0X54,0XF7,0X2E,0XFF,0X4C,0XFF,0X6B,0XFF,0X4B,

71860XFF,0X4B,0XFF,0X2B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X6C,0XFF,0X4C,

71870XFF,0X4C,0XFF,0X4B,0XFF,0X6C,0XFF,0X6B,0XFF,0X4B,0XFF,0X0A,0XFF,0X0B,0XFF,0X0B,

71880XFF,0X0B,0XF6,0XEA,0XEE,0XA8,0XEE,0X88,0XF6,0XA8,0XF6,0XA8,0XEE,0X87,0XF6,0X87,

71890XF6,0X66,0XEE,0X46,0XEE,0X25,0XE5,0XE4,0XE5,0XC3,0XDD,0XA3,0XDD,0X61,0XDD,0X61,

71900XDD,0X61,0XDD,0X61,0XDD,0X82,0XE5,0XA2,0XE5,0XA2,0XE5,0XA3,0XED,0XE3,0XED,0XE4,

71910XF6,0X04,0XF6,0X04,0XF6,0X25,0XF6,0X46,0XFE,0X66,0XFE,0X67,0XF6,0X67,0XF6,0X67,

71920XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0XA9,0XF6,0XA9,0XF6,0XAA,0XEE,0X8B,0XD5,0XEB,

71930X72,0XE2,0X41,0X60,0X49,0XA2,0X41,0X82,0X49,0XE2,0X41,0XC2,0X39,0XC3,0X6B,0X2A,

71940XDE,0XD9,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,

72040XFF,0X97,0XF7,0X32,0XF7,0X4E,0XFF,0X4B,0XFF,0X2B,0XFF,0X2B,0XFF,0X4B,0XFF,0X2B,

72050XFF,0X2B,0XFF,0X2B,0XFF,0X4B,0XFF,0X6B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X0B,

72060XFE,0XEA,0XFF,0X0A,0XFE,0XEA,0XF6,0XC9,0XF6,0XAA,0XEE,0X69,0XEE,0X48,0XF6,0X68,

72070XF6,0XA8,0XF6,0X88,0XEE,0X46,0XE5,0XE4,0XE5,0XC3,0XE5,0XA3,0XDD,0X62,0XD5,0X41,

72080XD5,0X40,0XDD,0X40,0XDD,0X41,0XDD,0X61,0XE5,0XA1,0XE5,0XA0,0XE5,0XC1,0XE5,0XC1,

72090XED,0XE2,0XED,0XE2,0XEE,0X03,0XF6,0X03,0XEE,0X04,0XF6,0X24,0XF6,0X45,0XF6,0X46,

72100XFE,0X66,0XFE,0X66,0XFE,0X67,0XF6,0X67,0XFE,0X87,0XFE,0XA8,0XFE,0X88,0XFE,0X89,

72110XFE,0X89,0XFE,0XA9,0XFE,0XA9,0XF6,0XC9,0XEE,0X68,0XF6,0XAC,0XA4,0X47,0X59,0XE0,

72120X49,0X81,0X49,0XA2,0X49,0XE3,0X39,0X82,0X41,0XC3,0X94,0X4F,0XFF,0X9C,0XFF,0XFF,

72130XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XF7,0X75,0XF7,0X30,

72230XFF,0X2D,0XFF,0X4B,0XFF,0X4B,0XFF,0X2B,0XFF,0X2B,0XFF,0X0B,0XFF,0X0B,0XFF,0X2B,

72240XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XF6,0XA9,0XF6,0X89,0XF6,0X89,0XEE,0X49,0XE6,0X07,

72250XE6,0X28,0XF6,0X89,0XF6,0X69,0XF6,0X48,0XEE,0X27,0XE5,0XE6,0XDD,0X83,0XD5,0X42,

72260XD5,0X21,0XD5,0X00,0XD5,0X20,0XDD,0X40,0XE5,0X61,0XE5,0X81,0XE5,0X81,0XE5,0X80,

72270XE5,0X80,0XE5,0X80,0XE5,0XA0,0XE5,0XC0,0XE5,0XE1,0XED,0XE1,0XED,0XE2,0XEE,0X02,

72280XEE,0X23,0XF6,0X24,0XF6,0X45,0XF6,0X45,0XF6,0X66,0XFE,0X87,0XFE,0X87,0XFE,0X88,

72290XFE,0X87,0XF6,0X88,0XFE,0XA8,0XFE,0XA8,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,

72300XFE,0X88,0XFE,0XA8,0XFF,0X0A,0XF6,0XAB,0XDE,0X0C,0X83,0X44,0X41,0X60,0X49,0XC2,

72310X49,0XC2,0X41,0XA2,0X4A,0X05,0XBD,0X94,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72410XFF,0XFF,0XFF,0XDE,0XFF,0XFD,0XFF,0XB9,0XF7,0X32,0XF7,0X2E,0XFF,0X0B,0XFF,0X2B,

72420XFF,0X0B,0XFF,0X2C,0XFF,0X2C,0XFF,0X0C,0XF6,0XA9,0XF6,0X88,0XEE,0X46,0XEE,0X46,

72430XEE,0X06,0XF6,0X48,0XF6,0X69,0XF6,0X49,0XEE,0X29,0XEE,0X09,0XDD,0X86,0XCD,0X04,

72440XBC,0XC1,0XC4,0XA1,0XBC,0XA0,0XC4,0XA0,0XCD,0X00,0XD5,0X40,0XDD,0X60,0XDD,0X60,

72450XE5,0X60,0XE5,0X80,0XE5,0X80,0XE5,0X80,0XE5,0X80,0XED,0XA0,0XED,0XC0,0XED,0XE1,

72460XED,0XE1,0XED,0XE2,0XEE,0X02,0XF6,0X23,0XF6,0X23,0XF6,0X44,0XF6,0X65,0XF6,0X65,

72470XF6,0X66,0XF6,0X86,0XFE,0X87,0XFE,0X87,0XFE,0XA8,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

72480XFE,0X88,0XF6,0X88,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X88,0XFE,0X88,

72490XFE,0XCA,0XF6,0XAA,0XF6,0XCD,0XB4,0XA8,0X5A,0X00,0X41,0X80,0X41,0XA1,0X41,0X82,

72500X6A,0XE9,0XE6,0XD9,0XFF,0XDE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

72600XFF,0XFC,0XF7,0X76,0XEF,0X10,0XF7,0X2D,0XFF,0X0A,0XFF,0X0A,0XFE,0XEA,0XFF,0X0C,

72610XFE,0XEC,0XFE,0XAB,0XE6,0X27,0XEE,0X25,0XE5,0XE4,0XEE,0X05,0XE5,0XC6,0XD5,0X24,

72620XC4,0X82,0XB4,0X21,0XAB,0XE1,0XA3,0XA0,0XA3,0XA0,0XA3,0XC0,0XAB,0XE0,0XB4,0X40,

72630XBC,0X80,0XCC,0XC0,0XD5,0X00,0XDD,0X40,0XDD,0X60,0XE5,0X80,0XED,0XA1,0XED,0XA1,

72640XED,0XC1,0XED,0XC1,0XED,0XC2,0XED,0XE2,0XF5,0XE2,0XF6,0X03,0XF6,0X24,0XF6,0X24,

72650XF6,0X44,0XF6,0X45,0XFE,0X65,0XFE,0X66,0XFE,0X66,0XFE,0X87,0XFE,0X87,0XF6,0X88,

72660XF6,0X88,0XFE,0X88,0XFE,0X88,0XFE,0XA9,0XFE,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

72670XFE,0X8A,0XFE,0X8A,0XFE,0XAA,0XFE,0X89,0XFE,0X89,0XFE,0X88,0XFE,0X89,0XFE,0XCB,

72680XF6,0XCC,0XE6,0X4D,0X8B,0XA5,0X49,0XA0,0X49,0XC2,0X41,0XC3,0X94,0X4F,0XFF,0X9D,

72690XFF,0XFE,0XFF,0XBE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XF7,0X55,

72790XEF,0X0E,0XF7,0X0B,0XFF,0X0A,0XFF,0X09,0XFF,0X0B,0XFE,0XCB,0XFE,0XCC,0XF6,0X6A,

72800XEE,0X26,0XDD,0XA3,0XC4,0XA0,0XB4,0X20,0XB4,0X00,0XB3,0XE0,0XAB,0XC0,0XA3,0X80,

72810X9B,0X40,0X9B,0X40,0XA3,0X80,0XAB,0XC0,0XB4,0X20,0XBC,0XA0,0XCC,0XE1,0XD5,0X01,

72820XD5,0X41,0XDD,0X61,0XE5,0X81,0XED,0XA2,0XED,0XA2,0XED,0XC2,0XED,0XE3,0XF5,0XE3,

72830XF6,0X04,0XF6,0X04,0XF6,0X25,0XF6,0X25,0XF6,0X26,0XFE,0X26,0XFE,0X47,0XFE,0X67,

72840XFE,0X67,0XFE,0X88,0XFE,0X88,0XFE,0XA9,0XFE,0XA9,0XFE,0X89,0XFE,0X89,0XFE,0X89,

72850XFE,0X89,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0X8A,0XFE,0X8A,

72860XFE,0X8A,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0XCA,0XFE,0XAA,0XEE,0X6A,0XF6,0XED,

72870XBD,0X29,0X62,0XA2,0X41,0X81,0X52,0X25,0XCD,0XF6,0XFF,0XDE,0XFF,0XDE,0XFF,0XBE,

72880XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72970XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XB9,0XEF,0X32,0XEE,0XEC,0XEE,0XE9,

72980XFE,0XE9,0XFE,0XE9,0XFF,0X0A,0XFE,0XCA,0XFE,0XEC,0XEE,0X29,0XEE,0X06,0XDD,0X63,

72990XCC,0XE2,0XBC,0X81,0XB3,0XE0,0XB4,0X00,0XB4,0X00,0XAB,0XC0,0XAB,0XA0,0XAB,0XA0,

73000XB3,0XE0,0XB4,0X00,0XBC,0X40,0XC4,0XC0,0XCC,0XE1,0XD5,0X21,0XDD,0X62,0XE5,0X82,

73010XE5,0XC2,0XED,0XE3,0XF6,0X03,0XF6,0X04,0XF6,0X24,0XF6,0X25,0XF6,0X25,0XF6,0X26,

73020XF6,0X46,0XFE,0X47,0XFE,0X47,0XFE,0X48,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,

73030XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X8A,0XFE,0X8A,

73040XFE,0X8A,0XFE,0XAA,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X69,0XFE,0X69,

73050XFE,0X89,0XFE,0X89,0XFE,0X8A,0XF6,0X69,0XF6,0XAA,0XF6,0XED,0XEE,0XAE,0XA4,0X89,

73060X39,0X60,0X6A,0XE9,0XF7,0X5B,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

73070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73160XFF,0XFF,0XFF,0XDD,0XFF,0X77,0XEE,0XF0,0XEE,0XCB,0XF6,0XE9,0XFE,0XE9,0XFE,0XC8,

73170XFF,0X0A,0XF6,0XA9,0XFE,0XAA,0XEE,0X28,0XDD,0XA6,0XC4,0XE3,0XD5,0X24,0XCC,0XE2,

73180XBC,0X81,0XBC,0X60,0XB4,0X20,0XB4,0X20,0XBC,0X40,0XBC,0X40,0XBC,0X40,0XC4,0X60,

73190XCC,0XC0,0XD5,0X00,0XDD,0X42,0XE5,0X82,0XE5,0XC3,0XED,0XE3,0XEE,0X03,0XEE,0X24,

73200XEE,0X44,0XF6,0X44,0XF6,0X45,0XF6,0X65,0XFE,0X46,0XFE,0X66,0XFE,0X67,0XFE,0X88,

73210XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0X89,

73220XFE,0X89,0XFE,0X89,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0XA9,0XFE,0X8A,0XFE,0X89,

73230XFE,0XA9,0XFE,0X88,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,

73240XF6,0X47,0XFE,0XCA,0XEE,0X8A,0XEE,0X8C,0XE6,0XAF,0XD6,0X31,0X62,0XA6,0X9C,0X8F,

73250XFF,0XDD,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFC,

73350XF7,0X34,0XEE,0XCE,0XF6,0XCB,0XFE,0XC8,0XFE,0XC8,0XFE,0XC8,0XFE,0XE9,0XFE,0XEA,

73360XF6,0X69,0XE5,0XE8,0XCD,0X25,0XBC,0X83,0XC4,0XC3,0XCD,0X04,0XD5,0X23,0XC4,0XC1,

73370XBC,0X60,0XBC,0X80,0XC4,0XA0,0XC4,0X80,0XC4,0XA0,0XD4,0XE0,0XD4,0XE0,0XDD,0X20,

73380XE5,0X82,0XED,0XE3,0XF6,0X24,0XF6,0X45,0XF6,0X45,0XF6,0X65,0XF6,0X65,0XF6,0X66,

73390XFE,0X86,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X68,0XFE,0X89,0XFE,0XA9,

73400XFE,0XA8,0XFE,0XA8,0XFE,0XA8,0XFE,0XA8,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0X89,

73410XFE,0X89,0XFE,0X89,0XFE,0XA9,0XFE,0X89,0XFE,0X8A,0XFE,0X8A,0XFE,0XA9,0XFE,0XA9,

73420XFE,0XAA,0XFE,0X8A,0XFE,0X8B,0XFE,0X6B,0XFE,0X8A,0XFE,0X8B,0XEE,0X49,0XF6,0XCC,

73430XEE,0X8C,0XE6,0X8E,0XE6,0X71,0XE6,0XB4,0XC5,0XB2,0XDE,0XB8,0XFF,0XFE,0XFF,0XFE,

73440XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XDA,0XEE,0XF1,0XE6,0X8C,

73540XF6,0XCA,0XF6,0XA8,0XFE,0XA9,0XFE,0XC9,0XFE,0XA8,0XFE,0XC9,0XEE,0X08,0XE5,0XC8,

73550XBC,0XA4,0XB4,0X22,0XB4,0X42,0XC4,0XA3,0XCC,0XE3,0XCD,0X03,0XCC,0XE2,0XC4,0XC0,

73560XC4,0XC0,0XCC,0XE0,0XD5,0X20,0XDD,0X40,0XED,0X81,0XED,0XA2,0XF5,0XE3,0XF6,0X04,

73570XFE,0X45,0XFE,0X66,0XFE,0X67,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X89,

73580XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0XA8,0XFE,0XA8,

73590XFE,0XA8,0XFE,0XA8,0XF6,0XA9,0XF6,0XA9,0XF6,0XAA,0XF6,0XAA,0XF6,0XAA,0XF6,0X8A,

73600XF6,0XAA,0XF6,0X8A,0XF6,0X8B,0XF6,0XAB,0XEE,0X8A,0XEE,0X8B,0XEE,0X8B,0XEE,0X8C,

73610XEE,0X6D,0XEE,0X6E,0XEE,0X6E,0XEE,0X8F,0XF7,0X11,0XE6,0XB0,0XEE,0XB2,0XF7,0X35,

73620XFF,0XB9,0XF7,0X58,0XFF,0XDC,0XFF,0XBC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73720XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XF7,0X76,0XE6,0XAF,0XE6,0X6B,0XF6,0XAA,0XF6,0X88,

73730XFE,0X89,0XFE,0XAA,0XFE,0XC9,0XFE,0XA9,0XE5,0XE8,0XCD,0X26,0XA3,0XE2,0XA3,0XE2,

73740XAC,0X03,0XAC,0X23,0XB4,0X42,0XC4,0XA3,0XCD,0X03,0XCD,0X22,0XD5,0X21,0XD5,0X20,

73750XDD,0X60,0XE5,0XC1,0XED,0XC1,0XF5,0XE2,0XFE,0X24,0XFE,0X45,0XFE,0X66,0XFE,0X67,

73760XFE,0X68,0XFE,0X68,0XFE,0XA9,0XFE,0XA9,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,

73770XFE,0X69,0XFE,0X69,0XFE,0X89,0XF6,0X89,0XF6,0X89,0XF6,0X89,0XF6,0X89,0XF6,0X8A,

73780XEE,0X8A,0XEE,0X8A,0XEE,0XAB,0XEE,0X8C,0XEE,0X8C,0XEE,0X8D,0XEE,0X8D,0XEE,0X8D,

73790XEE,0X8D,0XE6,0X8D,0XE6,0X8E,0XE6,0XAF,0XEE,0XD1,0XF7,0X12,0XF7,0X34,0XFF,0X55,

73800XFF,0X97,0XFF,0XB8,0XFF,0XFA,0XFF,0XDA,0XFF,0XDA,0XFF,0XFC,0XFF,0XFD,0XFF,0XFD,

73810XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

73910XFF,0XDA,0XEE,0XD2,0XE6,0X8D,0XEE,0X8A,0XF6,0XA9,0XFE,0XA9,0XF6,0X69,0XFE,0X89,

73920XF6,0X68,0XEE,0X48,0XDD,0XC8,0XB4,0XA4,0X9B,0XC3,0XA3,0XE3,0XA3,0XE3,0X9B,0XC3,

73930XA3,0XE3,0XAC,0X23,0XBC,0X83,0XC4,0XC3,0XCD,0X02,0XCD,0X41,0XD5,0X61,0XE5,0XC2,

73940XED,0XC2,0XF5,0XE3,0XFE,0X44,0XFE,0X86,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X89,

73950XFE,0X89,0XF6,0X89,0XFE,0X89,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XF6,0XAA,

73960XF6,0XAA,0XF6,0XAB,0XEE,0XAB,0XEE,0XAC,0XEE,0XAD,0XEE,0XAD,0XEE,0XAE,0XEE,0XAF,

73970XE6,0X8F,0XE6,0X8F,0XE6,0XB1,0XEE,0XD2,0XF7,0X13,0XFF,0X34,0XFF,0X74,0XFF,0X76,

73980XFF,0XB9,0XFF,0XBA,0XFF,0XBB,0XFF,0XDB,0XFF,0XDC,0XFF,0XDC,0XFF,0XFD,0XFF,0XFE,

73990XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XDE,0XFF,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XD8,0XE6,0X8F,

74100XE6,0X6C,0XF6,0X8A,0XF6,0X68,0XFE,0X89,0XF6,0X69,0XFE,0X8A,0XF6,0X89,0XEE,0X49,

74110XCD,0X67,0X93,0XA1,0X8B,0X61,0X8B,0X62,0X93,0X83,0X93,0XC3,0X9B,0XC3,0XA3,0XE3,

74120XA4,0X02,0XAC,0X22,0XB4,0X82,0XC4,0XE2,0XCD,0X43,0XD5,0X63,0XE5,0XC3,0XEE,0X04,

74130XFE,0X46,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0XAA,0XF6,0XAA,0XF6,0X8B,

74140XF6,0X8B,0XEE,0X8B,0XEE,0X8B,0XEE,0X6B,0XEE,0X6B,0XEE,0X6C,0XEE,0X8C,0XEE,0XAD,

74150XEE,0XAE,0XEE,0XD0,0XEE,0XD1,0XF7,0X12,0XF7,0X13,0XF7,0X34,0XFF,0X76,0XFF,0X77,

74160XFF,0X98,0XFF,0X98,0XFF,0XB9,0XFF,0XBA,0XFF,0XDA,0XFF,0XDB,0XFF,0XFD,0XFF,0XFE,

74170XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XFF,0X75,0XDE,0X4C,0XEE,0X4B,0XF6,0X6A,

74290XEE,0X48,0XF6,0X88,0XF6,0X68,0XF6,0X89,0XEE,0X69,0XE6,0X29,0XB4,0X84,0X83,0X20,

74300X83,0X21,0X83,0X21,0X83,0X42,0X8B,0X62,0X93,0X83,0X93,0X82,0X93,0X82,0X9B,0XC2,

74310XA3,0XE2,0XA3,0XE1,0XAC,0X42,0XC4,0XE3,0XD5,0X64,0XE5,0XE5,0XF6,0X68,0XFE,0XA9,

74320XFE,0XAA,0XF6,0X8A,0XF6,0X8B,0XF6,0X8C,0XEE,0X8C,0XEE,0X8D,0XEE,0X8E,0XEE,0X8F,

74330XEE,0XB0,0XEE,0XD1,0XF6,0XF2,0XF7,0X13,0XF7,0X34,0XFF,0X55,0XFF,0X76,0XFF,0X97,

74340XFF,0XB8,0XFF,0XD9,0XFF,0XFA,0XFF,0XFB,0XFF,0XFB,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,

74350XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFF,

74360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XDE,0XFF,0XFF,0XF7,0XDE,0XFF,0XFF,

74370XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74470XFF,0XFF,0XFF,0XFB,0XEE,0XF1,0XDE,0X2A,0XE6,0X2A,0XF6,0X6A,0XF6,0X48,0XF6,0X68,

74480XF6,0X68,0XEE,0X48,0XE6,0X09,0XCD,0X87,0X93,0XA1,0X7B,0X00,0X83,0X20,0X8B,0X82,

74490X93,0XE3,0X9C,0X04,0XA4,0X24,0XA4,0X45,0XA4,0X45,0XAC,0X45,0XAC,0X44,0XAC,0X44,

74500XB4,0X64,0XBC,0XA4,0XC5,0X24,0XD5,0XA6,0XE6,0X28,0XEE,0X8A,0XEE,0X8A,0XEE,0X8B,

74510XF6,0XAC,0XF6,0XCD,0XFF,0X30,0XFF,0X31,0XFF,0X53,0XFF,0X74,0XFF,0X95,0XFF,0X97,

74520XFF,0XB8,0XFF,0XB9,0XFF,0XB9,0XFF,0XDA,0XFF,0XDB,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,

74530XFF,0XFC,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

74540XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

74550XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

74560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XBD,0XFF,0XDA,

74660XD6,0X0C,0XE6,0X49,0XEE,0X2A,0XF6,0X29,0XF6,0X28,0XF6,0X48,0XF6,0X68,0XF6,0X68,

74670XF6,0XCB,0XE6,0X4A,0XD5,0XE9,0XD5,0XE9,0XDE,0X4B,0XEE,0XAD,0XEE,0XED,0XEE,0XED,

74680XF7,0X0D,0XF7,0X0E,0XF7,0X0E,0XF7,0X0E,0XF6,0XEE,0XFF,0X0E,0XFE,0XED,0XF6,0XEC,

74690XF6,0XEB,0XFF,0X0C,0XFF,0X4D,0XFF,0X6D,0XFF,0X4E,0XFF,0X4E,0XFF,0X6F,0XFF,0X70,

74700XFF,0X91,0XFF,0X93,0XFF,0XB5,0XFF,0XD6,0XFF,0XD8,0XFF,0XF9,0XFF,0XFA,0XFF,0XFB,

74710XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

74720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFE,

74730XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74740XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

74840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XBC,0XFF,0X97,0XD6,0X0B,0XE6,0X28,

74850XEE,0X29,0XEE,0X29,0XF6,0X28,0XF6,0X47,0XF6,0X67,0XF6,0X68,0XFF,0X0C,0XFF,0X0C,

74860XFE,0XED,0XF6,0XEC,0XF6,0XCC,0XEE,0XAB,0XEE,0XAA,0XE6,0XAA,0XE6,0X69,0XE6,0X6A,

74870XE6,0X6A,0XE6,0X4A,0XE6,0X4A,0XE6,0X4A,0XE6,0X4A,0XE6,0X49,0XEE,0X8A,0XEE,0XAA,

74880XEE,0XCB,0XF6,0XCB,0XF6,0XCB,0XFF,0X0C,0XFF,0X2E,0XFF,0X4F,0XFF,0X91,0XFF,0X91,

74890XFF,0X72,0XFF,0X54,0XFF,0X55,0XFF,0X76,0XFF,0XB8,0XFF,0XD9,0XFF,0XDA,0XFF,0XFC,

74900XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

74910XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,

74920XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

74930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,

75030XFF,0XDF,0XFF,0XBE,0XFF,0XDB,0XE6,0X92,0XDE,0X0A,0XE6,0X28,0XEE,0X28,0XEE,0X28,

75040XEE,0X28,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X48,0XEE,0X49,0XEE,0X49,0XEE,0X49,

75050XEE,0X49,0XE6,0X49,0XEE,0X68,0XEE,0X68,0XEE,0X68,0XEE,0X68,0XEE,0X68,0XEE,0X49,

75060XEE,0X49,0XEE,0X49,0XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

75070XEE,0X28,0XEE,0X28,0XEE,0X29,0XEE,0X49,0XEE,0X4A,0XF6,0X8B,0XFE,0XCD,0XFF,0X0F,

75080XFF,0X30,0XFF,0X31,0XFF,0X32,0XFF,0X32,0XEF,0X54,0XF7,0X95,0XFF,0XB7,0XFF,0XFA,

75090XFF,0XFB,0XFF,0XFC,0XFF,0XDD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

75100XFF,0XFF,0XFF,0XDE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

75110XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

75120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75210XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,

75220XFF,0X99,0XD5,0XEE,0XDE,0X09,0XE6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

75230XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X48,0XEE,0X48,0XEE,0X48,

75240XEE,0X47,0XEE,0X47,0XEE,0X67,0XEE,0X47,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X28,

75250XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X28,0XF6,0X28,

75260XEE,0X08,0XEE,0X07,0XEE,0X28,0XEE,0X28,0XE6,0X09,0XE6,0X09,0XE6,0X2A,0XEE,0X6B,

75270XF6,0XAD,0XF7,0X0E,0XEF,0X2F,0XF7,0X71,0XF7,0X93,0XEF,0X53,0XEF,0X55,0XFF,0X98,

75280XFF,0XDA,0XFF,0XDB,0XFF,0XFD,0XFF,0XFD,0XFF,0XDE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFF,

75290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75300XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75400XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XBD,0XF7,0X15,0XD5,0XEC,

75410XE6,0X09,0XE6,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

75420XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X48,0XEE,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X67,

75430XEE,0X47,0XEE,0X47,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X47,0XEE,0X47,

75440XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

75450XE6,0X07,0XE6,0X27,0XE6,0X28,0XE6,0X28,0XE6,0X29,0XE6,0X29,0XE6,0X29,0XE6,0X49,

75460XDE,0X4A,0XDE,0X6A,0XEE,0XCC,0XF7,0X2F,0XFF,0X71,0XF7,0X31,0XF7,0X33,0XF7,0X55,

75470XFF,0X78,0XFF,0XDA,0XFF,0XDC,0XFF,0XDD,0XFF,0XDD,0XFF,0XFE,0XFF,0XDE,0XFF,0XDF,

75480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75590XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XBB,0XE6,0X91,0XD5,0XEB,0XE6,0X08,0XE6,0X07,

75600XE6,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X47,

75610XEE,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X27,

75620XEE,0X28,0XEE,0X48,0XEE,0X48,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,

75630XEE,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X28,

75640XEE,0X28,0XE6,0X28,0XE6,0X28,0XE6,0X28,0XE6,0X48,0XE6,0X48,0XE6,0X48,0XE6,0X48,

75650XDE,0X28,0XDE,0X28,0XE6,0X6A,0XF6,0XED,0XFF,0X30,0XFF,0X52,0XF7,0X13,0XF7,0X56,

75660XFF,0X98,0XFF,0XBA,0XFF,0XDC,0XFF,0XDD,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,

75780XFF,0XDD,0XFF,0X79,0XDE,0X4F,0XD5,0XEA,0XE6,0X08,0XE6,0X07,0XE6,0X08,0XE6,0X28,

75790XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,

75800XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,

75810XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X27,0XEE,0X27,

75820XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X48,

75830XEE,0X48,0XEE,0X28,0XEE,0X08,0XE6,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X06,0XE6,0X27,

75840XEE,0X28,0XE6,0X29,0XE6,0X4B,0XE6,0X6C,0XEE,0XF0,0XF7,0X32,0XF7,0X33,0XEF,0X35,

75850XF7,0X97,0XFF,0XFB,0XFF,0XFC,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75860XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75960XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFE,0XFF,0XDB,0XEE,0XF4,

75970XD5,0XEC,0XDE,0X0A,0XE6,0X08,0XE6,0X07,0XE6,0X08,0XEE,0X08,0XE6,0X27,0XEE,0X27,

75980XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X08,0XEE,0X07,0XEE,0X27,

75990XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X27,

76000XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76010XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE5,0XE7,0XE5,0XE7,0XEE,0X07,

76020XEE,0X08,0XEE,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XE5,0XE6,0XE5,0XC6,0XE5,0XE7,

76030XE6,0X29,0XE6,0X4A,0XDE,0X0A,0XEE,0X8D,0XF7,0X10,0XF7,0X52,0XF7,0X53,0XEF,0X34,

76040XF7,0X97,0XFF,0XDA,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

76050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76150XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFA,0XDE,0X91,0XCD,0XCA,0XDD,0XE8,

76160XE6,0X08,0XE6,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X27,0XEE,0X27,

76170XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

76180XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76190XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76200XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76210XED,0XE6,0XED,0XE6,0XF6,0X07,0XF6,0X27,0XF6,0X28,0XEE,0X07,0XE6,0X07,0XE6,0X07,

76220XE6,0X08,0XDD,0XE8,0XDD,0XE9,0XE6,0X6B,0XFF,0X0F,0XFF,0X72,0XFF,0X72,0XF7,0X33,

76230XFF,0XF9,0XFF,0XFB,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

76250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

76340XFF,0XDE,0XFF,0XFC,0XF7,0X97,0XCE,0X0D,0XD5,0XE9,0XDE,0X08,0XE6,0X08,0XED,0XE7,

76350XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X26,0XEE,0X07,0XEE,0X27,

76360XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76370XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

76380XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76390XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

76400XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X27,0XE6,0X27,

76410XE6,0X28,0XE6,0X08,0XE6,0X09,0XEE,0X6B,0XFF,0X0F,0XFF,0X92,0XF7,0X33,0XFF,0XD7,

76420XFF,0XFA,0XFF,0XBB,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76430XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFE,0XFF,0XDB,

76530XEF,0X14,0XCD,0XCB,0XD5,0XE8,0XE6,0X08,0XE5,0XE8,0XED,0XE7,0XEE,0X07,0XEE,0X07,

76540XE6,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

76550XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76560XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

76570XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76580XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

76590XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X07,0XE6,0X07,0XE6,0X07,

76600XE5,0XE8,0XE6,0X09,0XEE,0X4B,0XF6,0X8D,0XFF,0X51,0XF7,0X52,0XFF,0X95,0XFF,0XD9,

76610XFF,0XFB,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

76620XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XBE,0XFF,0XFE,0XFF,0XBA,0XDE,0XB1,0XCD,0XEB,

76720XD5,0XC8,0XE6,0X07,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X08,

76730XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76740XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76750XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76760XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76770XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

76780XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X08,0XE5,0XE8,

76790XE5,0XC8,0XE5,0XE9,0XE6,0X6B,0XF7,0X2F,0XFF,0X92,0XFF,0X74,0XFF,0X97,0XFF,0XDB,

76800XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

76810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76900XFF,0XFF,0XFF,0XDE,0XFF,0XDD,0XF7,0X77,0XD6,0X0D,0XD5,0XE9,0XD5,0XC7,0XE6,0X08,

76910XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X08,0XEE,0X07,0XEE,0X07,

76920XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76930XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76940XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76950XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76960XEE,0X27,0XE6,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

76970XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XED,0XE7,0XED,0XC8,0XED,0XC8,0XEE,0X08,

76980XDD,0XC7,0XE6,0X49,0XF6,0XED,0XFF,0X51,0XFF,0X74,0XFF,0X97,0XFF,0XDB,0XFF,0XFD,

76990XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

77090XFF,0XBB,0XEE,0XF5,0XCD,0XEB,0XD5,0XA8,0XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,

77100XE6,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

77110XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77120XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77130XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77140XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77150XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,

77160XEE,0X06,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XED,0XE7,0XED,0XE7,0XEE,0X27,0XDD,0XE6,

77170XDE,0X08,0XF6,0XCD,0XFF,0X51,0XFF,0X74,0XFF,0X97,0XFF,0XDA,0XFF,0XFC,0XFF,0XFD,

77180XFF,0XFE,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBB,0XDE,0X72,

77280XD5,0XCA,0XD5,0XC7,0XE6,0X08,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

77290XE6,0X08,0XE6,0X08,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

77300XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77310XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77320XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77330XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,

77340XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X06,

77350XED,0XE6,0XED,0XE6,0XEE,0X06,0XEE,0X07,0XE5,0XC6,0XF6,0X69,0XE6,0X28,0XD5,0XC7,

77360XEE,0X8C,0XFF,0X30,0XFF,0X53,0XFF,0X95,0XFF,0XD8,0XFF,0XFA,0XFF,0XFD,0XFF,0XFE,

77370XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0X99,0XCD,0XCE,0XCD,0XA9,0XDD,0XE7,

77470XE5,0XE8,0XE5,0XA7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X08,

77480XED,0XE7,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,

77490XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77500XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77510XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77520XEE,0X27,0XEE,0X28,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,

77530XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X06,0XE6,0X06,0XEE,0X06,0XEE,0X27,

77540XEE,0X27,0XE5,0XE6,0XF6,0X48,0XDD,0XA6,0XEE,0X07,0XEE,0X48,0XD5,0XC7,0XE6,0X4A,

77550XFF,0X50,0XF7,0X51,0XFF,0X94,0XFF,0XD8,0XFF,0XFB,0XFF,0XFD,0XFF,0XDF,0XFF,0XDF,

77560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77650XFF,0XFF,0XFF,0XDC,0XF7,0X17,0XC5,0X8C,0XD5,0XC8,0XE5,0XE7,0XE5,0XC7,0XE5,0XC7,

77660XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X08,0XED,0XE7,0XEE,0X07,

77670XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

77680XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77690XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77700XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,

77710XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

77720XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,

77730XEE,0X07,0XEE,0X07,0XE5,0XE7,0XE5,0XE7,0XE6,0X08,0XDD,0XE7,0XDE,0X29,0XF6,0XED,

77740XF7,0X30,0XFF,0XB4,0XFF,0XD8,0XFF,0XDC,0XFF,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

77750XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBB,

77840XDE,0X52,0XC5,0X4B,0XDD,0XE9,0XE5,0XE7,0XE5,0XC7,0XED,0XE8,0XE5,0XE7,0XE5,0XE7,

77850XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

77860XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

77870XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77880XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X27,

77890XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77900XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

77910XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE5,0XE7,0XEE,0X07,

77920XE5,0XE7,0XE6,0X07,0XEE,0X07,0XE5,0XE7,0XDE,0X07,0XE6,0X69,0XF6,0XED,0XEF,0X10,

77930XEF,0X34,0XFF,0XB9,0XFF,0XFD,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77940XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XBA,0XC5,0X8E,0XCD,0X6B,

78030XE6,0X09,0XE5,0XC7,0XE5,0XC7,0XED,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,

78040XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,

78050XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

78060XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

78070XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

78080XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X07,

78090XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

78100XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X06,0XEE,0X06,0XE6,0X06,0XE6,0X07,

78110XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X28,0XDE,0X28,0XF7,0X0E,0XEE,0XD0,0XE6,0XD3,

78120XFF,0XBA,0XFF,0XFD,0XFF,0XDD,0XFF,0XDE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78130XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78210XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XF7,0X17,0XBD,0X4C,0XD5,0XCB,0XDD,0XC8,0XE5,0XC7,

78220XE5,0XC7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,

78230XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

78240XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

78250XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

78260XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X28,0XEE,0X28,

78270XEE,0X28,0XEE,0X28,0XE6,0X28,0XE6,0X28,0XE6,0X28,0XE6,0X27,0XEE,0X07,0XEE,0X07,

78280XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

78290XEE,0X07,0XEE,0X26,0XEE,0X26,0XE6,0X26,0XE6,0X06,0XE6,0X07,0XEE,0X07,0XEE,0X27,

78300XEE,0X27,0XE6,0X07,0XE6,0X07,0XE6,0X4A,0XEE,0XAE,0XDE,0X4F,0XE6,0XB3,0XFF,0XBA,

78310XFF,0XDC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

78400XFF,0XFC,0XD6,0X11,0XC5,0X6B,0XDD,0XEA,0XDD,0XA8,0XE5,0XC7,0XEE,0X08,0XE5,0XC7,

78410XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

78420XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

78430XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

78440XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

78450XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

78460XE6,0X27,0XE6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,

78470XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

78480XE6,0X26,0XE6,0X25,0XEE,0X26,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE5,0XE6,

78490XEE,0X27,0XDD,0XC7,0XE6,0X6A,0XEE,0X8D,0XC5,0X8C,0XDE,0X72,0XFF,0XDA,0XFF,0XDC,

78500XFF,0XFD,0XFF,0XDD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XDA,0XBD,0X4D,

78590XCD,0XAB,0XDD,0XC9,0XDD,0XC8,0XDD,0XA7,0XEE,0X28,0XE5,0XE7,0XE5,0XE8,0XE5,0XE8,

78600XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

78610XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,

78620XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

78630XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

78640XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

78650XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,

78660XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X26,0XE6,0X26,

78670XEE,0X27,0XEE,0X27,0XEE,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XE5,0XE6,0XEE,0X48,

78680XE6,0X07,0XE6,0X4A,0XDE,0X2C,0XAC,0XC9,0XD6,0X32,0XFF,0X99,0XFF,0XFD,0XFF,0XDD,

78690XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

78700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

78770XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XF7,0X16,0XBD,0X4C,0XD5,0XCA,0XD5,0XC8,

78780XE6,0X09,0XDD,0XC7,0XE6,0X07,0XE5,0XE7,0XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,

78790XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,

78800XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

78810XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

78820XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

78830XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,

78840XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

78850XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X26,0XE6,0X07,0XE6,0X07,

78860XE6,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XE6,0X06,0XEE,0X27,0XE6,0X28,

78870XE6,0X2A,0XCD,0XCB,0X8B,0XC6,0XD6,0X53,0XFF,0XDB,0XFF,0XFD,0XFF,0XFE,0XFF,0XDE,

78880XF7,0XBE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XFF,0XFF,

78960XFF,0XFE,0XFF,0XDC,0XCD,0XF0,0XC5,0X6B,0XCD,0XA8,0XD5,0XA7,0XE5,0XE8,0XE5,0XE8,

78970XDD,0XC7,0XDD,0XE7,0XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,

78980XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

78990XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

79000XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

79010XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

79020XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

79030XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,

79040XEE,0X27,0XEE,0X07,0XEE,0X06,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XEE,0X28,0XEE,0X28,

79050XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X06,0XEE,0X26,0XE6,0X26,0XE6,0X28,0XDE,0X2A,

79060XCD,0X8B,0X73,0X04,0XDE,0XB6,0XF7,0X9B,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

79070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0X99,

79150XC5,0X6C,0XD5,0XCA,0XDD,0XC8,0XDD,0XC8,0XE5,0XE8,0XE5,0XE8,0XE5,0XE8,0XE5,0XE8,

79160XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,

79170XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X07,0XEE,0X08,0XEE,0X28,

79180XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

79190XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

79200XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,

79210XEE,0X08,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

79220XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

79230XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X08,0XEE,0X08,0XEE,0X09,0XEE,0X08,

79240XEE,0X07,0XEE,0X07,0XEE,0X05,0XEE,0X26,0XEE,0X27,0XE6,0X09,0XCD,0X89,0XAC,0XA8,

79250X73,0X05,0XD6,0X74,0XFF,0XBC,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XFF,0XFF,

79260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79330XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFC,0XE6,0XD4,0XBD,0X4A,0XD5,0XA8,

79340XDD,0XC8,0XE5,0XE7,0XE5,0XE7,0XED,0XE7,0XE5,0XE8,0XE5,0XC8,0XE5,0XE8,0XE5,0XE7,

79350XE6,0X07,0XE5,0XE6,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

79360XEE,0X07,0XEE,0X08,0XEE,0X28,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X28,

79370XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XE6,0X27,0XE6,0X27,0XEE,0X48,0XEE,0X27,

79380XEE,0X28,0XEE,0X27,0XEE,0X07,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,

79390XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X27,

79400XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X07,

79410XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,

79420XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X09,0XEE,0X08,0XEE,0X08,0XEE,0X07,

79430XEE,0X06,0XEE,0X26,0XEE,0X07,0XE6,0X08,0XDD,0XC9,0XC5,0X29,0X72,0XE2,0X83,0XA8,

79440XE6,0X96,0XFF,0XBD,0XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79520XFF,0XDF,0XFF,0XFE,0XFF,0XDB,0XD6,0X31,0XC5,0X89,0XD5,0XE8,0XDD,0XE7,0XDD,0XE6,

79530XE5,0XE6,0XE5,0XC6,0XDD,0XC7,0XDD,0XC7,0XDD,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

79540XE6,0X07,0XE6,0X08,0XE6,0X08,0XE6,0X08,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

79550XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X28,0XEE,0X28,

79560XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

79570XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

79580XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

79590XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X07,

79600XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X07,0XEE,0X27,0XEE,0X27,

79610XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X06,

79620XEE,0X07,0XEE,0X08,0XE6,0X09,0XD5,0XAA,0XA4,0X87,0X5A,0X62,0X94,0X0B,0XEE,0XF9,

79630XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XFF,0XDF,0XFF,0XDE,

79710XF7,0X58,0XBD,0X8D,0XCD,0XA9,0XD5,0XE7,0XDD,0XE6,0XDD,0XE6,0XE5,0XC6,0XE5,0XC6,

79720XE5,0XE7,0XE5,0XE8,0XDD,0XE7,0XDD,0XE7,0XDD,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE8,

79730XE6,0X08,0XE6,0X08,0XE6,0X08,0XE6,0X07,0XE6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,

79740XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

79750XF6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X48,0XEE,0X48,

79760XEE,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,

79770XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

79780XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

79790XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X27,0XEE,0X26,0XEE,0X26,0XEE,0X27,

79800XEE,0X27,0XEE,0X28,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,

79810XE6,0X08,0XD5,0XC9,0XC5,0X49,0X83,0X64,0X52,0X22,0XA4,0XCF,0XFF,0XBC,0XFF,0XFE,

79820XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79890XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDD,0XDE,0XB4,0XBD,0X6B,

79900XCD,0XA9,0XDD,0XE7,0XDD,0XE6,0XE5,0XE6,0XE5,0XE6,0XE5,0XC6,0XE5,0XE7,0XE5,0XE8,

79910XE5,0XE8,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

79920XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X27,0XEE,0X27,0XEE,0X27,

79930XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,

79940XEE,0X28,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X48,

79950XEE,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

79960XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

79970XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

79980XEE,0X08,0XEE,0X28,0XEE,0X27,0XEE,0X26,0XEE,0X46,0XEE,0X46,0XEE,0X27,0XEE,0X27,

79990XEE,0X28,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X28,0XE6,0X08,0XDD,0XE8,

80000XC5,0X68,0X8B,0XC4,0X62,0X82,0X62,0XC6,0XB5,0X72,0XFF,0XDD,0XFF,0XDD,0XFF,0XFE,

80010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80080XFF,0XDF,0XFF,0XFF,0XFF,0XDE,0XFF,0X9B,0XCD,0XF0,0XBD,0X6A,0XCD,0XA7,0XDD,0XC6,

80090XDD,0XA5,0XDD,0XA4,0XE5,0XC5,0XE5,0XC5,0XE5,0XC6,0XE5,0XE7,0XE5,0XC6,0XDD,0XE6,

80100XE5,0XE6,0XE5,0XE6,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,

80110XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,

80120XEE,0X28,0XEE,0X28,0XEE,0X28,0XF6,0X08,0XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X47,

80130XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

80140XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

80150XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

80160XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X08,0XEE,0X08,

80170XEE,0X27,0XEE,0X26,0XEE,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X08,

80180XF6,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XE6,0X07,0XE6,0X49,0XD5,0XA8,0XBD,0X28,

80190X6A,0XC2,0X41,0XA0,0X62,0XE7,0XF7,0X9B,0XF7,0XBC,0XFF,0XDE,0XFF,0XFE,0XFF,0XFF,

80200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

80270XFF,0XBD,0XEF,0X38,0XC5,0XCE,0XC5,0X8A,0XDE,0X08,0XEE,0X27,0XEE,0X26,0XF6,0X26,

80280XFE,0X46,0XFE,0X67,0XFE,0X88,0XFE,0X88,0XFE,0XA9,0XFE,0XA8,0XFE,0XA8,0XFE,0XA9,

80290XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0X69,0XFE,0X69,0XFE,0X8A,0XFE,0XAA,

80300XFE,0X8A,0XF6,0X69,0XEE,0X49,0XEE,0X28,0XE6,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X29,

80310XEE,0X28,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XF6,0X47,

80320XF6,0X48,0XF6,0X48,0XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X28,

80330XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

80340XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

80350XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X26,

80360XEE,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XF6,0X27,0XEE,0X27,

80370XEE,0X27,0XEE,0X27,0XEE,0X28,0XF6,0X6A,0XDD,0XE8,0XC5,0X47,0X8B,0XA4,0X5A,0X41,

80380X49,0XE3,0X7B,0XCB,0XFF,0XBC,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFD,0XF7,0X58,

80460XDE,0X92,0XDE,0X6E,0XEE,0X6B,0XF6,0X8A,0XFE,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0X89,

80470XFE,0X88,0XF6,0X68,0XFE,0X88,0XF6,0X88,0XF6,0X67,0XF6,0X47,0XF6,0X27,0XEE,0X06,

80480XED,0XE6,0XED,0XC6,0XE5,0XA5,0XE5,0X85,0XE5,0X86,0XE5,0X86,0XE5,0XA6,0XDD,0XC7,

80490XE5,0XC8,0XE5,0XE8,0XE6,0X29,0XEE,0X2A,0XEE,0X4A,0XEE,0X4A,0XEE,0X4A,0XEE,0X4A,

80500XEE,0X2A,0XEE,0X29,0XEE,0X48,0XEE,0X47,0XE6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

80510XF6,0X48,0XF6,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X08,0XF6,0X08,0XEE,0X28,0XEE,0X27,

80520XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

80530XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

80540XEE,0X28,0XEE,0X28,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X26,0XEE,0X26,0XEE,0X27,

80550XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XF6,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X27,

80560XEE,0X08,0XF6,0X6A,0XE5,0XE8,0XCD,0X87,0X9C,0X25,0X62,0X61,0X52,0X23,0X5A,0X86,

80570XBD,0XD4,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0X9A,0XF7,0X36,0XEE,0XD2,

80650XEE,0X8F,0XEE,0X6D,0XEE,0X6C,0XF6,0X6B,0XF6,0X4A,0XF6,0X4A,0XEE,0X49,0XEE,0X49,

80660XEE,0X48,0XEE,0X27,0XF6,0X26,0XED,0XE6,0XED,0XC6,0XED,0XC6,0XED,0XA5,0XE5,0XA4,

80670XDD,0X63,0XDD,0X23,0XD5,0X03,0XCC,0XC2,0XC4,0XA2,0XBC,0X82,0XAC,0X42,0XAC,0X22,

80680XA4,0X22,0XAC,0X43,0XB4,0X84,0XBC,0XC5,0XC5,0X27,0XD5,0X88,0XDD,0XE9,0XE6,0X09,

80690XE6,0X29,0XEE,0X8A,0XEE,0X89,0XEE,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X06,0XEE,0X27,

80700XF6,0X27,0XF6,0X27,0XF6,0X07,0XEE,0X08,0XF6,0X48,0XEE,0X27,0XEE,0X07,0XEE,0X27,

80710XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

80720XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

80730XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

80740XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X48,

80750XEE,0X28,0XD5,0XA7,0XB4,0XA6,0X72,0XC2,0X52,0X02,0X49,0XE3,0X7B,0XAC,0XE7,0X1A,

80760XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80830XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0X9A,0XFF,0X78,0XFF,0X56,0XFF,0X34,

80840XF6,0XF2,0XF6,0XB0,0XF6,0X8E,0XEE,0X4D,0XEE,0X4C,0XEE,0X4B,0XEE,0X6A,0XF6,0X49,

80850XF6,0X48,0XF6,0X27,0XF6,0X07,0XF6,0X07,0XF6,0X06,0XED,0XE5,0XED,0XE5,0XED,0XC5,

80860XE5,0X85,0XD5,0X45,0XCD,0X05,0XBC,0XC4,0XB4,0X84,0XAC,0X64,0X9C,0X03,0X93,0XC3,

80870X8B,0X82,0X8B,0X82,0X83,0X41,0X83,0X21,0X8B,0XA2,0XA4,0X44,0XB4,0XC5,0XC5,0X67,

80880XDE,0X09,0XEE,0X6A,0XEE,0X8A,0XEE,0X49,0XEE,0X27,0XED,0XE6,0XF6,0X27,0XEE,0X27,

80890XF6,0X48,0XF6,0X47,0XED,0XE6,0XEE,0X27,0XF6,0X68,0XEE,0X27,0XEE,0X27,0XEE,0X27,

80900XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X27,0XEE,0X27,

80910XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

80920XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

80930XEE,0X27,0XEE,0X27,0XEE,0X27,0XF6,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X48,0XDD,0XE7,

80940XC5,0X28,0X72,0XE1,0X52,0X22,0X4A,0X04,0X52,0X66,0XB5,0X94,0XFF,0XDD,0XFF,0XFE,

80950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,

81020XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDD,0XFF,0XDC,0XFF,0XBA,0XFF,0X99,0XFF,0X77,

81030XFF,0X35,0XF6,0XF2,0XEE,0XD0,0XEE,0XAE,0XEE,0X8C,0XEE,0X6B,0XEE,0X49,0XEE,0X28,

81040XF6,0X28,0XF6,0X27,0XF6,0X26,0XEE,0X26,0XF6,0X27,0XEE,0X28,0XEE,0X28,0XE5,0XE8,

81050XDD,0XA8,0XCD,0X48,0XBD,0X08,0XB4,0XE8,0XB4,0XC8,0XAC,0X88,0X9C,0X06,0X8B,0XA5,

81060X83,0X84,0X83,0X84,0X73,0X22,0X62,0X80,0X6A,0XA0,0X6A,0XC0,0X8B,0X83,0XAC,0X86,

81070XCD,0X69,0XE6,0X0A,0XF6,0X6B,0XF6,0X6A,0XEE,0X07,0XEE,0X47,0XF6,0X46,0XEE,0X46,

81080XEE,0X26,0XEE,0X46,0XEE,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

81090XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X28,

81100XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

81110XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

81120XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X28,0XF6,0X48,0XE6,0X08,0XC5,0X48,0X83,0X43,

81130X52,0X21,0X52,0X23,0X39,0XA3,0X83,0XCC,0XEF,0X5A,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

81140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFE,0XFF,0XDF,

81210XFF,0XBF,0XFF,0XBF,0XFF,0XDF,0XFF,0XDE,0XFF,0XDD,0XFF,0XDC,0XFF,0XDA,0XFF,0XB8,

81220XFF,0X96,0XFF,0X74,0XF7,0X11,0XF6,0XEF,0XF6,0XAE,0XEE,0X6C,0XEE,0X4B,0XEE,0X2A,

81230XEE,0X29,0XEE,0X29,0XE6,0X29,0XE6,0X2A,0XE6,0X2B,0XDE,0X0B,0XD5,0XCB,0XCD,0X8B,

81240XC5,0X4B,0XBD,0X4C,0XB4,0XEB,0XA4,0XAB,0XA4,0XAB,0XA4,0XCB,0XA4,0X8B,0X8C,0X08,

81250X83,0X87,0X83,0X87,0X6A,0XE4,0X62,0X82,0X52,0X00,0X51,0XE0,0X6A,0X81,0X8B,0X84,

81260XBC,0XE8,0XE6,0X0B,0XEE,0X8B,0XE6,0X28,0XE6,0X26,0XEE,0X46,0XEE,0X47,0XEE,0X46,

81270XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X27,

81280XEE,0X27,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

81290XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

81300XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,

81310XF6,0X28,0XEE,0X47,0XF6,0X68,0XEE,0X48,0XCD,0X47,0X93,0XE4,0X52,0X00,0X52,0X03,

81320X41,0XC3,0X5A,0X87,0XC5,0XF4,0XFF,0XDC,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81390XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XBF,0XFF,0XDF,

81400XFF,0XDF,0XFF,0XDF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,0XFF,0XFA,

81410XFF,0XD8,0XFF,0XB7,0XFF,0X55,0XFF,0X13,0XF6,0XB1,0XEE,0X90,0XE6,0X6F,0XE6,0X8E,

81420XEE,0XB0,0XEE,0XD0,0XF6,0XF1,0XF7,0X12,0XF7,0X13,0XF7,0X14,0XEF,0X15,0XEF,0X15,

81430XF7,0X57,0XF7,0X58,0XF7,0X58,0XEF,0X17,0XEF,0X17,0XEF,0X17,0XE6,0XD6,0XDE,0X95,

81440XCE,0X13,0XC5,0XD3,0XAD,0X10,0X94,0X2C,0X7B,0X69,0X5A,0X23,0X51,0XE0,0X6A,0XA1,

81450XA4,0X86,0XD6,0X0A,0XEE,0XAB,0XE6,0X48,0XE6,0X27,0XEE,0X47,0XEE,0X27,0XEE,0X27,

81460XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X28,0XEE,0X48,

81470XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

81480XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

81490XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,

81500XF6,0X67,0XEE,0X69,0XCD,0X87,0XA4,0X45,0X5A,0X40,0X49,0XC1,0X52,0X24,0X41,0XE4,

81510X8C,0X2C,0XF7,0X7A,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,

81600XFF,0XDB,0XFF,0XBA,0XFF,0XB9,0XFF,0XB9,0XFF,0XD8,0XFF,0XF8,0XFF,0XD8,0XFF,0XF9,

81610XFF,0XF9,0XFF,0XFA,0XFF,0XFA,0XFF,0XFB,0XFF,0XFB,0XFF,0XFC,0XFF,0XDB,0XFF,0XFC,

81620XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XBC,

81630XFF,0XFE,0XFF,0XFD,0XFF,0X7C,0XFF,0X9B,0XEE,0XF7,0XB5,0X50,0X94,0X09,0X9C,0X48,

81640XC5,0X6A,0XDE,0X2B,0XE6,0X2A,0XE6,0X09,0XEE,0X49,0XEE,0X28,0XEE,0X27,0XEE,0X27,

81650XF6,0X27,0XEE,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X48,0XEE,0X48,

81660XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

81670XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

81680XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X67,0XEE,0X68,

81690XDE,0X09,0XA4,0X45,0X6A,0XA2,0X49,0XA0,0X52,0X03,0X41,0XC2,0X62,0XC7,0XDE,0XB7,

81700XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,

81770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDE,

81790XFF,0XDD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,

81800XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,

81820XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XFF,0XFD,0XFF,0XBC,0XF7,0X59,0XF7,0X16,0XFF,0X14,

81830XF6,0XB0,0XE6,0X2C,0XE5,0XE9,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XF6,0X27,0XEE,0X47,

81840XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X48,

81850XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

81860XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X27,

81870XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XEE,0X47,0XEE,0X68,0XE6,0X4A,0XA4,0X65,

81880X72,0XE2,0X49,0XC0,0X49,0XE2,0X41,0XE3,0X4A,0X24,0XB5,0X92,0XFF,0XBC,0XFF,0XFE,

81890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81960XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81980XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81990XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82000XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,

82010XFF,0XFF,0XFF,0XDF,0XFF,0XBF,0XFF,0XDE,0XFF,0XDD,0XFF,0XBA,0XFF,0X96,0XFE,0XF2,

82020XEE,0X6E,0XE6,0X2B,0XEE,0X29,0XEE,0X28,0XEE,0X28,0XEE,0X47,0XEE,0X27,0XEE,0X27,

82030XEE,0X28,0XF6,0X48,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X28,0XEE,0X28,

82040XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

82050XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XF6,0X27,0XF6,0X27,

82060XF6,0X27,0XF6,0X47,0XF6,0X67,0XEE,0X68,0XE6,0X4A,0XAC,0XA6,0X6A,0XA1,0X49,0XE0,

82070X41,0XC1,0X49,0XE3,0X39,0XA2,0X94,0X6E,0XF7,0X9B,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

82080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82190XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

82200XFF,0XBF,0XFF,0XBF,0XFF,0XBE,0XFF,0XDD,0XFF,0XFC,0XFF,0XD9,0XF7,0X55,0XEE,0XF1,

82210XE6,0X4B,0XE6,0X28,0XE6,0X27,0XEE,0X47,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,

82220XEE,0X48,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,

82230XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,

82240XEE,0X47,0XF6,0X48,0XF6,0X48,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X47,

82250XF6,0X67,0XF6,0X68,0XEE,0X6A,0XC5,0X28,0X72,0XC1,0X49,0XC0,0X49,0XE1,0X49,0XE3,

82260X39,0XA2,0X63,0X08,0XE7,0X1A,0XFF,0XBE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

82270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

82390XFF,0XDF,0XFF,0XDE,0XFF,0XDD,0XFF,0XFC,0XFF,0XDA,0XFF,0XB8,0XF7,0X32,0XEE,0X8D,

82400XDE,0X29,0XE6,0X27,0XEE,0X47,0XEE,0X27,0XEE,0X08,0XEE,0X28,0XF6,0X48,0XEE,0X47,

82410XEE,0X47,0XEE,0X47,0XEE,0X48,0XEE,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

82420XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

82430XF6,0X48,0XF6,0X48,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X68,

82440XEE,0X6A,0XCD,0X69,0X72,0XC1,0X51,0XE0,0X49,0XE1,0X49,0XE3,0X41,0XE3,0X4A,0X25,

82450XD6,0X98,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82570XFF,0XFF,0XFF,0XFE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

82580XFF,0XDE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFB,0XFF,0XBA,0XFF,0X35,0XEE,0X8E,0XDE,0X4A,

82590XE6,0X28,0XEE,0X48,0XEE,0X28,0XEE,0X07,0XF6,0X48,0XEE,0X47,0XF6,0X47,0XEE,0X47,

82600XEE,0X48,0XEE,0X48,0XF6,0X48,0XEE,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,

82610XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

82620XF6,0X28,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XEE,0X6A,0XDD,0XCA,

82630X7A,0XE1,0X52,0X00,0X51,0XE1,0X49,0XE2,0X49,0XE3,0X39,0XA3,0XB5,0X94,0XFF,0XDE,

82640XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

82730XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFE,

82770XFF,0XDD,0XFF,0XBD,0XFF,0XDD,0XFF,0XDB,0XFF,0X76,0XEE,0XCF,0XE6,0X4A,0XE6,0X49,

82780XEE,0X48,0XEE,0X28,0XEE,0X27,0XEE,0X28,0XF6,0X48,0XEE,0X48,0XEE,0X47,0XEE,0X47,

82790XF6,0X67,0XEE,0X47,0XEE,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

82800XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

82810XFE,0X48,0XF6,0X67,0XF6,0X47,0XF6,0X48,0XF6,0X6A,0XE6,0X0B,0X7B,0X02,0X52,0X00,

82820X52,0X02,0X49,0XC2,0X41,0XE3,0X41,0XC3,0X8C,0X2E,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,

82830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

82960XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XFF,0X97,0XEE,0XD0,0XDE,0X4B,0XDE,0X28,0XEE,0X68,

82970XEE,0X27,0XEE,0X28,0XF6,0X48,0XF6,0X48,0XEE,0X47,0XEE,0X67,0XEE,0X67,0XEE,0X47,

82980XEE,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

82990XEE,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XFE,0X48,0XF6,0X67,

83000XF6,0X67,0XF6,0X48,0XF6,0X6A,0XE6,0X0B,0X83,0X22,0X51,0XE0,0X52,0X02,0X49,0XE3,

83010X41,0XC2,0X42,0X04,0X6B,0X4A,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

83150XFF,0XDE,0XFF,0XFC,0XFF,0X97,0XEE,0XF0,0XE6,0X4A,0XE6,0X28,0XEE,0X48,0XEE,0X28,

83160XF6,0X48,0XF6,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X67,0XEE,0X47,0XEE,0X48,0XF6,0X47,

83170XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XF6,0X48,

83180XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X68,0XF6,0X48,

83190XF6,0X6A,0XE6,0X2B,0X8B,0X63,0X52,0X00,0X5A,0X22,0X52,0X03,0X49,0XE2,0X41,0XE3,

83200X5A,0XC8,0XF7,0X9C,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,

83340XFF,0XFB,0XFF,0XB7,0XEE,0XF0,0XDE,0X2B,0XE6,0X29,0XEE,0X28,0XF6,0X48,0XF6,0X47,

83350XF6,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

83360XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

83370XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X48,0XF6,0X6A,0XE6,0X2B,

83380X93,0XC4,0X5A,0X20,0X52,0X01,0X52,0X02,0X4A,0X03,0X41,0XC2,0X52,0X66,0XEF,0X3B,

83390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFD,0XFF,0XDA,

83530XFF,0X76,0XF6,0XF1,0XD5,0XEA,0XDE,0X08,0XEE,0X28,0XF6,0X47,0XF6,0X27,0XEE,0X27,

83540XF6,0X47,0XF6,0X68,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

83550XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,

83560XF6,0X47,0XF6,0X47,0XFE,0X68,0XF6,0X69,0XF6,0X69,0XEE,0X4B,0X9C,0X04,0X62,0X40,

83570X52,0X01,0X52,0X22,0X4A,0X02,0X41,0XE2,0X4A,0X05,0XDE,0XF9,0XFF,0XFF,0XFF,0XFF,

83580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XBA,0XFF,0X96,

83720XE6,0X8E,0XDE,0X2A,0XE6,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X48,0XF6,0X27,0XF6,0X47,

83730XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

83740XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

83750XFE,0X68,0XF6,0X69,0XF6,0X49,0XEE,0X6B,0XA4,0X45,0X6A,0X80,0X5A,0X21,0X52,0X22,

83760X4A,0X02,0X4A,0X23,0X41,0XE4,0XD6,0X77,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83900XFF,0XFF,0XFF,0XDE,0XFF,0XDF,0XFF,0XDE,0XFF,0XDC,0XFF,0XB9,0XFF,0X53,0XDE,0X4C,

83910XDE,0X09,0XEE,0X49,0XF6,0X48,0XF6,0X27,0XF6,0X27,0XFE,0X68,0XF6,0X47,0XF6,0X47,

83920XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,

83930XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XFE,0X68,0XF6,0X48,

83940XF6,0X69,0XEE,0X6A,0XAC,0X65,0X72,0XC1,0X62,0X41,0X5A,0X42,0X52,0X22,0X52,0X23,

83950X41,0XE3,0XC6,0X15,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

84090XFF,0XDF,0XFF,0XFF,0XFF,0XFD,0XFF,0XDB,0XFF,0XF8,0XEE,0XF1,0XE6,0X4C,0XE6,0X08,

84100XEE,0X48,0XF6,0X47,0XF6,0X27,0XFE,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

84110XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,

84120XF6,0X47,0XF6,0X67,0XFE,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X48,0XF6,0X89,0XEE,0X6A,

84130XB4,0XA5,0X7B,0X01,0X62,0X62,0X62,0X63,0X5A,0X42,0X52,0X43,0X41,0XC3,0XBD,0XB4,

84140XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84280XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0XB6,0XEE,0XF0,0XD5,0XE8,0XEE,0X68,0XF6,0X67,

84290XF6,0X27,0XF6,0X28,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

84300XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X67,0XFE,0X67,

84310XFE,0X67,0XFE,0X67,0XF6,0X48,0XF6,0X48,0XF6,0X89,0XEE,0X69,0XBC,0XE5,0X83,0X42,

84320X6A,0XA2,0X62,0X83,0X5A,0X63,0X5A,0X63,0X49,0XE3,0XB5,0X93,0XFF,0XFF,0XFF,0XFF,

84330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

84470XFF,0XFC,0XFF,0XF9,0XFF,0X73,0XDE,0X4B,0XE6,0X48,0XEE,0X47,0XEE,0X07,0XF6,0X48,

84480XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

84490XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,

84500XF6,0X48,0XF6,0X48,0XF6,0XA8,0XEE,0X68,0XBD,0X26,0X8B,0X62,0X72,0XC2,0X6A,0XA3,

84510X62,0XA3,0X62,0XA4,0X52,0X24,0XBD,0X93,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFB,

84660XFF,0XB6,0XEE,0XEF,0XD6,0X08,0XE6,0X48,0XEE,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X47,

84670XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

84680XF6,0X48,0XF6,0X68,0XF6,0X47,0XF6,0X67,0XFE,0X47,0XF6,0X67,0XF6,0X68,0XF6,0X48,

84690XF6,0XA8,0XEE,0X68,0XC5,0X47,0X8B,0X82,0X72,0XE3,0X72,0XC4,0X6A,0XC4,0X62,0XC5,

84700X5A,0X65,0XC5,0XD4,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XF9,0XFF,0X53,

84850XD6,0X2B,0XE6,0X49,0XEE,0X28,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

84860XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X68,

84870XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XF6,0X87,0XEE,0X68,

84880XCD,0X87,0X8B,0XA2,0X7B,0X03,0X72,0XE4,0X72,0XE4,0X6A,0XE5,0X62,0XA5,0XCE,0X55,

84890XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0X76,0XE6,0X90,0XDE,0X2A,

85040XE6,0X27,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

85050XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X48,0XF6,0X68,0XF6,0X47,0XF6,0X47,

85060XF6,0X47,0XF6,0X67,0XFE,0X88,0XF6,0X68,0XEE,0X67,0XEE,0X88,0XD5,0XC8,0X93,0XA3,

85070X83,0X23,0X7B,0X04,0X73,0X04,0X73,0X05,0X6A,0XE6,0XDE,0X97,0XFF,0XFE,0XFF,0XFF,

85080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85220XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XDB,0XEF,0X15,0XD6,0X0C,0XE6,0X29,0XEE,0X26,

85230XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

85240XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X67,0XFE,0X67,0XF6,0X47,

85250XFE,0X68,0XF6,0X68,0XEE,0X88,0XEE,0X68,0XDD,0XE9,0X93,0XA3,0X83,0X23,0X83,0X45,

85260X7B,0X24,0X73,0X25,0X73,0X28,0XEF,0X3A,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85410XFF,0XFE,0XFF,0XDC,0XF7,0X58,0XD5,0XEE,0XDE,0X29,0XEE,0X47,0XF6,0X47,0XF6,0X47,

85420XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X48,0XF6,0X47,0XF6,0X48,0XF6,0X47,

85430XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XFE,0X67,0XF6,0X47,0XF6,0X68,0XF6,0X68,

85440XEE,0X68,0XF6,0XAA,0XD5,0XC9,0X93,0XC3,0X93,0X84,0X8B,0X65,0X83,0X64,0X7B,0X46,

85450X7B,0X89,0XF7,0X7B,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,

85600XFF,0XBA,0XD6,0X0F,0XDD,0XE9,0XEE,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

85610XF6,0X47,0XF6,0X67,0XF6,0X68,0XF6,0X67,0XF6,0X68,0XF6,0X47,0XF6,0X47,0XF6,0X67,

85620XF6,0X67,0XF6,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X88,0XF6,0XCB,

85630XCD,0X68,0X9B,0XC3,0X9B,0XC5,0X93,0XA5,0X8B,0XA5,0X7B,0X65,0X8C,0X0B,0XFF,0XBC,

85640XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFB,0XE6,0X72,

85790XD5,0XC9,0XEE,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,

85800XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X67,

85810XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0XA9,0XFE,0XCB,0XC5,0X06,0X9B,0XE4,

85820X9B,0XE5,0X93,0XC5,0X93,0XE5,0X7B,0X85,0XA4,0XEF,0XFF,0XBC,0XFF,0XFE,0XFF,0XFF,

85830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

85910XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XF7,0X35,0XCD,0X8A,0XE6,0X29,

85980XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

85990XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XFE,0X67,0XF6,0X67,

86000XF6,0X67,0XEE,0X67,0XFE,0XCA,0XF6,0XAB,0XBC,0XC6,0XA4,0X25,0XA4,0X05,0X9C,0X05,

86010X9C,0X26,0X83,0XA6,0XC5,0XD2,0XFF,0XBC,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86090XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

86100XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86160XFF,0XFF,0XFF,0XFE,0XFF,0XBB,0XFF,0XB8,0XCD,0XAC,0XDE,0X09,0XEE,0X48,0XF6,0X47,

86170XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

86180XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X87,0XF6,0X88,

86190XFE,0XEB,0XE6,0X2A,0XB4,0XA6,0XAC,0X66,0XA4,0X25,0XA4,0X46,0X9C,0X06,0X94,0X07,

86200XDE,0X95,0XFF,0XBC,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86280XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86350XFF,0XDC,0XFF,0XDA,0XD5,0XEE,0XD5,0XC9,0XEE,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X67,

86360XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

86370XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X88,0XF6,0XA9,0XFE,0XCB,0XDD,0XC8,

86380XBC,0XC6,0XB4,0XA6,0XAC,0X66,0XA4,0X46,0X9C,0X26,0XA4,0XAA,0XEF,0X17,0XFF,0XDD,

86390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,

86540XD6,0X30,0XCD,0X89,0XEE,0X49,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

86550XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,

86560XF6,0X67,0XF6,0X67,0XF6,0X88,0XFE,0XC9,0XF6,0XCB,0XD5,0XA8,0XBC,0XE6,0XBC,0XC7,

86570XBC,0XA7,0XAC,0X87,0XA4,0X68,0XBD,0X4E,0XF7,0X78,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,

86580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86650XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86680XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86720XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBB,0XE6,0XB3,0XBD,0X49,

86730XEE,0X49,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

86740XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XFE,0X67,0XFE,0XA8,0XEE,0X27,

86750XF6,0XA8,0XFE,0XCA,0XF6,0XAB,0XCD,0X67,0XC5,0X27,0XBC,0XE7,0XBC,0XE8,0XB4,0XC8,

86760XAC,0X89,0XD6,0X32,0XFF,0X99,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

86850XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

86860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

86870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86910XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XBB,0XE6,0XB4,0XB5,0X09,0XEE,0X49,0XF6,0X47,

86920XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

86930XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X88,0XF6,0X47,0XF6,0XA9,0XFE,0XCA,

86940XEE,0X6A,0XCD,0X67,0XC5,0X26,0XC5,0X07,0XC5,0X08,0XB4,0XE9,0XB5,0X0C,0XE6,0XB5,

86950XFF,0XDB,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,

87030XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XF7,0XDF,0XF7,0XBF,0XF7,0XBE,

87040XF7,0XDF,0XF7,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

87050XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDF,

87060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87100XFF,0XDE,0XFF,0XDC,0XE6,0XD4,0XAC,0XC8,0XEE,0X4A,0XEE,0X47,0XF6,0X47,0XF6,0X47,

87110XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

87120XF6,0X67,0XFE,0X68,0XF6,0X68,0XF6,0X68,0XFE,0XCA,0XFE,0XCA,0XE6,0X08,0XCD,0X66,

87130XC5,0X26,0XC5,0X27,0XC5,0X49,0XBC,0XEA,0XC5,0X90,0XF7,0X38,0XFF,0XFC,0XFF,0XFD,

87140XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

87220XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87230XF7,0XDE,0XF7,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87250XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFC,

87290XEE,0XF5,0XAC,0XC8,0XEE,0X4A,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,

87300XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X68,0XFE,0X68,

87310XF6,0X47,0XFE,0X88,0XFE,0XCA,0XF6,0XAA,0XDD,0XC7,0XCD,0X66,0XCD,0X46,0XCD,0X48,

87320XCD,0X4A,0XB4,0XEB,0XD6,0X13,0XFF,0X7B,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

87330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87400XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,

87410XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

87420XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87430XFF,0XDE,0XFF,0XDE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

87440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87470XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFC,0XEE,0XF5,0XAC,0XC8,

87480XEE,0X4A,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

87490XF6,0X67,0XF6,0X67,0XFE,0X67,0XF6,0X67,0XFE,0X68,0XF6,0X68,0XF6,0X68,0XFE,0XA9,

87500XFE,0XCA,0XF6,0X69,0XDD,0XA7,0XCD,0X66,0XCD,0X87,0XCD,0X47,0XC5,0X4A,0XBD,0X2C,

87510XEE,0XD7,0XFF,0XBD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

87590XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,0XFF,0XFB,0XFF,0XFA,0XFF,0XDB,0XFF,0XDB,

87600XFF,0XDC,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XDE,

87610XFF,0XDE,0XFF,0XDE,0XFF,0XDD,0XFF,0XDD,0XFF,0XFE,0XFF,0XFE,0XFF,0XDD,0XFF,0XDD,

87620XFF,0XFE,0XFF,0XFE,0XFF,0XDD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

87630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

87660XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFC,0XE6,0XF5,0XAC,0XA8,0XEE,0X6A,0XF6,0X68,

87670XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

87680XF6,0X67,0XF6,0X67,0XFE,0X68,0XF6,0X68,0XF6,0X68,0XFE,0XC9,0XFE,0XAA,0XEE,0X29,

87690XDD,0XA7,0XD5,0X87,0XD5,0XA7,0XCD,0X68,0XC5,0X6A,0XD5,0XF0,0XFF,0X5A,0XFF,0XDE,

87700XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFC,0XFF,0XDA,

87780XFF,0XB9,0XF7,0XB8,0XFF,0XB7,0XFF,0XD7,0XFF,0XB6,0XEF,0X35,0XCE,0X52,0XB5,0X6E,

87790X9C,0XCC,0X94,0X8B,0X94,0X6B,0X9C,0X8C,0X9C,0X8C,0X9C,0X8D,0X9C,0X8D,0X9C,0X8D,

87800X9C,0X8D,0X9C,0X8D,0X9C,0X6E,0X94,0X6E,0X9C,0XAF,0XBD,0XB3,0XE7,0X19,0XFF,0XDD,

87810XFF,0XBC,0XFF,0XFE,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

87850XFF,0XFE,0XFF,0XFC,0XE6,0XD4,0XA4,0X87,0XEE,0X6A,0XF6,0X68,0XF6,0X67,0XF6,0X67,

87860XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X67,

87870XF6,0X67,0XF6,0X67,0XFE,0XA8,0XFE,0XC9,0XFE,0X89,0XE6,0X08,0XDD,0XC8,0XDD,0XA8,

87880XD5,0XA8,0XD5,0XA9,0XCD,0X6A,0XEE,0XD3,0XFF,0XBC,0XFF,0XBF,0XFF,0XFF,0XF7,0XFF,

87890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87960XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XDB,0XFF,0X98,0XF7,0X55,0XEF,0X13,0XEF,0X11,

87970XEF,0X31,0XF7,0X51,0XF7,0X72,0XFF,0XB3,0XFF,0XB3,0XF7,0X32,0XCE,0X2E,0XA4,0XA8,

87980X7B,0X83,0X6A,0XE2,0X6A,0XE2,0X6A,0XE3,0X6A,0XE3,0X6A,0XE4,0X6A,0XC4,0X6A,0XC4,

87990X62,0XC4,0X62,0XA4,0X62,0XA4,0X5A,0X84,0X6A,0XE6,0X94,0X4C,0XC5,0XD3,0XFF,0XDB,

88000XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88030XFF,0XDF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,

88040XE6,0XB4,0X9C,0X47,0XEE,0X4A,0XF6,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

88050XF6,0X67,0XF6,0X66,0XF6,0X46,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X67,

88060XFE,0XA9,0XFE,0XC9,0XF6,0X69,0XE5,0XE8,0XE5,0XC8,0XE5,0XE9,0XD5,0XA8,0XD5,0XC9,

88070XC5,0X8B,0XFF,0X76,0XFF,0XDD,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88140XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XF7,0XBF,0XFF,0XDF,0XF7,0XBD,0XFF,0XDC,

88150XFF,0XDA,0XEE,0XD3,0XDE,0X0E,0XD5,0XCB,0XDE,0X0A,0XDE,0X09,0XD6,0X08,0XD6,0X09,

88160XD6,0X09,0XDE,0X4A,0XEE,0X8C,0XFF,0X0E,0XFF,0X50,0XFF,0X91,0XFF,0X70,0XD6,0X0B,

88170XB5,0X08,0X9C,0X45,0XA4,0X66,0XA4,0X67,0XA4,0X67,0XA4,0X67,0XA4,0X47,0X9C,0X06,

88180X94,0X06,0X94,0X27,0X8B,0XE6,0X83,0XA6,0X7B,0X65,0X8B,0XE8,0XCE,0X11,0XFF,0XB9,

88190XFF,0XDB,0XFF,0XFD,0XFF,0XDD,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

88210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XF7,0XFF,0XFF,0XDF,0XFF,0XBF,0XFF,0XDE,

88220XFF,0XFE,0XFF,0XFD,0XF7,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XCD,0XF2,0XAC,0XA9,

88230XEE,0X4B,0XF6,0X69,0XF6,0X68,0XF6,0X67,0XFE,0X67,0XFE,0X46,0XFE,0X66,0XFE,0X66,

88240XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0XA8,0XFE,0XC9,0XFE,0X88,

88250XF6,0X49,0XEE,0X09,0XE5,0XC9,0XED,0XE9,0XE5,0XEA,0XCD,0X89,0XEE,0XF2,0XFF,0XF9,

88260XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88330XFF,0XDF,0XF7,0XDF,0XFF,0XFF,0XF7,0XBD,0XFF,0XDD,0XFF,0XDA,0XD6,0X31,0XC5,0X6B,

88340XCD,0X68,0XE5,0XC8,0XE5,0XE7,0XE6,0X27,0XDE,0X27,0XDE,0X28,0XE6,0X49,0XDE,0X08,

88350XDD,0XE8,0XDE,0X08,0XE6,0X4A,0XEE,0XCC,0XFF,0X4E,0XFF,0X6F,0XF6,0XED,0XDE,0X2B,

88360XC5,0X48,0XBD,0X28,0XBD,0X28,0XB4,0XC7,0XB4,0XC7,0XB4,0XC7,0XB4,0XC7,0XAC,0X86,

88370XB4,0XA7,0XA4,0X66,0X9C,0X26,0XA4,0X68,0X93,0XE6,0XAC,0XEC,0XDE,0XB5,0XF7,0X9A,

88380XFF,0XFC,0XFF,0XDC,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,

88390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88400XF7,0XFF,0XF7,0XFF,0XF7,0XFF,0XFF,0XDF,0XFF,0XBF,0XFF,0XBE,0XFF,0XFE,0XFF,0XFE,

88410XF7,0XFE,0XF7,0XFE,0XFF,0XDD,0XFF,0XFC,0XC5,0X6F,0XBC,0XE9,0XF6,0X4B,0XF6,0X49,

88420XF6,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X66,0XFE,0X66,0XF6,0X67,0XF6,0X67,

88430XF6,0X67,0XF6,0X68,0XF6,0X88,0XFE,0XA9,0XFE,0XC9,0XF6,0X89,0XEE,0X29,0XF6,0X0A,

88440XF6,0X09,0XEE,0X0A,0XDD,0XEA,0XE6,0X4E,0XF7,0X75,0XFF,0XFA,0XFF,0XFE,0XFF,0XFF,

88450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XDE,

88520XFF,0XFE,0XFF,0XBD,0XFF,0XBB,0XD6,0X74,0XBD,0X4C,0XCD,0X8A,0XE5,0XE9,0XEE,0X28,

88530XEE,0X07,0XE6,0X26,0XE6,0X48,0XDE,0X07,0XE6,0X28,0XE6,0X28,0XEE,0X48,0XE6,0X08,

88540XE6,0X08,0XE6,0X49,0XE6,0X4A,0XF6,0XCC,0XFF,0X6E,0XFF,0X6F,0XEE,0XAC,0XD5,0XE9,

88550XC5,0X68,0XC5,0X47,0XC5,0X28,0XC5,0X07,0XBC,0XE6,0XC5,0X07,0XB4,0XC6,0XBC,0XE7,

88560XB4,0XE8,0X9C,0X46,0XA4,0XA8,0X9C,0X48,0X9C,0X8B,0XBD,0XB0,0XEF,0X17,0XFF,0XFC,

88570XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XF7,0XFF,

88590XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XF7,0XFE,0XF7,0XFE,

88600XF7,0XDC,0XFF,0XBA,0XAC,0XCB,0XCD,0X8A,0XF6,0X6A,0XF6,0X68,0XF6,0X68,0XFE,0X67,

88610XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X88,

88620XFE,0XA9,0XFE,0XAA,0XFE,0XA9,0XF6,0X69,0XF6,0X29,0XF6,0X29,0XF6,0X29,0XEE,0X0A,

88630XD5,0XCB,0XF7,0X33,0XFF,0XD9,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDD,0XFF,0XDC,

88710XE6,0XB6,0XB5,0X2D,0XC5,0X8B,0XE6,0X2B,0XEE,0X2A,0XEE,0X07,0XEE,0X06,0XE6,0X06,

88720XE6,0X27,0XE6,0X48,0XE6,0X27,0XEE,0X28,0XEE,0X48,0XEE,0X07,0XE6,0X28,0XE6,0X28,

88730XDD,0XE8,0XE6,0X49,0XE6,0X6A,0XFF,0X4D,0XFF,0X8F,0XF6,0XED,0XDE,0X09,0XD5,0XA8,

88740XC5,0X26,0XCD,0X47,0XCD,0X47,0XC5,0X06,0XBC,0XE6,0XC5,0X07,0XB4,0XC6,0XBC,0XE8,

88750XAC,0XA7,0XA4,0X67,0X9C,0X48,0X9C,0X49,0XB5,0X2E,0XE6,0XB5,0XFF,0X9A,0XFF,0XDD,

88760XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88770XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

88780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XEF,0XFE,0XF7,0XFE,0XFF,0XFC,0XE6,0XF5,

88790XA4,0X88,0XE6,0X0A,0XF6,0X69,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XF6,0X67,

88800XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X88,0XFE,0XA9,0XFE,0XA9,

88810XFE,0X89,0XF6,0X48,0XF6,0X28,0XF6,0X49,0XEE,0X49,0XE6,0X2B,0XDE,0X2E,0XFF,0X97,

88820XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

88830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XBD,0XFF,0XFD,0XF7,0X58,0XBD,0X8F,0XC5,0XAC,

88900XD5,0XEB,0XE6,0X29,0XE5,0XE7,0XEE,0X06,0XF6,0X26,0XEE,0X06,0XE6,0X06,0XEE,0X47,

88910XEE,0X47,0XEE,0X27,0XEE,0X06,0XEE,0X27,0XEE,0X47,0XEE,0X27,0XEE,0X28,0XEE,0X69,

88920XE6,0X49,0XE6,0X69,0XF6,0XEB,0XFF,0X6E,0XFF,0X4D,0XEE,0XAB,0XD5,0XA7,0XCD,0X67,

88930XC5,0X26,0XC5,0X06,0XCD,0X47,0XC4,0XE6,0XC5,0X07,0XBC,0XC7,0XB4,0XC7,0XB4,0XC7,

88940XAC,0X87,0XAC,0X68,0XA4,0X69,0X9C,0X4A,0XD6,0X33,0XEF,0X38,0XFF,0XDC,0XFF,0XDD,

88950XFF,0XDD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88960XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88970XF7,0XFF,0XF7,0XFF,0XF7,0XFF,0XF7,0XFD,0XFF,0XDA,0XC5,0XCF,0XB4,0XC6,0XEE,0X49,

88980XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

88990XF6,0X67,0XF6,0X67,0XF6,0X88,0XFE,0XA8,0XFE,0XA9,0XFE,0XA9,0XFE,0X68,0XF6,0X48,

89000XF6,0X48,0XF6,0X69,0XE6,0X2A,0XEE,0X8E,0XF7,0X14,0XFF,0XFB,0XFF,0XFE,0XFF,0XFF,

89010XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

89080XFF,0XFF,0XFF,0XBD,0XFF,0XDB,0XDE,0X94,0XBD,0X4C,0XDE,0X0C,0XDE,0X29,0XE6,0X07,

89090XEE,0X06,0XF6,0X27,0XF6,0X26,0XEE,0X26,0XEE,0X47,0XE6,0X06,0XEE,0X27,0XEE,0X27,

89100XEE,0X26,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XE6,0X27,0XEE,0X69,0XE6,0X28,

89110XDE,0X07,0XF6,0XCA,0XFF,0X4C,0XFF,0X6D,0XFE,0XEB,0XDE,0X08,0XD5,0XA7,0XCD,0X46,

89120XC5,0X06,0XCD,0X27,0XC5,0X07,0XC5,0X07,0XBC,0XC7,0XB4,0XA6,0XAC,0X66,0XAC,0X86,

89130XAC,0X67,0XA4,0X68,0X94,0X08,0XBD,0X6F,0XE6,0XF6,0XFF,0XDB,0XFF,0XFD,0XFF,0XFE,

89140XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XF7,0XFF,

89160XF7,0XFF,0XFF,0XFE,0XF7,0X98,0XB5,0X0A,0XC5,0X27,0XF6,0X89,0XF6,0X67,0XF6,0X67,

89170XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X87,

89180XFE,0XA8,0XFE,0XA8,0XFE,0XA9,0XFE,0X89,0XFE,0X48,0XF6,0X49,0XF6,0X68,0XEE,0X49,

89190XE6,0X2B,0XEE,0XD1,0XFF,0XB9,0XFF,0XFD,0XFF,0XFF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,

89200XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDD,

89270XFF,0X79,0XCD,0XF0,0XCD,0XAB,0XDD,0XE9,0XE6,0X48,0XEE,0X26,0XF6,0X26,0XF6,0X05,

89280XED,0XC5,0XF6,0X26,0XF6,0X68,0XEE,0X47,0XEE,0X27,0XF6,0X67,0XF6,0X26,0XF6,0X06,

89290XEE,0X26,0XF6,0X47,0XF6,0X67,0XEE,0X47,0XEE,0X27,0XF6,0X69,0XEE,0X48,0XE6,0X48,

89300XEE,0X68,0XFF,0X0B,0XFF,0X8D,0XFF,0X2C,0XDE,0X08,0XCD,0X67,0XCD,0X47,0XCD,0X47,

89310XC5,0X07,0XBC,0XC6,0XCD,0X28,0XBC,0XC6,0XC4,0XC6,0XBC,0XA6,0XB4,0XA6,0XA4,0X45,

89320XA4,0X88,0X8B,0XE7,0XA4,0XCC,0XE6,0XD5,0XFF,0X9A,0XFF,0XDD,0XFF,0XDE,0XFF,0XDF,

89330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XF7,0XDF,0XFF,0XFF,0XFF,0XDD,

89350XE6,0X74,0XB4,0XC9,0XDD,0XA8,0XFE,0XA9,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

89360XF6,0X67,0XF6,0X86,0XF6,0X87,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XFE,0XA9,0XFE,0XA9,

89370XFE,0XA9,0XFE,0X89,0XFE,0X48,0XFE,0X69,0XF6,0X69,0XEE,0X6A,0XEE,0X8F,0XF7,0X55,

89380XFF,0XFC,0XFF,0XFE,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFD,0XF7,0X37,0XC5,0X8D,

89460XD5,0XEA,0XE6,0X29,0XEE,0X47,0XEE,0X26,0XF6,0X46,0XF6,0X26,0XF6,0X26,0XF6,0X27,

89470XEE,0X07,0XEE,0X27,0XEE,0X27,0XF6,0X47,0XF6,0X26,0XF6,0X26,0XF6,0X46,0XF6,0X26,

89480XEE,0X26,0XF6,0X47,0XF6,0X48,0XEE,0X07,0XF6,0X68,0XEE,0X47,0XE6,0X47,0XEE,0X68,

89490XF6,0XEA,0XFF,0X8D,0XFF,0X4D,0XE6,0X4A,0XCD,0X67,0XC5,0X27,0XC5,0X27,0XC5,0X27,

89500XC4,0XE7,0XBC,0XE6,0XC4,0XC6,0XBC,0XE6,0XB4,0XA5,0XAC,0XA5,0XA4,0X65,0XA4,0X87,

89510X94,0X27,0X9C,0X6A,0XD6,0X53,0XFF,0X9A,0XFF,0XFD,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,

89520XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

89530XFF,0XFF,0XFF,0XFF,0XF7,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0X5A,0XC5,0X4F,0XC5,0X09,

89540XEE,0X29,0XFE,0X68,0XFE,0X48,0XFE,0X48,0XFE,0X67,0XF6,0X67,0XFE,0X67,0XF6,0X67,

89550XF6,0X67,0XF6,0X67,0XF6,0X48,0XF6,0X68,0XFE,0X89,0XFE,0X89,0XFE,0XA9,0XFE,0X89,

89560XFE,0X49,0XFE,0X8A,0XEE,0X4A,0XE6,0X6D,0XF7,0X34,0XFF,0XDA,0XFF,0XFE,0XFF,0XFF,

89570XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XF7,0X15,0XCD,0XAC,0XDE,0X09,0XEE,0X48,

89650XEE,0X25,0XF6,0X25,0XF6,0X26,0XF6,0X26,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

89660XF6,0X27,0XF6,0X26,0XF6,0X26,0XF6,0X26,0XF6,0X26,0XF6,0X26,0XF6,0X46,0XF6,0X47,

89670XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XEE,0X67,0XEE,0X68,0XEE,0X88,0XEE,0XA9,

89680XFF,0X8D,0XFF,0X6E,0XE6,0X4A,0XC5,0X47,0XC5,0X67,0XC5,0X48,0XC5,0X47,0XBC,0XE6,

89690XBC,0XC5,0XBC,0XC5,0XB4,0XA4,0XAC,0XA4,0XAC,0XA5,0XAC,0XA6,0X9C,0X66,0X94,0X27,

89700X94,0X29,0XBD,0X70,0XF7,0X39,0XFF,0XDD,0XFF,0XDE,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

89710XF7,0X9E,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFE,

89720XFF,0XFF,0XF7,0XBD,0XFF,0XDC,0XE6,0X95,0XB4,0XAA,0XDD,0XAB,0XFE,0X6A,0XFE,0X48,

89730XFE,0X48,0XFE,0X48,0XFE,0X48,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,

89740XFE,0X69,0XFE,0X89,0XFE,0X8A,0XFE,0XA9,0XFE,0XA9,0XFE,0X69,0XFE,0X8B,0XF6,0X4B,

89750XEE,0X6D,0XF7,0X12,0XFF,0XB9,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89760XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89830XFF,0XFE,0XFF,0XDC,0XF7,0X14,0XD5,0XCB,0XE6,0X29,0XEE,0X47,0XEE,0X25,0XF6,0X45,

89840XF6,0X26,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X47,

89850XF6,0X27,0XF6,0X46,0XF6,0X26,0XF6,0X26,0XF6,0X46,0XF6,0X47,0XF6,0X47,0XF6,0X47,

89860XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X67,0XEE,0X88,0XEE,0X88,0XEE,0XAA,0XFF,0X6D,

89870XFF,0X8E,0XEE,0XAB,0XCD,0XA8,0XB5,0X06,0XBD,0X27,0XBD,0X26,0XBC,0XE6,0XBC,0XE6,

89880XBC,0XE5,0XB4,0XA5,0XB4,0XC5,0XA4,0X64,0XA4,0X45,0XA4,0X87,0X93,0XE6,0X9C,0X29,

89890XAC,0XCD,0XE6,0X96,0XFF,0X9B,0XFF,0XDD,0XFF,0XFE,0XF7,0XBE,0XFF,0XFF,0XF7,0XBE,

89900XFF,0XDF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XBB,

89910XEF,0X16,0XBD,0X2C,0XCD,0X6A,0XE6,0X09,0XFE,0XAA,0XF6,0X27,0XFE,0X48,0XFE,0X48,

89920XFE,0X48,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X89,0XFE,0X89,

89930XFE,0XA9,0XFE,0XAA,0XFE,0X89,0XFE,0X8A,0XF6,0X6C,0XEE,0X2D,0XF6,0XD2,0XFF,0X77,

89940XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

89950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDB,

90020XEE,0XF4,0XD5,0XEB,0XE6,0X48,0XEE,0X46,0XF6,0X25,0XF6,0X45,0XF6,0X47,0XF6,0X27,

90030XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

90040XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XFE,0X47,0XFE,0X67,0XF6,0X46,0XF6,0X66,

90050XF6,0X67,0XF6,0X67,0XEE,0X67,0XEE,0X68,0XEE,0X88,0XF6,0XA9,0XFF,0X0B,0XFF,0X4D,

90060XF7,0X0D,0XD6,0X09,0XBD,0X46,0XB5,0X05,0XBD,0X06,0XBC,0XE6,0XBC,0XE6,0XAC,0XA5,

90070XAC,0X85,0XA4,0X64,0XA4,0X65,0XA4,0X45,0XA4,0X46,0X94,0X06,0X8B,0XC7,0X9C,0X4B,

90080XCD,0XD3,0XEF,0X39,0XFF,0XBC,0XFF,0XFE,0XFF,0XBE,0XFF,0XFF,0XFF,0XDE,0XF7,0XDE,

90090XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XF7,0XDD,0XFF,0XDC,0XFF,0XB9,0XCD,0XCE,0XBD,0X07,

90100XE6,0X09,0XF6,0XA9,0XEE,0X27,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,

90110XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X88,0XFE,0XA9,0XFE,0XA9,0XFE,0X89,

90120XF6,0X8A,0XF6,0X8B,0XEE,0X2C,0XF6,0XB1,0XFF,0X57,0XFF,0XBB,0XFF,0XFD,0XFF,0XFE,

90130XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XEF,0X13,0XD6,0X0B,

90210XEE,0X48,0XF6,0X46,0XF6,0X45,0XF6,0X46,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,

90220XF6,0X47,0XF6,0X46,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

90230XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X66,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X67,

90240XF6,0X67,0XF6,0X67,0XF6,0X88,0XF6,0X68,0XEE,0X89,0XF6,0XCA,0XFF,0X8D,0XFF,0X4D,

90250XD6,0X49,0XB5,0X45,0XB4,0XE5,0XAC,0XA5,0XAC,0XA5,0XB4,0XC6,0XB4,0XC6,0XAC,0XA5,

90260XA4,0X65,0X9C,0X24,0XA4,0X45,0X9C,0X05,0X94,0X06,0X8B,0XA6,0X8B,0XE9,0XA4,0XAD,

90270XDE,0X96,0XFF,0X9B,0XFF,0XDD,0XF7,0X9D,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFE,

90280XFF,0XFD,0XFF,0XFC,0XFF,0XDA,0XDE,0X30,0XBD,0X07,0XE6,0X49,0XEE,0X47,0XF6,0XA8,

90290XEE,0X27,0XFE,0XA9,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X67,0XFE,0X87,

90300XFE,0X67,0XFE,0X68,0XFE,0X89,0XFE,0XCA,0XFE,0X89,0XF6,0X89,0XF6,0XAB,0XEE,0X8D,

90310XEE,0X6F,0XFF,0X35,0XFF,0XBB,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDB,0XF7,0X13,0XDE,0X2B,0XEE,0X48,0XF6,0X46,

90400XF6,0X26,0XF6,0X46,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X46,

90410XF6,0X66,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,

90420XF6,0X67,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

90430XF6,0X67,0XF6,0X67,0XF6,0X88,0XF6,0X88,0XEE,0XA9,0XFF,0X6C,0XFF,0X6D,0XE6,0XAA,

90440XC5,0X47,0XBD,0X27,0XB5,0X06,0XA4,0X64,0XB4,0XC6,0XA4,0X44,0XA4,0X45,0XA4,0X45,

90450XA4,0X45,0X93,0XE4,0X93,0XC4,0X83,0X64,0X8B,0XA7,0X8B,0XC8,0X8B,0XEA,0XAC,0XEF,

90460XE6,0XB8,0XFF,0XBD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDC,0XFF,0XFC,0XFF,0X78,

90470XE6,0X92,0XBD,0X09,0XDD,0XE9,0XEE,0X68,0XFE,0XC7,0XEE,0X45,0XFE,0XA9,0XF6,0X48,

90480XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X88,

90490XFE,0X8A,0XFE,0X8A,0XF6,0XAA,0XF6,0XAB,0XEE,0X8C,0XE6,0X8E,0XFF,0X54,0XFF,0XB9,

90500XFF,0XDD,0XFF,0XDE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90510XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90580XFF,0XFE,0XFF,0XFB,0XF7,0X34,0XE6,0X4C,0XE6,0X28,0XF6,0X46,0XF6,0X26,0XF6,0X47,

90590XF6,0X48,0XF6,0X49,0XF6,0X48,0XF6,0X47,0XF6,0X66,0XF6,0X66,0XF6,0X66,0XF6,0X67,

90600XF6,0X47,0XF6,0X48,0XFE,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

90610XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X47,0XFE,0X47,0XFE,0X67,0XF6,0X46,

90620XF6,0X67,0XF6,0X88,0XEE,0X67,0XF6,0XC9,0XFF,0X2B,0XFF,0X8E,0XFF,0X0D,0XC5,0X88,

90630XA4,0X64,0XB4,0XE6,0XA4,0X44,0XAC,0X86,0XA4,0X65,0X9C,0X24,0X9C,0X04,0X9C,0X05,

90640X8B,0XA3,0X94,0X06,0X83,0X85,0X7B,0X25,0X73,0X26,0X6A,0XE6,0X83,0X69,0XB5,0X11,

90650XF7,0X1A,0XFF,0XDD,0XFF,0XFC,0XFF,0XFB,0XFF,0XB8,0XEE,0X92,0XC5,0X0A,0XDD,0XEA,

90660XFE,0XAA,0XF6,0X87,0XF6,0X65,0XFE,0XA7,0XF6,0X48,0XF6,0X48,0XF6,0X67,0XFE,0X87,

90670XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X8A,0XFE,0X8B,

90680XF6,0X8B,0XEE,0X8C,0XEE,0XAE,0XF7,0X12,0XFF,0XD9,0XFF,0XFC,0XFF,0XDE,0XFF,0XFF,

90690XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

90700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFB,

90770XFF,0X75,0XE6,0X8D,0XE6,0X28,0XF6,0X47,0XF6,0X26,0XFE,0X27,0XF6,0X49,0XF6,0X49,

90780XF6,0X48,0XF6,0X68,0XF6,0X66,0XF6,0X66,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X68,

90790XFE,0X48,0XFE,0X47,0XF6,0X67,0XF6,0X67,0XFE,0X87,0XF6,0X67,0XF6,0X68,0XF6,0X68,

90800XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,

90810XF6,0X67,0XF6,0X68,0XEE,0X68,0XFE,0XEB,0XFF,0X8E,0XFF,0X4E,0XE6,0X4B,0XB4,0XC5,

90820XA4,0X64,0X9C,0X44,0X9C,0X24,0X9C,0X04,0X93,0XE4,0X93,0XC4,0X8B,0XA4,0X8B,0XA5,

90830X83,0X64,0X7B,0X24,0X72,0XE4,0X73,0X05,0X6A,0XA3,0X62,0X63,0X62,0XA5,0X7B,0X68,

90840XAC,0XED,0XD6,0X30,0XE6,0X6F,0XDD,0XEB,0XE5,0XEA,0XF6,0X29,0XFE,0X68,0XF6,0X66,

90850XFE,0X66,0XFE,0X66,0XFE,0X69,0XFE,0X69,0XF6,0X68,0XF6,0X87,0XF6,0X88,0XFE,0X88,

90860XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X89,0XFE,0X8C,0XFE,0X8D,0XEE,0X4D,0XEE,0X8F,

90870XFF,0X74,0XFF,0XD8,0XFF,0XDC,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XB6,0XEE,0XAF,

90960XE6,0X49,0XEE,0X67,0XF6,0X47,0XFE,0X47,0XF6,0X48,0XF6,0X49,0XF6,0X49,0XF6,0X68,

90970XF6,0X67,0XF6,0X66,0XF6,0X86,0XF6,0X67,0XF6,0X67,0XFE,0X68,0XFE,0X48,0XFE,0X48,

90980XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XFE,0X68,0XFE,0X68,

90990XFE,0X68,0XFE,0X67,0XFE,0X87,0XF6,0X46,0XFE,0X67,0XFE,0X87,0XF6,0X67,0XFE,0X88,

91000XF6,0X68,0XEE,0X48,0XF6,0XAA,0XFF,0X0C,0XFF,0X4E,0XFF,0X4E,0XCD,0XA9,0XB4,0XE6,

91010X9C,0X04,0X8B,0XC3,0X93,0XE4,0X83,0X63,0X83,0X63,0X72,0XE1,0X73,0X02,0X73,0X02,

91020X73,0X02,0X62,0X80,0X62,0X40,0X51,0XE0,0X62,0X41,0X5A,0X20,0X83,0X43,0XC5,0X6A,

91030XE6,0X2A,0XE6,0X29,0XEE,0X28,0XFE,0X89,0XF6,0X46,0XFE,0X66,0XFE,0X86,0XFE,0X67,

91040XFE,0X48,0XFE,0X69,0XF6,0X68,0XF6,0X88,0XF6,0X88,0XFE,0X88,0XFE,0X87,0XFE,0X88,

91050XFE,0X89,0XFE,0X8B,0XF6,0X6D,0XEE,0X4E,0XF6,0XB1,0XFF,0X54,0XFF,0XB8,0XFF,0XFB,

91060XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91140XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDD,0XFF,0XDA,0XF7,0X53,0XE6,0X8B,0XE6,0X47,

91150XF6,0X67,0XFE,0X46,0XF6,0X48,0XF6,0X69,0XF6,0X28,0XF6,0X49,0XFE,0X88,0XF6,0X47,

91160XF6,0X67,0XF6,0X66,0XFE,0X47,0XFE,0X48,0XFE,0X48,0XFE,0X48,0XF6,0X67,0XFE,0X67,

91170XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X67,

91180XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X68,

91190XEE,0X69,0XF6,0XAA,0XFF,0X0C,0XFF,0X4D,0XFF,0X6E,0XF7,0X0D,0XD5,0XEA,0XAC,0XE6,

91200X93,0XE3,0X83,0X62,0X7B,0X21,0X73,0X01,0X72,0XE0,0X6A,0XC0,0X62,0X80,0X6A,0XC0,

91210X7B,0X40,0X83,0X81,0X9C,0X44,0XC5,0X68,0XE6,0X6B,0XEE,0X8B,0XEE,0X69,0XF6,0X68,

91220XFE,0X88,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XF6,0X67,0XF6,0X67,0XF6,0X88,

91230XF6,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X87,0XFE,0XC8,0XFE,0XC9,0XF6,0XAA,0XEE,0X8B,

91240XEE,0XAE,0XF6,0XF2,0XFF,0X76,0XFF,0XDA,0XFF,0XFC,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,

91250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91330XFF,0XFF,0XFF,0XDE,0XFF,0XFB,0XFF,0X76,0XE6,0XCE,0XE6,0X49,0XF6,0X67,0XF6,0X46,

91340XF6,0X47,0XF6,0X48,0XFE,0X49,0XFE,0X49,0XFE,0X69,0XFE,0X68,0XFE,0X67,0XFE,0X67,

91350XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

91360XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X67,

91370XFE,0X67,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X88,0XF6,0X68,0XEE,0X89,

91380XEE,0X89,0XEE,0X89,0XF6,0XEB,0XFF,0X4D,0XFF,0X4E,0XFF,0X2E,0XEE,0XCD,0XD6,0X0A,

91390XC5,0X68,0XB5,0X07,0XB4,0XE6,0XB5,0X06,0XBD,0X06,0XC5,0X67,0XCD,0XC8,0XE6,0X8A,

91400XF7,0X2C,0XFF,0X2C,0XF6,0XC9,0XEE,0X68,0XF6,0X67,0XFE,0XA8,0XFE,0X67,0XFE,0X67,

91410XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XF6,0X87,0XF6,0X87,0XFE,0X88,0XFE,0X89,

91420XFE,0X89,0XFE,0XA9,0XFE,0XCA,0XF6,0X8A,0XEE,0X8B,0XE6,0X6D,0XF7,0X33,0XFF,0X97,

91430XFF,0XDA,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

91520XFF,0XFC,0XFF,0XB8,0XF7,0X11,0XE6,0X8B,0XF6,0X89,0XF6,0X87,0XF6,0X67,0XF6,0X48,

91530XF6,0X48,0XF6,0X28,0XF6,0X28,0XFE,0X69,0XFE,0X68,0XFE,0X67,0XFE,0X68,0XFE,0X68,

91540XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X87,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X68,

91550XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X87,0XFE,0X87,0XFE,0X87,

91560XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XF6,0X68,0XF6,0X88,0XF6,0X88,0XF6,0X88,

91570XF6,0X88,0XF6,0XA9,0XF6,0XCA,0XF6,0XCA,0XFF,0X0C,0XFF,0X2C,0XFF,0X4D,0XFF,0X2D,

91580XFF,0X2D,0XFF,0X2C,0XFF,0X0C,0XFF,0X0C,0XF6,0XEA,0XF6,0XCA,0XEE,0XA8,0XE6,0X66,

91590XEE,0X66,0XF6,0XA7,0XFE,0XA8,0XF6,0X47,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X66,

91600XFE,0X66,0XFE,0X86,0XFE,0XA7,0XFE,0X87,0XFE,0X88,0XFE,0X89,0XFE,0X89,0XF6,0X8A,

91610XF6,0X6C,0XEE,0X8E,0XF6,0XD1,0XFF,0X55,0XFF,0XB8,0XFF,0XDB,0XFF,0XFD,0XFF,0XFE,

91620XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFB,

91710XFF,0X75,0XEE,0XCF,0XEE,0X4A,0XEE,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X68,0XFE,0X68,

91720XFE,0X48,0XFE,0X68,0XFE,0X68,0XF6,0X67,0XF6,0X67,0XFE,0X87,0XFE,0X88,0XFE,0X67,

91730XFE,0X67,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X68,

91740XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,

91750XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X88,

91760XF6,0XA8,0XF6,0XA8,0XEE,0X68,0XF6,0X89,0XF6,0XA9,0XF6,0X89,0XEE,0X68,0XEE,0X68,

91770XF6,0X68,0XF6,0X88,0XF6,0X88,0XEE,0X67,0XF6,0X87,0XFE,0XE8,0XFE,0XA7,0XF6,0X66,

91780XF6,0X67,0XFE,0X88,0XF6,0X47,0XFE,0X47,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,

91790XF6,0X87,0XF6,0X87,0XFE,0X88,0XFE,0X8A,0XFE,0X8B,0XF6,0XAE,0XF6,0XD0,0XF6,0XF3,

91800XF7,0X57,0XFF,0XDA,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

91810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

91850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XB9,0XFF,0X54,

91900XEE,0X8E,0XE6,0X4A,0XEE,0X69,0XF6,0X88,0XFE,0X67,0XFE,0X87,0XFE,0X67,0XFE,0X46,

91910XFE,0X87,0XFE,0X86,0XF6,0X86,0XF6,0X87,0XF6,0X87,0XF6,0X67,0XFE,0X67,0XFE,0X67,

91920XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,

91930XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X67,

91940XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XF6,0X67,0XF6,0X47,0XF6,0X47,

91950XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X88,0XFE,0X88,0XFE,0X88,0XF6,0X67,

91960XF6,0X87,0XFE,0XA7,0XFE,0XA8,0XF6,0X67,0XF6,0X47,0XFE,0X68,0XFE,0X88,0XF6,0X27,

91970XFE,0X88,0XFE,0X68,0XFE,0X48,0XFE,0X68,0XF6,0X68,0XF6,0X88,0XFE,0XA8,0XFE,0XC9,

91980XFE,0XEB,0XF6,0X8C,0XEE,0X4D,0XEE,0XB0,0XFF,0X56,0XFF,0XDA,0XFF,0XFD,0XFF,0XFE,

91990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

92040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

92070XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0X98,0XFF,0X54,0XEE,0XAE,

92090XEE,0X8B,0XF6,0X89,0XF6,0X67,0XFE,0X86,0XFE,0X66,0XFE,0X66,0XFE,0X86,0XF6,0X86,

92100XF6,0X86,0XF6,0X87,0XF6,0X87,0XFE,0X67,0XFE,0X68,0XFE,0X88,0XFE,0X87,0XFE,0X87,

92110XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X87,0XFE,0X87,

92120XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X88,0XFE,0X68,

92130XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X88,0XFE,0X88,0XFE,0X88,

92140XFE,0X67,0XFE,0X88,0XFE,0X88,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X66,0XF6,0X46,

92150XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X47,0XF6,0X48,

92160XFE,0X69,0XFE,0XAA,0XFE,0XAB,0XF6,0X8A,0XEE,0X8A,0XEE,0X8B,0XEE,0X6C,0XF6,0XD0,

92170XFF,0X33,0XFF,0X97,0XFF,0XDA,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92220XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDE,

92260XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92270XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XFF,0XDC,0XFF,0XB9,0XF7,0X14,0XEE,0XCF,0XEE,0X8B,

92280XEE,0X88,0XFE,0XA8,0XFE,0X87,0XFE,0XA8,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X88,

92290XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,

92300XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X87,0XFE,0X87,0XFE,0X87,

92310XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

92320XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X88,0XFE,0X67,0XFE,0X68,

92330XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X88,0XFE,0X67,0XFE,0X67,

92340XFE,0X67,0XFE,0X86,0XFE,0X86,0XFE,0X87,0XFE,0XA7,0XF6,0X88,0XF6,0X69,0XEE,0X6A,

92350XEE,0X6C,0XEE,0X8D,0XF6,0XCF,0XF6,0XF1,0XFF,0X54,0XFF,0X96,0XFF,0XB8,0XFF,0XFA,

92360XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XF7,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92410XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

92440XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,

92450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

92460XFF,0XDF,0XFF,0XFE,0XFF,0XDC,0XFF,0X99,0XFF,0X74,0XEE,0XAF,0XEE,0X8B,0XF6,0XAA,

92470XF6,0X68,0XF6,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X68,

92480XFE,0X68,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X88,

92490XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,

92500XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X68,

92510XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

92520XFE,0X87,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X66,0XFE,0X86,0XF6,0X66,

92530XF6,0X66,0XF6,0XA7,0XF6,0XA9,0XF6,0XAA,0XF6,0XAC,0XF6,0XAE,0XF6,0XD0,0XF7,0X12,

92540XFF,0X55,0XFF,0X97,0XFF,0XDA,0XFF,0XFC,0XFF,0XFC,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,

92550XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

92560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,

92600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92620XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

92630XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X7D,0XF7,0X7D,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

92640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDE,

92650XFF,0XDE,0XFF,0XFC,0XFF,0XD9,0XF7,0X34,0XEE,0XD0,0XEE,0X8D,0XEE,0X6B,0XEE,0X49,

92660XF6,0X48,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X88,0XFE,0X68,0XFE,0X67,

92670XFE,0X88,0XFE,0XA8,0XFE,0X88,0XFE,0X67,0XFE,0X88,0XFE,0X88,0XFE,0X87,0XFE,0X87,

92680XFE,0X88,0XFE,0X87,0XFE,0X87,0XF6,0X87,0XF6,0X87,0XF6,0X87,0XF6,0X87,0XF6,0X87,

92690XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,

92700XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

92710XFE,0X68,0XFE,0X68,0XF6,0X46,0XFE,0X87,0XF6,0XA7,0XF6,0X87,0XF6,0XC9,0XF6,0XAA,

92720XF6,0XCC,0XF6,0XCE,0XF6,0XF1,0XFF,0X34,0XFF,0X77,0XFF,0XB9,0XFF,0XDA,0XFF,0XFB,

92730XFF,0XFD,0XF7,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,

92740XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,

92790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

92810XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,

92820XF7,0X7D,0XEF,0X7D,0XEF,0X5D,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XDF,0XFF,0XDE,

92830XFF,0XDE,0XF7,0XDE,0XF7,0XBE,0XF7,0XBF,0XF7,0XBF,0XF7,0XBF,0XF7,0X9E,0XF7,0X9C,

92840XFF,0XBB,0XFF,0X99,0XF7,0X35,0XEE,0XD2,0XEE,0XAF,0XF6,0XAC,0XEE,0X69,0XF6,0X88,

92850XFE,0X88,0XFE,0X67,0XFE,0X67,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XF6,0X68,0XF6,0X68,

92860XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X87,0XFE,0XA8,0XFE,0X87,0XFE,0X87,

92870XFE,0X88,0XFE,0X87,0XF6,0X87,0XF6,0XA7,0XF6,0X87,0XF6,0X87,0XFE,0X67,0XFE,0X67,

92880XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X87,

92890XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XF6,0X88,0XF6,0X68,0XFE,0X88,0XF6,0X68,

92900XFE,0XA9,0XEE,0X68,0XF6,0XAA,0XF6,0XCB,0XF6,0XED,0XF6,0XEF,0XF6,0XF1,0XF7,0X34,

92910XFF,0X77,0XFF,0XB9,0XFF,0XBA,0XFF,0XBB,0XFF,0XDC,0XFF,0XFD,0XF7,0XFF,0XF7,0XDF,

92920XF7,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

92930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

92940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92970XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,

93000XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XEF,0X9D,0XEF,0X7D,0XEF,0X5D,

93010XEF,0X5D,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XEF,0X9E,0XF7,0X9D,0XF7,0X9D,0XEF,0X7D,

93020XEF,0X7D,0XEF,0X7D,0XE7,0X5D,0XE7,0X5D,0XE7,0X3C,0XE7,0X1B,0XE7,0X1A,0XE7,0X19,

93030XE6,0XD7,0XDE,0X94,0XDE,0X51,0XE6,0X6E,0XF6,0XAC,0XF6,0XCA,0XFE,0XA9,0XF6,0X88,

93040XF6,0X67,0XF6,0X68,0XF6,0X88,0XF6,0X88,0XFE,0XA9,0XFE,0XA9,0XFE,0X68,0XFE,0X68,

93050XFE,0X88,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,

93060XFE,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X67,

93070XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XF6,0X87,0XF6,0X87,

93080XF6,0X88,0XF6,0X68,0XF6,0X68,0XF6,0X89,0XF6,0XA9,0XF6,0XAA,0XFE,0XEC,0XF6,0XCD,

93090XF6,0XCF,0XEE,0XB1,0XEE,0XB3,0XF7,0X16,0XF7,0X18,0XF7,0X39,0XF7,0X5A,0XF7,0X7B,

93100XEF,0X7B,0XEF,0X5B,0XEF,0X5C,0XEF,0X7D,0XEF,0X9E,0XEF,0X7E,0XEF,0X7E,0XF7,0X9E,

93110XF7,0X9E,0XF7,0X9D,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XDE,0XF7,0XDE,0XF7,0XDE,

93120XF7,0XDF,0XF7,0XDF,0XFF,0XBF,0XFF,0XBF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

93130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93160XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,

93190XF7,0XBE,0XF7,0X9E,0XF7,0XBE,0XF7,0X9E,0XF7,0X7D,0XEF,0X5D,0XEF,0X5D,0XF7,0X9E,

93200XEF,0X7E,0XEF,0X7D,0XEF,0X7D,0XEF,0X5C,0XE7,0X3C,0XE7,0X1B,0XE6,0XFB,0XDE,0XFB,

93210XD6,0XDB,0XD6,0XBA,0XD6,0XBA,0XCE,0X99,0XC6,0X58,0XC6,0X17,0XC5,0XD5,0XC5,0XB4,

93220XC5,0X91,0XC5,0X6E,0XCD,0XCC,0XDE,0X2B,0XEE,0X8B,0XF6,0XCC,0XF6,0XAB,0XF6,0X8A,

93230XF6,0X8A,0XF6,0XAA,0XF6,0X89,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X87,

93240XFE,0X88,0XFE,0XA8,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XF6,0X88,0XF6,0X69,

93250XF6,0X69,0XF6,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,

93260XFE,0X87,0XFE,0X87,0XF6,0X87,0XF6,0X87,0XF6,0XA8,0XF6,0XA8,0XF6,0X88,0XEE,0X89,

93270XF6,0X8A,0XF6,0XAB,0XF6,0XCC,0XF6,0XCD,0XDE,0X2D,0XD6,0X0E,0XCD,0XAF,0XCD,0XD2,

93280XCD,0XF4,0XCD,0XF6,0XD6,0X58,0XD6,0X58,0XD6,0X79,0XD6,0X99,0XD6,0XBA,0XD6,0XDA,

93290XDE,0XFB,0XDF,0X1C,0XDE,0XFC,0XDE,0XFC,0XE7,0X1C,0XE7,0X1C,0XEF,0X3C,0XEF,0X3C,

93300XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X9E,0XEF,0X7E,0XEF,0X7E,

93310XF7,0X7E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,

93320XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

93330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

93350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93370XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

93380XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X7E,0XF7,0X7E,0XEF,0X7E,0XEF,0X7D,0XE7,0X5C,

93390XE7,0X5C,0XE7,0X3C,0XE6,0XFB,0XDE,0XDB,0XDE,0XBA,0XD6,0X99,0XCE,0X79,0XC6,0X38,

93400XBE,0X18,0XBD,0XF8,0XB5,0X96,0XA5,0X34,0XA4,0XF3,0X9C,0XB2,0X9C,0X4F,0X8B,0XEC,

93410X83,0X88,0X8B,0XC8,0XA4,0X8A,0XCD,0XAD,0XEE,0X8F,0XEE,0XAE,0XEE,0XAD,0XEE,0XAB,

93420XF6,0X8A,0XF6,0X89,0XF6,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0X87,0XF6,0X67,0XFE,0X67,

93430XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XF6,0X89,0XF6,0X88,

93440XF6,0X68,0XF6,0X68,0XF6,0X88,0XFE,0X88,0XFE,0XA8,0XFE,0XA8,0XF6,0X88,0XF6,0X67,

93450XF6,0X88,0XF6,0XA9,0XF6,0XA9,0XF6,0XCA,0XF6,0XCC,0XF6,0XCD,0XF6,0XCD,0XEE,0XCE,

93460XC5,0XAB,0X8B,0XE6,0X4A,0X00,0X4A,0X02,0X52,0X25,0X5A,0X68,0X62,0XEA,0X73,0X6D,

93470X83,0XEF,0X84,0X0F,0X8C,0X71,0X9C,0XD3,0XA5,0X14,0XA5,0X55,0XAD,0X96,0XB5,0XD6,

93480XC6,0X17,0XC6,0X18,0XCE,0X38,0XCE,0X59,0XD6,0X7A,0XD6,0X9A,0XD6,0XBB,0XDE,0XDB,

93490XDE,0XFB,0XDE,0XFC,0XDF,0X1C,0XDF,0X1C,0XDF,0X1C,0XE7,0X3C,0XE7,0X3D,0XEF,0X5D,

93500XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

93510XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

93520XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

93540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

93560XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

93570XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XEF,0X7D,0XEF,0X7D,0XE7,0X5C,0XE7,0X3C,0XE7,0X1C,

93580XE6,0XFB,0XDE,0XBA,0XDE,0X9A,0XD6,0X99,0XCE,0X59,0XC6,0X38,0XB5,0XD7,0XB5,0XB6,

93590XAD,0X55,0X9C,0XF3,0X94,0X92,0X8C,0X31,0X83,0XAE,0X73,0X6C,0X7B,0X6C,0X62,0XA8,

93600X52,0X24,0X5A,0X64,0X73,0X26,0X94,0X28,0XBD,0X2A,0XDE,0X0C,0XE6,0X2C,0XEE,0X6C,

93610XEE,0X8B,0XEE,0X6A,0XF6,0X8A,0XFE,0XAA,0XFE,0XAA,0XFE,0XA9,0XF6,0X68,0XF6,0X69,

93620XF6,0X89,0XF6,0X69,0XF6,0X89,0XF6,0X89,0XF6,0X89,0XF6,0X89,0XF6,0XA9,0XF6,0X89,

93630XF6,0X69,0XEE,0X69,0XF6,0X69,0XF6,0X8A,0XFE,0XAB,0XFE,0XCB,0XF6,0XAC,0XEE,0X8B,

93640XE6,0X6B,0XE6,0X4C,0XD6,0X0C,0XBD,0X29,0X8B,0XE5,0X6A,0XE2,0X41,0XC0,0X39,0X80,

93650X39,0X61,0X31,0X42,0X31,0X64,0X39,0XA6,0X39,0XC6,0X42,0X07,0X42,0X07,0X4A,0X48,

93660X52,0XAA,0X5B,0X0C,0X63,0X2D,0X6B,0X6D,0X73,0XCF,0X84,0X10,0X94,0X71,0X94,0X92,

93670X9C,0XD3,0XA5,0X14,0XAD,0X55,0XAD,0X75,0XB5,0XB7,0XBD,0XF7,0XC6,0X18,0XC6,0X38,

93680XC6,0X59,0XCE,0X79,0XCE,0X7A,0XD6,0XBA,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,

93690XE7,0X1C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,

93700XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

93710XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

93720XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

93750XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XDF,0XFF,0XDF,0XFF,0XBF,0XFF,0XBF,

93760XF7,0XBF,0XEF,0X7D,0XEF,0X7D,0XE7,0X5C,0XE7,0X5C,0XE7,0X3C,0XE7,0X1C,0XE6,0XFB,

93770XE6,0XDB,0XDE,0XBB,0XD6,0X9A,0XCE,0X79,0XC6,0X58,0XBE,0X38,0XBD,0XD6,0XB5,0X95,

93780XAD,0X55,0XA4,0XF4,0X9C,0X93,0X94,0X72,0X83,0XCF,0X7B,0XAE,0X73,0X6C,0X62,0XE9,

93790X52,0X46,0X4A,0X03,0X52,0X02,0X5A,0X42,0X73,0X04,0X94,0X07,0XB4,0XEA,0XC5,0X6A,

93800XCD,0XAB,0XDE,0X0B,0XE6,0X2B,0XE6,0X2A,0XEE,0X6B,0XF6,0X8C,0XF6,0XAC,0XF6,0XAC,

93810XF6,0XAC,0XF6,0XAC,0XF6,0XAB,0XF6,0XAB,0XF6,0XAB,0XF6,0XAB,0XF6,0X8C,0XF6,0X8C,

93820XEE,0X6C,0XE6,0X2C,0XDD,0XEB,0XD5,0XAB,0XBD,0X0A,0XB4,0XEA,0XA4,0X48,0X7B,0X45,

93830X5A,0X42,0X41,0XA0,0X41,0X81,0X41,0XA2,0X41,0XC4,0X41,0XC4,0X4A,0X47,0X42,0X47,

93840X4A,0X68,0X4A,0X68,0X42,0X48,0X42,0X48,0X4A,0X69,0X4A,0X89,0X52,0XAA,0X52,0XCA,

93850X5A,0XCB,0X5B,0X0B,0X6B,0X4D,0X73,0X8E,0X73,0XAE,0X7B,0XCF,0X84,0X10,0X8C,0X50,

93860X8C,0X91,0X94,0XD2,0X9C,0XF3,0XA5,0X34,0XAD,0X55,0XB5,0X75,0XBD,0XB6,0XBD,0XD7,

93870XC5,0XF7,0XC6,0X38,0XCE,0X78,0XCE,0X99,0XD6,0X9A,0XD6,0XBA,0XD6,0XBA,0XDE,0XDB,

93880XDE,0XFB,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,

93890XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,

93900XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

93910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

93940XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XBF,0XEF,0X7D,

93950XEF,0X7D,0XEF,0X7C,0XEF,0X5C,0XEF,0X5C,0XEF,0X3D,0XEF,0X3C,0XE7,0X1C,0XE6,0XFC,

93960XDE,0XFB,0XDE,0XDB,0XD6,0XBA,0XD6,0XB9,0XCE,0X99,0XCE,0X79,0XCE,0X59,0XCE,0X39,

93970XC5,0XF8,0XBD,0XD7,0XB5,0X96,0XB5,0X96,0XAD,0X34,0X9C,0XD2,0X94,0X90,0X94,0X4F,

93980X8C,0X0D,0X83,0XCB,0X7B,0X89,0X7B,0X48,0X73,0X47,0X7B,0X67,0X8B,0XA7,0X93,0XE7,

93990X9C,0X27,0XA4,0X68,0XB4,0XC9,0XBD,0X09,0XC5,0X2A,0XC5,0X4A,0XBD,0X2A,0XBD,0X29,

94000XBD,0X29,0XBD,0X09,0XB4,0XE8,0XB4,0XC8,0XA4,0X87,0X9C,0X26,0X8B,0XA5,0X7B,0X24,

94010X6A,0XA2,0X62,0X42,0X52,0X01,0X49,0XA0,0X39,0X60,0X39,0X61,0X41,0XA3,0X41,0XE4,

94020X4A,0X05,0X41,0XE6,0X42,0X07,0X4A,0X28,0X4A,0X47,0X52,0X88,0X52,0XA9,0X52,0XA9,

94030X5B,0X0A,0X63,0X0B,0X5B,0X0B,0X5A,0XEB,0X5B,0X0B,0X63,0X0B,0X63,0X2C,0X6B,0X6C,

94040X73,0X8D,0X73,0XAE,0X7B,0XD0,0X7B,0XF0,0X84,0X30,0X8C,0X71,0X94,0X91,0X94,0XB2,

94050X9C,0XF3,0XA5,0X13,0XAD,0X34,0XAD,0X55,0XB5,0X76,0XBD,0XB6,0XBD,0XD7,0XBD,0XF7,

94060XC6,0X17,0XC6,0X37,0XCE,0X58,0XCE,0X59,0XCE,0X79,0XD6,0X9A,0XDE,0XDB,0XDE,0XDB,

94070XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,

94080XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,

94090XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XF7,0XBE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

94100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0X9D,0XF7,0X9D,

94140XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XEF,0X5D,0XEF,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

94150XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XDE,0XDB,0XD6,0XBA,0XD6,0X9A,0XD6,0X9A,0XD6,0X9A,

94160XCE,0X59,0XCE,0X79,0XCE,0X59,0XCE,0X58,0XD6,0X78,0XD6,0X78,0XCE,0X57,0XCE,0X56,

94170XCE,0X15,0XCE,0X15,0XCD,0XF4,0XC5,0XD3,0XBD,0X92,0XB5,0X51,0XB5,0X30,0XB5,0X30,

94180XB5,0X30,0XAD,0X0F,0XAC,0XCE,0XA4,0XAD,0XA4,0X8D,0X9C,0X6C,0X94,0X2B,0X94,0X0A,

94190X8B,0XEA,0X83,0XA9,0X73,0X67,0X6B,0X07,0X6A,0XE6,0X62,0XC6,0X5A,0X85,0X52,0X65,

94200X52,0X66,0X5A,0X86,0X52,0X67,0X52,0X87,0X5A,0XA9,0X5A,0XA9,0X52,0X88,0X62,0XEA,

94210X6B,0X2B,0X6B,0X2B,0X6B,0X2B,0X6B,0X4C,0X6B,0X6C,0X73,0X6C,0X73,0XAD,0X7B,0XAD,

94220X7B,0XEE,0X83,0XEE,0X83,0XEE,0X7B,0XEE,0X7B,0XCE,0X7B,0XEE,0X83,0XEF,0X84,0X0F,

94230X8C,0X51,0X8C,0X71,0X94,0X92,0X94,0XB2,0X9C,0XD3,0X9C,0XF3,0XA5,0X14,0XAD,0X55,

94240XAD,0X75,0XB5,0X76,0XB5,0X96,0XBD,0XB6,0XBD,0XD7,0XBD,0XF7,0XC6,0X18,0XC6,0X38,

94250XCE,0X59,0XCE,0X59,0XCE,0X79,0XD6,0X9A,0XD6,0XBA,0XDE,0XDB,0XDE,0XDB,0XDE,0XFB,

94260XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,

94270XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,

94280XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

94330XF7,0X9E,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XEF,0X5D,

94340XEF,0X5D,0XE7,0X3C,0XE7,0X1C,0XE7,0X1B,0XE7,0X1B,0XE7,0X1C,0XE7,0X3C,0XEF,0X3C,

94350XE7,0X3C,0XEF,0X3C,0XEF,0X5C,0XEF,0X7C,0XEF,0X5C,0XEF,0X7C,0XEF,0X5B,0XEF,0X3B,

94360XEF,0X3B,0XEF,0X3A,0XEF,0X1A,0XE6,0XFA,0XE6,0XD9,0XE6,0XF9,0XE6,0XD9,0XDE,0XB8,

94370XDE,0X98,0XDE,0X97,0XDE,0X77,0XD6,0X77,0XD6,0X57,0XCE,0X56,0XCE,0X56,0XCE,0X36,

94380XC6,0X15,0XC5,0XF5,0XC5,0XD4,0XBD,0XD4,0XBD,0XD4,0XBD,0XB4,0XBD,0XB4,0XB5,0XB4,

94390XB5,0X94,0XAD,0X74,0XAD,0X54,0XA5,0X33,0XA5,0X33,0XA5,0X33,0XA4,0XF2,0XA4,0XF2,

94400XA4,0XF2,0XA4,0XF2,0XA4,0XF2,0XA5,0X12,0XAD,0X33,0XAD,0X33,0XAD,0X53,0XAD,0X54,

94410XB5,0X74,0XB5,0X74,0XAD,0X54,0XAD,0X33,0XA4,0XF3,0X9C,0XF2,0XA5,0X14,0XA5,0X34,

94420XAD,0X55,0XAD,0X75,0XAD,0X75,0XB5,0X96,0XB5,0XB6,0XBD,0XD7,0XBD,0XF7,0XBD,0XF7,

94430XC6,0X18,0XC6,0X18,0XC6,0X38,0XCE,0X59,0XCE,0X59,0XCE,0X79,0XD6,0X9A,0XD6,0X9A,

94440XD6,0X9A,0XD6,0XBA,0XDE,0XDB,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,

94450XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,

94460XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

94470XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94510XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

94520XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XEF,0X7D,

94530XEF,0X7D,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDE,

94540XFF,0XDE,0XFF,0XDE,0XFF,0XDD,0XFF,0XDD,0XF7,0XBD,0XF7,0X9C,0XF7,0X9C,0XF7,0X9C,

94550XF7,0X9C,0XF7,0X9C,0XF7,0X7C,0XF7,0X7C,0XF7,0X7C,0XF7,0X7B,0XEF,0X7B,0XEF,0X7B,

94560XF7,0X7B,0XEF,0X7B,0XEF,0X7B,0XEF,0X5B,0XEF,0X5B,0XEF,0X5B,0XEF,0X5B,0XEF,0X5A,

94570XEF,0X5A,0XEF,0X3A,0XEF,0X3A,0XEF,0X5A,0XE7,0X1A,0XE6,0XFA,0XE7,0X1A,0XE7,0X1A,

94580XDE,0XFA,0XE7,0X1A,0XE7,0X3B,0XDE,0XFA,0XDE,0XFA,0XDE,0XF9,0XDE,0XD9,0XDE,0XD9,

94590XDE,0XD9,0XDE,0XD9,0XDE,0XD9,0XDE,0XD9,0XDE,0XB9,0XDE,0XB9,0XDE,0XD9,0XDE,0XD9,

94600XDE,0XD9,0XDE,0XD9,0XD6,0XB9,0XD6,0X99,0XC6,0X38,0XCE,0X59,0XCE,0X59,0XC6,0X38,

94610XC6,0X38,0XCE,0X59,0XCE,0X79,0XCE,0X79,0XCE,0X79,0XCE,0X79,0XD6,0X9A,0XD6,0X9A,

94620XD6,0X9A,0XD6,0XBA,0XD6,0XBA,0XD6,0XBA,0XDE,0XDB,0XDE,0XDB,0XDE,0XDB,0XDE,0XFB,

94630XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,

94640XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,

94650XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

94660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94700XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

94710XF7,0XBE,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,

94720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

94730XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,

94740XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,

94750XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XBD,0XFF,0XBC,

94760XF7,0XBC,0XF7,0XBC,0XFF,0XDD,0XFF,0XBD,0XFF,0XDD,0XF7,0XBD,0XF7,0X9C,0XF7,0XBD,

94770XFF,0XDD,0XF7,0X9C,0XF7,0XBD,0XF7,0XBC,0XF7,0XBC,0XF7,0XBC,0XF7,0XBC,0XF7,0XBC,

94780XF7,0X9C,0XF7,0X9C,0XF7,0X9C,0XF7,0X9C,0XF7,0X7C,0XF7,0X7C,0XF7,0X9C,0XF7,0X9C,

94790XF7,0X9C,0XF7,0X9D,0XEF,0X5C,0XE7,0X3C,0XDE,0XFB,0XDE,0XDB,0XDE,0XDB,0XDE,0XFB,

94800XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,

94810XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

94820XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

94830XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,

94840XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,

94850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94890XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

94900XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94920XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

94930XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

94940XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

94950XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,

94960XFF,0XFD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,

94970XFF,0XFE,0XFF,0XFD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,

94980XFF,0XFF,0XF7,0XBE,0XF7,0X9E,0XEF,0X7D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,

94990XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,

95000XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

95010XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,

95020XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

95030XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95080XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

95110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95130XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

95140XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

95150XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

95160XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95170XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0X9E,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

95180XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

95190XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

95200XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

95210XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

95220XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

95290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95320XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,

95330XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

95340XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95360XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

95370XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

95380XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

95390XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

95400XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,

95410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95550XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

95560XFF,0XDF,0XF7,0XBE,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

95570XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

95580XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

95590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

95600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95850XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,};

9599

9600const unsigned char gimage_9[51000] = { /* 0X10,0X10,0X00,0X96,0X00,0XAA,0X01,0X1B, */

96010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96670XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

96900XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDF,0XFF,0XDF,

97090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97410XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

97420XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

97430XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97590XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,

97600XFF,0XFC,0XFF,0XFB,0XFF,0XFB,0XFF,0XFB,0XFF,0XFB,0XFF,0XFB,0XFF,0XFB,0XFF,0XFB,

97610XFF,0XFB,0XFF,0XFB,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFD,0XFF,0XFD,

97620XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,

97780XFF,0XFC,0XFF,0XFB,0XFF,0XFB,0XFF,0XFA,0XFF,0XF9,0XFF,0XF9,0XFF,0XD8,0XFF,0XF7,

97790XFF,0XF7,0XFF,0XD7,0XFF,0XF7,0XFF,0XF7,0XFF,0XF7,0XFF,0XD7,0XFF,0XF8,0XFF,0XF8,

97800XFF,0XF8,0XFF,0XF9,0XFF,0XF9,0XFF,0XFA,0XFF,0XFB,0XFF,0XFB,0XFF,0XFC,0XFF,0XFD,

97810XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,

97950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

97960XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,0XFF,0XF9,0XFF,0XF7,0XFF,0XF7,0XFF,0XF7,

97970XFF,0XF6,0XFF,0XF5,0XFF,0XF5,0XFF,0XF4,0XFF,0XF3,0XFF,0XF3,0XFF,0XF3,0XFF,0XF2,

97980XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XD2,0XFF,0XF4,0XFF,0XD4,0XFF,0XF4,0XFF,0XF5,

97990XFF,0XF5,0XFF,0XF6,0XFF,0XF7,0XFF,0XF8,0XFF,0XF9,0XFF,0XFA,0XFF,0XFB,0XFF,0XFC,

98000XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

98140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XFB,

98150XFF,0XF9,0XFF,0XF7,0XFF,0XF5,0XF7,0XF3,0XFF,0XF3,0XFF,0XF3,0XFF,0XF3,0XFF,0XF2,

98160XFF,0XF2,0XFF,0XF2,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

98170XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF2,0XFF,0XF2,0XFF,0XF3,

98180XFF,0XF4,0XFF,0XF5,0XFF,0XD6,0XFF,0XF7,0XFF,0XF8,0XFF,0XF9,0XFF,0XFB,0XFF,0XFC,

98190XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98320XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

98330XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0XF9,0XFF,0XF7,0XFF,0XF5,0XFF,0XF4,

98340XF7,0XF2,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,

98350XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XD0,0XFF,0XD0,0XFF,0XF0,

98360XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF2,0XFF,0XF3,

98370XFF,0XF3,0XFF,0XF4,0XFF,0XF4,0XFF,0XF5,0XFF,0XF7,0XFF,0XF9,0XFF,0XFA,0XFF,0XFC,

98380XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98390XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98510XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,

98520XFF,0XF9,0XFF,0XD7,0XFF,0XD5,0XFF,0XF4,0XFF,0XF3,0XFF,0XF2,0XFF,0XF1,0XFF,0XF0,

98530XFF,0XF0,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

98540XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XD0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,

98550XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,

98560XFF,0XF1,0XFF,0XF2,0XFF,0XF3,0XFF,0XF5,0XFF,0XF7,0XFF,0XF8,0XFF,0XFB,0XFF,0XFC,

98570XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98580XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98700XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XFA,0XFF,0XF8,0XFF,0XF6,0XFF,0XF4,0XF7,0XD2,

98710XF7,0XD1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

98720XFF,0XF0,0XFF,0XD0,0XFF,0XF0,0XFF,0XF0,0XFF,0XD0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

98730XFF,0XD0,0XFF,0XF0,0XFF,0XF0,0XFF,0XD0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

98740XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

98750XFF,0XF0,0XFF,0XF2,0XFF,0XD3,0XFF,0XD5,0XFF,0XF8,0XFF,0XF9,0XFF,0XFB,0XFF,0XFC,

98760XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,

98890XFF,0XFA,0XFF,0XF7,0XF7,0XF5,0XF7,0XF3,0XF7,0XF1,0XF7,0XEF,0XF7,0XEF,0XFF,0XEF,

98900XFF,0XF0,0XFF,0XD0,0XFF,0XD0,0XFF,0XD0,0XFF,0XCF,0XFF,0XCF,0XFF,0XCF,0XFF,0XCF,

98910XFF,0XCF,0XFF,0XF0,0XFF,0XCF,0XFF,0XF0,0XFF,0XF0,0XFF,0XCF,0XFF,0XCF,0XFF,0XF0,

98920XFF,0XF0,0XFF,0XCF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

98930XFF,0XF0,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XF0,

98940XFF,0XD1,0XFF,0XD2,0XFF,0XF5,0XFF,0XF7,0XFF,0XF9,0XFF,0XFB,0XFF,0XFC,0XFF,0XFE,

98950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99070XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0XF9,0XFF,0XF6,0XFF,0XF4,

99080XFF,0XF2,0XF7,0XF0,0XF7,0XEF,0XF7,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XF0,0XFF,0XD0,

99090XFF,0XD0,0XFF,0X8E,0XFF,0X8C,0XFF,0X8C,0XFF,0X8B,0XFF,0X8C,0XFF,0XAD,0XFF,0XCF,

99100XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XF7,0XCE,0XF7,0XEE,0XFF,0XEF,

99110XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XEF,

99120XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,

99130XFF,0XF2,0XFF,0XF4,0XFF,0XF5,0XFF,0XF8,0XFF,0XFA,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,

99140XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

99260XFF,0XFC,0XFF,0XFA,0XFF,0XD8,0XFF,0XD5,0XFF,0XF3,0XFF,0XF2,0XF7,0XF1,0XF7,0XEF,

99270XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XCE,0XFF,0XAE,0XFF,0X6E,0XF7,0X0D,0XEE,0XCA,

99280XE6,0X87,0XD6,0X45,0XD6,0X25,0XD6,0X46,0XDE,0X68,0XEF,0X0B,0XFF,0X8E,0XFF,0XF0,

99290XFF,0XCE,0XFF,0XCF,0XFF,0XEF,0XFF,0XEF,0XF7,0XEE,0XF7,0XEE,0XFF,0XEF,0XFF,0XEF,

99300XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

99310XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XD1,

99320XFF,0XD3,0XFF,0XD5,0XFF,0XF7,0XFF,0XF9,0XFF,0XFB,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,

99330XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XF9,0XFF,0XF6,

99450XFF,0XD4,0XFF,0XF2,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,

99460XFF,0XEE,0XFF,0XAD,0XFF,0X4C,0XF6,0XCA,0XEE,0X48,0XE6,0X47,0XE6,0X26,0XDD,0XE4,

99470XDD,0XC4,0XCD,0X83,0XBD,0X03,0XC5,0X45,0XD6,0X29,0XFF,0X8F,0XFF,0XCF,0XFF,0XCF,

99480XFF,0XCF,0XFF,0XEF,0XFF,0XEF,0XF7,0XCE,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

99490XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

99500XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF1,0XFF,0XF2,

99510XFF,0XF4,0XFF,0XF6,0XFF,0XF9,0XFF,0XFB,0XFF,0XFD,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

99520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99630XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0XF8,0XFF,0XD5,0XFF,0XD3,0XFF,0XF1,0XFF,0XF0,

99640XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XCE,0XFF,0XAD,0XFF,0X4C,

99650XEE,0XC9,0XE6,0X47,0XE5,0XE5,0XE5,0XC4,0XDD,0XA3,0XDD,0X82,0XD5,0X62,0XCD,0X22,

99660XB4,0X81,0XAC,0X61,0XAC,0X62,0XD5,0XE9,0XF7,0X4E,0XFF,0XF0,0XFF,0XCF,0XF7,0XCF,

99670XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

99680XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

99690XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF1,0XFF,0XF3,

99700XFF,0XF6,0XFF,0XF8,0XFF,0XFB,0XFF,0XFD,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

99710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XFA,

99820XFF,0XF7,0XFF,0XD5,0XFF,0XD2,0XFF,0XD0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

99830XFF,0XEF,0XFF,0XEF,0XFF,0XCE,0XFF,0XAD,0XFF,0X4B,0XEE,0XA9,0XE6,0X26,0XEE,0X26,

99840XFE,0X67,0XFE,0X46,0XF6,0X04,0XEE,0X03,0XE5,0XC2,0XDD,0X62,0XC4,0XE1,0XAC,0X00,

99850X8B,0X40,0X9C,0X01,0XDE,0X2A,0XFF,0X8F,0XFF,0XCF,0XFF,0XCE,0XFF,0XEF,0XFF,0XEF,

99860XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

99870XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

99880XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XF7,0XF1,0XF7,0XD3,0XFF,0XD6,

99890XFF,0XD9,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100000XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFA,0XFF,0XF7,0XFF,0XF4,0XFF,0XF1,

100010XFF,0XF0,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEE,0XFF,0XCE,

100020XFF,0XCE,0XFF,0X8D,0XF6,0XE9,0XE6,0X06,0XDD,0XC4,0XF6,0X46,0XFE,0XA7,0XFE,0X86,

100030XFE,0X45,0XF6,0X24,0XED,0XC2,0XE5,0XA2,0XE5,0XA3,0XCC,0XE1,0X9B,0XA0,0X82,0XE0,

100040XAC,0X83,0XE6,0X8B,0XFF,0XAF,0XFF,0XEF,0XFF,0XEE,0XFF,0XED,0XFF,0XEF,0XFF,0XEF,

100050XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

100060XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,

100070XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XF7,0XEF,0XF7,0XD1,0XF7,0XD3,0XFF,0XD6,0XFF,0XD9,

100080XFF,0XDD,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100180XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

100190XFF,0XFD,0XFF,0XFA,0XFF,0XF6,0XFF,0XF3,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

100200XFF,0XEE,0XFF,0XCE,0XFF,0XCE,0XFF,0XEF,0XFF,0XCF,0XFF,0XCE,0XFF,0XAD,0XF6,0XEA,

100210XEE,0X67,0XD5,0X83,0XE5,0XA3,0XF6,0X25,0XFE,0X86,0XFE,0XA7,0XFE,0X87,0XFE,0X46,

100220XEE,0X04,0XE5,0XC3,0XE5,0XE2,0XD5,0X61,0XCD,0X41,0X93,0X60,0X8B,0X20,0XC5,0X06,

100230XFF,0X2E,0XFF,0XEF,0XFF,0XCC,0XFF,0XEC,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

100240XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

100250XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,

100260XFF,0XED,0XF7,0XED,0XFF,0XEF,0XFF,0XF1,0XFF,0XD4,0XFF,0XB6,0XFF,0XDA,0XFF,0XFD,

100270XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

100370XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFB,0XFF,0XF7,

100380XFF,0XF4,0XFF,0XF1,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

100390XFF,0XEE,0XFF,0XEF,0XFF,0XAF,0XFF,0XCE,0XFF,0X8D,0XE6,0X27,0XDD,0XE4,0XCD,0X21,

100400XDD,0X83,0XED,0XC3,0XF6,0X24,0XFE,0X66,0XFE,0X88,0XFE,0X88,0XF6,0X67,0XEE,0X45,

100410XE6,0X02,0XE5,0XE1,0XDD,0X81,0XC4,0XC0,0X9B,0X80,0XA4,0X01,0XDD,0XE9,0XFF,0X8E,

100420XFF,0XCD,0XFF,0XCC,0XFF,0XED,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

100430XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

100440XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,

100450XFF,0XED,0XFF,0XF0,0XFF,0XD1,0XF7,0XB4,0XFF,0XD8,0XFF,0XFB,0XFF,0XDE,0XFF,0XFF,

100460XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

100560XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XFF,0XD7,0XFF,0XD4,0XFF,0XD1,0XFF,0XEF,

100570XFF,0XCF,0XFF,0XEF,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,

100580XFF,0XAE,0XFF,0XCF,0XF6,0XEB,0XD5,0XA4,0XD5,0X62,0XD5,0X21,0XE5,0X82,0XE5,0XA2,

100590XED,0XC3,0XFE,0X67,0XFE,0X88,0XFE,0XA9,0XFE,0XA8,0XF6,0X87,0XF6,0X65,0XEE,0X23,

100600XE5,0XC2,0XE5,0XC3,0XBC,0XA0,0X9B,0XA0,0XC5,0X25,0XFF,0X4D,0XFF,0XAE,0XFF,0XCD,

100610XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

100620XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

100630XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,

100640XFF,0XF0,0XFF,0XD2,0XFF,0XB5,0XFF,0XB8,0XFF,0XFC,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

100650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,

100750XFF,0XFC,0XFF,0XD8,0XFF,0XD5,0XFF,0XD1,0XFF,0XCF,0XFF,0XEF,0XFF,0XCF,0XFF,0XCF,

100760XFF,0XEE,0XFF,0XED,0XFF,0XEC,0XFF,0XED,0XFF,0XED,0XFF,0XCD,0XFF,0XCE,0XFF,0X6D,

100770XE6,0X48,0XB4,0XC1,0XCD,0X21,0XD5,0X21,0XDD,0X20,0XE5,0XA2,0XED,0XC3,0XEE,0X04,

100780XFE,0X87,0XFE,0XA9,0XFE,0XA9,0XFE,0XA8,0XF6,0X86,0XFE,0X65,0XF6,0X23,0XF6,0X03,

100790XE5,0X83,0XC4,0XA1,0XB4,0XA3,0XE6,0XAA,0XFF,0XAD,0XFF,0XEE,0XFF,0XED,0XFF,0XED,

100800XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

100810XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XEE,

100820XFF,0XEE,0XFF,0XEE,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEE,0XFF,0XD0,

100830XFF,0XB2,0XF7,0X94,0XFF,0XFA,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

100840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XF9,0XFF,0XD5,

100940XFF,0XD1,0XFF,0XCF,0XFF,0XCF,0XFF,0XCF,0XFF,0XCF,0XFF,0XEE,0XFF,0XED,0XFF,0XED,

100950XFF,0XEC,0XFF,0XEC,0XFF,0XCD,0XFF,0XCE,0XFF,0XAE,0XFF,0X4C,0XBD,0X23,0XAC,0X60,

100960XD5,0X42,0XD5,0X21,0XDD,0X40,0XDD,0X60,0XE5,0XC1,0XE5,0XC2,0XF6,0X65,0XFE,0XA8,

100970XFE,0XA8,0XFE,0XA9,0XFE,0XA7,0XFE,0XA7,0XFE,0XA6,0XFE,0X25,0XF6,0X06,0XE5,0XA5,

100980XBC,0XC2,0XD5,0XE6,0XFF,0XAC,0XFF,0XCC,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

100990XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEC,

101000XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XED,0XFF,0XED,

101010XFF,0XEC,0XFF,0XEB,0XFF,0XEB,0XFF,0XEB,0XFF,0XED,0XFF,0XCE,0XFF,0XB0,0XF7,0X91,

101020XFF,0XB5,0XFF,0XD9,0XFF,0XFC,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101120XFF,0XDF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFA,0XFF,0XD5,0XFF,0XD2,0XFF,0XCF,0XFF,0XCE,

101130XFF,0XCE,0XFF,0XCE,0XFF,0XCE,0XFF,0XCE,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,

101140XFF,0XCD,0XFF,0XCE,0XFF,0XCE,0XF7,0X0B,0XA4,0X20,0XB4,0X60,0XCD,0X02,0XD5,0X21,

101150XD5,0X00,0XDD,0X40,0XE5,0XA0,0XE5,0XC2,0XF6,0X44,0XF6,0X86,0XF6,0X88,0XFE,0XA9,

101160XFE,0XA9,0XFE,0XA8,0XFE,0X87,0XFE,0X66,0XFE,0X47,0XFE,0X68,0XCD,0X64,0XBD,0X23,

101170XFF,0X8B,0XFF,0XCC,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

101180XFF,0XED,0XFF,0XED,0XFF,0XCD,0XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,

101190XFF,0XEC,0XFF,0XEC,0XFF,0XCC,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XEC,0XFF,0XEB,

101200XFF,0XEB,0XFF,0XEB,0XFF,0XCC,0XFF,0XCD,0XFF,0XAE,0XFF,0XB0,0XEF,0X51,0XFF,0XB6,

101210XFF,0XFB,0XFF,0XDD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFD,

101310XFF,0XFB,0XFF,0XD7,0XF7,0XB2,0XFF,0XCF,0XFF,0XCE,0XFF,0XCD,0XFF,0XCE,0XFF,0XCE,

101320XFF,0XCD,0XFF,0XCC,0XFF,0XEC,0XFF,0XEC,0XFF,0XCD,0XFF,0XCD,0XFF,0XCE,0XFF,0XAE,

101330XFF,0XAE,0XEE,0XAA,0X8B,0X80,0XBC,0XC1,0XC4,0XE2,0XC4,0XC0,0XCC,0XC0,0XCC,0XC0,

101340XD5,0X20,0XDD,0XA2,0XE5,0XE3,0XF6,0X45,0XF6,0X87,0XFE,0X68,0XFE,0X69,0XFE,0X69,

101350XFE,0X68,0XFE,0X88,0XFE,0X68,0XFE,0X88,0XEE,0X48,0XBD,0X23,0XEE,0XC8,0XFF,0XCC,

101360XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCD,

101370XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCC,

101380XFF,0XCC,0XFF,0XCC,0XFF,0XCD,0XFF,0XCD,0XFF,0XCC,0XFF,0XCC,0XFF,0XCB,0XFF,0XCB,

101390XFF,0XCC,0XFF,0XCC,0XFF,0XAD,0XFF,0XCE,0XF7,0X4F,0XF7,0X52,0XFF,0XD9,0XFF,0XDC,

101400XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

101490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XD8,0XFF,0XB4,

101500XF7,0XAF,0XF7,0XAD,0XFF,0XCC,0XFF,0XCC,0XFF,0XAD,0XFF,0XAD,0XFF,0XAC,0XFF,0XCC,

101510XFF,0XCC,0XFF,0XCC,0XFF,0XCD,0XFF,0XCD,0XFF,0XAE,0XFF,0XAE,0XFF,0X8E,0XCD,0X86,

101520X9B,0XE0,0XBC,0XC2,0XC4,0XC2,0XC4,0XA1,0XBC,0X40,0XBC,0X60,0XBC,0X80,0XC5,0X01,

101530XCD,0X41,0XE6,0X04,0XF6,0X68,0XF6,0X49,0XFE,0X4A,0XFE,0X6A,0XFE,0X68,0XFE,0X88,

101540XFE,0X88,0XF6,0X68,0XFE,0XCB,0XCD,0X85,0XD5,0XE6,0XFF,0XAC,0XFF,0XAC,0XFF,0XCC,

101550XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XED,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

101560XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XAD,0XFF,0XAD,0XFF,0XCD,0XFF,0XCC,0XFF,0XCC,

101570XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,

101580XFF,0XAC,0XFF,0XAC,0XFF,0XAE,0XEF,0X2F,0XFF,0X76,0XFF,0XDB,0XFF,0XDD,0XFF,0XDF,

101590XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

101680XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XD9,0XFF,0XB5,0XF7,0XB1,0XF7,0XAE,0XFF,0XCC,

101690XFF,0XCC,0XFF,0XCC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XCC,

101700XFF,0XCD,0XFF,0XCD,0XFF,0XAE,0XFF,0XAE,0XFF,0X8E,0XBD,0X25,0X9B,0XC0,0XB4,0X62,

101710XBC,0X61,0XB4,0X20,0XB3,0XE0,0XAB,0XE0,0XA4,0X00,0XA4,0X21,0XB4,0X81,0XCD,0X44,

101720XE5,0XE8,0XF6,0X2A,0XFE,0X4A,0XFE,0X8A,0XFE,0X67,0XFE,0XA8,0XFE,0XA9,0XFE,0X8A,

101730XFE,0X8C,0XDD,0XC8,0XC5,0X25,0XFF,0X6D,0XFF,0XAD,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,

101740XFF,0XAC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,

101750XFF,0XAC,0XFF,0XAC,0XFF,0XAD,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0X8D,0XFF,0X8E,

101760XFF,0X8E,0XFF,0X8D,0XFF,0X8C,0XFF,0X8C,0XFF,0X6C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,

101770XFF,0XAD,0XEF,0X4E,0XEE,0XF2,0XFF,0XB9,0XFF,0XDD,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

101780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,

101870XFF,0XFA,0XFF,0XD6,0XF7,0X92,0XF7,0X8F,0XFF,0X8D,0XFF,0XAC,0XFF,0XAC,0XFF,0XAB,

101880XFF,0XAB,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,

101890XFF,0XAD,0XFF,0X8E,0XFF,0X4D,0XB4,0XC4,0X9B,0XA0,0XB4,0X42,0XB4,0X21,0XAB,0XC0,

101900XA3,0X80,0X93,0X40,0X8B,0X60,0X83,0X40,0X9B,0XC1,0XAC,0X43,0XC4,0XE6,0XE5,0XC9,

101910XF6,0X2A,0XF6,0X49,0XFE,0X88,0XFE,0XC9,0XF6,0X8A,0XFE,0XCD,0XF6,0X8E,0XE6,0X2D,

101920XBD,0X07,0XF7,0X0E,0XFF,0X8E,0XFF,0XAD,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,

101930XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0X8C,

101940XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8D,0XFF,0X6E,0XFF,0X6D,0XFF,0X6D,

101950XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X8C,0XF7,0X4B,0XFF,0X6E,

101960XE6,0XAF,0XF7,0X56,0XFF,0XDB,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102050XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFC,0XFF,0XF7,0XFF,0XB3,

102060XF7,0X50,0XFF,0X4E,0XFF,0X6C,0XFF,0X8B,0XFF,0X8C,0XFF,0X8B,0XFF,0X8C,0XFF,0X8C,

102070XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8B,0XFF,0XAB,0XFF,0XAC,0XFF,0X8C,0XFF,0X8D,

102080XF6,0XEC,0XAC,0X63,0X9B,0XC0,0XAC,0X23,0XAC,0X02,0X9B,0XA1,0X93,0X40,0X83,0X00,

102090X7A,0XE0,0X72,0XE0,0X72,0XC0,0X83,0X63,0XA4,0X05,0XC4,0XE7,0XE5,0XC8,0XF6,0X48,

102100XFE,0X89,0XFE,0XEB,0XE6,0X6B,0XEE,0XAF,0XF7,0X12,0XFF,0X53,0XBD,0X6B,0XDE,0X4D,

102110XFF,0X8F,0XFF,0X8D,0XFF,0XAD,0XFF,0X8B,0XFF,0X8B,0XFF,0XAC,0XFF,0X6B,0XFF,0X8C,

102120XFF,0X6C,0XFF,0X6C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,

102130XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,

102140XFF,0X6C,0XFF,0X4C,0XFF,0X4B,0XFF,0X4C,0XFF,0X2C,0XFF,0X4E,0XEE,0XCE,0XE6,0XB0,

102150XFF,0X97,0XFF,0XFC,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

102160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102240XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XDA,0XFF,0XB4,0XFF,0X90,0XF7,0X4E,0XFF,0X4D,

102250XFF,0X4B,0XFF,0X6B,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6D,

102260XFF,0X8C,0XFF,0X8B,0XFF,0X8B,0XFF,0X8B,0XFF,0X8C,0XFF,0X6D,0XF6,0XCB,0XA4,0X01,

102270XA3,0XE2,0XA3,0XE2,0X9B,0XC2,0X93,0X61,0X83,0X00,0X7A,0XC0,0X6A,0X80,0X62,0X60,

102280X5A,0X20,0X62,0X61,0X7B,0X23,0XA4,0X05,0XC5,0X06,0XE5,0XE8,0XEE,0X6A,0XEE,0X6C,

102290XEE,0XB0,0XFF,0X74,0XFF,0XB7,0XFF,0XD8,0XD6,0X30,0XC5,0XAC,0XFF,0X50,0XFF,0X6D,

102300XFF,0X6C,0XFF,0X8B,0XFF,0X8B,0XFF,0X8B,0XFF,0X6B,0XFF,0X4C,0XFF,0X6C,0XFF,0X6C,

102310XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X4B,

102320XFF,0X6B,0XFF,0X6B,0XFF,0X6B,0XFF,0X4B,0XFF,0X4C,0XFF,0X4C,0XFF,0X2C,0XFF,0X4C,

102330XFF,0X4C,0XFF,0X2B,0XFF,0X2C,0XFF,0X4D,0XF6,0XED,0XDE,0X4C,0XF7,0X74,0XFF,0XF9,

102340XFF,0XFD,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,

102430XFF,0XFC,0XFF,0XB7,0XF7,0X51,0XF7,0X4E,0XF7,0X4D,0XFF,0X2C,0XFF,0X4B,0XFF,0X4B,

102440XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X6C,0XFF,0X6B,

102450XFF,0X8B,0XFF,0X8C,0XFF,0X8C,0XFF,0X6D,0XEE,0XAB,0X9B,0XE1,0XAC,0X22,0X9B,0XC2,

102460X93,0X81,0X8B,0X21,0X82,0XE0,0X72,0XA0,0X62,0X40,0X5A,0X20,0X49,0XE0,0X49,0XE1,

102470X5A,0X62,0X7B,0X23,0X93,0XE4,0XBD,0X08,0XD5,0XCB,0XDE,0X6E,0XF7,0X55,0XFF,0XD9,

102480XFF,0XFA,0XFF,0XFB,0XEE,0XF5,0XAC,0XEB,0XFF,0X30,0XFF,0X4D,0XFF,0X6C,0XFF,0X6B,

102490XFF,0X6B,0XFF,0X6B,0XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4B,0XFF,0X6B,

102500XFF,0X6C,0XFF,0X4C,0XFF,0X4C,0XFF,0X6B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4A,

102510XFF,0X4B,0XFF,0X4B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X4B,0XFF,0X2B,

102520XFF,0X0B,0XFF,0X2C,0XF6,0XEC,0XDE,0X2B,0XDE,0X90,0XFF,0XB8,0XFF,0XFD,0XFF,0XFF,

102530XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XDA,0XF7,0X75,

102620XF7,0X2F,0XF7,0X2D,0XFF,0X2C,0XFF,0X2C,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4C,

102630XFF,0X2C,0XFF,0X4C,0XFF,0X2C,0XFF,0X4C,0XFF,0X4C,0XFF,0X6B,0XFF,0X6B,0XFF,0X6C,

102640XFF,0X6C,0XFF,0X6D,0XE6,0X4A,0X9B,0XE1,0XA4,0X22,0X9B,0XA1,0X93,0X61,0X83,0X21,

102650X7A,0XE0,0X72,0X80,0X62,0X40,0X5A,0X21,0X41,0XA0,0X41,0XC1,0X41,0XC0,0X5A,0X62,

102660X6A,0XE2,0X94,0X06,0XAC,0XEA,0XE6,0XD3,0XFF,0XFA,0XFF,0XFC,0XFF,0XDC,0XFF,0XFC,

102670XFF,0X9A,0XA4,0X8A,0XF6,0XEF,0XFF,0X2D,0XFF,0X4C,0XFF,0X6B,0XFF,0X6B,0XFF,0X6B,

102680XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,

102690XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X2A,0XFF,0X2A,0XFF,0X2A,0XFF,0X2B,0XFF,0X2B,

102700XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X0B,0XFF,0X0A,0XFF,0X2B,0XFF,0X0B,0XF7,0X0B,

102710XFF,0X0C,0XE6,0X8C,0XBD,0XAB,0XF7,0X75,0XFF,0XFB,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,

102720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102800XFF,0XFF,0XF7,0XDE,0XFF,0XDD,0XFF,0XFC,0XFF,0X77,0XF7,0X11,0XF7,0X0D,0XF7,0X0C,

102810XFF,0X0B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2C,0XFF,0X2C,0XFF,0X2C,

102820XFF,0X0C,0XFF,0X2C,0XFF,0X2C,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2C,0XFF,0X2C,

102830XDE,0X08,0XA4,0X21,0X9B,0XE1,0X93,0X80,0X8B,0X61,0X83,0X01,0X72,0XC1,0X6A,0X81,

102840X5A,0X20,0X52,0X01,0X49,0XC1,0X49,0XE1,0X41,0XE1,0X4A,0X01,0X52,0X42,0X5A,0XC3,

102850X94,0X8B,0XFF,0XFA,0XFF,0XFD,0XF7,0XBC,0XFF,0XFE,0XFF,0XFD,0XFF,0X9A,0XB5,0X2E,

102860XE6,0X4D,0XF7,0X0C,0XFF,0X4C,0XFF,0X4A,0XFF,0X4B,0XFF,0X6C,0XF7,0X0C,0XFF,0X2C,

102870XFF,0X2B,0XFF,0X2B,0XFF,0X2A,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,

102880XFF,0X2A,0XFF,0X2A,0XFF,0X2A,0XFF,0X2A,0XFF,0X2A,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,

102890XFF,0X2B,0XFF,0X0A,0XFF,0X0A,0XFF,0X0B,0XFF,0X0B,0XF6,0XEA,0XFF,0X2C,0XEE,0XCC,

102900XC5,0XCA,0XCE,0X0E,0XFF,0XD9,0XFF,0X9C,0XFF,0XDE,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,

102910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XDD,

102990XFF,0XDD,0XFF,0XB9,0XF7,0X33,0XF6,0XEF,0XFF,0X0D,0XFF,0X0B,0XFF,0X0B,0XFF,0X2B,

103000XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X0C,0XFF,0X0C,0XFF,0X0C,

103010XFF,0X2C,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2C,0XFF,0X2C,0XDD,0XE8,0XA4,0X42,

103020X93,0XA0,0X8B,0X60,0X8B,0X61,0X7B,0X01,0X72,0XC1,0X6A,0X81,0X62,0X62,0X5A,0X22,

103030X4A,0X01,0X39,0XA0,0X41,0XE1,0X39,0XC1,0X42,0X02,0X4A,0X43,0XB5,0XB2,0XFF,0XFC,

103040XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDD,0XC5,0X90,0XCD,0X8B,0XFE,0XEC,

103050XFF,0X4B,0XFF,0X2A,0XFF,0X0A,0XFF,0X4C,0XF6,0XEB,0XFF,0X0C,0XFF,0X2B,0XFF,0X2A,

103060XFF,0X2A,0XFF,0X2A,0XFF,0X2B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0A,0XFF,0X0A,

103070XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0A,

103080XFF,0X0B,0XFF,0X0A,0XFE,0XEA,0XFE,0XEA,0XFF,0X0B,0XF6,0XEB,0XCD,0XE9,0XBD,0X8B,

103090XDE,0X93,0XFF,0XFC,0XFF,0XBD,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFD,0XFF,0XFC,0XFF,0X77,

103180XF6,0XF0,0XF6,0XED,0XFF,0X0C,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,

103190XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0C,0XFF,0X0C,0XFF,0X2B,0XFF,0X2B,

103200XFF,0X0B,0XFF,0X0B,0XFF,0X0C,0XFF,0X2C,0XD5,0XC8,0XA4,0X21,0X93,0XA0,0X8B,0X80,

103210X8B,0X41,0X7B,0X01,0X7A,0XE2,0X72,0XA2,0X62,0X62,0X5A,0X21,0X5A,0X22,0X41,0XC1,

103220X41,0XE2,0X39,0XC1,0X31,0X81,0X5A,0XA6,0XE7,0X19,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

103230XFF,0XDE,0XFF,0XFE,0XFF,0XDD,0XDE,0X54,0XBC,0XE9,0XFF,0X0D,0XFF,0X0A,0XFF,0X2A,

103240XF6,0XE9,0XFF,0X2C,0XFE,0XEC,0XFF,0X0C,0XFF,0X0B,0XFF,0X2A,0XFF,0X2A,0XFF,0X0A,

103250XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,

103260XFF,0X0A,0XFF,0X0A,0XFF,0X0B,0XFE,0XEB,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

103270XFE,0XE9,0XFF,0X0A,0XFE,0XEA,0XF6,0XCA,0XDE,0X29,0XBD,0X49,0XBD,0X4D,0XFF,0X9A,

103280XFF,0X9C,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103360XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XDA,0XFF,0X54,0XF6,0XCE,0XF6,0XCB,

103370XFE,0XCC,0XFE,0XEB,0XFE,0XEB,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0A,

103380XFF,0X0B,0XFF,0X0B,0XFE,0XEB,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,

103390XFF,0X0C,0XFF,0X0C,0XD5,0XC7,0XA4,0X01,0X93,0XC0,0X8B,0X80,0X83,0X41,0X7B,0X01,

103400X7A,0XE3,0X72,0XA3,0X6A,0X82,0X62,0X62,0X5A,0X43,0X52,0X22,0X4A,0X02,0X41,0XC2,

103410X31,0X61,0X7B,0XCB,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

103420XFF,0XDE,0XF7,0X18,0XA4,0X47,0XFF,0X0E,0XFE,0XEA,0XFF,0X2A,0XFE,0XEA,0XFF,0X0B,

103430XFE,0XEC,0XFE,0XCC,0XFE,0XEB,0XFF,0X0A,0XFF,0X09,0XFF,0X0A,0XFE,0XEB,0XFE,0XEB,

103440XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

103450XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XCA,0XFE,0XCA,0XFE,0XEA,0XFE,0XC9,0XFF,0X0A,

103460XFE,0XC9,0XF6,0XCA,0XE6,0X8A,0XBD,0X48,0XA4,0X89,0XDE,0X73,0XFF,0XDC,0XFF,0XDD,

103470XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103550XFF,0XFE,0XFF,0XFD,0XFF,0XB8,0XF6,0XF1,0XF6,0XCC,0XFE,0XCB,0XFE,0XAB,0XFE,0XEC,

103560XFE,0XEB,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

103570XFE,0XEB,0XFF,0X0B,0XFF,0X0B,0XFE,0XEA,0XFE,0XEA,0XFF,0X0B,0XFF,0X0B,0XFF,0X0C,

103580XD5,0XA7,0X9C,0X01,0X93,0XC0,0X8B,0X81,0X83,0X41,0X7B,0X22,0X7A,0XE3,0X72,0XC3,

103590X72,0XA3,0X6A,0X83,0X5A,0X22,0X62,0X84,0X41,0XC2,0X49,0XE3,0X39,0XA3,0XAD,0X32,

103600XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XBB,

103610XAC,0X88,0XEE,0X6C,0XFF,0X0B,0XFF,0X09,0XFE,0XEA,0XFE,0XEB,0XFE,0XEC,0XFE,0XCB,

103620XFE,0XCA,0XFE,0XE9,0XFE,0XE9,0XFE,0XE9,0XFE,0XCA,0XFE,0XCB,0XFE,0XCA,0XFE,0XCA,

103630XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,

103640XFE,0XCA,0XFE,0XAA,0XFE,0XCA,0XFE,0XC9,0XFE,0XC9,0XFE,0XE9,0XFE,0XC9,0XF6,0XC9,

103650XEE,0XAA,0XCD,0XA8,0XA4,0X87,0XAC,0XCB,0XFF,0X99,0XFF,0XDC,0XFF,0XFE,0XF7,0XBE,

103660XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,

103740XF7,0X56,0XEE,0XAF,0XF6,0XCB,0XFE,0XCA,0XFE,0XCB,0XFE,0XCB,0XFE,0XEA,0XFE,0XEA,

103750XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFF,0X0B,

103760XFF,0X0A,0XFE,0XEA,0XFE,0XEA,0XFE,0XEB,0XFE,0XEB,0XFE,0XEC,0XD5,0XA7,0X9B,0XE1,

103770X93,0XC1,0X8B,0X81,0X8B,0X62,0X83,0X22,0X7B,0X03,0X72,0XE4,0X72,0XC3,0X6A,0XA3,

103780X62,0X62,0X5A,0X63,0X52,0X23,0X4A,0X04,0X52,0X25,0XC6,0X15,0XFF,0XDE,0XFF,0XFE,

103790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDC,0XB4,0XCA,0XDE,0X0B,

103800XFE,0XEB,0XF6,0XE9,0XFE,0XE9,0XFE,0XAA,0XFE,0XCC,0XFE,0XAB,0XFE,0XCA,0XFE,0XC9,

103810XFE,0XC9,0XFE,0XC9,0XFE,0XCA,0XFE,0XAA,0XFE,0XCA,0XFE,0XAA,0XFE,0XC9,0XFE,0XC9,

103820XFE,0XCA,0XFE,0XCA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XA9,

103830XFE,0XAA,0XFE,0XA9,0XFE,0XA9,0XFE,0XC9,0XFE,0XA8,0XF6,0XC9,0XF6,0XAA,0XCD,0XA8,

103840XB4,0XE7,0X93,0XE6,0XD6,0X33,0XFF,0XBB,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

103850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBA,0XEE,0XF3,0XE6,0X8D,

103930XFE,0XCA,0XFE,0XA9,0XFE,0XCA,0XFE,0XAA,0XFE,0XCA,0XFE,0XE9,0XFE,0XE9,0XFE,0XEA,

103940XFE,0XCA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

103950XFE,0XEA,0XFE,0XEB,0XFE,0XEB,0XFE,0XCB,0XD5,0X87,0X9B,0XE1,0X93,0XC1,0X93,0X81,

103960X8B,0X62,0X83,0X43,0X83,0X24,0X7B,0X04,0X72,0XE4,0X6A,0XE4,0X62,0XA3,0X5A,0X63,

103970X5A,0X64,0X4A,0X03,0X5A,0XA7,0XDE,0XD8,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

103980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XBD,0X4D,0XCD,0X8A,0XF6,0XCB,0XF6,0XE9,

103990XFE,0XC9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAB,0XFE,0XAA,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,

104000XFE,0XC9,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,

104010XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,

104020XFE,0X89,0XFE,0XA9,0XFE,0XA8,0XF6,0XA8,0XF6,0XA9,0XD5,0XC7,0XBD,0X27,0X8B,0XC4,

104030XA4,0XAB,0XFF,0X99,0XFF,0XBC,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104110XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XF7,0X98,0XE6,0XB0,0XEE,0X8C,0XFE,0XAA,0XF6,0X68,

104120XFE,0XAA,0XFE,0XAA,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XCA,0XFE,0XCA,

104130XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XEA,0XFE,0XCA,0XFE,0XC9,0XFE,0XCA,0XFE,0XCA,

104140XFE,0XCB,0XFE,0XCB,0XD5,0X87,0X9B,0XE1,0X93,0XA1,0X93,0XA2,0X8B,0X82,0X83,0X43,

104150X83,0X24,0X7B,0X04,0X72,0XE3,0X73,0X04,0X6A,0XE4,0X62,0X83,0X5A,0X84,0X52,0X23,

104160X6B,0X08,0XEF,0X19,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104170XFF,0XFF,0XFF,0XFC,0XD5,0XD0,0XC5,0X29,0XF6,0XAC,0XFE,0XEA,0XF6,0XA8,0XFE,0XC9,

104180XFE,0X8A,0XFE,0XAA,0XFE,0XAA,0XFE,0XA9,0XFE,0XA9,0XFE,0XC9,0XFE,0XA9,0XFE,0XA9,

104190XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0X89,0XFE,0X89,0XFE,0X89,

104200XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XF6,0X89,0XF6,0X88,

104210XF6,0X88,0XF6,0XA8,0XF6,0X89,0XE6,0X29,0XBC,0XE6,0X9C,0X25,0X8B,0XC7,0XD6,0X33,

104220XFF,0XDC,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

104300XFF,0XDB,0XF7,0X56,0XE6,0X6E,0XEE,0X8B,0XF6,0X89,0XFE,0X68,0XFE,0X89,0XFE,0XA9,

104310XFE,0XA9,0XF6,0XC9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XCA,

104320XFE,0XCA,0XFE,0XCA,0XFE,0XC9,0XFE,0XC9,0XFE,0XA9,0XFE,0XCA,0XFE,0XCA,0XFE,0XCB,

104330XD5,0X88,0X9B,0XE2,0X93,0XA2,0X93,0X82,0X8B,0X83,0X83,0X43,0X83,0X44,0X7B,0X24,

104340X73,0X03,0X73,0X04,0X73,0X04,0X62,0XA3,0X62,0XA4,0X52,0X43,0X83,0XEB,0XEF,0X59,

104350XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,

104360XDE,0X73,0XB4,0XE9,0XEE,0XAC,0XF6,0XCA,0XF6,0XA8,0XFE,0XC8,0XFE,0X69,0XFE,0X8A,

104370XFE,0X89,0XFE,0X89,0XFE,0XA8,0XFE,0XA8,0XFE,0X88,0XFE,0X89,0XFE,0X89,0XFE,0X89,

104380XFE,0XA9,0XFE,0XA9,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X88,0XFE,0X88,

104390XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XF6,0X88,0XF6,0X88,0XF6,0X88,

104400XFE,0XA9,0XE6,0X08,0XC5,0X26,0XA4,0X45,0X8B,0XA5,0XA4,0XCC,0XF7,0X79,0XFF,0XFD,

104410XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XD9,0XE6,0XF2,

104490XDE,0X4C,0XEE,0X8B,0XF6,0X48,0XFE,0X88,0XFE,0X89,0XF6,0X89,0XF6,0XA9,0XF6,0XA9,

104500XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XA9,

104510XFE,0XA9,0XFE,0XA8,0XFE,0X89,0XFE,0XA9,0XFE,0XAA,0XFE,0XAB,0XD5,0XA8,0X9B,0XC2,

104520X8B,0X82,0X8B,0X82,0X8B,0X83,0X83,0X63,0X83,0X44,0X7B,0X24,0X7B,0X24,0X73,0X03,

104530X7B,0X24,0X62,0XA3,0X6A,0XC4,0X52,0X43,0X9C,0XAE,0XF7,0X9A,0XFF,0XFD,0XFF,0XFF,

104540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XEE,0XF5,0XAC,0XC9,

104550XEE,0X8C,0XEE,0X89,0XF6,0XA8,0XFE,0X87,0XFE,0X89,0XFE,0X69,0XFE,0X69,0XFE,0X69,

104560XF6,0X88,0XF6,0X88,0XF6,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,

104570XFE,0X89,0XFE,0X69,0XFE,0X69,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X89,

104580XF6,0X69,0XFE,0X89,0XF6,0X69,0XF6,0X68,0XF6,0X88,0XF6,0X68,0XF6,0X89,0XEE,0X28,

104590XC5,0X26,0XAC,0XA6,0X8B,0XC5,0X8B,0XE8,0XDE,0XB6,0XFF,0XBC,0XFF,0XFE,0XFF,0XFF,

104600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XB7,0XDE,0X8F,0XDE,0X2B,0XEE,0X6A,

104680XF6,0X28,0XFE,0X89,0XFE,0X68,0XF6,0X88,0XF6,0X88,0XF6,0X89,0XFE,0X69,0XFE,0X69,

104690XFE,0X69,0XFE,0X88,0XFE,0X89,0XFE,0XA9,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X88,

104700XFE,0X88,0XFE,0X89,0XFE,0XAA,0XFE,0X8B,0XD5,0X88,0X93,0XA2,0X8B,0X61,0X8B,0X82,

104710X8B,0X83,0X83,0X64,0X83,0X64,0X7B,0X44,0X83,0X44,0X7B,0X04,0X7B,0X04,0X6A,0XA3,

104720X6A,0XE5,0X5A,0X63,0XAD,0X30,0XFF,0XBB,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0X57,0XAC,0XCA,0XE6,0X6C,0XEE,0X69,

104740XF6,0XA8,0XF6,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X69,0XFE,0X69,0XF6,0X68,0XF6,0X88,

104750XF6,0X87,0XF6,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XF6,0X68,0XF6,0X68,

104760XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XFE,0X68,0XF6,0X48,0XF6,0X69,

104770XF6,0X69,0XF6,0X68,0XF6,0X87,0XF6,0X67,0XFE,0X89,0XEE,0X49,0XCD,0X47,0XAC,0X85,

104780X83,0X84,0X83,0XA7,0XB5,0X50,0XFF,0X9B,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104860XFF,0XFF,0XFF,0XFC,0XF7,0X75,0XD6,0X2C,0XE6,0X4B,0XEE,0X6A,0XEE,0X28,0XFE,0X69,

104870XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X69,0XF6,0X69,0XFE,0X69,0XFE,0X68,0XFE,0X68,

104880XF6,0X88,0XF6,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X89,

104890XFE,0X8A,0XFE,0X8B,0XCD,0X68,0X93,0X81,0X83,0X41,0X83,0X62,0X83,0X84,0X83,0X64,

104900X83,0X64,0X83,0X64,0X7B,0X44,0X7B,0X44,0X72,0XE3,0X73,0X04,0X72,0XE5,0X62,0X84,

104910XB5,0X71,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

104920XFF,0XFF,0XFF,0XFD,0XFF,0X98,0XB4,0XEA,0XDE,0X2B,0XEE,0X69,0XF6,0XA8,0XF6,0X67,

104930XFE,0X68,0XFE,0X68,0XFE,0X69,0XF6,0X69,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

104940XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X48,0XF6,0X68,0XF6,0X48,0XF6,0X68,

104950XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X48,

104960XF6,0X67,0XEE,0X47,0XF6,0X48,0XF6,0X49,0XD5,0X87,0XAC,0X65,0X93,0XC5,0X7B,0X45,

104970X94,0X4B,0XEF,0X18,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDA,

105050XEF,0X12,0XD6,0X0B,0XE6,0X6A,0XEE,0X48,0XEE,0X28,0XF6,0X48,0XF6,0X68,0XF6,0X48,

105060XF6,0X68,0XF6,0X48,0XF6,0X49,0XF6,0X49,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X88,

105070XF6,0X69,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XFE,0X88,0XF6,0X88,0XF6,0X69,0XF6,0X8B,

105080XCD,0X67,0X93,0X81,0X7B,0X01,0X83,0X43,0X83,0X64,0X83,0X65,0X83,0X65,0X83,0X65,

105090X83,0X44,0X7B,0X24,0X73,0X03,0X7B,0X24,0X6A,0XC4,0X6A,0XC5,0XBD,0XB2,0XFF,0XBC,

105100XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,

105110XFF,0X9A,0XB4,0XEB,0XD6,0X0B,0XEE,0X6A,0XF6,0X68,0XF6,0X47,0XFE,0X68,0XF6,0X48,

105120XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

105130XF6,0X47,0XF6,0X68,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X47,0XF6,0X67,

105140XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XEE,0X27,

105150XF6,0X68,0XEE,0X49,0XD5,0X87,0XAC,0X65,0X93,0XA4,0X83,0X65,0X83,0X88,0XC5,0XD3,

105160XFF,0X9B,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105230XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XDA,0XE6,0XB0,0XD5,0XEA,

105240XE6,0X49,0XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

105250XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

105260XF6,0X68,0XF6,0X68,0XFE,0X68,0XF6,0X68,0XF6,0X69,0XF6,0X8A,0XD5,0X88,0X93,0X61,

105270X83,0X22,0X83,0X43,0X83,0X45,0X83,0X65,0X83,0X65,0X83,0X64,0X83,0X64,0X7B,0X43,

105280X7B,0X23,0X7B,0X24,0X6A,0XC4,0X6A,0XE6,0XC5,0XD3,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,

105290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0X9A,0XB5,0X2D,

105300XCD,0XCA,0XEE,0X8A,0XF6,0X48,0XF6,0X47,0XFE,0X68,0XF6,0X47,0XF6,0X47,0XF6,0X48,

105310XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

105320XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,

105330XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X27,0XF6,0X48,0XEE,0X49,

105340XDD,0XA8,0XAC,0X65,0X8B,0X84,0X83,0X45,0X73,0X06,0XA4,0XAE,0XF7,0X7A,0XFF,0XDD,

105350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,

105420XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XB9,0XD6,0X2E,0XD5,0XC9,0XE6,0X29,0XE6,0X08,

105430XEE,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X27,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

105440XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

105450XF6,0X68,0XF6,0X48,0XF6,0X49,0XF6,0X8A,0XDD,0XA9,0X8B,0X61,0X83,0X42,0X83,0X43,

105460X83,0X45,0X83,0X65,0X83,0X65,0X83,0X64,0X83,0X64,0X7B,0X43,0X7B,0X23,0X73,0X24,

105470X6A,0XC4,0X6B,0X06,0XC5,0XD3,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBA,0XBD,0X6E,0XC5,0X69,0XEE,0X8A,

105490XEE,0X48,0XF6,0X47,0XFE,0X68,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

105500XF6,0X48,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

105510XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

105520XEE,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X28,0XE6,0X09,0XA4,0X24,

105530X93,0XC4,0X7B,0X24,0X73,0X06,0X83,0XAA,0XEF,0X18,0XFF,0XBC,0XFF,0XFF,0XFF,0XFF,

105540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,

105610XFF,0XFD,0XFF,0X99,0XD5,0XCD,0XD5,0XE9,0XE6,0X29,0XE6,0X07,0XEE,0X28,0XF6,0X28,

105620XEE,0X28,0XEE,0X28,0XEE,0X47,0XEE,0X48,0XEE,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

105630XF6,0X68,0XF6,0X68,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X48,0XF6,0X48,

105640XF6,0X49,0XF6,0X8A,0XDD,0XC9,0X8B,0X40,0X83,0X42,0X83,0X43,0X83,0X44,0X83,0X65,

105650X83,0X65,0X83,0X64,0X83,0X44,0X7B,0X43,0X7B,0X23,0X73,0X24,0X6A,0XE4,0X6B,0X06,

105660XC5,0XF3,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105670XFF,0XFF,0XFF,0XFE,0XFF,0XBB,0XC5,0XAF,0XBD,0X49,0XEE,0X6A,0XEE,0X48,0XF6,0X47,

105680XF6,0X48,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XEE,0X47,

105690XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

105700XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X27,

105710XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X29,0XE6,0X09,0XAC,0X44,0X8B,0X83,0X7B,0X44,

105720X73,0X26,0X73,0X48,0XCE,0X14,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105790XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XF7,0X57,

105800XCD,0XAC,0XDE,0X09,0XE6,0X29,0XE6,0X07,0XEE,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X28,

105810XEE,0X47,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X48,

105820XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X6A,

105830XDD,0XC9,0X8B,0X40,0X83,0X42,0X83,0X43,0X83,0X45,0X83,0X65,0X83,0X65,0X7B,0X44,

105840X83,0X44,0X7B,0X43,0X7B,0X24,0X7B,0X24,0X6A,0XE4,0X6B,0X26,0XCD,0XF4,0XFF,0XDC,

105850XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

105860XFF,0XBB,0XCD,0XAF,0XBD,0X29,0XE6,0X4A,0XEE,0X28,0XF6,0X47,0XF6,0X27,0XF6,0X27,

105870XF6,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

105880XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

105890XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

105900XEE,0X28,0XEE,0X28,0XE6,0X09,0XAC,0X44,0X83,0X42,0X7B,0X03,0X73,0X06,0X6B,0X07,

105910XA4,0XCF,0XFF,0XDC,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105980XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XEE,0XF6,0XCD,0X8B,0XDE,0X09,

105990XE6,0X08,0XE5,0XE7,0XEE,0X07,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

106000XEE,0X28,0XEE,0X28,0XEE,0X28,0XF6,0X48,0XF6,0X48,0XEE,0X48,0XF6,0X48,0XF6,0X48,

106010XF6,0X48,0XF6,0X48,0XF6,0X48,0XEE,0X48,0XEE,0X48,0XF6,0X6A,0XDD,0XC9,0X8B,0X40,

106020X83,0X42,0X83,0X64,0X83,0X65,0X83,0X65,0X83,0X65,0X83,0X45,0X83,0X44,0X7B,0X43,

106030X7B,0X44,0X7B,0X24,0X73,0X05,0X73,0X26,0XCE,0X14,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,

106040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBB,0XCD,0XF0,

106050XBD,0X29,0XE6,0X2A,0XEE,0X48,0XF6,0X27,0XEE,0X07,0XF6,0X27,0XF6,0X27,0XEE,0X27,

106060XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X27,

106070XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

106080XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XE6,0X28,

106090XEE,0X2A,0XAC,0X65,0X83,0X62,0X72,0XC2,0X73,0X05,0X6A,0XE6,0X83,0XCB,0XFF,0X9B,

106100XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

106170XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XDE,0X94,0XC5,0X6A,0XDD,0XE9,0XE6,0X07,0XE6,0X07,

106180XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X27,0XE6,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

106190XEE,0X27,0XEE,0X28,0XEE,0X48,0XEE,0X28,0XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X28,

106200XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X4A,0XDD,0XE9,0X93,0X81,0X83,0X22,0X8B,0X64,

106210X83,0X65,0X83,0X65,0X83,0X65,0X83,0X65,0X83,0X44,0X7B,0X43,0X7B,0X44,0X7B,0X24,

106220X73,0X05,0X73,0X27,0XCE,0X14,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBB,0XD6,0X32,0XB5,0X08,0XE6,0X2A,

106240XEE,0X28,0XEE,0X07,0XEE,0X07,0XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

106250XF6,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

106260XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

106270XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X29,0XE6,0X2A,0XB4,0XC6,

106280X83,0X22,0X72,0XE2,0X72,0XE4,0X6A,0XE5,0X6B,0X27,0XE6,0XF8,0XFF,0XFE,0XFF,0XFF,

106290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,

106360XFF,0XDC,0XD6,0X52,0XC5,0X4A,0XDD,0XE8,0XE5,0XE7,0XE6,0X07,0XE5,0XE7,0XE5,0XE7,

106370XEE,0X27,0XE6,0X07,0XE6,0X07,0XE6,0X27,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X28,

106380XEE,0X48,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

106390XEE,0X28,0XEE,0X4A,0XE6,0X09,0X93,0XA1,0X83,0X21,0X8B,0X84,0X83,0X65,0X83,0X65,

106400X83,0X65,0X83,0X65,0X83,0X64,0X7B,0X23,0X7B,0X24,0X73,0X24,0X73,0X05,0X6B,0X06,

106410XCE,0X14,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106420XFF,0XFF,0XFF,0XFE,0XFF,0XBB,0XDE,0X53,0XAC,0XC8,0XE6,0X2A,0XEE,0X28,0XEE,0X07,

106430XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

106440XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

106450XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

106460XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X09,0XEE,0X2A,0XB4,0XA5,0X83,0X42,0X6A,0XC1,

106470X72,0XE4,0X6A,0XE5,0X5A,0XA5,0XCE,0X55,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106540XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XCD,0XF1,

106550XC5,0X6A,0XDD,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XEE,0X07,0XEE,0X07,0XE6,0X07,

106560XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X28,

106570XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X28,0XEE,0X28,0XEE,0X49,

106580XE6,0X09,0X93,0XA2,0X83,0X41,0X8B,0X84,0X83,0X64,0X83,0X65,0X83,0X65,0X83,0X65,

106590X83,0X44,0X7B,0X44,0X7B,0X23,0X73,0X24,0X73,0X05,0X6B,0X06,0XCD,0XF4,0XFF,0XDD,

106600XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

106610XFF,0XBC,0XDE,0X73,0XAC,0XA8,0XE6,0X2A,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,

106620XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

106630XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

106640XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

106650XEE,0X08,0XE6,0X29,0XEE,0X2A,0XB4,0XC6,0X83,0X22,0X6A,0X81,0X72,0XE4,0X6A,0XE5,

106660X5A,0XA5,0XA4,0XEF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106730XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDE,0XFF,0XDB,0XBD,0X8F,0XCD,0X8A,0XDD,0XE8,

106740XE6,0X07,0XE6,0X07,0XE5,0XE7,0XEE,0X08,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

106750XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X27,

106760XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X49,0XEE,0X2A,0X9B,0XE2,

106770X8B,0X41,0X8B,0X84,0X8B,0X65,0X8B,0X85,0X83,0X85,0X83,0X65,0X83,0X64,0X7B,0X44,

106780X7B,0X24,0X73,0X24,0X73,0X05,0X6B,0X06,0XC5,0XF3,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,

106790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBC,0XDE,0X73,

106800XAC,0XA8,0XE6,0X2A,0XE6,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,

106810XEE,0X07,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

106820XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,

106830XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XE6,0X08,

106840XE6,0X2A,0XBC,0XE7,0X7B,0X21,0X62,0X81,0X6A,0XC3,0X62,0XA4,0X5A,0X84,0X8C,0X2C,

106850XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

106920XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XB5,0X2D,0XCD,0XCB,0XDE,0X08,0XE6,0X07,0XE5,0XE7,

106930XE5,0XE7,0XEE,0X08,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,

106940XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X28,0XEE,0X28,

106950XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X29,0XEE,0X4A,0XA4,0X23,0X83,0X41,0X8B,0XA4,

106960X8B,0X85,0X8B,0X85,0X83,0X85,0X83,0X65,0X83,0X64,0X83,0X64,0X7B,0X44,0X73,0X24,

106970X73,0X05,0X6B,0X06,0XC5,0XD3,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XDE,0X73,0XAC,0XA8,0XDE,0X2A,

106990XE6,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X08,

107000XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

107010XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107020XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XE6,0X08,0XE6,0X2A,0XBD,0X07,

107030X7A,0XE1,0X62,0X61,0X6A,0XA3,0X5A,0X83,0X52,0X64,0X6B,0X48,0XFF,0XBD,0XFF,0XDF,

107040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

107110XFF,0XDB,0XAC,0XEC,0XCD,0XAA,0XDD,0XE8,0XDD,0XE7,0XE5,0XE6,0XE5,0XE7,0XEE,0X08,

107120XE5,0XE8,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107130XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X07,

107140XEE,0X28,0XEE,0X49,0XEE,0X49,0XAC,0X63,0X83,0X20,0X8B,0XA3,0X8B,0XA5,0X8B,0X85,

107150X83,0X85,0X83,0X65,0X83,0X64,0X83,0X64,0X7B,0X44,0X73,0X24,0X73,0X05,0X6B,0X06,

107160XC5,0XD3,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107170XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XDE,0X74,0XAC,0XA8,0XDE,0X0A,0XE6,0X08,0XEE,0X28,

107180XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107190XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107200XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107210XEE,0X07,0XEE,0X07,0XEE,0X08,0XE6,0X08,0XE6,0X2A,0XC5,0X28,0X72,0XC0,0X62,0X40,

107220X62,0X82,0X5A,0X83,0X52,0X63,0X5A,0XC6,0XEF,0X3B,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107290XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XDB,0XAC,0XCB,

107300XCD,0XAA,0XDD,0XE8,0XDD,0XE7,0XE5,0XE7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE8,0XE6,0X08,

107310XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107320XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X48,

107330XEE,0X49,0XB4,0XA4,0X83,0X20,0X8B,0XA3,0X93,0XA5,0X8B,0XA5,0X8B,0X85,0X83,0X85,

107340X83,0X65,0X83,0X64,0X7B,0X44,0X7B,0X24,0X73,0X25,0X6B,0X06,0XBD,0XB3,0XFF,0XBC,

107350XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

107360XFF,0XDC,0XDE,0X94,0XAC,0XC8,0XDE,0X0A,0XE6,0X08,0XEE,0X28,0XEE,0X07,0XEE,0X07,

107370XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107380XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107390XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107400XE6,0X08,0XE6,0X09,0XE6,0X0B,0XC5,0X29,0X6A,0X80,0X5A,0X20,0X62,0X62,0X5A,0X83,

107410X52,0X43,0X52,0X85,0XD6,0X78,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

107480XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XDA,0XA4,0XCB,0XCD,0XAA,0XDD,0XE8,

107490XE5,0XE7,0XE6,0X07,0XE5,0XC7,0XED,0XE7,0XE5,0XE8,0XE6,0X08,0XE5,0XE7,0XE6,0X07,

107500XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X07,0XEE,0X27,0XEE,0X27,

107510XEE,0X28,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X49,0XC5,0X26,

107520X83,0X40,0X93,0XC3,0X93,0XC5,0X8B,0XA5,0X8B,0XA5,0X8B,0X85,0X83,0X65,0X83,0X64,

107530X83,0X64,0X7B,0X44,0X73,0X25,0X6B,0X06,0XBD,0X92,0XFF,0XBC,0XFF,0XFE,0XFF,0XFF,

107540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XE6,0XB4,

107550XAC,0XC8,0XDD,0XE9,0XE6,0X08,0XEE,0X27,0XE5,0XE7,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107560XEE,0X07,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107570XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

107580XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X08,0XE6,0X29,

107590XE6,0X0B,0XC5,0X09,0X6A,0X60,0X5A,0X20,0X5A,0X62,0X5A,0X63,0X52,0X43,0X4A,0X45,

107600XBD,0X94,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

107670XFF,0XFE,0XFF,0XFD,0XFF,0XDA,0XA4,0XCB,0XCD,0XCA,0XDE,0X08,0XDD,0XE7,0XE5,0XE7,

107680XE5,0XC7,0XED,0XE8,0XE5,0XC8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XEE,0X07,

107690XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X08,

107700XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X69,0XCD,0X67,0X8B,0X61,0X93,0XC4,

107710X93,0XC5,0X8B,0XA5,0X8B,0XA5,0X8B,0X85,0X83,0X65,0X83,0X64,0X83,0X65,0X7B,0X44,

107720X73,0X46,0X6B,0X06,0XB5,0X72,0XFF,0X9C,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XE6,0XB4,0XAC,0XC8,0XDD,0XE9,

107740XE6,0X08,0XEE,0X27,0XE5,0XE7,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X08,

107750XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107760XEE,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,

107770XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X08,0XE6,0X29,0XE6,0X0B,0XBC,0XE8,

107780X6A,0X60,0X5A,0X00,0X5A,0X41,0X5A,0X42,0X52,0X63,0X42,0X04,0XA4,0XF2,0XFF,0XDF,

107790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107850XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDD,

107860XFF,0XBA,0XA4,0XCB,0XD5,0XEA,0XDE,0X08,0XDD,0XE6,0XE5,0XE7,0XE5,0XE8,0XED,0XE8,

107870XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XED,0XE7,0XEE,0X07,0XEE,0X07,

107880XEE,0X08,0XE6,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X08,0XEE,0X08,

107890XEE,0X07,0XE6,0X28,0XEE,0X69,0XD5,0XA8,0X8B,0X81,0X93,0XE4,0X93,0XC5,0X8B,0XA5,

107900X8B,0XA5,0X8B,0XA5,0X83,0X84,0X83,0X64,0X83,0X65,0X7B,0X44,0X7B,0X45,0X6B,0X06,

107910XB5,0X71,0XF7,0X9B,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107920XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XE6,0XB4,0XAC,0XA7,0XD5,0XE9,0XE6,0X08,0XEE,0X28,

107930XE6,0X06,0XEE,0X07,0XEE,0X06,0XE6,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X07,

107940XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,

107950XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107960XEE,0X07,0XEE,0X07,0XE6,0X08,0XE6,0X29,0XE6,0X2B,0XBC,0XE8,0X62,0X60,0X52,0X00,

107970X5A,0X22,0X52,0X22,0X52,0X64,0X39,0XC3,0X9C,0XB1,0XFF,0XDE,0XFF,0XFF,0XFF,0XFE,

107980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XDA,0X9C,0X89,

108050XD6,0X0B,0XD5,0XA6,0XDD,0XC6,0XE5,0XE6,0XE5,0XE8,0XE5,0XA8,0XE5,0XE8,0XE6,0X08,

108060XE5,0XE8,0XE5,0XE8,0XE5,0XE8,0XED,0XE7,0XEE,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X08,

108070XEE,0X07,0XE6,0X07,0XEE,0X08,0XEE,0X08,0XE5,0XE8,0XEE,0X08,0XEE,0X28,0XE6,0X07,

108080XEE,0X28,0XE6,0X49,0X93,0XA1,0X9B,0XE4,0X93,0XC5,0X93,0XC6,0X93,0XC5,0X8B,0XA5,

108090X8B,0XA4,0X83,0X84,0X83,0X65,0X7B,0X45,0X7B,0X45,0X73,0X45,0XA4,0XCE,0XF7,0X7A,

108100XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,

108110XFF,0XDC,0XE6,0X94,0XAC,0XA8,0XDE,0X0A,0XE6,0X08,0XEE,0X28,0XEE,0X06,0XEE,0X26,

108120XEE,0X26,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,

108130XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

108140XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,

108150XE6,0X07,0XEE,0X29,0XE6,0X2B,0XB4,0XE8,0X5A,0X20,0X52,0X00,0X52,0X22,0X52,0X03,

108160X5A,0X64,0X41,0XE3,0X8C,0X2E,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

108170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDA,0XA4,0X89,0XD5,0XEA,0XD5,0XC7,

108240XE5,0XE6,0XE5,0XE6,0XE5,0XC8,0XE5,0XC8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE8,0XE5,0XE8,

108250XE5,0XE8,0XED,0XE7,0XE6,0X07,0XE6,0X07,0XE5,0XE8,0XE6,0X08,0XEE,0X07,0XEE,0X07,

108260XEE,0X08,0XEE,0X08,0XED,0XE8,0XEE,0X08,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X49,

108270XA4,0X02,0X9B,0XE3,0X93,0XA4,0X9B,0XC6,0X93,0XC5,0X8B,0XA5,0X8B,0XA5,0X8B,0XA5,

108280X8B,0X85,0X83,0X65,0X7B,0X44,0X73,0X25,0X9C,0X8C,0XF7,0X5A,0XFF,0XFE,0XFF,0XFF,

108290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XBC,0XE6,0X74,

108300XAC,0XC8,0XDE,0X0A,0XE6,0X09,0XEE,0X08,0XEE,0X26,0XEE,0X26,0XEE,0X26,0XEE,0X07,

108310XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

108320XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

108330XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X29,

108340XE6,0X2A,0XB4,0XE7,0X52,0X20,0X4A,0X00,0X52,0X02,0X4A,0X03,0X52,0X64,0X41,0XC3,

108350X83,0XED,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108420XFF,0XDF,0XFF,0XDD,0XFF,0XBA,0XA4,0X8A,0XCD,0XAA,0XD5,0XC7,0XE5,0XE6,0XE5,0XC6,

108430XE5,0XC8,0XE5,0XE9,0XE6,0X08,0XDD,0XE7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,

108440XE6,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,

108450XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X27,0XEE,0X48,0XEE,0X69,0XBC,0XA4,0X9B,0XC2,

108460XA4,0X05,0X9B,0XE6,0X9B,0XE5,0X93,0XC5,0X8B,0XA5,0X8B,0XA5,0X8B,0X85,0X8B,0X86,

108470X7B,0X44,0X73,0X25,0X94,0X2B,0XF7,0X39,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBC,0XE6,0X74,0XAC,0XC8,0XDE,0X0A,

108490XE6,0X09,0XEE,0X07,0XEE,0X06,0XEE,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X07,0XEE,0X07,

108500XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

108510XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

108520XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XEE,0X07,0XE6,0X29,0XE6,0X2B,0XAC,0XA6,

108530X52,0X20,0X4A,0X01,0X4A,0X02,0X4A,0X03,0X52,0X44,0X41,0XC3,0X73,0X8B,0XFF,0XFD,

108540XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,

108610XFF,0XDB,0XAC,0XCB,0XC5,0X69,0XD5,0XC8,0XDD,0XE6,0XDD,0XC6,0XE5,0XC8,0XE5,0XE9,

108620XE6,0X08,0XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

108630XE6,0X07,0XE6,0X07,0XEE,0X08,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,

108640XEE,0X08,0XEE,0X28,0XEE,0X27,0XEE,0X69,0XCD,0X46,0X9B,0XC2,0XA4,0X04,0X9B,0XE5,

108650X9B,0XE5,0X93,0XC5,0X93,0XA5,0X93,0XA5,0X8B,0X85,0X8B,0XA6,0X83,0X65,0X7B,0X45,

108660X8B,0XEA,0XEF,0X18,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108670XFF,0XFF,0XFF,0XDF,0XFF,0XBC,0XE6,0X94,0XAC,0XC7,0XDE,0X2A,0XE5,0XE8,0XEE,0X08,

108680XEE,0X06,0XEE,0X26,0XEE,0X26,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

108690XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

108700XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

108710XEE,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X2B,0XA4,0X45,0X52,0X00,0X4A,0X01,

108720X49,0XE1,0X4A,0X03,0X4A,0X23,0X41,0XC3,0X63,0X2A,0XFF,0XDD,0XFF,0XFE,0XFF,0XFE,

108730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XB5,0X2D,

108800XC5,0X49,0XD5,0XC8,0XDD,0XC7,0XDD,0XC6,0XE5,0XC8,0XE5,0XC9,0XE5,0XE8,0XE5,0XE8,

108810XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

108820XE6,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,

108830XEE,0X28,0XEE,0X69,0XDD,0XE8,0XA4,0X23,0X9B,0XE3,0XA4,0X25,0X9C,0X05,0X9B,0XE5,

108840X93,0XC5,0X93,0XA5,0X8B,0X85,0X8B,0XA5,0X83,0X85,0X7B,0X45,0X83,0XA8,0XE6,0XF8,

108850XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

108860XFF,0XBC,0XE6,0X94,0XAC,0XA7,0XE6,0X2A,0XE5,0XE8,0XEE,0X28,0XED,0XE6,0XEE,0X27,

108870XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,

108880XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

108890XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,

108900XE6,0X07,0XE6,0X08,0XE6,0X2B,0X94,0X04,0X52,0X00,0X49,0XE0,0X41,0XC1,0X49,0XE2,

108910X4A,0X03,0X41,0XC3,0X62,0XE9,0XF7,0XBD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

108920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XC5,0X8F,0XBD,0X2A,0XDD,0XE9,

108990XDD,0XC7,0XDD,0XC7,0XE5,0XC8,0XDD,0XC8,0XDD,0XC8,0XDD,0XE8,0XE5,0XE8,0XE5,0XE8,

109000XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,

109010XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XE6,0X07,0XF6,0X69,

109020XEE,0X49,0XA4,0X22,0XAC,0X44,0XA4,0X04,0XA4,0X05,0XA4,0X26,0X93,0XC5,0X93,0XA5,

109030X93,0XA5,0X8B,0X85,0X83,0X64,0X7B,0X64,0X7B,0X88,0XE6,0XD7,0XFF,0XDE,0XFF,0XFF,

109040XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBC,0XE6,0X94,

109050XAC,0XA7,0XE6,0X4A,0XE5,0XE8,0XEE,0X28,0XED,0XE7,0XEE,0X27,0XEE,0X07,0XEE,0X07,

109060XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,

109070XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

109080XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X29,

109090XDE,0X2B,0X93,0XC4,0X52,0X00,0X49,0XE0,0X49,0XC1,0X49,0XE2,0X49,0XE3,0X39,0XC3,

109100X5A,0XC9,0XF7,0XBD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109170XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XCD,0XF1,0XB4,0XE9,0XD5,0XEA,0XDD,0XC8,0XE5,0XC7,

109180XE5,0XC8,0XE5,0XC8,0XDD,0XC7,0XDD,0XE8,0XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,

109190XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,

109200XEE,0X27,0XEE,0X07,0XE6,0X07,0XEE,0X28,0XE5,0XE7,0XEE,0X49,0XF6,0X8A,0XB4,0XA3,

109210XAC,0X64,0XA4,0X24,0XA4,0X04,0XA4,0X25,0X9B,0XE5,0X9B,0XC5,0X9B,0XC5,0X8B,0XA4,

109220X8B,0X83,0X83,0X84,0X7B,0X66,0XD6,0X75,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

109230XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XBC,0XE6,0X73,0XAC,0XC7,0XDE,0X29,

109240XE6,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

109250XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

109260XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

109270XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X29,0XDE,0X0B,0X8B,0XA3,

109280X52,0X20,0X49,0XE1,0X49,0XC1,0X49,0XE2,0X41,0XE2,0X39,0XA2,0X5A,0XE9,0XF7,0XBD,

109290XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

109360XFF,0XFD,0XDE,0X74,0XAC,0XA9,0XD5,0XCA,0XDD,0XE9,0XE5,0XE7,0XE5,0XC8,0XE5,0XC8,

109370XDD,0XC8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

109380XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X07,

109390XE6,0X07,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XFE,0XCA,0XDD,0XE8,0XA4,0X22,0XB4,0XA5,

109400XAC,0X85,0XA4,0X25,0XA4,0X26,0X9B,0XE5,0X9B,0XE5,0X8B,0XA4,0X8B,0XC3,0X83,0XA4,

109410X73,0X45,0XC5,0XD2,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

109420XFF,0XFF,0XFF,0XDF,0XFF,0XBC,0XDE,0X73,0XB4,0XE7,0XDE,0X08,0XEE,0X28,0XE5,0XE7,

109430XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,

109440XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

109450XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

109460XEE,0X06,0XEE,0X07,0XE6,0X07,0XE6,0X29,0XDD,0XEA,0X83,0X63,0X52,0X00,0X49,0XC0,

109470X41,0XC1,0X41,0XC2,0X41,0XE2,0X39,0XA2,0X62,0XE9,0XF7,0XBD,0XFF,0XFE,0XFF,0XFF,

109480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XEF,0X17,

109550XAC,0XAA,0XD5,0XCB,0XDD,0XC8,0XE5,0XC7,0XE5,0XE7,0XE5,0XA7,0XE5,0XE8,0XE5,0XE8,

109560XE5,0XC7,0XE5,0XE8,0XE5,0XE8,0XE5,0XE8,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE5,0XE7,

109570XE6,0X07,0XE6,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,

109580XE6,0X08,0XEE,0X28,0XF6,0X89,0XEE,0X89,0XB4,0XA3,0XAC,0X83,0XB4,0X85,0XAC,0X45,

109590XA4,0X25,0XA4,0X26,0X9B,0XE5,0X93,0XC4,0X93,0XE4,0X8B,0XC4,0X7B,0X45,0XB5,0X2F,

109600XFF,0XDD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

109610XFF,0X9C,0XDE,0X32,0XB5,0X07,0XE6,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X27,0XEE,0X07,

109620XEE,0X08,0XE6,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

109630XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

109640XEE,0X07,0XEE,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X06,0XEE,0X27,

109650XE6,0X07,0XEE,0X4A,0XD5,0XAA,0X83,0X83,0X52,0X00,0X49,0XC0,0X49,0XE2,0X41,0XA1,

109660X41,0XE2,0X39,0XA2,0X62,0XEA,0XF7,0XBD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XF7,0X59,0XAC,0XCB,0XCD,0X8B,

109740XDD,0XCA,0XDD,0XA7,0XE5,0XE7,0XE5,0XC6,0XE5,0XC7,0XE5,0XE8,0XE5,0XC7,0XE5,0XE8,

109750XE5,0XE8,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE5,0XE8,0XE5,0XE8,0XE6,0X07,0XE6,0X07,

109760XEE,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XE6,0X28,

109770XEE,0X69,0XF6,0XAA,0XCD,0X65,0XB4,0X83,0XB4,0XA4,0XAC,0X65,0XAC,0X25,0XAC,0X26,

109780XAC,0X26,0X9B,0XE5,0X93,0XE4,0X8B,0XC4,0X83,0X85,0X9C,0X8C,0XFF,0XBC,0XFF,0XFF,

109790XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XBB,0XD6,0X31,

109800XBD,0X27,0XE6,0X28,0XEE,0X27,0XE6,0X06,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XE6,0X08,

109810XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,

109820XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

109830XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X06,0XEE,0X27,0XEE,0X07,0XEE,0X2A,

109840XCD,0X69,0X83,0X43,0X52,0X00,0X49,0XC1,0X49,0XC2,0X41,0XA1,0X41,0XC2,0X39,0X82,

109850X6B,0X4B,0XF7,0XBD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109920XF7,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0X9B,0XBD,0X2D,0XC5,0X2A,0XDD,0XCA,0XDD,0XA7,

109930XE5,0XC7,0XE5,0XC6,0XE5,0XC7,0XE5,0XE8,0XE5,0XC7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE7,

109940XE5,0XE7,0XE6,0X07,0XE5,0XE8,0XE5,0XE8,0XE6,0X07,0XE6,0X08,0XEE,0X07,0XE6,0X07,

109950XE6,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XE6,0X07,0XEE,0X48,0XFE,0XEA,

109960XE6,0X48,0XBC,0XC3,0XB4,0XA4,0XAC,0X65,0XB4,0X66,0XAC,0X26,0XAC,0X26,0X9B,0XE5,

109970X9C,0X05,0X93,0XE4,0X8B,0XC6,0X83,0XC9,0XF7,0X5A,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XBB,0XD5,0XF0,0XC5,0X48,0XE6,0X28,

109990XEE,0X28,0XEE,0X06,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,

110000XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

110010XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,

110020XEE,0X07,0XEE,0X27,0XE6,0X06,0XEE,0X27,0XEE,0X28,0XE6,0X09,0XC5,0X28,0X83,0X43,

110030X52,0X00,0X49,0XC1,0X49,0XC2,0X41,0XC2,0X41,0XC2,0X31,0X82,0X7B,0XAD,0XFF,0XDE,

110040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XFF,0XFF,

110110XFF,0XFF,0XFF,0XBC,0XCD,0XD1,0XB4,0XEA,0XD5,0XAA,0XDD,0XC8,0XE5,0XE7,0XE5,0XC6,

110120XE5,0XE7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

110130XE5,0XE8,0XE5,0XE8,0XE6,0X08,0XE6,0X08,0XE6,0X08,0XE6,0X07,0XE6,0X07,0XEE,0X27,

110140XEE,0X28,0XEE,0X28,0XEE,0X28,0XE6,0X28,0XE6,0X07,0XF6,0X89,0XFE,0XEA,0XCD,0X85,

110150XB4,0XC4,0XB4,0XA5,0XB4,0X86,0XAC,0X46,0XAC,0X47,0XA4,0X26,0XA4,0X25,0X93,0XE4,

110160X8B,0XE6,0X83,0XA8,0XE6,0XD8,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110170XFF,0XFF,0XFF,0XFE,0XFF,0XBB,0XCD,0XAF,0XC5,0X68,0XE6,0X28,0XEE,0X28,0XEE,0X07,

110180XEE,0X27,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X27,

110190XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

110200XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X47,

110210XE6,0X06,0XEE,0X27,0XEE,0X28,0XE6,0X09,0XB4,0XC7,0X83,0X43,0X52,0X01,0X41,0XC1,

110220X49,0XC2,0X41,0XC2,0X41,0XC2,0X31,0X82,0X83,0XED,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

110230XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,

110300XE6,0X95,0XAC,0XCB,0XD5,0XAB,0XE5,0XE9,0XE5,0XC6,0XE5,0XE6,0XE5,0XE7,0XE5,0XC7,

110310XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

110320XE6,0X08,0XE6,0X08,0XE6,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X07,

110330XEE,0X28,0XEE,0X48,0XE6,0X07,0XE6,0X27,0XFF,0X0A,0XEE,0X69,0XC5,0X25,0XBC,0XE5,

110340XBC,0XC6,0XB4,0X86,0XAC,0X46,0XAC,0X46,0XA4,0X45,0X9C,0X25,0X94,0X06,0X83,0XA7,

110350XCD,0XF3,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

110360XFF,0XDA,0XC5,0X8D,0XCD,0X88,0XE6,0X28,0XEE,0X28,0XEE,0X08,0XEE,0X07,0XEE,0X07,

110370XEE,0X07,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

110380XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

110390XEE,0X07,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X06,0XEE,0X27,

110400XEE,0X28,0XE6,0X0A,0XB4,0XA7,0X83,0X43,0X51,0XE1,0X41,0XC1,0X49,0XE2,0X41,0XC2,

110410X41,0XC2,0X31,0X61,0X84,0X0E,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XF7,0X38,0XAC,0XCB,

110490XCD,0X6B,0XDD,0XC9,0XDD,0XA6,0XE6,0X07,0XDD,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

110500XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

110510XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XE6,0X28,0XEE,0X48,

110520XE6,0X27,0XE6,0X27,0XFE,0XEA,0XFE,0XEA,0XD5,0XA6,0XBC,0XE5,0XB4,0XA5,0XBC,0XE7,

110530XB4,0X86,0XAC,0X46,0XAC,0X65,0XA4,0X65,0X9C,0X05,0X8B,0XA6,0XA4,0XCE,0XFF,0XFD,

110540XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XD9,0XC5,0X8C,

110550XCD,0XA8,0XE6,0X49,0XEE,0X09,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

110560XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,

110570XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,

110580XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X47,0XEE,0X07,0XEE,0X27,0XEE,0X49,0XE5,0XE9,

110590XB4,0XA7,0X7B,0X03,0X52,0X01,0X49,0XC1,0X49,0XE2,0X41,0XC2,0X41,0XC2,0X31,0X61,

110600X94,0X90,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XBD,0XFF,0X9A,0XBD,0X4F,0XBD,0X2A,0XD5,0XA9,

110680XDD,0XA6,0XE6,0X07,0XDD,0XC7,0XE6,0X08,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,

110690XE6,0X06,0XE6,0X06,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X08,

110700XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XE6,0X28,0XEE,0X48,0XEE,0X48,0XE6,0X27,

110710XF6,0X88,0XFF,0X0B,0XEE,0X69,0XCD,0X66,0XB4,0XA4,0XC4,0XE6,0XBC,0XC7,0XB4,0X86,

110720XAC,0X64,0XA4,0X64,0X9C,0X45,0X94,0X27,0X94,0X0A,0XF7,0X7A,0XFF,0XDD,0XFF,0XFF,

110730XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFC,0XFF,0XB7,0XC5,0XAC,0XCD,0XA8,0XE6,0X49,

110740XED,0XE9,0XF6,0X09,0XEE,0X08,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

110750XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

110760XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X07,0XEE,0X07,

110770XEE,0X07,0XF6,0X47,0XEE,0X07,0XEE,0X27,0XF6,0X49,0XDD,0XA8,0XB4,0XC7,0X72,0XC2,

110780X52,0X01,0X49,0XE2,0X49,0XE2,0X41,0XC2,0X41,0XE2,0X31,0X82,0XB5,0X74,0XFF,0XFF,

110790XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110860XFF,0XFF,0XFF,0XDE,0XFF,0XDC,0XD6,0X33,0XB4,0XEA,0XD5,0XAA,0XDD,0XC7,0XDD,0XE6,

110870XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

110880XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,

110890XEE,0X28,0XEE,0X28,0XEE,0X48,0XE6,0X07,0XEE,0X27,0XE6,0X27,0XE6,0X47,0XFE,0XEA,

110900XFF,0X4D,0XE6,0X49,0XC5,0X25,0XBC,0XC5,0XB4,0X85,0XB4,0X85,0XB4,0XC5,0XB4,0XC6,

110910XAC,0XA6,0X9C,0X47,0X8B,0XE8,0XDE,0X55,0XFF,0XDC,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,

110920XFF,0XFC,0XFF,0XFA,0XFF,0X95,0XCD,0XAB,0XCD,0XA8,0XEE,0X49,0XE5,0XE8,0XEE,0X09,

110930XEE,0X08,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,

110940XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

110950XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XF6,0X48,

110960XEE,0X27,0XEE,0X27,0XF6,0X69,0XD5,0X67,0XBC,0XE8,0X62,0X61,0X52,0X01,0X52,0X02,

110970X49,0XE2,0X49,0XC2,0X41,0XE2,0X39,0X82,0XC6,0X16,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110980XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

111050XFF,0XFD,0XEF,0X37,0XBD,0X6D,0XC5,0X8A,0XDD,0XC9,0XDD,0XC7,0XE5,0XE7,0XE5,0XC7,

111060XE5,0XC7,0XE5,0XE7,0XE5,0XE8,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

111070XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X28,

111080XEE,0X28,0XEE,0X07,0XEE,0X48,0XEE,0X68,0XE6,0X27,0XEE,0X68,0XFF,0X0C,0XFF,0X4D,

111090XE6,0X29,0XB4,0XC4,0XBC,0XE5,0XB4,0X85,0XAC,0X84,0XAC,0X84,0XA4,0X84,0XA4,0X86,

111100X9C,0X48,0XAC,0XED,0XFF,0XBA,0XFF,0XBB,0XFF,0XDC,0XFF,0XBB,0XFF,0XFA,0XFF,0XD6,

111110XFF,0X72,0XDE,0X2B,0XDE,0X09,0XE6,0X29,0XE5,0XE8,0XEE,0X08,0XEE,0X07,0XEE,0X07,

111120XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

111130XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,

111140XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X26,0XF6,0X67,

111150XEE,0X28,0XD5,0X68,0XB4,0XA8,0X62,0X40,0X51,0XE1,0X52,0X23,0X4A,0X02,0X4A,0X03,

111160X49,0XC3,0X41,0XC4,0XDE,0X99,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,

111170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XBA,

111240XCE,0X31,0XBD,0X4A,0XD5,0XA9,0XE5,0XE9,0XE5,0XC7,0XE5,0XC8,0XE5,0XC7,0XE5,0XE8,

111250XE5,0XE8,0XE5,0XE8,0XE5,0XE8,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

111260XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X08,0XEE,0X07,0XF6,0X48,

111270XEE,0X27,0XE6,0X27,0XEE,0X48,0XEE,0X48,0XEE,0X6A,0XFF,0X0C,0XFF,0X0C,0XE6,0X09,

111280XB4,0XA4,0XB4,0XC5,0XB4,0XA4,0XAC,0X84,0XAC,0XC5,0XA4,0X64,0XA4,0X87,0XAC,0X8A,

111290XEE,0XB5,0XFF,0XBA,0XFF,0XB9,0XFF,0XD8,0XF7,0X55,0XFF,0X93,0XEE,0XEE,0XE6,0X4A,

111300XE6,0X29,0XE6,0X29,0XE6,0X28,0XEE,0X48,0XF6,0X27,0XEE,0X07,0XF6,0X07,0XEE,0X07,

111310XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

111320XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,

111330XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X26,0XF6,0X67,0XEE,0X28,0XD5,0X88,

111340XAC,0X66,0X5A,0X40,0X52,0X01,0X52,0X23,0X52,0X02,0X4A,0X03,0X41,0XC3,0X52,0X26,

111350XF7,0X5C,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XFC,0XEE,0XF5,0XC5,0X6D,

111430XCD,0X8A,0XDD,0XCA,0XDD,0XA8,0XE5,0XC8,0XE5,0XC8,0XE5,0XC8,0XE5,0XE8,0XE5,0XE8,

111440XE5,0XE7,0XE5,0XE7,0XE5,0XE8,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

111450XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X08,0XEE,0X28,0XEE,0X48,0XEE,0X47,0XEE,0X47,

111460XEE,0X47,0XE6,0X48,0XE6,0X48,0XEE,0X8A,0XFE,0XEB,0XFF,0XAE,0XEE,0XAB,0XCD,0X87,

111470XAC,0X62,0XA4,0X62,0XAC,0X83,0XAC,0X84,0X9C,0X24,0XA4,0X67,0XC5,0X6D,0XFF,0X56,

111480XFF,0X55,0XFF,0X34,0XEE,0XD0,0XEE,0XCE,0XE6,0X4B,0XE6,0X4A,0XE6,0X49,0XE6,0X28,

111490XEE,0X28,0XEE,0X48,0XEE,0X27,0XEE,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X08,0XEE,0X28,

111500XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

111510XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

111520XEE,0X28,0XEE,0X28,0XEE,0X47,0XF6,0X68,0XE6,0X08,0XD5,0XA9,0X93,0XC4,0X5A,0X40,

111530X5A,0X22,0X5A,0X42,0X52,0X02,0X4A,0X02,0X41,0XC3,0X62,0XC8,0XFF,0XFE,0XFF,0XFF,

111540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111610XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDC,0XFF,0X99,0XDE,0X31,0XC5,0X4A,0XD5,0XCA,

111620XDD,0XC9,0XE5,0XC8,0XE5,0XC8,0XE5,0XC8,0XE5,0XC8,0XE5,0XE8,0XE5,0XE8,0XE5,0XE8,

111630XE5,0XE8,0XE5,0XE8,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,

111640XEE,0X08,0XEE,0X28,0XF6,0X48,0XEE,0X07,0XEE,0X47,0XF6,0X67,0XE6,0X26,0XE6,0X27,

111650XEE,0X68,0XE6,0X28,0XEE,0X69,0XEE,0XAA,0XFF,0X2D,0XFF,0X2D,0XFE,0XEC,0XE6,0X49,

111660XC5,0X65,0XCD,0X66,0XD5,0XC9,0XDE,0X0C,0XE6,0X4E,0XFF,0X12,0XF6,0XD0,0XEE,0X8E,

111670XE6,0X4C,0XDD,0XE9,0XE6,0X29,0XE6,0X49,0XE6,0X28,0XE6,0X28,0XEE,0X47,0XEE,0X27,

111680XEE,0X07,0XEE,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

111690XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,

111700XEE,0X27,0XEE,0X27,0XF6,0X27,0XEE,0X27,0XF6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

111710XEE,0X26,0XEE,0X47,0XE5,0XE8,0XD5,0XA9,0X83,0X42,0X62,0X61,0X5A,0X42,0X5A,0X43,

111720X52,0X22,0X52,0X02,0X41,0XC3,0X7B,0XAC,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

111730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111800XFF,0XDE,0XFF,0XBC,0XFF,0XFB,0XF7,0X36,0XBD,0X4B,0XD5,0XEB,0XD5,0XC8,0XDD,0XE7,

111810XE5,0XC6,0XE5,0XC6,0XE5,0XE7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE8,0XE5,0XE9,0XE5,0XE8,

111820XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X28,

111830XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XE6,0X27,0XE6,0X28,0XE6,0X48,

111840XE6,0X28,0XE6,0X49,0XEE,0X8A,0XF6,0XAA,0XFF,0X2C,0XFF,0X4C,0XFF,0X6D,0XFF,0X6D,

111850XFF,0X4D,0XFF,0X0D,0XFE,0XEE,0XEE,0X4C,0XE5,0XEA,0XEE,0X2A,0XE6,0X09,0XEE,0X48,

111860XE6,0X28,0XE6,0X28,0XE6,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X26,0XF6,0X47,0XF6,0X27,

111870XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,

111880XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

111890XF6,0X27,0XEE,0X27,0XF6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X48,

111900XE6,0X08,0XD5,0X89,0X7A,0XE1,0X6A,0XA2,0X5A,0X62,0X62,0X83,0X52,0X43,0X52,0X43,

111910X41,0XE3,0XA5,0X11,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,

111990XFF,0XDC,0XFF,0X99,0XE6,0XB3,0XB5,0X09,0XD6,0X0A,0XD5,0XC7,0XDD,0XE6,0XE5,0XE6,

112000XE5,0XE6,0XED,0XE7,0XED,0XE8,0XE5,0XE8,0XE5,0XE8,0XE5,0XE8,0XE5,0XE8,0XEE,0X07,

112010XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X47,

112020XEE,0X27,0XEE,0X26,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X49,0XEE,0X48,0XE6,0X48,

112030XE6,0X28,0XE6,0X48,0XE6,0X48,0XE6,0X48,0XEE,0X68,0XE6,0X48,0XEE,0X28,0XE6,0X28,

112040XEE,0X49,0XEE,0X29,0XEE,0X08,0XF6,0X28,0XEE,0X07,0XEE,0X47,0XEE,0X27,0XEE,0X47,

112050XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X68,0XEE,0X27,0XEE,0X27,0XEE,0X27,

112060XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

112070XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XF6,0X27,0XEE,0X27,

112080XF6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XE6,0X29,0XC5,0X07,

112090X72,0XC1,0X72,0XC2,0X62,0X63,0X62,0XA4,0X5A,0X63,0X52,0X63,0X41,0XC2,0XCE,0X35,

112100XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XFD,

112180XF7,0X37,0XDE,0X50,0XBD,0X69,0XD6,0X08,0XDD,0XE6,0XDD,0XE5,0XE5,0XE6,0XE5,0XE6,

112190XED,0XE7,0XED,0XE7,0XED,0XE7,0XE5,0XE7,0XED,0XE8,0XEE,0X08,0XEE,0X08,0XEE,0X07,

112200XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X48,0XEE,0X27,0XEE,0X27,0XEE,0X27,

112210XEE,0X27,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XE6,0X48,0XEE,0X48,0XEE,0X48,

112220XE6,0X48,0XEE,0X48,0XE6,0X27,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X07,0XF6,0X48,

112230XF6,0X27,0XEE,0X07,0XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X46,

112240XEE,0X46,0XF6,0X47,0XF6,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

112250XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

112260XEE,0X27,0XEE,0X27,0XEE,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X27,

112270XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X48,0XE6,0X2A,0XAC,0X65,0X72,0XE1,0X72,0XE3,

112280X6A,0XA3,0X62,0XA4,0X5A,0X83,0X52,0X64,0X52,0X65,0XE7,0X19,0XFF,0XFE,0XFF,0XFF,

112290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112360XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDD,0XFF,0XDC,0XF7,0X56,

112370XCD,0XCD,0XCD,0XC9,0XD5,0XE7,0XDD,0XE6,0XE5,0XE6,0XE5,0XE6,0XE5,0XE6,0XED,0XE7,

112380XED,0XE7,0XED,0XE7,0XED,0XE8,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X27,0XEE,0X27,

112390XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

112400XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X69,0XEE,0X28,0XEE,0X28,0XEE,0X48,0XE6,0X28,

112410XEE,0X48,0XEE,0X68,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X27,

112420XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X47,0XEE,0X47,

112430XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,

112440XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

112450XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X47,

112460XEE,0X47,0XEE,0X69,0XE6,0X4A,0X9C,0X04,0X7A,0XE2,0X72,0XE3,0X72,0XE4,0X62,0XA4,

112470X62,0XC4,0X52,0X64,0X73,0X69,0XF7,0X9B,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112550XFF,0XFE,0XF7,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XF7,0X35,0XD6,0X0E,

112560XCD,0XCA,0XD5,0XC7,0XDD,0XE7,0XDD,0XA6,0XF6,0X48,0XED,0XE7,0XED,0XE7,0XED,0XE7,

112570XED,0XE8,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XE6,0X07,0XEE,0X28,

112580XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,

112590XF6,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,

112600XEE,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XF6,0X47,0XEE,0X27,0XF6,0X27,0XF6,0X27,

112610XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

112620XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X27,

112630XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X47,0XF6,0X27,0XF6,0X27,

112640XEE,0X27,0XF6,0X48,0XEE,0X27,0XF6,0X48,0XEE,0X27,0XEE,0X47,0XF6,0X68,0XEE,0X49,

112650XDD,0XE9,0X93,0XA2,0X7B,0X02,0X7A,0XE3,0X7B,0X25,0X62,0XA4,0X62,0XA4,0X5A,0X84,

112660X9C,0XAE,0XF7,0XBC,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

112740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0X9A,0XEE,0XF4,0XD6,0X0D,0XD5,0XCA,

112750XDD,0XE8,0XDD,0XE7,0XE5,0XE7,0XE5,0XE7,0XEE,0X07,0XED,0XE7,0XE5,0XE7,0XEE,0X07,

112760XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X48,0XEE,0X28,0XEE,0X28,

112770XEE,0X27,0XEE,0X27,0XEE,0X26,0XEE,0X26,0XEE,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X47,

112780XF6,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XF6,0X68,0XEE,0X27,

112790XEE,0X47,0XEE,0X47,0XEE,0X27,0XF6,0X47,0XF6,0X48,0XEE,0X28,0XF6,0X27,0XF6,0X27,

112800XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

112810XEE,0X28,0XEE,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

112820XF6,0X27,0XF6,0X27,0XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X27,0XF6,0X48,

112830XF6,0X27,0XF6,0X47,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X6A,0XCD,0X68,0X8B,0X82,

112840X83,0X23,0X7B,0X03,0X7B,0X05,0X6A,0XC4,0X62,0XE5,0X5A,0XC6,0XB5,0X92,0XFF,0XDD,

112850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XF7,0XFE,0XFF,0XFF,0XFF,0XFF,

112930XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XBA,0XEE,0XD3,0XD6,0X0D,0XD5,0XC9,0XDE,0X08,

112940XDD,0XE7,0XDD,0XE6,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

112950XEE,0X27,0XEE,0X07,0XE6,0X07,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

112960XEE,0X26,0XEE,0X46,0XEE,0X46,0XEE,0X46,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

112970XF6,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X47,0XEE,0X48,0XF6,0X68,0XEE,0X47,

112980XEE,0X47,0XEE,0X48,0XEE,0X27,0XF6,0X68,0XEE,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X27,

112990XF6,0X27,0XF6,0X28,0XEE,0X28,0XF6,0X48,0XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X28,

113000XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X27,

113010XF6,0X48,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X48,0XEE,0X47,

113020XF6,0X68,0XEE,0X48,0XEE,0X28,0XEE,0X8A,0XB4,0XC6,0X8B,0XA3,0X83,0X63,0X83,0X44,

113030X72,0XE4,0X73,0X05,0X62,0XC5,0X6B,0X27,0XD6,0X97,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

113040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113110XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

113120XFF,0XDE,0XFF,0XDD,0XFF,0XDA,0XEF,0X14,0XCE,0X0C,0XCD,0XC9,0XDE,0X28,0XE6,0X28,

113130XDD,0XE7,0XE6,0X07,0XE6,0X07,0XEE,0X06,0XEE,0X06,0XEE,0X06,0XEE,0X27,0XEE,0X27,

113140XEE,0X28,0XEE,0X28,0XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X26,0XEE,0X46,

113150XEE,0X46,0XEE,0X46,0XF6,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X47,

113160XEE,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X68,0XEE,0X48,

113170XEE,0X48,0XEE,0X27,0XEE,0X27,0XF6,0X27,0XEE,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X28,

113180XEE,0X28,0XF6,0X48,0XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,

113190XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X27,

113200XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X28,0XF6,0X48,0XF6,0X47,0XF6,0X68,0XEE,0X48,

113210XEE,0X69,0XEE,0X6A,0XA4,0X44,0X93,0XC3,0X8B,0X84,0X8B,0X85,0X7B,0X04,0X7B,0X26,

113220X62,0XC5,0X83,0XEB,0XEF,0X5A,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBF,0XFF,0XDE,

113310XFF,0XFD,0XFF,0XB9,0XF7,0X74,0XDE,0XAE,0XCD,0XE9,0XD5,0XE7,0XE6,0X28,0XE6,0X07,

113320XE6,0X07,0XE6,0X07,0XE6,0X06,0XE6,0X06,0XEE,0X26,0XEE,0X27,0XEE,0X28,0XEE,0X48,

113330XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X67,

113340XEE,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XF6,0X48,0XF6,0X47,0XEE,0X47,

113350XEE,0X06,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X88,0XFE,0XA9,0XD5,0X84,

113360XEE,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X28,0XF6,0X28,

113370XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

113380XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X28,

113390XF6,0X28,0XF6,0X28,0XF6,0X48,0XF6,0X47,0XEE,0X47,0XEE,0X68,0XF6,0X8A,0XDD,0XE9,

113400X9B,0XE3,0X93,0XE4,0X8B,0X84,0X93,0XA6,0X83,0X45,0X83,0X66,0X6B,0X06,0XA4,0XEF,

113410XF7,0X9B,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,

113500XFF,0XD9,0XEF,0X34,0XEF,0X10,0XDE,0X2C,0XD5,0XC9,0XDD,0XC8,0XE5,0XE8,0XE6,0X08,

113510XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XE6,0X07,0XE6,0X07,0XEE,0X28,0XEE,0X28,

113520XF6,0X48,0XF6,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X48,0XEE,0X48,0XEE,0X47,0XEE,0X28,

113530XF6,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X47,0XF6,0X47,0XF6,0X68,0XEE,0X47,

113540XF6,0X68,0XFE,0XA9,0XF6,0X68,0XE5,0XC5,0XDD,0XA4,0XC4,0XC1,0XF6,0X47,0XF6,0X47,

113550XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,

113560XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,

113570XF6,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X28,

113580XF6,0X48,0XF6,0X47,0XEE,0X47,0XF6,0X89,0XF6,0X8A,0XC5,0X27,0X9B,0XE3,0X9C,0X05,

113590X93,0XA5,0X93,0XA6,0X8B,0X86,0X83,0X66,0X7B,0X68,0XC5,0XF3,0XFF,0XDC,0XFF,0XFE,

113600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113680XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFB,

113690XFF,0XB8,0XEE,0XD3,0XE6,0X4F,0XE6,0X0D,0XDD,0XEA,0XE5,0XE9,0XE6,0X08,0XE6,0X07,

113700XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X28,

113710XEE,0X28,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XF6,0X28,

113720XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XFE,0X88,0XEE,0X07,0XE5,0XC5,

113730XE5,0XA5,0XEE,0X06,0XE5,0XC5,0XDD,0XA4,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

113740XF6,0X48,0XF6,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X27,

113750XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X27,

113760XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X48,0XF6,0X47,

113770XEE,0X47,0XFE,0XCA,0XEE,0X49,0XB4,0XA5,0X9C,0X24,0X9C,0X05,0X9B,0XE6,0X93,0XA6,

113780X93,0XC7,0X7B,0X46,0X94,0X4B,0XE6,0XD7,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

113870XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFE,0XFF,0XBC,0XFF,0X9A,

113880XFF,0X78,0XF6,0XD3,0XE6,0X4E,0XEE,0X4C,0XE6,0X0A,0XDD,0XE8,0XDD,0XE8,0XE6,0X07,

113890XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X29,

113900XEE,0X29,0XEE,0X29,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XF6,0X29,0XF6,0X69,0XFE,0X69,

113910XFE,0X68,0XF6,0X68,0XF6,0X27,0XE5,0XC6,0XE5,0XA6,0XF6,0X48,0XF6,0X48,0XFE,0X89,

113920XDD,0XA5,0XE5,0XC5,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

113930XF6,0X48,0XF6,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

113940XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X27,0XF6,0X27,0XF6,0X27,

113950XF6,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X68,0XFE,0XEB,

113960XDD,0XE8,0XAC,0X43,0XA4,0X64,0X94,0X04,0XA4,0X26,0X93,0XA5,0X9C,0X08,0X83,0X67,

113970XB5,0X2F,0XF7,0X9A,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

114060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDE,0XFF,0XDD,0XFF,0XBC,0XFF,0XBB,

114070XFF,0X56,0XF7,0X12,0XEE,0XAF,0XE6,0X8D,0XE6,0X6C,0XE6,0X6A,0XE6,0X49,0XE6,0X48,

114080XE6,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XF6,0X49,0XEE,0X48,

114090XEE,0X68,0XF6,0X88,0XF6,0X89,0XFE,0X6A,0XFE,0X4A,0XFE,0X49,0XFE,0X48,0XF6,0X47,

114100XEE,0X27,0XF6,0X68,0XF6,0X69,0XFE,0XAA,0XFE,0XAA,0XEE,0X48,0XD5,0X64,0XF6,0X27,

114110XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X27,

114120XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X48,0XF6,0X48,0XF6,0X48,

114130XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XF6,0X48,0XF6,0X48,

114140XF6,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X69,0XF6,0X8A,0XF6,0X8B,0XD5,0X67,0XAC,0X43,

114150XA4,0X64,0X9C,0X44,0XA4,0X66,0X93,0XE6,0X93,0XE7,0X8B,0XE9,0XCE,0X13,0XFF,0XDC,

114160XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114250XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDE,0XFF,0XDD,0XFF,0XDB,0XFF,0XB8,

114260XFF,0X96,0XF7,0X54,0XEE,0XF1,0XEE,0XCF,0XEE,0XAE,0XE6,0X8C,0XE6,0X6C,0XEE,0X8B,

114270XEE,0X8B,0XEE,0X6B,0XF6,0X8B,0XEE,0X6A,0XEE,0X4A,0XEE,0X49,0XE6,0X48,0XE6,0X07,

114280XE5,0XC7,0XE5,0XE8,0XEE,0X08,0XF6,0X28,0XFE,0X68,0XFE,0XA9,0XFE,0XA9,0XFE,0XCA,

114290XFE,0XCB,0XF6,0X8A,0XFE,0XAA,0XEE,0X48,0XDD,0X85,0XEE,0X07,0XF6,0X48,0XF6,0X48,

114300XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X27,0XF6,0X27,0XF6,0X27,

114310XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

114320XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XEE,0X28,0XF6,0X48,

114330XF6,0X48,0XEE,0X48,0XFE,0XCC,0XEE,0X4A,0XCD,0X26,0XB4,0X84,0XAC,0X84,0XA4,0X65,

114340XA4,0X66,0X94,0X06,0X93,0XE7,0XA4,0X8C,0XE6,0XF7,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,

114350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114440XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFB,

114450XFF,0XD9,0XFF,0XB8,0XFF,0X76,0XF7,0X14,0XDE,0X50,0XCD,0XAD,0XBD,0X2B,0XB4,0XE8,

114460XAC,0XC7,0XAC,0XE6,0XBD,0X07,0XB5,0X06,0XC5,0X67,0XD5,0XA8,0XE6,0X09,0XEE,0X4A,

114470XFE,0X8A,0XFE,0XAA,0XFE,0XA9,0XFE,0XA9,0XF6,0X89,0XEE,0X68,0XF6,0XCA,0XF6,0XAA,

114480XFE,0XCA,0XDD,0XC5,0XDD,0X64,0XFE,0X67,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,

114490XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

114500XF6,0X27,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

114510XF6,0X47,0XF6,0X47,0XF6,0X48,0XEE,0X28,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XEE,0X48,

114520XFE,0XED,0XE5,0XC9,0XC4,0XE5,0XBC,0XE6,0XB4,0XA5,0XAC,0XA6,0XA4,0X66,0X9C,0X26,

114530X94,0X08,0XBD,0X70,0XFF,0XBB,0XFF,0XFD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDD,0XFF,0XFC,

114640XFF,0XFC,0XFF,0XDB,0XFF,0XDB,0XFF,0XBA,0XEF,0X16,0XCD,0XF1,0XB5,0X2C,0X9C,0X68,

114650X94,0X47,0XA4,0X88,0XBD,0X2A,0XCD,0XAB,0XE6,0X2C,0XEE,0X6C,0XF6,0X8B,0XF6,0X8B,

114660XF6,0X8B,0XEE,0X8A,0XF6,0XAB,0XEE,0X8B,0XF6,0XAB,0XEE,0X4A,0XF6,0X8A,0XDD,0X85,

114670XE5,0XA5,0XF6,0X46,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

114680XF6,0X48,0XF6,0X48,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

114690XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

114700XF6,0X48,0XEE,0X47,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XFE,0X8A,0XFE,0XCC,0XDD,0X88,

114710XBC,0XC5,0XC5,0X07,0XBC,0XC6,0XB4,0XA6,0XAC,0XA7,0XA4,0X47,0X9C,0X6A,0XD6,0X53,

114720XFF,0XFC,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

114830XFF,0XFE,0XFF,0XBD,0XFF,0XDD,0XFF,0XFC,0XFF,0XFC,0XFF,0XDA,0XEF,0X57,0XD6,0X53,

114840XBD,0X4F,0XAC,0XCC,0XA4,0X69,0XA4,0X87,0XB4,0XE8,0XC5,0X69,0XD5,0XEB,0XE6,0X4C,

114850XE6,0X6D,0XEE,0X8D,0XEE,0X8D,0XF6,0XAD,0XF6,0X6B,0XD5,0X66,0XEE,0X06,0XFE,0X67,

114860XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

114870XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

114880XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

114890XF6,0X47,0XF6,0X47,0XF6,0X89,0XFE,0XCB,0XEE,0X2A,0XD5,0X47,0XC4,0XC5,0XCD,0X07,

114900XC5,0X07,0XBC,0XA7,0XB4,0XC8,0X9C,0X48,0XB5,0X0D,0XEF,0X38,0XFF,0XFC,0XFF,0XFE,

114910XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XDF,

115010XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

115020XFF,0XFF,0XFF,0XBE,0XFF,0XDE,0XFF,0XDD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XBB,

115030XFF,0X58,0XE6,0XB4,0XCD,0XF0,0XC5,0X8E,0XC5,0X8E,0XCD,0XCE,0XCD,0XCE,0XE6,0X91,

115040XF6,0XD1,0XF6,0XF0,0XE6,0X0B,0XD5,0X67,0XEE,0X28,0XF6,0X27,0XF6,0X48,0XF6,0X48,

115050XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X27,0XF6,0X27,

115060XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X48,0XF6,0X48,

115070XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X68,

115080XFE,0XA9,0XFE,0XCB,0XDD,0XA8,0XD5,0X47,0XC5,0X06,0XCD,0X27,0XCD,0X28,0XBC,0XC7,

115090XB4,0XC9,0XA4,0X69,0XCD,0XF1,0XFF,0XFB,0XFF,0XFD,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

115100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115200XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

115210XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XBC,

115220XFF,0XBC,0XFF,0XDC,0XFF,0XDB,0XFF,0XBB,0XFF,0X9A,0XFF,0X99,0XFF,0X98,0XFF,0X75,

115230XE6,0X2E,0XD5,0X89,0XEE,0X4A,0XEE,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

115240XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

115250XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

115260XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XFE,0XA9,0XFE,0XCA,0XF6,0X49,

115270XD5,0X47,0XD5,0X47,0XCD,0X46,0XCD,0X26,0XCD,0X27,0XC4,0XE8,0XB4,0XA9,0XB4,0XEC,

115280XEF,0X17,0XFF,0XFC,0XFF,0XFE,0XFF,0XDE,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

115290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

115390XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,

115400XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

115410XFF,0XDE,0XFF,0XDE,0XFF,0XDD,0XFF,0XFD,0XFF,0XFB,0XF7,0X36,0XCD,0XCD,0XD5,0XAA,

115420XEE,0X6A,0XE6,0X07,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

115430XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

115440XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X28,0XF6,0X28,

115450XF6,0X48,0XF6,0X48,0XF6,0X47,0XFE,0XC9,0XFE,0XCA,0XDD,0XC7,0XCD,0X46,0XCD,0X46,

115460XCD,0X67,0XCD,0X46,0XCD,0X07,0XC5,0X08,0XB4,0XA9,0XC5,0X90,0XFF,0XFB,0XFF,0XDD,

115470XFF,0XFE,0XF7,0XDE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115590XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

115600XFF,0XDE,0XFF,0XFD,0XFF,0XFB,0XE6,0XD3,0XC5,0XAA,0XDE,0X2A,0XF6,0X8A,0XEE,0X48,

115610XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

115620XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

115630XEE,0X27,0XF6,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X48,0XF6,0X49,0XF6,0X49,0XF6,0X48,

115640XFE,0X89,0XFE,0XAA,0XFE,0X89,0XDD,0X86,0XD5,0X66,0XD5,0X67,0XCD,0X66,0XCD,0X67,

115650XCD,0X27,0XC5,0X08,0XBD,0X0C,0XEE,0XD6,0XFF,0XFD,0XFF,0XFE,0XF7,0XDE,0XFF,0XFF,

115660XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115780XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,

115790XFF,0X99,0XDE,0X70,0XBD,0X48,0XE6,0X69,0XEE,0X68,0XEE,0X68,0XF6,0X48,0XF6,0X48,

115800XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

115810XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,

115820XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X69,0XF6,0X28,0XF6,0X49,0XFE,0XAA,0XFE,0X89,

115830XEE,0X28,0XDD,0XA6,0XDD,0XA7,0XD5,0X66,0XD5,0X87,0XD5,0X67,0XCD,0X27,0XCD,0X4A,

115840XC5,0X6E,0XFF,0XDB,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

115850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115970XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XF7,0X37,0XBD,0X4B,

115980XD5,0XE9,0XE6,0X69,0XE6,0X07,0XF6,0X89,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

115990XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

116000XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XF6,0X67,0XF6,0X47,

116010XF6,0X48,0XF6,0X69,0XEE,0X28,0XF6,0X69,0XFE,0XCB,0XF6,0X69,0XE5,0XE7,0XDD,0XC6,

116020XDD,0XE7,0XD5,0X66,0XD5,0X87,0XD5,0X88,0XCD,0X49,0XBD,0X0A,0XF7,0X36,0XFF,0XFC,

116030XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

116040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

116160XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBC,0XE6,0X93,0XB5,0X09,0XE6,0X6A,0XEE,0X68,

116170XEE,0X68,0XEE,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

116180XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

116190XF6,0X48,0XF6,0X47,0XF6,0X68,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X48,

116200XF6,0X69,0XFE,0XAA,0XFE,0XCB,0XEE,0X49,0XE5,0XE7,0XE5,0XE7,0XDD,0XC6,0XDD,0XC7,

116210XD5,0X67,0XD5,0XA9,0XC5,0X29,0XD6,0X0F,0XFF,0XB9,0XFF,0XDC,0XFF,0XFF,0XFF,0XFF,

116220XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDE,

116350XFF,0XDE,0XFF,0XBA,0XC5,0X6D,0XC5,0X89,0XE6,0X69,0XEE,0X68,0XEE,0X48,0XEE,0X08,

116360XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

116370XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

116380XF6,0X48,0XF6,0X68,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0XA9,0XFE,0XCA,

116390XFE,0X8A,0XEE,0X49,0XEE,0X07,0XE5,0XE7,0XDD,0XC5,0XDE,0X07,0XD5,0XA8,0XCD,0X8A,

116400XC5,0X4C,0XFF,0X56,0XFF,0XBA,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116410XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDE,0XFF,0XDD,0XF7,0X37,

116540XAC,0XC9,0XDE,0X2A,0XEE,0X68,0XF6,0X67,0XEE,0X07,0XF6,0X48,0XF6,0X48,0XF6,0X47,

116550XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

116560XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X68,

116570XEE,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XFE,0XC9,0XFE,0XCA,0XF6,0X49,0XF6,0X49,

116580XEE,0X28,0XDE,0X06,0XE6,0X26,0XDD,0XE6,0XDD,0XCA,0XCD,0X6B,0XDE,0X31,0XFF,0X78,

116590XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116720XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDD,0XFF,0XBB,0XC5,0X8F,0XBD,0X6A,0XE6,0X8B,

116730XE6,0X47,0XEE,0X46,0XF6,0X68,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

116740XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

116750XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X67,

116760XF6,0X67,0XFE,0X87,0XFE,0XC9,0XFE,0XA9,0XF6,0X48,0XF6,0X49,0XEE,0X48,0XE6,0X26,

116770XE6,0X47,0XDD,0XE6,0XE5,0XEB,0XDD,0XCD,0XF7,0X16,0XFF,0XBB,0XFF,0XFC,0XFF,0XFE,

116780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116910XFF,0XDF,0XFF,0XDD,0XF7,0X17,0XA4,0X89,0XD5,0XEA,0XE6,0X69,0XEE,0X67,0XEE,0X46,

116920XF6,0X47,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

116930XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

116940XF6,0X48,0XF6,0X48,0XF6,0X48,0XEE,0X48,0XF6,0X68,0XF6,0X87,0XFE,0X88,0XFE,0XC8,

116950XFE,0XC8,0XF6,0X88,0XF6,0X68,0XEE,0X48,0XEE,0X68,0XEE,0X47,0XE6,0X67,0XDE,0X08,

116960XDE,0X0C,0XEE,0XB2,0XFF,0X99,0XFF,0XDC,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

116970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0X3A,

117100XD5,0XD1,0XC5,0X4A,0XE6,0X4A,0XEE,0X89,0XE6,0X26,0XF6,0XA7,0XED,0XE5,0XFE,0X68,

117110XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

117120XF6,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,

117130XF6,0X47,0XEE,0X47,0XF6,0X68,0XF6,0XA8,0XFE,0XA9,0XFE,0XA9,0XFE,0XA8,0XFE,0X88,

117140XF6,0X68,0XEE,0X28,0XEE,0X48,0XF6,0X89,0XE6,0X49,0XE6,0X4B,0XDE,0X2E,0XFF,0X56,

117150XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117160XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0X9D,0XFF,0X59,0XA4,0X29,0XE6,0X2C,

117290XEE,0X49,0XEE,0X67,0XEE,0X66,0XEE,0X46,0XFE,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,

117300XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

117310XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

117320XF6,0X68,0XF6,0X88,0XFE,0XC9,0XFE,0XA9,0XFE,0XA8,0XF6,0X88,0XFE,0X68,0XF6,0X48,

117330XF6,0X69,0XEE,0X6A,0XE6,0X4A,0XDE,0X4D,0XEE,0XF3,0XFF,0XB9,0XFF,0XFD,0XFF,0XFF,

117340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFE,

117470XFF,0XFF,0XFF,0XDD,0XFF,0X9A,0XD5,0XD0,0XC5,0X4A,0XEE,0X4B,0XEE,0X48,0XEE,0X26,

117480XEE,0X47,0XF6,0X67,0XEE,0X27,0XF6,0X68,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

117490XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

117500XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X88,0XFE,0XA9,

117510XFE,0XA9,0XFE,0XA9,0XFE,0X88,0XF6,0X68,0XFE,0X69,0XF6,0X6A,0XF6,0X6A,0XEE,0X4B,

117520XDE,0X2C,0XE6,0XB0,0XFF,0X97,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,

117660XEF,0X16,0XB4,0XCA,0XE6,0X0B,0XEE,0X29,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X68,

117670XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

117680XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

117690XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X67,0XFE,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

117700XF6,0X88,0XF6,0X88,0XF6,0X69,0XFE,0X8A,0XEE,0X4A,0XEE,0X4C,0XE6,0X6E,0XF7,0X34,

117710XFF,0XD9,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XBA,0XC5,0X8D,0XCD,0XAA,

117850XE6,0X08,0XF6,0X48,0XF6,0X26,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XEE,0X47,

117860XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

117870XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,

117880XF6,0X67,0XFE,0X88,0XFE,0XC9,0XFE,0XC9,0XFE,0XA9,0XF6,0X88,0XF6,0X89,0XFE,0X89,

117890XFE,0X8A,0XF6,0X6A,0XEE,0X6B,0XE6,0X6D,0XF7,0X12,0XFF,0XD8,0XFF,0XDB,0XFF,0XFE,

117900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118030XFF,0XDF,0XFF,0XDD,0XFF,0XDC,0XDE,0X94,0XB5,0X2A,0XE6,0X4B,0XEE,0X48,0XF6,0X26,

118040XF6,0X26,0XF6,0X06,0XF6,0X27,0XF6,0X47,0XEE,0X26,0XF6,0X66,0XF6,0X47,0XF6,0X47,

118050XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

118060XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X68,0XFE,0XA8,

118070XFE,0XC9,0XFE,0XC9,0XFE,0XA9,0XFE,0X89,0XFE,0X8A,0XF6,0X8A,0XFE,0XAB,0XEE,0X6A,

118080XEE,0XAD,0XEE,0XB0,0XFF,0XB7,0XFF,0XFB,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,

118220XF7,0X78,0XC5,0XAE,0XD5,0XCB,0XE6,0X29,0XEE,0X26,0XF6,0X46,0XFE,0X47,0XFE,0X48,

118230XF6,0X28,0XF6,0X27,0XF6,0X87,0XEE,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,

118240XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,

118250XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X88,0XFE,0XA8,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

118260XFE,0XA9,0XFE,0X8A,0XFE,0X8B,0XF6,0X6B,0XF6,0X8B,0XEE,0X6B,0XF6,0XEF,0XF7,0X54,

118270XFF,0XFA,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

118280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XDB,0XDE,0X72,0XBD,0X4B,

118410XDE,0X2A,0XEE,0X48,0XF6,0X67,0XF6,0X26,0XF6,0X07,0XF6,0X28,0XF6,0X28,0XF6,0X48,

118420XF6,0X66,0XEE,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

118430XF6,0X47,0XF6,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

118440XF6,0X87,0XFE,0XA8,0XFE,0XC9,0XFE,0XA9,0XFE,0X89,0XFE,0X8A,0XFE,0X8A,0XFE,0XAB,

118450XFE,0X8B,0XF6,0X6B,0XEE,0X6C,0XEE,0X8E,0XF7,0X12,0XFF,0XD8,0XFF,0XFC,0XFF,0XDE,

118460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118580XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118590XFF,0XDE,0XFF,0XFD,0XFF,0XDB,0XEF,0X16,0XBD,0X4C,0XD5,0XCA,0XE6,0X49,0XF6,0X67,

118600XEE,0X45,0XF6,0X46,0XF6,0X48,0XF6,0X28,0XF6,0X29,0XF6,0X28,0XEE,0X47,0XF6,0X66,

118610XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X47,

118620XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XFE,0X88,0XFE,0XC9,

118630XFE,0XA9,0XFE,0X89,0XFE,0X8A,0XFE,0X6A,0XFE,0X6A,0XFE,0X6A,0XFE,0X8B,0XEE,0X4C,

118640XE6,0X4E,0XFF,0X34,0XFF,0XB8,0XFF,0XDB,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118760XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118770XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,

118780XFF,0X98,0XC5,0X8E,0XC5,0X6A,0XE6,0X2A,0XEE,0X48,0XF6,0X87,0XF6,0X66,0XF6,0X46,

118790XF6,0X48,0XF6,0X29,0XF6,0X29,0XF6,0X48,0XF6,0X47,0XF6,0X66,0XF6,0X67,0XF6,0X67,

118800XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X47,

118810XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XFE,0XA8,0XFE,0XC9,0XFE,0XE9,0XFE,0XA9,

118820XFE,0X6A,0XFE,0X8B,0XFE,0X8A,0XFE,0XAB,0XF6,0X8C,0XF6,0X8E,0XF6,0XF3,0XFF,0X98,

118830XFF,0XDB,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

118960XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XBB,0XDE,0X52,0XAC,0XA9,

118970XE6,0X0B,0XEE,0X49,0XF6,0X67,0XEE,0X25,0XF6,0X66,0XF6,0X66,0XF6,0X47,0XF6,0X48,

118980XF6,0X48,0XF6,0X48,0XF6,0X67,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

118990XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,

119000XF6,0X88,0XFE,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0XC9,0XFE,0XC9,0XFE,0X89,0XFE,0XCA,

119010XFE,0XCA,0XF6,0XAB,0XEE,0X8D,0XF6,0XD1,0XFF,0X97,0XFF,0XDB,0XFF,0XFD,0XFF,0XFF,

119020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,

119150XFF,0XBD,0XFF,0XFD,0XFF,0XBB,0XE6,0XD5,0XB4,0XEB,0XDD,0XCC,0XEE,0X6B,0XEE,0X28,

119160XFE,0X67,0XE5,0XE4,0XFE,0X66,0XF6,0X67,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X68,

119170XF6,0X66,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X67,

119180XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XFE,0X68,0XFE,0X89,0XFE,0XAA,

119190XFE,0XAA,0XFE,0XAA,0XFE,0XCA,0XFE,0XC9,0XFE,0XC9,0XF6,0XA8,0XF6,0XA9,0XEE,0X8B,

119200XF6,0XF0,0XFF,0X55,0XFF,0XDA,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119330XFF,0XFF,0XF7,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDC,0XFF,0XFB,

119340XEE,0XF6,0XBD,0X2D,0XCD,0XAC,0XF6,0X8C,0XEE,0X28,0XF6,0X47,0XF6,0X46,0XF6,0X66,

119350XF6,0X66,0XF6,0X67,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X67,0XF6,0X66,0XF6,0X66,

119360XF6,0X66,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X66,0XF6,0X66,0XF6,0X67,0XF6,0X67,

119370XF6,0X67,0XF6,0X68,0XFE,0X68,0XFE,0X89,0XFE,0XAA,0XFE,0XAB,0XFE,0XAB,0XFE,0XAB,

119380XFE,0XAA,0XFE,0XC9,0XFE,0XE9,0XEE,0XC9,0XEE,0XAB,0XEE,0XEF,0XFF,0X75,0XFF,0XB9,

119390XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119510XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

119520XF7,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDD,0XFF,0XFC,0XEE,0XF6,0XD5,0XEF,0XBD,0X29,

119530XF6,0X8C,0XEE,0X49,0XF6,0X48,0XF6,0X46,0XEE,0X05,0XFE,0X87,0XF6,0X46,0XF6,0X47,

119540XFE,0X48,0XFE,0X48,0XF6,0X48,0XF6,0X67,0XF6,0X66,0XF6,0X66,0XF6,0X47,0XF6,0X47,

119550XF6,0X67,0XF6,0X67,0XF6,0X46,0XF6,0X66,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X68,

119560XFE,0X89,0XFE,0X8A,0XFE,0XAA,0XFE,0X8B,0XFE,0X8B,0XFE,0X8B,0XFE,0X8A,0XF6,0XAA,

119570XF6,0XC9,0XEE,0XEB,0XEE,0XEE,0XFF,0X74,0XFF,0XDA,0XFF,0XDC,0XFF,0XFE,0XFF,0XFE,

119580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

119700XFF,0XBF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFE,0XF7,0XFD,0XFF,0XFE,0XF7,0XFF,0XF7,0XDF,

119710XFF,0XBE,0XFF,0XDD,0XF7,0X58,0XC5,0XAF,0XC5,0X69,0XEE,0XAB,0XE6,0X07,0XF6,0X67,

119720XFE,0X87,0XF6,0X25,0XF6,0X46,0XF6,0X46,0XF6,0X47,0XFE,0X48,0XFE,0X48,0XFE,0X28,

119730XFE,0X48,0XF6,0X48,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,

119740XF6,0X46,0XF6,0X66,0XF6,0X66,0XF6,0X67,0XF6,0X87,0XFE,0X88,0XFE,0XA9,0XFE,0XAA,

119750XFE,0XAB,0XFE,0X8B,0XFE,0X8B,0XFE,0X8B,0XFE,0XAB,0XF6,0XAB,0XEE,0XAB,0XEE,0XEE,

119760XF7,0X34,0XFF,0XDA,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

119770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBF,0XFF,0XBF,

119890XFF,0XDF,0XFF,0XFE,0XF7,0XFD,0XF7,0XFD,0XFF,0XFF,0XF7,0XDE,0XFF,0XDD,0XFF,0X9A,

119900XD6,0X31,0XBD,0X2A,0XDE,0X08,0XF6,0X88,0XF6,0X67,0XF6,0X66,0XF6,0X46,0XF6,0X46,

119910XFE,0X67,0XF6,0X47,0XF6,0X47,0XFE,0X48,0XFE,0X28,0XFE,0X28,0XF6,0X28,0XF6,0X48,

119920XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

119930XF6,0X67,0XF6,0X67,0XFE,0XA8,0XFE,0XA9,0XFE,0XCA,0XFE,0XCB,0XFE,0XAB,0XFE,0X8B,

119940XFE,0X8C,0XFE,0X8C,0XF6,0XAC,0XF6,0XAD,0XF6,0XEF,0XF7,0X54,0XFF,0XFB,0XFF,0XFD,

119950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDE,

120080XFF,0XFD,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XF7,0X79,0XD6,0X31,0XBD,0X4A,0XDE,0X29,

120090XEE,0X67,0XF6,0X66,0XF6,0X66,0XF6,0X46,0XF6,0X46,0XFE,0X47,0XFE,0X47,0XF6,0X47,

120100XF6,0X47,0XF6,0X47,0XF6,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X67,

120110XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X88,0XFE,0XA8,

120120XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAB,0XFE,0X8B,0XFE,0XAC,0XFE,0XAC,0XF6,0X8C,

120130XEE,0X8E,0XEE,0XF1,0XFF,0X76,0XFF,0XDA,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFD,

120270XFF,0XDB,0XFF,0X78,0XDE,0X30,0XC5,0X6A,0XDE,0X09,0XEE,0X68,0XF6,0X66,0XF6,0X66,

120280XFE,0X66,0XF6,0X46,0XF6,0X47,0XF6,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,

120290XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X67,0XF6,0X47,

120300XF6,0X47,0XF6,0X68,0XF6,0X68,0XF6,0X88,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XCA,

120310XFE,0XCB,0XFE,0XAB,0XFE,0XAC,0XF6,0XAC,0XF6,0X8C,0XEE,0X8E,0XF7,0X12,0XF7,0X76,

120320XFF,0XDA,0XFF,0XDD,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120450XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XBE,0XFF,0XBE,0XFF,0XBC,0XFF,0X78,0XD6,0X2F,

120460XC5,0X88,0XE6,0X29,0XF6,0X88,0XEE,0X46,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

120470XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X48,

120480XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X67,

120490XF6,0X88,0XFE,0X88,0XFE,0X89,0XFE,0XAA,0XFE,0XAA,0XFE,0XAB,0XFE,0XAC,0XF6,0XAC,

120500XF6,0XAC,0XEE,0X8D,0XEE,0XAE,0XF7,0X11,0XFF,0X96,0XFF,0XDA,0XFF,0XFD,0XFF,0XFE,

120510XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

120520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120640XFF,0XDE,0XFF,0XBE,0XFF,0XBD,0XF7,0X38,0XD5,0XEF,0XC5,0X69,0XE6,0X48,0XEE,0X66,

120650XEE,0X46,0XF6,0X66,0XF6,0X47,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

120660XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,

120670XF6,0X48,0XF6,0X48,0XFE,0X48,0XFE,0X68,0XFE,0X88,0XFE,0XA8,0XFE,0XA9,0XFE,0XA9,

120680XFE,0XAA,0XFE,0X8A,0XFE,0XAB,0XFE,0XAC,0XFE,0XAC,0XF6,0X8C,0XEE,0X8D,0XEE,0XAF,

120690XF7,0X32,0XFF,0XB6,0XFF,0XFA,0XFF,0XDC,0XFF,0XDD,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

120700XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFC,

120830XF7,0X17,0XCD,0XCF,0XCD,0X6A,0XE6,0X09,0XF6,0X88,0XEE,0X24,0XF6,0X45,0XFE,0X46,

120840XF6,0X47,0XF6,0X48,0XFE,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

120850XF6,0X87,0XF6,0X86,0XF6,0X86,0XF6,0X86,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,

120860XFE,0X68,0XFE,0X88,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XAB,

120870XFE,0XCC,0XFE,0X8B,0XF6,0X8C,0XF6,0XAE,0XEE,0XD0,0XF7,0X33,0XFF,0XB8,0XFF,0XFB,

120880XFF,0XFC,0XFF,0XDD,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120890XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121010XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XFD,0XFF,0XDA,0XE6,0XD4,0XC5,0XAE,0XCD,0X6A,

121020XEE,0X4B,0XF6,0X89,0XEE,0X26,0XFE,0X86,0XFE,0X87,0XF6,0X26,0XF6,0X47,0XFE,0X48,

121030XFE,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X87,0XF6,0X67,

121040XF6,0X86,0XF6,0X66,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XFE,0X88,0XFE,0X89,

121050XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAB,0XFE,0XAB,0XFE,0XAC,0XEE,0X6C,

121060XEE,0XAE,0XF7,0X12,0XFF,0X75,0XFF,0XD9,0XFF,0XFC,0XFF,0XFD,0XFF,0XDD,0XFF,0XFF,

121070XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

121080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,

121200XFF,0XFB,0XFF,0XD8,0XE6,0XD2,0XBD,0X8B,0XCD,0XA9,0XF6,0XAB,0XF6,0X89,0XEE,0X47,

121210XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X47,0XFE,0X47,0XFE,0X67,0XFE,0X67,0XFE,0X67,

121220XFE,0X67,0XFE,0X67,0XFE,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X66,0XF6,0X66,

121230XF6,0X66,0XF6,0X67,0XFE,0X87,0XFE,0X67,0XFE,0XA9,0XFE,0XA9,0XFE,0XC9,0XFE,0XAA,

121240XFE,0XAA,0XFE,0XCA,0XFE,0XCB,0XFE,0XCC,0XF6,0XAD,0XF6,0XCF,0XF7,0X13,0XFF,0X97,

121250XFF,0XDA,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121380XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFD,0XFF,0XDB,0XF7,0X76,0XD6,0X4F,

121390XCD,0XCA,0XDE,0X4A,0XEE,0XA9,0XEE,0X67,0XF6,0X67,0XFE,0X88,0XF6,0X47,0XFE,0X68,

121400XF6,0X47,0XFE,0X47,0XFE,0X67,0XFE,0X66,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

121410XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X87,

121420XFE,0X88,0XFE,0XA8,0XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAB,

121430XF6,0X8C,0XEE,0X8D,0XEE,0XD0,0XFF,0X54,0XFF,0XB8,0XFF,0XDB,0XFF,0XFE,0XFF,0XFE,

121440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121550XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

121560XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,

121570XFF,0XFD,0XFF,0XDB,0XFF,0X79,0XEE,0XF4,0XD6,0X0D,0XD5,0XC9,0XDE,0X08,0XEE,0X88,

121580XEE,0X66,0XF6,0X66,0XF6,0X86,0XFE,0X87,0XF6,0X67,0XFE,0X67,0XF6,0X67,0XFE,0X67,

121590XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X66,0XF6,0X66,

121600XF6,0X66,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X69,0XFE,0X89,0XFE,0XA9,

121610XFE,0XC9,0XFE,0XC9,0XFE,0XAA,0XF6,0XAB,0XF6,0XAC,0XEE,0X8D,0XEE,0X8F,0XF6,0XD2,

121620XFF,0X56,0XFF,0X99,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

121750XF7,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XFB,0XFF,0X99,0XF7,0X35,

121760XDE,0X50,0XCD,0X8B,0XCD,0X89,0XEE,0X69,0XFE,0XA9,0XEE,0X46,0XF6,0X86,0XFE,0X86,

121770XFE,0X86,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

121780XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X66,0XF6,0X66,0XFE,0X86,0XFE,0X87,

121790XFE,0X67,0XFE,0X68,0XFE,0X69,0XFE,0X8A,0XFE,0X8A,0XFE,0X8A,0XFE,0XAA,0XFE,0XCA,

121800XF6,0XAB,0XF6,0XAD,0XEE,0XAF,0XF6,0XD1,0XFF,0X35,0XFF,0X98,0XFF,0XBA,0XFF,0XDC,

121810XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

121930XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

121940XFF,0XFE,0XFF,0XDC,0XFF,0XDA,0XFF,0X77,0XE6,0X91,0XD5,0XEC,0XD5,0XCA,0XE6,0X0A,

121950XF6,0X4B,0XF6,0X49,0XF6,0X48,0XFE,0X47,0XFE,0X46,0XFE,0X66,0XFE,0X67,0XFE,0X67,

121960XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X87,0XF6,0X87,0XF6,0X88,0XF6,0X68,

121970XF6,0X68,0XF6,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X89,

121980XFE,0X89,0XFE,0XA9,0XFE,0X89,0XFE,0XAA,0XF6,0X8A,0XF6,0X8C,0XEE,0XAE,0XF6,0XF0,

121990XF7,0X34,0XFF,0X98,0XFF,0XBB,0XFF,0XFD,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

122000XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

122120XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDD,0XFF,0XBC,0XFF,0X9A,0XFF,0XB8,

122130XEE,0XD3,0XD5,0XEE,0XDE,0X0B,0XE6,0X29,0XF6,0X6A,0XF6,0X49,0XF6,0X49,0XFE,0X29,

122140XFE,0X69,0XFE,0X48,0XFE,0X46,0XFE,0X47,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,

122150XFE,0X68,0XF6,0X68,0XF6,0X87,0XF6,0X87,0XF6,0X88,0XF6,0X88,0XF6,0X68,0XF6,0X68,

122160XFE,0X88,0XFE,0XA8,0XFE,0X88,0XFE,0XA9,0XFE,0XC9,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,

122170XFE,0XAA,0XFE,0XAB,0XEE,0X8D,0XF6,0XD0,0XF7,0X12,0XFF,0X75,0XFF,0XD9,0XFF,0XFC,

122180XFF,0XFD,0XFF,0XDE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

122190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDE,

122310XFF,0XFE,0XFF,0XBB,0XFF,0XDA,0XFF,0X97,0XF7,0X14,0XD5,0XED,0XD5,0XCB,0XDE,0X0A,

122320XEE,0X49,0XF6,0X67,0XFE,0X88,0XFE,0X88,0XFE,0X8A,0XFE,0X49,0XFE,0X49,0XFE,0X48,

122330XFE,0X67,0XFE,0X67,0XFE,0X48,0XFE,0X48,0XFE,0X48,0XFE,0X68,0XFE,0X68,0XFE,0X88,

122340XF6,0X68,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XFE,0XA8,0XFE,0XA9,

122350XFE,0XCA,0XFE,0XAA,0XF6,0XAA,0XF6,0XAB,0XFE,0XCC,0XF6,0XCD,0XEE,0X8C,0XEE,0X6E,

122360XFF,0X34,0XFF,0X77,0XFF,0XB8,0XFF,0XDA,0XFF,0XFB,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

122370XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

122380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122480XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

122490XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XDB,0XFF,0XBA,0XFF,0X98,

122500XEE,0XD3,0XDE,0X2E,0XD5,0XAA,0XDE,0X0A,0XEE,0X4A,0XF6,0X89,0XFE,0X88,0XFE,0X87,

122510XF6,0X66,0XF6,0X46,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,

122520XFE,0X68,0XFE,0X68,0XFE,0X48,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XF6,0X68,0XF6,0X68,

122530XF6,0X68,0XF6,0X88,0XFE,0X88,0XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XCB,0XF6,0XCB,

122540XF6,0XAC,0XEE,0X8C,0XE6,0X6D,0XE6,0X8F,0XF7,0X12,0XFF,0X96,0XFF,0XBA,0XFF,0XDC,

122550XFF,0XFC,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122560XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122670XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,

122680XFF,0XFA,0XFF,0XD8,0XFF,0X97,0XF7,0X75,0XE6,0XB1,0XD6,0X2E,0XD6,0X2B,0XE6,0X2A,

122690XEE,0X89,0XEE,0X48,0XF6,0X47,0XFE,0X47,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X87,

122700XF6,0XA6,0XF6,0X86,0XF6,0X86,0XFE,0XA7,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X87,

122710XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,

122720XFE,0X88,0XFE,0XA9,0XFE,0XAA,0XFE,0XAB,0XF6,0X8B,0XEE,0X8C,0XEE,0XAE,0XF7,0X12,

122730XFF,0X75,0XFF,0XB8,0XFF,0XBA,0XFF,0XDC,0XFF,0XFD,0XFF,0XFE,0XFF,0XDE,0XFF,0XFE,

122740XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

122860XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XDB,0XFF,0XD9,0XFF,0XB7,0XF7,0X75,0XEF,0X12,

122870XE6,0X8F,0XDE,0X2D,0XDE,0X2C,0XDE,0X2A,0XE6,0X29,0XEE,0X68,0XF6,0X87,0XFE,0X87,

122880XFE,0X87,0XFE,0X87,0XFE,0X47,0XFE,0X68,0XF6,0X48,0XF6,0X67,0XF6,0X86,0XF6,0XC6,

122890XF6,0XA6,0XF6,0XA7,0XFE,0XA8,0XFE,0X88,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X87,

122900XF6,0X87,0XFE,0XA8,0XFE,0X89,0XFE,0X89,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XAB,

122910XF6,0X8C,0XF6,0XAE,0XF6,0XD0,0XF7,0X12,0XFF,0X75,0XFF,0XB8,0XFF,0XFA,0XFF,0XDC,

122920XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122930XFF,0XDE,0XFF,0XFF,0XF7,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123040XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XFF,0XDE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFA,0XFF,0XD8,

123050XFF,0X96,0XFF,0X54,0XF6,0XF2,0XEE,0XD0,0XE6,0X8E,0XE6,0X4C,0XE6,0X2A,0XE6,0X29,

123060XEE,0X49,0XF6,0X69,0XF6,0X88,0XF6,0X87,0XFE,0X66,0XFE,0X86,0XFE,0X86,0XFE,0X66,

123070XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0XA8,0XFE,0X88,0XF6,0X88,

123080XFE,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0XA8,0XF6,0XA8,0XF6,0XA9,

123090XF6,0XCA,0XF6,0XAB,0XF6,0X8B,0XEE,0X8C,0XEE,0XAE,0XF6,0XD0,0XFF,0X13,0XFF,0X55,

123100XFF,0X97,0XFF,0XBA,0XFF,0XDB,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

123110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

123230XFF,0XFE,0XFF,0XFC,0XFF,0XB9,0XFF,0X76,0XF7,0X53,0XF7,0X11,0XEE,0XAF,0XE6,0X6D,

123240XE6,0X2B,0XE6,0X0A,0XEE,0X2A,0XEE,0X4A,0XF6,0X69,0XFE,0X68,0XF6,0X68,0XFE,0X67,

123250XFE,0X67,0XFE,0X67,0XFE,0X86,0XFE,0X86,0XFE,0X87,0XFE,0X87,0XFE,0X68,0XF6,0X68,

123260XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XF6,0X69,0XF6,0X69,

123270XF6,0X89,0XF6,0XAA,0XF6,0XAA,0XF6,0XAA,0XF6,0XCB,0XEE,0XCB,0XEE,0XAD,0XEE,0XCF,

123280XF7,0X11,0XFF,0X33,0XFF,0X55,0XFF,0X77,0XFF,0XB9,0XFF,0XDB,0XFF,0XBC,0XFF,0XDD,

123290XFF,0XDE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XDC,0XF7,0X78,

123420XE6,0XF2,0XDE,0X8E,0XE6,0X8C,0XDE,0X4A,0XE6,0X49,0XEE,0X49,0XEE,0X69,0XF6,0X69,

123430XF6,0X69,0XF6,0X68,0XF6,0X48,0XFE,0X47,0XFE,0X68,0XFE,0X68,0XFE,0X87,0XFE,0X88,

123440XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X87,0XFE,0XA7,0XF6,0XA7,0XFE,0XA7,0XFE,0XA8,

123450XFE,0XA8,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0XAA,0XFE,0XAB,0XF6,0XAC,0XF6,0XAD,

123460XEE,0XAE,0XEE,0XCF,0XF7,0X11,0XF7,0X53,0XF7,0X35,0XF7,0X57,0XFF,0X99,0XFF,0XBA,

123470XFF,0XDB,0XFF,0XDC,0XFF,0XDD,0XFF,0XBE,0XFF,0XBE,0XFF,0XBE,0XFF,0XDF,0XFF,0XDF,

123480XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123490XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123600XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDD,0XFF,0X99,0XE6,0XD3,0XD6,0X4D,0XDE,0X4A,

123610XEE,0X89,0XEE,0X88,0XF6,0X68,0XF6,0X67,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X67,

123620XFE,0X67,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,

123630XFE,0X68,0XF6,0X88,0XF6,0X87,0XEE,0X87,0XEE,0X87,0XEE,0X88,0XF6,0X88,0XFE,0X89,

123640XFE,0X8A,0XF6,0X8B,0XFE,0XAD,0XF6,0XCE,0XF6,0XD0,0XF6,0XF2,0XF7,0X14,0XF7,0X35,

123650XF7,0X56,0XF7,0X78,0XFF,0XBB,0XFF,0XBC,0XF7,0X9C,0XF7,0X7C,0XF7,0X7D,0XF7,0X7D,

123660XF7,0X9E,0XF7,0X7E,0XF7,0X9F,0XF7,0X9F,0XF7,0X7E,0XEF,0X7E,0XF7,0X9E,0XF7,0X9E,

123670XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

123680XF7,0XBE,0XFF,0XBE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,

123690XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

123700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

123750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123790XFF,0XFF,0XFF,0XFD,0XFF,0XD9,0XEE,0XD2,0XDE,0X4B,0XEE,0X89,0XEE,0X87,0XF6,0X87,

123800XFE,0XA8,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,

123810XFE,0X87,0XFE,0X87,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X88,0XFE,0X89,0XFE,0XAA,

123820XF6,0XA9,0XF6,0XAA,0XEE,0XAA,0XF6,0XCB,0XF6,0XCC,0XF6,0XED,0XE6,0X8E,0XDE,0X2E,

123830XC5,0XAD,0XBD,0X8E,0XB5,0X4F,0XBD,0X71,0XC5,0XB3,0XCD,0XF5,0XCE,0X16,0XCE,0X37,

123840XCE,0X58,0XCE,0X79,0XD6,0X99,0XD6,0XBA,0XD6,0XDB,0XDE,0XDB,0XDE,0XDB,0XD6,0XBB,

123850XD6,0XBB,0XDE,0XFC,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

123860XE7,0X5C,0XE7,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X7D,

123870XF7,0X7D,0XF7,0X7E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

123880XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

123890XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

123940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XF7,0XDF,0XF7,0XBF,0XF7,0X9C,

123980XFF,0XB9,0XEE,0XD1,0XE6,0X6C,0XFE,0XEB,0XF6,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X68,

123990XFE,0X69,0XFE,0X88,0XFE,0X68,0XF6,0X68,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X89,

124000XF6,0X8A,0XF6,0XAA,0XF6,0XAB,0XF6,0XAB,0XF6,0X8B,0XEE,0X6B,0XEE,0X6C,0XE6,0X6C,

124010XE6,0X4C,0XD5,0XEB,0XBD,0X2A,0X94,0X47,0X6B,0X03,0X4A,0X00,0X31,0X40,0X31,0X81,

124020X39,0XC3,0X4A,0X26,0X52,0X89,0X62,0XCB,0X6B,0X0C,0X6B,0X4D,0X7B,0XCF,0X84,0X0F,

124030X84,0X51,0X8C,0X92,0X94,0XB3,0X9C,0XF4,0XA5,0X55,0XAD,0X76,0XB5,0XB7,0XBD,0XD8,

124040XBD,0XF8,0XBD,0XF8,0XC6,0X38,0XCE,0X59,0XD6,0X9A,0XD6,0XBA,0XD6,0XBA,0XD6,0XBA,

124050XD6,0XDB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,

124060XEF,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

124070XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

124080XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

124090XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124120XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

124160XFF,0XDE,0XF7,0XDE,0XF7,0XBF,0XF7,0XBF,0XF7,0XBF,0XEF,0X5C,0XF7,0X58,0XE6,0XB2,

124170XE6,0X4D,0XF6,0XAC,0XEE,0X4A,0XF6,0X4A,0XF6,0X4B,0XF6,0X6B,0XF6,0X6B,0XF6,0X8B,

124180XF6,0X8B,0XF6,0XAB,0XF6,0XAB,0XF6,0XCC,0XF6,0XAC,0XF6,0XAC,0XEE,0XAD,0XE6,0X6D,

124190XE6,0X4D,0XDE,0X0D,0XCD,0XAB,0XC5,0X4B,0XAC,0X89,0X93,0XE7,0X72,0XE4,0X52,0X21,

124200X41,0XA0,0X39,0X60,0X31,0X60,0X31,0X61,0X39,0X83,0X39,0XA4,0X39,0XA5,0X39,0XA5,

124210X31,0X86,0X31,0X86,0X39,0XC7,0X39,0XE7,0X42,0X28,0X4A,0X48,0X52,0XA9,0X5A,0XEB,

124220X63,0X0C,0X63,0X4D,0X6B,0X8E,0X73,0XAF,0X7B,0XF0,0X84,0X31,0X8C,0X72,0X94,0XB3,

124230X9C,0XD3,0XA5,0X14,0XA5,0X35,0XAD,0X55,0XB5,0XD6,0XBD,0XD7,0XBD,0XF7,0XC6,0X18,

124240XC6,0X38,0XCE,0X59,0XCE,0X79,0XD6,0X9A,0XD6,0X9A,0XD6,0XBA,0XDE,0XDB,0XDE,0XDB,

124250XDE,0XFB,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,

124260XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

124270XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,

124280XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

124290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124310XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

124340XFF,0XDF,0XFF,0XDF,0XFF,0XBF,0XFF,0XBF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

124350XEF,0X9E,0XEF,0X9E,0XEF,0X5E,0XDE,0XDA,0XDE,0XB7,0XD6,0X32,0XD6,0X0E,0XE6,0X4D,

124360XE6,0X0C,0XE6,0X0D,0XE6,0X0C,0XDD,0XEC,0XD5,0XCB,0XD5,0XAB,0XD5,0XAB,0XCD,0XAB,

124370XC5,0X6A,0XBD,0X4A,0XB4,0XE8,0XAC,0XA8,0X9C,0X47,0X8B,0XA6,0X7B,0X24,0X6A,0XC3,

124380X5A,0X21,0X49,0XC0,0X39,0X60,0X39,0X40,0X39,0X40,0X39,0X61,0X41,0XA2,0X41,0XA3,

124390X41,0XC4,0X41,0XE5,0X41,0XE6,0X41,0XE6,0X42,0X07,0X4A,0X28,0X4A,0X48,0X4A,0X49,

124400X4A,0X48,0X4A,0X48,0X4A,0X48,0X4A,0X48,0X52,0X69,0X52,0XAA,0X5A,0XCA,0X5A,0XEB,

124410X63,0X0C,0X63,0X2C,0X6B,0X4D,0X73,0X8E,0X73,0XCF,0X7B,0XF0,0X84,0X31,0X8C,0X72,

124420X94,0X92,0X9C,0XD3,0X9C,0XF4,0XA5,0X14,0XA5,0X34,0XAD,0X75,0XB5,0X96,0XB5,0XB6,

124430XBD,0XD7,0XC5,0XF8,0XC6,0X18,0XCE,0X38,0XCE,0X59,0XD6,0X79,0XD6,0X9A,0XD6,0XBA,

124440XD6,0XBA,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

124450XE7,0X3C,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,

124460XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,

124470XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

124480XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,

124500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124520XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

124530XF7,0X9E,0XF7,0X9E,0XFF,0XDF,0XFF,0XDF,0XF7,0XDE,0XF7,0XBE,0XF7,0XBE,0XEF,0X9E,

124540XE7,0X3D,0XE6,0XFB,0XDE,0X98,0XD6,0X54,0XCD,0XF0,0XC5,0X6D,0XB4,0XEC,0XAC,0XAB,

124550XA4,0X69,0X9C,0X29,0X93,0XC7,0X83,0X66,0X7B,0X25,0X73,0X05,0X6A,0XC4,0X5A,0X83,

124560X52,0X22,0X49,0XE2,0X41,0XA1,0X39,0X81,0X39,0X82,0X39,0X62,0X41,0X82,0X41,0XA3,

124570X41,0XC3,0X41,0XE3,0X41,0XE4,0X4A,0X05,0X4A,0X26,0X52,0X26,0X52,0X47,0X52,0X68,

124580X52,0X68,0X5A,0X89,0X5A,0XAA,0X5A,0XCA,0X5A,0XCA,0X5A,0XEB,0X63,0X0B,0X63,0X2C,

124590X6B,0X2C,0X6B,0X0B,0X6B,0X0B,0X63,0X0B,0X63,0X0B,0X63,0X2B,0X6B,0X4C,0X73,0X8D,

124600X7B,0XCE,0X7B,0XCF,0X7B,0XEF,0X84,0X10,0X84,0X31,0X8C,0X51,0X8C,0X72,0X94,0XB2,

124610X9C,0XD3,0X9C,0XF3,0XA5,0X14,0XA5,0X34,0XAD,0X55,0XAD,0X75,0XB5,0X96,0XB5,0XB6,

124620XBD,0XD7,0XBD,0XF7,0XC6,0X18,0XC6,0X38,0XCE,0X59,0XCE,0X79,0XCE,0X79,0XD6,0X9A,

124630XD6,0XBA,0XD6,0XBA,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,

124640XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,

124650XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

124660XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

124670XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,

124690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

124710XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,

124720XFF,0XDF,0XFF,0XDF,0XFF,0XDE,0XF7,0XDE,0XF7,0XBE,0XF7,0X9E,0XEF,0X3E,0XEF,0X5D,

124730XEF,0X5B,0XEF,0X5A,0XF7,0X58,0XEF,0X17,0XEE,0XD6,0XE6,0X96,0XE6,0X75,0XDE,0X54,

124740XD6,0X34,0XCD,0XF3,0XC5,0XB2,0XC5,0X92,0XBD,0X72,0XB5,0X51,0XA4,0XD0,0X9C,0X8F,

124750X9C,0X8F,0X9C,0XB0,0X9C,0X90,0X94,0X4F,0X8C,0X0E,0X8C,0X2E,0X84,0X0E,0X84,0X0D,

124760X83,0XED,0X7B,0XCD,0X7B,0XCD,0X7B,0XAD,0X7B,0X8D,0X7B,0X8D,0X7B,0XAE,0X7B,0XCE,

124770X7B,0XCE,0X83,0XEE,0X83,0XEE,0X84,0X0F,0X84,0X2F,0X8C,0X2F,0X84,0X0F,0X8C,0X2F,

124780X8C,0X50,0X8C,0X50,0X84,0X2F,0X84,0X0F,0X84,0X0F,0X84,0X2F,0X8C,0X50,0X8C,0X70,

124790X94,0X91,0X94,0XB2,0X94,0XB2,0X94,0XB3,0X9C,0XD4,0XA5,0X14,0XA5,0X35,0XA5,0X55,

124800XAD,0X55,0XB5,0X96,0XB5,0X96,0XB5,0XB6,0XBD,0XD7,0XBD,0XF7,0XBD,0XF7,0XC6,0X18,

124810XC6,0X38,0XC6,0X38,0XCE,0X59,0XCE,0X59,0XCE,0X79,0XD6,0X9A,0XD6,0X9A,0XD6,0XBA,

124820XDE,0XDB,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,

124830XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

124840XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

124850XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

124860XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124870XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,

124900XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XFF,0XDF,0XFF,0XDF,

124910XFF,0XDE,0XFF,0XDE,0XFF,0XBE,0XF7,0XBF,0XF7,0X9F,0XF7,0X9F,0XF7,0X9D,0XFF,0XBC,

124920XFF,0XDC,0XFF,0XFC,0XFF,0XFD,0XFF,0XFD,0XFF,0XBD,0XFF,0XBD,0XFF,0XBD,0XFF,0X9C,

124930XFF,0X7C,0XF7,0X7C,0XF7,0X7B,0XF7,0X5B,0XEF,0X5B,0XEF,0X3B,0XEF,0X1A,0XE6,0XD9,

124940XE6,0XD9,0XE6,0XFA,0XDE,0XD9,0XD6,0X99,0XD6,0X99,0XD6,0X99,0XCE,0X79,0XCE,0X78,

124950XCE,0X58,0XC6,0X58,0XC6,0X58,0XC6,0X38,0XC6,0X38,0XC6,0X17,0XBD,0XF6,0XBD,0XF6,

124960XBD,0XD5,0XBD,0XD5,0XBD,0XB4,0XBD,0XD4,0XC6,0X16,0XBD,0XF5,0XBD,0XD5,0XBD,0XF5,

124970XBD,0XF6,0XBD,0XD5,0XB5,0XB5,0XAD,0X74,0XAD,0X74,0XAD,0X74,0XAD,0X75,0XB5,0X95,

124980XB5,0X96,0XB5,0XB6,0XB5,0XB7,0XB5,0XB7,0XBD,0XD7,0XBD,0XD7,0XBD,0XD7,0XBD,0XF7,

124990XBD,0XF7,0XBD,0XF7,0XC6,0X18,0XC6,0X38,0XCE,0X59,0XCE,0X59,0XCE,0X79,0XCE,0X79,

125000XCE,0X79,0XD6,0X9A,0XD6,0X9A,0XD6,0XBA,0XD6,0XBA,0XDE,0XDB,0XDE,0XDB,0XDE,0XFB,

125010XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

125020XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,

125030XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

125040XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

125050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125060XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,

125090XF7,0XBE,0XF7,0X9E,0XF7,0XBE,0XF7,0X9E,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDE,

125100XFF,0XDF,0XFF,0XDF,0XFF,0XBF,0XFF,0XBF,0XFF,0XDE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,

125110XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

125120XFF,0XDE,0XFF,0XDE,0XFF,0XFE,0XFF,0XDD,0XFF,0XBD,0XFF,0XBD,0XFF,0XDD,0XFF,0XBD,

125130XFF,0XBD,0XF7,0X9D,0XF7,0X9D,0XF7,0X9E,0XEF,0X7D,0XEF,0X7D,0XEF,0X7C,0XE7,0X7C,

125140XEF,0X5C,0XEF,0X5C,0XE7,0X5B,0XE7,0X3B,0XE7,0X3B,0XE7,0X3A,0XEF,0X3B,0XEF,0X3A,

125150XEF,0X3A,0XEF,0X3B,0XE7,0X3A,0XE7,0X3A,0XDF,0X1A,0XDF,0X1A,0XDF,0X1A,0XDE,0XFA,

125160XDE,0XFA,0XDE,0XFA,0XD6,0XD9,0XD6,0X99,0XCE,0X79,0XCE,0X79,0XCE,0X79,0XCE,0X7A,

125170XCE,0X7A,0XCE,0X7A,0XCE,0X79,0XCE,0X79,0XD6,0X9A,0XD6,0X9A,0XD6,0X9A,0XD6,0X9A,

125180XD6,0XBA,0XD6,0XBA,0XD6,0XBA,0XD6,0XBA,0XDE,0XDB,0XDE,0XDB,0XDE,0XDB,0XDE,0XFB,

125190XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

125200XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,

125210XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,

125220XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,

125230XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

125240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

125250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125270XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

125280XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

125290XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

125310XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,

125320XFF,0XDE,0XFF,0XDF,0XFF,0XDE,0XFF,0XDE,0XFF,0XDD,0XF7,0XDD,0XFF,0XDC,0XFF,0XBC,

125330XFF,0XDC,0XFF,0XBC,0XFF,0XBC,0XFF,0XBC,0XFF,0X9C,0XFF,0X9C,0XF7,0X7C,0XF7,0X7D,

125340XF7,0X9D,0XF7,0X9D,0XF7,0XBD,0XF7,0XBE,0XF7,0XBD,0XEF,0XBD,0XEF,0X9D,0XEF,0XBD,

125350XF7,0XBD,0XEF,0X9D,0XEF,0X5C,0XE7,0X3C,0XDE,0XFB,0XDE,0XDB,0XE6,0XFB,0XE7,0X1C,

125360XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,

125370XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

125380XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

125390XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

125400XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

125410XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

125420XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

125430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

125440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

125460XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XDE,0XF7,0XBE,

125470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

125500XFF,0XFE,0XFF,0XDE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,

125510XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XDD,0XFF,0XDD,

125520XFF,0XDD,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,

125530XFF,0XDE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,

125540XFF,0XDF,0XF7,0XBE,0XF7,0X9E,0XEF,0X7D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,

125550XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,

125560XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

125570XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

125580XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

125590XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

125600XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

125610XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

125620XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

125650XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

125660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

125690XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,

125700XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

125710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,

125720XFF,0XDE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125730XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

125740XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

125750XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

125760XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

125770XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,

125780XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

125790XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125800XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

125810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

125840XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125880XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

125890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

125910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125920XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,

125930XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

125940XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

125950XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

125960XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

125970XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0X9E,

125990XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XF7,0XBE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

126000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126050XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126110XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,

126120XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

126130XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

126140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0X9E,

126180XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

126240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

126310XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126360XFF,0XFF,0XFF,0XFF,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,

126370XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126550XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

126560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0X9E,0XF7,0XBE,

126740XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,

126750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

126930XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127110XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

127120XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127300XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,

127310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127450XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

127460XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

127470XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

127480XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

127490XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

127500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127750XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,};

12789

12790const unsigned char gimage_0[51000] = { /* 0X10,0X10,0X00,0X96,0X00,0XAA,0X01,0X1B, */

127910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128570XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128800XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

128990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

129310XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

129320XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129480XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129490XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,0XFF,0XFB,

129500XFF,0XFB,0XFF,0XFB,0XFF,0XFB,0XFF,0XFB,0XFF,0XFB,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,

129510XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

129530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

129670XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFC,0XFF,0XFB,

129680XFF,0XFB,0XFF,0XFA,0XFF,0XFA,0XFF,0XF9,0XFF,0XF8,0XFF,0XF8,0XFF,0XF8,0XFF,0XF8,

129690XFF,0XF8,0XFF,0XF8,0XFF,0XF8,0XFF,0XF9,0XFF,0XF8,0XFF,0XF9,0XFF,0XFA,0XFF,0XFB,

129700XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129710XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

129720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

129860XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFA,0XFF,0XF9,0XFF,0XF8,0XFF,0XF7,0XFF,0XF7,

129870XFF,0XF6,0XFF,0XF5,0XFF,0XF5,0XFF,0XF4,0XFF,0XF4,0XFF,0XF4,0XFF,0XF4,0XFF,0XF4,

129880XFF,0XF5,0XFF,0XF5,0XFF,0XD5,0XFF,0XF5,0XFF,0XF6,0XFF,0XF7,0XFF,0XF8,0XFF,0XF9,

129890XFF,0XFB,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129900XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

129910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0XFA,

130050XFF,0XF8,0XFF,0XF7,0XFF,0XF6,0XFF,0XF5,0XFF,0XF4,0XFF,0XF4,0XFF,0XF3,0XFF,0XF3,

130060XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,

130070XFF,0XF3,0XFF,0XF3,0XFF,0XF3,0XFF,0XF3,0XFF,0XF4,0XFF,0XF5,0XFF,0XF7,0XFF,0XF9,

130080XFF,0XFA,0XFF,0XFB,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

130090XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130230XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0XF9,0XFF,0XF6,0XFF,0XF5,0XFF,0XF3,

130240XFF,0XD2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,

130250XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,

130260XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF3,0XFF,0XF4,0XFF,0XF6,0XFF,0XF8,

130270XFF,0XF9,0XFF,0XFB,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,

130420XFF,0XF9,0XFF,0XF7,0XFF,0XF5,0XFF,0XF3,0XFF,0XF2,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,

130430XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

130440XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

130450XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF1,0XFF,0XF3,0XFF,0XF4,0XFF,0XF6,0XFF,0XD8,

130460XFF,0XDA,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130600XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0XF9,0XFF,0XF7,0XFF,0XF5,0XFF,0XF3,

130610XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XEF,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

130620XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

130630XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

130640XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF3,0XFF,0XF4,0XFF,0XF6,0XFF,0XF8,

130650XFF,0XFA,0XFF,0XFC,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130780XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,

130790XFF,0XFB,0XFF,0XF8,0XFF,0XF6,0XFF,0XF3,0XFF,0XD1,0XFF,0XD0,0XFF,0XEF,0XFF,0XEF,

130800XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XCF,0XFF,0XCF,0XFF,0XCF,

130810XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

130820XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XCF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

130830XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF1,0XFF,0XF3,0XFF,0XF5,0XFF,0XD7,0XFF,0XD9,

130840XFF,0XFB,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

130970XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFA,0XFF,0XD7,0XFF,0XF5,

130980XFF,0XF3,0XFF,0XD0,0XFF,0XCF,0XFF,0XCE,0XFF,0XCD,0XFF,0XED,0XFF,0XEE,0XFF,0XCE,

130990XFF,0XCE,0XFF,0XAE,0XFF,0X8D,0XFF,0X6C,0XFF,0X4D,0XF7,0X0C,0XF7,0X0C,0XFF,0X6E,

131000XFF,0XAE,0XFF,0XCF,0XFF,0XF0,0XFF,0XF1,0XF7,0XD0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,

131010XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

131020XFF,0XEE,0XFF,0XEF,0XFF,0XF0,0XFF,0XF1,0XFF,0XF3,0XFF,0XD5,0XFF,0XD8,0XFF,0XFA,

131030XFF,0XDC,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131040XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,

131160XFF,0XFC,0XFF,0XFB,0XFF,0XD9,0XFF,0XD6,0XFF,0XF4,0XFF,0XF2,0XFF,0XF0,0XFF,0XEF,

131170XFF,0XEF,0XFF,0XEF,0XFF,0XCD,0XFF,0XEE,0XFF,0XAE,0XFF,0XAD,0XFF,0X4C,0XF7,0X0B,

131180XF6,0XC9,0XEE,0XA9,0XE6,0X48,0XDE,0X07,0XDE,0X07,0XDE,0X28,0XE6,0X69,0XF7,0X2C,

131190XFF,0XAF,0XFF,0XD0,0XFF,0XD0,0XFF,0XF0,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

131200XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

131210XFF,0XEE,0XFF,0XEF,0XFF,0XF1,0XFF,0XF3,0XFF,0XD5,0XFF,0XD7,0XFF,0XF9,0XFF,0XFB,

131220XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

131230XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFB,0XFF,0XF9,0XFF,0XF7,

131350XFF,0XF3,0XFF,0XF1,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,

131360XFF,0XAF,0XFF,0XAF,0XFF,0X6D,0XF7,0X2B,0XEE,0XA9,0XE6,0X68,0XE6,0X26,0XDD,0XE5,

131370XD5,0X83,0XD5,0X63,0XCD,0X43,0XC5,0X03,0XBC,0XE3,0XC5,0X65,0XEE,0XCB,0XFF,0XAF,

131380XFF,0XF0,0XFF,0XCF,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

131390XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

131400XFF,0XF0,0XFF,0XF1,0XFF,0XD3,0XFF,0XD4,0XFF,0XF6,0XFF,0XF8,0XFF,0XFB,0XFF,0XFD,

131410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131530XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XF9,0XFF,0XF6,0XFF,0XF3,0XFF,0XF0,0XFF,0XEF,

131540XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XCF,0XFF,0XCF,0XFF,0X8F,0XFF,0X2D,

131550XF6,0XEB,0XEE,0X68,0XEE,0X68,0XE6,0X27,0XDE,0X04,0XDD,0XC3,0XDD,0X81,0XDD,0X82,

131560XD5,0X42,0XC4,0XE1,0XAC,0X20,0X93,0X80,0XCD,0X87,0XFF,0X6E,0XFF,0XAF,0XFF,0X8D,

131570XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,

131580XFF,0XEF,0XFF,0XF0,0XFF,0XEF,0XFF,0XCF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,

131590XFF,0XD1,0XFF,0XF2,0XFF,0XF3,0XFF,0XF5,0XFF,0XF8,0XFF,0XFB,0XFF,0XFE,0XFF,0XFF,

131600XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,

131720XFF,0XF9,0XFF,0XF6,0XF7,0XD3,0XF7,0XD0,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

131730XFF,0XEE,0XFF,0XEE,0XFF,0XCE,0XFF,0XCE,0XFF,0X4D,0XF6,0XCA,0XEE,0X48,0XE6,0X06,

131740XF6,0X67,0XF6,0X87,0XEE,0X45,0XE5,0XE3,0XE5,0XE1,0XE5,0XE1,0XE5,0X81,0XDD,0X41,

131750XCC,0XE1,0X93,0X40,0X9B,0XC0,0XE6,0X2A,0XFF,0XD0,0XFF,0XAE,0XFF,0XEE,0XF7,0X8C,

131760XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XCF,

131770XFF,0XEF,0XFF,0XEF,0XFF,0XCF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,

131780XFF,0XF0,0XFF,0XF2,0XFF,0XF5,0XFF,0XF9,0XFF,0XFD,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

131790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

131900XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFA,0XFF,0XF6,0XFF,0XF3,

131910XF7,0XD1,0XF7,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XCE,

131920XFF,0XEE,0XFF,0XAD,0XF6,0XCA,0XEE,0X68,0XDD,0XA5,0XED,0XE5,0XF6,0X46,0XFE,0XA7,

131930XFE,0XA6,0XF6,0X44,0XEE,0X22,0XED,0XE1,0XE5,0XC0,0XE5,0XA1,0XDD,0X42,0XC4,0X81,

131940X9B,0X80,0XC5,0X05,0XFF,0X6E,0XFF,0X8E,0XFF,0XCE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

131950XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,

131960XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEF,

131970XFF,0XD2,0XFF,0XD6,0XFF,0XDA,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132080XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132090XFF,0XFD,0XFF,0XFB,0XFF,0XF9,0XFF,0XF6,0XFF,0XF3,0XFF,0XF1,0XFF,0XF0,0XFF,0XEF,

132100XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XCE,0XFF,0XCE,0XF7,0X2B,

132110XE6,0X67,0XDD,0XA3,0XDD,0X62,0XED,0XC3,0XF6,0X45,0XFE,0X86,0XFE,0XA7,0XFE,0X86,

132120XF6,0X44,0XF6,0X23,0XF6,0X01,0XED,0XE1,0XED,0XC2,0XE5,0X83,0XBC,0X61,0XB4,0X82,

132130XEE,0XAB,0XFF,0XAE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

132140XFF,0XEE,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

132150XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XD1,0XF7,0XB3,

132160XF7,0XB7,0XFF,0XFA,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

132270XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XF9,

132280XFF,0XF5,0XF7,0XD2,0XF7,0XD1,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XCE,

132290XFF,0XCE,0XFF,0XEF,0XFF,0XCF,0XFF,0XEF,0XFF,0XAE,0XE6,0X89,0XDE,0X05,0XC4,0XC0,

132300XDD,0X61,0XED,0XA2,0XFE,0X44,0XFE,0X65,0XFE,0XA8,0XFE,0XA8,0XFE,0X67,0XF6,0X45,

132310XF6,0X43,0XF6,0X02,0XED,0XE2,0XE5,0XC2,0XDD,0X83,0XB4,0XA1,0XD5,0XE7,0XFF,0XCE,

132320XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,

132330XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,

132340XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XF7,0XB1,0XF7,0XB4,0XFF,0XD7,

132350XFF,0XFB,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

132460XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XF9,0XFF,0XF6,0XFF,0XF2,0XFF,0XF0,

132470XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XF7,0XCD,0XFF,0XEE,0XFF,0XEE,

132480XFF,0XCF,0XFF,0XCF,0XFF,0X6D,0XCD,0XA6,0XC4,0XE2,0XCC,0XE1,0XE5,0X41,0XED,0XA1,

132490XED,0XC1,0XF6,0X44,0XFE,0XA8,0XFE,0X89,0XFE,0X69,0XFE,0X68,0XFE,0X66,0XF6,0X44,

132500XEE,0X02,0XE5,0XE1,0XE6,0X23,0XCD,0X61,0XCD,0XC4,0XF7,0X4C,0XFF,0XEF,0XFF,0XEF,

132510XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

132520XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,

132530XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XD2,0XEF,0X73,0XFF,0XF8,0XFF,0XFB,

132540XFF,0XFD,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

132650XFF,0XFD,0XFF,0XFA,0XFF,0XF7,0XFF,0XF3,0XFF,0XF0,0XFF,0XEE,0XFF,0XED,0XFF,0XED,

132660XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XCC,0XFF,0XED,0XFF,0XEE,0XFF,0XCF,0XFF,0XAF,

132670XE6,0X8A,0XBD,0X03,0XBC,0XA1,0XD5,0X22,0XDD,0X01,0XE5,0X61,0XED,0XA0,0XEE,0X02,

132680XFE,0X67,0XFE,0X69,0XFE,0X8A,0XFE,0X8A,0XFE,0X67,0XFE,0X65,0XFE,0X84,0XEE,0X22,

132690XEE,0X23,0XDD,0XC2,0XCD,0XA3,0XEF,0X0A,0XFF,0XAE,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,

132700XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

132710XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XCE,0XFF,0XCE,

132720XFF,0XEE,0XFF,0XEE,0XF7,0XCF,0XF7,0XB1,0XF7,0XB5,0XFF,0XD9,0XFF,0XFD,0XFF,0XFE,

132730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFB,0XFF,0XD8,

132840XFF,0XD4,0XFF,0XD1,0XFF,0XEF,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XEE,

132850XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCD,0XFF,0XEF,0XFF,0X6D,0XCD,0XA6,0X9B,0XE0,

132860XC4,0XE2,0XCC,0XE2,0XDD,0X01,0XDD,0X20,0XED,0XC1,0XED,0XE1,0XF6,0X25,0XFE,0X47,

132870XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0XA8,0XFE,0X65,0XFE,0XA6,0XFE,0XA5,0XE6,0X24,

132880XC5,0X62,0XEE,0XE9,0XFF,0XAE,0XFF,0XAE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

132890XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

132900XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XCE,0XFF,0XAE,0XFF,0XEE,0XFF,0XCD,

132910XF7,0XCD,0XFF,0XD0,0XF7,0X73,0XF7,0X97,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

132920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133020XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFC,0XFF,0XF8,0XFF,0XD5,0XFF,0XD2,0XFF,0XCF,

133030XFF,0XCE,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

133040XFF,0XED,0XFF,0XCD,0XFF,0XCE,0XFF,0X2C,0XA4,0X61,0XA4,0X00,0XBC,0X81,0XD5,0X02,

133050XCC,0XC1,0XD5,0X21,0XE5,0X81,0XE5,0XA1,0XEE,0X04,0XF6,0X46,0XFE,0X89,0XFE,0X89,

133060XFE,0X88,0XFE,0X88,0XFE,0XA8,0XFE,0X87,0XF6,0X86,0XF6,0XA7,0XD5,0XA4,0XDE,0X47,

133070XFF,0X4C,0XFF,0XCE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

133080XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEC,

133090XFF,0XEC,0XFF,0XEC,0XFF,0XCE,0XFF,0XAE,0XFF,0XCD,0XFF,0XCD,0XFF,0XCC,0XFF,0XEF,

133100XF7,0X71,0XEF,0X54,0XFF,0XFA,0XFF,0XFC,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

133110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,

133210XFF,0XFD,0XFF,0XF9,0XFF,0XD5,0XFF,0XD2,0XFF,0XCF,0XFF,0XCE,0XFF,0XCE,0XFF,0XCD,

133220XFF,0XCD,0XFF,0XCC,0XFF,0XEC,0XFF,0XED,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

133230XFF,0XAE,0XE6,0X8A,0X93,0XA0,0XAC,0X21,0XBC,0XA2,0XBC,0X81,0XC4,0X80,0XC4,0XA0,

133240XCD,0X21,0XD5,0X41,0XE5,0XE3,0XF6,0X25,0XFE,0X87,0XFE,0XA8,0XFE,0X88,0XFE,0X88,

133250XFE,0X89,0XFE,0XA9,0XFE,0XA9,0XF6,0X89,0XD5,0XC6,0XD6,0X07,0XFF,0X6C,0XFF,0XAD,

133260XFF,0XCD,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEC,

133270XFF,0XEC,0XFF,0XEC,0XFF,0XCD,0XFF,0XED,0XFF,0XCD,0XFF,0XED,0XFF,0XCD,0XFF,0XCD,

133280XFF,0XCD,0XFF,0XCD,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCE,0XF7,0X70,0XEF,0X32,

133290XF7,0X76,0XFF,0XFB,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFB,0XFF,0XF7,

133400XFF,0XD2,0XFF,0XCF,0XFF,0XCE,0XFF,0XCD,0XFF,0XAE,0XFF,0XAE,0XFF,0XAD,0XFF,0XCD,

133410XFF,0XCC,0XFF,0XEC,0XFF,0XCC,0XFF,0XCD,0XFF,0XAD,0XFF,0XCE,0XFF,0X8E,0XD5,0XC7,

133420X83,0X20,0XB4,0X62,0XB4,0X61,0XB4,0X40,0XB4,0X20,0XB4,0X20,0XBC,0XA1,0XC4,0XE1,

133430XD5,0X63,0XE5,0XE4,0XF6,0X67,0XFE,0X88,0XFE,0X89,0XFE,0X89,0XFE,0XAA,0XFE,0X8A,

133440XFE,0XAB,0XF6,0X8A,0XE6,0X28,0XCD,0XC6,0XF7,0X4C,0XFF,0XAD,0XFF,0XCC,0XFF,0XCD,

133450XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,

133460XFF,0XCC,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XAD,0XFF,0XCD,

133470XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAD,0XFF,0X8F,0XEF,0X30,0XE6,0XF3,0XFF,0X98,

133480XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133580XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XF8,0XFF,0XD4,0XF7,0XAF,0XFF,0XCE,

133590XFF,0XCD,0XFF,0XAD,0XFF,0X8E,0XFF,0X8E,0XFF,0XAE,0XFF,0XAD,0XFF,0XAD,0XFF,0XCC,

133600XF7,0XAC,0XFF,0XCD,0XFF,0XAD,0XFF,0XAE,0XFF,0X6E,0XBD,0X05,0X8B,0X40,0XB4,0X42,

133610XAC,0X02,0XA3,0XC1,0XA3,0XA0,0X9B,0XA0,0X9B,0XE0,0XA4,0X00,0XBC,0XA2,0XCD,0X44,

133620XE6,0X07,0XF6,0X68,0XF6,0X69,0XF6,0X69,0XFE,0XAA,0XF6,0X89,0XFE,0XCB,0XF6,0XAB,

133630XEE,0X8A,0XCD,0XA6,0XEF,0X0B,0XFF,0XAC,0XFF,0XAC,0XFF,0XCC,0XFF,0XAD,0XFF,0XAD,

133640XFF,0XAD,0XFF,0XAD,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAD,

133650XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAB,0XFF,0X8B,

133660XFF,0X8C,0XFF,0X8D,0XFF,0X8E,0XF7,0X50,0XDE,0XB0,0XEE,0XF4,0XFF,0XDB,0XFF,0XFD,

133670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133770XFF,0XFD,0XFF,0XFA,0XFF,0XD5,0XF7,0XB1,0XF7,0XAE,0XFF,0XAC,0XFF,0XCC,0XFF,0XAC,

133780XFF,0X8D,0XFF,0X8E,0XFF,0X8E,0XFF,0X8D,0XFF,0XAC,0XFF,0XCC,0XFF,0XAC,0XFF,0XCD,

133790XFF,0X8D,0XFF,0XAF,0XFF,0X2D,0XB4,0X83,0X93,0X80,0XAC,0X01,0XAB,0XE2,0X9B,0X60,

133800X93,0X60,0X93,0X40,0X8B,0X40,0X8B,0X40,0X9B,0XC1,0XB4,0X83,0XD5,0X66,0XEE,0X08,

133810XF6,0X69,0XFE,0XA9,0XFE,0XAA,0XF6,0X8A,0XF6,0XCC,0XEE,0X6B,0XE6,0X8C,0XC5,0X87,

133820XEE,0XEB,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0X8D,0XFF,0X8D,

133830XFF,0XAC,0XFF,0X8C,0XFF,0XAC,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8D,0XFF,0X8D,

133840XFF,0X8C,0XFF,0XAC,0XFF,0XAC,0XFF,0X8B,0XFF,0X8B,0XFF,0X6B,0XFF,0X8C,0XFF,0X6D,

133850XFF,0X8D,0XFF,0X6F,0XE6,0XCF,0XD6,0X70,0XFF,0XB8,0XFF,0XBB,0XFF,0XFE,0XFF,0XFF,

133860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFB,0XFF,0XD7,

133960XF7,0X93,0XF7,0X8F,0XFF,0X8D,0XFF,0XAB,0XFF,0XAB,0XFF,0XAC,0XFF,0X8D,0XFF,0X6D,

133970XFF,0X8C,0XFF,0X8C,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XCD,0XFF,0X8D,0XFF,0X8E,

133980XF7,0X0C,0XA4,0X21,0X9B,0XE0,0XA4,0X01,0X93,0X80,0X93,0X41,0X8B,0X01,0X82,0XC1,

133990X7A,0XA0,0X7A,0XA0,0X7A,0XE1,0X93,0X83,0XAC,0X24,0XCD,0X26,0XEE,0X08,0XEE,0X48,

134000XF6,0X8A,0XF6,0XAB,0XEE,0XAC,0XEE,0XCD,0XF7,0X0F,0XCD,0XCA,0XEE,0XCB,0XFF,0X6C,

134010XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,

134020XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,

134030XFF,0X8C,0XFF,0X8B,0XFF,0X6B,0XFF,0X6B,0XFF,0X6B,0XFF,0X6B,0XFF,0X8C,0XFF,0X6D,

134040XF7,0X2E,0XD6,0X2D,0XE6,0X92,0XFF,0XDA,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XF9,0XFF,0X95,0XF7,0X51,0XFF,0X6E,

134150XFF,0X6C,0XFF,0X8B,0XFF,0X8B,0XFF,0X8B,0XFF,0X6C,0XFF,0X6C,0XFF,0X8C,0XFF,0X8C,

134160XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8D,0XFF,0X6D,0XFF,0X6D,0XF6,0XEB,0X9C,0X20,

134170X9C,0X00,0X9B,0XE1,0X93,0X60,0X83,0X00,0X82,0XC1,0X72,0X81,0X6A,0X61,0X62,0X20,

134180X62,0X41,0X72,0XC2,0X8B,0X63,0XAC,0X65,0XCD,0X47,0XE6,0X2A,0XEE,0X8C,0XE6,0X4C,

134190XEE,0XCE,0XFF,0X72,0XFF,0X94,0XDE,0X4E,0XEE,0XAC,0XFF,0X4D,0XFF,0X6C,0XFF,0X6C,

134200XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,

134210XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6B,0XFF,0X6B,

134220XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X6B,0XFF,0X6C,0XF7,0X6C,0XF7,0X2D,0XE6,0X8C,

134230XC5,0X8C,0XFF,0X97,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,

134330XFF,0XFF,0XFF,0XFC,0XFF,0XB6,0XFF,0X72,0XF7,0X4F,0XFF,0X4D,0XFF,0X6C,0XFF,0X8C,

134340XFF,0X6B,0XFF,0X6B,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X8C,0XFF,0X6B,0XFF,0X6B,

134350XFF,0X6C,0XFF,0X6C,0XFF,0X6D,0XFF,0X6D,0XEE,0XAA,0X9C,0X00,0X9C,0X01,0X9B,0XC1,

134360X8B,0X40,0X83,0X00,0X7A,0XA0,0X6A,0X60,0X5A,0X21,0X51,0XC1,0X49,0XE1,0X5A,0X21,

134370X6A,0XA2,0X83,0X63,0XA4,0X45,0XCD,0X89,0XDE,0X2D,0XDE,0X6F,0XF7,0X34,0XFF,0XF7,

134380XFF,0XD8,0XDE,0X91,0XDE,0X6D,0XFF,0X2D,0XFF,0X4C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,

134390XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X4C,0XFF,0X6C,

134400XFF,0X4C,0XFF,0X6C,0XFF,0X4C,0XFF,0X6B,0XFF,0X6B,0XFF,0X6B,0XFF,0X4B,0XFF,0X2B,

134410XFF,0X4B,0XFF,0X4B,0XFF,0X4C,0XFF,0X4C,0XF7,0X2C,0XEE,0XCC,0XCD,0XAB,0XD6,0X10,

134420XFF,0XFB,0XEF,0X5B,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134510XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDB,

134520XF7,0X74,0XF7,0X50,0XF7,0X2E,0XFF,0X4D,0XFF,0X6C,0XFF,0X6C,0XFF,0X6B,0XFF,0X6B,

134530XFF,0X6B,0XFF,0X6B,0XFF,0X4B,0XFF,0X6C,0XFF,0X6B,0XFF,0X4B,0XFF,0X6C,0XFF,0X4C,

134540XFF,0X6D,0XFF,0X4D,0XE6,0X69,0X93,0XE0,0X9C,0X01,0X93,0XA0,0X83,0X60,0X7B,0X00,

134550X72,0XA0,0X6A,0X61,0X52,0X01,0X49,0XC1,0X49,0XE2,0X41,0XC1,0X5A,0X41,0X62,0X81,

134560X83,0X84,0X9C,0X67,0XB5,0X2C,0XE6,0XD4,0XFF,0XB8,0XFF,0XFA,0XFF,0XFA,0XDE,0XB3,

134570XD6,0X2D,0XFF,0X4E,0XFF,0X4C,0XFF,0X4B,0XFF,0X4C,0XFF,0X6C,0XFF,0X4C,0XFF,0X4B,

134580XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,

134590XFF,0X4B,0XFF,0X4B,0XFF,0X4A,0XFF,0X4A,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,

134600XFF,0X2C,0XFF,0X2C,0XFF,0X2C,0XFF,0X2D,0XCD,0XA9,0XBD,0X4A,0XEF,0X16,0XFF,0XFD,

134610XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134700XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0X99,0XF7,0X31,0XF7,0X2E,

134710XFF,0X2D,0XFF,0X2C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,

134720XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X6C,0XFF,0X2C,0XFF,0X4C,0XFF,0X2C,

134730XE6,0X29,0X93,0XE0,0X9C,0X01,0X8B,0XA0,0X83,0X61,0X7B,0X00,0X72,0XC1,0X62,0X61,

134740X5A,0X21,0X49,0XE1,0X41,0XC1,0X41,0XA1,0X49,0XE0,0X52,0X00,0X6A,0XE3,0X73,0X44,

134750XAD,0X0D,0XF7,0X78,0XFF,0XFC,0XFF,0XFC,0XFF,0XDC,0XDE,0XD5,0XCE,0X0D,0XFF,0X4E,

134760XFF,0X4C,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,

134770XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X4B,

134780XFF,0X2A,0XFF,0X2B,0XFF,0X2B,0XFF,0X0C,0XFF,0X0B,0XFF,0X2B,0XFF,0X0B,0XFF,0X2B,

134790XFF,0X2B,0XFF,0X0B,0XDE,0X49,0XB5,0X28,0XC5,0XCF,0XFF,0XBB,0XFF,0XFE,0XFF,0XFF,

134800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFE,

134890XFF,0XFE,0XFF,0XFD,0XFF,0XBB,0XF7,0X56,0XF7,0X0F,0XF7,0X2C,0XFF,0X2C,0XFF,0X2C,

134900XFF,0X2C,0XFF,0X2C,0XFF,0X2B,0XFF,0X4B,0XFF,0X4B,0XFF,0X2B,0XFF,0X2B,0XFF,0X4B,

134910XFF,0X2B,0XFF,0X4B,0XFF,0X4C,0XFF,0X2C,0XFF,0X4C,0XFF,0X2C,0XDE,0X09,0X9C,0X01,

134920X93,0XE1,0X8B,0XA1,0X83,0X61,0X73,0X01,0X72,0XC1,0X62,0X81,0X5A,0X41,0X52,0X22,

134930X41,0XA1,0X41,0XC1,0X41,0XA0,0X49,0XE0,0X52,0X21,0X5A,0X83,0XD6,0X54,0XFF,0XFC,

134940XFF,0XFE,0XFF,0XFE,0XFF,0XDD,0XE6,0XD6,0XCD,0XED,0XF7,0X0D,0XFF,0X2C,0XFF,0X2B,

134950XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,

134960XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2A,0XFF,0X0B,

134970XFF,0X0B,0XFE,0XEB,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X2B,

134980XF6,0XCB,0XCD,0XC9,0X9C,0X89,0XDE,0XB5,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

134990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFC,

135080XFF,0X98,0XF7,0X13,0XF7,0X0E,0XFF,0X0B,0XFF,0X2C,0XFF,0X0B,0XFF,0X0C,0XFF,0X2B,

135090XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,

135100XFF,0X2B,0XFF,0X2B,0XFF,0X0C,0XFF,0X2C,0XDD,0XE8,0X9B,0XE1,0X8B,0XA0,0X8B,0X81,

135110X83,0X41,0X73,0X01,0X72,0XE2,0X6A,0XA2,0X62,0X61,0X5A,0X21,0X41,0XC1,0X4A,0X02,

135120X41,0X80,0X49,0XA1,0X41,0X81,0X6A,0XE7,0XF7,0X5A,0XFF,0XFD,0XFF,0XDE,0XFF,0XFE,

135130XFF,0XDD,0XE6,0XD6,0XD5,0XCD,0XF7,0X0D,0XFF,0X0C,0XFF,0X2B,0XFF,0X0B,0XFF,0X0B,

135140XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,

135150XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0B,0XFF,0X0B,0XFE,0XEB,0XFE,0XEB,

135160XFE,0XEA,0XFE,0XEA,0XFE,0XEB,0XFE,0XEB,0XFF,0X0B,0XFF,0X0B,0XFE,0XEB,0XD5,0XE9,

135170XAC,0XC8,0XC5,0XAF,0XFF,0XB9,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFA,0XFF,0X55,0XEE,0XF0,

135270XF7,0X0D,0XFF,0X0B,0XFF,0X2B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0A,0XFF,0X0A,

135280XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFE,0XEA,0XFF,0X2B,

135290XFE,0XEB,0XFF,0X2C,0XD5,0XA7,0X93,0XC1,0X83,0X60,0X83,0X61,0X7B,0X42,0X73,0X02,

135300X73,0X03,0X6A,0XC2,0X62,0X82,0X5A,0X41,0X4A,0X01,0X4A,0X22,0X41,0XA1,0X41,0X81,

135310X41,0X82,0X94,0X0D,0XFF,0X9D,0XFF,0XFF,0XFF,0XBE,0XFF,0XFF,0XFF,0XFE,0XE6,0XD6,

135320XC5,0X6B,0XF6,0XCD,0XFF,0X0B,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,

135330XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

135340XFE,0XEA,0XFE,0XEA,0XFF,0X0B,0XFE,0XEB,0XFE,0XEA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,

135350XFE,0XCA,0XFE,0XCA,0XFE,0XEA,0XFE,0XCA,0XFE,0XEB,0XDD,0XE9,0XBD,0X49,0XA4,0X89,

135360XDE,0XB4,0XFF,0XFB,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135450XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0X98,0XEF,0X11,0XF6,0XCE,0XFF,0X0C,0XFE,0XEB,

135460XFE,0XEB,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0A,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,

135470XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0C,0XFE,0XEC,

135480XCD,0X67,0X8B,0X60,0X7B,0X20,0X83,0X42,0X83,0X63,0X7B,0X23,0X7B,0X24,0X73,0X03,

135490X6A,0XC3,0X62,0X83,0X5A,0X83,0X4A,0X01,0X4A,0X02,0X41,0X81,0X41,0XC3,0XC5,0XD5,

135500XFF,0XBE,0XFF,0XFF,0XF7,0XBE,0XFF,0XFF,0XFF,0XDE,0XEE,0XF7,0XC5,0X6B,0XF6,0XCD,

135510XFE,0XEB,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

135520XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

135530XFE,0XCB,0XFE,0XCA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,

135540XFE,0XCA,0XFE,0XCA,0XFF,0X0B,0XE6,0X29,0XCD,0XA9,0X94,0X25,0XB5,0X2C,0XFF,0XB9,

135550XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

135560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XFF,0XFE,

135640XFF,0XFC,0XF7,0X56,0XEE,0XEF,0XF6,0XEC,0XFE,0XEB,0XFE,0XEB,0XFE,0XEA,0XFE,0XEA,

135650XFE,0XEB,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFE,0XEB,0XFE,0XEB,0XFF,0X0B,0XFE,0XEA,

135660XFF,0X0B,0XFE,0XEA,0XFE,0XEA,0XFE,0XEB,0XFE,0XEB,0XFE,0XCC,0XCD,0X67,0X83,0X40,

135670X72,0XE0,0X7B,0X01,0X7B,0X23,0X7B,0X03,0X7B,0X24,0X73,0X03,0X6A,0XE4,0X62,0XC3,

135680X62,0XC3,0X52,0X62,0X52,0X22,0X41,0XC2,0X5A,0X87,0XDE,0X99,0XFF,0XDF,0XFF,0XFF,

135690XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XEF,0X37,0XBD,0X6A,0XF6,0XCD,0XFE,0XEB,0XFE,0XEA,

135700XFE,0XCA,0XFE,0XEA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,

135710XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,

135720XFE,0XC9,0XFE,0XC9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0X89,0XFE,0XAA,

135730XFE,0XAA,0XFE,0XEC,0XCD,0X67,0XB4,0XC6,0X94,0X26,0XD6,0X32,0XFF,0XDB,0XFF,0XFE,

135740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XDA,0XEE,0XF3,

135830XEE,0XCD,0XF6,0XEB,0XFE,0XCB,0XFE,0XEB,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEB,

135840XFE,0XEB,0XFE,0XEB,0XFE,0XEB,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

135850XFE,0XCA,0XFE,0XCA,0XFE,0XCB,0XFE,0XCC,0XCD,0X47,0X83,0X20,0X72,0XA0,0X72,0XE1,

135860X7B,0X03,0X7B,0X03,0X7B,0X24,0X73,0X04,0X6A,0XE4,0X6A,0XE3,0X62,0XC3,0X5A,0XA2,

135870X52,0X41,0X49,0XE2,0X73,0X29,0XEF,0X1B,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135880XFF,0XFD,0XF7,0X78,0XBD,0X4A,0XF6,0XCC,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,

135890XFE,0XCA,0XFE,0XCA,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,

135900XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XCA,0XFE,0XCA,0XFE,0XC9,0XFE,0XC9,0XFE,0XA8,

135910XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XA9,0XFE,0XCA,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,

135920XDD,0XC7,0XBC,0XE6,0X94,0X05,0XAD,0X0C,0XF7,0X79,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

135930XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136010XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0X98,0XEE,0XB1,0XF6,0XCC,0XF6,0XCA,

136020XFE,0XCA,0XFE,0XCA,0XFE,0XC9,0XFE,0XE9,0XFE,0XCA,0XFE,0XCA,0XFE,0XCB,0XFE,0XCB,

136030XFE,0XCA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,

136040XFE,0XCB,0XFE,0XCC,0XC5,0X27,0X7B,0X00,0X72,0XA0,0X72,0XE2,0X7B,0X03,0X7B,0X04,

136050X7B,0X24,0X73,0X04,0X72,0XE4,0X6A,0XE4,0X62,0XC2,0X62,0XE3,0X5A,0X62,0X52,0X22,

136060X8B,0XEC,0XF7,0X3B,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XF7,0X78,

136070XBD,0X4A,0XF6,0XAC,0XFE,0XAA,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,

136080XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

136090XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XA9,0XFE,0XA8,0XFE,0XA9,0XFE,0X89,0XFE,0X8A,

136100XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0X89,0XFE,0X89,0XF6,0X89,0XE6,0X08,0XBC,0XE5,

136110XA4,0X46,0X9C,0X49,0XD6,0X95,0XFF,0XDC,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

136120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136200XFF,0XFD,0XFF,0XFB,0XF7,0X35,0XEE,0X8F,0XF6,0XAB,0XF6,0XA9,0XFE,0XAA,0XFE,0XAA,

136210XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XCA,0XFE,0XAB,0XFE,0XCA,0XFE,0XCA,0XFE,0XC9,

136220XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XCA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAB,0XF6,0XAC,

136230XBD,0X06,0X72,0XE0,0X6A,0XA0,0X72,0XC2,0X72,0XE3,0X72,0XE4,0X73,0X04,0X73,0X04,

136240X73,0X04,0X6A,0XE4,0X62,0XC3,0X6B,0X04,0X62,0X83,0X5A,0X64,0XA4,0XB0,0XFF,0X9C,

136250XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XF7,0X79,0XC5,0X4A,0XF6,0X8C,

136260XFE,0XAA,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

136270XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

136280XFE,0X89,0XFE,0XA9,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0X89,0XFE,0X88,0XFE,0X88,

136290XF6,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XEE,0X28,0XCD,0X46,0XAC,0X66,0X8B,0XC6,

136300XB5,0X6F,0XF7,0XBA,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XDA,

136390XEE,0XD2,0XEE,0X8D,0XF6,0X8A,0XFE,0X88,0XFE,0XA9,0XFE,0X89,0XFE,0XA9,0XFE,0XA8,

136400XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XA9,0XFE,0XA9,0XFE,0XC9,0XFE,0XA9,

136410XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAB,0XF6,0X8B,0XB4,0XC6,0X72,0XA0,

136420X6A,0X81,0X72,0XC2,0X72,0XC3,0X72,0XE4,0X73,0X04,0X73,0X04,0X72,0XE3,0X6B,0X03,

136430X6A,0XE3,0X6A,0XE4,0X62,0XA4,0X5A,0X65,0XBD,0X52,0XFF,0X9D,0XFF,0XDF,0XFF,0XFF,

136440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0X59,0XC5,0X4B,0XEE,0X6C,0XFE,0X8A,0XFE,0X89,

136450XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,

136460XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XF6,0X88,0XF6,0X88,

136470XF6,0X88,0XF6,0X88,0XF6,0X88,0XFE,0X68,0XFE,0X68,0XF6,0X87,0XFE,0XA8,0XF6,0X88,

136480XFE,0X88,0XFE,0X68,0XF6,0X48,0XDD,0X87,0XAC,0X86,0X8B,0XC6,0X94,0X6A,0XE7,0X17,

136490XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFD,0XFF,0X98,0XE6,0X8F,0XEE,0X6B,

136580XF6,0X69,0XFE,0XA8,0XFE,0X89,0XFE,0X89,0XFE,0X88,0XFE,0XA8,0XFE,0XA8,0XFE,0XA9,

136590XFE,0X8A,0XFE,0X8A,0XFE,0X89,0XFE,0XA9,0XFE,0XA8,0XFE,0XA8,0XFE,0XA9,0XFE,0X89,

136600XFE,0X89,0XFE,0X8A,0XF6,0X8B,0XF6,0X8B,0XB4,0XA6,0X6A,0XA0,0X6A,0X81,0X6A,0XC3,

136610X72,0XC4,0X72,0XE4,0X73,0X04,0X73,0X04,0X73,0X03,0X73,0X03,0X6B,0X03,0X6A,0XE4,

136620X6A,0XA5,0X62,0X86,0XC5,0XB4,0XFF,0XBD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136630XFF,0XFF,0XF7,0X7A,0XBD,0X2C,0XEE,0X4C,0XF6,0X8A,0XFE,0X88,0XFE,0X88,0XFE,0X88,

136640XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,

136650XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XFE,0X69,0XF6,0X69,0XF6,0X69,0XF6,0X68,

136660XF6,0X68,0XFE,0X67,0XF6,0X67,0XF6,0X87,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XFE,0X68,

136670XF6,0X49,0XE5,0XA8,0XB4,0XA6,0X93,0XC5,0X83,0XC8,0XBD,0XD1,0XFF,0XFC,0XFF,0XFE,

136680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136760XFF,0XFF,0XFF,0XDE,0XFF,0XFC,0XF7,0X56,0XE6,0X4D,0XEE,0X4A,0XF6,0X48,0XFE,0XA9,

136770XFE,0X68,0XFE,0X89,0XF6,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0X89,0XFE,0X89,

136780XFE,0X89,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0X89,0XF6,0X69,0XF6,0X89,

136790XF6,0X8A,0XF6,0X6B,0XB4,0XA6,0X6A,0XA0,0X6A,0XA1,0X72,0XC3,0X72,0XE4,0X72,0XE4,

136800X72,0XE4,0X72,0XE3,0X72,0XE3,0X6B,0X03,0X6B,0X03,0X62,0XC4,0X6A,0XC5,0X62,0XA6,

136810XCD,0XD5,0XFF,0XBD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0X7A,

136820XBD,0X2C,0XEE,0X4C,0XF6,0X6A,0XF6,0X68,0XFE,0X68,0XF6,0X88,0XFE,0X68,0XF6,0X88,

136830XFE,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

136840XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X69,0XF6,0X68,0XF6,0X68,0XF6,0X67,

136850XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X88,0XF6,0X68,0XF6,0X48,0XFE,0X69,0XDD,0X67,

136860XC5,0X07,0X9C,0X06,0X7B,0X86,0X94,0X8C,0XFF,0XBB,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,

136870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,

136950XFF,0XBB,0XF6,0XF3,0XDE,0X0B,0XF6,0X8A,0XF6,0X69,0XF6,0X28,0XFE,0X68,0XF6,0X68,

136960XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XFE,0X89,0XFE,0X88,0XF6,0X88,

136970XF6,0X88,0XF6,0X88,0XFE,0X88,0XFE,0X88,0XF6,0X88,0XF6,0X68,0XF6,0X8A,0XEE,0X6B,

136980XAC,0X65,0X72,0XC0,0X6A,0X81,0X72,0XC3,0X72,0XE4,0X72,0XE4,0X72,0XE4,0X73,0X04,

136990X73,0X03,0X73,0X03,0X6A,0XE3,0X6A,0XA3,0X6A,0XA5,0X72,0XE7,0XD6,0X56,0XFF,0XFE,

137000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBA,0XBD,0X2B,0XEE,0X4C,

137010XEE,0X69,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

137020XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

137030XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X47,

137040XF6,0X47,0XF6,0X68,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XE6,0X09,0XC4,0XE6,0XA4,0X45,

137050X83,0X85,0X8B,0XE9,0XDE,0X95,0XFF,0X9B,0XFF,0XFE,0XFF,0XFF,0XF7,0XBE,0XFF,0XFF,

137060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137130XFF,0XFF,0XFF,0XFF,0XF7,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0X99,0XE6,0X71,

137140XDE,0X0B,0XEE,0X49,0XF6,0X49,0XF6,0X28,0XF6,0X68,0XF6,0X67,0XF6,0X88,0XF6,0X88,

137150XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X68,0XF6,0X68,

137160XFE,0X88,0XFE,0X68,0XF6,0X88,0XF6,0X68,0XF6,0X8A,0XEE,0X4B,0XAC,0X44,0X72,0XC0,

137170X6A,0X81,0X72,0XC3,0X72,0XE4,0X72,0XE4,0X72,0XE4,0X72,0XE4,0X72,0XE3,0X73,0X03,

137180X6A,0XE3,0X6A,0XA3,0X6A,0XA4,0X72,0XE7,0XD6,0X57,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137190XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBA,0XBD,0X2B,0XE6,0X4C,0XEE,0X4A,0XF6,0X68,

137200XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

137210XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

137220XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X48,0XF6,0X68,

137230XF6,0X68,0XF6,0X68,0XF6,0X48,0XE6,0X09,0XC5,0X06,0XAC,0X45,0X8B,0XA5,0X7B,0X66,

137240XAD,0X0F,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

137250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137320XF7,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0X58,0XDE,0X0F,0XE6,0X2B,0XE6,0X08,

137330XEE,0X49,0XF6,0X49,0XF6,0X48,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

137340XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XFE,0X68,0XF6,0X68,

137350XF6,0X68,0XF6,0X68,0XF6,0X6A,0XEE,0X4A,0XA4,0X44,0X72,0XC0,0X6A,0X81,0X72,0XE3,

137360X72,0XE4,0X72,0XE4,0X72,0XE4,0X72,0XE4,0X72,0XE3,0X73,0X03,0X6A,0XE3,0X6A,0XA3,

137370X6A,0X84,0X73,0X08,0XD6,0X77,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137380XFF,0XFE,0XFF,0XBA,0XB5,0X0B,0XE6,0X2B,0XEE,0X49,0XF6,0X48,0XF6,0X48,0XF6,0X48,

137390XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

137400XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X48,0XF6,0X48,

137410XF6,0X68,0XEE,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XEE,0X47,

137420XEE,0X48,0XEE,0X29,0XCD,0X26,0XAC,0X65,0X8B,0XC5,0X73,0X45,0X83,0XA9,0XFF,0X9A,

137430XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

137510XFF,0XFF,0XFF,0XDD,0XEE,0XF5,0XD5,0XED,0XE6,0X4B,0XE6,0X08,0XEE,0X28,0XF6,0X49,

137520XF6,0X47,0XF6,0X67,0XF6,0X67,0XEE,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

137530XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X68,0XF6,0X48,

137540XF6,0X6A,0XE6,0X4A,0XA4,0X24,0X72,0XC0,0X6A,0XA1,0X72,0XC3,0X72,0XE4,0X72,0XE4,

137550X72,0XE4,0X72,0XE4,0X72,0XE3,0X72,0XE3,0X6A,0XE3,0X6A,0XA3,0X6A,0X84,0X7B,0X28,

137560XDE,0X98,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDA,

137570XB5,0X0B,0XE6,0X0B,0XEE,0X49,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,

137580XEE,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

137590XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X48,0XEE,0X48,0XEE,0X47,0XEE,0X47,

137600XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X48,0XE6,0X09,

137610XCD,0X47,0XAC,0X65,0X8B,0XC5,0X7B,0X45,0X7B,0X68,0XD6,0X35,0XFF,0XDD,0XFF,0XBD,

137620XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XBB,

137700XDE,0X72,0XD5,0XCC,0XE6,0X2A,0XE6,0X28,0XEE,0X08,0XF6,0X28,0XEE,0X47,0XEE,0X47,

137710XEE,0X47,0XEE,0X48,0XEE,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

137720XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X48,0XEE,0X48,0XEE,0X69,0XE6,0X2A,

137730X9C,0X04,0X72,0XC0,0X6A,0XA1,0X6A,0XC3,0X6A,0XC3,0X6A,0XE4,0X72,0XE4,0X72,0XE4,

137740X6A,0XC3,0X72,0XE3,0X6A,0XE3,0X6A,0XA3,0X62,0X64,0X7B,0X48,0XDE,0XB8,0XFF,0XFE,

137750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDA,0XB5,0X0B,0XDE,0X0B,

137760XEE,0X29,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

137770XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

137780XEE,0X47,0XEE,0X47,0XEE,0X28,0XEE,0X28,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X27,

137790XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X28,0XE6,0X28,0XD5,0X88,0XB4,0X86,

137800X8B,0XA4,0X7B,0X24,0X7B,0X47,0XA4,0XCF,0XFF,0X9B,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,

137810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0X9A,0XD5,0XEF,0XD5,0XEB,

137890XDE,0X08,0XEE,0X48,0XED,0XE7,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X48,

137900XEE,0X48,0XEE,0X48,0XF6,0X48,0XF6,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X48,0XEE,0X48,

137910XF6,0X47,0XEE,0X27,0XEE,0X47,0XEE,0X48,0XEE,0X49,0XE6,0X0A,0X9C,0X03,0X72,0XC0,

137920X6A,0XA1,0X6A,0XC3,0X6A,0XC3,0X6A,0XE4,0X72,0XE4,0X72,0XE4,0X6A,0XE3,0X6A,0XE3,

137930X6A,0XC3,0X6A,0XC4,0X62,0X64,0X7B,0X49,0XDE,0XD9,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

137940XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XDB,0XB5,0X0B,0XDD,0XEB,0XEE,0X29,0XEE,0X28,

137950XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

137960XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

137970XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,

137980XEE,0X27,0XEE,0X47,0XEE,0X28,0XEE,0X28,0XDD,0XC8,0XBC,0XC6,0X8B,0XA3,0X7B,0X44,

137990X73,0X05,0X83,0X8A,0XEF,0X3A,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

138000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138070XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XF7,0X57,0XCD,0XAD,0XDD,0XEB,0XDE,0X08,0XEE,0X48,

138080XEE,0X07,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,

138090XEE,0X28,0XEE,0X27,0XEE,0X47,0XEE,0X27,0XEE,0X48,0XEE,0X48,0XEE,0X47,0XEE,0X27,

138100XEE,0X47,0XEE,0X28,0XEE,0X49,0XDE,0X0A,0X9B,0XE3,0X6A,0XC0,0X6A,0XA2,0X6A,0XC3,

138110X6A,0XC3,0X6A,0XE4,0X72,0XE4,0X6A,0XC4,0X6A,0XC3,0X6A,0XC3,0X6A,0XC3,0X6A,0XA4,

138120X62,0X63,0X7B,0X49,0XE6,0XD9,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138130XFF,0XFE,0XFF,0XDB,0XB5,0X0B,0XDD,0XEB,0XEE,0X29,0XEE,0X28,0XEE,0X28,0XEE,0X28,

138140XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

138150XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

138160XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X27,

138170XEE,0X28,0XEE,0X29,0XE5,0XE9,0XC4,0XE7,0X93,0XC4,0X7B,0X44,0X7B,0X26,0X62,0XC6,

138180XD6,0X76,0XFF,0XBC,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

138260XFF,0XDC,0XEE,0XF5,0XCD,0XAB,0XDE,0X0A,0XE6,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X28,

138270XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

138280XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X28,

138290XEE,0X49,0XDE,0X0A,0X93,0XC3,0X6A,0XA0,0X6A,0XA1,0X6A,0XC3,0X62,0XA3,0X6A,0XC3,

138300X6A,0XC3,0X6A,0XA3,0X6A,0XC3,0X6A,0XA3,0X62,0XA3,0X6A,0XA4,0X62,0X43,0X7B,0X49,

138310XDE,0XD9,0XFF,0XDE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,

138320XB4,0XEB,0XDD,0XCB,0XEE,0X29,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,

138330XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

138340XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

138350XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X28,

138360XE6,0X09,0XC5,0X07,0X9B,0XE4,0X7B,0X23,0X73,0X25,0X73,0X07,0XA4,0XCF,0XFF,0XDC,

138370XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138440XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFC,0XDE,0X52,

138450XCD,0XAA,0XDE,0X09,0XE6,0X07,0XE6,0X07,0XE5,0XE7,0XEE,0X08,0XE6,0X07,0XEE,0X27,

138460XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

138470XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X49,0XDD,0XEA,

138480X8B,0XA2,0X6A,0XA0,0X6A,0XA2,0X6A,0XC3,0X62,0XA3,0X6A,0XC4,0X6A,0XC3,0X6A,0XC3,

138490X6A,0XC3,0X6A,0XC3,0X62,0X83,0X6A,0XC4,0X62,0X43,0X7B,0X49,0XDE,0XD8,0XFF,0XFE,

138500XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XB4,0XEB,0XD5,0XCA,

138510XEE,0X29,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

138520XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

138530XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

138540XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X07,0XEE,0X07,0XEE,0X28,0XE6,0X09,0XC5,0X27,

138550X9B,0XE4,0X7B,0X43,0X73,0X05,0X6A,0XE6,0X94,0X2D,0XF7,0X5A,0XFF,0XFD,0XFF,0XFE,

138560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138630XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFA,0XCD,0XEF,0XCD,0XAA,0XDE,0X08,

138640XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE5,0XE7,0XEE,0X07,0XEE,0X07,0XE6,0X28,0XEE,0X28,

138650XEE,0X28,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X27,

138660XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X49,0XDD,0XEA,0X8B,0XA2,0X6A,0XA0,

138670X6A,0XA2,0X6A,0XA3,0X62,0XA3,0X6A,0XC4,0X62,0XA3,0X6A,0XC3,0X62,0XA3,0X62,0XA3,

138680X62,0X83,0X6A,0XA4,0X62,0X43,0X83,0X69,0XE6,0XD8,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

138690XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XB4,0XEB,0XD5,0XCB,0XEE,0X29,0XEE,0X28,

138700XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

138710XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

138720XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X07,

138730XEE,0X27,0XE6,0X07,0XEE,0X27,0XEE,0X28,0XE6,0X08,0XCD,0X47,0X9C,0X04,0X83,0X23,

138740X72,0XE4,0X6A,0XE6,0X7B,0X89,0XDE,0X97,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

138750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

138820XFF,0XFF,0XFF,0XFD,0XFF,0XB9,0XBD,0X6C,0XD5,0XC9,0XDE,0X28,0XDD,0XE7,0XE6,0X07,

138830XEE,0X08,0XE5,0XE7,0XEE,0X07,0XE6,0X07,0XE6,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,

138840XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

138850XEE,0X27,0XEE,0X28,0XEE,0X49,0XDD,0XE9,0X8B,0X82,0X6A,0X80,0X6A,0XA2,0X62,0XA3,

138860X62,0XA3,0X62,0XA3,0X62,0XA4,0X62,0XA3,0X62,0XA3,0X62,0XA3,0X62,0XA3,0X62,0X83,

138870X62,0X43,0X83,0X69,0XE6,0XD9,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138880XFF,0XFE,0XFF,0XDB,0XB4,0XEB,0XD5,0XAA,0XE6,0X09,0XEE,0X08,0XEE,0X08,0XEE,0X08,

138890XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

138900XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

138910XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X07,

138920XEE,0X27,0XEE,0X28,0XE6,0X08,0XCD,0X47,0XA4,0X24,0X7B,0X22,0X72,0XC3,0X6A,0XE5,

138930X62,0XC6,0XBD,0XD3,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFC,

139010XF7,0X36,0XB5,0X2A,0XD6,0X09,0XDE,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X28,0XE5,0XE7,

139020XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,

139030XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,

139040XEE,0X49,0XD5,0XC9,0X8B,0X82,0X6A,0X80,0X6A,0XA2,0X62,0X82,0X62,0XA3,0X62,0XA3,

139050X62,0XA3,0X62,0XA3,0X62,0XA3,0X62,0X83,0X62,0XA4,0X5A,0X63,0X5A,0X43,0X83,0X8A,

139060XE6,0XF9,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,

139070XB4,0XEB,0XD5,0XAA,0XE6,0X09,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

139080XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

139090XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,

139100XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XEE,0X27,0XE6,0X28,

139110XE6,0X08,0XD5,0X88,0XAC,0X45,0X7B,0X22,0X72,0XC3,0X72,0XE5,0X62,0XA5,0XA4,0XF0,

139120XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139190XFF,0XFF,0XFF,0XBE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XDC,0XDE,0X93,0XBD,0X4A,

139200XDE,0X29,0XDD,0XE6,0XE6,0X07,0XE5,0XE7,0XEE,0X08,0XE5,0XE8,0XE5,0XE7,0XE6,0X07,

139210XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X27,

139220XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XE6,0X2A,0XD5,0XC9,

139230X8B,0X62,0X62,0X80,0X62,0XA2,0X62,0X82,0X62,0XA3,0X62,0X83,0X62,0XA4,0X62,0XA3,

139240X62,0XA3,0X62,0X83,0X62,0XA4,0X5A,0X63,0X5A,0X23,0X83,0X8A,0XE6,0XF9,0XFF,0XFE,

139250XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDB,0XB4,0XEB,0XCD,0X8A,

139260XE6,0X09,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

139270XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

139280XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,

139290XEE,0X08,0XEE,0X08,0XEE,0X07,0XE6,0X07,0XEE,0X27,0XE6,0X27,0XE6,0X08,0XD5,0XA8,

139300XAC,0X65,0X83,0X22,0X72,0XC3,0X6A,0XC5,0X62,0XA6,0X8C,0X2D,0XEF,0X3A,0XFF,0XFD,

139310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XBE,

139380XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XDB,0XCD,0XF0,0XC5,0X8B,0XDE,0X08,0XDD,0XE6,

139390XE6,0X07,0XE5,0XE7,0XE5,0XE7,0XE6,0X08,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,

139400XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

139410XEE,0X27,0XEE,0X27,0XE6,0X07,0XEE,0X28,0XE6,0X29,0XD5,0XC9,0X8B,0X62,0X62,0X60,

139420X62,0X82,0X62,0X82,0X62,0X83,0X62,0X83,0X62,0X83,0X62,0X83,0X62,0X83,0X62,0X83,

139430X62,0X83,0X5A,0X63,0X5A,0X23,0X83,0X8A,0XE6,0XF9,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

139440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XAC,0XCB,0XCD,0X8A,0XE6,0X09,0XEE,0X07,

139450XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

139460XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

139470XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,

139480XEE,0X07,0XE6,0X07,0XEE,0X27,0XE6,0X07,0XE6,0X08,0XDD,0XC8,0XAC,0X65,0X83,0X22,

139490X72,0XC3,0X6A,0XA4,0X62,0XA5,0X73,0X6A,0XD6,0X96,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

139500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XDE,

139570XFF,0XFE,0XFF,0XDB,0XBD,0X8E,0XCD,0XEB,0XDE,0X08,0XDD,0XE6,0XE5,0XE7,0XE5,0XE7,

139580XE5,0XC7,0XE6,0X08,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,

139590XEE,0X07,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,

139600XEE,0X07,0XEE,0X28,0XE6,0X29,0XD5,0XA9,0X83,0X42,0X62,0X60,0X62,0X61,0X62,0X83,

139610X62,0X83,0X62,0X84,0X62,0X83,0X62,0X83,0X5A,0X83,0X62,0X83,0X5A,0X63,0X5A,0X63,

139620X5A,0X43,0X83,0XAA,0XEF,0X19,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139630XFF,0XFF,0XFF,0XFC,0XAC,0XCB,0XCD,0X6A,0XE6,0X09,0XEE,0X07,0XEE,0X07,0XEE,0X07,

139640XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

139650XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

139660XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XE6,0X07,

139670XEE,0X27,0XE6,0X07,0XE6,0X08,0XDD,0XE9,0XB4,0X86,0X83,0X22,0X72,0XA2,0X6A,0XA4,

139680X62,0X85,0X62,0XE7,0XBD,0XD4,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139750XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XBB,

139760XB5,0X4C,0XD5,0XEB,0XDD,0XE7,0XDD,0XE6,0XDD,0XE6,0XE6,0X07,0XE5,0XC7,0XE6,0X08,

139770XE6,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,

139780XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X28,

139790XEE,0X29,0XD5,0XA9,0X83,0X42,0X62,0X60,0X62,0X61,0X62,0X83,0X5A,0X63,0X62,0X83,

139800X5A,0X63,0X5A,0X83,0X5A,0X83,0X62,0XA3,0X5A,0X62,0X5A,0X83,0X5A,0X43,0X83,0XAA,

139810XEF,0X1A,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,

139820XAC,0XEB,0XCD,0X6A,0XE6,0X09,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

139830XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

139840XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,

139850XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X07,

139860XE6,0X28,0XE5,0XE9,0XBC,0XC6,0X83,0X02,0X6A,0X82,0X6A,0X84,0X5A,0X85,0X5A,0XA6,

139870XB5,0X72,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139940XFF,0XFE,0XFF,0XDE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFE,0XEF,0X17,0XBD,0X4B,0XD5,0XCA,

139950XDD,0XE8,0XDD,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

139960XE6,0X08,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X08,0XE6,0X08,0XE6,0X08,0XE6,0X07,

139970XE6,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XE6,0X06,0XEE,0X28,0XEE,0X29,0XD5,0X89,

139980X83,0X42,0X62,0X60,0X62,0X61,0X62,0X62,0X62,0X83,0X5A,0X83,0X5A,0X83,0X5A,0X83,

139990X5A,0X83,0X5A,0X83,0X5A,0X83,0X52,0X43,0X52,0X43,0X83,0XCA,0XE7,0X3A,0XFF,0XFE,

140000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XB5,0X0C,0XC5,0X6A,

140010XE6,0X09,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140020XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140030XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140040XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X27,0XE6,0X08,0XE6,0X09,

140050XBC,0XC6,0X83,0X22,0X6A,0X83,0X62,0X43,0X62,0X85,0X52,0X45,0X9C,0XAF,0XF7,0X9B,

140060XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

140130XFF,0XFF,0XFF,0XDE,0XFF,0XFD,0XDE,0X95,0XBD,0X4A,0XD5,0XC9,0XDD,0XC8,0XE5,0XE7,

140140XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X08,0XE5,0XE8,0XE5,0XE8,0XE6,0X08,

140150XE6,0X08,0XEE,0X08,0XE6,0X08,0XE6,0X08,0XE6,0X08,0XE6,0X08,0XE6,0X27,0XE6,0X27,

140160XEE,0X27,0XEE,0X27,0XE6,0X06,0XEE,0X28,0XEE,0X29,0XD5,0X89,0X83,0X22,0X62,0X40,

140170X62,0X42,0X5A,0X62,0X5A,0X82,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X63,

140180X5A,0X83,0X52,0X43,0X52,0X63,0X83,0XEB,0XEF,0X3A,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

140190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XB5,0X0C,0XC5,0X6A,0XE6,0X09,0XEE,0X07,

140200XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140210XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140220XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140230XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X29,0XBD,0X07,0X83,0X42,

140240X62,0X62,0X62,0X44,0X62,0X65,0X4A,0X24,0X8C,0X0C,0XEF,0X39,0XFF,0XFE,0XFF,0XFF,

140250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDE,

140320XFF,0XFD,0XD6,0X13,0XBD,0X4A,0XD5,0XE9,0XDD,0XC8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

140330XE5,0XE7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE8,0XE5,0XE8,0XE6,0X08,0XE6,0X07,0XE6,0X07,

140340XE6,0X08,0XE6,0X08,0XE6,0X08,0XE6,0X08,0XE6,0X27,0XE6,0X27,0XEE,0X27,0XEE,0X27,

140350XE6,0X06,0XEE,0X27,0XEE,0X29,0XD5,0X89,0X83,0X01,0X62,0X40,0X5A,0X41,0X5A,0X62,

140360X5A,0X62,0X5A,0X62,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X52,0X43,

140370X52,0X43,0X83,0XEB,0XEF,0X3A,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140380XFF,0XFF,0XFF,0XFC,0XB5,0X0C,0XC5,0X6A,0XE6,0X09,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140390XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140400XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140410XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140420XE6,0X07,0XE6,0X07,0XEE,0X28,0XE6,0X29,0XC5,0X27,0X83,0X42,0X62,0X42,0X62,0X44,

140430X5A,0X64,0X4A,0X24,0X73,0X69,0XDE,0XB7,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XDE,0XFF,0XFE,0XFF,0XFD,0XCD,0XF2,

140510XC5,0X6A,0XD5,0XE9,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

140520XE5,0XE7,0XE5,0XE8,0XE5,0XE8,0XE5,0XE8,0XE6,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X08,

140530XE6,0X08,0XE6,0X07,0XE6,0X27,0XE6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X06,0XEE,0X07,

140540XEE,0X29,0XCD,0X69,0X7B,0X02,0X62,0X20,0X5A,0X42,0X5A,0X42,0X5A,0X62,0X5A,0X62,

140550X5A,0X63,0X5A,0X63,0X5A,0X43,0X5A,0X63,0X5A,0X63,0X52,0X43,0X52,0X23,0X8C,0X0B,

140560XEF,0X5A,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,

140570XB5,0X2D,0XC5,0X49,0XE6,0X09,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140580XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140590XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,

140600XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,

140610XEE,0X28,0XEE,0X49,0XC5,0X47,0X8B,0X63,0X62,0X41,0X5A,0X43,0X5A,0X44,0X52,0X44,

140620X62,0XE7,0XCE,0X56,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140690XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XFF,0XFE,0XFF,0XDC,0XC5,0XB0,0XC5,0X8A,0XD5,0XE8,

140700XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

140710XE5,0XE8,0XE5,0XE8,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

140720XE6,0X27,0XE6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X06,0XEE,0X07,0XEE,0X4A,0XCD,0X48,

140730X7A,0XE1,0X62,0X20,0X5A,0X41,0X5A,0X42,0X5A,0X42,0X5A,0X42,0X5A,0X43,0X5A,0X43,

140740X5A,0X43,0X5A,0X43,0X5A,0X43,0X52,0X43,0X52,0X23,0X8C,0X0B,0XEF,0X5B,0XFF,0XFE,

140750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XBD,0X4D,0XC5,0X49,

140760XE6,0X09,0XE6,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140770XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140780XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,

140790XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X27,0XE6,0X29,

140800XCD,0X68,0X8B,0X63,0X5A,0X21,0X5A,0X23,0X5A,0X44,0X52,0X44,0X5A,0X86,0XC5,0XF4,

140810XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140880XFF,0XFF,0XFF,0XDD,0XFF,0XDB,0XBD,0X4E,0XCD,0XCA,0XD5,0XE8,0XE5,0XC7,0XE5,0XC7,

140890XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE8,

140900XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X27,0XE6,0X27,

140910XEE,0X27,0XEE,0X27,0XEE,0X27,0XE6,0X07,0XEE,0X4A,0XCD,0X48,0X7A,0XE2,0X62,0X20,

140920X5A,0X21,0X5A,0X42,0X5A,0X42,0X5A,0X42,0X5A,0X43,0X5A,0X43,0X5A,0X43,0X5A,0X43,

140930X52,0X43,0X52,0X43,0X4A,0X03,0X8C,0X0C,0XEF,0X5B,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XBD,0X4D,0XC5,0X49,0XE6,0X09,0XE6,0X08,

140950XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140960XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140970XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140980XEE,0X27,0XEE,0X27,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X29,0XD5,0XA9,0X83,0X42,

140990X5A,0X00,0X5A,0X23,0X5A,0X23,0X52,0X24,0X4A,0X24,0XB5,0X72,0XFF,0XBD,0XFF,0XFF,

141000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,

141070XFF,0X99,0XB5,0X0C,0XD5,0XCA,0XDD,0XC8,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,

141080XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE6,0X07,

141090XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,

141100XEE,0X27,0XEE,0X07,0XEE,0X6A,0XCD,0X48,0X7A,0XE1,0X62,0X20,0X5A,0X21,0X5A,0X22,

141110X5A,0X42,0X5A,0X42,0X5A,0X43,0X5A,0X23,0X5A,0X22,0X52,0X22,0X52,0X23,0X52,0X43,

141120X4A,0X03,0X8C,0X0C,0XEF,0X5B,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141130XFF,0XFF,0XFF,0XDC,0XBD,0X6E,0XC5,0X49,0XE6,0X09,0XE6,0X08,0XEE,0X07,0XEE,0X07,

141140XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

141150XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,

141160XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,

141170XEE,0X27,0XE6,0X07,0XE6,0X07,0XE6,0X29,0XD5,0XC9,0X83,0X42,0X5A,0X21,0X5A,0X02,

141180X52,0X23,0X4A,0X03,0X42,0X03,0X9C,0XCF,0XF7,0X7C,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XF7,0X58,0XB5,0X2C,

141260XD5,0XCA,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE8,

141270XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,

141280XE6,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,

141290XF6,0X6A,0XCD,0X48,0X7A,0XE2,0X62,0X20,0X5A,0X21,0X5A,0X22,0X5A,0X42,0X5A,0X42,

141300X5A,0X43,0X5A,0X23,0X5A,0X22,0X52,0X22,0X52,0X22,0X52,0X43,0X52,0X03,0X8C,0X0C,

141310XEF,0X5B,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,

141320XBD,0X6E,0XC5,0X49,0XE6,0X09,0XE6,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

141330XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

141340XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

141350XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,0XE6,0X27,

141360XE6,0X27,0XE6,0X49,0XD5,0XC9,0X83,0X62,0X62,0X41,0X51,0XE2,0X52,0X03,0X49,0XE3,

141370X41,0XE3,0X8C,0X4E,0XF7,0X7C,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XEE,0XF6,0XBD,0X6C,0XD5,0XC9,0XDD,0XC7,

141450XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,

141460XE5,0XE7,0XE5,0XE8,0XE6,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

141470XE6,0X08,0XE6,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XCD,0X48,

141480X7A,0XC1,0X62,0X20,0X5A,0X01,0X5A,0X22,0X52,0X22,0X52,0X22,0X52,0X23,0X52,0X23,

141490X52,0X22,0X52,0X22,0X52,0X23,0X52,0X23,0X4A,0X03,0X8C,0X2D,0XF7,0X7C,0XFF,0XFF,

141500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XBD,0X4E,0XC5,0X49,

141510XE6,0X09,0XE6,0X08,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

141520XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

141530XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

141540XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X27,0XE6,0X27,0XE6,0X49,

141550XDD,0XE9,0X8B,0X83,0X5A,0X21,0X52,0X02,0X52,0X03,0X4A,0X03,0X41,0XE3,0X7B,0XAB,

141560XEF,0X5B,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141630XFF,0XFF,0XFF,0XFC,0XDE,0X94,0XBD,0X4B,0XD5,0XC9,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,

141640XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE8,

141650XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X28,

141660XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XCD,0X48,0X7A,0XC1,0X5A,0X20,

141670X5A,0X21,0X52,0X02,0X52,0X22,0X52,0X22,0X52,0X23,0X52,0X23,0X52,0X22,0X52,0X22,

141680X52,0X23,0X52,0X23,0X4A,0X03,0X94,0X2D,0XF7,0X5C,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XBD,0X4E,0XC5,0X49,0XE6,0X09,0XEE,0X08,

141700XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

141710XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

141720XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

141730XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X27,0XE6,0X29,0XDD,0XEA,0X8B,0X63,

141740X5A,0X20,0X51,0XE2,0X49,0XE2,0X4A,0X03,0X41,0XC3,0X6B,0X29,0XEF,0X3A,0XFF,0XDE,

141750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,

141820XD6,0X32,0XBD,0X2A,0XD5,0XC9,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,

141830XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE8,0XE6,0X07,0XE6,0X07,

141840XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X27,0XEE,0X07,0XEE,0X07,

141850XEE,0X27,0XE6,0X28,0XEE,0X4A,0XCD,0X48,0X72,0XC1,0X5A,0X00,0X5A,0X01,0X52,0X02,

141860X52,0X22,0X52,0X22,0X52,0X23,0X52,0X23,0X52,0X22,0X52,0X22,0X52,0X23,0X52,0X23,

141870X4A,0X03,0X94,0X4D,0XF7,0X7C,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141880XFF,0XFF,0XFF,0XDC,0XBD,0X4E,0XC5,0X49,0XE6,0X09,0XEE,0X07,0XEE,0X07,0XEE,0X07,

141890XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

141900XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

141910XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

141920XEE,0X27,0XEE,0X27,0XE6,0X27,0XE6,0X29,0XE6,0X2A,0X8B,0X83,0X5A,0X20,0X51,0XE1,

141930X49,0XC2,0X4A,0X03,0X41,0XE3,0X5A,0XA7,0XE6,0XFA,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

141940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XCD,0XF0,0XBD,0X4A,

142010XDD,0XC9,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE8,

142020XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE8,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

142030XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,

142040XEE,0X4A,0XC5,0X28,0X72,0XC1,0X5A,0X00,0X52,0X02,0X52,0X02,0X52,0X22,0X52,0X22,

142050X52,0X23,0X52,0X23,0X52,0X22,0X52,0X22,0X52,0X22,0X52,0X03,0X4A,0X03,0X94,0X4E,

142060XF7,0X7C,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,

142070XBD,0X6E,0XC5,0X29,0XE6,0X09,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

142080XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

142090XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,

142100XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

142110XEE,0X27,0XE6,0X48,0XE6,0X2B,0X8B,0XA3,0X5A,0X00,0X51,0XE1,0X49,0XE2,0X4A,0X03,

142120X41,0XE3,0X4A,0X46,0XDE,0XD9,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142190XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDB,0XC5,0XAF,0XC5,0X4A,0XDD,0XC8,0XDD,0XC7,

142200XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,

142210XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

142220XE6,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XC5,0X28,

142230X72,0XA1,0X5A,0X00,0X52,0X01,0X52,0X02,0X52,0X22,0X52,0X22,0X52,0X23,0X52,0X03,

142240X52,0X02,0X52,0X22,0X52,0X22,0X4A,0X03,0X4A,0X03,0X94,0X4E,0XF7,0X9C,0XFF,0XFF,

142250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XC5,0X6E,0XBD,0X29,

142260XE6,0X09,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

142270XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

142280XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

142290XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XE6,0X48,

142300XDE,0X2A,0X93,0XC3,0X5A,0X00,0X49,0XC1,0X49,0XE2,0X49,0XE2,0X41,0XE3,0X4A,0X25,

142310XDE,0X98,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142380XFF,0XDE,0XFF,0XDB,0XC5,0XAE,0XC5,0X6A,0XDD,0XC8,0XDD,0XA7,0XE5,0XC7,0XE5,0XC7,

142390XE5,0XC7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

142400XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

142410XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XC5,0X28,0X72,0XA1,0X52,0X00,

142420X52,0X02,0X52,0X02,0X52,0X22,0X52,0X02,0X4A,0X03,0X52,0X03,0X52,0X02,0X52,0X02,

142430X52,0X22,0X4A,0X03,0X4A,0X03,0X94,0X4E,0XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XC5,0X8E,0XBD,0X29,0XE6,0X09,0XEE,0X08,

142450XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

142460XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

142470XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

142480XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XE6,0X48,0XDE,0X2A,0X93,0XE4,

142490X5A,0X00,0X49,0XC0,0X49,0XE2,0X41,0XC2,0X41,0XC2,0X4A,0X04,0XCE,0X57,0XFF,0XDE,

142500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XDB,

142570XC5,0XAE,0XC5,0X6A,0XDD,0XC8,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,

142580XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

142590XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,

142600XEE,0X27,0XEE,0X28,0XEE,0X6A,0XBD,0X08,0X6A,0XA1,0X52,0X00,0X52,0X01,0X52,0X02,

142610X52,0X02,0X4A,0X02,0X4A,0X03,0X4A,0X03,0X52,0X02,0X52,0X02,0X52,0X02,0X4A,0X02,

142620X4A,0X03,0X94,0X6E,0XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142630XFF,0XFF,0XFF,0XFC,0XC5,0X8F,0XBD,0X29,0XE6,0X09,0XEE,0X27,0XEE,0X07,0XEE,0X07,

142640XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

142650XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

142660XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,

142670XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XE6,0X2A,0X93,0XE4,0X5A,0X00,0X49,0XA0,

142680X49,0XE2,0X41,0XC2,0X41,0XC2,0X41,0XE4,0XC5,0XF5,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

142690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XDB,0XC5,0X8E,0XC5,0X6A,

142760XDD,0XC8,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE8,

142770XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

142780XE6,0X07,0XE6,0X07,0XEE,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,

142790XEE,0X6A,0XBD,0X08,0X6A,0XA1,0X52,0X00,0X52,0X02,0X4A,0X02,0X52,0X22,0X4A,0X02,

142800X4A,0X03,0X4A,0X03,0X52,0X02,0X52,0X02,0X52,0X02,0X4A,0X02,0X4A,0X03,0X94,0X6E,

142810XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,

142820XC5,0X8F,0XBD,0X29,0XE6,0X29,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

142830XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,

142840XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

142850XEE,0X07,0XEE,0X07,0XF6,0X28,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

142860XEE,0X27,0XEE,0X28,0XE6,0X2A,0X93,0XE4,0X5A,0X00,0X49,0XA0,0X49,0XC1,0X41,0XC2,

142870X41,0XE3,0X39,0XA3,0XBD,0X94,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142940XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0X9A,0XC5,0X6D,0XCD,0X8A,0XD5,0XC8,0XDD,0XE7,

142950XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

142960XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

142970XE6,0X07,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XBD,0X07,

142980X6A,0X81,0X52,0X01,0X52,0X02,0X4A,0X02,0X52,0X22,0X4A,0X22,0X49,0XE3,0X49,0XE3,

142990X52,0X02,0X4A,0X01,0X4A,0X02,0X49,0XE2,0X4A,0X04,0X94,0X6E,0XF7,0X9D,0XFF,0XFF,

143000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XC5,0X8E,0XBD,0X29,

143010XEE,0X2A,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

143020XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

143030XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X28,

143040XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X48,

143050XE6,0X2A,0X93,0XE3,0X52,0X00,0X49,0XC1,0X49,0XC2,0X41,0XA2,0X49,0XE3,0X31,0X82,

143060XAD,0X12,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

143130XFF,0XDD,0XF7,0X7A,0XBD,0X4D,0XCD,0X8A,0XD5,0XA7,0XDD,0XC6,0XDD,0XC7,0XE5,0XC7,

143140XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

143150XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,

143160XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X28,0XEE,0X49,0XBD,0X07,0X6A,0X81,0X51,0XE1,

143170X52,0X02,0X4A,0X02,0X52,0X22,0X4A,0X22,0X49,0XE3,0X49,0XE3,0X52,0X02,0X4A,0X01,

143180X4A,0X02,0X49,0XE2,0X4A,0X04,0X94,0X6E,0XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XC5,0X8F,0XBD,0X29,0XEE,0X2A,0XEE,0X28,

143200XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

143210XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

143220XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X27,

143230XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XE6,0X2A,0X93,0XE3,

143240X52,0X00,0X49,0XC1,0X49,0XC2,0X41,0XA2,0X41,0XE3,0X31,0X62,0XA4,0XF1,0XFF,0XDD,

143250XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XF7,0X39,

143320XBD,0X4D,0XCD,0X8A,0XD5,0XC8,0XDD,0XC6,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,

143330XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

143340XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,

143350XEE,0X27,0XEE,0X28,0XEE,0X4A,0XBD,0X07,0X6A,0X81,0X51,0XE1,0X52,0X02,0X4A,0X02,

143360X4A,0X02,0X4A,0X22,0X49,0XE3,0X49,0XE3,0X52,0X02,0X4A,0X01,0X49,0XE2,0X49,0XE2,

143370X4A,0X03,0X94,0X6E,0XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143380XFF,0XFF,0XFF,0XFC,0XBD,0X8E,0XBD,0X29,0XEE,0X2A,0XEE,0X28,0XEE,0X28,0XEE,0X27,

143390XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

143400XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

143410XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

143420XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X48,0XE6,0X2A,0X93,0XE4,0X5A,0X00,0X49,0XC2,

143430X49,0XC2,0X41,0XC2,0X41,0XC3,0X31,0X62,0XA4,0XB0,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,

143440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XEF,0X39,0XBD,0X2C,0XCD,0X8A,

143510XD5,0XC8,0XDD,0XC6,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

143520XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

143530XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X28,

143540XEE,0X4A,0XBD,0X07,0X6A,0X61,0X51,0XE1,0X52,0X02,0X4A,0X02,0X4A,0X02,0X4A,0X02,

143550X49,0XE3,0X49,0XE3,0X52,0X02,0X4A,0X01,0X49,0XE1,0X49,0XE2,0X49,0XE3,0X94,0X6E,

143560XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,

143570XBD,0X8E,0XC5,0X49,0XEE,0X2A,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

143580XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

143590XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

143600XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

143610XEE,0X47,0XEE,0X48,0XE6,0X2A,0X9C,0X04,0X5A,0X20,0X49,0XE2,0X49,0XC2,0X41,0XE3,

143620X41,0XC3,0X31,0X82,0X9C,0X90,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143690XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XEF,0X18,0XB5,0X2C,0XCD,0X8A,0XD5,0XC8,0XDD,0XC6,

143700XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

143710XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

143720XE6,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XBD,0X07,

143730X6A,0X61,0X51,0XE1,0X52,0X02,0X4A,0X02,0X4A,0X02,0X4A,0X02,0X49,0XE3,0X49,0XE3,

143740X52,0X02,0X4A,0X01,0X49,0XE1,0X49,0XE2,0X49,0XE3,0X9C,0X6E,0XF7,0X9D,0XFF,0XFF,

143750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XBD,0X6E,0XC5,0X49,

143760XEE,0X2A,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

143770XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

143780XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

143790XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X48,

143800XE6,0X2A,0X9C,0X04,0X5A,0X20,0X49,0XC2,0X49,0XC2,0X41,0XE3,0X41,0XC3,0X39,0X82,

143810X9C,0X90,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

143880XFF,0XDE,0XEE,0XF8,0XB5,0X0C,0XCD,0X8A,0XD5,0XC8,0XDD,0XC6,0XDD,0XC7,0XE5,0XC7,

143890XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

143900XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,

143910XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XBC,0XE7,0X6A,0X60,0X51,0XE1,

143920X52,0X02,0X4A,0X02,0X4A,0X02,0X4A,0X02,0X49,0XE3,0X4A,0X03,0X52,0X02,0X52,0X01,

143930X49,0XE1,0X49,0XE2,0X49,0XE3,0X9C,0X6F,0XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XBD,0X6E,0XC5,0X4A,0XEE,0X2A,0XEE,0X28,

143950XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

143960XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

143970XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

143980XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X47,0XEE,0X48,0XEE,0X48,0XE6,0X2A,0X9C,0X04,

143990X5A,0X21,0X49,0XC1,0X49,0XC2,0X49,0XC3,0X41,0XC2,0X39,0X82,0X9C,0X90,0XFF,0XBD,

144000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XEE,0XF8,

144070XB5,0X2C,0XCD,0X8A,0XD5,0XC8,0XDD,0XC6,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,

144080XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

144090XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X07,

144100XEE,0X27,0XEE,0X28,0XEE,0X4A,0XBC,0XE7,0X6A,0X60,0X51,0XE0,0X52,0X02,0X4A,0X02,

144110X4A,0X02,0X4A,0X02,0X49,0XE3,0X4A,0X03,0X52,0X01,0X52,0X01,0X49,0XE1,0X49,0XE2,

144120X49,0XE3,0X9C,0X6F,0XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144130XFF,0XFF,0XFF,0XFC,0XBD,0X6E,0XC5,0X4A,0XEE,0X2A,0XEE,0X28,0XEE,0X28,0XEE,0X28,

144140XEE,0X28,0XEE,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,

144150XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,

144160XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X28,

144170XEE,0X47,0XF6,0X48,0XF6,0X48,0XEE,0X49,0XE6,0X0A,0X9B,0XE4,0X62,0X41,0X49,0XC1,

144180X49,0XE2,0X49,0XC3,0X41,0XC2,0X39,0XA3,0X9C,0X90,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,

144190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XEE,0XF8,0XB5,0X2C,0XCD,0X8A,

144260XD5,0XC8,0XDD,0XC6,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

144270XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

144280XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,

144290XEE,0X4A,0XBC,0XE7,0X6A,0X60,0X51,0XE0,0X52,0X02,0X4A,0X02,0X52,0X22,0X4A,0X02,

144300X49,0XE3,0X4A,0X02,0X52,0X01,0X52,0X01,0X49,0XE1,0X49,0XE2,0X49,0XC3,0X9C,0X6F,

144310XF7,0X9D,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,

144320XBD,0X6E,0XC5,0X4A,0XEE,0X2A,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X47,

144330XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,

144340XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,

144350XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X47,0XF6,0X48,0XF6,0X48,

144360XF6,0X48,0XEE,0X49,0XE6,0X0A,0X9B,0XE4,0X62,0X41,0X49,0XC1,0X49,0XE3,0X49,0XE3,

144370X41,0XC2,0X39,0XA3,0X9C,0X90,0XFF,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144440XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XEE,0XF8,0XB5,0X2C,0XCD,0X8A,0XDD,0XE8,0XDD,0XC7,

144450XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

144460XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

144470XEE,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X2A,0XBC,0XE7,

144480X62,0X60,0X52,0X00,0X52,0X02,0X52,0X22,0X4A,0X02,0X4A,0X02,0X49,0XE2,0X4A,0X02,

144490X52,0X02,0X4A,0X01,0X49,0XE1,0X4A,0X02,0X49,0XE3,0X9C,0X6F,0XF7,0X9D,0XFF,0XFF,

144500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XBD,0X6E,0XC5,0X4A,

144510XEE,0X2A,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X47,0XF6,0X27,0XF6,0X27,

144520XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,

144530XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,

144540XF6,0X48,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XF6,0X48,0XEE,0X47,0XF6,0X68,0XF6,0X69,

144550XE6,0X09,0X9B,0XE4,0X62,0X61,0X51,0XE2,0X49,0XE2,0X4A,0X03,0X41,0XE3,0X39,0XA2,

144560X9C,0XB0,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

144630XFF,0XDE,0XEE,0XF8,0XB5,0X2C,0XCD,0X8A,0XDD,0XC8,0XDD,0XC7,0XDD,0XC7,0XE5,0XC7,

144640XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

144650XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,

144660XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X2A,0XBC,0XE7,0X6A,0X60,0X52,0X01,

144670X52,0X02,0X52,0X22,0X4A,0X02,0X4A,0X02,0X49,0XE2,0X4A,0X02,0X52,0X02,0X4A,0X01,

144680X49,0XE1,0X4A,0X02,0X49,0XE3,0X9C,0X6F,0XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XBD,0X6E,0XC5,0X4A,0XEE,0X2A,0XEE,0X48,

144700XEE,0X28,0XEE,0X28,0XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

144710XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

144720XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X48,0XF6,0X27,

144730XEE,0X47,0XEE,0X47,0XF6,0X48,0XEE,0X47,0XF6,0X68,0XF6,0X69,0XDD,0XE9,0X9B,0XE4,

144740X62,0X62,0X51,0XE2,0X52,0X03,0X4A,0X03,0X49,0XE3,0X41,0XC3,0X9C,0XB0,0XFF,0XBD,

144750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XEE,0XD8,

144820XB5,0X0C,0XCD,0X8A,0XD5,0XC8,0XDD,0XC7,0XDD,0XC7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,

144830XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

144840XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

144850XEE,0X27,0XEE,0X28,0XEE,0X4A,0XBC,0XC7,0X6A,0X60,0X52,0X00,0X51,0XE1,0X4A,0X02,

144860X4A,0X02,0X4A,0X22,0X4A,0X02,0X52,0X02,0X52,0X02,0X4A,0X01,0X4A,0X02,0X4A,0X03,

144870X49,0XE3,0X9C,0X8F,0XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144880XFF,0XFF,0XFF,0XFC,0XBD,0X6E,0XC5,0X4A,0XEE,0X2A,0XEE,0X48,0XEE,0X28,0XEE,0X28,

144890XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

144900XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

144910XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X48,0XF6,0X27,0XF6,0X48,0XEE,0X47,

144920XF6,0X48,0XF6,0X47,0XF6,0X68,0XF6,0X69,0XDD,0XC8,0X9B,0XE4,0X6A,0X62,0X51,0XE1,

144930X52,0X03,0X4A,0X03,0X4A,0X03,0X41,0XC3,0XA4,0XD0,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,

144940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145000XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XEE,0XF8,0XB5,0X2C,0XCD,0X8A,

145010XD5,0XA8,0XDD,0XC7,0XDD,0XC7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,

145020XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

145030XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X28,

145040XEE,0X4A,0XBC,0XC7,0X6A,0X80,0X52,0X00,0X51,0XE1,0X4A,0X02,0X4A,0X02,0X4A,0X22,

145050X52,0X02,0X52,0X02,0X52,0X02,0X52,0X01,0X4A,0X02,0X4A,0X03,0X49,0XE3,0X9C,0X8F,

145060XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,

145070XBD,0X6E,0XC5,0X4A,0XEE,0X2A,0XEE,0X48,0XEE,0X28,0XEE,0X47,0XEE,0X47,0XEE,0X47,

145080XF6,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

145090XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

145100XF6,0X27,0XF6,0X27,0XF6,0X48,0XF6,0X27,0XF6,0X47,0XEE,0X47,0XF6,0X48,0XF6,0X47,

145110XF6,0X68,0XF6,0X69,0XD5,0XA8,0X9B,0XE4,0X6A,0X41,0X51,0XE1,0X52,0X02,0X49,0XE2,

145120X4A,0X03,0X41,0XC3,0XA4,0XF1,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145190XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XEF,0X18,0XBD,0X4D,0XCD,0X8A,0XD5,0XA8,0XDD,0XC7,

145200XDD,0XC7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

145210XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

145220XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X48,0XEE,0X4A,0XB4,0XC7,

145230X6A,0X80,0X52,0X00,0X51,0XE1,0X4A,0X02,0X4A,0X02,0X4A,0X22,0X52,0X02,0X52,0X02,

145240X52,0X02,0X52,0X01,0X4A,0X02,0X4A,0X03,0X49,0XE3,0X9C,0X8F,0XF7,0X9D,0XFF,0XFF,

145250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XBD,0X6E,0XC5,0X4A,

145260XEE,0X2A,0XEE,0X48,0XEE,0X28,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,

145270XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

145280XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

145290XF6,0X47,0XF6,0X27,0XF6,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X69,

145300XD5,0XA8,0X9B,0XE5,0X6A,0X41,0X51,0XE2,0X52,0X23,0X4A,0X03,0X4A,0X03,0X41,0XC3,

145310XAD,0X32,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

145380XFF,0XDE,0XF7,0X39,0XBD,0X6D,0XCD,0X8A,0XD5,0XA8,0XDD,0XC7,0XDD,0XC7,0XDD,0XC7,

145390XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

145400XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X27,

145410XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X48,0XEE,0X4A,0XB4,0XC7,0X6A,0X80,0X52,0X00,

145420X52,0X01,0X52,0X22,0X4A,0X02,0X4A,0X22,0X52,0X02,0X52,0X22,0X52,0X02,0X52,0X22,

145430X4A,0X02,0X4A,0X03,0X49,0XE3,0X9C,0X8F,0XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XBD,0X6E,0XC5,0X4A,0XEE,0X2A,0XEE,0X48,

145450XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X27,

145460XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

145470XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X27,

145480XF6,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X69,0XD5,0XA8,0X9B,0XE4,

145490X6A,0X62,0X5A,0X22,0X5A,0X43,0X52,0X23,0X4A,0X03,0X4A,0X04,0XB5,0X93,0XFF,0XDD,

145500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XFF,0X5A,

145570XC5,0X8E,0XC5,0X8A,0XD5,0XC8,0XDD,0XC7,0XDD,0XC7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,

145580XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

145590XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

145600XEE,0X27,0XEE,0X28,0XEE,0X2A,0XB4,0XC7,0X6A,0X60,0X52,0X00,0X52,0X01,0X52,0X22,

145610X52,0X22,0X52,0X22,0X52,0X02,0X52,0X22,0X52,0X22,0X52,0X22,0X52,0X02,0X4A,0X03,

145620X49,0XE3,0X9C,0X8F,0XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145630XFF,0XFF,0XFF,0XFC,0XBD,0X6E,0XC5,0X4A,0XEE,0X29,0XEE,0X48,0XEE,0X47,0XEE,0X47,

145640XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X27,

145650XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X47,

145660XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,

145670XF6,0X67,0XF6,0X47,0XF6,0X67,0XF6,0X69,0XD5,0X88,0X9B,0XE4,0X6A,0X62,0X5A,0X43,

145680X5A,0X43,0X52,0X44,0X4A,0X03,0X52,0X45,0XC5,0XD5,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

145690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0X7A,0XCD,0XAF,0XC5,0X6A,

145760XD5,0XC8,0XDD,0XE7,0XDD,0XC7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,

145770XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

145780XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,

145790XEE,0X2A,0XB4,0XC7,0X6A,0X60,0X52,0X00,0X52,0X01,0X52,0X22,0X52,0X22,0X52,0X22,

145800X52,0X02,0X52,0X22,0X52,0X22,0X52,0X22,0X52,0X02,0X4A,0X03,0X49,0XE3,0X9C,0X8F,

145810XFF,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,

145820XBD,0X6E,0XC5,0X4A,0XEE,0X29,0XEE,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

145830XF6,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X47,

145840XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

145850XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X47,

145860XF6,0X67,0XEE,0X68,0XD5,0X88,0X9B,0XE4,0X6A,0X82,0X62,0X63,0X5A,0X43,0X52,0X63,

145870X4A,0X03,0X52,0X85,0XCE,0X16,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145940XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0X9B,0XC5,0XAF,0XC5,0X8B,0XD5,0XC8,0XDD,0XC7,

145950XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,

145960XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

145970XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X28,0XEE,0X4A,0XB4,0XA6,

145980X6A,0X60,0X5A,0X00,0X52,0X01,0X52,0X22,0X52,0X22,0X52,0X22,0X52,0X23,0X52,0X22,

145990X52,0X22,0X52,0X22,0X52,0X02,0X49,0XE2,0X4A,0X03,0X9C,0X8F,0XFF,0X9D,0XFF,0XFF,

146000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XC5,0X8E,0XC5,0X49,

146010XEE,0X4A,0XEE,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

146020XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,

146030XF6,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

146040XF6,0X48,0XF6,0X68,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XEE,0X47,0XF6,0X88,0XEE,0X68,

146050XD5,0X87,0X9C,0X04,0X6A,0X81,0X6A,0X83,0X5A,0X63,0X5A,0X84,0X52,0X64,0X5A,0XA6,

146060XD6,0X97,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146130XFF,0XFF,0XFF,0XBC,0XC5,0XAF,0XC5,0X6B,0XD5,0XC8,0XDD,0XC7,0XDD,0XC7,0XE5,0XC7,

146140XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

146150XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,

146160XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X28,0XEE,0X4A,0XB4,0XA6,0X6A,0X60,0X5A,0X00,

146170X52,0X01,0X52,0X22,0X52,0X22,0X52,0X22,0X52,0X23,0X52,0X23,0X52,0X22,0X52,0X22,

146180X52,0X02,0X51,0XE2,0X4A,0X03,0X9C,0X8F,0XFF,0X9D,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

146190XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDC,0XC5,0X8E,0XC5,0X49,0XEE,0X4A,0XEE,0X48,

146200XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

146210XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,

146220XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,

146230XF6,0X47,0XF6,0X47,0XF6,0X68,0XEE,0X47,0XF6,0X88,0XEE,0X68,0XD5,0X87,0X9B,0XE4,

146240X6A,0X81,0X6A,0XA3,0X62,0X83,0X5A,0X84,0X52,0X64,0X5A,0XC6,0XDE,0XB8,0XFF,0XFE,

146250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XBC,

146320XCD,0XCF,0XC5,0X6A,0XDD,0XC9,0XDD,0XA7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,

146330XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,

146340XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

146350XEE,0X47,0XEE,0X28,0XEE,0X4A,0XB4,0XA6,0X6A,0X60,0X5A,0X00,0X52,0X01,0X52,0X22,

146360X52,0X22,0X52,0X22,0X52,0X23,0X52,0X23,0X52,0X22,0X52,0X22,0X52,0X02,0X52,0X02,

146370X4A,0X03,0X9C,0X8F,0XFF,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146380XFF,0XFF,0XFF,0XDC,0XC5,0X8E,0XC5,0X49,0XEE,0X4A,0XEE,0X48,0XF6,0X48,0XF6,0X47,

146390XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

146400XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

146410XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X68,0XF6,0X48,

146420XFE,0X88,0XEE,0X47,0XF6,0X88,0XEE,0X48,0XD5,0X87,0X9B,0XE3,0X72,0XA2,0X6A,0XA3,

146430X62,0XA4,0X62,0XA4,0X52,0X64,0X63,0X07,0XE6,0XF9,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

146440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDC,0XCD,0XF0,0XBD,0X29,

146510XDD,0XC9,0XDD,0XA7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,

146520XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

146530XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X28,

146540XEE,0X4A,0XB4,0XA6,0X6A,0X60,0X5A,0X21,0X52,0X01,0X52,0X22,0X52,0X22,0X52,0X22,

146550X52,0X23,0X52,0X23,0X52,0X22,0X52,0X22,0X52,0X22,0X51,0XE2,0X4A,0X03,0X9C,0X8F,

146560XFF,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,

146570XC5,0X8E,0XC5,0X49,0XEE,0X4A,0XEE,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

146580XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

146590XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

146600XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X68,0XF6,0X48,0XFE,0X88,0XEE,0X47,

146610XF6,0X88,0XEE,0X48,0XCD,0X87,0X93,0XC3,0X72,0XA2,0X72,0XC4,0X6A,0XC4,0X62,0XC5,

146620X5A,0X84,0X73,0X89,0XEF,0X3A,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146690XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDC,0XD6,0X31,0XBD,0X29,0XD5,0XC9,0XDD,0XC8,

146700XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

146710XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

146720XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XB4,0XA6,

146730X6A,0X80,0X5A,0X21,0X52,0X02,0X52,0X42,0X52,0X22,0X52,0X22,0X52,0X23,0X52,0X23,

146740X52,0X22,0X52,0X22,0X52,0X22,0X52,0X03,0X52,0X04,0X9C,0X8E,0XFF,0X9D,0XFF,0XDF,

146750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XC5,0X8E,0XC5,0X49,

146760XEE,0X2A,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

146770XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

146780XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

146790XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X48,0XF6,0X88,0XF6,0X68,0XF6,0X68,0XEE,0X48,

146800XCD,0X87,0X93,0XA2,0X7A,0XE2,0X72,0XC4,0X72,0XE4,0X6A,0XE5,0X5A,0XA5,0X8C,0X2C,

146810XEF,0X3A,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

146880XFF,0XDE,0XFF,0XDC,0XDE,0X92,0XBD,0X29,0XD5,0XA9,0XDD,0XC8,0XDD,0XC7,0XE5,0XC7,

146890XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

146900XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,

146910XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XB4,0XA6,0X6A,0X80,0X5A,0X21,

146920X52,0X02,0X5A,0X42,0X52,0X22,0X52,0X22,0X52,0X23,0X52,0X23,0X52,0X22,0X52,0X22,

146930X52,0X23,0X52,0X03,0X52,0X04,0X9C,0X6E,0XFF,0X9D,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

146940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XC5,0X8E,0XC5,0X49,0XEE,0X2A,0XF6,0X48,

146950XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

146960XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

146970XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

146980XF6,0X68,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XEE,0X48,0XCD,0X67,0X93,0X82,

146990X7B,0X02,0X72,0XE4,0X72,0XE4,0X6A,0XC4,0X5A,0XA5,0X9C,0XCE,0XF7,0X5B,0XFF,0XFE,

147000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDC,

147070XEE,0XF5,0XBD,0X4A,0XD5,0XA9,0XDD,0XC8,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,

147080XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

147090XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,

147100XEE,0X27,0XEE,0X28,0XEE,0X4B,0XB4,0XA6,0X6A,0X81,0X5A,0X21,0X5A,0X22,0X5A,0X43,

147110X52,0X42,0X52,0X22,0X52,0X23,0X52,0X23,0X52,0X22,0X52,0X22,0X52,0X43,0X52,0X03,

147120X52,0X04,0X9C,0X6E,0XFF,0X9D,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147130XFF,0XFE,0XFF,0XFC,0XC5,0X8E,0XC5,0X49,0XEE,0X2A,0XF6,0X48,0XF6,0X48,0XF6,0X48,

147140XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X28,0XF6,0X28,0XF6,0X48,0XF6,0X48,

147150XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

147160XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X48,0XF6,0X48,

147170XF6,0X48,0XF6,0X68,0XF6,0X68,0XEE,0X48,0XCD,0X67,0X8B,0X61,0X7B,0X03,0X7B,0X04,

147180X73,0X05,0X6A,0XE4,0X62,0XC5,0XAD,0X30,0XF7,0X9C,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147250XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XBE,0XFF,0XDD,0XF7,0X37,0XC5,0X6C,

147260XD5,0XA9,0XDD,0XC7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,

147270XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

147280XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,

147290XEE,0X4B,0XB4,0XA6,0X6A,0X81,0X5A,0X21,0X5A,0X22,0X5A,0X43,0X5A,0X42,0X52,0X22,

147300X52,0X23,0X52,0X23,0X52,0X22,0X52,0X23,0X52,0X43,0X52,0X03,0X52,0X04,0X9C,0X6E,

147310XFF,0X9D,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,

147320XC5,0X8E,0XC5,0X49,0XEE,0X2A,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,

147330XF6,0X47,0XF6,0X47,0XF6,0X28,0XF6,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

147340XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

147350XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X68,0XF6,0X48,0XF6,0X68,0XF6,0X47,0XF6,0X88,

147360XF6,0X47,0XEE,0X48,0XCD,0X67,0X8B,0X61,0X83,0X23,0X7B,0X24,0X7B,0X45,0X73,0X05,

147370X62,0XE5,0XBD,0X92,0XFF,0XBC,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147440XFF,0XFF,0XFF,0XFE,0XFF,0XBE,0XFF,0XDD,0XFF,0XB9,0XBD,0X6D,0XCD,0XA9,0XDD,0XC7,

147450XDD,0XC7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE8,

147460XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,

147470XE6,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XB4,0XC6,

147480X6A,0X80,0X62,0X41,0X5A,0X22,0X5A,0X42,0X5A,0X42,0X52,0X43,0X52,0X43,0X52,0X43,

147490X5A,0X43,0X52,0X43,0X52,0X43,0X52,0X23,0X52,0X04,0X9C,0X4E,0XF7,0X7C,0XFF,0XFF,

147500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XC5,0X8F,0XC5,0X49,

147510XEE,0X4A,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,

147520XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

147530XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X47,

147540XF6,0X48,0XFE,0X68,0XF6,0X48,0XF6,0X68,0XEE,0X27,0XF6,0X88,0XF6,0X47,0XEE,0X48,

147550XBC,0XE5,0X93,0XC3,0X83,0X43,0X7B,0X24,0X83,0X86,0X73,0X25,0X73,0X27,0XD6,0X55,

147560XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

147630XFF,0XDF,0XFF,0XDE,0XFF,0XBB,0XC5,0XAE,0XCD,0XA9,0XD5,0XC7,0XDD,0XC7,0XDD,0XC7,

147640XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

147650XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XEE,0X07,

147660XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XBC,0XC6,0X6A,0X80,0X62,0X41,

147670X5A,0X22,0X5A,0X42,0X5A,0X42,0X5A,0X42,0X52,0X43,0X52,0X43,0X5A,0X42,0X52,0X43,

147680X52,0X43,0X52,0X23,0X52,0X04,0X94,0X2E,0XF7,0X7C,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XC5,0X8F,0XC5,0X49,0XEE,0X4A,0XF6,0X48,

147700XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

147710XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

147720XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,

147730XF6,0X68,0XF6,0X68,0XEE,0X47,0XF6,0X88,0XF6,0X68,0XEE,0X49,0XBC,0XE5,0X93,0XC2,

147740X8B,0X64,0X83,0X24,0X83,0X66,0X73,0X25,0X83,0XA9,0XDE,0X96,0XFF,0XDD,0XFF,0XFF,

147750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDE,

147820XFF,0XDC,0XD5,0XF1,0XC5,0X89,0XD5,0XC8,0XDD,0XC7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,

147830XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

147840XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

147850XEE,0X27,0XEE,0X28,0XEE,0X4A,0XBC,0XC6,0X6A,0X80,0X62,0X41,0X5A,0X42,0X5A,0X43,

147860X5A,0X42,0X5A,0X42,0X5A,0X43,0X52,0X43,0X5A,0X42,0X5A,0X43,0X52,0X43,0X52,0X23,

147870X52,0X03,0X94,0X2D,0XF7,0X5C,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147880XFF,0XFF,0XFF,0XFC,0XC5,0X8F,0XC5,0X49,0XEE,0X4A,0XF6,0X48,0XF6,0X48,0XF6,0X48,

147890XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

147900XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

147910XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X68,

147920XF6,0X48,0XF6,0X68,0XF6,0X89,0XEE,0X49,0XB4,0XC4,0X93,0XA2,0X93,0XC5,0X8B,0X65,

147930X83,0X86,0X73,0X26,0X94,0X4B,0XE6,0XD7,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148000XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDE,0XFF,0XDD,0XDE,0X53,

148010XC5,0X69,0XD5,0XE8,0XDD,0XC7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,

148020XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

148030XE5,0XE7,0XE6,0X07,0XE6,0X08,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,

148040XEE,0X4A,0XBC,0XC6,0X6A,0X80,0X62,0X41,0X5A,0X42,0X5A,0X63,0X5A,0X63,0X5A,0X42,

148050X5A,0X43,0X5A,0X43,0X5A,0X43,0X5A,0X43,0X52,0X43,0X52,0X43,0X52,0X03,0X94,0X0D,

148060XF7,0X5B,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,

148070XC5,0X8F,0XC5,0X49,0XEE,0X4A,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

148080XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

148090XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,

148100XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

148110XF6,0X89,0XEE,0X48,0XB4,0X84,0X93,0XC3,0X9C,0X06,0X93,0XC6,0X8B,0X86,0X7B,0X46,

148120XA4,0XCD,0XEF,0X19,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148190XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XE6,0XB4,0XBD,0X4A,0XD5,0XE9,

148200XDD,0XC7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

148210XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,

148220XE6,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XBC,0XC7,

148230X6A,0X80,0X62,0X41,0X5A,0X42,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X43,

148240X5A,0X43,0X5A,0X43,0X52,0X43,0X52,0X43,0X52,0X03,0X8B,0XEC,0XEF,0X5B,0XFF,0XFF,

148250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XC5,0X8F,0XCD,0X4A,

148260XEE,0X4A,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

148270XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

148280XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

148290XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X48,0XF6,0X89,0XF6,0X89,0XE6,0X08,

148300XAC,0X63,0X9B,0XE3,0X9C,0X06,0X93,0XE7,0X8B,0XA7,0X83,0X87,0XB5,0X2F,0XF7,0X7A,

148310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,

148380XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XEF,0X16,0XBD,0X6A,0XD5,0XC9,0XDD,0XC8,0XDD,0XC7,

148390XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

148400XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XEE,0X07,

148410XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XBC,0XC7,0X72,0X80,0X62,0X61,

148420X5A,0X42,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X43,0X5A,0X43,

148430X52,0X42,0X52,0X63,0X52,0X03,0X8B,0XEC,0XEF,0X5B,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XC5,0X8E,0XCD,0X4A,0XEE,0X4A,0XF6,0X48,

148450XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

148460XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

148470XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,

148480XF6,0X48,0XF6,0X68,0XF6,0X48,0XF6,0X89,0XF6,0X89,0XDD,0XE7,0XA4,0X43,0X9C,0X04,

148490X9B,0XE6,0X93,0XE7,0X8B,0XC7,0X8B,0XC8,0XC5,0XB1,0XFF,0XBC,0XFF,0XFF,0XFF,0XFF,

148500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

148570XFF,0XFD,0XFF,0X78,0XC5,0XAC,0XCD,0XC9,0XDD,0XC8,0XDD,0XC7,0XDD,0XC7,0XE5,0XC7,

148580XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

148590XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,

148600XEE,0X27,0XEE,0X28,0XEE,0X4A,0XBC,0XE7,0X72,0XA0,0X62,0X61,0X62,0X42,0X5A,0X63,

148610X62,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X52,0X63,0X5A,0X64,

148620X52,0X03,0X8B,0XCB,0XEF,0X3B,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148630XFF,0XFF,0XFF,0XFC,0XC5,0X8E,0XCD,0X4A,0XEE,0X4A,0XF6,0X48,0XF6,0X48,0XF6,0X47,

148640XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

148650XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

148660XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X48,

148670XF6,0X48,0XF6,0X89,0XF6,0X89,0XD5,0X86,0XA4,0X43,0X9C,0X04,0X9C,0X06,0X93,0XE7,

148680X93,0XE7,0X94,0X29,0XD6,0X54,0XFF,0XDC,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFD,0XFF,0XB9,

148760XCD,0XCD,0XCD,0XAA,0XDD,0XC8,0XDD,0XC7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,

148770XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

148780XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,

148790XEE,0X4A,0XBC,0XE6,0X72,0XA0,0X62,0X61,0X62,0X42,0X62,0X63,0X5A,0X83,0X5A,0X63,

148800X5A,0X63,0X5A,0X63,0X62,0X63,0X5A,0X83,0X5A,0X63,0X5A,0X84,0X52,0X03,0X83,0XAB,

148810XEF,0X1A,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,

148820XC5,0X8E,0XCD,0X49,0XEE,0X4A,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,

148830XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

148840XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,

148850XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XFE,0X68,0XF6,0X48,0XF6,0X89,0XF6,0X89,

148860XF6,0X6A,0XCD,0X46,0XAC,0X64,0X9C,0X24,0XA4,0X46,0X9C,0X07,0X94,0X08,0X9C,0X6B,

148870XE6,0XD6,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148940XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XDA,0XDE,0X50,0XC5,0X6A,

148950XD5,0XC9,0XDD,0XE8,0XDD,0XE7,0XE5,0XC6,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,

148960XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,

148970XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X48,0XEE,0X4A,0XBC,0XE7,

148980X72,0XA0,0X62,0X40,0X62,0X82,0X62,0X83,0X5A,0X63,0X5A,0X83,0X5A,0X83,0X5A,0X63,

148990X5A,0X63,0X5A,0X83,0X5A,0X83,0X5A,0X63,0X5A,0X23,0X83,0XAA,0XE7,0X1A,0XFF,0XFE,

149000XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XC5,0X8E,0XCD,0X6A,

149010XEE,0X49,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

149020XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

149030XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

149040XFE,0X68,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XF6,0X69,0XFE,0X8A,0XF6,0X6B,0XBC,0XE6,

149050XAC,0X84,0XA4,0X65,0XA4,0X46,0X9C,0X27,0X94,0X08,0XB5,0X0E,0XF7,0X59,0XFF,0XFE,

149060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149130XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XE6,0XB3,0XC5,0X6A,0XD5,0XC9,0XDD,0XC7,

149140XDD,0XE7,0XDD,0XC6,0XE5,0XC7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

149150XE5,0XE7,0XED,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,

149160XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X47,0XEE,0X4A,0XC5,0X07,0X72,0XA0,0X62,0X40,

149170X62,0X82,0X62,0X83,0X5A,0X63,0X5A,0X83,0X5A,0X83,0X5A,0X83,0X62,0X83,0X5A,0X83,

149180X5A,0X83,0X5A,0X83,0X5A,0X23,0X83,0X8A,0XE6,0XF9,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

149190XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFC,0XC5,0X8E,0XCD,0X6A,0XEE,0X49,0XF6,0X47,

149200XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

149210XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,

149220XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X47,0XFE,0X67,0XF6,0X47,

149230XF6,0X67,0XF6,0X68,0XF6,0X69,0XFE,0XAB,0XEE,0X2A,0XBC,0XE6,0XAC,0XA5,0XAC,0XA6,

149240XA4,0X66,0XA4,0X67,0X9C,0X49,0XC5,0X91,0XFF,0X9B,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149320XFF,0XDE,0XFF,0XFC,0XF7,0X56,0XC5,0X8B,0XD5,0XA9,0XDD,0XC7,0XDD,0XE7,0XE5,0XE7,

149330XE5,0XC7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XED,0XE7,

149340XE5,0XE7,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

149350XEE,0X27,0XEE,0X27,0XEE,0X4A,0XC5,0X07,0X72,0XC1,0X62,0X41,0X62,0X82,0X62,0X83,

149360X62,0X83,0X62,0X83,0X62,0X83,0X62,0X83,0X62,0X83,0X62,0X83,0X5A,0X83,0X5A,0X83,

149370X5A,0X43,0X7B,0X69,0XE6,0XD9,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149380XFF,0XFF,0XFF,0XFC,0XC5,0X8E,0XCD,0X6A,0XEE,0X49,0XF6,0X48,0XF6,0X47,0XF6,0X47,

149390XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

149400XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,

149410XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X68,

149420XFE,0X89,0XFE,0XAB,0XDD,0XC9,0XBC,0XE6,0XAC,0XA5,0XB5,0X07,0XA4,0X86,0XAC,0XA8,

149430XA4,0X6A,0XD6,0X53,0XFF,0XDC,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149500XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,

149510XFF,0XD8,0XCD,0XCD,0XD5,0XCA,0XDD,0XC8,0XE5,0XE7,0XE5,0XE7,0XE5,0XC7,0XE5,0XC8,

149520XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE5,0XE7,0XED,0XE7,0XEE,0X07,0XEE,0X07,

149530XEE,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X27,

149540XEE,0X4A,0XC5,0X27,0X72,0XC1,0X62,0X61,0X6A,0XA2,0X62,0X83,0X62,0X83,0X62,0X83,

149550X62,0X83,0X62,0XA3,0X62,0X83,0X62,0X83,0X5A,0XA3,0X5A,0X83,0X5A,0X43,0X7B,0X49,

149560XDE,0XB8,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,

149570XC5,0X8E,0XCD,0X6A,0XEE,0X49,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

149580XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

149590XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,

149600XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XFE,0XAA,0XFE,0XAB,

149610XD5,0X88,0XBC,0XE6,0XB4,0XC7,0XB4,0XE7,0XB4,0XC7,0XA4,0X87,0XAC,0XEB,0XE6,0XD6,

149620XFF,0XFD,0XFF,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149690XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFA,0XD6,0X0F,

149700XD5,0XAA,0XDD,0XC8,0XE5,0XE7,0XE5,0XE7,0XE5,0XC7,0XE5,0XC8,0XE5,0XE8,0XE5,0XE7,

149710XE5,0XE7,0XE6,0X07,0XEE,0X07,0XE5,0XE7,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

149720XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X4A,0XCD,0X48,

149730X72,0XC1,0X62,0X61,0X6A,0XA3,0X62,0XA3,0X62,0X83,0X62,0X83,0X62,0XA3,0X62,0XA3,

149740X62,0X83,0X62,0X83,0X62,0XA3,0X5A,0X83,0X5A,0X43,0X73,0X49,0XDE,0XB8,0XFF,0XDE,

149750XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XC5,0X6E,0XCD,0X6A,

149760XEE,0X4A,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

149770XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

149780XF6,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,

149790XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XFE,0XCA,0XF6,0X8A,0XCD,0X67,0XC5,0X07,

149800XBC,0XE8,0XBC,0XE8,0XB4,0XE7,0XAC,0XC8,0XBD,0X4D,0XFF,0X79,0XFF,0XDD,0XFF,0XBF,

149810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

149880XF7,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XFB,0XE6,0XB2,0XD5,0XAA,0XDD,0XA8,

149890XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE8,0XE6,0X07,0XE6,0X07,

149900XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

149910XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X28,0XEE,0X6A,0XCD,0X48,0X7A,0XE1,0X62,0X61,

149920X6A,0XA3,0X62,0X83,0X62,0X83,0X62,0XA3,0X62,0XA3,0X62,0XA3,0X62,0XA3,0X62,0X83,

149930X62,0XA3,0X5A,0X83,0X5A,0X44,0X73,0X08,0XDE,0X98,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

149940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XC5,0X6F,0XCD,0X6A,0XEE,0X4A,0XF6,0X48,

149950XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

149960XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X48,0XF6,0X47,

149970XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

149980XF6,0X67,0XF6,0X88,0XFE,0XCA,0XEE,0X6A,0XCD,0X47,0XC5,0X27,0XC5,0X08,0XBC,0XE8,

149990XB4,0XE7,0XB4,0XE9,0XCD,0XF0,0XFF,0XDB,0XFF,0XBD,0XFF,0XBF,0XFF,0XFF,0XFF,0XFF,

150000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

150070XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0X56,0XD5,0XCB,0XDD,0XC8,0XE5,0XC7,0XE5,0XE7,

150080XED,0XE7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE8,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,

150090XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

150100XEE,0X27,0XEE,0X28,0XF6,0X6A,0XCD,0X48,0X7A,0XE1,0X6A,0X61,0X6A,0X83,0X62,0X83,

150110X62,0X83,0X62,0XA3,0X62,0XA3,0X62,0XA2,0X6A,0XA3,0X62,0XA3,0X62,0XA3,0X62,0X83,

150120X5A,0X44,0X73,0X08,0XDE,0X77,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

150130XFF,0XFF,0XFF,0XFD,0XC5,0X8F,0XCD,0X8B,0XEE,0X4A,0XF6,0X48,0XF6,0X47,0XF6,0X47,

150140XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

150150XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X67,

150160XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X87,0XF6,0X67,0XF6,0X68,0XFE,0XA9,

150170XFE,0XCA,0XE6,0X08,0XCD,0X26,0XCD,0X47,0XC5,0X28,0XB4,0XC7,0XC5,0X48,0XAC,0XC8,

150180XEE,0XD4,0XFF,0X9A,0XFF,0XDE,0XFF,0XBF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XDF,0XFF,0XFF,0XFF,0XFF,

150260XFF,0XDC,0XFF,0XB9,0XDD,0XED,0XDD,0XE9,0XE5,0XE7,0XE5,0XE7,0XED,0XE7,0XED,0XE7,

150270XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

150280XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,

150290XF6,0X6A,0XCD,0X68,0X7A,0XE1,0X6A,0X61,0X6A,0X83,0X62,0X83,0X62,0X83,0X62,0XA3,

150300X62,0XA3,0X62,0XA3,0X6A,0XA3,0X62,0X83,0X62,0XA3,0X62,0X63,0X5A,0X44,0X72,0XE8,

150310XD6,0X77,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XDC,

150320XC5,0X8F,0XCD,0X8B,0XEE,0X4A,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

150330XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

150340XF6,0X47,0XF6,0X68,0XF6,0X48,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

150350XF6,0X67,0XF6,0X67,0XFE,0X88,0XF6,0X67,0XF6,0X88,0XFE,0XA9,0XFE,0XCA,0XDD,0XE8,

150360XC5,0X26,0XCD,0X47,0XCD,0X69,0XBD,0X28,0XBD,0X28,0XBD,0X4A,0XF7,0X36,0XFF,0XDC,

150370XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XDA,

150450XEE,0XD1,0XDD,0XE9,0XDD,0XE7,0XE6,0X07,0XED,0XE6,0XEE,0X07,0XE5,0XE7,0XE6,0X07,

150460XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

150470XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X49,0XEE,0X4A,0XD5,0X88,

150480X83,0X01,0X6A,0X61,0X62,0X82,0X62,0X83,0X62,0X83,0X62,0XA3,0X62,0X82,0X62,0XA3,

150490X62,0XA3,0X62,0X83,0X6A,0XA3,0X62,0X84,0X5A,0X64,0X6A,0XC7,0XD6,0X56,0XFF,0XDE,

150500XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XC5,0X6F,0XCD,0X8B,

150510XEE,0X4A,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

150520XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

150530XF6,0X48,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

150540XF6,0X68,0XEE,0X47,0XF6,0X88,0XFE,0XEA,0XFE,0XAA,0XD5,0X86,0XCD,0X46,0XCD,0X47,

150550XCD,0X88,0XC5,0X48,0XBD,0X48,0XCD,0XEE,0XFF,0X78,0XFF,0XDD,0XFF,0XBE,0XFF,0XFF,

150560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XFF,0X33,0XDD,0XEB,

150640XE6,0X08,0XE5,0XE7,0XED,0XE6,0XEE,0X06,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,

150650XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

150660XEE,0X27,0XEE,0X28,0XEE,0X28,0XF6,0X49,0XEE,0X49,0XD5,0XA8,0X83,0X21,0X62,0X60,

150670X62,0X62,0X62,0X83,0X62,0X83,0X62,0XA3,0X62,0X82,0X62,0XA3,0X62,0XA3,0X6A,0XA3,

150680X62,0X83,0X62,0XA4,0X62,0X64,0X62,0XA7,0XCE,0X15,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,

150690XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XDC,0XC5,0X6E,0XCD,0X8A,0XEE,0X4A,0XF6,0X48,

150700XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

150710XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XF6,0X48,0XF6,0X68,

150720XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X67,0XF6,0X47,

150730XFE,0XA9,0XFE,0XEA,0XF6,0X69,0XD5,0X86,0XD5,0X67,0XCD,0X67,0XCD,0X68,0XC5,0X89,

150740XBD,0X49,0XE6,0XB2,0XFF,0XBA,0XFF,0XDE,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,

150750XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XFF,0X76,0XDE,0X2D,0XDD,0XE9,0XE5,0XE7,

150830XE5,0XE6,0XEE,0X06,0XEE,0X06,0XEE,0X06,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

150840XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,

150850XEE,0X28,0XF6,0X49,0XEE,0X49,0XDD,0XC8,0X8B,0X41,0X62,0X40,0X62,0X62,0X62,0X63,

150860X62,0X83,0X62,0X83,0X62,0XA3,0X62,0XA3,0X62,0XA3,0X62,0XA3,0X62,0X83,0X62,0X83,

150870X62,0X84,0X5A,0X85,0XC5,0XD4,0XFF,0XBD,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,

150880XFF,0XFF,0XFF,0XDC,0XC5,0X8E,0XCD,0X8A,0XEE,0X4A,0XF6,0X48,0XF6,0X48,0XF6,0X68,

150890XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,

150900XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X68,0XF6,0X48,0XF6,0X67,0XF6,0X67,0XF6,0X67,

150910XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X88,0XF6,0X47,0XF6,0X88,0XFE,0XA9,0XFE,0XCA,

150920XEE,0X07,0XD5,0X86,0XD5,0X87,0XD5,0X87,0XCD,0X67,0XCD,0X89,0XBD,0X6B,0XFF,0X76,

150930XFF,0XFC,0XFF,0XDE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

150940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151010XFF,0XFF,0XFF,0XFD,0XFF,0X99,0XEE,0X91,0XD5,0XEA,0XE6,0X28,0XE5,0XE6,0XEE,0X26,

151020XEE,0X06,0XEE,0X06,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,

151030XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XF6,0X49,

151040XEE,0X49,0XDD,0XE9,0X8B,0X62,0X62,0X40,0X62,0X42,0X62,0X63,0X62,0X83,0X62,0X83,

151050X62,0XA3,0X62,0X83,0X62,0X83,0X62,0X83,0X62,0X83,0X62,0X63,0X62,0X84,0X5A,0X45,

151060XBD,0XB3,0XFF,0X9C,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XDC,

151070XC5,0X6E,0XCD,0X8A,0XF6,0X4A,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X67,

151080XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,

151090XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

151100XF6,0X68,0XF6,0X68,0XF6,0X68,0XFE,0XA9,0XFE,0XC9,0XFE,0XA9,0XE5,0XC7,0XDD,0XC7,

151110XDD,0XA7,0XD5,0XA8,0XCD,0X88,0XCD,0XAA,0XCE,0X0E,0XFF,0XD9,0XFF,0XDC,0XFF,0XDE,

151120XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

151200XFF,0X9B,0XF7,0X35,0XD5,0XEC,0XE6,0X29,0XE6,0X07,0XEE,0X06,0XEE,0X06,0XEE,0X06,

151210XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

151220XEE,0X27,0XEE,0X47,0XF6,0X27,0XF6,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X48,0XDE,0X09,

151230X8B,0X82,0X5A,0X20,0X62,0X42,0X62,0X63,0X62,0X63,0X62,0X83,0X62,0X83,0X62,0X83,

151240X62,0X84,0X62,0X63,0X62,0X83,0X62,0X83,0X5A,0X63,0X5A,0X64,0XB5,0X72,0XF7,0X9C,

151250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDC,0XBD,0X4D,0XD5,0XAA,

151260XF6,0X49,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XFE,0X47,0XFE,0X47,

151270XFE,0X47,0XFE,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,

151280XFE,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X87,0XF6,0X87,0XF6,0X68,0XF6,0X68,

151290XF6,0X68,0XFE,0XA9,0XFE,0XA9,0XFE,0X89,0XE5,0XE6,0XE6,0X08,0XE5,0XE8,0XDD,0XC8,

151300XD5,0XC9,0XCD,0XCC,0XEE,0XF4,0XFF,0XFB,0XFF,0XDD,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

151310XFF,0XDE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XBC,0XFF,0X78,

151390XDE,0X4E,0XDD,0XE9,0XEE,0X28,0XE5,0XE5,0XEE,0X26,0XEE,0X06,0XEE,0X07,0XEE,0X27,

151400XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,

151410XF6,0X27,0XF6,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X48,0XE6,0X09,0X93,0XC2,0X5A,0X20,

151420X62,0X42,0X62,0X43,0X5A,0X63,0X62,0X63,0X62,0X83,0X62,0X83,0X62,0X84,0X62,0X84,

151430X5A,0X62,0X62,0XA3,0X52,0X42,0X5A,0X64,0XA4,0XCF,0XF7,0X9B,0XFF,0XDF,0XFF,0XFF,

151440XFF,0XFF,0XFF,0XFF,0XFF,0XBE,0XFF,0XBB,0XBD,0X2C,0XD5,0XEA,0XF6,0X49,0XF6,0X47,

151450XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,

151460XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XF6,0X67,

151470XF6,0X67,0XF6,0X67,0XF6,0X87,0XF6,0X87,0XF6,0X68,0XF6,0X68,0XFE,0X89,0XFE,0XAA,

151480XFE,0X89,0XF6,0X68,0XE5,0XE7,0XEE,0X28,0XE5,0XE8,0XDD,0XC8,0XD5,0XCA,0XD6,0X2E,

151490XFF,0XB8,0XFF,0XFC,0XFF,0XFF,0XFF,0XFF,0XF7,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XBE,0XFF,0XBA,0XEE,0XD1,0XDE,0X0A,

151580XE6,0X28,0XE5,0XE6,0XEE,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X27,

151590XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XF6,0X47,0XF6,0X27,0XF6,0X48,

151600XF6,0X48,0XF6,0X48,0XEE,0X68,0XE6,0X29,0X9C,0X03,0X5A,0X20,0X62,0X42,0X5A,0X43,

151610X5A,0X43,0X5A,0X63,0X62,0X83,0X5A,0X63,0X62,0X64,0X5A,0X63,0X5A,0X42,0X62,0X83,

151620X52,0X43,0X52,0X43,0X8C,0X2C,0XF7,0X5B,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

151630XFF,0XBE,0XFF,0X9B,0XB5,0X0B,0XDE,0X0A,0XEE,0X49,0XF6,0X47,0XF6,0X47,0XF6,0X47,

151640XF6,0X47,0XF6,0X67,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,

151650XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

151660XF6,0X67,0XF6,0X87,0XF6,0X68,0XF6,0X68,0XFE,0X89,0XFE,0XAA,0XFE,0X89,0XF6,0X48,

151670XEE,0X07,0XEE,0X48,0XE5,0XE8,0XE5,0XE9,0XDE,0X0B,0XEE,0XD1,0XFF,0XDA,0XFF,0XFE,

151680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XF7,0X34,0XE6,0X4D,0XE6,0X08,0XEE,0X27,

151770XEE,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

151780XEE,0X27,0XEE,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X27,0XF6,0X48,0XF6,0X48,0XF6,0X48,

151790XF6,0X68,0XEE,0X49,0XA4,0X44,0X62,0X40,0X5A,0X42,0X5A,0X23,0X5A,0X43,0X5A,0X43,

151800X5A,0X63,0X5A,0X63,0X5A,0X64,0X5A,0X43,0X5A,0X42,0X5A,0X42,0X5A,0X63,0X49,0XE2,

151810X7B,0XAA,0XEF,0X3A,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDE,0XFF,0X9A,

151820XB4,0XEA,0XE6,0X2A,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

151830XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XF6,0X67,0XF6,0X67,

151840XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

151850XF6,0X68,0XFE,0X89,0XFE,0XAA,0XFE,0XAA,0XFE,0X89,0XF6,0X48,0XEE,0X28,0XF6,0X49,

151860XEE,0X08,0XE6,0X2B,0XDE,0X4E,0XFF,0X76,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

151870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151950XFF,0XFF,0XFF,0XFD,0XFF,0X78,0XEE,0X6F,0XDD,0XE9,0XEE,0X27,0XEE,0X07,0XF6,0X27,

151960XEE,0X26,0XF6,0X27,0XF6,0X27,0XF6,0X07,0XF6,0X27,0XF6,0X27,0XEE,0X27,0XF6,0X48,

151970XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X27,0XF6,0X47,0XF6,0X68,0XF6,0X48,0XEE,0X49,

151980XAC,0X44,0X6A,0X80,0X5A,0X01,0X5A,0X23,0X5A,0X43,0X5A,0X23,0X5A,0X42,0X5A,0X42,

151990X5A,0X43,0X5A,0X43,0X52,0X23,0X52,0X43,0X52,0X23,0X4A,0X03,0X6B,0X09,0XEF,0X1A,

152000XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBE,0XF7,0X17,0XBD,0X2A,0XE6,0X29,

152010XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

152020XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

152030XF6,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X68,0XFE,0X89,

152040XFE,0XAA,0XFE,0XAA,0XFE,0X89,0XF6,0X48,0XF6,0X69,0XEE,0X29,0XEE,0X4A,0XE6,0X0C,

152050XEE,0XF3,0XFF,0XBA,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

152060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XF7,0XFF,0XFF,0XFE,

152140XFF,0XBB,0XF6,0XF3,0XE6,0X2B,0XEE,0X48,0XEE,0X27,0XEE,0X27,0XEE,0X26,0XF6,0X26,

152150XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X27,0XF6,0X48,0XF6,0X27,0XF6,0X27,

152160XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X48,0XF6,0X4A,0XBC,0XC6,0X7A,0XC1,

152170X5A,0X01,0X52,0X02,0X52,0X23,0X52,0X23,0X5A,0X42,0X5A,0X42,0X52,0X22,0X52,0X23,

152180X52,0X44,0X4A,0X03,0X52,0X23,0X49,0XE3,0X5A,0X87,0XDE,0X98,0XFF,0XDE,0XFF,0XFF,

152190XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XEE,0XB5,0XBD,0X29,0XEE,0X69,0XF6,0X67,0XF6,0X67,

152200XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

152210XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,

152220XFE,0X87,0XFE,0X87,0XF6,0X67,0XF6,0X67,0XFE,0X88,0XFE,0XA9,0XFE,0XAA,0XFE,0X89,

152230XFE,0X89,0XEE,0X28,0XF6,0X8A,0XE6,0X29,0XEE,0X2B,0XEE,0X6E,0XF7,0X56,0XFF,0XDB,

152240XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

152250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152320XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XF7,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDC,0XFF,0X57,

152330XEE,0X6E,0XE6,0X29,0XEE,0X47,0XEE,0X26,0XEE,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

152340XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X47,0XF6,0X27,0XF6,0X47,

152350XF6,0X47,0XFE,0X68,0XF6,0X48,0XF6,0X6A,0XC4,0XE6,0X7B,0X01,0X5A,0X00,0X52,0X02,

152360X52,0X23,0X52,0X23,0X52,0X22,0X52,0X22,0X52,0X02,0X52,0X02,0X52,0X24,0X49,0XE2,

152370X52,0X23,0X49,0XE2,0X49,0XE4,0XC5,0XF5,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

152380XFF,0XDD,0XD6,0X32,0XC5,0X69,0XEE,0X69,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

152390XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

152400XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XF6,0X87,0XF6,0X87,

152410XF6,0X67,0XF6,0X87,0XFE,0X88,0XFE,0XAA,0XFE,0X8A,0XFE,0X69,0XF6,0X68,0XF6,0X68,

152420XF6,0X89,0XEE,0X6A,0XE6,0X4B,0XF6,0XF1,0XFF,0XB9,0XFF,0XFC,0XFF,0XDE,0XFF,0XFF,

152430XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152510XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDD,0XFF,0XBA,0XEE,0XD1,0XE6,0X4B,

152520XEE,0X27,0XEE,0X46,0XF6,0X27,0XEE,0X27,0XF6,0X28,0XF6,0X48,0XF6,0X27,0XF6,0X27,

152530XF6,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X27,0XF6,0X48,0XF6,0X47,0XFE,0X88,

152540XF6,0X68,0XFE,0X8A,0XCD,0X47,0X8B,0X42,0X62,0X20,0X51,0XE1,0X52,0X03,0X52,0X03,

152550X52,0X02,0X52,0X22,0X52,0X02,0X4A,0X02,0X4A,0X03,0X4A,0X03,0X4A,0X02,0X4A,0X02,

152560X39,0X82,0XAD,0X11,0XFF,0XDD,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XFF,0XFC,0XCD,0XF0,

152570XCD,0X68,0XEE,0X48,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

152580XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

152590XFE,0X67,0XFE,0X87,0XF6,0X86,0XF6,0X86,0XF6,0X86,0XF6,0X86,0XF6,0X87,0XF6,0X88,

152600XFE,0XA9,0XFE,0XAA,0XFE,0X6A,0XFE,0X69,0XF6,0X48,0XFE,0X89,0XEE,0X69,0XEE,0X8B,

152610XE6,0X8E,0XFF,0X75,0XFF,0XFA,0XFF,0XFD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

152620XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152700XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XFC,0XFF,0X56,0XE6,0X8F,0XE6,0X28,0XF6,0X67,

152710XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X27,

152720XFE,0X47,0XFE,0X67,0XF6,0X47,0XF6,0X68,0XF6,0X47,0XFE,0X88,0XF6,0X48,0XFE,0X69,

152730XE5,0XC9,0X9B,0XC3,0X62,0X40,0X51,0XE0,0X52,0X02,0X51,0XE2,0X52,0X02,0X52,0X23,

152740X4A,0X02,0X4A,0X02,0X41,0XE2,0X4A,0X03,0X41,0XE2,0X41,0XE2,0X39,0X81,0X83,0XCC,

152750XFF,0XBD,0XF7,0XBE,0XFF,0XFF,0XFF,0XFD,0XFF,0XBA,0XCD,0XCE,0XDD,0XEA,0XE6,0X07,

152760XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

152770XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XF6,0X67,0XFE,0X87,

152780XFE,0X86,0XF6,0X86,0XF6,0X86,0XF6,0X86,0XF6,0XA7,0XFE,0XA8,0XFE,0XA9,0XFE,0XAA,

152790XFE,0X8A,0XFE,0X69,0XFE,0X69,0XF6,0X8A,0XEE,0X6A,0XE6,0X6D,0XF7,0X12,0XFF,0XB8,

152800XFF,0XDC,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

152810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

152890XFF,0XDD,0XFF,0XFC,0XFF,0XDA,0XF7,0X13,0XE6,0X4A,0XEE,0X47,0XEE,0X27,0XF6,0X27,

152900XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XFE,0X47,0XFE,0X27,0XFE,0X47,0XF6,0X47,

152910XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X68,0XF6,0X47,0XFE,0X69,0XEE,0X09,0XAC,0X44,

152920X72,0X80,0X51,0XE0,0X52,0X01,0X51,0XE2,0X49,0XE2,0X49,0XC2,0X49,0XE2,0X49,0XE2,

152930X4A,0X03,0X41,0XC2,0X4A,0X02,0X41,0XC1,0X41,0XC2,0X5A,0X66,0XF7,0X5B,0XFF,0XFE,

152940XFF,0XFE,0XFF,0XFC,0XF7,0X78,0XBD,0X4C,0XDD,0XC9,0XF6,0X68,0XF6,0X67,0XF6,0X67,

152950XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

152960XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XF6,0X67,0XFE,0X87,0XFE,0X86,0XF6,0X86,

152970XF6,0X86,0XF6,0XA7,0XF6,0XA8,0XFE,0XA8,0XFE,0X89,0XFE,0X8A,0XFE,0X8A,0XFE,0X8A,

152980XF6,0X69,0XF6,0X8B,0XE6,0X6C,0XEE,0XD0,0XFF,0X97,0XFF,0XDB,0XFF,0XDD,0XFF,0XFF,

152990XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

153000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,

153080XFF,0XFC,0XFF,0X97,0XEE,0XAD,0XE6,0X49,0XEE,0X27,0XF6,0X47,0XF6,0X48,0XF6,0X47,

153090XF6,0X47,0XF6,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

153100XFE,0X67,0XFE,0X67,0XFE,0X47,0XFE,0X68,0XF6,0X29,0XC4,0XE5,0X83,0X41,0X5A,0X20,

153110X52,0X01,0X52,0X01,0X52,0X02,0X49,0XC2,0X49,0XE2,0X4A,0X03,0X52,0X04,0X41,0XA2,

153120X4A,0X22,0X49,0XE1,0X49,0XE3,0X49,0XC3,0XCD,0XF6,0XFF,0XDE,0XFF,0XFE,0XFF,0XFC,

153130XE6,0XD4,0XBD,0X0A,0XE6,0X09,0XFE,0X69,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

153140XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

153150XF6,0X67,0XF6,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X86,0XF6,0X86,0XF6,0X87,0XFE,0X87,

153160XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0X8A,0XFE,0X8A,0XFE,0X8B,0XF6,0X6A,0XF6,0XAC,

153170XEE,0XAF,0XFF,0X75,0XFF,0XDA,0XFF,0XFD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153180XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFB,

153270XF7,0X12,0XEE,0X8C,0XEE,0X29,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X47,

153280XFE,0X27,0XFE,0X47,0XFE,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,

153290XFE,0X47,0XFE,0X68,0XFE,0X49,0XDD,0X87,0X9C,0X03,0X6A,0X80,0X5A,0X20,0X52,0X21,

153300X5A,0X22,0X52,0X02,0X52,0X23,0X52,0X03,0X52,0X04,0X49,0XC2,0X52,0X23,0X52,0X02,

153310X52,0X02,0X49,0XA3,0X8B,0XED,0XFF,0XBD,0XFF,0XFD,0XFF,0XDA,0XDE,0X71,0XC5,0X4A,

153320XF6,0X4A,0XFE,0X48,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

153330XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XFE,0X87,

153340XFE,0X87,0XFE,0X87,0XF6,0X67,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,

153350XFE,0X89,0XFE,0XAA,0XFE,0X8A,0XF6,0X6B,0XF6,0X8C,0XEE,0X8E,0XF7,0X33,0XFF,0XD8,

153360XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

153370XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153450XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0X97,0XF6,0XF1,

153460XE6,0X4B,0XEE,0X48,0XF6,0X67,0XFE,0X66,0XFE,0X46,0XFE,0X47,0XFE,0X47,0XFE,0X46,

153470XFE,0X67,0XF6,0X46,0XF6,0X67,0XF6,0X67,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X68,

153480XFE,0X89,0XE5,0XE8,0XBC,0XC5,0X7B,0X20,0X5A,0X20,0X5A,0X40,0X62,0X62,0X5A,0X22,

153490X5A,0X43,0X5A,0X43,0X5A,0X44,0X5A,0X23,0X5A,0X63,0X5A,0X42,0X5A,0X22,0X62,0X64,

153500X62,0X46,0XE6,0X97,0XFF,0XDB,0XFF,0X77,0XD5,0XEE,0XD5,0X8A,0XFE,0X8B,0XF6,0X27,

153510XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

153520XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XF6,0X67,0XF6,0X87,0XF6,0X67,

153530XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

153540XF6,0X6A,0XEE,0X8C,0XEE,0XAE,0XEE,0XF1,0XFF,0XD7,0XFF,0XFB,0XFF,0XFD,0XFF,0XDF,

153550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

153560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153640XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XBA,0XFF,0X55,0XEE,0X8E,0XEE,0X6A,

153650XF6,0X67,0XFE,0X86,0XFE,0X46,0XFE,0X46,0XFE,0X46,0XFE,0X26,0XFE,0X67,0XF6,0X67,

153660XFE,0X67,0XF6,0X67,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X69,

153670XD5,0X87,0XA4,0X43,0X72,0XC0,0X62,0X80,0X6A,0XA2,0X6A,0XA3,0X6A,0XA3,0X6A,0XA3,

153680X6A,0XC4,0X6A,0XC4,0X6A,0XA2,0X72,0XC3,0X72,0XC3,0X83,0X26,0X6A,0X85,0X9C,0X2B,

153690XFF,0X56,0XF7,0X34,0XC5,0X29,0XE5,0XEA,0XFE,0X6A,0XFE,0X27,0XFE,0X67,0XFE,0X67,

153700XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

153710XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XF6,0X87,0XF6,0X87,0XF6,0X68,0XFE,0X69,

153720XFE,0X69,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0XA8,0XFE,0XCA,0XF6,0X8B,0XEE,0XAE,

153730XF7,0X12,0XF7,0X76,0XFF,0XFA,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

153740XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153830XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XB9,0XF7,0X13,0XEE,0X8C,0XEE,0X48,0XF6,0X66,

153840XF6,0X45,0XFE,0X45,0XFE,0X67,0XFE,0X47,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XF6,0X67,

153850XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XE5,0XE7,0XC5,0X66,

153860X83,0X60,0X7B,0X21,0X7B,0X63,0X73,0X02,0X83,0X64,0X7B,0X03,0X83,0X44,0X8B,0X85,

153870X7B,0X23,0X8B,0X84,0X93,0X84,0X8B,0X64,0X93,0XA7,0X83,0X45,0XCD,0XAD,0XD5,0XCC,

153880XD5,0X88,0XF6,0X8A,0XEE,0X07,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

153890XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

153900XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X68,0XFE,0X69,0XFE,0X69,0XFE,0X68,

153910XFE,0X87,0XFE,0XA8,0XFE,0XA8,0XF6,0XAA,0XEE,0X8D,0XF6,0XF1,0XFF,0X97,0XFF,0XDA,

153920XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

154020XFF,0XFE,0XFF,0XFB,0XFF,0X97,0XEE,0XD0,0XEE,0X6B,0XF6,0X68,0XF6,0X66,0XFE,0X46,

154030XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XF6,0X67,0XFE,0X87,0XFE,0X67,

154040XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XEE,0X68,0XEE,0X49,0XAC,0X84,0X93,0XC2,

154050X93,0XE3,0X93,0XC4,0X93,0XA4,0X93,0XC4,0X93,0XC4,0X9C,0X05,0X9B,0XE4,0X9C,0X04,

154060X9B,0XE4,0X9B,0XE4,0X9B,0XC5,0X9B,0XE5,0X9B,0XE4,0XB4,0XA5,0XE6,0X09,0XF6,0X69,

154070XF6,0X67,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

154080XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,

154090XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X89,0XFE,0XA8,0XFE,0XA9,

154100XF6,0XA9,0XEE,0X8B,0XF6,0XF0,0XFF,0X55,0XFF,0XDB,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

154110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,

154210XFF,0XDA,0XFF,0X56,0XEE,0XCF,0XEE,0X6B,0XF6,0X68,0XF6,0X67,0XF6,0X47,0XF6,0X47,

154220XFE,0X67,0XFE,0X67,0XFE,0X88,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,

154230XFE,0X67,0XFE,0X87,0XF6,0X68,0XF6,0XAA,0XDE,0X29,0XB5,0X06,0X9C,0X24,0XA4,0X85,

154240XAC,0XA6,0XAC,0X65,0XAC,0X65,0XAC,0X64,0XA4,0X02,0XA4,0X02,0XA4,0X02,0X9B,0XC1,

154250X9B,0XC2,0X8B,0X40,0XA4,0X02,0XC5,0X05,0XF6,0X48,0XFE,0XA8,0XF6,0X87,0XF6,0X86,

154260XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

154270XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X67,

154280XFE,0X88,0XFE,0X89,0XFE,0XA9,0XFE,0XCA,0XFE,0XAA,0XF6,0XAA,0XEE,0XAC,0XEE,0XD0,

154290XFF,0X55,0XFF,0XBA,0XFF,0XDD,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154390XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XDA,

154400XF7,0X34,0XE6,0X6D,0XEE,0X49,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XFE,0X48,0XFE,0X68,

154410XFE,0X88,0XF6,0X67,0XF6,0X87,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,

154420XF6,0X67,0XF6,0X89,0XFF,0X2C,0XEE,0XAB,0XC5,0X67,0XAC,0XC5,0XAC,0X84,0XAC,0X84,

154430XA4,0X22,0XA4,0X01,0XAC,0X42,0XA4,0X21,0X9B,0XE0,0X9B,0XC0,0X93,0XA0,0X9B,0XA0,

154440XC4,0XC3,0XEE,0X07,0XFE,0X88,0XF6,0X67,0XFE,0XA7,0XF6,0X66,0XF6,0X67,0XFE,0X67,

154450XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

154460XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0XA9,

154470XFE,0XCA,0XFE,0XAB,0XEE,0X8B,0XEE,0X6D,0XF6,0XF1,0XFF,0X75,0XFF,0XBA,0XFF,0XFD,

154480XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0X98,0XEE,0XF2,

154590XEE,0X6D,0XEE,0X6A,0XF6,0X89,0XFE,0X89,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XF6,0X67,

154600XFE,0X88,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0XA8,0XF6,0XA8,

154610XFE,0XEB,0XFF,0X4D,0XF6,0XEC,0XD5,0XE9,0XBC,0XC5,0XB4,0X83,0XAC,0X42,0XAC,0X41,

154620XA3,0XE0,0X9B,0XC0,0X9C,0X00,0XA4,0X00,0XAC,0X21,0XC5,0X03,0XEE,0X07,0XF6,0X27,

154630XF6,0X46,0XFE,0X87,0XF6,0XA7,0XF6,0XA7,0XF6,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,

154640XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,

154650XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0X8A,0XFE,0XAB,0XF6,0X8C,

154660XEE,0X8E,0XF6,0XF2,0XFF,0X76,0XFF,0XDA,0XFF,0XDD,0XFF,0XFF,0XFF,0XBF,0XFF,0XDF,

154670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154760XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154770XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFC,0XFF,0XB7,0XEE,0XF1,0XE6,0X6C,

154780XEE,0X6A,0XF6,0X89,0XFE,0X88,0XF6,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X68,

154790XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XF6,0X68,0XF6,0X88,0XEE,0X89,0XF6,0XCA,

154800XFF,0X6E,0XFF,0X4D,0XF6,0XAA,0XE6,0X29,0XD5,0X65,0XCD,0X65,0XC5,0X24,0XC5,0X44,

154810XD5,0X85,0XDD,0XC6,0XE6,0X27,0XE5,0XE6,0XF6,0X48,0XFE,0X88,0XFE,0X67,0XF6,0X86,

154820XF6,0X86,0XF6,0X86,0XF6,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,

154830XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X88,

154840XFE,0X88,0XFE,0X89,0XFE,0XAA,0XF6,0XAB,0XF6,0X6C,0XEE,0X8E,0XF6,0XF3,0XFF,0X97,

154850XFF,0XDB,0XFF,0XFD,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,

154860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154950XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154960XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDA,0XFF,0XB7,0XEF,0X10,0XE6,0XAB,0XEE,0XA8,

154970XF6,0X87,0XFE,0X87,0XFE,0X68,0XFE,0X69,0XFE,0X69,0XFE,0X69,0XFE,0X68,0XFE,0X67,

154980XFE,0X67,0XFE,0X68,0XF6,0X68,0XF6,0X89,0XF6,0X69,0XEE,0X69,0XF6,0X8A,0XF6,0XCA,

154990XFF,0X4C,0XFF,0X4B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X0B,0XFE,0XCA,0XF6,0X89,

155000XEE,0X27,0XEE,0X48,0XF6,0X68,0XFE,0X88,0XFE,0X87,0XF6,0X67,0XF6,0X67,0XF6,0X87,

155010XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,

155020XFE,0X87,0XFE,0X67,0XFE,0X87,0XFE,0XA7,0XFE,0XA7,0XFE,0X88,0XFE,0X89,0XFE,0X8A,

155030XF6,0XCB,0XEE,0XAC,0XEE,0XAF,0XFF,0X34,0XFF,0XB8,0XFF,0XDB,0XFF,0XDE,0XFF,0XDF,

155040XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

155050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

155150XFF,0XDE,0XFF,0XDD,0XFF,0XFB,0XFF,0X96,0XEF,0X10,0XE6,0XAA,0XF6,0XA8,0XFE,0XA8,

155160XFE,0X89,0XFE,0X69,0XFE,0X49,0XFE,0X48,0XFE,0X48,0XFE,0X67,0XFE,0X87,0XFE,0X67,

155170XF6,0X68,0XF6,0X69,0XF6,0X69,0XF6,0X89,0XF6,0X89,0XF6,0X88,0XEE,0X67,0XEE,0X87,

155180XF6,0XA8,0XEE,0X88,0XEE,0X67,0XEE,0X47,0XEE,0X47,0XF6,0X68,0XFE,0X88,0XFE,0X88,

155190XF6,0X88,0XF6,0X88,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0XA8,0XF6,0X67,0XFE,0X87,

155200XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X67,0XFE,0X67,

155210XFE,0X87,0XFE,0XA7,0XFE,0XA8,0XFE,0X89,0XFE,0X8B,0XFE,0XAD,0XEE,0X8D,0XEE,0XD0,

155220XFF,0X54,0XFF,0X98,0XFF,0XDB,0XFF,0XDD,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

155230XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

155340XFF,0XFE,0XFF,0XDA,0XFF,0X96,0XF7,0X31,0XEE,0X8C,0XEE,0X8A,0XF6,0X89,0XF6,0X89,

155350XFE,0X89,0XFE,0X88,0XFE,0X68,0XFE,0X88,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XF6,0X87,

155360XF6,0X88,0XF6,0XA8,0XF6,0XA8,0XEE,0X87,0XF6,0X87,0XF6,0XA7,0XF6,0XA7,0XF6,0XA7,

155370XF6,0X87,0XF6,0X87,0XF6,0X88,0XFE,0XA8,0XFE,0XA8,0XFE,0X88,0XFE,0X88,0XFE,0X88,

155380XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X66,

155390XF6,0X66,0XF6,0X66,0XFE,0X67,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0XA8,0XFE,0XA8,

155400XF6,0X89,0XEE,0X6B,0XEE,0X4D,0XEE,0X50,0XFF,0X14,0XFF,0X77,0XFF,0XDB,0XFF,0XFC,

155410XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

155420XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

155520XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XDF,0XFF,0XBF,0XFF,0X9F,0XFF,0X9E,0XFF,0XBD,

155530XFF,0XBA,0XFF,0X76,0XF6,0XF1,0XEE,0XAD,0XEE,0X8B,0XEE,0X89,0XF6,0X88,0XF6,0X68,

155540XF6,0X47,0XF6,0X47,0XFE,0X87,0XFE,0X87,0XFE,0XA7,0XF6,0X87,0XF6,0X87,0XF6,0XA7,

155550XF6,0XA7,0XF6,0XA7,0XFE,0XA7,0XF6,0X87,0XF6,0X87,0XF6,0X87,0XF6,0X87,0XFE,0X87,

155560XFE,0X87,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X88,0XFE,0X88,0XFE,0X68,

155570XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0XA7,0XFE,0X87,0XF6,0X86,

155580XF6,0X67,0XF6,0X68,0XF6,0X69,0XF6,0X69,0XF6,0X8A,0XF6,0XAB,0XF6,0XAD,0XF6,0XD0,

155590XFF,0X13,0XFF,0X57,0XFF,0X9A,0XFF,0XBC,0XFF,0XDD,0XFF,0XBE,0XFF,0XBE,0XFF,0XDF,

155600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

155610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

155650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

155690XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

155700XF7,0XBF,0XF7,0XBF,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9D,0XF7,0X9D,

155710XF7,0X9D,0XEF,0X9D,0XEF,0X7E,0XEF,0X5E,0XEF,0X3D,0XF7,0X5C,0XFF,0X7C,0XFF,0X59,

155720XF7,0X15,0XEE,0XF2,0XEE,0XAE,0XEE,0X8B,0XEE,0X89,0XF6,0XA8,0XFE,0XA8,0XFE,0XA8,

155730XFE,0X87,0XFE,0X87,0XFE,0X86,0XFE,0X86,0XF6,0X87,0XF6,0X87,0XF6,0X87,0XFE,0XA8,

155740XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X88,

155750XFE,0X88,0XFE,0X88,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X88,

155760XFE,0X68,0XFE,0X89,0XFE,0X88,0XF6,0X46,0XF6,0X46,0XFE,0XC8,0XFE,0XE9,0XF6,0X89,

155770XF6,0X8B,0XEE,0X8C,0XEE,0X8D,0XEE,0XAF,0XF6,0XD1,0XF7,0X14,0XFF,0X58,0XFF,0X9A,

155780XFF,0XBC,0XFF,0X9D,0XFF,0X9E,0XFF,0XBE,0XFF,0XBF,0XFF,0XDF,0XFF,0XDF,0XF7,0XDF,

155790XF7,0XDE,0XF7,0XDE,0XF7,0XDE,0XF7,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

155800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

155840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

155870XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,

155880XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XEF,0X7E,0XEF,0X7E,

155890XEF,0X5D,0XEF,0X5D,0XEF,0X5C,0XEF,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3B,0XE7,0X3B,

155900XE7,0X1C,0XE7,0X1C,0XDE,0XDB,0XDE,0XDB,0XE6,0XDA,0XE6,0XD9,0XE6,0XB7,0XE6,0X93,

155910XDE,0X70,0XE6,0X6D,0XEE,0X8B,0XF6,0XAA,0XFE,0X89,0XFE,0X68,0XFE,0X88,0XFE,0X67,

155920XFE,0X66,0XFE,0X86,0XFE,0X87,0XF6,0X87,0XF6,0X87,0XFE,0X88,0XFE,0X68,0XFE,0X68,

155930XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X88,

155940XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XF6,0X47,

155950XF6,0X48,0XFE,0XA9,0XFE,0XA8,0XF6,0X89,0XF6,0XAA,0XF6,0XAC,0XEE,0XAE,0XEE,0XB0,

155960XEE,0XD2,0XF7,0X14,0XF7,0X36,0XF7,0X58,0XF7,0X5A,0XF7,0X7B,0XF7,0X5C,0XEF,0X5C,

155970XEF,0X5C,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7E,0XEF,0X9E,0XEF,0X9D,0XF7,0X9D,

155980XEF,0X9D,0XF7,0X9D,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBF,0XF7,0XBE,0XF7,0XBE,

155990XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

156000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156020XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156050XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,

156060XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

156070XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XE7,0X5D,0XE7,0X3D,0XE7,0X1C,0XE7,0X1B,

156080XE6,0XFB,0XDE,0XDB,0XDE,0XDA,0XDE,0XDA,0XD6,0XD9,0XD6,0XB8,0XCE,0X58,0XCE,0X58,

156090XCE,0X59,0XCE,0X59,0XC5,0XF7,0XBD,0XB5,0XBD,0XB4,0XC5,0X92,0XC5,0X90,0XCD,0XAE,

156100XDE,0X0D,0XEE,0X8C,0XF6,0XAC,0XFE,0XAB,0XF6,0X69,0XFE,0X69,0XFE,0X68,0XFE,0X87,

156110XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X48,0XFE,0X68,

156120XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,

156130XF6,0X88,0XF6,0X87,0XF6,0X87,0XF6,0X67,0XFE,0X88,0XFE,0X68,0XFE,0X89,0XFE,0X8A,

156140XF6,0X8B,0XF6,0XCC,0XEE,0XAE,0XD6,0X2E,0XCD,0XF0,0XCE,0X12,0XCE,0X33,0XCE,0X55,

156150XCE,0X76,0XD6,0X77,0XD6,0X98,0XDE,0XB9,0XDE,0XD9,0XDE,0XFA,0XDE,0XFA,0XDF,0X1B,

156160XDF,0X1B,0XDF,0X1B,0XE7,0X3C,0XE7,0X5D,0XE7,0X5C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,

156170XF7,0X7D,0XF7,0X7D,0XEF,0X7D,0XF7,0X9D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

156180XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

156190XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

156200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156210XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

156240XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

156250XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XEF,0X7D,0XEF,0X7D,0XEF,0X5D,

156260XEF,0X5D,0XE7,0X3D,0XE7,0X3D,0XE7,0X1C,0XDE,0XFB,0XDE,0XDA,0XDE,0XBA,0XD6,0X9A,

156270XD6,0X99,0XCE,0X79,0XC6,0X57,0XCE,0X57,0XBE,0X16,0XBD,0XF6,0XB5,0XD6,0XB5,0XB6,

156280XAD,0X55,0XA5,0X34,0XA4,0XF2,0XA4,0XD1,0X9C,0X6E,0X9C,0X2C,0XA4,0X8A,0XBD,0X2B,

156290XDE,0X0D,0XEE,0X8D,0XEE,0X4C,0XF6,0X8B,0XFE,0XAA,0XF6,0X89,0XF6,0X88,0XFE,0X88,

156300XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,

156310XFE,0X68,0XFE,0X88,0XFE,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,

156320XF6,0X88,0XF6,0X88,0XFE,0X89,0XEE,0X48,0XFE,0X8A,0XFE,0XEE,0XF6,0X8E,0XC5,0X4A,

156330X8B,0XA6,0X5A,0X83,0X62,0XA6,0X63,0X09,0X6B,0X8B,0X7C,0X0E,0X8C,0X70,0X94,0XD1,

156340XA5,0X13,0XAD,0X74,0XB5,0XB5,0XB5,0XD6,0XBE,0X16,0XC6,0X37,0XC6,0X58,0XCE,0X79,

156350XCE,0X99,0XD6,0XBA,0XDE,0XDB,0XDE,0XFB,0XDE,0XFC,0XE6,0XFC,0XE7,0X1C,0XE7,0X1C,

156360XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,

156370XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

156380XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

156390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,

156400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156420XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,

156430XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

156440XF7,0X9E,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

156450XE7,0X1C,0XDF,0X1B,0XDE,0XFA,0XDE,0XDA,0XD6,0X9A,0XD6,0X9A,0XCE,0X5A,0XCE,0X59,

156460XC6,0X38,0XBD,0XF7,0XB5,0XD6,0XB5,0XB5,0XAD,0X75,0XA5,0X35,0X9C,0XF4,0X9C,0XD3,

156470X9C,0XB2,0X8C,0X50,0X83,0XCE,0X83,0XCD,0X83,0X8B,0X73,0X07,0X83,0X88,0XB4,0XEB,

156480XEE,0X90,0XF6,0XAF,0XEE,0X6C,0XF6,0X8B,0XF6,0X8A,0XF6,0X68,0XF6,0X88,0XFE,0X88,

156490XFE,0X88,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XF6,0X87,

156500XF6,0X87,0XF6,0X87,0XF6,0XA8,0XF6,0XA8,0XEE,0X68,0XEE,0X88,0XF6,0X89,0XEE,0X89,

156510XF6,0XAB,0XFF,0X0D,0XF6,0X8D,0XBC,0XC9,0X72,0XC3,0X49,0X80,0X39,0X61,0X41,0XC5,

156520X39,0XC6,0X39,0XE6,0X3A,0X06,0X42,0X47,0X4A,0X88,0X52,0XCA,0X63,0X0C,0X6B,0X8E,

156530X7C,0X10,0X84,0X50,0X8C,0X71,0X94,0XD2,0XA5,0X34,0XAD,0X95,0XB5,0XB6,0XBD,0XD7,

156540XBD,0XF8,0XCE,0X39,0XCE,0X59,0XD6,0X7A,0XDE,0XBB,0XDE,0XDB,0XDE,0XDB,0XE6,0XFB,

156550XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,

156560XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,

156570XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

156580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,

156590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

156610XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,

156620XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

156630XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

156640XE7,0X1B,0XDE,0XFB,0XDE,0XDB,0XDE,0XDB,0XDE,0XBC,0XD6,0X9B,0XCE,0X7A,0XCE,0X58,

156650XBE,0X17,0XBD,0XF7,0XBD,0XD7,0XAD,0X96,0XA5,0X35,0X9C,0XF4,0X94,0XB2,0X8C,0X50,

156660X7B,0XCF,0X73,0X8E,0X73,0X6D,0X62,0XCA,0X52,0X46,0X52,0X44,0X62,0XA4,0X9C,0X49,

156670XCD,0XED,0XE6,0X8E,0XEE,0X8C,0XF6,0X8B,0XF6,0X8B,0XF6,0X6A,0XF6,0X69,0XF6,0X89,

156680XF6,0X89,0XF6,0X88,0XF6,0X68,0XEE,0X67,0XF6,0X87,0XEE,0X87,0XF6,0XA8,0XEE,0X88,

156690XEE,0X89,0XEE,0X8A,0XEE,0XAB,0XF6,0XCC,0XF6,0XED,0XF6,0XCD,0XE6,0X4C,0XA4,0X87,

156700X62,0X60,0X41,0X60,0X41,0X80,0X49,0XE4,0X4A,0X06,0X4A,0X08,0X52,0X49,0X52,0X8A,

156710X52,0XAA,0X52,0XCA,0X52,0XC9,0X52,0XCA,0X5A,0XEC,0X6B,0X4E,0X6B,0X8E,0X73,0XCF,

156720X7B,0XF0,0X7C,0X30,0X8C,0X71,0X94,0XB2,0X9C,0XD3,0XA5,0X13,0XAD,0X55,0XB5,0X96,

156730XBD,0XB7,0XBD,0XD8,0XC6,0X18,0XCE,0X18,0XCE,0X38,0XCE,0X79,0XD6,0XBA,0XD6,0XBA,

156740XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,

156750XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,

156760XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

156770XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,

156800XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

156810XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XEF,0X7D,

156820XEF,0X7D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5C,0XE7,0X5C,0XE7,0X3C,0XE7,0X1C,

156830XE7,0X1C,0XE6,0XFD,0XDE,0XDD,0XDE,0XDC,0XDE,0XDB,0XD6,0XBA,0XD6,0X99,0XCE,0X79,

156840XCE,0X79,0XC6,0X59,0XBE,0X18,0XB5,0XD7,0XB5,0XB5,0XB5,0X95,0XA5,0X54,0X9C,0XD3,

156850X8C,0X72,0X84,0X10,0X73,0X8D,0X6B,0X2A,0X5A,0X86,0X4A,0X22,0X4A,0X20,0X73,0X23,

156860XA4,0XA8,0XCD,0XCC,0XDE,0X2D,0XE6,0X4D,0XEE,0X4C,0XEE,0X6C,0XEE,0X6C,0XEE,0X8C,

156870XEE,0X8B,0XEE,0X8B,0XEE,0XAB,0XEE,0XAB,0XEE,0X8B,0XEE,0X8B,0XE6,0X8C,0XE6,0X6D,

156880XE6,0X4D,0XCD,0XCC,0XA4,0X88,0X7B,0X23,0X49,0XC0,0X39,0XA0,0X39,0X81,0X41,0XC3,

156890X4A,0X05,0X4A,0X26,0X52,0X47,0X5A,0XA9,0X62,0XCB,0X63,0X0B,0X6B,0X4C,0X6B,0X6C,

156900X6B,0X4C,0X6B,0X4D,0X6B,0X6E,0X73,0X8F,0X73,0XAF,0X7C,0X10,0X84,0X31,0X8C,0X71,

156910X94,0X92,0X94,0XB2,0X9C,0XF3,0XA5,0X14,0XA5,0X35,0XB5,0X76,0XBD,0X97,0XBD,0XB7,

156920XC5,0XF8,0XC6,0X18,0XC6,0X18,0XCE,0X59,0XCE,0X79,0XD6,0X9A,0XD6,0XBA,0XDE,0XDB,

156930XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,

156940XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

156950XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156960XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

156990XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

157000XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XEF,0X7D,

157010XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7C,0XEF,0X5C,0XE7,0X3C,0XE7,0X3D,0XE7,0X1D,

157020XE7,0X1D,0XE6,0XFD,0XDE,0XFC,0XDE,0XFB,0XDE,0XFB,0XDE,0XDB,0XDE,0XDB,0XD6,0XBB,

157030XD6,0XBA,0XCE,0X99,0XCE,0X79,0XCE,0X78,0XCE,0X79,0XC6,0X58,0XBD,0XF8,0XBD,0XD8,

157040XB5,0XB7,0XAD,0X75,0XA5,0X32,0XA5,0X10,0X9C,0XCE,0X8C,0X4B,0X8C,0X09,0X94,0X4A,

157050XAC,0XCB,0XC5,0X8E,0XCD,0XAE,0XD5,0XCE,0XD5,0XEE,0XDE,0X0D,0XDE,0X2D,0XDE,0X2D,

157060XD5,0XEC,0XCD,0XCB,0XC5,0X8B,0XBD,0X4A,0XAC,0XC9,0X93,0XE7,0X73,0X04,0X5A,0X42,

157070X51,0XE2,0X49,0XC2,0X4A,0X05,0X4A,0X26,0X52,0X47,0X52,0X88,0X5A,0XC9,0X63,0X0A,

157080X6B,0X2A,0X73,0X6B,0X73,0X6C,0X7B,0X6D,0X83,0XCE,0X8B,0XEF,0X8C,0X0F,0X8C,0X50,

157090X8C,0X52,0X8C,0X51,0X84,0X30,0X8C,0X51,0X94,0X92,0X94,0XD2,0X9C,0XF3,0XA5,0X13,

157100XA5,0X34,0XAD,0X55,0XAD,0X55,0XB5,0X96,0XBD,0XB7,0XBD,0XD7,0XC5,0XF8,0XC6,0X18,

157110XC6,0X38,0XCE,0X59,0XCE,0X79,0XD6,0X9A,0XD6,0XBA,0XD6,0XBA,0XDE,0XDB,0XDE,0XDB,

157120XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,

157130XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

157140XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

157150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157170XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,

157180XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

157190XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

157200XF7,0XBD,0XF7,0X9D,0XF7,0X9D,0XEF,0X7D,0XEF,0X7E,0XEF,0X5E,0XEF,0X5E,0XEF,0X5D,

157210XE7,0X3C,0XEF,0X3C,0XE7,0X3C,0XE7,0X1B,0XE7,0X1C,0XE7,0X1C,0XDE,0XFB,0XDE,0XFB,

157220XDE,0XFB,0XD6,0XDA,0XD6,0XDA,0XD6,0XDA,0XD6,0XBA,0XD6,0XBA,0XD6,0XBA,0XCE,0XB9,

157230XD6,0XD9,0XD6,0XD8,0XDE,0XF8,0XD6,0XB7,0XDE,0XD8,0XE6,0XD7,0XD6,0X55,0XCD,0XF3,

157240XCD,0XF3,0XCD,0XD2,0XCD,0XD2,0XCD,0XD1,0XCD,0XD1,0XC5,0XB0,0XC5,0X8F,0XBD,0X6F,

157250XB5,0X2E,0XB5,0X0E,0XA4,0X8E,0X94,0X2D,0X94,0X0E,0X9C,0X50,0X9C,0X50,0X8B,0XEF,

157260X8C,0X30,0X8C,0X51,0X94,0X71,0X94,0X71,0X94,0X91,0X9C,0XB0,0X9C,0XD0,0XA4,0XD0,

157270XA4,0XF1,0XAC,0XF2,0XAD,0X13,0XB5,0X34,0XB5,0X55,0XB5,0X95,0XB5,0X96,0XB5,0X75,

157280XAD,0X74,0XAD,0X74,0XAD,0X74,0XAD,0X95,0XB5,0X95,0XB5,0XB6,0XBD,0XD7,0XBD,0XD7,

157290XC5,0XF8,0XC6,0X18,0XCE,0X18,0XCE,0X39,0XD6,0X79,0XD6,0X79,0XD6,0X99,0XD6,0X9A,

157300XD6,0XBA,0XD6,0XBA,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,

157310XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,

157320XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,

157330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

157340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

157360XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

157370XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

157380XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

157390XF7,0XBE,0XF7,0X9E,0XF7,0X9F,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9D,0XF7,0X9D,

157400XEF,0X7C,0XEF,0X5C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5C,0XE7,0X3C,0XEF,0X5C,0XE7,0X5C,

157410XE7,0X5C,0XE7,0X3C,0XE7,0X3B,0XEF,0X5C,0XEF,0X9D,0XEF,0X9D,0XF7,0XBD,0XEF,0XBD,

157420XF7,0X9D,0XF7,0X9D,0XEF,0X7C,0XEF,0X3B,0XEF,0X1A,0XF7,0X5B,0XF7,0X5A,0XF7,0X3A,

157430XEF,0X19,0XEE,0XF9,0XE6,0XF8,0XE6,0XD7,0XE6,0XD7,0XE6,0XD8,0XE6,0XD8,0XE6,0XD8,

157440XE6,0XD9,0XE6,0XB9,0XE6,0XBA,0XDE,0X7A,0XE6,0X9B,0XEE,0XDC,0XDE,0X9A,0XDE,0XBA,

157450XDE,0XBB,0XD6,0X9A,0XD6,0X99,0XD6,0X98,0XD6,0X97,0XDE,0XB7,0XDE,0X98,0XDE,0X99,

157460XDE,0X9A,0XDE,0X9A,0XDE,0X99,0XDE,0XBA,0XDE,0XDA,0XDE,0XD9,0XDE,0XD9,0XD6,0X98,

157470XD6,0X78,0XCE,0X58,0XC6,0X38,0XCE,0X58,0XCE,0X79,0XCE,0X79,0XD6,0X7A,0XD6,0X7A,

157480XD6,0X9A,0XD6,0X9A,0XD6,0XBA,0XDE,0XDA,0XDE,0XDA,0XDE,0XDA,0XDE,0XFB,0XDE,0XFB,

157490XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,

157500XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,

157510XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XFF,

157520XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

157550XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

157560XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

157570XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBF,

157580XF7,0XBF,0XF7,0XBF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBD,0XF7,0XBD,0XF7,0X9D,0XF7,0X9E,

157590XF7,0X9E,0XF7,0X7E,0XF7,0X7E,0XF7,0X7E,0XEF,0X5D,0XEF,0X5D,0XF7,0X7D,0XF7,0X9D,

157600XFF,0XBD,0XFF,0XFE,0XFF,0XFE,0XF7,0XDD,0XFF,0XDE,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

157610XFF,0XDE,0XFF,0XDE,0XFF,0XDD,0XFF,0XBC,0XF7,0X7C,0XF7,0X9C,0XFF,0XBD,0XFF,0XBD,

157620XFF,0XBC,0XFF,0X9C,0XF7,0X9B,0XF7,0X9B,0XF7,0X9B,0XF7,0X7B,0XF7,0X5B,0XEF,0X5B,

157630XFF,0X9C,0XFF,0XBD,0XF7,0X7C,0XEF,0X3B,0XF7,0X7C,0XF7,0X5C,0XF7,0X5C,0XF7,0X5C,

157640XF7,0X7C,0XF7,0X7C,0XF7,0X7C,0XF7,0X7C,0XF7,0X5C,0XF7,0X7D,0XF7,0X7D,0XF7,0X7C,

157650XF7,0X7C,0XF7,0X7B,0XF7,0X7B,0XF7,0X7C,0XFF,0X9D,0XF7,0X7C,0XEF,0X5C,0XE7,0X3C,

157660XDE,0XFB,0XDE,0XDB,0XDE,0XFB,0XE7,0X1C,0XE6,0XFC,0XE6,0XFC,0XE7,0X1C,0XE7,0X1C,

157670XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,

157680XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

157690XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,

157700XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

157710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

157740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

157760XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XBF,0XFF,0XDF,0XFF,0XDF,0XF7,0XDF,0XF7,0XDF,

157770XF7,0XDF,0XFF,0XDE,0XF7,0XDE,0XFF,0XDD,0XFF,0XDE,0XFF,0XDF,0XFF,0XBF,0XF7,0X9F,

157780XF7,0X9F,0XFF,0XBF,0XFF,0XBF,0XFF,0XBF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFE,

157790XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XF7,0XBF,0XF7,0XDF,0XFF,0XFF,0XFF,0XFF,

157800XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,

157810XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFE,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,

157820XFF,0XDC,0XFF,0XFD,0XFF,0XBD,0XFF,0XDE,0XFF,0XDE,0XFF,0XBD,0XFF,0XBD,0XFF,0XBD,

157830XFF,0XBE,0XFF,0XDE,0XFF,0XBE,0XFF,0XDE,0XFF,0XBE,0XFF,0XDE,0XFF,0XDD,0XFF,0XDD,

157840XFF,0XBD,0XFF,0XDD,0XFF,0XBE,0XFF,0XBE,0XFF,0XDE,0XFF,0XBE,0XEF,0X5D,0XE7,0X3C,

157850XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X5D,0XEF,0X7D,

157860XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

157870XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,

157880XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

157890XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XF7,0XBE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

157900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157960XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

157970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0X9E,0XEF,0X7D,

158040XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

158050XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

158060XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

158070XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

158080XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

158160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,

158230XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

158240XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,

158250XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

158260XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,

158270XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,

158420XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

158430XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

158440XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

158460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158600XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

158610XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158640XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,

158650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158790XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158830XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

159020XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,

159210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

159400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159460XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

159650XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,};

15979

15980#endif

15981

15982

15983

15984

gimage_9

const unsigned char gimage_9[51000]

Definition: at_start_f435/examples/xmc/lcd_8bit/inc/picture.h:9600

gimage_5

const unsigned char gimage_5[51000]

Definition: at_start_f435/examples/xmc/lcd_8bit/inc/picture.h:6410

gimage_8

const unsigned char gimage_8[51000]

Definition: at_start_f435/examples/xmc/lcd_8bit/inc/picture.h:3220

gimage_3

const unsigned char gimage_3[51000]

Definition: at_start_f435/examples/xmc/lcd_8bit/inc/picture.h:29

gimage_0

const unsigned char gimage_0[51000]

Definition: at_start_f435/examples/xmc/lcd_8bit/inc/picture.h:12790

Generated by 1.9.2


AT32F435/437 Firmwary Library: xmc_lcd.h File Reference

  • at_start_f435
  • examples
  • xmc
  • lcd_8bit
  • inc
Macros | Functions
at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h File Reference

xmc_lcd header file More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | XMC_LCD_COMMAND 0x60000000
#define | XMC_LCD_DATA 0x60000001
#define | LCD_RESET_HIGH gpio_bits_set(GPIOB,GPIO_PINS_9)
#define | LCD_RESET_LOW gpio_bits_reset(GPIOB,GPIO_PINS_9)
#define | WHITE 0xFFFF
#define | BLACK 0x0000
#define | BLUE 0x001F
#define | BRED 0xF81F
#define | GRED 0xFFE0
#define | GBLUE 0x07FF
#define | RED 0xF800
#define | MAGENTA 0xF81F
#define | GREEN 0x07E0
#define | CYAN 0x7FFF
#define | YELLOW 0xFFE0
#define | BROWN 0xBC40
#define | BRRED 0xFC07
#define | GRAY 0x8430

Functions

void | xmc_init (void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_init (void)
configures the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_wr_command (uint8_t command)
this function is write command to lcd. More...
void | lcd_wr_data (uint8_t data)
this function is write data to lcd. More...
void | lcd_setblock (uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd. More...
void | lcd_writeonepoint (uint16_t color)
this function is write one point to lcd. More...
void | lcd_drawpoint (uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd. More...
void | lcd_clear (uint16_t color)
this function is clear the lcd. More...
void | lcd_display_number (void)
this function is display number on the lcd. More...

Detailed Description

xmc_lcd header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h.


AT32F435/437 Firmwary Library: xmc_lcd.h Source File

  • at_start_f435
  • examples
  • xmc
  • lcd_8bit
  • inc
at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h
Go to the documentation of this file.
1
27#ifndef __XMC_LCD_H
28#define __XMC_LCD_H
29
30#include "at32f435_437_board.h"
31
40/* the address of write data & command (xmc_a0) */
41#define XMC_LCD_COMMAND 0x60000000
42#define XMC_LCD_DATA 0x60000001
43
52/* the lcd reset line */
53#define LCD_RESET_HIGH gpio_bits_set(GPIOB,GPIO_PINS_9)
54#define LCD_RESET_LOW gpio_bits_reset(GPIOB,GPIO_PINS_9)
55
60#define WHITE 0xFFFF
61#define BLACK 0x0000
62#define BLUE 0x001F
63#define BRED 0xF81F
64#define GRED 0xFFE0
65#define GBLUE 0x07FF
66#define RED 0xF800
67#define MAGENTA 0xF81F
68#define GREEN 0x07E0
69#define CYAN 0x7FFF
70#define YELLOW 0xFFE0
71#define BROWN 0xBC40
72#define BRRED 0xFC07
73#define GRAY 0x8430
74
79void xmc_init(void);
80void lcd_init(void);
81void lcd_wr_command(uint8_t command);
82void lcd_wr_data(uint8_t data);
83void lcd_setblock(uint16_t xstart,uint16_t ystart,uint16_t xend,uint16_t yend);
84void lcd_writeonepoint(uint16_t color);
85void lcd_drawpoint(uint16_t x,uint16_t y,uint16_t color);
86void lcd_clear(uint16_t color);
87void lcd_display_number(void);
88
101#endif
at32f435_437_board.h
lcd_setblock
void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:332
lcd_init
void lcd_init(void)
configures the lcd. this function must be called before any write/read operation on the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:165
lcd_drawpoint
void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:367
lcd_clear
void lcd_clear(uint16_t color)
this function is clear the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:379
lcd_writeonepoint
void lcd_writeonepoint(uint16_t color)
this function is write one point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:357
xmc_init
void xmc_init(void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write...
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:57
lcd_wr_command
void lcd_wr_command(uint8_t command)
this function is write command to lcd.
Definition: at_start_f437/examples/xmc/lcd_8bit/src/xmc_lcd.c:260
lcd_display_number
void lcd_display_number(void)
this function is display number on the lcd.
Definition: at_start_f437/examples/xmc/lcd_8bit/src/xmc_lcd.c:347
lcd_wr_data
void lcd_wr_data(uint8_t data)
this function is write data to lcd.
Definition: at_start_f437/examples/xmc/lcd_8bit/src/xmc_lcd.c:270


AT32F435/437 Firmwary Library: xmc_lcd.c File Reference

  • at_start_f435
  • examples
  • xmc
  • lcd_8bit
  • src
Functions
at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c File Reference

xmc_lcd config program More...

#include "at32f435_437_board.h"
#include "xmc_lcd.h"
#include "picture.h"

Go to the source code of this file.

Functions

void | xmc_init (void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_init (void)
configures the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_wr_command (uint8_t command)
this function is write command to lcd. More...
void | lcd_wr_data (uint8_t data)
this function is write data to lcd. More...
void | lcd_setblock (uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd. More...
void | lcd_writeonepoint (uint16_t color)
this function is write one point to lcd. More...
void | lcd_drawpoint (uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd. More...
void | lcd_clear (uint16_t color)
this function is clear the lcd. More...
void | lcd_display_number (void)
this function is display number on the lcd. More...

Detailed Description

xmc_lcd config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c.


AT32F435/437 Firmwary Library: xmc_lcd.c Source File

  • at_start_f435
  • examples
  • xmc
  • lcd_8bit
  • src
at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "xmc_lcd.h"
29#include "picture.h"
30
46void xmc_init(void)
47{
48 gpio_init_type gpio_init_struct = {0};
49 xmc_norsram_init_type xmc_norsram_init_struct;
50 xmc_norsram_timing_init_type rw_timing_struct, w_timing_struct;
51
52 /* enable the gpio clock */
53 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
54 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
55 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
56 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
57 crm_periph_clock_enable(CRM_GPIOF_PERIPH_CLOCK, TRUE);
58
59 /* enable the xmc clock */
60 crm_periph_clock_enable(CRM_XMC_PERIPH_CLOCK, TRUE);
61
62 /*-- gpio configuration ------------------------------------------------------*/
63 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_12);
64 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE5, GPIO_MUX_12);
65 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE7, GPIO_MUX_12);
66 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE0, GPIO_MUX_12);
67 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_12);
68 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE14, GPIO_MUX_12);
69 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE15, GPIO_MUX_12);
70 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE7, GPIO_MUX_12);
71 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE8, GPIO_MUX_12);
72 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE9, GPIO_MUX_12);
73 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE10, GPIO_MUX_12);
74 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE0, GPIO_MUX_12);
75
76 /* ne1/nwe/noe lines configuration */
77 gpio_init_struct.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_7 ;
78 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
79 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
80 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
81 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
82 gpio_init(GPIOD, &gpio_init_struct);
83
84 /* a0 lines configuration */
85 gpio_init_struct.gpio_pins = GPIO_PINS_0;
86 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
87 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
88 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
89 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
90 gpio_init(GPIOF, &gpio_init_struct);
91
92 /* data lines configuration */
93 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_14 | GPIO_PINS_15;
94 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
95 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
96 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
97 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
98 gpio_init(GPIOD, &gpio_init_struct);
99
100 gpio_init_struct.gpio_pins = GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10;
101 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
102 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
103 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
104 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
105 gpio_init(GPIOE, &gpio_init_struct);
106
107 /* lcd reset lines configuration */
108 gpio_init_struct.gpio_pins = GPIO_PINS_9;
109 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
110 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
111 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
112 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
113 gpio_init(GPIOB, &gpio_init_struct);
114
115 /*-- xmc configuration ------------------------------------------------------*/
116 xmc_norsram_default_para_init(&xmc_norsram_init_struct);
117 xmc_norsram_init_struct.subbank = XMC_BANK1_NOR_SRAM1;
118 xmc_norsram_init_struct.data_addr_multiplex = XMC_DATA_ADDR_MUX_DISABLE;
119 xmc_norsram_init_struct.device = XMC_DEVICE_SRAM;
120 xmc_norsram_init_struct.bus_type = XMC_BUSTYPE_8_BITS;
121 xmc_norsram_init_struct.burst_mode_enable = XMC_BURST_MODE_DISABLE;
122 xmc_norsram_init_struct.asynwait_enable = XMC_ASYN_WAIT_DISABLE;
123 xmc_norsram_init_struct.wait_signal_lv = XMC_WAIT_SIGNAL_LEVEL_LOW;
124 xmc_norsram_init_struct.wrapped_mode_enable = XMC_WRAPPED_MODE_DISABLE;
125 xmc_norsram_init_struct.wait_signal_config = XMC_WAIT_SIGNAL_SYN_BEFORE;
126 xmc_norsram_init_struct.write_enable = XMC_WRITE_OPERATION_ENABLE;
127 xmc_norsram_init_struct.wait_signal_enable = XMC_WAIT_SIGNAL_DISABLE;
128 xmc_norsram_init_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
129 xmc_norsram_init_struct.write_burst_syn = XMC_WRITE_BURST_SYN_DISABLE;
130 xmc_nor_sram_init(&xmc_norsram_init_struct);
131
132 /* timing configuration */
133 xmc_norsram_timing_default_para_init(&rw_timing_struct, &w_timing_struct);
134 rw_timing_struct.subbank = XMC_BANK1_NOR_SRAM1;
135 rw_timing_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
136 rw_timing_struct.addr_setup_time = 0x2;
137 rw_timing_struct.addr_hold_time = 0x0;
138 rw_timing_struct.data_setup_time = 0x2;
139 rw_timing_struct.bus_latency_time = 0x0;
140 rw_timing_struct.clk_psc = 0x0;
141 rw_timing_struct.data_latency_time = 0x0;
142 rw_timing_struct.mode = XMC_ACCESS_MODE_A;
143 w_timing_struct.subbank = XMC_BANK1_NOR_SRAM1;
144 w_timing_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
145 w_timing_struct.addr_setup_time = 0x2;
146 w_timing_struct.addr_hold_time = 0x0;
147 w_timing_struct.data_setup_time = 0x2;
148 w_timing_struct.bus_latency_time = 0x0;
149 w_timing_struct.clk_psc = 0x0;
150 w_timing_struct.data_latency_time = 0x0;
151 w_timing_struct.mode = XMC_ACCESS_MODE_A;
152 xmc_nor_sram_timing_config(&rw_timing_struct, &w_timing_struct);
153
154 /* bus turnaround phase for consecutive read duration and consecutive write duration */
155 xmc_ext_timing_config(XMC_BANK1_NOR_SRAM1, 0x08, 0x08);
156
157 /* enable xmc_bank1_nor_sram4 */
158 xmc_nor_sram_enable(XMC_BANK1_NOR_SRAM1, TRUE);
159}
160
168void lcd_init(void)
169{
170 /* init xmc */
171 xmc_init();
172 delay_ms(50);
173
174 /* reset lcd */
175 LCD_RESET_HIGH;
176 delay_ms(1);
177 LCD_RESET_LOW;
178 delay_ms(10);
179 LCD_RESET_HIGH;
180 delay_ms(120);
181 lcd_wr_command(0x36);
182 lcd_wr_data(0x00);
183 lcd_wr_command(0x3a);
184 lcd_wr_data(0x55);
185
186 /* 320*240 */
187 lcd_wr_command(0x2a);
188 lcd_wr_data(0x00);
189 lcd_wr_data(0x00);
190 lcd_wr_data(0x01);
191 lcd_wr_data(0x3f);
192 lcd_wr_command(0x2b);
193 lcd_wr_data(0x00);
194 lcd_wr_data(0x00);
195 lcd_wr_data(0x00);
196 lcd_wr_data(0xef);
197 lcd_wr_command(0xb2);
198 lcd_wr_data(0x0c);
199 lcd_wr_data(0x0c);
200 lcd_wr_data(0x00);
201 lcd_wr_data(0x33);
202 lcd_wr_data(0x33);
203 lcd_wr_command(0xb7);
204 lcd_wr_data(0x35);
205 lcd_wr_command(0xbb);
206 lcd_wr_data(0x30);
207 lcd_wr_command(0xc3);
208 lcd_wr_data(0x1c);
209 lcd_wr_command(0xc4);
210 lcd_wr_data(0x18);
211 lcd_wr_command(0xc6);
212 lcd_wr_data(0x0f);
213 lcd_wr_command(0xd0);
214 lcd_wr_data(0xa4);
215 lcd_wr_data(0xa2);
216 lcd_wr_command(0xe0);
217 lcd_wr_data(0xf0);
218 lcd_wr_data(0x00);
219 lcd_wr_data(0x0a);
220 lcd_wr_data(0x10);
221 lcd_wr_data(0x12);
222 lcd_wr_data(0x1b);
223 lcd_wr_data(0x39);
224 lcd_wr_data(0x44);
225 lcd_wr_data(0x47);
226 lcd_wr_data(0x28);
227 lcd_wr_data(0x12);
228 lcd_wr_data(0x10);
229 lcd_wr_data(0x16);
230 lcd_wr_data(0x1b);
231 lcd_wr_command(0xe1);
232 lcd_wr_data(0xf0);
233 lcd_wr_data(0x00);
234 lcd_wr_data(0x0a);
235 lcd_wr_data(0x10);
236 lcd_wr_data(0x11);
237 lcd_wr_data(0x1a);
238 lcd_wr_data(0x3b);
239 lcd_wr_data(0x34);
240 lcd_wr_data(0x4e);
241 lcd_wr_data(0x3a);
242 lcd_wr_data(0x17);
243 lcd_wr_data(0x16);
244 lcd_wr_data(0x21);
245 lcd_wr_data(0x22);
246 lcd_wr_command(0x3a);
247 lcd_wr_data(0x55);
248 lcd_wr_command(0x11);
249 delay_ms(120);
250
251 /* display on */
252 lcd_wr_command(0x29);
253}
254
260void lcd_wr_command(uint8_t command)
261{
262 *(__IO uint8_t *) XMC_LCD_COMMAND = command;
263}
264
270void lcd_wr_data(uint8_t data)
271{
272 *(__IO uint8_t *) XMC_LCD_DATA = data;
273}
274
283void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
284{
285 /* set row coordinates */
286 lcd_wr_command(0x2a);
287 lcd_wr_data(xstart >> 8);
288 lcd_wr_data(xstart);
289 lcd_wr_data(xend >> 8);
290 lcd_wr_data(xend);
291
292 /* set column coordinates */
293 lcd_wr_command(0x2b);
294 lcd_wr_data(ystart >> 8);
295 lcd_wr_data(ystart);
296 lcd_wr_data(yend >> 8);
297 lcd_wr_data(yend);
298 /* enable write menory */
299 lcd_wr_command(0x2c);
300}
301
307void lcd_writeonepoint(uint16_t color)
308{
309 lcd_wr_data(color >> 8);
310 lcd_wr_data(color);
311}
312
318void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
319{
320 lcd_setblock(x, y, x, y);
321
322 lcd_writeonepoint(color);
323}
324
330void lcd_clear(uint16_t color)
331{
332 uint32_t i;
333
334 lcd_setblock(0, 0, 240, 320);
335
336 for(i = 0; i < 76800; i++)
337 {
338 lcd_writeonepoint(color);
339 }
340}
341
347void lcd_display_number(void)
348{
349 int i;
350
351 lcd_setblock(50, 50, 199, 219);
352
353 for(i=0; i<sizeof(gimage_8); i++)
354 {
355 lcd_wr_data(gimage_8[i]);
356 }
357
358 delay_ms(1000);
359 lcd_setblock(50, 50, 199, 219);
360
361 for(i=0; i<sizeof(gimage_3); i++)
362 {
363 lcd_wr_data(gimage_3[i]);
364 }
365
366 delay_ms(1000);
367 lcd_setblock(50, 50, 199, 219);
368
369 for(i=0; i<sizeof(gimage_5); i++)
370 {
371 lcd_wr_data(gimage_5[i]);
372 }
373
374 delay_ms(1000);
375 lcd_setblock(50, 50, 199, 219);
376
377 for(i=0; i<sizeof(gimage_9); i++)
378 {
379 lcd_wr_data(gimage_9[i]);
380 }
381
382 delay_ms(1000);
383 lcd_setblock(50, 50, 199, 219);
384
385 for(i=0; i<sizeof(gimage_0); i++)
386 {
387 lcd_wr_data(gimage_0[i]);
388 }
389
390 delay_ms(1000);
391}
392
at32f435_437_board.h
gimage_9
const unsigned char gimage_9[51000]
Definition: at_start_f435/examples/xmc/lcd_8bit/inc/picture.h:9600
gimage_5
const unsigned char gimage_5[51000]
Definition: at_start_f435/examples/xmc/lcd_8bit/inc/picture.h:6410
gimage_8
const unsigned char gimage_8[51000]
Definition: at_start_f435/examples/xmc/lcd_8bit/inc/picture.h:3220
gimage_3
const unsigned char gimage_3[51000]
Definition: at_start_f435/examples/xmc/lcd_8bit/inc/picture.h:29
gimage_0
const unsigned char gimage_0[51000]
Definition: at_start_f435/examples/xmc/lcd_8bit/inc/picture.h:12790
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
lcd_setblock
void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd.
Definition: at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c:283
lcd_init
void lcd_init(void)
configures the lcd. this function must be called before any write/read operation on the lcd.
Definition: at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c:168
lcd_drawpoint
void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd.
Definition: at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c:318
lcd_wr_command
void lcd_wr_command(uint8_t command)
this function is write command to lcd.
Definition: at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c:260
lcd_clear
void lcd_clear(uint16_t color)
this function is clear the lcd.
Definition: at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c:330
lcd_display_number
void lcd_display_number(void)
this function is display number on the lcd.
Definition: at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c:347
lcd_wr_data
void lcd_wr_data(uint8_t data)
this function is write data to lcd.
Definition: at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c:270
lcd_writeonepoint
void lcd_writeonepoint(uint16_t color)
this function is write one point to lcd.
Definition: at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c:307
xmc_init
void xmc_init(void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write...
Definition: at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c:46
XMC_LCD_COMMAND
#define XMC_LCD_COMMAND
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:65
XMC_LCD_DATA
#define XMC_LCD_DATA
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:66
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_XMC_PERIPH_CLOCK
@ CRM_XMC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:123
CRM_GPIOF_PERIPH_CLOCK
@ CRM_GPIOF_PERIPH_CLOCK
Definition: at32f435_437_crm.h:110
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOF
#define GPIOF
Definition: at32f435_437_gpio.h:526
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
LCD_RESET_HIGH
#define LCD_RESET_HIGH
Definition: at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h:53
LCD_RESET_LOW
#define LCD_RESET_LOW
Definition: at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h:54
xmc_nor_sram_init
void xmc_nor_sram_init(xmc_norsram_init_type *xmc_norsram_init_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_norsraminitstruct.
Definition: at32f435_437_xmc.c:78
xmc_norsram_timing_default_para_init
void xmc_norsram_timing_default_para_init(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
fill each xmc_rw_timing_struct and xmc_w_timing_struct member with its default value.
Definition: at32f435_437_xmc.c:176
xmc_nor_sram_timing_config
void xmc_nor_sram_timing_config(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_rw_timing_struct a...
Definition: at32f435_437_xmc.c:113
xmc_ext_timing_config
void xmc_ext_timing_config(xmc_nor_sram_subbank_type xmc_sub_bank, uint16_t w2w_timing, uint16_t r2r_timing)
config the bus turnaround phase.
Definition: at32f435_437_xmc.c:227
xmc_norsram_default_para_init
void xmc_norsram_default_para_init(xmc_norsram_init_type *xmc_nor_sram_init_struct)
fill each xmc_nor_sram_init_struct member with its default value.
Definition: at32f435_437_xmc.c:150
xmc_nor_sram_enable
void xmc_nor_sram_enable(xmc_nor_sram_subbank_type xmc_subbank, confirm_state new_state)
enable or disable the specified nor/sram memory bank.
Definition: at32f435_437_xmc.c:210
XMC_WAIT_SIGNAL_DISABLE
@ XMC_WAIT_SIGNAL_DISABLE
Definition: at32f435_437_xmc.h:101
XMC_WAIT_SIGNAL_SYN_BEFORE
@ XMC_WAIT_SIGNAL_SYN_BEFORE
Definition: at32f435_437_xmc.h:196
XMC_WRITE_OPERATION_ENABLE
@ XMC_WRITE_OPERATION_ENABLE
Definition: at32f435_437_xmc.h:93
XMC_WRITE_BURST_SYN_DISABLE
@ XMC_WRITE_BURST_SYN_DISABLE
Definition: at32f435_437_xmc.h:110
XMC_BURST_MODE_DISABLE
@ XMC_BURST_MODE_DISABLE
Definition: at32f435_437_xmc.h:65
XMC_DATA_ADDR_MUX_DISABLE
@ XMC_DATA_ADDR_MUX_DISABLE
Definition: at32f435_437_xmc.h:56
XMC_BUSTYPE_8_BITS
@ XMC_BUSTYPE_8_BITS
Definition: at32f435_437_xmc.h:178
XMC_WRITE_TIMING_ENABLE
@ XMC_WRITE_TIMING_ENABLE
Definition: at32f435_437_xmc.h:120
XMC_BANK1_NOR_SRAM1
@ XMC_BANK1_NOR_SRAM1
Definition: at32f435_437_xmc.h:146
XMC_ASYN_WAIT_DISABLE
@ XMC_ASYN_WAIT_DISABLE
Definition: at32f435_437_xmc.h:74
XMC_WRAPPED_MODE_DISABLE
@ XMC_WRAPPED_MODE_DISABLE
Definition: at32f435_437_xmc.h:83
XMC_ACCESS_MODE_A
@ XMC_ACCESS_MODE_A
Definition: at32f435_437_xmc.h:205
XMC_WAIT_SIGNAL_LEVEL_LOW
@ XMC_WAIT_SIGNAL_LEVEL_LOW
Definition: at32f435_437_xmc.h:187
XMC_DEVICE_SRAM
@ XMC_DEVICE_SRAM
Definition: at32f435_437_xmc.h:168
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
xmc_norsram_init_type
xmc nor/sram init structure definition
Definition: at32f435_437_xmc.h:409
xmc_norsram_init_type::wait_signal_enable
xmc_wait_signal_type wait_signal_enable
Definition: at32f435_437_xmc.h:420
xmc_norsram_init_type::data_addr_multiplex
xmc_data_addr_mux_type data_addr_multiplex
Definition: at32f435_437_xmc.h:411
xmc_norsram_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:421
xmc_norsram_init_type::burst_mode_enable
xmc_burst_access_mode_type burst_mode_enable
Definition: at32f435_437_xmc.h:414
xmc_norsram_init_type::bus_type
xmc_data_width_type bus_type
Definition: at32f435_437_xmc.h:413
xmc_norsram_init_type::device
xmc_memory_type device
Definition: at32f435_437_xmc.h:412
xmc_norsram_init_type::wait_signal_lv
xmc_wait_signal_polarity_type wait_signal_lv
Definition: at32f435_437_xmc.h:416
xmc_norsram_init_type::wrapped_mode_enable
xmc_wrap_mode_type wrapped_mode_enable
Definition: at32f435_437_xmc.h:417
xmc_norsram_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:410
xmc_norsram_init_type::write_burst_syn
xmc_write_burst_type write_burst_syn
Definition: at32f435_437_xmc.h:422
xmc_norsram_init_type::asynwait_enable
xmc_asyn_wait_type asynwait_enable
Definition: at32f435_437_xmc.h:415
xmc_norsram_init_type::wait_signal_config
xmc_wait_timing_type wait_signal_config
Definition: at32f435_437_xmc.h:418
xmc_norsram_init_type::write_enable
xmc_write_operation_type write_enable
Definition: at32f435_437_xmc.h:419
xmc_norsram_timing_init_type
nor/sram banks timing parameters
Definition: at32f435_437_xmc.h:393
xmc_norsram_timing_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:395
xmc_norsram_timing_init_type::data_latency_time
uint32_t data_latency_time
Definition: at32f435_437_xmc.h:401
xmc_norsram_timing_init_type::addr_hold_time
uint32_t addr_hold_time
Definition: at32f435_437_xmc.h:397
xmc_norsram_timing_init_type::bus_latency_time
uint32_t bus_latency_time
Definition: at32f435_437_xmc.h:399
xmc_norsram_timing_init_type::addr_setup_time
uint32_t addr_setup_time
Definition: at32f435_437_xmc.h:396
xmc_norsram_timing_init_type::mode
xmc_access_mode_type mode
Definition: at32f435_437_xmc.h:402
xmc_norsram_timing_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:394
xmc_norsram_timing_init_type::clk_psc
uint32_t clk_psc
Definition: at32f435_437_xmc.h:400
xmc_norsram_timing_init_type::data_setup_time
uint32_t data_setup_time
Definition: at32f435_437_xmc.h:398


AT32F435/437 Firmwary Library: touch.h File Reference

  • at_start_f435
  • examples
  • xmc
  • lcd_touch_16bit
  • inc
Data Structures | Macros | Functions | Variables
at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h File Reference

this file contains all the functions prototypes for the touch firmware driver. More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Data Structures

struct touch_dev_type

Macros

#define | TCLK_HIGH gpio_bits_set(GPIOB,GPIO_PINS_13)
#define | TCLK_LOW gpio_bits_reset(GPIOB,GPIO_PINS_13)
#define | TDOUT gpio_input_data_bit_read(GPIOB,GPIO_PINS_8)
#define | TDIN_HIGH gpio_bits_set(GPIOA,GPIO_PINS_1)
#define | TDIN_LOW gpio_bits_reset(GPIOA,GPIO_PINS_1)
#define | PEN_HIGH gpio_input_data_bit_read(GPIOB,GPIO_PINS_11)
#define | TCS_HIGH gpio_bits_set(GPIOB,GPIO_PINS_12)
#define | TCS_LOW gpio_bits_reset(GPIOB,GPIO_PINS_12)

Functions

void | touch_pin_init (void)
this function is init touch pin. More...
void | touch_read_xy (uint16_t *x, uint16_t *y)
this function is read data from touch. More...
void | touch_scan (void)
this function is scanning the screen. More...
uint16_t | touch_read_x_or_y (uint8_t xy)
uint16_t | touch_read_ad (uint8_t xy)
this function is read data from touch. More...
void | touch_write_1byte (uint8_t cmd)
this function is write command to touch. More...
uint8_t | touch_read_1byte (void)
this function is read data from touch. More...
error_status | touch_adjust (void)
this function is adjust the screen. More...

Variables

touch_dev_type touch_dev_struct
touch_dev_type * touch_struct

Detailed Description

this file contains all the functions prototypes for the touch firmware driver.

Version
v2.0.9
Date
2022-06-28
        Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h.


AT32F435/437 Firmwary Library: touch.h Source File

  • at_start_f435
  • examples
  • xmc
  • lcd_touch_16bit
  • inc
at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h
Go to the documentation of this file.
1
29#ifndef __TOUCH_H
30#define __TOUCH_H
31
32#include "at32f435_437_board.h"
33
46typedef struct
47{
48 void (*init)(void);
49 void (*touch_read_xy)(uint16_t *x, uint16_t *y);
50 void (*touch_scan)(void);
51 error_status (*touch_adjust)(void);
52 uint16_t x_p[6];
53 uint16_t y_p[6];
54}touch_dev_type;
55
60extern touch_dev_type touch_dev_struct;
61extern touch_dev_type *touch_struct;
62
63#define TCLK_HIGH gpio_bits_set(GPIOB,GPIO_PINS_13)
64#define TCLK_LOW gpio_bits_reset(GPIOB,GPIO_PINS_13)
65
66#define TDOUT gpio_input_data_bit_read(GPIOB,GPIO_PINS_8)
67
68#define TDIN_HIGH gpio_bits_set(GPIOA,GPIO_PINS_1)
69#define TDIN_LOW gpio_bits_reset(GPIOA,GPIO_PINS_1)
70
71#define PEN_HIGH gpio_input_data_bit_read(GPIOB,GPIO_PINS_11)
72
73#define TCS_HIGH gpio_bits_set(GPIOB,GPIO_PINS_12)
74#define TCS_LOW gpio_bits_reset(GPIOB,GPIO_PINS_12)
75
80void touch_pin_init(void);
81void touch_read_xy(uint16_t *x, uint16_t *y);
82void touch_scan(void);
83uint16_t touch_read_x_or_y(uint8_t xy);
84uint16_t touch_read_ad(uint8_t xy);
85void touch_write_1byte(uint8_t cmd);
86uint8_t touch_read_1byte(void);
87 error_status touch_adjust(void);
88
104#endif
105
106
107
108
109
at32f435_437_board.h
touch_struct
touch_dev_type * touch_struct
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c:51
touch_dev_struct
touch_dev_type touch_dev_struct
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c:38
error_status
error_status
Definition: at32f435_437.h:380
touch_read_ad
uint16_t touch_read_ad(uint8_t xy)
this function is read data from touch.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:181
touch_scan
void touch_scan(void)
this function is scanning the screen.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:240
touch_write_1byte
void touch_write_1byte(uint8_t cmd)
this function is write command to touch.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:208
touch_read_xy
void touch_read_xy(uint16_t *x, uint16_t *y)
this function is read data from touch.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:120
touch_adjust
error_status touch_adjust(void)
this function is adjust the screen.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:263
touch_read_1byte
uint8_t touch_read_1byte(void)
this function is read data from touch.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:222
touch_read_x_or_y
uint16_t touch_read_x_or_y(uint8_t xy)
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:138
touch_pin_init
void touch_pin_init(void)
this function is init touch pin.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:58
touch_dev_type
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h:47


AT32F435/437 Firmwary Library: xmc_lcd.h File Reference

  • at_start_f435
  • examples
  • xmc
  • lcd_touch_16bit
  • inc
Data Structures | Macros | Functions | Variables
at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h File Reference

xmc_lcd program header More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Data Structures

struct lcd_dev_type

Macros

#define | XMC_LCD_COMMAND 0x6C000000
#define | XMC_LCD_DATA 0x6C000800
#define | LCD_BL_HIGH gpio_bits_set(GPIOC,GPIO_PINS_0)
#define | LCD_BL_LOW gpio_bits_reset(GPIOC,GPIO_PINS_0)
#define | WHITE 0xFFFF
#define | BLACK 0x0000
#define | BLUE 0x001F
#define | BRED 0xF81F
#define | GRED 0xFFE0
#define | GBLUE 0x07FF
#define | RED 0xF800
#define | MAGENTA 0xF81F
#define | GREEN 0x07E0
#define | CYAN 0x7FFF
#define | YELLOW 0xFFE0
#define | BROWN 0xBC40
#define | BRRED 0xFC07
#define | GRAY 0x8430

Functions

void | xmc_init (void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_init (void)
configures the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_wr_command (uint16_t command)
this function is write command to lcd. More...
void | lcd_wr_data (uint16_t data)
this function is write data to lcd. More...
uint16_t | lcd_rd_data (void)
void | lcd_setblock (uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd. More...
void | lcd_writeonepoint (uint16_t color)
this function is write one point to lcd. More...
void | lcd_drawpoint (uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd. More...
void | lcd_clear (uint16_t color)
this function is clear the lcd. More...

Variables

lcd_dev_type lcd_dev_struct
lcd_dev_type * lcd_struct
static uint16_t LCD_ID

Detailed Description

xmc_lcd program header

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.


AT32F435/437 Firmwary Library: xmc_lcd.h Source File

  • at_start_f435
  • examples
  • xmc
  • lcd_touch_16bit
  • inc
at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
Go to the documentation of this file.
1
26#ifndef __XMC_LCD_H
27#define __XMC_LCD_H
28
29#include "at32f435_437_board.h"
30
43typedef struct
44{
45 uint16_t lcd_id;
46 void (*xmc_init)(void);
47 void (*lcd_init)(void);
48 void (*lcd_setblock)(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend);
49 void (*draw_point)(uint16_t x, uint16_t y, uint16_t color);
50 void (*lcd_clear)(uint16_t color);
51} lcd_dev_type;
52
57extern lcd_dev_type lcd_dev_struct;
58extern lcd_dev_type *lcd_struct;
59
64/* the address of write data & command (xmc_a10) */
65#define XMC_LCD_COMMAND 0x6C000000
66#define XMC_LCD_DATA 0x6C000800
79#define LCD_BL_HIGH gpio_bits_set(GPIOC,GPIO_PINS_0)
80#define LCD_BL_LOW gpio_bits_reset(GPIOC,GPIO_PINS_0)
81static uint16_t LCD_ID;
82#define WHITE 0xFFFF
83#define BLACK 0x0000
84#define BLUE 0x001F
85#define BRED 0xF81F
86#define GRED 0xFFE0
87#define GBLUE 0x07FF
88#define RED 0xF800
89#define MAGENTA 0xF81F
90#define GREEN 0x07E0
91#define CYAN 0x7FFF
92#define YELLOW 0xFFE0
93#define BROWN 0xBC40
94#define BRRED 0xFC07
95#define GRAY 0x8430
96
101void xmc_init(void);
102void lcd_init(void);
103void lcd_wr_command(uint16_t command);
104void lcd_wr_data(uint16_t data);
105uint16_t lcd_rd_data(void);
106void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend);
107void lcd_writeonepoint(uint16_t color);
108void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color);
109void lcd_clear(uint16_t color);
110
123#endif
124
125
at32f435_437_board.h
lcd_setblock
void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:332
lcd_init
void lcd_init(void)
configures the lcd. this function must be called before any write/read operation on the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:165
lcd_drawpoint
void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:367
lcd_wr_command
void lcd_wr_command(uint16_t command)
this function is write command to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:300
lcd_rd_data
uint16_t lcd_rd_data(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:315
lcd_clear
void lcd_clear(uint16_t color)
this function is clear the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:379
lcd_writeonepoint
void lcd_writeonepoint(uint16_t color)
this function is write one point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:357
lcd_wr_data
void lcd_wr_data(uint16_t data)
this function is write data to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:310
xmc_init
void xmc_init(void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write...
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:57
lcd_dev_struct
lcd_dev_type lcd_dev_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:38
LCD_ID
static uint16_t LCD_ID
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h:81
lcd_struct
lcd_dev_type * lcd_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:48
lcd_dev_type
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:44


AT32F435/437 Firmwary Library: touch.c File Reference

  • at_start_f435
  • examples
  • xmc
  • lcd_touch_16bit
  • src
Macros | Functions | Variables
at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c File Reference

this file contains all the functions prototypes for the touch firmware driver. More...

#include "touch.h"
#include "xmc_lcd.h"

Go to the source code of this file.

Macros

#define | READ_TIMES 5
this function is processing data that read from touch. More...
#define | LOST_VAL 1

Functions

void | touch_pin_init (void)
this function is init touch pin. More...
void | touch_read_xy (uint16_t *x, uint16_t *y)
this function is read data from touch. More...
uint16_t | touch_read_x_or_y (uint8_t xy)
uint16_t | touch_read_ad (uint8_t xy)
this function is read data from touch. More...
void | touch_write_1byte (uint8_t cmd)
this function is write command to touch. More...
uint8_t | touch_read_1byte (void)
this function is read data from touch. More...
void | touch_scan (void)
this function is scanning the screen. More...
error_status | touch_adjust (void)
this function is adjust the screen. More...

Variables

touch_dev_type touch_dev_struct
uint8_t | cmd_rdx = 0xd0
uint8_t | cmd_rdy = 0x90
touch_dev_type * touch_struct

Detailed Description

this file contains all the functions prototypes for the touch firmware driver.

Version
v2.0.9
Date
2022-06-28
        Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c.


AT32F435/437 Firmwary Library: touch.c Source File

  • at_start_f435
  • examples
  • xmc
  • lcd_touch_16bit
  • src
at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c
Go to the documentation of this file.
1
27#include "touch.h"
28#include "xmc_lcd.h"
29
38 touch_dev_type touch_dev_struct =
39{
40 touch_pin_init,
41 touch_read_xy,
42 touch_scan,
43 touch_adjust,
44 0,
45 0,
46};
47
48uint8_t cmd_rdx = 0xd0;
49uint8_t cmd_rdy = 0x90;
50
51 touch_dev_type *touch_struct;
52
58void touch_pin_init(void)
59{
60 gpio_init_type gpio_init_struct = {0};
61 spi_init_type spi_init_struct;
62
63 /* enable the gpio clock */
64 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
65 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_SPI4_PERIPH_CLOCK, TRUE);
67
68 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE13, GPIO_MUX_6);
69 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE8, GPIO_MUX_6);
70 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE1, GPIO_MUX_5);
71
72 gpio_init_struct.gpio_pins = GPIO_PINS_13 | GPIO_PINS_8;
73 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
74 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
75 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
76 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
77 gpio_init(GPIOB, &gpio_init_struct);
78
79 gpio_init_struct.gpio_pins = GPIO_PINS_1;
80 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
81 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
82 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
83 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
84 gpio_init(GPIOA, &gpio_init_struct);
85
86 gpio_init_struct.gpio_pins = GPIO_PINS_12;
87 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
88 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
89 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
90 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
91 gpio_init(GPIOB, &gpio_init_struct);
92
93 gpio_init_struct.gpio_pins = GPIO_PINS_11;
94 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
95 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
96 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
97 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
98 gpio_init(GPIOB, &gpio_init_struct);
99
100 gpio_bits_set(GPIOB, GPIO_PINS_11);
101
102 spi_default_para_init(&spi_init_struct);
103 spi_init_struct.transmission_mode = SPI_TRANSMIT_FULL_DUPLEX;
104 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
105 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_256;
106 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_MSB;
107 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
108 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_HIGH;
109 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
110 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
111 spi_init(SPI4, &spi_init_struct);
112 spi_enable(SPI4, TRUE);
113}
114
120void touch_read_xy(uint16_t *x, uint16_t *y)
121{
122 uint16_t xtemp, ytemp;
123 xtemp = touch_read_x_or_y(cmd_rdx);
124 ytemp = touch_read_x_or_y(cmd_rdy);
125
126 *x = xtemp;
127 *y = ytemp;
128}
129
135/* read five times, remove max and min, and then take the average */
136#define READ_TIMES 5
137#define LOST_VAL 1
138uint16_t touch_read_x_or_y(uint8_t xy)
139{
140 uint16_t i, j;
141 uint16_t buf[READ_TIMES];
142 uint16_t sum = 0;
143 uint16_t temp;
144
145 for(i = 0; i < READ_TIMES; i++)
146 {
147 buf[i] = touch_read_ad(xy);
148 }
149
150 for(i = 0; i < READ_TIMES - 1; i++)
151 {
152 for(j = i + 1; j < READ_TIMES; j++)
153 {
154 /* increase the sorting */
155 if(buf[i] > buf[j])
156 {
157 temp = buf[i];
158 buf[i] = buf[j];
159 buf[j] = temp;
160 }
161 }
162 }
163
164 sum = 0;
165
166 for(i = LOST_VAL; i < READ_TIMES - LOST_VAL; i++)
167 {
168 sum += buf[i];
169 }
170
171 temp = sum/(READ_TIMES - 2 * LOST_VAL);
172
173 return temp;
174}
175
181uint16_t touch_read_ad(uint8_t xy)
182{
183 uint16_t num = 0;
184
185 /* enable touch ic */
186 TCS_LOW;
187
188 /* send command */
189 touch_write_1byte(xy);
190
191 /* touch ic conversion timer */
192 delay_us(6);
193 num = touch_read_1byte();
194 num = num << 8;
195 num |= touch_read_1byte();
196 num >>= 3;
197
198 /* disable touch ic */
199 TCS_HIGH;
200 return(num);
201}
202
208void touch_write_1byte(uint8_t cmd)
209{
210 while(spi_i2s_flag_get(SPI4, SPI_I2S_TDBE_FLAG) == RESET);
211 spi_i2s_data_transmit(SPI4, cmd);
212
213 while(spi_i2s_flag_get(SPI4, SPI_I2S_RDBF_FLAG) == RESET);
214 SPI4->dt;
215}
216
222uint8_t touch_read_1byte(void)
223{
224 uint8_t touch;
225
226 while(spi_i2s_flag_get(SPI4, SPI_I2S_TDBE_FLAG) == RESET);
227 spi_i2s_data_transmit(SPI4, 0XFF);
228
229 while(spi_i2s_flag_get(SPI4, SPI_I2S_RDBF_FLAG) == RESET);
230 touch = spi_i2s_data_receive(SPI4);
231
232 return touch;
233}
234
240void touch_scan(void)
241{
242 uint16_t x, y;
243
244 if(gpio_input_data_bit_read(GPIOB, GPIO_PINS_11) == 0)
245 {
246 touch_dev_struct.touch_read_xy(&touch_dev_struct.x_p[1], &touch_dev_struct.y_p[1]);
247 x = (240 * touch_dev_struct.x_p[1]) / (0xed0);
248 y = (320 * touch_dev_struct.y_p[1]) / (0xe60);
249
250 lcd_drawpoint(x, y, RED);
251 lcd_drawpoint(x - 1, y, RED);
252 lcd_drawpoint(x + 1, y, RED);
253 lcd_drawpoint(x, y + 1, RED);
254 lcd_drawpoint(x, y - 1, RED);
255 }
256}
257
263 error_status touch_adjust(void)
264{
265 /* touch adjust code */
266 return SUCCESS;
267}
268
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
lcd_drawpoint
void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:367
RED
#define RED
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:90
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:40
cmd_rdy
uint8_t cmd_rdy
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c:49
LOST_VAL
#define LOST_VAL
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c:137
cmd_rdx
uint8_t cmd_rdx
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c:48
touch_read_ad
uint16_t touch_read_ad(uint8_t xy)
this function is read data from touch.
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c:181
touch_scan
void touch_scan(void)
this function is scanning the screen.
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c:240
touch_write_1byte
void touch_write_1byte(uint8_t cmd)
this function is write command to touch.
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c:208
TCS_HIGH
#define TCS_HIGH
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h:73
READ_TIMES
#define READ_TIMES
this function is processing data that read from touch.
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c:136
touch_read_xy
void touch_read_xy(uint16_t *x, uint16_t *y)
this function is read data from touch.
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c:120
touch_struct
touch_dev_type * touch_struct
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c:51
touch_adjust
error_status touch_adjust(void)
this function is adjust the screen.
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c:263
touch_dev_struct
touch_dev_type touch_dev_struct
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c:38
TCS_LOW
#define TCS_LOW
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h:74
touch_read_1byte
uint8_t touch_read_1byte(void)
this function is read data from touch.
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c:222
touch_read_x_or_y
uint16_t touch_read_x_or_y(uint8_t xy)
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c:138
touch_pin_init
void touch_pin_init(void)
this function is init touch pin.
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c:58
j
uint32_t j
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:44
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f435_437_board.c:306
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_SPI4_PERIPH_CLOCK
@ CRM_SPI4_PERIPH_CLOCK
Definition: at32f435_437_crm.h:162
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
error_status
error_status
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_input_data_bit_read
flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified input port pin.
Definition: at32f435_437_gpio.c:170
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f435_437_gpio.c:277
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f435_437_gpio.h:82
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f435_437_gpio.h:146
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_6
@ GPIO_MUX_6
Definition: at32f435_437_gpio.h:162
GPIO_MUX_5
@ GPIO_MUX_5
Definition: at32f435_437_gpio.h:161
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f435_437_gpio.h:64
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f435_437_spi.h:54
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f435_437_spi.h:53
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f435_437_spi.c:548
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f435_437_spi.c:583
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f435_437_spi.c:101
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f435_437_spi.c:81
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f435_437_spi.c:560
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f435_437_spi.c:321
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f435_437_spi.h:100
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f435_437_spi.h:118
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f435_437_spi.h:127
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f435_437_spi.h:153
SPI_CLOCK_POLARITY_HIGH
@ SPI_CLOCK_POLARITY_HIGH
Definition: at32f435_437_spi.h:109
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f435_437_spi.h:162
SPI_MCLK_DIV_256
@ SPI_MCLK_DIV_256
Definition: at32f435_437_spi.h:143
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f435_437_spi.h:90
SPI4
#define SPI4
Definition: at32f435_437_spi.h:456
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
spi_init_type
spi init type
Definition: at32f435_437_spi.h:259
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f435_437_spi.h:261
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f435_437_spi.h:263
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f435_437_spi.h:264
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:265
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f435_437_spi.h:267
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f435_437_spi.h:262
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f435_437_spi.h:260
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f435_437_spi.h:266
touch_dev_type
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h:47
touch_dev_type::touch_read_xy
void(* touch_read_xy)(uint16_t *x, uint16_t *y)
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h:49
touch_dev_type::y_p
uint16_t y_p[6]
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h:53
touch_dev_type::x_p
uint16_t x_p[6]
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h:52


AT32F435/437 Firmwary Library: xmc_lcd.c File Reference

  • at_start_f435
  • examples
  • xmc
  • lcd_touch_16bit
  • src
Functions | Variables
at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c File Reference

xmc_lcd program file More...

#include "xmc_lcd.h"

Go to the source code of this file.

Functions

void | xmc_init (void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_init (void)
configures the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_wr_command (uint16_t command)
this function is write command to lcd. More...
void | lcd_wr_data (uint16_t data)
this function is write data to lcd. More...
uint16_t | lcd_rd_data (void)
void | lcd_setblock (uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd. More...
void | lcd_writeonepoint (uint16_t color)
this function is write one point to lcd. More...
void | lcd_drawpoint (uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd. More...
void | lcd_clear (uint16_t color)
this function is clear the lcd. More...

Variables

lcd_dev_type lcd_dev_struct
lcd_dev_type * lcd_struct

Detailed Description

xmc_lcd program file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c.


AT32F435/437 Firmwary Library: xmc_lcd.c Source File

  • at_start_f435
  • examples
  • xmc
  • lcd_touch_16bit
  • src
at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c
Go to the documentation of this file.
1
27#include "xmc_lcd.h"
28
37 lcd_dev_type lcd_dev_struct =
38{
39 0,
40 xmc_init,
41 lcd_init,
42 lcd_setblock,
43 lcd_drawpoint,
44 lcd_clear,
45};
46
47 lcd_dev_type *lcd_struct;
48
56void xmc_init(void)
57{
58 gpio_init_type gpio_init_struct = {0};
59 xmc_norsram_init_type xmc_norsram_init_struct;
60 xmc_norsram_timing_init_type rw_timing_struct, w_timing_struct;
61
62 /* enable the gpio clock */
63// crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
64 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
65 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
67// crm_periph_clock_enable(CRM_GPIOF_PERIPH_CLOCK, TRUE);
68
69 /* enable the xmc clock */
70 crm_periph_clock_enable(CRM_XMC_PERIPH_CLOCK, TRUE);
71
72 /*-- gpio configuration ------------------------------------------------------*/
73 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE2, GPIO_MUX_14);
74 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE4, GPIO_MUX_14);
75 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE5, GPIO_MUX_14);
76 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE11, GPIO_MUX_14);
77 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE12, GPIO_MUX_14);
78 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE5, GPIO_MUX_10);
79 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE8, GPIO_MUX_12);
80 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE9, GPIO_MUX_12);
81 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE10, GPIO_MUX_12);
82 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE14, GPIO_MUX_12);
83 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE15, GPIO_MUX_12);
84
85 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE7, GPIO_MUX_12);
86 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE8, GPIO_MUX_12);
87 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE9, GPIO_MUX_12);
88 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE10, GPIO_MUX_12);
89 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE11, GPIO_MUX_12);
90 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE12, GPIO_MUX_12);
91 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE13, GPIO_MUX_12);
92 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE14, GPIO_MUX_12);
93 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE15, GPIO_MUX_12);
94
95 /* lcd data lines configuration */
96 gpio_init_struct.gpio_pins = GPIO_PINS_2 | GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_11| GPIO_PINS_12;
97 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
98 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
99 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
100 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
101 gpio_init(GPIOC, &gpio_init_struct);
102
103
104 gpio_init_struct.gpio_pins = GPIO_PINS_5 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_14 | GPIO_PINS_15;
105 gpio_init(GPIOD, &gpio_init_struct);
106
107 gpio_init_struct.gpio_pins = GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11 | GPIO_PINS_12 | GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
108 gpio_init(GPIOE, &gpio_init_struct);
109
110 /* lcd bl lines configuration */
111 gpio_init_struct.gpio_pins = GPIO_PINS_0;
112 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
113 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
114 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
115 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
116 gpio_init(GPIOC, &gpio_init_struct);
117
118
119 /*-- xmc configuration ------------------------------------------------------*/
120 xmc_norsram_default_para_init(&xmc_norsram_init_struct);
121 xmc_norsram_init_struct.subbank = XMC_BANK1_NOR_SRAM4;
122 xmc_norsram_init_struct.data_addr_multiplex = XMC_DATA_ADDR_MUX_DISABLE;
123 xmc_norsram_init_struct.device = XMC_DEVICE_SRAM;
124 xmc_norsram_init_struct.bus_type = XMC_BUSTYPE_16_BITS;
125 xmc_norsram_init_struct.burst_mode_enable = XMC_BURST_MODE_DISABLE;
126 xmc_norsram_init_struct.asynwait_enable = XMC_ASYN_WAIT_DISABLE;
127 xmc_norsram_init_struct.wait_signal_lv = XMC_WAIT_SIGNAL_LEVEL_LOW;
128 xmc_norsram_init_struct.wrapped_mode_enable = XMC_WRAPPED_MODE_DISABLE;
129 xmc_norsram_init_struct.wait_signal_config = XMC_WAIT_SIGNAL_SYN_BEFORE;
130 xmc_norsram_init_struct.write_enable = XMC_WRITE_OPERATION_ENABLE;
131 xmc_norsram_init_struct.wait_signal_enable = XMC_WAIT_SIGNAL_DISABLE;
132 xmc_norsram_init_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
133 xmc_norsram_init_struct.write_burst_syn = XMC_WRITE_BURST_SYN_DISABLE;
134 xmc_nor_sram_init(&xmc_norsram_init_struct);
135
136 /* timing configuration */
137 xmc_norsram_timing_default_para_init(&rw_timing_struct, &w_timing_struct);
138 rw_timing_struct.subbank = XMC_BANK1_NOR_SRAM4;
139 rw_timing_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
140 rw_timing_struct.addr_setup_time = 0x2;
141 rw_timing_struct.addr_hold_time = 0x0;
142 rw_timing_struct.data_setup_time = 0x2;
143 rw_timing_struct.bus_latency_time = 0x0;
144 rw_timing_struct.clk_psc = 0x0;
145 rw_timing_struct.data_latency_time = 0x0;
146 rw_timing_struct.mode = XMC_ACCESS_MODE_A;
147 w_timing_struct.subbank = XMC_BANK1_NOR_SRAM4;
148 w_timing_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
149 w_timing_struct.addr_setup_time = 0x2;
150 w_timing_struct.addr_hold_time = 0x0;
151 w_timing_struct.data_setup_time = 0x2;
152 w_timing_struct.bus_latency_time = 0x0;
153 w_timing_struct.clk_psc = 0x0;
154 w_timing_struct.data_latency_time = 0x0;
155 w_timing_struct.mode = XMC_ACCESS_MODE_A;
156 xmc_nor_sram_timing_config(&rw_timing_struct, &w_timing_struct);
157
158 /* bus turnaround phase for consecutive read duration and consecutive write duration */
159 xmc_ext_timing_config(XMC_BANK1_NOR_SRAM4, 0x08, 0x08);
160
161 /* enable xmc_bank1_nor_sram4 */
162 xmc_nor_sram_enable(XMC_BANK1_NOR_SRAM4, TRUE);
163}
164
172void lcd_init(void)
173{
174 /* init xmc */
175 lcd_struct->xmc_init();
176
177 delay_ms(50);
178
179 /* read id */
180 lcd_wr_command(0x0000);
181 delay_ms(5);
182
183 lcd_struct->lcd_id = lcd_rd_data();
184 lcd_wr_command(0xd3);
185
186 lcd_struct->lcd_id = lcd_rd_data();
187 lcd_struct->lcd_id = lcd_rd_data();
188 lcd_struct->lcd_id = lcd_rd_data();
189 lcd_struct->lcd_id = lcd_rd_data();
190 lcd_struct->lcd_id = lcd_struct->lcd_id << 8;
191 lcd_struct->lcd_id |= lcd_rd_data();
192
193 lcd_wr_command(0xcf);
194 lcd_wr_data(0x00);
195 lcd_wr_data(0xc1);
196 lcd_wr_data(0x30);
197 lcd_wr_command(0xed);
198 lcd_wr_data(0x64);
199 lcd_wr_data(0x03);
200 lcd_wr_data(0x12);
201 lcd_wr_data(0x81);
202 lcd_wr_command(0xe8);
203 lcd_wr_data(0x85);
204 lcd_wr_data(0x10);
205 lcd_wr_data(0x7a);
206 lcd_wr_command(0xcb);
207 lcd_wr_data(0x39);
208 lcd_wr_data(0x2c);
209 lcd_wr_data(0x00);
210 lcd_wr_data(0x34);
211 lcd_wr_data(0x02);
212 lcd_wr_command(0xf7);
213 lcd_wr_data(0x20);
214 lcd_wr_command(0xea);
215 lcd_wr_data(0x00);
216 lcd_wr_data(0x00);
217 lcd_wr_command(0xc0);
218 lcd_wr_data(0x1b);
219 lcd_wr_command(0xc1);
220 lcd_wr_data(0x01);
221 lcd_wr_command(0xc5);
222 lcd_wr_data(0x30);
223 lcd_wr_data(0x30);
224 lcd_wr_command(0xc7);
225 lcd_wr_data(0xb7);
226 lcd_wr_command(0x36);
227 lcd_wr_data(0x48);
228 lcd_wr_command(0x3a);
229 lcd_wr_data(0x55);
230 lcd_wr_command(0xb1);
231 lcd_wr_data(0x00);
232 lcd_wr_data(0x1a);
233 lcd_wr_command(0xb6);
234 lcd_wr_data(0x0a);
235 lcd_wr_data(0xa2);
236 lcd_wr_command(0xf2);
237 lcd_wr_data(0x00);
238 lcd_wr_command(0x26);
239 lcd_wr_data(0x01);
240 lcd_wr_command(0xe0);
241 lcd_wr_data(0x0f);
242 lcd_wr_data(0x2a);
243 lcd_wr_data(0x28);
244 lcd_wr_data(0x08);
245 lcd_wr_data(0x0e);
246 lcd_wr_data(0x08);
247 lcd_wr_data(0x54);
248 lcd_wr_data(0xa9);
249 lcd_wr_data(0x43);
250 lcd_wr_data(0x0a);
251 lcd_wr_data(0x0f);
252 lcd_wr_data(0x00);
253 lcd_wr_data(0x00);
254 lcd_wr_data(0x00);
255 lcd_wr_data(0x00);
256 lcd_wr_command(0xe1);
257 lcd_wr_data(0x00);
258 lcd_wr_data(0x15);
259 lcd_wr_data(0x17);
260 lcd_wr_data(0x07);
261 lcd_wr_data(0x11);
262 lcd_wr_data(0x06);
263 lcd_wr_data(0x2b);
264 lcd_wr_data(0x56);
265 lcd_wr_data(0x3c);
266 lcd_wr_data(0x05);
267 lcd_wr_data(0x10);
268 lcd_wr_data(0x0f);
269 lcd_wr_data(0x3f);
270 lcd_wr_data(0x3f);
271 lcd_wr_data(0x0f);
272 lcd_wr_command(0x2b);
273 lcd_wr_data(0x00);
274 lcd_wr_data(0x00);
275 lcd_wr_data(0x01);
276 lcd_wr_data(0x3f);
277 lcd_wr_command(0x2a);
278 lcd_wr_data(0x00);
279 lcd_wr_data(0x00);
280 lcd_wr_data(0x00);
281 lcd_wr_data(0xef);
282 lcd_wr_command(0x11);
283 delay_ms(120);
284 lcd_wr_command(0x29);
285 lcd_wr_command(0x36);
286 lcd_wr_data(0x08);
287 lcd_wr_command(0x2a);
288 lcd_wr_data(0x00);
289 lcd_wr_data(0x00);
290 lcd_wr_data(0xef >> 8);
291 lcd_wr_data(0xef & 0xff);
292 lcd_wr_command(0x2b);
293 lcd_wr_data(0x00);
294 lcd_wr_data(0x00);
295 lcd_wr_data(0x13f >> 8);
296 lcd_wr_data(0x13f & 0xff);
297 LCD_BL_HIGH;
298}
299
305void lcd_wr_command(uint16_t command)
306{
307 *(__IO uint16_t*) XMC_LCD_COMMAND = command;
308}
309
315void lcd_wr_data(uint16_t data)
316{
317 *(__IO uint16_t*) XMC_LCD_DATA = data;
318}
319
320uint16_t lcd_rd_data(void)
321{
322 uint16_t data;
323
324 data = *(uint16_t*)XMC_LCD_DATA;
325
326 return data;
327}
328
337void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
338{
339 /* set row coordinates */
340 lcd_wr_command(0x2a);
341 lcd_wr_data(xstart >> 8);
342 lcd_wr_data(xstart);
343 lcd_wr_data(xend >> 8);
344 lcd_wr_data(xend);
345
346 /* set column coordinates */
347 lcd_wr_command(0x2b);
348 lcd_wr_data(ystart >> 8);
349 lcd_wr_data(ystart);
350 lcd_wr_data(yend >> 8);
351 lcd_wr_data(yend);
352
353 /* enable write menory */
354 lcd_wr_command(0x2c);
355}
356
362void lcd_writeonepoint(uint16_t color)
363{
364 lcd_wr_data(color);
365}
366
372void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
373{
374 lcd_struct->lcd_setblock(x, y ,x ,y);
375
376 lcd_writeonepoint(color);
377}
378
384void lcd_clear(uint16_t color)
385{
386 uint32_t i;
387
388 lcd_struct->lcd_setblock(0, 0, 240, 320);
389
390 for(i = 0; i < 76800; i++)
391 {
392 lcd_writeonepoint(color);
393 }
394}
395
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
LCD_BL_HIGH
#define LCD_BL_HIGH
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:81
lcd_setblock
void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd.
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c:337
lcd_dev_struct
lcd_dev_type lcd_dev_struct
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c:37
lcd_init
void lcd_init(void)
configures the lcd. this function must be called before any write/read operation on the lcd.
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c:172
lcd_drawpoint
void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd.
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c:372
lcd_wr_command
void lcd_wr_command(uint16_t command)
this function is write command to lcd.
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c:305
lcd_rd_data
uint16_t lcd_rd_data(void)
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c:320
lcd_clear
void lcd_clear(uint16_t color)
this function is clear the lcd.
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c:384
lcd_struct
lcd_dev_type * lcd_struct
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c:47
lcd_writeonepoint
void lcd_writeonepoint(uint16_t color)
this function is write one point to lcd.
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c:362
lcd_wr_data
void lcd_wr_data(uint16_t data)
this function is write data to lcd.
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c:315
xmc_init
void xmc_init(void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write...
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c:56
XMC_LCD_COMMAND
#define XMC_LCD_COMMAND
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:65
XMC_LCD_DATA
#define XMC_LCD_DATA
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:66
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_XMC_PERIPH_CLOCK
@ CRM_XMC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:123
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f435_437_gpio.h:146
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_10
@ GPIO_MUX_10
Definition: at32f435_437_gpio.h:166
GPIO_MUX_14
@ GPIO_MUX_14
Definition: at32f435_437_gpio.h:170
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f435_437_gpio.h:64
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
xmc_nor_sram_init
void xmc_nor_sram_init(xmc_norsram_init_type *xmc_norsram_init_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_norsraminitstruct.
Definition: at32f435_437_xmc.c:78
xmc_norsram_timing_default_para_init
void xmc_norsram_timing_default_para_init(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
fill each xmc_rw_timing_struct and xmc_w_timing_struct member with its default value.
Definition: at32f435_437_xmc.c:176
xmc_nor_sram_timing_config
void xmc_nor_sram_timing_config(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_rw_timing_struct a...
Definition: at32f435_437_xmc.c:113
xmc_ext_timing_config
void xmc_ext_timing_config(xmc_nor_sram_subbank_type xmc_sub_bank, uint16_t w2w_timing, uint16_t r2r_timing)
config the bus turnaround phase.
Definition: at32f435_437_xmc.c:227
xmc_norsram_default_para_init
void xmc_norsram_default_para_init(xmc_norsram_init_type *xmc_nor_sram_init_struct)
fill each xmc_nor_sram_init_struct member with its default value.
Definition: at32f435_437_xmc.c:150
xmc_nor_sram_enable
void xmc_nor_sram_enable(xmc_nor_sram_subbank_type xmc_subbank, confirm_state new_state)
enable or disable the specified nor/sram memory bank.
Definition: at32f435_437_xmc.c:210
XMC_WAIT_SIGNAL_DISABLE
@ XMC_WAIT_SIGNAL_DISABLE
Definition: at32f435_437_xmc.h:101
XMC_WAIT_SIGNAL_SYN_BEFORE
@ XMC_WAIT_SIGNAL_SYN_BEFORE
Definition: at32f435_437_xmc.h:196
XMC_WRITE_OPERATION_ENABLE
@ XMC_WRITE_OPERATION_ENABLE
Definition: at32f435_437_xmc.h:93
XMC_WRITE_BURST_SYN_DISABLE
@ XMC_WRITE_BURST_SYN_DISABLE
Definition: at32f435_437_xmc.h:110
XMC_BURST_MODE_DISABLE
@ XMC_BURST_MODE_DISABLE
Definition: at32f435_437_xmc.h:65
XMC_DATA_ADDR_MUX_DISABLE
@ XMC_DATA_ADDR_MUX_DISABLE
Definition: at32f435_437_xmc.h:56
XMC_BUSTYPE_16_BITS
@ XMC_BUSTYPE_16_BITS
Definition: at32f435_437_xmc.h:179
XMC_WRITE_TIMING_ENABLE
@ XMC_WRITE_TIMING_ENABLE
Definition: at32f435_437_xmc.h:120
XMC_BANK1_NOR_SRAM4
@ XMC_BANK1_NOR_SRAM4
Definition: at32f435_437_xmc.h:149
XMC_ASYN_WAIT_DISABLE
@ XMC_ASYN_WAIT_DISABLE
Definition: at32f435_437_xmc.h:74
XMC_WRAPPED_MODE_DISABLE
@ XMC_WRAPPED_MODE_DISABLE
Definition: at32f435_437_xmc.h:83
XMC_ACCESS_MODE_A
@ XMC_ACCESS_MODE_A
Definition: at32f435_437_xmc.h:205
XMC_WAIT_SIGNAL_LEVEL_LOW
@ XMC_WAIT_SIGNAL_LEVEL_LOW
Definition: at32f435_437_xmc.h:187
XMC_DEVICE_SRAM
@ XMC_DEVICE_SRAM
Definition: at32f435_437_xmc.h:168
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
lcd_dev_type
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:44
lcd_dev_type::lcd_setblock
void(* lcd_setblock)(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:48
lcd_dev_type::lcd_id
uint16_t lcd_id
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:45
lcd_dev_type::xmc_init
void(* xmc_init)(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:46
xmc_norsram_init_type
xmc nor/sram init structure definition
Definition: at32f435_437_xmc.h:409
xmc_norsram_init_type::wait_signal_enable
xmc_wait_signal_type wait_signal_enable
Definition: at32f435_437_xmc.h:420
xmc_norsram_init_type::data_addr_multiplex
xmc_data_addr_mux_type data_addr_multiplex
Definition: at32f435_437_xmc.h:411
xmc_norsram_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:421
xmc_norsram_init_type::burst_mode_enable
xmc_burst_access_mode_type burst_mode_enable
Definition: at32f435_437_xmc.h:414
xmc_norsram_init_type::bus_type
xmc_data_width_type bus_type
Definition: at32f435_437_xmc.h:413
xmc_norsram_init_type::device
xmc_memory_type device
Definition: at32f435_437_xmc.h:412
xmc_norsram_init_type::wait_signal_lv
xmc_wait_signal_polarity_type wait_signal_lv
Definition: at32f435_437_xmc.h:416
xmc_norsram_init_type::wrapped_mode_enable
xmc_wrap_mode_type wrapped_mode_enable
Definition: at32f435_437_xmc.h:417
xmc_norsram_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:410
xmc_norsram_init_type::write_burst_syn
xmc_write_burst_type write_burst_syn
Definition: at32f435_437_xmc.h:422
xmc_norsram_init_type::asynwait_enable
xmc_asyn_wait_type asynwait_enable
Definition: at32f435_437_xmc.h:415
xmc_norsram_init_type::wait_signal_config
xmc_wait_timing_type wait_signal_config
Definition: at32f435_437_xmc.h:418
xmc_norsram_init_type::write_enable
xmc_write_operation_type write_enable
Definition: at32f435_437_xmc.h:419
xmc_norsram_timing_init_type
nor/sram banks timing parameters
Definition: at32f435_437_xmc.h:393
xmc_norsram_timing_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:395
xmc_norsram_timing_init_type::data_latency_time
uint32_t data_latency_time
Definition: at32f435_437_xmc.h:401
xmc_norsram_timing_init_type::addr_hold_time
uint32_t addr_hold_time
Definition: at32f435_437_xmc.h:397
xmc_norsram_timing_init_type::bus_latency_time
uint32_t bus_latency_time
Definition: at32f435_437_xmc.h:399
xmc_norsram_timing_init_type::addr_setup_time
uint32_t addr_setup_time
Definition: at32f435_437_xmc.h:396
xmc_norsram_timing_init_type::mode
xmc_access_mode_type mode
Definition: at32f435_437_xmc.h:402
xmc_norsram_timing_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:394
xmc_norsram_timing_init_type::clk_psc
uint32_t clk_psc
Definition: at32f435_437_xmc.h:400
xmc_norsram_timing_init_type::data_setup_time
uint32_t data_setup_time
Definition: at32f435_437_xmc.h:398


AT32F435/437 Firmwary Library: xmc_ecc.h File Reference

  • at_start_f435
  • examples
  • xmc
  • nand_flash
  • ecc
  • inc
Data Structures | Macros | Functions | Variables
at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h File Reference

header file for the nand ecc configuration. More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Data Structures

struct | nand_id_type
struct | nand_address_type

Macros

#define | ROW_ADDRESS (address_struct.page + (address_struct.block + (address_struct.zone * NAND_ZONE_SIZE)) * NAND_BLOCK_SIZE)
#define | COL_ADDRESS address_struct.byte
#define | BUFFER_SIZE NAND_PAGE_SIZE
#define | XMC_Bank_NAND XMC_Bank2_NAND
#define | Bank_NAND_ADDR Bank2_NAND_ADDR
#define | Bank2_NAND_ADDR ((uint32_t)0x70000000)
#define | CMD_AREA (uint32_t)(1<<16)
#define | ADDR_AREA (uint32_t)(1<<17)
#define | DATA_AREA ((uint32_t)0x00000000)
#define | NAND_CMD_AREA_A ((uint8_t)0x00)
#define | NAND_CMD_AREA_B ((uint8_t)0x01)
#define | NAND_CMD_AREA_C ((uint8_t)0x50)
#define | NAND_CMD_AREA_TRUE1 ((uint8_t)0x30)
#define | NAND_CMD_WRITE0 ((uint8_t)0x80)
#define | NAND_CMD_WRITE_TRUE1 ((uint8_t)0x10)
#define | NAND_CMD_ERASE0 ((uint8_t)0x60)
#define | NAND_CMD_ERASE1 ((uint8_t)0xD0)
#define | NAND_CMD_READID ((uint8_t)0x90)
#define | NAND_CMD_STATUS ((uint8_t)0x70)
#define | NAND_CMD_LOCK_STATUS ((uint8_t)0x7A)
#define | NAND_CMD_RESET ((uint8_t)0xFF)
#define | NAND_VALID_ADDRESS ((uint32_t)0x00000100)
#define | NAND_INVALID_ADDRESS ((uint32_t)0x00000200)
#define | NAND_TIMEOUT_ERROR ((uint32_t)0x00000400)
#define | NAND_BUSY ((uint32_t)0x00000000)
#define | NAND_ERROR ((uint32_t)0x00000001)
#define | NAND_READY ((uint32_t)0x00000040)
#define | addr_1st_cycle(addr) (uint8_t)((addr) & 0xFF)
#define | addr_2nd_cycle(addr) (uint8_t)(((addr) & 0xFF00) >> 8)
#define | addr_3rd_cycle(addr) (uint8_t)(((addr) & 0xFF0000) >> 16)
#define | addr_4th_cycle(addr) (uint8_t)(((addr) & 0xFF000000) >> 24)

Functions

void | nand_init (void)
configures the xmc and gpios to interface with the nand memory. this function must be called before any write/read operation on the nand. More...
void | nand_read_id (nand_id_type *nand_id_struct)
reads nand memory's id. More...
uint32_t | nand_write_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write)
this routine is for writing one or several 512 bytes page size. More...
uint32_t | nand_read_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read)
this routine is for sequential read from one or several 512 bytes page size. More...
uint32_t | nand_write_spare_area (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write)
this routine write the spare area information for the specified pages addresses. More...
uint32_t | nand_read_spare_area (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read)
this routine read the spare area information from the specified pages addresses. More...
uint32_t | nand_erase_block (nand_address_type address_struct)
this routine erase complete block from nand flash More...
uint32_t | nand_reset (void)
this routine reset the nand flash. More...
uint32_t | nand_get_status (void)
get the nand operation status. More...
uint32_t | nand_read_status (void)
reads the nand memory status using the read status command. More...
uint32_t | nand_address_increment (nand_address_type *address_struct)
increment the nand memory address. More...

Variables

uint32_t | ecc_value_write
uint32_t | ecc_value_read

Detailed Description

header file for the nand ecc configuration.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.


AT32F435/437 Firmwary Library: xmc_ecc.h Source File

  • at_start_f435
  • examples
  • xmc
  • nand_flash
  • ecc
  • inc
at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h
Go to the documentation of this file.
1
27#ifndef __XMC_ECC_H
28#define __XMC_ECC_H
29
30#include "at32f435_437_board.h"
31
44typedef struct
45{
46 uint8_t maker_id;
47 uint8_t device_id;
48 uint8_t third_id;
49 uint8_t fourth_id;
50 uint8_t fifth_id;
51 uint8_t sixth_id;
52} nand_id_type;
53
62typedef struct
63{
64 uint16_t zone;
65 uint16_t block;
66 uint16_t page;
67 uint16_t byte;
68} nand_address_type;
69
74#define ROW_ADDRESS (address_struct.page + (address_struct.block + (address_struct.zone * NAND_ZONE_SIZE)) * NAND_BLOCK_SIZE)
75#define COL_ADDRESS address_struct.byte
76
77#define BUFFER_SIZE NAND_PAGE_SIZE
78
79#define XMC_Bank_NAND XMC_Bank2_NAND
80#define Bank_NAND_ADDR Bank2_NAND_ADDR
81#define Bank2_NAND_ADDR ((uint32_t)0x70000000)
82
83#ifdef H27U1G8F2CTR
84#define NAND_AT_MakerID 0xAD
85#define NAND_AT_DeviceID 0xF1
86#elif defined K9GAG08U0E
87#define NAND_AT_MakerID 0xEC
88#define NAND_AT_DeviceID 0xD5
89#endif
90
95/* a16 = cle high */
96#define CMD_AREA (uint32_t)(1<<16)
97/* a17 = ale high */
98#define ADDR_AREA (uint32_t)(1<<17)
99
100#define DATA_AREA ((uint32_t)0x00000000)
101
110/*-- XMC NAND memory command -------------------------------------*/
111#define NAND_CMD_AREA_A ((uint8_t)0x00)
112#define NAND_CMD_AREA_B ((uint8_t)0x01)
113#define NAND_CMD_AREA_C ((uint8_t)0x50)
114#define NAND_CMD_AREA_TRUE1 ((uint8_t)0x30)
115
116#define NAND_CMD_WRITE0 ((uint8_t)0x80)
117#define NAND_CMD_WRITE_TRUE1 ((uint8_t)0x10)
118
119#define NAND_CMD_ERASE0 ((uint8_t)0x60)
120#define NAND_CMD_ERASE1 ((uint8_t)0xD0)
121
122#define NAND_CMD_READID ((uint8_t)0x90)
123#define NAND_CMD_STATUS ((uint8_t)0x70)
124#define NAND_CMD_LOCK_STATUS ((uint8_t)0x7A)
125#define NAND_CMD_RESET ((uint8_t)0xFF)
126
135/*-- nand memory status -------------------------------------*/
136#define NAND_VALID_ADDRESS ((uint32_t)0x00000100)
137#define NAND_INVALID_ADDRESS ((uint32_t)0x00000200)
138#define NAND_TIMEOUT_ERROR ((uint32_t)0x00000400)
139#define NAND_BUSY ((uint32_t)0x00000000)
140#define NAND_ERROR ((uint32_t)0x00000001)
141#define NAND_READY ((uint32_t)0x00000040)
142
151/*-- xmc nand memory parameters -------------------------------------*/
152#ifdef H27U1G8F2CTR
153 /* 2k bytes per page w/o Spare Area */
154 #define NAND_PAGE_SIZE ((uint16_t)0x0800)
155 /* 64x2k bytes pages per block */
156 #define NAND_BLOCK_SIZE ((uint16_t)0x0040)
157 /* 1024 block per zone */
158 #define NAND_ZONE_SIZE ((uint16_t)0x0400)
159 /* last 64 bytes as spare area */
160 #define NAND_SPARE_AREA_SIZE ((uint16_t)0x0040)
161 /* 1 zones of 1024 block */
162 #define NAND_MAX_ZONE ((uint16_t)0x0001)
163#elif defined K9GAG08U0E
164 /* 8k bytes per page w/o spare area */
165 #define NAND_PAGE_SIZE ((uint16_t)0x2000)
166 /* 128x8k bytes pages per block */
167 #define NAND_BLOCK_SIZE ((uint16_t)0x0080)
168 /* 2048 block per zone */
169 #define NAND_ZONE_SIZE ((uint16_t)0x0800)
170 /* last 436 bytes as spare area */
171 #define NAND_SPARE_AREA_SIZE ((uint16_t)0x01B4)
172 /* 1 zones of 1024 block */
173 #define NAND_MAX_ZONE ((uint16_t)0x0001)
174#endif
175
184/*-- xmc nand memory address computation -------------------------------------*/
185/* 1st addressing cycle */
186#define addr_1st_cycle(addr) (uint8_t)((addr) & 0xFF)
187/* 2nd addressing cycle */
188#define addr_2nd_cycle(addr) (uint8_t)(((addr) & 0xFF00) >> 8)
189/* 3rd addressing cycle */
190#define addr_3rd_cycle(addr) (uint8_t)(((addr) & 0xFF0000) >> 16)
191/* 4th addressing cycle */
192#define addr_4th_cycle(addr) (uint8_t)(((addr) & 0xFF000000) >> 24)
193
198extern uint32_t ecc_value_write;
199extern uint32_t ecc_value_read;
200
205void nand_init(void);
206void nand_read_id(nand_id_type* nand_id_struct);
207uint32_t nand_write_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write);
208uint32_t nand_read_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read);
209uint32_t nand_write_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write);
210uint32_t nand_read_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read);
211uint32_t nand_erase_block(nand_address_type address_struct);
212uint32_t nand_reset(void);
213uint32_t nand_get_status(void);
214uint32_t nand_read_status(void);
215uint32_t nand_address_increment(nand_address_type* address_struct);
216
229#endif
at32f435_437_board.h
ecc_value_read
uint32_t ecc_value_read
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:44
nand_id_struct
nand_id_type nand_id_struct
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:40
ecc_value_write
uint32_t ecc_value_write
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:44
nand_read_small_page
uint32_t nand_read_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read)
this routine is for sequential read from one or several 512 bytes page size.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:228
nand_read_id
void nand_read_id(nand_id_type *nand_id_struct)
reads nand memory's id.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:120
nand_init
void nand_init(void)
configures the xmc and gpios to interface with the nand memory. this function must be called before a...
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:44
nand_read_status
uint32_t nand_read_status(void)
reads the nand memory status using the read status command.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:471
nand_address_increment
uint32_t nand_address_increment(nand_address_type *address_struct)
increment the nand memory address.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:502
nand_reset
uint32_t nand_reset(void)
this routine reset the nand flash.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:426
nand_erase_block
uint32_t nand_erase_block(nand_address_type address_struct)
this routine erase complete block from nand flash
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:403
nand_read_spare_area
uint32_t nand_read_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read)
this routine read the spare area information from the specified pages addresses.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:353
nand_write_small_page
uint32_t nand_write_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write)
this routine is for writing one or several 512 bytes page size.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:161
nand_get_status
uint32_t nand_get_status(void)
get the nand operation status.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:441
nand_write_spare_area
uint32_t nand_write_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write)
this routine write the spare area information for the specified pages addresses.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:294
nand_address_type
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:63
nand_address_type::byte
uint16_t byte
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:67
nand_address_type::page
uint16_t page
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:66
nand_address_type::block
uint16_t block
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:65
nand_address_type::zone
uint16_t zone
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:64
nand_id_type
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:45
nand_id_type::sixth_id
uint8_t sixth_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:51
nand_id_type::device_id
uint8_t device_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:47
nand_id_type::fourth_id
uint8_t fourth_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:49
nand_id_type::fifth_id
uint8_t fifth_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:50
nand_id_type::third_id
uint8_t third_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:48
nand_id_type::maker_id
uint8_t maker_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:46


AT32F435/437 Firmwary Library: xmc_ecc.c File Reference

  • at_start_f435
  • examples
  • xmc
  • nand_flash
  • ecc
  • src
Functions
at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c File Reference

nand ecc configuration More...

#include "xmc_ecc.h"

Go to the source code of this file.

Functions

void | nand_init (void)
configures the xmc and gpios to interface with the nand memory. this function must be called before any write/read operation on the nand. More...
void | nand_read_id (nand_id_type *nand_id_struct)
reads nand memory's id. More...
uint32_t | nand_write_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write)
this routine is for writing one or several 512 bytes page size. More...
uint32_t | nand_read_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read)
this routine is for sequential read from one or several 512 bytes page size. More...
uint32_t | nand_write_spare_area (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write)
this routine write the spare area information for the specified pages addresses. More...
uint32_t | nand_read_spare_area (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read)
this routine read the spare area information from the specified pages addresses. More...
uint32_t | nand_erase_block (nand_address_type address_struct)
this routine erase complete block from nand flash More...
uint32_t | nand_reset (void)
this routine reset the nand flash. More...
uint32_t | nand_get_status (void)
get the nand operation status. More...
uint32_t | nand_read_status (void)
reads the nand memory status using the read status command. More...
uint32_t | nand_address_increment (nand_address_type *address_struct)
increment the nand memory address. More...

Detailed Description

nand ecc configuration

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.


AT32F435/437 Firmwary Library: xmc_ecc.c Source File

  • at_start_f435
  • examples
  • xmc
  • nand_flash
  • ecc
  • src
at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c
Go to the documentation of this file.
1
27#include "xmc_ecc.h"
28
44void nand_init(void)
45{
46 gpio_init_type gpio_init_struct;
47 xmc_nand_init_type nand_init_struct;
48 xmc_nand_pccard_timinginit_type xmc_regular_spacetimingstruct;
49
50 /* enable the xmc clock */
51 crm_periph_clock_enable(CRM_XMC_PERIPH_CLOCK, TRUE);
52 /* enable gpiod/gpiob/gpioe clock */
53 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
54 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
55
56 /*-- gpio configuration ------------------------------------------------------*/
57 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE0, GPIO_MUX_12);
58 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_12);
59 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE11, GPIO_MUX_12);
60 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE12, GPIO_MUX_12);
61 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE14, GPIO_MUX_12);
62 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE15, GPIO_MUX_12);
63 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_12);
64 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE5, GPIO_MUX_12);
65 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE6, GPIO_MUX_12);
66 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE7, GPIO_MUX_12);
67 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE7, GPIO_MUX_12);
68 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE8, GPIO_MUX_12);
69 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE9, GPIO_MUX_12);
70 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE10, GPIO_MUX_12);
71
72 /* cle, ale, d0->d3, noe, nwe , nce2 and nwait nand pin configuration */
73 gpio_default_para_init(&gpio_init_struct);
74 gpio_init_struct.gpio_pins = GPIO_PINS_11 | GPIO_PINS_12 | GPIO_PINS_14 | GPIO_PINS_15 |
75 GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_4 | GPIO_PINS_5 |
76 GPIO_PINS_6 | GPIO_PINS_7;
77 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
78 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
79 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
80 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
81 gpio_init(GPIOD, &gpio_init_struct);
82
83 /* d4->d7 nand pin configuration */
84 gpio_init_struct.gpio_pins = GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10;
85 gpio_init(GPIOE, &gpio_init_struct);
86
87 /*-- xmc configuration ------------------------------------------------------*/
88 xmc_nand_default_para_init(&nand_init_struct);
89 nand_init_struct.nand_bank = XMC_BANK2_NAND;
90 nand_init_struct.wait_enable = XMC_WAIT_OPERATION_DISABLE;
91 nand_init_struct.bus_type = XMC_BUSTYPE_8_BITS;
92 nand_init_struct.ecc_enable = XMC_ECC_OPERATION_DISABLE;
93#ifdef H27U1G8F2CTR
94 nand_init_struct.ecc_pagesize = XMC_ECC_PAGESIZE_2048_BYTES;
95#elif defined K9GAG08U0E
96 nand_init_struct.ecc_pagesize = XMC_ECC_PAGESIZE_8192_BYTES;
97#endif
98 nand_init_struct.delay_time_cycle = 0x10;
99 nand_init_struct.delay_time_ar = 0x10;
100 xmc_nand_init(&nand_init_struct);
101
102 xmc_nand_timing_default_para_init(&xmc_regular_spacetimingstruct, &xmc_regular_spacetimingstruct);
103 xmc_regular_spacetimingstruct.class_bank = XMC_BANK2_NAND;
104 xmc_regular_spacetimingstruct.mem_setup_time = 254;
105 xmc_regular_spacetimingstruct.mem_hiz_time = 254;
106 xmc_regular_spacetimingstruct.mem_hold_time = 254;
107 xmc_regular_spacetimingstruct.mem_waite_time = 254;
108 xmc_nand_timing_config(&xmc_regular_spacetimingstruct, &xmc_regular_spacetimingstruct);
109
110 /* xmc nand bank cmd test */
111 xmc_nand_enable(XMC_BANK2_NAND, TRUE);
112}
113
120void nand_read_id(nand_id_type* nand_id_struct)
121{
122 uint32_t data = 0;
123
124 /* send command to the command area */
125 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = 0x90;
126 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = 0x00;
127
128#ifdef H27U1G8F2CTR
129 /* sequence to read id from nand flash */
130 data = *(__IO uint32_t *)(Bank_NAND_ADDR | DATA_AREA);
131 nand_id_struct->maker_id = addr_1st_cycle (data);
132 nand_id_struct->device_id = addr_2nd_cycle (data);
133 nand_id_struct->third_id = addr_3rd_cycle (data);
134 nand_id_struct->fourth_id = addr_4th_cycle (data);
135#elif defined K9GAG08U0E
136 /* sequence to read id from nand flash */
137 data = *(__IO uint32_t *)(Bank_NAND_ADDR | DATA_AREA);
138 nand_id_struct->maker_id = addr_1st_cycle (data);
139 nand_id_struct->device_id = addr_2nd_cycle (data);
140 nand_id_struct->third_id = addr_3rd_cycle (data);
141 nand_id_struct->fourth_id = addr_4th_cycle (data);
142 data = *(__IO uint16_t *)(Bank_NAND_ADDR | DATA_AREA);
143 nand_id_struct->fifth_id = addr_1st_cycle (data);
144 nand_id_struct->sixth_id = addr_2nd_cycle (data);
145#endif
146}
147
161uint32_t nand_write_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write)
162{
163 uint32_t index = 0x00, num_page_written = 0x00, address_status = NAND_VALID_ADDRESS;
164 uint32_t status = NAND_READY, size = 0x00;
165
166 while((num_page_to_write != 0x00) && (address_status == NAND_VALID_ADDRESS) && (status == NAND_READY))
167 {
168 /* page write command and address */
169 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_WRITE0;
170
171#ifdef H27U1G8F2CTR
172 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(COL_ADDRESS);
173 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(COL_ADDRESS);
174 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
175 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
176#elif defined K9GAG08U0E
177 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(COL_ADDRESS);
178 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(COL_ADDRESS);
179 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
180 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
181 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_3rd_cycle(ROW_ADDRESS);
182#endif
183
184 /* calculate the size */
185 size = NAND_PAGE_SIZE + (NAND_PAGE_SIZE * num_page_written);
186
187 /* write data */
188 for(index = 0x00; index < size; index++)
189 {
190 *(__IO uint8_t *)(Bank_NAND_ADDR | DATA_AREA) = pbuffer[index];
191 }
192 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_WRITE_TRUE1;
193
194 while(xmc_flag_status_get(XMC_BANK2_NAND,XMC_FEMPT_FLAG) == RESET);
195 ecc_value_write = xmc_ecc_get(XMC_BANK2_NAND);
196 xmc_nand_ecc_enable(XMC_BANK2_NAND, FALSE);
197
198 /* check status for successful operation */
199 status = nand_get_status();
200
201 if(status == NAND_READY)
202 {
203 num_page_written++;
204
205 num_page_to_write--;
206
207 /* calculate next small page address */
208 address_status = nand_address_increment(&address_struct);
209 }
210 }
211
212 return (status | address_status);
213}
214
228uint32_t nand_read_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read)
229{
230 uint32_t index = 0x00, num_page_read = 0x00, address_status = NAND_VALID_ADDRESS;
231 uint32_t status = NAND_READY, size = 0x00;
232
233 while((num_page_to_read != 0x0) && (address_status == NAND_VALID_ADDRESS))
234 {
235 /* page read command and page address */
236 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_AREA_A;
237
238#ifdef H27U1G8F2CTR
239 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(COL_ADDRESS);
240 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(COL_ADDRESS);
241 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
242 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
243#elif defined K9GAG08U0E
244 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(COL_ADDRESS);
245 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(COL_ADDRESS);
246 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
247 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
248 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_3rd_cycle(ROW_ADDRESS);
249#endif
250
251 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_AREA_TRUE1;
252
253 delay_ms(1);
254
255 /* calculate the size */
256 size = NAND_PAGE_SIZE + (NAND_PAGE_SIZE * num_page_read);
257
258 /* get data into buffer */
259 for(index = 0x00; index < size; index++)
260 {
261 pbuffer[index]= *(__IO uint8_t *)(Bank_NAND_ADDR | DATA_AREA);
262 }
263
264 ecc_value_read = xmc_ecc_get(XMC_BANK2_NAND);
265 xmc_nand_ecc_enable(XMC_BANK2_NAND, FALSE);
266
267 num_page_read++;
268
269 num_page_to_read--;
270
271 /* calculate page address */
272 address_status = nand_address_increment(&address_struct);
273 }
274
275 status = nand_get_status();
276
277 return (status | address_status);
278}
279
294uint32_t nand_write_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write)
295{
296 uint32_t index = 0x00, num_spare_area_written = 0x00, address_status = NAND_VALID_ADDRESS;
297 uint32_t status = NAND_READY, size = 0x00;
298
299 while((num_spare_area_to_write != 0x00) && (address_status == NAND_VALID_ADDRESS) && (status == NAND_READY))
300 {
301 /* page write spare area command and address */
302 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_AREA_C;
303 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_WRITE0;
304
305 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = 0x00;
306 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
307 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
308 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_3rd_cycle(ROW_ADDRESS);
309 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_4th_cycle(ROW_ADDRESS);
310
311 /* calculate the size */
312 size = NAND_SPARE_AREA_SIZE + (NAND_SPARE_AREA_SIZE * num_spare_area_written);
313
314 /* write the data */
315 for(index = 0x00; index < size; index++)
316 {
317 *(__IO uint8_t *)(Bank_NAND_ADDR | DATA_AREA) = pbuffer[index];
318 }
319
320 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_WRITE_TRUE1;
321
322 /* check status for successful operation */
323 status = nand_get_status();
324
325 if(status == NAND_READY)
326 {
327 num_spare_area_written++;
328
329 num_spare_area_to_write--;
330
331 /* calculate next page address */
332 address_status = nand_address_increment(&address_struct);
333 }
334 }
335
336 return (status | address_status);
337}
338
353uint32_t nand_read_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read)
354{
355 uint32_t num_spare_area_read = 0x00, index = 0x00, address_status = NAND_VALID_ADDRESS;
356 uint32_t status = NAND_READY, size = 0x00;
357
358 while((num_spare_area_to_read != 0x0) && (address_status == NAND_VALID_ADDRESS))
359 {
360 /* page read command and page address */
361 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_AREA_C;
362
363 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = 0x00;
364 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
365 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
366 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_3rd_cycle(ROW_ADDRESS);
367 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_4th_cycle(ROW_ADDRESS);
368
369 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_AREA_TRUE1;
370
371 delay_ms(1);
372
373 /* data read */
374 size = NAND_SPARE_AREA_SIZE + (NAND_SPARE_AREA_SIZE * num_spare_area_read);
375
376 /* get data into buffer */
377 for(index = 0x00 ;index < size; index++)
378 {
379 pbuffer[index] = *(__IO uint8_t *)(Bank_NAND_ADDR | DATA_AREA);
380 }
381
382 num_spare_area_read++;
383
384 num_spare_area_to_read--;
385
386 /* calculate page address */
387 address_status = nand_address_increment(&address_struct);
388 }
389
390 status = nand_get_status();
391
392 return (status | address_status);
393}
394
403uint32_t nand_erase_block(nand_address_type address_struct)
404{
405 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_ERASE0;
406
407#ifdef H27U1G8F2CTR
408 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
409 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
410#elif defined K9GAG08U0E
411 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
412 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
413 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_3rd_cycle(ROW_ADDRESS);
414#endif
415
416 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_ERASE1;
417
418 return (nand_get_status());
419}
420
426uint32_t nand_reset(void)
427{
428 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_RESET;
429
430 return (NAND_READY);
431}
432
441uint32_t nand_get_status(void)
442{
443 uint32_t timeout = 0x1000000, status = NAND_READY;
444
445 status = nand_read_status();
446
447 /* wait for a nand operation to complete or a timeout to occur */
448 while((status != NAND_READY) && ( timeout != 0x00))
449 {
450 status = nand_read_status();
451 timeout --;
452 }
453
454 if(timeout == 0x00)
455 {
456 status = NAND_TIMEOUT_ERROR;
457 }
458
459 /* return the operation status */
460 return (status);
461}
462
471uint32_t nand_read_status(void)
472{
473 uint32_t data = 0x00, status = NAND_BUSY;
474
475 /* read status operation */
476 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_STATUS;
477 data = *(__IO uint8_t *)(Bank_NAND_ADDR);
478
479 if((data & NAND_ERROR) == NAND_ERROR)
480 {
481 status = NAND_ERROR;
482 }
483 else if((data & NAND_READY) == NAND_READY)
484 {
485 status = NAND_READY;
486 }
487 else
488 {
489 status = NAND_BUSY;
490 }
491
492 return (status);
493}
494
502uint32_t nand_address_increment(nand_address_type* address_struct)
503{
504 uint32_t status = NAND_VALID_ADDRESS;
505
506 address_struct->page++;
507
508 if(address_struct->page == NAND_BLOCK_SIZE)
509 {
510 address_struct->page = 0;
511 address_struct->block++;
512
513 if(address_struct->block == NAND_ZONE_SIZE)
514 {
515 address_struct->block = 0;
516 address_struct->zone++;
517
518 if(address_struct->zone == NAND_MAX_ZONE)
519 {
520 status = NAND_INVALID_ADDRESS;
521 }
522 }
523 }
524
525 return (status);
526}
527
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
nand_read_small_page
uint32_t nand_read_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read)
this routine is for sequential read from one or several 512 bytes page size.
Definition: at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:228
nand_read_id
void nand_read_id(nand_id_type *nand_id_struct)
reads nand memory's id.
Definition: at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:120
COL_ADDRESS
#define COL_ADDRESS
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:75
nand_init
void nand_init(void)
configures the xmc and gpios to interface with the nand memory. this function must be called before a...
Definition: at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:44
nand_read_status
uint32_t nand_read_status(void)
reads the nand memory status using the read status command.
Definition: at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:471
ecc_value_read
uint32_t ecc_value_read
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:44
Bank_NAND_ADDR
#define Bank_NAND_ADDR
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:80
nand_address_increment
uint32_t nand_address_increment(nand_address_type *address_struct)
increment the nand memory address.
Definition: at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:502
nand_reset
uint32_t nand_reset(void)
this routine reset the nand flash.
Definition: at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:426
nand_id_struct
nand_id_type nand_id_struct
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:40
nand_erase_block
uint32_t nand_erase_block(nand_address_type address_struct)
this routine erase complete block from nand flash
Definition: at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:403
nand_read_spare_area
uint32_t nand_read_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read)
this routine read the spare area information from the specified pages addresses.
Definition: at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:353
nand_write_small_page
uint32_t nand_write_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write)
this routine is for writing one or several 512 bytes page size.
Definition: at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:161
ecc_value_write
uint32_t ecc_value_write
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:44
ROW_ADDRESS
#define ROW_ADDRESS
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:74
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
nand_get_status
uint32_t nand_get_status(void)
get the nand operation status.
Definition: at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:441
nand_write_spare_area
uint32_t nand_write_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write)
this routine write the spare area information for the specified pages addresses.
Definition: at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:294
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_XMC_PERIPH_CLOCK
@ CRM_XMC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:123
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_MODERATE
@ GPIO_DRIVE_STRENGTH_MODERATE
Definition: at32f435_437_gpio.h:94
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
ADDR_AREA
#define ADDR_AREA
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:98
CMD_AREA
#define CMD_AREA
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:96
DATA_AREA
#define DATA_AREA
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:100
xmc_ecc_get
uint32_t xmc_ecc_get(xmc_class_bank_type xmc_bank)
return the error correction code register value.
Definition: at32f435_437_xmc.c:429
xmc_nand_init
void xmc_nand_init(xmc_nand_init_type *xmc_nand_init_struct)
initialize the xmc nand banks according to the specified parameters in the xmc_nandinitstruct.
Definition: at32f435_437_xmc.c:269
xmc_nand_timing_default_para_init
void xmc_nand_timing_default_para_init(xmc_nand_pccard_timinginit_type *xmc_common_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_attribute_spacetiming_struct)
fill each xmc_common_spacetiming_struct and xmc_attribute_spacetiming_struct member with its default ...
Definition: at32f435_437_xmc.c:360
xmc_nand_ecc_enable
void xmc_nand_ecc_enable(xmc_class_bank_type xmc_bank, confirm_state new_state)
enable or disable the xmc nand ecc feature.
Definition: at32f435_437_xmc.c:407
xmc_nand_default_para_init
void xmc_nand_default_para_init(xmc_nand_init_type *xmc_nand_init_struct)
fill each xmc_nand_init_struct member with its default value.
Definition: at32f435_437_xmc.c:340
xmc_nand_timing_config
void xmc_nand_timing_config(xmc_nand_pccard_timinginit_type *xmc_common_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_attribute_spacetiming_struct)
initialize the xmc nand banks according to the specified parameters in the xmc_nandinitstruct.
Definition: at32f435_437_xmc.c:305
xmc_nand_enable
void xmc_nand_enable(xmc_class_bank_type xmc_bank, confirm_state new_state)
enable or disable the specified nand memory bank.
Definition: at32f435_437_xmc.c:384
xmc_flag_status_get
flag_status xmc_flag_status_get(xmc_class_bank_type xmc_bank, xmc_interrupt_flag_type xmc_flag)
check whether the specified xmc flag is set or not.
Definition: at32f435_437_xmc.c:695
XMC_BANK2_NAND
@ XMC_BANK2_NAND
Definition: at32f435_437_xmc.h:157
XMC_BUSTYPE_8_BITS
@ XMC_BUSTYPE_8_BITS
Definition: at32f435_437_xmc.h:178
XMC_FEMPT_FLAG
@ XMC_FEMPT_FLAG
Definition: at32f435_437_xmc.h:243
XMC_WAIT_OPERATION_DISABLE
@ XMC_WAIT_OPERATION_DISABLE
Definition: at32f435_437_xmc.h:128
XMC_ECC_PAGESIZE_8192_BYTES
@ XMC_ECC_PAGESIZE_8192_BYTES
Definition: at32f435_437_xmc.h:221
XMC_ECC_PAGESIZE_2048_BYTES
@ XMC_ECC_PAGESIZE_2048_BYTES
Definition: at32f435_437_xmc.h:219
XMC_ECC_OPERATION_DISABLE
@ XMC_ECC_OPERATION_DISABLE
Definition: at32f435_437_xmc.h:137
addr_2nd_cycle
#define addr_2nd_cycle(addr)
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:188
addr_3rd_cycle
#define addr_3rd_cycle(addr)
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:190
addr_4th_cycle
#define addr_4th_cycle(addr)
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:192
addr_1st_cycle
#define addr_1st_cycle(addr)
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:186
NAND_CMD_WRITE_TRUE1
#define NAND_CMD_WRITE_TRUE1
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:117
NAND_CMD_RESET
#define NAND_CMD_RESET
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:125
NAND_CMD_WRITE0
#define NAND_CMD_WRITE0
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:116
NAND_CMD_STATUS
#define NAND_CMD_STATUS
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:123
NAND_CMD_AREA_A
#define NAND_CMD_AREA_A
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:111
NAND_CMD_ERASE1
#define NAND_CMD_ERASE1
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:120
NAND_CMD_ERASE0
#define NAND_CMD_ERASE0
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:119
NAND_CMD_AREA_TRUE1
#define NAND_CMD_AREA_TRUE1
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:114
NAND_CMD_AREA_C
#define NAND_CMD_AREA_C
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:113
NAND_ERROR
#define NAND_ERROR
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:140
NAND_READY
#define NAND_READY
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:141
NAND_VALID_ADDRESS
#define NAND_VALID_ADDRESS
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:136
NAND_INVALID_ADDRESS
#define NAND_INVALID_ADDRESS
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:137
NAND_TIMEOUT_ERROR
#define NAND_TIMEOUT_ERROR
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:138
NAND_BUSY
#define NAND_BUSY
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:139
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
nand_address_type
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:63
nand_address_type::page
uint16_t page
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:66
nand_address_type::block
uint16_t block
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:65
nand_address_type::zone
uint16_t zone
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:64
nand_id_type
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:45
nand_id_type::sixth_id
uint8_t sixth_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:51
nand_id_type::device_id
uint8_t device_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:47
nand_id_type::fourth_id
uint8_t fourth_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:49
nand_id_type::fifth_id
uint8_t fifth_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:50
nand_id_type::third_id
uint8_t third_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:48
nand_id_type::maker_id
uint8_t maker_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:46
xmc_nand_init_type
xmc nand init structure definition
Definition: at32f435_437_xmc.h:443
xmc_nand_init_type::ecc_enable
xmc_ecc_enable_type ecc_enable
Definition: at32f435_437_xmc.h:447
xmc_nand_init_type::delay_time_cycle
uint32_t delay_time_cycle
Definition: at32f435_437_xmc.h:449
xmc_nand_init_type::nand_bank
xmc_class_bank_type nand_bank
Definition: at32f435_437_xmc.h:444
xmc_nand_init_type::wait_enable
xmc_nand_pccard_wait_type wait_enable
Definition: at32f435_437_xmc.h:445
xmc_nand_init_type::ecc_pagesize
xmc_ecc_pagesize_type ecc_pagesize
Definition: at32f435_437_xmc.h:448
xmc_nand_init_type::delay_time_ar
uint32_t delay_time_ar
Definition: at32f435_437_xmc.h:450
xmc_nand_init_type::bus_type
xmc_data_width_type bus_type
Definition: at32f435_437_xmc.h:446
xmc_nand_pccard_timinginit_type
nand and pccard timing parameters xmc
Definition: at32f435_437_xmc.h:430
xmc_nand_pccard_timinginit_type::class_bank
xmc_class_bank_type class_bank
Definition: at32f435_437_xmc.h:431
xmc_nand_pccard_timinginit_type::mem_waite_time
uint32_t mem_waite_time
Definition: at32f435_437_xmc.h:433
xmc_nand_pccard_timinginit_type::mem_hold_time
uint32_t mem_hold_time
Definition: at32f435_437_xmc.h:434
xmc_nand_pccard_timinginit_type::mem_hiz_time
uint32_t mem_hiz_time
Definition: at32f435_437_xmc.h:435
xmc_nand_pccard_timinginit_type::mem_setup_time
uint32_t mem_setup_time
Definition: at32f435_437_xmc.h:432


AT32F435/437 Firmwary Library: xmc_nand.h File Reference

  • at_start_f435
  • examples
  • xmc
  • nand_flash
  • nand
  • inc
Data Structures | Macros | Functions
at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h File Reference

header file for the nand configuration. More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Data Structures

struct | nand_id_type
struct | nand_address_type

Macros

#define | ROW_ADDRESS (address_struct.page + (address_struct.block + (address_struct.zone * NAND_ZONE_SIZE)) * NAND_BLOCK_SIZE)
#define | COL_ADDRESS address_struct.byte
#define | BUFFER_SIZE NAND_PAGE_SIZE
#define | XMC_Bank_NAND XMC_Bank2_NAND
#define | Bank_NAND_ADDR Bank2_NAND_ADDR
#define | Bank2_NAND_ADDR ((uint32_t)0x70000000)
#define | CMD_AREA (uint32_t)(1<<16)
#define | ADDR_AREA (uint32_t)(1<<17)
#define | DATA_AREA ((uint32_t)0x00000000)
#define | NAND_CMD_AREA_A ((uint8_t)0x00)
#define | NAND_CMD_AREA_B ((uint8_t)0x01)
#define | NAND_CMD_AREA_C ((uint8_t)0x50)
#define | NAND_CMD_AREA_TRUE1 ((uint8_t)0x30)
#define | NAND_CMD_WRITE0 ((uint8_t)0x80)
#define | NAND_CMD_WRITE_TRUE1 ((uint8_t)0x10)
#define | NAND_CMD_ERASE0 ((uint8_t)0x60)
#define | NAND_CMD_ERASE1 ((uint8_t)0xD0)
#define | NAND_CMD_READID ((uint8_t)0x90)
#define | NAND_CMD_STATUS ((uint8_t)0x70)
#define | NAND_CMD_LOCK_STATUS ((uint8_t)0x7A)
#define | NAND_CMD_RESET ((uint8_t)0xFF)
#define | NAND_VALID_ADDRESS ((uint32_t)0x00000100)
#define | NAND_INVALID_ADDRESS ((uint32_t)0x00000200)
#define | NAND_TIMEOUT_ERROR ((uint32_t)0x00000400)
#define | NAND_BUSY ((uint32_t)0x00000000)
#define | NAND_ERROR ((uint32_t)0x00000001)
#define | NAND_READY ((uint32_t)0x00000040)
#define | addr_1st_cycle(addr) (uint8_t)((addr) & (uint32_t)0x000000FF)
#define | addr_2nd_cycle(addr) (uint8_t)(((addr) & (uint32_t)0x0000FF00) >> 8)
#define | addr_3rd_cycle(addr) (uint8_t)(((addr) & (uint32_t)0x00FF0000) >> 16)
#define | addr_4th_cycle(addr) (uint8_t)(((addr) & (uint32_t)0xFF000000) >> 24)

Functions

void | nand_init (void)
configures the xmc and gpios to interface with the nand memory. this function must be called before any write/read operation on the nand. More...
void | nand_read_id (nand_id_type *nand_id_struct)
reads nand memory's id. More...
uint32_t | nand_write_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write)
this routine is for writing one or several 512 bytes page size. More...
uint32_t | nand_read_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read)
this routine is for sequential read from one or several 512 bytes page size. More...
uint32_t | nand_write_spare_area (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write)
this routine write the spare area information for the specified pages addresses. More...
uint32_t | nand_read_spare_area (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read)
this routine read the spare area information from the specified pages addresses. More...
uint32_t | nand_erase_block (nand_address_type address_struct)
this routine erase complete block from nand flash More...
uint32_t | nand_reset (void)
this routine reset the nand flash. More...
uint32_t | nand_get_status (void)
get the nand operation status. More...
uint32_t | nand_read_status (void)
reads the nand memory status using the read status command. More...
uint32_t | nand_address_increment (nand_address_type *address_struct)
increment the nand memory address. More...

Detailed Description

header file for the nand configuration.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h.


AT32F435/437 Firmwary Library: xmc_nand.h Source File

  • at_start_f435
  • examples
  • xmc
  • nand_flash
  • nand
  • inc
at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h
Go to the documentation of this file.
1
27/*-- define to prevent recursive inclusion -------------------------------------*/
28#ifndef __XMC_NAND_H
29#define __XMC_NAND_H
30
31#include "at32f435_437_board.h"
32
45typedef struct
46{
47 uint8_t maker_id;
48 uint8_t device_id;
49 uint8_t third_id;
50 uint8_t fourth_id;
51 uint8_t fifth_id;
52 uint8_t sixth_id;
53} nand_id_type;
54
63typedef struct
64{
65 uint16_t zone;
66 uint16_t block;
67 uint16_t page;
68 uint16_t byte;
69} nand_address_type;
70
76#define ROW_ADDRESS (address_struct.page + (address_struct.block + (address_struct.zone * NAND_ZONE_SIZE)) * NAND_BLOCK_SIZE)
77#define COL_ADDRESS address_struct.byte
78
79#define BUFFER_SIZE NAND_PAGE_SIZE
80
81#define XMC_Bank_NAND XMC_Bank2_NAND
82#define Bank_NAND_ADDR Bank2_NAND_ADDR
83#define Bank2_NAND_ADDR ((uint32_t)0x70000000)
84
85#ifdef H27U1G8F2CTR
86#define NAND_AT_MakerID (uint8_t)0xAD
87#define NAND_AT_DeviceID (uint8_t)0xF1
88#elif defined K9GAG08U0E
89#define NAND_AT_MakerID (uint8_t)0xEC
90#define NAND_AT_DeviceID (uint8_t)0xD5
91#endif
92
96/* a16 = cle high */
97#define CMD_AREA (uint32_t)(1<<16)
98/* a17 = ale high */
99#define ADDR_AREA (uint32_t)(1<<17)
100
101#define DATA_AREA ((uint32_t)0x00000000)
102
111/*-- xmc nand memory command ------------------------------------*/
112#define NAND_CMD_AREA_A ((uint8_t)0x00)
113#define NAND_CMD_AREA_B ((uint8_t)0x01)
114#define NAND_CMD_AREA_C ((uint8_t)0x50)
115#define NAND_CMD_AREA_TRUE1 ((uint8_t)0x30)
116
117#define NAND_CMD_WRITE0 ((uint8_t)0x80)
118#define NAND_CMD_WRITE_TRUE1 ((uint8_t)0x10)
119
120#define NAND_CMD_ERASE0 ((uint8_t)0x60)
121#define NAND_CMD_ERASE1 ((uint8_t)0xD0)
122
123#define NAND_CMD_READID ((uint8_t)0x90)
124#define NAND_CMD_STATUS ((uint8_t)0x70)
125#define NAND_CMD_LOCK_STATUS ((uint8_t)0x7A)
126#define NAND_CMD_RESET ((uint8_t)0xFF)
127
136/*-- nand memory status ----------- -------------------------*/
137#define NAND_VALID_ADDRESS ((uint32_t)0x00000100)
138#define NAND_INVALID_ADDRESS ((uint32_t)0x00000200)
139#define NAND_TIMEOUT_ERROR ((uint32_t)0x00000400)
140#define NAND_BUSY ((uint32_t)0x00000000)
141#define NAND_ERROR ((uint32_t)0x00000001)
142#define NAND_READY ((uint32_t)0x00000040)
143
152/*-- xmc nand memory parameters ------------------------------------*/
153#ifdef H27U1G8F2CTR
154 /* 2k bytes per page w/o Spare Area */
155 #define NAND_PAGE_SIZE ((uint16_t)0x0800)
156 /* 64x2k bytes pages per block */
157 #define NAND_BLOCK_SIZE ((uint16_t)0x0040)
158 /* 1024 Block per zone */
159 #define NAND_ZONE_SIZE ((uint16_t)0x0400)
160 /* last 64 bytes as spare area */
161 #define NAND_SPARE_AREA_SIZE ((uint16_t)0x0040)
162 /* 1 zones of 1024 block */
163 #define NAND_MAX_ZONE ((uint16_t)0x0001)
164#elif defined K9GAG08U0E
165 /* 8k bytes per page w/o Spare Area */
166 #define NAND_PAGE_SIZE ((uint16_t)0x2000)
167 /* 128x8k bytes pages per block */
168 #define NAND_BLOCK_SIZE ((uint16_t)0x0080)
169 /* 2048 Block per zone */
170 #define NAND_ZONE_SIZE ((uint16_t)0x0800)
171 /* last 436 bytes as spare area */
172 #define NAND_SPARE_AREA_SIZE ((uint16_t)0x01B4)
173 /* 1 zones of 1024 block */
174 #define NAND_MAX_ZONE ((uint16_t)0x0001)
175#endif
176
185/*-- xmc nand memory address computation ------------------------------------*/
186/* 1st addressing cycle */
187#define addr_1st_cycle(addr) (uint8_t)((addr) & (uint32_t)0x000000FF)
188/* 2nd addressing cycle */
189#define addr_2nd_cycle(addr) (uint8_t)(((addr) & (uint32_t)0x0000FF00) >> 8)
190/* 3rd addressing cycle */
191#define addr_3rd_cycle(addr) (uint8_t)(((addr) & (uint32_t)0x00FF0000) >> 16)
192/* 4th addressing cycle */
193#define addr_4th_cycle(addr) (uint8_t)(((addr) & (uint32_t)0xFF000000) >> 24)
194
203void nand_init(void);
204void nand_read_id(nand_id_type* nand_id_struct);
205uint32_t nand_write_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write);
206uint32_t nand_read_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read);
207uint32_t nand_write_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write);
208uint32_t nand_read_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read);
209uint32_t nand_erase_block(nand_address_type address_struct);
210uint32_t nand_reset(void);
211uint32_t nand_get_status(void);
212uint32_t nand_read_status(void);
213uint32_t nand_address_increment(nand_address_type* address_struct);
214
227#endif
228
229
at32f435_437_board.h
nand_id_struct
nand_id_type nand_id_struct
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:40
nand_read_small_page
uint32_t nand_read_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read)
this routine is for sequential read from one or several 512 bytes page size.
Definition: at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:228
nand_read_id
void nand_read_id(nand_id_type *nand_id_struct)
reads nand memory's id.
Definition: at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:120
nand_init
void nand_init(void)
configures the xmc and gpios to interface with the nand memory. this function must be called before a...
Definition: at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:44
nand_read_status
uint32_t nand_read_status(void)
reads the nand memory status using the read status command.
Definition: at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:471
nand_address_increment
uint32_t nand_address_increment(nand_address_type *address_struct)
increment the nand memory address.
Definition: at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:502
nand_reset
uint32_t nand_reset(void)
this routine reset the nand flash.
Definition: at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:426
nand_erase_block
uint32_t nand_erase_block(nand_address_type address_struct)
this routine erase complete block from nand flash
Definition: at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:403
nand_read_spare_area
uint32_t nand_read_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read)
this routine read the spare area information from the specified pages addresses.
Definition: at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:353
nand_write_small_page
uint32_t nand_write_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write)
this routine is for writing one or several 512 bytes page size.
Definition: at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:161
nand_get_status
uint32_t nand_get_status(void)
get the nand operation status.
Definition: at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:441
nand_write_spare_area
uint32_t nand_write_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write)
this routine write the spare area information for the specified pages addresses.
Definition: at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:294
nand_address_type
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:63
nand_id_type
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:45


AT32F435/437 Firmwary Library: xmc_nand.c File Reference

  • at_start_f435
  • examples
  • xmc
  • nand_flash
  • nand
  • src
Functions
at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c File Reference

nand configuration More...

#include "xmc_nand.h"

Go to the source code of this file.

Functions

void | nand_init (void)
configures the xmc and gpios to interface with the nand memory. this function must be called before any write/read operation on the nand. More...
void | nand_read_id (nand_id_type *nand_id_struct)
reads nand memory's id. More...
uint32_t | nand_write_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write)
this routine is for writing one or several 512 bytes page size. More...
uint32_t | nand_read_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read)
this routine is for sequential read from one or several 512 bytes page size. More...
uint32_t | nand_write_spare_area (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write)
this routine write the spare area information for the specified pages addresses. More...
uint32_t | nand_read_spare_area (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read)
this routine read the spare area information from the specified pages addresses. More...
uint32_t | nand_erase_block (nand_address_type address_struct)
this routine erase complete block from nand flash More...
uint32_t | nand_reset (void)
this routine reset the nand flash. More...
uint32_t | nand_get_status (void)
get the nand operation status. More...
uint32_t | nand_read_status (void)
reads the nand memory status using the read status command. More...
uint32_t | nand_address_increment (nand_address_type *address_struct)
increment the nand memory address. More...

Detailed Description

nand configuration

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c.


AT32F435/437 Firmwary Library: xmc_nand.c Source File

  • at_start_f435
  • examples
  • xmc
  • nand_flash
  • nand
  • src
at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c
Go to the documentation of this file.
1
26#include "xmc_nand.h"
27
43void nand_init(void)
44{
45 gpio_init_type gpio_init_struct;
46 xmc_nand_init_type nand_init_struct;
47 xmc_nand_pccard_timinginit_type regular_spacetiming_struct, special_spacetiming_struct;
48
49 /* enable the xmc clock */
50 crm_periph_clock_enable(CRM_XMC_PERIPH_CLOCK, TRUE);
51
52 /* enable gpiod/gpiob/gpioe clock */
53 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
54 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
55
56 /*-- gpio configuration ------------------------------------------------------*/
57 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE0, GPIO_MUX_12);
58 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_12);
59 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE11, GPIO_MUX_12);
60 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE12, GPIO_MUX_12);
61 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE14, GPIO_MUX_12);
62 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE15, GPIO_MUX_12);
63 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_12);
64 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE5, GPIO_MUX_12);
65 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE6, GPIO_MUX_12);
66 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE7, GPIO_MUX_12);
67 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE7, GPIO_MUX_12);
68 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE8, GPIO_MUX_12);
69 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE9, GPIO_MUX_12);
70 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE10, GPIO_MUX_12);
71 /* cle, ale, d0->d3, noe, nwe , nce2 and nwait nand pin configuration */
72 gpio_default_para_init(&gpio_init_struct);
73 gpio_init_struct.gpio_pins = GPIO_PINS_11 | GPIO_PINS_12 | GPIO_PINS_14 | GPIO_PINS_15 |
74 GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_4 | GPIO_PINS_5 |
75 GPIO_PINS_6 | GPIO_PINS_7;
76 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
77 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
78 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
79 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
80 gpio_init(GPIOD, &gpio_init_struct);
81
82 /* d4->d7 nand pin configuration */
83 gpio_init_struct.gpio_pins = GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10;
84 gpio_init(GPIOE, &gpio_init_struct);
85
86 /* -- xmc configuration ------------------------------------------------------ */
87 xmc_nand_default_para_init(&nand_init_struct);
88 nand_init_struct.nand_bank = XMC_BANK2_NAND;
89 nand_init_struct.wait_enable = XMC_WAIT_OPERATION_DISABLE;
90 nand_init_struct.bus_type = XMC_BUSTYPE_8_BITS;
91 nand_init_struct.ecc_enable = XMC_ECC_OPERATION_DISABLE;
92#ifdef H27U1G8F2CTR
93 nand_init_struct.ecc_pagesize = XMC_ECC_PAGESIZE_2048_BYTES;
94#elif defined K9GAG08U0E
95 nand_init_struct.ecc_pagesize = XMC_ECC_PAGESIZE_8192_BYTES;
96#endif
97 nand_init_struct.delay_time_cycle = 0x00;
98 nand_init_struct.delay_time_ar = 0x00;
99 xmc_nand_init(&nand_init_struct);
100
101 xmc_nand_timing_default_para_init(&regular_spacetiming_struct, &special_spacetiming_struct);
102 regular_spacetiming_struct.class_bank = XMC_BANK2_NAND;
103 regular_spacetiming_struct.mem_setup_time = 254;
104 regular_spacetiming_struct.mem_hiz_time = 254;
105 regular_spacetiming_struct.mem_hold_time = 254;
106 regular_spacetiming_struct.mem_waite_time = 254;
107 special_spacetiming_struct.class_bank = XMC_BANK2_NAND;
108 special_spacetiming_struct.mem_setup_time = 254;
109 special_spacetiming_struct.mem_hiz_time = 254;
110 special_spacetiming_struct.mem_hold_time = 254;
111 special_spacetiming_struct.mem_waite_time = 254;
112 xmc_nand_timing_config(&regular_spacetiming_struct, &special_spacetiming_struct);
113
114 /* xmc nand bank cmd test */
115 xmc_nand_enable(XMC_BANK2_NAND, TRUE);
116}
117
124void nand_read_id(nand_id_type* nand_id_struct)
125{
126 uint32_t data = 0;
127
128 /* send command to the command area */
129 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = 0x90;
130 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = 0x00;
131
132#ifdef H27U1G8F2CTR
133 /* sequence to read id from nand flash */
134 data = *(__IO uint32_t *)(Bank_NAND_ADDR | DATA_AREA);
135 nand_id_struct->maker_id = addr_1st_cycle (data);
136 nand_id_struct->device_id = addr_2nd_cycle (data);
137 nand_id_struct->third_id = addr_3rd_cycle (data);
138 nand_id_struct->fourth_id = addr_4th_cycle (data);
139#elif defined K9GAG08U0E
140 /* sequence to read id from nand flash */
141 data = *(__IO uint32_t *)(Bank_NAND_ADDR | DATA_AREA);
142 nand_id_struct->maker_id = addr_1st_cycle (data);
143 nand_id_struct->device_id = addr_2nd_cycle (data);
144 nand_id_struct->third_id = addr_3rd_cycle (data);
145 nand_id_struct->fourth_id = addr_4th_cycle (data);
146 data = *(__IO uint16_t *)(Bank_NAND_ADDR | DATA_AREA);
147 nand_id_struct->fifth_id = addr_1st_cycle (data);
148 nand_id_struct->sixth_id = addr_2nd_cycle (data);
149#endif
150}
151
165uint32_t nand_write_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write)
166{
167 uint32_t index = 0x00, num_page_written = 0x00, address_status = NAND_VALID_ADDRESS;
168 uint32_t status = NAND_READY, size = 0x00;
169
170 while((num_page_to_write != 0x00) && (address_status == NAND_VALID_ADDRESS) && (status == NAND_READY))
171 {
172 /* page write command and address */
173 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_WRITE0;
174#ifdef H27U1G8F2CTR
175 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(COL_ADDRESS);
176 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(COL_ADDRESS);
177 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
178 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
179#elif defined K9GAG08U0E
180 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(COL_ADDRESS);
181 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(COL_ADDRESS);
182 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
183 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
184 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_3rd_cycle(ROW_ADDRESS);
185#endif
186
187 /* calculate the size */
188 size = NAND_PAGE_SIZE + (NAND_PAGE_SIZE * num_page_written);
189
190 /* write data */
191 for(index = 0; index < size; index++)
192 {
193 *(__IO uint8_t *)(Bank_NAND_ADDR | DATA_AREA) = pbuffer[index];
194 }
195
196 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_WRITE_TRUE1;
197
198 /* check status for successful operation */
199 status = nand_get_status();
200
201 if(status == NAND_READY)
202 {
203 num_page_written++;
204
205 num_page_to_write--;
206
207 /* calculate next small page address */
208 address_status = nand_address_increment(&address_struct);
209 }
210 }
211
212 return (status | address_status);
213}
214
228uint32_t nand_read_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read)
229{
230 uint32_t index = 0x00, num_page_read = 0x00, address_status = NAND_VALID_ADDRESS;
231 uint32_t status = NAND_READY, size = 0x00 ;
232
233 while((num_page_to_read != 0x0) && (address_status == NAND_VALID_ADDRESS))
234 {
235 /* page read command and page address */
236 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_AREA_A;
237
238#ifdef H27U1G8F2CTR
239 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(COL_ADDRESS);
240 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(COL_ADDRESS);
241 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
242 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
243#elif defined K9GAG08U0E
244 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(COL_ADDRESS);
245 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(COL_ADDRESS);
246 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
247 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
248 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_3rd_cycle(ROW_ADDRESS);
249#endif
250 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_AREA_TRUE1;
251
252 delay_ms(1);
253
254 /* calculate the size */
255 size = (NAND_PAGE_SIZE + NAND_SPARE_AREA_SIZE) + ((NAND_PAGE_SIZE + NAND_SPARE_AREA_SIZE) * num_page_read);
256
257 /* get data into buffer */
258 for(index = 0x00; index < size; index++)
259 {
260 pbuffer[index]= *(__IO uint8_t *)(Bank_NAND_ADDR | DATA_AREA);
261 }
262
263 num_page_read++;
264
265 num_page_to_read--;
266
267 /* calculate page address */
268 address_status = nand_address_increment(&address_struct);
269 }
270
271 status = nand_get_status();
272
273 return (status | address_status);
274}
275
290uint32_t nand_write_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write)
291{
292 uint32_t index = 0x00, num_spare_area_written = 0x00, address_status = NAND_VALID_ADDRESS;
293 uint32_t status = NAND_READY, size = 0x00;
294
295 while((num_spare_area_to_write != 0x00) && (address_status == NAND_VALID_ADDRESS) && (status == NAND_READY))
296 {
297 /* page write spare area command and address */
298 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_AREA_C;
299 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_WRITE0;
300
301 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(COL_ADDRESS);
302 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(COL_ADDRESS);
303 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
304 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
305
306 /* calculate the size */
307 size = NAND_SPARE_AREA_SIZE + (NAND_SPARE_AREA_SIZE * num_spare_area_written);
308
309 /* write the data */
310 for(index = 0x00; index < size; index++)
311 {
312 *(__IO uint8_t *)(Bank_NAND_ADDR | DATA_AREA) = pbuffer[index];
313 }
314
315 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_WRITE_TRUE1;
316
317 /* check status for successful operation */
318 status = nand_get_status();
319
320 if(status == NAND_READY)
321 {
322 num_spare_area_written++;
323
324 num_spare_area_to_write--;
325
326 /* calculate next page address */
327 address_status = nand_address_increment(&address_struct);
328 }
329 }
330
331 return (status | address_status);
332}
333
348uint32_t nand_read_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read)
349{
350 uint32_t num_spare_area_read = 0x00, index = 0x00, address_status = NAND_VALID_ADDRESS;
351 uint32_t status = NAND_READY, size = 0x00;
352
353 while((num_spare_area_to_read != 0x0) && (address_status == NAND_VALID_ADDRESS))
354 {
355 /* page read command and page address */
356 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_AREA_C;
357
358 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = 0x00;
359 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
360 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
361 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_3rd_cycle(ROW_ADDRESS);
362 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_4th_cycle(ROW_ADDRESS);
363
364 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_AREA_TRUE1;
365
366 delay_ms(1);
367
368 /* data read */
369 size = NAND_SPARE_AREA_SIZE + (NAND_SPARE_AREA_SIZE * num_spare_area_read);
370
371 /* get data into buffer */
372 for(index = 0x00 ;index < size; index++)
373 {
374 pbuffer[index] = *(__IO uint8_t *)(Bank_NAND_ADDR | DATA_AREA);
375 }
376
377 num_spare_area_read++;
378
379 num_spare_area_to_read--;
380
381 /* calculate page address */
382 address_status = nand_address_increment(&address_struct);
383 }
384
385 status = nand_get_status();
386
387 return (status | address_status);
388}
389
398uint32_t nand_erase_block(nand_address_type address_struct)
399{
400 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_ERASE0;
401
402#ifdef H27U1G8F2CTR
403 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
404 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
405#elif defined K9GAG08U0E
406 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
407 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
408 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_3rd_cycle(ROW_ADDRESS);
409#endif
410 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_ERASE1;
411
412 return (nand_get_status());
413}
414
420uint32_t nand_reset(void)
421{
422 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_RESET;
423
424 return (NAND_READY);
425}
426
435uint32_t nand_get_status(void)
436{
437 uint32_t timeout = 0x1000000, status = NAND_READY;
438
439 status = nand_read_status();
440
441 /* wait for a nand operation to complete or a timeout to occur */
442 while((status != NAND_READY) && ( timeout != 0x00))
443 {
444 status = nand_read_status();
445 timeout --;
446 }
447
448 if(timeout == 0x00)
449 {
450 status = NAND_TIMEOUT_ERROR;
451 }
452
453 /* return the operation status */
454 return (status);
455}
456
465uint32_t nand_read_status(void)
466{
467 uint32_t data = 0x00, status = NAND_BUSY;
468
469 /* read status operation ------------------------------------*/
470 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_STATUS;
471 data = *(__IO uint8_t *)(Bank_NAND_ADDR);
472
473 if((data & NAND_ERROR) == NAND_ERROR)
474 {
475 status = NAND_ERROR;
476 }
477 else if((data & NAND_READY) == NAND_READY)
478 {
479 status = NAND_READY;
480 }
481 else
482 {
483 status = NAND_BUSY;
484 }
485
486 return (status);
487}
488
496uint32_t nand_address_increment(nand_address_type* address_struct)
497{
498 uint32_t status = NAND_VALID_ADDRESS;
499
500 address_struct->page++;
501
502 if(address_struct->page == NAND_BLOCK_SIZE)
503 {
504 address_struct->page = 0;
505 address_struct->block++;
506
507 if(address_struct->block == NAND_ZONE_SIZE)
508 {
509 address_struct->block = 0;
510 address_struct->zone++;
511
512 if(address_struct->zone == NAND_MAX_ZONE)
513 {
514 status = NAND_INVALID_ADDRESS;
515 }
516 }
517 }
518
519 return (status);
520}
521
522
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
COL_ADDRESS
#define COL_ADDRESS
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:75
Bank_NAND_ADDR
#define Bank_NAND_ADDR
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:80
nand_id_struct
nand_id_type nand_id_struct
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:40
ROW_ADDRESS
#define ROW_ADDRESS
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:74
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
nand_read_small_page
uint32_t nand_read_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read)
this routine is for sequential read from one or several 512 bytes page size.
Definition: at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c:228
nand_read_id
void nand_read_id(nand_id_type *nand_id_struct)
reads nand memory's id.
Definition: at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c:124
nand_init
void nand_init(void)
configures the xmc and gpios to interface with the nand memory. this function must be called before a...
Definition: at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c:43
nand_read_status
uint32_t nand_read_status(void)
reads the nand memory status using the read status command.
Definition: at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c:465
nand_address_increment
uint32_t nand_address_increment(nand_address_type *address_struct)
increment the nand memory address.
Definition: at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c:496
nand_reset
uint32_t nand_reset(void)
this routine reset the nand flash.
Definition: at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c:420
nand_erase_block
uint32_t nand_erase_block(nand_address_type address_struct)
this routine erase complete block from nand flash
Definition: at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c:398
nand_read_spare_area
uint32_t nand_read_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read)
this routine read the spare area information from the specified pages addresses.
Definition: at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c:348
nand_write_small_page
uint32_t nand_write_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write)
this routine is for writing one or several 512 bytes page size.
Definition: at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c:165
nand_get_status
uint32_t nand_get_status(void)
get the nand operation status.
Definition: at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c:435
nand_write_spare_area
uint32_t nand_write_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write)
this routine write the spare area information for the specified pages addresses.
Definition: at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c:290
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_XMC_PERIPH_CLOCK
@ CRM_XMC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:123
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_MODERATE
@ GPIO_DRIVE_STRENGTH_MODERATE
Definition: at32f435_437_gpio.h:94
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
ADDR_AREA
#define ADDR_AREA
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:98
CMD_AREA
#define CMD_AREA
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:96
DATA_AREA
#define DATA_AREA
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:100
xmc_nand_init
void xmc_nand_init(xmc_nand_init_type *xmc_nand_init_struct)
initialize the xmc nand banks according to the specified parameters in the xmc_nandinitstruct.
Definition: at32f435_437_xmc.c:269
xmc_nand_timing_default_para_init
void xmc_nand_timing_default_para_init(xmc_nand_pccard_timinginit_type *xmc_common_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_attribute_spacetiming_struct)
fill each xmc_common_spacetiming_struct and xmc_attribute_spacetiming_struct member with its default ...
Definition: at32f435_437_xmc.c:360
xmc_nand_default_para_init
void xmc_nand_default_para_init(xmc_nand_init_type *xmc_nand_init_struct)
fill each xmc_nand_init_struct member with its default value.
Definition: at32f435_437_xmc.c:340
xmc_nand_timing_config
void xmc_nand_timing_config(xmc_nand_pccard_timinginit_type *xmc_common_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_attribute_spacetiming_struct)
initialize the xmc nand banks according to the specified parameters in the xmc_nandinitstruct.
Definition: at32f435_437_xmc.c:305
xmc_nand_enable
void xmc_nand_enable(xmc_class_bank_type xmc_bank, confirm_state new_state)
enable or disable the specified nand memory bank.
Definition: at32f435_437_xmc.c:384
XMC_BANK2_NAND
@ XMC_BANK2_NAND
Definition: at32f435_437_xmc.h:157
XMC_BUSTYPE_8_BITS
@ XMC_BUSTYPE_8_BITS
Definition: at32f435_437_xmc.h:178
XMC_WAIT_OPERATION_DISABLE
@ XMC_WAIT_OPERATION_DISABLE
Definition: at32f435_437_xmc.h:128
XMC_ECC_PAGESIZE_8192_BYTES
@ XMC_ECC_PAGESIZE_8192_BYTES
Definition: at32f435_437_xmc.h:221
XMC_ECC_PAGESIZE_2048_BYTES
@ XMC_ECC_PAGESIZE_2048_BYTES
Definition: at32f435_437_xmc.h:219
XMC_ECC_OPERATION_DISABLE
@ XMC_ECC_OPERATION_DISABLE
Definition: at32f435_437_xmc.h:137
addr_2nd_cycle
#define addr_2nd_cycle(addr)
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:188
addr_3rd_cycle
#define addr_3rd_cycle(addr)
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:190
addr_4th_cycle
#define addr_4th_cycle(addr)
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:192
addr_1st_cycle
#define addr_1st_cycle(addr)
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:186
NAND_CMD_WRITE_TRUE1
#define NAND_CMD_WRITE_TRUE1
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:117
NAND_CMD_RESET
#define NAND_CMD_RESET
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:125
NAND_CMD_WRITE0
#define NAND_CMD_WRITE0
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:116
NAND_CMD_STATUS
#define NAND_CMD_STATUS
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:123
NAND_CMD_AREA_A
#define NAND_CMD_AREA_A
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:111
NAND_CMD_ERASE1
#define NAND_CMD_ERASE1
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:120
NAND_CMD_ERASE0
#define NAND_CMD_ERASE0
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:119
NAND_CMD_AREA_TRUE1
#define NAND_CMD_AREA_TRUE1
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:114
NAND_CMD_AREA_C
#define NAND_CMD_AREA_C
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:113
NAND_ERROR
#define NAND_ERROR
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:140
NAND_READY
#define NAND_READY
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:141
NAND_VALID_ADDRESS
#define NAND_VALID_ADDRESS
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:136
NAND_INVALID_ADDRESS
#define NAND_INVALID_ADDRESS
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:137
NAND_TIMEOUT_ERROR
#define NAND_TIMEOUT_ERROR
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:138
NAND_BUSY
#define NAND_BUSY
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:139
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
nand_address_type
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:63
nand_address_type::page
uint16_t page
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:66
nand_address_type::block
uint16_t block
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:65
nand_address_type::zone
uint16_t zone
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:64
nand_id_type
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:45
nand_id_type::sixth_id
uint8_t sixth_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:51
nand_id_type::device_id
uint8_t device_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:47
nand_id_type::fourth_id
uint8_t fourth_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:49
nand_id_type::fifth_id
uint8_t fifth_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:50
nand_id_type::third_id
uint8_t third_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:48
nand_id_type::maker_id
uint8_t maker_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:46
xmc_nand_init_type
xmc nand init structure definition
Definition: at32f435_437_xmc.h:443
xmc_nand_init_type::ecc_enable
xmc_ecc_enable_type ecc_enable
Definition: at32f435_437_xmc.h:447
xmc_nand_init_type::delay_time_cycle
uint32_t delay_time_cycle
Definition: at32f435_437_xmc.h:449
xmc_nand_init_type::nand_bank
xmc_class_bank_type nand_bank
Definition: at32f435_437_xmc.h:444
xmc_nand_init_type::wait_enable
xmc_nand_pccard_wait_type wait_enable
Definition: at32f435_437_xmc.h:445
xmc_nand_init_type::ecc_pagesize
xmc_ecc_pagesize_type ecc_pagesize
Definition: at32f435_437_xmc.h:448
xmc_nand_init_type::delay_time_ar
uint32_t delay_time_ar
Definition: at32f435_437_xmc.h:450
xmc_nand_init_type::bus_type
xmc_data_width_type bus_type
Definition: at32f435_437_xmc.h:446
xmc_nand_pccard_timinginit_type
nand and pccard timing parameters xmc
Definition: at32f435_437_xmc.h:430
xmc_nand_pccard_timinginit_type::class_bank
xmc_class_bank_type class_bank
Definition: at32f435_437_xmc.h:431
xmc_nand_pccard_timinginit_type::mem_waite_time
uint32_t mem_waite_time
Definition: at32f435_437_xmc.h:433
xmc_nand_pccard_timinginit_type::mem_hold_time
uint32_t mem_hold_time
Definition: at32f435_437_xmc.h:434
xmc_nand_pccard_timinginit_type::mem_hiz_time
uint32_t mem_hiz_time
Definition: at32f435_437_xmc.h:435
xmc_nand_pccard_timinginit_type::mem_setup_time
uint32_t mem_setup_time
Definition: at32f435_437_xmc.h:432


AT32F435/437 Firmwary Library: xmc_nor.h File Reference

  • at_start_f435
  • examples
  • xmc
  • nor_flash
  • inc
Data Structures | Enumerations | Functions
at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h File Reference
#include "at32f435_437_board.h"

Go to the source code of this file.

Data Structures

struct nor_idtype

Enumerations

enum nor_status {
NOR_SUCCESS = 0 , NOR_ONGOING , NOR_ERROR , NOR_TIMEOUT ,
NOR_SUCCESS = 0 , NOR_ONGOING , NOR_ERROR , NOR_TIMEOUT
}

Functions

void | nor_init (void)
init nor flash interface More...
void | nor_readid (nor_idtype *nor_id)
reads nor memory's manufacturer and device code. More...
nor_status | nor_eraseblock (uint32_t blockaddr)
erases the specified nor memory block. More...
nor_status | nor_erasechip (void)
erases the entire chip. More...
nor_status | nor_writehalfword (uint32_t writeaddr, uint16_t data)
writes a half-word to the nor memory. More...
nor_status | nor_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc nor memory. More...
nor_status | nor_programbuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc nor memory. this function must be used only with s29gl128p nor memory. More...
uint16_t | nor_readhalfword (uint32_t readaddr)
reads a half-word from the nor memory. More...
void | nor_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc nor memory. More...
nor_status | nor_returntoreadmode (void)
returns the nor memory to read mode. More...
nor_status | nor_reset (void)
returns the nor memory to read mode and resets the errors in the nor memory status register. More...
nor_status | nor_getstatus (uint32_t timeout)
returns the nor operation status. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...

Enumeration Type Documentation

◆ nor_status

enum nor_status
Enumerator
NOR_SUCCESS
NOR_ONGOING
NOR_ERROR
NOR_TIMEOUT
NOR_SUCCESS
NOR_ONGOING
NOR_ERROR
NOR_TIMEOUT

Definition at line 41 of file at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h.


AT32F435/437 Firmwary Library: xmc_nor.h Source File

  • at_start_f435
  • examples
  • xmc
  • nor_flash
  • inc
at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h
Go to the documentation of this file.
1
27#ifndef __XMC_SRAM_H
28#define __XMC_SRAM_H
29
30#include "at32f435_437_board.h"
31
32typedef struct
33{
34 uint16_t manufacturer_code;
35 uint16_t device_code1;
36 uint16_t device_code2;
37 uint16_t device_code3;
38}nor_idtype;
39
40/* nor status */
41typedef enum
42{
43 NOR_SUCCESS = 0,
44 NOR_ONGOING,
45 NOR_ERROR,
46 NOR_TIMEOUT
47}nor_status;
48
49void nor_init(void);
50void nor_readid(nor_idtype* nor_id);
51 nor_status nor_eraseblock(uint32_t blockaddr);
52 nor_status nor_erasechip(void);
53 nor_status nor_writehalfword(uint32_t writeaddr, uint16_t data);
54 nor_status nor_writebuffer(uint16_t* pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite);
55 nor_status nor_programbuffer(uint16_t* pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite);
56uint16_t nor_readhalfword(uint32_t readaddr);
57void nor_readbuffer(uint16_t* pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread);
58 nor_status nor_returntoreadmode(void);
59 nor_status nor_reset(void);
60 nor_status nor_getstatus(uint32_t timeout);
61void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset);
62
63#endif
at32f435_437_board.h
nor_status
nor_status
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:42
NOR_TIMEOUT
@ NOR_TIMEOUT
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:46
NOR_SUCCESS
@ NOR_SUCCESS
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:43
NOR_ONGOING
@ NOR_ONGOING
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:44
NOR_ERROR
@ NOR_ERROR
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:45
nor_readhalfword
uint16_t nor_readhalfword(uint32_t readaddr)
reads a half-word from the nor memory.
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:389
nor_eraseblock
nor_status nor_eraseblock(uint32_t blockaddr)
erases the specified nor memory block.
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:266
nor_writebuffer
nor_status nor_writebuffer(uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc nor memory.
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:322
nor_readid
void nor_readid(nor_idtype *nor_id)
reads nor memory's manufacturer and device code.
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:248
nor_id
nor_idtype nor_id
Definition: project/at_start_f435/examples/xmc/nor_flash/src/main.c:45
nor_programbuffer
nor_status nor_programbuffer(uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc nor memory. this function must be used only with s29gl128p nor m...
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:349
nor_init
void nor_init(void)
init nor flash interface
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:51
nor_writehalfword
nor_status nor_writehalfword(uint32_t writeaddr, uint16_t data)
writes a half-word to the nor memory.
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:303
fill_buffer
void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:520
nor_getstatus
nor_status nor_getstatus(uint32_t timeout)
returns the nor operation status.
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:453
nor_returntoreadmode
nor_status nor_returntoreadmode(void)
returns the nor memory to read mode.
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:425
nor_readbuffer
void nor_readbuffer(uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc nor memory.
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:406
nor_reset
nor_status nor_reset(void)
returns the nor memory to read mode and resets the errors in the nor memory status register.
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:438
nor_erasechip
nor_status nor_erasechip(void)
erases the entire chip.
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:284
nor_idtype
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:33
nor_idtype::manufacturer_code
uint16_t manufacturer_code
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:34
nor_idtype::device_code1
uint16_t device_code1
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:35
nor_idtype::device_code3
uint16_t device_code3
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:37
nor_idtype::device_code2
uint16_t device_code2
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:36


AT32F435/437 Firmwary Library: xmc_nor.c File Reference

  • at_start_f435
  • examples
  • xmc
  • nor_flash
  • src
Macros | Functions
at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c File Reference
#include "xmc_nor.h"

Go to the source code of this file.

Macros

#define | BANK1_NOR2_ADDR ((uint32_t)0x64000000)
#define | BLOCKERASE_TIMEOUT ((uint32_t)0x00A00000)
#define | CHIPERASE_TIMEOUT ((uint32_t)0x30000000)
#define | PROGRAM_TIMEOUT ((uint32_t)0x00001400)
#define | ADDR_SHIFT(A) (BANK1_NOR2_ADDR + (2 * (A)))
#define | NOR_WRITE(address, data) (*(__IO uint16_t *)(address) = (data))

Functions

void | nor_init (void)
init nor flash interface More...
void | nor_readid (nor_idtype *nor_id)
reads nor memory's manufacturer and device code. More...
nor_status | nor_eraseblock (uint32_t blockaddr)
erases the specified nor memory block. More...
nor_status | nor_erasechip (void)
erases the entire chip. More...
nor_status | nor_writehalfword (uint32_t writeaddr, uint16_t data)
writes a half-word to the nor memory. More...
nor_status | nor_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc nor memory. More...
nor_status | nor_programbuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc nor memory. this function must be used only with s29gl128p nor memory. More...
uint16_t | nor_readhalfword (uint32_t readaddr)
reads a half-word from the nor memory. More...
void | nor_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc nor memory. More...
nor_status | nor_returntoreadmode (void)
returns the nor memory to read mode. More...
nor_status | nor_reset (void)
returns the nor memory to read mode and resets the errors in the nor memory status register. More...
nor_status | nor_getstatus (uint32_t timeout)
returns the nor operation status. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...


AT32F435/437 Firmwary Library: xmc_nor.c Source File

  • at_start_f435
  • examples
  • xmc
  • nor_flash
  • src
at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c
Go to the documentation of this file.
1
27#include "xmc_nor.h"
28
37#define BANK1_NOR2_ADDR ((uint32_t)0x64000000)
38
39/* delay definition */
40#define BLOCKERASE_TIMEOUT ((uint32_t)0x00A00000)
41#define CHIPERASE_TIMEOUT ((uint32_t)0x30000000)
42#define PROGRAM_TIMEOUT ((uint32_t)0x00001400)
43
44#define ADDR_SHIFT(A) (BANK1_NOR2_ADDR + (2 * (A)))
45#define NOR_WRITE(address, data) (*(__IO uint16_t *)(address) = (data))
51void nor_init(void)
52{
53 gpio_init_type gpio_init_struct = {0};
54 xmc_norsram_init_type xmc_norsram_init_struct;
55 xmc_norsram_timing_init_type rw_timing_struct, w_timing_struct;
56
57 /* enable the gpio clock */
58 crm_periph_clock_enable(CRM_GPIOF_PERIPH_CLOCK, TRUE);
59 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
60 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
61 crm_periph_clock_enable(CRM_GPIOG_PERIPH_CLOCK, TRUE);
62 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
63
64 /* enable the xmc clock */
65 crm_periph_clock_enable(CRM_XMC_PERIPH_CLOCK, TRUE);
66
67 /*-- gpio configuration ------------------------------------------------------*/
68 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE0, GPIO_MUX_12);
69 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE1, GPIO_MUX_12);
70 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE2, GPIO_MUX_12);
71 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE3, GPIO_MUX_12);
72 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE4, GPIO_MUX_12);
73 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE5, GPIO_MUX_12);
74 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE12, GPIO_MUX_12);
75 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE13, GPIO_MUX_12);
76 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE14, GPIO_MUX_12);
77 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE15, GPIO_MUX_12);
78 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE0, GPIO_MUX_12);
79 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE1, GPIO_MUX_12);
80 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE2, GPIO_MUX_12);
81 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE3, GPIO_MUX_12);
82 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE4, GPIO_MUX_12);
83 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE5, GPIO_MUX_12);
84 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE13, GPIO_MUX_12);
85 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE14, GPIO_MUX_12);
86 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE9, GPIO_MUX_12);
87 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE11, GPIO_MUX_12);
88 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE12, GPIO_MUX_12);
89 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE13, GPIO_MUX_12);
90 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE0, GPIO_MUX_12);
91 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_12);
92 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE8, GPIO_MUX_12);
93 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE9, GPIO_MUX_12);
94 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE10, GPIO_MUX_12);
95 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE14, GPIO_MUX_12);
96 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE15, GPIO_MUX_12);
97 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_12);
98 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE5, GPIO_MUX_12);
99 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE6, GPIO_MUX_12);
100 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE3, GPIO_MUX_12);
101 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE4, GPIO_MUX_12);
102 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE5, GPIO_MUX_12);
103 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE6, GPIO_MUX_12);
104 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE2, GPIO_MUX_12);
105 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE13, GPIO_MUX_12);
106 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE7, GPIO_MUX_12);
107 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE8, GPIO_MUX_12);
108 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE9, GPIO_MUX_12);
109 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE10, GPIO_MUX_12);
110 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE11, GPIO_MUX_12);
111 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE12, GPIO_MUX_12);
112 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE14, GPIO_MUX_12);
113 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE15, GPIO_MUX_12);
114 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE0, GPIO_MUX_12);
115 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE1, GPIO_MUX_12);
116 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE7, GPIO_MUX_12);
117
118 /* address lines configuration */
119 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_2 | GPIO_PINS_3 | GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_12 | GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
120 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
121 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
122 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
123 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
124 gpio_init(GPIOF, &gpio_init_struct);
125
126 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_2 | GPIO_PINS_3 | GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_13 | GPIO_PINS_14;
127 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
128 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
129 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
130 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
131 gpio_init(GPIOG, &gpio_init_struct);
132
133 gpio_init_struct.gpio_pins = GPIO_PINS_11 | GPIO_PINS_12 | GPIO_PINS_13;
134 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
135 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
136 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
137 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
138 gpio_init(GPIOD, &gpio_init_struct);
139
140 gpio_init_struct.gpio_pins = GPIO_PINS_3 | GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6 | GPIO_PINS_2;
141 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
142 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
143 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
144 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
145 gpio_init(GPIOE, &gpio_init_struct);
146
147 /* data lines configuration */
148 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_14 | GPIO_PINS_15;
149 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
150 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
151 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
152 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
153 gpio_init(GPIOD, &gpio_init_struct);
154
155 gpio_init_struct.gpio_pins = GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11 | GPIO_PINS_12 | GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
156 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
157 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
158 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
159 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
160 gpio_init(GPIOE, &gpio_init_struct);
161
162 /* ne/noe/nwe/nbl0/nbl1/nwait lines configuration */
163 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
164 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
165 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
166 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
167 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
168 gpio_init(GPIOE, &gpio_init_struct);
169
170 gpio_init_struct.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5;
171 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
172 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
173 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
174 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
175 gpio_init(GPIOD, &gpio_init_struct);
176
177 gpio_init_struct.gpio_pins = GPIO_PINS_9;
178 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
179 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
180 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
181 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
182 gpio_init(GPIOG, &gpio_init_struct);
183
184 gpio_init_struct.gpio_pins = GPIO_PINS_6;
185 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
186 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
187 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
188 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
189 gpio_init(GPIOD, &gpio_init_struct);
190
191 gpio_init_struct.gpio_pins = GPIO_PINS_7;
192 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
193 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
194 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
195 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
196 gpio_init(GPIOB, &gpio_init_struct);
197
198
199 /*-- xmc configuration ------------------------------------------------------*/
200 xmc_norsram_default_para_init(&xmc_norsram_init_struct);
201 xmc_norsram_init_struct.subbank = XMC_BANK1_NOR_SRAM2;
202 xmc_norsram_init_struct.data_addr_multiplex = XMC_DATA_ADDR_MUX_DISABLE;
203 xmc_norsram_init_struct.device = XMC_DEVICE_NOR;
204 xmc_norsram_init_struct.bus_type = XMC_BUSTYPE_16_BITS;
205 xmc_norsram_init_struct.burst_mode_enable = XMC_BURST_MODE_DISABLE;
206 xmc_norsram_init_struct.asynwait_enable = XMC_ASYN_WAIT_DISABLE;
207 xmc_norsram_init_struct.wait_signal_lv = XMC_WAIT_SIGNAL_LEVEL_LOW;
208 xmc_norsram_init_struct.wrapped_mode_enable = XMC_WRAPPED_MODE_DISABLE;
209 xmc_norsram_init_struct.wait_signal_config = XMC_WAIT_SIGNAL_SYN_BEFORE;
210 xmc_norsram_init_struct.write_enable = XMC_WRITE_OPERATION_ENABLE;
211 xmc_norsram_init_struct.wait_signal_enable = XMC_WAIT_SIGNAL_DISABLE;
212 xmc_norsram_init_struct.write_timing_enable = XMC_WRITE_TIMING_DISABLE;
213 xmc_norsram_init_struct.write_burst_syn = XMC_WRITE_BURST_SYN_DISABLE;
214 xmc_nor_sram_init(&xmc_norsram_init_struct);
215
216 /* timing configuration */
217 xmc_norsram_timing_default_para_init(&rw_timing_struct, &w_timing_struct);
218 rw_timing_struct.subbank = XMC_BANK1_NOR_SRAM2;
219 rw_timing_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
220 rw_timing_struct.addr_setup_time = 0x8;
221 rw_timing_struct.addr_hold_time = 0x0;
222 rw_timing_struct.data_setup_time = 0x10;
223 rw_timing_struct.bus_latency_time = 0x0;
224 rw_timing_struct.clk_psc = 0x0;
225 rw_timing_struct.data_latency_time = 0x0;
226 rw_timing_struct.mode = XMC_ACCESS_MODE_B;
227 w_timing_struct.subbank = XMC_BANK1_NOR_SRAM2;
228 w_timing_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
229 w_timing_struct.addr_setup_time = 0x8;
230 w_timing_struct.addr_hold_time = 0x0;
231 w_timing_struct.data_setup_time = 0x10;
232 w_timing_struct.bus_latency_time = 0x0;
233 w_timing_struct.clk_psc = 0x0;
234 w_timing_struct.data_latency_time = 0x0;
235 w_timing_struct.mode = XMC_ACCESS_MODE_B;
236 xmc_nor_sram_timing_config(&rw_timing_struct, &w_timing_struct);
237
238 /* enable xmc_bank1_nor_sram2 */
239 xmc_nor_sram_enable(XMC_BANK1_NOR_SRAM2, TRUE);
240}
241
248void nor_readid(nor_idtype* nor_id)
249{
250 NOR_WRITE(ADDR_SHIFT(0x0555), 0x00AA);
251 NOR_WRITE(ADDR_SHIFT(0x02AA), 0x0055);
252 NOR_WRITE(ADDR_SHIFT(0x0555), 0x0090);
253
254 nor_id->manufacturer_code = *(__IO uint16_t *) ADDR_SHIFT(0x0000);
255 nor_id->device_code1 = *(__IO uint16_t *) ADDR_SHIFT(0x0001);
256 nor_id->device_code2 = *(__IO uint16_t *) ADDR_SHIFT(0x000E);
257 nor_id->device_code3 = *(__IO uint16_t *) ADDR_SHIFT(0x000F);
258}
259
266 nor_status nor_eraseblock(uint32_t blockaddr)
267{
268 NOR_WRITE(ADDR_SHIFT(0x0555), 0x00AA);
269 NOR_WRITE(ADDR_SHIFT(0x02AA), 0x0055);
270 NOR_WRITE(ADDR_SHIFT(0x0555), 0x0080);
271 NOR_WRITE(ADDR_SHIFT(0x0555), 0x00AA);
272 NOR_WRITE(ADDR_SHIFT(0x02AA), 0x0055);
273 NOR_WRITE((BANK1_NOR2_ADDR + blockaddr), 0x30);
274
275 return (nor_getstatus(BLOCKERASE_TIMEOUT));
276}
277
284 nor_status nor_erasechip(void)
285{
286 NOR_WRITE(ADDR_SHIFT(0x0555), 0x00AA);
287 NOR_WRITE(ADDR_SHIFT(0x02AA), 0x0055);
288 NOR_WRITE(ADDR_SHIFT(0x0555), 0x0080);
289 NOR_WRITE(ADDR_SHIFT(0x0555), 0x00AA);
290 NOR_WRITE(ADDR_SHIFT(0x02AA), 0x0055);
291 NOR_WRITE(ADDR_SHIFT(0x0555), 0x0010);
292
293 return (nor_getstatus(CHIPERASE_TIMEOUT));
294}
295
303 nor_status nor_writehalfword(uint32_t writeaddr, uint16_t data)
304{
305 NOR_WRITE(ADDR_SHIFT(0x0555), 0x00AA);
306 NOR_WRITE(ADDR_SHIFT(0x02AA), 0x0055);
307 NOR_WRITE(ADDR_SHIFT(0x0555), 0x00A0);
308 NOR_WRITE((BANK1_NOR2_ADDR + writeaddr), data);
309
310 return (nor_getstatus(PROGRAM_TIMEOUT));
311}
312
322 nor_status nor_writebuffer(uint16_t* pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
323{
324 nor_status status = NOR_ONGOING;
325
326 do
327 {
329 status = nor_writehalfword(writeaddr, *pbuffer++);
330 writeaddr = writeaddr + 2;
331 numhalfwordtowrite--;
332 }
333 while((status == NOR_SUCCESS) && (numhalfwordtowrite != 0));
334
335 return (status);
336}
337
349 nor_status nor_programbuffer(uint16_t* pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
350{
351 uint32_t lastloadedaddress = 0x00;
352 uint32_t currentaddress = 0x00;
353 uint32_t endaddress = 0x00;
354
356 currentaddress = writeaddr;
357 endaddress = writeaddr + numhalfwordtowrite - 1;
358 lastloadedaddress = writeaddr;
359
361 NOR_WRITE(ADDR_SHIFT(0x00555), 0x00AA);
362
363 NOR_WRITE(ADDR_SHIFT(0x02AA), 0x0055);
364
366 NOR_WRITE(ADDR_SHIFT(writeaddr), 0x0025);
367 NOR_WRITE(ADDR_SHIFT(writeaddr), (numhalfwordtowrite - 1));
368
370 while(currentaddress <= endaddress)
371 {
373 lastloadedaddress = currentaddress;
374
375 NOR_WRITE(ADDR_SHIFT(currentaddress), *pbuffer++);
376 currentaddress += 1;
377 }
378
379 NOR_WRITE(ADDR_SHIFT(lastloadedaddress), 0x29);
380
381 return(nor_getstatus(PROGRAM_TIMEOUT));
382}
383
389uint16_t nor_readhalfword(uint32_t readaddr)
390{
391 NOR_WRITE(ADDR_SHIFT(0x00555), 0x00AA);
392 NOR_WRITE(ADDR_SHIFT(0x002AA), 0x0055);
393 NOR_WRITE((BANK1_NOR2_ADDR + readaddr), 0x00F0 );
394
395 return (*(__IO uint16_t *)((BANK1_NOR2_ADDR + readaddr)));
396}
397
406void nor_readbuffer(uint16_t* pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
407{
408 NOR_WRITE(ADDR_SHIFT(0x0555), 0x00AA);
409 NOR_WRITE(ADDR_SHIFT(0x02AA), 0x0055);
410 NOR_WRITE((BANK1_NOR2_ADDR + readaddr), 0x00F0);
411
412 for(; numhalfwordtoread != 0x00; numhalfwordtoread--)
413 {
415 *pbuffer++ = *(__IO uint16_t *)((BANK1_NOR2_ADDR + readaddr));
416 readaddr = readaddr + 2;
417 }
418}
419
425 nor_status nor_returntoreadmode(void)
426{
427 NOR_WRITE(BANK1_NOR2_ADDR, 0x00F0);
428
429 return (NOR_SUCCESS);
430}
431
438 nor_status nor_reset(void)
439{
440 NOR_WRITE(ADDR_SHIFT(0x00555), 0x00AA);
441 NOR_WRITE(ADDR_SHIFT(0x002AA), 0x0055);
442 NOR_WRITE(BANK1_NOR2_ADDR, 0x00F0);
443
444 return (NOR_SUCCESS);
445}
446
453 nor_status nor_getstatus(uint32_t timeout)
454{
455 uint16_t val1 = 0x00, val2 = 0x00;
456 nor_status status = NOR_ONGOING;
457 uint32_t timeout1 = timeout;
458
460 while((gpio_input_data_bit_read(GPIOD, GPIO_PINS_6) != RESET) && (timeout1 > 0))
461 {
462 timeout1--;
463 }
464
465 timeout1 = timeout;
466
467 while((gpio_input_data_bit_read(GPIOD, GPIO_PINS_6) == RESET) && (timeout1 > 0))
468 {
469 timeout1--;
470 }
471
473 while((timeout != 0x00) && (status != NOR_SUCCESS))
474 {
475 timeout--;
476
478 val1 = *(__IO uint16_t *)(BANK1_NOR2_ADDR);
479 val2 = *(__IO uint16_t *)(BANK1_NOR2_ADDR);
480
482 if((val1 & 0x0040) == (val2 & 0x0040))
483 {
484 return NOR_SUCCESS;
485 }
486
487 if((val1 & 0x0020) != 0x0020)
488 {
489 status = NOR_ONGOING;
490 }
491
492 val1 = *(__IO uint16_t *)(BANK1_NOR2_ADDR);
493 val2 = *(__IO uint16_t *)(BANK1_NOR2_ADDR);
494
495 if((val1 & 0x0040) == (val2 & 0x0040))
496 {
497 return NOR_SUCCESS;
498 }
499 else if((val1 & 0x0020) == 0x0020)
500 {
501 return NOR_ERROR;
502 }
503 }
504
505 if(timeout == 0x00)
506 {
507 status = NOR_TIMEOUT;
508 }
509
511 return (status);
512}
513
520void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
521{
522 uint16_t indextmp = 0;
523
524 /* put in global buffer same values */
525 for (indextmp = 0; indextmp < bufferlenght; indextmp++ )
526 {
527 pbuffer[indextmp] = indextmp + offset;
528 }
529}
530
nor_status
nor_status
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:42
NOR_TIMEOUT
@ NOR_TIMEOUT
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:46
NOR_SUCCESS
@ NOR_SUCCESS
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:43
NOR_ONGOING
@ NOR_ONGOING
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:44
NOR_ERROR
@ NOR_ERROR
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:45
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
nor_readhalfword
uint16_t nor_readhalfword(uint32_t readaddr)
reads a half-word from the nor memory.
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:389
NOR_WRITE
#define NOR_WRITE(address, data)
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:45
nor_eraseblock
nor_status nor_eraseblock(uint32_t blockaddr)
erases the specified nor memory block.
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:266
nor_writebuffer
nor_status nor_writebuffer(uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc nor memory.
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:322
ADDR_SHIFT
#define ADDR_SHIFT(A)
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:44
nor_readid
void nor_readid(nor_idtype *nor_id)
reads nor memory's manufacturer and device code.
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:248
nor_id
nor_idtype nor_id
Definition: project/at_start_f435/examples/xmc/nor_flash/src/main.c:45
nor_programbuffer
nor_status nor_programbuffer(uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc nor memory. this function must be used only with s29gl128p nor m...
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:349
nor_init
void nor_init(void)
init nor flash interface
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:51
nor_writehalfword
nor_status nor_writehalfword(uint32_t writeaddr, uint16_t data)
writes a half-word to the nor memory.
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:303
CHIPERASE_TIMEOUT
#define CHIPERASE_TIMEOUT
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:41
fill_buffer
void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:520
BANK1_NOR2_ADDR
#define BANK1_NOR2_ADDR
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:37
PROGRAM_TIMEOUT
#define PROGRAM_TIMEOUT
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:42
nor_getstatus
nor_status nor_getstatus(uint32_t timeout)
returns the nor operation status.
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:453
nor_returntoreadmode
nor_status nor_returntoreadmode(void)
returns the nor memory to read mode.
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:425
nor_readbuffer
void nor_readbuffer(uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc nor memory.
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:406
BLOCKERASE_TIMEOUT
#define BLOCKERASE_TIMEOUT
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:40
nor_reset
nor_status nor_reset(void)
returns the nor memory to read mode and resets the errors in the nor memory status register.
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:438
nor_erasechip
nor_status nor_erasechip(void)
erases the entire chip.
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:284
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_XMC_PERIPH_CLOCK
@ CRM_XMC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:123
CRM_GPIOF_PERIPH_CLOCK
@ CRM_GPIOF_PERIPH_CLOCK
Definition: at32f435_437_crm.h:110
CRM_GPIOG_PERIPH_CLOCK
@ CRM_GPIOG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:111
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_input_data_bit_read
flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified input port pin.
Definition: at32f435_437_gpio.c:170
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f435_437_gpio.h:146
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f435_437_gpio.h:64
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOG
#define GPIOG
Definition: at32f435_437_gpio.h:527
GPIOF
#define GPIOF
Definition: at32f435_437_gpio.h:526
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
xmc_nor_sram_init
void xmc_nor_sram_init(xmc_norsram_init_type *xmc_norsram_init_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_norsraminitstruct.
Definition: at32f435_437_xmc.c:78
xmc_norsram_timing_default_para_init
void xmc_norsram_timing_default_para_init(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
fill each xmc_rw_timing_struct and xmc_w_timing_struct member with its default value.
Definition: at32f435_437_xmc.c:176
xmc_nor_sram_timing_config
void xmc_nor_sram_timing_config(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_rw_timing_struct a...
Definition: at32f435_437_xmc.c:113
xmc_norsram_default_para_init
void xmc_norsram_default_para_init(xmc_norsram_init_type *xmc_nor_sram_init_struct)
fill each xmc_nor_sram_init_struct member with its default value.
Definition: at32f435_437_xmc.c:150
xmc_nor_sram_enable
void xmc_nor_sram_enable(xmc_nor_sram_subbank_type xmc_subbank, confirm_state new_state)
enable or disable the specified nor/sram memory bank.
Definition: at32f435_437_xmc.c:210
XMC_WAIT_SIGNAL_DISABLE
@ XMC_WAIT_SIGNAL_DISABLE
Definition: at32f435_437_xmc.h:101
XMC_WAIT_SIGNAL_SYN_BEFORE
@ XMC_WAIT_SIGNAL_SYN_BEFORE
Definition: at32f435_437_xmc.h:196
XMC_WRITE_OPERATION_ENABLE
@ XMC_WRITE_OPERATION_ENABLE
Definition: at32f435_437_xmc.h:93
XMC_WRITE_BURST_SYN_DISABLE
@ XMC_WRITE_BURST_SYN_DISABLE
Definition: at32f435_437_xmc.h:110
XMC_BURST_MODE_DISABLE
@ XMC_BURST_MODE_DISABLE
Definition: at32f435_437_xmc.h:65
XMC_DATA_ADDR_MUX_DISABLE
@ XMC_DATA_ADDR_MUX_DISABLE
Definition: at32f435_437_xmc.h:56
XMC_BUSTYPE_16_BITS
@ XMC_BUSTYPE_16_BITS
Definition: at32f435_437_xmc.h:179
XMC_WRITE_TIMING_ENABLE
@ XMC_WRITE_TIMING_ENABLE
Definition: at32f435_437_xmc.h:120
XMC_WRITE_TIMING_DISABLE
@ XMC_WRITE_TIMING_DISABLE
Definition: at32f435_437_xmc.h:119
XMC_BANK1_NOR_SRAM2
@ XMC_BANK1_NOR_SRAM2
Definition: at32f435_437_xmc.h:147
XMC_ASYN_WAIT_DISABLE
@ XMC_ASYN_WAIT_DISABLE
Definition: at32f435_437_xmc.h:74
XMC_WRAPPED_MODE_DISABLE
@ XMC_WRAPPED_MODE_DISABLE
Definition: at32f435_437_xmc.h:83
XMC_ACCESS_MODE_B
@ XMC_ACCESS_MODE_B
Definition: at32f435_437_xmc.h:206
XMC_WAIT_SIGNAL_LEVEL_LOW
@ XMC_WAIT_SIGNAL_LEVEL_LOW
Definition: at32f435_437_xmc.h:187
XMC_DEVICE_NOR
@ XMC_DEVICE_NOR
Definition: at32f435_437_xmc.h:170
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
nor_idtype
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:33
nor_idtype::manufacturer_code
uint16_t manufacturer_code
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:34
nor_idtype::device_code1
uint16_t device_code1
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:35
nor_idtype::device_code3
uint16_t device_code3
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:37
nor_idtype::device_code2
uint16_t device_code2
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:36
xmc_norsram_init_type
xmc nor/sram init structure definition
Definition: at32f435_437_xmc.h:409
xmc_norsram_init_type::wait_signal_enable
xmc_wait_signal_type wait_signal_enable
Definition: at32f435_437_xmc.h:420
xmc_norsram_init_type::data_addr_multiplex
xmc_data_addr_mux_type data_addr_multiplex
Definition: at32f435_437_xmc.h:411
xmc_norsram_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:421
xmc_norsram_init_type::burst_mode_enable
xmc_burst_access_mode_type burst_mode_enable
Definition: at32f435_437_xmc.h:414
xmc_norsram_init_type::bus_type
xmc_data_width_type bus_type
Definition: at32f435_437_xmc.h:413
xmc_norsram_init_type::device
xmc_memory_type device
Definition: at32f435_437_xmc.h:412
xmc_norsram_init_type::wait_signal_lv
xmc_wait_signal_polarity_type wait_signal_lv
Definition: at32f435_437_xmc.h:416
xmc_norsram_init_type::wrapped_mode_enable
xmc_wrap_mode_type wrapped_mode_enable
Definition: at32f435_437_xmc.h:417
xmc_norsram_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:410
xmc_norsram_init_type::write_burst_syn
xmc_write_burst_type write_burst_syn
Definition: at32f435_437_xmc.h:422
xmc_norsram_init_type::asynwait_enable
xmc_asyn_wait_type asynwait_enable
Definition: at32f435_437_xmc.h:415
xmc_norsram_init_type::wait_signal_config
xmc_wait_timing_type wait_signal_config
Definition: at32f435_437_xmc.h:418
xmc_norsram_init_type::write_enable
xmc_write_operation_type write_enable
Definition: at32f435_437_xmc.h:419
xmc_norsram_timing_init_type
nor/sram banks timing parameters
Definition: at32f435_437_xmc.h:393
xmc_norsram_timing_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:395
xmc_norsram_timing_init_type::data_latency_time
uint32_t data_latency_time
Definition: at32f435_437_xmc.h:401
xmc_norsram_timing_init_type::addr_hold_time
uint32_t addr_hold_time
Definition: at32f435_437_xmc.h:397
xmc_norsram_timing_init_type::bus_latency_time
uint32_t bus_latency_time
Definition: at32f435_437_xmc.h:399
xmc_norsram_timing_init_type::addr_setup_time
uint32_t addr_setup_time
Definition: at32f435_437_xmc.h:396
xmc_norsram_timing_init_type::mode
xmc_access_mode_type mode
Definition: at32f435_437_xmc.h:402
xmc_norsram_timing_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:394
xmc_norsram_timing_init_type::clk_psc
uint32_t clk_psc
Definition: at32f435_437_xmc.h:400
xmc_norsram_timing_init_type::data_setup_time
uint32_t data_setup_time
Definition: at32f435_437_xmc.h:398


AT32F435/437 Firmwary Library: xmc_psram.h File Reference

  • at_start_f435
  • examples
  • xmc
  • psram
  • inc
Functions
at_start_f435/examples/xmc/psram/inc/xmc_psram.h File Reference
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void | psram_init (void)
init psram interface More...
void | psram_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc psram memory. More...
void | psram_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc psram memory. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...


AT32F435/437 Firmwary Library: xmc_psram.h Source File

  • at_start_f435
  • examples
  • xmc
  • psram
  • inc
at_start_f435/examples/xmc/psram/inc/xmc_psram.h
Go to the documentation of this file.
1
27#ifndef __XMC_SRAM_H
28#define __XMC_SRAM_H
29
30#include "at32f435_437_board.h"
31
32void psram_init(void);
33void psram_writebuffer(uint16_t* pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite);
34void psram_readbuffer(uint16_t* pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread);
35void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset);
36
37#endif
at32f435_437_board.h
fill_buffer
void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:520
psram_init
void psram_init(void)
init psram interface
Definition: at_start_f437/examples/xmc/psram/src/xmc_psram.c:44
psram_readbuffer
void psram_readbuffer(uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc psram memory.
Definition: at_start_f437/examples/xmc/psram/src/xmc_psram.c:235
psram_writebuffer
void psram_writebuffer(uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc psram memory.
Definition: at_start_f437/examples/xmc/psram/src/xmc_psram.c:215


AT32F435/437 Firmwary Library: xmc_psram.c File Reference

  • at_start_f435
  • examples
  • xmc
  • psram
  • src
Macros | Functions
at_start_f435/examples/xmc/psram/src/xmc_psram.c File Reference

xmc_psram program More...

#include "xmc_psram.h"

Go to the source code of this file.

Macros

#define BANK1_SRAM3_ADDR (uint32_t)0x68000000

Functions

void | psram_init (void)
init psram interface More...
void | psram_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc psram memory. More...
void | psram_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc psram memory. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...

Detailed Description

xmc_psram program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/xmc/psram/src/xmc_psram.c.


AT32F435/437 Firmwary Library: xmc_psram.c Source File

  • at_start_f435
  • examples
  • xmc
  • psram
  • src
at_start_f435/examples/xmc/psram/src/xmc_psram.c
Go to the documentation of this file.
1
27#include "xmc_psram.h"
28
37#define BANK1_SRAM3_ADDR (uint32_t)0x68000000
38
44void psram_init(void)
45{
46 gpio_init_type gpio_init_struct = {0};
47 xmc_norsram_init_type xmc_norsram_init_struct;
48 xmc_norsram_timing_init_type rw_timing_struct, w_timing_struct;
49
50 /* enable the gpio clock */
51 crm_periph_clock_enable(CRM_GPIOF_PERIPH_CLOCK, TRUE);
52 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
53 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
54 crm_periph_clock_enable(CRM_GPIOG_PERIPH_CLOCK, TRUE);
55 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
56
57 /* enable the xmc clock */
58 crm_periph_clock_enable(CRM_XMC_PERIPH_CLOCK, TRUE);
59
60 /*-- gpio configuration ------------------------------------------------------*/
61 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE13, GPIO_MUX_12);
62 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE14, GPIO_MUX_12);
63 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE10, GPIO_MUX_12);
64 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE11, GPIO_MUX_12);
65 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE12, GPIO_MUX_12);
66 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE13, GPIO_MUX_12);
67 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE0, GPIO_MUX_12);
68 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_12);
69 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE8, GPIO_MUX_12);
70 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE9, GPIO_MUX_12);
71 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE10, GPIO_MUX_12);
72 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE14, GPIO_MUX_12);
73 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE15, GPIO_MUX_12);
74 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_12);
75 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE5, GPIO_MUX_12);
76 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE3, GPIO_MUX_12);
77 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE4, GPIO_MUX_12);
78 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE5, GPIO_MUX_12);
79 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE6, GPIO_MUX_12);
80 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE2, GPIO_MUX_12);
81 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE13, GPIO_MUX_12);
82 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE7, GPIO_MUX_12);
83 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE8, GPIO_MUX_12);
84 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE9, GPIO_MUX_12);
85 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE10, GPIO_MUX_12);
86 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE11, GPIO_MUX_12);
87 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE12, GPIO_MUX_12);
88 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE14, GPIO_MUX_12);
89 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE15, GPIO_MUX_12);
90 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE0, GPIO_MUX_12);
91 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE1, GPIO_MUX_12);
92 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE7, GPIO_MUX_12);
93
94 /* address lines configuration */
95 gpio_init_struct.gpio_pins = GPIO_PINS_13 | GPIO_PINS_14;
96 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
97 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
98 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
99 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
100 gpio_init(GPIOG, &gpio_init_struct);
101
102 gpio_init_struct.gpio_pins = GPIO_PINS_11 | GPIO_PINS_12 | GPIO_PINS_13;
103 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
104 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
105 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
106 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
107 gpio_init(GPIOD, &gpio_init_struct);
108
109 gpio_init_struct.gpio_pins = GPIO_PINS_3 | GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6 | GPIO_PINS_2;
110 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
111 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
112 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
113 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
114 gpio_init(GPIOE, &gpio_init_struct);
115
116 /* data lines configuration */
117 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_14 | GPIO_PINS_15;
118 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
119 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
120 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
121 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
122 gpio_init(GPIOD, &gpio_init_struct);
123
124 gpio_init_struct.gpio_pins = GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11 | GPIO_PINS_12 | GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
125 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
126 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
127 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
128 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
129 gpio_init(GPIOE, &gpio_init_struct);
130
131 /* ne/noe/nwe/nbl0/nbl1 lines configuration */
132 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
133 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
134 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
135 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
136 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
137 gpio_init(GPIOE, &gpio_init_struct);
138
139 gpio_init_struct.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5;
140 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
141 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
142 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
143 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
144 gpio_init(GPIOD, &gpio_init_struct);
145
146 gpio_init_struct.gpio_pins = GPIO_PINS_10;
147 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
148 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
149 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
150 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
151 gpio_init(GPIOG, &gpio_init_struct);
152
153 gpio_init_struct.gpio_pins = GPIO_PINS_7;
154 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
155 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
156 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
157 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
158 gpio_init(GPIOB, &gpio_init_struct);
159
160
161 /*-- xmc configuration ------------------------------------------------------*/
162 xmc_norsram_default_para_init(&xmc_norsram_init_struct);
163 xmc_norsram_init_struct.subbank = XMC_BANK1_NOR_SRAM3;
164 xmc_norsram_init_struct.data_addr_multiplex = XMC_DATA_ADDR_MUX_ENABLE;
165 xmc_norsram_init_struct.device = XMC_DEVICE_PSRAM;
166 xmc_norsram_init_struct.bus_type = XMC_BUSTYPE_16_BITS;
167 xmc_norsram_init_struct.burst_mode_enable = XMC_BURST_MODE_DISABLE;
168 xmc_norsram_init_struct.asynwait_enable = XMC_ASYN_WAIT_DISABLE;
169 xmc_norsram_init_struct.wait_signal_lv = XMC_WAIT_SIGNAL_LEVEL_LOW;
170 xmc_norsram_init_struct.wrapped_mode_enable = XMC_WRAPPED_MODE_DISABLE;
171 xmc_norsram_init_struct.wait_signal_config = XMC_WAIT_SIGNAL_SYN_BEFORE;
172 xmc_norsram_init_struct.write_enable = XMC_WRITE_OPERATION_ENABLE;
173 xmc_norsram_init_struct.wait_signal_enable = XMC_WAIT_SIGNAL_DISABLE;
174 xmc_norsram_init_struct.write_timing_enable = XMC_WRITE_TIMING_DISABLE;
175 xmc_norsram_init_struct.write_burst_syn = XMC_WRITE_BURST_SYN_DISABLE;
176 xmc_nor_sram_init(&xmc_norsram_init_struct);
177
178 /* timing configuration */
179 xmc_norsram_timing_default_para_init(&rw_timing_struct, &w_timing_struct);
180 rw_timing_struct.subbank = XMC_BANK1_NOR_SRAM3;
181 rw_timing_struct.write_timing_enable = XMC_WRITE_TIMING_DISABLE;
182 rw_timing_struct.addr_hold_time = 0x08;
183 rw_timing_struct.addr_setup_time = 0x09;
184 rw_timing_struct.data_setup_time = 0x0F;
185 rw_timing_struct.data_latency_time = 0x0;
186 rw_timing_struct.bus_latency_time = 0x0;
187 rw_timing_struct.clk_psc = 0x0;
188 rw_timing_struct.mode = XMC_ACCESS_MODE_A;
189 w_timing_struct.subbank = XMC_BANK1_NOR_SRAM3;
190 w_timing_struct.write_timing_enable = XMC_WRITE_TIMING_DISABLE;
191 w_timing_struct.addr_hold_time = 0x08;
192 w_timing_struct.addr_setup_time = 0x09;
193 w_timing_struct.data_setup_time = 0x0F;
194 w_timing_struct.data_latency_time = 0x0;
195 w_timing_struct.bus_latency_time = 0x0;
196 w_timing_struct.clk_psc = 0x0;
197 w_timing_struct.mode = XMC_ACCESS_MODE_A;
198 xmc_nor_sram_timing_config(&rw_timing_struct, &w_timing_struct);
199
200 /* bus turnaround phase for consecutive read duration and consecutive write duration */
201 xmc_ext_timing_config(XMC_BANK1_NOR_SRAM3, 0x08, 0x08);
202
203 /* enable xmc_bank1_nor_sram3 */
204 xmc_nor_sram_enable(XMC_BANK1_NOR_SRAM3, TRUE);
205}
206
215void psram_writebuffer(uint16_t* pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
216{
217 for(; numhalfwordtowrite != 0; numhalfwordtowrite--)
218 {
220 *(__IO uint16_t *) (BANK1_SRAM3_ADDR + writeaddr) = *pbuffer++;
221
223 writeaddr += 2;
224 }
225}
226
235void psram_readbuffer(uint16_t* pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
236{
237 for(; numhalfwordtoread != 0; numhalfwordtoread--)
238 {
240 *pbuffer++ = *(__IO uint16_t*) (BANK1_SRAM3_ADDR + readaddr);
241
243 readaddr += 2;
244 }
245}
246
253void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
254{
255 uint16_t indextmp = 0;
256
257 /* put in global buffer same values */
258 for (indextmp = 0; indextmp < bufferlenght; indextmp++ )
259 {
260 pbuffer[indextmp] = indextmp + offset;
261 }
262}
263
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
psram_init
void psram_init(void)
init psram interface
Definition: at_start_f435/examples/xmc/psram/src/xmc_psram.c:44
BANK1_SRAM3_ADDR
#define BANK1_SRAM3_ADDR
Definition: at_start_f435/examples/xmc/psram/src/xmc_psram.c:37
psram_readbuffer
void psram_readbuffer(uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc psram memory.
Definition: at_start_f435/examples/xmc/psram/src/xmc_psram.c:235
psram_writebuffer
void psram_writebuffer(uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc psram memory.
Definition: at_start_f435/examples/xmc/psram/src/xmc_psram.c:215
fill_buffer
void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer
Definition: at_start_f435/examples/xmc/psram/src/xmc_psram.c:253
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_XMC_PERIPH_CLOCK
@ CRM_XMC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:123
CRM_GPIOF_PERIPH_CLOCK
@ CRM_GPIOF_PERIPH_CLOCK
Definition: at32f435_437_crm.h:110
CRM_GPIOG_PERIPH_CLOCK
@ CRM_GPIOG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:111
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f435_437_gpio.h:146
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f435_437_gpio.h:64
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOG
#define GPIOG
Definition: at32f435_437_gpio.h:527
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
xmc_nor_sram_init
void xmc_nor_sram_init(xmc_norsram_init_type *xmc_norsram_init_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_norsraminitstruct.
Definition: at32f435_437_xmc.c:78
xmc_norsram_timing_default_para_init
void xmc_norsram_timing_default_para_init(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
fill each xmc_rw_timing_struct and xmc_w_timing_struct member with its default value.
Definition: at32f435_437_xmc.c:176
xmc_nor_sram_timing_config
void xmc_nor_sram_timing_config(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_rw_timing_struct a...
Definition: at32f435_437_xmc.c:113
xmc_ext_timing_config
void xmc_ext_timing_config(xmc_nor_sram_subbank_type xmc_sub_bank, uint16_t w2w_timing, uint16_t r2r_timing)
config the bus turnaround phase.
Definition: at32f435_437_xmc.c:227
xmc_norsram_default_para_init
void xmc_norsram_default_para_init(xmc_norsram_init_type *xmc_nor_sram_init_struct)
fill each xmc_nor_sram_init_struct member with its default value.
Definition: at32f435_437_xmc.c:150
xmc_nor_sram_enable
void xmc_nor_sram_enable(xmc_nor_sram_subbank_type xmc_subbank, confirm_state new_state)
enable or disable the specified nor/sram memory bank.
Definition: at32f435_437_xmc.c:210
XMC_WAIT_SIGNAL_DISABLE
@ XMC_WAIT_SIGNAL_DISABLE
Definition: at32f435_437_xmc.h:101
XMC_WAIT_SIGNAL_SYN_BEFORE
@ XMC_WAIT_SIGNAL_SYN_BEFORE
Definition: at32f435_437_xmc.h:196
XMC_WRITE_OPERATION_ENABLE
@ XMC_WRITE_OPERATION_ENABLE
Definition: at32f435_437_xmc.h:93
XMC_WRITE_BURST_SYN_DISABLE
@ XMC_WRITE_BURST_SYN_DISABLE
Definition: at32f435_437_xmc.h:110
XMC_BURST_MODE_DISABLE
@ XMC_BURST_MODE_DISABLE
Definition: at32f435_437_xmc.h:65
XMC_DATA_ADDR_MUX_ENABLE
@ XMC_DATA_ADDR_MUX_ENABLE
Definition: at32f435_437_xmc.h:57
XMC_BUSTYPE_16_BITS
@ XMC_BUSTYPE_16_BITS
Definition: at32f435_437_xmc.h:179
XMC_WRITE_TIMING_DISABLE
@ XMC_WRITE_TIMING_DISABLE
Definition: at32f435_437_xmc.h:119
XMC_BANK1_NOR_SRAM3
@ XMC_BANK1_NOR_SRAM3
Definition: at32f435_437_xmc.h:148
XMC_ASYN_WAIT_DISABLE
@ XMC_ASYN_WAIT_DISABLE
Definition: at32f435_437_xmc.h:74
XMC_WRAPPED_MODE_DISABLE
@ XMC_WRAPPED_MODE_DISABLE
Definition: at32f435_437_xmc.h:83
XMC_ACCESS_MODE_A
@ XMC_ACCESS_MODE_A
Definition: at32f435_437_xmc.h:205
XMC_WAIT_SIGNAL_LEVEL_LOW
@ XMC_WAIT_SIGNAL_LEVEL_LOW
Definition: at32f435_437_xmc.h:187
XMC_DEVICE_PSRAM
@ XMC_DEVICE_PSRAM
Definition: at32f435_437_xmc.h:169
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
xmc_norsram_init_type
xmc nor/sram init structure definition
Definition: at32f435_437_xmc.h:409
xmc_norsram_init_type::wait_signal_enable
xmc_wait_signal_type wait_signal_enable
Definition: at32f435_437_xmc.h:420
xmc_norsram_init_type::data_addr_multiplex
xmc_data_addr_mux_type data_addr_multiplex
Definition: at32f435_437_xmc.h:411
xmc_norsram_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:421
xmc_norsram_init_type::burst_mode_enable
xmc_burst_access_mode_type burst_mode_enable
Definition: at32f435_437_xmc.h:414
xmc_norsram_init_type::bus_type
xmc_data_width_type bus_type
Definition: at32f435_437_xmc.h:413
xmc_norsram_init_type::device
xmc_memory_type device
Definition: at32f435_437_xmc.h:412
xmc_norsram_init_type::wait_signal_lv
xmc_wait_signal_polarity_type wait_signal_lv
Definition: at32f435_437_xmc.h:416
xmc_norsram_init_type::wrapped_mode_enable
xmc_wrap_mode_type wrapped_mode_enable
Definition: at32f435_437_xmc.h:417
xmc_norsram_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:410
xmc_norsram_init_type::write_burst_syn
xmc_write_burst_type write_burst_syn
Definition: at32f435_437_xmc.h:422
xmc_norsram_init_type::asynwait_enable
xmc_asyn_wait_type asynwait_enable
Definition: at32f435_437_xmc.h:415
xmc_norsram_init_type::wait_signal_config
xmc_wait_timing_type wait_signal_config
Definition: at32f435_437_xmc.h:418
xmc_norsram_init_type::write_enable
xmc_write_operation_type write_enable
Definition: at32f435_437_xmc.h:419
xmc_norsram_timing_init_type
nor/sram banks timing parameters
Definition: at32f435_437_xmc.h:393
xmc_norsram_timing_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:395
xmc_norsram_timing_init_type::data_latency_time
uint32_t data_latency_time
Definition: at32f435_437_xmc.h:401
xmc_norsram_timing_init_type::addr_hold_time
uint32_t addr_hold_time
Definition: at32f435_437_xmc.h:397
xmc_norsram_timing_init_type::bus_latency_time
uint32_t bus_latency_time
Definition: at32f435_437_xmc.h:399
xmc_norsram_timing_init_type::addr_setup_time
uint32_t addr_setup_time
Definition: at32f435_437_xmc.h:396
xmc_norsram_timing_init_type::mode
xmc_access_mode_type mode
Definition: at32f435_437_xmc.h:402
xmc_norsram_timing_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:394
xmc_norsram_timing_init_type::clk_psc
uint32_t clk_psc
Definition: at32f435_437_xmc.h:400
xmc_norsram_timing_init_type::data_setup_time
uint32_t data_setup_time
Definition: at32f435_437_xmc.h:398


AT32F435/437 Firmwary Library: xmc_sdram.h File Reference

  • at_start_f435
  • examples
  • xmc
  • sdram_basic
  • inc
Macros | Functions
at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h File Reference

header file for the sdram configuration. More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | SDRAM_BURST_LEN_1 ((uint16_t)0x0000)
#define | SDRAM_BURST_LEN_2 ((uint16_t)0x0001)
#define | SDRAM_BURST_LEN_4 ((uint16_t)0x0002)
#define | SDRAM_BURST_LEN_8 ((uint16_t)0x0004)
#define | SDRAM_BURST_SEQUENTIAL ((uint16_t)0x0000)
#define | SDRAM_BURST_INTERLEAVED ((uint16_t)0x0008)
#define | SDRAM_CAS_LATENCY_1 ((uint16_t)0x0010)
#define | SDRAM_CAS_LATENCY_2 ((uint16_t)0x0020)
#define | SDRAM_CAS_LATENCY_3 ((uint16_t)0x0030)
#define | SDRAM_OPERATING_MODE_STANDARD ((uint16_t)0x0000)
#define | SDRAM_WR_BURST_PROGRAMMED ((uint16_t)0x0000)
#define | SDRAM_WR_BURST_SINGLE ((uint16_t)0x0200)

Functions

void | sdram_init (void)
init sdram interface More...
void | sdram_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the sdram memory. More...
void | sdram_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the sdram. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...

Detailed Description

header file for the sdram configuration.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h.

Macro Definition Documentation

◆ SDRAM_BURST_INTERLEAVED

#define SDRAM_BURST_INTERLEAVED ((uint16_t)0x0008)

Definition at line 37 of file at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h.

◆ SDRAM_BURST_LEN_1

#define SDRAM_BURST_LEN_1 ((uint16_t)0x0000)

Definition at line 32 of file at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h.

◆ SDRAM_BURST_LEN_2

#define SDRAM_BURST_LEN_2 ((uint16_t)0x0001)

Definition at line 33 of file at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h.

◆ SDRAM_BURST_LEN_4

#define SDRAM_BURST_LEN_4 ((uint16_t)0x0002)

Definition at line 34 of file at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h.

◆ SDRAM_BURST_LEN_8

#define SDRAM_BURST_LEN_8 ((uint16_t)0x0004)

Definition at line 35 of file at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h.

◆ SDRAM_BURST_SEQUENTIAL

#define SDRAM_BURST_SEQUENTIAL ((uint16_t)0x0000)

Definition at line 36 of file at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h.

◆ SDRAM_CAS_LATENCY_1

#define SDRAM_CAS_LATENCY_1 ((uint16_t)0x0010)

Definition at line 38 of file at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h.

◆ SDRAM_CAS_LATENCY_2

#define SDRAM_CAS_LATENCY_2 ((uint16_t)0x0020)

Definition at line 39 of file at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h.

◆ SDRAM_CAS_LATENCY_3

#define SDRAM_CAS_LATENCY_3 ((uint16_t)0x0030)

Definition at line 40 of file at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h.

◆ SDRAM_OPERATING_MODE_STANDARD

#define SDRAM_OPERATING_MODE_STANDARD ((uint16_t)0x0000)

Definition at line 41 of file at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h.

◆ SDRAM_WR_BURST_PROGRAMMED

#define SDRAM_WR_BURST_PROGRAMMED ((uint16_t)0x0000)

Definition at line 42 of file at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h.

◆ SDRAM_WR_BURST_SINGLE

#define SDRAM_WR_BURST_SINGLE ((uint16_t)0x0200)

Definition at line 43 of file at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h.


AT32F435/437 Firmwary Library: xmc_sdram.h Source File

  • at_start_f435
  • examples
  • xmc
  • sdram_basic
  • inc
at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h
Go to the documentation of this file.
1
27#ifndef __XMC_SDRAM_H
28#define __XMC_SDRAM_H
29
30#include "at32f435_437_board.h"
31
32#define SDRAM_BURST_LEN_1 ((uint16_t)0x0000)
33#define SDRAM_BURST_LEN_2 ((uint16_t)0x0001)
34#define SDRAM_BURST_LEN_4 ((uint16_t)0x0002)
35#define SDRAM_BURST_LEN_8 ((uint16_t)0x0004)
36#define SDRAM_BURST_SEQUENTIAL ((uint16_t)0x0000)
37#define SDRAM_BURST_INTERLEAVED ((uint16_t)0x0008)
38#define SDRAM_CAS_LATENCY_1 ((uint16_t)0x0010)
39#define SDRAM_CAS_LATENCY_2 ((uint16_t)0x0020)
40#define SDRAM_CAS_LATENCY_3 ((uint16_t)0x0030)
41#define SDRAM_OPERATING_MODE_STANDARD ((uint16_t)0x0000)
42#define SDRAM_WR_BURST_PROGRAMMED ((uint16_t)0x0000)
43#define SDRAM_WR_BURST_SINGLE ((uint16_t)0x0200)
44
45void sdram_init(void);
46void sdram_writebuffer(uint16_t* pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite);
47void sdram_readbuffer(uint16_t* pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread);
48void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset);
49
50#endif
at32f435_437_board.h
fill_buffer
void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:520
sdram_writebuffer
void sdram_writebuffer(uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the sdram memory.
Definition: at_start_f437/examples/xmc/sdram_basic/src/xmc_sdram.c:248
sdram_init
void sdram_init(void)
init sdram interface
Definition: at_start_f437/examples/xmc/sdram_basic/src/xmc_sdram.c:46
sdram_readbuffer
void sdram_readbuffer(uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the sdram.
Definition: at_start_f437/examples/xmc/sdram_basic/src/xmc_sdram.c:268


AT32F435/437 Firmwary Library: xmc_sdram.c File Reference

  • at_start_f435
  • examples
  • xmc
  • sdram_basic
  • src
Macros | Functions
at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c File Reference

sdram program. More...

#include "xmc_sdram.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define SDRAM_BANK1_ADDR ((uint32_t)0xC0000000)

Functions

void | sdram_init_sequence (xmc_cmd_bank1_2_type cmd_bank)
init sdram sequence More...
void | sdram_init (void)
init sdram interface More...
void | sdram_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the sdram memory. More...
void | sdram_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the sdram. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...

Detailed Description

sdram program.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c.


AT32F435/437 Firmwary Library: xmc_sdram.c Source File

  • at_start_f435
  • examples
  • xmc
  • sdram_basic
  • src
at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c
Go to the documentation of this file.
1
27#include "xmc_sdram.h"
28#include "at32f435_437_board.h"
29
38#define SDRAM_BANK1_ADDR ((uint32_t)0xC0000000)
39void sdram_init_sequence(xmc_cmd_bank1_2_type cmd_bank);
40
46void sdram_init(void)
47{
48 gpio_init_type gpio_init_struct = {0};
49
50 xmc_sdram_init_type sdram_init_struct;
51 xmc_sdram_timing_type sdram_timing_struct;
52
53
54 /* enable the gpio clock */
55 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
56 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
57 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
58 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
59 crm_periph_clock_enable(CRM_GPIOF_PERIPH_CLOCK, TRUE);
60 crm_periph_clock_enable(CRM_GPIOG_PERIPH_CLOCK, TRUE);
61
62 /* enable the xmc clock */
63 crm_periph_clock_enable(CRM_XMC_PERIPH_CLOCK, TRUE);
64
65 /*-- gpio configuration ------------------------------------------------------*/
66
67 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE5, GPIO_MUX_12);
68 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE6, GPIO_MUX_12);
69
70 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE0, GPIO_MUX_12);
71 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE2, GPIO_MUX_12);
72 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE3, GPIO_MUX_12);
73
74 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE0, GPIO_MUX_12);
75 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_12);
76 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE8, GPIO_MUX_12);
77 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE9, GPIO_MUX_12);
78 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE10, GPIO_MUX_12);
79 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE14, GPIO_MUX_12);
80 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE15, GPIO_MUX_12);
81
82 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE0, GPIO_MUX_12);
83 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE1, GPIO_MUX_12);
84 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE7, GPIO_MUX_12);
85 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE8, GPIO_MUX_12);
86 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE9, GPIO_MUX_12);
87 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE10, GPIO_MUX_12);
88 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE11, GPIO_MUX_12);
89 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE12, GPIO_MUX_12);
90 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE13, GPIO_MUX_12);
91 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE14, GPIO_MUX_12);
92 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE15, GPIO_MUX_12);
93
94 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE0, GPIO_MUX_12);
95 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE1, GPIO_MUX_12);
96 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE2, GPIO_MUX_12);
97 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE3, GPIO_MUX_12);
98 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE4, GPIO_MUX_12);
99 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE5, GPIO_MUX_12);
100 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE11, GPIO_MUX_12);
101 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE12, GPIO_MUX_12);
102 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE13, GPIO_MUX_12);
103 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE14, GPIO_MUX_12);
104 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE15, GPIO_MUX_12);
105
106 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE0, GPIO_MUX_12);
107 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE1, GPIO_MUX_12);
108 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE2, GPIO_MUX_12);
109 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE4, GPIO_MUX_12);
110 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE5, GPIO_MUX_12);
111 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE8, GPIO_MUX_12);
112 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE15, GPIO_MUX_12);
113
114 /* address lines configuration */
115 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
116 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
117 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
118 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
119
120 gpio_init_struct.gpio_pins = GPIO_PINS_5 | GPIO_PINS_6;
121 gpio_init(GPIOB, &gpio_init_struct);
122
123 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_2 | GPIO_PINS_3;
124 gpio_init(GPIOC, &gpio_init_struct);
125
126 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_14 | GPIO_PINS_15;
127 gpio_init(GPIOD, &gpio_init_struct);
128
129 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_10 |
130 GPIO_PINS_9 | GPIO_PINS_11 | GPIO_PINS_11 | GPIO_PINS_12 |
131 GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
132 gpio_init(GPIOE, &gpio_init_struct);
133
134 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_2 | GPIO_PINS_3 |
135 GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_11 | GPIO_PINS_12 |
136 GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
137 gpio_init(GPIOF, &gpio_init_struct);
138
139 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_2 | GPIO_PINS_4 |
140 GPIO_PINS_5 | GPIO_PINS_8 | GPIO_PINS_15;
141 gpio_init(GPIOG, &gpio_init_struct);
142
143
144 /*-- xmc configuration ------------------------------------------------------*/
145 xmc_sdram_default_para_init(&sdram_init_struct, &sdram_timing_struct);
146
147 sdram_init_struct.sdram_bank = XMC_SDRAM_BANK1;
148 sdram_init_struct.internel_banks = XMC_INBK_4;
149 sdram_init_struct.clkdiv = XMC_CLKDIV_3;
150 sdram_init_struct.write_protection = FALSE;
151 sdram_init_struct.burst_read = FALSE;
152 sdram_init_struct.read_delay = XMC_READ_DELAY_1;
153 sdram_init_struct.column_address = XMC_COLUMN_9;
154 sdram_init_struct.row_address = XMC_ROW_13;
155 sdram_init_struct.cas = XMC_CAS_3;
156 sdram_init_struct.width = XMC_MEM_WIDTH_16;
157
158 sdram_timing_struct.tmrd = XMC_DELAY_CYCLE_2;
159 sdram_timing_struct.txsr = XMC_DELAY_CYCLE_11;
160 sdram_timing_struct.tras = XMC_DELAY_CYCLE_7;
161 sdram_timing_struct.trc = XMC_DELAY_CYCLE_9;
162 sdram_timing_struct.twr = XMC_DELAY_CYCLE_2;
163 sdram_timing_struct.trp = XMC_DELAY_CYCLE_3;
164 sdram_timing_struct.trcd = XMC_DELAY_CYCLE_3;
165
166
167 xmc_sdram_init(&sdram_init_struct, &sdram_timing_struct);
168
169 sdram_init_sequence(XMC_CMD_BANK1);
170
171}
172
178void sdram_init_sequence(xmc_cmd_bank1_2_type cmd_bank)
179{
180 xmc_sdram_cmd_type sdram_cmd_struct;
181 uint32_t timeout = 0xFFFF;
182
183 sdram_cmd_struct.cmd = XMC_CMD_CLK;
184 sdram_cmd_struct.auto_refresh = 1;
185 sdram_cmd_struct.cmd_banks = cmd_bank;
186 sdram_cmd_struct.data = 0;
187 xmc_sdram_cmd(&sdram_cmd_struct);
188
189 while((xmc_flag_status_get(XMC_BANK5_6_SDRAM, XMC_BUSY_FLAG) != RESET) && (timeout > 0))
190 {
191 timeout --;
192 }
193 delay_ms(100);
194
195 sdram_cmd_struct.cmd = XMC_CMD_PRECHARG_ALL;
196 sdram_cmd_struct.auto_refresh = 1;
197 sdram_cmd_struct.cmd_banks = cmd_bank;
198 sdram_cmd_struct.data = 0;
199 xmc_sdram_cmd(&sdram_cmd_struct);
200
201 timeout = 0xFFFF;
202 while((xmc_flag_status_get(XMC_BANK5_6_SDRAM, XMC_BUSY_FLAG) != RESET) && (timeout > 0))
203 {
204 timeout --;
205 }
206
207 /* counter = (refresh_count * 1000 * SDCLK) / row - 20 */
208 /* counter = (64ms * 1000 * 144MHz) / 2^13 - 20 */
209 xmc_sdram_refresh_counter_set(1105);
210
211 sdram_cmd_struct.cmd = XMC_CMD_AUTO_REFRESH;
212 sdram_cmd_struct.auto_refresh = 8;
213 sdram_cmd_struct.cmd_banks = cmd_bank;
214 sdram_cmd_struct.data = 0;
215 xmc_sdram_cmd(&sdram_cmd_struct);
216
217 timeout = 0xFFFF;
218 while((xmc_flag_status_get(XMC_BANK5_6_SDRAM, XMC_BUSY_FLAG) != RESET) && (timeout > 0))
219 {
220 timeout --;
221 }
222
223 sdram_cmd_struct.cmd = XMC_CMD_LOAD_MODE;
224 sdram_cmd_struct.auto_refresh = 1;
225 sdram_cmd_struct.cmd_banks = cmd_bank;
226 sdram_cmd_struct.data = (uint32_t)SDRAM_BURST_LEN_1 | SDRAM_BURST_SEQUENTIAL |
227 SDRAM_CAS_LATENCY_3 | SDRAM_OPERATING_MODE_STANDARD |
228 SDRAM_WR_BURST_SINGLE;
229 xmc_sdram_cmd(&sdram_cmd_struct);
230
231 timeout = 0xFFFF;
232 while((xmc_flag_status_get(XMC_BANK5_6_SDRAM, XMC_BUSY_FLAG) != RESET) && (timeout > 0))
233 {
234 timeout --;
235 }
236
237}
238
239
248void sdram_writebuffer(uint16_t* pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
249{
250 for(; numhalfwordtowrite != 0; numhalfwordtowrite--)
251 {
253 *(__IO uint16_t *) (SDRAM_BANK1_ADDR + writeaddr) = *pbuffer++;
254
256 writeaddr += 2;
257 }
258}
259
268void sdram_readbuffer(uint16_t* pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
269{
270 for(; numhalfwordtoread != 0; numhalfwordtoread--)
271 {
273 *pbuffer++ = *(__IO uint16_t*) (SDRAM_BANK1_ADDR + readaddr);
274
276 readaddr += 2;
277 }
278}
279
286void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
287{
288 uint16_t indextmp = 0;
289
290 /* put in global buffer same values */
291 for (indextmp = 0; indextmp < bufferlenght; indextmp++ )
292 {
293 pbuffer[indextmp] = indextmp + offset;
294 }
295}
296
at32f435_437_board.h
SDRAM_CAS_LATENCY_3
#define SDRAM_CAS_LATENCY_3
Definition: at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h:40
SDRAM_BURST_LEN_1
#define SDRAM_BURST_LEN_1
Definition: at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h:32
SDRAM_BURST_SEQUENTIAL
#define SDRAM_BURST_SEQUENTIAL
Definition: at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h:36
SDRAM_WR_BURST_SINGLE
#define SDRAM_WR_BURST_SINGLE
Definition: at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h:43
SDRAM_OPERATING_MODE_STANDARD
#define SDRAM_OPERATING_MODE_STANDARD
Definition: at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h:41
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
sdram_writebuffer
void sdram_writebuffer(uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the sdram memory.
Definition: at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c:248
sdram_init_sequence
void sdram_init_sequence(xmc_cmd_bank1_2_type cmd_bank)
init sdram sequence
Definition: at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c:178
sdram_init
void sdram_init(void)
init sdram interface
Definition: at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c:46
sdram_readbuffer
void sdram_readbuffer(uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the sdram.
Definition: at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c:268
fill_buffer
void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer
Definition: at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c:286
SDRAM_BANK1_ADDR
#define SDRAM_BANK1_ADDR
Definition: at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c:38
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_XMC_PERIPH_CLOCK
@ CRM_XMC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:123
CRM_GPIOF_PERIPH_CLOCK
@ CRM_GPIOF_PERIPH_CLOCK
Definition: at32f435_437_crm.h:110
CRM_GPIOG_PERIPH_CLOCK
@ CRM_GPIOG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:111
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f435_437_gpio.h:146
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f435_437_gpio.h:64
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOG
#define GPIOG
Definition: at32f435_437_gpio.h:527
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOF
#define GPIOF
Definition: at32f435_437_gpio.h:526
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
xmc_sdram_cmd
void xmc_sdram_cmd(xmc_sdram_cmd_type *xmc_sdram_cmd_struct)
sdram command confg
Definition: at32f435_437_xmc.c:561
xmc_sdram_refresh_counter_set
void xmc_sdram_refresh_counter_set(uint32_t counter)
set sdram refresh counter
Definition: at32f435_437_xmc.c:595
xmc_sdram_init
void xmc_sdram_init(xmc_sdram_init_type *xmc_sdram_init_struct, xmc_sdram_timing_type *xmc_sdram_timing_struct)
initialize the xmc sdram banks according to the specified parameters in the xmc_sdram_init_struct and...
Definition: at32f435_437_xmc.c:475
xmc_sdram_default_para_init
void xmc_sdram_default_para_init(xmc_sdram_init_type *xmc_sdram_init_struct, xmc_sdram_timing_type *xmc_sdram_timing_struct)
fill each xmc_sdram_init_struct member with its default value.
Definition: at32f435_437_xmc.c:532
xmc_flag_status_get
flag_status xmc_flag_status_get(xmc_class_bank_type xmc_bank, xmc_interrupt_flag_type xmc_flag)
check whether the specified xmc flag is set or not.
Definition: at32f435_437_xmc.c:695
xmc_cmd_bank1_2_type
xmc_cmd_bank1_2_type
xmc sdram command bank select type
Definition: at32f435_437_xmc.h:370
XMC_CMD_LOAD_MODE
@ XMC_CMD_LOAD_MODE
Definition: at32f435_437_xmc.h:361
XMC_CMD_CLK
@ XMC_CMD_CLK
Definition: at32f435_437_xmc.h:358
XMC_CMD_AUTO_REFRESH
@ XMC_CMD_AUTO_REFRESH
Definition: at32f435_437_xmc.h:360
XMC_CMD_PRECHARG_ALL
@ XMC_CMD_PRECHARG_ALL
Definition: at32f435_437_xmc.h:359
XMC_DELAY_CYCLE_9
@ XMC_DELAY_CYCLE_9
Definition: at32f435_437_xmc.h:341
XMC_DELAY_CYCLE_11
@ XMC_DELAY_CYCLE_11
Definition: at32f435_437_xmc.h:343
XMC_DELAY_CYCLE_7
@ XMC_DELAY_CYCLE_7
Definition: at32f435_437_xmc.h:339
XMC_DELAY_CYCLE_3
@ XMC_DELAY_CYCLE_3
Definition: at32f435_437_xmc.h:335
XMC_DELAY_CYCLE_2
@ XMC_DELAY_CYCLE_2
Definition: at32f435_437_xmc.h:334
XMC_BANK5_6_SDRAM
@ XMC_BANK5_6_SDRAM
Definition: at32f435_437_xmc.h:160
XMC_CLKDIV_3
@ XMC_CLKDIV_3
Definition: at32f435_437_xmc.h:304
XMC_SDRAM_BANK1
@ XMC_SDRAM_BANK1
Definition: at32f435_437_xmc.h:323
XMC_BUSY_FLAG
@ XMC_BUSY_FLAG
Definition: at32f435_437_xmc.h:245
XMC_ROW_13
@ XMC_ROW_13
Definition: at32f435_437_xmc.h:266
XMC_READ_DELAY_1
@ XMC_READ_DELAY_1
Definition: at32f435_437_xmc.h:314
XMC_INBK_4
@ XMC_INBK_4
Definition: at32f435_437_xmc.h:284
XMC_CAS_3
@ XMC_CAS_3
Definition: at32f435_437_xmc.h:294
XMC_CMD_BANK1
@ XMC_CMD_BANK1
Definition: at32f435_437_xmc.h:371
XMC_MEM_WIDTH_16
@ XMC_MEM_WIDTH_16
Definition: at32f435_437_xmc.h:275
XMC_COLUMN_9
@ XMC_COLUMN_9
Definition: at32f435_437_xmc.h:254
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
xmc_sdram_cmd_type
xmc sdram command structure definition
Definition: at32f435_437_xmc.h:502
xmc_sdram_cmd_type::cmd_banks
xmc_cmd_bank1_2_type cmd_banks
Definition: at32f435_437_xmc.h:504
xmc_sdram_cmd_type::auto_refresh
uint32_t auto_refresh
Definition: at32f435_437_xmc.h:505
xmc_sdram_cmd_type::data
uint32_t data
Definition: at32f435_437_xmc.h:506
xmc_sdram_cmd_type::cmd
xmc_command_type cmd
Definition: at32f435_437_xmc.h:503
xmc_sdram_init_type
xmc sdram init structure definition
Definition: at32f435_437_xmc.h:469
xmc_sdram_init_type::row_address
xmc_sdram_row_type row_address
Definition: at32f435_437_xmc.h:477
xmc_sdram_init_type::burst_read
uint8_t burst_read
Definition: at32f435_437_xmc.h:474
xmc_sdram_init_type::clkdiv
xmc_sdram_clkdiv_type clkdiv
Definition: at32f435_437_xmc.h:472
xmc_sdram_init_type::write_protection
uint8_t write_protection
Definition: at32f435_437_xmc.h:473
xmc_sdram_init_type::column_address
xmc_sdram_column_type column_address
Definition: at32f435_437_xmc.h:476
xmc_sdram_init_type::read_delay
uint8_t read_delay
Definition: at32f435_437_xmc.h:475
xmc_sdram_init_type::width
xmc_sdram_width_type width
Definition: at32f435_437_xmc.h:479
xmc_sdram_init_type::cas
xmc_sdram_cas_type cas
Definition: at32f435_437_xmc.h:478
xmc_sdram_init_type::sdram_bank
xmc_sdram_bank_type sdram_bank
Definition: at32f435_437_xmc.h:470
xmc_sdram_init_type::internel_banks
xmc_sdram_inbk_type internel_banks
Definition: at32f435_437_xmc.h:471
xmc_sdram_timing_type
xmc sdram timing structure definition
Definition: at32f435_437_xmc.h:487
xmc_sdram_timing_type::trcd
xmc_sdram_delay_type trcd
Definition: at32f435_437_xmc.h:494
xmc_sdram_timing_type::trc
xmc_sdram_delay_type trc
Definition: at32f435_437_xmc.h:491
xmc_sdram_timing_type::tmrd
xmc_sdram_delay_type tmrd
Definition: at32f435_437_xmc.h:488
xmc_sdram_timing_type::twr
xmc_sdram_delay_type twr
Definition: at32f435_437_xmc.h:492
xmc_sdram_timing_type::tras
xmc_sdram_delay_type tras
Definition: at32f435_437_xmc.h:490
xmc_sdram_timing_type::txsr
xmc_sdram_delay_type txsr
Definition: at32f435_437_xmc.h:489
xmc_sdram_timing_type::trp
xmc_sdram_delay_type trp
Definition: at32f435_437_xmc.h:493


AT32F435/437 Firmwary Library: xmc_sdram.h File Reference

  • at_start_f435
  • examples
  • xmc
  • sdram_dma
  • inc
Macros | Functions
at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h File Reference

header file for the sdram configuration. More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | SDRAM_BURST_LEN_1 ((uint16_t)0x0000)
#define | SDRAM_BURST_LEN_2 ((uint16_t)0x0001)
#define | SDRAM_BURST_LEN_4 ((uint16_t)0x0002)
#define | SDRAM_BURST_LEN_8 ((uint16_t)0x0004)
#define | SDRAM_BURST_SEQUENTIAL ((uint16_t)0x0000)
#define | SDRAM_BURST_INTERLEAVED ((uint16_t)0x0008)
#define | SDRAM_CAS_LATENCY_1 ((uint16_t)0x0010)
#define | SDRAM_CAS_LATENCY_2 ((uint16_t)0x0020)
#define | SDRAM_CAS_LATENCY_3 ((uint16_t)0x0030)
#define | SDRAM_OPERATING_MODE_STANDARD ((uint16_t)0x0000)
#define | SDRAM_WR_BURST_PROGRAMMED ((uint16_t)0x0000)
#define | SDRAM_WR_BURST_SINGLE ((uint16_t)0x0200)

Functions

void | sdram_init (void)
init sdram interface More...
void | sdram_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the sdram memory. More...
void | sdram_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the sdram. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...
void | sdram_copy_to_sram_dma (uint16_t *buffer, uint32_t length)
copy sdram data to sram More...
void | sram_copy_to_sdram_dma (uint16_t *buffer, uint32_t length)
copy sram data copy to sdram More...

Detailed Description

header file for the sdram configuration.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h.

Macro Definition Documentation

◆ SDRAM_BURST_INTERLEAVED

#define SDRAM_BURST_INTERLEAVED ((uint16_t)0x0008)

Definition at line 37 of file at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h.

◆ SDRAM_BURST_LEN_1

#define SDRAM_BURST_LEN_1 ((uint16_t)0x0000)

Definition at line 32 of file at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h.

◆ SDRAM_BURST_LEN_2

#define SDRAM_BURST_LEN_2 ((uint16_t)0x0001)

Definition at line 33 of file at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h.

◆ SDRAM_BURST_LEN_4

#define SDRAM_BURST_LEN_4 ((uint16_t)0x0002)

Definition at line 34 of file at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h.

◆ SDRAM_BURST_LEN_8

#define SDRAM_BURST_LEN_8 ((uint16_t)0x0004)

Definition at line 35 of file at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h.

◆ SDRAM_BURST_SEQUENTIAL

#define SDRAM_BURST_SEQUENTIAL ((uint16_t)0x0000)

Definition at line 36 of file at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h.

◆ SDRAM_CAS_LATENCY_1

#define SDRAM_CAS_LATENCY_1 ((uint16_t)0x0010)

Definition at line 38 of file at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h.

◆ SDRAM_CAS_LATENCY_2

#define SDRAM_CAS_LATENCY_2 ((uint16_t)0x0020)

Definition at line 39 of file at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h.

◆ SDRAM_CAS_LATENCY_3

#define SDRAM_CAS_LATENCY_3 ((uint16_t)0x0030)

Definition at line 40 of file at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h.

◆ SDRAM_OPERATING_MODE_STANDARD

#define SDRAM_OPERATING_MODE_STANDARD ((uint16_t)0x0000)

Definition at line 41 of file at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h.

◆ SDRAM_WR_BURST_PROGRAMMED

#define SDRAM_WR_BURST_PROGRAMMED ((uint16_t)0x0000)

Definition at line 42 of file at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h.

◆ SDRAM_WR_BURST_SINGLE

#define SDRAM_WR_BURST_SINGLE ((uint16_t)0x0200)

Definition at line 43 of file at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h.


AT32F435/437 Firmwary Library: xmc_sdram.h Source File

  • at_start_f435
  • examples
  • xmc
  • sdram_dma
  • inc
at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h
Go to the documentation of this file.
1
27#ifndef __XMC_SDRAM_H
28#define __XMC_SDRAM_H
29
30#include "at32f435_437_board.h"
31
32#define SDRAM_BURST_LEN_1 ((uint16_t)0x0000)
33#define SDRAM_BURST_LEN_2 ((uint16_t)0x0001)
34#define SDRAM_BURST_LEN_4 ((uint16_t)0x0002)
35#define SDRAM_BURST_LEN_8 ((uint16_t)0x0004)
36#define SDRAM_BURST_SEQUENTIAL ((uint16_t)0x0000)
37#define SDRAM_BURST_INTERLEAVED ((uint16_t)0x0008)
38#define SDRAM_CAS_LATENCY_1 ((uint16_t)0x0010)
39#define SDRAM_CAS_LATENCY_2 ((uint16_t)0x0020)
40#define SDRAM_CAS_LATENCY_3 ((uint16_t)0x0030)
41#define SDRAM_OPERATING_MODE_STANDARD ((uint16_t)0x0000)
42#define SDRAM_WR_BURST_PROGRAMMED ((uint16_t)0x0000)
43#define SDRAM_WR_BURST_SINGLE ((uint16_t)0x0200)
44
45void sdram_init(void);
46void sdram_writebuffer(uint16_t* pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite);
47void sdram_readbuffer(uint16_t* pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread);
48void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset);
49void sdram_copy_to_sram_dma(uint16_t *buffer, uint32_t length);
50void sram_copy_to_sdram_dma(uint16_t *buffer, uint32_t length);
51
52#endif
at32f435_437_board.h
buffer
uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:43
fill_buffer
void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:520
sdram_writebuffer
void sdram_writebuffer(uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the sdram memory.
Definition: at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c:248
sdram_init
void sdram_init(void)
init sdram interface
Definition: at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c:46
sdram_readbuffer
void sdram_readbuffer(uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the sdram.
Definition: at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c:268
sram_copy_to_sdram_dma
void sram_copy_to_sdram_dma(uint16_t *buffer, uint32_t length)
copy sram data copy to sdram
Definition: at_start_f437/examples/xmc/sdram_dma/src/xmc_sdram.c:336
sdram_copy_to_sram_dma
void sdram_copy_to_sram_dma(uint16_t *buffer, uint32_t length)
copy sdram data to sram
Definition: at_start_f437/examples/xmc/sdram_dma/src/xmc_sdram.c:305


AT32F435/437 Firmwary Library: xmc_sdram.c File Reference

  • at_start_f435
  • examples
  • xmc
  • sdram_dma
  • src
Macros | Functions | Variables
at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c File Reference

sdram program. More...

#include "xmc_sdram.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define SDRAM_BANK1_ADDR ((uint32_t)0xC0000000)

Functions

void | sdram_init_sequence (xmc_cmd_bank1_2_type cmd_bank)
init sdram sequence More...
void | sdram_init (void)
init sdram interface More...
void | sdram_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the sdram memory. More...
void | sdram_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the sdram. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...
void | sdram_copy_to_sram_dma (uint16_t *buffer, uint32_t length)
copy sdram data to sram More...
void | sram_copy_to_sdram_dma (uint16_t *buffer, uint32_t length)
copy sram data copy to sdram More...

Variables

dma_init_type dma_init_struct

Detailed Description

sdram program.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c.


AT32F435/437 Firmwary Library: xmc_sdram.c Source File

  • at_start_f435
  • examples
  • xmc
  • sdram_dma
  • src
at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c
Go to the documentation of this file.
1
27#include "xmc_sdram.h"
28#include "at32f435_437_board.h"
29
38#define SDRAM_BANK1_ADDR ((uint32_t)0xC0000000)
39
40 dma_init_type dma_init_struct;
41void sdram_init_sequence(xmc_cmd_bank1_2_type cmd_bank);
42
48void sdram_init(void)
49{
50 gpio_init_type gpio_init_struct = {0};
51
52 xmc_sdram_init_type sdram_init_struct;
53 xmc_sdram_timing_type sdram_timing_struct;
54
55
56 /* enable the gpio clock */
57 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
58 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
59 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
60 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
61 crm_periph_clock_enable(CRM_GPIOF_PERIPH_CLOCK, TRUE);
62 crm_periph_clock_enable(CRM_GPIOG_PERIPH_CLOCK, TRUE);
63
64 /* enable the xmc clock */
65 crm_periph_clock_enable(CRM_XMC_PERIPH_CLOCK, TRUE);
66
67 /*-- gpio configuration ------------------------------------------------------*/
68
69 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE5, GPIO_MUX_12);
70 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE6, GPIO_MUX_12);
71
72 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE0, GPIO_MUX_12);
73 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE2, GPIO_MUX_12);
74 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE3, GPIO_MUX_12);
75
76 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE0, GPIO_MUX_12);
77 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_12);
78 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE8, GPIO_MUX_12);
79 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE9, GPIO_MUX_12);
80 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE10, GPIO_MUX_12);
81 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE14, GPIO_MUX_12);
82 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE15, GPIO_MUX_12);
83
84 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE0, GPIO_MUX_12);
85 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE1, GPIO_MUX_12);
86 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE7, GPIO_MUX_12);
87 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE8, GPIO_MUX_12);
88 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE9, GPIO_MUX_12);
89 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE10, GPIO_MUX_12);
90 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE11, GPIO_MUX_12);
91 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE12, GPIO_MUX_12);
92 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE13, GPIO_MUX_12);
93 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE14, GPIO_MUX_12);
94 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE15, GPIO_MUX_12);
95
96 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE0, GPIO_MUX_12);
97 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE1, GPIO_MUX_12);
98 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE2, GPIO_MUX_12);
99 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE3, GPIO_MUX_12);
100 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE4, GPIO_MUX_12);
101 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE5, GPIO_MUX_12);
102 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE11, GPIO_MUX_12);
103 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE12, GPIO_MUX_12);
104 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE13, GPIO_MUX_12);
105 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE14, GPIO_MUX_12);
106 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE15, GPIO_MUX_12);
107
108 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE0, GPIO_MUX_12);
109 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE1, GPIO_MUX_12);
110 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE2, GPIO_MUX_12);
111 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE4, GPIO_MUX_12);
112 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE5, GPIO_MUX_12);
113 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE8, GPIO_MUX_12);
114 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE15, GPIO_MUX_12);
115
116 /* address lines configuration */
117 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
118 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
119 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
120 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
121
122 gpio_init_struct.gpio_pins = GPIO_PINS_5 | GPIO_PINS_6;
123 gpio_init(GPIOB, &gpio_init_struct);
124
125 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_2 | GPIO_PINS_3;
126 gpio_init(GPIOC, &gpio_init_struct);
127
128 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_14 | GPIO_PINS_15;
129 gpio_init(GPIOD, &gpio_init_struct);
130
131 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_10 |
132 GPIO_PINS_9 | GPIO_PINS_11 | GPIO_PINS_11 | GPIO_PINS_12 |
133 GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
134 gpio_init(GPIOE, &gpio_init_struct);
135
136 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_2 | GPIO_PINS_3 |
137 GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_11 | GPIO_PINS_12 |
138 GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
139 gpio_init(GPIOF, &gpio_init_struct);
140
141 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_2 | GPIO_PINS_4 |
142 GPIO_PINS_5 | GPIO_PINS_8 | GPIO_PINS_15;
143 gpio_init(GPIOG, &gpio_init_struct);
144
145
146 /*-- xmc configuration ------------------------------------------------------*/
147 xmc_sdram_default_para_init(&sdram_init_struct, &sdram_timing_struct);
148
149 sdram_init_struct.sdram_bank = XMC_SDRAM_BANK1;
150 sdram_init_struct.internel_banks = XMC_INBK_4;
151 sdram_init_struct.clkdiv = XMC_CLKDIV_3;
152 sdram_init_struct.write_protection = FALSE;
153 sdram_init_struct.burst_read = FALSE;
154 sdram_init_struct.read_delay = XMC_READ_DELAY_1;
155 sdram_init_struct.column_address = XMC_COLUMN_9;
156 sdram_init_struct.row_address = XMC_ROW_13;
157 sdram_init_struct.cas = XMC_CAS_3;
158 sdram_init_struct.width = XMC_MEM_WIDTH_16;
159
160 sdram_timing_struct.tmrd = XMC_DELAY_CYCLE_2;
161 sdram_timing_struct.txsr = XMC_DELAY_CYCLE_11;
162 sdram_timing_struct.tras = XMC_DELAY_CYCLE_7;
163 sdram_timing_struct.trc = XMC_DELAY_CYCLE_9;
164 sdram_timing_struct.twr = XMC_DELAY_CYCLE_2;
165 sdram_timing_struct.trp = XMC_DELAY_CYCLE_3;
166 sdram_timing_struct.trcd = XMC_DELAY_CYCLE_3;
167
168 xmc_sdram_init(&sdram_init_struct, &sdram_timing_struct);
169
170 sdram_init_sequence(XMC_CMD_BANK1);
171
172}
173
179void sdram_init_sequence(xmc_cmd_bank1_2_type cmd_bank)
180{
181 xmc_sdram_cmd_type sdram_cmd_struct;
182 uint32_t timeout = 0xFFFF;
183
184 sdram_cmd_struct.cmd = XMC_CMD_CLK;
185 sdram_cmd_struct.auto_refresh = 1;
186 sdram_cmd_struct.cmd_banks = cmd_bank;
187 sdram_cmd_struct.data = 0;
188 xmc_sdram_cmd(&sdram_cmd_struct);
189
190 while((xmc_flag_status_get(XMC_BANK5_6_SDRAM, XMC_BUSY_FLAG) != RESET) && (timeout > 0))
191 {
192 timeout --;
193 }
194 delay_ms(100);
195
196 sdram_cmd_struct.cmd = XMC_CMD_PRECHARG_ALL;
197 sdram_cmd_struct.auto_refresh = 1;
198 sdram_cmd_struct.cmd_banks = cmd_bank;
199 sdram_cmd_struct.data = 0;
200 xmc_sdram_cmd(&sdram_cmd_struct);
201
202 timeout = 0xFFFF;
203 while((xmc_flag_status_get(XMC_BANK5_6_SDRAM, XMC_BUSY_FLAG) != RESET) && (timeout > 0))
204 {
205 timeout --;
206 }
207
208 /* counter = (refresh_count * 1000 * SDCLK) / row - 20 */
209 /* counter = (64ms * 1000 * 144MHz ) / 2^13 - 20 */
210 xmc_sdram_refresh_counter_set(1105);
211
212 sdram_cmd_struct.cmd = XMC_CMD_AUTO_REFRESH;
213 sdram_cmd_struct.auto_refresh = 8;
214 sdram_cmd_struct.cmd_banks = cmd_bank;
215 sdram_cmd_struct.data = 0;
216 xmc_sdram_cmd(&sdram_cmd_struct);
217
218 timeout = 0xFFFF;
219 while((xmc_flag_status_get(XMC_BANK5_6_SDRAM, XMC_BUSY_FLAG) != RESET) && (timeout > 0))
220 {
221 timeout --;
222 }
223
224 sdram_cmd_struct.cmd = XMC_CMD_LOAD_MODE;
225 sdram_cmd_struct.auto_refresh = 1;
226 sdram_cmd_struct.cmd_banks = cmd_bank;
227 sdram_cmd_struct.data = (uint32_t)SDRAM_BURST_LEN_1 | SDRAM_BURST_SEQUENTIAL |
228 SDRAM_CAS_LATENCY_3 | SDRAM_OPERATING_MODE_STANDARD |
229 SDRAM_WR_BURST_SINGLE;
230 xmc_sdram_cmd(&sdram_cmd_struct);
231
232 timeout = 0xFFFF;
233 while((xmc_flag_status_get(XMC_BANK5_6_SDRAM, XMC_BUSY_FLAG) != RESET) && (timeout > 0))
234 {
235 timeout --;
236 }
237
238}
239
240
249void sdram_writebuffer(uint16_t* pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
250{
251 for(; numhalfwordtowrite != 0; numhalfwordtowrite--)
252 {
254 *(__IO uint16_t *) (SDRAM_BANK1_ADDR + writeaddr) = *pbuffer++;
255
257 writeaddr += 2;
258 }
259}
260
269void sdram_readbuffer(uint16_t* pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
270{
271 for(; numhalfwordtoread != 0; numhalfwordtoread--)
272 {
274 *pbuffer++ = *(__IO uint16_t*) (SDRAM_BANK1_ADDR + readaddr);
275
277 readaddr += 2;
278 }
279}
280
288void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
289{
290 uint16_t indextmp = 0;
291
292 /* put in global buffer same values */
293 for (indextmp = 0; indextmp < bufferlenght; indextmp++ )
294 {
295 pbuffer[indextmp] = indextmp + offset;
296 }
297}
298
305void sdram_copy_to_sram_dma(uint16_t *buffer, uint32_t length)
306{
307 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
308 /* dma1 channel1 configuration */
309 dma_reset(DMA1_CHANNEL1);
310 dma_init_struct.buffer_size = length;
311 dma_init_struct.direction = DMA_DIR_MEMORY_TO_MEMORY;
312 dma_init_struct.memory_base_addr = (uint32_t)buffer;
313 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
314 dma_init_struct.memory_inc_enable = TRUE;
315 dma_init_struct.peripheral_base_addr = (uint32_t)SDRAM_BANK1_ADDR;
316 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
317 dma_init_struct.peripheral_inc_enable = TRUE;
318 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
319 dma_init_struct.loop_mode_enable = FALSE;
320 dma_init(DMA1_CHANNEL1, &dma_init_struct);
321 dma_channel_enable(DMA1_CHANNEL1, TRUE);
322
323 while(dma_flag_get(DMA1_FDT1_FLAG) == RESET)
324 {
325 }
326 dma_channel_enable(DMA1_CHANNEL1, FALSE);
327
328}
329
336void sram_copy_to_sdram_dma(uint16_t *buffer, uint32_t length)
337{
338 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
339 /* dma1 channel1 configuration */
340 dma_reset(DMA1_CHANNEL1);
341 dma_init_struct.buffer_size = length;
342 dma_init_struct.direction = DMA_DIR_MEMORY_TO_MEMORY;
343 dma_init_struct.memory_base_addr = (uint32_t)SDRAM_BANK1_ADDR;
344 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
345 dma_init_struct.memory_inc_enable = TRUE;
346 dma_init_struct.peripheral_base_addr = (uint32_t)buffer;
347 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
348 dma_init_struct.peripheral_inc_enable = TRUE;
349 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
350 dma_init_struct.loop_mode_enable = FALSE;
351 dma_init(DMA1_CHANNEL1, &dma_init_struct);
352 dma_channel_enable(DMA1_CHANNEL1, TRUE);
353
354 while(dma_flag_get(DMA1_FDT1_FLAG) == RESET)
355 {
356 }
357 dma_channel_enable(DMA1_CHANNEL1, FALSE);
358}
359
at32f435_437_board.h
SDRAM_CAS_LATENCY_3
#define SDRAM_CAS_LATENCY_3
Definition: at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h:40
SDRAM_BURST_LEN_1
#define SDRAM_BURST_LEN_1
Definition: at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h:32
SDRAM_BURST_SEQUENTIAL
#define SDRAM_BURST_SEQUENTIAL
Definition: at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h:36
SDRAM_WR_BURST_SINGLE
#define SDRAM_WR_BURST_SINGLE
Definition: at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h:43
SDRAM_OPERATING_MODE_STANDARD
#define SDRAM_OPERATING_MODE_STANDARD
Definition: at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h:41
buffer
uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:43
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c:40
sdram_writebuffer
void sdram_writebuffer(uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the sdram memory.
Definition: at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c:249
sram_copy_to_sdram_dma
void sram_copy_to_sdram_dma(uint16_t *buffer, uint32_t length)
copy sram data copy to sdram
Definition: at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c:336
sdram_init_sequence
void sdram_init_sequence(xmc_cmd_bank1_2_type cmd_bank)
init sdram sequence
Definition: at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c:179
sdram_init
void sdram_init(void)
init sdram interface
Definition: at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c:48
sdram_copy_to_sram_dma
void sdram_copy_to_sram_dma(uint16_t *buffer, uint32_t length)
copy sdram data to sram
Definition: at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c:305
sdram_readbuffer
void sdram_readbuffer(uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the sdram.
Definition: at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c:269
fill_buffer
void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer
Definition: at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c:288
SDRAM_BANK1_ADDR
#define SDRAM_BANK1_ADDR
Definition: at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c:38
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_XMC_PERIPH_CLOCK
@ CRM_XMC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:123
CRM_GPIOF_PERIPH_CLOCK
@ CRM_GPIOF_PERIPH_CLOCK
Definition: at32f435_437_crm.h:110
CRM_GPIOG_PERIPH_CLOCK
@ CRM_GPIOG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:111
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_DIR_MEMORY_TO_MEMORY
@ DMA_DIR_MEMORY_TO_MEMORY
Definition: at32f435_437_dma.h:154
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f435_437_dma.h:183
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f435_437_dma.h:66
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f435_437_gpio.h:146
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f435_437_gpio.h:64
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOG
#define GPIOG
Definition: at32f435_437_gpio.h:527
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOF
#define GPIOF
Definition: at32f435_437_gpio.h:526
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
xmc_sdram_cmd
void xmc_sdram_cmd(xmc_sdram_cmd_type *xmc_sdram_cmd_struct)
sdram command confg
Definition: at32f435_437_xmc.c:561
xmc_sdram_refresh_counter_set
void xmc_sdram_refresh_counter_set(uint32_t counter)
set sdram refresh counter
Definition: at32f435_437_xmc.c:595
xmc_sdram_init
void xmc_sdram_init(xmc_sdram_init_type *xmc_sdram_init_struct, xmc_sdram_timing_type *xmc_sdram_timing_struct)
initialize the xmc sdram banks according to the specified parameters in the xmc_sdram_init_struct and...
Definition: at32f435_437_xmc.c:475
xmc_sdram_default_para_init
void xmc_sdram_default_para_init(xmc_sdram_init_type *xmc_sdram_init_struct, xmc_sdram_timing_type *xmc_sdram_timing_struct)
fill each xmc_sdram_init_struct member with its default value.
Definition: at32f435_437_xmc.c:532
xmc_flag_status_get
flag_status xmc_flag_status_get(xmc_class_bank_type xmc_bank, xmc_interrupt_flag_type xmc_flag)
check whether the specified xmc flag is set or not.
Definition: at32f435_437_xmc.c:695
xmc_cmd_bank1_2_type
xmc_cmd_bank1_2_type
xmc sdram command bank select type
Definition: at32f435_437_xmc.h:370
XMC_CMD_LOAD_MODE
@ XMC_CMD_LOAD_MODE
Definition: at32f435_437_xmc.h:361
XMC_CMD_CLK
@ XMC_CMD_CLK
Definition: at32f435_437_xmc.h:358
XMC_CMD_AUTO_REFRESH
@ XMC_CMD_AUTO_REFRESH
Definition: at32f435_437_xmc.h:360
XMC_CMD_PRECHARG_ALL
@ XMC_CMD_PRECHARG_ALL
Definition: at32f435_437_xmc.h:359
XMC_DELAY_CYCLE_9
@ XMC_DELAY_CYCLE_9
Definition: at32f435_437_xmc.h:341
XMC_DELAY_CYCLE_11
@ XMC_DELAY_CYCLE_11
Definition: at32f435_437_xmc.h:343
XMC_DELAY_CYCLE_7
@ XMC_DELAY_CYCLE_7
Definition: at32f435_437_xmc.h:339
XMC_DELAY_CYCLE_3
@ XMC_DELAY_CYCLE_3
Definition: at32f435_437_xmc.h:335
XMC_DELAY_CYCLE_2
@ XMC_DELAY_CYCLE_2
Definition: at32f435_437_xmc.h:334
XMC_BANK5_6_SDRAM
@ XMC_BANK5_6_SDRAM
Definition: at32f435_437_xmc.h:160
XMC_CLKDIV_3
@ XMC_CLKDIV_3
Definition: at32f435_437_xmc.h:304
XMC_SDRAM_BANK1
@ XMC_SDRAM_BANK1
Definition: at32f435_437_xmc.h:323
XMC_BUSY_FLAG
@ XMC_BUSY_FLAG
Definition: at32f435_437_xmc.h:245
XMC_ROW_13
@ XMC_ROW_13
Definition: at32f435_437_xmc.h:266
XMC_READ_DELAY_1
@ XMC_READ_DELAY_1
Definition: at32f435_437_xmc.h:314
XMC_INBK_4
@ XMC_INBK_4
Definition: at32f435_437_xmc.h:284
XMC_CAS_3
@ XMC_CAS_3
Definition: at32f435_437_xmc.h:294
XMC_CMD_BANK1
@ XMC_CMD_BANK1
Definition: at32f435_437_xmc.h:371
XMC_MEM_WIDTH_16
@ XMC_MEM_WIDTH_16
Definition: at32f435_437_xmc.h:275
XMC_COLUMN_9
@ XMC_COLUMN_9
Definition: at32f435_437_xmc.h:254
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
xmc_sdram_cmd_type
xmc sdram command structure definition
Definition: at32f435_437_xmc.h:502
xmc_sdram_cmd_type::cmd_banks
xmc_cmd_bank1_2_type cmd_banks
Definition: at32f435_437_xmc.h:504
xmc_sdram_cmd_type::auto_refresh
uint32_t auto_refresh
Definition: at32f435_437_xmc.h:505
xmc_sdram_cmd_type::data
uint32_t data
Definition: at32f435_437_xmc.h:506
xmc_sdram_cmd_type::cmd
xmc_command_type cmd
Definition: at32f435_437_xmc.h:503
xmc_sdram_init_type
xmc sdram init structure definition
Definition: at32f435_437_xmc.h:469
xmc_sdram_init_type::row_address
xmc_sdram_row_type row_address
Definition: at32f435_437_xmc.h:477
xmc_sdram_init_type::burst_read
uint8_t burst_read
Definition: at32f435_437_xmc.h:474
xmc_sdram_init_type::clkdiv
xmc_sdram_clkdiv_type clkdiv
Definition: at32f435_437_xmc.h:472
xmc_sdram_init_type::write_protection
uint8_t write_protection
Definition: at32f435_437_xmc.h:473
xmc_sdram_init_type::column_address
xmc_sdram_column_type column_address
Definition: at32f435_437_xmc.h:476
xmc_sdram_init_type::read_delay
uint8_t read_delay
Definition: at32f435_437_xmc.h:475
xmc_sdram_init_type::width
xmc_sdram_width_type width
Definition: at32f435_437_xmc.h:479
xmc_sdram_init_type::cas
xmc_sdram_cas_type cas
Definition: at32f435_437_xmc.h:478
xmc_sdram_init_type::sdram_bank
xmc_sdram_bank_type sdram_bank
Definition: at32f435_437_xmc.h:470
xmc_sdram_init_type::internel_banks
xmc_sdram_inbk_type internel_banks
Definition: at32f435_437_xmc.h:471
xmc_sdram_timing_type
xmc sdram timing structure definition
Definition: at32f435_437_xmc.h:487
xmc_sdram_timing_type::trcd
xmc_sdram_delay_type trcd
Definition: at32f435_437_xmc.h:494
xmc_sdram_timing_type::trc
xmc_sdram_delay_type trc
Definition: at32f435_437_xmc.h:491
xmc_sdram_timing_type::tmrd
xmc_sdram_delay_type tmrd
Definition: at32f435_437_xmc.h:488
xmc_sdram_timing_type::twr
xmc_sdram_delay_type twr
Definition: at32f435_437_xmc.h:492
xmc_sdram_timing_type::tras
xmc_sdram_delay_type tras
Definition: at32f435_437_xmc.h:490
xmc_sdram_timing_type::txsr
xmc_sdram_delay_type txsr
Definition: at32f435_437_xmc.h:489
xmc_sdram_timing_type::trp
xmc_sdram_delay_type trp
Definition: at32f435_437_xmc.h:493


AT32F435/437 Firmwary Library: xmc_sram.h File Reference

  • at_start_f435
  • examples
  • xmc
  • sram
  • inc
Functions
at_start_f435/examples/xmc/sram/inc/xmc_sram.h File Reference

header file for the nand configuration. More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void | sram_init (void)
init sram interface More...
void | sram_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc sram memory. More...
void | sram_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc sram memory. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...

Detailed Description

header file for the nand configuration.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/xmc/sram/inc/xmc_sram.h.


AT32F435/437 Firmwary Library: xmc_sram.h Source File

  • at_start_f435
  • examples
  • xmc
  • sram
  • inc
at_start_f435/examples/xmc/sram/inc/xmc_sram.h
Go to the documentation of this file.
1
27#ifndef __XMC_SRAM_H
28#define __XMC_SRAM_H
29
30#include "at32f435_437_board.h"
31
32
33
34void sram_init(void);
35void sram_writebuffer(uint16_t* pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite);
36void sram_readbuffer(uint16_t* pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread);
37void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset);
38
39#endif
at32f435_437_board.h
fill_buffer
void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:520
sram_init
void sram_init(void)
init sram interface
Definition: at_start_f437/examples/xmc/sram/src/xmc_sram.c:44
sram_readbuffer
void sram_readbuffer(uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc sram memory.
Definition: at_start_f437/examples/xmc/sram/src/xmc_sram.c:249
sram_writebuffer
void sram_writebuffer(uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc sram memory.
Definition: at_start_f437/examples/xmc/sram/src/xmc_sram.c:229


AT32F435/437 Firmwary Library: xmc_sram.c File Reference

  • at_start_f435
  • examples
  • xmc
  • sram
  • src
Macros | Functions
at_start_f435/examples/xmc/sram/src/xmc_sram.c File Reference

sram program. More...

#include "xmc_sram.h"

Go to the source code of this file.

Macros

#define BANK1_SRAM3_ADDR ((uint32_t)0x68000000)

Functions

void | sram_init (void)
init sram interface More...
void | sram_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc sram memory. More...
void | sram_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc sram memory. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...

Detailed Description

sram program.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f435/examples/xmc/sram/src/xmc_sram.c.


AT32F435/437 Firmwary Library: xmc_sram.c Source File

  • at_start_f435
  • examples
  • xmc
  • sram
  • src
at_start_f435/examples/xmc/sram/src/xmc_sram.c
Go to the documentation of this file.
1
27#include "xmc_sram.h"
28
37#define BANK1_SRAM3_ADDR ((uint32_t)0x68000000)
38
44void sram_init(void)
45{
46 gpio_init_type gpio_init_struct = {0};
47 xmc_norsram_init_type xmc_norsram_init_struct;
48 xmc_norsram_timing_init_type rw_timing_struct, w_timing_struct;
49
50 /* enable the gpio clock */
51 crm_periph_clock_enable(CRM_GPIOF_PERIPH_CLOCK, TRUE);
52 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
53 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
54 crm_periph_clock_enable(CRM_GPIOG_PERIPH_CLOCK, TRUE);
55
56 /* enable the xmc clock */
57 crm_periph_clock_enable(CRM_XMC_PERIPH_CLOCK, TRUE);
58
59 /*-- gpio configuration ------------------------------------------------------*/
60 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE0, GPIO_MUX_12);
61 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE1, GPIO_MUX_12);
62 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE2, GPIO_MUX_12);
63 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE3, GPIO_MUX_12);
64 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE4, GPIO_MUX_12);
65 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE5, GPIO_MUX_12);
66 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE12, GPIO_MUX_12);
67 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE13, GPIO_MUX_12);
68 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE14, GPIO_MUX_12);
69 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE15, GPIO_MUX_12);
70 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE0, GPIO_MUX_12);
71 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE1, GPIO_MUX_12);
72 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE2, GPIO_MUX_12);
73 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE3, GPIO_MUX_12);
74 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE4, GPIO_MUX_12);
75 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE5, GPIO_MUX_12);
76 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE13, GPIO_MUX_12);
77 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE14, GPIO_MUX_12);
78 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE10, GPIO_MUX_12);
79 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE11, GPIO_MUX_12);
80 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE12, GPIO_MUX_12);
81 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE13, GPIO_MUX_12);
82 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE0, GPIO_MUX_12);
83 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_12);
84 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE8, GPIO_MUX_12);
85 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE9, GPIO_MUX_12);
86 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE10, GPIO_MUX_12);
87 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE14, GPIO_MUX_12);
88 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE15, GPIO_MUX_12);
89 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_12);
90 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE5, GPIO_MUX_12);
91 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE3, GPIO_MUX_12);
92 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE4, GPIO_MUX_12);
93 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE5, GPIO_MUX_12);
94 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE6, GPIO_MUX_12);
95 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE2, GPIO_MUX_12);
96 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE13, GPIO_MUX_12);
97 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE7, GPIO_MUX_12);
98 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE8, GPIO_MUX_12);
99 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE9, GPIO_MUX_12);
100 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE10, GPIO_MUX_12);
101 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE11, GPIO_MUX_12);
102 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE12, GPIO_MUX_12);
103 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE14, GPIO_MUX_12);
104 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE15, GPIO_MUX_12);
105 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE0, GPIO_MUX_12);
106 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE1, GPIO_MUX_12);
107
108 /* address lines configuration */
109 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_2 | GPIO_PINS_3 | GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_12 | GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
110 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
111 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
112 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
113 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
114 gpio_init(GPIOF, &gpio_init_struct);
115
116 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_2 | GPIO_PINS_3 | GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_13 | GPIO_PINS_14;
117 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
118 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
119 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
120 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
121 gpio_init(GPIOG, &gpio_init_struct);
122
123 gpio_init_struct.gpio_pins = GPIO_PINS_11 | GPIO_PINS_12 | GPIO_PINS_13;
124 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
125 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
126 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
127 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
128 gpio_init(GPIOD, &gpio_init_struct);
129
130 gpio_init_struct.gpio_pins = GPIO_PINS_3 | GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6 | GPIO_PINS_2;
131 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
132 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
133 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
134 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
135 gpio_init(GPIOE, &gpio_init_struct);
136
137 /* data lines configuration */
138 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_14 | GPIO_PINS_15;
139 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
140 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
141 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
142 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
143 gpio_init(GPIOD, &gpio_init_struct);
144
145 gpio_init_struct.gpio_pins = GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11 | GPIO_PINS_12 | GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
146 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
147 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
148 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
149 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
150 gpio_init(GPIOE, &gpio_init_struct);
151
152 /* ne/noe/nwe/nbl0/nbl1 lines configuration */
153 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
154 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
155 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
156 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
157 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
158 gpio_init(GPIOE, &gpio_init_struct);
159
160 gpio_init_struct.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5;
161 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
162 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
163 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
164 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
165 gpio_init(GPIOD, &gpio_init_struct);
166
167 gpio_init_struct.gpio_pins = GPIO_PINS_10;
168 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
169 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
170 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
171 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
172 gpio_init(GPIOG, &gpio_init_struct);
173
174
175 /*-- xmc configuration ------------------------------------------------------*/
176 xmc_norsram_default_para_init(&xmc_norsram_init_struct);
177 xmc_norsram_init_struct.subbank = XMC_BANK1_NOR_SRAM3;
178 xmc_norsram_init_struct.data_addr_multiplex = XMC_DATA_ADDR_MUX_DISABLE;
179 xmc_norsram_init_struct.device = XMC_DEVICE_SRAM;
180 xmc_norsram_init_struct.bus_type = XMC_BUSTYPE_16_BITS;
181 xmc_norsram_init_struct.burst_mode_enable = XMC_BURST_MODE_DISABLE;
182 xmc_norsram_init_struct.asynwait_enable = XMC_ASYN_WAIT_DISABLE;
183 xmc_norsram_init_struct.wait_signal_lv = XMC_WAIT_SIGNAL_LEVEL_LOW;
184 xmc_norsram_init_struct.wrapped_mode_enable = XMC_WRAPPED_MODE_DISABLE;
185 xmc_norsram_init_struct.wait_signal_config = XMC_WAIT_SIGNAL_SYN_BEFORE;
186 xmc_norsram_init_struct.write_enable = XMC_WRITE_OPERATION_ENABLE;
187 xmc_norsram_init_struct.wait_signal_enable = XMC_WAIT_SIGNAL_DISABLE;
188 xmc_norsram_init_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
189 xmc_norsram_init_struct.write_burst_syn = XMC_WRITE_BURST_SYN_DISABLE;
190 xmc_nor_sram_init(&xmc_norsram_init_struct);
191
192 /* timing configuration */
193 xmc_norsram_timing_default_para_init(&rw_timing_struct, &w_timing_struct);
194 rw_timing_struct.subbank = XMC_BANK1_NOR_SRAM3;
195 rw_timing_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
196 rw_timing_struct.addr_setup_time = 0x2;
197 rw_timing_struct.addr_hold_time = 0x0;
198 rw_timing_struct.data_setup_time = 0xc;
199 rw_timing_struct.bus_latency_time = 0x0;
200 rw_timing_struct.clk_psc = 0x0;
201 rw_timing_struct.data_latency_time = 0x0;
202 rw_timing_struct.mode = XMC_ACCESS_MODE_A;
203 w_timing_struct.subbank = XMC_BANK1_NOR_SRAM3;
204 w_timing_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
205 w_timing_struct.addr_setup_time = 0x2;
206 w_timing_struct.addr_hold_time = 0x0;
207 w_timing_struct.data_setup_time = 0xc;
208 w_timing_struct.bus_latency_time = 0x0;
209 w_timing_struct.clk_psc = 0x0;
210 w_timing_struct.data_latency_time = 0x0;
211 w_timing_struct.mode = XMC_ACCESS_MODE_A;
212 xmc_nor_sram_timing_config(&rw_timing_struct, &w_timing_struct);
213
214 /* bus turnaround phase for consecutive read duration and consecutive write duration */
215 xmc_ext_timing_config(XMC_BANK1_NOR_SRAM3, 0x08, 0x08);
216
217 /* enable xmc_bank1_nor_sram3 */
218 xmc_nor_sram_enable(XMC_BANK1_NOR_SRAM3, TRUE);
219}
220
229void sram_writebuffer(uint16_t* pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
230{
231 for(; numhalfwordtowrite != 0; numhalfwordtowrite--)
232 {
234 *(__IO uint16_t *) (BANK1_SRAM3_ADDR + writeaddr) = *pbuffer++;
235
237 writeaddr += 2;
238 }
239}
240
249void sram_readbuffer(uint16_t* pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
250{
251 for(; numhalfwordtoread != 0; numhalfwordtoread--)
252 {
254 *pbuffer++ = *(__IO uint16_t*) (BANK1_SRAM3_ADDR + readaddr);
255
257 readaddr += 2;
258 }
259}
260
267void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
268{
269 uint16_t indextmp = 0;
270
271 /* put in global buffer same values */
272 for (indextmp = 0; indextmp < bufferlenght; indextmp++ )
273 {
274 pbuffer[indextmp] = indextmp + offset;
275 }
276}
277
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
BANK1_SRAM3_ADDR
#define BANK1_SRAM3_ADDR
Definition: at_start_f435/examples/xmc/sram/src/xmc_sram.c:37
sram_init
void sram_init(void)
init sram interface
Definition: at_start_f435/examples/xmc/sram/src/xmc_sram.c:44
fill_buffer
void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer
Definition: at_start_f435/examples/xmc/sram/src/xmc_sram.c:267
sram_readbuffer
void sram_readbuffer(uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc sram memory.
Definition: at_start_f435/examples/xmc/sram/src/xmc_sram.c:249
sram_writebuffer
void sram_writebuffer(uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc sram memory.
Definition: at_start_f435/examples/xmc/sram/src/xmc_sram.c:229
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_XMC_PERIPH_CLOCK
@ CRM_XMC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:123
CRM_GPIOF_PERIPH_CLOCK
@ CRM_GPIOF_PERIPH_CLOCK
Definition: at32f435_437_crm.h:110
CRM_GPIOG_PERIPH_CLOCK
@ CRM_GPIOG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:111
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f435_437_gpio.h:146
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f435_437_gpio.h:64
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOG
#define GPIOG
Definition: at32f435_437_gpio.h:527
GPIOF
#define GPIOF
Definition: at32f435_437_gpio.h:526
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
xmc_nor_sram_init
void xmc_nor_sram_init(xmc_norsram_init_type *xmc_norsram_init_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_norsraminitstruct.
Definition: at32f435_437_xmc.c:78
xmc_norsram_timing_default_para_init
void xmc_norsram_timing_default_para_init(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
fill each xmc_rw_timing_struct and xmc_w_timing_struct member with its default value.
Definition: at32f435_437_xmc.c:176
xmc_nor_sram_timing_config
void xmc_nor_sram_timing_config(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_rw_timing_struct a...
Definition: at32f435_437_xmc.c:113
xmc_ext_timing_config
void xmc_ext_timing_config(xmc_nor_sram_subbank_type xmc_sub_bank, uint16_t w2w_timing, uint16_t r2r_timing)
config the bus turnaround phase.
Definition: at32f435_437_xmc.c:227
xmc_norsram_default_para_init
void xmc_norsram_default_para_init(xmc_norsram_init_type *xmc_nor_sram_init_struct)
fill each xmc_nor_sram_init_struct member with its default value.
Definition: at32f435_437_xmc.c:150
xmc_nor_sram_enable
void xmc_nor_sram_enable(xmc_nor_sram_subbank_type xmc_subbank, confirm_state new_state)
enable or disable the specified nor/sram memory bank.
Definition: at32f435_437_xmc.c:210
XMC_WAIT_SIGNAL_DISABLE
@ XMC_WAIT_SIGNAL_DISABLE
Definition: at32f435_437_xmc.h:101
XMC_WAIT_SIGNAL_SYN_BEFORE
@ XMC_WAIT_SIGNAL_SYN_BEFORE
Definition: at32f435_437_xmc.h:196
XMC_WRITE_OPERATION_ENABLE
@ XMC_WRITE_OPERATION_ENABLE
Definition: at32f435_437_xmc.h:93
XMC_WRITE_BURST_SYN_DISABLE
@ XMC_WRITE_BURST_SYN_DISABLE
Definition: at32f435_437_xmc.h:110
XMC_BURST_MODE_DISABLE
@ XMC_BURST_MODE_DISABLE
Definition: at32f435_437_xmc.h:65
XMC_DATA_ADDR_MUX_DISABLE
@ XMC_DATA_ADDR_MUX_DISABLE
Definition: at32f435_437_xmc.h:56
XMC_BUSTYPE_16_BITS
@ XMC_BUSTYPE_16_BITS
Definition: at32f435_437_xmc.h:179
XMC_WRITE_TIMING_ENABLE
@ XMC_WRITE_TIMING_ENABLE
Definition: at32f435_437_xmc.h:120
XMC_BANK1_NOR_SRAM3
@ XMC_BANK1_NOR_SRAM3
Definition: at32f435_437_xmc.h:148
XMC_ASYN_WAIT_DISABLE
@ XMC_ASYN_WAIT_DISABLE
Definition: at32f435_437_xmc.h:74
XMC_WRAPPED_MODE_DISABLE
@ XMC_WRAPPED_MODE_DISABLE
Definition: at32f435_437_xmc.h:83
XMC_ACCESS_MODE_A
@ XMC_ACCESS_MODE_A
Definition: at32f435_437_xmc.h:205
XMC_WAIT_SIGNAL_LEVEL_LOW
@ XMC_WAIT_SIGNAL_LEVEL_LOW
Definition: at32f435_437_xmc.h:187
XMC_DEVICE_SRAM
@ XMC_DEVICE_SRAM
Definition: at32f435_437_xmc.h:168
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
xmc_norsram_init_type
xmc nor/sram init structure definition
Definition: at32f435_437_xmc.h:409
xmc_norsram_init_type::wait_signal_enable
xmc_wait_signal_type wait_signal_enable
Definition: at32f435_437_xmc.h:420
xmc_norsram_init_type::data_addr_multiplex
xmc_data_addr_mux_type data_addr_multiplex
Definition: at32f435_437_xmc.h:411
xmc_norsram_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:421
xmc_norsram_init_type::burst_mode_enable
xmc_burst_access_mode_type burst_mode_enable
Definition: at32f435_437_xmc.h:414
xmc_norsram_init_type::bus_type
xmc_data_width_type bus_type
Definition: at32f435_437_xmc.h:413
xmc_norsram_init_type::device
xmc_memory_type device
Definition: at32f435_437_xmc.h:412
xmc_norsram_init_type::wait_signal_lv
xmc_wait_signal_polarity_type wait_signal_lv
Definition: at32f435_437_xmc.h:416
xmc_norsram_init_type::wrapped_mode_enable
xmc_wrap_mode_type wrapped_mode_enable
Definition: at32f435_437_xmc.h:417
xmc_norsram_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:410
xmc_norsram_init_type::write_burst_syn
xmc_write_burst_type write_burst_syn
Definition: at32f435_437_xmc.h:422
xmc_norsram_init_type::asynwait_enable
xmc_asyn_wait_type asynwait_enable
Definition: at32f435_437_xmc.h:415
xmc_norsram_init_type::wait_signal_config
xmc_wait_timing_type wait_signal_config
Definition: at32f435_437_xmc.h:418
xmc_norsram_init_type::write_enable
xmc_write_operation_type write_enable
Definition: at32f435_437_xmc.h:419
xmc_norsram_timing_init_type
nor/sram banks timing parameters
Definition: at32f435_437_xmc.h:393
xmc_norsram_timing_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:395
xmc_norsram_timing_init_type::data_latency_time
uint32_t data_latency_time
Definition: at32f435_437_xmc.h:401
xmc_norsram_timing_init_type::addr_hold_time
uint32_t addr_hold_time
Definition: at32f435_437_xmc.h:397
xmc_norsram_timing_init_type::bus_latency_time
uint32_t bus_latency_time
Definition: at32f435_437_xmc.h:399
xmc_norsram_timing_init_type::addr_setup_time
uint32_t addr_setup_time
Definition: at32f435_437_xmc.h:396
xmc_norsram_timing_init_type::mode
xmc_access_mode_type mode
Definition: at32f435_437_xmc.h:402
xmc_norsram_timing_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:394
xmc_norsram_timing_init_type::clk_psc
uint32_t clk_psc
Definition: at32f435_437_xmc.h:400
xmc_norsram_timing_init_type::data_setup_time
uint32_t data_setup_time
Definition: at32f435_437_xmc.h:398


AT32F435/437 Firmwary Library: at32f435_437_board.d File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_board.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: at32f435_437_board.d Source File

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_board.d
Go to the documentation of this file.
1./objects/at32f435_437_board.o: \
2 ..\..\..\..\..\at32f435_437_board\at32f435_437_board.c \
3 ..\..\..\..\..\at32f435_437_board\at32f435_437_board.h \
4 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdio.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\at32f435_437.h \
6 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\core_cm4.h \
7 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
8 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_version.h \
9 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
10 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
13 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\mpu_armv7.h \
14 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\system_at32f435_437.h \
15 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_def.h \
16 ..\inc\at32f435_437_conf.h \
17 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crm.h \
18 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_tmr.h \
19 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_ertc.h \
20 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_gpio.h \
21 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_i2c.h \
22 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usart.h \
23 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_pwc.h \
24 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_can.h \
25 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_adc.h \
26 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dac.h \
27 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_spi.h \
28 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dma.h \
29 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_debug.h \
30 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_flash.h \
31 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crc.h \
32 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wwdt.h \
33 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wdt.h \
34 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_exint.h \
35 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_sdio.h \
36 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_xmc.h \
37 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_acc.h \
38 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_misc.h \
39 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_edma.h \
40 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_qspi.h \
41 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_scfg.h \
42 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_emac.h \
43 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dvp.h \
44 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usb.h


AT32F435/437 Firmwary Library: at32f435_437_clock.d File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_clock.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: at32f435_437_clock.d Source File

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_clock.d
Go to the documentation of this file.
1./objects/at32f435_437_clock.o: ..\src\at32f435_437_clock.c \
2 ..\inc\at32f435_437_clock.h \
3 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\at32f435_437.h \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\core_cm4.h \
5 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
6 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_version.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
8 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
11 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\mpu_armv7.h \
12 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\system_at32f435_437.h \
13 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_def.h \
14 ..\inc\at32f435_437_conf.h \
15 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crm.h \
16 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_tmr.h \
17 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_ertc.h \
18 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_gpio.h \
19 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_i2c.h \
20 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usart.h \
21 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_pwc.h \
22 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_can.h \
23 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_adc.h \
24 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dac.h \
25 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_spi.h \
26 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dma.h \
27 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_debug.h \
28 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_flash.h \
29 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crc.h \
30 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wwdt.h \
31 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wdt.h \
32 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_exint.h \
33 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_sdio.h \
34 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_xmc.h \
35 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_acc.h \
36 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_misc.h \
37 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_edma.h \
38 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_qspi.h \
39 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_scfg.h \
40 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_emac.h \
41 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dvp.h \
42 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usb.h


AT32F435/437 Firmwary Library: at32f435_437_crm.d File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_crm.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: at32f435_437_crm.d Source File

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_crm.d
Go to the documentation of this file.
1./objects/at32f435_437_crm.o: \
2 ..\..\..\..\..\..\libraries\drivers\src\at32f435_437_crm.c \
3 ..\inc\at32f435_437_conf.h \
4 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crm.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\at32f435_437.h \
6 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\core_cm4.h \
7 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
8 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_version.h \
9 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
10 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
13 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\mpu_armv7.h \
14 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\system_at32f435_437.h \
15 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_def.h \
16 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_tmr.h \
17 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_ertc.h \
18 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_gpio.h \
19 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_i2c.h \
20 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usart.h \
21 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_pwc.h \
22 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_can.h \
23 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_adc.h \
24 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dac.h \
25 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_spi.h \
26 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dma.h \
27 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_debug.h \
28 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_flash.h \
29 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crc.h \
30 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wwdt.h \
31 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wdt.h \
32 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_exint.h \
33 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_sdio.h \
34 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_xmc.h \
35 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_acc.h \
36 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_misc.h \
37 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_edma.h \
38 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_qspi.h \
39 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_scfg.h \
40 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_emac.h \
41 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dvp.h \
42 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usb.h


AT32F435/437 Firmwary Library: at32f435_437_gpio.d File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_gpio.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: at32f435_437_gpio.d Source File

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_gpio.d
Go to the documentation of this file.
1./objects/at32f435_437_gpio.o: \
2 ..\..\..\..\..\..\libraries\drivers\src\at32f435_437_gpio.c \
3 ..\inc\at32f435_437_conf.h \
4 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crm.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\at32f435_437.h \
6 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\core_cm4.h \
7 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
8 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_version.h \
9 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
10 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
13 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\mpu_armv7.h \
14 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\system_at32f435_437.h \
15 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_def.h \
16 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_tmr.h \
17 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_ertc.h \
18 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_gpio.h \
19 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_i2c.h \
20 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usart.h \
21 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_pwc.h \
22 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_can.h \
23 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_adc.h \
24 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dac.h \
25 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_spi.h \
26 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dma.h \
27 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_debug.h \
28 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_flash.h \
29 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crc.h \
30 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wwdt.h \
31 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wdt.h \
32 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_exint.h \
33 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_sdio.h \
34 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_xmc.h \
35 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_acc.h \
36 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_misc.h \
37 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_edma.h \
38 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_qspi.h \
39 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_scfg.h \
40 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_emac.h \
41 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dvp.h \
42 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usb.h


AT32F435/437 Firmwary Library: at32f435_437_int.d File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_int.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: at32f435_437_int.d Source File

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_int.d
Go to the documentation of this file.
1./objects/at32f435_437_int.o: ..\src\at32f435_437_int.c \
2 ..\inc\at32f435_437_int.h \
3 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\at32f435_437.h \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\core_cm4.h \
5 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
6 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_version.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
8 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
11 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\mpu_armv7.h \
12 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\system_at32f435_437.h \
13 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_def.h \
14 ..\inc\at32f435_437_conf.h \
15 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crm.h \
16 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_tmr.h \
17 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_ertc.h \
18 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_gpio.h \
19 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_i2c.h \
20 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usart.h \
21 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_pwc.h \
22 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_can.h \
23 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_adc.h \
24 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dac.h \
25 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_spi.h \
26 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dma.h \
27 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_debug.h \
28 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_flash.h \
29 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crc.h \
30 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wwdt.h \
31 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wdt.h \
32 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_exint.h \
33 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_sdio.h \
34 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_xmc.h \
35 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_acc.h \
36 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_misc.h \
37 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_edma.h \
38 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_qspi.h \
39 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_scfg.h \
40 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_emac.h \
41 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dvp.h \
42 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usb.h


AT32F435/437 Firmwary Library: at32f435_437_misc.d File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_misc.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: at32f435_437_misc.d Source File

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_misc.d
Go to the documentation of this file.
1./objects/at32f435_437_misc.o: \
2 ..\..\..\..\..\..\libraries\drivers\src\at32f435_437_misc.c \
3 ..\inc\at32f435_437_conf.h \
4 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crm.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\at32f435_437.h \
6 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\core_cm4.h \
7 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
8 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_version.h \
9 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
10 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
13 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\mpu_armv7.h \
14 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\system_at32f435_437.h \
15 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_def.h \
16 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_tmr.h \
17 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_ertc.h \
18 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_gpio.h \
19 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_i2c.h \
20 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usart.h \
21 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_pwc.h \
22 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_can.h \
23 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_adc.h \
24 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dac.h \
25 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_spi.h \
26 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dma.h \
27 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_debug.h \
28 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_flash.h \
29 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crc.h \
30 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wwdt.h \
31 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wdt.h \
32 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_exint.h \
33 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_sdio.h \
34 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_xmc.h \
35 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_acc.h \
36 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_misc.h \
37 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_edma.h \
38 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_qspi.h \
39 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_scfg.h \
40 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_emac.h \
41 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dvp.h \
42 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usb.h


AT32F435/437 Firmwary Library: at32f435_437_usart.d File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_usart.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: at32f435_437_usart.d Source File

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_usart.d
Go to the documentation of this file.
1./objects/at32f435_437_usart.o: \
2 ..\..\..\..\..\..\libraries\drivers\src\at32f435_437_usart.c \
3 ..\inc\at32f435_437_conf.h \
4 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crm.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\at32f435_437.h \
6 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\core_cm4.h \
7 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
8 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_version.h \
9 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
10 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
13 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\mpu_armv7.h \
14 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\system_at32f435_437.h \
15 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_def.h \
16 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_tmr.h \
17 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_ertc.h \
18 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_gpio.h \
19 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_i2c.h \
20 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usart.h \
21 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_pwc.h \
22 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_can.h \
23 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_adc.h \
24 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dac.h \
25 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_spi.h \
26 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dma.h \
27 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_debug.h \
28 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_flash.h \
29 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crc.h \
30 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wwdt.h \
31 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wdt.h \
32 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_exint.h \
33 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_sdio.h \
34 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_xmc.h \
35 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_acc.h \
36 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_misc.h \
37 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_edma.h \
38 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_qspi.h \
39 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_scfg.h \
40 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_emac.h \
41 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dvp.h \
42 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usb.h


AT32F435/437 Firmwary Library: basicmathfunctions.d File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/basicmathfunctions.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: basicmathfunctions.d Source File

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/basicmathfunctions.d
Go to the documentation of this file.
1./objects/basicmathfunctions.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\BasicMathFunctions.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_abs_f32.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h \
14 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_abs_q15.c \
15 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_abs_q31.c \
16 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_abs_q7.c \
17 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_add_f32.c \
18 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_add_q15.c \
19 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_add_q31.c \
20 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_add_q7.c \
21 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_and_u16.c \
22 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_and_u32.c \
23 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_and_u8.c \
24 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_dot_prod_f32.c \
25 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_dot_prod_q15.c \
26 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_dot_prod_q31.c \
27 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_dot_prod_q7.c \
28 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_mult_f32.c \
29 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_mult_q15.c \
30 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_mult_q31.c \
31 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_mult_q7.c \
32 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_negate_f32.c \
33 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_negate_q15.c \
34 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_negate_q31.c \
35 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_negate_q7.c \
36 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_not_u16.c \
37 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_not_u32.c \
38 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_not_u8.c \
39 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_offset_f32.c \
40 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_offset_q15.c \
41 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_offset_q31.c \
42 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_offset_q7.c \
43 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_or_u16.c \
44 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_or_u32.c \
45 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_or_u8.c \
46 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_scale_f32.c \
47 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_scale_q15.c \
48 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_scale_q31.c \
49 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_scale_q7.c \
50 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_shift_q15.c \
51 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_shift_q31.c \
52 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_shift_q7.c \
53 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_sub_f32.c \
54 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_sub_q15.c \
55 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_sub_q31.c \
56 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_sub_q7.c \
57 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_xor_u16.c \
58 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_xor_u32.c \
59 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BasicMathFunctions\arm_xor_u8.c


AT32F435/437 Firmwary Library: bayesfunctions.d File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/bayesfunctions.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: bayesfunctions.d Source File

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/bayesfunctions.d
Go to the documentation of this file.
1./objects/bayesfunctions.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BayesFunctions\BayesFunctions.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\BayesFunctions\arm_gaussian_naive_bayes_predict_f32.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h


AT32F435/437 Firmwary Library: commontables.d File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/commontables.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: commontables.d Source File

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/commontables.d
Go to the documentation of this file.
1./objects/commontables.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\CommonTables\CommonTables.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\CommonTables\arm_common_tables.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h \
14 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_common_tables.h \
15 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
16 ..\..\..\..\..\..\libraries\cmsis\dsp\source\CommonTables\arm_const_structs.c \
17 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_const_structs.h \
18 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_common_tables.h \
19 ..\..\..\..\..\..\libraries\cmsis\dsp\source\CommonTables\arm_mve_tables.c


AT32F435/437 Firmwary Library: complexmathfunctions.d File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/complexmathfunctions.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: complexmathfunctions.d Source File

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/complexmathfunctions.d
Go to the documentation of this file.
1./objects/complexmathfunctions.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\ComplexMathFunctions.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_conj_f32.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h \
14 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_conj_q15.c \
15 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_conj_q31.c \
16 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_dot_prod_f32.c \
17 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_dot_prod_q15.c \
18 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_dot_prod_q31.c \
19 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_mag_f32.c \
20 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_mag_q15.c \
21 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_mag_q31.c \
22 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_mag_squared_f32.c \
23 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_mag_squared_q15.c \
24 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_mag_squared_q31.c \
25 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_mult_cmplx_f32.c \
26 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_mult_cmplx_q15.c \
27 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_mult_cmplx_q31.c \
28 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_mult_real_f32.c \
29 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_mult_real_q15.c \
30 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ComplexMathFunctions\arm_cmplx_mult_real_q31.c


AT32F435/437 Firmwary Library: controllerfunctions.d File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/controllerfunctions.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: controllerfunctions.d Source File

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/controllerfunctions.d
Go to the documentation of this file.
1./objects/controllerfunctions.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ControllerFunctions\ControllerFunctions.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ControllerFunctions\arm_pid_init_f32.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h \
14 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ControllerFunctions\arm_pid_init_q15.c \
15 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ControllerFunctions\arm_pid_init_q31.c \
16 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ControllerFunctions\arm_pid_reset_f32.c \
17 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ControllerFunctions\arm_pid_reset_q15.c \
18 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ControllerFunctions\arm_pid_reset_q31.c \
19 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ControllerFunctions\arm_sin_cos_f32.c \
20 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_common_tables.h \
21 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
22 ..\..\..\..\..\..\libraries\cmsis\dsp\source\ControllerFunctions\arm_sin_cos_q31.c


AT32F435/437 Firmwary Library: distancefunctions.d File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/distancefunctions.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: distancefunctions.d Source File

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/distancefunctions.d
Go to the documentation of this file.
1./objects/distancefunctions.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\DistanceFunctions.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_boolean_distance.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h \
14 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_boolean_distance_template.h \
15 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_braycurtis_distance_f32.c \
16 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_canberra_distance_f32.c \
17 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_chebyshev_distance_f32.c \
18 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_cityblock_distance_f32.c \
19 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_correlation_distance_f32.c \
20 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_cosine_distance_f32.c \
21 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_dice_distance.c \
22 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_euclidean_distance_f32.c \
23 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_hamming_distance.c \
24 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_jaccard_distance.c \
25 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_jensenshannon_distance_f32.c \
26 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_kulsinski_distance.c \
27 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_minkowski_distance_f32.c \
28 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_rogerstanimoto_distance.c \
29 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_russellrao_distance.c \
30 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_sokalmichener_distance.c \
31 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_sokalsneath_distance.c \
32 ..\..\..\..\..\..\libraries\cmsis\dsp\source\DistanceFunctions\arm_yule_distance.c


AT32F435/437 Firmwary Library: fastmathfunctions.d File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/fastmathfunctions.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: fastmathfunctions.d Source File

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/fastmathfunctions.d
Go to the documentation of this file.
1./objects/fastmathfunctions.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FastMathFunctions\FastMathFunctions.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FastMathFunctions\arm_cos_f32.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h \
14 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_common_tables.h \
15 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
16 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FastMathFunctions\arm_cos_q15.c \
17 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FastMathFunctions\arm_cos_q31.c \
18 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FastMathFunctions\arm_sin_f32.c \
19 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FastMathFunctions\arm_sin_q15.c \
20 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FastMathFunctions\arm_sin_q31.c \
21 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FastMathFunctions\arm_sqrt_q15.c \
22 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FastMathFunctions\arm_sqrt_q31.c \
23 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FastMathFunctions\arm_vexp_f32.c \
24 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FastMathFunctions\arm_vlog_f32.c


AT32F435/437 Firmwary Library: filteringfunctions.d File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/filteringfunctions.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: filteringfunctions.d Source File

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/filteringfunctions.d
Go to the documentation of this file.
1./objects/filteringfunctions.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\FilteringFunctions.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df1_32x64_init_q31.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h \
14 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df1_32x64_q31.c \
15 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df1_f32.c \
16 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df1_fast_q15.c \
17 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df1_fast_q31.c \
18 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df1_init_f32.c \
19 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df1_init_q15.c \
20 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df1_init_q31.c \
21 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df1_q15.c \
22 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df1_q31.c \
23 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df2T_f32.c \
24 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df2T_f64.c \
25 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df2T_init_f32.c \
26 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_df2T_init_f64.c \
27 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_stereo_df2T_f32.c \
28 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_biquad_cascade_stereo_df2T_init_f32.c \
29 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_f32.c \
30 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_fast_opt_q15.c \
31 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_fast_q15.c \
32 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_fast_q31.c \
33 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_opt_q15.c \
34 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_opt_q7.c \
35 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_partial_f32.c \
36 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_partial_fast_opt_q15.c \
37 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_partial_fast_q15.c \
38 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_partial_fast_q31.c \
39 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_partial_opt_q15.c \
40 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_partial_opt_q7.c \
41 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_partial_q15.c \
42 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_partial_q31.c \
43 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_partial_q7.c \
44 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_q15.c \
45 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_q31.c \
46 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_conv_q7.c \
47 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_correlate_f32.c \
48 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_correlate_fast_opt_q15.c \
49 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_correlate_fast_q15.c \
50 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_correlate_fast_q31.c \
51 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_correlate_opt_q15.c \
52 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_correlate_opt_q7.c \
53 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_correlate_q15.c \
54 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_correlate_q31.c \
55 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_correlate_q7.c \
56 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_decimate_f32.c \
57 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_decimate_fast_q15.c \
58 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_decimate_fast_q31.c \
59 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_decimate_init_f32.c \
60 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_decimate_init_q15.c \
61 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_decimate_init_q31.c \
62 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_decimate_q15.c \
63 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_decimate_q31.c \
64 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_f32.c \
65 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_fast_q15.c \
66 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_fast_q31.c \
67 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_init_f32.c \
68 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_init_q15.c \
69 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_init_q31.c \
70 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_init_q7.c \
71 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_interpolate_f32.c \
72 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_interpolate_init_f32.c \
73 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_interpolate_init_q15.c \
74 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_interpolate_init_q31.c \
75 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_interpolate_q15.c \
76 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_interpolate_q31.c \
77 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_lattice_f32.c \
78 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_lattice_init_f32.c \
79 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_lattice_init_q15.c \
80 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_lattice_init_q31.c \
81 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_lattice_q15.c \
82 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_lattice_q31.c \
83 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_q15.c \
84 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_q31.c \
85 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_q7.c \
86 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_sparse_f32.c \
87 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_sparse_init_f32.c \
88 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_sparse_init_q15.c \
89 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_sparse_init_q31.c \
90 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_sparse_init_q7.c \
91 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_sparse_q15.c \
92 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_sparse_q31.c \
93 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_fir_sparse_q7.c \
94 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_iir_lattice_f32.c \
95 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_iir_lattice_init_f32.c \
96 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_iir_lattice_init_q15.c \
97 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_iir_lattice_init_q31.c \
98 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_iir_lattice_q15.c \
99 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_iir_lattice_q31.c \
100 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_lms_f32.c \
101 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_lms_init_f32.c \
102 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_lms_init_q15.c \
103 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_lms_init_q31.c \
104 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_lms_norm_f32.c \
105 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_lms_norm_init_f32.c \
106 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_lms_norm_init_q15.c \
107 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_common_tables.h \
108 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
109 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_lms_norm_init_q31.c \
110 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_lms_norm_q15.c \
111 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_lms_norm_q31.c \
112 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_lms_q15.c \
113 ..\..\..\..\..\..\libraries\cmsis\dsp\source\FilteringFunctions\arm_lms_q31.c
arm_fir_f32
void arm_fir_f32(const arm_fir_instance_f32 *S, const float32_t *pSrc, float32_t *pDst, uint32_t blockSize)
arm_fir_init_f32
void arm_fir_init_f32(arm_fir_instance_f32 *S, uint16_t numTaps, const float32_t *pCoeffs, float32_t *pState, uint32_t blockSize)
Initialization function for the floating-point FIR filter.
Definition: arm_fir_init_f32.c:59


AT32F435/437 Firmwary Library: main.d File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/main.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: main.d Source File

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/main.d
Go to the documentation of this file.
1./objects/main.o: ..\src\main.c \
2 ..\..\..\..\..\at32f435_437_board\at32f435_437_board.h \
3 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdio.h \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\at32f435_437.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\core_cm4.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_version.h \
8 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
9 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
12 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\mpu_armv7.h \
13 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\system_at32f435_437.h \
14 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_def.h \
15 ..\inc\at32f435_437_conf.h \
16 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crm.h \
17 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_tmr.h \
18 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_ertc.h \
19 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_gpio.h \
20 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_i2c.h \
21 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usart.h \
22 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_pwc.h \
23 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_can.h \
24 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_adc.h \
25 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dac.h \
26 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_spi.h \
27 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dma.h \
28 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_debug.h \
29 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_flash.h \
30 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crc.h \
31 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wwdt.h \
32 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wdt.h \
33 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_exint.h \
34 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_sdio.h \
35 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_xmc.h \
36 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_acc.h \
37 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_misc.h \
38 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_edma.h \
39 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_qspi.h \
40 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_scfg.h \
41 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_emac.h \
42 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dvp.h \
43 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usb.h \
44 ..\inc\at32f435_437_clock.h \
45 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
46 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
47 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
48 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
49 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h
main
int main(void)
main function.
Definition: project/at_start_f435/examples/acc/calibration/src/main.c:167


AT32F435/437 Firmwary Library: matrixfunctions.d File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/matrixfunctions.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: matrixfunctions.d Source File

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/matrixfunctions.d
Go to the documentation of this file.
1./objects/matrixfunctions.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\MatrixFunctions.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_add_f32.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h \
14 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_add_q15.c \
15 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_add_q31.c \
16 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_cmplx_mult_f32.c \
17 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_cmplx_mult_q15.c \
18 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_cmplx_mult_q31.c \
19 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_init_f32.c \
20 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_init_q15.c \
21 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_init_q31.c \
22 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_inverse_f32.c \
23 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_inverse_f64.c \
24 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_mult_f32.c \
25 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_mult_fast_q15.c \
26 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_mult_fast_q31.c \
27 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_mult_q15.c \
28 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_mult_q31.c \
29 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_scale_f32.c \
30 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_scale_q15.c \
31 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_scale_q31.c \
32 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_sub_f32.c \
33 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_sub_q15.c \
34 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_sub_q31.c \
35 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_trans_f32.c \
36 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_trans_q15.c \
37 ..\..\..\..\..\..\libraries\cmsis\dsp\source\MatrixFunctions\arm_mat_trans_q31.c


AT32F435/437 Firmwary Library: startup_at32f435_437.d File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/startup_at32f435_437.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: startup_at32f435_437.d Source File

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/startup_at32f435_437.d
Go to the documentation of this file.
1.\objects\startup_at32f435_437.o: ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\startup\mdk\startup_at32f435_437.s


AT32F435/437 Firmwary Library: statisticsfunctions.d File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/statisticsfunctions.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: statisticsfunctions.d Source File

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/statisticsfunctions.d
Go to the documentation of this file.
1./objects/statisticsfunctions.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\StatisticsFunctions.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_entropy_f32.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h \
14 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_entropy_f64.c \
15 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_kullback_leibler_f32.c \
16 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_kullback_leibler_f64.c \
17 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_logsumexp_dot_prod_f32.c \
18 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_logsumexp_f32.c \
19 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_max_f32.c \
20 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_max_q15.c \
21 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_max_q31.c \
22 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_max_q7.c \
23 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_max_no_idx_f32.c \
24 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_mean_f32.c \
25 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_mean_q15.c \
26 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_mean_q31.c \
27 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_mean_q7.c \
28 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_min_f32.c \
29 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_min_q15.c \
30 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_min_q31.c \
31 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_min_q7.c \
32 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_power_f32.c \
33 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_power_q15.c \
34 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_power_q31.c \
35 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_power_q7.c \
36 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_rms_f32.c \
37 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_rms_q15.c \
38 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_rms_q31.c \
39 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_std_f32.c \
40 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_std_q15.c \
41 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_std_q31.c \
42 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_var_f32.c \
43 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_var_q15.c \
44 ..\..\..\..\..\..\libraries\cmsis\dsp\source\StatisticsFunctions\arm_var_q31.c


AT32F435/437 Firmwary Library: supportfunctions.d File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/supportfunctions.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: supportfunctions.d Source File

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/supportfunctions.d
Go to the documentation of this file.
1./objects/supportfunctions.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\SupportFunctions.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_barycenter_f32.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h \
14 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_bitonic_sort_f32.c \
15 ..\..\..\..\..\..\libraries\cmsis\dsp\PrivateInclude\arm_sorting.h \
16 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_bubble_sort_f32.c \
17 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_copy_f32.c \
18 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_copy_q15.c \
19 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_copy_q31.c \
20 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_copy_q7.c \
21 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_fill_f32.c \
22 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_fill_q15.c \
23 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_fill_q31.c \
24 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_fill_q7.c \
25 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_heap_sort_f32.c \
26 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_insertion_sort_f32.c \
27 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_merge_sort_f32.c \
28 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_merge_sort_init_f32.c \
29 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_quick_sort_f32.c \
30 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_selection_sort_f32.c \
31 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_sort_f32.c \
32 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_sort_init_f32.c \
33 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_spline_interp_f32.c \
34 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_spline_interp_init_f32.c \
35 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_weighted_sum_f32.c \
36 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_float_to_q15.c \
37 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_float_to_q31.c \
38 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_float_to_q7.c \
39 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_q15_to_float.c \
40 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_q15_to_q31.c \
41 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_q15_to_q7.c \
42 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_q31_to_float.c \
43 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_q31_to_q15.c \
44 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_q31_to_q7.c \
45 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_q7_to_float.c \
46 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_q7_to_q15.c \
47 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SupportFunctions\arm_q7_to_q31.c


AT32F435/437 Firmwary Library: svmfunctions.d File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/svmfunctions.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: svmfunctions.d Source File

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/svmfunctions.d
Go to the documentation of this file.
1./objects/svmfunctions.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SVMFunctions\SVMFunctions.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SVMFunctions\arm_svm_linear_init_f32.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h \
14 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SVMFunctions\arm_svm_linear_predict_f32.c \
15 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SVMFunctions\arm_svm_polynomial_init_f32.c \
16 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SVMFunctions\arm_svm_polynomial_predict_f32.c \
17 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SVMFunctions\arm_svm_rbf_init_f32.c \
18 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SVMFunctions\arm_svm_rbf_predict_f32.c \
19 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SVMFunctions\arm_svm_sigmoid_init_f32.c \
20 ..\..\..\..\..\..\libraries\cmsis\dsp\source\SVMFunctions\arm_svm_sigmoid_predict_f32.c


AT32F435/437 Firmwary Library: system_at32f435_437.d File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/system_at32f435_437.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: system_at32f435_437.d Source File

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/system_at32f435_437.d
Go to the documentation of this file.
1./objects/system_at32f435_437.o: \
2 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\system_at32f435_437.c \
3 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\at32f435_437.h \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\core_cm4.h \
5 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
6 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_version.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
8 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
11 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\mpu_armv7.h \
12 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\system_at32f435_437.h \
13 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_def.h \
14 ..\inc\at32f435_437_conf.h \
15 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crm.h \
16 ..\..\..\..\..\..\libraries\cmsis\cm4\device_support\at32f435_437.h \
17 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_tmr.h \
18 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_ertc.h \
19 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_gpio.h \
20 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_i2c.h \
21 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usart.h \
22 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_pwc.h \
23 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_can.h \
24 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_adc.h \
25 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dac.h \
26 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_spi.h \
27 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dma.h \
28 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_debug.h \
29 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_flash.h \
30 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_crc.h \
31 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wwdt.h \
32 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_wdt.h \
33 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_exint.h \
34 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_sdio.h \
35 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_xmc.h \
36 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_acc.h \
37 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_misc.h \
38 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_edma.h \
39 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_qspi.h \
40 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_scfg.h \
41 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_emac.h \
42 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_dvp.h \
43 ..\..\..\..\..\..\libraries\drivers\inc\at32f435_437_usb.h


AT32F435/437 Firmwary Library: transformfunctions.d File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/transformfunctions.d File Reference

Go to the source code of this file.


AT32F435/437 Firmwary Library: transformfunctions.d Source File

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/transformfunctions.d
Go to the documentation of this file.
1./objects/transformfunctions.o: \
2 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\TransformFunctions.c \
3 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_bitreversal.c \
4 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
5 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_compiler.h \
6 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\stdint.h \
7 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\cmsis_armclang.h \
8 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_compat.h \
9 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\arm_acle.h \
10 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\string.h \
11 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\math.h \
12 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\float.h \
13 C:\Keil_v5\ARM\ARMCLANG\Bin\..\include\limits.h \
14 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_common_tables.h \
15 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_math.h \
16 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_bitreversal2.c \
17 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_f32.c \
18 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_f64.c \
19 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_q15.c \
20 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_q31.c \
21 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_init_f32.c \
22 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_const_structs.h \
23 ..\..\..\..\..\..\libraries\cmsis\cm4\core_support\arm_common_tables.h \
24 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_init_f64.c \
25 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_init_q15.c \
26 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_init_q31.c \
27 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix2_f32.c \
28 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix2_init_f32.c \
29 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix2_init_q15.c \
30 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix2_init_q31.c \
31 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix2_q15.c \
32 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix2_q31.c \
33 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix4_f32.c \
34 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix4_init_f32.c \
35 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix4_init_q15.c \
36 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix4_init_q31.c \
37 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix4_q15.c \
38 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix4_q31.c \
39 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_cfft_radix8_f32.c \
40 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_dct4_f32.c \
41 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_dct4_init_f32.c \
42 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_dct4_init_q15.c \
43 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_dct4_init_q31.c \
44 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_dct4_q15.c \
45 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_dct4_q31.c \
46 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_rfft_f32.c \
47 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_rfft_fast_f32.c \
48 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_rfft_fast_f64.c \
49 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_rfft_fast_init_f32.c \
50 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_rfft_fast_init_f64.c \
51 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_rfft_init_f32.c \
52 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_rfft_init_q15.c \
53 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_rfft_init_q31.c \
54 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_rfft_q15.c \
55 ..\..\..\..\..\..\libraries\cmsis\dsp\source\TransformFunctions\arm_rfft_q31.c


AT32F435/437 Firmwary Library: julia_fpu.h File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • fpu
  • inc
Macros | Functions
at_start_f437/examples/cortex_m4/fpu/inc/julia_fpu.h File Reference

julia_fpu header file More...

#include "at32f435_437.h"

Go to the source code of this file.

Macros

#define | ITERATION 200
#define | REAL_CONSTANT (0.285f)
#define | IMG_CONSTANT (0.01f)

Functions

void generate_julia_fpu (uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable More...

Detailed Description

julia_fpu header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/cortex_m4/fpu/inc/julia_fpu.h.


AT32F435/437 Firmwary Library: julia_fpu.h Source File

  • at_start_f437
  • examples
  • cortex_m4
  • fpu
  • inc
at_start_f437/examples/cortex_m4/fpu/inc/julia_fpu.h
Go to the documentation of this file.
1
27#ifndef __JULIA_FPU_H
28#define __JULIA_FPU_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
46#define ITERATION 200
47#define REAL_CONSTANT (0.285f)
48#define IMG_CONSTANT (0.01f)
49
54void generate_julia_fpu(uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t * buffer);
55
68#ifdef __cplusplus
69}
70#endif
71
72#endif
73
at32f435_437.h
at32f435_437 header file
buffer
uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:43
generate_julia_fpu
void generate_julia_fpu(uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable
Definition: at_start_f437/examples/cortex_m4/fpu/src/julia_fpu.c:48


AT32F435/437 Firmwary Library: julia_fpu.c File Reference

  • at_start_f437
  • examples
  • cortex_m4
  • fpu
  • src
Functions
at_start_f437/examples/cortex_m4/fpu/src/julia_fpu.c File Reference

julia_fpu source file More...

#include "julia_fpu.h"

Go to the source code of this file.

Functions

void generate_julia_fpu (uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable More...

Detailed Description

julia_fpu source file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/cortex_m4/fpu/src/julia_fpu.c.


AT32F435/437 Firmwary Library: julia_fpu.c Source File

  • at_start_f437
  • examples
  • cortex_m4
  • fpu
  • src
at_start_f437/examples/cortex_m4/fpu/src/julia_fpu.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "julia_fpu.h"
29
48void generate_julia_fpu(uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t * buffer)
49{
50 float tmp1, tmp2;
51 float num_real, num_img;
52 float rayon;
53 uint16_t i;
54 uint16_t x, y;
55 for (y = 0; y < size_y; y++)
56 {
57 for (x = 0; x < size_x; x++)
58 {
59 num_real = y - offset_y;
60 num_real = num_real / zoom;
61 num_img = x - offset_x;
62 num_img = num_img / zoom;
63 i = 0;
64 rayon = 0;
65 while((i < ITERATION - 1) && (rayon < 4))
66 {
67 tmp1 = num_real * num_real;
68 tmp2 = num_img * num_img;
69 num_img = 2 * num_real * num_img + IMG_CONSTANT;
70 num_real = tmp1 - tmp2 + REAL_CONSTANT;
71 rayon = tmp1 + tmp2;
72 i++;
73 }
74 /* store the value in the buffer */
75 buffer[x + y * size_x] = i;
76 }
77 }
78}
79
IMG_CONSTANT
#define IMG_CONSTANT
Definition: at_start_f435/examples/cortex_m4/fpu/inc/julia_fpu.h:48
REAL_CONSTANT
#define REAL_CONSTANT
Definition: at_start_f435/examples/cortex_m4/fpu/inc/julia_fpu.h:47
ITERATION
#define ITERATION
Definition: at_start_f435/examples/cortex_m4/fpu/inc/julia_fpu.h:46
buffer
uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:43
generate_julia_fpu
void generate_julia_fpu(uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable
Definition: at_start_f437/examples/cortex_m4/fpu/src/julia_fpu.c:48


AT32F435/437 Firmwary Library: dvp.c File Reference

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • dvp
Data Structures | Functions | Variables
at_start_f437/examples/dvp/ov2640_capture/hardware/dvp/dvp.c File Reference

dvp program More...

#include "at32f435_437.h"
#include "dvp.h"
#include "xmc_lcd.h"
#include "ov2640.h"

Go to the source code of this file.

Data Structures

struct Descriptors_Format_def

Functions

void | jpeg_data_process (void)
void | dvp_int_handler (void)
handles dvp interrupt request. More...
void | dvp_config (void)
configure dvp More...
void | dvp_io_init (void)
initialize gpio for dvp More...
void | dvp_dma_init (uint32_t mem0addr, uint32_t mem1addr, uint16_t memsize)
initialize dma for dvp More...
void | dvp_start (void)
start dvp transmission More...
void | dvp_stop (void)
stop dvp transmission More...
void | DVP_IRQHandler (void)
dvp irq handler More...
void | dvp_frame_done (void)
dvp frame transmit done More...
void | EDMA_Stream4_IRQHandler (void)
edma stream4 irq handler More...

Variables

edma_init_type edma_init_struct
uint8_t ov_frame = 0

Detailed Description

dvp program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/dvp/ov2640_capture/hardware/dvp/dvp.c.


AT32F435/437 Firmwary Library: dvp.c Source File

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • dvp
at_start_f437/examples/dvp/ov2640_capture/hardware/dvp/dvp.c
Go to the documentation of this file.
1
27#include "at32f435_437.h"
28#include "dvp.h"
29#include "xmc_lcd.h"
30#include "ov2640.h"
31
40 edma_init_type edma_init_struct;
41uint8_t ov_frame = 0;
42
43extern void jpeg_data_process(void);
44void dvp_int_handler(void);
45
46typedef struct
47{
48 uint32_t CR_NDT;
49 uint32_t PA;
50 uint32_t M0A;
51 uint32_t LLP;
52
53}Descriptors_Format_def;
54
60void dvp_config(void)
61{
62 dvp_io_init();
63
64 nvic_irq_enable(DVP_IRQn, 0, 0);
65
66 dvp_capture_mode_set(DVP_CAP_FUNC_MODE_CONTINUOUS);
67 dvp_hsync_polarity_set(DVP_HSYNC_POLARITY_HIGH);
68 dvp_vsync_polarity_set(DVP_VSYNC_POLARITY_LOW);
69 dvp_pclk_polarity_set(DVP_CLK_POLARITY_RISING);
70 dvp_pixel_data_length_set(DVP_PIXEL_DATA_LENGTH_8);
71 dvp_sync_mode_set(DVP_SYNC_MODE_HARDWARE);
72
73 /* enable the interrupts */
74 dvp_interrupt_enable(DVP_CFD_INT | DVP_OVR_INT | DVP_ESE_INT | DVP_VS_INT | DVP_HS_INT, TRUE);
75
76 /* enable dvp by setting dvpen bit */
77 dvp_enable(TRUE);
78}
79
85void dvp_io_init(void)
86{
87 gpio_init_type gpio_initure;
88
89 crm_periph_clock_enable(CRM_DVP_PERIPH_CLOCK, TRUE);
90 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
91 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
92 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
93
94 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE4, GPIO_MUX_13);//HS
95 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE6, GPIO_MUX_13);//PCLK
96 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE9, GPIO_MUX_13);//D0
97 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE10, GPIO_MUX_13);//D1
98 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE11, GPIO_MUX_13);//D2
99 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE12, GPIO_MUX_13);//D3
100 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE4, GPIO_MUX_13);//D5
101 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE7, GPIO_MUX_13);//VS
102 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE9, GPIO_MUX_13);//D7
103 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE4, GPIO_MUX_13);//D4
104 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE5, GPIO_MUX_13);//D6
105
106 gpio_initure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_6 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11 | GPIO_PINS_12;
107 gpio_initure.gpio_mode = GPIO_MODE_MUX;
108 gpio_initure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
109 gpio_initure.gpio_pull = GPIO_PULL_UP;
110 gpio_initure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
111 gpio_init(GPIOA, &gpio_initure);
112
113 gpio_initure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_7 | GPIO_PINS_9;
114 gpio_init(GPIOB, &gpio_initure);
115
116 gpio_initure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5;
117 gpio_init(GPIOE, &gpio_initure);
118}
119
129void dvp_dma_init(uint32_t mem0addr, uint32_t mem1addr, uint16_t memsize)
130{
131 crm_periph_clock_enable(CRM_EDMA_PERIPH_CLOCK, TRUE);
132
133 edma_init_struct.peripheral_base_addr = (uint32_t)&DVP->dt;
134 edma_init_struct.memory0_base_addr = (uint32_t)mem0addr;
135 edma_init_struct.buffer_size = memsize;
136 edma_init_struct.direction = EDMA_DIR_PERIPHERAL_TO_MEMORY;
137 edma_init_struct.peripheral_inc_enable = FALSE;
138 edma_init_struct.memory_inc_enable = FALSE;
139 edma_init_struct.peripheral_data_width = EDMA_PERIPHERAL_DATA_WIDTH_WORD;
140 edma_init_struct.memory_data_width = EDMA_MEMORY_DATA_WIDTH_HALFWORD;
141 edma_init_struct.loop_mode_enable = TRUE;
142 edma_init_struct.priority = EDMA_PRIORITY_HIGH;
143 edma_init_struct.fifo_mode_enable = TRUE;
144 edma_init_struct.fifo_threshold = EDMA_FIFO_THRESHOLD_FULL;
145 edma_init_struct.memory_burst_mode = EDMA_MEMORY_SINGLE;
146 edma_init_struct.peripheral_burst_mode = EDMA_PERIPHERAL_SINGLE;
147
148 edma_reset(EDMA_STREAM4);
149 edma_init(EDMA_STREAM4, &edma_init_struct);
150
151 edmamux_enable(TRUE);
152 edmamux_init(EDMAMUX_CHANNEL4, EDMAMUX_DMAREQ_ID_DVP);
153
154 if(mem1addr != 0)
155 {
156 edma_double_buffer_mode_init(EDMA_STREAM4, mem1addr, EDMA_MEMORY_0);
157 edma_double_buffer_mode_enable(EDMA_STREAM4, TRUE);
158 }
159
160 edma_interrupt_enable(EDMA_STREAM4, EDMA_FDT_INT, TRUE);
161 nvic_irq_enable(EDMA_Stream4_IRQn, 0, 0);
162}
163
169void dvp_start(void)
170{
171 lcd_struct->lcd_setblock(0, 0, LCD_W, LCD_H);
172 edma_stream_enable(EDMA_STREAM4, TRUE);
173 dvp_capture_enable(TRUE);
174}
175
181void dvp_stop(void)
182{
183 dvp_capture_enable(FALSE);
184
185 while(DVP->ctrl & 0x01);
186
187 edma_stream_enable(EDMA_STREAM4, FALSE);
188}
189
195void DVP_IRQHandler(void)
196{
197 dvp_int_handler();
198}
199
205void dvp_frame_done(void)
206{
207 lcd_struct->lcd_setblock(0, 0, LCD_W, LCD_H);
208 ov_frame++;
209}
210
216void EDMA_Stream4_IRQHandler(void)
217{
218 if(edma_flag_get(EDMA_FDT4_FLAG) != RESET)
219 {
220 edma_flag_clear(EDMA_FDT4_FLAG);
221 }
222}
223
229void dvp_int_handler(void)
230{
231 /* synchronization error interrupt management */
232 if(dvp_flag_get(DVP_ESE_INT_FLAG) != RESET)
233 {
234 /* clear the synchronization error flag */
235 dvp_flag_clear(DVP_ESE_INT_FLAG);
236 }
237
238 /* overflow interrupt management */
239 if(dvp_flag_get(DVP_OVR_INT_FLAG) != RESET)
240 {
241 /* clear the overflow flag */
242 dvp_flag_clear(DVP_OVR_INT_FLAG);
243 }
244
245 /* line interrupt management */
246 if(dvp_flag_get(DVP_HS_INT_FLAG) != RESET)
247 {
248 /* clear the line interrupt flag */
249 dvp_flag_clear(DVP_HS_INT_FLAG);
250 }
251
252 /* vsync interrupt management */
253 if(dvp_flag_get(DVP_VS_INT_FLAG) != RESET)
254 {
255 /* clear the vsync flag */
256 dvp_flag_clear(DVP_VS_INT_FLAG);
257 }
258
259 /* end of frame interrupt management */
260 if(dvp_flag_get(DVP_CFD_INT_FLAG) != RESET)
261 {
262 /* clear the end of frame flag */
263 dvp_flag_clear(DVP_CFD_INT_FLAG);
264
265 dvp_frame_done();
266 }
267}
268
at32f435_437.h
at32f435_437 header file
dvp.h
header file of dvp program
LCD_H
#define LCD_H
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:79
dvp_stop
void dvp_stop(void)
stop dvp transmission
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:181
dvp_io_init
void dvp_io_init(void)
initialize gpio for dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:85
edma_init_struct
edma_init_type edma_init_struct
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:40
dvp_frame_done
void dvp_frame_done(void)
dvp frame transmit done
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:205
dvp_start
void dvp_start(void)
start dvp transmission
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:169
DVP_IRQHandler
void DVP_IRQHandler(void)
dvp irq handler
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:195
ov_frame
uint8_t ov_frame
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:41
dvp_int_handler
void dvp_int_handler(void)
handles dvp interrupt request.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:229
LCD_W
#define LCD_W
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:78
dvp_dma_init
void dvp_dma_init(uint32_t mem0addr, uint32_t mem1addr, uint16_t memsize)
initialize dma for dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:129
lcd_struct
lcd_dev_type * lcd_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:48
dvp_config
void dvp_config(void)
configure dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:60
EDMA_Stream4_IRQHandler
void EDMA_Stream4_IRQHandler(void)
edma stream4 irq handler
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:216
jpeg_data_process
void jpeg_data_process(void)
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_EDMA_PERIPH_CLOCK
@ CRM_EDMA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:114
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_DVP_PERIPH_CLOCK
@ CRM_DVP_PERIPH_CLOCK
Definition: at32f435_437_crm.h:119
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
dvp_capture_mode_set
void dvp_capture_mode_set(dvp_cfm_type cap_mode)
set dvp capture mode
Definition: at32f435_437_dvp.c:73
dvp_capture_enable
void dvp_capture_enable(confirm_state new_state)
enable or disable dvp capture
Definition: at32f435_437_dvp.c:60
dvp_flag_get
flag_status dvp_flag_get(uint32_t flag)
get dvp event/interrupt flag status
Definition: at32f435_437_dvp.c:342
dvp_pixel_data_length_set
void dvp_pixel_data_length_set(dvp_pdl_type dvp_pdl)
config dvp pixel data length
Definition: at32f435_437_dvp.c:217
dvp_hsync_polarity_set
void dvp_hsync_polarity_set(dvp_hsp_type hsync_pol)
set dvp horizontal synchronization polarity
Definition: at32f435_437_dvp.c:174
dvp_sync_mode_set
void dvp_sync_mode_set(dvp_sm_type sync_mode)
set dvp synchronization mode
Definition: at32f435_437_dvp.c:122
dvp_vsync_polarity_set
void dvp_vsync_polarity_set(dvp_vsp_type vsync_pol)
set dvp vertical synchronization polarity
Definition: at32f435_437_dvp.c:187
dvp_interrupt_enable
void dvp_interrupt_enable(uint32_t dvp_int, confirm_state new_state)
enable or disable dvp interrupt
Definition: at32f435_437_dvp.c:312
dvp_enable
void dvp_enable(confirm_state new_state)
enable or disable dvp function
Definition: at32f435_437_dvp.c:227
dvp_pclk_polarity_set
void dvp_pclk_polarity_set(dvp_ckp_type eage)
set dvp pixel clock polarity
Definition: at32f435_437_dvp.c:161
dvp_flag_clear
void dvp_flag_clear(uint32_t flag)
clear dvp's pending flags
Definition: at32f435_437_dvp.c:388
DVP_VSYNC_POLARITY_LOW
@ DVP_VSYNC_POLARITY_LOW
Definition: at32f435_437_dvp.h:137
DVP_PIXEL_DATA_LENGTH_8
@ DVP_PIXEL_DATA_LENGTH_8
Definition: at32f435_437_dvp.h:156
DVP_SYNC_MODE_HARDWARE
@ DVP_SYNC_MODE_HARDWARE
Definition: at32f435_437_dvp.h:110
DVP_HSYNC_POLARITY_HIGH
@ DVP_HSYNC_POLARITY_HIGH
Definition: at32f435_437_dvp.h:128
DVP_CAP_FUNC_MODE_CONTINUOUS
@ DVP_CAP_FUNC_MODE_CONTINUOUS
Definition: at32f435_437_dvp.h:101
DVP_CLK_POLARITY_RISING
@ DVP_CLK_POLARITY_RISING
Definition: at32f435_437_dvp.h:119
DVP_VS_INT_FLAG
#define DVP_VS_INT_FLAG
Definition: at32f435_437_dvp.h:70
DVP_HS_INT_FLAG
#define DVP_HS_INT_FLAG
Definition: at32f435_437_dvp.h:71
DVP_CFD_INT_FLAG
#define DVP_CFD_INT_FLAG
Definition: at32f435_437_dvp.h:67
DVP_ESE_INT_FLAG
#define DVP_ESE_INT_FLAG
Definition: at32f435_437_dvp.h:69
DVP_OVR_INT_FLAG
#define DVP_OVR_INT_FLAG
Definition: at32f435_437_dvp.h:68
DVP_ESE_INT
#define DVP_ESE_INT
Definition: at32f435_437_dvp.h:84
DVP_VS_INT
#define DVP_VS_INT
Definition: at32f435_437_dvp.h:85
DVP_HS_INT
#define DVP_HS_INT
Definition: at32f435_437_dvp.h:86
DVP_OVR_INT
#define DVP_OVR_INT
Definition: at32f435_437_dvp.h:83
DVP_CFD_INT
#define DVP_CFD_INT
Definition: at32f435_437_dvp.h:82
DVP
#define DVP
Definition: at32f435_437_dvp.h:569
edma_flag_get
flag_status edma_flag_get(uint32_t edma_flag)
get the edma flag.
Definition: at32f435_437_edma.c:512
edma_flag_clear
void edma_flag_clear(uint32_t edma_flag)
clear the edma flag.
Definition: at32f435_437_edma.c:549
edma_double_buffer_mode_init
void edma_double_buffer_mode_init(edma_stream_type *edma_streamx, uint32_t memory1_addr, edma_memory_type current_memory)
config the the double buffer mode.
Definition: at32f435_437_edma.c:354
edmamux_init
void edmamux_init(edmamux_channel_type *edmamux_channelx, edmamux_requst_id_sel_type edmamux_req_id)
edmamux init.
Definition: at32f435_437_edma.c:718
edma_init
void edma_init(edma_stream_type *edma_streamx, edma_init_type *edma_init_struct)
edma init.
Definition: at32f435_437_edma.c:115
edma_double_buffer_mode_enable
void edma_double_buffer_mode_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the double memory mode.
Definition: at32f435_437_edma.c:383
edma_stream_enable
void edma_stream_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx.
Definition: at32f435_437_edma.c:198
edma_reset
void edma_reset(edma_stream_type *edma_streamx)
reset edma_streamx channely register.
Definition: at32f435_437_edma.c:58
edmamux_enable
void edmamux_enable(confirm_state new_state)
enable or disable the edma edmamux.
Definition: at32f435_437_edma.c:673
edma_interrupt_enable
void edma_interrupt_enable(edma_stream_type *edma_streamx, uint32_t edma_int, confirm_state new_state)
enable or disable the edma streamx interrupts.
Definition: at32f435_437_edma.c:225
EDMA_PRIORITY_HIGH
@ EDMA_PRIORITY_HIGH
Definition: at32f435_437_edma.h:191
EDMA_PERIPHERAL_DATA_WIDTH_WORD
@ EDMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_edma.h:171
EDMA_MEMORY_DATA_WIDTH_HALFWORD
@ EDMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_edma.h:180
EDMA_MEMORY_SINGLE
@ EDMA_MEMORY_SINGLE
Definition: at32f435_437_edma.h:224
EDMA_PERIPHERAL_SINGLE
@ EDMA_PERIPHERAL_SINGLE
Definition: at32f435_437_edma.h:235
EDMA_FIFO_THRESHOLD_FULL
@ EDMA_FIFO_THRESHOLD_FULL
Definition: at32f435_437_edma.h:203
EDMA_MEMORY_0
@ EDMA_MEMORY_0
Definition: at32f435_437_edma.h:150
EDMA_DIR_PERIPHERAL_TO_MEMORY
@ EDMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_edma.h:159
EDMAMUX_DMAREQ_ID_DVP
@ EDMAMUX_DMAREQ_ID_DVP
Definition: at32f435_437_edma.h:349
EDMA_FDT4_FLAG
#define EDMA_FDT4_FLAG
Definition: at32f435_437_edma.h:86
EDMA_FDT_INT
#define EDMA_FDT_INT
Definition: at32f435_437_edma.h:55
EDMA_STREAM4
#define EDMA_STREAM4
Definition: at32f435_437_edma.h:965
EDMAMUX_CHANNEL4
#define EDMAMUX_CHANNEL4
Definition: at32f435_437_edma.h:992
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_13
@ GPIO_MUX_13
Definition: at32f435_437_gpio.h:169
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
DVP_IRQn
@ DVP_IRQn
Definition: at32f435_437.h:221
EDMA_Stream4_IRQn
@ EDMA_Stream4_IRQn
Definition: at32f435_437.h:160
Descriptors_Format_def
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:47
edma_init_type
edma init type
Definition: at32f435_437_edma.h:440
edma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_edma.h:441
edma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_edma.h:444
edma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_edma.h:446
edma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_edma.h:445
edma_init_type::direction
edma_dir_type direction
Definition: at32f435_437_edma.h:443
edma_init_type::fifo_mode_enable
confirm_state fifo_mode_enable
Definition: at32f435_437_edma.h:451
edma_init_type::peripheral_data_width
edma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_edma.h:447
edma_init_type::fifo_threshold
edma_fifo_threshold_type fifo_threshold
Definition: at32f435_437_edma.h:452
edma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_edma.h:449
edma_init_type::priority
edma_priority_level_type priority
Definition: at32f435_437_edma.h:450
edma_init_type::memory0_base_addr
uint32_t memory0_base_addr
Definition: at32f435_437_edma.h:442
edma_init_type::peripheral_burst_mode
edma_peripheral_burst_type peripheral_burst_mode
Definition: at32f435_437_edma.h:454
edma_init_type::memory_data_width
edma_memory_data_size_type memory_data_width
Definition: at32f435_437_edma.h:448
edma_init_type::memory_burst_mode
edma_memory_burst_type memory_burst_mode
Definition: at32f435_437_edma.h:453
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
lcd_dev_type::lcd_setblock
void(* lcd_setblock)(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:48


AT32F435/437 Firmwary Library: dvp.h File Reference

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • dvp
Functions | Variables
at_start_f437/examples/dvp/ov2640_capture/hardware/dvp/dvp.h File Reference

header file of dvp program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | dvp_config (void)
configure dvp More...
void | dvp_dma_init (uint32_t mem0addr, uint32_t mem1addr, uint16_t memsize)
initialize dma for dvp More...
void | dvp_start (void)
start dvp transmission More...
void | dvp_stop (void)
stop dvp transmission More...
void | dvp_io_init (void)
initialize gpio for dvp More...

Variables

edma_init_type edma_init_struct

Detailed Description

header file of dvp program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/dvp/ov2640_capture/hardware/dvp/dvp.h.


AT32F435/437 Firmwary Library: dvp.h Source File

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • dvp
at_start_f437/examples/dvp/ov2640_capture/hardware/dvp/dvp.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __DVP_H
29#define __DVP_H
30
31#ifdef __cplusplus
32 extern "C" {
33#endif
34
35/* Includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
46extern edma_init_type edma_init_struct;
47void dvp_config(void);
48void dvp_dma_init(uint32_t mem0addr,uint32_t mem1addr,uint16_t memsize);
49void dvp_start(void);
50void dvp_stop(void);
51void dvp_io_init(void);
52
61#ifdef __cplusplus
62}
63#endif
64
65#endif /*__DVP_H */
at32f435_437.h
at32f435_437 header file
dvp_stop
void dvp_stop(void)
stop dvp transmission
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:181
dvp_io_init
void dvp_io_init(void)
initialize gpio for dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:85
edma_init_struct
edma_init_type edma_init_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:40
dvp_start
void dvp_start(void)
start dvp transmission
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:169
dvp_dma_init
void dvp_dma_init(uint32_t mem0addr, uint32_t mem1addr, uint16_t memsize)
initialize dma for dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:129
dvp_config
void dvp_config(void)
configure dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:60
edma_init_type
edma init type
Definition: at32f435_437_edma.h:440


AT32F435/437 Firmwary Library: font.h File Reference

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • lcd
Variables
at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/font.h File Reference

Go to the source code of this file.

Variables

const unsigned char | asc2_1206 [95][12]
const unsigned char | asc2_1608 [95][16]
const unsigned char | asc2_2412 [95][36]
const unsigned char | asc2_3216 [95][128]


AT32F435/437 Firmwary Library: font.h Source File

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • lcd
at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/font.h
Go to the documentation of this file.
1/* *
2 **************************************************************************
3 * @file font.h
4 * @version v2.0.9
5 * @date 2022-06-28
6 * @brief header file of font
7 **************************************************************************
8 * Copyright notice & Disclaimer
9 *
10 * The software Board Support Package (BSP) that is made available to
11 * download from Artery official website is the copyrighted work of Artery.
12 * Artery authorizes customers to use, copy, and distribute the BSP
13 * software and its related documentation for the purpose of design and
14 * development in conjunction with Artery microcontrollers. Use of the
15 * software is governed by this copyright notice and the following disclaimer.
16 *
17 * THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES,
18 * GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS,
19 * TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR
20 * STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS,
21 * INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY,
22 * FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.
23 *
24 **************************************************************************
25 */
26
27#ifndef __FONT_H
28#define __FONT_H
29
38const unsigned char asc2_1206[95][12]={
39{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
40{0x00,0x00,0x00,0x00,0x3F,0x40,0x00,0x00,0x00,0x00,0x00,0x00},
41{0x00,0x00,0x30,0x00,0x40,0x00,0x30,0x00,0x40,0x00,0x00,0x00},
42{0x09,0x00,0x0B,0xC0,0x3D,0x00,0x0B,0xC0,0x3D,0x00,0x09,0x00},
43{0x18,0xC0,0x24,0x40,0x7F,0xE0,0x22,0x40,0x31,0x80,0x00,0x00},
44{0x18,0x00,0x24,0xC0,0x1B,0x00,0x0D,0x80,0x32,0x40,0x01,0x80},
45{0x03,0x80,0x1C,0x40,0x27,0x40,0x1C,0x80,0x07,0x40,0x00,0x40},
46{0x10,0x00,0x60,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
47{0x00,0x00,0x00,0x00,0x00,0x00,0x1F,0x80,0x20,0x40,0x40,0x20},
48{0x00,0x00,0x40,0x20,0x20,0x40,0x1F,0x80,0x00,0x00,0x00,0x00},
49{0x09,0x00,0x06,0x00,0x1F,0x80,0x06,0x00,0x09,0x00,0x00,0x00},
50{0x04,0x00,0x04,0x00,0x3F,0x80,0x04,0x00,0x04,0x00,0x00,0x00},
51{0x00,0x10,0x00,0x60,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
52{0x04,0x00,0x04,0x00,0x04,0x00,0x04,0x00,0x04,0x00,0x00,0x00},
53{0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
54{0x00,0x20,0x01,0xC0,0x06,0x00,0x38,0x00,0x40,0x00,0x00,0x00},
55{0x1F,0x80,0x20,0x40,0x20,0x40,0x20,0x40,0x1F,0x80,0x00,0x00},
56{0x00,0x00,0x10,0x40,0x3F,0xC0,0x00,0x40,0x00,0x00,0x00,0x00},
57{0x18,0xC0,0x21,0x40,0x22,0x40,0x24,0x40,0x18,0x40,0x00,0x00},
58{0x10,0x80,0x20,0x40,0x24,0x40,0x24,0x40,0x1B,0x80,0x00,0x00},
59{0x02,0x00,0x0D,0x00,0x11,0x00,0x3F,0xC0,0x01,0x40,0x00,0x00},
60{0x3C,0x80,0x24,0x40,0x24,0x40,0x24,0x40,0x23,0x80,0x00,0x00},
61{0x1F,0x80,0x24,0x40,0x24,0x40,0x34,0x40,0x03,0x80,0x00,0x00},
62{0x30,0x00,0x20,0x00,0x27,0xC0,0x38,0x00,0x20,0x00,0x00,0x00},
63{0x1B,0x80,0x24,0x40,0x24,0x40,0x24,0x40,0x1B,0x80,0x00,0x00},
64{0x1C,0x00,0x22,0xC0,0x22,0x40,0x22,0x40,0x1F,0x80,0x00,0x00},
65{0x00,0x00,0x00,0x00,0x08,0x40,0x00,0x00,0x00,0x00,0x00,0x00},
66{0x00,0x00,0x00,0x00,0x04,0x60,0x00,0x00,0x00,0x00,0x00,0x00},
67{0x00,0x00,0x04,0x00,0x0A,0x00,0x11,0x00,0x20,0x80,0x40,0x40},
68{0x09,0x00,0x09,0x00,0x09,0x00,0x09,0x00,0x09,0x00,0x00,0x00},
69{0x00,0x00,0x40,0x40,0x20,0x80,0x11,0x00,0x0A,0x00,0x04,0x00},
70{0x18,0x00,0x20,0x00,0x23,0x40,0x24,0x00,0x18,0x00,0x00,0x00},
71{0x1F,0x80,0x20,0x40,0x27,0x40,0x29,0x40,0x1F,0x40,0x00,0x00},
72{0x00,0x40,0x07,0xC0,0x39,0x00,0x0F,0x00,0x01,0xC0,0x00,0x40},
73{0x20,0x40,0x3F,0xC0,0x24,0x40,0x24,0x40,0x1B,0x80,0x00,0x00},
74{0x1F,0x80,0x20,0x40,0x20,0x40,0x20,0x40,0x30,0x80,0x00,0x00},
75{0x20,0x40,0x3F,0xC0,0x20,0x40,0x20,0x40,0x1F,0x80,0x00,0x00},
76{0x20,0x40,0x3F,0xC0,0x24,0x40,0x2E,0x40,0x30,0xC0,0x00,0x00},
77{0x20,0x40,0x3F,0xC0,0x24,0x40,0x2E,0x00,0x30,0x00,0x00,0x00},
78{0x0F,0x00,0x10,0x80,0x20,0x40,0x22,0x40,0x33,0x80,0x02,0x00},
79{0x20,0x40,0x3F,0xC0,0x04,0x00,0x04,0x00,0x3F,0xC0,0x20,0x40},
80{0x20,0x40,0x20,0x40,0x3F,0xC0,0x20,0x40,0x20,0x40,0x00,0x00},
81{0x00,0x60,0x20,0x20,0x20,0x20,0x3F,0xC0,0x20,0x00,0x20,0x00},
82{0x20,0x40,0x3F,0xC0,0x24,0x40,0x0B,0x00,0x30,0xC0,0x20,0x40},
83{0x20,0x40,0x3F,0xC0,0x20,0x40,0x00,0x40,0x00,0x40,0x00,0xC0},
84{0x3F,0xC0,0x3C,0x00,0x03,0xC0,0x3C,0x00,0x3F,0xC0,0x00,0x00},
85{0x20,0x40,0x3F,0xC0,0x0C,0x40,0x23,0x00,0x3F,0xC0,0x20,0x00},
86{0x1F,0x80,0x20,0x40,0x20,0x40,0x20,0x40,0x1F,0x80,0x00,0x00},
87{0x20,0x40,0x3F,0xC0,0x24,0x40,0x24,0x00,0x18,0x00,0x00,0x00},
88{0x1F,0x80,0x21,0x40,0x21,0x40,0x20,0xE0,0x1F,0xA0,0x00,0x00},
89{0x20,0x40,0x3F,0xC0,0x24,0x40,0x26,0x00,0x19,0xC0,0x00,0x40},
90{0x18,0xC0,0x24,0x40,0x24,0x40,0x22,0x40,0x31,0x80,0x00,0x00},
91{0x30,0x00,0x20,0x40,0x3F,0xC0,0x20,0x40,0x30,0x00,0x00,0x00},
92{0x20,0x00,0x3F,0x80,0x00,0x40,0x00,0x40,0x3F,0x80,0x20,0x00},
93{0x20,0x00,0x3E,0x00,0x01,0xC0,0x07,0x00,0x38,0x00,0x20,0x00},
94{0x38,0x00,0x07,0xC0,0x3C,0x00,0x07,0xC0,0x38,0x00,0x00,0x00},
95{0x20,0x40,0x39,0xC0,0x06,0x00,0x39,0xC0,0x20,0x40,0x00,0x00},
96{0x20,0x00,0x38,0x40,0x07,0xC0,0x38,0x40,0x20,0x00,0x00,0x00},
97{0x30,0x40,0x21,0xC0,0x26,0x40,0x38,0x40,0x20,0xC0,0x00,0x00},
98{0x00,0x00,0x00,0x00,0x7F,0xE0,0x40,0x20,0x40,0x20,0x00,0x00},
99{0x00,0x00,0x70,0x00,0x0C,0x00,0x03,0x80,0x00,0x40,0x00,0x00},
100{0x00,0x00,0x40,0x20,0x40,0x20,0x7F,0xE0,0x00,0x00,0x00,0x00},
101{0x00,0x00,0x20,0x00,0x40,0x00,0x20,0x00,0x00,0x00,0x00,0x00},
102{0x00,0x10,0x00,0x10,0x00,0x10,0x00,0x10,0x00,0x10,0x00,0x10},
103{0x00,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
104{0x00,0x00,0x02,0x80,0x05,0x40,0x05,0x40,0x03,0xC0,0x00,0x40},
105{0x20,0x00,0x3F,0xC0,0x04,0x40,0x04,0x40,0x03,0x80,0x00,0x00},
106{0x00,0x00,0x03,0x80,0x04,0x40,0x04,0x40,0x06,0x40,0x00,0x00},
107{0x00,0x00,0x03,0x80,0x04,0x40,0x24,0x40,0x3F,0xC0,0x00,0x40},
108{0x00,0x00,0x03,0x80,0x05,0x40,0x05,0x40,0x03,0x40,0x00,0x00},
109{0x00,0x00,0x04,0x40,0x1F,0xC0,0x24,0x40,0x24,0x40,0x20,0x00},
110{0x00,0x00,0x02,0xE0,0x05,0x50,0x05,0x50,0x06,0x50,0x04,0x20},
111{0x20,0x40,0x3F,0xC0,0x04,0x40,0x04,0x00,0x03,0xC0,0x00,0x40},
112{0x00,0x00,0x04,0x40,0x27,0xC0,0x00,0x40,0x00,0x00,0x00,0x00},
113{0x00,0x10,0x00,0x10,0x04,0x10,0x27,0xE0,0x00,0x00,0x00,0x00},
114{0x20,0x40,0x3F,0xC0,0x01,0x40,0x07,0x00,0x04,0xC0,0x04,0x40},
115{0x20,0x40,0x20,0x40,0x3F,0xC0,0x00,0x40,0x00,0x40,0x00,0x00},
116{0x07,0xC0,0x04,0x00,0x07,0xC0,0x04,0x00,0x03,0xC0,0x00,0x00},
117{0x04,0x40,0x07,0xC0,0x04,0x40,0x04,0x00,0x03,0xC0,0x00,0x40},
118{0x00,0x00,0x03,0x80,0x04,0x40,0x04,0x40,0x03,0x80,0x00,0x00},
119{0x04,0x10,0x07,0xF0,0x04,0x50,0x04,0x40,0x03,0x80,0x00,0x00},
120{0x00,0x00,0x03,0x80,0x04,0x40,0x04,0x50,0x07,0xF0,0x00,0x10},
121{0x04,0x40,0x07,0xC0,0x02,0x40,0x04,0x00,0x04,0x00,0x00,0x00},
122{0x00,0x00,0x06,0x40,0x05,0x40,0x05,0x40,0x04,0xC0,0x00,0x00},
123{0x00,0x00,0x04,0x00,0x1F,0x80,0x04,0x40,0x00,0x40,0x00,0x00},
124{0x04,0x00,0x07,0x80,0x00,0x40,0x04,0x40,0x07,0xC0,0x00,0x40},
125{0x04,0x00,0x07,0x00,0x04,0xC0,0x01,0x80,0x06,0x00,0x04,0x00},
126{0x06,0x00,0x01,0xC0,0x07,0x00,0x01,0xC0,0x06,0x00,0x00,0x00},
127{0x04,0x40,0x06,0xC0,0x01,0x00,0x06,0xC0,0x04,0x40,0x00,0x00},
128{0x04,0x10,0x07,0x10,0x04,0xE0,0x01,0x80,0x06,0x00,0x04,0x00},
129{0x00,0x00,0x04,0x40,0x05,0xC0,0x06,0x40,0x04,0x40,0x00,0x00},
130{0x00,0x00,0x00,0x00,0x04,0x00,0x7B,0xE0,0x40,0x20,0x00,0x00},
131{0x00,0x00,0x00,0x00,0x00,0x00,0xFF,0xF0,0x00,0x00,0x00,0x00},
132{0x00,0x00,0x40,0x20,0x7B,0xE0,0x04,0x00,0x00,0x00,0x00,0x00},
133{0x40,0x00,0x80,0x00,0x40,0x00,0x20,0x00,0x20,0x00,0x40,0x00},
134};
135
136const unsigned char asc2_1608[95][16]={
137{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
138{0x00,0x00,0x00,0x00,0x00,0x00,0x1F,0xCC,0x00,0x0C,0x00,0x00,0x00,0x00,0x00,0x00},
139{0x00,0x00,0x08,0x00,0x30,0x00,0x60,0x00,0x08,0x00,0x30,0x00,0x60,0x00,0x00,0x00},
140{0x02,0x20,0x03,0xFC,0x1E,0x20,0x02,0x20,0x03,0xFC,0x1E,0x20,0x02,0x20,0x00,0x00},
141{0x00,0x00,0x0E,0x18,0x11,0x04,0x3F,0xFF,0x10,0x84,0x0C,0x78,0x00,0x00,0x00,0x00},
142{0x0F,0x00,0x10,0x84,0x0F,0x38,0x00,0xC0,0x07,0x78,0x18,0x84,0x00,0x78,0x00,0x00},
143{0x00,0x78,0x0F,0x84,0x10,0xC4,0x11,0x24,0x0E,0x98,0x00,0xE4,0x00,0x84,0x00,0x08},
144{0x08,0x00,0x68,0x00,0x70,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
145{0x00,0x00,0x00,0x00,0x00,0x00,0x07,0xE0,0x18,0x18,0x20,0x04,0x40,0x02,0x00,0x00},
146{0x00,0x00,0x40,0x02,0x20,0x04,0x18,0x18,0x07,0xE0,0x00,0x00,0x00,0x00,0x00,0x00},
147{0x02,0x40,0x02,0x40,0x01,0x80,0x0F,0xF0,0x01,0x80,0x02,0x40,0x02,0x40,0x00,0x00},
148{0x00,0x80,0x00,0x80,0x00,0x80,0x0F,0xF8,0x00,0x80,0x00,0x80,0x00,0x80,0x00,0x00},
149{0x00,0x01,0x00,0x0D,0x00,0x0E,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
150{0x00,0x00,0x00,0x80,0x00,0x80,0x00,0x80,0x00,0x80,0x00,0x80,0x00,0x80,0x00,0x80},
151{0x00,0x00,0x00,0x0C,0x00,0x0C,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
152{0x00,0x00,0x00,0x06,0x00,0x18,0x00,0x60,0x01,0x80,0x06,0x00,0x18,0x00,0x20,0x00},
153{0x00,0x00,0x07,0xF0,0x08,0x08,0x10,0x04,0x10,0x04,0x08,0x08,0x07,0xF0,0x00,0x00},
154{0x00,0x00,0x08,0x04,0x08,0x04,0x1F,0xFC,0x00,0x04,0x00,0x04,0x00,0x00,0x00,0x00},
155{0x00,0x00,0x0E,0x0C,0x10,0x14,0x10,0x24,0x10,0x44,0x11,0x84,0x0E,0x0C,0x00,0x00},
156{0x00,0x00,0x0C,0x18,0x10,0x04,0x11,0x04,0x11,0x04,0x12,0x88,0x0C,0x70,0x00,0x00},
157{0x00,0x00,0x00,0xE0,0x03,0x20,0x04,0x24,0x08,0x24,0x1F,0xFC,0x00,0x24,0x00,0x00},
158{0x00,0x00,0x1F,0x98,0x10,0x84,0x11,0x04,0x11,0x04,0x10,0x88,0x10,0x70,0x00,0x00},
159{0x00,0x00,0x07,0xF0,0x08,0x88,0x11,0x04,0x11,0x04,0x18,0x88,0x00,0x70,0x00,0x00},
160{0x00,0x00,0x1C,0x00,0x10,0x00,0x10,0xFC,0x13,0x00,0x1C,0x00,0x10,0x00,0x00,0x00},
161{0x00,0x00,0x0E,0x38,0x11,0x44,0x10,0x84,0x10,0x84,0x11,0x44,0x0E,0x38,0x00,0x00},
162{0x00,0x00,0x07,0x00,0x08,0x8C,0x10,0x44,0x10,0x44,0x08,0x88,0x07,0xF0,0x00,0x00},
163{0x00,0x00,0x00,0x00,0x00,0x00,0x03,0x0C,0x03,0x0C,0x00,0x00,0x00,0x00,0x00,0x00},
164{0x00,0x00,0x00,0x00,0x00,0x01,0x01,0x06,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
165{0x00,0x00,0x00,0x80,0x01,0x40,0x02,0x20,0x04,0x10,0x08,0x08,0x10,0x04,0x00,0x00},
166{0x02,0x20,0x02,0x20,0x02,0x20,0x02,0x20,0x02,0x20,0x02,0x20,0x02,0x20,0x00,0x00},
167{0x00,0x00,0x10,0x04,0x08,0x08,0x04,0x10,0x02,0x20,0x01,0x40,0x00,0x80,0x00,0x00},
168{0x00,0x00,0x0E,0x00,0x12,0x00,0x10,0x0C,0x10,0x6C,0x10,0x80,0x0F,0x00,0x00,0x00},
169{0x03,0xE0,0x0C,0x18,0x13,0xE4,0x14,0x24,0x17,0xC4,0x08,0x28,0x07,0xD0,0x00,0x00},
170{0x00,0x04,0x00,0x3C,0x03,0xC4,0x1C,0x40,0x07,0x40,0x00,0xE4,0x00,0x1C,0x00,0x04},
171{0x10,0x04,0x1F,0xFC,0x11,0x04,0x11,0x04,0x11,0x04,0x0E,0x88,0x00,0x70,0x00,0x00},
172{0x03,0xE0,0x0C,0x18,0x10,0x04,0x10,0x04,0x10,0x04,0x10,0x08,0x1C,0x10,0x00,0x00},
173{0x10,0x04,0x1F,0xFC,0x10,0x04,0x10,0x04,0x10,0x04,0x08,0x08,0x07,0xF0,0x00,0x00},
174{0x10,0x04,0x1F,0xFC,0x11,0x04,0x11,0x04,0x17,0xC4,0x10,0x04,0x08,0x18,0x00,0x00},
175{0x10,0x04,0x1F,0xFC,0x11,0x04,0x11,0x00,0x17,0xC0,0x10,0x00,0x08,0x00,0x00,0x00},
176{0x03,0xE0,0x0C,0x18,0x10,0x04,0x10,0x04,0x10,0x44,0x1C,0x78,0x00,0x40,0x00,0x00},
177{0x10,0x04,0x1F,0xFC,0x10,0x84,0x00,0x80,0x00,0x80,0x10,0x84,0x1F,0xFC,0x10,0x04},
178{0x00,0x00,0x10,0x04,0x10,0x04,0x1F,0xFC,0x10,0x04,0x10,0x04,0x00,0x00,0x00,0x00},
179{0x00,0x03,0x00,0x01,0x10,0x01,0x10,0x01,0x1F,0xFE,0x10,0x00,0x10,0x00,0x00,0x00},
180{0x10,0x04,0x1F,0xFC,0x11,0x04,0x03,0x80,0x14,0x64,0x18,0x1C,0x10,0x04,0x00,0x00},
181{0x10,0x04,0x1F,0xFC,0x10,0x04,0x00,0x04,0x00,0x04,0x00,0x04,0x00,0x0C,0x00,0x00},
182{0x10,0x04,0x1F,0xFC,0x1F,0x00,0x00,0xFC,0x1F,0x00,0x1F,0xFC,0x10,0x04,0x00,0x00},
183{0x10,0x04,0x1F,0xFC,0x0C,0x04,0x03,0x00,0x00,0xE0,0x10,0x18,0x1F,0xFC,0x10,0x00},
184{0x07,0xF0,0x08,0x08,0x10,0x04,0x10,0x04,0x10,0x04,0x08,0x08,0x07,0xF0,0x00,0x00},
185{0x10,0x04,0x1F,0xFC,0x10,0x84,0x10,0x80,0x10,0x80,0x10,0x80,0x0F,0x00,0x00,0x00},
186{0x07,0xF0,0x08,0x18,0x10,0x24,0x10,0x24,0x10,0x1C,0x08,0x0A,0x07,0xF2,0x00,0x00},
187{0x10,0x04,0x1F,0xFC,0x11,0x04,0x11,0x00,0x11,0xC0,0x11,0x30,0x0E,0x0C,0x00,0x04},
188{0x00,0x00,0x0E,0x1C,0x11,0x04,0x10,0x84,0x10,0x84,0x10,0x44,0x1C,0x38,0x00,0x00},
189{0x18,0x00,0x10,0x00,0x10,0x04,0x1F,0xFC,0x10,0x04,0x10,0x00,0x18,0x00,0x00,0x00},
190{0x10,0x00,0x1F,0xF8,0x10,0x04,0x00,0x04,0x00,0x04,0x10,0x04,0x1F,0xF8,0x10,0x00},
191{0x10,0x00,0x1E,0x00,0x11,0xE0,0x00,0x1C,0x00,0x70,0x13,0x80,0x1C,0x00,0x10,0x00},
192{0x1F,0xC0,0x10,0x3C,0x00,0xE0,0x1F,0x00,0x00,0xE0,0x10,0x3C,0x1F,0xC0,0x00,0x00},
193{0x10,0x04,0x18,0x0C,0x16,0x34,0x01,0xC0,0x01,0xC0,0x16,0x34,0x18,0x0C,0x10,0x04},
194{0x10,0x00,0x1C,0x00,0x13,0x04,0x00,0xFC,0x13,0x04,0x1C,0x00,0x10,0x00,0x00,0x00},
195{0x08,0x04,0x10,0x1C,0x10,0x64,0x10,0x84,0x13,0x04,0x1C,0x04,0x10,0x18,0x00,0x00},
196{0x00,0x00,0x00,0x00,0x00,0x00,0x7F,0xFE,0x40,0x02,0x40,0x02,0x40,0x02,0x00,0x00},
197{0x00,0x00,0x30,0x00,0x0C,0x00,0x03,0x80,0x00,0x60,0x00,0x1C,0x00,0x03,0x00,0x00},
198{0x00,0x00,0x40,0x02,0x40,0x02,0x40,0x02,0x7F,0xFE,0x00,0x00,0x00,0x00,0x00,0x00},
199{0x00,0x00,0x00,0x00,0x20,0x00,0x40,0x00,0x40,0x00,0x40,0x00,0x20,0x00,0x00,0x00},
200{0x00,0x01,0x00,0x01,0x00,0x01,0x00,0x01,0x00,0x01,0x00,0x01,0x00,0x01,0x00,0x01},
201{0x00,0x00,0x40,0x00,0x40,0x00,0x20,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
202{0x00,0x00,0x00,0x98,0x01,0x24,0x01,0x44,0x01,0x44,0x01,0x44,0x00,0xFC,0x00,0x04},
203{0x10,0x00,0x1F,0xFC,0x00,0x88,0x01,0x04,0x01,0x04,0x00,0x88,0x00,0x70,0x00,0x00},
204{0x00,0x00,0x00,0x70,0x00,0x88,0x01,0x04,0x01,0x04,0x01,0x04,0x00,0x88,0x00,0x00},
205{0x00,0x00,0x00,0x70,0x00,0x88,0x01,0x04,0x01,0x04,0x11,0x08,0x1F,0xFC,0x00,0x04},
206{0x00,0x00,0x00,0xF8,0x01,0x44,0x01,0x44,0x01,0x44,0x01,0x44,0x00,0xC8,0x00,0x00},
207{0x00,0x00,0x01,0x04,0x01,0x04,0x0F,0xFC,0x11,0x04,0x11,0x04,0x11,0x00,0x18,0x00},
208{0x00,0x00,0x00,0xD6,0x01,0x29,0x01,0x29,0x01,0x29,0x01,0xC9,0x01,0x06,0x00,0x00},
209{0x10,0x04,0x1F,0xFC,0x00,0x84,0x01,0x00,0x01,0x00,0x01,0x04,0x00,0xFC,0x00,0x04},
210{0x00,0x00,0x01,0x04,0x19,0x04,0x19,0xFC,0x00,0x04,0x00,0x04,0x00,0x00,0x00,0x00},
211{0x00,0x00,0x00,0x03,0x00,0x01,0x01,0x01,0x19,0x01,0x19,0xFE,0x00,0x00,0x00,0x00},
212{0x10,0x04,0x1F,0xFC,0x00,0x24,0x00,0x40,0x01,0xB4,0x01,0x0C,0x01,0x04,0x00,0x00},
213{0x00,0x00,0x10,0x04,0x10,0x04,0x1F,0xFC,0x00,0x04,0x00,0x04,0x00,0x00,0x00,0x00},
214{0x01,0x04,0x01,0xFC,0x01,0x04,0x01,0x00,0x01,0xFC,0x01,0x04,0x01,0x00,0x00,0xFC},
215{0x01,0x04,0x01,0xFC,0x00,0x84,0x01,0x00,0x01,0x00,0x01,0x04,0x00,0xFC,0x00,0x04},
216{0x00,0x00,0x00,0xF8,0x01,0x04,0x01,0x04,0x01,0x04,0x01,0x04,0x00,0xF8,0x00,0x00},
217{0x01,0x01,0x01,0xFF,0x00,0x85,0x01,0x04,0x01,0x04,0x00,0x88,0x00,0x70,0x00,0x00},
218{0x00,0x00,0x00,0x70,0x00,0x88,0x01,0x04,0x01,0x04,0x01,0x05,0x01,0xFF,0x00,0x01},
219{0x01,0x04,0x01,0x04,0x01,0xFC,0x00,0x84,0x01,0x04,0x01,0x00,0x01,0x80,0x00,0x00},
220{0x00,0x00,0x00,0xCC,0x01,0x24,0x01,0x24,0x01,0x24,0x01,0x24,0x01,0x98,0x00,0x00},
221{0x00,0x00,0x01,0x00,0x01,0x00,0x07,0xF8,0x01,0x04,0x01,0x04,0x00,0x00,0x00,0x00},
222{0x01,0x00,0x01,0xF8,0x00,0x04,0x00,0x04,0x00,0x04,0x01,0x08,0x01,0xFC,0x00,0x04},
223{0x01,0x00,0x01,0x80,0x01,0x70,0x00,0x0C,0x00,0x10,0x01,0x60,0x01,0x80,0x01,0x00},
224{0x01,0xF0,0x01,0x0C,0x00,0x30,0x01,0xC0,0x00,0x30,0x01,0x0C,0x01,0xF0,0x01,0x00},
225{0x00,0x00,0x01,0x04,0x01,0x8C,0x00,0x74,0x01,0x70,0x01,0x8C,0x01,0x04,0x00,0x00},
226{0x01,0x01,0x01,0x81,0x01,0x71,0x00,0x0E,0x00,0x18,0x01,0x60,0x01,0x80,0x01,0x00},
227{0x00,0x00,0x01,0x84,0x01,0x0C,0x01,0x34,0x01,0x44,0x01,0x84,0x01,0x0C,0x00,0x00},
228{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x01,0x00,0x3E,0xFC,0x40,0x02,0x40,0x02},
229{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0xFF,0xFF,0x00,0x00,0x00,0x00,0x00,0x00},
230{0x00,0x00,0x40,0x02,0x40,0x02,0x3E,0xFC,0x01,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
231{0x00,0x00,0x60,0x00,0x80,0x00,0x80,0x00,0x40,0x00,0x40,0x00,0x20,0x00,0x20,0x00},
232};
233
234const unsigned char asc2_2412[95][36]={
235{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
236{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x0F,0x80,0x38,0x0F,0xFE,0x38,0x0F,0x80,0x38,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
237{0x00,0x00,0x00,0x00,0x00,0x00,0x01,0x00,0x00,0x06,0x00,0x00,0x0C,0x00,0x00,0x38,0x00,0x00,0x31,0x00,0x00,0x06,0x00,0x00,0x0C,0x00,0x00,0x38,0x00,0x00,0x30,0x00,0x00,0x00,0x00,0x00},
238{0x00,0x00,0x00,0x00,0x61,0x80,0x00,0x67,0xF8,0x07,0xF9,0x80,0x00,0x61,0x80,0x00,0x61,0x80,0x00,0x61,0x80,0x00,0x61,0x80,0x00,0x67,0xF8,0x07,0xF9,0x80,0x00,0x61,0x80,0x00,0x00,0x00},
239{0x00,0x00,0x00,0x00,0x00,0x00,0x01,0xC0,0xE0,0x03,0xE0,0xF0,0x06,0x30,0x08,0x04,0x18,0x08,0x1F,0xFF,0xFE,0x04,0x0E,0x08,0x07,0x87,0xF0,0x03,0x81,0xE0,0x00,0x00,0x00,0x00,0x00,0x00},
240{0x01,0xF0,0x00,0x06,0x0C,0x00,0x04,0x04,0x08,0x06,0x0C,0x70,0x01,0xF9,0xC0,0x00,0x0E,0x00,0x00,0x3B,0xE0,0x00,0xEC,0x18,0x07,0x08,0x08,0x04,0x0C,0x18,0x00,0x03,0xE0,0x00,0x00,0x00},
241{0x00,0x01,0xE0,0x00,0x07,0xF0,0x03,0xF8,0x18,0x04,0x1C,0x08,0x04,0x17,0x08,0x07,0xE1,0xD0,0x03,0xC0,0xE0,0x00,0x23,0xB0,0x00,0x3C,0x08,0x00,0x20,0x08,0x00,0x00,0x10,0x00,0x00,0x00},
242{0x00,0x00,0x00,0x01,0x00,0x00,0x31,0x00,0x00,0x32,0x00,0x00,0x1C,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
243{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7F,0x00,0x01,0xFF,0xC0,0x07,0x80,0xF0,0x0C,0x00,0x18,0x10,0x00,0x04,0x20,0x00,0x02,0x00,0x00,0x00},
244{0x00,0x00,0x00,0x20,0x00,0x02,0x10,0x00,0x04,0x0C,0x00,0x18,0x07,0x80,0xF0,0x01,0xFF,0xC0,0x00,0x7F,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
245{0x00,0x00,0x00,0x00,0x42,0x00,0x00,0x66,0x00,0x00,0x66,0x00,0x00,0x3C,0x00,0x00,0x18,0x00,0x03,0xFF,0xC0,0x00,0x18,0x00,0x00,0x3C,0x00,0x00,0x66,0x00,0x00,0x66,0x00,0x00,0x42,0x00},
246{0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x01,0xFF,0xC0,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00},
247{0x00,0x00,0x00,0x00,0x00,0x01,0x00,0x00,0x31,0x00,0x00,0x32,0x00,0x00,0x1C,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
248{0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x00,0x00},
249{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x38,0x00,0x00,0x38,0x00,0x00,0x38,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
250{0x00,0x00,0x00,0x00,0x00,0x06,0x00,0x00,0x1C,0x00,0x00,0x70,0x00,0x01,0x80,0x00,0x0E,0x00,0x00,0x38,0x00,0x00,0xC0,0x00,0x07,0x00,0x00,0x1C,0x00,0x00,0x30,0x00,0x00,0x00,0x00,0x00},
251{0x00,0x00,0x00,0x00,0x7F,0x80,0x01,0xFF,0xE0,0x03,0x80,0x70,0x06,0x00,0x18,0x04,0x00,0x08,0x04,0x00,0x08,0x06,0x00,0x18,0x03,0x80,0x70,0x01,0xFF,0xE0,0x00,0x7F,0x80,0x00,0x00,0x00},
252{0x00,0x00,0x00,0x00,0x00,0x00,0x01,0x00,0x08,0x01,0x00,0x08,0x01,0x00,0x08,0x03,0xFF,0xF8,0x07,0xFF,0xF8,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x00,0x00,0x00,0x00},
253{0x00,0x00,0x00,0x01,0xC0,0x38,0x02,0xC0,0x58,0x04,0x00,0x98,0x04,0x01,0x18,0x04,0x02,0x18,0x04,0x04,0x18,0x06,0x1C,0x18,0x03,0xF8,0x18,0x01,0xE0,0xF8,0x00,0x00,0x00,0x00,0x00,0x00},
254{0x00,0x00,0x00,0x01,0xC0,0xE0,0x03,0xC0,0xF0,0x04,0x00,0x08,0x04,0x08,0x08,0x04,0x08,0x08,0x06,0x18,0x08,0x03,0xF4,0x18,0x01,0xE7,0xF0,0x00,0x01,0xE0,0x00,0x00,0x00,0x00,0x00,0x00},
255{0x00,0x00,0x00,0x00,0x03,0x00,0x00,0x0D,0x00,0x00,0x11,0x00,0x00,0x61,0x00,0x00,0x81,0x08,0x03,0x01,0x08,0x07,0xFF,0xF8,0x0F,0xFF,0xF8,0x00,0x01,0x08,0x00,0x01,0x08,0x00,0x00,0x00},
256{0x00,0x00,0x00,0x00,0x00,0xE0,0x07,0xFC,0xD0,0x06,0x08,0x08,0x06,0x10,0x08,0x06,0x10,0x08,0x06,0x10,0x08,0x06,0x18,0x38,0x06,0x0F,0xF0,0x06,0x07,0xC0,0x00,0x00,0x00,0x00,0x00,0x00},
257{0x00,0x00,0x00,0x00,0x3F,0x80,0x01,0xFF,0xE0,0x03,0x84,0x30,0x02,0x08,0x18,0x04,0x10,0x08,0x04,0x10,0x08,0x04,0x10,0x08,0x07,0x18,0x10,0x03,0x0F,0xF0,0x00,0x07,0xC0,0x00,0x00,0x00},
258{0x00,0x00,0x00,0x00,0x00,0x00,0x03,0xC0,0x00,0x07,0x00,0x00,0x06,0x00,0x00,0x06,0x00,0xF8,0x06,0x07,0xF8,0x06,0x18,0x00,0x06,0xE0,0x00,0x07,0x00,0x00,0x06,0x00,0x00,0x00,0x00,0x00},
259{0x00,0x00,0x00,0x01,0xE1,0xE0,0x03,0xF7,0xF0,0x06,0x34,0x10,0x04,0x18,0x08,0x04,0x18,0x08,0x04,0x0C,0x08,0x04,0x0C,0x08,0x06,0x16,0x18,0x03,0xF3,0xF0,0x01,0xC1,0xE0,0x00,0x00,0x00},
260{0x00,0x00,0x00,0x00,0xF8,0x00,0x03,0xFC,0x30,0x03,0x06,0x38,0x04,0x02,0x08,0x04,0x02,0x08,0x04,0x02,0x08,0x04,0x04,0x10,0x03,0x08,0xF0,0x01,0xFF,0xC0,0x00,0x7F,0x00,0x00,0x00,0x00},
261{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x70,0x38,0x00,0x70,0x38,0x00,0x70,0x38,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
262{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x30,0x1A,0x00,0x30,0x1C,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
263{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x14,0x00,0x00,0x22,0x00,0x00,0x41,0x00,0x00,0x80,0x80,0x01,0x00,0x40,0x02,0x00,0x20,0x04,0x00,0x10,0x08,0x00,0x08,0x00,0x00,0x00},
264{0x00,0x00,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x00,0x00},
265{0x00,0x00,0x00,0x00,0x00,0x00,0x08,0x00,0x08,0x04,0x00,0x10,0x02,0x00,0x20,0x01,0x00,0x40,0x00,0x80,0x80,0x00,0x41,0x00,0x00,0x22,0x00,0x00,0x14,0x00,0x00,0x08,0x00,0x00,0x00,0x00},
266{0x00,0x00,0x00,0x03,0xC0,0x00,0x04,0xC0,0x00,0x04,0x00,0x00,0x08,0x00,0x38,0x08,0x0F,0x38,0x08,0x08,0x38,0x08,0x10,0x00,0x0C,0x30,0x00,0x07,0xE0,0x00,0x03,0xC0,0x00,0x00,0x00,0x00},
267{0x00,0x00,0x00,0x00,0x3F,0x80,0x00,0xFF,0xE0,0x03,0x80,0x70,0x02,0x0F,0x10,0x06,0x70,0x88,0x04,0xC0,0x88,0x04,0x83,0x08,0x04,0x7F,0x88,0x02,0xC0,0x90,0x03,0x01,0x20,0x00,0xFE,0x40},
268{0x00,0x00,0x08,0x00,0x00,0x18,0x00,0x01,0xF8,0x00,0x3E,0x08,0x01,0xC2,0x00,0x07,0x02,0x00,0x07,0xE2,0x00,0x00,0xFE,0x00,0x00,0x1F,0xC8,0x00,0x01,0xF8,0x00,0x00,0x38,0x00,0x00,0x08},
269{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x08,0x08,0x04,0x08,0x08,0x04,0x08,0x08,0x04,0x08,0x08,0x06,0x18,0x08,0x03,0xF4,0x18,0x01,0xE7,0xF0,0x00,0x01,0xE0,0x00,0x00,0x00},
270{0x00,0x00,0x00,0x00,0x3F,0x80,0x01,0xFF,0xE0,0x03,0x80,0x70,0x02,0x00,0x18,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x10,0x06,0x00,0x20,0x07,0x80,0xC0,0x00,0x00,0x00},
271{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x18,0x02,0x00,0x10,0x03,0x80,0x70,0x01,0xFF,0xE0,0x00,0x7F,0x80,0x00,0x00,0x00},
272{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x08,0x08,0x04,0x08,0x08,0x04,0x08,0x08,0x04,0x08,0x08,0x04,0x3E,0x08,0x04,0x00,0x08,0x06,0x00,0x18,0x01,0x00,0x60,0x00,0x00,0x00},
273{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x08,0x08,0x04,0x08,0x00,0x04,0x08,0x00,0x04,0x08,0x00,0x04,0x3E,0x00,0x06,0x00,0x00,0x06,0x00,0x00,0x01,0x80,0x00,0x00,0x00,0x00},
274{0x00,0x00,0x00,0x00,0x3F,0x80,0x01,0xFF,0xE0,0x03,0x80,0x70,0x06,0x00,0x18,0x04,0x00,0x08,0x04,0x02,0x08,0x04,0x02,0x08,0x02,0x03,0xF0,0x07,0x83,0xF0,0x00,0x02,0x00,0x00,0x02,0x00},
275{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x08,0x08,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x04,0x08,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x00,0x08},
276{0x00,0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x08,0x00,0x00,0x00,0x00,0x00,0x00},
277{0x00,0x00,0x00,0x00,0x00,0x06,0x00,0x00,0x07,0x00,0x00,0x01,0x04,0x00,0x01,0x04,0x00,0x01,0x04,0x00,0x03,0x07,0xFF,0xFE,0x07,0xFF,0xFC,0x04,0x00,0x00,0x04,0x00,0x00,0x04,0x00,0x00},
278{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x0C,0x08,0x00,0x18,0x00,0x00,0x3E,0x00,0x04,0xC7,0x80,0x05,0x03,0xC8,0x06,0x00,0xF8,0x04,0x00,0x38,0x04,0x00,0x18,0x00,0x00,0x08},
279{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x18,0x00,0x00,0x60,0x00,0x00,0x00},
280{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0x80,0x08,0x07,0xFC,0x00,0x00,0x7F,0xC0,0x00,0x03,0xF8,0x00,0x07,0xC0,0x00,0x78,0x00,0x07,0x80,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x00,0x08},
281{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0x00,0x08,0x03,0xC0,0x00,0x00,0xE0,0x00,0x00,0x38,0x00,0x00,0x1E,0x00,0x00,0x07,0x00,0x00,0x01,0xC0,0x04,0x00,0xF0,0x07,0xFF,0xF8,0x04,0x00,0x00},
282{0x00,0x00,0x00,0x00,0x7F,0x80,0x01,0xFF,0xE0,0x03,0x80,0x70,0x06,0x00,0x18,0x04,0x00,0x08,0x04,0x00,0x08,0x06,0x00,0x18,0x03,0x00,0x30,0x01,0xFF,0xE0,0x00,0x7F,0x80,0x00,0x00,0x00},
283{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x04,0x08,0x04,0x04,0x00,0x04,0x04,0x00,0x04,0x04,0x00,0x04,0x04,0x00,0x06,0x0C,0x00,0x03,0xF8,0x00,0x01,0xF0,0x00,0x00,0x00,0x00},
284{0x00,0x00,0x00,0x00,0x7F,0x80,0x01,0xFF,0xE0,0x03,0x80,0x70,0x06,0x00,0x88,0x04,0x00,0x88,0x04,0x00,0xC8,0x06,0x00,0x3C,0x03,0x00,0x3E,0x01,0xFF,0xE6,0x00,0x7F,0x84,0x00,0x00,0x00},
285{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x08,0x08,0x04,0x08,0x00,0x04,0x0C,0x00,0x04,0x0F,0x00,0x04,0x0B,0xC0,0x06,0x10,0xF0,0x03,0xF0,0x38,0x01,0xE0,0x08,0x00,0x00,0x08},
286{0x00,0x00,0x00,0x01,0xE0,0xF8,0x03,0xF0,0x30,0x06,0x30,0x10,0x04,0x18,0x08,0x04,0x18,0x08,0x04,0x0C,0x08,0x04,0x0C,0x08,0x02,0x06,0x18,0x02,0x07,0xF0,0x07,0x81,0xE0,0x00,0x00,0x00},
287{0x01,0x80,0x00,0x06,0x00,0x00,0x04,0x00,0x00,0x04,0x00,0x00,0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x00,0x08,0x04,0x00,0x00,0x04,0x00,0x00,0x06,0x00,0x00,0x01,0x80,0x00},
288{0x04,0x00,0x00,0x07,0xFF,0xE0,0x07,0xFF,0xF0,0x04,0x00,0x18,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x04,0x00,0x10,0x07,0xFF,0xE0,0x04,0x00,0x00},
289{0x04,0x00,0x00,0x06,0x00,0x00,0x07,0xE0,0x00,0x07,0xFE,0x00,0x04,0x1F,0xE0,0x00,0x01,0xF8,0x00,0x00,0x38,0x00,0x01,0xE0,0x04,0x3E,0x00,0x07,0xC0,0x00,0x06,0x00,0x00,0x04,0x00,0x00},
290{0x04,0x00,0x00,0x07,0xE0,0x00,0x07,0xFF,0xC0,0x04,0x1F,0xF8,0x00,0x07,0xC0,0x07,0xF8,0x00,0x07,0xFF,0x80,0x04,0x3F,0xF8,0x00,0x07,0xC0,0x04,0xF8,0x00,0x07,0x00,0x00,0x04,0x00,0x00},
291{0x00,0x00,0x00,0x04,0x00,0x08,0x06,0x00,0x18,0x07,0xC0,0x78,0x05,0xF1,0xC8,0x00,0x3E,0x00,0x00,0x1F,0x80,0x04,0x63,0xE8,0x07,0x80,0xF8,0x06,0x00,0x18,0x04,0x00,0x08,0x00,0x00,0x00},
292{0x04,0x00,0x00,0x06,0x00,0x00,0x07,0x80,0x00,0x07,0xE0,0x08,0x04,0x7C,0x08,0x00,0x1F,0xF8,0x00,0x07,0xF8,0x00,0x18,0x08,0x04,0xE0,0x08,0x07,0x00,0x00,0x06,0x00,0x00,0x04,0x00,0x00},
293{0x00,0x00,0x00,0x01,0x00,0x08,0x06,0x00,0x38,0x04,0x00,0xF8,0x04,0x03,0xE8,0x04,0x0F,0x08,0x04,0x7C,0x08,0x05,0xF0,0x08,0x07,0xC0,0x08,0x07,0x00,0x18,0x04,0x00,0x60,0x00,0x00,0x00},
294{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x3F,0xFF,0xFE,0x20,0x00,0x02,0x20,0x00,0x02,0x20,0x00,0x02,0x20,0x00,0x02,0x20,0x00,0x02,0x00,0x00,0x00},
295{0x00,0x00,0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x07,0x00,0x00,0x00,0xC0,0x00,0x00,0x38,0x00,0x00,0x06,0x00,0x00,0x01,0xC0,0x00,0x00,0x30,0x00,0x00,0x0E,0x00,0x00,0x01,0x00,0x00,0x00},
296{0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x02,0x20,0x00,0x02,0x20,0x00,0x02,0x20,0x00,0x02,0x20,0x00,0x02,0x3F,0xFF,0xFE,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
297{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x10,0x00,0x00,0x30,0x00,0x00,0x20,0x00,0x00,0x30,0x00,0x00,0x10,0x00,0x00,0x08,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
298{0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01},
299{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x20,0x00,0x00,0x10,0x00,0x00,0x10,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
300{0x00,0x00,0x00,0x00,0x00,0xF0,0x00,0x19,0xF8,0x00,0x1B,0x18,0x00,0x22,0x08,0x00,0x26,0x08,0x00,0x24,0x08,0x00,0x24,0x10,0x00,0x3F,0xF8,0x00,0x1F,0xF8,0x00,0x00,0x08,0x00,0x00,0x18},
301{0x00,0x00,0x00,0x04,0x00,0x00,0x07,0xFF,0xF8,0x0F,0xFF,0xF0,0x00,0x18,0x18,0x00,0x10,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x30,0x18,0x00,0x1F,0xF0,0x00,0x0F,0xC0,0x00,0x00,0x00},
302{0x00,0x00,0x00,0x00,0x07,0xC0,0x00,0x1F,0xF0,0x00,0x18,0x30,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x3C,0x08,0x00,0x1C,0x10,0x00,0x00,0x60,0x00,0x00,0x00,0x00,0x00,0x00},
303{0x00,0x00,0x00,0x00,0x07,0xC0,0x00,0x1F,0xF0,0x00,0x38,0x18,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x04,0x10,0x10,0x07,0xFF,0xF8,0x0F,0xFF,0xF0,0x00,0x00,0x10,0x00,0x00,0x00},
304{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0xC0,0x00,0x1F,0xF0,0x00,0x12,0x30,0x00,0x22,0x18,0x00,0x22,0x08,0x00,0x22,0x08,0x00,0x32,0x08,0x00,0x1E,0x10,0x00,0x0E,0x20,0x00,0x00,0x00},
305{0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x20,0x08,0x00,0x20,0x08,0x01,0xFF,0xF8,0x03,0xFF,0xF8,0x06,0x20,0x08,0x04,0x20,0x08,0x04,0x20,0x08,0x07,0x20,0x00,0x03,0x00,0x00,0x00,0x00,0x00},
306{0x00,0x00,0x00,0x00,0x00,0x0E,0x00,0x0E,0x6E,0x00,0x1F,0xF3,0x00,0x31,0xB1,0x00,0x20,0xB1,0x00,0x20,0xB1,0x00,0x31,0x91,0x00,0x1F,0x13,0x00,0x2E,0x1E,0x00,0x20,0x0E,0x00,0x30,0x00},
307{0x00,0x00,0x00,0x04,0x00,0x08,0x07,0xFF,0xF8,0x0F,0xFF,0xF8,0x00,0x10,0x08,0x00,0x20,0x00,0x00,0x20,0x00,0x00,0x20,0x08,0x00,0x3F,0xF8,0x00,0x1F,0xF8,0x00,0x00,0x08,0x00,0x00,0x00},
308{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x06,0x3F,0xF8,0x06,0x3F,0xF8,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x00,0x00,0x00,0x00},
309{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x03,0x00,0x00,0x03,0x00,0x20,0x01,0x00,0x20,0x01,0x00,0x20,0x03,0x06,0x3F,0xFE,0x06,0x3F,0xFC,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
310{0x00,0x00,0x00,0x04,0x00,0x08,0x07,0xFF,0xF8,0x0F,0xFF,0xF8,0x00,0x01,0x88,0x00,0x03,0x00,0x00,0x2F,0xC0,0x00,0x38,0xF8,0x00,0x20,0x38,0x00,0x20,0x08,0x00,0x00,0x08,0x00,0x00,0x00},
311{0x00,0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x08,0x07,0xFF,0xF8,0x0F,0xFF,0xF8,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x00,0x00,0x00,0x00},
312{0x00,0x20,0x08,0x00,0x3F,0xF8,0x00,0x3F,0xF8,0x00,0x10,0x08,0x00,0x20,0x00,0x00,0x3F,0xF8,0x00,0x3F,0xF8,0x00,0x10,0x08,0x00,0x20,0x00,0x00,0x3F,0xF8,0x00,0x3F,0xF8,0x00,0x00,0x08},
313{0x00,0x00,0x00,0x00,0x20,0x08,0x00,0x3F,0xF8,0x00,0x3F,0xF8,0x00,0x10,0x08,0x00,0x10,0x00,0x00,0x20,0x00,0x00,0x20,0x08,0x00,0x3F,0xF8,0x00,0x1F,0xF8,0x00,0x00,0x08,0x00,0x00,0x00},
314{0x00,0x00,0x00,0x00,0x07,0xC0,0x00,0x0F,0xF0,0x00,0x18,0x30,0x00,0x30,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x30,0x08,0x00,0x18,0x30,0x00,0x0F,0xF0,0x00,0x07,0xC0,0x00,0x00,0x00},
315{0x00,0x00,0x00,0x00,0x20,0x01,0x00,0x3F,0xFF,0x00,0x3F,0xFF,0x00,0x10,0x11,0x00,0x20,0x09,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x30,0x38,0x00,0x1F,0xF0,0x00,0x0F,0xC0,0x00,0x00,0x00},
316{0x00,0x00,0x00,0x00,0x07,0xC0,0x00,0x1F,0xF0,0x00,0x38,0x18,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x20,0x09,0x00,0x10,0x11,0x00,0x1F,0xFF,0x00,0x3F,0xFF,0x00,0x00,0x01,0x00,0x00,0x00},
317{0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x3F,0xF8,0x00,0x3F,0xF8,0x00,0x08,0x08,0x00,0x10,0x08,0x00,0x20,0x08,0x00,0x20,0x00,0x00,0x30,0x00,0x00,0x30,0x00,0x00,0x00,0x00},
318{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x0C,0x78,0x00,0x1E,0x18,0x00,0x33,0x08,0x00,0x23,0x08,0x00,0x21,0x08,0x00,0x21,0x88,0x00,0x21,0x98,0x00,0x30,0xF0,0x00,0x38,0x60,0x00,0x00,0x00},
319{0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x20,0x00,0x00,0x20,0x00,0x00,0xFF,0xF0,0x03,0xFF,0xF8,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x00,0x30,0x00,0x00,0x00,0x00,0x00,0x00},
320{0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x3F,0xF0,0x00,0x7F,0xF8,0x00,0x00,0x18,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x20,0x10,0x00,0x3F,0xF8,0x00,0x7F,0xF0,0x00,0x00,0x10,0x00,0x00,0x00},
321{0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x30,0x00,0x00,0x3C,0x00,0x00,0x3F,0x80,0x00,0x23,0xF0,0x00,0x00,0x78,0x00,0x00,0x70,0x00,0x23,0x80,0x00,0x3C,0x00,0x00,0x30,0x00,0x00,0x20,0x00},
322{0x00,0x20,0x00,0x00,0x3C,0x00,0x00,0x3F,0xE0,0x00,0x23,0xF8,0x00,0x00,0xE0,0x00,0x27,0x00,0x00,0x3E,0x00,0x00,0x3F,0xE0,0x00,0x21,0xF8,0x00,0x01,0xE0,0x00,0x3E,0x00,0x00,0x20,0x00},
323{0x00,0x00,0x00,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x38,0x38,0x00,0x3E,0x68,0x00,0x27,0x80,0x00,0x03,0xC8,0x00,0x2C,0xF8,0x00,0x38,0x38,0x00,0x20,0x18,0x00,0x20,0x08,0x00,0x00,0x00},
324{0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x30,0x03,0x00,0x3C,0x01,0x00,0x3F,0x83,0x00,0x23,0xEC,0x00,0x00,0x70,0x00,0x23,0x80,0x00,0x3C,0x00,0x00,0x20,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
325{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x38,0x08,0x00,0x20,0x38,0x00,0x20,0xF8,0x00,0x23,0xE8,0x00,0x2F,0x88,0x00,0x3E,0x08,0x00,0x38,0x08,0x00,0x20,0x18,0x00,0x00,0x70,0x00,0x00,0x00},
326{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x14,0x00,0x1F,0xF7,0xFC,0x30,0x00,0x06,0x20,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00},
327{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0xFF,0xFF,0xFF,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
328{0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x02,0x30,0x00,0x06,0x1F,0xF7,0xFC,0x00,0x14,0x00,0x00,0x08,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
329{0x00,0x00,0x00,0x18,0x00,0x00,0x60,0x00,0x00,0x40,0x00,0x00,0x40,0x00,0x00,0x20,0x00,0x00,0x10,0x00,0x00,0x08,0x00,0x00,0x04,0x00,0x00,0x04,0x00,0x00,0x0C,0x00,0x00,0x10,0x00,0x00},
330};
331
332const unsigned char asc2_3216[95][128]={
333{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
334{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0xF0,0x00,0xC0,0x07,0xFF,0xE1,0xE0,0x07,0xF0,0x01,0xE0,0x00,0x00,0x00,0xC0,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
335{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x01,0xC0,0x00,0x00,0x07,0x80,0x00,0x00,0x1F,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0x1C,0x20,0x00,0x00,0x01,0xC0,0x00,0x00,0x07,0x80,0x00,0x00,0x1F,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0x1C,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
336{0x00,0x00,0x00,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0F,0xE0,0x00,0x1F,0xFC,0x00,0x03,0xF8,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0F,0xE0,0x00,0x1F,0xFC,0x00,0x03,0xF8,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x00,0x00,0x00},
337{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0x80,0x00,0x78,0x07,0xC0,0x00,0xFC,0x06,0x40,0x01,0x0E,0x00,0x20,0x03,0x07,0x00,0x20,0x02,0x03,0x80,0x20,0x0F,0xFF,0xFF,0xFC,0x02,0x01,0xC0,0x20,0x02,0x00,0xE0,0x60,0x01,0x30,0x70,0x40,0x01,0xF0,0x3F,0x80,0x00,0xF0,0x1F,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
338{0x00,0xFE,0x00,0x00,0x01,0xFF,0x00,0x00,0x03,0x01,0x80,0x00,0x02,0x00,0x80,0x60,0x03,0x01,0x81,0xC0,0x01,0xFF,0x07,0x00,0x00,0xFE,0x18,0x00,0x00,0x00,0xE0,0x00,0x00,0x03,0xBF,0x00,0x00,0x0C,0xFF,0xC0,0x00,0x71,0x80,0x60,0x01,0xC1,0x00,0x20,0x03,0x01,0x80,0x60,0x00,0x00,0xFF,0xC0,0x00,0x00,0x3F,0x00,0x00,0x00,0x00,0x00},
339{0x00,0x00,0x1F,0x00,0x00,0x00,0x7F,0xC0,0x00,0xFC,0xC0,0xC0,0x01,0xFF,0x80,0x60,0x03,0x03,0xE0,0x20,0x02,0x02,0x78,0x20,0x02,0x06,0x1E,0x20,0x03,0xFC,0x07,0x40,0x01,0xF0,0x03,0x80,0x00,0x01,0x03,0xC0,0x00,0x01,0x1C,0x60,0x00,0x01,0xE0,0x20,0x00,0x01,0x00,0x20,0x00,0x01,0x00,0x40,0x00,0x00,0x01,0x80,0x00,0x00,0x00,0x00},
340{0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x1C,0x60,0x00,0x00,0x1C,0x40,0x00,0x00,0x1F,0x80,0x00,0x00,0x0F,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
341{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0xF8,0x00,0x00,0x3F,0xFF,0x00,0x00,0x78,0x07,0xC0,0x01,0xC0,0x00,0xE0,0x03,0x00,0x00,0x30,0x04,0x00,0x00,0x08,0x08,0x00,0x00,0x04,0x10,0x00,0x00,0x02,0x00,0x00,0x00,0x00},
342{0x00,0x00,0x00,0x00,0x10,0x00,0x00,0x02,0x08,0x00,0x00,0x04,0x04,0x00,0x00,0x08,0x03,0x00,0x00,0x30,0x01,0xC0,0x00,0xE0,0x00,0x78,0x07,0xC0,0x00,0x3F,0xFF,0x00,0x00,0x07,0xF8,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
343{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x0C,0x18,0x00,0x00,0x0E,0x38,0x00,0x00,0x0E,0x38,0x00,0x00,0x06,0x30,0x00,0x00,0x03,0x60,0x00,0x00,0x61,0x43,0x80,0x00,0xFF,0xFF,0x80,0x00,0x61,0x43,0x00,0x00,0x03,0x60,0x00,0x00,0x06,0x30,0x00,0x00,0x0E,0x38,0x00,0x00,0x0E,0x38,0x00,0x00,0x0C,0x18,0x00,0x00,0x00,0x00,0x00},
344{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x7F,0xFF,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x00,0x00},
345{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0xE3,0x00,0x00,0x00,0xE2,0x00,0x00,0x00,0xFC,0x00,0x00,0x00,0x78,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
346{0x00,0x00,0x00,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x00,0x00},
347{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0xC0,0x00,0x00,0x01,0xE0,0x00,0x00,0x01,0xE0,0x00,0x00,0x00,0xC0,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
348{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x0C,0x00,0x00,0x00,0x38,0x00,0x00,0x00,0xE0,0x00,0x00,0x03,0x80,0x00,0x00,0x0E,0x00,0x00,0x00,0x38,0x00,0x00,0x00,0xE0,0x00,0x00,0x03,0x80,0x00,0x00,0x0E,0x00,0x00,0x00,0x38,0x00,0x00,0x00,0xE0,0x00,0x00,0x03,0x80,0x00,0x00,0x0E,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
349{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x0F,0xF8,0x00,0x00,0x7F,0xFF,0x00,0x00,0xF0,0x07,0x80,0x01,0x80,0x00,0xC0,0x03,0x00,0x00,0x60,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0x00,0x00,0x60,0x01,0x80,0x00,0xC0,0x00,0xE0,0x03,0x80,0x00,0x7F,0xFF,0x00,0x00,0x0F,0xF8,0x00,0x00,0x00,0x00,0x00},
350{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x80,0x00,0x20,0x00,0x80,0x00,0x20,0x00,0x80,0x00,0x20,0x00,0x80,0x00,0x60,0x01,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x00,0x00,0x00,0x60,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
351{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x78,0x00,0xE0,0x00,0x98,0x01,0x60,0x01,0x00,0x02,0x60,0x02,0x00,0x04,0x60,0x02,0x00,0x08,0x60,0x02,0x00,0x10,0x60,0x02,0x00,0x20,0x60,0x02,0x00,0x40,0x60,0x03,0x00,0x80,0x60,0x01,0x83,0x00,0x60,0x01,0xFE,0x00,0xE0,0x00,0x7C,0x07,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
352{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0xF0,0x07,0x80,0x01,0xF0,0x07,0xC0,0x01,0x00,0x00,0x40,0x02,0x00,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x03,0x03,0x80,0x20,0x01,0x86,0x80,0x40,0x01,0xFC,0xC0,0xC0,0x00,0x78,0x7F,0x80,0x00,0x00,0x1E,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
353{0x00,0x00,0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x00,0x38,0x00,0x00,0x00,0x48,0x00,0x00,0x01,0x88,0x00,0x00,0x06,0x08,0x00,0x00,0x0C,0x08,0x10,0x00,0x30,0x08,0x10,0x00,0x40,0x08,0x10,0x01,0xFF,0xFF,0xF0,0x03,0xFF,0xFF,0xF0,0x03,0xFF,0xFF,0xF0,0x00,0x00,0x08,0x10,0x00,0x00,0x08,0x10,0x00,0x00,0x08,0x10,0x00,0x00,0x00,0x00},
354{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0x80,0x00,0x1F,0x86,0x40,0x03,0xE1,0x00,0x20,0x03,0x02,0x00,0x20,0x03,0x04,0x00,0x20,0x03,0x04,0x00,0x20,0x03,0x04,0x00,0x20,0x03,0x04,0x00,0x20,0x03,0x06,0x00,0x40,0x03,0x03,0x01,0xC0,0x03,0x01,0xFF,0x80,0x03,0x00,0x7E,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
355{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0xFC,0x00,0x00,0x3F,0xFF,0x00,0x00,0x70,0xC3,0x80,0x00,0x81,0x80,0xC0,0x01,0x01,0x00,0x60,0x03,0x02,0x00,0x20,0x02,0x02,0x00,0x20,0x02,0x02,0x00,0x20,0x02,0x02,0x00,0x20,0x02,0x03,0x00,0x40,0x01,0xC1,0x80,0xC0,0x00,0xC0,0xFF,0x80,0x00,0x00,0x7E,0x00,0x00,0x00,0x00,0x00},
356{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0xF0,0x00,0x00,0x03,0xC0,0x00,0x00,0x03,0x80,0x00,0x00,0x03,0x00,0x00,0x00,0x03,0x00,0x07,0xE0,0x03,0x00,0x3F,0xE0,0x03,0x01,0xC0,0x00,0x03,0x06,0x00,0x00,0x03,0x18,0x00,0x00,0x03,0x60,0x00,0x00,0x03,0x80,0x00,0x00,0x03,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
357{0x00,0x00,0x00,0x00,0x00,0x00,0x1F,0x00,0x00,0x78,0x3F,0x80,0x00,0xFC,0x60,0xC0,0x01,0x8E,0xC0,0x40,0x03,0x07,0x80,0x20,0x02,0x03,0x00,0x20,0x02,0x01,0x80,0x20,0x02,0x01,0x80,0x20,0x02,0x01,0xC0,0x20,0x03,0x01,0xE0,0x40,0x01,0x86,0x70,0xC0,0x00,0xFC,0x3F,0x80,0x00,0x78,0x1F,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
358{0x00,0x00,0x00,0x00,0x00,0x3F,0x00,0x00,0x00,0xFF,0x81,0xC0,0x01,0xC0,0xC1,0xC0,0x01,0x00,0x60,0x20,0x02,0x00,0x20,0x20,0x02,0x00,0x20,0x20,0x02,0x00,0x20,0x20,0x02,0x00,0x20,0x60,0x02,0x00,0x40,0xC0,0x01,0x00,0xC1,0x80,0x00,0xC1,0x8F,0x00,0x00,0x7F,0xFE,0x00,0x00,0x1F,0xF0,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
359{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x03,0x00,0xC0,0x00,0x07,0x81,0xE0,0x00,0x07,0x81,0xE0,0x00,0x03,0x00,0xC0,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
360{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x06,0x00,0x66,0x00,0x06,0x00,0x78,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
361{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x80,0x00,0x00,0x01,0xC0,0x00,0x00,0x03,0x60,0x00,0x00,0x06,0x30,0x00,0x00,0x0C,0x18,0x00,0x00,0x18,0x0C,0x00,0x00,0x30,0x06,0x00,0x00,0x60,0x03,0x00,0x00,0xC0,0x01,0x80,0x01,0x00,0x00,0x40,0x02,0x00,0x00,0x20,0x04,0x00,0x00,0x10,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
362{0x00,0x00,0x00,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x00,0x00,0x00},
363{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x00,0x10,0x02,0x00,0x00,0x20,0x01,0x00,0x00,0x40,0x00,0xC0,0x01,0x80,0x00,0x60,0x03,0x00,0x00,0x30,0x06,0x00,0x00,0x18,0x0C,0x00,0x00,0x0C,0x18,0x00,0x00,0x06,0x30,0x00,0x00,0x03,0x60,0x00,0x00,0x01,0xC0,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
364{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x78,0x00,0x00,0x01,0xF8,0x00,0x00,0x02,0x38,0x00,0x00,0x02,0x00,0x00,0x00,0x04,0x00,0x00,0xC0,0x04,0x00,0x79,0xE0,0x04,0x00,0x81,0xE0,0x04,0x01,0x00,0xC0,0x04,0x03,0x00,0x00,0x02,0x02,0x00,0x00,0x03,0x06,0x00,0x00,0x01,0xFC,0x00,0x00,0x00,0xF8,0x00,0x00,0x00,0x00,0x00,0x00},
365{0x00,0x00,0x00,0x00,0x00,0x0F,0xF8,0x00,0x00,0x3F,0xFE,0x00,0x00,0x70,0x07,0x80,0x00,0xC0,0x00,0xC0,0x01,0x01,0xF8,0x40,0x03,0x07,0xFC,0x20,0x02,0x1E,0x04,0x20,0x02,0x30,0x08,0x20,0x02,0x20,0x30,0x20,0x02,0x3F,0xFC,0x20,0x01,0x3F,0x04,0x40,0x01,0x80,0x0C,0xC0,0x00,0xE0,0x31,0x80,0x00,0x1F,0xC2,0x00,0x00,0x00,0x00,0x00},
366{0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x60,0x00,0x00,0x03,0xE0,0x00,0x00,0x3E,0x20,0x00,0x03,0xE0,0x20,0x00,0x3E,0x20,0x00,0x03,0xE0,0x20,0x00,0x03,0x80,0x20,0x00,0x07,0xFC,0x20,0x00,0x00,0x3F,0xE0,0x00,0x00,0x03,0xFE,0x20,0x00,0x00,0x3F,0xE0,0x00,0x00,0x01,0xE0,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
367{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x03,0x03,0x00,0x20,0x01,0x86,0x80,0x60,0x01,0xFC,0xC0,0xC0,0x00,0xF8,0x7F,0x80,0x00,0x00,0x1F,0x00,0x00,0x00,0x00,0x00},
368{0x00,0x00,0x00,0x00,0x00,0x07,0xF8,0x00,0x00,0x3F,0xFF,0x00,0x00,0x70,0x07,0x80,0x00,0xC0,0x00,0xC0,0x01,0x00,0x00,0x40,0x03,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x01,0x00,0x00,0x40,0x01,0x80,0x00,0xC0,0x03,0xC0,0x01,0x80,0x00,0x30,0x06,0x00,0x00,0x00,0x00,0x00},
369{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0x00,0x00,0x60,0x01,0x00,0x00,0x40,0x01,0x80,0x00,0xC0,0x00,0xF0,0x07,0x80,0x00,0x7F,0xFE,0x00,0x00,0x0F,0xF8,0x00,0x00,0x00,0x00,0x00},
370{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x03,0x80,0x20,0x02,0x0F,0xE0,0x20,0x03,0x00,0x00,0x60,0x03,0xC0,0x00,0xE0,0x00,0x60,0x03,0x00,0x00,0x00,0x00,0x00},
371{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x00,0x02,0x01,0x00,0x00,0x02,0x01,0x00,0x00,0x02,0x01,0x00,0x00,0x02,0x03,0x80,0x00,0x03,0x0F,0xE0,0x00,0x03,0x00,0x00,0x00,0x03,0xC0,0x00,0x00,0x00,0x60,0x00,0x00},
372{0x00,0x00,0x00,0x00,0x00,0x07,0xF8,0x00,0x00,0x3F,0xFE,0x00,0x00,0x70,0x07,0x80,0x01,0xC0,0x01,0xC0,0x01,0x00,0x00,0x40,0x03,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x01,0x00,0x20,0x20,0x01,0x00,0x20,0x40,0x03,0xC0,0x3F,0x80,0x00,0x30,0x3F,0x80,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00},
373{0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x80,0x20,0x02,0x00,0x80,0x20,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x02,0x00,0x80,0x20,0x02,0x00,0x80,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
374{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
375{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x0E,0x00,0x00,0x00,0x0F,0x00,0x00,0x00,0x0F,0x00,0x00,0x00,0x01,0x02,0x00,0x00,0x01,0x02,0x00,0x00,0x01,0x02,0x00,0x00,0x03,0x02,0x00,0x00,0x06,0x03,0xFF,0xFF,0xFC,0x03,0xFF,0xFF,0xF8,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
376{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0xC0,0x20,0x02,0x01,0x00,0x20,0x00,0x07,0x80,0x00,0x00,0x0F,0xE0,0x00,0x00,0x30,0xF8,0x00,0x02,0x60,0x3E,0x20,0x03,0x80,0x0F,0x20,0x03,0x00,0x03,0xE0,0x02,0x00,0x00,0xE0,0x02,0x00,0x00,0x20,0x00,0x00,0x00,0x20},
377{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x60,0x00,0x00,0x00,0xE0,0x00,0x00,0x03,0x00,0x00,0x00,0x00,0x00},
378{0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xE0,0x00,0x20,0x03,0xFF,0x00,0x20,0x00,0x1F,0xF0,0x00,0x00,0x01,0xFF,0x80,0x00,0x00,0x0F,0xE0,0x00,0x00,0x1E,0x00,0x00,0x03,0xE0,0x00,0x00,0x3E,0x00,0x20,0x03,0xE0,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20},
379{0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0x80,0x00,0x20,0x03,0xF0,0x00,0x20,0x00,0xFC,0x00,0x00,0x00,0x1F,0x00,0x00,0x00,0x07,0xC0,0x00,0x00,0x01,0xF0,0x00,0x00,0x00,0x7C,0x00,0x02,0x00,0x1F,0x80,0x02,0x00,0x07,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
380{0x00,0x00,0x00,0x00,0x00,0x0F,0xF8,0x00,0x00,0x3F,0xFE,0x00,0x00,0xF0,0x07,0x80,0x01,0x80,0x00,0xC0,0x01,0x00,0x00,0x40,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x01,0x00,0x00,0x40,0x01,0x80,0x00,0xC0,0x00,0xF0,0x03,0x80,0x00,0x3F,0xFE,0x00,0x00,0x0F,0xF8,0x00,0x00,0x00,0x00,0x00},
381{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x80,0x20,0x02,0x00,0x80,0x20,0x02,0x00,0x80,0x00,0x02,0x00,0x80,0x00,0x02,0x00,0x80,0x00,0x02,0x00,0x80,0x00,0x03,0x01,0x80,0x00,0x01,0x83,0x00,0x00,0x00,0xFE,0x00,0x00,0x00,0x7C,0x00,0x00,0x00,0x00,0x00,0x00},
382{0x00,0x00,0x00,0x00,0x00,0x0F,0xF8,0x00,0x00,0x7F,0xFF,0x00,0x00,0xF0,0x03,0x80,0x01,0x80,0x01,0xC0,0x01,0x00,0x06,0x40,0x02,0x00,0x04,0x20,0x02,0x00,0x04,0x20,0x02,0x00,0x06,0x20,0x02,0x00,0x03,0xE0,0x01,0x00,0x00,0xF8,0x01,0x80,0x00,0x5C,0x00,0xE0,0x03,0x8C,0x00,0x3F,0xFF,0x0C,0x00,0x0F,0xFC,0x18,0x00,0x00,0x00,0x00},
383{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x80,0x00,0x02,0x01,0xE0,0x00,0x02,0x01,0xFC,0x00,0x03,0x03,0x3F,0x80,0x01,0x86,0x07,0xE0,0x01,0xFC,0x00,0xE0,0x00,0xF8,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
384{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x78,0x06,0x00,0x00,0xFE,0x01,0xE0,0x01,0x86,0x00,0xC0,0x03,0x03,0x00,0x40,0x02,0x03,0x00,0x20,0x02,0x01,0x80,0x20,0x02,0x01,0x80,0x20,0x02,0x01,0xC0,0x20,0x02,0x00,0xC0,0x20,0x01,0x00,0xE0,0x60,0x01,0x80,0x70,0xC0,0x03,0xE0,0x3F,0x80,0x00,0x00,0x1F,0x00,0x00,0x00,0x00,0x00},
385{0x00,0x00,0x00,0x00,0x00,0x60,0x00,0x00,0x03,0x80,0x00,0x00,0x03,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x03,0x80,0x00,0x00,0x00,0xE0,0x00,0x00,0x00,0x00,0x00,0x00},
386{0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x03,0xFF,0xFF,0x00,0x03,0xFF,0xFF,0xC0,0x02,0x00,0x00,0x40,0x02,0x00,0x00,0x60,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x02,0x00,0x00,0x40,0x02,0x00,0x00,0x80,0x03,0xFF,0xFF,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
387{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x03,0xC0,0x00,0x00,0x03,0xFC,0x00,0x00,0x02,0x3F,0xC0,0x00,0x00,0x03,0xF8,0x00,0x00,0x00,0x7F,0x80,0x00,0x00,0x07,0xE0,0x00,0x00,0x07,0x80,0x00,0x00,0x78,0x00,0x02,0x03,0xC0,0x00,0x02,0x3C,0x00,0x00,0x03,0xC0,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00},
388{0x02,0x00,0x00,0x00,0x03,0xC0,0x00,0x00,0x03,0xFF,0x80,0x00,0x02,0x3F,0xFE,0x00,0x02,0x00,0x7F,0xE0,0x00,0x00,0x0F,0x00,0x02,0x00,0xF0,0x00,0x03,0xEF,0x00,0x00,0x03,0xFF,0x80,0x00,0x02,0x0F,0xFE,0x00,0x00,0x00,0x3F,0xE0,0x00,0x00,0x1F,0x00,0x02,0x07,0xE0,0x00,0x03,0xF8,0x00,0x00,0x03,0x00,0x00,0x00,0x02,0x00,0x00,0x00},
389{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0x80,0x00,0xE0,0x03,0xF0,0x03,0x20,0x02,0xFC,0x0C,0x20,0x02,0x1F,0x30,0x00,0x00,0x07,0xC0,0x00,0x00,0x07,0xF0,0x00,0x02,0x18,0x7C,0x00,0x02,0x60,0x1F,0x20,0x03,0x80,0x03,0xE0,0x02,0x00,0x00,0xE0,0x02,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
390{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x03,0x00,0x00,0x00,0x03,0xC0,0x00,0x00,0x03,0xF8,0x00,0x00,0x02,0x3E,0x00,0x20,0x02,0x0F,0xC0,0x20,0x00,0x01,0xFF,0xE0,0x00,0x00,0x7F,0xE0,0x00,0x03,0x80,0x20,0x02,0x1C,0x00,0x20,0x02,0x70,0x00,0x00,0x03,0x80,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
391{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x60,0x00,0xE0,0x03,0x80,0x03,0xE0,0x03,0x00,0x0F,0xA0,0x02,0x00,0x3E,0x20,0x02,0x00,0xF8,0x20,0x02,0x03,0xE0,0x20,0x02,0x0F,0x80,0x20,0x02,0x3E,0x00,0x20,0x02,0x78,0x00,0x20,0x03,0xE0,0x00,0x60,0x03,0x80,0x00,0xE0,0x02,0x00,0x03,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
392{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x1F,0xFF,0xFF,0xFC,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
393{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0x00,0x00,0x00,0x03,0xC0,0x00,0x00,0x00,0x78,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0x03,0xC0,0x00,0x00,0x00,0xF0,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0x07,0x80,0x00,0x00,0x00,0xF0,0x00,0x00,0x00,0x3C,0x00,0x00,0x00,0x06,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
394{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x1F,0xFF,0xFF,0xFC,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
395{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x08,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x10,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
396{0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01},
397{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x10,0x00,0x00,0x00,0x10,0x00,0x00,0x00,0x10,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x08,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
398{0x00,0x00,0x00,0x00,0x00,0x00,0x03,0x80,0x00,0x01,0x8F,0xC0,0x00,0x03,0x8C,0x60,0x00,0x06,0x18,0x20,0x00,0x04,0x10,0x20,0x00,0x04,0x10,0x20,0x00,0x04,0x20,0x20,0x00,0x04,0x20,0x40,0x00,0x06,0x20,0x40,0x00,0x03,0xFF,0xC0,0x00,0x01,0xFF,0xE0,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0xC0,0x00,0x00,0x00,0x00},
399{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x03,0xFF,0xFF,0xE0,0x07,0xFF,0xFF,0xC0,0x00,0x01,0x80,0xC0,0x00,0x02,0x00,0x60,0x00,0x02,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x06,0x00,0x40,0x00,0x03,0x00,0xC0,0x00,0x01,0xFF,0x80,0x00,0x00,0xFE,0x00,0x00,0x00,0x00,0x00},
400{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7E,0x00,0x00,0x01,0xFF,0x80,0x00,0x03,0x81,0xC0,0x00,0x02,0x00,0x40,0x00,0x06,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x06,0x00,0x20,0x00,0x03,0xC0,0x40,0x00,0x01,0xC0,0x80,0x00,0x00,0x03,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
401{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7E,0x00,0x00,0x01,0xFF,0x80,0x00,0x03,0x80,0xC0,0x00,0x06,0x00,0x60,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x02,0x04,0x00,0x40,0x02,0x02,0x00,0x80,0x03,0xFF,0xFF,0xE0,0x07,0xFF,0xFF,0xC0,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x00},
402{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7E,0x00,0x00,0x01,0xFF,0x80,0x00,0x03,0x11,0xC0,0x00,0x02,0x10,0x40,0x00,0x04,0x10,0x60,0x00,0x04,0x10,0x20,0x00,0x04,0x10,0x20,0x00,0x04,0x10,0x20,0x00,0x06,0x10,0x20,0x00,0x03,0x10,0x40,0x00,0x01,0xF0,0xC0,0x00,0x00,0x71,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
403{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x7F,0xFF,0xE0,0x01,0xFF,0xFF,0xE0,0x01,0x04,0x00,0x20,0x03,0x04,0x00,0x20,0x02,0x04,0x00,0x20,0x02,0x04,0x00,0x20,0x02,0x04,0x00,0x00,0x02,0x00,0x00,0x00,0x01,0xC0,0x00,0x00,0x01,0xC0,0x00,0x00},
404{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x1C,0x00,0x00,0xE3,0x3E,0x00,0x03,0xFF,0xC2,0x00,0x02,0x0C,0xC3,0x00,0x04,0x04,0xC1,0x00,0x04,0x04,0xC1,0x00,0x04,0x04,0xC1,0x00,0x04,0x04,0xC1,0x00,0x06,0x0C,0xC1,0x00,0x03,0xF8,0xC3,0x00,0x05,0xF0,0x62,0x00,0x06,0x00,0x7E,0x00,0x06,0x00,0x3C,0x00,0x00,0x00,0x00},
405{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x07,0xFF,0xFF,0xE0,0x00,0x01,0x00,0x20,0x00,0x02,0x00,0x20,0x00,0x06,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x06,0x00,0x20,0x00,0x03,0xFF,0xE0,0x00,0x01,0xFF,0xE0,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20},
406{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x03,0x87,0xFF,0xE0,0x03,0x8F,0xFF,0xE0,0x03,0x80,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
407{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x06,0x00,0x00,0x00,0x07,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x04,0x00,0x01,0x00,0x04,0x00,0x01,0x00,0x04,0x00,0x03,0x00,0x04,0x00,0x06,0x03,0x87,0xFF,0xFC,0x03,0x8F,0xFF,0xF8,0x03,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
408{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x07,0xFF,0xFF,0xE0,0x00,0x00,0x08,0x20,0x00,0x00,0x10,0x20,0x00,0x00,0x30,0x00,0x00,0x00,0xFC,0x00,0x00,0x05,0x8E,0x00,0x00,0x07,0x07,0xA0,0x00,0x06,0x01,0xE0,0x00,0x04,0x00,0xE0,0x00,0x04,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
409{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x07,0xFF,0xFF,0xE0,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
410{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x07,0xFF,0xE0,0x00,0x0F,0xFF,0xE0,0x00,0x02,0x00,0x20,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x07,0xFF,0xE0,0x00,0x03,0xFF,0xE0,0x00,0x02,0x00,0x20,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x07,0xFF,0xE0,0x00,0x03,0xFF,0xE0,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
411{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x07,0xFF,0xE0,0x00,0x0F,0xFF,0xE0,0x00,0x01,0x00,0x20,0x00,0x02,0x00,0x20,0x00,0x02,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x06,0x00,0x20,0x00,0x03,0xFF,0xE0,0x00,0x01,0xFF,0xE0,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20},
412{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7E,0x00,0x00,0x00,0xFF,0x80,0x00,0x03,0x81,0xC0,0x00,0x02,0x00,0x40,0x00,0x06,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x06,0x00,0x20,0x00,0x02,0x00,0x40,0x00,0x03,0x81,0xC0,0x00,0x01,0xFF,0x80,0x00,0x00,0x7E,0x00,0x00,0x00,0x00,0x00},
413{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x01,0x00,0x04,0x00,0x01,0x00,0x07,0xFF,0xFF,0x00,0x0F,0xFF,0xFF,0x00,0x01,0x00,0xC1,0x00,0x02,0x00,0x41,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x06,0x00,0x40,0x00,0x03,0x01,0xC0,0x00,0x01,0xFF,0x80,0x00,0x00,0x7E,0x00,0x00,0x00,0x00,0x00},
414{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7E,0x00,0x00,0x01,0xFF,0x80,0x00,0x03,0x80,0xC0,0x00,0x02,0x00,0x60,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x02,0x00,0x41,0x00,0x03,0x00,0xC1,0x00,0x03,0xFF,0xFF,0x00,0x07,0xFF,0xFF,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01},
415{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x0F,0xFF,0xE0,0x00,0x0F,0xFF,0xE0,0x00,0x00,0xC0,0x20,0x00,0x01,0x00,0x20,0x00,0x02,0x00,0x20,0x00,0x06,0x00,0x20,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x07,0x00,0x00,0x00,0x03,0x00,0x00,0x00,0x00,0x00,0x00},
416{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x03,0xE0,0x00,0x01,0xC0,0xE0,0x00,0x03,0xE0,0x40,0x00,0x06,0x30,0x20,0x00,0x04,0x30,0x20,0x00,0x04,0x18,0x20,0x00,0x04,0x18,0x20,0x00,0x04,0x18,0x20,0x00,0x04,0x0C,0x20,0x00,0x02,0x0C,0x60,0x00,0x03,0x07,0xC0,0x00,0x07,0x83,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
417{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x0C,0x00,0x00,0x00,0x1F,0xFF,0x80,0x00,0xFF,0xFF,0xC0,0x00,0x04,0x00,0x60,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x40,0x00,0x00,0x01,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
418{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x07,0xFF,0x80,0x00,0x0F,0xFF,0xC0,0x00,0x00,0x00,0x60,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x04,0x00,0x40,0x00,0x04,0x00,0x80,0x00,0x07,0xFF,0xE0,0x00,0x0F,0xFF,0xC0,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x40},
419{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x07,0x80,0x00,0x00,0x07,0xF0,0x00,0x00,0x04,0xFE,0x00,0x00,0x04,0x1F,0xC0,0x00,0x00,0x03,0xE0,0x00,0x00,0x03,0x80,0x00,0x00,0x1C,0x00,0x00,0x04,0x60,0x00,0x00,0x07,0x80,0x00,0x00,0x06,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
420{0x00,0x04,0x00,0x00,0x00,0x06,0x00,0x00,0x00,0x07,0xC0,0x00,0x00,0x07,0xFC,0x00,0x00,0x04,0x3F,0x80,0x00,0x00,0x03,0xE0,0x00,0x04,0x0F,0x80,0x00,0x06,0xF0,0x00,0x00,0x07,0xF0,0x00,0x00,0x07,0xFF,0x80,0x00,0x04,0x0F,0xE0,0x00,0x00,0x03,0x80,0x00,0x04,0x3C,0x00,0x00,0x07,0xC0,0x00,0x00,0x06,0x00,0x00,0x00,0x04,0x00,0x00},
421{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x60,0x00,0x07,0x00,0xE0,0x00,0x07,0x83,0x20,0x00,0x07,0xE6,0x00,0x00,0x04,0xF8,0x00,0x00,0x00,0x3C,0x00,0x00,0x04,0x5E,0x20,0x00,0x05,0x87,0xA0,0x00,0x06,0x01,0xE0,0x00,0x04,0x00,0x60,0x00,0x04,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
422{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x03,0x00,0x07,0x00,0x03,0x00,0x07,0xE0,0x01,0x00,0x04,0xF8,0x01,0x00,0x04,0x1F,0x02,0x00,0x00,0x07,0xFC,0x00,0x00,0x00,0xE0,0x00,0x00,0x07,0x00,0x00,0x04,0x38,0x00,0x00,0x07,0xC0,0x00,0x00,0x06,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x00,0x00,0x00},
423{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0x80,0x60,0x00,0x06,0x00,0xE0,0x00,0x04,0x03,0xE0,0x00,0x04,0x07,0xA0,0x00,0x04,0x0E,0x20,0x00,0x04,0x3C,0x20,0x00,0x04,0x70,0x20,0x00,0x05,0xE0,0x20,0x00,0x07,0x80,0x20,0x00,0x07,0x00,0x60,0x00,0x04,0x00,0xE0,0x00,0x00,0x03,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
424{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x01,0x40,0x00,0x07,0xFE,0x3F,0xF8,0x08,0x00,0x00,0x04,0x10,0x00,0x00,0x02,0x10,0x00,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
425{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0xFF,0xFF,0xFF,0xFF,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
426{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x10,0x00,0x00,0x02,0x10,0x00,0x00,0x02,0x08,0x00,0x00,0x04,0x07,0xFE,0x3F,0xF8,0x00,0x01,0x40,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
427{0x00,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x30,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x30,0x00,0x00,0x00,0x08,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x0C,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
428};
429
438#endif
asc2_2412
const unsigned char asc2_2412[95][36]
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/font.h:234
asc2_3216
const unsigned char asc2_3216[95][128]
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/font.h:332
asc2_1206
const unsigned char asc2_1206[95][12]
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/font.h:38
asc2_1608
const unsigned char asc2_1608[95][16]
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/font.h:136


AT32F435/437 Firmwary Library: xmc_lcd.c File Reference

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • lcd
Functions | Variables
at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c File Reference

xmc_lcd program file More...

#include "xmc_lcd.h"
#include "font.h"

Go to the source code of this file.

Functions

void | xmc_init (void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_init (void)
configures the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_wr_command (uint16_t command)
this function is write command to lcd. More...
void | lcd_wr_data (uint16_t data)
this function is write data to lcd. More...
uint16_t | lcd_rd_data (void)
void | lcd_setblock (uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd. More...
void | lcd_writeonepoint (uint16_t color)
this function is write one point to lcd. More...
void | lcd_drawpoint (uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd. More...
void | lcd_clear (uint16_t color)
this function is clear the lcd. More...
void | lcd_char_show (uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode)
this function is show char to lcd More...
void | lcd_string_show (uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p)
this function is show string to lcd More...
void | lcd_fill (uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color)
this function is fill in lcd with concolorous More...
void | lcd_color_fill (uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color)
this function is fill in lcd with color-pointer More...

Variables

lcd_dev_type lcd_dev_struct
lcd_dev_type * lcd_struct

Detailed Description

xmc_lcd program file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c.


AT32F435/437 Firmwary Library: xmc_lcd.c Source File

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • lcd
at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c
Go to the documentation of this file.
1
27#include "xmc_lcd.h"
28#include "font.h"
29
38 lcd_dev_type lcd_dev_struct =
39{
40 0,
41 xmc_init,
42 lcd_init,
43 lcd_setblock,
44 lcd_drawpoint,
45 lcd_clear,
46};
47
48 lcd_dev_type *lcd_struct;
49
57void xmc_init(void)
58{
59 gpio_init_type gpio_init_struct = {0};
60 xmc_norsram_init_type xmc_norsram_init_struct;
61 xmc_norsram_timing_init_type rw_timing_struct, w_timing_struct;
62
63 /* enable the gpio clock */
64 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
65 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
67 /* enable the xmc clock */
68 crm_periph_clock_enable(CRM_XMC_PERIPH_CLOCK, TRUE);
69
70 /*-- gpio configuration ------------------------------------------------------*/
71 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE2, GPIO_MUX_14);
72 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE4, GPIO_MUX_14);
73 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE5, GPIO_MUX_14);
74 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE11, GPIO_MUX_14);
75 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE12, GPIO_MUX_14);
76 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE5, GPIO_MUX_10);
77 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE8, GPIO_MUX_12);
78 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE9, GPIO_MUX_12);
79 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE10, GPIO_MUX_12);
80 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE14, GPIO_MUX_12);
81 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE15, GPIO_MUX_12);
82
83 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE7, GPIO_MUX_12);
84 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE8, GPIO_MUX_12);
85 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE9, GPIO_MUX_12);
86 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE10, GPIO_MUX_12);
87 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE11, GPIO_MUX_12);
88 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE12, GPIO_MUX_12);
89 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE13, GPIO_MUX_12);
90 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE14, GPIO_MUX_12);
91 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE15, GPIO_MUX_12);
92
93 /* lcd data lines configuration */
94 gpio_init_struct.gpio_pins = GPIO_PINS_2 | GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_11| GPIO_PINS_12;
95 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
96 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
97 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
98 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
99 gpio_init(GPIOC, &gpio_init_struct);
100
101
102 gpio_init_struct.gpio_pins = GPIO_PINS_5 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_14 | GPIO_PINS_15;
103 gpio_init(GPIOD, &gpio_init_struct);
104
105 gpio_init_struct.gpio_pins = GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11 | GPIO_PINS_12 | GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
106 gpio_init(GPIOE, &gpio_init_struct);
107
108 /*-- xmc configuration ------------------------------------------------------*/
109 xmc_norsram_default_para_init(&xmc_norsram_init_struct);
110 xmc_norsram_init_struct.subbank = XMC_BANK1_NOR_SRAM4;
111 xmc_norsram_init_struct.data_addr_multiplex = XMC_DATA_ADDR_MUX_DISABLE;
112 xmc_norsram_init_struct.device = XMC_DEVICE_SRAM;
113 xmc_norsram_init_struct.bus_type = XMC_BUSTYPE_16_BITS;
114 xmc_norsram_init_struct.burst_mode_enable = XMC_BURST_MODE_DISABLE;
115 xmc_norsram_init_struct.asynwait_enable = XMC_ASYN_WAIT_DISABLE;
116 xmc_norsram_init_struct.wait_signal_lv = XMC_WAIT_SIGNAL_LEVEL_LOW;
117 xmc_norsram_init_struct.wrapped_mode_enable = XMC_WRAPPED_MODE_DISABLE;
118 xmc_norsram_init_struct.wait_signal_config = XMC_WAIT_SIGNAL_SYN_BEFORE;
119 xmc_norsram_init_struct.write_enable = XMC_WRITE_OPERATION_ENABLE;
120 xmc_norsram_init_struct.wait_signal_enable = XMC_WAIT_SIGNAL_DISABLE;
121 xmc_norsram_init_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
122 xmc_norsram_init_struct.write_burst_syn = XMC_WRITE_BURST_SYN_DISABLE;
123 xmc_nor_sram_init(&xmc_norsram_init_struct);
124
125 /* timing configuration */
126 xmc_norsram_timing_default_para_init(&rw_timing_struct, &w_timing_struct);
127 rw_timing_struct.subbank = XMC_BANK1_NOR_SRAM4;
128 rw_timing_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
129 rw_timing_struct.addr_setup_time = 0x2;
130 rw_timing_struct.addr_hold_time = 0x0;
131 rw_timing_struct.data_setup_time = 0x2;
132 rw_timing_struct.bus_latency_time = 0x0;
133 rw_timing_struct.clk_psc = 0x0;
134 rw_timing_struct.data_latency_time = 0x0;
135 rw_timing_struct.mode = XMC_ACCESS_MODE_A;
136 w_timing_struct.subbank = XMC_BANK1_NOR_SRAM4;
137 w_timing_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
138 w_timing_struct.addr_setup_time = 0x2;
139 w_timing_struct.addr_hold_time = 0x0;
140 w_timing_struct.data_setup_time = 0x2;
141 w_timing_struct.bus_latency_time = 0x0;
142 w_timing_struct.clk_psc = 0x0;
143 w_timing_struct.data_latency_time = 0x0;
144 w_timing_struct.mode = XMC_ACCESS_MODE_A;
145 xmc_nor_sram_timing_config(&rw_timing_struct, &w_timing_struct);
146
147 /* enable xmc_bank1_nor_sram4 */
148 xmc_nor_sram_enable(XMC_BANK1_NOR_SRAM4, TRUE);
149
150 gpio_init_struct.gpio_pins = GPIO_PINS_0;
151 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
152 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
153 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
154 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
155 gpio_init(GPIOC, &gpio_init_struct);
156}
157
165void lcd_init(void)
166{
167 /* init xmc */
168 lcd_struct->xmc_init();
169
170 delay_ms(50);
171
172 /* read id */
173 lcd_wr_command(0x0000);
174 delay_ms(5);
175
176 lcd_struct->lcd_id = lcd_rd_data();
177 lcd_wr_command(0xd3);
178
179 lcd_struct->lcd_id = lcd_rd_data();
180 lcd_struct->lcd_id = lcd_rd_data();
181 lcd_struct->lcd_id = lcd_rd_data();
182 lcd_struct->lcd_id = lcd_rd_data();
183 lcd_struct->lcd_id = lcd_struct->lcd_id << 8;
184 lcd_struct->lcd_id |= lcd_rd_data();
185
186 lcd_wr_command(0xcf);
187 lcd_wr_data(0x00);
188 lcd_wr_data(0xc1);
189 lcd_wr_data(0x30);
190 lcd_wr_command(0xed);
191 lcd_wr_data(0x64);
192 lcd_wr_data(0x03);
193 lcd_wr_data(0x12);
194 lcd_wr_data(0x81);
195 lcd_wr_command(0xe8);
196 lcd_wr_data(0x85);
197 lcd_wr_data(0x10);
198 lcd_wr_data(0x7a);
199 lcd_wr_command(0xcb);
200 lcd_wr_data(0x39);
201 lcd_wr_data(0x2c);
202 lcd_wr_data(0x00);
203 lcd_wr_data(0x34);
204 lcd_wr_data(0x02);
205 lcd_wr_command(0xf7);
206 lcd_wr_data(0x20);
207 lcd_wr_command(0xea);
208 lcd_wr_data(0x00);
209 lcd_wr_data(0x00);
210 lcd_wr_command(0xc0);
211 lcd_wr_data(0x1b);
212 lcd_wr_command(0xc1);
213 lcd_wr_data(0x01);
214 lcd_wr_command(0xc5);
215 lcd_wr_data(0x30);
216 lcd_wr_data(0x30);
217 lcd_wr_command(0xc7);
218 lcd_wr_data(0xb7);
219 lcd_wr_command(0x36);
220 lcd_wr_data(0x48);
221 lcd_wr_command(0x3a);
222 lcd_wr_data(0x55);
223 lcd_wr_command(0xb1);
224 lcd_wr_data(0x00);
225 lcd_wr_data(0x1a);
226 lcd_wr_command(0xb6);
227 lcd_wr_data(0x0a);
228 lcd_wr_data(0xa2);
229 lcd_wr_command(0xf2);
230 lcd_wr_data(0x00);
231 lcd_wr_command(0x26);
232 lcd_wr_data(0x01);
233 lcd_wr_command(0xe0);
234 lcd_wr_data(0x0f);
235 lcd_wr_data(0x2a);
236 lcd_wr_data(0x28);
237 lcd_wr_data(0x08);
238 lcd_wr_data(0x0e);
239 lcd_wr_data(0x08);
240 lcd_wr_data(0x54);
241 lcd_wr_data(0xa9);
242 lcd_wr_data(0x43);
243 lcd_wr_data(0x0a);
244 lcd_wr_data(0x0f);
245 lcd_wr_data(0x00);
246 lcd_wr_data(0x00);
247 lcd_wr_data(0x00);
248 lcd_wr_data(0x00);
249 lcd_wr_command(0xe1);
250 lcd_wr_data(0x00);
251 lcd_wr_data(0x15);
252 lcd_wr_data(0x17);
253 lcd_wr_data(0x07);
254 lcd_wr_data(0x11);
255 lcd_wr_data(0x06);
256 lcd_wr_data(0x2b);
257 lcd_wr_data(0x56);
258 lcd_wr_data(0x3c);
259 lcd_wr_data(0x05);
260 lcd_wr_data(0x10);
261 lcd_wr_data(0x0f);
262 lcd_wr_data(0x3f);
263 lcd_wr_data(0x3f);
264 lcd_wr_data(0x0f);
265 lcd_wr_command(0x2b);
266 lcd_wr_data(0x00);
267 lcd_wr_data(0x00);
268 lcd_wr_data(0x01);
269 lcd_wr_data(0x3f);
270 lcd_wr_command(0x2a);
271 lcd_wr_data(0x00);
272 lcd_wr_data(0x00);
273 lcd_wr_data(0x00);
274 lcd_wr_data(0xef);
275 lcd_wr_command(0x11);
276 delay_ms(120);
277 lcd_wr_command(0x29);
278 lcd_wr_command(0x36);
279 lcd_wr_data(0x08);
280 lcd_wr_command(0x2a);
281 lcd_wr_data(0x00);
282 lcd_wr_data(0x00);
283 lcd_wr_data(0xef >> 8);
284 lcd_wr_data(0xef & 0xff);
285 lcd_wr_command(0x2b);
286 lcd_wr_data(0x00);
287 lcd_wr_data(0x00);
288 lcd_wr_data(0x13f >> 8);
289 lcd_wr_data(0x13f & 0xff);
290 lcd_wr_command(0x36); //setting the display direction
291 lcd_wr_data(0x68); //90 degree
292 LCD_BL_HIGH;
293}
294
300void lcd_wr_command(uint16_t command)
301{
302 *(uint16_t*) XMC_LCD_COMMAND = command;
303}
304
310void lcd_wr_data(uint16_t data)
311{
312 *(uint16_t*) XMC_LCD_DATA = data;
313}
314
315uint16_t lcd_rd_data(void)
316{
317 uint16_t data;
318
319 data = *(uint16_t*)XMC_LCD_DATA;
320
321 return data;
322}
323
332void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
333{
334 /* set row coordinates */
335 lcd_wr_command(0x2a);
336 lcd_wr_data(xstart >> 8);
337 lcd_wr_data(xstart);
338 lcd_wr_data(xend >> 8);
339 lcd_wr_data(xend);
340
341 /* set column coordinates */
342 lcd_wr_command(0x2b);
343 lcd_wr_data(ystart >> 8);
344 lcd_wr_data(ystart);
345 lcd_wr_data(yend >> 8);
346 lcd_wr_data(yend);
347
348 /* enable write menory */
349 lcd_wr_command(0x2c);
350}
351
357void lcd_writeonepoint(uint16_t color)
358{
359 lcd_wr_data(color);
360}
361
367void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
368{
369 lcd_struct->lcd_setblock(x, y ,x ,y);
370
371 lcd_writeonepoint(color);
372}
373
379void lcd_clear(uint16_t color)
380{
381 uint32_t i;
382
383 lcd_struct->lcd_setblock(0, 0, LCD_W, LCD_H);
384
385 for(i = 0; i < 76800; i++)
386 {
387 lcd_writeonepoint(color);
388 }
389}
390
400void lcd_char_show(uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode)
401{
402 uint8_t temp, t1, t;
403 uint16_t y0 = y;
404 uint8_t csize = (size / 8 + ((size % 8) ? 1 : 0)) * (size / 2);
405 num = num - ' ';
406
407 for(t = 0; t < csize; t++)
408 {
409 if(size == 12)
410 {
411 temp = asc2_1206[num][t];
412 }
413 else if(size == 16)
414 {
415 temp = asc2_1608[num][t];
416 }
417 else if(size == 24)
418 {
419 temp = asc2_2412[num][t];
420 }
421 else if(size == 32)
422 {
423 temp = asc2_3216[num][t];
424 }
425 else
426 {
427 return;
428 }
429
430 for(t1 = 0; t1 < 8; t1++)
431 {
432 if(temp & 0x80)
433 {
434 lcd_drawpoint(x, y, RED);
435 }
436 else if(mode == 0)
437 {
438 lcd_drawpoint(x, y, WHITE);
439 }
440
441 temp <<= 1;
442 y++;
443
444 if(y >= LCD_H)
445 {
446 return;
447 }
448
449 if((y - y0) == size)
450 {
451 y = y0;
452 x++;
453
454 if(x >= LCD_W)
455 {
456 return;
457 }
458
459 break;
460 }
461 }
462 }
463}
464
474void lcd_string_show(uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p)
475{
476 uint8_t x0 = x;
477 width += x;
478 height += y;
479
480 while((*p <= '~') && (*p >= ' '))
481 {
482 if(x >= width)
483 {
484 x = x0;
485 y += size;
486 }
487
488 if(y >= height)
489 {
490 break;
491 }
492
493 lcd_char_show(x, y, *p, size, 0);
494 x += size / 2;
495 p++;
496 }
497}
498
508void lcd_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color)
509{
510 uint32_t i, num;
511 num = (ex - sx) * (ey - sy);
512 lcd_struct->lcd_setblock(sx, sy, ex, ey);
513
514 for(i = 0; i < num; i++)
515 {
516 lcd_writeonepoint(color);
517 }
518}
519
529void lcd_color_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color)
530{
531 uint16_t height, width;
532 uint16_t i, j;
533
534 width = ex - sx + 1;
535 height = ey - sy + 1;
536 lcd_struct->lcd_setblock(sx, sy, ex, ey);
537
538 for(i = 0; i < height; i++)
539 {
540 for(j = 0; j < width; j++)
541 {
542 lcd_writeonepoint(color[i * width + j]);
543 }
544 }
545}
font.h
xmc_lcd.h
xmc_lcd program header
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
lcd_color_fill
void lcd_color_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color)
this function is fill in lcd with color-pointer
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:529
lcd_setblock
void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:332
LCD_H
#define LCD_H
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:79
lcd_char_show
void lcd_char_show(uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode)
this function is show char to lcd
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:400
lcd_dev_struct
lcd_dev_type lcd_dev_struct
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:38
lcd_init
void lcd_init(void)
configures the lcd. this function must be called before any write/read operation on the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:165
lcd_string_show
void lcd_string_show(uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p)
this function is show string to lcd
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:474
lcd_fill
void lcd_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color)
this function is fill in lcd with concolorous
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:508
lcd_drawpoint
void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:367
WHITE
#define WHITE
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:84
lcd_wr_command
void lcd_wr_command(uint16_t command)
this function is write command to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:300
RED
#define RED
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:90
lcd_rd_data
uint16_t lcd_rd_data(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:315
LCD_W
#define LCD_W
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:78
asc2_2412
const unsigned char asc2_2412[95][36]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h:234
asc2_3216
const unsigned char asc2_3216[95][128]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h:332
asc2_1206
const unsigned char asc2_1206[95][12]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h:38
lcd_clear
void lcd_clear(uint16_t color)
this function is clear the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:379
asc2_1608
const unsigned char asc2_1608[95][16]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h:136
lcd_struct
lcd_dev_type * lcd_struct
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:48
lcd_writeonepoint
void lcd_writeonepoint(uint16_t color)
this function is write one point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:357
lcd_wr_data
void lcd_wr_data(uint16_t data)
this function is write data to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:310
LCD_BL_HIGH
#define LCD_BL_HIGH
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:81
xmc_init
void xmc_init(void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write...
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:57
j
uint32_t j
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:44
XMC_LCD_COMMAND
#define XMC_LCD_COMMAND
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:65
XMC_LCD_DATA
#define XMC_LCD_DATA
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:66
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_XMC_PERIPH_CLOCK
@ CRM_XMC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:123
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f435_437_gpio.h:146
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_10
@ GPIO_MUX_10
Definition: at32f435_437_gpio.h:166
GPIO_MUX_14
@ GPIO_MUX_14
Definition: at32f435_437_gpio.h:170
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f435_437_gpio.h:64
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
xmc_nor_sram_init
void xmc_nor_sram_init(xmc_norsram_init_type *xmc_norsram_init_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_norsraminitstruct.
Definition: at32f435_437_xmc.c:78
xmc_norsram_timing_default_para_init
void xmc_norsram_timing_default_para_init(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
fill each xmc_rw_timing_struct and xmc_w_timing_struct member with its default value.
Definition: at32f435_437_xmc.c:176
xmc_nor_sram_timing_config
void xmc_nor_sram_timing_config(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_rw_timing_struct a...
Definition: at32f435_437_xmc.c:113
xmc_norsram_default_para_init
void xmc_norsram_default_para_init(xmc_norsram_init_type *xmc_nor_sram_init_struct)
fill each xmc_nor_sram_init_struct member with its default value.
Definition: at32f435_437_xmc.c:150
xmc_nor_sram_enable
void xmc_nor_sram_enable(xmc_nor_sram_subbank_type xmc_subbank, confirm_state new_state)
enable or disable the specified nor/sram memory bank.
Definition: at32f435_437_xmc.c:210
XMC_WAIT_SIGNAL_DISABLE
@ XMC_WAIT_SIGNAL_DISABLE
Definition: at32f435_437_xmc.h:101
XMC_WAIT_SIGNAL_SYN_BEFORE
@ XMC_WAIT_SIGNAL_SYN_BEFORE
Definition: at32f435_437_xmc.h:196
XMC_WRITE_OPERATION_ENABLE
@ XMC_WRITE_OPERATION_ENABLE
Definition: at32f435_437_xmc.h:93
XMC_WRITE_BURST_SYN_DISABLE
@ XMC_WRITE_BURST_SYN_DISABLE
Definition: at32f435_437_xmc.h:110
XMC_BURST_MODE_DISABLE
@ XMC_BURST_MODE_DISABLE
Definition: at32f435_437_xmc.h:65
XMC_DATA_ADDR_MUX_DISABLE
@ XMC_DATA_ADDR_MUX_DISABLE
Definition: at32f435_437_xmc.h:56
XMC_BUSTYPE_16_BITS
@ XMC_BUSTYPE_16_BITS
Definition: at32f435_437_xmc.h:179
XMC_WRITE_TIMING_ENABLE
@ XMC_WRITE_TIMING_ENABLE
Definition: at32f435_437_xmc.h:120
XMC_BANK1_NOR_SRAM4
@ XMC_BANK1_NOR_SRAM4
Definition: at32f435_437_xmc.h:149
XMC_ASYN_WAIT_DISABLE
@ XMC_ASYN_WAIT_DISABLE
Definition: at32f435_437_xmc.h:74
XMC_WRAPPED_MODE_DISABLE
@ XMC_WRAPPED_MODE_DISABLE
Definition: at32f435_437_xmc.h:83
XMC_ACCESS_MODE_A
@ XMC_ACCESS_MODE_A
Definition: at32f435_437_xmc.h:205
XMC_WAIT_SIGNAL_LEVEL_LOW
@ XMC_WAIT_SIGNAL_LEVEL_LOW
Definition: at32f435_437_xmc.h:187
XMC_DEVICE_SRAM
@ XMC_DEVICE_SRAM
Definition: at32f435_437_xmc.h:168
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
lcd_dev_type
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:44
lcd_dev_type::lcd_setblock
void(* lcd_setblock)(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:48
lcd_dev_type::lcd_id
uint16_t lcd_id
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:45
lcd_dev_type::xmc_init
void(* xmc_init)(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:46
xmc_norsram_init_type
xmc nor/sram init structure definition
Definition: at32f435_437_xmc.h:409
xmc_norsram_init_type::wait_signal_enable
xmc_wait_signal_type wait_signal_enable
Definition: at32f435_437_xmc.h:420
xmc_norsram_init_type::data_addr_multiplex
xmc_data_addr_mux_type data_addr_multiplex
Definition: at32f435_437_xmc.h:411
xmc_norsram_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:421
xmc_norsram_init_type::burst_mode_enable
xmc_burst_access_mode_type burst_mode_enable
Definition: at32f435_437_xmc.h:414
xmc_norsram_init_type::bus_type
xmc_data_width_type bus_type
Definition: at32f435_437_xmc.h:413
xmc_norsram_init_type::device
xmc_memory_type device
Definition: at32f435_437_xmc.h:412
xmc_norsram_init_type::wait_signal_lv
xmc_wait_signal_polarity_type wait_signal_lv
Definition: at32f435_437_xmc.h:416
xmc_norsram_init_type::wrapped_mode_enable
xmc_wrap_mode_type wrapped_mode_enable
Definition: at32f435_437_xmc.h:417
xmc_norsram_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:410
xmc_norsram_init_type::write_burst_syn
xmc_write_burst_type write_burst_syn
Definition: at32f435_437_xmc.h:422
xmc_norsram_init_type::asynwait_enable
xmc_asyn_wait_type asynwait_enable
Definition: at32f435_437_xmc.h:415
xmc_norsram_init_type::wait_signal_config
xmc_wait_timing_type wait_signal_config
Definition: at32f435_437_xmc.h:418
xmc_norsram_init_type::write_enable
xmc_write_operation_type write_enable
Definition: at32f435_437_xmc.h:419
xmc_norsram_timing_init_type
nor/sram banks timing parameters
Definition: at32f435_437_xmc.h:393
xmc_norsram_timing_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:395
xmc_norsram_timing_init_type::data_latency_time
uint32_t data_latency_time
Definition: at32f435_437_xmc.h:401
xmc_norsram_timing_init_type::addr_hold_time
uint32_t addr_hold_time
Definition: at32f435_437_xmc.h:397
xmc_norsram_timing_init_type::bus_latency_time
uint32_t bus_latency_time
Definition: at32f435_437_xmc.h:399
xmc_norsram_timing_init_type::addr_setup_time
uint32_t addr_setup_time
Definition: at32f435_437_xmc.h:396
xmc_norsram_timing_init_type::mode
xmc_access_mode_type mode
Definition: at32f435_437_xmc.h:402
xmc_norsram_timing_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:394
xmc_norsram_timing_init_type::clk_psc
uint32_t clk_psc
Definition: at32f435_437_xmc.h:400
xmc_norsram_timing_init_type::data_setup_time
uint32_t data_setup_time
Definition: at32f435_437_xmc.h:398


AT32F435/437 Firmwary Library: xmc_lcd.h File Reference

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • lcd
Data Structures | Macros | Functions | Variables
at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h File Reference

xmc_lcd program header More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Data Structures

struct lcd_dev_type

Macros

#define | XMC_LCD_COMMAND (0x6C000000)
#define | XMC_LCD_DATA (0x6C000800)
#define | LCD_W 320
#define | LCD_H 240
#define | LCD_BL_HIGH gpio_bits_set(GPIOC,GPIO_PINS_0)
#define | LCD_BL_LOW gpio_bits_reset(GPIOC,GPIO_PINS_0)
#define | WHITE 0xFFFF
#define | BLACK 0x0000
#define | BLUE 0x001F
#define | BRED 0xF81F
#define | GRED 0xFFE0
#define | GBLUE 0x07FF
#define | RED 0xF800
#define | MAGENTA 0xF81F
#define | GREEN 0x07E0
#define | CYAN 0x7FFF
#define | YELLOW 0xFFE0
#define | BROWN 0xBC40
#define | BRRED 0xFC07
#define | GRAY 0x8430

Functions

void | xmc_init (void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_init (void)
configures the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_wr_command (uint16_t command)
this function is write command to lcd. More...
void | lcd_wr_data (uint16_t data)
this function is write data to lcd. More...
uint16_t | lcd_rd_data (void)
void | lcd_setblock (uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd. More...
void | lcd_writeonepoint (uint16_t color)
this function is write one point to lcd. More...
void | lcd_drawpoint (uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd. More...
void | lcd_clear (uint16_t color)
this function is clear the lcd. More...
void | lcd_char_show (uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode)
this function is show char to lcd More...
void | lcd_string_show (uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p)
this function is show string to lcd More...
void | lcd_fill (uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color)
this function is fill in lcd with concolorous More...
void | lcd_color_fill (uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color)
this function is fill in lcd with color-pointer More...

Variables

lcd_dev_type lcd_dev_struct
lcd_dev_type * lcd_struct
static uint16_t LCD_ID

Detailed Description

xmc_lcd program header

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h.


AT32F435/437 Firmwary Library: xmc_lcd.h Source File

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • lcd
at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h
Go to the documentation of this file.
1
26#ifndef __XMC_LCD_H
27#define __XMC_LCD_H
28
29#include "at32f435_437_board.h"
30
43typedef struct
44{
45 uint16_t lcd_id;
46 void (*xmc_init)(void);
47 void (*lcd_init)(void);
48 void (*lcd_setblock)(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend);
49 void (*draw_point)(uint16_t x, uint16_t y, uint16_t color);
50 void (*lcd_clear)(uint16_t color);
51} lcd_dev_type;
52
57extern lcd_dev_type lcd_dev_struct;
58extern lcd_dev_type *lcd_struct;
59
64/* the address of write data & command (xmc_a0) */
65#define XMC_LCD_COMMAND (0x6C000000)
66#define XMC_LCD_DATA (0x6C000800)
78#define LCD_W 320
79#define LCD_H 240
80
81#define LCD_BL_HIGH gpio_bits_set(GPIOC,GPIO_PINS_0)
82#define LCD_BL_LOW gpio_bits_reset(GPIOC,GPIO_PINS_0)
83static uint16_t LCD_ID;
84#define WHITE 0xFFFF
85#define BLACK 0x0000
86#define BLUE 0x001F
87#define BRED 0xF81F
88#define GRED 0xFFE0
89#define GBLUE 0x07FF
90#define RED 0xF800
91#define MAGENTA 0xF81F
92#define GREEN 0x07E0
93#define CYAN 0x7FFF
94#define YELLOW 0xFFE0
95#define BROWN 0xBC40
96#define BRRED 0xFC07
97#define GRAY 0x8430
98
103void xmc_init(void);
104void lcd_init(void);
105void lcd_wr_command(uint16_t command);
106void lcd_wr_data(uint16_t data);
107uint16_t lcd_rd_data(void);
108void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend);
109void lcd_writeonepoint(uint16_t color);
110void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color);
111void lcd_clear(uint16_t color);
112void lcd_char_show(uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode);
113void lcd_string_show(uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p);
114void lcd_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color);
115void lcd_color_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color);
116
129#endif
130
131
at32f435_437_board.h
lcd_color_fill
void lcd_color_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color)
this function is fill in lcd with color-pointer
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:529
lcd_setblock
void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:332
lcd_char_show
void lcd_char_show(uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode)
this function is show char to lcd
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:400
lcd_dev_struct
lcd_dev_type lcd_dev_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:38
lcd_init
void lcd_init(void)
configures the lcd. this function must be called before any write/read operation on the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:165
lcd_string_show
void lcd_string_show(uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p)
this function is show string to lcd
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:474
lcd_fill
void lcd_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color)
this function is fill in lcd with concolorous
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:508
LCD_ID
static uint16_t LCD_ID
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:83
lcd_drawpoint
void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:367
lcd_wr_command
void lcd_wr_command(uint16_t command)
this function is write command to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:300
lcd_rd_data
uint16_t lcd_rd_data(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:315
lcd_clear
void lcd_clear(uint16_t color)
this function is clear the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:379
lcd_struct
lcd_dev_type * lcd_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:48
lcd_writeonepoint
void lcd_writeonepoint(uint16_t color)
this function is write one point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:357
lcd_wr_data
void lcd_wr_data(uint16_t data)
this function is write data to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:310
xmc_init
void xmc_init(void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write...
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:57
lcd_dev_type
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:44


AT32F435/437 Firmwary Library: ov2640.c File Reference

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • ov2640
Macros | Functions | Variables
at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c File Reference
#include "ov2640.h"
#include "ov2640cfg.h"
#include "at32f435_437.h"
#include "i2c_application.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0x2FFFFFF
#define | I2Cx_CLKCTRL 0x30F05292
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_DMA DMA1
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_AF GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_AF GPIO_MUX_4

Functions

error_status | ov2640_reg_write (uint8_t reg, uint8_t data)
write register to ov2640 More...
error_status | ov2640_reg_read (uint8_t reg, uint8_t *data)
read register from ov2640 More...
error_status | ov2640_init (void)
void | ov2640_jpeg_mode (void)
void | ov2640_rgb565_mode (void)
void | ov2640_auto_exposure (u8 level)
void | ov2640_light_mode (u8 mode)
void | ov2640_color_saturation (u8 sat)
void | ov2640_brightness (u8 bright)
void | ov2640_contrast (u8 contrast)
void | ov2640_special_effects (u8 eft)
void | ov2640_color_bar (u8 sw)
void | ov2640_window_set (u16 sx, u16 sy, u16 width, u16 height)
u8 | ov2640_outsize_set (u16 width, u16 height)
u8 | ov2640_imagewin_set (u16 offx, u16 offy, u16 width, u16 height)
u8 | ov2640_imagesize_set (u16 width, u16 height)
void | ov2640_i2c_init (void)
ov2640 i2c initialize More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...

Variables

i2c_handle_type hi2cx
i2c_status_type STA
static const u8 OV2640_AUTOEXPOSURE_LEVEL [5][8]


AT32F435/437 Firmwary Library: ov2640.c Source File

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • ov2640
at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c
Go to the documentation of this file.
1#include "ov2640.h"
2#include "ov2640cfg.h"
3#include "at32f435_437.h"
4#include "i2c_application.h"
5#include "at32f435_437_board.h"
6
15#define I2C_TIMEOUT 0x2FFFFFF
16
17#define I2Cx_CLKCTRL 0x30F05292
18#define I2Cx_ADDRESS 0xA0
19
20#define I2Cx_PORT I2C1
21#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
22#define I2Cx_DMA DMA1
23#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
24
25#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
26#define I2Cx_SCL_GPIO_PIN GPIO_PINS_6
27#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
28#define I2Cx_SCL_GPIO_PORT GPIOB
29#define I2Cx_SCL_GPIO_AF GPIO_MUX_4
30
31#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
32#define I2Cx_SDA_GPIO_PIN GPIO_PINS_7
33#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
34#define I2Cx_SDA_GPIO_PORT GPIOB
35#define I2Cx_SDA_GPIO_AF GPIO_MUX_4
36
37 i2c_handle_type hi2cx;
38 i2c_status_type STA;
39
46 error_status ov2640_reg_write(uint8_t reg, uint8_t data)
47{
48 uint8_t temp_data[2];
49 temp_data[0] = reg;
50 temp_data[1] = data;
51
52 if((STA = i2c_master_transmit(&hi2cx, (uint16_t)OV2640_ADDR, (uint8_t*)temp_data, 2, 1000000)) != I2C_OK)
53 {
54 return ERROR;
55 }
56
57 return SUCCESS;
58}
59
66 error_status ov2640_reg_read(uint8_t reg, uint8_t *data)
67{
68 uint8_t temp_data[1];
69 temp_data[0] = reg;
70
71 if(i2c_master_transmit(&hi2cx, (uint16_t)OV2640_ADDR, (uint8_t*)temp_data, 1, 10000) != I2C_OK)
72 {
73 return ERROR;
74 }
75
76 if(i2c_master_receive(&hi2cx, (uint16_t)OV2640_ADDR, data, 1, 10000) != I2C_OK)
77 {
78 return ERROR;
79 }
80
81 return SUCCESS;
82}
83
84 error_status ov2640_init(void)
85{
86 u16 i=0;
87 uint16_t reg;
88 uint8_t temp;
89 gpio_init_type gpio_initure;
90
91 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
92 gpio_default_para_init(&gpio_initure);
93 /* DVP_RST Pin-PD6 */
94 gpio_initure.gpio_pins = GPIO_PINS_3 | GPIO_PINS_1;
95 gpio_initure.gpio_mode = GPIO_MODE_OUTPUT;
96 gpio_initure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
97 gpio_initure.gpio_pull = GPIO_PULL_UP;
98 gpio_initure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
99 gpio_init(GPIOC, &gpio_initure);
100
101 OV2640_RST_LOW; //POWER ON;
102 delay_ms(10);
103 OV2640_PWRON_LOW;
104 delay_ms(10);
105 OV2640_RST_HIGH;
106 delay_ms(10);
107
108 ov2640_i2c_init();
109 ov2640_reg_write(OV2640_DSP_RA_DLMT, 0x01);
110 ov2640_reg_write(OV2640_SENSOR_COM7, 0x80);
111 delay_ms(50);
112 ov2640_reg_read(OV2640_SENSOR_MIDH, &temp);
113 reg = (uint16_t)temp << 8;
114 ov2640_reg_read(OV2640_SENSOR_MIDL, &temp);
115 reg |= temp;
116 if(reg!=OV2640_MID)
117 {
118 return ERROR;
119 }
120 ov2640_reg_read(OV2640_SENSOR_PIDH, &temp);
121 reg = (uint16_t)temp << 8;
122 ov2640_reg_read(OV2640_SENSOR_PIDL, &temp);
123 reg |= temp;
124 if(reg!=OV2640_PID)
125 {
126 return ERROR;
127 }
128 for(i=0;i<sizeof(ov2640_svga_init_reg_tbl)/2;i++)
129 {
130 ov2640_reg_write(ov2640_svga_init_reg_tbl[i][0],ov2640_svga_init_reg_tbl[i][1]);
131 }
132 return SUCCESS; //ok
133}
134
135//OV2640 jpeg mode
136void ov2640_jpeg_mode(void)
137{
138 u16 i=0;
139
140 for(i=0;i<(sizeof(ov2640_yuv422_reg_tbl)/2);i++)
141 {
142 ov2640_reg_write(ov2640_yuv422_reg_tbl[i][0],ov2640_yuv422_reg_tbl[i][1]);
143 }
144
145 for(i=0;i<(sizeof(ov2640_jpeg_reg_tbl)/2);i++)
146 {
147 ov2640_reg_write(ov2640_jpeg_reg_tbl[i][0],ov2640_jpeg_reg_tbl[i][1]);
148 }
149}
150//OV2640 RGB565 mode
151void ov2640_rgb565_mode(void)
152{
153 u16 i=0;
154 for(i=0;i<(sizeof(ov2640_rgb565_reg_tbl)/2);i++)
155 {
156 ov2640_reg_write(ov2640_rgb565_reg_tbl[i][0],ov2640_rgb565_reg_tbl[i][1]);
157 }
158}
159
160const static u8 OV2640_AUTOEXPOSURE_LEVEL[5][8]=
161{
162 {
163 0xFF,0x01,
164 0x24,0x20,
165 0x25,0x18,
166 0x26,0x60,
167 },
168 {
169 0xFF,0x01,
170 0x24,0x34,
171 0x25,0x1c,
172 0x26,0x00,
173 },
174 {
175 0xFF,0x01,
176 0x24,0x3e,
177 0x25,0x38,
178 0x26,0x81,
179 },
180 {
181 0xFF,0x01,
182 0x24,0x48,
183 0x25,0x40,
184 0x26,0x81,
185 },
186 {
187 0xFF,0x01,
188 0x24,0x58,
189 0x25,0x50,
190 0x26,0x92,
191 },
192};
193
194//level:0~4
195void ov2640_auto_exposure(u8 level)
196{
197 u8 i;
198 u8 *p=(u8*)OV2640_AUTOEXPOSURE_LEVEL[level];
199 for(i=0;i<4;i++)
200 {
201 ov2640_reg_write(p[i*2],p[i*2+1]);
202 }
203}
204
205//0:auto
206//1:sunny
207//2:cloudy
208//3:office
209//4:home
210void ov2640_light_mode(u8 mode)
211{
212 u8 regccval=0X5E;//Sunny
213 u8 regcdval=0X41;
214 u8 regceval=0X54;
215 switch(mode)
216 {
217 case 0://auto
218 ov2640_reg_write(0XFF,0X00);
219 ov2640_reg_write(0XC7,0X10);//AWB ON
220 return;
221 case 2://cloudy
222 regccval=0X65;
223 regcdval=0X41;
224 regceval=0X4F;
225 break;
226 case 3://office
227 regccval=0X52;
228 regcdval=0X41;
229 regceval=0X66;
230 break;
231 case 4://home
232 regccval=0X42;
233 regcdval=0X3F;
234 regceval=0X71;
235 break;
236 }
237 ov2640_reg_write(0XFF,0X00);
238 ov2640_reg_write(0XC7,0X40); //AWB OFF
239 ov2640_reg_write(0XCC,regccval);
240 ov2640_reg_write(0XCD,regcdval);
241 ov2640_reg_write(0XCE,regceval);
242}
243
244//0:-2
245//1:-1
246//2,0
247//3,+1
248//4,+2
249void ov2640_color_saturation(u8 sat)
250{
251 u8 reg7dval=((sat+2)<<4)|0X08;
252 ov2640_reg_write(0XFF,0X00);
253 ov2640_reg_write(0X7C,0X00);
254 ov2640_reg_write(0X7D,0X02);
255 ov2640_reg_write(0X7C,0X03);
256 ov2640_reg_write(0X7D,reg7dval);
257 ov2640_reg_write(0X7D,reg7dval);
258}
259
260//0:(0X00)-2
261//1:(0X10)-1
262//2,(0X20) 0
263//3,(0X30)+1
264//4,(0X40)+2
265void ov2640_brightness(u8 bright)
266{
267 ov2640_reg_write(0xff, 0x00);
268 ov2640_reg_write(0x7c, 0x00);
269 ov2640_reg_write(0x7d, 0x04);
270 ov2640_reg_write(0x7c, 0x09);
271 ov2640_reg_write(0x7d, bright<<4);
272 ov2640_reg_write(0x7d, 0x00);
273}
274
275//0:-2
276//1:-1
277//2,0
278//3,+1
279//4,+2
280void ov2640_contrast(u8 contrast)
281{
282 u8 reg7d0val=0X20;
283 u8 reg7d1val=0X20;
284 switch(contrast)
285 {
286 case 0://-2
287 reg7d0val=0X18;
288 reg7d1val=0X34;
289 break;
290 case 1://-1
291 reg7d0val=0X1C;
292 reg7d1val=0X2A;
293 break;
294 case 3://1
295 reg7d0val=0X24;
296 reg7d1val=0X16;
297 break;
298 case 4://2
299 reg7d0val=0X28;
300 reg7d1val=0X0C;
301 break;
302 }
303 ov2640_reg_write(0xff,0x00);
304 ov2640_reg_write(0x7c,0x00);
305 ov2640_reg_write(0x7d,0x04);
306 ov2640_reg_write(0x7c,0x07);
307 ov2640_reg_write(0x7d,0x20);
308 ov2640_reg_write(0x7d,reg7d0val);
309 ov2640_reg_write(0x7d,reg7d1val);
310 ov2640_reg_write(0x7d,0x06);
311}
312
313void ov2640_special_effects(u8 eft)
314{
315 u8 reg7d0val=0X00;
316 u8 reg7d1val=0X80;
317 u8 reg7d2val=0X80;
318 switch(eft)
319 {
320 case 1://negative film
321 reg7d0val=0X40;
322 break;
323 case 2://black and white
324 reg7d0val=0X18;
325 break;
326 case 3://red
327 reg7d0val=0X18;
328 reg7d1val=0X40;
329 reg7d2val=0XC0;
330 break;
331 case 4://green
332 reg7d0val=0X18;
333 reg7d1val=0X40;
334 reg7d2val=0X40;
335 break;
336 case 5://blue
337 reg7d0val=0X18;
338 reg7d1val=0XA0;
339 reg7d2val=0X40;
340 break;
341 case 6://retro
342 reg7d0val=0X18;
343 reg7d1val=0X40;
344 reg7d2val=0XA6;
345 break;
346 }
347 ov2640_reg_write(0xff,0x00);
348 ov2640_reg_write(0x7c,0x00);
349 ov2640_reg_write(0x7d,reg7d0val);
350 ov2640_reg_write(0x7c,0x05);
351 ov2640_reg_write(0x7d,reg7d1val);
352 ov2640_reg_write(0x7d,reg7d2val);
353}
354
355void ov2640_color_bar(u8 sw)
356{
357 u8 reg;
358 ov2640_reg_write(0XFF,0X01);
359 ov2640_reg_read(0X12, &reg);
360 reg&=~(1<<1);
361 if(sw)reg|=1<<1;
362 ov2640_reg_write(0X12,reg);
363}
364
365void ov2640_window_set(u16 sx,u16 sy,u16 width,u16 height)
366{
367 u16 endx;
368 u16 endy;
369 u8 temp;
370 endx=sx+width/2; //V*2
371 endy=sy+height/2;
372
373 ov2640_reg_write(0XFF,0X01);
374 ov2640_reg_read(0X03, &temp);
375 temp&=0XF0;
376 temp|=((endy&0X03)<<2)|(sy&0X03);
377 ov2640_reg_write(0X03,temp);
378 ov2640_reg_write(0X19,sy>>2);
379 ov2640_reg_write(0X1A,endy>>2);
380
381 ov2640_reg_read(0X32, &temp);
382 temp&=0XC0;
383 temp|=((endx&0X07)<<3)|(sx&0X07);
384 ov2640_reg_write(0X32,temp);
385 ov2640_reg_write(0X17,sx>>3);
386 ov2640_reg_write(0X18,endx>>3);
387}
388
389 u8 ov2640_outsize_set(u16 width,u16 height)
390{
391 u16 outh;
392 u16 outw;
393 u8 temp;
394 if(width%4)return 1;
395 if(height%4)return 2;
396 outw=width/4;
397 outh=height/4;
398 ov2640_reg_write(0XFF,0X00);
399 ov2640_reg_write(0XE0,0X04);
400 ov2640_reg_write(0X5A,outw&0XFF);
401 ov2640_reg_write(0X5B,outh&0XFF);
402 temp=(outw>>8)&0X03;
403 temp|=(outh>>6)&0X04;
404 ov2640_reg_write(0X5C,temp);
405 ov2640_reg_write(0XE0,0X00);
406 return 0;
407}
408
409 u8 ov2640_imagewin_set(u16 offx,u16 offy,u16 width,u16 height)
410{
411 u16 hsize;
412 u16 vsize;
413 u8 temp;
414 if(width%4)return 1;
415 if(height%4)return 2;
416 hsize=width/4;
417 vsize=height/4;
418 ov2640_reg_write(0XFF,0X00);
419 ov2640_reg_write(0XE0,0X04);
420 ov2640_reg_write(0X51,hsize&0XFF);
421 ov2640_reg_write(0X52,vsize&0XFF);
422 ov2640_reg_write(0X53,offx&0XFF);
423 ov2640_reg_write(0X54,offy&0XFF);
424 temp=(vsize>>1)&0X80;
425 temp|=(offy>>4)&0X70;
426 temp|=(hsize>>5)&0X08;
427 temp|=(offx>>8)&0X07;
428 ov2640_reg_write(0X55,temp);
429 ov2640_reg_write(0X57,(hsize>>2)&0X80);
430 ov2640_reg_write(0XE0,0X00);
431 return 0;
432}
433
434 u8 ov2640_imagesize_set(u16 width,u16 height)
435{
436 u8 temp;
437 ov2640_reg_write(0XFF,0X00);
438 ov2640_reg_write(0XE0,0X04);
439 ov2640_reg_write(0XC0,(width)>>3&0XFF);
440 ov2640_reg_write(0XC1,(height)>>3&0XFF);
441 temp=(width&0X07)<<3;
442 temp|=height&0X07;
443 temp|=(width>>4)&0X80;
444 ov2640_reg_write(0X8C,temp);
445 ov2640_reg_write(0XE0,0X00);
446 return 0;
447}
448
454void ov2640_i2c_init(void)
455{
456 hi2cx.i2cx = I2C2;
457 i2c_config(&hi2cx);
458}
459
465void i2c_lowlevel_init(i2c_handle_type* hi2c)
466{
467 gpio_init_type gpio_init_structure;
468
469 /* i2c periph clock enable */
470 crm_periph_clock_enable(CRM_I2C2_PERIPH_CLOCK, TRUE);
471 crm_periph_clock_enable(CRM_GPIOH_PERIPH_CLOCK, TRUE);
472 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
473
474 /* gpio configuration */
475 gpio_pin_mux_config(GPIOH, GPIO_PINS_SOURCE2, GPIO_MUX_4);
476
477 gpio_pin_mux_config(GPIOH, GPIO_PINS_SOURCE3, GPIO_MUX_4);
478
479 gpio_default_para_init(&gpio_init_structure);
480 /* configure i2c pins: scl */
481 gpio_init_structure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
482 gpio_init_structure.gpio_mode = GPIO_MODE_MUX;
483 gpio_init_structure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
484 gpio_init_structure.gpio_pull = GPIO_PULL_UP;
485 gpio_init_structure.gpio_pins = GPIO_PINS_2;
486 gpio_init(GPIOH, &gpio_init_structure);
487
488 gpio_init_structure.gpio_pins = GPIO_PINS_3;
489 gpio_init(GPIOH, &gpio_init_structure);
490
491 /* configure and enable i2c interrupt */
492 nvic_irq_enable(I2C2_EVT_IRQn, 0, 0);
493 nvic_irq_enable(I2C2_ERR_IRQn, 0, 0);
494
495 /* configure and enable i2c dma channel interrupt */
496 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
497 nvic_irq_enable(DMA1_Channel2_IRQn, 0, 0);
498
499 /* i2c dma tx and rx channels configuration */
500 /* enable the dma clock */
501
502 /* i2c dma channel configuration */
503 dma_reset(hi2c->dma_tx_channel);
504 dma_reset(hi2c->dma_rx_channel);
505
506 hi2c->dma_tx_channel = DMA1_CHANNEL1;
507 hi2c->dma_rx_channel = DMA1_CHANNEL2;
508
509 hi2c->dma_init_struct.peripheral_base_addr = (uint32_t)&hi2c->i2cx->txdt;
510 hi2c->dma_init_struct.memory_base_addr = 0;
511 hi2c->dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
512 hi2c->dma_init_struct.buffer_size = 0xFFFF;
513 hi2c->dma_init_struct.peripheral_inc_enable = FALSE;
514 hi2c->dma_init_struct.memory_inc_enable = TRUE;
515 hi2c->dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
516 hi2c->dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
517 hi2c->dma_init_struct.loop_mode_enable = FALSE;
518 hi2c->dma_init_struct.priority = DMA_PRIORITY_LOW;
519
520 dma_init(hi2c->dma_tx_channel, &hi2c->dma_init_struct);
521 dma_init(hi2c->dma_rx_channel, &hi2c->dma_init_struct);
522
523 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_I2C1_TX);
524 dmamux_init(DMA1MUX_CHANNEL2, DMAMUX_DMAREQ_ID_I2C1_RX);
525
526 dmamux_enable(DMA1, TRUE);
527
528 /* config i2c */
529 i2c_init(hi2c->i2cx, 0x0F, I2Cx_CLKCTRL);
530
531 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
532}
533
at32f435_437.h
at32f435_437 header file
at32f435_437_board.h
OV2640_SENSOR_COM7
#define OV2640_SENSOR_COM7
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h:60
OV2640_SENSOR_MIDH
#define OV2640_SENSOR_MIDH
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h:68
OV2640_DSP_RA_DLMT
#define OV2640_DSP_RA_DLMT
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h:47
OV2640_ADDR
#define OV2640_ADDR
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h:10
OV2640_SENSOR_MIDL
#define OV2640_SENSOR_MIDL
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h:69
OV2640_MID
#define OV2640_MID
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h:11
OV2640_RST_LOW
#define OV2640_RST_LOW
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h:6
OV2640_RST_HIGH
#define OV2640_RST_HIGH
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h:5
OV2640_SENSOR_PIDL
#define OV2640_SENSOR_PIDL
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h:55
OV2640_SENSOR_PIDH
#define OV2640_SENSOR_PIDH
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h:54
OV2640_PWRON_LOW
#define OV2640_PWRON_LOW
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h:8
OV2640_PID
#define OV2640_PID
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h:12
ov2640_jpeg_reg_tbl
const u8 ov2640_jpeg_reg_tbl[][2]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h:416
ov2640_svga_init_reg_tbl
const u8 ov2640_svga_init_reg_tbl[][2]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h:213
ov2640_yuv422_reg_tbl
const u8 ov2640_yuv422_reg_tbl[][2]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h:444
ov2640_rgb565_reg_tbl
const u8 ov2640_rgb565_reg_tbl[][2]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h:426
ov2640.h
ov2640cfg.h
STA
i2c_status_type STA
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:38
ov2640_reg_read
error_status ov2640_reg_read(uint8_t reg, uint8_t *data)
read register from ov2640
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:66
ov2640_init
error_status ov2640_init(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:84
ov2640_reg_write
error_status ov2640_reg_write(uint8_t reg, uint8_t data)
write register to ov2640
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:46
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:18
I2Cx_CLKCTRL
#define I2Cx_CLKCTRL
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:17
ov2640_i2c_init
void ov2640_i2c_init(void)
ov2640 i2c initialize
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:454
ov2640_light_mode
void ov2640_light_mode(u8 mode)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:210
ov2640_color_bar
void ov2640_color_bar(u8 sw)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:355
ov2640_auto_exposure
void ov2640_auto_exposure(u8 level)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:195
ov2640_window_set
void ov2640_window_set(u16 sx, u16 sy, u16 width, u16 height)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:365
ov2640_brightness
void ov2640_brightness(u8 bright)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:265
ov2640_special_effects
void ov2640_special_effects(u8 eft)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:313
hi2cx
i2c_handle_type hi2cx
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:37
ov2640_outsize_set
u8 ov2640_outsize_set(u16 width, u16 height)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:389
ov2640_rgb565_mode
void ov2640_rgb565_mode(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:151
ov2640_imagesize_set
u8 ov2640_imagesize_set(u16 width, u16 height)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:434
ov2640_jpeg_mode
void ov2640_jpeg_mode(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:136
ov2640_contrast
void ov2640_contrast(u8 contrast)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:280
OV2640_AUTOEXPOSURE_LEVEL
static const u8 OV2640_AUTOEXPOSURE_LEVEL[5][8]
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:160
ov2640_imagewin_set
u8 ov2640_imagewin_set(u16 offx, u16 offy, u16 width, u16 height)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:409
ov2640_color_saturation
void ov2640_color_saturation(u8 sat)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:249
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_GPIOH_PERIPH_CLOCK
@ CRM_GPIOH_PERIPH_CLOCK
Definition: at32f435_437_crm.h:112
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
CRM_I2C2_PERIPH_CLOCK
@ CRM_I2C2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:145
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:162
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:172
DMA_PRIORITY_LOW
@ DMA_PRIORITY_LOW
Definition: at32f435_437_dma.h:182
DMAMUX_DMAREQ_ID_I2C1_RX
@ DMAMUX_DMAREQ_ID_I2C1_RX
Definition: at32f435_437_dma.h:216
DMAMUX_DMAREQ_ID_I2C1_TX
@ DMAMUX_DMAREQ_ID_I2C1_TX
Definition: at32f435_437_dma.h:217
DMA1MUX_CHANNEL2
#define DMA1MUX_CHANNEL2
Definition: at32f435_437_dma.h:705
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f435_437_dma.h:697
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
error_status
error_status
Definition: at32f435_437.h:380
u8
uint8_t u8
Definition: at32f435_437.h:364
u16
uint16_t u16
Definition: at32f435_437.h:363
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f435_437_gpio.h:103
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_4
@ GPIO_MUX_4
Definition: at32f435_437_gpio.h:160
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOH
#define GPIOH
Definition: at32f435_437_gpio.h:528
i2c_init
void i2c_init(i2c_type *i2c_x, uint8_t dfilters, uint32_t clk)
init i2c digit filters and clock control register.
Definition: at32f435_437_i2c.c:79
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config i2c own address 1.
Definition: at32f435_437_i2c.c:103
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f435_437_i2c.h:113
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:113
i2c_lowlevel_init
__WEAK void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: i2c_application.c:103
i2c_master_receive
i2c_status_type i2c_master_receive(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through polling mode.
Definition: i2c_application.c:524
i2c_master_transmit
i2c_status_type i2c_master_transmit(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode.
Definition: i2c_application.c:375
i2c_status_type
i2c_status_type
Definition: i2c_application.h:80
I2C_OK
@ I2C_OK
Definition: i2c_application.h:81
I2C2
#define I2C2
Definition: at32f435_437_i2c.h:415
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
DMA1_Channel2_IRQn
@ DMA1_Channel2_IRQn
Definition: at32f435_437.h:205
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f435_437.h:204
I2C2_ERR_IRQn
@ I2C2_ERR_IRQn
Definition: at32f435_437.h:182
I2C2_EVT_IRQn
@ I2C2_EVT_IRQn
Definition: at32f435_437.h:181
i2c_application.h
i2c application libray header file
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
i2c_handle_type
Definition: i2c_application.h:112
i2c_handle_type::dma_rx_channel
dma_channel_type * dma_rx_channel
Definition: i2c_application.h:121
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:113
i2c_handle_type::dma_init_struct
dma_init_type dma_init_struct
Definition: i2c_application.h:122
i2c_handle_type::dma_tx_channel
dma_channel_type * dma_tx_channel
Definition: i2c_application.h:120
i2c_type::txdt
__IO uint32_t txdt
Definition: at32f435_437_i2c.h:400


AT32F435/437 Firmwary Library: ov2640.h File Reference

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • ov2640
Macros | Functions
at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h File Reference
#include "at32f435_437.h"

Go to the source code of this file.

Macros

#define | OV2640_RST_HIGH gpio_bits_set(GPIOC, GPIO_PINS_3);
#define | OV2640_RST_LOW gpio_bits_reset(GPIOC, GPIO_PINS_3);
#define | OV2640_PWRON_HIGH gpio_bits_set(GPIOC, GPIO_PINS_1);
#define | OV2640_PWRON_LOW gpio_bits_reset(GPIOC, GPIO_PINS_1);
#define | OV2640_ADDR 0X60
#define | OV2640_MID 0X7FA2
#define | OV2640_PID 0X2642
#define | OV2640_DSP_R_BYPASS 0x05
#define | OV2640_DSP_Qs 0x44
#define | OV2640_DSP_CTRL 0x50
#define | OV2640_DSP_HSIZE1 0x51
#define | OV2640_DSP_VSIZE1 0x52
#define | OV2640_DSP_XOFFL 0x53
#define | OV2640_DSP_YOFFL 0x54
#define | OV2640_DSP_VHYX 0x55
#define | OV2640_DSP_DPRP 0x56
#define | OV2640_DSP_TEST 0x57
#define | OV2640_DSP_ZMOW 0x5A
#define | OV2640_DSP_ZMOH 0x5B
#define | OV2640_DSP_ZMHH 0x5C
#define | OV2640_DSP_BPADDR 0x7C
#define | OV2640_DSP_BPDATA 0x7D
#define | OV2640_DSP_CTRL2 0x86
#define | OV2640_DSP_CTRL3 0x87
#define | OV2640_DSP_SIZEL 0x8C
#define | OV2640_DSP_HSIZE2 0xC0
#define | OV2640_DSP_VSIZE2 0xC1
#define | OV2640_DSP_CTRL0 0xC2
#define | OV2640_DSP_CTRL1 0xC3
#define | OV2640_DSP_R_DVP_SP 0xD3
#define | OV2640_DSP_IMAGE_MODE 0xDA
#define | OV2640_DSP_RESET 0xE0
#define | OV2640_DSP_MS_SP 0xF0
#define | OV2640_DSP_SS_ID 0x7F
#define | OV2640_DSP_SS_CTRL 0xF8
#define | OV2640_DSP_MC_BIST 0xF9
#define | OV2640_DSP_MC_AL 0xFA
#define | OV2640_DSP_MC_AH 0xFB
#define | OV2640_DSP_MC_D 0xFC
#define | OV2640_DSP_P_STATUS 0xFE
#define | OV2640_DSP_RA_DLMT 0xFF
#define | OV2640_SENSOR_GAIN 0x00
#define | OV2640_SENSOR_COM1 0x03
#define | OV2640_SENSOR_REG04 0x04
#define | OV2640_SENSOR_REG08 0x08
#define | OV2640_SENSOR_COM2 0x09
#define | OV2640_SENSOR_PIDH 0x0A
#define | OV2640_SENSOR_PIDL 0x0B
#define | OV2640_SENSOR_COM3 0x0C
#define | OV2640_SENSOR_COM4 0x0D
#define | OV2640_SENSOR_AEC 0x10
#define | OV2640_SENSOR_CLKRC 0x11
#define | OV2640_SENSOR_COM7 0x12
#define | OV2640_SENSOR_COM8 0x13
#define | OV2640_SENSOR_COM9 0x14
#define | OV2640_SENSOR_COM10 0x15
#define | OV2640_SENSOR_HREFST 0x17
#define | OV2640_SENSOR_HREFEND 0x18
#define | OV2640_SENSOR_VSTART 0x19
#define | OV2640_SENSOR_VEND 0x1A
#define | OV2640_SENSOR_MIDH 0x1C
#define | OV2640_SENSOR_MIDL 0x1D
#define | OV2640_SENSOR_AEW 0x24
#define | OV2640_SENSOR_AEB 0x25
#define | OV2640_SENSOR_W 0x26
#define | OV2640_SENSOR_REG2A 0x2A
#define | OV2640_SENSOR_FRARL 0x2B
#define | OV2640_SENSOR_ADDVSL 0x2D
#define | OV2640_SENSOR_ADDVHS 0x2E
#define | OV2640_SENSOR_YAVG 0x2F
#define | OV2640_SENSOR_REG32 0x32
#define | OV2640_SENSOR_ARCOM2 0x34
#define | OV2640_SENSOR_REG45 0x45
#define | OV2640_SENSOR_FLL 0x46
#define | OV2640_SENSOR_FLH 0x47
#define | OV2640_SENSOR_COM19 0x48
#define | OV2640_SENSOR_ZOOMS 0x49
#define | OV2640_SENSOR_COM22 0x4B
#define | OV2640_SENSOR_COM25 0x4E
#define | OV2640_SENSOR_BD50 0x4F
#define | OV2640_SENSOR_BD60 0x50
#define | OV2640_SENSOR_REG5D 0x5D
#define | OV2640_SENSOR_REG5E 0x5E
#define | OV2640_SENSOR_REG5F 0x5F
#define | OV2640_SENSOR_REG60 0x60
#define | OV2640_SENSOR_HISTO_LOW 0x61
#define | OV2640_SENSOR_HISTO_HIGH 0x62

Functions

error_status | ov2640_reg_write (uint8_t reg, uint8_t data)
write register to ov2640 More...
error_status | ov2640_reg_read (uint8_t reg, uint8_t *data)
read register from ov2640 More...
error_status | ov2640_init (void)
void | ov2640_jpeg_mode (void)
void | ov2640_rgb565_mode (void)
void | ov2640_auto_exposure (u8 level)
void | ov2640_light_mode (u8 mode)
void | ov2640_color_saturation (u8 sat)
void | ov2640_brightness (u8 bright)
void | ov2640_contrast (u8 contrast)
void | ov2640_special_effects (u8 eft)
void | ov2640_color_bar (u8 sw)
void | ov2640_window_set (u16 sx, u16 sy, u16 width, u16 height)
u8 | ov2640_outsize_set (u16 width, u16 height)
u8 | ov2640_imagewin_set (u16 offx, u16 offy, u16 width, u16 height)
u8 | ov2640_imagesize_set (u16 width, u16 height)
void | ov2640_i2c_init (void)
ov2640 i2c initialize More...

Macro Definition Documentation

◆ OV2640_ADDR

#define OV2640_ADDR 0X60

Definition at line 10 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_BPADDR

#define OV2640_DSP_BPADDR 0x7C

Definition at line 27 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_BPDATA

#define OV2640_DSP_BPDATA 0x7D

Definition at line 28 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_CTRL

#define OV2640_DSP_CTRL 0x50

Definition at line 16 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_CTRL0

#define OV2640_DSP_CTRL0 0xC2

Definition at line 34 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_CTRL1

#define OV2640_DSP_CTRL1 0xC3

Definition at line 35 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_CTRL2

#define OV2640_DSP_CTRL2 0x86

Definition at line 29 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_CTRL3

#define OV2640_DSP_CTRL3 0x87

Definition at line 30 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_DPRP

#define OV2640_DSP_DPRP 0x56

Definition at line 22 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_HSIZE1

#define OV2640_DSP_HSIZE1 0x51

Definition at line 17 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_HSIZE2

#define OV2640_DSP_HSIZE2 0xC0

Definition at line 32 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_IMAGE_MODE

#define OV2640_DSP_IMAGE_MODE 0xDA

Definition at line 37 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_MC_AH

#define OV2640_DSP_MC_AH 0xFB

Definition at line 44 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_MC_AL

#define OV2640_DSP_MC_AL 0xFA

Definition at line 43 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_MC_BIST

#define OV2640_DSP_MC_BIST 0xF9

Definition at line 42 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_MC_D

#define OV2640_DSP_MC_D 0xFC

Definition at line 45 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_MS_SP

#define OV2640_DSP_MS_SP 0xF0

Definition at line 39 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_P_STATUS

#define OV2640_DSP_P_STATUS 0xFE

Definition at line 46 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_Qs

#define OV2640_DSP_Qs 0x44

Definition at line 15 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_R_BYPASS

#define OV2640_DSP_R_BYPASS 0x05

Definition at line 14 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_R_DVP_SP

#define OV2640_DSP_R_DVP_SP 0xD3

Definition at line 36 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_RA_DLMT

#define OV2640_DSP_RA_DLMT 0xFF

Definition at line 47 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_RESET

#define OV2640_DSP_RESET 0xE0

Definition at line 38 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_SIZEL

#define OV2640_DSP_SIZEL 0x8C

Definition at line 31 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_SS_CTRL

#define OV2640_DSP_SS_CTRL 0xF8

Definition at line 41 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_SS_ID

#define OV2640_DSP_SS_ID 0x7F

Definition at line 40 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_TEST

#define OV2640_DSP_TEST 0x57

Definition at line 23 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_VHYX

#define OV2640_DSP_VHYX 0x55

Definition at line 21 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_VSIZE1

#define OV2640_DSP_VSIZE1 0x52

Definition at line 18 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_VSIZE2

#define OV2640_DSP_VSIZE2 0xC1

Definition at line 33 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_XOFFL

#define OV2640_DSP_XOFFL 0x53

Definition at line 19 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_YOFFL

#define OV2640_DSP_YOFFL 0x54

Definition at line 20 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_ZMHH

#define OV2640_DSP_ZMHH 0x5C

Definition at line 26 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_ZMOH

#define OV2640_DSP_ZMOH 0x5B

Definition at line 25 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_DSP_ZMOW

#define OV2640_DSP_ZMOW 0x5A

Definition at line 24 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_MID

#define OV2640_MID 0X7FA2

Definition at line 11 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_PID

#define OV2640_PID 0X2642

Definition at line 12 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_PWRON_HIGH

#define OV2640_PWRON_HIGH gpio_bits_set(GPIOC, GPIO_PINS_1);

Definition at line 7 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_PWRON_LOW

#define OV2640_PWRON_LOW gpio_bits_reset(GPIOC, GPIO_PINS_1);

Definition at line 8 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_RST_HIGH

#define OV2640_RST_HIGH gpio_bits_set(GPIOC, GPIO_PINS_3);

Definition at line 5 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_RST_LOW

#define OV2640_RST_LOW gpio_bits_reset(GPIOC, GPIO_PINS_3);

Definition at line 6 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_ADDVHS

#define OV2640_SENSOR_ADDVHS 0x2E

Definition at line 76 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_ADDVSL

#define OV2640_SENSOR_ADDVSL 0x2D

Definition at line 75 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_AEB

#define OV2640_SENSOR_AEB 0x25

Definition at line 71 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_AEC

#define OV2640_SENSOR_AEC 0x10

Definition at line 58 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_AEW

#define OV2640_SENSOR_AEW 0x24

Definition at line 70 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_ARCOM2

#define OV2640_SENSOR_ARCOM2 0x34

Definition at line 79 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_BD50

#define OV2640_SENSOR_BD50 0x4F

Definition at line 87 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_BD60

#define OV2640_SENSOR_BD60 0x50

Definition at line 88 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_CLKRC

#define OV2640_SENSOR_CLKRC 0x11

Definition at line 59 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_COM1

#define OV2640_SENSOR_COM1 0x03

Definition at line 50 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_COM10

#define OV2640_SENSOR_COM10 0x15

Definition at line 63 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_COM19

#define OV2640_SENSOR_COM19 0x48

Definition at line 83 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_COM2

#define OV2640_SENSOR_COM2 0x09

Definition at line 53 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_COM22

#define OV2640_SENSOR_COM22 0x4B

Definition at line 85 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_COM25

#define OV2640_SENSOR_COM25 0x4E

Definition at line 86 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_COM3

#define OV2640_SENSOR_COM3 0x0C

Definition at line 56 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_COM4

#define OV2640_SENSOR_COM4 0x0D

Definition at line 57 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_COM7

#define OV2640_SENSOR_COM7 0x12

Definition at line 60 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_COM8

#define OV2640_SENSOR_COM8 0x13

Definition at line 61 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_COM9

#define OV2640_SENSOR_COM9 0x14

Definition at line 62 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_FLH

#define OV2640_SENSOR_FLH 0x47

Definition at line 82 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_FLL

#define OV2640_SENSOR_FLL 0x46

Definition at line 81 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_FRARL

#define OV2640_SENSOR_FRARL 0x2B

Definition at line 74 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_GAIN

#define OV2640_SENSOR_GAIN 0x00

Definition at line 49 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_HISTO_HIGH

#define OV2640_SENSOR_HISTO_HIGH 0x62

Definition at line 94 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_HISTO_LOW

#define OV2640_SENSOR_HISTO_LOW 0x61

Definition at line 93 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_HREFEND

#define OV2640_SENSOR_HREFEND 0x18

Definition at line 65 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_HREFST

#define OV2640_SENSOR_HREFST 0x17

Definition at line 64 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_MIDH

#define OV2640_SENSOR_MIDH 0x1C

Definition at line 68 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_MIDL

#define OV2640_SENSOR_MIDL 0x1D

Definition at line 69 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_PIDH

#define OV2640_SENSOR_PIDH 0x0A

Definition at line 54 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_PIDL

#define OV2640_SENSOR_PIDL 0x0B

Definition at line 55 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_REG04

#define OV2640_SENSOR_REG04 0x04

Definition at line 51 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_REG08

#define OV2640_SENSOR_REG08 0x08

Definition at line 52 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_REG2A

#define OV2640_SENSOR_REG2A 0x2A

Definition at line 73 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_REG32

#define OV2640_SENSOR_REG32 0x32

Definition at line 78 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_REG45

#define OV2640_SENSOR_REG45 0x45

Definition at line 80 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_REG5D

#define OV2640_SENSOR_REG5D 0x5D

Definition at line 89 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_REG5E

#define OV2640_SENSOR_REG5E 0x5E

Definition at line 90 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_REG5F

#define OV2640_SENSOR_REG5F 0x5F

Definition at line 91 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_REG60

#define OV2640_SENSOR_REG60 0x60

Definition at line 92 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_VEND

#define OV2640_SENSOR_VEND 0x1A

Definition at line 67 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_VSTART

#define OV2640_SENSOR_VSTART 0x19

Definition at line 66 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_W

#define OV2640_SENSOR_W 0x26

Definition at line 72 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_YAVG

#define OV2640_SENSOR_YAVG 0x2F

Definition at line 77 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.

◆ OV2640_SENSOR_ZOOMS

#define OV2640_SENSOR_ZOOMS 0x49

Definition at line 84 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h.


AT32F435/437 Firmwary Library: ov2640.h Source File

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • ov2640
at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
Go to the documentation of this file.
1#ifndef _OV2640_H
2#define _OV2640_H
3#include "at32f435_437.h"
4
5#define OV2640_RST_HIGH gpio_bits_set(GPIOC, GPIO_PINS_3);
6#define OV2640_RST_LOW gpio_bits_reset(GPIOC, GPIO_PINS_3);
7#define OV2640_PWRON_HIGH gpio_bits_set(GPIOC, GPIO_PINS_1);
8#define OV2640_PWRON_LOW gpio_bits_reset(GPIOC, GPIO_PINS_1);
9
10#define OV2640_ADDR 0X60 //OV2640 ID
11#define OV2640_MID 0X7FA2
12#define OV2640_PID 0X2642
13
14#define OV2640_DSP_R_BYPASS 0x05
15#define OV2640_DSP_Qs 0x44
16#define OV2640_DSP_CTRL 0x50
17#define OV2640_DSP_HSIZE1 0x51
18#define OV2640_DSP_VSIZE1 0x52
19#define OV2640_DSP_XOFFL 0x53
20#define OV2640_DSP_YOFFL 0x54
21#define OV2640_DSP_VHYX 0x55
22#define OV2640_DSP_DPRP 0x56
23#define OV2640_DSP_TEST 0x57
24#define OV2640_DSP_ZMOW 0x5A
25#define OV2640_DSP_ZMOH 0x5B
26#define OV2640_DSP_ZMHH 0x5C
27#define OV2640_DSP_BPADDR 0x7C
28#define OV2640_DSP_BPDATA 0x7D
29#define OV2640_DSP_CTRL2 0x86
30#define OV2640_DSP_CTRL3 0x87
31#define OV2640_DSP_SIZEL 0x8C
32#define OV2640_DSP_HSIZE2 0xC0
33#define OV2640_DSP_VSIZE2 0xC1
34#define OV2640_DSP_CTRL0 0xC2
35#define OV2640_DSP_CTRL1 0xC3
36#define OV2640_DSP_R_DVP_SP 0xD3
37#define OV2640_DSP_IMAGE_MODE 0xDA
38#define OV2640_DSP_RESET 0xE0
39#define OV2640_DSP_MS_SP 0xF0
40#define OV2640_DSP_SS_ID 0x7F
41#define OV2640_DSP_SS_CTRL 0xF8
42#define OV2640_DSP_MC_BIST 0xF9
43#define OV2640_DSP_MC_AL 0xFA
44#define OV2640_DSP_MC_AH 0xFB
45#define OV2640_DSP_MC_D 0xFC
46#define OV2640_DSP_P_STATUS 0xFE
47#define OV2640_DSP_RA_DLMT 0xFF
48
49#define OV2640_SENSOR_GAIN 0x00
50#define OV2640_SENSOR_COM1 0x03
51#define OV2640_SENSOR_REG04 0x04
52#define OV2640_SENSOR_REG08 0x08
53#define OV2640_SENSOR_COM2 0x09
54#define OV2640_SENSOR_PIDH 0x0A
55#define OV2640_SENSOR_PIDL 0x0B
56#define OV2640_SENSOR_COM3 0x0C
57#define OV2640_SENSOR_COM4 0x0D
58#define OV2640_SENSOR_AEC 0x10
59#define OV2640_SENSOR_CLKRC 0x11
60#define OV2640_SENSOR_COM7 0x12
61#define OV2640_SENSOR_COM8 0x13
62#define OV2640_SENSOR_COM9 0x14
63#define OV2640_SENSOR_COM10 0x15
64#define OV2640_SENSOR_HREFST 0x17
65#define OV2640_SENSOR_HREFEND 0x18
66#define OV2640_SENSOR_VSTART 0x19
67#define OV2640_SENSOR_VEND 0x1A
68#define OV2640_SENSOR_MIDH 0x1C
69#define OV2640_SENSOR_MIDL 0x1D
70#define OV2640_SENSOR_AEW 0x24
71#define OV2640_SENSOR_AEB 0x25
72#define OV2640_SENSOR_W 0x26
73#define OV2640_SENSOR_REG2A 0x2A
74#define OV2640_SENSOR_FRARL 0x2B
75#define OV2640_SENSOR_ADDVSL 0x2D
76#define OV2640_SENSOR_ADDVHS 0x2E
77#define OV2640_SENSOR_YAVG 0x2F
78#define OV2640_SENSOR_REG32 0x32
79#define OV2640_SENSOR_ARCOM2 0x34
80#define OV2640_SENSOR_REG45 0x45
81#define OV2640_SENSOR_FLL 0x46
82#define OV2640_SENSOR_FLH 0x47
83#define OV2640_SENSOR_COM19 0x48
84#define OV2640_SENSOR_ZOOMS 0x49
85#define OV2640_SENSOR_COM22 0x4B
86#define OV2640_SENSOR_COM25 0x4E
87#define OV2640_SENSOR_BD50 0x4F
88#define OV2640_SENSOR_BD60 0x50
89#define OV2640_SENSOR_REG5D 0x5D
90#define OV2640_SENSOR_REG5E 0x5E
91#define OV2640_SENSOR_REG5F 0x5F
92#define OV2640_SENSOR_REG60 0x60
93#define OV2640_SENSOR_HISTO_LOW 0x61
94#define OV2640_SENSOR_HISTO_HIGH 0x62
95
96 error_status ov2640_reg_write(uint8_t reg, uint8_t data);
97 error_status ov2640_reg_read(uint8_t reg, uint8_t *data);
98 error_status ov2640_init(void);
99void ov2640_jpeg_mode(void);
100void ov2640_rgb565_mode(void);
101void ov2640_auto_exposure(u8 level);
102void ov2640_light_mode(u8 mode);
103void ov2640_color_saturation(u8 sat);
104void ov2640_brightness(u8 bright);
105void ov2640_contrast(u8 contrast);
106void ov2640_special_effects(u8 eft);
107void ov2640_color_bar(u8 sw);
108void ov2640_window_set(u16 sx,u16 sy,u16 width,u16 height);
109 u8 ov2640_outsize_set(u16 width,u16 height);
110 u8 ov2640_imagewin_set(u16 offx,u16 offy,u16 width,u16 height);
111 u8 ov2640_imagesize_set(u16 width,u16 height);
112void ov2640_i2c_init(void);
113
114#endif
at32f435_437.h
at32f435_437 header file
ov2640_reg_read
error_status ov2640_reg_read(uint8_t reg, uint8_t *data)
read register from ov2640
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:66
ov2640_init
error_status ov2640_init(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:84
ov2640_reg_write
error_status ov2640_reg_write(uint8_t reg, uint8_t data)
write register to ov2640
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:46
ov2640_i2c_init
void ov2640_i2c_init(void)
ov2640 i2c initialize
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:454
ov2640_light_mode
void ov2640_light_mode(u8 mode)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:210
ov2640_color_bar
void ov2640_color_bar(u8 sw)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:355
ov2640_auto_exposure
void ov2640_auto_exposure(u8 level)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:195
ov2640_window_set
void ov2640_window_set(u16 sx, u16 sy, u16 width, u16 height)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:365
ov2640_brightness
void ov2640_brightness(u8 bright)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:265
ov2640_special_effects
void ov2640_special_effects(u8 eft)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:313
ov2640_outsize_set
u8 ov2640_outsize_set(u16 width, u16 height)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:389
ov2640_rgb565_mode
void ov2640_rgb565_mode(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:151
ov2640_imagesize_set
u8 ov2640_imagesize_set(u16 width, u16 height)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:434
ov2640_jpeg_mode
void ov2640_jpeg_mode(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:136
ov2640_contrast
void ov2640_contrast(u8 contrast)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:280
ov2640_imagewin_set
u8 ov2640_imagewin_set(u16 offx, u16 offy, u16 width, u16 height)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:409
ov2640_color_saturation
void ov2640_color_saturation(u8 sat)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:249
error_status
error_status
Definition: at32f435_437.h:380
u8
uint8_t u8
Definition: at32f435_437.h:364
u16
uint16_t u16
Definition: at32f435_437.h:363


AT32F435/437 Firmwary Library: ov2640cfg.h File Reference

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • ov2640
Variables
at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h File Reference
#include "ov2640.h"

Go to the source code of this file.

Variables

const u8 | ov2640_sxga_init_reg_tbl [][2]
const u8 | ov2640_svga_init_reg_tbl [][2]
const u8 | ov2640_jpeg_reg_tbl [][2]
const u8 | ov2640_rgb565_reg_tbl [][2]
const u8 | ov2640_yuv422_reg_tbl [][2]

Variable Documentation

◆ ov2640_jpeg_reg_tbl

const u8 ov2640_jpeg_reg_tbl[][2]
Initial value:
=
{
0xff, 0x01,
0xe0, 0x14,
0xe1, 0x77,
0xe5, 0x1f,
0xd7, 0x03,
0xda, 0x10,
0xe0, 0x00,
}

Definition at line 416 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h.

◆ ov2640_rgb565_reg_tbl

const u8 ov2640_rgb565_reg_tbl[][2]
Initial value:
=
{
0xFF, 0x00,
0xDA, 0x09,
0xD7, 0x03,
0xDF, 0x02,
0x33, 0xa0,
0x3C, 0x00,
0xe1, 0x67,
0xff, 0x01,
0xe0, 0x00,
0xe1, 0x00,
0xe5, 0x00,
0xd7, 0x00,
0xda, 0x00,
0xe0, 0x00,
}

Definition at line 426 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h.

◆ ov2640_svga_init_reg_tbl

const u8 ov2640_svga_init_reg_tbl[][2]

Definition at line 213 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h.

◆ ov2640_sxga_init_reg_tbl

const u8 ov2640_sxga_init_reg_tbl[][2]

Definition at line 5 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h.

◆ ov2640_yuv422_reg_tbl

const u8 ov2640_yuv422_reg_tbl[][2]
Initial value:
=
{
0xFF, 0x00,
0xDA, 0x10,
0xD7, 0x03,
0xDF, 0x00,
0x33, 0x80,
0x3C, 0x40,
0xe1, 0x77,
0x00, 0x00,
}

Definition at line 444 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h.


AT32F435/437 Firmwary Library: ov2640cfg.h Source File

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • ov2640
at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h
Go to the documentation of this file.
1#ifndef _OV2640CFG_H
2#define _OV2640CFG_H
3#include "ov2640.h"
4
5const u8 ov2640_sxga_init_reg_tbl[][2]=
6{
7 0xff, 0x00,
8 0x2c, 0xff,
9 0x2e, 0xdf,
10 0xff, 0x01,
11 0x3c, 0x32,
12 //
13 0x11, 0x00,
14 0x09, 0x02,
15 0x04, 0xD8,
16 0x13, 0xe5,
17 0x14, 0x48,
18 0x2c, 0x0c,
19 0x33, 0x78,
20 0x3a, 0x33,
21 0x3b, 0xfB,
22 //
23 0x3e, 0x00,
24 0x43, 0x11,
25 0x16, 0x10,
26 //
27 0x39, 0x92,
28 //
29 0x35, 0xda,
30 0x22, 0x1a,
31 0x37, 0xc3,
32 0x23, 0x00,
33 0x34, 0xc0,
34 0x36, 0x1a,
35 0x06, 0x88,
36 0x07, 0xc0,
37 0x0d, 0x87,
38 0x0e, 0x41,
39 0x4c, 0x00,
40
41 0x48, 0x00,
42 0x5B, 0x00,
43 0x42, 0x03,
44 //
45 0x4a, 0x81,
46 0x21, 0x99,
47 //
48 0x24, 0x40,
49 0x25, 0x38,
50 0x26, 0x82,
51 0x5c, 0x00,
52 0x63, 0x00,
53 0x46, 0x00,
54 0x0c, 0x3c,
55 //
56 0x61, 0x70,
57 0x62, 0x80,
58 0x7c, 0x05,
59 //
60 0x20, 0x80,
61 0x28, 0x30,
62 0x6c, 0x00,
63 0x6d, 0x80,
64 0x6e, 0x00,
65 0x70, 0x02,
66 0x71, 0x94,
67 0x73, 0xc1,
68 0x3d, 0x34,
69 0x5a, 0x57,
70 //
71 0x12, 0x00,//UXGA 1600*1200
72
73 0x17, 0x11,
74 0x18, 0x75,
75 0x19, 0x01,
76 0x1a, 0x97,
77 0x32, 0x36,
78 0x03, 0x0f,
79 0x37, 0x40,
80 //
81 0x4f, 0xca,
82 0x50, 0xa8,
83 0x5a, 0x23,
84 0x6d, 0x00,
85 0x6d, 0x38,
86 //
87 0xff, 0x00,
88 0xe5, 0x7f,
89 0xf9, 0xc0,
90 0x41, 0x24,
91 0xe0, 0x14,
92 0x76, 0xff,
93 0x33, 0xa0,
94 0x42, 0x20,
95 0x43, 0x18,
96 0x4c, 0x00,
97 0x87, 0xd5,
98 0x88, 0x3f,
99 0xd7, 0x03,
100 0xd9, 0x10,
101 0xd3, 0x82,
102 //
103 0xc8, 0x08,
104 0xc9, 0x80,
105 //
106 0x7c, 0x00,
107 0x7d, 0x00,
108 0x7c, 0x03,
109 0x7d, 0x48,
110 0x7d, 0x48,
111 0x7c, 0x08,
112 0x7d, 0x20,
113 0x7d, 0x10,
114 0x7d, 0x0e,
115 //
116 0x90, 0x00,
117 0x91, 0x0e,
118 0x91, 0x1a,
119 0x91, 0x31,
120 0x91, 0x5a,
121 0x91, 0x69,
122 0x91, 0x75,
123 0x91, 0x7e,
124 0x91, 0x88,
125 0x91, 0x8f,
126 0x91, 0x96,
127 0x91, 0xa3,
128 0x91, 0xaf,
129 0x91, 0xc4,
130 0x91, 0xd7,
131 0x91, 0xe8,
132 0x91, 0x20,
133 //
134 0x92, 0x00,
135 0x93, 0x06,
136 0x93, 0xe3,
137 0x93, 0x05,
138 0x93, 0x05,
139 0x93, 0x00,
140 0x93, 0x04,
141 0x93, 0x00,
142 0x93, 0x00,
143 0x93, 0x00,
144 0x93, 0x00,
145 0x93, 0x00,
146 0x93, 0x00,
147 0x93, 0x00,
148 //
149 0x96, 0x00,
150 0x97, 0x08,
151 0x97, 0x19,
152 0x97, 0x02,
153 0x97, 0x0c,
154 0x97, 0x24,
155 0x97, 0x30,
156 0x97, 0x28,
157 0x97, 0x26,
158 0x97, 0x02,
159 0x97, 0x98,
160 0x97, 0x80,
161 0x97, 0x00,
162 0x97, 0x00,
163 //
164 0xc3, 0xef,
165
166 0xa4, 0x00,
167 0xa8, 0x00,
168 0xc5, 0x11,
169 0xc6, 0x51,
170 0xbf, 0x80,
171 0xc7, 0x10,
172 0xb6, 0x66,
173 0xb8, 0xA5,
174 0xb7, 0x64,
175 0xb9, 0x7C,
176 0xb3, 0xaf,
177 0xb4, 0x97,
178 0xb5, 0xFF,
179 0xb0, 0xC5,
180 0xb1, 0x94,
181 0xb2, 0x0f,
182 0xc4, 0x5c,
183 //
184 0xc0, 0xc8,
185 0xc1, 0x96,
186 0x8c, 0x00,
187 0x86, 0x3d,
188 0x50, 0x00,
189 0x51, 0x90,
190 0x52, 0x2c,
191 0x53, 0x00,
192 0x54, 0x00,
193 0x55, 0x88,
194
195 0x5a, 0x90,
196 0x5b, 0x2C,
197 0x5c, 0x05,
198
199 0xd3, 0x02,//auto
200 //
201 0xc3, 0xed,
202 0x7f, 0x00,
203
204 0xda, 0x09,
205
206 0xe5, 0x1f,
207 0xe1, 0x67,
208 0xe0, 0x00,
209 0xdd, 0x7f,
210 0x05, 0x00,
211};
212
213const u8 ov2640_svga_init_reg_tbl[][2]=
214{
215 0xff, 0x00,
216 0x2c, 0xff,
217 0x2e, 0xdf,
218 0xff, 0x01,
219 0x3c, 0x32,
220 //
221 0x11, 0x00,
222 0x09, 0x02,
223 0x04, 0xD8,
224 0x13, 0xe5,
225 0x14, 0x48,
226 0x2c, 0x0c,
227 0x33, 0x78,
228 0x3a, 0x33,
229 0x3b, 0xfB,
230 //
231 0x3e, 0x00,
232 0x43, 0x11,
233 0x16, 0x10,
234 //
235 0x39, 0x92,
236 //
237 0x35, 0xda,
238 0x22, 0x1a,
239 0x37, 0xc3,
240 0x23, 0x00,
241 0x34, 0xc0,
242 0x36, 0x1a,
243 0x06, 0x88,
244 0x07, 0xc0,
245 0x0d, 0x87,
246 0x0e, 0x41,
247 0x4c, 0x00,
248 0x48, 0x00,
249 0x5B, 0x00,
250 0x42, 0x03,
251 //
252 0x4a, 0x81,
253 0x21, 0x99,
254 //
255 0x24, 0x40,
256 0x25, 0x38,
257 0x26, 0x82,
258 0x5c, 0x00,
259 0x63, 0x00,
260 0x46, 0x22,
261 0x0c, 0x3c,
262 //
263 0x61, 0x70,
264 0x62, 0x80,
265 0x7c, 0x05,
266 //
267 0x20, 0x80,
268 0x28, 0x30,
269 0x6c, 0x00,
270 0x6d, 0x80,
271 0x6e, 0x00,
272 0x70, 0x02,
273 0x71, 0x94,
274 0x73, 0xc1,
275
276 0x3d, 0x34,
277 0x5a, 0x57,
278
279 0x12, 0x40,//SVGA 800*600
280 0x17, 0x11,
281 0x18, 0x43,
282 0x19, 0x00,
283 0x1a, 0x4b,
284 0x32, 0x09,
285 0x37, 0xc0,
286 //
287 0x4f, 0xca,
288 0x50, 0xa8,
289 0x5a, 0x23,
290 0x6d, 0x00,
291 0x3d, 0x38,
292 //
293 0xff, 0x00,
294 0xe5, 0x7f,
295 0xf9, 0xc0,
296 0x41, 0x24,
297 0xe0, 0x14,
298 0x76, 0xff,
299 0x33, 0xa0,
300 0x42, 0x20,
301 0x43, 0x18,
302 0x4c, 0x00,
303 0x87, 0xd5,
304 0x88, 0x3f,
305 0xd7, 0x03,
306 0xd9, 0x10,
307 0xd3, 0x82,
308 //
309 0xc8, 0x08,
310 0xc9, 0x80,
311 //
312 0x7c, 0x00,
313 0x7d, 0x00,
314 0x7c, 0x03,
315 0x7d, 0x48,
316 0x7d, 0x48,
317 0x7c, 0x08,
318 0x7d, 0x20,
319 0x7d, 0x10,
320 0x7d, 0x0e,
321 //
322 0x90, 0x00,
323 0x91, 0x0e,
324 0x91, 0x1a,
325 0x91, 0x31,
326 0x91, 0x5a,
327 0x91, 0x69,
328 0x91, 0x75,
329 0x91, 0x7e,
330 0x91, 0x88,
331 0x91, 0x8f,
332 0x91, 0x96,
333 0x91, 0xa3,
334 0x91, 0xaf,
335 0x91, 0xc4,
336 0x91, 0xd7,
337 0x91, 0xe8,
338 0x91, 0x20,
339 //
340 0x92, 0x00,
341 0x93, 0x06,
342 0x93, 0xe3,
343 0x93, 0x05,
344 0x93, 0x05,
345 0x93, 0x00,
346 0x93, 0x04,
347 0x93, 0x00,
348 0x93, 0x00,
349 0x93, 0x00,
350 0x93, 0x00,
351 0x93, 0x00,
352 0x93, 0x00,
353 0x93, 0x00,
354 //
355 0x96, 0x00,
356 0x97, 0x08,
357 0x97, 0x19,
358 0x97, 0x02,
359 0x97, 0x0c,
360 0x97, 0x24,
361 0x97, 0x30,
362 0x97, 0x28,
363 0x97, 0x26,
364 0x97, 0x02,
365 0x97, 0x98,
366 0x97, 0x80,
367 0x97, 0x00,
368 0x97, 0x00,
369 //
370 0xc3, 0xed,
371 0xa4, 0x00,
372 0xa8, 0x00,
373 0xc5, 0x11,
374 0xc6, 0x51,
375 0xbf, 0x80,
376 0xc7, 0x10,
377 0xb6, 0x66,
378 0xb8, 0xA5,
379 0xb7, 0x64,
380 0xb9, 0x7C,
381 0xb3, 0xaf,
382 0xb4, 0x97,
383 0xb5, 0xFF,
384 0xb0, 0xC5,
385 0xb1, 0x94,
386 0xb2, 0x0f,
387 0xc4, 0x5c,
388
389 0xc0, 0x64,
390 0xc1, 0x4B,
391 0x8c, 0x00,
392 0x86, 0x3D,
393 0x50, 0x00,
394 0x51, 0xC8,
395 0x52, 0x96,
396 0x53, 0x00,
397 0x54, 0x00,
398 0x55, 0x00,
399 0x5a, 0xC8,
400 0x5b, 0x96,
401 0x5c, 0x00,
402
403 0xd3, 0x02,//auto
404 //
405 0xc3, 0xed,
406 0x7f, 0x00,
407
408 0xda, 0x09,
409
410 0xe5, 0x1f,
411 0xe1, 0x67,
412 0xe0, 0x00,
413 0xdd, 0x7f,
414 0x05, 0x00,
415};
416const u8 ov2640_jpeg_reg_tbl[][2]=
417{
418 0xff, 0x01,
419 0xe0, 0x14,
420 0xe1, 0x77,
421 0xe5, 0x1f,
422 0xd7, 0x03,
423 0xda, 0x10,
424 0xe0, 0x00,
425};
426const u8 ov2640_rgb565_reg_tbl[][2]=
427{
428 0xFF, 0x00,
429 0xDA, 0x09,
430 0xD7, 0x03,
431 0xDF, 0x02,
432 0x33, 0xa0,
433 0x3C, 0x00,
434 0xe1, 0x67,
435
436 0xff, 0x01,
437 0xe0, 0x00,
438 0xe1, 0x00,
439 0xe5, 0x00,
440 0xd7, 0x00,
441 0xda, 0x00,
442 0xe0, 0x00,
443};
444const u8 ov2640_yuv422_reg_tbl[][2]=
445{
446 0xFF, 0x00,
447 0xDA, 0x10,
448 0xD7, 0x03,
449 0xDF, 0x00,
450 0x33, 0x80,
451 0x3C, 0x40,
452 0xe1, 0x77,
453 0x00, 0x00,
454};
455
456#endif
ov2640.h
ov2640_jpeg_reg_tbl
const u8 ov2640_jpeg_reg_tbl[][2]
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h:416
ov2640_sxga_init_reg_tbl
const u8 ov2640_sxga_init_reg_tbl[][2]
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h:5
ov2640_svga_init_reg_tbl
const u8 ov2640_svga_init_reg_tbl[][2]
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h:213
ov2640_yuv422_reg_tbl
const u8 ov2640_yuv422_reg_tbl[][2]
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h:444
ov2640_rgb565_reg_tbl
const u8 ov2640_rgb565_reg_tbl[][2]
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h:426
u8
uint8_t u8
Definition: at32f435_437.h:364


AT32F435/437 Firmwary Library: sccb.c File Reference

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • ov2640
Functions
at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c File Reference
#include "sys.h"
#include "sccb.h"
#include "delay.h"

Go to the source code of this file.

Functions

void | SCCB_Init (void)
void | SCCB_Start (void)
void | SCCB_Stop (void)
void | SCCB_No_Ack (void)
u8 | SCCB_WR_Byte (u8 dat)
u8 | SCCB_RD_Byte (void)
u8 | SCCB_WR_Reg (u8 reg, u8 data)
u8 | SCCB_RD_Reg (u8 reg)

Function Documentation

◆ SCCB_Init()

void SCCB_Init ( void )

Definition at line 18 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

◆ SCCB_No_Ack()

void SCCB_No_Ack ( void )

Definition at line 58 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

Referenced by SCCB_RD_Reg().

◆ SCCB_RD_Byte()

u8 SCCB_RD_Byte ( void )

Definition at line 97 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

Referenced by SCCB_RD_Reg().

◆ SCCB_RD_Reg()

u8 SCCB_RD_Reg ( u8 reg )

Definition at line 129 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

◆ SCCB_Start()

void SCCB_Start ( void )

Definition at line 35 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

Referenced by SCCB_RD_Reg(), and SCCB_WR_Reg().

◆ SCCB_Stop()

void SCCB_Stop ( void )

Definition at line 48 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

Referenced by SCCB_RD_Reg(), and SCCB_WR_Reg().

◆ SCCB_WR_Byte()

u8 SCCB_WR_Byte ( u8 dat )

Definition at line 71 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

Referenced by SCCB_RD_Reg(), and SCCB_WR_Reg().

◆ SCCB_WR_Reg()

u8 SCCB_WR_Reg | ( | u8 | reg,
 |  | u8 | data
 | ) |  |

Definition at line 115 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.


AT32F435/437 Firmwary Library: sccb.c Source File

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • ov2640
at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c
Go to the documentation of this file.
1#include "sys.h"
2#include "sccb.h"
3#include "delay.h"
5//本程序只供学习使用，未经作者许可，不得用于其它任何用途
6//ALIENTEK STM32F407开发板
7//OV系列摄像头 SCCB 驱动代码
8//正点原子@ALIENTEK
9//技术论坛:www.openedv.com
10//创建日期:2014/5/14
11//版本：V1.0
12//版权所有，盗版必究。
13//Copyright(C) 广州市星翼电子科技有限公司 2014-2024
14//All rights reserved
16
17//初始化SCCB接口
18void SCCB_Init(void)
19{
20 GPIO_InitTypeDef GPIO_Initure;
21 __HAL_RCC_GPIOB_CLK_ENABLE(); //使能GPIOB时钟
22
23 //PB3.4初始化设置
24 GPIO_Initure.Pin=GPIO_PIN_3|GPIO_PIN_4;
25 GPIO_Initure.Mode=GPIO_MODE_OUTPUT_PP; //推挽输出
26 GPIO_Initure.Pull=GPIO_PULLUP; //上拉
27 GPIO_Initure.Speed=GPIO_SPEED_FAST; //快速
28 HAL_GPIO_Init(GPIOB,&GPIO_Initure);
29 SCCB_SDA_OUT();
30}
31
32//SCCB起始信号
33//当时钟为高的时候,数据线的高到低,为SCCB起始信号
34//在激活状态下,SDA和SCL均为低电平
35void SCCB_Start(void)
36{
37 SCCB_SDA=1; //数据线高电平
38 SCCB_SCL=1; //在时钟线高的时候数据线由高至低
39 delay_us(50);
40 SCCB_SDA=0;
41 delay_us(50);
42 SCCB_SCL=0; //数据线恢复低电平，单操作函数必要
43}
44
45//SCCB停止信号
46//当时钟为高的时候,数据线的低到高,为SCCB停止信号
47//空闲状况下,SDA,SCL均为高电平
48void SCCB_Stop(void)
49{
50 SCCB_SDA=0;
51 delay_us(50);
52 SCCB_SCL=1;
53 delay_us(50);
54 SCCB_SDA=1;
55 delay_us(50);
56}
57//产生NA信号
58void SCCB_No_Ack(void)
59{
60 delay_us(50);
61 SCCB_SDA=1;
62 SCCB_SCL=1;
63 delay_us(50);
64 SCCB_SCL=0;
65 delay_us(50);
66 SCCB_SDA=0;
67 delay_us(50);
68}
69//SCCB,写入一个字节
70//返回值:0,成功;1,失败.
71 u8 SCCB_WR_Byte(u8 dat)
72{
73 u8 j,res;
74 for(j=0;j<8;j++) //循环8次发送数据
75 {
76 if(dat&0x80)SCCB_SDA=1;
77 else SCCB_SDA=0;
78 dat<<=1;
79 delay_us(50);
80 SCCB_SCL=1;
81 delay_us(50);
82 SCCB_SCL=0;
83 }
84 SCCB_SDA_IN(); //设置SDA为输入
85 delay_us(50);
86 SCCB_SCL=1; //接收第九位,以判断是否发送成功
87 delay_us(50);
88 if(SCCB_READ_SDA)res=1; //SDA=1发送失败，返回1
89 else res=0; //SDA=0发送成功，返回0
90 SCCB_SCL=0;
91 SCCB_SDA_OUT(); //设置SDA为输出
92 return res;
93}
94//SCCB 读取一个字节
95//在SCL的上升沿,数据锁存
96//返回值:读到的数据
97 u8 SCCB_RD_Byte(void)
98{
99 u8 temp=0,j;
100 SCCB_SDA_IN(); //设置SDA为输入
101 for(j=8;j>0;j--) //循环8次接收数据
102 {
103 delay_us(50);
104 SCCB_SCL=1;
105 temp=temp<<1;
106 if(SCCB_READ_SDA)temp++;
107 delay_us(50);
108 SCCB_SCL=0;
109 }
110 SCCB_SDA_OUT(); //设置SDA为输出
111 return temp;
112}
113//写寄存器
114//返回值:0,成功;1,失败.
115 u8 SCCB_WR_Reg(u8 reg,u8 data)
116{
117 u8 res=0;
118 SCCB_Start(); //启动SCCB传输
119 if(SCCB_WR_Byte(SCCB_ID))res=1; //写器件ID
120 delay_us(100);
121 if(SCCB_WR_Byte(reg))res=1; //写寄存器地址
122 delay_us(100);
123 if(SCCB_WR_Byte(data))res=1; //写数据
124 SCCB_Stop();
125 return res;
126}
127//读寄存器
128//返回值:读到的寄存器值
129 u8 SCCB_RD_Reg(u8 reg)
130{
131 u8 val=0;
132 SCCB_Start(); //启动SCCB传输
133 SCCB_WR_Byte(SCCB_ID); //写器件ID
134 delay_us(100);
135 SCCB_WR_Byte(reg); //写寄存器地址
136 delay_us(100);
137 SCCB_Stop();
138 delay_us(100);
139 //设置寄存器地址后，才是读
140 SCCB_Start();
141 SCCB_WR_Byte(SCCB_ID|0X01); //发送读命令
142 delay_us(100);
143 val=SCCB_RD_Byte(); //读取数据
144 SCCB_No_Ack();
145 SCCB_Stop();
146 return val;
147}
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
SCCB_READ_SDA
#define SCCB_READ_SDA
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h:23
SCCB_ID
#define SCCB_ID
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h:25
SCCB_SDA_IN
#define SCCB_SDA_IN()
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h:17
SCCB_SDA_OUT
#define SCCB_SDA_OUT()
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h:18
SCCB_SCL
#define SCCB_SCL
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h:21
SCCB_SDA
#define SCCB_SDA
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h:22
SCCB_No_Ack
void SCCB_No_Ack(void)
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:58
SCCB_Init
void SCCB_Init(void)
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:18
SCCB_RD_Byte
u8 SCCB_RD_Byte(void)
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:97
SCCB_WR_Reg
u8 SCCB_WR_Reg(u8 reg, u8 data)
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:115
SCCB_Stop
void SCCB_Stop(void)
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:48
SCCB_Start
void SCCB_Start(void)
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:35
SCCB_RD_Reg
u8 SCCB_RD_Reg(u8 reg)
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:129
SCCB_WR_Byte
u8 SCCB_WR_Byte(u8 dat)
Definition: at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:71
sccb.h
j
uint32_t j
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:44
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f435_437_board.c:306
u8
uint8_t u8
Definition: at32f435_437.h:364
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522


AT32F435/437 Firmwary Library: sccb.h File Reference

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • ov2640
Macros | Functions
at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h File Reference
#include "sys.h"

Go to the source code of this file.

Macros

#define | SCCB_SDA_IN() {GPIOB->MODER&=~(3<<(3*2));GPIOB->MODER|=0<<3*2;}
#define | SCCB_SDA_OUT() {GPIOB->MODER&=~(3<<(3*2));GPIOB->MODER|=1<<3*2;}
#define | SCCB_SCL PBout(4)
#define | SCCB_SDA PBout(3)
#define | SCCB_READ_SDA PBin(3)
#define | SCCB_ID 0X60

Functions

void | SCCB_Init (void)
void | SCCB_Start (void)
void | SCCB_Stop (void)
void | SCCB_No_Ack (void)
u8 | SCCB_WR_Byte (u8 dat)
u8 | SCCB_RD_Byte (void)
u8 | SCCB_WR_Reg (u8 reg, u8 data)
u8 | SCCB_RD_Reg (u8 reg)

Macro Definition Documentation

◆ SCCB_ID

#define SCCB_ID 0X60

Definition at line 25 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h.

◆ SCCB_READ_SDA

#define SCCB_READ_SDA PBin(3)

Definition at line 23 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h.

◆ SCCB_SCL

#define SCCB_SCL PBout(4)

Definition at line 21 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h.

◆ SCCB_SDA

#define SCCB_SDA PBout(3)

Definition at line 22 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h.

◆ SCCB_SDA_IN

#define SCCB_SDA_IN ( ) {GPIOB->MODER&=~(3<<(3*2));GPIOB->MODER|=0<<3*2;}

Definition at line 17 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h.

◆ SCCB_SDA_OUT

#define SCCB_SDA_OUT ( ) {GPIOB->MODER&=~(3<<(3*2));GPIOB->MODER|=1<<3*2;}

Definition at line 18 of file at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h.

Function Documentation

◆ SCCB_Init()

void SCCB_Init ( void )

Definition at line 18 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

◆ SCCB_No_Ack()

void SCCB_No_Ack ( void )

Definition at line 58 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

Referenced by SCCB_RD_Reg().

◆ SCCB_RD_Byte()

u8 SCCB_RD_Byte ( void )

Definition at line 97 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

Referenced by SCCB_RD_Reg().

◆ SCCB_RD_Reg()

u8 SCCB_RD_Reg ( u8 reg )

Definition at line 129 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

◆ SCCB_Start()

void SCCB_Start ( void )

Definition at line 35 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

Referenced by SCCB_RD_Reg(), and SCCB_WR_Reg().

◆ SCCB_Stop()

void SCCB_Stop ( void )

Definition at line 48 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

Referenced by SCCB_RD_Reg(), and SCCB_WR_Reg().

◆ SCCB_WR_Byte()

u8 SCCB_WR_Byte ( u8 dat )

Definition at line 71 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.

Referenced by SCCB_RD_Reg(), and SCCB_WR_Reg().

◆ SCCB_WR_Reg()

u8 SCCB_WR_Reg | ( | u8 | reg,
 |  | u8 | data
 | ) |  |

Definition at line 115 of file at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c.


AT32F435/437 Firmwary Library: sccb.h Source File

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • ov2640
at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
Go to the documentation of this file.
1#ifndef __SCCB_H
2#define __SCCB_H
3#include "sys.h"
5//本程序只供学习使用，未经作者许可，不得用于其它任何用途
6//ALIENTEK STM32F407开发板
7//OV系列摄像头 SCCB 驱动代码
8//正点原子@ALIENTEK
9//技术论坛:www.openedv.com
10//创建日期:2014/5/14
11//版本：V1.0
12//版权所有，盗版必究。
13//Copyright(C) 广州市星翼电子科技有限公司 2014-2024
14//All rights reserved
16//IO方向设置
17#define SCCB_SDA_IN() {GPIOB->MODER&=~(3<<(3*2));GPIOB->MODER|=0<<3*2;} //PB3输入模式
18#define SCCB_SDA_OUT() {GPIOB->MODER&=~(3<<(3*2));GPIOB->MODER|=1<<3*2;} //PB3输出模式
19
20//IO操作
21#define SCCB_SCL PBout(4) //SCL
22#define SCCB_SDA PBout(3) //SDA
23#define SCCB_READ_SDA PBin(3) //输入SDA
24
25#define SCCB_ID 0X60 //OV2640的ID
26
28void SCCB_Init(void);
29void SCCB_Start(void);
30void SCCB_Stop(void);
31void SCCB_No_Ack(void);
32 u8 SCCB_WR_Byte(u8 dat);
33 u8 SCCB_RD_Byte(void);
34 u8 SCCB_WR_Reg(u8 reg,u8 data);
35 u8 SCCB_RD_Reg(u8 reg);
36#endif
37
38
39
40
41
42
43
44
45
46
47
48
49
SCCB_No_Ack
void SCCB_No_Ack(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:58
SCCB_Init
void SCCB_Init(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:18
SCCB_RD_Byte
u8 SCCB_RD_Byte(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:97
SCCB_WR_Reg
u8 SCCB_WR_Reg(u8 reg, u8 data)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:115
SCCB_Stop
void SCCB_Stop(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:48
SCCB_Start
void SCCB_Start(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:35
SCCB_RD_Reg
u8 SCCB_RD_Reg(u8 reg)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:129
SCCB_WR_Byte
u8 SCCB_WR_Byte(u8 dat)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c:71
u8
uint8_t u8
Definition: at32f435_437.h:364


AT32F435/437 Firmwary Library: dvp.c File Reference

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • dvp
Data Structures | Functions | Variables
at_start_f437/examples/dvp/ov5640_capture/hardware/dvp/dvp.c File Reference

dvp program More...

#include "at32f435_437.h"
#include "dvp.h"
#include "xmc_lcd.h"
#include "ov5640.h"

Go to the source code of this file.

Data Structures

struct Descriptors_Format_def

Functions

void | jpeg_data_process (void)
void | dvp_int_handler (void)
handles dvp interrupt request. More...
void | dvp_config (void)
configure dvp More...
void | dvp_io_init (void)
initialize gpio for dvp More...
void | dvp_dma_init (uint32_t mem0addr, uint32_t mem1addr, uint16_t memsize)
initialize dma for dvp More...
void | dvp_start (void)
start dvp transmission More...
void | dvp_stop (void)
stop dvp transmission More...
void | DVP_IRQHandler (void)
dvp irq handler More...
void | dvp_frame_done (void)
dvp frame transmit done More...
void | EDMA_Stream4_IRQHandler (void)
edma stream4 irq handler More...

Variables

edma_init_type edma_init_struct
uint8_t ov_frame = 0

Detailed Description

dvp program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/dvp/ov5640_capture/hardware/dvp/dvp.c.


AT32F435/437 Firmwary Library: dvp.c Source File

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • dvp
at_start_f437/examples/dvp/ov5640_capture/hardware/dvp/dvp.c
Go to the documentation of this file.
1
27#include "at32f435_437.h"
28#include "dvp.h"
29#include "xmc_lcd.h"
30#include "ov5640.h"
31
40 edma_init_type edma_init_struct;
41uint8_t ov_frame = 0;
42
43extern void jpeg_data_process(void);
44void dvp_int_handler(void);
45
46typedef struct
47{
48 uint32_t CR_NDT;
49 uint32_t PA;
50 uint32_t M0A;
51 uint32_t LLP;
52
53}Descriptors_Format_def;
54
60void dvp_config(void)
61{
62 dvp_io_init();
63
64 nvic_irq_enable(DVP_IRQn, 0, 0);
65
66 dvp_capture_mode_set(DVP_CAP_FUNC_MODE_CONTINUOUS);
67 dvp_hsync_polarity_set(DVP_HSYNC_POLARITY_LOW);
68 dvp_vsync_polarity_set(DVP_VSYNC_POLARITY_LOW);
69 dvp_pclk_polarity_set(DVP_CLK_POLARITY_RISING);
70 dvp_zoomout_set(DVP_PCDC_ALL, DVP_PCDS_CAP_FIRST, DVP_LCDC_ALL, DVP_LCDS_CAP_FIRST);
71 dvp_zoomout_select(DVP_PCDES_CAP_FIRST);
72 dvp_pixel_data_length_set(DVP_PIXEL_DATA_LENGTH_8);
73#ifdef HARDWARE_MODE
74 dvp_sync_mode_set(DVP_SYNC_MODE_HARDWARE);
75#else
76 dvp_sync_mode_set(DVP_SYNC_MODE_EMBEDDED);
77 dvp_sync_code_set(0xFF, 0xFF, 0xC7, 0xDA);
78#endif
79
80 /* enable the interrupts */
81 dvp_interrupt_enable(DVP_CFD_INT | DVP_OVR_INT | DVP_ESE_INT | DVP_VS_INT | DVP_HS_INT, TRUE);
82
83 /* enable dvp by setting dvpen bit */
84 dvp_enable(TRUE);
85}
86
92void dvp_io_init(void)
93{
94 gpio_init_type gpio_initure;
95
96 crm_periph_clock_enable(CRM_DVP_PERIPH_CLOCK, TRUE);
97 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
98 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
99 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
100
101 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE4, GPIO_MUX_13);//HS
102 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE6, GPIO_MUX_13);//PCLK
103 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE9, GPIO_MUX_13);//D0
104 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE10, GPIO_MUX_13);//D1
105 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE11, GPIO_MUX_13);//D2
106 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE12, GPIO_MUX_13);//D3
107 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE4, GPIO_MUX_13);//D5
108 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE7, GPIO_MUX_13);//VS
109 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE9, GPIO_MUX_13);//D7
110 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE4, GPIO_MUX_13);//D4
111 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE5, GPIO_MUX_13);//D6
112
113 gpio_initure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_6 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11 | GPIO_PINS_12;
114 gpio_initure.gpio_mode = GPIO_MODE_MUX;
115 gpio_initure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
116 gpio_initure.gpio_pull = GPIO_PULL_UP;
117 gpio_initure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
118 gpio_init(GPIOA, &gpio_initure);
119
120 gpio_initure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_7 | GPIO_PINS_9;
121 gpio_init(GPIOB, &gpio_initure);
122
123 gpio_initure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5;
124 gpio_init(GPIOE, &gpio_initure);
125}
126
136void dvp_dma_init(uint32_t mem0addr, uint32_t mem1addr, uint16_t memsize)
137{
138 crm_periph_clock_enable(CRM_EDMA_PERIPH_CLOCK, TRUE);
139
140 edma_init_struct.peripheral_base_addr = (uint32_t)&DVP->dt;
141 edma_init_struct.memory0_base_addr = (uint32_t)mem0addr;
142 edma_init_struct.buffer_size = memsize;
143 edma_init_struct.direction = EDMA_DIR_PERIPHERAL_TO_MEMORY;
144 edma_init_struct.peripheral_inc_enable = FALSE;
145 edma_init_struct.memory_inc_enable = FALSE;
146 edma_init_struct.peripheral_data_width = EDMA_PERIPHERAL_DATA_WIDTH_WORD;
147 edma_init_struct.memory_data_width = EDMA_MEMORY_DATA_WIDTH_HALFWORD;
148 edma_init_struct.loop_mode_enable = TRUE;
149 edma_init_struct.priority = EDMA_PRIORITY_HIGH;
150 edma_init_struct.fifo_mode_enable = TRUE;
151 edma_init_struct.fifo_threshold = EDMA_FIFO_THRESHOLD_FULL;
152 edma_init_struct.memory_burst_mode = EDMA_MEMORY_SINGLE;
153 edma_init_struct.peripheral_burst_mode = EDMA_PERIPHERAL_SINGLE;
154
155 edma_reset(EDMA_STREAM4);
156 edma_init(EDMA_STREAM4, &edma_init_struct);
157
158 edmamux_enable(TRUE);
159 edmamux_init(EDMAMUX_CHANNEL4, EDMAMUX_DMAREQ_ID_DVP);
160
161 if(mem1addr != 0)
162 {
163 edma_double_buffer_mode_init(EDMA_STREAM4, mem1addr, EDMA_MEMORY_0);
164 edma_double_buffer_mode_enable(EDMA_STREAM4, TRUE);
165 }
166
167 edma_interrupt_enable(EDMA_STREAM4, EDMA_FDT_INT, TRUE);
168 nvic_irq_enable(EDMA_Stream4_IRQn, 0, 0);
169}
170
176void dvp_start(void)
177{
178 lcd_struct->lcd_setblock(0, 0, LCD_W, LCD_H);
179 edma_stream_enable(EDMA_STREAM4, TRUE);
180 dvp_capture_enable(TRUE);
181}
182
188void dvp_stop(void)
189{
190 dvp_capture_enable(FALSE);
191
192 while(DVP->ctrl & 0x01);
193
194 edma_stream_enable(EDMA_STREAM4, FALSE);
195}
196
202void DVP_IRQHandler(void)
203{
204 dvp_int_handler();
205}
206
212void dvp_frame_done(void)
213{
214 lcd_struct->lcd_setblock(0, 0, LCD_W, LCD_H);
215 ov_frame++;
216}
217
223void EDMA_Stream4_IRQHandler(void)
224{
225 if(edma_flag_get(EDMA_FDT4_FLAG) != RESET)
226 {
227 edma_flag_clear(EDMA_FDT4_FLAG);
228 }
229}
230
236void dvp_int_handler(void)
237{
238 /* synchronization error interrupt management */
239 if(dvp_flag_get(DVP_ESE_INT_FLAG) != RESET)
240 {
241 /* clear the synchronization error flag */
242 dvp_flag_clear(DVP_ESE_INT_FLAG);
243 }
244
245 /* overflow interrupt management */
246 if(dvp_flag_get(DVP_OVR_INT_FLAG) != RESET)
247 {
248 /* clear the overflow flag */
249 dvp_flag_clear(DVP_OVR_INT_FLAG);
250 }
251
252 /* line interrupt management */
253 if(dvp_flag_get(DVP_HS_INT_FLAG) != RESET)
254 {
255 /* clear the line interrupt flag */
256 dvp_flag_clear(DVP_HS_INT_FLAG);
257 }
258
259 /* vsync interrupt management */
260 if(dvp_flag_get(DVP_VS_INT_FLAG) != RESET)
261 {
262 /* clear the vsync flag */
263 dvp_flag_clear(DVP_VS_INT_FLAG);
264 }
265
266 /* end of frame interrupt management */
267 if(dvp_flag_get(DVP_CFD_INT_FLAG) != RESET)
268 {
269 /* clear the end of frame flag */
270 dvp_flag_clear(DVP_CFD_INT_FLAG);
271
272 dvp_frame_done();
273 }
274}
275
at32f435_437.h
at32f435_437 header file
dvp.h
header file of dvp program
LCD_H
#define LCD_H
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:79
dvp_stop
void dvp_stop(void)
stop dvp transmission
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:181
dvp_io_init
void dvp_io_init(void)
initialize gpio for dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:85
dvp_frame_done
void dvp_frame_done(void)
dvp frame transmit done
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:205
dvp_start
void dvp_start(void)
start dvp transmission
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:169
DVP_IRQHandler
void DVP_IRQHandler(void)
dvp irq handler
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:195
dvp_int_handler
void dvp_int_handler(void)
handles dvp interrupt request.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:229
LCD_W
#define LCD_W
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:78
dvp_dma_init
void dvp_dma_init(uint32_t mem0addr, uint32_t mem1addr, uint16_t memsize)
initialize dma for dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:129
lcd_struct
lcd_dev_type * lcd_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:48
dvp_config
void dvp_config(void)
configure dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:60
EDMA_Stream4_IRQHandler
void EDMA_Stream4_IRQHandler(void)
edma stream4 irq handler
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:216
jpeg_data_process
void jpeg_data_process(void)
edma_init_struct
edma_init_type edma_init_struct
Definition: at_start_f437/examples/dvp/ov5640_capture/hardware/dvp/dvp.c:40
ov_frame
uint8_t ov_frame
Definition: at_start_f437/examples/dvp/ov5640_capture/hardware/dvp/dvp.c:41
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_EDMA_PERIPH_CLOCK
@ CRM_EDMA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:114
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_DVP_PERIPH_CLOCK
@ CRM_DVP_PERIPH_CLOCK
Definition: at32f435_437_crm.h:119
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
dvp_capture_mode_set
void dvp_capture_mode_set(dvp_cfm_type cap_mode)
set dvp capture mode
Definition: at32f435_437_dvp.c:73
dvp_capture_enable
void dvp_capture_enable(confirm_state new_state)
enable or disable dvp capture
Definition: at32f435_437_dvp.c:60
dvp_flag_get
flag_status dvp_flag_get(uint32_t flag)
get dvp event/interrupt flag status
Definition: at32f435_437_dvp.c:342
dvp_sync_code_set
void dvp_sync_code_set(uint8_t fmsc, uint8_t fmec, uint8_t lnsc, uint8_t lnec)
set dvp synchronization code configuration
Definition: at32f435_437_dvp.c:135
dvp_pixel_data_length_set
void dvp_pixel_data_length_set(dvp_pdl_type dvp_pdl)
config dvp pixel data length
Definition: at32f435_437_dvp.c:217
dvp_hsync_polarity_set
void dvp_hsync_polarity_set(dvp_hsp_type hsync_pol)
set dvp horizontal synchronization polarity
Definition: at32f435_437_dvp.c:174
dvp_zoomout_select
void dvp_zoomout_select(dvp_pcdes_type dvp_pcdes)
set dvp zoomout select
Definition: at32f435_437_dvp.c:240
dvp_sync_mode_set
void dvp_sync_mode_set(dvp_sm_type sync_mode)
set dvp synchronization mode
Definition: at32f435_437_dvp.c:122
dvp_vsync_polarity_set
void dvp_vsync_polarity_set(dvp_vsp_type vsync_pol)
set dvp vertical synchronization polarity
Definition: at32f435_437_dvp.c:187
dvp_zoomout_set
void dvp_zoomout_set(dvp_pcdc_type dvp_pcdc, dvp_pcds_type dvp_pcds, dvp_lcdc_type dvp_lcdc, dvp_lcds_type dvp_lcds)
set dvp zoomout configuration
Definition: at32f435_437_dvp.c:267
dvp_interrupt_enable
void dvp_interrupt_enable(uint32_t dvp_int, confirm_state new_state)
enable or disable dvp interrupt
Definition: at32f435_437_dvp.c:312
dvp_enable
void dvp_enable(confirm_state new_state)
enable or disable dvp function
Definition: at32f435_437_dvp.c:227
dvp_pclk_polarity_set
void dvp_pclk_polarity_set(dvp_ckp_type eage)
set dvp pixel clock polarity
Definition: at32f435_437_dvp.c:161
dvp_flag_clear
void dvp_flag_clear(uint32_t flag)
clear dvp's pending flags
Definition: at32f435_437_dvp.c:388
DVP_VSYNC_POLARITY_LOW
@ DVP_VSYNC_POLARITY_LOW
Definition: at32f435_437_dvp.h:137
DVP_PIXEL_DATA_LENGTH_8
@ DVP_PIXEL_DATA_LENGTH_8
Definition: at32f435_437_dvp.h:156
DVP_SYNC_MODE_EMBEDDED
@ DVP_SYNC_MODE_EMBEDDED
Definition: at32f435_437_dvp.h:111
DVP_SYNC_MODE_HARDWARE
@ DVP_SYNC_MODE_HARDWARE
Definition: at32f435_437_dvp.h:110
DVP_HSYNC_POLARITY_LOW
@ DVP_HSYNC_POLARITY_LOW
Definition: at32f435_437_dvp.h:129
DVP_CAP_FUNC_MODE_CONTINUOUS
@ DVP_CAP_FUNC_MODE_CONTINUOUS
Definition: at32f435_437_dvp.h:101
DVP_PCDES_CAP_FIRST
@ DVP_PCDES_CAP_FIRST
Definition: at32f435_437_dvp.h:215
DVP_CLK_POLARITY_RISING
@ DVP_CLK_POLARITY_RISING
Definition: at32f435_437_dvp.h:119
DVP_LCDS_CAP_FIRST
@ DVP_LCDS_CAP_FIRST
Definition: at32f435_437_dvp.h:196
DVP_LCDC_ALL
@ DVP_LCDC_ALL
Definition: at32f435_437_dvp.h:187
DVP_PCDC_ALL
@ DVP_PCDC_ALL
Definition: at32f435_437_dvp.h:167
DVP_PCDS_CAP_FIRST
@ DVP_PCDS_CAP_FIRST
Definition: at32f435_437_dvp.h:178
DVP_VS_INT_FLAG
#define DVP_VS_INT_FLAG
Definition: at32f435_437_dvp.h:70
DVP_HS_INT_FLAG
#define DVP_HS_INT_FLAG
Definition: at32f435_437_dvp.h:71
DVP_CFD_INT_FLAG
#define DVP_CFD_INT_FLAG
Definition: at32f435_437_dvp.h:67
DVP_ESE_INT_FLAG
#define DVP_ESE_INT_FLAG
Definition: at32f435_437_dvp.h:69
DVP_OVR_INT_FLAG
#define DVP_OVR_INT_FLAG
Definition: at32f435_437_dvp.h:68
DVP_ESE_INT
#define DVP_ESE_INT
Definition: at32f435_437_dvp.h:84
DVP_VS_INT
#define DVP_VS_INT
Definition: at32f435_437_dvp.h:85
DVP_HS_INT
#define DVP_HS_INT
Definition: at32f435_437_dvp.h:86
DVP_OVR_INT
#define DVP_OVR_INT
Definition: at32f435_437_dvp.h:83
DVP_CFD_INT
#define DVP_CFD_INT
Definition: at32f435_437_dvp.h:82
DVP
#define DVP
Definition: at32f435_437_dvp.h:569
edma_flag_get
flag_status edma_flag_get(uint32_t edma_flag)
get the edma flag.
Definition: at32f435_437_edma.c:512
edma_flag_clear
void edma_flag_clear(uint32_t edma_flag)
clear the edma flag.
Definition: at32f435_437_edma.c:549
edma_double_buffer_mode_init
void edma_double_buffer_mode_init(edma_stream_type *edma_streamx, uint32_t memory1_addr, edma_memory_type current_memory)
config the the double buffer mode.
Definition: at32f435_437_edma.c:354
edmamux_init
void edmamux_init(edmamux_channel_type *edmamux_channelx, edmamux_requst_id_sel_type edmamux_req_id)
edmamux init.
Definition: at32f435_437_edma.c:718
edma_init
void edma_init(edma_stream_type *edma_streamx, edma_init_type *edma_init_struct)
edma init.
Definition: at32f435_437_edma.c:115
edma_double_buffer_mode_enable
void edma_double_buffer_mode_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the double memory mode.
Definition: at32f435_437_edma.c:383
edma_stream_enable
void edma_stream_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx.
Definition: at32f435_437_edma.c:198
edma_reset
void edma_reset(edma_stream_type *edma_streamx)
reset edma_streamx channely register.
Definition: at32f435_437_edma.c:58
edmamux_enable
void edmamux_enable(confirm_state new_state)
enable or disable the edma edmamux.
Definition: at32f435_437_edma.c:673
edma_interrupt_enable
void edma_interrupt_enable(edma_stream_type *edma_streamx, uint32_t edma_int, confirm_state new_state)
enable or disable the edma streamx interrupts.
Definition: at32f435_437_edma.c:225
EDMA_PRIORITY_HIGH
@ EDMA_PRIORITY_HIGH
Definition: at32f435_437_edma.h:191
EDMA_PERIPHERAL_DATA_WIDTH_WORD
@ EDMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_edma.h:171
EDMA_MEMORY_DATA_WIDTH_HALFWORD
@ EDMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_edma.h:180
EDMA_MEMORY_SINGLE
@ EDMA_MEMORY_SINGLE
Definition: at32f435_437_edma.h:224
EDMA_PERIPHERAL_SINGLE
@ EDMA_PERIPHERAL_SINGLE
Definition: at32f435_437_edma.h:235
EDMA_FIFO_THRESHOLD_FULL
@ EDMA_FIFO_THRESHOLD_FULL
Definition: at32f435_437_edma.h:203
EDMA_MEMORY_0
@ EDMA_MEMORY_0
Definition: at32f435_437_edma.h:150
EDMA_DIR_PERIPHERAL_TO_MEMORY
@ EDMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_edma.h:159
EDMAMUX_DMAREQ_ID_DVP
@ EDMAMUX_DMAREQ_ID_DVP
Definition: at32f435_437_edma.h:349
EDMA_FDT4_FLAG
#define EDMA_FDT4_FLAG
Definition: at32f435_437_edma.h:86
EDMA_FDT_INT
#define EDMA_FDT_INT
Definition: at32f435_437_edma.h:55
EDMA_STREAM4
#define EDMA_STREAM4
Definition: at32f435_437_edma.h:965
EDMAMUX_CHANNEL4
#define EDMAMUX_CHANNEL4
Definition: at32f435_437_edma.h:992
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_13
@ GPIO_MUX_13
Definition: at32f435_437_gpio.h:169
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
DVP_IRQn
@ DVP_IRQn
Definition: at32f435_437.h:221
EDMA_Stream4_IRQn
@ EDMA_Stream4_IRQn
Definition: at32f435_437.h:160
Descriptors_Format_def
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:47
edma_init_type
edma init type
Definition: at32f435_437_edma.h:440
edma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_edma.h:441
edma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_edma.h:444
edma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_edma.h:446
edma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_edma.h:445
edma_init_type::direction
edma_dir_type direction
Definition: at32f435_437_edma.h:443
edma_init_type::fifo_mode_enable
confirm_state fifo_mode_enable
Definition: at32f435_437_edma.h:451
edma_init_type::peripheral_data_width
edma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_edma.h:447
edma_init_type::fifo_threshold
edma_fifo_threshold_type fifo_threshold
Definition: at32f435_437_edma.h:452
edma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_edma.h:449
edma_init_type::priority
edma_priority_level_type priority
Definition: at32f435_437_edma.h:450
edma_init_type::memory0_base_addr
uint32_t memory0_base_addr
Definition: at32f435_437_edma.h:442
edma_init_type::peripheral_burst_mode
edma_peripheral_burst_type peripheral_burst_mode
Definition: at32f435_437_edma.h:454
edma_init_type::memory_data_width
edma_memory_data_size_type memory_data_width
Definition: at32f435_437_edma.h:448
edma_init_type::memory_burst_mode
edma_memory_burst_type memory_burst_mode
Definition: at32f435_437_edma.h:453
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
lcd_dev_type::lcd_setblock
void(* lcd_setblock)(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:48


AT32F435/437 Firmwary Library: dvp.h File Reference

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • dvp
Functions | Variables
at_start_f437/examples/dvp/ov5640_capture/hardware/dvp/dvp.h File Reference

header file of dvp program More...

#include "at32f435_437.h"

Go to the source code of this file.

Functions

void | dvp_config (void)
configure dvp More...
void | dvp_dma_init (uint32_t mem0addr, uint32_t mem1addr, uint16_t memsize)
initialize dma for dvp More...
void | dvp_start (void)
start dvp transmission More...
void | dvp_stop (void)
stop dvp transmission More...
void | dvp_io_init (void)
initialize gpio for dvp More...

Variables

edma_init_type edma_init_struct

Detailed Description

header file of dvp program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/dvp/ov5640_capture/hardware/dvp/dvp.h.


AT32F435/437 Firmwary Library: dvp.h Source File

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • dvp
at_start_f437/examples/dvp/ov5640_capture/hardware/dvp/dvp.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __DVP_H
29#define __DVP_H
30
31#ifdef __cplusplus
32 extern "C" {
33#endif
34
35/* Includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
46extern edma_init_type edma_init_struct;
47void dvp_config(void);
48void dvp_dma_init(uint32_t mem0addr,uint32_t mem1addr,uint16_t memsize);
49void dvp_start(void);
50void dvp_stop(void);
51void dvp_io_init(void);
52
61#ifdef __cplusplus
62}
63#endif
64
65#endif /*__DVP_H */
at32f435_437.h
at32f435_437 header file
dvp_stop
void dvp_stop(void)
stop dvp transmission
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:181
dvp_io_init
void dvp_io_init(void)
initialize gpio for dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:85
dvp_start
void dvp_start(void)
start dvp transmission
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:169
dvp_dma_init
void dvp_dma_init(uint32_t mem0addr, uint32_t mem1addr, uint16_t memsize)
initialize dma for dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:129
dvp_config
void dvp_config(void)
configure dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:60
edma_init_struct
edma_init_type edma_init_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:40
edma_init_type
edma init type
Definition: at32f435_437_edma.h:440


AT32F435/437 Firmwary Library: font.h File Reference

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • lcd
Variables
at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/font.h File Reference

Go to the source code of this file.

Variables

const unsigned char | asc2_1206 [95][12]
const unsigned char | asc2_1608 [95][16]
const unsigned char | asc2_2412 [95][36]
const unsigned char | asc2_3216 [95][128]


AT32F435/437 Firmwary Library: font.h Source File

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • lcd
at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/font.h
Go to the documentation of this file.
1/* *
2 **************************************************************************
3 * @file font.h
4 * @version v2.0.9
5 * @date 2022-06-28
6 * @brief header file of font
7 **************************************************************************
8 * Copyright notice & Disclaimer
9 *
10 * The software Board Support Package (BSP) that is made available to
11 * download from Artery official website is the copyrighted work of Artery.
12 * Artery authorizes customers to use, copy, and distribute the BSP
13 * software and its related documentation for the purpose of design and
14 * development in conjunction with Artery microcontrollers. Use of the
15 * software is governed by this copyright notice and the following disclaimer.
16 *
17 * THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES,
18 * GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS,
19 * TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR
20 * STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS,
21 * INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY,
22 * FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.
23 *
24 **************************************************************************
25 */
26
27#ifndef __FONT_H
28#define __FONT_H
29
38const unsigned char asc2_1206[95][12]={
39{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
40{0x00,0x00,0x00,0x00,0x3F,0x40,0x00,0x00,0x00,0x00,0x00,0x00},
41{0x00,0x00,0x30,0x00,0x40,0x00,0x30,0x00,0x40,0x00,0x00,0x00},
42{0x09,0x00,0x0B,0xC0,0x3D,0x00,0x0B,0xC0,0x3D,0x00,0x09,0x00},
43{0x18,0xC0,0x24,0x40,0x7F,0xE0,0x22,0x40,0x31,0x80,0x00,0x00},
44{0x18,0x00,0x24,0xC0,0x1B,0x00,0x0D,0x80,0x32,0x40,0x01,0x80},
45{0x03,0x80,0x1C,0x40,0x27,0x40,0x1C,0x80,0x07,0x40,0x00,0x40},
46{0x10,0x00,0x60,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
47{0x00,0x00,0x00,0x00,0x00,0x00,0x1F,0x80,0x20,0x40,0x40,0x20},
48{0x00,0x00,0x40,0x20,0x20,0x40,0x1F,0x80,0x00,0x00,0x00,0x00},
49{0x09,0x00,0x06,0x00,0x1F,0x80,0x06,0x00,0x09,0x00,0x00,0x00},
50{0x04,0x00,0x04,0x00,0x3F,0x80,0x04,0x00,0x04,0x00,0x00,0x00},
51{0x00,0x10,0x00,0x60,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
52{0x04,0x00,0x04,0x00,0x04,0x00,0x04,0x00,0x04,0x00,0x00,0x00},
53{0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
54{0x00,0x20,0x01,0xC0,0x06,0x00,0x38,0x00,0x40,0x00,0x00,0x00},
55{0x1F,0x80,0x20,0x40,0x20,0x40,0x20,0x40,0x1F,0x80,0x00,0x00},
56{0x00,0x00,0x10,0x40,0x3F,0xC0,0x00,0x40,0x00,0x00,0x00,0x00},
57{0x18,0xC0,0x21,0x40,0x22,0x40,0x24,0x40,0x18,0x40,0x00,0x00},
58{0x10,0x80,0x20,0x40,0x24,0x40,0x24,0x40,0x1B,0x80,0x00,0x00},
59{0x02,0x00,0x0D,0x00,0x11,0x00,0x3F,0xC0,0x01,0x40,0x00,0x00},
60{0x3C,0x80,0x24,0x40,0x24,0x40,0x24,0x40,0x23,0x80,0x00,0x00},
61{0x1F,0x80,0x24,0x40,0x24,0x40,0x34,0x40,0x03,0x80,0x00,0x00},
62{0x30,0x00,0x20,0x00,0x27,0xC0,0x38,0x00,0x20,0x00,0x00,0x00},
63{0x1B,0x80,0x24,0x40,0x24,0x40,0x24,0x40,0x1B,0x80,0x00,0x00},
64{0x1C,0x00,0x22,0xC0,0x22,0x40,0x22,0x40,0x1F,0x80,0x00,0x00},
65{0x00,0x00,0x00,0x00,0x08,0x40,0x00,0x00,0x00,0x00,0x00,0x00},
66{0x00,0x00,0x00,0x00,0x04,0x60,0x00,0x00,0x00,0x00,0x00,0x00},
67{0x00,0x00,0x04,0x00,0x0A,0x00,0x11,0x00,0x20,0x80,0x40,0x40},
68{0x09,0x00,0x09,0x00,0x09,0x00,0x09,0x00,0x09,0x00,0x00,0x00},
69{0x00,0x00,0x40,0x40,0x20,0x80,0x11,0x00,0x0A,0x00,0x04,0x00},
70{0x18,0x00,0x20,0x00,0x23,0x40,0x24,0x00,0x18,0x00,0x00,0x00},
71{0x1F,0x80,0x20,0x40,0x27,0x40,0x29,0x40,0x1F,0x40,0x00,0x00},
72{0x00,0x40,0x07,0xC0,0x39,0x00,0x0F,0x00,0x01,0xC0,0x00,0x40},
73{0x20,0x40,0x3F,0xC0,0x24,0x40,0x24,0x40,0x1B,0x80,0x00,0x00},
74{0x1F,0x80,0x20,0x40,0x20,0x40,0x20,0x40,0x30,0x80,0x00,0x00},
75{0x20,0x40,0x3F,0xC0,0x20,0x40,0x20,0x40,0x1F,0x80,0x00,0x00},
76{0x20,0x40,0x3F,0xC0,0x24,0x40,0x2E,0x40,0x30,0xC0,0x00,0x00},
77{0x20,0x40,0x3F,0xC0,0x24,0x40,0x2E,0x00,0x30,0x00,0x00,0x00},
78{0x0F,0x00,0x10,0x80,0x20,0x40,0x22,0x40,0x33,0x80,0x02,0x00},
79{0x20,0x40,0x3F,0xC0,0x04,0x00,0x04,0x00,0x3F,0xC0,0x20,0x40},
80{0x20,0x40,0x20,0x40,0x3F,0xC0,0x20,0x40,0x20,0x40,0x00,0x00},
81{0x00,0x60,0x20,0x20,0x20,0x20,0x3F,0xC0,0x20,0x00,0x20,0x00},
82{0x20,0x40,0x3F,0xC0,0x24,0x40,0x0B,0x00,0x30,0xC0,0x20,0x40},
83{0x20,0x40,0x3F,0xC0,0x20,0x40,0x00,0x40,0x00,0x40,0x00,0xC0},
84{0x3F,0xC0,0x3C,0x00,0x03,0xC0,0x3C,0x00,0x3F,0xC0,0x00,0x00},
85{0x20,0x40,0x3F,0xC0,0x0C,0x40,0x23,0x00,0x3F,0xC0,0x20,0x00},
86{0x1F,0x80,0x20,0x40,0x20,0x40,0x20,0x40,0x1F,0x80,0x00,0x00},
87{0x20,0x40,0x3F,0xC0,0x24,0x40,0x24,0x00,0x18,0x00,0x00,0x00},
88{0x1F,0x80,0x21,0x40,0x21,0x40,0x20,0xE0,0x1F,0xA0,0x00,0x00},
89{0x20,0x40,0x3F,0xC0,0x24,0x40,0x26,0x00,0x19,0xC0,0x00,0x40},
90{0x18,0xC0,0x24,0x40,0x24,0x40,0x22,0x40,0x31,0x80,0x00,0x00},
91{0x30,0x00,0x20,0x40,0x3F,0xC0,0x20,0x40,0x30,0x00,0x00,0x00},
92{0x20,0x00,0x3F,0x80,0x00,0x40,0x00,0x40,0x3F,0x80,0x20,0x00},
93{0x20,0x00,0x3E,0x00,0x01,0xC0,0x07,0x00,0x38,0x00,0x20,0x00},
94{0x38,0x00,0x07,0xC0,0x3C,0x00,0x07,0xC0,0x38,0x00,0x00,0x00},
95{0x20,0x40,0x39,0xC0,0x06,0x00,0x39,0xC0,0x20,0x40,0x00,0x00},
96{0x20,0x00,0x38,0x40,0x07,0xC0,0x38,0x40,0x20,0x00,0x00,0x00},
97{0x30,0x40,0x21,0xC0,0x26,0x40,0x38,0x40,0x20,0xC0,0x00,0x00},
98{0x00,0x00,0x00,0x00,0x7F,0xE0,0x40,0x20,0x40,0x20,0x00,0x00},
99{0x00,0x00,0x70,0x00,0x0C,0x00,0x03,0x80,0x00,0x40,0x00,0x00},
100{0x00,0x00,0x40,0x20,0x40,0x20,0x7F,0xE0,0x00,0x00,0x00,0x00},
101{0x00,0x00,0x20,0x00,0x40,0x00,0x20,0x00,0x00,0x00,0x00,0x00},
102{0x00,0x10,0x00,0x10,0x00,0x10,0x00,0x10,0x00,0x10,0x00,0x10},
103{0x00,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
104{0x00,0x00,0x02,0x80,0x05,0x40,0x05,0x40,0x03,0xC0,0x00,0x40},
105{0x20,0x00,0x3F,0xC0,0x04,0x40,0x04,0x40,0x03,0x80,0x00,0x00},
106{0x00,0x00,0x03,0x80,0x04,0x40,0x04,0x40,0x06,0x40,0x00,0x00},
107{0x00,0x00,0x03,0x80,0x04,0x40,0x24,0x40,0x3F,0xC0,0x00,0x40},
108{0x00,0x00,0x03,0x80,0x05,0x40,0x05,0x40,0x03,0x40,0x00,0x00},
109{0x00,0x00,0x04,0x40,0x1F,0xC0,0x24,0x40,0x24,0x40,0x20,0x00},
110{0x00,0x00,0x02,0xE0,0x05,0x50,0x05,0x50,0x06,0x50,0x04,0x20},
111{0x20,0x40,0x3F,0xC0,0x04,0x40,0x04,0x00,0x03,0xC0,0x00,0x40},
112{0x00,0x00,0x04,0x40,0x27,0xC0,0x00,0x40,0x00,0x00,0x00,0x00},
113{0x00,0x10,0x00,0x10,0x04,0x10,0x27,0xE0,0x00,0x00,0x00,0x00},
114{0x20,0x40,0x3F,0xC0,0x01,0x40,0x07,0x00,0x04,0xC0,0x04,0x40},
115{0x20,0x40,0x20,0x40,0x3F,0xC0,0x00,0x40,0x00,0x40,0x00,0x00},
116{0x07,0xC0,0x04,0x00,0x07,0xC0,0x04,0x00,0x03,0xC0,0x00,0x00},
117{0x04,0x40,0x07,0xC0,0x04,0x40,0x04,0x00,0x03,0xC0,0x00,0x40},
118{0x00,0x00,0x03,0x80,0x04,0x40,0x04,0x40,0x03,0x80,0x00,0x00},
119{0x04,0x10,0x07,0xF0,0x04,0x50,0x04,0x40,0x03,0x80,0x00,0x00},
120{0x00,0x00,0x03,0x80,0x04,0x40,0x04,0x50,0x07,0xF0,0x00,0x10},
121{0x04,0x40,0x07,0xC0,0x02,0x40,0x04,0x00,0x04,0x00,0x00,0x00},
122{0x00,0x00,0x06,0x40,0x05,0x40,0x05,0x40,0x04,0xC0,0x00,0x00},
123{0x00,0x00,0x04,0x00,0x1F,0x80,0x04,0x40,0x00,0x40,0x00,0x00},
124{0x04,0x00,0x07,0x80,0x00,0x40,0x04,0x40,0x07,0xC0,0x00,0x40},
125{0x04,0x00,0x07,0x00,0x04,0xC0,0x01,0x80,0x06,0x00,0x04,0x00},
126{0x06,0x00,0x01,0xC0,0x07,0x00,0x01,0xC0,0x06,0x00,0x00,0x00},
127{0x04,0x40,0x06,0xC0,0x01,0x00,0x06,0xC0,0x04,0x40,0x00,0x00},
128{0x04,0x10,0x07,0x10,0x04,0xE0,0x01,0x80,0x06,0x00,0x04,0x00},
129{0x00,0x00,0x04,0x40,0x05,0xC0,0x06,0x40,0x04,0x40,0x00,0x00},
130{0x00,0x00,0x00,0x00,0x04,0x00,0x7B,0xE0,0x40,0x20,0x00,0x00},
131{0x00,0x00,0x00,0x00,0x00,0x00,0xFF,0xF0,0x00,0x00,0x00,0x00},
132{0x00,0x00,0x40,0x20,0x7B,0xE0,0x04,0x00,0x00,0x00,0x00,0x00},
133{0x40,0x00,0x80,0x00,0x40,0x00,0x20,0x00,0x20,0x00,0x40,0x00},
134};
135
136const unsigned char asc2_1608[95][16]={
137{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
138{0x00,0x00,0x00,0x00,0x00,0x00,0x1F,0xCC,0x00,0x0C,0x00,0x00,0x00,0x00,0x00,0x00},
139{0x00,0x00,0x08,0x00,0x30,0x00,0x60,0x00,0x08,0x00,0x30,0x00,0x60,0x00,0x00,0x00},
140{0x02,0x20,0x03,0xFC,0x1E,0x20,0x02,0x20,0x03,0xFC,0x1E,0x20,0x02,0x20,0x00,0x00},
141{0x00,0x00,0x0E,0x18,0x11,0x04,0x3F,0xFF,0x10,0x84,0x0C,0x78,0x00,0x00,0x00,0x00},
142{0x0F,0x00,0x10,0x84,0x0F,0x38,0x00,0xC0,0x07,0x78,0x18,0x84,0x00,0x78,0x00,0x00},
143{0x00,0x78,0x0F,0x84,0x10,0xC4,0x11,0x24,0x0E,0x98,0x00,0xE4,0x00,0x84,0x00,0x08},
144{0x08,0x00,0x68,0x00,0x70,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
145{0x00,0x00,0x00,0x00,0x00,0x00,0x07,0xE0,0x18,0x18,0x20,0x04,0x40,0x02,0x00,0x00},
146{0x00,0x00,0x40,0x02,0x20,0x04,0x18,0x18,0x07,0xE0,0x00,0x00,0x00,0x00,0x00,0x00},
147{0x02,0x40,0x02,0x40,0x01,0x80,0x0F,0xF0,0x01,0x80,0x02,0x40,0x02,0x40,0x00,0x00},
148{0x00,0x80,0x00,0x80,0x00,0x80,0x0F,0xF8,0x00,0x80,0x00,0x80,0x00,0x80,0x00,0x00},
149{0x00,0x01,0x00,0x0D,0x00,0x0E,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
150{0x00,0x00,0x00,0x80,0x00,0x80,0x00,0x80,0x00,0x80,0x00,0x80,0x00,0x80,0x00,0x80},
151{0x00,0x00,0x00,0x0C,0x00,0x0C,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
152{0x00,0x00,0x00,0x06,0x00,0x18,0x00,0x60,0x01,0x80,0x06,0x00,0x18,0x00,0x20,0x00},
153{0x00,0x00,0x07,0xF0,0x08,0x08,0x10,0x04,0x10,0x04,0x08,0x08,0x07,0xF0,0x00,0x00},
154{0x00,0x00,0x08,0x04,0x08,0x04,0x1F,0xFC,0x00,0x04,0x00,0x04,0x00,0x00,0x00,0x00},
155{0x00,0x00,0x0E,0x0C,0x10,0x14,0x10,0x24,0x10,0x44,0x11,0x84,0x0E,0x0C,0x00,0x00},
156{0x00,0x00,0x0C,0x18,0x10,0x04,0x11,0x04,0x11,0x04,0x12,0x88,0x0C,0x70,0x00,0x00},
157{0x00,0x00,0x00,0xE0,0x03,0x20,0x04,0x24,0x08,0x24,0x1F,0xFC,0x00,0x24,0x00,0x00},
158{0x00,0x00,0x1F,0x98,0x10,0x84,0x11,0x04,0x11,0x04,0x10,0x88,0x10,0x70,0x00,0x00},
159{0x00,0x00,0x07,0xF0,0x08,0x88,0x11,0x04,0x11,0x04,0x18,0x88,0x00,0x70,0x00,0x00},
160{0x00,0x00,0x1C,0x00,0x10,0x00,0x10,0xFC,0x13,0x00,0x1C,0x00,0x10,0x00,0x00,0x00},
161{0x00,0x00,0x0E,0x38,0x11,0x44,0x10,0x84,0x10,0x84,0x11,0x44,0x0E,0x38,0x00,0x00},
162{0x00,0x00,0x07,0x00,0x08,0x8C,0x10,0x44,0x10,0x44,0x08,0x88,0x07,0xF0,0x00,0x00},
163{0x00,0x00,0x00,0x00,0x00,0x00,0x03,0x0C,0x03,0x0C,0x00,0x00,0x00,0x00,0x00,0x00},
164{0x00,0x00,0x00,0x00,0x00,0x01,0x01,0x06,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
165{0x00,0x00,0x00,0x80,0x01,0x40,0x02,0x20,0x04,0x10,0x08,0x08,0x10,0x04,0x00,0x00},
166{0x02,0x20,0x02,0x20,0x02,0x20,0x02,0x20,0x02,0x20,0x02,0x20,0x02,0x20,0x00,0x00},
167{0x00,0x00,0x10,0x04,0x08,0x08,0x04,0x10,0x02,0x20,0x01,0x40,0x00,0x80,0x00,0x00},
168{0x00,0x00,0x0E,0x00,0x12,0x00,0x10,0x0C,0x10,0x6C,0x10,0x80,0x0F,0x00,0x00,0x00},
169{0x03,0xE0,0x0C,0x18,0x13,0xE4,0x14,0x24,0x17,0xC4,0x08,0x28,0x07,0xD0,0x00,0x00},
170{0x00,0x04,0x00,0x3C,0x03,0xC4,0x1C,0x40,0x07,0x40,0x00,0xE4,0x00,0x1C,0x00,0x04},
171{0x10,0x04,0x1F,0xFC,0x11,0x04,0x11,0x04,0x11,0x04,0x0E,0x88,0x00,0x70,0x00,0x00},
172{0x03,0xE0,0x0C,0x18,0x10,0x04,0x10,0x04,0x10,0x04,0x10,0x08,0x1C,0x10,0x00,0x00},
173{0x10,0x04,0x1F,0xFC,0x10,0x04,0x10,0x04,0x10,0x04,0x08,0x08,0x07,0xF0,0x00,0x00},
174{0x10,0x04,0x1F,0xFC,0x11,0x04,0x11,0x04,0x17,0xC4,0x10,0x04,0x08,0x18,0x00,0x00},
175{0x10,0x04,0x1F,0xFC,0x11,0x04,0x11,0x00,0x17,0xC0,0x10,0x00,0x08,0x00,0x00,0x00},
176{0x03,0xE0,0x0C,0x18,0x10,0x04,0x10,0x04,0x10,0x44,0x1C,0x78,0x00,0x40,0x00,0x00},
177{0x10,0x04,0x1F,0xFC,0x10,0x84,0x00,0x80,0x00,0x80,0x10,0x84,0x1F,0xFC,0x10,0x04},
178{0x00,0x00,0x10,0x04,0x10,0x04,0x1F,0xFC,0x10,0x04,0x10,0x04,0x00,0x00,0x00,0x00},
179{0x00,0x03,0x00,0x01,0x10,0x01,0x10,0x01,0x1F,0xFE,0x10,0x00,0x10,0x00,0x00,0x00},
180{0x10,0x04,0x1F,0xFC,0x11,0x04,0x03,0x80,0x14,0x64,0x18,0x1C,0x10,0x04,0x00,0x00},
181{0x10,0x04,0x1F,0xFC,0x10,0x04,0x00,0x04,0x00,0x04,0x00,0x04,0x00,0x0C,0x00,0x00},
182{0x10,0x04,0x1F,0xFC,0x1F,0x00,0x00,0xFC,0x1F,0x00,0x1F,0xFC,0x10,0x04,0x00,0x00},
183{0x10,0x04,0x1F,0xFC,0x0C,0x04,0x03,0x00,0x00,0xE0,0x10,0x18,0x1F,0xFC,0x10,0x00},
184{0x07,0xF0,0x08,0x08,0x10,0x04,0x10,0x04,0x10,0x04,0x08,0x08,0x07,0xF0,0x00,0x00},
185{0x10,0x04,0x1F,0xFC,0x10,0x84,0x10,0x80,0x10,0x80,0x10,0x80,0x0F,0x00,0x00,0x00},
186{0x07,0xF0,0x08,0x18,0x10,0x24,0x10,0x24,0x10,0x1C,0x08,0x0A,0x07,0xF2,0x00,0x00},
187{0x10,0x04,0x1F,0xFC,0x11,0x04,0x11,0x00,0x11,0xC0,0x11,0x30,0x0E,0x0C,0x00,0x04},
188{0x00,0x00,0x0E,0x1C,0x11,0x04,0x10,0x84,0x10,0x84,0x10,0x44,0x1C,0x38,0x00,0x00},
189{0x18,0x00,0x10,0x00,0x10,0x04,0x1F,0xFC,0x10,0x04,0x10,0x00,0x18,0x00,0x00,0x00},
190{0x10,0x00,0x1F,0xF8,0x10,0x04,0x00,0x04,0x00,0x04,0x10,0x04,0x1F,0xF8,0x10,0x00},
191{0x10,0x00,0x1E,0x00,0x11,0xE0,0x00,0x1C,0x00,0x70,0x13,0x80,0x1C,0x00,0x10,0x00},
192{0x1F,0xC0,0x10,0x3C,0x00,0xE0,0x1F,0x00,0x00,0xE0,0x10,0x3C,0x1F,0xC0,0x00,0x00},
193{0x10,0x04,0x18,0x0C,0x16,0x34,0x01,0xC0,0x01,0xC0,0x16,0x34,0x18,0x0C,0x10,0x04},
194{0x10,0x00,0x1C,0x00,0x13,0x04,0x00,0xFC,0x13,0x04,0x1C,0x00,0x10,0x00,0x00,0x00},
195{0x08,0x04,0x10,0x1C,0x10,0x64,0x10,0x84,0x13,0x04,0x1C,0x04,0x10,0x18,0x00,0x00},
196{0x00,0x00,0x00,0x00,0x00,0x00,0x7F,0xFE,0x40,0x02,0x40,0x02,0x40,0x02,0x00,0x00},
197{0x00,0x00,0x30,0x00,0x0C,0x00,0x03,0x80,0x00,0x60,0x00,0x1C,0x00,0x03,0x00,0x00},
198{0x00,0x00,0x40,0x02,0x40,0x02,0x40,0x02,0x7F,0xFE,0x00,0x00,0x00,0x00,0x00,0x00},
199{0x00,0x00,0x00,0x00,0x20,0x00,0x40,0x00,0x40,0x00,0x40,0x00,0x20,0x00,0x00,0x00},
200{0x00,0x01,0x00,0x01,0x00,0x01,0x00,0x01,0x00,0x01,0x00,0x01,0x00,0x01,0x00,0x01},
201{0x00,0x00,0x40,0x00,0x40,0x00,0x20,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
202{0x00,0x00,0x00,0x98,0x01,0x24,0x01,0x44,0x01,0x44,0x01,0x44,0x00,0xFC,0x00,0x04},
203{0x10,0x00,0x1F,0xFC,0x00,0x88,0x01,0x04,0x01,0x04,0x00,0x88,0x00,0x70,0x00,0x00},
204{0x00,0x00,0x00,0x70,0x00,0x88,0x01,0x04,0x01,0x04,0x01,0x04,0x00,0x88,0x00,0x00},
205{0x00,0x00,0x00,0x70,0x00,0x88,0x01,0x04,0x01,0x04,0x11,0x08,0x1F,0xFC,0x00,0x04},
206{0x00,0x00,0x00,0xF8,0x01,0x44,0x01,0x44,0x01,0x44,0x01,0x44,0x00,0xC8,0x00,0x00},
207{0x00,0x00,0x01,0x04,0x01,0x04,0x0F,0xFC,0x11,0x04,0x11,0x04,0x11,0x00,0x18,0x00},
208{0x00,0x00,0x00,0xD6,0x01,0x29,0x01,0x29,0x01,0x29,0x01,0xC9,0x01,0x06,0x00,0x00},
209{0x10,0x04,0x1F,0xFC,0x00,0x84,0x01,0x00,0x01,0x00,0x01,0x04,0x00,0xFC,0x00,0x04},
210{0x00,0x00,0x01,0x04,0x19,0x04,0x19,0xFC,0x00,0x04,0x00,0x04,0x00,0x00,0x00,0x00},
211{0x00,0x00,0x00,0x03,0x00,0x01,0x01,0x01,0x19,0x01,0x19,0xFE,0x00,0x00,0x00,0x00},
212{0x10,0x04,0x1F,0xFC,0x00,0x24,0x00,0x40,0x01,0xB4,0x01,0x0C,0x01,0x04,0x00,0x00},
213{0x00,0x00,0x10,0x04,0x10,0x04,0x1F,0xFC,0x00,0x04,0x00,0x04,0x00,0x00,0x00,0x00},
214{0x01,0x04,0x01,0xFC,0x01,0x04,0x01,0x00,0x01,0xFC,0x01,0x04,0x01,0x00,0x00,0xFC},
215{0x01,0x04,0x01,0xFC,0x00,0x84,0x01,0x00,0x01,0x00,0x01,0x04,0x00,0xFC,0x00,0x04},
216{0x00,0x00,0x00,0xF8,0x01,0x04,0x01,0x04,0x01,0x04,0x01,0x04,0x00,0xF8,0x00,0x00},
217{0x01,0x01,0x01,0xFF,0x00,0x85,0x01,0x04,0x01,0x04,0x00,0x88,0x00,0x70,0x00,0x00},
218{0x00,0x00,0x00,0x70,0x00,0x88,0x01,0x04,0x01,0x04,0x01,0x05,0x01,0xFF,0x00,0x01},
219{0x01,0x04,0x01,0x04,0x01,0xFC,0x00,0x84,0x01,0x04,0x01,0x00,0x01,0x80,0x00,0x00},
220{0x00,0x00,0x00,0xCC,0x01,0x24,0x01,0x24,0x01,0x24,0x01,0x24,0x01,0x98,0x00,0x00},
221{0x00,0x00,0x01,0x00,0x01,0x00,0x07,0xF8,0x01,0x04,0x01,0x04,0x00,0x00,0x00,0x00},
222{0x01,0x00,0x01,0xF8,0x00,0x04,0x00,0x04,0x00,0x04,0x01,0x08,0x01,0xFC,0x00,0x04},
223{0x01,0x00,0x01,0x80,0x01,0x70,0x00,0x0C,0x00,0x10,0x01,0x60,0x01,0x80,0x01,0x00},
224{0x01,0xF0,0x01,0x0C,0x00,0x30,0x01,0xC0,0x00,0x30,0x01,0x0C,0x01,0xF0,0x01,0x00},
225{0x00,0x00,0x01,0x04,0x01,0x8C,0x00,0x74,0x01,0x70,0x01,0x8C,0x01,0x04,0x00,0x00},
226{0x01,0x01,0x01,0x81,0x01,0x71,0x00,0x0E,0x00,0x18,0x01,0x60,0x01,0x80,0x01,0x00},
227{0x00,0x00,0x01,0x84,0x01,0x0C,0x01,0x34,0x01,0x44,0x01,0x84,0x01,0x0C,0x00,0x00},
228{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x01,0x00,0x3E,0xFC,0x40,0x02,0x40,0x02},
229{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0xFF,0xFF,0x00,0x00,0x00,0x00,0x00,0x00},
230{0x00,0x00,0x40,0x02,0x40,0x02,0x3E,0xFC,0x01,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
231{0x00,0x00,0x60,0x00,0x80,0x00,0x80,0x00,0x40,0x00,0x40,0x00,0x20,0x00,0x20,0x00},
232};
233
234const unsigned char asc2_2412[95][36]={
235{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
236{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x0F,0x80,0x38,0x0F,0xFE,0x38,0x0F,0x80,0x38,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
237{0x00,0x00,0x00,0x00,0x00,0x00,0x01,0x00,0x00,0x06,0x00,0x00,0x0C,0x00,0x00,0x38,0x00,0x00,0x31,0x00,0x00,0x06,0x00,0x00,0x0C,0x00,0x00,0x38,0x00,0x00,0x30,0x00,0x00,0x00,0x00,0x00},
238{0x00,0x00,0x00,0x00,0x61,0x80,0x00,0x67,0xF8,0x07,0xF9,0x80,0x00,0x61,0x80,0x00,0x61,0x80,0x00,0x61,0x80,0x00,0x61,0x80,0x00,0x67,0xF8,0x07,0xF9,0x80,0x00,0x61,0x80,0x00,0x00,0x00},
239{0x00,0x00,0x00,0x00,0x00,0x00,0x01,0xC0,0xE0,0x03,0xE0,0xF0,0x06,0x30,0x08,0x04,0x18,0x08,0x1F,0xFF,0xFE,0x04,0x0E,0x08,0x07,0x87,0xF0,0x03,0x81,0xE0,0x00,0x00,0x00,0x00,0x00,0x00},
240{0x01,0xF0,0x00,0x06,0x0C,0x00,0x04,0x04,0x08,0x06,0x0C,0x70,0x01,0xF9,0xC0,0x00,0x0E,0x00,0x00,0x3B,0xE0,0x00,0xEC,0x18,0x07,0x08,0x08,0x04,0x0C,0x18,0x00,0x03,0xE0,0x00,0x00,0x00},
241{0x00,0x01,0xE0,0x00,0x07,0xF0,0x03,0xF8,0x18,0x04,0x1C,0x08,0x04,0x17,0x08,0x07,0xE1,0xD0,0x03,0xC0,0xE0,0x00,0x23,0xB0,0x00,0x3C,0x08,0x00,0x20,0x08,0x00,0x00,0x10,0x00,0x00,0x00},
242{0x00,0x00,0x00,0x01,0x00,0x00,0x31,0x00,0x00,0x32,0x00,0x00,0x1C,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
243{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7F,0x00,0x01,0xFF,0xC0,0x07,0x80,0xF0,0x0C,0x00,0x18,0x10,0x00,0x04,0x20,0x00,0x02,0x00,0x00,0x00},
244{0x00,0x00,0x00,0x20,0x00,0x02,0x10,0x00,0x04,0x0C,0x00,0x18,0x07,0x80,0xF0,0x01,0xFF,0xC0,0x00,0x7F,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
245{0x00,0x00,0x00,0x00,0x42,0x00,0x00,0x66,0x00,0x00,0x66,0x00,0x00,0x3C,0x00,0x00,0x18,0x00,0x03,0xFF,0xC0,0x00,0x18,0x00,0x00,0x3C,0x00,0x00,0x66,0x00,0x00,0x66,0x00,0x00,0x42,0x00},
246{0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x01,0xFF,0xC0,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00},
247{0x00,0x00,0x00,0x00,0x00,0x01,0x00,0x00,0x31,0x00,0x00,0x32,0x00,0x00,0x1C,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
248{0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x00,0x00},
249{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x38,0x00,0x00,0x38,0x00,0x00,0x38,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
250{0x00,0x00,0x00,0x00,0x00,0x06,0x00,0x00,0x1C,0x00,0x00,0x70,0x00,0x01,0x80,0x00,0x0E,0x00,0x00,0x38,0x00,0x00,0xC0,0x00,0x07,0x00,0x00,0x1C,0x00,0x00,0x30,0x00,0x00,0x00,0x00,0x00},
251{0x00,0x00,0x00,0x00,0x7F,0x80,0x01,0xFF,0xE0,0x03,0x80,0x70,0x06,0x00,0x18,0x04,0x00,0x08,0x04,0x00,0x08,0x06,0x00,0x18,0x03,0x80,0x70,0x01,0xFF,0xE0,0x00,0x7F,0x80,0x00,0x00,0x00},
252{0x00,0x00,0x00,0x00,0x00,0x00,0x01,0x00,0x08,0x01,0x00,0x08,0x01,0x00,0x08,0x03,0xFF,0xF8,0x07,0xFF,0xF8,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x00,0x00,0x00,0x00},
253{0x00,0x00,0x00,0x01,0xC0,0x38,0x02,0xC0,0x58,0x04,0x00,0x98,0x04,0x01,0x18,0x04,0x02,0x18,0x04,0x04,0x18,0x06,0x1C,0x18,0x03,0xF8,0x18,0x01,0xE0,0xF8,0x00,0x00,0x00,0x00,0x00,0x00},
254{0x00,0x00,0x00,0x01,0xC0,0xE0,0x03,0xC0,0xF0,0x04,0x00,0x08,0x04,0x08,0x08,0x04,0x08,0x08,0x06,0x18,0x08,0x03,0xF4,0x18,0x01,0xE7,0xF0,0x00,0x01,0xE0,0x00,0x00,0x00,0x00,0x00,0x00},
255{0x00,0x00,0x00,0x00,0x03,0x00,0x00,0x0D,0x00,0x00,0x11,0x00,0x00,0x61,0x00,0x00,0x81,0x08,0x03,0x01,0x08,0x07,0xFF,0xF8,0x0F,0xFF,0xF8,0x00,0x01,0x08,0x00,0x01,0x08,0x00,0x00,0x00},
256{0x00,0x00,0x00,0x00,0x00,0xE0,0x07,0xFC,0xD0,0x06,0x08,0x08,0x06,0x10,0x08,0x06,0x10,0x08,0x06,0x10,0x08,0x06,0x18,0x38,0x06,0x0F,0xF0,0x06,0x07,0xC0,0x00,0x00,0x00,0x00,0x00,0x00},
257{0x00,0x00,0x00,0x00,0x3F,0x80,0x01,0xFF,0xE0,0x03,0x84,0x30,0x02,0x08,0x18,0x04,0x10,0x08,0x04,0x10,0x08,0x04,0x10,0x08,0x07,0x18,0x10,0x03,0x0F,0xF0,0x00,0x07,0xC0,0x00,0x00,0x00},
258{0x00,0x00,0x00,0x00,0x00,0x00,0x03,0xC0,0x00,0x07,0x00,0x00,0x06,0x00,0x00,0x06,0x00,0xF8,0x06,0x07,0xF8,0x06,0x18,0x00,0x06,0xE0,0x00,0x07,0x00,0x00,0x06,0x00,0x00,0x00,0x00,0x00},
259{0x00,0x00,0x00,0x01,0xE1,0xE0,0x03,0xF7,0xF0,0x06,0x34,0x10,0x04,0x18,0x08,0x04,0x18,0x08,0x04,0x0C,0x08,0x04,0x0C,0x08,0x06,0x16,0x18,0x03,0xF3,0xF0,0x01,0xC1,0xE0,0x00,0x00,0x00},
260{0x00,0x00,0x00,0x00,0xF8,0x00,0x03,0xFC,0x30,0x03,0x06,0x38,0x04,0x02,0x08,0x04,0x02,0x08,0x04,0x02,0x08,0x04,0x04,0x10,0x03,0x08,0xF0,0x01,0xFF,0xC0,0x00,0x7F,0x00,0x00,0x00,0x00},
261{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x70,0x38,0x00,0x70,0x38,0x00,0x70,0x38,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
262{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x30,0x1A,0x00,0x30,0x1C,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
263{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x14,0x00,0x00,0x22,0x00,0x00,0x41,0x00,0x00,0x80,0x80,0x01,0x00,0x40,0x02,0x00,0x20,0x04,0x00,0x10,0x08,0x00,0x08,0x00,0x00,0x00},
264{0x00,0x00,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x21,0x00,0x00,0x00,0x00},
265{0x00,0x00,0x00,0x00,0x00,0x00,0x08,0x00,0x08,0x04,0x00,0x10,0x02,0x00,0x20,0x01,0x00,0x40,0x00,0x80,0x80,0x00,0x41,0x00,0x00,0x22,0x00,0x00,0x14,0x00,0x00,0x08,0x00,0x00,0x00,0x00},
266{0x00,0x00,0x00,0x03,0xC0,0x00,0x04,0xC0,0x00,0x04,0x00,0x00,0x08,0x00,0x38,0x08,0x0F,0x38,0x08,0x08,0x38,0x08,0x10,0x00,0x0C,0x30,0x00,0x07,0xE0,0x00,0x03,0xC0,0x00,0x00,0x00,0x00},
267{0x00,0x00,0x00,0x00,0x3F,0x80,0x00,0xFF,0xE0,0x03,0x80,0x70,0x02,0x0F,0x10,0x06,0x70,0x88,0x04,0xC0,0x88,0x04,0x83,0x08,0x04,0x7F,0x88,0x02,0xC0,0x90,0x03,0x01,0x20,0x00,0xFE,0x40},
268{0x00,0x00,0x08,0x00,0x00,0x18,0x00,0x01,0xF8,0x00,0x3E,0x08,0x01,0xC2,0x00,0x07,0x02,0x00,0x07,0xE2,0x00,0x00,0xFE,0x00,0x00,0x1F,0xC8,0x00,0x01,0xF8,0x00,0x00,0x38,0x00,0x00,0x08},
269{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x08,0x08,0x04,0x08,0x08,0x04,0x08,0x08,0x04,0x08,0x08,0x06,0x18,0x08,0x03,0xF4,0x18,0x01,0xE7,0xF0,0x00,0x01,0xE0,0x00,0x00,0x00},
270{0x00,0x00,0x00,0x00,0x3F,0x80,0x01,0xFF,0xE0,0x03,0x80,0x70,0x02,0x00,0x18,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x10,0x06,0x00,0x20,0x07,0x80,0xC0,0x00,0x00,0x00},
271{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x18,0x02,0x00,0x10,0x03,0x80,0x70,0x01,0xFF,0xE0,0x00,0x7F,0x80,0x00,0x00,0x00},
272{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x08,0x08,0x04,0x08,0x08,0x04,0x08,0x08,0x04,0x08,0x08,0x04,0x3E,0x08,0x04,0x00,0x08,0x06,0x00,0x18,0x01,0x00,0x60,0x00,0x00,0x00},
273{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x08,0x08,0x04,0x08,0x00,0x04,0x08,0x00,0x04,0x08,0x00,0x04,0x3E,0x00,0x06,0x00,0x00,0x06,0x00,0x00,0x01,0x80,0x00,0x00,0x00,0x00},
274{0x00,0x00,0x00,0x00,0x3F,0x80,0x01,0xFF,0xE0,0x03,0x80,0x70,0x06,0x00,0x18,0x04,0x00,0x08,0x04,0x02,0x08,0x04,0x02,0x08,0x02,0x03,0xF0,0x07,0x83,0xF0,0x00,0x02,0x00,0x00,0x02,0x00},
275{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x08,0x08,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x04,0x08,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x00,0x08},
276{0x00,0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x08,0x00,0x00,0x00,0x00,0x00,0x00},
277{0x00,0x00,0x00,0x00,0x00,0x06,0x00,0x00,0x07,0x00,0x00,0x01,0x04,0x00,0x01,0x04,0x00,0x01,0x04,0x00,0x03,0x07,0xFF,0xFE,0x07,0xFF,0xFC,0x04,0x00,0x00,0x04,0x00,0x00,0x04,0x00,0x00},
278{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x0C,0x08,0x00,0x18,0x00,0x00,0x3E,0x00,0x04,0xC7,0x80,0x05,0x03,0xC8,0x06,0x00,0xF8,0x04,0x00,0x38,0x04,0x00,0x18,0x00,0x00,0x08},
279{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x18,0x00,0x00,0x60,0x00,0x00,0x00},
280{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0x80,0x08,0x07,0xFC,0x00,0x00,0x7F,0xC0,0x00,0x03,0xF8,0x00,0x07,0xC0,0x00,0x78,0x00,0x07,0x80,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x00,0x08},
281{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0x00,0x08,0x03,0xC0,0x00,0x00,0xE0,0x00,0x00,0x38,0x00,0x00,0x1E,0x00,0x00,0x07,0x00,0x00,0x01,0xC0,0x04,0x00,0xF0,0x07,0xFF,0xF8,0x04,0x00,0x00},
282{0x00,0x00,0x00,0x00,0x7F,0x80,0x01,0xFF,0xE0,0x03,0x80,0x70,0x06,0x00,0x18,0x04,0x00,0x08,0x04,0x00,0x08,0x06,0x00,0x18,0x03,0x00,0x30,0x01,0xFF,0xE0,0x00,0x7F,0x80,0x00,0x00,0x00},
283{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x04,0x08,0x04,0x04,0x00,0x04,0x04,0x00,0x04,0x04,0x00,0x04,0x04,0x00,0x06,0x0C,0x00,0x03,0xF8,0x00,0x01,0xF0,0x00,0x00,0x00,0x00},
284{0x00,0x00,0x00,0x00,0x7F,0x80,0x01,0xFF,0xE0,0x03,0x80,0x70,0x06,0x00,0x88,0x04,0x00,0x88,0x04,0x00,0xC8,0x06,0x00,0x3C,0x03,0x00,0x3E,0x01,0xFF,0xE6,0x00,0x7F,0x84,0x00,0x00,0x00},
285{0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x08,0x08,0x04,0x08,0x00,0x04,0x0C,0x00,0x04,0x0F,0x00,0x04,0x0B,0xC0,0x06,0x10,0xF0,0x03,0xF0,0x38,0x01,0xE0,0x08,0x00,0x00,0x08},
286{0x00,0x00,0x00,0x01,0xE0,0xF8,0x03,0xF0,0x30,0x06,0x30,0x10,0x04,0x18,0x08,0x04,0x18,0x08,0x04,0x0C,0x08,0x04,0x0C,0x08,0x02,0x06,0x18,0x02,0x07,0xF0,0x07,0x81,0xE0,0x00,0x00,0x00},
287{0x01,0x80,0x00,0x06,0x00,0x00,0x04,0x00,0x00,0x04,0x00,0x00,0x04,0x00,0x08,0x07,0xFF,0xF8,0x07,0xFF,0xF8,0x04,0x00,0x08,0x04,0x00,0x00,0x04,0x00,0x00,0x06,0x00,0x00,0x01,0x80,0x00},
288{0x04,0x00,0x00,0x07,0xFF,0xE0,0x07,0xFF,0xF0,0x04,0x00,0x18,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x04,0x00,0x10,0x07,0xFF,0xE0,0x04,0x00,0x00},
289{0x04,0x00,0x00,0x06,0x00,0x00,0x07,0xE0,0x00,0x07,0xFE,0x00,0x04,0x1F,0xE0,0x00,0x01,0xF8,0x00,0x00,0x38,0x00,0x01,0xE0,0x04,0x3E,0x00,0x07,0xC0,0x00,0x06,0x00,0x00,0x04,0x00,0x00},
290{0x04,0x00,0x00,0x07,0xE0,0x00,0x07,0xFF,0xC0,0x04,0x1F,0xF8,0x00,0x07,0xC0,0x07,0xF8,0x00,0x07,0xFF,0x80,0x04,0x3F,0xF8,0x00,0x07,0xC0,0x04,0xF8,0x00,0x07,0x00,0x00,0x04,0x00,0x00},
291{0x00,0x00,0x00,0x04,0x00,0x08,0x06,0x00,0x18,0x07,0xC0,0x78,0x05,0xF1,0xC8,0x00,0x3E,0x00,0x00,0x1F,0x80,0x04,0x63,0xE8,0x07,0x80,0xF8,0x06,0x00,0x18,0x04,0x00,0x08,0x00,0x00,0x00},
292{0x04,0x00,0x00,0x06,0x00,0x00,0x07,0x80,0x00,0x07,0xE0,0x08,0x04,0x7C,0x08,0x00,0x1F,0xF8,0x00,0x07,0xF8,0x00,0x18,0x08,0x04,0xE0,0x08,0x07,0x00,0x00,0x06,0x00,0x00,0x04,0x00,0x00},
293{0x00,0x00,0x00,0x01,0x00,0x08,0x06,0x00,0x38,0x04,0x00,0xF8,0x04,0x03,0xE8,0x04,0x0F,0x08,0x04,0x7C,0x08,0x05,0xF0,0x08,0x07,0xC0,0x08,0x07,0x00,0x18,0x04,0x00,0x60,0x00,0x00,0x00},
294{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x3F,0xFF,0xFE,0x20,0x00,0x02,0x20,0x00,0x02,0x20,0x00,0x02,0x20,0x00,0x02,0x20,0x00,0x02,0x00,0x00,0x00},
295{0x00,0x00,0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x07,0x00,0x00,0x00,0xC0,0x00,0x00,0x38,0x00,0x00,0x06,0x00,0x00,0x01,0xC0,0x00,0x00,0x30,0x00,0x00,0x0E,0x00,0x00,0x01,0x00,0x00,0x00},
296{0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x02,0x20,0x00,0x02,0x20,0x00,0x02,0x20,0x00,0x02,0x20,0x00,0x02,0x3F,0xFF,0xFE,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
297{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x10,0x00,0x00,0x30,0x00,0x00,0x20,0x00,0x00,0x30,0x00,0x00,0x10,0x00,0x00,0x08,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
298{0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01,0x00,0x00,0x01},
299{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x20,0x00,0x00,0x10,0x00,0x00,0x10,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
300{0x00,0x00,0x00,0x00,0x00,0xF0,0x00,0x19,0xF8,0x00,0x1B,0x18,0x00,0x22,0x08,0x00,0x26,0x08,0x00,0x24,0x08,0x00,0x24,0x10,0x00,0x3F,0xF8,0x00,0x1F,0xF8,0x00,0x00,0x08,0x00,0x00,0x18},
301{0x00,0x00,0x00,0x04,0x00,0x00,0x07,0xFF,0xF8,0x0F,0xFF,0xF0,0x00,0x18,0x18,0x00,0x10,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x30,0x18,0x00,0x1F,0xF0,0x00,0x0F,0xC0,0x00,0x00,0x00},
302{0x00,0x00,0x00,0x00,0x07,0xC0,0x00,0x1F,0xF0,0x00,0x18,0x30,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x3C,0x08,0x00,0x1C,0x10,0x00,0x00,0x60,0x00,0x00,0x00,0x00,0x00,0x00},
303{0x00,0x00,0x00,0x00,0x07,0xC0,0x00,0x1F,0xF0,0x00,0x38,0x18,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x04,0x10,0x10,0x07,0xFF,0xF8,0x0F,0xFF,0xF0,0x00,0x00,0x10,0x00,0x00,0x00},
304{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0xC0,0x00,0x1F,0xF0,0x00,0x12,0x30,0x00,0x22,0x18,0x00,0x22,0x08,0x00,0x22,0x08,0x00,0x32,0x08,0x00,0x1E,0x10,0x00,0x0E,0x20,0x00,0x00,0x00},
305{0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x20,0x08,0x00,0x20,0x08,0x01,0xFF,0xF8,0x03,0xFF,0xF8,0x06,0x20,0x08,0x04,0x20,0x08,0x04,0x20,0x08,0x07,0x20,0x00,0x03,0x00,0x00,0x00,0x00,0x00},
306{0x00,0x00,0x00,0x00,0x00,0x0E,0x00,0x0E,0x6E,0x00,0x1F,0xF3,0x00,0x31,0xB1,0x00,0x20,0xB1,0x00,0x20,0xB1,0x00,0x31,0x91,0x00,0x1F,0x13,0x00,0x2E,0x1E,0x00,0x20,0x0E,0x00,0x30,0x00},
307{0x00,0x00,0x00,0x04,0x00,0x08,0x07,0xFF,0xF8,0x0F,0xFF,0xF8,0x00,0x10,0x08,0x00,0x20,0x00,0x00,0x20,0x00,0x00,0x20,0x08,0x00,0x3F,0xF8,0x00,0x1F,0xF8,0x00,0x00,0x08,0x00,0x00,0x00},
308{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x06,0x3F,0xF8,0x06,0x3F,0xF8,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x00,0x00,0x00,0x00},
309{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x03,0x00,0x00,0x03,0x00,0x20,0x01,0x00,0x20,0x01,0x00,0x20,0x03,0x06,0x3F,0xFE,0x06,0x3F,0xFC,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
310{0x00,0x00,0x00,0x04,0x00,0x08,0x07,0xFF,0xF8,0x0F,0xFF,0xF8,0x00,0x01,0x88,0x00,0x03,0x00,0x00,0x2F,0xC0,0x00,0x38,0xF8,0x00,0x20,0x38,0x00,0x20,0x08,0x00,0x00,0x08,0x00,0x00,0x00},
311{0x00,0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x08,0x04,0x00,0x08,0x04,0x00,0x08,0x07,0xFF,0xF8,0x0F,0xFF,0xF8,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x00,0x00,0x00,0x00,0x00},
312{0x00,0x20,0x08,0x00,0x3F,0xF8,0x00,0x3F,0xF8,0x00,0x10,0x08,0x00,0x20,0x00,0x00,0x3F,0xF8,0x00,0x3F,0xF8,0x00,0x10,0x08,0x00,0x20,0x00,0x00,0x3F,0xF8,0x00,0x3F,0xF8,0x00,0x00,0x08},
313{0x00,0x00,0x00,0x00,0x20,0x08,0x00,0x3F,0xF8,0x00,0x3F,0xF8,0x00,0x10,0x08,0x00,0x10,0x00,0x00,0x20,0x00,0x00,0x20,0x08,0x00,0x3F,0xF8,0x00,0x1F,0xF8,0x00,0x00,0x08,0x00,0x00,0x00},
314{0x00,0x00,0x00,0x00,0x07,0xC0,0x00,0x0F,0xF0,0x00,0x18,0x30,0x00,0x30,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x30,0x08,0x00,0x18,0x30,0x00,0x0F,0xF0,0x00,0x07,0xC0,0x00,0x00,0x00},
315{0x00,0x00,0x00,0x00,0x20,0x01,0x00,0x3F,0xFF,0x00,0x3F,0xFF,0x00,0x10,0x11,0x00,0x20,0x09,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x30,0x38,0x00,0x1F,0xF0,0x00,0x0F,0xC0,0x00,0x00,0x00},
316{0x00,0x00,0x00,0x00,0x07,0xC0,0x00,0x1F,0xF0,0x00,0x38,0x18,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x20,0x09,0x00,0x10,0x11,0x00,0x1F,0xFF,0x00,0x3F,0xFF,0x00,0x00,0x01,0x00,0x00,0x00},
317{0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x3F,0xF8,0x00,0x3F,0xF8,0x00,0x08,0x08,0x00,0x10,0x08,0x00,0x20,0x08,0x00,0x20,0x00,0x00,0x30,0x00,0x00,0x30,0x00,0x00,0x00,0x00},
318{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x0C,0x78,0x00,0x1E,0x18,0x00,0x33,0x08,0x00,0x23,0x08,0x00,0x21,0x08,0x00,0x21,0x88,0x00,0x21,0x98,0x00,0x30,0xF0,0x00,0x38,0x60,0x00,0x00,0x00},
319{0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x20,0x00,0x00,0x20,0x00,0x00,0xFF,0xF0,0x03,0xFF,0xF8,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x00,0x30,0x00,0x00,0x00,0x00,0x00,0x00},
320{0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x3F,0xF0,0x00,0x7F,0xF8,0x00,0x00,0x18,0x00,0x00,0x08,0x00,0x00,0x08,0x00,0x20,0x10,0x00,0x3F,0xF8,0x00,0x7F,0xF0,0x00,0x00,0x10,0x00,0x00,0x00},
321{0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x30,0x00,0x00,0x3C,0x00,0x00,0x3F,0x80,0x00,0x23,0xF0,0x00,0x00,0x78,0x00,0x00,0x70,0x00,0x23,0x80,0x00,0x3C,0x00,0x00,0x30,0x00,0x00,0x20,0x00},
322{0x00,0x20,0x00,0x00,0x3C,0x00,0x00,0x3F,0xE0,0x00,0x23,0xF8,0x00,0x00,0xE0,0x00,0x27,0x00,0x00,0x3E,0x00,0x00,0x3F,0xE0,0x00,0x21,0xF8,0x00,0x01,0xE0,0x00,0x3E,0x00,0x00,0x20,0x00},
323{0x00,0x00,0x00,0x00,0x20,0x08,0x00,0x20,0x08,0x00,0x38,0x38,0x00,0x3E,0x68,0x00,0x27,0x80,0x00,0x03,0xC8,0x00,0x2C,0xF8,0x00,0x38,0x38,0x00,0x20,0x18,0x00,0x20,0x08,0x00,0x00,0x00},
324{0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x30,0x03,0x00,0x3C,0x01,0x00,0x3F,0x83,0x00,0x23,0xEC,0x00,0x00,0x70,0x00,0x23,0x80,0x00,0x3C,0x00,0x00,0x20,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
325{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x38,0x08,0x00,0x20,0x38,0x00,0x20,0xF8,0x00,0x23,0xE8,0x00,0x2F,0x88,0x00,0x3E,0x08,0x00,0x38,0x08,0x00,0x20,0x18,0x00,0x00,0x70,0x00,0x00,0x00},
326{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x14,0x00,0x1F,0xF7,0xFC,0x30,0x00,0x06,0x20,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00},
327{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0xFF,0xFF,0xFF,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
328{0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x02,0x30,0x00,0x06,0x1F,0xF7,0xFC,0x00,0x14,0x00,0x00,0x08,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
329{0x00,0x00,0x00,0x18,0x00,0x00,0x60,0x00,0x00,0x40,0x00,0x00,0x40,0x00,0x00,0x20,0x00,0x00,0x10,0x00,0x00,0x08,0x00,0x00,0x04,0x00,0x00,0x04,0x00,0x00,0x0C,0x00,0x00,0x10,0x00,0x00},
330};
331
332const unsigned char asc2_3216[95][128]={
333{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
334{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0xF0,0x00,0xC0,0x07,0xFF,0xE1,0xE0,0x07,0xF0,0x01,0xE0,0x00,0x00,0x00,0xC0,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
335{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x01,0xC0,0x00,0x00,0x07,0x80,0x00,0x00,0x1F,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0x1C,0x20,0x00,0x00,0x01,0xC0,0x00,0x00,0x07,0x80,0x00,0x00,0x1F,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0x1C,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
336{0x00,0x00,0x00,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0F,0xE0,0x00,0x1F,0xFC,0x00,0x03,0xF8,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0F,0xE0,0x00,0x1F,0xFC,0x00,0x03,0xF8,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x18,0x0C,0x00,0x00,0x00,0x00,0x00},
337{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0x80,0x00,0x78,0x07,0xC0,0x00,0xFC,0x06,0x40,0x01,0x0E,0x00,0x20,0x03,0x07,0x00,0x20,0x02,0x03,0x80,0x20,0x0F,0xFF,0xFF,0xFC,0x02,0x01,0xC0,0x20,0x02,0x00,0xE0,0x60,0x01,0x30,0x70,0x40,0x01,0xF0,0x3F,0x80,0x00,0xF0,0x1F,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
338{0x00,0xFE,0x00,0x00,0x01,0xFF,0x00,0x00,0x03,0x01,0x80,0x00,0x02,0x00,0x80,0x60,0x03,0x01,0x81,0xC0,0x01,0xFF,0x07,0x00,0x00,0xFE,0x18,0x00,0x00,0x00,0xE0,0x00,0x00,0x03,0xBF,0x00,0x00,0x0C,0xFF,0xC0,0x00,0x71,0x80,0x60,0x01,0xC1,0x00,0x20,0x03,0x01,0x80,0x60,0x00,0x00,0xFF,0xC0,0x00,0x00,0x3F,0x00,0x00,0x00,0x00,0x00},
339{0x00,0x00,0x1F,0x00,0x00,0x00,0x7F,0xC0,0x00,0xFC,0xC0,0xC0,0x01,0xFF,0x80,0x60,0x03,0x03,0xE0,0x20,0x02,0x02,0x78,0x20,0x02,0x06,0x1E,0x20,0x03,0xFC,0x07,0x40,0x01,0xF0,0x03,0x80,0x00,0x01,0x03,0xC0,0x00,0x01,0x1C,0x60,0x00,0x01,0xE0,0x20,0x00,0x01,0x00,0x20,0x00,0x01,0x00,0x40,0x00,0x00,0x01,0x80,0x00,0x00,0x00,0x00},
340{0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x00,0x1C,0x60,0x00,0x00,0x1C,0x40,0x00,0x00,0x1F,0x80,0x00,0x00,0x0F,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
341{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0xF8,0x00,0x00,0x3F,0xFF,0x00,0x00,0x78,0x07,0xC0,0x01,0xC0,0x00,0xE0,0x03,0x00,0x00,0x30,0x04,0x00,0x00,0x08,0x08,0x00,0x00,0x04,0x10,0x00,0x00,0x02,0x00,0x00,0x00,0x00},
342{0x00,0x00,0x00,0x00,0x10,0x00,0x00,0x02,0x08,0x00,0x00,0x04,0x04,0x00,0x00,0x08,0x03,0x00,0x00,0x30,0x01,0xC0,0x00,0xE0,0x00,0x78,0x07,0xC0,0x00,0x3F,0xFF,0x00,0x00,0x07,0xF8,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
343{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x0C,0x18,0x00,0x00,0x0E,0x38,0x00,0x00,0x0E,0x38,0x00,0x00,0x06,0x30,0x00,0x00,0x03,0x60,0x00,0x00,0x61,0x43,0x80,0x00,0xFF,0xFF,0x80,0x00,0x61,0x43,0x00,0x00,0x03,0x60,0x00,0x00,0x06,0x30,0x00,0x00,0x0E,0x38,0x00,0x00,0x0E,0x38,0x00,0x00,0x0C,0x18,0x00,0x00,0x00,0x00,0x00},
344{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x7F,0xFF,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x00,0x00},
345{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0xE3,0x00,0x00,0x00,0xE2,0x00,0x00,0x00,0xFC,0x00,0x00,0x00,0x78,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
346{0x00,0x00,0x00,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x00,0x00},
347{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0xC0,0x00,0x00,0x01,0xE0,0x00,0x00,0x01,0xE0,0x00,0x00,0x00,0xC0,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
348{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x0C,0x00,0x00,0x00,0x38,0x00,0x00,0x00,0xE0,0x00,0x00,0x03,0x80,0x00,0x00,0x0E,0x00,0x00,0x00,0x38,0x00,0x00,0x00,0xE0,0x00,0x00,0x03,0x80,0x00,0x00,0x0E,0x00,0x00,0x00,0x38,0x00,0x00,0x00,0xE0,0x00,0x00,0x03,0x80,0x00,0x00,0x0E,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
349{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x0F,0xF8,0x00,0x00,0x7F,0xFF,0x00,0x00,0xF0,0x07,0x80,0x01,0x80,0x00,0xC0,0x03,0x00,0x00,0x60,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0x00,0x00,0x60,0x01,0x80,0x00,0xC0,0x00,0xE0,0x03,0x80,0x00,0x7F,0xFF,0x00,0x00,0x0F,0xF8,0x00,0x00,0x00,0x00,0x00},
350{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x80,0x00,0x20,0x00,0x80,0x00,0x20,0x00,0x80,0x00,0x20,0x00,0x80,0x00,0x60,0x01,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x00,0x00,0x00,0x60,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
351{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x78,0x00,0xE0,0x00,0x98,0x01,0x60,0x01,0x00,0x02,0x60,0x02,0x00,0x04,0x60,0x02,0x00,0x08,0x60,0x02,0x00,0x10,0x60,0x02,0x00,0x20,0x60,0x02,0x00,0x40,0x60,0x03,0x00,0x80,0x60,0x01,0x83,0x00,0x60,0x01,0xFE,0x00,0xE0,0x00,0x7C,0x07,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
352{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0xF0,0x07,0x80,0x01,0xF0,0x07,0xC0,0x01,0x00,0x00,0x40,0x02,0x00,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x03,0x03,0x80,0x20,0x01,0x86,0x80,0x40,0x01,0xFC,0xC0,0xC0,0x00,0x78,0x7F,0x80,0x00,0x00,0x1E,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
353{0x00,0x00,0x00,0x00,0x00,0x00,0x08,0x00,0x00,0x00,0x38,0x00,0x00,0x00,0x48,0x00,0x00,0x01,0x88,0x00,0x00,0x06,0x08,0x00,0x00,0x0C,0x08,0x10,0x00,0x30,0x08,0x10,0x00,0x40,0x08,0x10,0x01,0xFF,0xFF,0xF0,0x03,0xFF,0xFF,0xF0,0x03,0xFF,0xFF,0xF0,0x00,0x00,0x08,0x10,0x00,0x00,0x08,0x10,0x00,0x00,0x08,0x10,0x00,0x00,0x00,0x00},
354{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0x80,0x00,0x1F,0x86,0x40,0x03,0xE1,0x00,0x20,0x03,0x02,0x00,0x20,0x03,0x04,0x00,0x20,0x03,0x04,0x00,0x20,0x03,0x04,0x00,0x20,0x03,0x04,0x00,0x20,0x03,0x06,0x00,0x40,0x03,0x03,0x01,0xC0,0x03,0x01,0xFF,0x80,0x03,0x00,0x7E,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
355{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0xFC,0x00,0x00,0x3F,0xFF,0x00,0x00,0x70,0xC3,0x80,0x00,0x81,0x80,0xC0,0x01,0x01,0x00,0x60,0x03,0x02,0x00,0x20,0x02,0x02,0x00,0x20,0x02,0x02,0x00,0x20,0x02,0x02,0x00,0x20,0x02,0x03,0x00,0x40,0x01,0xC1,0x80,0xC0,0x00,0xC0,0xFF,0x80,0x00,0x00,0x7E,0x00,0x00,0x00,0x00,0x00},
356{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0xF0,0x00,0x00,0x03,0xC0,0x00,0x00,0x03,0x80,0x00,0x00,0x03,0x00,0x00,0x00,0x03,0x00,0x07,0xE0,0x03,0x00,0x3F,0xE0,0x03,0x01,0xC0,0x00,0x03,0x06,0x00,0x00,0x03,0x18,0x00,0x00,0x03,0x60,0x00,0x00,0x03,0x80,0x00,0x00,0x03,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
357{0x00,0x00,0x00,0x00,0x00,0x00,0x1F,0x00,0x00,0x78,0x3F,0x80,0x00,0xFC,0x60,0xC0,0x01,0x8E,0xC0,0x40,0x03,0x07,0x80,0x20,0x02,0x03,0x00,0x20,0x02,0x01,0x80,0x20,0x02,0x01,0x80,0x20,0x02,0x01,0xC0,0x20,0x03,0x01,0xE0,0x40,0x01,0x86,0x70,0xC0,0x00,0xFC,0x3F,0x80,0x00,0x78,0x1F,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
358{0x00,0x00,0x00,0x00,0x00,0x3F,0x00,0x00,0x00,0xFF,0x81,0xC0,0x01,0xC0,0xC1,0xC0,0x01,0x00,0x60,0x20,0x02,0x00,0x20,0x20,0x02,0x00,0x20,0x20,0x02,0x00,0x20,0x20,0x02,0x00,0x20,0x60,0x02,0x00,0x40,0xC0,0x01,0x00,0xC1,0x80,0x00,0xC1,0x8F,0x00,0x00,0x7F,0xFE,0x00,0x00,0x1F,0xF0,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
359{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x03,0x00,0xC0,0x00,0x07,0x81,0xE0,0x00,0x07,0x81,0xE0,0x00,0x03,0x00,0xC0,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
360{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x06,0x00,0x66,0x00,0x06,0x00,0x78,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
361{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x80,0x00,0x00,0x01,0xC0,0x00,0x00,0x03,0x60,0x00,0x00,0x06,0x30,0x00,0x00,0x0C,0x18,0x00,0x00,0x18,0x0C,0x00,0x00,0x30,0x06,0x00,0x00,0x60,0x03,0x00,0x00,0xC0,0x01,0x80,0x01,0x00,0x00,0x40,0x02,0x00,0x00,0x20,0x04,0x00,0x00,0x10,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
362{0x00,0x00,0x00,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x00,0x00,0x00},
363{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x00,0x10,0x02,0x00,0x00,0x20,0x01,0x00,0x00,0x40,0x00,0xC0,0x01,0x80,0x00,0x60,0x03,0x00,0x00,0x30,0x06,0x00,0x00,0x18,0x0C,0x00,0x00,0x0C,0x18,0x00,0x00,0x06,0x30,0x00,0x00,0x03,0x60,0x00,0x00,0x01,0xC0,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
364{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x78,0x00,0x00,0x01,0xF8,0x00,0x00,0x02,0x38,0x00,0x00,0x02,0x00,0x00,0x00,0x04,0x00,0x00,0xC0,0x04,0x00,0x79,0xE0,0x04,0x00,0x81,0xE0,0x04,0x01,0x00,0xC0,0x04,0x03,0x00,0x00,0x02,0x02,0x00,0x00,0x03,0x06,0x00,0x00,0x01,0xFC,0x00,0x00,0x00,0xF8,0x00,0x00,0x00,0x00,0x00,0x00},
365{0x00,0x00,0x00,0x00,0x00,0x0F,0xF8,0x00,0x00,0x3F,0xFE,0x00,0x00,0x70,0x07,0x80,0x00,0xC0,0x00,0xC0,0x01,0x01,0xF8,0x40,0x03,0x07,0xFC,0x20,0x02,0x1E,0x04,0x20,0x02,0x30,0x08,0x20,0x02,0x20,0x30,0x20,0x02,0x3F,0xFC,0x20,0x01,0x3F,0x04,0x40,0x01,0x80,0x0C,0xC0,0x00,0xE0,0x31,0x80,0x00,0x1F,0xC2,0x00,0x00,0x00,0x00,0x00},
366{0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x60,0x00,0x00,0x03,0xE0,0x00,0x00,0x3E,0x20,0x00,0x03,0xE0,0x20,0x00,0x3E,0x20,0x00,0x03,0xE0,0x20,0x00,0x03,0x80,0x20,0x00,0x07,0xFC,0x20,0x00,0x00,0x3F,0xE0,0x00,0x00,0x03,0xFE,0x20,0x00,0x00,0x3F,0xE0,0x00,0x00,0x01,0xE0,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
367{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x03,0x03,0x00,0x20,0x01,0x86,0x80,0x60,0x01,0xFC,0xC0,0xC0,0x00,0xF8,0x7F,0x80,0x00,0x00,0x1F,0x00,0x00,0x00,0x00,0x00},
368{0x00,0x00,0x00,0x00,0x00,0x07,0xF8,0x00,0x00,0x3F,0xFF,0x00,0x00,0x70,0x07,0x80,0x00,0xC0,0x00,0xC0,0x01,0x00,0x00,0x40,0x03,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x01,0x00,0x00,0x40,0x01,0x80,0x00,0xC0,0x03,0xC0,0x01,0x80,0x00,0x30,0x06,0x00,0x00,0x00,0x00,0x00},
369{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0x00,0x00,0x60,0x01,0x00,0x00,0x40,0x01,0x80,0x00,0xC0,0x00,0xF0,0x07,0x80,0x00,0x7F,0xFE,0x00,0x00,0x0F,0xF8,0x00,0x00,0x00,0x00,0x00},
370{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x03,0x80,0x20,0x02,0x0F,0xE0,0x20,0x03,0x00,0x00,0x60,0x03,0xC0,0x00,0xE0,0x00,0x60,0x03,0x00,0x00,0x00,0x00,0x00},
371{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x00,0x02,0x01,0x00,0x00,0x02,0x01,0x00,0x00,0x02,0x01,0x00,0x00,0x02,0x03,0x80,0x00,0x03,0x0F,0xE0,0x00,0x03,0x00,0x00,0x00,0x03,0xC0,0x00,0x00,0x00,0x60,0x00,0x00},
372{0x00,0x00,0x00,0x00,0x00,0x07,0xF8,0x00,0x00,0x3F,0xFE,0x00,0x00,0x70,0x07,0x80,0x01,0xC0,0x01,0xC0,0x01,0x00,0x00,0x40,0x03,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x01,0x00,0x20,0x20,0x01,0x00,0x20,0x40,0x03,0xC0,0x3F,0x80,0x00,0x30,0x3F,0x80,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00},
373{0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x80,0x20,0x02,0x00,0x80,0x20,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x02,0x00,0x80,0x20,0x02,0x00,0x80,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
374{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
375{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x0E,0x00,0x00,0x00,0x0F,0x00,0x00,0x00,0x0F,0x00,0x00,0x00,0x01,0x02,0x00,0x00,0x01,0x02,0x00,0x00,0x01,0x02,0x00,0x00,0x03,0x02,0x00,0x00,0x06,0x03,0xFF,0xFF,0xFC,0x03,0xFF,0xFF,0xF8,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
376{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0xC0,0x20,0x02,0x01,0x00,0x20,0x00,0x07,0x80,0x00,0x00,0x0F,0xE0,0x00,0x00,0x30,0xF8,0x00,0x02,0x60,0x3E,0x20,0x03,0x80,0x0F,0x20,0x03,0x00,0x03,0xE0,0x02,0x00,0x00,0xE0,0x02,0x00,0x00,0x20,0x00,0x00,0x00,0x20},
377{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x60,0x00,0x00,0x00,0xE0,0x00,0x00,0x03,0x00,0x00,0x00,0x00,0x00},
378{0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xE0,0x00,0x20,0x03,0xFF,0x00,0x20,0x00,0x1F,0xF0,0x00,0x00,0x01,0xFF,0x80,0x00,0x00,0x0F,0xE0,0x00,0x00,0x1E,0x00,0x00,0x03,0xE0,0x00,0x00,0x3E,0x00,0x20,0x03,0xE0,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20},
379{0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0x80,0x00,0x20,0x03,0xF0,0x00,0x20,0x00,0xFC,0x00,0x00,0x00,0x1F,0x00,0x00,0x00,0x07,0xC0,0x00,0x00,0x01,0xF0,0x00,0x00,0x00,0x7C,0x00,0x02,0x00,0x1F,0x80,0x02,0x00,0x07,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
380{0x00,0x00,0x00,0x00,0x00,0x0F,0xF8,0x00,0x00,0x3F,0xFE,0x00,0x00,0xF0,0x07,0x80,0x01,0x80,0x00,0xC0,0x01,0x00,0x00,0x40,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x01,0x00,0x00,0x40,0x01,0x80,0x00,0xC0,0x00,0xF0,0x03,0x80,0x00,0x3F,0xFE,0x00,0x00,0x0F,0xF8,0x00,0x00,0x00,0x00,0x00},
381{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x80,0x20,0x02,0x00,0x80,0x20,0x02,0x00,0x80,0x00,0x02,0x00,0x80,0x00,0x02,0x00,0x80,0x00,0x02,0x00,0x80,0x00,0x03,0x01,0x80,0x00,0x01,0x83,0x00,0x00,0x00,0xFE,0x00,0x00,0x00,0x7C,0x00,0x00,0x00,0x00,0x00,0x00},
382{0x00,0x00,0x00,0x00,0x00,0x0F,0xF8,0x00,0x00,0x7F,0xFF,0x00,0x00,0xF0,0x03,0x80,0x01,0x80,0x01,0xC0,0x01,0x00,0x06,0x40,0x02,0x00,0x04,0x20,0x02,0x00,0x04,0x20,0x02,0x00,0x06,0x20,0x02,0x00,0x03,0xE0,0x01,0x00,0x00,0xF8,0x01,0x80,0x00,0x5C,0x00,0xE0,0x03,0x8C,0x00,0x3F,0xFF,0x0C,0x00,0x0F,0xFC,0x18,0x00,0x00,0x00,0x00},
383{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x01,0x00,0x20,0x02,0x01,0x00,0x20,0x02,0x01,0x80,0x00,0x02,0x01,0xE0,0x00,0x02,0x01,0xFC,0x00,0x03,0x03,0x3F,0x80,0x01,0x86,0x07,0xE0,0x01,0xFC,0x00,0xE0,0x00,0xF8,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
384{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x78,0x06,0x00,0x00,0xFE,0x01,0xE0,0x01,0x86,0x00,0xC0,0x03,0x03,0x00,0x40,0x02,0x03,0x00,0x20,0x02,0x01,0x80,0x20,0x02,0x01,0x80,0x20,0x02,0x01,0xC0,0x20,0x02,0x00,0xC0,0x20,0x01,0x00,0xE0,0x60,0x01,0x80,0x70,0xC0,0x03,0xE0,0x3F,0x80,0x00,0x00,0x1F,0x00,0x00,0x00,0x00,0x00},
385{0x00,0x00,0x00,0x00,0x00,0x60,0x00,0x00,0x03,0x80,0x00,0x00,0x03,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x03,0xFF,0xFF,0xE0,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x03,0x80,0x00,0x00,0x00,0xE0,0x00,0x00,0x00,0x00,0x00,0x00},
386{0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x03,0xFF,0xFF,0x00,0x03,0xFF,0xFF,0xC0,0x02,0x00,0x00,0x40,0x02,0x00,0x00,0x60,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x02,0x00,0x00,0x40,0x02,0x00,0x00,0x80,0x03,0xFF,0xFF,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
387{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x03,0xC0,0x00,0x00,0x03,0xFC,0x00,0x00,0x02,0x3F,0xC0,0x00,0x00,0x03,0xF8,0x00,0x00,0x00,0x7F,0x80,0x00,0x00,0x07,0xE0,0x00,0x00,0x07,0x80,0x00,0x00,0x78,0x00,0x02,0x03,0xC0,0x00,0x02,0x3C,0x00,0x00,0x03,0xC0,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00},
388{0x02,0x00,0x00,0x00,0x03,0xC0,0x00,0x00,0x03,0xFF,0x80,0x00,0x02,0x3F,0xFE,0x00,0x02,0x00,0x7F,0xE0,0x00,0x00,0x0F,0x00,0x02,0x00,0xF0,0x00,0x03,0xEF,0x00,0x00,0x03,0xFF,0x80,0x00,0x02,0x0F,0xFE,0x00,0x00,0x00,0x3F,0xE0,0x00,0x00,0x1F,0x00,0x02,0x07,0xE0,0x00,0x03,0xF8,0x00,0x00,0x03,0x00,0x00,0x00,0x02,0x00,0x00,0x00},
389{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0x80,0x00,0xE0,0x03,0xF0,0x03,0x20,0x02,0xFC,0x0C,0x20,0x02,0x1F,0x30,0x00,0x00,0x07,0xC0,0x00,0x00,0x07,0xF0,0x00,0x02,0x18,0x7C,0x00,0x02,0x60,0x1F,0x20,0x03,0x80,0x03,0xE0,0x02,0x00,0x00,0xE0,0x02,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
390{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x03,0x00,0x00,0x00,0x03,0xC0,0x00,0x00,0x03,0xF8,0x00,0x00,0x02,0x3E,0x00,0x20,0x02,0x0F,0xC0,0x20,0x00,0x01,0xFF,0xE0,0x00,0x00,0x7F,0xE0,0x00,0x03,0x80,0x20,0x02,0x1C,0x00,0x20,0x02,0x70,0x00,0x00,0x03,0x80,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
391{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x60,0x00,0xE0,0x03,0x80,0x03,0xE0,0x03,0x00,0x0F,0xA0,0x02,0x00,0x3E,0x20,0x02,0x00,0xF8,0x20,0x02,0x03,0xE0,0x20,0x02,0x0F,0x80,0x20,0x02,0x3E,0x00,0x20,0x02,0x78,0x00,0x20,0x03,0xE0,0x00,0x60,0x03,0x80,0x00,0xE0,0x02,0x00,0x03,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
392{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x1F,0xFF,0xFF,0xFC,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
393{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0x00,0x00,0x00,0x03,0xC0,0x00,0x00,0x00,0x78,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0x03,0xC0,0x00,0x00,0x00,0xF0,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0x07,0x80,0x00,0x00,0x00,0xF0,0x00,0x00,0x00,0x3C,0x00,0x00,0x00,0x06,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
394{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x10,0x00,0x00,0x04,0x1F,0xFF,0xFF,0xFC,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
395{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x08,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x10,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
396{0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01},
397{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x10,0x00,0x00,0x00,0x10,0x00,0x00,0x00,0x10,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x08,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
398{0x00,0x00,0x00,0x00,0x00,0x00,0x03,0x80,0x00,0x01,0x8F,0xC0,0x00,0x03,0x8C,0x60,0x00,0x06,0x18,0x20,0x00,0x04,0x10,0x20,0x00,0x04,0x10,0x20,0x00,0x04,0x20,0x20,0x00,0x04,0x20,0x40,0x00,0x06,0x20,0x40,0x00,0x03,0xFF,0xC0,0x00,0x01,0xFF,0xE0,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0xC0,0x00,0x00,0x00,0x00},
399{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x03,0xFF,0xFF,0xE0,0x07,0xFF,0xFF,0xC0,0x00,0x01,0x80,0xC0,0x00,0x02,0x00,0x60,0x00,0x02,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x06,0x00,0x40,0x00,0x03,0x00,0xC0,0x00,0x01,0xFF,0x80,0x00,0x00,0xFE,0x00,0x00,0x00,0x00,0x00},
400{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7E,0x00,0x00,0x01,0xFF,0x80,0x00,0x03,0x81,0xC0,0x00,0x02,0x00,0x40,0x00,0x06,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x06,0x00,0x20,0x00,0x03,0xC0,0x40,0x00,0x01,0xC0,0x80,0x00,0x00,0x03,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
401{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7E,0x00,0x00,0x01,0xFF,0x80,0x00,0x03,0x80,0xC0,0x00,0x06,0x00,0x60,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x02,0x04,0x00,0x40,0x02,0x02,0x00,0x80,0x03,0xFF,0xFF,0xE0,0x07,0xFF,0xFF,0xC0,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x00},
402{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7E,0x00,0x00,0x01,0xFF,0x80,0x00,0x03,0x11,0xC0,0x00,0x02,0x10,0x40,0x00,0x04,0x10,0x60,0x00,0x04,0x10,0x20,0x00,0x04,0x10,0x20,0x00,0x04,0x10,0x20,0x00,0x06,0x10,0x20,0x00,0x03,0x10,0x40,0x00,0x01,0xF0,0xC0,0x00,0x00,0x71,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
403{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x7F,0xFF,0xE0,0x01,0xFF,0xFF,0xE0,0x01,0x04,0x00,0x20,0x03,0x04,0x00,0x20,0x02,0x04,0x00,0x20,0x02,0x04,0x00,0x20,0x02,0x04,0x00,0x00,0x02,0x00,0x00,0x00,0x01,0xC0,0x00,0x00,0x01,0xC0,0x00,0x00},
404{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x1C,0x00,0x00,0xE3,0x3E,0x00,0x03,0xFF,0xC2,0x00,0x02,0x0C,0xC3,0x00,0x04,0x04,0xC1,0x00,0x04,0x04,0xC1,0x00,0x04,0x04,0xC1,0x00,0x04,0x04,0xC1,0x00,0x06,0x0C,0xC1,0x00,0x03,0xF8,0xC3,0x00,0x05,0xF0,0x62,0x00,0x06,0x00,0x7E,0x00,0x06,0x00,0x3C,0x00,0x00,0x00,0x00},
405{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x07,0xFF,0xFF,0xE0,0x00,0x01,0x00,0x20,0x00,0x02,0x00,0x20,0x00,0x06,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x06,0x00,0x20,0x00,0x03,0xFF,0xE0,0x00,0x01,0xFF,0xE0,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20},
406{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x03,0x87,0xFF,0xE0,0x03,0x8F,0xFF,0xE0,0x03,0x80,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
407{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x06,0x00,0x00,0x00,0x07,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01,0x00,0x04,0x00,0x01,0x00,0x04,0x00,0x01,0x00,0x04,0x00,0x03,0x00,0x04,0x00,0x06,0x03,0x87,0xFF,0xFC,0x03,0x8F,0xFF,0xF8,0x03,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
408{0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x07,0xFF,0xFF,0xE0,0x00,0x00,0x08,0x20,0x00,0x00,0x10,0x20,0x00,0x00,0x30,0x00,0x00,0x00,0xFC,0x00,0x00,0x05,0x8E,0x00,0x00,0x07,0x07,0xA0,0x00,0x06,0x01,0xE0,0x00,0x04,0x00,0xE0,0x00,0x04,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
409{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x02,0x00,0x00,0x20,0x03,0xFF,0xFF,0xE0,0x07,0xFF,0xFF,0xE0,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
410{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x07,0xFF,0xE0,0x00,0x0F,0xFF,0xE0,0x00,0x02,0x00,0x20,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x07,0xFF,0xE0,0x00,0x03,0xFF,0xE0,0x00,0x02,0x00,0x20,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x07,0xFF,0xE0,0x00,0x03,0xFF,0xE0,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
411{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x07,0xFF,0xE0,0x00,0x0F,0xFF,0xE0,0x00,0x01,0x00,0x20,0x00,0x02,0x00,0x20,0x00,0x02,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x06,0x00,0x20,0x00,0x03,0xFF,0xE0,0x00,0x01,0xFF,0xE0,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20},
412{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7E,0x00,0x00,0x00,0xFF,0x80,0x00,0x03,0x81,0xC0,0x00,0x02,0x00,0x40,0x00,0x06,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x06,0x00,0x20,0x00,0x02,0x00,0x40,0x00,0x03,0x81,0xC0,0x00,0x01,0xFF,0x80,0x00,0x00,0x7E,0x00,0x00,0x00,0x00,0x00},
413{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x01,0x00,0x04,0x00,0x01,0x00,0x07,0xFF,0xFF,0x00,0x0F,0xFF,0xFF,0x00,0x01,0x00,0xC1,0x00,0x02,0x00,0x41,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x06,0x00,0x40,0x00,0x03,0x01,0xC0,0x00,0x01,0xFF,0x80,0x00,0x00,0x7E,0x00,0x00,0x00,0x00,0x00},
414{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7E,0x00,0x00,0x01,0xFF,0x80,0x00,0x03,0x80,0xC0,0x00,0x02,0x00,0x60,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x02,0x00,0x41,0x00,0x03,0x00,0xC1,0x00,0x03,0xFF,0xFF,0x00,0x07,0xFF,0xFF,0x00,0x00,0x00,0x01,0x00,0x00,0x00,0x01},
415{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x0F,0xFF,0xE0,0x00,0x0F,0xFF,0xE0,0x00,0x00,0xC0,0x20,0x00,0x01,0x00,0x20,0x00,0x02,0x00,0x20,0x00,0x06,0x00,0x20,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x07,0x00,0x00,0x00,0x03,0x00,0x00,0x00,0x00,0x00,0x00},
416{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x03,0xE0,0x00,0x01,0xC0,0xE0,0x00,0x03,0xE0,0x40,0x00,0x06,0x30,0x20,0x00,0x04,0x30,0x20,0x00,0x04,0x18,0x20,0x00,0x04,0x18,0x20,0x00,0x04,0x18,0x20,0x00,0x04,0x0C,0x20,0x00,0x02,0x0C,0x60,0x00,0x03,0x07,0xC0,0x00,0x07,0x83,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
417{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x0C,0x00,0x00,0x00,0x1F,0xFF,0x80,0x00,0xFF,0xFF,0xC0,0x00,0x04,0x00,0x60,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x40,0x00,0x00,0x01,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
418{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x07,0xFF,0x80,0x00,0x0F,0xFF,0xC0,0x00,0x00,0x00,0x60,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x04,0x00,0x40,0x00,0x04,0x00,0x80,0x00,0x07,0xFF,0xE0,0x00,0x0F,0xFF,0xC0,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x40},
419{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x07,0x80,0x00,0x00,0x07,0xF0,0x00,0x00,0x04,0xFE,0x00,0x00,0x04,0x1F,0xC0,0x00,0x00,0x03,0xE0,0x00,0x00,0x03,0x80,0x00,0x00,0x1C,0x00,0x00,0x04,0x60,0x00,0x00,0x07,0x80,0x00,0x00,0x06,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
420{0x00,0x04,0x00,0x00,0x00,0x06,0x00,0x00,0x00,0x07,0xC0,0x00,0x00,0x07,0xFC,0x00,0x00,0x04,0x3F,0x80,0x00,0x00,0x03,0xE0,0x00,0x04,0x0F,0x80,0x00,0x06,0xF0,0x00,0x00,0x07,0xF0,0x00,0x00,0x07,0xFF,0x80,0x00,0x04,0x0F,0xE0,0x00,0x00,0x03,0x80,0x00,0x04,0x3C,0x00,0x00,0x07,0xC0,0x00,0x00,0x06,0x00,0x00,0x00,0x04,0x00,0x00},
421{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x20,0x00,0x04,0x00,0x20,0x00,0x04,0x00,0x60,0x00,0x07,0x00,0xE0,0x00,0x07,0x83,0x20,0x00,0x07,0xE6,0x00,0x00,0x04,0xF8,0x00,0x00,0x00,0x3C,0x00,0x00,0x04,0x5E,0x20,0x00,0x05,0x87,0xA0,0x00,0x06,0x01,0xE0,0x00,0x04,0x00,0x60,0x00,0x04,0x00,0x20,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x00},
422{0x00,0x00,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x03,0x00,0x07,0x00,0x03,0x00,0x07,0xE0,0x01,0x00,0x04,0xF8,0x01,0x00,0x04,0x1F,0x02,0x00,0x00,0x07,0xFC,0x00,0x00,0x00,0xE0,0x00,0x00,0x07,0x00,0x00,0x04,0x38,0x00,0x00,0x07,0xC0,0x00,0x00,0x06,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x00,0x00,0x00},
423{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x07,0x80,0x60,0x00,0x06,0x00,0xE0,0x00,0x04,0x03,0xE0,0x00,0x04,0x07,0xA0,0x00,0x04,0x0E,0x20,0x00,0x04,0x3C,0x20,0x00,0x04,0x70,0x20,0x00,0x05,0xE0,0x20,0x00,0x07,0x80,0x20,0x00,0x07,0x00,0x60,0x00,0x04,0x00,0xE0,0x00,0x00,0x03,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
424{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x01,0x40,0x00,0x07,0xFE,0x3F,0xF8,0x08,0x00,0x00,0x04,0x10,0x00,0x00,0x02,0x10,0x00,0x00,0x02,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
425{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0xFF,0xFF,0xFF,0xFF,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
426{0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x10,0x00,0x00,0x02,0x10,0x00,0x00,0x02,0x08,0x00,0x00,0x04,0x07,0xFE,0x3F,0xF8,0x00,0x01,0x40,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x80,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
427{0x00,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x30,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x40,0x00,0x00,0x00,0x20,0x00,0x00,0x00,0x30,0x00,0x00,0x00,0x08,0x00,0x00,0x00,0x04,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x02,0x00,0x00,0x00,0x0C,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0x00,0x00,0x00,0x00},
428};
429
438#endif
asc2_2412
const unsigned char asc2_2412[95][36]
Definition: at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/font.h:234
asc2_3216
const unsigned char asc2_3216[95][128]
Definition: at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/font.h:332
asc2_1206
const unsigned char asc2_1206[95][12]
Definition: at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/font.h:38
asc2_1608
const unsigned char asc2_1608[95][16]
Definition: at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/font.h:136


AT32F435/437 Firmwary Library: xmc_lcd.c File Reference

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • lcd
Functions | Variables
at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c File Reference

xmc_lcd program file More...

#include "xmc_lcd.h"
#include "font.h"

Go to the source code of this file.

Functions

void | xmc_init (void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_init (void)
configures the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_wr_command (uint16_t command)
this function is write command to lcd. More...
void | lcd_wr_data (uint16_t data)
this function is write data to lcd. More...
uint16_t | lcd_rd_data (void)
void | lcd_setblock (uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd. More...
void | lcd_writeonepoint (uint16_t color)
this function is write one point to lcd. More...
void | lcd_drawpoint (uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd. More...
void | lcd_clear (uint16_t color)
this function is clear the lcd. More...
void | lcd_char_show (uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode)
this function is show char to lcd More...
void | lcd_string_show (uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p)
this function is show string to lcd More...
void | lcd_fill (uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color)
this function is fill in lcd with concolorous More...
void | lcd_color_fill (uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color)
this function is fill in lcd with color-pointer More...

Variables

lcd_dev_type lcd_dev_struct
lcd_dev_type * lcd_struct

Detailed Description

xmc_lcd program file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c.


AT32F435/437 Firmwary Library: xmc_lcd.c Source File

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • lcd
at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c
Go to the documentation of this file.
1
27#include "xmc_lcd.h"
28#include "font.h"
29
38 lcd_dev_type lcd_dev_struct =
39{
40 0,
41 xmc_init,
42 lcd_init,
43 lcd_setblock,
44 lcd_drawpoint,
45 lcd_clear,
46};
47
48 lcd_dev_type *lcd_struct;
49
57void xmc_init(void)
58{
59 gpio_init_type gpio_init_struct = {0};
60 xmc_norsram_init_type xmc_norsram_init_struct;
61 xmc_norsram_timing_init_type rw_timing_struct, w_timing_struct;
62
63 /* enable the gpio clock */
64 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
65 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
67 /* enable the xmc clock */
68 crm_periph_clock_enable(CRM_XMC_PERIPH_CLOCK, TRUE);
69
70 /*-- gpio configuration ------------------------------------------------------*/
71 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE2, GPIO_MUX_14);
72 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE4, GPIO_MUX_14);
73 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE5, GPIO_MUX_14);
74 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE11, GPIO_MUX_14);
75 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE12, GPIO_MUX_14);
76 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE5, GPIO_MUX_10);
77 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE8, GPIO_MUX_12);
78 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE9, GPIO_MUX_12);
79 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE10, GPIO_MUX_12);
80 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE14, GPIO_MUX_12);
81 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE15, GPIO_MUX_12);
82
83 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE7, GPIO_MUX_12);
84 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE8, GPIO_MUX_12);
85 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE9, GPIO_MUX_12);
86 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE10, GPIO_MUX_12);
87 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE11, GPIO_MUX_12);
88 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE12, GPIO_MUX_12);
89 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE13, GPIO_MUX_12);
90 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE14, GPIO_MUX_12);
91 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE15, GPIO_MUX_12);
92
93 /* lcd data lines configuration */
94 gpio_init_struct.gpio_pins = GPIO_PINS_2 | GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_11| GPIO_PINS_12;
95 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
96 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
97 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
98 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
99 gpio_init(GPIOC, &gpio_init_struct);
100
101
102 gpio_init_struct.gpio_pins = GPIO_PINS_5 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_14 | GPIO_PINS_15;
103 gpio_init(GPIOD, &gpio_init_struct);
104
105 gpio_init_struct.gpio_pins = GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11 | GPIO_PINS_12 | GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
106 gpio_init(GPIOE, &gpio_init_struct);
107
108 /*-- xmc configuration ------------------------------------------------------*/
109 xmc_norsram_default_para_init(&xmc_norsram_init_struct);
110 xmc_norsram_init_struct.subbank = XMC_BANK1_NOR_SRAM4;
111 xmc_norsram_init_struct.data_addr_multiplex = XMC_DATA_ADDR_MUX_DISABLE;
112 xmc_norsram_init_struct.device = XMC_DEVICE_SRAM;
113 xmc_norsram_init_struct.bus_type = XMC_BUSTYPE_16_BITS;
114 xmc_norsram_init_struct.burst_mode_enable = XMC_BURST_MODE_DISABLE;
115 xmc_norsram_init_struct.asynwait_enable = XMC_ASYN_WAIT_DISABLE;
116 xmc_norsram_init_struct.wait_signal_lv = XMC_WAIT_SIGNAL_LEVEL_LOW;
117 xmc_norsram_init_struct.wrapped_mode_enable = XMC_WRAPPED_MODE_DISABLE;
118 xmc_norsram_init_struct.wait_signal_config = XMC_WAIT_SIGNAL_SYN_BEFORE;
119 xmc_norsram_init_struct.write_enable = XMC_WRITE_OPERATION_ENABLE;
120 xmc_norsram_init_struct.wait_signal_enable = XMC_WAIT_SIGNAL_DISABLE;
121 xmc_norsram_init_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
122 xmc_norsram_init_struct.write_burst_syn = XMC_WRITE_BURST_SYN_DISABLE;
123 xmc_nor_sram_init(&xmc_norsram_init_struct);
124
125 /* timing configuration */
126 xmc_norsram_timing_default_para_init(&rw_timing_struct, &w_timing_struct);
127 rw_timing_struct.subbank = XMC_BANK1_NOR_SRAM4;
128 rw_timing_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
129 rw_timing_struct.addr_setup_time = 0x2;
130 rw_timing_struct.addr_hold_time = 0x0;
131 rw_timing_struct.data_setup_time = 0x2;
132 rw_timing_struct.bus_latency_time = 0x0;
133 rw_timing_struct.clk_psc = 0x0;
134 rw_timing_struct.data_latency_time = 0x0;
135 rw_timing_struct.mode = XMC_ACCESS_MODE_A;
136 w_timing_struct.subbank = XMC_BANK1_NOR_SRAM4;
137 w_timing_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
138 w_timing_struct.addr_setup_time = 0x2;
139 w_timing_struct.addr_hold_time = 0x0;
140 w_timing_struct.data_setup_time = 0x2;
141 w_timing_struct.bus_latency_time = 0x0;
142 w_timing_struct.clk_psc = 0x0;
143 w_timing_struct.data_latency_time = 0x0;
144 w_timing_struct.mode = XMC_ACCESS_MODE_A;
145 xmc_nor_sram_timing_config(&rw_timing_struct, &w_timing_struct);
146
147 /* enable xmc_bank1_nor_sram4 */
148 xmc_nor_sram_enable(XMC_BANK1_NOR_SRAM4, TRUE);
149
150 gpio_init_struct.gpio_pins = GPIO_PINS_0;
151 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
152 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
153 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
154 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
155 gpio_init(GPIOC, &gpio_init_struct);
156}
157
165void lcd_init(void)
166{
167 /* init xmc */
168 lcd_struct->xmc_init();
169
170 delay_ms(50);
171
172 /* read id */
173 lcd_wr_command(0x0000);
174 delay_ms(5);
175
176 lcd_struct->lcd_id = lcd_rd_data();
177 lcd_wr_command(0xd3);
178
179 lcd_struct->lcd_id = lcd_rd_data();
180 lcd_struct->lcd_id = lcd_rd_data();
181 lcd_struct->lcd_id = lcd_rd_data();
182 lcd_struct->lcd_id = lcd_rd_data();
183 lcd_struct->lcd_id = lcd_struct->lcd_id << 8;
184 lcd_struct->lcd_id |= lcd_rd_data();
185
186 lcd_wr_command(0xcf);
187 lcd_wr_data(0x00);
188 lcd_wr_data(0xc1);
189 lcd_wr_data(0x30);
190 lcd_wr_command(0xed);
191 lcd_wr_data(0x64);
192 lcd_wr_data(0x03);
193 lcd_wr_data(0x12);
194 lcd_wr_data(0x81);
195 lcd_wr_command(0xe8);
196 lcd_wr_data(0x85);
197 lcd_wr_data(0x10);
198 lcd_wr_data(0x7a);
199 lcd_wr_command(0xcb);
200 lcd_wr_data(0x39);
201 lcd_wr_data(0x2c);
202 lcd_wr_data(0x00);
203 lcd_wr_data(0x34);
204 lcd_wr_data(0x02);
205 lcd_wr_command(0xf7);
206 lcd_wr_data(0x20);
207 lcd_wr_command(0xea);
208 lcd_wr_data(0x00);
209 lcd_wr_data(0x00);
210 lcd_wr_command(0xc0);
211 lcd_wr_data(0x1b);
212 lcd_wr_command(0xc1);
213 lcd_wr_data(0x01);
214 lcd_wr_command(0xc5);
215 lcd_wr_data(0x30);
216 lcd_wr_data(0x30);
217 lcd_wr_command(0xc7);
218 lcd_wr_data(0xb7);
219 lcd_wr_command(0x36);
220 lcd_wr_data(0x48);
221 lcd_wr_command(0x3a);
222 lcd_wr_data(0x55);
223 lcd_wr_command(0xb1);
224 lcd_wr_data(0x00);
225 lcd_wr_data(0x1a);
226 lcd_wr_command(0xb6);
227 lcd_wr_data(0x0a);
228 lcd_wr_data(0xa2);
229 lcd_wr_command(0xf2);
230 lcd_wr_data(0x00);
231 lcd_wr_command(0x26);
232 lcd_wr_data(0x01);
233 lcd_wr_command(0xe0);
234 lcd_wr_data(0x0f);
235 lcd_wr_data(0x2a);
236 lcd_wr_data(0x28);
237 lcd_wr_data(0x08);
238 lcd_wr_data(0x0e);
239 lcd_wr_data(0x08);
240 lcd_wr_data(0x54);
241 lcd_wr_data(0xa9);
242 lcd_wr_data(0x43);
243 lcd_wr_data(0x0a);
244 lcd_wr_data(0x0f);
245 lcd_wr_data(0x00);
246 lcd_wr_data(0x00);
247 lcd_wr_data(0x00);
248 lcd_wr_data(0x00);
249 lcd_wr_command(0xe1);
250 lcd_wr_data(0x00);
251 lcd_wr_data(0x15);
252 lcd_wr_data(0x17);
253 lcd_wr_data(0x07);
254 lcd_wr_data(0x11);
255 lcd_wr_data(0x06);
256 lcd_wr_data(0x2b);
257 lcd_wr_data(0x56);
258 lcd_wr_data(0x3c);
259 lcd_wr_data(0x05);
260 lcd_wr_data(0x10);
261 lcd_wr_data(0x0f);
262 lcd_wr_data(0x3f);
263 lcd_wr_data(0x3f);
264 lcd_wr_data(0x0f);
265 lcd_wr_command(0x2b);
266 lcd_wr_data(0x00);
267 lcd_wr_data(0x00);
268 lcd_wr_data(0x01);
269 lcd_wr_data(0x3f);
270 lcd_wr_command(0x2a);
271 lcd_wr_data(0x00);
272 lcd_wr_data(0x00);
273 lcd_wr_data(0x00);
274 lcd_wr_data(0xef);
275 lcd_wr_command(0x11);
276 delay_ms(120);
277 lcd_wr_command(0x29);
278 lcd_wr_command(0x36);
279 lcd_wr_data(0x08);
280 lcd_wr_command(0x2a);
281 lcd_wr_data(0x00);
282 lcd_wr_data(0x00);
283 lcd_wr_data(0xef >> 8);
284 lcd_wr_data(0xef & 0xff);
285 lcd_wr_command(0x2b);
286 lcd_wr_data(0x00);
287 lcd_wr_data(0x00);
288 lcd_wr_data(0x13f >> 8);
289 lcd_wr_data(0x13f & 0xff);
290 lcd_wr_command(0x36); //setting the display direction
291 lcd_wr_data(0x68); //90 degree
292 LCD_BL_HIGH;
293}
294
300void lcd_wr_command(uint16_t command)
301{
302 *(uint16_t*) XMC_LCD_COMMAND = command;
303}
304
310void lcd_wr_data(uint16_t data)
311{
312 *(uint16_t*) XMC_LCD_DATA = data;
313}
314
315uint16_t lcd_rd_data(void)
316{
317 uint16_t data;
318
319 data = *(uint16_t*)XMC_LCD_DATA;
320
321 return data;
322}
323
332void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
333{
334 /* set row coordinates */
335 lcd_wr_command(0x2a);
336 lcd_wr_data(xstart >> 8);
337 lcd_wr_data(xstart);
338 lcd_wr_data(xend >> 8);
339 lcd_wr_data(xend);
340
341 /* set column coordinates */
342 lcd_wr_command(0x2b);
343 lcd_wr_data(ystart >> 8);
344 lcd_wr_data(ystart);
345 lcd_wr_data(yend >> 8);
346 lcd_wr_data(yend);
347
348 /* enable write menory */
349 lcd_wr_command(0x2c);
350}
351
357void lcd_writeonepoint(uint16_t color)
358{
359 lcd_wr_data(color);
360}
361
367void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
368{
369 lcd_struct->lcd_setblock(x, y ,x ,y);
370
371 lcd_writeonepoint(color);
372}
373
379void lcd_clear(uint16_t color)
380{
381 uint32_t i;
382
383 lcd_struct->lcd_setblock(0, 0, LCD_W, LCD_H);
384
385 for(i = 0; i < 76800; i++)
386 {
387 lcd_writeonepoint(color);
388 }
389}
390
400void lcd_char_show(uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode)
401{
402 uint8_t temp, t1, t;
403 uint16_t y0 = y;
404 uint8_t csize = (size / 8 + ((size % 8) ? 1 : 0)) * (size / 2);
405 num = num - ' ';
406
407 for(t = 0; t < csize; t++)
408 {
409 if(size == 12)
410 {
411 temp = asc2_1206[num][t];
412 }
413 else if(size == 16)
414 {
415 temp = asc2_1608[num][t];
416 }
417 else if(size == 24)
418 {
419 temp = asc2_2412[num][t];
420 }
421 else if(size == 32)
422 {
423 temp = asc2_3216[num][t];
424 }
425 else
426 {
427 return;
428 }
429
430 for(t1 = 0; t1 < 8; t1++)
431 {
432 if(temp & 0x80)
433 {
434 lcd_drawpoint(x, y, RED);
435 }
436 else if(mode == 0)
437 {
438 lcd_drawpoint(x, y, WHITE);
439 }
440
441 temp <<= 1;
442 y++;
443
444 if(y >= LCD_H)
445 {
446 return;
447 }
448
449 if((y - y0) == size)
450 {
451 y = y0;
452 x++;
453
454 if(x >= LCD_W)
455 {
456 return;
457 }
458
459 break;
460 }
461 }
462 }
463}
464
474void lcd_string_show(uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p)
475{
476 uint8_t x0 = x;
477 width += x;
478 height += y;
479
480 while((*p <= '~') && (*p >= ' '))
481 {
482 if(x >= width)
483 {
484 x = x0;
485 y += size;
486 }
487
488 if(y >= height)
489 {
490 break;
491 }
492
493 lcd_char_show(x, y, *p, size, 0);
494 x += size / 2;
495 p++;
496 }
497}
498
508void lcd_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color)
509{
510 uint32_t i, num;
511 num = (ex - sx) * (ey - sy);
512 lcd_struct->lcd_setblock(sx, sy, ex, ey);
513
514 for(i = 0; i < num; i++)
515 {
516 lcd_writeonepoint(color);
517 }
518}
519
529void lcd_color_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color)
530{
531 uint16_t height, width;
532 uint16_t i, j;
533
534 width = ex - sx + 1;
535 height = ey - sy + 1;
536 lcd_struct->lcd_setblock(sx, sy, ex, ey);
537
538 for(i = 0; i < height; i++)
539 {
540 for(j = 0; j < width; j++)
541 {
542 lcd_writeonepoint(color[i * width + j]);
543 }
544 }
545}
font.h
xmc_lcd.h
xmc_lcd program header
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
lcd_color_fill
void lcd_color_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color)
this function is fill in lcd with color-pointer
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:529
lcd_setblock
void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:332
LCD_H
#define LCD_H
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:79
lcd_char_show
void lcd_char_show(uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode)
this function is show char to lcd
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:400
lcd_init
void lcd_init(void)
configures the lcd. this function must be called before any write/read operation on the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:165
lcd_string_show
void lcd_string_show(uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p)
this function is show string to lcd
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:474
lcd_fill
void lcd_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color)
this function is fill in lcd with concolorous
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:508
lcd_drawpoint
void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:367
WHITE
#define WHITE
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:84
lcd_wr_command
void lcd_wr_command(uint16_t command)
this function is write command to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:300
RED
#define RED
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:90
lcd_rd_data
uint16_t lcd_rd_data(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:315
LCD_W
#define LCD_W
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:78
asc2_2412
const unsigned char asc2_2412[95][36]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h:234
asc2_3216
const unsigned char asc2_3216[95][128]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h:332
asc2_1206
const unsigned char asc2_1206[95][12]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h:38
lcd_clear
void lcd_clear(uint16_t color)
this function is clear the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:379
asc2_1608
const unsigned char asc2_1608[95][16]
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h:136
lcd_writeonepoint
void lcd_writeonepoint(uint16_t color)
this function is write one point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:357
lcd_wr_data
void lcd_wr_data(uint16_t data)
this function is write data to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:310
LCD_BL_HIGH
#define LCD_BL_HIGH
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:81
xmc_init
void xmc_init(void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write...
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:57
lcd_dev_struct
lcd_dev_type lcd_dev_struct
Definition: at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c:38
lcd_struct
lcd_dev_type * lcd_struct
Definition: at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c:48
j
uint32_t j
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:44
XMC_LCD_COMMAND
#define XMC_LCD_COMMAND
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:65
XMC_LCD_DATA
#define XMC_LCD_DATA
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:66
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_XMC_PERIPH_CLOCK
@ CRM_XMC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:123
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f435_437_gpio.h:146
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_10
@ GPIO_MUX_10
Definition: at32f435_437_gpio.h:166
GPIO_MUX_14
@ GPIO_MUX_14
Definition: at32f435_437_gpio.h:170
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f435_437_gpio.h:64
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
xmc_nor_sram_init
void xmc_nor_sram_init(xmc_norsram_init_type *xmc_norsram_init_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_norsraminitstruct.
Definition: at32f435_437_xmc.c:78
xmc_norsram_timing_default_para_init
void xmc_norsram_timing_default_para_init(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
fill each xmc_rw_timing_struct and xmc_w_timing_struct member with its default value.
Definition: at32f435_437_xmc.c:176
xmc_nor_sram_timing_config
void xmc_nor_sram_timing_config(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_rw_timing_struct a...
Definition: at32f435_437_xmc.c:113
xmc_norsram_default_para_init
void xmc_norsram_default_para_init(xmc_norsram_init_type *xmc_nor_sram_init_struct)
fill each xmc_nor_sram_init_struct member with its default value.
Definition: at32f435_437_xmc.c:150
xmc_nor_sram_enable
void xmc_nor_sram_enable(xmc_nor_sram_subbank_type xmc_subbank, confirm_state new_state)
enable or disable the specified nor/sram memory bank.
Definition: at32f435_437_xmc.c:210
XMC_WAIT_SIGNAL_DISABLE
@ XMC_WAIT_SIGNAL_DISABLE
Definition: at32f435_437_xmc.h:101
XMC_WAIT_SIGNAL_SYN_BEFORE
@ XMC_WAIT_SIGNAL_SYN_BEFORE
Definition: at32f435_437_xmc.h:196
XMC_WRITE_OPERATION_ENABLE
@ XMC_WRITE_OPERATION_ENABLE
Definition: at32f435_437_xmc.h:93
XMC_WRITE_BURST_SYN_DISABLE
@ XMC_WRITE_BURST_SYN_DISABLE
Definition: at32f435_437_xmc.h:110
XMC_BURST_MODE_DISABLE
@ XMC_BURST_MODE_DISABLE
Definition: at32f435_437_xmc.h:65
XMC_DATA_ADDR_MUX_DISABLE
@ XMC_DATA_ADDR_MUX_DISABLE
Definition: at32f435_437_xmc.h:56
XMC_BUSTYPE_16_BITS
@ XMC_BUSTYPE_16_BITS
Definition: at32f435_437_xmc.h:179
XMC_WRITE_TIMING_ENABLE
@ XMC_WRITE_TIMING_ENABLE
Definition: at32f435_437_xmc.h:120
XMC_BANK1_NOR_SRAM4
@ XMC_BANK1_NOR_SRAM4
Definition: at32f435_437_xmc.h:149
XMC_ASYN_WAIT_DISABLE
@ XMC_ASYN_WAIT_DISABLE
Definition: at32f435_437_xmc.h:74
XMC_WRAPPED_MODE_DISABLE
@ XMC_WRAPPED_MODE_DISABLE
Definition: at32f435_437_xmc.h:83
XMC_ACCESS_MODE_A
@ XMC_ACCESS_MODE_A
Definition: at32f435_437_xmc.h:205
XMC_WAIT_SIGNAL_LEVEL_LOW
@ XMC_WAIT_SIGNAL_LEVEL_LOW
Definition: at32f435_437_xmc.h:187
XMC_DEVICE_SRAM
@ XMC_DEVICE_SRAM
Definition: at32f435_437_xmc.h:168
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
lcd_dev_type
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:44
lcd_dev_type::lcd_setblock
void(* lcd_setblock)(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:48
lcd_dev_type::lcd_id
uint16_t lcd_id
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:45
lcd_dev_type::xmc_init
void(* xmc_init)(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:46
xmc_norsram_init_type
xmc nor/sram init structure definition
Definition: at32f435_437_xmc.h:409
xmc_norsram_init_type::wait_signal_enable
xmc_wait_signal_type wait_signal_enable
Definition: at32f435_437_xmc.h:420
xmc_norsram_init_type::data_addr_multiplex
xmc_data_addr_mux_type data_addr_multiplex
Definition: at32f435_437_xmc.h:411
xmc_norsram_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:421
xmc_norsram_init_type::burst_mode_enable
xmc_burst_access_mode_type burst_mode_enable
Definition: at32f435_437_xmc.h:414
xmc_norsram_init_type::bus_type
xmc_data_width_type bus_type
Definition: at32f435_437_xmc.h:413
xmc_norsram_init_type::device
xmc_memory_type device
Definition: at32f435_437_xmc.h:412
xmc_norsram_init_type::wait_signal_lv
xmc_wait_signal_polarity_type wait_signal_lv
Definition: at32f435_437_xmc.h:416
xmc_norsram_init_type::wrapped_mode_enable
xmc_wrap_mode_type wrapped_mode_enable
Definition: at32f435_437_xmc.h:417
xmc_norsram_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:410
xmc_norsram_init_type::write_burst_syn
xmc_write_burst_type write_burst_syn
Definition: at32f435_437_xmc.h:422
xmc_norsram_init_type::asynwait_enable
xmc_asyn_wait_type asynwait_enable
Definition: at32f435_437_xmc.h:415
xmc_norsram_init_type::wait_signal_config
xmc_wait_timing_type wait_signal_config
Definition: at32f435_437_xmc.h:418
xmc_norsram_init_type::write_enable
xmc_write_operation_type write_enable
Definition: at32f435_437_xmc.h:419
xmc_norsram_timing_init_type
nor/sram banks timing parameters
Definition: at32f435_437_xmc.h:393
xmc_norsram_timing_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:395
xmc_norsram_timing_init_type::data_latency_time
uint32_t data_latency_time
Definition: at32f435_437_xmc.h:401
xmc_norsram_timing_init_type::addr_hold_time
uint32_t addr_hold_time
Definition: at32f435_437_xmc.h:397
xmc_norsram_timing_init_type::bus_latency_time
uint32_t bus_latency_time
Definition: at32f435_437_xmc.h:399
xmc_norsram_timing_init_type::addr_setup_time
uint32_t addr_setup_time
Definition: at32f435_437_xmc.h:396
xmc_norsram_timing_init_type::mode
xmc_access_mode_type mode
Definition: at32f435_437_xmc.h:402
xmc_norsram_timing_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:394
xmc_norsram_timing_init_type::clk_psc
uint32_t clk_psc
Definition: at32f435_437_xmc.h:400
xmc_norsram_timing_init_type::data_setup_time
uint32_t data_setup_time
Definition: at32f435_437_xmc.h:398


AT32F435/437 Firmwary Library: xmc_lcd.h File Reference

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • lcd
Data Structures | Macros | Functions | Variables
at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h File Reference

xmc_lcd program header More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Data Structures

struct lcd_dev_type

Macros

#define | XMC_LCD_COMMAND (0x6C000000)
#define | XMC_LCD_DATA (0x6C000800)
#define | LCD_W 320
#define | LCD_H 240
#define | LCD_BL_HIGH gpio_bits_set(GPIOC,GPIO_PINS_0)
#define | LCD_BL_LOW gpio_bits_reset(GPIOC,GPIO_PINS_0)
#define | WHITE 0xFFFF
#define | BLACK 0x0000
#define | BLUE 0x001F
#define | BRED 0xF81F
#define | GRED 0xFFE0
#define | GBLUE 0x07FF
#define | RED 0xF800
#define | MAGENTA 0xF81F
#define | GREEN 0x07E0
#define | CYAN 0x7FFF
#define | YELLOW 0xFFE0
#define | BROWN 0xBC40
#define | BRRED 0xFC07
#define | GRAY 0x8430

Functions

void | xmc_init (void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_init (void)
configures the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_wr_command (uint16_t command)
this function is write command to lcd. More...
void | lcd_wr_data (uint16_t data)
this function is write data to lcd. More...
uint16_t | lcd_rd_data (void)
void | lcd_setblock (uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd. More...
void | lcd_writeonepoint (uint16_t color)
this function is write one point to lcd. More...
void | lcd_drawpoint (uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd. More...
void | lcd_clear (uint16_t color)
this function is clear the lcd. More...
void | lcd_char_show (uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode)
this function is show char to lcd More...
void | lcd_string_show (uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p)
this function is show string to lcd More...
void | lcd_fill (uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color)
this function is fill in lcd with concolorous More...
void | lcd_color_fill (uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color)
this function is fill in lcd with color-pointer More...

Variables

lcd_dev_type lcd_dev_struct
lcd_dev_type * lcd_struct
static uint16_t LCD_ID

Detailed Description

xmc_lcd program header

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h.


AT32F435/437 Firmwary Library: xmc_lcd.h Source File

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • lcd
at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h
Go to the documentation of this file.
1
26#ifndef __XMC_LCD_H
27#define __XMC_LCD_H
28
29#include "at32f435_437_board.h"
30
43typedef struct
44{
45 uint16_t lcd_id;
46 void (*xmc_init)(void);
47 void (*lcd_init)(void);
48 void (*lcd_setblock)(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend);
49 void (*draw_point)(uint16_t x, uint16_t y, uint16_t color);
50 void (*lcd_clear)(uint16_t color);
51} lcd_dev_type;
52
57extern lcd_dev_type lcd_dev_struct;
58extern lcd_dev_type *lcd_struct;
59
64/* the address of write data & command (xmc_a0) */
65#define XMC_LCD_COMMAND (0x6C000000)
66#define XMC_LCD_DATA (0x6C000800)
78#define LCD_W 320
79#define LCD_H 240
80
81#define LCD_BL_HIGH gpio_bits_set(GPIOC,GPIO_PINS_0)
82#define LCD_BL_LOW gpio_bits_reset(GPIOC,GPIO_PINS_0)
83static uint16_t LCD_ID;
84#define WHITE 0xFFFF
85#define BLACK 0x0000
86#define BLUE 0x001F
87#define BRED 0xF81F
88#define GRED 0xFFE0
89#define GBLUE 0x07FF
90#define RED 0xF800
91#define MAGENTA 0xF81F
92#define GREEN 0x07E0
93#define CYAN 0x7FFF
94#define YELLOW 0xFFE0
95#define BROWN 0xBC40
96#define BRRED 0xFC07
97#define GRAY 0x8430
98
103void xmc_init(void);
104void lcd_init(void);
105void lcd_wr_command(uint16_t command);
106void lcd_wr_data(uint16_t data);
107uint16_t lcd_rd_data(void);
108void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend);
109void lcd_writeonepoint(uint16_t color);
110void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color);
111void lcd_clear(uint16_t color);
112void lcd_char_show(uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode);
113void lcd_string_show(uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p);
114void lcd_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color);
115void lcd_color_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color);
116
129#endif
130
131
at32f435_437_board.h
lcd_color_fill
void lcd_color_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t *color)
this function is fill in lcd with color-pointer
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:529
lcd_setblock
void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:332
lcd_char_show
void lcd_char_show(uint16_t x, uint16_t y, uint8_t num, uint8_t size, uint8_t mode)
this function is show char to lcd
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:400
lcd_init
void lcd_init(void)
configures the lcd. this function must be called before any write/read operation on the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:165
lcd_string_show
void lcd_string_show(uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p)
this function is show string to lcd
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:474
lcd_fill
void lcd_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color)
this function is fill in lcd with concolorous
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:508
lcd_drawpoint
void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:367
lcd_wr_command
void lcd_wr_command(uint16_t command)
this function is write command to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:300
lcd_rd_data
uint16_t lcd_rd_data(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:315
lcd_clear
void lcd_clear(uint16_t color)
this function is clear the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:379
lcd_writeonepoint
void lcd_writeonepoint(uint16_t color)
this function is write one point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:357
lcd_wr_data
void lcd_wr_data(uint16_t data)
this function is write data to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:310
xmc_init
void xmc_init(void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write...
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:57
lcd_dev_struct
lcd_dev_type lcd_dev_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:38
LCD_ID
static uint16_t LCD_ID
Definition: at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h:83
lcd_struct
lcd_dev_type * lcd_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:48
lcd_dev_type
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:44


AT32F435/437 Firmwary Library: ov5640.c File Reference

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • ov5640
Macros | Functions | Variables
at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c File Reference

ov5640 program More...

#include "at32f435_437.h"
#include "at32f435_437_board.h"
#include "ov5640.h"
#include "ov5640cfg.h"
#include "ov5640af.h"
#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0x2FFFFFF
#define | I2Cx_CLKCTRL 0x30F05292
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_DMA DMA1
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_AF GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_AF GPIO_MUX_4

Functions

error_status | ov5640_reg_write (uint16_t reg, uint8_t data)
write register to ov5640 More...
error_status | ov5640_reg_read (uint16_t reg, uint8_t *data)
read register from ov5640 More...
error_status | ov5640_init (void)
initialize ov5640 More...
void | ov5640_jpeg_mode (void)
ov5640 jpeg mode configure More...
void | ov5640_rgb565_mode (void)
ov5640 rgb565 mode configure More...
void | ov5640_exposure (uint8_t exposure)
ov5640 exposure configure More...
void | ov5640_light_mode (uint8_t mode)
this function is draw point to lcd More...
void | ov5640_color_saturation (uint8_t sat)
ov5640 color saturation configure More...
void | ov5640_brightness (uint8_t bright)
ov5640 brightness configure More...
void | ov5640_contrast (uint8_t contrast)
ov5640 contrast configure More...
void | ov5640_sharpness (uint8_t sharp)
ov5640 sharpness configure More...
void | ov5640_special_effects (uint8_t eft)
ov5640 special effects configure More...
void | ov5640_flash_ctrl (uint8_t sw)
ov5640 flash control More...
void | ov5640_outsize_set (uint16_t offx, uint16_t offy, uint16_t width, uint16_t height)
ov5640 output size set More...
void | ov5640_imagewin_set (uint16_t offx, uint16_t offy, uint16_t width, uint16_t height)
ov5640 image window set More...
error_status | ov5640_focus_init (void)
initialize ov5640 focus function More...
error_status | ov5640_focus_single (void)
ov5640 focus single More...
error_status | ov5640_focus_constant (void)
ov5640 focus constant More...
void | ov5640_i2c_init (void)
ov5640 i2c initialize More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...

Variables

i2c_handle_type hi2cx
i2c_status_type STA
const uint8_t | OV5640_EXPOSURE_TBL [7][6]
const uint8_t | OV5640_LIGHTMODE_TBL [5][7]
const uint8_t | OV5640_SATURATION_TBL [7][6]
const uint8_t | OV5640_EFFECTS_TBL [7][3]

Detailed Description

ov5640 program

header file of ov5640 program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c.


AT32F435/437 Firmwary Library: ov5640.c Source File

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • ov5640
at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c
Go to the documentation of this file.
1
27#include "at32f435_437.h"
28#include "at32f435_437_board.h"
29#include "ov5640.h"
30#include "ov5640cfg.h"
31#include "ov5640af.h"
32#include "i2c_application.h"
33
42#define I2C_TIMEOUT 0x2FFFFFF
43
44#define I2Cx_CLKCTRL 0x30F05292
45#define I2Cx_ADDRESS 0xA0
46
47#define I2Cx_PORT I2C1
48#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
49#define I2Cx_DMA DMA1
50#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
51
52#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
53#define I2Cx_SCL_GPIO_PIN GPIO_PINS_6
54#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
55#define I2Cx_SCL_GPIO_PORT GPIOB
56#define I2Cx_SCL_GPIO_AF GPIO_MUX_4
57
58#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
59#define I2Cx_SDA_GPIO_PIN GPIO_PINS_7
60#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
61#define I2Cx_SDA_GPIO_PORT GPIOB
62#define I2Cx_SDA_GPIO_AF GPIO_MUX_4
63
64 i2c_handle_type hi2cx;
65 i2c_status_type STA;
66
67const uint8_t OV5640_EXPOSURE_TBL[7][6] =
68{
69 0x10, 0x08, 0x10, 0x08, 0x20, 0x10, /* -3 */
70 0x20, 0x18, 0x41, 0x20, 0x18, 0x10, /* -2 */
71 0x30, 0x28, 0x61, 0x30, 0x28, 0x10, /* -1 */
72 0x38, 0x30, 0x61, 0x38, 0x30, 0x10, /* 0 */
73 0x40, 0x38, 0x71, 0x40, 0x38, 0x10, /* +1 */
74 0x50, 0x48, 0x90, 0x50, 0x48, 0x20, /* +2 */
75 0x60, 0x58, 0xa0, 0x60, 0x58, 0x20, /* +3 */
76};
77
78const uint8_t OV5640_LIGHTMODE_TBL[5][7] =
79{
80 0x04, 0x00, 0x04, 0x00, 0x04, 0x00, 0x00, /* auto */
81 0x06, 0x1C, 0x04, 0x00, 0x04, 0xF3, 0x01, /* sunny */
82 0x05, 0x48, 0x04, 0x00, 0x07, 0xCF, 0x01, /* office */
83 0x06, 0x48, 0x04, 0x00, 0x04, 0xD3, 0x01, /* cloudy */
84 0x04, 0x10, 0x04, 0x00, 0x08, 0x40, 0x01, /* home */
85};
86
87const uint8_t OV5640_SATURATION_TBL[7][6] =
88{
89 0x0C, 0x30, 0x3D, 0x3E, 0x3D, 0x01, /* -3 */
90 0x10, 0x3D, 0x4D, 0x4E, 0x4D, 0x01, /* -2 */
91 0x15, 0x52, 0x66, 0x68, 0x66, 0x02, /* -1 */
92 0x1A, 0x66, 0x80, 0x82, 0x80, 0x02, /* +0 */
93 0x1F, 0x7A, 0x9A, 0x9C, 0x9A, 0x02, /* +1 */
94 0x24, 0x8F, 0xB3, 0xB6, 0xB3, 0x03, /* +2 */
95 0x2B, 0xAB, 0xD6, 0xDA, 0xD6, 0x04, /* +3 */
96};
97
98const uint8_t OV5640_EFFECTS_TBL[7][3] =
99{
100 0x06, 0x40, 0x10,
101 0x1E, 0xA0, 0x40,
102 0x1E, 0x80, 0xC0,
103 0x1E, 0x80, 0x80,
104 0x1E, 0x40, 0xA0,
105 0x40, 0x40, 0x10,
106 0x1E, 0x60, 0x60,
107};
108
115 error_status ov5640_reg_write(uint16_t reg, uint8_t data)
116{
117 uint8_t temp_data[3];
118 temp_data[0] = reg >> 8;
119 temp_data[1] = reg;
120 temp_data[2] = data;
121
122 if((STA = i2c_master_transmit(&hi2cx, (uint16_t)OV5640_ADDR, (uint8_t*)temp_data, 3, 1000000)) != I2C_OK)
123 {
124 return ERROR;
125 }
126
127 return SUCCESS;
128}
129
136 error_status ov5640_reg_read(uint16_t reg, uint8_t *data)
137{
138 uint8_t temp_data[2];
139 temp_data[0] = reg >> 8;
140 temp_data[1] = reg;
141
142 if(i2c_master_transmit(&hi2cx, (uint16_t)OV5640_ADDR, (uint8_t*)temp_data, 2, 10000) != I2C_OK)
143 {
144 return ERROR;
145 }
146
147 if(i2c_master_receive(&hi2cx, (uint16_t)OV5640_ADDR, data, 1, 10000) != I2C_OK)
148 {
149 return ERROR;
150 }
151
152 return SUCCESS;
153}
154
160 error_status ov5640_init(void)
161{
162 uint16_t i = 0;
163 uint8_t temp = 0;
164 uint16_t reg;
165 gpio_init_type gpio_initure;
166
167 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
168 gpio_default_para_init(&gpio_initure);
169 /* DVP_RST Pin-PD6 */
170 gpio_initure.gpio_pins = GPIO_PINS_3;
171 gpio_initure.gpio_mode = GPIO_MODE_OUTPUT;
172 gpio_initure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
173 gpio_initure.gpio_pull = GPIO_PULL_UP;
174 gpio_initure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
175 gpio_init(GPIOC, &gpio_initure);
176
177 OV5640_RST_LOW;
178 delay_ms(100);
179 OV5640_RST_HIGH;
180 delay_ms(20);
181 ov5640_i2c_init();
182 delay_ms(5);
183 ov5640_reg_read(OV5640_CHIPIDH, &temp);
184 reg = (uint16_t)temp << 8;
185 ov5640_reg_read(OV5640_CHIPIDL, &temp);
186 reg |= temp;
187
188 if(reg != OV5640_ID)
189 {
190 return ERROR;
191 }
192
193 ov5640_reg_write(0x3103, 0x11);
194 ov5640_reg_write(0x3008, 0x82);
195 delay_ms(10);
196
197 for(i = 0; i < sizeof(ov5640_uxga_init_reg_tbl) / 4; i++)
198 {
199 ov5640_reg_write(ov5640_uxga_init_reg_tbl[i][0], ov5640_uxga_init_reg_tbl[i][1]);
200 }
201
202#if LIGHT_SWITCH
203 ov5640_flash_ctrl(1);
204 delay_ms(500);
205 ov5640_flash_ctrl(0);
206#endif
207
208 return SUCCESS;
209}
210
216void ov5640_jpeg_mode(void)
217{
218 uint16_t i = 0;
219
220 for(i = 0; i < (sizeof(OV5640_jpeg_reg_tbl) / 4); i++)
221 {
222 ov5640_reg_write(OV5640_jpeg_reg_tbl[i][0], OV5640_jpeg_reg_tbl[i][1]);
223 }
224}
225
231void ov5640_rgb565_mode(void)
232{
233 uint16_t i = 0;
234
235 for(i = 0; i < (sizeof(ov5640_rgb565_reg_tbl) / 4); i++)
236 {
237 ov5640_reg_write(ov5640_rgb565_reg_tbl[i][0], ov5640_rgb565_reg_tbl[i][1]);
238 }
239}
240
246void ov5640_exposure(uint8_t exposure)
247{
248 ov5640_reg_write(0x3212, 0x03);
249 ov5640_reg_write(0x3a0f, OV5640_EXPOSURE_TBL[exposure][0]);
250 ov5640_reg_write(0x3a10, OV5640_EXPOSURE_TBL[exposure][1]);
251 ov5640_reg_write(0x3a1b, OV5640_EXPOSURE_TBL[exposure][2]);
252 ov5640_reg_write(0x3a1e, OV5640_EXPOSURE_TBL[exposure][3]);
253 ov5640_reg_write(0x3a11, OV5640_EXPOSURE_TBL[exposure][4]);
254 ov5640_reg_write(0x3a1f, OV5640_EXPOSURE_TBL[exposure][5]);
255 ov5640_reg_write(0x3212, 0x13);
256 ov5640_reg_write(0x3212, 0xa3);
257}
258
269void ov5640_light_mode(uint8_t mode)
270{
271 uint8_t i;
272 ov5640_reg_write(0x3212, 0x03);
273
274 for(i = 0; i < 7; i++)
275 {
276 ov5640_reg_write(0x3400 + i, OV5640_LIGHTMODE_TBL[mode][i]);
277 }
278
279 ov5640_reg_write(0x3212, 0x13);
280 ov5640_reg_write(0x3212, 0xa3);
281}
282
288void ov5640_color_saturation(uint8_t sat)
289{
290 uint8_t i;
291 ov5640_reg_write(0x3212, 0x03);
292 ov5640_reg_write(0x5381, 0x1c);
293 ov5640_reg_write(0x5382, 0x5a);
294 ov5640_reg_write(0x5383, 0x06);
295
296 for(i = 0; i < 6; i++)
297 {
298 ov5640_reg_write(0x5384 + i, OV5640_SATURATION_TBL[sat][i]);
299 }
300
301 ov5640_reg_write(0x538b, 0x98);
302 ov5640_reg_write(0x538a, 0x01);
303 ov5640_reg_write(0x3212, 0x13);
304 ov5640_reg_write(0x3212, 0xa3);
305}
306
312void ov5640_brightness(uint8_t bright)
313{
314 uint8_t brtval;
315
316 if(bright < 4)
317 {
318 brtval = 4 - bright;
319 }
320 else
321 {
322 brtval = bright - 4;
323 }
324
325 ov5640_reg_write(0x3212, 0x03);
326 ov5640_reg_write(0x5587, brtval << 4);
327
328 if(bright < 4)
329 {
330 ov5640_reg_write(0x5588, 0x09);
331 }
332 else
333 {
334 ov5640_reg_write(0x5588, 0x01);
335 }
336
337 ov5640_reg_write(0x3212, 0x13);
338 ov5640_reg_write(0x3212, 0xa3);
339}
340
346void ov5640_contrast(uint8_t contrast)
347{
348 uint8_t reg0val = 0x00;
349 uint8_t reg1val = 0x20;
350
351 switch(contrast)
352 {
353 case 0:
354 reg1val = reg0val = 0x14;
355 break;
356
357 case 1:
358 reg1val = reg0val = 0x18;
359 break;
360
361 case 2:
362 reg1val = reg0val = 0x1C;
363 break;
364
365 case 4:
366 reg0val = 0x10;
367 reg1val = 0x24;
368 break;
369
370 case 5:
371 reg0val = 0x18;
372 reg1val = 0x28;
373 break;
374
375 case 6:
376 reg0val = 0x1C;
377 reg1val = 0x2C;
378 break;
379 }
380
381 ov5640_reg_write(0x3212, 0x03);
382 ov5640_reg_write(0x5585, reg0val);
383 ov5640_reg_write(0x5586, reg1val);
384 ov5640_reg_write(0x3212, 0x13);
385 ov5640_reg_write(0x3212, 0xa3);
386}
387
393void ov5640_sharpness(uint8_t sharp)
394{
395 if(sharp < 33)
396 {
397 ov5640_reg_write(0x5308, 0x65);
398 ov5640_reg_write(0x5302, sharp);
399 }
400 else
401 {
402 ov5640_reg_write(0x5308, 0x25);
403 ov5640_reg_write(0x5300, 0x08);
404 ov5640_reg_write(0x5301, 0x30);
405 ov5640_reg_write(0x5302, 0x10);
406 ov5640_reg_write(0x5303, 0x00);
407 ov5640_reg_write(0x5309, 0x08);
408 ov5640_reg_write(0x530a, 0x30);
409 ov5640_reg_write(0x530b, 0x04);
410 ov5640_reg_write(0x530c, 0x06);
411 }
412
413}
414
420void ov5640_special_effects(uint8_t eft)
421{
422 ov5640_reg_write(0x3212, 0x03);
423 ov5640_reg_write(0x5580, OV5640_EFFECTS_TBL[eft][0]);
424 ov5640_reg_write(0x5583, OV5640_EFFECTS_TBL[eft][1]);
425 ov5640_reg_write(0x5584, OV5640_EFFECTS_TBL[eft][2]);
426 ov5640_reg_write(0x5003, 0x08);
427 ov5640_reg_write(0x3212, 0x13);
428 ov5640_reg_write(0x3212, 0xa3);
429}
430
436void ov5640_flash_ctrl(uint8_t sw)
437{
438 ov5640_reg_write(0x3016, 0x02);
439 ov5640_reg_write(0x301C, 0x02);
440
441 if(sw)
442 {
443 ov5640_reg_write(0x3019, 0x02);
444 }
445 else
446 {
447 ov5640_reg_write(0x3019, 0x00);
448 }
449}
450
459void ov5640_outsize_set(uint16_t offx, uint16_t offy, uint16_t width, uint16_t height)
460{
461 ov5640_reg_write(0x3212, 0x03);
462 ov5640_reg_write(0x3808, width >> 8);
463 ov5640_reg_write(0x3809, width & 0xFF);
464 ov5640_reg_write(0x380a, height >> 8);
465 ov5640_reg_write(0x380b, height & 0xFF);
466
467 ov5640_reg_write(0x3810, offx >> 8);
468 ov5640_reg_write(0x3811, offx & 0xFF);
469
470 ov5640_reg_write(0x3812, offy >> 8);
471 ov5640_reg_write(0x3813, offy & 0xFF);
472
473 ov5640_reg_write(0x3212, 0x13);
474 ov5640_reg_write(0x3212, 0xA3);
475}
476
485void ov5640_imagewin_set(uint16_t offx, uint16_t offy, uint16_t width, uint16_t height)
486{
487 uint16_t xst, yst, xend, yend;
488 xst = offx;
489 yst = offy;
490 xend = offx + width - 1;
491 yend = offy + height - 1;
492 ov5640_reg_write(0x3212, 0x03);
493 ov5640_reg_write(0x3800, xst >> 8);
494 ov5640_reg_write(0x3801, xst & 0xFF);
495 ov5640_reg_write(0x3802, yst >> 8);
496 ov5640_reg_write(0x3803, yst & 0xFF);
497 ov5640_reg_write(0x3804, xend >> 8);
498 ov5640_reg_write(0x3805, xend & 0xFF);
499 ov5640_reg_write(0x3806, yend >> 8);
500 ov5640_reg_write(0x3807, yend & 0xFF);
501 ov5640_reg_write(0x3212, 0x13);
502 ov5640_reg_write(0x3212, 0xA3);
503}
504
510 error_status ov5640_focus_init(void)
511{
512 uint16_t i;
513 uint16_t addr = 0x8000;
514 uint8_t state = 0x8F;
515 ov5640_reg_write(0x3000, 0x20);
516
517 for(i = 0; i < sizeof(OV5640_AF_Config); i++)
518 {
519 ov5640_reg_write(addr, OV5640_AF_Config[i]);
520 addr++;
521 }
522
523 ov5640_reg_write(0x3022, 0x00);
524 ov5640_reg_write(0x3023, 0x00);
525 ov5640_reg_write(0x3024, 0x00);
526 ov5640_reg_write(0x3025, 0x00);
527 ov5640_reg_write(0x3026, 0x00);
528 ov5640_reg_write(0x3027, 0x00);
529 ov5640_reg_write(0x3028, 0x00);
530 ov5640_reg_write(0x3029, 0x7f);
531 ov5640_reg_write(0x3000, 0x00);
532 i = 0;
533
534 do
535 {
536 ov5640_reg_read(0x3029, &state);
537 delay_ms(5);
538 i++;
539
540 if(i > 1000)
541 {
542 return ERROR;
543 }
544 }
545 while(state != 0x70);
546
547 return SUCCESS;
548}
549
555 error_status ov5640_focus_single(void)
556{
557 uint8_t temp;
558 uint16_t retry = 0;
559 ov5640_reg_write(0x3022, 0x03);
560
561 while(1)
562 {
563 retry++;
564 ov5640_reg_read(0x3029, &temp);
565
566 if(temp == 0x10)
567 {
568 break;
569 }
570
571 delay_ms(5);
572
573 if(retry > 1000)
574 {
575 return SUCCESS;
576 }
577 }
578
579 return ERROR;
580}
581
587 error_status ov5640_focus_constant(void)
588{
589 uint8_t temp = 0;
590 uint16_t retry = 0;
591 ov5640_reg_write(0x3023, 0x01);
592 ov5640_reg_write(0x3022, 0x08);
593
594 do
595 {
596 ov5640_reg_read(0x3023, &temp);
597 retry++;
598
599 if(retry > 1000)
600 {
601 return ERROR;
602 }
603
604 delay_ms(5);
605 }
606 while(temp != 0x00);
607
608 ov5640_reg_write(0x3023, 0x01);
609 ov5640_reg_write(0x3022, 0x04);
610 retry = 0;
611
612 do
613 {
614 ov5640_reg_read(0x3023, &temp);
615 retry++;
616
617 if(retry > 1000)
618 {
619 return ERROR;
620 }
621
622 delay_ms(5);
623 }
624 while(temp != 0x00);
625
626 return SUCCESS;
627}
628
634void ov5640_i2c_init(void)
635{
636 hi2cx.i2cx = I2C2;
637 i2c_config(&hi2cx);
638}
639
645void i2c_lowlevel_init(i2c_handle_type* hi2c)
646{
647 gpio_init_type gpio_init_structure;
648
649 /* i2c periph clock enable */
650 crm_periph_clock_enable(CRM_I2C2_PERIPH_CLOCK, TRUE);
651 crm_periph_clock_enable(CRM_GPIOH_PERIPH_CLOCK, TRUE);
652 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
653
654 /* gpio configuration */
655 gpio_pin_mux_config(GPIOH, GPIO_PINS_SOURCE2, GPIO_MUX_4);
656
657 gpio_pin_mux_config(GPIOH, GPIO_PINS_SOURCE3, GPIO_MUX_4);
658
659 gpio_default_para_init(&gpio_init_structure);
660 /* configure i2c pins: scl */
661 gpio_init_structure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
662 gpio_init_structure.gpio_mode = GPIO_MODE_MUX;
663 gpio_init_structure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
664 gpio_init_structure.gpio_pull = GPIO_PULL_UP;
665 gpio_init_structure.gpio_pins = GPIO_PINS_2;
666 gpio_init(GPIOH, &gpio_init_structure);
667
668 gpio_init_structure.gpio_pins = GPIO_PINS_3;
669 gpio_init(GPIOH, &gpio_init_structure);
670
671 /* configure and enable i2c interrupt */
672 nvic_irq_enable(I2C2_EVT_IRQn, 0, 0);
673 nvic_irq_enable(I2C2_ERR_IRQn, 0, 0);
674
675 /* configure and enable i2c dma channel interrupt */
676 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
677 nvic_irq_enable(DMA1_Channel2_IRQn, 0, 0);
678
679 /* i2c dma tx and rx channels configuration */
680 /* enable the dma clock */
681
682 /* i2c dma channel configuration */
683 dma_reset(hi2c->dma_tx_channel);
684 dma_reset(hi2c->dma_rx_channel);
685
686 hi2c->dma_tx_channel = DMA1_CHANNEL1;
687 hi2c->dma_rx_channel = DMA1_CHANNEL2;
688
689 hi2c->dma_init_struct.peripheral_base_addr = (uint32_t)&hi2c->i2cx->txdt;
690 hi2c->dma_init_struct.memory_base_addr = 0;
691 hi2c->dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
692 hi2c->dma_init_struct.buffer_size = 0xFFFF;
693 hi2c->dma_init_struct.peripheral_inc_enable = FALSE;
694 hi2c->dma_init_struct.memory_inc_enable = TRUE;
695 hi2c->dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
696 hi2c->dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
697 hi2c->dma_init_struct.loop_mode_enable = FALSE;
698 hi2c->dma_init_struct.priority = DMA_PRIORITY_LOW;
699
700 dma_init(hi2c->dma_tx_channel, &hi2c->dma_init_struct);
701 dma_init(hi2c->dma_rx_channel, &hi2c->dma_init_struct);
702
703 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_I2C1_TX);
704 dmamux_init(DMA1MUX_CHANNEL2, DMAMUX_DMAREQ_ID_I2C1_RX);
705
706 dmamux_enable(DMA1, TRUE);
707
708 /* config i2c */
709 i2c_init(hi2c->i2cx, 0x0F, I2Cx_CLKCTRL);
710
711 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
712}
713
at32f435_437.h
at32f435_437 header file
at32f435_437_board.h
ov5640.h
ov5640af.h
header file of ov5640af program
ov5640cfg.h
header file of ov5640cfg program
STA
i2c_status_type STA
Definition: at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:65
ov5640_init
error_status ov5640_init(void)
initialize ov5640
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:160
OV5640_EXPOSURE_TBL
const uint8_t OV5640_EXPOSURE_TBL[7][6]
Definition: at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:67
ov5640_outsize_set
void ov5640_outsize_set(uint16_t offx, uint16_t offy, uint16_t width, uint16_t height)
ov5640 output size set
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:459
ov5640_light_mode
void ov5640_light_mode(uint8_t mode)
this function is draw point to lcd
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:269
ov5640_focus_constant
error_status ov5640_focus_constant(void)
ov5640 focus constant
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:587
ov5640_brightness
void ov5640_brightness(uint8_t bright)
ov5640 brightness configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:312
ov5640_reg_read
error_status ov5640_reg_read(uint16_t reg, uint8_t *data)
read register from ov5640
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:136
ov5640_focus_single
error_status ov5640_focus_single(void)
ov5640 focus single
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:555
ov5640_color_saturation
void ov5640_color_saturation(uint8_t sat)
ov5640 color saturation configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:288
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:45
ov5640_rgb565_reg_tbl
const uint16_t ov5640_rgb565_reg_tbl[][2]
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h:89
ov5640_flash_ctrl
void ov5640_flash_ctrl(uint8_t sw)
ov5640 flash control
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:436
OV5640_LIGHTMODE_TBL
const uint8_t OV5640_LIGHTMODE_TBL[5][7]
Definition: at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:78
ov5640_i2c_init
void ov5640_i2c_init(void)
ov5640 i2c initialize
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:634
I2Cx_CLKCTRL
#define I2Cx_CLKCTRL
Definition: at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:44
ov5640_rgb565_mode
void ov5640_rgb565_mode(void)
ov5640 rgb565 mode configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:231
ov5640_uxga_init_reg_tbl
const uint16_t ov5640_uxga_init_reg_tbl[][2]
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h:154
OV5640_jpeg_reg_tbl
const uint16_t OV5640_jpeg_reg_tbl[][2]
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h:39
ov5640_jpeg_mode
void ov5640_jpeg_mode(void)
ov5640 jpeg mode configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:216
ov5640_sharpness
void ov5640_sharpness(uint8_t sharp)
ov5640 sharpness configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:393
OV5640_EFFECTS_TBL
const uint8_t OV5640_EFFECTS_TBL[7][3]
Definition: at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:98
hi2cx
i2c_handle_type hi2cx
Definition: at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:64
ov5640_special_effects
void ov5640_special_effects(uint8_t eft)
ov5640 special effects configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:420
OV5640_SATURATION_TBL
const uint8_t OV5640_SATURATION_TBL[7][6]
Definition: at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:87
OV5640_AF_Config
const unsigned char OV5640_AF_Config[]
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640af.h:38
ov5640_reg_write
error_status ov5640_reg_write(uint16_t reg, uint8_t data)
write register to ov5640
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:115
ov5640_exposure
void ov5640_exposure(uint8_t exposure)
ov5640 exposure configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:246
ov5640_imagewin_set
void ov5640_imagewin_set(uint16_t offx, uint16_t offy, uint16_t width, uint16_t height)
ov5640 image window set
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:485
ov5640_focus_init
error_status ov5640_focus_init(void)
initialize ov5640 focus function
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:510
ov5640_contrast
void ov5640_contrast(uint8_t contrast)
ov5640 contrast configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:346
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_GPIOH_PERIPH_CLOCK
@ CRM_GPIOH_PERIPH_CLOCK
Definition: at32f435_437_crm.h:112
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
CRM_I2C2_PERIPH_CLOCK
@ CRM_I2C2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:145
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:162
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:172
DMA_PRIORITY_LOW
@ DMA_PRIORITY_LOW
Definition: at32f435_437_dma.h:182
DMAMUX_DMAREQ_ID_I2C1_RX
@ DMAMUX_DMAREQ_ID_I2C1_RX
Definition: at32f435_437_dma.h:216
DMAMUX_DMAREQ_ID_I2C1_TX
@ DMAMUX_DMAREQ_ID_I2C1_TX
Definition: at32f435_437_dma.h:217
DMA1MUX_CHANNEL2
#define DMA1MUX_CHANNEL2
Definition: at32f435_437_dma.h:705
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f435_437_dma.h:697
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f435_437_gpio.h:103
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_4
@ GPIO_MUX_4
Definition: at32f435_437_gpio.h:160
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOH
#define GPIOH
Definition: at32f435_437_gpio.h:528
i2c_init
void i2c_init(i2c_type *i2c_x, uint8_t dfilters, uint32_t clk)
init i2c digit filters and clock control register.
Definition: at32f435_437_i2c.c:79
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config i2c own address 1.
Definition: at32f435_437_i2c.c:103
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f435_437_i2c.h:113
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:113
i2c_lowlevel_init
__WEAK void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: i2c_application.c:103
i2c_master_receive
i2c_status_type i2c_master_receive(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through polling mode.
Definition: i2c_application.c:524
i2c_master_transmit
i2c_status_type i2c_master_transmit(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode.
Definition: i2c_application.c:375
i2c_status_type
i2c_status_type
Definition: i2c_application.h:80
I2C_OK
@ I2C_OK
Definition: i2c_application.h:81
I2C2
#define I2C2
Definition: at32f435_437_i2c.h:415
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
DMA1_Channel2_IRQn
@ DMA1_Channel2_IRQn
Definition: at32f435_437.h:205
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f435_437.h:204
I2C2_ERR_IRQn
@ I2C2_ERR_IRQn
Definition: at32f435_437.h:182
I2C2_EVT_IRQn
@ I2C2_EVT_IRQn
Definition: at32f435_437.h:181
OV5640_RST_LOW
#define OV5640_RST_LOW
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h:47
OV5640_CHIPIDH
#define OV5640_CHIPIDH
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h:51
OV5640_RST_HIGH
#define OV5640_RST_HIGH
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h:46
OV5640_ADDR
#define OV5640_ADDR
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h:50
OV5640_CHIPIDL
#define OV5640_CHIPIDL
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h:52
OV5640_ID
#define OV5640_ID
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h:49
i2c_application.h
i2c application libray header file
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
i2c_handle_type
Definition: i2c_application.h:112
i2c_handle_type::dma_rx_channel
dma_channel_type * dma_rx_channel
Definition: i2c_application.h:121
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:113
i2c_handle_type::dma_init_struct
dma_init_type dma_init_struct
Definition: i2c_application.h:122
i2c_handle_type::dma_tx_channel
dma_channel_type * dma_tx_channel
Definition: i2c_application.h:120
i2c_type::txdt
__IO uint32_t txdt
Definition: at32f435_437_i2c.h:400


AT32F435/437 Firmwary Library: ov5640.h File Reference

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • ov5640
Macros | Functions
at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h File Reference
#include "at32f435_437.h"

Go to the source code of this file.

Macros

#define | LIGHT_SWITCH 0
#define | OV5640_RST_HIGH gpio_bits_set(GPIOC, GPIO_PINS_3);
#define | OV5640_RST_LOW gpio_bits_reset(GPIOC, GPIO_PINS_3);
#define | OV5640_ID ((uint16_t)0x5640)
#define | OV5640_ADDR ((uint16_t)0x0078)
#define | OV5640_CHIPIDH ((uint16_t)0x300A)
#define | OV5640_CHIPIDL ((uint16_t)0x300B)
#define | HARDWARE_MODE

Functions

error_status | ov5640_reg_write (uint16_t reg, uint8_t data)
write register to ov5640 More...
error_status | ov5640_reg_read (uint16_t reg, uint8_t *val)
read register from ov5640 More...
error_status | ov5640_init (void)
initialize ov5640 More...
void | ov5640_jpeg_mode (void)
ov5640 jpeg mode configure More...
void | ov5640_rgb565_mode (void)
ov5640 rgb565 mode configure More...
void | ov5640_exposure (uint8_t exposure)
ov5640 exposure configure More...
void | ov5640_light_mode (uint8_t mode)
this function is draw point to lcd More...
void | ov5640_color_saturation (uint8_t sat)
ov5640 color saturation configure More...
void | ov5640_brightness (uint8_t bright)
ov5640 brightness configure More...
void | ov5640_contrast (uint8_t contrast)
ov5640 contrast configure More...
void | ov5640_sharpness (uint8_t sharp)
ov5640 sharpness configure More...
void | ov5640_special_effects (uint8_t eft)
ov5640 special effects configure More...
void | ov5640_flash_ctrl (uint8_t sw)
ov5640 flash control More...
void | ov5640_outsize_set (uint16_t offx, uint16_t offy, uint16_t width, uint16_t height)
ov5640 output size set More...
void | ov5640_imagewin_set (uint16_t offx, uint16_t offy, uint16_t width, uint16_t height)
ov5640 image window set More...
error_status | ov5640_focus_init (void)
initialize ov5640 focus function More...
error_status | ov5640_focus_single (void)
ov5640 focus single More...
error_status | ov5640_focus_constant (void)
ov5640 focus constant More...
void | ov5640_i2c_init (void)
ov5640 i2c initialize More...


AT32F435/437 Firmwary Library: ov5640.h Source File

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • ov5640
at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
Go to the documentation of this file.
1
27#ifndef _OV5640_H
28#define _OV5640_H
29
30#include "at32f435_437.h"
31
44#define LIGHT_SWITCH 0
45
46#define OV5640_RST_HIGH gpio_bits_set(GPIOC, GPIO_PINS_3);
47#define OV5640_RST_LOW gpio_bits_reset(GPIOC, GPIO_PINS_3);
48
49#define OV5640_ID ((uint16_t)0x5640)
50#define OV5640_ADDR ((uint16_t)0x0078)
51#define OV5640_CHIPIDH ((uint16_t)0x300A)
52#define OV5640_CHIPIDL ((uint16_t)0x300B)
54#define HARDWARE_MODE
55//#define EMBEDDED_MODE
56
65 error_status ov5640_reg_write(uint16_t reg, uint8_t data);
66 error_status ov5640_reg_read(uint16_t reg, uint8_t *val);
67 error_status ov5640_init(void);
68void ov5640_jpeg_mode(void);
69void ov5640_rgb565_mode(void);
70void ov5640_exposure(uint8_t exposure);
71void ov5640_light_mode(uint8_t mode);
72void ov5640_color_saturation(uint8_t sat);
73void ov5640_brightness(uint8_t bright);
74void ov5640_contrast(uint8_t contrast);
75void ov5640_sharpness(uint8_t sharp);
76void ov5640_special_effects(uint8_t eft);
77void ov5640_flash_ctrl(uint8_t sw);
78void ov5640_outsize_set(uint16_t offx, uint16_t offy, uint16_t width, uint16_t height);
79void ov5640_imagewin_set(uint16_t offx, uint16_t offy, uint16_t width, uint16_t height);
80 error_status ov5640_focus_init(void);
81 error_status ov5640_focus_single(void);
82 error_status ov5640_focus_constant(void);
83void ov5640_i2c_init(void);
84
97#endif
at32f435_437.h
at32f435_437 header file
ov5640_init
error_status ov5640_init(void)
initialize ov5640
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:160
ov5640_outsize_set
void ov5640_outsize_set(uint16_t offx, uint16_t offy, uint16_t width, uint16_t height)
ov5640 output size set
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:459
ov5640_light_mode
void ov5640_light_mode(uint8_t mode)
this function is draw point to lcd
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:269
ov5640_focus_constant
error_status ov5640_focus_constant(void)
ov5640 focus constant
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:587
ov5640_brightness
void ov5640_brightness(uint8_t bright)
ov5640 brightness configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:312
ov5640_reg_read
error_status ov5640_reg_read(uint16_t reg, uint8_t *data)
read register from ov5640
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:136
ov5640_focus_single
error_status ov5640_focus_single(void)
ov5640 focus single
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:555
ov5640_color_saturation
void ov5640_color_saturation(uint8_t sat)
ov5640 color saturation configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:288
ov5640_flash_ctrl
void ov5640_flash_ctrl(uint8_t sw)
ov5640 flash control
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:436
ov5640_i2c_init
void ov5640_i2c_init(void)
ov5640 i2c initialize
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:634
ov5640_rgb565_mode
void ov5640_rgb565_mode(void)
ov5640 rgb565 mode configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:231
ov5640_jpeg_mode
void ov5640_jpeg_mode(void)
ov5640 jpeg mode configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:216
ov5640_sharpness
void ov5640_sharpness(uint8_t sharp)
ov5640 sharpness configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:393
ov5640_special_effects
void ov5640_special_effects(uint8_t eft)
ov5640 special effects configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:420
ov5640_reg_write
error_status ov5640_reg_write(uint16_t reg, uint8_t data)
write register to ov5640
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:115
ov5640_exposure
void ov5640_exposure(uint8_t exposure)
ov5640 exposure configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:246
ov5640_imagewin_set
void ov5640_imagewin_set(uint16_t offx, uint16_t offy, uint16_t width, uint16_t height)
ov5640 image window set
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:485
ov5640_focus_init
error_status ov5640_focus_init(void)
initialize ov5640 focus function
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:510
ov5640_contrast
void ov5640_contrast(uint8_t contrast)
ov5640 contrast configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:346
error_status
error_status
Definition: at32f435_437.h:380


AT32F435/437 Firmwary Library: ov5640af.h File Reference

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • ov5640
Variables
at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640af.h File Reference

header file of ov5640af program More...

Go to the source code of this file.

Variables

const unsigned char OV5640_AF_Config []

Detailed Description

header file of ov5640af program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640af.h.


AT32F435/437 Firmwary Library: ov5640af.h Source File

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • ov5640
at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640af.h
Go to the documentation of this file.
1
27#ifndef _OV5640AF_H
28#define _OV5640AF_H
29
38const unsigned char OV5640_AF_Config[] =
39{
40 0x02, 0x0F, 0xD6, 0x02, 0x0A, 0x39, 0xC2, 0x01, 0x22, 0x22, 0x00, 0x02, 0x0F, 0xB2, 0xE5, 0x1F,
41
42 0x70, 0x72, 0xF5, 0x1E, 0xD2, 0x35, 0xFF, 0xEF, 0x25, 0xE0, 0x24, 0x4E, 0xF8, 0xE4, 0xF6, 0x08,
43
44 0xF6, 0x0F, 0xBF, 0x34, 0xF2, 0x90, 0x0E, 0x93, 0xE4, 0x93, 0xFF, 0xE5, 0x4B, 0xC3, 0x9F, 0x50,
45
46 0x04, 0x7F, 0x05, 0x80, 0x02, 0x7F, 0xFB, 0x78, 0xBD, 0xA6, 0x07, 0x12, 0x0F, 0x04, 0x40, 0x04,
47
48 0x7F, 0x03, 0x80, 0x02, 0x7F, 0x30, 0x78, 0xBC, 0xA6, 0x07, 0xE6, 0x18, 0xF6, 0x08, 0xE6, 0x78,
49
50 0xB9, 0xF6, 0x78, 0xBC, 0xE6, 0x78, 0xBA, 0xF6, 0x78, 0xBF, 0x76, 0x33, 0xE4, 0x08, 0xF6, 0x78,
51
52 0xB8, 0x76, 0x01, 0x75, 0x4A, 0x02, 0x78, 0xB6, 0xF6, 0x08, 0xF6, 0x74, 0xFF, 0x78, 0xC1, 0xF6,
53
54 0x08, 0xF6, 0x75, 0x1F, 0x01, 0x78, 0xBC, 0xE6, 0x75, 0xF0, 0x05, 0xA4, 0xF5, 0x4B, 0x12, 0x0A,
55
56 0xFF, 0xC2, 0x37, 0x22, 0x78, 0xB8, 0xE6, 0xD3, 0x94, 0x00, 0x40, 0x02, 0x16, 0x22, 0xE5, 0x1F,
57
58 0xB4, 0x05, 0x23, 0xE4, 0xF5, 0x1F, 0xC2, 0x01, 0x78, 0xB6, 0xE6, 0xFE, 0x08, 0xE6, 0xFF, 0x78,
59
60 0x4E, 0xA6, 0x06, 0x08, 0xA6, 0x07, 0xA2, 0x37, 0xE4, 0x33, 0xF5, 0x3C, 0x90, 0x30, 0x28, 0xF0,
61
62 0x75, 0x1E, 0x10, 0xD2, 0x35, 0x22, 0xE5, 0x4B, 0x75, 0xF0, 0x05, 0x84, 0x78, 0xBC, 0xF6, 0x90,
63
64 0x0E, 0x8C, 0xE4, 0x93, 0xFF, 0x25, 0xE0, 0x24, 0x0A, 0xF8, 0xE6, 0xFC, 0x08, 0xE6, 0xFD, 0x78,
65
66 0xBC, 0xE6, 0x25, 0xE0, 0x24, 0x4E, 0xF8, 0xA6, 0x04, 0x08, 0xA6, 0x05, 0xEF, 0x12, 0x0F, 0x0B,
67
68 0xD3, 0x78, 0xB7, 0x96, 0xEE, 0x18, 0x96, 0x40, 0x0D, 0x78, 0xBC, 0xE6, 0x78, 0xB9, 0xF6, 0x78,
69
70 0xB6, 0xA6, 0x06, 0x08, 0xA6, 0x07, 0x90, 0x0E, 0x8C, 0xE4, 0x93, 0x12, 0x0F, 0x0B, 0xC3, 0x78,
71
72 0xC2, 0x96, 0xEE, 0x18, 0x96, 0x50, 0x0D, 0x78, 0xBC, 0xE6, 0x78, 0xBA, 0xF6, 0x78, 0xC1, 0xA6,
73
74 0x06, 0x08, 0xA6, 0x07, 0x78, 0xB6, 0xE6, 0xFE, 0x08, 0xE6, 0xC3, 0x78, 0xC2, 0x96, 0xFF, 0xEE,
75
76 0x18, 0x96, 0x78, 0xC3, 0xF6, 0x08, 0xA6, 0x07, 0x90, 0x0E, 0x95, 0xE4, 0x18, 0x12, 0x0E, 0xE9,
77
78 0x40, 0x02, 0xD2, 0x37, 0x78, 0xBC, 0xE6, 0x08, 0x26, 0x08, 0xF6, 0xE5, 0x1F, 0x64, 0x01, 0x70,
79
80 0x4A, 0xE6, 0xC3, 0x78, 0xC0, 0x12, 0x0E, 0xDF, 0x40, 0x05, 0x12, 0x0E, 0xDA, 0x40, 0x39, 0x12,
81
82 0x0F, 0x02, 0x40, 0x04, 0x7F, 0xFE, 0x80, 0x02, 0x7F, 0x02, 0x78, 0xBD, 0xA6, 0x07, 0x78, 0xB9,
83
84 0xE6, 0x24, 0x03, 0x78, 0xBF, 0xF6, 0x78, 0xB9, 0xE6, 0x24, 0xFD, 0x78, 0xC0, 0xF6, 0x12, 0x0F,
85
86 0x02, 0x40, 0x06, 0x78, 0xC0, 0xE6, 0xFF, 0x80, 0x04, 0x78, 0xBF, 0xE6, 0xFF, 0x78, 0xBE, 0xA6,
87
88 0x07, 0x75, 0x1F, 0x02, 0x78, 0xB8, 0x76, 0x01, 0x02, 0x02, 0x4A, 0xE5, 0x1F, 0x64, 0x02, 0x60,
89
90 0x03, 0x02, 0x02, 0x2A, 0x78, 0xBE, 0xE6, 0xFF, 0xC3, 0x78, 0xC0, 0x12, 0x0E, 0xE0, 0x40, 0x08,
91
92 0x12, 0x0E, 0xDA, 0x50, 0x03, 0x02, 0x02, 0x28, 0x12, 0x0F, 0x02, 0x40, 0x04, 0x7F, 0xFF, 0x80,
93
94 0x02, 0x7F, 0x01, 0x78, 0xBD, 0xA6, 0x07, 0x78, 0xB9, 0xE6, 0x04, 0x78, 0xBF, 0xF6, 0x78, 0xB9,
95
96 0xE6, 0x14, 0x78, 0xC0, 0xF6, 0x18, 0x12, 0x0F, 0x04, 0x40, 0x04, 0xE6, 0xFF, 0x80, 0x02, 0x7F,
97
98 0x00, 0x78, 0xBF, 0xA6, 0x07, 0xD3, 0x08, 0xE6, 0x64, 0x80, 0x94, 0x80, 0x40, 0x04, 0xE6, 0xFF,
99
100 0x80, 0x02, 0x7F, 0x00, 0x78, 0xC0, 0xA6, 0x07, 0xC3, 0x18, 0xE6, 0x64, 0x80, 0x94, 0xB3, 0x50,
101
102 0x04, 0xE6, 0xFF, 0x80, 0x02, 0x7F, 0x33, 0x78, 0xBF, 0xA6, 0x07, 0xC3, 0x08, 0xE6, 0x64, 0x80,
103
104 0x94, 0xB3, 0x50, 0x04, 0xE6, 0xFF, 0x80, 0x02, 0x7F, 0x33, 0x78, 0xC0, 0xA6, 0x07, 0x12, 0x0F,
105
106 0x02, 0x40, 0x06, 0x78, 0xC0, 0xE6, 0xFF, 0x80, 0x04, 0x78, 0xBF, 0xE6, 0xFF, 0x78, 0xBE, 0xA6,
107
108 0x07, 0x75, 0x1F, 0x03, 0x78, 0xB8, 0x76, 0x01, 0x80, 0x20, 0xE5, 0x1F, 0x64, 0x03, 0x70, 0x26,
109
110 0x78, 0xBE, 0xE6, 0xFF, 0xC3, 0x78, 0xC0, 0x12, 0x0E, 0xE0, 0x40, 0x05, 0x12, 0x0E, 0xDA, 0x40,
111
112 0x09, 0x78, 0xB9, 0xE6, 0x78, 0xBE, 0xF6, 0x75, 0x1F, 0x04, 0x78, 0xBE, 0xE6, 0x75, 0xF0, 0x05,
113
114 0xA4, 0xF5, 0x4B, 0x02, 0x0A, 0xFF, 0xE5, 0x1F, 0xB4, 0x04, 0x10, 0x90, 0x0E, 0x94, 0xE4, 0x78,
115
116 0xC3, 0x12, 0x0E, 0xE9, 0x40, 0x02, 0xD2, 0x37, 0x75, 0x1F, 0x05, 0x22, 0x30, 0x01, 0x03, 0x02,
117
118 0x04, 0xC0, 0x30, 0x02, 0x03, 0x02, 0x04, 0xC0, 0x90, 0x51, 0xA5, 0xE0, 0x78, 0x93, 0xF6, 0xA3,
119
120 0xE0, 0x08, 0xF6, 0xA3, 0xE0, 0x08, 0xF6, 0xE5, 0x1F, 0x70, 0x3C, 0x75, 0x1E, 0x20, 0xD2, 0x35,
121
122 0x12, 0x0C, 0x7A, 0x78, 0x7E, 0xA6, 0x06, 0x08, 0xA6, 0x07, 0x78, 0x8B, 0xA6, 0x09, 0x18, 0x76,
123
124 0x01, 0x12, 0x0C, 0x5B, 0x78, 0x4E, 0xA6, 0x06, 0x08, 0xA6, 0x07, 0x78, 0x8B, 0xE6, 0x78, 0x6E,
125
126 0xF6, 0x75, 0x1F, 0x01, 0x78, 0x93, 0xE6, 0x78, 0x90, 0xF6, 0x78, 0x94, 0xE6, 0x78, 0x91, 0xF6,
127
128 0x78, 0x95, 0xE6, 0x78, 0x92, 0xF6, 0x22, 0x79, 0x90, 0xE7, 0xD3, 0x78, 0x93, 0x96, 0x40, 0x05,
129
130 0xE7, 0x96, 0xFF, 0x80, 0x08, 0xC3, 0x79, 0x93, 0xE7, 0x78, 0x90, 0x96, 0xFF, 0x78, 0x88, 0x76,
131
132 0x00, 0x08, 0xA6, 0x07, 0x79, 0x91, 0xE7, 0xD3, 0x78, 0x94, 0x96, 0x40, 0x05, 0xE7, 0x96, 0xFF,
133
134 0x80, 0x08, 0xC3, 0x79, 0x94, 0xE7, 0x78, 0x91, 0x96, 0xFF, 0x12, 0x0C, 0x8E, 0x79, 0x92, 0xE7,
135
136 0xD3, 0x78, 0x95, 0x96, 0x40, 0x05, 0xE7, 0x96, 0xFF, 0x80, 0x08, 0xC3, 0x79, 0x95, 0xE7, 0x78,
137
138 0x92, 0x96, 0xFF, 0x12, 0x0C, 0x8E, 0x12, 0x0C, 0x5B, 0x78, 0x8A, 0xE6, 0x25, 0xE0, 0x24, 0x4E,
139
140 0xF8, 0xA6, 0x06, 0x08, 0xA6, 0x07, 0x78, 0x8A, 0xE6, 0x24, 0x6E, 0xF8, 0xA6, 0x09, 0x78, 0x8A,
141
142 0xE6, 0x24, 0x01, 0xFF, 0xE4, 0x33, 0xFE, 0xD3, 0xEF, 0x94, 0x0F, 0xEE, 0x64, 0x80, 0x94, 0x80,
143
144 0x40, 0x04, 0x7F, 0x00, 0x80, 0x05, 0x78, 0x8A, 0xE6, 0x04, 0xFF, 0x78, 0x8A, 0xA6, 0x07, 0xE5,
145
146 0x1F, 0xB4, 0x01, 0x0A, 0xE6, 0x60, 0x03, 0x02, 0x04, 0xC0, 0x75, 0x1F, 0x02, 0x22, 0x12, 0x0C,
147
148 0x7A, 0x78, 0x80, 0xA6, 0x06, 0x08, 0xA6, 0x07, 0x12, 0x0C, 0x7A, 0x78, 0x82, 0xA6, 0x06, 0x08,
149
150 0xA6, 0x07, 0x78, 0x6E, 0xE6, 0x78, 0x8C, 0xF6, 0x78, 0x6E, 0xE6, 0x78, 0x8D, 0xF6, 0x7F, 0x01,
151
152 0xEF, 0x25, 0xE0, 0x24, 0x4F, 0xF9, 0xC3, 0x78, 0x81, 0xE6, 0x97, 0x18, 0xE6, 0x19, 0x97, 0x50,
153
154 0x0A, 0x12, 0x0C, 0x82, 0x78, 0x80, 0xA6, 0x04, 0x08, 0xA6, 0x05, 0x74, 0x6E, 0x2F, 0xF9, 0x78,
155
156 0x8C, 0xE6, 0xC3, 0x97, 0x50, 0x08, 0x74, 0x6E, 0x2F, 0xF8, 0xE6, 0x78, 0x8C, 0xF6, 0xEF, 0x25,
157
158 0xE0, 0x24, 0x4F, 0xF9, 0xD3, 0x78, 0x83, 0xE6, 0x97, 0x18, 0xE6, 0x19, 0x97, 0x40, 0x0A, 0x12,
159
160 0x0C, 0x82, 0x78, 0x82, 0xA6, 0x04, 0x08, 0xA6, 0x05, 0x74, 0x6E, 0x2F, 0xF9, 0x78, 0x8D, 0xE6,
161
162 0xD3, 0x97, 0x40, 0x08, 0x74, 0x6E, 0x2F, 0xF8, 0xE6, 0x78, 0x8D, 0xF6, 0x0F, 0xEF, 0x64, 0x10,
163
164 0x70, 0x9E, 0xC3, 0x79, 0x81, 0xE7, 0x78, 0x83, 0x96, 0xFF, 0x19, 0xE7, 0x18, 0x96, 0x78, 0x84,
165
166 0xF6, 0x08, 0xA6, 0x07, 0xC3, 0x79, 0x8C, 0xE7, 0x78, 0x8D, 0x96, 0x08, 0xF6, 0xD3, 0x79, 0x81,
167
168 0xE7, 0x78, 0x7F, 0x96, 0x19, 0xE7, 0x18, 0x96, 0x40, 0x05, 0x09, 0xE7, 0x08, 0x80, 0x06, 0xC3,
169
170 0x79, 0x7F, 0xE7, 0x78, 0x81, 0x96, 0xFF, 0x19, 0xE7, 0x18, 0x96, 0xFE, 0x78, 0x86, 0xA6, 0x06,
171
172 0x08, 0xA6, 0x07, 0x79, 0x8C, 0xE7, 0xD3, 0x78, 0x8B, 0x96, 0x40, 0x05, 0xE7, 0x96, 0xFF, 0x80,
173
174 0x08, 0xC3, 0x79, 0x8B, 0xE7, 0x78, 0x8C, 0x96, 0xFF, 0x78, 0x8F, 0xA6, 0x07, 0xE5, 0x1F, 0x64,
175
176 0x02, 0x70, 0x69, 0x90, 0x0E, 0x91, 0x93, 0xFF, 0x18, 0xE6, 0xC3, 0x9F, 0x50, 0x72, 0x12, 0x0C,
177
178 0x4A, 0x12, 0x0C, 0x2F, 0x90, 0x0E, 0x8E, 0x12, 0x0C, 0x38, 0x78, 0x80, 0x12, 0x0C, 0x6B, 0x7B,
179
180 0x04, 0x12, 0x0C, 0x1D, 0xC3, 0x12, 0x06, 0x45, 0x50, 0x56, 0x90, 0x0E, 0x92, 0xE4, 0x93, 0xFF,
181
182 0x78, 0x8F, 0xE6, 0x9F, 0x40, 0x02, 0x80, 0x11, 0x90, 0x0E, 0x90, 0xE4, 0x93, 0xFF, 0xD3, 0x78,
183
184 0x89, 0xE6, 0x9F, 0x18, 0xE6, 0x94, 0x00, 0x40, 0x03, 0x75, 0x1F, 0x05, 0x12, 0x0C, 0x4A, 0x12,
185
186 0x0C, 0x2F, 0x90, 0x0E, 0x8F, 0x12, 0x0C, 0x38, 0x78, 0x7E, 0x12, 0x0C, 0x6B, 0x7B, 0x40, 0x12,
187
188 0x0C, 0x1D, 0xD3, 0x12, 0x06, 0x45, 0x40, 0x18, 0x75, 0x1F, 0x05, 0x22, 0xE5, 0x1F, 0xB4, 0x05,
189
190 0x0F, 0xD2, 0x01, 0xC2, 0x02, 0xE4, 0xF5, 0x1F, 0xF5, 0x1E, 0xD2, 0x35, 0xD2, 0x33, 0xD2, 0x36,
191
192 0x22, 0xEF, 0x8D, 0xF0, 0xA4, 0xA8, 0xF0, 0xCF, 0x8C, 0xF0, 0xA4, 0x28, 0xCE, 0x8D, 0xF0, 0xA4,
193
194 0x2E, 0xFE, 0x22, 0xBC, 0x00, 0x0B, 0xBE, 0x00, 0x29, 0xEF, 0x8D, 0xF0, 0x84, 0xFF, 0xAD, 0xF0,
195
196 0x22, 0xE4, 0xCC, 0xF8, 0x75, 0xF0, 0x08, 0xEF, 0x2F, 0xFF, 0xEE, 0x33, 0xFE, 0xEC, 0x33, 0xFC,
197
198 0xEE, 0x9D, 0xEC, 0x98, 0x40, 0x05, 0xFC, 0xEE, 0x9D, 0xFE, 0x0F, 0xD5, 0xF0, 0xE9, 0xE4, 0xCE,
199
200 0xFD, 0x22, 0xED, 0xF8, 0xF5, 0xF0, 0xEE, 0x84, 0x20, 0xD2, 0x1C, 0xFE, 0xAD, 0xF0, 0x75, 0xF0,
201
202 0x08, 0xEF, 0x2F, 0xFF, 0xED, 0x33, 0xFD, 0x40, 0x07, 0x98, 0x50, 0x06, 0xD5, 0xF0, 0xF2, 0x22,
203
204 0xC3, 0x98, 0xFD, 0x0F, 0xD5, 0xF0, 0xEA, 0x22, 0xE8, 0x8F, 0xF0, 0xA4, 0xCC, 0x8B, 0xF0, 0xA4,
205
206 0x2C, 0xFC, 0xE9, 0x8E, 0xF0, 0xA4, 0x2C, 0xFC, 0x8A, 0xF0, 0xED, 0xA4, 0x2C, 0xFC, 0xEA, 0x8E,
207
208 0xF0, 0xA4, 0xCD, 0xA8, 0xF0, 0x8B, 0xF0, 0xA4, 0x2D, 0xCC, 0x38, 0x25, 0xF0, 0xFD, 0xE9, 0x8F,
209
210 0xF0, 0xA4, 0x2C, 0xCD, 0x35, 0xF0, 0xFC, 0xEB, 0x8E, 0xF0, 0xA4, 0xFE, 0xA9, 0xF0, 0xEB, 0x8F,
211
212 0xF0, 0xA4, 0xCF, 0xC5, 0xF0, 0x2E, 0xCD, 0x39, 0xFE, 0xE4, 0x3C, 0xFC, 0xEA, 0xA4, 0x2D, 0xCE,
213
214 0x35, 0xF0, 0xFD, 0xE4, 0x3C, 0xFC, 0x22, 0x75, 0xF0, 0x08, 0x75, 0x82, 0x00, 0xEF, 0x2F, 0xFF,
215
216 0xEE, 0x33, 0xFE, 0xCD, 0x33, 0xCD, 0xCC, 0x33, 0xCC, 0xC5, 0x82, 0x33, 0xC5, 0x82, 0x9B, 0xED,
217
218 0x9A, 0xEC, 0x99, 0xE5, 0x82, 0x98, 0x40, 0x0C, 0xF5, 0x82, 0xEE, 0x9B, 0xFE, 0xED, 0x9A, 0xFD,
219
220 0xEC, 0x99, 0xFC, 0x0F, 0xD5, 0xF0, 0xD6, 0xE4, 0xCE, 0xFB, 0xE4, 0xCD, 0xFA, 0xE4, 0xCC, 0xF9,
221
222 0xA8, 0x82, 0x22, 0xB8, 0x00, 0xC1, 0xB9, 0x00, 0x59, 0xBA, 0x00, 0x2D, 0xEC, 0x8B, 0xF0, 0x84,
223
224 0xCF, 0xCE, 0xCD, 0xFC, 0xE5, 0xF0, 0xCB, 0xF9, 0x78, 0x18, 0xEF, 0x2F, 0xFF, 0xEE, 0x33, 0xFE,
225
226 0xED, 0x33, 0xFD, 0xEC, 0x33, 0xFC, 0xEB, 0x33, 0xFB, 0x10, 0xD7, 0x03, 0x99, 0x40, 0x04, 0xEB,
227
228 0x99, 0xFB, 0x0F, 0xD8, 0xE5, 0xE4, 0xF9, 0xFA, 0x22, 0x78, 0x18, 0xEF, 0x2F, 0xFF, 0xEE, 0x33,
229
230 0xFE, 0xED, 0x33, 0xFD, 0xEC, 0x33, 0xFC, 0xC9, 0x33, 0xC9, 0x10, 0xD7, 0x05, 0x9B, 0xE9, 0x9A,
231
232 0x40, 0x07, 0xEC, 0x9B, 0xFC, 0xE9, 0x9A, 0xF9, 0x0F, 0xD8, 0xE0, 0xE4, 0xC9, 0xFA, 0xE4, 0xCC,
233
234 0xFB, 0x22, 0x75, 0xF0, 0x10, 0xEF, 0x2F, 0xFF, 0xEE, 0x33, 0xFE, 0xED, 0x33, 0xFD, 0xCC, 0x33,
235
236 0xCC, 0xC8, 0x33, 0xC8, 0x10, 0xD7, 0x07, 0x9B, 0xEC, 0x9A, 0xE8, 0x99, 0x40, 0x0A, 0xED, 0x9B,
237
238 0xFD, 0xEC, 0x9A, 0xFC, 0xE8, 0x99, 0xF8, 0x0F, 0xD5, 0xF0, 0xDA, 0xE4, 0xCD, 0xFB, 0xE4, 0xCC,
239
240 0xFA, 0xE4, 0xC8, 0xF9, 0x22, 0xEB, 0x9F, 0xF5, 0xF0, 0xEA, 0x9E, 0x42, 0xF0, 0xE9, 0x9D, 0x42,
241
242 0xF0, 0xE8, 0x9C, 0x45, 0xF0, 0x22, 0xE8, 0x60, 0x0F, 0xEC, 0xC3, 0x13, 0xFC, 0xED, 0x13, 0xFD,
243
244 0xEE, 0x13, 0xFE, 0xEF, 0x13, 0xFF, 0xD8, 0xF1, 0x22, 0xE8, 0x60, 0x0F, 0xEF, 0xC3, 0x33, 0xFF,
245
246 0xEE, 0x33, 0xFE, 0xED, 0x33, 0xFD, 0xEC, 0x33, 0xFC, 0xD8, 0xF1, 0x22, 0xE4, 0x93, 0xFC, 0x74,
247
248 0x01, 0x93, 0xFD, 0x74, 0x02, 0x93, 0xFE, 0x74, 0x03, 0x93, 0xFF, 0x22, 0xE6, 0xFB, 0x08, 0xE6,
249
250 0xF9, 0x08, 0xE6, 0xFA, 0x08, 0xE6, 0xCB, 0xF8, 0x22, 0xEC, 0xF6, 0x08, 0xED, 0xF6, 0x08, 0xEE,
251
252 0xF6, 0x08, 0xEF, 0xF6, 0x22, 0xA4, 0x25, 0x82, 0xF5, 0x82, 0xE5, 0xF0, 0x35, 0x83, 0xF5, 0x83,
253
254 0x22, 0xD0, 0x83, 0xD0, 0x82, 0xF8, 0xE4, 0x93, 0x70, 0x12, 0x74, 0x01, 0x93, 0x70, 0x0D, 0xA3,
255
256 0xA3, 0x93, 0xF8, 0x74, 0x01, 0x93, 0xF5, 0x82, 0x88, 0x83, 0xE4, 0x73, 0x74, 0x02, 0x93, 0x68,
257
258 0x60, 0xEF, 0xA3, 0xA3, 0xA3, 0x80, 0xDF, 0x90, 0x38, 0x04, 0x78, 0x52, 0x12, 0x0B, 0xFD, 0x90,
259
260 0x38, 0x00, 0xE0, 0xFE, 0xA3, 0xE0, 0xFD, 0xED, 0xFF, 0xC3, 0x12, 0x0B, 0x9E, 0x90, 0x38, 0x10,
261
262 0x12, 0x0B, 0x92, 0x90, 0x38, 0x06, 0x78, 0x54, 0x12, 0x0B, 0xFD, 0x90, 0x38, 0x02, 0xE0, 0xFE,
263
264 0xA3, 0xE0, 0xFD, 0xED, 0xFF, 0xC3, 0x12, 0x0B, 0x9E, 0x90, 0x38, 0x12, 0x12, 0x0B, 0x92, 0xA3,
265
266 0xE0, 0xB4, 0x31, 0x07, 0x78, 0x52, 0x79, 0x52, 0x12, 0x0C, 0x13, 0x90, 0x38, 0x14, 0xE0, 0xB4,
267
268 0x71, 0x15, 0x78, 0x52, 0xE6, 0xFE, 0x08, 0xE6, 0x78, 0x02, 0xCE, 0xC3, 0x13, 0xCE, 0x13, 0xD8,
269
270 0xF9, 0x79, 0x53, 0xF7, 0xEE, 0x19, 0xF7, 0x90, 0x38, 0x15, 0xE0, 0xB4, 0x31, 0x07, 0x78, 0x54,
271
272 0x79, 0x54, 0x12, 0x0C, 0x13, 0x90, 0x38, 0x15, 0xE0, 0xB4, 0x71, 0x15, 0x78, 0x54, 0xE6, 0xFE,
273
274 0x08, 0xE6, 0x78, 0x02, 0xCE, 0xC3, 0x13, 0xCE, 0x13, 0xD8, 0xF9, 0x79, 0x55, 0xF7, 0xEE, 0x19,
275
276 0xF7, 0x79, 0x52, 0x12, 0x0B, 0xD9, 0x09, 0x12, 0x0B, 0xD9, 0xAF, 0x47, 0x12, 0x0B, 0xB2, 0xE5,
277
278 0x44, 0xFB, 0x7A, 0x00, 0xFD, 0x7C, 0x00, 0x12, 0x04, 0xD3, 0x78, 0x5A, 0xA6, 0x06, 0x08, 0xA6,
279
280 0x07, 0xAF, 0x45, 0x12, 0x0B, 0xB2, 0xAD, 0x03, 0x7C, 0x00, 0x12, 0x04, 0xD3, 0x78, 0x56, 0xA6,
281
282 0x06, 0x08, 0xA6, 0x07, 0xAF, 0x48, 0x78, 0x54, 0x12, 0x0B, 0xB4, 0xE5, 0x43, 0xFB, 0xFD, 0x7C,
283
284 0x00, 0x12, 0x04, 0xD3, 0x78, 0x5C, 0xA6, 0x06, 0x08, 0xA6, 0x07, 0xAF, 0x46, 0x7E, 0x00, 0x78,
285
286 0x54, 0x12, 0x0B, 0xB6, 0xAD, 0x03, 0x7C, 0x00, 0x12, 0x04, 0xD3, 0x78, 0x58, 0xA6, 0x06, 0x08,
287
288 0xA6, 0x07, 0xC3, 0x78, 0x5B, 0xE6, 0x94, 0x08, 0x18, 0xE6, 0x94, 0x00, 0x50, 0x05, 0x76, 0x00,
289
290 0x08, 0x76, 0x08, 0xC3, 0x78, 0x5D, 0xE6, 0x94, 0x08, 0x18, 0xE6, 0x94, 0x00, 0x50, 0x05, 0x76,
291
292 0x00, 0x08, 0x76, 0x08, 0x78, 0x5A, 0x12, 0x0B, 0xC6, 0xFF, 0xD3, 0x78, 0x57, 0xE6, 0x9F, 0x18,
293
294 0xE6, 0x9E, 0x40, 0x0E, 0x78, 0x5A, 0xE6, 0x13, 0xFE, 0x08, 0xE6, 0x78, 0x57, 0x12, 0x0C, 0x08,
295
296 0x80, 0x04, 0x7E, 0x00, 0x7F, 0x00, 0x78, 0x5E, 0x12, 0x0B, 0xBE, 0xFF, 0xD3, 0x78, 0x59, 0xE6,
297
298 0x9F, 0x18, 0xE6, 0x9E, 0x40, 0x0E, 0x78, 0x5C, 0xE6, 0x13, 0xFE, 0x08, 0xE6, 0x78, 0x59, 0x12,
299
300 0x0C, 0x08, 0x80, 0x04, 0x7E, 0x00, 0x7F, 0x00, 0xE4, 0xFC, 0xFD, 0x78, 0x62, 0x12, 0x06, 0x99,
301
302 0x78, 0x5A, 0x12, 0x0B, 0xC6, 0x78, 0x57, 0x26, 0xFF, 0xEE, 0x18, 0x36, 0xFE, 0x78, 0x66, 0x12,
303
304 0x0B, 0xBE, 0x78, 0x59, 0x26, 0xFF, 0xEE, 0x18, 0x36, 0xFE, 0xE4, 0xFC, 0xFD, 0x78, 0x6A, 0x12,
305
306 0x06, 0x99, 0x12, 0x0B, 0xCE, 0x78, 0x66, 0x12, 0x06, 0x8C, 0xD3, 0x12, 0x06, 0x45, 0x40, 0x08,
307
308 0x12, 0x0B, 0xCE, 0x78, 0x66, 0x12, 0x06, 0x99, 0x78, 0x54, 0x12, 0x0B, 0xD0, 0x78, 0x6A, 0x12,
309
310 0x06, 0x8C, 0xD3, 0x12, 0x06, 0x45, 0x40, 0x0A, 0x78, 0x54, 0x12, 0x0B, 0xD0, 0x78, 0x6A, 0x12,
311
312 0x06, 0x99, 0x78, 0x61, 0xE6, 0x90, 0x60, 0x01, 0xF0, 0x78, 0x65, 0xE6, 0xA3, 0xF0, 0x78, 0x69,
313
314 0xE6, 0xA3, 0xF0, 0x78, 0x55, 0xE6, 0xA3, 0xF0, 0x7D, 0x01, 0x78, 0x61, 0x12, 0x0B, 0xE9, 0x24,
315
316 0x01, 0x12, 0x0B, 0xA6, 0x78, 0x65, 0x12, 0x0B, 0xE9, 0x24, 0x02, 0x12, 0x0B, 0xA6, 0x78, 0x69,
317
318 0x12, 0x0B, 0xE9, 0x24, 0x03, 0x12, 0x0B, 0xA6, 0x78, 0x6D, 0x12, 0x0B, 0xE9, 0x24, 0x04, 0x12,
319
320 0x0B, 0xA6, 0x0D, 0xBD, 0x05, 0xD4, 0xC2, 0x0E, 0xC2, 0x06, 0x22, 0x85, 0x08, 0x41, 0x90, 0x30,
321
322 0x24, 0xE0, 0xF5, 0x3D, 0xA3, 0xE0, 0xF5, 0x3E, 0xA3, 0xE0, 0xF5, 0x3F, 0xA3, 0xE0, 0xF5, 0x40,
323
324 0xA3, 0xE0, 0xF5, 0x3C, 0xD2, 0x34, 0xE5, 0x41, 0x12, 0x06, 0xB1, 0x09, 0x31, 0x03, 0x09, 0x35,
325
326 0x04, 0x09, 0x3B, 0x05, 0x09, 0x3E, 0x06, 0x09, 0x41, 0x07, 0x09, 0x4A, 0x08, 0x09, 0x5B, 0x12,
327
328 0x09, 0x73, 0x18, 0x09, 0x89, 0x19, 0x09, 0x5E, 0x1A, 0x09, 0x6A, 0x1B, 0x09, 0xAD, 0x80, 0x09,
329
330 0xB2, 0x81, 0x0A, 0x1D, 0x8F, 0x0A, 0x09, 0x90, 0x0A, 0x1D, 0x91, 0x0A, 0x1D, 0x92, 0x0A, 0x1D,
331
332 0x93, 0x0A, 0x1D, 0x94, 0x0A, 0x1D, 0x98, 0x0A, 0x17, 0x9F, 0x0A, 0x1A, 0xEC, 0x00, 0x00, 0x0A,
333
334 0x38, 0x12, 0x0F, 0x74, 0x22, 0x12, 0x0F, 0x74, 0xD2, 0x03, 0x22, 0xD2, 0x03, 0x22, 0xC2, 0x03,
335
336 0x22, 0xA2, 0x37, 0xE4, 0x33, 0xF5, 0x3C, 0x02, 0x0A, 0x1D, 0xC2, 0x01, 0xC2, 0x02, 0xC2, 0x03,
337
338 0x12, 0x0D, 0x0D, 0x75, 0x1E, 0x70, 0xD2, 0x35, 0x02, 0x0A, 0x1D, 0x02, 0x0A, 0x04, 0x85, 0x40,
339
340 0x4A, 0x85, 0x3C, 0x4B, 0x12, 0x0A, 0xFF, 0x02, 0x0A, 0x1D, 0x85, 0x4A, 0x40, 0x85, 0x4B, 0x3C,
341
342 0x02, 0x0A, 0x1D, 0xE4, 0xF5, 0x22, 0xF5, 0x23, 0x85, 0x40, 0x31, 0x85, 0x3F, 0x30, 0x85, 0x3E,
343
344 0x2F, 0x85, 0x3D, 0x2E, 0x12, 0x0F, 0x46, 0x80, 0x1F, 0x75, 0x22, 0x00, 0x75, 0x23, 0x01, 0x74,
345
346 0xFF, 0xF5, 0x2D, 0xF5, 0x2C, 0xF5, 0x2B, 0xF5, 0x2A, 0x12, 0x0F, 0x46, 0x85, 0x2D, 0x40, 0x85,
347
348 0x2C, 0x3F, 0x85, 0x2B, 0x3E, 0x85, 0x2A, 0x3D, 0xE4, 0xF5, 0x3C, 0x80, 0x70, 0x12, 0x0F, 0x16,
349
350 0x80, 0x6B, 0x85, 0x3D, 0x45, 0x85, 0x3E, 0x46, 0xE5, 0x47, 0xC3, 0x13, 0xFF, 0xE5, 0x45, 0xC3,
351
352 0x9F, 0x50, 0x02, 0x8F, 0x45, 0xE5, 0x48, 0xC3, 0x13, 0xFF, 0xE5, 0x46, 0xC3, 0x9F, 0x50, 0x02,
353
354 0x8F, 0x46, 0xE5, 0x47, 0xC3, 0x13, 0xFF, 0xFD, 0xE5, 0x45, 0x2D, 0xFD, 0xE4, 0x33, 0xFC, 0xE5,
355
356 0x44, 0x12, 0x0F, 0x90, 0x40, 0x05, 0xE5, 0x44, 0x9F, 0xF5, 0x45, 0xE5, 0x48, 0xC3, 0x13, 0xFF,
357
358 0xFD, 0xE5, 0x46, 0x2D, 0xFD, 0xE4, 0x33, 0xFC, 0xE5, 0x43, 0x12, 0x0F, 0x90, 0x40, 0x05, 0xE5,
359
360 0x43, 0x9F, 0xF5, 0x46, 0x12, 0x06, 0xD7, 0x80, 0x14, 0x85, 0x40, 0x48, 0x85, 0x3F, 0x47, 0x85,
361
362 0x3E, 0x46, 0x85, 0x3D, 0x45, 0x80, 0x06, 0x02, 0x06, 0xD7, 0x12, 0x0D, 0x7E, 0x90, 0x30, 0x24,
363
364 0xE5, 0x3D, 0xF0, 0xA3, 0xE5, 0x3E, 0xF0, 0xA3, 0xE5, 0x3F, 0xF0, 0xA3, 0xE5, 0x40, 0xF0, 0xA3,
365
366 0xE5, 0x3C, 0xF0, 0x90, 0x30, 0x23, 0xE4, 0xF0, 0x22, 0xC0, 0xE0, 0xC0, 0x83, 0xC0, 0x82, 0xC0,
367
368 0xD0, 0x90, 0x3F, 0x0C, 0xE0, 0xF5, 0x32, 0xE5, 0x32, 0x30, 0xE3, 0x74, 0x30, 0x36, 0x66, 0x90,
369
370 0x60, 0x19, 0xE0, 0xF5, 0x0A, 0xA3, 0xE0, 0xF5, 0x0B, 0x90, 0x60, 0x1D, 0xE0, 0xF5, 0x14, 0xA3,
371
372 0xE0, 0xF5, 0x15, 0x90, 0x60, 0x21, 0xE0, 0xF5, 0x0C, 0xA3, 0xE0, 0xF5, 0x0D, 0x90, 0x60, 0x29,
373
374 0xE0, 0xF5, 0x0E, 0xA3, 0xE0, 0xF5, 0x0F, 0x90, 0x60, 0x31, 0xE0, 0xF5, 0x10, 0xA3, 0xE0, 0xF5,
375
376 0x11, 0x90, 0x60, 0x39, 0xE0, 0xF5, 0x12, 0xA3, 0xE0, 0xF5, 0x13, 0x30, 0x01, 0x06, 0x30, 0x33,
377
378 0x03, 0xD3, 0x80, 0x01, 0xC3, 0x92, 0x09, 0x30, 0x02, 0x06, 0x30, 0x33, 0x03, 0xD3, 0x80, 0x01,
379
380 0xC3, 0x92, 0x0A, 0x30, 0x33, 0x0C, 0x30, 0x03, 0x09, 0x20, 0x02, 0x06, 0x20, 0x01, 0x03, 0xD3,
381
382 0x80, 0x01, 0xC3, 0x92, 0x0B, 0x90, 0x30, 0x01, 0xE0, 0x44, 0x40, 0xF0, 0xE0, 0x54, 0xBF, 0xF0,
383
384 0xE5, 0x32, 0x30, 0xE1, 0x14, 0x30, 0x34, 0x11, 0x90, 0x30, 0x22, 0xE0, 0xF5, 0x08, 0xE4, 0xF0,
385
386 0x30, 0x00, 0x03, 0xD3, 0x80, 0x01, 0xC3, 0x92, 0x08, 0xE5, 0x32, 0x30, 0xE5, 0x12, 0x90, 0x56,
387
388 0xA1, 0xE0, 0xF5, 0x09, 0x30, 0x31, 0x09, 0x30, 0x05, 0x03, 0xD3, 0x80, 0x01, 0xC3, 0x92, 0x0D,
389
390 0x90, 0x3F, 0x0C, 0xE5, 0x32, 0xF0, 0xD0, 0xD0, 0xD0, 0x82, 0xD0, 0x83, 0xD0, 0xE0, 0x32, 0x90,
391
392 0x0E, 0x7E, 0xE4, 0x93, 0xFE, 0x74, 0x01, 0x93, 0xFF, 0xC3, 0x90, 0x0E, 0x7C, 0x74, 0x01, 0x93,
393
394 0x9F, 0xFF, 0xE4, 0x93, 0x9E, 0xFE, 0xE4, 0x8F, 0x3B, 0x8E, 0x3A, 0xF5, 0x39, 0xF5, 0x38, 0xAB,
395
396 0x3B, 0xAA, 0x3A, 0xA9, 0x39, 0xA8, 0x38, 0xAF, 0x4B, 0xFC, 0xFD, 0xFE, 0x12, 0x05, 0x28, 0x12,
397
398 0x0D, 0xE1, 0xE4, 0x7B, 0xFF, 0xFA, 0xF9, 0xF8, 0x12, 0x05, 0xB3, 0x12, 0x0D, 0xE1, 0x90, 0x0E,
399
400 0x69, 0xE4, 0x12, 0x0D, 0xF6, 0x12, 0x0D, 0xE1, 0xE4, 0x85, 0x4A, 0x37, 0xF5, 0x36, 0xF5, 0x35,
401
402 0xF5, 0x34, 0xAF, 0x37, 0xAE, 0x36, 0xAD, 0x35, 0xAC, 0x34, 0xA3, 0x12, 0x0D, 0xF6, 0x8F, 0x37,
403
404 0x8E, 0x36, 0x8D, 0x35, 0x8C, 0x34, 0xE5, 0x3B, 0x45, 0x37, 0xF5, 0x3B, 0xE5, 0x3A, 0x45, 0x36,
405
406 0xF5, 0x3A, 0xE5, 0x39, 0x45, 0x35, 0xF5, 0x39, 0xE5, 0x38, 0x45, 0x34, 0xF5, 0x38, 0xE4, 0xF5,
407
408 0x22, 0xF5, 0x23, 0x85, 0x3B, 0x31, 0x85, 0x3A, 0x30, 0x85, 0x39, 0x2F, 0x85, 0x38, 0x2E, 0x02,
409
410 0x0F, 0x46, 0xE0, 0xA3, 0xE0, 0x75, 0xF0, 0x02, 0xA4, 0xFF, 0xAE, 0xF0, 0xC3, 0x08, 0xE6, 0x9F,
411
412 0xF6, 0x18, 0xE6, 0x9E, 0xF6, 0x22, 0xFF, 0xE5, 0xF0, 0x34, 0x60, 0x8F, 0x82, 0xF5, 0x83, 0xEC,
413
414 0xF0, 0x22, 0x78, 0x52, 0x7E, 0x00, 0xE6, 0xFC, 0x08, 0xE6, 0xFD, 0x02, 0x04, 0xC1, 0xE4, 0xFC,
415
416 0xFD, 0x12, 0x06, 0x99, 0x78, 0x5C, 0xE6, 0xC3, 0x13, 0xFE, 0x08, 0xE6, 0x13, 0x22, 0x78, 0x52,
417
418 0xE6, 0xFE, 0x08, 0xE6, 0xFF, 0xE4, 0xFC, 0xFD, 0x22, 0xE7, 0xC4, 0xF8, 0x54, 0xF0, 0xC8, 0x68,
419
420 0xF7, 0x09, 0xE7, 0xC4, 0x54, 0x0F, 0x48, 0xF7, 0x22, 0xE6, 0xFC, 0xED, 0x75, 0xF0, 0x04, 0xA4,
421
422 0x22, 0x12, 0x06, 0x7C, 0x8F, 0x48, 0x8E, 0x47, 0x8D, 0x46, 0x8C, 0x45, 0x22, 0xE0, 0xFE, 0xA3,
423
424 0xE0, 0xFD, 0xEE, 0xF6, 0xED, 0x08, 0xF6, 0x22, 0x13, 0xFF, 0xC3, 0xE6, 0x9F, 0xFF, 0x18, 0xE6,
425
426 0x9E, 0xFE, 0x22, 0xE6, 0xC3, 0x13, 0xF7, 0x08, 0xE6, 0x13, 0x09, 0xF7, 0x22, 0xAD, 0x39, 0xAC,
427
428 0x38, 0xFA, 0xF9, 0xF8, 0x12, 0x05, 0x28, 0x8F, 0x3B, 0x8E, 0x3A, 0x8D, 0x39, 0x8C, 0x38, 0xAB,
429
430 0x37, 0xAA, 0x36, 0xA9, 0x35, 0xA8, 0x34, 0x22, 0x93, 0xFF, 0xE4, 0xFC, 0xFD, 0xFE, 0x12, 0x05,
431
432 0x28, 0x8F, 0x37, 0x8E, 0x36, 0x8D, 0x35, 0x8C, 0x34, 0x22, 0x78, 0x84, 0xE6, 0xFE, 0x08, 0xE6,
433
434 0xFF, 0xE4, 0x8F, 0x37, 0x8E, 0x36, 0xF5, 0x35, 0xF5, 0x34, 0x22, 0x90, 0x0E, 0x8C, 0xE4, 0x93,
435
436 0x25, 0xE0, 0x24, 0x0A, 0xF8, 0xE6, 0xFE, 0x08, 0xE6, 0xFF, 0x22, 0xE6, 0xFE, 0x08, 0xE6, 0xFF,
437
438 0xE4, 0x8F, 0x3B, 0x8E, 0x3A, 0xF5, 0x39, 0xF5, 0x38, 0x22, 0x78, 0x4E, 0xE6, 0xFE, 0x08, 0xE6,
439
440 0xFF, 0x22, 0xEF, 0x25, 0xE0, 0x24, 0x4E, 0xF8, 0xE6, 0xFC, 0x08, 0xE6, 0xFD, 0x22, 0x78, 0x89,
441
442 0xEF, 0x26, 0xF6, 0x18, 0xE4, 0x36, 0xF6, 0x22, 0x75, 0x89, 0x03, 0x75, 0xA8, 0x01, 0x75, 0xB8,
443
444 0x04, 0x75, 0x34, 0xFF, 0x75, 0x35, 0x0E, 0x75, 0x36, 0x15, 0x75, 0x37, 0x0D, 0x12, 0x0E, 0x9A,
445
446 0x12, 0x00, 0x09, 0x12, 0x0F, 0x16, 0x12, 0x00, 0x06, 0xD2, 0x00, 0xD2, 0x34, 0xD2, 0xAF, 0x75,
447
448 0x34, 0xFF, 0x75, 0x35, 0x0E, 0x75, 0x36, 0x49, 0x75, 0x37, 0x03, 0x12, 0x0E, 0x9A, 0x30, 0x08,
449
450 0x09, 0xC2, 0x34, 0x12, 0x08, 0xCB, 0xC2, 0x08, 0xD2, 0x34, 0x30, 0x0B, 0x09, 0xC2, 0x36, 0x12,
451
452 0x02, 0x6C, 0xC2, 0x0B, 0xD2, 0x36, 0x30, 0x09, 0x09, 0xC2, 0x36, 0x12, 0x00, 0x0E, 0xC2, 0x09,
453
454 0xD2, 0x36, 0x30, 0x0E, 0x03, 0x12, 0x06, 0xD7, 0x30, 0x35, 0xD3, 0x90, 0x30, 0x29, 0xE5, 0x1E,
455
456 0xF0, 0xB4, 0x10, 0x05, 0x90, 0x30, 0x23, 0xE4, 0xF0, 0xC2, 0x35, 0x80, 0xC1, 0xE4, 0xF5, 0x4B,
457
458 0x90, 0x0E, 0x7A, 0x93, 0xFF, 0xE4, 0x8F, 0x37, 0xF5, 0x36, 0xF5, 0x35, 0xF5, 0x34, 0xAF, 0x37,
459
460 0xAE, 0x36, 0xAD, 0x35, 0xAC, 0x34, 0x90, 0x0E, 0x6A, 0x12, 0x0D, 0xF6, 0x8F, 0x37, 0x8E, 0x36,
461
462 0x8D, 0x35, 0x8C, 0x34, 0x90, 0x0E, 0x72, 0x12, 0x06, 0x7C, 0xEF, 0x45, 0x37, 0xF5, 0x37, 0xEE,
463
464 0x45, 0x36, 0xF5, 0x36, 0xED, 0x45, 0x35, 0xF5, 0x35, 0xEC, 0x45, 0x34, 0xF5, 0x34, 0xE4, 0xF5,
465
466 0x22, 0xF5, 0x23, 0x85, 0x37, 0x31, 0x85, 0x36, 0x30, 0x85, 0x35, 0x2F, 0x85, 0x34, 0x2E, 0x12,
467
468 0x0F, 0x46, 0xE4, 0xF5, 0x22, 0xF5, 0x23, 0x90, 0x0E, 0x72, 0x12, 0x0D, 0xEA, 0x12, 0x0F, 0x46,
469
470 0xE4, 0xF5, 0x22, 0xF5, 0x23, 0x90, 0x0E, 0x6E, 0x12, 0x0D, 0xEA, 0x02, 0x0F, 0x46, 0xE5, 0x40,
471
472 0x24, 0xF2, 0xF5, 0x37, 0xE5, 0x3F, 0x34, 0x43, 0xF5, 0x36, 0xE5, 0x3E, 0x34, 0xA2, 0xF5, 0x35,
473
474 0xE5, 0x3D, 0x34, 0x28, 0xF5, 0x34, 0xE5, 0x37, 0xFF, 0xE4, 0xFE, 0xFD, 0xFC, 0x78, 0x18, 0x12,
475
476 0x06, 0x69, 0x8F, 0x40, 0x8E, 0x3F, 0x8D, 0x3E, 0x8C, 0x3D, 0xE5, 0x37, 0x54, 0xA0, 0xFF, 0xE5,
477
478 0x36, 0xFE, 0xE4, 0xFD, 0xFC, 0x78, 0x07, 0x12, 0x06, 0x56, 0x78, 0x10, 0x12, 0x0F, 0x9A, 0xE4,
479
480 0xFF, 0xFE, 0xE5, 0x35, 0xFD, 0xE4, 0xFC, 0x78, 0x0E, 0x12, 0x06, 0x56, 0x12, 0x0F, 0x9D, 0xE4,
481
482 0xFF, 0xFE, 0xFD, 0xE5, 0x34, 0xFC, 0x78, 0x18, 0x12, 0x06, 0x56, 0x78, 0x08, 0x12, 0x0F, 0x9A,
483
484 0x22, 0x8F, 0x3B, 0x8E, 0x3A, 0x8D, 0x39, 0x8C, 0x38, 0x22, 0x12, 0x06, 0x7C, 0x8F, 0x31, 0x8E,
485
486 0x30, 0x8D, 0x2F, 0x8C, 0x2E, 0x22, 0x93, 0xF9, 0xF8, 0x02, 0x06, 0x69, 0x00, 0x00, 0x00, 0x00,
487
488 0x12, 0x01, 0x17, 0x08, 0x31, 0x15, 0x53, 0x54, 0x44, 0x20, 0x20, 0x20, 0x20, 0x20, 0x13, 0x01,
489
490 0x10, 0x01, 0x56, 0x40, 0x1A, 0x30, 0x29, 0x7E, 0x00, 0x30, 0x04, 0x20, 0xDF, 0x30, 0x05, 0x40,
491
492 0xBF, 0x50, 0x03, 0x00, 0xFD, 0x50, 0x27, 0x01, 0xFE, 0x60, 0x00, 0x11, 0x00, 0x3F, 0x05, 0x30,
493
494 0x00, 0x3F, 0x06, 0x22, 0x00, 0x3F, 0x01, 0x2A, 0x00, 0x3F, 0x02, 0x00, 0x00, 0x36, 0x06, 0x07,
495
496 0x00, 0x3F, 0x0B, 0x0F, 0xF0, 0x00, 0x00, 0x00, 0x00, 0x30, 0x01, 0x40, 0xBF, 0x30, 0x01, 0x00,
497
498 0xBF, 0x30, 0x29, 0x70, 0x00, 0x3A, 0x00, 0x00, 0xFF, 0x3A, 0x00, 0x00, 0xFF, 0x36, 0x03, 0x36,
499
500 0x02, 0x41, 0x44, 0x58, 0x20, 0x18, 0x10, 0x0A, 0x04, 0x04, 0x00, 0x03, 0xFF, 0x64, 0x00, 0x00,
501
502 0x80, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x02, 0x04, 0x06, 0x06, 0x00, 0x03, 0x51, 0x00, 0x7A,
503
504 0x50, 0x3C, 0x28, 0x1E, 0x10, 0x10, 0x50, 0x2D, 0x28, 0x16, 0x10, 0x10, 0x02, 0x00, 0x10, 0x0C,
505
506 0x10, 0x04, 0x0C, 0x6E, 0x06, 0x05, 0x00, 0xA5, 0x5A, 0x00, 0xAE, 0x35, 0xAF, 0x36, 0xE4, 0xFD,
507
508 0xED, 0xC3, 0x95, 0x37, 0x50, 0x33, 0x12, 0x0F, 0xE2, 0xE4, 0x93, 0xF5, 0x38, 0x74, 0x01, 0x93,
509
510 0xF5, 0x39, 0x45, 0x38, 0x60, 0x23, 0x85, 0x39, 0x82, 0x85, 0x38, 0x83, 0xE0, 0xFC, 0x12, 0x0F,
511
512 0xE2, 0x74, 0x03, 0x93, 0x52, 0x04, 0x12, 0x0F, 0xE2, 0x74, 0x02, 0x93, 0x42, 0x04, 0x85, 0x39,
513
514 0x82, 0x85, 0x38, 0x83, 0xEC, 0xF0, 0x0D, 0x80, 0xC7, 0x22, 0x78, 0xBE, 0xE6, 0xD3, 0x08, 0xFF,
515
516 0xE6, 0x64, 0x80, 0xF8, 0xEF, 0x64, 0x80, 0x98, 0x22, 0x93, 0xFF, 0x7E, 0x00, 0xE6, 0xFC, 0x08,
517
518 0xE6, 0xFD, 0x12, 0x04, 0xC1, 0x78, 0xC1, 0xE6, 0xFC, 0x08, 0xE6, 0xFD, 0xD3, 0xEF, 0x9D, 0xEE,
519
520 0x9C, 0x22, 0x78, 0xBD, 0xD3, 0xE6, 0x64, 0x80, 0x94, 0x80, 0x22, 0x25, 0xE0, 0x24, 0x0A, 0xF8,
521
522 0xE6, 0xFE, 0x08, 0xE6, 0xFF, 0x22, 0xE5, 0x3C, 0xD3, 0x94, 0x00, 0x40, 0x0B, 0x90, 0x0E, 0x88,
523
524 0x12, 0x0B, 0xF1, 0x90, 0x0E, 0x86, 0x80, 0x09, 0x90, 0x0E, 0x82, 0x12, 0x0B, 0xF1, 0x90, 0x0E,
525
526 0x80, 0xE4, 0x93, 0xF5, 0x44, 0xA3, 0xE4, 0x93, 0xF5, 0x43, 0xD2, 0x06, 0x30, 0x06, 0x03, 0xD3,
527
528 0x80, 0x01, 0xC3, 0x92, 0x0E, 0x22, 0xA2, 0xAF, 0x92, 0x32, 0xC2, 0xAF, 0xE5, 0x23, 0x45, 0x22,
529
530 0x90, 0x0E, 0x5D, 0x60, 0x0E, 0x12, 0x0F, 0xCB, 0xE0, 0xF5, 0x2C, 0x12, 0x0F, 0xC8, 0xE0, 0xF5,
531
532 0x2D, 0x80, 0x0C, 0x12, 0x0F, 0xCB, 0xE5, 0x30, 0xF0, 0x12, 0x0F, 0xC8, 0xE5, 0x31, 0xF0, 0xA2,
533
534 0x32, 0x92, 0xAF, 0x22, 0xD2, 0x01, 0xC2, 0x02, 0xE4, 0xF5, 0x1F, 0xF5, 0x1E, 0xD2, 0x35, 0xD2,
535
536 0x33, 0xD2, 0x36, 0xD2, 0x01, 0xC2, 0x02, 0xF5, 0x1F, 0xF5, 0x1E, 0xD2, 0x35, 0xD2, 0x33, 0x22,
537
538 0xFB, 0xD3, 0xED, 0x9B, 0x74, 0x80, 0xF8, 0x6C, 0x98, 0x22, 0x12, 0x06, 0x69, 0xE5, 0x40, 0x2F,
539
540 0xF5, 0x40, 0xE5, 0x3F, 0x3E, 0xF5, 0x3F, 0xE5, 0x3E, 0x3D, 0xF5, 0x3E, 0xE5, 0x3D, 0x3C, 0xF5,
541
542 0x3D, 0x22, 0xC0, 0xE0, 0xC0, 0x83, 0xC0, 0x82, 0x90, 0x3F, 0x0D, 0xE0, 0xF5, 0x33, 0xE5, 0x33,
543
544 0xF0, 0xD0, 0x82, 0xD0, 0x83, 0xD0, 0xE0, 0x32, 0x90, 0x0E, 0x5F, 0xE4, 0x93, 0xFE, 0x74, 0x01,
545
546 0x93, 0xF5, 0x82, 0x8E, 0x83, 0x22, 0x78, 0x7F, 0xE4, 0xF6, 0xD8, 0xFD, 0x75, 0x81, 0xCD, 0x02,
547
548 0x0C, 0x98, 0x8F, 0x82, 0x8E, 0x83, 0x75, 0xF0, 0x04, 0xED, 0x02, 0x06, 0xA5,
549
550};
551
560#endif
OV5640_AF_Config
const unsigned char OV5640_AF_Config[]
Definition: at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640af.h:38


AT32F435/437 Firmwary Library: ov5640cfg.h File Reference

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • ov5640
Variables
at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h File Reference

header file of ov5640cfg program More...

#include "ov5640.h"

Go to the source code of this file.

Variables

const uint16_t | OV5640_jpeg_reg_tbl [][2]
const uint16_t | ov5640_rgb565_reg_tbl [][2]
const uint16_t | ov5640_uxga_init_reg_tbl [][2]

Detailed Description

header file of ov5640cfg program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h.


AT32F435/437 Firmwary Library: ov5640cfg.h Source File

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • ov5640
at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h
Go to the documentation of this file.
1
27#ifndef _OV5640CFG_H
28#define _OV5640CFG_H
29#include "ov5640.h"
30
39const uint16_t OV5640_jpeg_reg_tbl[][2] =
40{
41 0x4300, 0x30, /* yuv 422, yuyv */
42 0x501f, 0x00, /* yuv 422 */
43
44 /* input clock = 24mhz */
45 0x3035, 0x81, /* pll */
46 0x3036, 0x69, /* pll */
47 0x3c07, 0x07, /* lightmeter 1 threshold[7:0] */
48 0x3820, 0x46, /* flip */
49 0x3821, 0x20, /* mirror */
50 0x3814, 0x11, /* timing x inc */
51 0x3815, 0x11, /* timing y inc */
52 0x3800, 0x00, /* hs */
53 0x3801, 0x00, /* hs */
54 0x3802, 0x00, /* vs */
55 0x3803, 0x00, /* vs */
56 0x3804, 0x0a, /* hw (he) */
57 0x3805, 0x3f, /* hw (he) */
58 0x3806, 0x07, /* vh (ve) */
59 0x3807, 0x9f, /* vh (ve) */
60
61 0x3808, 0x02, /* dvpho */
62 0x3809, 0x80, /* dvpho */
63 0x380a, 0x01, /* dvpvo */
64 0x380b, 0xe0, /* dvpvo */
65
66 0x380c, 0x0b, /* hts */
67 0x380d, 0x1c, /* hts */
68 0x380e, 0x07, /* vts */
69 0x380f, 0xb0, /* vts */
70 0x3813, 0x04, /* timing v offset 04 */
71 0x3618, 0x04,
72 0x3612, 0x2b,
73 0x3709, 0x12,
74 0x370c, 0x00,
75
76 0x4004, 0x06, /* blc line number */
77 0x3002, 0x00, /* enable jfifo, sfifo, jpg */
78 0x3006, 0xff, /* enable clock of jpeg2x, jpeg */
79 0x4713, 0x03, /* jpeg mode 3 */
80 0x4407, 0x01, /* quantization sacle */
81 0x460b, 0x35,
82 0x460c, 0x22,
83 0x4837, 0x16, /* mipi global timing */
84 0x3824, 0x02, /* pclk manual divider */
85 0x5001, 0xA3, /* sde on, scaling on, cmx on, awb on */
86 0x3503, 0x00, /* aec/agc on */
87};
88
89const uint16_t ov5640_rgb565_reg_tbl[][2] =
90{
91 0x4300, 0x6F,
92 0x501F, 0x01,
93 /* 1280x800, 15fps */
94 /* input clock 24mhz, pclk 42mhz */
95 0x3035, 0x21, /* pll */
96 0x3036, 0x69, /* pll */
97 0x3c07, 0x07, /* lightmeter 1 threshold[7:0] */
98 0x3820, 0x46, /* flip */
99 0x3821, 0x00, /* mirror */
100 0x3814, 0x31, /* timing x inc */
101 0x3815, 0x31, /* timing y inc */
102 0x3800, 0x00, /* hs */
103 0x3801, 0x00, /* hs */
104 0x3802, 0x00, /* vs */
105 0x3803, 0x00, /* vs */
106 0x3804, 0x0a, /* hw (he) */
107 0x3805, 0x3f, /* hw (he) */
108 0x3806, 0x06, /* vh (ve) */
109 0x3807, 0xa9, /* vh (ve) */
110 0x3808, 0x05, /* dvpho */
111 0x3809, 0x00, /* dvpho */
112 0x380a, 0x02, /* dvpvo */
113 0x380b, 0xd0, /* dvpvo */
114 0x380c, 0x05, /* hts */
115 0x380d, 0xF8, /* hts */
116 0x380e, 0x03, /* vts */
117 0x380f, 0x84, /* vts */
118 0x3813, 0x04, /* timing v offset */
119 0x3618, 0x00,
120 0x3612, 0x29,
121 0x3709, 0x52,
122 0x370c, 0x03,
123 0x3a02, 0x02, /* 60hz max exposure */
124 0x3a03, 0xe0, /* 60hz max exposure */
125
126 0x3a14, 0x02, /* 50hz max exposure */
127 0x3a15, 0xe0, /* 50hz max exposure */
128 0x4004, 0x02, /* blc line number */
129 0x3002, 0x1c, /* reset jfifo, sfifo, jpg */
130 0x3006, 0xc3, /* disable clock of jpeg2x, jpeg */
131 0x4713, 0x03, /* jpeg mode 3 */
132 0x4407, 0x04, /* quantization scale */
133 0x460b, 0x37,
134 0x460c, 0x20,
135 0x4837, 0x16, /* mipi global timing */
136 0x3824, 0x04, /* pclk manual divider */
137 0x5001, 0xA3, /* sde on, scale on, uv average off, color matrix on, awb on */
138 0x3503, 0x00, /* aec/agc on */
139
140#ifdef EMBEDDED_MODE
141 /* embedded code configer */
142 0x471b, 0x00, /* hsync mode enable */
143 0x4719, 0x01, /* ccir656 eav/sav option */
144 0x4715, 0x00, /* 0x0f ccir656 dummy line number at beginning of the frame */
145 0x4730, 0x61, /* ccir656 mode */
146
147 0x4732, 0x01, /* sync code frame start */
148 0x4733, 0x0F, /* sync code frame end */
149 0x4734, 0x10, /* sync code line start */
150 0x4735, 0xF0, /* sync code line end */
151#endif
152};
153
154const uint16_t ov5640_uxga_init_reg_tbl[][2] =
155{
156 /* 24MHz input clock, 24MHz PCLK */
157 0x3008, 0x42, /* software power down, bit[6] */
158 0x3103, 0x03, /* system clock from pll, bit[1] */
159 0x3017, 0xff, /* frex, vsync, href, pclk, d[9:6] output enable */
160 0x3018, 0xff, /* d[5:0], gpio[1:0] output enable */
161 0x3034, 0x1a, /* mipi 10-bit */
162 0x3037, 0x13, /* pll root divider, bit[4], pll pre-divider, bit[3:0] */
163 0x3108, 0x01, /* pclk root divider, bit[5:4], sclk2x root divider, bit[3:2] */
164
165 /* sclk root divider, bit[1:0] */
166 0x3630, 0x36,
167 0x3631, 0x0e,
168 0x3632, 0xe2,
169 0x3633, 0x12,
170 0x3621, 0xe0,
171 0x3704, 0xa0,
172 0x3703, 0x5a,
173 0x3715, 0x78,
174 0x3717, 0x01,
175 0x370b, 0x60,
176 0x3705, 0x1a,
177 0x3905, 0x02,
178 0x3906, 0x10,
179 0x3901, 0x0a,
180 0x3731, 0x12,
181 0x3600, 0x08, /* vcm control */
182 0x3601, 0x33, /* vcm control */
183 0x302d, 0x60, /* system control */
184 0x3620, 0x52,
185 0x371b, 0x20,
186 0x471c, 0x50,
187 0x3a13, 0x43, /* pre-gain = 1.047x */
188 0x3a18, 0x00, /* gain ceiling */
189 0x3a19, 0xf8, /* gain ceiling = 15.5x */
190 0x3635, 0x13,
191 0x3636, 0x03,
192 0x3634, 0x40,
193 0x3622, 0x01,
194 0x3c01, 0x34, /* band auto, bit[7] */
195 0x3c04, 0x28, /* threshold low sum */
196 0x3c05, 0x98, /* threshold high sum */
197 0x3c06, 0x00, /* light meter 1 threshold[15:8] */
198 0x3c07, 0x08, /* light meter 1 threshold[7:0] */
199 0x3c08, 0x00, /* light meter 2 threshold[15:8] */
200 0x3c09, 0x1c, /* light meter 2 threshold[7:0] */
201 0x3c0a, 0x9c, /* sample number[15:8] */
202 0x3c0b, 0x40, /* sample number[7:0] */
203 0x3810, 0x00, /* timing hoffset[11:8] */
204 0x3811, 0x10, /* timing hoffset[7:0] */
205 0x3812, 0x00, /* timing voffset[10:8] */
206 0x3708, 0x64,
207 0x4001, 0x02, /* blc start from line 2 */
208 0x4005, 0x1a, /* blc always update */
209 0x3000, 0x00, /* enable blocks */
210 0x3004, 0xff, /* enable clocks */
211 0x300e, 0x58, /* mipi power down, dvp enable */
212 0x302e, 0x00,
213 0x4300, 0x30, /* yuv 422, yuyv */
214 0x501f, 0x00, /* yuv 422 */
215 0x440e, 0x00,
216 0x5000, 0xa7, /* lenc on, raw gamma on, bpc on, wpc on, cip on */
217
218 0x3a0f, 0x30, /* stable range in high */
219 0x3a10, 0x28, /* stable range in low */
220 0x3a1b, 0x30, /* stable range out high */
221 0x3a1e, 0x26, /* stable range out low */
222 0x3a11, 0x60, /* fast zone high */
223 0x3a1f, 0x14, /* fast zone low */
224
225 0x5800, 0x23,
226 0x5801, 0x14,
227 0x5802, 0x0f,
228 0x5803, 0x0f,
229 0x5804, 0x12,
230 0x5805, 0x26,
231 0x5806, 0x0c,
232 0x5807, 0x08,
233 0x5808, 0x05,
234 0x5809, 0x05,
235 0x580a, 0x08,
236
237 0x580b, 0x0d,
238 0x580c, 0x08,
239 0x580d, 0x03,
240 0x580e, 0x00,
241 0x580f, 0x00,
242 0x5810, 0x03,
243 0x5811, 0x09,
244 0x5812, 0x07,
245 0x5813, 0x03,
246 0x5814, 0x00,
247 0x5815, 0x01,
248 0x5816, 0x03,
249 0x5817, 0x08,
250 0x5818, 0x0d,
251 0x5819, 0x08,
252 0x581a, 0x05,
253 0x581b, 0x06,
254 0x581c, 0x08,
255 0x581d, 0x0e,
256 0x581e, 0x29,
257 0x581f, 0x17,
258 0x5820, 0x11,
259 0x5821, 0x11,
260 0x5822, 0x15,
261 0x5823, 0x28,
262 0x5824, 0x46,
263 0x5825, 0x26,
264 0x5826, 0x08,
265 0x5827, 0x26,
266 0x5828, 0x64,
267 0x5829, 0x26,
268 0x582a, 0x24,
269 0x582b, 0x22,
270 0x582c, 0x24,
271 0x582d, 0x24,
272 0x582e, 0x06,
273 0x582f, 0x22,
274 0x5830, 0x40,
275 0x5831, 0x42,
276 0x5832, 0x24,
277 0x5833, 0x26,
278 0x5834, 0x24,
279 0x5835, 0x22,
280 0x5836, 0x22,
281 0x5837, 0x26,
282 0x5838, 0x44,
283 0x5839, 0x24,
284 0x583a, 0x26,
285 0x583b, 0x28,
286 0x583c, 0x42,
287 0x583d, 0xce, /* lenc br offset */
288
289 0x5180, 0xff, /* awb b block */
290 0x5181, 0xf2, /* awb control */
291 0x5182, 0x00, /* [7:4] max local counter, [3:0] max fast counter */
292 0x5183, 0x14, /* awb advanced */
293 0x5184, 0x25,
294 0x5185, 0x24,
295 0x5186, 0x09,
296 0x5187, 0x09,
297 0x5188, 0x09,
298 0x5189, 0x75,
299 0x518a, 0x54,
300 0x518b, 0xe0,
301 0x518c, 0xb2,
302 0x518d, 0x42,
303 0x518e, 0x3d,
304 0x518f, 0x56,
305 0x5190, 0x46,
306 0x5191, 0xf8, /* awb top limit */
307 0x5192, 0x04, /* awb bottom limit */
308 0x5193, 0x70, /* red limit */
309 0x5194, 0xf0, /* green limit */
310 0x5195, 0xf0, /* blue limit */
311 0x5196, 0x03, /* awb control */
312 0x5197, 0x01, /* local limit */
313 0x5198, 0x04,
314 0x5199, 0x12,
315 0x519a, 0x04,
316 0x519b, 0x00,
317 0x519c, 0x06,
318 0x519d, 0x82,
319 0x519e, 0x38, /* awb control */
320
321 0x5480, 0x01, /* gamma bias plus on, bit[0] */
322 0x5481, 0x08,
323 0x5482, 0x14,
324 0x5483, 0x28,
325 0x5484, 0x51,
326 0x5485, 0x65,
327 0x5486, 0x71,
328 0x5487, 0x7d,
329 0x5488, 0x87,
330 0x5489, 0x91,
331 0x548a, 0x9a,
332 0x548b, 0xaa,
333 0x548c, 0xb8,
334 0x548d, 0xcd,
335 0x548e, 0xdd,
336 0x548f, 0xea,
337 0x5490, 0x1d,
338
339 0x5381, 0x1e, /* cmx1 for y */
340 0x5382, 0x5b, /* cmx2 for y */
341 0x5383, 0x08, /* cmx3 for y */
342 0x5384, 0x0a, /* cmx4 for u */
343 0x5385, 0x7e, /* cmx5 for u */
344 0x5386, 0x88, /* cmx6 for u */
345 0x5387, 0x7c, /* cmx7 for v */
346 0x5388, 0x6c, /* cmx8 for v */
347 0x5389, 0x10, /* cmx9 for v */
348 0x538a, 0x01, /* sign[9] */
349 0x538b, 0x98, /* sign[8:1] */
350
351 0x5580, 0x06, /* saturation on, bit[1] */
352 0x5583, 0x40,
353 0x5584, 0x10,
354 0x5589, 0x10,
355 0x558a, 0x00,
356 0x558b, 0xf8,
357 0x501d, 0x40, /* enable manual offset of contrast */
358
359 0x5300, 0x08, /* cip sharpen mt threshold 1 */
360 0x5301, 0x30, /* cip sharpen mt threshold 2 */
361 0x5302, 0x10, /* cip sharpen mt offset 1 */
362 0x5303, 0x00, /* cip sharpen mt offset 2 */
363 0x5304, 0x08, /* cip dns threshold 1 */
364 0x5305, 0x30, /* cip dns threshold 2 */
365 0x5306, 0x08, /* cip dns offset 1 */
366 0x5307, 0x16, /* cip dns offset 2 */
367 0x5309, 0x08, /* cip sharpen th threshold 1 */
368 0x530a, 0x30, /* cip sharpen th threshold 2 */
369 0x530b, 0x04, /* cip sharpen th offset 1 */
370 0x530c, 0x06, /* cip sharpen th offset 2 */
371 0x5025, 0x00,
372 0x4740, 0x23, /* vsync high */
373 0x3008, 0x02, /* wake up from standby, bit[6] */
374
375};
376
385#endif
ov5640.h
ov5640_rgb565_reg_tbl
const uint16_t ov5640_rgb565_reg_tbl[][2]
Definition: at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h:89
ov5640_uxga_init_reg_tbl
const uint16_t ov5640_uxga_init_reg_tbl[][2]
Definition: at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h:154
OV5640_jpeg_reg_tbl
const uint16_t OV5640_jpeg_reg_tbl[][2]
Definition: at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h:39


AT32F435/437 Firmwary Library: qspi_cmd_esmt32m.c File Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_dma
  • src
Macros | Functions | Variables
at_start_f437/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c File Reference

qspi_cmd_esmt32m program More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define FLASH_PAGE_PROGRAM_SIZE 256

Functions

void | qspi_busy_check (void)
qspi check busy More...
void | qspi_write_enable (void)
qspi write enable More...
void | esmt32m_cmd_read_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config More...
void | esmt32m_cmd_write_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config More...
void | esmt32m_cmd_erase_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config More...
void | esmt32m_cmd_wren_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config More...
void | esmt32m_cmd_rdsr_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config More...
void | qspi_dma_set (dma_dir_type dir, uint8_t *buf, uint32_t length)
qspi dma set More...
void | qspi_data_read (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data More...
static void | qspi_data_once_write (uint32_t addr, uint32_t sz, uint8_t *buf)
qspi write data for one time More...
void | qspi_data_write (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data More...
void | qspi_erase (uint32_t sec_addr)
qspi erase data More...

Variables

qspi_cmd_type esmt32m_cmd_config

Detailed Description

qspi_cmd_esmt32m program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c.

Function Documentation

◆ qspi_data_once_write()

static void qspi_data_once_write | ( | uint32_t | addr,
 |  | uint32_t | sz,
 |  | uint8_t * | buf
 | ) |  |
static

qspi write data for one time

Parameters
addr | the address for write
sz | the length for write
buf | the pointer for write data
Return values
none

Definition at line 222 of file at_start_f437/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c.


AT32F435/437 Firmwary Library: qspi_cmd_esmt32m.c Source File

  • at_start_f437
  • examples
  • qspi
  • command_port_using_dma
  • src
at_start_f437/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28
37#define FLASH_PAGE_PROGRAM_SIZE 256
38
39 qspi_cmd_type esmt32m_cmd_config;
40
41void qspi_busy_check(void);
42void qspi_write_enable(void);
43
51void esmt32m_cmd_read_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
52{
53 qspi_cmd_struct->pe_mode_enable = FALSE;
54 qspi_cmd_struct->pe_mode_operate_code = 0;
55 qspi_cmd_struct->instruction_code = 0xEB;
56 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
57 qspi_cmd_struct->address_code = addr;
58 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
59 qspi_cmd_struct->data_counter = counter;
60 qspi_cmd_struct->second_dummy_cycle_num = 6;
61 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_144;
62 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
63 qspi_cmd_struct->read_status_enable = FALSE;
64 qspi_cmd_struct->write_data_enable = FALSE;
65}
66
74void esmt32m_cmd_write_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
75{
76 qspi_cmd_struct->pe_mode_enable = FALSE;
77 qspi_cmd_struct->pe_mode_operate_code = 0;
78 qspi_cmd_struct->instruction_code = 0x32;
79 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
80 qspi_cmd_struct->address_code = addr;
81 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
82 qspi_cmd_struct->data_counter = counter;
83 qspi_cmd_struct->second_dummy_cycle_num = 0;
84 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_114;
85 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
86 qspi_cmd_struct->read_status_enable = FALSE;
87 qspi_cmd_struct->write_data_enable = TRUE;
88}
89
96void esmt32m_cmd_erase_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
97{
98 qspi_cmd_struct->pe_mode_enable = FALSE;
99 qspi_cmd_struct->pe_mode_operate_code = 0;
100 qspi_cmd_struct->instruction_code = 0x20;
101 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
102 qspi_cmd_struct->address_code = addr;
103 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
104 qspi_cmd_struct->data_counter = 0;
105 qspi_cmd_struct->second_dummy_cycle_num = 0;
106 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
107 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
108 qspi_cmd_struct->read_status_enable = FALSE;
109 qspi_cmd_struct->write_data_enable = TRUE;
110}
111
117void esmt32m_cmd_wren_config(qspi_cmd_type *qspi_cmd_struct)
118{
119 qspi_cmd_struct->pe_mode_enable = FALSE;
120 qspi_cmd_struct->pe_mode_operate_code = 0;
121 qspi_cmd_struct->instruction_code = 0x06;
122 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
123 qspi_cmd_struct->address_code = 0;
124 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
125 qspi_cmd_struct->data_counter = 0;
126 qspi_cmd_struct->second_dummy_cycle_num = 0;
127 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
128 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
129 qspi_cmd_struct->read_status_enable = FALSE;
130 qspi_cmd_struct->write_data_enable = TRUE;
131}
132
138void esmt32m_cmd_rdsr_config(qspi_cmd_type *qspi_cmd_struct)
139{
140 qspi_cmd_struct->pe_mode_enable = FALSE;
141 qspi_cmd_struct->pe_mode_operate_code = 0;
142 qspi_cmd_struct->instruction_code = 0x05;
143 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
144 qspi_cmd_struct->address_code = 0;
145 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
146 qspi_cmd_struct->data_counter = 0;
147 qspi_cmd_struct->second_dummy_cycle_num = 0;
148 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
149 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
150 qspi_cmd_struct->read_status_enable = TRUE;
151 qspi_cmd_struct->write_data_enable = FALSE;
152}
153
161void qspi_dma_set(dma_dir_type dir, uint8_t* buf, uint32_t length)
162{
163 dma_init_type dma_init_struct;
164 dma_reset(DMA2_CHANNEL1);
165 dma_default_para_init(&dma_init_struct);
166 dma_init_struct.buffer_size = length / 4; /* using word unit */
167 dma_init_struct.loop_mode_enable = FALSE;
168 dma_init_struct.direction = dir;
169 dma_init_struct.memory_base_addr = (uint32_t)buf;
170 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_WORD;
171 dma_init_struct.memory_inc_enable = TRUE;
172 dma_init_struct.peripheral_base_addr = (uint32_t)(&(QSPI1->dt));
173 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_WORD;
174 dma_init_struct.peripheral_inc_enable = FALSE;
175 dma_init_struct.priority = DMA_PRIORITY_HIGH;
176
177 dma_init(DMA2_CHANNEL1, &dma_init_struct);
178
179 dmamux_init(DMA2MUX_CHANNEL1, DMAMUX_DMAREQ_ID_QSPI1);
180 dmamux_enable(DMA2, TRUE);
181
182 dma_channel_enable(DMA2_CHANNEL1, TRUE);
183}
184
192void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t* buf)
193{
194 /* config qspi's dma mode */
195 qspi_dma_enable(QSPI1, TRUE);
196 qspi_dma_rx_threshold_set(QSPI1, QSPI_DMA_FIFO_THOD_WORD08);
197
198 /* config and enable dma */
199 qspi_dma_set(DMA_DIR_PERIPHERAL_TO_MEMORY, buf, total_len);
200
201 /* kick command */
202 esmt32m_cmd_read_config(&esmt32m_cmd_config, addr, total_len);
203 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
204
205 /* wait command completed */
206 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
207 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
208
209 /* wait dma completed */
210 while(dma_flag_get(DMA2_FDT1_FLAG) == RESET);
211 dma_flag_clear(DMA2_FDT1_FLAG);
212 qspi_dma_enable(QSPI1, FALSE);
213}
214
222static void qspi_data_once_write(uint32_t addr, uint32_t sz, uint8_t* buf)
223{
224 qspi_write_enable();
225
226 /* config qspi's dma mode */
227 qspi_dma_enable(QSPI1, TRUE);
228 qspi_dma_tx_threshold_set(QSPI1, QSPI_DMA_FIFO_THOD_WORD08);
229
230 /* config and enable dma */
231 qspi_dma_set(DMA_DIR_MEMORY_TO_PERIPHERAL, buf, sz);
232
233 /* kick command */
234 esmt32m_cmd_write_config(&esmt32m_cmd_config, addr, sz);
235 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
236
237 /* wait command completed */
238 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
239 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
240
241 /* wait dma completed */
242 while(dma_flag_get(DMA2_FDT1_FLAG) == RESET);
243 dma_flag_clear(DMA2_FDT1_FLAG);
244 qspi_dma_enable(QSPI1, FALSE);
245
246 qspi_busy_check();
247}
248
256void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t* buf)
257{
258 uint32_t blk_sz;
259 do
260 { /* send up to 256 bytes at one time */
261 if(total_len > FLASH_PAGE_PROGRAM_SIZE)
262 {
263 blk_sz = FLASH_PAGE_PROGRAM_SIZE;
264 }
265 else
266 {
267 blk_sz = total_len;
268 }
269 qspi_data_once_write(addr, blk_sz, buf);
270 addr += blk_sz;
271 buf += blk_sz;
272 total_len -= blk_sz;
273 }while(total_len > 0);
274}
275
281void qspi_erase(uint32_t sec_addr)
282{
283 qspi_write_enable();
284
285 esmt32m_cmd_erase_config(&esmt32m_cmd_config, sec_addr);
286 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
287
288 /* wait command completed */
289 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
290 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
291
292 qspi_busy_check();
293}
294
300void qspi_busy_check(void)
301{
302 esmt32m_cmd_rdsr_config(&esmt32m_cmd_config);
303 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
304
305 /* wait command completed */
306 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
307 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
308}
309
315void qspi_write_enable(void)
316{
317 esmt32m_cmd_wren_config(&esmt32m_cmd_config);
318 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
319
320 /* wait command completed */
321 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
322 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
323}
324
at32f435_437_board.h
qspi_data_once_write
static void qspi_data_once_write(uint32_t addr, uint32_t sz, uint8_t *buf)
qspi write data for one time
Definition: at_start_f437/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:222
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
counter
uint16_t counter
Definition: project/at_start_f435/examples/debug/tmr1/src/main.c:39
qspi_dma_set
void qspi_dma_set(dma_dir_type dir, uint8_t *buf, uint32_t length)
qspi dma set
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:161
qspi_busy_check
void qspi_busy_check(void)
qspi check busy
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:300
esmt32m_cmd_wren_config
void esmt32m_cmd_wren_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:117
qspi_erase
void qspi_erase(uint32_t sec_addr)
qspi erase data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:281
esmt32m_cmd_erase_config
void esmt32m_cmd_erase_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:96
FLASH_PAGE_PROGRAM_SIZE
#define FLASH_PAGE_PROGRAM_SIZE
Definition: at_start_f437/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:37
qspi_write_enable
void qspi_write_enable(void)
qspi write enable
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:315
qspi_data_read
void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:192
qspi_data_write
void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:256
esmt32m_cmd_config
qspi_cmd_type esmt32m_cmd_config
Definition: at_start_f437/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:39
esmt32m_cmd_read_config
void esmt32m_cmd_read_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:51
esmt32m_cmd_write_config
void esmt32m_cmd_write_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:74
esmt32m_cmd_rdsr_config
void esmt32m_cmd_rdsr_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:138
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f435_437_dma.h:151
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:164
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:174
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_QSPI1
@ DMAMUX_DMAREQ_ID_QSPI1
Definition: at32f435_437_dma.h:240
DMA2_FDT1_FLAG
#define DMA2_FDT1_FLAG
Definition: at32f435_437_dma.h:95
DMA2MUX_CHANNEL1
#define DMA2MUX_CHANNEL1
Definition: at32f435_437_dma.h:726
DMA2
#define DMA2
Definition: at32f435_437_dma.h:717
DMA2_CHANNEL1
#define DMA2_CHANNEL1
Definition: at32f435_437_dma.h:718
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
qspi_flag_clear
void qspi_flag_clear(qspi_type *qspi_x, uint32_t flag)
clear flags
Definition: at32f435_437_qspi.c:168
qspi_dma_enable
void qspi_dma_enable(qspi_type *qspi_x, confirm_state new_state)
enable/disable dma transfer
Definition: at32f435_437_qspi.c:218
qspi_dma_tx_threshold_set
void qspi_dma_tx_threshold_set(qspi_type *qspi_x, qspi_dma_fifo_thod_type new_threshold)
set dma threshold for dma tx
Definition: at32f435_437_qspi.c:204
qspi_dma_rx_threshold_set
void qspi_dma_rx_threshold_set(qspi_type *qspi_x, qspi_dma_fifo_thod_type new_threshold)
set dma threshold for dma rx
Definition: at32f435_437_qspi.c:186
qspi_cmd_operation_kick
void qspi_cmd_operation_kick(qspi_type *qspi_x, qspi_cmd_type *qspi_cmd_struct)
set command-port and qspi_x will start to work
Definition: at32f435_437_qspi.c:292
qspi_flag_get
flag_status qspi_flag_get(qspi_type *qspi_x, uint32_t flag)
get status flags.
Definition: at32f435_437_qspi.c:138
QSPI_RSTSC_HW_AUTO
@ QSPI_RSTSC_HW_AUTO
Definition: at32f435_437_qspi.h:102
QSPI_CMD_INSLEN_1_BYTE
@ QSPI_CMD_INSLEN_1_BYTE
Definition: at32f435_437_qspi.h:153
QSPI_DMA_FIFO_THOD_WORD08
@ QSPI_DMA_FIFO_THOD_WORD08
Definition: at32f435_437_qspi.h:180
QSPI_OPERATE_MODE_144
@ QSPI_OPERATE_MODE_144
Definition: at32f435_437_qspi.h:115
QSPI_OPERATE_MODE_111
@ QSPI_OPERATE_MODE_111
Definition: at32f435_437_qspi.h:111
QSPI_OPERATE_MODE_114
@ QSPI_OPERATE_MODE_114
Definition: at32f435_437_qspi.h:113
QSPI_CMD_ADRLEN_0_BYTE
@ QSPI_CMD_ADRLEN_0_BYTE
Definition: at32f435_437_qspi.h:140
QSPI_CMD_ADRLEN_3_BYTE
@ QSPI_CMD_ADRLEN_3_BYTE
Definition: at32f435_437_qspi.h:143
QSPI_CMDSTS_FLAG
#define QSPI_CMDSTS_FLAG
Definition: at32f435_437_qspi.h:52
QSPI1
#define QSPI1
Definition: at32f435_437_qspi.h:512
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
qspi_cmd_type
qspi cmd type
Definition: at32f435_437_qspi.h:189
qspi_cmd_type::instruction_length
qspi_cmd_inslen_type instruction_length
Definition: at32f435_437_qspi.h:193
qspi_cmd_type::write_data_enable
confirm_state write_data_enable
Definition: at32f435_437_qspi.h:201
qspi_cmd_type::operation_mode
qspi_operate_mode_type operation_mode
Definition: at32f435_437_qspi.h:198
qspi_cmd_type::instruction_code
uint8_t instruction_code
Definition: at32f435_437_qspi.h:192
qspi_cmd_type::read_status_config
qspi_read_status_conf_type read_status_config
Definition: at32f435_437_qspi.h:199
qspi_cmd_type::pe_mode_enable
confirm_state pe_mode_enable
Definition: at32f435_437_qspi.h:190
qspi_cmd_type::read_status_enable
confirm_state read_status_enable
Definition: at32f435_437_qspi.h:200
qspi_cmd_type::data_counter
uint32_t data_counter
Definition: at32f435_437_qspi.h:196
qspi_cmd_type::address_code
uint32_t address_code
Definition: at32f435_437_qspi.h:194
qspi_cmd_type::pe_mode_operate_code
uint8_t pe_mode_operate_code
Definition: at32f435_437_qspi.h:191
qspi_cmd_type::address_length
qspi_cmd_adrlen_type address_length
Definition: at32f435_437_qspi.h:195
qspi_cmd_type::second_dummy_cycle_num
uint8_t second_dummy_cycle_num
Definition: at32f435_437_qspi.h:197


AT32F435/437 Firmwary Library: qspi_cmd_esmt32m.c File Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_dma_and_pem
  • src
Macros | Enumerations | Functions | Variables
at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c File Reference

qspi_cmd_esmt32m program More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | FLASH_PAGE_PROGRAM_SIZE 256
#define | PEMOPC_SET 0xA5
#define | PEMOPC_RESET 0xFF

Enumerations

enum pem_step_type {
PEM_STEP_BEGIN , PEM_STEP_KEEP , PEM_STEP_END , PEM_STEP_BEGIN ,
PEM_STEP_KEEP , PEM_STEP_END
}

Functions

void | qspi_busy_check (void)
qspi check busy More...
void | qspi_write_enable (void)
qspi write enable More...
void | esmt32m_cmd_read_pem_begin_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read pem begin config More...
void | esmt32m_cmd_read_pem_keep_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read pem keep config More...
void | esmt32m_cmd_read_pem_end_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read pem end config More...
void | esmt32m_cmd_write_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config More...
void | esmt32m_cmd_erase_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config More...
void | esmt32m_cmd_wren_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config More...
void | esmt32m_cmd_rdsr_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config More...
void | qspi_dma_set (dma_dir_type dir, uint8_t *buf, uint32_t length)
qspi dma set More...
void | qspi_read_data_using_pem (pem_step_type pem_step, uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data using pem More...
void | qspi_data_read (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data More...
static void | qspi_data_once_write (uint32_t addr, uint32_t sz, uint8_t *buf)
qspi write data for one time More...
void | qspi_data_write (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data More...
void | qspi_erase (uint32_t sec_addr)
qspi erase data More...

Variables

qspi_cmd_type esmt32m_cmd_config

Detailed Description

qspi_cmd_esmt32m program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.

Function Documentation

◆ qspi_data_once_write()

static void qspi_data_once_write | ( | uint32_t | addr,
 |  | uint32_t | sz,
 |  | uint8_t * | buf
 | ) |  |
static

qspi write data for one time

Parameters
addr | the address for write
sz | the length for write
buf | the pointer for write data
Return values
none

Definition at line 314 of file at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c.


AT32F435/437 Firmwary Library: qspi_cmd_esmt32m.c Source File

  • at_start_f437
  • examples
  • qspi
  • command_port_using_dma_and_pem
  • src
at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28
37#define FLASH_PAGE_PROGRAM_SIZE 256
38#define PEMOPC_SET 0xA5
39#define PEMOPC_RESET 0xFF
40
41typedef enum
42{
43 PEM_STEP_BEGIN,
44 PEM_STEP_KEEP,
45 PEM_STEP_END
46}pem_step_type;
47
48 qspi_cmd_type esmt32m_cmd_config;
49
50void qspi_busy_check(void);
51void qspi_write_enable(void);
52
60void esmt32m_cmd_read_pem_begin_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
61{
62 qspi_cmd_struct->pe_mode_enable = TRUE;
63 qspi_cmd_struct->pe_mode_operate_code = PEMOPC_SET;
64 qspi_cmd_struct->instruction_code = 0xEB;
65 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
66 qspi_cmd_struct->address_code = addr;
67 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
68 qspi_cmd_struct->data_counter = counter;
69 qspi_cmd_struct->second_dummy_cycle_num = 4;
70 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_144;
71 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
72 qspi_cmd_struct->read_status_enable = FALSE;
73 qspi_cmd_struct->write_data_enable = FALSE;
74}
75
83void esmt32m_cmd_read_pem_keep_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
84{
85 qspi_cmd_struct->pe_mode_enable = TRUE;
86 qspi_cmd_struct->pe_mode_operate_code = PEMOPC_SET;
87 qspi_cmd_struct->instruction_code = 0xEB;
88 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_0_BYTE;
89 qspi_cmd_struct->address_code = addr;
90 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
91 qspi_cmd_struct->data_counter = counter;
92 qspi_cmd_struct->second_dummy_cycle_num = 4;
93 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_144;
94 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
95 qspi_cmd_struct->read_status_enable = FALSE;
96 qspi_cmd_struct->write_data_enable = FALSE;
97}
98
106void esmt32m_cmd_read_pem_end_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
107{
108 qspi_cmd_struct->pe_mode_enable = TRUE;
109 qspi_cmd_struct->pe_mode_operate_code = PEMOPC_RESET;
110 qspi_cmd_struct->instruction_code = 0xEB;
111 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_0_BYTE;
112 qspi_cmd_struct->address_code = addr;
113 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
114 qspi_cmd_struct->data_counter = counter;
115 qspi_cmd_struct->second_dummy_cycle_num = 4;
116 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_144;
117 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
118 qspi_cmd_struct->read_status_enable = FALSE;
119 qspi_cmd_struct->write_data_enable = FALSE;
120}
121
129void esmt32m_cmd_write_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
130{
131 qspi_cmd_struct->pe_mode_enable = FALSE;
132 qspi_cmd_struct->pe_mode_operate_code = 0;
133 qspi_cmd_struct->instruction_code = 0x32;
134 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
135 qspi_cmd_struct->address_code = addr;
136 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
137 qspi_cmd_struct->data_counter = counter;
138 qspi_cmd_struct->second_dummy_cycle_num = 0;
139 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_114;
140 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
141 qspi_cmd_struct->read_status_enable = FALSE;
142 qspi_cmd_struct->write_data_enable = TRUE;
143}
144
151void esmt32m_cmd_erase_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
152{
153 qspi_cmd_struct->pe_mode_enable = FALSE;
154 qspi_cmd_struct->pe_mode_operate_code = 0;
155 qspi_cmd_struct->instruction_code = 0x20;
156 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
157 qspi_cmd_struct->address_code = addr;
158 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
159 qspi_cmd_struct->data_counter = 0;
160 qspi_cmd_struct->second_dummy_cycle_num = 0;
161 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
162 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
163 qspi_cmd_struct->read_status_enable = FALSE;
164 qspi_cmd_struct->write_data_enable = TRUE;
165}
166
172void esmt32m_cmd_wren_config(qspi_cmd_type *qspi_cmd_struct)
173{
174 qspi_cmd_struct->pe_mode_enable = FALSE;
175 qspi_cmd_struct->pe_mode_operate_code = 0;
176 qspi_cmd_struct->instruction_code = 0x06;
177 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
178 qspi_cmd_struct->address_code = 0;
179 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
180 qspi_cmd_struct->data_counter = 0;
181 qspi_cmd_struct->second_dummy_cycle_num = 0;
182 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
183 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
184 qspi_cmd_struct->read_status_enable = FALSE;
185 qspi_cmd_struct->write_data_enable = TRUE;
186}
187
193void esmt32m_cmd_rdsr_config(qspi_cmd_type *qspi_cmd_struct)
194{
195 qspi_cmd_struct->pe_mode_enable = FALSE;
196 qspi_cmd_struct->pe_mode_operate_code = 0;
197 qspi_cmd_struct->instruction_code = 0x05;
198 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
199 qspi_cmd_struct->address_code = 0;
200 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
201 qspi_cmd_struct->data_counter = 0;
202 qspi_cmd_struct->second_dummy_cycle_num = 0;
203 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
204 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
205 qspi_cmd_struct->read_status_enable = TRUE;
206 qspi_cmd_struct->write_data_enable = FALSE;
207}
208
216void qspi_dma_set(dma_dir_type dir, uint8_t* buf, uint32_t length)
217{
218 dma_init_type dma_init_struct;
219 dma_reset(DMA2_CHANNEL1);
220 dma_default_para_init(&dma_init_struct);
221 dma_init_struct.buffer_size = length / 4; /* using word unit */
222 dma_init_struct.loop_mode_enable = FALSE;
223 dma_init_struct.direction = dir;
224 dma_init_struct.memory_base_addr = (uint32_t)buf;
225 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_WORD;
226 dma_init_struct.memory_inc_enable = TRUE;
227 dma_init_struct.peripheral_base_addr = (uint32_t)(&(QSPI1->dt));
228 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_WORD;
229 dma_init_struct.peripheral_inc_enable = FALSE;
230 dma_init_struct.priority = DMA_PRIORITY_HIGH;
231
232 dma_init(DMA2_CHANNEL1, &dma_init_struct);
233
234 dmamux_init(DMA2MUX_CHANNEL1, DMAMUX_DMAREQ_ID_QSPI1);
235 dmamux_enable(DMA2, TRUE);
236
237 dma_channel_enable(DMA2_CHANNEL1, TRUE);
238}
239
248void qspi_read_data_using_pem(pem_step_type pem_step, uint32_t addr, uint32_t total_len, uint8_t* buf)
249{
250 qspi_dma_enable(QSPI1, TRUE);
251 qspi_dma_rx_threshold_set(QSPI1, QSPI_DMA_FIFO_THOD_WORD08);
252 /* config dma */
253 qspi_dma_set(DMA_DIR_PERIPHERAL_TO_MEMORY, buf, total_len);
254 /* kick command */
255 if(pem_step == PEM_STEP_BEGIN)
256 {
257 esmt32m_cmd_read_pem_begin_config(&esmt32m_cmd_config, addr, total_len);
258 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
259 }
260 else if(pem_step == PEM_STEP_KEEP)
261 {
262 esmt32m_cmd_read_pem_keep_config(&esmt32m_cmd_config, addr, total_len);
263 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
264 }
265 else if(pem_step == PEM_STEP_END)
266 {
267 esmt32m_cmd_read_pem_end_config(&esmt32m_cmd_config, addr, total_len);
268 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
269 }
270
271 /* wait command completed */
272 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
273 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
274
275 /* wait dma completed */
276 while(dma_flag_get(DMA2_FDT1_FLAG) == RESET);
277 dma_flag_clear(DMA2_FDT1_FLAG);
278 qspi_dma_enable(QSPI1, FALSE);
279}
280
288void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t* buf)
289{
290 uint32_t rdsz = sizeof(uint32_t); /* dma transfer must word aligning */
291 /* fist phase */
292 qspi_read_data_using_pem(PEM_STEP_BEGIN, addr, rdsz, buf);
293 addr += rdsz;
294 buf += rdsz;
295 total_len -= rdsz;
296
297 /* keep phase */
298 qspi_read_data_using_pem(PEM_STEP_KEEP, addr, rdsz, buf);
299 addr += rdsz;
300 buf += rdsz;
301 total_len -= rdsz;
302
303 /* last phase */
304 qspi_read_data_using_pem(PEM_STEP_END, addr, total_len, buf);
305}
306
314static void qspi_data_once_write(uint32_t addr, uint32_t sz, uint8_t* buf)
315{
316 qspi_write_enable();
317
318 /* config qspi's dma mode */
319 qspi_dma_enable(QSPI1, TRUE);
320 qspi_dma_tx_threshold_set(QSPI1, QSPI_DMA_FIFO_THOD_WORD08);
321
322 /* config and enable dma */
323 qspi_dma_set(DMA_DIR_MEMORY_TO_PERIPHERAL, buf, sz);
324
325 /* kick command */
326 esmt32m_cmd_write_config(&esmt32m_cmd_config, addr, sz);
327 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
328
329 /* wait command completed */
330 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
331 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
332
333 /* wait dma completed */
334 while(dma_flag_get(DMA2_FDT1_FLAG) == RESET);
335 dma_flag_clear(DMA2_FDT1_FLAG);
336 qspi_dma_enable(QSPI1, FALSE);
337
338 qspi_busy_check();
339}
340
348void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t* buf)
349{
350 uint32_t blk_sz;
351 do
352 { /* send up to 256 bytes at one time */
353 if(total_len > FLASH_PAGE_PROGRAM_SIZE)
354 {
355 blk_sz = FLASH_PAGE_PROGRAM_SIZE;
356 }
357 else
358 {
359 blk_sz = total_len;
360 }
361 qspi_data_once_write(addr, blk_sz, buf);
362 addr += blk_sz;
363 buf += blk_sz;
364 total_len -= blk_sz;
365 }while(total_len > 0);
366}
367
373void qspi_erase(uint32_t sec_addr)
374{
375 qspi_write_enable();
376
377 esmt32m_cmd_erase_config(&esmt32m_cmd_config, sec_addr);
378 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
379
380 /* wait command completed */
381 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
382 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
383
384 qspi_busy_check();
385}
386
392void qspi_busy_check(void)
393{
394 esmt32m_cmd_rdsr_config(&esmt32m_cmd_config);
395 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
396
397 /* wait command completed */
398 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
399 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
400}
401
407void qspi_write_enable(void)
408{
409 esmt32m_cmd_wren_config(&esmt32m_cmd_config);
410 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
411
412 /* wait command completed */
413 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
414 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
415}
416
at32f435_437_board.h
qspi_data_once_write
static void qspi_data_once_write(uint32_t addr, uint32_t sz, uint8_t *buf)
qspi write data for one time
Definition: at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:314
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
counter
uint16_t counter
Definition: project/at_start_f435/examples/debug/tmr1/src/main.c:39
PEMOPC_SET
#define PEMOPC_SET
Definition: at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:38
pem_step_type
pem_step_type
Definition: at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:42
esmt32m_cmd_read_pem_keep_config
void esmt32m_cmd_read_pem_keep_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read pem keep config
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:83
esmt32m_cmd_read_pem_end_config
void esmt32m_cmd_read_pem_end_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read pem end config
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:106
qspi_read_data_using_pem
void qspi_read_data_using_pem(pem_step_type pem_step, uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data using pem
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:248
FLASH_PAGE_PROGRAM_SIZE
#define FLASH_PAGE_PROGRAM_SIZE
Definition: at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:37
esmt32m_cmd_read_pem_begin_config
void esmt32m_cmd_read_pem_begin_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read pem begin config
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:60
esmt32m_cmd_config
qspi_cmd_type esmt32m_cmd_config
Definition: at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:48
PEMOPC_RESET
#define PEMOPC_RESET
Definition: at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:39
PEM_STEP_BEGIN
@ PEM_STEP_BEGIN
Definition: at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:43
PEM_STEP_KEEP
@ PEM_STEP_KEEP
Definition: at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:44
PEM_STEP_END
@ PEM_STEP_END
Definition: at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:45
qspi_dma_set
void qspi_dma_set(dma_dir_type dir, uint8_t *buf, uint32_t length)
qspi dma set
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:161
qspi_busy_check
void qspi_busy_check(void)
qspi check busy
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:300
esmt32m_cmd_wren_config
void esmt32m_cmd_wren_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:117
qspi_erase
void qspi_erase(uint32_t sec_addr)
qspi erase data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:281
esmt32m_cmd_erase_config
void esmt32m_cmd_erase_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:96
qspi_write_enable
void qspi_write_enable(void)
qspi write enable
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:315
qspi_data_read
void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:192
qspi_data_write
void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:256
esmt32m_cmd_write_config
void esmt32m_cmd_write_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:74
esmt32m_cmd_rdsr_config
void esmt32m_cmd_rdsr_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:138
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f435_437_dma.h:151
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:164
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:174
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_QSPI1
@ DMAMUX_DMAREQ_ID_QSPI1
Definition: at32f435_437_dma.h:240
DMA2_FDT1_FLAG
#define DMA2_FDT1_FLAG
Definition: at32f435_437_dma.h:95
DMA2MUX_CHANNEL1
#define DMA2MUX_CHANNEL1
Definition: at32f435_437_dma.h:726
DMA2
#define DMA2
Definition: at32f435_437_dma.h:717
DMA2_CHANNEL1
#define DMA2_CHANNEL1
Definition: at32f435_437_dma.h:718
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
qspi_flag_clear
void qspi_flag_clear(qspi_type *qspi_x, uint32_t flag)
clear flags
Definition: at32f435_437_qspi.c:168
qspi_dma_enable
void qspi_dma_enable(qspi_type *qspi_x, confirm_state new_state)
enable/disable dma transfer
Definition: at32f435_437_qspi.c:218
qspi_dma_tx_threshold_set
void qspi_dma_tx_threshold_set(qspi_type *qspi_x, qspi_dma_fifo_thod_type new_threshold)
set dma threshold for dma tx
Definition: at32f435_437_qspi.c:204
qspi_dma_rx_threshold_set
void qspi_dma_rx_threshold_set(qspi_type *qspi_x, qspi_dma_fifo_thod_type new_threshold)
set dma threshold for dma rx
Definition: at32f435_437_qspi.c:186
qspi_cmd_operation_kick
void qspi_cmd_operation_kick(qspi_type *qspi_x, qspi_cmd_type *qspi_cmd_struct)
set command-port and qspi_x will start to work
Definition: at32f435_437_qspi.c:292
qspi_flag_get
flag_status qspi_flag_get(qspi_type *qspi_x, uint32_t flag)
get status flags.
Definition: at32f435_437_qspi.c:138
QSPI_RSTSC_HW_AUTO
@ QSPI_RSTSC_HW_AUTO
Definition: at32f435_437_qspi.h:102
QSPI_CMD_INSLEN_1_BYTE
@ QSPI_CMD_INSLEN_1_BYTE
Definition: at32f435_437_qspi.h:153
QSPI_CMD_INSLEN_0_BYTE
@ QSPI_CMD_INSLEN_0_BYTE
Definition: at32f435_437_qspi.h:152
QSPI_DMA_FIFO_THOD_WORD08
@ QSPI_DMA_FIFO_THOD_WORD08
Definition: at32f435_437_qspi.h:180
QSPI_OPERATE_MODE_144
@ QSPI_OPERATE_MODE_144
Definition: at32f435_437_qspi.h:115
QSPI_OPERATE_MODE_111
@ QSPI_OPERATE_MODE_111
Definition: at32f435_437_qspi.h:111
QSPI_OPERATE_MODE_114
@ QSPI_OPERATE_MODE_114
Definition: at32f435_437_qspi.h:113
QSPI_CMD_ADRLEN_0_BYTE
@ QSPI_CMD_ADRLEN_0_BYTE
Definition: at32f435_437_qspi.h:140
QSPI_CMD_ADRLEN_3_BYTE
@ QSPI_CMD_ADRLEN_3_BYTE
Definition: at32f435_437_qspi.h:143
QSPI_CMDSTS_FLAG
#define QSPI_CMDSTS_FLAG
Definition: at32f435_437_qspi.h:52
QSPI1
#define QSPI1
Definition: at32f435_437_qspi.h:512
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
qspi_cmd_type
qspi cmd type
Definition: at32f435_437_qspi.h:189
qspi_cmd_type::instruction_length
qspi_cmd_inslen_type instruction_length
Definition: at32f435_437_qspi.h:193
qspi_cmd_type::write_data_enable
confirm_state write_data_enable
Definition: at32f435_437_qspi.h:201
qspi_cmd_type::operation_mode
qspi_operate_mode_type operation_mode
Definition: at32f435_437_qspi.h:198
qspi_cmd_type::instruction_code
uint8_t instruction_code
Definition: at32f435_437_qspi.h:192
qspi_cmd_type::read_status_config
qspi_read_status_conf_type read_status_config
Definition: at32f435_437_qspi.h:199
qspi_cmd_type::pe_mode_enable
confirm_state pe_mode_enable
Definition: at32f435_437_qspi.h:190
qspi_cmd_type::read_status_enable
confirm_state read_status_enable
Definition: at32f435_437_qspi.h:200
qspi_cmd_type::data_counter
uint32_t data_counter
Definition: at32f435_437_qspi.h:196
qspi_cmd_type::address_code
uint32_t address_code
Definition: at32f435_437_qspi.h:194
qspi_cmd_type::pe_mode_operate_code
uint8_t pe_mode_operate_code
Definition: at32f435_437_qspi.h:191
qspi_cmd_type::address_length
qspi_cmd_adrlen_type address_length
Definition: at32f435_437_qspi.h:195
qspi_cmd_type::second_dummy_cycle_num
uint8_t second_dummy_cycle_num
Definition: at32f435_437_qspi.h:197


AT32F435/437 Firmwary Library: qspi_cmd_esmt32m.c File Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
  • src
Macros | Functions | Variables
at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c File Reference

qspi_cmd_esmt32m program More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define FLASH_PAGE_PROGRAM_SIZE 256

Functions

void | qspi_busy_check (void)
qspi check busy More...
void | qspi_write_enable (void)
qspi write enable More...
void | esmt32m_cmd_read_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config More...
void | esmt32m_cmd_write_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config More...
void | esmt32m_cmd_erase_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config More...
void | esmt32m_cmd_wren_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config More...
void | esmt32m_cmd_rdsr_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config More...
void | qspi_dma_set (dma_dir_type dir, uint8_t *buf, uint32_t length)
qspi dma set More...
void | qspi_data_read (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data More...
static void | qspi_data_once_write (uint32_t addr, uint32_t sz, uint8_t *buf)
qspi write data for one time More...
void | qspi_data_write (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data More...
void | qspi_erase (uint32_t sec_addr)
qspi erase data More...
void | esmt32m_cmd_qpien_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd qpi enter config More...
void | esmt32m_cmd_rstqpi_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rstqpi config More...
void | esmt32m_cmd_rsten_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rst config More...
void | esmt32m_cmd_rst_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rst config More...
void | esmt32m_cmd_send (qspi_cmd_type *cmd)
esmt32m cmd kick and wait completed More...
void | esmt32m_qpi_mode_init (void)
switch QSPI to cmd port and setup to qpi mode More...

Variables

qspi_cmd_type esmt32m_cmd_config

Detailed Description

qspi_cmd_esmt32m program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.

Function Documentation

◆ qspi_data_once_write()

static void qspi_data_once_write | ( | uint32_t | addr,
 |  | uint32_t | sz,
 |  | uint8_t * | buf
 | ) |  |
static

qspi write data for one time

Parameters
addr | the address for write
sz | the length for write
buf | the pointer for write data
Return values
none

Definition at line 222 of file at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c.


AT32F435/437 Firmwary Library: qspi_cmd_esmt32m.c Source File

  • at_start_f437
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
  • src
at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28
37#define FLASH_PAGE_PROGRAM_SIZE 256
38
39 qspi_cmd_type esmt32m_cmd_config;
40
41void qspi_busy_check(void);
42void qspi_write_enable(void);
43
51void esmt32m_cmd_read_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
52{
53 qspi_cmd_struct->pe_mode_enable = FALSE;
54 qspi_cmd_struct->pe_mode_operate_code = 0;
55 qspi_cmd_struct->instruction_code = 0xEB;
56 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
57 qspi_cmd_struct->address_code = addr;
58 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
59 qspi_cmd_struct->data_counter = counter;
60 qspi_cmd_struct->second_dummy_cycle_num = 6;
61 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_444;
62 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
63 qspi_cmd_struct->read_status_enable = FALSE;
64 qspi_cmd_struct->write_data_enable = FALSE;
65}
66
74void esmt32m_cmd_write_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
75{
76 qspi_cmd_struct->pe_mode_enable = FALSE;
77 qspi_cmd_struct->pe_mode_operate_code = 0;
78 qspi_cmd_struct->instruction_code = 0x2;
79 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
80 qspi_cmd_struct->address_code = addr;
81 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
82 qspi_cmd_struct->data_counter = counter;
83 qspi_cmd_struct->second_dummy_cycle_num = 0;
84 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_444;
85 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
86 qspi_cmd_struct->read_status_enable = FALSE;
87 qspi_cmd_struct->write_data_enable = TRUE;
88}
89
96void esmt32m_cmd_erase_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
97{
98 qspi_cmd_struct->pe_mode_enable = FALSE;
99 qspi_cmd_struct->pe_mode_operate_code = 0;
100 qspi_cmd_struct->instruction_code = 0x20;
101 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
102 qspi_cmd_struct->address_code = addr;
103 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
104 qspi_cmd_struct->data_counter = 0;
105 qspi_cmd_struct->second_dummy_cycle_num = 0;
106 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_444;
107 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
108 qspi_cmd_struct->read_status_enable = FALSE;
109 qspi_cmd_struct->write_data_enable = TRUE;
110}
111
117void esmt32m_cmd_wren_config(qspi_cmd_type *qspi_cmd_struct)
118{
119 qspi_cmd_struct->pe_mode_enable = FALSE;
120 qspi_cmd_struct->pe_mode_operate_code = 0;
121 qspi_cmd_struct->instruction_code = 0x06;
122 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
123 qspi_cmd_struct->address_code = 0;
124 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
125 qspi_cmd_struct->data_counter = 0;
126 qspi_cmd_struct->second_dummy_cycle_num = 0;
127 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_444;
128 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
129 qspi_cmd_struct->read_status_enable = FALSE;
130 qspi_cmd_struct->write_data_enable = TRUE;
131}
132
138void esmt32m_cmd_rdsr_config(qspi_cmd_type *qspi_cmd_struct)
139{
140 qspi_cmd_struct->pe_mode_enable = FALSE;
141 qspi_cmd_struct->pe_mode_operate_code = 0;
142 qspi_cmd_struct->instruction_code = 0x05;
143 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
144 qspi_cmd_struct->address_code = 0;
145 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
146 qspi_cmd_struct->data_counter = 0;
147 qspi_cmd_struct->second_dummy_cycle_num = 0;
148 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_444;
149 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
150 qspi_cmd_struct->read_status_enable = TRUE;
151 qspi_cmd_struct->write_data_enable = FALSE;
152}
153
161void qspi_dma_set(dma_dir_type dir, uint8_t* buf, uint32_t length)
162{
163 dma_init_type dma_init_struct;
164 dma_reset(DMA2_CHANNEL1);
165 dma_default_para_init(&dma_init_struct);
166 dma_init_struct.buffer_size = length / 4; /* using word unit */
167 dma_init_struct.loop_mode_enable = FALSE;
168 dma_init_struct.direction = dir;
169 dma_init_struct.memory_base_addr = (uint32_t)buf;
170 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_WORD;
171 dma_init_struct.memory_inc_enable = TRUE;
172 dma_init_struct.peripheral_base_addr = (uint32_t)(&(QSPI1->dt));
173 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_WORD;
174 dma_init_struct.peripheral_inc_enable = FALSE;
175 dma_init_struct.priority = DMA_PRIORITY_HIGH;
176
177 dma_init(DMA2_CHANNEL1, &dma_init_struct);
178
179 dmamux_init(DMA2MUX_CHANNEL1, DMAMUX_DMAREQ_ID_QSPI1);
180 dmamux_enable(DMA2, TRUE);
181
182 dma_channel_enable(DMA2_CHANNEL1, TRUE);
183}
184
192void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t* buf)
193{
194 /* config qspi's dma mode */
195 qspi_dma_enable(QSPI1, TRUE);
196 qspi_dma_rx_threshold_set(QSPI1, QSPI_DMA_FIFO_THOD_WORD08);
197
198 /* config and enable dma */
199 qspi_dma_set(DMA_DIR_PERIPHERAL_TO_MEMORY, buf, total_len);
200
201 /* kick command */
202 esmt32m_cmd_read_config(&esmt32m_cmd_config, addr, total_len);
203 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
204
205 /* wait command completed */
206 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
207 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
208
209 /* wait dma completed */
210 while(dma_flag_get(DMA2_FDT1_FLAG) == RESET);
211 dma_flag_clear(DMA2_FDT1_FLAG);
212 qspi_dma_enable(QSPI1, FALSE);
213}
214
222static void qspi_data_once_write(uint32_t addr, uint32_t sz, uint8_t* buf)
223{
224 qspi_write_enable();
225
226 /* config qspi's dma mode */
227 qspi_dma_enable(QSPI1, TRUE);
228 qspi_dma_tx_threshold_set(QSPI1, QSPI_DMA_FIFO_THOD_WORD08);
229
230 /* config and enable dma */
231 qspi_dma_set(DMA_DIR_MEMORY_TO_PERIPHERAL, buf, sz);
232
233 /* kick command */
234 esmt32m_cmd_write_config(&esmt32m_cmd_config, addr, sz);
235 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
236
237 /* wait command completed */
238 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
239 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
240
241 /* wait dma completed */
242 while(dma_flag_get(DMA2_FDT1_FLAG) == RESET);
243 dma_flag_clear(DMA2_FDT1_FLAG);
244 qspi_dma_enable(QSPI1, FALSE);
245
246 qspi_busy_check();
247}
248
256void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t* buf)
257{
258 uint32_t blk_sz;
259 do
260 { /* send up to 256 bytes at one time */
261 if(total_len > FLASH_PAGE_PROGRAM_SIZE)
262 {
263 blk_sz = FLASH_PAGE_PROGRAM_SIZE;
264 }
265 else
266 {
267 blk_sz = total_len;
268 }
269 qspi_data_once_write(addr, blk_sz, buf);
270 addr += blk_sz;
271 buf += blk_sz;
272 total_len -= blk_sz;
273 }while(total_len > 0);
274}
275
281void qspi_erase(uint32_t sec_addr)
282{
283 qspi_write_enable();
284
285 esmt32m_cmd_erase_config(&esmt32m_cmd_config, sec_addr);
286 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
287
288 /* wait command completed */
289 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
290 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
291
292 qspi_busy_check();
293}
294
300void qspi_busy_check(void)
301{
302 esmt32m_cmd_rdsr_config(&esmt32m_cmd_config);
303 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
304
305 /* wait command completed */
306 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
307 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
308}
309
315void qspi_write_enable(void)
316{
317 esmt32m_cmd_wren_config(&esmt32m_cmd_config);
318 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
319
320 /* wait command completed */
321 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
322 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
323}
324
330void esmt32m_cmd_qpien_config(qspi_cmd_type *qspi_cmd_struct)
331{
332 qspi_cmd_struct->pe_mode_enable = FALSE;
333 qspi_cmd_struct->pe_mode_operate_code = 0;
334 qspi_cmd_struct->instruction_code = 0x38;
335 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
336 qspi_cmd_struct->address_code = 0;
337 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
338 qspi_cmd_struct->data_counter = 0;
339 qspi_cmd_struct->second_dummy_cycle_num = 0;
340 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
341 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
342 qspi_cmd_struct->read_status_enable = FALSE;
343 qspi_cmd_struct->write_data_enable = TRUE;
344}
345
351void esmt32m_cmd_rstqpi_config(qspi_cmd_type *qspi_cmd_struct)
352{
353 qspi_cmd_struct->pe_mode_enable = FALSE;
354 qspi_cmd_struct->pe_mode_operate_code = 0;
355 qspi_cmd_struct->instruction_code = 0xFF;
356 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
357 qspi_cmd_struct->address_code = 0;
358 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
359 qspi_cmd_struct->data_counter = 0;
360 qspi_cmd_struct->second_dummy_cycle_num = 0;
361 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_444;
362 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
363 qspi_cmd_struct->read_status_enable = FALSE;
364 qspi_cmd_struct->write_data_enable = TRUE;
365}
366
372void esmt32m_cmd_rsten_config(qspi_cmd_type *qspi_cmd_struct)
373{
374 qspi_cmd_struct->pe_mode_enable = FALSE;
375 qspi_cmd_struct->pe_mode_operate_code = 0;
376 qspi_cmd_struct->instruction_code = 0x66;
377 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
378 qspi_cmd_struct->address_code = 0;
379 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
380 qspi_cmd_struct->data_counter = 0;
381 qspi_cmd_struct->second_dummy_cycle_num = 0;
382 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
383 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
384 qspi_cmd_struct->read_status_enable = FALSE;
385 qspi_cmd_struct->write_data_enable = TRUE;
386}
387
393void esmt32m_cmd_rst_config(qspi_cmd_type *qspi_cmd_struct)
394{
395 qspi_cmd_struct->pe_mode_enable = FALSE;
396 qspi_cmd_struct->pe_mode_operate_code = 0;
397 qspi_cmd_struct->instruction_code = 0x99;
398 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
399 qspi_cmd_struct->address_code = 0;
400 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
401 qspi_cmd_struct->data_counter = 0;
402 qspi_cmd_struct->second_dummy_cycle_num = 0;
403 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
404 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
405 qspi_cmd_struct->read_status_enable = FALSE;
406 qspi_cmd_struct->write_data_enable = TRUE;
407}
408
414void esmt32m_cmd_send(qspi_cmd_type* cmd)
415{
416 qspi_cmd_operation_kick(QSPI1, cmd);
417 /* wait command completed */
418 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
419 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
420}
421
427void esmt32m_qpi_mode_init(void)
428{
429 /* reset qpi */
430 esmt32m_cmd_rstqpi_config(&esmt32m_cmd_config);
431 esmt32m_cmd_send(&esmt32m_cmd_config);
432
433 /* system reset */
434 esmt32m_cmd_rsten_config(&esmt32m_cmd_config);
435 esmt32m_cmd_send(&esmt32m_cmd_config);
436 esmt32m_cmd_rst_config(&esmt32m_cmd_config);
437 esmt32m_cmd_send(&esmt32m_cmd_config);
438
439 /* once the reset command is accepted by the device, the device will
440 take some time to reset. esmt32m will take about 28us in worst case.
441 user can set delay or check wip status */
442 delay_us(30);
443
444 esmt32m_cmd_qpien_config(&esmt32m_cmd_config);
445 esmt32m_cmd_send(&esmt32m_cmd_config);
446}
447
at32f435_437_board.h
qspi_data_once_write
static void qspi_data_once_write(uint32_t addr, uint32_t sz, uint8_t *buf)
qspi write data for one time
Definition: at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:222
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
counter
uint16_t counter
Definition: project/at_start_f435/examples/debug/tmr1/src/main.c:39
esmt32m_cmd_qpien_config
void esmt32m_cmd_qpien_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd qpi enter config
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:330
esmt32m_cmd_rst_config
void esmt32m_cmd_rst_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rst config
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:393
esmt32m_cmd_send
void esmt32m_cmd_send(qspi_cmd_type *cmd)
esmt32m cmd kick and wait completed
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:414
esmt32m_cmd_rstqpi_config
void esmt32m_cmd_rstqpi_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rstqpi config
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:351
FLASH_PAGE_PROGRAM_SIZE
#define FLASH_PAGE_PROGRAM_SIZE
Definition: at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:37
esmt32m_cmd_config
qspi_cmd_type esmt32m_cmd_config
Definition: at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:39
esmt32m_cmd_rsten_config
void esmt32m_cmd_rsten_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rst config
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:372
esmt32m_qpi_mode_init
void esmt32m_qpi_mode_init(void)
switch QSPI to cmd port and setup to qpi mode
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:427
qspi_dma_set
void qspi_dma_set(dma_dir_type dir, uint8_t *buf, uint32_t length)
qspi dma set
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:161
qspi_busy_check
void qspi_busy_check(void)
qspi check busy
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:300
esmt32m_cmd_wren_config
void esmt32m_cmd_wren_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:117
qspi_erase
void qspi_erase(uint32_t sec_addr)
qspi erase data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:281
esmt32m_cmd_erase_config
void esmt32m_cmd_erase_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:96
qspi_write_enable
void qspi_write_enable(void)
qspi write enable
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:315
qspi_data_read
void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:192
qspi_data_write
void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:256
esmt32m_cmd_read_config
void esmt32m_cmd_read_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:51
esmt32m_cmd_write_config
void esmt32m_cmd_write_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:74
esmt32m_cmd_rdsr_config
void esmt32m_cmd_rdsr_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:138
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f435_437_board.c:306
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f435_437_dma.h:151
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:164
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:174
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_QSPI1
@ DMAMUX_DMAREQ_ID_QSPI1
Definition: at32f435_437_dma.h:240
DMA2_FDT1_FLAG
#define DMA2_FDT1_FLAG
Definition: at32f435_437_dma.h:95
DMA2MUX_CHANNEL1
#define DMA2MUX_CHANNEL1
Definition: at32f435_437_dma.h:726
DMA2
#define DMA2
Definition: at32f435_437_dma.h:717
DMA2_CHANNEL1
#define DMA2_CHANNEL1
Definition: at32f435_437_dma.h:718
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
qspi_flag_clear
void qspi_flag_clear(qspi_type *qspi_x, uint32_t flag)
clear flags
Definition: at32f435_437_qspi.c:168
qspi_dma_enable
void qspi_dma_enable(qspi_type *qspi_x, confirm_state new_state)
enable/disable dma transfer
Definition: at32f435_437_qspi.c:218
qspi_dma_tx_threshold_set
void qspi_dma_tx_threshold_set(qspi_type *qspi_x, qspi_dma_fifo_thod_type new_threshold)
set dma threshold for dma tx
Definition: at32f435_437_qspi.c:204
qspi_dma_rx_threshold_set
void qspi_dma_rx_threshold_set(qspi_type *qspi_x, qspi_dma_fifo_thod_type new_threshold)
set dma threshold for dma rx
Definition: at32f435_437_qspi.c:186
qspi_cmd_operation_kick
void qspi_cmd_operation_kick(qspi_type *qspi_x, qspi_cmd_type *qspi_cmd_struct)
set command-port and qspi_x will start to work
Definition: at32f435_437_qspi.c:292
qspi_flag_get
flag_status qspi_flag_get(qspi_type *qspi_x, uint32_t flag)
get status flags.
Definition: at32f435_437_qspi.c:138
QSPI_RSTSC_HW_AUTO
@ QSPI_RSTSC_HW_AUTO
Definition: at32f435_437_qspi.h:102
QSPI_CMD_INSLEN_1_BYTE
@ QSPI_CMD_INSLEN_1_BYTE
Definition: at32f435_437_qspi.h:153
QSPI_DMA_FIFO_THOD_WORD08
@ QSPI_DMA_FIFO_THOD_WORD08
Definition: at32f435_437_qspi.h:180
QSPI_OPERATE_MODE_111
@ QSPI_OPERATE_MODE_111
Definition: at32f435_437_qspi.h:111
QSPI_OPERATE_MODE_444
@ QSPI_OPERATE_MODE_444
Definition: at32f435_437_qspi.h:117
QSPI_CMD_ADRLEN_0_BYTE
@ QSPI_CMD_ADRLEN_0_BYTE
Definition: at32f435_437_qspi.h:140
QSPI_CMD_ADRLEN_3_BYTE
@ QSPI_CMD_ADRLEN_3_BYTE
Definition: at32f435_437_qspi.h:143
QSPI_CMDSTS_FLAG
#define QSPI_CMDSTS_FLAG
Definition: at32f435_437_qspi.h:52
QSPI1
#define QSPI1
Definition: at32f435_437_qspi.h:512
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
qspi_cmd_type
qspi cmd type
Definition: at32f435_437_qspi.h:189
qspi_cmd_type::instruction_length
qspi_cmd_inslen_type instruction_length
Definition: at32f435_437_qspi.h:193
qspi_cmd_type::write_data_enable
confirm_state write_data_enable
Definition: at32f435_437_qspi.h:201
qspi_cmd_type::operation_mode
qspi_operate_mode_type operation_mode
Definition: at32f435_437_qspi.h:198
qspi_cmd_type::instruction_code
uint8_t instruction_code
Definition: at32f435_437_qspi.h:192
qspi_cmd_type::read_status_config
qspi_read_status_conf_type read_status_config
Definition: at32f435_437_qspi.h:199
qspi_cmd_type::pe_mode_enable
confirm_state pe_mode_enable
Definition: at32f435_437_qspi.h:190
qspi_cmd_type::read_status_enable
confirm_state read_status_enable
Definition: at32f435_437_qspi.h:200
qspi_cmd_type::data_counter
uint32_t data_counter
Definition: at32f435_437_qspi.h:196
qspi_cmd_type::address_code
uint32_t address_code
Definition: at32f435_437_qspi.h:194
qspi_cmd_type::pe_mode_operate_code
uint8_t pe_mode_operate_code
Definition: at32f435_437_qspi.h:191
qspi_cmd_type::address_length
qspi_cmd_adrlen_type address_length
Definition: at32f435_437_qspi.h:195
qspi_cmd_type::second_dummy_cycle_num
uint8_t second_dummy_cycle_num
Definition: at32f435_437_qspi.h:197


AT32F435/437 Firmwary Library: qspi_cmd_esmt32m.c File Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_interrupt
  • src
Macros | Functions | Variables
at_start_f437/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c File Reference

qspi_cmd_esmt32m program More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | QSPI_FIFO_DEPTH (32*4)
#define | FLASH_PAGE_PROGRAM_SIZE 256

Functions

void | qspi_busy_check (void)
qspi check busy More...
void | qspi_write_enable (void)
qspi write enable More...
void | esmt32m_cmd_read_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config More...
void | esmt32m_cmd_write_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config More...
void | esmt32m_cmd_erase_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config More...
void | esmt32m_cmd_wren_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config More...
void | esmt32m_cmd_rdsr_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config More...
void | qspi_command_set_busy ()
set qspi_state_is_busy More...
void | qspi_command_not_busy ()
reset qspi_state_is_busy More...
flag_status | qspi_command_is_busy (void)
return qspi_state_is_busy More...
void | QSPI1_IRQHandler (void)
this function handles qspi1 handler. More...
void | qspi_data_read (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data More...
void | qspi_data_write (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data More...
void | qspi_erase (uint32_t sec_addr)
qspi erase data More...

Variables

qspi_cmd_type esmt32m_cmd_config
volatile flag_status qspi_state_is_busy = RESET

Detailed Description

qspi_cmd_esmt32m program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c.


AT32F435/437 Firmwary Library: qspi_cmd_esmt32m.c Source File

  • at_start_f437
  • examples
  • qspi
  • command_port_using_interrupt
  • src
at_start_f437/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28
37#define QSPI_FIFO_DEPTH (32*4)
38#define FLASH_PAGE_PROGRAM_SIZE 256
39
40 qspi_cmd_type esmt32m_cmd_config;
41volatile flag_status qspi_state_is_busy = RESET;
42
43void qspi_busy_check(void);
44void qspi_write_enable(void);
45
53void esmt32m_cmd_read_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
54{
55 qspi_cmd_struct->pe_mode_enable = FALSE;
56 qspi_cmd_struct->pe_mode_operate_code = 0;
57 qspi_cmd_struct->instruction_code = 0xEB;
58 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
59 qspi_cmd_struct->address_code = addr;
60 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
61 qspi_cmd_struct->data_counter = counter;
62 qspi_cmd_struct->second_dummy_cycle_num = 6;
63 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_144;
64 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
65 qspi_cmd_struct->read_status_enable = FALSE;
66 qspi_cmd_struct->write_data_enable = FALSE;
67}
68
76void esmt32m_cmd_write_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
77{
78 qspi_cmd_struct->pe_mode_enable = FALSE;
79 qspi_cmd_struct->pe_mode_operate_code = 0;
80 qspi_cmd_struct->instruction_code = 0x32;
81 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
82 qspi_cmd_struct->address_code = addr;
83 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
84 qspi_cmd_struct->data_counter = counter;
85 qspi_cmd_struct->second_dummy_cycle_num = 0;
86 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_114;
87 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
88 qspi_cmd_struct->read_status_enable = FALSE;
89 qspi_cmd_struct->write_data_enable = TRUE;
90}
91
98void esmt32m_cmd_erase_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
99{
100 qspi_cmd_struct->pe_mode_enable = FALSE;
101 qspi_cmd_struct->pe_mode_operate_code = 0;
102 qspi_cmd_struct->instruction_code = 0x20;
103 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
104 qspi_cmd_struct->address_code = addr;
105 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
106 qspi_cmd_struct->data_counter = 0;
107 qspi_cmd_struct->second_dummy_cycle_num = 0;
108 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
109 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
110 qspi_cmd_struct->read_status_enable = FALSE;
111 qspi_cmd_struct->write_data_enable = TRUE;
112}
113
119void esmt32m_cmd_wren_config(qspi_cmd_type *qspi_cmd_struct)
120{
121 qspi_cmd_struct->pe_mode_enable = FALSE;
122 qspi_cmd_struct->pe_mode_operate_code = 0;
123 qspi_cmd_struct->instruction_code = 0x06;
124 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
125 qspi_cmd_struct->address_code = 0;
126 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
127 qspi_cmd_struct->data_counter = 0;
128 qspi_cmd_struct->second_dummy_cycle_num = 0;
129 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
130 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
131 qspi_cmd_struct->read_status_enable = FALSE;
132 qspi_cmd_struct->write_data_enable = TRUE;
133}
134
140void esmt32m_cmd_rdsr_config(qspi_cmd_type *qspi_cmd_struct)
141{
142 qspi_cmd_struct->pe_mode_enable = FALSE;
143 qspi_cmd_struct->pe_mode_operate_code = 0;
144 qspi_cmd_struct->instruction_code = 0x05;
145 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
146 qspi_cmd_struct->address_code = 0;
147 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
148 qspi_cmd_struct->data_counter = 0;
149 qspi_cmd_struct->second_dummy_cycle_num = 0;
150 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
151 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
152 qspi_cmd_struct->read_status_enable = TRUE;
153 qspi_cmd_struct->write_data_enable = FALSE;
154}
155
161void qspi_command_set_busy()
162{
163 qspi_state_is_busy = SET;
164}
165
171void qspi_command_not_busy()
172{
173 qspi_state_is_busy = RESET;
174}
175
181 flag_status qspi_command_is_busy(void)
182{
183 return qspi_state_is_busy;
184}
185
191void QSPI1_IRQHandler(void)
192{
193 if(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) != RESET)
194 {
195 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
196 qspi_command_not_busy();
197 }
198}
199
207void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t* buf)
208{
209 uint32_t i, len = total_len;
210 /* set busy state */
211 qspi_command_set_busy();
212
213 esmt32m_cmd_read_config(&esmt32m_cmd_config, addr, total_len);
214 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
215
216 /* read data */
217 do
218 {
219 if(total_len >= QSPI_FIFO_DEPTH)
220 {
221 len = QSPI_FIFO_DEPTH;
222 }
223 else
224 {
225 len = total_len;
226 }
227 while(qspi_flag_get(QSPI1, QSPI_RXFIFORDY_FLAG) == RESET);
228
229 for(i = 0; i < len; ++i)
230 {
231 *buf++ = qspi_byte_read(QSPI1);
232 }
233 total_len -= len;
234 }while(total_len);
235
236 /* wait command completed */
237 while(qspi_command_is_busy() != RESET);
238}
239
247void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t* buf)
248{
249 uint32_t i, len = total_len;
250
251 do
252 {
253 qspi_write_enable();
254 if(total_len >= FLASH_PAGE_PROGRAM_SIZE)
255 {
256 len = FLASH_PAGE_PROGRAM_SIZE;
257 }
258 else
259 {
260 len = total_len;
261 }
262 /* set busy state */
263 qspi_command_set_busy();
264
265 esmt32m_cmd_write_config(&esmt32m_cmd_config, addr, len);
266 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
267
268 for(i = 0; i < len; ++i)
269 {
270 while(qspi_flag_get(QSPI1, QSPI_TXFIFORDY_FLAG) == RESET);
271 qspi_byte_write(QSPI1, *buf++);
272 }
273 total_len -= len;
274 addr += len;
275
276 /* wait command completed */
277 while(qspi_command_is_busy() != RESET);
278
279 qspi_busy_check();
280
281 }while(total_len);
282}
283
289void qspi_erase(uint32_t sec_addr)
290{
291 qspi_write_enable();
292
293 /* set busy state */
294 qspi_command_set_busy();
295
296 esmt32m_cmd_erase_config(&esmt32m_cmd_config, sec_addr);
297 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
298
299 /* wait command completed */
300 while(qspi_command_is_busy() != RESET);
301
302 qspi_busy_check();
303}
304
310void qspi_busy_check(void)
311{
312 /* set busy state */
313 qspi_command_set_busy();
314
315 esmt32m_cmd_rdsr_config(&esmt32m_cmd_config);
316 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
317
318 /* wait command completed */
319 while(qspi_command_is_busy() != RESET);
320}
321
327void qspi_write_enable(void)
328{
329 /* set busy state */
330 qspi_command_set_busy();
331
332 esmt32m_cmd_wren_config(&esmt32m_cmd_config);
333 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
334
335 /* wait command completed */
336 while(qspi_command_is_busy() != RESET);
337}
338
at32f435_437_board.h
counter
uint16_t counter
Definition: project/at_start_f435/examples/debug/tmr1/src/main.c:39
qspi_busy_check
void qspi_busy_check(void)
qspi check busy
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:300
esmt32m_cmd_wren_config
void esmt32m_cmd_wren_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:117
qspi_erase
void qspi_erase(uint32_t sec_addr)
qspi erase data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:281
esmt32m_cmd_erase_config
void esmt32m_cmd_erase_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:96
qspi_write_enable
void qspi_write_enable(void)
qspi write enable
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:315
qspi_data_read
void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:192
qspi_data_write
void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:256
esmt32m_cmd_read_config
void esmt32m_cmd_read_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:51
esmt32m_cmd_write_config
void esmt32m_cmd_write_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:74
esmt32m_cmd_rdsr_config
void esmt32m_cmd_rdsr_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:138
qspi_command_not_busy
void qspi_command_not_busy()
reset qspi_state_is_busy
Definition: at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:171
qspi_command_set_busy
void qspi_command_set_busy()
set qspi_state_is_busy
Definition: at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:161
FLASH_PAGE_PROGRAM_SIZE
#define FLASH_PAGE_PROGRAM_SIZE
Definition: at_start_f437/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:38
qspi_state_is_busy
volatile flag_status qspi_state_is_busy
Definition: at_start_f437/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:41
QSPI1_IRQHandler
void QSPI1_IRQHandler(void)
this function handles qspi1 handler.
Definition: at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:191
esmt32m_cmd_config
qspi_cmd_type esmt32m_cmd_config
Definition: at_start_f437/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:40
qspi_command_is_busy
flag_status qspi_command_is_busy(void)
return qspi_state_is_busy
Definition: at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:181
QSPI_FIFO_DEPTH
#define QSPI_FIFO_DEPTH
Definition: at_start_f437/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:37
flag_status
flag_status
Definition: at32f435_437.h:378
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
qspi_flag_clear
void qspi_flag_clear(qspi_type *qspi_x, uint32_t flag)
clear flags
Definition: at32f435_437_qspi.c:168
qspi_byte_read
uint8_t qspi_byte_read(qspi_type *qspi_x)
read one byte from qspi device in command mode
Definition: at32f435_437_qspi.c:359
qspi_byte_write
void qspi_byte_write(qspi_type *qspi_x, uint8_t value)
write one byte to qspi device in command mode
Definition: at32f435_437_qspi.c:390
qspi_cmd_operation_kick
void qspi_cmd_operation_kick(qspi_type *qspi_x, qspi_cmd_type *qspi_cmd_struct)
set command-port and qspi_x will start to work
Definition: at32f435_437_qspi.c:292
qspi_flag_get
flag_status qspi_flag_get(qspi_type *qspi_x, uint32_t flag)
get status flags.
Definition: at32f435_437_qspi.c:138
QSPI_RSTSC_HW_AUTO
@ QSPI_RSTSC_HW_AUTO
Definition: at32f435_437_qspi.h:102
QSPI_CMD_INSLEN_1_BYTE
@ QSPI_CMD_INSLEN_1_BYTE
Definition: at32f435_437_qspi.h:153
QSPI_OPERATE_MODE_144
@ QSPI_OPERATE_MODE_144
Definition: at32f435_437_qspi.h:115
QSPI_OPERATE_MODE_111
@ QSPI_OPERATE_MODE_111
Definition: at32f435_437_qspi.h:111
QSPI_OPERATE_MODE_114
@ QSPI_OPERATE_MODE_114
Definition: at32f435_437_qspi.h:113
QSPI_CMD_ADRLEN_0_BYTE
@ QSPI_CMD_ADRLEN_0_BYTE
Definition: at32f435_437_qspi.h:140
QSPI_CMD_ADRLEN_3_BYTE
@ QSPI_CMD_ADRLEN_3_BYTE
Definition: at32f435_437_qspi.h:143
QSPI_CMDSTS_FLAG
#define QSPI_CMDSTS_FLAG
Definition: at32f435_437_qspi.h:52
QSPI_RXFIFORDY_FLAG
#define QSPI_RXFIFORDY_FLAG
Definition: at32f435_437_qspi.h:53
QSPI_TXFIFORDY_FLAG
#define QSPI_TXFIFORDY_FLAG
Definition: at32f435_437_qspi.h:54
QSPI1
#define QSPI1
Definition: at32f435_437_qspi.h:512
qspi_cmd_type
qspi cmd type
Definition: at32f435_437_qspi.h:189
qspi_cmd_type::instruction_length
qspi_cmd_inslen_type instruction_length
Definition: at32f435_437_qspi.h:193
qspi_cmd_type::write_data_enable
confirm_state write_data_enable
Definition: at32f435_437_qspi.h:201
qspi_cmd_type::operation_mode
qspi_operate_mode_type operation_mode
Definition: at32f435_437_qspi.h:198
qspi_cmd_type::instruction_code
uint8_t instruction_code
Definition: at32f435_437_qspi.h:192
qspi_cmd_type::read_status_config
qspi_read_status_conf_type read_status_config
Definition: at32f435_437_qspi.h:199
qspi_cmd_type::pe_mode_enable
confirm_state pe_mode_enable
Definition: at32f435_437_qspi.h:190
qspi_cmd_type::read_status_enable
confirm_state read_status_enable
Definition: at32f435_437_qspi.h:200
qspi_cmd_type::data_counter
uint32_t data_counter
Definition: at32f435_437_qspi.h:196
qspi_cmd_type::address_code
uint32_t address_code
Definition: at32f435_437_qspi.h:194
qspi_cmd_type::pe_mode_operate_code
uint8_t pe_mode_operate_code
Definition: at32f435_437_qspi.h:191
qspi_cmd_type::address_length
qspi_cmd_adrlen_type address_length
Definition: at32f435_437_qspi.h:195
qspi_cmd_type::second_dummy_cycle_num
uint8_t second_dummy_cycle_num
Definition: at32f435_437_qspi.h:197


AT32F435/437 Firmwary Library: qspi_cmd_esmt32m.c File Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_polling
  • src
Macros | Functions | Variables
at_start_f437/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c File Reference

qspi_cmd_esmt32m program More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | QSPI_FIFO_DEPTH (32*4)
#define | FLASH_PAGE_PROGRAM_SIZE 256

Functions

void | qspi_busy_check (void)
qspi check busy More...
void | qspi_write_enable (void)
qspi write enable More...
void | esmt32m_cmd_read_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config More...
void | esmt32m_cmd_write_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config More...
void | esmt32m_cmd_erase_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config More...
void | esmt32m_cmd_wren_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config More...
void | esmt32m_cmd_rdsr_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config More...
void | qspi_data_read (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data More...
void | qspi_data_write (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data More...
void | qspi_erase (uint32_t sec_addr)
qspi erase data More...

Variables

qspi_cmd_type esmt32m_cmd_config

Detailed Description

qspi_cmd_esmt32m program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c.


AT32F435/437 Firmwary Library: qspi_cmd_esmt32m.c Source File

  • at_start_f437
  • examples
  • qspi
  • command_port_using_polling
  • src
at_start_f437/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28
37#define QSPI_FIFO_DEPTH (32*4)
38#define FLASH_PAGE_PROGRAM_SIZE 256
39
40 qspi_cmd_type esmt32m_cmd_config;
41
42void qspi_busy_check(void);
43void qspi_write_enable(void);
44
52void esmt32m_cmd_read_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
53{
54 qspi_cmd_struct->pe_mode_enable = FALSE;
55 qspi_cmd_struct->pe_mode_operate_code = 0;
56 qspi_cmd_struct->instruction_code = 0xEB;
57 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
58 qspi_cmd_struct->address_code = addr;
59 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
60 qspi_cmd_struct->data_counter = counter;
61 qspi_cmd_struct->second_dummy_cycle_num = 6;
62 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_144;
63 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
64 qspi_cmd_struct->read_status_enable = FALSE;
65 qspi_cmd_struct->write_data_enable = FALSE;
66}
67
75void esmt32m_cmd_write_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
76{
77 qspi_cmd_struct->pe_mode_enable = FALSE;
78 qspi_cmd_struct->pe_mode_operate_code = 0;
79 qspi_cmd_struct->instruction_code = 0x32;
80 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
81 qspi_cmd_struct->address_code = addr;
82 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
83 qspi_cmd_struct->data_counter = counter;
84 qspi_cmd_struct->second_dummy_cycle_num = 0;
85 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_114;
86 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
87 qspi_cmd_struct->read_status_enable = FALSE;
88 qspi_cmd_struct->write_data_enable = TRUE;
89}
90
97void esmt32m_cmd_erase_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
98{
99 qspi_cmd_struct->pe_mode_enable = FALSE;
100 qspi_cmd_struct->pe_mode_operate_code = 0;
101 qspi_cmd_struct->instruction_code = 0x20;
102 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
103 qspi_cmd_struct->address_code = addr;
104 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
105 qspi_cmd_struct->data_counter = 0;
106 qspi_cmd_struct->second_dummy_cycle_num = 0;
107 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
108 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
109 qspi_cmd_struct->read_status_enable = FALSE;
110 qspi_cmd_struct->write_data_enable = TRUE;
111}
112
118void esmt32m_cmd_wren_config(qspi_cmd_type *qspi_cmd_struct)
119{
120 qspi_cmd_struct->pe_mode_enable = FALSE;
121 qspi_cmd_struct->pe_mode_operate_code = 0;
122 qspi_cmd_struct->instruction_code = 0x06;
123 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
124 qspi_cmd_struct->address_code = 0;
125 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
126 qspi_cmd_struct->data_counter = 0;
127 qspi_cmd_struct->second_dummy_cycle_num = 0;
128 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
129 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
130 qspi_cmd_struct->read_status_enable = FALSE;
131 qspi_cmd_struct->write_data_enable = TRUE;
132}
133
139void esmt32m_cmd_rdsr_config(qspi_cmd_type *qspi_cmd_struct)
140{
141 qspi_cmd_struct->pe_mode_enable = FALSE;
142 qspi_cmd_struct->pe_mode_operate_code = 0;
143 qspi_cmd_struct->instruction_code = 0x05;
144 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
145 qspi_cmd_struct->address_code = 0;
146 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
147 qspi_cmd_struct->data_counter = 0;
148 qspi_cmd_struct->second_dummy_cycle_num = 0;
149 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
150 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
151 qspi_cmd_struct->read_status_enable = TRUE;
152 qspi_cmd_struct->write_data_enable = FALSE;
153}
154
162void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t* buf)
163{
164 uint32_t i, len = total_len;
165
166 esmt32m_cmd_read_config(&esmt32m_cmd_config, addr, total_len);
167 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
168
169 /* read data */
170 do
171 {
172 if(total_len >= QSPI_FIFO_DEPTH)
173 {
174 len = QSPI_FIFO_DEPTH;
175 }
176 else
177 {
178 len = total_len;
179 }
180 while(qspi_flag_get(QSPI1, QSPI_RXFIFORDY_FLAG) == RESET);
181 for(i = 0; i < len; ++i)
182 {
183 *buf++ = qspi_byte_read(QSPI1);
184 }
185 total_len -= len;
186 }while(total_len);
187
188 /* wait command completed */
189 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
190 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
191}
192
200void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t* buf)
201{
202 uint32_t i, len = total_len;
203
204 do
205 {
206 qspi_write_enable();
207 if(total_len >= FLASH_PAGE_PROGRAM_SIZE)
208 {
209 len = FLASH_PAGE_PROGRAM_SIZE;
210 }
211 else
212 {
213 len = total_len;
214 }
215 esmt32m_cmd_write_config(&esmt32m_cmd_config, addr, len);
216 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
217
218 for(i = 0; i < len; ++i)
219 {
220 while(qspi_flag_get(QSPI1, QSPI_TXFIFORDY_FLAG) == RESET);
221 qspi_byte_write(QSPI1, *buf++);
222 }
223 total_len -= len;
224 addr += len;
225
226 /* wait command completed */
227 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
228 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
229
230 qspi_busy_check();
231
232 }while(total_len);
233}
234
240void qspi_erase(uint32_t sec_addr)
241{
242 qspi_write_enable();
243
244 esmt32m_cmd_erase_config(&esmt32m_cmd_config, sec_addr);
245 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
246
247 /* wait command completed */
248 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
249 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
250
251 qspi_busy_check();
252}
253
259void qspi_busy_check(void)
260{
261 esmt32m_cmd_rdsr_config(&esmt32m_cmd_config);
262 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
263
264 /* wait command completed */
265 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
266 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
267}
268
274void qspi_write_enable(void)
275{
276 esmt32m_cmd_wren_config(&esmt32m_cmd_config);
277 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
278
279 /* wait command completed */
280 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
281 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
282}
283
at32f435_437_board.h
counter
uint16_t counter
Definition: project/at_start_f435/examples/debug/tmr1/src/main.c:39
qspi_busy_check
void qspi_busy_check(void)
qspi check busy
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:300
esmt32m_cmd_wren_config
void esmt32m_cmd_wren_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:117
qspi_erase
void qspi_erase(uint32_t sec_addr)
qspi erase data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:281
esmt32m_cmd_erase_config
void esmt32m_cmd_erase_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:96
qspi_write_enable
void qspi_write_enable(void)
qspi write enable
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:315
qspi_data_read
void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:192
qspi_data_write
void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:256
esmt32m_cmd_read_config
void esmt32m_cmd_read_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:51
esmt32m_cmd_write_config
void esmt32m_cmd_write_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:74
esmt32m_cmd_rdsr_config
void esmt32m_cmd_rdsr_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:138
FLASH_PAGE_PROGRAM_SIZE
#define FLASH_PAGE_PROGRAM_SIZE
Definition: at_start_f437/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c:38
esmt32m_cmd_config
qspi_cmd_type esmt32m_cmd_config
Definition: at_start_f437/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c:40
QSPI_FIFO_DEPTH
#define QSPI_FIFO_DEPTH
Definition: at_start_f437/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c:37
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
qspi_flag_clear
void qspi_flag_clear(qspi_type *qspi_x, uint32_t flag)
clear flags
Definition: at32f435_437_qspi.c:168
qspi_byte_read
uint8_t qspi_byte_read(qspi_type *qspi_x)
read one byte from qspi device in command mode
Definition: at32f435_437_qspi.c:359
qspi_byte_write
void qspi_byte_write(qspi_type *qspi_x, uint8_t value)
write one byte to qspi device in command mode
Definition: at32f435_437_qspi.c:390
qspi_cmd_operation_kick
void qspi_cmd_operation_kick(qspi_type *qspi_x, qspi_cmd_type *qspi_cmd_struct)
set command-port and qspi_x will start to work
Definition: at32f435_437_qspi.c:292
qspi_flag_get
flag_status qspi_flag_get(qspi_type *qspi_x, uint32_t flag)
get status flags.
Definition: at32f435_437_qspi.c:138
QSPI_RSTSC_HW_AUTO
@ QSPI_RSTSC_HW_AUTO
Definition: at32f435_437_qspi.h:102
QSPI_CMD_INSLEN_1_BYTE
@ QSPI_CMD_INSLEN_1_BYTE
Definition: at32f435_437_qspi.h:153
QSPI_OPERATE_MODE_144
@ QSPI_OPERATE_MODE_144
Definition: at32f435_437_qspi.h:115
QSPI_OPERATE_MODE_111
@ QSPI_OPERATE_MODE_111
Definition: at32f435_437_qspi.h:111
QSPI_OPERATE_MODE_114
@ QSPI_OPERATE_MODE_114
Definition: at32f435_437_qspi.h:113
QSPI_CMD_ADRLEN_0_BYTE
@ QSPI_CMD_ADRLEN_0_BYTE
Definition: at32f435_437_qspi.h:140
QSPI_CMD_ADRLEN_3_BYTE
@ QSPI_CMD_ADRLEN_3_BYTE
Definition: at32f435_437_qspi.h:143
QSPI_CMDSTS_FLAG
#define QSPI_CMDSTS_FLAG
Definition: at32f435_437_qspi.h:52
QSPI_RXFIFORDY_FLAG
#define QSPI_RXFIFORDY_FLAG
Definition: at32f435_437_qspi.h:53
QSPI_TXFIFORDY_FLAG
#define QSPI_TXFIFORDY_FLAG
Definition: at32f435_437_qspi.h:54
QSPI1
#define QSPI1
Definition: at32f435_437_qspi.h:512
qspi_cmd_type
qspi cmd type
Definition: at32f435_437_qspi.h:189
qspi_cmd_type::instruction_length
qspi_cmd_inslen_type instruction_length
Definition: at32f435_437_qspi.h:193
qspi_cmd_type::write_data_enable
confirm_state write_data_enable
Definition: at32f435_437_qspi.h:201
qspi_cmd_type::operation_mode
qspi_operate_mode_type operation_mode
Definition: at32f435_437_qspi.h:198
qspi_cmd_type::instruction_code
uint8_t instruction_code
Definition: at32f435_437_qspi.h:192
qspi_cmd_type::read_status_config
qspi_read_status_conf_type read_status_config
Definition: at32f435_437_qspi.h:199
qspi_cmd_type::pe_mode_enable
confirm_state pe_mode_enable
Definition: at32f435_437_qspi.h:190
qspi_cmd_type::read_status_enable
confirm_state read_status_enable
Definition: at32f435_437_qspi.h:200
qspi_cmd_type::data_counter
uint32_t data_counter
Definition: at32f435_437_qspi.h:196
qspi_cmd_type::address_code
uint32_t address_code
Definition: at32f435_437_qspi.h:194
qspi_cmd_type::pe_mode_operate_code
uint8_t pe_mode_operate_code
Definition: at32f435_437_qspi.h:191
qspi_cmd_type::address_length
qspi_cmd_adrlen_type address_length
Definition: at32f435_437_qspi.h:195
qspi_cmd_type::second_dummy_cycle_num
uint8_t second_dummy_cycle_num
Definition: at32f435_437_qspi.h:197


AT32F435/437 Firmwary Library: qspi_cmd_esmt32m.c File Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_rdsr_sw
  • src
Macros | Functions | Variables
at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c File Reference

qspi_cmd_esmt32m program More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | QSPI_FIFO_DEPTH (32*4)
#define | FLASH_PAGE_PROGRAM_SIZE 256

Functions

void | qspi_busy_check (void)
qspi check busy More...
void | qspi_write_enable (void)
qspi write enable More...
void | esmt32m_cmd_read_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config More...
void | esmt32m_cmd_write_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config More...
void | esmt32m_cmd_erase_config (qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config More...
void | esmt32m_cmd_wren_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config More...
void | esmt32m_cmd_rdsr_config (qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config More...
void | qspi_data_read (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data More...
void | qspi_data_write (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data More...
void | qspi_erase (uint32_t sec_addr)
qspi erase data More...

Variables

qspi_cmd_type esmt32m_cmd_config

Detailed Description

qspi_cmd_esmt32m program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c.


AT32F435/437 Firmwary Library: qspi_cmd_esmt32m.c Source File

  • at_start_f437
  • examples
  • qspi
  • command_port_using_rdsr_sw
  • src
at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28
37#define QSPI_FIFO_DEPTH (32*4)
38#define FLASH_PAGE_PROGRAM_SIZE 256
39
40 qspi_cmd_type esmt32m_cmd_config;
41
42void qspi_busy_check(void);
43void qspi_write_enable(void);
44
52void esmt32m_cmd_read_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
53{
54 qspi_cmd_struct->pe_mode_enable = FALSE;
55 qspi_cmd_struct->pe_mode_operate_code = 0;
56 qspi_cmd_struct->instruction_code = 0xEB;
57 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
58 qspi_cmd_struct->address_code = addr;
59 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
60 qspi_cmd_struct->data_counter = counter;
61 qspi_cmd_struct->second_dummy_cycle_num = 6;
62 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_144;
63 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
64 qspi_cmd_struct->read_status_enable = FALSE;
65 qspi_cmd_struct->write_data_enable = FALSE;
66}
67
75void esmt32m_cmd_write_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
76{
77 qspi_cmd_struct->pe_mode_enable = FALSE;
78 qspi_cmd_struct->pe_mode_operate_code = 0;
79 qspi_cmd_struct->instruction_code = 0x32;
80 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
81 qspi_cmd_struct->address_code = addr;
82 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
83 qspi_cmd_struct->data_counter = counter;
84 qspi_cmd_struct->second_dummy_cycle_num = 0;
85 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_114;
86 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
87 qspi_cmd_struct->read_status_enable = FALSE;
88 qspi_cmd_struct->write_data_enable = TRUE;
89}
90
97void esmt32m_cmd_erase_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
98{
99 qspi_cmd_struct->pe_mode_enable = FALSE;
100 qspi_cmd_struct->pe_mode_operate_code = 0;
101 qspi_cmd_struct->instruction_code = 0x20;
102 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
103 qspi_cmd_struct->address_code = addr;
104 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_3_BYTE;
105 qspi_cmd_struct->data_counter = 0;
106 qspi_cmd_struct->second_dummy_cycle_num = 0;
107 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
108 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
109 qspi_cmd_struct->read_status_enable = FALSE;
110 qspi_cmd_struct->write_data_enable = TRUE;
111}
112
118void esmt32m_cmd_wren_config(qspi_cmd_type *qspi_cmd_struct)
119{
120 qspi_cmd_struct->pe_mode_enable = FALSE;
121 qspi_cmd_struct->pe_mode_operate_code = 0;
122 qspi_cmd_struct->instruction_code = 0x06;
123 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
124 qspi_cmd_struct->address_code = 0;
125 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
126 qspi_cmd_struct->data_counter = 0;
127 qspi_cmd_struct->second_dummy_cycle_num = 0;
128 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
129 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
130 qspi_cmd_struct->read_status_enable = FALSE;
131 qspi_cmd_struct->write_data_enable = TRUE;
132}
133
139void esmt32m_cmd_rdsr_config(qspi_cmd_type *qspi_cmd_struct)
140{
141 qspi_cmd_struct->pe_mode_enable = FALSE;
142 qspi_cmd_struct->pe_mode_operate_code = 0;
143 qspi_cmd_struct->instruction_code = 0x05;
144 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
145 qspi_cmd_struct->address_code = 0;
146 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
147 qspi_cmd_struct->data_counter = 0;
148 qspi_cmd_struct->second_dummy_cycle_num = 0;
149 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
150 qspi_cmd_struct->read_status_config = QSPI_RSTSC_SW_ONCE;
151 qspi_cmd_struct->read_status_enable = TRUE;
152 qspi_cmd_struct->write_data_enable = FALSE;
153}
154
162void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t* buf)
163{
164 uint32_t i, len = total_len;
165
166 esmt32m_cmd_read_config(&esmt32m_cmd_config, addr, total_len);
167 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
168
169 /* read data */
170 do
171 {
172 if(total_len >= QSPI_FIFO_DEPTH)
173 {
174 len = QSPI_FIFO_DEPTH;
175 }
176 else
177 {
178 len = total_len;
179 }
180 while(qspi_flag_get(QSPI1, QSPI_RXFIFORDY_FLAG) == RESET);
181 for(i = 0; i < len; ++i)
182 {
183 *buf++ = qspi_byte_read(QSPI1);
184 }
185 total_len -= len;
186 }while(total_len);
187
188 /* wait command completed */
189 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
190 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
191}
192
200void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t* buf)
201{
202 uint32_t i, len = total_len;
203
204 do
205 {
206 qspi_write_enable();
207 if(total_len >= FLASH_PAGE_PROGRAM_SIZE)
208 {
209 len = FLASH_PAGE_PROGRAM_SIZE;
210 }
211 else
212 {
213 len = total_len;
214 }
215 esmt32m_cmd_write_config(&esmt32m_cmd_config, addr, len);
216 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
217
218 for(i = 0; i < len; ++i)
219 {
220 while(qspi_flag_get(QSPI1, QSPI_TXFIFORDY_FLAG) == RESET);
221 qspi_byte_write(QSPI1, *buf++);
222 }
223 total_len -= len;
224 addr += len;
225
226 /* wait command completed */
227 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
228 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
229
230 qspi_busy_check();
231
232 }while(total_len);
233}
234
240void qspi_erase(uint32_t sec_addr)
241{
242 qspi_write_enable();
243
244 esmt32m_cmd_erase_config(&esmt32m_cmd_config, sec_addr);
245 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
246
247 /* wait command completed */
248 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
249 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
250
251 qspi_busy_check();
252}
253
259void qspi_busy_check(void)
260{
261 do
262 {
263 esmt32m_cmd_rdsr_config(&esmt32m_cmd_config);
264 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
265
266 /* wait command completed */
267 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
268 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
269 /* check wip status */
270 }while(QSPI1->rsts & (1 << QSPI_BUSY_OFFSET_0));
271}
272
278void qspi_write_enable(void)
279{
280 esmt32m_cmd_wren_config(&esmt32m_cmd_config);
281 qspi_cmd_operation_kick(QSPI1, &esmt32m_cmd_config);
282
283 /* wait command completed */
284 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
285 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
286}
287
at32f435_437_board.h
counter
uint16_t counter
Definition: project/at_start_f435/examples/debug/tmr1/src/main.c:39
qspi_busy_check
void qspi_busy_check(void)
qspi check busy
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:300
esmt32m_cmd_wren_config
void esmt32m_cmd_wren_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd wren config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:117
qspi_erase
void qspi_erase(uint32_t sec_addr)
qspi erase data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:281
esmt32m_cmd_erase_config
void esmt32m_cmd_erase_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr)
esmt32m cmd erase config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:96
qspi_write_enable
void qspi_write_enable(void)
qspi write enable
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:315
qspi_data_read
void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:192
qspi_data_write
void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:256
esmt32m_cmd_read_config
void esmt32m_cmd_read_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd read config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:51
esmt32m_cmd_write_config
void esmt32m_cmd_write_config(qspi_cmd_type *qspi_cmd_struct, uint32_t addr, uint32_t counter)
esmt32m cmd write config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:74
esmt32m_cmd_rdsr_config
void esmt32m_cmd_rdsr_config(qspi_cmd_type *qspi_cmd_struct)
esmt32m cmd rdsr config
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:138
FLASH_PAGE_PROGRAM_SIZE
#define FLASH_PAGE_PROGRAM_SIZE
Definition: at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c:38
esmt32m_cmd_config
qspi_cmd_type esmt32m_cmd_config
Definition: at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c:40
QSPI_FIFO_DEPTH
#define QSPI_FIFO_DEPTH
Definition: at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c:37
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
qspi_flag_clear
void qspi_flag_clear(qspi_type *qspi_x, uint32_t flag)
clear flags
Definition: at32f435_437_qspi.c:168
qspi_byte_read
uint8_t qspi_byte_read(qspi_type *qspi_x)
read one byte from qspi device in command mode
Definition: at32f435_437_qspi.c:359
qspi_byte_write
void qspi_byte_write(qspi_type *qspi_x, uint8_t value)
write one byte to qspi device in command mode
Definition: at32f435_437_qspi.c:390
qspi_cmd_operation_kick
void qspi_cmd_operation_kick(qspi_type *qspi_x, qspi_cmd_type *qspi_cmd_struct)
set command-port and qspi_x will start to work
Definition: at32f435_437_qspi.c:292
qspi_flag_get
flag_status qspi_flag_get(qspi_type *qspi_x, uint32_t flag)
get status flags.
Definition: at32f435_437_qspi.c:138
QSPI_RSTSC_SW_ONCE
@ QSPI_RSTSC_SW_ONCE
Definition: at32f435_437_qspi.h:103
QSPI_RSTSC_HW_AUTO
@ QSPI_RSTSC_HW_AUTO
Definition: at32f435_437_qspi.h:102
QSPI_CMD_INSLEN_1_BYTE
@ QSPI_CMD_INSLEN_1_BYTE
Definition: at32f435_437_qspi.h:153
QSPI_BUSY_OFFSET_0
@ QSPI_BUSY_OFFSET_0
Definition: at32f435_437_qspi.h:87
QSPI_OPERATE_MODE_144
@ QSPI_OPERATE_MODE_144
Definition: at32f435_437_qspi.h:115
QSPI_OPERATE_MODE_111
@ QSPI_OPERATE_MODE_111
Definition: at32f435_437_qspi.h:111
QSPI_OPERATE_MODE_114
@ QSPI_OPERATE_MODE_114
Definition: at32f435_437_qspi.h:113
QSPI_CMD_ADRLEN_0_BYTE
@ QSPI_CMD_ADRLEN_0_BYTE
Definition: at32f435_437_qspi.h:140
QSPI_CMD_ADRLEN_3_BYTE
@ QSPI_CMD_ADRLEN_3_BYTE
Definition: at32f435_437_qspi.h:143
QSPI_CMDSTS_FLAG
#define QSPI_CMDSTS_FLAG
Definition: at32f435_437_qspi.h:52
QSPI_RXFIFORDY_FLAG
#define QSPI_RXFIFORDY_FLAG
Definition: at32f435_437_qspi.h:53
QSPI_TXFIFORDY_FLAG
#define QSPI_TXFIFORDY_FLAG
Definition: at32f435_437_qspi.h:54
QSPI1
#define QSPI1
Definition: at32f435_437_qspi.h:512
qspi_cmd_type
qspi cmd type
Definition: at32f435_437_qspi.h:189
qspi_cmd_type::instruction_length
qspi_cmd_inslen_type instruction_length
Definition: at32f435_437_qspi.h:193
qspi_cmd_type::write_data_enable
confirm_state write_data_enable
Definition: at32f435_437_qspi.h:201
qspi_cmd_type::operation_mode
qspi_operate_mode_type operation_mode
Definition: at32f435_437_qspi.h:198
qspi_cmd_type::instruction_code
uint8_t instruction_code
Definition: at32f435_437_qspi.h:192
qspi_cmd_type::read_status_config
qspi_read_status_conf_type read_status_config
Definition: at32f435_437_qspi.h:199
qspi_cmd_type::pe_mode_enable
confirm_state pe_mode_enable
Definition: at32f435_437_qspi.h:190
qspi_cmd_type::read_status_enable
confirm_state read_status_enable
Definition: at32f435_437_qspi.h:200
qspi_cmd_type::data_counter
uint32_t data_counter
Definition: at32f435_437_qspi.h:196
qspi_cmd_type::address_code
uint32_t address_code
Definition: at32f435_437_qspi.h:194
qspi_cmd_type::pe_mode_operate_code
uint8_t pe_mode_operate_code
Definition: at32f435_437_qspi.h:191
qspi_cmd_type::address_length
qspi_cmd_adrlen_type address_length
Definition: at32f435_437_qspi.h:195
qspi_cmd_type::second_dummy_cycle_num
uint8_t second_dummy_cycle_num
Definition: at32f435_437_qspi.h:197


AT32F435/437 Firmwary Library: qspi_xip_ly68l6400.c File Reference

  • at_start_f437
  • examples
  • qspi
  • xip_port_write_read
  • src
Functions | Variables
at_start_f437/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c File Reference
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void | xip_init_ly68l6400_config (qspi_xip_type *qspi_xip_struct)
xip init ly68l6400 config More...
void | cmd_rsten_ly68l6400_config (qspi_cmd_type *qspi_cmd_struct)
cmd rsten ly68l6400 config More...
void | cmd_rst_ly68l6400_config (qspi_cmd_type *qspi_cmd_struct)
cmd rst ly68l6400 config More...
void | qspi_cmd_ly68l6400_send (qspi_cmd_type *cmd)
void | qspi_xip_init_ly68l6400 (void)

Variables

qspi_xip_type ly68l6400_xip_init
qspi_cmd_type ly68l6400_cmd_config


AT32F435/437 Firmwary Library: qspi_xip_ly68l6400.c Source File

  • at_start_f437
  • examples
  • qspi
  • xip_port_write_read
  • src
at_start_f437/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28
37 qspi_xip_type ly68l6400_xip_init;
38 qspi_cmd_type ly68l6400_cmd_config;
39
45void xip_init_ly68l6400_config(qspi_xip_type *qspi_xip_struct)
46{
47 qspi_xip_struct->read_instruction_code = 0xEB;
48 qspi_xip_struct->read_address_length = QSPI_XIP_ADDRLEN_3_BYTE;
49 qspi_xip_struct->read_operation_mode = QSPI_OPERATE_MODE_144;
50 qspi_xip_struct->read_second_dummy_cycle_num = 6;
51 qspi_xip_struct->write_instruction_code = 0x38;
52 qspi_xip_struct->write_address_length = QSPI_XIP_ADDRLEN_3_BYTE;
53 qspi_xip_struct->write_operation_mode = QSPI_OPERATE_MODE_144;
54 qspi_xip_struct->write_second_dummy_cycle_num = 0;
55 qspi_xip_struct->write_select_mode = QSPI_XIPW_SEL_MODED;
56 qspi_xip_struct->write_time_counter = 0x7F;
57 qspi_xip_struct->write_data_counter = 0x1F;
58 qspi_xip_struct->read_select_mode = QSPI_XIPR_SEL_MODED;
59 qspi_xip_struct->read_time_counter = 0x7F;
60 qspi_xip_struct->read_data_counter = 0x1F;
61}
62
68void cmd_rsten_ly68l6400_config(qspi_cmd_type *qspi_cmd_struct)
69{
70 qspi_cmd_struct->pe_mode_enable = FALSE;
71 qspi_cmd_struct->pe_mode_operate_code = 0;
72 qspi_cmd_struct->instruction_code = 0x66;
73 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
74 qspi_cmd_struct->address_code = 0;
75 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
76 qspi_cmd_struct->data_counter = 0;
77 qspi_cmd_struct->second_dummy_cycle_num = 0;
78 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
79 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
80 qspi_cmd_struct->read_status_enable = FALSE;
81 qspi_cmd_struct->write_data_enable = TRUE;
82}
83
89void cmd_rst_ly68l6400_config(qspi_cmd_type *qspi_cmd_struct)
90{
91 qspi_cmd_struct->pe_mode_enable = FALSE;
92 qspi_cmd_struct->pe_mode_operate_code = 0;
93 qspi_cmd_struct->instruction_code = 0x99;
94 qspi_cmd_struct->instruction_length = QSPI_CMD_INSLEN_1_BYTE;
95 qspi_cmd_struct->address_code = 0;
96 qspi_cmd_struct->address_length = QSPI_CMD_ADRLEN_0_BYTE;
97 qspi_cmd_struct->data_counter = 0;
98 qspi_cmd_struct->second_dummy_cycle_num = 0;
99 qspi_cmd_struct->operation_mode = QSPI_OPERATE_MODE_111;
100 qspi_cmd_struct->read_status_config = QSPI_RSTSC_HW_AUTO;
101 qspi_cmd_struct->read_status_enable = FALSE;
102 qspi_cmd_struct->write_data_enable = TRUE;
103}
104
105void qspi_cmd_ly68l6400_send(qspi_cmd_type* cmd)
106{
107 qspi_cmd_operation_kick(QSPI1, cmd);
108 /* wait command completed */
109 while(qspi_flag_get(QSPI1, QSPI_CMDSTS_FLAG) == RESET);
110 qspi_flag_clear(QSPI1, QSPI_CMDSTS_FLAG);
111}
112
113
114void qspi_xip_init_ly68l6400(void)
115{
116 /* switch to command-port mode */
117 qspi_xip_enable(QSPI1, FALSE);
118
119 /* issue reset command */
120 cmd_rsten_ly68l6400_config(&ly68l6400_cmd_config);
121 qspi_cmd_ly68l6400_send(&ly68l6400_cmd_config);
122 cmd_rst_ly68l6400_config(&ly68l6400_cmd_config);
123 qspi_cmd_ly68l6400_send(&ly68l6400_cmd_config);
124
125 /* initial xip */
126 xip_init_ly68l6400_config(&ly68l6400_xip_init);
127 qspi_xip_init(QSPI1, &ly68l6400_xip_init);
128 qspi_xip_cache_bypass_set(QSPI1,TRUE);
129 qspi_xip_enable(QSPI1, TRUE);
130}
131
at32f435_437_board.h
cmd_rst_ly68l6400_config
void cmd_rst_ly68l6400_config(qspi_cmd_type *qspi_cmd_struct)
cmd rst ly68l6400 config
Definition: at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c:89
qspi_cmd_ly68l6400_send
void qspi_cmd_ly68l6400_send(qspi_cmd_type *cmd)
Definition: at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c:105
ly68l6400_cmd_config
qspi_cmd_type ly68l6400_cmd_config
Definition: at_start_f437/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c:38
qspi_xip_init_ly68l6400
void qspi_xip_init_ly68l6400(void)
Definition: at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c:114
xip_init_ly68l6400_config
void xip_init_ly68l6400_config(qspi_xip_type *qspi_xip_struct)
xip init ly68l6400 config
Definition: at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c:45
cmd_rsten_ly68l6400_config
void cmd_rsten_ly68l6400_config(qspi_cmd_type *qspi_cmd_struct)
cmd rsten ly68l6400 config
Definition: at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c:68
ly68l6400_xip_init
qspi_xip_type ly68l6400_xip_init
Definition: at_start_f437/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c:37
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
qspi_flag_clear
void qspi_flag_clear(qspi_type *qspi_x, uint32_t flag)
clear flags
Definition: at32f435_437_qspi.c:168
qspi_xip_enable
void qspi_xip_enable(qspi_type *qspi_x, confirm_state new_state)
enable xip mode or command-port mode.
Definition: at32f435_437_qspi.c:254
qspi_cmd_operation_kick
void qspi_cmd_operation_kick(qspi_type *qspi_x, qspi_cmd_type *qspi_cmd_struct)
set command-port and qspi_x will start to work
Definition: at32f435_437_qspi.c:292
qspi_xip_init
void qspi_xip_init(qspi_type *qspi_x, qspi_xip_type *xip_init_struct)
initial xip mode for qspi_x
Definition: at32f435_437_qspi.c:327
qspi_flag_get
flag_status qspi_flag_get(qspi_type *qspi_x, uint32_t flag)
get status flags.
Definition: at32f435_437_qspi.c:138
qspi_xip_cache_bypass_set
void qspi_xip_cache_bypass_set(qspi_type *qspi_x, confirm_state new_state)
enable/disable cache in xip mode
Definition: at32f435_437_qspi.c:107
QSPI_RSTSC_HW_AUTO
@ QSPI_RSTSC_HW_AUTO
Definition: at32f435_437_qspi.h:102
QSPI_CMD_INSLEN_1_BYTE
@ QSPI_CMD_INSLEN_1_BYTE
Definition: at32f435_437_qspi.h:153
QSPI_XIP_ADDRLEN_3_BYTE
@ QSPI_XIP_ADDRLEN_3_BYTE
Definition: at32f435_437_qspi.h:162
QSPI_OPERATE_MODE_144
@ QSPI_OPERATE_MODE_144
Definition: at32f435_437_qspi.h:115
QSPI_OPERATE_MODE_111
@ QSPI_OPERATE_MODE_111
Definition: at32f435_437_qspi.h:111
QSPI_CMD_ADRLEN_0_BYTE
@ QSPI_CMD_ADRLEN_0_BYTE
Definition: at32f435_437_qspi.h:140
QSPI_XIPR_SEL_MODED
@ QSPI_XIPR_SEL_MODED
Definition: at32f435_437_qspi.h:69
QSPI_XIPW_SEL_MODED
@ QSPI_XIPW_SEL_MODED
Definition: at32f435_437_qspi.h:78
QSPI_CMDSTS_FLAG
#define QSPI_CMDSTS_FLAG
Definition: at32f435_437_qspi.h:52
QSPI1
#define QSPI1
Definition: at32f435_437_qspi.h:512
qspi_cmd_type
qspi cmd type
Definition: at32f435_437_qspi.h:189
qspi_cmd_type::instruction_length
qspi_cmd_inslen_type instruction_length
Definition: at32f435_437_qspi.h:193
qspi_cmd_type::write_data_enable
confirm_state write_data_enable
Definition: at32f435_437_qspi.h:201
qspi_cmd_type::operation_mode
qspi_operate_mode_type operation_mode
Definition: at32f435_437_qspi.h:198
qspi_cmd_type::instruction_code
uint8_t instruction_code
Definition: at32f435_437_qspi.h:192
qspi_cmd_type::read_status_config
qspi_read_status_conf_type read_status_config
Definition: at32f435_437_qspi.h:199
qspi_cmd_type::pe_mode_enable
confirm_state pe_mode_enable
Definition: at32f435_437_qspi.h:190
qspi_cmd_type::read_status_enable
confirm_state read_status_enable
Definition: at32f435_437_qspi.h:200
qspi_cmd_type::data_counter
uint32_t data_counter
Definition: at32f435_437_qspi.h:196
qspi_cmd_type::address_code
uint32_t address_code
Definition: at32f435_437_qspi.h:194
qspi_cmd_type::pe_mode_operate_code
uint8_t pe_mode_operate_code
Definition: at32f435_437_qspi.h:191
qspi_cmd_type::address_length
qspi_cmd_adrlen_type address_length
Definition: at32f435_437_qspi.h:195
qspi_cmd_type::second_dummy_cycle_num
uint8_t second_dummy_cycle_num
Definition: at32f435_437_qspi.h:197
qspi_xip_type
qspi xip type
Definition: at32f435_437_qspi.h:208
qspi_xip_type::write_operation_mode
qspi_operate_mode_type write_operation_mode
Definition: at32f435_437_qspi.h:215
qspi_xip_type::read_second_dummy_cycle_num
uint8_t read_second_dummy_cycle_num
Definition: at32f435_437_qspi.h:212
qspi_xip_type::write_address_length
qspi_xip_addrlen_type write_address_length
Definition: at32f435_437_qspi.h:214
qspi_xip_type::write_instruction_code
uint8_t write_instruction_code
Definition: at32f435_437_qspi.h:213
qspi_xip_type::write_data_counter
uint8_t write_data_counter
Definition: at32f435_437_qspi.h:219
qspi_xip_type::read_select_mode
qspi_xip_read_sel_type read_select_mode
Definition: at32f435_437_qspi.h:220
qspi_xip_type::write_time_counter
uint8_t write_time_counter
Definition: at32f435_437_qspi.h:218
qspi_xip_type::read_operation_mode
qspi_operate_mode_type read_operation_mode
Definition: at32f435_437_qspi.h:211
qspi_xip_type::read_address_length
qspi_xip_addrlen_type read_address_length
Definition: at32f435_437_qspi.h:210
qspi_xip_type::read_data_counter
uint8_t read_data_counter
Definition: at32f435_437_qspi.h:222
qspi_xip_type::read_time_counter
uint8_t read_time_counter
Definition: at32f435_437_qspi.h:221
qspi_xip_type::write_select_mode
qspi_xip_write_sel_type write_select_mode
Definition: at32f435_437_qspi.h:217
qspi_xip_type::write_second_dummy_cycle_num
uint8_t write_second_dummy_cycle_num
Definition: at32f435_437_qspi.h:216
qspi_xip_type::read_instruction_code
uint8_t read_instruction_code
Definition: at32f435_437_qspi.h:209


AT32F435/437 Firmwary Library: at32_sdio.h File Reference

  • at_start_f437
  • examples
  • sdio
  • sd_mmc_card
  • inc
Data Structures | Macros | Enumerations | Functions | Variables
at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h File Reference

this file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library. More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct | sd_csd_struct_type
struct | sd_cid_struct_type
struct | sd_scr_struct_type
struct | sd_card_info_struct_type

Macros

#define | SDIOx SDIO1
#define | DMAMUX_SDIOx DMAMUX_DMAREQ_ID_SDIO1
#define | SD_CMD_GO_IDLE_STATE ((uint8_t)0)
#define | SD_CMD_SEND_OP_COND ((uint8_t)1)
#define | SD_CMD_ALL_SEND_CID ((uint8_t)2)
#define | SD_CMD_SET_REL_ADDR ((uint8_t)3)
#define | SD_CMD_SET_DSR ((uint8_t)4)
#define | SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)
#define | SD_CMD_HS_SWITCH ((uint8_t)6)
#define | SD_CMD_SEL_DESEL_CARD ((uint8_t)7)
#define | SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)
#define | SD_CMD_SEND_CSD ((uint8_t)9)
#define | SD_CMD_SEND_CID ((uint8_t)10)
#define | SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)
#define | SD_CMD_STOP_TRANSMISSION ((uint8_t)12)
#define | SD_CMD_SEND_STATUS ((uint8_t)13)
#define | SD_CMD_HS_BUSTEST_READ ((uint8_t)14)
#define | SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)
#define | SD_CMD_SET_BLOCKLEN ((uint8_t)16)
#define | SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)
#define | SD_CMD_READ_MULT_BLOCK ((uint8_t)18)
#define | SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)
#define | SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)
#define | SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)
#define | SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)
#define | SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)
#define | SD_CMD_PROG_CID ((uint8_t)26)
#define | SD_CMD_PROG_CSD ((uint8_t)27)
#define | SD_CMD_SET_WRITE_PROT ((uint8_t)28)
#define | SD_CMD_CLR_WRITE_PROT ((uint8_t)29)
#define | SD_CMD_SEND_WRITE_PROT ((uint8_t)30)
#define | SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)
#define | SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)
#define | SD_CMD_ERASE_GRP_START ((uint8_t)35)
#define | SD_CMD_ERASE_GRP_END ((uint8_t)36)
#define | SD_CMD_ERASE ((uint8_t)38)
#define | SD_CMD_FAST_IO ((uint8_t)39)
#define | SD_CMD_GO_IRQ_STATE ((uint8_t)40)
#define | SD_CMD_LOCK_UNLOCK ((uint8_t)42)
#define | SD_CMD_APP_CMD ((uint8_t)55)
#define | SD_CMD_GEN_CMD ((uint8_t)56)
#define | SD_CMD_NO_CMD ((uint8_t)64)
#define | SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)
#define | SD_CMD_SD_APP_STAUS ((uint8_t)13)
#define | SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)
#define | SD_CMD_SD_APP_OP_COND ((uint8_t)41)
#define | SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)
#define | SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)
#define | SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)
#define | SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)
#define | SD_CMD_SD_APP_GET_MKB ((uint8_t)43)
#define | SD_CMD_SD_APP_GET_MID ((uint8_t)44)
#define | SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)
#define | SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)
#define | SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)
#define | SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)
#define | SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)
#define | SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)
#define | SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)
#define | SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)
#define | SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)
#define | NULL 0
#define | SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)
#define | SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)
#define | SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SDIO_FIFO_Address ((uint32_t)0x40018080)
#define | SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)
#define | SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)
#define | SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)
#define | SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)
#define | SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)
#define | SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)
#define | SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)
#define | SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)
#define | SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)
#define | SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)
#define | SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)
#define | SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)
#define | SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)
#define | SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)
#define | SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)
#define | SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)
#define | SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)
#define | SD_OCR_ERASE_RESET ((uint32_t)0x00002000)
#define | MMC_SWITCH_ERROR ((uint32_t)0x00000080)
#define | SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)
#define | SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)
#define | SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)
#define | SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)
#define | SD_R5_ERROR ((uint32_t)0x00000800)
#define | SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)
#define | SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)
#define | SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)
#define | SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)
#define | SD_HIGH_CAPACITY ((uint32_t)0x40000000)
#define | SD_STD_CAPACITY ((uint32_t)0x00000000)
#define | SD_CHECK_PATTERN ((uint32_t)0x000001AA)
#define | SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)
#define | SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)
#define | SD_ALLZERO ((uint32_t)0x00000000)
#define | SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)
#define | SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)
#define | SD_CARD_LOCKED ((uint32_t)0x02000000)
#define | SD_CARD_PROGRAMMING ((uint32_t)0x00000007)
#define | SD_CARD_RECEIVING ((uint32_t)0x00000006)
#define | SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SD_0TO7BITS ((uint32_t)0x000000FF)
#define | SD_8TO15BITS ((uint32_t)0x0000FF00)
#define | SD_16TO23BITS ((uint32_t)0x00FF0000)
#define | SD_24TO31BITS ((uint32_t)0xFF000000)
#define | SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)
#define | SD_HALFFIFO ((uint32_t)0x00000008)
#define | SD_HALFFIFOBYTES ((uint32_t)0x00000020)
#define | SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)
#define | SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)
#define | SD_CCCC_ERASE ((uint32_t)0x00000020)
#define | SDIO_SEND_IF_COND ((uint32_t)0x00000008)
#define | EXT_CSD_Command_set 0x0
#define | EXT_CSD_Set_bit 0x1
#define | EXT_CSD_Clear_byte 0x2
#define | EXT_CSD_Write_byte 0x3
#define | EXT_CSD_CMD_SET_NORMAL (1<<0)
#define | EXT_CSD_CMD_SET_SECURE (1<<1)
#define | EXT_CSD_CMD_SET_CPSECURE (1<<2)
#define | EXT_CSD_BUS_WIDTH 183
#define | EXT_CSD_HS_TIMING 185
#define | SDIO_INTR_STS_WRITE_MASK
#define | SDIO_INTR_STS_READ_MASK

Enumerations

enum sd_data_transfer_mode_type {
SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 , SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 ,
SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 , SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1
}
enum sd_error_status_type {
SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 , SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 ,
SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 , SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 ,
SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 , SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 ,
SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 , SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 ,
SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 , SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 ,
SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 , SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 ,
SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 , SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 ,
SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 , SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 ,
SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR , SD_NOT_CONFIGURED , SD_REQ_PENDING ,
SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER , SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW ,
SD_ERROR , SD_OK = 0 , SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 ,
SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 , SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 ,
SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 , SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 ,
SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 , SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 ,
SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 , SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 ,
SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 , SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 ,
SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 , SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 ,
SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 , SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 ,
SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 , SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR ,
SD_NOT_CONFIGURED , SD_REQ_PENDING , SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER ,
SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW , SD_ERROR , SD_OK = 0 ,
SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 , SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 ,
SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 , SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 ,
SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 , SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 ,
SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 , SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 ,
SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 , SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 ,
SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 , SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 ,
SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 , SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 ,
SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 , SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 ,
SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR , SD_NOT_CONFIGURED , SD_REQ_PENDING ,
SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER , SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW ,
SD_ERROR , SD_OK = 0 , SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 ,
SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 , SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 ,
SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 , SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 ,
SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 , SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 ,
SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 , SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 ,
SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 , SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 ,
SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 , SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 ,
SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 , SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 ,
SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 , SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR ,
SD_NOT_CONFIGURED , SD_REQ_PENDING , SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER ,
SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW , SD_ERROR , SD_OK = 0
}
enum sd_card_state_type {
SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) ,
SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) ,
SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) ,
SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) ,
SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) ,
SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) ,
SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) ,
SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) ,
SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF)
}
enum sd_memory_card_type {
SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 ,
SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 ,
SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 ,
SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 ,
SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 ,
SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 ,
SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 ,
SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 ,
SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8
}

Functions

sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clkdiv)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...

Variables

sd_card_info_struct_type sd_card_info

Detailed Description

this file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library.

Version
v2.0.9
Date
2022-06-28
        Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h.


AT32F435/437 Firmwary Library: at32_sdio.h Source File

  • at_start_f437
  • examples
  • sdio
  • sd_mmc_card
  • inc
at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h
Go to the documentation of this file.
1
28/* define to prevent recursive inclusion -------------------------------------*/
29#ifndef __AT32_SDIO_H
30#define __AT32_SDIO_H
31
32#ifdef __cplusplus
33extern "C" {
34#endif
35
36/* includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
51#define SDIOx SDIO1
52#define DMAMUX_SDIOx DMAMUX_DMAREQ_ID_SDIO1
53
65typedef enum
66{
67 SD_TRANSFER_POLLING_MODE = 0,
68 SD_TRANSFER_DMA_MODE = 1
69} sd_data_transfer_mode_type;
70
74typedef enum
75{
76 /* sdio specific error defines ------------------------------------------*/
77 SD_CMD_FAIL = 1,
78 SD_DATA_FAIL = 2,
79 SD_CMD_RSP_TIMEOUT = 3,
80 SD_DATA_TIMEOUT = 4,
81 SD_TX_UNDERRUN = 5,
82 SD_RX_OVERRUN = 6,
83 SD_START_BIT_ERR = 7,
84 SD_CMD_OUT_OF_RANGE = 8,
85 SD_ADDR_MISALIGNED = 9,
86 SD_BLK_LEN_ERR = 10,
87 SD_ERASE_SEQ_ERR = 11,
88 SD_INVALID_ERASE_PARAM = 12,
89 SD_WR_PROTECT_VIOLATION = 13,
90 SD_LOCK_UNLOCK_ERROR = 14,
91 SD_CMD_CRC_ERROR = 15,
92 SD_ILLEGAL_CMD = 16,
93 SD_CARD_ECC_ERROR = 17,
94 SD_CARD_CONTROLLER_ERR = 18,
95 SD_GENERAL_UNKNOWN_ERROR = 19,
96 SD_STREAM_RD_UNDERRUN = 20,
97 SD_STREAM_WR_OVERRUN = 21,
98 SD_CID_CSD_OVERWRITE = 22,
99 SD_WP_ERASE_SKIP = 23,
100 SD_CARD_ECC_DISABLED = 24,
101 SD_ERASE_RESET = 25,
102 SD_AKE_SEQ_ERROR = 26,
103 SD_INVALID_VOLTRANGE = 27,
104 SD_ADDR_OUT_OF_RANGE = 28,
105 SD_SWITCH_ERROR = 29,
106 SD_SDIO_DISABLED = 30,
107 SD_SDIO_FUNC_BUSY = 31,
108 SD_SDIO_FUNC_ERROR = 32,
109 SD_SDIO_UNKNOWN_FUNC = 33,
111 /* standard error defines --------------------------------------------*/
112 SD_INTERNAL_ERROR,
113 SD_NOT_CONFIGURED,
114 SD_REQ_PENDING,
115 SD_REQ_NOT_APPLICABLE,
116 SD_INVALID_PARAMETER,
117 SD_UNSUPPORTED_FEATURE,
118 SD_UNSUPPORTED_HW,
119 SD_ERROR,
120 SD_OK = 0
121} sd_error_status_type;
122
126typedef struct
127{
128 uint8_t csd_struct;
129 uint8_t spec_version;
130 uint8_t reserved1;
131 uint8_t taac;
132 uint8_t nsac;
133 uint8_t max_bus_clk_freq;
134 uint16_t card_cmd_classes;
135 uint8_t max_read_blk_length;
136 uint8_t part_blk_read;
137 uint8_t write_blk_misalign;
138 uint8_t read_blk_misalign;
139 uint8_t dsr_implemented;
140 uint8_t reserved2;
141 uint32_t device_size;
142 uint8_t max_read_current_vdd_min;
143 uint8_t max_read_current_vdd_max;
144 uint8_t max_write_current_vdd_min;
145 uint8_t max_write_current_vdd_max;
146 uint8_t device_size_mult;
147 uint8_t erase_group_size;
148 uint8_t erase_group_size_mult;
149 uint8_t write_protect_group_size;
150 uint8_t write_protect_group_enable;
151 uint8_t manufacturer_default_ecc;
152 uint8_t write_speed_factor;
153 uint8_t max_write_blk_length;
154 uint8_t part_blk_write;
155 uint8_t reserved3;
156 uint8_t content_protect_app;
157 uint8_t file_format_group;
158 uint8_t copy_flag;
159 uint8_t permanent_write_protect;
160 uint8_t temp_write_protect;
161 uint8_t file_formart;
162 uint8_t ecc_code;
163 uint8_t csd_crc;
164 uint8_t reserved4;
165} sd_csd_struct_type;
166
170typedef struct
171{
172 uint8_t manufacturer_id;
173 uint16_t oem_app_id;
174 uint32_t product_name1;
175 uint8_t product_name2;
176 uint8_t product_reversion;
177 uint32_t product_sn;
178 uint8_t reserved1;
179 uint16_t manufact_date;
180 uint8_t cid_crc;
181 uint8_t reserved2;
182} sd_cid_struct_type;
183
187typedef enum
188{
189 SD_CARD_READY = ((uint32_t)0x00000001),
190 SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002),
191 SD_CARD_STANDBY = ((uint32_t)0x00000003),
192 SD_CARD_TRANSFER = ((uint32_t)0x00000004),
193 SD_CARD_SENDING = ((uint32_t)0x00000005),
194 SD_CARD_RECEIVING = ((uint32_t)0x00000006),
195 SD_CARD_PROGRAMMING = ((uint32_t)0x00000007),
196 SD_CARD_DISCONNECTED = ((uint32_t)0x00000008),
197 SD_CARD_ERROR = ((uint32_t)0x000000FF)
198} sd_card_state_type;
199
203typedef enum
204{
205 SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0,
206 SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1,
207 SDIO_HIGH_CAPACITY_SD_CARD = 2,
208 SDIO_MULTIMEDIA_CARD = 3,
209 SDIO_SECURE_DIGITAL_IO_CARD = 4,
210 SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5,
211 SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6,
212 SDIO_HIGH_CAPACITY_MMC_CARD = 7,
213 SDIO_SDIO_CARD = 8
214} sd_memory_card_type;
215
219typedef struct
220{
221 uint32_t sd_spec :4; /* [59:56] */
222 uint32_t scr_structure :4; /* [60:63] */
223 uint32_t sd_bus_width :4; /* [51:48] */
224 uint32_t sd_security :3; /* [52:54] */
225 uint32_t data_stat_after_erase :1; /* [55:55] */
226 uint32_t reserved1 :7; /* [46:40] */
227 uint32_t sd_spec3 :1; /* [47:47] */
228 uint32_t cmd20_support :1; /* [32:32] */
229 uint32_t cmd23_support :1; /* [33:33] */
230 uint32_t reserverd2 :6; /* [34:39] */
231 uint32_t reserverd3; /* [31:0] */
232} sd_scr_struct_type;
233
237typedef struct
238{
239 sd_csd_struct_type sd_csd_reg;
240 sd_cid_struct_type sd_cid_reg;
241 sd_scr_struct_type sd_scr_reg;
242 long long card_capacity;
243 uint32_t card_blk_size;
244 uint16_t rca;
245 uint8_t card_type;
246} sd_card_info_struct_type;
247
248extern sd_card_info_struct_type sd_card_info;
249
261#define SD_CMD_GO_IDLE_STATE ((uint8_t)0)
262#define SD_CMD_SEND_OP_COND ((uint8_t)1)
263#define SD_CMD_ALL_SEND_CID ((uint8_t)2)
264#define SD_CMD_SET_REL_ADDR ((uint8_t)3)
265#define SD_CMD_SET_DSR ((uint8_t)4)
266#define SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)
267#define SD_CMD_HS_SWITCH ((uint8_t)6)
268#define SD_CMD_SEL_DESEL_CARD ((uint8_t)7)
269#define SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)
270#define SD_CMD_SEND_CSD ((uint8_t)9)
271#define SD_CMD_SEND_CID ((uint8_t)10)
272#define SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)
273#define SD_CMD_STOP_TRANSMISSION ((uint8_t)12)
274#define SD_CMD_SEND_STATUS ((uint8_t)13)
275#define SD_CMD_HS_BUSTEST_READ ((uint8_t)14)
276#define SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)
277#define SD_CMD_SET_BLOCKLEN ((uint8_t)16)
278#define SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)
279#define SD_CMD_READ_MULT_BLOCK ((uint8_t)18)
280#define SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)
281#define SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)
282#define SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)
283#define SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)
284#define SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)
285#define SD_CMD_PROG_CID ((uint8_t)26)
286#define SD_CMD_PROG_CSD ((uint8_t)27)
287#define SD_CMD_SET_WRITE_PROT ((uint8_t)28)
288#define SD_CMD_CLR_WRITE_PROT ((uint8_t)29)
289#define SD_CMD_SEND_WRITE_PROT ((uint8_t)30)
290#define SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)
291#define SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)
292#define SD_CMD_ERASE_GRP_START ((uint8_t)35)
293#define SD_CMD_ERASE_GRP_END ((uint8_t)36)
294#define SD_CMD_ERASE ((uint8_t)38)
295#define SD_CMD_FAST_IO ((uint8_t)39)
296#define SD_CMD_GO_IRQ_STATE ((uint8_t)40)
297#define SD_CMD_LOCK_UNLOCK ((uint8_t)42)
298#define SD_CMD_APP_CMD ((uint8_t)55)
299#define SD_CMD_GEN_CMD ((uint8_t)56)
300#define SD_CMD_NO_CMD ((uint8_t)64)
301
306#define SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)
307#define SD_CMD_SD_APP_STAUS ((uint8_t)13)
308#define SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)
309#define SD_CMD_SD_APP_OP_COND ((uint8_t)41)
310#define SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)
311#define SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)
312#define SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)
313#define SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)
314
319#define SD_CMD_SD_APP_GET_MKB ((uint8_t)43)
320#define SD_CMD_SD_APP_GET_MID ((uint8_t)44)
321#define SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)
322#define SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)
323#define SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)
324#define SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)
325#define SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)
326#define SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)
327#define SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)
328#define SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)
329#define SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)
330
342#define NULL 0
343#define SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)
344#define SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)
345#define SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
346#define SDIO_FIFO_Address ((uint32_t)0x40018080)
347
359#define SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)
360#define SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)
361#define SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)
362#define SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)
363#define SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)
364#define SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)
365#define SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)
366#define SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)
367#define SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)
368#define SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)
369#define SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)
370#define SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)
371#define SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)
372#define SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)
373#define SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)
374#define SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)
375#define SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)
376#define SD_OCR_ERASE_RESET ((uint32_t)0x00002000)
377#define MMC_SWITCH_ERROR ((uint32_t)0x00000080)
378#define SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)
379#define SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)
380
384#define SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)
385#define SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)
386#define SD_R5_ERROR ((uint32_t)0x00000800)
387
391#define SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)
392#define SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)
393#define SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)
394#define SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)
395#define SD_HIGH_CAPACITY ((uint32_t)0x40000000)
396#define SD_STD_CAPACITY ((uint32_t)0x00000000)
397#define SD_CHECK_PATTERN ((uint32_t)0x000001AA)
398#define SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)
399#define SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)
400#define SD_ALLZERO ((uint32_t)0x00000000)
401#define SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)
402#define SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)
403#define SD_CARD_LOCKED ((uint32_t)0x02000000)
404#define SD_CARD_PROGRAMMING ((uint32_t)0x00000007)
405#define SD_CARD_RECEIVING ((uint32_t)0x00000006)
406#define SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
407#define SD_0TO7BITS ((uint32_t)0x000000FF)
408#define SD_8TO15BITS ((uint32_t)0x0000FF00)
409#define SD_16TO23BITS ((uint32_t)0x00FF0000)
410#define SD_24TO31BITS ((uint32_t)0xFF000000)
411#define SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)
412#define SD_HALFFIFO ((uint32_t)0x00000008)
413#define SD_HALFFIFOBYTES ((uint32_t)0x00000020)
414
426#define SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)
427#define SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)
428#define SD_CCCC_ERASE ((uint32_t)0x00000020)
429
441#define SDIO_SEND_IF_COND ((uint32_t)0x00000008)
442
454#define EXT_CSD_Command_set 0x0
455#define EXT_CSD_Set_bit 0x1
456#define EXT_CSD_Clear_byte 0x2
457#define EXT_CSD_Write_byte 0x3
458
459#define EXT_CSD_CMD_SET_NORMAL (1<<0)
460#define EXT_CSD_CMD_SET_SECURE (1<<1)
461#define EXT_CSD_CMD_SET_CPSECURE (1<<2)
462
466#define EXT_CSD_BUS_WIDTH 183
467#define EXT_CSD_HS_TIMING 185
468
477#define SDIO_INTR_STS_WRITE_MASK (SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_TXERRU_FLAG | \
478 SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
479#define SDIO_INTR_STS_READ_MASK (SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_RXERRO_FLAG | \
480 SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
489/* sd exported functions ----------------------------------------*/
490 sd_error_status_type sd_init(void);
491void sdio_clock_set(uint32_t clkdiv);
492 sd_error_status_type sd_power_on(void);
493 sd_error_status_type sd_power_off(void);
494 sd_error_status_type sd_card_init(void);
495 sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info);
496 sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode);
497 sd_error_status_type sd_device_mode_set(uint32_t mode);
498 sd_error_status_type sd_deselect_select(uint32_t addr);
499 sd_error_status_type sd_status_send(uint32_t *p_card_status);
500 sd_card_state_type sd_state_get(void);
501 sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks);
502 sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size);
503 sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks);
504 sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size);
505 sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks);
506 sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len);
507 sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len);
508 sd_error_status_type sd_irq_service(void);
509void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir);
510
523#ifdef __cplusplus
524}
525#endif
526
527#endif /* __AT32_SDIO_H */
528
at32f435_437.h
at32f435_437 header file
card_type
static sd_memory_card_type card_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:42
rca
static uint32_t rca
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:43
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f435_437_dma.h:151
sd_power_off
sd_error_status_type sd_power_off(void)
turns the sdio output signals off.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:403
sd_irq_service
sd_error_status_type sd_irq_service(void)
allows to process all the interrupts that are high.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1789
sd_device_mode_set
sd_error_status_type sd_device_mode_set(uint32_t mode)
set sdio work mode.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:786
sd_card_info_get
sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info)
returns information about specific card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:532
mmc_stream_write
sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1700
sd_card_init
sd_error_status_type sd_card_init(void)
intialises all cards or single card as the case may be card(s) come into standby state.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:417
sd_block_read
sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma ...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1188
sd_deselect_select
sd_error_status_type sd_deselect_select(uint32_t addr)
selects od deselects the corresponding card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:807
sdio_clock_set
void sdio_clock_set(uint32_t clkdiv)
set sdio clock devision factor.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:188
sd_blocks_erase
sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks)
erase continuous data block
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1030
sd_mult_blocks_write
sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed ...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1489
sd_state_get
sd_card_state_type sd_state_get(void)
returns information about sd card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:2489
sd_dma_config
void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:2706
sd_block_write
sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be manag...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1367
sd_status_send
sd_error_status_type sd_status_send(uint32_t *p_card_status)
read current card status.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:2452
sd_init
sd_error_status_type sd_init(void)
initializes the sd card and put it into standby state (ready for data transfer).
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:72
mmc_stream_read
sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1653
sd_power_on
sd_error_status_type sd_power_on(void)
enquires cards about their operating voltage and configures clock controls.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:203
sd_mult_blocks_read
sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mod...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1277
sd_wide_bus_operation_config
sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:743
sd_card_info
sd_card_info_struct_type sd_card_info
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:48
sd_data_transfer_mode_type
sd_data_transfer_mode_type
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:66
sd_error_status_type
sd_error_status_type
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:75
sd_card_state_type
sd_card_state_type
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:188
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f435_437_sdio.h:139
sd_memory_card_type
sd_memory_card_type
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:204
SD_TRANSFER_DMA_MODE
@ SD_TRANSFER_DMA_MODE
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:68
SD_TRANSFER_POLLING_MODE
@ SD_TRANSFER_POLLING_MODE
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:67
SD_ERROR
@ SD_ERROR
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:119
SD_WP_ERASE_SKIP
@ SD_WP_ERASE_SKIP
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:99
SD_SDIO_UNKNOWN_FUNC
@ SD_SDIO_UNKNOWN_FUNC
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:109
SD_DATA_FAIL
@ SD_DATA_FAIL
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:78
SD_STREAM_WR_OVERRUN
@ SD_STREAM_WR_OVERRUN
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:97
SD_INVALID_PARAMETER
@ SD_INVALID_PARAMETER
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:116
SD_CMD_FAIL
@ SD_CMD_FAIL
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:77
SD_CMD_OUT_OF_RANGE
@ SD_CMD_OUT_OF_RANGE
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:84
SD_UNSUPPORTED_HW
@ SD_UNSUPPORTED_HW
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:118
SD_SDIO_FUNC_ERROR
@ SD_SDIO_FUNC_ERROR
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:108
SD_INTERNAL_ERROR
@ SD_INTERNAL_ERROR
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:112
SD_INVALID_ERASE_PARAM
@ SD_INVALID_ERASE_PARAM
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:88
SD_GENERAL_UNKNOWN_ERROR
@ SD_GENERAL_UNKNOWN_ERROR
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:95
SD_CARD_ECC_DISABLED
@ SD_CARD_ECC_DISABLED
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:100
SD_CARD_CONTROLLER_ERR
@ SD_CARD_CONTROLLER_ERR
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:94
SD_ERASE_RESET
@ SD_ERASE_RESET
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:101
SD_CARD_ECC_ERROR
@ SD_CARD_ECC_ERROR
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:93
SD_STREAM_RD_UNDERRUN
@ SD_STREAM_RD_UNDERRUN
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:96
SD_UNSUPPORTED_FEATURE
@ SD_UNSUPPORTED_FEATURE
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:117
SD_TX_UNDERRUN
@ SD_TX_UNDERRUN
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:81
SD_ILLEGAL_CMD
@ SD_ILLEGAL_CMD
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:92
SD_SDIO_FUNC_BUSY
@ SD_SDIO_FUNC_BUSY
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:107
SD_CMD_CRC_ERROR
@ SD_CMD_CRC_ERROR
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:91
SD_ADDR_OUT_OF_RANGE
@ SD_ADDR_OUT_OF_RANGE
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:104
SD_RX_OVERRUN
@ SD_RX_OVERRUN
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:82
SD_REQ_PENDING
@ SD_REQ_PENDING
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:114
SD_REQ_NOT_APPLICABLE
@ SD_REQ_NOT_APPLICABLE
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:115
SD_SWITCH_ERROR
@ SD_SWITCH_ERROR
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:105
SD_INVALID_VOLTRANGE
@ SD_INVALID_VOLTRANGE
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:103
SD_SDIO_DISABLED
@ SD_SDIO_DISABLED
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:106
SD_DATA_TIMEOUT
@ SD_DATA_TIMEOUT
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:80
SD_ADDR_MISALIGNED
@ SD_ADDR_MISALIGNED
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:85
SD_START_BIT_ERR
@ SD_START_BIT_ERR
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:83
SD_LOCK_UNLOCK_ERROR
@ SD_LOCK_UNLOCK_ERROR
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:90
SD_NOT_CONFIGURED
@ SD_NOT_CONFIGURED
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:113
SD_CID_CSD_OVERWRITE
@ SD_CID_CSD_OVERWRITE
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:98
SD_WR_PROTECT_VIOLATION
@ SD_WR_PROTECT_VIOLATION
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:89
SD_CMD_RSP_TIMEOUT
@ SD_CMD_RSP_TIMEOUT
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:79
SD_BLK_LEN_ERR
@ SD_BLK_LEN_ERR
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:86
SD_OK
@ SD_OK
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:120
SD_ERASE_SEQ_ERR
@ SD_ERASE_SEQ_ERR
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:87
SD_AKE_SEQ_ERROR
@ SD_AKE_SEQ_ERROR
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:102
SD_CARD_TRANSFER
@ SD_CARD_TRANSFER
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:192
SD_CARD_IDENTIFICATION
@ SD_CARD_IDENTIFICATION
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:190
SD_CARD_SENDING
@ SD_CARD_SENDING
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:193
SD_CARD_STANDBY
@ SD_CARD_STANDBY
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:191
SD_CARD_READY
@ SD_CARD_READY
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:189
SD_CARD_DISCONNECTED
@ SD_CARD_DISCONNECTED
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:196
SD_CARD_ERROR
@ SD_CARD_ERROR
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:197
SDIO_SDIO_CARD
@ SDIO_SDIO_CARD
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:213
SDIO_HIGH_CAPACITY_SD_CARD
@ SDIO_HIGH_CAPACITY_SD_CARD
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:207
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
@ SDIO_SECURE_DIGITAL_IO_COMBO_CARD
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:211
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
@ SDIO_HIGH_SPEED_MULTIMEDIA_CARD
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:210
SDIO_STD_CAPACITY_SD_CARD_V1_1
@ SDIO_STD_CAPACITY_SD_CARD_V1_1
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:205
SDIO_SECURE_DIGITAL_IO_CARD
@ SDIO_SECURE_DIGITAL_IO_CARD
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:209
SDIO_STD_CAPACITY_SD_CARD_V2_0
@ SDIO_STD_CAPACITY_SD_CARD_V2_0
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:206
SDIO_MULTIMEDIA_CARD
@ SDIO_MULTIMEDIA_CARD
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:208
SDIO_HIGH_CAPACITY_MMC_CARD
@ SDIO_HIGH_CAPACITY_MMC_CARD
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:212
SD_CARD_RECEIVING
#define SD_CARD_RECEIVING
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:405
SD_CARD_PROGRAMMING
#define SD_CARD_PROGRAMMING
Definition: at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h:404
sd_card_info_struct_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:238
sd_cid_struct_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:171
sd_csd_struct_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:127
sd_scr_struct_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:220


AT32F435/437 Firmwary Library: at32_sdio.c File Reference

  • at_start_f437
  • examples
  • sdio
  • sd_mmc_card
  • src
Functions | Variables
at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c File Reference

this file provides a set of functions needed to manage the sdio/mmc card memory. More...

#include "at32_sdio.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

sd_error_status_type | command_error (void)
checks for error conditions for cmd0. More...
sd_error_status_type | command_rsp1_error (uint8_t cmd)
checks for error conditions for R1 response. More...
sd_error_status_type | command_rsp2_error (void)
checks for error conditions for R2 (cid or csd) response. More...
sd_error_status_type | command_rsp3_error (void)
checks for error conditions for R3 (ocr) response. More...
sd_error_status_type | command_rsp4_error (uint8_t cmd)
checks for error conditions for r4 response. More...
sd_error_status_type | command_rsp5_error (uint8_t cmd)
checks for error conditions for r5 response. More...
sd_error_status_type | command_rsp6_error (uint8_t cmd, uint16_t *prca)
checks for error conditions for r6 (rca) response. More...
sd_error_status_type | command_rsp7_error (void)
checks for error conditions for R7 response. More...
sd_error_status_type | sd_bus_wide_enable (confirm_state new_state)
enable or disable the sdio wide bus mode. More...
sd_error_status_type | mmc_switch (uint8_t set, uint8_t index, uint8_t value)
switch mmc card speed to high speed More...
sd_error_status_type | sd_switch (uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
switch sd card speed to high speed More...
sd_error_status_type | check_card_programming (uint8_t *p_status)
checks if the sd card is in programming state. More...
sd_error_status_type | speed_change (uint8_t speed)
set bus speed More...
sd_error_status_type | scr_find (void)
find the sd card scr register value. More...
uint8_t | convert_from_bytes_to_power_of_two (uint16_t number_of_bytes)
converts the number of bytes in power of two and returns the power. More...
sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clk_div)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sdio_command_data_send (sdio_command_struct_type *sdio_cmd_init_t, sdio_data_struct_type *sdio_data_init_t, uint32_t *buf)
read data from or write data to sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
void | SDIO1_IRQHandler (void)
sdio1 isr. More...
void | SDIO2_IRQHandler (void)
sdio2 isr. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...

Variables

sdio_command_struct_type sdio_command_init_struct
sdio_data_struct_type sdio_data_init_struct
static sd_memory_card_type | card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1
static uint32_t | csd_table [4]
static uint32_t | cid_table [4]
static uint32_t | rca = 0
static sd_data_transfer_mode_type | device_mode = SD_TRANSFER_POLLING_MODE
static uint8_t | stop_flag = 0
volatile sd_error_status_type | transfer_error = SD_OK
volatile uint8_t | transfer_end = 0
sd_card_info_struct_type sd_card_info

Detailed Description

this file provides a set of functions needed to manage the sdio/mmc card memory.

Version
v2.0.9
Date
2022-06-28
        Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c.


AT32F435/437 Firmwary Library: at32_sdio.c Source File

  • at_start_f437
  • examples
  • sdio
  • sd_mmc_card
  • src
at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c
Go to the documentation of this file.
1
28#include "at32_sdio.h"
29#include "at32f435_437_board.h"
30
39 sdio_command_struct_type sdio_command_init_struct;
40 sdio_data_struct_type sdio_data_init_struct;
41
42static sd_memory_card_type card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1; /* sd card type */
43static uint32_t csd_table[4], cid_table[4], rca = 0; /* csd, sid, rca */
44static sd_data_transfer_mode_type device_mode = SD_TRANSFER_POLLING_MODE; /* working mode */
45static uint8_t stop_flag = 0; /* transmit stop flag */
46volatile sd_error_status_type transfer_error = SD_OK; /* transmit error flag */
47volatile uint8_t transfer_end = 0; /* transmit end flag */
48 sd_card_info_struct_type sd_card_info; /* sd card information */
49
50 sd_error_status_type command_error(void);
51 sd_error_status_type command_rsp1_error(uint8_t cmd);
52 sd_error_status_type command_rsp2_error(void);
53 sd_error_status_type command_rsp3_error(void);
54 sd_error_status_type command_rsp4_error(uint8_t cmd);
55 sd_error_status_type command_rsp5_error(uint8_t cmd);
56 sd_error_status_type command_rsp6_error(uint8_t cmd, uint16_t *p_rca);
57 sd_error_status_type command_rsp7_error(void);
58 sd_error_status_type sd_bus_wide_enable(confirm_state new_state);
59 sd_error_status_type mmc_switch(uint8_t set, uint8_t index, uint8_t value);
60 sd_error_status_type sd_switch(uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp);
61 sd_error_status_type check_card_programming(uint8_t *p_status);
62 sd_error_status_type speed_change(uint8_t speed);
63 sd_error_status_type scr_find(void);
64uint8_t convert_from_bytes_to_power_of_two(uint16_t number_of_bytes);
65
72 sd_error_status_type sd_init(void)
73{
74 uint16_t clkdiv = 0;
75 sd_error_status_type status = SD_OK;
76 gpio_init_type gpio_init_struct = {0};
77 uint8_t retry = 0;
78
79 /* gpioc and gpiod periph clock enable */
80 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
81 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
82
83 /* sdio periph clock enable */
84 crm_periph_clock_enable(CRM_SDIO1_PERIPH_CLOCK, TRUE);
85
86 /* configure pc.08, pc.09, pc.10, pc.11, pc.12 pin: d0, d1, d2, d3, clk pin */
87 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
88 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
89 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
90 gpio_init_struct.gpio_pins = GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11 | GPIO_PINS_12;
91 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
92 gpio_init(GPIOC, &gpio_init_struct);
93
94 /* configure pd.02 cmd line */
95 gpio_init_struct.gpio_pins = GPIO_PINS_2;
96 gpio_init(GPIOD, &gpio_init_struct);
97
98 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE8, GPIO_MUX_12);
99 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE9, GPIO_MUX_12);
100 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE10, GPIO_MUX_12);
101 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE11, GPIO_MUX_12);
102 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE12, GPIO_MUX_12);
103 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE2, GPIO_MUX_12);
104
105 retry = 3;
106 while(retry--){
107 /* reset sdio */
108 sdio_reset(SDIOx);
109 /* power on */
110 status = sd_power_on();
111
112 if(status == SD_OK)
113 break;
114 }
115
116 if(status == SD_OK)
117 {
118 /* sdio card initialize */
119 status = sd_card_init();
120 }
121
122 if(status == SD_OK)
123 {
124 /* get card information*/
125 status = sd_card_info_get(&sd_card_info);
126 }
127
128 if((SDIO_MULTIMEDIA_CARD == card_type) && (sd_card_info.sd_csd_reg.spec_version >= 4))
129 {
130 card_type = SDIO_HIGH_SPEED_MULTIMEDIA_CARD;
131 }
132
133 if(status == SD_OK)
134 {
135 /* select card */
136 status = sd_deselect_select((uint32_t)(sd_card_info.rca << 16));
137 }
138
139 if(status == SD_OK && ((SDIO_STD_CAPACITY_SD_CARD_V1_1 == card_type) || (SDIO_STD_CAPACITY_SD_CARD_V2_0 == card_type) || \
140 (SDIO_SECURE_DIGITAL_IO_COMBO_CARD == card_type) || (SDIO_HIGH_CAPACITY_SD_CARD == card_type)))
141 {
142 status = scr_find();
143 }
144
145 if(status == SD_OK)
146 {
147 /* set normal speed */
148 status = speed_change(0);
149 }
150
151 if((status == SD_OK) || (card_type == SDIO_MULTIMEDIA_CARD))
152 {
153 if(sd_card_info.card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1 || sd_card_info.card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0)
154 {
155 /* set sdio_ck to 12mhz */
156 clkdiv = system_core_clock / 12000000;
157
158 if(clkdiv >= 2)
159 {
160 clkdiv -= 2;
161 }
162 }
163 else
164 {
165 /* set sdio_ck to 48mhz */
166 clkdiv = system_core_clock / 48000000;
167
168 if(clkdiv >= 2)
169 {
170 clkdiv -= 2;
171 }
172 }
173 /* set sdio clock divider */
174 sdio_clock_set(clkdiv);
175
176 /* set transfer mode */
177 status = sd_device_mode_set(SD_TRANSFER_DMA_MODE);
178 }
179
180 return status;
181}
182
188void sdio_clock_set(uint32_t clk_div)
189{
190 /* config clock divide [7:0] */
191 SDIOx->clkctrl_bit.clkdiv_l = (clk_div & 0xFF);
192
193 /* config clock divide [9:8] */
194 SDIOx->clkctrl_bit.clkdiv_h = ((clk_div & 0x300) >> 8);
195}
196
203 sd_error_status_type sd_power_on(void)
204{
205 uint8_t retry = 0;
206 sd_error_status_type status = SD_OK;
207 uint32_t response = 0, count = 0, valid_voltage = 0, clk_psc;
208 uint32_t sd_type = SD_STD_CAPACITY;
209
210 /* sdio_ck is less than 400KHz in initialization stage, set to 200KHz */
211 clk_psc = (system_core_clock / 200000) - 2;
212
213 if(clk_psc > 0x3FF)
214 {
215 clk_psc = 0x3FF;
216 }
217
218 /* config sdio clock divide and edge phase */
219 sdio_clock_config(SDIOx, clk_psc, SDIO_CLOCK_EDGE_FALLING);
220 /* config sdio bus width */
221 sdio_bus_width_config(SDIOx, SDIO_BUS_WIDTH_D1);
222 /* disable flow control */
223 sdio_flow_control_enable(SDIOx, FALSE);
224 /* disable clock bypass */
225 sdio_clock_bypass(SDIOx, FALSE);
226 /* disable power saving mode */
227 sdio_power_saving_mode_enable(SDIOx, FALSE);
228
229 /* sdio power on */
230 sdio_power_set(SDIOx, SDIO_POWER_ON);
231 /* enable to output sdio_ck */
232 sdio_clock_enable(SDIOx, TRUE);
233
234 for(retry = 0; retry < 5; retry++)
235 {
236 /* send cmd0, get in idle stage */
237 sdio_command_init_struct.argument = 0x0;
238 sdio_command_init_struct.cmd_index = SD_CMD_GO_IDLE_STATE;
239 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_NO;
240 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
241
242 /* sdio command config */
243 sdio_command_config(SDIOx, &sdio_command_init_struct);
244 /* enable ccsm */
245 sdio_command_state_machine_enable(SDIOx, TRUE);
246
247 /* get command status */
248 status = command_error();
249 }
250
251 /* send cmd8, check card interface feature */
252 sdio_command_init_struct.argument = SD_CHECK_PATTERN;
253 sdio_command_init_struct.cmd_index = SDIO_SEND_IF_COND;
254 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
255 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
256
257 /* sdio command config */
258 sdio_command_config(SDIOx, &sdio_command_init_struct);
259 /* enable ccsm */
260 sdio_command_state_machine_enable(SDIOx, TRUE);
261
262 /* waiting R7 */
263 status = command_rsp7_error();
264
265 if(status == SD_OK)
266 {
267 /* set card type and sd type */
268 card_type = SDIO_STD_CAPACITY_SD_CARD_V2_0;
269 sd_type = SD_HIGH_CAPACITY;
270 }
271
272 /* send cmd55, check sd version */
273 sdio_command_init_struct.argument = 0x00;
274 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
275 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
276 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
277
278 /* sdio command config */
279 sdio_command_config(SDIOx, &sdio_command_init_struct);
280 /* enable ccsm */
281 sdio_command_state_machine_enable(SDIOx, TRUE);
282
283 /* waiting R1 */
284 status = command_rsp1_error(SD_CMD_APP_CMD);
285
286 /* check sd card or mmc card */
287 if(SD_OK == status)
288 {
289 /* send acmd41, check voltage operation range */
290 while((!valid_voltage) && (count < SD_MAX_VOLT_TRIAL))
291 {
292 delay_ms(10);
293
294 /* send cmd55 before acmd41 */
295 sdio_command_init_struct.argument = 0x00;
296 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
297 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
298 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
299
300 /* sdio command config */
301 sdio_command_config(SDIOx, &sdio_command_init_struct);
302 /* enable ccsm */
303 sdio_command_state_machine_enable(SDIOx, TRUE);
304
305 /* waiting R1 */
306 status = command_rsp1_error(SD_CMD_APP_CMD);
307
308 /* if any errors occured, return status */
309 if(status != SD_OK)
310 {
311 return status;
312 }
313
314 /* send acmd41 */
315 sdio_command_init_struct.argument = SD_VOLTAGE_WINDOW_SD | sd_type;
316 sdio_command_init_struct.cmd_index = SD_CMD_SD_APP_OP_COND;
317 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
318 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
319
320 /* sdio command config */
321 sdio_command_config(SDIOx, &sdio_command_init_struct);
322 /* enable ccsm */
323 sdio_command_state_machine_enable(SDIOx, TRUE);
324
325 /* waiting R3 */
326 status = command_rsp3_error();
327
328 /* if any errors occured, return status */
329 if(status != SD_OK)
330 {
331 return status;
332 }
333
334 /* get response1 */
335 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
336
337 /* check sd card power on stage is success or not */
338 valid_voltage = (((response >> 31) == 1) ? 1 : 0);
339 count++;
340 }
341
342 if(count >= SD_MAX_VOLT_TRIAL)
343 {
344 status = SD_INVALID_VOLTRANGE;
345 return status;
346 }
347
348 if(response &= SD_HIGH_CAPACITY)
349 {
350 card_type = SDIO_HIGH_CAPACITY_SD_CARD;
351 }
352 }
353 /* mmc card */
354 else
355 {
356 /* send cmd1 */
357 while((!valid_voltage) && (count < SD_MAX_VOLT_TRIAL))
358 {
359 delay_ms(10);
360
361 sdio_command_init_struct.argument = SD_VOLTAGE_WINDOW_MMC;
362 sdio_command_init_struct.cmd_index = SD_CMD_SEND_OP_COND;
363 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
364 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
365
366 /* sdio command config */
367 sdio_command_config(SDIOx, &sdio_command_init_struct);
368 /* enable ccsm */
369 sdio_command_state_machine_enable(SDIOx, TRUE);
370
371 /* waiting R3 */
372 status = command_rsp3_error();
373
374 if(status != SD_OK)
375 {
376 return status;
377 }
378
379 /* get response1 */
380 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
381
382 valid_voltage = (((response >> 31) == 1) ? 1 : 0);
383 count++;
384 }
385
386 if(count >= SD_MAX_VOLT_TRIAL)
387 {
388 status = SD_INVALID_VOLTRANGE;
389 return status;
390 }
391
392 card_type = SDIO_MULTIMEDIA_CARD;
393 }
394
395 return(status);
396}
397
403 sd_error_status_type sd_power_off(void)
404{
405 /* sdio power off */
406 sdio_power_set(SDIOx, SDIO_POWER_OFF);
407
408 return SD_OK;
409}
410
417 sd_error_status_type sd_card_init(void)
418{
419 sd_error_status_type status = SD_OK;
420 uint16_t rca_temp = 0x01;
421
422 /* check power status */
423 if(SDIO_POWER_OFF == sdio_power_status_get(SDIOx))
424 {
425 return SD_REQ_NOT_APPLICABLE;
426 }
427
428 /* check is secure_digital_io_card or not */
429 if(SDIO_SECURE_DIGITAL_IO_CARD != card_type)
430 {
431 /* send cmd2, get cid register */
432 sdio_command_init_struct.argument = 0x0;
433 sdio_command_init_struct.cmd_index = SD_CMD_ALL_SEND_CID;
434 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_LONG;
435 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
436
437 /* sdio command config */
438 sdio_command_config(SDIOx, &sdio_command_init_struct);
439 /* enable ccsm */
440 sdio_command_state_machine_enable(SDIOx, TRUE);
441
442 status = command_rsp2_error();
443 if(status != SD_OK)
444 {
445 return status;
446 }
447
448 cid_table[0] = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
449 cid_table[1] = sdio_response_get(SDIOx, SDIO_RSP2_INDEX);
450 cid_table[2] = sdio_response_get(SDIOx, SDIO_RSP3_INDEX);
451 cid_table[3] = sdio_response_get(SDIOx, SDIO_RSP4_INDEX);
452 }
453
454 /* check card type */
455 if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || \
456 (card_type == SDIO_SECURE_DIGITAL_IO_COMBO_CARD) || (card_type == SDIO_HIGH_CAPACITY_SD_CARD))
457 {
458 /* send cmd3, get rca */
459 sdio_command_init_struct.argument = 0x00;
460 sdio_command_init_struct.cmd_index = SD_CMD_SET_REL_ADDR;
461 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
462 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
463
464 /* sdio command config */
465 sdio_command_config(SDIOx, &sdio_command_init_struct);
466 /* enable ccsm */
467 sdio_command_state_machine_enable(SDIOx, TRUE);
468
469 status = command_rsp6_error(SD_CMD_SET_REL_ADDR, &rca_temp);
470 if(status != SD_OK)
471 {
472 return status;
473 }
474 }
475
476 /* mmc card */
477 if(card_type == SDIO_MULTIMEDIA_CARD)
478 {
479 /* send cmd3 */
480 sdio_command_init_struct.argument = (uint32_t)(rca_temp << 16);
481 sdio_command_init_struct.cmd_index = SD_CMD_SET_REL_ADDR;
482 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
483 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
484
485 /* sdio command config */
486 sdio_command_config(SDIOx, &sdio_command_init_struct);
487 /* enable ccsm */
488 sdio_command_state_machine_enable(SDIOx, TRUE);
489
490 status = command_rsp2_error();
491 if(status != SD_OK)
492 {
493 return status;
494 }
495 }
496
497 /* check is secure_digital_io_card or not */
498 if(card_type != SDIO_SECURE_DIGITAL_IO_CARD)
499 {
500 rca = rca_temp;
501 sdio_command_init_struct.argument = (uint32_t)(rca << 16);
502 sdio_command_init_struct.cmd_index = SD_CMD_SEND_CSD;
503 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_LONG;
504 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
505
506 /* sdio command config */
507 sdio_command_config(SDIOx, &sdio_command_init_struct);
508 /* enable ccsm */
509 sdio_command_state_machine_enable(SDIOx, TRUE);
510
511 status = command_rsp2_error();
512 if(status != SD_OK)
513 {
514 return status;
515 }
516
517 csd_table[0] = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
518 csd_table[1] = sdio_response_get(SDIOx, SDIO_RSP2_INDEX);
519 csd_table[2] = sdio_response_get(SDIOx, SDIO_RSP3_INDEX);
520 csd_table[3] = sdio_response_get(SDIOx, SDIO_RSP4_INDEX);
521 }
522
523 return SD_OK;
524}
525
532 sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info)
533{
534 sd_error_status_type status = SD_OK;
535 uint8_t tmp = 0;
536
537 card_info->card_type = (uint8_t)card_type;
538 card_info->rca = (uint16_t)rca;
539
540 /* byte 0 */
541 tmp = (uint8_t)((csd_table[0] & 0xFF000000) >> 24);
542 card_info->sd_csd_reg.csd_struct = (tmp & 0xC0) >> 6;
543 card_info->sd_csd_reg.spec_version = (tmp & 0x3C) >> 2;
544 card_info->sd_csd_reg.reserved1 = tmp & 0x03;
545
546 /* byte 1 */
547 tmp = (uint8_t)((csd_table[0] & 0x00FF0000) >> 16);
548 card_info->sd_csd_reg.taac = tmp;
549
550 /* byte 2 */
551 tmp = (uint8_t)((csd_table[0] & 0x0000FF00) >> 8);
552 card_info->sd_csd_reg.nsac = tmp;
553
554 /* byte 3 */
555 tmp = (uint8_t)(csd_table[0] & 0x000000FF);
556 card_info->sd_csd_reg.max_bus_clk_freq = tmp;
557
558 /* byte 4 */
559 tmp = (uint8_t)((csd_table[1] & 0xFF000000) >> 24);
560 card_info->sd_csd_reg.card_cmd_classes = tmp << 4;
561
562 /* byte 5 */
563 tmp = (uint8_t)((csd_table[1] & 0x00FF0000) >> 16);
564 card_info->sd_csd_reg.card_cmd_classes |= (tmp & 0xF0) >> 4;
565 card_info->sd_csd_reg.max_read_blk_length = tmp & 0x0F;
566
567 /* byte 6 */
568 tmp = (uint8_t)((csd_table[1] & 0x0000FF00) >> 8);
569 card_info->sd_csd_reg.part_blk_read = (tmp & 0x80) >> 7;
570 card_info->sd_csd_reg.write_blk_misalign = (tmp & 0x40) >> 6;
571 card_info->sd_csd_reg.read_blk_misalign = (tmp & 0x20) >> 5;
572 card_info->sd_csd_reg.dsr_implemented = (tmp & 0x10) >> 4;
573 card_info->sd_csd_reg.reserved2 = 0; /* reserved */
574
575 if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || (card_type == SDIO_MULTIMEDIA_CARD))
576 {
577 card_info->sd_csd_reg.device_size = (tmp & 0x03) << 10;
578
579 /* byte 7 */
580 tmp = (uint8_t)(csd_table[1] & 0x000000FF);
581 card_info->sd_csd_reg.device_size |= (tmp) << 2;
582
583 /* byte 8 */
584 tmp = (uint8_t)((csd_table[2] & 0xFF000000) >> 24);
585 card_info->sd_csd_reg.device_size |= (tmp & 0xC0) >> 6;
586
587 card_info->sd_csd_reg.max_read_current_vdd_min = (tmp & 0x38) >> 3;
588 card_info->sd_csd_reg.max_read_current_vdd_max = (tmp & 0x07);
589
590 /* byte 9 */
591 tmp = (uint8_t)((csd_table[2] & 0x00FF0000) >> 16);
592 card_info->sd_csd_reg.max_write_current_vdd_min = (tmp & 0xE0) >> 5;
593 card_info->sd_csd_reg.max_write_current_vdd_max = (tmp & 0x1C) >> 2;
594 card_info->sd_csd_reg.device_size_mult = (tmp & 0x03) << 1;
595 /* byte 10 */
596 tmp = (uint8_t)((csd_table[2] & 0x0000FF00) >> 8);
597 card_info->sd_csd_reg.device_size_mult |= (tmp & 0x80) >> 7;
598
599 card_info->card_capacity = (card_info->sd_csd_reg.device_size + 1) ;
600 card_info->card_capacity *= (1 << (card_info->sd_csd_reg.device_size_mult + 2));
601 card_info->card_blk_size = 1 << (card_info->sd_csd_reg.max_read_blk_length);
602 card_info->card_capacity *= card_info->card_blk_size;
603 }
604 else if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
605 {
606 /* byte 7 */
607 tmp = (uint8_t)(csd_table[1] & 0x000000FF);
608 card_info->sd_csd_reg.device_size = (tmp & 0x3F) << 16;
609
610 /* byte 8 */
611 tmp = (uint8_t)((csd_table[2] & 0xFF000000) >> 24);
612
613 card_info->sd_csd_reg.device_size |= (tmp << 8);
614
615 /* byte 9 */
616 tmp = (uint8_t)((csd_table[2] & 0x00FF0000) >> 16);
617
618 card_info->sd_csd_reg.device_size |= (tmp);
619
620 /* byte 10 */
621 tmp = (uint8_t)((csd_table[2] & 0x0000FF00) >> 8);
622
623 card_info->card_capacity = (uint64_t)(card_info->sd_csd_reg.device_size + 1) * 512 * 1024;
624 card_info->card_blk_size = 512;
625 }
626
627
628 card_info->sd_csd_reg.erase_group_size = (tmp & 0x40) >> 6;
629 card_info->sd_csd_reg.erase_group_size_mult = (tmp & 0x3F) << 1;
630
631 /* byte 11 */
632 tmp = (uint8_t)(csd_table[2] & 0x000000FF);
633 card_info->sd_csd_reg.erase_group_size_mult |= (tmp & 0x80) >> 7;
634 card_info->sd_csd_reg.write_protect_group_size = (tmp & 0x7F);
635
636 /* byte 12 */
637 tmp = (uint8_t)((csd_table[3] & 0xFF000000) >> 24);
638 card_info->sd_csd_reg.write_protect_group_enable = (tmp & 0x80) >> 7;
639 card_info->sd_csd_reg.manufacturer_default_ecc = (tmp & 0x60) >> 5;
640 card_info->sd_csd_reg.write_speed_factor = (tmp & 0x1C) >> 2;
641 card_info->sd_csd_reg.max_write_blk_length = (tmp & 0x03) << 2;
642
643 /* byte 13 */
644 tmp = (uint8_t)((csd_table[3] & 0x00FF0000) >> 16);
645 card_info->sd_csd_reg.max_write_blk_length |= (tmp & 0xC0) >> 6;
646 card_info->sd_csd_reg.part_blk_write = (tmp & 0x20) >> 5;
647 card_info->sd_csd_reg.reserved3 = 0;
648 card_info->sd_csd_reg.content_protect_app = (tmp & 0x01);
649
650 /* byte 14 */
651 tmp = (uint8_t)((csd_table[3] & 0x0000FF00) >> 8);
652 card_info->sd_csd_reg.file_format_group = (tmp & 0x80) >> 7;
653 card_info->sd_csd_reg.copy_flag = (tmp & 0x40) >> 6;
654 card_info->sd_csd_reg.permanent_write_protect = (tmp & 0x20) >> 5;
655 card_info->sd_csd_reg.temp_write_protect = (tmp & 0x10) >> 4;
656 card_info->sd_csd_reg.file_formart = (tmp & 0x0C) >> 2;
657 card_info->sd_csd_reg.ecc_code = (tmp & 0x03);
658
659 /* byte 15 */
660 tmp = (uint8_t)(csd_table[3] & 0x000000FF);
661 card_info->sd_csd_reg.csd_crc = (tmp & 0xFE) >> 1;
662 card_info->sd_csd_reg.reserved4 = 1;
663
664 /* byte 0 */
665 tmp = (uint8_t)((cid_table[0] & 0xFF000000) >> 24);
666 card_info->sd_cid_reg.manufacturer_id = tmp;
667
668 /* byte 1 */
669 tmp = (uint8_t)((cid_table[0] & 0x00FF0000) >> 16);
670 card_info->sd_cid_reg.oem_app_id = tmp << 8;
671
672 /* byte 2 */
673 tmp = (uint8_t)((cid_table[0] & 0x000000FF00) >> 8);
674 card_info->sd_cid_reg.oem_app_id |= tmp;
675
676 /* byte 3 */
677 tmp = (uint8_t)(cid_table[0] & 0x000000FF);
678 card_info->sd_cid_reg.product_name1 = tmp << 24;
679
680 /* byte 4 */
681 tmp = (uint8_t)((cid_table[1] & 0xFF000000) >> 24);
682 card_info->sd_cid_reg.product_name1 |= tmp << 16;
683
684 /* byte 5 */
685 tmp = (uint8_t)((cid_table[1] & 0x00FF0000) >> 16);
686 card_info->sd_cid_reg.product_name1 |= tmp << 8;
687
688 /* byte 6 */
689 tmp = (uint8_t)((cid_table[1] & 0x0000FF00) >> 8);
690 card_info->sd_cid_reg.product_name1 |= tmp;
691
692 /* byte 7 */
693 tmp = (uint8_t)(cid_table[1] & 0x000000FF);
694 card_info->sd_cid_reg.product_name2 = tmp;
695
696 /* byte 8 */
697 tmp = (uint8_t)((cid_table[2] & 0xFF000000) >> 24);
698 card_info->sd_cid_reg.product_reversion = tmp;
699
700 /* byte 9 */
701 tmp = (uint8_t)((cid_table[2] & 0x00FF0000) >> 16);
702 card_info->sd_cid_reg.product_sn = tmp << 24;
703
704 /* byte 10 */
705 tmp = (uint8_t)((cid_table[2] & 0x0000FF00) >> 8);
706 card_info->sd_cid_reg.product_sn |= tmp << 16;
707
708 /* byte 11 */
709 tmp = (uint8_t)(cid_table[2] & 0x000000FF);
710 card_info->sd_cid_reg.product_sn |= tmp << 8;
711
712 /* byte 12 */
713 tmp = (uint8_t)((cid_table[3] & 0xFF000000) >> 24);
714 card_info->sd_cid_reg.product_sn |= tmp;
715
716 /* byte 13 */
717 tmp = (uint8_t)((cid_table[3] & 0x00FF0000) >> 16);
718 card_info->sd_cid_reg.reserved1 |= (tmp & 0xF0) >> 4;
719 card_info->sd_cid_reg.manufact_date = (tmp & 0x0F) << 8;
720
721 /* byte 14 */
722 tmp = (uint8_t)((cid_table[3] & 0x0000FF00) >> 8);
723 card_info->sd_cid_reg.manufact_date |= tmp;
724
725 /* byte 15 */
726 tmp = (uint8_t)(cid_table[3] & 0x000000FF);
727 card_info->sd_cid_reg.cid_crc = (tmp & 0xFE) >> 1;
728 card_info->sd_cid_reg.reserved2 = 1;
729
730 return(status);
731}
732
743 sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
744{
745 sd_error_status_type status = SD_OK;
746
747 if((card_type == SDIO_MULTIMEDIA_CARD) || (card_type == SDIO_HIGH_SPEED_MULTIMEDIA_CARD))
748 {
749 status = mmc_switch(EXT_CSD_CMD_SET_NORMAL, EXT_CSD_BUS_WIDTH, (uint8_t)mode);
750 }
751 else if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || \
752 (card_type == SDIO_HIGH_CAPACITY_SD_CARD))
753 {
754 if(mode >= 2)
755 {
756 /* not support D8 mode */
757 return SD_UNSUPPORTED_FEATURE;
758 }
759
760 if(SDIO_BUS_WIDTH_D4 == mode)
761 {
762 status = sd_bus_wide_enable(TRUE);
763 }
764 else
765 {
766 status = sd_bus_wide_enable(FALSE);
767 }
768 }
769
770 if(status == SD_OK)
771 {
772 sdio_bus_width_config(SDIOx, mode);
773 }
774
775 return status;
776}
777
786 sd_error_status_type sd_device_mode_set(uint32_t mode)
787{
788 sd_error_status_type status = SD_OK;
789
790 if((mode == SD_TRANSFER_DMA_MODE) || (mode == SD_TRANSFER_POLLING_MODE))
791 {
792 device_mode = (sd_data_transfer_mode_type)mode;
793 }
794 else
795 {
796 status = SD_INVALID_PARAMETER;
797 }
798
799 return status;
800}
801
807 sd_error_status_type sd_deselect_select(uint32_t addr)
808{
809 /* send cmd7, select card */
810 sdio_command_init_struct.argument = addr;
811 sdio_command_init_struct.cmd_index = SD_CMD_SEL_DESEL_CARD;
812 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
813 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_INT;
814
815 /* sdio command config */
816 sdio_command_config(SDIOx, &sdio_command_init_struct);
817 /* enable ccsm */
818 sdio_command_state_machine_enable(SDIOx, TRUE);
819
820 return command_rsp1_error(SD_CMD_SEL_DESEL_CARD);
821}
822
830 sd_error_status_type sdio_command_data_send(sdio_command_struct_type *sdio_cmd_init_t, \
831 sdio_data_struct_type* sdio_data_init_t, uint32_t *buf)
832{
833 sd_error_status_type status = SD_OK;
834 uint32_t count = 0;
835 uint32_t timeout = SDIO_DATATIMEOUT;
836 uint32_t length = 0;
837
838 if(buf == NULL)
839 {
840 return SD_INVALID_PARAMETER;
841 }
842 /* clear dtctrl register */
843 SDIOx->dtcnt = 0x0;
844
845 /* sdio command config */
846 sdio_data_config(SDIOx, sdio_data_init_t);
847 /* enable dcsm */
848 sdio_data_state_machine_enable(SDIOx, TRUE);
849
850 length = sdio_data_init_t->data_length;
851
852 if(device_mode == SD_TRANSFER_DMA_MODE)
853 {
854 if(sdio_data_init_t->transfer_direction == SDIO_DATA_TRANSFER_TO_CONTROLLER)
855 {
856 sd_dma_config(buf, length, DMA_DIR_PERIPHERAL_TO_MEMORY);
857 SDIOx->inten |= SDIO_INTR_STS_READ_MASK;
858 transfer_error = SD_OK;
859 transfer_end = 0;
860 sdio_dma_enable(SDIOx, TRUE);
861 }
862 }
863
864 /* sdio command config */
865 sdio_command_config(SDIOx, sdio_cmd_init_t);
866 /* enable ccsm */
867 sdio_command_state_machine_enable(SDIOx, TRUE);
868
869 status = command_rsp1_error(sdio_cmd_init_t->cmd_index);
870 if(status != SD_OK)
871 {
872 return status;
873 }
874
875 /* polling mode */
876 if(device_mode == SD_TRANSFER_POLLING_MODE)
877 {
878 if(SDIO_DATA_TRANSFER_TO_CONTROLLER == sdio_data_init_t->transfer_direction)
879 {
880 while(!(SDIOx->sts & (SDIO_INTR_STS_READ_MASK)))
881 {
882 if(sdio_flag_get(SDIOx, SDIO_RXBUFH_FLAG) != RESET)
883 {
884 for(count = 0; count < 8; count++, buf++)
885 {
886 *buf = sdio_data_read(SDIOx);
887 }
888
889 timeout = 0x7FFFFF;
890 }
891 else
892 {
893 if(0 == timeout)
894 {
895 sd_init();
896 return SD_DATA_TIMEOUT;
897 }
898
899 timeout--;
900 }
901 }
902
903 while(sdio_flag_get(SDIOx, SDIO_RXBUF_FLAG) != RESET)
904 {
905 *buf = sdio_data_read(SDIOx);
906 buf++;
907 }
908 }
909 else
910 {
911 while(!(SDIOx->sts & SDIO_INTR_STS_WRITE_MASK))
912 {
913 if(sdio_flag_get(SDIOx, SDIO_TXBUFH_FLAG) != RESET)
914 {
915 for(count = 0; count < 8 && length > 0; count++, buf++, length -= 4)
916 {
917 sdio_data_write(SDIOx, *buf);
918 }
919
920 timeout = 0x3FFFFFFF;
921 }
922 else
923 {
924 if(timeout == 0)
925 {
926 sd_init();
927 return SD_DATA_TIMEOUT;
928 }
929
930 timeout--;
931 }
932 }
933 }
934 /* data timeout */
935 if(sdio_flag_get(SDIOx, SDIO_DTTIMEOUT_FLAG) != RESET)
936 {
937 sdio_flag_clear(SDIOx, SDIO_DTTIMEOUT_FLAG);
938 return SD_DATA_TIMEOUT;
939 }
940 /* crc error */
941 else if(sdio_flag_get(SDIOx, SDIO_DTFAIL_FLAG) != RESET)
942 {
943 sdio_flag_clear(SDIOx, SDIO_DTFAIL_FLAG);
944 return SD_DATA_FAIL;
945 }
946 /* over run error */
947 else if(sdio_flag_get(SDIOx, SDIO_RXERRO_FLAG) != RESET)
948 {
949 sdio_flag_clear(SDIOx, SDIO_RXERRO_FLAG);
950 return SD_RX_OVERRUN;
951 }
952 /* under run error */
953 else if(sdio_flag_get(SDIOx, SDIO_TXERRU_FLAG) != RESET)
954 {
955 sdio_flag_clear(SDIOx, SDIO_TXERRU_FLAG);
956 return SD_TX_UNDERRUN;
957 }
958 /* start bit error */
959 else if(sdio_flag_get(SDIOx, SDIO_SBITERR_FLAG) != RESET)
960 {
961 sdio_flag_clear(SDIOx, SDIO_SBITERR_FLAG);
962 return SD_START_BIT_ERR;
963 }
964 /* data transfer complete */
965 if((stop_flag == 1) && (sdio_flag_get(SDIOx, SDIO_DTCMPL_FLAG) != RESET))
966 {
967 /* send cmd12, stop transmission */
968 sdio_cmd_init_t->argument = 0;
969 sdio_cmd_init_t->cmd_index = SD_CMD_STOP_TRANSMISSION;
970 sdio_cmd_init_t->rsp_type = SDIO_RESPONSE_SHORT;
971 sdio_cmd_init_t->wait_type = SDIO_WAIT_FOR_NO;
972
973 /* sdio command config */
974 sdio_command_config(SDIOx, sdio_cmd_init_t);
975 /* enable ccsm */
976 sdio_command_state_machine_enable(SDIOx, TRUE);
977
978 status = command_rsp1_error(SD_CMD_STOP_TRANSMISSION);
979
980 if(status != SD_OK)
981 {
982 return status;
983 }
984 }
985
986 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
987 }
988 else if(device_mode == SD_TRANSFER_DMA_MODE)
989 {
990 if(sdio_data_init_t->transfer_direction == SDIO_DATA_TRANSFER_TO_CARD)
991 {
992 sd_dma_config(buf, length, DMA_DIR_MEMORY_TO_PERIPHERAL);
993 SDIOx->inten |= SDIO_INTR_STS_WRITE_MASK;
994 transfer_error = SD_OK;
995 transfer_end = 0;
996 sdio_dma_enable(SDIOx, TRUE);
997 }
998
999 while(!(SDIOx->sts & SDIOx->inten) && timeout)
1000 {
1001 timeout--;
1002
1003 if(transfer_end)
1004 {
1005 break;
1006 }
1007 }
1008
1009 if(timeout == 0)
1010 {
1011 sd_init();
1012 return SD_DATA_TIMEOUT;
1013 }
1014
1015 if(transfer_error != SD_OK)
1016 {
1017 status = transfer_error;
1018 }
1019 }
1020
1021 return status;
1022}
1023
1030 sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks)
1031{
1032 sd_error_status_type status = SD_OK;
1033 uint32_t start_addr = 0, end_addr = 0, response = 0;
1034 uint8_t card_state;
1035
1036 /* high capacity sd card */
1037 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1038 {
1039 start_addr = addr >> 9;
1040 end_addr = start_addr + nblks - 1;
1041 }
1042 else
1043 {
1044 start_addr = addr;
1045 end_addr = start_addr + (nblks - 1) * 512;
1046 }
1047
1048 /* clear dcsm configuration */
1049 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1050 sdio_data_init_struct.data_length = 0 ;
1051 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1052 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1053 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1054
1055 sdio_data_config(SDIOx, &sdio_data_init_struct);
1056 sdio_data_state_machine_enable(SDIOx, FALSE);
1057
1058 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1059
1060 /* check card locked */
1061 if(response & SD_CARD_LOCKED)
1062 {
1063 return SD_LOCK_UNLOCK_ERROR;
1064 }
1065
1066 if(card_type == SDIO_MULTIMEDIA_CARD || card_type == SDIO_HIGH_SPEED_MULTIMEDIA_CARD)
1067 {
1068 /* send cmd35, set erase group start */
1069 sdio_command_init_struct.argument = start_addr;
1070 sdio_command_init_struct.cmd_index = SD_CMD_ERASE_GRP_START;
1071 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1072 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1073
1074 /* sdio command config */
1075 sdio_command_config(SDIOx, &sdio_command_init_struct);
1076 /* enable ccsm */
1077 sdio_command_state_machine_enable(SDIOx, TRUE);
1078
1079 status = command_rsp1_error(SD_CMD_ERASE_GRP_START);
1080
1081 if(status != SD_OK)
1082 {
1083 return status;
1084 }
1085
1086 /* send cmd36, set erase group end */
1087 sdio_command_init_struct.argument = end_addr;
1088 sdio_command_init_struct.cmd_index = SD_CMD_ERASE_GRP_END;
1089
1090 /* sdio command config */
1091 sdio_command_config(SDIOx, &sdio_command_init_struct);
1092 /* enable ccsm */
1093 sdio_command_state_machine_enable(SDIOx, TRUE);
1094
1095 status = command_rsp1_error(SD_CMD_ERASE_GRP_END);
1096
1097 if(status != SD_OK)
1098 {
1099 return status;
1100 }
1101
1102 /* send cmd38, start erase gourp */
1103 sdio_command_init_struct.argument = 0;
1104 sdio_command_init_struct.cmd_index = SD_CMD_ERASE;
1105
1106 /* sdio command config */
1107 sdio_command_config(SDIOx, &sdio_command_init_struct);
1108 /* enable ccsm */
1109 sdio_command_state_machine_enable(SDIOx, TRUE);
1110
1111 status = command_rsp1_error(SD_CMD_ERASE);
1112
1113 if(status != SD_OK)
1114 {
1115 return status;
1116 }
1117 }
1118 else
1119 {
1120 /* send cmd32, set erase block start */
1121 sdio_command_init_struct.argument = start_addr;
1122 sdio_command_init_struct.cmd_index = SD_CMD_SD_ERASE_GRP_START;
1123 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1124 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1125
1126 /* sdio command config */
1127 sdio_command_config(SDIOx, &sdio_command_init_struct);
1128 /* enable ccsm */
1129 sdio_command_state_machine_enable(SDIOx, TRUE);
1130
1131 status = command_rsp1_error(SD_CMD_SD_ERASE_GRP_START);
1132
1133 if(status != SD_OK)
1134 {
1135 return status;
1136 }
1137
1138 /* send cmd33, set erase block end */
1139 sdio_command_init_struct.argument = end_addr;
1140 sdio_command_init_struct.cmd_index = SD_CMD_SD_ERASE_GRP_END;
1141
1142 /* sdio command config */
1143 sdio_command_config(SDIOx, &sdio_command_init_struct);
1144 /* enable ccsm */
1145 sdio_command_state_machine_enable(SDIOx, TRUE);
1146
1147 if(status != SD_OK)
1148 {
1149 return status;
1150 }
1151
1152 /* send cmd38, start erase block */
1153 sdio_command_init_struct.argument = 0;
1154 sdio_command_init_struct.cmd_index = SD_CMD_ERASE;
1155
1156 /* sdio command config */
1157 sdio_command_config(SDIOx, &sdio_command_init_struct);
1158 /* enable ccsm */
1159 sdio_command_state_machine_enable(SDIOx, TRUE);
1160
1161 status = command_rsp1_error(SD_CMD_ERASE);
1162
1163 if(status != SD_OK)
1164 {
1165 return status;
1166 }
1167 }
1168
1169 status = check_card_programming(&card_state);
1170
1171 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || \
1172 (card_state == SD_CARD_RECEIVING)))
1173 {
1174 status = check_card_programming(&card_state);
1175 }
1176
1177 return status;
1178}
1179
1188 sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
1189{
1190 sd_error_status_type status = SD_OK;
1191 uint32_t response = 0;
1192 uint8_t power;
1193
1194 if(NULL == buf)
1195 {
1196 return SD_INVALID_PARAMETER;
1197 }
1198
1199 SDIOx->dtctrl = 0x0;
1200
1201 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1202 {
1203 blk_size = 512;
1204 addr >>= 9;
1205 }
1206
1207 /* clear dcsm configuration */
1208 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1209 sdio_data_init_struct.data_length = 0;
1210 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1211 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1212 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1213
1214 sdio_data_config(SDIOx, &sdio_data_init_struct);
1215 sdio_data_state_machine_enable(SDIOx, FALSE);
1216
1217 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1218
1219 /* check card locked */
1220 if(response & SD_CARD_LOCKED)
1221 {
1222 return SD_LOCK_UNLOCK_ERROR;
1223 }
1224
1225 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1226 {
1227 power = convert_from_bytes_to_power_of_two(blk_size);
1228
1229 /* send cmd16, set block size */
1230 sdio_command_init_struct.argument = blk_size;
1231 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1232 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1233 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1234
1235 /* sdio command config */
1236 sdio_command_config(SDIOx, &sdio_command_init_struct);
1237 /* enable ccsm */
1238 sdio_command_state_machine_enable(SDIOx, TRUE);
1239
1240 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1241
1242 if(status != SD_OK)
1243 {
1244 return status;
1245 }
1246 }
1247 else
1248 {
1249 return SD_INVALID_PARAMETER;
1250 }
1251
1252 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1253 sdio_data_init_struct.data_length = blk_size ;
1254 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1255 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
1256 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1257
1258 sdio_command_init_struct.argument = addr;
1259 sdio_command_init_struct.cmd_index = SD_CMD_READ_SINGLE_BLOCK;
1260 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1261 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1262
1263 stop_flag = 0;
1264
1265 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1266}
1267
1277 sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
1278{
1279 sd_error_status_type status = SD_OK;
1280 uint32_t response = 0;
1281 uint8_t power;
1282
1283 SDIOx->dtctrl = 0x0;
1284
1285 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1286 {
1287 blk_size = 512;
1288 addr >>= 9;
1289 }
1290
1291 /* clear dcsm configuration */
1292 sdio_data_init_struct.block_size = (sdio_block_size_type)0;
1293 sdio_data_init_struct.data_length = 0;
1294 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1295 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1296 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1297
1298 sdio_data_config(SDIOx, &sdio_data_init_struct);
1299 sdio_data_state_machine_enable(SDIOx, FALSE);
1300
1301 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1302
1303 /* check card locked */
1304 if(response & SD_CARD_LOCKED)
1305 {
1306 return SD_LOCK_UNLOCK_ERROR;
1307 }
1308
1309 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1310 {
1311 power = convert_from_bytes_to_power_of_two(blk_size);
1312
1313 /* send cmd16, set block size */
1314 sdio_command_init_struct.argument = blk_size;
1315 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1316 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1317 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1318
1319 /* sdio command config */
1320 sdio_command_config(SDIOx, &sdio_command_init_struct);
1321 /* enable ccsm */
1322 sdio_command_state_machine_enable(SDIOx, TRUE);
1323
1324 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1325
1326 if(status != SD_OK)
1327 {
1328 return status;
1329 }
1330 }
1331 else
1332 {
1333 return SD_INVALID_PARAMETER;
1334 }
1335
1336 /* check max receive length */
1337 if(nblks * blk_size > SD_MAX_DATA_LENGTH)
1338 {
1339 return SD_INVALID_PARAMETER;
1340 }
1341
1342 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1343 sdio_data_init_struct.data_length = nblks * blk_size ;
1344 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1345 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
1346 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1347
1348 /* send cmd18, read block data */
1349 sdio_command_init_struct.argument = addr;
1350 sdio_command_init_struct.cmd_index = SD_CMD_READ_MULT_BLOCK;
1351 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1352 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1353
1354 stop_flag = 1;
1355
1356 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1357}
1358
1367 sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
1368{
1369 sd_error_status_type status = SD_OK;
1370 uint8_t power = 0, card_state = 0;
1371 uint32_t timeout = 0, card_status = 0, response = 0;
1372
1373 if(buf == NULL)
1374 {
1375 return SD_INVALID_PARAMETER;
1376 }
1377
1378 SDIOx->dtctrl = 0x0;
1379
1380 /* clear dcsm configuration */
1381 sdio_data_init_struct.block_size = (sdio_block_size_type)0;
1382 sdio_data_init_struct.data_length = 0;
1383 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1384 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1385 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1386
1387 sdio_data_config(SDIOx, &sdio_data_init_struct);
1388 sdio_data_state_machine_enable(SDIOx, FALSE);
1389
1390 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1391
1392 /* check card locked */
1393 if(response & SD_CARD_LOCKED)
1394 {
1395 return SD_LOCK_UNLOCK_ERROR;
1396 }
1397
1398 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1399 {
1400 blk_size = 512;
1401 addr >>= 9;
1402 }
1403
1404 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1405 {
1406 power = convert_from_bytes_to_power_of_two(blk_size);
1407
1408 /* send cmd16, set block size */
1409 sdio_command_init_struct.argument = blk_size;
1410 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1411 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1412 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1413
1414 /* sdio command config */
1415 sdio_command_config(SDIOx, &sdio_command_init_struct);
1416 /* enable ccsm */
1417 sdio_command_state_machine_enable(SDIOx, TRUE);
1418
1419 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1420
1421 if(status != SD_OK)
1422 {
1423 return status;
1424 }
1425 }
1426 else
1427 {
1428 return SD_INVALID_PARAMETER;
1429 }
1430
1431 timeout = SD_DATATIMEOUT;
1432
1433 do
1434 {
1435 timeout--;
1436 status = sd_status_send(&card_status);
1437 }
1438 /* check ready_for_data flag */
1439 while(((card_status & 0x00000100) == 0) && (timeout > 0));
1440
1441 if(timeout == 0)
1442 {
1443 return SD_ERROR;
1444 }
1445
1446 /* send cmd24, write single block */
1447 sdio_command_init_struct.argument = addr;
1448 sdio_command_init_struct.cmd_index = SD_CMD_WRITE_SINGLE_BLOCK;
1449 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1450 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1451
1452 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1453 sdio_data_init_struct.data_length = blk_size;
1454 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1455 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1456 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1457
1458 stop_flag = 0;
1459
1460 /* single block, stop command is unnecessary */
1461 status = sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1462
1463 if(status != SD_OK)
1464 {
1465 return status;
1466 }
1467
1468 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1469
1470 status = check_card_programming(&card_state);
1471
1472 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || (card_state == SD_CARD_RECEIVING)))
1473 {
1474 status = check_card_programming(&card_state);
1475 }
1476
1477 return status;
1478}
1479
1489 sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
1490{
1491 sd_error_status_type status = SD_OK;
1492 uint8_t power = 0, card_state = 0;
1493 uint32_t timeout = 0, card_status = 0, response = 0;;
1494
1495 if(buf == NULL)
1496 {
1497 return SD_INVALID_PARAMETER;
1498 }
1499
1500 SDIOx->dtctrl = 0x0;
1501
1502 /* clear dcsm configuration */
1503 sdio_data_init_struct.block_size = (sdio_block_size_type)0;
1504 sdio_data_init_struct.data_length = 0;
1505 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1506 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1507 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1508
1509 sdio_data_config(SDIOx, &sdio_data_init_struct);
1510 sdio_data_state_machine_enable(SDIOx, FALSE);
1511
1512 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1513
1514 /* check card locked */
1515 if(response & SD_CARD_LOCKED)
1516 {
1517 return SD_LOCK_UNLOCK_ERROR;
1518 }
1519
1520 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1521 {
1522 blk_size = 512;
1523 addr >>= 9;
1524 }
1525
1526 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1527 {
1528 power = convert_from_bytes_to_power_of_two(blk_size);
1529
1530 /* send cmd16, set block size */
1531 sdio_command_init_struct.argument = blk_size;
1532 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1533 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1534 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1535
1536 /* sdio command config */
1537 sdio_command_config(SDIOx, &sdio_command_init_struct);
1538 /* enable ccsm */
1539 sdio_command_state_machine_enable(SDIOx, TRUE);
1540
1541 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1542
1543 if(status != SD_OK)
1544 {
1545 return status;
1546 }
1547 }
1548 else
1549 {
1550 return SD_INVALID_PARAMETER;
1551 }
1552
1553 if((nblks * blk_size) > SD_MAX_DATA_LENGTH)
1554 {
1555 return SD_INVALID_PARAMETER;
1556 }
1557
1558 timeout = SD_DATATIMEOUT;
1559
1560 do
1561 {
1562 timeout--;
1563 status = sd_status_send(&card_status);
1564 }
1565 /* check ready_for_data flag */
1566 while(((card_status & 0x00000100) == 0) && (timeout > 0));
1567
1568 if(timeout == 0)
1569 {
1570 return SD_ERROR;
1571 }
1572
1573 if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || \
1574 (card_type == SDIO_HIGH_CAPACITY_SD_CARD))
1575 {
1576 /* send cmd55 */
1577 sdio_command_init_struct.argument = (uint32_t)rca << 16;
1578 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
1579 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1580 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1581
1582 /* sdio command config */
1583 sdio_command_config(SDIOx, &sdio_command_init_struct);
1584 /* enable ccsm */
1585 sdio_command_state_machine_enable(SDIOx, TRUE);
1586
1587 status = command_rsp1_error(SD_CMD_APP_CMD);
1588
1589 if(status != SD_OK)
1590 {
1591 return status;
1592 }
1593
1594 /* send cmd23, set block count */
1595 sdio_command_init_struct.argument = blk_size;
1596 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCK_COUNT;
1597 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1598 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1599
1600 /* sdio command config */
1601 sdio_command_config(SDIOx, &sdio_command_init_struct);
1602 /* enable ccsm */
1603 sdio_command_state_machine_enable(SDIOx, TRUE);
1604
1605 status = command_rsp1_error(SD_CMD_SET_BLOCK_COUNT);
1606
1607 if(status != SD_OK)
1608 {
1609 return status;
1610 }
1611 }
1612
1613 /* send cmd25, write mult blocks */
1614 sdio_command_init_struct.argument = addr;
1615 sdio_command_init_struct.cmd_index = SD_CMD_WRITE_MULT_BLOCK;
1616 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1617 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1618
1619 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1620 sdio_data_init_struct.data_length = nblks * blk_size ;
1621 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1622 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1623 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1624
1625 stop_flag = 1;
1626 /* cmd12 is needed */
1627 status = sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1628
1629 if(status != SD_OK)
1630 {
1631 return status;
1632 }
1633
1634 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1635
1636 status = check_card_programming(&card_state);
1637
1638 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || (card_state == SD_CARD_RECEIVING)))
1639 {
1640 status = check_card_programming(&card_state);
1641 }
1642
1643 return status;
1644}
1645
1653 sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
1654{
1655 uint32_t response = 0;
1656
1657 SDIOx->dtctrl = 0x0;
1658
1659 /* clear dcsm configuration */
1660 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1661 sdio_data_init_struct.data_length = 0 ;
1662 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1663 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1664 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1665
1666 sdio_data_config(SDIOx, &sdio_data_init_struct);
1667 sdio_data_state_machine_enable(SDIOx, FALSE);
1668
1669 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1670
1671 /* check card locked */
1672 if(response & SD_CARD_LOCKED)
1673 {
1674 return SD_LOCK_UNLOCK_ERROR;
1675 }
1676 /* send cmd11, read data */
1677 sdio_command_init_struct.argument = addr;
1678 sdio_command_init_struct.cmd_index = SD_CMD_READ_DAT_UNTIL_STOP;
1679 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1680 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1681
1682 sdio_data_init_struct.block_size = (sdio_block_size_type)(5 << 4);
1683 sdio_data_init_struct.data_length = len;
1684 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1685 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
1686 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1687
1688 stop_flag = 1;
1689 /* cmd12 is needed */
1690 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1691}
1692
1700 sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
1701{
1702 sd_error_status_type status = SD_OK;
1703 uint32_t response = 0;
1704 uint8_t card_state = 0;
1705
1706 if(buf == NULL)
1707 {
1708 return SD_INVALID_PARAMETER;
1709 }
1710
1711 SDIOx->dtctrl = 0x0;
1712
1713 /* clear dcsm configuration */
1714 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1715 sdio_data_init_struct.data_length = 0;
1716 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1717 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1718 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1719
1720 sdio_data_config(SDIOx, &sdio_data_init_struct);
1721 sdio_data_state_machine_enable(SDIOx, FALSE);
1722
1723 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1724
1725 /* check card locked */
1726 if(response & SD_CARD_LOCKED)
1727 {
1728 return SD_LOCK_UNLOCK_ERROR;
1729 }
1730 /* send cmd20, write data */
1731 sdio_command_init_struct.argument = addr;
1732 sdio_command_init_struct.cmd_index = SD_CMD_WRITE_DAT_UNTIL_STOP;
1733 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1734 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1735
1736
1737 sdio_data_init_struct.block_size = (sdio_block_size_type)(15 << 4);
1738 sdio_data_init_struct.data_length = len;
1739 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1740 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1741 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1742
1743 stop_flag = 1;
1744 /* cmd12 is needed */
1745 status = sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1746
1747 if(status != SD_OK)
1748 {
1749 return status;
1750 }
1751
1752 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1753
1754 status = check_card_programming(&card_state);
1755
1756 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || (card_state == SD_CARD_RECEIVING)))
1757 {
1758 status = check_card_programming(&card_state);
1759 }
1760
1761 return status;
1762}
1763
1769void SDIO1_IRQHandler(void)
1770{
1771 sd_irq_service();
1772}
1773
1779void SDIO2_IRQHandler(void)
1780{
1781 sd_irq_service();
1782}
1783
1789 sd_error_status_type sd_irq_service(void)
1790{
1791 if(sdio_flag_get(SDIOx, SDIO_DTCMPL_FLAG) != RESET)
1792 {
1793 if(stop_flag == 1)
1794 {
1795 /* send cmd12, stop transmission */
1796 sdio_command_init_struct.argument = 0;
1797 sdio_command_init_struct.cmd_index = SD_CMD_STOP_TRANSMISSION;
1798 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1799 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1800 /* sdio command config */
1801 sdio_command_config(SDIOx, &sdio_command_init_struct);
1802 /* enable ccsm */
1803 sdio_command_state_machine_enable(SDIOx, TRUE);
1804 transfer_error = command_rsp1_error(SD_CMD_STOP_TRANSMISSION);
1805 }
1806 else
1807 {
1808 transfer_error = SD_OK;
1809 }
1810 /* clear flag */
1811 sdio_flag_clear(SDIOx, SDIO_DTCMPL_FLAG);
1812 transfer_end = 1;
1813 return transfer_error;
1814 }
1815
1816 if(sdio_flag_get(SDIOx, SDIO_DTFAIL_FLAG) != RESET)
1817 {
1818 /* clear flag */
1819 sdio_flag_clear(SDIOx, SDIO_DTFAIL_FLAG);
1820 transfer_error = SD_DATA_FAIL;
1821 transfer_end = 1;
1822 return transfer_error;
1823 }
1824
1825 if(sdio_flag_get(SDIOx, SDIO_DTTIMEOUT_FLAG) != RESET)
1826 {
1827 /* clear flag */
1828 sdio_flag_clear(SDIOx, SDIO_DTTIMEOUT_FLAG);
1829 transfer_error = SD_DATA_TIMEOUT;
1830 transfer_end = 1;
1831 return transfer_error;
1832 }
1833
1834 if(sdio_flag_get(SDIOx, SDIO_RXERRO_FLAG) != RESET)
1835 {
1836 /* clear flag */
1837 sdio_flag_clear(SDIOx, SDIO_RXERRO_FLAG);
1838 transfer_error = SD_RX_OVERRUN;
1839 transfer_end = 1;
1840 return(SD_RX_OVERRUN);
1841 }
1842
1843 if(sdio_flag_get(SDIOx, SDIO_TXERRU_FLAG) != RESET)
1844 {
1845 /* clear flag */
1846 sdio_flag_clear(SDIOx, SDIO_TXERRU_FLAG);
1847 transfer_error = SD_TX_UNDERRUN;
1848 transfer_end = 1;
1849 return(SD_TX_UNDERRUN);
1850 }
1851
1852 if(sdio_flag_get(SDIOx, SDIO_SBITERR_FLAG) != RESET)
1853 {
1854 /* clear flag */
1855 sdio_flag_clear(SDIOx, SDIO_SBITERR_FLAG);
1856 transfer_error = SD_START_BIT_ERR;
1857 transfer_end = 1;
1858 return(SD_START_BIT_ERR);
1859 }
1860
1861 /* disable interrupt */
1862 sdio_interrupt_enable(SDIOx, (SDIO_DTFAIL_INT | SDIO_DTTIMEOUT_INT | \
1863 SDIO_DTCMP_INT | SDIO_TXBUFH_INT | SDIO_RXBUFH_INT | \
1864 SDIO_TXERRU_INT| SDIO_RXERRO_INT | SDIO_SBITERR_INT), FALSE);
1865 return(SD_OK);
1866}
1867
1873 sd_error_status_type command_error(void)
1874{
1875 sd_error_status_type status = SD_OK;
1876 uint32_t timeout = SDIO_CMD0TIMEOUT;
1877
1878 while(timeout--)
1879 {
1880 if(sdio_flag_get(SDIOx, SDIO_CMDCMPL_FLAG) != RESET)
1881 {
1882 break;
1883 }
1884 }
1885
1886 if(timeout == 0)
1887 {
1888 return SD_CMD_RSP_TIMEOUT;
1889 }
1890
1891 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1892 return status;
1893}
1894
1900 sd_error_status_type command_rsp7_error(void)
1901{
1902 sd_error_status_type status = SD_OK;
1903 uint32_t sts_reg = 0;
1904 uint32_t timeout = SDIO_CMD0TIMEOUT;
1905
1906 while(timeout--)
1907 {
1908 sts_reg = SDIOx->sts;
1909
1910 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
1911 {
1912 break;
1913 }
1914 }
1915
1916 if((timeout == 0) || (sts_reg & SDIO_CMDTIMEOUT_FLAG))
1917 {
1918 status = SD_CMD_RSP_TIMEOUT;
1919 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
1920 return status;
1921 }
1922
1923 if(sts_reg & SDIO_CMDRSPCMPL_FLAG)
1924 {
1925 status = SD_OK;
1926 sdio_flag_clear(SDIOx, SDIO_CMDRSPCMPL_FLAG);
1927 }
1928
1929 return status;
1930}
1931
1937 sd_error_status_type command_rsp1_error(uint8_t cmd)
1938{
1939 uint32_t sts_reg = 0;
1940 uint32_t rsp_cmd = 0;
1941
1942 while(1)
1943 {
1944 sts_reg = SDIOx->sts;
1945
1946 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
1947 {
1948 break;
1949 }
1950 }
1951
1952 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
1953 {
1954 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
1955 return SD_CMD_RSP_TIMEOUT;
1956 }
1957
1958 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
1959 {
1960 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
1961 return SD_CMD_FAIL;
1962 }
1963
1964 rsp_cmd = sdio_command_response_get(SDIOx);
1965 if(rsp_cmd != cmd)
1966 {
1967 return SD_ILLEGAL_CMD;
1968 }
1969
1970 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1971
1972 return (sd_error_status_type)(sdio_response_get(SDIOx, SDIO_RSP1_INDEX) & SD_OCR_ERRORBITS);
1973}
1974
1980 sd_error_status_type command_rsp3_error(void)
1981{
1982 uint32_t sts_reg = 0;;
1983
1984 while(1)
1985 {
1986 sts_reg = SDIOx->sts;
1987
1988 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
1989 {
1990 break;
1991 }
1992 }
1993
1994 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
1995 {
1996 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
1997 return SD_CMD_RSP_TIMEOUT;
1998 }
1999
2000 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2001
2002 return SD_OK;
2003}
2004
2010 sd_error_status_type command_rsp2_error(void)
2011{
2012 sd_error_status_type status = SD_OK;
2013 uint32_t sts_reg;
2014 uint32_t timeout = SDIO_CMD0TIMEOUT;
2015
2016 while(timeout--)
2017 {
2018 sts_reg = SDIOx->sts;
2019
2020 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2021 {
2022 break;
2023 }
2024 }
2025
2026 if((timeout == 0) || sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2027 {
2028 status = SD_CMD_RSP_TIMEOUT;
2029 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2030
2031 return status;
2032 }
2033
2034 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2035 {
2036 status = SD_CMD_FAIL;
2037 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2038 }
2039
2040 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2041
2042 return status;
2043}
2044
2050 sd_error_status_type command_rsp4_error(uint8_t cmd)
2051{
2052 uint32_t sts_reg = 0, rsp_cmd = 0;
2053
2054 while(1)
2055 {
2056 sts_reg = SDIOx->sts;
2057
2058 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2059 {
2060 break;
2061 }
2062 }
2063
2064 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2065 {
2066 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2067 return SD_CMD_RSP_TIMEOUT;
2068 }
2069
2070 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2071 {
2072 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2073
2074 return SD_CMD_FAIL;
2075 }
2076
2077 rsp_cmd = sdio_command_response_get(SDIOx);
2078 if(rsp_cmd != cmd)
2079 {
2080 return SD_ILLEGAL_CMD;
2081 }
2082
2083 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2084
2085 return SD_OK;
2086}
2087
2093 sd_error_status_type command_rsp5_error(uint8_t cmd)
2094{
2095 uint32_t sts_reg = 0, rsp_cmd = 0, response = 0;
2096
2097 while(1)
2098 {
2099 sts_reg = SDIOx->sts;
2100
2101 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2102 {
2103 break;
2104 }
2105 }
2106
2107 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2108 {
2109 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2110
2111 return SD_CMD_RSP_TIMEOUT;
2112 }
2113
2114 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2115 {
2116 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2117
2118 return SD_CMD_FAIL;
2119 }
2120
2121 rsp_cmd = sdio_command_response_get(SDIOx);
2122 if(rsp_cmd != cmd)
2123 {
2124 return SD_ILLEGAL_CMD;
2125 }
2126
2127 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2128
2129 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2130
2131 if(response & SD_R5_OUT_OF_RANGE)
2132 {
2133 return SD_CMD_OUT_OF_RANGE;
2134 }
2135
2136 if(response & SD_R5_FUNCTION_NUMBER)
2137 {
2138 return SD_SDIO_UNKNOWN_FUNC;
2139 }
2140
2141 if(response & SD_R5_ERROR)
2142 {
2143 return SD_GENERAL_UNKNOWN_ERROR;
2144 }
2145
2146 return SD_OK;
2147}
2148
2156 sd_error_status_type command_rsp6_error(uint8_t cmd, uint16_t *prca)
2157{
2158 sd_error_status_type status = SD_OK;
2159 uint32_t sts_reg, rsp_cmd = 0, response = 0;
2160
2161 while(1)
2162 {
2163 sts_reg = SDIOx->sts;
2164
2165 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2166 {
2167 break;
2168 }
2169 }
2170
2171 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2172 {
2173 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2174 return SD_CMD_RSP_TIMEOUT;
2175 }
2176
2177 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2178 {
2179 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2180 return SD_CMD_FAIL;
2181 }
2182
2183 rsp_cmd = sdio_command_response_get(SDIOx);
2184 if(rsp_cmd != cmd)
2185 {
2186 return SD_ILLEGAL_CMD;
2187 }
2188
2189 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2190
2191 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2192
2193 if(SD_ALLZERO == (response & (SD_R6_GENERAL_UNKNOWN_ERROR | SD_R6_ILLEGAL_CMD | SD_R6_CMD_CRC_ERROR)))
2194 {
2195 *prca = (uint16_t)(response >> 16);
2196 return status;
2197 }
2198
2199 if(response & SD_R6_GENERAL_UNKNOWN_ERROR)
2200 {
2201 return SD_GENERAL_UNKNOWN_ERROR;
2202 }
2203
2204 if(response & SD_R6_ILLEGAL_CMD)
2205 {
2206 return SD_ILLEGAL_CMD;
2207 }
2208
2209 if(response & SD_R6_CMD_CRC_ERROR)
2210 {
2211 return SD_CMD_CRC_ERROR;
2212 }
2213
2214 return status;
2215}
2216
2222 sd_error_status_type sd_bus_wide_enable(confirm_state new_state)
2223{
2224 sd_error_status_type status = SD_OK;
2225 uint32_t response = 0;
2226 uint8_t arg = 0x00;
2227
2228 if(new_state == TRUE)
2229 {
2230 arg = 0x02;
2231 }
2232 else
2233 {
2234 arg = 0x00;
2235 }
2236
2237 /* get response1 */
2238 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2239
2240 /* check card locked or not */
2241 if(response & SD_CARD_LOCKED)
2242 {
2243 return SD_LOCK_UNLOCK_ERROR;
2244 }
2245
2246 if(sd_card_info.sd_scr_reg.sd_bus_width)
2247 {
2248 sdio_command_init_struct.argument = (uint32_t)(sd_card_info.rca << 16);
2249 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
2250 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2251 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2252
2253 /* sdio command config */
2254 sdio_command_config(SDIOx, &sdio_command_init_struct);
2255 /* enable ccsm */
2256 sdio_command_state_machine_enable(SDIOx, TRUE);
2257
2258 status = command_rsp1_error(SD_CMD_APP_CMD);
2259
2260 if(status != SD_OK)
2261 {
2262 return status;
2263 }
2264
2265 sdio_command_init_struct.argument = arg;
2266 sdio_command_init_struct.cmd_index = SD_CMD_APP_SD_SET_BUSWIDTH;
2267 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2268 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2269
2270 /* sdio command config */
2271 sdio_command_config(SDIOx, &sdio_command_init_struct);
2272 /* enable ccsm */
2273 sdio_command_state_machine_enable(SDIOx, TRUE);
2274
2275 status = command_rsp1_error(SD_CMD_APP_SD_SET_BUSWIDTH);
2276 return status;
2277 }
2278 else
2279 {
2280 return SD_REQ_NOT_APPLICABLE;
2281 }
2282}
2283
2291 sd_error_status_type mmc_switch(uint8_t set, uint8_t index, uint8_t value)
2292{
2293 sd_error_status_type status = SD_OK;
2294 uint32_t card_status = 0, timeout = 0;
2295
2296 sdio_command_init_struct.argument = (EXT_CSD_Write_byte << 24) | (index << 16) | (value << 8) | set;
2297 sdio_command_init_struct.cmd_index = SD_CMD_HS_SWITCH;
2298 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2299 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2300
2301 /* sdio command config */
2302 sdio_command_config(SDIOx, &sdio_command_init_struct);
2303 /* enable ccsm */
2304 sdio_command_state_machine_enable(SDIOx, TRUE);
2305
2306 status = command_rsp1_error(SD_CMD_HS_SWITCH);
2307 if(status != SD_OK)
2308 {
2309 return status;
2310 }
2311
2312 card_status = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2313 if(card_status & MMC_SWITCH_ERROR)
2314 {
2315 return SD_SWITCH_ERROR;
2316 }
2317
2318 timeout = SD_DATATIMEOUT;
2319 do
2320 {
2321 timeout--;
2322 status = sd_status_send(&card_status);
2323 } /* check ready_for_data flag */
2324 while(((card_status & 0x00000100) == 0) && (timeout > 0));
2325
2326 if(timeout == 0)
2327 {
2328 return SD_ERROR;
2329 }
2330
2331 return status;
2332}
2333
2342 sd_error_status_type sd_switch(uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
2343{
2344 sd_error_status_type status = SD_OK;
2345 uint8_t power;
2346 uint16_t blk_size;
2347
2348 if(rsp == NULL)
2349 {
2350 return SD_INVALID_PARAMETER;
2351 }
2352
2353 SDIOx->dtctrl = 0x0;
2354
2355 blk_size = 64;
2356 power = convert_from_bytes_to_power_of_two(blk_size);
2357
2358 sdio_command_init_struct.argument = blk_size;
2359 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
2360 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2361 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2362
2363 /* sdio command config */
2364 sdio_command_config(SDIOx, &sdio_command_init_struct);
2365 /* enable ccsm */
2366 sdio_command_state_machine_enable(SDIOx, TRUE);
2367
2368 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
2369
2370 if(status != SD_OK)
2371 {
2372 return status;
2373 }
2374
2375 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
2376 sdio_data_init_struct.data_length = blk_size ;
2377 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
2378 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
2379 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
2380
2381 sdio_command_init_struct.argument = (mode << 31) | 0x00FFFFFF;
2382 sdio_command_init_struct.argument &= ~(0xF << (group * 4));
2383 sdio_command_init_struct.argument |= value << (group * 4);
2384 sdio_command_init_struct.cmd_index = SD_CMD_HS_SWITCH;
2385 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2386 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2387
2388 stop_flag = 0;
2389
2390 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)rsp);
2391}
2392
2398 sd_error_status_type check_card_programming(uint8_t *p_status)
2399{
2400 volatile uint32_t response = 0, sts_reg = 0, rsp_cmd = 0;
2401
2402 /* send cmd13 */
2403 sdio_command_init_struct.argument = (uint32_t)(rca << 16);
2404 sdio_command_init_struct.cmd_index = SD_CMD_SEND_STATUS;
2405 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2406 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2407
2408 /* sdio command config */
2409 sdio_command_config(SDIOx, &sdio_command_init_struct);
2410 /* enable ccsm */
2411 sdio_command_state_machine_enable(SDIOx, TRUE);
2412
2413 sts_reg = SDIOx->sts;
2414
2415 while(!(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG)))
2416 {
2417 sts_reg = SDIOx->sts;
2418 }
2419
2420 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2421 {
2422 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2423 return SD_CMD_FAIL;
2424 }
2425
2426 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2427 {
2428 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2429 return SD_CMD_RSP_TIMEOUT;
2430 }
2431
2432 rsp_cmd = sdio_command_response_get(SDIOx);
2433 if(rsp_cmd!= SD_CMD_SEND_STATUS)
2434 {
2435 return SD_ILLEGAL_CMD;
2436 }
2437
2438 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2439
2440 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2441
2442 *p_status = (uint8_t)((response >> 9) & 0x0000000F);
2443
2444 return SD_OK;
2445}
2446
2452 sd_error_status_type sd_status_send(uint32_t *p_card_status)
2453{
2454 sd_error_status_type status = SD_OK;
2455
2456 if(p_card_status == NULL)
2457 {
2458 status = SD_INVALID_PARAMETER;
2459 return status;
2460 }
2461
2462 sdio_command_init_struct.argument = (uint32_t)(rca << 16);
2463 sdio_command_init_struct.cmd_index = SD_CMD_SEND_STATUS;
2464 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2465 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2466
2467 /* sdio command config */
2468 sdio_command_config(SDIOx, &sdio_command_init_struct);
2469 /* enable ccsm */
2470 sdio_command_state_machine_enable(SDIOx, TRUE);
2471
2472 status = command_rsp1_error(SD_CMD_SEND_STATUS);
2473
2474 if(status != SD_OK)
2475 {
2476 return status;
2477 }
2478
2479 *p_card_status = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2480
2481 return status;
2482}
2483
2489 sd_card_state_type sd_state_get(void)
2490{
2491 uint32_t response = 0;
2492
2493 if(sd_status_send(&response) != SD_OK)
2494 {
2495 return SD_CARD_ERROR;
2496 }
2497 else
2498 {
2499 return (sd_card_state_type)((response >> 9) & 0x0F);
2500 }
2501}
2502
2507 sd_error_status_type scr_find(void)
2508{
2509 uint32_t index = 0, sts_reg = 0;
2510 sd_error_status_type status = SD_OK;
2511 uint32_t *tempscr;
2512
2513 tempscr = (uint32_t *) &(sd_card_info.sd_scr_reg);
2514
2515 /* send cmd16, set block length */
2516 sdio_command_init_struct.argument = (uint32_t)8;
2517 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
2518 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2519 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2520
2521 /* sdio command config */
2522 sdio_command_config(SDIOx, &sdio_command_init_struct);
2523 /* enable ccsm */
2524 sdio_command_state_machine_enable(SDIOx, TRUE);
2525
2526 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
2527
2528 if(status != SD_OK)
2529 {
2530 return status;
2531 }
2532
2533 /* send cmd55 */
2534 sdio_command_init_struct.argument = (uint32_t)(sd_card_info.rca << 16);
2535 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
2536 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2537 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2538
2539 /* sdio command config */
2540 sdio_command_config(SDIOx, &sdio_command_init_struct);
2541 /* enable ccsm */
2542 sdio_command_state_machine_enable(SDIOx, TRUE);
2543
2544 status = command_rsp1_error(SD_CMD_APP_CMD);
2545
2546 if(status != SD_OK)
2547 {
2548 return status;
2549 }
2550
2551 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_8B;
2552 sdio_data_init_struct.data_length = 8;
2553 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
2554 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
2555 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
2556
2557 sdio_data_config(SDIOx, &sdio_data_init_struct);
2558 sdio_data_state_machine_enable(SDIOx, TRUE);
2559
2560 /* send cmd51 */
2561 sdio_command_init_struct.argument = 0x0;
2562 sdio_command_init_struct.cmd_index = SD_CMD_SD_APP_SEND_SCR;
2563 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2564 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2565
2566 /* sdio command config */
2567 sdio_command_config(SDIOx, &sdio_command_init_struct);
2568 /* enable ccsm */
2569 sdio_command_state_machine_enable(SDIOx, TRUE);
2570
2571 status = command_rsp1_error(SD_CMD_SD_APP_SEND_SCR);
2572
2573 if(status != SD_OK)
2574 {
2575 return status;
2576 }
2577
2578 sts_reg = SDIOx->sts;
2579
2580 while(!(sts_reg & (SDIO_RXERRO_FLAG | SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_DTBLKCMPL_FLAG | SDIO_SBITERR_FLAG)))
2581 {
2582 if(sdio_flag_get(SDIOx, SDIO_RXBUF_FLAG) != RESET)
2583 {
2584 *(tempscr + index) = sdio_data_read(SDIOx);
2585 index++;
2586 }
2587 sts_reg = SDIOx->sts;
2588 }
2589
2590 if(sdio_flag_get(SDIOx, SDIO_DTTIMEOUT_FLAG) != RESET)
2591 {
2592 sdio_flag_clear(SDIOx, SDIO_DTTIMEOUT_FLAG);
2593 return SD_DATA_TIMEOUT;
2594 }
2595 else if(sdio_flag_get(SDIOx, SDIO_DTFAIL_FLAG) != RESET)
2596 {
2597 sdio_flag_clear(SDIOx, SDIO_DTFAIL_FLAG);
2598 return SD_DATA_FAIL;
2599 }
2600 else if(sdio_flag_get(SDIOx, SDIO_RXERRO_FLAG) != RESET)
2601 {
2602 sdio_flag_clear(SDIOx, SDIO_RXERRO_FLAG);
2603 return SD_RX_OVERRUN;
2604 }
2605 else if(sdio_flag_get(SDIOx, SDIO_SBITERR_FLAG) != RESET)
2606 {
2607 sdio_flag_clear(SDIOx, SDIO_SBITERR_FLAG);
2608 return SD_START_BIT_ERR;
2609 }
2610
2611 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2612
2613 return status;
2614}
2615
2621 sd_error_status_type speed_change(uint8_t speed)
2622{
2623 sd_error_status_type status = SD_OK;
2624 uint8_t switch_sts[64];
2625
2626 if(speed > 1)
2627 {
2628 return SD_ERROR;
2629 }
2630
2631 /* check card type */
2632 if((SDIO_STD_CAPACITY_SD_CARD_V1_1 == card_type) || (SDIO_STD_CAPACITY_SD_CARD_V2_0 == card_type) || \
2633 (SDIO_HIGH_CAPACITY_SD_CARD == card_type))
2634 {
2635 /* version 1.01 card does not support cmd6 */
2636 if(sd_card_info.sd_scr_reg.sd_spec == 0)
2637 {
2638 return SD_ERROR;
2639 }
2640
2641 /* check group 1 function support speed */
2642 status = sd_switch(0, 0, speed, switch_sts);
2643
2644 if(status != 0)
2645 {
2646 return status;
2647 }
2648
2649 if((switch_sts[13] & (1 << speed)) == 0)
2650 {
2651 return SD_ERROR;
2652 }
2653
2654 status = sd_switch(1, 0, speed, switch_sts);
2655
2656 if(status != 0)
2657 {
2658 return status;
2659 }
2660
2661 /* read it back for confirmation */
2662 if((switch_sts[16] & 0xF) != speed)
2663 {
2664 return SD_ERROR;
2665 }
2666 }
2667 else if(card_type == SDIO_HIGH_SPEED_MULTIMEDIA_CARD)
2668 {
2669 status = mmc_switch(EXT_CSD_CMD_SET_NORMAL, EXT_CSD_BUS_WIDTH, (uint8_t)speed);
2670
2671 if(status != 0)
2672 {
2673 return status;
2674 }
2675 }
2676
2677 return status;
2678}
2679
2685uint8_t convert_from_bytes_to_power_of_two(uint16_t number_of_bytes)
2686{
2687 uint8_t count = 0;
2688
2689 while(number_of_bytes != 1)
2690 {
2691 number_of_bytes >>= 1;
2692 count++;
2693 }
2694
2695 return count;
2696}
2697
2706void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
2707{
2708 dma_init_type dma_init_struct;
2709 dma_default_para_init(&dma_init_struct);
2710
2711 crm_periph_clock_enable(CRM_DMA2_PERIPH_CLOCK, TRUE);
2712
2713 dma_reset(DMA2_CHANNEL4);
2714 dma_channel_enable(DMA2_CHANNEL4, FALSE);
2715
2716 dma_init_struct.peripheral_base_addr = (uint32_t)&SDIOx->buf;
2717 dma_init_struct.memory_base_addr = (uint32_t)mbuf;
2718 dma_init_struct.direction = dir;
2719 dma_init_struct.buffer_size = buf_size / 4;
2720 dma_init_struct.peripheral_inc_enable = FALSE;
2721 dma_init_struct.memory_inc_enable = TRUE;
2722 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_WORD;
2723 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_WORD;
2724 dma_init_struct.loop_mode_enable = FALSE;
2725 dma_init_struct.priority = DMA_PRIORITY_HIGH;
2726 dma_init(DMA2_CHANNEL4, &dma_init_struct);
2727
2728 dmamux_init(DMA2MUX_CHANNEL4, DMAMUX_SDIOx);
2729 dmamux_enable(DMA2, TRUE);
2730 dma_channel_enable(DMA2_CHANNEL4, TRUE);
2731}
2732
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
sd_card_info
sd_card_info_struct_type sd_card_info
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:48
sd_switch
sd_error_status_type sd_switch(uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
switch sd card speed to high speed
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2342
command_rsp5_error
sd_error_status_type command_rsp5_error(uint8_t cmd)
checks for error conditions for r5 response.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2093
speed_change
sd_error_status_type speed_change(uint8_t speed)
set bus speed
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2621
sdio_data_init_struct
sdio_data_struct_type sdio_data_init_struct
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:40
transfer_end
volatile uint8_t transfer_end
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:47
command_rsp7_error
sd_error_status_type command_rsp7_error(void)
checks for error conditions for R7 response.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1900
card_type
static sd_memory_card_type card_type
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:42
convert_from_bytes_to_power_of_two
uint8_t convert_from_bytes_to_power_of_two(uint16_t number_of_bytes)
converts the number of bytes in power of two and returns the power.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2685
sdio_command_init_struct
sdio_command_struct_type sdio_command_init_struct
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:39
command_rsp6_error
sd_error_status_type command_rsp6_error(uint8_t cmd, uint16_t *p_rca)
checks for error conditions for r6 (rca) response.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2156
SDIO1_IRQHandler
void SDIO1_IRQHandler(void)
sdio1 isr.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1769
stop_flag
static uint8_t stop_flag
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:45
mmc_switch
sd_error_status_type mmc_switch(uint8_t set, uint8_t index, uint8_t value)
switch mmc card speed to high speed
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2291
check_card_programming
sd_error_status_type check_card_programming(uint8_t *p_status)
checks if the sd card is in programming state.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2398
transfer_error
volatile sd_error_status_type transfer_error
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:46
sd_bus_wide_enable
sd_error_status_type sd_bus_wide_enable(confirm_state new_state)
enable or disable the sdio wide bus mode.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2222
command_rsp1_error
sd_error_status_type command_rsp1_error(uint8_t cmd)
checks for error conditions for R1 response.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1937
SDIO2_IRQHandler
void SDIO2_IRQHandler(void)
sdio2 isr.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1779
csd_table
static uint32_t csd_table[4]
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:43
cid_table
static uint32_t cid_table[4]
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:43
device_mode
static sd_data_transfer_mode_type device_mode
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:44
sdio_command_data_send
sd_error_status_type sdio_command_data_send(sdio_command_struct_type *sdio_cmd_init_t, sdio_data_struct_type *sdio_data_init_t, uint32_t *buf)
read data from or write data to sd card.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:830
command_rsp2_error
sd_error_status_type command_rsp2_error(void)
checks for error conditions for R2 (cid or csd) response.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2010
scr_find
sd_error_status_type scr_find(void)
find the sd card scr register value.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2507
command_rsp4_error
sd_error_status_type command_rsp4_error(uint8_t cmd)
checks for error conditions for r4 response.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2050
rca
static uint32_t rca
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:43
command_rsp3_error
sd_error_status_type command_rsp3_error(void)
checks for error conditions for R3 (ocr) response.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1980
command_error
sd_error_status_type command_error(void)
checks for error conditions for cmd0.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1873
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
system_core_clock
unsigned int system_core_clock
Definition: system_at32f435_437.c:48
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_SDIO1_PERIPH_CLOCK
@ CRM_SDIO1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:121
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_DMA2_PERIPH_CLOCK
@ CRM_DMA2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:116
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f435_437_dma.h:151
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:164
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:174
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMA2MUX_CHANNEL4
#define DMA2MUX_CHANNEL4
Definition: at32f435_437_dma.h:729
DMA2
#define DMA2
Definition: at32f435_437_dma.h:717
DMA2_CHANNEL4
#define DMA2_CHANNEL4
Definition: at32f435_437_dma.h:721
confirm_state
confirm_state
Definition: at32f435_437.h:379
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
SDIO_SEND_IF_COND
#define SDIO_SEND_IF_COND
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:441
SD_CMD_SD_APP_SEND_SCR
#define SD_CMD_SD_APP_SEND_SCR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:311
SD_CMD_ERASE
#define SD_CMD_ERASE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:294
SD_CMD_APP_SD_SET_BUSWIDTH
#define SD_CMD_APP_SD_SET_BUSWIDTH
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:306
SD_CMD_WRITE_SINGLE_BLOCK
#define SD_CMD_WRITE_SINGLE_BLOCK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:283
SD_CMD_SD_ERASE_GRP_START
#define SD_CMD_SD_ERASE_GRP_START
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:290
SD_CMD_APP_CMD
#define SD_CMD_APP_CMD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:298
SD_CMD_ALL_SEND_CID
#define SD_CMD_ALL_SEND_CID
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:263
SD_CMD_STOP_TRANSMISSION
#define SD_CMD_STOP_TRANSMISSION
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:273
SD_CMD_SEND_STATUS
#define SD_CMD_SEND_STATUS
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:274
SD_CMD_SET_BLOCK_COUNT
#define SD_CMD_SET_BLOCK_COUNT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:282
SD_CMD_WRITE_DAT_UNTIL_STOP
#define SD_CMD_WRITE_DAT_UNTIL_STOP
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:281
SD_CMD_SEND_OP_COND
#define SD_CMD_SEND_OP_COND
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:262
SD_CMD_SET_BLOCKLEN
#define SD_CMD_SET_BLOCKLEN
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:277
SD_CMD_HS_SWITCH
#define SD_CMD_HS_SWITCH
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:267
SD_CMD_READ_SINGLE_BLOCK
#define SD_CMD_READ_SINGLE_BLOCK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:278
SD_CMD_SD_APP_OP_COND
#define SD_CMD_SD_APP_OP_COND
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:309
SD_CMD_GO_IDLE_STATE
#define SD_CMD_GO_IDLE_STATE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:261
SD_CMD_SET_REL_ADDR
#define SD_CMD_SET_REL_ADDR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:264
SD_CMD_ERASE_GRP_END
#define SD_CMD_ERASE_GRP_END
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:293
SD_CMD_READ_DAT_UNTIL_STOP
#define SD_CMD_READ_DAT_UNTIL_STOP
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:272
SD_CMD_SD_ERASE_GRP_END
#define SD_CMD_SD_ERASE_GRP_END
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:291
SD_CMD_ERASE_GRP_START
#define SD_CMD_ERASE_GRP_START
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:292
SD_CMD_SEL_DESEL_CARD
#define SD_CMD_SEL_DESEL_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:268
SD_CMD_WRITE_MULT_BLOCK
#define SD_CMD_WRITE_MULT_BLOCK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:284
SD_CMD_READ_MULT_BLOCK
#define SD_CMD_READ_MULT_BLOCK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:279
SD_CMD_SEND_CSD
#define SD_CMD_SEND_CSD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:270
sdio_command_config
void sdio_command_config(sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command.
Definition: at32f435_437_sdio.c:329
sdio_data_write
void sdio_data_write(sdio_type *sdio_x, uint32_t data)
write one word data to fifo.
Definition: at32f435_437_sdio.c:490
sdio_data_config
void sdio_data_config(sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data.
Definition: at32f435_437_sdio.c:416
sd_power_off
sd_error_status_type sd_power_off(void)
turns the sdio output signals off.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:403
sd_irq_service
sd_error_status_type sd_irq_service(void)
allows to process all the interrupts that are high.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1789
sd_device_mode_set
sd_error_status_type sd_device_mode_set(uint32_t mode)
set sdio work mode.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:786
sdio_data_read
uint32_t sdio_data_read(sdio_type *sdio_x)
read a word data from sdio fifo.
Definition: at32f435_437_sdio.c:465
sd_card_info_get
sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info)
returns information about specific card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:532
sdio_command_state_machine_enable
void sdio_command_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM).
Definition: at32f435_437_sdio.c:352
sdio_clock_bypass
void sdio_clock_bypass(sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss
Definition: at32f435_437_sdio.c:141
mmc_stream_write
sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1700
sd_card_init
sd_error_status_type sd_card_init(void)
intialises all cards or single card as the case may be card(s) come into standby state.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:417
sd_block_read
sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma ...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1188
sd_deselect_select
sd_error_status_type sd_deselect_select(uint32_t addr)
selects od deselects the corresponding card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:807
sdio_flow_control_enable
void sdio_flow_control_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control.
Definition: at32f435_437_sdio.c:168
sdio_power_set
void sdio_power_set(sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller
Definition: at32f435_437_sdio.c:75
sdio_clock_config
void sdio_clock_config(sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock
Definition: at32f435_437_sdio.c:104
sdio_clock_set
void sdio_clock_set(uint32_t clkdiv)
set sdio clock devision factor.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:188
sdio_bus_width_config
void sdio_bus_width_config(sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width
Definition: at32f435_437_sdio.c:128
sd_blocks_erase
sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks)
erase continuous data block
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1030
sdio_interrupt_enable
void sdio_interrupt_enable(sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt.
Definition: at32f435_437_sdio.c:232
sdio_flag_clear
void sdio_flag_clear(sdio_type *sdio_x, uint32_t flag)
clear sdio flag.
Definition: at32f435_437_sdio.c:315
sdio_power_status_get
sdio_power_state_type sdio_power_status_get(sdio_type *sdio_x)
get power status.
Definition: at32f435_437_sdio.c:87
sd_mult_blocks_write
sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed ...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1489
sdio_response_get
uint32_t sdio_response_get(sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command.
Definition: at32f435_437_sdio.c:383
sdio_data_state_machine_enable
void sdio_data_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM).
Definition: at32f435_437_sdio.c:441
sdio_power_saving_mode_enable
void sdio_power_saving_mode_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle.
Definition: at32f435_437_sdio.c:155
sd_state_get
sd_card_state_type sd_state_get(void)
returns information about sd card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:2489
sdio_flag_get
flag_status sdio_flag_get(sdio_type *sdio_x, uint32_t flag)
get sdio flag.
Definition: at32f435_437_sdio.c:278
sdio_dma_enable
void sdio_dma_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable dma.
Definition: at32f435_437_sdio.c:194
sd_dma_config
void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:2706
sd_block_write
sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be manag...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1367
sd_status_send
sd_error_status_type sd_status_send(uint32_t *p_card_status)
read current card status.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:2452
sd_init
sd_error_status_type sd_init(void)
initializes the sd card and put it into standby state (ready for data transfer).
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:72
mmc_stream_read
sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1653
sd_power_on
sd_error_status_type sd_power_on(void)
enquires cards about their operating voltage and configures clock controls.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:203
sdio_reset
void sdio_reset(sdio_type *sdio_x)
reset the sdio register
Definition: at32f435_437_sdio.c:51
sd_mult_blocks_read
sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mod...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1277
sdio_clock_enable
void sdio_clock_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output.
Definition: at32f435_437_sdio.c:181
sd_wide_bus_operation_config
sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:743
sdio_command_response_get
uint8_t sdio_command_response_get(sdio_type *sdio_x)
get command index of last command for which response received.
Definition: at32f435_437_sdio.c:365
sd_data_transfer_mode_type
sd_data_transfer_mode_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:66
sd_error_status_type
sd_error_status_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:75
sd_card_state_type
sd_card_state_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:188
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f435_437_sdio.h:139
sd_memory_card_type
sd_memory_card_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:204
sdio_block_size_type
sdio_block_size_type
sdio data block size
Definition: at32f435_437_sdio.h:180
SDIO_WAIT_FOR_NO
@ SDIO_WAIT_FOR_NO
Definition: at32f435_437_sdio.h:160
SDIO_WAIT_FOR_INT
@ SDIO_WAIT_FOR_INT
Definition: at32f435_437_sdio.h:161
SDIO_RESPONSE_LONG
@ SDIO_RESPONSE_LONG
Definition: at32f435_437_sdio.h:152
SDIO_RESPONSE_SHORT
@ SDIO_RESPONSE_SHORT
Definition: at32f435_437_sdio.h:151
SDIO_RESPONSE_NO
@ SDIO_RESPONSE_NO
Definition: at32f435_437_sdio.h:150
SD_TRANSFER_DMA_MODE
@ SD_TRANSFER_DMA_MODE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:68
SD_TRANSFER_POLLING_MODE
@ SD_TRANSFER_POLLING_MODE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:67
SD_ERROR
@ SD_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:119
SD_SDIO_UNKNOWN_FUNC
@ SD_SDIO_UNKNOWN_FUNC
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:109
SD_DATA_FAIL
@ SD_DATA_FAIL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:78
SD_INVALID_PARAMETER
@ SD_INVALID_PARAMETER
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:116
SD_CMD_FAIL
@ SD_CMD_FAIL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:77
SD_CMD_OUT_OF_RANGE
@ SD_CMD_OUT_OF_RANGE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:84
SD_GENERAL_UNKNOWN_ERROR
@ SD_GENERAL_UNKNOWN_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:95
SD_UNSUPPORTED_FEATURE
@ SD_UNSUPPORTED_FEATURE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:117
SD_TX_UNDERRUN
@ SD_TX_UNDERRUN
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:81
SD_ILLEGAL_CMD
@ SD_ILLEGAL_CMD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:92
SD_CMD_CRC_ERROR
@ SD_CMD_CRC_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:91
SD_RX_OVERRUN
@ SD_RX_OVERRUN
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:82
SD_REQ_NOT_APPLICABLE
@ SD_REQ_NOT_APPLICABLE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:115
SD_SWITCH_ERROR
@ SD_SWITCH_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:105
SD_INVALID_VOLTRANGE
@ SD_INVALID_VOLTRANGE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:103
SD_DATA_TIMEOUT
@ SD_DATA_TIMEOUT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:80
SD_START_BIT_ERR
@ SD_START_BIT_ERR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:83
SD_LOCK_UNLOCK_ERROR
@ SD_LOCK_UNLOCK_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:90
SD_CMD_RSP_TIMEOUT
@ SD_CMD_RSP_TIMEOUT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:79
SD_OK
@ SD_OK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:120
SDIO_CLOCK_EDGE_FALLING
@ SDIO_CLOCK_EDGE_FALLING
Definition: at32f435_437_sdio.h:132
SDIO_DATA_TRANSFER_TO_CARD
@ SDIO_DATA_TRANSFER_TO_CARD
Definition: at32f435_437_sdio.h:212
SDIO_DATA_TRANSFER_TO_CONTROLLER
@ SDIO_DATA_TRANSFER_TO_CONTROLLER
Definition: at32f435_437_sdio.h:213
SDIO_POWER_OFF
@ SDIO_POWER_OFF
Definition: at32f435_437_sdio.h:122
SDIO_POWER_ON
@ SDIO_POWER_ON
Definition: at32f435_437_sdio.h:123
SD_CARD_ERROR
@ SD_CARD_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:197
SDIO_DATA_BLOCK_TRANSFER
@ SDIO_DATA_BLOCK_TRANSFER
Definition: at32f435_437_sdio.h:203
SDIO_DATA_STREAM_TRANSFER
@ SDIO_DATA_STREAM_TRANSFER
Definition: at32f435_437_sdio.h:204
SDIO_BUS_WIDTH_D1
@ SDIO_BUS_WIDTH_D1
Definition: at32f435_437_sdio.h:140
SDIO_BUS_WIDTH_D4
@ SDIO_BUS_WIDTH_D4
Definition: at32f435_437_sdio.h:141
SDIO_RSP3_INDEX
@ SDIO_RSP3_INDEX
Definition: at32f435_437_sdio.h:172
SDIO_RSP2_INDEX
@ SDIO_RSP2_INDEX
Definition: at32f435_437_sdio.h:171
SDIO_RSP4_INDEX
@ SDIO_RSP4_INDEX
Definition: at32f435_437_sdio.h:173
SDIO_RSP1_INDEX
@ SDIO_RSP1_INDEX
Definition: at32f435_437_sdio.h:170
SDIO_HIGH_CAPACITY_SD_CARD
@ SDIO_HIGH_CAPACITY_SD_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:207
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
@ SDIO_SECURE_DIGITAL_IO_COMBO_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:211
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
@ SDIO_HIGH_SPEED_MULTIMEDIA_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:210
SDIO_STD_CAPACITY_SD_CARD_V1_1
@ SDIO_STD_CAPACITY_SD_CARD_V1_1
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:205
SDIO_SECURE_DIGITAL_IO_CARD
@ SDIO_SECURE_DIGITAL_IO_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:209
SDIO_STD_CAPACITY_SD_CARD_V2_0
@ SDIO_STD_CAPACITY_SD_CARD_V2_0
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:206
SDIO_MULTIMEDIA_CARD
@ SDIO_MULTIMEDIA_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:208
SDIO_DATA_BLOCK_SIZE_8B
@ SDIO_DATA_BLOCK_SIZE_8B
Definition: at32f435_437_sdio.h:184
SDIO_DATA_BLOCK_SIZE_1B
@ SDIO_DATA_BLOCK_SIZE_1B
Definition: at32f435_437_sdio.h:181
SDIO_CMDTIMEOUT_FLAG
#define SDIO_CMDTIMEOUT_FLAG
Definition: at32f435_437_sdio.h:87
SDIO_TXBUFH_FLAG
#define SDIO_TXBUFH_FLAG
Definition: at32f435_437_sdio.h:99
SDIO_CMDCMPL_FLAG
#define SDIO_CMDCMPL_FLAG
Definition: at32f435_437_sdio.h:92
SDIO_DTFAIL_FLAG
#define SDIO_DTFAIL_FLAG
Definition: at32f435_437_sdio.h:86
SDIO_RXERRO_FLAG
#define SDIO_RXERRO_FLAG
Definition: at32f435_437_sdio.h:90
SDIO_RXBUFH_FLAG
#define SDIO_RXBUFH_FLAG
Definition: at32f435_437_sdio.h:100
SDIO_RXBUF_FLAG
#define SDIO_RXBUF_FLAG
Definition: at32f435_437_sdio.h:106
SDIO_CMDFAIL_FLAG
#define SDIO_CMDFAIL_FLAG
Definition: at32f435_437_sdio.h:85
SDIO_CMDRSPCMPL_FLAG
#define SDIO_CMDRSPCMPL_FLAG
Definition: at32f435_437_sdio.h:91
SDIO_DTBLKCMPL_FLAG
#define SDIO_DTBLKCMPL_FLAG
Definition: at32f435_437_sdio.h:95
SDIO_DTTIMEOUT_FLAG
#define SDIO_DTTIMEOUT_FLAG
Definition: at32f435_437_sdio.h:88
SDIO_SBITERR_FLAG
#define SDIO_SBITERR_FLAG
Definition: at32f435_437_sdio.h:94
SDIO_DTCMPL_FLAG
#define SDIO_DTCMPL_FLAG
Definition: at32f435_437_sdio.h:93
SDIO_TXERRU_FLAG
#define SDIO_TXERRU_FLAG
Definition: at32f435_437_sdio.h:89
DMAMUX_SDIOx
#define DMAMUX_SDIOx
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:52
SDIOx
#define SDIOx
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:51
SDIO_INTR_STS_WRITE_MASK
#define SDIO_INTR_STS_WRITE_MASK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:477
SDIO_INTR_STS_READ_MASK
#define SDIO_INTR_STS_READ_MASK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:479
SDIO_SBITERR_INT
#define SDIO_SBITERR_INT
Definition: at32f435_437_sdio.h:61
SDIO_RXBUFH_INT
#define SDIO_RXBUFH_INT
Definition: at32f435_437_sdio.h:67
SDIO_DTTIMEOUT_INT
#define SDIO_DTTIMEOUT_INT
Definition: at32f435_437_sdio.h:55
SDIO_TXERRU_INT
#define SDIO_TXERRU_INT
Definition: at32f435_437_sdio.h:56
SDIO_RXERRO_INT
#define SDIO_RXERRO_INT
Definition: at32f435_437_sdio.h:57
SDIO_DTFAIL_INT
#define SDIO_DTFAIL_INT
Definition: at32f435_437_sdio.h:53
SDIO_TXBUFH_INT
#define SDIO_TXBUFH_INT
Definition: at32f435_437_sdio.h:66
SDIO_DTCMP_INT
#define SDIO_DTCMP_INT
Definition: at32f435_437_sdio.h:60
EXT_CSD_BUS_WIDTH
#define EXT_CSD_BUS_WIDTH
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:466
EXT_CSD_CMD_SET_NORMAL
#define EXT_CSD_CMD_SET_NORMAL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:459
EXT_CSD_Write_byte
#define EXT_CSD_Write_byte
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:457
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
SDIO_DATATIMEOUT
#define SDIO_DATATIMEOUT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:345
SDIO_CMD0TIMEOUT
#define SDIO_CMD0TIMEOUT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:344
SDIO_STATIC_FLAGS
#define SDIO_STATIC_FLAGS
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:343
SD_CARD_LOCKED
#define SD_CARD_LOCKED
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:403
SD_VOLTAGE_WINDOW_SD
#define SD_VOLTAGE_WINDOW_SD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:394
SD_R5_ERROR
#define SD_R5_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:386
SD_CARD_RECEIVING
#define SD_CARD_RECEIVING
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:405
SD_R5_OUT_OF_RANGE
#define SD_R5_OUT_OF_RANGE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:384
SD_MAX_DATA_LENGTH
#define SD_MAX_DATA_LENGTH
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:411
SD_STD_CAPACITY
#define SD_STD_CAPACITY
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:396
SD_R5_FUNCTION_NUMBER
#define SD_R5_FUNCTION_NUMBER
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:385
SD_R6_ILLEGAL_CMD
#define SD_R6_ILLEGAL_CMD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:392
SD_R6_GENERAL_UNKNOWN_ERROR
#define SD_R6_GENERAL_UNKNOWN_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:391
SD_MAX_VOLT_TRIAL
#define SD_MAX_VOLT_TRIAL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:399
SD_DATATIMEOUT
#define SD_DATATIMEOUT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:406
SD_ALLZERO
#define SD_ALLZERO
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:400
SD_R6_CMD_CRC_ERROR
#define SD_R6_CMD_CRC_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:393
MMC_SWITCH_ERROR
#define MMC_SWITCH_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:377
SD_VOLTAGE_WINDOW_MMC
#define SD_VOLTAGE_WINDOW_MMC
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:398
SD_CHECK_PATTERN
#define SD_CHECK_PATTERN
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:397
SD_OCR_ERRORBITS
#define SD_OCR_ERRORBITS
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:379
SD_CARD_PROGRAMMING
#define SD_CARD_PROGRAMMING
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:404
SD_HIGH_CAPACITY
#define SD_HIGH_CAPACITY
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:395
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
sd_card_info_struct_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:238
sd_card_info_struct_type::sd_scr_reg
sd_scr_struct_type sd_scr_reg
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:241
sd_card_info_struct_type::card_capacity
long long card_capacity
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:242
sd_card_info_struct_type::sd_cid_reg
sd_cid_struct_type sd_cid_reg
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:240
sd_card_info_struct_type::sd_csd_reg
sd_csd_struct_type sd_csd_reg
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:239
sd_card_info_struct_type::card_blk_size
uint32_t card_blk_size
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:243
sd_card_info_struct_type::rca
uint16_t rca
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:244
sd_card_info_struct_type::card_type
uint8_t card_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:245
sd_cid_struct_type::reserved1
uint8_t reserved1
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:178
sd_cid_struct_type::product_name2
uint8_t product_name2
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:175
sd_cid_struct_type::manufact_date
uint16_t manufact_date
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:179
sd_cid_struct_type::cid_crc
uint8_t cid_crc
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:180
sd_cid_struct_type::product_reversion
uint8_t product_reversion
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:176
sd_cid_struct_type::manufacturer_id
uint8_t manufacturer_id
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:172
sd_cid_struct_type::product_sn
uint32_t product_sn
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:177
sd_cid_struct_type::product_name1
uint32_t product_name1
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:174
sd_cid_struct_type::reserved2
uint8_t reserved2
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:181
sd_cid_struct_type::oem_app_id
uint16_t oem_app_id
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:173
sd_csd_struct_type::spec_version
uint8_t spec_version
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:129
sd_csd_struct_type::max_write_current_vdd_max
uint8_t max_write_current_vdd_max
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:145
sd_csd_struct_type::nsac
uint8_t nsac
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:132
sd_csd_struct_type::card_cmd_classes
uint16_t card_cmd_classes
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:134
sd_csd_struct_type::part_blk_read
uint8_t part_blk_read
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:136
sd_csd_struct_type::read_blk_misalign
uint8_t read_blk_misalign
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:138
sd_csd_struct_type::content_protect_app
uint8_t content_protect_app
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:156
sd_csd_struct_type::write_speed_factor
uint8_t write_speed_factor
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:152
sd_csd_struct_type::max_read_blk_length
uint8_t max_read_blk_length
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:135
sd_csd_struct_type::max_bus_clk_freq
uint8_t max_bus_clk_freq
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:133
sd_csd_struct_type::ecc_code
uint8_t ecc_code
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:162
sd_csd_struct_type::reserved4
uint8_t reserved4
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:164
sd_csd_struct_type::dsr_implemented
uint8_t dsr_implemented
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:139
sd_csd_struct_type::max_read_current_vdd_min
uint8_t max_read_current_vdd_min
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:142
sd_csd_struct_type::reserved2
uint8_t reserved2
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:140
sd_csd_struct_type::erase_group_size_mult
uint8_t erase_group_size_mult
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:148
sd_csd_struct_type::file_formart
uint8_t file_formart
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:161
sd_csd_struct_type::temp_write_protect
uint8_t temp_write_protect
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:160
sd_csd_struct_type::permanent_write_protect
uint8_t permanent_write_protect
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:159
sd_csd_struct_type::max_read_current_vdd_max
uint8_t max_read_current_vdd_max
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:143
sd_csd_struct_type::file_format_group
uint8_t file_format_group
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:157
sd_csd_struct_type::device_size
uint32_t device_size
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:141
sd_csd_struct_type::write_blk_misalign
uint8_t write_blk_misalign
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:137
sd_csd_struct_type::csd_struct
uint8_t csd_struct
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:128
sd_csd_struct_type::write_protect_group_enable
uint8_t write_protect_group_enable
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:150
sd_csd_struct_type::max_write_current_vdd_min
uint8_t max_write_current_vdd_min
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:144
sd_csd_struct_type::reserved1
uint8_t reserved1
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:130
sd_csd_struct_type::max_write_blk_length
uint8_t max_write_blk_length
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:153
sd_csd_struct_type::csd_crc
uint8_t csd_crc
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:163
sd_csd_struct_type::write_protect_group_size
uint8_t write_protect_group_size
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:149
sd_csd_struct_type::reserved3
uint8_t reserved3
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:155
sd_csd_struct_type::taac
uint8_t taac
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:131
sd_csd_struct_type::manufacturer_default_ecc
uint8_t manufacturer_default_ecc
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:151
sd_csd_struct_type::part_blk_write
uint8_t part_blk_write
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:154
sd_csd_struct_type::copy_flag
uint8_t copy_flag
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:158
sd_csd_struct_type::erase_group_size
uint8_t erase_group_size
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:147
sd_csd_struct_type::device_size_mult
uint8_t device_size_mult
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:146
sd_scr_struct_type::sd_bus_width
uint32_t sd_bus_width
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:223
sd_scr_struct_type::sd_spec
uint32_t sd_spec
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:221
sdio_command_struct_type
sdio command structure
Definition: at32f435_437_sdio.h:229
sdio_command_struct_type::cmd_index
uint8_t cmd_index
Definition: at32f435_437_sdio.h:231
sdio_command_struct_type::argument
uint32_t argument
Definition: at32f435_437_sdio.h:230
sdio_command_struct_type::wait_type
sdio_wait_type wait_type
Definition: at32f435_437_sdio.h:233
sdio_command_struct_type::rsp_type
sdio_reponse_type rsp_type
Definition: at32f435_437_sdio.h:232
sdio_data_struct_type
sdio data structure
Definition: at32f435_437_sdio.h:240
sdio_data_struct_type::block_size
sdio_block_size_type block_size
Definition: at32f435_437_sdio.h:243
sdio_data_struct_type::transfer_direction
sdio_transfer_direction_type transfer_direction
Definition: at32f435_437_sdio.h:245
sdio_data_struct_type::timeout
uint32_t timeout
Definition: at32f435_437_sdio.h:241
sdio_data_struct_type::transfer_mode
sdio_transfer_mode_type transfer_mode
Definition: at32f435_437_sdio.h:244
sdio_data_struct_type::data_length
uint32_t data_length
Definition: at32f435_437_sdio.h:242


AT32F435/437 Firmwary Library: at32_sdio.h File Reference

  • at_start_f437
  • examples
  • sdio
  • sdio_fatfs
  • inc
Data Structures | Macros | Enumerations | Functions | Variables
at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h File Reference

this file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library. More...

#include "at32f435_437.h"

Go to the source code of this file.

Data Structures

struct | sd_csd_struct_type
struct | sd_cid_struct_type
struct | sd_scr_struct_type
struct | sd_card_info_struct_type

Macros

#define | SDIOx SDIO1
#define | DMAMUX_SDIOx DMAMUX_DMAREQ_ID_SDIO1
#define | SD_CMD_GO_IDLE_STATE ((uint8_t)0)
#define | SD_CMD_SEND_OP_COND ((uint8_t)1)
#define | SD_CMD_ALL_SEND_CID ((uint8_t)2)
#define | SD_CMD_SET_REL_ADDR ((uint8_t)3)
#define | SD_CMD_SET_DSR ((uint8_t)4)
#define | SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)
#define | SD_CMD_HS_SWITCH ((uint8_t)6)
#define | SD_CMD_SEL_DESEL_CARD ((uint8_t)7)
#define | SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)
#define | SD_CMD_SEND_CSD ((uint8_t)9)
#define | SD_CMD_SEND_CID ((uint8_t)10)
#define | SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)
#define | SD_CMD_STOP_TRANSMISSION ((uint8_t)12)
#define | SD_CMD_SEND_STATUS ((uint8_t)13)
#define | SD_CMD_HS_BUSTEST_READ ((uint8_t)14)
#define | SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)
#define | SD_CMD_SET_BLOCKLEN ((uint8_t)16)
#define | SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)
#define | SD_CMD_READ_MULT_BLOCK ((uint8_t)18)
#define | SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)
#define | SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)
#define | SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)
#define | SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)
#define | SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)
#define | SD_CMD_PROG_CID ((uint8_t)26)
#define | SD_CMD_PROG_CSD ((uint8_t)27)
#define | SD_CMD_SET_WRITE_PROT ((uint8_t)28)
#define | SD_CMD_CLR_WRITE_PROT ((uint8_t)29)
#define | SD_CMD_SEND_WRITE_PROT ((uint8_t)30)
#define | SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)
#define | SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)
#define | SD_CMD_ERASE_GRP_START ((uint8_t)35)
#define | SD_CMD_ERASE_GRP_END ((uint8_t)36)
#define | SD_CMD_ERASE ((uint8_t)38)
#define | SD_CMD_FAST_IO ((uint8_t)39)
#define | SD_CMD_GO_IRQ_STATE ((uint8_t)40)
#define | SD_CMD_LOCK_UNLOCK ((uint8_t)42)
#define | SD_CMD_APP_CMD ((uint8_t)55)
#define | SD_CMD_GEN_CMD ((uint8_t)56)
#define | SD_CMD_NO_CMD ((uint8_t)64)
#define | SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)
#define | SD_CMD_SD_APP_STAUS ((uint8_t)13)
#define | SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)
#define | SD_CMD_SD_APP_OP_COND ((uint8_t)41)
#define | SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)
#define | SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)
#define | SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)
#define | SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)
#define | SD_CMD_SD_APP_GET_MKB ((uint8_t)43)
#define | SD_CMD_SD_APP_GET_MID ((uint8_t)44)
#define | SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)
#define | SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)
#define | SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)
#define | SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)
#define | SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)
#define | SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)
#define | SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)
#define | SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)
#define | SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)
#define | NULL 0
#define | SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)
#define | SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)
#define | SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SDIO_FIFO_Address ((uint32_t)0x40018080)
#define | SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)
#define | SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)
#define | SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)
#define | SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)
#define | SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)
#define | SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)
#define | SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)
#define | SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)
#define | SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)
#define | SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)
#define | SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)
#define | SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)
#define | SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)
#define | SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)
#define | SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)
#define | SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)
#define | SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)
#define | SD_OCR_ERASE_RESET ((uint32_t)0x00002000)
#define | MMC_SWITCH_ERROR ((uint32_t)0x00000080)
#define | SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)
#define | SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)
#define | SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)
#define | SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)
#define | SD_R5_ERROR ((uint32_t)0x00000800)
#define | SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)
#define | SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)
#define | SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)
#define | SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)
#define | SD_HIGH_CAPACITY ((uint32_t)0x40000000)
#define | SD_STD_CAPACITY ((uint32_t)0x00000000)
#define | SD_CHECK_PATTERN ((uint32_t)0x000001AA)
#define | SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)
#define | SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)
#define | SD_ALLZERO ((uint32_t)0x00000000)
#define | SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)
#define | SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)
#define | SD_CARD_LOCKED ((uint32_t)0x02000000)
#define | SD_CARD_PROGRAMMING ((uint32_t)0x00000007)
#define | SD_CARD_RECEIVING ((uint32_t)0x00000006)
#define | SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SD_0TO7BITS ((uint32_t)0x000000FF)
#define | SD_8TO15BITS ((uint32_t)0x0000FF00)
#define | SD_16TO23BITS ((uint32_t)0x00FF0000)
#define | SD_24TO31BITS ((uint32_t)0xFF000000)
#define | SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)
#define | SD_HALFFIFO ((uint32_t)0x00000008)
#define | SD_HALFFIFOBYTES ((uint32_t)0x00000020)
#define | SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)
#define | SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)
#define | SD_CCCC_ERASE ((uint32_t)0x00000020)
#define | SDIO_SEND_IF_COND ((uint32_t)0x00000008)
#define | EXT_CSD_Command_set 0x0
#define | EXT_CSD_Set_bit 0x1
#define | EXT_CSD_Clear_byte 0x2
#define | EXT_CSD_Write_byte 0x3
#define | EXT_CSD_CMD_SET_NORMAL (1<<0)
#define | EXT_CSD_CMD_SET_SECURE (1<<1)
#define | EXT_CSD_CMD_SET_CPSECURE (1<<2)
#define | EXT_CSD_BUS_WIDTH 183
#define | EXT_CSD_HS_TIMING 185
#define | SDIO_INTR_STS_WRITE_MASK
#define | SDIO_INTR_STS_READ_MASK

Enumerations

enum sd_data_transfer_mode_type {
SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 , SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 ,
SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 , SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1
}
enum sd_error_status_type {
SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 , SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 ,
SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 , SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 ,
SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 , SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 ,
SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 , SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 ,
SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 , SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 ,
SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 , SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 ,
SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 , SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 ,
SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 , SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 ,
SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR , SD_NOT_CONFIGURED , SD_REQ_PENDING ,
SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER , SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW ,
SD_ERROR , SD_OK = 0 , SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 ,
SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 , SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 ,
SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 , SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 ,
SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 , SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 ,
SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 , SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 ,
SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 , SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 ,
SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 , SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 ,
SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 , SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 ,
SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 , SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR ,
SD_NOT_CONFIGURED , SD_REQ_PENDING , SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER ,
SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW , SD_ERROR , SD_OK = 0 ,
SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 , SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 ,
SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 , SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 ,
SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 , SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 ,
SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 , SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 ,
SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 , SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 ,
SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 , SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 ,
SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 , SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 ,
SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 , SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 ,
SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR , SD_NOT_CONFIGURED , SD_REQ_PENDING ,
SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER , SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW ,
SD_ERROR , SD_OK = 0 , SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 ,
SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 , SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 ,
SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 , SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 ,
SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 , SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 ,
SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 , SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 ,
SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 , SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 ,
SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 , SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 ,
SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 , SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 ,
SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 , SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR ,
SD_NOT_CONFIGURED , SD_REQ_PENDING , SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER ,
SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW , SD_ERROR , SD_OK = 0
}
enum sd_card_state_type {
SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) ,
SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) ,
SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) ,
SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) ,
SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) ,
SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) ,
SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) ,
SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) ,
SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF)
}
enum sd_memory_card_type {
SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 ,
SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 ,
SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 ,
SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 ,
SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 ,
SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 ,
SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 ,
SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 ,
SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8
}

Functions

sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clkdiv)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...

Variables

sd_card_info_struct_type sd_card_info

Detailed Description

this file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library.

Version
v2.0.9
Date
2022-06-28
        Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h.


AT32F435/437 Firmwary Library: at32_sdio.h Source File

  • at_start_f437
  • examples
  • sdio
  • sdio_fatfs
  • inc
at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
Go to the documentation of this file.
1
28/* define to prevent recursive inclusion -------------------------------------*/
29#ifndef __AT32_SDIO_H
30#define __AT32_SDIO_H
31
32#ifdef __cplusplus
33extern "C" {
34#endif
35
36/* includes ------------------------------------------------------------------*/
37#include "at32f435_437.h"
38
51#define SDIOx SDIO1
52#define DMAMUX_SDIOx DMAMUX_DMAREQ_ID_SDIO1
53
65typedef enum
66{
67 SD_TRANSFER_POLLING_MODE = 0,
68 SD_TRANSFER_DMA_MODE = 1
69} sd_data_transfer_mode_type;
70
74typedef enum
75{
76 /* sdio specific error defines ------------------------------------------*/
77 SD_CMD_FAIL = 1,
78 SD_DATA_FAIL = 2,
79 SD_CMD_RSP_TIMEOUT = 3,
80 SD_DATA_TIMEOUT = 4,
81 SD_TX_UNDERRUN = 5,
82 SD_RX_OVERRUN = 6,
83 SD_START_BIT_ERR = 7,
84 SD_CMD_OUT_OF_RANGE = 8,
85 SD_ADDR_MISALIGNED = 9,
86 SD_BLK_LEN_ERR = 10,
87 SD_ERASE_SEQ_ERR = 11,
88 SD_INVALID_ERASE_PARAM = 12,
89 SD_WR_PROTECT_VIOLATION = 13,
90 SD_LOCK_UNLOCK_ERROR = 14,
91 SD_CMD_CRC_ERROR = 15,
92 SD_ILLEGAL_CMD = 16,
93 SD_CARD_ECC_ERROR = 17,
94 SD_CARD_CONTROLLER_ERR = 18,
95 SD_GENERAL_UNKNOWN_ERROR = 19,
96 SD_STREAM_RD_UNDERRUN = 20,
97 SD_STREAM_WR_OVERRUN = 21,
98 SD_CID_CSD_OVERWRITE = 22,
99 SD_WP_ERASE_SKIP = 23,
100 SD_CARD_ECC_DISABLED = 24,
101 SD_ERASE_RESET = 25,
102 SD_AKE_SEQ_ERROR = 26,
103 SD_INVALID_VOLTRANGE = 27,
104 SD_ADDR_OUT_OF_RANGE = 28,
105 SD_SWITCH_ERROR = 29,
106 SD_SDIO_DISABLED = 30,
107 SD_SDIO_FUNC_BUSY = 31,
108 SD_SDIO_FUNC_ERROR = 32,
109 SD_SDIO_UNKNOWN_FUNC = 33,
111 /* standard error defines --------------------------------------------*/
112 SD_INTERNAL_ERROR,
113 SD_NOT_CONFIGURED,
114 SD_REQ_PENDING,
115 SD_REQ_NOT_APPLICABLE,
116 SD_INVALID_PARAMETER,
117 SD_UNSUPPORTED_FEATURE,
118 SD_UNSUPPORTED_HW,
119 SD_ERROR,
120 SD_OK = 0
121} sd_error_status_type;
122
126typedef struct
127{
128 uint8_t csd_struct;
129 uint8_t spec_version;
130 uint8_t reserved1;
131 uint8_t taac;
132 uint8_t nsac;
133 uint8_t max_bus_clk_freq;
134 uint16_t card_cmd_classes;
135 uint8_t max_read_blk_length;
136 uint8_t part_blk_read;
137 uint8_t write_blk_misalign;
138 uint8_t read_blk_misalign;
139 uint8_t dsr_implemented;
140 uint8_t reserved2;
141 uint32_t device_size;
142 uint8_t max_read_current_vdd_min;
143 uint8_t max_read_current_vdd_max;
144 uint8_t max_write_current_vdd_min;
145 uint8_t max_write_current_vdd_max;
146 uint8_t device_size_mult;
147 uint8_t erase_group_size;
148 uint8_t erase_group_size_mult;
149 uint8_t write_protect_group_size;
150 uint8_t write_protect_group_enable;
151 uint8_t manufacturer_default_ecc;
152 uint8_t write_speed_factor;
153 uint8_t max_write_blk_length;
154 uint8_t part_blk_write;
155 uint8_t reserved3;
156 uint8_t content_protect_app;
157 uint8_t file_format_group;
158 uint8_t copy_flag;
159 uint8_t permanent_write_protect;
160 uint8_t temp_write_protect;
161 uint8_t file_formart;
162 uint8_t ecc_code;
163 uint8_t csd_crc;
164 uint8_t reserved4;
165} sd_csd_struct_type;
166
170typedef struct
171{
172 uint8_t manufacturer_id;
173 uint16_t oem_app_id;
174 uint32_t product_name1;
175 uint8_t product_name2;
176 uint8_t product_reversion;
177 uint32_t product_sn;
178 uint8_t reserved1;
179 uint16_t manufact_date;
180 uint8_t cid_crc;
181 uint8_t reserved2;
182} sd_cid_struct_type;
183
187typedef enum
188{
189 SD_CARD_READY = ((uint32_t)0x00000001),
190 SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002),
191 SD_CARD_STANDBY = ((uint32_t)0x00000003),
192 SD_CARD_TRANSFER = ((uint32_t)0x00000004),
193 SD_CARD_SENDING = ((uint32_t)0x00000005),
194 SD_CARD_RECEIVING = ((uint32_t)0x00000006),
195 SD_CARD_PROGRAMMING = ((uint32_t)0x00000007),
196 SD_CARD_DISCONNECTED = ((uint32_t)0x00000008),
197 SD_CARD_ERROR = ((uint32_t)0x000000FF)
198} sd_card_state_type;
199
203typedef enum
204{
205 SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0,
206 SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1,
207 SDIO_HIGH_CAPACITY_SD_CARD = 2,
208 SDIO_MULTIMEDIA_CARD = 3,
209 SDIO_SECURE_DIGITAL_IO_CARD = 4,
210 SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5,
211 SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6,
212 SDIO_HIGH_CAPACITY_MMC_CARD = 7,
213 SDIO_SDIO_CARD = 8
214} sd_memory_card_type;
215
219typedef struct
220{
221 uint32_t sd_spec :4; /* [59:56] */
222 uint32_t scr_structure :4; /* [60:63] */
223 uint32_t sd_bus_width :4; /* [51:48] */
224 uint32_t sd_security :3; /* [52:54] */
225 uint32_t data_stat_after_erase :1; /* [55:55] */
226 uint32_t reserved1 :7; /* [46:40] */
227 uint32_t sd_spec3 :1; /* [47:47] */
228 uint32_t cmd20_support :1; /* [32:32] */
229 uint32_t cmd23_support :1; /* [33:33] */
230 uint32_t reserverd2 :6; /* [34:39] */
231 uint32_t reserverd3; /* [31:0] */
232} sd_scr_struct_type;
233
237typedef struct
238{
239 sd_csd_struct_type sd_csd_reg;
240 sd_cid_struct_type sd_cid_reg;
241 sd_scr_struct_type sd_scr_reg;
242 long long card_capacity;
243 uint32_t card_blk_size;
244 uint16_t rca;
245 uint8_t card_type;
246} sd_card_info_struct_type;
247
248extern sd_card_info_struct_type sd_card_info;
249
261#define SD_CMD_GO_IDLE_STATE ((uint8_t)0)
262#define SD_CMD_SEND_OP_COND ((uint8_t)1)
263#define SD_CMD_ALL_SEND_CID ((uint8_t)2)
264#define SD_CMD_SET_REL_ADDR ((uint8_t)3)
265#define SD_CMD_SET_DSR ((uint8_t)4)
266#define SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)
267#define SD_CMD_HS_SWITCH ((uint8_t)6)
268#define SD_CMD_SEL_DESEL_CARD ((uint8_t)7)
269#define SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)
270#define SD_CMD_SEND_CSD ((uint8_t)9)
271#define SD_CMD_SEND_CID ((uint8_t)10)
272#define SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)
273#define SD_CMD_STOP_TRANSMISSION ((uint8_t)12)
274#define SD_CMD_SEND_STATUS ((uint8_t)13)
275#define SD_CMD_HS_BUSTEST_READ ((uint8_t)14)
276#define SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)
277#define SD_CMD_SET_BLOCKLEN ((uint8_t)16)
278#define SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)
279#define SD_CMD_READ_MULT_BLOCK ((uint8_t)18)
280#define SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)
281#define SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)
282#define SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)
283#define SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)
284#define SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)
285#define SD_CMD_PROG_CID ((uint8_t)26)
286#define SD_CMD_PROG_CSD ((uint8_t)27)
287#define SD_CMD_SET_WRITE_PROT ((uint8_t)28)
288#define SD_CMD_CLR_WRITE_PROT ((uint8_t)29)
289#define SD_CMD_SEND_WRITE_PROT ((uint8_t)30)
290#define SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)
291#define SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)
292#define SD_CMD_ERASE_GRP_START ((uint8_t)35)
293#define SD_CMD_ERASE_GRP_END ((uint8_t)36)
294#define SD_CMD_ERASE ((uint8_t)38)
295#define SD_CMD_FAST_IO ((uint8_t)39)
296#define SD_CMD_GO_IRQ_STATE ((uint8_t)40)
297#define SD_CMD_LOCK_UNLOCK ((uint8_t)42)
298#define SD_CMD_APP_CMD ((uint8_t)55)
299#define SD_CMD_GEN_CMD ((uint8_t)56)
300#define SD_CMD_NO_CMD ((uint8_t)64)
301
306#define SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)
307#define SD_CMD_SD_APP_STAUS ((uint8_t)13)
308#define SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)
309#define SD_CMD_SD_APP_OP_COND ((uint8_t)41)
310#define SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)
311#define SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)
312#define SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)
313#define SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)
314
319#define SD_CMD_SD_APP_GET_MKB ((uint8_t)43)
320#define SD_CMD_SD_APP_GET_MID ((uint8_t)44)
321#define SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)
322#define SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)
323#define SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)
324#define SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)
325#define SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)
326#define SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)
327#define SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)
328#define SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)
329#define SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)
330
342#define NULL 0
343#define SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)
344#define SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)
345#define SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
346#define SDIO_FIFO_Address ((uint32_t)0x40018080)
347
359#define SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)
360#define SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)
361#define SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)
362#define SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)
363#define SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)
364#define SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)
365#define SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)
366#define SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)
367#define SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)
368#define SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)
369#define SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)
370#define SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)
371#define SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)
372#define SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)
373#define SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)
374#define SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)
375#define SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)
376#define SD_OCR_ERASE_RESET ((uint32_t)0x00002000)
377#define MMC_SWITCH_ERROR ((uint32_t)0x00000080)
378#define SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)
379#define SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)
380
384#define SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)
385#define SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)
386#define SD_R5_ERROR ((uint32_t)0x00000800)
387
391#define SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)
392#define SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)
393#define SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)
394#define SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)
395#define SD_HIGH_CAPACITY ((uint32_t)0x40000000)
396#define SD_STD_CAPACITY ((uint32_t)0x00000000)
397#define SD_CHECK_PATTERN ((uint32_t)0x000001AA)
398#define SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)
399#define SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)
400#define SD_ALLZERO ((uint32_t)0x00000000)
401#define SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)
402#define SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)
403#define SD_CARD_LOCKED ((uint32_t)0x02000000)
404#define SD_CARD_PROGRAMMING ((uint32_t)0x00000007)
405#define SD_CARD_RECEIVING ((uint32_t)0x00000006)
406#define SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
407#define SD_0TO7BITS ((uint32_t)0x000000FF)
408#define SD_8TO15BITS ((uint32_t)0x0000FF00)
409#define SD_16TO23BITS ((uint32_t)0x00FF0000)
410#define SD_24TO31BITS ((uint32_t)0xFF000000)
411#define SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)
412#define SD_HALFFIFO ((uint32_t)0x00000008)
413#define SD_HALFFIFOBYTES ((uint32_t)0x00000020)
414
426#define SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)
427#define SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)
428#define SD_CCCC_ERASE ((uint32_t)0x00000020)
429
441#define SDIO_SEND_IF_COND ((uint32_t)0x00000008)
442
454#define EXT_CSD_Command_set 0x0
455#define EXT_CSD_Set_bit 0x1
456#define EXT_CSD_Clear_byte 0x2
457#define EXT_CSD_Write_byte 0x3
458
459#define EXT_CSD_CMD_SET_NORMAL (1<<0)
460#define EXT_CSD_CMD_SET_SECURE (1<<1)
461#define EXT_CSD_CMD_SET_CPSECURE (1<<2)
462
466#define EXT_CSD_BUS_WIDTH 183
467#define EXT_CSD_HS_TIMING 185
468
477#define SDIO_INTR_STS_WRITE_MASK (SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_TXERRU_FLAG | \
478 SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
479#define SDIO_INTR_STS_READ_MASK (SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_RXERRO_FLAG | \
480 SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
489/* sd exported functions ----------------------------------------*/
490 sd_error_status_type sd_init(void);
491void sdio_clock_set(uint32_t clkdiv);
492 sd_error_status_type sd_power_on(void);
493 sd_error_status_type sd_power_off(void);
494 sd_error_status_type sd_card_init(void);
495 sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info);
496 sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode);
497 sd_error_status_type sd_device_mode_set(uint32_t mode);
498 sd_error_status_type sd_deselect_select(uint32_t addr);
499 sd_error_status_type sd_status_send(uint32_t *p_card_status);
500 sd_card_state_type sd_state_get(void);
501 sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks);
502 sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size);
503 sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks);
504 sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size);
505 sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks);
506 sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len);
507 sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len);
508 sd_error_status_type sd_irq_service(void);
509void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir);
510
523#ifdef __cplusplus
524}
525#endif
526
527#endif /* __AT32_SDIO_H */
528
at32f435_437.h
at32f435_437 header file
card_type
static sd_memory_card_type card_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:42
rca
static uint32_t rca
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:43
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f435_437_dma.h:151
sd_power_off
sd_error_status_type sd_power_off(void)
turns the sdio output signals off.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:403
sd_irq_service
sd_error_status_type sd_irq_service(void)
allows to process all the interrupts that are high.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1789
sd_device_mode_set
sd_error_status_type sd_device_mode_set(uint32_t mode)
set sdio work mode.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:786
sd_card_info_get
sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info)
returns information about specific card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:532
mmc_stream_write
sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1700
sd_card_init
sd_error_status_type sd_card_init(void)
intialises all cards or single card as the case may be card(s) come into standby state.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:417
sd_block_read
sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma ...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1188
sd_deselect_select
sd_error_status_type sd_deselect_select(uint32_t addr)
selects od deselects the corresponding card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:807
sdio_clock_set
void sdio_clock_set(uint32_t clkdiv)
set sdio clock devision factor.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:188
sd_blocks_erase
sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks)
erase continuous data block
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1030
sd_mult_blocks_write
sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed ...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1489
sd_state_get
sd_card_state_type sd_state_get(void)
returns information about sd card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:2489
sd_dma_config
void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:2706
sd_block_write
sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be manag...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1367
sd_status_send
sd_error_status_type sd_status_send(uint32_t *p_card_status)
read current card status.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:2452
sd_init
sd_error_status_type sd_init(void)
initializes the sd card and put it into standby state (ready for data transfer).
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:72
mmc_stream_read
sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1653
sd_power_on
sd_error_status_type sd_power_on(void)
enquires cards about their operating voltage and configures clock controls.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:203
sd_mult_blocks_read
sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mod...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1277
sd_wide_bus_operation_config
sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:743
sd_card_info
sd_card_info_struct_type sd_card_info
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:48
sd_data_transfer_mode_type
sd_data_transfer_mode_type
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:66
sd_error_status_type
sd_error_status_type
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:75
sd_card_state_type
sd_card_state_type
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:188
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f435_437_sdio.h:139
sd_memory_card_type
sd_memory_card_type
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:204
SD_TRANSFER_DMA_MODE
@ SD_TRANSFER_DMA_MODE
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:68
SD_TRANSFER_POLLING_MODE
@ SD_TRANSFER_POLLING_MODE
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:67
SD_ERROR
@ SD_ERROR
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:119
SD_WP_ERASE_SKIP
@ SD_WP_ERASE_SKIP
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:99
SD_SDIO_UNKNOWN_FUNC
@ SD_SDIO_UNKNOWN_FUNC
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:109
SD_DATA_FAIL
@ SD_DATA_FAIL
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:78
SD_STREAM_WR_OVERRUN
@ SD_STREAM_WR_OVERRUN
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:97
SD_INVALID_PARAMETER
@ SD_INVALID_PARAMETER
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:116
SD_CMD_FAIL
@ SD_CMD_FAIL
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:77
SD_CMD_OUT_OF_RANGE
@ SD_CMD_OUT_OF_RANGE
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:84
SD_UNSUPPORTED_HW
@ SD_UNSUPPORTED_HW
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:118
SD_SDIO_FUNC_ERROR
@ SD_SDIO_FUNC_ERROR
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:108
SD_INTERNAL_ERROR
@ SD_INTERNAL_ERROR
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:112
SD_INVALID_ERASE_PARAM
@ SD_INVALID_ERASE_PARAM
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:88
SD_GENERAL_UNKNOWN_ERROR
@ SD_GENERAL_UNKNOWN_ERROR
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:95
SD_CARD_ECC_DISABLED
@ SD_CARD_ECC_DISABLED
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:100
SD_CARD_CONTROLLER_ERR
@ SD_CARD_CONTROLLER_ERR
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:94
SD_ERASE_RESET
@ SD_ERASE_RESET
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:101
SD_CARD_ECC_ERROR
@ SD_CARD_ECC_ERROR
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:93
SD_STREAM_RD_UNDERRUN
@ SD_STREAM_RD_UNDERRUN
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:96
SD_UNSUPPORTED_FEATURE
@ SD_UNSUPPORTED_FEATURE
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:117
SD_TX_UNDERRUN
@ SD_TX_UNDERRUN
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:81
SD_ILLEGAL_CMD
@ SD_ILLEGAL_CMD
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:92
SD_SDIO_FUNC_BUSY
@ SD_SDIO_FUNC_BUSY
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:107
SD_CMD_CRC_ERROR
@ SD_CMD_CRC_ERROR
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:91
SD_ADDR_OUT_OF_RANGE
@ SD_ADDR_OUT_OF_RANGE
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:104
SD_RX_OVERRUN
@ SD_RX_OVERRUN
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:82
SD_REQ_PENDING
@ SD_REQ_PENDING
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:114
SD_REQ_NOT_APPLICABLE
@ SD_REQ_NOT_APPLICABLE
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:115
SD_SWITCH_ERROR
@ SD_SWITCH_ERROR
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:105
SD_INVALID_VOLTRANGE
@ SD_INVALID_VOLTRANGE
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:103
SD_SDIO_DISABLED
@ SD_SDIO_DISABLED
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:106
SD_DATA_TIMEOUT
@ SD_DATA_TIMEOUT
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:80
SD_ADDR_MISALIGNED
@ SD_ADDR_MISALIGNED
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:85
SD_START_BIT_ERR
@ SD_START_BIT_ERR
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:83
SD_LOCK_UNLOCK_ERROR
@ SD_LOCK_UNLOCK_ERROR
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:90
SD_NOT_CONFIGURED
@ SD_NOT_CONFIGURED
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:113
SD_CID_CSD_OVERWRITE
@ SD_CID_CSD_OVERWRITE
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:98
SD_WR_PROTECT_VIOLATION
@ SD_WR_PROTECT_VIOLATION
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:89
SD_CMD_RSP_TIMEOUT
@ SD_CMD_RSP_TIMEOUT
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:79
SD_BLK_LEN_ERR
@ SD_BLK_LEN_ERR
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:86
SD_OK
@ SD_OK
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:120
SD_ERASE_SEQ_ERR
@ SD_ERASE_SEQ_ERR
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:87
SD_AKE_SEQ_ERROR
@ SD_AKE_SEQ_ERROR
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:102
SD_CARD_TRANSFER
@ SD_CARD_TRANSFER
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:192
SD_CARD_IDENTIFICATION
@ SD_CARD_IDENTIFICATION
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:190
SD_CARD_SENDING
@ SD_CARD_SENDING
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:193
SD_CARD_STANDBY
@ SD_CARD_STANDBY
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:191
SD_CARD_READY
@ SD_CARD_READY
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:189
SD_CARD_DISCONNECTED
@ SD_CARD_DISCONNECTED
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:196
SD_CARD_ERROR
@ SD_CARD_ERROR
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:197
SDIO_SDIO_CARD
@ SDIO_SDIO_CARD
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:213
SDIO_HIGH_CAPACITY_SD_CARD
@ SDIO_HIGH_CAPACITY_SD_CARD
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:207
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
@ SDIO_SECURE_DIGITAL_IO_COMBO_CARD
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:211
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
@ SDIO_HIGH_SPEED_MULTIMEDIA_CARD
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:210
SDIO_STD_CAPACITY_SD_CARD_V1_1
@ SDIO_STD_CAPACITY_SD_CARD_V1_1
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:205
SDIO_SECURE_DIGITAL_IO_CARD
@ SDIO_SECURE_DIGITAL_IO_CARD
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:209
SDIO_STD_CAPACITY_SD_CARD_V2_0
@ SDIO_STD_CAPACITY_SD_CARD_V2_0
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:206
SDIO_MULTIMEDIA_CARD
@ SDIO_MULTIMEDIA_CARD
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:208
SDIO_HIGH_CAPACITY_MMC_CARD
@ SDIO_HIGH_CAPACITY_MMC_CARD
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:212
SD_CARD_RECEIVING
#define SD_CARD_RECEIVING
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:405
SD_CARD_PROGRAMMING
#define SD_CARD_PROGRAMMING
Definition: at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h:404
sd_card_info_struct_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:238
sd_cid_struct_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:171
sd_csd_struct_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:127
sd_scr_struct_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:220


AT32F435/437 Firmwary Library: ffconf.h File Reference

  • at_start_f437
  • examples
  • sdio
  • sdio_fatfs
  • inc
Macros
at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h File Reference

Go to the source code of this file.

Macros

#define | FFCONF_DEF 86631 /* Revision ID */
#define | FF_FS_READONLY 0
#define | FF_FS_MINIMIZE 0
#define | FF_USE_FIND 0
#define | FF_USE_MKFS 1
#define | FF_USE_FASTSEEK 1
#define | FF_USE_EXPAND 0
#define | FF_USE_CHMOD 0
#define | FF_USE_LABEL 0
#define | FF_USE_FORWARD 0
#define | FF_USE_STRFUNC 0
#define | FF_PRINT_LLI 0
#define | FF_PRINT_FLOAT 0
#define | FF_STRF_ENCODE 0
#define | FF_CODE_PAGE 932
#define | FF_USE_LFN 0
#define | FF_MAX_LFN 255
#define | FF_LFN_UNICODE 0
#define | FF_LFN_BUF 255
#define | FF_SFN_BUF 12
#define | FF_FS_RPATH 0
#define | FF_VOLUMES 3
#define | FF_STR_VOLUME_ID 0
#define | FF_VOLUME_STRS "RAM","NAND","CF","SD","SD2","USB","USB2","USB3"
#define | FF_MULTI_PARTITION 0
#define | FF_MIN_SS 512
#define | FF_MAX_SS 512
#define | FF_LBA64 0
#define | FF_MIN_GPT 0x10000000
#define | FF_USE_TRIM 0
#define | FF_FS_TINY 0
#define | FF_FS_EXFAT 0
#define | FF_FS_NORTC 1
#define | FF_NORTC_MON 1
#define | FF_NORTC_MDAY 1
#define | FF_NORTC_YEAR 2020
#define | FF_FS_NOFSINFO 0
#define | FF_FS_LOCK 0
#define | FF_FS_REENTRANT 0
#define | FF_FS_TIMEOUT 1000
#define | FF_SYNC_t HANDLE

Macro Definition Documentation

◆ FF_CODE_PAGE

#define FF_CODE_PAGE 932

Definition at line 87 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_FS_EXFAT

#define FF_FS_EXFAT 0

Definition at line 234 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_FS_LOCK

#define FF_FS_LOCK 0

Definition at line 266 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_FS_MINIMIZE

#define FF_FS_MINIMIZE 0

Definition at line 18 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_FS_NOFSINFO

#define FF_FS_NOFSINFO 0

Definition at line 254 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_FS_NORTC

#define FF_FS_NORTC 1

Definition at line 240 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_FS_READONLY

#define FF_FS_READONLY 0

Definition at line 11 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_FS_REENTRANT

#define FF_FS_REENTRANT 0

Definition at line 279 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_FS_RPATH

#define FF_FS_RPATH 0

Definition at line 156 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_FS_TIMEOUT

#define FF_FS_TIMEOUT 1000

Definition at line 280 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_FS_TINY

#define FF_FS_TINY 0

Definition at line 227 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_LBA64

#define FF_LBA64 0

Definition at line 206 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_LFN_BUF

#define FF_LFN_BUF 255

Definition at line 148 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_LFN_UNICODE

#define FF_LFN_UNICODE 0

Definition at line 136 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_MAX_LFN

#define FF_MAX_LFN 255

Definition at line 117 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_MAX_SS

#define FF_MAX_SS 512

Definition at line 197 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_MIN_GPT

#define FF_MIN_GPT 0x10000000

Definition at line 211 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_MIN_SS

#define FF_MIN_SS 512

Definition at line 196 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_MULTI_PARTITION

#define FF_MULTI_PARTITION 0

Definition at line 187 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_NORTC_MDAY

#define FF_NORTC_MDAY 1

Definition at line 242 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_NORTC_MON

#define FF_NORTC_MON 1

Definition at line 241 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_NORTC_YEAR

#define FF_NORTC_YEAR 2020

Definition at line 243 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_PRINT_FLOAT

#define FF_PRINT_FLOAT 0

Definition at line 61 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_PRINT_LLI

#define FF_PRINT_LLI 0

Definition at line 60 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_SFN_BUF

#define FF_SFN_BUF 12

Definition at line 149 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_STR_VOLUME_ID

#define FF_STR_VOLUME_ID 0

Definition at line 173 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_STRF_ENCODE

#define FF_STRF_ENCODE 0

Definition at line 62 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_SYNC_t

#define FF_SYNC_t HANDLE

Definition at line 281 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_USE_CHMOD

#define FF_USE_CHMOD 0

Definition at line 45 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_USE_EXPAND

#define FF_USE_EXPAND 0

Definition at line 41 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_USE_FASTSEEK

#define FF_USE_FASTSEEK 1

Definition at line 37 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_USE_FIND

#define FF_USE_FIND 0

Definition at line 28 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_USE_FORWARD

#define FF_USE_FORWARD 0

Definition at line 55 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_USE_LABEL

#define FF_USE_LABEL 0

Definition at line 50 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_USE_LFN

#define FF_USE_LFN 0

Definition at line 116 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_USE_MKFS

#define FF_USE_MKFS 1

Definition at line 33 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_USE_STRFUNC

#define FF_USE_STRFUNC 0

Definition at line 59 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_USE_TRIM

#define FF_USE_TRIM 0

Definition at line 216 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_VOLUME_STRS

#define FF_VOLUME_STRS "RAM","NAND","CF","SD","SD2","USB","USB2","USB3"

Definition at line 174 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FF_VOLUMES

#define FF_VOLUMES 3

Definition at line 169 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.

◆ FFCONF_DEF

#define FFCONF_DEF 86631 /* Revision ID */

Definition at line 5 of file at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h.


AT32F435/437 Firmwary Library: ffconf.h Source File

  • at_start_f437
  • examples
  • sdio
  • sdio_fatfs
  • inc
at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h
Go to the documentation of this file.
1/*---------------------------------------------------------------------------/
2/ FatFs Functional Configurations
3/---------------------------------------------------------------------------*/
4
5#define FFCONF_DEF 86631 /* Revision ID */
6
7/*---------------------------------------------------------------------------/
8/ Function Configurations
9/---------------------------------------------------------------------------*/
10
11#define FF_FS_READONLY 0
12/* This option switches read-only configuration. (0:Read/Write or 1:Read-only)
13/ Read-only configuration removes writing API functions, f_write(), f_sync(),
14/ f_unlink(), f_mkdir(), f_chmod(), f_rename(), f_truncate(), f_getfree()
15/ and optional writing functions as well. */
16
17
18#define FF_FS_MINIMIZE 0
19/* This option defines minimization level to remove some basic API functions.
20/
21/ 0: Basic functions are fully enabled.
22/ 1: f_stat(), f_getfree(), f_unlink(), f_mkdir(), f_truncate() and f_rename()
23/ are removed.
24/ 2: f_opendir(), f_readdir() and f_closedir() are removed in addition to 1.
25/ 3: f_lseek() function is removed in addition to 2. */
26
27
28#define FF_USE_FIND 0
29/* This option switches filtered directory read functions, f_findfirst() and
30/ f_findnext(). (0:Disable, 1:Enable 2:Enable with matching altname[] too) */
31
32
33#define FF_USE_MKFS 1//0
34/* This option switches f_mkfs() function. (0:Disable or 1:Enable) */
35
36
37#define FF_USE_FASTSEEK 1//0
38/* This option switches fast seek function. (0:Disable or 1:Enable) */
39
40
41#define FF_USE_EXPAND 0
42/* This option switches f_expand function. (0:Disable or 1:Enable) */
43
44
45#define FF_USE_CHMOD 0
46/* This option switches attribute manipulation functions, f_chmod() and f_utime().
47/ (0:Disable or 1:Enable) Also FF_FS_READONLY needs to be 0 to enable this option. */
48
49
50#define FF_USE_LABEL 0
51/* This option switches volume label functions, f_getlabel() and f_setlabel().
52/ (0:Disable or 1:Enable) */
53
54
55#define FF_USE_FORWARD 0
56/* This option switches f_forward() function. (0:Disable or 1:Enable) */
57
58
59#define FF_USE_STRFUNC 0
60#define FF_PRINT_LLI 0
61#define FF_PRINT_FLOAT 0
62#define FF_STRF_ENCODE 0
63/* FF_USE_STRFUNC switches string functions, f_gets(), f_putc(), f_puts() and
64/ f_printf().
65/
66/ 0: Disable. FF_PRINT_LLI, FF_PRINT_FLOAT and FF_STRF_ENCODE have no effect.
67/ 1: Enable without LF-CRLF conversion.
68/ 2: Enable with LF-CRLF conversion.
69/
70/ FF_PRINT_LLI = 1 makes f_printf() support long long argument and FF_PRINT_FLOAT = 1/2
71 makes f_printf() support floating point argument. These features want C99 or later.
72/ When FF_LFN_UNICODE >= 1 with LFN enabled, string functions convert the character
73/ encoding in it. FF_STRF_ENCODE selects assumption of character encoding ON THE FILE
74/ to be read/written via those functions.
75/
76/ 0: ANSI/OEM in current CP
77/ 1: Unicode in UTF-16LE
78/ 2: Unicode in UTF-16BE
79/ 3: Unicode in UTF-8
80*/
81
82
83/*---------------------------------------------------------------------------/
84/ Locale and Namespace Configurations
85/---------------------------------------------------------------------------*/
86
87#define FF_CODE_PAGE 932
88/* This option specifies the OEM code page to be used on the target system.
89/ Incorrect code page setting can cause a file open failure.
90/
91/ 437 - U.S.
92/ 720 - Arabic
93/ 737 - Greek
94/ 771 - KBL
95/ 775 - Baltic
96/ 850 - Latin 1
97/ 852 - Latin 2
98/ 855 - Cyrillic
99/ 857 - Turkish
100/ 860 - Portuguese
101/ 861 - Icelandic
102/ 862 - Hebrew
103/ 863 - Canadian French
104/ 864 - Arabic
105/ 865 - Nordic
106/ 866 - Russian
107/ 869 - Greek 2
108/ 932 - Japanese (DBCS)
109/ 936 - Simplified Chinese (DBCS)
110/ 949 - Korean (DBCS)
111/ 950 - Traditional Chinese (DBCS)
112/ 0 - Include all code pages above and configured by f_setcp()
113*/
114
115
116#define FF_USE_LFN 0
117#define FF_MAX_LFN 255
118/* The FF_USE_LFN switches the support for LFN (long file name).
119/
120/ 0: Disable LFN. FF_MAX_LFN has no effect.
121/ 1: Enable LFN with static working buffer on the BSS. Always NOT thread-safe.
122/ 2: Enable LFN with dynamic working buffer on the STACK.
123/ 3: Enable LFN with dynamic working buffer on the HEAP.
124/
125/ To enable the LFN, ffunicode.c needs to be added to the project. The LFN function
126/ requiers certain internal working buffer occupies (FF_MAX_LFN + 1) * 2 bytes and
127/ additional (FF_MAX_LFN + 44) / 15 * 32 bytes when exFAT is enabled.
128/ The FF_MAX_LFN defines size of the working buffer in UTF-16 code unit and it can
129/ be in range of 12 to 255. It is recommended to be set it 255 to fully support LFN
130/ specification.
131/ When use stack for the working buffer, take care on stack overflow. When use heap
132/ memory for the working buffer, memory management functions, ff_memalloc() and
133/ ff_memfree() exemplified in ffsystem.c, need to be added to the project. */
134
135
136#define FF_LFN_UNICODE 0
137/* This option switches the character encoding on the API when LFN is enabled.
138/
139/ 0: ANSI/OEM in current CP (TCHAR = char)
140/ 1: Unicode in UTF-16 (TCHAR = WCHAR)
141/ 2: Unicode in UTF-8 (TCHAR = char)
142/ 3: Unicode in UTF-32 (TCHAR = DWORD)
143/
144/ Also behavior of string I/O functions will be affected by this option.
145/ When LFN is not enabled, this option has no effect. */
146
147
148#define FF_LFN_BUF 255
149#define FF_SFN_BUF 12
150/* This set of options defines size of file name members in the FILINFO structure
151/ which is used to read out directory items. These values should be suffcient for
152/ the file names to read. The maximum possible length of the read file name depends
153/ on character encoding. When LFN is not enabled, these options have no effect. */
154
155
156#define FF_FS_RPATH 0
157/* This option configures support for relative path.
158/
159/ 0: Disable relative path and remove related functions.
160/ 1: Enable relative path. f_chdir() and f_chdrive() are available.
161/ 2: f_getcwd() function is available in addition to 1.
162*/
163
164
165/*---------------------------------------------------------------------------/
166/ Drive/Volume Configurations
167/---------------------------------------------------------------------------*/
168
169#define FF_VOLUMES 3//1
170/* Number of volumes (logical drives) to be used. (1-10) */
171
172
173#define FF_STR_VOLUME_ID 0
174#define FF_VOLUME_STRS "RAM","NAND","CF","SD","SD2","USB","USB2","USB3"
175/* FF_STR_VOLUME_ID switches support for volume ID in arbitrary strings.
176/ When FF_STR_VOLUME_ID is set to 1 or 2, arbitrary strings can be used as drive
177/ number in the path name. FF_VOLUME_STRS defines the volume ID strings for each
178/ logical drives. Number of items must not be less than FF_VOLUMES. Valid
179/ characters for the volume ID strings are A-Z, a-z and 0-9, however, they are
180/ compared in case-insensitive. If FF_STR_VOLUME_ID >= 1 and FF_VOLUME_STRS is
181/ not defined, a user defined volume string table needs to be defined as:
182/
183/ const char* VolumeStr[FF_VOLUMES] = {"ram","flash","sd","usb",...
184*/
185
186
187#define FF_MULTI_PARTITION 0
188/* This option switches support for multiple volumes on the physical drive.
189/ By default (0), each logical drive number is bound to the same physical drive
190/ number and only an FAT volume found on the physical drive will be mounted.
191/ When this function is enabled (1), each logical drive number can be bound to
192/ arbitrary physical drive and partition listed in the VolToPart[]. Also f_fdisk()
193/ funciton will be available. */
194
195
196#define FF_MIN_SS 512
197#define FF_MAX_SS 512
198/* This set of options configures the range of sector size to be supported. (512,
199/ 1024, 2048 or 4096) Always set both 512 for most systems, generic memory card and
200/ harddisk, but a larger value may be required for on-board flash memory and some
201/ type of optical media. When FF_MAX_SS is larger than FF_MIN_SS, FatFs is configured
202/ for variable sector size mode and disk_ioctl() function needs to implement
203/ GET_SECTOR_SIZE command. */
204
205
206#define FF_LBA64 0
207/* This option switches support for 64-bit LBA. (0:Disable or 1:Enable)
208/ To enable the 64-bit LBA, also exFAT needs to be enabled. (FF_FS_EXFAT == 1) */
209
210
211#define FF_MIN_GPT 0x10000000
212/* Minimum number of sectors to switch GPT as partitioning format in f_mkfs and
213/ f_fdisk function. 0x100000000 max. This option has no effect when FF_LBA64 == 0. */
214
215
216#define FF_USE_TRIM 0
217/* This option switches support for ATA-TRIM. (0:Disable or 1:Enable)
218/ To enable Trim function, also CTRL_TRIM command should be implemented to the
219/ disk_ioctl() function. */
220
221
222
223/*---------------------------------------------------------------------------/
224/ System Configurations
225/---------------------------------------------------------------------------*/
226
227#define FF_FS_TINY 0
228/* This option switches tiny buffer configuration. (0:Normal or 1:Tiny)
229/ At the tiny configuration, size of file object (FIL) is shrinked FF_MAX_SS bytes.
230/ Instead of private sector buffer eliminated from the file object, common sector
231/ buffer in the filesystem object (FATFS) is used for the file data transfer. */
232
233
234#define FF_FS_EXFAT 0
235/* This option switches support for exFAT filesystem. (0:Disable or 1:Enable)
236/ To enable exFAT, also LFN needs to be enabled. (FF_USE_LFN >= 1)
237/ Note that enabling exFAT discards ANSI C (C89) compatibility. */
238
239
240#define FF_FS_NORTC 1//0
241#define FF_NORTC_MON 1
242#define FF_NORTC_MDAY 1
243#define FF_NORTC_YEAR 2020
244/* The option FF_FS_NORTC switches timestamp functiton. If the system does not have
245/ any RTC function or valid timestamp is not needed, set FF_FS_NORTC = 1 to disable
246/ the timestamp function. Every object modified by FatFs will have a fixed timestamp
247/ defined by FF_NORTC_MON, FF_NORTC_MDAY and FF_NORTC_YEAR in local time.
248/ To enable timestamp function (FF_FS_NORTC = 0), get_fattime() function need to be
249/ added to the project to read current time form real-time clock. FF_NORTC_MON,
250/ FF_NORTC_MDAY and FF_NORTC_YEAR have no effect.
251/ These options have no effect in read-only configuration (FF_FS_READONLY = 1). */
252
253
254#define FF_FS_NOFSINFO 0
255/* If you need to know correct free space on the FAT32 volume, set bit 0 of this
256/ option, and f_getfree() function at first time after volume mount will force
257/ a full FAT scan. Bit 1 controls the use of last allocated cluster number.
258/
259/ bit0=0: Use free cluster count in the FSINFO if available.
260/ bit0=1: Do not trust free cluster count in the FSINFO.
261/ bit1=0: Use last allocated cluster number in the FSINFO if available.
262/ bit1=1: Do not trust last allocated cluster number in the FSINFO.
263*/
264
265
266#define FF_FS_LOCK 0
267/* The option FF_FS_LOCK switches file lock function to control duplicated file open
268/ and illegal operation to open objects. This option must be 0 when FF_FS_READONLY
269/ is 1.
270/
271/ 0: Disable file lock function. To avoid volume corruption, application program
272/ should avoid illegal open, remove and rename to the open objects.
273/ >0: Enable file lock function. The value defines how many files/sub-directories
274/ can be opened simultaneously under file lock control. Note that the file
275/ lock control is independent of re-entrancy. */
276
277
278/* #include <somertos.h> // O/S definitions */
279#define FF_FS_REENTRANT 0
280#define FF_FS_TIMEOUT 1000
281#define FF_SYNC_t HANDLE
282/* The option FF_FS_REENTRANT switches the re-entrancy (thread safe) of the FatFs
283/ module itself. Note that regardless of this option, file access to different
284/ volume is always re-entrant and volume control functions, f_mount(), f_mkfs()
285/ and f_fdisk() function, are always not re-entrant. Only file/directory access
286/ to the same volume is under control of this function.
287/
288/ 0: Disable re-entrancy. FF_FS_TIMEOUT and FF_SYNC_t have no effect.
289/ 1: Enable re-entrancy. Also user provided synchronization handlers,
290/ ff_req_grant(), ff_rel_grant(), ff_del_syncobj() and ff_cre_syncobj()
291/ function, must be added to the project. Samples are available in
292/ option/syscall.c.
293/
294/ The FF_FS_TIMEOUT defines timeout period in unit of time tick.
295/ The FF_SYNC_t defines O/S dependent sync object type. e.g. HANDLE, ID, OS_EVENT*,
296/ SemaphoreHandle_t and etc. A header file for O/S definitions needs to be
297/ included somewhere in the scope of ff.h. */
298
299
300
301/*--- End of configuration options ---*/


AT32F435/437 Firmwary Library: at32_sdio.c File Reference

  • at_start_f437
  • examples
  • sdio
  • sdio_fatfs
  • src
Functions | Variables
at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c File Reference

this file provides a set of functions needed to manage the sdio/mmc card memory. More...

#include <string.h>
#include "at32_sdio.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

sd_error_status_type | command_error (void)
checks for error conditions for cmd0. More...
sd_error_status_type | command_rsp1_error (uint8_t cmd)
checks for error conditions for R1 response. More...
sd_error_status_type | command_rsp2_error (void)
checks for error conditions for R2 (cid or csd) response. More...
sd_error_status_type | command_rsp3_error (void)
checks for error conditions for R3 (ocr) response. More...
sd_error_status_type | command_rsp4_error (uint8_t cmd)
checks for error conditions for r4 response. More...
sd_error_status_type | command_rsp5_error (uint8_t cmd)
checks for error conditions for r5 response. More...
sd_error_status_type | command_rsp6_error (uint8_t cmd, uint16_t *prca)
checks for error conditions for r6 (rca) response. More...
sd_error_status_type | command_rsp7_error (void)
checks for error conditions for R7 response. More...
sd_error_status_type | sd_bus_wide_enable (confirm_state new_state)
enable or disable the sdio wide bus mode. More...
sd_error_status_type | mmc_switch (uint8_t set, uint8_t index, uint8_t value)
switch mmc card speed to high speed More...
sd_error_status_type | sd_switch (uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
switch sd card speed to high speed More...
sd_error_status_type | check_card_programming (uint8_t *p_status)
checks if the sd card is in programming state. More...
sd_error_status_type | speed_change (uint8_t speed)
set bus speed More...
sd_error_status_type | scr_find (void)
find the sd card scr register value. More...
uint8_t | convert_from_bytes_to_power_of_two (uint16_t number_of_bytes)
converts the number of bytes in power of two and returns the power. More...
sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clk_div)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sdio_command_data_send (sdio_command_struct_type *sdio_cmd_init_t, sdio_data_struct_type *sdio_data_init_t, uint32_t *buf)
read data from or write data to sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
void | SDIO1_IRQHandler (void)
sdio1 isr. More...
void | SDIO2_IRQHandler (void)
sdio2 isr. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...

Variables

sdio_command_struct_type sdio_command_init_struct
sdio_data_struct_type sdio_data_init_struct
static sd_memory_card_type | card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1
static uint32_t | csd_table [4]
static uint32_t | cid_table [4]
static uint32_t | rca = 0
static sd_data_transfer_mode_type | device_mode = SD_TRANSFER_POLLING_MODE
static uint8_t | stop_flag = 0
volatile sd_error_status_type | transfer_error = SD_OK
volatile uint8_t | transfer_end = 0
sd_card_info_struct_type sd_card_info

Detailed Description

this file provides a set of functions needed to manage the sdio/mmc card memory.

Version
v2.0.9
Date
2022-06-28
        Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c.


AT32F435/437 Firmwary Library: at32_sdio.c Source File

  • at_start_f437
  • examples
  • sdio
  • sdio_fatfs
  • src
at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c
Go to the documentation of this file.
1
28#include <string.h>
29#include "at32_sdio.h"
30#include "at32f435_437_board.h"
31
40 sdio_command_struct_type sdio_command_init_struct;
41 sdio_data_struct_type sdio_data_init_struct;
42
43static sd_memory_card_type card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1; /* sd card type */
44static uint32_t csd_table[4], cid_table[4], rca = 0; /* csd, sid, rca */
45static sd_data_transfer_mode_type device_mode = SD_TRANSFER_POLLING_MODE; /* working mode */
46static uint8_t stop_flag = 0; /* transmit stop flag */
47volatile sd_error_status_type transfer_error = SD_OK; /* transmit error flag */
48volatile uint8_t transfer_end = 0; /* transmit end flag */
49 sd_card_info_struct_type sd_card_info; /* sd card information */
50
51 sd_error_status_type command_error(void);
52 sd_error_status_type command_rsp1_error(uint8_t cmd);
53 sd_error_status_type command_rsp2_error(void);
54 sd_error_status_type command_rsp3_error(void);
55 sd_error_status_type command_rsp4_error(uint8_t cmd);
56 sd_error_status_type command_rsp5_error(uint8_t cmd);
57 sd_error_status_type command_rsp6_error(uint8_t cmd, uint16_t *p_rca);
58 sd_error_status_type command_rsp7_error(void);
59 sd_error_status_type sd_bus_wide_enable(confirm_state new_state);
60 sd_error_status_type mmc_switch(uint8_t set, uint8_t index, uint8_t value);
61 sd_error_status_type sd_switch(uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp);
62 sd_error_status_type check_card_programming(uint8_t *p_status);
63 sd_error_status_type speed_change(uint8_t speed);
64 sd_error_status_type scr_find(void);
65uint8_t convert_from_bytes_to_power_of_two(uint16_t number_of_bytes);
66
73 sd_error_status_type sd_init(void)
74{
75 uint16_t clkdiv = 0;
76 sd_error_status_type status = SD_OK;
77 gpio_init_type gpio_init_struct = {0};
78 uint8_t retry = 0;
79
80 /* gpioc and gpiod periph clock enable */
81 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
82 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
83
84 /* sdio periph clock enable */
85 crm_periph_clock_enable(CRM_SDIO1_PERIPH_CLOCK, TRUE);
86
87 /* configure pc.08, pc.09, pc.10, pc.11, pc.12 pin: d0, d1, d2, d3, clk pin */
88 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
89 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
90 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
91 gpio_init_struct.gpio_pins = GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11 | GPIO_PINS_12;
92 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
93 gpio_init(GPIOC, &gpio_init_struct);
94
95 /* configure pd.02 cmd line */
96 gpio_init_struct.gpio_pins = GPIO_PINS_2;
97 gpio_init(GPIOD, &gpio_init_struct);
98
99 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE8, GPIO_MUX_12);
100 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE9, GPIO_MUX_12);
101 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE10, GPIO_MUX_12);
102 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE11, GPIO_MUX_12);
103 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE12, GPIO_MUX_12);
104 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE2, GPIO_MUX_12);
105
106 retry = 3;
107 while(retry--){
108 /* reset sdio */
109 sdio_reset(SDIOx);
110 /* power on */
111 status = sd_power_on();
112
113 if(status == SD_OK)
114 break;
115 }
116
117 if(status == SD_OK)
118 {
119 /* sdio card initialize */
120 status = sd_card_init();
121 }
122
123 if(status == SD_OK)
124 {
125 /* get card information*/
126 status = sd_card_info_get(&sd_card_info);
127 }
128
129 if((SDIO_MULTIMEDIA_CARD == card_type) && (sd_card_info.sd_csd_reg.spec_version >= 4))
130 {
131 card_type = SDIO_HIGH_SPEED_MULTIMEDIA_CARD;
132 }
133
134 if(status == SD_OK)
135 {
136 /* select card */
137 status = sd_deselect_select((uint32_t)(sd_card_info.rca << 16));
138 }
139
140 if(status == SD_OK && ((SDIO_STD_CAPACITY_SD_CARD_V1_1 == card_type) || (SDIO_STD_CAPACITY_SD_CARD_V2_0 == card_type) || \
141 (SDIO_SECURE_DIGITAL_IO_COMBO_CARD == card_type) || (SDIO_HIGH_CAPACITY_SD_CARD == card_type)))
142 {
143 status = scr_find();
144 }
145
146 if(status == SD_OK)
147 {
148 /* set normal speed */
149 status = speed_change(0);
150 }
151
152 if((status == SD_OK) || (card_type == SDIO_MULTIMEDIA_CARD))
153 {
154 if(sd_card_info.card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1 || sd_card_info.card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0)
155 {
156 /* set sdio_ck to 12mhz */
157 clkdiv = system_core_clock / 12000000;
158
159 if(clkdiv >= 2)
160 {
161 clkdiv -= 2;
162 }
163 }
164 else
165 {
166 /* set sdio_ck to 48mhz */
167 clkdiv = system_core_clock / 48000000;
168
169 if(clkdiv >= 2)
170 {
171 clkdiv -= 2;
172 }
173 }
174 /* set sdio clock divider */
175 sdio_clock_set(clkdiv);
176
177 /* set transfer mode */
178 status = sd_device_mode_set(SD_TRANSFER_DMA_MODE);
179 }
180
181 if(status == SD_OK)
182 {
183 /* Set data width */
184 status = sd_wide_bus_operation_config(SDIO_BUS_WIDTH_D4);
185 }
186
187 return status;
188}
189
195void sdio_clock_set(uint32_t clk_div)
196{
197 /* config clock divide [7:0] */
198 SDIOx->clkctrl_bit.clkdiv_l = (clk_div & 0xFF);
199
200 /* config clock divide [9:8] */
201 SDIOx->clkctrl_bit.clkdiv_h = ((clk_div & 0x300) >> 8);
202}
203
210 sd_error_status_type sd_power_on(void)
211{
212 uint8_t retry = 0;
213 sd_error_status_type status = SD_OK;
214 uint32_t response = 0, count = 0, valid_voltage = 0, clk_psc;
215 uint32_t sd_type = SD_STD_CAPACITY;
216
217 /* sdio_ck is less than 400KHz in initialization stage, set to 200KHz */
218 clk_psc = (system_core_clock / 200000) - 2;
219
220 if(clk_psc > 0x3FF)
221 {
222 clk_psc = 0x3FF;
223 }
224
225 /* config sdio clock divide and edge phase */
226 sdio_clock_config(SDIOx, clk_psc, SDIO_CLOCK_EDGE_FALLING);
227 /* config sdio bus width */
228 sdio_bus_width_config(SDIOx, SDIO_BUS_WIDTH_D1);
229 /* disable flow control */
230 sdio_flow_control_enable(SDIOx, FALSE);
231 /* disable clock bypass */
232 sdio_clock_bypass(SDIOx, FALSE);
233 /* disable power saving mode */
234 sdio_power_saving_mode_enable(SDIOx, FALSE);
235
236 /* sdio power on */
237 sdio_power_set(SDIOx, SDIO_POWER_ON);
238 /* enable to output sdio_ck */
239 sdio_clock_enable(SDIOx, TRUE);
240
241 for(retry = 0; retry < 5; retry++)
242 {
243 /* send cmd0, get in idle stage */
244 sdio_command_init_struct.argument = 0x0;
245 sdio_command_init_struct.cmd_index = SD_CMD_GO_IDLE_STATE;
246 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_NO;
247 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
248
249 /* sdio command config */
250 sdio_command_config(SDIOx, &sdio_command_init_struct);
251 /* enable ccsm */
252 sdio_command_state_machine_enable(SDIOx, TRUE);
253
254 /* get command status */
255 status = command_error();
256 }
257
258 /* send cmd8, check card interface feature */
259 sdio_command_init_struct.argument = SD_CHECK_PATTERN;
260 sdio_command_init_struct.cmd_index = SDIO_SEND_IF_COND;
261 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
262 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
263
264 /* sdio command config */
265 sdio_command_config(SDIOx, &sdio_command_init_struct);
266 /* enable ccsm */
267 sdio_command_state_machine_enable(SDIOx, TRUE);
268
269 /* waiting R7 */
270 status = command_rsp7_error();
271
272 if(status == SD_OK)
273 {
274 /* set card type and sd type */
275 card_type = SDIO_STD_CAPACITY_SD_CARD_V2_0;
276 sd_type = SD_HIGH_CAPACITY;
277 }
278
279 /* send cmd55, check sd version */
280 sdio_command_init_struct.argument = 0x00;
281 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
282 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
283 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
284
285 /* sdio command config */
286 sdio_command_config(SDIOx, &sdio_command_init_struct);
287 /* enable ccsm */
288 sdio_command_state_machine_enable(SDIOx, TRUE);
289
290 /* waiting R1 */
291 status = command_rsp1_error(SD_CMD_APP_CMD);
292
293 /* check sd card or mmc card */
294 if(SD_OK == status)
295 {
296 /* send acmd41, check voltage operation range */
297 while((!valid_voltage) && (count < SD_MAX_VOLT_TRIAL))
298 {
299 delay_ms(10);
300
301 /* send cmd55 before acmd41 */
302 sdio_command_init_struct.argument = 0x00;
303 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
304 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
305 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
306
307 /* sdio command config */
308 sdio_command_config(SDIOx, &sdio_command_init_struct);
309 /* enable ccsm */
310 sdio_command_state_machine_enable(SDIOx, TRUE);
311
312 /* waiting R1 */
313 status = command_rsp1_error(SD_CMD_APP_CMD);
314
315 /* if any errors occured, return status */
316 if(status != SD_OK)
317 {
318 return status;
319 }
320
321 /* send acmd41 */
322 sdio_command_init_struct.argument = SD_VOLTAGE_WINDOW_SD | sd_type;
323 sdio_command_init_struct.cmd_index = SD_CMD_SD_APP_OP_COND;
324 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
325 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
326
327 /* sdio command config */
328 sdio_command_config(SDIOx, &sdio_command_init_struct);
329 /* enable ccsm */
330 sdio_command_state_machine_enable(SDIOx, TRUE);
331
332 /* waiting R3 */
333 status = command_rsp3_error();
334
335 /* if any errors occured, return status */
336 if(status != SD_OK)
337 {
338 return status;
339 }
340
341 /* get response1 */
342 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
343
344 /* check sd card power on stage is success or not */
345 valid_voltage = (((response >> 31) == 1) ? 1 : 0);
346 count++;
347 }
348
349 if(count >= SD_MAX_VOLT_TRIAL)
350 {
351 status = SD_INVALID_VOLTRANGE;
352 return status;
353 }
354
355 if(response &= SD_HIGH_CAPACITY)
356 {
357 card_type = SDIO_HIGH_CAPACITY_SD_CARD;
358 }
359 }
360 /* mmc card */
361 else
362 {
363 /* send cmd1 */
364 while((!valid_voltage) && (count < SD_MAX_VOLT_TRIAL))
365 {
366 delay_ms(10);
367
368 sdio_command_init_struct.argument = SD_VOLTAGE_WINDOW_MMC;
369 sdio_command_init_struct.cmd_index = SD_CMD_SEND_OP_COND;
370 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
371 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
372
373 /* sdio command config */
374 sdio_command_config(SDIOx, &sdio_command_init_struct);
375 /* enable ccsm */
376 sdio_command_state_machine_enable(SDIOx, TRUE);
377
378 /* waiting R3 */
379 status = command_rsp3_error();
380
381 if(status != SD_OK)
382 {
383 return status;
384 }
385
386 /* get response1 */
387 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
388
389 valid_voltage = (((response >> 31) == 1) ? 1 : 0);
390 count++;
391 }
392
393 if(count >= SD_MAX_VOLT_TRIAL)
394 {
395 status = SD_INVALID_VOLTRANGE;
396 return status;
397 }
398
399 card_type = SDIO_MULTIMEDIA_CARD;
400 }
401
402 return(status);
403}
404
410 sd_error_status_type sd_power_off(void)
411{
412 /* sdio power off */
413 sdio_power_set(SDIOx, SDIO_POWER_OFF);
414
415 return SD_OK;
416}
417
424 sd_error_status_type sd_card_init(void)
425{
426 sd_error_status_type status = SD_OK;
427 uint16_t rca_temp = 0x01;
428
429 /* check power status */
430 if(SDIO_POWER_OFF == sdio_power_status_get(SDIOx))
431 {
432 return SD_REQ_NOT_APPLICABLE;
433 }
434
435 /* check is secure_digital_io_card or not */
436 if(SDIO_SECURE_DIGITAL_IO_CARD != card_type)
437 {
438 /* send cmd2, get cid register */
439 sdio_command_init_struct.argument = 0x0;
440 sdio_command_init_struct.cmd_index = SD_CMD_ALL_SEND_CID;
441 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_LONG;
442 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
443
444 /* sdio command config */
445 sdio_command_config(SDIOx, &sdio_command_init_struct);
446 /* enable ccsm */
447 sdio_command_state_machine_enable(SDIOx, TRUE);
448
449 status = command_rsp2_error();
450 if(status != SD_OK)
451 {
452 return status;
453 }
454
455 cid_table[0] = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
456 cid_table[1] = sdio_response_get(SDIOx, SDIO_RSP2_INDEX);
457 cid_table[2] = sdio_response_get(SDIOx, SDIO_RSP3_INDEX);
458 cid_table[3] = sdio_response_get(SDIOx, SDIO_RSP4_INDEX);
459 }
460
461 /* check card type */
462 if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || \
463 (card_type == SDIO_SECURE_DIGITAL_IO_COMBO_CARD) || (card_type == SDIO_HIGH_CAPACITY_SD_CARD))
464 {
465 /* send cmd3, get rca */
466 sdio_command_init_struct.argument = 0x00;
467 sdio_command_init_struct.cmd_index = SD_CMD_SET_REL_ADDR;
468 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
469 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
470
471 /* sdio command config */
472 sdio_command_config(SDIOx, &sdio_command_init_struct);
473 /* enable ccsm */
474 sdio_command_state_machine_enable(SDIOx, TRUE);
475
476 status = command_rsp6_error(SD_CMD_SET_REL_ADDR, &rca_temp);
477 if(status != SD_OK)
478 {
479 return status;
480 }
481 }
482
483 /* mmc card */
484 if(card_type == SDIO_MULTIMEDIA_CARD)
485 {
486 /* send cmd3 */
487 sdio_command_init_struct.argument = (uint32_t)(rca_temp << 16);
488 sdio_command_init_struct.cmd_index = SD_CMD_SET_REL_ADDR;
489 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
490 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
491
492 /* sdio command config */
493 sdio_command_config(SDIOx, &sdio_command_init_struct);
494 /* enable ccsm */
495 sdio_command_state_machine_enable(SDIOx, TRUE);
496
497 status = command_rsp2_error();
498 if(status != SD_OK)
499 {
500 return status;
501 }
502 }
503
504 /* check is secure_digital_io_card or not */
505 if(card_type != SDIO_SECURE_DIGITAL_IO_CARD)
506 {
507 rca = rca_temp;
508 sdio_command_init_struct.argument = (uint32_t)(rca << 16);
509 sdio_command_init_struct.cmd_index = SD_CMD_SEND_CSD;
510 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_LONG;
511 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
512
513 /* sdio command config */
514 sdio_command_config(SDIOx, &sdio_command_init_struct);
515 /* enable ccsm */
516 sdio_command_state_machine_enable(SDIOx, TRUE);
517
518 status = command_rsp2_error();
519 if(status != SD_OK)
520 {
521 return status;
522 }
523
524 csd_table[0] = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
525 csd_table[1] = sdio_response_get(SDIOx, SDIO_RSP2_INDEX);
526 csd_table[2] = sdio_response_get(SDIOx, SDIO_RSP3_INDEX);
527 csd_table[3] = sdio_response_get(SDIOx, SDIO_RSP4_INDEX);
528 }
529
530 return SD_OK;
531}
532
539 sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info)
540{
541 sd_error_status_type status = SD_OK;
542 uint8_t tmp = 0;
543
544 card_info->card_type = (uint8_t)card_type;
545 card_info->rca = (uint16_t)rca;
546
547 /* byte 0 */
548 tmp = (uint8_t)((csd_table[0] & 0xFF000000) >> 24);
549 card_info->sd_csd_reg.csd_struct = (tmp & 0xC0) >> 6;
550 card_info->sd_csd_reg.spec_version = (tmp & 0x3C) >> 2;
551 card_info->sd_csd_reg.reserved1 = tmp & 0x03;
552
553 /* byte 1 */
554 tmp = (uint8_t)((csd_table[0] & 0x00FF0000) >> 16);
555 card_info->sd_csd_reg.taac = tmp;
556
557 /* byte 2 */
558 tmp = (uint8_t)((csd_table[0] & 0x0000FF00) >> 8);
559 card_info->sd_csd_reg.nsac = tmp;
560
561 /* byte 3 */
562 tmp = (uint8_t)(csd_table[0] & 0x000000FF);
563 card_info->sd_csd_reg.max_bus_clk_freq = tmp;
564
565 /* byte 4 */
566 tmp = (uint8_t)((csd_table[1] & 0xFF000000) >> 24);
567 card_info->sd_csd_reg.card_cmd_classes = tmp << 4;
568
569 /* byte 5 */
570 tmp = (uint8_t)((csd_table[1] & 0x00FF0000) >> 16);
571 card_info->sd_csd_reg.card_cmd_classes |= (tmp & 0xF0) >> 4;
572 card_info->sd_csd_reg.max_read_blk_length = tmp & 0x0F;
573
574 /* byte 6 */
575 tmp = (uint8_t)((csd_table[1] & 0x0000FF00) >> 8);
576 card_info->sd_csd_reg.part_blk_read = (tmp & 0x80) >> 7;
577 card_info->sd_csd_reg.write_blk_misalign = (tmp & 0x40) >> 6;
578 card_info->sd_csd_reg.read_blk_misalign = (tmp & 0x20) >> 5;
579 card_info->sd_csd_reg.dsr_implemented = (tmp & 0x10) >> 4;
580 card_info->sd_csd_reg.reserved2 = 0; /* reserved */
581
582 if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || (card_type == SDIO_MULTIMEDIA_CARD))
583 {
584 card_info->sd_csd_reg.device_size = (tmp & 0x03) << 10;
585
586 /* byte 7 */
587 tmp = (uint8_t)(csd_table[1] & 0x000000FF);
588 card_info->sd_csd_reg.device_size |= (tmp) << 2;
589
590 /* byte 8 */
591 tmp = (uint8_t)((csd_table[2] & 0xFF000000) >> 24);
592 card_info->sd_csd_reg.device_size |= (tmp & 0xC0) >> 6;
593
594 card_info->sd_csd_reg.max_read_current_vdd_min = (tmp & 0x38) >> 3;
595 card_info->sd_csd_reg.max_read_current_vdd_max = (tmp & 0x07);
596
597 /* byte 9 */
598 tmp = (uint8_t)((csd_table[2] & 0x00FF0000) >> 16);
599 card_info->sd_csd_reg.max_write_current_vdd_min = (tmp & 0xE0) >> 5;
600 card_info->sd_csd_reg.max_write_current_vdd_max = (tmp & 0x1C) >> 2;
601 card_info->sd_csd_reg.device_size_mult = (tmp & 0x03) << 1;
602 /* byte 10 */
603 tmp = (uint8_t)((csd_table[2] & 0x0000FF00) >> 8);
604 card_info->sd_csd_reg.device_size_mult |= (tmp & 0x80) >> 7;
605
606 card_info->card_capacity = (card_info->sd_csd_reg.device_size + 1) ;
607 card_info->card_capacity *= (1 << (card_info->sd_csd_reg.device_size_mult + 2));
608 card_info->card_blk_size = 1 << (card_info->sd_csd_reg.max_read_blk_length);
609 card_info->card_capacity *= card_info->card_blk_size;
610 }
611 else if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
612 {
613 /* byte 7 */
614 tmp = (uint8_t)(csd_table[1] & 0x000000FF);
615 card_info->sd_csd_reg.device_size = (tmp & 0x3F) << 16;
616
617 /* byte 8 */
618 tmp = (uint8_t)((csd_table[2] & 0xFF000000) >> 24);
619
620 card_info->sd_csd_reg.device_size |= (tmp << 8);
621
622 /* byte 9 */
623 tmp = (uint8_t)((csd_table[2] & 0x00FF0000) >> 16);
624
625 card_info->sd_csd_reg.device_size |= (tmp);
626
627 /* byte 10 */
628 tmp = (uint8_t)((csd_table[2] & 0x0000FF00) >> 8);
629
630 card_info->card_capacity = (uint64_t)(card_info->sd_csd_reg.device_size + 1) * 512 * 1024;
631 card_info->card_blk_size = 512;
632 }
633
634
635 card_info->sd_csd_reg.erase_group_size = (tmp & 0x40) >> 6;
636 card_info->sd_csd_reg.erase_group_size_mult = (tmp & 0x3F) << 1;
637
638 /* byte 11 */
639 tmp = (uint8_t)(csd_table[2] & 0x000000FF);
640 card_info->sd_csd_reg.erase_group_size_mult |= (tmp & 0x80) >> 7;
641 card_info->sd_csd_reg.write_protect_group_size = (tmp & 0x7F);
642
643 /* byte 12 */
644 tmp = (uint8_t)((csd_table[3] & 0xFF000000) >> 24);
645 card_info->sd_csd_reg.write_protect_group_enable = (tmp & 0x80) >> 7;
646 card_info->sd_csd_reg.manufacturer_default_ecc = (tmp & 0x60) >> 5;
647 card_info->sd_csd_reg.write_speed_factor = (tmp & 0x1C) >> 2;
648 card_info->sd_csd_reg.max_write_blk_length = (tmp & 0x03) << 2;
649
650 /* byte 13 */
651 tmp = (uint8_t)((csd_table[3] & 0x00FF0000) >> 16);
652 card_info->sd_csd_reg.max_write_blk_length |= (tmp & 0xC0) >> 6;
653 card_info->sd_csd_reg.part_blk_write = (tmp & 0x20) >> 5;
654 card_info->sd_csd_reg.reserved3 = 0;
655 card_info->sd_csd_reg.content_protect_app = (tmp & 0x01);
656
657 /* byte 14 */
658 tmp = (uint8_t)((csd_table[3] & 0x0000FF00) >> 8);
659 card_info->sd_csd_reg.file_format_group = (tmp & 0x80) >> 7;
660 card_info->sd_csd_reg.copy_flag = (tmp & 0x40) >> 6;
661 card_info->sd_csd_reg.permanent_write_protect = (tmp & 0x20) >> 5;
662 card_info->sd_csd_reg.temp_write_protect = (tmp & 0x10) >> 4;
663 card_info->sd_csd_reg.file_formart = (tmp & 0x0C) >> 2;
664 card_info->sd_csd_reg.ecc_code = (tmp & 0x03);
665
666 /* byte 15 */
667 tmp = (uint8_t)(csd_table[3] & 0x000000FF);
668 card_info->sd_csd_reg.csd_crc = (tmp & 0xFE) >> 1;
669 card_info->sd_csd_reg.reserved4 = 1;
670
671 /* byte 0 */
672 tmp = (uint8_t)((cid_table[0] & 0xFF000000) >> 24);
673 card_info->sd_cid_reg.manufacturer_id = tmp;
674
675 /* byte 1 */
676 tmp = (uint8_t)((cid_table[0] & 0x00FF0000) >> 16);
677 card_info->sd_cid_reg.oem_app_id = tmp << 8;
678
679 /* byte 2 */
680 tmp = (uint8_t)((cid_table[0] & 0x000000FF00) >> 8);
681 card_info->sd_cid_reg.oem_app_id |= tmp;
682
683 /* byte 3 */
684 tmp = (uint8_t)(cid_table[0] & 0x000000FF);
685 card_info->sd_cid_reg.product_name1 = tmp << 24;
686
687 /* byte 4 */
688 tmp = (uint8_t)((cid_table[1] & 0xFF000000) >> 24);
689 card_info->sd_cid_reg.product_name1 |= tmp << 16;
690
691 /* byte 5 */
692 tmp = (uint8_t)((cid_table[1] & 0x00FF0000) >> 16);
693 card_info->sd_cid_reg.product_name1 |= tmp << 8;
694
695 /* byte 6 */
696 tmp = (uint8_t)((cid_table[1] & 0x0000FF00) >> 8);
697 card_info->sd_cid_reg.product_name1 |= tmp;
698
699 /* byte 7 */
700 tmp = (uint8_t)(cid_table[1] & 0x000000FF);
701 card_info->sd_cid_reg.product_name2 = tmp;
702
703 /* byte 8 */
704 tmp = (uint8_t)((cid_table[2] & 0xFF000000) >> 24);
705 card_info->sd_cid_reg.product_reversion = tmp;
706
707 /* byte 9 */
708 tmp = (uint8_t)((cid_table[2] & 0x00FF0000) >> 16);
709 card_info->sd_cid_reg.product_sn = tmp << 24;
710
711 /* byte 10 */
712 tmp = (uint8_t)((cid_table[2] & 0x0000FF00) >> 8);
713 card_info->sd_cid_reg.product_sn |= tmp << 16;
714
715 /* byte 11 */
716 tmp = (uint8_t)(cid_table[2] & 0x000000FF);
717 card_info->sd_cid_reg.product_sn |= tmp << 8;
718
719 /* byte 12 */
720 tmp = (uint8_t)((cid_table[3] & 0xFF000000) >> 24);
721 card_info->sd_cid_reg.product_sn |= tmp;
722
723 /* byte 13 */
724 tmp = (uint8_t)((cid_table[3] & 0x00FF0000) >> 16);
725 card_info->sd_cid_reg.reserved1 |= (tmp & 0xF0) >> 4;
726 card_info->sd_cid_reg.manufact_date = (tmp & 0x0F) << 8;
727
728 /* byte 14 */
729 tmp = (uint8_t)((cid_table[3] & 0x0000FF00) >> 8);
730 card_info->sd_cid_reg.manufact_date |= tmp;
731
732 /* byte 15 */
733 tmp = (uint8_t)(cid_table[3] & 0x000000FF);
734 card_info->sd_cid_reg.cid_crc = (tmp & 0xFE) >> 1;
735 card_info->sd_cid_reg.reserved2 = 1;
736
737 return(status);
738}
739
750 sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
751{
752 sd_error_status_type status = SD_OK;
753
754 if((card_type == SDIO_MULTIMEDIA_CARD) || (card_type == SDIO_HIGH_SPEED_MULTIMEDIA_CARD))
755 {
756 status = mmc_switch(EXT_CSD_CMD_SET_NORMAL, EXT_CSD_BUS_WIDTH, (uint8_t)mode);
757 }
758 else if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || \
759 (card_type == SDIO_HIGH_CAPACITY_SD_CARD))
760 {
761 if(mode >= 2)
762 {
763 /* not support D8 mode */
764 return SD_UNSUPPORTED_FEATURE;
765 }
766
767 if(SDIO_BUS_WIDTH_D4 == mode)
768 {
769 status = sd_bus_wide_enable(TRUE);
770 }
771 else
772 {
773 status = sd_bus_wide_enable(FALSE);
774 }
775 }
776
777 if(status == SD_OK)
778 {
779 sdio_bus_width_config(SDIOx, mode);
780 }
781
782 return status;
783}
784
793 sd_error_status_type sd_device_mode_set(uint32_t mode)
794{
795 sd_error_status_type status = SD_OK;
796
797 if((mode == SD_TRANSFER_DMA_MODE) || (mode == SD_TRANSFER_POLLING_MODE))
798 {
799 device_mode = (sd_data_transfer_mode_type)mode;
800 }
801 else
802 {
803 status = SD_INVALID_PARAMETER;
804 }
805
806 return status;
807}
808
814 sd_error_status_type sd_deselect_select(uint32_t addr)
815{
816 /* send cmd7, select card */
817 sdio_command_init_struct.argument = addr;
818 sdio_command_init_struct.cmd_index = SD_CMD_SEL_DESEL_CARD;
819 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
820 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_INT;
821
822 /* sdio command config */
823 sdio_command_config(SDIOx, &sdio_command_init_struct);
824 /* enable ccsm */
825 sdio_command_state_machine_enable(SDIOx, TRUE);
826
827 return command_rsp1_error(SD_CMD_SEL_DESEL_CARD);
828}
829
837 sd_error_status_type sdio_command_data_send(sdio_command_struct_type *sdio_cmd_init_t, \
838 sdio_data_struct_type* sdio_data_init_t, uint32_t *buf)
839{
840 sd_error_status_type status = SD_OK;
841 uint32_t count = 0;
842 uint32_t timeout = SDIO_DATATIMEOUT;
843 uint32_t length = 0;
844
845 if(buf == NULL)
846 {
847 return SD_INVALID_PARAMETER;
848 }
849 /* clear dtctrl register */
850 SDIOx->dtcnt = 0x0;
851
852 /* sdio command config */
853 sdio_data_config(SDIOx, sdio_data_init_t);
854 /* enable dcsm */
855 sdio_data_state_machine_enable(SDIOx, TRUE);
856
857 length = sdio_data_init_t->data_length;
858
859 if(device_mode == SD_TRANSFER_DMA_MODE)
860 {
861 if(sdio_data_init_t->transfer_direction == SDIO_DATA_TRANSFER_TO_CONTROLLER)
862 {
863 sd_dma_config(buf, length, DMA_DIR_PERIPHERAL_TO_MEMORY);
864 SDIOx->inten |= SDIO_INTR_STS_READ_MASK;
865 transfer_error = SD_OK;
866 transfer_end = 0;
867 sdio_dma_enable(SDIOx, TRUE);
868 }
869 }
870
871 /* sdio command config */
872 sdio_command_config(SDIOx, sdio_cmd_init_t);
873 /* enable ccsm */
874 sdio_command_state_machine_enable(SDIOx, TRUE);
875
876 status = command_rsp1_error(sdio_cmd_init_t->cmd_index);
877 if(status != SD_OK)
878 {
879 return status;
880 }
881
882 /* polling mode */
883 if(device_mode == SD_TRANSFER_POLLING_MODE)
884 {
885 if(SDIO_DATA_TRANSFER_TO_CONTROLLER == sdio_data_init_t->transfer_direction)
886 {
887 while(!(SDIOx->sts & (SDIO_INTR_STS_READ_MASK)))
888 {
889 if(sdio_flag_get(SDIOx, SDIO_RXBUFH_FLAG) != RESET)
890 {
891 for(count = 0; count < 8; count++, buf++)
892 {
893 *buf = sdio_data_read(SDIOx);
894 }
895
896 timeout = 0x7FFFFF;
897 }
898 else
899 {
900 if(0 == timeout)
901 {
902 sd_init();
903 return SD_DATA_TIMEOUT;
904 }
905
906 timeout--;
907 }
908 }
909
910 while(sdio_flag_get(SDIOx, SDIO_RXBUF_FLAG) != RESET)
911 {
912 *buf = sdio_data_read(SDIOx);
913 buf++;
914 }
915 }
916 else
917 {
918 while(!(SDIOx->sts & SDIO_INTR_STS_WRITE_MASK))
919 {
920 if(sdio_flag_get(SDIOx, SDIO_TXBUFH_FLAG) != RESET)
921 {
922 for(count = 0; count < 8 && length > 0; count++, buf++, length -= 4)
923 {
924 sdio_data_write(SDIOx, *buf);
925 }
926
927 timeout = 0x3FFFFFFF;
928 }
929 else
930 {
931 if(timeout == 0)
932 {
933 sd_init();
934 return SD_DATA_TIMEOUT;
935 }
936
937 timeout--;
938 }
939 }
940 }
941 /* data timeout */
942 if(sdio_flag_get(SDIOx, SDIO_DTTIMEOUT_FLAG) != RESET)
943 {
944 sdio_flag_clear(SDIOx, SDIO_DTTIMEOUT_FLAG);
945 return SD_DATA_TIMEOUT;
946 }
947 /* crc error */
948 else if(sdio_flag_get(SDIOx, SDIO_DTFAIL_FLAG) != RESET)
949 {
950 sdio_flag_clear(SDIOx, SDIO_DTFAIL_FLAG);
951 return SD_DATA_FAIL;
952 }
953 /* over run error */
954 else if(sdio_flag_get(SDIOx, SDIO_RXERRO_FLAG) != RESET)
955 {
956 sdio_flag_clear(SDIOx, SDIO_RXERRO_FLAG);
957 return SD_RX_OVERRUN;
958 }
959 /* under run error */
960 else if(sdio_flag_get(SDIOx, SDIO_TXERRU_FLAG) != RESET)
961 {
962 sdio_flag_clear(SDIOx, SDIO_TXERRU_FLAG);
963 return SD_TX_UNDERRUN;
964 }
965 /* start bit error */
966 else if(sdio_flag_get(SDIOx, SDIO_SBITERR_FLAG) != RESET)
967 {
968 sdio_flag_clear(SDIOx, SDIO_SBITERR_FLAG);
969 return SD_START_BIT_ERR;
970 }
971 /* data transfer complete */
972 if((stop_flag == 1) && (sdio_flag_get(SDIOx, SDIO_DTCMPL_FLAG) != RESET))
973 {
974 /* send cmd12, stop transmission */
975 sdio_cmd_init_t->argument = 0;
976 sdio_cmd_init_t->cmd_index = SD_CMD_STOP_TRANSMISSION;
977 sdio_cmd_init_t->rsp_type = SDIO_RESPONSE_SHORT;
978 sdio_cmd_init_t->wait_type = SDIO_WAIT_FOR_NO;
979
980 /* sdio command config */
981 sdio_command_config(SDIOx, sdio_cmd_init_t);
982 /* enable ccsm */
983 sdio_command_state_machine_enable(SDIOx, TRUE);
984
985 status = command_rsp1_error(SD_CMD_STOP_TRANSMISSION);
986
987 if(status != SD_OK)
988 {
989 return status;
990 }
991 }
992
993 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
994 }
995 else if(device_mode == SD_TRANSFER_DMA_MODE)
996 {
997 if(sdio_data_init_t->transfer_direction == SDIO_DATA_TRANSFER_TO_CARD)
998 {
999 sd_dma_config(buf, length, DMA_DIR_MEMORY_TO_PERIPHERAL);
1000 SDIOx->inten |= SDIO_INTR_STS_WRITE_MASK;
1001 transfer_error = SD_OK;
1002 transfer_end = 0;
1003 sdio_dma_enable(SDIOx, TRUE);
1004 }
1005
1006 while(!(SDIOx->sts & SDIOx->inten) && timeout)
1007 {
1008 timeout--;
1009
1010 if(transfer_end)
1011 {
1012 break;
1013 }
1014 }
1015
1016 if(timeout == 0)
1017 {
1018 sd_init();
1019 return SD_DATA_TIMEOUT;
1020 }
1021
1022 if(transfer_error != SD_OK)
1023 {
1024 status = transfer_error;
1025 }
1026 }
1027
1028 return status;
1029}
1030
1037 sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks)
1038{
1039 sd_error_status_type status = SD_OK;
1040 uint32_t start_addr = 0, end_addr = 0, response = 0;
1041 uint8_t card_state;
1042
1043 /* high capacity sd card */
1044 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1045 {
1046 start_addr = addr >> 9;
1047 end_addr = start_addr + nblks - 1;
1048 }
1049 else
1050 {
1051 start_addr = addr;
1052 end_addr = start_addr + (nblks - 1) * 512;
1053 }
1054
1055 /* clear dcsm configuration */
1056 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1057 sdio_data_init_struct.data_length = 0 ;
1058 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1059 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1060 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1061
1062 sdio_data_config(SDIOx, &sdio_data_init_struct);
1063 sdio_data_state_machine_enable(SDIOx, FALSE);
1064
1065 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1066
1067 /* check card locked */
1068 if(response & SD_CARD_LOCKED)
1069 {
1070 return SD_LOCK_UNLOCK_ERROR;
1071 }
1072
1073 if(card_type == SDIO_MULTIMEDIA_CARD || card_type == SDIO_HIGH_SPEED_MULTIMEDIA_CARD)
1074 {
1075 /* send cmd35, set erase group start */
1076 sdio_command_init_struct.argument = start_addr;
1077 sdio_command_init_struct.cmd_index = SD_CMD_ERASE_GRP_START;
1078 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1079 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1080
1081 /* sdio command config */
1082 sdio_command_config(SDIOx, &sdio_command_init_struct);
1083 /* enable ccsm */
1084 sdio_command_state_machine_enable(SDIOx, TRUE);
1085
1086 status = command_rsp1_error(SD_CMD_ERASE_GRP_START);
1087
1088 if(status != SD_OK)
1089 {
1090 return status;
1091 }
1092
1093 /* send cmd36, set erase group end */
1094 sdio_command_init_struct.argument = end_addr;
1095 sdio_command_init_struct.cmd_index = SD_CMD_ERASE_GRP_END;
1096
1097 /* sdio command config */
1098 sdio_command_config(SDIOx, &sdio_command_init_struct);
1099 /* enable ccsm */
1100 sdio_command_state_machine_enable(SDIOx, TRUE);
1101
1102 status = command_rsp1_error(SD_CMD_ERASE_GRP_END);
1103
1104 if(status != SD_OK)
1105 {
1106 return status;
1107 }
1108
1109 /* send cmd38, start erase gourp */
1110 sdio_command_init_struct.argument = 0;
1111 sdio_command_init_struct.cmd_index = SD_CMD_ERASE;
1112
1113 /* sdio command config */
1114 sdio_command_config(SDIOx, &sdio_command_init_struct);
1115 /* enable ccsm */
1116 sdio_command_state_machine_enable(SDIOx, TRUE);
1117
1118 status = command_rsp1_error(SD_CMD_ERASE);
1119
1120 if(status != SD_OK)
1121 {
1122 return status;
1123 }
1124 }
1125 else
1126 {
1127 /* send cmd32, set erase block start */
1128 sdio_command_init_struct.argument = start_addr;
1129 sdio_command_init_struct.cmd_index = SD_CMD_SD_ERASE_GRP_START;
1130 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1131 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1132
1133 /* sdio command config */
1134 sdio_command_config(SDIOx, &sdio_command_init_struct);
1135 /* enable ccsm */
1136 sdio_command_state_machine_enable(SDIOx, TRUE);
1137
1138 status = command_rsp1_error(SD_CMD_SD_ERASE_GRP_START);
1139
1140 if(status != SD_OK)
1141 {
1142 return status;
1143 }
1144
1145 /* send cmd33, set erase block end */
1146 sdio_command_init_struct.argument = end_addr;
1147 sdio_command_init_struct.cmd_index = SD_CMD_SD_ERASE_GRP_END;
1148
1149 /* sdio command config */
1150 sdio_command_config(SDIOx, &sdio_command_init_struct);
1151 /* enable ccsm */
1152 sdio_command_state_machine_enable(SDIOx, TRUE);
1153
1154 if(status != SD_OK)
1155 {
1156 return status;
1157 }
1158
1159 /* send cmd38, start erase block */
1160 sdio_command_init_struct.argument = 0;
1161 sdio_command_init_struct.cmd_index = SD_CMD_ERASE;
1162
1163 /* sdio command config */
1164 sdio_command_config(SDIOx, &sdio_command_init_struct);
1165 /* enable ccsm */
1166 sdio_command_state_machine_enable(SDIOx, TRUE);
1167
1168 status = command_rsp1_error(SD_CMD_ERASE);
1169
1170 if(status != SD_OK)
1171 {
1172 return status;
1173 }
1174 }
1175
1176 status = check_card_programming(&card_state);
1177
1178 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || \
1179 (card_state == SD_CARD_RECEIVING)))
1180 {
1181 status = check_card_programming(&card_state);
1182 }
1183
1184 return status;
1185}
1186
1195 sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
1196{
1197 sd_error_status_type status = SD_OK;
1198 uint32_t response = 0;
1199 uint8_t power;
1200
1201 if(NULL == buf)
1202 {
1203 return SD_INVALID_PARAMETER;
1204 }
1205
1206 SDIOx->dtctrl = 0x0;
1207
1208 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1209 {
1210 blk_size = 512;
1211 addr >>= 9;
1212 }
1213
1214 /* clear dcsm configuration */
1215 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1216 sdio_data_init_struct.data_length = 0;
1217 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1218 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1219 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1220
1221 sdio_data_config(SDIOx, &sdio_data_init_struct);
1222 sdio_data_state_machine_enable(SDIOx, FALSE);
1223
1224 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1225
1226 /* check card locked */
1227 if(response & SD_CARD_LOCKED)
1228 {
1229 return SD_LOCK_UNLOCK_ERROR;
1230 }
1231
1232 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1233 {
1234 power = convert_from_bytes_to_power_of_two(blk_size);
1235
1236 /* send cmd16, set block size */
1237 sdio_command_init_struct.argument = blk_size;
1238 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1239 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1240 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1241
1242 /* sdio command config */
1243 sdio_command_config(SDIOx, &sdio_command_init_struct);
1244 /* enable ccsm */
1245 sdio_command_state_machine_enable(SDIOx, TRUE);
1246
1247 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1248
1249 if(status != SD_OK)
1250 {
1251 return status;
1252 }
1253 }
1254 else
1255 {
1256 return SD_INVALID_PARAMETER;
1257 }
1258
1259 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1260 sdio_data_init_struct.data_length = blk_size ;
1261 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1262 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
1263 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1264
1265 sdio_command_init_struct.argument = addr;
1266 sdio_command_init_struct.cmd_index = SD_CMD_READ_SINGLE_BLOCK;
1267 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1268 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1269
1270 stop_flag = 0;
1271
1272 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1273}
1274
1284 sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
1285{
1286 sd_error_status_type status = SD_OK;
1287 uint32_t response = 0;
1288 uint8_t power;
1289
1290 SDIOx->dtctrl = 0x0;
1291
1292 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1293 {
1294 blk_size = 512;
1295 addr >>= 9;
1296 }
1297
1298 /* clear dcsm configuration */
1299 sdio_data_init_struct.block_size = (sdio_block_size_type)0;
1300 sdio_data_init_struct.data_length = 0;
1301 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1302 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1303 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1304
1305 sdio_data_config(SDIOx, &sdio_data_init_struct);
1306 sdio_data_state_machine_enable(SDIOx, FALSE);
1307
1308 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1309
1310 /* check card locked */
1311 if(response & SD_CARD_LOCKED)
1312 {
1313 return SD_LOCK_UNLOCK_ERROR;
1314 }
1315
1316 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1317 {
1318 power = convert_from_bytes_to_power_of_two(blk_size);
1319
1320 /* send cmd16, set block size */
1321 sdio_command_init_struct.argument = blk_size;
1322 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1323 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1324 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1325
1326 /* sdio command config */
1327 sdio_command_config(SDIOx, &sdio_command_init_struct);
1328 /* enable ccsm */
1329 sdio_command_state_machine_enable(SDIOx, TRUE);
1330
1331 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1332
1333 if(status != SD_OK)
1334 {
1335 return status;
1336 }
1337 }
1338 else
1339 {
1340 return SD_INVALID_PARAMETER;
1341 }
1342
1343 /* check max receive length */
1344 if(nblks * blk_size > SD_MAX_DATA_LENGTH)
1345 {
1346 return SD_INVALID_PARAMETER;
1347 }
1348
1349 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1350 sdio_data_init_struct.data_length = nblks * blk_size ;
1351 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1352 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
1353 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1354
1355 /* send cmd18, read block data */
1356 sdio_command_init_struct.argument = addr;
1357 sdio_command_init_struct.cmd_index = SD_CMD_READ_MULT_BLOCK;
1358 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1359 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1360
1361 stop_flag = 1;
1362
1363 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1364}
1365
1374 sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
1375{
1376 sd_error_status_type status = SD_OK;
1377 uint8_t power = 0, card_state = 0;
1378 uint32_t timeout = 0, card_status = 0, response = 0;
1379
1380 if(buf == NULL)
1381 {
1382 return SD_INVALID_PARAMETER;
1383 }
1384
1385 SDIOx->dtctrl = 0x0;
1386
1387 /* clear dcsm configuration */
1388 sdio_data_init_struct.block_size = (sdio_block_size_type)0;
1389 sdio_data_init_struct.data_length = 0;
1390 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1391 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1392 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1393
1394 sdio_data_config(SDIOx, &sdio_data_init_struct);
1395 sdio_data_state_machine_enable(SDIOx, FALSE);
1396
1397 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1398
1399 /* check card locked */
1400 if(response & SD_CARD_LOCKED)
1401 {
1402 return SD_LOCK_UNLOCK_ERROR;
1403 }
1404
1405 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1406 {
1407 blk_size = 512;
1408 addr >>= 9;
1409 }
1410
1411 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1412 {
1413 power = convert_from_bytes_to_power_of_two(blk_size);
1414
1415 /* send cmd16, set block size */
1416 sdio_command_init_struct.argument = blk_size;
1417 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1418 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1419 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1420
1421 /* sdio command config */
1422 sdio_command_config(SDIOx, &sdio_command_init_struct);
1423 /* enable ccsm */
1424 sdio_command_state_machine_enable(SDIOx, TRUE);
1425
1426 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1427
1428 if(status != SD_OK)
1429 {
1430 return status;
1431 }
1432 }
1433 else
1434 {
1435 return SD_INVALID_PARAMETER;
1436 }
1437
1438 timeout = SD_DATATIMEOUT;
1439
1440 do
1441 {
1442 timeout--;
1443 status = sd_status_send(&card_status);
1444 }
1445 /* check ready_for_data flag */
1446 while(((card_status & 0x00000100) == 0) && (timeout > 0));
1447
1448 if(timeout == 0)
1449 {
1450 return SD_ERROR;
1451 }
1452
1453 /* send cmd24, write single block */
1454 sdio_command_init_struct.argument = addr;
1455 sdio_command_init_struct.cmd_index = SD_CMD_WRITE_SINGLE_BLOCK;
1456 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1457 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1458
1459 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1460 sdio_data_init_struct.data_length = blk_size;
1461 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1462 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1463 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1464
1465 stop_flag = 0;
1466
1467 /* single block, stop command is unnecessary */
1468 status = sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1469
1470 if(status != SD_OK)
1471 {
1472 return status;
1473 }
1474
1475 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1476
1477 status = check_card_programming(&card_state);
1478
1479 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || (card_state == SD_CARD_RECEIVING)))
1480 {
1481 status = check_card_programming(&card_state);
1482 }
1483
1484 return status;
1485}
1486
1496 sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
1497{
1498 sd_error_status_type status = SD_OK;
1499 uint8_t power = 0, card_state = 0;
1500 uint32_t timeout = 0, card_status = 0, response = 0;;
1501
1502 if(buf == NULL)
1503 {
1504 return SD_INVALID_PARAMETER;
1505 }
1506
1507 SDIOx->dtctrl = 0x0;
1508
1509 /* clear dcsm configuration */
1510 sdio_data_init_struct.block_size = (sdio_block_size_type)0;
1511 sdio_data_init_struct.data_length = 0;
1512 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1513 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1514 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1515
1516 sdio_data_config(SDIOx, &sdio_data_init_struct);
1517 sdio_data_state_machine_enable(SDIOx, FALSE);
1518
1519 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1520
1521 /* check card locked */
1522 if(response & SD_CARD_LOCKED)
1523 {
1524 return SD_LOCK_UNLOCK_ERROR;
1525 }
1526
1527 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1528 {
1529 blk_size = 512;
1530 addr >>= 9;
1531 }
1532
1533 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1534 {
1535 power = convert_from_bytes_to_power_of_two(blk_size);
1536
1537 /* send cmd16, set block size */
1538 sdio_command_init_struct.argument = blk_size;
1539 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1540 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1541 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1542
1543 /* sdio command config */
1544 sdio_command_config(SDIOx, &sdio_command_init_struct);
1545 /* enable ccsm */
1546 sdio_command_state_machine_enable(SDIOx, TRUE);
1547
1548 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1549
1550 if(status != SD_OK)
1551 {
1552 return status;
1553 }
1554 }
1555 else
1556 {
1557 return SD_INVALID_PARAMETER;
1558 }
1559
1560 if((nblks * blk_size) > SD_MAX_DATA_LENGTH)
1561 {
1562 return SD_INVALID_PARAMETER;
1563 }
1564
1565 timeout = SD_DATATIMEOUT;
1566
1567 do
1568 {
1569 timeout--;
1570 status = sd_status_send(&card_status);
1571 }
1572 /* check ready_for_data flag */
1573 while(((card_status & 0x00000100) == 0) && (timeout > 0));
1574
1575 if(timeout == 0)
1576 {
1577 return SD_ERROR;
1578 }
1579
1580 if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || \
1581 (card_type == SDIO_HIGH_CAPACITY_SD_CARD))
1582 {
1583 /* send cmd55 */
1584 sdio_command_init_struct.argument = (uint32_t)rca << 16;
1585 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
1586 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1587 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1588
1589 /* sdio command config */
1590 sdio_command_config(SDIOx, &sdio_command_init_struct);
1591 /* enable ccsm */
1592 sdio_command_state_machine_enable(SDIOx, TRUE);
1593
1594 status = command_rsp1_error(SD_CMD_APP_CMD);
1595
1596 if(status != SD_OK)
1597 {
1598 return status;
1599 }
1600
1601 /* send cmd23, set block count */
1602 sdio_command_init_struct.argument = blk_size;
1603 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCK_COUNT;
1604 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1605 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1606
1607 /* sdio command config */
1608 sdio_command_config(SDIOx, &sdio_command_init_struct);
1609 /* enable ccsm */
1610 sdio_command_state_machine_enable(SDIOx, TRUE);
1611
1612 status = command_rsp1_error(SD_CMD_SET_BLOCK_COUNT);
1613
1614 if(status != SD_OK)
1615 {
1616 return status;
1617 }
1618 }
1619
1620 /* send cmd25, write mult blocks */
1621 sdio_command_init_struct.argument = addr;
1622 sdio_command_init_struct.cmd_index = SD_CMD_WRITE_MULT_BLOCK;
1623 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1624 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1625
1626 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1627 sdio_data_init_struct.data_length = nblks * blk_size ;
1628 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1629 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1630 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1631
1632 stop_flag = 1;
1633 /* cmd12 is needed */
1634 status = sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1635
1636 if(status != SD_OK)
1637 {
1638 return status;
1639 }
1640
1641 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1642
1643 status = check_card_programming(&card_state);
1644
1645 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || (card_state == SD_CARD_RECEIVING)))
1646 {
1647 status = check_card_programming(&card_state);
1648 }
1649
1650 return status;
1651}
1652
1660 sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
1661{
1662 uint32_t response = 0;
1663
1664 SDIOx->dtctrl = 0x0;
1665
1666 /* clear dcsm configuration */
1667 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1668 sdio_data_init_struct.data_length = 0 ;
1669 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1670 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1671 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1672
1673 sdio_data_config(SDIOx, &sdio_data_init_struct);
1674 sdio_data_state_machine_enable(SDIOx, FALSE);
1675
1676 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1677
1678 /* check card locked */
1679 if(response & SD_CARD_LOCKED)
1680 {
1681 return SD_LOCK_UNLOCK_ERROR;
1682 }
1683 /* send cmd11, read data */
1684 sdio_command_init_struct.argument = addr;
1685 sdio_command_init_struct.cmd_index = SD_CMD_READ_DAT_UNTIL_STOP;
1686 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1687 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1688
1689 sdio_data_init_struct.block_size = (sdio_block_size_type)(5 << 4);
1690 sdio_data_init_struct.data_length = len;
1691 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1692 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
1693 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1694
1695 stop_flag = 1;
1696 /* cmd12 is needed */
1697 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1698}
1699
1707 sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
1708{
1709 sd_error_status_type status = SD_OK;
1710 uint32_t response = 0;
1711 uint8_t card_state = 0;
1712
1713 if(buf == NULL)
1714 {
1715 return SD_INVALID_PARAMETER;
1716 }
1717
1718 SDIOx->dtctrl = 0x0;
1719
1720 /* clear dcsm configuration */
1721 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1722 sdio_data_init_struct.data_length = 0;
1723 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1724 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1725 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1726
1727 sdio_data_config(SDIOx, &sdio_data_init_struct);
1728 sdio_data_state_machine_enable(SDIOx, FALSE);
1729
1730 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1731
1732 /* check card locked */
1733 if(response & SD_CARD_LOCKED)
1734 {
1735 return SD_LOCK_UNLOCK_ERROR;
1736 }
1737 /* send cmd20, write data */
1738 sdio_command_init_struct.argument = addr;
1739 sdio_command_init_struct.cmd_index = SD_CMD_WRITE_DAT_UNTIL_STOP;
1740 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1741 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1742
1743
1744 sdio_data_init_struct.block_size = (sdio_block_size_type)(15 << 4);
1745 sdio_data_init_struct.data_length = len;
1746 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1747 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1748 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1749
1750 stop_flag = 1;
1751 /* cmd12 is needed */
1752 status = sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1753
1754 if(status != SD_OK)
1755 {
1756 return status;
1757 }
1758
1759 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1760
1761 status = check_card_programming(&card_state);
1762
1763 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || (card_state == SD_CARD_RECEIVING)))
1764 {
1765 status = check_card_programming(&card_state);
1766 }
1767
1768 return status;
1769}
1770
1776void SDIO1_IRQHandler(void)
1777{
1778 sd_irq_service();
1779}
1780
1786void SDIO2_IRQHandler(void)
1787{
1788 sd_irq_service();
1789}
1790
1796 sd_error_status_type sd_irq_service(void)
1797{
1798 if(sdio_flag_get(SDIOx, SDIO_DTCMPL_FLAG) != RESET)
1799 {
1800 if(stop_flag == 1)
1801 {
1802 /* send cmd12, stop transmission */
1803 sdio_command_init_struct.argument = 0;
1804 sdio_command_init_struct.cmd_index = SD_CMD_STOP_TRANSMISSION;
1805 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1806 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1807 /* sdio command config */
1808 sdio_command_config(SDIOx, &sdio_command_init_struct);
1809 /* enable ccsm */
1810 sdio_command_state_machine_enable(SDIOx, TRUE);
1811 transfer_error = command_rsp1_error(SD_CMD_STOP_TRANSMISSION);
1812 }
1813 else
1814 {
1815 transfer_error = SD_OK;
1816 }
1817 /* clear flag */
1818 sdio_flag_clear(SDIOx, SDIO_DTCMPL_FLAG);
1819 transfer_end = 1;
1820 return transfer_error;
1821 }
1822
1823 if(sdio_flag_get(SDIOx, SDIO_DTFAIL_FLAG) != RESET)
1824 {
1825 /* clear flag */
1826 sdio_flag_clear(SDIOx, SDIO_DTFAIL_FLAG);
1827 transfer_error = SD_DATA_FAIL;
1828 transfer_end = 1;
1829 return transfer_error;
1830 }
1831
1832 if(sdio_flag_get(SDIOx, SDIO_DTTIMEOUT_FLAG) != RESET)
1833 {
1834 /* clear flag */
1835 sdio_flag_clear(SDIOx, SDIO_DTTIMEOUT_FLAG);
1836 transfer_error = SD_DATA_TIMEOUT;
1837 transfer_end = 1;
1838 return transfer_error;
1839 }
1840
1841 if(sdio_flag_get(SDIOx, SDIO_RXERRO_FLAG) != RESET)
1842 {
1843 /* clear flag */
1844 sdio_flag_clear(SDIOx, SDIO_RXERRO_FLAG);
1845 transfer_error = SD_RX_OVERRUN;
1846 transfer_end = 1;
1847 return(SD_RX_OVERRUN);
1848 }
1849
1850 if(sdio_flag_get(SDIOx, SDIO_TXERRU_FLAG) != RESET)
1851 {
1852 /* clear flag */
1853 sdio_flag_clear(SDIOx, SDIO_TXERRU_FLAG);
1854 transfer_error = SD_TX_UNDERRUN;
1855 transfer_end = 1;
1856 return(SD_TX_UNDERRUN);
1857 }
1858
1859 if(sdio_flag_get(SDIOx, SDIO_SBITERR_FLAG) != RESET)
1860 {
1861 /* clear flag */
1862 sdio_flag_clear(SDIOx, SDIO_SBITERR_FLAG);
1863 transfer_error = SD_START_BIT_ERR;
1864 transfer_end = 1;
1865 return(SD_START_BIT_ERR);
1866 }
1867
1868 /* disable interrupt */
1869 sdio_interrupt_enable(SDIOx, (SDIO_DTFAIL_INT | SDIO_DTTIMEOUT_INT | \
1870 SDIO_DTCMP_INT | SDIO_TXBUFH_INT | SDIO_RXBUFH_INT | \
1871 SDIO_TXERRU_INT| SDIO_RXERRO_INT | SDIO_SBITERR_INT), FALSE);
1872 return(SD_OK);
1873}
1874
1880 sd_error_status_type command_error(void)
1881{
1882 sd_error_status_type status = SD_OK;
1883 uint32_t timeout = SDIO_CMD0TIMEOUT;
1884
1885 while(timeout--)
1886 {
1887 if(sdio_flag_get(SDIOx, SDIO_CMDCMPL_FLAG) != RESET)
1888 {
1889 break;
1890 }
1891 }
1892
1893 if(timeout == 0)
1894 {
1895 return SD_CMD_RSP_TIMEOUT;
1896 }
1897
1898 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1899 return status;
1900}
1901
1907 sd_error_status_type command_rsp7_error(void)
1908{
1909 sd_error_status_type status = SD_OK;
1910 uint32_t sts_reg = 0;
1911 uint32_t timeout = SDIO_CMD0TIMEOUT;
1912
1913 while(timeout--)
1914 {
1915 sts_reg = SDIOx->sts;
1916
1917 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
1918 {
1919 break;
1920 }
1921 }
1922
1923 if((timeout == 0) || (sts_reg & SDIO_CMDTIMEOUT_FLAG))
1924 {
1925 status = SD_CMD_RSP_TIMEOUT;
1926 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
1927 return status;
1928 }
1929
1930 if(sts_reg & SDIO_CMDRSPCMPL_FLAG)
1931 {
1932 status = SD_OK;
1933 sdio_flag_clear(SDIOx, SDIO_CMDRSPCMPL_FLAG);
1934 }
1935
1936 return status;
1937}
1938
1944 sd_error_status_type command_rsp1_error(uint8_t cmd)
1945{
1946 uint32_t sts_reg = 0;
1947 uint32_t rsp_cmd = 0;
1948
1949 while(1)
1950 {
1951 sts_reg = SDIOx->sts;
1952
1953 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
1954 {
1955 break;
1956 }
1957 }
1958
1959 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
1960 {
1961 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
1962 return SD_CMD_RSP_TIMEOUT;
1963 }
1964
1965 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
1966 {
1967 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
1968 return SD_CMD_FAIL;
1969 }
1970
1971 rsp_cmd = sdio_command_response_get(SDIOx);
1972 if(rsp_cmd != cmd)
1973 {
1974 return SD_ILLEGAL_CMD;
1975 }
1976
1977 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1978
1979 return (sd_error_status_type)(sdio_response_get(SDIOx, SDIO_RSP1_INDEX) & SD_OCR_ERRORBITS);
1980}
1981
1987 sd_error_status_type command_rsp3_error(void)
1988{
1989 uint32_t sts_reg = 0;;
1990
1991 while(1)
1992 {
1993 sts_reg = SDIOx->sts;
1994
1995 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
1996 {
1997 break;
1998 }
1999 }
2000
2001 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2002 {
2003 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2004 return SD_CMD_RSP_TIMEOUT;
2005 }
2006
2007 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2008
2009 return SD_OK;
2010}
2011
2017 sd_error_status_type command_rsp2_error(void)
2018{
2019 sd_error_status_type status = SD_OK;
2020 uint32_t sts_reg;
2021 uint32_t timeout = SDIO_CMD0TIMEOUT;
2022
2023 while(timeout--)
2024 {
2025 sts_reg = SDIOx->sts;
2026
2027 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2028 {
2029 break;
2030 }
2031 }
2032
2033 if((timeout == 0) || sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2034 {
2035 status = SD_CMD_RSP_TIMEOUT;
2036 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2037
2038 return status;
2039 }
2040
2041 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2042 {
2043 status = SD_CMD_FAIL;
2044 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2045 }
2046
2047 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2048
2049 return status;
2050}
2051
2057 sd_error_status_type command_rsp4_error(uint8_t cmd)
2058{
2059 uint32_t sts_reg = 0, rsp_cmd = 0;
2060
2061 while(1)
2062 {
2063 sts_reg = SDIOx->sts;
2064
2065 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2066 {
2067 break;
2068 }
2069 }
2070
2071 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2072 {
2073 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2074 return SD_CMD_RSP_TIMEOUT;
2075 }
2076
2077 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2078 {
2079 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2080
2081 return SD_CMD_FAIL;
2082 }
2083
2084 rsp_cmd = sdio_command_response_get(SDIOx);
2085 if(rsp_cmd != cmd)
2086 {
2087 return SD_ILLEGAL_CMD;
2088 }
2089
2090 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2091
2092 return SD_OK;
2093}
2094
2100 sd_error_status_type command_rsp5_error(uint8_t cmd)
2101{
2102 uint32_t sts_reg = 0, rsp_cmd = 0, response = 0;
2103
2104 while(1)
2105 {
2106 sts_reg = SDIOx->sts;
2107
2108 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2109 {
2110 break;
2111 }
2112 }
2113
2114 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2115 {
2116 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2117
2118 return SD_CMD_RSP_TIMEOUT;
2119 }
2120
2121 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2122 {
2123 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2124
2125 return SD_CMD_FAIL;
2126 }
2127
2128 rsp_cmd = sdio_command_response_get(SDIOx);
2129 if(rsp_cmd != cmd)
2130 {
2131 return SD_ILLEGAL_CMD;
2132 }
2133
2134 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2135
2136 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2137
2138 if(response & SD_R5_OUT_OF_RANGE)
2139 {
2140 return SD_CMD_OUT_OF_RANGE;
2141 }
2142
2143 if(response & SD_R5_FUNCTION_NUMBER)
2144 {
2145 return SD_SDIO_UNKNOWN_FUNC;
2146 }
2147
2148 if(response & SD_R5_ERROR)
2149 {
2150 return SD_GENERAL_UNKNOWN_ERROR;
2151 }
2152
2153 return SD_OK;
2154}
2155
2163 sd_error_status_type command_rsp6_error(uint8_t cmd, uint16_t *prca)
2164{
2165 sd_error_status_type status = SD_OK;
2166 uint32_t sts_reg, rsp_cmd = 0, response = 0;
2167
2168 while(1)
2169 {
2170 sts_reg = SDIOx->sts;
2171
2172 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2173 {
2174 break;
2175 }
2176 }
2177
2178 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2179 {
2180 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2181 return SD_CMD_RSP_TIMEOUT;
2182 }
2183
2184 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2185 {
2186 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2187 return SD_CMD_FAIL;
2188 }
2189
2190 rsp_cmd = sdio_command_response_get(SDIOx);
2191 if(rsp_cmd != cmd)
2192 {
2193 return SD_ILLEGAL_CMD;
2194 }
2195
2196 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2197
2198 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2199
2200 if(SD_ALLZERO == (response & (SD_R6_GENERAL_UNKNOWN_ERROR | SD_R6_ILLEGAL_CMD | SD_R6_CMD_CRC_ERROR)))
2201 {
2202 *prca = (uint16_t)(response >> 16);
2203 return status;
2204 }
2205
2206 if(response & SD_R6_GENERAL_UNKNOWN_ERROR)
2207 {
2208 return SD_GENERAL_UNKNOWN_ERROR;
2209 }
2210
2211 if(response & SD_R6_ILLEGAL_CMD)
2212 {
2213 return SD_ILLEGAL_CMD;
2214 }
2215
2216 if(response & SD_R6_CMD_CRC_ERROR)
2217 {
2218 return SD_CMD_CRC_ERROR;
2219 }
2220
2221 return status;
2222}
2223
2229 sd_error_status_type sd_bus_wide_enable(confirm_state new_state)
2230{
2231 sd_error_status_type status = SD_OK;
2232 uint32_t response = 0;
2233 uint8_t arg = 0x00;
2234
2235 if(new_state == TRUE)
2236 {
2237 arg = 0x02;
2238 }
2239 else
2240 {
2241 arg = 0x00;
2242 }
2243
2244 /* get response1 */
2245 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2246
2247 /* check card locked or not */
2248 if(response & SD_CARD_LOCKED)
2249 {
2250 return SD_LOCK_UNLOCK_ERROR;
2251 }
2252
2253 if(sd_card_info.sd_scr_reg.sd_bus_width)
2254 {
2255 sdio_command_init_struct.argument = (uint32_t)(sd_card_info.rca << 16);
2256 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
2257 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2258 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2259
2260 /* sdio command config */
2261 sdio_command_config(SDIOx, &sdio_command_init_struct);
2262 /* enable ccsm */
2263 sdio_command_state_machine_enable(SDIOx, TRUE);
2264
2265 status = command_rsp1_error(SD_CMD_APP_CMD);
2266
2267 if(status != SD_OK)
2268 {
2269 return status;
2270 }
2271
2272 sdio_command_init_struct.argument = arg;
2273 sdio_command_init_struct.cmd_index = SD_CMD_APP_SD_SET_BUSWIDTH;
2274 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2275 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2276
2277 /* sdio command config */
2278 sdio_command_config(SDIOx, &sdio_command_init_struct);
2279 /* enable ccsm */
2280 sdio_command_state_machine_enable(SDIOx, TRUE);
2281
2282 status = command_rsp1_error(SD_CMD_APP_SD_SET_BUSWIDTH);
2283 return status;
2284 }
2285 else
2286 {
2287 return SD_REQ_NOT_APPLICABLE;
2288 }
2289}
2290
2298 sd_error_status_type mmc_switch(uint8_t set, uint8_t index, uint8_t value)
2299{
2300 sd_error_status_type status = SD_OK;
2301 uint32_t card_status = 0, timeout = 0;
2302
2303 sdio_command_init_struct.argument = (EXT_CSD_Write_byte << 24) | (index << 16) | (value << 8) | set;
2304 sdio_command_init_struct.cmd_index = SD_CMD_HS_SWITCH;
2305 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2306 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2307
2308 /* sdio command config */
2309 sdio_command_config(SDIOx, &sdio_command_init_struct);
2310 /* enable ccsm */
2311 sdio_command_state_machine_enable(SDIOx, TRUE);
2312
2313 status = command_rsp1_error(SD_CMD_HS_SWITCH);
2314 if(status != SD_OK)
2315 {
2316 return status;
2317 }
2318
2319 card_status = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2320 if(card_status & MMC_SWITCH_ERROR)
2321 {
2322 return SD_SWITCH_ERROR;
2323 }
2324
2325 timeout = SD_DATATIMEOUT;
2326 do
2327 {
2328 timeout--;
2329 status = sd_status_send(&card_status);
2330 } /* check ready_for_data flag */
2331 while(((card_status & 0x00000100) == 0) && (timeout > 0));
2332
2333 if(timeout == 0)
2334 {
2335 return SD_ERROR;
2336 }
2337
2338 return status;
2339}
2340
2349 sd_error_status_type sd_switch(uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
2350{
2351 sd_error_status_type status = SD_OK;
2352 uint8_t power;
2353 uint16_t blk_size;
2354
2355 if(rsp == NULL)
2356 {
2357 return SD_INVALID_PARAMETER;
2358 }
2359
2360 SDIOx->dtctrl = 0x0;
2361
2362 blk_size = 64;
2363 power = convert_from_bytes_to_power_of_two(blk_size);
2364
2365 sdio_command_init_struct.argument = blk_size;
2366 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
2367 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2368 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2369
2370 /* sdio command config */
2371 sdio_command_config(SDIOx, &sdio_command_init_struct);
2372 /* enable ccsm */
2373 sdio_command_state_machine_enable(SDIOx, TRUE);
2374
2375 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
2376
2377 if(status != SD_OK)
2378 {
2379 return status;
2380 }
2381
2382 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
2383 sdio_data_init_struct.data_length = blk_size ;
2384 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
2385 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
2386 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
2387
2388 sdio_command_init_struct.argument = (mode << 31) | 0x00FFFFFF;
2389 sdio_command_init_struct.argument &= ~(0xF << (group * 4));
2390 sdio_command_init_struct.argument |= value << (group * 4);
2391 sdio_command_init_struct.cmd_index = SD_CMD_HS_SWITCH;
2392 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2393 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2394
2395 stop_flag = 0;
2396
2397 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)rsp);
2398}
2399
2405 sd_error_status_type check_card_programming(uint8_t *p_status)
2406{
2407 volatile uint32_t response = 0, sts_reg = 0, rsp_cmd = 0;
2408
2409 /* send cmd13 */
2410 sdio_command_init_struct.argument = (uint32_t)(rca << 16);
2411 sdio_command_init_struct.cmd_index = SD_CMD_SEND_STATUS;
2412 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2413 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2414
2415 /* sdio command config */
2416 sdio_command_config(SDIOx, &sdio_command_init_struct);
2417 /* enable ccsm */
2418 sdio_command_state_machine_enable(SDIOx, TRUE);
2419
2420 sts_reg = SDIOx->sts;
2421
2422 while(!(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG)))
2423 {
2424 sts_reg = SDIOx->sts;
2425 }
2426
2427 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2428 {
2429 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2430 return SD_CMD_FAIL;
2431 }
2432
2433 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2434 {
2435 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2436 return SD_CMD_RSP_TIMEOUT;
2437 }
2438
2439 rsp_cmd = sdio_command_response_get(SDIOx);
2440 if(rsp_cmd!= SD_CMD_SEND_STATUS)
2441 {
2442 return SD_ILLEGAL_CMD;
2443 }
2444
2445 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2446
2447 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2448
2449 *p_status = (uint8_t)((response >> 9) & 0x0000000F);
2450
2451 return SD_OK;
2452}
2453
2459 sd_error_status_type sd_status_send(uint32_t *p_card_status)
2460{
2461 sd_error_status_type status = SD_OK;
2462
2463 if(p_card_status == NULL)
2464 {
2465 status = SD_INVALID_PARAMETER;
2466 return status;
2467 }
2468
2469 sdio_command_init_struct.argument = (uint32_t)(rca << 16);
2470 sdio_command_init_struct.cmd_index = SD_CMD_SEND_STATUS;
2471 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2472 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2473
2474 /* sdio command config */
2475 sdio_command_config(SDIOx, &sdio_command_init_struct);
2476 /* enable ccsm */
2477 sdio_command_state_machine_enable(SDIOx, TRUE);
2478
2479 status = command_rsp1_error(SD_CMD_SEND_STATUS);
2480
2481 if(status != SD_OK)
2482 {
2483 return status;
2484 }
2485
2486 *p_card_status = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2487
2488 return status;
2489}
2490
2496 sd_card_state_type sd_state_get(void)
2497{
2498 uint32_t response = 0;
2499
2500 if(sd_status_send(&response) != SD_OK)
2501 {
2502 return SD_CARD_ERROR;
2503 }
2504 else
2505 {
2506 return (sd_card_state_type)((response >> 9) & 0x0F);
2507 }
2508}
2509
2514 sd_error_status_type scr_find(void)
2515{
2516 uint32_t index = 0, sts_reg = 0;
2517 sd_error_status_type status = SD_OK;
2518 uint32_t *tempscr;
2519
2520 tempscr = (uint32_t *) &(sd_card_info.sd_scr_reg);
2521
2522 /* send cmd16, set block length */
2523 sdio_command_init_struct.argument = (uint32_t)8;
2524 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
2525 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2526 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2527
2528 /* sdio command config */
2529 sdio_command_config(SDIOx, &sdio_command_init_struct);
2530 /* enable ccsm */
2531 sdio_command_state_machine_enable(SDIOx, TRUE);
2532
2533 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
2534
2535 if(status != SD_OK)
2536 {
2537 return status;
2538 }
2539
2540 /* send cmd55 */
2541 sdio_command_init_struct.argument = (uint32_t)(sd_card_info.rca << 16);
2542 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
2543 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2544 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2545
2546 /* sdio command config */
2547 sdio_command_config(SDIOx, &sdio_command_init_struct);
2548 /* enable ccsm */
2549 sdio_command_state_machine_enable(SDIOx, TRUE);
2550
2551 status = command_rsp1_error(SD_CMD_APP_CMD);
2552
2553 if(status != SD_OK)
2554 {
2555 return status;
2556 }
2557
2558 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_8B;
2559 sdio_data_init_struct.data_length = 8;
2560 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
2561 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
2562 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
2563
2564 sdio_data_config(SDIOx, &sdio_data_init_struct);
2565 sdio_data_state_machine_enable(SDIOx, TRUE);
2566
2567 /* send cmd51 */
2568 sdio_command_init_struct.argument = 0x0;
2569 sdio_command_init_struct.cmd_index = SD_CMD_SD_APP_SEND_SCR;
2570 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2571 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2572
2573 /* sdio command config */
2574 sdio_command_config(SDIOx, &sdio_command_init_struct);
2575 /* enable ccsm */
2576 sdio_command_state_machine_enable(SDIOx, TRUE);
2577
2578 status = command_rsp1_error(SD_CMD_SD_APP_SEND_SCR);
2579
2580 if(status != SD_OK)
2581 {
2582 return status;
2583 }
2584
2585 sts_reg = SDIOx->sts;
2586
2587 while(!(sts_reg & (SDIO_RXERRO_FLAG | SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_DTBLKCMPL_FLAG | SDIO_SBITERR_FLAG)))
2588 {
2589 if(sdio_flag_get(SDIOx, SDIO_RXBUF_FLAG) != RESET)
2590 {
2591 *(tempscr + index) = sdio_data_read(SDIOx);
2592 index++;
2593 }
2594 sts_reg = SDIOx->sts;
2595 }
2596
2597 if(sdio_flag_get(SDIOx, SDIO_DTTIMEOUT_FLAG) != RESET)
2598 {
2599 sdio_flag_clear(SDIOx, SDIO_DTTIMEOUT_FLAG);
2600 return SD_DATA_TIMEOUT;
2601 }
2602 else if(sdio_flag_get(SDIOx, SDIO_DTFAIL_FLAG) != RESET)
2603 {
2604 sdio_flag_clear(SDIOx, SDIO_DTFAIL_FLAG);
2605 return SD_DATA_FAIL;
2606 }
2607 else if(sdio_flag_get(SDIOx, SDIO_RXERRO_FLAG) != RESET)
2608 {
2609 sdio_flag_clear(SDIOx, SDIO_RXERRO_FLAG);
2610 return SD_RX_OVERRUN;
2611 }
2612 else if(sdio_flag_get(SDIOx, SDIO_SBITERR_FLAG) != RESET)
2613 {
2614 sdio_flag_clear(SDIOx, SDIO_SBITERR_FLAG);
2615 return SD_START_BIT_ERR;
2616 }
2617
2618 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2619
2620 return status;
2621}
2622
2628 sd_error_status_type speed_change(uint8_t speed)
2629{
2630 sd_error_status_type status = SD_OK;
2631 uint8_t switch_sts[64];
2632
2633 if(speed > 1)
2634 {
2635 return SD_ERROR;
2636 }
2637
2638 /* check card type */
2639 if((SDIO_STD_CAPACITY_SD_CARD_V1_1 == card_type) || (SDIO_STD_CAPACITY_SD_CARD_V2_0 == card_type) || \
2640 (SDIO_HIGH_CAPACITY_SD_CARD == card_type))
2641 {
2642 /* version 1.01 card does not support cmd6 */
2643 if(sd_card_info.sd_scr_reg.sd_spec == 0)
2644 {
2645 return SD_ERROR;
2646 }
2647
2648 /* check group 1 function support speed */
2649 status = sd_switch(0, 0, speed, switch_sts);
2650
2651 if(status != 0)
2652 {
2653 return status;
2654 }
2655
2656 if((switch_sts[13] & (1 << speed)) == 0)
2657 {
2658 return SD_ERROR;
2659 }
2660
2661 status = sd_switch(1, 0, speed, switch_sts);
2662
2663 if(status != 0)
2664 {
2665 return status;
2666 }
2667
2668 /* read it back for confirmation */
2669 if((switch_sts[16] & 0xF) != speed)
2670 {
2671 return SD_ERROR;
2672 }
2673 }
2674 else if(card_type == SDIO_HIGH_SPEED_MULTIMEDIA_CARD)
2675 {
2676 status = mmc_switch(EXT_CSD_CMD_SET_NORMAL, EXT_CSD_BUS_WIDTH, (uint8_t)speed);
2677
2678 if(status != 0)
2679 {
2680 return status;
2681 }
2682 }
2683
2684 return status;
2685}
2686
2692uint8_t convert_from_bytes_to_power_of_two(uint16_t number_of_bytes)
2693{
2694 uint8_t count = 0;
2695
2696 while(number_of_bytes != 1)
2697 {
2698 number_of_bytes >>= 1;
2699 count++;
2700 }
2701
2702 return count;
2703}
2704
2713void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
2714{
2715 dma_init_type dma_init_struct;
2716 dma_default_para_init(&dma_init_struct);
2717
2718 crm_periph_clock_enable(CRM_DMA2_PERIPH_CLOCK, TRUE);
2719
2720 dma_reset(DMA2_CHANNEL4);
2721 dma_channel_enable(DMA2_CHANNEL4, FALSE);
2722
2723 dma_init_struct.peripheral_base_addr = (uint32_t)&SDIOx->buf;
2724 dma_init_struct.memory_base_addr = (uint32_t)mbuf;
2725 dma_init_struct.direction = dir;
2726 dma_init_struct.buffer_size = buf_size / 4;
2727 dma_init_struct.peripheral_inc_enable = FALSE;
2728 dma_init_struct.memory_inc_enable = TRUE;
2729 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_WORD;
2730 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_WORD;
2731 dma_init_struct.loop_mode_enable = FALSE;
2732 dma_init_struct.priority = DMA_PRIORITY_HIGH;
2733 dma_init(DMA2_CHANNEL4, &dma_init_struct);
2734
2735 dmamux_init(DMA2MUX_CHANNEL4, DMAMUX_SDIOx);
2736 dmamux_enable(DMA2, TRUE);
2737 dma_channel_enable(DMA2_CHANNEL4, TRUE);
2738}
2739
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
sd_switch
sd_error_status_type sd_switch(uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
switch sd card speed to high speed
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2342
command_rsp5_error
sd_error_status_type command_rsp5_error(uint8_t cmd)
checks for error conditions for r5 response.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2093
speed_change
sd_error_status_type speed_change(uint8_t speed)
set bus speed
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2621
command_rsp7_error
sd_error_status_type command_rsp7_error(void)
checks for error conditions for R7 response.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1900
convert_from_bytes_to_power_of_two
uint8_t convert_from_bytes_to_power_of_two(uint16_t number_of_bytes)
converts the number of bytes in power of two and returns the power.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2685
command_rsp6_error
sd_error_status_type command_rsp6_error(uint8_t cmd, uint16_t *p_rca)
checks for error conditions for r6 (rca) response.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2156
SDIO1_IRQHandler
void SDIO1_IRQHandler(void)
sdio1 isr.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1769
mmc_switch
sd_error_status_type mmc_switch(uint8_t set, uint8_t index, uint8_t value)
switch mmc card speed to high speed
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2291
check_card_programming
sd_error_status_type check_card_programming(uint8_t *p_status)
checks if the sd card is in programming state.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2398
sd_bus_wide_enable
sd_error_status_type sd_bus_wide_enable(confirm_state new_state)
enable or disable the sdio wide bus mode.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2222
command_rsp1_error
sd_error_status_type command_rsp1_error(uint8_t cmd)
checks for error conditions for R1 response.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1937
SDIO2_IRQHandler
void SDIO2_IRQHandler(void)
sdio2 isr.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1779
sdio_command_data_send
sd_error_status_type sdio_command_data_send(sdio_command_struct_type *sdio_cmd_init_t, sdio_data_struct_type *sdio_data_init_t, uint32_t *buf)
read data from or write data to sd card.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:830
command_rsp2_error
sd_error_status_type command_rsp2_error(void)
checks for error conditions for R2 (cid or csd) response.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2010
scr_find
sd_error_status_type scr_find(void)
find the sd card scr register value.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2507
command_rsp4_error
sd_error_status_type command_rsp4_error(uint8_t cmd)
checks for error conditions for r4 response.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:2050
command_rsp3_error
sd_error_status_type command_rsp3_error(void)
checks for error conditions for R3 (ocr) response.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1980
command_error
sd_error_status_type command_error(void)
checks for error conditions for cmd0.
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:1873
sd_card_info
sd_card_info_struct_type sd_card_info
Definition: at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c:49
sdio_data_init_struct
sdio_data_struct_type sdio_data_init_struct
Definition: at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c:41
transfer_end
volatile uint8_t transfer_end
Definition: at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c:48
card_type
static sd_memory_card_type card_type
Definition: at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c:43
sdio_command_init_struct
sdio_command_struct_type sdio_command_init_struct
Definition: at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c:40
stop_flag
static uint8_t stop_flag
Definition: at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c:46
transfer_error
volatile sd_error_status_type transfer_error
Definition: at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c:47
csd_table
static uint32_t csd_table[4]
Definition: at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c:44
cid_table
static uint32_t cid_table[4]
Definition: at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c:44
device_mode
static sd_data_transfer_mode_type device_mode
Definition: at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c:45
rca
static uint32_t rca
Definition: at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c:44
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
system_core_clock
unsigned int system_core_clock
Definition: system_at32f435_437.c:48
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_SDIO1_PERIPH_CLOCK
@ CRM_SDIO1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:121
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_DMA2_PERIPH_CLOCK
@ CRM_DMA2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:116
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f435_437_dma.h:151
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:164
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:174
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMA2MUX_CHANNEL4
#define DMA2MUX_CHANNEL4
Definition: at32f435_437_dma.h:729
DMA2
#define DMA2
Definition: at32f435_437_dma.h:717
DMA2_CHANNEL4
#define DMA2_CHANNEL4
Definition: at32f435_437_dma.h:721
confirm_state
confirm_state
Definition: at32f435_437.h:379
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
SDIO_SEND_IF_COND
#define SDIO_SEND_IF_COND
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:441
SD_CMD_SD_APP_SEND_SCR
#define SD_CMD_SD_APP_SEND_SCR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:311
SD_CMD_ERASE
#define SD_CMD_ERASE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:294
SD_CMD_APP_SD_SET_BUSWIDTH
#define SD_CMD_APP_SD_SET_BUSWIDTH
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:306
SD_CMD_WRITE_SINGLE_BLOCK
#define SD_CMD_WRITE_SINGLE_BLOCK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:283
SD_CMD_SD_ERASE_GRP_START
#define SD_CMD_SD_ERASE_GRP_START
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:290
SD_CMD_APP_CMD
#define SD_CMD_APP_CMD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:298
SD_CMD_ALL_SEND_CID
#define SD_CMD_ALL_SEND_CID
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:263
SD_CMD_STOP_TRANSMISSION
#define SD_CMD_STOP_TRANSMISSION
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:273
SD_CMD_SEND_STATUS
#define SD_CMD_SEND_STATUS
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:274
SD_CMD_SET_BLOCK_COUNT
#define SD_CMD_SET_BLOCK_COUNT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:282
SD_CMD_WRITE_DAT_UNTIL_STOP
#define SD_CMD_WRITE_DAT_UNTIL_STOP
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:281
SD_CMD_SEND_OP_COND
#define SD_CMD_SEND_OP_COND
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:262
SD_CMD_SET_BLOCKLEN
#define SD_CMD_SET_BLOCKLEN
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:277
SD_CMD_HS_SWITCH
#define SD_CMD_HS_SWITCH
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:267
SD_CMD_READ_SINGLE_BLOCK
#define SD_CMD_READ_SINGLE_BLOCK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:278
SD_CMD_SD_APP_OP_COND
#define SD_CMD_SD_APP_OP_COND
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:309
SD_CMD_GO_IDLE_STATE
#define SD_CMD_GO_IDLE_STATE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:261
SD_CMD_SET_REL_ADDR
#define SD_CMD_SET_REL_ADDR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:264
SD_CMD_ERASE_GRP_END
#define SD_CMD_ERASE_GRP_END
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:293
SD_CMD_READ_DAT_UNTIL_STOP
#define SD_CMD_READ_DAT_UNTIL_STOP
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:272
SD_CMD_SD_ERASE_GRP_END
#define SD_CMD_SD_ERASE_GRP_END
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:291
SD_CMD_ERASE_GRP_START
#define SD_CMD_ERASE_GRP_START
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:292
SD_CMD_SEL_DESEL_CARD
#define SD_CMD_SEL_DESEL_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:268
SD_CMD_WRITE_MULT_BLOCK
#define SD_CMD_WRITE_MULT_BLOCK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:284
SD_CMD_READ_MULT_BLOCK
#define SD_CMD_READ_MULT_BLOCK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:279
SD_CMD_SEND_CSD
#define SD_CMD_SEND_CSD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:270
sdio_command_config
void sdio_command_config(sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command.
Definition: at32f435_437_sdio.c:329
sdio_data_write
void sdio_data_write(sdio_type *sdio_x, uint32_t data)
write one word data to fifo.
Definition: at32f435_437_sdio.c:490
sdio_data_config
void sdio_data_config(sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data.
Definition: at32f435_437_sdio.c:416
sd_power_off
sd_error_status_type sd_power_off(void)
turns the sdio output signals off.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:403
sd_irq_service
sd_error_status_type sd_irq_service(void)
allows to process all the interrupts that are high.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1789
sd_device_mode_set
sd_error_status_type sd_device_mode_set(uint32_t mode)
set sdio work mode.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:786
sdio_data_read
uint32_t sdio_data_read(sdio_type *sdio_x)
read a word data from sdio fifo.
Definition: at32f435_437_sdio.c:465
sd_card_info_get
sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info)
returns information about specific card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:532
sdio_command_state_machine_enable
void sdio_command_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM).
Definition: at32f435_437_sdio.c:352
sdio_clock_bypass
void sdio_clock_bypass(sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss
Definition: at32f435_437_sdio.c:141
mmc_stream_write
sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1700
sd_card_init
sd_error_status_type sd_card_init(void)
intialises all cards or single card as the case may be card(s) come into standby state.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:417
sd_block_read
sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma ...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1188
sd_deselect_select
sd_error_status_type sd_deselect_select(uint32_t addr)
selects od deselects the corresponding card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:807
sdio_flow_control_enable
void sdio_flow_control_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control.
Definition: at32f435_437_sdio.c:168
sdio_power_set
void sdio_power_set(sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller
Definition: at32f435_437_sdio.c:75
sdio_clock_config
void sdio_clock_config(sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock
Definition: at32f435_437_sdio.c:104
sdio_clock_set
void sdio_clock_set(uint32_t clkdiv)
set sdio clock devision factor.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:188
sdio_bus_width_config
void sdio_bus_width_config(sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width
Definition: at32f435_437_sdio.c:128
sd_blocks_erase
sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks)
erase continuous data block
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1030
sdio_interrupt_enable
void sdio_interrupt_enable(sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt.
Definition: at32f435_437_sdio.c:232
sdio_flag_clear
void sdio_flag_clear(sdio_type *sdio_x, uint32_t flag)
clear sdio flag.
Definition: at32f435_437_sdio.c:315
sdio_power_status_get
sdio_power_state_type sdio_power_status_get(sdio_type *sdio_x)
get power status.
Definition: at32f435_437_sdio.c:87
sd_mult_blocks_write
sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed ...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1489
sdio_response_get
uint32_t sdio_response_get(sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command.
Definition: at32f435_437_sdio.c:383
sdio_data_state_machine_enable
void sdio_data_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM).
Definition: at32f435_437_sdio.c:441
sdio_power_saving_mode_enable
void sdio_power_saving_mode_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle.
Definition: at32f435_437_sdio.c:155
sd_state_get
sd_card_state_type sd_state_get(void)
returns information about sd card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:2489
sdio_flag_get
flag_status sdio_flag_get(sdio_type *sdio_x, uint32_t flag)
get sdio flag.
Definition: at32f435_437_sdio.c:278
sdio_dma_enable
void sdio_dma_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable dma.
Definition: at32f435_437_sdio.c:194
sd_dma_config
void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:2706
sd_block_write
sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be manag...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1367
sd_status_send
sd_error_status_type sd_status_send(uint32_t *p_card_status)
read current card status.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:2452
sd_init
sd_error_status_type sd_init(void)
initializes the sd card and put it into standby state (ready for data transfer).
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:72
mmc_stream_read
sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1653
sd_power_on
sd_error_status_type sd_power_on(void)
enquires cards about their operating voltage and configures clock controls.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:203
sdio_reset
void sdio_reset(sdio_type *sdio_x)
reset the sdio register
Definition: at32f435_437_sdio.c:51
sd_mult_blocks_read
sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mod...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1277
sdio_clock_enable
void sdio_clock_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output.
Definition: at32f435_437_sdio.c:181
sd_wide_bus_operation_config
sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:743
sdio_command_response_get
uint8_t sdio_command_response_get(sdio_type *sdio_x)
get command index of last command for which response received.
Definition: at32f435_437_sdio.c:365
sd_data_transfer_mode_type
sd_data_transfer_mode_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:66
sd_error_status_type
sd_error_status_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:75
sd_card_state_type
sd_card_state_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:188
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f435_437_sdio.h:139
sd_memory_card_type
sd_memory_card_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:204
sdio_block_size_type
sdio_block_size_type
sdio data block size
Definition: at32f435_437_sdio.h:180
SDIO_WAIT_FOR_NO
@ SDIO_WAIT_FOR_NO
Definition: at32f435_437_sdio.h:160
SDIO_WAIT_FOR_INT
@ SDIO_WAIT_FOR_INT
Definition: at32f435_437_sdio.h:161
SDIO_RESPONSE_LONG
@ SDIO_RESPONSE_LONG
Definition: at32f435_437_sdio.h:152
SDIO_RESPONSE_SHORT
@ SDIO_RESPONSE_SHORT
Definition: at32f435_437_sdio.h:151
SDIO_RESPONSE_NO
@ SDIO_RESPONSE_NO
Definition: at32f435_437_sdio.h:150
SD_TRANSFER_DMA_MODE
@ SD_TRANSFER_DMA_MODE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:68
SD_TRANSFER_POLLING_MODE
@ SD_TRANSFER_POLLING_MODE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:67
SD_ERROR
@ SD_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:119
SD_SDIO_UNKNOWN_FUNC
@ SD_SDIO_UNKNOWN_FUNC
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:109
SD_DATA_FAIL
@ SD_DATA_FAIL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:78
SD_INVALID_PARAMETER
@ SD_INVALID_PARAMETER
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:116
SD_CMD_FAIL
@ SD_CMD_FAIL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:77
SD_CMD_OUT_OF_RANGE
@ SD_CMD_OUT_OF_RANGE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:84
SD_GENERAL_UNKNOWN_ERROR
@ SD_GENERAL_UNKNOWN_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:95
SD_UNSUPPORTED_FEATURE
@ SD_UNSUPPORTED_FEATURE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:117
SD_TX_UNDERRUN
@ SD_TX_UNDERRUN
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:81
SD_ILLEGAL_CMD
@ SD_ILLEGAL_CMD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:92
SD_CMD_CRC_ERROR
@ SD_CMD_CRC_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:91
SD_RX_OVERRUN
@ SD_RX_OVERRUN
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:82
SD_REQ_NOT_APPLICABLE
@ SD_REQ_NOT_APPLICABLE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:115
SD_SWITCH_ERROR
@ SD_SWITCH_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:105
SD_INVALID_VOLTRANGE
@ SD_INVALID_VOLTRANGE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:103
SD_DATA_TIMEOUT
@ SD_DATA_TIMEOUT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:80
SD_START_BIT_ERR
@ SD_START_BIT_ERR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:83
SD_LOCK_UNLOCK_ERROR
@ SD_LOCK_UNLOCK_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:90
SD_CMD_RSP_TIMEOUT
@ SD_CMD_RSP_TIMEOUT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:79
SD_OK
@ SD_OK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:120
SDIO_CLOCK_EDGE_FALLING
@ SDIO_CLOCK_EDGE_FALLING
Definition: at32f435_437_sdio.h:132
SDIO_DATA_TRANSFER_TO_CARD
@ SDIO_DATA_TRANSFER_TO_CARD
Definition: at32f435_437_sdio.h:212
SDIO_DATA_TRANSFER_TO_CONTROLLER
@ SDIO_DATA_TRANSFER_TO_CONTROLLER
Definition: at32f435_437_sdio.h:213
SDIO_POWER_OFF
@ SDIO_POWER_OFF
Definition: at32f435_437_sdio.h:122
SDIO_POWER_ON
@ SDIO_POWER_ON
Definition: at32f435_437_sdio.h:123
SD_CARD_ERROR
@ SD_CARD_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:197
SDIO_DATA_BLOCK_TRANSFER
@ SDIO_DATA_BLOCK_TRANSFER
Definition: at32f435_437_sdio.h:203
SDIO_DATA_STREAM_TRANSFER
@ SDIO_DATA_STREAM_TRANSFER
Definition: at32f435_437_sdio.h:204
SDIO_BUS_WIDTH_D1
@ SDIO_BUS_WIDTH_D1
Definition: at32f435_437_sdio.h:140
SDIO_BUS_WIDTH_D4
@ SDIO_BUS_WIDTH_D4
Definition: at32f435_437_sdio.h:141
SDIO_RSP3_INDEX
@ SDIO_RSP3_INDEX
Definition: at32f435_437_sdio.h:172
SDIO_RSP2_INDEX
@ SDIO_RSP2_INDEX
Definition: at32f435_437_sdio.h:171
SDIO_RSP4_INDEX
@ SDIO_RSP4_INDEX
Definition: at32f435_437_sdio.h:173
SDIO_RSP1_INDEX
@ SDIO_RSP1_INDEX
Definition: at32f435_437_sdio.h:170
SDIO_HIGH_CAPACITY_SD_CARD
@ SDIO_HIGH_CAPACITY_SD_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:207
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
@ SDIO_SECURE_DIGITAL_IO_COMBO_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:211
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
@ SDIO_HIGH_SPEED_MULTIMEDIA_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:210
SDIO_STD_CAPACITY_SD_CARD_V1_1
@ SDIO_STD_CAPACITY_SD_CARD_V1_1
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:205
SDIO_SECURE_DIGITAL_IO_CARD
@ SDIO_SECURE_DIGITAL_IO_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:209
SDIO_STD_CAPACITY_SD_CARD_V2_0
@ SDIO_STD_CAPACITY_SD_CARD_V2_0
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:206
SDIO_MULTIMEDIA_CARD
@ SDIO_MULTIMEDIA_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:208
SDIO_DATA_BLOCK_SIZE_8B
@ SDIO_DATA_BLOCK_SIZE_8B
Definition: at32f435_437_sdio.h:184
SDIO_DATA_BLOCK_SIZE_1B
@ SDIO_DATA_BLOCK_SIZE_1B
Definition: at32f435_437_sdio.h:181
SDIO_CMDTIMEOUT_FLAG
#define SDIO_CMDTIMEOUT_FLAG
Definition: at32f435_437_sdio.h:87
SDIO_TXBUFH_FLAG
#define SDIO_TXBUFH_FLAG
Definition: at32f435_437_sdio.h:99
SDIO_CMDCMPL_FLAG
#define SDIO_CMDCMPL_FLAG
Definition: at32f435_437_sdio.h:92
SDIO_DTFAIL_FLAG
#define SDIO_DTFAIL_FLAG
Definition: at32f435_437_sdio.h:86
SDIO_RXERRO_FLAG
#define SDIO_RXERRO_FLAG
Definition: at32f435_437_sdio.h:90
SDIO_RXBUFH_FLAG
#define SDIO_RXBUFH_FLAG
Definition: at32f435_437_sdio.h:100
SDIO_RXBUF_FLAG
#define SDIO_RXBUF_FLAG
Definition: at32f435_437_sdio.h:106
SDIO_CMDFAIL_FLAG
#define SDIO_CMDFAIL_FLAG
Definition: at32f435_437_sdio.h:85
SDIO_CMDRSPCMPL_FLAG
#define SDIO_CMDRSPCMPL_FLAG
Definition: at32f435_437_sdio.h:91
SDIO_DTBLKCMPL_FLAG
#define SDIO_DTBLKCMPL_FLAG
Definition: at32f435_437_sdio.h:95
SDIO_DTTIMEOUT_FLAG
#define SDIO_DTTIMEOUT_FLAG
Definition: at32f435_437_sdio.h:88
SDIO_SBITERR_FLAG
#define SDIO_SBITERR_FLAG
Definition: at32f435_437_sdio.h:94
SDIO_DTCMPL_FLAG
#define SDIO_DTCMPL_FLAG
Definition: at32f435_437_sdio.h:93
SDIO_TXERRU_FLAG
#define SDIO_TXERRU_FLAG
Definition: at32f435_437_sdio.h:89
DMAMUX_SDIOx
#define DMAMUX_SDIOx
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:52
SDIOx
#define SDIOx
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:51
SDIO_INTR_STS_WRITE_MASK
#define SDIO_INTR_STS_WRITE_MASK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:477
SDIO_INTR_STS_READ_MASK
#define SDIO_INTR_STS_READ_MASK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:479
SDIO_SBITERR_INT
#define SDIO_SBITERR_INT
Definition: at32f435_437_sdio.h:61
SDIO_RXBUFH_INT
#define SDIO_RXBUFH_INT
Definition: at32f435_437_sdio.h:67
SDIO_DTTIMEOUT_INT
#define SDIO_DTTIMEOUT_INT
Definition: at32f435_437_sdio.h:55
SDIO_TXERRU_INT
#define SDIO_TXERRU_INT
Definition: at32f435_437_sdio.h:56
SDIO_RXERRO_INT
#define SDIO_RXERRO_INT
Definition: at32f435_437_sdio.h:57
SDIO_DTFAIL_INT
#define SDIO_DTFAIL_INT
Definition: at32f435_437_sdio.h:53
SDIO_TXBUFH_INT
#define SDIO_TXBUFH_INT
Definition: at32f435_437_sdio.h:66
SDIO_DTCMP_INT
#define SDIO_DTCMP_INT
Definition: at32f435_437_sdio.h:60
EXT_CSD_BUS_WIDTH
#define EXT_CSD_BUS_WIDTH
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:466
EXT_CSD_CMD_SET_NORMAL
#define EXT_CSD_CMD_SET_NORMAL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:459
EXT_CSD_Write_byte
#define EXT_CSD_Write_byte
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:457
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
SDIO_DATATIMEOUT
#define SDIO_DATATIMEOUT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:345
SDIO_CMD0TIMEOUT
#define SDIO_CMD0TIMEOUT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:344
SDIO_STATIC_FLAGS
#define SDIO_STATIC_FLAGS
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:343
SD_CARD_LOCKED
#define SD_CARD_LOCKED
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:403
SD_VOLTAGE_WINDOW_SD
#define SD_VOLTAGE_WINDOW_SD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:394
SD_R5_ERROR
#define SD_R5_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:386
SD_CARD_RECEIVING
#define SD_CARD_RECEIVING
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:405
SD_R5_OUT_OF_RANGE
#define SD_R5_OUT_OF_RANGE
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:384
SD_MAX_DATA_LENGTH
#define SD_MAX_DATA_LENGTH
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:411
SD_STD_CAPACITY
#define SD_STD_CAPACITY
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:396
SD_R5_FUNCTION_NUMBER
#define SD_R5_FUNCTION_NUMBER
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:385
SD_R6_ILLEGAL_CMD
#define SD_R6_ILLEGAL_CMD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:392
SD_R6_GENERAL_UNKNOWN_ERROR
#define SD_R6_GENERAL_UNKNOWN_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:391
SD_MAX_VOLT_TRIAL
#define SD_MAX_VOLT_TRIAL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:399
SD_DATATIMEOUT
#define SD_DATATIMEOUT
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:406
SD_ALLZERO
#define SD_ALLZERO
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:400
SD_R6_CMD_CRC_ERROR
#define SD_R6_CMD_CRC_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:393
MMC_SWITCH_ERROR
#define MMC_SWITCH_ERROR
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:377
SD_VOLTAGE_WINDOW_MMC
#define SD_VOLTAGE_WINDOW_MMC
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:398
SD_CHECK_PATTERN
#define SD_CHECK_PATTERN
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:397
SD_OCR_ERRORBITS
#define SD_OCR_ERRORBITS
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:379
SD_CARD_PROGRAMMING
#define SD_CARD_PROGRAMMING
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:404
SD_HIGH_CAPACITY
#define SD_HIGH_CAPACITY
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:395
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
sd_card_info_struct_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:238
sd_card_info_struct_type::sd_scr_reg
sd_scr_struct_type sd_scr_reg
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:241
sd_card_info_struct_type::card_capacity
long long card_capacity
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:242
sd_card_info_struct_type::sd_cid_reg
sd_cid_struct_type sd_cid_reg
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:240
sd_card_info_struct_type::sd_csd_reg
sd_csd_struct_type sd_csd_reg
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:239
sd_card_info_struct_type::card_blk_size
uint32_t card_blk_size
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:243
sd_card_info_struct_type::rca
uint16_t rca
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:244
sd_card_info_struct_type::card_type
uint8_t card_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:245
sd_cid_struct_type::reserved1
uint8_t reserved1
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:178
sd_cid_struct_type::product_name2
uint8_t product_name2
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:175
sd_cid_struct_type::manufact_date
uint16_t manufact_date
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:179
sd_cid_struct_type::cid_crc
uint8_t cid_crc
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:180
sd_cid_struct_type::product_reversion
uint8_t product_reversion
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:176
sd_cid_struct_type::manufacturer_id
uint8_t manufacturer_id
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:172
sd_cid_struct_type::product_sn
uint32_t product_sn
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:177
sd_cid_struct_type::product_name1
uint32_t product_name1
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:174
sd_cid_struct_type::reserved2
uint8_t reserved2
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:181
sd_cid_struct_type::oem_app_id
uint16_t oem_app_id
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:173
sd_csd_struct_type::spec_version
uint8_t spec_version
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:129
sd_csd_struct_type::max_write_current_vdd_max
uint8_t max_write_current_vdd_max
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:145
sd_csd_struct_type::nsac
uint8_t nsac
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:132
sd_csd_struct_type::card_cmd_classes
uint16_t card_cmd_classes
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:134
sd_csd_struct_type::part_blk_read
uint8_t part_blk_read
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:136
sd_csd_struct_type::read_blk_misalign
uint8_t read_blk_misalign
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:138
sd_csd_struct_type::content_protect_app
uint8_t content_protect_app
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:156
sd_csd_struct_type::write_speed_factor
uint8_t write_speed_factor
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:152
sd_csd_struct_type::max_read_blk_length
uint8_t max_read_blk_length
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:135
sd_csd_struct_type::max_bus_clk_freq
uint8_t max_bus_clk_freq
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:133
sd_csd_struct_type::ecc_code
uint8_t ecc_code
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:162
sd_csd_struct_type::reserved4
uint8_t reserved4
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:164
sd_csd_struct_type::dsr_implemented
uint8_t dsr_implemented
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:139
sd_csd_struct_type::max_read_current_vdd_min
uint8_t max_read_current_vdd_min
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:142
sd_csd_struct_type::reserved2
uint8_t reserved2
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:140
sd_csd_struct_type::erase_group_size_mult
uint8_t erase_group_size_mult
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:148
sd_csd_struct_type::file_formart
uint8_t file_formart
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:161
sd_csd_struct_type::temp_write_protect
uint8_t temp_write_protect
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:160
sd_csd_struct_type::permanent_write_protect
uint8_t permanent_write_protect
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:159
sd_csd_struct_type::max_read_current_vdd_max
uint8_t max_read_current_vdd_max
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:143
sd_csd_struct_type::file_format_group
uint8_t file_format_group
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:157
sd_csd_struct_type::device_size
uint32_t device_size
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:141
sd_csd_struct_type::write_blk_misalign
uint8_t write_blk_misalign
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:137
sd_csd_struct_type::csd_struct
uint8_t csd_struct
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:128
sd_csd_struct_type::write_protect_group_enable
uint8_t write_protect_group_enable
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:150
sd_csd_struct_type::max_write_current_vdd_min
uint8_t max_write_current_vdd_min
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:144
sd_csd_struct_type::reserved1
uint8_t reserved1
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:130
sd_csd_struct_type::max_write_blk_length
uint8_t max_write_blk_length
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:153
sd_csd_struct_type::csd_crc
uint8_t csd_crc
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:163
sd_csd_struct_type::write_protect_group_size
uint8_t write_protect_group_size
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:149
sd_csd_struct_type::reserved3
uint8_t reserved3
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:155
sd_csd_struct_type::taac
uint8_t taac
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:131
sd_csd_struct_type::manufacturer_default_ecc
uint8_t manufacturer_default_ecc
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:151
sd_csd_struct_type::part_blk_write
uint8_t part_blk_write
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:154
sd_csd_struct_type::copy_flag
uint8_t copy_flag
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:158
sd_csd_struct_type::erase_group_size
uint8_t erase_group_size
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:147
sd_csd_struct_type::device_size_mult
uint8_t device_size_mult
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:146
sd_scr_struct_type::sd_bus_width
uint32_t sd_bus_width
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:223
sd_scr_struct_type::sd_spec
uint32_t sd_spec
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:221
sdio_command_struct_type
sdio command structure
Definition: at32f435_437_sdio.h:229
sdio_command_struct_type::cmd_index
uint8_t cmd_index
Definition: at32f435_437_sdio.h:231
sdio_command_struct_type::argument
uint32_t argument
Definition: at32f435_437_sdio.h:230
sdio_command_struct_type::wait_type
sdio_wait_type wait_type
Definition: at32f435_437_sdio.h:233
sdio_command_struct_type::rsp_type
sdio_reponse_type rsp_type
Definition: at32f435_437_sdio.h:232
sdio_data_struct_type
sdio data structure
Definition: at32f435_437_sdio.h:240
sdio_data_struct_type::block_size
sdio_block_size_type block_size
Definition: at32f435_437_sdio.h:243
sdio_data_struct_type::transfer_direction
sdio_transfer_direction_type transfer_direction
Definition: at32f435_437_sdio.h:245
sdio_data_struct_type::timeout
uint32_t timeout
Definition: at32f435_437_sdio.h:241
sdio_data_struct_type::transfer_mode
sdio_transfer_mode_type transfer_mode
Definition: at32f435_437_sdio.h:244
sdio_data_struct_type::data_length
uint32_t data_length
Definition: at32f435_437_sdio.h:242


AT32F435/437 Firmwary Library: diskio.c File Reference

  • at_start_f437
  • examples
  • sdio
  • sdio_fatfs
  • src
Macros | Functions | Variables
at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c File Reference
#include "ff.h"
#include "diskio.h"
#include <string.h>
#include "at32_sdio.h"

Go to the source code of this file.

Macros

#define | DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */
#define | DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */
#define | DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */

Functions

sd_error_status_type | sd_read_disk (uint8_t *buf, uint32_t sector, uint8_t cnt)
read sd card sector More...
sd_error_status_type | sd_write_disk (const uint8_t *buf, uint32_t sector, uint8_t cnt)
write sd card sector More...
DSTATUS | disk_status (BYTE pdrv)
DSTATUS | disk_initialize (BYTE pdrv)
DRESULT | disk_read (BYTE pdrv, BYTE *buff, LBA_t sector, UINT count)
DRESULT | disk_write (BYTE pdrv, const BYTE *buff, LBA_t sector, UINT count)
DRESULT | disk_ioctl (BYTE pdrv, BYTE cmd, void *buff)

Variables

uint8_t sdio_data_buffer [512]

Macro Definition Documentation

◆ DEV_MMC

#define DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */

Definition at line 19 of file at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c.

◆ DEV_RAM

#define DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */

Definition at line 18 of file at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c.

◆ DEV_USB

#define DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */

Definition at line 20 of file at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c.

Function Documentation

◆ disk_initialize()

DSTATUS disk_initialize ( BYTE pdrv )

Definition at line 141 of file at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c.

◆ disk_ioctl()

DRESULT disk_ioctl | ( | BYTE | pdrv,
 |  | BYTE | cmd,
 |  | void * | buff
 | ) |  |

Definition at line 245 of file at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c.

◆ disk_read()

DRESULT disk_read | ( | BYTE | pdrv,
 |  | BYTE * | buff,
 |  | LBA_t | sector,
 |  | UINT | count
 | ) |  |

Definition at line 172 of file at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c.

◆ disk_status()

DSTATUS disk_status ( BYTE pdrv )

Definition at line 110 of file at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c.

◆ disk_write()

DRESULT disk_write | ( | BYTE | pdrv,
 |  | const BYTE * | buff,
 |  | LBA_t | sector,
 |  | UINT | count
 | ) |  |

Definition at line 209 of file at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c.

◆ sd_read_disk()

sd_error_status_type sd_read_disk | ( | uint8_t * | buf,
 |  | uint32_t | sector,
 |  | uint8_t | cnt
 | ) |  |

read sd card sector

Parameters
buf | read data buf
sector | sector address
cnt | sector count
Return values
sd_error_status_type sd card error code.

Definition at line 34 of file at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c.

Referenced by disk_read().

◆ sd_write_disk()

sd_error_status_type sd_write_disk | ( | const uint8_t * | buf,
 |  | uint32_t | sector,
 |  | uint8_t | cnt
 | ) |  |

write sd card sector

Parameters
buf | write data buf
sector | sector address
cnt | sector count
Return values
sd_error_status_type sd card error code.

Definition at line 74 of file at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c.

Referenced by disk_write().

Variable Documentation

◆ sdio_data_buffer

uint8_t sdio_data_buffer[512]

Definition at line 22 of file at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c.

Referenced by sd_read_disk(), and sd_write_disk().


AT32F435/437 Firmwary Library: diskio.c Source File

  • at_start_f437
  • examples
  • sdio
  • sdio_fatfs
  • src
at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c
Go to the documentation of this file.
1/*-----------------------------------------------------------------------*/
2/* Low level disk I/O module SKELETON for FatFs (C)ChaN, 2019 */
3/*-----------------------------------------------------------------------*/
4/* If a working storage control module is available, it should be */
5/* attached to the FatFs via a glue function rather than modifying it. */
6/* This is an example of glue functions to attach various exsisting */
7/* storage control modules to the FatFs module with a defined API. */
8/*-----------------------------------------------------------------------*/
9
10
11#include "ff.h" /* Obtains integer types */
12#include "diskio.h" /* Declarations of disk functions */
13
14#include <string.h>
15#include "at32_sdio.h" /* Example: Header file of existing MMC/SDC contorl module */
16
17/* Definitions of physical drive number for each drive */
18#define DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */
19#define DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */
20#define DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */
21
22uint8_t sdio_data_buffer[512]; /* buf for sd_read_disk/sd_write_disk function used. */
23
24 sd_error_status_type sd_read_disk(uint8_t *buf, uint32_t sector, uint8_t cnt);
25 sd_error_status_type sd_write_disk(const uint8_t *buf, uint32_t sector, uint8_t cnt);
26
34 sd_error_status_type sd_read_disk(uint8_t *buf, uint32_t sector, uint8_t cnt)
35{
36 sd_error_status_type sta = SD_OK;
37 long long lsector = sector;
38 uint8_t n;
39
40 /* data address is in block (512 byte) units. */
41 lsector <<= 9;
42
43 if((uint32_t)buf % 4 != 0)
44 {
45 for(n = 0; n < cnt; n++)
46 {
47 sta = sd_block_read(sdio_data_buffer, lsector + 512 * n, 512);
48 memcpy(buf, sdio_data_buffer, 512);
49 buf += 512;
50 }
51 }
52 else
53 {
54 if(cnt == 1)
55 {
56 sta = sd_block_read(buf, lsector, 512);
57 }
58 else
59 {
60 sta = sd_mult_blocks_read(buf, lsector, 512, cnt);
61 }
62 }
63
64 return sta;
65}
66
74 sd_error_status_type sd_write_disk(const uint8_t *buf, uint32_t sector, uint8_t cnt)
75{
76 sd_error_status_type sta = SD_OK;
77 uint8_t n;
78 long long lsector = sector;
79
80 /* data address is in block (512 byte) units. */
81 lsector <<= 9;
82
83 if((uint32_t)buf % 4 != 0)
84 {
85 for(n = 0; n < cnt; n++)
86 {
87 memcpy(sdio_data_buffer, buf, 512);
88 sta = sd_block_write(sdio_data_buffer, lsector + 512*n, 512);
89 buf += 512;
90 }
91 }
92 else
93 {
94 if(cnt == 1)
95 {
96 sta = sd_block_write(buf, lsector, 512);
97 }
98 else
99 {
100 sta = sd_mult_blocks_write(buf, lsector, 512, cnt);
101 }
102 }
103
104 return sta;
105}
106
107/*-----------------------------------------------------------------------*/
108/* Get Drive Status */
109/*-----------------------------------------------------------------------*/
110DSTATUS disk_status (
111 BYTE pdrv /* Physical drive nmuber to identify the drive */
112)
113{
114 DSTATUS stat;
115 int result;
116
117 switch (pdrv) {
118 case DEV_RAM :
119 result = 1;
120 stat = (DSTATUS)result;
121 return stat;
122
123 case DEV_MMC :
124 result = 0;
125 stat = (DSTATUS)result;
126 return stat;
127
128 case DEV_USB :
129 result = 1;
130 stat = (DSTATUS)result;
131 return stat;
132 }
133 return STA_NOINIT;
134}
135
136
137
138/*-----------------------------------------------------------------------*/
139/* Inidialize a Drive */
140/*-----------------------------------------------------------------------*/
141DSTATUS disk_initialize (
142 BYTE pdrv /* Physical drive nmuber to identify the drive */
143)
144{
145 DSTATUS stat;
146 int result;
147
148 switch (pdrv) {
149 case DEV_RAM :
150 result = 1;
151 stat = (DSTATUS)result;
152 return stat;
153
154 case DEV_MMC :
155 result = sd_init();
156 stat = (DSTATUS)result;
157 return stat;
158
159 case DEV_USB :
160 result = 1;
161 stat = (DSTATUS)result;
162 return stat;
163 }
164 return STA_NOINIT;
165}
166
167
168
169/*-----------------------------------------------------------------------*/
170/* Read Sector(s) */
171/*-----------------------------------------------------------------------*/
172DRESULT disk_read (
173 BYTE pdrv, /* Physical drive nmuber to identify the drive */
174 BYTE *buff, /* Data buffer to store read data */
175 LBA_t sector, /* Start sector in LBA */
176 UINT count /* Number of sectors to read */
177)
178{
179 DRESULT res;
180 int result;
181
182 switch (pdrv) {
183 case DEV_RAM :
184 result = 1;
185 res = (DRESULT)result;
186 return res;
187
188 case DEV_MMC :
189 result = sd_read_disk(buff, sector, count);
190 res = (DRESULT)result;
191 return res;
192
193 case DEV_USB :
194 result = 1;
195 res = (DRESULT)result;
196 return res;
197 }
198
199 return RES_PARERR;
200}
201
202
203
204/*-----------------------------------------------------------------------*/
205/* Write Sector(s) */
206/*-----------------------------------------------------------------------*/
207#if FF_FS_READONLY == 0
208
209DRESULT disk_write (
210 BYTE pdrv, /* Physical drive nmuber to identify the drive */
211 const BYTE *buff, /* Data to be written */
212 LBA_t sector, /* Start sector in LBA */
213 UINT count /* Number of sectors to write */
214)
215{
216 DRESULT res;
217 int result;
218
219 switch (pdrv) {
220 case DEV_RAM :
221 result = 1;
222 res = (DRESULT)result;
223 return res;
224
225 case DEV_MMC :
226 result = sd_write_disk(buff, sector, count);
227 res = (DRESULT)result;
228 return res;
229
230 case DEV_USB :
231 result = 1;
232 res = (DRESULT)result;
233 return res;
234 }
235
236 return RES_PARERR;
237}
238
239#endif
240
241
242/*-----------------------------------------------------------------------*/
243/* Miscellaneous Functions */
244/*-----------------------------------------------------------------------*/
245DRESULT disk_ioctl (
246 BYTE pdrv, /* Physical drive nmuber (0..) */
247 BYTE cmd, /* Control code */
248 void *buff /* Buffer to send/receive control data */
249)
250{
251 DRESULT res;
252 int result;
253
254 switch (pdrv) {
255 case DEV_RAM :
256 result = 1;
257 res = (DRESULT)result;
258 return res;
259
260 case DEV_MMC :
261 switch(cmd){
262 case CTRL_SYNC:
263 result = RES_OK;
264 break;
265 case GET_SECTOR_SIZE:
266 *(DWORD*)buff = 512;
267 result = RES_OK;
268 break;
269 case GET_SECTOR_COUNT:
270 *(DWORD*)buff = sd_card_info.card_capacity/512;
271 result = RES_OK;
272 break;
273 case GET_BLOCK_SIZE:
274 *(DWORD*)buff = sd_card_info.card_blk_size;
275 result = RES_OK;
276 break;
277 default:
278 result = RES_PARERR;
279 break;
280 }
281 res = (DRESULT)result;
282 return res;
283
284 case DEV_USB :
285 result = 1;
286 res = (DRESULT)result;
287 return res;
288 }
289
290 return RES_PARERR;
291}
disk_read
DRESULT disk_read(BYTE pdrv, BYTE *buff, LBA_t sector, UINT count)
Definition: at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c:172
disk_initialize
DSTATUS disk_initialize(BYTE pdrv)
Definition: at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c:141
DEV_USB
#define DEV_USB
Definition: at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c:20
DEV_RAM
#define DEV_RAM
Definition: at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c:18
disk_status
DSTATUS disk_status(BYTE pdrv)
Definition: at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c:110
disk_ioctl
DRESULT disk_ioctl(BYTE pdrv, BYTE cmd, void *buff)
Definition: at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c:245
disk_write
DRESULT disk_write(BYTE pdrv, const BYTE *buff, LBA_t sector, UINT count)
Definition: at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c:209
sdio_data_buffer
uint8_t sdio_data_buffer[512]
Definition: at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c:22
sd_read_disk
sd_error_status_type sd_read_disk(uint8_t *buf, uint32_t sector, uint8_t cnt)
read sd card sector
Definition: at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c:34
DEV_MMC
#define DEV_MMC
Definition: at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c:19
sd_write_disk
sd_error_status_type sd_write_disk(const uint8_t *buf, uint32_t sector, uint8_t cnt)
write sd card sector
Definition: at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c:74
sd_block_read
sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma ...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1188
sd_mult_blocks_write
sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed ...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1489
sd_block_write
sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be manag...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1367
sd_init
sd_error_status_type sd_init(void)
initializes the sd card and put it into standby state (ready for data transfer).
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:72
sd_mult_blocks_read
sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mod...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1277
sd_card_info
sd_card_info_struct_type sd_card_info
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:48
sd_error_status_type
sd_error_status_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:75
SD_OK
@ SD_OK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:120
sd_card_info_struct_type::card_capacity
long long card_capacity
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:242
sd_card_info_struct_type::card_blk_size
uint32_t card_blk_size
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:243


AT32F435/437 Firmwary Library: spi_flash.h File Reference

  • at_start_f437
  • examples
  • spi
  • w25q_flash
  • inc
Macros | Functions
at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h File Reference

header file of spi_flash More...

#include "at32f435_437.h"

Go to the source code of this file.

Macros

#define | SPI_TRANS_DMA
#define | FLASH_CS_HIGH() gpio_bits_set(GPIOD, GPIO_PINS_0)
#define | FLASH_CS_LOW() gpio_bits_reset(GPIOD, GPIO_PINS_0)
#define | W25Q80 0xEF13
#define | W25Q16 0xEF14
#define | W25Q32 0xEF15
#define | W25Q64 0xEF16
#define | W25Q128 0xEF17
#define | SPIF_CHIP_SIZE 0x1000000
#define | SPIF_SECTOR_SIZE 4096
#define | SPIF_PAGE_SIZE 256
#define | SPIF_WRITEENABLE 0x06
#define | SPIF_WRITEDISABLE 0x04
#define | SPIF_READSTATUSREG1 0x05
#define | SPIF_WRITESTATUSREG1 0x01
#define | SPIF_READSTATUSREG2 0x35
#define | SPIF_WRITESTATUSREG2 0x31
#define | SPIF_READSTATUSREG3 0x15
#define | SPIF_WRITESTATUSREG3 0x11
#define | SPIF_READDATA 0x03
#define | SPIF_FASTREADDATA 0x0B
#define | SPIF_FASTREADDUAL 0x3B
#define | SPIF_PAGEPROGRAM 0x02
#define | SPIF_BLOCKERASE 0xD8
#define | SPIF_SECTORERASE 0x20
#define | SPIF_CHIPERASE 0xC7
#define | SPIF_POWERDOWN 0xB9
#define | SPIF_RELEASEPOWERDOWN 0xAB
#define | SPIF_DEVICEID 0xAB
#define | SPIF_MANUFACTDEVICEID 0x90
#define | SPIF_JEDECDEVICEID 0x9F
#define | FLASH_SPI_DUMMY_BYTE 0xA5

Functions

void | spiflash_init (void)
spi configuration. More...
void | spiflash_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash More...
void | spiflash_read (uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash More...
void | spiflash_sector_erase (uint32_t erase_addr)
erase a sector data More...
void | spiflash_write_nocheck (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data without check More...
void | spiflash_page_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write a page data More...
void | spi_bytes_write (uint8_t *pbuffer, uint32_t length)
write data continuously More...
void | spi_bytes_read (uint8_t *pbuffer, uint32_t length)
read data continuously More...
void | spiflash_wait_busy (void)
wait program done More...
uint8_t | spiflash_read_sr1 (void)
read sr1 register More...
void | spiflash_write_enable (void)
enable write operation More...
uint16_t | spiflash_read_id (void)
read device id More...
uint8_t | spi_byte_write (uint8_t data)
write a byte to flash More...
uint8_t | spi_byte_read (void)
read a byte to flash More...

Detailed Description

header file of spi_flash

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h.


AT32F435/437 Firmwary Library: spi_flash.h Source File

  • at_start_f437
  • examples
  • spi
  • w25q_flash
  • inc
at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
Go to the documentation of this file.
1
27#ifndef __SPI_FLASH_H
28#define __SPI_FLASH_H
29
30#include "at32f435_437.h"
31
41 /* use dma transfer spi data */
42#define SPI_TRANS_DMA
43
48#define FLASH_CS_HIGH() gpio_bits_set(GPIOD, GPIO_PINS_0)
49#define FLASH_CS_LOW() gpio_bits_reset(GPIOD, GPIO_PINS_0)
50
59/*
60 * flash define
61 */
62#define W25Q80 0xEF13
63#define W25Q16 0xEF14
64#define W25Q32 0xEF15
65#define W25Q64 0xEF16
66/* 16mb, the range of address:0~0xFFFFFF */
67#define W25Q128 0xEF17
68
77#define SPIF_CHIP_SIZE 0x1000000
78#define SPIF_SECTOR_SIZE 4096
79#define SPIF_PAGE_SIZE 256
80
81#define SPIF_WRITEENABLE 0x06
82#define SPIF_WRITEDISABLE 0x04
83/* s7-s0 */
84#define SPIF_READSTATUSREG1 0x05
85#define SPIF_WRITESTATUSREG1 0x01
86/* s15-s8 */
87#define SPIF_READSTATUSREG2 0x35
88#define SPIF_WRITESTATUSREG2 0x31
89/* s23-s16 */
90#define SPIF_READSTATUSREG3 0x15
91#define SPIF_WRITESTATUSREG3 0x11
92#define SPIF_READDATA 0x03
93#define SPIF_FASTREADDATA 0x0B
94#define SPIF_FASTREADDUAL 0x3B
95#define SPIF_PAGEPROGRAM 0x02
96/* block size:64kb */
97#define SPIF_BLOCKERASE 0xD8
98#define SPIF_SECTORERASE 0x20
99#define SPIF_CHIPERASE 0xC7
100#define SPIF_POWERDOWN 0xB9
101#define SPIF_RELEASEPOWERDOWN 0xAB
102#define SPIF_DEVICEID 0xAB
103#define SPIF_MANUFACTDEVICEID 0x90
104#define SPIF_JEDECDEVICEID 0x9F
105#define FLASH_SPI_DUMMY_BYTE 0xA5
106
115void spiflash_init(void);
116void spiflash_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length);
117void spiflash_read(uint8_t *pbuffer, uint32_t read_addr, uint32_t length);
118void spiflash_sector_erase(uint32_t erase_addr);
119void spiflash_write_nocheck(uint8_t *pbuffer, uint32_t write_addr, uint32_t length);
120void spiflash_page_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length);
121void spi_bytes_write(uint8_t *pbuffer, uint32_t length);
122void spi_bytes_read(uint8_t *pbuffer, uint32_t length);
123void spiflash_wait_busy(void);
124uint8_t spiflash_read_sr1(void);
125void spiflash_write_enable(void);
126uint16_t spiflash_read_id(void);
127uint8_t spi_byte_write(uint8_t data);
128uint8_t spi_byte_read(void);
129
142#endif
143
at32f435_437.h
at32f435_437 header file
spiflash_init
void spiflash_init(void)
spi configuration.
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:45
spiflash_write
void spiflash_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:103
spiflash_wait_busy
void spiflash_wait_busy(void)
wait program done
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:441
spiflash_write_enable
void spiflash_write_enable(void)
enable write operation
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:466
spiflash_read_sr1
uint8_t spiflash_read_sr1(void)
read sr1 register
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:451
spiflash_write_nocheck
void spiflash_write_nocheck(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data without check
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:228
spiflash_sector_erase
void spiflash_sector_erase(uint32_t erase_addr)
erase a sector data
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:207
spi_byte_write
uint8_t spi_byte_write(uint8_t data)
write a byte to flash
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:497
spiflash_read
void spiflash_read(uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:191
spiflash_read_id
uint16_t spiflash_read_id(void)
read device id
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:478
spi_bytes_read
void spi_bytes_read(uint8_t *pbuffer, uint32_t length)
read data continuously
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:375
spi_bytes_write
void spi_bytes_write(uint8_t *pbuffer, uint32_t length)
write data continuously
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:307
spiflash_page_write
void spiflash_page_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write a page data
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:276
spi_byte_read
uint8_t spi_byte_read(void)
read a byte to flash
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:514


AT32F435/437 Firmwary Library: spi_flash.c File Reference

  • at_start_f437
  • examples
  • spi
  • w25q_flash
  • src
Functions | Variables
at_start_f437/examples/spi/w25q_flash/src/spi_flash.c File Reference

spi_flash source code More...

#include "spi_flash.h"

Go to the source code of this file.

Functions

void | spiflash_init (void)
spi configuration. More...
void | spiflash_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash More...
void | spiflash_read (uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash More...
void | spiflash_sector_erase (uint32_t erase_addr)
erase a sector data More...
void | spiflash_write_nocheck (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data without check More...
void | spiflash_page_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write a page data More...
void | spi_bytes_write (uint8_t *pbuffer, uint32_t length)
write data continuously More...
void | spi_bytes_read (uint8_t *pbuffer, uint32_t length)
read data continuously More...
void | spiflash_wait_busy (void)
wait program done More...
uint8_t | spiflash_read_sr1 (void)
read sr1 register More...
void | spiflash_write_enable (void)
enable write operation More...
uint16_t | spiflash_read_id (void)
read device id More...
uint8_t | spi_byte_write (uint8_t data)
write a byte to flash More...
uint8_t | spi_byte_read (void)
read a byte to flash More...

Variables

uint8_t spiflash_sector_buf [SPIF_SECTOR_SIZE]

Detailed Description

spi_flash source code

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/spi/w25q_flash/src/spi_flash.c.


AT32F435/437 Firmwary Library: spi_flash.c Source File

  • at_start_f437
  • examples
  • spi
  • w25q_flash
  • src
at_start_f437/examples/spi/w25q_flash/src/spi_flash.c
Go to the documentation of this file.
1
27#include "spi_flash.h"
28
29
38uint8_t spiflash_sector_buf[SPIF_SECTOR_SIZE];
39
45void spiflash_init(void)
46{
47 gpio_init_type gpio_initstructure;
48 spi_init_type spi_init_struct;
49
50 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
51 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
52 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
53 /* software cs, pd0 as a general io to control flash cs */
54 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
55 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
56 gpio_initstructure.gpio_mode = GPIO_MODE_OUTPUT;
57 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
58 gpio_initstructure.gpio_pins = GPIO_PINS_0;
59 gpio_init(GPIOD, &gpio_initstructure);
60
61 /* sck */
62 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
63 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
64 gpio_initstructure.gpio_pins = GPIO_PINS_1;
65 gpio_init(GPIOD, &gpio_initstructure);
66 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_6);
67
68 /* miso */
69 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
70 gpio_initstructure.gpio_pins = GPIO_PINS_2;
71 gpio_init(GPIOC, &gpio_initstructure);
72 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE2, GPIO_MUX_5);
73
74 /* mosi */
75 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
76 gpio_initstructure.gpio_pins = GPIO_PINS_4;
77 gpio_init(GPIOD, &gpio_initstructure);
78 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_6);
79
80 FLASH_CS_HIGH();
81 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
82 spi_default_para_init(&spi_init_struct);
83 spi_init_struct.transmission_mode = SPI_TRANSMIT_FULL_DUPLEX;
84 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
85 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_32;
86 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_MSB;
87 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
88 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_HIGH;
89 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
90 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
91 spi_init(SPI2, &spi_init_struct);
92 spi_enable(SPI2, TRUE);
93
94}
95
103void spiflash_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
104{
105 uint32_t sector_pos;
106 uint16_t sector_offset;
107 uint16_t sector_remain;
108 uint16_t index;
109 uint8_t *spiflash_buf;
110 spiflash_buf = spiflash_sector_buf;
111
112 /* sector address */
113 sector_pos = write_addr / SPIF_SECTOR_SIZE;
114
115 /* address offset in a sector */
116 sector_offset = write_addr % SPIF_SECTOR_SIZE;
117
118 /* the remain in a sector */
119 sector_remain = SPIF_SECTOR_SIZE - sector_offset;
120 if(length <= sector_remain)
121 {
122 /* smaller than a sector size */
123 sector_remain = length;
124 }
125 while(1)
126 {
127 /* read a sector */
128 spiflash_read(spiflash_buf, sector_pos * SPIF_SECTOR_SIZE, SPIF_SECTOR_SIZE);
129
130 /* validate the read erea */
131 for(index = 0; index < sector_remain; index++)
132 {
133 if(spiflash_buf[sector_offset + index] != 0xFF)
134 {
135 /* there are some data not equal 0xff, so this secotr needs erased */
136 break;
137 }
138 }
139 if(index < sector_remain)
140 {
141 /* erase the sector */
142 spiflash_sector_erase(sector_pos);
143
144 /* copy the write data */
145 for(index = 0; index < sector_remain; index++)
146 {
147 spiflash_buf[index + sector_offset] = pbuffer[index];
148 }
149 spiflash_write_nocheck(spiflash_buf, sector_pos * SPIF_SECTOR_SIZE, SPIF_SECTOR_SIZE); /* program the sector */
150 }
151 else
152 {
153 /* write directly in the erased area */
154 spiflash_write_nocheck(pbuffer, write_addr, sector_remain);
155 }
156 if(length == sector_remain)
157 {
158 /* write end */
159 break;
160 }
161 else
162 {
163 /* go on writing */
164 sector_pos++;
165 sector_offset = 0;
166
167 pbuffer += sector_remain;
168 write_addr += sector_remain;
169 length -= sector_remain;
170 if(length > SPIF_SECTOR_SIZE)
171 {
172 /* could not write the remain data in the next sector */
173 sector_remain = SPIF_SECTOR_SIZE;
174 }
175 else
176 {
177 /* could write the remain data in the next sector */
178 sector_remain = length;
179 }
180 }
181 }
182}
183
191void spiflash_read(uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
192{
193 FLASH_CS_LOW();
194 spi_byte_write(SPIF_READDATA); /* send instruction */
195 spi_byte_write((uint8_t)((read_addr) >> 16)); /* send 24-bit address */
196 spi_byte_write((uint8_t)((read_addr) >> 8));
197 spi_byte_write((uint8_t)read_addr);
198 spi_bytes_read(pbuffer, length);
199 FLASH_CS_HIGH();
200}
201
207void spiflash_sector_erase(uint32_t erase_addr)
208{
209 erase_addr *= SPIF_SECTOR_SIZE; /* translate sector address to byte address */
210 spiflash_write_enable();
211 spiflash_wait_busy();
212 FLASH_CS_LOW();
213 spi_byte_write(SPIF_SECTORERASE);
214 spi_byte_write((uint8_t)((erase_addr) >> 16));
215 spi_byte_write((uint8_t)((erase_addr) >> 8));
216 spi_byte_write((uint8_t)erase_addr);
217 FLASH_CS_HIGH();
218 spiflash_wait_busy();
219}
220
228void spiflash_write_nocheck(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
229{
230 uint16_t page_remain;
231
232 /* remain bytes in a page */
233 page_remain = SPIF_PAGE_SIZE - write_addr % SPIF_PAGE_SIZE;
234 if(length <= page_remain)
235 {
236 /* smaller than a page size */
237 page_remain = length;
238 }
239 while(1)
240 {
241 spiflash_page_write(pbuffer, write_addr, page_remain);
242 if(length == page_remain)
243 {
244 /* all data are programmed */
245 break;
246 }
247 else
248 {
249 /* length > page_remain */
250 pbuffer += page_remain;
251 write_addr += page_remain;
252
253 /* the remain bytes to be prorammed */
254 length -= page_remain;
255 if(length > SPIF_PAGE_SIZE)
256 {
257 /* can be progrmmed a page at a time */
258 page_remain = SPIF_PAGE_SIZE;
259 }
260 else
261 {
262 /* smaller than a page size */
263 page_remain = length;
264 }
265 }
266 }
267}
268
276void spiflash_page_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
277{
278 if((0 < length) && (length <= SPIF_PAGE_SIZE))
279 {
280 /* set write enable */
281 spiflash_write_enable();
282
283 FLASH_CS_LOW();
284
285 /* send instruction */
286 spi_byte_write(SPIF_PAGEPROGRAM);
287
288 /* send 24-bit address */
289 spi_byte_write((uint8_t)((write_addr) >> 16));
290 spi_byte_write((uint8_t)((write_addr) >> 8));
291 spi_byte_write((uint8_t)write_addr);
292 spi_bytes_write(pbuffer,length);
293
294 FLASH_CS_HIGH();
295
296 /* wait for program end */
297 spiflash_wait_busy();
298 }
299}
300
307void spi_bytes_write(uint8_t *pbuffer, uint32_t length)
308{
309 volatile uint8_t dummy_data;
310
311#if defined(SPI_TRANS_DMA)
312 dma_init_type dma_init_struct;
313 dma_reset(DMA1_CHANNEL2);
314 dma_reset(DMA1_CHANNEL3);
315 dma_default_para_init(&dma_init_struct);
316 dma_init_struct.buffer_size = length;
317 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
318 dma_init_struct.memory_base_addr = (uint32_t)&dummy_data;
319 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
320 dma_init_struct.memory_inc_enable = FALSE;
321 dma_init_struct.peripheral_base_addr = (uint32_t)(&SPI2->dt);
322 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
323 dma_init_struct.peripheral_inc_enable = FALSE;
324 dma_init_struct.priority = DMA_PRIORITY_VERY_HIGH;
325 dma_init_struct.loop_mode_enable = FALSE;
326 dma_init(DMA1_CHANNEL2, &dma_init_struct);
327 dmamux_enable(DMA1, TRUE);
328 dmamux_init(DMA1MUX_CHANNEL2, DMAMUX_DMAREQ_ID_SPI2_RX);
329
330 dma_init_struct.buffer_size = length;
331 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
332 dma_init_struct.memory_base_addr = (uint32_t)pbuffer;
333 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
334 dma_init_struct.memory_inc_enable = TRUE;
335 dma_init_struct.peripheral_base_addr = (uint32_t)(&SPI2->dt);
336 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
337 dma_init_struct.peripheral_inc_enable = FALSE;
338 dma_init_struct.priority = DMA_PRIORITY_VERY_HIGH;
339 dma_init_struct.loop_mode_enable = FALSE;
340 dma_init(DMA1_CHANNEL3, &dma_init_struct);
341 dmamux_init(DMA1MUX_CHANNEL3, DMAMUX_DMAREQ_ID_SPI2_TX);
342
343 spi_i2s_dma_transmitter_enable(SPI2, TRUE);
344 spi_i2s_dma_receiver_enable(SPI2, TRUE);
345
346 dma_channel_enable(DMA1_CHANNEL2, TRUE);
347 dma_channel_enable(DMA1_CHANNEL3, TRUE);
348
349 while(dma_flag_get(DMA1_FDT2_FLAG) == RESET);
350 dma_flag_clear(DMA1_FDT2_FLAG);
351
352 dma_channel_enable(DMA1_CHANNEL2, FALSE);
353 dma_channel_enable(DMA1_CHANNEL3, FALSE);
354
355 spi_i2s_dma_transmitter_enable(SPI2, FALSE);
356 spi_i2s_dma_receiver_enable(SPI2, FALSE);
357#else
358 while(length--)
359 {
360 while(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) == RESET);
361 spi_i2s_data_transmit(SPI2, *pbuffer);
362 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
363 dummy_data = spi_i2s_data_receive(SPI2);
364 pbuffer++;
365 }
366#endif
367}
368
375void spi_bytes_read(uint8_t *pbuffer, uint32_t length)
376{
377 uint8_t write_value = FLASH_SPI_DUMMY_BYTE;
378
379#if defined(SPI_TRANS_DMA)
380 dma_init_type dma_init_struct;
381 dma_reset(DMA1_CHANNEL2);
382 dma_reset(DMA1_CHANNEL3);
383 dma_default_para_init(&dma_init_struct);
384 dma_init_struct.buffer_size = length;
385 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
386 dma_init_struct.memory_base_addr = (uint32_t)&write_value;
387 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
388 dma_init_struct.memory_inc_enable = FALSE;
389 dma_init_struct.peripheral_base_addr = (uint32_t)(&SPI2->dt);
390 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
391 dma_init_struct.peripheral_inc_enable = FALSE;
392 dma_init_struct.priority = DMA_PRIORITY_VERY_HIGH;
393 dma_init_struct.loop_mode_enable = FALSE;
394 dma_init(DMA1_CHANNEL3, &dma_init_struct);
395 dmamux_enable(DMA1, TRUE);
396 dmamux_init(DMA1MUX_CHANNEL3, DMAMUX_DMAREQ_ID_SPI2_TX);
397
398 dma_init_struct.buffer_size = length;
399 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
400 dma_init_struct.memory_base_addr = (uint32_t)pbuffer;
401 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
402 dma_init_struct.memory_inc_enable = TRUE;
403 dma_init_struct.peripheral_base_addr = (uint32_t)(&SPI2->dt);
404 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
405 dma_init_struct.peripheral_inc_enable = FALSE;
406 dma_init_struct.priority = DMA_PRIORITY_VERY_HIGH;
407 dma_init_struct.loop_mode_enable = FALSE;
408 dma_init(DMA1_CHANNEL2, &dma_init_struct);
409 dmamux_init(DMA1MUX_CHANNEL2, DMAMUX_DMAREQ_ID_SPI2_RX);
410
411 spi_i2s_dma_transmitter_enable(SPI2, TRUE);
412 spi_i2s_dma_receiver_enable(SPI2, TRUE);
413 dma_channel_enable(DMA1_CHANNEL2, TRUE);
414 dma_channel_enable(DMA1_CHANNEL3, TRUE);
415
416 while(dma_flag_get(DMA1_FDT2_FLAG) == RESET);
417 dma_flag_clear(DMA1_FDT2_FLAG);
418
419 dma_channel_enable(DMA1_CHANNEL2, FALSE);
420 dma_channel_enable(DMA1_CHANNEL3, FALSE);
421
422 spi_i2s_dma_transmitter_enable(SPI2, FALSE);
423 spi_i2s_dma_receiver_enable(SPI2, FALSE);
424#else
425 while(length--)
426 {
427 while(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) == RESET);
428 spi_i2s_data_transmit(SPI2, write_value);
429 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
430 *pbuffer = spi_i2s_data_receive(SPI2);
431 pbuffer++;
432 }
433#endif
434}
435
441void spiflash_wait_busy(void)
442{
443 while((spiflash_read_sr1() & 0x01) == 0x01);
444}
445
451uint8_t spiflash_read_sr1(void)
452{
453 uint8_t breadbyte = 0;
454 FLASH_CS_LOW();
455 spi_byte_write(SPIF_READSTATUSREG1);
456 breadbyte = (uint8_t)spi_byte_read();
457 FLASH_CS_HIGH();
458 return (breadbyte);
459}
460
466void spiflash_write_enable(void)
467{
468 FLASH_CS_LOW();
469 spi_byte_write(SPIF_WRITEENABLE);
470 FLASH_CS_HIGH();
471}
472
478uint16_t spiflash_read_id(void)
479{
480 uint16_t wreceivedata = 0;
481 FLASH_CS_LOW();
482 spi_byte_write(SPIF_MANUFACTDEVICEID);
483 spi_byte_write(0x00);
484 spi_byte_write(0x00);
485 spi_byte_write(0x00);
486 wreceivedata |= spi_byte_read() << 8;
487 wreceivedata |= spi_byte_read();
488 FLASH_CS_HIGH();
489 return wreceivedata;
490}
491
497uint8_t spi_byte_write(uint8_t data)
498{
499 uint8_t brxbuff;
500 spi_i2s_dma_transmitter_enable(SPI2, FALSE);
501 spi_i2s_dma_receiver_enable(SPI2, FALSE);
502 spi_i2s_data_transmit(SPI2, data);
503 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
504 brxbuff = spi_i2s_data_receive(SPI2);
505 while(spi_i2s_flag_get(SPI2, SPI_I2S_BF_FLAG) != RESET);
506 return brxbuff;
507}
508
514uint8_t spi_byte_read(void)
515{
516 return (spi_byte_write(FLASH_SPI_DUMMY_BYTE));
517}
518
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:40
spiflash_sector_buf
uint8_t spiflash_sector_buf[SPIF_SECTOR_SIZE]
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:38
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:138
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:162
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:172
DMA_PRIORITY_VERY_HIGH
@ DMA_PRIORITY_VERY_HIGH
Definition: at32f435_437_dma.h:185
DMAMUX_DMAREQ_ID_SPI2_TX
@ DMAMUX_DMAREQ_ID_SPI2_TX
Definition: at32f435_437_dma.h:207
DMAMUX_DMAREQ_ID_SPI2_RX
@ DMAMUX_DMAREQ_ID_SPI2_RX
Definition: at32f435_437_dma.h:206
DMA1_FDT2_FLAG
#define DMA1_FDT2_FLAG
Definition: at32f435_437_dma.h:70
DMA1MUX_CHANNEL2
#define DMA1MUX_CHANNEL2
Definition: at32f435_437_dma.h:705
DMA1MUX_CHANNEL3
#define DMA1MUX_CHANNEL3
Definition: at32f435_437_dma.h:706
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f435_437_dma.h:698
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f435_437_dma.h:697
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_6
@ GPIO_MUX_6
Definition: at32f435_437_gpio.h:162
GPIO_MUX_5
@ GPIO_MUX_5
Definition: at32f435_437_gpio.h:161
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f435_437_spi.h:54
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f435_437_spi.h:53
SPI_I2S_BF_FLAG
#define SPI_I2S_BF_FLAG
Definition: at32f435_437_spi.h:60
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f435_437_spi.c:548
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f435_437_spi.c:533
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f435_437_spi.c:583
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f435_437_spi.c:101
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f435_437_spi.c:81
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f435_437_spi.c:560
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f435_437_spi.c:321
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f435_437_spi.c:519
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f435_437_spi.h:100
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f435_437_spi.h:118
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f435_437_spi.h:127
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f435_437_spi.h:153
SPI_CLOCK_POLARITY_HIGH
@ SPI_CLOCK_POLARITY_HIGH
Definition: at32f435_437_spi.h:109
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f435_437_spi.h:162
SPI_MCLK_DIV_32
@ SPI_MCLK_DIV_32
Definition: at32f435_437_spi.h:140
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f435_437_spi.h:90
FLASH_CS_LOW
#define FLASH_CS_LOW()
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:49
FLASH_CS_HIGH
#define FLASH_CS_HIGH()
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:48
spiflash_init
void spiflash_init(void)
spi configuration.
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:45
spiflash_write
void spiflash_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:103
spiflash_wait_busy
void spiflash_wait_busy(void)
wait program done
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:441
spiflash_write_enable
void spiflash_write_enable(void)
enable write operation
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:466
spiflash_read_sr1
uint8_t spiflash_read_sr1(void)
read sr1 register
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:451
spiflash_write_nocheck
void spiflash_write_nocheck(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data without check
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:228
spiflash_sector_erase
void spiflash_sector_erase(uint32_t erase_addr)
erase a sector data
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:207
spi_byte_write
uint8_t spi_byte_write(uint8_t data)
write a byte to flash
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:497
spiflash_read
void spiflash_read(uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:191
spiflash_read_id
uint16_t spiflash_read_id(void)
read device id
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:478
spi_bytes_read
void spi_bytes_read(uint8_t *pbuffer, uint32_t length)
read data continuously
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:375
spi_bytes_write
void spi_bytes_write(uint8_t *pbuffer, uint32_t length)
write data continuously
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:307
spiflash_page_write
void spiflash_page_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write a page data
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:276
spi_byte_read
uint8_t spi_byte_read(void)
read a byte to flash
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:514
SPIF_READDATA
#define SPIF_READDATA
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:92
SPIF_PAGE_SIZE
#define SPIF_PAGE_SIZE
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:79
SPIF_SECTORERASE
#define SPIF_SECTORERASE
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:98
SPIF_MANUFACTDEVICEID
#define SPIF_MANUFACTDEVICEID
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:103
FLASH_SPI_DUMMY_BYTE
#define FLASH_SPI_DUMMY_BYTE
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:105
SPIF_SECTOR_SIZE
#define SPIF_SECTOR_SIZE
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:78
SPIF_READSTATUSREG1
#define SPIF_READSTATUSREG1
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:84
SPIF_PAGEPROGRAM
#define SPIF_PAGEPROGRAM
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:95
SPIF_WRITEENABLE
#define SPIF_WRITEENABLE
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:81
SPI2
#define SPI2
Definition: at32f435_437_spi.h:454
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
spi_init_type
spi init type
Definition: at32f435_437_spi.h:259
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f435_437_spi.h:261
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f435_437_spi.h:263
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f435_437_spi.h:264
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:265
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f435_437_spi.h:267
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f435_437_spi.h:262
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f435_437_spi.h:260
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f435_437_spi.h:266


AT32F435/437 Firmwary Library: smartcard_config.h File Reference

  • at_start_f437
  • examples
  • usart
  • smartcard
  • inc
Macros
at_start_f437/examples/usart/smartcard/inc/smartcard_config.h File Reference

header file of clock program More...

Go to the source code of this file.

Macros

#define | SC_USART USART2
#define | SC_USART_CLK CRM_USART2_PERIPH_CLOCK
#define | SC_USART_GPIO_CLK CRM_GPIOA_PERIPH_CLOCK
#define | SC_USART_TX_PIN GPIO_PINS_2
#define | SC_USART_TX_PORT GPIOA
#define | SC_USART_CLK_PIN GPIO_PINS_4
#define | SC_USART_CLK_PORT GPIOA
#define | SC_USART_IRQn USART2_IRQn
#define | SC_USART_IRQHandler USART2_IRQHandler
#define | SC_3_5V_PIN GPIO_PINS_5
#define | SC_RESET_PIN GPIO_PINS_6
#define | SC_CMDVCC_PIN GPIO_PINS_7
#define | SC_OFF_PIN GPIO_PINS_8
#define | SC_3_5V_PORT GPIOA
#define | SC_RESET_PORT GPIOA
#define | SC_CMDVCC_PORT GPIOA
#define | SC_OFF_PORT GPIOA
#define | SC_3_5V_CLK CRM_GPIOA_PERIPH_CLOCK
#define | SC_RESET_CLK CRM_GPIOA_PERIPH_CLOCK
#define | SC_CMDVCC_CLK CRM_GPIOA_PERIPH_CLOCK
#define | SC_OFF_CLK CRM_GPIOA_PERIPH_CLOCK
#define | SC_OFF_EXINT EXINT_LINE_8
#define | SC_OFF_PORTSOURCE SCFG_PORT_SOURCE_GPIOA
#define | SC_OFF_PINSOURCE SCFG_PINS_SOURCE8
#define | SC_OFF_EXINT_IRQ EXINT9_5_IRQn

Detailed Description

header file of clock program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

Macro Definition Documentation

◆ SC_3_5V_CLK

#define SC_3_5V_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 51 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_3_5V_PIN

#define SC_3_5V_PIN GPIO_PINS_5

Definition at line 43 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_3_5V_PORT

#define SC_3_5V_PORT GPIOA

Definition at line 47 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_CMDVCC_CLK

#define SC_CMDVCC_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 53 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_CMDVCC_PIN

#define SC_CMDVCC_PIN GPIO_PINS_7

Definition at line 45 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_CMDVCC_PORT

#define SC_CMDVCC_PORT GPIOA

Definition at line 49 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_OFF_CLK

#define SC_OFF_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 54 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_OFF_EXINT

#define SC_OFF_EXINT EXINT_LINE_8

Definition at line 55 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_OFF_EXINT_IRQ

#define SC_OFF_EXINT_IRQ EXINT9_5_IRQn

Definition at line 58 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_OFF_PIN

#define SC_OFF_PIN GPIO_PINS_8

Definition at line 46 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_OFF_PINSOURCE

#define SC_OFF_PINSOURCE SCFG_PINS_SOURCE8

Definition at line 57 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_OFF_PORT

#define SC_OFF_PORT GPIOA

Definition at line 50 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_OFF_PORTSOURCE

#define SC_OFF_PORTSOURCE SCFG_PORT_SOURCE_GPIOA

Definition at line 56 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_RESET_CLK

#define SC_RESET_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 52 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_RESET_PIN

#define SC_RESET_PIN GPIO_PINS_6

Definition at line 44 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_RESET_PORT

#define SC_RESET_PORT GPIOA

Definition at line 48 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_USART

#define SC_USART USART2

Definition at line 32 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_USART_CLK

#define SC_USART_CLK CRM_USART2_PERIPH_CLOCK

Definition at line 33 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_USART_CLK_PIN

#define SC_USART_CLK_PIN GPIO_PINS_4

Definition at line 37 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_USART_CLK_PORT

#define SC_USART_CLK_PORT GPIOA

Definition at line 38 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_USART_GPIO_CLK

#define SC_USART_GPIO_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 34 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_USART_IRQHandler

#define SC_USART_IRQHandler ( void ) USART2_IRQHandler

Definition at line 40 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_USART_IRQn

#define SC_USART_IRQn USART2_IRQn

Definition at line 39 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_USART_TX_PIN

#define SC_USART_TX_PIN GPIO_PINS_2

Definition at line 35 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.

◆ SC_USART_TX_PORT

#define SC_USART_TX_PORT GPIOA

Definition at line 36 of file at_start_f437/examples/usart/smartcard/inc/smartcard_config.h.


AT32F435/437 Firmwary Library: smartcard_config.h Source File

  • at_start_f437
  • examples
  • usart
  • smartcard
  • inc
at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __SMARTCARD_CONFIG_H
29#define __SMARTCARD_CONFIG_H
30
31/* smartcard inteface usart pins */
32#define SC_USART USART2
33#define SC_USART_CLK CRM_USART2_PERIPH_CLOCK
34#define SC_USART_GPIO_CLK CRM_GPIOA_PERIPH_CLOCK
35#define SC_USART_TX_PIN GPIO_PINS_2
36#define SC_USART_TX_PORT GPIOA
37#define SC_USART_CLK_PIN GPIO_PINS_4
38#define SC_USART_CLK_PORT GPIOA
39#define SC_USART_IRQn USART2_IRQn
40#define SC_USART_IRQHandler USART2_IRQHandler
41
42/* smartcard inteface gpio pins */
43#define SC_3_5V_PIN GPIO_PINS_5
44#define SC_RESET_PIN GPIO_PINS_6
45#define SC_CMDVCC_PIN GPIO_PINS_7
46#define SC_OFF_PIN GPIO_PINS_8
47#define SC_3_5V_PORT GPIOA
48#define SC_RESET_PORT GPIOA
49#define SC_CMDVCC_PORT GPIOA
50#define SC_OFF_PORT GPIOA
51#define SC_3_5V_CLK CRM_GPIOA_PERIPH_CLOCK
52#define SC_RESET_CLK CRM_GPIOA_PERIPH_CLOCK
53#define SC_CMDVCC_CLK CRM_GPIOA_PERIPH_CLOCK
54#define SC_OFF_CLK CRM_GPIOA_PERIPH_CLOCK
55#define SC_OFF_EXINT EXINT_LINE_8
56#define SC_OFF_PORTSOURCE SCFG_PORT_SOURCE_GPIOA
57#define SC_OFF_PINSOURCE SCFG_PINS_SOURCE8
58#define SC_OFF_EXINT_IRQ EXINT9_5_IRQn
59
60#endif /* __SMARTCARD_CONFIG_H */
61


AT32F435/437 Firmwary Library: audio_codec.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • audio
  • inc
Data Structures | Macros | Functions
at_start_f437/examples/usb_device/audio/inc/audio_codec.h File Reference

audio codec header file More...

#include "usb_conf.h"

Go to the source code of this file.

Data Structures

struct audio_codec_type

Macros

#define | WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/
#define | WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/
#define | WM8988_R2_LOUT1_VOLUME 0x02
#define | WM8988_R3_ROUT1_VOLUME 0x03
#define | WM8988_R4_RESERVED 0x04
#define | WM8988_R5_ADC_DAC_CONTROL 0x05
#define | WM8988_R6_RESERVED 0x06
#define | WM8988_R7_AUDIO_INTERFACE 0x07
#define | WM8988_R8_SAMPLE_RATE 0x08
#define | WM8988_R9_RESERVED 0x09
#define | WM8988_R10_LEFT_DAC_VOLUME 0x0A
#define | WM8988_R11_RIGHT_DAC_VOLUME 0x0B
#define | WM8988_R12_BASS_CONTROL 0x0C
#define | WM8988_R13_TREBLE_CONTROL 0x0D
#define | WM8988_R14_
#define | WM8988_R15_RESET 0x0F
#define | WM8988_R16_3D_CONTROL 0x10
#define | WM8988_R17_ALC1 0x11
#define | WM8988_R18_ALC2 0x12
#define | WM8988_R19_ALC3 0x13
#define | WM8988_R20_NOISE_GATE 0x14
#define | WM8988_R21_LEFT_ADC_VOLUME 0x15
#define | WM8988_R22_RIGHT_ADC_VOLUME 0x16
#define | WM8988_R23_ADDITIONAL_1_CONTROL 0x17
#define | WM8988_R24_ADDITIONAL_2_CONTROL 0x18
#define | WM8988_R25_PWR_1_MGMT 0x19
#define | WM8988_R26_PWR_2_MGMT 0x1A
#define | WM8988_R27_ADDITIONAL_3_CONTROL 0x1B
#define | WM8988_R31_ADC_INPUT_MODE 0x1F
#define | WM8988_R32_ADC_L_SIGNAL_PATH 0x20
#define | WM8988_R33_ADC_R_SIGNAL_PATH 0x21
#define | WM8988_R34_LEFT_OUT_MIX_1 0x22
#define | WM8988_R35_LEFT_OUT_MIX_2 0x23
#define | WM8988_R36_RIGHT_OUT_MIX_1 0x24
#define | WM8988_R37_RIGHT_OUT_MIX_2 0x25
#define | WM8988_R38_RESERVED
#define | WM8988_R39_RESERVED
#define | WM8988_R40_LOUT2_VOLUME 0x28
#define | WM8988_R41_ROUT2_VOLUME 0x29
#define | WM8988_R42_RESERVED
#define | WM8988_R43_LOW_POWER_PALYBACK 0x43
#define | WM8988_I2C_ADDR_CSB_LOW 0x34
#define | WM8988_I2C_ADDR_CSB_HIGH 0x36
#define | I2S1_WS_PIN GPIO_PINS_4
#define | I2S1_WS_PIN_SOURCE GPIO_PINS_SOURCE4
#define | I2S1_WS_GPIO_MUX GPIO_MUX_5
#define | I2S1_CK_PIN GPIO_PINS_5
#define | I2S1_CK_PIN_SOURCE GPIO_PINS_SOURCE5
#define | I2S1_CK_GPIO_MUX GPIO_MUX_5
#define | I2S1_SD_PIN GPIO_PINS_7
#define | I2S1_SD_PIN_SOURCE GPIO_PINS_SOURCE7
#define | I2S1_SD_GPIO_MUX GPIO_MUX_5
#define | I2S1_GPIO GPIOA
#define | I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
#define | I2S1_DT_ADDRESS (&(SPI1->dt))
#define | I2S2_WS_PIN GPIO_PINS_0
#define | I2S2_WS_PIN_SOURCE GPIO_PINS_SOURCE0
#define | I2S2_WS_GPIO_MUX GPIO_MUX_7
#define | I2S2_CK_PIN GPIO_PINS_1
#define | I2S2_CK_PIN_SOURCE GPIO_PINS_SOURCE1
#define | I2S2_CK_GPIO_MUX GPIO_MUX_6
#define | I2S2_SD_PIN GPIO_PINS_4
#define | I2S2_SD_PIN_SOURCE GPIO_PINS_SOURCE4
#define | I2S2_SD_GPIO_MUX GPIO_MUX_6
#define | I2S2_GPIO GPIOD
#define | I2S2_GPIO_CRM_CLK CRM_GPIOD_PERIPH_CLOCK
#define | I2S2_DT_ADDRESS (&(SPI2->dt))
#define | SPK_TX_FIFO_SIZE (1024 * 4)
#define | MIC_BUFFER_SIZE 1024
#define | SPK_BUFFER_SIZE 4096
#define | DMA_BUFFER_SIZE 288

Functions

error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
audio codec interface More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...

Detailed Description

audio codec header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/usb_device/audio/inc/audio_codec.h.


AT32F435/437 Firmwary Library: audio_codec.h Source File

  • at_start_f437
  • examples
  • usb_device
  • audio
  • inc
at_start_f437/examples/usb_device/audio/inc/audio_codec.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AUDIO_CODEC_H
29#define __AUDIO_CODEC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
44/* includes ------------------------------------------------------------------*/
45#include "usb_conf.h"
46
50#define WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/
51#define WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/
52#define WM8988_R2_LOUT1_VOLUME 0x02
53#define WM8988_R3_ROUT1_VOLUME 0x03
54#define WM8988_R4_RESERVED 0x04
55#define WM8988_R5_ADC_DAC_CONTROL 0x05
56#define WM8988_R6_RESERVED 0x06
57#define WM8988_R7_AUDIO_INTERFACE 0x07
58#define WM8988_R8_SAMPLE_RATE 0x08
59#define WM8988_R9_RESERVED 0x09
60#define WM8988_R10_LEFT_DAC_VOLUME 0x0A
61#define WM8988_R11_RIGHT_DAC_VOLUME 0x0B
62#define WM8988_R12_BASS_CONTROL 0x0C
63#define WM8988_R13_TREBLE_CONTROL 0x0D
64#define WM8988_R14_
65#define WM8988_R15_RESET 0x0F
66#define WM8988_R16_3D_CONTROL 0x10
67#define WM8988_R17_ALC1 0x11
68#define WM8988_R18_ALC2 0x12
69#define WM8988_R19_ALC3 0x13
70#define WM8988_R20_NOISE_GATE 0x14
71#define WM8988_R21_LEFT_ADC_VOLUME 0x15
72#define WM8988_R22_RIGHT_ADC_VOLUME 0x16
73#define WM8988_R23_ADDITIONAL_1_CONTROL 0x17
74#define WM8988_R24_ADDITIONAL_2_CONTROL 0x18
75#define WM8988_R25_PWR_1_MGMT 0x19
76#define WM8988_R26_PWR_2_MGMT 0x1A
77#define WM8988_R27_ADDITIONAL_3_CONTROL 0x1B
78
79#define WM8988_R31_ADC_INPUT_MODE 0x1F
80#define WM8988_R32_ADC_L_SIGNAL_PATH 0x20
81#define WM8988_R33_ADC_R_SIGNAL_PATH 0x21
82#define WM8988_R34_LEFT_OUT_MIX_1 0x22
83#define WM8988_R35_LEFT_OUT_MIX_2 0x23
84#define WM8988_R36_RIGHT_OUT_MIX_1 0x24
85#define WM8988_R37_RIGHT_OUT_MIX_2 0x25
86#define WM8988_R38_RESERVED
87#define WM8988_R39_RESERVED
88#define WM8988_R40_LOUT2_VOLUME 0x28
89#define WM8988_R41_ROUT2_VOLUME 0x29
90#define WM8988_R42_RESERVED
91#define WM8988_R43_LOW_POWER_PALYBACK 0x43
92
93#define WM8988_I2C_ADDR_CSB_LOW 0x34
94#define WM8988_I2C_ADDR_CSB_HIGH 0x36
95
103#define I2S1_WS_PIN GPIO_PINS_4
104#define I2S1_WS_PIN_SOURCE GPIO_PINS_SOURCE4
105#define I2S1_WS_GPIO_MUX GPIO_MUX_5
106
107#define I2S1_CK_PIN GPIO_PINS_5
108#define I2S1_CK_PIN_SOURCE GPIO_PINS_SOURCE5
109#define I2S1_CK_GPIO_MUX GPIO_MUX_5
110
111#define I2S1_SD_PIN GPIO_PINS_7
112#define I2S1_SD_PIN_SOURCE GPIO_PINS_SOURCE7
113#define I2S1_SD_GPIO_MUX GPIO_MUX_5
114
115#define I2S1_GPIO GPIOA
116#define I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
117#define I2S1_DT_ADDRESS (&(SPI1->dt))
118
119/*I2S2 Pin*/
120#define I2S2_WS_PIN GPIO_PINS_0
121#define I2S2_WS_PIN_SOURCE GPIO_PINS_SOURCE0
122#define I2S2_WS_GPIO_MUX GPIO_MUX_7
123
124#define I2S2_CK_PIN GPIO_PINS_1
125#define I2S2_CK_PIN_SOURCE GPIO_PINS_SOURCE1
126#define I2S2_CK_GPIO_MUX GPIO_MUX_6
127
128#define I2S2_SD_PIN GPIO_PINS_4
129#define I2S2_SD_PIN_SOURCE GPIO_PINS_SOURCE4
130#define I2S2_SD_GPIO_MUX GPIO_MUX_6
131
132#define I2S2_GPIO GPIOD
133#define I2S2_GPIO_CRM_CLK CRM_GPIOD_PERIPH_CLOCK
134#define I2S2_DT_ADDRESS (&(SPI2->dt))
135
136#define SPK_TX_FIFO_SIZE (1024 * 4)
137
145#define MIC_BUFFER_SIZE 1024
146#define SPK_BUFFER_SIZE 4096
147#define DMA_BUFFER_SIZE 288
148
149typedef struct
150{
151 uint32_t audio_freq;
152 uint32_t audio_bitw;
153 //spk part
154 uint16_t spk_buffer[SPK_BUFFER_SIZE];
155 uint16_t *spk_roff;
156 uint16_t *spk_woff;
157 uint16_t *spk_rend;
158 uint32_t spk_freq;
159 uint32_t spk_wtotal;
160 uint32_t spk_rtotal;
161 uint16_t spk_threshold;
162 uint16_t spk_calc;
163 uint8_t spk_stage;
164
165 //mic part
166 uint16_t mic_buffer[MIC_BUFFER_SIZE];
167 uint16_t *mic_roff;
168 uint16_t *mic_woff;
169 uint16_t *mic_wend;
170 uint32_t mic_wtotal;
171 uint32_t mic_rtotal;
172 uint32_t mic_delta;
173 uint16_t mic_calc;
174 uint16_t mic_adj_count;
175 uint8_t mic_adj_stage;
176 uint8_t mic_stage;
177
178 uint8_t mic_mute;
179 uint8_t spk_mute;
180
181 uint16_t mic_volume;
182 uint16_t spk_volume;
183
184 uint32_t spk_tx_size;
185 uint32_t mic_rx_size;
186
187 uint32_t spk_enable;
188 uint32_t mic_enable;
189
190}audio_codec_type;
191
192 error_status audio_codec_init(void);
193 error_status audio_codec_loop(void);
194void audio_codec_modify_freq(uint32_t freq);
195
199void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len);
200uint32_t audio_codec_mic_get_data(uint8_t *buffer);
201uint8_t audio_codec_spk_feedback(uint8_t *feedback);
202void audio_codec_spk_alt_setting(uint32_t alt_seting);
203void audio_codec_mic_alt_setting(uint32_t alt_seting);
204void audio_codec_set_mic_mute(uint8_t mute);
205void audio_codec_set_spk_mute(uint8_t mute);
206void audio_codec_set_mic_volume(uint16_t volume);
207void audio_codec_set_spk_volume(uint16_t volume);
208void audio_codec_set_mic_freq(uint32_t freq);
209void audio_codec_set_spk_freq(uint32_t freq);
210
222#ifdef __cplusplus
223}
224#endif
225
226#endif
227
buffer
uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:43
error_status
error_status
Definition: at32f435_437.h:380
audio_codec_mic_alt_setting
void audio_codec_mic_alt_setting(uint32_t alt_seting)
audio codec microphone alt setting config
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:173
audio_codec_set_spk_volume
void audio_codec_set_spk_volume(uint16_t volume)
audio codec set speaker volume
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:221
audio_codec_set_spk_mute
void audio_codec_set_spk_mute(uint8_t mute)
audio codec set speaker mute
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:199
MIC_BUFFER_SIZE
#define MIC_BUFFER_SIZE
Definition: at_start_f437/examples/usb_device/audio/inc/audio_codec.h:145
audio_codec_set_mic_freq
void audio_codec_set_mic_freq(uint32_t freq)
audio codec set microphone freq
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:125
audio_codec_mic_get_data
uint32_t audio_codec_mic_get_data(uint8_t *buffer)
codec microphone get data
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:286
audio_codec_loop
error_status audio_codec_loop(void)
audio codec loop
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:870
SPK_BUFFER_SIZE
#define SPK_BUFFER_SIZE
Definition: at_start_f437/examples/usb_device/audio/inc/audio_codec.h:146
audio_codec_set_mic_mute
void audio_codec_set_mic_mute(uint8_t mute)
audio codec set microphone mute
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:188
audio_codec_spk_fifo_write
void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
audio codec interface
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:248
audio_codec_spk_feedback
uint8_t audio_codec_spk_feedback(uint8_t *feedback)
codec speaker feedback
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:232
audio_codec_modify_freq
void audio_codec_modify_freq(uint32_t freq)
audio codec modify freq
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:346
audio_codec_set_mic_volume
void audio_codec_set_mic_volume(uint16_t volume)
audio codec set microphone volume
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:210
audio_codec_spk_alt_setting
void audio_codec_spk_alt_setting(uint32_t alt_seting)
audio codec speaker alt setting config
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:158
audio_codec_init
error_status audio_codec_init(void)
audio codec init
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:811
audio_codec_set_spk_freq
void audio_codec_set_spk_freq(uint32_t freq)
audio codec set speaker freq
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:141
audio_codec_type
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:150
usb_conf.h
usb config header file


AT32F435/437 Firmwary Library: audio_codec.c File Reference

  • at_start_f437
  • examples
  • usb_device
  • audio
  • src
Macros | Functions | Variables
at_start_f437/examples/usb_device/audio/src/audio_codec.c File Reference

audio codec function More...

#include "audio_codec.h"
#include "i2c_application.h"
#include "audio_conf.h"
#include <string.h>

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_CLKCTRL 0x80504C4E
#define | I2Cx_ADDRESS 0x00
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_8
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE8
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_MUX GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_9
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE9
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_MUX GPIO_MUX_4
#define | WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)
wm8988 freq More...
#define | WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)
#define | WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)
wm8988 bit width More...

Functions

void | memset16_buffer (uint16_t *buffer, uint32_t set, uint32_t len)
buffer memset More...
void | codec_i2s_reset (void)
audio codec i2s reset More...
void | codec_i2s_init (audio_codec_type *param)
audio codec i2s init More...
void | mclk_tmr1_init (void)
mclk clock conifg More...
void | copy_buff (uint16_t *dest, uint16_t *src, uint32_t len)
copy buffer More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
codec speaker write fifo More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | DMA1_Channel3_IRQHandler (void)
this function handles dma1 channel3 interrupt. More...
void | DMA1_Channel4_IRQHandler (void)
this function handles dma1 channel4 interrupt. More...
error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...

Variables

uint16_t | reg_addr_data []
wm8988 register default value More...
i2c_handle_type hi2cx
audio_codec_type audio_codec
uint16_t | spk_dma_buffer [DMA_BUFFER_SIZE]
uint16_t | mic_dma_buffer [DMA_BUFFER_SIZE]

Detailed Description

audio codec function

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/usb_device/audio/src/audio_codec.c.


AT32F435/437 Firmwary Library: audio_codec.c Source File

  • at_start_f437
  • examples
  • usb_device
  • audio
  • src
at_start_f437/examples/usb_device/audio/src/audio_codec.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "audio_codec.h"
29#include "i2c_application.h"
30#include "audio_conf.h"
31#include <string.h>
32
41#define I2C_TIMEOUT 0xFFFFFFFF
42
43#define I2Cx_CLKCTRL 0x80504C4E
44#define I2Cx_ADDRESS 0x00
45
46#define I2Cx_PORT I2C1
47#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
48
49#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
50#define I2Cx_SCL_GPIO_PIN GPIO_PINS_8
51#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE8
52#define I2Cx_SCL_GPIO_PORT GPIOB
53#define I2Cx_SCL_GPIO_MUX GPIO_MUX_4
54
55#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
56#define I2Cx_SDA_GPIO_PIN GPIO_PINS_9
57#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE9
58#define I2Cx_SDA_GPIO_PORT GPIOB
59#define I2Cx_SDA_GPIO_MUX GPIO_MUX_4
60
64#define WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)
65#define WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)
66
70#define WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)
71
75uint16_t reg_addr_data[] =
76{
77 (WM8988_R0_LEFT_INPUT_VOLUME << 9) | 0x012F, /*Left Input Channel Volume*/
78 (WM8988_R1_RIGHT_INPUT_VOLUME << 9) | 0x012F, /*Right Input Channel Volume*/
79 (WM8988_R2_LOUT1_VOLUME << 9) | 0x0179, /*Left Output Channel Volume*/
80 (WM8988_R3_ROUT1_VOLUME << 9) | 0x0179, /*Right Output Channel Volume*/
81 (WM8988_R5_ADC_DAC_CONTROL << 9) | 0x0006, /*De-emphasis Control and Digital soft mute*/
82 (WM8988_REG_BITW16),
83 (WM8988_REG_FREQ16K),
84 (WM8988_R10_LEFT_DAC_VOLUME << 9) | 0x01FF, /*Left Digital DAC Volume Control*/
85 (WM8988_R11_RIGHT_DAC_VOLUME << 9) | 0x01FF, /*Right Digital DAC Volume Control*/
86 (WM8988_R12_BASS_CONTROL << 9) | 0x000F, /*Bass Control*/
87 (WM8988_R13_TREBLE_CONTROL << 9) | 0x000F, /*Treble Control*/
88 (WM8988_R16_3D_CONTROL << 9) | 0x0000, /*3D stereo Enhancment*/
89 (WM8988_R21_LEFT_ADC_VOLUME << 9) | 0x01C3, /*Left ADC Digital Volume*/
90 (WM8988_R22_RIGHT_ADC_VOLUME << 9) | 0x01C3, /*Right ADC Digital Volume*/
91 (WM8988_R23_ADDITIONAL_1_CONTROL << 9) | 0x00C2, /*Additional Control 1*/
92 (WM8988_R24_ADDITIONAL_2_CONTROL << 9) | 0x0000, /*Additional Control 2*/
93 (WM8988_R27_ADDITIONAL_3_CONTROL << 9) | 0x0000, /*Additional Control 3*/
94 (WM8988_R31_ADC_INPUT_MODE << 9) | 0x0000, /*ADC input mode*/
95 (WM8988_R32_ADC_L_SIGNAL_PATH << 9) | 0x0000, /*ADC Signal Path Control left*/
96 (WM8988_R33_ADC_R_SIGNAL_PATH << 9) | 0x0000, /*ADC Signal Path Control right*/
97 (WM8988_R34_LEFT_OUT_MIX_1 << 9) | 0x0152, /*Left DAC mixer Control*/
98 (WM8988_R35_LEFT_OUT_MIX_2 << 9) | 0x0050, /*Left DAC mixer Control*/
99 (WM8988_R36_RIGHT_OUT_MIX_1 << 9) | 0x0052, /*Right DAC mixer Control*/
100 (WM8988_R37_RIGHT_OUT_MIX_2 << 9) | 0x0150, /*Right DAC mixer Control*/
101 (WM8988_R40_LOUT2_VOLUME << 9) | 0x01FF, /*Output left channel volume*/
102 (WM8988_R41_ROUT2_VOLUME << 9) | 0x01FF, /*Output left channel volume*/
103 (WM8988_R43_LOW_POWER_PALYBACK << 9) | 0x0008, /*Output left channel volume*/
104 (WM8988_R25_PWR_1_MGMT << 9) | 0x017C, /*Power Management1*/
105 (WM8988_R26_PWR_2_MGMT << 9) | 0x01F8, /*Power Management2*/
106};
107
108 i2c_handle_type hi2cx;
109
110 audio_codec_type audio_codec;
111uint16_t spk_dma_buffer[DMA_BUFFER_SIZE];
112uint16_t mic_dma_buffer[DMA_BUFFER_SIZE];
113
114void memset16_buffer(uint16_t *buffer, uint32_t set, uint32_t len);
115void codec_i2s_reset(void);
116void codec_i2s_init(audio_codec_type *param);
117void mclk_tmr1_init(void);
118void copy_buff(uint16_t *dest, uint16_t *src, uint32_t len);
119
125void audio_codec_set_mic_freq(uint32_t freq)
126{
127 if(audio_codec.audio_freq != freq)
128 {
129 audio_codec.audio_freq = freq;
130 codec_i2s_reset();
131 audio_codec_modify_freq(freq);
132 codec_i2s_init(&audio_codec);
133 }
134}
135
141void audio_codec_set_spk_freq(uint32_t freq)
142{
143 if(audio_codec.audio_freq != freq)
144 {
145 audio_codec.audio_freq = freq;
146 codec_i2s_reset();
147 audio_codec_modify_freq(freq);
148 codec_i2s_init(&audio_codec);
149 }
150}
151
152
158void audio_codec_spk_alt_setting(uint32_t alt_seting)
159{
160 if(alt_seting == 0)
161 {
162 }
163 else
164 {
165 }
166}
167
173void audio_codec_mic_alt_setting(uint32_t alt_seting)
174{
175 if(alt_seting == 0)
176 {
177 }
178 else
179 {
180 }
181}
182
188void audio_codec_set_mic_mute(uint8_t mute)
189{
190 audio_codec.mic_mute = mute;
191}
192
193
199void audio_codec_set_spk_mute(uint8_t mute)
200{
201 audio_codec.spk_mute = mute;
202}
203
204
210void audio_codec_set_mic_volume(uint16_t volume)
211{
212 /* wm8988 adc have 256 steps */
213 audio_codec.mic_volume = volume;
214}
215
221void audio_codec_set_spk_volume(uint16_t volume)
222{
223 /* wm8988 dac have 80 steps */
224 audio_codec.spk_volume = (volume * 0x50) / 0x64 + 0x30 - 1;
225}
226
232uint8_t audio_codec_spk_feedback(uint8_t *feedback)
233{
234 uint32_t feedback_value = (audio_codec.spk_freq);
235 feedback_value = ((feedback_value/1000)<<14)|((feedback_value%1000)<<4);
236 feedback[0] = (uint8_t)(feedback_value);
237 feedback[1] = (uint8_t)(feedback_value >> 8);
238 feedback[2] = (uint8_t)(feedback_value >> 16);
239 return 3;
240}
241
248void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
249{
250 uint16_t ulen = len / 2, i;
251 uint16_t *u16data = (uint16_t *)data;
252
253 switch(audio_codec.spk_stage)
254 {
255 case 0:
256 audio_codec.spk_woff = audio_codec.spk_roff = audio_codec.spk_buffer;
257 audio_codec.spk_wtotal = audio_codec.spk_rtotal = 0;
258 audio_codec.spk_stage = 1;
259 audio_codec.spk_threshold = SPK_BUFFER_SIZE/2;
260 break;
261 case 1:
262 if( audio_codec.spk_wtotal >= SPK_BUFFER_SIZE/2 )
263 {
264 audio_codec.spk_stage = 2;
265 }
266 break;
267 case 2:
268 break;
269 }
270 for( i = 0; i < ulen; ++i )
271 {
272 *audio_codec.spk_woff++ = *u16data++;
273 if( audio_codec.spk_woff >= audio_codec.spk_rend )
274 {
275 audio_codec.spk_woff = audio_codec.spk_buffer;
276 }
277 }
278 audio_codec.spk_wtotal += ulen;
279}
280
286uint32_t audio_codec_mic_get_data(uint8_t *buffer)
287{
288 //copy_buff((uint16_t *)buffer, audio_codec.mic_buffer + audio_codec.mic_hf_status, audio_codec.mic_rx_size);
289 uint16_t len = audio_codec.mic_rx_size << 1;
290 uint16_t i;
291 uint16_t* u16buf = (uint16_t*)buffer;
292 switch(audio_codec.mic_stage)
293 {
294 case 0:
295 audio_codec.mic_stage = 1;
296 memset( buffer, 0, len );
297 return len;
298 case 1:
299 if( audio_codec.mic_wtotal - audio_codec.mic_rtotal >= MIC_BUFFER_SIZE/2 )
300 {
301 audio_codec.mic_stage = 2;
302 }
303 return len;
304 }
305 switch( audio_codec.mic_adj_stage )
306 {
307 case 0:
308 break;
309 case 1:
310 if( audio_codec.mic_adj_count >= 4 ){
311 len += 4;
312 audio_codec.mic_adj_count -= 4;
313 }
314 break;
315 case 2:
316 if( audio_codec.mic_adj_count >= 4 ){
317 len -= 4;
318 audio_codec.mic_adj_count -= 4;
319 }
320 break;
321 }
322
323 for( i = 0; i < len/2; ++i )
324 {
325 *u16buf++ = *audio_codec.mic_roff++;
326 if( audio_codec.mic_roff >= audio_codec.mic_wend )
327 {
328 audio_codec.mic_roff = audio_codec.mic_buffer;
329 }
330 }
331 if( audio_codec.mic_wtotal <= audio_codec.mic_rtotal )
332 { //should not happen
333 while(1);
334 }
335
336 audio_codec.mic_rtotal += len/2;
337 audio_codec.mic_delta += len/2;
338 return len;
339}
340
346void audio_codec_modify_freq(uint32_t freq)
347{
348 uint16_t codec_cmd;
349 uint8_t i2c_cmd[2];
350 if(freq == AUDIO_FREQ_16K)
351 {
352 codec_cmd = WM8988_REG_FREQ16K;
353 }
354 else if(freq == AUDIO_FREQ_48K)
355 {
356 codec_cmd = WM8988_REG_FREQ48K;
357 }
358 i2c_cmd[0] = (uint8_t)(codec_cmd >> 8);
359 i2c_cmd[1] = (uint8_t)codec_cmd & 0xFF;
360 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
361 {
362 while(1);
363 }
364}
365
373void memset16_buffer(uint16_t *buffer, uint32_t set, uint32_t len)
374{
375 uint32_t i_index = 0;
376 for(i_index = 0; i_index < len; i_index ++)
377 {
378 buffer[i_index] = (uint16_t)set;
379 }
380}
381
389void copy_buff(uint16_t *dest, uint16_t *src, uint32_t len)
390{
391 uint16_t i_index;
392 for(i_index = 0; i_index < len; i_index ++)
393 {
394 dest[i_index] = src[i_index];
395 }
396}
397
403void i2c_lowlevel_init(i2c_handle_type* hi2c)
404{
405 gpio_init_type gpio_init_structure;
406
407 if(hi2c->i2cx == I2Cx_PORT)
408 {
409 /* i2c periph clock enable */
410 crm_periph_clock_enable(I2Cx_CLK, TRUE);
411 crm_periph_clock_enable(I2Cx_SCL_GPIO_CLK, TRUE);
412 crm_periph_clock_enable(I2Cx_SDA_GPIO_CLK, TRUE);
413
414 /* gpio configuration */
415 gpio_pin_mux_config(I2Cx_SCL_GPIO_PORT, I2Cx_SCL_GPIO_PinsSource, I2Cx_SCL_GPIO_MUX);
416
417 gpio_pin_mux_config(I2Cx_SDA_GPIO_PORT, I2Cx_SDA_GPIO_PinsSource, I2Cx_SDA_GPIO_MUX);
418
419 /* configure i2c pins: scl */
420 gpio_init_structure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
421 gpio_init_structure.gpio_mode = GPIO_MODE_MUX;
422 gpio_init_structure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
423 gpio_init_structure.gpio_pull = GPIO_PULL_UP;
424
425 gpio_init_structure.gpio_pins = I2Cx_SCL_GPIO_PIN;
426 gpio_init(I2Cx_SCL_GPIO_PORT, &gpio_init_structure);
427
428 /* configure i2c pins: sda */
429 gpio_init_structure.gpio_pins = I2Cx_SDA_GPIO_PIN;
430 gpio_init(I2Cx_SDA_GPIO_PORT, &gpio_init_structure);
431
432 /* config i2c */
433 i2c_init(hi2c->i2cx, 0x0F, I2Cx_CLKCTRL);
434
435 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
436 }
437}
438
444void mclk_tmr1_init(void)
445{
446 gpio_init_type gpio_init_struct;
447 tmr_output_config_type tmr_oc_init_structure;
448 uint16_t prescaler_value = (uint16_t)(system_core_clock / 24000000) - 1;
449
450 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
451 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
452
453 gpio_default_para_init(&gpio_init_struct);
454
455 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE8, GPIO_MUX_1);
456
457 gpio_init_struct.gpio_pins = GPIO_PINS_8;
458 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
459 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
460 gpio_init(GPIOA, &gpio_init_struct);
461
462 tmr_base_init(TMR1, 1, prescaler_value);
463 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
464 tmr_clock_source_div_set(TMR1, TMR_CLOCK_DIV1);
465
466 tmr_output_default_para_init(&tmr_oc_init_structure);
467 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
468 tmr_oc_init_structure.oc_idle_state = FALSE;
469 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
470 tmr_oc_init_structure.oc_output_state = TRUE;
471 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
472 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, 1);
473 tmr_output_channel_buffer_enable(TMR1, TMR_SELECT_CHANNEL_1, TRUE);
474
475 /* tmr enable counter */
476 tmr_counter_enable(TMR1, TRUE);
477 tmr_output_enable(TMR1, TRUE);
478}
479
480
486void codec_i2s_reset(void)
487{
488 i2s_enable(SPI1, FALSE);
489 i2s_enable(SPI2, FALSE);
490 dma_channel_enable(DMA1_CHANNEL3, FALSE);
491 dma_channel_enable(DMA1_CHANNEL4, FALSE);
492}
493
500void codec_i2s_init(audio_codec_type *param)
501{
502 gpio_init_type gpio_init_struct;
503 dma_init_type dma_init_struct;
504 i2s_init_type i2s_init_struct;
505 i2s_data_channel_format_type format = I2S_DATA_16BIT_CHANNEL_16BIT;
506
507 crm_periph_clock_enable(I2S1_GPIO_CRM_CLK, TRUE);
508 crm_periph_clock_enable(I2S2_GPIO_CRM_CLK, TRUE);
509 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
510 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
511 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
512
513 param->spk_freq = param->audio_freq;
514
515 param->spk_tx_size = (param->audio_freq / 1000) * (param->audio_bitw / 8) * AUDIO_SPK_CHANEL_NUM / 2;
516 param->mic_rx_size = (param->audio_freq / 1000) * (param->audio_bitw / 8) * AUDIO_MIC_CHANEL_NUM / 2;
517
518 memset(param->spk_buffer, 0, SPK_BUFFER_SIZE*sizeof(uint16_t));
519 memset(param->mic_buffer, 0, MIC_BUFFER_SIZE*sizeof(uint16_t));
520
521 param->mic_wend = param->mic_woff = param->mic_roff = param->mic_buffer;
522 param->spk_rend = param->spk_woff = param->spk_roff = param->spk_buffer;
523
524 while(param->mic_wend < param->mic_buffer+MIC_BUFFER_SIZE)
525 {
526 param->mic_wend += param->mic_rx_size;
527 }
528 param->mic_wend -= param->mic_rx_size;
529 while(param->spk_rend < param->spk_buffer+SPK_BUFFER_SIZE)
530 {
531 param->spk_rend += param->spk_tx_size;
532 }
533 param->spk_rend -= param->spk_tx_size;
534 if(param->audio_bitw == 16)
535 {
536 format = I2S_DATA_16BIT_CHANNEL_16BIT;
537 }
538 else
539 {
540 format = I2S_DATA_24BIT_CHANNEL_32BIT;
541 }
542
543 gpio_default_para_init(&gpio_init_struct);
544
545 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
546 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
547 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
548 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
549
550
551 /* i2s1 ws pins */
552 gpio_init_struct.gpio_pins = I2S1_WS_PIN;
553 gpio_init(I2S1_GPIO, &gpio_init_struct);
554 gpio_pin_mux_config(I2S1_GPIO, I2S1_WS_PIN_SOURCE, I2S1_WS_GPIO_MUX);
555
556 /* i2s1 ck pins */
557 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
558 gpio_init_struct.gpio_pins = I2S1_CK_PIN;
559 gpio_init(I2S1_GPIO, &gpio_init_struct);
560 gpio_pin_mux_config(I2S1_GPIO, I2S1_CK_PIN_SOURCE, I2S1_CK_GPIO_MUX);
561
562 /* i2s1 sd pins slave tx */
563 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
564 gpio_init_struct.gpio_pins = I2S1_SD_PIN;
565 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
566 gpio_init(I2S1_GPIO, &gpio_init_struct);
567 gpio_pin_mux_config(I2S1_GPIO, I2S1_SD_PIN_SOURCE, I2S1_SD_GPIO_MUX);
568
569 /* i2s2 ws pins */
570 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
571 gpio_init_struct.gpio_pins = I2S2_WS_PIN;
572 gpio_init(I2S2_GPIO, &gpio_init_struct);
573 gpio_pin_mux_config(I2S2_GPIO, I2S2_WS_PIN_SOURCE, I2S2_WS_GPIO_MUX);
574
575 /* i2s2 ck pins */
576 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
577 gpio_init_struct.gpio_pins = I2S2_CK_PIN;
578 gpio_init(I2S2_GPIO, &gpio_init_struct);
579 gpio_pin_mux_config(I2S2_GPIO, I2S2_CK_PIN_SOURCE, I2S2_CK_GPIO_MUX);
580
581 /* i2s2 sd pins slave rx */
582 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
583 gpio_init_struct.gpio_pins = I2S2_SD_PIN;
584 gpio_init(I2S2_GPIO, &gpio_init_struct);
585 gpio_pin_mux_config(I2S2_GPIO, I2S2_SD_PIN_SOURCE, I2S2_SD_GPIO_MUX);
586
587 /* dma config */
588 dma_reset(DMA1_CHANNEL3);
589 dma_reset(DMA1_CHANNEL4);
590
591 /* dma1 channel3: speaker i2s1 tx */
592 dma_default_para_init(&dma_init_struct);
593 dma_init_struct.buffer_size = param->spk_tx_size << 1;
594 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
595 dma_init_struct.memory_base_addr = (uint32_t)spk_dma_buffer;
596 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
597 dma_init_struct.memory_inc_enable = TRUE;
598 dma_init_struct.peripheral_base_addr = (uint32_t)I2S1_DT_ADDRESS;
599 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
600 dma_init_struct.peripheral_inc_enable = FALSE;
601 dma_init_struct.priority = DMA_PRIORITY_HIGH;
602 dma_init_struct.loop_mode_enable = TRUE;
603 dma_init(DMA1_CHANNEL3, &dma_init_struct);
604 dma_interrupt_enable(DMA1_CHANNEL3, DMA_FDT_INT, TRUE);
605 dma_interrupt_enable(DMA1_CHANNEL3, DMA_HDT_INT, TRUE);
606 nvic_irq_enable(DMA1_Channel3_IRQn, 1, 0);
607
608 /* dma1 channel4: microphone i2s2 rx */
609 dma_default_para_init(&dma_init_struct);
610 dma_init_struct.buffer_size = param->mic_rx_size << 1;
611 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
612 dma_init_struct.memory_base_addr = (uint32_t)mic_dma_buffer;
613 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
614 dma_init_struct.memory_inc_enable = TRUE;
615 dma_init_struct.peripheral_base_addr = (uint32_t)I2S2_DT_ADDRESS;
616 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
617 dma_init_struct.peripheral_inc_enable = FALSE;
618 dma_init_struct.priority = DMA_PRIORITY_HIGH;
619 dma_init_struct.loop_mode_enable = TRUE;
620 dma_init(DMA1_CHANNEL4, &dma_init_struct);
621 dma_interrupt_enable(DMA1_CHANNEL4, DMA_FDT_INT, TRUE);
622 dma_interrupt_enable(DMA1_CHANNEL4, DMA_HDT_INT, TRUE);
623 nvic_irq_enable(DMA1_Channel4_IRQn, 2, 0);
624
625 /* i2s1 tx init */
626 spi_i2s_reset(SPI1);
627 i2s_default_para_init(&i2s_init_struct);
628 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
629 i2s_init_struct.data_channel_format = format;
630 i2s_init_struct.mclk_output_enable = FALSE;
631 i2s_init_struct.audio_sampling_freq = (i2s_audio_sampling_freq_type)param->audio_freq;
632 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
633 i2s_init_struct.operation_mode = I2S_MODE_SLAVE_TX;
634 i2s_init(SPI1, &i2s_init_struct);
635
636 /* i2s2 rx init */
637 spi_i2s_reset(SPI2);
638 i2s_default_para_init(&i2s_init_struct);
639 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
640 i2s_init_struct.data_channel_format = format;
641 i2s_init_struct.mclk_output_enable = FALSE;
642 i2s_init_struct.audio_sampling_freq = (i2s_audio_sampling_freq_type)param->audio_freq;
643 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
644 i2s_init_struct.operation_mode = I2S_MODE_SLAVE_RX;
645 i2s_init(SPI2, &i2s_init_struct);
646
647
648 spi_i2s_dma_transmitter_enable(SPI1, TRUE);
649 spi_i2s_dma_receiver_enable(SPI2, TRUE);
650 i2s_enable(SPI1, TRUE);
651 i2s_enable(SPI2, TRUE);
652
653 dmamux_enable(DMA1, TRUE);
654 dmamux_init(DMA1MUX_CHANNEL3, DMAMUX_DMAREQ_ID_SPI1_TX);
655 dmamux_init(DMA1MUX_CHANNEL4, DMAMUX_DMAREQ_ID_SPI2_RX);
656 dma_channel_enable(DMA1_CHANNEL3, TRUE);
657 dma_channel_enable(DMA1_CHANNEL4, TRUE);
658
659}
660
666void DMA1_Channel3_IRQHandler(void)
667{
668 uint16_t half_size = audio_codec.spk_tx_size;
669 uint16_t *pdst;
670
671 if(dma_flag_get(DMA1_HDT3_FLAG) == SET)
672 {
673 //copy_buff(audio_codec.spk_buffer, audio_codec.spk_tx_fifo + audio_codec.r_pos, half_size);
674 pdst = spk_dma_buffer;
675 dma_flag_clear(DMA1_HDT3_FLAG);
676 }
677 else if(dma_flag_get(DMA1_FDT3_FLAG) == SET)
678 {
679 //copy_buff(&audio_codec.spk_buffer[half_size], audio_codec.spk_tx_fifo + audio_codec.r_pos, half_size);
680 pdst = spk_dma_buffer + half_size;
681 dma_flag_clear(DMA1_FDT3_FLAG);
682 }
683
684 switch( audio_codec.spk_stage )
685 {
686 case 0:
687 case 1:
688 memset( pdst, 0, half_size << 1);
689 break;
690 case 2:
691 if( audio_codec.spk_wtotal >= audio_codec.spk_rtotal + SPK_BUFFER_SIZE )
692 {
693 while(1);//should not happen;
694 }
695 if( audio_codec.spk_rtotal >= audio_codec.spk_wtotal )
696 {
697 audio_codec.spk_stage = 0;
698 audio_codec.spk_woff = audio_codec.spk_roff = audio_codec.spk_buffer;
699 audio_codec.spk_rtotal = audio_codec.spk_wtotal = 0;
700 }
701 else
702 {
703 memcpy( pdst, audio_codec.spk_roff, half_size << 1 );
704 audio_codec.spk_roff += half_size;
705 audio_codec.spk_rtotal += half_size;
706 if( audio_codec.spk_roff >= audio_codec.spk_rend )
707 {
708 audio_codec.spk_roff = audio_codec.spk_buffer;
709 }
710 if( ++audio_codec.spk_calc == 256 )
711 {
712 uint16_t delta = audio_codec.spk_wtotal - audio_codec.spk_rtotal;
713 audio_codec.spk_calc = 0;
714 if( delta < audio_codec.spk_threshold - half_size )
715 {
716 audio_codec.spk_threshold -= half_size;
717 audio_codec.spk_freq += audio_codec.audio_freq/1024;
718 }
719 else if( delta > audio_codec.spk_threshold + half_size )
720 {
721 audio_codec.spk_threshold += half_size;
722 audio_codec.spk_freq -= audio_codec.audio_freq/1024;
723 }
724 if(audio_codec.spk_rtotal > 0x20000000)
725 {
726 audio_codec.spk_rtotal -= 0x10000000;
727 audio_codec.spk_wtotal -= 0x10000000;
728 }
729 }
730 }
731 break;
732 }
733
734}
735
741void DMA1_Channel4_IRQHandler(void)
742{
743 uint16_t *psrc;
744 uint16_t len = audio_codec.mic_rx_size << 1;
745
746 if(dma_flag_get(DMA1_HDT4_FLAG) == SET)
747 {
748 dma_flag_clear(DMA1_HDT4_FLAG);
749 psrc = mic_dma_buffer;
750 }
751 else if(dma_flag_get(DMA1_FDT4_FLAG) == SET)
752 {
753 psrc = mic_dma_buffer + audio_codec.mic_rx_size;
754 dma_flag_clear(DMA1_FDT4_FLAG);
755 }
756 if( audio_codec.mic_stage )
757 {
758 memcpy( audio_codec.mic_woff, psrc, len );
759 audio_codec.mic_woff += len/2;
760 audio_codec.mic_wtotal += len/2;
761 if( audio_codec.mic_woff >= audio_codec.mic_wend )
762 {
763 audio_codec.mic_woff = audio_codec.mic_buffer;
764 }
765 if( audio_codec.mic_stage == 2 )
766 {
767 if( 1024 == ++audio_codec.mic_calc )
768 {
769 uint32_t size_estimate = 1024*audio_codec.mic_rx_size;
770 audio_codec.mic_calc = 0;
771 if( audio_codec.mic_delta > size_estimate )
772 {
773 audio_codec.mic_adj_count = audio_codec.mic_delta - size_estimate;
774 audio_codec.mic_adj_stage = 2;
775 }
776 else if( audio_codec.mic_delta < size_estimate )
777 {
778 audio_codec.mic_adj_count = size_estimate - audio_codec.mic_delta;
779 audio_codec.mic_adj_stage = 1;
780 }
781 else
782 {
783 audio_codec.mic_adj_count = 0;
784 audio_codec.mic_adj_stage = 0;
785 }
786 audio_codec.mic_delta = 0;
787 if( audio_codec.mic_rtotal >= 0x80000000 )
788 {
789 audio_codec.mic_rtotal -= 0x80000000;
790 audio_codec.mic_wtotal -= 0x80000000;
791 }
792 }
793 if( audio_codec.mic_wtotal >= audio_codec.mic_rtotal + MIC_BUFFER_SIZE )
794 {
795 audio_codec.mic_delta = audio_codec.mic_wtotal = audio_codec.mic_rtotal = 0;
796 audio_codec.mic_woff = audio_codec.mic_roff = audio_codec.mic_buffer;
797 audio_codec.mic_stage = 0;
798 audio_codec.mic_adj_stage = 0;
799 audio_codec.mic_adj_count = 0;
800 audio_codec.mic_calc = 0;
801 }
802 }
803 }
804}
805
811 error_status audio_codec_init(void)
812{
813 uint32_t reg_len = sizeof(reg_addr_data) / sizeof(uint16_t);
814 uint32_t i_index = 0;
815 uint8_t i2c_cmd[2];
816
817 if(AUDIO_DEFAULT_FREQ == AUDIO_FREQ_16K)
818 {
819 reg_addr_data[6] = WM8988_REG_FREQ16K;
820 audio_codec.audio_freq = AUDIO_FREQ_16K;
821 }
822 else if(AUDIO_DEFAULT_FREQ == AUDIO_FREQ_48K)
823 {
824 reg_addr_data[6] = WM8988_REG_FREQ48K;
825 audio_codec.audio_freq = AUDIO_FREQ_48K;
826 }
827 else
828 {
829 return ERROR;
830 }
831
832 if(AUDIO_DEFAULT_BITW == AUDIO_BITW_16)
833 {
834 reg_addr_data[5] = WM8988_REG_BITW16;
835 audio_codec.audio_bitw = AUDIO_BITW_16;
836 }
837 else
838 {
839 return ERROR;
840 }
841
842 /* i2c init */
843 hi2cx.i2cx = I2Cx_PORT;
844
845 i2c_config(&hi2cx);
846
847 for(i_index = 0; i_index < reg_len; i_index ++)
848 {
849 i2c_cmd[0] = (uint8_t)(reg_addr_data[i_index] >> 8);
850 i2c_cmd[1] = (uint8_t)reg_addr_data[i_index] & 0xFF;
851 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
852 {
853 return ERROR;
854 }
855 }
856
857 /* timer init */
858 mclk_tmr1_init();
859
860 codec_i2s_init(&audio_codec);
861
862 return SUCCESS;
863}
864
870 error_status audio_codec_loop(void)
871{
872 static uint8_t mic_mute = 0;
873 static uint16_t mic_volume = 0;
874 static uint8_t spk_mute = 0;
875 static uint16_t spk_volume = 0;
876 uint16_t audio_ctrl_l;
877 uint16_t audio_ctrl_r;
878 uint8_t i2c_cmd[2];
879
880 if(mic_mute != audio_codec.mic_mute)
881 {
882 mic_mute = audio_codec.mic_mute;
883 audio_ctrl_l = WM8988_R21_LEFT_ADC_VOLUME << 9 | 0x100;
884 audio_ctrl_r = WM8988_R22_RIGHT_ADC_VOLUME << 9 | 0x100;
885 if(audio_codec.mic_mute == 0)
886 {
887 audio_ctrl_l |= audio_codec.mic_volume;
888 audio_ctrl_r |= audio_codec.mic_volume;
889 }
890 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
891 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
892 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
893 {
894 return ERROR;
895 }
896 i2c_cmd[0] = (uint8_t)(audio_ctrl_r >> 8);
897 i2c_cmd[1] = (uint8_t)audio_ctrl_r & 0xFF;
898 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
899 {
900 return ERROR;
901 }
902 }
903
904 if(mic_volume != audio_codec.mic_volume)
905 {
906 mic_volume = audio_codec.mic_volume;
907 audio_ctrl_l = WM8988_R21_LEFT_ADC_VOLUME << 9 | 0x100;
908 audio_ctrl_r = WM8988_R22_RIGHT_ADC_VOLUME << 9 | 0x100;
909 audio_ctrl_l |= audio_codec.mic_volume;
910 audio_ctrl_r |= audio_codec.mic_volume;
911 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
912 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
913 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
914 {
915 return ERROR;
916 }
917 i2c_cmd[0] = (uint8_t)(audio_ctrl_r >> 8);
918 i2c_cmd[1] = (uint8_t)audio_ctrl_r & 0xFF;
919 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
920 {
921 return ERROR;
922 }
923 }
924
925 if(spk_mute != audio_codec.spk_mute)
926 {
927 spk_mute = audio_codec.spk_mute;
928 audio_ctrl_l = (WM8988_R5_ADC_DAC_CONTROL << 9) | 0x0006 | (audio_codec.spk_mute << 3);
929 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
930 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
931 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
932 {
933 return ERROR;
934 }
935 }
936
937 if(spk_volume != audio_codec.spk_volume)
938 {
939 spk_volume = audio_codec.spk_volume;
940 audio_ctrl_l = WM8988_R2_LOUT1_VOLUME << 9 | 0x100;
941 audio_ctrl_r = WM8988_R3_ROUT1_VOLUME << 9 | 0x100;
942 audio_ctrl_l |= audio_codec.spk_volume;
943 audio_ctrl_r |= audio_codec.spk_volume;
944
945 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
946 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
947
948 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
949 {
950 return ERROR;
951 }
952 i2c_cmd[0] = (uint8_t)(audio_ctrl_r >> 8);
953 i2c_cmd[1] = (uint8_t)audio_ctrl_r & 0xFF;
954 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
955 {
956 return ERROR;
957 }
958 }
959 return SUCCESS;
960}
961
buffer
uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:43
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/main.c:38
DMA1_Channel4_IRQHandler
void DMA1_Channel4_IRQHandler(void)
this function handles dma1 channel4 handler.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c:190
DMA1_Channel3_IRQHandler
void DMA1_Channel3_IRQHandler(void)
this function handles dma1 channel3 handler.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c:175
reg_addr_data
uint16_t reg_addr_data[]
wm8988 register default value
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:75
codec_i2s_reset
void codec_i2s_reset(void)
audio codec i2s reset
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:486
spk_dma_buffer
uint16_t spk_dma_buffer[DMA_BUFFER_SIZE]
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:111
WM8988_REG_FREQ48K
#define WM8988_REG_FREQ48K
wm8988 freq
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:64
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:44
I2Cx_SDA_GPIO_PIN
#define I2Cx_SDA_GPIO_PIN
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:56
I2Cx_SDA_GPIO_MUX
#define I2Cx_SDA_GPIO_MUX
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:59
I2Cx_CLKCTRL
#define I2Cx_CLKCTRL
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:43
I2Cx_CLK
#define I2Cx_CLK
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:47
WM8988_REG_BITW16
#define WM8988_REG_BITW16
wm8988 bit width
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:70
codec_i2s_init
void codec_i2s_init(audio_codec_type *param)
audio codec i2s init
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:500
I2Cx_SCL_GPIO_PinsSource
#define I2Cx_SCL_GPIO_PinsSource
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:51
mic_dma_buffer
uint16_t mic_dma_buffer[DMA_BUFFER_SIZE]
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:112
hi2cx
i2c_handle_type hi2cx
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:108
I2Cx_SCL_GPIO_MUX
#define I2Cx_SCL_GPIO_MUX
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:53
I2Cx_SDA_GPIO_PORT
#define I2Cx_SDA_GPIO_PORT
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:58
mclk_tmr1_init
void mclk_tmr1_init(void)
mclk clock conifg
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:444
I2Cx_SDA_GPIO_PinsSource
#define I2Cx_SDA_GPIO_PinsSource
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:57
I2Cx_SDA_GPIO_CLK
#define I2Cx_SDA_GPIO_CLK
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:55
audio_codec
audio_codec_type audio_codec
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:110
WM8988_REG_FREQ16K
#define WM8988_REG_FREQ16K
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:65
copy_buff
void copy_buff(uint16_t *dest, uint16_t *src, uint32_t len)
copy buffer
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:389
memset16_buffer
void memset16_buffer(uint16_t *buffer, uint32_t set, uint32_t len)
buffer memset
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:373
I2Cx_PORT
#define I2Cx_PORT
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:46
I2Cx_SCL_GPIO_PIN
#define I2Cx_SCL_GPIO_PIN
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:50
I2Cx_SCL_GPIO_CLK
#define I2Cx_SCL_GPIO_CLK
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:49
I2Cx_SCL_GPIO_PORT
#define I2Cx_SCL_GPIO_PORT
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:52
system_core_clock
unsigned int system_core_clock
Definition: system_at32f435_437.c:48
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:138
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:161
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:154
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_SPI2_RX
@ DMAMUX_DMAREQ_ID_SPI2_RX
Definition: at32f435_437_dma.h:206
DMAMUX_DMAREQ_ID_SPI1_TX
@ DMAMUX_DMAREQ_ID_SPI1_TX
Definition: at32f435_437_dma.h:205
DMA1_HDT4_FLAG
#define DMA1_HDT4_FLAG
Definition: at32f435_437_dma.h:79
DMA1_HDT3_FLAG
#define DMA1_HDT3_FLAG
Definition: at32f435_437_dma.h:75
DMA1_FDT4_FLAG
#define DMA1_FDT4_FLAG
Definition: at32f435_437_dma.h:78
DMA1_FDT3_FLAG
#define DMA1_FDT3_FLAG
Definition: at32f435_437_dma.h:74
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA_HDT_INT
#define DMA_HDT_INT
Definition: at32f435_437_dma.h:53
DMA1MUX_CHANNEL3
#define DMA1MUX_CHANNEL3
Definition: at32f435_437_dma.h:706
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f435_437_dma.h:698
DMA1MUX_CHANNEL4
#define DMA1MUX_CHANNEL4
Definition: at32f435_437_dma.h:707
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f435_437_dma.h:699
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_MODERATE
@ GPIO_DRIVE_STRENGTH_MODERATE
Definition: at32f435_437_gpio.h:94
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f435_437_gpio.h:103
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_1
@ GPIO_MUX_1
Definition: at32f435_437_gpio.h:157
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
i2c_init
void i2c_init(i2c_type *i2c_x, uint8_t dfilters, uint32_t clk)
init i2c digit filters and clock control register.
Definition: at32f435_437_i2c.c:79
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config i2c own address 1.
Definition: at32f435_437_i2c.c:103
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f435_437_i2c.h:113
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:113
i2c_lowlevel_init
__WEAK void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: i2c_application.c:103
i2c_master_transmit
i2c_status_type i2c_master_transmit(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode.
Definition: i2c_application.c:375
I2C_OK
@ I2C_OK
Definition: i2c_application.h:81
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f435_437_spi.c:350
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f435_437_spi.c:533
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f435_437_spi.c:479
spi_i2s_reset
void spi_i2s_reset(spi_type *spi_x)
spi reset by crm reset register
Definition: at32f435_437_spi.c:51
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f435_437_spi.c:332
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f435_437_spi.c:519
i2s_data_channel_format_type
i2s_data_channel_format_type
i2s data bit num and channel bit num type
Definition: at32f435_437_spi.h:228
i2s_audio_sampling_freq_type
i2s_audio_sampling_freq_type
i2s audio frequency type
Definition: at32f435_437_spi.h:211
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f435_437_spi.h:251
I2S_DATA_16BIT_CHANNEL_16BIT
@ I2S_DATA_16BIT_CHANNEL_16BIT
Definition: at32f435_437_spi.h:229
I2S_DATA_24BIT_CHANNEL_32BIT
@ I2S_DATA_24BIT_CHANNEL_32BIT
Definition: at32f435_437_spi.h:231
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f435_437_spi.h:200
I2S_MODE_SLAVE_RX
@ I2S_MODE_SLAVE_RX
Definition: at32f435_437_spi.h:241
I2S_MODE_SLAVE_TX
@ I2S_MODE_SLAVE_TX
Definition: at32f435_437_spi.h:240
SPI1
#define SPI1
Definition: at32f435_437_spi.h:453
SPI2
#define SPI2
Definition: at32f435_437_spi.h:454
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f435_437_tmr.c:1499
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_output_channel_buffer_enable
void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel buffer
Definition: at32f435_437_tmr.c:660
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f435_437_tmr.h:97
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f435_437_tmr.h:180
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:198
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
audio_codec_mic_alt_setting
void audio_codec_mic_alt_setting(uint32_t alt_seting)
audio codec microphone alt setting config
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:173
audio_codec_set_spk_volume
void audio_codec_set_spk_volume(uint16_t volume)
audio codec set speaker volume
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:221
audio_codec_set_spk_mute
void audio_codec_set_spk_mute(uint8_t mute)
audio codec set speaker mute
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:199
MIC_BUFFER_SIZE
#define MIC_BUFFER_SIZE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:145
audio_codec_set_mic_freq
void audio_codec_set_mic_freq(uint32_t freq)
audio codec set microphone freq
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:125
audio_codec_mic_get_data
uint32_t audio_codec_mic_get_data(uint8_t *buffer)
codec microphone get data
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:286
audio_codec_loop
error_status audio_codec_loop(void)
audio codec loop
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:870
SPK_BUFFER_SIZE
#define SPK_BUFFER_SIZE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:146
audio_codec_set_mic_mute
void audio_codec_set_mic_mute(uint8_t mute)
audio codec set microphone mute
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:188
audio_codec_spk_fifo_write
void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
audio codec interface
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:248
audio_codec_spk_feedback
uint8_t audio_codec_spk_feedback(uint8_t *feedback)
codec speaker feedback
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:232
audio_codec_modify_freq
void audio_codec_modify_freq(uint32_t freq)
audio codec modify freq
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:346
audio_codec_set_mic_volume
void audio_codec_set_mic_volume(uint16_t volume)
audio codec set microphone volume
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:210
audio_codec_spk_alt_setting
void audio_codec_spk_alt_setting(uint32_t alt_seting)
audio codec speaker alt setting config
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:158
DMA_BUFFER_SIZE
#define DMA_BUFFER_SIZE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:147
audio_codec_init
error_status audio_codec_init(void)
audio codec init
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:811
audio_codec_set_spk_freq
void audio_codec_set_spk_freq(uint32_t freq)
audio codec set speaker freq
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:141
I2S1_SD_PIN_SOURCE
#define I2S1_SD_PIN_SOURCE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:112
I2S1_WS_PIN_SOURCE
#define I2S1_WS_PIN_SOURCE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:104
I2S2_DT_ADDRESS
#define I2S2_DT_ADDRESS
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:134
I2S1_SD_PIN
#define I2S1_SD_PIN
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:111
I2S1_CK_PIN_SOURCE
#define I2S1_CK_PIN_SOURCE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:108
I2S1_CK_PIN
#define I2S1_CK_PIN
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:107
I2S2_GPIO
#define I2S2_GPIO
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:132
I2S2_WS_GPIO_MUX
#define I2S2_WS_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:122
I2S2_SD_PIN
#define I2S2_SD_PIN
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:128
I2S2_SD_GPIO_MUX
#define I2S2_SD_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:130
I2S1_CK_GPIO_MUX
#define I2S1_CK_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:109
I2S2_CK_PIN_SOURCE
#define I2S2_CK_PIN_SOURCE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:125
I2S2_WS_PIN
#define I2S2_WS_PIN
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:120
I2S2_GPIO_CRM_CLK
#define I2S2_GPIO_CRM_CLK
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:133
I2S2_CK_GPIO_MUX
#define I2S2_CK_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:126
I2S1_SD_GPIO_MUX
#define I2S1_SD_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:113
I2S2_SD_PIN_SOURCE
#define I2S2_SD_PIN_SOURCE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:129
I2S1_DT_ADDRESS
#define I2S1_DT_ADDRESS
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:117
I2S1_GPIO_CRM_CLK
#define I2S1_GPIO_CRM_CLK
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:116
I2S1_WS_GPIO_MUX
#define I2S1_WS_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:105
I2S1_WS_PIN
#define I2S1_WS_PIN
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:103
I2S2_WS_PIN_SOURCE
#define I2S2_WS_PIN_SOURCE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:121
I2S1_GPIO
#define I2S1_GPIO
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:115
I2S2_CK_PIN
#define I2S2_CK_PIN
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:124
WM8988_R27_ADDITIONAL_3_CONTROL
#define WM8988_R27_ADDITIONAL_3_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:77
WM8988_I2C_ADDR_CSB_LOW
#define WM8988_I2C_ADDR_CSB_LOW
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:93
WM8988_R10_LEFT_DAC_VOLUME
#define WM8988_R10_LEFT_DAC_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:60
WM8988_R1_RIGHT_INPUT_VOLUME
#define WM8988_R1_RIGHT_INPUT_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:51
WM8988_R3_ROUT1_VOLUME
#define WM8988_R3_ROUT1_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:53
WM8988_R36_RIGHT_OUT_MIX_1
#define WM8988_R36_RIGHT_OUT_MIX_1
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:84
WM8988_R21_LEFT_ADC_VOLUME
#define WM8988_R21_LEFT_ADC_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:71
WM8988_R31_ADC_INPUT_MODE
#define WM8988_R31_ADC_INPUT_MODE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:79
WM8988_R13_TREBLE_CONTROL
#define WM8988_R13_TREBLE_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:63
WM8988_R16_3D_CONTROL
#define WM8988_R16_3D_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:66
WM8988_R22_RIGHT_ADC_VOLUME
#define WM8988_R22_RIGHT_ADC_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:72
WM8988_R0_LEFT_INPUT_VOLUME
#define WM8988_R0_LEFT_INPUT_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:50
WM8988_R23_ADDITIONAL_1_CONTROL
#define WM8988_R23_ADDITIONAL_1_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:73
WM8988_R35_LEFT_OUT_MIX_2
#define WM8988_R35_LEFT_OUT_MIX_2
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:83
WM8988_R43_LOW_POWER_PALYBACK
#define WM8988_R43_LOW_POWER_PALYBACK
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:91
WM8988_R32_ADC_L_SIGNAL_PATH
#define WM8988_R32_ADC_L_SIGNAL_PATH
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:80
WM8988_R26_PWR_2_MGMT
#define WM8988_R26_PWR_2_MGMT
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:76
WM8988_R11_RIGHT_DAC_VOLUME
#define WM8988_R11_RIGHT_DAC_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:61
WM8988_R24_ADDITIONAL_2_CONTROL
#define WM8988_R24_ADDITIONAL_2_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:74
WM8988_R40_LOUT2_VOLUME
#define WM8988_R40_LOUT2_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:88
WM8988_R34_LEFT_OUT_MIX_1
#define WM8988_R34_LEFT_OUT_MIX_1
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:82
WM8988_R5_ADC_DAC_CONTROL
#define WM8988_R5_ADC_DAC_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:55
WM8988_R25_PWR_1_MGMT
#define WM8988_R25_PWR_1_MGMT
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:75
WM8988_R41_ROUT2_VOLUME
#define WM8988_R41_ROUT2_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:89
WM8988_R2_LOUT1_VOLUME
#define WM8988_R2_LOUT1_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:52
WM8988_R37_RIGHT_OUT_MIX_2
#define WM8988_R37_RIGHT_OUT_MIX_2
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:85
WM8988_R33_ADC_R_SIGNAL_PATH
#define WM8988_R33_ADC_R_SIGNAL_PATH
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:81
WM8988_R12_BASS_CONTROL
#define WM8988_R12_BASS_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:62
AUDIO_BITW_16
#define AUDIO_BITW_16
Definition: audio/audio_conf.h:61
AUDIO_MIC_CHANEL_NUM
#define AUDIO_MIC_CHANEL_NUM
Definition: audio/audio_conf.h:63
AUDIO_DEFAULT_FREQ
#define AUDIO_DEFAULT_FREQ
Definition: audio/audio_conf.h:71
AUDIO_FREQ_16K
#define AUDIO_FREQ_16K
Definition: audio/audio_conf.h:59
AUDIO_SPK_CHANEL_NUM
#define AUDIO_SPK_CHANEL_NUM
Definition: audio/audio_conf.h:66
AUDIO_DEFAULT_BITW
#define AUDIO_DEFAULT_BITW
Definition: audio/audio_conf.h:72
AUDIO_FREQ_48K
#define AUDIO_FREQ_48K
Definition: audio/audio_conf.h:60
DMA1_Channel3_IRQn
@ DMA1_Channel3_IRQn
Definition: at32f435_437.h:206
DMA1_Channel4_IRQn
@ DMA1_Channel4_IRQn
Definition: at32f435_437.h:207
i2c_application.h
i2c application libray header file
audio_codec_type
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:150
audio_codec_type::spk_mute
uint8_t spk_mute
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:179
audio_codec_type::spk_threshold
uint16_t spk_threshold
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:161
audio_codec_type::spk_stage
uint8_t spk_stage
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:163
audio_codec_type::mic_roff
uint16_t * mic_roff
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:167
audio_codec_type::spk_buffer
uint16_t spk_buffer[4096]
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:154
audio_codec_type::mic_volume
uint16_t mic_volume
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:181
audio_codec_type::spk_roff
uint16_t * spk_roff
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:155
audio_codec_type::spk_rtotal
uint32_t spk_rtotal
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:160
audio_codec_type::mic_delta
uint32_t mic_delta
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:172
audio_codec_type::spk_calc
uint16_t spk_calc
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:162
audio_codec_type::mic_woff
uint16_t * mic_woff
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:168
audio_codec_type::mic_stage
uint8_t mic_stage
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:176
audio_codec_type::mic_adj_count
uint16_t mic_adj_count
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:174
audio_codec_type::spk_freq
uint32_t spk_freq
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:158
audio_codec_type::audio_bitw
uint32_t audio_bitw
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:152
audio_codec_type::mic_wend
uint16_t * mic_wend
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:169
audio_codec_type::spk_rend
uint16_t * spk_rend
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:157
audio_codec_type::mic_wtotal
uint32_t mic_wtotal
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:170
audio_codec_type::mic_rtotal
uint32_t mic_rtotal
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:171
audio_codec_type::audio_freq
uint32_t audio_freq
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:151
audio_codec_type::mic_mute
uint8_t mic_mute
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:178
audio_codec_type::spk_volume
uint16_t spk_volume
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:182
audio_codec_type::mic_calc
uint16_t mic_calc
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:173
audio_codec_type::spk_wtotal
uint32_t spk_wtotal
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:159
audio_codec_type::mic_adj_stage
uint8_t mic_adj_stage
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:175
audio_codec_type::spk_tx_size
uint32_t spk_tx_size
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:184
audio_codec_type::mic_rx_size
uint32_t mic_rx_size
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:185
audio_codec_type::spk_woff
uint16_t * spk_woff
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:156
audio_codec_type::mic_buffer
uint16_t mic_buffer[1024]
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:166
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
i2c_handle_type
Definition: i2c_application.h:112
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:113
i2s_init_type
i2s init type
Definition: at32f435_437_spi.h:274
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f435_437_spi.h:277
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f435_437_spi.h:278
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f435_437_spi.h:280
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f435_437_spi.h:276
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f435_437_spi.h:275
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:279
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415


AT32F435/437 Firmwary Library: audio_codec.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • composite_audio_hid
  • inc
Data Structures | Macros | Functions
at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h File Reference

audio codec header file More...

#include "usb_conf.h"

Go to the source code of this file.

Data Structures

struct audio_codec_type

Macros

#define | WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/
#define | WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/
#define | WM8988_R2_LOUT1_VOLUME 0x02
#define | WM8988_R3_ROUT1_VOLUME 0x03
#define | WM8988_R4_RESERVED 0x04
#define | WM8988_R5_ADC_DAC_CONTROL 0x05
#define | WM8988_R6_RESERVED 0x06
#define | WM8988_R7_AUDIO_INTERFACE 0x07
#define | WM8988_R8_SAMPLE_RATE 0x08
#define | WM8988_R9_RESERVED 0x09
#define | WM8988_R10_LEFT_DAC_VOLUME 0x0A
#define | WM8988_R11_RIGHT_DAC_VOLUME 0x0B
#define | WM8988_R12_BASS_CONTROL 0x0C
#define | WM8988_R13_TREBLE_CONTROL 0x0D
#define | WM8988_R14_
#define | WM8988_R15_RESET 0x0F
#define | WM8988_R16_3D_CONTROL 0x10
#define | WM8988_R17_ALC1 0x11
#define | WM8988_R18_ALC2 0x12
#define | WM8988_R19_ALC3 0x13
#define | WM8988_R20_NOISE_GATE 0x14
#define | WM8988_R21_LEFT_ADC_VOLUME 0x15
#define | WM8988_R22_RIGHT_ADC_VOLUME 0x16
#define | WM8988_R23_ADDITIONAL_1_CONTROL 0x17
#define | WM8988_R24_ADDITIONAL_2_CONTROL 0x18
#define | WM8988_R25_PWR_1_MGMT 0x19
#define | WM8988_R26_PWR_2_MGMT 0x1A
#define | WM8988_R27_ADDITIONAL_3_CONTROL 0x1B
#define | WM8988_R31_ADC_INPUT_MODE 0x1F
#define | WM8988_R32_ADC_L_SIGNAL_PATH 0x20
#define | WM8988_R33_ADC_R_SIGNAL_PATH 0x21
#define | WM8988_R34_LEFT_OUT_MIX_1 0x22
#define | WM8988_R35_LEFT_OUT_MIX_2 0x23
#define | WM8988_R36_RIGHT_OUT_MIX_1 0x24
#define | WM8988_R37_RIGHT_OUT_MIX_2 0x25
#define | WM8988_R38_RESERVED
#define | WM8988_R39_RESERVED
#define | WM8988_R40_LOUT2_VOLUME 0x28
#define | WM8988_R41_ROUT2_VOLUME 0x29
#define | WM8988_R42_RESERVED
#define | WM8988_R43_LOW_POWER_PALYBACK 0x43
#define | WM8988_I2C_ADDR_CSB_LOW 0x34
#define | WM8988_I2C_ADDR_CSB_HIGH 0x36
#define | I2S1_WS_PIN GPIO_PINS_4
#define | I2S1_WS_PIN_SOURCE GPIO_PINS_SOURCE4
#define | I2S1_WS_GPIO_MUX GPIO_MUX_5
#define | I2S1_CK_PIN GPIO_PINS_5
#define | I2S1_CK_PIN_SOURCE GPIO_PINS_SOURCE5
#define | I2S1_CK_GPIO_MUX GPIO_MUX_5
#define | I2S1_SD_PIN GPIO_PINS_7
#define | I2S1_SD_PIN_SOURCE GPIO_PINS_SOURCE7
#define | I2S1_SD_GPIO_MUX GPIO_MUX_5
#define | I2S1_GPIO GPIOA
#define | I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
#define | I2S1_DT_ADDRESS (&(SPI1->dt))
#define | I2S2_WS_PIN GPIO_PINS_0
#define | I2S2_WS_PIN_SOURCE GPIO_PINS_SOURCE0
#define | I2S2_WS_GPIO_MUX GPIO_MUX_7
#define | I2S2_CK_PIN GPIO_PINS_1
#define | I2S2_CK_PIN_SOURCE GPIO_PINS_SOURCE1
#define | I2S2_CK_GPIO_MUX GPIO_MUX_6
#define | I2S2_SD_PIN GPIO_PINS_4
#define | I2S2_SD_PIN_SOURCE GPIO_PINS_SOURCE4
#define | I2S2_SD_GPIO_MUX GPIO_MUX_6
#define | I2S2_GPIO GPIOD
#define | I2S2_GPIO_CRM_CLK CRM_GPIOD_PERIPH_CLOCK
#define | I2S2_DT_ADDRESS (&(SPI2->dt))
#define | SPK_TX_FIFO_SIZE (1024 * 4)
#define | MIC_BUFFER_SIZE 1024
#define | SPK_BUFFER_SIZE 4096
#define | DMA_BUFFER_SIZE 288

Functions

error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
audio codec interface More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...

Detailed Description

audio codec header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h.


AT32F435/437 Firmwary Library: audio_codec.h Source File

  • at_start_f437
  • examples
  • usb_device
  • composite_audio_hid
  • inc
at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AUDIO_CODEC_H
29#define __AUDIO_CODEC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
44/* includes ------------------------------------------------------------------*/
45#include "usb_conf.h"
46
50#define WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/
51#define WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/
52#define WM8988_R2_LOUT1_VOLUME 0x02
53#define WM8988_R3_ROUT1_VOLUME 0x03
54#define WM8988_R4_RESERVED 0x04
55#define WM8988_R5_ADC_DAC_CONTROL 0x05
56#define WM8988_R6_RESERVED 0x06
57#define WM8988_R7_AUDIO_INTERFACE 0x07
58#define WM8988_R8_SAMPLE_RATE 0x08
59#define WM8988_R9_RESERVED 0x09
60#define WM8988_R10_LEFT_DAC_VOLUME 0x0A
61#define WM8988_R11_RIGHT_DAC_VOLUME 0x0B
62#define WM8988_R12_BASS_CONTROL 0x0C
63#define WM8988_R13_TREBLE_CONTROL 0x0D
64#define WM8988_R14_
65#define WM8988_R15_RESET 0x0F
66#define WM8988_R16_3D_CONTROL 0x10
67#define WM8988_R17_ALC1 0x11
68#define WM8988_R18_ALC2 0x12
69#define WM8988_R19_ALC3 0x13
70#define WM8988_R20_NOISE_GATE 0x14
71#define WM8988_R21_LEFT_ADC_VOLUME 0x15
72#define WM8988_R22_RIGHT_ADC_VOLUME 0x16
73#define WM8988_R23_ADDITIONAL_1_CONTROL 0x17
74#define WM8988_R24_ADDITIONAL_2_CONTROL 0x18
75#define WM8988_R25_PWR_1_MGMT 0x19
76#define WM8988_R26_PWR_2_MGMT 0x1A
77#define WM8988_R27_ADDITIONAL_3_CONTROL 0x1B
78
79#define WM8988_R31_ADC_INPUT_MODE 0x1F
80#define WM8988_R32_ADC_L_SIGNAL_PATH 0x20
81#define WM8988_R33_ADC_R_SIGNAL_PATH 0x21
82#define WM8988_R34_LEFT_OUT_MIX_1 0x22
83#define WM8988_R35_LEFT_OUT_MIX_2 0x23
84#define WM8988_R36_RIGHT_OUT_MIX_1 0x24
85#define WM8988_R37_RIGHT_OUT_MIX_2 0x25
86#define WM8988_R38_RESERVED
87#define WM8988_R39_RESERVED
88#define WM8988_R40_LOUT2_VOLUME 0x28
89#define WM8988_R41_ROUT2_VOLUME 0x29
90#define WM8988_R42_RESERVED
91#define WM8988_R43_LOW_POWER_PALYBACK 0x43
92
93#define WM8988_I2C_ADDR_CSB_LOW 0x34
94#define WM8988_I2C_ADDR_CSB_HIGH 0x36
95
103#define I2S1_WS_PIN GPIO_PINS_4
104#define I2S1_WS_PIN_SOURCE GPIO_PINS_SOURCE4
105#define I2S1_WS_GPIO_MUX GPIO_MUX_5
106
107#define I2S1_CK_PIN GPIO_PINS_5
108#define I2S1_CK_PIN_SOURCE GPIO_PINS_SOURCE5
109#define I2S1_CK_GPIO_MUX GPIO_MUX_5
110
111#define I2S1_SD_PIN GPIO_PINS_7
112#define I2S1_SD_PIN_SOURCE GPIO_PINS_SOURCE7
113#define I2S1_SD_GPIO_MUX GPIO_MUX_5
114
115#define I2S1_GPIO GPIOA
116#define I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
117#define I2S1_DT_ADDRESS (&(SPI1->dt))
118
119/*I2S2 Pin*/
120#define I2S2_WS_PIN GPIO_PINS_0
121#define I2S2_WS_PIN_SOURCE GPIO_PINS_SOURCE0
122#define I2S2_WS_GPIO_MUX GPIO_MUX_7
123
124#define I2S2_CK_PIN GPIO_PINS_1
125#define I2S2_CK_PIN_SOURCE GPIO_PINS_SOURCE1
126#define I2S2_CK_GPIO_MUX GPIO_MUX_6
127
128#define I2S2_SD_PIN GPIO_PINS_4
129#define I2S2_SD_PIN_SOURCE GPIO_PINS_SOURCE4
130#define I2S2_SD_GPIO_MUX GPIO_MUX_6
131
132#define I2S2_GPIO GPIOD
133#define I2S2_GPIO_CRM_CLK CRM_GPIOD_PERIPH_CLOCK
134#define I2S2_DT_ADDRESS (&(SPI2->dt))
135
136#define SPK_TX_FIFO_SIZE (1024 * 4)
137
145#define MIC_BUFFER_SIZE 1024
146#define SPK_BUFFER_SIZE 4096
147#define DMA_BUFFER_SIZE 288
148
149typedef struct
150{
151 uint32_t audio_freq;
152 uint32_t audio_bitw;
153 //spk part
154 uint16_t spk_buffer[SPK_BUFFER_SIZE];
155 uint16_t *spk_roff;
156 uint16_t *spk_woff;
157 uint16_t *spk_rend;
158 uint32_t spk_freq;
159 uint32_t spk_wtotal;
160 uint32_t spk_rtotal;
161 uint16_t spk_threshold;
162 uint16_t spk_calc;
163 uint8_t spk_stage;
164
165 //mic part
166 uint16_t mic_buffer[MIC_BUFFER_SIZE];
167 uint16_t *mic_roff;
168 uint16_t *mic_woff;
169 uint16_t *mic_wend;
170 uint32_t mic_wtotal;
171 uint32_t mic_rtotal;
172 uint32_t mic_delta;
173 uint16_t mic_calc;
174 uint16_t mic_adj_count;
175 uint8_t mic_adj_stage;
176 uint8_t mic_stage;
177
178 uint8_t mic_mute;
179 uint8_t spk_mute;
180
181 uint16_t mic_volume;
182 uint16_t spk_volume;
183
184 uint32_t spk_tx_size;
185 uint32_t mic_rx_size;
186
187 uint32_t spk_enable;
188 uint32_t mic_enable;
189
190}audio_codec_type;
191
192 error_status audio_codec_init(void);
193 error_status audio_codec_loop(void);
194void audio_codec_modify_freq(uint32_t freq);
195
199void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len);
200uint32_t audio_codec_mic_get_data(uint8_t *buffer);
201uint8_t audio_codec_spk_feedback(uint8_t *feedback);
202void audio_codec_spk_alt_setting(uint32_t alt_seting);
203void audio_codec_mic_alt_setting(uint32_t alt_seting);
204void audio_codec_set_mic_mute(uint8_t mute);
205void audio_codec_set_spk_mute(uint8_t mute);
206void audio_codec_set_mic_volume(uint16_t volume);
207void audio_codec_set_spk_volume(uint16_t volume);
208void audio_codec_set_mic_freq(uint32_t freq);
209void audio_codec_set_spk_freq(uint32_t freq);
210
222#ifdef __cplusplus
223}
224#endif
225
226#endif
227
buffer
uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:43
error_status
error_status
Definition: at32f435_437.h:380
audio_codec_mic_alt_setting
void audio_codec_mic_alt_setting(uint32_t alt_seting)
audio codec microphone alt setting config
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:173
audio_codec_set_spk_volume
void audio_codec_set_spk_volume(uint16_t volume)
audio codec set speaker volume
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:221
audio_codec_set_spk_mute
void audio_codec_set_spk_mute(uint8_t mute)
audio codec set speaker mute
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:199
audio_codec_set_mic_freq
void audio_codec_set_mic_freq(uint32_t freq)
audio codec set microphone freq
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:125
audio_codec_mic_get_data
uint32_t audio_codec_mic_get_data(uint8_t *buffer)
codec microphone get data
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:286
audio_codec_loop
error_status audio_codec_loop(void)
audio codec loop
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:870
audio_codec_set_mic_mute
void audio_codec_set_mic_mute(uint8_t mute)
audio codec set microphone mute
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:188
audio_codec_spk_fifo_write
void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
audio codec interface
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:248
audio_codec_spk_feedback
uint8_t audio_codec_spk_feedback(uint8_t *feedback)
codec speaker feedback
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:232
audio_codec_modify_freq
void audio_codec_modify_freq(uint32_t freq)
audio codec modify freq
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:346
audio_codec_set_mic_volume
void audio_codec_set_mic_volume(uint16_t volume)
audio codec set microphone volume
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:210
audio_codec_spk_alt_setting
void audio_codec_spk_alt_setting(uint32_t alt_seting)
audio codec speaker alt setting config
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:158
audio_codec_init
error_status audio_codec_init(void)
audio codec init
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:811
audio_codec_set_spk_freq
void audio_codec_set_spk_freq(uint32_t freq)
audio codec set speaker freq
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:141
MIC_BUFFER_SIZE
#define MIC_BUFFER_SIZE
Definition: at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h:145
SPK_BUFFER_SIZE
#define SPK_BUFFER_SIZE
Definition: at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h:146
audio_codec_type
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:150
usb_conf.h
usb config header file


AT32F435/437 Firmwary Library: audio_codec.c File Reference

  • at_start_f437
  • examples
  • usb_device
  • composite_audio_hid
  • src
Macros | Functions | Variables
at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c File Reference

audio codec function More...

#include "audio_codec.h"
#include "i2c_application.h"
#include "audio_conf.h"
#include <string.h>

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_CLKCTRL 0x80504C4E
#define | I2Cx_ADDRESS 0x00
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_8
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE8
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_MUX GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_9
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE9
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_MUX GPIO_MUX_4
#define | WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)
wm8988 freq More...
#define | WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)
#define | WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)
wm8988 bit width More...

Functions

void | memset16_buffer (uint16_t *buffer, uint32_t set, uint32_t len)
buffer memset More...
void | codec_i2s_reset (void)
audio codec i2s reset More...
void | codec_i2s_init (audio_codec_type *param)
audio codec i2s init More...
void | mclk_tmr1_init (void)
mclk clock conifg More...
void | copy_buff (uint16_t *dest, uint16_t *src, uint32_t len)
copy buffer More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
codec speaker write fifo More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | DMA1_Channel3_IRQHandler (void)
this function handles dma1 channel3 interrupt. More...
void | DMA1_Channel4_IRQHandler (void)
this function handles dma1 channel4 interrupt. More...
error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...

Variables

uint16_t | reg_addr_data []
wm8988 register default value More...
i2c_handle_type hi2cx
audio_codec_type audio_codec
uint16_t | spk_dma_buffer [DMA_BUFFER_SIZE]
uint16_t | mic_dma_buffer [DMA_BUFFER_SIZE]

Detailed Description

audio codec function

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c.


AT32F435/437 Firmwary Library: audio_codec.c Source File

  • at_start_f437
  • examples
  • usb_device
  • composite_audio_hid
  • src
at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "audio_codec.h"
29#include "i2c_application.h"
30#include "audio_conf.h"
31#include <string.h>
32
41#define I2C_TIMEOUT 0xFFFFFFFF
42
43#define I2Cx_CLKCTRL 0x80504C4E
44#define I2Cx_ADDRESS 0x00
45
46#define I2Cx_PORT I2C1
47#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
48
49#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
50#define I2Cx_SCL_GPIO_PIN GPIO_PINS_8
51#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE8
52#define I2Cx_SCL_GPIO_PORT GPIOB
53#define I2Cx_SCL_GPIO_MUX GPIO_MUX_4
54
55#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
56#define I2Cx_SDA_GPIO_PIN GPIO_PINS_9
57#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE9
58#define I2Cx_SDA_GPIO_PORT GPIOB
59#define I2Cx_SDA_GPIO_MUX GPIO_MUX_4
60
64#define WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)
65#define WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)
66
70#define WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)
71
75uint16_t reg_addr_data[] =
76{
77 (WM8988_R0_LEFT_INPUT_VOLUME << 9) | 0x012F, /*Left Input Channel Volume*/
78 (WM8988_R1_RIGHT_INPUT_VOLUME << 9) | 0x012F, /*Right Input Channel Volume*/
79 (WM8988_R2_LOUT1_VOLUME << 9) | 0x0179, /*Left Output Channel Volume*/
80 (WM8988_R3_ROUT1_VOLUME << 9) | 0x0179, /*Right Output Channel Volume*/
81 (WM8988_R5_ADC_DAC_CONTROL << 9) | 0x0006, /*De-emphasis Control and Digital soft mute*/
82 (WM8988_REG_BITW16),
83 (WM8988_REG_FREQ16K),
84 (WM8988_R10_LEFT_DAC_VOLUME << 9) | 0x01FF, /*Left Digital DAC Volume Control*/
85 (WM8988_R11_RIGHT_DAC_VOLUME << 9) | 0x01FF, /*Right Digital DAC Volume Control*/
86 (WM8988_R12_BASS_CONTROL << 9) | 0x000F, /*Bass Control*/
87 (WM8988_R13_TREBLE_CONTROL << 9) | 0x000F, /*Treble Control*/
88 (WM8988_R16_3D_CONTROL << 9) | 0x0000, /*3D stereo Enhancment*/
89 (WM8988_R21_LEFT_ADC_VOLUME << 9) | 0x01C3, /*Left ADC Digital Volume*/
90 (WM8988_R22_RIGHT_ADC_VOLUME << 9) | 0x01C3, /*Right ADC Digital Volume*/
91 (WM8988_R23_ADDITIONAL_1_CONTROL << 9) | 0x00C2, /*Additional Control 1*/
92 (WM8988_R24_ADDITIONAL_2_CONTROL << 9) | 0x0000, /*Additional Control 2*/
93 (WM8988_R27_ADDITIONAL_3_CONTROL << 9) | 0x0000, /*Additional Control 3*/
94 (WM8988_R31_ADC_INPUT_MODE << 9) | 0x0000, /*ADC input mode*/
95 (WM8988_R32_ADC_L_SIGNAL_PATH << 9) | 0x0000, /*ADC Signal Path Control left*/
96 (WM8988_R33_ADC_R_SIGNAL_PATH << 9) | 0x0000, /*ADC Signal Path Control right*/
97 (WM8988_R34_LEFT_OUT_MIX_1 << 9) | 0x0152, /*Left DAC mixer Control*/
98 (WM8988_R35_LEFT_OUT_MIX_2 << 9) | 0x0050, /*Left DAC mixer Control*/
99 (WM8988_R36_RIGHT_OUT_MIX_1 << 9) | 0x0052, /*Right DAC mixer Control*/
100 (WM8988_R37_RIGHT_OUT_MIX_2 << 9) | 0x0150, /*Right DAC mixer Control*/
101 (WM8988_R40_LOUT2_VOLUME << 9) | 0x01FF, /*Output left channel volume*/
102 (WM8988_R41_ROUT2_VOLUME << 9) | 0x01FF, /*Output left channel volume*/
103 (WM8988_R43_LOW_POWER_PALYBACK << 9) | 0x0008, /*Output left channel volume*/
104 (WM8988_R25_PWR_1_MGMT << 9) | 0x017C, /*Power Management1*/
105 (WM8988_R26_PWR_2_MGMT << 9) | 0x01F8, /*Power Management2*/
106};
107
108 i2c_handle_type hi2cx;
109
110 audio_codec_type audio_codec;
111uint16_t spk_dma_buffer[DMA_BUFFER_SIZE];
112uint16_t mic_dma_buffer[DMA_BUFFER_SIZE];
113
114void memset16_buffer(uint16_t *buffer, uint32_t set, uint32_t len);
115void codec_i2s_reset(void);
116void codec_i2s_init(audio_codec_type *param);
117void mclk_tmr1_init(void);
118void copy_buff(uint16_t *dest, uint16_t *src, uint32_t len);
119
125void audio_codec_set_mic_freq(uint32_t freq)
126{
127 if(audio_codec.audio_freq != freq)
128 {
129 audio_codec.audio_freq = freq;
130 codec_i2s_reset();
131 audio_codec_modify_freq(freq);
132 codec_i2s_init(&audio_codec);
133 }
134}
135
141void audio_codec_set_spk_freq(uint32_t freq)
142{
143 if(audio_codec.audio_freq != freq)
144 {
145 audio_codec.audio_freq = freq;
146 codec_i2s_reset();
147 audio_codec_modify_freq(freq);
148 codec_i2s_init(&audio_codec);
149 }
150}
151
152
158void audio_codec_spk_alt_setting(uint32_t alt_seting)
159{
160 if(alt_seting == 0)
161 {
162 }
163 else
164 {
165 }
166}
167
173void audio_codec_mic_alt_setting(uint32_t alt_seting)
174{
175 if(alt_seting == 0)
176 {
177 }
178 else
179 {
180 }
181}
182
188void audio_codec_set_mic_mute(uint8_t mute)
189{
190 audio_codec.mic_mute = mute;
191}
192
193
199void audio_codec_set_spk_mute(uint8_t mute)
200{
201 audio_codec.spk_mute = mute;
202}
203
204
210void audio_codec_set_mic_volume(uint16_t volume)
211{
212 /* wm8988 adc have 256 steps */
213 audio_codec.mic_volume = volume;
214}
215
221void audio_codec_set_spk_volume(uint16_t volume)
222{
223 /* wm8988 dac have 80 steps */
224 audio_codec.spk_volume = (volume * 0x50) / 0x64 + 0x30 - 1;
225}
226
232uint8_t audio_codec_spk_feedback(uint8_t *feedback)
233{
234 uint32_t feedback_value = (audio_codec.spk_freq);
235 feedback_value = ((feedback_value/1000)<<14)|((feedback_value%1000)<<4);
236 feedback[0] = (uint8_t)(feedback_value);
237 feedback[1] = (uint8_t)(feedback_value >> 8);
238 feedback[2] = (uint8_t)(feedback_value >> 16);
239 return 3;
240}
241
248void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
249{
250 uint16_t ulen = len / 2, i;
251 uint16_t *u16data = (uint16_t *)data;
252
253 switch(audio_codec.spk_stage)
254 {
255 case 0:
256 audio_codec.spk_woff = audio_codec.spk_roff = audio_codec.spk_buffer;
257 audio_codec.spk_wtotal = audio_codec.spk_rtotal = 0;
258 audio_codec.spk_stage = 1;
259 audio_codec.spk_threshold = SPK_BUFFER_SIZE/2;
260 break;
261 case 1:
262 if( audio_codec.spk_wtotal >= SPK_BUFFER_SIZE/2 )
263 {
264 audio_codec.spk_stage = 2;
265 }
266 break;
267 case 2:
268 break;
269 }
270 for( i = 0; i < ulen; ++i )
271 {
272 *audio_codec.spk_woff++ = *u16data++;
273 if( audio_codec.spk_woff >= audio_codec.spk_rend )
274 {
275 audio_codec.spk_woff = audio_codec.spk_buffer;
276 }
277 }
278 audio_codec.spk_wtotal += ulen;
279}
280
286uint32_t audio_codec_mic_get_data(uint8_t *buffer)
287{
288 //copy_buff((uint16_t *)buffer, audio_codec.mic_buffer + audio_codec.mic_hf_status, audio_codec.mic_rx_size);
289 uint16_t len = audio_codec.mic_rx_size << 1;
290 uint16_t i;
291 uint16_t* u16buf = (uint16_t*)buffer;
292 switch(audio_codec.mic_stage)
293 {
294 case 0:
295 audio_codec.mic_stage = 1;
296 memset( buffer, 0, len );
297 return len;
298 case 1:
299 if( audio_codec.mic_wtotal - audio_codec.mic_rtotal >= MIC_BUFFER_SIZE/2 )
300 {
301 audio_codec.mic_stage = 2;
302 }
303 return len;
304 }
305 switch( audio_codec.mic_adj_stage )
306 {
307 case 0:
308 break;
309 case 1:
310 if( audio_codec.mic_adj_count >= 4 ){
311 len += 4;
312 audio_codec.mic_adj_count -= 4;
313 }
314 break;
315 case 2:
316 if( audio_codec.mic_adj_count >= 4 ){
317 len -= 4;
318 audio_codec.mic_adj_count -= 4;
319 }
320 break;
321 }
322
323 for( i = 0; i < len/2; ++i )
324 {
325 *u16buf++ = *audio_codec.mic_roff++;
326 if( audio_codec.mic_roff >= audio_codec.mic_wend )
327 {
328 audio_codec.mic_roff = audio_codec.mic_buffer;
329 }
330 }
331 if( audio_codec.mic_wtotal <= audio_codec.mic_rtotal )
332 { //should not happen
333 while(1);
334 }
335
336 audio_codec.mic_rtotal += len/2;
337 audio_codec.mic_delta += len/2;
338 return len;
339}
340
346void audio_codec_modify_freq(uint32_t freq)
347{
348 uint16_t codec_cmd;
349 uint8_t i2c_cmd[2];
350 if(freq == AUDIO_FREQ_16K)
351 {
352 codec_cmd = WM8988_REG_FREQ16K;
353 }
354 else if(freq == AUDIO_FREQ_48K)
355 {
356 codec_cmd = WM8988_REG_FREQ48K;
357 }
358 i2c_cmd[0] = (uint8_t)(codec_cmd >> 8);
359 i2c_cmd[1] = (uint8_t)codec_cmd & 0xFF;
360 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
361 {
362 while(1);
363 }
364}
365
373void memset16_buffer(uint16_t *buffer, uint32_t set, uint32_t len)
374{
375 uint32_t i_index = 0;
376 for(i_index = 0; i_index < len; i_index ++)
377 {
378 buffer[i_index] = (uint16_t)set;
379 }
380}
381
389void copy_buff(uint16_t *dest, uint16_t *src, uint32_t len)
390{
391 uint16_t i_index;
392 for(i_index = 0; i_index < len; i_index ++)
393 {
394 dest[i_index] = src[i_index];
395 }
396}
397
403void i2c_lowlevel_init(i2c_handle_type* hi2c)
404{
405 gpio_init_type gpio_init_structure;
406
407 if(hi2c->i2cx == I2Cx_PORT)
408 {
409 /* i2c periph clock enable */
410 crm_periph_clock_enable(I2Cx_CLK, TRUE);
411 crm_periph_clock_enable(I2Cx_SCL_GPIO_CLK, TRUE);
412 crm_periph_clock_enable(I2Cx_SDA_GPIO_CLK, TRUE);
413
414 /* gpio configuration */
415 gpio_pin_mux_config(I2Cx_SCL_GPIO_PORT, I2Cx_SCL_GPIO_PinsSource, I2Cx_SCL_GPIO_MUX);
416
417 gpio_pin_mux_config(I2Cx_SDA_GPIO_PORT, I2Cx_SDA_GPIO_PinsSource, I2Cx_SDA_GPIO_MUX);
418
419 /* configure i2c pins: scl */
420 gpio_init_structure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
421 gpio_init_structure.gpio_mode = GPIO_MODE_MUX;
422 gpio_init_structure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
423 gpio_init_structure.gpio_pull = GPIO_PULL_UP;
424
425 gpio_init_structure.gpio_pins = I2Cx_SCL_GPIO_PIN;
426 gpio_init(I2Cx_SCL_GPIO_PORT, &gpio_init_structure);
427
428 /* configure i2c pins: sda */
429 gpio_init_structure.gpio_pins = I2Cx_SDA_GPIO_PIN;
430 gpio_init(I2Cx_SDA_GPIO_PORT, &gpio_init_structure);
431
432 /* config i2c */
433 i2c_init(hi2c->i2cx, 0x0F, I2Cx_CLKCTRL);
434
435 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
436 }
437}
438
444void mclk_tmr1_init(void)
445{
446 gpio_init_type gpio_init_struct;
447 tmr_output_config_type tmr_oc_init_structure;
448 uint16_t prescaler_value = (uint16_t)(system_core_clock / 24000000) - 1;
449
450 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
451 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
452
453 gpio_default_para_init(&gpio_init_struct);
454
455 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE8, GPIO_MUX_1);
456
457 gpio_init_struct.gpio_pins = GPIO_PINS_8;
458 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
459 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
460 gpio_init(GPIOA, &gpio_init_struct);
461
462 tmr_base_init(TMR1, 1, prescaler_value);
463 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
464 tmr_clock_source_div_set(TMR1, TMR_CLOCK_DIV1);
465
466 tmr_output_default_para_init(&tmr_oc_init_structure);
467 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
468 tmr_oc_init_structure.oc_idle_state = FALSE;
469 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
470 tmr_oc_init_structure.oc_output_state = TRUE;
471 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
472 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, 1);
473 tmr_output_channel_buffer_enable(TMR1, TMR_SELECT_CHANNEL_1, TRUE);
474
475 /* tmr enable counter */
476 tmr_counter_enable(TMR1, TRUE);
477 tmr_output_enable(TMR1, TRUE);
478}
479
480
486void codec_i2s_reset(void)
487{
488 i2s_enable(SPI1, FALSE);
489 i2s_enable(SPI2, FALSE);
490 dma_channel_enable(DMA1_CHANNEL3, FALSE);
491 dma_channel_enable(DMA1_CHANNEL4, FALSE);
492}
493
500void codec_i2s_init(audio_codec_type *param)
501{
502 gpio_init_type gpio_init_struct;
503 dma_init_type dma_init_struct;
504 i2s_init_type i2s_init_struct;
505 i2s_data_channel_format_type format = I2S_DATA_16BIT_CHANNEL_16BIT;
506
507 crm_periph_clock_enable(I2S1_GPIO_CRM_CLK, TRUE);
508 crm_periph_clock_enable(I2S2_GPIO_CRM_CLK, TRUE);
509 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
510 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
511 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
512
513 param->spk_freq = param->audio_freq;
514
515 param->spk_tx_size = (param->audio_freq / 1000) * (param->audio_bitw / 8) * AUDIO_SPK_CHANEL_NUM / 2;
516 param->mic_rx_size = (param->audio_freq / 1000) * (param->audio_bitw / 8) * AUDIO_MIC_CHANEL_NUM / 2;
517
518 memset(param->spk_buffer, 0, SPK_BUFFER_SIZE*sizeof(uint16_t));
519 memset(param->mic_buffer, 0, MIC_BUFFER_SIZE*sizeof(uint16_t));
520
521 param->mic_wend = param->mic_woff = param->mic_roff = param->mic_buffer;
522 param->spk_rend = param->spk_woff = param->spk_roff = param->spk_buffer;
523
524 while(param->mic_wend < param->mic_buffer+MIC_BUFFER_SIZE)
525 {
526 param->mic_wend += param->mic_rx_size;
527 }
528 param->mic_wend -= param->mic_rx_size;
529 while(param->spk_rend < param->spk_buffer+SPK_BUFFER_SIZE)
530 {
531 param->spk_rend += param->spk_tx_size;
532 }
533 param->spk_rend -= param->spk_tx_size;
534 if(param->audio_bitw == 16)
535 {
536 format = I2S_DATA_16BIT_CHANNEL_16BIT;
537 }
538 else
539 {
540 format = I2S_DATA_24BIT_CHANNEL_32BIT;
541 }
542
543 gpio_default_para_init(&gpio_init_struct);
544
545 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
546 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
547 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
548 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
549
550
551 /* i2s1 ws pins */
552 gpio_init_struct.gpio_pins = I2S1_WS_PIN;
553 gpio_init(I2S1_GPIO, &gpio_init_struct);
554 gpio_pin_mux_config(I2S1_GPIO, I2S1_WS_PIN_SOURCE, I2S1_WS_GPIO_MUX);
555
556 /* i2s1 ck pins */
557 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
558 gpio_init_struct.gpio_pins = I2S1_CK_PIN;
559 gpio_init(I2S1_GPIO, &gpio_init_struct);
560 gpio_pin_mux_config(I2S1_GPIO, I2S1_CK_PIN_SOURCE, I2S1_CK_GPIO_MUX);
561
562 /* i2s1 sd pins slave tx */
563 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
564 gpio_init_struct.gpio_pins = I2S1_SD_PIN;
565 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
566 gpio_init(I2S1_GPIO, &gpio_init_struct);
567 gpio_pin_mux_config(I2S1_GPIO, I2S1_SD_PIN_SOURCE, I2S1_SD_GPIO_MUX);
568
569 /* i2s2 ws pins */
570 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
571 gpio_init_struct.gpio_pins = I2S2_WS_PIN;
572 gpio_init(I2S2_GPIO, &gpio_init_struct);
573 gpio_pin_mux_config(I2S2_GPIO, I2S2_WS_PIN_SOURCE, I2S2_WS_GPIO_MUX);
574
575 /* i2s2 ck pins */
576 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
577 gpio_init_struct.gpio_pins = I2S2_CK_PIN;
578 gpio_init(I2S2_GPIO, &gpio_init_struct);
579 gpio_pin_mux_config(I2S2_GPIO, I2S2_CK_PIN_SOURCE, I2S2_CK_GPIO_MUX);
580
581 /* i2s2 sd pins slave rx */
582 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
583 gpio_init_struct.gpio_pins = I2S2_SD_PIN;
584 gpio_init(I2S2_GPIO, &gpio_init_struct);
585 gpio_pin_mux_config(I2S2_GPIO, I2S2_SD_PIN_SOURCE, I2S2_SD_GPIO_MUX);
586
587 /* dma config */
588 dma_reset(DMA1_CHANNEL3);
589 dma_reset(DMA1_CHANNEL4);
590
591 /* dma1 channel3: speaker i2s1 tx */
592 dma_default_para_init(&dma_init_struct);
593 dma_init_struct.buffer_size = param->spk_tx_size << 1;
594 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
595 dma_init_struct.memory_base_addr = (uint32_t)spk_dma_buffer;
596 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
597 dma_init_struct.memory_inc_enable = TRUE;
598 dma_init_struct.peripheral_base_addr = (uint32_t)I2S1_DT_ADDRESS;
599 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
600 dma_init_struct.peripheral_inc_enable = FALSE;
601 dma_init_struct.priority = DMA_PRIORITY_HIGH;
602 dma_init_struct.loop_mode_enable = TRUE;
603 dma_init(DMA1_CHANNEL3, &dma_init_struct);
604 dma_interrupt_enable(DMA1_CHANNEL3, DMA_FDT_INT, TRUE);
605 dma_interrupt_enable(DMA1_CHANNEL3, DMA_HDT_INT, TRUE);
606 nvic_irq_enable(DMA1_Channel3_IRQn, 1, 0);
607
608 /* dma1 channel4: microphone i2s2 rx */
609 dma_default_para_init(&dma_init_struct);
610 dma_init_struct.buffer_size = param->mic_rx_size << 1;
611 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
612 dma_init_struct.memory_base_addr = (uint32_t)mic_dma_buffer;
613 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
614 dma_init_struct.memory_inc_enable = TRUE;
615 dma_init_struct.peripheral_base_addr = (uint32_t)I2S2_DT_ADDRESS;
616 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
617 dma_init_struct.peripheral_inc_enable = FALSE;
618 dma_init_struct.priority = DMA_PRIORITY_HIGH;
619 dma_init_struct.loop_mode_enable = TRUE;
620 dma_init(DMA1_CHANNEL4, &dma_init_struct);
621 dma_interrupt_enable(DMA1_CHANNEL4, DMA_FDT_INT, TRUE);
622 dma_interrupt_enable(DMA1_CHANNEL4, DMA_HDT_INT, TRUE);
623 nvic_irq_enable(DMA1_Channel4_IRQn, 2, 0);
624
625 /* i2s1 tx init */
626 spi_i2s_reset(SPI1);
627 i2s_default_para_init(&i2s_init_struct);
628 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
629 i2s_init_struct.data_channel_format = format;
630 i2s_init_struct.mclk_output_enable = FALSE;
631 i2s_init_struct.audio_sampling_freq = (i2s_audio_sampling_freq_type)param->audio_freq;
632 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
633 i2s_init_struct.operation_mode = I2S_MODE_SLAVE_TX;
634 i2s_init(SPI1, &i2s_init_struct);
635
636 /* i2s2 rx init */
637 spi_i2s_reset(SPI2);
638 i2s_default_para_init(&i2s_init_struct);
639 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
640 i2s_init_struct.data_channel_format = format;
641 i2s_init_struct.mclk_output_enable = FALSE;
642 i2s_init_struct.audio_sampling_freq = (i2s_audio_sampling_freq_type)param->audio_freq;
643 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
644 i2s_init_struct.operation_mode = I2S_MODE_SLAVE_RX;
645 i2s_init(SPI2, &i2s_init_struct);
646
647
648 spi_i2s_dma_transmitter_enable(SPI1, TRUE);
649 spi_i2s_dma_receiver_enable(SPI2, TRUE);
650 i2s_enable(SPI1, TRUE);
651 i2s_enable(SPI2, TRUE);
652
653 dmamux_enable(DMA1, TRUE);
654 dmamux_init(DMA1MUX_CHANNEL3, DMAMUX_DMAREQ_ID_SPI1_TX);
655 dmamux_init(DMA1MUX_CHANNEL4, DMAMUX_DMAREQ_ID_SPI2_RX);
656 dma_channel_enable(DMA1_CHANNEL3, TRUE);
657 dma_channel_enable(DMA1_CHANNEL4, TRUE);
658
659}
660
666void DMA1_Channel3_IRQHandler(void)
667{
668 uint16_t half_size = audio_codec.spk_tx_size;
669 uint16_t *pdst;
670
671 if(dma_flag_get(DMA1_HDT3_FLAG) == SET)
672 {
673 //copy_buff(audio_codec.spk_buffer, audio_codec.spk_tx_fifo + audio_codec.r_pos, half_size);
674 pdst = spk_dma_buffer;
675 dma_flag_clear(DMA1_HDT3_FLAG);
676 }
677 else if(dma_flag_get(DMA1_FDT3_FLAG) == SET)
678 {
679 //copy_buff(&audio_codec.spk_buffer[half_size], audio_codec.spk_tx_fifo + audio_codec.r_pos, half_size);
680 pdst = spk_dma_buffer + half_size;
681 dma_flag_clear(DMA1_FDT3_FLAG);
682 }
683
684 switch( audio_codec.spk_stage )
685 {
686 case 0:
687 case 1:
688 memset( pdst, 0, half_size << 1);
689 break;
690 case 2:
691 if( audio_codec.spk_wtotal >= audio_codec.spk_rtotal + SPK_BUFFER_SIZE )
692 {
693 while(1);//should not happen;
694 }
695 if( audio_codec.spk_rtotal >= audio_codec.spk_wtotal )
696 {
697 audio_codec.spk_stage = 0;
698 audio_codec.spk_woff = audio_codec.spk_roff = audio_codec.spk_buffer;
699 audio_codec.spk_rtotal = audio_codec.spk_wtotal = 0;
700 }
701 else
702 {
703 memcpy( pdst, audio_codec.spk_roff, half_size << 1 );
704 audio_codec.spk_roff += half_size;
705 audio_codec.spk_rtotal += half_size;
706 if( audio_codec.spk_roff >= audio_codec.spk_rend )
707 {
708 audio_codec.spk_roff = audio_codec.spk_buffer;
709 }
710 if( ++audio_codec.spk_calc == 256 )
711 {
712 uint16_t delta = audio_codec.spk_wtotal - audio_codec.spk_rtotal;
713 audio_codec.spk_calc = 0;
714 if( delta < audio_codec.spk_threshold - half_size )
715 {
716 audio_codec.spk_threshold -= half_size;
717 audio_codec.spk_freq += audio_codec.audio_freq/1024;
718 }
719 else if( delta > audio_codec.spk_threshold + half_size )
720 {
721 audio_codec.spk_threshold += half_size;
722 audio_codec.spk_freq -= audio_codec.audio_freq/1024;
723 }
724 if(audio_codec.spk_rtotal > 0x20000000)
725 {
726 audio_codec.spk_rtotal -= 0x10000000;
727 audio_codec.spk_wtotal -= 0x10000000;
728 }
729 }
730 }
731 break;
732 }
733
734}
735
741void DMA1_Channel4_IRQHandler(void)
742{
743 uint16_t *psrc;
744 uint16_t len = audio_codec.mic_rx_size << 1;
745
746 if(dma_flag_get(DMA1_HDT4_FLAG) == SET)
747 {
748 dma_flag_clear(DMA1_HDT4_FLAG);
749 psrc = mic_dma_buffer;
750 }
751 else if(dma_flag_get(DMA1_FDT4_FLAG) == SET)
752 {
753 psrc = mic_dma_buffer + audio_codec.mic_rx_size;
754 dma_flag_clear(DMA1_FDT4_FLAG);
755 }
756 if( audio_codec.mic_stage )
757 {
758 memcpy( audio_codec.mic_woff, psrc, len );
759 audio_codec.mic_woff += len/2;
760 audio_codec.mic_wtotal += len/2;
761 if( audio_codec.mic_woff >= audio_codec.mic_wend )
762 {
763 audio_codec.mic_woff = audio_codec.mic_buffer;
764 }
765 if( audio_codec.mic_stage == 2 )
766 {
767 if( 1024 == ++audio_codec.mic_calc )
768 {
769 uint32_t size_estimate = 1024*audio_codec.mic_rx_size;
770 audio_codec.mic_calc = 0;
771 if( audio_codec.mic_delta > size_estimate )
772 {
773 audio_codec.mic_adj_count = audio_codec.mic_delta - size_estimate;
774 audio_codec.mic_adj_stage = 2;
775 }
776 else if( audio_codec.mic_delta < size_estimate )
777 {
778 audio_codec.mic_adj_count = size_estimate - audio_codec.mic_delta;
779 audio_codec.mic_adj_stage = 1;
780 }
781 else
782 {
783 audio_codec.mic_adj_count = 0;
784 audio_codec.mic_adj_stage = 0;
785 }
786 audio_codec.mic_delta = 0;
787 if( audio_codec.mic_rtotal >= 0x80000000 )
788 {
789 audio_codec.mic_rtotal -= 0x80000000;
790 audio_codec.mic_wtotal -= 0x80000000;
791 }
792 }
793 if( audio_codec.mic_wtotal >= audio_codec.mic_rtotal + MIC_BUFFER_SIZE )
794 {
795 audio_codec.mic_delta = audio_codec.mic_wtotal = audio_codec.mic_rtotal = 0;
796 audio_codec.mic_woff = audio_codec.mic_roff = audio_codec.mic_buffer;
797 audio_codec.mic_stage = 0;
798 audio_codec.mic_adj_stage = 0;
799 audio_codec.mic_adj_count = 0;
800 audio_codec.mic_calc = 0;
801 }
802 }
803 }
804}
805
811 error_status audio_codec_init(void)
812{
813 uint32_t reg_len = sizeof(reg_addr_data) / sizeof(uint16_t);
814 uint32_t i_index = 0;
815 uint8_t i2c_cmd[2];
816
817 if(AUDIO_DEFAULT_FREQ == AUDIO_FREQ_16K)
818 {
819 reg_addr_data[6] = WM8988_REG_FREQ16K;
820 audio_codec.audio_freq = AUDIO_FREQ_16K;
821 }
822 else if(AUDIO_DEFAULT_FREQ == AUDIO_FREQ_48K)
823 {
824 reg_addr_data[6] = WM8988_REG_FREQ48K;
825 audio_codec.audio_freq = AUDIO_FREQ_48K;
826 }
827 else
828 {
829 return ERROR;
830 }
831
832 if(AUDIO_DEFAULT_BITW == AUDIO_BITW_16)
833 {
834 reg_addr_data[5] = WM8988_REG_BITW16;
835 audio_codec.audio_bitw = AUDIO_BITW_16;
836 }
837 else
838 {
839 return ERROR;
840 }
841
842 /* i2c init */
843 hi2cx.i2cx = I2Cx_PORT;
844
845 i2c_config(&hi2cx);
846
847 for(i_index = 0; i_index < reg_len; i_index ++)
848 {
849 i2c_cmd[0] = (uint8_t)(reg_addr_data[i_index] >> 8);
850 i2c_cmd[1] = (uint8_t)reg_addr_data[i_index] & 0xFF;
851 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
852 {
853 return ERROR;
854 }
855 }
856
857 /* timer init */
858 mclk_tmr1_init();
859
860 codec_i2s_init(&audio_codec);
861
862 return SUCCESS;
863}
864
870 error_status audio_codec_loop(void)
871{
872 static uint8_t mic_mute = 0;
873 static uint16_t mic_volume = 0;
874 static uint8_t spk_mute = 0;
875 static uint16_t spk_volume = 0;
876 uint16_t audio_ctrl_l;
877 uint16_t audio_ctrl_r;
878 uint8_t i2c_cmd[2];
879
880 if(mic_mute != audio_codec.mic_mute)
881 {
882 mic_mute = audio_codec.mic_mute;
883 audio_ctrl_l = WM8988_R21_LEFT_ADC_VOLUME << 9 | 0x100;
884 audio_ctrl_r = WM8988_R22_RIGHT_ADC_VOLUME << 9 | 0x100;
885 if(audio_codec.mic_mute == 0)
886 {
887 audio_ctrl_l |= audio_codec.mic_volume;
888 audio_ctrl_r |= audio_codec.mic_volume;
889 }
890 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
891 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
892 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
893 {
894 return ERROR;
895 }
896 i2c_cmd[0] = (uint8_t)(audio_ctrl_r >> 8);
897 i2c_cmd[1] = (uint8_t)audio_ctrl_r & 0xFF;
898 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
899 {
900 return ERROR;
901 }
902 }
903
904 if(mic_volume != audio_codec.mic_volume)
905 {
906 mic_volume = audio_codec.mic_volume;
907 audio_ctrl_l = WM8988_R21_LEFT_ADC_VOLUME << 9 | 0x100;
908 audio_ctrl_r = WM8988_R22_RIGHT_ADC_VOLUME << 9 | 0x100;
909 audio_ctrl_l |= audio_codec.mic_volume;
910 audio_ctrl_r |= audio_codec.mic_volume;
911 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
912 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
913 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
914 {
915 return ERROR;
916 }
917 i2c_cmd[0] = (uint8_t)(audio_ctrl_r >> 8);
918 i2c_cmd[1] = (uint8_t)audio_ctrl_r & 0xFF;
919 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
920 {
921 return ERROR;
922 }
923 }
924
925 if(spk_mute != audio_codec.spk_mute)
926 {
927 spk_mute = audio_codec.spk_mute;
928 audio_ctrl_l = (WM8988_R5_ADC_DAC_CONTROL << 9) | 0x0006 | (audio_codec.spk_mute << 3);
929 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
930 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
931 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
932 {
933 return ERROR;
934 }
935 }
936
937 if(spk_volume != audio_codec.spk_volume)
938 {
939 spk_volume = audio_codec.spk_volume;
940 audio_ctrl_l = WM8988_R2_LOUT1_VOLUME << 9 | 0x100;
941 audio_ctrl_r = WM8988_R3_ROUT1_VOLUME << 9 | 0x100;
942 audio_ctrl_l |= audio_codec.spk_volume;
943 audio_ctrl_r |= audio_codec.spk_volume;
944
945 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
946 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
947
948 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
949 {
950 return ERROR;
951 }
952 i2c_cmd[0] = (uint8_t)(audio_ctrl_r >> 8);
953 i2c_cmd[1] = (uint8_t)audio_ctrl_r & 0xFF;
954 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
955 {
956 return ERROR;
957 }
958 }
959 return SUCCESS;
960}
961
buffer
uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:43
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/main.c:38
DMA1_Channel4_IRQHandler
void DMA1_Channel4_IRQHandler(void)
this function handles dma1 channel4 handler.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c:190
DMA1_Channel3_IRQHandler
void DMA1_Channel3_IRQHandler(void)
this function handles dma1 channel3 handler.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c:175
reg_addr_data
uint16_t reg_addr_data[]
wm8988 register default value
Definition: at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c:75
spk_dma_buffer
uint16_t spk_dma_buffer[DMA_BUFFER_SIZE]
Definition: at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c:111
WM8988_REG_FREQ48K
#define WM8988_REG_FREQ48K
wm8988 freq
Definition: at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c:64
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c:44
I2Cx_SDA_GPIO_PIN
#define I2Cx_SDA_GPIO_PIN
Definition: at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c:56
I2Cx_SDA_GPIO_MUX
#define I2Cx_SDA_GPIO_MUX
Definition: at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c:59
I2Cx_CLKCTRL
#define I2Cx_CLKCTRL
Definition: at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c:43
I2Cx_CLK
#define I2Cx_CLK
Definition: at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c:47
WM8988_REG_BITW16
#define WM8988_REG_BITW16
wm8988 bit width
Definition: at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c:70
I2Cx_SCL_GPIO_PinsSource
#define I2Cx_SCL_GPIO_PinsSource
Definition: at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c:51
mic_dma_buffer
uint16_t mic_dma_buffer[DMA_BUFFER_SIZE]
Definition: at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c:112
hi2cx
i2c_handle_type hi2cx
Definition: at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c:108
I2Cx_SCL_GPIO_MUX
#define I2Cx_SCL_GPIO_MUX
Definition: at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c:53
I2Cx_SDA_GPIO_PORT
#define I2Cx_SDA_GPIO_PORT
Definition: at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c:58
I2Cx_SDA_GPIO_PinsSource
#define I2Cx_SDA_GPIO_PinsSource
Definition: at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c:57
I2Cx_SDA_GPIO_CLK
#define I2Cx_SDA_GPIO_CLK
Definition: at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c:55
audio_codec
audio_codec_type audio_codec
Definition: at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c:110
WM8988_REG_FREQ16K
#define WM8988_REG_FREQ16K
Definition: at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c:65
I2Cx_PORT
#define I2Cx_PORT
Definition: at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c:46
I2Cx_SCL_GPIO_PIN
#define I2Cx_SCL_GPIO_PIN
Definition: at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c:50
I2Cx_SCL_GPIO_CLK
#define I2Cx_SCL_GPIO_CLK
Definition: at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c:49
I2Cx_SCL_GPIO_PORT
#define I2Cx_SCL_GPIO_PORT
Definition: at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c:52
codec_i2s_reset
void codec_i2s_reset(void)
audio codec i2s reset
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:486
codec_i2s_init
void codec_i2s_init(audio_codec_type *param)
audio codec i2s init
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:500
mclk_tmr1_init
void mclk_tmr1_init(void)
mclk clock conifg
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:444
copy_buff
void copy_buff(uint16_t *dest, uint16_t *src, uint32_t len)
copy buffer
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:389
memset16_buffer
void memset16_buffer(uint16_t *buffer, uint32_t set, uint32_t len)
buffer memset
Definition: at_start_f435/examples/usb_device/audio/src/audio_codec.c:373
system_core_clock
unsigned int system_core_clock
Definition: system_at32f435_437.c:48
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:138
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:161
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:154
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_SPI2_RX
@ DMAMUX_DMAREQ_ID_SPI2_RX
Definition: at32f435_437_dma.h:206
DMAMUX_DMAREQ_ID_SPI1_TX
@ DMAMUX_DMAREQ_ID_SPI1_TX
Definition: at32f435_437_dma.h:205
DMA1_HDT4_FLAG
#define DMA1_HDT4_FLAG
Definition: at32f435_437_dma.h:79
DMA1_HDT3_FLAG
#define DMA1_HDT3_FLAG
Definition: at32f435_437_dma.h:75
DMA1_FDT4_FLAG
#define DMA1_FDT4_FLAG
Definition: at32f435_437_dma.h:78
DMA1_FDT3_FLAG
#define DMA1_FDT3_FLAG
Definition: at32f435_437_dma.h:74
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA_HDT_INT
#define DMA_HDT_INT
Definition: at32f435_437_dma.h:53
DMA1MUX_CHANNEL3
#define DMA1MUX_CHANNEL3
Definition: at32f435_437_dma.h:706
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f435_437_dma.h:698
DMA1MUX_CHANNEL4
#define DMA1MUX_CHANNEL4
Definition: at32f435_437_dma.h:707
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f435_437_dma.h:699
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_MODERATE
@ GPIO_DRIVE_STRENGTH_MODERATE
Definition: at32f435_437_gpio.h:94
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f435_437_gpio.h:103
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_1
@ GPIO_MUX_1
Definition: at32f435_437_gpio.h:157
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
i2c_init
void i2c_init(i2c_type *i2c_x, uint8_t dfilters, uint32_t clk)
init i2c digit filters and clock control register.
Definition: at32f435_437_i2c.c:79
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config i2c own address 1.
Definition: at32f435_437_i2c.c:103
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f435_437_i2c.h:113
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:113
i2c_lowlevel_init
__WEAK void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: i2c_application.c:103
i2c_master_transmit
i2c_status_type i2c_master_transmit(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode.
Definition: i2c_application.c:375
I2C_OK
@ I2C_OK
Definition: i2c_application.h:81
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f435_437_spi.c:350
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f435_437_spi.c:533
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f435_437_spi.c:479
spi_i2s_reset
void spi_i2s_reset(spi_type *spi_x)
spi reset by crm reset register
Definition: at32f435_437_spi.c:51
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f435_437_spi.c:332
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f435_437_spi.c:519
i2s_data_channel_format_type
i2s_data_channel_format_type
i2s data bit num and channel bit num type
Definition: at32f435_437_spi.h:228
i2s_audio_sampling_freq_type
i2s_audio_sampling_freq_type
i2s audio frequency type
Definition: at32f435_437_spi.h:211
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f435_437_spi.h:251
I2S_DATA_16BIT_CHANNEL_16BIT
@ I2S_DATA_16BIT_CHANNEL_16BIT
Definition: at32f435_437_spi.h:229
I2S_DATA_24BIT_CHANNEL_32BIT
@ I2S_DATA_24BIT_CHANNEL_32BIT
Definition: at32f435_437_spi.h:231
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f435_437_spi.h:200
I2S_MODE_SLAVE_RX
@ I2S_MODE_SLAVE_RX
Definition: at32f435_437_spi.h:241
I2S_MODE_SLAVE_TX
@ I2S_MODE_SLAVE_TX
Definition: at32f435_437_spi.h:240
SPI1
#define SPI1
Definition: at32f435_437_spi.h:453
SPI2
#define SPI2
Definition: at32f435_437_spi.h:454
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f435_437_tmr.c:1499
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_output_channel_buffer_enable
void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel buffer
Definition: at32f435_437_tmr.c:660
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f435_437_tmr.h:97
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f435_437_tmr.h:180
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:198
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
audio_codec_mic_alt_setting
void audio_codec_mic_alt_setting(uint32_t alt_seting)
audio codec microphone alt setting config
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:173
audio_codec_set_spk_volume
void audio_codec_set_spk_volume(uint16_t volume)
audio codec set speaker volume
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:221
audio_codec_set_spk_mute
void audio_codec_set_spk_mute(uint8_t mute)
audio codec set speaker mute
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:199
MIC_BUFFER_SIZE
#define MIC_BUFFER_SIZE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:145
audio_codec_set_mic_freq
void audio_codec_set_mic_freq(uint32_t freq)
audio codec set microphone freq
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:125
audio_codec_mic_get_data
uint32_t audio_codec_mic_get_data(uint8_t *buffer)
codec microphone get data
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:286
audio_codec_loop
error_status audio_codec_loop(void)
audio codec loop
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:870
SPK_BUFFER_SIZE
#define SPK_BUFFER_SIZE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:146
audio_codec_set_mic_mute
void audio_codec_set_mic_mute(uint8_t mute)
audio codec set microphone mute
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:188
audio_codec_spk_fifo_write
void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
audio codec interface
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:248
audio_codec_spk_feedback
uint8_t audio_codec_spk_feedback(uint8_t *feedback)
codec speaker feedback
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:232
audio_codec_modify_freq
void audio_codec_modify_freq(uint32_t freq)
audio codec modify freq
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:346
audio_codec_set_mic_volume
void audio_codec_set_mic_volume(uint16_t volume)
audio codec set microphone volume
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:210
audio_codec_spk_alt_setting
void audio_codec_spk_alt_setting(uint32_t alt_seting)
audio codec speaker alt setting config
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:158
DMA_BUFFER_SIZE
#define DMA_BUFFER_SIZE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:147
audio_codec_init
error_status audio_codec_init(void)
audio codec init
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:811
audio_codec_set_spk_freq
void audio_codec_set_spk_freq(uint32_t freq)
audio codec set speaker freq
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:141
I2S1_SD_PIN_SOURCE
#define I2S1_SD_PIN_SOURCE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:112
I2S1_WS_PIN_SOURCE
#define I2S1_WS_PIN_SOURCE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:104
I2S2_DT_ADDRESS
#define I2S2_DT_ADDRESS
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:134
I2S1_SD_PIN
#define I2S1_SD_PIN
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:111
I2S1_CK_PIN_SOURCE
#define I2S1_CK_PIN_SOURCE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:108
I2S1_CK_PIN
#define I2S1_CK_PIN
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:107
I2S2_GPIO
#define I2S2_GPIO
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:132
I2S2_WS_GPIO_MUX
#define I2S2_WS_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:122
I2S2_SD_PIN
#define I2S2_SD_PIN
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:128
I2S2_SD_GPIO_MUX
#define I2S2_SD_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:130
I2S1_CK_GPIO_MUX
#define I2S1_CK_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:109
I2S2_CK_PIN_SOURCE
#define I2S2_CK_PIN_SOURCE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:125
I2S2_WS_PIN
#define I2S2_WS_PIN
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:120
I2S2_GPIO_CRM_CLK
#define I2S2_GPIO_CRM_CLK
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:133
I2S2_CK_GPIO_MUX
#define I2S2_CK_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:126
I2S1_SD_GPIO_MUX
#define I2S1_SD_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:113
I2S2_SD_PIN_SOURCE
#define I2S2_SD_PIN_SOURCE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:129
I2S1_DT_ADDRESS
#define I2S1_DT_ADDRESS
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:117
I2S1_GPIO_CRM_CLK
#define I2S1_GPIO_CRM_CLK
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:116
I2S1_WS_GPIO_MUX
#define I2S1_WS_GPIO_MUX
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:105
I2S1_WS_PIN
#define I2S1_WS_PIN
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:103
I2S2_WS_PIN_SOURCE
#define I2S2_WS_PIN_SOURCE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:121
I2S1_GPIO
#define I2S1_GPIO
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:115
I2S2_CK_PIN
#define I2S2_CK_PIN
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:124
WM8988_R27_ADDITIONAL_3_CONTROL
#define WM8988_R27_ADDITIONAL_3_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:77
WM8988_I2C_ADDR_CSB_LOW
#define WM8988_I2C_ADDR_CSB_LOW
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:93
WM8988_R10_LEFT_DAC_VOLUME
#define WM8988_R10_LEFT_DAC_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:60
WM8988_R1_RIGHT_INPUT_VOLUME
#define WM8988_R1_RIGHT_INPUT_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:51
WM8988_R3_ROUT1_VOLUME
#define WM8988_R3_ROUT1_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:53
WM8988_R36_RIGHT_OUT_MIX_1
#define WM8988_R36_RIGHT_OUT_MIX_1
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:84
WM8988_R21_LEFT_ADC_VOLUME
#define WM8988_R21_LEFT_ADC_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:71
WM8988_R31_ADC_INPUT_MODE
#define WM8988_R31_ADC_INPUT_MODE
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:79
WM8988_R13_TREBLE_CONTROL
#define WM8988_R13_TREBLE_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:63
WM8988_R16_3D_CONTROL
#define WM8988_R16_3D_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:66
WM8988_R22_RIGHT_ADC_VOLUME
#define WM8988_R22_RIGHT_ADC_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:72
WM8988_R0_LEFT_INPUT_VOLUME
#define WM8988_R0_LEFT_INPUT_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:50
WM8988_R23_ADDITIONAL_1_CONTROL
#define WM8988_R23_ADDITIONAL_1_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:73
WM8988_R35_LEFT_OUT_MIX_2
#define WM8988_R35_LEFT_OUT_MIX_2
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:83
WM8988_R43_LOW_POWER_PALYBACK
#define WM8988_R43_LOW_POWER_PALYBACK
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:91
WM8988_R32_ADC_L_SIGNAL_PATH
#define WM8988_R32_ADC_L_SIGNAL_PATH
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:80
WM8988_R26_PWR_2_MGMT
#define WM8988_R26_PWR_2_MGMT
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:76
WM8988_R11_RIGHT_DAC_VOLUME
#define WM8988_R11_RIGHT_DAC_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:61
WM8988_R24_ADDITIONAL_2_CONTROL
#define WM8988_R24_ADDITIONAL_2_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:74
WM8988_R40_LOUT2_VOLUME
#define WM8988_R40_LOUT2_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:88
WM8988_R34_LEFT_OUT_MIX_1
#define WM8988_R34_LEFT_OUT_MIX_1
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:82
WM8988_R5_ADC_DAC_CONTROL
#define WM8988_R5_ADC_DAC_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:55
WM8988_R25_PWR_1_MGMT
#define WM8988_R25_PWR_1_MGMT
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:75
WM8988_R41_ROUT2_VOLUME
#define WM8988_R41_ROUT2_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:89
WM8988_R2_LOUT1_VOLUME
#define WM8988_R2_LOUT1_VOLUME
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:52
WM8988_R37_RIGHT_OUT_MIX_2
#define WM8988_R37_RIGHT_OUT_MIX_2
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:85
WM8988_R33_ADC_R_SIGNAL_PATH
#define WM8988_R33_ADC_R_SIGNAL_PATH
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:81
WM8988_R12_BASS_CONTROL
#define WM8988_R12_BASS_CONTROL
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:62
AUDIO_BITW_16
#define AUDIO_BITW_16
Definition: audio/audio_conf.h:61
AUDIO_MIC_CHANEL_NUM
#define AUDIO_MIC_CHANEL_NUM
Definition: audio/audio_conf.h:63
AUDIO_DEFAULT_FREQ
#define AUDIO_DEFAULT_FREQ
Definition: audio/audio_conf.h:71
AUDIO_FREQ_16K
#define AUDIO_FREQ_16K
Definition: audio/audio_conf.h:59
AUDIO_SPK_CHANEL_NUM
#define AUDIO_SPK_CHANEL_NUM
Definition: audio/audio_conf.h:66
AUDIO_DEFAULT_BITW
#define AUDIO_DEFAULT_BITW
Definition: audio/audio_conf.h:72
AUDIO_FREQ_48K
#define AUDIO_FREQ_48K
Definition: audio/audio_conf.h:60
DMA1_Channel3_IRQn
@ DMA1_Channel3_IRQn
Definition: at32f435_437.h:206
DMA1_Channel4_IRQn
@ DMA1_Channel4_IRQn
Definition: at32f435_437.h:207
i2c_application.h
i2c application libray header file
audio_codec_type
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:150
audio_codec_type::spk_mute
uint8_t spk_mute
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:179
audio_codec_type::spk_threshold
uint16_t spk_threshold
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:161
audio_codec_type::spk_stage
uint8_t spk_stage
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:163
audio_codec_type::mic_roff
uint16_t * mic_roff
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:167
audio_codec_type::spk_buffer
uint16_t spk_buffer[4096]
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:154
audio_codec_type::mic_volume
uint16_t mic_volume
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:181
audio_codec_type::spk_roff
uint16_t * spk_roff
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:155
audio_codec_type::spk_rtotal
uint32_t spk_rtotal
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:160
audio_codec_type::mic_delta
uint32_t mic_delta
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:172
audio_codec_type::spk_calc
uint16_t spk_calc
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:162
audio_codec_type::mic_woff
uint16_t * mic_woff
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:168
audio_codec_type::mic_stage
uint8_t mic_stage
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:176
audio_codec_type::mic_adj_count
uint16_t mic_adj_count
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:174
audio_codec_type::spk_freq
uint32_t spk_freq
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:158
audio_codec_type::audio_bitw
uint32_t audio_bitw
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:152
audio_codec_type::mic_wend
uint16_t * mic_wend
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:169
audio_codec_type::spk_rend
uint16_t * spk_rend
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:157
audio_codec_type::mic_wtotal
uint32_t mic_wtotal
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:170
audio_codec_type::mic_rtotal
uint32_t mic_rtotal
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:171
audio_codec_type::audio_freq
uint32_t audio_freq
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:151
audio_codec_type::mic_mute
uint8_t mic_mute
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:178
audio_codec_type::spk_volume
uint16_t spk_volume
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:182
audio_codec_type::mic_calc
uint16_t mic_calc
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:173
audio_codec_type::spk_wtotal
uint32_t spk_wtotal
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:159
audio_codec_type::mic_adj_stage
uint8_t mic_adj_stage
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:175
audio_codec_type::spk_tx_size
uint32_t spk_tx_size
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:184
audio_codec_type::mic_rx_size
uint32_t mic_rx_size
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:185
audio_codec_type::spk_woff
uint16_t * spk_woff
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:156
audio_codec_type::mic_buffer
uint16_t mic_buffer[1024]
Definition: at_start_f435/examples/usb_device/audio/inc/audio_codec.h:166
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
i2c_handle_type
Definition: i2c_application.h:112
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:113
i2s_init_type
i2s init type
Definition: at32f435_437_spi.h:274
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f435_437_spi.h:277
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f435_437_spi.h:278
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f435_437_spi.h:280
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f435_437_spi.h:276
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f435_437_spi.h:275
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:279
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415


AT32F435/437 Firmwary Library: msc_diskio.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • composite_vcp_msc
  • inc
Macros | Functions
at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h File Reference

usb mass storage disk interface header file More...

#include "usb_conf.h"
#include "usb_std.h"

Go to the source code of this file.

Macros

#define | INTERNAL_FLASH_LUN 0
#define | SPI_FLASH_LUN 1
#define | SD_LUN 2
#define | USB_FLASH_ADDR_OFFSET 0x08005000
#define | SECTOR_SIZE_1K 1024
#define | SECTOR_SIZE_2K 2048
#define | SECTOR_SIZE_4K 4096

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Detailed Description

usb mass storage disk interface header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h.


AT32F435/437 Firmwary Library: msc_diskio.h Source File

  • at_start_f437
  • examples
  • usb_device
  • composite_vcp_msc
  • inc
at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h
Go to the documentation of this file.
1
26/* Define to prevent recursive inclusion -------------------------------------*/
27#ifndef __MSC_DISKIO_H
28#define __MSC_DISKIO_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34
35#include "usb_conf.h"
36#include "usb_std.h"
37
45#define INTERNAL_FLASH_LUN 0
46#define SPI_FLASH_LUN 1
47#define SD_LUN 2
48
49#define USB_FLASH_ADDR_OFFSET 0x08005000
50
51#define SECTOR_SIZE_1K 1024
52#define SECTOR_SIZE_2K 2048
53#define SECTOR_SIZE_4K 4096
54
55uint8_t *get_inquiry(uint8_t lun);
56 usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len);
57 usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len);
58 usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size);
59
68#ifdef __cplusplus
69}
70#endif
71
72#endif
73
74
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:106
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:75
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:144
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:59
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
usb_std.h
usb standard header file
usb_conf.h
usb config header file


AT32F435/437 Firmwary Library: msc_diskio.c File Reference

  • at_start_f437
  • examples
  • usb_device
  • composite_vcp_msc
  • src
Functions | Variables
at_start_f437/examples/usb_device/composite_vcp_msc/src/msc_diskio.c File Reference

usb mass storage disk function More...

#include "msc_diskio.h"
#include "cdc_msc_class.h"

Go to the source code of this file.

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Variables

uint32_t | sector_size = 2048
uint32_t | msc_flash_size
uint8_t | scsi_inquiry [MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]

Detailed Description

usb mass storage disk function

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/usb_device/composite_vcp_msc/src/msc_diskio.c.


AT32F435/437 Firmwary Library: msc_diskio.c Source File

  • at_start_f437
  • examples
  • usb_device
  • composite_vcp_msc
  • src
at_start_f437/examples/usb_device/composite_vcp_msc/src/msc_diskio.c
Go to the documentation of this file.
1
26#include "msc_diskio.h"
27#include "cdc_msc_class.h"
28
36uint32_t sector_size = 2048;
37uint32_t msc_flash_size;
38uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH] =
39{
40 /* lun = 0 */
41 {
42 0x00, /* peripheral device type (direct-access device) */
43 0x80, /* removable media bit */
44 0x00, /* ansi version, ecma version, iso version */
45 0x01, /* respond data format */
46 SCSI_INQUIRY_DATA_LENGTH - 5, /* additional length */
47 0x00, 0x00, 0x00, /* reserved */
48 'A', 'T', '3', '2', ' ', ' ', ' ', ' ', /* vendor information "AT32" */
49 'D', 'i', 's', 'k', '0', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', /* Product identification "Disk" */
50 '2', '.', '0', '0' /* product revision level */
51 }
52};
53
59uint8_t *get_inquiry(uint8_t lun)
60{
61 if(lun < MSC_SUPPORT_MAX_LUN)
62 return (uint8_t *)scsi_inquiry[lun];
63 else
64 return NULL;
65}
66
75 usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
76{
77 uint32_t i = 0;
78 uint32_t flash_addr = addr + USB_FLASH_ADDR_OFFSET;
79 switch(lun)
80 {
81 case INTERNAL_FLASH_LUN:
82 for(i = 0; i < len; i ++)
83 {
84 read_buf[i] = *((uint8_t *)flash_addr);
85 flash_addr += 1;
86 }
87 break;
88 case SPI_FLASH_LUN:
89 break;
90 case SD_LUN:
91 break;
92 default:
93 break;
94 }
95 return USB_OK;
96}
97
106 usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
107{
108 uint32_t flash_addr = addr + USB_FLASH_ADDR_OFFSET;
109 uint32_t i = 0, tolen = len;
110 uint32_t erase_addr = flash_addr;
111 switch(lun)
112 {
113 case INTERNAL_FLASH_LUN:
114 flash_unlock();
115 while(tolen >= sector_size)
116 {
117 flash_sector_erase(erase_addr);
118 tolen -= sector_size;
119 erase_addr += sector_size;
120 }
121 for(i = 0; i < len; i ++)
122 {
123 flash_byte_program(flash_addr+i, buf[i]);
124 }
125 flash_lock();
126 break;
127 case SPI_FLASH_LUN:
128 break;
129 case SD_LUN:
130 break;
131 default:
132 break;;
133 }
134 return USB_OK;
135}
136
144 usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
145{
146 uint32_t devid = (*((uint32_t *)DEBUG_BASE) & 0x00007000) >> 12;
147 msc_flash_size = (*((uint32_t *)0x1FFFF7E0) << 10) - (USB_FLASH_ADDR_OFFSET - FLASH_BASE);
148 switch(devid)
149 {
150 case 2:
151 sector_size = SECTOR_SIZE_1K;
152 break;
153 case 3:
154 sector_size = SECTOR_SIZE_2K;
155 break;
156 case 4:
157 sector_size = SECTOR_SIZE_4K;
158 break;
159 default:
160 sector_size = SECTOR_SIZE_2K;
161 break;
162 }
163 switch(lun)
164 {
165 case INTERNAL_FLASH_LUN:
166 *blk_nbr = msc_flash_size / sector_size;
167 *blk_size = sector_size;
168 break;
169 case SPI_FLASH_LUN:
170 break;
171 case SD_LUN:
172 break;
173 default:
174 break;
175 }
176 return USB_OK;
177}
178
cdc_msc_class.h
usb cdc class file
msc_flash_size
uint32_t msc_flash_size
Definition: at_start_f437/examples/usb_device/composite_vcp_msc/src/msc_diskio.c:37
sector_size
uint32_t sector_size
Definition: at_start_f437/examples/usb_device/composite_vcp_msc/src/msc_diskio.c:36
scsi_inquiry
uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
Definition: at_start_f437/examples/usb_device/composite_vcp_msc/src/msc_diskio.c:38
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:106
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:75
USB_FLASH_ADDR_OFFSET
#define USB_FLASH_ADDR_OFFSET
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h:49
INTERNAL_FLASH_LUN
#define INTERNAL_FLASH_LUN
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h:45
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:144
SD_LUN
#define SD_LUN
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h:47
SPI_FLASH_LUN
#define SPI_FLASH_LUN
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h:46
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:59
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f435_437_flash.c:357
flash_byte_program
flash_status_type flash_byte_program(uint32_t address, uint8_t data)
program a byte at a specified address.
Definition: at32f435_437_flash.c:679
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f435_437_flash.c:290
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f435_437_flash.c:325
DEBUG_BASE
#define DEBUG_BASE
Definition: at32f435_437.h:427
FLASH_BASE
#define FLASH_BASE
Definition: at32f435_437.h:425
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
SECTOR_SIZE_1K
#define SECTOR_SIZE_1K
Definition: hid_iap_class.h:61
SECTOR_SIZE_2K
#define SECTOR_SIZE_2K
Definition: hid_iap_class.h:62
SECTOR_SIZE_4K
#define SECTOR_SIZE_4K
Definition: hid_iap_class.h:63
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:157
MSC_SUPPORT_MAX_LUN
#define MSC_SUPPORT_MAX_LUN
Definition: cdc_msc_class.h:83
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_OK
@ USB_OK
Definition: usb_std.h:268


AT32F435/437 Firmwary Library: msc_diskio.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • msc
  • inc
Macros | Functions
at_start_f437/examples/usb_device/msc/inc/msc_diskio.h File Reference

usb mass storage disk interface header file More...

#include "usb_conf.h"
#include "usb_std.h"

Go to the source code of this file.

Macros

#define | INTERNAL_FLASH_LUN 0
#define | SPI_FLASH_LUN 1
#define | SD_LUN 2
#define | USB_FLASH_ADDR_OFFSET 0x08005000
#define | SECTOR_SIZE_1K 1024
#define | SECTOR_SIZE_2K 2048
#define | SECTOR_SIZE_4K 4096

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Detailed Description

usb mass storage disk interface header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/usb_device/msc/inc/msc_diskio.h.


AT32F435/437 Firmwary Library: msc_diskio.h Source File

  • at_start_f437
  • examples
  • usb_device
  • msc
  • inc
at_start_f437/examples/usb_device/msc/inc/msc_diskio.h
Go to the documentation of this file.
1
26/* Define to prevent recursive inclusion -------------------------------------*/
27#ifndef __MSC_DISKIO_H
28#define __MSC_DISKIO_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34
35#include "usb_conf.h"
36#include "usb_std.h"
37
45#define INTERNAL_FLASH_LUN 0
46#define SPI_FLASH_LUN 1
47#define SD_LUN 2
48
49#define USB_FLASH_ADDR_OFFSET 0x08005000
50
51#define SECTOR_SIZE_1K 1024
52#define SECTOR_SIZE_2K 2048
53#define SECTOR_SIZE_4K 4096
54
55uint8_t *get_inquiry(uint8_t lun);
56 usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len);
57 usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len);
58 usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size);
59
68#ifdef __cplusplus
69}
70#endif
71
72#endif
73
74
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:106
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:75
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:144
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:59
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
usb_std.h
usb standard header file
usb_conf.h
usb config header file


AT32F435/437 Firmwary Library: msc_diskio.c File Reference

  • at_start_f437
  • examples
  • usb_device
  • msc
  • src
Functions | Variables
at_start_f437/examples/usb_device/msc/src/msc_diskio.c File Reference

usb mass storage disk function More...

#include "msc_diskio.h"
#include "msc_bot_scsi.h"

Go to the source code of this file.

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Variables

uint32_t | sector_size = 2048
uint32_t | msc_flash_size
uint8_t | scsi_inquiry [MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]

Detailed Description

usb mass storage disk function

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/usb_device/msc/src/msc_diskio.c.


AT32F435/437 Firmwary Library: msc_diskio.c Source File

  • at_start_f437
  • examples
  • usb_device
  • msc
  • src
at_start_f437/examples/usb_device/msc/src/msc_diskio.c
Go to the documentation of this file.
1
26#include "msc_diskio.h"
27#include "msc_bot_scsi.h"
28
36uint32_t sector_size = 2048;
37uint32_t msc_flash_size;
38uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH] =
39{
40 /* lun = 0 */
41 {
42 0x00, /* peripheral device type (direct-access device) */
43 0x80, /* removable media bit */
44 0x00, /* ansi version, ecma version, iso version */
45 0x01, /* respond data format */
46 SCSI_INQUIRY_DATA_LENGTH - 5, /* additional length */
47 0x00, 0x00, 0x00, /* reserved */
48 'A', 'T', '3', '2', ' ', ' ', ' ', ' ', /* vendor information "AT32" */
49 'D', 'i', 's', 'k', '0', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', /* Product identification "Disk" */
50 '2', '.', '0', '0' /* product revision level */
51 }
52};
53
59uint8_t *get_inquiry(uint8_t lun)
60{
61 if(lun < MSC_SUPPORT_MAX_LUN)
62 return (uint8_t *)scsi_inquiry[lun];
63 else
64 return NULL;
65}
66
75 usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
76{
77 uint32_t i = 0;
78 uint32_t flash_addr = addr + USB_FLASH_ADDR_OFFSET;
79 switch(lun)
80 {
81 case INTERNAL_FLASH_LUN:
82 for(i = 0; i < len; i ++)
83 {
84 read_buf[i] = *((uint8_t *)flash_addr);
85 flash_addr += 1;
86 }
87 break;
88 case SPI_FLASH_LUN:
89 break;
90 case SD_LUN:
91 break;
92 default:
93 break;
94 }
95 return USB_OK;
96}
97
106 usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
107{
108 uint32_t flash_addr = addr + USB_FLASH_ADDR_OFFSET;
109 uint32_t i = 0, tolen = len;
110 uint32_t erase_addr = flash_addr;
111 switch(lun)
112 {
113 case INTERNAL_FLASH_LUN:
114 flash_unlock();
115 while(tolen >= sector_size)
116 {
117 flash_sector_erase(erase_addr);
118 tolen -= sector_size;
119 erase_addr += sector_size;
120 }
121 for(i = 0; i < len; i ++)
122 {
123 flash_byte_program(flash_addr+i, buf[i]);
124 }
125 flash_lock();
126 break;
127 case SPI_FLASH_LUN:
128 break;
129 case SD_LUN:
130 break;
131 default:
132 break;;
133 }
134 return USB_OK;
135}
136
144 usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
145{
146 uint32_t devid = (*((uint32_t *)DEBUG_BASE) & 0x00007000) >> 12;
147 msc_flash_size = (*((uint32_t *)0x1FFFF7E0) << 10) - (USB_FLASH_ADDR_OFFSET - FLASH_BASE);
148 switch(devid)
149 {
150 case 2:
151 sector_size = SECTOR_SIZE_1K;
152 break;
153 case 3:
154 sector_size = SECTOR_SIZE_2K;
155 break;
156 case 4:
157 sector_size = SECTOR_SIZE_4K;
158 break;
159 default:
160 sector_size = SECTOR_SIZE_2K;
161 break;
162 }
163 switch(lun)
164 {
165 case INTERNAL_FLASH_LUN:
166 *blk_nbr = msc_flash_size / sector_size;
167 *blk_size = sector_size;
168 break;
169 case SPI_FLASH_LUN:
170 break;
171 case SD_LUN:
172 break;
173 default:
174 break;
175 }
176 return USB_OK;
177}
178
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:106
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:75
USB_FLASH_ADDR_OFFSET
#define USB_FLASH_ADDR_OFFSET
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h:49
INTERNAL_FLASH_LUN
#define INTERNAL_FLASH_LUN
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h:45
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:144
msc_flash_size
uint32_t msc_flash_size
Definition: at_start_f437/examples/usb_device/msc/src/msc_diskio.c:37
sector_size
uint32_t sector_size
Definition: at_start_f437/examples/usb_device/msc/src/msc_diskio.c:36
SD_LUN
#define SD_LUN
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h:47
scsi_inquiry
uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
Definition: at_start_f437/examples/usb_device/msc/src/msc_diskio.c:38
SPI_FLASH_LUN
#define SPI_FLASH_LUN
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h:46
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:59
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f435_437_flash.c:357
flash_byte_program
flash_status_type flash_byte_program(uint32_t address, uint8_t data)
program a byte at a specified address.
Definition: at32f435_437_flash.c:679
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f435_437_flash.c:290
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f435_437_flash.c:325
DEBUG_BASE
#define DEBUG_BASE
Definition: at32f435_437.h:427
FLASH_BASE
#define FLASH_BASE
Definition: at32f435_437.h:425
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
SECTOR_SIZE_1K
#define SECTOR_SIZE_1K
Definition: hid_iap_class.h:61
SECTOR_SIZE_2K
#define SECTOR_SIZE_2K
Definition: hid_iap_class.h:62
SECTOR_SIZE_4K
#define SECTOR_SIZE_4K
Definition: hid_iap_class.h:63
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:157
MSC_SUPPORT_MAX_LUN
#define MSC_SUPPORT_MAX_LUN
Definition: cdc_msc_class.h:83
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_OK
@ USB_OK
Definition: usb_std.h:268
msc_bot_scsi.h
usb mass storage bulk-only transport and scsi command header file


AT32F435/437 Firmwary Library: usbh_user.c File Reference

  • at_start_f437
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
  • src
Functions | Variables
at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c File Reference

usb user function More...

#include "usbh_user.h"

Go to the source code of this file.

Functions

static usb_sts_type | usbh_user_init (void)
usb host init user handler More...
static usb_sts_type | usbh_user_reset (void)
usb host reset user handler More...
static usb_sts_type | usbh_user_attached (void)
usb host check device attached More...
static usb_sts_type | usbh_user_disconnect (void)
usb host discconet user handler More...
static usb_sts_type | usbh_user_speed (uint8_t speed)
usb host speed user handler More...
static usb_sts_type | usbh_user_mfc_string (void *string)
usb host manufacturer string user handler More...
static usb_sts_type | usbh_user_product_string (void *string)
usb host product string user handler More...
static usb_sts_type | usbh_user_serial_string (void *string)
usb host serial string user handler More...
static usb_sts_type | usbh_user_enumeration_done (void)
usb host enumeration done user handler More...
static usb_sts_type | usbh_user_application (void)
usb host application user handler More...
static usb_sts_type | usbh_user_active_vbus (void *uhost, confirm_state state)
usb host active vbus user handler More...
static usb_sts_type | usbh_user_not_support (void)
usb host not support user handler More...

Variables

usbh_user_handler_type usbh_user_handle

Detailed Description

usb user function

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

Function Documentation

◆ usbh_user_active_vbus()

static usb_sts_type usbh_user_active_vbus | ( | void * | uhost,
 |  | confirm_state | state
 | ) |  |
static

usb host active vbus user handler

Parameters
uhost | to the structure of usbh_core_type
state | vbus state TRUE: active vbus FALSE: deactive vbus
Return values
usb_sts_type

Definition at line 202 of file at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

◆ usbh_user_application()

static usb_sts_type usbh_user_application ( void )
static

usb host application user handler

Parameters
none
Return values
usb_sts_type

Definition at line 186 of file at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

◆ usbh_user_attached()

static usb_sts_type usbh_user_attached ( void )
static

usb host check device attached

Parameters
none
Return values
usb_sts_type

Definition at line 95 of file at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

◆ usbh_user_disconnect()

static usb_sts_type usbh_user_disconnect ( void )
static

usb host discconet user handler

Parameters
none
Return values
usb_sts_type

Definition at line 107 of file at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

◆ usbh_user_enumeration_done()

static usb_sts_type usbh_user_enumeration_done ( void )
static

usb host enumeration done user handler

Parameters
none
Return values
usb_sts_type

Definition at line 174 of file at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

◆ usbh_user_init()

static usb_sts_type usbh_user_init ( void )
static

usb host init user handler

Parameters
none
Return values
usb_sts_type

Definition at line 71 of file at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

◆ usbh_user_mfc_string()

static usb_sts_type usbh_user_mfc_string ( void * string )
static

usb host manufacturer string user handler

Parameters
none
Return values
usb_sts_type

Definition at line 138 of file at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

◆ usbh_user_not_support()

static usb_sts_type usbh_user_not_support ( void )
static

usb host not support user handler

Parameters
none
Return values
usb_sts_type

Definition at line 233 of file at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

◆ usbh_user_product_string()

static usb_sts_type usbh_user_product_string ( void * string )
static

usb host product string user handler

Parameters
none
Return values
usb_sts_type

Definition at line 150 of file at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

◆ usbh_user_reset()

static usb_sts_type usbh_user_reset ( void )
static

usb host reset user handler

Parameters
none
Return values
usb_sts_type

Definition at line 83 of file at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

◆ usbh_user_serial_string()

static usb_sts_type usbh_user_serial_string ( void * string )
static

usb host serial string user handler

Parameters
none
Return values
usb_sts_type

Definition at line 162 of file at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.

◆ usbh_user_speed()

static usb_sts_type usbh_user_speed ( uint8_t speed )
static

usb host speed user handler

Parameters
none
Return values
usb_sts_type

Definition at line 119 of file at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c.


AT32F435/437 Firmwary Library: usbh_user.c Source File

  • at_start_f437
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
  • src
at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c
Go to the documentation of this file.
1
26#include "usbh_user.h"
27
36static usb_sts_type usbh_user_init(void);
37static usb_sts_type usbh_user_reset(void);
38static usb_sts_type usbh_user_attached(void);
39static usb_sts_type usbh_user_disconnect(void);
40static usb_sts_type usbh_user_speed(uint8_t speed);
41static usb_sts_type usbh_user_mfc_string(void *string);
42static usb_sts_type usbh_user_product_string(void *string);
43static usb_sts_type usbh_user_serial_string(void *string);
44static usb_sts_type usbh_user_enumeration_done(void);
45static usb_sts_type usbh_user_application(void);
46static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state);
47static usb_sts_type usbh_user_not_support(void);
48
49
50usbh_user_handler_type usbh_user_handle =
51{
52 usbh_user_init,
53 usbh_user_reset,
54 usbh_user_attached,
55 usbh_user_disconnect,
56 usbh_user_speed,
57 usbh_user_mfc_string,
58 usbh_user_product_string,
59 usbh_user_serial_string,
60 usbh_user_enumeration_done,
61 usbh_user_application,
62 usbh_user_active_vbus,
63 usbh_user_not_support,
64};
65
71static usb_sts_type usbh_user_init(void)
72{
73 usb_sts_type status = USB_OK;
74
75 return status;
76}
77
83static usb_sts_type usbh_user_reset(void)
84{
85 usb_sts_type status = USB_OK;
86
87 return status;
88}
89
95static usb_sts_type usbh_user_attached(void)
96{
97 usb_sts_type status = USB_OK;
98 USBH_DEBUG("USB Device Attached");
99 return status;
100}
101
107static usb_sts_type usbh_user_disconnect(void)
108{
109 usb_sts_type status = USB_OK;
110 USBH_DEBUG("Device Disconnect");
111 return status;
112}
113
119static usb_sts_type usbh_user_speed(uint8_t speed)
120{
121 usb_sts_type status = USB_OK;
122 if(speed == USB_PRTSPD_FULL_SPEED)
123 {
124 USBH_DEBUG("This is a Full-Speed device");
125 }
126 else if(speed == USB_PRTSPD_LOW_SPEED)
127 {
128 USBH_DEBUG("This is a Low-Speed device");
129 }
130 return status;
131}
132
138static usb_sts_type usbh_user_mfc_string(void *string)
139{
140 usb_sts_type status = USB_OK;
141 USBH_DEBUG("Manufacturer: %s", (uint8_t *)string);
142 return status;
143}
144
150static usb_sts_type usbh_user_product_string(void *string)
151{
152 usb_sts_type status = USB_OK;
153 USBH_DEBUG("Product: %s", (uint8_t *)string);
154 return status;
155}
156
162static usb_sts_type usbh_user_serial_string(void *string)
163{
164 usb_sts_type status = USB_OK;
165 USBH_DEBUG("Serial: %s", (uint8_t *)string);
166 return status;
167}
168
174static usb_sts_type usbh_user_enumeration_done(void)
175{
176 usb_sts_type status = USB_OK;
177 USBH_DEBUG("Enumeration done");
178 return status;
179}
180
186static usb_sts_type usbh_user_application(void)
187{
188 usb_sts_type status = USB_OK;
189
190
191 return status;
192}
193
202static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state)
203{
204 usb_sts_type status = USB_OK;
205 usbh_core_type *puhost = (usbh_core_type *)uhost;
206#ifdef USBH_5V_POWER_SWITCH
207 if(state == TRUE)
208 {
209 /* active vbus */
210 if(puhost->usb_reg == OTG1_GLOBAL)
211 {
212 gpio_bits_reset(OTG_PIN_POWER_SWITCH_GPIO, OTG_PIN_POWER_SWITCH);
213 }
214
215 }
216 else
217 {
218 /* deactive vubs */
219 if(puhost->usb_reg == OTG1_GLOBAL)
220 {
221 gpio_bits_set(OTG_PIN_POWER_SWITCH_GPIO, OTG_PIN_POWER_SWITCH);
222 }
223 }
224#endif
225 return status;
226}
227
233static usb_sts_type usbh_user_not_support(void)
234{
235 usb_sts_type status = USB_OK;
236
237 return status;
238}
239
usbh_user_init
static usb_sts_type usbh_user_init(void)
usb host init user handler
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:71
usbh_user_disconnect
static usb_sts_type usbh_user_disconnect(void)
usb host discconet user handler
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:107
usbh_user_not_support
static usb_sts_type usbh_user_not_support(void)
usb host not support user handler
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:233
usbh_user_application
static usb_sts_type usbh_user_application(void)
usb host application user handler
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:186
usbh_user_speed
static usb_sts_type usbh_user_speed(uint8_t speed)
usb host speed user handler
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:119
usbh_user_active_vbus
static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state)
usb host active vbus user handler
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:202
usbh_user_serial_string
static usb_sts_type usbh_user_serial_string(void *string)
usb host serial string user handler
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:162
usbh_user_reset
static usb_sts_type usbh_user_reset(void)
usb host reset user handler
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:83
usbh_user_mfc_string
static usb_sts_type usbh_user_mfc_string(void *string)
usb host manufacturer string user handler
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:138
usbh_user_enumeration_done
static usb_sts_type usbh_user_enumeration_done(void)
usb host enumeration done user handler
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:174
usbh_user_attached
static usb_sts_type usbh_user_attached(void)
usb host check device attached
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:95
usbh_user_product_string
static usb_sts_type usbh_user_product_string(void *string)
usb host product string user handler
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:150
usbh_user.h
usb host user header file
OTG_PIN_POWER_SWITCH_GPIO
#define OTG_PIN_POWER_SWITCH_GPIO
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h:91
OTG_PIN_POWER_SWITCH
#define OTG_PIN_POWER_SWITCH
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h:93
usbh_user_handle
usbh_user_handler_type usbh_user_handle
Definition: at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:50
USBH_DEBUG
#define USBH_DEBUG(...)
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h:206
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
confirm_state
confirm_state
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f435_437_gpio.c:308
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f435_437_gpio.c:277
OTG1_GLOBAL
#define OTG1_GLOBAL
usb host and device register define
Definition: at32f435_437_usb.h:1328
USB_PRTSPD_LOW_SPEED
#define USB_PRTSPD_LOW_SPEED
Definition: at32f435_437_usb.h:188
USB_PRTSPD_FULL_SPEED
#define USB_PRTSPD_FULL_SPEED
Definition: at32f435_437_usb.h:187
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_OK
@ USB_OK
Definition: usb_std.h:268


AT32F435/437 Firmwary Library: usbh_user.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
  • src
Variables
at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.h File Reference

usb host user header file More...

#include "usbh_core.h"

Go to the source code of this file.

Variables

usbh_user_handler_type usbh_user_handle

Detailed Description

usb host user header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.h.


AT32F435/437 Firmwary Library: usbh_user.h Source File

  • at_start_f437
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
  • src
at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.h
Go to the documentation of this file.
1
26/* define to prevent recursive inclusion -------------------------------------*/
27#ifndef __USBH_USER_H
28#define __USBH_USER_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "usbh_core.h"
35
36extern usbh_user_handler_type usbh_user_handle;
37#ifdef __cplusplus
38}
39#endif
40
41#endif
42
43
usbh_user_handle
usbh_user_handler_type usbh_user_handle
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:50
usbh_core.h
usb host core header file


AT32F435/437 Firmwary Library: flash_fat16.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • virtual_msc_iap
  • inc
Data Structures | Macros | Enumerations | Functions | Variables
at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h File Reference

fat16 file system header file More...

#include "usb_conf.h"

Go to the source code of this file.

Data Structures

struct | fat_dir_type
struct | flash_iap_type

Macros

#define | FAT16_SECTOR_SIZE 62
#define | FAT16_TABLE_SIZE 4
#define | FAT16_BYTE_PER_SIZE 2048
#define | FAT16_FILENAME_SIZE 11
#define | FAT16_DIR_SIZE 47
#define | FLASH_FAT16_BOOT_SECTOR_ADDR 0x00
#define | FLASH_FAT16_1_ADDR 0x3000
#define | FLASH_FAT16_2_ADDR 0x3800
#define | FLASH_FAT16_ROOT_ADDR 0x4000
#define | FLASH_FAT16_FILE_START_ADDR 0x8800
#define | FLASH_APP_START_ADDR 0x08006000
#define | FLASH_SECTOR_1K_SIZE 0x400
#define | FLASH_SECTOR_2K_SIZE 0x800
#define | FLASH_SECTOR_4K_SIZE 0x1000
#define | FLASH_SECTOR_1K_ALLGNED 0x3FF
#define | FLASH_SECTOR_2K_ALLGNED 0x7FF
#define | FLASH_SECTOR_4K_ALLGNED 0xFFF
#define | FILE_SUFFIX1_LEN 3
#define | FILE_SUFFIX2_LEN 3
#define | FILE_SUFFIX1_NAME "BIN"
#define | FILE_SUFFIX2_NAME "bin"
#define | INVAILD_OFFSET_ADDR 0xFFFFFFFF
#define | IAP_UPGRADE_COMPLETE_FLAG 0x41544B38
#define | IAP_SUCCESS 0
#define | IAP_FAILED 1

Enumerations

enum upgrade_status_type {
UPGRADE_READY = 0 , UPGRAGE_ONGOING , UPGRADE_SUCCESS , UPGRADE_FAILED ,
UPGRADE_LARGE , UPGRADE_UNKNOWN , UPGRADE_DONE , UPGRADE_JUMP ,
UPGRADE_READY = 0 , UPGRAGE_ONGOING , UPGRADE_SUCCESS , UPGRADE_FAILED ,
UPGRADE_LARGE , UPGRADE_UNKNOWN , UPGRADE_DONE , UPGRADE_JUMP
}

Functions

uint32_t | flash_fat16_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address More...
uint32_t | flash_fat16_read (uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address More...
void | flash_fat16_init (void)
flash fat16 iap init More...
void | flash_fat16_loop_status (void)
loop status More...
uint32_t | flash_fat16_set_name (const uint8_t *file_name, uint8_t len)
set file name More...
uint8_t | flash_fat16_get_upgrade_flag (void)
get iap upgrade complete flag More...

Variables

flash_iap_type flash_iap

Detailed Description

fat16 file system header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h.


AT32F435/437 Firmwary Library: flash_fat16.h Source File

  • at_start_f437
  • examples
  • usb_device
  • virtual_msc_iap
  • inc
at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
Go to the documentation of this file.
1
26/* Define to prevent recursive inclusion -------------------------------------*/
27#ifndef __FLASH_FAT16_H
28#define __FLASH_FAT16_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34
35#include "usb_conf.h"
36
48#define FAT16_SECTOR_SIZE 62
49#define FAT16_TABLE_SIZE 4
50#define FAT16_BYTE_PER_SIZE 2048
51#define FAT16_FILENAME_SIZE 11
52#define FAT16_DIR_SIZE 47
53
54#define FLASH_FAT16_BOOT_SECTOR_ADDR 0x00
55#define FLASH_FAT16_1_ADDR 0x3000
56#define FLASH_FAT16_2_ADDR 0x3800
57#define FLASH_FAT16_ROOT_ADDR 0x4000
58#define FLASH_FAT16_FILE_START_ADDR 0x8800
59
60#define FLASH_APP_START_ADDR 0x08006000
61
62#define FLASH_SECTOR_1K_SIZE 0x400
63#define FLASH_SECTOR_2K_SIZE 0x800
64#define FLASH_SECTOR_4K_SIZE 0x1000
65
66#define FLASH_SECTOR_1K_ALLGNED 0x3FF
67#define FLASH_SECTOR_2K_ALLGNED 0x7FF
68#define FLASH_SECTOR_4K_ALLGNED 0xFFF
69
70#define FILE_SUFFIX1_LEN 3
71#define FILE_SUFFIX2_LEN 3
72#define FILE_SUFFIX1_NAME "BIN"
73#define FILE_SUFFIX2_NAME "bin"
74
75#define INVAILD_OFFSET_ADDR 0xFFFFFFFF
76#define IAP_UPGRADE_COMPLETE_FLAG 0x41544B38
77#define IAP_SUCCESS 0
78#define IAP_FAILED 1
79
80typedef enum
81{
82 UPGRADE_READY = 0,
83 UPGRAGE_ONGOING,
84 UPGRADE_SUCCESS,
85 UPGRADE_FAILED,
86 UPGRADE_LARGE,
87 UPGRADE_UNKNOWN,
88 UPGRADE_DONE,
89 UPGRADE_JUMP
90}upgrade_status_type;
91
92typedef struct
93{
94 uint8_t file_name[11];
95 uint8_t attr;
96 uint8_t res;
97 uint8_t create_time_tenth;
98 uint16_t create_time;
99 uint16_t create_data;
100 uint16_t last_access_data;
101 uint16_t clus_high;
102 uint16_t write_time;
103 uint16_t write_data;
104 uint16_t clus_low;
105 uint32_t file_size;
106}fat_dir_type;
107
108typedef struct
109{
110 uint32_t flash_base_addr;
111 uint32_t flash_app_addr;
112 uint32_t flash_size;
113 uint32_t flash_app_size;
114 uint32_t sector_size;
115 uint32_t sector_mask;
116 uint32_t firmware_length;
117 uint32_t write_crc;
118 uint32_t read_crc;
119
120 uint32_t write_addr;
121 uint32_t file_write_nr;
122 upgrade_status_type msc_up_status;
123}flash_iap_type;
124
125
126extern flash_iap_type flash_iap;
127
128uint32_t flash_fat16_write(uint32_t fat_lbk, uint8_t *data, uint32_t len);
129uint32_t flash_fat16_read(uint32_t fat_lbk, uint8_t *data, uint32_t len);
130
131void flash_fat16_init(void);
132void flash_fat16_loop_status(void);
133uint32_t flash_fat16_set_name(const uint8_t *file_name, uint8_t len);
134uint8_t flash_fat16_get_upgrade_flag(void);
135
148#ifdef __cplusplus
149}
150#endif
151
152#endif
153
154
sector_size
uint32_t sector_size
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c:36
file_write_nr
uint32_t file_write_nr
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:174
upgrade_status_type
upgrade_status_type
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:81
flash_fat16_set_name
uint32_t flash_fat16_set_name(const uint8_t *file_name, uint8_t len)
set file name
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:360
flash_fat16_get_upgrade_flag
uint8_t flash_fat16_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:270
flash_fat16_loop_status
void flash_fat16_loop_status(void)
loop status
Definition: project/at_start_f437/examples/usb_device/virtual_msc_iap/src/main.c:294
flash_iap
flash_iap_type flash_iap
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:173
flash_fat16_write
uint32_t flash_fat16_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:332
flash_fat16_init
void flash_fat16_init(void)
flash fat16 iap init
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:712
flash_fat16_read
uint32_t flash_fat16_read(uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:291
UPGRADE_LARGE
@ UPGRADE_LARGE
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:86
UPGRADE_UNKNOWN
@ UPGRADE_UNKNOWN
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:87
UPGRADE_JUMP
@ UPGRADE_JUMP
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:89
UPGRADE_FAILED
@ UPGRADE_FAILED
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:85
UPGRADE_SUCCESS
@ UPGRADE_SUCCESS
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:84
UPGRADE_READY
@ UPGRADE_READY
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:82
UPGRAGE_ONGOING
@ UPGRAGE_ONGOING
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:83
UPGRADE_DONE
@ UPGRADE_DONE
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:88
fat_dir_type
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:93
flash_iap_type
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:109
usb_conf.h
usb config header file


AT32F435/437 Firmwary Library: msc_diskio.h File Reference

  • at_start_f437
  • examples
  • usb_device
  • virtual_msc_iap
  • inc
Macros | Functions
at_start_f437/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h File Reference

usb mass storage disk interface header file More...

#include "usb_conf.h"
#include "usb_std.h"

Go to the source code of this file.

Macros

#define | INTERNAL_FLASH_LUN 0
#define | SPI_FLASH_LUN 1
#define | SD_LUN 2
#define | USB_FLASH_ADDR_OFFSET 0x08004000

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Detailed Description

usb mass storage disk interface header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h.


AT32F435/437 Firmwary Library: msc_diskio.h Source File

  • at_start_f437
  • examples
  • usb_device
  • virtual_msc_iap
  • inc
at_start_f437/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h
Go to the documentation of this file.
1
26/* Define to prevent recursive inclusion -------------------------------------*/
27#ifndef __MSC_DISKIO_H
28#define __MSC_DISKIO_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34
35#include "usb_conf.h"
36#include "usb_std.h"
37
45#define INTERNAL_FLASH_LUN 0
46#define SPI_FLASH_LUN 1
47#define SD_LUN 2
48
49#define USB_FLASH_ADDR_OFFSET 0x08004000
50
51uint8_t *get_inquiry(uint8_t lun);
52 usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len);
53 usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len);
54 usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size);
55
64#ifdef __cplusplus
65}
66#endif
67
68#endif
69
70
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:106
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:75
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:144
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:59
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
usb_std.h
usb standard header file
usb_conf.h
usb config header file


AT32F435/437 Firmwary Library: flash_fat16.c File Reference

  • at_start_f437
  • examples
  • usb_device
  • virtual_msc_iap
  • src
Macros | Functions | Variables
at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c File Reference

fat16 file system More...

#include "flash_fat16.h"
#include "usb_conf.h"

Go to the source code of this file.

Macros

#define FAT16_SECTOR_SIZE 62

Functions

uint32_t | flash_fat16_boot_dir_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
boot dir write More...
uint32_t | flash_fat16_sector_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
write sector More...
uint32_t | fat16_memory_copy (uint8_t *dst, const uint8_t *src, uint32_t len)
memory copy function More...
uint32_t | fat16_memory_memset (uint8_t *dst, uint32_t set, uint32_t len)
memset function More...
uint32_t | flash_write_data (uint32_t address, uint8_t *data, uint32_t len)
write data to flash More...
uint32_t | flash_read_data (uint32_t address, uint8_t *data, uint32_t len)
read data from flash More...
uint32_t | fat16_memory_cmp (uint8_t *dst, uint8_t *src, uint32_t len)
memory compare function More...
uint32_t | flash_crc_check (uint32_t address, uint8_t *data, uint32_t len)
crc check More...
void | flash_fat16_clear_upgrade_flag (void)
clear iap upgrade flag More...
void | flash_fat16_set_upgrade_flag (void)
set iap upgrade complete flag More...
uint8_t | flash_fat16_get_upgrade_flag (void)
get iap upgrade complete flag More...
uint32_t | flash_fat16_read (uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address More...
uint32_t | flash_fat16_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address More...
uint32_t | flash_fat16_set_name (const uint8_t *file_name, uint8_t len)
set file name More...
uint32_t | flash_fat16_addr_offset (uint8_t *file_name)
get offset address More...
void | flash_fat16_init (void)
flash fat16 iap init More...

Variables

static uint8_t | fat16_sector [62]
const uint8_t | fat16_root_dir_sector [FAT16_DIR_SIZE]
const uint8_t | fat16_table_sector0 [FAT16_TABLE_SIZE]
uint8_t | fat16_file_name [FAT16_FILENAME_SIZE]
fat_dir_type g_file_attr
flash_iap_type flash_iap
uint32_t | file_write_nr = 0
uint8_t | file_match = 0

Detailed Description

fat16 file system

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c.


AT32F435/437 Firmwary Library: flash_fat16.c Source File

  • at_start_f437
  • examples
  • usb_device
  • virtual_msc_iap
  • src
at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
Go to the documentation of this file.
1
26#include "flash_fat16.h"
27#include "usb_conf.h"
28
36#define FAT16_SECTOR_SIZE 62
37static uint8_t fat16_sector[FAT16_SECTOR_SIZE] =
38{
39 0xEB, /*0*/
40 0x3C, /*1*/
41 0x90, /*2*/
42 0x4D, /*3*/
43 0x53, /*4*/
44 0x44, /*5*/
45 0x4F, /*6*/
46 0x53, /*7*/
47 0x35, /*8*/
48 0x2E, /*9*/
49 0x30, /*10*/
50 0x00, /*11*/
51 0x08, /*12*/ //2K
52 0x04, /*13*/
53 0x06, /*14*/
54 0x00, /*15*/
55
56 0x02, /*16*/
57 0x00, /*17*/
58 0x02, /*18*/
59 0xFF, /*19*/
60 0x0F, /*20*/
61 0xF8, /*21*/
62 0x01, /*22*/
63 0x00, /*23*/
64 0x01, /*24*/
65 0x00, /*25*/
66 0x01, /*26*/
67 0x00, /*27*/
68 0x00, /*28*/
69 0x00, /*29*/
70 0x00, /*30*/
71 0x00, /*31*/
72
73 0x00, /*32*/
74 0x00, /*33*/
75 0x00, /*34*/
76 0x00, /*35*/
77 0x00, /*36*/
78 0x00, /*37*/
79 0x29, /*38*/
80 0x96, /*39*/
81 0x16, /*40*/
82 0x66, /*41*/
83 0xD3, /*42*/
84 0x20, /*43*/
85 0x20, /*44*/
86 0x20, /*45*/
87 0x20, /*46*/
88 0x20, /*47*/
89
90 0x20, /*48*/
91 0x20, /*49*/
92 0x20, /*50*/
93 0x20, /*51*/
94 0x20, /*52*/
95 0x20, /*53*/
96 0x46, /*54*/
97 0x41, /*55*/
98 0x54, /*56*/
99 0x31, /*57*/
100 0x36, /*58*/
101 0x20, /*59*/
102 0x20, /*60*/
103 0x20 /*61*/
104};
105
106
107
108const uint8_t fat16_root_dir_sector[FAT16_DIR_SIZE]=
109{
110 0x20, /*11 - Archive Attribute set */
111 0x00, /*12 - Reserved */
112 0x4B, /*13 - Create Time Tenth */
113 0x9C, /*14 - Create Time */
114 0x42, /*15 - Create Time */
115 0x92, /*16 - Create Date */
116 0x38, /*17 - Create Date */
117 0x92, /*18 - Last Access Date */
118 0x38, /*19 - Last Access Date */
119 0x00, /*20 - Not used in FAT16 */
120 0x00, /*21 - Not used in FAT16 */
121 0x9D, /*22 - Write Time */
122 0x42, /*23 - Write Time */
123 0x92, /*24 - Write Date */
124 0x38, /*25 - Write Date */
125 0x00, /*26 - First Cluster (none, because file is empty) */
126 0x00, /*27 - First Cluster (none, because file is empty) */
127 0x00, /*28 - File Size */
128 0x00, /*29 - File Size */
129 0x00, /*30 - File Size */
130 0x00, /*31 - File Size */
131 'A','T','3','2',' ','I','A','P',' ',' ',' ', /*32-42 - Volume label */
132 0x08, /*43 - File attribute = Volume label */
133 0x00, /*44 - Reserved */
134 0x00, /*45 - Create Time Tenth */
135 0x00, /*46 - Create Time */
136 0x00, /*47 - Create Time */
137 0x00, /*48 - Create Date */
138 0x00, /*49 - Create Date */
139 0x00, /*50 - Last Access Date */
140 0x00, /*51 - Last Access Date */
141 0x00, /*52 - Not used in FAT16 */
142 0x00, /*53 - Not used in FAT16 */
143 0x9D, /*54 - Write Time */
144 0x42, /*55 - Write Time */
145 0x92, /*56 - Write Date */
146 0x38, /*57 - Write Date */
147};
148
149const uint8_t fat16_table_sector0[FAT16_TABLE_SIZE] =
150{
151 0xF8,
152 0xFF,
153 0xFF,
154 0xFF
155};
156
157uint8_t fat16_file_name[FAT16_FILENAME_SIZE] =
158{
159 'R',
160 'e',
161 'a',
162 'd',
163 'y',
164 ' ',
165 ' ',
166 ' ',
167 'T',
168 'X',
169 'T'
170};
171
172 fat_dir_type g_file_attr;
173 flash_iap_type flash_iap;
174uint32_t file_write_nr = 0;
175uint8_t file_match = 0;
176
177uint32_t flash_fat16_boot_dir_write(uint32_t fat_lbk, uint8_t *data, uint32_t len);
178uint32_t flash_fat16_sector_write(uint32_t fat_lbk, uint8_t *data, uint32_t len);
179uint32_t fat16_memory_copy(uint8_t *dst, const uint8_t *src, uint32_t len);
180uint32_t fat16_memory_memset(uint8_t *dst, uint32_t set, uint32_t len);
181uint32_t flash_write_data(uint32_t address, uint8_t *data, uint32_t len);
182uint32_t flash_read_data(uint32_t address, uint8_t *data, uint32_t len);
183uint32_t fat16_memory_cmp(uint8_t *dst, uint8_t *src, uint32_t len);
184uint32_t flash_crc_check(uint32_t address, uint8_t *data, uint32_t len);
185void flash_fat16_clear_upgrade_flag(void);
186void flash_fat16_set_upgrade_flag(void);
187
195uint32_t fat16_memory_copy(uint8_t *dst, const uint8_t *src, uint32_t len)
196{
197 uint32_t i_index;
198 for(i_index = 0; i_index < len; i_index ++)
199 {
200 dst[i_index] = src[i_index];
201 }
202 return i_index;
203}
204
212uint32_t fat16_memory_memset(uint8_t *dst, uint32_t set, uint32_t len)
213{
214 uint32_t i_index;
215 for(i_index = 0; i_index < len; i_index ++)
216 {
217 dst[i_index] = (uint8_t)set;
218 }
219 return i_index;
220}
221
229uint32_t fat16_memory_cmp(uint8_t *dst, uint8_t *src, uint32_t len)
230{
231 uint32_t i_index;
232 for(i_index = 0; i_index < len; i_index ++)
233 {
234 if(dst[i_index] != src[i_index])
235 return 1;
236 }
237 return 0;
238}
239
245void flash_fat16_clear_upgrade_flag(void)
246{
247 flash_unlock();
248 flash_sector_erase(flash_iap.flash_app_addr - flash_iap.sector_size);
249 flash_lock();
250}
251
257void flash_fat16_set_upgrade_flag(void)
258{
259 flash_unlock();
260 flash_word_program(flash_iap.flash_app_addr - flash_iap.sector_size,
261 IAP_UPGRADE_COMPLETE_FLAG);
262 flash_lock();
263}
264
270uint8_t flash_fat16_get_upgrade_flag(void)
271{
272 uint32_t flag_address = flash_iap.flash_app_addr - flash_iap.sector_size;
273 if(*((uint32_t *)flag_address) == IAP_UPGRADE_COMPLETE_FLAG)
274 {
275 return IAP_SUCCESS;
276 }
277 else
278 {
279 return IAP_FAILED;
280 }
281}
282
283
291uint32_t flash_fat16_read(uint32_t fat_lbk, uint8_t *data, uint32_t len)
292{
293 uint32_t i_index = 0;
294 switch(fat_lbk)
295 {
296 case FLASH_FAT16_BOOT_SECTOR_ADDR:
297 i_index += fat16_memory_copy(data, fat16_sector, FAT16_SECTOR_SIZE);
298 i_index += 2;
299
300 fat16_memory_memset(data+i_index, 0, FAT16_BYTE_PER_SIZE-i_index);
301 data[510] = 0x55;
302 data[511] = 0xAA;
303
304 break;
305 case FLASH_FAT16_1_ADDR:
306 case FLASH_FAT16_2_ADDR:
307 i_index += fat16_memory_copy(data, fat16_table_sector0, FAT16_TABLE_SIZE);
308
309 fat16_memory_memset(data+i_index, 0, FAT16_BYTE_PER_SIZE-i_index);
310 break;
311 case FLASH_FAT16_ROOT_ADDR:
312 i_index += fat16_memory_copy(data, fat16_file_name, FAT16_FILENAME_SIZE);
313 i_index += fat16_memory_copy(data + i_index, fat16_root_dir_sector, FAT16_DIR_SIZE);
314
315 fat16_memory_memset(data+i_index, 0, FAT16_BYTE_PER_SIZE-i_index);
316 break;
317 default:
318 i_index = 0;
319 fat16_memory_memset(data+i_index, 0, FAT16_BYTE_PER_SIZE-i_index);
320 break;
321 }
322 return FAT16_BYTE_PER_SIZE;
323}
324
332uint32_t flash_fat16_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
333{
334 switch(fat_lbk)
335 {
336 case FLASH_FAT16_BOOT_SECTOR_ADDR:
337 case FLASH_FAT16_1_ADDR:
338 case FLASH_FAT16_2_ADDR:
339 break;
340 case FLASH_FAT16_ROOT_ADDR:
341 flash_fat16_boot_dir_write(fat_lbk, data, len);
342 break;
343 default:
344 if(fat_lbk >= FLASH_FAT16_FILE_START_ADDR)
345 {
346 flash_fat16_sector_write(fat_lbk, data, len);
347 }
348 break;
349
350 }
351 return len;
352}
353
360uint32_t flash_fat16_set_name(const uint8_t *file_name, uint8_t len)
361{
362 uint8_t i_index = 0;
363 for(i_index = 0; i_index < len && i_index < 8; i_index ++)
364 {
365 fat16_file_name[i_index] = file_name[i_index];
366 }
367
368 for(; i_index < 8; i_index ++)
369 {
370 fat16_file_name[i_index] = ' ';
371 }
372 return i_index;
373}
374
382uint32_t flash_fat16_boot_dir_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
383{
384 fat_dir_type *pdir = (fat_dir_type *)data;
385 uint32_t i_index = 2, loop_len = 0;
386
387 pdir ++;
388 pdir ++;
389 loop_len += 64;
390
391 while(i_index ++ < 512 && loop_len < len)
392 {
393 if((pdir->attr == 0x20) && ((pdir + 1)->attr == 0x00))
394 {
395 break;
396 }
397 else
398 {
399 pdir ++;
400 }
401 loop_len += 32;
402 }
403
404 if(i_index <= 512 && loop_len < len)
405 {
406 fat16_memory_copy((uint8_t *)&g_file_attr, (const uint8_t *)pdir, 32);
407
408 if(file_match == 1)
409 {
410 file_match = 0;
411 if(g_file_attr.file_size > 0)
412 {
413 if(flash_iap.file_write_nr >= g_file_attr.file_size)
414 {
415 /* upgrade finish */
416 flash_iap.file_write_nr = 0;
417 flash_iap.msc_up_status = UPGRADE_SUCCESS;
418
419 /* set the upgrade done flag to flash */
420 flash_fat16_set_upgrade_flag();
421 }
422 }
423 }
424 g_file_attr.write_data = 0;
425 g_file_attr.write_time = 0;
426 flash_iap.file_write_nr = 0;
427 }
428 else
429 {
430 fat16_memory_memset((uint8_t *)&g_file_attr, 0, 32);
431 }
432 return len;
433}
434
440uint32_t flash_fat16_addr_offset(uint8_t *file_name)
441{
442 uint8_t i_index = 0, offset_shift = 20;
443 uint32_t offset = 0;
444 uint8_t *pfile = file_name;
445
446 if(*pfile != 'A')
447 {
448 return INVAILD_OFFSET_ADDR;
449 }
450 pfile += 1;
451
452 for(i_index = 0; i_index < 6; i_index ++)
453 {
454 if(*pfile >= '0' && *pfile <= '9')
455 {
456 offset |= (*pfile - '0') << offset_shift;
457 }
458 else if(*pfile >= 'A' && *pfile <= 'F')
459 {
460 offset |= (*pfile - 'A' + 0xA) << offset_shift;
461 }
462 else if(*pfile >= 'a' && *pfile <= 'f')
463 {
464 offset |= (*pfile - 'a' + 0xA) << offset_shift;
465 }
466 else
467 {
468 return INVAILD_OFFSET_ADDR;
469 }
470 pfile ++;
471 offset_shift -= 4;
472 }
473
474 if((offset < (flash_iap.flash_app_addr - flash_iap.flash_base_addr)) ||
475 (offset > flash_iap.flash_size ))
476 {
477 return INVAILD_OFFSET_ADDR;
478 }
479 return offset;
480}
481
489uint32_t flash_fat16_sector_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
490{
491 uint32_t file_size = g_file_attr.file_size;
492 uint32_t flash_offset = 0;
493 uint32_t status;
494
495 /* check the suffix is .bin or .BIN*/
496 if((fat16_memory_cmp((uint8_t *)&g_file_attr.file_name[8],
497 (uint8_t *)FILE_SUFFIX1_NAME, FILE_SUFFIX1_LEN) == 0) ||
498 (fat16_memory_cmp((uint8_t *)&g_file_attr.file_name[8],
499 (uint8_t *)FILE_SUFFIX2_NAME, FILE_SUFFIX2_LEN) == 0))
500 {
501 /* check the upgrade status */
502 if(flash_iap.msc_up_status == UPGRADE_DONE || flash_iap.msc_up_status == UPGRADE_SUCCESS)
503 {
504 return 0;
505 }
506
507 if(g_file_attr.file_size == 0)
508 {
509 g_file_attr.file_size = flash_iap.flash_app_size;
510 file_match = 1;
511 }
512
513 file_size = g_file_attr.file_size;
514
515 if(flash_iap.msc_up_status == UPGRADE_READY)
516 {
517 /* get offset address from filename */
518 flash_offset = flash_fat16_addr_offset(g_file_attr.file_name);
519
520 if(flash_offset == INVAILD_OFFSET_ADDR)
521 {
522 /* use default app address */
523 flash_iap.write_addr = FLASH_APP_START_ADDR;
524 }
525 else
526 {
527 flash_iap.write_addr = flash_offset + flash_iap.flash_base_addr;
528 }
529 /* clear upgrade flag */
530 flash_fat16_clear_upgrade_flag();
531
532 flash_iap.msc_up_status = UPGRAGE_ONGOING;
533 }
534
535 if(flash_iap.flash_app_size >= g_file_attr.file_size)
536 {
537 if((flash_iap.file_write_nr + len) >= file_size)
538 {
539 len = file_size - flash_iap.file_write_nr;
540 }
541 /* write data to flash and check crc */
542 status = flash_write_data(flash_iap.write_addr + flash_iap.file_write_nr, data, len);
543
544 flash_iap.file_write_nr += len;
545
546 if(status == 0)
547 {
548 if(flash_iap.file_write_nr >= file_size)
549 {
550 /* upgrade finish */
551 flash_iap.file_write_nr = 0;
552 flash_iap.msc_up_status = UPGRADE_SUCCESS;
553
554 /* set the upgrade done flag to flash */
555 flash_fat16_set_upgrade_flag();
556 }
557 }
558 else
559 {
560 /* upgrade error */
561 flash_iap.file_write_nr = 0;
562 flash_iap.msc_up_status = UPGRADE_FAILED;
563 }
564 }
565 else
566 {
567 /* upgrade file is large than flash size */
568 flash_iap.msc_up_status = UPGRADE_LARGE;
569 }
570
571 }
572 else if((fat16_memory_cmp((uint8_t *)&g_file_attr.file_name[0],
573 (uint8_t *)"JUMP", 4) == 0))
574 {
575 /* receive jump command file */
576 flash_iap.msc_up_status = UPGRADE_JUMP;
577 }
578 else
579 {
580 /* unkonw upgrade status */
581 }
582
583 return len;
584}
585
593uint32_t flash_crc_check(uint32_t address, uint8_t *data, uint32_t len)
594{
595 uint32_t flash_crc = 0;
596 uint32_t data_crc = 0;
597 uint32_t i_index = 0;
598 uint32_t wlen = len / sizeof(uint32_t);
599 uint32_t remain_len = len % sizeof(uint32_t);
600 uint32_t *u32data = (uint32_t *)data;
601 uint32_t *flash_addr = (uint32_t *)address;
602
603 /* enable crc clock */
604 crm_periph_clock_enable(CRM_CRC_PERIPH_CLOCK, TRUE);
605
606 if(remain_len)
607 {
608 wlen += 1;
609 for(i_index = 0; i_index < (4 - remain_len); i_index ++)
610 {
611 data[len+i_index] = 0xFF;
612 }
613 }
614
615 /* calculate write buffer */
616 crc_data_reset();
617 for(i_index = 0; i_index < wlen; i_index ++)
618 {
619 data_crc = crc_one_word_calculate(u32data[i_index]);
620 }
621
622 /* calculate flash data */
623 crc_data_reset();
624 for(i_index = 0; i_index < wlen; i_index ++)
625 {
626 flash_crc = crc_one_word_calculate(*flash_addr++);
627 }
628 crm_periph_clock_enable(CRM_CRC_PERIPH_CLOCK, FALSE);
629
630 if(data_crc != flash_crc)
631 return 1;
632
633 return 0;
634
635}
636
644uint32_t flash_read_data(uint32_t address, uint8_t *data, uint32_t len)
645{
646 uint32_t i_index;
647 for(i_index = 0; i_index < len; i_index ++)
648 {
649 data[i_index] = *(uint8_t *)address;
650 address += 1;
651 }
652 return i_index;
653}
654
655
663uint32_t flash_write_data(uint32_t address, uint8_t *data, uint32_t len)
664{
665 uint32_t waddr = address;
666 uint32_t wlength = len;
667 uint32_t i_index = 0;
668 if((address + len) > flash_iap.flash_base_addr + flash_iap.flash_size)
669 {
670 return 1;
671 }
672
673 if((waddr & flash_iap.sector_mask) == 0)
674 {
675 flash_unlock();
676 if(len > flash_iap.sector_size)
677 {
678 for(; wlength >= flash_iap.sector_size; wlength -= flash_iap.sector_size)
679 {
680 flash_sector_erase(waddr);
681 waddr += flash_iap.sector_size;
682 }
683 if(wlength > 0)
684 {
685 flash_sector_erase(waddr);
686 }
687 }
688 else
689 {
690 flash_sector_erase(waddr);
691 }
692
693 flash_lock();
694 }
695
696 waddr = address;
697 flash_unlock();
698 for(i_index = 0; i_index < len; i_index ++)
699 {
700 flash_byte_program(waddr+i_index, data[i_index]);
701 }
702 flash_lock();
703
704 return flash_crc_check(address, data, len);
705}
706
712void flash_fat16_init(void)
713{
714 uint32_t flash_size = *(uint32_t *)0x1FFFF7E0;
715 uint32_t devid = (*((uint32_t *)DEBUG_BASE) & 0x00007000) >> 12;
716
717 switch(devid)
718 {
719 case 2:
720 flash_iap.sector_size = FLASH_SECTOR_1K_SIZE;
721 flash_iap.sector_mask = FLASH_SECTOR_1K_ALLGNED;
722 break;
723 case 3:
724 flash_iap.sector_size = FLASH_SECTOR_2K_SIZE;
725 flash_iap.sector_mask = FLASH_SECTOR_2K_ALLGNED;
726 break;
727 case 4:
728 flash_iap.sector_size = FLASH_SECTOR_4K_SIZE;
729 flash_iap.sector_mask = FLASH_SECTOR_4K_ALLGNED;
730 break;
731 default:
732 flash_iap.sector_size = FLASH_SECTOR_2K_SIZE;
733 flash_iap.sector_mask = FLASH_SECTOR_2K_ALLGNED;
734 break;
735 }
736
737 flash_iap.flash_base_addr = FLASH_BASE;
738 flash_iap.flash_app_addr = FLASH_APP_START_ADDR;
739 flash_iap.write_addr = FLASH_APP_START_ADDR;
740 flash_iap.flash_size = flash_size << 10;
741
742 flash_iap.flash_app_size = flash_iap.flash_size -
743 (flash_iap.flash_app_addr -
744 flash_iap.flash_base_addr);
745}
746
747
748
FAT16_SECTOR_SIZE
#define FAT16_SECTOR_SIZE
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:36
g_file_attr
fat_dir_type g_file_attr
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:172
fat16_sector
static uint8_t fat16_sector[62]
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:37
flash_read_data
uint32_t flash_read_data(uint32_t address, uint8_t *data, uint32_t len)
read data from flash
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:644
file_match
uint8_t file_match
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:175
fat16_root_dir_sector
const uint8_t fat16_root_dir_sector[FAT16_DIR_SIZE]
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:108
file_write_nr
uint32_t file_write_nr
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:174
flash_fat16_addr_offset
uint32_t flash_fat16_addr_offset(uint8_t *file_name)
get offset address
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:440
fat16_table_sector0
const uint8_t fat16_table_sector0[FAT16_TABLE_SIZE]
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:149
flash_fat16_clear_upgrade_flag
void flash_fat16_clear_upgrade_flag(void)
clear iap upgrade flag
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:245
fat16_memory_memset
uint32_t fat16_memory_memset(uint8_t *dst, uint32_t set, uint32_t len)
memset function
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:212
flash_iap
flash_iap_type flash_iap
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:173
flash_crc_check
uint32_t flash_crc_check(uint32_t address, uint8_t *data, uint32_t len)
crc check
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:593
fat16_memory_cmp
uint32_t fat16_memory_cmp(uint8_t *dst, uint8_t *src, uint32_t len)
memory compare function
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:229
flash_fat16_sector_write
uint32_t flash_fat16_sector_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
write sector
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:489
flash_fat16_set_upgrade_flag
void flash_fat16_set_upgrade_flag(void)
set iap upgrade complete flag
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:257
flash_write_data
uint32_t flash_write_data(uint32_t address, uint8_t *data, uint32_t len)
write data to flash
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:663
fat16_memory_copy
uint32_t fat16_memory_copy(uint8_t *dst, const uint8_t *src, uint32_t len)
memory copy function
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:195
flash_fat16_boot_dir_write
uint32_t flash_fat16_boot_dir_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
boot dir write
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:382
fat16_file_name
uint8_t fat16_file_name[FAT16_FILENAME_SIZE]
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:157
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
crc_data_reset
void crc_data_reset(void)
reset the crc data register.
Definition: at32f435_437_crc.c:49
crc_one_word_calculate
uint32_t crc_one_word_calculate(uint32_t data)
compute the 32-bit crc of a given data word(32-bit).
Definition: at32f435_437_crc.c:60
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_CRC_PERIPH_CLOCK
@ CRM_CRC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:113
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f435_437_flash.c:357
flash_byte_program
flash_status_type flash_byte_program(uint32_t address, uint8_t data)
program a byte at a specified address.
Definition: at32f435_437_flash.c:679
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f435_437_flash.c:290
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f435_437_flash.c:608
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f435_437_flash.c:325
DEBUG_BASE
#define DEBUG_BASE
Definition: at32f435_437.h:427
FLASH_BASE
#define FLASH_BASE
Definition: at32f435_437.h:425
FLASH_APP_START_ADDR
#define FLASH_APP_START_ADDR
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:60
FLASH_SECTOR_1K_ALLGNED
#define FLASH_SECTOR_1K_ALLGNED
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:66
flash_fat16_set_name
uint32_t flash_fat16_set_name(const uint8_t *file_name, uint8_t len)
set file name
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:360
FAT16_TABLE_SIZE
#define FAT16_TABLE_SIZE
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:49
INVAILD_OFFSET_ADDR
#define INVAILD_OFFSET_ADDR
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:75
FLASH_FAT16_2_ADDR
#define FLASH_FAT16_2_ADDR
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:56
FLASH_FAT16_1_ADDR
#define FLASH_FAT16_1_ADDR
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:55
FLASH_FAT16_ROOT_ADDR
#define FLASH_FAT16_ROOT_ADDR
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:57
FAT16_DIR_SIZE
#define FAT16_DIR_SIZE
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:52
flash_fat16_get_upgrade_flag
uint8_t flash_fat16_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:270
FLASH_SECTOR_2K_SIZE
#define FLASH_SECTOR_2K_SIZE
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:63
FILE_SUFFIX1_NAME
#define FILE_SUFFIX1_NAME
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:72
FLASH_SECTOR_4K_ALLGNED
#define FLASH_SECTOR_4K_ALLGNED
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:68
FLASH_FAT16_FILE_START_ADDR
#define FLASH_FAT16_FILE_START_ADDR
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:58
FILE_SUFFIX2_LEN
#define FILE_SUFFIX2_LEN
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:71
FLASH_SECTOR_2K_ALLGNED
#define FLASH_SECTOR_2K_ALLGNED
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:67
FLASH_FAT16_BOOT_SECTOR_ADDR
#define FLASH_FAT16_BOOT_SECTOR_ADDR
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:54
flash_fat16_write
uint32_t flash_fat16_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:332
FILE_SUFFIX1_LEN
#define FILE_SUFFIX1_LEN
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:70
FAT16_BYTE_PER_SIZE
#define FAT16_BYTE_PER_SIZE
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:50
flash_fat16_init
void flash_fat16_init(void)
flash fat16 iap init
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:712
FLASH_SECTOR_4K_SIZE
#define FLASH_SECTOR_4K_SIZE
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:64
FILE_SUFFIX2_NAME
#define FILE_SUFFIX2_NAME
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:73
FAT16_FILENAME_SIZE
#define FAT16_FILENAME_SIZE
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:51
flash_fat16_read
uint32_t flash_fat16_read(uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:291
FLASH_SECTOR_1K_SIZE
#define FLASH_SECTOR_1K_SIZE
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:62
UPGRADE_LARGE
@ UPGRADE_LARGE
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:86
UPGRADE_JUMP
@ UPGRADE_JUMP
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:89
UPGRADE_FAILED
@ UPGRADE_FAILED
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:85
UPGRADE_SUCCESS
@ UPGRADE_SUCCESS
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:84
UPGRADE_READY
@ UPGRADE_READY
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:82
UPGRAGE_ONGOING
@ UPGRAGE_ONGOING
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:83
UPGRADE_DONE
@ UPGRADE_DONE
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:88
IAP_UPGRADE_COMPLETE_FLAG
#define IAP_UPGRADE_COMPLETE_FLAG
Definition: hid_iap_class.h:78
IAP_FAILED
@ IAP_FAILED
Definition: hid_iap_class.h:89
IAP_SUCCESS
@ IAP_SUCCESS
Definition: hid_iap_class.h:87
fat_dir_type
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:93
fat_dir_type::write_data
uint16_t write_data
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:103
fat_dir_type::file_size
uint32_t file_size
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:105
fat_dir_type::write_time
uint16_t write_time
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:102
fat_dir_type::file_name
uint8_t file_name[11]
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:94
fat_dir_type::attr
uint8_t attr
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:95
flash_iap_type
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:109
flash_iap_type::flash_size
uint32_t flash_size
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:112
flash_iap_type::msc_up_status
upgrade_status_type msc_up_status
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:122
flash_iap_type::flash_base_addr
uint32_t flash_base_addr
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:110
flash_iap_type::sector_size
uint32_t sector_size
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:114
flash_iap_type::sector_mask
uint32_t sector_mask
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:115
flash_iap_type::file_write_nr
uint32_t file_write_nr
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:121
flash_iap_type::flash_app_size
uint32_t flash_app_size
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:113
flash_iap_type::write_addr
uint32_t write_addr
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:120
flash_iap_type::flash_app_addr
uint32_t flash_app_addr
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:111


AT32F435/437 Firmwary Library: msc_diskio.c File Reference

  • at_start_f437
  • examples
  • usb_device
  • virtual_msc_iap
  • src
Functions | Variables
at_start_f437/examples/usb_device/virtual_msc_iap/src/msc_diskio.c File Reference

usb mass storage disk function More...

#include "msc_diskio.h"
#include "msc_bot_scsi.h"
#include "flash_fat16.h"

Go to the source code of this file.

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Variables

uint8_t scsi_inquiry [MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]

Detailed Description

usb mass storage disk function

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/usb_device/virtual_msc_iap/src/msc_diskio.c.


AT32F435/437 Firmwary Library: msc_diskio.c Source File

  • at_start_f437
  • examples
  • usb_device
  • virtual_msc_iap
  • src
at_start_f437/examples/usb_device/virtual_msc_iap/src/msc_diskio.c
Go to the documentation of this file.
1
26#include "msc_diskio.h"
27#include "msc_bot_scsi.h"
28#include "flash_fat16.h"
29
38uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH] =
39{
40 /* lun = 0 */
41 {
42 0x00, /* peripheral device type (direct-access device) */
43 0x80, /* removable media bit */
44 0x00, /* ansi version, ecma version, iso version */
45 0x01, /* respond data format */
46 SCSI_INQUIRY_DATA_LENGTH - 5, /* additional length */
47 0x00, 0x00, 0x00, /* reserved */
48 'A', 'T', '3', '2', ' ', ' ', ' ', ' ', /* vendor information "AT32" */
49 'M', 's', 'c', ' ', 'i', 'a', 'p', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', /* Product identification "Disk" */
50 '2', '.', '0', '0' /* product revision level */
51 },
52};
53
59uint8_t *get_inquiry(uint8_t lun)
60{
61 if(lun < MSC_SUPPORT_MAX_LUN)
62 return (uint8_t *)scsi_inquiry[lun];
63 else
64 return NULL;
65}
66
75 usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
76{
77
78 switch(lun)
79 {
80 case 0:
81 flash_fat16_read(addr, read_buf, len);
82 break;
83 case 1:
84 break;
85 }
86 return USB_OK;
87}
88
97 usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
98{
99 switch(lun)
100 {
101 case 0:
102 flash_fat16_write(addr, buf, len);
103 break;
104 case 1:
105 break;
106 }
107 return USB_OK;
108}
109
117 usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
118{
119 switch(lun)
120 {
121 case INTERNAL_FLASH_LUN:
122 *blk_nbr = 0x0FFF;
123 *blk_size = FLASH_SECTOR_2K_SIZE;
124 break;
125 case SPI_FLASH_LUN:
126 break;
127 case SD_LUN:
128 break;
129 default:
130 break;
131 }
132 return USB_OK;
133}
134
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:106
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:75
INTERNAL_FLASH_LUN
#define INTERNAL_FLASH_LUN
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h:45
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:144
SD_LUN
#define SD_LUN
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h:47
SPI_FLASH_LUN
#define SPI_FLASH_LUN
Definition: at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h:46
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:59
scsi_inquiry
uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/msc_diskio.c:38
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
FLASH_SECTOR_2K_SIZE
#define FLASH_SECTOR_2K_SIZE
Definition: at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h:63
flash_fat16_write
uint32_t flash_fat16_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:332
flash_fat16_read
uint32_t flash_fat16_read(uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address
Definition: at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c:291
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:157
MSC_SUPPORT_MAX_LUN
#define MSC_SUPPORT_MAX_LUN
Definition: cdc_msc_class.h:83
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_OK
@ USB_OK
Definition: usb_std.h:268
msc_bot_scsi.h
usb mass storage bulk-only transport and scsi command header file


AT32F435/437 Firmwary Library: usbh_user.h File Reference

  • at_start_f437
  • examples
  • usb_host
  • hid_demo
  • inc
Variables
at_start_f437/examples/usb_host/hid_demo/inc/usbh_user.h File Reference

usb host user header file More...

#include "usbh_core.h"

Go to the source code of this file.

Variables

usbh_user_handler_type usbh_user_handle

Detailed Description

usb host user header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/usb_host/hid_demo/inc/usbh_user.h.


AT32F435/437 Firmwary Library: usbh_user.h Source File

  • at_start_f437
  • examples
  • usb_host
  • hid_demo
  • inc
at_start_f437/examples/usb_host/hid_demo/inc/usbh_user.h
Go to the documentation of this file.
1
26/* define to prevent recursive inclusion -------------------------------------*/
27#ifndef __USBH_USER_H
28#define __USBH_USER_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "usbh_core.h"
35
36extern usbh_user_handler_type usbh_user_handle;
37#ifdef __cplusplus
38}
39#endif
40
41#endif
42
43
usbh_user_handle
usbh_user_handler_type usbh_user_handle
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:50
usbh_core.h
usb host core header file


AT32F435/437 Firmwary Library: usbh_user.c File Reference

  • at_start_f437
  • examples
  • usb_host
  • hid_demo
  • src
Functions | Variables
at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c File Reference

usb user function More...

#include "usbh_user.h"

Go to the source code of this file.

Functions

static usb_sts_type | usbh_user_init (void)
usb host init user handler More...
static usb_sts_type | usbh_user_reset (void)
usb host reset user handler More...
static usb_sts_type | usbh_user_attached (void)
usb host check device attached More...
static usb_sts_type | usbh_user_disconnect (void)
usb host discconet user handler More...
static usb_sts_type | usbh_user_speed (uint8_t speed)
usb host speed user handler More...
static usb_sts_type | usbh_user_mfc_string (void *string)
usb host manufacturer string user handler More...
static usb_sts_type | usbh_user_product_string (void *string)
usb host product string user handler More...
static usb_sts_type | usbh_user_serial_string (void *string)
usb host serial string user handler More...
static usb_sts_type | usbh_user_enumeration_done (void)
usb host enumeration done user handler More...
static usb_sts_type | usbh_user_application (void)
usb host application user handler More...
static usb_sts_type | usbh_user_active_vbus (void *uhost, confirm_state state)
usb host active vbus user handler More...
static usb_sts_type | usbh_user_not_support (void)
usb host not support user handler More...

Variables

usbh_user_handler_type usbh_user_handle

Detailed Description

usb user function

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c.

Function Documentation

◆ usbh_user_active_vbus()

static usb_sts_type usbh_user_active_vbus | ( | void * | uhost,
 |  | confirm_state | state
 | ) |  |
static

usb host active vbus user handler

Parameters
uhost | to the structure of usbh_core_type
state | vbus state TRUE: active vbus FALSE: deactive vbus
Return values
usb_sts_type

Definition at line 202 of file at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c.

◆ usbh_user_application()

static usb_sts_type usbh_user_application ( void )
static

usb host application user handler

Parameters
none
Return values
usb_sts_type

Definition at line 186 of file at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c.

◆ usbh_user_attached()

static usb_sts_type usbh_user_attached ( void )
static

usb host check device attached

Parameters
none
Return values
usb_sts_type

Definition at line 95 of file at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c.

◆ usbh_user_disconnect()

static usb_sts_type usbh_user_disconnect ( void )
static

usb host discconet user handler

Parameters
none
Return values
usb_sts_type

Definition at line 107 of file at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c.

◆ usbh_user_enumeration_done()

static usb_sts_type usbh_user_enumeration_done ( void )
static

usb host enumeration done user handler

Parameters
none
Return values
usb_sts_type

Definition at line 174 of file at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c.

◆ usbh_user_init()

static usb_sts_type usbh_user_init ( void )
static

usb host init user handler

Parameters
none
Return values
usb_sts_type

Definition at line 71 of file at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c.

◆ usbh_user_mfc_string()

static usb_sts_type usbh_user_mfc_string ( void * string )
static

usb host manufacturer string user handler

Parameters
none
Return values
usb_sts_type

Definition at line 138 of file at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c.

◆ usbh_user_not_support()

static usb_sts_type usbh_user_not_support ( void )
static

usb host not support user handler

Parameters
none
Return values
usb_sts_type

Definition at line 225 of file at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c.

◆ usbh_user_product_string()

static usb_sts_type usbh_user_product_string ( void * string )
static

usb host product string user handler

Parameters
none
Return values
usb_sts_type

Definition at line 150 of file at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c.

◆ usbh_user_reset()

static usb_sts_type usbh_user_reset ( void )
static

usb host reset user handler

Parameters
none
Return values
usb_sts_type

Definition at line 83 of file at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c.

◆ usbh_user_serial_string()

static usb_sts_type usbh_user_serial_string ( void * string )
static

usb host serial string user handler

Parameters
none
Return values
usb_sts_type

Definition at line 162 of file at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c.

◆ usbh_user_speed()

static usb_sts_type usbh_user_speed ( uint8_t speed )
static

usb host speed user handler

Parameters
none
Return values
usb_sts_type

Definition at line 119 of file at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c.


AT32F435/437 Firmwary Library: usbh_user.c Source File

  • at_start_f437
  • examples
  • usb_host
  • hid_demo
  • src
at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c
Go to the documentation of this file.
1
26#include "usbh_user.h"
27
36static usb_sts_type usbh_user_init(void);
37static usb_sts_type usbh_user_reset(void);
38static usb_sts_type usbh_user_attached(void);
39static usb_sts_type usbh_user_disconnect(void);
40static usb_sts_type usbh_user_speed(uint8_t speed);
41static usb_sts_type usbh_user_mfc_string(void *string);
42static usb_sts_type usbh_user_product_string(void *string);
43static usb_sts_type usbh_user_serial_string(void *string);
44static usb_sts_type usbh_user_enumeration_done(void);
45static usb_sts_type usbh_user_application(void);
46static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state);
47static usb_sts_type usbh_user_not_support(void);
48
49
50usbh_user_handler_type usbh_user_handle =
51{
52 usbh_user_init,
53 usbh_user_reset,
54 usbh_user_attached,
55 usbh_user_disconnect,
56 usbh_user_speed,
57 usbh_user_mfc_string,
58 usbh_user_product_string,
59 usbh_user_serial_string,
60 usbh_user_enumeration_done,
61 usbh_user_application,
62 usbh_user_active_vbus,
63 usbh_user_not_support,
64};
65
71static usb_sts_type usbh_user_init(void)
72{
73 usb_sts_type status = USB_OK;
74
75 return status;
76}
77
83static usb_sts_type usbh_user_reset(void)
84{
85 usb_sts_type status = USB_OK;
86
87 return status;
88}
89
95static usb_sts_type usbh_user_attached(void)
96{
97 usb_sts_type status = USB_OK;
98 USBH_DEBUG("USB Device Attached");
99 return status;
100}
101
107static usb_sts_type usbh_user_disconnect(void)
108{
109 usb_sts_type status = USB_OK;
110 USBH_DEBUG("Device Disconnect");
111 return status;
112}
113
119static usb_sts_type usbh_user_speed(uint8_t speed)
120{
121 usb_sts_type status = USB_OK;
122 if(speed == USB_PRTSPD_FULL_SPEED)
123 {
124 USBH_DEBUG("This is a Full-Speed device");
125 }
126 else if(speed == USB_PRTSPD_LOW_SPEED)
127 {
128 USBH_DEBUG("This is a Low-Speed device");
129 }
130 return status;
131}
132
138static usb_sts_type usbh_user_mfc_string(void *string)
139{
140 usb_sts_type status = USB_OK;
141 USBH_DEBUG("Manufacturer: %s", (uint8_t *)string);
142 return status;
143}
144
150static usb_sts_type usbh_user_product_string(void *string)
151{
152 usb_sts_type status = USB_OK;
153 USBH_DEBUG("Product: %s", (uint8_t *)string);
154 return status;
155}
156
162static usb_sts_type usbh_user_serial_string(void *string)
163{
164 usb_sts_type status = USB_OK;
165 USBH_DEBUG("Serial: %s", (uint8_t *)string);
166 return status;
167}
168
174static usb_sts_type usbh_user_enumeration_done(void)
175{
176 usb_sts_type status = USB_OK;
177 USBH_DEBUG("Enumeration done");
178 return status;
179}
180
186static usb_sts_type usbh_user_application(void)
187{
188 usb_sts_type status = USB_OK;
189
190 return status;
191}
192
193
202static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state)
203{
204 usb_sts_type status = USB_OK;
205#ifdef USBH_5V_POWER_SWITCH
206 if(state == TRUE)
207 {
208 /* active vbus */
209 gpio_bits_reset(OTG_PIN_POWER_SWITCH_GPIO, OTG_PIN_POWER_SWITCH);
210 }
211 else
212 {
213 /* deactive vubs */
214 gpio_bits_set(OTG_PIN_POWER_SWITCH_GPIO, OTG_PIN_POWER_SWITCH);
215 }
216#endif
217 return status;
218}
219
225static usb_sts_type usbh_user_not_support(void)
226{
227 usb_sts_type status = USB_OK;
228
229 return status;
230}
231
usbh_user_init
static usb_sts_type usbh_user_init(void)
usb host init user handler
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:71
usbh_user_disconnect
static usb_sts_type usbh_user_disconnect(void)
usb host discconet user handler
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:107
usbh_user_not_support
static usb_sts_type usbh_user_not_support(void)
usb host not support user handler
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:225
usbh_user_application
static usb_sts_type usbh_user_application(void)
usb host application user handler
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:186
usbh_user_speed
static usb_sts_type usbh_user_speed(uint8_t speed)
usb host speed user handler
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:119
usbh_user_active_vbus
static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state)
usb host active vbus user handler
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:202
usbh_user_serial_string
static usb_sts_type usbh_user_serial_string(void *string)
usb host serial string user handler
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:162
usbh_user_reset
static usb_sts_type usbh_user_reset(void)
usb host reset user handler
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:83
usbh_user_mfc_string
static usb_sts_type usbh_user_mfc_string(void *string)
usb host manufacturer string user handler
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:138
usbh_user_enumeration_done
static usb_sts_type usbh_user_enumeration_done(void)
usb host enumeration done user handler
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:174
usbh_user_attached
static usb_sts_type usbh_user_attached(void)
usb host check device attached
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:95
usbh_user_product_string
static usb_sts_type usbh_user_product_string(void *string)
usb host product string user handler
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:150
OTG_PIN_POWER_SWITCH_GPIO
#define OTG_PIN_POWER_SWITCH_GPIO
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h:91
OTG_PIN_POWER_SWITCH
#define OTG_PIN_POWER_SWITCH
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h:93
USBH_DEBUG
#define USBH_DEBUG(...)
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h:206
usbh_user_handle
usbh_user_handler_type usbh_user_handle
Definition: at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c:50
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
confirm_state
confirm_state
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f435_437_gpio.c:308
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f435_437_gpio.c:277
USB_PRTSPD_LOW_SPEED
#define USB_PRTSPD_LOW_SPEED
Definition: at32f435_437_usb.h:188
USB_PRTSPD_FULL_SPEED
#define USB_PRTSPD_FULL_SPEED
Definition: at32f435_437_usb.h:187
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_OK
@ USB_OK
Definition: usb_std.h:268


AT32F435/437 Firmwary Library: ffconf.h File Reference

  • at_start_f437
  • examples
  • usb_host
  • msc_only_fat32
  • inc
Macros
at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h File Reference

Go to the source code of this file.

Macros

#define | FFCONF_DEF 86631 /* Revision ID */
#define | FF_FS_READONLY 0
#define | FF_FS_MINIMIZE 0
#define | FF_USE_FIND 0
#define | FF_USE_MKFS 0
#define | FF_USE_FASTSEEK 0
#define | FF_USE_EXPAND 0
#define | FF_USE_CHMOD 0
#define | FF_USE_LABEL 0
#define | FF_USE_FORWARD 0
#define | FF_USE_STRFUNC 0
#define | FF_PRINT_LLI 0
#define | FF_PRINT_FLOAT 0
#define | FF_STRF_ENCODE 0
#define | FF_CODE_PAGE 932
#define | FF_USE_LFN 0
#define | FF_MAX_LFN 255
#define | FF_LFN_UNICODE 0
#define | FF_LFN_BUF 255
#define | FF_SFN_BUF 12
#define | FF_FS_RPATH 0
#define | FF_VOLUMES 1
#define | FF_STR_VOLUME_ID 0
#define | FF_VOLUME_STRS "RAM","NAND","CF","SD","SD2","USB","USB2","USB3"
#define | FF_MULTI_PARTITION 0
#define | FF_MIN_SS 512
#define | FF_MAX_SS 512
#define | FF_LBA64 0
#define | FF_MIN_GPT 0x10000000
#define | FF_USE_TRIM 0
#define | FF_FS_TINY 0
#define | FF_FS_EXFAT 0
#define | FF_FS_NORTC 0
#define | FF_NORTC_MON 1
#define | FF_NORTC_MDAY 1
#define | FF_NORTC_YEAR 2020
#define | FF_FS_NOFSINFO 0
#define | FF_FS_LOCK 0
#define | FF_FS_REENTRANT 0
#define | FF_FS_TIMEOUT 1000
#define | FF_SYNC_t HANDLE

Macro Definition Documentation

◆ FF_CODE_PAGE

#define FF_CODE_PAGE 932

Definition at line 87 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_FS_EXFAT

#define FF_FS_EXFAT 0

Definition at line 234 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_FS_LOCK

#define FF_FS_LOCK 0

Definition at line 266 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_FS_MINIMIZE

#define FF_FS_MINIMIZE 0

Definition at line 18 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_FS_NOFSINFO

#define FF_FS_NOFSINFO 0

Definition at line 254 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_FS_NORTC

#define FF_FS_NORTC 0

Definition at line 240 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_FS_READONLY

#define FF_FS_READONLY 0

Definition at line 11 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_FS_REENTRANT

#define FF_FS_REENTRANT 0

Definition at line 279 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_FS_RPATH

#define FF_FS_RPATH 0

Definition at line 156 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_FS_TIMEOUT

#define FF_FS_TIMEOUT 1000

Definition at line 280 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_FS_TINY

#define FF_FS_TINY 0

Definition at line 227 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_LBA64

#define FF_LBA64 0

Definition at line 206 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_LFN_BUF

#define FF_LFN_BUF 255

Definition at line 148 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_LFN_UNICODE

#define FF_LFN_UNICODE 0

Definition at line 136 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_MAX_LFN

#define FF_MAX_LFN 255

Definition at line 117 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_MAX_SS

#define FF_MAX_SS 512

Definition at line 197 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_MIN_GPT

#define FF_MIN_GPT 0x10000000

Definition at line 211 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_MIN_SS

#define FF_MIN_SS 512

Definition at line 196 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_MULTI_PARTITION

#define FF_MULTI_PARTITION 0

Definition at line 187 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_NORTC_MDAY

#define FF_NORTC_MDAY 1

Definition at line 242 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_NORTC_MON

#define FF_NORTC_MON 1

Definition at line 241 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_NORTC_YEAR

#define FF_NORTC_YEAR 2020

Definition at line 243 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_PRINT_FLOAT

#define FF_PRINT_FLOAT 0

Definition at line 61 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_PRINT_LLI

#define FF_PRINT_LLI 0

Definition at line 60 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_SFN_BUF

#define FF_SFN_BUF 12

Definition at line 149 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_STR_VOLUME_ID

#define FF_STR_VOLUME_ID 0

Definition at line 173 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_STRF_ENCODE

#define FF_STRF_ENCODE 0

Definition at line 62 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_SYNC_t

#define FF_SYNC_t HANDLE

Definition at line 281 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_USE_CHMOD

#define FF_USE_CHMOD 0

Definition at line 45 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_USE_EXPAND

#define FF_USE_EXPAND 0

Definition at line 41 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_USE_FASTSEEK

#define FF_USE_FASTSEEK 0

Definition at line 37 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_USE_FIND

#define FF_USE_FIND 0

Definition at line 28 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_USE_FORWARD

#define FF_USE_FORWARD 0

Definition at line 55 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_USE_LABEL

#define FF_USE_LABEL 0

Definition at line 50 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_USE_LFN

#define FF_USE_LFN 0

Definition at line 116 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_USE_MKFS

#define FF_USE_MKFS 0

Definition at line 33 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_USE_STRFUNC

#define FF_USE_STRFUNC 0

Definition at line 59 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_USE_TRIM

#define FF_USE_TRIM 0

Definition at line 216 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_VOLUME_STRS

#define FF_VOLUME_STRS "RAM","NAND","CF","SD","SD2","USB","USB2","USB3"

Definition at line 174 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FF_VOLUMES

#define FF_VOLUMES 1

Definition at line 169 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.

◆ FFCONF_DEF

#define FFCONF_DEF 86631 /* Revision ID */

Definition at line 5 of file at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h.


AT32F435/437 Firmwary Library: ffconf.h Source File

  • at_start_f437
  • examples
  • usb_host
  • msc_only_fat32
  • inc
at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h
Go to the documentation of this file.
1/*---------------------------------------------------------------------------/
2/ FatFs Functional Configurations
3/---------------------------------------------------------------------------*/
4
5#define FFCONF_DEF 86631 /* Revision ID */
6
7/*---------------------------------------------------------------------------/
8/ Function Configurations
9/---------------------------------------------------------------------------*/
10
11#define FF_FS_READONLY 0
12/* This option switches read-only configuration. (0:Read/Write or 1:Read-only)
13/ Read-only configuration removes writing API functions, f_write(), f_sync(),
14/ f_unlink(), f_mkdir(), f_chmod(), f_rename(), f_truncate(), f_getfree()
15/ and optional writing functions as well. */
16
17
18#define FF_FS_MINIMIZE 0
19/* This option defines minimization level to remove some basic API functions.
20/
21/ 0: Basic functions are fully enabled.
22/ 1: f_stat(), f_getfree(), f_unlink(), f_mkdir(), f_truncate() and f_rename()
23/ are removed.
24/ 2: f_opendir(), f_readdir() and f_closedir() are removed in addition to 1.
25/ 3: f_lseek() function is removed in addition to 2. */
26
27
28#define FF_USE_FIND 0
29/* This option switches filtered directory read functions, f_findfirst() and
30/ f_findnext(). (0:Disable, 1:Enable 2:Enable with matching altname[] too) */
31
32
33#define FF_USE_MKFS 0
34/* This option switches f_mkfs() function. (0:Disable or 1:Enable) */
35
36
37#define FF_USE_FASTSEEK 0
38/* This option switches fast seek function. (0:Disable or 1:Enable) */
39
40
41#define FF_USE_EXPAND 0
42/* This option switches f_expand function. (0:Disable or 1:Enable) */
43
44
45#define FF_USE_CHMOD 0
46/* This option switches attribute manipulation functions, f_chmod() and f_utime().
47/ (0:Disable or 1:Enable) Also FF_FS_READONLY needs to be 0 to enable this option. */
48
49
50#define FF_USE_LABEL 0
51/* This option switches volume label functions, f_getlabel() and f_setlabel().
52/ (0:Disable or 1:Enable) */
53
54
55#define FF_USE_FORWARD 0
56/* This option switches f_forward() function. (0:Disable or 1:Enable) */
57
58
59#define FF_USE_STRFUNC 0
60#define FF_PRINT_LLI 0
61#define FF_PRINT_FLOAT 0
62#define FF_STRF_ENCODE 0
63/* FF_USE_STRFUNC switches string functions, f_gets(), f_putc(), f_puts() and
64/ f_printf().
65/
66/ 0: Disable. FF_PRINT_LLI, FF_PRINT_FLOAT and FF_STRF_ENCODE have no effect.
67/ 1: Enable without LF-CRLF conversion.
68/ 2: Enable with LF-CRLF conversion.
69/
70/ FF_PRINT_LLI = 1 makes f_printf() support long long argument and FF_PRINT_FLOAT = 1/2
71 makes f_printf() support floating point argument. These features want C99 or later.
72/ When FF_LFN_UNICODE >= 1 with LFN enabled, string functions convert the character
73/ encoding in it. FF_STRF_ENCODE selects assumption of character encoding ON THE FILE
74/ to be read/written via those functions.
75/
76/ 0: ANSI/OEM in current CP
77/ 1: Unicode in UTF-16LE
78/ 2: Unicode in UTF-16BE
79/ 3: Unicode in UTF-8
80*/
81
82
83/*---------------------------------------------------------------------------/
84/ Locale and Namespace Configurations
85/---------------------------------------------------------------------------*/
86
87#define FF_CODE_PAGE 932
88/* This option specifies the OEM code page to be used on the target system.
89/ Incorrect code page setting can cause a file open failure.
90/
91/ 437 - U.S.
92/ 720 - Arabic
93/ 737 - Greek
94/ 771 - KBL
95/ 775 - Baltic
96/ 850 - Latin 1
97/ 852 - Latin 2
98/ 855 - Cyrillic
99/ 857 - Turkish
100/ 860 - Portuguese
101/ 861 - Icelandic
102/ 862 - Hebrew
103/ 863 - Canadian French
104/ 864 - Arabic
105/ 865 - Nordic
106/ 866 - Russian
107/ 869 - Greek 2
108/ 932 - Japanese (DBCS)
109/ 936 - Simplified Chinese (DBCS)
110/ 949 - Korean (DBCS)
111/ 950 - Traditional Chinese (DBCS)
112/ 0 - Include all code pages above and configured by f_setcp()
113*/
114
115
116#define FF_USE_LFN 0
117#define FF_MAX_LFN 255
118/* The FF_USE_LFN switches the support for LFN (long file name).
119/
120/ 0: Disable LFN. FF_MAX_LFN has no effect.
121/ 1: Enable LFN with static working buffer on the BSS. Always NOT thread-safe.
122/ 2: Enable LFN with dynamic working buffer on the STACK.
123/ 3: Enable LFN with dynamic working buffer on the HEAP.
124/
125/ To enable the LFN, ffunicode.c needs to be added to the project. The LFN function
126/ requiers certain internal working buffer occupies (FF_MAX_LFN + 1) * 2 bytes and
127/ additional (FF_MAX_LFN + 44) / 15 * 32 bytes when exFAT is enabled.
128/ The FF_MAX_LFN defines size of the working buffer in UTF-16 code unit and it can
129/ be in range of 12 to 255. It is recommended to be set it 255 to fully support LFN
130/ specification.
131/ When use stack for the working buffer, take care on stack overflow. When use heap
132/ memory for the working buffer, memory management functions, ff_memalloc() and
133/ ff_memfree() exemplified in ffsystem.c, need to be added to the project. */
134
135
136#define FF_LFN_UNICODE 0
137/* This option switches the character encoding on the API when LFN is enabled.
138/
139/ 0: ANSI/OEM in current CP (TCHAR = char)
140/ 1: Unicode in UTF-16 (TCHAR = WCHAR)
141/ 2: Unicode in UTF-8 (TCHAR = char)
142/ 3: Unicode in UTF-32 (TCHAR = DWORD)
143/
144/ Also behavior of string I/O functions will be affected by this option.
145/ When LFN is not enabled, this option has no effect. */
146
147
148#define FF_LFN_BUF 255
149#define FF_SFN_BUF 12
150/* This set of options defines size of file name members in the FILINFO structure
151/ which is used to read out directory items. These values should be suffcient for
152/ the file names to read. The maximum possible length of the read file name depends
153/ on character encoding. When LFN is not enabled, these options have no effect. */
154
155
156#define FF_FS_RPATH 0
157/* This option configures support for relative path.
158/
159/ 0: Disable relative path and remove related functions.
160/ 1: Enable relative path. f_chdir() and f_chdrive() are available.
161/ 2: f_getcwd() function is available in addition to 1.
162*/
163
164
165/*---------------------------------------------------------------------------/
166/ Drive/Volume Configurations
167/---------------------------------------------------------------------------*/
168
169#define FF_VOLUMES 1
170/* Number of volumes (logical drives) to be used. (1-10) */
171
172
173#define FF_STR_VOLUME_ID 0
174#define FF_VOLUME_STRS "RAM","NAND","CF","SD","SD2","USB","USB2","USB3"
175/* FF_STR_VOLUME_ID switches support for volume ID in arbitrary strings.
176/ When FF_STR_VOLUME_ID is set to 1 or 2, arbitrary strings can be used as drive
177/ number in the path name. FF_VOLUME_STRS defines the volume ID strings for each
178/ logical drives. Number of items must not be less than FF_VOLUMES. Valid
179/ characters for the volume ID strings are A-Z, a-z and 0-9, however, they are
180/ compared in case-insensitive. If FF_STR_VOLUME_ID >= 1 and FF_VOLUME_STRS is
181/ not defined, a user defined volume string table needs to be defined as:
182/
183/ const char* VolumeStr[FF_VOLUMES] = {"ram","flash","sd","usb",...
184*/
185
186
187#define FF_MULTI_PARTITION 0
188/* This option switches support for multiple volumes on the physical drive.
189/ By default (0), each logical drive number is bound to the same physical drive
190/ number and only an FAT volume found on the physical drive will be mounted.
191/ When this function is enabled (1), each logical drive number can be bound to
192/ arbitrary physical drive and partition listed in the VolToPart[]. Also f_fdisk()
193/ funciton will be available. */
194
195
196#define FF_MIN_SS 512
197#define FF_MAX_SS 512
198/* This set of options configures the range of sector size to be supported. (512,
199/ 1024, 2048 or 4096) Always set both 512 for most systems, generic memory card and
200/ harddisk, but a larger value may be required for on-board flash memory and some
201/ type of optical media. When FF_MAX_SS is larger than FF_MIN_SS, FatFs is configured
202/ for variable sector size mode and disk_ioctl() function needs to implement
203/ GET_SECTOR_SIZE command. */
204
205
206#define FF_LBA64 0
207/* This option switches support for 64-bit LBA. (0:Disable or 1:Enable)
208/ To enable the 64-bit LBA, also exFAT needs to be enabled. (FF_FS_EXFAT == 1) */
209
210
211#define FF_MIN_GPT 0x10000000
212/* Minimum number of sectors to switch GPT as partitioning format in f_mkfs and
213/ f_fdisk function. 0x100000000 max. This option has no effect when FF_LBA64 == 0. */
214
215
216#define FF_USE_TRIM 0
217/* This option switches support for ATA-TRIM. (0:Disable or 1:Enable)
218/ To enable Trim function, also CTRL_TRIM command should be implemented to the
219/ disk_ioctl() function. */
220
221
222
223/*---------------------------------------------------------------------------/
224/ System Configurations
225/---------------------------------------------------------------------------*/
226
227#define FF_FS_TINY 0
228/* This option switches tiny buffer configuration. (0:Normal or 1:Tiny)
229/ At the tiny configuration, size of file object (FIL) is shrinked FF_MAX_SS bytes.
230/ Instead of private sector buffer eliminated from the file object, common sector
231/ buffer in the filesystem object (FATFS) is used for the file data transfer. */
232
233
234#define FF_FS_EXFAT 0
235/* This option switches support for exFAT filesystem. (0:Disable or 1:Enable)
236/ To enable exFAT, also LFN needs to be enabled. (FF_USE_LFN >= 1)
237/ Note that enabling exFAT discards ANSI C (C89) compatibility. */
238
239
240#define FF_FS_NORTC 0
241#define FF_NORTC_MON 1
242#define FF_NORTC_MDAY 1
243#define FF_NORTC_YEAR 2020
244/* The option FF_FS_NORTC switches timestamp functiton. If the system does not have
245/ any RTC function or valid timestamp is not needed, set FF_FS_NORTC = 1 to disable
246/ the timestamp function. Every object modified by FatFs will have a fixed timestamp
247/ defined by FF_NORTC_MON, FF_NORTC_MDAY and FF_NORTC_YEAR in local time.
248/ To enable timestamp function (FF_FS_NORTC = 0), get_fattime() function need to be
249/ added to the project to read current time form real-time clock. FF_NORTC_MON,
250/ FF_NORTC_MDAY and FF_NORTC_YEAR have no effect.
251/ These options have no effect in read-only configuration (FF_FS_READONLY = 1). */
252
253
254#define FF_FS_NOFSINFO 0
255/* If you need to know correct free space on the FAT32 volume, set bit 0 of this
256/ option, and f_getfree() function at first time after volume mount will force
257/ a full FAT scan. Bit 1 controls the use of last allocated cluster number.
258/
259/ bit0=0: Use free cluster count in the FSINFO if available.
260/ bit0=1: Do not trust free cluster count in the FSINFO.
261/ bit1=0: Use last allocated cluster number in the FSINFO if available.
262/ bit1=1: Do not trust last allocated cluster number in the FSINFO.
263*/
264
265
266#define FF_FS_LOCK 0
267/* The option FF_FS_LOCK switches file lock function to control duplicated file open
268/ and illegal operation to open objects. This option must be 0 when FF_FS_READONLY
269/ is 1.
270/
271/ 0: Disable file lock function. To avoid volume corruption, application program
272/ should avoid illegal open, remove and rename to the open objects.
273/ >0: Enable file lock function. The value defines how many files/sub-directories
274/ can be opened simultaneously under file lock control. Note that the file
275/ lock control is independent of re-entrancy. */
276
277
278/* #include <somertos.h> // O/S definitions */
279#define FF_FS_REENTRANT 0
280#define FF_FS_TIMEOUT 1000
281#define FF_SYNC_t HANDLE
282/* The option FF_FS_REENTRANT switches the re-entrancy (thread safe) of the FatFs
283/ module itself. Note that regardless of this option, file access to different
284/ volume is always re-entrant and volume control functions, f_mount(), f_mkfs()
285/ and f_fdisk() function, are always not re-entrant. Only file/directory access
286/ to the same volume is under control of this function.
287/
288/ 0: Disable re-entrancy. FF_FS_TIMEOUT and FF_SYNC_t have no effect.
289/ 1: Enable re-entrancy. Also user provided synchronization handlers,
290/ ff_req_grant(), ff_rel_grant(), ff_del_syncobj() and ff_cre_syncobj()
291/ function, must be added to the project. Samples are available in
292/ option/syscall.c.
293/
294/ The FF_FS_TIMEOUT defines timeout period in unit of time tick.
295/ The FF_SYNC_t defines O/S dependent sync object type. e.g. HANDLE, ID, OS_EVENT*,
296/ SemaphoreHandle_t and etc. A header file for O/S definitions needs to be
297/ included somewhere in the scope of ff.h. */
298
299
300
301/*--- End of configuration options ---*/


AT32F435/437 Firmwary Library: usbh_user.h File Reference

  • at_start_f437
  • examples
  • usb_host
  • msc_only_fat32
  • inc
Variables
at_start_f437/examples/usb_host/msc_only_fat32/inc/usbh_user.h File Reference

usb host user header file More...

#include "usbh_core.h"

Go to the source code of this file.

Variables

usbh_user_handler_type usbh_user_handle

Detailed Description

usb host user header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/usb_host/msc_only_fat32/inc/usbh_user.h.


AT32F435/437 Firmwary Library: usbh_user.h Source File

  • at_start_f437
  • examples
  • usb_host
  • msc_only_fat32
  • inc
at_start_f437/examples/usb_host/msc_only_fat32/inc/usbh_user.h
Go to the documentation of this file.
1
26/* define to prevent recursive inclusion -------------------------------------*/
27#ifndef __USBH_USER_H
28#define __USBH_USER_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "usbh_core.h"
35
36extern usbh_user_handler_type usbh_user_handle;
37#ifdef __cplusplus
38}
39#endif
40
41#endif
42
43
usbh_user_handle
usbh_user_handler_type usbh_user_handle
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:50
usbh_core.h
usb host core header file


AT32F435/437 Firmwary Library: usbh_msc_diskio.c File Reference

  • at_start_f437
  • examples
  • usb_host
  • msc_only_fat32
  • src
Macros | Functions | Variables
at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c File Reference

usb mass storage disk io More...

#include "ff.h"
#include "diskio.h"
#include "usb_core.h"
#include "usbh_msc_class.h"

Go to the source code of this file.

Macros

#define | DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */
#define | DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */
#define | DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */

Functions

DSTATUS | disk_status (BYTE pdrv)
DSTATUS | disk_initialize (BYTE pdrv)
DRESULT | disk_read (BYTE pdrv, BYTE *buff, LBA_t sector, UINT count)
DRESULT | disk_write (BYTE pdrv, const BYTE *buff, LBA_t sector, UINT count)
DRESULT | disk_ioctl (BYTE pdrv, BYTE cmd, void *buff)
DWORD | get_fattime (void)

Variables

otg_core_type otg_core_struct

Detailed Description

usb mass storage disk io

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c.


AT32F435/437 Firmwary Library: usbh_msc_diskio.c Source File

  • at_start_f437
  • examples
  • usb_host
  • msc_only_fat32
  • src
at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c
Go to the documentation of this file.
1
26#include "ff.h" /* Obtains integer types */
27#include "diskio.h" /* Declarations of disk functions */
28#include "usb_core.h"
29#include "usbh_msc_class.h"
38extern otg_core_type otg_core_struct;
39
40/* Definitions of physical drive number for each drive */
41#define DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */
42#define DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */
43#define DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */
44
45
46/*-----------------------------------------------------------------------*/
47/* Get Drive Status */
48/*-----------------------------------------------------------------------*/
49
50DSTATUS disk_status (
51 BYTE pdrv /* Physical drive nmuber to identify the drive */
52)
53{
54 if(usbh_msc_is_ready(&otg_core_struct.host, pdrv) == MSC_OK)
55 {
56 return RES_OK;
57 }
58
59 return RES_ERROR;
60}
61
62
63
64/*-----------------------------------------------------------------------*/
65/* Inidialize a Drive */
66/*-----------------------------------------------------------------------*/
67
68DSTATUS disk_initialize (
69 BYTE pdrv /* Physical drive nmuber to identify the drive */
70)
71{
72 return RES_OK;
73}
74
75
76
77/*-----------------------------------------------------------------------*/
78/* Read Sector(s) */
79/*-----------------------------------------------------------------------*/
80DRESULT disk_read (
81 BYTE pdrv, /* Physical drive nmuber to identify the drive */
82 BYTE *buff, /* Data buffer to store read data */
83 LBA_t sector, /* Start sector in LBA */
84 UINT count /* Number of sectors to read */
85)
86{
87 usb_sts_type status;
88
89 status = usbh_msc_read(&otg_core_struct.host, sector, count, buff, pdrv);
90
91 if(status == USB_OK)
92 return RES_OK;
93
94 return RES_ERROR;
95}
96
97
98
99/*-----------------------------------------------------------------------*/
100/* Write Sector(s) */
101/*-----------------------------------------------------------------------*/
102
103#if FF_FS_READONLY == 0
104
105DRESULT disk_write (
106 BYTE pdrv, /* Physical drive nmuber to identify the drive */
107 const BYTE *buff, /* Data to be written */
108 LBA_t sector, /* Start sector in LBA */
109 UINT count /* Number of sectors to write */
110)
111{
112 usb_sts_type status;
113
114 status = usbh_msc_write(&otg_core_struct.host, sector, count, (uint8_t *)buff, pdrv);
115
116 if(status == USB_OK)
117 return RES_OK;
118
119 return RES_ERROR;
120
121
122}
123
124#endif
125
126
127/*-----------------------------------------------------------------------*/
128/* Miscellaneous Functions */
129/*-----------------------------------------------------------------------*/
130
131DRESULT disk_ioctl (
132 BYTE pdrv, /* Physical drive nmuber (0..) */
133 BYTE cmd, /* Control code */
134 void *buff /* Buffer to send/receive control data */
135)
136{
137 usbh_core_type *host = (usbh_core_type *)&otg_core_struct.host;
138 usbh_msc_type *pmsc = (usbh_msc_type *)host->class_handler->pdata;
139 DRESULT res = RES_OK;
140 switch(cmd)
141 {
142 case CTRL_SYNC:
143 res = RES_OK;
144 break;
145 case GET_SECTOR_COUNT:
146 *(DWORD*)buff = pmsc->l_unit_n[pdrv].capacity.blk_nbr;
147 break;
148 case GET_SECTOR_SIZE:
149 *(DWORD*)buff = pmsc->l_unit_n[pdrv].capacity.blk_size;
150 break;
151 case GET_BLOCK_SIZE:
152 *(DWORD*)buff = pmsc->l_unit_n[pdrv].capacity.blk_size;
153 break;
154 default:
155 res = RES_PARERR;
156 }
157 return res;
158}
159
160/*-----------------------------------------------------------------------*/
161/* get_fattime */
162/*-----------------------------------------------------------------------*/
163DWORD get_fattime (void)
164{
165 return 0;
166}
167
disk_read
DRESULT disk_read(BYTE pdrv, BYTE *buff, LBA_t sector, UINT count)
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c:172
disk_initialize
DSTATUS disk_initialize(BYTE pdrv)
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c:141
disk_status
DSTATUS disk_status(BYTE pdrv)
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c:110
disk_ioctl
DRESULT disk_ioctl(BYTE pdrv, BYTE cmd, void *buff)
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c:245
disk_write
DRESULT disk_write(BYTE pdrv, const BYTE *buff, LBA_t sector, UINT count)
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c:209
otg_core_struct
otg_core_type otg_core_struct
Definition: project/at_start_f435/examples/acc/calibration/src/main.c:45
get_fattime
DWORD get_fattime(void)
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c:163
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_OK
@ USB_OK
Definition: usb_std.h:268
MSC_OK
@ MSC_OK
Definition: usbh_msc_bot_scsi.h:117
usbh_msc_write
usb_sts_type usbh_msc_write(void *uhost, uint32_t address, uint32_t len, uint8_t *buffer, uint8_t lun)
usb host msc write
Definition: usbh_msc_class.c:486
usbh_msc_read
usb_sts_type usbh_msc_read(void *uhost, uint32_t address, uint32_t len, uint8_t *buffer, uint8_t lun)
usb host msc read
Definition: usbh_msc_class.c:450
usbh_msc_is_ready
msc_error_type usbh_msc_is_ready(void *uhost, uint8_t lun)
usb host msc clear feature
Definition: usbh_msc_class.c:375
msc_scsi_data_capacity::blk_nbr
uint32_t blk_nbr
Definition: usbh_msc_bot_scsi.h:145
otg_core_type
usb otg core struct type
Definition: usb_core.h:92
usbh_msc_type
usb msc struct
Definition: usbh_msc_class.h:94
usbh_msc_type::l_unit_n
usbh_msc_unit_type l_unit_n[0x2]
Definition: usbh_msc_class.h:115
usbh_msc_unit_type::capacity
msc_scsi_data_capacity capacity
Definition: usbh_msc_bot_scsi.h:194
usb_core.h
usb core header file
usbh_msc_class.h
usb host msc class header file


AT32F435/437 Firmwary Library: usbh_user.c File Reference

  • at_start_f437
  • examples
  • usb_host
  • msc_only_fat32
  • src
Enumerations | Functions | Variables
at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c File Reference

usb user function More...

#include "usbh_user.h"
#include "ff.h"

Go to the source code of this file.

Enumerations

enum msc_usr_state {
USR_IDLE , USR_APP , USR_FINISH , USR_IDLE ,
USR_APP , USR_FINISH , USR_IDLE , USR_APP ,
USR_FINISH , USR_IDLE , USR_APP , USR_FINISH
}

Functions

static usb_sts_type | usbh_user_init (void)
usb host init user handler More...
static usb_sts_type | usbh_user_reset (void)
usb host reset user handler More...
static usb_sts_type | usbh_user_attached (void)
usb host check device attached More...
static usb_sts_type | usbh_user_disconnect (void)
usb host discconet user handler More...
static usb_sts_type | usbh_user_speed (uint8_t speed)
usb host speed user handler More...
static usb_sts_type | usbh_user_mfc_string (void *string)
usb host manufacturer string user handler More...
static usb_sts_type | usbh_user_product_string (void *string)
usb host product string user handler More...
static usb_sts_type | usbh_user_serial_string (void *string)
usb host serial string user handler More...
static usb_sts_type | usbh_user_enumeration_done (void)
usb host enumeration done user handler More...
static usb_sts_type | usbh_user_application (void)
static usb_sts_type | usbh_user_active_vbus (void *uhost, confirm_state state)
usb host active vbus user handler More...
static usb_sts_type | usbh_user_not_support (void)
usb host not support user handler More...

Variables

usbh_user_handler_type | usbh_user_handle
msc_usr_state usr_state = USR_IDLE
FIL | file
usb host application user handler More...
FATFS | fs

Detailed Description

usb user function

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c.

Function Documentation

◆ usbh_user_active_vbus()

static usb_sts_type usbh_user_active_vbus | ( | void * | uhost,
 |  | confirm_state | state
 | ) |  |
static

usb host active vbus user handler

Parameters
uhost | to the structure of usbh_core_type
state | vbus state TRUE: active vbus FALSE: deactive vbus
Return values
usb_sts_type

Definition at line 278 of file at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ usbh_user_application()

static usb_sts_type usbh_user_application ( void )
static

Definition at line 199 of file at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ usbh_user_attached()

static usb_sts_type usbh_user_attached ( void )
static

usb host check device attached

Parameters
none
Return values
usb_sts_type

Definition at line 105 of file at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ usbh_user_disconnect()

static usb_sts_type usbh_user_disconnect ( void )
static

usb host discconet user handler

Parameters
none
Return values
usb_sts_type

Definition at line 117 of file at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ usbh_user_enumeration_done()

static usb_sts_type usbh_user_enumeration_done ( void )
static

usb host enumeration done user handler

Parameters
none
Return values
usb_sts_type

Definition at line 185 of file at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ usbh_user_init()

static usb_sts_type usbh_user_init ( void )
static

usb host init user handler

Parameters
none
Return values
usb_sts_type

Definition at line 81 of file at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ usbh_user_mfc_string()

static usb_sts_type usbh_user_mfc_string ( void * string )
static

usb host manufacturer string user handler

Parameters
none
Return values
usb_sts_type

Definition at line 149 of file at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ usbh_user_not_support()

static usb_sts_type usbh_user_not_support ( void )
static

usb host not support user handler

Parameters
none
Return values
usb_sts_type

Definition at line 301 of file at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ usbh_user_product_string()

static usb_sts_type usbh_user_product_string ( void * string )
static

usb host product string user handler

Parameters
none
Return values
usb_sts_type

Definition at line 161 of file at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ usbh_user_reset()

static usb_sts_type usbh_user_reset ( void )
static

usb host reset user handler

Parameters
none
Return values
usb_sts_type

Definition at line 93 of file at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ usbh_user_serial_string()

static usb_sts_type usbh_user_serial_string ( void * string )
static

usb host serial string user handler

Parameters
none
Return values
usb_sts_type

Definition at line 173 of file at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c.

◆ usbh_user_speed()

static usb_sts_type usbh_user_speed ( uint8_t speed )
static

usb host speed user handler

Parameters
none
Return values
usb_sts_type

Definition at line 130 of file at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c.


AT32F435/437 Firmwary Library: usbh_user.c Source File

  • at_start_f437
  • examples
  • usb_host
  • msc_only_fat32
  • src
at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c
Go to the documentation of this file.
1
26#include "usbh_user.h"
27#include "ff.h"
28
37static usb_sts_type usbh_user_init(void);
38static usb_sts_type usbh_user_reset(void);
39static usb_sts_type usbh_user_attached(void);
40static usb_sts_type usbh_user_disconnect(void);
41static usb_sts_type usbh_user_speed(uint8_t speed);
42static usb_sts_type usbh_user_mfc_string(void *string);
43static usb_sts_type usbh_user_product_string(void *string);
44static usb_sts_type usbh_user_serial_string(void *string);
45static usb_sts_type usbh_user_enumeration_done(void);
46static usb_sts_type usbh_user_application(void);
47static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state);
48static usb_sts_type usbh_user_not_support(void);
49
50
51usbh_user_handler_type usbh_user_handle =
52{
53 usbh_user_init,
54 usbh_user_reset,
55 usbh_user_attached,
56 usbh_user_disconnect,
57 usbh_user_speed,
58 usbh_user_mfc_string,
59 usbh_user_product_string,
60 usbh_user_serial_string,
61 usbh_user_enumeration_done,
62 usbh_user_application,
63 usbh_user_active_vbus,
64 usbh_user_not_support,
65};
66
67typedef enum
68{
69 USR_IDLE,
70 USR_APP,
71 USR_FINISH
72}msc_usr_state;
73
74 msc_usr_state usr_state = USR_IDLE;
75
81static usb_sts_type usbh_user_init(void)
82{
83 usb_sts_type status = USB_OK;
84
85 return status;
86}
87
93static usb_sts_type usbh_user_reset(void)
94{
95 usb_sts_type status = USB_OK;
96
97 return status;
98}
99
105static usb_sts_type usbh_user_attached(void)
106{
107 usb_sts_type status = USB_OK;
108 USBH_DEBUG("USB Device Attached");
109 return status;
110}
111
117static usb_sts_type usbh_user_disconnect(void)
118{
119 usb_sts_type status = USB_OK;
120 usr_state = USR_IDLE;
121 USBH_DEBUG("Device Disconnect");
122 return status;
123}
124
130static usb_sts_type usbh_user_speed(uint8_t speed)
131{
132 usb_sts_type status = USB_OK;
133 if(speed == USB_PRTSPD_FULL_SPEED)
134 {
135 USBH_DEBUG("This is a Full-Speed device");
136 }
137 else if(speed == USB_PRTSPD_LOW_SPEED)
138 {
139 USBH_DEBUG("This is a Low-Speed device");
140 }
141 return status;
142}
143
149static usb_sts_type usbh_user_mfc_string(void *string)
150{
151 usb_sts_type status = USB_OK;
152 USBH_DEBUG("Manufacturer: %s", (uint8_t *)string);
153 return status;
154}
155
161static usb_sts_type usbh_user_product_string(void *string)
162{
163 usb_sts_type status = USB_OK;
164 USBH_DEBUG("Product: %s", (uint8_t *)string);
165 return status;
166}
167
173static usb_sts_type usbh_user_serial_string(void *string)
174{
175 usb_sts_type status = USB_OK;
176 USBH_DEBUG("Serial: %s", (uint8_t *)string);
177 return status;
178}
179
185static usb_sts_type usbh_user_enumeration_done(void)
186{
187 usb_sts_type status = USB_OK;
188 USBH_DEBUG("Enumeration done");
189 return status;
190}
191
197FIL file;
198FATFS fs;
199static usb_sts_type usbh_user_application(void)
200{
201 usb_sts_type status = USB_OK;
202 FRESULT res;
203
204 uint32_t len;
205 uint8_t write_data[] = "usb host msc demo";
206 uint8_t read_data[32] = {0};
207
208 switch(usr_state)
209 {
210 case USR_IDLE:
211 usr_state = USR_APP;
212 break;
213 case USR_APP:
214 res = f_mount(&fs, "", 0);
215 if(res == FR_OK)
216 {
217 /* start write data */
218 if(f_open(&file, "0:AT32.txt", FA_CREATE_ALWAYS | FA_WRITE) != FR_OK)
219 {
220 // error
221 USBH_DEBUG("Open AT32.txt failed");
222 }
223 else
224 {
225 res = f_write(&file, write_data, sizeof(write_data), &len);
226 if(res != FR_OK || len == 0)
227 {
228 //write error
229 USBH_DEBUG("Write AT32.txt failed");
230 }
231 else
232 {
233 //write success
234 USBH_DEBUG("Write AT32.txt Success");
235 }
236 f_close(&file);
237 }
238
239 /* start read file */
240 if(f_open(&file, "0:AT32.txt", FA_READ) != FR_OK)
241 {
242 // error
243 USBH_DEBUG("Open AT32.txt failed");
244 }
245 else
246 {
247 res = f_read(&file, read_data, sizeof(read_data), &len);
248 if(res != FR_OK || len == 0)
249 {
250 //read error
251 USBH_DEBUG("Read AT32.txt failed");
252 }
253 else
254 {
255 //read success
256 USBH_DEBUG("Read AT32.txt Success");
257 }
258 f_close(&file);
259 }
260 f_mount(NULL, "", 0);
261 }
262 usr_state = USR_FINISH;
263 break;
264 case USR_FINISH:
265 break;
266 }
267 return status;
268}
269
278static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state)
279{
280 usb_sts_type status = USB_OK;
281#ifdef USBH_5V_POWER_SWITCH
282 if(state == TRUE)
283 {
284 /* active vbus */
285 gpio_bits_reset(OTG_PIN_POWER_SWITCH_GPIO, OTG_PIN_POWER_SWITCH);
286 }
287 else
288 {
289 /* deactive vubs */
290 gpio_bits_set(OTG_PIN_POWER_SWITCH_GPIO, OTG_PIN_POWER_SWITCH);
291 }
292#endif
293 return status;
294}
295
301static usb_sts_type usbh_user_not_support(void)
302{
303 usb_sts_type status = USB_OK;
304
305 return status;
306}
307
usbh_user_init
static usb_sts_type usbh_user_init(void)
usb host init user handler
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:81
usbh_user_disconnect
static usb_sts_type usbh_user_disconnect(void)
usb host discconet user handler
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:117
usbh_user_not_support
static usb_sts_type usbh_user_not_support(void)
usb host not support user handler
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:301
usbh_user_application
static usb_sts_type usbh_user_application(void)
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:199
usbh_user_speed
static usb_sts_type usbh_user_speed(uint8_t speed)
usb host speed user handler
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:130
usbh_user_active_vbus
static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state)
usb host active vbus user handler
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:278
usbh_user_serial_string
static usb_sts_type usbh_user_serial_string(void *string)
usb host serial string user handler
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:173
usbh_user_reset
static usb_sts_type usbh_user_reset(void)
usb host reset user handler
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:93
usbh_user_mfc_string
static usb_sts_type usbh_user_mfc_string(void *string)
usb host manufacturer string user handler
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:149
usbh_user_enumeration_done
static usb_sts_type usbh_user_enumeration_done(void)
usb host enumeration done user handler
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:185
usbh_user_attached
static usb_sts_type usbh_user_attached(void)
usb host check device attached
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:105
usbh_user_product_string
static usb_sts_type usbh_user_product_string(void *string)
usb host product string user handler
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:161
OTG_PIN_POWER_SWITCH_GPIO
#define OTG_PIN_POWER_SWITCH_GPIO
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h:91
OTG_PIN_POWER_SWITCH
#define OTG_PIN_POWER_SWITCH
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h:93
USBH_DEBUG
#define USBH_DEBUG(...)
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h:206
file
FIL file
usb host application user handler
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:197
usbh_user_handle
usbh_user_handler_type usbh_user_handle
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:51
msc_usr_state
msc_usr_state
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:68
usr_state
msc_usr_state usr_state
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:74
fs
FATFS fs
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:198
USR_APP
@ USR_APP
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:70
USR_FINISH
@ USR_FINISH
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:71
USR_IDLE
@ USR_IDLE
Definition: at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c:69
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
confirm_state
confirm_state
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f435_437_gpio.c:308
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f435_437_gpio.c:277
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
USB_PRTSPD_LOW_SPEED
#define USB_PRTSPD_LOW_SPEED
Definition: at32f435_437_usb.h:188
USB_PRTSPD_FULL_SPEED
#define USB_PRTSPD_FULL_SPEED
Definition: at32f435_437_usb.h:187
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_OK
@ USB_OK
Definition: usb_std.h:268


AT32F435/437 Firmwary Library: ffconf.h File Reference

  • at_start_f437
  • examples
  • usb_host
  • two_otg_host_demo
  • inc
Macros
at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h File Reference

Go to the source code of this file.

Macros

#define | FFCONF_DEF 86631 /* Revision ID */
#define | FF_FS_READONLY 0
#define | FF_FS_MINIMIZE 0
#define | FF_USE_FIND 0
#define | FF_USE_MKFS 0
#define | FF_USE_FASTSEEK 0
#define | FF_USE_EXPAND 0
#define | FF_USE_CHMOD 0
#define | FF_USE_LABEL 0
#define | FF_USE_FORWARD 0
#define | FF_USE_STRFUNC 0
#define | FF_PRINT_LLI 0
#define | FF_PRINT_FLOAT 0
#define | FF_STRF_ENCODE 0
#define | FF_CODE_PAGE 932
#define | FF_USE_LFN 0
#define | FF_MAX_LFN 255
#define | FF_LFN_UNICODE 0
#define | FF_LFN_BUF 255
#define | FF_SFN_BUF 12
#define | FF_FS_RPATH 0
#define | FF_VOLUMES 1
#define | FF_STR_VOLUME_ID 0
#define | FF_VOLUME_STRS "RAM","NAND","CF","SD","SD2","USB","USB2","USB3"
#define | FF_MULTI_PARTITION 0
#define | FF_MIN_SS 512
#define | FF_MAX_SS 512
#define | FF_LBA64 0
#define | FF_MIN_GPT 0x10000000
#define | FF_USE_TRIM 0
#define | FF_FS_TINY 0
#define | FF_FS_EXFAT 0
#define | FF_FS_NORTC 0
#define | FF_NORTC_MON 1
#define | FF_NORTC_MDAY 1
#define | FF_NORTC_YEAR 2020
#define | FF_FS_NOFSINFO 0
#define | FF_FS_LOCK 0
#define | FF_FS_REENTRANT 0
#define | FF_FS_TIMEOUT 1000
#define | FF_SYNC_t HANDLE

Macro Definition Documentation

◆ FF_CODE_PAGE

#define FF_CODE_PAGE 932

Definition at line 87 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_FS_EXFAT

#define FF_FS_EXFAT 0

Definition at line 234 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_FS_LOCK

#define FF_FS_LOCK 0

Definition at line 266 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_FS_MINIMIZE

#define FF_FS_MINIMIZE 0

Definition at line 18 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_FS_NOFSINFO

#define FF_FS_NOFSINFO 0

Definition at line 254 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_FS_NORTC

#define FF_FS_NORTC 0

Definition at line 240 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_FS_READONLY

#define FF_FS_READONLY 0

Definition at line 11 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_FS_REENTRANT

#define FF_FS_REENTRANT 0

Definition at line 279 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_FS_RPATH

#define FF_FS_RPATH 0

Definition at line 156 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_FS_TIMEOUT

#define FF_FS_TIMEOUT 1000

Definition at line 280 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_FS_TINY

#define FF_FS_TINY 0

Definition at line 227 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_LBA64

#define FF_LBA64 0

Definition at line 206 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_LFN_BUF

#define FF_LFN_BUF 255

Definition at line 148 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_LFN_UNICODE

#define FF_LFN_UNICODE 0

Definition at line 136 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_MAX_LFN

#define FF_MAX_LFN 255

Definition at line 117 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_MAX_SS

#define FF_MAX_SS 512

Definition at line 197 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_MIN_GPT

#define FF_MIN_GPT 0x10000000

Definition at line 211 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_MIN_SS

#define FF_MIN_SS 512

Definition at line 196 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_MULTI_PARTITION

#define FF_MULTI_PARTITION 0

Definition at line 187 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_NORTC_MDAY

#define FF_NORTC_MDAY 1

Definition at line 242 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_NORTC_MON

#define FF_NORTC_MON 1

Definition at line 241 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_NORTC_YEAR

#define FF_NORTC_YEAR 2020

Definition at line 243 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_PRINT_FLOAT

#define FF_PRINT_FLOAT 0

Definition at line 61 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_PRINT_LLI

#define FF_PRINT_LLI 0

Definition at line 60 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_SFN_BUF

#define FF_SFN_BUF 12

Definition at line 149 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_STR_VOLUME_ID

#define FF_STR_VOLUME_ID 0

Definition at line 173 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_STRF_ENCODE

#define FF_STRF_ENCODE 0

Definition at line 62 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_SYNC_t

#define FF_SYNC_t HANDLE

Definition at line 281 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_USE_CHMOD

#define FF_USE_CHMOD 0

Definition at line 45 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_USE_EXPAND

#define FF_USE_EXPAND 0

Definition at line 41 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_USE_FASTSEEK

#define FF_USE_FASTSEEK 0

Definition at line 37 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_USE_FIND

#define FF_USE_FIND 0

Definition at line 28 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_USE_FORWARD

#define FF_USE_FORWARD 0

Definition at line 55 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_USE_LABEL

#define FF_USE_LABEL 0

Definition at line 50 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_USE_LFN

#define FF_USE_LFN 0

Definition at line 116 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_USE_MKFS

#define FF_USE_MKFS 0

Definition at line 33 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_USE_STRFUNC

#define FF_USE_STRFUNC 0

Definition at line 59 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_USE_TRIM

#define FF_USE_TRIM 0

Definition at line 216 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_VOLUME_STRS

#define FF_VOLUME_STRS "RAM","NAND","CF","SD","SD2","USB","USB2","USB3"

Definition at line 174 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FF_VOLUMES

#define FF_VOLUMES 1

Definition at line 169 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.

◆ FFCONF_DEF

#define FFCONF_DEF 86631 /* Revision ID */

Definition at line 5 of file at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h.


AT32F435/437 Firmwary Library: ffconf.h Source File

  • at_start_f437
  • examples
  • usb_host
  • two_otg_host_demo
  • inc
at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
Go to the documentation of this file.
1/*---------------------------------------------------------------------------/
2/ FatFs Functional Configurations
3/---------------------------------------------------------------------------*/
4
5#define FFCONF_DEF 86631 /* Revision ID */
6
7/*---------------------------------------------------------------------------/
8/ Function Configurations
9/---------------------------------------------------------------------------*/
10
11#define FF_FS_READONLY 0
12/* This option switches read-only configuration. (0:Read/Write or 1:Read-only)
13/ Read-only configuration removes writing API functions, f_write(), f_sync(),
14/ f_unlink(), f_mkdir(), f_chmod(), f_rename(), f_truncate(), f_getfree()
15/ and optional writing functions as well. */
16
17
18#define FF_FS_MINIMIZE 0
19/* This option defines minimization level to remove some basic API functions.
20/
21/ 0: Basic functions are fully enabled.
22/ 1: f_stat(), f_getfree(), f_unlink(), f_mkdir(), f_truncate() and f_rename()
23/ are removed.
24/ 2: f_opendir(), f_readdir() and f_closedir() are removed in addition to 1.
25/ 3: f_lseek() function is removed in addition to 2. */
26
27
28#define FF_USE_FIND 0
29/* This option switches filtered directory read functions, f_findfirst() and
30/ f_findnext(). (0:Disable, 1:Enable 2:Enable with matching altname[] too) */
31
32
33#define FF_USE_MKFS 0
34/* This option switches f_mkfs() function. (0:Disable or 1:Enable) */
35
36
37#define FF_USE_FASTSEEK 0
38/* This option switches fast seek function. (0:Disable or 1:Enable) */
39
40
41#define FF_USE_EXPAND 0
42/* This option switches f_expand function. (0:Disable or 1:Enable) */
43
44
45#define FF_USE_CHMOD 0
46/* This option switches attribute manipulation functions, f_chmod() and f_utime().
47/ (0:Disable or 1:Enable) Also FF_FS_READONLY needs to be 0 to enable this option. */
48
49
50#define FF_USE_LABEL 0
51/* This option switches volume label functions, f_getlabel() and f_setlabel().
52/ (0:Disable or 1:Enable) */
53
54
55#define FF_USE_FORWARD 0
56/* This option switches f_forward() function. (0:Disable or 1:Enable) */
57
58
59#define FF_USE_STRFUNC 0
60#define FF_PRINT_LLI 0
61#define FF_PRINT_FLOAT 0
62#define FF_STRF_ENCODE 0
63/* FF_USE_STRFUNC switches string functions, f_gets(), f_putc(), f_puts() and
64/ f_printf().
65/
66/ 0: Disable. FF_PRINT_LLI, FF_PRINT_FLOAT and FF_STRF_ENCODE have no effect.
67/ 1: Enable without LF-CRLF conversion.
68/ 2: Enable with LF-CRLF conversion.
69/
70/ FF_PRINT_LLI = 1 makes f_printf() support long long argument and FF_PRINT_FLOAT = 1/2
71 makes f_printf() support floating point argument. These features want C99 or later.
72/ When FF_LFN_UNICODE >= 1 with LFN enabled, string functions convert the character
73/ encoding in it. FF_STRF_ENCODE selects assumption of character encoding ON THE FILE
74/ to be read/written via those functions.
75/
76/ 0: ANSI/OEM in current CP
77/ 1: Unicode in UTF-16LE
78/ 2: Unicode in UTF-16BE
79/ 3: Unicode in UTF-8
80*/
81
82
83/*---------------------------------------------------------------------------/
84/ Locale and Namespace Configurations
85/---------------------------------------------------------------------------*/
86
87#define FF_CODE_PAGE 932
88/* This option specifies the OEM code page to be used on the target system.
89/ Incorrect code page setting can cause a file open failure.
90/
91/ 437 - U.S.
92/ 720 - Arabic
93/ 737 - Greek
94/ 771 - KBL
95/ 775 - Baltic
96/ 850 - Latin 1
97/ 852 - Latin 2
98/ 855 - Cyrillic
99/ 857 - Turkish
100/ 860 - Portuguese
101/ 861 - Icelandic
102/ 862 - Hebrew
103/ 863 - Canadian French
104/ 864 - Arabic
105/ 865 - Nordic
106/ 866 - Russian
107/ 869 - Greek 2
108/ 932 - Japanese (DBCS)
109/ 936 - Simplified Chinese (DBCS)
110/ 949 - Korean (DBCS)
111/ 950 - Traditional Chinese (DBCS)
112/ 0 - Include all code pages above and configured by f_setcp()
113*/
114
115
116#define FF_USE_LFN 0
117#define FF_MAX_LFN 255
118/* The FF_USE_LFN switches the support for LFN (long file name).
119/
120/ 0: Disable LFN. FF_MAX_LFN has no effect.
121/ 1: Enable LFN with static working buffer on the BSS. Always NOT thread-safe.
122/ 2: Enable LFN with dynamic working buffer on the STACK.
123/ 3: Enable LFN with dynamic working buffer on the HEAP.
124/
125/ To enable the LFN, ffunicode.c needs to be added to the project. The LFN function
126/ requiers certain internal working buffer occupies (FF_MAX_LFN + 1) * 2 bytes and
127/ additional (FF_MAX_LFN + 44) / 15 * 32 bytes when exFAT is enabled.
128/ The FF_MAX_LFN defines size of the working buffer in UTF-16 code unit and it can
129/ be in range of 12 to 255. It is recommended to be set it 255 to fully support LFN
130/ specification.
131/ When use stack for the working buffer, take care on stack overflow. When use heap
132/ memory for the working buffer, memory management functions, ff_memalloc() and
133/ ff_memfree() exemplified in ffsystem.c, need to be added to the project. */
134
135
136#define FF_LFN_UNICODE 0
137/* This option switches the character encoding on the API when LFN is enabled.
138/
139/ 0: ANSI/OEM in current CP (TCHAR = char)
140/ 1: Unicode in UTF-16 (TCHAR = WCHAR)
141/ 2: Unicode in UTF-8 (TCHAR = char)
142/ 3: Unicode in UTF-32 (TCHAR = DWORD)
143/
144/ Also behavior of string I/O functions will be affected by this option.
145/ When LFN is not enabled, this option has no effect. */
146
147
148#define FF_LFN_BUF 255
149#define FF_SFN_BUF 12
150/* This set of options defines size of file name members in the FILINFO structure
151/ which is used to read out directory items. These values should be suffcient for
152/ the file names to read. The maximum possible length of the read file name depends
153/ on character encoding. When LFN is not enabled, these options have no effect. */
154
155
156#define FF_FS_RPATH 0
157/* This option configures support for relative path.
158/
159/ 0: Disable relative path and remove related functions.
160/ 1: Enable relative path. f_chdir() and f_chdrive() are available.
161/ 2: f_getcwd() function is available in addition to 1.
162*/
163
164
165/*---------------------------------------------------------------------------/
166/ Drive/Volume Configurations
167/---------------------------------------------------------------------------*/
168
169#define FF_VOLUMES 1
170/* Number of volumes (logical drives) to be used. (1-10) */
171
172
173#define FF_STR_VOLUME_ID 0
174#define FF_VOLUME_STRS "RAM","NAND","CF","SD","SD2","USB","USB2","USB3"
175/* FF_STR_VOLUME_ID switches support for volume ID in arbitrary strings.
176/ When FF_STR_VOLUME_ID is set to 1 or 2, arbitrary strings can be used as drive
177/ number in the path name. FF_VOLUME_STRS defines the volume ID strings for each
178/ logical drives. Number of items must not be less than FF_VOLUMES. Valid
179/ characters for the volume ID strings are A-Z, a-z and 0-9, however, they are
180/ compared in case-insensitive. If FF_STR_VOLUME_ID >= 1 and FF_VOLUME_STRS is
181/ not defined, a user defined volume string table needs to be defined as:
182/
183/ const char* VolumeStr[FF_VOLUMES] = {"ram","flash","sd","usb",...
184*/
185
186
187#define FF_MULTI_PARTITION 0
188/* This option switches support for multiple volumes on the physical drive.
189/ By default (0), each logical drive number is bound to the same physical drive
190/ number and only an FAT volume found on the physical drive will be mounted.
191/ When this function is enabled (1), each logical drive number can be bound to
192/ arbitrary physical drive and partition listed in the VolToPart[]. Also f_fdisk()
193/ funciton will be available. */
194
195
196#define FF_MIN_SS 512
197#define FF_MAX_SS 512
198/* This set of options configures the range of sector size to be supported. (512,
199/ 1024, 2048 or 4096) Always set both 512 for most systems, generic memory card and
200/ harddisk, but a larger value may be required for on-board flash memory and some
201/ type of optical media. When FF_MAX_SS is larger than FF_MIN_SS, FatFs is configured
202/ for variable sector size mode and disk_ioctl() function needs to implement
203/ GET_SECTOR_SIZE command. */
204
205
206#define FF_LBA64 0
207/* This option switches support for 64-bit LBA. (0:Disable or 1:Enable)
208/ To enable the 64-bit LBA, also exFAT needs to be enabled. (FF_FS_EXFAT == 1) */
209
210
211#define FF_MIN_GPT 0x10000000
212/* Minimum number of sectors to switch GPT as partitioning format in f_mkfs and
213/ f_fdisk function. 0x100000000 max. This option has no effect when FF_LBA64 == 0. */
214
215
216#define FF_USE_TRIM 0
217/* This option switches support for ATA-TRIM. (0:Disable or 1:Enable)
218/ To enable Trim function, also CTRL_TRIM command should be implemented to the
219/ disk_ioctl() function. */
220
221
222
223/*---------------------------------------------------------------------------/
224/ System Configurations
225/---------------------------------------------------------------------------*/
226
227#define FF_FS_TINY 0
228/* This option switches tiny buffer configuration. (0:Normal or 1:Tiny)
229/ At the tiny configuration, size of file object (FIL) is shrinked FF_MAX_SS bytes.
230/ Instead of private sector buffer eliminated from the file object, common sector
231/ buffer in the filesystem object (FATFS) is used for the file data transfer. */
232
233
234#define FF_FS_EXFAT 0
235/* This option switches support for exFAT filesystem. (0:Disable or 1:Enable)
236/ To enable exFAT, also LFN needs to be enabled. (FF_USE_LFN >= 1)
237/ Note that enabling exFAT discards ANSI C (C89) compatibility. */
238
239
240#define FF_FS_NORTC 0
241#define FF_NORTC_MON 1
242#define FF_NORTC_MDAY 1
243#define FF_NORTC_YEAR 2020
244/* The option FF_FS_NORTC switches timestamp functiton. If the system does not have
245/ any RTC function or valid timestamp is not needed, set FF_FS_NORTC = 1 to disable
246/ the timestamp function. Every object modified by FatFs will have a fixed timestamp
247/ defined by FF_NORTC_MON, FF_NORTC_MDAY and FF_NORTC_YEAR in local time.
248/ To enable timestamp function (FF_FS_NORTC = 0), get_fattime() function need to be
249/ added to the project to read current time form real-time clock. FF_NORTC_MON,
250/ FF_NORTC_MDAY and FF_NORTC_YEAR have no effect.
251/ These options have no effect in read-only configuration (FF_FS_READONLY = 1). */
252
253
254#define FF_FS_NOFSINFO 0
255/* If you need to know correct free space on the FAT32 volume, set bit 0 of this
256/ option, and f_getfree() function at first time after volume mount will force
257/ a full FAT scan. Bit 1 controls the use of last allocated cluster number.
258/
259/ bit0=0: Use free cluster count in the FSINFO if available.
260/ bit0=1: Do not trust free cluster count in the FSINFO.
261/ bit1=0: Use last allocated cluster number in the FSINFO if available.
262/ bit1=1: Do not trust last allocated cluster number in the FSINFO.
263*/
264
265
266#define FF_FS_LOCK 0
267/* The option FF_FS_LOCK switches file lock function to control duplicated file open
268/ and illegal operation to open objects. This option must be 0 when FF_FS_READONLY
269/ is 1.
270/
271/ 0: Disable file lock function. To avoid volume corruption, application program
272/ should avoid illegal open, remove and rename to the open objects.
273/ >0: Enable file lock function. The value defines how many files/sub-directories
274/ can be opened simultaneously under file lock control. Note that the file
275/ lock control is independent of re-entrancy. */
276
277
278/* #include <somertos.h> // O/S definitions */
279#define FF_FS_REENTRANT 0
280#define FF_FS_TIMEOUT 1000
281#define FF_SYNC_t HANDLE
282/* The option FF_FS_REENTRANT switches the re-entrancy (thread safe) of the FatFs
283/ module itself. Note that regardless of this option, file access to different
284/ volume is always re-entrant and volume control functions, f_mount(), f_mkfs()
285/ and f_fdisk() function, are always not re-entrant. Only file/directory access
286/ to the same volume is under control of this function.
287/
288/ 0: Disable re-entrancy. FF_FS_TIMEOUT and FF_SYNC_t have no effect.
289/ 1: Enable re-entrancy. Also user provided synchronization handlers,
290/ ff_req_grant(), ff_rel_grant(), ff_del_syncobj() and ff_cre_syncobj()
291/ function, must be added to the project. Samples are available in
292/ option/syscall.c.
293/
294/ The FF_FS_TIMEOUT defines timeout period in unit of time tick.
295/ The FF_SYNC_t defines O/S dependent sync object type. e.g. HANDLE, ID, OS_EVENT*,
296/ SemaphoreHandle_t and etc. A header file for O/S definitions needs to be
297/ included somewhere in the scope of ff.h. */
298
299
300
301/*--- End of configuration options ---*/


AT32F435/437 Firmwary Library: usbh_user.h File Reference

  • at_start_f437
  • examples
  • usb_host
  • two_otg_host_demo
  • inc
Variables
at_start_f437/examples/usb_host/two_otg_host_demo/inc/usbh_user.h File Reference

usb host user header file More...

#include "usbh_core.h"

Go to the source code of this file.

Variables

usbh_user_handler_type usbh_user_handle

Detailed Description

usb host user header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/usb_host/two_otg_host_demo/inc/usbh_user.h.


AT32F435/437 Firmwary Library: usbh_user.h Source File

  • at_start_f437
  • examples
  • usb_host
  • two_otg_host_demo
  • inc
at_start_f437/examples/usb_host/two_otg_host_demo/inc/usbh_user.h
Go to the documentation of this file.
1
26/* define to prevent recursive inclusion -------------------------------------*/
27#ifndef __USBH_USER_H
28#define __USBH_USER_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "usbh_core.h"
35
36extern usbh_user_handler_type usbh_user_handle;
37#ifdef __cplusplus
38}
39#endif
40
41#endif
42
43
usbh_user_handle
usbh_user_handler_type usbh_user_handle
Definition: at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c:50
usbh_core.h
usb host core header file


AT32F435/437 Firmwary Library: usbh_msc_diskio.c File Reference

  • at_start_f437
  • examples
  • usb_host
  • two_otg_host_demo
  • src
Macros | Functions | Variables
at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c File Reference

usb mass storage disk io More...

#include "ff.h"
#include "diskio.h"
#include "usb_core.h"
#include "usbh_msc_class.h"

Go to the source code of this file.

Macros

#define | DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */
#define | DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */
#define | DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */

Functions

DSTATUS | disk_status (BYTE pdrv)
DSTATUS | disk_initialize (BYTE pdrv)
DRESULT | disk_read (BYTE pdrv, BYTE *buff, LBA_t sector, UINT count)
DRESULT | disk_write (BYTE pdrv, const BYTE *buff, LBA_t sector, UINT count)
DRESULT | disk_ioctl (BYTE pdrv, BYTE cmd, void *buff)
DWORD | get_fattime (void)

Variables

otg_core_type otg_core_struct

Detailed Description

usb mass storage disk io

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c.


AT32F435/437 Firmwary Library: usbh_msc_diskio.c Source File

  • at_start_f437
  • examples
  • usb_host
  • two_otg_host_demo
  • src
at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c
Go to the documentation of this file.
1
26#include "ff.h" /* Obtains integer types */
27#include "diskio.h" /* Declarations of disk functions */
28#include "usb_core.h"
29#include "usbh_msc_class.h"
38extern otg_core_type otg_core_struct;
39
40/* Definitions of physical drive number for each drive */
41#define DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */
42#define DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */
43#define DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */
44
45
46/*-----------------------------------------------------------------------*/
47/* Get Drive Status */
48/*-----------------------------------------------------------------------*/
49
50DSTATUS disk_status (
51 BYTE pdrv /* Physical drive nmuber to identify the drive */
52)
53{
54 if(usbh_msc_is_ready(&otg_core_struct.host, pdrv) == MSC_OK)
55 {
56 return RES_OK;
57 }
58
59 return RES_ERROR;
60}
61
62
63
64/*-----------------------------------------------------------------------*/
65/* Inidialize a Drive */
66/*-----------------------------------------------------------------------*/
67
68DSTATUS disk_initialize (
69 BYTE pdrv /* Physical drive nmuber to identify the drive */
70)
71{
72 return RES_OK;
73}
74
75
76
77/*-----------------------------------------------------------------------*/
78/* Read Sector(s) */
79/*-----------------------------------------------------------------------*/
80DRESULT disk_read (
81 BYTE pdrv, /* Physical drive nmuber to identify the drive */
82 BYTE *buff, /* Data buffer to store read data */
83 LBA_t sector, /* Start sector in LBA */
84 UINT count /* Number of sectors to read */
85)
86{
87 usb_sts_type status;
88
89 status = usbh_msc_read(&otg_core_struct.host, sector, count, buff, pdrv);
90
91 if(status == USB_OK)
92 return RES_OK;
93
94 return RES_ERROR;
95}
96
97
98
99/*-----------------------------------------------------------------------*/
100/* Write Sector(s) */
101/*-----------------------------------------------------------------------*/
102
103#if FF_FS_READONLY == 0
104
105DRESULT disk_write (
106 BYTE pdrv, /* Physical drive nmuber to identify the drive */
107 const BYTE *buff, /* Data to be written */
108 LBA_t sector, /* Start sector in LBA */
109 UINT count /* Number of sectors to write */
110)
111{
112 usb_sts_type status;
113
114 status = usbh_msc_write(&otg_core_struct.host, sector, count, (uint8_t *)buff, pdrv);
115
116 if(status == USB_OK)
117 return RES_OK;
118
119 return RES_ERROR;
120
121
122}
123
124#endif
125
126
127/*-----------------------------------------------------------------------*/
128/* Miscellaneous Functions */
129/*-----------------------------------------------------------------------*/
130
131DRESULT disk_ioctl (
132 BYTE pdrv, /* Physical drive nmuber (0..) */
133 BYTE cmd, /* Control code */
134 void *buff /* Buffer to send/receive control data */
135)
136{
137 usbh_core_type *host = (usbh_core_type *)&otg_core_struct.host;
138 usbh_msc_type *pmsc = (usbh_msc_type *)host->class_handler->pdata;
139 DRESULT res = RES_OK;
140 switch(cmd)
141 {
142 case CTRL_SYNC:
143 res = RES_OK;
144 break;
145 case GET_SECTOR_COUNT:
146 *(DWORD*)buff = pmsc->l_unit_n[pdrv].capacity.blk_nbr;
147 break;
148 case GET_SECTOR_SIZE:
149 *(DWORD*)buff = pmsc->l_unit_n[pdrv].capacity.blk_size;
150 break;
151 case GET_BLOCK_SIZE:
152 *(DWORD*)buff = pmsc->l_unit_n[pdrv].capacity.blk_size;
153 break;
154 default:
155 res = RES_PARERR;
156 }
157 return res;
158}
159
160/*-----------------------------------------------------------------------*/
161/* get_fattime */
162/*-----------------------------------------------------------------------*/
163DWORD get_fattime (void)
164{
165 return 0;
166}
167
disk_read
DRESULT disk_read(BYTE pdrv, BYTE *buff, LBA_t sector, UINT count)
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c:172
disk_initialize
DSTATUS disk_initialize(BYTE pdrv)
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c:141
disk_status
DSTATUS disk_status(BYTE pdrv)
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c:110
disk_ioctl
DRESULT disk_ioctl(BYTE pdrv, BYTE cmd, void *buff)
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c:245
disk_write
DRESULT disk_write(BYTE pdrv, const BYTE *buff, LBA_t sector, UINT count)
Definition: at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c:209
get_fattime
DWORD get_fattime(void)
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c:163
otg_core_struct
otg_core_type otg_core_struct
Definition: project/at_start_f435/examples/acc/calibration/src/main.c:45
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_OK
@ USB_OK
Definition: usb_std.h:268
MSC_OK
@ MSC_OK
Definition: usbh_msc_bot_scsi.h:117
usbh_msc_write
usb_sts_type usbh_msc_write(void *uhost, uint32_t address, uint32_t len, uint8_t *buffer, uint8_t lun)
usb host msc write
Definition: usbh_msc_class.c:486
usbh_msc_read
usb_sts_type usbh_msc_read(void *uhost, uint32_t address, uint32_t len, uint8_t *buffer, uint8_t lun)
usb host msc read
Definition: usbh_msc_class.c:450
usbh_msc_is_ready
msc_error_type usbh_msc_is_ready(void *uhost, uint8_t lun)
usb host msc clear feature
Definition: usbh_msc_class.c:375
msc_scsi_data_capacity::blk_nbr
uint32_t blk_nbr
Definition: usbh_msc_bot_scsi.h:145
otg_core_type
usb otg core struct type
Definition: usb_core.h:92
usbh_msc_type
usb msc struct
Definition: usbh_msc_class.h:94
usbh_msc_type::l_unit_n
usbh_msc_unit_type l_unit_n[0x2]
Definition: usbh_msc_class.h:115
usbh_msc_unit_type::capacity
msc_scsi_data_capacity capacity
Definition: usbh_msc_bot_scsi.h:194
usb_core.h
usb core header file
usbh_msc_class.h
usb host msc class header file


AT32F435/437 Firmwary Library: usbh_user.c File Reference

  • at_start_f437
  • examples
  • usb_host
  • two_otg_host_demo
  • src
Enumerations | Functions | Variables
at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c File Reference

usb user function More...

#include "usbh_user.h"
#include "ff.h"

Go to the source code of this file.

Enumerations

enum msc_usr_state {
USR_IDLE , USR_APP , USR_FINISH , USR_IDLE ,
USR_APP , USR_FINISH , USR_IDLE , USR_APP ,
USR_FINISH , USR_IDLE , USR_APP , USR_FINISH
}

Functions

static usb_sts_type | usbh_user_init (void)
usb host init user handler More...
static usb_sts_type | usbh_user_reset (void)
usb host reset user handler More...
static usb_sts_type | usbh_user_attached (void)
usb host check device attached More...
static usb_sts_type | usbh_user_disconnect (void)
usb host discconet user handler More...
static usb_sts_type | usbh_user_speed (uint8_t speed)
usb host speed user handler More...
static usb_sts_type | usbh_user_mfc_string (void *string)
usb host manufacturer string user handler More...
static usb_sts_type | usbh_user_product_string (void *string)
usb host product string user handler More...
static usb_sts_type | usbh_user_serial_string (void *string)
usb host serial string user handler More...
static usb_sts_type | usbh_user_enumeration_done (void)
usb host enumeration done user handler More...
static usb_sts_type | usbh_user_application (void)
static usb_sts_type | usbh_user_active_vbus (void *uhost, confirm_state state)
usb host active vbus user handler More...
static usb_sts_type | usbh_user_not_support (void)
usb host not support user handler More...

Variables

usbh_user_handler_type | usbh_user_handle
msc_usr_state usr_state = USR_IDLE
FIL | file
usb host application user handler More...
FATFS | fs

Detailed Description

usb user function

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

Function Documentation

◆ usbh_user_active_vbus()

static usb_sts_type usbh_user_active_vbus | ( | void * | uhost,
 |  | confirm_state | state
 | ) |  |
static

usb host active vbus user handler

Parameters
uhost | to the structure of usbh_core_type
state | vbus state TRUE: active vbus FALSE: deactive vbus
Return values
usb_sts_type

Definition at line 278 of file at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ usbh_user_application()

static usb_sts_type usbh_user_application ( void )
static

Definition at line 199 of file at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ usbh_user_attached()

static usb_sts_type usbh_user_attached ( void )
static

usb host check device attached

Parameters
none
Return values
usb_sts_type

Definition at line 105 of file at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ usbh_user_disconnect()

static usb_sts_type usbh_user_disconnect ( void )
static

usb host discconet user handler

Parameters
none
Return values
usb_sts_type

Definition at line 117 of file at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ usbh_user_enumeration_done()

static usb_sts_type usbh_user_enumeration_done ( void )
static

usb host enumeration done user handler

Parameters
none
Return values
usb_sts_type

Definition at line 185 of file at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ usbh_user_init()

static usb_sts_type usbh_user_init ( void )
static

usb host init user handler

Parameters
none
Return values
usb_sts_type

Definition at line 81 of file at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ usbh_user_mfc_string()

static usb_sts_type usbh_user_mfc_string ( void * string )
static

usb host manufacturer string user handler

Parameters
none
Return values
usb_sts_type

Definition at line 149 of file at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ usbh_user_not_support()

static usb_sts_type usbh_user_not_support ( void )
static

usb host not support user handler

Parameters
none
Return values
usb_sts_type

Definition at line 316 of file at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ usbh_user_product_string()

static usb_sts_type usbh_user_product_string ( void * string )
static

usb host product string user handler

Parameters
none
Return values
usb_sts_type

Definition at line 161 of file at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ usbh_user_reset()

static usb_sts_type usbh_user_reset ( void )
static

usb host reset user handler

Parameters
none
Return values
usb_sts_type

Definition at line 93 of file at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ usbh_user_serial_string()

static usb_sts_type usbh_user_serial_string ( void * string )
static

usb host serial string user handler

Parameters
none
Return values
usb_sts_type

Definition at line 173 of file at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c.

◆ usbh_user_speed()

static usb_sts_type usbh_user_speed ( uint8_t speed )
static

usb host speed user handler

Parameters
none
Return values
usb_sts_type

Definition at line 130 of file at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c.


AT32F435/437 Firmwary Library: usbh_user.c Source File

  • at_start_f437
  • examples
  • usb_host
  • two_otg_host_demo
  • src
at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
Go to the documentation of this file.
1
26#include "usbh_user.h"
27#include "ff.h"
28
37static usb_sts_type usbh_user_init(void);
38static usb_sts_type usbh_user_reset(void);
39static usb_sts_type usbh_user_attached(void);
40static usb_sts_type usbh_user_disconnect(void);
41static usb_sts_type usbh_user_speed(uint8_t speed);
42static usb_sts_type usbh_user_mfc_string(void *string);
43static usb_sts_type usbh_user_product_string(void *string);
44static usb_sts_type usbh_user_serial_string(void *string);
45static usb_sts_type usbh_user_enumeration_done(void);
46static usb_sts_type usbh_user_application(void);
47static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state);
48static usb_sts_type usbh_user_not_support(void);
49
50
51usbh_user_handler_type usbh_user_handle =
52{
53 usbh_user_init,
54 usbh_user_reset,
55 usbh_user_attached,
56 usbh_user_disconnect,
57 usbh_user_speed,
58 usbh_user_mfc_string,
59 usbh_user_product_string,
60 usbh_user_serial_string,
61 usbh_user_enumeration_done,
62 usbh_user_application,
63 usbh_user_active_vbus,
64 usbh_user_not_support,
65};
66
67typedef enum
68{
69 USR_IDLE,
70 USR_APP,
71 USR_FINISH
72}msc_usr_state;
73
74 msc_usr_state usr_state = USR_IDLE;
75
81static usb_sts_type usbh_user_init(void)
82{
83 usb_sts_type status = USB_OK;
84
85 return status;
86}
87
93static usb_sts_type usbh_user_reset(void)
94{
95 usb_sts_type status = USB_OK;
96
97 return status;
98}
99
105static usb_sts_type usbh_user_attached(void)
106{
107 usb_sts_type status = USB_OK;
108 USBH_DEBUG("USB Device Attached");
109 return status;
110}
111
117static usb_sts_type usbh_user_disconnect(void)
118{
119 usb_sts_type status = USB_OK;
120 usr_state = USR_IDLE;
121 USBH_DEBUG("Device Disconnect");
122 return status;
123}
124
130static usb_sts_type usbh_user_speed(uint8_t speed)
131{
132 usb_sts_type status = USB_OK;
133 if(speed == USB_PRTSPD_FULL_SPEED)
134 {
135 USBH_DEBUG("This is a Full-Speed device");
136 }
137 else if(speed == USB_PRTSPD_LOW_SPEED)
138 {
139 USBH_DEBUG("This is a Low-Speed device");
140 }
141 return status;
142}
143
149static usb_sts_type usbh_user_mfc_string(void *string)
150{
151 usb_sts_type status = USB_OK;
152 USBH_DEBUG("Manufacturer: %s", (uint8_t *)string);
153 return status;
154}
155
161static usb_sts_type usbh_user_product_string(void *string)
162{
163 usb_sts_type status = USB_OK;
164 USBH_DEBUG("Product: %s", (uint8_t *)string);
165 return status;
166}
167
173static usb_sts_type usbh_user_serial_string(void *string)
174{
175 usb_sts_type status = USB_OK;
176 USBH_DEBUG("Serial: %s", (uint8_t *)string);
177 return status;
178}
179
185static usb_sts_type usbh_user_enumeration_done(void)
186{
187 usb_sts_type status = USB_OK;
188 USBH_DEBUG("Enumeration done");
189 return status;
190}
191
197FIL file;
198FATFS fs;
199static usb_sts_type usbh_user_application(void)
200{
201 usb_sts_type status = USB_OK;
202 FRESULT res;
203
204 uint32_t len;
205 uint8_t write_data[] = "usb host msc demo";
206 uint8_t read_data[32] = {0};
207
208 switch(usr_state)
209 {
210 case USR_IDLE:
211 usr_state = USR_APP;
212 break;
213 case USR_APP:
214 res = f_mount(&fs, "", 0);
215 if(res == FR_OK)
216 {
217 /* start write data */
218 if(f_open(&file, "0:AT32.txt", FA_CREATE_ALWAYS | FA_WRITE) != FR_OK)
219 {
220 // error
221 USBH_DEBUG("Open AT32.txt failed");
222 }
223 else
224 {
225 res = f_write(&file, write_data, sizeof(write_data), &len);
226 if(res != FR_OK || len == 0)
227 {
228 //write error
229 USBH_DEBUG("Write AT32.txt failed");
230 }
231 else
232 {
233 //write success
234 USBH_DEBUG("Write AT32.txt Success");
235 }
236 f_close(&file);
237 }
238
239 /* start read file */
240 if(f_open(&file, "0:AT32.txt", FA_READ) != FR_OK)
241 {
242 // error
243 USBH_DEBUG("Open AT32.txt failed");
244 }
245 else
246 {
247 res = f_read(&file, read_data, sizeof(read_data), &len);
248 if(res != FR_OK || len == 0)
249 {
250 //read error
251 USBH_DEBUG("Read AT32.txt failed");
252 }
253 else
254 {
255 //read success
256 USBH_DEBUG("Read AT32.txt Success");
257 }
258 f_close(&file);
259 }
260 f_mount(NULL, "", 0);
261 }
262 usr_state = USR_FINISH;
263 break;
264 case USR_FINISH:
265 break;
266 }
267 return status;
268}
269
278static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state)
279{
280 usb_sts_type status = USB_OK;
281 usbh_core_type *puhost = (usbh_core_type *)uhost;
282#ifdef USBH_5V_POWER_SWITCH
283 if(state == TRUE)
284 {
285 /* active vbus */
286 if(puhost->usb_reg == OTG1_GLOBAL)
287 {
288 gpio_bits_reset(OTG_PIN_POWER_SWITCH_GPIO, OTG_PIN_POWER_SWITCH);
289 }
290 else if(puhost->usb_reg == OTG2_GLOBAL)
291 {
292 gpio_bits_reset(OTG2_PIN_POWER_SWITCH_GPIO, OTG2_PIN_POWER_SWITCH);
293 }
294 }
295 else
296 {
297 /* deactive vubs */
298 if(puhost->usb_reg == OTG1_GLOBAL)
299 {
300 gpio_bits_set(OTG_PIN_POWER_SWITCH_GPIO, OTG_PIN_POWER_SWITCH);
301 }
302 else if(puhost->usb_reg == OTG2_GLOBAL)
303 {
304 gpio_bits_set(OTG2_PIN_POWER_SWITCH_GPIO, OTG2_PIN_POWER_SWITCH);
305 }
306 }
307#endif
308 return status;
309}
310
316static usb_sts_type usbh_user_not_support(void)
317{
318 usb_sts_type status = USB_OK;
319
320 return status;
321}
322
usbh_user_init
static usb_sts_type usbh_user_init(void)
usb host init user handler
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:81
usbh_user_disconnect
static usb_sts_type usbh_user_disconnect(void)
usb host discconet user handler
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:117
usbh_user_not_support
static usb_sts_type usbh_user_not_support(void)
usb host not support user handler
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:316
usbh_user_application
static usb_sts_type usbh_user_application(void)
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:199
usbh_user_speed
static usb_sts_type usbh_user_speed(uint8_t speed)
usb host speed user handler
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:130
usbh_user_active_vbus
static usb_sts_type usbh_user_active_vbus(void *uhost, confirm_state state)
usb host active vbus user handler
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:278
usbh_user_serial_string
static usb_sts_type usbh_user_serial_string(void *string)
usb host serial string user handler
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:173
usbh_user_reset
static usb_sts_type usbh_user_reset(void)
usb host reset user handler
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:93
usbh_user_mfc_string
static usb_sts_type usbh_user_mfc_string(void *string)
usb host manufacturer string user handler
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:149
usbh_user_enumeration_done
static usb_sts_type usbh_user_enumeration_done(void)
usb host enumeration done user handler
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:185
usbh_user_attached
static usb_sts_type usbh_user_attached(void)
usb host check device attached
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:105
usbh_user_product_string
static usb_sts_type usbh_user_product_string(void *string)
usb host product string user handler
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:161
OTG_PIN_POWER_SWITCH_GPIO
#define OTG_PIN_POWER_SWITCH_GPIO
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h:91
OTG_PIN_POWER_SWITCH
#define OTG_PIN_POWER_SWITCH
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h:93
USBH_DEBUG
#define USBH_DEBUG(...)
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h:206
msc_usr_state
msc_usr_state
Definition: at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c:68
file
FIL file
usb host application user handler
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:197
OTG2_PIN_POWER_SWITCH
#define OTG2_PIN_POWER_SWITCH
Definition: project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h:129
OTG2_PIN_POWER_SWITCH_GPIO
#define OTG2_PIN_POWER_SWITCH_GPIO
Definition: project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h:127
usbh_user_handle
usbh_user_handler_type usbh_user_handle
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:51
msc_usr_state
msc_usr_state
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:68
usr_state
msc_usr_state usr_state
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:74
fs
FATFS fs
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:198
USR_APP
@ USR_APP
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:70
USR_FINISH
@ USR_FINISH
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:71
USR_IDLE
@ USR_IDLE
Definition: at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c:69
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
confirm_state
confirm_state
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f435_437_gpio.c:308
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f435_437_gpio.c:277
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
OTG2_GLOBAL
#define OTG2_GLOBAL
Definition: at32f435_437_usb.h:1329
OTG1_GLOBAL
#define OTG1_GLOBAL
usb host and device register define
Definition: at32f435_437_usb.h:1328
USB_PRTSPD_LOW_SPEED
#define USB_PRTSPD_LOW_SPEED
Definition: at32f435_437_usb.h:188
USB_PRTSPD_FULL_SPEED
#define USB_PRTSPD_FULL_SPEED
Definition: at32f435_437_usb.h:187
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_OK
@ USB_OK
Definition: usb_std.h:268


AT32F435/437 Firmwary Library: picture.h File Reference

  • at_start_f437
  • examples
  • xmc
  • lcd_8bit
  • inc
Variables
at_start_f437/examples/xmc/lcd_8bit/inc/picture.h File Reference

this file contains all the picture used for lcd display. More...

Go to the source code of this file.

Variables

const unsigned char | gimage_3 [51000]
const unsigned char | gimage_8 [51000]
const unsigned char | gimage_5 [51000]
const unsigned char | gimage_9 [51000]
const unsigned char | gimage_0 [51000]

Detailed Description

this file contains all the picture used for lcd display.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/xmc/lcd_8bit/inc/picture.h.

Variable Documentation

◆ gimage_0

const unsigned char gimage_0[51000]

Definition at line 12790 of file at_start_f437/examples/xmc/lcd_8bit/inc/picture.h.

◆ gimage_3

const unsigned char gimage_3[51000]

Definition at line 29 of file at_start_f437/examples/xmc/lcd_8bit/inc/picture.h.

◆ gimage_5

const unsigned char gimage_5[51000]

Definition at line 6410 of file at_start_f437/examples/xmc/lcd_8bit/inc/picture.h.

◆ gimage_8

const unsigned char gimage_8[51000]

Definition at line 3220 of file at_start_f437/examples/xmc/lcd_8bit/inc/picture.h.

◆ gimage_9

const unsigned char gimage_9[51000]

Definition at line 9600 of file at_start_f437/examples/xmc/lcd_8bit/inc/picture.h.


AT32F435/437 Firmwary Library: picture.h Source File

AT32F435_437_Firmware_Library_V2.0.9

project

at_start_f437

examples

xmc

lcd_8bit

inc

at_start_f437/examples/xmc/lcd_8bit/inc/picture.h

Go to the documentation of this file.

1

26#ifndef __PICTURE_H

27#define __PICTURE_H

28

29const unsigned char gimage_3[51000] = { /* 0X10,0X10,0X00,0X96,0X00,0XAA,0X01,0X1B, */

300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

940XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1130XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

1150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1320XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,

1330XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

1340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1500XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,

1510XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XDB,0XFF,0XDC,0XFF,0XDC,0XFF,0XDC,

1520XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

1530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1690XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,

1700XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFD,0XFF,0XFD,

1710XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

1720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1880XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,

1890XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,

1900XFF,0XFB,0XFF,0XFB,0XFF,0XFC,0XFF,0XFC,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,

1910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

1920XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

1990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2070XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFB,0XFF,0XFB,

2080XFF,0XFA,0XFF,0XFA,0XFF,0XF9,0XFF,0XF9,0XFF,0XF9,0XFF,0XF8,0XFF,0XF8,0XFF,0XF8,

2090XFF,0XF9,0XFF,0XF9,0XFF,0XFA,0XFF,0XFA,0XFF,0XFB,0XFF,0XFC,0XFF,0XFC,0XFF,0XFD,

2100XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2250XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,

2260XFF,0XFC,0XFF,0XFB,0XFF,0XFA,0XFF,0XF9,0XFF,0XF8,0XFF,0XF7,0XFF,0XF6,0XFF,0XF6,

2270XFF,0XF5,0XFF,0XF5,0XFF,0XF4,0XFF,0XF4,0XFF,0XF4,0XFF,0XF5,0XFF,0XF5,0XFF,0XF5,

2280XFF,0XF6,0XFF,0XF6,0XFF,0XF7,0XFF,0XF7,0XFF,0XF8,0XFF,0XF9,0XFF,0XFA,0XFF,0XFB,

2290XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

2310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2440XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFA,0XFF,0XF9,0XFF,0XD8,

2450XFF,0XD6,0XFF,0XD5,0XFF,0XF5,0XFF,0XF4,0XFF,0XF3,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,

2460XF7,0XF2,0XF7,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF3,

2470XFF,0XF3,0XFF,0XF4,0XFF,0XF5,0XFF,0XF6,0XFF,0XF7,0XFF,0XF8,0XFF,0XF9,0XFF,0XFB,

2480XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2490XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,

2630XFF,0XFA,0XFF,0XF9,0XFF,0XF8,0XFF,0XF6,0XFF,0XD5,0XF7,0XD4,0XFF,0XD2,0XF7,0XD2,

2640XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,

2650XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,

2660XFF,0XF2,0XFF,0XF3,0XFF,0XF3,0XFF,0XF5,0XFF,0XF6,0XFF,0XF7,0XFF,0XF8,0XFF,0XFA,

2670XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2680XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2810XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,0XFF,0XFA,0XFF,0XF8,0XFF,0XD6,0XFF,0XF5,

2820XFF,0XF4,0XFF,0XF3,0XFF,0XF2,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

2830XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

2840XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,

2850XFF,0XF2,0XFF,0XF2,0XFF,0XD3,0XFF,0XD4,0XFF,0XF5,0XFF,0XF7,0XFF,0XF9,0XFF,0XFB,

2860XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

2990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,

3000XFF,0XF9,0XFF,0XF8,0XF7,0XD7,0XF7,0XF5,0XF7,0XD2,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,

3010XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

3020XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

3030XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF1,

3040XFF,0XF2,0XFF,0XD2,0XFF,0XF3,0XFF,0XF5,0XFF,0XF7,0XFF,0XF9,0XFF,0XFB,0XFF,0XFD,

3050XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3180XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFA,0XFF,0XF8,0XFF,0XF6,0XFF,0XD5,

3190XF7,0XF4,0XF7,0XF2,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

3200XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

3210XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

3220XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF1,

3230XFF,0XF1,0XFF,0XF2,0XFF,0XF3,0XFF,0XF6,0XFF,0XF8,0XFF,0XFA,0XFF,0XFD,0XFF,0XFF,

3240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3360XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,

3370XFF,0XFB,0XFF,0XF9,0XFF,0XF6,0XFF,0XF4,0XFF,0XF3,0XFF,0XF2,0XFF,0XF1,0XFF,0XF0,

3380XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,

3390XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

3400XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

3410XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

3420XFF,0XF1,0XFF,0XF3,0XFF,0XD5,0XFF,0XD7,0XFF,0XFB,0XFF,0XFD,0XFF,0XFF,0XFF,0XDF,

3430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,

3550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFC,0XFF,0XFA,0XFF,0XF8,0XFF,0XD6,

3560XFF,0XD3,0XFF,0XF2,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

3570XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,

3580XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,

3590XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,

3600XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF1,

3610XFF,0XD3,0XFF,0XB5,0XFF,0XF8,0XFF,0XDB,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

3620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3740XFF,0XFE,0XFF,0XFC,0XFF,0XF9,0XFF,0XF7,0XFF,0XD4,0XFF,0XD3,0XFF,0XD1,0XFF,0XF0,

3750XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

3760XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

3770XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

3780XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

3790XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF1,0XFF,0XF2,0XF7,0XB3,

3800XFF,0XD6,0XFF,0XB8,0XFF,0XDB,0XFF,0XFD,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

3810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

3920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XFF,0XF9,

3930XFF,0XF6,0XFF,0XD4,0XFF,0XF2,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

3940XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

3950XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

3960XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

3970XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

3980XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XD1,0XFF,0XD3,0XF7,0XB5,

3990XFF,0XD8,0XFF,0XFB,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4110XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0XD9,0XFF,0XD6,0XFF,0XD3,0XFF,0XF1,

4120XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,

4130XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4140XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4150XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4160XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,

4170XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XD0,0XFF,0XF1,0XF7,0XB2,0XF7,0XB5,0XFF,0XD8,

4180XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFC,

4300XFF,0XFA,0XFF,0XF7,0XFF,0XD5,0XFF,0XD3,0XFF,0XF1,0XFF,0XEF,0XFF,0XEE,0XFF,0XED,

4310XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4320XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4330XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4340XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4350XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4360XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XF7,0XAF,0XF7,0X91,0XF7,0X95,0XFF,0XDB,0XFF,0XFD,

4370XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4480XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XD9,0XFF,0XF6,0XFF,0XD3,

4490XFF,0XF1,0XFF,0XF0,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

4500XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4510XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4520XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4530XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,

4540XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XCC,

4550XFF,0XED,0XFF,0XEE,0XF7,0X8F,0XEF,0X31,0XF7,0X98,0XFF,0XFC,0XFF,0XFE,0XFF,0XFE,

4560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

4670XFF,0XFD,0XFF,0XFC,0XFF,0XFA,0XFF,0XD6,0XFF,0XD2,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,

4680XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

4690XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4700XFF,0XEF,0XFF,0XEE,0XFF,0XEF,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

4710XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,

4720XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,

4730XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XED,0XF7,0XCB,0XFF,0XEC,0XFF,0XED,

4740XF7,0XAE,0XE7,0X0F,0XEF,0X55,0XFF,0XFA,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,

4750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XFB,0XFF,0XF9,

4860XFF,0XD6,0XFF,0XD3,0XFF,0XF0,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,

4870XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

4880XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

4890XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

4900XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

4910XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,

4920XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XCE,0XE7,0X0E,

4930XDE,0XB0,0XFF,0XB8,0XFF,0XFC,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

4990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5040XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0XF9,0XFF,0XF6,0XFF,0XD3,0XFF,0XD1,

5050XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

5060XFF,0XEE,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

5070XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

5080XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

5090XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

5100XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,

5110XFF,0XED,0XFF,0XCC,0XFF,0XEC,0XFF,0XCC,0XFF,0XCE,0XEF,0X2E,0XCE,0X4D,0XDE,0XD2,

5120XFF,0XFB,0XFF,0XFE,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

5130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

5230XFF,0XFC,0XFF,0XF9,0XFF,0XF6,0XFF,0XF3,0XFF,0XF0,0XFF,0XEF,0XFF,0XEE,0XFF,0XED,

5240XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,

5250XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XCD,0XFF,0XCE,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,

5260XFF,0XEE,0XFF,0XED,0XFF,0XEE,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

5270XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

5280XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

5290XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCC,

5300XFF,0XCC,0XFF,0XED,0XFF,0XCE,0XF7,0X4E,0XCE,0X0B,0XC5,0XCD,0XFF,0X78,0XFF,0XFD,

5310XFF,0XBE,0XFF,0XDF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFA,0XFF,0XF7,

5420XFF,0XF3,0XFF,0XF0,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

5430XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,

5440XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

5450XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

5460XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

5470XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

5480XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,

5490XFF,0XCE,0XFF,0X6E,0XCE,0X0A,0XB5,0X6A,0XDE,0X73,0XFF,0XFC,0XFF,0XDD,0XFF,0XFF,

5500XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5600XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XF8,0XF7,0XD4,0XF7,0XD0,0XFF,0XEE,

5610XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,

5620XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCD,

5630XFF,0XED,0XFF,0XED,0XFF,0XCD,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

5640XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

5650XFF,0XCD,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCD,0XFF,0XED,

5660XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

5670XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCD,0XFF,0XCC,0XFF,0XCD,0XFF,0XAD,0XFF,0X8E,

5680XD6,0X2A,0XB5,0X29,0XB5,0X0D,0XFF,0X58,0XFF,0XFD,0XFF,0XDE,0XFF,0XFE,0XFF,0XDE,

5690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

5790XFF,0XFC,0XFF,0XF9,0XFF,0XD5,0XF7,0XB2,0XF7,0XAF,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,

5800XFF,0XEE,0XFF,0XEE,0XFF,0XCE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

5810XFF,0XEC,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCD,0XFF,0XCD,0XFF,0XED,0XFF,0XED,

5820XFF,0XCD,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

5830XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XCD,0XFF,0XCD,

5840XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XED,0XFF,0XCD,

5850XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

5860XFF,0XCD,0XFF,0XCD,0XFF,0XCC,0XFF,0XCD,0XFF,0XAD,0XFF,0XAE,0XDE,0X2A,0XB5,0X08,

5870XA4,0X69,0XDE,0X53,0XFF,0XDB,0XFF,0XDD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

5880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

5970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XFA,0XF7,0XD6,

5980XF7,0XB3,0XF7,0XD0,0XFF,0XCE,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XCE,

5990XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XF7,0XCC,0XFF,0XCD,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,

6000XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XAC,0XFF,0XAC,0XFF,0XCC,0XFF,0XCD,

6010XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCD,

6020XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCC,0XFF,0XCC,

6030XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

6040XFF,0XCD,0XFF,0XCD,0XFF,0XCC,0XFF,0XCC,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

6050XFF,0XCC,0XFF,0XEC,0XFF,0XAC,0XFF,0XAD,0XDE,0X2A,0XAC,0XC7,0X9C,0X47,0XBD,0X4E,

6060XF7,0X37,0XFF,0XDC,0XFF,0XFD,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6160XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0XF7,0XF7,0XB3,0XF7,0XB0,0XFF,0XCF,

6170XFF,0XEE,0XFF,0XCD,0XFF,0XEC,0XFF,0XEC,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

6180XFF,0XCD,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0X6B,0XF7,0X4A,0XF7,0X4A,0XF7,0X4B,

6190XF7,0X2B,0XF7,0X4B,0XF7,0X6B,0XF7,0X8B,0XFF,0XAC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,

6200XFF,0XCC,0XFF,0XCC,0XFF,0XED,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

6210XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAC,0XFF,0XAD,0XFF,0XAD,

6220XFF,0XAD,0XFF,0XAD,0XFF,0XCD,0XFF,0XCC,0XFF,0XCD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAD,

6230XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAC,0XFF,0XCC,

6240XFF,0X8B,0XFF,0X8D,0XD6,0X0A,0XAC,0X66,0XA4,0X47,0XAC,0XAA,0XD6,0X53,0XFF,0XDA,

6250XFF,0XFC,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

6350XFF,0XFC,0XFF,0XF8,0XF7,0XD4,0XF7,0XB0,0XF7,0XAF,0XFF,0XAE,0XFF,0X8E,0XFF,0XAD,

6360XFF,0XAC,0XFF,0XAB,0XFF,0XAC,0XFF,0XAD,0XFF,0X8D,0XFF,0X6C,0XF7,0X4B,0XF7,0X0A,

6370XEE,0XE9,0XEE,0XC8,0XEE,0X88,0XE6,0X87,0XE6,0X68,0XE6,0X47,0XE6,0X47,0XE6,0X47,

6380XDE,0X46,0XE6,0X87,0XEE,0XE9,0XF7,0X4A,0XFF,0X8B,0XFF,0X8C,0XFF,0XCD,0XFF,0X8C,

6390XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0X8C,0XFF,0XAD,0XFF,0XCD,0XFF,0X8C,0XFF,0X8C,

6400XFF,0XAC,0XFF,0XAC,0XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAC,0XFF,0XAC,

6410XFF,0XAC,0XFF,0XAC,0XFF,0XAD,0XFF,0XAD,0XFF,0X8D,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,

6420XFF,0X8C,0XFF,0X8C,0XFF,0XAD,0XFF,0X8C,0XFF,0XAC,0XFF,0XAB,0XF7,0X6B,0XFF,0X8D,

6430XCD,0XC9,0X9C,0X25,0X9C,0X47,0X9C,0X48,0XB5,0X4D,0XF7,0X78,0XFF,0XDC,0XFF,0XFE,

6440XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFA,0XF7,0XD6,

6540XF7,0XB1,0XF7,0XAF,0XFF,0XAD,0XFF,0XAD,0XFF,0X8D,0XFF,0X8D,0XFF,0X8C,0XFF,0X8C,

6550XFF,0X6C,0XFF,0X4C,0XF7,0X0B,0XF6,0XCA,0XEE,0XA9,0XEE,0X88,0XEE,0X88,0XEE,0X88,

6560XEE,0X68,0XF6,0X88,0XF6,0X68,0XF6,0X68,0XEE,0X47,0XEE,0X26,0XE6,0X45,0XE6,0X25,

6570XDE,0X05,0XD6,0X05,0XDE,0X68,0XF7,0X2B,0XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0X8D,

6580XFF,0X8D,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0XAC,0XFF,0X8C,0XFF,0X8C,

6590XFF,0X8C,0XFF,0X8D,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0XAC,0XFF,0X8C,0XFF,0X8C,

6600XFF,0X8D,0XFF,0X8D,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8B,0XFF,0X8B,0XFF,0X8C,

6610XFF,0X8D,0XFF,0X8D,0XFF,0X8B,0XFF,0XCC,0XFF,0X6B,0XFF,0X8D,0XCD,0XC9,0X8B,0XA3,

6620X8B,0XA5,0X9C,0X27,0X9C,0X89,0XD6,0X72,0XFF,0XFB,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

6630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6720XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XD8,0XF7,0X93,0XF7,0X6F,0XF7,0X8D,

6730XFF,0XAC,0XFF,0X8C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X2B,0XFE,0XEB,0XF6,0XCA,

6740XF6,0X89,0XEE,0X68,0XEE,0X68,0XF6,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,

6750XFE,0X68,0XF6,0X47,0XEE,0X06,0XE5,0XE6,0XD5,0X63,0XD5,0X83,0XD5,0XA4,0XD5,0XC5,

6760XD5,0XE6,0XD6,0X07,0XE6,0X69,0XFF,0X4D,0XFF,0X8D,0XFF,0X8D,0XFF,0X8D,0XFF,0X8C,

6770XFF,0X8C,0XFF,0X8C,0XFF,0XCC,0XFF,0X8B,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,

6780XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X6D,

6790XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6B,0XFF,0X6B,0XFF,0X8C,0XFF,0X6C,0XFF,0X6C,

6800XFF,0X8B,0XFF,0XAC,0XFF,0X6B,0XFF,0X6D,0XC5,0X69,0X73,0X01,0X83,0X84,0X94,0X07,

6810X8C,0X27,0XAD,0X2E,0XEF,0X18,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

6820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

6900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

6910XFF,0XFD,0XFF,0XD9,0XFF,0X95,0XF7,0X71,0XF7,0X6E,0XFF,0X6C,0XFF,0X8B,0XFF,0X8B,

6920XFF,0X6B,0XFF,0X4C,0XFF,0X0C,0XFE,0XAA,0XEE,0X69,0XEE,0X48,0XF6,0X68,0XF6,0X89,

6930XFE,0XA9,0XFE,0XA9,0XFE,0X89,0XFE,0XA9,0XFE,0XA8,0XFE,0X88,0XFE,0X88,0XF6,0X67,

6940XF6,0X27,0XEE,0X27,0XEE,0X06,0XDD,0X63,0XBC,0XC1,0XAC,0X60,0XA4,0X40,0XB4,0XE3,

6950XD5,0XA8,0XEE,0XCC,0XF7,0X0D,0XFF,0X6E,0XFF,0X8D,0XFF,0X6C,0XFF,0X6B,0XFF,0X8B,

6960XFF,0XAB,0XFF,0X6B,0XFF,0X8B,0XFF,0X8C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,

6970XFF,0X6C,0XFF,0X6C,0XFF,0X8C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,

6980XFF,0X6B,0XFF,0X6B,0XFF,0X6B,0XFF,0X4C,0XFF,0X6C,0XF7,0X2B,0XFF,0X8B,0XFF,0X6B,

6990XFF,0X6C,0XF7,0X4D,0XBD,0X27,0X6A,0XC0,0X83,0X63,0X94,0X27,0X94,0X27,0X94,0X49,

7000XDE,0X95,0XFF,0XBB,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XFF,0XDA,0XFF,0XB6,

7100XF7,0X51,0XF7,0X6E,0XF7,0X4C,0XFF,0X6B,0XFF,0X8B,0XFF,0X6A,0XFF,0X4A,0XFF,0X0B,

7110XF6,0X8A,0XF6,0X4A,0XEE,0X48,0XF6,0X68,0XFE,0XA9,0XFE,0XC9,0XFE,0XA9,0XFE,0XA9,

7120XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA8,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,

7130XF6,0X46,0XED,0XC4,0XE5,0XA4,0XCD,0X02,0X9B,0XA0,0X93,0X60,0XA4,0X01,0XBC,0XE6,

7140XDE,0X0A,0XFF,0X0D,0XFF,0X4D,0XFF,0X6C,0XFF,0X6B,0XFF,0X6A,0XFF,0X6A,0XFF,0X6B,

7150XFF,0X6B,0XFF,0X6B,0XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X6C,0XFF,0X6B,0XFF,0X6B,

7160XFF,0X6C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4B,0XFF,0X4B,

7170XFF,0X4B,0XFF,0X2B,0XFF,0X4C,0XF7,0X0B,0XFF,0X6B,0XFF,0X2B,0XFF,0X4C,0XF7,0X2D,

7180X9C,0X45,0X62,0X80,0X73,0X02,0X7B,0X64,0X8C,0X07,0X8C,0X08,0XAC,0XEE,0XF7,0X59,

7190XFF,0XFC,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7280XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XFF,0XB8,0XF7,0X73,0XF7,0X2F,0XFF,0X4D,

7290XFF,0X4C,0XFF,0X4B,0XFF,0X4A,0XFF,0X49,0XFF,0X09,0XF6,0XA9,0XF6,0X6A,0XF6,0X6A,

7300XF6,0X89,0XFE,0XA9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XCA,0XFE,0XCA,

7310XFE,0XC9,0XFE,0XA9,0XFE,0XA8,0XFE,0XA8,0XF6,0X88,0XFE,0X88,0XFE,0X46,0XFE,0X26,

7320XF6,0X05,0XE5,0XA5,0XBC,0XA2,0X9B,0X80,0X83,0X00,0X93,0X81,0XB4,0XA5,0XEE,0X4B,

7330XFF,0X2E,0XFF,0X4C,0XFF,0X4B,0XFF,0X4B,0XFF,0X6B,0XFF,0X6B,0XFF,0X6B,0XFF,0X4C,

7340XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4C,0XFF,0X4C,

7350XFF,0X2C,0XFF,0X2C,0XFF,0X4C,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,

7360XFF,0X2C,0XFF,0X4C,0XFF,0X0B,0XFF,0X4B,0XFF,0X2C,0XEE,0XED,0X8B,0XC3,0X62,0X80,

7370X62,0XA1,0X7B,0X64,0X8B,0XC6,0X8C,0X08,0X9C,0X4B,0XDE,0X75,0XFF,0XDC,0XFF,0XFD,

7380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

7470XFF,0XFC,0XFF,0XD9,0XFF,0X95,0XF7,0X51,0XF7,0X2D,0XFF,0X2C,0XFF,0X2B,0XFF,0X2A,

7480XFF,0X09,0XFE,0XE9,0XF6,0XA8,0XF6,0X88,0XF6,0X8A,0XFE,0XAA,0XFE,0XAA,0XFE,0XC9,

7490XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XA9,0XFE,0XA9,0XFE,0XC9,0XFE,0XC9,

7500XFE,0XC8,0XFE,0XC8,0XFE,0XC8,0XFE,0XA8,0XF6,0X26,0XFE,0X88,0XFE,0X67,0XEE,0X06,

7510XE5,0XE6,0XC4,0XC3,0X93,0X60,0X7A,0X80,0X8B,0X41,0XC4,0XE7,0XF6,0X8C,0XFE,0XEC,

7520XFF,0X0B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4A,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,

7530XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X2B,0XFF,0X2C,0XFF,0X2C,0XFF,0X2C,

7540XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X0B,0XFF,0X2C,

7550XF6,0XEA,0XFF,0X2C,0XF7,0X0C,0XDE,0X4B,0X7B,0X41,0X5A,0X40,0X62,0XA1,0X73,0X23,

7560X7B,0X85,0X94,0X07,0X83,0X87,0XBD,0X50,0XFF,0XBB,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

7570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFA,0XFF,0XD7,

7660XF7,0X73,0XEF,0X0F,0XF7,0X0C,0XFF,0X0B,0XFF,0X0A,0XFF,0X09,0XFE,0XE9,0XFE,0XC8,

7670XF6,0XA8,0XF6,0XA8,0XFE,0XA9,0XFE,0XCA,0XFE,0XCA,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,

7680XFE,0XC9,0XFE,0XA9,0XFE,0XCA,0XFE,0XCA,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,

7690XFE,0XC9,0XFE,0XA9,0XFE,0XA9,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XF6,0X68,0XDD,0XC6,

7700XBC,0XC4,0X8B,0X20,0X72,0X80,0X93,0X82,0XD5,0X89,0XFE,0XEC,0XFF,0X2C,0XFF,0X2B,

7710XFF,0X0A,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,

7720XFF,0X2B,0XFF,0X2B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,

7730XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XF6,0XCA,0XFF,0X0C,

7740XF6,0XEC,0XCD,0XC9,0X7B,0X22,0X52,0X00,0X5A,0X81,0X6A,0XE3,0X73,0X23,0X83,0XA6,

7750X8B,0X87,0X9C,0X6C,0XF7,0X99,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7840XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XF8,0XFF,0XB4,0XF7,0X10,0XF7,0X0E,

7850XFF,0X0C,0XFE,0XEA,0XFF,0X09,0XFE,0XA7,0XF6,0XA8,0XF6,0X88,0XF6,0XA8,0XFE,0XA9,

7860XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,

7870XFE,0XCA,0XFE,0XCA,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XA9,0XFE,0XA9,0XFE,0XAA,

7880XFE,0XAA,0XFE,0X89,0XFE,0X89,0XFE,0X88,0XF6,0X67,0XE6,0X27,0XDD,0XE7,0XB4,0X84,

7890X83,0X00,0X72,0XC0,0XAC,0X44,0XEE,0X6B,0XFF,0X4D,0XFE,0XEA,0XFF,0X2B,0XFF,0X0B,

7900XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,

7910XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,

7920XFE,0XEA,0XFF,0X0B,0XFE,0XEB,0XFE,0XAA,0XFF,0X0B,0XFE,0XEB,0XEE,0XAC,0XBD,0X27,

7930X7B,0X43,0X49,0XE0,0X5A,0X41,0X5A,0X81,0X6A,0XE3,0X7B,0X45,0X8B,0X87,0X8B,0XE9,

7940XDE,0X96,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

7990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8030XFF,0XFE,0XFF,0XFB,0XFF,0XB6,0XF7,0X51,0XEE,0XCE,0XF6,0XED,0XFF,0X2C,0XFF,0X0A,

8040XF6,0XA7,0XFE,0XA7,0XF6,0X88,0XF6,0X89,0XFE,0XA9,0XFE,0XC9,0XFE,0XC8,0XFE,0XC8,

8050XFE,0XC9,0XFE,0XCA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,

8060XFE,0XCA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XA9,0XFE,0XAA,0XFE,0X8A,0XFE,0X6A,

8070XFE,0X89,0XF6,0X88,0XF6,0X87,0XEE,0X88,0XEE,0X89,0XCD,0XA7,0XA4,0X23,0X7A,0XE0,

8080X93,0XA1,0XD5,0XC8,0XFE,0XEB,0XFE,0XEB,0XFE,0XEB,0XFE,0XEB,0XFE,0XEB,0XFF,0X0B,

8090XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFE,0XEB,0XFE,0XEA,0XFE,0XEB,0XFE,0XEB,

8100XFE,0XEB,0XFE,0XEB,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

8110XFE,0XCA,0XFE,0XCA,0XFE,0XCB,0XFE,0XEB,0XEE,0X6B,0XAC,0XC7,0X73,0X02,0X49,0XE0,

8120X52,0X20,0X52,0X41,0X62,0XC2,0X73,0X04,0X7B,0X25,0X83,0X88,0XC5,0XF3,0XFF,0XFD,

8130XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFA,

8220XFF,0X73,0XF7,0X0F,0XF6,0XCD,0XFF,0X0D,0XFE,0XEB,0XFE,0XC9,0XF6,0X86,0XFE,0XC7,

8230XFE,0XA8,0XFE,0X89,0XFE,0XAA,0XFE,0XCA,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XCA,

8240XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,

8250XFE,0XAA,0XFE,0XAA,0XFE,0XA9,0XFE,0XA9,0XFE,0X8A,0XFE,0X8A,0XFE,0XA9,0XFE,0XA8,

8260XF6,0XA7,0XF6,0X87,0XEE,0XA8,0XDE,0X08,0XC5,0X68,0X93,0XC2,0X83,0X40,0XBC,0XE5,

8270XF6,0XAB,0XFE,0XEB,0XFE,0XEC,0XFE,0XEB,0XFE,0XEB,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

8280XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XCA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

8290XFE,0XEA,0XFE,0XEA,0XFE,0XCA,0XFE,0XCA,0XFE,0XEA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,

8300XFE,0XCB,0XFE,0XEC,0XDD,0XEA,0XAC,0XC7,0X6A,0XA1,0X49,0XE0,0X49,0XE0,0X4A,0X01,

8310X62,0X82,0X6A,0XC3,0X72,0XE4,0X7B,0X47,0XAD,0X10,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,

8320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8400XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XFC,0XFF,0XB8,0XEE,0XF0,0XF6,0XCD,

8410XF6,0XAC,0XFE,0XCB,0XF6,0XA9,0XF6,0X88,0XFE,0XC7,0XF6,0XA6,0XFE,0XA9,0XFE,0XAA,

8420XFE,0XAA,0XFE,0XCA,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,

8430XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XAB,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,

8440XFE,0XAA,0XFE,0X8A,0XFE,0X8A,0XFE,0X8A,0XFE,0X8A,0XFE,0XA9,0XFE,0XC9,0XF6,0XC9,

8450XF6,0XCA,0XE6,0X8B,0XDE,0X2C,0XC5,0X29,0X9C,0X04,0XAC,0X84,0XF6,0X8B,0XF6,0XAB,

8460XFE,0XCB,0XFE,0XCB,0XFE,0XCB,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XE9,0XFE,0XEA,

8470XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,

8480XFE,0XC9,0XFE,0XCA,0XFE,0XCA,0XFE,0XA9,0XFE,0XCA,0XFE,0XAA,0XFE,0XEB,0XF6,0XAB,

8490XCD,0X89,0XB4,0XE8,0X5A,0X40,0X49,0XE1,0X49,0XE1,0X49,0XC1,0X5A,0X42,0X62,0X83,

8500X6A,0XA4,0X73,0X26,0X9C,0X8E,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

8590XFF,0XFE,0XFF,0XFD,0XFF,0XDA,0XFF,0X54,0XEE,0XAE,0XFE,0XCC,0XFE,0XCB,0XFE,0XAA,

8600XFE,0XA9,0XF6,0X88,0XFE,0XC7,0XF6,0X87,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XCA,

8610XFE,0XAA,0XFE,0XCA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,

8620XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,

8630XFE,0XAB,0XFE,0XAB,0XF6,0X6B,0XEE,0X6B,0XEE,0X8B,0XEE,0X8B,0XE6,0X6C,0XE6,0X6E,

8640XDE,0X2E,0XDE,0X0E,0XBD,0X2A,0XAC,0XA6,0XE6,0X0A,0XF6,0XAA,0XFE,0XCA,0XFE,0XAA,

8650XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XCA,0XFE,0XCA,

8660XFE,0XAA,0XFE,0XAA,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

8670XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XF6,0X89,0XFE,0XCA,0XE6,0X29,0XCD,0XA9,0XA4,0X46,

8680X52,0X00,0X51,0XE1,0X49,0XC2,0X41,0XA1,0X52,0X02,0X5A,0X42,0X62,0X83,0X6A,0XC6,

8690X8C,0X2C,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,

8780XFF,0X97,0XEE,0XD1,0XEE,0X8C,0XF6,0XAA,0XFE,0XA9,0XF6,0X68,0XFE,0XA9,0XFE,0XA9,

8790XF6,0X67,0XFE,0XA8,0XFE,0XAA,0XFE,0XAA,0XFE,0XCA,0XFE,0XCA,0XFE,0XAA,0XFE,0XAA,

8800XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XCA,0XFE,0XCA,0XFE,0XC9,

8810XFE,0XC9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XAB,0XFE,0XAB,0XEE,0X8B,0XF6,0XAD,

8820XF6,0XAE,0XF6,0XCF,0XF6,0XF0,0XF7,0X11,0XF7,0X13,0XFF,0X75,0XFF,0X77,0XFF,0X56,

8830XF7,0X13,0XD5,0XCC,0XD5,0XE9,0XFF,0X0B,0XFE,0XCA,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,

8840XFE,0XA9,0XFE,0XC9,0XFE,0XC9,0XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,

8850XFE,0XA9,0XFE,0XA9,0XFE,0XA8,0XFE,0XA8,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

8860XFE,0X89,0XFE,0XA9,0XF6,0XAA,0XDE,0X09,0XD5,0XEB,0X83,0X63,0X51,0XE0,0X51,0XE2,

8870X49,0XC2,0X41,0XA1,0X49,0XC1,0X52,0X02,0X5A,0X43,0X62,0XA5,0X83,0XCB,0XFF,0XFD,

8880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

8890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

8960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XF9,0XF7,0X74,0XE6,0X8E,

8970XF6,0XAA,0XFE,0XA8,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XF6,0X68,0XFE,0XCA,

8980XFE,0XCB,0XFE,0XAB,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,

8990XFE,0XAB,0XFE,0XAB,0XFE,0XAA,0XFE,0XAA,0XFE,0XC9,0XFE,0XC8,0XFE,0XE8,0XFE,0XC9,

9000XFE,0XC9,0XF6,0XAA,0XFE,0XAC,0XF6,0XCD,0XEE,0XAE,0XEF,0X10,0XF7,0X13,0XFF,0X55,

9010XFF,0X77,0XFF,0XB9,0XFF,0X9A,0XFF,0XDB,0XFF,0XDC,0XFF,0XDB,0XFF,0XD8,0XE6,0X90,

9020XD5,0XC9,0XF6,0XEA,0XFE,0XC9,0XFE,0XA8,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

9030XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA8,

9040XFE,0XA8,0XFE,0XA8,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0X89,0XF6,0X88,0XF6,0XA9,

9050XEE,0X68,0XE6,0X4A,0XCD,0X69,0X7B,0X02,0X62,0X42,0X52,0X02,0X49,0XA2,0X49,0XC2,

9060X49,0XC2,0X49,0XE2,0X52,0X23,0X52,0X64,0X7B,0XCB,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,

9070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9150XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XFF,0XB8,0XEF,0X12,0XDE,0X4C,0XF6,0XAA,0XF6,0X67,

9160XF6,0X46,0XFE,0X88,0XFE,0X88,0XF6,0X69,0XFE,0XCA,0XFE,0XAA,0XFE,0XAB,0XFE,0XAA,

9170XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAB,0XFE,0XAB,0XFE,0XAB,

9180XFE,0XAB,0XFE,0XAA,0XFE,0XA9,0XFE,0XC8,0XFE,0XE8,0XFE,0XE9,0XF6,0XCA,0XF6,0XAB,

9190XF6,0XAE,0XEE,0XD0,0XFF,0X94,0XFF,0XB6,0XFF,0XB8,0XFF,0XDB,0XFF,0XDC,0XFF,0XFE,

9200XFF,0XDE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFD,0XFF,0XB9,0XE6,0XB2,0XD6,0X0A,0XE6,0X69,

9210XF6,0XA9,0XFE,0XA8,0XFE,0X89,0XFE,0X89,0XFE,0XA9,0XFE,0XA8,0XFE,0XA8,0XFE,0X88,

9220XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,

9230XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0X88,0XF6,0X89,0XF6,0X68,0XE6,0X08,0XE6,0X4A,

9240XAC,0X85,0X7A,0XE2,0X72,0XA4,0X5A,0X23,0X51,0XC2,0X51,0XE3,0X49,0XC2,0X41,0XC1,

9250X49,0XE2,0X4A,0X03,0X83,0XCC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

9340XFF,0XDB,0XF7,0X56,0XCD,0XEE,0XCD,0XEA,0XE6,0X49,0XEE,0X48,0XFE,0X89,0XFE,0X88,

9350XF6,0X68,0XFE,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0XCA,0XFE,0X89,0XFE,0XAA,0XFE,0XAA,

9360XFE,0XA9,0XFE,0XCA,0XFE,0XCA,0XFE,0XCB,0XFE,0XAB,0XFE,0XAB,0XFE,0X8A,0XFE,0XAA,

9370XFE,0XA8,0XFE,0XA8,0XFE,0XC8,0XF6,0XC9,0XF6,0XAC,0XEE,0XCE,0XF7,0X12,0XFF,0X77,

9380XFF,0XFB,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

9390XFF,0XDF,0XFF,0XFE,0XFF,0XDB,0XEE,0XD3,0XDE,0X2C,0XEE,0X8A,0XF6,0XAA,0XF6,0X89,

9400XF6,0X89,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X69,0XF6,0X69,

9410XFE,0X89,0XF6,0X68,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,

9420XF6,0X68,0XF6,0X68,0XF6,0X88,0XEE,0X48,0XE6,0X49,0XD5,0XC9,0X93,0XE4,0X83,0X44,

9430X7A,0XE5,0X62,0X64,0X5A,0X03,0X51,0XE2,0X49,0XC1,0X49,0XC2,0X39,0XA2,0X41,0XC4,

9440X84,0X0E,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XEF,0X16,

9530XCD,0XEF,0XD6,0X0D,0XD5,0XC9,0XEE,0X6A,0XF6,0X8A,0XF6,0X6A,0XF6,0X89,0XFE,0X89,

9540XF6,0X88,0XFE,0XA8,0XFE,0XA8,0XFE,0XA9,0XFE,0X89,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,

9550XF6,0XAA,0XFE,0XAA,0XFE,0XCA,0XFE,0XAA,0XFE,0XAA,0XFE,0X89,0XFE,0X89,0XFE,0XC9,

9560XFE,0XCA,0XEE,0XAB,0XEE,0XAE,0XF7,0X13,0XFF,0X98,0XFF,0XFB,0XFF,0XFE,0XFF,0XFF,

9570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XF7,0XDF,0XFF,0XDE,

9580XFF,0XDB,0XEE,0XB3,0XDE,0X2C,0XEE,0X6A,0XF6,0X6A,0XF6,0X69,0XF6,0X88,0XF6,0X88,

9590XF6,0X88,0XF6,0X88,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

9600XF6,0X88,0XF6,0X88,0XF6,0X68,0XF6,0X68,0XF6,0X88,0XF6,0X68,0XF6,0X68,0XF6,0X88,

9610XF6,0X68,0XE6,0X07,0XFE,0XCC,0XBC,0XE6,0X93,0XE4,0X8B,0XA5,0X72,0XC4,0X72,0XC5,

9620X5A,0X23,0X5A,0X43,0X49,0XE1,0X49,0XC2,0X41,0XC3,0X39,0XA4,0X94,0X91,0XFF,0XFE,

9630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9710XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFD,0XFF,0X9A,0XCE,0X11,0X94,0X08,

9720XAC,0XA8,0XD5,0X8A,0XE6,0X2C,0XF6,0X6C,0XF6,0XAB,0XFE,0XCA,0XF6,0X88,0XF6,0X87,

9730XFE,0XC8,0XFE,0XC9,0XFE,0X89,0XFE,0X89,0XFE,0XAA,0XF6,0X89,0XF6,0X89,0XFE,0XC9,

9740XFE,0XC9,0XFE,0XC9,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XF6,0XAA,0XF6,0X8B,0XEE,0XAE,

9750XFF,0X33,0XFF,0XD9,0XFF,0XFC,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XDB,0XE6,0X93,

9770XDE,0X2C,0XEE,0X6A,0XEE,0X69,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

9780XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

9790XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XFE,0X89,0XEE,0X28,0XEE,0X07,0XFF,0X0C,

9800XDD,0XC7,0XB4,0XC5,0XA4,0X65,0X93,0XC5,0X83,0X45,0X72,0XE5,0X62,0X43,0X62,0X63,

9810X52,0X02,0X49,0XE3,0X41,0XA3,0X31,0X83,0XBD,0XD6,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9900XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0X9A,0XE6,0X95,0X9C,0X29,0X72,0XC3,

9910X7B,0X02,0XB4,0XC7,0XEE,0X4C,0XEE,0X6A,0XF6,0XCA,0XF6,0XC9,0XF6,0X88,0XF6,0X88,

9920XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XA9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC8,0XFE,0XA9,

9930XFE,0XAA,0XFE,0XAA,0XF6,0XAB,0XEE,0X8C,0XF6,0XCF,0XFF,0X53,0XFF,0XB8,0XFF,0XFC,

9940XFF,0XFE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

9950XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XDD,0XFF,0XDA,0XE6,0X92,0XE6,0X4C,0XEE,0X6A,

9960XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

9970XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X48,0XF6,0X68,0XF6,0X68,

9980XF6,0X68,0XF6,0X48,0XEE,0X28,0XF6,0X48,0XFE,0X8A,0XEE,0X29,0XDD,0XA7,0XBC,0XC4,

9990XAC,0XA6,0XA4,0X46,0X8B,0XA6,0X7B,0X25,0X72,0XC4,0X62,0X83,0X52,0X02,0X49,0XC2,

10000X41,0XC3,0X4A,0X06,0XE6,0XFA,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10090XFF,0XFE,0XFF,0XFE,0XFF,0XDD,0XFF,0XDC,0XFF,0XBB,0XC5,0X91,0X83,0X47,0X62,0X82,

10100X8B,0XA4,0XCD,0XAA,0XEE,0X8B,0XEE,0X8A,0XF6,0XA9,0XFE,0XC9,0XF6,0X88,0XFE,0X88,

10110XFE,0XA8,0XFE,0XA8,0XFE,0XC8,0XFE,0XC8,0XFE,0XA8,0XFE,0XA9,0XFE,0XAA,0XF6,0XAB,

10120XF6,0XAD,0XF6,0XD0,0XF7,0X34,0XFF,0X98,0XFF,0XDB,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,

10130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

10140XFF,0XFE,0XFF,0XDC,0XFF,0XB9,0XE6,0X91,0XE6,0X4B,0XEE,0X69,0XF6,0X48,0XF6,0X68,

10150XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

10160XF6,0X48,0XF6,0X68,0XF6,0X48,0XEE,0X48,0XF6,0X48,0XF6,0X48,0XEE,0X48,0XEE,0X48,

10170XEE,0X27,0XF6,0X69,0XFE,0XAA,0XE5,0XE7,0XD5,0X66,0XC5,0X26,0XBC,0XE6,0XAC,0X86,

10180X93,0XC5,0X8B,0XA6,0X7B,0X04,0X6A,0X83,0X5A,0X42,0X49,0XE2,0X41,0XC3,0X6B,0X2A,

10190XF7,0X7C,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XDE,

10280XFF,0XFF,0XFF,0XFF,0XFF,0X9D,0XFF,0X5B,0XEE,0XD7,0XAC,0XEE,0X73,0X05,0X72,0XE2,

10290X9C,0X45,0XDE,0X4C,0XE6,0X6A,0XF6,0XCB,0XFE,0XCA,0XF6,0X68,0XF6,0X88,0XFE,0XA8,

10300XFE,0XA8,0XFE,0X88,0XFE,0XA9,0XFE,0XCA,0XFE,0XAB,0XF6,0XAC,0XEE,0XAF,0XF7,0X34,

10310XFF,0X98,0XFF,0XDB,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDC,

10330XFF,0X98,0XE6,0X90,0XE6,0X4A,0XEE,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X28,0XF6,0X28,

10340XF6,0X28,0XF6,0X28,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XF6,0X48,

10350XEE,0X28,0XEE,0X48,0XF6,0X68,0XEE,0X48,0XEE,0X28,0XEE,0X48,0XF6,0X89,0XFE,0X89,

10360XF6,0X68,0XE5,0XE7,0XDD,0XA7,0XCD,0X46,0XC5,0X07,0XB4,0XC7,0XA4,0X46,0X93,0XC5,

10370X83,0X64,0X72,0XC3,0X6A,0XA3,0X5A,0X64,0X39,0X82,0XA4,0XD1,0XFF,0XBD,0XFF,0XFF,

10380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10470XFF,0XFF,0XFF,0XDE,0XFF,0XDD,0XF7,0X7B,0XD6,0X75,0X9C,0X6C,0X62,0XA3,0X73,0X23,

10480XB4,0XE8,0XE6,0X4C,0XEE,0X8B,0XF6,0XAA,0XFE,0XA9,0XFE,0XE9,0XFE,0XA8,0XF6,0X88,

10490XFE,0XA9,0XF6,0XAA,0XEE,0X8B,0XEE,0X8E,0XEE,0XF2,0XFF,0XB8,0XFF,0XFC,0XFF,0XFD,

10500XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XFF,0X56,0XE6,0X6E,

10520XE6,0X49,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

10530XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X28,

10540XF6,0X48,0XEE,0X28,0XEE,0X28,0XF6,0X68,0XFE,0XA9,0XFE,0X88,0XF6,0X47,0XF6,0X28,

10550XE5,0XE8,0XDD,0X88,0XCD,0X27,0XC5,0X08,0XB4,0XA7,0X9C,0X05,0X9C,0X06,0X83,0X44,

10560X6A,0XC4,0X5A,0X84,0X52,0X45,0XDE,0X97,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10650XFF,0XFF,0XFF,0XDF,0XF7,0XFE,0XF7,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0X9E,

10660XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XEF,0X3A,0XD6,0X35,0X8B,0XC9,0X62,0X82,0X83,0X63,

10670XD5,0XCB,0XEE,0X8C,0XEE,0X8A,0XF6,0XCA,0XF6,0XA9,0XF6,0X89,0XF6,0XAA,0XF6,0X8B,

10680XEE,0X8D,0XF6,0XD1,0XFF,0X97,0XFF,0XFB,0XFF,0XFD,0XF7,0XDE,0XFF,0XFF,0XFF,0XFF,

10690XF7,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

10700XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XFF,0XBB,0XF7,0X14,0XE6,0X4D,0XE6,0X28,0XEE,0X47,

10710XF6,0X27,0XF6,0X07,0XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

10720XEE,0X27,0XEE,0X27,0XEE,0X28,0XF6,0X28,0XEE,0X27,0XEE,0X27,0XF6,0X48,0XEE,0X27,

10730XF6,0X48,0XFE,0XA9,0XF6,0X87,0XF6,0X46,0XFE,0X68,0XF6,0X28,0XF6,0X09,0XE5,0XA9,

10740XD5,0X48,0XCD,0X28,0XBC,0XC7,0XAC,0X86,0X9C,0X25,0X83,0X84,0X72,0XE4,0X5A,0X84,

10750X8C,0X0C,0XEF,0X3A,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10840XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XF7,0XDF,0XF7,0XDF,0XFF,0XDF,0XFF,0XDF,

10850XFF,0XFF,0XFF,0XDE,0XFF,0X9D,0XFF,0X7B,0XB5,0X10,0X62,0X83,0X62,0XA1,0XAC,0XA7,

10860XEE,0X8E,0XF6,0XCE,0XEE,0XAB,0XEE,0XAB,0XEE,0XAB,0XE6,0X6C,0XE6,0X6F,0XF7,0X14,

10870XFF,0XDA,0XFF,0XFC,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XF7,0XFE,0XFF,0XFE,

10880XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

10890XFF,0XDD,0XFF,0XBA,0XEE,0XD2,0XE6,0X0C,0XEE,0X28,0XEE,0X46,0XF6,0X27,0XF6,0X27,

10900XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X28,0XEE,0X28,0XF6,0X48,

10910XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XE5,0XE6,0XFE,0X88,0XFE,0XC9,0XFE,0X88,

10920XF6,0X46,0XF6,0X67,0XF6,0X47,0XF6,0X08,0XF6,0X09,0XED,0XC9,0XDD,0XA9,0XCD,0X48,

10930XC5,0X07,0XB4,0XC6,0X9C,0X24,0X93,0XE5,0X7B,0X45,0X6A,0XE6,0XCD,0XF5,0XFF,0XBD,

10940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

10990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11040XFF,0XFF,0XFF,0X9E,0XFF,0XBC,0XE6,0XB7,0X94,0X2A,0X52,0X21,0X7B,0X24,0XCD,0XAC,

11050XEE,0X8E,0XEE,0X8D,0XEE,0XAD,0XE6,0X8E,0XEE,0XD2,0XFF,0XD9,0XFF,0XFB,0XFF,0XFD,

11060XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11070XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDC,0XFF,0X78,

11080XEE,0X90,0XE6,0X0B,0XEE,0X28,0XEE,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X47,

11090XEE,0X27,0XEE,0X27,0XEE,0X48,0XE5,0XE7,0XEE,0X28,0XE5,0XE7,0XEE,0X28,0XF6,0X48,

11100XEE,0X08,0XEE,0X27,0XFE,0X68,0XF6,0X68,0XEE,0X06,0XE5,0XE5,0XF6,0X46,0XF6,0X66,

11110XFE,0X67,0XF6,0X28,0XF6,0X29,0XF5,0XE9,0XED,0XEA,0XDD,0XA8,0XCD,0X67,0XBD,0X06,

11120XAC,0XA6,0X9C,0X46,0X7B,0X66,0X94,0X2C,0XEE,0XF9,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

11130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

11230XFF,0XDE,0XFF,0XDD,0XF7,0X5A,0XBD,0XB2,0X83,0X88,0X73,0X05,0XA4,0X89,0XD6,0X0E,

11240XDE,0X8F,0XDE,0X70,0XF7,0X56,0XFF,0XDA,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

11250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

11260XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDD,0XFF,0XD9,0XF7,0X34,0XE6,0X4D,0XE6,0X0A,

11270XEE,0X08,0XEE,0X07,0XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X48,

11280XEE,0X27,0XF6,0X69,0XE6,0X07,0XEE,0X28,0XF6,0X49,0XE5,0XE7,0XEE,0X07,0XF6,0X69,

11290XF6,0X68,0XDD,0XA5,0XD5,0X23,0XD5,0X64,0XE5,0XE4,0XEE,0X25,0XFE,0X67,0XFE,0X68,

11300XFE,0X49,0XF6,0X08,0XEE,0X08,0XDD,0XC7,0XCD,0X86,0XBD,0X25,0XBD,0X27,0XA4,0X66,

11310X94,0X09,0XD6,0X13,0XFF,0X9C,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XBF,0XFF,0XDF,

11420XFF,0XDE,0XFF,0XDD,0XF7,0X59,0XDE,0X75,0XBD,0X6F,0XC5,0XAF,0XD6,0X31,0XEF,0X36,

11430XFF,0XFB,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

11450XFF,0XFD,0XFF,0XFB,0XFF,0XB6,0XEE,0XD0,0XE6,0X2B,0XE6,0X29,0XEE,0X08,0XEE,0X07,

11460XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XE6,0X07,

11470XEE,0X28,0XEE,0X08,0XE5,0XE7,0XF6,0X49,0XEE,0X28,0XE5,0XC6,0XAC,0X40,0XB4,0X61,

11480XC4,0XC2,0XD5,0X64,0XDD,0XC4,0XEE,0X25,0XF6,0X46,0XFE,0X47,0XFE,0X48,0XF6,0X28,

11490XEE,0X28,0XE6,0X07,0XD5,0XC6,0XC5,0X86,0XBD,0X47,0XA4,0XA7,0XBD,0X8F,0XF7,0X59,

11500XFF,0XBD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11600XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0X9F,0XFF,0XBF,0XFF,0XDE,0XFF,0XFE,

11610XFF,0XFD,0XFF,0XBB,0XFF,0XDB,0XF7,0X9A,0XFF,0XBA,0XFF,0XBB,0XFF,0XDC,0XFF,0XDD,

11620XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11630XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XFF,0XDF,0XFF,0XDE,0XFF,0XFC,0XFF,0XF8,

11640XF7,0X52,0XE6,0X8B,0XDE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X28,

11650XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XE6,0X27,0XE6,0X07,0XEE,0X28,0XEE,0X28,

11660XF6,0X69,0XE5,0XE7,0XBC,0XC3,0X8B,0X40,0X93,0X60,0X9B,0XC0,0XB4,0X62,0XBC,0XC2,

11670XD5,0X84,0XDD,0XE5,0XEE,0X25,0XF6,0X67,0XFE,0X67,0XF6,0X47,0XF6,0X47,0XE6,0X47,

11680XD5,0XE6,0XD5,0XE7,0XB5,0X27,0XBD,0X4B,0XE6,0XD5,0XFF,0XBB,0XFF,0XBD,0XFF,0XFF,

11690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11790XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XBF,0XFF,0XFF,0XF7,0XBE,0XFF,0XDD,0XFF,0XFE,

11800XFF,0XBC,0XFF,0XFE,0XFF,0XDD,0XFF,0XDD,0XFF,0XDE,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,

11810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,

11820XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFD,0XFF,0XFA,0XFF,0XB4,0XEE,0XED,0XDE,0X49,

11830XE6,0X27,0XEE,0X47,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XE6,0X07,

11840XEE,0X27,0XEE,0X48,0XE5,0XE7,0XEE,0X48,0XE6,0X27,0XF6,0X69,0XFE,0XEB,0XFE,0XAA,

11850XD5,0X86,0XAC,0X21,0X83,0X20,0X9B,0XA0,0XAC,0X21,0XAC,0X62,0XBD,0X03,0XD5,0X84,

11860XE6,0X05,0XF6,0X67,0XFE,0X67,0XFE,0X88,0XF6,0X68,0XE6,0X47,0XDE,0X08,0XD6,0X09,

11870XB5,0X29,0XDE,0X92,0XFF,0XB9,0XFF,0XDC,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

11880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

11970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XF7,0X7E,

11980XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDE,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XF7,0X9D,

11990XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

12010XFF,0XDF,0XFF,0XFC,0XFF,0XF7,0XEF,0X50,0XDE,0X8A,0XDE,0X27,0XE6,0X27,0XEE,0X47,

12020XEE,0X06,0XEE,0X07,0XEE,0X28,0XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X07,0XEE,0X07,

12030XEE,0X27,0XDD,0XC6,0XE6,0X27,0XE6,0X07,0XEE,0X48,0XFF,0X2C,0XFF,0X0C,0XF6,0XAB,

12040XDD,0XC8,0XAC,0X43,0X8B,0X20,0X9B,0XE1,0XAC,0X82,0XC5,0X44,0XDD,0XA5,0XEE,0X47,

12050XF6,0X67,0XFE,0X88,0XF6,0X69,0XEE,0X69,0XE6,0X4A,0XD6,0X0C,0XDE,0X4F,0XFF,0X97,

12060XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XF7,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XBE,0XFF,0XDE,

12170XFF,0XFF,0XFF,0XDE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,

12180XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12190XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDD,0XFF,0XFA,

12200XFF,0XD4,0XE6,0XCC,0XD6,0X48,0XDE,0X07,0XE6,0X47,0XEE,0X27,0XE6,0X06,0XEE,0X27,

12210XEE,0X28,0XEE,0X08,0XEE,0X08,0XE6,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X27,0XEE,0X27,

12220XE6,0X07,0XE6,0X27,0XEE,0X48,0XDE,0X07,0XE6,0X08,0XFE,0XCB,0XFF,0X4E,0XFE,0XCD,

12230XCD,0X67,0X9C,0X01,0X93,0XE0,0XB4,0XC2,0XD5,0X65,0XEE,0X27,0XF6,0X48,0XF6,0X69,

12240XEE,0X6A,0XE6,0X4B,0XDE,0X2C,0XD6,0X0E,0XFF,0XB7,0XFF,0XBA,0XFF,0X9C,0XFF,0XDE,

12250XF7,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12360XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12370XF7,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

12380XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDE,0XFF,0XDB,0XFF,0XB6,0XEF,0X0F,0XDE,0X4A,

12390XDE,0X49,0XDE,0X28,0XE6,0X28,0XE6,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

12400XEE,0X27,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

12410XE6,0X28,0XE5,0XE7,0XE6,0X28,0XE6,0X08,0XDE,0X08,0XF6,0XAB,0XFF,0X4D,0XFE,0XEC,

12420XBD,0X24,0XA4,0X61,0XCD,0X24,0XE5,0XE8,0XEE,0X29,0XF6,0X8B,0XEE,0X6B,0XDE,0X2C,

12430XE6,0X90,0XFF,0XB7,0XFF,0XDB,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

12560XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12570XFF,0XDE,0XFF,0XDB,0XFF,0XB7,0XF7,0X12,0XE6,0X6C,0XDE,0X29,0XDE,0X29,0XE6,0X29,

12580XE6,0X08,0XE6,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

12590XE6,0X07,0XE6,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X28,

12600XE6,0X28,0XE6,0X28,0XE6,0X08,0XDD,0XE7,0XE6,0X49,0XF6,0XEB,0XFF,0X6D,0XEE,0XAA,

12610XCD,0X45,0XD5,0X86,0XF6,0X8B,0XEE,0X6B,0XE6,0X4D,0XEE,0XB0,0XF7,0X35,0XFF,0XB9,

12620XFF,0XFD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

12740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12750XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XDA,0XFF,0X97,

12760XFF,0X53,0XE6,0XAD,0XDE,0X09,0XE6,0X09,0XE6,0X09,0XE6,0X09,0XEE,0X08,0XEE,0X08,

12770XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XE6,0X07,0XE6,0X07,

12780XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X27,0XE6,0X07,0XDE,0X07,

12790XE6,0X48,0XE6,0X49,0XDE,0X08,0XDD,0XE7,0XE6,0X49,0XFF,0X4C,0XFF,0X2C,0XF6,0XAA,

12800XEE,0X8A,0XE6,0X6B,0XEE,0XAF,0XFF,0X95,0XFF,0XD9,0XFF,0XBB,0XFF,0XFE,0XFF,0XFE,

12810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12920XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

12930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

12940XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0XB6,0XF7,0X31,0XEE,0XCD,0XDE,0X4A,

12950XDE,0X08,0XE6,0X09,0XE6,0X09,0XEE,0X09,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,

12960XEE,0X27,0XEE,0X27,0XEE,0X27,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,

12970XE6,0X07,0XE6,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X28,0XE6,0X08,0XDD,0XE7,

12980XE6,0X08,0XE6,0X48,0XE6,0X28,0XE6,0X48,0XEE,0X89,0XFF,0X4C,0XFF,0X2C,0XEE,0XCD,

12990XFF,0X32,0XFF,0XB7,0XFF,0XDA,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13110XFF,0XFE,0XF7,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,

13130XFF,0XFA,0XFF,0XB7,0XFF,0X71,0XEE,0XCC,0XDE,0X28,0XDE,0X07,0XE6,0X08,0XEE,0X08,

13140XEE,0X09,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

13150XEE,0X27,0XEE,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,

13160XE6,0X07,0XEE,0X28,0XE6,0X07,0XE5,0XE7,0XE6,0X07,0XE6,0X28,0XE6,0X07,0XE6,0X08,

13170XDD,0XE7,0XD5,0XC6,0XE6,0X47,0XEE,0XA9,0XF6,0XEB,0XFF,0X6F,0XFF,0X73,0XFF,0XB7,

13180XFF,0X99,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

13310XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XFB,0XFF,0XF9,0XFF,0X96,0XEE,0XF1,

13320XE6,0XAC,0XE6,0X68,0XDE,0X06,0XE6,0X06,0XEE,0X28,0XEE,0X08,0XEE,0X08,0XEE,0X07,

13330XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,

13340XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE5,0XE7,

13350XE6,0X07,0XEE,0X28,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XDD,0XE7,0XF6,0X69,0XEE,0X48,

13360XD5,0XA5,0XDE,0X07,0XE6,0X69,0XEE,0XCC,0XFF,0X72,0XFF,0X34,0XF7,0X77,0XFF,0XFC,

13370XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

13500XFF,0XFC,0XFF,0XFA,0XFF,0XB7,0XFF,0X94,0XEE,0XCF,0XDE,0X4B,0XDE,0X07,0XDE,0X26,

13510XE6,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

13520XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,

13530XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X07,0XEE,0X27,0XE6,0X07,

13540XDD,0XC6,0XEE,0X28,0XEE,0X68,0XDD,0XC6,0XE5,0XC6,0XE6,0X07,0XEE,0X47,0XE6,0X27,

13550XDE,0X07,0XDE,0X29,0XEE,0XAD,0XFF,0X51,0XFF,0X54,0XFF,0XB8,0XFF,0XFB,0XFF,0XFD,

13560XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

13680XF7,0XDF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFA,0XFF,0XB8,0XFF,0X75,

13690XF7,0X11,0XE6,0X8E,0XDE,0X2A,0XE6,0X29,0XE6,0X27,0XE6,0X46,0XEE,0X26,0XEE,0X06,

13700XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

13710XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,

13720XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X28,0XE6,0X27,

13730XE6,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XE6,0X27,0XDE,0X07,0XE6,0X28,0XE6,0X28,

13740XDD,0XE8,0XEE,0X8C,0XF7,0X10,0XF7,0X33,0XFF,0XD8,0XFF,0XFA,0XFF,0XDD,0XFF,0XFE,

13750XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XFF,0XDD,0XFF,0XFD,0XFF,0XFC,

13870XFF,0XFA,0XFF,0XF8,0XFF,0XB6,0XFF,0X95,0XF7,0X11,0XEE,0X8E,0XE6,0X2B,0XDE,0X09,

13880XE6,0X28,0XE6,0X28,0XE6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,

13890XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X08,0XEE,0X08,

13900XEE,0X08,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

13910XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

13920XEE,0X07,0XEE,0X07,0XE6,0X28,0XE6,0X27,0XDE,0X07,0XE6,0X07,0XE6,0X28,0XE6,0X29,

13930XEE,0X8B,0XFF,0X0F,0XEE,0XD1,0XFF,0X76,0XFF,0XBA,0XFF,0XDD,0XFF,0XBE,0XFF,0XDF,

13940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

13990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14050XFF,0XBE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFA,0XFF,0XD8,0XFF,0XB5,0XF7,0X73,

14060XEF,0X30,0XE6,0XAE,0XDE,0X2B,0XDE,0X09,0XE6,0X08,0XE6,0X07,0XEE,0X07,0XEE,0X07,

14070XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

14080XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X27,

14090XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

14100XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,

14110XE6,0X28,0XE6,0X28,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X08,0XF6,0X8C,

14120XEE,0XCF,0XDE,0X70,0XF7,0X57,0XFF,0XDC,0XFF,0XDD,0XFF,0XDE,0XFF,0XDE,0XFF,0XFF,

14130XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,

14240XFF,0XDA,0XFF,0XB7,0XFF,0XB4,0XFF,0X92,0XF7,0X2F,0XE6,0XAC,0XDE,0X4A,0XDE,0X29,

14250XE6,0X28,0XE6,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

14260XEE,0X27,0XEE,0X27,0XEE,0X27,0XE6,0X27,0XEE,0X28,0XE6,0X28,0XE6,0X47,0XEE,0X27,

14270XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X27,

14280XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

14290XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XE6,0X27,0XE6,0X27,0XE6,0X27,

14300XE6,0X27,0XE6,0X07,0XE5,0XE7,0XE6,0X07,0XE5,0XE7,0XEE,0X49,0XEE,0X6B,0XE6,0X4E,

14310XD6,0X10,0XEF,0X16,0XFF,0XDC,0XFF,0XBD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0X7B,0XFF,0X77,0XFF,0X52,

14430XEE,0XEE,0XEE,0XAB,0XDE,0X2A,0XDE,0X09,0XDE,0X08,0XE6,0X28,0XE6,0X27,0XE6,0X26,

14440XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

14450XEE,0X27,0XEE,0X28,0XEE,0X28,0XE6,0X28,0XE6,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

14460XEE,0X07,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,

14470XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

14480XEE,0X07,0XEE,0X27,0XE6,0X07,0XEE,0X28,0XE6,0X27,0XE6,0X27,0XEE,0X28,0XEE,0X07,

14490XE5,0XE7,0XEE,0X07,0XF6,0X48,0XE5,0XE7,0XE6,0X29,0XE6,0X4B,0XCD,0XCC,0XC5,0XAE,

14500XEE,0XF6,0XFF,0XDC,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

14510XFF,0XFF,0XF7,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14610XFF,0XFF,0XFF,0XFF,0XFF,0XBD,0XDE,0X75,0XDE,0X30,0XE6,0X6D,0XE6,0X29,0XE6,0X28,

14620XDD,0XC8,0XE5,0XE9,0XEE,0X09,0XE6,0X08,0XE6,0X06,0XEE,0X26,0XEE,0X26,0XE6,0X06,

14630XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,

14640XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,

14650XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,

14660XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

14670XE6,0X07,0XE6,0X28,0XE6,0X07,0XE6,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X08,0XEE,0X08,

14680XEE,0X08,0XE5,0XE7,0XEE,0X28,0XE6,0X08,0XDE,0X0B,0XB5,0X0A,0XAC,0XCC,0XF7,0X38,

14690XFF,0XBC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

14700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14800XFF,0XDC,0XBD,0X90,0XBD,0X4A,0XDD,0XE9,0XE6,0X07,0XF6,0X27,0XF6,0X09,0XED,0XE9,

14810XED,0XE9,0XEE,0X09,0XEE,0X28,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X27,

14820XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,

14830XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

14840XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

14850XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X28,

14860XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X08,0XEE,0X08,0XE5,0XC7,0XF6,0X27,

14870XEE,0X06,0XEE,0X27,0XE6,0X09,0XCD,0X6A,0X9C,0X28,0X9C,0X6B,0XFF,0X9A,0XFF,0XFD,

14880XFF,0XDE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

14980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0X9A,0XC5,0X8F,

14990XC5,0X6A,0XE6,0X29,0XEE,0X06,0XEE,0X06,0XF6,0X07,0XED,0XC8,0XED,0XE9,0XF6,0X29,

15000XEE,0X28,0XEE,0X07,0XEE,0X27,0XF6,0X68,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

15010XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

15020XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

15030XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,

15040XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,

15050XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XF6,0X07,0XEE,0X05,0XED,0XE6,

15060XEE,0X28,0XDD,0XEA,0XC5,0X4A,0X6A,0XA3,0XA4,0XCE,0XFF,0XFC,0XFF,0XDD,0XFF,0XDE,

15070XFF,0XFF,0XEF,0X7D,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XF7,0X79,0XC5,0XAF,0XC5,0X6A,0XDE,0X09,

15180XE6,0X06,0XF6,0X47,0XF6,0X07,0XF6,0X07,0XED,0XE8,0XED,0XE8,0XEE,0X08,0XF6,0X48,

15190XEE,0X48,0XE6,0X07,0XEE,0X27,0XEE,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

15200XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

15210XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X27,

15220XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

15230XEE,0X07,0XEE,0X07,0XEE,0X08,0XED,0XE7,0XEE,0X07,0XEE,0X07,0XEE,0X06,0XEE,0X27,

15240XEE,0X28,0XEE,0X07,0XEE,0X07,0XF6,0X07,0XF6,0X26,0XF6,0X27,0XED,0XE7,0XE5,0XC8,

15250XDD,0XEB,0X9C,0X06,0X62,0X83,0X94,0X6D,0XF7,0X7B,0XFF,0XDD,0XFF,0XDE,0XFF,0XDF,

15260XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15360XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XC5,0XF0,0XC5,0XAC,0XE6,0X4B,0XDE,0X07,0XE6,0X26,

15370XEE,0X26,0XEE,0X26,0XEE,0X27,0XF6,0X48,0XEE,0X28,0XEE,0X08,0XEE,0X08,0XF6,0X49,

15380XEE,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X27,

15390XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XE6,0X28,

15400XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X08,0XEE,0X27,

15410XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,

15420XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

15430XEE,0X07,0XEE,0X06,0XEE,0X06,0XEE,0X07,0XEE,0X28,0XE6,0X28,0XD5,0XC8,0XC5,0X48,

15440X6A,0X81,0X5A,0X43,0XB5,0X30,0XFF,0X9C,0XFF,0XBE,0XFF,0XFF,0XFF,0XBF,0XFF,0XFF,

15450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

15550XF7,0XBB,0XE6,0XF6,0XD6,0X51,0XCD,0XED,0XD6,0X0A,0XE6,0X6A,0XEE,0X69,0XE6,0X48,

15560XE6,0X28,0XE6,0X08,0XE5,0XE7,0XEE,0X29,0XEE,0X49,0XE6,0X08,0XEE,0X28,0XEE,0X27,

15570XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X27,0XEE,0X27,

15580XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

15590XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

15600XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,

15610XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XF6,0X27,0XEE,0X07,

15620XF6,0X48,0XEE,0X07,0XEE,0X28,0XEE,0X49,0XDD,0XE7,0XCD,0X67,0XA4,0X05,0X5A,0X21,

15630X62,0XA5,0XCD,0XF5,0XFF,0XBD,0XFF,0XDE,0XFF,0XBE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

15640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XBB,

15740XEE,0XF7,0XC5,0XD0,0XAC,0XCA,0XA4,0XA8,0XC5,0X69,0XD5,0XCA,0XE6,0X2C,0XEE,0X6C,

15750XEE,0X6B,0XE6,0X09,0XE6,0X08,0XEE,0X69,0XEE,0X28,0XEE,0X07,0XEE,0X27,0XEE,0X48,

15760XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

15770XEE,0X28,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

15780XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

15790XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X28,

15800XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XF6,0X27,0XEE,0X07,

15810XEE,0X28,0XEE,0X69,0XE6,0X08,0XD5,0XA8,0XB4,0XA7,0X5A,0X20,0X52,0X02,0X7B,0X8A,

15820XE6,0XD9,0XFF,0XDE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

15920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0X7C,0XFF,0XFE,0XFF,0XBC,0XF7,0X59,

15930XEE,0XF7,0XC5,0X90,0X8B,0XC7,0X7B,0X24,0X7B,0X44,0XA4,0X87,0XCD,0XAB,0XEE,0X8C,

15940XEE,0X8B,0XDD,0XE8,0XEE,0X29,0XEE,0X29,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X28,

15950XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X28,

15960XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

15970XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X08,

15980XEE,0X27,0XEE,0X27,0XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

15990XEE,0X27,0XEE,0X27,0XEE,0X07,0XF6,0X47,0XED,0XE6,0XEE,0X47,0XEE,0X48,0XE6,0X07,

16000XEE,0X48,0XDD,0XE8,0XC5,0X07,0X7B,0X02,0X62,0X83,0X4A,0X03,0XA4,0XD0,0XF7,0X9C,

16010XFF,0XBD,0XFF,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBE,0XFF,0XDE,0XFF,0XBC,0XFF,0XDC,

16120XFF,0X9A,0XDE,0X95,0X9C,0X6C,0X62,0X83,0X51,0XE0,0X73,0X02,0XB4,0XE8,0XE6,0X6D,

16130XE6,0X0B,0XEE,0X0A,0XEE,0X29,0XEE,0X08,0XEE,0X27,0XEE,0X07,0XEE,0X08,0XF6,0X48,

16140XEE,0X28,0XEE,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X28,0XEE,0X28,

16150XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

16160XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

16170XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

16180XF6,0X47,0XEE,0X06,0XF6,0X68,0XEE,0X27,0XEE,0X27,0XF6,0X48,0XE6,0X07,0XE6,0X29,

16190XC5,0X07,0X9B,0XE5,0X52,0X00,0X52,0X43,0X5A,0XA7,0XCE,0X16,0XFF,0XBD,0XFF,0XFE,

16200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16300XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XDC,

16310XFF,0XFC,0XF7,0X79,0XB5,0X2F,0X62,0XC4,0X49,0XC0,0X49,0XC0,0XAC,0X87,0XE6,0X0C,

16320XEE,0X4B,0XDD,0XC8,0XEE,0X28,0XF6,0X48,0XEE,0X07,0XEE,0X28,0XEE,0X27,0XEE,0X47,

16330XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

16340XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

16350XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XF6,0X27,0XF6,0X27,

16360XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XF6,0X48,

16370XEE,0X27,0XEE,0X47,0XEE,0X27,0XEE,0X28,0XF6,0X69,0XE6,0X29,0XCD,0X67,0XAC,0X66,

16380X5A,0X40,0X52,0X43,0X41,0XC2,0X83,0XEC,0XF7,0X5B,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,

16390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

16490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XDC,

16500XFF,0XFD,0XF7,0X7A,0XC5,0XD3,0X94,0X2B,0X62,0X83,0X72,0XC2,0XAC,0X87,0XDD,0XEB,

16510XE6,0X09,0XE6,0X08,0XF6,0X49,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X47,

16520XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

16530XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

16540XEE,0X28,0XEE,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

16550XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X06,0XF6,0X47,0XEE,0X27,0XEE,0X47,

16560XEE,0X28,0XEE,0X28,0XF6,0X69,0XEE,0X29,0XD5,0X88,0XA4,0X44,0X6A,0XC1,0X41,0XC0,

16570X4A,0X24,0X5A,0X87,0XCE,0X16,0XFF,0XBD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

16690XFF,0XDD,0XFF,0XBC,0XE6,0XF7,0XBD,0X6F,0X9C,0X8A,0XB5,0X0B,0XDE,0X0C,0XE6,0X6C,

16700XE6,0X2A,0XE6,0X09,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X27,

16710XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X47,0XEE,0X27,0XEE,0X27,0XF6,0X27,0XF6,0X27,

16720XF6,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

16730XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

16740XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XF6,0X47,0XEE,0X48,0XEE,0X48,

16750XF6,0X48,0XEE,0X49,0XE5,0XE9,0XB4,0XA5,0X72,0XE1,0X49,0XC0,0X52,0X44,0X39,0X82,

16760X8C,0X0D,0XFF,0XBD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16870XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDD,

16880XFF,0XBC,0XFF,0XFC,0XFF,0XDB,0XFF,0X98,0XF7,0X56,0XFF,0X34,0XEE,0XB0,0XE6,0X0B,

16890XE6,0X0A,0XEE,0X09,0XEE,0X28,0XFE,0X69,0XF6,0X27,0XED,0XE7,0XF6,0X47,0XF6,0X27,

16900XEE,0X27,0XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X27,

16910XEE,0X28,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,

16920XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X27,

16930XEE,0X47,0XEE,0X27,0XEE,0X27,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X49,

16940XF6,0X6A,0XB4,0XA5,0X73,0X02,0X52,0X21,0X4A,0X03,0X39,0X82,0X5A,0X87,0XE6,0XF9,

16950XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

16960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

16990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17060XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDE,0XFF,0XFE,

17070XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XDA,0XFF,0X76,0XF6,0XD2,0XE6,0X4E,0XE5,0XEA,

17080XE5,0XE9,0XEE,0X08,0XF6,0X28,0XF6,0X47,0XF6,0X27,0XEE,0X26,0XEE,0X47,0XEE,0X47,

17090XEE,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X47,0XEE,0X47,

17100XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

17110XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X27,

17120XEE,0X27,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X49,0XF6,0X6A,0XBC,0XE6,

17130X7B,0X22,0X52,0X00,0X49,0XE2,0X49,0XE4,0X49,0XE4,0XAD,0X32,0XFF,0XFE,0XFF,0XFF,

17140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,

17250XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XF7,0XDE,0XFF,0XDF,0XFF,0XDE,0XF7,0XDE,

17260XFF,0XDE,0XFF,0XFE,0XFF,0XDC,0XFF,0X99,0XF7,0X14,0XE6,0X4E,0XE6,0X0A,0XE6,0X08,

17270XEE,0X27,0XF6,0X47,0XEE,0X26,0XF6,0X26,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X27,

17280XF6,0X28,0XF6,0X28,0XF6,0X48,0XF6,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

17290XEE,0X47,0XEE,0X47,0XF6,0X28,0XF6,0X28,0XF6,0X27,0XEE,0X47,0XF6,0X27,0XF6,0X27,

17300XF6,0X27,0XF6,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,

17310XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X49,0XF6,0X6A,0XCD,0X47,0X83,0X84,0X49,0XC0,

17320X4A,0X02,0X4A,0X04,0X39,0X83,0X6B,0X0A,0XFF,0XBD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

17330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

17440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XF7,0XDF,0XFF,0XFF,

17450XFF,0XFF,0XFF,0XFE,0XFF,0XBA,0XFF,0X35,0XEE,0XAF,0XDE,0X09,0XE5,0XE7,0XEE,0X47,

17460XF6,0X47,0XEE,0X26,0XEE,0X47,0XEE,0X47,0XEE,0X28,0XEE,0X27,0XF6,0X28,0XF6,0X28,

17470XF6,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

17480XF6,0X28,0XF6,0X28,0XF6,0X27,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

17490XF6,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X48,0XF6,0X48,

17500XF6,0X48,0XF6,0X49,0XF6,0X4A,0XE5,0XEA,0X83,0X63,0X52,0X00,0X49,0XC1,0X4A,0X04,

17510X41,0XA3,0X41,0XC4,0XF7,0X7B,0XF7,0XBD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17630XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XFF,0XDF,0XFF,0XFF,

17640XFF,0XFD,0XFF,0XDA,0XFF,0X54,0XE6,0X8D,0XD5,0XE8,0XE6,0X48,0XF6,0XA8,0XEE,0X27,

17650XEE,0X47,0XEE,0X48,0XEE,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X47,0XEE,0X47,

17660XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X27,

17670XF6,0X27,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,

17680XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X49,

17690XEE,0X29,0XE6,0X2B,0X8B,0XA3,0X49,0XE0,0X4A,0X02,0X41,0XC2,0X49,0XE4,0X31,0X62,

17700XAD,0X52,0XFF,0XFE,0XFF,0XFE,0XF7,0X9D,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

17820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFC,

17830XFF,0XD8,0XFF,0X74,0XE6,0X8D,0XDE,0X09,0XE6,0X69,0XE6,0X48,0XEE,0X48,0XEE,0X48,

17840XEE,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,

17850XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,

17860XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,

17870XEE,0X47,0XEE,0X47,0XF6,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X29,0XEE,0X29,0XEE,0X4B,

17880X8B,0XA3,0X52,0X00,0X49,0XC1,0X49,0XE3,0X49,0XE3,0X39,0X62,0X8C,0X2E,0XFF,0XBD,

17890XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

17990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBF,0XFF,0XDE,0XFF,0XDE,

18010XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDD,0XFF,0XFC,0XFF,0XFA,

18020XFF,0X74,0XDE,0X6E,0XDE,0X2A,0XE6,0X49,0XE6,0X28,0XEE,0X28,0XEE,0X28,0XF6,0X28,

18030XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

18040XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,0XF6,0X27,0XF6,0X27,

18050XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

18060XF6,0X48,0XF6,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X49,0XE6,0X4B,0X9C,0X05,0X52,0X00,

18070X49,0XE1,0X49,0XE2,0X49,0XE3,0X39,0XA3,0X62,0XC8,0XEF,0X7B,0XFF,0XFE,0XFF,0XFF,

18080XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18190XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,

18200XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XFF,0XF9,0XFF,0X54,

18210XDE,0X6D,0XDE,0X2A,0XE6,0X29,0XEE,0X29,0XEE,0X48,0XEE,0X47,0XF6,0X27,0XF6,0X27,

18220XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X48,0XEE,0X47,

18230XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X28,0XF6,0X28,

18240XF6,0X48,0XF6,0X48,0XF6,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X28,

18250XFE,0X28,0XF6,0X48,0XF6,0X49,0XEE,0X8B,0X9C,0X45,0X5A,0X20,0X49,0XE1,0X49,0XE2,

18260X49,0XE3,0X41,0XC3,0X42,0X04,0XDE,0XF9,0XFF,0XDD,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,

18270XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18380XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

18390XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFC,0XFF,0XF9,0XEF,0X31,0XD6,0X4C,

18400XD5,0XE9,0XEE,0X4A,0XEE,0X48,0XEE,0X27,0XF6,0X67,0XF6,0X26,0XF6,0X26,0XF6,0X47,

18410XF6,0X46,0XEE,0X47,0XEE,0X47,0XEE,0X48,0XEE,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,

18420XF6,0X27,0XF6,0X27,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

18430XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

18440XEE,0X69,0XEE,0X6B,0XAC,0XA6,0X62,0X40,0X51,0XE1,0X49,0XE2,0X49,0XE2,0X41,0XE3,

18450X39,0XC3,0XC6,0X35,0XFF,0XFD,0XFF,0XFF,0XF7,0XDE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

18460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

18580XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFB,0XFF,0XB6,0XE6,0XF0,0XDE,0X2C,0XDE,0X2A,

18590XEE,0X28,0XEE,0X47,0XF6,0X47,0XF6,0X26,0XF6,0X26,0XF6,0X46,0XF6,0X46,0XEE,0X47,

18600XEE,0X47,0XEE,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

18610XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

18620XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X69,0XEE,0X8B,

18630XB4,0XC6,0X62,0X60,0X51,0XE1,0X52,0X03,0X49,0XE2,0X4A,0X03,0X39,0XA2,0XB5,0X92,

18640XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

18770XFF,0XDE,0XFF,0XFD,0XFF,0XFA,0XFF,0X95,0XE6,0XB0,0XDE,0X0B,0XE6,0X28,0XEE,0X68,

18780XF6,0X26,0XF6,0X46,0XF6,0X26,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X48,

18790XF6,0X48,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X47,

18800XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

18810XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XEE,0X69,0XF6,0X8B,0XB4,0XC7,0X6A,0X80,

18820X5A,0X01,0X52,0X02,0X49,0XE2,0X4A,0X03,0X39,0XC2,0X94,0XAF,0XFF,0XFE,0XFF,0XFF,

18830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

18950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,

18960XFF,0XFC,0XFF,0XD9,0XF7,0X54,0XDE,0X4D,0XDE,0X09,0XEE,0X68,0XEE,0X46,0XF6,0X47,

18970XF6,0X47,0XF6,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,

18980XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

18990XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X48,0XF6,0X48,

19000XF6,0X48,0XF6,0X68,0XF6,0X48,0XF6,0X8B,0XBC,0XE7,0X6A,0XA1,0X5A,0X21,0X52,0X23,

19010X49,0XE2,0X52,0X23,0X41,0XE2,0X8C,0X2D,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XFF,0XFC,

19150XFF,0XB8,0XEE,0XD2,0XDE,0X0A,0XE6,0X48,0XEE,0X47,0XF6,0X46,0XF6,0X47,0XF6,0X47,

19160XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,

19170XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

19180XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X68,

19190XF6,0X69,0XF6,0X8B,0XBC,0XE7,0X72,0XE1,0X62,0X42,0X5A,0X43,0X52,0X02,0X52,0X23,

19200X41,0XE3,0X84,0X0C,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XDB,0XFF,0X76,

19340XE6,0X4D,0XDE,0X29,0XEE,0X47,0XEE,0X46,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XF6,0X48,

19350XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,

19360XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

19370XF6,0X67,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X89,0XF6,0X8B,

19380XBD,0X07,0X7B,0X01,0X62,0X62,0X5A,0X43,0X52,0X02,0X52,0X23,0X49,0XE3,0X8C,0X0C,

19390XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19520XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDD,0XFF,0XDA,0XEE,0XF2,0XDE,0X0B,

19530XE6,0X28,0XEE,0X46,0XEE,0X46,0XEE,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,

19540XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

19550XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X47,

19560XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X8A,0XC5,0X07,0X83,0X42,

19570X62,0X62,0X62,0X63,0X52,0X22,0X52,0X43,0X4A,0X03,0X8C,0X0C,0XFF,0XFD,0XFF,0XFE,

19580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19710XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFC,0XFF,0X77,0XDE,0X0D,0XDE,0X09,0XEE,0X67,

19720XEE,0X46,0XEE,0X46,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,

19730XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

19740XF6,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X48,0XF6,0X48,

19750XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X8A,0XC5,0X27,0X8B,0X83,0X6A,0X82,0X62,0X83,

19760X5A,0X42,0X5A,0X63,0X52,0X43,0X8C,0X2C,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

19900XFF,0XFF,0XFF,0XDD,0XFF,0XDB,0XF6,0XF3,0XDE,0X0B,0XE6,0X48,0XEE,0X46,0XEE,0X46,

19910XF6,0X47,0XF6,0X48,0XF6,0X47,0XFE,0X48,0XF6,0X27,0XF6,0X47,0XEE,0X47,0XF6,0X47,

19920XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

19930XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,

19940XF6,0X68,0XF6,0X69,0XCD,0X67,0X93,0XC3,0X72,0XC2,0X6A,0XA3,0X6A,0XA3,0X5A,0X63,

19950X5A,0X64,0X8C,0X2C,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

19990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,

20090XFF,0X7B,0XFF,0X98,0XDE,0X0C,0XE6,0X49,0XE6,0X27,0XF6,0X66,0XF6,0X47,0XF6,0X47,

20100XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

20110XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,

20120XF6,0X67,0XF6,0X67,0XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XEE,0X69,

20130XCD,0X67,0X9B,0XE4,0X72,0XC2,0X72,0XC3,0X6A,0XC4,0X62,0XA4,0X5A,0X84,0X8C,0X2C,

20140XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20270XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0X9A,

20280XF7,0X13,0XCD,0XA8,0XEE,0X68,0XEE,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X47,0XF6,0X27,

20290XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

20300XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

20310XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X69,0XD5,0X67,0XA4,0X04,

20320X7A,0XE2,0X72,0XE4,0X72,0XE4,0X6A,0XC4,0X62,0XA5,0X94,0X4D,0XFF,0XFD,0XFF,0XFF,

20330XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

20460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFD,0XFF,0X76,0XD5,0XCC,

20470XDD,0XE9,0XEE,0X48,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X27,0XF6,0X48,0XF6,0X48,

20480XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,

20490XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X48,0XF6,0X48,

20500XF6,0X48,0XFE,0X68,0XFE,0X68,0XF6,0X69,0XD5,0X87,0XA4,0X24,0X7B,0X03,0X7B,0X04,

20510X7B,0X04,0X72,0XE4,0X6A,0XC5,0X9C,0X8E,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

20520XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20650XFF,0XFF,0XF7,0XDE,0XFF,0XFF,0XFF,0XFD,0XFF,0XBA,0XE6,0X50,0XD5,0X89,0XEE,0X29,

20660XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XF6,0X68,0XF6,0X48,0XF6,0X48,

20670XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,

20680XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XFE,0X68,

20690XFE,0X68,0XF6,0X69,0XD5,0X88,0XA4,0X24,0X83,0X23,0X7B,0X04,0X7B,0X25,0X73,0X05,

20700X6A,0XE6,0XAD,0X10,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

20710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFE,

20840XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XF7,0X15,0XD5,0X6B,0XEE,0X2A,0XF6,0X48,0XF6,0X67,

20850XF6,0X47,0XF6,0X67,0XEE,0X67,0XF6,0X68,0XF6,0X47,0XF6,0X28,0XF6,0X47,0XF6,0X47,

20860XF6,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X67,0XF6,0X67,

20870XF6,0X67,0XF6,0X67,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XFE,0X68,0XFE,0X88,0XF6,0X89,

20880XDD,0XA8,0XA4,0X04,0X8B,0X64,0X83,0X45,0X83,0X65,0X73,0X05,0X6A,0XC5,0XBD,0X92,

20890XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

20990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21020XFF,0XFF,0XFF,0XDF,0XFF,0XBF,0XFF,0XDF,0XFF,0XFF,0XF7,0XFE,0XFF,0XFE,0XFF,0XFE,

21030XFF,0XFD,0XFF,0X58,0XDD,0XCE,0XE5,0XEA,0XF6,0X49,0XF6,0X67,0XF6,0X67,0XEE,0X67,

21040XEE,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,

21050XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

21060XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XFE,0X68,0XF6,0X89,0XDD,0XC8,0XA4,0X03,

21070X93,0XA5,0X8B,0X85,0X8B,0XA6,0X7B,0X46,0X73,0X06,0XD6,0X55,0XFF,0XDD,0XFF,0XFF,

21080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

21210XFF,0XBF,0XFF,0XDF,0XFF,0XFE,0XF7,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0X7A,

21220XE6,0X31,0XDD,0XAB,0XEE,0X49,0XF6,0X47,0XF6,0X68,0XEE,0X47,0XF6,0X67,0XEE,0X47,

21230XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X48,0XF6,0X48,

21240XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X48,0XF6,0X68,

21250XF6,0X68,0XF6,0X68,0XF6,0X68,0XFE,0X89,0XDD,0XC8,0X9B,0XE3,0X9B,0XE5,0X93,0XA6,

21260X93,0XE7,0X83,0X86,0X83,0X88,0XEE,0XF8,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

21400XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XBB,0XEE,0XD3,0XCD,0X8A,

21410XE6,0X29,0XF6,0X47,0XF6,0X28,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

21420XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

21430XFE,0X48,0XF6,0X47,0XFE,0X88,0XF6,0X67,0XF6,0X47,0XFE,0X68,0XF6,0X68,0XF6,0X68,

21440XF6,0X68,0XFE,0X8A,0XDD,0XA8,0XA4,0X04,0X9B,0XE5,0X93,0XE6,0X94,0X26,0X83,0XA6,

21450X8C,0X0B,0XFF,0X9B,0XFF,0XFD,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XEE,0XF5,0XCD,0XAB,0XE6,0X29,0XEE,0X48,

21600XF6,0X28,0XFE,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,

21610XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XFE,0X48,0XFE,0X48,0XFE,0X48,0XFE,0X47,

21620XFE,0X68,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XFE,0XA9,0XFE,0X8A,

21630XCD,0X47,0XA4,0X24,0XA4,0X26,0X94,0X06,0X94,0X26,0X83,0XC6,0XAD,0X0F,0XFF,0XDD,

21640XFF,0XFE,0XFF,0XFE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21780XFF,0XFF,0XFF,0XFC,0XF7,0X36,0XCD,0XCC,0XDE,0X09,0XEE,0X48,0XF6,0X28,0XFE,0X48,

21790XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X48,0XF6,0X48,

21800XF6,0X48,0XF6,0X48,0XFE,0X48,0XFE,0X48,0XFE,0X48,0XFE,0X48,0XFE,0X68,0XF6,0X47,

21810XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X88,0XFE,0XAA,0XFE,0XAA,0XC4,0XE6,0XAC,0X45,

21820XAC,0X67,0X9C,0X26,0X94,0X26,0X8B,0XE7,0XC5,0XF3,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,

21830XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

21960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,

21970XF7,0X57,0XCD,0XCD,0XDD,0XE9,0XEE,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

21980XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

21990XFE,0X48,0XFE,0X48,0XFE,0X48,0XFE,0X67,0XFE,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,

22000XF6,0X67,0XF6,0X89,0XFE,0XCA,0XF6,0X8A,0XC4,0XC5,0XB4,0X86,0XAC,0X87,0XA4,0X67,

22010X9C,0X67,0X94,0X28,0XDE,0XB6,0XFF,0XFD,0XFF,0XDD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

22020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

22120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0X78,0XD5,0XEE,

22160XD5,0XA9,0XEE,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,

22170XF6,0X48,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

22180XFE,0X48,0XFE,0X68,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XFE,0XA9,

22190XFE,0XCB,0XEE,0X09,0XC4,0XC5,0XC4,0XE7,0XBC,0XC8,0XAC,0X87,0XA4,0XA8,0XA4,0XCB,

22200XFF,0X7A,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0X9A,0XDE,0X30,0XCD,0X89,0XEE,0X49,

22350XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X47,

22360XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XFE,0X47,0XFE,0X68,

22370XF6,0X47,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X88,0XFE,0XA9,0XFE,0XCB,0XDD,0X87,

22380XC4,0XC5,0XCD,0X07,0XC5,0X08,0XB4,0XC8,0XAC,0XC9,0XBD,0X8F,0XFF,0XFB,0XFF,0XFE,

22390XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22530XFF,0XFF,0XFF,0XFE,0XFF,0XBA,0XE6,0X92,0XCD,0X89,0XEE,0X29,0XF6,0X48,0XF6,0X48,

22540XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X47,

22550XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

22560XF6,0X68,0XF6,0X68,0XFE,0XA9,0XFE,0XA9,0XFE,0X8A,0XD5,0X46,0XC4,0XE5,0XCD,0X27,

22570XC5,0X28,0XBD,0X0A,0XAC,0XCA,0XE6,0XB4,0XFF,0XDC,0XFF,0XDD,0XFF,0XFE,0XFF,0XFE,

22580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

22720XFF,0XDB,0XEE,0XB3,0XCD,0X69,0XEE,0X29,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X67,

22730XF6,0X47,0XF6,0X47,0XFE,0X67,0XFE,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,

22740XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X68,

22750XFE,0XC9,0XFE,0XAA,0XF6,0X49,0XD5,0X66,0XD5,0X46,0XCD,0X27,0XC5,0X28,0XC5,0X4B,

22760XB4,0XEB,0XFF,0X78,0XFF,0XFD,0XFF,0XDE,0XFF,0XFF,0XF7,0XFE,0XFF,0XFF,0XFF,0XFF,

22770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBF,0XFF,0XDF,

22840XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

22850XF7,0XFF,0XF7,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

22860XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22870XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XF7,0XFE,0XF7,0XFE,

22880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDC,0XE6,0XB3,

22910XC5,0X69,0XEE,0X4A,0XF6,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XFE,0X67,

22920XFE,0X67,0XFE,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

22930XF6,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X88,0XF6,0X47,0XF6,0X88,0XFE,0XEA,0XFE,0XAA,

22940XDD,0XC6,0XDD,0X86,0XCD,0X05,0XCD,0X68,0XC5,0X08,0XBD,0X2B,0XCD,0XF0,0XFF,0XB9,

22950XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

22990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBE,0XFF,0XDE,

23030XFF,0XDE,0XFF,0XFE,0XFF,0XDD,0XFF,0XDC,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,

23040XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XFE,0XFF,0XDD,0XFF,0XDE,

23050XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBD,

23060XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XF7,0XFE,0XFF,0XFF,0XFF,0XFF,

23070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDD,0XE6,0XB4,0XC5,0X6A,0XEE,0X29,

23100XF6,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XFE,0X67,0XFE,0X67,0XFE,0X47,

23110XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

23120XF6,0X67,0XF6,0X67,0XF6,0X68,0XFE,0XA9,0XFE,0XCA,0XF6,0X89,0XDD,0XA6,0XDD,0X86,

23130XD5,0X87,0XCD,0X68,0XC5,0X6A,0XBD,0X2B,0XE6,0XB4,0XFF,0XDB,0XFF,0XFE,0XFF,0XFF,

23140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23210XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XFC,0XFF,0X9A,0XFF,0XDA,

23220XFF,0XDA,0XFF,0XDA,0XFF,0XDA,0XF7,0X79,0XEF,0X38,0XE7,0X18,0XDE,0XF8,0XE6,0XF8,

23230XE7,0X19,0XEF,0X39,0XEF,0X18,0XEF,0X18,0XEE,0XF7,0XEF,0X38,0XEF,0X39,0XEF,0X39,

23240XEF,0X19,0XEF,0X19,0XF7,0X5A,0XFF,0X9B,0XFF,0XDC,0XFF,0XDD,0XFF,0XBC,0XFF,0XBD,

23250XFF,0XFE,0XFF,0XFE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23280XFF,0XFF,0XFF,0XDE,0XFF,0XDD,0XE6,0XB4,0XC5,0X69,0XEE,0X29,0XF6,0X48,0XF6,0X67,

23290XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XF6,0X67,0XF6,0X67,

23300XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XF6,0X67,0XFE,0X67,0XF6,0X67,

23310XF6,0X68,0XFE,0XCA,0XFE,0XAA,0XEE,0X48,0XDD,0XC6,0XDD,0X86,0XDD,0XC8,0XCD,0X68,

23320XC5,0X6B,0XCD,0XAE,0XF7,0X57,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

23400XFF,0X9D,0XFF,0XDC,0XFF,0XDA,0XFF,0XB9,0XFF,0X77,0XFF,0X76,0XFF,0X55,0XFF,0X55,

23410XFF,0X55,0XF7,0X55,0XDE,0X93,0XBD,0XAF,0XAD,0X0D,0X94,0X6B,0X8C,0X2A,0X8C,0X2A,

23420X9C,0X4A,0X8C,0X09,0X94,0X29,0X94,0X29,0X94,0X29,0X94,0X09,0X94,0X0A,0X94,0X0B,

23430XA4,0X8D,0XB5,0X2F,0XCD,0XD2,0XEE,0XD7,0XFF,0XBB,0XFF,0XDC,0XFF,0XDD,0XFF,0XFE,

23440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

23470XFF,0XDD,0XE6,0X94,0XC5,0X49,0XE6,0X29,0XF6,0X48,0XFE,0X68,0XF6,0X47,0XF6,0X47,

23480XFE,0X67,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

23490XF6,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XFE,0X67,0XF6,0X47,0XFE,0X88,0XFE,0XCA,

23500XFE,0X89,0XEE,0X07,0XE5,0XC6,0XE5,0XC7,0XD5,0XA8,0XCD,0X89,0XC5,0X6C,0XE6,0X93,

23510XFF,0XBA,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XBC,0XFF,0XFB,0XFF,0XD9,

23590XEE,0XF4,0XE6,0XB0,0XE6,0X90,0XE6,0X8F,0XEE,0X8E,0XE6,0X6D,0XE6,0X8E,0XF6,0XF0,

23600XF7,0X32,0XEE,0XF1,0XE6,0X90,0XC5,0XAD,0XA4,0XA9,0X9C,0X47,0XA4,0X88,0X9C,0X67,

23610X9C,0X26,0X9C,0X46,0XA4,0X66,0XA4,0X67,0X9C,0X27,0X93,0XE6,0X93,0XC6,0X93,0XE7,

23620X9C,0X29,0XB4,0XED,0XD6,0X12,0XF7,0X38,0XFF,0XBB,0XFF,0XDD,0XFF,0XDE,0XFF,0XFF,

23630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23650XFF,0XFF,0XF7,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBC,0XDE,0X74,

23660XC5,0X49,0XE6,0X29,0XF6,0X68,0XFE,0X67,0XF6,0X47,0XF6,0X47,0XFE,0X67,0XFE,0X47,

23670XFE,0X47,0XFE,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,

23680XFE,0X67,0XFE,0X67,0XFE,0X88,0XF6,0X68,0XFE,0X89,0XFE,0XCA,0XF6,0X69,0XEE,0X08,

23690XE5,0XE7,0XEE,0X28,0XD5,0X88,0XD5,0XCB,0XD6,0X0F,0XF7,0X37,0XFF,0XFC,0XFF,0XFE,

23700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

23770XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFC,0XFF,0X98,0XDE,0XB1,0XCD,0XEC,0XD5,0XCA,

23780XDE,0X0B,0XD5,0XE9,0XDE,0X09,0XDE,0X09,0XDE,0X09,0XDE,0X2A,0XE6,0X4B,0XF6,0XEF,

23790XFF,0X50,0XFF,0X71,0XEE,0XCF,0XDE,0X4C,0XCD,0X89,0XCD,0XC9,0XCD,0XA9,0XCD,0X68,

23800XC5,0X48,0XC5,0X48,0XC5,0X28,0XC5,0X08,0XBC,0XE8,0XC4,0XE9,0XBC,0XC9,0XB4,0XA9,

23810XAC,0X8A,0XC5,0X90,0XF7,0X38,0XFF,0XFC,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

23840XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDE,0XFF,0XBC,0XE6,0X94,0XC5,0X49,0XEE,0X29,

23850XF6,0X68,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,

23860XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

23870XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0XAA,0XF6,0X69,0XEE,0X28,0XEE,0X07,0XE5,0XE8,

23880XE6,0X0B,0XD5,0XCC,0XE6,0XD3,0XFF,0XB9,0XFF,0XDC,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23950XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

23960XFF,0XFD,0XFF,0XDA,0XCE,0X50,0XAD,0X29,0XCD,0XA9,0XDE,0X09,0XE6,0X49,0XE6,0X08,

23970XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X28,0XDE,0X09,0XDE,0X09,0XF6,0XED,

23980XFF,0X8F,0XFF,0X2D,0XDE,0X29,0XDE,0X09,0XE5,0XE9,0XDD,0XA8,0XD5,0X87,0XD5,0X88,

23990XDD,0X87,0XD5,0X67,0XD5,0X47,0XCD,0X27,0XCD,0X27,0XC4,0XE8,0XBC,0XC8,0XB4,0XAA,

24000XC5,0X6F,0XEE,0XF6,0XFF,0XDB,0XFF,0XBC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,

24030XFF,0XFF,0XFF,0XFF,0XFF,0XBC,0XDE,0X53,0XC5,0X49,0XEE,0X49,0XF6,0X68,0XF6,0X47,

24040XF6,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XF6,0X67,0XF6,0X67,

24050XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X89,

24060XFE,0XA9,0XFE,0X69,0XF6,0X49,0XF6,0X29,0XEE,0X28,0XE5,0XE8,0XEE,0X4C,0XDE,0X2E,

24070XF7,0X56,0XFF,0XFB,0XF7,0XBD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24140XFF,0XFE,0XFF,0XFE,0XF7,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0X9D,0XFF,0XDB,0XCE,0X31,

24150XBD,0X8A,0XC5,0XA8,0XE6,0X4A,0XE6,0X29,0XDD,0XC6,0XE6,0X06,0XEE,0X26,0XEE,0X26,

24160XEE,0X26,0XEE,0X27,0XEE,0X28,0XE6,0X28,0XDE,0X08,0XDD,0XE8,0XFE,0XEC,0XFF,0X8E,

24170XFF,0X4D,0XEE,0X69,0XDD,0XC7,0XD5,0XA7,0XDD,0XA7,0XDD,0XA7,0XDD,0X87,0XDD,0X66,

24180XD5,0X46,0XD5,0X26,0XCD,0X06,0XCD,0X27,0XC5,0X28,0XB4,0XE8,0XAC,0XAA,0XBD,0X2D,

24190XDE,0X74,0XFF,0XDB,0XFF,0XBD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

24200XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,

24220XF7,0X3A,0XBD,0X6F,0XC5,0X69,0XEE,0X4A,0XF6,0X48,0XF6,0X47,0XFE,0X67,0XFE,0X68,

24230XFE,0X47,0XFE,0X47,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

24240XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0XA9,0XFE,0XAA,0XF6,0X69,

24250XF6,0X49,0XF6,0X49,0XEE,0X28,0XEE,0X4A,0XDD,0XEC,0XEE,0XD2,0XFF,0XB9,0XFF,0XDC,

24260XFF,0XDE,0XF7,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

24330XFF,0XFF,0XFF,0XFF,0XFF,0XBF,0XFF,0XDD,0XEE,0XD5,0XAC,0XA9,0XD5,0XE9,0XE6,0X08,

24340XE6,0X08,0XEE,0X28,0XEE,0X48,0XEE,0X27,0XEE,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X27,

24350XEE,0X28,0XE6,0X07,0XE6,0X28,0XEE,0X48,0XE6,0X08,0XEE,0X8A,0XFF,0X6D,0XFF,0X2C,

24360XE6,0X49,0XDD,0XE8,0XDD,0XC7,0XDD,0XA7,0XDD,0X87,0XDD,0X87,0XD5,0X26,0XD5,0X26,

24370XD5,0X47,0XCD,0X47,0XBC,0XE6,0XB4,0XC7,0XB4,0XE8,0XAC,0XA9,0XBD,0X4C,0XDE,0X73,

24380XFF,0XBB,0XFF,0XDD,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,

24390XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

24400XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XBD,0XF7,0X58,0XB5,0X0C,

24410XD5,0XAA,0XEE,0X29,0XFE,0X69,0XF6,0X27,0XFE,0X47,0XFE,0X47,0XFE,0X68,0XF6,0X67,

24420XFE,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

24430XFE,0X67,0XFE,0X68,0XFE,0X89,0XFE,0XAA,0XFE,0X8A,0XF6,0X69,0XF6,0X49,0XF6,0X69,

24440XEE,0X49,0XE6,0X0B,0XEE,0XB1,0XFF,0X57,0XFF,0XDC,0XFF,0XFF,0XF7,0XDF,0XFF,0XFF,

24450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,

24520XFF,0XDE,0XFF,0X7A,0XBD,0X2D,0XC5,0X29,0XEE,0X29,0XEE,0X48,0XE5,0XE7,0XEE,0X07,

24530XEE,0X27,0XEE,0X26,0XEE,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X48,

24540XEE,0X28,0XE5,0XE7,0XE6,0X28,0XEE,0X69,0XEE,0X8A,0XFF,0X6D,0XFF,0X6D,0XE6,0X69,

24550XDD,0XC7,0XD5,0XA7,0XDD,0X87,0XDD,0XA8,0XDD,0X87,0XD5,0X26,0XD5,0X67,0XCD,0X26,

24560XC5,0X06,0XC5,0X27,0XBD,0X08,0XAC,0X86,0XAC,0X87,0XB5,0X0B,0XDE,0X73,0XFF,0XBB,

24570XFF,0XFD,0XFF,0XBD,0XFF,0XDE,0XFF,0XFF,0XF7,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24590XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDC,0XEF,0X16,0XB4,0XEA,0XDE,0X0A,0XEE,0X28,

24600XFE,0X68,0XFE,0X27,0XFE,0X47,0XFE,0X47,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,

24610XFE,0X68,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X66,0XFE,0X67,0XFE,0X67,0XFE,0X68,

24620XFE,0XA9,0XFE,0XAA,0XF6,0X89,0XF6,0X69,0XF6,0X69,0XEE,0X49,0XEE,0X4B,0XE6,0X6E,

24630XFF,0X15,0XFF,0XBA,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDE,0XFF,0XDD,0XDE,0X75,

24710XB4,0XEA,0XE6,0X2B,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X26,

24720XEE,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

24730XF6,0X68,0XEE,0X68,0XE6,0X28,0XF6,0XAA,0XFF,0X4D,0XFF,0X2C,0XF6,0XAB,0XDD,0XC8,

24740XD5,0X87,0XDD,0XA7,0XDD,0X87,0XD5,0X66,0XD5,0X66,0XCD,0X06,0XCD,0X47,0XCD,0X47,

24750XBC,0XC6,0XBC,0XE8,0XBD,0X09,0XA4,0X67,0XAC,0XAA,0XD6,0X31,0XFF,0X78,0XFF,0XFC,

24760XFF,0XDD,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24780XFF,0XFE,0XFF,0XDB,0XD6,0X71,0XB4,0XE7,0XE6,0X49,0XF6,0X67,0XF6,0X47,0XFE,0X47,

24790XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X47,0XFE,0X68,0XF6,0X67,

24800XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X88,0XFE,0X68,0XFE,0X89,0XFE,0XA9,

24810XFE,0X88,0XF6,0X88,0XF6,0X88,0XEE,0X6A,0XE6,0X4D,0XF6,0XD2,0XFF,0X98,0XFF,0XFC,

24820XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XF7,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDC,0XBD,0X6F,0XCD,0XAB,0XE6,0X2A,

24900XE6,0X07,0XF6,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X46,0XF6,0X46,0XEE,0X26,

24910XEE,0X27,0XF6,0X27,0XEE,0X07,0XF6,0X27,0XEE,0X47,0XF6,0X47,0XEE,0X27,0XE6,0X27,

24920XEE,0X68,0XE6,0X48,0XF6,0XAA,0XFF,0X4D,0XFF,0X4D,0XEE,0X8A,0XDD,0XC7,0XD5,0XA7,

24930XD5,0X87,0XD5,0X86,0XD5,0X66,0XD5,0X66,0XC5,0X05,0XC4,0XE6,0XC5,0X27,0XBD,0X07,

24940XB4,0XC7,0XB4,0XC8,0XA4,0X67,0XAC,0XC9,0XCD,0XF0,0XF7,0X58,0XFF,0XDC,0XFF,0XFE,

24950XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

24960XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XD9,

24970XBD,0X6B,0XC5,0X67,0XEE,0X68,0XF6,0X87,0XF6,0X26,0XFE,0X67,0XFE,0X46,0XFE,0X67,

24980XFE,0X67,0XFE,0X67,0XFE,0X47,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XFE,0X67,

24990XFE,0X87,0XF6,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0XA8,0XFE,0XA8,0XF6,0XA8,

25000XEE,0X89,0XEE,0X8C,0XEE,0XB1,0XFF,0X97,0XFF,0XDB,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,

25010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

25080XFF,0XFF,0XFF,0XDD,0XFF,0X99,0XBD,0X4C,0XDE,0X0B,0XE6,0X08,0XF6,0X47,0XF6,0X47,

25090XEE,0X07,0XEE,0X07,0XEE,0X06,0XEE,0X26,0XF6,0X46,0XF6,0X26,0XF6,0X26,0XF6,0X47,

25100XF6,0X27,0XF6,0X48,0XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XF6,0X68,0XEE,0X48,

25110XEE,0X68,0XF6,0XAA,0XFF,0X2C,0XFF,0X4D,0XEE,0X8A,0XD5,0XC7,0XD5,0XA7,0XD5,0X86,

25120XD5,0X66,0XD5,0X66,0XCD,0X05,0XC5,0X05,0XCD,0X27,0XBC,0XE7,0XB4,0XA6,0XBC,0XE7,

25130XB4,0XC7,0XAC,0XA7,0XAC,0X89,0XC5,0XB0,0XF7,0X59,0XFF,0XFE,0XF7,0XBD,0XFF,0XFF,

25140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFC,0XEE,0XD4,0XB5,0X07,0XDE,0X28,

25160XEE,0X67,0XF6,0X86,0XFE,0X67,0XFE,0X47,0XFE,0X46,0XFE,0X67,0XFE,0X67,0XFE,0X67,

25170XFE,0X67,0XFE,0X66,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X88,0XFE,0X88,

25180XFE,0X89,0XFE,0XC9,0XFE,0XA8,0XF6,0X87,0XF6,0X88,0XEE,0X89,0XEE,0X8B,0XEE,0XD0,

25190XF7,0X56,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBF,0XFF,0XFF,0XFF,0XDC,

25270XE6,0XB4,0XCD,0XCD,0XE6,0X4A,0XEE,0X68,0XF6,0X26,0XEE,0X05,0XF6,0X27,0XF6,0X27,

25280XF6,0X27,0XF6,0X47,0XF6,0X46,0XF6,0X46,0XF6,0X26,0XF6,0X47,0XF6,0X47,0XF6,0X27,

25290XF6,0X27,0XF6,0X27,0XF6,0X67,0XFE,0X88,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X48,

25300XF6,0XAA,0XFF,0X4D,0XFF,0X2C,0XE6,0X69,0XD5,0XE7,0XCD,0X86,0XCD,0X86,0XCD,0X45,

25310XD5,0X66,0XD5,0X67,0XC5,0X06,0XC4,0XE6,0XC5,0X07,0XBC,0XC6,0XBC,0XC6,0XB4,0X86,

25320XA4,0X47,0XA4,0X8A,0XC5,0XB1,0XF7,0X39,0XFF,0XDC,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

25330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XDE,

25340XFF,0XFF,0XFF,0XFE,0XFF,0XBA,0XD5,0XEE,0XAC,0XA4,0XF6,0XA9,0XF6,0X67,0XF6,0X46,

25350XFE,0XA8,0XF6,0X26,0XFE,0X67,0XFE,0X67,0XF6,0X47,0XFE,0X67,0XFE,0X66,0XFE,0X66,

25360XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XF6,0X88,0XF6,0X89,0XFE,0XA9,0XFE,0XA9,

25370XFE,0XA8,0XF6,0X88,0XEE,0X89,0XE6,0X4A,0XE6,0X8E,0XF7,0X54,0XFF,0XDB,0XFF,0XDD,

25380XFF,0XDE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

25390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XFF,0XFC,0XDE,0X72,0XD6,0X0C,

25460XE6,0X28,0XF6,0X47,0XF6,0X06,0XF6,0X26,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

25470XF6,0X47,0XF6,0X46,0XF6,0X46,0XF6,0X46,0XF6,0X47,0XF6,0X06,0XFE,0X47,0XFE,0X47,

25480XF6,0X26,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XEE,0X47,0XEE,0X48,0XE6,0X28,0XF6,0XA9,

25490XFF,0X4C,0XFF,0X4C,0XEE,0X89,0XD5,0XA6,0XD5,0XA6,0XCD,0X66,0XCD,0X46,0XCD,0X46,

25500XC5,0X26,0XBC,0XE6,0XBC,0XC6,0XBC,0XE6,0XC4,0XC7,0XB4,0X86,0XB4,0X88,0XA4,0X48,

25510X9C,0X29,0XC5,0X90,0XEF,0X17,0XFF,0XFB,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

25520XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XFF,0XDC,

25530XFF,0X77,0XAC,0X67,0XD5,0XE8,0XEE,0X68,0XF6,0X67,0XF6,0X67,0XFE,0X88,0XF6,0X26,

25540XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X66,0XF6,0X66,0XF6,0X66,0XF6,0X67,

25550XF6,0X67,0XF6,0X88,0XF6,0X69,0XFE,0X89,0XFE,0XAA,0XF6,0X89,0XF6,0X89,0XF6,0XAA,

25560XEE,0X8B,0XE6,0X6D,0XEF,0X13,0XFF,0XB9,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25570XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25640XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XDB,0XE6,0XB1,0XD6,0X2B,0XE6,0X48,0XEE,0X26,

25650XFE,0X27,0XFE,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X46,

25660XF6,0X46,0XF6,0X46,0XF6,0X27,0XFE,0X47,0XF6,0X26,0XF6,0X47,0XF6,0X47,0XF6,0X27,

25670XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XEE,0X47,0XEE,0X68,0XF6,0XA9,0XFF,0X2B,

25680XFF,0X4C,0XE6,0X69,0XCD,0X86,0XCD,0X86,0XCD,0X66,0XC5,0X26,0XC5,0X06,0XC5,0X27,

25690XC5,0X27,0XBC,0XC6,0XBC,0XA6,0XBC,0X87,0XB4,0X87,0XAC,0X67,0X9C,0X06,0X94,0X27,

25700XAD,0X2C,0XEF,0X15,0XFF,0XBA,0XFF,0XFC,0XFF,0XDE,0XFF,0XFF,0XFF,0XDF,0XF7,0XBF,

25710XFF,0XDF,0XFF,0XDE,0XFF,0XDE,0XFF,0XFE,0XFF,0XDD,0XFF,0X99,0XC5,0X6D,0XC5,0X49,

25720XDD,0XE8,0XF6,0X88,0XF6,0X68,0XFE,0X88,0XF6,0X47,0XF6,0X67,0XFE,0X67,0XFE,0X47,

25730XFE,0X88,0XFE,0X67,0XFE,0X67,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X88,0XFE,0X89,

25740XFE,0X89,0XFE,0X8A,0XFE,0X8A,0XF6,0X89,0XF6,0XAA,0XF6,0X8B,0XE6,0X6D,0XEE,0XF2,

25750XFF,0XB8,0XFF,0XDC,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

25760XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

25830XFF,0XFE,0XFF,0XFB,0XE6,0XD1,0XD6,0X2B,0XEE,0X68,0XEE,0X47,0XF6,0X07,0XFE,0X07,

25840XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

25850XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

25860XF6,0X67,0XF6,0X67,0XF6,0X68,0XEE,0X47,0XEE,0X68,0XF6,0XCA,0XFF,0X4C,0XFF,0X6C,

25870XE6,0X89,0XCD,0XA6,0XC5,0X66,0XC5,0X46,0XBD,0X05,0XC5,0X06,0XC5,0X06,0XBC,0XE6,

25880XBC,0XA6,0XBC,0XA7,0XB4,0X87,0XAC,0X86,0XA4,0X66,0X9C,0X25,0X94,0X05,0X94,0X48,

25890XC5,0XF1,0XEF,0X38,0XFF,0XFD,0XFF,0XBD,0XFF,0XDE,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,

25900XFF,0XDE,0XFF,0X9C,0XFF,0XDA,0XE6,0X92,0XAC,0XA7,0XE6,0X0A,0XEE,0X49,0XF6,0X68,

25910XF6,0X48,0XF6,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

25920XFE,0X68,0XF6,0X67,0XF6,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X89,0XFE,0X8A,0XFE,0XAA,

25930XFE,0X8A,0XFE,0X8B,0XF6,0X6B,0XE6,0X6D,0XEE,0XD1,0XFF,0X97,0XFF,0XFC,0XFF,0XFE,

25940XF7,0XFE,0XF7,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

25990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFD,0XFF,0XFA,

26020XEF,0X12,0XDE,0X6C,0XE6,0X28,0XEE,0X47,0XFE,0X28,0XFE,0X07,0XF6,0X47,0XF6,0X47,

26030XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X47,

26040XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X47,

26050XF6,0X67,0XF6,0X88,0XF6,0X88,0XEE,0X68,0XF6,0XA9,0XFF,0X2B,0XFF,0X8D,0XEE,0XCA,

26060XD5,0XE8,0XC5,0X66,0XC5,0X46,0XBD,0X26,0XBC,0XC5,0XBC,0XC6,0XBC,0XA7,0XB4,0XA7,

26070XB4,0X86,0XAC,0X65,0XAC,0X85,0XA4,0X65,0X9C,0X24,0X8B,0XE5,0X94,0X28,0XAD,0X0E,

26080XD6,0X35,0XF7,0X7B,0XFF,0XFD,0XFF,0XDD,0XF7,0XBC,0XFF,0XFD,0XFF,0XBD,0XFF,0XBB,

26090XE6,0X93,0XBD,0X29,0XD5,0XA8,0XEE,0X48,0XF6,0X69,0XFE,0X68,0XF6,0X48,0XF6,0X68,

26100XF6,0X68,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,

26110XFE,0XA7,0XFE,0XA8,0XFE,0XA8,0XFE,0X89,0XFE,0X8A,0XFE,0X8B,0XFE,0X8B,0XF6,0X6B,

26120XEE,0X8D,0XF6,0XF1,0XFF,0X77,0XFF,0XBA,0XFF,0XFD,0XFF,0XFE,0XF7,0XFE,0XF7,0XFF,

26130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFA,0XF7,0X53,0XDE,0X4C,

26210XE6,0X29,0XF6,0X48,0XFE,0X48,0XFE,0X27,0XFE,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

26220XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X47,0XF6,0X67,0XFE,0X47,0XFE,0X67,0XFE,0X48,

26230XFE,0X48,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X68,

26240XFE,0X88,0XF6,0X68,0XEE,0X68,0XF6,0XA9,0XFF,0X2C,0XFF,0X6D,0XFF,0X2C,0XDE,0X49,

26250XBD,0X25,0XAC,0XC4,0XB4,0XC5,0XBC,0XE6,0XB4,0XC6,0XB4,0XA6,0XAC,0X65,0XA4,0X24,

26260XA4,0X24,0XA4,0X24,0X9C,0X04,0X8B,0XC4,0X83,0X84,0X83,0XA7,0X8C,0X0A,0XAD,0X0F,

26270XDE,0X75,0XF7,0X7A,0XFF,0XFB,0XFF,0XFB,0XFF,0X9A,0XF7,0X36,0XD5,0XED,0XC5,0X68,

26280XEE,0X89,0XF6,0X87,0XF6,0X67,0XF6,0X47,0XF6,0X68,0XFE,0X68,0XFE,0X87,0XF6,0X67,

26290XF6,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0XA7,0XF6,0XA7,

26300XFE,0XA8,0XFE,0XCA,0XFE,0XAB,0XFE,0X8C,0XF6,0X6C,0XEE,0X6D,0XEE,0XB1,0XFF,0X77,

26310XFF,0XFB,0XFF,0XDD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

26320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26390XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFB,0XFF,0X95,0XDE,0X4D,0XEE,0X8B,0XF6,0X49,

26400XFE,0X48,0XFE,0X27,0XFE,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,

26410XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,

26420XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X87,0XFE,0X67,0XF6,0X47,0XFE,0X67,0XF6,0X88,

26430XF6,0X68,0XEE,0X68,0XEE,0X89,0XF7,0X0B,0XFF,0X6D,0XFF,0X6D,0XDE,0X4A,0XC5,0X46,

26440XBC,0XE5,0XB4,0XC5,0XA4,0X65,0XA4,0X65,0XAC,0X65,0XA4,0X45,0X9C,0X04,0X9C,0X04,

26450X9B,0XE4,0X93,0XC4,0X8B,0XA5,0X7B,0X24,0X73,0X25,0X6A,0XC5,0X73,0X26,0X9C,0X4B,

26460XCD,0XF1,0XE6,0X93,0XFF,0X15,0XC5,0X6D,0XC5,0X69,0XEE,0X8A,0XF6,0X87,0XF6,0X86,

26470XFE,0X87,0XFE,0X67,0XFE,0X88,0XF6,0X88,0XF6,0X87,0XF6,0X86,0XF6,0X67,0XF6,0X67,

26480XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XF6,0XA7,0XF6,0XA7,0XFE,0XC9,0XFE,0XCA,

26490XFE,0XAC,0XF6,0X8D,0XEE,0X6E,0XF6,0XD1,0XFF,0X56,0XFF,0XDB,0XFF,0XFD,0XFF,0XDE,

26500XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

26580XFF,0XFE,0XFF,0XFB,0XFF,0XB6,0XDE,0X6F,0XEE,0X6C,0XEE,0X49,0XF6,0X28,0XFE,0X47,

26590XFE,0X66,0XFE,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X67,

26600XF6,0X67,0XF6,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,

26610XFE,0X67,0XFE,0X47,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X88,0XF6,0XA8,

26620XEE,0X68,0XEE,0XA9,0XEE,0XAA,0XFF,0X4D,0XFF,0XCF,0XF6,0XEC,0XCD,0X87,0XAC,0X83,

26630XAC,0XA5,0XA4,0X64,0X9C,0X24,0X9C,0X24,0X93,0XE4,0X93,0XA3,0X8B,0XA3,0X8B,0X83,

26640X7B,0X22,0X73,0X02,0X73,0X03,0X6A,0XC2,0X62,0X81,0X5A,0X60,0X49,0XC0,0X8B,0X84,

26650XC5,0X4A,0XD5,0XCB,0XEE,0X6B,0XEE,0X68,0XF6,0XA7,0XFE,0X86,0XF6,0X46,0XFE,0X88,

26660XFE,0X68,0XF6,0X87,0XF6,0X87,0XF6,0X86,0XF6,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X88,

26670XFE,0X87,0XFE,0X87,0XFE,0XA7,0XFE,0XC8,0XFE,0XCA,0XF6,0X8B,0XEE,0X6D,0XEE,0X6F,

26680XF6,0XF3,0XFF,0X77,0XFF,0XDB,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26690XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,

26770XFF,0XB8,0XF7,0X12,0XE6,0X2C,0XEE,0X2A,0XFE,0X48,0XFE,0X67,0XFE,0X66,0XFE,0X66,

26780XFE,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

26790XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X47,

26800XFE,0X67,0XFE,0X87,0XF6,0X67,0XF6,0X67,0XFE,0XA8,0XF6,0X88,0XF6,0X88,0XF6,0X89,

26810XEE,0X69,0XEE,0X89,0XFF,0X0C,0XFF,0X8E,0XFF,0X6E,0XF6,0XEC,0XB5,0X26,0XA4,0X84,

26820X93,0XE2,0X93,0XC2,0X8B,0XA3,0X83,0X62,0X7B,0X22,0X7B,0X01,0X72,0XE1,0X6A,0XA0,

26830X6A,0XA0,0X62,0X80,0X62,0X60,0X62,0X80,0XB4,0XC7,0XCD,0XA9,0XEE,0X4B,0XEE,0X4A,

26840XF6,0X69,0XF6,0X67,0XFE,0XA7,0XF6,0X86,0XFE,0X87,0XFE,0X88,0XF6,0X68,0XF6,0X88,

26850XF6,0X87,0XF6,0X87,0XF6,0X87,0XF6,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X87,0XFE,0XA7,

26860XFE,0XA8,0XFE,0XA9,0XF6,0X8B,0XEE,0X6D,0XEE,0XB0,0XF6,0XF4,0XFF,0X98,0XFF,0XDB,

26870XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

26950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XFF,0XD9,0XFF,0X54,

26960XE6,0X6E,0XEE,0X2A,0XF6,0X48,0XFE,0X66,0XFE,0X66,0XFE,0X66,0XFE,0X67,0XF6,0X67,

26970XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,

26980XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X47,0XFE,0X67,0XFE,0X67,

26990XFE,0X67,0XFE,0X87,0XFE,0X87,0XF6,0X67,0XF6,0X68,0XEE,0X48,0XF6,0XA9,0XF6,0X8A,

27000XE6,0X28,0XE6,0X8A,0XFF,0X2D,0XFF,0X8E,0XFF,0XAE,0XEE,0XCC,0XC5,0XA8,0XAC,0XA5,

27010X94,0X04,0X83,0X82,0X7B,0X21,0X7B,0X21,0X7B,0X21,0X83,0X62,0X7B,0X21,0X8B,0X82,

27020XB4,0XA6,0XE6,0X2B,0XE6,0X09,0XF6,0X6A,0XF6,0X89,0XF6,0X68,0XF6,0X68,0XFE,0X88,

27030XFE,0X87,0XFE,0X67,0XFE,0X88,0XF6,0X68,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X87,

27040XF6,0X68,0XF6,0X88,0XFE,0X88,0XFE,0XA7,0XFE,0XA7,0XFE,0XA8,0XFE,0X89,0XFE,0X8A,

27050XF6,0X8D,0XF6,0XD0,0XFF,0X35,0XFF,0X99,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

27060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFB,0XFF,0X56,0XFE,0XF2,0XEE,0X4C,

27150XF6,0X68,0XF6,0X66,0XFE,0X66,0XFE,0X66,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,

27160XFE,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,

27170XFE,0X68,0XFE,0X67,0XFE,0X47,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XF6,0X67,

27180XF6,0X67,0XFE,0X87,0XFE,0X88,0XF6,0X68,0XF6,0X89,0XF6,0X69,0XEE,0X69,0XEE,0X8A,

27190XEE,0X8A,0XEE,0XAA,0XF7,0X2C,0XFF,0X6D,0XFF,0X8F,0XFF,0X4E,0XEE,0XCD,0XDE,0X4C,

27200XD5,0XCA,0XCD,0XCA,0XC5,0X89,0XC5,0X69,0XE6,0X8D,0XFF,0X0E,0XFE,0XED,0XF6,0XAB,

27210XF6,0XAA,0XF6,0X88,0XF6,0X67,0XF6,0X46,0XFE,0XA8,0XFE,0X87,0XFE,0X67,0XFE,0X67,

27220XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XF6,0X68,0XF6,0X68,0XFE,0X88,

27230XFE,0XA8,0XFE,0XC9,0XFE,0XA9,0XF6,0X8A,0XF6,0X8B,0XF6,0X8E,0XFE,0XD2,0XFF,0X56,

27240XFF,0XBA,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27330XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XBB,0XFF,0X76,0XE6,0X6E,0XEE,0X69,0XEE,0X67,

27340XF6,0X86,0XFE,0XA6,0XFE,0X67,0XF6,0X47,0XFE,0X88,0XFE,0X68,0XF6,0X67,0XFE,0X87,

27350XF6,0X86,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XF6,0X67,0XF6,0X67,0XFE,0X87,0XFE,0X87,

27360XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,

27370XFE,0X88,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XFE,0X89,0XFE,0X89,0XF6,0X69,0XEE,0X69,

27380XEE,0X69,0XEE,0XA9,0XF6,0XCA,0XF6,0XEB,0XFF,0X0C,0XFF,0X2D,0XFF,0X2E,0XFF,0X4E,

27390XFF,0X2E,0XFE,0XED,0XF6,0XCC,0XF6,0X8A,0XEE,0X69,0XEE,0X68,0XEE,0X68,0XF6,0X88,

27400XF6,0X87,0XF6,0X87,0XF6,0X67,0XF6,0X67,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X68,

27410XFE,0X68,0XFE,0X48,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0XA9,0XFE,0XA9,0XF6,0X89,

27420XF6,0XAB,0XEE,0XAD,0XEE,0XB0,0XF7,0X14,0XFF,0X99,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,

27430XF7,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27520XFF,0XDF,0XFF,0XBD,0XFF,0XB9,0XEE,0XF2,0XEE,0XAD,0XE6,0X68,0XF6,0X67,0XF6,0X67,

27530XFE,0X88,0XFE,0X68,0XF6,0X48,0XFE,0X68,0XFE,0X88,0XF6,0X67,0XFE,0X87,0XFE,0X87,

27540XF6,0X67,0XF6,0X67,0XF6,0X87,0XFE,0X88,0XFE,0X88,0XF6,0X67,0XFE,0X87,0XFE,0X87,

27550XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,

27560XFE,0X88,0XFE,0X68,0XF6,0X67,0XF6,0X68,0XFE,0X68,0XFE,0X88,0XF6,0X88,0XF6,0X88,

27570XEE,0X68,0XEE,0X89,0XF6,0X89,0XF6,0X89,0XEE,0X89,0XEE,0X69,0XF6,0X89,0XF6,0X69,

27580XF6,0X69,0XF6,0X68,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XFE,0X88,0XF6,0X87,0XFE,0X87,

27590XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X47,0XFE,0X68,

27600XFE,0X68,0XFE,0X68,0XFE,0X8A,0XFE,0X8A,0XF6,0X6A,0XF6,0X8C,0XF6,0XCF,0XF7,0X12,

27610XFF,0X77,0XFF,0XBA,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFE,0XFF,0XFE,

27620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

27710XFF,0XFB,0XFF,0X96,0XF7,0X32,0XE6,0X6C,0XF6,0X6A,0XF6,0X68,0XFE,0X69,0XFE,0X89,

27720XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X88,

27730XF6,0X68,0XF6,0X68,0XF6,0X68,0XFE,0X88,0XFE,0X69,0XFE,0X69,0XFE,0X68,0XFE,0X68,

27740XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0XA7,0XFE,0X67,0XF6,0X67,0XFE,0X87,

27750XFE,0XA8,0XFE,0X88,0XFE,0X87,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,

27760XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XF6,0XA8,0XF6,0X88,0XF6,0X67,0XF6,0X67,0XFE,0X67,

27770XFE,0X87,0XFE,0X67,0XFE,0X48,0XFE,0X47,0XFE,0X88,0XFE,0X67,0XFE,0X67,0XFE,0X87,

27780XFE,0XA8,0XFE,0X67,0XF6,0X67,0XFE,0XA7,0XFE,0XA7,0XFE,0XA7,0XF6,0X87,0XF6,0X88,

27790XF6,0XAA,0XF6,0XAD,0XF6,0XCF,0XF6,0XD1,0XFF,0X35,0XFF,0X99,0XFF,0XDC,0XFF,0XFE,

27800XFF,0XDF,0XFF,0XDF,0XF7,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

27890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDE,0XFF,0XFC,0XFF,0XB9,

27900XFF,0X96,0XEE,0XD0,0XEE,0X4C,0XFE,0X6B,0XFE,0X6A,0XF6,0X48,0XFE,0X68,0XFE,0X88,

27910XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,

27920XFE,0X68,0XF6,0X49,0XFE,0X69,0XFE,0X69,0XFE,0X69,0XFE,0X68,0XFE,0X87,0XFE,0X87,

27930XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,

27940XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X68,0XF6,0X68,

27950XF6,0X67,0XF6,0X67,0XFE,0X87,0XFE,0X66,0XFE,0X66,0XFE,0X66,0XFE,0X67,0XFE,0X67,

27960XFE,0X68,0XFE,0X68,0XFE,0X47,0XFE,0X88,0XFE,0X87,0XF6,0X67,0XF6,0X67,0XFE,0XA8,

27970XFE,0XA8,0XF6,0X88,0XF6,0XA8,0XF6,0XA9,0XF6,0XCA,0XEE,0XCB,0XE6,0X8D,0XEE,0XD0,

27980XFF,0X75,0XFF,0XD9,0XFF,0XDB,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

27990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

28040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0X97,

28090XF6,0XD1,0XEE,0X2C,0XEE,0X2A,0XFE,0X89,0XF6,0X88,0XF6,0X67,0XFE,0X87,0XFE,0X87,

28100XFE,0XA8,0XFE,0X87,0XFE,0X67,0XF6,0X66,0XF6,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X69,

28110XFE,0X69,0XFE,0X69,0XFE,0X69,0XFE,0X68,0XFE,0X88,0XFE,0X87,0XFE,0X87,0XFE,0X87,

28120XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0XA7,

28130XF6,0X88,0XFE,0X88,0XFE,0XA8,0XFE,0X88,0XFE,0X68,0XFE,0X67,0XFE,0X87,0XFE,0X87,

28140XFE,0X67,0XFE,0X66,0XFE,0X46,0XFE,0X46,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X67,

28150XFE,0X47,0XFE,0X87,0XFE,0X87,0XF6,0X67,0XF6,0X67,0XF6,0XA8,0XF6,0XA9,0XEE,0X8A,

28160XEE,0X6B,0XEE,0XAD,0XEE,0XF0,0XF7,0X33,0XFF,0XB6,0XFF,0XF9,0XFF,0XDA,0XFF,0XDB,

28170XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

28180XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

28230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XDF,

28270XF7,0XDF,0XFF,0XDF,0XFF,0XDE,0XFF,0XBD,0XFF,0XDD,0XFF,0XBB,0XFF,0X56,0XFE,0XF2,

28280XF6,0XAE,0XEE,0X8B,0XF6,0X89,0XFE,0XA8,0XFE,0XA8,0XF6,0X87,0XF6,0X67,0XFE,0X87,

28290XFE,0XA7,0XFE,0XA7,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X48,0XFE,0X68,0XFE,0X68,

28300XFE,0X68,0XFE,0X68,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X67,

28310XFE,0X67,0XFE,0X88,0XFE,0XA8,0XFE,0X87,0XFE,0X87,0XF6,0X67,0XFE,0X88,0XF6,0X88,

28320XF6,0X88,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,

28330XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X87,0XF6,0X67,

28340XF6,0X68,0XFE,0X89,0XFE,0XAB,0XF6,0XAB,0XF6,0XAD,0XF7,0X10,0XFF,0X12,0XFF,0X55,

28350XFF,0X97,0XFF,0XBA,0XFF,0XDB,0XFF,0XDC,0XFF,0XFD,0XFF,0XFE,0XF7,0XFE,0XF7,0XDF,

28360XF7,0XDF,0XF7,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,

28370XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28410XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

28450XFF,0XDF,0XFF,0XBF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XEF,0XBE,0XEF,0X9E,

28460XEF,0X9E,0XEF,0X7D,0XEF,0X5D,0XF7,0X7C,0XFF,0X59,0XFF,0X35,0XEE,0XB0,0XE6,0X8D,

28470XEE,0XCC,0XEE,0XAA,0XEE,0X69,0XFE,0XA9,0XFE,0XA9,0XFE,0X87,0XF6,0X66,0XF6,0X65,

28480XFE,0X85,0XFE,0X86,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X86,0XFE,0X87,0XFE,0X87,

28490XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X87,

28500XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0XA8,0XFE,0X88,0XF6,0X88,0XFE,0X67,0XFE,0X87,

28510XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X68,0XFE,0X88,0XFE,0X88,

28520XFE,0X88,0XFE,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0XA9,0XF6,0X8B,0XF6,0X8C,

28530XF6,0XAF,0XF6,0XD1,0XF6,0XF3,0XF7,0X35,0XFF,0X98,0XFF,0X7A,0XFF,0X9C,0XFF,0XBE,

28540XF7,0X9E,0XF7,0XBE,0XF7,0XDE,0XEF,0XBD,0XEF,0XDD,0XEF,0XDD,0XF7,0XDE,0XF7,0XDF,

28550XF7,0XBF,0XF7,0XBF,0XFF,0XDE,0XFF,0XDE,0XFF,0XBE,0XFF,0XBE,0XFF,0XBF,0XFF,0XDF,

28560XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28600XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

28630XFF,0XDF,0XFF,0XDF,0XF7,0XDE,0XF7,0XDE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,

28640XF7,0X9E,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XE7,0X5D,0XE7,0X3C,0XE7,0X3D,0XE7,0X1C,

28650XDE,0XDB,0XDE,0XDA,0XDE,0XB8,0XDE,0X96,0XDE,0X93,0XDE,0X70,0XDE,0X6E,0XE6,0X8D,

28660XEE,0XAD,0XF6,0X8C,0XEE,0X6A,0XF6,0X89,0XF6,0XA8,0XFE,0XA7,0XFE,0XA6,0XFE,0X86,

28670XFE,0X87,0XFE,0X86,0XFE,0X86,0XFE,0X86,0XFE,0X86,0XFE,0X86,0XFE,0X87,0XFE,0X87,

28680XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,

28690XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0XA8,0XFE,0X88,0XFE,0X67,0XFE,0X67,

28700XFE,0X87,0XFE,0X87,0XFE,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X89,0XF6,0X89,0XF6,0X8A,

28710XF6,0X8A,0XF6,0XAB,0XF6,0XCB,0XF6,0XCC,0XEE,0XAE,0XEE,0X90,0XE6,0X93,0XE6,0X94,

28720XEE,0XD6,0XEF,0X18,0XEE,0XF9,0XEF,0X1B,0XE7,0X1C,0XE6,0XFD,0XE7,0X3E,0XE7,0X5E,

28730XE7,0X5D,0XE7,0X9D,0XE7,0X9C,0XE7,0X9C,0XEF,0X9D,0XEF,0X9D,0XEF,0X9E,0XEF,0X7E,

28740XF7,0X9D,0XF7,0X9D,0XF7,0X9D,0XF7,0X9D,0XFF,0X9E,0XFF,0XBE,0XF7,0XBE,0XF7,0XBE,

28750XF7,0XDE,0XF7,0XDE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

28760XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,

28790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28810XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

28820XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9D,0XF7,0X7D,0XEF,0X7D,0XEF,0X3C,0XE7,0X1C,

28830XE7,0X1C,0XDF,0X1C,0XDE,0XFB,0XD6,0XBB,0XD6,0X9A,0XCE,0X7A,0XC6,0X39,0XC6,0X18,

28840XBD,0XD6,0XB5,0X94,0XAD,0X52,0XAD,0X30,0XAC,0XED,0XB4,0XEC,0XC5,0X6D,0XDD,0XEE,

28850XEE,0X8F,0XF6,0X8D,0XF6,0X8B,0XF6,0XCA,0XF6,0X88,0XF6,0X87,0XF6,0X67,0XFE,0XA7,

28860XFE,0XA6,0XFE,0X86,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X68,

28870XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,

28880XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X87,0XF6,0X87,

28890XF6,0X67,0XF6,0X88,0XF6,0XA9,0XF6,0XAA,0XEE,0XAB,0XF6,0XAD,0XF6,0XCD,0XE6,0X4D,

28900XC5,0X8A,0XAC,0XA9,0X9C,0X2A,0X9C,0X4C,0XA4,0X8F,0XAC,0XD1,0XAD,0X13,0XB5,0X54,

28910XBD,0X96,0XBD,0XD7,0XC5,0XF8,0XC6,0X19,0XCE,0X5A,0XCE,0X7A,0XCE,0X99,0XCE,0XB9,

28920XD6,0XDA,0XD6,0XFA,0XDF,0X1B,0XDF,0X1C,0XDF,0X1C,0XE7,0X1C,0XE7,0X1C,0XEF,0X3C,

28930XEF,0X5C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9D,0XF7,0X9D,

28940XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,

28950XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

28960XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,

28980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

28990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

29000XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,

29010XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XEF,0X3C,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XDE,0XDB,

29020XD6,0X9A,0XCE,0X79,0XCE,0X59,0XC6,0X18,0XB5,0XB7,0XAD,0X76,0XA5,0X35,0X9C,0XD3,

29030X94,0X71,0X8C,0X0E,0X83,0XAC,0X7B,0X6A,0X7B,0X49,0X83,0X68,0X9C,0X29,0XBD,0X2C,

29040XE6,0X4E,0XEE,0XAE,0XF6,0XAC,0XFF,0X0C,0XFE,0XCB,0XF6,0XAA,0XF6,0XA9,0XF6,0X88,

29050XF6,0X88,0XFE,0X89,0XFE,0X89,0XF6,0X69,0XF6,0X69,0XFE,0X89,0XF6,0X89,0XF6,0X89,

29060XF6,0X89,0XF6,0X89,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X68,

29070XF6,0X68,0XF6,0X89,0XF6,0X89,0XF6,0X69,0XF6,0X89,0XEE,0X89,0XF6,0XAA,0XF6,0XAB,

29080XFF,0X0D,0XF6,0XCD,0XE6,0X8E,0XD6,0X2D,0XA4,0XA8,0X73,0X24,0X49,0XC0,0X39,0X80,

29090X41,0X82,0X41,0XC5,0X4A,0X07,0X52,0X49,0X5A,0X8A,0X62,0XCB,0X6B,0X2C,0X73,0X8E,

29100X7B,0XF0,0X8C,0X31,0X94,0X92,0X94,0XD2,0XA5,0X33,0XAD,0X74,0XAD,0X95,0XB5,0XB6,

29110XBD,0XF7,0XC6,0X18,0XC6,0X39,0XCE,0X59,0XCE,0X79,0XD6,0XBA,0XD6,0XBA,0XDE,0XBB,

29120XDE,0XDB,0XDE,0XFB,0XE6,0XFC,0XE7,0X1B,0XE7,0X3C,0XE7,0X5C,0XEF,0X5C,0XEF,0X5D,

29130XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,

29140XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,

29150XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

29160XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

29170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

29180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,

29190XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XEF,0X9E,0XEF,0X7D,0XEF,0X7D,

29200XEF,0X5C,0XE7,0X3C,0XE7,0X3C,0XE7,0X1C,0XE7,0X1C,0XDE,0XDB,0XD6,0X9A,0XCE,0X79,

29210XCE,0X59,0XC6,0X38,0XBD,0XD6,0XB5,0X96,0XA5,0X35,0X9C,0XD4,0X94,0X72,0X83,0XF0,

29220X7B,0X8D,0X6B,0X0B,0X5A,0X88,0X52,0X26,0X52,0X04,0X49,0XE2,0X51,0XE0,0X7B,0X44,

29230XAC,0XC9,0XCD,0XCC,0XE6,0X8F,0XEE,0XAE,0XF6,0XCD,0XFE,0XCD,0XF6,0XAC,0XEE,0X8B,

29240XF6,0X8B,0XF6,0XAB,0XF6,0X8A,0XEE,0X69,0XEE,0X8A,0XF6,0X8A,0XF6,0X8A,0XF6,0X8A,

29250XF6,0XA9,0XF6,0XA9,0XF6,0XA9,0XF6,0XA9,0XF6,0X8A,0XEE,0X6A,0XF6,0X8B,0XF6,0X8B,

29260XF6,0X8B,0XF6,0XAC,0XFE,0XEE,0XFF,0X0F,0XF6,0XEF,0XE6,0X8E,0XC5,0X8B,0X9C,0X88,

29270X62,0XC3,0X39,0X80,0X39,0X80,0X39,0XA1,0X41,0XE4,0X41,0XE4,0X41,0XE5,0X39,0XC5,

29280X39,0XA5,0X41,0XE7,0X42,0X28,0X4A,0X49,0X4A,0X69,0X52,0XAA,0X62,0XEB,0X63,0X0B,

29290X6B,0X4C,0X6B,0X6C,0X73,0XAD,0X7B,0XEE,0X8C,0X30,0X8C,0X72,0X94,0XB3,0X9C,0XF3,

29300XA5,0X34,0XAD,0X54,0XB5,0X95,0XBD,0XD6,0XBE,0X17,0XC6,0X38,0XCE,0X59,0XCE,0X7A,

29310XD6,0X9A,0XD6,0XBA,0XDE,0XDA,0XDE,0XFA,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X3C,

29320XE7,0X3C,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,

29330XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,

29340XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

29350XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

29360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

29370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,

29380XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XEF,0X9E,0XEF,0X9D,0XEF,0X7D,0XEF,0X5D,

29390XE7,0X3C,0XE7,0X3C,0XE7,0X1C,0XE6,0XFC,0XDE,0XFB,0XDE,0XDB,0XDE,0XBA,0XD6,0X99,

29400XCE,0X79,0XCE,0X59,0XC6,0X19,0XBD,0XF8,0XB5,0X97,0XB5,0X76,0XAD,0X35,0XA4,0XD3,

29410X94,0X51,0X8C,0X0F,0X83,0XCD,0X73,0X2A,0X62,0XC7,0X52,0X44,0X41,0XC1,0X49,0XE1,

29420X5A,0X42,0X7B,0X25,0X9C,0X27,0XBC,0XEA,0XD5,0XAC,0XDE,0X0C,0XE6,0X2D,0XEE,0X8D,

29430XEE,0XAE,0XEE,0XAD,0XEE,0X8D,0XEE,0XAD,0XEE,0XAD,0XEE,0XAD,0XEE,0XCD,0XEE,0XCC,

29440XEE,0XCC,0XEE,0XCC,0XF6,0XCE,0XEE,0X8E,0XEE,0X8E,0XEE,0X8E,0XDE,0X4D,0XC5,0X8B,

29450XA4,0X87,0X83,0XA5,0X6B,0X03,0X4A,0X00,0X31,0X40,0X29,0X20,0X31,0X60,0X39,0XC3,

29460X41,0XE4,0X42,0X05,0X42,0X06,0X4A,0X27,0X52,0X88,0X52,0X88,0X52,0X88,0X52,0XA9,

29470X52,0X89,0X4A,0X69,0X52,0XAA,0X5A,0XAA,0X5A,0XCA,0X62,0XEA,0X6B,0X2B,0X73,0X6C,

29480X73,0XAD,0X7B,0XEE,0X7B,0XCF,0X84,0X10,0X8C,0X51,0X94,0X91,0X94,0XD2,0X9C,0XF2,

29490XA5,0X33,0XAD,0X74,0XAD,0X95,0XB5,0XB6,0XBD,0XD7,0XBE,0X18,0XC6,0X18,0XCE,0X38,

29500XD6,0X79,0XD6,0X99,0XD6,0XBA,0XD6,0XBA,0XDE,0XDB,0XDE,0XDB,0XDE,0XFB,0XE7,0X1C,

29510XE7,0X1C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

29520XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

29530XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XFF,0XDF,

29540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

29550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

29560XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

29570XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XEF,0X7E,0XEF,0X7D,0XEF,0X7D,0XEF,0X5D,

29580XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X1C,0XE7,0X1B,0XDE,0XFB,0XDE,0XFA,0XDE,0XFA,

29590XD6,0XBA,0XD6,0X9A,0XCE,0X79,0XCE,0X59,0XCE,0X59,0XCE,0X18,0XC5,0XF7,0XC5,0XD6,

29600XBD,0XB5,0XBD,0XD5,0XB5,0X93,0XBD,0X93,0XBD,0X93,0XB5,0X52,0XB5,0X11,0XA4,0X8F,

29610X9C,0X2D,0X9C,0X0C,0X93,0XEA,0X93,0XEA,0X94,0X09,0X9C,0X29,0XA4,0X69,0XAC,0XAA,

29620XAC,0XCA,0XAC,0XAA,0XA4,0X8A,0XA4,0X69,0X9C,0X48,0X9C,0X47,0X94,0X26,0X94,0X06,

29630X83,0X65,0X73,0X04,0X62,0X82,0X52,0X20,0X49,0XC0,0X41,0XA0,0X39,0X80,0X39,0X80,

29640X39,0XA2,0X39,0XC3,0X42,0X05,0X42,0X05,0X42,0X26,0X4A,0X67,0X4A,0X47,0X42,0X47,

29650X52,0X88,0X52,0X88,0X5A,0XC9,0X5A,0XE9,0X63,0X2A,0X6B,0X6C,0X73,0X8D,0X73,0X8D,

29660X73,0X6D,0X73,0X6C,0X73,0X6C,0X73,0X6C,0X73,0X8C,0X7B,0XAE,0X83,0XEF,0X84,0X10,

29670X8C,0X51,0X8C,0X71,0X94,0XB2,0X9C,0XD2,0X9C,0XF2,0XA5,0X13,0XA5,0X54,0XAD,0X74,

29680XAD,0X95,0XB5,0XB6,0XB5,0XD7,0XBD,0XF7,0XBD,0XF8,0XC6,0X18,0XCE,0X38,0XCE,0X79,

29690XD6,0X7A,0XD6,0X9A,0XD6,0XBA,0XD6,0XBA,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,

29700XE7,0X3C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,

29710XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

29720XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

29730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

29740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

29750XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

29760XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XEF,0X9E,0XEF,0X9E,0XEF,0X9D,0XEF,0X7D,0XEF,0X7D,

29770XEF,0X5D,0XEF,0X5D,0XEF,0X3D,0XE7,0X3C,0XE7,0X3C,0XE7,0X1C,0XE7,0X3C,0XE7,0X1C,

29780XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1B,0XE7,0X1B,0XDE,0XFA,

29790XE7,0X3B,0XE6,0XFA,0XE7,0X1A,0XEE,0XFA,0XE6,0XD9,0XE6,0XDA,0XE6,0X99,0XE6,0X98,

29800XE6,0X98,0XDE,0X77,0XD6,0X35,0XCD,0XF4,0XCD,0XD3,0XCD,0XD2,0XC5,0XB2,0XBD,0X91,

29810XBD,0X50,0XB5,0X2F,0XAD,0X0E,0XA4,0XCD,0X9C,0XAC,0X9C,0X8C,0X9C,0X4C,0X94,0X2B,

29820X8C,0X0B,0X8B,0XEB,0X8B,0XEB,0X83,0XEB,0X7B,0XCB,0X73,0X8B,0X73,0X8B,0X73,0XAC,

29830X73,0X6C,0X73,0X8C,0X73,0X8D,0X6B,0X6C,0X73,0XAD,0X73,0XCD,0X7B,0XEE,0X7B,0XED,

29840X84,0X0E,0X84,0X0E,0X84,0X2E,0X84,0X2F,0X8C,0X50,0X8C,0X50,0X94,0X70,0X94,0X90,

29850X94,0X70,0X94,0X70,0X94,0X70,0X94,0X71,0X94,0X92,0X9C,0XB3,0X9C,0XD3,0X9C,0XF3,

29860XA5,0X13,0XA5,0X34,0XAD,0X54,0XAD,0X74,0XAD,0X95,0XB5,0XB6,0XB5,0XD6,0XBD,0XF7,

29870XBE,0X17,0XBE,0X18,0XC6,0X38,0XCE,0X59,0XCE,0X79,0XD6,0X7A,0XD6,0X9A,0XD6,0X9A,

29880XD6,0XBA,0XD6,0XBA,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XE7,0X3C,0XE7,0X1C,

29890XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

29900XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

29910XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

29920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

29930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

29940XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XF7,0XBF,0XF7,0XBF,

29950XF7,0XBF,0XF7,0XBF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBD,0XF7,0X9D,0XF7,0X9E,

29960XF7,0X9E,0XEF,0X7E,0XEF,0X7D,0XEF,0X7D,0XE7,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7C,

29970XEF,0X7D,0XF7,0X9E,0XF7,0XBE,0XF7,0XDE,0XF7,0XBE,0XFF,0XDE,0XF7,0XBD,0XF7,0X9C,

29980XF7,0X9C,0XF7,0X5B,0XFF,0X7C,0XF7,0X3B,0XF7,0X5C,0XF7,0X5B,0XEF,0X3B,0XEF,0X1A,

29990XEF,0X3B,0XF7,0X7B,0XF7,0X3B,0XEE,0XF9,0XEF,0X19,0XEF,0X19,0XE7,0X19,0XE7,0X19,

30000XE6,0XF8,0XE6,0XF8,0XE6,0XD8,0XE6,0XD8,0XE6,0XB8,0XE6,0XB8,0XE6,0XB8,0XDE,0X98,

30010XD6,0X77,0XD6,0X77,0XD6,0X77,0XD6,0X77,0XCE,0X56,0XCE,0X36,0XCE,0X56,0XC6,0X16,

30020XC6,0X16,0XC6,0X36,0XBD,0XD5,0XBD,0XD5,0XBD,0XB6,0XBD,0XB5,0XBD,0XD6,0XBD,0XD6,

30030XBD,0XB5,0XBD,0XD6,0XBD,0XD6,0XBD,0XD6,0XC5,0XF6,0XC6,0X16,0XC6,0X16,0XC5,0XF5,

30040XBD,0XD5,0XB5,0XB5,0XB5,0X95,0XB5,0X96,0XB5,0XB5,0XB5,0XB6,0XB5,0XD6,0XBD,0XD7,

30050XBD,0XD7,0XBD,0XF8,0XC6,0X18,0XC6,0X39,0XC6,0X38,0XC6,0X38,0XC6,0X58,0XCE,0X79,

30060XCE,0X79,0XD6,0X9A,0XD6,0X9B,0XDE,0XBB,0XDE,0XDB,0XDE,0XDB,0XDE,0XDB,0XDE,0XFB,

30070XDE,0XFB,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,

30080XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

30090XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,

30100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

30130XFF,0XDF,0XFF,0XDF,0XFF,0XDE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XDF,

30140XF7,0XDF,0XF7,0XDE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,

30150XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XDE,0XF7,0XBE,0XFF,0XDE,0XFF,0XFF,

30160XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XDE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XBD,

30170XFF,0XBD,0XFF,0XBE,0XFF,0XBD,0XF7,0XBD,0XF7,0XBD,0XFF,0XBD,0XFF,0XDE,0XFF,0XDE,

30180XFF,0XBD,0XFF,0XBD,0XF7,0X9D,0XF7,0X9C,0XF7,0XBD,0XF7,0XBC,0XF7,0X9C,0XF7,0X9C,

30190XF7,0XBD,0XFF,0XBD,0XF7,0X7C,0XF7,0X7C,0XF7,0X5C,0XF7,0X5C,0XF7,0X7C,0XF7,0X9C,

30200XF7,0X9C,0XEF,0X7B,0XEF,0X5B,0XF7,0X7B,0XEF,0X5A,0XEF,0X5A,0XEF,0X3B,0XE7,0X3B,

30210XEF,0X5B,0XEF,0X5C,0XEF,0X3C,0XEF,0X1C,0XEF,0X3C,0XE7,0X1B,0XE7,0X1B,0XE7,0X3B,

30220XE7,0X1B,0XE7,0X1B,0XE7,0X1A,0XE7,0X1A,0XE7,0X1A,0XE7,0X1A,0XE7,0X3B,0XDF,0X1B,

30230XD6,0XBA,0XD6,0X99,0XCE,0X99,0XCE,0X99,0XCE,0X99,0XD6,0X9A,0XD6,0X9A,0XD6,0X9B,

30240XD6,0XBB,0XD6,0XBB,0XD6,0XBA,0XD6,0XBA,0XDE,0XDA,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,

30250XDE,0XFC,0XDE,0XFC,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

30260XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,

30270XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

30280XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XF7,0XBE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

30290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

30330XFF,0XDE,0XFF,0XDE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

30340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30350XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XFE,

30360XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

30370XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

30380XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XFE,

30390XFF,0XDE,0XFF,0XDE,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XF7,0XBD,

30400XF7,0XBD,0XF7,0XBD,0XF7,0XBD,0XF7,0XBD,0XF7,0XBD,0XF7,0XBD,0XF7,0XBD,0XF7,0XBD,

30410XF7,0X9D,0XF7,0XBD,0XF7,0XBD,0XFF,0XDE,0XF7,0XDE,0XF7,0XBE,0XF7,0X9D,0XF7,0X9D,

30420XEF,0X7D,0XE7,0X3C,0XE7,0X1B,0XE7,0X1B,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,

30430XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3D,0XE7,0X3D,0XE7,0X3D,

30440XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,

30450XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

30460XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

30470XF7,0XBE,0XFF,0XDF,0XF7,0XBE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30550XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

30560XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30580XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

30590XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

30600XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDE,0XF7,0X9E,

30610XEF,0X7D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

30620XEF,0X7D,0XEF,0X7D,0XEF,0X7E,0XEF,0X7E,0XEF,0X7E,0XEF,0X7E,0XEF,0X7D,0XEF,0X7D,

30630XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

30640XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

30650XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

30660XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30770XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XF7,0XBE,

30800XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

30810XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

30820XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

30830XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

30840XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

30850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

30980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XFF,0XDE,

30990XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

31000XF7,0XBE,0XF7,0XBF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

31010XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

31020XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

31030XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,

31180XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

31190XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

31200XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

31210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,

31370XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

31380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

31990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,};

3218

3219

3220const unsigned char gimage_8[51000] = { /* 0X10,0X10,0X00,0X96,0X00,0XAA,0X01,0X1B, */

32210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

32990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33610XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

33620XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

33630XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,

33800XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,

33810XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,

33820XFF,0XFC,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

33970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

33980XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFB,0XFF,0XFA,0XFF,0XFA,

33990XFF,0XFA,0XFF,0XF9,0XFF,0XF9,0XFF,0XD9,0XFF,0XD9,0XFF,0XD9,0XFF,0XF8,0XFF,0XF8,

34000XFF,0XF8,0XFF,0XF8,0XFF,0XF8,0XFF,0XF8,0XFF,0XF8,0XFF,0XF8,0XFF,0XF9,0XFF,0XFA,

34010XFF,0XFA,0XFF,0XFB,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34160XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFB,0XFF,0XFA,

34170XFF,0XFA,0XFF,0XF9,0XFF,0XF8,0XFF,0XF7,0XFF,0XF7,0XFF,0XF6,0XFF,0XF6,0XFF,0XF5,

34180XFF,0XD5,0XFF,0XD4,0XFF,0XD4,0XFF,0XD4,0XFF,0XF4,0XFF,0XF4,0XFF,0XF4,0XFF,0XF4,

34190XFF,0XF4,0XFF,0XD4,0XFF,0XF5,0XFF,0XD5,0XFF,0XF6,0XFF,0XF6,0XFF,0XF7,0XFF,0XF8,

34200XFF,0XFA,0XFF,0XFB,0XFF,0XFC,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XFB,

34350XFF,0XFA,0XFF,0XF9,0XFF,0XF9,0XFF,0XF8,0XFF,0XF8,0XFF,0XF7,0XFF,0XF7,0XFF,0XF6,

34360XFF,0XD5,0XFF,0XD4,0XFF,0XF4,0XFF,0XF3,0XFF,0XF3,0XFF,0XF2,0XFF,0XF1,0XFF,0XF1,

34370XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,

34380XFF,0XF2,0XFF,0XF3,0XFF,0XF3,0XFF,0XF4,0XFF,0XF5,0XFF,0XD6,0XFF,0XD7,0XFF,0XF8,

34390XFF,0XF9,0XFF,0XFA,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

34530XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,0XFF,0XF9,0XFF,0XF8,0XFF,0XF7,0XFF,0XF6,

34540XFF,0XF5,0XFF,0XF4,0XFF,0XF4,0XFF,0XF4,0XFF,0XF3,0XFF,0XF3,0XFF,0XF2,0XFF,0XF2,

34550XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,

34560XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF2,

34570XFF,0XF2,0XFF,0XF2,0XFF,0XF3,0XFF,0XD4,0XFF,0XD5,0XFF,0XF5,0XFF,0XF6,0XFF,0XD7,

34580XFF,0XFA,0XFF,0XFB,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

34590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34710XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,0XFF,0XFA,

34720XFF,0XF9,0XFF,0XF7,0XFF,0XF6,0XFF,0XF5,0XFF,0XF4,0XFF,0XF3,0XFF,0XF2,0XFF,0XF2,

34730XFF,0XF2,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,

34740XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

34750XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF1,

34760XFF,0XF1,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF3,0XFF,0XF4,0XFF,0XD7,0XFF,0XD8,

34770XFF,0XD9,0XFF,0XFB,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

34900XFF,0XFE,0XFF,0XFC,0XFF,0XFB,0XFF,0XF9,0XFF,0XF7,0XFF,0XF5,0XFF,0XF4,0XFF,0XF3,

34910XF7,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

34920XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

34930XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

34940XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

34950XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF3,0XFF,0XF5,0XFF,0XD6,0XFF,0XF8,

34960XFF,0XFA,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

34990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFA,

35090XFF,0XF8,0XFF,0XF6,0XF7,0XF4,0XF7,0XF2,0XF7,0XF1,0XF7,0XF0,0XFF,0XF0,0XFF,0XF0,

35100XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XCF,0XFF,0XCF,

35110XFF,0XCF,0XFF,0XD0,0XFF,0XD0,0XFF,0XD0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

35120XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

35130XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

35140XFF,0XEE,0XFF,0XEF,0XFF,0XF1,0XFF,0XD2,0XFF,0XD3,0XFF,0XD5,0XFF,0XF7,0XFF,0XF9,

35150XFF,0XFB,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

35270XFF,0XFD,0XFF,0XFD,0XFF,0XFB,0XFF,0XFA,0XFF,0XF8,0XFF,0XD6,0XFF,0XD5,0XFF,0XF3,

35280XFF,0XF2,0XF7,0XF0,0XF7,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,

35290XFF,0XB0,0XFF,0XD0,0XFF,0XAF,0XFF,0XAE,0XFF,0XAE,0XFF,0XAE,0XFF,0X6E,0XFF,0X6E,

35300XFF,0X6F,0XFF,0XAF,0XFF,0XD0,0XFF,0XF0,0XF7,0XAF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

35310XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XCE,0XFF,0XEF,0XFF,0XCE,0XFF,0XCF,0XFF,0XEF,

35320XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,

35330XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF2,0XFF,0XF3,0XFF,0XF5,0XFF,0XF8,0XFF,0XFB,

35340XFF,0XFD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XFB,0XFF,0XFA,

35460XFF,0XF8,0XFF,0XD6,0XFF,0XD5,0XFF,0XD3,0XFF,0XD2,0XFF,0XF1,0XF7,0XF0,0XFF,0XEF,

35470XFF,0XEF,0XFF,0XEE,0XFF,0XCE,0XFF,0XCE,0XFF,0XCE,0XFF,0X8E,0XFF,0X8E,0XFF,0X2D,

35480XEE,0XEA,0XE6,0XA9,0XDE,0X68,0XDE,0X47,0XDE,0X28,0XDE,0X08,0XE6,0X29,0XE6,0X6A,

35490XE6,0XAB,0XF7,0X4E,0XFF,0XF0,0XFF,0XD0,0XF7,0XAF,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,

35500XFF,0XEF,0XFF,0XCE,0XFF,0XEF,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

35510XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

35520XFF,0XEF,0XFF,0XF0,0XFF,0XF1,0XF7,0XF2,0XFF,0XD5,0XFF,0XD8,0XFF,0XDB,0XFF,0XFE,

35530XFF,0XDE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35640XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XFB,0XFF,0XF9,0XFF,0XF7,0XFF,0XD5,0XFF,0XD3,

35650XFF,0XD1,0XFF,0XD0,0XFF,0XF0,0XFF,0XF0,0XF7,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XCF,

35660XFF,0XAE,0XFF,0XAE,0XFF,0X8D,0XF7,0X4B,0XEE,0X88,0XE6,0X46,0XDE,0X26,0XDE,0X05,

35670XD5,0XC4,0XD5,0X83,0XCD,0X62,0XCD,0X22,0XCD,0X23,0XC5,0X03,0XC5,0X45,0XD6,0X08,

35680XF7,0X0C,0XFF,0X8F,0XFF,0XD0,0XFF,0XD0,0XFF,0XD0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,

35690XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

35700XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,

35710XFF,0XEF,0XFF,0XD0,0XF7,0XD2,0XF7,0XB5,0XFF,0XD9,0XFF,0XFD,0XFF,0XBD,0XFF,0XFF,

35720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFC,

35830XFF,0XFA,0XFF,0XF8,0XFF,0XF6,0XFF,0XF5,0XFF,0XD2,0XFF,0XD1,0XFF,0XEF,0XFF,0XEF,

35840XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XAF,0XFF,0X8D,0XFF,0X2C,

35850XEE,0XC9,0XE6,0X47,0XD5,0XC3,0XCD,0X82,0XCD,0X62,0XD5,0X62,0XD5,0X61,0XD5,0X81,

35860XDD,0X81,0XDD,0X81,0XD5,0X21,0XC4,0XE2,0XBC,0XA1,0XAC,0X61,0XBD,0X04,0XE6,0X6A,

35870XFF,0XB0,0XFF,0XD0,0XFF,0XCF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,

35880XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

35890XFF,0XEF,0XFF,0XEF,0XFF,0XCF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,

35900XFF,0XD1,0XFF,0XD3,0XFF,0XB6,0XFF,0XB9,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

35910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

35990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36010XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0XF9,0XFF,0XF7,0XFF,0XF5,

36020XFF,0XF3,0XFF,0XF1,0XFF,0XF0,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,

36030XFF,0XEF,0XFF,0XEF,0XFF,0XCF,0XFF,0X8E,0XFF,0X0B,0XEE,0X68,0XE6,0X06,0XDD,0XC5,

36040XDD,0XC3,0XE5,0XE3,0XE5,0XC3,0XE5,0XC3,0XED,0XE2,0XEE,0X02,0XED,0XE1,0XED,0XE1,

36050XDD,0X61,0XDD,0X42,0XC4,0XA1,0XA3,0XC0,0X9B,0XC0,0XB4,0XE4,0XE6,0X8B,0XFF,0XAF,

36060XFF,0XCF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

36070XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

36080XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEF,0XFF,0XF1,

36090XF7,0X93,0XF7,0X95,0XFF,0XFA,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

36100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

36200XFF,0XFD,0XFF,0XFA,0XFF,0XF8,0XFF,0XD6,0XFF,0XD4,0XFF,0XD2,0XFF,0XF0,0XFF,0XEF,

36210XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XCE,

36220XFF,0X8D,0XF7,0X0B,0XE6,0X48,0XE5,0XE6,0XE6,0X06,0XEE,0X26,0XEE,0X25,0XF6,0X65,

36230XF6,0X66,0XFE,0X45,0XFE,0X65,0XFE,0X43,0XED,0XE1,0XED,0XC1,0XED,0XE2,0XE5,0X82,

36240XD5,0X42,0XBC,0X81,0X93,0X60,0X8B,0X60,0XB4,0XC4,0XF7,0X0D,0XFF,0XCF,0XFF,0XF0,

36250XFF,0XCF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

36260XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

36270XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEF,0XFF,0XB0,0XF7,0X93,

36280XF7,0X55,0XFF,0XFB,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

36380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFA,0XFF,0XF7,

36390XFF,0XD5,0XFF,0XF2,0XFF,0XF1,0XFF,0XF0,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

36400XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XAD,0XF7,0X2A,0XE6,0X67,

36410XDD,0XE6,0XEE,0X06,0XF6,0X48,0XF6,0X68,0XFE,0XC9,0XFE,0XA8,0XFE,0X67,0XFE,0X46,

36420XFE,0X46,0XFE,0X45,0XFE,0X44,0XFE,0X44,0XFE,0X44,0XED,0XE3,0XED,0XC4,0XDD,0X44,

36430XA3,0XC0,0X83,0X00,0X8B,0X60,0XD5,0XE8,0XF7,0X4D,0XFF,0XF0,0XFF,0XCF,0XFF,0XCF,

36440XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,

36450XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,

36460XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEF,0XF7,0XB0,0XE6,0XF1,0XFF,0XF8,

36470XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

36570XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XFF,0XF8,0XFF,0XF4,0XFF,0XF1,0XFF,0XF0,

36580XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,

36590XFF,0XEF,0XFF,0XEE,0XFF,0X6C,0XF7,0X2A,0XEE,0X87,0XDD,0XE4,0XE6,0X05,0XFE,0X88,

36600XFE,0XA9,0XF6,0X48,0XFE,0XC9,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X87,

36610XFE,0X87,0XFE,0X86,0XF6,0X44,0XF6,0X24,0XED,0XE4,0XE5,0XC5,0XD5,0X45,0XAC,0X21,

36620X72,0X80,0X94,0X01,0XE6,0XAB,0XFF,0XCF,0XFF,0XCF,0XFF,0XCF,0XFF,0XCF,0XFF,0XEE,

36630XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

36640XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,

36650XFF,0XEE,0XFF,0XCD,0XFF,0XED,0XF7,0X8E,0XEF,0X2F,0XEF,0X33,0XFF,0XF9,0XFF,0XFC,

36660XFF,0XFE,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

36760XFF,0XFB,0XFF,0XD8,0XFF,0XD4,0XFF,0XF2,0XFF,0XEF,0XFF,0XEE,0XFF,0XCE,0XFF,0XEE,

36770XFF,0XEE,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XCD,

36780XFF,0X4B,0XF6,0XC8,0XD5,0XA3,0XEE,0X05,0XF6,0X67,0XFE,0XC8,0XFE,0XC9,0XFE,0X89,

36790XF6,0X88,0XFE,0XA8,0XFE,0XA9,0XFE,0X89,0XFE,0X69,0XFE,0X89,0XFE,0X88,0XFE,0XA8,

36800XF6,0X86,0XFE,0XA6,0XFE,0X66,0XEE,0X06,0XE5,0XC7,0XC4,0XC4,0X93,0X80,0X83,0X20,

36810XBD,0X46,0XF7,0X4D,0XFF,0XCF,0XFF,0XEF,0XFF,0XCE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,

36820XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,

36830XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCE,0XFF,0XEE,0XFF,0XCE,0XFF,0XCD,

36840XFF,0XCD,0XFF,0XCE,0XEF,0X4E,0XD6,0X8E,0XFF,0XB6,0XFF,0XFB,0XFF,0XFD,0XFF,0XFF,

36850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

36940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFC,0XFF,0XF8,0XFF,0XD5,

36950XFF,0XD2,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,

36960XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0X8C,0XF6,0XA8,0XDD,0XE5,

36970XDD,0XA4,0XEE,0X25,0XF6,0X67,0XFE,0X87,0XFE,0XA9,0XFE,0XEA,0XFE,0X88,0XFE,0XA9,

36980XFE,0XA9,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0XA8,0XFE,0X87,

36990XFE,0X86,0XFE,0X67,0XF6,0X27,0XE5,0XA7,0XBC,0X84,0X8B,0X20,0X9C,0X21,0XEE,0XEB,

37000XFF,0X8E,0XFF,0XEF,0XFF,0XCE,0XFF,0XEE,0XF7,0XCC,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,

37010XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

37020XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XCE,0XFF,0XCD,0XFF,0XED,0XFF,0XCD,

37030XFF,0XAE,0XCE,0X4C,0XE6,0XF2,0XFF,0XF9,0XFF,0XDD,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,

37040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37130XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XF9,0XFF,0XD4,0XFF,0XD1,0XFF,0XCF,0XFF,0XEE,

37140XFF,0XED,0XFF,0XEE,0XFF,0XCF,0XFF,0XEF,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,

37150XFF,0XED,0XFF,0XED,0XFF,0XCD,0XF7,0X0A,0XE6,0X06,0XD5,0X43,0XE5,0XE5,0XF6,0X66,

37160XFE,0X87,0XF6,0X67,0XFE,0X88,0XFE,0XA9,0XFE,0X89,0XFE,0XAA,0XFE,0XAA,0XFE,0XA9,

37170XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA8,0XFE,0X88,0XFE,0XA8,0XFE,0XA8,

37180XFE,0X67,0XF6,0X48,0XDD,0X87,0XAC,0X01,0X83,0X60,0XD6,0X28,0XFF,0XAE,0XFF,0XCE,

37190XFF,0XEE,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XED,

37200XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,

37210XFF,0XED,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCE,0XFF,0XAD,0XFF,0XCF,0XCE,0X4B,

37220XCE,0X4F,0XF7,0X77,0XFF,0XFC,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,

37320XFF,0XF9,0XFF,0XF5,0XFF,0XD1,0XFF,0XCF,0XFF,0XCD,0XFF,0XED,0XFF,0XED,0XFF,0XEE,

37330XFF,0XCF,0XFF,0XCF,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XED,0XFF,0XCD,

37340XFF,0X8C,0XE6,0X68,0XD5,0XA5,0XCD,0X43,0XEE,0X06,0XF6,0X46,0XF6,0X67,0XFE,0X67,

37350XFE,0X88,0XF6,0X69,0XFE,0X8A,0XFE,0X8A,0XFE,0X8A,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

37360XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X68,

37370XEE,0X08,0XCD,0X24,0X93,0XA0,0XBD,0X65,0XFF,0X4C,0XFF,0XCD,0XFF,0XED,0XFF,0XED,

37380XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

37390XFF,0XCD,0XFF,0XCD,0XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XCC,

37400XFF,0XCD,0XFF,0XCD,0XFF,0XAD,0XFF,0XCE,0XFF,0XAE,0XE6,0XED,0XC5,0XCC,0XDE,0XB2,

37410XFF,0XBA,0XFF,0XFD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFA,0XFF,0XD5,0XFF,0XB2,

37510XFF,0XCF,0XFF,0XCE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCD,0XFF,0XCE,0XFF,0XCE,

37520XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCD,0XF7,0X0A,0XD5,0XA5,

37530XC5,0X03,0XCD,0X44,0XE5,0XC5,0XEE,0X06,0XF6,0X47,0XFE,0X88,0XFE,0X89,0XFE,0X69,

37540XFE,0X6A,0XFE,0X6A,0XFE,0X89,0XFE,0X89,0XFE,0XA9,0XFE,0XA8,0XFE,0XA8,0XFE,0XA8,

37550XFE,0X89,0XFE,0XCA,0XFE,0X89,0XFE,0X88,0XFE,0XA9,0XFE,0X88,0XF6,0X68,0XE5,0XE7,

37560XB4,0XA3,0XAC,0XC3,0XEE,0XEB,0XFF,0XAD,0XFF,0XCD,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,

37570XFF,0XEC,0XFF,0XED,0XFF,0XCC,0XFF,0XCC,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

37580XFF,0XCD,0XFF,0XCD,0XFF,0XCC,0XFF,0XEC,0XFF,0XEC,0XFF,0XCC,0XFF,0XCD,0XFF,0XCD,

37590XFF,0XAD,0XFF,0XAE,0XFF,0XCE,0XEF,0X0D,0XBD,0XAA,0XBD,0XAD,0XF7,0X57,0XFF,0XFC,

37600XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37690XFF,0XFF,0XFF,0XFD,0XFF,0XFB,0XFF,0XD7,0XFF,0XB2,0XF7,0XAF,0XFF,0XCE,0XFF,0XCD,

37700XFF,0XCC,0XFF,0XCC,0XFF,0XEC,0XFF,0XCD,0XFF,0XCE,0XFF,0XCE,0XFF,0XCE,0XFF,0XED,

37710XFF,0XCD,0XFF,0XED,0XFF,0XED,0XFF,0X8C,0XDE,0X28,0XB4,0XA3,0XAC,0X61,0XC5,0X03,

37720XD5,0X64,0XE5,0XE6,0XEE,0X47,0XF6,0X68,0XFE,0X68,0XFE,0X69,0XFE,0X69,0XFE,0X69,

37730XFE,0X89,0XFE,0X89,0XFE,0XA9,0XFE,0XA8,0XFE,0XA8,0XFE,0XA9,0XFE,0X88,0XFE,0XA9,

37740XFE,0XAA,0XFE,0XAA,0XFE,0X89,0XFE,0X89,0XFE,0XAA,0XF6,0X69,0XD5,0XC7,0XAC,0XA3,

37750XE6,0XAA,0XFF,0XAD,0XFF,0XCD,0XF7,0XCC,0XFF,0XED,0XFF,0XEC,0XFF,0XED,0XFF,0XCC,

37760XFF,0XCC,0XFF,0XCC,0XFF,0XAC,0XFF,0XCC,0XFF,0XAD,0XFF,0XCD,0XFF,0XAD,0XFF,0XAD,

37770XFF,0XAC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XAC,0XFF,0XAD,0XFF,0XAD,0XFF,0X8D,

37780XFF,0XCE,0XEF,0X0C,0XB5,0X68,0XAD,0X09,0XE6,0X93,0XFF,0XDB,0XFF,0XDD,0XFF,0XFF,

37790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFB,

37880XFF,0XF7,0XF7,0XB3,0XF7,0X90,0XF7,0XAE,0XFF,0XAD,0XFF,0XCD,0XFF,0XCC,0XFF,0XCC,

37890XFF,0XCC,0XFF,0XCC,0XFF,0XCD,0XFF,0XCD,0XFF,0XCE,0XFF,0XCE,0XFF,0XCD,0XFF,0XCD,

37900XFF,0XAD,0XFF,0X2C,0XC5,0X25,0X9B,0XE0,0X9B,0XC0,0XAC,0X42,0XBC,0XA3,0XD5,0X85,

37910XE5,0XE7,0XF6,0X27,0XFE,0X27,0XFE,0X48,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0XA9,

37920XFE,0XA9,0XFE,0X89,0XFE,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0X89,0XFE,0X89,0XFE,0X8A,

37930XF6,0X8B,0XFE,0X8C,0XFE,0X8C,0XF6,0X6B,0XE6,0X2A,0XC5,0X46,0XD6,0X08,0XFF,0XAE,

37940XF7,0X6C,0XFF,0XED,0XF7,0XCC,0XF7,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,

37950XFF,0XAC,0XFF,0XAC,0XFF,0XCC,0XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAC,

37960XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0X8C,0XFF,0XAC,0XFF,0X8C,0XFF,0X8D,

37970XAD,0X05,0XAD,0X08,0XC5,0X8E,0XFF,0X79,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

37990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFC,0XFF,0XF9,0XFF,0XD4,0XF7,0X90,

38070XF7,0X8E,0XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAC,0XFF,0XCC,0XFF,0XCB,0XFF,0XCB,

38080XFF,0XCC,0XFF,0XCD,0XFF,0XAE,0XFF,0XAE,0XFF,0XAE,0XFF,0XAE,0XFF,0X8D,0XF6,0XEB,

38090XB4,0X83,0X8B,0X40,0X8B,0X40,0X93,0X60,0X9B,0XE1,0XB4,0XA3,0XCD,0X66,0XE5,0XE7,

38100XF6,0X28,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0XA9,0XFE,0X89,0XFE,0X89,

38110XFE,0X69,0XFE,0X8A,0XFE,0X69,0XFE,0X69,0XFE,0XAB,0XFE,0XAD,0XF6,0XAE,0XEE,0X6E,

38120XEE,0X4D,0XF6,0X6E,0XEE,0X6E,0XD5,0XEA,0XD6,0X09,0XFF,0X8D,0XF7,0X8C,0XFF,0XCD,

38130XFF,0XCD,0XFF,0XCC,0XFF,0XCD,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAB,0XFF,0XAC,

38140XFF,0XAC,0XFF,0XAD,0XFF,0X8D,0XFF,0XAD,0XFF,0XAD,0XFF,0X8C,0XFF,0X8C,0XFF,0XAC,

38150XFF,0XAC,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8D,0XBD,0X46,0XA4,0X86,

38160XAC,0XEA,0XE6,0XB4,0XFF,0XFC,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

38250XFF,0XFD,0XFF,0XFC,0XFF,0XFA,0XFF,0XB6,0XF7,0X70,0XFF,0X8E,0XFF,0X8D,0XFF,0X8C,

38260XFF,0X8C,0XFF,0XAC,0XFF,0XAC,0XFF,0XCB,0XFF,0XCA,0XFF,0XCB,0XFF,0XAC,0XFF,0XAC,

38270XFF,0X8D,0XFF,0XAE,0XFF,0XAE,0XFF,0X8E,0XFF,0X6E,0XEE,0X6B,0XAC,0X03,0X8B,0X00,

38280X8B,0X00,0X7A,0XC0,0X7B,0X00,0X93,0XC2,0XAC,0X84,0XC5,0X46,0XE5,0XC8,0XF6,0X48,

38290XF6,0X67,0XFE,0X88,0XFE,0X88,0XF6,0X68,0XFE,0X89,0XFE,0X69,0XFE,0X8A,0XFE,0X6A,

38300XFE,0X8B,0XF6,0X8C,0XF6,0X8D,0XEE,0X8F,0XF6,0XB1,0XFE,0XF3,0XFF,0X34,0XFF,0X34,

38310XFF,0X75,0XEE,0XF1,0XD6,0X2B,0XFF,0X4D,0XFF,0X6C,0XFF,0X8C,0XFF,0X8C,0XFF,0XAD,

38320XFF,0XAC,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0XAC,0XFF,0X8C,

38330XFF,0X8D,0XFF,0X8C,0XFF,0X6C,0XFF,0X6C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,

38340XFF,0X6C,0XFF,0X8C,0XFF,0X6C,0XFF,0X2C,0XC5,0X67,0X9C,0X45,0X94,0X26,0XC5,0XAF,

38350XF7,0X99,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

38360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XFA,

38440XFF,0XD7,0XFF,0X93,0XFF,0X4F,0XFF,0X6D,0XFF,0X4C,0XFF,0X6C,0XFF,0X8C,0XFF,0X8C,

38450XFF,0XAB,0XFF,0XAB,0XFF,0XAB,0XFF,0XAB,0XFF,0XAC,0XFF,0X8D,0XFF,0X8C,0XFF,0X8D,

38460XFF,0X8D,0XFF,0X8E,0XFF,0X6E,0XEE,0X4A,0XAB,0XE2,0X8B,0X00,0X8A,0XE0,0X72,0X80,

38470X6A,0X80,0X72,0XE1,0X83,0X82,0XA4,0X44,0XC5,0X27,0XDD,0XC8,0XEE,0X28,0XF6,0X47,

38480XF6,0X48,0XFE,0X68,0XFE,0X69,0XFE,0X89,0XFE,0X8A,0XFE,0X8B,0XEE,0X4C,0XEE,0X8E,

38490XF6,0XD1,0XF7,0X14,0XFF,0X56,0XFF,0X98,0XFF,0XB9,0XFF,0XDA,0XFF,0XD9,0XEF,0X34,

38500XD6,0X4C,0XF7,0X4D,0XFF,0X6C,0XFF,0X8C,0XFF,0X6C,0XFF,0X6C,0XFF,0X8C,0XFF,0X8C,

38510XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X6C,

38520XFF,0X4C,0XFF,0X4C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X4C,

38530XFF,0X2C,0XFF,0X0C,0XC5,0X47,0X9C,0X24,0X94,0X05,0XA4,0XAB,0XEF,0X17,0XFF,0XFC,

38540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XB8,0XFF,0X94,0XFF,0X50,

38630XF7,0X2E,0XFF,0X4D,0XFF,0X4C,0XFF,0X6C,0XFF,0X6B,0XFF,0X8B,0XFF,0X8B,0XFF,0X8B,

38640XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X6C,0XFF,0X8C,

38650XFF,0X6C,0XE6,0X49,0XAC,0X22,0X93,0X60,0X8B,0X00,0X72,0XA0,0X62,0X40,0X5A,0X40,

38660X6A,0XA1,0X83,0X42,0XA4,0X25,0XC5,0X28,0XE5,0XC8,0XF6,0X28,0XF6,0X48,0XFE,0X88,

38670XFE,0X68,0XFE,0X89,0XF6,0X6A,0XEE,0X6C,0XE6,0X6E,0XF6,0XF3,0XFF,0X77,0XFF,0XDA,

38680XFF,0XFB,0XFF,0XFC,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,0XF7,0X76,0XDE,0X6E,0XEE,0XED,

38690XFF,0X4D,0XFF,0X6C,0XFF,0X4C,0XFF,0X4C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,

38700XFF,0X6B,0XFF,0X6B,0XFF,0X6B,0XFF,0X6C,0XFF,0X6C,0XFF,0X4C,0XFF,0X4B,0XFF,0X4B,

38710XFF,0X4C,0XFF,0X4B,0XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X2C,0XFF,0X2C,0XFF,0X0D,

38720XBD,0X06,0X93,0XC3,0X93,0XE5,0X8B,0XE7,0XCE,0X12,0XFF,0XDB,0XFF,0XFE,0XFF,0XFF,

38730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38810XFF,0XDF,0XFF,0XDE,0XFF,0XDB,0XFF,0X96,0XFF,0X51,0XF7,0X2E,0XFF,0X2D,0XFF,0X4D,

38820XFF,0X2C,0XFF,0X4C,0XFF,0X6B,0XFF,0X6B,0XFF,0X6B,0XFF,0X8C,0XFF,0X6C,0XFF,0X6D,

38830XFF,0X6D,0XFF,0X6C,0XFF,0X8C,0XFF,0X6B,0XFF,0X8B,0XFF,0X6B,0XFF,0X6C,0XE6,0X68,

38840XB4,0XA2,0XA3,0XC1,0X8B,0X20,0X7A,0XC0,0X62,0X60,0X52,0X00,0X52,0X00,0X62,0X61,

38850X7B,0X23,0XA4,0X26,0XC4,0XE7,0XDD,0XA8,0XE6,0X07,0XF6,0X47,0XF6,0X88,0XF6,0XA9,

38860XEE,0X8B,0XEE,0XAF,0XFF,0X34,0XFF,0X78,0XFF,0XDB,0XFF,0XFD,0XFF,0XFD,0XF7,0XFE,

38870XF7,0XFE,0XFF,0XFE,0XFF,0XFC,0XFF,0X97,0XDE,0X6F,0XE6,0XAD,0XFF,0X2D,0XFF,0X4C,

38880XFF,0X4C,0XFF,0X4B,0XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4B,0XFF,0X6B,0XFF,0X6B,

38890XFF,0X6B,0XFF,0X4B,0XFF,0X4C,0XFF,0X4B,0XFF,0X2B,0XFF,0X4B,0XFF,0X2B,0XFF,0X2B,

38900XFF,0X2B,0XFF,0X4B,0XFF,0X4B,0XFF,0X2C,0XFF,0X2C,0XFF,0X0D,0XB4,0XA5,0X83,0X41,

38910X8B,0XC5,0X8B,0XC7,0X9C,0XAC,0XEF,0X38,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

38920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

38990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDD,

39000XFF,0XB9,0XFF,0X54,0XF7,0X2F,0XF7,0X0C,0XFF,0X2C,0XFF,0X2D,0XFF,0X2C,0XFF,0X4C,

39010XFF,0X4B,0XFF,0X6B,0XFF,0X6C,0XFF,0X6C,0XFF,0X4D,0XFF,0X4D,0XFF,0X4D,0XFF,0X4C,

39020XFF,0X4B,0XFF,0X6B,0XFF,0X6B,0XFF,0X6B,0XFF,0X4B,0XEE,0XA9,0XC5,0X03,0XA3,0XE1,

39030X8B,0X40,0X83,0X00,0X6A,0XA1,0X5A,0X20,0X49,0XC0,0X49,0XC0,0X62,0X41,0X83,0X24,

39040XA4,0X27,0XC5,0X08,0XD5,0XA8,0XDE,0X08,0XEE,0X89,0XE6,0X69,0XE6,0X6D,0XEE,0XD2,

39050XFF,0XB9,0XFF,0XDC,0XFF,0XFD,0XFF,0XFE,0XF7,0XFE,0XF7,0XFF,0XF7,0XFF,0XFF,0XFF,

39060XFF,0XFD,0XFF,0XB9,0XDE,0X70,0XE6,0X8D,0XFF,0X2D,0XFF,0X2C,0XFF,0X2C,0XFF,0X2B,

39070XFF,0X4C,0XFF,0X4C,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,

39080XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,

39090XFF,0X0B,0XFF,0X0B,0XFF,0X0C,0XF6,0XCD,0XA4,0X44,0X72,0XC0,0X8B,0XA5,0X8B,0XE7,

39100X83,0XC8,0XBD,0XB1,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDC,0XFF,0X77,0XF7,0X32,

39190XF7,0X0D,0XF7,0X0B,0XFF,0X0C,0XFF,0X0C,0XFF,0X0C,0XFF,0X2B,0XFF,0X2A,0XFF,0X4A,

39200XFF,0X4B,0XFF,0X4C,0XFF,0X2C,0XFF,0X2C,0XFF,0X2C,0XFF,0X2C,0XFF,0X2B,0XFF,0X6B,

39210XFF,0X4B,0XFF,0X4B,0XF7,0X2A,0XFF,0X0B,0XCD,0X65,0X9B,0XE0,0X93,0XA1,0X8B,0X61,

39220X7B,0X02,0X62,0X81,0X52,0X00,0X49,0XA0,0X49,0XC0,0X62,0X42,0X7A,0XE4,0X9B,0XE6,

39230XBD,0X07,0XCD,0XA8,0XDE,0X4A,0XDE,0X4B,0XEE,0XF1,0XFF,0XB8,0XFF,0XDB,0XFF,0XDE,

39240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XBA,

39250XDE,0X70,0XE6,0X8D,0XFF,0X2D,0XFF,0X0C,0XFF,0X2C,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,

39260XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,

39270XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFE,0XEB,0XFE,0XEB,

39280XFE,0XEC,0XF6,0XAC,0X9B,0XE4,0X6A,0XA0,0X83,0X64,0X8B,0XC7,0X83,0XC7,0X94,0X4B,

39290XFF,0X9A,0XFF,0XFD,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XF7,0XDF,0XFF,0XFF,0XFF,0XFF,

39300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39370XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XBB,0XF7,0X14,0XF6,0XF0,0XF7,0X0D,0XF6,0XEB,

39380XFF,0X0C,0XFE,0XEC,0XFF,0X0B,0XFF,0X0B,0XFF,0X2A,0XFF,0X2A,0XFF,0X2B,0XFF,0X2C,

39390XFF,0X2C,0XFF,0X2C,0XFF,0X2C,0XFF,0X2C,0XFF,0X0B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,

39400XF7,0X0B,0XFF,0X4D,0XDD,0XE7,0XA4,0X01,0X93,0XC0,0X8B,0X81,0X83,0X62,0X73,0X02,

39410X5A,0X61,0X52,0X00,0X49,0XC0,0X49,0XC1,0X5A,0X22,0X73,0X04,0X94,0X26,0XAC,0XE8,

39420XC5,0X8A,0XD6,0X6F,0XF7,0X56,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

39430XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XB9,0XD6,0X50,0XE6,0X8D,

39440XFF,0X0D,0XFE,0XEB,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,

39450XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0A,0XFF,0X0A,

39460XFE,0XEB,0XFE,0XEA,0XFE,0XEA,0XFF,0X0B,0XFE,0XEA,0XFE,0XEB,0XFE,0XEC,0XEE,0X6C,

39470X8B,0X62,0X6A,0X60,0X7B,0X24,0X7B,0X65,0X83,0XC7,0X83,0XC8,0XD6,0X34,0XFF,0XDC,

39480XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XF7,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,

39560XFF,0XDD,0XFF,0X99,0XF6,0XF2,0XF6,0XCE,0XFF,0X0C,0XFE,0XEB,0XFF,0X0C,0XFE,0XEC,

39570XFE,0XEB,0XFF,0X0B,0XFF,0X0A,0XFF,0X2A,0XFF,0X0B,0XFF,0X2C,0XFF,0X2B,0XFF,0X2B,

39580XFF,0X2B,0XFF,0X0B,0XFF,0X2B,0XFF,0X0B,0XFF,0X2C,0XF7,0X0B,0XFF,0X4C,0XFF,0X6D,

39590XE6,0X69,0XA4,0X42,0X93,0XC0,0X93,0XA1,0X8B,0XA2,0X83,0X63,0X72,0XE2,0X62,0X82,

39600X52,0X01,0X49,0XC1,0X49,0XA0,0X5A,0X21,0X73,0X03,0X8B,0XE7,0XAC,0XEB,0XE6,0XB4,

39610XFF,0XDB,0XFF,0X9D,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

39620XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBA,0XD6,0X4F,0XEE,0X8D,0XFF,0X0D,0XFE,0XEB,

39630XFE,0XEB,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,

39640XFE,0XEB,0XFE,0XEB,0XFE,0XEB,0XFE,0XEB,0XFF,0X0A,0XFF,0X0A,0XFE,0XEA,0XFE,0XCA,

39650XFE,0XEA,0XFE,0XEA,0XFE,0XCA,0XFE,0XCB,0XFF,0X0D,0XE6,0X2B,0X72,0XC0,0X5A,0X20,

39660X72,0XE3,0X73,0X04,0X7B,0X65,0X8B,0XE8,0XA4,0XCD,0XFF,0XBA,0XFF,0XFD,0XFF,0XFE,

39670XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XFF,0X57,

39750XEE,0XB0,0XF6,0XCD,0XFE,0XEB,0XFE,0XEB,0XFE,0XEB,0XFE,0XEB,0XFE,0XEB,0XFE,0XEA,

39760XFF,0X0A,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0A,0XFF,0X0B,0XFF,0X0B,

39770XFF,0X0A,0XFF,0X0A,0XFF,0X2B,0XFF,0X2B,0XF7,0X2B,0XFF,0X4D,0XF6,0XEC,0XB4,0XC4,

39780X8B,0X80,0X93,0XA1,0X93,0XA2,0X8B,0XA3,0X83,0X84,0X7B,0X24,0X62,0X83,0X5A,0X22,

39790X49,0XA0,0X49,0XA0,0X5A,0X21,0X6A,0XC4,0XAC,0XCD,0XFF,0X59,0XFF,0XBD,0XFF,0XDF,

39800XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

39810XFF,0XFE,0XF7,0X79,0XDE,0X50,0XEE,0XAD,0XFF,0X0C,0XFE,0XCA,0XFE,0XEA,0XFE,0XEA,

39820XFE,0XEA,0XFF,0X0B,0XFF,0X0B,0XFE,0XEB,0XFE,0XEA,0XFE,0XEA,0XFE,0XCA,0XFE,0XCA,

39830XFE,0XCA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XC9,0XFE,0XEA,0XFE,0XCA,0XFE,0XEA,

39840XFE,0XCA,0XFE,0XCB,0XFE,0XED,0XCD,0X89,0X62,0X60,0X5A,0X20,0X6A,0XC3,0X72,0XE4,

39850X83,0X85,0X83,0X86,0X83,0XC9,0XEF,0X38,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

39860XF7,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

39930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBB,0XF6,0XF4,0XEE,0XAE,0XF6,0XCB,

39940XFE,0XEA,0XFE,0XEA,0XFE,0XEB,0XFE,0XEB,0XFE,0XEA,0XFE,0XEA,0XFF,0X0A,0XFF,0X0A,

39950XFE,0XEB,0XFF,0X0B,0XFF,0X0A,0XFF,0X0A,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

39960XFF,0X0A,0XF7,0X0A,0XF7,0X0B,0XFF,0X2C,0XFF,0X2C,0XCD,0X87,0X93,0XA0,0X8B,0X80,

39970X93,0XC2,0X9B,0XE4,0X93,0XE5,0X8B,0X85,0X7B,0X25,0X62,0X83,0X5A,0X01,0X51,0XC1,

39980X49,0XA0,0X5A,0X44,0XC5,0X93,0XFF,0XBC,0XFF,0XBE,0XFF,0XBF,0XFF,0XDF,0XFF,0XFF,

39990XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XF7,0X79,

40000XDE,0X50,0XEE,0X8D,0XFE,0XCC,0XFE,0XAA,0XFE,0XCA,0XFE,0XC9,0XFE,0XEA,0XFE,0XEA,

40010XFE,0XEA,0XFE,0XEA,0XFE,0XCA,0XFE,0XC9,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XC9,

40020XFE,0XC9,0XFE,0XE9,0XFE,0XC9,0XFE,0XEA,0XFE,0XC9,0XFE,0XCA,0XFE,0XCA,0XFE,0XAA,

40030XF6,0XAC,0XB4,0XE7,0X62,0X20,0X52,0X00,0X62,0X83,0X62,0X83,0X7B,0X24,0X7B,0X65,

40040X7B,0X87,0XD6,0X75,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XFF,0XFF,

40050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40120XFF,0XFF,0XFF,0XFE,0XFF,0X99,0XE6,0X91,0XEE,0X8C,0XF6,0XAA,0XF6,0XC9,0XFE,0XE9,

40130XFE,0XEA,0XFE,0XCA,0XFE,0XCA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEB,0XFE,0XEB,

40140XFE,0XEB,0XFE,0XEA,0XFE,0XEB,0XFE,0XEA,0XFE,0XEA,0XFE,0XCA,0XFF,0X0A,0XF6,0XEA,

40150XF7,0X0A,0XF6,0XEA,0XFF,0X6D,0XEE,0X8B,0XA4,0X02,0X8B,0X60,0X93,0XA2,0X9C,0X04,

40160X9C,0X05,0X9C,0X26,0X8B,0XA5,0X83,0X44,0X6A,0X82,0X5A,0X22,0X49,0XA1,0X62,0XA7,

40170XE6,0X98,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XF7,0X79,0XDE,0X4F,0XEE,0XAD,

40190XFE,0XCB,0XFE,0XA9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

40200XFE,0XC9,0XFE,0XC9,0XFE,0XA9,0XFE,0XA9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC8,

40210XFE,0XA9,0XFE,0XC9,0XFE,0XA9,0XFE,0XA9,0XFE,0XCA,0XF6,0X8A,0XEE,0X8C,0XA4,0X25,

40220X62,0X81,0X52,0X01,0X5A,0X42,0X62,0X83,0X6A,0XE4,0X73,0X45,0X73,0X46,0XB5,0X71,

40230XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFD,

40310XFF,0X78,0XE6,0X70,0XEE,0X8B,0XF6,0XA9,0XF6,0XC8,0XFE,0XC8,0XFE,0XCA,0XFE,0XCA,

40320XFE,0XCA,0XFE,0XCA,0XFE,0XEA,0XFE,0XEA,0XFE,0XCB,0XFE,0XEB,0XFE,0XCB,0XFE,0XEA,

40330XFE,0XEA,0XFE,0XEA,0XFE,0XEB,0XFE,0XEA,0XFE,0XEA,0XFF,0X0A,0XF6,0XE9,0XF6,0XEA,

40340XFF,0X4C,0XFF,0X2D,0XBC,0XE5,0X8B,0X60,0X93,0XA2,0XA4,0X04,0XA4,0X24,0XA4,0X46,

40350XA4,0X45,0X93,0XC5,0X83,0X45,0X6A,0X84,0X5A,0X24,0X8B,0XEC,0XFF,0X7C,0XFF,0XDE,

40360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40370XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XF7,0X58,0XDE,0X2F,0XEE,0XAD,0XFE,0XAB,0XFE,0XA9,

40380XFE,0XA9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC8,

40390XFE,0XA8,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XC8,0XFE,0XA8,0XFE,0XA8,0XFE,0X88,

40400XFE,0X88,0XFE,0X89,0XFE,0XA9,0XF6,0X8A,0XE6,0X0A,0X9C,0X05,0X72,0XC3,0X51,0XE0,

40410X52,0X01,0X5A,0X63,0X6A,0XC3,0X73,0X25,0X73,0X26,0X9C,0XAE,0XFF,0XDD,0XFF,0XDE,

40420XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFC,0XF7,0X36,0XE6,0X4E,

40500XF6,0X8B,0XF6,0XA8,0XF6,0XC8,0XFE,0XA8,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XCA,

40510XFE,0XC9,0XFE,0XC9,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,

40520XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFF,0X0A,0XF6,0XC9,0XF6,0XC9,0XFE,0XEB,0XFF,0X4E,

40530XEE,0X6B,0X8B,0X60,0X93,0XA1,0X9B,0XC2,0XAC,0X64,0XBC,0XE6,0XAC,0X85,0X9C,0X25,

40540X93,0XE6,0X7B,0X25,0X62,0XC5,0XA4,0XCF,0XFF,0XFD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

40550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

40560XFF,0XFD,0XF7,0X58,0XD6,0X2E,0XEE,0XAC,0XF6,0XAA,0XFE,0XA9,0XFE,0XA8,0XFE,0XA8,

40570XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA8,0XFE,0XA8,0XFE,0XA8,0XFE,0XA8,

40580XFE,0X88,0XFE,0X88,0XFE,0XA8,0XFE,0XA8,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0X89,

40590XF6,0X48,0XFE,0XAB,0XBC,0XE6,0XB4,0XC8,0X52,0X00,0X51,0XE1,0X49,0XC0,0X52,0X43,

40600X5A,0X63,0X6A,0XE4,0X6B,0X06,0X94,0X4C,0XFF,0X9C,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

40610XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40680XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFC,0XE6,0X93,0XDE,0X0D,0XF6,0XAA,0XFE,0XA8,

40690XFE,0XA8,0XFE,0XA8,0XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XA9,0XFE,0XC9,0XFE,0XC9,

40700XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XCA,

40710XFE,0XA9,0XFE,0XEA,0XF6,0XA9,0XFE,0XC9,0XF6,0XCA,0XFF,0X2D,0XFE,0XED,0XCD,0X67,

40720X8B,0X80,0XA4,0X02,0XAC,0X63,0XAC,0X43,0XBC,0XC5,0XB4,0XC6,0X9C,0X45,0X8B,0XE6,

40730X7B,0X46,0XAD,0X30,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XEF,0X37,

40750XDE,0X2E,0XEE,0X8C,0XFE,0XAA,0XFE,0XA8,0XFE,0XA8,0XFE,0XA8,0XFE,0XA9,0XF6,0XA9,

40760XF6,0XA9,0XF6,0XA9,0XFE,0XA9,0XFE,0XA8,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0X88,

40770XF6,0X87,0XF6,0X87,0XFE,0XA8,0XF6,0X88,0XFE,0X89,0XFE,0X68,0XFE,0X89,0XE5,0XE8,

40780XCD,0X69,0XA4,0X47,0X51,0XC0,0X49,0XA1,0X49,0XC1,0X52,0X02,0X52,0X42,0X62,0XA4,

40790X62,0XE6,0X84,0X0B,0XF7,0X7B,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,

40800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

40870XFF,0XFE,0XFF,0XDB,0XD6,0X10,0XDE,0X0C,0XF6,0X8A,0XF6,0X88,0XF6,0X88,0XF6,0X88,

40880XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

40890XFE,0XAA,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0X89,0XFE,0XAA,0XFE,0XA9,0XFE,0XC9,

40900XF6,0X88,0XFE,0XCA,0XF6,0X89,0XFE,0XEB,0XFF,0X4E,0XFF,0X0D,0XA4,0X21,0X9C,0X01,

40910XAC,0X42,0XB4,0XA4,0XBC,0XC5,0XB4,0XC6,0XAC,0X85,0XA4,0X66,0X94,0X07,0XBD,0X8F,

40920XFF,0XDB,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

40930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XEF,0X36,0XDE,0X4D,0XEE,0X8B,

40940XFE,0X89,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XF6,0X89,0XF6,0X89,0XF6,0X89,

40950XFE,0X89,0XFE,0X88,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X88,0XF6,0X87,0XF6,0X87,

40960XFE,0X88,0XF6,0X68,0XFE,0X68,0XF6,0X48,0XFE,0X69,0XD5,0X87,0XDE,0X0B,0X83,0X63,

40970X49,0XC0,0X49,0XC2,0X41,0XC1,0X4A,0X02,0X52,0X02,0X5A,0X64,0X62,0XC5,0X7B,0XAA,

40980XF7,0X5B,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

40990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41050XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XBB,

41060XCD,0XAE,0XE6,0X2B,0XF6,0X89,0XF6,0X88,0XF6,0X68,0XF6,0X69,0XFE,0X89,0XFE,0X89,

41070XFE,0X89,0XF6,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,

41080XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X88,0XF6,0X68,0XFE,0XA9,

41090XEE,0X69,0XF6,0X8A,0XFF,0X2C,0XFF,0X4D,0XE6,0X29,0XAC,0X62,0X9B,0XE0,0XB4,0XA3,

41100XBC,0XC5,0XB4,0XC5,0XBD,0X05,0XAC,0XA5,0XA4,0X68,0XCD,0XD0,0XFF,0XDB,0XFF,0XFE,

41110XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41120XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XEF,0X15,0XDE,0X4D,0XEE,0X8A,0XF6,0X88,0XFE,0X67,

41130XFE,0X67,0XFE,0X68,0XF6,0X88,0XF6,0X89,0XF6,0X89,0XF6,0X89,0XF6,0X89,0XF6,0X89,

41140XFE,0X69,0XFE,0X69,0XFE,0X68,0XFE,0X68,0XF6,0X87,0XF6,0X87,0XF6,0X88,0XEE,0X47,

41150XFE,0X68,0XFE,0X69,0XE5,0XE7,0XE5,0XE8,0XD5,0XCA,0X72,0XC1,0X49,0XA0,0X49,0XC2,

41160X41,0XC2,0X49,0XE2,0X49,0XE2,0X52,0X43,0X5A,0X85,0X73,0X49,0XEF,0X5B,0XFF,0XFF,

41170XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XBD,0XFF,0XDB,0XCD,0X8D,0XE6,0X4B,

41250XEE,0X68,0XF6,0X67,0XF6,0X48,0XF6,0X49,0XFE,0X69,0XF6,0X69,0XF6,0X68,0XF6,0X88,

41260XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X89,0XF6,0X89,0XFE,0X89,0XFE,0X89,

41270XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XF6,0X89,0XF6,0X89,0XF6,0X89,

41280XF6,0XCA,0XFF,0X0C,0XFF,0X4D,0XCD,0X86,0XA4,0X20,0XAC,0X61,0XB4,0XA3,0XBC,0XE4,

41290XC5,0X25,0XB4,0XA5,0XB4,0XC9,0XCD,0XB0,0XFF,0XBB,0XFF,0XFE,0XFF,0XFF,0XFF,0XDE,

41300XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,

41310XFF,0XDB,0XE6,0XB2,0XDE,0X6C,0XEE,0X89,0XEE,0X67,0XF6,0X66,0XFE,0X67,0XFE,0X48,

41320XFE,0X69,0XF6,0X69,0XF6,0X69,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X69,0XF6,0X69,

41330XF6,0X48,0XF6,0X68,0XF6,0X67,0XEE,0X47,0XEE,0X47,0XF6,0X88,0XFE,0X69,0XEE,0X28,

41340XE5,0XE8,0XF6,0X8C,0XAC,0X86,0X62,0X60,0X52,0X01,0X49,0XE2,0X49,0XC2,0X49,0XC2,

41350X41,0XC1,0X4A,0X23,0X4A,0X24,0X73,0X8B,0XEF,0X5C,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

41360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41430XFF,0XFF,0XFF,0XFF,0XFF,0XBE,0XFF,0XBB,0XC5,0X6C,0XE6,0X4B,0XEE,0X47,0XF6,0X67,

41440XF6,0X49,0XF6,0X29,0XF6,0X69,0XF6,0X49,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X88,

41450XF6,0X88,0XF6,0X88,0XF6,0X89,0XF6,0X89,0XF6,0X69,0XFE,0X69,0XFE,0X68,0XFE,0X88,

41460XF6,0X88,0XF6,0X88,0XF6,0X89,0XF6,0X89,0XF6,0X89,0XF6,0X89,0XEE,0X48,0XF6,0XAA,

41470XFF,0X4C,0XFE,0XEB,0XCD,0X65,0XAC,0X41,0XAC,0X61,0XBC,0XE3,0XBC,0XC3,0XBC,0XE6,

41480XAC,0X88,0XCD,0X8F,0XFF,0X9B,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

41490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XB9,0XE6,0X91,

41500XDE,0X4C,0XEE,0X89,0XEE,0X66,0XF6,0X66,0XFE,0X67,0XFE,0X48,0XFE,0X49,0XF6,0X49,

41510XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X69,0XF6,0X49,0XF6,0X49,0XF6,0X48,

41520XEE,0X67,0XEE,0X67,0XEE,0X47,0XF6,0X68,0XF6,0X48,0XED,0XE8,0XF6,0X4A,0XDD,0XC9,

41530X93,0XA3,0X6A,0XA1,0X62,0X83,0X4A,0X02,0X49,0XE2,0X41,0XA1,0X41,0XC1,0X4A,0X02,

41540X41,0XE3,0X7B,0XAC,0XF7,0X9D,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

41620XFF,0XBE,0XFF,0XBA,0XBD,0X2B,0XE6,0X4B,0XEE,0X27,0XF6,0X67,0XF6,0X49,0XF6,0X29,

41630XF6,0X49,0XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

41640XF6,0X68,0XF6,0X69,0XF6,0X69,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

41650XF6,0X68,0XF6,0X68,0XF6,0X69,0XF6,0X69,0XEE,0X68,0XEE,0X69,0XF6,0XA9,0XFF,0X4C,

41660XF6,0XCA,0XC5,0X24,0XA4,0X20,0XB4,0X82,0XBC,0XE3,0XBD,0X06,0XBC,0XE8,0XC5,0X6E,

41670XFF,0X5A,0XFF,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

41680XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XFF,0X78,0XE6,0X70,0XDE,0X4B,0XEE,0X69,

41690XEE,0X66,0XF6,0X66,0XF6,0X47,0XFE,0X48,0XF6,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X68,

41700XF6,0X68,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X28,0XEE,0X47,0XF6,0X67,

41710XEE,0X67,0XEE,0X47,0XEE,0X28,0XEE,0X08,0XF6,0X6B,0XC5,0X06,0X83,0X21,0X72,0XE2,

41720X6A,0XE4,0X52,0X22,0X49,0XE2,0X41,0XE1,0X41,0XC1,0X41,0XC1,0X41,0XC3,0X83,0XCD,

41730XFF,0XBD,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XBA,

41810XBD,0X0A,0XE6,0X4B,0XE6,0X27,0XF6,0X47,0XF6,0X48,0XF6,0X29,0XF6,0X28,0XF6,0X48,

41820XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X69,

41830XF6,0X69,0XF6,0X68,0XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X48,0XF6,0X48,0XF6,0X48,

41840XF6,0X68,0XEE,0X68,0XEE,0X68,0XEE,0X48,0XE6,0X48,0XF6,0XCA,0XFF,0X4C,0XF6,0XCA,

41850XBD,0X04,0XA4,0X20,0XAC,0X82,0XB4,0XA4,0XC5,0X69,0XBD,0X2B,0XE6,0XB6,0XFF,0XDD,

41860XFF,0XDE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41870XFF,0XFE,0XFF,0XDB,0XF7,0X35,0XDE,0X6F,0XE6,0X4B,0XEE,0X69,0XEE,0X47,0XF6,0X67,

41880XF6,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

41890XF6,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X68,0XEE,0X47,0XF6,0X88,0XE6,0X07,

41900XEE,0X28,0XF6,0X6A,0XE6,0X09,0XB4,0X85,0X8B,0XA3,0X7B,0X63,0X6A,0XE4,0X5A,0X83,

41910X4A,0X02,0X4A,0X22,0X4A,0X02,0X39,0XA1,0X39,0XA3,0X8C,0X0E,0XFF,0XDE,0XFF,0XFF,

41920XFF,0XBF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

41990XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XBA,0XB5,0X0A,0XE6,0X4B,

42000XE6,0X07,0XEE,0X26,0XEE,0X28,0XEE,0X08,0XEE,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X48,

42010XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

42020XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X68,

42030XEE,0X68,0XEE,0X48,0XEE,0X89,0XE6,0X48,0XEE,0X89,0XFF,0X4C,0XF6,0XCB,0XC5,0X24,

42040XA4,0X20,0XAC,0XA3,0XA4,0X43,0XB5,0X09,0XDE,0X53,0XFF,0X9B,0XFF,0XDE,0XF7,0XBE,

42050XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XBA,

42060XF6,0XF3,0XE6,0X4E,0XE6,0X4A,0XEE,0X48,0XEE,0X47,0XF6,0X47,0XF6,0X28,0XF6,0X28,

42070XF6,0X28,0XF6,0X28,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X28,0XF6,0X28,

42080XF6,0X28,0XF6,0X28,0XF6,0X48,0XEE,0X47,0XEE,0X27,0XEE,0X27,0XF6,0X49,0XF6,0X6A,

42090XD5,0X67,0XAC,0X65,0XA4,0X46,0X8B,0XC5,0X73,0X24,0X62,0XC3,0X5A,0X62,0X4A,0X22,

42100X41,0XE1,0X41,0XE2,0X39,0XA3,0XAD,0X12,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

42110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

42180XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XDA,0XBD,0X2B,0XDE,0X0A,0XE6,0X07,0XEE,0X26,

42190XEE,0X27,0XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X48,0XEE,0X28,0XF6,0X48,0XF6,0X48,

42200XEE,0X48,0XF6,0X68,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

42210XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X68,0XEE,0X48,

42220XEE,0X68,0XE6,0X48,0XE6,0X27,0XEE,0X89,0XFF,0X4D,0XF6,0XCB,0XCD,0XA6,0XA4,0X62,

42230XA4,0X43,0XAC,0XC7,0XBD,0X4D,0XEE,0XF7,0XFF,0XDD,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,

42240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0X98,0XEE,0XD1,0XE6,0X4C,

42250XE6,0X49,0XEE,0X48,0XEE,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,

42260XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X28,0XF6,0X28,0XF6,0X08,

42270XEE,0X27,0XEE,0X47,0XE5,0XE6,0XF6,0X89,0XF6,0X89,0XE6,0X08,0XCD,0X47,0XBC,0XC6,

42280XAC,0X66,0X9C,0X06,0X83,0X64,0X73,0X04,0X6A,0XC3,0X52,0X42,0X41,0XC1,0X4A,0X03,

42290X41,0XE4,0XD6,0X57,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

42370XFF,0XDD,0XFF,0XDB,0XBD,0X2C,0XCD,0XAA,0XE6,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X28,

42380XEE,0X08,0XF6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,

42390XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XF6,0X48,0XF6,0X48,

42400XF6,0X48,0XF6,0X48,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X48,0XEE,0X28,0XEE,0X48,

42410XEE,0X69,0XE6,0X28,0XEE,0X89,0XFE,0XEB,0XFF,0X4D,0XDE,0X08,0XB4,0XE4,0X93,0XE2,

42420XAC,0XE8,0XD6,0X51,0XF7,0X9A,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42430XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XF7,0X35,0XE6,0X8F,0XE6,0X2A,0XE6,0X49,0XEE,0X27,

42440XEE,0X26,0XF6,0X27,0XF6,0X07,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X47,

42450XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X28,0XF6,0X28,0XEE,0X08,0XEE,0X07,0XEE,0X47,

42460XEE,0X27,0XFE,0XA9,0XF6,0X69,0XDD,0XA7,0XD5,0X67,0XC5,0X07,0XB4,0XA6,0XA4,0X46,

42470X8B,0XC5,0X7B,0X64,0X73,0X03,0X62,0X83,0X4A,0X22,0X41,0XC3,0X62,0XC8,0XEF,0X5B,

42480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XDB,

42560XBD,0X2D,0XC5,0X69,0XE6,0X29,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X07,0XEE,0X07,

42570XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,

42580XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X47,0XEE,0X47,

42590XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X48,0XE6,0X27,0XE6,0X48,0XEE,0X89,

42600XE6,0X28,0XE6,0X49,0XFE,0XEB,0XFF,0X0C,0XF6,0XAB,0XBD,0X06,0X9C,0X23,0XB5,0X2A,

42610XF7,0X56,0XFF,0XDB,0XFF,0XFE,0XFF,0XFF,0XF7,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,

42620XFF,0XDA,0XEE,0XF3,0XE6,0X4C,0XDE,0X09,0XE6,0X28,0XEE,0X27,0XEE,0X26,0XF6,0X26,

42630XF6,0X07,0XF6,0X08,0XF6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X47,

42640XEE,0X47,0XEE,0X28,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XFE,0XC9,0XF6,0X89,

42650XEE,0X07,0XDD,0XA7,0XD5,0X47,0XC5,0X27,0XC4,0XE7,0XAC,0X66,0X9C,0X06,0X8B,0XA5,

42660X73,0X03,0X6A,0XC3,0X52,0X43,0X39,0XA2,0X94,0X6E,0XFF,0XFE,0XFF,0XDE,0XFF,0XDE,

42670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XBD,0X4E,0XC5,0X6A,

42750XE6,0X09,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X28,

42760XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

42770XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

42780XEE,0X27,0XEE,0X27,0XEE,0X27,0XE6,0X27,0XE6,0X27,0XE6,0X28,0XE6,0X48,0XEE,0X69,

42790XE6,0X29,0XF6,0X8B,0XFF,0X2D,0XFE,0XCC,0XCD,0XC8,0XA4,0XA5,0XBD,0XAD,0XFF,0XD9,

42800XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFB,0XFF,0XB7,0XEE,0XB0,

42810XE6,0X2B,0XE6,0X08,0XEE,0X27,0XEE,0X26,0XEE,0X26,0XEE,0X26,0XEE,0X07,0XEE,0X08,

42820XEE,0X08,0XEE,0X09,0XEE,0X08,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

42830XEE,0X07,0XEE,0X07,0XF6,0X27,0XFE,0X88,0XFE,0X88,0XF6,0X68,0XEE,0X07,0XE5,0XE8,

42840XDD,0X87,0XCD,0X27,0XC5,0X27,0XBC,0XA7,0XAC,0X66,0X9B,0XE5,0X83,0X64,0X72,0XE4,

42850X5A,0X64,0X52,0X66,0XCE,0X36,0XFF,0XFE,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

42860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

42930XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XCD,0XD1,0XBD,0X2B,0XE6,0X2A,0XE5,0XE7,

42940XE5,0XE7,0XEE,0X48,0XEE,0X07,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X28,

42950XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

42960XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

42970XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X28,0XE6,0X28,0XE6,0X28,0XEE,0X49,0XE6,0X09,

42980XEE,0X29,0XFE,0XCC,0XFF,0XAE,0XEE,0XCC,0XB5,0X29,0XD6,0X71,0XFF,0XFC,0XFF,0XFE,

42990XFF,0XDE,0XFF,0XDE,0XFF,0XFD,0XFF,0XD9,0XF7,0X54,0XE6,0X8D,0XE6,0X29,0XE6,0X07,

43000XEE,0X27,0XEE,0X26,0XEE,0X25,0XEE,0X26,0XEE,0X06,0XEE,0X07,0XEE,0X08,0XEE,0X09,

43010XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XE6,0X06,0XEE,0X06,0XEE,0X07,0XEE,0X07,

43020XFE,0X68,0XFE,0X88,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XE5,0XE7,0XE5,0XA8,0XDD,0X87,

43030XD5,0X48,0XC4,0XE7,0XB4,0X86,0XA4,0X26,0X93,0XC6,0X73,0X04,0X6A,0XE6,0X6B,0X4A,

43040XFF,0XDD,0XFF,0XFE,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43120XFF,0XFF,0XFF,0XFD,0XDE,0X95,0XAC,0XCA,0XDE,0X0B,0XDD,0XE8,0XDD,0XE7,0XEE,0X68,

43130XEE,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X28,

43140XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,

43150XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X48,

43160XEE,0X48,0XEE,0X48,0XEE,0X28,0XE6,0X28,0XE6,0X08,0XEE,0X29,0XEE,0X09,0XEE,0X49,

43170XEE,0X6A,0XFF,0X4D,0XFF,0X4F,0XCE,0X2D,0XF7,0X76,0XFF,0X9A,0XFF,0XBC,0XFF,0XFD,

43180XFF,0XFB,0XFF,0XB6,0XEE,0XF0,0XDE,0X4B,0XE6,0X29,0XE6,0X07,0XEE,0X27,0XEE,0X26,

43190XEE,0X26,0XEE,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,

43200XEE,0X28,0XEE,0X27,0XEE,0X06,0XE6,0X06,0XEE,0X28,0XF6,0X69,0XFE,0XA9,0XFE,0X88,

43210XF6,0X67,0XF6,0X68,0XF6,0X48,0XEE,0X28,0XE5,0XE8,0XDD,0XA7,0XD5,0X67,0XCD,0X27,

43220XBC,0XA6,0XAC,0X46,0X9C,0X07,0X7B,0X26,0X6A,0XE7,0XD6,0X77,0XFF,0XDD,0XFF,0XDE,

43230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,

43310XF7,0X38,0XA4,0X8B,0XD5,0XCB,0XDE,0X09,0XDE,0X07,0XE6,0X27,0XE6,0X07,0XE5,0XE7,

43320XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X28,

43330XEE,0X28,0XEE,0X28,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

43340XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

43350XEE,0X48,0XEE,0X48,0XEE,0X28,0XE5,0XC7,0XF6,0X49,0XE5,0XE8,0XDD,0XE7,0XE6,0X69,

43360XEE,0XEB,0XFF,0X6F,0XEE,0XD1,0XFF,0X56,0XFF,0X99,0XFF,0XBA,0XFF,0XB7,0XF7,0X73,

43370XE6,0XAD,0XDE,0X29,0XE6,0X28,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X26,0XEE,0X26,

43380XEE,0X26,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X06,

43390XEE,0X26,0XF6,0X47,0XF6,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0X88,0XFE,0X68,0XF6,0X47,

43400XF6,0X27,0XF6,0X48,0XEE,0X08,0XE5,0XC7,0XDD,0X87,0XCD,0X47,0XC5,0X07,0XB4,0XA7,

43410XA4,0X28,0X83,0X67,0XAC,0XF0,0XF7,0X5B,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

43420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0X9B,0XB4,0XED,

43500XC5,0X4A,0XDE,0X0A,0XDD,0XE8,0XDD,0XE6,0XE6,0X08,0XE6,0X07,0XEE,0X08,0XE5,0XE7,

43510XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X28,

43520XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

43530XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

43540XEE,0X28,0XEE,0X08,0XF6,0X28,0XEE,0X28,0XEE,0X28,0XE6,0X08,0XE6,0X69,0XE6,0X6A,

43550XFF,0X0F,0XF6,0XF1,0XF6,0XD4,0XFF,0X35,0XFF,0X73,0XF6,0XEF,0XDE,0X2A,0XDE,0X28,

43560XE6,0X27,0XE6,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

43570XEE,0X07,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XE6,0X06,0XE6,0X06,0XF6,0X27,0XFE,0X88,

43580XFE,0XA9,0XF6,0X69,0XFE,0X89,0XFE,0X89,0XFE,0X68,0XF6,0X47,0XF6,0X68,0XF6,0X48,

43590XEE,0X28,0XE6,0X08,0XDD,0XC7,0XCD,0X46,0XCD,0X28,0XC5,0X09,0XA4,0X69,0X94,0X2B,

43600XE6,0XD7,0XFF,0XDD,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XCD,0XD2,0XB4,0XC9,0XDD,0XEA,

43690XDE,0X08,0XE6,0X07,0XE5,0XE7,0XE6,0X08,0XE5,0XE7,0XEE,0X07,0XEE,0X07,0XEE,0X07,

43700XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,

43710XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

43720XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XF6,0X69,

43730XEE,0X07,0XED,0XE7,0XEE,0X28,0XEE,0X48,0XDE,0X07,0XDE,0X07,0XDE,0X09,0XF6,0XAD,

43740XFF,0X11,0XFE,0XF1,0XEE,0XAE,0XEE,0X8C,0XDE,0X28,0XE6,0X27,0XE6,0X07,0XEE,0X27,

43750XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X06,0XEE,0X27,0XEE,0X07,

43760XE6,0X06,0XEE,0X06,0XEE,0X47,0XF6,0X47,0XF6,0X67,0XFE,0X88,0XF6,0X68,0XF6,0X69,

43770XFE,0X69,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X48,0XEE,0X28,

43780XE6,0X08,0XDD,0XA7,0XCD,0X68,0XBD,0X09,0XAC,0XAB,0XC5,0XB2,0XF7,0X7B,0XFF,0XFE,

43790XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43870XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XEE,0XB6,0XB4,0XC9,0XD5,0XA9,0XE6,0X09,0XE6,0X28,

43880XDD,0XC7,0XE5,0XE7,0XE5,0XE7,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,

43890XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,

43900XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X07,

43910XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XF6,0X48,0XEE,0X07,0XEE,0X07,

43920XEE,0X07,0XEE,0X27,0XE6,0X06,0XEE,0X68,0XE6,0X28,0XE6,0X08,0XEE,0X4A,0XF6,0XAC,

43930XFE,0XCC,0XEE,0X69,0XDD,0XE7,0XE6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X09,

43940XEE,0X08,0XEE,0X08,0XEE,0X27,0XE6,0X06,0XEE,0X27,0XEE,0X06,0XEE,0X06,0XEE,0X46,

43950XF6,0X67,0XF6,0X47,0XEE,0X26,0XEE,0X27,0XEE,0X27,0XFE,0X89,0XFE,0X69,0XFE,0X48,

43960XFE,0X69,0XFE,0X68,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XEE,0X28,0XE6,0X28,0XE6,0X08,

43970XCD,0X88,0XBD,0X2A,0XC5,0X8F,0XF7,0X38,0XFF,0XDC,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

43980XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

43990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44060XFF,0XBE,0XFF,0X5A,0XC5,0X4D,0XCD,0X6A,0XDD,0XE9,0XDE,0X08,0XE5,0XE7,0XE6,0X07,

44070XEE,0X08,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XEE,0X08,0XE6,0X07,0XEE,0X07,0XEE,0X07,

44080XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X28,

44090XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,

44100XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XF6,0X48,0XEE,0X27,

44110XEE,0X27,0XDD,0XE6,0XF6,0X89,0XEE,0X27,0XE6,0X08,0XDD,0XE7,0XE6,0X28,0XEE,0X28,

44120XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X08,0XEE,0X09,0XEE,0X08,0XEE,0X08,

44130XEE,0X28,0XE6,0X06,0XE5,0XE6,0XEE,0X27,0XF6,0X67,0XF6,0X67,0XF6,0X46,0XE5,0XC5,

44140XDD,0XA5,0XE5,0XC5,0XEE,0X27,0XF6,0X48,0XFE,0X69,0XFE,0X69,0XFE,0X68,0XFE,0X68,

44150XFE,0X68,0XF6,0X88,0XF6,0X68,0XEE,0X48,0XE6,0X08,0XDD,0XE9,0XCD,0XA9,0XCD,0XED,

44160XDE,0XB3,0XFF,0XDB,0XFF,0XFD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

44170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBC,

44250XDE,0X32,0XB4,0XC9,0XD5,0XCA,0XD5,0XC7,0XE6,0X07,0XE6,0X07,0XE5,0XE7,0XE5,0XE8,

44260XE5,0XE8,0XE6,0X08,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,

44270XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,

44280XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,

44290XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

44300XE5,0XE6,0XE6,0X07,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X07,0XEE,0X07,

44310XEE,0X27,0XE6,0X07,0XEE,0X28,0XE5,0XE7,0XEE,0X28,0XE6,0X08,0XEE,0X28,0XEE,0X07,

44320XEE,0X28,0XF6,0X48,0XFE,0X88,0XE5,0XC6,0XCD,0X02,0XCC,0XE2,0XCD,0X03,0XDD,0X85,

44330XEE,0X07,0XF6,0X48,0XF6,0X69,0XF6,0X88,0XFE,0XA8,0XF6,0X88,0XF6,0X68,0XF6,0X88,

44340XF6,0X48,0XEE,0X29,0XEE,0X4A,0XDE,0X0A,0XD6,0X2D,0XDE,0XB2,0XFF,0XD9,0XFF,0XFC,

44350XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBD,0XF7,0X17,0XBD,0X4D,

44440XC5,0X6A,0XD5,0XC8,0XDE,0X07,0XE6,0X27,0XE5,0XE7,0XEE,0X08,0XE5,0XC8,0XE6,0X09,

44450XE6,0X08,0XE6,0X27,0XEE,0X26,0XE6,0X06,0XE6,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,

44460XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X27,

44470XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X07,

44480XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,

44490XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,

44500XEE,0X28,0XEE,0X07,0XE5,0XE7,0XE5,0XE7,0XEE,0X28,0XE6,0X08,0XF6,0X49,0XEE,0X48,

44510XCD,0X24,0XAC,0X20,0XB4,0X40,0XBC,0X81,0XCD,0X03,0XDD,0X65,0XE5,0XC6,0XEE,0X28,

44520XFE,0X89,0XFE,0XA9,0XF6,0X88,0XFE,0XA9,0XFE,0XC9,0XF6,0X68,0XF6,0X69,0XF6,0X8A,

44530XE6,0X2B,0XD5,0XEC,0XEF,0X13,0XFF,0XD8,0XFF,0XFB,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

44540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44620XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDD,0XFF,0X9B,0XDE,0X32,0XAC,0XC9,0XDE,0X2B,

44630XD5,0XC7,0XE5,0XE6,0XE5,0XE6,0XE5,0XE7,0XEE,0X08,0XED,0XE9,0XE5,0XE8,0XE5,0XE7,

44640XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X08,

44650XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

44660XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X28,

44670XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

44680XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XE6,0X07,

44690XEE,0X27,0XEE,0X27,0XE6,0X07,0XF6,0XAA,0XDD,0XA7,0XAC,0X41,0X93,0X60,0X9B,0XC0,

44700XA3,0XE0,0XAC,0X21,0XC4,0XC2,0XCD,0X03,0XDD,0X85,0XEE,0X07,0XFE,0X68,0XFE,0X88,

44710XFE,0X88,0XFE,0X88,0XF6,0X88,0XF6,0X89,0XF6,0X69,0XE6,0X4A,0XE6,0X4D,0XE6,0X91,

44720XFF,0X98,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44810XFF,0XFF,0XFF,0XDE,0XFF,0XDC,0XF7,0X37,0XBD,0X6D,0XC5,0X8A,0XD5,0XC8,0XDE,0X07,

44820XE5,0XE6,0XE5,0XE7,0XEE,0X08,0XEE,0X09,0XE5,0XE8,0XE5,0XC8,0XE6,0X08,0XE6,0X08,

44830XE6,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

44840XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

44850XEE,0X28,0XEE,0X27,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

44860XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,

44870XEE,0X28,0XEE,0X28,0XED,0XE8,0XEE,0X08,0XEE,0X07,0XE6,0X07,0XEE,0X47,0XF6,0X88,

44880XFF,0X0B,0XD5,0XA6,0XA4,0X21,0X83,0X20,0X82,0XE0,0X8B,0X40,0X9B,0XC0,0XA3,0XE1,

44890XB4,0X41,0XC4,0XC3,0XDD,0X65,0XEE,0X07,0XF6,0X48,0XFE,0X48,0XFE,0X89,0XFE,0X69,

44900XF6,0X69,0XF6,0XAA,0XEE,0X6B,0XE6,0X4C,0XEE,0XF2,0XFF,0XB8,0XFF,0XBB,0XFF,0XDD,

44910XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

44990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45000XFF,0XFE,0XFF,0XBB,0XEF,0X16,0XB4,0XEA,0XCD,0XA9,0XE6,0X09,0XE5,0XE7,0XEE,0X07,

45010XE5,0XE7,0XED,0XE8,0XEE,0X08,0XED,0XE8,0XEE,0X08,0XE6,0X08,0XE6,0X07,0XEE,0X07,

45020XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

45030XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

45040XEE,0X28,0XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

45050XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X08,

45060XF6,0X09,0XED,0XE8,0XE5,0XE7,0XEE,0X48,0XEE,0X47,0XE6,0X26,0XFF,0X2B,0XF6,0XEB,

45070XD5,0XA7,0X9B,0XE1,0X83,0X00,0X83,0X00,0X8B,0X40,0X9B,0XC1,0XA3,0XE1,0XBC,0XA3,

45080XD5,0X44,0XED,0XE6,0XFE,0X68,0XFE,0X68,0XFE,0X48,0XFE,0X8A,0XFE,0X8B,0XEE,0X6C,

45090XEE,0X8F,0XF7,0X33,0XFF,0X97,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,

45100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,

45190XFF,0XDA,0XDE,0X72,0XB4,0XE9,0XD5,0XAA,0XDD,0XC8,0XEE,0X08,0XE5,0XE7,0XED,0XE7,

45200XED,0XE7,0XE5,0XE8,0XE5,0XE8,0XE6,0X08,0XE5,0XE8,0XE6,0X08,0XEE,0X07,0XEE,0X07,

45210XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

45220XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X07,

45230XEE,0X27,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

45240XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XED,0XE8,

45250XEE,0X08,0XE6,0X07,0XE6,0X27,0XE6,0X27,0XDE,0X06,0XEE,0X8A,0XFF,0X4D,0XE6,0X6B,

45260XB4,0XC5,0X8B,0X60,0X83,0X20,0X7A,0XE0,0X9B,0XC1,0XAC,0X42,0XCD,0X03,0XE5,0XE6,

45270XFE,0X69,0XFE,0X69,0XFE,0X6A,0XF6,0X6B,0XEE,0X6C,0XEE,0X6F,0XF7,0X14,0XFF,0XD9,

45280XFF,0XBB,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XDE,0XFF,0XFE,0XFF,0XBB,0XFF,0XDA,

45380XCD,0XAF,0XC5,0X4B,0XD5,0X89,0XDD,0XC8,0XE6,0X07,0XE5,0XE6,0XE5,0XE6,0XE5,0XE6,

45390XE6,0X07,0XEE,0X08,0XE5,0XE8,0XE5,0XE8,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,

45400XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

45410XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X27,0XEE,0X28,

45420XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

45430XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XED,0XE7,0XEE,0X08,0XEE,0X07,0XEE,0X27,

45440XE5,0XE6,0XDE,0X07,0XE6,0X48,0XE6,0X48,0XE6,0X6A,0XFF,0X0D,0XFF,0X4E,0XCD,0X88,

45450X83,0X20,0X8B,0X40,0X83,0X40,0X9B,0XC0,0XBC,0XA3,0XDD,0XC6,0XF6,0X69,0XF6,0X8A,

45460XFE,0X8C,0XF6,0X6D,0XEE,0X90,0XFF,0X35,0XFF,0XBA,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,

45470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0X7B,0XFF,0XBA,0XC5,0X8E,

45570XCD,0X8C,0XD5,0XA9,0XDD,0XE8,0XE6,0X06,0XE6,0X26,0XE6,0X06,0XEE,0X07,0XE6,0X07,

45580XE5,0XE8,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

45590XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

45600XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X27,

45610XEE,0X27,0XEE,0X07,0XEE,0X28,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X28,

45620XEE,0X28,0XEE,0X27,0XEE,0X07,0XED,0XE7,0XEE,0X07,0XE6,0X07,0XEE,0X48,0XE6,0X27,

45630XE6,0X48,0XE6,0X28,0XDE,0X07,0XDE,0X29,0XF6,0XAB,0XFF,0X2D,0XF6,0XCD,0X83,0X40,

45640X83,0X20,0X83,0X40,0XAC,0X83,0XD5,0XA7,0XF6,0X8A,0XF6,0XAB,0XEE,0X6D,0XF6,0XD0,

45650XFF,0X56,0XFF,0XFB,0XFF,0XFD,0XFF,0XDE,0XFF,0XFF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,

45660XFF,0XDE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFD,0XFF,0X9A,0XD6,0X11,0XBD,0X2A,

45760XD5,0XC9,0XDE,0X27,0XDD,0XE5,0XE6,0X25,0XDD,0XE5,0XEE,0X27,0XE5,0XE8,0XE5,0XE8,

45770XEE,0X28,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X28,

45780XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

45790XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

45800XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,

45810XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XE6,0X27,0XE6,0X07,0XE6,0X07,

45820XE6,0X28,0XDE,0X07,0XDD,0XE7,0XEE,0X8A,0XFF,0X2D,0XFF,0X4E,0XA4,0X63,0X83,0X40,

45830X9C,0X22,0XCD,0XA8,0XE6,0X6C,0XEE,0XCF,0XEE,0XD1,0XFF,0X76,0XFF,0XFB,0XFF,0XFD,

45840XFF,0XFE,0XF7,0XDF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

45940XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XBC,0XF7,0X37,0XDE,0X50,0XC5,0XAA,0XCD,0XC8,

45950XDE,0X27,0XE6,0X46,0XDD,0XE5,0XE6,0X07,0XEE,0X08,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,

45960XE5,0XE7,0XE6,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

45970XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

45980XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

45990XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X26,0XEE,0X26,

46000XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XE6,0X27,0XE6,0X27,

46010XDE,0X07,0XE6,0X48,0XE6,0X49,0XEE,0XAB,0XFF,0X4E,0XBD,0X46,0XA4,0X84,0XD6,0X0B,

46020XF6,0XF0,0XE6,0X91,0XFF,0XF8,0XFF,0XFB,0XFF,0XDC,0XFF,0XDE,0XFF,0XFF,0XF7,0XFF,

46030XF7,0XFF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

46130XFF,0XFF,0XFF,0XDE,0XFF,0XFC,0XF7,0X57,0XD6,0X4F,0XC5,0XCA,0XCD,0XE8,0XDE,0X27,

46140XE6,0X27,0XE5,0XE6,0XE6,0X07,0XE5,0XE7,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

46150XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

46160XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

46170XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

46180XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XE6,0X27,0XEE,0X27,0XEE,0X27,

46190XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XE6,0X07,0XEE,0X47,0XE6,0X27,

46200XDE,0X07,0XE6,0X48,0XF7,0X0C,0XFF,0X2D,0XDE,0X29,0XDE,0X4C,0XFF,0X93,0XFF,0XD7,

46210XFF,0XBA,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XF7,0XDF,0XF7,0XFF,0XFF,0XFF,

46220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46320XFF,0XFD,0XFF,0XDB,0XF7,0X77,0XDE,0X91,0XCD,0XCB,0XCD,0XA8,0XDE,0X28,0XDE,0X07,

46330XE5,0XE7,0XEE,0X08,0XE6,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,

46340XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

46350XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

46360XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

46370XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,

46380XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X07,0XE6,0X48,

46390XDE,0X27,0XEE,0X89,0XFF,0X2C,0XF7,0X4E,0XEE,0XF1,0XFF,0X96,0XFF,0XFC,0XFF,0XDD,

46400XFF,0XDF,0XFF,0XFF,0XF7,0XDF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XDE,0XFF,0XFD,

46510XFF,0XFC,0XFF,0X98,0XDE,0X91,0XCD,0XEC,0XD5,0XCA,0XDE,0X09,0XE6,0X08,0XEE,0X28,

46520XE5,0XE8,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X28,0XEE,0X28,

46530XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

46540XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

46550XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

46560XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

46570XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X28,0XEE,0X48,0XDE,0X07,

46580XEE,0XA9,0XFF,0X4D,0XF7,0X0F,0XEE,0XF2,0XF7,0X77,0XFF,0XFD,0XFF,0XDE,0XF7,0XBE,

46590XF7,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XDF,0XFF,0XFF,0XFF,0XDD,0XFF,0XDC,

46700XFF,0X78,0XEE,0XD2,0XD5,0XCC,0XCD,0XA9,0XDD,0XC8,0XE6,0X08,0XEE,0X28,0XEE,0X28,

46710XEE,0X28,0XEE,0X28,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,

46720XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

46730XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

46740XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,

46750XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

46760XEE,0X08,0XED,0XE7,0XEE,0X08,0XEE,0X28,0XE5,0XE7,0XEE,0X48,0XE6,0X27,0XDE,0X49,

46770XF7,0X2E,0XFF,0X72,0XDE,0X92,0XF7,0X58,0XFF,0XFC,0XFF,0XFE,0XFF,0XDD,0XFF,0XDE,

46780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,

46880XFF,0XFF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDE,0XFF,0XDB,0XFF,0XB8,

46890XEE,0XB2,0XDE,0X2C,0XD5,0XC9,0XDD,0XE8,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,

46900XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

46910XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

46920XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

46930XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

46940XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XF6,0X28,0XED,0XE7,0XF6,0X28,

46950XED,0XE7,0XF6,0X08,0XEE,0X07,0XE5,0XC6,0XE6,0X27,0XDE,0X07,0XDE,0X29,0XF6,0XEE,

46960XFF,0X52,0XD6,0X50,0XE6,0XD4,0XFF,0XBA,0XFF,0XDC,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,

46970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

46990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XDB,0XFF,0XD8,0XF7,0X33,

47080XDE,0X2C,0XD5,0XC9,0XE6,0X29,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

47090XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

47100XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

47110XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

47120XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X07,0XEE,0X07,

47130XEE,0X07,0XEE,0X07,0XEE,0X07,0XF6,0X28,0XEE,0X07,0XEE,0X08,0XEE,0X07,0XF6,0X08,

47140XF5,0XE7,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X48,0XE6,0X29,0XEE,0XCD,0XF7,0X30,

47150XCD,0XEE,0XDE,0X93,0XFF,0XBA,0XFF,0XDC,0XFF,0XDD,0XFF,0XDE,0XFF,0XDE,0XFF,0XDF,

47160XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47260XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XD9,0XF7,0X54,0XE6,0X8E,

47270XDD,0XC8,0XDD,0XA6,0XEE,0X48,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XF6,0X48,0XEE,0X28,

47280XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X27,

47290XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XF6,0X28,0XEE,0X27,0XEE,0X27,

47300XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

47310XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,

47320XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

47330XEE,0X07,0XEE,0X07,0XE6,0X07,0XEE,0X28,0XE6,0X48,0XEE,0XAB,0XF7,0X0F,0XB5,0X2B,

47340XCD,0XF1,0XF7,0X9A,0XFF,0XDC,0XFF,0XDD,0XFF,0XDE,0XFF,0XBF,0XFF,0XDF,0XFF,0XDF,

47350XF7,0X9E,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47450XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XFC,0XFF,0XD8,0XFF,0X53,0XEE,0X4B,0XE5,0XC7,

47460XE6,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

47470XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X27,

47480XEE,0X27,0XEE,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

47490XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,

47500XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

47510XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XED,0XE7,0XED,0XE7,

47520XEE,0X07,0XEE,0X27,0XE6,0X05,0XEE,0X68,0XF6,0XCC,0XE6,0X8E,0XA4,0XCA,0XB5,0X2E,

47530XEF,0X38,0XFF,0XFD,0XFF,0XFE,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47540XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47640XFF,0XDD,0XFF,0XBB,0XFF,0XB9,0XFF,0X94,0XFE,0XEE,0XEE,0X49,0XE5,0XE7,0XEE,0X08,

47650XEE,0X07,0XEE,0X08,0XEE,0X27,0XF6,0X48,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,

47660XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X27,0XEE,0X27,0XF6,0X28,0XF6,0X28,

47670XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

47680XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

47690XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

47700XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,

47710XE6,0X05,0XE6,0X26,0XEE,0X68,0XF6,0XEC,0XD6,0X0C,0X94,0X27,0X94,0X29,0XE6,0XD6,

47720XFF,0XDC,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XBF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

47730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XBD,0XFF,0XBC,0XFF,0XDB,

47830XFF,0X77,0XEE,0XB1,0XEE,0X6B,0XEE,0X48,0XE6,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X28,

47840XEE,0X07,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

47850XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XF6,0X28,0XF6,0X48,0XF6,0X28,0XF6,0X28,

47860XF6,0X28,0XF6,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

47870XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X27,

47880XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

47890XEE,0X27,0XEE,0X27,0XEE,0X08,0XF6,0X28,0XEE,0X07,0XEE,0X07,0XF6,0X66,0XEE,0X25,

47900XE6,0X46,0XE6,0X48,0XEE,0X8B,0XDE,0X2C,0X7B,0X63,0X83,0XA7,0XDE,0X95,0XFF,0XFC,

47910XFF,0XDD,0XFF,0XDE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

47990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48010XFF,0XFF,0XFF,0XDD,0XFF,0XDD,0XFF,0XFB,0XFF,0XB9,0XFF,0X55,0XEE,0XB1,0XDE,0X2C,

48020XDD,0XE8,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X28,0XEE,0X08,0XEE,0X28,0XEE,0X28,

48030XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

48040XEE,0X28,0XEE,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X48,

48050XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

48060XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X27,0XEE,0X27,

48070XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

48080XEE,0X07,0XEE,0X28,0XEE,0X08,0XEE,0X07,0XF6,0X46,0XEE,0X25,0XEE,0X45,0XEE,0X26,

48090XEE,0X68,0XE6,0X29,0XE6,0X6D,0X5A,0X60,0X83,0XA8,0XDE,0XB6,0XFF,0XFC,0XFF,0XDD,

48100XFF,0XFF,0XF7,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,

48200XFF,0XFA,0XFF,0XB7,0XF7,0X12,0XDE,0X2D,0XD5,0XEB,0XDE,0X2A,0XE6,0X08,0XEE,0X07,

48210XE6,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X07,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

48220XEE,0X48,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X28,0XEE,0X28,

48230XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X28,

48240XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,

48250XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

48260XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X07,

48270XEE,0X28,0XF6,0X08,0XEE,0X06,0XF6,0X46,0XEE,0X25,0XF6,0X46,0XF6,0X47,0XEE,0X48,

48280XDE,0X0A,0XBD,0X49,0X52,0X20,0X73,0X46,0XE6,0XF7,0XFF,0XFD,0XFF,0XDE,0XFF,0XFF,

48290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XD9,0XF7,0X54,0XDE,0X8E,

48390XD6,0X0B,0XDE,0X09,0XDE,0X28,0XDE,0X07,0XE6,0X07,0XEE,0X27,0XE6,0X07,0XEE,0X48,

48400XEE,0X28,0XEE,0X27,0XEE,0X07,0XE6,0X07,0XEE,0X48,0XEE,0X48,0XEE,0X27,0XEE,0X27,

48410XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XF6,0X48,0XEE,0X28,0XF6,0X28,0XF6,0X28,

48420XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X48,

48430XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

48440XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

48450XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XF6,0X28,

48460XF6,0X07,0XF6,0X27,0XEE,0X05,0XF6,0X26,0XEE,0X07,0XEE,0X48,0XE6,0X09,0XDE,0X0B,

48470X94,0X26,0X4A,0X00,0X7B,0X67,0XE6,0XD7,0XFF,0XDD,0XFF,0XFF,0XFF,0XFE,0XF7,0XBE,

48480XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48560XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48570XFF,0XDE,0XFF,0XDC,0XFF,0X97,0XF7,0X12,0XE6,0X8D,0XDE,0X2A,0XDE,0X28,0XDE,0X07,

48580XDE,0X07,0XE6,0X47,0XE6,0X07,0XEE,0X48,0XE6,0X07,0XEE,0X27,0XE5,0XE7,0XEE,0X28,

48590XEE,0X48,0XEE,0X28,0XF6,0X68,0XEE,0X27,0XE6,0X07,0XE6,0X06,0XEE,0X27,0XEE,0X47,

48600XEE,0X47,0XEE,0X27,0XF6,0X48,0XF6,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,

48610XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X28,

48620XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

48630XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

48640XEE,0X27,0XEE,0X27,0XEE,0X27,0XF6,0X48,0XEE,0X28,0XEE,0X08,0XF6,0X28,0XEE,0X06,

48650XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X28,0XEE,0X49,0XDD,0XE9,0XCD,0XAA,0X6A,0XA1,

48660X52,0X01,0X8C,0X2B,0XE6,0XF9,0XFF,0XDE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

48670XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48750XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XBD,0XFF,0XDC,0XFF,0X57,

48760XEE,0XD0,0XDE,0X4B,0XD5,0XE7,0XDD,0XE6,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X27,

48770XEE,0X27,0XEE,0X27,0XE6,0X07,0XEE,0X48,0XE6,0X07,0XEE,0X48,0XEE,0X48,0XF6,0X48,

48780XF6,0X68,0XE5,0XE7,0XE5,0XE6,0XE5,0XE6,0XE6,0X07,0XEE,0X27,0XEE,0X47,0XEE,0X47,

48790XEE,0X47,0XEE,0X28,0XF6,0X28,0XF6,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,

48800XEE,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X28,

48810XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

48820XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

48830XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XF6,0X27,0XF6,0X07,0XF6,0X28,

48840XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X6A,0XCD,0XA9,0XA4,0X66,0X62,0X61,0X49,0XE2,

48850X9C,0XAF,0XF7,0X7C,0XFF,0XFE,0XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,

48860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

48930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,

48940XFF,0XFD,0XFF,0XFC,0XFF,0XFD,0XFF,0XDB,0XF7,0X36,0XE6,0X91,0XDE,0X0A,0XDE,0X07,

48950XDE,0X06,0XE6,0X06,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,

48960XE6,0X07,0XEE,0X27,0XF6,0X69,0XEE,0X07,0XEE,0X48,0XF6,0X89,0XEE,0X07,0XE6,0X07,

48970XF6,0X68,0XEE,0X47,0XE5,0XE6,0XE6,0X06,0XEE,0X27,0XF6,0X47,0XEE,0X27,0XF6,0X48,

48980XF6,0X48,0XEE,0X27,0XF6,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X28,

48990XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X28,

49000XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

49010XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

49020XEE,0X27,0XEE,0X27,0XEE,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X29,0XEE,0X28,

49030XEE,0X28,0XEE,0X48,0XD5,0XC8,0XD5,0XEA,0X7B,0X22,0X52,0X01,0X52,0X44,0XAD,0X11,

49040XF7,0XBC,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,

49050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,

49130XFF,0XFB,0XEE,0XD4,0XE6,0X6F,0XD5,0XEA,0XD5,0XE8,0XDE,0X06,0XE6,0X06,0XE6,0X06,

49140XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

49150XEE,0X48,0XE6,0X07,0XFE,0X89,0XF6,0X68,0XDD,0XA5,0XFE,0X89,0XFE,0XA9,0XFE,0XA9,

49160XF6,0X68,0XEE,0X06,0XE6,0X06,0XEE,0X07,0XF6,0X68,0XEE,0X47,0XF6,0X27,0XF6,0X48,

49170XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

49180XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

49190XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

49200XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XEE,0X47,0XEE,0X47,

49210XEE,0X47,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XF6,0X48,0XF6,0X48,0XEE,0X48,

49220XE6,0X28,0XDD,0XE9,0XA4,0X45,0X6A,0XA2,0X49,0XC1,0X52,0X66,0XC6,0X15,0XFF,0XFD,

49230XFF,0XFE,0XFF,0XFE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49310XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XDA,0XEE,0XF4,0XD6,0X0D,

49320XD5,0XEA,0XDD,0XC8,0XDE,0X07,0XE6,0X07,0XE6,0X07,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,

49330XEE,0X08,0XE6,0X07,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XE5,0XC6,0XEE,0X47,

49340XFE,0X88,0XE6,0X06,0XE5,0XE6,0XFE,0XC9,0XFE,0XA9,0XFE,0XC9,0XFE,0XC9,0XF6,0X68,

49350XEE,0X27,0XE5,0XE6,0XEE,0X27,0XEE,0X27,0XF6,0X27,0XF6,0X48,0XF6,0X27,0XF6,0X27,

49360XF6,0X27,0XF6,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

49370XF6,0X27,0XF6,0X27,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

49380XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

49390XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

49400XEE,0X48,0XEE,0X48,0XEE,0X28,0XF6,0X48,0XEE,0X27,0XEE,0X27,0XF6,0X89,0XD5,0XA7,

49410XCD,0X48,0X7B,0X02,0X5A,0X22,0X41,0XC2,0X73,0X49,0XE6,0XF8,0XFF,0XFD,0XFF,0XDE,

49420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49500XFF,0XFE,0XFF,0XBC,0XFF,0XFB,0XEE,0XD4,0XD5,0XED,0XD5,0XC9,0XDD,0XE8,0XDE,0X07,

49510XDD,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

49520XE6,0X07,0XEE,0X48,0XEE,0X27,0XE6,0X07,0XEE,0X27,0XFE,0XA9,0XE6,0X06,0XE5,0XC5,

49530XFE,0X88,0XF6,0X47,0XFE,0XA9,0XFE,0X88,0XFE,0X88,0XFE,0XC9,0XF6,0X68,0XEE,0X27,

49540XDD,0X85,0XEE,0X47,0XF6,0X27,0XEE,0X07,0XF6,0X27,0XFE,0X68,0XEE,0X27,0XEE,0X27,

49550XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X27,

49560XF6,0X48,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X27,0XF6,0X27,0XF6,0X27,

49570XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

49580XF6,0X27,0XF6,0X27,0XF6,0X47,0XEE,0X46,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

49590XF6,0X48,0XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X47,0XE6,0X28,0XDD,0XC9,0X93,0XC4,

49600X51,0XE0,0X5A,0X43,0X31,0X40,0XAD,0X31,0XFF,0XBC,0XFF,0XFE,0XFF,0XFF,0XEF,0X7D,

49610XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFD,0XFF,0XBA,

49690XEE,0XD4,0XCD,0XED,0XCD,0XA9,0XD5,0XC8,0XDE,0X07,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

49700XE5,0XE7,0XE5,0XE8,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,

49710XEE,0X07,0XE5,0XE6,0XF6,0X68,0XFE,0XC9,0XDD,0XC5,0XEE,0X26,0XFE,0X88,0XF6,0X47,

49720XFE,0XA8,0XFE,0X88,0XFE,0X88,0XFE,0XA9,0XFE,0XA9,0XFE,0X88,0XFE,0X88,0XD5,0X64,

49730XE5,0XC6,0XF6,0X27,0XFE,0X69,0XED,0XE6,0XF6,0X48,0XF6,0X27,0XEE,0X47,0XEE,0X47,

49740XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

49750XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

49760XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X27,

49770XEE,0X47,0XEE,0X46,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X28,

49780XFE,0X68,0XF6,0X47,0XEE,0X27,0XEE,0X48,0XE6,0X08,0XB4,0X86,0X7B,0X03,0X41,0XA0,

49790X49,0XE2,0X5A,0X86,0XD6,0X56,0XFF,0XDD,0XFF,0XBE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

49800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49870XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBE,0XFF,0X9B,0XF7,0X16,0XC5,0X8C,0XD5,0XCA,

49880XD5,0XA7,0XDE,0X07,0XDD,0XC7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

49890XE5,0XE7,0XE5,0XE8,0XE5,0XE8,0XEE,0X08,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X27,

49900XF6,0X68,0XF6,0X68,0XE5,0XE5,0XF6,0X67,0XF6,0X47,0XFE,0X88,0XFE,0X67,0XFE,0X88,

49910XFE,0X88,0XFE,0X68,0XFE,0XA9,0XFE,0X89,0XFE,0X89,0XFE,0X88,0XDD,0X85,0XE5,0XE6,

49920XEE,0X06,0XFE,0X88,0XED,0XE6,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

49930XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

49940XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

49950XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X47,0XEE,0X47,

49960XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X48,0XF6,0X28,0XF6,0X27,0XF6,0X47,

49970XF6,0X88,0XEE,0X47,0XEE,0X29,0XBD,0X07,0X83,0X44,0X51,0XE0,0X52,0X02,0X52,0X04,

49980X8C,0X0D,0XF7,0X7C,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

49990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50060XFF,0XDE,0XFF,0XBC,0XF7,0X38,0XCD,0XAF,0XD5,0XCB,0XCD,0X67,0XE6,0X08,0XE5,0XE7,

50070XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE6,0XE6,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X08,

50080XEE,0X08,0XED,0XE7,0XEE,0X07,0XEE,0X28,0XEE,0X27,0XF6,0X68,0XF6,0X68,0XEE,0X47,

50090XE5,0XC5,0XF6,0X67,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XFE,0X88,

50100XFE,0X88,0XF6,0X68,0XFE,0X89,0XF6,0X68,0XF6,0X48,0XDD,0XA6,0XE5,0XC7,0XE6,0X08,

50110XF6,0X69,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X28,0XEE,0X47,0XEE,0X47,

50120XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

50130XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

50140XF6,0X27,0XF6,0X27,0XF6,0X28,0XEE,0X28,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,

50150XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X28,0XF6,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X88,

50160XEE,0X48,0XD5,0X88,0X93,0XA5,0X5A,0X01,0X5A,0X22,0X41,0XC2,0X5A,0X66,0XCE,0X16,

50170XFF,0XDE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBC,0XFF,0X9A,

50250XD6,0X10,0XC5,0X4B,0XDE,0X0A,0XD5,0XC7,0XDD,0XE8,0XE5,0XE7,0XE5,0XC7,0XE5,0XC7,

50260XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

50270XEE,0X07,0XEE,0X27,0XEE,0X27,0XF6,0X68,0XF6,0XA8,0XDD,0XA4,0XEE,0X26,0XEE,0X26,

50280XF6,0X46,0XF6,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X68,

50290XF6,0X69,0XF6,0X69,0XEE,0X4A,0XF6,0X6C,0XDD,0XCA,0XDD,0XEA,0XDE,0X29,0XEE,0X89,

50300XEE,0X27,0XF6,0X47,0XF6,0X08,0XF6,0X49,0XEE,0X28,0XEE,0X27,0XF6,0X67,0XEE,0X46,

50310XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,

50320XEE,0X27,0XEE,0X47,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

50330XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

50340XF6,0X48,0XF6,0X47,0XF6,0X48,0XEE,0X47,0XF6,0X47,0XF6,0X68,0XEE,0X48,0XDD,0XE9,

50350XA4,0X06,0X62,0X42,0X49,0XC1,0X49,0XE3,0X49,0XE4,0X8C,0X2E,0XE7,0X1A,0XFF,0XFF,

50360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBB,0XE6,0X93,0XC5,0X4B,0XD5,0XCA,

50440XD5,0X87,0XE6,0X28,0XD5,0X87,0XE5,0XE8,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

50450XE5,0XE8,0XE5,0XE8,0XE6,0X07,0XE6,0X06,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X27,

50460XEE,0X27,0XF6,0X67,0XFE,0XA8,0XD5,0X63,0XEE,0X46,0XEE,0X26,0XEE,0X26,0XF6,0X27,

50470XF6,0X07,0XF6,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X48,0XF6,0X6A,

50480XEE,0X4B,0XEE,0X6D,0XFF,0X12,0XDE,0X6F,0XD5,0XEB,0XDE,0X29,0XEE,0X48,0XEE,0X07,

50490XF6,0X28,0XED,0XE8,0XF6,0X28,0XF6,0X68,0XEE,0X66,0XF6,0X66,0XF6,0X47,0XF6,0X47,

50500XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

50510XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

50520XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

50530XF6,0X68,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XEE,0X29,0XB4,0XA8,0X6A,0X82,

50540X49,0XA1,0X52,0X03,0X41,0XA3,0X62,0XC8,0XD6,0X98,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

50550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50620XFF,0XDE,0XFF,0XDC,0XFF,0X99,0XBD,0X4D,0XC5,0X69,0XDD,0XE9,0XD5,0X87,0XDD,0XA7,

50630XE6,0X08,0XDD,0XA7,0XE5,0XE8,0XDD,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE8,0XE6,0X08,

50640XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XFE,0XA9,

50650XEE,0X46,0XDD,0XA4,0XEE,0X26,0XEE,0X06,0XED,0XE6,0XED,0XE7,0XED,0XE7,0XED,0XE7,

50660XED,0XE7,0XE5,0XE7,0XE5,0XE7,0XEE,0X08,0XE6,0X07,0XEE,0X4A,0XDD,0XCA,0XFE,0XF1,

50670XFF,0XD7,0XFF,0X96,0XD6,0X2E,0XD6,0X0B,0XE6,0X28,0XF6,0X48,0XF6,0X28,0XF6,0X08,

50680XF6,0X49,0XEE,0X48,0XE6,0X46,0XEE,0X87,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

50690XF6,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

50700XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

50710XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X68,0XF6,0X48,

50720XF6,0X88,0XF6,0X68,0XF6,0X68,0XEE,0X6A,0XC5,0X09,0X7B,0X04,0X51,0XC1,0X51,0XE3,

50730X49,0XE3,0X41,0XC4,0XAD,0X11,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,

50810XC5,0XD0,0XBD,0X6B,0XD5,0XA8,0XDD,0XE8,0XE5,0XE7,0XDD,0XA6,0XE5,0XE8,0XDD,0XA8,

50820XE5,0XC8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X08,0XE6,0X08,0XE6,0X07,0XE6,0X07,

50830XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XFE,0XEA,0XDD,0XC5,0XE5,0XE5,

50840XE5,0XE5,0XEE,0X06,0XE5,0XA5,0XE5,0XC6,0XE5,0XC7,0XE5,0XA7,0XDD,0XA7,0XDD,0XA7,

50850XDD,0XA7,0XE5,0XC7,0XE5,0XC7,0XDD,0XA8,0XDE,0X2C,0XEE,0XF2,0XFF,0XB8,0XFF,0XDA,

50860XF7,0X76,0XCE,0X0E,0XE6,0X4B,0XE6,0X08,0XF6,0X29,0XF6,0X08,0XF6,0X28,0XF6,0X48,

50870XEE,0X87,0XEE,0X67,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

50880XF6,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,

50890XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

50900XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X48,0XF6,0X88,0XF6,0X47,

50910XEE,0X47,0XEE,0X6A,0XC5,0X29,0X83,0X44,0X51,0XE1,0X49,0XC2,0X52,0X24,0X39,0XC3,

50920X73,0X4A,0XEF,0X3B,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

50990XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDD,0XFF,0XDD,0XFF,0X79,0XAC,0XCB,0XCD,0XAA,

51000XDD,0XE7,0XDD,0XE6,0XDD,0XE6,0XE5,0XE7,0XDD,0XA7,0XE5,0XE9,0XE5,0XC7,0XE5,0XE7,

51010XE5,0XE7,0XE6,0X07,0XE5,0XE7,0XE6,0X08,0XE6,0X08,0XE6,0X07,0XE6,0X07,0XEE,0X07,

51020XEE,0X27,0XE6,0X06,0XEE,0X47,0XFE,0XC9,0XDD,0XA4,0XE5,0XC5,0XE5,0XC5,0XE5,0XE6,

51030XDD,0X85,0XDD,0X86,0XDD,0X87,0XD5,0X67,0XD5,0X67,0XD5,0X67,0XD5,0X67,0XDD,0X87,

51040XDD,0X67,0XD5,0X88,0XD5,0XED,0XFF,0X96,0XFF,0XFC,0XFF,0XFD,0XFF,0XBB,0XFF,0XF9,

51050XC5,0X8B,0XE6,0X2B,0XF6,0X2A,0XF6,0X28,0XFE,0X89,0XE5,0XE6,0XEE,0X88,0XE6,0X47,

51060XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X27,

51070XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

51080XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

51090XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X47,0XF6,0X88,0XF6,0X47,0XF6,0X47,0XF6,0X69,

51100XD5,0XAA,0X8B,0X64,0X5A,0X01,0X51,0XE2,0X49,0XE3,0X41,0XE3,0X52,0X45,0XD6,0X77,

51110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

51180XFF,0XFE,0XFF,0XDD,0XFF,0X9A,0XC5,0XB0,0XBD,0X6B,0XCD,0XA9,0XDE,0X06,0XDD,0XC4,

51190XDD,0XC5,0XE5,0XC6,0XE5,0XE8,0XE5,0XC8,0XE5,0XE8,0XDD,0XC7,0XE5,0XE7,0XE6,0X07,

51200XE5,0XE7,0XE6,0X08,0XE6,0X08,0XE6,0X08,0XE6,0X08,0XEE,0X07,0XE6,0X07,0XEE,0X27,

51210XF6,0X68,0XFE,0X88,0XDD,0XA4,0XDD,0X84,0XE5,0XA5,0XDD,0X85,0XD5,0X45,0XD5,0X67,

51220XD5,0X67,0XCD,0X47,0XCD,0X47,0XD5,0X47,0XD5,0X47,0XD5,0X47,0XD5,0X47,0XCD,0X49,

51230XDE,0X70,0XFF,0XD8,0XF7,0XDC,0XFF,0XFE,0XFF,0XFE,0XFF,0XDB,0XF7,0X35,0XCD,0XCC,

51240XDD,0XC9,0XEE,0X49,0XE6,0X07,0XF6,0X68,0XEE,0X68,0XEE,0X47,0XEE,0X47,0XF6,0X47,

51250XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X27,0XEE,0X47,0XEE,0X47,

51260XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

51270XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X48,

51280XF6,0X68,0XF6,0X47,0XF6,0X88,0XF6,0X67,0XF6,0X68,0XF6,0X69,0XE6,0X0A,0X93,0XA4,

51290X5A,0X01,0X52,0X03,0X49,0XE2,0X41,0XE2,0X41,0XE3,0XAD,0X11,0XFF,0XBE,0XFF,0XFF,

51300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XDC,

51370XF7,0X38,0XA4,0X8A,0XCD,0XAB,0XDE,0X09,0XDD,0XC5,0XE5,0XE5,0XE5,0XE5,0XEE,0X07,

51380XE5,0XA7,0XE5,0XC8,0XE5,0XC8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

51390XE6,0X07,0XE6,0X08,0XEE,0X08,0XEE,0X07,0XE6,0X07,0XEE,0X48,0XF6,0X88,0XF6,0X68,

51400XDD,0X84,0XDD,0X64,0XDD,0X65,0XD5,0X65,0XCD,0X26,0XCD,0X47,0XCD,0X47,0XCD,0X27,

51410XCD,0X47,0XCD,0X47,0XCD,0X26,0XCD,0X27,0XCD,0X28,0XC5,0X29,0XE6,0XB2,0XFF,0XFA,

51420XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XDA,0XE6,0XB2,0XD5,0XCC,0XEE,0X6C,

51430XE6,0X08,0XF6,0X68,0XEE,0X27,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

51440XF6,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,

51450XEE,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

51460XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X47,0XF6,0X68,0XF6,0X68,

51470XF6,0X68,0XF6,0X67,0XF6,0X88,0XF6,0X89,0XE6,0X2A,0XA4,0X46,0X62,0X21,0X52,0X02,

51480X52,0X02,0X4A,0X02,0X41,0XC2,0X7B,0XAB,0XF7,0X7D,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

51490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XFF,0XDB,0XCD,0XD1,0XBD,0X4B,

51560XD5,0XEA,0XD5,0XC7,0XE5,0XE6,0XE5,0XC5,0XE5,0XE6,0XE5,0XC6,0XE5,0XC7,0XE5,0XC8,

51570XE5,0XC8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

51580XEE,0X08,0XEE,0X07,0XE6,0X07,0XEE,0X48,0XFE,0XCA,0XEE,0X27,0XD5,0X64,0XD5,0X65,

51590XCD,0X24,0XCD,0X25,0XCD,0X26,0XCD,0X47,0XCD,0X47,0XC5,0X27,0XCD,0X27,0XCD,0X47,

51600XCD,0X26,0XCD,0X27,0XC5,0X08,0XBD,0X2B,0XF7,0X35,0XFF,0XFC,0XFF,0XDE,0XFF,0XBF,

51610XFF,0XFF,0XFF,0XFE,0XF7,0XBB,0XFF,0XB9,0XDE,0X91,0XCD,0XCB,0XE6,0X4A,0XEE,0X49,

51620XEE,0X07,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

51630XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X28,0XF6,0X48,

51640XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

51650XF6,0X47,0XF6,0X48,0XF6,0X68,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X67,

51660XF6,0X88,0XF6,0X89,0XF6,0X8B,0XB4,0XA6,0X6A,0X62,0X49,0XC1,0X52,0X22,0X52,0X22,

51670X41,0XE2,0X5A,0XA7,0XF7,0X5C,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51740XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XFF,0X78,0XAC,0XEB,0XD5,0XCC,0XD5,0XC9,0XD5,0XA6,

51750XE5,0XC6,0XE5,0XC7,0XE5,0XE7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE8,

51760XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XE6,0X07,0XE5,0XE7,0XE6,0X07,

51770XEE,0X07,0XEE,0X48,0XFE,0XAA,0XE5,0XE7,0XCD,0X24,0XD5,0X45,0XCD,0X25,0XCD,0X26,

51780XCD,0X26,0XCD,0X47,0XC5,0X27,0XC5,0X27,0XC5,0X27,0XCD,0X47,0XC5,0X06,0XC5,0X07,

51790XBD,0X08,0XC5,0X6C,0XFF,0XB9,0XFF,0XFD,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

51800XFF,0XDD,0XFF,0XFC,0XF7,0X77,0XCD,0XEF,0XDD,0XEB,0XEE,0X4A,0XF6,0X48,0XF6,0X47,

51810XF6,0X47,0XEE,0X27,0XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

51820XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

51830XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

51840XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X87,0XF6,0X89,

51850XF6,0X8A,0XC5,0X48,0X6A,0X61,0X51,0XE1,0X52,0X22,0X52,0X22,0X4A,0X02,0X4A,0X04,

51860XD6,0X58,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

51920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XFF,0XFE,

51930XFF,0XBB,0XDE,0X73,0XBD,0X0A,0XD5,0XCA,0XD5,0XA8,0XDD,0XA7,0XE5,0XC7,0XE5,0XC8,

51940XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE7,

51950XE5,0XE6,0XE6,0X06,0XE6,0X07,0XE6,0X07,0XE5,0XE7,0XEE,0X07,0XEE,0X27,0XF6,0X68,

51960XFE,0X89,0XDD,0X86,0XCC,0XE4,0XCD,0X05,0XCD,0X05,0XC5,0X06,0XC5,0X06,0XC5,0X07,

51970XBD,0X07,0XBD,0X07,0XBD,0X07,0XC5,0X27,0XC4,0XE6,0XBD,0X07,0XB4,0XE8,0XCD,0XCE,

51980XFF,0XBA,0XFF,0XDE,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XFF,0XDD,

51990XFF,0XDB,0XEF,0X15,0XD5,0XED,0XDD,0XCA,0XF6,0X6A,0XF6,0X48,0XF6,0X48,0XF6,0X47,

52000XF6,0X47,0XF6,0X26,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

52010XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

52020XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X68,

52030XF6,0X67,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X88,0XFE,0XCB,0XCD,0X48,

52040X6A,0X61,0X5A,0X01,0X52,0X01,0X52,0X22,0X4A,0X02,0X39,0XA2,0XB5,0X74,0XFF,0XDE,

52050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

52060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XFF,0XFE,0XFF,0XBA,0XBD,0X4D,

52120XCD,0XAB,0XD5,0X88,0XE5,0XE8,0XDD,0XA7,0XE5,0XC8,0XE5,0XC8,0XE5,0XC8,0XE5,0XC7,

52130XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE7,0XE6,0X07,0XE6,0X06,

52140XE6,0X06,0XE6,0X06,0XE6,0X07,0XEE,0X07,0XEE,0X48,0XF6,0X68,0XF6,0X48,0XCD,0X25,

52150XC4,0XC4,0XC4,0XE5,0XBC,0XC5,0XBC,0XC6,0XBC,0XE6,0XBC,0XE7,0XBC,0XE7,0XBD,0X07,

52160XBD,0X07,0XBD,0X07,0XBC,0XE6,0XBC,0XE7,0XAC,0XC8,0XDE,0X51,0XFF,0XBB,0XFF,0XDE,

52170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XFC,0XFF,0XD9,

52180XE6,0X71,0XCD,0X8B,0XEE,0X4B,0XEE,0X29,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XEE,0X26,

52190XF6,0X68,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

52200XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

52210XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X68,

52220XF6,0X87,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XFE,0XAA,0XD5,0XA9,0X72,0XA1,0X5A,0X21,

52230X52,0X21,0X52,0X42,0X52,0X43,0X41,0XC2,0X9C,0X6F,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XEE,0XF6,0XC5,0X8D,0XC5,0X49,0XDD,0XE9,

52310XDD,0XC7,0XE5,0XC7,0XE5,0XC8,0XE5,0XC8,0XE5,0XA8,0XE5,0XC8,0XE5,0XE7,0XE5,0XE7,

52320XE5,0XE7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE6,0X06,0XE6,0X06,0XE6,0X06,

52330XE6,0X07,0XEE,0X07,0XEE,0X48,0XF6,0X68,0XEE,0X08,0XBC,0XC4,0XBC,0XA4,0XBC,0XA5,

52340XB4,0X85,0XB4,0XA6,0XB4,0XA6,0XB4,0XA6,0XB4,0XC6,0XB4,0XC6,0XB4,0XC6,0XB4,0XC6,

52350XB4,0XA6,0XB4,0XC7,0XAC,0X88,0XEE,0XD4,0XFF,0XBC,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

52360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDD,0XFF,0XFB,0XFF,0X76,0XD6,0X0E,

52370XDD,0XEB,0XE6,0X0A,0XEE,0X49,0XEE,0X47,0XF6,0X47,0XEE,0X26,0XFE,0X68,0XF6,0X27,

52380XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

52390XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

52400XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

52410XF6,0X67,0XF6,0X68,0XF6,0X69,0XE6,0X2B,0X7B,0X02,0X62,0X41,0X5A,0X62,0X5A,0X62,

52420X52,0X42,0X52,0X44,0X6B,0X2A,0XFF,0XBD,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

52430XFF,0XDF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52490XFF,0XFF,0XFF,0XDC,0XE6,0XB4,0XC5,0X6B,0XCD,0X89,0XDD,0XC8,0XDD,0XC7,0XE5,0XC7,

52500XE5,0XC8,0XE5,0XC8,0XE5,0XC8,0XE5,0XC8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

52510XE5,0XE8,0XE5,0XE8,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

52520XEE,0X47,0XF6,0X68,0XDD,0XA7,0XB4,0X83,0XB4,0X84,0XAC,0X65,0XAC,0X65,0XAC,0X46,

52530XAC,0X66,0XAC,0X66,0XAC,0X66,0XAC,0X85,0XAC,0X86,0XAC,0X66,0XA4,0X66,0XA4,0X67,

52540XA4,0X69,0XF7,0X57,0XFF,0XDC,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52550XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFB,0XFF,0XF9,0XEE,0XD3,0XCD,0X8C,0XE6,0X0C,

52560XF6,0X6A,0XEE,0X27,0XF6,0X67,0XF6,0X47,0XF6,0X68,0XEE,0X27,0XF6,0X48,0XF6,0X48,

52570XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

52580XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

52590XF6,0X68,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,

52600XEE,0X49,0XF6,0X6B,0X8B,0X62,0X62,0X60,0X62,0X82,0X5A,0X83,0X52,0X42,0X52,0X44,

52610X5A,0XA7,0XFF,0XBC,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

52620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,

52680XDE,0X72,0XBD,0X4A,0XD5,0XA9,0XDD,0XC8,0XDD,0XC7,0XDD,0XC7,0XDD,0XC7,0XE5,0XC7,

52690XE5,0XC8,0XE5,0XC8,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE8,

52700XE5,0XE7,0XE6,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X07,0XE6,0X06,0XEE,0X47,0XEE,0X47,

52710XCD,0X65,0XAC,0X42,0XAC,0X64,0XAC,0X25,0XA4,0X25,0XA4,0X25,0XA4,0X25,0XA4,0X25,

52720XA4,0X45,0XA4,0X45,0XA4,0X46,0XA4,0X45,0X9C,0X26,0X9C,0X27,0X9C,0X6B,0XFF,0X9A,

52730XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

52740XFF,0XDD,0XFF,0XFC,0XFF,0XFB,0XFF,0X98,0XD5,0XCF,0XD5,0XAC,0XF6,0X6A,0XEE,0X27,

52750XF6,0X67,0XF6,0X47,0XF6,0X47,0XEE,0X27,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

52760XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

52770XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

52780XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X69,0XEE,0X6B,

52790X93,0XC3,0X6A,0X81,0X62,0X82,0X62,0XA3,0X5A,0X83,0X52,0X43,0X5A,0X86,0XF7,0X7B,

52800XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

52810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

52860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBB,0XCD,0XF0,0XBD,0X6A,

52870XD5,0XC9,0XDD,0XC8,0XDD,0XC7,0XDD,0XC7,0XDD,0XC6,0XDD,0XC7,0XE5,0XC8,0XE5,0XC8,

52880XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,

52890XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X06,0XF6,0X47,0XEE,0X27,0XC5,0X04,0XA4,0X22,

52900XA4,0X24,0XA4,0X25,0XA4,0X05,0XA4,0X05,0XA4,0X05,0XA4,0X05,0XA4,0X25,0XA4,0X05,

52910XA4,0X26,0X9C,0X05,0X9C,0X06,0X93,0XE7,0XA4,0XAD,0XFF,0XFB,0XFF,0XDE,0XFF,0XFF,

52920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XFD,

52930XFF,0XDC,0XFF,0XFB,0XEE,0XB3,0XD5,0X8B,0XE6,0X2A,0XEE,0X27,0XF6,0X67,0XF6,0X46,

52940XEE,0X47,0XEE,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

52950XF6,0X28,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

52960XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X67,

52970XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X89,0XEE,0X6A,0XA4,0X24,0X72,0XE2,

52980X6A,0XA2,0X6A,0XC4,0X6A,0XC4,0X5A,0X64,0X5A,0X65,0XE7,0X19,0XFF,0XFE,0XFF,0XFF,

52990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53050XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XF7,0X79,0XC5,0X8D,0XCD,0X8A,0XD5,0XA8,0XDD,0XA7,

53060XE5,0XC7,0XDD,0XC6,0XDD,0XE6,0XDD,0XE6,0XE5,0XC7,0XE5,0XC8,0XE5,0XC7,0XE5,0XE7,

53070XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X08,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

53080XE6,0X06,0XEE,0X06,0XF6,0X47,0XE6,0X07,0XBC,0XC3,0XA4,0X02,0X9C,0X04,0X9B,0XE5,

53090X9B,0XE5,0X9B,0XE5,0X9B,0XE5,0X9B,0XE5,0X9C,0X05,0X9B,0XE4,0X9C,0X05,0X93,0XE5,

53100X93,0XC5,0X8B,0XA6,0XAD,0X0E,0XFF,0XFD,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

53110XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDD,0XFF,0XFC,

53120XFF,0X98,0XCD,0XAE,0XDD,0XCA,0XEE,0X48,0XF6,0X67,0XEE,0X47,0XF6,0X47,0XF6,0X68,

53130XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X46,0XF6,0X47,0XF6,0X47,0XF6,0X28,0XF6,0X48,

53140XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,

53150XF6,0X68,0XF6,0X68,0XF6,0X47,0XF6,0X68,0XF6,0X67,0XF6,0X68,0XF6,0X67,0XF6,0X67,

53160XF6,0X67,0XF6,0X68,0XF6,0X69,0XF6,0X6A,0XAC,0X85,0X7B,0X22,0X72,0XE3,0X6A,0XE4,

53170X72,0XE4,0X62,0XA4,0X62,0XA5,0XDE,0XB8,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53180XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53240XFF,0XFD,0XEF,0X38,0XC5,0X8D,0XCD,0XAA,0XD5,0X88,0XE5,0XC7,0XE5,0XC6,0XDD,0XC6,

53250XE5,0XE6,0XE5,0XE6,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

53260XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE5,0XE7,0XE6,0X06,0XEE,0X07,0XEE,0X07,0XED,0XE7,

53270XF6,0X48,0XE5,0XE7,0XAC,0X42,0X9B,0XE2,0X9B,0XE4,0X93,0XC4,0X93,0XC5,0X93,0XC5,

53280X93,0XC5,0X93,0XC5,0X9B,0XE5,0X8B,0XA4,0X93,0XE5,0X8B,0XC5,0X8B,0XA6,0X83,0X66,

53290XBD,0X50,0XFF,0XFC,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

53300XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XBD,0XFF,0XDC,0XEE,0XB4,

53310XCD,0X6B,0XEE,0X2A,0XEE,0X48,0XEE,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,

53320XF6,0X66,0XF6,0X66,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

53330XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

53340XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X88,

53350XFE,0X68,0XF6,0X6A,0XBC,0XE7,0X83,0X63,0X73,0X03,0X72,0XE3,0X73,0X04,0X6A,0XC4,

53360X62,0XA5,0XDE,0X76,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,

53370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XEF,0X17,

53430XC5,0X6C,0XD5,0XAA,0XDD,0XA8,0XE5,0XE7,0XE5,0XE6,0XDD,0XE5,0XE5,0XE6,0XE5,0XE6,

53440XE5,0XC7,0XE5,0XE7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,

53450XE6,0X07,0XE6,0X06,0XE6,0X06,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XF6,0X48,0XDD,0XA6,

53460XAC,0X22,0X93,0XC2,0X93,0XA4,0X93,0XA4,0X93,0XA5,0X93,0XA5,0X93,0XA6,0X93,0XC5,

53470X93,0XC5,0X8B,0XA4,0X8B,0XC5,0X8B,0XA5,0X8B,0XA6,0X83,0X67,0XC5,0X91,0XFF,0XFD,

53480XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

53490XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XBE,0XFF,0XFE,0XFF,0X79,0XD5,0XCD,0XDD,0XEA,

53500XEE,0X49,0XEE,0X27,0XF6,0X48,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X66,0XF6,0X66,

53510XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

53520XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

53530XF6,0X67,0XF6,0X87,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X89,0XF6,0X8A,

53540XC5,0X07,0X8B,0XA3,0X7B,0X43,0X73,0X03,0X7B,0X24,0X72,0XE4,0X6A,0XA5,0XDE,0X96,

53550XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XE6,0XF7,0XBD,0X4C,0XD5,0XAA,

53620XDD,0XA8,0XE5,0XC7,0XE5,0XE6,0XDD,0XE6,0XDD,0XE6,0XE5,0XE6,0XE5,0XE7,0XE5,0XE7,

53630XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X06,

53640XE6,0X06,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XF6,0X49,0XD5,0X46,0XA3,0XE2,0X8B,0X82,

53650X8B,0X63,0X8B,0X84,0X8B,0X65,0X8B,0X65,0X8B,0X65,0X8B,0X65,0X8B,0X85,0X83,0X64,

53660X83,0X64,0X83,0X65,0X83,0X66,0X7B,0X26,0XCD,0XF3,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,

53670XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

53680XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XDB,0XE6,0X71,0XD5,0XAA,0XEE,0X49,0XEE,0X47,

53690XFE,0X68,0XF6,0X27,0XF6,0X48,0XF6,0X47,0XF6,0X66,0XF6,0X66,0XF6,0X47,0XF6,0X48,

53700XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,

53710XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

53720XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XF6,0X6A,0XCD,0X47,0X9B,0XE4,

53730X83,0X64,0X7B,0X44,0X7B,0X44,0X73,0X25,0X6A,0XC5,0XDE,0X96,0XFF,0XFE,0XFF,0XFF,

53740XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53800XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XE6,0XD6,0XBD,0X4B,0XD5,0XAA,0XDD,0XA8,0XE5,0XC7,

53810XE5,0XC6,0XE5,0XE6,0XE5,0XE6,0XE5,0XE6,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

53820XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X06,0XEE,0X06,0XEE,0X27,

53830XEE,0X08,0XEE,0X08,0XF6,0X4A,0XCD,0X06,0X9B,0XC2,0X83,0X42,0X83,0X43,0X83,0X44,

53840X83,0X45,0X83,0X25,0X83,0X45,0X83,0X45,0X83,0X44,0X83,0X64,0X7B,0X24,0X7B,0X45,

53850X7B,0X26,0X72,0XE6,0XD6,0X14,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53860XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53870XFF,0XFE,0XFF,0XDB,0XF6,0XF4,0XCD,0X8A,0XE6,0X29,0XF6,0X68,0XF6,0X68,0XF6,0X27,

53880XF6,0X48,0XF6,0X47,0XF6,0X46,0XF6,0X66,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,

53890XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

53900XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,

53910XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X69,0XD5,0X88,0XA4,0X45,0X8B,0XA5,0X8B,0X85,

53920X8B,0X85,0X7B,0X45,0X73,0X05,0XDE,0XB6,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53930XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

53980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

53990XFF,0XDD,0XE6,0XD5,0XC5,0X4B,0XDD,0XCA,0XDD,0XA8,0XE5,0XC7,0XE5,0XC6,0XE5,0XE6,

54000XE5,0XE6,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

54010XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X09,

54020XF6,0X4A,0XC4,0XE5,0X93,0X82,0X83,0X02,0X7B,0X03,0X7B,0X04,0X7B,0X04,0X7B,0X04,

54030X7B,0X05,0X7B,0X04,0X7B,0X24,0X7B,0X44,0X73,0X04,0X7B,0X25,0X73,0X05,0X6A,0XC6,

54040XD6,0X35,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,

54060XFF,0X56,0XCD,0XAC,0XDD,0XE9,0XEE,0X68,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

54070XF6,0X47,0XF6,0X46,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X67,

54080XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X68,

54090XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X87,

54100XFE,0X88,0XF6,0X89,0XDD,0XC9,0XAC,0X66,0X93,0XC5,0X93,0XC6,0X93,0XC6,0X8B,0X86,

54110X83,0X87,0XEF,0X17,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XE6,0XD5,

54180XC5,0X6B,0XDD,0XC9,0XE5,0XA7,0XE5,0XC6,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

54190XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,

54200XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X09,0XF6,0X2A,0XBC,0XC5,

54210X8B,0X41,0X7B,0X02,0X7B,0X03,0X72,0XE4,0X7B,0X04,0X7B,0X05,0X7A,0XE4,0X72,0XE4,

54220X73,0X04,0X73,0X24,0X72,0XE3,0X73,0X04,0X72,0XC5,0X6A,0XA6,0XD6,0X35,0XFF,0XFE,

54230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0X78,0XD5,0XEE,

54250XCD,0XA8,0XEE,0X68,0XEE,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

54260XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

54270XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XF6,0X68,

54280XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X66,0XFE,0X87,0XFE,0X87,0XFE,0X89,

54290XE6,0X09,0XAC,0X65,0X9B,0XE5,0X93,0XC6,0X9B,0XE6,0X8B,0XA6,0X8B,0XC8,0XF7,0X38,

54300XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XE6,0XD5,0XC5,0X6B,0XDD,0XE9,

54370XDD,0XA7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

54380XE5,0XE8,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

54390XE6,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X09,0XF6,0X2A,0XBC,0XC5,0X83,0X00,0X7A,0XE1,

54400X7B,0X03,0X72,0XE4,0X72,0XE4,0X73,0X04,0X7A,0XE4,0X73,0X04,0X73,0X04,0X73,0X03,

54410X6B,0X03,0X6A,0XE4,0X6A,0XC5,0X62,0XA6,0XCE,0X35,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

54420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBA,0XDE,0X71,0XCD,0X89,0XEE,0X69,

54440XEE,0X47,0XF6,0X67,0XFE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

54450XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

54460XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X67,

54470XF6,0X67,0XF6,0X66,0XFE,0X66,0XFE,0X86,0XFE,0X87,0XFE,0X89,0XEE,0X4A,0XAC,0X45,

54480XA4,0X05,0X9B,0XE6,0X9C,0X06,0X8B,0XC6,0X94,0X09,0XFF,0X99,0XFF,0XDD,0XFF,0XFF,

54490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54550XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XEE,0XF5,0XCD,0X8B,0XDD,0XC9,0XDD,0XA7,0XED,0XE7,

54560XE6,0X07,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

54570XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X07,

54580XEE,0X08,0XEE,0X29,0XEE,0X4A,0XBC,0XC5,0X7A,0XE0,0X7A,0XE1,0X72,0XE3,0X72,0XE3,

54590X72,0XC4,0X72,0XE4,0X72,0XE4,0X72,0XE4,0X6A,0XE3,0X6A,0XE3,0X6A,0XE3,0X6A,0XC3,

54600X62,0XA4,0X62,0X85,0XCE,0X15,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54610XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54620XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XE6,0XB3,0XC5,0X69,0XEE,0X69,0XF6,0X67,0XF6,0X67,

54630XF6,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

54640XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

54650XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XF6,0X67,0XFE,0X67,0XFE,0X87,0XF6,0X66,

54660XF6,0X66,0XFE,0X86,0XFE,0XA7,0XFE,0XA9,0XF6,0X6A,0XAC,0X64,0XAC,0X46,0XA4,0X26,

54670XA4,0X26,0X93,0XC6,0XA4,0X8B,0XFF,0XFA,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

54740XFF,0XDC,0XEE,0XF5,0XCD,0X8B,0XDD,0XC8,0XE5,0XA7,0XED,0XE7,0XE5,0XE7,0XE5,0XE7,

54750XE5,0XE6,0XE6,0X07,0XE5,0XE7,0XE5,0XE8,0XED,0XE7,0XEE,0X07,0XEE,0X07,0XE6,0X06,

54760XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X06,0XEE,0X28,0XEE,0X08,0XEE,0X29,

54770XF6,0X4A,0XBC,0XA5,0X7B,0X00,0X72,0XC1,0X72,0XC2,0X6A,0XC3,0X6A,0XC4,0X6A,0XC4,

54780X6A,0XA4,0X6A,0XC3,0X6A,0XC3,0X62,0XA3,0X62,0XA3,0X6A,0XC4,0X62,0XA4,0X5A,0X45,

54790XC5,0XD4,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54800XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54810XFF,0XFD,0XE6,0XD5,0XC5,0X69,0XDE,0X29,0XEE,0X47,0XF6,0X46,0XF6,0X47,0XFE,0X47,

54820XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

54830XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,

54840XF6,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X87,0XF6,0X67,0XF6,0X66,0XFE,0X87,

54850XFE,0X87,0XFE,0XCA,0XEE,0X09,0XB4,0X84,0XB4,0X87,0XAC,0X47,0XAC,0X67,0X9C,0X27,

54860XC5,0X8F,0XFF,0XDB,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

54870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

54920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XEE,0XF5,

54930XCD,0X8B,0XDD,0XA9,0XE5,0XA7,0XED,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X06,0XE6,0X07,

54940XE5,0XE7,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

54950XEE,0X27,0XEE,0X27,0XE6,0X07,0XEE,0X27,0XEE,0X08,0XEE,0X09,0XF6,0X4A,0XBC,0X85,

54960X7B,0X00,0X6A,0X80,0X6A,0XA2,0X62,0X83,0X6A,0XA3,0X6A,0XA4,0X62,0X84,0X62,0XA3,

54970X62,0XA3,0X62,0XA3,0X62,0XA3,0X62,0XA3,0X62,0X64,0X52,0X24,0XB5,0X73,0XFF,0XDE,

54980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

54990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XEE,0XF6,

55000XC5,0X8A,0XDE,0X09,0XEE,0X47,0XF6,0X46,0XF6,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X47,

55010XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X46,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,

55020XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XFE,0X68,

55030XFE,0X68,0XFE,0X67,0XFE,0X87,0XF6,0X67,0XF6,0X86,0XFE,0X87,0XFE,0XA8,0XFE,0XCA,

55040XE5,0XE8,0XBC,0XA5,0XBC,0XC7,0XB4,0X87,0XAC,0XA8,0XA4,0X89,0XD6,0X32,0XFF,0XFB,

55050XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XEF,0X16,0XD5,0XAC,0XDD,0XC9,

55120XE5,0XC8,0XED,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X06,0XE6,0X06,0XE6,0X07,0XE6,0X07,

55130XEE,0X07,0XED,0XE7,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

55140XE6,0X06,0XEE,0X48,0XEE,0X08,0XEE,0X09,0XF6,0X6B,0XBC,0XA5,0X83,0X01,0X6A,0X60,

55150X62,0X82,0X5A,0X42,0X62,0X63,0X62,0X64,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X83,

55160X5A,0X83,0X5A,0X63,0X52,0X43,0X4A,0X04,0XA4,0XF1,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

55170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XF7,0X37,0XC5,0X8B,0XDD,0XE9,

55190XF6,0X48,0XF6,0X47,0XF6,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

55200XF6,0X46,0XF6,0X66,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,

55210XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X67,

55220XFE,0X87,0XF6,0X67,0XF6,0X87,0XFE,0XA7,0XFE,0XC9,0XFE,0XCA,0XE5,0XC7,0XC4,0XE6,

55230XC4,0XE7,0XBC,0XE8,0XB4,0XC9,0XB4,0XEB,0XEE,0XF6,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,

55240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55300XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XF7,0X57,0XD5,0XED,0XDD,0XCA,0XE5,0XE8,0XED,0XE7,

55310XE5,0XE7,0XE6,0X07,0XE6,0X06,0XE6,0X06,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

55320XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X06,0XEE,0X47,

55330XEE,0X28,0XEE,0X29,0XF6,0X6B,0XBC,0XC6,0X83,0X01,0X62,0X60,0X5A,0X41,0X5A,0X42,

55340X5A,0X43,0X5A,0X43,0X5A,0X23,0X5A,0X23,0X5A,0X43,0X5A,0X63,0X52,0X42,0X52,0X43,

55350X52,0X03,0X49,0XE4,0X94,0X4E,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

55360XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55370XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0X78,0XCD,0XAC,0XDD,0XE9,0XF6,0X48,0XF6,0X67,

55380XFE,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X66,0XF6,0X66,

55390XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

55400XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XF6,0X67,

55410XF6,0X87,0XFE,0XA8,0XFE,0XA9,0XFE,0XAA,0XDD,0X67,0XCD,0X06,0XC5,0X27,0XC5,0X28,

55420XB4,0XC9,0XBD,0X6E,0XFF,0X79,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

55490XFF,0XFD,0XF7,0X78,0XDE,0X0E,0XDD,0XCA,0XED,0XE9,0XED,0XE7,0XE5,0XE7,0XE6,0X06,

55500XE6,0X26,0XE6,0X26,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

55510XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X26,0XEE,0X47,0XEE,0X27,0XEE,0X29,

55520XF6,0X6A,0XC5,0X07,0X7B,0X00,0X62,0X40,0X5A,0X21,0X5A,0X22,0X52,0X03,0X52,0X23,

55530X52,0X23,0X52,0X23,0X52,0X23,0X52,0X42,0X52,0X42,0X52,0X23,0X52,0X03,0X49,0XE4,

55540X7B,0XAC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

55550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55560XFF,0XFE,0XFF,0X99,0XCD,0XCD,0XD5,0XC9,0XF6,0X49,0XF6,0X47,0XFE,0X47,0XFE,0X47,

55570XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X66,0XF6,0X66,0XF6,0X67,0XF6,0X67,

55580XFE,0X47,0XFE,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,

55590XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X88,0XFE,0X87,0XF6,0X87,0XFE,0XA8,

55600XFE,0XAA,0XFE,0X8A,0XD5,0X46,0XCD,0X26,0XCD,0X47,0XC5,0X48,0XB4,0XE9,0XCE,0X11,

55610XFF,0XDB,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0X99,

55680XDE,0X70,0XDD,0XCA,0XED,0XE9,0XED,0XC7,0XEE,0X07,0XE6,0X06,0XEE,0X26,0XEE,0X26,

55690XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

55700XEE,0X27,0XEE,0X27,0XEE,0X26,0XEE,0X47,0XEE,0X27,0XEE,0X28,0XF6,0X4A,0XCD,0X68,

55710X83,0X01,0X62,0X40,0X5A,0X21,0X52,0X22,0X52,0X02,0X52,0X03,0X52,0X03,0X52,0X03,

55720X52,0X02,0X52,0X22,0X4A,0X22,0X4A,0X22,0X4A,0X03,0X49,0XE3,0X62,0XC8,0XFF,0XDD,

55730XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0X79,

55750XCD,0XAD,0XD5,0XC9,0XF6,0X69,0XF6,0X27,0XFE,0X47,0XFE,0X67,0XF6,0X67,0XF6,0X67,

55760XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,

55770XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

55780XFE,0X67,0XFE,0X67,0XFE,0X88,0XF6,0X87,0XFE,0X88,0XFE,0XC9,0XFE,0X8A,0XF6,0X4A,

55790XD5,0X46,0XD5,0X67,0XCD,0X67,0XC5,0X68,0XBD,0X2B,0XE6,0XB4,0XFF,0XDC,0XFF,0XFE,

55800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDA,0XEE,0XB1,0XDD,0XEB,

55870XE5,0XE9,0XE5,0XC7,0XEE,0X27,0XEE,0X26,0XEE,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X27,

55880XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

55890XEE,0X26,0XEE,0X47,0XEE,0X27,0XEE,0X28,0XF6,0X4A,0XDD,0XC9,0X83,0X41,0X62,0X40,

55900X5A,0X21,0X52,0X02,0X52,0X02,0X52,0X03,0X52,0X03,0X4A,0X03,0X4A,0X02,0X4A,0X02,

55910X4A,0X01,0X4A,0X02,0X4A,0X02,0X49,0XC3,0X4A,0X05,0XEF,0X1A,0XFF,0XBE,0XFF,0XFF,

55920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0X78,0XCD,0XAD,0XDD,0XCA,

55940XF6,0X49,0XF6,0X27,0XFE,0X47,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

55950XF6,0X66,0XF6,0X66,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X67,

55960XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

55970XFE,0X68,0XF6,0X87,0XFE,0X88,0XFE,0XC9,0XFE,0X8A,0XED,0XE8,0XD5,0X47,0XDD,0X88,

55980XD5,0X86,0XC5,0X68,0XCD,0XAD,0XF7,0X37,0XFF,0XDC,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

55990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56050XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XEE,0XF3,0XDD,0XEC,0XE5,0XE9,0XE5,0XC7,

56060XEE,0X27,0XEE,0X26,0XEE,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,

56070XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X26,0XF6,0X47,

56080XEE,0X47,0XF6,0X48,0XF6,0X69,0XE6,0X2A,0X8B,0X82,0X62,0X40,0X5A,0X21,0X51,0XE1,

56090X52,0X02,0X49,0XE3,0X52,0X03,0X52,0X03,0X52,0X22,0X4A,0X22,0X4A,0X01,0X4A,0X22,

56100X4A,0X02,0X49,0XC3,0X39,0X83,0XD6,0X57,0XF7,0X7D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56120XFF,0XFF,0XFF,0XFF,0XFF,0XBD,0XFF,0X58,0XCD,0XAD,0XDD,0XC9,0XF6,0X69,0XF6,0X07,

56130XFE,0X47,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X66,0XF6,0X66,

56140XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

56150XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,

56160XFE,0X88,0XFE,0XCA,0XFE,0X8A,0XE5,0XA8,0XDD,0X67,0XDD,0XC9,0XD5,0X87,0XC5,0X89,

56170XD6,0X30,0XFF,0X99,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56240XFF,0XFD,0XFF,0XFB,0XF7,0X55,0XDE,0X4E,0XDD,0XEA,0XE6,0X08,0XEE,0X27,0XEE,0X06,

56250XF6,0X06,0XF6,0X06,0XEE,0X07,0XEE,0X27,0XEE,0X26,0XEE,0X26,0XEE,0X26,0XF6,0X26,

56260XF6,0X27,0XF6,0X28,0XEE,0X28,0XEE,0X47,0XEE,0X47,0XEE,0X46,0XEE,0X46,0XEE,0X47,

56270XEE,0X48,0XEE,0X6A,0XAC,0X65,0X62,0X60,0X52,0X00,0X52,0X01,0X52,0X23,0X49,0XE2,

56280X4A,0X03,0X4A,0X03,0X4A,0X02,0X4A,0X01,0X4A,0X02,0X49,0XE1,0X49,0XC2,0X41,0XC2,

56290X41,0XA2,0XA4,0XB0,0XFF,0XFF,0XFF,0XDF,0XF7,0XBF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

56310XFF,0XDE,0XF7,0X17,0XCD,0X8B,0XE6,0X0A,0XEE,0X28,0XFE,0X47,0XFE,0X67,0XF6,0X46,

56320XF6,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X66,0XF6,0X66,0XF6,0X67,0XF6,0X67,

56330XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

56340XFE,0X87,0XFE,0X67,0XFE,0X87,0XFE,0X88,0XFE,0X67,0XFE,0X88,0XFE,0XA9,0XFE,0XAA,

56350XF6,0X2A,0XE5,0XC9,0XDD,0X88,0XDD,0XC9,0XD5,0XA8,0XCD,0XAB,0XEE,0XF4,0XFF,0XDB,

56360XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFC,

56430XFF,0X98,0XE6,0XB1,0XDE,0X0B,0XDD,0XE8,0XEE,0X47,0XEE,0X06,0XF6,0X06,0XF6,0X06,

56440XEE,0X27,0XEE,0X27,0XEE,0X46,0XEE,0X26,0XF6,0X26,0XF6,0X26,0XF6,0X27,0XF6,0X28,

56450XEE,0X28,0XEE,0X47,0XEE,0X47,0XEE,0X46,0XEE,0X46,0XEE,0X47,0XEE,0X48,0XF6,0X8A,

56460XBC,0XE6,0X72,0XC0,0X5A,0X20,0X51,0XE1,0X52,0X22,0X4A,0X03,0X4A,0X03,0X4A,0X02,

56470X4A,0X02,0X4A,0X01,0X4A,0X01,0X4A,0X02,0X49,0XE2,0X49,0XC2,0X41,0XA2,0X7B,0X4A,

56480XFF,0XBD,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDE,0XEE,0XF7,

56500XC5,0X6A,0XE6,0X09,0XF6,0X48,0XFE,0X47,0XFE,0X47,0XFE,0X46,0XF6,0X66,0XF6,0X66,

56510XF6,0X67,0XF6,0X67,0XF6,0X66,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XFE,0X68,0XFE,0X67,

56520XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

56530XFE,0X87,0XFE,0X87,0XFE,0X68,0XFE,0X88,0XFE,0XAA,0XFE,0X8A,0XF6,0X4A,0XE5,0XC9,

56540XE5,0XE9,0XDD,0XEA,0XD5,0XCA,0XDE,0X4F,0XFF,0X77,0XFF,0XFC,0XFF,0XFF,0XFF,0XFF,

56550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XDA,0XF7,0X14,

56620XDE,0X2C,0XE6,0X28,0XEE,0X47,0XEE,0X26,0XF6,0X26,0XF6,0X26,0XEE,0X27,0XEE,0X27,

56630XEE,0X46,0XEE,0X46,0XF6,0X26,0XF6,0X26,0XF6,0X27,0XF6,0X28,0XF6,0X28,0XEE,0X47,

56640XEE,0X47,0XEE,0X46,0XEE,0X46,0XEE,0X47,0XF6,0X48,0XF6,0X8A,0XD5,0XA8,0X8B,0X61,

56650X62,0X40,0X52,0X00,0X5A,0X42,0X52,0X22,0X52,0X23,0X4A,0X22,0X4A,0X22,0X4A,0X22,

56660X52,0X22,0X52,0X22,0X52,0X02,0X51,0XE2,0X49,0XE3,0X52,0X25,0XE6,0XF9,0XFF,0XDE,

56670XFF,0XFE,0XFF,0XFE,0XFF,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XBD,0XEE,0XD6,0XC5,0X49,0XE6,0X08,

56690XFE,0X68,0XFE,0X67,0XF6,0X26,0XFE,0X67,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X67,

56700XF6,0X66,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

56710XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X88,

56720XFE,0X88,0XFE,0XA9,0XFE,0XAA,0XFE,0X8A,0XF6,0X49,0XEE,0X29,0XE6,0X09,0XE6,0X2B,

56730XDE,0X0C,0XF6,0XF3,0XFF,0XFA,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56800XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XDE,0XFF,0XFC,0XFF,0X56,0XDE,0X4D,0XE6,0X49,

56810XEE,0X26,0XF6,0X46,0XF6,0X26,0XF6,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X46,0XEE,0X46,

56820XF6,0X26,0XF6,0X26,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,0XF6,0X67,0XF6,0X47,

56830XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X89,0XE6,0X09,0XA4,0X03,0X72,0XA0,0X5A,0X20,

56840X5A,0X62,0X52,0X42,0X5A,0X63,0X5A,0X63,0X52,0X42,0X52,0X42,0X52,0X42,0X5A,0X42,

56850X52,0X22,0X52,0X22,0X52,0X23,0X4A,0X04,0XB5,0X93,0XFF,0XFD,0XFF,0XDD,0XFF,0XDD,

56860XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56870XFF,0XFF,0XFF,0XFE,0XFF,0X7B,0XE6,0X94,0XC5,0X69,0XE6,0X28,0XFE,0X88,0XFE,0X47,

56880XFE,0X46,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X66,

56890XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

56900XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X88,0XFE,0XA9,0XFE,0XCA,

56910XFE,0XAA,0XF6,0X69,0XF6,0X68,0XEE,0X48,0XEE,0X29,0XE6,0X2B,0XE6,0X90,0XFF,0X97,

56920XFF,0XFC,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

56980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

56990XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0X99,0XEE,0XCF,0XE6,0X49,0XE6,0X26,0XF6,0X46,

57000XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,0XEE,0X46,0XF6,0X46,0XF6,0X46,0XF6,0X46,

57010XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

57020XF6,0X47,0XF6,0X89,0XF6,0X6A,0XBC,0XC5,0X83,0X41,0X62,0X60,0X62,0X61,0X62,0X82,

57030X62,0X83,0X5A,0X83,0X5A,0X83,0X5A,0X83,0X5A,0X63,0X62,0X62,0X62,0X42,0X5A,0X42,

57040X52,0X43,0X52,0X64,0X83,0XEC,0XFF,0XBC,0XFF,0XDC,0XFF,0XFE,0XFF,0XFE,0XFF,0XDF,

57050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

57060XFF,0X9A,0XD6,0X11,0XCD,0X69,0XEE,0X48,0XFE,0X88,0XFE,0X46,0XFE,0X67,0XFE,0X67,

57070XFE,0X67,0XFE,0X67,0XF6,0X68,0XF6,0X68,0XFE,0X67,0XFE,0X66,0XFE,0X67,0XFE,0X67,

57080XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X67,

57090XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0XA9,0XFE,0XCA,0XF6,0X8A,0XEE,0X49,

57100XF6,0X68,0XEE,0X47,0XEE,0X6A,0XDE,0X2C,0XFF,0X55,0XFF,0XDB,0XFF,0XDD,0XFF,0XFF,

57110XF7,0XFF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

57180XFF,0XFF,0XFF,0XDB,0XFF,0X53,0XDE,0X2A,0XEE,0X48,0XEE,0X26,0XF6,0X27,0XF6,0X27,

57190XF6,0X27,0XEE,0X47,0XF6,0X46,0XF6,0X46,0XF6,0X46,0XF6,0X46,0XF6,0X47,0XF6,0X47,

57200XF6,0X67,0XF6,0X66,0XF6,0X66,0XF6,0X46,0XF6,0X47,0XF6,0X47,0XFE,0X68,0XEE,0X28,

57210XFE,0XAB,0XDD,0XC8,0X93,0XC2,0X72,0XC0,0X72,0XE2,0X6A,0XA2,0X6A,0XC3,0X6A,0XC3,

57220X6A,0XA3,0X62,0XA3,0X6A,0XA3,0X6A,0XA3,0X6A,0XA3,0X6A,0XA3,0X62,0X84,0X5A,0X84,

57230X6B,0X28,0XD6,0X96,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

57240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0X99,0XC5,0X8D,

57250XCD,0X88,0XEE,0X48,0XFE,0X87,0XF6,0X45,0XFE,0X66,0XFE,0X67,0XFE,0X67,0XFE,0X67,

57260XF6,0X68,0XF6,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

57270XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X87,0XFE,0X87,

57280XFE,0X87,0XFE,0X87,0XFE,0XC9,0XFE,0XAA,0XF6,0X8A,0XEE,0X69,0XEE,0X67,0XEE,0X89,

57290XE6,0X4A,0XEE,0XF1,0XFF,0XB9,0XFF,0XDD,0XF7,0XDE,0XF7,0XFF,0XF7,0XFE,0XF7,0XFF,

57300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57360XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,

57370XFF,0XB6,0XEE,0XAE,0XE6,0X49,0XEE,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X47,

57380XF6,0X46,0XF6,0X46,0XF6,0X46,0XF6,0X46,0XF6,0X46,0XF6,0X66,0XF6,0X66,0XF6,0X66,

57390XF6,0X66,0XF6,0X66,0XF6,0X47,0XF6,0X47,0XFE,0X88,0XEE,0X07,0XFE,0XAA,0XF6,0X6B,

57400XB4,0X84,0X8B,0X61,0X83,0X42,0X73,0X02,0X73,0X24,0X73,0X24,0X73,0X05,0X73,0X05,

57410X73,0X04,0X7A,0XE4,0X7A,0XE4,0X7A,0XE4,0X73,0X05,0X72,0XE5,0X6A,0XE6,0XA4,0XCE,

57420XFF,0XBB,0XFF,0XFD,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57430XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XF7,0X16,0XBD,0X2A,0XDD,0XE9,0XEE,0X68,

57440XFE,0XA7,0XF6,0X45,0XFE,0X66,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XF6,0X68,0XF6,0X68,

57450XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

57460XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0XA7,

57470XFE,0XA8,0XFE,0XA9,0XF6,0X89,0XEE,0X89,0XE6,0X68,0XEE,0XAB,0XE6,0X8D,0XFF,0XB6,

57480XFF,0XBB,0XFF,0XDE,0XFF,0XFF,0XF7,0XFF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57550XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDD,0XFF,0XB9,0XFF,0X53,

57560XDE,0X2B,0XEE,0X49,0XEE,0X28,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X46,

57570XF6,0X46,0XF6,0X46,0XF6,0X46,0XF6,0X46,0XF6,0X66,0XF6,0X66,0XF6,0X66,0XF6,0X66,

57580XF6,0X66,0XF6,0X67,0XF6,0X47,0XF6,0X68,0XF6,0X69,0XF6,0X6A,0XD5,0X67,0XA4,0X03,

57590X83,0X21,0X83,0X63,0X83,0X64,0X83,0X65,0X83,0X65,0X83,0X45,0X83,0X45,0X83,0X45,

57600X83,0X25,0X83,0X24,0X83,0X25,0X8B,0X87,0X62,0XA4,0X8B,0XC9,0XDE,0X95,0XFF,0XFC,

57610XFF,0XDE,0XFF,0XFF,0XF7,0XBF,0XFF,0XDF,0XF7,0XDF,0XF7,0XDF,0XFF,0XFF,0XFF,0XFE,

57620XFF,0XFD,0XFF,0XD9,0XE6,0X72,0XBD,0X08,0XEE,0X4A,0XF6,0X67,0XFE,0X87,0XF6,0X45,

57630XFE,0X66,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X87,

57640XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

57650XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X87,0XFE,0X87,0XFE,0XA8,0XF6,0X88,

57660XEE,0X69,0XEE,0X8A,0XEE,0XAB,0XD6,0X0B,0XFF,0X74,0XFF,0XD9,0XFF,0XDD,0XFF,0XFF,

57670XF7,0XDF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XFF,0X97,0XEE,0XD0,0XE6,0X2B,

57750XEE,0X28,0XF6,0X68,0XF6,0X47,0XF6,0X26,0XF6,0X46,0XF6,0X46,0XF6,0X26,0XFE,0X47,

57760XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X66,0XF6,0X66,0XF6,0X66,0XF6,0X67,

57770XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X69,0XEE,0X29,0XC5,0X05,0X9B,0XC2,0X93,0XC3,

57780X93,0XE5,0X8B,0X84,0X93,0XE6,0X8B,0XA5,0X8B,0XA5,0X93,0XA6,0X93,0X85,0X93,0X85,

57790X93,0XA5,0X83,0X24,0X8B,0XA6,0X83,0X87,0XAD,0X0E,0XEF,0X58,0XFF,0XDD,0XFF,0XFE,

57800XFF,0XFF,0XFF,0XFF,0XF7,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBA,0XFF,0X97,

57810XBD,0X2B,0XCD,0X89,0XEE,0X69,0XF6,0X67,0XF6,0X66,0XFE,0X86,0XFE,0X66,0XFE,0X67,

57820XFE,0X68,0XFE,0X68,0XFE,0X68,0XF6,0X68,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,

57830XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X66,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,

57840XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0XA8,0XF6,0XA8,0XF6,0XA9,0XF6,0X88,0XE6,0X69,

57850XE6,0X6C,0XF7,0X32,0XFF,0XB8,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

57920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XFF,0XFF,

57930XFF,0XFF,0XFF,0XDD,0XFF,0XDD,0XFF,0XDA,0XFF,0X55,0XEE,0XAE,0XE6,0X29,0XF6,0X68,

57940XF6,0X47,0XF6,0X26,0XF6,0X46,0XFE,0X46,0XF6,0X27,0XF6,0X48,0XF6,0X48,0XF6,0X48,

57950XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X47,

57960XF6,0X47,0XF6,0X68,0XF6,0X89,0XDD,0XE8,0XBC,0XC4,0X9C,0X02,0XA4,0X25,0X9C,0X25,

57970X9C,0X05,0XA4,0X47,0X9C,0X06,0X9C,0X06,0X9C,0X05,0XA4,0X05,0XA3,0XC5,0X9B,0XC5,

57980XA4,0X27,0X8B,0XA6,0X8B,0XE8,0XC5,0XD1,0XF7,0X79,0XFF,0XDD,0XFF,0XFF,0XF7,0XBE,

57990XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFD,0XFF,0XFA,0XDE,0X50,0XAC,0XA7,0XE6,0X2A,

58000XF6,0XA9,0XF6,0X87,0XF6,0X66,0XFE,0X66,0XFE,0X67,0XFE,0X47,0XFE,0X68,0XFE,0X68,

58010XFE,0X68,0XF6,0X88,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

58020XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X87,0XFE,0X67,0XFE,0X68,0XFE,0X88,0XFE,0X88,

58030XFE,0X88,0XF6,0X88,0XF6,0XA9,0XF6,0XCA,0XF6,0XAA,0XE6,0X4B,0XF7,0X11,0XFF,0X97,

58040XFF,0XDB,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,

58120XFF,0XDE,0XFF,0XFD,0XFF,0XB9,0XF7,0X33,0XE6,0X6B,0XEE,0X68,0XEE,0X67,0XF6,0X87,

58130XF6,0X46,0XFE,0X46,0XFE,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X68,

58140XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X87,0XF6,0X67,0XF6,0X67,0XF6,0X87,0XF6,0X88,

58150XF6,0X68,0XEE,0X48,0XDD,0XC7,0XBC,0XC4,0XAC,0X64,0XB4,0XA6,0XAC,0X85,0XAC,0X86,

58160XAC,0X66,0XAC,0X66,0XAC,0X45,0XAC,0X45,0XAC,0X45,0XAC,0X25,0XA4,0X25,0X9C,0X46,

58170X94,0X06,0X94,0X69,0XCE,0X12,0XF7,0X9A,0XFF,0XFE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDE,

58180XFF,0XDD,0XFF,0XFB,0XF7,0X55,0XB5,0X09,0XCD,0X68,0XF6,0X6A,0XEE,0X47,0XF6,0X87,

58190XFE,0XA6,0XF6,0X45,0XFE,0X46,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XF6,0X68,0XF6,0X87,

58200XF6,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,

58210XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0XA8,0XF6,0XA9,

58220XF6,0X8A,0XEE,0X6B,0XEE,0X8D,0XF6,0XF0,0XFF,0X96,0XFF,0XDB,0XFF,0XFE,0XFF,0XFF,

58230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDF,0XFF,0XFE,

58310XFF,0XDB,0XFF,0XB7,0XEE,0XCF,0XE6,0X49,0XEE,0X68,0XF6,0XA8,0XF6,0X26,0XF6,0X26,

58320XFE,0X68,0XF6,0X28,0XF6,0X49,0XF6,0X49,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XF6,0X68,

58330XF6,0X67,0XF6,0X67,0XF6,0X87,0XF6,0X87,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X88,

58340XF6,0XA9,0XDD,0XE7,0XBC,0XE4,0XB4,0XC4,0XB4,0XE6,0XAC,0XA5,0XB4,0XA5,0XB4,0XA6,

58350XB4,0X85,0XB4,0X65,0XB4,0X85,0XB4,0X45,0XAC,0X45,0XA4,0X45,0X9C,0X25,0X94,0X46,

58360X9C,0X69,0XB5,0X6F,0XE6,0XF8,0XFF,0XDD,0XFF,0XFD,0XFF,0XBC,0XFF,0XDB,0XFF,0X97,

58370XCD,0XAD,0XB4,0XE7,0XF6,0X6B,0XF6,0X69,0XEE,0X47,0XF6,0X66,0XF6,0X66,0XFE,0X87,

58380XFE,0X67,0XFE,0X48,0XFE,0X68,0XFE,0X68,0XF6,0X88,0XF6,0X87,0XF6,0X87,0XFE,0X87,

58390XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X88,0XFE,0X87,

58400XFE,0X87,0XFE,0X87,0XFE,0XA7,0XFE,0XA7,0XF6,0XA8,0XF6,0XAA,0XEE,0XAC,0XE6,0X8D,

58410XEE,0XD1,0XFF,0X76,0XFF,0XBA,0XFF,0XDD,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

58420XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58490XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFA,

58500XFF,0X74,0XEE,0XAE,0XE6,0X6A,0XF6,0X89,0XF6,0X67,0XFE,0X47,0XFE,0X68,0XFE,0X48,

58510XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XF6,0X68,0XF6,0X67,

58520XF6,0X87,0XF6,0X87,0XF6,0X66,0XF6,0X87,0XF6,0X67,0XFE,0XA8,0XFF,0X0A,0XFE,0XEA,

58530XDE,0X07,0XBD,0X04,0XB5,0X04,0XBD,0X05,0XBC,0XE5,0XB4,0XC5,0XBC,0XC5,0XB4,0X84,

58540XB4,0X64,0XBC,0XC5,0XA4,0X03,0XAC,0X65,0X9C,0X44,0X8B,0XE4,0X94,0X27,0X7B,0X66,

58550X94,0X0A,0XCD,0XF3,0XF7,0X58,0XFF,0XB9,0XFF,0X97,0XDE,0X30,0XA4,0X65,0XE6,0X0A,

58560XFE,0X8A,0XF6,0X47,0XFE,0X87,0XF6,0X66,0XF6,0X46,0XFE,0X87,0XFE,0X88,0XFE,0X48,

58570XFE,0X68,0XFE,0X68,0XF6,0X87,0XF6,0X87,0XF6,0X87,0XF6,0X87,0XFE,0X67,0XFE,0X67,

58580XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X88,

58590XF6,0X87,0XFE,0XC9,0XF6,0XCA,0XEE,0XAB,0XE6,0XAE,0XEE,0XF2,0XFF,0X56,0XFF,0XBB,

58600XFF,0XDD,0XFF,0XDE,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

58610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

58680XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XD9,0XF7,0X33,

58690XE6,0X6C,0XE6,0X29,0XF6,0X88,0XFE,0X87,0XFE,0X47,0XFE,0X87,0XFE,0X67,0XFE,0X68,

58700XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XF6,0X67,0XF6,0X66,0XF6,0X87,

58710XF6,0X87,0XF6,0X87,0XF6,0X87,0XF6,0X87,0XFE,0XA8,0XFF,0X0A,0XFE,0XEA,0XE6,0X48,

58720XBD,0X24,0XBD,0X04,0XBC,0XE4,0XB4,0XC4,0XB4,0XA4,0XB4,0X84,0XB4,0X64,0XB4,0X64,

58730XA4,0X24,0XA4,0X24,0X9C,0X03,0X93,0XC3,0X8B,0XA4,0X8B,0X85,0X83,0X66,0X72,0XE4,

58740X7B,0X25,0XBD,0X2C,0XC5,0X8C,0XBD,0X29,0XE6,0X0A,0XEE,0X49,0XF6,0X88,0XF6,0X47,

58750XF6,0X67,0XFE,0X87,0XFE,0XA7,0XF6,0X46,0XFE,0X48,0XFE,0X69,0XFE,0X68,0XFE,0X68,

58760XF6,0X87,0XF6,0X87,0XF6,0X87,0XF6,0X87,0XFE,0X67,0XFE,0X68,0XFE,0X67,0XFE,0X67,

58770XFE,0X67,0XFE,0X67,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0XA8,0XF6,0XC9,0XF6,0XCA,

58780XEE,0XAB,0XE6,0XAD,0XEE,0XF1,0XF7,0X56,0XFF,0XBA,0XFF,0XFE,0XFF,0XBE,0XFF,0XDF,

58790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

58800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58870XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XF7,0XFD,0XFF,0XDC,0XFF,0X98,0XEE,0XD0,0XE6,0X4B,

58880XF6,0X69,0XF6,0X67,0XF6,0X46,0XFE,0X66,0XFE,0X66,0XFE,0X66,0XFE,0X67,0XFE,0X67,

58890XFE,0X48,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0XA8,0XF6,0X87,0XF6,0X66,0XF6,0X67,

58900XFE,0X87,0XFE,0X87,0XF6,0X67,0XF6,0X88,0XFF,0X0A,0XFF,0X4C,0XDE,0X28,0XCD,0X86,

58910XBD,0X05,0XB4,0XC4,0XB4,0XA3,0XB4,0X83,0XAC,0X42,0XB4,0X44,0XA4,0X24,0X93,0XA3,

58920X93,0X82,0X8B,0X41,0X83,0X21,0X83,0X22,0X72,0XC2,0X62,0X40,0X6A,0X80,0X83,0X62,

58930XBC,0XE7,0XE6,0X0A,0XF6,0X6A,0XF6,0X69,0XF6,0X67,0XFE,0X87,0XF6,0X66,0XFE,0X87,

58940XFE,0X87,0XFE,0X47,0XFE,0X48,0XFE,0X48,0XFE,0X68,0XFE,0X68,0XF6,0X87,0XF6,0X87,

58950XF6,0X87,0XF6,0X87,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,

58960XFE,0X87,0XFE,0X88,0XFE,0X88,0XF6,0XA9,0XFE,0XEC,0XEE,0X8C,0XE6,0X8D,0XEE,0XF1,

58970XFF,0X96,0XFF,0XFA,0XFF,0XFC,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

58980XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

58990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59050XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59060XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XFF,0X76,0XF6,0XD0,0XEE,0X6B,0XF6,0X89,

59070XFE,0XA8,0XFE,0X87,0XFE,0X66,0XFE,0X66,0XFE,0X66,0XFE,0X67,0XFE,0X48,0XFE,0X48,

59080XFE,0X68,0XFE,0X68,0XF6,0X87,0XF6,0X87,0XF6,0X87,0XF6,0X67,0XFE,0X88,0XFE,0X88,

59090XF6,0X68,0XFE,0XA9,0XFE,0XEA,0XFF,0X0B,0XFF,0X6D,0XEE,0XAA,0XCD,0X86,0XBD,0X04,

59100XBC,0XE4,0XAC,0X63,0XAC,0X42,0X9B,0XE1,0X9B,0XC3,0X9B,0XA3,0X93,0X81,0X83,0X00,

59110X7A,0XE0,0X72,0X80,0X72,0XA0,0X8B,0X81,0XAC,0X84,0XCD,0X67,0XE6,0X29,0XEE,0X49,

59120XFE,0X89,0XFE,0X88,0XFE,0X67,0XFE,0X87,0XF6,0X67,0XFE,0X87,0XFE,0X67,0XFE,0X67,

59130XFE,0X68,0XFE,0X48,0XFE,0X68,0XFE,0X68,0XF6,0X87,0XF6,0X87,0XF6,0X87,0XFE,0X68,

59140XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X87,0XFE,0X87,0XFE,0XA7,0XFE,0XA7,0XF6,0XA8,

59150XF6,0X8A,0XF6,0X8B,0XE6,0X4C,0XEE,0X8F,0XF7,0X33,0XFF,0XB7,0XFF,0XDA,0XFF,0XFC,

59160XFF,0XFE,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

59170XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59250XFF,0XFE,0XFF,0XDC,0XFF,0XDA,0XFF,0X95,0XF6,0XF0,0XE6,0X6B,0XEE,0X69,0XF6,0X88,

59260XF6,0X67,0XFE,0X66,0XFE,0X46,0XFE,0X67,0XFE,0X88,0XFE,0X68,0XFE,0X48,0XFE,0X68,

59270XF6,0X67,0XF6,0X67,0XF6,0X87,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XF6,0X88,

59280XF6,0X89,0XF6,0XA9,0XFE,0XEB,0XFF,0X2C,0XFF,0X2C,0XEE,0X8A,0XCD,0X87,0XBC,0XC4,

59290XAC,0X83,0XAC,0X42,0XA4,0X02,0X93,0XC1,0X93,0X81,0X93,0X81,0X9B,0XC2,0XA4,0X02,

59300XC5,0X05,0XD5,0XA7,0XEE,0X48,0XEE,0X68,0XF6,0X68,0XF6,0X68,0XFE,0X68,0XFE,0X68,

59310XFE,0X88,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,

59320XFE,0X68,0XFE,0X67,0XF6,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X69,0XFE,0X49,0XFE,0X49,

59330XFE,0X67,0XFE,0X66,0XFE,0X86,0XF6,0XA7,0XFE,0XA8,0XF6,0XAA,0XEE,0XAC,0XEE,0X8E,

59340XEE,0XB2,0XF7,0X36,0XFF,0XB9,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

59350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDD,

59440XFF,0XFC,0XFF,0XD9,0XFF,0X55,0XEE,0XD0,0XEE,0X8C,0XEE,0X6A,0XF6,0X68,0XFE,0X87,

59450XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X48,0XFE,0X48,0XFE,0X69,0XFE,0X88,0XFE,0X88,

59460XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

59470XF6,0X68,0XF6,0XA9,0XFF,0X0B,0XFF,0X4C,0XFF,0X2C,0XFE,0XEB,0XEE,0X6A,0XE6,0X29,

59480XDD,0XE8,0XD5,0XA8,0XD5,0XC8,0XE5,0XE9,0XEE,0X4A,0XF6,0X8A,0XF6,0X8A,0XF6,0X68,

59490XF6,0X47,0XF6,0X67,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X87,0XFE,0X87,

59500XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X67,

59510XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X69,0XFE,0X6A,0XFE,0X69,0XFE,0X68,0XFE,0X88,

59520XFE,0XA8,0XF6,0XA9,0XEE,0X8A,0XEE,0X8C,0XEE,0XCF,0XF7,0X13,0XFF,0X98,0XFF,0XBB,

59530XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFC,

59630XFF,0XDA,0XFF,0X76,0XF6,0XF1,0XEE,0X8D,0XEE,0X69,0XEE,0X68,0XF6,0X87,0XFE,0X87,

59640XFE,0X87,0XFE,0X88,0XFE,0X69,0XFE,0X49,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X88,

59650XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0XA7,0XFE,0XA7,0XF6,0X87,0XF6,0X87,0XF6,0X88,

59660XF6,0X88,0XEE,0X68,0XF6,0X88,0XFE,0XCA,0XFF,0X2C,0XFF,0X2C,0XFF,0X0C,0XFF,0X0C,

59670XFE,0XEB,0XFE,0XCA,0XF6,0X89,0XEE,0X48,0XEE,0X27,0XF6,0X68,0XFE,0X88,0XFE,0X88,

59680XFE,0X87,0XFE,0X87,0XFE,0X66,0XFE,0X66,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,

59690XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,

59700XFE,0X68,0XFE,0X68,0XF6,0X88,0XF6,0X89,0XFE,0X89,0XF6,0X89,0XEE,0X8A,0XEE,0XAC,

59710XEE,0XAE,0XF6,0XF1,0XFF,0X55,0XFF,0XB9,0XFF,0XDB,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,

59720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

59730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59800XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

59810XFF,0XDF,0XFF,0XDE,0XFF,0XFF,0XFF,0XDE,0XFF,0XBE,0XFF,0XDE,0XFF,0XDD,0XFF,0XBA,

59820XFF,0X76,0XF7,0X12,0XEE,0XCD,0XEE,0X8A,0XF6,0XA8,0XFE,0XA8,0XFE,0X88,0XFE,0X68,

59830XFE,0X69,0XFE,0X69,0XFE,0X68,0XFE,0X87,0XFE,0X88,0XFE,0X87,0XFE,0X87,0XFE,0X87,

59840XFE,0X87,0XFE,0XA7,0XF6,0X86,0XFE,0XA7,0XF6,0X87,0XF6,0X66,0XF6,0X67,0XFE,0XA8,

59850XFE,0XC9,0XF6,0XA9,0XEE,0X48,0XEE,0X48,0XEE,0X68,0XEE,0X68,0XF6,0X88,0XF6,0X88,

59860XF6,0X88,0XF6,0XA8,0XF6,0X88,0XFE,0XA9,0XFE,0XA9,0XF6,0X67,0XF6,0X46,0XFE,0X86,

59870XFE,0XA6,0XFE,0X86,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X67,

59880XFE,0X67,0XFE,0X67,0XFE,0X66,0XFE,0X66,0XFE,0X67,0XFE,0X68,0XFE,0X88,0XF6,0X89,

59890XF6,0XA9,0XF6,0XCA,0XEE,0X8B,0XEE,0X8C,0XEE,0XAE,0XF7,0X11,0XFF,0X55,0XFF,0X98,

59900XFF,0XDA,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59910XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

59980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

59990XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,

60000XF7,0X9D,0XF7,0X9D,0XFF,0XBE,0XF7,0X9E,0XF7,0X7E,0XFF,0X7C,0XFF,0X7A,0XFF,0X77,

60010XF7,0X33,0XEE,0XAE,0XE6,0X8B,0XEE,0X69,0XF6,0X69,0XFE,0X89,0XFE,0X89,0XFE,0X69,

60020XFE,0X87,0XFE,0X86,0XFE,0X67,0XFE,0X87,0XFE,0XA7,0XFE,0XA7,0XFE,0X87,0XF6,0X66,

60030XF6,0X86,0XF6,0X86,0XF6,0X87,0XFE,0XC8,0XFE,0XA9,0XF6,0X68,0XF6,0X28,0XF6,0X49,

60040XF6,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0XA8,0XF6,0XA7,0XF6,0X87,0XF6,0X87,0XF6,0X87,

60050XF6,0X68,0XF6,0X47,0XF6,0X47,0XFE,0X68,0XFE,0X87,0XFE,0X86,0XFE,0X66,0XFE,0X66,

60060XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X87,0XFE,0X87,

60070XFE,0X87,0XFE,0X67,0XFE,0X67,0XF6,0X68,0XF6,0X68,0XEE,0X69,0XEE,0X8A,0XEE,0XAC,

60080XEE,0XCE,0XF7,0X11,0XFF,0X75,0XFF,0XB8,0XFF,0XDA,0XFF,0XDC,0XFF,0XDD,0XFF,0XDE,

60090XFF,0XFE,0XFF,0XDE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBF,

60100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

60170XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,

60180XF7,0X9E,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X5C,0XEF,0X3C,0XEF,0X5C,

60190XEF,0X5D,0XEF,0X3D,0XE7,0X1D,0XE7,0X1C,0XEF,0X1B,0XEF,0X19,0XEE,0XF6,0XEE,0XF3,

60200XF6,0XF0,0XEE,0XAD,0XEE,0X6B,0XF6,0X6A,0XF6,0X6A,0XFE,0X69,0XFE,0X87,0XFE,0X86,

60210XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XF6,0X87,0XF6,0X87,0XF6,0X86,0XFE,0XA7,

60220XFE,0XA7,0XF6,0X87,0XF6,0X47,0XFE,0X68,0XFE,0X69,0XFE,0X69,0XF6,0X88,0XF6,0X68,

60230XF6,0X67,0XF6,0X87,0XF6,0X87,0XF6,0X87,0XFE,0X87,0XFE,0X87,0XFE,0XA8,0XFE,0X88,

60240XFE,0X88,0XFE,0X88,0XFE,0X87,0XFE,0X66,0XFE,0X66,0XFE,0X66,0XFE,0X67,0XFE,0X68,

60250XFE,0X68,0XF6,0X68,0XF6,0X88,0XF6,0X87,0XF6,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X88,

60260XFE,0X89,0XFE,0X8A,0XF6,0XAB,0XEE,0XAC,0XEE,0XCE,0XEE,0XF0,0XFF,0X74,0XFF,0XB7,

60270XFF,0XDA,0XFF,0XDB,0XFF,0XBD,0XFF,0XBE,0XFF,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

60280XF7,0XBE,0XF7,0XBE,0XF7,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

60290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,

60360XF7,0X9E,0XF7,0X9E,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XE7,0X3C,

60370XE7,0X3C,0XE7,0X3C,0XE7,0X1C,0XDE,0XFB,0XDE,0XFA,0XDE,0XDA,0XD6,0XBA,0XD6,0X9A,

60380XCE,0X7A,0XCE,0X5A,0XCE,0X59,0XC6,0X17,0XCE,0X15,0XCD,0XD3,0XC5,0XB0,0XCD,0XCE,

60390XE6,0X4E,0XF6,0X8E,0XF6,0X8D,0XF6,0X8B,0XF6,0X89,0XFE,0XA7,0XFE,0XA7,0XFE,0XA7,

60400XF6,0X87,0XF6,0X86,0XFE,0XA6,0XFE,0XA7,0XF6,0X86,0XF6,0X66,0XF6,0X66,0XFE,0X87,

60410XFE,0XA8,0XFE,0XA8,0XFE,0X88,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,

60420XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

60430XFE,0X87,0XFE,0XA8,0XFE,0XA8,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,

60440XF6,0X87,0XF6,0X87,0XF6,0X88,0XF6,0X89,0XFE,0X8A,0XF6,0X8B,0XF6,0X8C,0XF6,0X8E,

60450XEE,0X8F,0XEE,0XB1,0XEE,0XF3,0XEF,0X15,0XEF,0X57,0XEF,0X59,0XEF,0X5A,0XE7,0X3B,

60460XE7,0X3C,0XEF,0X3D,0XEF,0X5D,0XEF,0X5D,0XEF,0X9D,0XEF,0X9D,0XEF,0X9E,0XEF,0X9D,

60470XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,

60480XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

60490XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60540XFF,0XFF,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XEF,0X7D,0XEF,0X7D,

60550XEF,0X5D,0XEF,0X5D,0XE7,0X3C,0XE7,0X3C,0XE7,0X1C,0XDE,0XFB,0XDE,0XDB,0XDE,0XDB,

60560XD6,0XBA,0XD6,0X9A,0XCE,0X79,0XCE,0X58,0XC6,0X38,0XBD,0XF8,0XB5,0XD7,0XB5,0X97,

60570XAD,0X76,0XAD,0X55,0XAD,0X14,0XAC,0XF2,0XA4,0X8F,0XA4,0X8D,0XAC,0XAB,0XBD,0X0B,

60580XD5,0XCC,0XEE,0X6D,0XFE,0XCD,0XF6,0XAB,0XEE,0X89,0XEE,0X89,0XF6,0XA8,0XFE,0XC8,

60590XFE,0XA7,0XF6,0X87,0XF6,0X87,0XFE,0X87,0XFE,0XA7,0XFE,0X87,0XFE,0X87,0XFE,0X87,

60600XF6,0X86,0XF6,0X66,0XF6,0X66,0XFE,0X66,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XF6,0X67,

60610XFE,0X67,0XFE,0X87,0XFE,0X88,0XFE,0X87,0XFE,0X67,0XFE,0X87,0XFE,0X67,0XFE,0X67,

60620XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X87,0XF6,0X87,0XF6,0X88,0XF6,0XA9,

60630XF6,0XAA,0XF6,0XAC,0XF6,0XAD,0XEE,0X4E,0XDE,0X0E,0XD5,0XAE,0XC5,0X8F,0XC5,0X91,

60640XCD,0XD3,0XCE,0X35,0XC6,0X56,0XCE,0X77,0XCE,0X79,0XD6,0X9A,0XD6,0XBB,0XDE,0XDB,

60650XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XDF,0X1B,0XE7,0X3C,0XE7,0X3C,0XE7,0X3D,0XEF,0X5D,

60660XEF,0X5C,0XE7,0X5C,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,

60670XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

60680XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

60690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0X9E,

60730XF7,0X9E,0XF7,0X9E,0XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XE7,0X3C,

60740XE7,0X1C,0XE7,0X1C,0XDE,0XFB,0XDE,0XDB,0XD6,0XBA,0XD6,0XBA,0XD6,0X9A,0XCE,0X59,

60750XC6,0X38,0XBE,0X18,0XB5,0XD7,0XAD,0X96,0XAD,0X75,0XA5,0X34,0X9C,0XF3,0X9C,0XB3,

60760X94,0X52,0X8C,0X30,0X83,0XCE,0X83,0XCD,0X7B,0X49,0X73,0X47,0X83,0XA8,0X9C,0X49,

60770XC5,0X4B,0XD5,0XEC,0XEE,0X8D,0XF6,0XCD,0XEE,0XAB,0XEE,0X89,0XF6,0X89,0XFE,0XA9,

60780XF6,0X88,0XF6,0X67,0XFE,0X88,0XFE,0X88,0XF6,0X67,0XF6,0X87,0XFE,0XC7,0XF6,0X86,

60790XFE,0X86,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,

60800XF6,0X47,0XF6,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X88,0XFE,0X68,0XF6,0X48,0XFE,0X89,

60810XFE,0X88,0XF6,0X67,0XF6,0X67,0XF6,0X89,0XF6,0XAA,0XF6,0XCB,0XF6,0XAD,0XEE,0X8E,

60820XC5,0X4C,0X93,0XE8,0X6A,0XA5,0X5A,0X66,0X6A,0XC9,0X73,0X2B,0X7B,0X8C,0X83,0XCD,

60830X84,0X30,0X8C,0X91,0X9C,0XD3,0XA5,0X14,0XA5,0X35,0XAD,0X76,0XB5,0XB6,0XBD,0XD7,

60840XC6,0X17,0XCE,0X58,0XCE,0X79,0XD6,0X9A,0XD6,0XBA,0XD6,0XDA,0XDE,0XFA,0XDE,0XFB,

60850XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,

60860XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

60870XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

60880XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

60910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0X9E,0XEF,0X7D,

60920XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XEF,0X5D,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

60930XE7,0X1C,0XDE,0XFB,0XDE,0XDB,0XDE,0XDB,0XD6,0XBA,0XCE,0X9A,0XCE,0X59,0XC6,0X39,

60940XBE,0X17,0XB5,0XD6,0XB5,0X95,0XAD,0X55,0XA5,0X14,0X9C,0XF4,0X94,0X72,0X8C,0X31,

60950X7B,0XAF,0X73,0X6D,0X6B,0X2B,0X6B,0X09,0X5A,0X86,0X52,0X24,0X5A,0X44,0X73,0X26,

60960X9C,0X49,0XBD,0X4C,0XDE,0X2D,0XEE,0XAE,0XF6,0XAD,0XEE,0X6B,0XF6,0X6B,0XF6,0X8B,

60970XF6,0XAA,0XF6,0X89,0XF6,0X88,0XEE,0X67,0XEE,0X86,0XF6,0X86,0XF6,0XA7,0XF6,0X87,

60980XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XFE,0X89,0XFE,0XA9,

60990XF6,0X88,0XF6,0X68,0XF6,0X69,0XF6,0X6A,0XFE,0X8B,0XF6,0X6A,0XF6,0X8A,0XFE,0XAA,

61000XFE,0XCB,0XF6,0XAC,0XEE,0X6C,0XD5,0XEB,0XAC,0XA8,0X83,0X85,0X5A,0X42,0X49,0XC2,

61010X39,0X63,0X39,0X85,0X39,0XA6,0X41,0XA7,0X49,0XE7,0X4A,0X28,0X52,0X8A,0X5A,0XCB,

61020X63,0X2D,0X6B,0X6E,0X73,0XAF,0X84,0X10,0X8C,0X71,0X94,0XB2,0X9D,0X13,0XA5,0X34,

61030XAD,0X75,0XB5,0X96,0XBD,0XD7,0XBD,0XF7,0XC6,0X38,0XCE,0X58,0XCE,0X79,0XD6,0X9A,

61040XD6,0XBB,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,

61050XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

61060XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,

61070XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0X9E,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

61110XEF,0X7D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XE7,0X3C,0XE7,0X1C,

61120XE7,0X1C,0XDE,0XFB,0XDE,0XFB,0XD6,0XDB,0XD6,0XBA,0XD6,0XBA,0XCE,0X7A,0XCE,0X59,

61130XC6,0X39,0XC6,0X18,0XBD,0XD8,0XBD,0XB7,0XB5,0X56,0XAD,0X15,0X9C,0XD3,0X9C,0XB2,

61140X8C,0X50,0X83,0XEE,0X73,0X6C,0X6B,0X2B,0X62,0XEA,0X52,0X26,0X41,0XA3,0X41,0XA3,

61150X5A,0X44,0X83,0X47,0XAC,0X8B,0XCD,0X8D,0XE6,0X0E,0XEE,0X4E,0XEE,0X6D,0XEE,0X8C,

61160XF6,0XEC,0XF6,0XEB,0XEE,0XA9,0XEE,0XC9,0XEE,0XA8,0XF6,0X88,0XF6,0X89,0XF6,0X89,

61170XF6,0X89,0XF6,0XA9,0XF6,0X89,0XF6,0X89,0XEE,0X48,0XEE,0X68,0XF6,0X89,0XF6,0XAA,

61180XF6,0XCB,0XFE,0XCC,0XF6,0XAB,0XFE,0XED,0XF6,0XAD,0XE6,0X2D,0XCD,0X6A,0XA4,0X47,

61190X7B,0X23,0X62,0X61,0X51,0XE0,0X41,0XA1,0X41,0XE3,0X4A,0X05,0X4A,0X47,0X4A,0X68,

61200X4A,0X49,0X4A,0X49,0X52,0X49,0X52,0X6A,0X5A,0XAA,0X5A,0XCB,0X62,0XEC,0X63,0X2D,

61210X6B,0X4E,0X73,0X8E,0X73,0XAF,0X7B,0XEF,0X84,0X30,0X8C,0X71,0X94,0XB2,0X9C,0XF3,

61220XA5,0X14,0XAD,0X55,0XB5,0X95,0XB5,0XB6,0XBD,0XF7,0XC6,0X18,0XCE,0X59,0XCE,0X79,

61230XCE,0X79,0XD6,0X9A,0XD6,0XBA,0XDE,0XFB,0XDE,0XDB,0XDE,0XFB,0XE7,0X1C,0XE7,0X3C,

61240XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,

61250XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,

61260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61290XFF,0XFF,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XEF,0X7D,

61300XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

61310XE7,0X1C,0XE7,0X1C,0XDF,0X1B,0XDE,0XFB,0XDE,0XFB,0XDE,0XDB,0XDE,0XDB,0XD6,0XBB,

61320XD6,0X9A,0XD6,0X7A,0XD6,0X5A,0XCE,0X59,0XCE,0X18,0XC5,0XF7,0XBD,0XD7,0XBD,0XD7,

61330XB5,0X96,0XAD,0X55,0XA4,0XF4,0XA4,0XF3,0XA4,0XD2,0X94,0X50,0X8B,0XED,0X83,0X6A,

61340X7B,0X28,0X73,0X06,0X8B,0XA8,0XA4,0X49,0XB4,0XEA,0XC5,0X6B,0XD6,0X0C,0XDE,0X2C,

61350XDE,0X2B,0XE6,0X6C,0XEE,0XCD,0XEE,0XAC,0XEE,0XAC,0XEE,0X8C,0XEE,0X8C,0XEE,0X8C,

61360XEE,0X8C,0XEE,0X8C,0XF6,0XEE,0XF6,0XEE,0XF6,0XCE,0XEE,0XAE,0XDE,0X0B,0XC5,0X69,

61370XB4,0XE8,0X8B,0XA4,0X72,0XE2,0X5A,0X20,0X41,0X80,0X41,0X60,0X41,0X80,0X41,0XA1,

61380X49,0XE3,0X4A,0X25,0X4A,0X25,0X4A,0X46,0X52,0X87,0X52,0XA9,0X5A,0XCA,0X62,0XEB,

61390X63,0X0C,0X6B,0X2C,0X62,0XEB,0X62,0XEB,0X6B,0X2C,0X73,0X4D,0X73,0X8E,0X7B,0XCF,

61400X84,0X10,0X84,0X51,0X84,0X51,0X8C,0X92,0X94,0XD2,0X9C,0XF3,0XA4,0XF4,0XA5,0X34,

61410XAD,0X55,0XB5,0X96,0XB5,0XB6,0XBD,0XD7,0XC6,0X18,0XC6,0X38,0XC6,0X38,0XCE,0X59,

61420XCE,0X79,0XD6,0X9A,0XD6,0XBA,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,

61430XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,

61440XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,

61450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

61480XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

61490XF7,0X9E,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,

61500XE7,0X5C,0XE7,0X5C,0XE7,0X3C,0XE7,0X3C,0XE7,0X1C,0XE6,0XFC,0XE6,0XDC,0XE6,0XDC,

61510XDE,0XDB,0XDE,0XBB,0XDE,0X9A,0XD6,0X9A,0XD6,0X9A,0XD6,0XBA,0XD6,0X99,0XCE,0X79,

61520XD6,0X79,0XD6,0X99,0XD6,0X99,0XD6,0X78,0XDE,0XB8,0XDE,0XB7,0XDE,0XB6,0XDE,0X75,

61530XD6,0X54,0XCE,0X13,0XC5,0XB1,0XBD,0X70,0XC5,0X70,0XBD,0X4F,0XB5,0X2E,0XB5,0X0D,

61540XB5,0X0D,0XBD,0X2D,0XBD,0X4D,0XC5,0X6D,0XBD,0X4D,0XB5,0X0C,0XAC,0XAB,0XA4,0X6A,

61550X94,0X08,0X83,0X87,0X7B,0X05,0X62,0X43,0X51,0XE1,0X49,0XA0,0X41,0X60,0X49,0XA1,

61560X41,0XA2,0X41,0XA3,0X49,0XE4,0X52,0X25,0X52,0X45,0X52,0X66,0X5A,0X87,0X5A,0XA8,

61570X62,0XE9,0X63,0X09,0X6B,0X4A,0X6B,0X6A,0X6B,0X6B,0X73,0X8C,0X73,0XAD,0X7B,0XEE,

61580X8C,0X0F,0X84,0X0F,0X83,0XEF,0X83,0XEF,0X84,0X0F,0X84,0X30,0X8C,0X72,0X94,0XB3,

61590X9C,0XD3,0X9C,0XF4,0XA5,0X14,0XA5,0X34,0XAD,0X55,0XAD,0X75,0XB5,0X96,0XBD,0XB7,

61600XC5,0XF7,0XC6,0X18,0XC6,0X38,0XCE,0X59,0XCE,0X79,0XCE,0X79,0XD6,0XBA,0XD6,0XBA,

61610XDE,0XDB,0XDE,0XDB,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,

61620XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,

61630XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

61670XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,

61680XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XEF,0X7D,0XF7,0X9E,0XEF,0X7D,

61690XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XEF,0X5D,0XEF,0X3D,0XEF,0X3D,0XEF,0X3D,0XE6,0XFC,

61700XE7,0X1C,0XEF,0X3C,0XE7,0X3C,0XDE,0XFB,0XE7,0X1C,0XEF,0X7C,0XEF,0X7C,0XEF,0X7C,

61710XEF,0X7B,0XEF,0X7B,0XEF,0X9B,0XEF,0X7B,0XEF,0X7A,0XEF,0X5A,0XE7,0X39,0XE7,0X18,

61720XEF,0X19,0XEE,0XF8,0XE6,0XD8,0XE6,0XB8,0XE6,0XB8,0XE6,0XB7,0XDE,0X76,0XDE,0X75,

61730XDE,0X55,0XD6,0X54,0XD6,0X34,0XCD,0XF3,0XCD,0XF3,0XCD,0XD3,0XC5,0XD3,0XC5,0XB3,

61740XBD,0X72,0XBD,0X52,0XB5,0X12,0XB5,0X32,0XB5,0X32,0XA4,0XB0,0XA4,0XD1,0XA4,0XD1,

61750X9C,0XB1,0X9C,0XB0,0X94,0X90,0X94,0XB0,0X94,0XB1,0X94,0X90,0X94,0X90,0X94,0X90,

61760X94,0XB0,0X9C,0XD0,0X9C,0XF1,0X9C,0XF1,0XA5,0X12,0XA5,0X33,0XAD,0X33,0XAD,0X33,

61770XAD,0X33,0XAD,0X33,0XA5,0X13,0XA5,0X13,0XA5,0X14,0XA5,0X35,0XAD,0X56,0XAD,0X76,

61780XB5,0X96,0XB5,0XB6,0XB5,0XB6,0XBD,0XD7,0XBD,0XF8,0XC6,0X18,0XC6,0X38,0XC6,0X38,

61790XCE,0X59,0XCE,0X59,0XCE,0X79,0XD6,0X9A,0XD6,0XBA,0XD6,0XBA,0XDE,0XDB,0XDE,0XDB,

61800XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,

61810XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

61820XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

61850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

61860XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

61870XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9F,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

61880XF7,0X9D,0XF7,0X7D,0XF7,0X7D,0XF7,0X7D,0XF7,0X7E,0XF7,0X7E,0XF7,0X9E,0XF7,0X7E,

61890XF7,0X9E,0XFF,0XDE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XDE,

61900XF7,0XDE,0XF7,0XFE,0XF7,0XDE,0XEF,0XBC,0XF7,0XDC,0XF7,0XBB,0XF7,0XBB,0XF7,0X9B,

61910XF7,0X9B,0XF7,0X7B,0XF7,0X5B,0XF7,0X3B,0XF7,0X5B,0XF7,0X7A,0XF7,0X7A,0XEF,0X5A,

61920XEF,0X39,0XEF,0X19,0XEF,0X19,0XEF,0X19,0XEF,0X19,0XEF,0X19,0XEF,0X3A,0XEF,0X1A,

61930XEF,0X1A,0XE6,0XFA,0XDE,0XB9,0XE7,0X1A,0XDE,0XFA,0XDE,0XDA,0XDE,0XD9,0XDE,0XF9,

61940XD6,0XD9,0XD6,0XB9,0XD6,0XB8,0XD6,0X98,0XDE,0XBA,0XDE,0X99,0XDE,0X79,0XDE,0X99,

61950XD6,0X98,0XD6,0X98,0XD6,0XB7,0XCE,0X97,0XD6,0X98,0XD6,0XB8,0XD6,0XD8,0XDE,0XB8,

61960XD6,0X98,0XD6,0X78,0XCE,0X38,0XC6,0X18,0XCE,0X39,0XCE,0X19,0XCE,0X39,0XCE,0X59,

61970XCE,0X59,0XCE,0X79,0XCE,0X7A,0XCE,0X9A,0XD6,0XBA,0XD6,0XBA,0XD6,0XBA,0XDE,0XDA,

61980XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,

61990XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

62000XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,

62010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62040XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

62050XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

62060XFF,0XDF,0XFF,0XDF,0XFF,0XBF,0XFF,0XBF,0XF7,0XBF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBD,

62070XF7,0XBD,0XF7,0XBE,0XFF,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,

62080XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XF7,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62090XF7,0XDF,0XF7,0XFE,0XF7,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XDD,0XFF,0XDD,

62100XFF,0XBE,0XFF,0XDE,0XFF,0XBD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XBC,0XFF,0XBC,

62110XF7,0XBC,0XFF,0XBC,0XF7,0X9C,0XF7,0XBC,0XF7,0X9C,0XF7,0X7C,0XF7,0X7D,0XF7,0X7D,

62120XEF,0X7D,0XF7,0X7D,0XEF,0X9D,0XEF,0X9D,0XEF,0X9D,0XEF,0X9C,0XEF,0X9C,0XEF,0X9C,

62130XEF,0X7C,0XEF,0X5C,0XEF,0X3C,0XEF,0X3C,0XF7,0X5D,0XF7,0X5D,0XEF,0X5C,0XEF,0X7C,

62140XEF,0X9B,0XEF,0X7B,0XEF,0X7B,0XEF,0X7B,0XEF,0X9C,0XEF,0X9B,0XF7,0X7C,0XF7,0X7C,

62150XEF,0X5C,0XE7,0X1C,0XE6,0XFB,0XDE,0XDB,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFC,

62160XDE,0XFC,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

62170XE7,0X3C,0XEF,0X5D,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,

62180XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

62190XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,

62200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62240XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

62250XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

62260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

62270XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62280XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,

62290XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,

62300XFF,0XDE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,

62310XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XF7,0XDE,0XF7,0XDD,0XF7,0XDD,0XFF,0XDE,0XFF,0XDE,

62320XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,

62330XFF,0XDD,0XFF,0XDD,0XF7,0XBD,0XFF,0XDD,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XF7,0XBE,

62340XF7,0X7D,0XEF,0X5D,0XEF,0X3C,0XE7,0X3C,0XEF,0X3C,0XEF,0X5D,0XEF,0X5D,0XE7,0X3C,

62350XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

62360XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

62370XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

62380XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62490XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

62500XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

62510XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

62520XFF,0XDE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDE,0XFF,0XDE,0XF7,0XBE,

62530XF7,0X9D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X7D,0XEF,0X7D,0XEF,0X7D,

62540XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

62550XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

62560XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,

62570XF7,0XBE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBE,

62720XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

62730XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,

62740XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

62750XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

62760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBF,

62910XFF,0XBE,0XFF,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

62920XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

62930XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

62940XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

62990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

63100XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

63110XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

63120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

63290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

63990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,};

6409

6410const unsigned char gimage_5[51000] = { /* 0X10,0X10,0X00,0X96,0X00,0XAA,0X01,0X1B, */

64110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64630XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

64990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65000XFF,0XFF,0XFF,0XDE,0XFF,0XDE,0XFF,0XFF,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

65010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XFE,0XFF,0XDD,

65190XFF,0XDD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

65370XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XDB,0XFF,0XDC,0XEF,0X5A,0XEF,0X3A,0XFF,0XDD,

65380XFF,0XDD,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

65550XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFB,0XFF,0XFA,

65560XFF,0XF9,0XFF,0XD9,0XC6,0X13,0X7B,0XCB,0X9C,0XAF,0XF7,0X9C,0XFF,0XFE,0XFF,0XDE,

65570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65730XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFB,

65740XFF,0XFB,0XFF,0XFA,0XFF,0XF9,0XFF,0XF8,0XFF,0XF8,0XFF,0XF7,0XFF,0XF6,0XE7,0X34,

65750X9C,0XCC,0X42,0X02,0X63,0X08,0XDE,0XD8,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,

65920XFF,0XFD,0XFF,0XFC,0XFF,0XFB,0XFF,0XFA,0XFF,0XF9,0XFF,0XF8,0XFF,0XF7,0XFF,0XF6,

65930XFF,0XF6,0XFF,0XF5,0XF7,0XD4,0XFF,0XF4,0XFF,0XD4,0XDE,0XF1,0X7B,0X86,0X4A,0X21,

65940X52,0X64,0XBD,0XB3,0XFF,0XBD,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

65950XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

65990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

66090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,

66100XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFB,0XFF,0XFA,0XFF,0XF9,

66110XFF,0XF8,0XFF,0XF7,0XFF,0XF5,0XFF,0XF5,0XF7,0XD3,0XFF,0XF3,0XFF,0XF2,0XFF,0XF2,

66120XF7,0XD2,0XFF,0XF2,0XFF,0XD2,0XBD,0XEC,0X5A,0XC1,0X52,0X41,0X4A,0X22,0X8C,0X2D,

66130XFF,0X9D,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

66140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66270XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

66280XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,0XFF,0XFA,0XFF,0XF9,

66290XFF,0XF9,0XFF,0XF8,0XFF,0XD8,0XFF,0XD8,0XFF,0XD7,0XFF,0XF6,0XFF,0XF5,0XFF,0XF4,

66300XFF,0XF3,0XFF,0XF2,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XD0,0XFF,0XF2,

66310XF7,0X91,0X9C,0XA7,0X5A,0X80,0X52,0X61,0X52,0X42,0X62,0XC7,0XE6,0XD9,0XFF,0XDE,

66320XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

66460XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,

66470XFF,0XFA,0XFF,0XF9,0XFF,0XF8,0XFF,0XF7,0XFF,0XF5,0XFF,0XF5,0XFF,0XF4,0XFF,0XF4,

66480XFF,0XD4,0XFF,0XD4,0XFF,0XD4,0XFF,0XF3,0XFF,0XF2,0XFF,0XF2,0XFF,0XF1,0XFF,0XF1,

66490XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XD0,0XFF,0XF1,0XE7,0X0F,0X73,0X62,

66500X5A,0X80,0X52,0X41,0X52,0X43,0X4A,0X03,0XAD,0X11,0XFF,0XFE,0XFF,0XDE,0XFF,0XDF,

66510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66640XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,

66650XFF,0XFC,0XFF,0XFB,0XFF,0XFB,0XFF,0XFA,0XFF,0XF9,0XFF,0XF8,0XFF,0XF7,0XFF,0XF6,

66660XFF,0XF5,0XFF,0XF4,0XFF,0XF3,0XFF,0XF2,0XFF,0XF1,0XFF,0XF1,0XFF,0XF2,0XFF,0XF2,

66670XFF,0XF2,0XFF,0XF2,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,

66680XFF,0XEF,0XFF,0XEF,0XFF,0XD0,0XFF,0XD1,0XC5,0XCB,0X62,0XA0,0X5A,0X40,0X5A,0X42,

66690X5A,0X42,0X52,0X23,0X73,0X49,0XFF,0XBC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,

66830XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFA,0XFF,0XF9,0XFF,0XF8,0XFF,0XF7,

66840XFF,0XF6,0XFF,0XF5,0XFF,0XF5,0XFF,0XF4,0XFF,0XF3,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,

66850XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

66860XFF,0XF0,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XCF,0XFF,0XEF,0XFF,0XF0,

66870XFF,0XD1,0XFF,0X71,0X94,0X25,0X62,0X80,0X52,0X00,0X5A,0X42,0X5A,0X42,0X52,0X43,

66880X52,0X44,0XCE,0X55,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

66990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

67010XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFB,0XFF,0XFB,0XFF,0XFA,0XFF,0XFA,

67020XFF,0XF9,0XFF,0XF8,0XFF,0XF7,0XFF,0XD6,0XFF,0XD5,0XFF,0XD4,0XF7,0XD3,0XF7,0XF2,

67030XFF,0XF2,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,

67040XFF,0XF2,0XFF,0XF1,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,

67050XFF,0XF1,0XFF,0XF0,0XFF,0XF1,0XFF,0XD0,0XFF,0XF0,0XFF,0XF0,0XFF,0X90,0XEF,0X30,

67060X6B,0X02,0X62,0XA2,0X52,0X00,0X5A,0X42,0X52,0X43,0X52,0X43,0X4A,0X03,0X9C,0XCF,

67070XFF,0XDC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67170XFF,0XFF,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XFF,0XDF,0XFF,0XDF,

67190XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,0XFF,0XFA,

67200XFF,0XD9,0XFF,0XF8,0XFF,0XF7,0XFF,0XF6,0XFF,0XF5,0XFF,0XF4,0XFF,0XF3,0XFF,0XF3,

67210XFF,0XF3,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,

67220XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,

67230XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

67240XFF,0XF0,0XFF,0XCF,0XFF,0XF0,0XFF,0XF0,0XFF,0XD1,0XAD,0X29,0X62,0XA1,0X52,0X21,

67250X52,0X22,0X52,0X43,0X52,0X23,0X52,0X43,0X4A,0X24,0X62,0XE7,0XF7,0X7A,0XFF,0XDD,

67260XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67360XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

67370XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,

67380XFF,0XFB,0XFF,0XFA,0XFF,0XDA,0XFF,0XD8,0XFF,0XD7,0XFF,0XD6,0XFF,0XD6,0XFF,0XF4,

67390XFF,0XF3,0XFF,0XF3,0XFF,0XF2,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,

67400XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

67410XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,

67420XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XD0,

67430XFF,0XCF,0XFF,0XF1,0XEF,0X2F,0X9C,0X86,0X5A,0X81,0X52,0X22,0X52,0X22,0X52,0X23,

67440X52,0X23,0X52,0X43,0X52,0X24,0X52,0X45,0XC5,0XD4,0XFF,0XFD,0XFF,0XDE,0XFF,0XFF,

67450XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

67550XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,

67560XFF,0XFB,0XFF,0XFA,0XFF,0XF9,0XFF,0XF8,0XFF,0XF8,0XFF,0XF7,0XFF,0XF6,0XFF,0XF6,

67570XFF,0XD5,0XFF,0XD4,0XFF,0XD4,0XFF,0XF3,0XFF,0XF3,0XFF,0XF2,0XFF,0XF2,0XFF,0XF1,

67580XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

67590XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

67600XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,

67610XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XAF,0XFF,0XF0,

67620XC5,0XEA,0X7B,0X63,0X52,0X41,0X52,0X22,0X52,0X22,0X52,0X22,0X52,0X23,0X52,0X43,

67630X52,0X44,0X4A,0X04,0X8C,0X0D,0XFF,0XDC,0XFF,0XDD,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

67640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,

67740XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFB,0XFF,0XFB,0XFF,0XF9,0XFF,0XF8,0XFF,0XF7,

67750XFF,0XF6,0XFF,0XF4,0XFF,0XF3,0XFF,0XF3,0XFF,0XF2,0XFF,0XF2,0XFF,0XF1,0XFF,0XF1,

67760XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,

67770XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

67780XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

67790XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

67800XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XD0,0XFF,0XD1,0XAD,0X07,0X62,0XE1,

67810X52,0X01,0X52,0X22,0X52,0X23,0X52,0X23,0X52,0X23,0X52,0X23,0X52,0X44,0X4A,0X24,

67820X6B,0X08,0XE6,0XF9,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

67920XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XFA,0XFF,0XF9,0XFF,0XF8,0XFF,0XF8,

67930XFF,0XF8,0XFF,0XF7,0XFF,0XD6,0XFF,0XF5,0XFF,0XF4,0XFF,0XF3,0XFF,0XF2,0XFF,0XF1,

67940XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

67950XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

67960XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

67970XFF,0XF0,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,

67980XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

67990XFF,0XF0,0XFF,0XF0,0XFF,0XD0,0XE7,0X0E,0X8C,0X25,0X62,0X80,0X52,0X01,0X52,0X02,

68000X52,0X22,0X52,0X22,0X52,0X23,0X52,0X23,0X52,0X23,0X52,0X44,0X52,0X86,0XB5,0X93,

68010XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

68110XFF,0XFC,0XFF,0XF9,0XFF,0XD7,0XFF,0XD5,0XFF,0XF4,0XFF,0XF4,0XFF,0XF3,0XFF,0XF3,

68120XFF,0XF2,0XFF,0XF2,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,

68130XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

68140XFF,0XEE,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

68150XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68160XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68170XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XCF,0XFF,0XD0,

68180XFF,0XB0,0XCE,0X0B,0X7B,0X62,0X52,0X20,0X51,0XE1,0X52,0X23,0X52,0X22,0X52,0X02,

68190X52,0X23,0X52,0X43,0X52,0X03,0X52,0X24,0X4A,0X25,0X84,0X0D,0XF7,0X9C,0XFF,0XFE,

68200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFA,0XFF,0XD7,

68300XF7,0XD4,0XFF,0XD2,0XFF,0XD1,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XF0,0XFF,0XEF,

68310XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68320XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68330XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68340XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68350XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68360XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0X8E,0XFF,0XD0,0XFF,0X90,0XAD,0X28,

68370X73,0X22,0X52,0X00,0X51,0XE1,0X52,0X03,0X52,0X23,0X52,0X02,0X52,0X23,0X52,0X23,

68380X52,0X03,0X52,0X24,0X42,0X04,0X63,0X08,0XD6,0XB8,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,

68390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68480XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFC,0XFF,0XF8,0XF7,0XD5,0XFF,0XD2,0XFF,0XF0,

68490XFF,0XEF,0XFF,0XEE,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68500XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68510XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68520XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68530XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68540XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,

68550XFF,0XEE,0XFF,0XEF,0XFF,0XF0,0XFF,0XD0,0XE6,0XCE,0X8B,0XE4,0X62,0XA1,0X49,0XC0,

68560X52,0X02,0X52,0X02,0X52,0X02,0X52,0X02,0X52,0X23,0X4A,0X02,0X52,0X23,0X52,0X44,

68570X41,0XE3,0X52,0X66,0XBD,0XF5,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68670XFF,0XFD,0XFF,0XFB,0XFF,0XD7,0XF7,0XB3,0XFF,0XD1,0XFF,0XF0,0XFF,0XEF,0XFF,0XEE,

68680XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68690XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XEF,

68700XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

68710XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEF,0XFF,0XEE,

68720XFF,0XEF,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68730XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XCE,

68740XFF,0XF0,0XFF,0X90,0XCD,0XEB,0X7B,0X84,0X5A,0X41,0X49,0XE1,0X51,0XE2,0X52,0X03,

68750X52,0X02,0X52,0X02,0X52,0X03,0X52,0X23,0X4A,0X02,0X4A,0X03,0X4A,0X04,0X73,0X6A,

68760XE7,0X19,0XFF,0XFE,0XFF,0XFF,0XF7,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

68770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFA,

68860XFF,0XD6,0XF7,0XD2,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

68870XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,

68880XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

68890XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

68900XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

68910XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,

68920XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XCF,0XFF,0XD0,0XF7,0X4F,

68930XAD,0X08,0X6A,0XE2,0X49,0XE0,0X49,0XE1,0X51,0XE2,0X52,0X03,0X52,0X02,0X52,0X23,

68940X49,0XE2,0X52,0X23,0X4A,0X03,0X52,0X24,0X41,0XE4,0X9C,0XD0,0XF7,0X9C,0XFF,0XFE,

68950XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

68990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XD9,0XFF,0XD5,0XF7,0XD2,

69050XFF,0XF0,0XFF,0XEF,0XFF,0XEE,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,

69060XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

69070XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

69080XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

69090XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

69100XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

69110XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XCF,0XFF,0XAF,0XE6,0XCE,0X94,0X25,0X5A,0X81,

69120X49,0XE1,0X52,0X02,0X49,0XE2,0X51,0XE3,0X52,0X03,0X4A,0X02,0X4A,0X02,0X49,0XE2,

69130X4A,0X03,0X52,0X44,0X4A,0X25,0XCE,0X56,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

69140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69230XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XD8,0XF7,0XB4,0XFF,0XD1,0XFF,0XEF,0XFF,0XEE,

69240XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,

69250XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

69260XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,

69270XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

69280XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,

69290XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

69300XFF,0XCE,0XFF,0XCF,0XF7,0X6F,0XCE,0X0B,0X7B,0X84,0X5A,0X41,0X49,0XE1,0X51,0XE2,

69310X49,0XC2,0X49,0XE2,0X52,0X03,0X4A,0X02,0X52,0X23,0X49,0XE2,0X4A,0X03,0X4A,0X04,

69320X6B,0X29,0XEF,0X5A,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69330XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,

69420XFF,0XDA,0XFF,0XB6,0XF7,0XB2,0XFF,0XF0,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,

69430XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,

69440XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

69450XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

69460XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

69470XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

69480XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XCD,0XFF,0XCE,0XFF,0XCF,

69490XF7,0X4E,0XAD,0X07,0X6B,0X22,0X52,0X00,0X49,0XC1,0X49,0XC2,0X49,0XC2,0X49,0XE3,

69500X49,0XE2,0X4A,0X03,0X4A,0X03,0X4A,0X03,0X49,0XE3,0X41,0XC3,0XA4,0XF1,0XFF,0XFD,

69510XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XD9,0XFF,0XB5,

69610XFF,0XB1,0XFF,0XEF,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

69620XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

69630XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

69640XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,

69650XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

69660XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,

69670XFF,0XEE,0XFF,0XED,0XFF,0XCD,0XFF,0XCD,0XFF,0XCE,0XFF,0XCF,0XE6,0XED,0X8C,0X24,

69680X62,0XA1,0X49,0XE0,0X49,0XC2,0X49,0XE3,0X49,0XC2,0X49,0XE3,0X49,0XE2,0X4A,0X03,

69690X49,0XE3,0X49,0XE3,0X41,0XE3,0X41,0XC3,0XDE,0XB8,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

69700XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69790XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFC,0XFF,0XB7,0XFF,0XB3,0XFF,0XD0,0XFF,0XEE,

69800XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,

69810XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,

69820XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

69830XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCD,

69840XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

69850XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,

69860XFF,0XCD,0XFF,0XCD,0XFF,0XCE,0XFF,0XAF,0XC5,0XE9,0X7B,0X82,0X5A,0X60,0X49,0XC0,

69870X49,0XE2,0X49,0XE3,0X49,0XE2,0X49,0XE2,0X4A,0X03,0X49,0XE2,0X4A,0X03,0X41,0XC3,

69880X41,0XC3,0X6B,0X29,0XFF,0XBC,0XFF,0XDD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

69970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

69980XFF,0XFE,0XFF,0XFB,0XFF,0XB6,0XFF,0XB2,0XFF,0XCF,0XFF,0XED,0XFF,0XED,0XFF,0XED,

69990XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XED,0XFF,0XED,

70000XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,

70010XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

70020XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

70030XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

70040XFF,0XED,0XFF,0XED,0XFF,0XCE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCD,

70050XFF,0XAE,0XF7,0X8F,0XAD,0X07,0X6B,0X21,0X4A,0X00,0X41,0XA0,0X49,0XC2,0X41,0XC2,

70060X49,0XC2,0X49,0XE2,0X4A,0X03,0X49,0XE2,0X4A,0X03,0X4A,0X04,0X31,0X62,0XA5,0X11,

70070XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XF9,

70170XFF,0X94,0XFF,0XB1,0XFF,0XCE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEC,

70180XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

70190XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,

70200XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

70210XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XED,

70220XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

70230XFF,0XEE,0XFF,0XCD,0XFF,0XCC,0XFF,0XEC,0XFF,0XCC,0XFF,0XAD,0XFF,0XAF,0XDE,0X8C,

70240X8C,0X05,0X6A,0XE2,0X41,0XA0,0X49,0XE2,0X41,0XC2,0X49,0XC2,0X41,0XC1,0X4A,0X01,

70250X4A,0X02,0X41,0XC2,0X41,0XE3,0X41,0XE4,0X41,0XE4,0XDE,0XB9,0XFF,0XDE,0XFF,0XFF,

70260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XFF,0XB8,0XFF,0X93,0XFF,0XB0,

70360XFF,0XCD,0XFF,0XEC,0XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,

70370XFF,0XCD,0XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

70380XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,

70390XFF,0XCD,0XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,

70400XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,

70410XFF,0XED,0XFF,0XCD,0XFF,0XCD,0XFF,0XCE,0XFF,0XCE,0XFF,0XCE,0XFF,0XCE,0XFF,0XCD,

70420XFF,0XCC,0XFF,0XCB,0XFF,0XCC,0XFF,0XAD,0XFF,0X6E,0XC5,0XAA,0X83,0XA4,0X5A,0X42,

70430X49,0XE1,0X41,0XC2,0X49,0XE2,0X41,0XC2,0X49,0XE1,0X4A,0X01,0X4A,0X02,0X41,0XC2,

70440X49,0XE4,0X39,0X83,0X7B,0XAC,0XFF,0XDD,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

70450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70540XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XF7,0X95,0XFF,0X91,0XFF,0XAF,0XFF,0XCD,0XFF,0XEC,

70550XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

70560XFF,0XCD,0XFF,0XED,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCC,

70570XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XAC,0XFF,0XAC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCD,

70580XFF,0XCC,0XFF,0XEC,0XFF,0XCC,0XFF,0XEC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,

70590XFF,0XEC,0XFF,0XEC,0XFF,0XCC,0XFF,0XEC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XAD,

70600XFF,0XAD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCE,0XFF,0X8D,0XFF,0XCD,0XFF,0XCC,0XFF,0XAB,

70610XFF,0XAB,0XFF,0X8D,0XF6,0XED,0XA4,0XA6,0X73,0X03,0X49,0XC0,0X49,0XE2,0X41,0XC2,

70620X4A,0X02,0X41,0XE1,0X49,0XE1,0X49,0XE1,0X4A,0X02,0X41,0XC2,0X41,0XE3,0X31,0X83,

70630XBD,0X94,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,

70730XFF,0XFA,0XF7,0X74,0XFF,0X90,0XFF,0XAE,0XFF,0XAD,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,

70740XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

70750XFF,0XCC,0XFF,0XCC,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCC,0XFF,0XCC,

70760XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XAD,0XFF,0XAD,0XFF,0XCC,0XFF,0XCC,

70770XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,

70780XFF,0XCC,0XFF,0XCC,0XFF,0XCD,0XFF,0XCC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAD,0XFF,0XAD,

70790XFF,0X8D,0XFF,0X8D,0XFF,0X8D,0XFF,0X6C,0XFF,0X6B,0XFF,0X6A,0XFF,0X6A,0XF6,0XCA,

70800XDE,0X4A,0X9C,0X25,0X62,0X82,0X49,0XA0,0X41,0XA1,0X49,0XE2,0X41,0XE1,0X41,0XE1,

70810X41,0XC1,0X41,0XE2,0X49,0XE2,0X41,0XE2,0X41,0XC3,0X5A,0XC8,0XF7,0X7B,0XFF,0XFE,

70820XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

70910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XD8,0XF7,0X52,

70920XFF,0X8F,0XFF,0X8D,0XFF,0XAC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XAD,0XFF,0XAD,

70930XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

70940XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

70950XFF,0XCD,0XFF,0XCD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,

70960XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,

70970XFF,0XAC,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X6C,

70980XF6,0XCA,0XFE,0XEB,0XF6,0XC9,0XEE,0X67,0XEE,0X87,0XF6,0XA9,0XDE,0X0A,0X93,0XE4,

70990X5A,0X01,0X49,0XC1,0X41,0XC1,0X41,0XC2,0X41,0XC1,0X41,0XE1,0X41,0XC1,0X41,0XE2,

71000X41,0XE2,0X4A,0X03,0X31,0X62,0X8C,0X4E,0XFF,0XBC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

71010XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

71100XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFA,0XF7,0X95,0XF7,0X51,0XFF,0X8E,0XFF,0X8C,

71110XFF,0X8C,0XFF,0XAC,0XFF,0XAC,0XFF,0XAB,0XFF,0XAC,0XFF,0XAC,0XFF,0X8C,0XFF,0XAC,

71120XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0XAC,0XFF,0XAC,

71130XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,

71140XFF,0XAD,0XFF,0X8D,0XFF,0X8D,0XFF,0XAC,0XFF,0XAD,0XFF,0XAD,0XFF,0X8C,0XFF,0X8C,

71150XFF,0X8C,0XFF,0X8C,0XFF,0X6C,0XFF,0X6B,0XFF,0X6B,0XFF,0X6B,0XFF,0X4B,0XFF,0X4B,

71160XFF,0X0A,0XFE,0XE9,0XF6,0XC8,0XEE,0X88,0XEE,0X67,0XEE,0X47,0XEE,0X48,0XEE,0X68,

71170XEE,0X47,0XEE,0X46,0XDD,0XE4,0XCD,0X44,0XBC,0XE5,0X9C,0X04,0X51,0XC0,0X49,0X80,

71180X49,0XC1,0X41,0XA1,0X41,0XE1,0X41,0XE1,0X41,0XE2,0X41,0XC2,0X39,0XA2,0X41,0XE3,

71190X41,0XE4,0XCE,0X56,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,

71290XFF,0XFD,0XFF,0XD9,0XF7,0X53,0XF7,0X6F,0XFF,0X6D,0XFF,0X6C,0XFF,0X6C,0XFF,0X8B,

71300XFF,0X8B,0XFF,0X8B,0XFF,0X8C,0XFF,0X8C,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,

71310XFF,0XAC,0XFF,0X8D,0XFF,0X8D,0XFF,0X8C,0XFF,0X8C,0XFF,0X8B,0XFF,0X8B,0XFF,0X8B,

71320XFF,0X8B,0XFF,0X8B,0XFF,0X8B,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,

71330XFF,0X6C,0XFF,0X8C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X4C,0XFF,0X2B,0XFF,0X0B,

71340XFF,0X0A,0XFE,0XEA,0XFE,0XC9,0XFE,0XA9,0XF6,0X88,0XF6,0X68,0XF6,0X67,0XEE,0X46,

71350XEE,0X26,0XE6,0X05,0XE6,0X05,0XE6,0X05,0XDD,0XA5,0XD5,0X64,0XCD,0X22,0XCD,0X43,

71360XD5,0X83,0XDD,0XE6,0XE6,0X29,0XE6,0X0C,0X7A,0XE2,0X49,0XA0,0X49,0XA1,0X41,0XA1,

71370X49,0XE2,0X41,0XC2,0X41,0XE2,0X41,0XC2,0X41,0XE3,0X39,0XA2,0X62,0XE8,0XE6,0XF9,

71380XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XB7,

71480XEF,0X31,0XFF,0X6E,0XFF,0X6C,0XFF,0X6B,0XFF,0X6B,0XFF,0X6C,0XFF,0X6B,0XFF,0X8C,

71490XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8B,0XFF,0X8C,0XFF,0X6C,0XFF,0X6C,

71500XFF,0X6C,0XFF,0X6C,0XFF,0X8C,0XFF,0X8B,0XFF,0X8B,0XFF,0X8B,0XFF,0X8B,0XFF,0X8B,

71510XFF,0X8B,0XFF,0X8B,0XFF,0X6B,0XFF,0X8B,0XFF,0X6C,0XFF,0X4B,0XFF,0X4B,0XFF,0X2B,

71520XFF,0X0A,0XFF,0X0A,0XFE,0XE9,0XF6,0XA9,0XF6,0X88,0XF6,0X88,0XF6,0X68,0XF6,0X47,

71530XEE,0X26,0XEE,0X06,0XEE,0X06,0XEE,0X05,0XED,0XE5,0XE5,0XC4,0XE5,0XA3,0XDD,0X83,

71540XDD,0X83,0XDD,0X83,0XE5,0XC5,0XEE,0X06,0XF6,0X27,0XF6,0X88,0XF6,0X68,0XFE,0XA9,

71550XF6,0X8A,0XFE,0XCD,0XBD,0X09,0X62,0X40,0X49,0XA0,0X49,0XC2,0X49,0XC2,0X41,0XC2,

71560X41,0XC2,0X41,0XE3,0X39,0XC3,0X39,0XA3,0X9C,0XD0,0XEF,0X5A,0XFF,0XFE,0XFF,0XFF,

71570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71660XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XFF,0X96,0XEF,0X2F,0XFF,0X6D,

71670XFF,0X6B,0XFF,0X4B,0XFF,0X4B,0XFF,0X6B,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X4C,

71680XFF,0X6C,0XFF,0X4C,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X6B,0XFF,0X6C,

71690XFF,0X6C,0XFF,0X4B,0XFF,0X6B,0XFF,0X6B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4A,0XFF,0X2A,

71700XF7,0X09,0XF6,0XE9,0XF6,0XC9,0XF6,0XA8,0XF6,0XA8,0XF6,0X87,0XEE,0X67,0XEE,0X67,

71710XEE,0X46,0XEE,0X25,0XEE,0X05,0XE5,0XE4,0XE5,0XC4,0XE5,0XA4,0XE5,0X83,0XDD,0X62,

71720XDD,0X62,0XE5,0X83,0XE5,0X83,0XE5,0X83,0XE5,0XC3,0XEE,0X04,0XF6,0X25,0XF6,0X46,

71730XF6,0X67,0XF6,0X67,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0XA9,0XF6,0XA9,0XF6,0X8A,

71740XF6,0XAD,0X93,0XC4,0X51,0XC0,0X51,0XC2,0X49,0XC3,0X41,0XA2,0X41,0XA2,0X41,0XE2,

71750X39,0XA3,0X4A,0X25,0XC5,0XF5,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

71850XFF,0XFF,0XFF,0XFE,0XFF,0XB9,0XF7,0X54,0XF7,0X2E,0XFF,0X4C,0XFF,0X6B,0XFF,0X4B,

71860XFF,0X4B,0XFF,0X2B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X6C,0XFF,0X4C,

71870XFF,0X4C,0XFF,0X4B,0XFF,0X6C,0XFF,0X6B,0XFF,0X4B,0XFF,0X0A,0XFF,0X0B,0XFF,0X0B,

71880XFF,0X0B,0XF6,0XEA,0XEE,0XA8,0XEE,0X88,0XF6,0XA8,0XF6,0XA8,0XEE,0X87,0XF6,0X87,

71890XF6,0X66,0XEE,0X46,0XEE,0X25,0XE5,0XE4,0XE5,0XC3,0XDD,0XA3,0XDD,0X61,0XDD,0X61,

71900XDD,0X61,0XDD,0X61,0XDD,0X82,0XE5,0XA2,0XE5,0XA2,0XE5,0XA3,0XED,0XE3,0XED,0XE4,

71910XF6,0X04,0XF6,0X04,0XF6,0X25,0XF6,0X46,0XFE,0X66,0XFE,0X67,0XF6,0X67,0XF6,0X67,

71920XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0XA9,0XF6,0XA9,0XF6,0XAA,0XEE,0X8B,0XD5,0XEB,

71930X72,0XE2,0X41,0X60,0X49,0XA2,0X41,0X82,0X49,0XE2,0X41,0XC2,0X39,0XC3,0X6B,0X2A,

71940XDE,0XD9,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

71990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,

72040XFF,0X97,0XF7,0X32,0XF7,0X4E,0XFF,0X4B,0XFF,0X2B,0XFF,0X2B,0XFF,0X4B,0XFF,0X2B,

72050XFF,0X2B,0XFF,0X2B,0XFF,0X4B,0XFF,0X6B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X0B,

72060XFE,0XEA,0XFF,0X0A,0XFE,0XEA,0XF6,0XC9,0XF6,0XAA,0XEE,0X69,0XEE,0X48,0XF6,0X68,

72070XF6,0XA8,0XF6,0X88,0XEE,0X46,0XE5,0XE4,0XE5,0XC3,0XE5,0XA3,0XDD,0X62,0XD5,0X41,

72080XD5,0X40,0XDD,0X40,0XDD,0X41,0XDD,0X61,0XE5,0XA1,0XE5,0XA0,0XE5,0XC1,0XE5,0XC1,

72090XED,0XE2,0XED,0XE2,0XEE,0X03,0XF6,0X03,0XEE,0X04,0XF6,0X24,0XF6,0X45,0XF6,0X46,

72100XFE,0X66,0XFE,0X66,0XFE,0X67,0XF6,0X67,0XFE,0X87,0XFE,0XA8,0XFE,0X88,0XFE,0X89,

72110XFE,0X89,0XFE,0XA9,0XFE,0XA9,0XF6,0XC9,0XEE,0X68,0XF6,0XAC,0XA4,0X47,0X59,0XE0,

72120X49,0X81,0X49,0XA2,0X49,0XE3,0X39,0X82,0X41,0XC3,0X94,0X4F,0XFF,0X9C,0XFF,0XFF,

72130XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XF7,0X75,0XF7,0X30,

72230XFF,0X2D,0XFF,0X4B,0XFF,0X4B,0XFF,0X2B,0XFF,0X2B,0XFF,0X0B,0XFF,0X0B,0XFF,0X2B,

72240XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XF6,0XA9,0XF6,0X89,0XF6,0X89,0XEE,0X49,0XE6,0X07,

72250XE6,0X28,0XF6,0X89,0XF6,0X69,0XF6,0X48,0XEE,0X27,0XE5,0XE6,0XDD,0X83,0XD5,0X42,

72260XD5,0X21,0XD5,0X00,0XD5,0X20,0XDD,0X40,0XE5,0X61,0XE5,0X81,0XE5,0X81,0XE5,0X80,

72270XE5,0X80,0XE5,0X80,0XE5,0XA0,0XE5,0XC0,0XE5,0XE1,0XED,0XE1,0XED,0XE2,0XEE,0X02,

72280XEE,0X23,0XF6,0X24,0XF6,0X45,0XF6,0X45,0XF6,0X66,0XFE,0X87,0XFE,0X87,0XFE,0X88,

72290XFE,0X87,0XF6,0X88,0XFE,0XA8,0XFE,0XA8,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,

72300XFE,0X88,0XFE,0XA8,0XFF,0X0A,0XF6,0XAB,0XDE,0X0C,0X83,0X44,0X41,0X60,0X49,0XC2,

72310X49,0XC2,0X41,0XA2,0X4A,0X05,0XBD,0X94,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72410XFF,0XFF,0XFF,0XDE,0XFF,0XFD,0XFF,0XB9,0XF7,0X32,0XF7,0X2E,0XFF,0X0B,0XFF,0X2B,

72420XFF,0X0B,0XFF,0X2C,0XFF,0X2C,0XFF,0X0C,0XF6,0XA9,0XF6,0X88,0XEE,0X46,0XEE,0X46,

72430XEE,0X06,0XF6,0X48,0XF6,0X69,0XF6,0X49,0XEE,0X29,0XEE,0X09,0XDD,0X86,0XCD,0X04,

72440XBC,0XC1,0XC4,0XA1,0XBC,0XA0,0XC4,0XA0,0XCD,0X00,0XD5,0X40,0XDD,0X60,0XDD,0X60,

72450XE5,0X60,0XE5,0X80,0XE5,0X80,0XE5,0X80,0XE5,0X80,0XED,0XA0,0XED,0XC0,0XED,0XE1,

72460XED,0XE1,0XED,0XE2,0XEE,0X02,0XF6,0X23,0XF6,0X23,0XF6,0X44,0XF6,0X65,0XF6,0X65,

72470XF6,0X66,0XF6,0X86,0XFE,0X87,0XFE,0X87,0XFE,0XA8,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

72480XFE,0X88,0XF6,0X88,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X88,0XFE,0X88,

72490XFE,0XCA,0XF6,0XAA,0XF6,0XCD,0XB4,0XA8,0X5A,0X00,0X41,0X80,0X41,0XA1,0X41,0X82,

72500X6A,0XE9,0XE6,0XD9,0XFF,0XDE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

72600XFF,0XFC,0XF7,0X76,0XEF,0X10,0XF7,0X2D,0XFF,0X0A,0XFF,0X0A,0XFE,0XEA,0XFF,0X0C,

72610XFE,0XEC,0XFE,0XAB,0XE6,0X27,0XEE,0X25,0XE5,0XE4,0XEE,0X05,0XE5,0XC6,0XD5,0X24,

72620XC4,0X82,0XB4,0X21,0XAB,0XE1,0XA3,0XA0,0XA3,0XA0,0XA3,0XC0,0XAB,0XE0,0XB4,0X40,

72630XBC,0X80,0XCC,0XC0,0XD5,0X00,0XDD,0X40,0XDD,0X60,0XE5,0X80,0XED,0XA1,0XED,0XA1,

72640XED,0XC1,0XED,0XC1,0XED,0XC2,0XED,0XE2,0XF5,0XE2,0XF6,0X03,0XF6,0X24,0XF6,0X24,

72650XF6,0X44,0XF6,0X45,0XFE,0X65,0XFE,0X66,0XFE,0X66,0XFE,0X87,0XFE,0X87,0XF6,0X88,

72660XF6,0X88,0XFE,0X88,0XFE,0X88,0XFE,0XA9,0XFE,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

72670XFE,0X8A,0XFE,0X8A,0XFE,0XAA,0XFE,0X89,0XFE,0X89,0XFE,0X88,0XFE,0X89,0XFE,0XCB,

72680XF6,0XCC,0XE6,0X4D,0X8B,0XA5,0X49,0XA0,0X49,0XC2,0X41,0XC3,0X94,0X4F,0XFF,0X9D,

72690XFF,0XFE,0XFF,0XBE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XF7,0X55,

72790XEF,0X0E,0XF7,0X0B,0XFF,0X0A,0XFF,0X09,0XFF,0X0B,0XFE,0XCB,0XFE,0XCC,0XF6,0X6A,

72800XEE,0X26,0XDD,0XA3,0XC4,0XA0,0XB4,0X20,0XB4,0X00,0XB3,0XE0,0XAB,0XC0,0XA3,0X80,

72810X9B,0X40,0X9B,0X40,0XA3,0X80,0XAB,0XC0,0XB4,0X20,0XBC,0XA0,0XCC,0XE1,0XD5,0X01,

72820XD5,0X41,0XDD,0X61,0XE5,0X81,0XED,0XA2,0XED,0XA2,0XED,0XC2,0XED,0XE3,0XF5,0XE3,

72830XF6,0X04,0XF6,0X04,0XF6,0X25,0XF6,0X25,0XF6,0X26,0XFE,0X26,0XFE,0X47,0XFE,0X67,

72840XFE,0X67,0XFE,0X88,0XFE,0X88,0XFE,0XA9,0XFE,0XA9,0XFE,0X89,0XFE,0X89,0XFE,0X89,

72850XFE,0X89,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0X8A,0XFE,0X8A,

72860XFE,0X8A,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0XCA,0XFE,0XAA,0XEE,0X6A,0XF6,0XED,

72870XBD,0X29,0X62,0XA2,0X41,0X81,0X52,0X25,0XCD,0XF6,0XFF,0XDE,0XFF,0XDE,0XFF,0XBE,

72880XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

72970XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XB9,0XEF,0X32,0XEE,0XEC,0XEE,0XE9,

72980XFE,0XE9,0XFE,0XE9,0XFF,0X0A,0XFE,0XCA,0XFE,0XEC,0XEE,0X29,0XEE,0X06,0XDD,0X63,

72990XCC,0XE2,0XBC,0X81,0XB3,0XE0,0XB4,0X00,0XB4,0X00,0XAB,0XC0,0XAB,0XA0,0XAB,0XA0,

73000XB3,0XE0,0XB4,0X00,0XBC,0X40,0XC4,0XC0,0XCC,0XE1,0XD5,0X21,0XDD,0X62,0XE5,0X82,

73010XE5,0XC2,0XED,0XE3,0XF6,0X03,0XF6,0X04,0XF6,0X24,0XF6,0X25,0XF6,0X25,0XF6,0X26,

73020XF6,0X46,0XFE,0X47,0XFE,0X47,0XFE,0X48,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,

73030XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X8A,0XFE,0X8A,

73040XFE,0X8A,0XFE,0XAA,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X69,0XFE,0X69,

73050XFE,0X89,0XFE,0X89,0XFE,0X8A,0XF6,0X69,0XF6,0XAA,0XF6,0XED,0XEE,0XAE,0XA4,0X89,

73060X39,0X60,0X6A,0XE9,0XF7,0X5B,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

73070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73160XFF,0XFF,0XFF,0XDD,0XFF,0X77,0XEE,0XF0,0XEE,0XCB,0XF6,0XE9,0XFE,0XE9,0XFE,0XC8,

73170XFF,0X0A,0XF6,0XA9,0XFE,0XAA,0XEE,0X28,0XDD,0XA6,0XC4,0XE3,0XD5,0X24,0XCC,0XE2,

73180XBC,0X81,0XBC,0X60,0XB4,0X20,0XB4,0X20,0XBC,0X40,0XBC,0X40,0XBC,0X40,0XC4,0X60,

73190XCC,0XC0,0XD5,0X00,0XDD,0X42,0XE5,0X82,0XE5,0XC3,0XED,0XE3,0XEE,0X03,0XEE,0X24,

73200XEE,0X44,0XF6,0X44,0XF6,0X45,0XF6,0X65,0XFE,0X46,0XFE,0X66,0XFE,0X67,0XFE,0X88,

73210XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0X89,

73220XFE,0X89,0XFE,0X89,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0XA9,0XFE,0X8A,0XFE,0X89,

73230XFE,0XA9,0XFE,0X88,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,

73240XF6,0X47,0XFE,0XCA,0XEE,0X8A,0XEE,0X8C,0XE6,0XAF,0XD6,0X31,0X62,0XA6,0X9C,0X8F,

73250XFF,0XDD,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFC,

73350XF7,0X34,0XEE,0XCE,0XF6,0XCB,0XFE,0XC8,0XFE,0XC8,0XFE,0XC8,0XFE,0XE9,0XFE,0XEA,

73360XF6,0X69,0XE5,0XE8,0XCD,0X25,0XBC,0X83,0XC4,0XC3,0XCD,0X04,0XD5,0X23,0XC4,0XC1,

73370XBC,0X60,0XBC,0X80,0XC4,0XA0,0XC4,0X80,0XC4,0XA0,0XD4,0XE0,0XD4,0XE0,0XDD,0X20,

73380XE5,0X82,0XED,0XE3,0XF6,0X24,0XF6,0X45,0XF6,0X45,0XF6,0X65,0XF6,0X65,0XF6,0X66,

73390XFE,0X86,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X68,0XFE,0X89,0XFE,0XA9,

73400XFE,0XA8,0XFE,0XA8,0XFE,0XA8,0XFE,0XA8,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0X89,

73410XFE,0X89,0XFE,0X89,0XFE,0XA9,0XFE,0X89,0XFE,0X8A,0XFE,0X8A,0XFE,0XA9,0XFE,0XA9,

73420XFE,0XAA,0XFE,0X8A,0XFE,0X8B,0XFE,0X6B,0XFE,0X8A,0XFE,0X8B,0XEE,0X49,0XF6,0XCC,

73430XEE,0X8C,0XE6,0X8E,0XE6,0X71,0XE6,0XB4,0XC5,0XB2,0XDE,0XB8,0XFF,0XFE,0XFF,0XFE,

73440XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XDA,0XEE,0XF1,0XE6,0X8C,

73540XF6,0XCA,0XF6,0XA8,0XFE,0XA9,0XFE,0XC9,0XFE,0XA8,0XFE,0XC9,0XEE,0X08,0XE5,0XC8,

73550XBC,0XA4,0XB4,0X22,0XB4,0X42,0XC4,0XA3,0XCC,0XE3,0XCD,0X03,0XCC,0XE2,0XC4,0XC0,

73560XC4,0XC0,0XCC,0XE0,0XD5,0X20,0XDD,0X40,0XED,0X81,0XED,0XA2,0XF5,0XE3,0XF6,0X04,

73570XFE,0X45,0XFE,0X66,0XFE,0X67,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X89,

73580XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0XA8,0XFE,0XA8,

73590XFE,0XA8,0XFE,0XA8,0XF6,0XA9,0XF6,0XA9,0XF6,0XAA,0XF6,0XAA,0XF6,0XAA,0XF6,0X8A,

73600XF6,0XAA,0XF6,0X8A,0XF6,0X8B,0XF6,0XAB,0XEE,0X8A,0XEE,0X8B,0XEE,0X8B,0XEE,0X8C,

73610XEE,0X6D,0XEE,0X6E,0XEE,0X6E,0XEE,0X8F,0XF7,0X11,0XE6,0XB0,0XEE,0XB2,0XF7,0X35,

73620XFF,0XB9,0XF7,0X58,0XFF,0XDC,0XFF,0XBC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73720XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XF7,0X76,0XE6,0XAF,0XE6,0X6B,0XF6,0XAA,0XF6,0X88,

73730XFE,0X89,0XFE,0XAA,0XFE,0XC9,0XFE,0XA9,0XE5,0XE8,0XCD,0X26,0XA3,0XE2,0XA3,0XE2,

73740XAC,0X03,0XAC,0X23,0XB4,0X42,0XC4,0XA3,0XCD,0X03,0XCD,0X22,0XD5,0X21,0XD5,0X20,

73750XDD,0X60,0XE5,0XC1,0XED,0XC1,0XF5,0XE2,0XFE,0X24,0XFE,0X45,0XFE,0X66,0XFE,0X67,

73760XFE,0X68,0XFE,0X68,0XFE,0XA9,0XFE,0XA9,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,

73770XFE,0X69,0XFE,0X69,0XFE,0X89,0XF6,0X89,0XF6,0X89,0XF6,0X89,0XF6,0X89,0XF6,0X8A,

73780XEE,0X8A,0XEE,0X8A,0XEE,0XAB,0XEE,0X8C,0XEE,0X8C,0XEE,0X8D,0XEE,0X8D,0XEE,0X8D,

73790XEE,0X8D,0XE6,0X8D,0XE6,0X8E,0XE6,0XAF,0XEE,0XD1,0XF7,0X12,0XF7,0X34,0XFF,0X55,

73800XFF,0X97,0XFF,0XB8,0XFF,0XFA,0XFF,0XDA,0XFF,0XDA,0XFF,0XFC,0XFF,0XFD,0XFF,0XFD,

73810XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

73900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

73910XFF,0XDA,0XEE,0XD2,0XE6,0X8D,0XEE,0X8A,0XF6,0XA9,0XFE,0XA9,0XF6,0X69,0XFE,0X89,

73920XF6,0X68,0XEE,0X48,0XDD,0XC8,0XB4,0XA4,0X9B,0XC3,0XA3,0XE3,0XA3,0XE3,0X9B,0XC3,

73930XA3,0XE3,0XAC,0X23,0XBC,0X83,0XC4,0XC3,0XCD,0X02,0XCD,0X41,0XD5,0X61,0XE5,0XC2,

73940XED,0XC2,0XF5,0XE3,0XFE,0X44,0XFE,0X86,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X89,

73950XFE,0X89,0XF6,0X89,0XFE,0X89,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XF6,0XAA,

73960XF6,0XAA,0XF6,0XAB,0XEE,0XAB,0XEE,0XAC,0XEE,0XAD,0XEE,0XAD,0XEE,0XAE,0XEE,0XAF,

73970XE6,0X8F,0XE6,0X8F,0XE6,0XB1,0XEE,0XD2,0XF7,0X13,0XFF,0X34,0XFF,0X74,0XFF,0X76,

73980XFF,0XB9,0XFF,0XBA,0XFF,0XBB,0XFF,0XDB,0XFF,0XDC,0XFF,0XDC,0XFF,0XFD,0XFF,0XFE,

73990XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XDE,0XFF,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XD8,0XE6,0X8F,

74100XE6,0X6C,0XF6,0X8A,0XF6,0X68,0XFE,0X89,0XF6,0X69,0XFE,0X8A,0XF6,0X89,0XEE,0X49,

74110XCD,0X67,0X93,0XA1,0X8B,0X61,0X8B,0X62,0X93,0X83,0X93,0XC3,0X9B,0XC3,0XA3,0XE3,

74120XA4,0X02,0XAC,0X22,0XB4,0X82,0XC4,0XE2,0XCD,0X43,0XD5,0X63,0XE5,0XC3,0XEE,0X04,

74130XFE,0X46,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0XAA,0XF6,0XAA,0XF6,0X8B,

74140XF6,0X8B,0XEE,0X8B,0XEE,0X8B,0XEE,0X6B,0XEE,0X6B,0XEE,0X6C,0XEE,0X8C,0XEE,0XAD,

74150XEE,0XAE,0XEE,0XD0,0XEE,0XD1,0XF7,0X12,0XF7,0X13,0XF7,0X34,0XFF,0X76,0XFF,0X77,

74160XFF,0X98,0XFF,0X98,0XFF,0XB9,0XFF,0XBA,0XFF,0XDA,0XFF,0XDB,0XFF,0XFD,0XFF,0XFE,

74170XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XFF,0X75,0XDE,0X4C,0XEE,0X4B,0XF6,0X6A,

74290XEE,0X48,0XF6,0X88,0XF6,0X68,0XF6,0X89,0XEE,0X69,0XE6,0X29,0XB4,0X84,0X83,0X20,

74300X83,0X21,0X83,0X21,0X83,0X42,0X8B,0X62,0X93,0X83,0X93,0X82,0X93,0X82,0X9B,0XC2,

74310XA3,0XE2,0XA3,0XE1,0XAC,0X42,0XC4,0XE3,0XD5,0X64,0XE5,0XE5,0XF6,0X68,0XFE,0XA9,

74320XFE,0XAA,0XF6,0X8A,0XF6,0X8B,0XF6,0X8C,0XEE,0X8C,0XEE,0X8D,0XEE,0X8E,0XEE,0X8F,

74330XEE,0XB0,0XEE,0XD1,0XF6,0XF2,0XF7,0X13,0XF7,0X34,0XFF,0X55,0XFF,0X76,0XFF,0X97,

74340XFF,0XB8,0XFF,0XD9,0XFF,0XFA,0XFF,0XFB,0XFF,0XFB,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,

74350XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFF,

74360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XDE,0XFF,0XFF,0XF7,0XDE,0XFF,0XFF,

74370XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74470XFF,0XFF,0XFF,0XFB,0XEE,0XF1,0XDE,0X2A,0XE6,0X2A,0XF6,0X6A,0XF6,0X48,0XF6,0X68,

74480XF6,0X68,0XEE,0X48,0XE6,0X09,0XCD,0X87,0X93,0XA1,0X7B,0X00,0X83,0X20,0X8B,0X82,

74490X93,0XE3,0X9C,0X04,0XA4,0X24,0XA4,0X45,0XA4,0X45,0XAC,0X45,0XAC,0X44,0XAC,0X44,

74500XB4,0X64,0XBC,0XA4,0XC5,0X24,0XD5,0XA6,0XE6,0X28,0XEE,0X8A,0XEE,0X8A,0XEE,0X8B,

74510XF6,0XAC,0XF6,0XCD,0XFF,0X30,0XFF,0X31,0XFF,0X53,0XFF,0X74,0XFF,0X95,0XFF,0X97,

74520XFF,0XB8,0XFF,0XB9,0XFF,0XB9,0XFF,0XDA,0XFF,0XDB,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,

74530XFF,0XFC,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

74540XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

74550XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

74560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XBD,0XFF,0XDA,

74660XD6,0X0C,0XE6,0X49,0XEE,0X2A,0XF6,0X29,0XF6,0X28,0XF6,0X48,0XF6,0X68,0XF6,0X68,

74670XF6,0XCB,0XE6,0X4A,0XD5,0XE9,0XD5,0XE9,0XDE,0X4B,0XEE,0XAD,0XEE,0XED,0XEE,0XED,

74680XF7,0X0D,0XF7,0X0E,0XF7,0X0E,0XF7,0X0E,0XF6,0XEE,0XFF,0X0E,0XFE,0XED,0XF6,0XEC,

74690XF6,0XEB,0XFF,0X0C,0XFF,0X4D,0XFF,0X6D,0XFF,0X4E,0XFF,0X4E,0XFF,0X6F,0XFF,0X70,

74700XFF,0X91,0XFF,0X93,0XFF,0XB5,0XFF,0XD6,0XFF,0XD8,0XFF,0XF9,0XFF,0XFA,0XFF,0XFB,

74710XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

74720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFE,

74730XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74740XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

74840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XBC,0XFF,0X97,0XD6,0X0B,0XE6,0X28,

74850XEE,0X29,0XEE,0X29,0XF6,0X28,0XF6,0X47,0XF6,0X67,0XF6,0X68,0XFF,0X0C,0XFF,0X0C,

74860XFE,0XED,0XF6,0XEC,0XF6,0XCC,0XEE,0XAB,0XEE,0XAA,0XE6,0XAA,0XE6,0X69,0XE6,0X6A,

74870XE6,0X6A,0XE6,0X4A,0XE6,0X4A,0XE6,0X4A,0XE6,0X4A,0XE6,0X49,0XEE,0X8A,0XEE,0XAA,

74880XEE,0XCB,0XF6,0XCB,0XF6,0XCB,0XFF,0X0C,0XFF,0X2E,0XFF,0X4F,0XFF,0X91,0XFF,0X91,

74890XFF,0X72,0XFF,0X54,0XFF,0X55,0XFF,0X76,0XFF,0XB8,0XFF,0XD9,0XFF,0XDA,0XFF,0XFC,

74900XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

74910XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,

74920XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

74930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

74990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,

75030XFF,0XDF,0XFF,0XBE,0XFF,0XDB,0XE6,0X92,0XDE,0X0A,0XE6,0X28,0XEE,0X28,0XEE,0X28,

75040XEE,0X28,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X48,0XEE,0X49,0XEE,0X49,0XEE,0X49,

75050XEE,0X49,0XE6,0X49,0XEE,0X68,0XEE,0X68,0XEE,0X68,0XEE,0X68,0XEE,0X68,0XEE,0X49,

75060XEE,0X49,0XEE,0X49,0XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

75070XEE,0X28,0XEE,0X28,0XEE,0X29,0XEE,0X49,0XEE,0X4A,0XF6,0X8B,0XFE,0XCD,0XFF,0X0F,

75080XFF,0X30,0XFF,0X31,0XFF,0X32,0XFF,0X32,0XEF,0X54,0XF7,0X95,0XFF,0XB7,0XFF,0XFA,

75090XFF,0XFB,0XFF,0XFC,0XFF,0XDD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

75100XFF,0XFF,0XFF,0XDE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

75110XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

75120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75210XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,

75220XFF,0X99,0XD5,0XEE,0XDE,0X09,0XE6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

75230XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X48,0XEE,0X48,0XEE,0X48,

75240XEE,0X47,0XEE,0X47,0XEE,0X67,0XEE,0X47,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X28,

75250XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X28,0XF6,0X28,

75260XEE,0X08,0XEE,0X07,0XEE,0X28,0XEE,0X28,0XE6,0X09,0XE6,0X09,0XE6,0X2A,0XEE,0X6B,

75270XF6,0XAD,0XF7,0X0E,0XEF,0X2F,0XF7,0X71,0XF7,0X93,0XEF,0X53,0XEF,0X55,0XFF,0X98,

75280XFF,0XDA,0XFF,0XDB,0XFF,0XFD,0XFF,0XFD,0XFF,0XDE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFF,

75290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75300XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75400XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XBD,0XF7,0X15,0XD5,0XEC,

75410XE6,0X09,0XE6,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

75420XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X48,0XEE,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X67,

75430XEE,0X47,0XEE,0X47,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X47,0XEE,0X47,

75440XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

75450XE6,0X07,0XE6,0X27,0XE6,0X28,0XE6,0X28,0XE6,0X29,0XE6,0X29,0XE6,0X29,0XE6,0X49,

75460XDE,0X4A,0XDE,0X6A,0XEE,0XCC,0XF7,0X2F,0XFF,0X71,0XF7,0X31,0XF7,0X33,0XF7,0X55,

75470XFF,0X78,0XFF,0XDA,0XFF,0XDC,0XFF,0XDD,0XFF,0XDD,0XFF,0XFE,0XFF,0XDE,0XFF,0XDF,

75480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75590XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XBB,0XE6,0X91,0XD5,0XEB,0XE6,0X08,0XE6,0X07,

75600XE6,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X47,

75610XEE,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X27,

75620XEE,0X28,0XEE,0X48,0XEE,0X48,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,

75630XEE,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X28,

75640XEE,0X28,0XE6,0X28,0XE6,0X28,0XE6,0X28,0XE6,0X48,0XE6,0X48,0XE6,0X48,0XE6,0X48,

75650XDE,0X28,0XDE,0X28,0XE6,0X6A,0XF6,0XED,0XFF,0X30,0XFF,0X52,0XF7,0X13,0XF7,0X56,

75660XFF,0X98,0XFF,0XBA,0XFF,0XDC,0XFF,0XDD,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,

75780XFF,0XDD,0XFF,0X79,0XDE,0X4F,0XD5,0XEA,0XE6,0X08,0XE6,0X07,0XE6,0X08,0XE6,0X28,

75790XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,

75800XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,

75810XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X27,0XEE,0X27,

75820XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X48,

75830XEE,0X48,0XEE,0X28,0XEE,0X08,0XE6,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X06,0XE6,0X27,

75840XEE,0X28,0XE6,0X29,0XE6,0X4B,0XE6,0X6C,0XEE,0XF0,0XF7,0X32,0XF7,0X33,0XEF,0X35,

75850XF7,0X97,0XFF,0XFB,0XFF,0XFC,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75860XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

75960XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFE,0XFF,0XDB,0XEE,0XF4,

75970XD5,0XEC,0XDE,0X0A,0XE6,0X08,0XE6,0X07,0XE6,0X08,0XEE,0X08,0XE6,0X27,0XEE,0X27,

75980XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X08,0XEE,0X07,0XEE,0X27,

75990XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X27,

76000XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76010XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE5,0XE7,0XE5,0XE7,0XEE,0X07,

76020XEE,0X08,0XEE,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XE5,0XE6,0XE5,0XC6,0XE5,0XE7,

76030XE6,0X29,0XE6,0X4A,0XDE,0X0A,0XEE,0X8D,0XF7,0X10,0XF7,0X52,0XF7,0X53,0XEF,0X34,

76040XF7,0X97,0XFF,0XDA,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

76050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76150XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFA,0XDE,0X91,0XCD,0XCA,0XDD,0XE8,

76160XE6,0X08,0XE6,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X27,0XEE,0X27,

76170XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

76180XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76190XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76200XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76210XED,0XE6,0XED,0XE6,0XF6,0X07,0XF6,0X27,0XF6,0X28,0XEE,0X07,0XE6,0X07,0XE6,0X07,

76220XE6,0X08,0XDD,0XE8,0XDD,0XE9,0XE6,0X6B,0XFF,0X0F,0XFF,0X72,0XFF,0X72,0XF7,0X33,

76230XFF,0XF9,0XFF,0XFB,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

76250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

76340XFF,0XDE,0XFF,0XFC,0XF7,0X97,0XCE,0X0D,0XD5,0XE9,0XDE,0X08,0XE6,0X08,0XED,0XE7,

76350XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X26,0XEE,0X07,0XEE,0X27,

76360XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76370XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

76380XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76390XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

76400XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X27,0XE6,0X27,

76410XE6,0X28,0XE6,0X08,0XE6,0X09,0XEE,0X6B,0XFF,0X0F,0XFF,0X92,0XF7,0X33,0XFF,0XD7,

76420XFF,0XFA,0XFF,0XBB,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76430XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFE,0XFF,0XDB,

76530XEF,0X14,0XCD,0XCB,0XD5,0XE8,0XE6,0X08,0XE5,0XE8,0XED,0XE7,0XEE,0X07,0XEE,0X07,

76540XE6,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

76550XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76560XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

76570XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76580XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

76590XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X07,0XE6,0X07,0XE6,0X07,

76600XE5,0XE8,0XE6,0X09,0XEE,0X4B,0XF6,0X8D,0XFF,0X51,0XF7,0X52,0XFF,0X95,0XFF,0XD9,

76610XFF,0XFB,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

76620XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XBE,0XFF,0XFE,0XFF,0XBA,0XDE,0XB1,0XCD,0XEB,

76720XD5,0XC8,0XE6,0X07,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X08,

76730XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76740XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76750XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76760XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76770XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

76780XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X08,0XE5,0XE8,

76790XE5,0XC8,0XE5,0XE9,0XE6,0X6B,0XF7,0X2F,0XFF,0X92,0XFF,0X74,0XFF,0X97,0XFF,0XDB,

76800XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

76810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

76900XFF,0XFF,0XFF,0XDE,0XFF,0XDD,0XF7,0X77,0XD6,0X0D,0XD5,0XE9,0XD5,0XC7,0XE6,0X08,

76910XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X08,0XEE,0X07,0XEE,0X07,

76920XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76930XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76940XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76950XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

76960XEE,0X27,0XE6,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

76970XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XED,0XE7,0XED,0XC8,0XED,0XC8,0XEE,0X08,

76980XDD,0XC7,0XE6,0X49,0XF6,0XED,0XFF,0X51,0XFF,0X74,0XFF,0X97,0XFF,0XDB,0XFF,0XFD,

76990XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

77090XFF,0XBB,0XEE,0XF5,0XCD,0XEB,0XD5,0XA8,0XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,

77100XE6,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

77110XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77120XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77130XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77140XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77150XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,

77160XEE,0X06,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XED,0XE7,0XED,0XE7,0XEE,0X27,0XDD,0XE6,

77170XDE,0X08,0XF6,0XCD,0XFF,0X51,0XFF,0X74,0XFF,0X97,0XFF,0XDA,0XFF,0XFC,0XFF,0XFD,

77180XFF,0XFE,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBB,0XDE,0X72,

77280XD5,0XCA,0XD5,0XC7,0XE6,0X08,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

77290XE6,0X08,0XE6,0X08,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

77300XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77310XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77320XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77330XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,

77340XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X06,

77350XED,0XE6,0XED,0XE6,0XEE,0X06,0XEE,0X07,0XE5,0XC6,0XF6,0X69,0XE6,0X28,0XD5,0XC7,

77360XEE,0X8C,0XFF,0X30,0XFF,0X53,0XFF,0X95,0XFF,0XD8,0XFF,0XFA,0XFF,0XFD,0XFF,0XFE,

77370XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0X99,0XCD,0XCE,0XCD,0XA9,0XDD,0XE7,

77470XE5,0XE8,0XE5,0XA7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X08,

77480XED,0XE7,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,

77490XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77500XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77510XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77520XEE,0X27,0XEE,0X28,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,

77530XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X06,0XE6,0X06,0XEE,0X06,0XEE,0X27,

77540XEE,0X27,0XE5,0XE6,0XF6,0X48,0XDD,0XA6,0XEE,0X07,0XEE,0X48,0XD5,0XC7,0XE6,0X4A,

77550XFF,0X50,0XF7,0X51,0XFF,0X94,0XFF,0XD8,0XFF,0XFB,0XFF,0XFD,0XFF,0XDF,0XFF,0XDF,

77560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77650XFF,0XFF,0XFF,0XDC,0XF7,0X17,0XC5,0X8C,0XD5,0XC8,0XE5,0XE7,0XE5,0XC7,0XE5,0XC7,

77660XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X08,0XED,0XE7,0XEE,0X07,

77670XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

77680XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77690XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77700XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,

77710XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

77720XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,

77730XEE,0X07,0XEE,0X07,0XE5,0XE7,0XE5,0XE7,0XE6,0X08,0XDD,0XE7,0XDE,0X29,0XF6,0XED,

77740XF7,0X30,0XFF,0XB4,0XFF,0XD8,0XFF,0XDC,0XFF,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

77750XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBB,

77840XDE,0X52,0XC5,0X4B,0XDD,0XE9,0XE5,0XE7,0XE5,0XC7,0XED,0XE8,0XE5,0XE7,0XE5,0XE7,

77850XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

77860XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

77870XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77880XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X27,

77890XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

77900XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

77910XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE5,0XE7,0XEE,0X07,

77920XE5,0XE7,0XE6,0X07,0XEE,0X07,0XE5,0XE7,0XDE,0X07,0XE6,0X69,0XF6,0XED,0XEF,0X10,

77930XEF,0X34,0XFF,0XB9,0XFF,0XFD,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77940XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

77990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XBA,0XC5,0X8E,0XCD,0X6B,

78030XE6,0X09,0XE5,0XC7,0XE5,0XC7,0XED,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,

78040XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,

78050XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

78060XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

78070XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

78080XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X07,

78090XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

78100XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X06,0XEE,0X06,0XE6,0X06,0XE6,0X07,

78110XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X28,0XDE,0X28,0XF7,0X0E,0XEE,0XD0,0XE6,0XD3,

78120XFF,0XBA,0XFF,0XFD,0XFF,0XDD,0XFF,0XDE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78130XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78210XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XF7,0X17,0XBD,0X4C,0XD5,0XCB,0XDD,0XC8,0XE5,0XC7,

78220XE5,0XC7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,

78230XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

78240XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

78250XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

78260XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X28,0XEE,0X28,

78270XEE,0X28,0XEE,0X28,0XE6,0X28,0XE6,0X28,0XE6,0X28,0XE6,0X27,0XEE,0X07,0XEE,0X07,

78280XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

78290XEE,0X07,0XEE,0X26,0XEE,0X26,0XE6,0X26,0XE6,0X06,0XE6,0X07,0XEE,0X07,0XEE,0X27,

78300XEE,0X27,0XE6,0X07,0XE6,0X07,0XE6,0X4A,0XEE,0XAE,0XDE,0X4F,0XE6,0XB3,0XFF,0XBA,

78310XFF,0XDC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

78400XFF,0XFC,0XD6,0X11,0XC5,0X6B,0XDD,0XEA,0XDD,0XA8,0XE5,0XC7,0XEE,0X08,0XE5,0XC7,

78410XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

78420XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

78430XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

78440XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

78450XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

78460XE6,0X27,0XE6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,

78470XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

78480XE6,0X26,0XE6,0X25,0XEE,0X26,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE5,0XE6,

78490XEE,0X27,0XDD,0XC7,0XE6,0X6A,0XEE,0X8D,0XC5,0X8C,0XDE,0X72,0XFF,0XDA,0XFF,0XDC,

78500XFF,0XFD,0XFF,0XDD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XDA,0XBD,0X4D,

78590XCD,0XAB,0XDD,0XC9,0XDD,0XC8,0XDD,0XA7,0XEE,0X28,0XE5,0XE7,0XE5,0XE8,0XE5,0XE8,

78600XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

78610XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,

78620XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

78630XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

78640XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

78650XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,

78660XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X26,0XE6,0X26,

78670XEE,0X27,0XEE,0X27,0XEE,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XE5,0XE6,0XEE,0X48,

78680XE6,0X07,0XE6,0X4A,0XDE,0X2C,0XAC,0XC9,0XD6,0X32,0XFF,0X99,0XFF,0XFD,0XFF,0XDD,

78690XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

78700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

78770XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XF7,0X16,0XBD,0X4C,0XD5,0XCA,0XD5,0XC8,

78780XE6,0X09,0XDD,0XC7,0XE6,0X07,0XE5,0XE7,0XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,

78790XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,

78800XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

78810XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

78820XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

78830XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,

78840XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

78850XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X26,0XE6,0X07,0XE6,0X07,

78860XE6,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XE6,0X06,0XEE,0X27,0XE6,0X28,

78870XE6,0X2A,0XCD,0XCB,0X8B,0XC6,0XD6,0X53,0XFF,0XDB,0XFF,0XFD,0XFF,0XFE,0XFF,0XDE,

78880XF7,0XBE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

78950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XFF,0XFF,

78960XFF,0XFE,0XFF,0XDC,0XCD,0XF0,0XC5,0X6B,0XCD,0XA8,0XD5,0XA7,0XE5,0XE8,0XE5,0XE8,

78970XDD,0XC7,0XDD,0XE7,0XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,

78980XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

78990XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

79000XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

79010XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

79020XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

79030XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,

79040XEE,0X27,0XEE,0X07,0XEE,0X06,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XEE,0X28,0XEE,0X28,

79050XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X06,0XEE,0X26,0XE6,0X26,0XE6,0X28,0XDE,0X2A,

79060XCD,0X8B,0X73,0X04,0XDE,0XB6,0XF7,0X9B,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

79070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0X99,

79150XC5,0X6C,0XD5,0XCA,0XDD,0XC8,0XDD,0XC8,0XE5,0XE8,0XE5,0XE8,0XE5,0XE8,0XE5,0XE8,

79160XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,

79170XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X07,0XEE,0X08,0XEE,0X28,

79180XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

79190XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

79200XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,

79210XEE,0X08,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

79220XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

79230XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X08,0XEE,0X08,0XEE,0X09,0XEE,0X08,

79240XEE,0X07,0XEE,0X07,0XEE,0X05,0XEE,0X26,0XEE,0X27,0XE6,0X09,0XCD,0X89,0XAC,0XA8,

79250X73,0X05,0XD6,0X74,0XFF,0XBC,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XFF,0XFF,

79260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79330XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFC,0XE6,0XD4,0XBD,0X4A,0XD5,0XA8,

79340XDD,0XC8,0XE5,0XE7,0XE5,0XE7,0XED,0XE7,0XE5,0XE8,0XE5,0XC8,0XE5,0XE8,0XE5,0XE7,

79350XE6,0X07,0XE5,0XE6,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

79360XEE,0X07,0XEE,0X08,0XEE,0X28,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X28,

79370XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XE6,0X27,0XE6,0X27,0XEE,0X48,0XEE,0X27,

79380XEE,0X28,0XEE,0X27,0XEE,0X07,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,

79390XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X27,

79400XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X07,

79410XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,

79420XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X09,0XEE,0X08,0XEE,0X08,0XEE,0X07,

79430XEE,0X06,0XEE,0X26,0XEE,0X07,0XE6,0X08,0XDD,0XC9,0XC5,0X29,0X72,0XE2,0X83,0XA8,

79440XE6,0X96,0XFF,0XBD,0XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79520XFF,0XDF,0XFF,0XFE,0XFF,0XDB,0XD6,0X31,0XC5,0X89,0XD5,0XE8,0XDD,0XE7,0XDD,0XE6,

79530XE5,0XE6,0XE5,0XC6,0XDD,0XC7,0XDD,0XC7,0XDD,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

79540XE6,0X07,0XE6,0X08,0XE6,0X08,0XE6,0X08,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

79550XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X28,0XEE,0X28,

79560XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

79570XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

79580XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

79590XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X07,

79600XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X07,0XEE,0X27,0XEE,0X27,

79610XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X06,

79620XEE,0X07,0XEE,0X08,0XE6,0X09,0XD5,0XAA,0XA4,0X87,0X5A,0X62,0X94,0X0B,0XEE,0XF9,

79630XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XFF,0XDF,0XFF,0XDE,

79710XF7,0X58,0XBD,0X8D,0XCD,0XA9,0XD5,0XE7,0XDD,0XE6,0XDD,0XE6,0XE5,0XC6,0XE5,0XC6,

79720XE5,0XE7,0XE5,0XE8,0XDD,0XE7,0XDD,0XE7,0XDD,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE8,

79730XE6,0X08,0XE6,0X08,0XE6,0X08,0XE6,0X07,0XE6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,

79740XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

79750XF6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X48,0XEE,0X48,

79760XEE,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,

79770XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

79780XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

79790XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X27,0XEE,0X26,0XEE,0X26,0XEE,0X27,

79800XEE,0X27,0XEE,0X28,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,

79810XE6,0X08,0XD5,0XC9,0XC5,0X49,0X83,0X64,0X52,0X22,0XA4,0XCF,0XFF,0XBC,0XFF,0XFE,

79820XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

79890XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDD,0XDE,0XB4,0XBD,0X6B,

79900XCD,0XA9,0XDD,0XE7,0XDD,0XE6,0XE5,0XE6,0XE5,0XE6,0XE5,0XC6,0XE5,0XE7,0XE5,0XE8,

79910XE5,0XE8,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

79920XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X27,0XEE,0X27,0XEE,0X27,

79930XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,

79940XEE,0X28,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X48,

79950XEE,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

79960XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

79970XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

79980XEE,0X08,0XEE,0X28,0XEE,0X27,0XEE,0X26,0XEE,0X46,0XEE,0X46,0XEE,0X27,0XEE,0X27,

79990XEE,0X28,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X28,0XE6,0X08,0XDD,0XE8,

80000XC5,0X68,0X8B,0XC4,0X62,0X82,0X62,0XC6,0XB5,0X72,0XFF,0XDD,0XFF,0XDD,0XFF,0XFE,

80010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80080XFF,0XDF,0XFF,0XFF,0XFF,0XDE,0XFF,0X9B,0XCD,0XF0,0XBD,0X6A,0XCD,0XA7,0XDD,0XC6,

80090XDD,0XA5,0XDD,0XA4,0XE5,0XC5,0XE5,0XC5,0XE5,0XC6,0XE5,0XE7,0XE5,0XC6,0XDD,0XE6,

80100XE5,0XE6,0XE5,0XE6,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,

80110XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,

80120XEE,0X28,0XEE,0X28,0XEE,0X28,0XF6,0X08,0XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X47,

80130XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

80140XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

80150XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

80160XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X08,0XEE,0X08,

80170XEE,0X27,0XEE,0X26,0XEE,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X08,

80180XF6,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XE6,0X07,0XE6,0X49,0XD5,0XA8,0XBD,0X28,

80190X6A,0XC2,0X41,0XA0,0X62,0XE7,0XF7,0X9B,0XF7,0XBC,0XFF,0XDE,0XFF,0XFE,0XFF,0XFF,

80200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

80270XFF,0XBD,0XEF,0X38,0XC5,0XCE,0XC5,0X8A,0XDE,0X08,0XEE,0X27,0XEE,0X26,0XF6,0X26,

80280XFE,0X46,0XFE,0X67,0XFE,0X88,0XFE,0X88,0XFE,0XA9,0XFE,0XA8,0XFE,0XA8,0XFE,0XA9,

80290XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0X69,0XFE,0X69,0XFE,0X8A,0XFE,0XAA,

80300XFE,0X8A,0XF6,0X69,0XEE,0X49,0XEE,0X28,0XE6,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X29,

80310XEE,0X28,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XF6,0X47,

80320XF6,0X48,0XF6,0X48,0XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X28,

80330XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

80340XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

80350XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X26,

80360XEE,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XF6,0X27,0XEE,0X27,

80370XEE,0X27,0XEE,0X27,0XEE,0X28,0XF6,0X6A,0XDD,0XE8,0XC5,0X47,0X8B,0XA4,0X5A,0X41,

80380X49,0XE3,0X7B,0XCB,0XFF,0XBC,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFD,0XF7,0X58,

80460XDE,0X92,0XDE,0X6E,0XEE,0X6B,0XF6,0X8A,0XFE,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0X89,

80470XFE,0X88,0XF6,0X68,0XFE,0X88,0XF6,0X88,0XF6,0X67,0XF6,0X47,0XF6,0X27,0XEE,0X06,

80480XED,0XE6,0XED,0XC6,0XE5,0XA5,0XE5,0X85,0XE5,0X86,0XE5,0X86,0XE5,0XA6,0XDD,0XC7,

80490XE5,0XC8,0XE5,0XE8,0XE6,0X29,0XEE,0X2A,0XEE,0X4A,0XEE,0X4A,0XEE,0X4A,0XEE,0X4A,

80500XEE,0X2A,0XEE,0X29,0XEE,0X48,0XEE,0X47,0XE6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

80510XF6,0X48,0XF6,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X08,0XF6,0X08,0XEE,0X28,0XEE,0X27,

80520XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

80530XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

80540XEE,0X28,0XEE,0X28,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X26,0XEE,0X26,0XEE,0X27,

80550XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XF6,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X27,

80560XEE,0X08,0XF6,0X6A,0XE5,0XE8,0XCD,0X87,0X9C,0X25,0X62,0X61,0X52,0X23,0X5A,0X86,

80570XBD,0XD4,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0X9A,0XF7,0X36,0XEE,0XD2,

80650XEE,0X8F,0XEE,0X6D,0XEE,0X6C,0XF6,0X6B,0XF6,0X4A,0XF6,0X4A,0XEE,0X49,0XEE,0X49,

80660XEE,0X48,0XEE,0X27,0XF6,0X26,0XED,0XE6,0XED,0XC6,0XED,0XC6,0XED,0XA5,0XE5,0XA4,

80670XDD,0X63,0XDD,0X23,0XD5,0X03,0XCC,0XC2,0XC4,0XA2,0XBC,0X82,0XAC,0X42,0XAC,0X22,

80680XA4,0X22,0XAC,0X43,0XB4,0X84,0XBC,0XC5,0XC5,0X27,0XD5,0X88,0XDD,0XE9,0XE6,0X09,

80690XE6,0X29,0XEE,0X8A,0XEE,0X89,0XEE,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X06,0XEE,0X27,

80700XF6,0X27,0XF6,0X27,0XF6,0X07,0XEE,0X08,0XF6,0X48,0XEE,0X27,0XEE,0X07,0XEE,0X27,

80710XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

80720XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

80730XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

80740XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X48,

80750XEE,0X28,0XD5,0XA7,0XB4,0XA6,0X72,0XC2,0X52,0X02,0X49,0XE3,0X7B,0XAC,0XE7,0X1A,

80760XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80830XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0X9A,0XFF,0X78,0XFF,0X56,0XFF,0X34,

80840XF6,0XF2,0XF6,0XB0,0XF6,0X8E,0XEE,0X4D,0XEE,0X4C,0XEE,0X4B,0XEE,0X6A,0XF6,0X49,

80850XF6,0X48,0XF6,0X27,0XF6,0X07,0XF6,0X07,0XF6,0X06,0XED,0XE5,0XED,0XE5,0XED,0XC5,

80860XE5,0X85,0XD5,0X45,0XCD,0X05,0XBC,0XC4,0XB4,0X84,0XAC,0X64,0X9C,0X03,0X93,0XC3,

80870X8B,0X82,0X8B,0X82,0X83,0X41,0X83,0X21,0X8B,0XA2,0XA4,0X44,0XB4,0XC5,0XC5,0X67,

80880XDE,0X09,0XEE,0X6A,0XEE,0X8A,0XEE,0X49,0XEE,0X27,0XED,0XE6,0XF6,0X27,0XEE,0X27,

80890XF6,0X48,0XF6,0X47,0XED,0XE6,0XEE,0X27,0XF6,0X68,0XEE,0X27,0XEE,0X27,0XEE,0X27,

80900XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X27,0XEE,0X27,

80910XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

80920XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

80930XEE,0X27,0XEE,0X27,0XEE,0X27,0XF6,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X48,0XDD,0XE7,

80940XC5,0X28,0X72,0XE1,0X52,0X22,0X4A,0X04,0X52,0X66,0XB5,0X94,0XFF,0XDD,0XFF,0XFE,

80950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

80990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,

81020XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDD,0XFF,0XDC,0XFF,0XBA,0XFF,0X99,0XFF,0X77,

81030XFF,0X35,0XF6,0XF2,0XEE,0XD0,0XEE,0XAE,0XEE,0X8C,0XEE,0X6B,0XEE,0X49,0XEE,0X28,

81040XF6,0X28,0XF6,0X27,0XF6,0X26,0XEE,0X26,0XF6,0X27,0XEE,0X28,0XEE,0X28,0XE5,0XE8,

81050XDD,0XA8,0XCD,0X48,0XBD,0X08,0XB4,0XE8,0XB4,0XC8,0XAC,0X88,0X9C,0X06,0X8B,0XA5,

81060X83,0X84,0X83,0X84,0X73,0X22,0X62,0X80,0X6A,0XA0,0X6A,0XC0,0X8B,0X83,0XAC,0X86,

81070XCD,0X69,0XE6,0X0A,0XF6,0X6B,0XF6,0X6A,0XEE,0X07,0XEE,0X47,0XF6,0X46,0XEE,0X46,

81080XEE,0X26,0XEE,0X46,0XEE,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

81090XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X28,

81100XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

81110XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

81120XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X28,0XF6,0X48,0XE6,0X08,0XC5,0X48,0X83,0X43,

81130X52,0X21,0X52,0X23,0X39,0XA3,0X83,0XCC,0XEF,0X5A,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

81140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFE,0XFF,0XDF,

81210XFF,0XBF,0XFF,0XBF,0XFF,0XDF,0XFF,0XDE,0XFF,0XDD,0XFF,0XDC,0XFF,0XDA,0XFF,0XB8,

81220XFF,0X96,0XFF,0X74,0XF7,0X11,0XF6,0XEF,0XF6,0XAE,0XEE,0X6C,0XEE,0X4B,0XEE,0X2A,

81230XEE,0X29,0XEE,0X29,0XE6,0X29,0XE6,0X2A,0XE6,0X2B,0XDE,0X0B,0XD5,0XCB,0XCD,0X8B,

81240XC5,0X4B,0XBD,0X4C,0XB4,0XEB,0XA4,0XAB,0XA4,0XAB,0XA4,0XCB,0XA4,0X8B,0X8C,0X08,

81250X83,0X87,0X83,0X87,0X6A,0XE4,0X62,0X82,0X52,0X00,0X51,0XE0,0X6A,0X81,0X8B,0X84,

81260XBC,0XE8,0XE6,0X0B,0XEE,0X8B,0XE6,0X28,0XE6,0X26,0XEE,0X46,0XEE,0X47,0XEE,0X46,

81270XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X27,

81280XEE,0X27,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

81290XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

81300XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,

81310XF6,0X28,0XEE,0X47,0XF6,0X68,0XEE,0X48,0XCD,0X47,0X93,0XE4,0X52,0X00,0X52,0X03,

81320X41,0XC3,0X5A,0X87,0XC5,0XF4,0XFF,0XDC,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81390XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XBF,0XFF,0XDF,

81400XFF,0XDF,0XFF,0XDF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,0XFF,0XFA,

81410XFF,0XD8,0XFF,0XB7,0XFF,0X55,0XFF,0X13,0XF6,0XB1,0XEE,0X90,0XE6,0X6F,0XE6,0X8E,

81420XEE,0XB0,0XEE,0XD0,0XF6,0XF1,0XF7,0X12,0XF7,0X13,0XF7,0X14,0XEF,0X15,0XEF,0X15,

81430XF7,0X57,0XF7,0X58,0XF7,0X58,0XEF,0X17,0XEF,0X17,0XEF,0X17,0XE6,0XD6,0XDE,0X95,

81440XCE,0X13,0XC5,0XD3,0XAD,0X10,0X94,0X2C,0X7B,0X69,0X5A,0X23,0X51,0XE0,0X6A,0XA1,

81450XA4,0X86,0XD6,0X0A,0XEE,0XAB,0XE6,0X48,0XE6,0X27,0XEE,0X47,0XEE,0X27,0XEE,0X27,

81460XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X28,0XEE,0X48,

81470XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

81480XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

81490XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,

81500XF6,0X67,0XEE,0X69,0XCD,0X87,0XA4,0X45,0X5A,0X40,0X49,0XC1,0X52,0X24,0X41,0XE4,

81510X8C,0X2C,0XF7,0X7A,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,

81600XFF,0XDB,0XFF,0XBA,0XFF,0XB9,0XFF,0XB9,0XFF,0XD8,0XFF,0XF8,0XFF,0XD8,0XFF,0XF9,

81610XFF,0XF9,0XFF,0XFA,0XFF,0XFA,0XFF,0XFB,0XFF,0XFB,0XFF,0XFC,0XFF,0XDB,0XFF,0XFC,

81620XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XBC,

81630XFF,0XFE,0XFF,0XFD,0XFF,0X7C,0XFF,0X9B,0XEE,0XF7,0XB5,0X50,0X94,0X09,0X9C,0X48,

81640XC5,0X6A,0XDE,0X2B,0XE6,0X2A,0XE6,0X09,0XEE,0X49,0XEE,0X28,0XEE,0X27,0XEE,0X27,

81650XF6,0X27,0XEE,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X48,0XEE,0X48,

81660XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

81670XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

81680XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X67,0XEE,0X68,

81690XDE,0X09,0XA4,0X45,0X6A,0XA2,0X49,0XA0,0X52,0X03,0X41,0XC2,0X62,0XC7,0XDE,0XB7,

81700XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,

81770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDE,

81790XFF,0XDD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,

81800XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,

81820XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XFF,0XFD,0XFF,0XBC,0XF7,0X59,0XF7,0X16,0XFF,0X14,

81830XF6,0XB0,0XE6,0X2C,0XE5,0XE9,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XF6,0X27,0XEE,0X47,

81840XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X48,

81850XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

81860XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X27,

81870XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XEE,0X47,0XEE,0X68,0XE6,0X4A,0XA4,0X65,

81880X72,0XE2,0X49,0XC0,0X49,0XE2,0X41,0XE3,0X4A,0X24,0XB5,0X92,0XFF,0XBC,0XFF,0XFE,

81890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81960XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81980XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

81990XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82000XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,

82010XFF,0XFF,0XFF,0XDF,0XFF,0XBF,0XFF,0XDE,0XFF,0XDD,0XFF,0XBA,0XFF,0X96,0XFE,0XF2,

82020XEE,0X6E,0XE6,0X2B,0XEE,0X29,0XEE,0X28,0XEE,0X28,0XEE,0X47,0XEE,0X27,0XEE,0X27,

82030XEE,0X28,0XF6,0X48,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X28,0XEE,0X28,

82040XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

82050XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XF6,0X27,0XF6,0X27,

82060XF6,0X27,0XF6,0X47,0XF6,0X67,0XEE,0X68,0XE6,0X4A,0XAC,0XA6,0X6A,0XA1,0X49,0XE0,

82070X41,0XC1,0X49,0XE3,0X39,0XA2,0X94,0X6E,0XF7,0X9B,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

82080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82190XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

82200XFF,0XBF,0XFF,0XBF,0XFF,0XBE,0XFF,0XDD,0XFF,0XFC,0XFF,0XD9,0XF7,0X55,0XEE,0XF1,

82210XE6,0X4B,0XE6,0X28,0XE6,0X27,0XEE,0X47,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,

82220XEE,0X48,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,

82230XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X47,

82240XEE,0X47,0XF6,0X48,0XF6,0X48,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X47,

82250XF6,0X67,0XF6,0X68,0XEE,0X6A,0XC5,0X28,0X72,0XC1,0X49,0XC0,0X49,0XE1,0X49,0XE3,

82260X39,0XA2,0X63,0X08,0XE7,0X1A,0XFF,0XBE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

82270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

82390XFF,0XDF,0XFF,0XDE,0XFF,0XDD,0XFF,0XFC,0XFF,0XDA,0XFF,0XB8,0XF7,0X32,0XEE,0X8D,

82400XDE,0X29,0XE6,0X27,0XEE,0X47,0XEE,0X27,0XEE,0X08,0XEE,0X28,0XF6,0X48,0XEE,0X47,

82410XEE,0X47,0XEE,0X47,0XEE,0X48,0XEE,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

82420XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

82430XF6,0X48,0XF6,0X48,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X68,

82440XEE,0X6A,0XCD,0X69,0X72,0XC1,0X51,0XE0,0X49,0XE1,0X49,0XE3,0X41,0XE3,0X4A,0X25,

82450XD6,0X98,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82570XFF,0XFF,0XFF,0XFE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

82580XFF,0XDE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFB,0XFF,0XBA,0XFF,0X35,0XEE,0X8E,0XDE,0X4A,

82590XE6,0X28,0XEE,0X48,0XEE,0X28,0XEE,0X07,0XF6,0X48,0XEE,0X47,0XF6,0X47,0XEE,0X47,

82600XEE,0X48,0XEE,0X48,0XF6,0X48,0XEE,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,

82610XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

82620XF6,0X28,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XEE,0X6A,0XDD,0XCA,

82630X7A,0XE1,0X52,0X00,0X51,0XE1,0X49,0XE2,0X49,0XE3,0X39,0XA3,0XB5,0X94,0XFF,0XDE,

82640XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

82730XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFE,

82770XFF,0XDD,0XFF,0XBD,0XFF,0XDD,0XFF,0XDB,0XFF,0X76,0XEE,0XCF,0XE6,0X4A,0XE6,0X49,

82780XEE,0X48,0XEE,0X28,0XEE,0X27,0XEE,0X28,0XF6,0X48,0XEE,0X48,0XEE,0X47,0XEE,0X47,

82790XF6,0X67,0XEE,0X47,0XEE,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

82800XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

82810XFE,0X48,0XF6,0X67,0XF6,0X47,0XF6,0X48,0XF6,0X6A,0XE6,0X0B,0X7B,0X02,0X52,0X00,

82820X52,0X02,0X49,0XC2,0X41,0XE3,0X41,0XC3,0X8C,0X2E,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,

82830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

82950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

82960XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XFF,0X97,0XEE,0XD0,0XDE,0X4B,0XDE,0X28,0XEE,0X68,

82970XEE,0X27,0XEE,0X28,0XF6,0X48,0XF6,0X48,0XEE,0X47,0XEE,0X67,0XEE,0X67,0XEE,0X47,

82980XEE,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

82990XEE,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XFE,0X48,0XF6,0X67,

83000XF6,0X67,0XF6,0X48,0XF6,0X6A,0XE6,0X0B,0X83,0X22,0X51,0XE0,0X52,0X02,0X49,0XE3,

83010X41,0XC2,0X42,0X04,0X6B,0X4A,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

83150XFF,0XDE,0XFF,0XFC,0XFF,0X97,0XEE,0XF0,0XE6,0X4A,0XE6,0X28,0XEE,0X48,0XEE,0X28,

83160XF6,0X48,0XF6,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X67,0XEE,0X47,0XEE,0X48,0XF6,0X47,

83170XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XF6,0X48,

83180XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X68,0XF6,0X48,

83190XF6,0X6A,0XE6,0X2B,0X8B,0X63,0X52,0X00,0X5A,0X22,0X52,0X03,0X49,0XE2,0X41,0XE3,

83200X5A,0XC8,0XF7,0X9C,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,

83340XFF,0XFB,0XFF,0XB7,0XEE,0XF0,0XDE,0X2B,0XE6,0X29,0XEE,0X28,0XF6,0X48,0XF6,0X47,

83350XF6,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

83360XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

83370XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X48,0XF6,0X6A,0XE6,0X2B,

83380X93,0XC4,0X5A,0X20,0X52,0X01,0X52,0X02,0X4A,0X03,0X41,0XC2,0X52,0X66,0XEF,0X3B,

83390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFD,0XFF,0XDA,

83530XFF,0X76,0XF6,0XF1,0XD5,0XEA,0XDE,0X08,0XEE,0X28,0XF6,0X47,0XF6,0X27,0XEE,0X27,

83540XF6,0X47,0XF6,0X68,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

83550XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,

83560XF6,0X47,0XF6,0X47,0XFE,0X68,0XF6,0X69,0XF6,0X69,0XEE,0X4B,0X9C,0X04,0X62,0X40,

83570X52,0X01,0X52,0X22,0X4A,0X02,0X41,0XE2,0X4A,0X05,0XDE,0XF9,0XFF,0XFF,0XFF,0XFF,

83580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XBA,0XFF,0X96,

83720XE6,0X8E,0XDE,0X2A,0XE6,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X48,0XF6,0X27,0XF6,0X47,

83730XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

83740XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

83750XFE,0X68,0XF6,0X69,0XF6,0X49,0XEE,0X6B,0XA4,0X45,0X6A,0X80,0X5A,0X21,0X52,0X22,

83760X4A,0X02,0X4A,0X23,0X41,0XE4,0XD6,0X77,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83900XFF,0XFF,0XFF,0XDE,0XFF,0XDF,0XFF,0XDE,0XFF,0XDC,0XFF,0XB9,0XFF,0X53,0XDE,0X4C,

83910XDE,0X09,0XEE,0X49,0XF6,0X48,0XF6,0X27,0XF6,0X27,0XFE,0X68,0XF6,0X47,0XF6,0X47,

83920XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,

83930XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XFE,0X68,0XF6,0X48,

83940XF6,0X69,0XEE,0X6A,0XAC,0X65,0X72,0XC1,0X62,0X41,0X5A,0X42,0X52,0X22,0X52,0X23,

83950X41,0XE3,0XC6,0X15,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

83990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

84090XFF,0XDF,0XFF,0XFF,0XFF,0XFD,0XFF,0XDB,0XFF,0XF8,0XEE,0XF1,0XE6,0X4C,0XE6,0X08,

84100XEE,0X48,0XF6,0X47,0XF6,0X27,0XFE,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

84110XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,

84120XF6,0X47,0XF6,0X67,0XFE,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X48,0XF6,0X89,0XEE,0X6A,

84130XB4,0XA5,0X7B,0X01,0X62,0X62,0X62,0X63,0X5A,0X42,0X52,0X43,0X41,0XC3,0XBD,0XB4,

84140XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84280XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0XB6,0XEE,0XF0,0XD5,0XE8,0XEE,0X68,0XF6,0X67,

84290XF6,0X27,0XF6,0X28,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

84300XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X67,0XFE,0X67,

84310XFE,0X67,0XFE,0X67,0XF6,0X48,0XF6,0X48,0XF6,0X89,0XEE,0X69,0XBC,0XE5,0X83,0X42,

84320X6A,0XA2,0X62,0X83,0X5A,0X63,0X5A,0X63,0X49,0XE3,0XB5,0X93,0XFF,0XFF,0XFF,0XFF,

84330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

84470XFF,0XFC,0XFF,0XF9,0XFF,0X73,0XDE,0X4B,0XE6,0X48,0XEE,0X47,0XEE,0X07,0XF6,0X48,

84480XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

84490XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,

84500XF6,0X48,0XF6,0X48,0XF6,0XA8,0XEE,0X68,0XBD,0X26,0X8B,0X62,0X72,0XC2,0X6A,0XA3,

84510X62,0XA3,0X62,0XA4,0X52,0X24,0XBD,0X93,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFB,

84660XFF,0XB6,0XEE,0XEF,0XD6,0X08,0XE6,0X48,0XEE,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X47,

84670XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

84680XF6,0X48,0XF6,0X68,0XF6,0X47,0XF6,0X67,0XFE,0X47,0XF6,0X67,0XF6,0X68,0XF6,0X48,

84690XF6,0XA8,0XEE,0X68,0XC5,0X47,0X8B,0X82,0X72,0XE3,0X72,0XC4,0X6A,0XC4,0X62,0XC5,

84700X5A,0X65,0XC5,0XD4,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XF9,0XFF,0X53,

84850XD6,0X2B,0XE6,0X49,0XEE,0X28,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

84860XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X68,

84870XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XF6,0X87,0XEE,0X68,

84880XCD,0X87,0X8B,0XA2,0X7B,0X03,0X72,0XE4,0X72,0XE4,0X6A,0XE5,0X62,0XA5,0XCE,0X55,

84890XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

84990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0X76,0XE6,0X90,0XDE,0X2A,

85040XE6,0X27,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

85050XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X48,0XF6,0X68,0XF6,0X47,0XF6,0X47,

85060XF6,0X47,0XF6,0X67,0XFE,0X88,0XF6,0X68,0XEE,0X67,0XEE,0X88,0XD5,0XC8,0X93,0XA3,

85070X83,0X23,0X7B,0X04,0X73,0X04,0X73,0X05,0X6A,0XE6,0XDE,0X97,0XFF,0XFE,0XFF,0XFF,

85080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85220XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XDB,0XEF,0X15,0XD6,0X0C,0XE6,0X29,0XEE,0X26,

85230XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

85240XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X67,0XFE,0X67,0XF6,0X47,

85250XFE,0X68,0XF6,0X68,0XEE,0X88,0XEE,0X68,0XDD,0XE9,0X93,0XA3,0X83,0X23,0X83,0X45,

85260X7B,0X24,0X73,0X25,0X73,0X28,0XEF,0X3A,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85410XFF,0XFE,0XFF,0XDC,0XF7,0X58,0XD5,0XEE,0XDE,0X29,0XEE,0X47,0XF6,0X47,0XF6,0X47,

85420XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X48,0XF6,0X47,0XF6,0X48,0XF6,0X47,

85430XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XFE,0X67,0XF6,0X47,0XF6,0X68,0XF6,0X68,

85440XEE,0X68,0XF6,0XAA,0XD5,0XC9,0X93,0XC3,0X93,0X84,0X8B,0X65,0X83,0X64,0X7B,0X46,

85450X7B,0X89,0XF7,0X7B,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,

85600XFF,0XBA,0XD6,0X0F,0XDD,0XE9,0XEE,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

85610XF6,0X47,0XF6,0X67,0XF6,0X68,0XF6,0X67,0XF6,0X68,0XF6,0X47,0XF6,0X47,0XF6,0X67,

85620XF6,0X67,0XF6,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X88,0XF6,0XCB,

85630XCD,0X68,0X9B,0XC3,0X9B,0XC5,0X93,0XA5,0X8B,0XA5,0X7B,0X65,0X8C,0X0B,0XFF,0XBC,

85640XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFB,0XE6,0X72,

85790XD5,0XC9,0XEE,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,

85800XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X67,

85810XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0XA9,0XFE,0XCB,0XC5,0X06,0X9B,0XE4,

85820X9B,0XE5,0X93,0XC5,0X93,0XE5,0X7B,0X85,0XA4,0XEF,0XFF,0XBC,0XFF,0XFE,0XFF,0XFF,

85830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

85910XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

85970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XF7,0X35,0XCD,0X8A,0XE6,0X29,

85980XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

85990XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XFE,0X67,0XF6,0X67,

86000XF6,0X67,0XEE,0X67,0XFE,0XCA,0XF6,0XAB,0XBC,0XC6,0XA4,0X25,0XA4,0X05,0X9C,0X05,

86010X9C,0X26,0X83,0XA6,0XC5,0XD2,0XFF,0XBC,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86090XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

86100XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86160XFF,0XFF,0XFF,0XFE,0XFF,0XBB,0XFF,0XB8,0XCD,0XAC,0XDE,0X09,0XEE,0X48,0XF6,0X47,

86170XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

86180XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X87,0XF6,0X88,

86190XFE,0XEB,0XE6,0X2A,0XB4,0XA6,0XAC,0X66,0XA4,0X25,0XA4,0X46,0X9C,0X06,0X94,0X07,

86200XDE,0X95,0XFF,0XBC,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86280XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86350XFF,0XDC,0XFF,0XDA,0XD5,0XEE,0XD5,0XC9,0XEE,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X67,

86360XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

86370XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X88,0XF6,0XA9,0XFE,0XCB,0XDD,0XC8,

86380XBC,0XC6,0XB4,0XA6,0XAC,0X66,0XA4,0X46,0X9C,0X26,0XA4,0XAA,0XEF,0X17,0XFF,0XDD,

86390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,

86540XD6,0X30,0XCD,0X89,0XEE,0X49,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

86550XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,

86560XF6,0X67,0XF6,0X67,0XF6,0X88,0XFE,0XC9,0XF6,0XCB,0XD5,0XA8,0XBC,0XE6,0XBC,0XC7,

86570XBC,0XA7,0XAC,0X87,0XA4,0X68,0XBD,0X4E,0XF7,0X78,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,

86580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86650XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86680XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86720XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBB,0XE6,0XB3,0XBD,0X49,

86730XEE,0X49,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

86740XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XFE,0X67,0XFE,0XA8,0XEE,0X27,

86750XF6,0XA8,0XFE,0XCA,0XF6,0XAB,0XCD,0X67,0XC5,0X27,0XBC,0XE7,0XBC,0XE8,0XB4,0XC8,

86760XAC,0X89,0XD6,0X32,0XFF,0X99,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

86850XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

86860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

86870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86910XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XBB,0XE6,0XB4,0XB5,0X09,0XEE,0X49,0XF6,0X47,

86920XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

86930XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X88,0XF6,0X47,0XF6,0XA9,0XFE,0XCA,

86940XEE,0X6A,0XCD,0X67,0XC5,0X26,0XC5,0X07,0XC5,0X08,0XB4,0XE9,0XB5,0X0C,0XE6,0XB5,

86950XFF,0XDB,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

86990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,

87030XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XF7,0XDF,0XF7,0XBF,0XF7,0XBE,

87040XF7,0XDF,0XF7,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

87050XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDF,

87060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87100XFF,0XDE,0XFF,0XDC,0XE6,0XD4,0XAC,0XC8,0XEE,0X4A,0XEE,0X47,0XF6,0X47,0XF6,0X47,

87110XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

87120XF6,0X67,0XFE,0X68,0XF6,0X68,0XF6,0X68,0XFE,0XCA,0XFE,0XCA,0XE6,0X08,0XCD,0X66,

87130XC5,0X26,0XC5,0X27,0XC5,0X49,0XBC,0XEA,0XC5,0X90,0XF7,0X38,0XFF,0XFC,0XFF,0XFD,

87140XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

87220XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87230XF7,0XDE,0XF7,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87250XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFC,

87290XEE,0XF5,0XAC,0XC8,0XEE,0X4A,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,

87300XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X68,0XFE,0X68,

87310XF6,0X47,0XFE,0X88,0XFE,0XCA,0XF6,0XAA,0XDD,0XC7,0XCD,0X66,0XCD,0X46,0XCD,0X48,

87320XCD,0X4A,0XB4,0XEB,0XD6,0X13,0XFF,0X7B,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

87330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87400XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,

87410XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

87420XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87430XFF,0XDE,0XFF,0XDE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

87440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87470XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFC,0XEE,0XF5,0XAC,0XC8,

87480XEE,0X4A,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

87490XF6,0X67,0XF6,0X67,0XFE,0X67,0XF6,0X67,0XFE,0X68,0XF6,0X68,0XF6,0X68,0XFE,0XA9,

87500XFE,0XCA,0XF6,0X69,0XDD,0XA7,0XCD,0X66,0XCD,0X87,0XCD,0X47,0XC5,0X4A,0XBD,0X2C,

87510XEE,0XD7,0XFF,0XBD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

87590XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,0XFF,0XFB,0XFF,0XFA,0XFF,0XDB,0XFF,0XDB,

87600XFF,0XDC,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XDE,

87610XFF,0XDE,0XFF,0XDE,0XFF,0XDD,0XFF,0XDD,0XFF,0XFE,0XFF,0XFE,0XFF,0XDD,0XFF,0XDD,

87620XFF,0XFE,0XFF,0XFE,0XFF,0XDD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

87630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

87660XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFC,0XE6,0XF5,0XAC,0XA8,0XEE,0X6A,0XF6,0X68,

87670XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

87680XF6,0X67,0XF6,0X67,0XFE,0X68,0XF6,0X68,0XF6,0X68,0XFE,0XC9,0XFE,0XAA,0XEE,0X29,

87690XDD,0XA7,0XD5,0X87,0XD5,0XA7,0XCD,0X68,0XC5,0X6A,0XD5,0XF0,0XFF,0X5A,0XFF,0XDE,

87700XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFC,0XFF,0XDA,

87780XFF,0XB9,0XF7,0XB8,0XFF,0XB7,0XFF,0XD7,0XFF,0XB6,0XEF,0X35,0XCE,0X52,0XB5,0X6E,

87790X9C,0XCC,0X94,0X8B,0X94,0X6B,0X9C,0X8C,0X9C,0X8C,0X9C,0X8D,0X9C,0X8D,0X9C,0X8D,

87800X9C,0X8D,0X9C,0X8D,0X9C,0X6E,0X94,0X6E,0X9C,0XAF,0XBD,0XB3,0XE7,0X19,0XFF,0XDD,

87810XFF,0XBC,0XFF,0XFE,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

87850XFF,0XFE,0XFF,0XFC,0XE6,0XD4,0XA4,0X87,0XEE,0X6A,0XF6,0X68,0XF6,0X67,0XF6,0X67,

87860XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X67,

87870XF6,0X67,0XF6,0X67,0XFE,0XA8,0XFE,0XC9,0XFE,0X89,0XE6,0X08,0XDD,0XC8,0XDD,0XA8,

87880XD5,0XA8,0XD5,0XA9,0XCD,0X6A,0XEE,0XD3,0XFF,0XBC,0XFF,0XBF,0XFF,0XFF,0XF7,0XFF,

87890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

87960XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XDB,0XFF,0X98,0XF7,0X55,0XEF,0X13,0XEF,0X11,

87970XEF,0X31,0XF7,0X51,0XF7,0X72,0XFF,0XB3,0XFF,0XB3,0XF7,0X32,0XCE,0X2E,0XA4,0XA8,

87980X7B,0X83,0X6A,0XE2,0X6A,0XE2,0X6A,0XE3,0X6A,0XE3,0X6A,0XE4,0X6A,0XC4,0X6A,0XC4,

87990X62,0XC4,0X62,0XA4,0X62,0XA4,0X5A,0X84,0X6A,0XE6,0X94,0X4C,0XC5,0XD3,0XFF,0XDB,

88000XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88030XFF,0XDF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,

88040XE6,0XB4,0X9C,0X47,0XEE,0X4A,0XF6,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

88050XF6,0X67,0XF6,0X66,0XF6,0X46,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X67,

88060XFE,0XA9,0XFE,0XC9,0XF6,0X69,0XE5,0XE8,0XE5,0XC8,0XE5,0XE9,0XD5,0XA8,0XD5,0XC9,

88070XC5,0X8B,0XFF,0X76,0XFF,0XDD,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88140XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XF7,0XBF,0XFF,0XDF,0XF7,0XBD,0XFF,0XDC,

88150XFF,0XDA,0XEE,0XD3,0XDE,0X0E,0XD5,0XCB,0XDE,0X0A,0XDE,0X09,0XD6,0X08,0XD6,0X09,

88160XD6,0X09,0XDE,0X4A,0XEE,0X8C,0XFF,0X0E,0XFF,0X50,0XFF,0X91,0XFF,0X70,0XD6,0X0B,

88170XB5,0X08,0X9C,0X45,0XA4,0X66,0XA4,0X67,0XA4,0X67,0XA4,0X67,0XA4,0X47,0X9C,0X06,

88180X94,0X06,0X94,0X27,0X8B,0XE6,0X83,0XA6,0X7B,0X65,0X8B,0XE8,0XCE,0X11,0XFF,0XB9,

88190XFF,0XDB,0XFF,0XFD,0XFF,0XDD,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

88210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XF7,0XFF,0XFF,0XDF,0XFF,0XBF,0XFF,0XDE,

88220XFF,0XFE,0XFF,0XFD,0XF7,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XCD,0XF2,0XAC,0XA9,

88230XEE,0X4B,0XF6,0X69,0XF6,0X68,0XF6,0X67,0XFE,0X67,0XFE,0X46,0XFE,0X66,0XFE,0X66,

88240XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0XA8,0XFE,0XC9,0XFE,0X88,

88250XF6,0X49,0XEE,0X09,0XE5,0XC9,0XED,0XE9,0XE5,0XEA,0XCD,0X89,0XEE,0XF2,0XFF,0XF9,

88260XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88330XFF,0XDF,0XF7,0XDF,0XFF,0XFF,0XF7,0XBD,0XFF,0XDD,0XFF,0XDA,0XD6,0X31,0XC5,0X6B,

88340XCD,0X68,0XE5,0XC8,0XE5,0XE7,0XE6,0X27,0XDE,0X27,0XDE,0X28,0XE6,0X49,0XDE,0X08,

88350XDD,0XE8,0XDE,0X08,0XE6,0X4A,0XEE,0XCC,0XFF,0X4E,0XFF,0X6F,0XF6,0XED,0XDE,0X2B,

88360XC5,0X48,0XBD,0X28,0XBD,0X28,0XB4,0XC7,0XB4,0XC7,0XB4,0XC7,0XB4,0XC7,0XAC,0X86,

88370XB4,0XA7,0XA4,0X66,0X9C,0X26,0XA4,0X68,0X93,0XE6,0XAC,0XEC,0XDE,0XB5,0XF7,0X9A,

88380XFF,0XFC,0XFF,0XDC,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,

88390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88400XF7,0XFF,0XF7,0XFF,0XF7,0XFF,0XFF,0XDF,0XFF,0XBF,0XFF,0XBE,0XFF,0XFE,0XFF,0XFE,

88410XF7,0XFE,0XF7,0XFE,0XFF,0XDD,0XFF,0XFC,0XC5,0X6F,0XBC,0XE9,0XF6,0X4B,0XF6,0X49,

88420XF6,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X66,0XFE,0X66,0XF6,0X67,0XF6,0X67,

88430XF6,0X67,0XF6,0X68,0XF6,0X88,0XFE,0XA9,0XFE,0XC9,0XF6,0X89,0XEE,0X29,0XF6,0X0A,

88440XF6,0X09,0XEE,0X0A,0XDD,0XEA,0XE6,0X4E,0XF7,0X75,0XFF,0XFA,0XFF,0XFE,0XFF,0XFF,

88450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XDE,

88520XFF,0XFE,0XFF,0XBD,0XFF,0XBB,0XD6,0X74,0XBD,0X4C,0XCD,0X8A,0XE5,0XE9,0XEE,0X28,

88530XEE,0X07,0XE6,0X26,0XE6,0X48,0XDE,0X07,0XE6,0X28,0XE6,0X28,0XEE,0X48,0XE6,0X08,

88540XE6,0X08,0XE6,0X49,0XE6,0X4A,0XF6,0XCC,0XFF,0X6E,0XFF,0X6F,0XEE,0XAC,0XD5,0XE9,

88550XC5,0X68,0XC5,0X47,0XC5,0X28,0XC5,0X07,0XBC,0XE6,0XC5,0X07,0XB4,0XC6,0XBC,0XE7,

88560XB4,0XE8,0X9C,0X46,0XA4,0XA8,0X9C,0X48,0X9C,0X8B,0XBD,0XB0,0XEF,0X17,0XFF,0XFC,

88570XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XF7,0XFF,

88590XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XF7,0XFE,0XF7,0XFE,

88600XF7,0XDC,0XFF,0XBA,0XAC,0XCB,0XCD,0X8A,0XF6,0X6A,0XF6,0X68,0XF6,0X68,0XFE,0X67,

88610XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X88,

88620XFE,0XA9,0XFE,0XAA,0XFE,0XA9,0XF6,0X69,0XF6,0X29,0XF6,0X29,0XF6,0X29,0XEE,0X0A,

88630XD5,0XCB,0XF7,0X33,0XFF,0XD9,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDD,0XFF,0XDC,

88710XE6,0XB6,0XB5,0X2D,0XC5,0X8B,0XE6,0X2B,0XEE,0X2A,0XEE,0X07,0XEE,0X06,0XE6,0X06,

88720XE6,0X27,0XE6,0X48,0XE6,0X27,0XEE,0X28,0XEE,0X48,0XEE,0X07,0XE6,0X28,0XE6,0X28,

88730XDD,0XE8,0XE6,0X49,0XE6,0X6A,0XFF,0X4D,0XFF,0X8F,0XF6,0XED,0XDE,0X09,0XD5,0XA8,

88740XC5,0X26,0XCD,0X47,0XCD,0X47,0XC5,0X06,0XBC,0XE6,0XC5,0X07,0XB4,0XC6,0XBC,0XE8,

88750XAC,0XA7,0XA4,0X67,0X9C,0X48,0X9C,0X49,0XB5,0X2E,0XE6,0XB5,0XFF,0X9A,0XFF,0XDD,

88760XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88770XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

88780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XEF,0XFE,0XF7,0XFE,0XFF,0XFC,0XE6,0XF5,

88790XA4,0X88,0XE6,0X0A,0XF6,0X69,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XF6,0X67,

88800XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X88,0XFE,0XA9,0XFE,0XA9,

88810XFE,0X89,0XF6,0X48,0XF6,0X28,0XF6,0X49,0XEE,0X49,0XE6,0X2B,0XDE,0X2E,0XFF,0X97,

88820XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

88830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XBD,0XFF,0XFD,0XF7,0X58,0XBD,0X8F,0XC5,0XAC,

88900XD5,0XEB,0XE6,0X29,0XE5,0XE7,0XEE,0X06,0XF6,0X26,0XEE,0X06,0XE6,0X06,0XEE,0X47,

88910XEE,0X47,0XEE,0X27,0XEE,0X06,0XEE,0X27,0XEE,0X47,0XEE,0X27,0XEE,0X28,0XEE,0X69,

88920XE6,0X49,0XE6,0X69,0XF6,0XEB,0XFF,0X6E,0XFF,0X4D,0XEE,0XAB,0XD5,0XA7,0XCD,0X67,

88930XC5,0X26,0XC5,0X06,0XCD,0X47,0XC4,0XE6,0XC5,0X07,0XBC,0XC7,0XB4,0XC7,0XB4,0XC7,

88940XAC,0X87,0XAC,0X68,0XA4,0X69,0X9C,0X4A,0XD6,0X33,0XEF,0X38,0XFF,0XDC,0XFF,0XDD,

88950XFF,0XDD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88960XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

88970XF7,0XFF,0XF7,0XFF,0XF7,0XFF,0XF7,0XFD,0XFF,0XDA,0XC5,0XCF,0XB4,0XC6,0XEE,0X49,

88980XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

88990XF6,0X67,0XF6,0X67,0XF6,0X88,0XFE,0XA8,0XFE,0XA9,0XFE,0XA9,0XFE,0X68,0XF6,0X48,

89000XF6,0X48,0XF6,0X69,0XE6,0X2A,0XEE,0X8E,0XF7,0X14,0XFF,0XFB,0XFF,0XFE,0XFF,0XFF,

89010XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

89080XFF,0XFF,0XFF,0XBD,0XFF,0XDB,0XDE,0X94,0XBD,0X4C,0XDE,0X0C,0XDE,0X29,0XE6,0X07,

89090XEE,0X06,0XF6,0X27,0XF6,0X26,0XEE,0X26,0XEE,0X47,0XE6,0X06,0XEE,0X27,0XEE,0X27,

89100XEE,0X26,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XE6,0X27,0XEE,0X69,0XE6,0X28,

89110XDE,0X07,0XF6,0XCA,0XFF,0X4C,0XFF,0X6D,0XFE,0XEB,0XDE,0X08,0XD5,0XA7,0XCD,0X46,

89120XC5,0X06,0XCD,0X27,0XC5,0X07,0XC5,0X07,0XBC,0XC7,0XB4,0XA6,0XAC,0X66,0XAC,0X86,

89130XAC,0X67,0XA4,0X68,0X94,0X08,0XBD,0X6F,0XE6,0XF6,0XFF,0XDB,0XFF,0XFD,0XFF,0XFE,

89140XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XF7,0XFF,

89160XF7,0XFF,0XFF,0XFE,0XF7,0X98,0XB5,0X0A,0XC5,0X27,0XF6,0X89,0XF6,0X67,0XF6,0X67,

89170XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X87,

89180XFE,0XA8,0XFE,0XA8,0XFE,0XA9,0XFE,0X89,0XFE,0X48,0XF6,0X49,0XF6,0X68,0XEE,0X49,

89190XE6,0X2B,0XEE,0XD1,0XFF,0XB9,0XFF,0XFD,0XFF,0XFF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,

89200XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDD,

89270XFF,0X79,0XCD,0XF0,0XCD,0XAB,0XDD,0XE9,0XE6,0X48,0XEE,0X26,0XF6,0X26,0XF6,0X05,

89280XED,0XC5,0XF6,0X26,0XF6,0X68,0XEE,0X47,0XEE,0X27,0XF6,0X67,0XF6,0X26,0XF6,0X06,

89290XEE,0X26,0XF6,0X47,0XF6,0X67,0XEE,0X47,0XEE,0X27,0XF6,0X69,0XEE,0X48,0XE6,0X48,

89300XEE,0X68,0XFF,0X0B,0XFF,0X8D,0XFF,0X2C,0XDE,0X08,0XCD,0X67,0XCD,0X47,0XCD,0X47,

89310XC5,0X07,0XBC,0XC6,0XCD,0X28,0XBC,0XC6,0XC4,0XC6,0XBC,0XA6,0XB4,0XA6,0XA4,0X45,

89320XA4,0X88,0X8B,0XE7,0XA4,0XCC,0XE6,0XD5,0XFF,0X9A,0XFF,0XDD,0XFF,0XDE,0XFF,0XDF,

89330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XF7,0XDF,0XFF,0XFF,0XFF,0XDD,

89350XE6,0X74,0XB4,0XC9,0XDD,0XA8,0XFE,0XA9,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

89360XF6,0X67,0XF6,0X86,0XF6,0X87,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XFE,0XA9,0XFE,0XA9,

89370XFE,0XA9,0XFE,0X89,0XFE,0X48,0XFE,0X69,0XF6,0X69,0XEE,0X6A,0XEE,0X8F,0XF7,0X55,

89380XFF,0XFC,0XFF,0XFE,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFD,0XF7,0X37,0XC5,0X8D,

89460XD5,0XEA,0XE6,0X29,0XEE,0X47,0XEE,0X26,0XF6,0X46,0XF6,0X26,0XF6,0X26,0XF6,0X27,

89470XEE,0X07,0XEE,0X27,0XEE,0X27,0XF6,0X47,0XF6,0X26,0XF6,0X26,0XF6,0X46,0XF6,0X26,

89480XEE,0X26,0XF6,0X47,0XF6,0X48,0XEE,0X07,0XF6,0X68,0XEE,0X47,0XE6,0X47,0XEE,0X68,

89490XF6,0XEA,0XFF,0X8D,0XFF,0X4D,0XE6,0X4A,0XCD,0X67,0XC5,0X27,0XC5,0X27,0XC5,0X27,

89500XC4,0XE7,0XBC,0XE6,0XC4,0XC6,0XBC,0XE6,0XB4,0XA5,0XAC,0XA5,0XA4,0X65,0XA4,0X87,

89510X94,0X27,0X9C,0X6A,0XD6,0X53,0XFF,0X9A,0XFF,0XFD,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,

89520XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

89530XFF,0XFF,0XFF,0XFF,0XF7,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0X5A,0XC5,0X4F,0XC5,0X09,

89540XEE,0X29,0XFE,0X68,0XFE,0X48,0XFE,0X48,0XFE,0X67,0XF6,0X67,0XFE,0X67,0XF6,0X67,

89550XF6,0X67,0XF6,0X67,0XF6,0X48,0XF6,0X68,0XFE,0X89,0XFE,0X89,0XFE,0XA9,0XFE,0X89,

89560XFE,0X49,0XFE,0X8A,0XEE,0X4A,0XE6,0X6D,0XF7,0X34,0XFF,0XDA,0XFF,0XFE,0XFF,0XFF,

89570XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XF7,0X15,0XCD,0XAC,0XDE,0X09,0XEE,0X48,

89650XEE,0X25,0XF6,0X25,0XF6,0X26,0XF6,0X26,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

89660XF6,0X27,0XF6,0X26,0XF6,0X26,0XF6,0X26,0XF6,0X26,0XF6,0X26,0XF6,0X46,0XF6,0X47,

89670XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XEE,0X67,0XEE,0X68,0XEE,0X88,0XEE,0XA9,

89680XFF,0X8D,0XFF,0X6E,0XE6,0X4A,0XC5,0X47,0XC5,0X67,0XC5,0X48,0XC5,0X47,0XBC,0XE6,

89690XBC,0XC5,0XBC,0XC5,0XB4,0XA4,0XAC,0XA4,0XAC,0XA5,0XAC,0XA6,0X9C,0X66,0X94,0X27,

89700X94,0X29,0XBD,0X70,0XF7,0X39,0XFF,0XDD,0XFF,0XDE,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

89710XF7,0X9E,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFE,

89720XFF,0XFF,0XF7,0XBD,0XFF,0XDC,0XE6,0X95,0XB4,0XAA,0XDD,0XAB,0XFE,0X6A,0XFE,0X48,

89730XFE,0X48,0XFE,0X48,0XFE,0X48,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,

89740XFE,0X69,0XFE,0X89,0XFE,0X8A,0XFE,0XA9,0XFE,0XA9,0XFE,0X69,0XFE,0X8B,0XF6,0X4B,

89750XEE,0X6D,0XF7,0X12,0XFF,0XB9,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89760XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89830XFF,0XFE,0XFF,0XDC,0XF7,0X14,0XD5,0XCB,0XE6,0X29,0XEE,0X47,0XEE,0X25,0XF6,0X45,

89840XF6,0X26,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X47,

89850XF6,0X27,0XF6,0X46,0XF6,0X26,0XF6,0X26,0XF6,0X46,0XF6,0X47,0XF6,0X47,0XF6,0X47,

89860XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X67,0XEE,0X88,0XEE,0X88,0XEE,0XAA,0XFF,0X6D,

89870XFF,0X8E,0XEE,0XAB,0XCD,0XA8,0XB5,0X06,0XBD,0X27,0XBD,0X26,0XBC,0XE6,0XBC,0XE6,

89880XBC,0XE5,0XB4,0XA5,0XB4,0XC5,0XA4,0X64,0XA4,0X45,0XA4,0X87,0X93,0XE6,0X9C,0X29,

89890XAC,0XCD,0XE6,0X96,0XFF,0X9B,0XFF,0XDD,0XFF,0XFE,0XF7,0XBE,0XFF,0XFF,0XF7,0XBE,

89900XFF,0XDF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XBB,

89910XEF,0X16,0XBD,0X2C,0XCD,0X6A,0XE6,0X09,0XFE,0XAA,0XF6,0X27,0XFE,0X48,0XFE,0X48,

89920XFE,0X48,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X89,0XFE,0X89,

89930XFE,0XA9,0XFE,0XAA,0XFE,0X89,0XFE,0X8A,0XF6,0X6C,0XEE,0X2D,0XF6,0XD2,0XFF,0X77,

89940XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

89950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

89990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDB,

90020XEE,0XF4,0XD5,0XEB,0XE6,0X48,0XEE,0X46,0XF6,0X25,0XF6,0X45,0XF6,0X47,0XF6,0X27,

90030XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

90040XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XFE,0X47,0XFE,0X67,0XF6,0X46,0XF6,0X66,

90050XF6,0X67,0XF6,0X67,0XEE,0X67,0XEE,0X68,0XEE,0X88,0XF6,0XA9,0XFF,0X0B,0XFF,0X4D,

90060XF7,0X0D,0XD6,0X09,0XBD,0X46,0XB5,0X05,0XBD,0X06,0XBC,0XE6,0XBC,0XE6,0XAC,0XA5,

90070XAC,0X85,0XA4,0X64,0XA4,0X65,0XA4,0X45,0XA4,0X46,0X94,0X06,0X8B,0XC7,0X9C,0X4B,

90080XCD,0XD3,0XEF,0X39,0XFF,0XBC,0XFF,0XFE,0XFF,0XBE,0XFF,0XFF,0XFF,0XDE,0XF7,0XDE,

90090XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XF7,0XDD,0XFF,0XDC,0XFF,0XB9,0XCD,0XCE,0XBD,0X07,

90100XE6,0X09,0XF6,0XA9,0XEE,0X27,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,

90110XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X88,0XFE,0XA9,0XFE,0XA9,0XFE,0X89,

90120XF6,0X8A,0XF6,0X8B,0XEE,0X2C,0XF6,0XB1,0XFF,0X57,0XFF,0XBB,0XFF,0XFD,0XFF,0XFE,

90130XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XEF,0X13,0XD6,0X0B,

90210XEE,0X48,0XF6,0X46,0XF6,0X45,0XF6,0X46,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,

90220XF6,0X47,0XF6,0X46,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

90230XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X66,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X67,

90240XF6,0X67,0XF6,0X67,0XF6,0X88,0XF6,0X68,0XEE,0X89,0XF6,0XCA,0XFF,0X8D,0XFF,0X4D,

90250XD6,0X49,0XB5,0X45,0XB4,0XE5,0XAC,0XA5,0XAC,0XA5,0XB4,0XC6,0XB4,0XC6,0XAC,0XA5,

90260XA4,0X65,0X9C,0X24,0XA4,0X45,0X9C,0X05,0X94,0X06,0X8B,0XA6,0X8B,0XE9,0XA4,0XAD,

90270XDE,0X96,0XFF,0X9B,0XFF,0XDD,0XF7,0X9D,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFE,

90280XFF,0XFD,0XFF,0XFC,0XFF,0XDA,0XDE,0X30,0XBD,0X07,0XE6,0X49,0XEE,0X47,0XF6,0XA8,

90290XEE,0X27,0XFE,0XA9,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X67,0XFE,0X87,

90300XFE,0X67,0XFE,0X68,0XFE,0X89,0XFE,0XCA,0XFE,0X89,0XF6,0X89,0XF6,0XAB,0XEE,0X8D,

90310XEE,0X6F,0XFF,0X35,0XFF,0XBB,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDB,0XF7,0X13,0XDE,0X2B,0XEE,0X48,0XF6,0X46,

90400XF6,0X26,0XF6,0X46,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X46,

90410XF6,0X66,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,

90420XF6,0X67,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

90430XF6,0X67,0XF6,0X67,0XF6,0X88,0XF6,0X88,0XEE,0XA9,0XFF,0X6C,0XFF,0X6D,0XE6,0XAA,

90440XC5,0X47,0XBD,0X27,0XB5,0X06,0XA4,0X64,0XB4,0XC6,0XA4,0X44,0XA4,0X45,0XA4,0X45,

90450XA4,0X45,0X93,0XE4,0X93,0XC4,0X83,0X64,0X8B,0XA7,0X8B,0XC8,0X8B,0XEA,0XAC,0XEF,

90460XE6,0XB8,0XFF,0XBD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDC,0XFF,0XFC,0XFF,0X78,

90470XE6,0X92,0XBD,0X09,0XDD,0XE9,0XEE,0X68,0XFE,0XC7,0XEE,0X45,0XFE,0XA9,0XF6,0X48,

90480XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X88,

90490XFE,0X8A,0XFE,0X8A,0XF6,0XAA,0XF6,0XAB,0XEE,0X8C,0XE6,0X8E,0XFF,0X54,0XFF,0XB9,

90500XFF,0XDD,0XFF,0XDE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90510XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90580XFF,0XFE,0XFF,0XFB,0XF7,0X34,0XE6,0X4C,0XE6,0X28,0XF6,0X46,0XF6,0X26,0XF6,0X47,

90590XF6,0X48,0XF6,0X49,0XF6,0X48,0XF6,0X47,0XF6,0X66,0XF6,0X66,0XF6,0X66,0XF6,0X67,

90600XF6,0X47,0XF6,0X48,0XFE,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

90610XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X47,0XFE,0X47,0XFE,0X67,0XF6,0X46,

90620XF6,0X67,0XF6,0X88,0XEE,0X67,0XF6,0XC9,0XFF,0X2B,0XFF,0X8E,0XFF,0X0D,0XC5,0X88,

90630XA4,0X64,0XB4,0XE6,0XA4,0X44,0XAC,0X86,0XA4,0X65,0X9C,0X24,0X9C,0X04,0X9C,0X05,

90640X8B,0XA3,0X94,0X06,0X83,0X85,0X7B,0X25,0X73,0X26,0X6A,0XE6,0X83,0X69,0XB5,0X11,

90650XF7,0X1A,0XFF,0XDD,0XFF,0XFC,0XFF,0XFB,0XFF,0XB8,0XEE,0X92,0XC5,0X0A,0XDD,0XEA,

90660XFE,0XAA,0XF6,0X87,0XF6,0X65,0XFE,0XA7,0XF6,0X48,0XF6,0X48,0XF6,0X67,0XFE,0X87,

90670XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X8A,0XFE,0X8B,

90680XF6,0X8B,0XEE,0X8C,0XEE,0XAE,0XF7,0X12,0XFF,0XD9,0XFF,0XFC,0XFF,0XDE,0XFF,0XFF,

90690XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

90700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFB,

90770XFF,0X75,0XE6,0X8D,0XE6,0X28,0XF6,0X47,0XF6,0X26,0XFE,0X27,0XF6,0X49,0XF6,0X49,

90780XF6,0X48,0XF6,0X68,0XF6,0X66,0XF6,0X66,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X68,

90790XFE,0X48,0XFE,0X47,0XF6,0X67,0XF6,0X67,0XFE,0X87,0XF6,0X67,0XF6,0X68,0XF6,0X68,

90800XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,

90810XF6,0X67,0XF6,0X68,0XEE,0X68,0XFE,0XEB,0XFF,0X8E,0XFF,0X4E,0XE6,0X4B,0XB4,0XC5,

90820XA4,0X64,0X9C,0X44,0X9C,0X24,0X9C,0X04,0X93,0XE4,0X93,0XC4,0X8B,0XA4,0X8B,0XA5,

90830X83,0X64,0X7B,0X24,0X72,0XE4,0X73,0X05,0X6A,0XA3,0X62,0X63,0X62,0XA5,0X7B,0X68,

90840XAC,0XED,0XD6,0X30,0XE6,0X6F,0XDD,0XEB,0XE5,0XEA,0XF6,0X29,0XFE,0X68,0XF6,0X66,

90850XFE,0X66,0XFE,0X66,0XFE,0X69,0XFE,0X69,0XF6,0X68,0XF6,0X87,0XF6,0X88,0XFE,0X88,

90860XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X89,0XFE,0X8C,0XFE,0X8D,0XEE,0X4D,0XEE,0X8F,

90870XFF,0X74,0XFF,0XD8,0XFF,0XDC,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

90950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XB6,0XEE,0XAF,

90960XE6,0X49,0XEE,0X67,0XF6,0X47,0XFE,0X47,0XF6,0X48,0XF6,0X49,0XF6,0X49,0XF6,0X68,

90970XF6,0X67,0XF6,0X66,0XF6,0X86,0XF6,0X67,0XF6,0X67,0XFE,0X68,0XFE,0X48,0XFE,0X48,

90980XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XFE,0X68,0XFE,0X68,

90990XFE,0X68,0XFE,0X67,0XFE,0X87,0XF6,0X46,0XFE,0X67,0XFE,0X87,0XF6,0X67,0XFE,0X88,

91000XF6,0X68,0XEE,0X48,0XF6,0XAA,0XFF,0X0C,0XFF,0X4E,0XFF,0X4E,0XCD,0XA9,0XB4,0XE6,

91010X9C,0X04,0X8B,0XC3,0X93,0XE4,0X83,0X63,0X83,0X63,0X72,0XE1,0X73,0X02,0X73,0X02,

91020X73,0X02,0X62,0X80,0X62,0X40,0X51,0XE0,0X62,0X41,0X5A,0X20,0X83,0X43,0XC5,0X6A,

91030XE6,0X2A,0XE6,0X29,0XEE,0X28,0XFE,0X89,0XF6,0X46,0XFE,0X66,0XFE,0X86,0XFE,0X67,

91040XFE,0X48,0XFE,0X69,0XF6,0X68,0XF6,0X88,0XF6,0X88,0XFE,0X88,0XFE,0X87,0XFE,0X88,

91050XFE,0X89,0XFE,0X8B,0XF6,0X6D,0XEE,0X4E,0XF6,0XB1,0XFF,0X54,0XFF,0XB8,0XFF,0XFB,

91060XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91140XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDD,0XFF,0XDA,0XF7,0X53,0XE6,0X8B,0XE6,0X47,

91150XF6,0X67,0XFE,0X46,0XF6,0X48,0XF6,0X69,0XF6,0X28,0XF6,0X49,0XFE,0X88,0XF6,0X47,

91160XF6,0X67,0XF6,0X66,0XFE,0X47,0XFE,0X48,0XFE,0X48,0XFE,0X48,0XF6,0X67,0XFE,0X67,

91170XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X67,

91180XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X68,

91190XEE,0X69,0XF6,0XAA,0XFF,0X0C,0XFF,0X4D,0XFF,0X6E,0XF7,0X0D,0XD5,0XEA,0XAC,0XE6,

91200X93,0XE3,0X83,0X62,0X7B,0X21,0X73,0X01,0X72,0XE0,0X6A,0XC0,0X62,0X80,0X6A,0XC0,

91210X7B,0X40,0X83,0X81,0X9C,0X44,0XC5,0X68,0XE6,0X6B,0XEE,0X8B,0XEE,0X69,0XF6,0X68,

91220XFE,0X88,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XF6,0X67,0XF6,0X67,0XF6,0X88,

91230XF6,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X87,0XFE,0XC8,0XFE,0XC9,0XF6,0XAA,0XEE,0X8B,

91240XEE,0XAE,0XF6,0XF2,0XFF,0X76,0XFF,0XDA,0XFF,0XFC,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,

91250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91330XFF,0XFF,0XFF,0XDE,0XFF,0XFB,0XFF,0X76,0XE6,0XCE,0XE6,0X49,0XF6,0X67,0XF6,0X46,

91340XF6,0X47,0XF6,0X48,0XFE,0X49,0XFE,0X49,0XFE,0X69,0XFE,0X68,0XFE,0X67,0XFE,0X67,

91350XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

91360XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X67,

91370XFE,0X67,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X88,0XF6,0X68,0XEE,0X89,

91380XEE,0X89,0XEE,0X89,0XF6,0XEB,0XFF,0X4D,0XFF,0X4E,0XFF,0X2E,0XEE,0XCD,0XD6,0X0A,

91390XC5,0X68,0XB5,0X07,0XB4,0XE6,0XB5,0X06,0XBD,0X06,0XC5,0X67,0XCD,0XC8,0XE6,0X8A,

91400XF7,0X2C,0XFF,0X2C,0XF6,0XC9,0XEE,0X68,0XF6,0X67,0XFE,0XA8,0XFE,0X67,0XFE,0X67,

91410XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XF6,0X87,0XF6,0X87,0XFE,0X88,0XFE,0X89,

91420XFE,0X89,0XFE,0XA9,0XFE,0XCA,0XF6,0X8A,0XEE,0X8B,0XE6,0X6D,0XF7,0X33,0XFF,0X97,

91430XFF,0XDA,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

91520XFF,0XFC,0XFF,0XB8,0XF7,0X11,0XE6,0X8B,0XF6,0X89,0XF6,0X87,0XF6,0X67,0XF6,0X48,

91530XF6,0X48,0XF6,0X28,0XF6,0X28,0XFE,0X69,0XFE,0X68,0XFE,0X67,0XFE,0X68,0XFE,0X68,

91540XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X87,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X68,

91550XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X87,0XFE,0X87,0XFE,0X87,

91560XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XF6,0X68,0XF6,0X88,0XF6,0X88,0XF6,0X88,

91570XF6,0X88,0XF6,0XA9,0XF6,0XCA,0XF6,0XCA,0XFF,0X0C,0XFF,0X2C,0XFF,0X4D,0XFF,0X2D,

91580XFF,0X2D,0XFF,0X2C,0XFF,0X0C,0XFF,0X0C,0XF6,0XEA,0XF6,0XCA,0XEE,0XA8,0XE6,0X66,

91590XEE,0X66,0XF6,0XA7,0XFE,0XA8,0XF6,0X47,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X66,

91600XFE,0X66,0XFE,0X86,0XFE,0XA7,0XFE,0X87,0XFE,0X88,0XFE,0X89,0XFE,0X89,0XF6,0X8A,

91610XF6,0X6C,0XEE,0X8E,0XF6,0XD1,0XFF,0X55,0XFF,0XB8,0XFF,0XDB,0XFF,0XFD,0XFF,0XFE,

91620XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFB,

91710XFF,0X75,0XEE,0XCF,0XEE,0X4A,0XEE,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X68,0XFE,0X68,

91720XFE,0X48,0XFE,0X68,0XFE,0X68,0XF6,0X67,0XF6,0X67,0XFE,0X87,0XFE,0X88,0XFE,0X67,

91730XFE,0X67,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X68,

91740XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,

91750XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X88,

91760XF6,0XA8,0XF6,0XA8,0XEE,0X68,0XF6,0X89,0XF6,0XA9,0XF6,0X89,0XEE,0X68,0XEE,0X68,

91770XF6,0X68,0XF6,0X88,0XF6,0X88,0XEE,0X67,0XF6,0X87,0XFE,0XE8,0XFE,0XA7,0XF6,0X66,

91780XF6,0X67,0XFE,0X88,0XF6,0X47,0XFE,0X47,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,

91790XF6,0X87,0XF6,0X87,0XFE,0X88,0XFE,0X8A,0XFE,0X8B,0XF6,0XAE,0XF6,0XD0,0XF6,0XF3,

91800XF7,0X57,0XFF,0XDA,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

91810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

91850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

91890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XB9,0XFF,0X54,

91900XEE,0X8E,0XE6,0X4A,0XEE,0X69,0XF6,0X88,0XFE,0X67,0XFE,0X87,0XFE,0X67,0XFE,0X46,

91910XFE,0X87,0XFE,0X86,0XF6,0X86,0XF6,0X87,0XF6,0X87,0XF6,0X67,0XFE,0X67,0XFE,0X67,

91920XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,

91930XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X67,

91940XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XF6,0X67,0XF6,0X47,0XF6,0X47,

91950XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X88,0XFE,0X88,0XFE,0X88,0XF6,0X67,

91960XF6,0X87,0XFE,0XA7,0XFE,0XA8,0XF6,0X67,0XF6,0X47,0XFE,0X68,0XFE,0X88,0XF6,0X27,

91970XFE,0X88,0XFE,0X68,0XFE,0X48,0XFE,0X68,0XF6,0X68,0XF6,0X88,0XFE,0XA8,0XFE,0XC9,

91980XFE,0XEB,0XF6,0X8C,0XEE,0X4D,0XEE,0XB0,0XFF,0X56,0XFF,0XDA,0XFF,0XFD,0XFF,0XFE,

91990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

92040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

92070XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0X98,0XFF,0X54,0XEE,0XAE,

92090XEE,0X8B,0XF6,0X89,0XF6,0X67,0XFE,0X86,0XFE,0X66,0XFE,0X66,0XFE,0X86,0XF6,0X86,

92100XF6,0X86,0XF6,0X87,0XF6,0X87,0XFE,0X67,0XFE,0X68,0XFE,0X88,0XFE,0X87,0XFE,0X87,

92110XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X87,0XFE,0X87,

92120XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X88,0XFE,0X68,

92130XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X88,0XFE,0X88,0XFE,0X88,

92140XFE,0X67,0XFE,0X88,0XFE,0X88,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X66,0XF6,0X46,

92150XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X47,0XF6,0X48,

92160XFE,0X69,0XFE,0XAA,0XFE,0XAB,0XF6,0X8A,0XEE,0X8A,0XEE,0X8B,0XEE,0X6C,0XF6,0XD0,

92170XFF,0X33,0XFF,0X97,0XFF,0XDA,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92220XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDE,

92260XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92270XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XFF,0XDC,0XFF,0XB9,0XF7,0X14,0XEE,0XCF,0XEE,0X8B,

92280XEE,0X88,0XFE,0XA8,0XFE,0X87,0XFE,0XA8,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X88,

92290XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,

92300XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X87,0XFE,0X87,0XFE,0X87,

92310XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

92320XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X88,0XFE,0X67,0XFE,0X68,

92330XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X88,0XFE,0X67,0XFE,0X67,

92340XFE,0X67,0XFE,0X86,0XFE,0X86,0XFE,0X87,0XFE,0XA7,0XF6,0X88,0XF6,0X69,0XEE,0X6A,

92350XEE,0X6C,0XEE,0X8D,0XF6,0XCF,0XF6,0XF1,0XFF,0X54,0XFF,0X96,0XFF,0XB8,0XFF,0XFA,

92360XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XF7,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92410XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

92440XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,

92450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

92460XFF,0XDF,0XFF,0XFE,0XFF,0XDC,0XFF,0X99,0XFF,0X74,0XEE,0XAF,0XEE,0X8B,0XF6,0XAA,

92470XF6,0X68,0XF6,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X68,

92480XFE,0X68,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X88,

92490XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,

92500XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X68,

92510XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

92520XFE,0X87,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X66,0XFE,0X86,0XF6,0X66,

92530XF6,0X66,0XF6,0XA7,0XF6,0XA9,0XF6,0XAA,0XF6,0XAC,0XF6,0XAE,0XF6,0XD0,0XF7,0X12,

92540XFF,0X55,0XFF,0X97,0XFF,0XDA,0XFF,0XFC,0XFF,0XFC,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,

92550XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

92560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,

92600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92620XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

92630XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X7D,0XF7,0X7D,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

92640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDE,

92650XFF,0XDE,0XFF,0XFC,0XFF,0XD9,0XF7,0X34,0XEE,0XD0,0XEE,0X8D,0XEE,0X6B,0XEE,0X49,

92660XF6,0X48,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X88,0XFE,0X68,0XFE,0X67,

92670XFE,0X88,0XFE,0XA8,0XFE,0X88,0XFE,0X67,0XFE,0X88,0XFE,0X88,0XFE,0X87,0XFE,0X87,

92680XFE,0X88,0XFE,0X87,0XFE,0X87,0XF6,0X87,0XF6,0X87,0XF6,0X87,0XF6,0X87,0XF6,0X87,

92690XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,

92700XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

92710XFE,0X68,0XFE,0X68,0XF6,0X46,0XFE,0X87,0XF6,0XA7,0XF6,0X87,0XF6,0XC9,0XF6,0XAA,

92720XF6,0XCC,0XF6,0XCE,0XF6,0XF1,0XFF,0X34,0XFF,0X77,0XFF,0XB9,0XFF,0XDA,0XFF,0XFB,

92730XFF,0XFD,0XF7,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,

92740XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,

92790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

92810XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,

92820XF7,0X7D,0XEF,0X7D,0XEF,0X5D,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XDF,0XFF,0XDE,

92830XFF,0XDE,0XF7,0XDE,0XF7,0XBE,0XF7,0XBF,0XF7,0XBF,0XF7,0XBF,0XF7,0X9E,0XF7,0X9C,

92840XFF,0XBB,0XFF,0X99,0XF7,0X35,0XEE,0XD2,0XEE,0XAF,0XF6,0XAC,0XEE,0X69,0XF6,0X88,

92850XFE,0X88,0XFE,0X67,0XFE,0X67,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XF6,0X68,0XF6,0X68,

92860XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X87,0XFE,0XA8,0XFE,0X87,0XFE,0X87,

92870XFE,0X88,0XFE,0X87,0XF6,0X87,0XF6,0XA7,0XF6,0X87,0XF6,0X87,0XFE,0X67,0XFE,0X67,

92880XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X87,

92890XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XF6,0X88,0XF6,0X68,0XFE,0X88,0XF6,0X68,

92900XFE,0XA9,0XEE,0X68,0XF6,0XAA,0XF6,0XCB,0XF6,0XED,0XF6,0XEF,0XF6,0XF1,0XF7,0X34,

92910XFF,0X77,0XFF,0XB9,0XFF,0XBA,0XFF,0XBB,0XFF,0XDC,0XFF,0XFD,0XF7,0XFF,0XF7,0XDF,

92920XF7,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

92930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

92940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92970XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

92990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,

93000XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XEF,0X9D,0XEF,0X7D,0XEF,0X5D,

93010XEF,0X5D,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XEF,0X9E,0XF7,0X9D,0XF7,0X9D,0XEF,0X7D,

93020XEF,0X7D,0XEF,0X7D,0XE7,0X5D,0XE7,0X5D,0XE7,0X3C,0XE7,0X1B,0XE7,0X1A,0XE7,0X19,

93030XE6,0XD7,0XDE,0X94,0XDE,0X51,0XE6,0X6E,0XF6,0XAC,0XF6,0XCA,0XFE,0XA9,0XF6,0X88,

93040XF6,0X67,0XF6,0X68,0XF6,0X88,0XF6,0X88,0XFE,0XA9,0XFE,0XA9,0XFE,0X68,0XFE,0X68,

93050XFE,0X88,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,

93060XFE,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X67,

93070XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XF6,0X87,0XF6,0X87,

93080XF6,0X88,0XF6,0X68,0XF6,0X68,0XF6,0X89,0XF6,0XA9,0XF6,0XAA,0XFE,0XEC,0XF6,0XCD,

93090XF6,0XCF,0XEE,0XB1,0XEE,0XB3,0XF7,0X16,0XF7,0X18,0XF7,0X39,0XF7,0X5A,0XF7,0X7B,

93100XEF,0X7B,0XEF,0X5B,0XEF,0X5C,0XEF,0X7D,0XEF,0X9E,0XEF,0X7E,0XEF,0X7E,0XF7,0X9E,

93110XF7,0X9E,0XF7,0X9D,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XDE,0XF7,0XDE,0XF7,0XDE,

93120XF7,0XDF,0XF7,0XDF,0XFF,0XBF,0XFF,0XBF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

93130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93160XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,

93190XF7,0XBE,0XF7,0X9E,0XF7,0XBE,0XF7,0X9E,0XF7,0X7D,0XEF,0X5D,0XEF,0X5D,0XF7,0X9E,

93200XEF,0X7E,0XEF,0X7D,0XEF,0X7D,0XEF,0X5C,0XE7,0X3C,0XE7,0X1B,0XE6,0XFB,0XDE,0XFB,

93210XD6,0XDB,0XD6,0XBA,0XD6,0XBA,0XCE,0X99,0XC6,0X58,0XC6,0X17,0XC5,0XD5,0XC5,0XB4,

93220XC5,0X91,0XC5,0X6E,0XCD,0XCC,0XDE,0X2B,0XEE,0X8B,0XF6,0XCC,0XF6,0XAB,0XF6,0X8A,

93230XF6,0X8A,0XF6,0XAA,0XF6,0X89,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X87,

93240XFE,0X88,0XFE,0XA8,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XF6,0X88,0XF6,0X69,

93250XF6,0X69,0XF6,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,

93260XFE,0X87,0XFE,0X87,0XF6,0X87,0XF6,0X87,0XF6,0XA8,0XF6,0XA8,0XF6,0X88,0XEE,0X89,

93270XF6,0X8A,0XF6,0XAB,0XF6,0XCC,0XF6,0XCD,0XDE,0X2D,0XD6,0X0E,0XCD,0XAF,0XCD,0XD2,

93280XCD,0XF4,0XCD,0XF6,0XD6,0X58,0XD6,0X58,0XD6,0X79,0XD6,0X99,0XD6,0XBA,0XD6,0XDA,

93290XDE,0XFB,0XDF,0X1C,0XDE,0XFC,0XDE,0XFC,0XE7,0X1C,0XE7,0X1C,0XEF,0X3C,0XEF,0X3C,

93300XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X9E,0XEF,0X7E,0XEF,0X7E,

93310XF7,0X7E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,

93320XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

93330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

93350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93370XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

93380XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X7E,0XF7,0X7E,0XEF,0X7E,0XEF,0X7D,0XE7,0X5C,

93390XE7,0X5C,0XE7,0X3C,0XE6,0XFB,0XDE,0XDB,0XDE,0XBA,0XD6,0X99,0XCE,0X79,0XC6,0X38,

93400XBE,0X18,0XBD,0XF8,0XB5,0X96,0XA5,0X34,0XA4,0XF3,0X9C,0XB2,0X9C,0X4F,0X8B,0XEC,

93410X83,0X88,0X8B,0XC8,0XA4,0X8A,0XCD,0XAD,0XEE,0X8F,0XEE,0XAE,0XEE,0XAD,0XEE,0XAB,

93420XF6,0X8A,0XF6,0X89,0XF6,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0X87,0XF6,0X67,0XFE,0X67,

93430XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XF6,0X89,0XF6,0X88,

93440XF6,0X68,0XF6,0X68,0XF6,0X88,0XFE,0X88,0XFE,0XA8,0XFE,0XA8,0XF6,0X88,0XF6,0X67,

93450XF6,0X88,0XF6,0XA9,0XF6,0XA9,0XF6,0XCA,0XF6,0XCC,0XF6,0XCD,0XF6,0XCD,0XEE,0XCE,

93460XC5,0XAB,0X8B,0XE6,0X4A,0X00,0X4A,0X02,0X52,0X25,0X5A,0X68,0X62,0XEA,0X73,0X6D,

93470X83,0XEF,0X84,0X0F,0X8C,0X71,0X9C,0XD3,0XA5,0X14,0XA5,0X55,0XAD,0X96,0XB5,0XD6,

93480XC6,0X17,0XC6,0X18,0XCE,0X38,0XCE,0X59,0XD6,0X7A,0XD6,0X9A,0XD6,0XBB,0XDE,0XDB,

93490XDE,0XFB,0XDE,0XFC,0XDF,0X1C,0XDF,0X1C,0XDF,0X1C,0XE7,0X3C,0XE7,0X3D,0XEF,0X5D,

93500XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

93510XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

93520XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

93540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

93560XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

93570XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XEF,0X7D,0XEF,0X7D,0XE7,0X5C,0XE7,0X3C,0XE7,0X1C,

93580XE6,0XFB,0XDE,0XBA,0XDE,0X9A,0XD6,0X99,0XCE,0X59,0XC6,0X38,0XB5,0XD7,0XB5,0XB6,

93590XAD,0X55,0X9C,0XF3,0X94,0X92,0X8C,0X31,0X83,0XAE,0X73,0X6C,0X7B,0X6C,0X62,0XA8,

93600X52,0X24,0X5A,0X64,0X73,0X26,0X94,0X28,0XBD,0X2A,0XDE,0X0C,0XE6,0X2C,0XEE,0X6C,

93610XEE,0X8B,0XEE,0X6A,0XF6,0X8A,0XFE,0XAA,0XFE,0XAA,0XFE,0XA9,0XF6,0X68,0XF6,0X69,

93620XF6,0X89,0XF6,0X69,0XF6,0X89,0XF6,0X89,0XF6,0X89,0XF6,0X89,0XF6,0XA9,0XF6,0X89,

93630XF6,0X69,0XEE,0X69,0XF6,0X69,0XF6,0X8A,0XFE,0XAB,0XFE,0XCB,0XF6,0XAC,0XEE,0X8B,

93640XE6,0X6B,0XE6,0X4C,0XD6,0X0C,0XBD,0X29,0X8B,0XE5,0X6A,0XE2,0X41,0XC0,0X39,0X80,

93650X39,0X61,0X31,0X42,0X31,0X64,0X39,0XA6,0X39,0XC6,0X42,0X07,0X42,0X07,0X4A,0X48,

93660X52,0XAA,0X5B,0X0C,0X63,0X2D,0X6B,0X6D,0X73,0XCF,0X84,0X10,0X94,0X71,0X94,0X92,

93670X9C,0XD3,0XA5,0X14,0XAD,0X55,0XAD,0X75,0XB5,0XB7,0XBD,0XF7,0XC6,0X18,0XC6,0X38,

93680XC6,0X59,0XCE,0X79,0XCE,0X7A,0XD6,0XBA,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,

93690XE7,0X1C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,

93700XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

93710XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

93720XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

93750XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XDF,0XFF,0XDF,0XFF,0XBF,0XFF,0XBF,

93760XF7,0XBF,0XEF,0X7D,0XEF,0X7D,0XE7,0X5C,0XE7,0X5C,0XE7,0X3C,0XE7,0X1C,0XE6,0XFB,

93770XE6,0XDB,0XDE,0XBB,0XD6,0X9A,0XCE,0X79,0XC6,0X58,0XBE,0X38,0XBD,0XD6,0XB5,0X95,

93780XAD,0X55,0XA4,0XF4,0X9C,0X93,0X94,0X72,0X83,0XCF,0X7B,0XAE,0X73,0X6C,0X62,0XE9,

93790X52,0X46,0X4A,0X03,0X52,0X02,0X5A,0X42,0X73,0X04,0X94,0X07,0XB4,0XEA,0XC5,0X6A,

93800XCD,0XAB,0XDE,0X0B,0XE6,0X2B,0XE6,0X2A,0XEE,0X6B,0XF6,0X8C,0XF6,0XAC,0XF6,0XAC,

93810XF6,0XAC,0XF6,0XAC,0XF6,0XAB,0XF6,0XAB,0XF6,0XAB,0XF6,0XAB,0XF6,0X8C,0XF6,0X8C,

93820XEE,0X6C,0XE6,0X2C,0XDD,0XEB,0XD5,0XAB,0XBD,0X0A,0XB4,0XEA,0XA4,0X48,0X7B,0X45,

93830X5A,0X42,0X41,0XA0,0X41,0X81,0X41,0XA2,0X41,0XC4,0X41,0XC4,0X4A,0X47,0X42,0X47,

93840X4A,0X68,0X4A,0X68,0X42,0X48,0X42,0X48,0X4A,0X69,0X4A,0X89,0X52,0XAA,0X52,0XCA,

93850X5A,0XCB,0X5B,0X0B,0X6B,0X4D,0X73,0X8E,0X73,0XAE,0X7B,0XCF,0X84,0X10,0X8C,0X50,

93860X8C,0X91,0X94,0XD2,0X9C,0XF3,0XA5,0X34,0XAD,0X55,0XB5,0X75,0XBD,0XB6,0XBD,0XD7,

93870XC5,0XF7,0XC6,0X38,0XCE,0X78,0XCE,0X99,0XD6,0X9A,0XD6,0XBA,0XD6,0XBA,0XDE,0XDB,

93880XDE,0XFB,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,

93890XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,

93900XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

93910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

93930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

93940XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XBF,0XEF,0X7D,

93950XEF,0X7D,0XEF,0X7C,0XEF,0X5C,0XEF,0X5C,0XEF,0X3D,0XEF,0X3C,0XE7,0X1C,0XE6,0XFC,

93960XDE,0XFB,0XDE,0XDB,0XD6,0XBA,0XD6,0XB9,0XCE,0X99,0XCE,0X79,0XCE,0X59,0XCE,0X39,

93970XC5,0XF8,0XBD,0XD7,0XB5,0X96,0XB5,0X96,0XAD,0X34,0X9C,0XD2,0X94,0X90,0X94,0X4F,

93980X8C,0X0D,0X83,0XCB,0X7B,0X89,0X7B,0X48,0X73,0X47,0X7B,0X67,0X8B,0XA7,0X93,0XE7,

93990X9C,0X27,0XA4,0X68,0XB4,0XC9,0XBD,0X09,0XC5,0X2A,0XC5,0X4A,0XBD,0X2A,0XBD,0X29,

94000XBD,0X29,0XBD,0X09,0XB4,0XE8,0XB4,0XC8,0XA4,0X87,0X9C,0X26,0X8B,0XA5,0X7B,0X24,

94010X6A,0XA2,0X62,0X42,0X52,0X01,0X49,0XA0,0X39,0X60,0X39,0X61,0X41,0XA3,0X41,0XE4,

94020X4A,0X05,0X41,0XE6,0X42,0X07,0X4A,0X28,0X4A,0X47,0X52,0X88,0X52,0XA9,0X52,0XA9,

94030X5B,0X0A,0X63,0X0B,0X5B,0X0B,0X5A,0XEB,0X5B,0X0B,0X63,0X0B,0X63,0X2C,0X6B,0X6C,

94040X73,0X8D,0X73,0XAE,0X7B,0XD0,0X7B,0XF0,0X84,0X30,0X8C,0X71,0X94,0X91,0X94,0XB2,

94050X9C,0XF3,0XA5,0X13,0XAD,0X34,0XAD,0X55,0XB5,0X76,0XBD,0XB6,0XBD,0XD7,0XBD,0XF7,

94060XC6,0X17,0XC6,0X37,0XCE,0X58,0XCE,0X59,0XCE,0X79,0XD6,0X9A,0XDE,0XDB,0XDE,0XDB,

94070XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,

94080XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,

94090XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XF7,0XBE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

94100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0X9D,0XF7,0X9D,

94140XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XEF,0X5D,0XEF,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

94150XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XDE,0XDB,0XD6,0XBA,0XD6,0X9A,0XD6,0X9A,0XD6,0X9A,

94160XCE,0X59,0XCE,0X79,0XCE,0X59,0XCE,0X58,0XD6,0X78,0XD6,0X78,0XCE,0X57,0XCE,0X56,

94170XCE,0X15,0XCE,0X15,0XCD,0XF4,0XC5,0XD3,0XBD,0X92,0XB5,0X51,0XB5,0X30,0XB5,0X30,

94180XB5,0X30,0XAD,0X0F,0XAC,0XCE,0XA4,0XAD,0XA4,0X8D,0X9C,0X6C,0X94,0X2B,0X94,0X0A,

94190X8B,0XEA,0X83,0XA9,0X73,0X67,0X6B,0X07,0X6A,0XE6,0X62,0XC6,0X5A,0X85,0X52,0X65,

94200X52,0X66,0X5A,0X86,0X52,0X67,0X52,0X87,0X5A,0XA9,0X5A,0XA9,0X52,0X88,0X62,0XEA,

94210X6B,0X2B,0X6B,0X2B,0X6B,0X2B,0X6B,0X4C,0X6B,0X6C,0X73,0X6C,0X73,0XAD,0X7B,0XAD,

94220X7B,0XEE,0X83,0XEE,0X83,0XEE,0X7B,0XEE,0X7B,0XCE,0X7B,0XEE,0X83,0XEF,0X84,0X0F,

94230X8C,0X51,0X8C,0X71,0X94,0X92,0X94,0XB2,0X9C,0XD3,0X9C,0XF3,0XA5,0X14,0XAD,0X55,

94240XAD,0X75,0XB5,0X76,0XB5,0X96,0XBD,0XB6,0XBD,0XD7,0XBD,0XF7,0XC6,0X18,0XC6,0X38,

94250XCE,0X59,0XCE,0X59,0XCE,0X79,0XD6,0X9A,0XD6,0XBA,0XDE,0XDB,0XDE,0XDB,0XDE,0XFB,

94260XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,

94270XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,

94280XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

94330XF7,0X9E,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XEF,0X5D,

94340XEF,0X5D,0XE7,0X3C,0XE7,0X1C,0XE7,0X1B,0XE7,0X1B,0XE7,0X1C,0XE7,0X3C,0XEF,0X3C,

94350XE7,0X3C,0XEF,0X3C,0XEF,0X5C,0XEF,0X7C,0XEF,0X5C,0XEF,0X7C,0XEF,0X5B,0XEF,0X3B,

94360XEF,0X3B,0XEF,0X3A,0XEF,0X1A,0XE6,0XFA,0XE6,0XD9,0XE6,0XF9,0XE6,0XD9,0XDE,0XB8,

94370XDE,0X98,0XDE,0X97,0XDE,0X77,0XD6,0X77,0XD6,0X57,0XCE,0X56,0XCE,0X56,0XCE,0X36,

94380XC6,0X15,0XC5,0XF5,0XC5,0XD4,0XBD,0XD4,0XBD,0XD4,0XBD,0XB4,0XBD,0XB4,0XB5,0XB4,

94390XB5,0X94,0XAD,0X74,0XAD,0X54,0XA5,0X33,0XA5,0X33,0XA5,0X33,0XA4,0XF2,0XA4,0XF2,

94400XA4,0XF2,0XA4,0XF2,0XA4,0XF2,0XA5,0X12,0XAD,0X33,0XAD,0X33,0XAD,0X53,0XAD,0X54,

94410XB5,0X74,0XB5,0X74,0XAD,0X54,0XAD,0X33,0XA4,0XF3,0X9C,0XF2,0XA5,0X14,0XA5,0X34,

94420XAD,0X55,0XAD,0X75,0XAD,0X75,0XB5,0X96,0XB5,0XB6,0XBD,0XD7,0XBD,0XF7,0XBD,0XF7,

94430XC6,0X18,0XC6,0X18,0XC6,0X38,0XCE,0X59,0XCE,0X59,0XCE,0X79,0XD6,0X9A,0XD6,0X9A,

94440XD6,0X9A,0XD6,0XBA,0XDE,0XDB,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,

94450XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,

94460XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

94470XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94510XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

94520XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XEF,0X7D,

94530XEF,0X7D,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDE,

94540XFF,0XDE,0XFF,0XDE,0XFF,0XDD,0XFF,0XDD,0XF7,0XBD,0XF7,0X9C,0XF7,0X9C,0XF7,0X9C,

94550XF7,0X9C,0XF7,0X9C,0XF7,0X7C,0XF7,0X7C,0XF7,0X7C,0XF7,0X7B,0XEF,0X7B,0XEF,0X7B,

94560XF7,0X7B,0XEF,0X7B,0XEF,0X7B,0XEF,0X5B,0XEF,0X5B,0XEF,0X5B,0XEF,0X5B,0XEF,0X5A,

94570XEF,0X5A,0XEF,0X3A,0XEF,0X3A,0XEF,0X5A,0XE7,0X1A,0XE6,0XFA,0XE7,0X1A,0XE7,0X1A,

94580XDE,0XFA,0XE7,0X1A,0XE7,0X3B,0XDE,0XFA,0XDE,0XFA,0XDE,0XF9,0XDE,0XD9,0XDE,0XD9,

94590XDE,0XD9,0XDE,0XD9,0XDE,0XD9,0XDE,0XD9,0XDE,0XB9,0XDE,0XB9,0XDE,0XD9,0XDE,0XD9,

94600XDE,0XD9,0XDE,0XD9,0XD6,0XB9,0XD6,0X99,0XC6,0X38,0XCE,0X59,0XCE,0X59,0XC6,0X38,

94610XC6,0X38,0XCE,0X59,0XCE,0X79,0XCE,0X79,0XCE,0X79,0XCE,0X79,0XD6,0X9A,0XD6,0X9A,

94620XD6,0X9A,0XD6,0XBA,0XD6,0XBA,0XD6,0XBA,0XDE,0XDB,0XDE,0XDB,0XDE,0XDB,0XDE,0XFB,

94630XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,

94640XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,

94650XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

94660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94700XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

94710XF7,0XBE,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,

94720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

94730XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,

94740XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,

94750XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XBD,0XFF,0XBC,

94760XF7,0XBC,0XF7,0XBC,0XFF,0XDD,0XFF,0XBD,0XFF,0XDD,0XF7,0XBD,0XF7,0X9C,0XF7,0XBD,

94770XFF,0XDD,0XF7,0X9C,0XF7,0XBD,0XF7,0XBC,0XF7,0XBC,0XF7,0XBC,0XF7,0XBC,0XF7,0XBC,

94780XF7,0X9C,0XF7,0X9C,0XF7,0X9C,0XF7,0X9C,0XF7,0X7C,0XF7,0X7C,0XF7,0X9C,0XF7,0X9C,

94790XF7,0X9C,0XF7,0X9D,0XEF,0X5C,0XE7,0X3C,0XDE,0XFB,0XDE,0XDB,0XDE,0XDB,0XDE,0XFB,

94800XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,

94810XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

94820XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

94830XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,

94840XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,

94850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94890XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

94900XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

94920XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

94930XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

94940XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

94950XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,

94960XFF,0XFD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,

94970XFF,0XFE,0XFF,0XFD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,

94980XFF,0XFF,0XF7,0XBE,0XF7,0X9E,0XEF,0X7D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,

94990XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,

95000XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

95010XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,

95020XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

95030XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95080XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

95110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95130XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

95140XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

95150XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

95160XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95170XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0X9E,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

95180XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

95190XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

95200XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

95210XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

95220XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

95290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95320XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,

95330XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

95340XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95360XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

95370XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

95380XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

95390XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

95400XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,

95410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95550XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

95560XFF,0XDF,0XF7,0XBE,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

95570XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

95580XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

95590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

95600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95850XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

95980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,};

9599

9600const unsigned char gimage_9[51000] = { /* 0X10,0X10,0X00,0X96,0X00,0XAA,0X01,0X1B, */

96010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96670XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

96900XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

96990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDF,0XFF,0XDF,

97090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97410XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

97420XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

97430XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97590XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,

97600XFF,0XFC,0XFF,0XFB,0XFF,0XFB,0XFF,0XFB,0XFF,0XFB,0XFF,0XFB,0XFF,0XFB,0XFF,0XFB,

97610XFF,0XFB,0XFF,0XFB,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,0XFF,0XFD,0XFF,0XFD,

97620XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,

97780XFF,0XFC,0XFF,0XFB,0XFF,0XFB,0XFF,0XFA,0XFF,0XF9,0XFF,0XF9,0XFF,0XD8,0XFF,0XF7,

97790XFF,0XF7,0XFF,0XD7,0XFF,0XF7,0XFF,0XF7,0XFF,0XF7,0XFF,0XD7,0XFF,0XF8,0XFF,0XF8,

97800XFF,0XF8,0XFF,0XF9,0XFF,0XF9,0XFF,0XFA,0XFF,0XFB,0XFF,0XFB,0XFF,0XFC,0XFF,0XFD,

97810XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

97940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,

97950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

97960XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,0XFF,0XF9,0XFF,0XF7,0XFF,0XF7,0XFF,0XF7,

97970XFF,0XF6,0XFF,0XF5,0XFF,0XF5,0XFF,0XF4,0XFF,0XF3,0XFF,0XF3,0XFF,0XF3,0XFF,0XF2,

97980XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XD2,0XFF,0XF4,0XFF,0XD4,0XFF,0XF4,0XFF,0XF5,

97990XFF,0XF5,0XFF,0XF6,0XFF,0XF7,0XFF,0XF8,0XFF,0XF9,0XFF,0XFA,0XFF,0XFB,0XFF,0XFC,

98000XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

98140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XFB,

98150XFF,0XF9,0XFF,0XF7,0XFF,0XF5,0XF7,0XF3,0XFF,0XF3,0XFF,0XF3,0XFF,0XF3,0XFF,0XF2,

98160XFF,0XF2,0XFF,0XF2,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

98170XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF2,0XFF,0XF2,0XFF,0XF3,

98180XFF,0XF4,0XFF,0XF5,0XFF,0XD6,0XFF,0XF7,0XFF,0XF8,0XFF,0XF9,0XFF,0XFB,0XFF,0XFC,

98190XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98320XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

98330XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0XF9,0XFF,0XF7,0XFF,0XF5,0XFF,0XF4,

98340XF7,0XF2,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,

98350XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XD0,0XFF,0XD0,0XFF,0XF0,

98360XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF2,0XFF,0XF3,

98370XFF,0XF3,0XFF,0XF4,0XFF,0XF4,0XFF,0XF5,0XFF,0XF7,0XFF,0XF9,0XFF,0XFA,0XFF,0XFC,

98380XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98390XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98510XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,

98520XFF,0XF9,0XFF,0XD7,0XFF,0XD5,0XFF,0XF4,0XFF,0XF3,0XFF,0XF2,0XFF,0XF1,0XFF,0XF0,

98530XFF,0XF0,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

98540XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XD0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,

98550XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,

98560XFF,0XF1,0XFF,0XF2,0XFF,0XF3,0XFF,0XF5,0XFF,0XF7,0XFF,0XF8,0XFF,0XFB,0XFF,0XFC,

98570XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98580XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98700XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XFA,0XFF,0XF8,0XFF,0XF6,0XFF,0XF4,0XF7,0XD2,

98710XF7,0XD1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

98720XFF,0XF0,0XFF,0XD0,0XFF,0XF0,0XFF,0XF0,0XFF,0XD0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

98730XFF,0XD0,0XFF,0XF0,0XFF,0XF0,0XFF,0XD0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

98740XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

98750XFF,0XF0,0XFF,0XF2,0XFF,0XD3,0XFF,0XD5,0XFF,0XF8,0XFF,0XF9,0XFF,0XFB,0XFF,0XFC,

98760XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,

98890XFF,0XFA,0XFF,0XF7,0XF7,0XF5,0XF7,0XF3,0XF7,0XF1,0XF7,0XEF,0XF7,0XEF,0XFF,0XEF,

98900XFF,0XF0,0XFF,0XD0,0XFF,0XD0,0XFF,0XD0,0XFF,0XCF,0XFF,0XCF,0XFF,0XCF,0XFF,0XCF,

98910XFF,0XCF,0XFF,0XF0,0XFF,0XCF,0XFF,0XF0,0XFF,0XF0,0XFF,0XCF,0XFF,0XCF,0XFF,0XF0,

98920XFF,0XF0,0XFF,0XCF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

98930XFF,0XF0,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XF0,

98940XFF,0XD1,0XFF,0XD2,0XFF,0XF5,0XFF,0XF7,0XFF,0XF9,0XFF,0XFB,0XFF,0XFC,0XFF,0XFE,

98950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

98990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99070XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0XF9,0XFF,0XF6,0XFF,0XF4,

99080XFF,0XF2,0XF7,0XF0,0XF7,0XEF,0XF7,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XF0,0XFF,0XD0,

99090XFF,0XD0,0XFF,0X8E,0XFF,0X8C,0XFF,0X8C,0XFF,0X8B,0XFF,0X8C,0XFF,0XAD,0XFF,0XCF,

99100XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XF7,0XCE,0XF7,0XEE,0XFF,0XEF,

99110XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XEF,

99120XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,

99130XFF,0XF2,0XFF,0XF4,0XFF,0XF5,0XFF,0XF8,0XFF,0XFA,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,

99140XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

99260XFF,0XFC,0XFF,0XFA,0XFF,0XD8,0XFF,0XD5,0XFF,0XF3,0XFF,0XF2,0XF7,0XF1,0XF7,0XEF,

99270XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XCE,0XFF,0XAE,0XFF,0X6E,0XF7,0X0D,0XEE,0XCA,

99280XE6,0X87,0XD6,0X45,0XD6,0X25,0XD6,0X46,0XDE,0X68,0XEF,0X0B,0XFF,0X8E,0XFF,0XF0,

99290XFF,0XCE,0XFF,0XCF,0XFF,0XEF,0XFF,0XEF,0XF7,0XEE,0XF7,0XEE,0XFF,0XEF,0XFF,0XEF,

99300XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

99310XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XD1,

99320XFF,0XD3,0XFF,0XD5,0XFF,0XF7,0XFF,0XF9,0XFF,0XFB,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,

99330XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XF9,0XFF,0XF6,

99450XFF,0XD4,0XFF,0XF2,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,

99460XFF,0XEE,0XFF,0XAD,0XFF,0X4C,0XF6,0XCA,0XEE,0X48,0XE6,0X47,0XE6,0X26,0XDD,0XE4,

99470XDD,0XC4,0XCD,0X83,0XBD,0X03,0XC5,0X45,0XD6,0X29,0XFF,0X8F,0XFF,0XCF,0XFF,0XCF,

99480XFF,0XCF,0XFF,0XEF,0XFF,0XEF,0XF7,0XCE,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

99490XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

99500XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF1,0XFF,0XF2,

99510XFF,0XF4,0XFF,0XF6,0XFF,0XF9,0XFF,0XFB,0XFF,0XFD,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

99520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99630XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0XF8,0XFF,0XD5,0XFF,0XD3,0XFF,0XF1,0XFF,0XF0,

99640XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XCE,0XFF,0XAD,0XFF,0X4C,

99650XEE,0XC9,0XE6,0X47,0XE5,0XE5,0XE5,0XC4,0XDD,0XA3,0XDD,0X82,0XD5,0X62,0XCD,0X22,

99660XB4,0X81,0XAC,0X61,0XAC,0X62,0XD5,0XE9,0XF7,0X4E,0XFF,0XF0,0XFF,0XCF,0XF7,0XCF,

99670XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

99680XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

99690XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF1,0XFF,0XF3,

99700XFF,0XF6,0XFF,0XF8,0XFF,0XFB,0XFF,0XFD,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

99710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XFA,

99820XFF,0XF7,0XFF,0XD5,0XFF,0XD2,0XFF,0XD0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

99830XFF,0XEF,0XFF,0XEF,0XFF,0XCE,0XFF,0XAD,0XFF,0X4B,0XEE,0XA9,0XE6,0X26,0XEE,0X26,

99840XFE,0X67,0XFE,0X46,0XF6,0X04,0XEE,0X03,0XE5,0XC2,0XDD,0X62,0XC4,0XE1,0XAC,0X00,

99850X8B,0X40,0X9C,0X01,0XDE,0X2A,0XFF,0X8F,0XFF,0XCF,0XFF,0XCE,0XFF,0XEF,0XFF,0XEF,

99860XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

99870XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

99880XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XF7,0XF1,0XF7,0XD3,0XFF,0XD6,

99890XFF,0XD9,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

99990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100000XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFA,0XFF,0XF7,0XFF,0XF4,0XFF,0XF1,

100010XFF,0XF0,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEE,0XFF,0XCE,

100020XFF,0XCE,0XFF,0X8D,0XF6,0XE9,0XE6,0X06,0XDD,0XC4,0XF6,0X46,0XFE,0XA7,0XFE,0X86,

100030XFE,0X45,0XF6,0X24,0XED,0XC2,0XE5,0XA2,0XE5,0XA3,0XCC,0XE1,0X9B,0XA0,0X82,0XE0,

100040XAC,0X83,0XE6,0X8B,0XFF,0XAF,0XFF,0XEF,0XFF,0XEE,0XFF,0XED,0XFF,0XEF,0XFF,0XEF,

100050XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

100060XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,

100070XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XF7,0XEF,0XF7,0XD1,0XF7,0XD3,0XFF,0XD6,0XFF,0XD9,

100080XFF,0XDD,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100180XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

100190XFF,0XFD,0XFF,0XFA,0XFF,0XF6,0XFF,0XF3,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

100200XFF,0XEE,0XFF,0XCE,0XFF,0XCE,0XFF,0XEF,0XFF,0XCF,0XFF,0XCE,0XFF,0XAD,0XF6,0XEA,

100210XEE,0X67,0XD5,0X83,0XE5,0XA3,0XF6,0X25,0XFE,0X86,0XFE,0XA7,0XFE,0X87,0XFE,0X46,

100220XEE,0X04,0XE5,0XC3,0XE5,0XE2,0XD5,0X61,0XCD,0X41,0X93,0X60,0X8B,0X20,0XC5,0X06,

100230XFF,0X2E,0XFF,0XEF,0XFF,0XCC,0XFF,0XEC,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

100240XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

100250XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,

100260XFF,0XED,0XF7,0XED,0XFF,0XEF,0XFF,0XF1,0XFF,0XD4,0XFF,0XB6,0XFF,0XDA,0XFF,0XFD,

100270XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

100370XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFB,0XFF,0XF7,

100380XFF,0XF4,0XFF,0XF1,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

100390XFF,0XEE,0XFF,0XEF,0XFF,0XAF,0XFF,0XCE,0XFF,0X8D,0XE6,0X27,0XDD,0XE4,0XCD,0X21,

100400XDD,0X83,0XED,0XC3,0XF6,0X24,0XFE,0X66,0XFE,0X88,0XFE,0X88,0XF6,0X67,0XEE,0X45,

100410XE6,0X02,0XE5,0XE1,0XDD,0X81,0XC4,0XC0,0X9B,0X80,0XA4,0X01,0XDD,0XE9,0XFF,0X8E,

100420XFF,0XCD,0XFF,0XCC,0XFF,0XED,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

100430XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

100440XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,

100450XFF,0XED,0XFF,0XF0,0XFF,0XD1,0XF7,0XB4,0XFF,0XD8,0XFF,0XFB,0XFF,0XDE,0XFF,0XFF,

100460XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

100560XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XFF,0XD7,0XFF,0XD4,0XFF,0XD1,0XFF,0XEF,

100570XFF,0XCF,0XFF,0XEF,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,

100580XFF,0XAE,0XFF,0XCF,0XF6,0XEB,0XD5,0XA4,0XD5,0X62,0XD5,0X21,0XE5,0X82,0XE5,0XA2,

100590XED,0XC3,0XFE,0X67,0XFE,0X88,0XFE,0XA9,0XFE,0XA8,0XF6,0X87,0XF6,0X65,0XEE,0X23,

100600XE5,0XC2,0XE5,0XC3,0XBC,0XA0,0X9B,0XA0,0XC5,0X25,0XFF,0X4D,0XFF,0XAE,0XFF,0XCD,

100610XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

100620XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

100630XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,

100640XFF,0XF0,0XFF,0XD2,0XFF,0XB5,0XFF,0XB8,0XFF,0XFC,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

100650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,

100750XFF,0XFC,0XFF,0XD8,0XFF,0XD5,0XFF,0XD1,0XFF,0XCF,0XFF,0XEF,0XFF,0XCF,0XFF,0XCF,

100760XFF,0XEE,0XFF,0XED,0XFF,0XEC,0XFF,0XED,0XFF,0XED,0XFF,0XCD,0XFF,0XCE,0XFF,0X6D,

100770XE6,0X48,0XB4,0XC1,0XCD,0X21,0XD5,0X21,0XDD,0X20,0XE5,0XA2,0XED,0XC3,0XEE,0X04,

100780XFE,0X87,0XFE,0XA9,0XFE,0XA9,0XFE,0XA8,0XF6,0X86,0XFE,0X65,0XF6,0X23,0XF6,0X03,

100790XE5,0X83,0XC4,0XA1,0XB4,0XA3,0XE6,0XAA,0XFF,0XAD,0XFF,0XEE,0XFF,0XED,0XFF,0XED,

100800XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

100810XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XEE,

100820XFF,0XEE,0XFF,0XEE,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEE,0XFF,0XD0,

100830XFF,0XB2,0XF7,0X94,0XFF,0XFA,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

100840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

100930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XF9,0XFF,0XD5,

100940XFF,0XD1,0XFF,0XCF,0XFF,0XCF,0XFF,0XCF,0XFF,0XCF,0XFF,0XEE,0XFF,0XED,0XFF,0XED,

100950XFF,0XEC,0XFF,0XEC,0XFF,0XCD,0XFF,0XCE,0XFF,0XAE,0XFF,0X4C,0XBD,0X23,0XAC,0X60,

100960XD5,0X42,0XD5,0X21,0XDD,0X40,0XDD,0X60,0XE5,0XC1,0XE5,0XC2,0XF6,0X65,0XFE,0XA8,

100970XFE,0XA8,0XFE,0XA9,0XFE,0XA7,0XFE,0XA7,0XFE,0XA6,0XFE,0X25,0XF6,0X06,0XE5,0XA5,

100980XBC,0XC2,0XD5,0XE6,0XFF,0XAC,0XFF,0XCC,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

100990XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEC,

101000XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XED,0XFF,0XED,

101010XFF,0XEC,0XFF,0XEB,0XFF,0XEB,0XFF,0XEB,0XFF,0XED,0XFF,0XCE,0XFF,0XB0,0XF7,0X91,

101020XFF,0XB5,0XFF,0XD9,0XFF,0XFC,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101120XFF,0XDF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFA,0XFF,0XD5,0XFF,0XD2,0XFF,0XCF,0XFF,0XCE,

101130XFF,0XCE,0XFF,0XCE,0XFF,0XCE,0XFF,0XCE,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,

101140XFF,0XCD,0XFF,0XCE,0XFF,0XCE,0XF7,0X0B,0XA4,0X20,0XB4,0X60,0XCD,0X02,0XD5,0X21,

101150XD5,0X00,0XDD,0X40,0XE5,0XA0,0XE5,0XC2,0XF6,0X44,0XF6,0X86,0XF6,0X88,0XFE,0XA9,

101160XFE,0XA9,0XFE,0XA8,0XFE,0X87,0XFE,0X66,0XFE,0X47,0XFE,0X68,0XCD,0X64,0XBD,0X23,

101170XFF,0X8B,0XFF,0XCC,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

101180XFF,0XED,0XFF,0XED,0XFF,0XCD,0XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,

101190XFF,0XEC,0XFF,0XEC,0XFF,0XCC,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XEC,0XFF,0XEB,

101200XFF,0XEB,0XFF,0XEB,0XFF,0XCC,0XFF,0XCD,0XFF,0XAE,0XFF,0XB0,0XEF,0X51,0XFF,0XB6,

101210XFF,0XFB,0XFF,0XDD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFD,

101310XFF,0XFB,0XFF,0XD7,0XF7,0XB2,0XFF,0XCF,0XFF,0XCE,0XFF,0XCD,0XFF,0XCE,0XFF,0XCE,

101320XFF,0XCD,0XFF,0XCC,0XFF,0XEC,0XFF,0XEC,0XFF,0XCD,0XFF,0XCD,0XFF,0XCE,0XFF,0XAE,

101330XFF,0XAE,0XEE,0XAA,0X8B,0X80,0XBC,0XC1,0XC4,0XE2,0XC4,0XC0,0XCC,0XC0,0XCC,0XC0,

101340XD5,0X20,0XDD,0XA2,0XE5,0XE3,0XF6,0X45,0XF6,0X87,0XFE,0X68,0XFE,0X69,0XFE,0X69,

101350XFE,0X68,0XFE,0X88,0XFE,0X68,0XFE,0X88,0XEE,0X48,0XBD,0X23,0XEE,0XC8,0XFF,0XCC,

101360XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCD,

101370XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCC,

101380XFF,0XCC,0XFF,0XCC,0XFF,0XCD,0XFF,0XCD,0XFF,0XCC,0XFF,0XCC,0XFF,0XCB,0XFF,0XCB,

101390XFF,0XCC,0XFF,0XCC,0XFF,0XAD,0XFF,0XCE,0XF7,0X4F,0XF7,0X52,0XFF,0XD9,0XFF,0XDC,

101400XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

101490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XD8,0XFF,0XB4,

101500XF7,0XAF,0XF7,0XAD,0XFF,0XCC,0XFF,0XCC,0XFF,0XAD,0XFF,0XAD,0XFF,0XAC,0XFF,0XCC,

101510XFF,0XCC,0XFF,0XCC,0XFF,0XCD,0XFF,0XCD,0XFF,0XAE,0XFF,0XAE,0XFF,0X8E,0XCD,0X86,

101520X9B,0XE0,0XBC,0XC2,0XC4,0XC2,0XC4,0XA1,0XBC,0X40,0XBC,0X60,0XBC,0X80,0XC5,0X01,

101530XCD,0X41,0XE6,0X04,0XF6,0X68,0XF6,0X49,0XFE,0X4A,0XFE,0X6A,0XFE,0X68,0XFE,0X88,

101540XFE,0X88,0XF6,0X68,0XFE,0XCB,0XCD,0X85,0XD5,0XE6,0XFF,0XAC,0XFF,0XAC,0XFF,0XCC,

101550XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XED,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

101560XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XAD,0XFF,0XAD,0XFF,0XCD,0XFF,0XCC,0XFF,0XCC,

101570XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,

101580XFF,0XAC,0XFF,0XAC,0XFF,0XAE,0XEF,0X2F,0XFF,0X76,0XFF,0XDB,0XFF,0XDD,0XFF,0XDF,

101590XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

101680XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XD9,0XFF,0XB5,0XF7,0XB1,0XF7,0XAE,0XFF,0XCC,

101690XFF,0XCC,0XFF,0XCC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XCC,

101700XFF,0XCD,0XFF,0XCD,0XFF,0XAE,0XFF,0XAE,0XFF,0X8E,0XBD,0X25,0X9B,0XC0,0XB4,0X62,

101710XBC,0X61,0XB4,0X20,0XB3,0XE0,0XAB,0XE0,0XA4,0X00,0XA4,0X21,0XB4,0X81,0XCD,0X44,

101720XE5,0XE8,0XF6,0X2A,0XFE,0X4A,0XFE,0X8A,0XFE,0X67,0XFE,0XA8,0XFE,0XA9,0XFE,0X8A,

101730XFE,0X8C,0XDD,0XC8,0XC5,0X25,0XFF,0X6D,0XFF,0XAD,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,

101740XFF,0XAC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,

101750XFF,0XAC,0XFF,0XAC,0XFF,0XAD,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0X8D,0XFF,0X8E,

101760XFF,0X8E,0XFF,0X8D,0XFF,0X8C,0XFF,0X8C,0XFF,0X6C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,

101770XFF,0XAD,0XEF,0X4E,0XEE,0XF2,0XFF,0XB9,0XFF,0XDD,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

101780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,

101870XFF,0XFA,0XFF,0XD6,0XF7,0X92,0XF7,0X8F,0XFF,0X8D,0XFF,0XAC,0XFF,0XAC,0XFF,0XAB,

101880XFF,0XAB,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,

101890XFF,0XAD,0XFF,0X8E,0XFF,0X4D,0XB4,0XC4,0X9B,0XA0,0XB4,0X42,0XB4,0X21,0XAB,0XC0,

101900XA3,0X80,0X93,0X40,0X8B,0X60,0X83,0X40,0X9B,0XC1,0XAC,0X43,0XC4,0XE6,0XE5,0XC9,

101910XF6,0X2A,0XF6,0X49,0XFE,0X88,0XFE,0XC9,0XF6,0X8A,0XFE,0XCD,0XF6,0X8E,0XE6,0X2D,

101920XBD,0X07,0XF7,0X0E,0XFF,0X8E,0XFF,0XAD,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,

101930XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0X8C,

101940XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8D,0XFF,0X6E,0XFF,0X6D,0XFF,0X6D,

101950XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X8C,0XF7,0X4B,0XFF,0X6E,

101960XE6,0XAF,0XF7,0X56,0XFF,0XDB,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

101990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102050XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFC,0XFF,0XF7,0XFF,0XB3,

102060XF7,0X50,0XFF,0X4E,0XFF,0X6C,0XFF,0X8B,0XFF,0X8C,0XFF,0X8B,0XFF,0X8C,0XFF,0X8C,

102070XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8B,0XFF,0XAB,0XFF,0XAC,0XFF,0X8C,0XFF,0X8D,

102080XF6,0XEC,0XAC,0X63,0X9B,0XC0,0XAC,0X23,0XAC,0X02,0X9B,0XA1,0X93,0X40,0X83,0X00,

102090X7A,0XE0,0X72,0XE0,0X72,0XC0,0X83,0X63,0XA4,0X05,0XC4,0XE7,0XE5,0XC8,0XF6,0X48,

102100XFE,0X89,0XFE,0XEB,0XE6,0X6B,0XEE,0XAF,0XF7,0X12,0XFF,0X53,0XBD,0X6B,0XDE,0X4D,

102110XFF,0X8F,0XFF,0X8D,0XFF,0XAD,0XFF,0X8B,0XFF,0X8B,0XFF,0XAC,0XFF,0X6B,0XFF,0X8C,

102120XFF,0X6C,0XFF,0X6C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,

102130XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,

102140XFF,0X6C,0XFF,0X4C,0XFF,0X4B,0XFF,0X4C,0XFF,0X2C,0XFF,0X4E,0XEE,0XCE,0XE6,0XB0,

102150XFF,0X97,0XFF,0XFC,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

102160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102240XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XDA,0XFF,0XB4,0XFF,0X90,0XF7,0X4E,0XFF,0X4D,

102250XFF,0X4B,0XFF,0X6B,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6D,

102260XFF,0X8C,0XFF,0X8B,0XFF,0X8B,0XFF,0X8B,0XFF,0X8C,0XFF,0X6D,0XF6,0XCB,0XA4,0X01,

102270XA3,0XE2,0XA3,0XE2,0X9B,0XC2,0X93,0X61,0X83,0X00,0X7A,0XC0,0X6A,0X80,0X62,0X60,

102280X5A,0X20,0X62,0X61,0X7B,0X23,0XA4,0X05,0XC5,0X06,0XE5,0XE8,0XEE,0X6A,0XEE,0X6C,

102290XEE,0XB0,0XFF,0X74,0XFF,0XB7,0XFF,0XD8,0XD6,0X30,0XC5,0XAC,0XFF,0X50,0XFF,0X6D,

102300XFF,0X6C,0XFF,0X8B,0XFF,0X8B,0XFF,0X8B,0XFF,0X6B,0XFF,0X4C,0XFF,0X6C,0XFF,0X6C,

102310XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X4B,

102320XFF,0X6B,0XFF,0X6B,0XFF,0X6B,0XFF,0X4B,0XFF,0X4C,0XFF,0X4C,0XFF,0X2C,0XFF,0X4C,

102330XFF,0X4C,0XFF,0X2B,0XFF,0X2C,0XFF,0X4D,0XF6,0XED,0XDE,0X4C,0XF7,0X74,0XFF,0XF9,

102340XFF,0XFD,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,

102430XFF,0XFC,0XFF,0XB7,0XF7,0X51,0XF7,0X4E,0XF7,0X4D,0XFF,0X2C,0XFF,0X4B,0XFF,0X4B,

102440XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X6C,0XFF,0X6B,

102450XFF,0X8B,0XFF,0X8C,0XFF,0X8C,0XFF,0X6D,0XEE,0XAB,0X9B,0XE1,0XAC,0X22,0X9B,0XC2,

102460X93,0X81,0X8B,0X21,0X82,0XE0,0X72,0XA0,0X62,0X40,0X5A,0X20,0X49,0XE0,0X49,0XE1,

102470X5A,0X62,0X7B,0X23,0X93,0XE4,0XBD,0X08,0XD5,0XCB,0XDE,0X6E,0XF7,0X55,0XFF,0XD9,

102480XFF,0XFA,0XFF,0XFB,0XEE,0XF5,0XAC,0XEB,0XFF,0X30,0XFF,0X4D,0XFF,0X6C,0XFF,0X6B,

102490XFF,0X6B,0XFF,0X6B,0XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4B,0XFF,0X6B,

102500XFF,0X6C,0XFF,0X4C,0XFF,0X4C,0XFF,0X6B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4A,

102510XFF,0X4B,0XFF,0X4B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X4B,0XFF,0X2B,

102520XFF,0X0B,0XFF,0X2C,0XF6,0XEC,0XDE,0X2B,0XDE,0X90,0XFF,0XB8,0XFF,0XFD,0XFF,0XFF,

102530XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XDA,0XF7,0X75,

102620XF7,0X2F,0XF7,0X2D,0XFF,0X2C,0XFF,0X2C,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4C,

102630XFF,0X2C,0XFF,0X4C,0XFF,0X2C,0XFF,0X4C,0XFF,0X4C,0XFF,0X6B,0XFF,0X6B,0XFF,0X6C,

102640XFF,0X6C,0XFF,0X6D,0XE6,0X4A,0X9B,0XE1,0XA4,0X22,0X9B,0XA1,0X93,0X61,0X83,0X21,

102650X7A,0XE0,0X72,0X80,0X62,0X40,0X5A,0X21,0X41,0XA0,0X41,0XC1,0X41,0XC0,0X5A,0X62,

102660X6A,0XE2,0X94,0X06,0XAC,0XEA,0XE6,0XD3,0XFF,0XFA,0XFF,0XFC,0XFF,0XDC,0XFF,0XFC,

102670XFF,0X9A,0XA4,0X8A,0XF6,0XEF,0XFF,0X2D,0XFF,0X4C,0XFF,0X6B,0XFF,0X6B,0XFF,0X6B,

102680XFF,0X4C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,

102690XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X2A,0XFF,0X2A,0XFF,0X2A,0XFF,0X2B,0XFF,0X2B,

102700XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X0B,0XFF,0X0A,0XFF,0X2B,0XFF,0X0B,0XF7,0X0B,

102710XFF,0X0C,0XE6,0X8C,0XBD,0XAB,0XF7,0X75,0XFF,0XFB,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,

102720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102800XFF,0XFF,0XF7,0XDE,0XFF,0XDD,0XFF,0XFC,0XFF,0X77,0XF7,0X11,0XF7,0X0D,0XF7,0X0C,

102810XFF,0X0B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2C,0XFF,0X2C,0XFF,0X2C,

102820XFF,0X0C,0XFF,0X2C,0XFF,0X2C,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2C,0XFF,0X2C,

102830XDE,0X08,0XA4,0X21,0X9B,0XE1,0X93,0X80,0X8B,0X61,0X83,0X01,0X72,0XC1,0X6A,0X81,

102840X5A,0X20,0X52,0X01,0X49,0XC1,0X49,0XE1,0X41,0XE1,0X4A,0X01,0X52,0X42,0X5A,0XC3,

102850X94,0X8B,0XFF,0XFA,0XFF,0XFD,0XF7,0XBC,0XFF,0XFE,0XFF,0XFD,0XFF,0X9A,0XB5,0X2E,

102860XE6,0X4D,0XF7,0X0C,0XFF,0X4C,0XFF,0X4A,0XFF,0X4B,0XFF,0X6C,0XF7,0X0C,0XFF,0X2C,

102870XFF,0X2B,0XFF,0X2B,0XFF,0X2A,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,

102880XFF,0X2A,0XFF,0X2A,0XFF,0X2A,0XFF,0X2A,0XFF,0X2A,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,

102890XFF,0X2B,0XFF,0X0A,0XFF,0X0A,0XFF,0X0B,0XFF,0X0B,0XF6,0XEA,0XFF,0X2C,0XEE,0XCC,

102900XC5,0XCA,0XCE,0X0E,0XFF,0XD9,0XFF,0X9C,0XFF,0XDE,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,

102910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

102980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XDD,

102990XFF,0XDD,0XFF,0XB9,0XF7,0X33,0XF6,0XEF,0XFF,0X0D,0XFF,0X0B,0XFF,0X0B,0XFF,0X2B,

103000XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X0C,0XFF,0X0C,0XFF,0X0C,

103010XFF,0X2C,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2C,0XFF,0X2C,0XDD,0XE8,0XA4,0X42,

103020X93,0XA0,0X8B,0X60,0X8B,0X61,0X7B,0X01,0X72,0XC1,0X6A,0X81,0X62,0X62,0X5A,0X22,

103030X4A,0X01,0X39,0XA0,0X41,0XE1,0X39,0XC1,0X42,0X02,0X4A,0X43,0XB5,0XB2,0XFF,0XFC,

103040XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDD,0XC5,0X90,0XCD,0X8B,0XFE,0XEC,

103050XFF,0X4B,0XFF,0X2A,0XFF,0X0A,0XFF,0X4C,0XF6,0XEB,0XFF,0X0C,0XFF,0X2B,0XFF,0X2A,

103060XFF,0X2A,0XFF,0X2A,0XFF,0X2B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0A,0XFF,0X0A,

103070XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0A,

103080XFF,0X0B,0XFF,0X0A,0XFE,0XEA,0XFE,0XEA,0XFF,0X0B,0XF6,0XEB,0XCD,0XE9,0XBD,0X8B,

103090XDE,0X93,0XFF,0XFC,0XFF,0XBD,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFD,0XFF,0XFC,0XFF,0X77,

103180XF6,0XF0,0XF6,0XED,0XFF,0X0C,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,

103190XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0C,0XFF,0X0C,0XFF,0X2B,0XFF,0X2B,

103200XFF,0X0B,0XFF,0X0B,0XFF,0X0C,0XFF,0X2C,0XD5,0XC8,0XA4,0X21,0X93,0XA0,0X8B,0X80,

103210X8B,0X41,0X7B,0X01,0X7A,0XE2,0X72,0XA2,0X62,0X62,0X5A,0X21,0X5A,0X22,0X41,0XC1,

103220X41,0XE2,0X39,0XC1,0X31,0X81,0X5A,0XA6,0XE7,0X19,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

103230XFF,0XDE,0XFF,0XFE,0XFF,0XDD,0XDE,0X54,0XBC,0XE9,0XFF,0X0D,0XFF,0X0A,0XFF,0X2A,

103240XF6,0XE9,0XFF,0X2C,0XFE,0XEC,0XFF,0X0C,0XFF,0X0B,0XFF,0X2A,0XFF,0X2A,0XFF,0X0A,

103250XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,

103260XFF,0X0A,0XFF,0X0A,0XFF,0X0B,0XFE,0XEB,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

103270XFE,0XE9,0XFF,0X0A,0XFE,0XEA,0XF6,0XCA,0XDE,0X29,0XBD,0X49,0XBD,0X4D,0XFF,0X9A,

103280XFF,0X9C,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103360XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XDA,0XFF,0X54,0XF6,0XCE,0XF6,0XCB,

103370XFE,0XCC,0XFE,0XEB,0XFE,0XEB,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0A,

103380XFF,0X0B,0XFF,0X0B,0XFE,0XEB,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,

103390XFF,0X0C,0XFF,0X0C,0XD5,0XC7,0XA4,0X01,0X93,0XC0,0X8B,0X80,0X83,0X41,0X7B,0X01,

103400X7A,0XE3,0X72,0XA3,0X6A,0X82,0X62,0X62,0X5A,0X43,0X52,0X22,0X4A,0X02,0X41,0XC2,

103410X31,0X61,0X7B,0XCB,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

103420XFF,0XDE,0XF7,0X18,0XA4,0X47,0XFF,0X0E,0XFE,0XEA,0XFF,0X2A,0XFE,0XEA,0XFF,0X0B,

103430XFE,0XEC,0XFE,0XCC,0XFE,0XEB,0XFF,0X0A,0XFF,0X09,0XFF,0X0A,0XFE,0XEB,0XFE,0XEB,

103440XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

103450XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XCA,0XFE,0XCA,0XFE,0XEA,0XFE,0XC9,0XFF,0X0A,

103460XFE,0XC9,0XF6,0XCA,0XE6,0X8A,0XBD,0X48,0XA4,0X89,0XDE,0X73,0XFF,0XDC,0XFF,0XDD,

103470XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103550XFF,0XFE,0XFF,0XFD,0XFF,0XB8,0XF6,0XF1,0XF6,0XCC,0XFE,0XCB,0XFE,0XAB,0XFE,0XEC,

103560XFE,0XEB,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

103570XFE,0XEB,0XFF,0X0B,0XFF,0X0B,0XFE,0XEA,0XFE,0XEA,0XFF,0X0B,0XFF,0X0B,0XFF,0X0C,

103580XD5,0XA7,0X9C,0X01,0X93,0XC0,0X8B,0X81,0X83,0X41,0X7B,0X22,0X7A,0XE3,0X72,0XC3,

103590X72,0XA3,0X6A,0X83,0X5A,0X22,0X62,0X84,0X41,0XC2,0X49,0XE3,0X39,0XA3,0XAD,0X32,

103600XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XBB,

103610XAC,0X88,0XEE,0X6C,0XFF,0X0B,0XFF,0X09,0XFE,0XEA,0XFE,0XEB,0XFE,0XEC,0XFE,0XCB,

103620XFE,0XCA,0XFE,0XE9,0XFE,0XE9,0XFE,0XE9,0XFE,0XCA,0XFE,0XCB,0XFE,0XCA,0XFE,0XCA,

103630XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,

103640XFE,0XCA,0XFE,0XAA,0XFE,0XCA,0XFE,0XC9,0XFE,0XC9,0XFE,0XE9,0XFE,0XC9,0XF6,0XC9,

103650XEE,0XAA,0XCD,0XA8,0XA4,0X87,0XAC,0XCB,0XFF,0X99,0XFF,0XDC,0XFF,0XFE,0XF7,0XBE,

103660XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,

103740XF7,0X56,0XEE,0XAF,0XF6,0XCB,0XFE,0XCA,0XFE,0XCB,0XFE,0XCB,0XFE,0XEA,0XFE,0XEA,

103750XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFF,0X0B,

103760XFF,0X0A,0XFE,0XEA,0XFE,0XEA,0XFE,0XEB,0XFE,0XEB,0XFE,0XEC,0XD5,0XA7,0X9B,0XE1,

103770X93,0XC1,0X8B,0X81,0X8B,0X62,0X83,0X22,0X7B,0X03,0X72,0XE4,0X72,0XC3,0X6A,0XA3,

103780X62,0X62,0X5A,0X63,0X52,0X23,0X4A,0X04,0X52,0X25,0XC6,0X15,0XFF,0XDE,0XFF,0XFE,

103790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDC,0XB4,0XCA,0XDE,0X0B,

103800XFE,0XEB,0XF6,0XE9,0XFE,0XE9,0XFE,0XAA,0XFE,0XCC,0XFE,0XAB,0XFE,0XCA,0XFE,0XC9,

103810XFE,0XC9,0XFE,0XC9,0XFE,0XCA,0XFE,0XAA,0XFE,0XCA,0XFE,0XAA,0XFE,0XC9,0XFE,0XC9,

103820XFE,0XCA,0XFE,0XCA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XA9,

103830XFE,0XAA,0XFE,0XA9,0XFE,0XA9,0XFE,0XC9,0XFE,0XA8,0XF6,0XC9,0XF6,0XAA,0XCD,0XA8,

103840XB4,0XE7,0X93,0XE6,0XD6,0X33,0XFF,0XBB,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

103850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

103920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBA,0XEE,0XF3,0XE6,0X8D,

103930XFE,0XCA,0XFE,0XA9,0XFE,0XCA,0XFE,0XAA,0XFE,0XCA,0XFE,0XE9,0XFE,0XE9,0XFE,0XEA,

103940XFE,0XCA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

103950XFE,0XEA,0XFE,0XEB,0XFE,0XEB,0XFE,0XCB,0XD5,0X87,0X9B,0XE1,0X93,0XC1,0X93,0X81,

103960X8B,0X62,0X83,0X43,0X83,0X24,0X7B,0X04,0X72,0XE4,0X6A,0XE4,0X62,0XA3,0X5A,0X63,

103970X5A,0X64,0X4A,0X03,0X5A,0XA7,0XDE,0XD8,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

103980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XBD,0X4D,0XCD,0X8A,0XF6,0XCB,0XF6,0XE9,

103990XFE,0XC9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAB,0XFE,0XAA,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,

104000XFE,0XC9,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,

104010XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,

104020XFE,0X89,0XFE,0XA9,0XFE,0XA8,0XF6,0XA8,0XF6,0XA9,0XD5,0XC7,0XBD,0X27,0X8B,0XC4,

104030XA4,0XAB,0XFF,0X99,0XFF,0XBC,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104110XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XF7,0X98,0XE6,0XB0,0XEE,0X8C,0XFE,0XAA,0XF6,0X68,

104120XFE,0XAA,0XFE,0XAA,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XCA,0XFE,0XCA,

104130XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XEA,0XFE,0XCA,0XFE,0XC9,0XFE,0XCA,0XFE,0XCA,

104140XFE,0XCB,0XFE,0XCB,0XD5,0X87,0X9B,0XE1,0X93,0XA1,0X93,0XA2,0X8B,0X82,0X83,0X43,

104150X83,0X24,0X7B,0X04,0X72,0XE3,0X73,0X04,0X6A,0XE4,0X62,0X83,0X5A,0X84,0X52,0X23,

104160X6B,0X08,0XEF,0X19,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104170XFF,0XFF,0XFF,0XFC,0XD5,0XD0,0XC5,0X29,0XF6,0XAC,0XFE,0XEA,0XF6,0XA8,0XFE,0XC9,

104180XFE,0X8A,0XFE,0XAA,0XFE,0XAA,0XFE,0XA9,0XFE,0XA9,0XFE,0XC9,0XFE,0XA9,0XFE,0XA9,

104190XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0X89,0XFE,0X89,0XFE,0X89,

104200XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XF6,0X89,0XF6,0X88,

104210XF6,0X88,0XF6,0XA8,0XF6,0X89,0XE6,0X29,0XBC,0XE6,0X9C,0X25,0X8B,0XC7,0XD6,0X33,

104220XFF,0XDC,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

104300XFF,0XDB,0XF7,0X56,0XE6,0X6E,0XEE,0X8B,0XF6,0X89,0XFE,0X68,0XFE,0X89,0XFE,0XA9,

104310XFE,0XA9,0XF6,0XC9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XCA,

104320XFE,0XCA,0XFE,0XCA,0XFE,0XC9,0XFE,0XC9,0XFE,0XA9,0XFE,0XCA,0XFE,0XCA,0XFE,0XCB,

104330XD5,0X88,0X9B,0XE2,0X93,0XA2,0X93,0X82,0X8B,0X83,0X83,0X43,0X83,0X44,0X7B,0X24,

104340X73,0X03,0X73,0X04,0X73,0X04,0X62,0XA3,0X62,0XA4,0X52,0X43,0X83,0XEB,0XEF,0X59,

104350XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,

104360XDE,0X73,0XB4,0XE9,0XEE,0XAC,0XF6,0XCA,0XF6,0XA8,0XFE,0XC8,0XFE,0X69,0XFE,0X8A,

104370XFE,0X89,0XFE,0X89,0XFE,0XA8,0XFE,0XA8,0XFE,0X88,0XFE,0X89,0XFE,0X89,0XFE,0X89,

104380XFE,0XA9,0XFE,0XA9,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X88,0XFE,0X88,

104390XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XF6,0X88,0XF6,0X88,0XF6,0X88,

104400XFE,0XA9,0XE6,0X08,0XC5,0X26,0XA4,0X45,0X8B,0XA5,0XA4,0XCC,0XF7,0X79,0XFF,0XFD,

104410XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XD9,0XE6,0XF2,

104490XDE,0X4C,0XEE,0X8B,0XF6,0X48,0XFE,0X88,0XFE,0X89,0XF6,0X89,0XF6,0XA9,0XF6,0XA9,

104500XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XA9,

104510XFE,0XA9,0XFE,0XA8,0XFE,0X89,0XFE,0XA9,0XFE,0XAA,0XFE,0XAB,0XD5,0XA8,0X9B,0XC2,

104520X8B,0X82,0X8B,0X82,0X8B,0X83,0X83,0X63,0X83,0X44,0X7B,0X24,0X7B,0X24,0X73,0X03,

104530X7B,0X24,0X62,0XA3,0X6A,0XC4,0X52,0X43,0X9C,0XAE,0XF7,0X9A,0XFF,0XFD,0XFF,0XFF,

104540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XEE,0XF5,0XAC,0XC9,

104550XEE,0X8C,0XEE,0X89,0XF6,0XA8,0XFE,0X87,0XFE,0X89,0XFE,0X69,0XFE,0X69,0XFE,0X69,

104560XF6,0X88,0XF6,0X88,0XF6,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,

104570XFE,0X89,0XFE,0X69,0XFE,0X69,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X89,

104580XF6,0X69,0XFE,0X89,0XF6,0X69,0XF6,0X68,0XF6,0X88,0XF6,0X68,0XF6,0X89,0XEE,0X28,

104590XC5,0X26,0XAC,0XA6,0X8B,0XC5,0X8B,0XE8,0XDE,0XB6,0XFF,0XBC,0XFF,0XFE,0XFF,0XFF,

104600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XB7,0XDE,0X8F,0XDE,0X2B,0XEE,0X6A,

104680XF6,0X28,0XFE,0X89,0XFE,0X68,0XF6,0X88,0XF6,0X88,0XF6,0X89,0XFE,0X69,0XFE,0X69,

104690XFE,0X69,0XFE,0X88,0XFE,0X89,0XFE,0XA9,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X88,

104700XFE,0X88,0XFE,0X89,0XFE,0XAA,0XFE,0X8B,0XD5,0X88,0X93,0XA2,0X8B,0X61,0X8B,0X82,

104710X8B,0X83,0X83,0X64,0X83,0X64,0X7B,0X44,0X83,0X44,0X7B,0X04,0X7B,0X04,0X6A,0XA3,

104720X6A,0XE5,0X5A,0X63,0XAD,0X30,0XFF,0XBB,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0X57,0XAC,0XCA,0XE6,0X6C,0XEE,0X69,

104740XF6,0XA8,0XF6,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X69,0XFE,0X69,0XF6,0X68,0XF6,0X88,

104750XF6,0X87,0XF6,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XF6,0X68,0XF6,0X68,

104760XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XFE,0X68,0XF6,0X48,0XF6,0X69,

104770XF6,0X69,0XF6,0X68,0XF6,0X87,0XF6,0X67,0XFE,0X89,0XEE,0X49,0XCD,0X47,0XAC,0X85,

104780X83,0X84,0X83,0XA7,0XB5,0X50,0XFF,0X9B,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104860XFF,0XFF,0XFF,0XFC,0XF7,0X75,0XD6,0X2C,0XE6,0X4B,0XEE,0X6A,0XEE,0X28,0XFE,0X69,

104870XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X69,0XF6,0X69,0XFE,0X69,0XFE,0X68,0XFE,0X68,

104880XF6,0X88,0XF6,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X89,

104890XFE,0X8A,0XFE,0X8B,0XCD,0X68,0X93,0X81,0X83,0X41,0X83,0X62,0X83,0X84,0X83,0X64,

104900X83,0X64,0X83,0X64,0X7B,0X44,0X7B,0X44,0X72,0XE3,0X73,0X04,0X72,0XE5,0X62,0X84,

104910XB5,0X71,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

104920XFF,0XFF,0XFF,0XFD,0XFF,0X98,0XB4,0XEA,0XDE,0X2B,0XEE,0X69,0XF6,0XA8,0XF6,0X67,

104930XFE,0X68,0XFE,0X68,0XFE,0X69,0XF6,0X69,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

104940XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X48,0XF6,0X68,0XF6,0X48,0XF6,0X68,

104950XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X48,

104960XF6,0X67,0XEE,0X47,0XF6,0X48,0XF6,0X49,0XD5,0X87,0XAC,0X65,0X93,0XC5,0X7B,0X45,

104970X94,0X4B,0XEF,0X18,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

104990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDA,

105050XEF,0X12,0XD6,0X0B,0XE6,0X6A,0XEE,0X48,0XEE,0X28,0XF6,0X48,0XF6,0X68,0XF6,0X48,

105060XF6,0X68,0XF6,0X48,0XF6,0X49,0XF6,0X49,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X88,

105070XF6,0X69,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XFE,0X88,0XF6,0X88,0XF6,0X69,0XF6,0X8B,

105080XCD,0X67,0X93,0X81,0X7B,0X01,0X83,0X43,0X83,0X64,0X83,0X65,0X83,0X65,0X83,0X65,

105090X83,0X44,0X7B,0X24,0X73,0X03,0X7B,0X24,0X6A,0XC4,0X6A,0XC5,0XBD,0XB2,0XFF,0XBC,

105100XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,

105110XFF,0X9A,0XB4,0XEB,0XD6,0X0B,0XEE,0X6A,0XF6,0X68,0XF6,0X47,0XFE,0X68,0XF6,0X48,

105120XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

105130XF6,0X47,0XF6,0X68,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X47,0XF6,0X67,

105140XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XEE,0X27,

105150XF6,0X68,0XEE,0X49,0XD5,0X87,0XAC,0X65,0X93,0XA4,0X83,0X65,0X83,0X88,0XC5,0XD3,

105160XFF,0X9B,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105230XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XDA,0XE6,0XB0,0XD5,0XEA,

105240XE6,0X49,0XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

105250XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

105260XF6,0X68,0XF6,0X68,0XFE,0X68,0XF6,0X68,0XF6,0X69,0XF6,0X8A,0XD5,0X88,0X93,0X61,

105270X83,0X22,0X83,0X43,0X83,0X45,0X83,0X65,0X83,0X65,0X83,0X64,0X83,0X64,0X7B,0X43,

105280X7B,0X23,0X7B,0X24,0X6A,0XC4,0X6A,0XE6,0XC5,0XD3,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,

105290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0X9A,0XB5,0X2D,

105300XCD,0XCA,0XEE,0X8A,0XF6,0X48,0XF6,0X47,0XFE,0X68,0XF6,0X47,0XF6,0X47,0XF6,0X48,

105310XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

105320XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,

105330XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X27,0XF6,0X48,0XEE,0X49,

105340XDD,0XA8,0XAC,0X65,0X8B,0X84,0X83,0X45,0X73,0X06,0XA4,0XAE,0XF7,0X7A,0XFF,0XDD,

105350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,

105420XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XB9,0XD6,0X2E,0XD5,0XC9,0XE6,0X29,0XE6,0X08,

105430XEE,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X27,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

105440XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

105450XF6,0X68,0XF6,0X48,0XF6,0X49,0XF6,0X8A,0XDD,0XA9,0X8B,0X61,0X83,0X42,0X83,0X43,

105460X83,0X45,0X83,0X65,0X83,0X65,0X83,0X64,0X83,0X64,0X7B,0X43,0X7B,0X23,0X73,0X24,

105470X6A,0XC4,0X6B,0X06,0XC5,0XD3,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBA,0XBD,0X6E,0XC5,0X69,0XEE,0X8A,

105490XEE,0X48,0XF6,0X47,0XFE,0X68,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

105500XF6,0X48,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

105510XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

105520XEE,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X28,0XE6,0X09,0XA4,0X24,

105530X93,0XC4,0X7B,0X24,0X73,0X06,0X83,0XAA,0XEF,0X18,0XFF,0XBC,0XFF,0XFF,0XFF,0XFF,

105540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,

105610XFF,0XFD,0XFF,0X99,0XD5,0XCD,0XD5,0XE9,0XE6,0X29,0XE6,0X07,0XEE,0X28,0XF6,0X28,

105620XEE,0X28,0XEE,0X28,0XEE,0X47,0XEE,0X48,0XEE,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

105630XF6,0X68,0XF6,0X68,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X48,0XF6,0X48,

105640XF6,0X49,0XF6,0X8A,0XDD,0XC9,0X8B,0X40,0X83,0X42,0X83,0X43,0X83,0X44,0X83,0X65,

105650X83,0X65,0X83,0X64,0X83,0X44,0X7B,0X43,0X7B,0X23,0X73,0X24,0X6A,0XE4,0X6B,0X06,

105660XC5,0XF3,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105670XFF,0XFF,0XFF,0XFE,0XFF,0XBB,0XC5,0XAF,0XBD,0X49,0XEE,0X6A,0XEE,0X48,0XF6,0X47,

105680XF6,0X48,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XEE,0X47,

105690XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

105700XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X27,

105710XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X29,0XE6,0X09,0XAC,0X44,0X8B,0X83,0X7B,0X44,

105720X73,0X26,0X73,0X48,0XCE,0X14,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105790XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XF7,0X57,

105800XCD,0XAC,0XDE,0X09,0XE6,0X29,0XE6,0X07,0XEE,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X28,

105810XEE,0X47,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X48,

105820XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X6A,

105830XDD,0XC9,0X8B,0X40,0X83,0X42,0X83,0X43,0X83,0X45,0X83,0X65,0X83,0X65,0X7B,0X44,

105840X83,0X44,0X7B,0X43,0X7B,0X24,0X7B,0X24,0X6A,0XE4,0X6B,0X26,0XCD,0XF4,0XFF,0XDC,

105850XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

105860XFF,0XBB,0XCD,0XAF,0XBD,0X29,0XE6,0X4A,0XEE,0X28,0XF6,0X47,0XF6,0X27,0XF6,0X27,

105870XF6,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

105880XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

105890XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

105900XEE,0X28,0XEE,0X28,0XE6,0X09,0XAC,0X44,0X83,0X42,0X7B,0X03,0X73,0X06,0X6B,0X07,

105910XA4,0XCF,0XFF,0XDC,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

105980XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XEE,0XF6,0XCD,0X8B,0XDE,0X09,

105990XE6,0X08,0XE5,0XE7,0XEE,0X07,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

106000XEE,0X28,0XEE,0X28,0XEE,0X28,0XF6,0X48,0XF6,0X48,0XEE,0X48,0XF6,0X48,0XF6,0X48,

106010XF6,0X48,0XF6,0X48,0XF6,0X48,0XEE,0X48,0XEE,0X48,0XF6,0X6A,0XDD,0XC9,0X8B,0X40,

106020X83,0X42,0X83,0X64,0X83,0X65,0X83,0X65,0X83,0X65,0X83,0X45,0X83,0X44,0X7B,0X43,

106030X7B,0X44,0X7B,0X24,0X73,0X05,0X73,0X26,0XCE,0X14,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,

106040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBB,0XCD,0XF0,

106050XBD,0X29,0XE6,0X2A,0XEE,0X48,0XF6,0X27,0XEE,0X07,0XF6,0X27,0XF6,0X27,0XEE,0X27,

106060XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X27,

106070XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

106080XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XE6,0X28,

106090XEE,0X2A,0XAC,0X65,0X83,0X62,0X72,0XC2,0X73,0X05,0X6A,0XE6,0X83,0XCB,0XFF,0X9B,

106100XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

106170XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XDE,0X94,0XC5,0X6A,0XDD,0XE9,0XE6,0X07,0XE6,0X07,

106180XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X27,0XE6,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

106190XEE,0X27,0XEE,0X28,0XEE,0X48,0XEE,0X28,0XEE,0X48,0XEE,0X48,0XEE,0X28,0XEE,0X28,

106200XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X4A,0XDD,0XE9,0X93,0X81,0X83,0X22,0X8B,0X64,

106210X83,0X65,0X83,0X65,0X83,0X65,0X83,0X65,0X83,0X44,0X7B,0X43,0X7B,0X44,0X7B,0X24,

106220X73,0X05,0X73,0X27,0XCE,0X14,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBB,0XD6,0X32,0XB5,0X08,0XE6,0X2A,

106240XEE,0X28,0XEE,0X07,0XEE,0X07,0XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

106250XF6,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

106260XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

106270XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X29,0XE6,0X2A,0XB4,0XC6,

106280X83,0X22,0X72,0XE2,0X72,0XE4,0X6A,0XE5,0X6B,0X27,0XE6,0XF8,0XFF,0XFE,0XFF,0XFF,

106290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,

106360XFF,0XDC,0XD6,0X52,0XC5,0X4A,0XDD,0XE8,0XE5,0XE7,0XE6,0X07,0XE5,0XE7,0XE5,0XE7,

106370XEE,0X27,0XE6,0X07,0XE6,0X07,0XE6,0X27,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X28,

106380XEE,0X48,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

106390XEE,0X28,0XEE,0X4A,0XE6,0X09,0X93,0XA1,0X83,0X21,0X8B,0X84,0X83,0X65,0X83,0X65,

106400X83,0X65,0X83,0X65,0X83,0X64,0X7B,0X23,0X7B,0X24,0X73,0X24,0X73,0X05,0X6B,0X06,

106410XCE,0X14,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106420XFF,0XFF,0XFF,0XFE,0XFF,0XBB,0XDE,0X53,0XAC,0XC8,0XE6,0X2A,0XEE,0X28,0XEE,0X07,

106430XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

106440XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

106450XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

106460XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X09,0XEE,0X2A,0XB4,0XA5,0X83,0X42,0X6A,0XC1,

106470X72,0XE4,0X6A,0XE5,0X5A,0XA5,0XCE,0X55,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106540XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XCD,0XF1,

106550XC5,0X6A,0XDD,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XEE,0X07,0XEE,0X07,0XE6,0X07,

106560XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X28,

106570XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X28,0XEE,0X28,0XEE,0X49,

106580XE6,0X09,0X93,0XA2,0X83,0X41,0X8B,0X84,0X83,0X64,0X83,0X65,0X83,0X65,0X83,0X65,

106590X83,0X44,0X7B,0X44,0X7B,0X23,0X73,0X24,0X73,0X05,0X6B,0X06,0XCD,0XF4,0XFF,0XDD,

106600XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

106610XFF,0XBC,0XDE,0X73,0XAC,0XA8,0XE6,0X2A,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,

106620XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

106630XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

106640XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

106650XEE,0X08,0XE6,0X29,0XEE,0X2A,0XB4,0XC6,0X83,0X22,0X6A,0X81,0X72,0XE4,0X6A,0XE5,

106660X5A,0XA5,0XA4,0XEF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106730XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDE,0XFF,0XDB,0XBD,0X8F,0XCD,0X8A,0XDD,0XE8,

106740XE6,0X07,0XE6,0X07,0XE5,0XE7,0XEE,0X08,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

106750XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X27,

106760XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X49,0XEE,0X2A,0X9B,0XE2,

106770X8B,0X41,0X8B,0X84,0X8B,0X65,0X8B,0X85,0X83,0X85,0X83,0X65,0X83,0X64,0X7B,0X44,

106780X7B,0X24,0X73,0X24,0X73,0X05,0X6B,0X06,0XC5,0XF3,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,

106790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBC,0XDE,0X73,

106800XAC,0XA8,0XE6,0X2A,0XE6,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,

106810XEE,0X07,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

106820XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,

106830XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XE6,0X08,

106840XE6,0X2A,0XBC,0XE7,0X7B,0X21,0X62,0X81,0X6A,0XC3,0X62,0XA4,0X5A,0X84,0X8C,0X2C,

106850XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

106920XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XB5,0X2D,0XCD,0XCB,0XDE,0X08,0XE6,0X07,0XE5,0XE7,

106930XE5,0XE7,0XEE,0X08,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,

106940XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X28,0XEE,0X28,

106950XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X29,0XEE,0X4A,0XA4,0X23,0X83,0X41,0X8B,0XA4,

106960X8B,0X85,0X8B,0X85,0X83,0X85,0X83,0X65,0X83,0X64,0X83,0X64,0X7B,0X44,0X73,0X24,

106970X73,0X05,0X6B,0X06,0XC5,0XD3,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

106980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XDE,0X73,0XAC,0XA8,0XDE,0X2A,

106990XE6,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X08,

107000XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

107010XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107020XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XE6,0X08,0XE6,0X2A,0XBD,0X07,

107030X7A,0XE1,0X62,0X61,0X6A,0XA3,0X5A,0X83,0X52,0X64,0X6B,0X48,0XFF,0XBD,0XFF,0XDF,

107040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

107110XFF,0XDB,0XAC,0XEC,0XCD,0XAA,0XDD,0XE8,0XDD,0XE7,0XE5,0XE6,0XE5,0XE7,0XEE,0X08,

107120XE5,0XE8,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107130XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X07,

107140XEE,0X28,0XEE,0X49,0XEE,0X49,0XAC,0X63,0X83,0X20,0X8B,0XA3,0X8B,0XA5,0X8B,0X85,

107150X83,0X85,0X83,0X65,0X83,0X64,0X83,0X64,0X7B,0X44,0X73,0X24,0X73,0X05,0X6B,0X06,

107160XC5,0XD3,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107170XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XDE,0X74,0XAC,0XA8,0XDE,0X0A,0XE6,0X08,0XEE,0X28,

107180XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107190XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107200XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107210XEE,0X07,0XEE,0X07,0XEE,0X08,0XE6,0X08,0XE6,0X2A,0XC5,0X28,0X72,0XC0,0X62,0X40,

107220X62,0X82,0X5A,0X83,0X52,0X63,0X5A,0XC6,0XEF,0X3B,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107290XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XDB,0XAC,0XCB,

107300XCD,0XAA,0XDD,0XE8,0XDD,0XE7,0XE5,0XE7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE8,0XE6,0X08,

107310XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107320XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X48,

107330XEE,0X49,0XB4,0XA4,0X83,0X20,0X8B,0XA3,0X93,0XA5,0X8B,0XA5,0X8B,0X85,0X83,0X85,

107340X83,0X65,0X83,0X64,0X7B,0X44,0X7B,0X24,0X73,0X25,0X6B,0X06,0XBD,0XB3,0XFF,0XBC,

107350XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

107360XFF,0XDC,0XDE,0X94,0XAC,0XC8,0XDE,0X0A,0XE6,0X08,0XEE,0X28,0XEE,0X07,0XEE,0X07,

107370XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107380XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107390XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107400XE6,0X08,0XE6,0X09,0XE6,0X0B,0XC5,0X29,0X6A,0X80,0X5A,0X20,0X62,0X62,0X5A,0X83,

107410X52,0X43,0X52,0X85,0XD6,0X78,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

107480XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XDA,0XA4,0XCB,0XCD,0XAA,0XDD,0XE8,

107490XE5,0XE7,0XE6,0X07,0XE5,0XC7,0XED,0XE7,0XE5,0XE8,0XE6,0X08,0XE5,0XE7,0XE6,0X07,

107500XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X07,0XEE,0X27,0XEE,0X27,

107510XEE,0X28,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X49,0XC5,0X26,

107520X83,0X40,0X93,0XC3,0X93,0XC5,0X8B,0XA5,0X8B,0XA5,0X8B,0X85,0X83,0X65,0X83,0X64,

107530X83,0X64,0X7B,0X44,0X73,0X25,0X6B,0X06,0XBD,0X92,0XFF,0XBC,0XFF,0XFE,0XFF,0XFF,

107540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XE6,0XB4,

107550XAC,0XC8,0XDD,0XE9,0XE6,0X08,0XEE,0X27,0XE5,0XE7,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107560XEE,0X07,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107570XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

107580XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X08,0XE6,0X29,

107590XE6,0X0B,0XC5,0X09,0X6A,0X60,0X5A,0X20,0X5A,0X62,0X5A,0X63,0X52,0X43,0X4A,0X45,

107600XBD,0X94,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

107670XFF,0XFE,0XFF,0XFD,0XFF,0XDA,0XA4,0XCB,0XCD,0XCA,0XDE,0X08,0XDD,0XE7,0XE5,0XE7,

107680XE5,0XC7,0XED,0XE8,0XE5,0XC8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XEE,0X07,

107690XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X08,

107700XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X69,0XCD,0X67,0X8B,0X61,0X93,0XC4,

107710X93,0XC5,0X8B,0XA5,0X8B,0XA5,0X8B,0X85,0X83,0X65,0X83,0X64,0X83,0X65,0X7B,0X44,

107720X73,0X46,0X6B,0X06,0XB5,0X72,0XFF,0X9C,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XE6,0XB4,0XAC,0XC8,0XDD,0XE9,

107740XE6,0X08,0XEE,0X27,0XE5,0XE7,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X08,

107750XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107760XEE,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,

107770XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X08,0XE6,0X29,0XE6,0X0B,0XBC,0XE8,

107780X6A,0X60,0X5A,0X00,0X5A,0X41,0X5A,0X42,0X52,0X63,0X42,0X04,0XA4,0XF2,0XFF,0XDF,

107790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107850XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDD,

107860XFF,0XBA,0XA4,0XCB,0XD5,0XEA,0XDE,0X08,0XDD,0XE6,0XE5,0XE7,0XE5,0XE8,0XED,0XE8,

107870XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XED,0XE7,0XEE,0X07,0XEE,0X07,

107880XEE,0X08,0XE6,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X08,0XEE,0X08,

107890XEE,0X07,0XE6,0X28,0XEE,0X69,0XD5,0XA8,0X8B,0X81,0X93,0XE4,0X93,0XC5,0X8B,0XA5,

107900X8B,0XA5,0X8B,0XA5,0X83,0X84,0X83,0X64,0X83,0X65,0X7B,0X44,0X7B,0X45,0X6B,0X06,

107910XB5,0X71,0XF7,0X9B,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107920XFF,0XFF,0XFF,0XFE,0XFF,0XDC,0XE6,0XB4,0XAC,0XA7,0XD5,0XE9,0XE6,0X08,0XEE,0X28,

107930XE6,0X06,0XEE,0X07,0XEE,0X06,0XE6,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X07,

107940XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,

107950XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

107960XEE,0X07,0XEE,0X07,0XE6,0X08,0XE6,0X29,0XE6,0X2B,0XBC,0XE8,0X62,0X60,0X52,0X00,

107970X5A,0X22,0X52,0X22,0X52,0X64,0X39,0XC3,0X9C,0XB1,0XFF,0XDE,0XFF,0XFF,0XFF,0XFE,

107980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

107990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XDA,0X9C,0X89,

108050XD6,0X0B,0XD5,0XA6,0XDD,0XC6,0XE5,0XE6,0XE5,0XE8,0XE5,0XA8,0XE5,0XE8,0XE6,0X08,

108060XE5,0XE8,0XE5,0XE8,0XE5,0XE8,0XED,0XE7,0XEE,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X08,

108070XEE,0X07,0XE6,0X07,0XEE,0X08,0XEE,0X08,0XE5,0XE8,0XEE,0X08,0XEE,0X28,0XE6,0X07,

108080XEE,0X28,0XE6,0X49,0X93,0XA1,0X9B,0XE4,0X93,0XC5,0X93,0XC6,0X93,0XC5,0X8B,0XA5,

108090X8B,0XA4,0X83,0X84,0X83,0X65,0X7B,0X45,0X7B,0X45,0X73,0X45,0XA4,0XCE,0XF7,0X7A,

108100XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,

108110XFF,0XDC,0XE6,0X94,0XAC,0XA8,0XDE,0X0A,0XE6,0X08,0XEE,0X28,0XEE,0X06,0XEE,0X26,

108120XEE,0X26,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,

108130XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

108140XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,

108150XE6,0X07,0XEE,0X29,0XE6,0X2B,0XB4,0XE8,0X5A,0X20,0X52,0X00,0X52,0X22,0X52,0X03,

108160X5A,0X64,0X41,0XE3,0X8C,0X2E,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

108170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDA,0XA4,0X89,0XD5,0XEA,0XD5,0XC7,

108240XE5,0XE6,0XE5,0XE6,0XE5,0XC8,0XE5,0XC8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE8,0XE5,0XE8,

108250XE5,0XE8,0XED,0XE7,0XE6,0X07,0XE6,0X07,0XE5,0XE8,0XE6,0X08,0XEE,0X07,0XEE,0X07,

108260XEE,0X08,0XEE,0X08,0XED,0XE8,0XEE,0X08,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X49,

108270XA4,0X02,0X9B,0XE3,0X93,0XA4,0X9B,0XC6,0X93,0XC5,0X8B,0XA5,0X8B,0XA5,0X8B,0XA5,

108280X8B,0X85,0X83,0X65,0X7B,0X44,0X73,0X25,0X9C,0X8C,0XF7,0X5A,0XFF,0XFE,0XFF,0XFF,

108290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XBC,0XE6,0X74,

108300XAC,0XC8,0XDE,0X0A,0XE6,0X09,0XEE,0X08,0XEE,0X26,0XEE,0X26,0XEE,0X26,0XEE,0X07,

108310XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

108320XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

108330XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X29,

108340XE6,0X2A,0XB4,0XE7,0X52,0X20,0X4A,0X00,0X52,0X02,0X4A,0X03,0X52,0X64,0X41,0XC3,

108350X83,0XED,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108420XFF,0XDF,0XFF,0XDD,0XFF,0XBA,0XA4,0X8A,0XCD,0XAA,0XD5,0XC7,0XE5,0XE6,0XE5,0XC6,

108430XE5,0XC8,0XE5,0XE9,0XE6,0X08,0XDD,0XE7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,

108440XE6,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,

108450XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X27,0XEE,0X48,0XEE,0X69,0XBC,0XA4,0X9B,0XC2,

108460XA4,0X05,0X9B,0XE6,0X9B,0XE5,0X93,0XC5,0X8B,0XA5,0X8B,0XA5,0X8B,0X85,0X8B,0X86,

108470X7B,0X44,0X73,0X25,0X94,0X2B,0XF7,0X39,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBC,0XE6,0X74,0XAC,0XC8,0XDE,0X0A,

108490XE6,0X09,0XEE,0X07,0XEE,0X06,0XEE,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X07,0XEE,0X07,

108500XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

108510XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

108520XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XEE,0X07,0XE6,0X29,0XE6,0X2B,0XAC,0XA6,

108530X52,0X20,0X4A,0X01,0X4A,0X02,0X4A,0X03,0X52,0X44,0X41,0XC3,0X73,0X8B,0XFF,0XFD,

108540XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,

108610XFF,0XDB,0XAC,0XCB,0XC5,0X69,0XD5,0XC8,0XDD,0XE6,0XDD,0XC6,0XE5,0XC8,0XE5,0XE9,

108620XE6,0X08,0XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

108630XE6,0X07,0XE6,0X07,0XEE,0X08,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,

108640XEE,0X08,0XEE,0X28,0XEE,0X27,0XEE,0X69,0XCD,0X46,0X9B,0XC2,0XA4,0X04,0X9B,0XE5,

108650X9B,0XE5,0X93,0XC5,0X93,0XA5,0X93,0XA5,0X8B,0X85,0X8B,0XA6,0X83,0X65,0X7B,0X45,

108660X8B,0XEA,0XEF,0X18,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108670XFF,0XFF,0XFF,0XDF,0XFF,0XBC,0XE6,0X94,0XAC,0XC7,0XDE,0X2A,0XE5,0XE8,0XEE,0X08,

108680XEE,0X06,0XEE,0X26,0XEE,0X26,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

108690XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

108700XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

108710XEE,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X2B,0XA4,0X45,0X52,0X00,0X4A,0X01,

108720X49,0XE1,0X4A,0X03,0X4A,0X23,0X41,0XC3,0X63,0X2A,0XFF,0XDD,0XFF,0XFE,0XFF,0XFE,

108730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XB5,0X2D,

108800XC5,0X49,0XD5,0XC8,0XDD,0XC7,0XDD,0XC6,0XE5,0XC8,0XE5,0XC9,0XE5,0XE8,0XE5,0XE8,

108810XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

108820XE6,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,

108830XEE,0X28,0XEE,0X69,0XDD,0XE8,0XA4,0X23,0X9B,0XE3,0XA4,0X25,0X9C,0X05,0X9B,0XE5,

108840X93,0XC5,0X93,0XA5,0X8B,0X85,0X8B,0XA5,0X83,0X85,0X7B,0X45,0X83,0XA8,0XE6,0XF8,

108850XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

108860XFF,0XBC,0XE6,0X94,0XAC,0XA7,0XE6,0X2A,0XE5,0XE8,0XEE,0X28,0XED,0XE6,0XEE,0X27,

108870XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,

108880XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

108890XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,

108900XE6,0X07,0XE6,0X08,0XE6,0X2B,0X94,0X04,0X52,0X00,0X49,0XE0,0X41,0XC1,0X49,0XE2,

108910X4A,0X03,0X41,0XC3,0X62,0XE9,0XF7,0XBD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

108920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

108980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XC5,0X8F,0XBD,0X2A,0XDD,0XE9,

108990XDD,0XC7,0XDD,0XC7,0XE5,0XC8,0XDD,0XC8,0XDD,0XC8,0XDD,0XE8,0XE5,0XE8,0XE5,0XE8,

109000XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,

109010XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XE6,0X07,0XF6,0X69,

109020XEE,0X49,0XA4,0X22,0XAC,0X44,0XA4,0X04,0XA4,0X05,0XA4,0X26,0X93,0XC5,0X93,0XA5,

109030X93,0XA5,0X8B,0X85,0X83,0X64,0X7B,0X64,0X7B,0X88,0XE6,0XD7,0XFF,0XDE,0XFF,0XFF,

109040XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBC,0XE6,0X94,

109050XAC,0XA7,0XE6,0X4A,0XE5,0XE8,0XEE,0X28,0XED,0XE7,0XEE,0X27,0XEE,0X07,0XEE,0X07,

109060XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,

109070XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

109080XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X29,

109090XDE,0X2B,0X93,0XC4,0X52,0X00,0X49,0XE0,0X49,0XC1,0X49,0XE2,0X49,0XE3,0X39,0XC3,

109100X5A,0XC9,0XF7,0XBD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109170XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XCD,0XF1,0XB4,0XE9,0XD5,0XEA,0XDD,0XC8,0XE5,0XC7,

109180XE5,0XC8,0XE5,0XC8,0XDD,0XC7,0XDD,0XE8,0XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,

109190XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,

109200XEE,0X27,0XEE,0X07,0XE6,0X07,0XEE,0X28,0XE5,0XE7,0XEE,0X49,0XF6,0X8A,0XB4,0XA3,

109210XAC,0X64,0XA4,0X24,0XA4,0X04,0XA4,0X25,0X9B,0XE5,0X9B,0XC5,0X9B,0XC5,0X8B,0XA4,

109220X8B,0X83,0X83,0X84,0X7B,0X66,0XD6,0X75,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

109230XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XBC,0XE6,0X73,0XAC,0XC7,0XDE,0X29,

109240XE6,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

109250XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

109260XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

109270XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X29,0XDE,0X0B,0X8B,0XA3,

109280X52,0X20,0X49,0XE1,0X49,0XC1,0X49,0XE2,0X41,0XE2,0X39,0XA2,0X5A,0XE9,0XF7,0XBD,

109290XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

109360XFF,0XFD,0XDE,0X74,0XAC,0XA9,0XD5,0XCA,0XDD,0XE9,0XE5,0XE7,0XE5,0XC8,0XE5,0XC8,

109370XDD,0XC8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

109380XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X07,

109390XE6,0X07,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XFE,0XCA,0XDD,0XE8,0XA4,0X22,0XB4,0XA5,

109400XAC,0X85,0XA4,0X25,0XA4,0X26,0X9B,0XE5,0X9B,0XE5,0X8B,0XA4,0X8B,0XC3,0X83,0XA4,

109410X73,0X45,0XC5,0XD2,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

109420XFF,0XFF,0XFF,0XDF,0XFF,0XBC,0XDE,0X73,0XB4,0XE7,0XDE,0X08,0XEE,0X28,0XE5,0XE7,

109430XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,

109440XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

109450XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

109460XEE,0X06,0XEE,0X07,0XE6,0X07,0XE6,0X29,0XDD,0XEA,0X83,0X63,0X52,0X00,0X49,0XC0,

109470X41,0XC1,0X41,0XC2,0X41,0XE2,0X39,0XA2,0X62,0XE9,0XF7,0XBD,0XFF,0XFE,0XFF,0XFF,

109480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XEF,0X17,

109550XAC,0XAA,0XD5,0XCB,0XDD,0XC8,0XE5,0XC7,0XE5,0XE7,0XE5,0XA7,0XE5,0XE8,0XE5,0XE8,

109560XE5,0XC7,0XE5,0XE8,0XE5,0XE8,0XE5,0XE8,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE5,0XE7,

109570XE6,0X07,0XE6,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,

109580XE6,0X08,0XEE,0X28,0XF6,0X89,0XEE,0X89,0XB4,0XA3,0XAC,0X83,0XB4,0X85,0XAC,0X45,

109590XA4,0X25,0XA4,0X26,0X9B,0XE5,0X93,0XC4,0X93,0XE4,0X8B,0XC4,0X7B,0X45,0XB5,0X2F,

109600XFF,0XDD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

109610XFF,0X9C,0XDE,0X32,0XB5,0X07,0XE6,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X27,0XEE,0X07,

109620XEE,0X08,0XE6,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

109630XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

109640XEE,0X07,0XEE,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X06,0XEE,0X27,

109650XE6,0X07,0XEE,0X4A,0XD5,0XAA,0X83,0X83,0X52,0X00,0X49,0XC0,0X49,0XE2,0X41,0XA1,

109660X41,0XE2,0X39,0XA2,0X62,0XEA,0XF7,0XBD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XF7,0X59,0XAC,0XCB,0XCD,0X8B,

109740XDD,0XCA,0XDD,0XA7,0XE5,0XE7,0XE5,0XC6,0XE5,0XC7,0XE5,0XE8,0XE5,0XC7,0XE5,0XE8,

109750XE5,0XE8,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE5,0XE8,0XE5,0XE8,0XE6,0X07,0XE6,0X07,

109760XEE,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XE6,0X28,

109770XEE,0X69,0XF6,0XAA,0XCD,0X65,0XB4,0X83,0XB4,0XA4,0XAC,0X65,0XAC,0X25,0XAC,0X26,

109780XAC,0X26,0X9B,0XE5,0X93,0XE4,0X8B,0XC4,0X83,0X85,0X9C,0X8C,0XFF,0XBC,0XFF,0XFF,

109790XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XBB,0XD6,0X31,

109800XBD,0X27,0XE6,0X28,0XEE,0X27,0XE6,0X06,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XE6,0X08,

109810XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,

109820XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

109830XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X06,0XEE,0X27,0XEE,0X07,0XEE,0X2A,

109840XCD,0X69,0X83,0X43,0X52,0X00,0X49,0XC1,0X49,0XC2,0X41,0XA1,0X41,0XC2,0X39,0X82,

109850X6B,0X4B,0XF7,0XBD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109920XF7,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0X9B,0XBD,0X2D,0XC5,0X2A,0XDD,0XCA,0XDD,0XA7,

109930XE5,0XC7,0XE5,0XC6,0XE5,0XC7,0XE5,0XE8,0XE5,0XC7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE7,

109940XE5,0XE7,0XE6,0X07,0XE5,0XE8,0XE5,0XE8,0XE6,0X07,0XE6,0X08,0XEE,0X07,0XE6,0X07,

109950XE6,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XE6,0X07,0XEE,0X48,0XFE,0XEA,

109960XE6,0X48,0XBC,0XC3,0XB4,0XA4,0XAC,0X65,0XB4,0X66,0XAC,0X26,0XAC,0X26,0X9B,0XE5,

109970X9C,0X05,0X93,0XE4,0X8B,0XC6,0X83,0XC9,0XF7,0X5A,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

109980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XBB,0XD5,0XF0,0XC5,0X48,0XE6,0X28,

109990XEE,0X28,0XEE,0X06,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,

110000XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

110010XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,

110020XEE,0X07,0XEE,0X27,0XE6,0X06,0XEE,0X27,0XEE,0X28,0XE6,0X09,0XC5,0X28,0X83,0X43,

110030X52,0X00,0X49,0XC1,0X49,0XC2,0X41,0XC2,0X41,0XC2,0X31,0X82,0X7B,0XAD,0XFF,0XDE,

110040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XFF,0XFF,

110110XFF,0XFF,0XFF,0XBC,0XCD,0XD1,0XB4,0XEA,0XD5,0XAA,0XDD,0XC8,0XE5,0XE7,0XE5,0XC6,

110120XE5,0XE7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

110130XE5,0XE8,0XE5,0XE8,0XE6,0X08,0XE6,0X08,0XE6,0X08,0XE6,0X07,0XE6,0X07,0XEE,0X27,

110140XEE,0X28,0XEE,0X28,0XEE,0X28,0XE6,0X28,0XE6,0X07,0XF6,0X89,0XFE,0XEA,0XCD,0X85,

110150XB4,0XC4,0XB4,0XA5,0XB4,0X86,0XAC,0X46,0XAC,0X47,0XA4,0X26,0XA4,0X25,0X93,0XE4,

110160X8B,0XE6,0X83,0XA8,0XE6,0XD8,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110170XFF,0XFF,0XFF,0XFE,0XFF,0XBB,0XCD,0XAF,0XC5,0X68,0XE6,0X28,0XEE,0X28,0XEE,0X07,

110180XEE,0X27,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X27,

110190XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

110200XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X47,

110210XE6,0X06,0XEE,0X27,0XEE,0X28,0XE6,0X09,0XB4,0XC7,0X83,0X43,0X52,0X01,0X41,0XC1,

110220X49,0XC2,0X41,0XC2,0X41,0XC2,0X31,0X82,0X83,0XED,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

110230XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,

110300XE6,0X95,0XAC,0XCB,0XD5,0XAB,0XE5,0XE9,0XE5,0XC6,0XE5,0XE6,0XE5,0XE7,0XE5,0XC7,

110310XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

110320XE6,0X08,0XE6,0X08,0XE6,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X07,

110330XEE,0X28,0XEE,0X48,0XE6,0X07,0XE6,0X27,0XFF,0X0A,0XEE,0X69,0XC5,0X25,0XBC,0XE5,

110340XBC,0XC6,0XB4,0X86,0XAC,0X46,0XAC,0X46,0XA4,0X45,0X9C,0X25,0X94,0X06,0X83,0XA7,

110350XCD,0XF3,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

110360XFF,0XDA,0XC5,0X8D,0XCD,0X88,0XE6,0X28,0XEE,0X28,0XEE,0X08,0XEE,0X07,0XEE,0X07,

110370XEE,0X07,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

110380XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

110390XEE,0X07,0XEE,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X06,0XEE,0X27,

110400XEE,0X28,0XE6,0X0A,0XB4,0XA7,0X83,0X43,0X51,0XE1,0X41,0XC1,0X49,0XE2,0X41,0XC2,

110410X41,0XC2,0X31,0X61,0X84,0X0E,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XF7,0X38,0XAC,0XCB,

110490XCD,0X6B,0XDD,0XC9,0XDD,0XA6,0XE6,0X07,0XDD,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

110500XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

110510XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XE6,0X28,0XEE,0X48,

110520XE6,0X27,0XE6,0X27,0XFE,0XEA,0XFE,0XEA,0XD5,0XA6,0XBC,0XE5,0XB4,0XA5,0XBC,0XE7,

110530XB4,0X86,0XAC,0X46,0XAC,0X65,0XA4,0X65,0X9C,0X05,0X8B,0XA6,0XA4,0XCE,0XFF,0XFD,

110540XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XD9,0XC5,0X8C,

110550XCD,0XA8,0XE6,0X49,0XEE,0X09,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

110560XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,

110570XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,

110580XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X47,0XEE,0X07,0XEE,0X27,0XEE,0X49,0XE5,0XE9,

110590XB4,0XA7,0X7B,0X03,0X52,0X01,0X49,0XC1,0X49,0XE2,0X41,0XC2,0X41,0XC2,0X31,0X61,

110600X94,0X90,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XBD,0XFF,0X9A,0XBD,0X4F,0XBD,0X2A,0XD5,0XA9,

110680XDD,0XA6,0XE6,0X07,0XDD,0XC7,0XE6,0X08,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,

110690XE6,0X06,0XE6,0X06,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X08,

110700XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XE6,0X28,0XEE,0X48,0XEE,0X48,0XE6,0X27,

110710XF6,0X88,0XFF,0X0B,0XEE,0X69,0XCD,0X66,0XB4,0XA4,0XC4,0XE6,0XBC,0XC7,0XB4,0X86,

110720XAC,0X64,0XA4,0X64,0X9C,0X45,0X94,0X27,0X94,0X0A,0XF7,0X7A,0XFF,0XDD,0XFF,0XFF,

110730XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFC,0XFF,0XB7,0XC5,0XAC,0XCD,0XA8,0XE6,0X49,

110740XED,0XE9,0XF6,0X09,0XEE,0X08,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

110750XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

110760XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X07,0XEE,0X07,

110770XEE,0X07,0XF6,0X47,0XEE,0X07,0XEE,0X27,0XF6,0X49,0XDD,0XA8,0XB4,0XC7,0X72,0XC2,

110780X52,0X01,0X49,0XE2,0X49,0XE2,0X41,0XC2,0X41,0XE2,0X31,0X82,0XB5,0X74,0XFF,0XFF,

110790XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110860XFF,0XFF,0XFF,0XDE,0XFF,0XDC,0XD6,0X33,0XB4,0XEA,0XD5,0XAA,0XDD,0XC7,0XDD,0XE6,

110870XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

110880XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,

110890XEE,0X28,0XEE,0X28,0XEE,0X48,0XE6,0X07,0XEE,0X27,0XE6,0X27,0XE6,0X47,0XFE,0XEA,

110900XFF,0X4D,0XE6,0X49,0XC5,0X25,0XBC,0XC5,0XB4,0X85,0XB4,0X85,0XB4,0XC5,0XB4,0XC6,

110910XAC,0XA6,0X9C,0X47,0X8B,0XE8,0XDE,0X55,0XFF,0XDC,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,

110920XFF,0XFC,0XFF,0XFA,0XFF,0X95,0XCD,0XAB,0XCD,0XA8,0XEE,0X49,0XE5,0XE8,0XEE,0X09,

110930XEE,0X08,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,

110940XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

110950XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XF6,0X48,

110960XEE,0X27,0XEE,0X27,0XF6,0X69,0XD5,0X67,0XBC,0XE8,0X62,0X61,0X52,0X01,0X52,0X02,

110970X49,0XE2,0X49,0XC2,0X41,0XE2,0X39,0X82,0XC6,0X16,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110980XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

110990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

111050XFF,0XFD,0XEF,0X37,0XBD,0X6D,0XC5,0X8A,0XDD,0XC9,0XDD,0XC7,0XE5,0XE7,0XE5,0XC7,

111060XE5,0XC7,0XE5,0XE7,0XE5,0XE8,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

111070XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X28,

111080XEE,0X28,0XEE,0X07,0XEE,0X48,0XEE,0X68,0XE6,0X27,0XEE,0X68,0XFF,0X0C,0XFF,0X4D,

111090XE6,0X29,0XB4,0XC4,0XBC,0XE5,0XB4,0X85,0XAC,0X84,0XAC,0X84,0XA4,0X84,0XA4,0X86,

111100X9C,0X48,0XAC,0XED,0XFF,0XBA,0XFF,0XBB,0XFF,0XDC,0XFF,0XBB,0XFF,0XFA,0XFF,0XD6,

111110XFF,0X72,0XDE,0X2B,0XDE,0X09,0XE6,0X29,0XE5,0XE8,0XEE,0X08,0XEE,0X07,0XEE,0X07,

111120XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

111130XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,

111140XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X26,0XF6,0X67,

111150XEE,0X28,0XD5,0X68,0XB4,0XA8,0X62,0X40,0X51,0XE1,0X52,0X23,0X4A,0X02,0X4A,0X03,

111160X49,0XC3,0X41,0XC4,0XDE,0X99,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,

111170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XBA,

111240XCE,0X31,0XBD,0X4A,0XD5,0XA9,0XE5,0XE9,0XE5,0XC7,0XE5,0XC8,0XE5,0XC7,0XE5,0XE8,

111250XE5,0XE8,0XE5,0XE8,0XE5,0XE8,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

111260XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X08,0XEE,0X07,0XF6,0X48,

111270XEE,0X27,0XE6,0X27,0XEE,0X48,0XEE,0X48,0XEE,0X6A,0XFF,0X0C,0XFF,0X0C,0XE6,0X09,

111280XB4,0XA4,0XB4,0XC5,0XB4,0XA4,0XAC,0X84,0XAC,0XC5,0XA4,0X64,0XA4,0X87,0XAC,0X8A,

111290XEE,0XB5,0XFF,0XBA,0XFF,0XB9,0XFF,0XD8,0XF7,0X55,0XFF,0X93,0XEE,0XEE,0XE6,0X4A,

111300XE6,0X29,0XE6,0X29,0XE6,0X28,0XEE,0X48,0XF6,0X27,0XEE,0X07,0XF6,0X07,0XEE,0X07,

111310XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

111320XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,

111330XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X26,0XF6,0X67,0XEE,0X28,0XD5,0X88,

111340XAC,0X66,0X5A,0X40,0X52,0X01,0X52,0X23,0X52,0X02,0X4A,0X03,0X41,0XC3,0X52,0X26,

111350XF7,0X5C,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XFC,0XEE,0XF5,0XC5,0X6D,

111430XCD,0X8A,0XDD,0XCA,0XDD,0XA8,0XE5,0XC8,0XE5,0XC8,0XE5,0XC8,0XE5,0XE8,0XE5,0XE8,

111440XE5,0XE7,0XE5,0XE7,0XE5,0XE8,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

111450XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X08,0XEE,0X28,0XEE,0X48,0XEE,0X47,0XEE,0X47,

111460XEE,0X47,0XE6,0X48,0XE6,0X48,0XEE,0X8A,0XFE,0XEB,0XFF,0XAE,0XEE,0XAB,0XCD,0X87,

111470XAC,0X62,0XA4,0X62,0XAC,0X83,0XAC,0X84,0X9C,0X24,0XA4,0X67,0XC5,0X6D,0XFF,0X56,

111480XFF,0X55,0XFF,0X34,0XEE,0XD0,0XEE,0XCE,0XE6,0X4B,0XE6,0X4A,0XE6,0X49,0XE6,0X28,

111490XEE,0X28,0XEE,0X48,0XEE,0X27,0XEE,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X08,0XEE,0X28,

111500XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

111510XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

111520XEE,0X28,0XEE,0X28,0XEE,0X47,0XF6,0X68,0XE6,0X08,0XD5,0XA9,0X93,0XC4,0X5A,0X40,

111530X5A,0X22,0X5A,0X42,0X52,0X02,0X4A,0X02,0X41,0XC3,0X62,0XC8,0XFF,0XFE,0XFF,0XFF,

111540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111610XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDC,0XFF,0X99,0XDE,0X31,0XC5,0X4A,0XD5,0XCA,

111620XDD,0XC9,0XE5,0XC8,0XE5,0XC8,0XE5,0XC8,0XE5,0XC8,0XE5,0XE8,0XE5,0XE8,0XE5,0XE8,

111630XE5,0XE8,0XE5,0XE8,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,

111640XEE,0X08,0XEE,0X28,0XF6,0X48,0XEE,0X07,0XEE,0X47,0XF6,0X67,0XE6,0X26,0XE6,0X27,

111650XEE,0X68,0XE6,0X28,0XEE,0X69,0XEE,0XAA,0XFF,0X2D,0XFF,0X2D,0XFE,0XEC,0XE6,0X49,

111660XC5,0X65,0XCD,0X66,0XD5,0XC9,0XDE,0X0C,0XE6,0X4E,0XFF,0X12,0XF6,0XD0,0XEE,0X8E,

111670XE6,0X4C,0XDD,0XE9,0XE6,0X29,0XE6,0X49,0XE6,0X28,0XE6,0X28,0XEE,0X47,0XEE,0X27,

111680XEE,0X07,0XEE,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

111690XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,

111700XEE,0X27,0XEE,0X27,0XF6,0X27,0XEE,0X27,0XF6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

111710XEE,0X26,0XEE,0X47,0XE5,0XE8,0XD5,0XA9,0X83,0X42,0X62,0X61,0X5A,0X42,0X5A,0X43,

111720X52,0X22,0X52,0X02,0X41,0XC3,0X7B,0XAC,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

111730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111800XFF,0XDE,0XFF,0XBC,0XFF,0XFB,0XF7,0X36,0XBD,0X4B,0XD5,0XEB,0XD5,0XC8,0XDD,0XE7,

111810XE5,0XC6,0XE5,0XC6,0XE5,0XE7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE8,0XE5,0XE9,0XE5,0XE8,

111820XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X28,

111830XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XE6,0X27,0XE6,0X28,0XE6,0X48,

111840XE6,0X28,0XE6,0X49,0XEE,0X8A,0XF6,0XAA,0XFF,0X2C,0XFF,0X4C,0XFF,0X6D,0XFF,0X6D,

111850XFF,0X4D,0XFF,0X0D,0XFE,0XEE,0XEE,0X4C,0XE5,0XEA,0XEE,0X2A,0XE6,0X09,0XEE,0X48,

111860XE6,0X28,0XE6,0X28,0XE6,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X26,0XF6,0X47,0XF6,0X27,

111870XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,

111880XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

111890XF6,0X27,0XEE,0X27,0XF6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X48,

111900XE6,0X08,0XD5,0X89,0X7A,0XE1,0X6A,0XA2,0X5A,0X62,0X62,0X83,0X52,0X43,0X52,0X43,

111910X41,0XE3,0XA5,0X11,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

111980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,

111990XFF,0XDC,0XFF,0X99,0XE6,0XB3,0XB5,0X09,0XD6,0X0A,0XD5,0XC7,0XDD,0XE6,0XE5,0XE6,

112000XE5,0XE6,0XED,0XE7,0XED,0XE8,0XE5,0XE8,0XE5,0XE8,0XE5,0XE8,0XE5,0XE8,0XEE,0X07,

112010XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X47,

112020XEE,0X27,0XEE,0X26,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X49,0XEE,0X48,0XE6,0X48,

112030XE6,0X28,0XE6,0X48,0XE6,0X48,0XE6,0X48,0XEE,0X68,0XE6,0X48,0XEE,0X28,0XE6,0X28,

112040XEE,0X49,0XEE,0X29,0XEE,0X08,0XF6,0X28,0XEE,0X07,0XEE,0X47,0XEE,0X27,0XEE,0X47,

112050XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X68,0XEE,0X27,0XEE,0X27,0XEE,0X27,

112060XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

112070XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XF6,0X27,0XEE,0X27,

112080XF6,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XE6,0X29,0XC5,0X07,

112090X72,0XC1,0X72,0XC2,0X62,0X63,0X62,0XA4,0X5A,0X63,0X52,0X63,0X41,0XC2,0XCE,0X35,

112100XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XFD,

112180XF7,0X37,0XDE,0X50,0XBD,0X69,0XD6,0X08,0XDD,0XE6,0XDD,0XE5,0XE5,0XE6,0XE5,0XE6,

112190XED,0XE7,0XED,0XE7,0XED,0XE7,0XE5,0XE7,0XED,0XE8,0XEE,0X08,0XEE,0X08,0XEE,0X07,

112200XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X48,0XEE,0X27,0XEE,0X27,0XEE,0X27,

112210XEE,0X27,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XE6,0X48,0XEE,0X48,0XEE,0X48,

112220XE6,0X48,0XEE,0X48,0XE6,0X27,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X07,0XF6,0X48,

112230XF6,0X27,0XEE,0X07,0XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X46,

112240XEE,0X46,0XF6,0X47,0XF6,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

112250XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

112260XEE,0X27,0XEE,0X27,0XEE,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X27,

112270XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X48,0XE6,0X2A,0XAC,0X65,0X72,0XE1,0X72,0XE3,

112280X6A,0XA3,0X62,0XA4,0X5A,0X83,0X52,0X64,0X52,0X65,0XE7,0X19,0XFF,0XFE,0XFF,0XFF,

112290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112360XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDD,0XFF,0XDC,0XF7,0X56,

112370XCD,0XCD,0XCD,0XC9,0XD5,0XE7,0XDD,0XE6,0XE5,0XE6,0XE5,0XE6,0XE5,0XE6,0XED,0XE7,

112380XED,0XE7,0XED,0XE7,0XED,0XE8,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X27,0XEE,0X27,

112390XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

112400XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X69,0XEE,0X28,0XEE,0X28,0XEE,0X48,0XE6,0X28,

112410XEE,0X48,0XEE,0X68,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X27,

112420XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X47,0XEE,0X47,

112430XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,

112440XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

112450XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X47,

112460XEE,0X47,0XEE,0X69,0XE6,0X4A,0X9C,0X04,0X7A,0XE2,0X72,0XE3,0X72,0XE4,0X62,0XA4,

112470X62,0XC4,0X52,0X64,0X73,0X69,0XF7,0X9B,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112550XFF,0XFE,0XF7,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XF7,0X35,0XD6,0X0E,

112560XCD,0XCA,0XD5,0XC7,0XDD,0XE7,0XDD,0XA6,0XF6,0X48,0XED,0XE7,0XED,0XE7,0XED,0XE7,

112570XED,0XE8,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XE6,0X07,0XEE,0X28,

112580XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,

112590XF6,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,

112600XEE,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XF6,0X47,0XEE,0X27,0XF6,0X27,0XF6,0X27,

112610XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

112620XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X27,

112630XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X47,0XF6,0X27,0XF6,0X27,

112640XEE,0X27,0XF6,0X48,0XEE,0X27,0XF6,0X48,0XEE,0X27,0XEE,0X47,0XF6,0X68,0XEE,0X49,

112650XDD,0XE9,0X93,0XA2,0X7B,0X02,0X7A,0XE3,0X7B,0X25,0X62,0XA4,0X62,0XA4,0X5A,0X84,

112660X9C,0XAE,0XF7,0XBC,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

112740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0X9A,0XEE,0XF4,0XD6,0X0D,0XD5,0XCA,

112750XDD,0XE8,0XDD,0XE7,0XE5,0XE7,0XE5,0XE7,0XEE,0X07,0XED,0XE7,0XE5,0XE7,0XEE,0X07,

112760XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X48,0XEE,0X28,0XEE,0X28,

112770XEE,0X27,0XEE,0X27,0XEE,0X26,0XEE,0X26,0XEE,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X47,

112780XF6,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XF6,0X68,0XEE,0X27,

112790XEE,0X47,0XEE,0X47,0XEE,0X27,0XF6,0X47,0XF6,0X48,0XEE,0X28,0XF6,0X27,0XF6,0X27,

112800XF6,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

112810XEE,0X28,0XEE,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

112820XF6,0X27,0XF6,0X27,0XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X27,0XF6,0X48,

112830XF6,0X27,0XF6,0X47,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X6A,0XCD,0X68,0X8B,0X82,

112840X83,0X23,0X7B,0X03,0X7B,0X05,0X6A,0XC4,0X62,0XE5,0X5A,0XC6,0XB5,0X92,0XFF,0XDD,

112850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

112920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XF7,0XFE,0XFF,0XFF,0XFF,0XFF,

112930XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XBA,0XEE,0XD3,0XD6,0X0D,0XD5,0XC9,0XDE,0X08,

112940XDD,0XE7,0XDD,0XE6,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

112950XEE,0X27,0XEE,0X07,0XE6,0X07,0XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

112960XEE,0X26,0XEE,0X46,0XEE,0X46,0XEE,0X46,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

112970XF6,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X47,0XEE,0X48,0XF6,0X68,0XEE,0X47,

112980XEE,0X47,0XEE,0X48,0XEE,0X27,0XF6,0X68,0XEE,0X27,0XF6,0X27,0XEE,0X27,0XEE,0X27,

112990XF6,0X27,0XF6,0X28,0XEE,0X28,0XF6,0X48,0XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X28,

113000XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X27,

113010XF6,0X48,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X48,0XEE,0X47,

113020XF6,0X68,0XEE,0X48,0XEE,0X28,0XEE,0X8A,0XB4,0XC6,0X8B,0XA3,0X83,0X63,0X83,0X44,

113030X72,0XE4,0X73,0X05,0X62,0XC5,0X6B,0X27,0XD6,0X97,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

113040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113110XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

113120XFF,0XDE,0XFF,0XDD,0XFF,0XDA,0XEF,0X14,0XCE,0X0C,0XCD,0XC9,0XDE,0X28,0XE6,0X28,

113130XDD,0XE7,0XE6,0X07,0XE6,0X07,0XEE,0X06,0XEE,0X06,0XEE,0X06,0XEE,0X27,0XEE,0X27,

113140XEE,0X28,0XEE,0X28,0XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X26,0XEE,0X46,

113150XEE,0X46,0XEE,0X46,0XF6,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X47,

113160XEE,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X68,0XEE,0X48,

113170XEE,0X48,0XEE,0X27,0XEE,0X27,0XF6,0X27,0XEE,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X28,

113180XEE,0X28,0XF6,0X48,0XEE,0X28,0XEE,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,

113190XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X27,

113200XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X28,0XF6,0X48,0XF6,0X47,0XF6,0X68,0XEE,0X48,

113210XEE,0X69,0XEE,0X6A,0XA4,0X44,0X93,0XC3,0X8B,0X84,0X8B,0X85,0X7B,0X04,0X7B,0X26,

113220X62,0XC5,0X83,0XEB,0XEF,0X5A,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBF,0XFF,0XDE,

113310XFF,0XFD,0XFF,0XB9,0XF7,0X74,0XDE,0XAE,0XCD,0XE9,0XD5,0XE7,0XE6,0X28,0XE6,0X07,

113320XE6,0X07,0XE6,0X07,0XE6,0X06,0XE6,0X06,0XEE,0X26,0XEE,0X27,0XEE,0X28,0XEE,0X48,

113330XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X67,

113340XEE,0X47,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XF6,0X48,0XF6,0X47,0XEE,0X47,

113350XEE,0X06,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X88,0XFE,0XA9,0XD5,0X84,

113360XEE,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X28,0XF6,0X28,

113370XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

113380XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X28,

113390XF6,0X28,0XF6,0X28,0XF6,0X48,0XF6,0X47,0XEE,0X47,0XEE,0X68,0XF6,0X8A,0XDD,0XE9,

113400X9B,0XE3,0X93,0XE4,0X8B,0X84,0X93,0XA6,0X83,0X45,0X83,0X66,0X6B,0X06,0XA4,0XEF,

113410XF7,0X9B,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,

113500XFF,0XD9,0XEF,0X34,0XEF,0X10,0XDE,0X2C,0XD5,0XC9,0XDD,0XC8,0XE5,0XE8,0XE6,0X08,

113510XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XE6,0X07,0XE6,0X07,0XEE,0X28,0XEE,0X28,

113520XF6,0X48,0XF6,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X48,0XEE,0X48,0XEE,0X47,0XEE,0X28,

113530XF6,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X47,0XF6,0X47,0XF6,0X68,0XEE,0X47,

113540XF6,0X68,0XFE,0XA9,0XF6,0X68,0XE5,0XC5,0XDD,0XA4,0XC4,0XC1,0XF6,0X47,0XF6,0X47,

113550XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,

113560XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,

113570XF6,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X28,

113580XF6,0X48,0XF6,0X47,0XEE,0X47,0XF6,0X89,0XF6,0X8A,0XC5,0X27,0X9B,0XE3,0X9C,0X05,

113590X93,0XA5,0X93,0XA6,0X8B,0X86,0X83,0X66,0X7B,0X68,0XC5,0XF3,0XFF,0XDC,0XFF,0XFE,

113600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113680XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFB,

113690XFF,0XB8,0XEE,0XD3,0XE6,0X4F,0XE6,0X0D,0XDD,0XEA,0XE5,0XE9,0XE6,0X08,0XE6,0X07,

113700XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X28,

113710XEE,0X28,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XF6,0X28,

113720XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XFE,0X88,0XEE,0X07,0XE5,0XC5,

113730XE5,0XA5,0XEE,0X06,0XE5,0XC5,0XDD,0XA4,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

113740XF6,0X48,0XF6,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X27,

113750XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X27,

113760XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X48,0XF6,0X47,

113770XEE,0X47,0XFE,0XCA,0XEE,0X49,0XB4,0XA5,0X9C,0X24,0X9C,0X05,0X9B,0XE6,0X93,0XA6,

113780X93,0XC7,0X7B,0X46,0X94,0X4B,0XE6,0XD7,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

113870XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFE,0XFF,0XBC,0XFF,0X9A,

113880XFF,0X78,0XF6,0XD3,0XE6,0X4E,0XEE,0X4C,0XE6,0X0A,0XDD,0XE8,0XDD,0XE8,0XE6,0X07,

113890XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X29,

113900XEE,0X29,0XEE,0X29,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XF6,0X29,0XF6,0X69,0XFE,0X69,

113910XFE,0X68,0XF6,0X68,0XF6,0X27,0XE5,0XC6,0XE5,0XA6,0XF6,0X48,0XF6,0X48,0XFE,0X89,

113920XDD,0XA5,0XE5,0XC5,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

113930XF6,0X48,0XF6,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

113940XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X27,0XF6,0X27,0XF6,0X27,

113950XF6,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X68,0XFE,0XEB,

113960XDD,0XE8,0XAC,0X43,0XA4,0X64,0X94,0X04,0XA4,0X26,0X93,0XA5,0X9C,0X08,0X83,0X67,

113970XB5,0X2F,0XF7,0X9A,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

113990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

114060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDE,0XFF,0XDD,0XFF,0XBC,0XFF,0XBB,

114070XFF,0X56,0XF7,0X12,0XEE,0XAF,0XE6,0X8D,0XE6,0X6C,0XE6,0X6A,0XE6,0X49,0XE6,0X48,

114080XE6,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XF6,0X49,0XEE,0X48,

114090XEE,0X68,0XF6,0X88,0XF6,0X89,0XFE,0X6A,0XFE,0X4A,0XFE,0X49,0XFE,0X48,0XF6,0X47,

114100XEE,0X27,0XF6,0X68,0XF6,0X69,0XFE,0XAA,0XFE,0XAA,0XEE,0X48,0XD5,0X64,0XF6,0X27,

114110XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X27,

114120XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X48,0XF6,0X48,0XF6,0X48,

114130XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XF6,0X48,0XF6,0X48,

114140XF6,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X69,0XF6,0X8A,0XF6,0X8B,0XD5,0X67,0XAC,0X43,

114150XA4,0X64,0X9C,0X44,0XA4,0X66,0X93,0XE6,0X93,0XE7,0X8B,0XE9,0XCE,0X13,0XFF,0XDC,

114160XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114250XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDE,0XFF,0XDD,0XFF,0XDB,0XFF,0XB8,

114260XFF,0X96,0XF7,0X54,0XEE,0XF1,0XEE,0XCF,0XEE,0XAE,0XE6,0X8C,0XE6,0X6C,0XEE,0X8B,

114270XEE,0X8B,0XEE,0X6B,0XF6,0X8B,0XEE,0X6A,0XEE,0X4A,0XEE,0X49,0XE6,0X48,0XE6,0X07,

114280XE5,0XC7,0XE5,0XE8,0XEE,0X08,0XF6,0X28,0XFE,0X68,0XFE,0XA9,0XFE,0XA9,0XFE,0XCA,

114290XFE,0XCB,0XF6,0X8A,0XFE,0XAA,0XEE,0X48,0XDD,0X85,0XEE,0X07,0XF6,0X48,0XF6,0X48,

114300XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X27,0XF6,0X27,0XF6,0X27,

114310XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

114320XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XEE,0X28,0XF6,0X48,

114330XF6,0X48,0XEE,0X48,0XFE,0XCC,0XEE,0X4A,0XCD,0X26,0XB4,0X84,0XAC,0X84,0XA4,0X65,

114340XA4,0X66,0X94,0X06,0X93,0XE7,0XA4,0X8C,0XE6,0XF7,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,

114350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114440XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFB,

114450XFF,0XD9,0XFF,0XB8,0XFF,0X76,0XF7,0X14,0XDE,0X50,0XCD,0XAD,0XBD,0X2B,0XB4,0XE8,

114460XAC,0XC7,0XAC,0XE6,0XBD,0X07,0XB5,0X06,0XC5,0X67,0XD5,0XA8,0XE6,0X09,0XEE,0X4A,

114470XFE,0X8A,0XFE,0XAA,0XFE,0XA9,0XFE,0XA9,0XF6,0X89,0XEE,0X68,0XF6,0XCA,0XF6,0XAA,

114480XFE,0XCA,0XDD,0XC5,0XDD,0X64,0XFE,0X67,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,

114490XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

114500XF6,0X27,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

114510XF6,0X47,0XF6,0X47,0XF6,0X48,0XEE,0X28,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XEE,0X48,

114520XFE,0XED,0XE5,0XC9,0XC4,0XE5,0XBC,0XE6,0XB4,0XA5,0XAC,0XA6,0XA4,0X66,0X9C,0X26,

114530X94,0X08,0XBD,0X70,0XFF,0XBB,0XFF,0XFD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDD,0XFF,0XFC,

114640XFF,0XFC,0XFF,0XDB,0XFF,0XDB,0XFF,0XBA,0XEF,0X16,0XCD,0XF1,0XB5,0X2C,0X9C,0X68,

114650X94,0X47,0XA4,0X88,0XBD,0X2A,0XCD,0XAB,0XE6,0X2C,0XEE,0X6C,0XF6,0X8B,0XF6,0X8B,

114660XF6,0X8B,0XEE,0X8A,0XF6,0XAB,0XEE,0X8B,0XF6,0XAB,0XEE,0X4A,0XF6,0X8A,0XDD,0X85,

114670XE5,0XA5,0XF6,0X46,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

114680XF6,0X48,0XF6,0X48,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

114690XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

114700XF6,0X48,0XEE,0X47,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XFE,0X8A,0XFE,0XCC,0XDD,0X88,

114710XBC,0XC5,0XC5,0X07,0XBC,0XC6,0XB4,0XA6,0XAC,0XA7,0XA4,0X47,0X9C,0X6A,0XD6,0X53,

114720XFF,0XFC,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

114830XFF,0XFE,0XFF,0XBD,0XFF,0XDD,0XFF,0XFC,0XFF,0XFC,0XFF,0XDA,0XEF,0X57,0XD6,0X53,

114840XBD,0X4F,0XAC,0XCC,0XA4,0X69,0XA4,0X87,0XB4,0XE8,0XC5,0X69,0XD5,0XEB,0XE6,0X4C,

114850XE6,0X6D,0XEE,0X8D,0XEE,0X8D,0XF6,0XAD,0XF6,0X6B,0XD5,0X66,0XEE,0X06,0XFE,0X67,

114860XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

114870XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

114880XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

114890XF6,0X47,0XF6,0X47,0XF6,0X89,0XFE,0XCB,0XEE,0X2A,0XD5,0X47,0XC4,0XC5,0XCD,0X07,

114900XC5,0X07,0XBC,0XA7,0XB4,0XC8,0X9C,0X48,0XB5,0X0D,0XEF,0X38,0XFF,0XFC,0XFF,0XFE,

114910XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

114990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XDF,

115010XF7,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

115020XFF,0XFF,0XFF,0XBE,0XFF,0XDE,0XFF,0XDD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XBB,

115030XFF,0X58,0XE6,0XB4,0XCD,0XF0,0XC5,0X8E,0XC5,0X8E,0XCD,0XCE,0XCD,0XCE,0XE6,0X91,

115040XF6,0XD1,0XF6,0XF0,0XE6,0X0B,0XD5,0X67,0XEE,0X28,0XF6,0X27,0XF6,0X48,0XF6,0X48,

115050XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X27,0XF6,0X27,

115060XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X48,0XF6,0X48,

115070XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X68,

115080XFE,0XA9,0XFE,0XCB,0XDD,0XA8,0XD5,0X47,0XC5,0X06,0XCD,0X27,0XCD,0X28,0XBC,0XC7,

115090XB4,0XC9,0XA4,0X69,0XCD,0XF1,0XFF,0XFB,0XFF,0XFD,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

115100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115200XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

115210XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XBC,

115220XFF,0XBC,0XFF,0XDC,0XFF,0XDB,0XFF,0XBB,0XFF,0X9A,0XFF,0X99,0XFF,0X98,0XFF,0X75,

115230XE6,0X2E,0XD5,0X89,0XEE,0X4A,0XEE,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

115240XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

115250XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

115260XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XFE,0XA9,0XFE,0XCA,0XF6,0X49,

115270XD5,0X47,0XD5,0X47,0XCD,0X46,0XCD,0X26,0XCD,0X27,0XC4,0XE8,0XB4,0XA9,0XB4,0XEC,

115280XEF,0X17,0XFF,0XFC,0XFF,0XFE,0XFF,0XDE,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

115290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

115390XFF,0XFE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,

115400XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

115410XFF,0XDE,0XFF,0XDE,0XFF,0XDD,0XFF,0XFD,0XFF,0XFB,0XF7,0X36,0XCD,0XCD,0XD5,0XAA,

115420XEE,0X6A,0XE6,0X07,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

115430XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

115440XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X28,0XF6,0X28,

115450XF6,0X48,0XF6,0X48,0XF6,0X47,0XFE,0XC9,0XFE,0XCA,0XDD,0XC7,0XCD,0X46,0XCD,0X46,

115460XCD,0X67,0XCD,0X46,0XCD,0X07,0XC5,0X08,0XB4,0XA9,0XC5,0X90,0XFF,0XFB,0XFF,0XDD,

115470XFF,0XFE,0XF7,0XDE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115590XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

115600XFF,0XDE,0XFF,0XFD,0XFF,0XFB,0XE6,0XD3,0XC5,0XAA,0XDE,0X2A,0XF6,0X8A,0XEE,0X48,

115610XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

115620XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

115630XEE,0X27,0XF6,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X48,0XF6,0X49,0XF6,0X49,0XF6,0X48,

115640XFE,0X89,0XFE,0XAA,0XFE,0X89,0XDD,0X86,0XD5,0X66,0XD5,0X67,0XCD,0X66,0XCD,0X67,

115650XCD,0X27,0XC5,0X08,0XBD,0X0C,0XEE,0XD6,0XFF,0XFD,0XFF,0XFE,0XF7,0XDE,0XFF,0XFF,

115660XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115780XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,

115790XFF,0X99,0XDE,0X70,0XBD,0X48,0XE6,0X69,0XEE,0X68,0XEE,0X68,0XF6,0X48,0XF6,0X48,

115800XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

115810XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,

115820XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X69,0XF6,0X28,0XF6,0X49,0XFE,0XAA,0XFE,0X89,

115830XEE,0X28,0XDD,0XA6,0XDD,0XA7,0XD5,0X66,0XD5,0X87,0XD5,0X67,0XCD,0X27,0XCD,0X4A,

115840XC5,0X6E,0XFF,0XDB,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

115850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

115970XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XF7,0X37,0XBD,0X4B,

115980XD5,0XE9,0XE6,0X69,0XE6,0X07,0XF6,0X89,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

115990XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

116000XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XF6,0X67,0XF6,0X47,

116010XF6,0X48,0XF6,0X69,0XEE,0X28,0XF6,0X69,0XFE,0XCB,0XF6,0X69,0XE5,0XE7,0XDD,0XC6,

116020XDD,0XE7,0XD5,0X66,0XD5,0X87,0XD5,0X88,0XCD,0X49,0XBD,0X0A,0XF7,0X36,0XFF,0XFC,

116030XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

116040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

116160XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBC,0XE6,0X93,0XB5,0X09,0XE6,0X6A,0XEE,0X68,

116170XEE,0X68,0XEE,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

116180XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

116190XF6,0X48,0XF6,0X47,0XF6,0X68,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X48,

116200XF6,0X69,0XFE,0XAA,0XFE,0XCB,0XEE,0X49,0XE5,0XE7,0XE5,0XE7,0XDD,0XC6,0XDD,0XC7,

116210XD5,0X67,0XD5,0XA9,0XC5,0X29,0XD6,0X0F,0XFF,0XB9,0XFF,0XDC,0XFF,0XFF,0XFF,0XFF,

116220XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDE,

116350XFF,0XDE,0XFF,0XBA,0XC5,0X6D,0XC5,0X89,0XE6,0X69,0XEE,0X68,0XEE,0X48,0XEE,0X08,

116360XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

116370XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

116380XF6,0X48,0XF6,0X68,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0XA9,0XFE,0XCA,

116390XFE,0X8A,0XEE,0X49,0XEE,0X07,0XE5,0XE7,0XDD,0XC5,0XDE,0X07,0XD5,0XA8,0XCD,0X8A,

116400XC5,0X4C,0XFF,0X56,0XFF,0XBA,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116410XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDE,0XFF,0XDD,0XF7,0X37,

116540XAC,0XC9,0XDE,0X2A,0XEE,0X68,0XF6,0X67,0XEE,0X07,0XF6,0X48,0XF6,0X48,0XF6,0X47,

116550XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

116560XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X68,

116570XEE,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XFE,0XC9,0XFE,0XCA,0XF6,0X49,0XF6,0X49,

116580XEE,0X28,0XDE,0X06,0XE6,0X26,0XDD,0XE6,0XDD,0XCA,0XCD,0X6B,0XDE,0X31,0XFF,0X78,

116590XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116720XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDD,0XFF,0XBB,0XC5,0X8F,0XBD,0X6A,0XE6,0X8B,

116730XE6,0X47,0XEE,0X46,0XF6,0X68,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

116740XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

116750XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X67,

116760XF6,0X67,0XFE,0X87,0XFE,0XC9,0XFE,0XA9,0XF6,0X48,0XF6,0X49,0XEE,0X48,0XE6,0X26,

116770XE6,0X47,0XDD,0XE6,0XE5,0XEB,0XDD,0XCD,0XF7,0X16,0XFF,0XBB,0XFF,0XFC,0XFF,0XFE,

116780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116910XFF,0XDF,0XFF,0XDD,0XF7,0X17,0XA4,0X89,0XD5,0XEA,0XE6,0X69,0XEE,0X67,0XEE,0X46,

116920XF6,0X47,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

116930XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

116940XF6,0X48,0XF6,0X48,0XF6,0X48,0XEE,0X48,0XF6,0X68,0XF6,0X87,0XFE,0X88,0XFE,0XC8,

116950XFE,0XC8,0XF6,0X88,0XF6,0X68,0XEE,0X48,0XEE,0X68,0XEE,0X47,0XE6,0X67,0XDE,0X08,

116960XDE,0X0C,0XEE,0XB2,0XFF,0X99,0XFF,0XDC,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

116970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

116990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0X3A,

117100XD5,0XD1,0XC5,0X4A,0XE6,0X4A,0XEE,0X89,0XE6,0X26,0XF6,0XA7,0XED,0XE5,0XFE,0X68,

117110XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

117120XF6,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,

117130XF6,0X47,0XEE,0X47,0XF6,0X68,0XF6,0XA8,0XFE,0XA9,0XFE,0XA9,0XFE,0XA8,0XFE,0X88,

117140XF6,0X68,0XEE,0X28,0XEE,0X48,0XF6,0X89,0XE6,0X49,0XE6,0X4B,0XDE,0X2E,0XFF,0X56,

117150XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117160XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0X9D,0XFF,0X59,0XA4,0X29,0XE6,0X2C,

117290XEE,0X49,0XEE,0X67,0XEE,0X66,0XEE,0X46,0XFE,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,

117300XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

117310XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

117320XF6,0X68,0XF6,0X88,0XFE,0XC9,0XFE,0XA9,0XFE,0XA8,0XF6,0X88,0XFE,0X68,0XF6,0X48,

117330XF6,0X69,0XEE,0X6A,0XE6,0X4A,0XDE,0X4D,0XEE,0XF3,0XFF,0XB9,0XFF,0XFD,0XFF,0XFF,

117340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFE,

117470XFF,0XFF,0XFF,0XDD,0XFF,0X9A,0XD5,0XD0,0XC5,0X4A,0XEE,0X4B,0XEE,0X48,0XEE,0X26,

117480XEE,0X47,0XF6,0X67,0XEE,0X27,0XF6,0X68,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

117490XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

117500XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X88,0XFE,0XA9,

117510XFE,0XA9,0XFE,0XA9,0XFE,0X88,0XF6,0X68,0XFE,0X69,0XF6,0X6A,0XF6,0X6A,0XEE,0X4B,

117520XDE,0X2C,0XE6,0XB0,0XFF,0X97,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,

117660XEF,0X16,0XB4,0XCA,0XE6,0X0B,0XEE,0X29,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X68,

117670XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

117680XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

117690XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X67,0XFE,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

117700XF6,0X88,0XF6,0X88,0XF6,0X69,0XFE,0X8A,0XEE,0X4A,0XEE,0X4C,0XE6,0X6E,0XF7,0X34,

117710XFF,0XD9,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XBA,0XC5,0X8D,0XCD,0XAA,

117850XE6,0X08,0XF6,0X48,0XF6,0X26,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XEE,0X47,

117860XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

117870XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,

117880XF6,0X67,0XFE,0X88,0XFE,0XC9,0XFE,0XC9,0XFE,0XA9,0XF6,0X88,0XF6,0X89,0XFE,0X89,

117890XFE,0X8A,0XF6,0X6A,0XEE,0X6B,0XE6,0X6D,0XF7,0X12,0XFF,0XD8,0XFF,0XDB,0XFF,0XFE,

117900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

117990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118030XFF,0XDF,0XFF,0XDD,0XFF,0XDC,0XDE,0X94,0XB5,0X2A,0XE6,0X4B,0XEE,0X48,0XF6,0X26,

118040XF6,0X26,0XF6,0X06,0XF6,0X27,0XF6,0X47,0XEE,0X26,0XF6,0X66,0XF6,0X47,0XF6,0X47,

118050XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

118060XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X68,0XFE,0XA8,

118070XFE,0XC9,0XFE,0XC9,0XFE,0XA9,0XFE,0X89,0XFE,0X8A,0XF6,0X8A,0XFE,0XAB,0XEE,0X6A,

118080XEE,0XAD,0XEE,0XB0,0XFF,0XB7,0XFF,0XFB,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,

118220XF7,0X78,0XC5,0XAE,0XD5,0XCB,0XE6,0X29,0XEE,0X26,0XF6,0X46,0XFE,0X47,0XFE,0X48,

118230XF6,0X28,0XF6,0X27,0XF6,0X87,0XEE,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,

118240XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,

118250XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X88,0XFE,0XA8,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

118260XFE,0XA9,0XFE,0X8A,0XFE,0X8B,0XF6,0X6B,0XF6,0X8B,0XEE,0X6B,0XF6,0XEF,0XF7,0X54,

118270XFF,0XFA,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

118280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XDB,0XDE,0X72,0XBD,0X4B,

118410XDE,0X2A,0XEE,0X48,0XF6,0X67,0XF6,0X26,0XF6,0X07,0XF6,0X28,0XF6,0X28,0XF6,0X48,

118420XF6,0X66,0XEE,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

118430XF6,0X47,0XF6,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

118440XF6,0X87,0XFE,0XA8,0XFE,0XC9,0XFE,0XA9,0XFE,0X89,0XFE,0X8A,0XFE,0X8A,0XFE,0XAB,

118450XFE,0X8B,0XF6,0X6B,0XEE,0X6C,0XEE,0X8E,0XF7,0X12,0XFF,0XD8,0XFF,0XFC,0XFF,0XDE,

118460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118580XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118590XFF,0XDE,0XFF,0XFD,0XFF,0XDB,0XEF,0X16,0XBD,0X4C,0XD5,0XCA,0XE6,0X49,0XF6,0X67,

118600XEE,0X45,0XF6,0X46,0XF6,0X48,0XF6,0X28,0XF6,0X29,0XF6,0X28,0XEE,0X47,0XF6,0X66,

118610XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X47,

118620XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XFE,0X88,0XFE,0XC9,

118630XFE,0XA9,0XFE,0X89,0XFE,0X8A,0XFE,0X6A,0XFE,0X6A,0XFE,0X6A,0XFE,0X8B,0XEE,0X4C,

118640XE6,0X4E,0XFF,0X34,0XFF,0XB8,0XFF,0XDB,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118760XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118770XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,

118780XFF,0X98,0XC5,0X8E,0XC5,0X6A,0XE6,0X2A,0XEE,0X48,0XF6,0X87,0XF6,0X66,0XF6,0X46,

118790XF6,0X48,0XF6,0X29,0XF6,0X29,0XF6,0X48,0XF6,0X47,0XF6,0X66,0XF6,0X67,0XF6,0X67,

118800XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X47,

118810XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XFE,0XA8,0XFE,0XC9,0XFE,0XE9,0XFE,0XA9,

118820XFE,0X6A,0XFE,0X8B,0XFE,0X8A,0XFE,0XAB,0XF6,0X8C,0XF6,0X8E,0XF6,0XF3,0XFF,0X98,

118830XFF,0XDB,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

118950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

118960XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XBB,0XDE,0X52,0XAC,0XA9,

118970XE6,0X0B,0XEE,0X49,0XF6,0X67,0XEE,0X25,0XF6,0X66,0XF6,0X66,0XF6,0X47,0XF6,0X48,

118980XF6,0X48,0XF6,0X48,0XF6,0X67,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

118990XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,

119000XF6,0X88,0XFE,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0XC9,0XFE,0XC9,0XFE,0X89,0XFE,0XCA,

119010XFE,0XCA,0XF6,0XAB,0XEE,0X8D,0XF6,0XD1,0XFF,0X97,0XFF,0XDB,0XFF,0XFD,0XFF,0XFF,

119020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,

119150XFF,0XBD,0XFF,0XFD,0XFF,0XBB,0XE6,0XD5,0XB4,0XEB,0XDD,0XCC,0XEE,0X6B,0XEE,0X28,

119160XFE,0X67,0XE5,0XE4,0XFE,0X66,0XF6,0X67,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X68,

119170XF6,0X66,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X67,

119180XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XFE,0X68,0XFE,0X89,0XFE,0XAA,

119190XFE,0XAA,0XFE,0XAA,0XFE,0XCA,0XFE,0XC9,0XFE,0XC9,0XF6,0XA8,0XF6,0XA9,0XEE,0X8B,

119200XF6,0XF0,0XFF,0X55,0XFF,0XDA,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119330XFF,0XFF,0XF7,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDC,0XFF,0XFB,

119340XEE,0XF6,0XBD,0X2D,0XCD,0XAC,0XF6,0X8C,0XEE,0X28,0XF6,0X47,0XF6,0X46,0XF6,0X66,

119350XF6,0X66,0XF6,0X67,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X67,0XF6,0X66,0XF6,0X66,

119360XF6,0X66,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X66,0XF6,0X66,0XF6,0X67,0XF6,0X67,

119370XF6,0X67,0XF6,0X68,0XFE,0X68,0XFE,0X89,0XFE,0XAA,0XFE,0XAB,0XFE,0XAB,0XFE,0XAB,

119380XFE,0XAA,0XFE,0XC9,0XFE,0XE9,0XEE,0XC9,0XEE,0XAB,0XEE,0XEF,0XFF,0X75,0XFF,0XB9,

119390XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119510XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

119520XF7,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDD,0XFF,0XFC,0XEE,0XF6,0XD5,0XEF,0XBD,0X29,

119530XF6,0X8C,0XEE,0X49,0XF6,0X48,0XF6,0X46,0XEE,0X05,0XFE,0X87,0XF6,0X46,0XF6,0X47,

119540XFE,0X48,0XFE,0X48,0XF6,0X48,0XF6,0X67,0XF6,0X66,0XF6,0X66,0XF6,0X47,0XF6,0X47,

119550XF6,0X67,0XF6,0X67,0XF6,0X46,0XF6,0X66,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X68,

119560XFE,0X89,0XFE,0X8A,0XFE,0XAA,0XFE,0X8B,0XFE,0X8B,0XFE,0X8B,0XFE,0X8A,0XF6,0XAA,

119570XF6,0XC9,0XEE,0XEB,0XEE,0XEE,0XFF,0X74,0XFF,0XDA,0XFF,0XDC,0XFF,0XFE,0XFF,0XFE,

119580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

119700XFF,0XBF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFE,0XF7,0XFD,0XFF,0XFE,0XF7,0XFF,0XF7,0XDF,

119710XFF,0XBE,0XFF,0XDD,0XF7,0X58,0XC5,0XAF,0XC5,0X69,0XEE,0XAB,0XE6,0X07,0XF6,0X67,

119720XFE,0X87,0XF6,0X25,0XF6,0X46,0XF6,0X46,0XF6,0X47,0XFE,0X48,0XFE,0X48,0XFE,0X28,

119730XFE,0X48,0XF6,0X48,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,

119740XF6,0X46,0XF6,0X66,0XF6,0X66,0XF6,0X67,0XF6,0X87,0XFE,0X88,0XFE,0XA9,0XFE,0XAA,

119750XFE,0XAB,0XFE,0X8B,0XFE,0X8B,0XFE,0X8B,0XFE,0XAB,0XF6,0XAB,0XEE,0XAB,0XEE,0XEE,

119760XF7,0X34,0XFF,0XDA,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

119770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBF,0XFF,0XBF,

119890XFF,0XDF,0XFF,0XFE,0XF7,0XFD,0XF7,0XFD,0XFF,0XFF,0XF7,0XDE,0XFF,0XDD,0XFF,0X9A,

119900XD6,0X31,0XBD,0X2A,0XDE,0X08,0XF6,0X88,0XF6,0X67,0XF6,0X66,0XF6,0X46,0XF6,0X46,

119910XFE,0X67,0XF6,0X47,0XF6,0X47,0XFE,0X48,0XFE,0X28,0XFE,0X28,0XF6,0X28,0XF6,0X48,

119920XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

119930XF6,0X67,0XF6,0X67,0XFE,0XA8,0XFE,0XA9,0XFE,0XCA,0XFE,0XCB,0XFE,0XAB,0XFE,0X8B,

119940XFE,0X8C,0XFE,0X8C,0XF6,0XAC,0XF6,0XAD,0XF6,0XEF,0XF7,0X54,0XFF,0XFB,0XFF,0XFD,

119950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

119990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDE,

120080XFF,0XFD,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XF7,0X79,0XD6,0X31,0XBD,0X4A,0XDE,0X29,

120090XEE,0X67,0XF6,0X66,0XF6,0X66,0XF6,0X46,0XF6,0X46,0XFE,0X47,0XFE,0X47,0XF6,0X47,

120100XF6,0X47,0XF6,0X47,0XF6,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X67,

120110XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X88,0XFE,0XA8,

120120XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAB,0XFE,0X8B,0XFE,0XAC,0XFE,0XAC,0XF6,0X8C,

120130XEE,0X8E,0XEE,0XF1,0XFF,0X76,0XFF,0XDA,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFD,

120270XFF,0XDB,0XFF,0X78,0XDE,0X30,0XC5,0X6A,0XDE,0X09,0XEE,0X68,0XF6,0X66,0XF6,0X66,

120280XFE,0X66,0XF6,0X46,0XF6,0X47,0XF6,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,

120290XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X67,0XF6,0X47,

120300XF6,0X47,0XF6,0X68,0XF6,0X68,0XF6,0X88,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XCA,

120310XFE,0XCB,0XFE,0XAB,0XFE,0XAC,0XF6,0XAC,0XF6,0X8C,0XEE,0X8E,0XF7,0X12,0XF7,0X76,

120320XFF,0XDA,0XFF,0XDD,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120450XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XBE,0XFF,0XBE,0XFF,0XBC,0XFF,0X78,0XD6,0X2F,

120460XC5,0X88,0XE6,0X29,0XF6,0X88,0XEE,0X46,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

120470XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X48,

120480XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X67,

120490XF6,0X88,0XFE,0X88,0XFE,0X89,0XFE,0XAA,0XFE,0XAA,0XFE,0XAB,0XFE,0XAC,0XF6,0XAC,

120500XF6,0XAC,0XEE,0X8D,0XEE,0XAE,0XF7,0X11,0XFF,0X96,0XFF,0XDA,0XFF,0XFD,0XFF,0XFE,

120510XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

120520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120640XFF,0XDE,0XFF,0XBE,0XFF,0XBD,0XF7,0X38,0XD5,0XEF,0XC5,0X69,0XE6,0X48,0XEE,0X66,

120650XEE,0X46,0XF6,0X66,0XF6,0X47,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

120660XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,

120670XF6,0X48,0XF6,0X48,0XFE,0X48,0XFE,0X68,0XFE,0X88,0XFE,0XA8,0XFE,0XA9,0XFE,0XA9,

120680XFE,0XAA,0XFE,0X8A,0XFE,0XAB,0XFE,0XAC,0XFE,0XAC,0XF6,0X8C,0XEE,0X8D,0XEE,0XAF,

120690XF7,0X32,0XFF,0XB6,0XFF,0XFA,0XFF,0XDC,0XFF,0XDD,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

120700XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFC,

120830XF7,0X17,0XCD,0XCF,0XCD,0X6A,0XE6,0X09,0XF6,0X88,0XEE,0X24,0XF6,0X45,0XFE,0X46,

120840XF6,0X47,0XF6,0X48,0XFE,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

120850XF6,0X87,0XF6,0X86,0XF6,0X86,0XF6,0X86,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,

120860XFE,0X68,0XFE,0X88,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XAB,

120870XFE,0XCC,0XFE,0X8B,0XF6,0X8C,0XF6,0XAE,0XEE,0XD0,0XF7,0X33,0XFF,0XB8,0XFF,0XFB,

120880XFF,0XFC,0XFF,0XDD,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120890XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

120990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121010XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XFD,0XFF,0XDA,0XE6,0XD4,0XC5,0XAE,0XCD,0X6A,

121020XEE,0X4B,0XF6,0X89,0XEE,0X26,0XFE,0X86,0XFE,0X87,0XF6,0X26,0XF6,0X47,0XFE,0X48,

121030XFE,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X87,0XF6,0X67,

121040XF6,0X86,0XF6,0X66,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XFE,0X88,0XFE,0X89,

121050XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAB,0XFE,0XAB,0XFE,0XAC,0XEE,0X6C,

121060XEE,0XAE,0XF7,0X12,0XFF,0X75,0XFF,0XD9,0XFF,0XFC,0XFF,0XFD,0XFF,0XDD,0XFF,0XFF,

121070XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

121080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,

121200XFF,0XFB,0XFF,0XD8,0XE6,0XD2,0XBD,0X8B,0XCD,0XA9,0XF6,0XAB,0XF6,0X89,0XEE,0X47,

121210XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X47,0XFE,0X47,0XFE,0X67,0XFE,0X67,0XFE,0X67,

121220XFE,0X67,0XFE,0X67,0XFE,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X66,0XF6,0X66,

121230XF6,0X66,0XF6,0X67,0XFE,0X87,0XFE,0X67,0XFE,0XA9,0XFE,0XA9,0XFE,0XC9,0XFE,0XAA,

121240XFE,0XAA,0XFE,0XCA,0XFE,0XCB,0XFE,0XCC,0XF6,0XAD,0XF6,0XCF,0XF7,0X13,0XFF,0X97,

121250XFF,0XDA,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121380XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFD,0XFF,0XDB,0XF7,0X76,0XD6,0X4F,

121390XCD,0XCA,0XDE,0X4A,0XEE,0XA9,0XEE,0X67,0XF6,0X67,0XFE,0X88,0XF6,0X47,0XFE,0X68,

121400XF6,0X47,0XFE,0X47,0XFE,0X67,0XFE,0X66,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

121410XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X87,

121420XFE,0X88,0XFE,0XA8,0XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAB,

121430XF6,0X8C,0XEE,0X8D,0XEE,0XD0,0XFF,0X54,0XFF,0XB8,0XFF,0XDB,0XFF,0XFE,0XFF,0XFE,

121440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121550XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

121560XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,

121570XFF,0XFD,0XFF,0XDB,0XFF,0X79,0XEE,0XF4,0XD6,0X0D,0XD5,0XC9,0XDE,0X08,0XEE,0X88,

121580XEE,0X66,0XF6,0X66,0XF6,0X86,0XFE,0X87,0XF6,0X67,0XFE,0X67,0XF6,0X67,0XFE,0X67,

121590XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X66,0XF6,0X66,

121600XF6,0X66,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X69,0XFE,0X89,0XFE,0XA9,

121610XFE,0XC9,0XFE,0XC9,0XFE,0XAA,0XF6,0XAB,0XF6,0XAC,0XEE,0X8D,0XEE,0X8F,0XF6,0XD2,

121620XFF,0X56,0XFF,0X99,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

121750XF7,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XFB,0XFF,0X99,0XF7,0X35,

121760XDE,0X50,0XCD,0X8B,0XCD,0X89,0XEE,0X69,0XFE,0XA9,0XEE,0X46,0XF6,0X86,0XFE,0X86,

121770XFE,0X86,0XF6,0X66,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

121780XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X66,0XF6,0X66,0XFE,0X86,0XFE,0X87,

121790XFE,0X67,0XFE,0X68,0XFE,0X69,0XFE,0X8A,0XFE,0X8A,0XFE,0X8A,0XFE,0XAA,0XFE,0XCA,

121800XF6,0XAB,0XF6,0XAD,0XEE,0XAF,0XF6,0XD1,0XFF,0X35,0XFF,0X98,0XFF,0XBA,0XFF,0XDC,

121810XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

121920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

121930XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

121940XFF,0XFE,0XFF,0XDC,0XFF,0XDA,0XFF,0X77,0XE6,0X91,0XD5,0XEC,0XD5,0XCA,0XE6,0X0A,

121950XF6,0X4B,0XF6,0X49,0XF6,0X48,0XFE,0X47,0XFE,0X46,0XFE,0X66,0XFE,0X67,0XFE,0X67,

121960XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X87,0XF6,0X87,0XF6,0X88,0XF6,0X68,

121970XF6,0X68,0XF6,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X89,

121980XFE,0X89,0XFE,0XA9,0XFE,0X89,0XFE,0XAA,0XF6,0X8A,0XF6,0X8C,0XEE,0XAE,0XF6,0XF0,

121990XF7,0X34,0XFF,0X98,0XFF,0XBB,0XFF,0XFD,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

122000XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

122120XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDD,0XFF,0XBC,0XFF,0X9A,0XFF,0XB8,

122130XEE,0XD3,0XD5,0XEE,0XDE,0X0B,0XE6,0X29,0XF6,0X6A,0XF6,0X49,0XF6,0X49,0XFE,0X29,

122140XFE,0X69,0XFE,0X48,0XFE,0X46,0XFE,0X47,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X68,

122150XFE,0X68,0XF6,0X68,0XF6,0X87,0XF6,0X87,0XF6,0X88,0XF6,0X88,0XF6,0X68,0XF6,0X68,

122160XFE,0X88,0XFE,0XA8,0XFE,0X88,0XFE,0XA9,0XFE,0XC9,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,

122170XFE,0XAA,0XFE,0XAB,0XEE,0X8D,0XF6,0XD0,0XF7,0X12,0XFF,0X75,0XFF,0XD9,0XFF,0XFC,

122180XFF,0XFD,0XFF,0XDE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

122190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDE,

122310XFF,0XFE,0XFF,0XBB,0XFF,0XDA,0XFF,0X97,0XF7,0X14,0XD5,0XED,0XD5,0XCB,0XDE,0X0A,

122320XEE,0X49,0XF6,0X67,0XFE,0X88,0XFE,0X88,0XFE,0X8A,0XFE,0X49,0XFE,0X49,0XFE,0X48,

122330XFE,0X67,0XFE,0X67,0XFE,0X48,0XFE,0X48,0XFE,0X48,0XFE,0X68,0XFE,0X68,0XFE,0X88,

122340XF6,0X68,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XFE,0XA8,0XFE,0XA9,

122350XFE,0XCA,0XFE,0XAA,0XF6,0XAA,0XF6,0XAB,0XFE,0XCC,0XF6,0XCD,0XEE,0X8C,0XEE,0X6E,

122360XFF,0X34,0XFF,0X77,0XFF,0XB8,0XFF,0XDA,0XFF,0XFB,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

122370XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

122380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122480XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

122490XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XDB,0XFF,0XBA,0XFF,0X98,

122500XEE,0XD3,0XDE,0X2E,0XD5,0XAA,0XDE,0X0A,0XEE,0X4A,0XF6,0X89,0XFE,0X88,0XFE,0X87,

122510XF6,0X66,0XF6,0X46,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,

122520XFE,0X68,0XFE,0X68,0XFE,0X48,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XF6,0X68,0XF6,0X68,

122530XF6,0X68,0XF6,0X88,0XFE,0X88,0XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XCB,0XF6,0XCB,

122540XF6,0XAC,0XEE,0X8C,0XE6,0X6D,0XE6,0X8F,0XF7,0X12,0XFF,0X96,0XFF,0XBA,0XFF,0XDC,

122550XFF,0XFC,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122560XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122670XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,

122680XFF,0XFA,0XFF,0XD8,0XFF,0X97,0XF7,0X75,0XE6,0XB1,0XD6,0X2E,0XD6,0X2B,0XE6,0X2A,

122690XEE,0X89,0XEE,0X48,0XF6,0X47,0XFE,0X47,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X87,

122700XF6,0XA6,0XF6,0X86,0XF6,0X86,0XFE,0XA7,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X87,

122710XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,

122720XFE,0X88,0XFE,0XA9,0XFE,0XAA,0XFE,0XAB,0XF6,0X8B,0XEE,0X8C,0XEE,0XAE,0XF7,0X12,

122730XFF,0X75,0XFF,0XB8,0XFF,0XBA,0XFF,0XDC,0XFF,0XFD,0XFF,0XFE,0XFF,0XDE,0XFF,0XFE,

122740XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

122860XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XDB,0XFF,0XD9,0XFF,0XB7,0XF7,0X75,0XEF,0X12,

122870XE6,0X8F,0XDE,0X2D,0XDE,0X2C,0XDE,0X2A,0XE6,0X29,0XEE,0X68,0XF6,0X87,0XFE,0X87,

122880XFE,0X87,0XFE,0X87,0XFE,0X47,0XFE,0X68,0XF6,0X48,0XF6,0X67,0XF6,0X86,0XF6,0XC6,

122890XF6,0XA6,0XF6,0XA7,0XFE,0XA8,0XFE,0X88,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X87,

122900XF6,0X87,0XFE,0XA8,0XFE,0X89,0XFE,0X89,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XAB,

122910XF6,0X8C,0XF6,0XAE,0XF6,0XD0,0XF7,0X12,0XFF,0X75,0XFF,0XB8,0XFF,0XFA,0XFF,0XDC,

122920XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122930XFF,0XDE,0XFF,0XFF,0XF7,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

122990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123040XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XFF,0XDE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFA,0XFF,0XD8,

123050XFF,0X96,0XFF,0X54,0XF6,0XF2,0XEE,0XD0,0XE6,0X8E,0XE6,0X4C,0XE6,0X2A,0XE6,0X29,

123060XEE,0X49,0XF6,0X69,0XF6,0X88,0XF6,0X87,0XFE,0X66,0XFE,0X86,0XFE,0X86,0XFE,0X66,

123070XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0XA8,0XFE,0X88,0XF6,0X88,

123080XFE,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0XA8,0XF6,0XA8,0XF6,0XA9,

123090XF6,0XCA,0XF6,0XAB,0XF6,0X8B,0XEE,0X8C,0XEE,0XAE,0XF6,0XD0,0XFF,0X13,0XFF,0X55,

123100XFF,0X97,0XFF,0XBA,0XFF,0XDB,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

123110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

123230XFF,0XFE,0XFF,0XFC,0XFF,0XB9,0XFF,0X76,0XF7,0X53,0XF7,0X11,0XEE,0XAF,0XE6,0X6D,

123240XE6,0X2B,0XE6,0X0A,0XEE,0X2A,0XEE,0X4A,0XF6,0X69,0XFE,0X68,0XF6,0X68,0XFE,0X67,

123250XFE,0X67,0XFE,0X67,0XFE,0X86,0XFE,0X86,0XFE,0X87,0XFE,0X87,0XFE,0X68,0XF6,0X68,

123260XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XF6,0X69,0XF6,0X69,

123270XF6,0X89,0XF6,0XAA,0XF6,0XAA,0XF6,0XAA,0XF6,0XCB,0XEE,0XCB,0XEE,0XAD,0XEE,0XCF,

123280XF7,0X11,0XFF,0X33,0XFF,0X55,0XFF,0X77,0XFF,0XB9,0XFF,0XDB,0XFF,0XBC,0XFF,0XDD,

123290XFF,0XDE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XDC,0XF7,0X78,

123420XE6,0XF2,0XDE,0X8E,0XE6,0X8C,0XDE,0X4A,0XE6,0X49,0XEE,0X49,0XEE,0X69,0XF6,0X69,

123430XF6,0X69,0XF6,0X68,0XF6,0X48,0XFE,0X47,0XFE,0X68,0XFE,0X68,0XFE,0X87,0XFE,0X88,

123440XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X87,0XFE,0XA7,0XF6,0XA7,0XFE,0XA7,0XFE,0XA8,

123450XFE,0XA8,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0XAA,0XFE,0XAB,0XF6,0XAC,0XF6,0XAD,

123460XEE,0XAE,0XEE,0XCF,0XF7,0X11,0XF7,0X53,0XF7,0X35,0XF7,0X57,0XFF,0X99,0XFF,0XBA,

123470XFF,0XDB,0XFF,0XDC,0XFF,0XDD,0XFF,0XBE,0XFF,0XBE,0XFF,0XBE,0XFF,0XDF,0XFF,0XDF,

123480XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123490XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123600XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDD,0XFF,0X99,0XE6,0XD3,0XD6,0X4D,0XDE,0X4A,

123610XEE,0X89,0XEE,0X88,0XF6,0X68,0XF6,0X67,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X67,

123620XFE,0X67,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,

123630XFE,0X68,0XF6,0X88,0XF6,0X87,0XEE,0X87,0XEE,0X87,0XEE,0X88,0XF6,0X88,0XFE,0X89,

123640XFE,0X8A,0XF6,0X8B,0XFE,0XAD,0XF6,0XCE,0XF6,0XD0,0XF6,0XF2,0XF7,0X14,0XF7,0X35,

123650XF7,0X56,0XF7,0X78,0XFF,0XBB,0XFF,0XBC,0XF7,0X9C,0XF7,0X7C,0XF7,0X7D,0XF7,0X7D,

123660XF7,0X9E,0XF7,0X7E,0XF7,0X9F,0XF7,0X9F,0XF7,0X7E,0XEF,0X7E,0XF7,0X9E,0XF7,0X9E,

123670XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

123680XF7,0XBE,0XFF,0XBE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,

123690XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

123700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

123750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123790XFF,0XFF,0XFF,0XFD,0XFF,0XD9,0XEE,0XD2,0XDE,0X4B,0XEE,0X89,0XEE,0X87,0XF6,0X87,

123800XFE,0XA8,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,

123810XFE,0X87,0XFE,0X87,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X88,0XFE,0X89,0XFE,0XAA,

123820XF6,0XA9,0XF6,0XAA,0XEE,0XAA,0XF6,0XCB,0XF6,0XCC,0XF6,0XED,0XE6,0X8E,0XDE,0X2E,

123830XC5,0XAD,0XBD,0X8E,0XB5,0X4F,0XBD,0X71,0XC5,0XB3,0XCD,0XF5,0XCE,0X16,0XCE,0X37,

123840XCE,0X58,0XCE,0X79,0XD6,0X99,0XD6,0XBA,0XD6,0XDB,0XDE,0XDB,0XDE,0XDB,0XD6,0XBB,

123850XD6,0XBB,0XDE,0XFC,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

123860XE7,0X5C,0XE7,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X7D,

123870XF7,0X7D,0XF7,0X7E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

123880XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

123890XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

123940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

123970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XF7,0XDF,0XF7,0XBF,0XF7,0X9C,

123980XFF,0XB9,0XEE,0XD1,0XE6,0X6C,0XFE,0XEB,0XF6,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X68,

123990XFE,0X69,0XFE,0X88,0XFE,0X68,0XF6,0X68,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X89,

124000XF6,0X8A,0XF6,0XAA,0XF6,0XAB,0XF6,0XAB,0XF6,0X8B,0XEE,0X6B,0XEE,0X6C,0XE6,0X6C,

124010XE6,0X4C,0XD5,0XEB,0XBD,0X2A,0X94,0X47,0X6B,0X03,0X4A,0X00,0X31,0X40,0X31,0X81,

124020X39,0XC3,0X4A,0X26,0X52,0X89,0X62,0XCB,0X6B,0X0C,0X6B,0X4D,0X7B,0XCF,0X84,0X0F,

124030X84,0X51,0X8C,0X92,0X94,0XB3,0X9C,0XF4,0XA5,0X55,0XAD,0X76,0XB5,0XB7,0XBD,0XD8,

124040XBD,0XF8,0XBD,0XF8,0XC6,0X38,0XCE,0X59,0XD6,0X9A,0XD6,0XBA,0XD6,0XBA,0XD6,0XBA,

124050XD6,0XDB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,

124060XEF,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

124070XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

124080XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

124090XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124120XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

124160XFF,0XDE,0XF7,0XDE,0XF7,0XBF,0XF7,0XBF,0XF7,0XBF,0XEF,0X5C,0XF7,0X58,0XE6,0XB2,

124170XE6,0X4D,0XF6,0XAC,0XEE,0X4A,0XF6,0X4A,0XF6,0X4B,0XF6,0X6B,0XF6,0X6B,0XF6,0X8B,

124180XF6,0X8B,0XF6,0XAB,0XF6,0XAB,0XF6,0XCC,0XF6,0XAC,0XF6,0XAC,0XEE,0XAD,0XE6,0X6D,

124190XE6,0X4D,0XDE,0X0D,0XCD,0XAB,0XC5,0X4B,0XAC,0X89,0X93,0XE7,0X72,0XE4,0X52,0X21,

124200X41,0XA0,0X39,0X60,0X31,0X60,0X31,0X61,0X39,0X83,0X39,0XA4,0X39,0XA5,0X39,0XA5,

124210X31,0X86,0X31,0X86,0X39,0XC7,0X39,0XE7,0X42,0X28,0X4A,0X48,0X52,0XA9,0X5A,0XEB,

124220X63,0X0C,0X63,0X4D,0X6B,0X8E,0X73,0XAF,0X7B,0XF0,0X84,0X31,0X8C,0X72,0X94,0XB3,

124230X9C,0XD3,0XA5,0X14,0XA5,0X35,0XAD,0X55,0XB5,0XD6,0XBD,0XD7,0XBD,0XF7,0XC6,0X18,

124240XC6,0X38,0XCE,0X59,0XCE,0X79,0XD6,0X9A,0XD6,0X9A,0XD6,0XBA,0XDE,0XDB,0XDE,0XDB,

124250XDE,0XFB,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,

124260XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

124270XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,

124280XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

124290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124310XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

124340XFF,0XDF,0XFF,0XDF,0XFF,0XBF,0XFF,0XBF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

124350XEF,0X9E,0XEF,0X9E,0XEF,0X5E,0XDE,0XDA,0XDE,0XB7,0XD6,0X32,0XD6,0X0E,0XE6,0X4D,

124360XE6,0X0C,0XE6,0X0D,0XE6,0X0C,0XDD,0XEC,0XD5,0XCB,0XD5,0XAB,0XD5,0XAB,0XCD,0XAB,

124370XC5,0X6A,0XBD,0X4A,0XB4,0XE8,0XAC,0XA8,0X9C,0X47,0X8B,0XA6,0X7B,0X24,0X6A,0XC3,

124380X5A,0X21,0X49,0XC0,0X39,0X60,0X39,0X40,0X39,0X40,0X39,0X61,0X41,0XA2,0X41,0XA3,

124390X41,0XC4,0X41,0XE5,0X41,0XE6,0X41,0XE6,0X42,0X07,0X4A,0X28,0X4A,0X48,0X4A,0X49,

124400X4A,0X48,0X4A,0X48,0X4A,0X48,0X4A,0X48,0X52,0X69,0X52,0XAA,0X5A,0XCA,0X5A,0XEB,

124410X63,0X0C,0X63,0X2C,0X6B,0X4D,0X73,0X8E,0X73,0XCF,0X7B,0XF0,0X84,0X31,0X8C,0X72,

124420X94,0X92,0X9C,0XD3,0X9C,0XF4,0XA5,0X14,0XA5,0X34,0XAD,0X75,0XB5,0X96,0XB5,0XB6,

124430XBD,0XD7,0XC5,0XF8,0XC6,0X18,0XCE,0X38,0XCE,0X59,0XD6,0X79,0XD6,0X9A,0XD6,0XBA,

124440XD6,0XBA,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

124450XE7,0X3C,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,

124460XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,

124470XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

124480XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,

124500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124520XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

124530XF7,0X9E,0XF7,0X9E,0XFF,0XDF,0XFF,0XDF,0XF7,0XDE,0XF7,0XBE,0XF7,0XBE,0XEF,0X9E,

124540XE7,0X3D,0XE6,0XFB,0XDE,0X98,0XD6,0X54,0XCD,0XF0,0XC5,0X6D,0XB4,0XEC,0XAC,0XAB,

124550XA4,0X69,0X9C,0X29,0X93,0XC7,0X83,0X66,0X7B,0X25,0X73,0X05,0X6A,0XC4,0X5A,0X83,

124560X52,0X22,0X49,0XE2,0X41,0XA1,0X39,0X81,0X39,0X82,0X39,0X62,0X41,0X82,0X41,0XA3,

124570X41,0XC3,0X41,0XE3,0X41,0XE4,0X4A,0X05,0X4A,0X26,0X52,0X26,0X52,0X47,0X52,0X68,

124580X52,0X68,0X5A,0X89,0X5A,0XAA,0X5A,0XCA,0X5A,0XCA,0X5A,0XEB,0X63,0X0B,0X63,0X2C,

124590X6B,0X2C,0X6B,0X0B,0X6B,0X0B,0X63,0X0B,0X63,0X0B,0X63,0X2B,0X6B,0X4C,0X73,0X8D,

124600X7B,0XCE,0X7B,0XCF,0X7B,0XEF,0X84,0X10,0X84,0X31,0X8C,0X51,0X8C,0X72,0X94,0XB2,

124610X9C,0XD3,0X9C,0XF3,0XA5,0X14,0XA5,0X34,0XAD,0X55,0XAD,0X75,0XB5,0X96,0XB5,0XB6,

124620XBD,0XD7,0XBD,0XF7,0XC6,0X18,0XC6,0X38,0XCE,0X59,0XCE,0X79,0XCE,0X79,0XD6,0X9A,

124630XD6,0XBA,0XD6,0XBA,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,

124640XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,

124650XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

124660XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

124670XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,

124690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

124710XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,

124720XFF,0XDF,0XFF,0XDF,0XFF,0XDE,0XF7,0XDE,0XF7,0XBE,0XF7,0X9E,0XEF,0X3E,0XEF,0X5D,

124730XEF,0X5B,0XEF,0X5A,0XF7,0X58,0XEF,0X17,0XEE,0XD6,0XE6,0X96,0XE6,0X75,0XDE,0X54,

124740XD6,0X34,0XCD,0XF3,0XC5,0XB2,0XC5,0X92,0XBD,0X72,0XB5,0X51,0XA4,0XD0,0X9C,0X8F,

124750X9C,0X8F,0X9C,0XB0,0X9C,0X90,0X94,0X4F,0X8C,0X0E,0X8C,0X2E,0X84,0X0E,0X84,0X0D,

124760X83,0XED,0X7B,0XCD,0X7B,0XCD,0X7B,0XAD,0X7B,0X8D,0X7B,0X8D,0X7B,0XAE,0X7B,0XCE,

124770X7B,0XCE,0X83,0XEE,0X83,0XEE,0X84,0X0F,0X84,0X2F,0X8C,0X2F,0X84,0X0F,0X8C,0X2F,

124780X8C,0X50,0X8C,0X50,0X84,0X2F,0X84,0X0F,0X84,0X0F,0X84,0X2F,0X8C,0X50,0X8C,0X70,

124790X94,0X91,0X94,0XB2,0X94,0XB2,0X94,0XB3,0X9C,0XD4,0XA5,0X14,0XA5,0X35,0XA5,0X55,

124800XAD,0X55,0XB5,0X96,0XB5,0X96,0XB5,0XB6,0XBD,0XD7,0XBD,0XF7,0XBD,0XF7,0XC6,0X18,

124810XC6,0X38,0XC6,0X38,0XCE,0X59,0XCE,0X59,0XCE,0X79,0XD6,0X9A,0XD6,0X9A,0XD6,0XBA,

124820XDE,0XDB,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,

124830XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

124840XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

124850XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

124860XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124870XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

124890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,

124900XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XFF,0XDF,0XFF,0XDF,

124910XFF,0XDE,0XFF,0XDE,0XFF,0XBE,0XF7,0XBF,0XF7,0X9F,0XF7,0X9F,0XF7,0X9D,0XFF,0XBC,

124920XFF,0XDC,0XFF,0XFC,0XFF,0XFD,0XFF,0XFD,0XFF,0XBD,0XFF,0XBD,0XFF,0XBD,0XFF,0X9C,

124930XFF,0X7C,0XF7,0X7C,0XF7,0X7B,0XF7,0X5B,0XEF,0X5B,0XEF,0X3B,0XEF,0X1A,0XE6,0XD9,

124940XE6,0XD9,0XE6,0XFA,0XDE,0XD9,0XD6,0X99,0XD6,0X99,0XD6,0X99,0XCE,0X79,0XCE,0X78,

124950XCE,0X58,0XC6,0X58,0XC6,0X58,0XC6,0X38,0XC6,0X38,0XC6,0X17,0XBD,0XF6,0XBD,0XF6,

124960XBD,0XD5,0XBD,0XD5,0XBD,0XB4,0XBD,0XD4,0XC6,0X16,0XBD,0XF5,0XBD,0XD5,0XBD,0XF5,

124970XBD,0XF6,0XBD,0XD5,0XB5,0XB5,0XAD,0X74,0XAD,0X74,0XAD,0X74,0XAD,0X75,0XB5,0X95,

124980XB5,0X96,0XB5,0XB6,0XB5,0XB7,0XB5,0XB7,0XBD,0XD7,0XBD,0XD7,0XBD,0XD7,0XBD,0XF7,

124990XBD,0XF7,0XBD,0XF7,0XC6,0X18,0XC6,0X38,0XCE,0X59,0XCE,0X59,0XCE,0X79,0XCE,0X79,

125000XCE,0X79,0XD6,0X9A,0XD6,0X9A,0XD6,0XBA,0XD6,0XBA,0XDE,0XDB,0XDE,0XDB,0XDE,0XFB,

125010XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

125020XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,

125030XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

125040XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

125050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125060XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,

125090XF7,0XBE,0XF7,0X9E,0XF7,0XBE,0XF7,0X9E,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDE,

125100XFF,0XDF,0XFF,0XDF,0XFF,0XBF,0XFF,0XBF,0XFF,0XDE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,

125110XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

125120XFF,0XDE,0XFF,0XDE,0XFF,0XFE,0XFF,0XDD,0XFF,0XBD,0XFF,0XBD,0XFF,0XDD,0XFF,0XBD,

125130XFF,0XBD,0XF7,0X9D,0XF7,0X9D,0XF7,0X9E,0XEF,0X7D,0XEF,0X7D,0XEF,0X7C,0XE7,0X7C,

125140XEF,0X5C,0XEF,0X5C,0XE7,0X5B,0XE7,0X3B,0XE7,0X3B,0XE7,0X3A,0XEF,0X3B,0XEF,0X3A,

125150XEF,0X3A,0XEF,0X3B,0XE7,0X3A,0XE7,0X3A,0XDF,0X1A,0XDF,0X1A,0XDF,0X1A,0XDE,0XFA,

125160XDE,0XFA,0XDE,0XFA,0XD6,0XD9,0XD6,0X99,0XCE,0X79,0XCE,0X79,0XCE,0X79,0XCE,0X7A,

125170XCE,0X7A,0XCE,0X7A,0XCE,0X79,0XCE,0X79,0XD6,0X9A,0XD6,0X9A,0XD6,0X9A,0XD6,0X9A,

125180XD6,0XBA,0XD6,0XBA,0XD6,0XBA,0XD6,0XBA,0XDE,0XDB,0XDE,0XDB,0XDE,0XDB,0XDE,0XFB,

125190XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

125200XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,

125210XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,

125220XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,

125230XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

125240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

125250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125270XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

125280XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

125290XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

125310XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,

125320XFF,0XDE,0XFF,0XDF,0XFF,0XDE,0XFF,0XDE,0XFF,0XDD,0XF7,0XDD,0XFF,0XDC,0XFF,0XBC,

125330XFF,0XDC,0XFF,0XBC,0XFF,0XBC,0XFF,0XBC,0XFF,0X9C,0XFF,0X9C,0XF7,0X7C,0XF7,0X7D,

125340XF7,0X9D,0XF7,0X9D,0XF7,0XBD,0XF7,0XBE,0XF7,0XBD,0XEF,0XBD,0XEF,0X9D,0XEF,0XBD,

125350XF7,0XBD,0XEF,0X9D,0XEF,0X5C,0XE7,0X3C,0XDE,0XFB,0XDE,0XDB,0XE6,0XFB,0XE7,0X1C,

125360XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,

125370XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

125380XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

125390XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

125400XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

125410XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

125420XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

125430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

125440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

125460XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XDE,0XF7,0XBE,

125470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

125500XFF,0XFE,0XFF,0XDE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,

125510XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XDD,0XFF,0XDD,

125520XFF,0XDD,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,

125530XFF,0XDE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,

125540XFF,0XDF,0XF7,0XBE,0XF7,0X9E,0XEF,0X7D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,

125550XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,

125560XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

125570XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

125580XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

125590XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

125600XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

125610XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

125620XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

125650XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

125660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

125690XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,

125700XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

125710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,

125720XFF,0XDE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125730XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

125740XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

125750XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

125760XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

125770XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,

125780XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

125790XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125800XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

125810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

125840XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125880XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

125890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

125910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125920XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,

125930XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

125940XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

125950XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

125960XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

125970XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

125980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0X9E,

125990XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XF7,0XBE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

126000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126050XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126110XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,

126120XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

126130XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

126140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0X9E,

126180XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

126240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

126310XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126360XFF,0XFF,0XFF,0XFF,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,

126370XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126550XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

126560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0X9E,0XF7,0XBE,

126740XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,

126750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

126930XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

126990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127110XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

127120XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127300XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,

127310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127450XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

127460XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

127470XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

127480XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

127490XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

127500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127750XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,};

12789

12790const unsigned char gimage_0[51000] = { /* 0X10,0X10,0X00,0X96,0X00,0XAA,0X01,0X1B, */

127910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

127990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128570XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128800XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

128980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

128990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

129310XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

129320XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129480XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129490XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFC,0XFF,0XFB,0XFF,0XFB,

129500XFF,0XFB,0XFF,0XFB,0XFF,0XFB,0XFF,0XFB,0XFF,0XFB,0XFF,0XFC,0XFF,0XFC,0XFF,0XFC,

129510XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

129530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

129670XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFC,0XFF,0XFB,

129680XFF,0XFB,0XFF,0XFA,0XFF,0XFA,0XFF,0XF9,0XFF,0XF8,0XFF,0XF8,0XFF,0XF8,0XFF,0XF8,

129690XFF,0XF8,0XFF,0XF8,0XFF,0XF8,0XFF,0XF9,0XFF,0XF8,0XFF,0XF9,0XFF,0XFA,0XFF,0XFB,

129700XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129710XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

129720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

129860XFF,0XFD,0XFF,0XFC,0XFF,0XFC,0XFF,0XFA,0XFF,0XF9,0XFF,0XF8,0XFF,0XF7,0XFF,0XF7,

129870XFF,0XF6,0XFF,0XF5,0XFF,0XF5,0XFF,0XF4,0XFF,0XF4,0XFF,0XF4,0XFF,0XF4,0XFF,0XF4,

129880XFF,0XF5,0XFF,0XF5,0XFF,0XD5,0XFF,0XF5,0XFF,0XF6,0XFF,0XF7,0XFF,0XF8,0XFF,0XF9,

129890XFF,0XFB,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129900XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

129910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

129990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0XFA,

130050XFF,0XF8,0XFF,0XF7,0XFF,0XF6,0XFF,0XF5,0XFF,0XF4,0XFF,0XF4,0XFF,0XF3,0XFF,0XF3,

130060XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF2,

130070XFF,0XF3,0XFF,0XF3,0XFF,0XF3,0XFF,0XF3,0XFF,0XF4,0XFF,0XF5,0XFF,0XF7,0XFF,0XF9,

130080XFF,0XFA,0XFF,0XFB,0XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

130090XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130230XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0XF9,0XFF,0XF6,0XFF,0XF5,0XFF,0XF3,

130240XFF,0XD2,0XFF,0XF2,0XFF,0XF2,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF0,

130250XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,0XFF,0XF1,

130260XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF3,0XFF,0XF4,0XFF,0XF6,0XFF,0XF8,

130270XFF,0XF9,0XFF,0XFB,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,

130420XFF,0XF9,0XFF,0XF7,0XFF,0XF5,0XFF,0XF3,0XFF,0XF2,0XFF,0XF1,0XFF,0XF0,0XFF,0XF0,

130430XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

130440XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

130450XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF1,0XFF,0XF3,0XFF,0XF4,0XFF,0XF6,0XFF,0XD8,

130460XFF,0XDA,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130600XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFB,0XFF,0XF9,0XFF,0XF7,0XFF,0XF5,0XFF,0XF3,

130610XFF,0XF1,0XFF,0XF1,0XFF,0XF0,0XFF,0XEF,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

130620XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

130630XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

130640XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF1,0XFF,0XF3,0XFF,0XF4,0XFF,0XF6,0XFF,0XF8,

130650XFF,0XFA,0XFF,0XFC,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130780XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,

130790XFF,0XFB,0XFF,0XF8,0XFF,0XF6,0XFF,0XF3,0XFF,0XD1,0XFF,0XD0,0XFF,0XEF,0XFF,0XEF,

130800XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XCF,0XFF,0XCF,0XFF,0XCF,

130810XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

130820XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XCF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

130830XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF1,0XFF,0XF3,0XFF,0XF5,0XFF,0XD7,0XFF,0XD9,

130840XFF,0XFB,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

130960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

130970XFF,0XFD,0XFF,0XFD,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFA,0XFF,0XD7,0XFF,0XF5,

130980XFF,0XF3,0XFF,0XD0,0XFF,0XCF,0XFF,0XCE,0XFF,0XCD,0XFF,0XED,0XFF,0XEE,0XFF,0XCE,

130990XFF,0XCE,0XFF,0XAE,0XFF,0X8D,0XFF,0X6C,0XFF,0X4D,0XF7,0X0C,0XF7,0X0C,0XFF,0X6E,

131000XFF,0XAE,0XFF,0XCF,0XFF,0XF0,0XFF,0XF1,0XF7,0XD0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,

131010XFF,0XF0,0XFF,0XF0,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

131020XFF,0XEE,0XFF,0XEF,0XFF,0XF0,0XFF,0XF1,0XFF,0XF3,0XFF,0XD5,0XFF,0XD8,0XFF,0XFA,

131030XFF,0XDC,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131040XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,

131160XFF,0XFC,0XFF,0XFB,0XFF,0XD9,0XFF,0XD6,0XFF,0XF4,0XFF,0XF2,0XFF,0XF0,0XFF,0XEF,

131170XFF,0XEF,0XFF,0XEF,0XFF,0XCD,0XFF,0XEE,0XFF,0XAE,0XFF,0XAD,0XFF,0X4C,0XF7,0X0B,

131180XF6,0XC9,0XEE,0XA9,0XE6,0X48,0XDE,0X07,0XDE,0X07,0XDE,0X28,0XE6,0X69,0XF7,0X2C,

131190XFF,0XAF,0XFF,0XD0,0XFF,0XD0,0XFF,0XF0,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,0XFF,0XF0,

131200XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

131210XFF,0XEE,0XFF,0XEF,0XFF,0XF1,0XFF,0XF3,0XFF,0XD5,0XFF,0XD7,0XFF,0XF9,0XFF,0XFB,

131220XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

131230XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFB,0XFF,0XF9,0XFF,0XF7,

131350XFF,0XF3,0XFF,0XF1,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XEF,0XFF,0XEF,

131360XFF,0XAF,0XFF,0XAF,0XFF,0X6D,0XF7,0X2B,0XEE,0XA9,0XE6,0X68,0XE6,0X26,0XDD,0XE5,

131370XD5,0X83,0XD5,0X63,0XCD,0X43,0XC5,0X03,0XBC,0XE3,0XC5,0X65,0XEE,0XCB,0XFF,0XAF,

131380XFF,0XF0,0XFF,0XCF,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

131390XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,

131400XFF,0XF0,0XFF,0XF1,0XFF,0XD3,0XFF,0XD4,0XFF,0XF6,0XFF,0XF8,0XFF,0XFB,0XFF,0XFD,

131410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131530XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XF9,0XFF,0XF6,0XFF,0XF3,0XFF,0XF0,0XFF,0XEF,

131540XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XCF,0XFF,0XCF,0XFF,0X8F,0XFF,0X2D,

131550XF6,0XEB,0XEE,0X68,0XEE,0X68,0XE6,0X27,0XDE,0X04,0XDD,0XC3,0XDD,0X81,0XDD,0X82,

131560XD5,0X42,0XC4,0XE1,0XAC,0X20,0X93,0X80,0XCD,0X87,0XFF,0X6E,0XFF,0XAF,0XFF,0X8D,

131570XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,

131580XFF,0XEF,0XFF,0XF0,0XFF,0XEF,0XFF,0XCF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,

131590XFF,0XD1,0XFF,0XF2,0XFF,0XF3,0XFF,0XF5,0XFF,0XF8,0XFF,0XFB,0XFF,0XFE,0XFF,0XFF,

131600XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,

131720XFF,0XF9,0XFF,0XF6,0XF7,0XD3,0XF7,0XD0,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

131730XFF,0XEE,0XFF,0XEE,0XFF,0XCE,0XFF,0XCE,0XFF,0X4D,0XF6,0XCA,0XEE,0X48,0XE6,0X06,

131740XF6,0X67,0XF6,0X87,0XEE,0X45,0XE5,0XE3,0XE5,0XE1,0XE5,0XE1,0XE5,0X81,0XDD,0X41,

131750XCC,0XE1,0X93,0X40,0X9B,0XC0,0XE6,0X2A,0XFF,0XD0,0XFF,0XAE,0XFF,0XEE,0XF7,0X8C,

131760XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XCF,

131770XFF,0XEF,0XFF,0XEF,0XFF,0XCF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XF0,

131780XFF,0XF0,0XFF,0XF2,0XFF,0XF5,0XFF,0XF9,0XFF,0XFD,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

131790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

131900XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0XFA,0XFF,0XF6,0XFF,0XF3,

131910XF7,0XD1,0XF7,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XCE,

131920XFF,0XEE,0XFF,0XAD,0XF6,0XCA,0XEE,0X68,0XDD,0XA5,0XED,0XE5,0XF6,0X46,0XFE,0XA7,

131930XFE,0XA6,0XF6,0X44,0XEE,0X22,0XED,0XE1,0XE5,0XC0,0XE5,0XA1,0XDD,0X42,0XC4,0X81,

131940X9B,0X80,0XC5,0X05,0XFF,0X6E,0XFF,0X8E,0XFF,0XCE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

131950XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,

131960XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEF,

131970XFF,0XD2,0XFF,0XD6,0XFF,0XDA,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

131990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132080XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132090XFF,0XFD,0XFF,0XFB,0XFF,0XF9,0XFF,0XF6,0XFF,0XF3,0XFF,0XF1,0XFF,0XF0,0XFF,0XEF,

132100XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XCE,0XFF,0XCE,0XF7,0X2B,

132110XE6,0X67,0XDD,0XA3,0XDD,0X62,0XED,0XC3,0XF6,0X45,0XFE,0X86,0XFE,0XA7,0XFE,0X86,

132120XF6,0X44,0XF6,0X23,0XF6,0X01,0XED,0XE1,0XED,0XC2,0XE5,0X83,0XBC,0X61,0XB4,0X82,

132130XEE,0XAB,0XFF,0XAE,0XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

132140XFF,0XEE,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,

132150XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEF,0XFF,0XD1,0XF7,0XB3,

132160XF7,0XB7,0XFF,0XFA,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

132270XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XF9,

132280XFF,0XF5,0XF7,0XD2,0XF7,0XD1,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XCE,

132290XFF,0XCE,0XFF,0XEF,0XFF,0XCF,0XFF,0XEF,0XFF,0XAE,0XE6,0X89,0XDE,0X05,0XC4,0XC0,

132300XDD,0X61,0XED,0XA2,0XFE,0X44,0XFE,0X65,0XFE,0XA8,0XFE,0XA8,0XFE,0X67,0XF6,0X45,

132310XF6,0X43,0XF6,0X02,0XED,0XE2,0XE5,0XC2,0XDD,0X83,0XB4,0XA1,0XD5,0XE7,0XFF,0XCE,

132320XFF,0XEF,0XFF,0XEF,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,

132330XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,

132340XFF,0XED,0XFF,0XED,0XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XF7,0XB1,0XF7,0XB4,0XFF,0XD7,

132350XFF,0XFB,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

132460XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XF9,0XFF,0XF6,0XFF,0XF2,0XFF,0XF0,

132470XFF,0XEF,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XF7,0XCD,0XFF,0XEE,0XFF,0XEE,

132480XFF,0XCF,0XFF,0XCF,0XFF,0X6D,0XCD,0XA6,0XC4,0XE2,0XCC,0XE1,0XE5,0X41,0XED,0XA1,

132490XED,0XC1,0XF6,0X44,0XFE,0XA8,0XFE,0X89,0XFE,0X69,0XFE,0X68,0XFE,0X66,0XF6,0X44,

132500XEE,0X02,0XE5,0XE1,0XE6,0X23,0XCD,0X61,0XCD,0XC4,0XF7,0X4C,0XFF,0XEF,0XFF,0XEF,

132510XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

132520XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,

132530XFF,0XEE,0XFF,0XEF,0XFF,0XEF,0XFF,0XF0,0XFF,0XD2,0XEF,0X73,0XFF,0XF8,0XFF,0XFB,

132540XFF,0XFD,0XFF,0XFF,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

132650XFF,0XFD,0XFF,0XFA,0XFF,0XF7,0XFF,0XF3,0XFF,0XF0,0XFF,0XEE,0XFF,0XED,0XFF,0XED,

132660XFF,0XEE,0XFF,0XEE,0XFF,0XED,0XFF,0XCC,0XFF,0XED,0XFF,0XEE,0XFF,0XCF,0XFF,0XAF,

132670XE6,0X8A,0XBD,0X03,0XBC,0XA1,0XD5,0X22,0XDD,0X01,0XE5,0X61,0XED,0XA0,0XEE,0X02,

132680XFE,0X67,0XFE,0X69,0XFE,0X8A,0XFE,0X8A,0XFE,0X67,0XFE,0X65,0XFE,0X84,0XEE,0X22,

132690XEE,0X23,0XDD,0XC2,0XCD,0XA3,0XEF,0X0A,0XFF,0XAE,0XFF,0XEF,0XFF,0XEE,0XFF,0XEE,

132700XFF,0XEE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

132710XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XCE,0XFF,0XCE,

132720XFF,0XEE,0XFF,0XEE,0XF7,0XCF,0XF7,0XB1,0XF7,0XB5,0XFF,0XD9,0XFF,0XFD,0XFF,0XFE,

132730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFB,0XFF,0XD8,

132840XFF,0XD4,0XFF,0XD1,0XFF,0XEF,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XEE,

132850XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XCD,0XFF,0XEF,0XFF,0X6D,0XCD,0XA6,0X9B,0XE0,

132860XC4,0XE2,0XCC,0XE2,0XDD,0X01,0XDD,0X20,0XED,0XC1,0XED,0XE1,0XF6,0X25,0XFE,0X47,

132870XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0XA8,0XFE,0X65,0XFE,0XA6,0XFE,0XA5,0XE6,0X24,

132880XC5,0X62,0XEE,0XE9,0XFF,0XAE,0XFF,0XAE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

132890XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

132900XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XEC,0XFF,0XCE,0XFF,0XAE,0XFF,0XEE,0XFF,0XCD,

132910XF7,0XCD,0XFF,0XD0,0XF7,0X73,0XF7,0X97,0XFF,0XFC,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

132920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

132990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133020XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFC,0XFF,0XF8,0XFF,0XD5,0XFF,0XD2,0XFF,0XCF,

133030XFF,0XCE,0XFF,0XED,0XFF,0XEC,0XFF,0XEC,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

133040XFF,0XED,0XFF,0XCD,0XFF,0XCE,0XFF,0X2C,0XA4,0X61,0XA4,0X00,0XBC,0X81,0XD5,0X02,

133050XCC,0XC1,0XD5,0X21,0XE5,0X81,0XE5,0XA1,0XEE,0X04,0XF6,0X46,0XFE,0X89,0XFE,0X89,

133060XFE,0X88,0XFE,0X88,0XFE,0XA8,0XFE,0X87,0XF6,0X86,0XF6,0XA7,0XD5,0XA4,0XDE,0X47,

133070XFF,0X4C,0XFF,0XCE,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,

133080XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEC,

133090XFF,0XEC,0XFF,0XEC,0XFF,0XCE,0XFF,0XAE,0XFF,0XCD,0XFF,0XCD,0XFF,0XCC,0XFF,0XEF,

133100XF7,0X71,0XEF,0X54,0XFF,0XFA,0XFF,0XFC,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

133110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,

133210XFF,0XFD,0XFF,0XF9,0XFF,0XD5,0XFF,0XD2,0XFF,0XCF,0XFF,0XCE,0XFF,0XCE,0XFF,0XCD,

133220XFF,0XCD,0XFF,0XCC,0XFF,0XEC,0XFF,0XED,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,

133230XFF,0XAE,0XE6,0X8A,0X93,0XA0,0XAC,0X21,0XBC,0XA2,0XBC,0X81,0XC4,0X80,0XC4,0XA0,

133240XCD,0X21,0XD5,0X41,0XE5,0XE3,0XF6,0X25,0XFE,0X87,0XFE,0XA8,0XFE,0X88,0XFE,0X88,

133250XFE,0X89,0XFE,0XA9,0XFE,0XA9,0XF6,0X89,0XD5,0XC6,0XD6,0X07,0XFF,0X6C,0XFF,0XAD,

133260XFF,0XCD,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XED,0XFF,0XEC,

133270XFF,0XEC,0XFF,0XEC,0XFF,0XCD,0XFF,0XED,0XFF,0XCD,0XFF,0XED,0XFF,0XCD,0XFF,0XCD,

133280XFF,0XCD,0XFF,0XCD,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCE,0XF7,0X70,0XEF,0X32,

133290XF7,0X76,0XFF,0XFB,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFB,0XFF,0XF7,

133400XFF,0XD2,0XFF,0XCF,0XFF,0XCE,0XFF,0XCD,0XFF,0XAE,0XFF,0XAE,0XFF,0XAD,0XFF,0XCD,

133410XFF,0XCC,0XFF,0XEC,0XFF,0XCC,0XFF,0XCD,0XFF,0XAD,0XFF,0XCE,0XFF,0X8E,0XD5,0XC7,

133420X83,0X20,0XB4,0X62,0XB4,0X61,0XB4,0X40,0XB4,0X20,0XB4,0X20,0XBC,0XA1,0XC4,0XE1,

133430XD5,0X63,0XE5,0XE4,0XF6,0X67,0XFE,0X88,0XFE,0X89,0XFE,0X89,0XFE,0XAA,0XFE,0X8A,

133440XFE,0XAB,0XF6,0X8A,0XE6,0X28,0XCD,0XC6,0XF7,0X4C,0XFF,0XAD,0XFF,0XCC,0XFF,0XCD,

133450XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,0XFF,0XCC,

133460XFF,0XCC,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XCD,0XFF,0XAD,0XFF,0XCD,

133470XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAD,0XFF,0X8F,0XEF,0X30,0XE6,0XF3,0XFF,0X98,

133480XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133580XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XF8,0XFF,0XD4,0XF7,0XAF,0XFF,0XCE,

133590XFF,0XCD,0XFF,0XAD,0XFF,0X8E,0XFF,0X8E,0XFF,0XAE,0XFF,0XAD,0XFF,0XAD,0XFF,0XCC,

133600XF7,0XAC,0XFF,0XCD,0XFF,0XAD,0XFF,0XAE,0XFF,0X6E,0XBD,0X05,0X8B,0X40,0XB4,0X42,

133610XAC,0X02,0XA3,0XC1,0XA3,0XA0,0X9B,0XA0,0X9B,0XE0,0XA4,0X00,0XBC,0XA2,0XCD,0X44,

133620XE6,0X07,0XF6,0X68,0XF6,0X69,0XF6,0X69,0XFE,0XAA,0XF6,0X89,0XFE,0XCB,0XF6,0XAB,

133630XEE,0X8A,0XCD,0XA6,0XEF,0X0B,0XFF,0XAC,0XFF,0XAC,0XFF,0XCC,0XFF,0XAD,0XFF,0XAD,

133640XFF,0XAD,0XFF,0XAD,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAD,

133650XFF,0XAD,0XFF,0XAD,0XFF,0XAD,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAB,0XFF,0X8B,

133660XFF,0X8C,0XFF,0X8D,0XFF,0X8E,0XF7,0X50,0XDE,0XB0,0XEE,0XF4,0XFF,0XDB,0XFF,0XFD,

133670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133770XFF,0XFD,0XFF,0XFA,0XFF,0XD5,0XF7,0XB1,0XF7,0XAE,0XFF,0XAC,0XFF,0XCC,0XFF,0XAC,

133780XFF,0X8D,0XFF,0X8E,0XFF,0X8E,0XFF,0X8D,0XFF,0XAC,0XFF,0XCC,0XFF,0XAC,0XFF,0XCD,

133790XFF,0X8D,0XFF,0XAF,0XFF,0X2D,0XB4,0X83,0X93,0X80,0XAC,0X01,0XAB,0XE2,0X9B,0X60,

133800X93,0X60,0X93,0X40,0X8B,0X40,0X8B,0X40,0X9B,0XC1,0XB4,0X83,0XD5,0X66,0XEE,0X08,

133810XF6,0X69,0XFE,0XA9,0XFE,0XAA,0XF6,0X8A,0XF6,0XCC,0XEE,0X6B,0XE6,0X8C,0XC5,0X87,

133820XEE,0XEB,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0X8D,0XFF,0X8D,

133830XFF,0XAC,0XFF,0X8C,0XFF,0XAC,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8D,0XFF,0X8D,

133840XFF,0X8C,0XFF,0XAC,0XFF,0XAC,0XFF,0X8B,0XFF,0X8B,0XFF,0X6B,0XFF,0X8C,0XFF,0X6D,

133850XFF,0X8D,0XFF,0X6F,0XE6,0XCF,0XD6,0X70,0XFF,0XB8,0XFF,0XBB,0XFF,0XFE,0XFF,0XFF,

133860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

133950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFB,0XFF,0XD7,

133960XF7,0X93,0XF7,0X8F,0XFF,0X8D,0XFF,0XAB,0XFF,0XAB,0XFF,0XAC,0XFF,0X8D,0XFF,0X6D,

133970XFF,0X8C,0XFF,0X8C,0XFF,0XAC,0XFF,0XAC,0XFF,0XAC,0XFF,0XCD,0XFF,0X8D,0XFF,0X8E,

133980XF7,0X0C,0XA4,0X21,0X9B,0XE0,0XA4,0X01,0X93,0X80,0X93,0X41,0X8B,0X01,0X82,0XC1,

133990X7A,0XA0,0X7A,0XA0,0X7A,0XE1,0X93,0X83,0XAC,0X24,0XCD,0X26,0XEE,0X08,0XEE,0X48,

134000XF6,0X8A,0XF6,0XAB,0XEE,0XAC,0XEE,0XCD,0XF7,0X0F,0XCD,0XCA,0XEE,0XCB,0XFF,0X6C,

134010XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,

134020XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8C,

134030XFF,0X8C,0XFF,0X8B,0XFF,0X6B,0XFF,0X6B,0XFF,0X6B,0XFF,0X6B,0XFF,0X8C,0XFF,0X6D,

134040XF7,0X2E,0XD6,0X2D,0XE6,0X92,0XFF,0XDA,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XF9,0XFF,0X95,0XF7,0X51,0XFF,0X6E,

134150XFF,0X6C,0XFF,0X8B,0XFF,0X8B,0XFF,0X8B,0XFF,0X6C,0XFF,0X6C,0XFF,0X8C,0XFF,0X8C,

134160XFF,0X8C,0XFF,0X8C,0XFF,0X8C,0XFF,0X8D,0XFF,0X6D,0XFF,0X6D,0XF6,0XEB,0X9C,0X20,

134170X9C,0X00,0X9B,0XE1,0X93,0X60,0X83,0X00,0X82,0XC1,0X72,0X81,0X6A,0X61,0X62,0X20,

134180X62,0X41,0X72,0XC2,0X8B,0X63,0XAC,0X65,0XCD,0X47,0XE6,0X2A,0XEE,0X8C,0XE6,0X4C,

134190XEE,0XCE,0XFF,0X72,0XFF,0X94,0XDE,0X4E,0XEE,0XAC,0XFF,0X4D,0XFF,0X6C,0XFF,0X6C,

134200XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,

134210XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6B,0XFF,0X6B,

134220XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X6B,0XFF,0X6C,0XF7,0X6C,0XF7,0X2D,0XE6,0X8C,

134230XC5,0X8C,0XFF,0X97,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,

134330XFF,0XFF,0XFF,0XFC,0XFF,0XB6,0XFF,0X72,0XF7,0X4F,0XFF,0X4D,0XFF,0X6C,0XFF,0X8C,

134340XFF,0X6B,0XFF,0X6B,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X8C,0XFF,0X6B,0XFF,0X6B,

134350XFF,0X6C,0XFF,0X6C,0XFF,0X6D,0XFF,0X6D,0XEE,0XAA,0X9C,0X00,0X9C,0X01,0X9B,0XC1,

134360X8B,0X40,0X83,0X00,0X7A,0XA0,0X6A,0X60,0X5A,0X21,0X51,0XC1,0X49,0XE1,0X5A,0X21,

134370X6A,0XA2,0X83,0X63,0XA4,0X45,0XCD,0X89,0XDE,0X2D,0XDE,0X6F,0XF7,0X34,0XFF,0XF7,

134380XFF,0XD8,0XDE,0X91,0XDE,0X6D,0XFF,0X2D,0XFF,0X4C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,

134390XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X6C,0XFF,0X4C,0XFF,0X6C,

134400XFF,0X4C,0XFF,0X6C,0XFF,0X4C,0XFF,0X6B,0XFF,0X6B,0XFF,0X6B,0XFF,0X4B,0XFF,0X2B,

134410XFF,0X4B,0XFF,0X4B,0XFF,0X4C,0XFF,0X4C,0XF7,0X2C,0XEE,0XCC,0XCD,0XAB,0XD6,0X10,

134420XFF,0XFB,0XEF,0X5B,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134510XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDB,

134520XF7,0X74,0XF7,0X50,0XF7,0X2E,0XFF,0X4D,0XFF,0X6C,0XFF,0X6C,0XFF,0X6B,0XFF,0X6B,

134530XFF,0X6B,0XFF,0X6B,0XFF,0X4B,0XFF,0X6C,0XFF,0X6B,0XFF,0X4B,0XFF,0X6C,0XFF,0X4C,

134540XFF,0X6D,0XFF,0X4D,0XE6,0X69,0X93,0XE0,0X9C,0X01,0X93,0XA0,0X83,0X60,0X7B,0X00,

134550X72,0XA0,0X6A,0X61,0X52,0X01,0X49,0XC1,0X49,0XE2,0X41,0XC1,0X5A,0X41,0X62,0X81,

134560X83,0X84,0X9C,0X67,0XB5,0X2C,0XE6,0XD4,0XFF,0XB8,0XFF,0XFA,0XFF,0XFA,0XDE,0XB3,

134570XD6,0X2D,0XFF,0X4E,0XFF,0X4C,0XFF,0X4B,0XFF,0X4C,0XFF,0X6C,0XFF,0X4C,0XFF,0X4B,

134580XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,

134590XFF,0X4B,0XFF,0X4B,0XFF,0X4A,0XFF,0X4A,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,

134600XFF,0X2C,0XFF,0X2C,0XFF,0X2C,0XFF,0X2D,0XCD,0XA9,0XBD,0X4A,0XEF,0X16,0XFF,0XFD,

134610XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134700XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0X99,0XF7,0X31,0XF7,0X2E,

134710XFF,0X2D,0XFF,0X2C,0XFF,0X4C,0XFF,0X4C,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,

134720XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X6C,0XFF,0X2C,0XFF,0X4C,0XFF,0X2C,

134730XE6,0X29,0X93,0XE0,0X9C,0X01,0X8B,0XA0,0X83,0X61,0X7B,0X00,0X72,0XC1,0X62,0X61,

134740X5A,0X21,0X49,0XE1,0X41,0XC1,0X41,0XA1,0X49,0XE0,0X52,0X00,0X6A,0XE3,0X73,0X44,

134750XAD,0X0D,0XF7,0X78,0XFF,0XFC,0XFF,0XFC,0XFF,0XDC,0XDE,0XD5,0XCE,0X0D,0XFF,0X4E,

134760XFF,0X4C,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,0XFF,0X4B,

134770XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X4B,

134780XFF,0X2A,0XFF,0X2B,0XFF,0X2B,0XFF,0X0C,0XFF,0X0B,0XFF,0X2B,0XFF,0X0B,0XFF,0X2B,

134790XFF,0X2B,0XFF,0X0B,0XDE,0X49,0XB5,0X28,0XC5,0XCF,0XFF,0XBB,0XFF,0XFE,0XFF,0XFF,

134800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

134880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFE,

134890XFF,0XFE,0XFF,0XFD,0XFF,0XBB,0XF7,0X56,0XF7,0X0F,0XF7,0X2C,0XFF,0X2C,0XFF,0X2C,

134900XFF,0X2C,0XFF,0X2C,0XFF,0X2B,0XFF,0X4B,0XFF,0X4B,0XFF,0X2B,0XFF,0X2B,0XFF,0X4B,

134910XFF,0X2B,0XFF,0X4B,0XFF,0X4C,0XFF,0X2C,0XFF,0X4C,0XFF,0X2C,0XDE,0X09,0X9C,0X01,

134920X93,0XE1,0X8B,0XA1,0X83,0X61,0X73,0X01,0X72,0XC1,0X62,0X81,0X5A,0X41,0X52,0X22,

134930X41,0XA1,0X41,0XC1,0X41,0XA0,0X49,0XE0,0X52,0X21,0X5A,0X83,0XD6,0X54,0XFF,0XFC,

134940XFF,0XFE,0XFF,0XFE,0XFF,0XDD,0XE6,0XD6,0XCD,0XED,0XF7,0X0D,0XFF,0X2C,0XFF,0X2B,

134950XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,

134960XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2A,0XFF,0X0B,

134970XFF,0X0B,0XFE,0XEB,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X2B,

134980XF6,0XCB,0XCD,0XC9,0X9C,0X89,0XDE,0XB5,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

134990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFC,

135080XFF,0X98,0XF7,0X13,0XF7,0X0E,0XFF,0X0B,0XFF,0X2C,0XFF,0X0B,0XFF,0X0C,0XFF,0X2B,

135090XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,

135100XFF,0X2B,0XFF,0X2B,0XFF,0X0C,0XFF,0X2C,0XDD,0XE8,0X9B,0XE1,0X8B,0XA0,0X8B,0X81,

135110X83,0X41,0X73,0X01,0X72,0XE2,0X6A,0XA2,0X62,0X61,0X5A,0X21,0X41,0XC1,0X4A,0X02,

135120X41,0X80,0X49,0XA1,0X41,0X81,0X6A,0XE7,0XF7,0X5A,0XFF,0XFD,0XFF,0XDE,0XFF,0XFE,

135130XFF,0XDD,0XE6,0XD6,0XD5,0XCD,0XF7,0X0D,0XFF,0X0C,0XFF,0X2B,0XFF,0X0B,0XFF,0X0B,

135140XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,

135150XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0B,0XFF,0X0B,0XFE,0XEB,0XFE,0XEB,

135160XFE,0XEA,0XFE,0XEA,0XFE,0XEB,0XFE,0XEB,0XFF,0X0B,0XFF,0X0B,0XFE,0XEB,0XD5,0XE9,

135170XAC,0XC8,0XC5,0XAF,0XFF,0XB9,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFA,0XFF,0X55,0XEE,0XF0,

135270XF7,0X0D,0XFF,0X0B,0XFF,0X2B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0A,0XFF,0X0A,

135280XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFE,0XEA,0XFF,0X2B,

135290XFE,0XEB,0XFF,0X2C,0XD5,0XA7,0X93,0XC1,0X83,0X60,0X83,0X61,0X7B,0X42,0X73,0X02,

135300X73,0X03,0X6A,0XC2,0X62,0X82,0X5A,0X41,0X4A,0X01,0X4A,0X22,0X41,0XA1,0X41,0X81,

135310X41,0X82,0X94,0X0D,0XFF,0X9D,0XFF,0XFF,0XFF,0XBE,0XFF,0XFF,0XFF,0XFE,0XE6,0XD6,

135320XC5,0X6B,0XF6,0XCD,0XFF,0X0B,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,

135330XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

135340XFE,0XEA,0XFE,0XEA,0XFF,0X0B,0XFE,0XEB,0XFE,0XEA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,

135350XFE,0XCA,0XFE,0XCA,0XFE,0XEA,0XFE,0XCA,0XFE,0XEB,0XDD,0XE9,0XBD,0X49,0XA4,0X89,

135360XDE,0XB4,0XFF,0XFB,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135450XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0X98,0XEF,0X11,0XF6,0XCE,0XFF,0X0C,0XFE,0XEB,

135460XFE,0XEB,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0A,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,

135470XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFF,0X0C,0XFE,0XEC,

135480XCD,0X67,0X8B,0X60,0X7B,0X20,0X83,0X42,0X83,0X63,0X7B,0X23,0X7B,0X24,0X73,0X03,

135490X6A,0XC3,0X62,0X83,0X5A,0X83,0X4A,0X01,0X4A,0X02,0X41,0X81,0X41,0XC3,0XC5,0XD5,

135500XFF,0XBE,0XFF,0XFF,0XF7,0XBE,0XFF,0XFF,0XFF,0XDE,0XEE,0XF7,0XC5,0X6B,0XF6,0XCD,

135510XFE,0XEB,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFF,0X0A,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

135520XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

135530XFE,0XCB,0XFE,0XCA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,

135540XFE,0XCA,0XFE,0XCA,0XFF,0X0B,0XE6,0X29,0XCD,0XA9,0X94,0X25,0XB5,0X2C,0XFF,0XB9,

135550XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

135560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFF,0XFF,0XFE,

135640XFF,0XFC,0XF7,0X56,0XEE,0XEF,0XF6,0XEC,0XFE,0XEB,0XFE,0XEB,0XFE,0XEA,0XFE,0XEA,

135650XFE,0XEB,0XFF,0X0B,0XFF,0X0B,0XFF,0X0B,0XFE,0XEB,0XFE,0XEB,0XFF,0X0B,0XFE,0XEA,

135660XFF,0X0B,0XFE,0XEA,0XFE,0XEA,0XFE,0XEB,0XFE,0XEB,0XFE,0XCC,0XCD,0X67,0X83,0X40,

135670X72,0XE0,0X7B,0X01,0X7B,0X23,0X7B,0X03,0X7B,0X24,0X73,0X03,0X6A,0XE4,0X62,0XC3,

135680X62,0XC3,0X52,0X62,0X52,0X22,0X41,0XC2,0X5A,0X87,0XDE,0X99,0XFF,0XDF,0XFF,0XFF,

135690XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XEF,0X37,0XBD,0X6A,0XF6,0XCD,0XFE,0XEB,0XFE,0XEA,

135700XFE,0XCA,0XFE,0XEA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,

135710XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,

135720XFE,0XC9,0XFE,0XC9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XAA,0XFE,0X89,0XFE,0XAA,

135730XFE,0XAA,0XFE,0XEC,0XCD,0X67,0XB4,0XC6,0X94,0X26,0XD6,0X32,0XFF,0XDB,0XFF,0XFE,

135740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XDA,0XEE,0XF3,

135830XEE,0XCD,0XF6,0XEB,0XFE,0XCB,0XFE,0XEB,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEB,

135840XFE,0XEB,0XFE,0XEB,0XFE,0XEB,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,

135850XFE,0XCA,0XFE,0XCA,0XFE,0XCB,0XFE,0XCC,0XCD,0X47,0X83,0X20,0X72,0XA0,0X72,0XE1,

135860X7B,0X03,0X7B,0X03,0X7B,0X24,0X73,0X04,0X6A,0XE4,0X6A,0XE3,0X62,0XC3,0X5A,0XA2,

135870X52,0X41,0X49,0XE2,0X73,0X29,0XEF,0X1B,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135880XFF,0XFD,0XF7,0X78,0XBD,0X4A,0XF6,0XCC,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,

135890XFE,0XCA,0XFE,0XCA,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,

135900XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XCA,0XFE,0XCA,0XFE,0XC9,0XFE,0XC9,0XFE,0XA8,

135910XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XA9,0XFE,0XCA,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,

135920XDD,0XC7,0XBC,0XE6,0X94,0X05,0XAD,0X0C,0XF7,0X79,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

135930XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

135990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136010XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0X98,0XEE,0XB1,0XF6,0XCC,0XF6,0XCA,

136020XFE,0XCA,0XFE,0XCA,0XFE,0XC9,0XFE,0XE9,0XFE,0XCA,0XFE,0XCA,0XFE,0XCB,0XFE,0XCB,

136030XFE,0XCA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XEA,0XFE,0XCA,0XFE,0XCA,0XFE,0XCA,

136040XFE,0XCB,0XFE,0XCC,0XC5,0X27,0X7B,0X00,0X72,0XA0,0X72,0XE2,0X7B,0X03,0X7B,0X04,

136050X7B,0X24,0X73,0X04,0X72,0XE4,0X6A,0XE4,0X62,0XC2,0X62,0XE3,0X5A,0X62,0X52,0X22,

136060X8B,0XEC,0XF7,0X3B,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XF7,0X78,

136070XBD,0X4A,0XF6,0XAC,0XFE,0XAA,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XC9,

136080XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

136090XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XA9,0XFE,0XA8,0XFE,0XA9,0XFE,0X89,0XFE,0X8A,

136100XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0X89,0XFE,0X89,0XF6,0X89,0XE6,0X08,0XBC,0XE5,

136110XA4,0X46,0X9C,0X49,0XD6,0X95,0XFF,0XDC,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

136120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136200XFF,0XFD,0XFF,0XFB,0XF7,0X35,0XEE,0X8F,0XF6,0XAB,0XF6,0XA9,0XFE,0XAA,0XFE,0XAA,

136210XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XCA,0XFE,0XAB,0XFE,0XCA,0XFE,0XCA,0XFE,0XC9,

136220XFE,0XC9,0XFE,0XC9,0XFE,0XC9,0XFE,0XCA,0XFE,0XAA,0XFE,0XAA,0XFE,0XAB,0XF6,0XAC,

136230XBD,0X06,0X72,0XE0,0X6A,0XA0,0X72,0XC2,0X72,0XE3,0X72,0XE4,0X73,0X04,0X73,0X04,

136240X73,0X04,0X6A,0XE4,0X62,0XC3,0X6B,0X04,0X62,0X83,0X5A,0X64,0XA4,0XB0,0XFF,0X9C,

136250XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XF7,0X79,0XC5,0X4A,0XF6,0X8C,

136260XFE,0XAA,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

136270XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

136280XFE,0X89,0XFE,0XA9,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0X89,0XFE,0X88,0XFE,0X88,

136290XF6,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XEE,0X28,0XCD,0X46,0XAC,0X66,0X8B,0XC6,

136300XB5,0X6F,0XF7,0XBA,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XDA,

136390XEE,0XD2,0XEE,0X8D,0XF6,0X8A,0XFE,0X88,0XFE,0XA9,0XFE,0X89,0XFE,0XA9,0XFE,0XA8,

136400XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAA,0XFE,0XA9,0XFE,0XA9,0XFE,0XC9,0XFE,0XA9,

136410XFE,0XA9,0XFE,0XA9,0XFE,0XA9,0XFE,0XAA,0XFE,0XAB,0XF6,0X8B,0XB4,0XC6,0X72,0XA0,

136420X6A,0X81,0X72,0XC2,0X72,0XC3,0X72,0XE4,0X73,0X04,0X73,0X04,0X72,0XE3,0X6B,0X03,

136430X6A,0XE3,0X6A,0XE4,0X62,0XA4,0X5A,0X65,0XBD,0X52,0XFF,0X9D,0XFF,0XDF,0XFF,0XFF,

136440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0X59,0XC5,0X4B,0XEE,0X6C,0XFE,0X8A,0XFE,0X89,

136450XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,

136460XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XFE,0X89,0XF6,0X88,0XF6,0X88,

136470XF6,0X88,0XF6,0X88,0XF6,0X88,0XFE,0X68,0XFE,0X68,0XF6,0X87,0XFE,0XA8,0XF6,0X88,

136480XFE,0X88,0XFE,0X68,0XF6,0X48,0XDD,0X87,0XAC,0X86,0X8B,0XC6,0X94,0X6A,0XE7,0X17,

136490XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFD,0XFF,0X98,0XE6,0X8F,0XEE,0X6B,

136580XF6,0X69,0XFE,0XA8,0XFE,0X89,0XFE,0X89,0XFE,0X88,0XFE,0XA8,0XFE,0XA8,0XFE,0XA9,

136590XFE,0X8A,0XFE,0X8A,0XFE,0X89,0XFE,0XA9,0XFE,0XA8,0XFE,0XA8,0XFE,0XA9,0XFE,0X89,

136600XFE,0X89,0XFE,0X8A,0XF6,0X8B,0XF6,0X8B,0XB4,0XA6,0X6A,0XA0,0X6A,0X81,0X6A,0XC3,

136610X72,0XC4,0X72,0XE4,0X73,0X04,0X73,0X04,0X73,0X03,0X73,0X03,0X6B,0X03,0X6A,0XE4,

136620X6A,0XA5,0X62,0X86,0XC5,0XB4,0XFF,0XBD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136630XFF,0XFF,0XF7,0X7A,0XBD,0X2C,0XEE,0X4C,0XF6,0X8A,0XFE,0X88,0XFE,0X88,0XFE,0X88,

136640XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,

136650XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XFE,0X69,0XF6,0X69,0XF6,0X69,0XF6,0X68,

136660XF6,0X68,0XFE,0X67,0XF6,0X67,0XF6,0X87,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XFE,0X68,

136670XF6,0X49,0XE5,0XA8,0XB4,0XA6,0X93,0XC5,0X83,0XC8,0XBD,0XD1,0XFF,0XFC,0XFF,0XFE,

136680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136760XFF,0XFF,0XFF,0XDE,0XFF,0XFC,0XF7,0X56,0XE6,0X4D,0XEE,0X4A,0XF6,0X48,0XFE,0XA9,

136770XFE,0X68,0XFE,0X89,0XF6,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0X89,0XFE,0X89,

136780XFE,0X89,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0X89,0XF6,0X69,0XF6,0X89,

136790XF6,0X8A,0XF6,0X6B,0XB4,0XA6,0X6A,0XA0,0X6A,0XA1,0X72,0XC3,0X72,0XE4,0X72,0XE4,

136800X72,0XE4,0X72,0XE3,0X72,0XE3,0X6B,0X03,0X6B,0X03,0X62,0XC4,0X6A,0XC5,0X62,0XA6,

136810XCD,0XD5,0XFF,0XBD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0X7A,

136820XBD,0X2C,0XEE,0X4C,0XF6,0X6A,0XF6,0X68,0XFE,0X68,0XF6,0X88,0XFE,0X68,0XF6,0X88,

136830XFE,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

136840XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X69,0XF6,0X68,0XF6,0X68,0XF6,0X67,

136850XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X88,0XF6,0X68,0XF6,0X48,0XFE,0X69,0XDD,0X67,

136860XC5,0X07,0X9C,0X06,0X7B,0X86,0X94,0X8C,0XFF,0XBB,0XFF,0XFD,0XFF,0XFF,0XFF,0XFF,

136870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

136940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,

136950XFF,0XBB,0XF6,0XF3,0XDE,0X0B,0XF6,0X8A,0XF6,0X69,0XF6,0X28,0XFE,0X68,0XF6,0X68,

136960XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XFE,0X89,0XFE,0X88,0XF6,0X88,

136970XF6,0X88,0XF6,0X88,0XFE,0X88,0XFE,0X88,0XF6,0X88,0XF6,0X68,0XF6,0X8A,0XEE,0X6B,

136980XAC,0X65,0X72,0XC0,0X6A,0X81,0X72,0XC3,0X72,0XE4,0X72,0XE4,0X72,0XE4,0X73,0X04,

136990X73,0X03,0X73,0X03,0X6A,0XE3,0X6A,0XA3,0X6A,0XA5,0X72,0XE7,0XD6,0X56,0XFF,0XFE,

137000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBA,0XBD,0X2B,0XEE,0X4C,

137010XEE,0X69,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

137020XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

137030XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X47,

137040XF6,0X47,0XF6,0X68,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XE6,0X09,0XC4,0XE6,0XA4,0X45,

137050X83,0X85,0X8B,0XE9,0XDE,0X95,0XFF,0X9B,0XFF,0XFE,0XFF,0XFF,0XF7,0XBE,0XFF,0XFF,

137060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137130XFF,0XFF,0XFF,0XFF,0XF7,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0X99,0XE6,0X71,

137140XDE,0X0B,0XEE,0X49,0XF6,0X49,0XF6,0X28,0XF6,0X68,0XF6,0X67,0XF6,0X88,0XF6,0X88,

137150XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X68,0XF6,0X68,

137160XFE,0X88,0XFE,0X68,0XF6,0X88,0XF6,0X68,0XF6,0X8A,0XEE,0X4B,0XAC,0X44,0X72,0XC0,

137170X6A,0X81,0X72,0XC3,0X72,0XE4,0X72,0XE4,0X72,0XE4,0X72,0XE4,0X72,0XE3,0X73,0X03,

137180X6A,0XE3,0X6A,0XA3,0X6A,0XA4,0X72,0XE7,0XD6,0X57,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137190XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XBA,0XBD,0X2B,0XE6,0X4C,0XEE,0X4A,0XF6,0X68,

137200XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

137210XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

137220XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X48,0XF6,0X68,

137230XF6,0X68,0XF6,0X68,0XF6,0X48,0XE6,0X09,0XC5,0X06,0XAC,0X45,0X8B,0XA5,0X7B,0X66,

137240XAD,0X0F,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

137250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137320XF7,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0X58,0XDE,0X0F,0XE6,0X2B,0XE6,0X08,

137330XEE,0X49,0XF6,0X49,0XF6,0X48,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

137340XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XFE,0X68,0XF6,0X68,

137350XF6,0X68,0XF6,0X68,0XF6,0X6A,0XEE,0X4A,0XA4,0X44,0X72,0XC0,0X6A,0X81,0X72,0XE3,

137360X72,0XE4,0X72,0XE4,0X72,0XE4,0X72,0XE4,0X72,0XE3,0X73,0X03,0X6A,0XE3,0X6A,0XA3,

137370X6A,0X84,0X73,0X08,0XD6,0X77,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137380XFF,0XFE,0XFF,0XBA,0XB5,0X0B,0XE6,0X2B,0XEE,0X49,0XF6,0X48,0XF6,0X48,0XF6,0X48,

137390XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

137400XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X48,0XF6,0X48,

137410XF6,0X68,0XEE,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XEE,0X47,

137420XEE,0X48,0XEE,0X29,0XCD,0X26,0XAC,0X65,0X8B,0XC5,0X73,0X45,0X83,0XA9,0XFF,0X9A,

137430XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

137510XFF,0XFF,0XFF,0XDD,0XEE,0XF5,0XD5,0XED,0XE6,0X4B,0XE6,0X08,0XEE,0X28,0XF6,0X49,

137520XF6,0X47,0XF6,0X67,0XF6,0X67,0XEE,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

137530XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X68,0XF6,0X48,

137540XF6,0X6A,0XE6,0X4A,0XA4,0X24,0X72,0XC0,0X6A,0XA1,0X72,0XC3,0X72,0XE4,0X72,0XE4,

137550X72,0XE4,0X72,0XE4,0X72,0XE3,0X72,0XE3,0X6A,0XE3,0X6A,0XA3,0X6A,0X84,0X7B,0X28,

137560XDE,0X98,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDA,

137570XB5,0X0B,0XE6,0X0B,0XEE,0X49,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,0XEE,0X48,

137580XEE,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

137590XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X48,0XEE,0X48,0XEE,0X47,0XEE,0X47,

137600XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X48,0XE6,0X09,

137610XCD,0X47,0XAC,0X65,0X8B,0XC5,0X7B,0X45,0X7B,0X68,0XD6,0X35,0XFF,0XDD,0XFF,0XBD,

137620XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XBB,

137700XDE,0X72,0XD5,0XCC,0XE6,0X2A,0XE6,0X28,0XEE,0X08,0XF6,0X28,0XEE,0X47,0XEE,0X47,

137710XEE,0X47,0XEE,0X48,0XEE,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

137720XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X48,0XEE,0X48,0XEE,0X69,0XE6,0X2A,

137730X9C,0X04,0X72,0XC0,0X6A,0XA1,0X6A,0XC3,0X6A,0XC3,0X6A,0XE4,0X72,0XE4,0X72,0XE4,

137740X6A,0XC3,0X72,0XE3,0X6A,0XE3,0X6A,0XA3,0X62,0X64,0X7B,0X48,0XDE,0XB8,0XFF,0XFE,

137750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDA,0XB5,0X0B,0XDE,0X0B,

137760XEE,0X29,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

137770XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

137780XEE,0X47,0XEE,0X47,0XEE,0X28,0XEE,0X28,0XEE,0X47,0XEE,0X47,0XEE,0X27,0XEE,0X27,

137790XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X28,0XE6,0X28,0XD5,0X88,0XB4,0X86,

137800X8B,0XA4,0X7B,0X24,0X7B,0X47,0XA4,0XCF,0XFF,0X9B,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,

137810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

137880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0X9A,0XD5,0XEF,0XD5,0XEB,

137890XDE,0X08,0XEE,0X48,0XED,0XE7,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X48,

137900XEE,0X48,0XEE,0X48,0XF6,0X48,0XF6,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X48,0XEE,0X48,

137910XF6,0X47,0XEE,0X27,0XEE,0X47,0XEE,0X48,0XEE,0X49,0XE6,0X0A,0X9C,0X03,0X72,0XC0,

137920X6A,0XA1,0X6A,0XC3,0X6A,0XC3,0X6A,0XE4,0X72,0XE4,0X72,0XE4,0X6A,0XE3,0X6A,0XE3,

137930X6A,0XC3,0X6A,0XC4,0X62,0X64,0X7B,0X49,0XDE,0XD9,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

137940XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XDB,0XB5,0X0B,0XDD,0XEB,0XEE,0X29,0XEE,0X28,

137950XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

137960XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

137970XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,

137980XEE,0X27,0XEE,0X47,0XEE,0X28,0XEE,0X28,0XDD,0XC8,0XBC,0XC6,0X8B,0XA3,0X7B,0X44,

137990X73,0X05,0X83,0X8A,0XEF,0X3A,0XFF,0XFD,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

138000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138070XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XF7,0X57,0XCD,0XAD,0XDD,0XEB,0XDE,0X08,0XEE,0X48,

138080XEE,0X07,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,

138090XEE,0X28,0XEE,0X27,0XEE,0X47,0XEE,0X27,0XEE,0X48,0XEE,0X48,0XEE,0X47,0XEE,0X27,

138100XEE,0X47,0XEE,0X28,0XEE,0X49,0XDE,0X0A,0X9B,0XE3,0X6A,0XC0,0X6A,0XA2,0X6A,0XC3,

138110X6A,0XC3,0X6A,0XE4,0X72,0XE4,0X6A,0XC4,0X6A,0XC3,0X6A,0XC3,0X6A,0XC3,0X6A,0XA4,

138120X62,0X63,0X7B,0X49,0XE6,0XD9,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138130XFF,0XFE,0XFF,0XDB,0XB5,0X0B,0XDD,0XEB,0XEE,0X29,0XEE,0X28,0XEE,0X28,0XEE,0X28,

138140XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

138150XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

138160XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X27,

138170XEE,0X28,0XEE,0X29,0XE5,0XE9,0XC4,0XE7,0X93,0XC4,0X7B,0X44,0X7B,0X26,0X62,0XC6,

138180XD6,0X76,0XFF,0XBC,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

138260XFF,0XDC,0XEE,0XF5,0XCD,0XAB,0XDE,0X0A,0XE6,0X28,0XEE,0X28,0XEE,0X07,0XEE,0X28,

138270XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

138280XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X48,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X28,

138290XEE,0X49,0XDE,0X0A,0X93,0XC3,0X6A,0XA0,0X6A,0XA1,0X6A,0XC3,0X62,0XA3,0X6A,0XC3,

138300X6A,0XC3,0X6A,0XA3,0X6A,0XC3,0X6A,0XA3,0X62,0XA3,0X6A,0XA4,0X62,0X43,0X7B,0X49,

138310XDE,0XD9,0XFF,0XDE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,

138320XB4,0XEB,0XDD,0XCB,0XEE,0X29,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,

138330XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

138340XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

138350XEE,0X07,0XEE,0X07,0XEE,0X28,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X28,

138360XE6,0X09,0XC5,0X07,0X9B,0XE4,0X7B,0X23,0X73,0X25,0X73,0X07,0XA4,0XCF,0XFF,0XDC,

138370XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138440XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XFC,0XDE,0X52,

138450XCD,0XAA,0XDE,0X09,0XE6,0X07,0XE6,0X07,0XE5,0XE7,0XEE,0X08,0XE6,0X07,0XEE,0X27,

138460XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

138470XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X49,0XDD,0XEA,

138480X8B,0XA2,0X6A,0XA0,0X6A,0XA2,0X6A,0XC3,0X62,0XA3,0X6A,0XC4,0X6A,0XC3,0X6A,0XC3,

138490X6A,0XC3,0X6A,0XC3,0X62,0X83,0X6A,0XC4,0X62,0X43,0X7B,0X49,0XDE,0XD8,0XFF,0XFE,

138500XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XB4,0XEB,0XD5,0XCA,

138510XEE,0X29,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

138520XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

138530XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

138540XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X07,0XEE,0X07,0XEE,0X28,0XE6,0X09,0XC5,0X27,

138550X9B,0XE4,0X7B,0X43,0X73,0X05,0X6A,0XE6,0X94,0X2D,0XF7,0X5A,0XFF,0XFD,0XFF,0XFE,

138560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138630XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFA,0XCD,0XEF,0XCD,0XAA,0XDE,0X08,

138640XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE5,0XE7,0XEE,0X07,0XEE,0X07,0XE6,0X28,0XEE,0X28,

138650XEE,0X28,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X27,

138660XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X49,0XDD,0XEA,0X8B,0XA2,0X6A,0XA0,

138670X6A,0XA2,0X6A,0XA3,0X62,0XA3,0X6A,0XC4,0X62,0XA3,0X6A,0XC3,0X62,0XA3,0X62,0XA3,

138680X62,0X83,0X6A,0XA4,0X62,0X43,0X83,0X69,0XE6,0XD8,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

138690XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XB4,0XEB,0XD5,0XCB,0XEE,0X29,0XEE,0X28,

138700XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

138710XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

138720XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X07,

138730XEE,0X27,0XE6,0X07,0XEE,0X27,0XEE,0X28,0XE6,0X08,0XCD,0X47,0X9C,0X04,0X83,0X23,

138740X72,0XE4,0X6A,0XE6,0X7B,0X89,0XDE,0X97,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

138750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

138820XFF,0XFF,0XFF,0XFD,0XFF,0XB9,0XBD,0X6C,0XD5,0XC9,0XDE,0X28,0XDD,0XE7,0XE6,0X07,

138830XEE,0X08,0XE5,0XE7,0XEE,0X07,0XE6,0X07,0XE6,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,

138840XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

138850XEE,0X27,0XEE,0X28,0XEE,0X49,0XDD,0XE9,0X8B,0X82,0X6A,0X80,0X6A,0XA2,0X62,0XA3,

138860X62,0XA3,0X62,0XA3,0X62,0XA4,0X62,0XA3,0X62,0XA3,0X62,0XA3,0X62,0XA3,0X62,0X83,

138870X62,0X43,0X83,0X69,0XE6,0XD9,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138880XFF,0XFE,0XFF,0XDB,0XB4,0XEB,0XD5,0XAA,0XE6,0X09,0XEE,0X08,0XEE,0X08,0XEE,0X08,

138890XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

138900XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

138910XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X07,

138920XEE,0X27,0XEE,0X28,0XE6,0X08,0XCD,0X47,0XA4,0X24,0X7B,0X22,0X72,0XC3,0X6A,0XE5,

138930X62,0XC6,0XBD,0XD3,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

138990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFC,

139010XF7,0X36,0XB5,0X2A,0XD6,0X09,0XDE,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X28,0XE5,0XE7,

139020XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,

139030XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,

139040XEE,0X49,0XD5,0XC9,0X8B,0X82,0X6A,0X80,0X6A,0XA2,0X62,0X82,0X62,0XA3,0X62,0XA3,

139050X62,0XA3,0X62,0XA3,0X62,0XA3,0X62,0X83,0X62,0XA4,0X5A,0X63,0X5A,0X43,0X83,0X8A,

139060XE6,0XF9,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,

139070XB4,0XEB,0XD5,0XAA,0XE6,0X09,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

139080XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

139090XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,

139100XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XEE,0X27,0XE6,0X28,

139110XE6,0X08,0XD5,0X88,0XAC,0X45,0X7B,0X22,0X72,0XC3,0X72,0XE5,0X62,0XA5,0XA4,0XF0,

139120XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139190XFF,0XFF,0XFF,0XBE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XDC,0XDE,0X93,0XBD,0X4A,

139200XDE,0X29,0XDD,0XE6,0XE6,0X07,0XE5,0XE7,0XEE,0X08,0XE5,0XE8,0XE5,0XE7,0XE6,0X07,

139210XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X27,

139220XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XE6,0X2A,0XD5,0XC9,

139230X8B,0X62,0X62,0X80,0X62,0XA2,0X62,0X82,0X62,0XA3,0X62,0X83,0X62,0XA4,0X62,0XA3,

139240X62,0XA3,0X62,0X83,0X62,0XA4,0X5A,0X63,0X5A,0X23,0X83,0X8A,0XE6,0XF9,0XFF,0XFE,

139250XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDB,0XB4,0XEB,0XCD,0X8A,

139260XE6,0X09,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

139270XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

139280XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,

139290XEE,0X08,0XEE,0X08,0XEE,0X07,0XE6,0X07,0XEE,0X27,0XE6,0X27,0XE6,0X08,0XD5,0XA8,

139300XAC,0X65,0X83,0X22,0X72,0XC3,0X6A,0XC5,0X62,0XA6,0X8C,0X2D,0XEF,0X3A,0XFF,0XFD,

139310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XBE,

139380XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XDB,0XCD,0XF0,0XC5,0X8B,0XDE,0X08,0XDD,0XE6,

139390XE6,0X07,0XE5,0XE7,0XE5,0XE7,0XE6,0X08,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,

139400XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

139410XEE,0X27,0XEE,0X27,0XE6,0X07,0XEE,0X28,0XE6,0X29,0XD5,0XC9,0X8B,0X62,0X62,0X60,

139420X62,0X82,0X62,0X82,0X62,0X83,0X62,0X83,0X62,0X83,0X62,0X83,0X62,0X83,0X62,0X83,

139430X62,0X83,0X5A,0X63,0X5A,0X23,0X83,0X8A,0XE6,0XF9,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

139440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XAC,0XCB,0XCD,0X8A,0XE6,0X09,0XEE,0X07,

139450XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

139460XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

139470XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,

139480XEE,0X07,0XE6,0X07,0XEE,0X27,0XE6,0X07,0XE6,0X08,0XDD,0XC8,0XAC,0X65,0X83,0X22,

139490X72,0XC3,0X6A,0XA4,0X62,0XA5,0X73,0X6A,0XD6,0X96,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

139500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XDE,

139570XFF,0XFE,0XFF,0XDB,0XBD,0X8E,0XCD,0XEB,0XDE,0X08,0XDD,0XE6,0XE5,0XE7,0XE5,0XE7,

139580XE5,0XC7,0XE6,0X08,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,

139590XEE,0X07,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,

139600XEE,0X07,0XEE,0X28,0XE6,0X29,0XD5,0XA9,0X83,0X42,0X62,0X60,0X62,0X61,0X62,0X83,

139610X62,0X83,0X62,0X84,0X62,0X83,0X62,0X83,0X5A,0X83,0X62,0X83,0X5A,0X63,0X5A,0X63,

139620X5A,0X43,0X83,0XAA,0XEF,0X19,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139630XFF,0XFF,0XFF,0XFC,0XAC,0XCB,0XCD,0X6A,0XE6,0X09,0XEE,0X07,0XEE,0X07,0XEE,0X07,

139640XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

139650XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

139660XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XE6,0X07,

139670XEE,0X27,0XE6,0X07,0XE6,0X08,0XDD,0XE9,0XB4,0X86,0X83,0X22,0X72,0XA2,0X6A,0XA4,

139680X62,0X85,0X62,0XE7,0XBD,0XD4,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139750XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XFE,0XFF,0XBB,

139760XB5,0X4C,0XD5,0XEB,0XDD,0XE7,0XDD,0XE6,0XDD,0XE6,0XE6,0X07,0XE5,0XC7,0XE6,0X08,

139770XE6,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,

139780XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X28,

139790XEE,0X29,0XD5,0XA9,0X83,0X42,0X62,0X60,0X62,0X61,0X62,0X83,0X5A,0X63,0X62,0X83,

139800X5A,0X63,0X5A,0X83,0X5A,0X83,0X62,0XA3,0X5A,0X62,0X5A,0X83,0X5A,0X43,0X83,0XAA,

139810XEF,0X1A,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,

139820XAC,0XEB,0XCD,0X6A,0XE6,0X09,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

139830XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

139840XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,

139850XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X07,

139860XE6,0X28,0XE5,0XE9,0XBC,0XC6,0X83,0X02,0X6A,0X82,0X6A,0X84,0X5A,0X85,0X5A,0XA6,

139870XB5,0X72,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

139940XFF,0XFE,0XFF,0XDE,0XFF,0XDE,0XFF,0XFF,0XFF,0XFE,0XEF,0X17,0XBD,0X4B,0XD5,0XCA,

139950XDD,0XE8,0XDD,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

139960XE6,0X08,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X08,0XE6,0X08,0XE6,0X08,0XE6,0X07,

139970XE6,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XE6,0X06,0XEE,0X28,0XEE,0X29,0XD5,0X89,

139980X83,0X42,0X62,0X60,0X62,0X61,0X62,0X62,0X62,0X83,0X5A,0X83,0X5A,0X83,0X5A,0X83,

139990X5A,0X83,0X5A,0X83,0X5A,0X83,0X52,0X43,0X52,0X43,0X83,0XCA,0XE7,0X3A,0XFF,0XFE,

140000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XB5,0X0C,0XC5,0X6A,

140010XE6,0X09,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140020XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140030XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140040XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X27,0XE6,0X08,0XE6,0X09,

140050XBC,0XC6,0X83,0X22,0X6A,0X83,0X62,0X43,0X62,0X85,0X52,0X45,0X9C,0XAF,0XF7,0X9B,

140060XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

140130XFF,0XFF,0XFF,0XDE,0XFF,0XFD,0XDE,0X95,0XBD,0X4A,0XD5,0XC9,0XDD,0XC8,0XE5,0XE7,

140140XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X08,0XE5,0XE8,0XE5,0XE8,0XE6,0X08,

140150XE6,0X08,0XEE,0X08,0XE6,0X08,0XE6,0X08,0XE6,0X08,0XE6,0X08,0XE6,0X27,0XE6,0X27,

140160XEE,0X27,0XEE,0X27,0XE6,0X06,0XEE,0X28,0XEE,0X29,0XD5,0X89,0X83,0X22,0X62,0X40,

140170X62,0X42,0X5A,0X62,0X5A,0X82,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X63,

140180X5A,0X83,0X52,0X43,0X52,0X63,0X83,0XEB,0XEF,0X3A,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

140190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XB5,0X0C,0XC5,0X6A,0XE6,0X09,0XEE,0X07,

140200XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140210XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140220XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140230XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X29,0XBD,0X07,0X83,0X42,

140240X62,0X62,0X62,0X44,0X62,0X65,0X4A,0X24,0X8C,0X0C,0XEF,0X39,0XFF,0XFE,0XFF,0XFF,

140250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDE,

140320XFF,0XFD,0XD6,0X13,0XBD,0X4A,0XD5,0XE9,0XDD,0XC8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

140330XE5,0XE7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE8,0XE5,0XE8,0XE6,0X08,0XE6,0X07,0XE6,0X07,

140340XE6,0X08,0XE6,0X08,0XE6,0X08,0XE6,0X08,0XE6,0X27,0XE6,0X27,0XEE,0X27,0XEE,0X27,

140350XE6,0X06,0XEE,0X27,0XEE,0X29,0XD5,0X89,0X83,0X01,0X62,0X40,0X5A,0X41,0X5A,0X62,

140360X5A,0X62,0X5A,0X62,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X52,0X43,

140370X52,0X43,0X83,0XEB,0XEF,0X3A,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140380XFF,0XFF,0XFF,0XFC,0XB5,0X0C,0XC5,0X6A,0XE6,0X09,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140390XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140400XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140410XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140420XE6,0X07,0XE6,0X07,0XEE,0X28,0XE6,0X29,0XC5,0X27,0X83,0X42,0X62,0X42,0X62,0X44,

140430X5A,0X64,0X4A,0X24,0X73,0X69,0XDE,0XB7,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XDE,0XFF,0XFE,0XFF,0XFD,0XCD,0XF2,

140510XC5,0X6A,0XD5,0XE9,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

140520XE5,0XE7,0XE5,0XE8,0XE5,0XE8,0XE5,0XE8,0XE6,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X08,

140530XE6,0X08,0XE6,0X07,0XE6,0X27,0XE6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X06,0XEE,0X07,

140540XEE,0X29,0XCD,0X69,0X7B,0X02,0X62,0X20,0X5A,0X42,0X5A,0X42,0X5A,0X62,0X5A,0X62,

140550X5A,0X63,0X5A,0X63,0X5A,0X43,0X5A,0X63,0X5A,0X63,0X52,0X43,0X52,0X23,0X8C,0X0B,

140560XEF,0X5A,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,

140570XB5,0X2D,0XC5,0X49,0XE6,0X09,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140580XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140590XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,

140600XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,

140610XEE,0X28,0XEE,0X49,0XC5,0X47,0X8B,0X63,0X62,0X41,0X5A,0X43,0X5A,0X44,0X52,0X44,

140620X62,0XE7,0XCE,0X56,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140690XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XFF,0XFE,0XFF,0XDC,0XC5,0XB0,0XC5,0X8A,0XD5,0XE8,

140700XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

140710XE5,0XE8,0XE5,0XE8,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

140720XE6,0X27,0XE6,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X06,0XEE,0X07,0XEE,0X4A,0XCD,0X48,

140730X7A,0XE1,0X62,0X20,0X5A,0X41,0X5A,0X42,0X5A,0X42,0X5A,0X42,0X5A,0X43,0X5A,0X43,

140740X5A,0X43,0X5A,0X43,0X5A,0X43,0X52,0X43,0X52,0X23,0X8C,0X0B,0XEF,0X5B,0XFF,0XFE,

140750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XBD,0X4D,0XC5,0X49,

140760XE6,0X09,0XE6,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140770XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140780XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,

140790XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X27,0XE6,0X29,

140800XCD,0X68,0X8B,0X63,0X5A,0X21,0X5A,0X23,0X5A,0X44,0X52,0X44,0X5A,0X86,0XC5,0XF4,

140810XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140880XFF,0XFF,0XFF,0XDD,0XFF,0XDB,0XBD,0X4E,0XCD,0XCA,0XD5,0XE8,0XE5,0XC7,0XE5,0XC7,

140890XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE8,

140900XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X27,0XE6,0X27,

140910XEE,0X27,0XEE,0X27,0XEE,0X27,0XE6,0X07,0XEE,0X4A,0XCD,0X48,0X7A,0XE2,0X62,0X20,

140920X5A,0X21,0X5A,0X42,0X5A,0X42,0X5A,0X42,0X5A,0X43,0X5A,0X43,0X5A,0X43,0X5A,0X43,

140930X52,0X43,0X52,0X43,0X4A,0X03,0X8C,0X0C,0XEF,0X5B,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

140940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XBD,0X4D,0XC5,0X49,0XE6,0X09,0XE6,0X08,

140950XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140960XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140970XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

140980XEE,0X27,0XEE,0X27,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X29,0XD5,0XA9,0X83,0X42,

140990X5A,0X00,0X5A,0X23,0X5A,0X23,0X52,0X24,0X4A,0X24,0XB5,0X72,0XFF,0XBD,0XFF,0XFF,

141000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,

141070XFF,0X99,0XB5,0X0C,0XD5,0XCA,0XDD,0XC8,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,

141080XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE6,0X07,

141090XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,

141100XEE,0X27,0XEE,0X07,0XEE,0X6A,0XCD,0X48,0X7A,0XE1,0X62,0X20,0X5A,0X21,0X5A,0X22,

141110X5A,0X42,0X5A,0X42,0X5A,0X43,0X5A,0X23,0X5A,0X22,0X52,0X22,0X52,0X23,0X52,0X43,

141120X4A,0X03,0X8C,0X0C,0XEF,0X5B,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141130XFF,0XFF,0XFF,0XDC,0XBD,0X6E,0XC5,0X49,0XE6,0X09,0XE6,0X08,0XEE,0X07,0XEE,0X07,

141140XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

141150XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,

141160XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X28,

141170XEE,0X27,0XE6,0X07,0XE6,0X07,0XE6,0X29,0XD5,0XC9,0X83,0X42,0X5A,0X21,0X5A,0X02,

141180X52,0X23,0X4A,0X03,0X42,0X03,0X9C,0XCF,0XF7,0X7C,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XF7,0X58,0XB5,0X2C,

141260XD5,0XCA,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE8,

141270XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,

141280XE6,0X07,0XE6,0X07,0XE6,0X08,0XE6,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,

141290XF6,0X6A,0XCD,0X48,0X7A,0XE2,0X62,0X20,0X5A,0X21,0X5A,0X22,0X5A,0X42,0X5A,0X42,

141300X5A,0X43,0X5A,0X23,0X5A,0X22,0X52,0X22,0X52,0X22,0X52,0X43,0X52,0X03,0X8C,0X0C,

141310XEF,0X5B,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,

141320XBD,0X6E,0XC5,0X49,0XE6,0X09,0XE6,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

141330XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

141340XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

141350XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,0XE6,0X27,

141360XE6,0X27,0XE6,0X49,0XD5,0XC9,0X83,0X62,0X62,0X41,0X51,0XE2,0X52,0X03,0X49,0XE3,

141370X41,0XE3,0X8C,0X4E,0XF7,0X7C,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XEE,0XF6,0XBD,0X6C,0XD5,0XC9,0XDD,0XC7,

141450XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,

141460XE5,0XE7,0XE5,0XE8,0XE6,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

141470XE6,0X08,0XE6,0X28,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XCD,0X48,

141480X7A,0XC1,0X62,0X20,0X5A,0X01,0X5A,0X22,0X52,0X22,0X52,0X22,0X52,0X23,0X52,0X23,

141490X52,0X22,0X52,0X22,0X52,0X23,0X52,0X23,0X4A,0X03,0X8C,0X2D,0XF7,0X7C,0XFF,0XFF,

141500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XBD,0X4E,0XC5,0X49,

141510XE6,0X09,0XE6,0X08,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

141520XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

141530XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

141540XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X27,0XE6,0X27,0XE6,0X49,

141550XDD,0XE9,0X8B,0X83,0X5A,0X21,0X52,0X02,0X52,0X03,0X4A,0X03,0X41,0XE3,0X7B,0XAB,

141560XEF,0X5B,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141630XFF,0XFF,0XFF,0XFC,0XDE,0X94,0XBD,0X4B,0XD5,0XC9,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,

141640XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE8,

141650XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X28,

141660XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XCD,0X48,0X7A,0XC1,0X5A,0X20,

141670X5A,0X21,0X52,0X02,0X52,0X22,0X52,0X22,0X52,0X23,0X52,0X23,0X52,0X22,0X52,0X22,

141680X52,0X23,0X52,0X23,0X4A,0X03,0X94,0X2D,0XF7,0X5C,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XBD,0X4E,0XC5,0X49,0XE6,0X09,0XEE,0X08,

141700XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

141710XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

141720XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

141730XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XE6,0X27,0XE6,0X29,0XDD,0XEA,0X8B,0X63,

141740X5A,0X20,0X51,0XE2,0X49,0XE2,0X4A,0X03,0X41,0XC3,0X6B,0X29,0XEF,0X3A,0XFF,0XDE,

141750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,

141820XD6,0X32,0XBD,0X2A,0XD5,0XC9,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,

141830XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE8,0XE6,0X07,0XE6,0X07,

141840XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X27,0XEE,0X07,0XEE,0X07,

141850XEE,0X27,0XE6,0X28,0XEE,0X4A,0XCD,0X48,0X72,0XC1,0X5A,0X00,0X5A,0X01,0X52,0X02,

141860X52,0X22,0X52,0X22,0X52,0X23,0X52,0X23,0X52,0X22,0X52,0X22,0X52,0X23,0X52,0X23,

141870X4A,0X03,0X94,0X4D,0XF7,0X7C,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141880XFF,0XFF,0XFF,0XDC,0XBD,0X4E,0XC5,0X49,0XE6,0X09,0XEE,0X07,0XEE,0X07,0XEE,0X07,

141890XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

141900XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

141910XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

141920XEE,0X27,0XEE,0X27,0XE6,0X27,0XE6,0X29,0XE6,0X2A,0X8B,0X83,0X5A,0X20,0X51,0XE1,

141930X49,0XC2,0X4A,0X03,0X41,0XE3,0X5A,0XA7,0XE6,0XFA,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

141940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

141990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFB,0XCD,0XF0,0XBD,0X4A,

142010XDD,0XC9,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE8,

142020XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE8,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

142030XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,

142040XEE,0X4A,0XC5,0X28,0X72,0XC1,0X5A,0X00,0X52,0X02,0X52,0X02,0X52,0X22,0X52,0X22,

142050X52,0X23,0X52,0X23,0X52,0X22,0X52,0X22,0X52,0X22,0X52,0X03,0X4A,0X03,0X94,0X4E,

142060XF7,0X7C,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,

142070XBD,0X6E,0XC5,0X29,0XE6,0X09,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

142080XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

142090XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,

142100XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

142110XEE,0X27,0XE6,0X48,0XE6,0X2B,0X8B,0XA3,0X5A,0X00,0X51,0XE1,0X49,0XE2,0X4A,0X03,

142120X41,0XE3,0X4A,0X46,0XDE,0XD9,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142190XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDB,0XC5,0XAF,0XC5,0X4A,0XDD,0XC8,0XDD,0XC7,

142200XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,

142210XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

142220XE6,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XC5,0X28,

142230X72,0XA1,0X5A,0X00,0X52,0X01,0X52,0X02,0X52,0X22,0X52,0X22,0X52,0X23,0X52,0X03,

142240X52,0X02,0X52,0X22,0X52,0X22,0X4A,0X03,0X4A,0X03,0X94,0X4E,0XF7,0X9C,0XFF,0XFF,

142250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XC5,0X6E,0XBD,0X29,

142260XE6,0X09,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

142270XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

142280XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

142290XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XE6,0X48,

142300XDE,0X2A,0X93,0XC3,0X5A,0X00,0X49,0XC1,0X49,0XE2,0X49,0XE2,0X41,0XE3,0X4A,0X25,

142310XDE,0X98,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142380XFF,0XDE,0XFF,0XDB,0XC5,0XAE,0XC5,0X6A,0XDD,0XC8,0XDD,0XA7,0XE5,0XC7,0XE5,0XC7,

142390XE5,0XC7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

142400XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

142410XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XC5,0X28,0X72,0XA1,0X52,0X00,

142420X52,0X02,0X52,0X02,0X52,0X22,0X52,0X02,0X4A,0X03,0X52,0X03,0X52,0X02,0X52,0X02,

142430X52,0X22,0X4A,0X03,0X4A,0X03,0X94,0X4E,0XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XC5,0X8E,0XBD,0X29,0XE6,0X09,0XEE,0X08,

142450XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

142460XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

142470XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

142480XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XE6,0X48,0XDE,0X2A,0X93,0XE4,

142490X5A,0X00,0X49,0XC0,0X49,0XE2,0X41,0XC2,0X41,0XC2,0X4A,0X04,0XCE,0X57,0XFF,0XDE,

142500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XDB,

142570XC5,0XAE,0XC5,0X6A,0XDD,0XC8,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,

142580XE5,0XE8,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

142590XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,

142600XEE,0X27,0XEE,0X28,0XEE,0X6A,0XBD,0X08,0X6A,0XA1,0X52,0X00,0X52,0X01,0X52,0X02,

142610X52,0X02,0X4A,0X02,0X4A,0X03,0X4A,0X03,0X52,0X02,0X52,0X02,0X52,0X02,0X4A,0X02,

142620X4A,0X03,0X94,0X6E,0XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142630XFF,0XFF,0XFF,0XFC,0XC5,0X8F,0XBD,0X29,0XE6,0X09,0XEE,0X27,0XEE,0X07,0XEE,0X07,

142640XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

142650XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

142660XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X07,0XEE,0X07,0XEE,0X27,

142670XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XE6,0X2A,0X93,0XE4,0X5A,0X00,0X49,0XA0,

142680X49,0XE2,0X41,0XC2,0X41,0XC2,0X41,0XE4,0XC5,0XF5,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,

142690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XDB,0XC5,0X8E,0XC5,0X6A,

142760XDD,0XC8,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE8,0XE5,0XE8,

142770XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

142780XE6,0X07,0XE6,0X07,0XEE,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,

142790XEE,0X6A,0XBD,0X08,0X6A,0XA1,0X52,0X00,0X52,0X02,0X4A,0X02,0X52,0X22,0X4A,0X02,

142800X4A,0X03,0X4A,0X03,0X52,0X02,0X52,0X02,0X52,0X02,0X4A,0X02,0X4A,0X03,0X94,0X6E,

142810XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDC,

142820XC5,0X8F,0XBD,0X29,0XE6,0X29,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

142830XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X07,

142840XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

142850XEE,0X07,0XEE,0X07,0XF6,0X28,0XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

142860XEE,0X27,0XEE,0X28,0XE6,0X2A,0X93,0XE4,0X5A,0X00,0X49,0XA0,0X49,0XC1,0X41,0XC2,

142870X41,0XE3,0X39,0XA3,0XBD,0X94,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

142940XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0X9A,0XC5,0X6D,0XCD,0X8A,0XD5,0XC8,0XDD,0XE7,

142950XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

142960XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

142970XE6,0X07,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XBD,0X07,

142980X6A,0X81,0X52,0X01,0X52,0X02,0X4A,0X02,0X52,0X22,0X4A,0X22,0X49,0XE3,0X49,0XE3,

142990X52,0X02,0X4A,0X01,0X4A,0X02,0X49,0XE2,0X4A,0X04,0X94,0X6E,0XF7,0X9D,0XFF,0XFF,

143000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XC5,0X8E,0XBD,0X29,

143010XEE,0X2A,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

143020XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

143030XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X28,0XEE,0X28,

143040XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X48,

143050XE6,0X2A,0X93,0XE3,0X52,0X00,0X49,0XC1,0X49,0XC2,0X41,0XA2,0X49,0XE3,0X31,0X82,

143060XAD,0X12,0XFF,0XDD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

143130XFF,0XDD,0XF7,0X7A,0XBD,0X4D,0XCD,0X8A,0XD5,0XA7,0XDD,0XC6,0XDD,0XC7,0XE5,0XC7,

143140XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

143150XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,

143160XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X28,0XEE,0X49,0XBD,0X07,0X6A,0X81,0X51,0XE1,

143170X52,0X02,0X4A,0X02,0X52,0X22,0X4A,0X22,0X49,0XE3,0X49,0XE3,0X52,0X02,0X4A,0X01,

143180X4A,0X02,0X49,0XE2,0X4A,0X04,0X94,0X6E,0XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XC5,0X8F,0XBD,0X29,0XEE,0X2A,0XEE,0X28,

143200XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

143210XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

143220XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X27,

143230XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XE6,0X2A,0X93,0XE3,

143240X52,0X00,0X49,0XC1,0X49,0XC2,0X41,0XA2,0X41,0XE3,0X31,0X62,0XA4,0XF1,0XFF,0XDD,

143250XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XF7,0X39,

143320XBD,0X4D,0XCD,0X8A,0XD5,0XC8,0XDD,0XC6,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,

143330XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

143340XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,

143350XEE,0X27,0XEE,0X28,0XEE,0X4A,0XBD,0X07,0X6A,0X81,0X51,0XE1,0X52,0X02,0X4A,0X02,

143360X4A,0X02,0X4A,0X22,0X49,0XE3,0X49,0XE3,0X52,0X02,0X4A,0X01,0X49,0XE2,0X49,0XE2,

143370X4A,0X03,0X94,0X6E,0XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143380XFF,0XFF,0XFF,0XFC,0XBD,0X8E,0XBD,0X29,0XEE,0X2A,0XEE,0X28,0XEE,0X28,0XEE,0X27,

143390XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

143400XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

143410XEE,0X08,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

143420XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X48,0XE6,0X2A,0X93,0XE4,0X5A,0X00,0X49,0XC2,

143430X49,0XC2,0X41,0XC2,0X41,0XC3,0X31,0X62,0XA4,0XB0,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,

143440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XEF,0X39,0XBD,0X2C,0XCD,0X8A,

143510XD5,0XC8,0XDD,0XC6,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

143520XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

143530XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X28,

143540XEE,0X4A,0XBD,0X07,0X6A,0X61,0X51,0XE1,0X52,0X02,0X4A,0X02,0X4A,0X02,0X4A,0X02,

143550X49,0XE3,0X49,0XE3,0X52,0X02,0X4A,0X01,0X49,0XE1,0X49,0XE2,0X49,0XE3,0X94,0X6E,

143560XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,

143570XBD,0X8E,0XC5,0X49,0XEE,0X2A,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,

143580XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

143590XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

143600XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

143610XEE,0X47,0XEE,0X48,0XE6,0X2A,0X9C,0X04,0X5A,0X20,0X49,0XE2,0X49,0XC2,0X41,0XE3,

143620X41,0XC3,0X31,0X82,0X9C,0X90,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143690XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XEF,0X18,0XB5,0X2C,0XCD,0X8A,0XD5,0XC8,0XDD,0XC6,

143700XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

143710XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

143720XE6,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XBD,0X07,

143730X6A,0X61,0X51,0XE1,0X52,0X02,0X4A,0X02,0X4A,0X02,0X4A,0X02,0X49,0XE3,0X49,0XE3,

143740X52,0X02,0X4A,0X01,0X49,0XE1,0X49,0XE2,0X49,0XE3,0X9C,0X6E,0XF7,0X9D,0XFF,0XFF,

143750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XBD,0X6E,0XC5,0X49,

143760XEE,0X2A,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

143770XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

143780XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,

143790XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XEE,0X48,

143800XE6,0X2A,0X9C,0X04,0X5A,0X20,0X49,0XC2,0X49,0XC2,0X41,0XE3,0X41,0XC3,0X39,0X82,

143810X9C,0X90,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

143880XFF,0XDE,0XEE,0XF8,0XB5,0X0C,0XCD,0X8A,0XD5,0XC8,0XDD,0XC6,0XDD,0XC7,0XE5,0XC7,

143890XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

143900XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,

143910XEE,0X08,0XEE,0X08,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XBC,0XE7,0X6A,0X60,0X51,0XE1,

143920X52,0X02,0X4A,0X02,0X4A,0X02,0X4A,0X02,0X49,0XE3,0X4A,0X03,0X52,0X02,0X52,0X01,

143930X49,0XE1,0X49,0XE2,0X49,0XE3,0X9C,0X6F,0XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

143940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XBD,0X6E,0XC5,0X4A,0XEE,0X2A,0XEE,0X28,

143950XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

143960XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

143970XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X27,

143980XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X47,0XEE,0X48,0XEE,0X48,0XE6,0X2A,0X9C,0X04,

143990X5A,0X21,0X49,0XC1,0X49,0XC2,0X49,0XC3,0X41,0XC2,0X39,0X82,0X9C,0X90,0XFF,0XBD,

144000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XEE,0XF8,

144070XB5,0X2C,0XCD,0X8A,0XD5,0XC8,0XDD,0XC6,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,

144080XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

144090XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X08,0XEE,0X07,

144100XEE,0X27,0XEE,0X28,0XEE,0X4A,0XBC,0XE7,0X6A,0X60,0X51,0XE0,0X52,0X02,0X4A,0X02,

144110X4A,0X02,0X4A,0X02,0X49,0XE3,0X4A,0X03,0X52,0X01,0X52,0X01,0X49,0XE1,0X49,0XE2,

144120X49,0XE3,0X9C,0X6F,0XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144130XFF,0XFF,0XFF,0XFC,0XBD,0X6E,0XC5,0X4A,0XEE,0X2A,0XEE,0X28,0XEE,0X28,0XEE,0X28,

144140XEE,0X28,0XEE,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,

144150XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,

144160XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X28,

144170XEE,0X47,0XF6,0X48,0XF6,0X48,0XEE,0X49,0XE6,0X0A,0X9B,0XE4,0X62,0X41,0X49,0XC1,

144180X49,0XE2,0X49,0XC3,0X41,0XC2,0X39,0XA3,0X9C,0X90,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,

144190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XEE,0XF8,0XB5,0X2C,0XCD,0X8A,

144260XD5,0XC8,0XDD,0XC6,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

144270XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

144280XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X28,

144290XEE,0X4A,0XBC,0XE7,0X6A,0X60,0X51,0XE0,0X52,0X02,0X4A,0X02,0X52,0X22,0X4A,0X02,

144300X49,0XE3,0X4A,0X02,0X52,0X01,0X52,0X01,0X49,0XE1,0X49,0XE2,0X49,0XC3,0X9C,0X6F,

144310XF7,0X9D,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,

144320XBD,0X6E,0XC5,0X4A,0XEE,0X2A,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X47,

144330XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,

144340XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,

144350XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XEE,0X28,0XEE,0X47,0XF6,0X48,0XF6,0X48,

144360XF6,0X48,0XEE,0X49,0XE6,0X0A,0X9B,0XE4,0X62,0X41,0X49,0XC1,0X49,0XE3,0X49,0XE3,

144370X41,0XC2,0X39,0XA3,0X9C,0X90,0XFF,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144440XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XEE,0XF8,0XB5,0X2C,0XCD,0X8A,0XDD,0XE8,0XDD,0XC7,

144450XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

144460XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

144470XEE,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X2A,0XBC,0XE7,

144480X62,0X60,0X52,0X00,0X52,0X02,0X52,0X22,0X4A,0X02,0X4A,0X02,0X49,0XE2,0X4A,0X02,

144490X52,0X02,0X4A,0X01,0X49,0XE1,0X4A,0X02,0X49,0XE3,0X9C,0X6F,0XF7,0X9D,0XFF,0XFF,

144500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XBD,0X6E,0XC5,0X4A,

144510XEE,0X2A,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X28,0XEE,0X47,0XF6,0X27,0XF6,0X27,

144520XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,

144530XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,

144540XF6,0X48,0XEE,0X27,0XEE,0X47,0XEE,0X47,0XF6,0X48,0XEE,0X47,0XF6,0X68,0XF6,0X69,

144550XE6,0X09,0X9B,0XE4,0X62,0X61,0X51,0XE2,0X49,0XE2,0X4A,0X03,0X41,0XE3,0X39,0XA2,

144560X9C,0XB0,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

144630XFF,0XDE,0XEE,0XF8,0XB5,0X2C,0XCD,0X8A,0XDD,0XC8,0XDD,0XC7,0XDD,0XC7,0XE5,0XC7,

144640XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

144650XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,

144660XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X2A,0XBC,0XE7,0X6A,0X60,0X52,0X01,

144670X52,0X02,0X52,0X22,0X4A,0X02,0X4A,0X02,0X49,0XE2,0X4A,0X02,0X52,0X02,0X4A,0X01,

144680X49,0XE1,0X4A,0X02,0X49,0XE3,0X9C,0X6F,0XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XBD,0X6E,0XC5,0X4A,0XEE,0X2A,0XEE,0X48,

144700XEE,0X28,0XEE,0X28,0XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

144710XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

144720XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X28,0XF6,0X48,0XF6,0X27,

144730XEE,0X47,0XEE,0X47,0XF6,0X48,0XEE,0X47,0XF6,0X68,0XF6,0X69,0XDD,0XE9,0X9B,0XE4,

144740X62,0X62,0X51,0XE2,0X52,0X03,0X4A,0X03,0X49,0XE3,0X41,0XC3,0X9C,0XB0,0XFF,0XBD,

144750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XEE,0XD8,

144820XB5,0X0C,0XCD,0X8A,0XD5,0XC8,0XDD,0XC7,0XDD,0XC7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,

144830XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

144840XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

144850XEE,0X27,0XEE,0X28,0XEE,0X4A,0XBC,0XC7,0X6A,0X60,0X52,0X00,0X51,0XE1,0X4A,0X02,

144860X4A,0X02,0X4A,0X22,0X4A,0X02,0X52,0X02,0X52,0X02,0X4A,0X01,0X4A,0X02,0X4A,0X03,

144870X49,0XE3,0X9C,0X8F,0XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144880XFF,0XFF,0XFF,0XFC,0XBD,0X6E,0XC5,0X4A,0XEE,0X2A,0XEE,0X48,0XEE,0X28,0XEE,0X28,

144890XEE,0X47,0XEE,0X47,0XF6,0X27,0XF6,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

144900XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

144910XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X48,0XF6,0X27,0XF6,0X48,0XEE,0X47,

144920XF6,0X48,0XF6,0X47,0XF6,0X68,0XF6,0X69,0XDD,0XC8,0X9B,0XE4,0X6A,0X62,0X51,0XE1,

144930X52,0X03,0X4A,0X03,0X4A,0X03,0X41,0XC3,0XA4,0XD0,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,

144940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

144990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145000XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XEE,0XF8,0XB5,0X2C,0XCD,0X8A,

145010XD5,0XA8,0XDD,0XC7,0XDD,0XC7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,

145020XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

145030XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X28,

145040XEE,0X4A,0XBC,0XC7,0X6A,0X80,0X52,0X00,0X51,0XE1,0X4A,0X02,0X4A,0X02,0X4A,0X22,

145050X52,0X02,0X52,0X02,0X52,0X02,0X52,0X01,0X4A,0X02,0X4A,0X03,0X49,0XE3,0X9C,0X8F,

145060XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,

145070XBD,0X6E,0XC5,0X4A,0XEE,0X2A,0XEE,0X48,0XEE,0X28,0XEE,0X47,0XEE,0X47,0XEE,0X47,

145080XF6,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

145090XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

145100XF6,0X27,0XF6,0X27,0XF6,0X48,0XF6,0X27,0XF6,0X47,0XEE,0X47,0XF6,0X48,0XF6,0X47,

145110XF6,0X68,0XF6,0X69,0XD5,0XA8,0X9B,0XE4,0X6A,0X41,0X51,0XE1,0X52,0X02,0X49,0XE2,

145120X4A,0X03,0X41,0XC3,0XA4,0XF1,0XFF,0XBD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145190XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XEF,0X18,0XBD,0X4D,0XCD,0X8A,0XD5,0XA8,0XDD,0XC7,

145200XDD,0XC7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

145210XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

145220XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X48,0XEE,0X4A,0XB4,0XC7,

145230X6A,0X80,0X52,0X00,0X51,0XE1,0X4A,0X02,0X4A,0X02,0X4A,0X22,0X52,0X02,0X52,0X02,

145240X52,0X02,0X52,0X01,0X4A,0X02,0X4A,0X03,0X49,0XE3,0X9C,0X8F,0XF7,0X9D,0XFF,0XFF,

145250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XBD,0X6E,0XC5,0X4A,

145260XEE,0X2A,0XEE,0X48,0XEE,0X28,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,

145270XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

145280XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

145290XF6,0X47,0XF6,0X27,0XF6,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X69,

145300XD5,0XA8,0X9B,0XE5,0X6A,0X41,0X51,0XE2,0X52,0X23,0X4A,0X03,0X4A,0X03,0X41,0XC3,

145310XAD,0X32,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

145380XFF,0XDE,0XF7,0X39,0XBD,0X6D,0XCD,0X8A,0XD5,0XA8,0XDD,0XC7,0XDD,0XC7,0XDD,0XC7,

145390XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

145400XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X27,

145410XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X48,0XEE,0X4A,0XB4,0XC7,0X6A,0X80,0X52,0X00,

145420X52,0X01,0X52,0X22,0X4A,0X02,0X4A,0X22,0X52,0X02,0X52,0X22,0X52,0X02,0X52,0X22,

145430X4A,0X02,0X4A,0X03,0X49,0XE3,0X9C,0X8F,0XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XBD,0X6E,0XC5,0X4A,0XEE,0X2A,0XEE,0X48,

145450XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X27,

145460XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

145470XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X27,

145480XF6,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X69,0XD5,0XA8,0X9B,0XE4,

145490X6A,0X62,0X5A,0X22,0X5A,0X43,0X52,0X23,0X4A,0X03,0X4A,0X04,0XB5,0X93,0XFF,0XDD,

145500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDE,0XFF,0X5A,

145570XC5,0X8E,0XC5,0X8A,0XD5,0XC8,0XDD,0XC7,0XDD,0XC7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,

145580XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

145590XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

145600XEE,0X27,0XEE,0X28,0XEE,0X2A,0XB4,0XC7,0X6A,0X60,0X52,0X00,0X52,0X01,0X52,0X22,

145610X52,0X22,0X52,0X22,0X52,0X02,0X52,0X22,0X52,0X22,0X52,0X22,0X52,0X02,0X4A,0X03,

145620X49,0XE3,0X9C,0X8F,0XF7,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145630XFF,0XFF,0XFF,0XFC,0XBD,0X6E,0XC5,0X4A,0XEE,0X29,0XEE,0X48,0XEE,0X47,0XEE,0X47,

145640XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X27,

145650XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X47,

145660XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,

145670XF6,0X67,0XF6,0X47,0XF6,0X67,0XF6,0X69,0XD5,0X88,0X9B,0XE4,0X6A,0X62,0X5A,0X43,

145680X5A,0X43,0X52,0X44,0X4A,0X03,0X52,0X45,0XC5,0XD5,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

145690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0X7A,0XCD,0XAF,0XC5,0X6A,

145760XD5,0XC8,0XDD,0XE7,0XDD,0XC7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,

145770XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

145780XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,

145790XEE,0X2A,0XB4,0XC7,0X6A,0X60,0X52,0X00,0X52,0X01,0X52,0X22,0X52,0X22,0X52,0X22,

145800X52,0X02,0X52,0X22,0X52,0X22,0X52,0X22,0X52,0X02,0X4A,0X03,0X49,0XE3,0X9C,0X8F,

145810XFF,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,

145820XBD,0X6E,0XC5,0X4A,0XEE,0X29,0XEE,0X48,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

145830XF6,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X47,

145840XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

145850XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X47,

145860XF6,0X67,0XEE,0X68,0XD5,0X88,0X9B,0XE4,0X6A,0X82,0X62,0X63,0X5A,0X43,0X52,0X63,

145870X4A,0X03,0X52,0X85,0XCE,0X16,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

145940XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0X9B,0XC5,0XAF,0XC5,0X8B,0XD5,0XC8,0XDD,0XC7,

145950XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,

145960XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,

145970XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X28,0XEE,0X4A,0XB4,0XA6,

145980X6A,0X60,0X5A,0X00,0X52,0X01,0X52,0X22,0X52,0X22,0X52,0X22,0X52,0X23,0X52,0X22,

145990X52,0X22,0X52,0X22,0X52,0X02,0X49,0XE2,0X4A,0X03,0X9C,0X8F,0XFF,0X9D,0XFF,0XFF,

146000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XC5,0X8E,0XC5,0X49,

146010XEE,0X4A,0XEE,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

146020XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,

146030XF6,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

146040XF6,0X48,0XF6,0X68,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XEE,0X47,0XF6,0X88,0XEE,0X68,

146050XD5,0X87,0X9C,0X04,0X6A,0X81,0X6A,0X83,0X5A,0X63,0X5A,0X84,0X52,0X64,0X5A,0XA6,

146060XD6,0X97,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146130XFF,0XFF,0XFF,0XBC,0XC5,0XAF,0XC5,0X6B,0XD5,0XC8,0XDD,0XC7,0XDD,0XC7,0XE5,0XC7,

146140XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

146150XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,

146160XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X28,0XEE,0X4A,0XB4,0XA6,0X6A,0X60,0X5A,0X00,

146170X52,0X01,0X52,0X22,0X52,0X22,0X52,0X22,0X52,0X23,0X52,0X23,0X52,0X22,0X52,0X22,

146180X52,0X02,0X51,0XE2,0X4A,0X03,0X9C,0X8F,0XFF,0X9D,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

146190XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDC,0XC5,0X8E,0XC5,0X49,0XEE,0X4A,0XEE,0X48,

146200XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

146210XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,

146220XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,

146230XF6,0X47,0XF6,0X47,0XF6,0X68,0XEE,0X47,0XF6,0X88,0XEE,0X68,0XD5,0X87,0X9B,0XE4,

146240X6A,0X81,0X6A,0XA3,0X62,0X83,0X5A,0X84,0X52,0X64,0X5A,0XC6,0XDE,0XB8,0XFF,0XFE,

146250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XBC,

146320XCD,0XCF,0XC5,0X6A,0XDD,0XC9,0XDD,0XA7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,

146330XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,

146340XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

146350XEE,0X47,0XEE,0X28,0XEE,0X4A,0XB4,0XA6,0X6A,0X60,0X5A,0X00,0X52,0X01,0X52,0X22,

146360X52,0X22,0X52,0X22,0X52,0X23,0X52,0X23,0X52,0X22,0X52,0X22,0X52,0X02,0X52,0X02,

146370X4A,0X03,0X9C,0X8F,0XFF,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146380XFF,0XFF,0XFF,0XDC,0XC5,0X8E,0XC5,0X49,0XEE,0X4A,0XEE,0X48,0XF6,0X48,0XF6,0X47,

146390XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

146400XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,

146410XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X68,0XF6,0X48,

146420XFE,0X88,0XEE,0X47,0XF6,0X88,0XEE,0X48,0XD5,0X87,0X9B,0XE3,0X72,0XA2,0X6A,0XA3,

146430X62,0XA4,0X62,0XA4,0X52,0X64,0X63,0X07,0XE6,0XF9,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

146440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDC,0XCD,0XF0,0XBD,0X29,

146510XDD,0XC9,0XDD,0XA7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,

146520XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

146530XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X28,

146540XEE,0X4A,0XB4,0XA6,0X6A,0X60,0X5A,0X21,0X52,0X01,0X52,0X22,0X52,0X22,0X52,0X22,

146550X52,0X23,0X52,0X23,0X52,0X22,0X52,0X22,0X52,0X22,0X51,0XE2,0X4A,0X03,0X9C,0X8F,

146560XFF,0X9D,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,

146570XC5,0X8E,0XC5,0X49,0XEE,0X4A,0XEE,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

146580XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

146590XF6,0X47,0XF6,0X47,0XEE,0X47,0XEE,0X47,0XEE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

146600XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X68,0XF6,0X48,0XFE,0X88,0XEE,0X47,

146610XF6,0X88,0XEE,0X48,0XCD,0X87,0X93,0XC3,0X72,0XA2,0X72,0XC4,0X6A,0XC4,0X62,0XC5,

146620X5A,0X84,0X73,0X89,0XEF,0X3A,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146690XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDC,0XD6,0X31,0XBD,0X29,0XD5,0XC9,0XDD,0XC8,

146700XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

146710XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,

146720XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XB4,0XA6,

146730X6A,0X80,0X5A,0X21,0X52,0X02,0X52,0X42,0X52,0X22,0X52,0X22,0X52,0X23,0X52,0X23,

146740X52,0X22,0X52,0X22,0X52,0X22,0X52,0X03,0X52,0X04,0X9C,0X8E,0XFF,0X9D,0XFF,0XDF,

146750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XC5,0X8E,0XC5,0X49,

146760XEE,0X2A,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

146770XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

146780XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

146790XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X48,0XF6,0X88,0XF6,0X68,0XF6,0X68,0XEE,0X48,

146800XCD,0X87,0X93,0XA2,0X7A,0XE2,0X72,0XC4,0X72,0XE4,0X6A,0XE5,0X5A,0XA5,0X8C,0X2C,

146810XEF,0X3A,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

146870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

146880XFF,0XDE,0XFF,0XDC,0XDE,0X92,0XBD,0X29,0XD5,0XA9,0XDD,0XC8,0XDD,0XC7,0XE5,0XC7,

146890XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

146900XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,

146910XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XB4,0XA6,0X6A,0X80,0X5A,0X21,

146920X52,0X02,0X5A,0X42,0X52,0X22,0X52,0X22,0X52,0X23,0X52,0X23,0X52,0X22,0X52,0X22,

146930X52,0X23,0X52,0X03,0X52,0X04,0X9C,0X6E,0XFF,0X9D,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

146940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XC5,0X8E,0XC5,0X49,0XEE,0X2A,0XF6,0X48,

146950XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

146960XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

146970XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,

146980XF6,0X68,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XEE,0X48,0XCD,0X67,0X93,0X82,

146990X7B,0X02,0X72,0XE4,0X72,0XE4,0X6A,0XC4,0X5A,0XA5,0X9C,0XCE,0XF7,0X5B,0XFF,0XFE,

147000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDC,

147070XEE,0XF5,0XBD,0X4A,0XD5,0XA9,0XDD,0XC8,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,

147080XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

147090XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,

147100XEE,0X27,0XEE,0X28,0XEE,0X4B,0XB4,0XA6,0X6A,0X81,0X5A,0X21,0X5A,0X22,0X5A,0X43,

147110X52,0X42,0X52,0X22,0X52,0X23,0X52,0X23,0X52,0X22,0X52,0X22,0X52,0X43,0X52,0X03,

147120X52,0X04,0X9C,0X6E,0XFF,0X9D,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147130XFF,0XFE,0XFF,0XFC,0XC5,0X8E,0XC5,0X49,0XEE,0X2A,0XF6,0X48,0XF6,0X48,0XF6,0X48,

147140XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X28,0XF6,0X28,0XF6,0X48,0XF6,0X48,

147150XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

147160XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X68,0XF6,0X48,0XF6,0X48,

147170XF6,0X48,0XF6,0X68,0XF6,0X68,0XEE,0X48,0XCD,0X67,0X8B,0X61,0X7B,0X03,0X7B,0X04,

147180X73,0X05,0X6A,0XE4,0X62,0XC5,0XAD,0X30,0XF7,0X9C,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147250XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XBE,0XFF,0XDD,0XF7,0X37,0XC5,0X6C,

147260XD5,0XA9,0XDD,0XC7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,

147270XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

147280XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,

147290XEE,0X4B,0XB4,0XA6,0X6A,0X81,0X5A,0X21,0X5A,0X22,0X5A,0X43,0X5A,0X42,0X52,0X22,

147300X52,0X23,0X52,0X23,0X52,0X22,0X52,0X23,0X52,0X43,0X52,0X03,0X52,0X04,0X9C,0X6E,

147310XFF,0X9D,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,

147320XC5,0X8E,0XC5,0X49,0XEE,0X2A,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,

147330XF6,0X47,0XF6,0X47,0XF6,0X28,0XF6,0X28,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

147340XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

147350XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X68,0XF6,0X48,0XF6,0X68,0XF6,0X47,0XF6,0X88,

147360XF6,0X47,0XEE,0X48,0XCD,0X67,0X8B,0X61,0X83,0X23,0X7B,0X24,0X7B,0X45,0X73,0X05,

147370X62,0XE5,0XBD,0X92,0XFF,0XBC,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147440XFF,0XFF,0XFF,0XFE,0XFF,0XBE,0XFF,0XDD,0XFF,0XB9,0XBD,0X6D,0XCD,0XA9,0XDD,0XC7,

147450XDD,0XC7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE8,

147460XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,

147470XE6,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XB4,0XC6,

147480X6A,0X80,0X62,0X41,0X5A,0X22,0X5A,0X42,0X5A,0X42,0X52,0X43,0X52,0X43,0X52,0X43,

147490X5A,0X43,0X52,0X43,0X52,0X43,0X52,0X23,0X52,0X04,0X9C,0X4E,0XF7,0X7C,0XFF,0XFF,

147500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XC5,0X8F,0XC5,0X49,

147510XEE,0X4A,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,

147520XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

147530XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X47,

147540XF6,0X48,0XFE,0X68,0XF6,0X48,0XF6,0X68,0XEE,0X27,0XF6,0X88,0XF6,0X47,0XEE,0X48,

147550XBC,0XE5,0X93,0XC3,0X83,0X43,0X7B,0X24,0X83,0X86,0X73,0X25,0X73,0X27,0XD6,0X55,

147560XFF,0XDD,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

147630XFF,0XDF,0XFF,0XDE,0XFF,0XBB,0XC5,0XAE,0XCD,0XA9,0XD5,0XC7,0XDD,0XC7,0XDD,0XC7,

147640XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

147650XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XEE,0X07,

147660XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XBC,0XC6,0X6A,0X80,0X62,0X41,

147670X5A,0X22,0X5A,0X42,0X5A,0X42,0X5A,0X42,0X52,0X43,0X52,0X43,0X5A,0X42,0X52,0X43,

147680X52,0X43,0X52,0X23,0X52,0X04,0X94,0X2E,0XF7,0X7C,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XC5,0X8F,0XC5,0X49,0XEE,0X4A,0XF6,0X48,

147700XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

147710XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

147720XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,

147730XF6,0X68,0XF6,0X68,0XEE,0X47,0XF6,0X88,0XF6,0X68,0XEE,0X49,0XBC,0XE5,0X93,0XC2,

147740X8B,0X64,0X83,0X24,0X83,0X66,0X73,0X25,0X83,0XA9,0XDE,0X96,0XFF,0XDD,0XFF,0XFF,

147750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDE,

147820XFF,0XDC,0XD5,0XF1,0XC5,0X89,0XD5,0XC8,0XDD,0XC7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,

147830XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

147840XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

147850XEE,0X27,0XEE,0X28,0XEE,0X4A,0XBC,0XC6,0X6A,0X80,0X62,0X41,0X5A,0X42,0X5A,0X43,

147860X5A,0X42,0X5A,0X42,0X5A,0X43,0X52,0X43,0X5A,0X42,0X5A,0X43,0X52,0X43,0X52,0X23,

147870X52,0X03,0X94,0X2D,0XF7,0X5C,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147880XFF,0XFF,0XFF,0XFC,0XC5,0X8F,0XC5,0X49,0XEE,0X4A,0XF6,0X48,0XF6,0X48,0XF6,0X48,

147890XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,

147900XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

147910XF6,0X47,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X68,

147920XF6,0X48,0XF6,0X68,0XF6,0X89,0XEE,0X49,0XB4,0XC4,0X93,0XA2,0X93,0XC5,0X8B,0X65,

147930X83,0X86,0X73,0X26,0X94,0X4B,0XE6,0XD7,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

147990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148000XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XDE,0XFF,0XDD,0XDE,0X53,

148010XC5,0X69,0XD5,0XE8,0XDD,0XC7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,

148020XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

148030XE5,0XE7,0XE6,0X07,0XE6,0X08,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,

148040XEE,0X4A,0XBC,0XC6,0X6A,0X80,0X62,0X41,0X5A,0X42,0X5A,0X63,0X5A,0X63,0X5A,0X42,

148050X5A,0X43,0X5A,0X43,0X5A,0X43,0X5A,0X43,0X52,0X43,0X52,0X43,0X52,0X03,0X94,0X0D,

148060XF7,0X5B,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,

148070XC5,0X8F,0XC5,0X49,0XEE,0X4A,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

148080XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,

148090XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,

148100XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X68,

148110XF6,0X89,0XEE,0X48,0XB4,0X84,0X93,0XC3,0X9C,0X06,0X93,0XC6,0X8B,0X86,0X7B,0X46,

148120XA4,0XCD,0XEF,0X19,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148190XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XE6,0XB4,0XBD,0X4A,0XD5,0XE9,

148200XDD,0XC7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

148210XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,

148220XE6,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XBC,0XC7,

148230X6A,0X80,0X62,0X41,0X5A,0X42,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X43,

148240X5A,0X43,0X5A,0X43,0X52,0X43,0X52,0X43,0X52,0X03,0X8B,0XEC,0XEF,0X5B,0XFF,0XFF,

148250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XC5,0X8F,0XCD,0X4A,

148260XEE,0X4A,0XF6,0X48,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

148270XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

148280XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

148290XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X48,0XF6,0X89,0XF6,0X89,0XE6,0X08,

148300XAC,0X63,0X9B,0XE3,0X9C,0X06,0X93,0XE7,0X8B,0XA7,0X83,0X87,0XB5,0X2F,0XF7,0X7A,

148310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,

148380XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XEF,0X16,0XBD,0X6A,0XD5,0XC9,0XDD,0XC8,0XDD,0XC7,

148390XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

148400XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XEE,0X07,

148410XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X4A,0XBC,0XC7,0X72,0X80,0X62,0X61,

148420X5A,0X42,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X43,0X5A,0X43,

148430X52,0X42,0X52,0X63,0X52,0X03,0X8B,0XEC,0XEF,0X5B,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XC5,0X8E,0XCD,0X4A,0XEE,0X4A,0XF6,0X48,

148450XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

148460XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

148470XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,

148480XF6,0X48,0XF6,0X68,0XF6,0X48,0XF6,0X89,0XF6,0X89,0XDD,0XE7,0XA4,0X43,0X9C,0X04,

148490X9B,0XE6,0X93,0XE7,0X8B,0XC7,0X8B,0XC8,0XC5,0XB1,0XFF,0XBC,0XFF,0XFF,0XFF,0XFF,

148500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

148570XFF,0XFD,0XFF,0X78,0XC5,0XAC,0XCD,0XC9,0XDD,0XC8,0XDD,0XC7,0XDD,0XC7,0XE5,0XC7,

148580XE5,0XC7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

148590XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,

148600XEE,0X27,0XEE,0X28,0XEE,0X4A,0XBC,0XE7,0X72,0XA0,0X62,0X61,0X62,0X42,0X5A,0X63,

148610X62,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X5A,0X63,0X52,0X63,0X5A,0X64,

148620X52,0X03,0X8B,0XCB,0XEF,0X3B,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148630XFF,0XFF,0XFF,0XFC,0XC5,0X8E,0XCD,0X4A,0XEE,0X4A,0XF6,0X48,0XF6,0X48,0XF6,0X47,

148640XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

148650XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

148660XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X48,

148670XF6,0X48,0XF6,0X89,0XF6,0X89,0XD5,0X86,0XA4,0X43,0X9C,0X04,0X9C,0X06,0X93,0XE7,

148680X93,0XE7,0X94,0X29,0XD6,0X54,0XFF,0XDC,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFD,0XFF,0XB9,

148760XCD,0XCD,0XCD,0XAA,0XDD,0XC8,0XDD,0XC7,0XDD,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,

148770XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

148780XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,

148790XEE,0X4A,0XBC,0XE6,0X72,0XA0,0X62,0X61,0X62,0X42,0X62,0X63,0X5A,0X83,0X5A,0X63,

148800X5A,0X63,0X5A,0X63,0X62,0X63,0X5A,0X83,0X5A,0X63,0X5A,0X84,0X52,0X03,0X83,0XAB,

148810XEF,0X1A,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,

148820XC5,0X8E,0XCD,0X49,0XEE,0X4A,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,

148830XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

148840XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,

148850XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XFE,0X68,0XF6,0X48,0XF6,0X89,0XF6,0X89,

148860XF6,0X6A,0XCD,0X46,0XAC,0X64,0X9C,0X24,0XA4,0X46,0X9C,0X07,0X94,0X08,0X9C,0X6B,

148870XE6,0XD6,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

148940XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XDA,0XDE,0X50,0XC5,0X6A,

148950XD5,0XC9,0XDD,0XE8,0XDD,0XE7,0XE5,0XC6,0XE5,0XC7,0XE5,0XC7,0XE5,0XE7,0XE5,0XE7,

148960XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,

148970XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X48,0XEE,0X4A,0XBC,0XE7,

148980X72,0XA0,0X62,0X40,0X62,0X82,0X62,0X83,0X5A,0X63,0X5A,0X83,0X5A,0X83,0X5A,0X63,

148990X5A,0X63,0X5A,0X83,0X5A,0X83,0X5A,0X63,0X5A,0X23,0X83,0XAA,0XE7,0X1A,0XFF,0XFE,

149000XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XC5,0X8E,0XCD,0X6A,

149010XEE,0X49,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

149020XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

149030XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

149040XFE,0X68,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XF6,0X69,0XFE,0X8A,0XF6,0X6B,0XBC,0XE6,

149050XAC,0X84,0XA4,0X65,0XA4,0X46,0X9C,0X27,0X94,0X08,0XB5,0X0E,0XF7,0X59,0XFF,0XFE,

149060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149130XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XE6,0XB3,0XC5,0X6A,0XD5,0XC9,0XDD,0XC7,

149140XDD,0XE7,0XDD,0XC6,0XE5,0XC7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,

149150XE5,0XE7,0XED,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,

149160XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X47,0XEE,0X4A,0XC5,0X07,0X72,0XA0,0X62,0X40,

149170X62,0X82,0X62,0X83,0X5A,0X63,0X5A,0X83,0X5A,0X83,0X5A,0X83,0X62,0X83,0X5A,0X83,

149180X5A,0X83,0X5A,0X83,0X5A,0X23,0X83,0X8A,0XE6,0XF9,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

149190XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFC,0XC5,0X8E,0XCD,0X6A,0XEE,0X49,0XF6,0X47,

149200XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

149210XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,

149220XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X47,0XFE,0X67,0XF6,0X47,

149230XF6,0X67,0XF6,0X68,0XF6,0X69,0XFE,0XAB,0XEE,0X2A,0XBC,0XE6,0XAC,0XA5,0XAC,0XA6,

149240XA4,0X66,0XA4,0X67,0X9C,0X49,0XC5,0X91,0XFF,0X9B,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149320XFF,0XDE,0XFF,0XFC,0XF7,0X56,0XC5,0X8B,0XD5,0XA9,0XDD,0XC7,0XDD,0XE7,0XE5,0XE7,

149330XE5,0XC7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XE5,0XE7,0XED,0XE7,

149340XE5,0XE7,0XEE,0X07,0XE6,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

149350XEE,0X27,0XEE,0X27,0XEE,0X4A,0XC5,0X07,0X72,0XC1,0X62,0X41,0X62,0X82,0X62,0X83,

149360X62,0X83,0X62,0X83,0X62,0X83,0X62,0X83,0X62,0X83,0X62,0X83,0X5A,0X83,0X5A,0X83,

149370X5A,0X43,0X7B,0X69,0XE6,0XD9,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149380XFF,0XFF,0XFF,0XFC,0XC5,0X8E,0XCD,0X6A,0XEE,0X49,0XF6,0X48,0XF6,0X47,0XF6,0X47,

149390XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

149400XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,

149410XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X68,

149420XFE,0X89,0XFE,0XAB,0XDD,0XC9,0XBC,0XE6,0XAC,0XA5,0XB5,0X07,0XA4,0X86,0XAC,0XA8,

149430XA4,0X6A,0XD6,0X53,0XFF,0XDC,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149500XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,

149510XFF,0XD8,0XCD,0XCD,0XD5,0XCA,0XDD,0XC8,0XE5,0XE7,0XE5,0XE7,0XE5,0XC7,0XE5,0XC8,

149520XE5,0XE8,0XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE5,0XE7,0XED,0XE7,0XEE,0X07,0XEE,0X07,

149530XEE,0X07,0XE6,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X27,

149540XEE,0X4A,0XC5,0X27,0X72,0XC1,0X62,0X61,0X6A,0XA2,0X62,0X83,0X62,0X83,0X62,0X83,

149550X62,0X83,0X62,0XA3,0X62,0X83,0X62,0X83,0X5A,0XA3,0X5A,0X83,0X5A,0X43,0X7B,0X49,

149560XDE,0XB8,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,

149570XC5,0X8E,0XCD,0X6A,0XEE,0X49,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

149580XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

149590XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,

149600XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XFE,0XAA,0XFE,0XAB,

149610XD5,0X88,0XBC,0XE6,0XB4,0XC7,0XB4,0XE7,0XB4,0XC7,0XA4,0X87,0XAC,0XEB,0XE6,0XD6,

149620XFF,0XFD,0XFF,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149690XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFA,0XD6,0X0F,

149700XD5,0XAA,0XDD,0XC8,0XE5,0XE7,0XE5,0XE7,0XE5,0XC7,0XE5,0XC8,0XE5,0XE8,0XE5,0XE7,

149710XE5,0XE7,0XE6,0X07,0XEE,0X07,0XE5,0XE7,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

149720XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X27,0XEE,0X4A,0XCD,0X48,

149730X72,0XC1,0X62,0X61,0X6A,0XA3,0X62,0XA3,0X62,0X83,0X62,0X83,0X62,0XA3,0X62,0XA3,

149740X62,0X83,0X62,0X83,0X62,0XA3,0X5A,0X83,0X5A,0X43,0X73,0X49,0XDE,0XB8,0XFF,0XDE,

149750XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFC,0XC5,0X6E,0XCD,0X6A,

149760XEE,0X4A,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

149770XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

149780XF6,0X48,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,

149790XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XFE,0XCA,0XF6,0X8A,0XCD,0X67,0XC5,0X07,

149800XBC,0XE8,0XBC,0XE8,0XB4,0XE7,0XAC,0XC8,0XBD,0X4D,0XFF,0X79,0XFF,0XDD,0XFF,0XBF,

149810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

149870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

149880XF7,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XFF,0XFB,0XE6,0XB2,0XD5,0XAA,0XDD,0XA8,

149890XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE8,0XE6,0X07,0XE6,0X07,

149900XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

149910XEE,0X28,0XEE,0X28,0XEE,0X27,0XEE,0X28,0XEE,0X6A,0XCD,0X48,0X7A,0XE1,0X62,0X61,

149920X6A,0XA3,0X62,0X83,0X62,0X83,0X62,0XA3,0X62,0XA3,0X62,0XA3,0X62,0XA3,0X62,0X83,

149930X62,0XA3,0X5A,0X83,0X5A,0X44,0X73,0X08,0XDE,0X98,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

149940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XC5,0X6F,0XCD,0X6A,0XEE,0X4A,0XF6,0X48,

149950XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

149960XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X48,0XF6,0X47,

149970XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

149980XF6,0X67,0XF6,0X88,0XFE,0XCA,0XEE,0X6A,0XCD,0X47,0XC5,0X27,0XC5,0X08,0XBC,0XE8,

149990XB4,0XE7,0XB4,0XE9,0XCD,0XF0,0XFF,0XDB,0XFF,0XBD,0XFF,0XBF,0XFF,0XFF,0XFF,0XFF,

150000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

150070XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0X56,0XD5,0XCB,0XDD,0XC8,0XE5,0XC7,0XE5,0XE7,

150080XED,0XE7,0XE5,0XC7,0XE5,0XE8,0XE5,0XE8,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,

150090XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,

150100XEE,0X27,0XEE,0X28,0XF6,0X6A,0XCD,0X48,0X7A,0XE1,0X6A,0X61,0X6A,0X83,0X62,0X83,

150110X62,0X83,0X62,0XA3,0X62,0XA3,0X62,0XA2,0X6A,0XA3,0X62,0XA3,0X62,0XA3,0X62,0X83,

150120X5A,0X44,0X73,0X08,0XDE,0X77,0XFF,0XFE,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

150130XFF,0XFF,0XFF,0XFD,0XC5,0X8F,0XCD,0X8B,0XEE,0X4A,0XF6,0X48,0XF6,0X47,0XF6,0X47,

150140XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

150150XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X67,

150160XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X87,0XF6,0X67,0XF6,0X68,0XFE,0XA9,

150170XFE,0XCA,0XE6,0X08,0XCD,0X26,0XCD,0X47,0XC5,0X28,0XB4,0XC7,0XC5,0X48,0XAC,0XC8,

150180XEE,0XD4,0XFF,0X9A,0XFF,0XDE,0XFF,0XBF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XDF,0XFF,0XFF,0XFF,0XFF,

150260XFF,0XDC,0XFF,0XB9,0XDD,0XED,0XDD,0XE9,0XE5,0XE7,0XE5,0XE7,0XED,0XE7,0XED,0XE7,

150270XE5,0XE7,0XE5,0XE7,0XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

150280XEE,0X27,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XEE,0X28,

150290XF6,0X6A,0XCD,0X68,0X7A,0XE1,0X6A,0X61,0X6A,0X83,0X62,0X83,0X62,0X83,0X62,0XA3,

150300X62,0XA3,0X62,0XA3,0X6A,0XA3,0X62,0X83,0X62,0XA3,0X62,0X63,0X5A,0X44,0X72,0XE8,

150310XD6,0X77,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XDC,

150320XC5,0X8F,0XCD,0X8B,0XEE,0X4A,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

150330XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

150340XF6,0X47,0XF6,0X68,0XF6,0X48,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

150350XF6,0X67,0XF6,0X67,0XFE,0X88,0XF6,0X67,0XF6,0X88,0XFE,0XA9,0XFE,0XCA,0XDD,0XE8,

150360XC5,0X26,0XCD,0X47,0XCD,0X69,0XBD,0X28,0XBD,0X28,0XBD,0X4A,0XF7,0X36,0XFF,0XDC,

150370XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFD,0XFF,0XDA,

150450XEE,0XD1,0XDD,0XE9,0XDD,0XE7,0XE6,0X07,0XED,0XE6,0XEE,0X07,0XE5,0XE7,0XE6,0X07,

150460XE6,0X07,0XE6,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,

150470XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,0XEE,0X27,0XEE,0X49,0XEE,0X4A,0XD5,0X88,

150480X83,0X01,0X6A,0X61,0X62,0X82,0X62,0X83,0X62,0X83,0X62,0XA3,0X62,0X82,0X62,0XA3,

150490X62,0XA3,0X62,0X83,0X6A,0XA3,0X62,0X84,0X5A,0X64,0X6A,0XC7,0XD6,0X56,0XFF,0XDE,

150500XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDD,0XC5,0X6F,0XCD,0X8B,

150510XEE,0X4A,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

150520XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

150530XF6,0X48,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

150540XF6,0X68,0XEE,0X47,0XF6,0X88,0XFE,0XEA,0XFE,0XAA,0XD5,0X86,0XCD,0X46,0XCD,0X47,

150550XCD,0X88,0XC5,0X48,0XBD,0X48,0XCD,0XEE,0XFF,0X78,0XFF,0XDD,0XFF,0XBE,0XFF,0XFF,

150560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XDB,0XFF,0X33,0XDD,0XEB,

150640XE6,0X08,0XE5,0XE7,0XED,0XE6,0XEE,0X06,0XEE,0X07,0XEE,0X07,0XE6,0X07,0XE6,0X07,

150650XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,

150660XEE,0X27,0XEE,0X28,0XEE,0X28,0XF6,0X49,0XEE,0X49,0XD5,0XA8,0X83,0X21,0X62,0X60,

150670X62,0X62,0X62,0X83,0X62,0X83,0X62,0XA3,0X62,0X82,0X62,0XA3,0X62,0XA3,0X6A,0XA3,

150680X62,0X83,0X62,0XA4,0X62,0X64,0X62,0XA7,0XCE,0X15,0XFF,0XDD,0XFF,0XFF,0XFF,0XFF,

150690XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XDC,0XC5,0X6E,0XCD,0X8A,0XEE,0X4A,0XF6,0X48,

150700XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

150710XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X68,0XF6,0X68,0XF6,0X48,0XF6,0X68,

150720XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X67,0XF6,0X47,

150730XFE,0XA9,0XFE,0XEA,0XF6,0X69,0XD5,0X86,0XD5,0X67,0XCD,0X67,0XCD,0X68,0XC5,0X89,

150740XBD,0X49,0XE6,0XB2,0XFF,0XBA,0XFF,0XDE,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,

150750XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XFF,0X76,0XDE,0X2D,0XDD,0XE9,0XE5,0XE7,

150830XE5,0XE6,0XEE,0X06,0XEE,0X06,0XEE,0X06,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,

150840XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X28,

150850XEE,0X28,0XF6,0X49,0XEE,0X49,0XDD,0XC8,0X8B,0X41,0X62,0X40,0X62,0X62,0X62,0X63,

150860X62,0X83,0X62,0X83,0X62,0XA3,0X62,0XA3,0X62,0XA3,0X62,0XA3,0X62,0X83,0X62,0X83,

150870X62,0X84,0X5A,0X85,0XC5,0XD4,0XFF,0XBD,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,

150880XFF,0XFF,0XFF,0XDC,0XC5,0X8E,0XCD,0X8A,0XEE,0X4A,0XF6,0X48,0XF6,0X48,0XF6,0X68,

150890XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,

150900XF6,0X47,0XF6,0X47,0XF6,0X48,0XF6,0X68,0XF6,0X48,0XF6,0X67,0XF6,0X67,0XF6,0X67,

150910XF6,0X67,0XF6,0X67,0XF6,0X68,0XF6,0X88,0XF6,0X47,0XF6,0X88,0XFE,0XA9,0XFE,0XCA,

150920XEE,0X07,0XD5,0X86,0XD5,0X87,0XD5,0X87,0XCD,0X67,0XCD,0X89,0XBD,0X6B,0XFF,0X76,

150930XFF,0XFC,0XFF,0XDE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

150940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

150990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151010XFF,0XFF,0XFF,0XFD,0XFF,0X99,0XEE,0X91,0XD5,0XEA,0XE6,0X28,0XE5,0XE6,0XEE,0X26,

151020XEE,0X06,0XEE,0X06,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X07,0XEE,0X27,

151030XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,0XEE,0X27,0XEE,0X28,0XEE,0X28,0XF6,0X49,

151040XEE,0X49,0XDD,0XE9,0X8B,0X62,0X62,0X40,0X62,0X42,0X62,0X63,0X62,0X83,0X62,0X83,

151050X62,0XA3,0X62,0X83,0X62,0X83,0X62,0X83,0X62,0X83,0X62,0X63,0X62,0X84,0X5A,0X45,

151060XBD,0XB3,0XFF,0X9C,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XDC,

151070XC5,0X6E,0XCD,0X8A,0XF6,0X4A,0XF6,0X48,0XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X67,

151080XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,

151090XF6,0X68,0XF6,0X68,0XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

151100XF6,0X68,0XF6,0X68,0XF6,0X68,0XFE,0XA9,0XFE,0XC9,0XFE,0XA9,0XE5,0XC7,0XDD,0XC7,

151110XDD,0XA7,0XD5,0XA8,0XCD,0X88,0XCD,0XAA,0XCE,0X0E,0XFF,0XD9,0XFF,0XDC,0XFF,0XDE,

151120XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

151200XFF,0X9B,0XF7,0X35,0XD5,0XEC,0XE6,0X29,0XE6,0X07,0XEE,0X06,0XEE,0X06,0XEE,0X06,

151210XEE,0X07,0XEE,0X27,0XEE,0X07,0XEE,0X07,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,

151220XEE,0X27,0XEE,0X47,0XF6,0X27,0XF6,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X48,0XDE,0X09,

151230X8B,0X82,0X5A,0X20,0X62,0X42,0X62,0X63,0X62,0X63,0X62,0X83,0X62,0X83,0X62,0X83,

151240X62,0X84,0X62,0X63,0X62,0X83,0X62,0X83,0X5A,0X63,0X5A,0X64,0XB5,0X72,0XF7,0X9C,

151250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDC,0XBD,0X4D,0XD5,0XAA,

151260XF6,0X49,0XF6,0X47,0XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XFE,0X47,0XFE,0X47,

151270XFE,0X47,0XFE,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,

151280XFE,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X87,0XF6,0X87,0XF6,0X68,0XF6,0X68,

151290XF6,0X68,0XFE,0XA9,0XFE,0XA9,0XFE,0X89,0XE5,0XE6,0XE6,0X08,0XE5,0XE8,0XDD,0XC8,

151300XD5,0XC9,0XCD,0XCC,0XEE,0XF4,0XFF,0XFB,0XFF,0XDD,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

151310XFF,0XDE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XBC,0XFF,0X78,

151390XDE,0X4E,0XDD,0XE9,0XEE,0X28,0XE5,0XE5,0XEE,0X26,0XEE,0X06,0XEE,0X07,0XEE,0X27,

151400XEE,0X08,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X47,

151410XF6,0X27,0XF6,0X28,0XEE,0X28,0XEE,0X48,0XEE,0X48,0XE6,0X09,0X93,0XC2,0X5A,0X20,

151420X62,0X42,0X62,0X43,0X5A,0X63,0X62,0X63,0X62,0X83,0X62,0X83,0X62,0X84,0X62,0X84,

151430X5A,0X62,0X62,0XA3,0X52,0X42,0X5A,0X64,0XA4,0XCF,0XF7,0X9B,0XFF,0XDF,0XFF,0XFF,

151440XFF,0XFF,0XFF,0XFF,0XFF,0XBE,0XFF,0XBB,0XBD,0X2C,0XD5,0XEA,0XF6,0X49,0XF6,0X47,

151450XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,

151460XF6,0X67,0XF6,0X67,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XF6,0X67,

151470XF6,0X67,0XF6,0X67,0XF6,0X87,0XF6,0X87,0XF6,0X68,0XF6,0X68,0XFE,0X89,0XFE,0XAA,

151480XFE,0X89,0XF6,0X68,0XE5,0XE7,0XEE,0X28,0XE5,0XE8,0XDD,0XC8,0XD5,0XCA,0XD6,0X2E,

151490XFF,0XB8,0XFF,0XFC,0XFF,0XFF,0XFF,0XFF,0XF7,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XBE,0XFF,0XBA,0XEE,0XD1,0XDE,0X0A,

151580XE6,0X28,0XE5,0XE6,0XEE,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X27,0XEE,0X08,0XEE,0X27,

151590XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XEE,0X27,0XF6,0X47,0XF6,0X27,0XF6,0X48,

151600XF6,0X48,0XF6,0X48,0XEE,0X68,0XE6,0X29,0X9C,0X03,0X5A,0X20,0X62,0X42,0X5A,0X43,

151610X5A,0X43,0X5A,0X63,0X62,0X83,0X5A,0X63,0X62,0X64,0X5A,0X63,0X5A,0X42,0X62,0X83,

151620X52,0X43,0X52,0X43,0X8C,0X2C,0XF7,0X5B,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

151630XFF,0XBE,0XFF,0X9B,0XB5,0X0B,0XDE,0X0A,0XEE,0X49,0XF6,0X47,0XF6,0X47,0XF6,0X47,

151640XF6,0X47,0XF6,0X67,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,

151650XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

151660XF6,0X67,0XF6,0X87,0XF6,0X68,0XF6,0X68,0XFE,0X89,0XFE,0XAA,0XFE,0X89,0XF6,0X48,

151670XEE,0X07,0XEE,0X48,0XE5,0XE8,0XE5,0XE9,0XDE,0X0B,0XEE,0XD1,0XFF,0XDA,0XFF,0XFE,

151680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDC,0XF7,0X34,0XE6,0X4D,0XE6,0X08,0XEE,0X27,

151770XEE,0X26,0XEE,0X26,0XEE,0X27,0XEE,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

151780XEE,0X27,0XEE,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X27,0XF6,0X48,0XF6,0X48,0XF6,0X48,

151790XF6,0X68,0XEE,0X49,0XA4,0X44,0X62,0X40,0X5A,0X42,0X5A,0X23,0X5A,0X43,0X5A,0X43,

151800X5A,0X63,0X5A,0X63,0X5A,0X64,0X5A,0X43,0X5A,0X42,0X5A,0X42,0X5A,0X63,0X49,0XE2,

151810X7B,0XAA,0XEF,0X3A,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,0XFF,0XDE,0XFF,0X9A,

151820XB4,0XEA,0XE6,0X2A,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,

151830XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XF6,0X67,0XF6,0X67,

151840XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

151850XF6,0X68,0XFE,0X89,0XFE,0XAA,0XFE,0XAA,0XFE,0X89,0XF6,0X48,0XEE,0X28,0XF6,0X49,

151860XEE,0X08,0XE6,0X2B,0XDE,0X4E,0XFF,0X76,0XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

151870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

151950XFF,0XFF,0XFF,0XFD,0XFF,0X78,0XEE,0X6F,0XDD,0XE9,0XEE,0X27,0XEE,0X07,0XF6,0X27,

151960XEE,0X26,0XF6,0X27,0XF6,0X27,0XF6,0X07,0XF6,0X27,0XF6,0X27,0XEE,0X27,0XF6,0X48,

151970XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X27,0XF6,0X47,0XF6,0X68,0XF6,0X48,0XEE,0X49,

151980XAC,0X44,0X6A,0X80,0X5A,0X01,0X5A,0X23,0X5A,0X43,0X5A,0X23,0X5A,0X42,0X5A,0X42,

151990X5A,0X43,0X5A,0X43,0X52,0X23,0X52,0X43,0X52,0X23,0X4A,0X03,0X6B,0X09,0XEF,0X1A,

152000XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XBE,0XF7,0X17,0XBD,0X2A,0XE6,0X29,

152010XF6,0X68,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

152020XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

152030XF6,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X68,0XFE,0X89,

152040XFE,0XAA,0XFE,0XAA,0XFE,0X89,0XF6,0X48,0XF6,0X69,0XEE,0X29,0XEE,0X4A,0XE6,0X0C,

152050XEE,0XF3,0XFF,0XBA,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

152060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XF7,0XFF,0XFF,0XFE,

152140XFF,0XBB,0XF6,0XF3,0XE6,0X2B,0XEE,0X48,0XEE,0X27,0XEE,0X27,0XEE,0X26,0XF6,0X26,

152150XF6,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,0XEE,0X27,0XF6,0X48,0XF6,0X27,0XF6,0X27,

152160XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X67,0XF6,0X48,0XF6,0X4A,0XBC,0XC6,0X7A,0XC1,

152170X5A,0X01,0X52,0X02,0X52,0X23,0X52,0X23,0X5A,0X42,0X5A,0X42,0X52,0X22,0X52,0X23,

152180X52,0X44,0X4A,0X03,0X52,0X23,0X49,0XE3,0X5A,0X87,0XDE,0X98,0XFF,0XDE,0XFF,0XFF,

152190XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XEE,0XB5,0XBD,0X29,0XEE,0X69,0XF6,0X67,0XF6,0X67,

152200XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

152210XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,

152220XFE,0X87,0XFE,0X87,0XF6,0X67,0XF6,0X67,0XFE,0X88,0XFE,0XA9,0XFE,0XAA,0XFE,0X89,

152230XFE,0X89,0XEE,0X28,0XF6,0X8A,0XE6,0X29,0XEE,0X2B,0XEE,0X6E,0XF7,0X56,0XFF,0XDB,

152240XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

152250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152320XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XF7,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDC,0XFF,0X57,

152330XEE,0X6E,0XE6,0X29,0XEE,0X47,0XEE,0X26,0XEE,0X27,0XF6,0X27,0XF6,0X27,0XF6,0X27,

152340XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X47,0XF6,0X27,0XF6,0X47,0XF6,0X27,0XF6,0X47,

152350XF6,0X47,0XFE,0X68,0XF6,0X48,0XF6,0X6A,0XC4,0XE6,0X7B,0X01,0X5A,0X00,0X52,0X02,

152360X52,0X23,0X52,0X23,0X52,0X22,0X52,0X22,0X52,0X02,0X52,0X02,0X52,0X24,0X49,0XE2,

152370X52,0X23,0X49,0XE2,0X49,0XE4,0XC5,0XF5,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,

152380XFF,0XDD,0XD6,0X32,0XC5,0X69,0XEE,0X69,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

152390XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

152400XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XF6,0X87,0XF6,0X87,

152410XF6,0X67,0XF6,0X87,0XFE,0X88,0XFE,0XAA,0XFE,0X8A,0XFE,0X69,0XF6,0X68,0XF6,0X68,

152420XF6,0X89,0XEE,0X6A,0XE6,0X4B,0XF6,0XF1,0XFF,0XB9,0XFF,0XFC,0XFF,0XDE,0XFF,0XFF,

152430XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152510XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDD,0XFF,0XBA,0XEE,0XD1,0XE6,0X4B,

152520XEE,0X27,0XEE,0X46,0XF6,0X27,0XEE,0X27,0XF6,0X28,0XF6,0X48,0XF6,0X27,0XF6,0X27,

152530XF6,0X47,0XF6,0X27,0XF6,0X27,0XF6,0X47,0XF6,0X27,0XF6,0X48,0XF6,0X47,0XFE,0X88,

152540XF6,0X68,0XFE,0X8A,0XCD,0X47,0X8B,0X42,0X62,0X20,0X51,0XE1,0X52,0X03,0X52,0X03,

152550X52,0X02,0X52,0X22,0X52,0X02,0X4A,0X02,0X4A,0X03,0X4A,0X03,0X4A,0X02,0X4A,0X02,

152560X39,0X82,0XAD,0X11,0XFF,0XDD,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XFF,0XFC,0XCD,0XF0,

152570XCD,0X68,0XEE,0X48,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

152580XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

152590XFE,0X67,0XFE,0X87,0XF6,0X86,0XF6,0X86,0XF6,0X86,0XF6,0X86,0XF6,0X87,0XF6,0X88,

152600XFE,0XA9,0XFE,0XAA,0XFE,0X6A,0XFE,0X69,0XF6,0X48,0XFE,0X89,0XEE,0X69,0XEE,0X8B,

152610XE6,0X8E,0XFF,0X75,0XFF,0XFA,0XFF,0XFD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDE,

152620XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152700XFF,0XFF,0XFF,0XFE,0XFF,0XDD,0XFF,0XFC,0XFF,0X56,0XE6,0X8F,0XE6,0X28,0XF6,0X67,

152710XF6,0X27,0XF6,0X27,0XF6,0X28,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X27,

152720XFE,0X47,0XFE,0X67,0XF6,0X47,0XF6,0X68,0XF6,0X47,0XFE,0X88,0XF6,0X48,0XFE,0X69,

152730XE5,0XC9,0X9B,0XC3,0X62,0X40,0X51,0XE0,0X52,0X02,0X51,0XE2,0X52,0X02,0X52,0X23,

152740X4A,0X02,0X4A,0X02,0X41,0XE2,0X4A,0X03,0X41,0XE2,0X41,0XE2,0X39,0X81,0X83,0XCC,

152750XFF,0XBD,0XF7,0XBE,0XFF,0XFF,0XFF,0XFD,0XFF,0XBA,0XCD,0XCE,0XDD,0XEA,0XE6,0X07,

152760XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

152770XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XF6,0X67,0XFE,0X87,

152780XFE,0X86,0XF6,0X86,0XF6,0X86,0XF6,0X86,0XF6,0XA7,0XFE,0XA8,0XFE,0XA9,0XFE,0XAA,

152790XFE,0X8A,0XFE,0X69,0XFE,0X69,0XF6,0X8A,0XEE,0X6A,0XE6,0X6D,0XF7,0X12,0XFF,0XB8,

152800XFF,0XDC,0XFF,0XFE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,

152810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

152880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

152890XFF,0XDD,0XFF,0XFC,0XFF,0XDA,0XF7,0X13,0XE6,0X4A,0XEE,0X47,0XEE,0X27,0XF6,0X27,

152900XF6,0X48,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XFE,0X47,0XFE,0X27,0XFE,0X47,0XF6,0X47,

152910XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X68,0XF6,0X47,0XFE,0X69,0XEE,0X09,0XAC,0X44,

152920X72,0X80,0X51,0XE0,0X52,0X01,0X51,0XE2,0X49,0XE2,0X49,0XC2,0X49,0XE2,0X49,0XE2,

152930X4A,0X03,0X41,0XC2,0X4A,0X02,0X41,0XC1,0X41,0XC2,0X5A,0X66,0XF7,0X5B,0XFF,0XFE,

152940XFF,0XFE,0XFF,0XFC,0XF7,0X78,0XBD,0X4C,0XDD,0XC9,0XF6,0X68,0XF6,0X67,0XF6,0X67,

152950XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

152960XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XF6,0X67,0XFE,0X87,0XFE,0X86,0XF6,0X86,

152970XF6,0X86,0XF6,0XA7,0XF6,0XA8,0XFE,0XA8,0XFE,0X89,0XFE,0X8A,0XFE,0X8A,0XFE,0X8A,

152980XF6,0X69,0XF6,0X8B,0XE6,0X6C,0XEE,0XD0,0XFF,0X97,0XFF,0XDB,0XFF,0XDD,0XFF,0XFF,

152990XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

153000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,

153080XFF,0XFC,0XFF,0X97,0XEE,0XAD,0XE6,0X49,0XEE,0X27,0XF6,0X47,0XF6,0X48,0XF6,0X47,

153090XF6,0X47,0XF6,0X47,0XFE,0X47,0XFE,0X47,0XFE,0X47,0XF6,0X47,0XF6,0X47,0XF6,0X47,

153100XFE,0X67,0XFE,0X67,0XFE,0X47,0XFE,0X68,0XF6,0X29,0XC4,0XE5,0X83,0X41,0X5A,0X20,

153110X52,0X01,0X52,0X01,0X52,0X02,0X49,0XC2,0X49,0XE2,0X4A,0X03,0X52,0X04,0X41,0XA2,

153120X4A,0X22,0X49,0XE1,0X49,0XE3,0X49,0XC3,0XCD,0XF6,0XFF,0XDE,0XFF,0XFE,0XFF,0XFC,

153130XE6,0XD4,0XBD,0X0A,0XE6,0X09,0XFE,0X69,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

153140XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XF6,0X67,

153150XF6,0X67,0XF6,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X86,0XF6,0X86,0XF6,0X87,0XFE,0X87,

153160XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0X8A,0XFE,0X8A,0XFE,0X8B,0XF6,0X6A,0XF6,0XAC,

153170XEE,0XAF,0XFF,0X75,0XFF,0XDA,0XFF,0XFD,0XFF,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153180XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XFD,0XFF,0XFD,0XFF,0XFB,

153270XF7,0X12,0XEE,0X8C,0XEE,0X29,0XF6,0X48,0XF6,0X47,0XF6,0X47,0XF6,0X47,0XFE,0X47,

153280XFE,0X27,0XFE,0X47,0XFE,0X47,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,

153290XFE,0X47,0XFE,0X68,0XFE,0X49,0XDD,0X87,0X9C,0X03,0X6A,0X80,0X5A,0X20,0X52,0X21,

153300X5A,0X22,0X52,0X02,0X52,0X23,0X52,0X03,0X52,0X04,0X49,0XC2,0X52,0X23,0X52,0X02,

153310X52,0X02,0X49,0XA3,0X8B,0XED,0XFF,0XBD,0XFF,0XFD,0XFF,0XDA,0XDE,0X71,0XC5,0X4A,

153320XF6,0X4A,0XFE,0X48,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

153330XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XFE,0X87,

153340XFE,0X87,0XFE,0X87,0XF6,0X67,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,

153350XFE,0X89,0XFE,0XAA,0XFE,0X8A,0XF6,0X6B,0XF6,0X8C,0XEE,0X8E,0XF7,0X33,0XFF,0XD8,

153360XFF,0XDC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

153370XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153450XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFC,0XFF,0X97,0XF6,0XF1,

153460XE6,0X4B,0XEE,0X48,0XF6,0X67,0XFE,0X66,0XFE,0X46,0XFE,0X47,0XFE,0X47,0XFE,0X46,

153470XFE,0X67,0XF6,0X46,0XF6,0X67,0XF6,0X67,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X68,

153480XFE,0X89,0XE5,0XE8,0XBC,0XC5,0X7B,0X20,0X5A,0X20,0X5A,0X40,0X62,0X62,0X5A,0X22,

153490X5A,0X43,0X5A,0X43,0X5A,0X44,0X5A,0X23,0X5A,0X63,0X5A,0X42,0X5A,0X22,0X62,0X64,

153500X62,0X46,0XE6,0X97,0XFF,0XDB,0XFF,0X77,0XD5,0XEE,0XD5,0X8A,0XFE,0X8B,0XF6,0X27,

153510XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

153520XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XF6,0X67,0XF6,0X87,0XF6,0X67,

153530XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X89,0XFE,0XA9,0XFE,0XA9,0XFE,0XA9,

153540XF6,0X6A,0XEE,0X8C,0XEE,0XAE,0XEE,0XF1,0XFF,0XD7,0XFF,0XFB,0XFF,0XFD,0XFF,0XDF,

153550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

153560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153640XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XBA,0XFF,0X55,0XEE,0X8E,0XEE,0X6A,

153650XF6,0X67,0XFE,0X86,0XFE,0X46,0XFE,0X46,0XFE,0X46,0XFE,0X26,0XFE,0X67,0XF6,0X67,

153660XFE,0X67,0XF6,0X67,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X69,

153670XD5,0X87,0XA4,0X43,0X72,0XC0,0X62,0X80,0X6A,0XA2,0X6A,0XA3,0X6A,0XA3,0X6A,0XA3,

153680X6A,0XC4,0X6A,0XC4,0X6A,0XA2,0X72,0XC3,0X72,0XC3,0X83,0X26,0X6A,0X85,0X9C,0X2B,

153690XFF,0X56,0XF7,0X34,0XC5,0X29,0XE5,0XEA,0XFE,0X6A,0XFE,0X27,0XFE,0X67,0XFE,0X67,

153700XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

153710XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XF6,0X87,0XF6,0X87,0XF6,0X68,0XFE,0X69,

153720XFE,0X69,0XFE,0X68,0XFE,0X88,0XFE,0X88,0XFE,0XA8,0XFE,0XCA,0XF6,0X8B,0XEE,0XAE,

153730XF7,0X12,0XF7,0X76,0XFF,0XFA,0XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

153740XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153830XFF,0XFF,0XFF,0XFE,0XFF,0XFC,0XFF,0XB9,0XF7,0X13,0XEE,0X8C,0XEE,0X48,0XF6,0X66,

153840XF6,0X45,0XFE,0X45,0XFE,0X67,0XFE,0X47,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XF6,0X67,

153850XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XE5,0XE7,0XC5,0X66,

153860X83,0X60,0X7B,0X21,0X7B,0X63,0X73,0X02,0X83,0X64,0X7B,0X03,0X83,0X44,0X8B,0X85,

153870X7B,0X23,0X8B,0X84,0X93,0X84,0X8B,0X64,0X93,0XA7,0X83,0X45,0XCD,0XAD,0XD5,0XCC,

153880XD5,0X88,0XF6,0X8A,0XEE,0X07,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

153890XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

153900XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X68,0XFE,0X69,0XFE,0X69,0XFE,0X68,

153910XFE,0X87,0XFE,0XA8,0XFE,0XA8,0XF6,0XAA,0XEE,0X8D,0XF6,0XF1,0XFF,0X97,0XFF,0XDA,

153920XFF,0XFC,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

153990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

154020XFF,0XFE,0XFF,0XFB,0XFF,0X97,0XEE,0XD0,0XEE,0X6B,0XF6,0X68,0XF6,0X66,0XFE,0X46,

154030XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XF6,0X67,0XFE,0X87,0XFE,0X67,

154040XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,0XEE,0X68,0XEE,0X49,0XAC,0X84,0X93,0XC2,

154050X93,0XE3,0X93,0XC4,0X93,0XA4,0X93,0XC4,0X93,0XC4,0X9C,0X05,0X9B,0XE4,0X9C,0X04,

154060X9B,0XE4,0X9B,0XE4,0X9B,0XC5,0X9B,0XE5,0X9B,0XE4,0XB4,0XA5,0XE6,0X09,0XF6,0X69,

154070XF6,0X67,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

154080XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,

154090XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X89,0XFE,0XA8,0XFE,0XA9,

154100XF6,0XA9,0XEE,0X8B,0XF6,0XF0,0XFF,0X55,0XFF,0XDB,0XFF,0XFD,0XFF,0XFE,0XFF,0XFF,

154110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,

154210XFF,0XDA,0XFF,0X56,0XEE,0XCF,0XEE,0X6B,0XF6,0X68,0XF6,0X67,0XF6,0X47,0XF6,0X47,

154220XFE,0X67,0XFE,0X67,0XFE,0X88,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X67,

154230XFE,0X67,0XFE,0X87,0XF6,0X68,0XF6,0XAA,0XDE,0X29,0XB5,0X06,0X9C,0X24,0XA4,0X85,

154240XAC,0XA6,0XAC,0X65,0XAC,0X65,0XAC,0X64,0XA4,0X02,0XA4,0X02,0XA4,0X02,0X9B,0XC1,

154250X9B,0XC2,0X8B,0X40,0XA4,0X02,0XC5,0X05,0XF6,0X48,0XFE,0XA8,0XF6,0X87,0XF6,0X86,

154260XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

154270XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X67,

154280XFE,0X88,0XFE,0X89,0XFE,0XA9,0XFE,0XCA,0XFE,0XAA,0XF6,0XAA,0XEE,0XAC,0XEE,0XD0,

154290XFF,0X55,0XFF,0XBA,0XFF,0XDD,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154390XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0XDA,

154400XF7,0X34,0XE6,0X6D,0XEE,0X49,0XF6,0X68,0XF6,0X68,0XF6,0X68,0XFE,0X48,0XFE,0X68,

154410XFE,0X88,0XF6,0X67,0XF6,0X87,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XF6,0X67,

154420XF6,0X67,0XF6,0X89,0XFF,0X2C,0XEE,0XAB,0XC5,0X67,0XAC,0XC5,0XAC,0X84,0XAC,0X84,

154430XA4,0X22,0XA4,0X01,0XAC,0X42,0XA4,0X21,0X9B,0XE0,0X9B,0XC0,0X93,0XA0,0X9B,0XA0,

154440XC4,0XC3,0XEE,0X07,0XFE,0X88,0XF6,0X67,0XFE,0XA7,0XF6,0X66,0XF6,0X67,0XFE,0X67,

154450XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,

154460XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XFE,0X88,0XFE,0XA9,

154470XFE,0XCA,0XFE,0XAB,0XEE,0X8B,0XEE,0X6D,0XF6,0XF1,0XFF,0X75,0XFF,0XBA,0XFF,0XFD,

154480XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFD,0XFF,0X98,0XEE,0XF2,

154590XEE,0X6D,0XEE,0X6A,0XF6,0X89,0XFE,0X89,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XF6,0X67,

154600XFE,0X88,0XF6,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0XA8,0XF6,0XA8,

154610XFE,0XEB,0XFF,0X4D,0XF6,0XEC,0XD5,0XE9,0XBC,0XC5,0XB4,0X83,0XAC,0X42,0XAC,0X41,

154620XA3,0XE0,0X9B,0XC0,0X9C,0X00,0XA4,0X00,0XAC,0X21,0XC5,0X03,0XEE,0X07,0XF6,0X27,

154630XF6,0X46,0XFE,0X87,0XF6,0XA7,0XF6,0XA7,0XF6,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,

154640XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,

154650XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X89,0XFE,0X8A,0XFE,0XAB,0XF6,0X8C,

154660XEE,0X8E,0XF6,0XF2,0XFF,0X76,0XFF,0XDA,0XFF,0XDD,0XFF,0XFF,0XFF,0XBF,0XFF,0XDF,

154670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154760XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154770XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFC,0XFF,0XB7,0XEE,0XF1,0XE6,0X6C,

154780XEE,0X6A,0XF6,0X89,0XFE,0X88,0XF6,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X68,

154790XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XF6,0X68,0XF6,0X88,0XEE,0X89,0XF6,0XCA,

154800XFF,0X6E,0XFF,0X4D,0XF6,0XAA,0XE6,0X29,0XD5,0X65,0XCD,0X65,0XC5,0X24,0XC5,0X44,

154810XD5,0X85,0XDD,0XC6,0XE6,0X27,0XE5,0XE6,0XF6,0X48,0XFE,0X88,0XFE,0X67,0XF6,0X86,

154820XF6,0X86,0XF6,0X86,0XF6,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,

154830XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X88,

154840XFE,0X88,0XFE,0X89,0XFE,0XAA,0XF6,0XAB,0XF6,0X6C,0XEE,0X8E,0XF6,0XF3,0XFF,0X97,

154850XFF,0XDB,0XFF,0XFD,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFF,

154860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154950XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

154960XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XDA,0XFF,0XB7,0XEF,0X10,0XE6,0XAB,0XEE,0XA8,

154970XF6,0X87,0XFE,0X87,0XFE,0X68,0XFE,0X69,0XFE,0X69,0XFE,0X69,0XFE,0X68,0XFE,0X67,

154980XFE,0X67,0XFE,0X68,0XF6,0X68,0XF6,0X89,0XF6,0X69,0XEE,0X69,0XF6,0X8A,0XF6,0XCA,

154990XFF,0X4C,0XFF,0X4B,0XFF,0X2B,0XFF,0X2B,0XFF,0X2B,0XFF,0X0B,0XFE,0XCA,0XF6,0X89,

155000XEE,0X27,0XEE,0X48,0XF6,0X68,0XFE,0X88,0XFE,0X87,0XF6,0X67,0XF6,0X67,0XF6,0X87,

155010XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,

155020XFE,0X87,0XFE,0X67,0XFE,0X87,0XFE,0XA7,0XFE,0XA7,0XFE,0X88,0XFE,0X89,0XFE,0X8A,

155030XF6,0XCB,0XEE,0XAC,0XEE,0XAF,0XFF,0X34,0XFF,0XB8,0XFF,0XDB,0XFF,0XDE,0XFF,0XDF,

155040XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,

155050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

155150XFF,0XDE,0XFF,0XDD,0XFF,0XFB,0XFF,0X96,0XEF,0X10,0XE6,0XAA,0XF6,0XA8,0XFE,0XA8,

155160XFE,0X89,0XFE,0X69,0XFE,0X49,0XFE,0X48,0XFE,0X48,0XFE,0X67,0XFE,0X87,0XFE,0X67,

155170XF6,0X68,0XF6,0X69,0XF6,0X69,0XF6,0X89,0XF6,0X89,0XF6,0X88,0XEE,0X67,0XEE,0X87,

155180XF6,0XA8,0XEE,0X88,0XEE,0X67,0XEE,0X47,0XEE,0X47,0XF6,0X68,0XFE,0X88,0XFE,0X88,

155190XF6,0X88,0XF6,0X88,0XF6,0X67,0XF6,0X67,0XF6,0X67,0XFE,0XA8,0XF6,0X67,0XFE,0X87,

155200XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X67,0XFE,0X67,

155210XFE,0X87,0XFE,0XA7,0XFE,0XA8,0XFE,0X89,0XFE,0X8B,0XFE,0XAD,0XEE,0X8D,0XEE,0XD0,

155220XFF,0X54,0XFF,0X98,0XFF,0XDB,0XFF,0XDD,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

155230XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

155340XFF,0XFE,0XFF,0XDA,0XFF,0X96,0XF7,0X31,0XEE,0X8C,0XEE,0X8A,0XF6,0X89,0XF6,0X89,

155350XFE,0X89,0XFE,0X88,0XFE,0X68,0XFE,0X88,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XF6,0X87,

155360XF6,0X88,0XF6,0XA8,0XF6,0XA8,0XEE,0X87,0XF6,0X87,0XF6,0XA7,0XF6,0XA7,0XF6,0XA7,

155370XF6,0X87,0XF6,0X87,0XF6,0X88,0XFE,0XA8,0XFE,0XA8,0XFE,0X88,0XFE,0X88,0XFE,0X88,

155380XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X66,

155390XF6,0X66,0XF6,0X66,0XFE,0X67,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0XA8,0XFE,0XA8,

155400XF6,0X89,0XEE,0X6B,0XEE,0X4D,0XEE,0X50,0XFF,0X14,0XFF,0X77,0XFF,0XDB,0XFF,0XFC,

155410XFF,0XDE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,

155420XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

155520XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XDF,0XFF,0XBF,0XFF,0X9F,0XFF,0X9E,0XFF,0XBD,

155530XFF,0XBA,0XFF,0X76,0XF6,0XF1,0XEE,0XAD,0XEE,0X8B,0XEE,0X89,0XF6,0X88,0XF6,0X68,

155540XF6,0X47,0XF6,0X47,0XFE,0X87,0XFE,0X87,0XFE,0XA7,0XF6,0X87,0XF6,0X87,0XF6,0XA7,

155550XF6,0XA7,0XF6,0XA7,0XFE,0XA7,0XF6,0X87,0XF6,0X87,0XF6,0X87,0XF6,0X87,0XFE,0X87,

155560XFE,0X87,0XFE,0X67,0XF6,0X67,0XF6,0X67,0XFE,0X67,0XFE,0X88,0XFE,0X88,0XFE,0X68,

155570XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0XA7,0XFE,0X87,0XF6,0X86,

155580XF6,0X67,0XF6,0X68,0XF6,0X69,0XF6,0X69,0XF6,0X8A,0XF6,0XAB,0XF6,0XAD,0XF6,0XD0,

155590XFF,0X13,0XFF,0X57,0XFF,0X9A,0XFF,0XBC,0XFF,0XDD,0XFF,0XBE,0XFF,0XBE,0XFF,0XDF,

155600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,

155610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

155650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

155690XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

155700XF7,0XBF,0XF7,0XBF,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9D,0XF7,0X9D,

155710XF7,0X9D,0XEF,0X9D,0XEF,0X7E,0XEF,0X5E,0XEF,0X3D,0XF7,0X5C,0XFF,0X7C,0XFF,0X59,

155720XF7,0X15,0XEE,0XF2,0XEE,0XAE,0XEE,0X8B,0XEE,0X89,0XF6,0XA8,0XFE,0XA8,0XFE,0XA8,

155730XFE,0X87,0XFE,0X87,0XFE,0X86,0XFE,0X86,0XF6,0X87,0XF6,0X87,0XF6,0X87,0XFE,0XA8,

155740XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X88,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X88,

155750XFE,0X88,0XFE,0X88,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X88,

155760XFE,0X68,0XFE,0X89,0XFE,0X88,0XF6,0X46,0XF6,0X46,0XFE,0XC8,0XFE,0XE9,0XF6,0X89,

155770XF6,0X8B,0XEE,0X8C,0XEE,0X8D,0XEE,0XAF,0XF6,0XD1,0XF7,0X14,0XFF,0X58,0XFF,0X9A,

155780XFF,0XBC,0XFF,0X9D,0XFF,0X9E,0XFF,0XBE,0XFF,0XBF,0XFF,0XDF,0XFF,0XDF,0XF7,0XDF,

155790XF7,0XDE,0XF7,0XDE,0XF7,0XDE,0XF7,0XDE,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

155800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155830XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

155840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

155860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

155870XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,

155880XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XEF,0X7E,0XEF,0X7E,

155890XEF,0X5D,0XEF,0X5D,0XEF,0X5C,0XEF,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3B,0XE7,0X3B,

155900XE7,0X1C,0XE7,0X1C,0XDE,0XDB,0XDE,0XDB,0XE6,0XDA,0XE6,0XD9,0XE6,0XB7,0XE6,0X93,

155910XDE,0X70,0XE6,0X6D,0XEE,0X8B,0XF6,0XAA,0XFE,0X89,0XFE,0X68,0XFE,0X88,0XFE,0X67,

155920XFE,0X66,0XFE,0X86,0XFE,0X87,0XF6,0X87,0XF6,0X87,0XFE,0X88,0XFE,0X68,0XFE,0X68,

155930XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,0XFE,0X88,

155940XFE,0X67,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X88,0XF6,0X47,

155950XF6,0X48,0XFE,0XA9,0XFE,0XA8,0XF6,0X89,0XF6,0XAA,0XF6,0XAC,0XEE,0XAE,0XEE,0XB0,

155960XEE,0XD2,0XF7,0X14,0XF7,0X36,0XF7,0X58,0XF7,0X5A,0XF7,0X7B,0XF7,0X5C,0XEF,0X5C,

155970XEF,0X5C,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7E,0XEF,0X9E,0XEF,0X9D,0XF7,0X9D,

155980XEF,0X9D,0XF7,0X9D,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBF,0XF7,0XBE,0XF7,0XBE,

155990XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

156000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156020XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156050XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,

156060XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

156070XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XE7,0X5D,0XE7,0X3D,0XE7,0X1C,0XE7,0X1B,

156080XE6,0XFB,0XDE,0XDB,0XDE,0XDA,0XDE,0XDA,0XD6,0XD9,0XD6,0XB8,0XCE,0X58,0XCE,0X58,

156090XCE,0X59,0XCE,0X59,0XC5,0XF7,0XBD,0XB5,0XBD,0XB4,0XC5,0X92,0XC5,0X90,0XCD,0XAE,

156100XDE,0X0D,0XEE,0X8C,0XF6,0XAC,0XFE,0XAB,0XF6,0X69,0XFE,0X69,0XFE,0X68,0XFE,0X87,

156110XFE,0X87,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X68,0XFE,0X68,0XFE,0X48,0XFE,0X68,

156120XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X88,

156130XF6,0X88,0XF6,0X87,0XF6,0X87,0XF6,0X67,0XFE,0X88,0XFE,0X68,0XFE,0X89,0XFE,0X8A,

156140XF6,0X8B,0XF6,0XCC,0XEE,0XAE,0XD6,0X2E,0XCD,0XF0,0XCE,0X12,0XCE,0X33,0XCE,0X55,

156150XCE,0X76,0XD6,0X77,0XD6,0X98,0XDE,0XB9,0XDE,0XD9,0XDE,0XFA,0XDE,0XFA,0XDF,0X1B,

156160XDF,0X1B,0XDF,0X1B,0XE7,0X3C,0XE7,0X5D,0XE7,0X5C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,

156170XF7,0X7D,0XF7,0X7D,0XEF,0X7D,0XF7,0X9D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

156180XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

156190XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

156200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156210XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

156240XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

156250XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XEF,0X7D,0XEF,0X7D,0XEF,0X5D,

156260XEF,0X5D,0XE7,0X3D,0XE7,0X3D,0XE7,0X1C,0XDE,0XFB,0XDE,0XDA,0XDE,0XBA,0XD6,0X9A,

156270XD6,0X99,0XCE,0X79,0XC6,0X57,0XCE,0X57,0XBE,0X16,0XBD,0XF6,0XB5,0XD6,0XB5,0XB6,

156280XAD,0X55,0XA5,0X34,0XA4,0XF2,0XA4,0XD1,0X9C,0X6E,0X9C,0X2C,0XA4,0X8A,0XBD,0X2B,

156290XDE,0X0D,0XEE,0X8D,0XEE,0X4C,0XF6,0X8B,0XFE,0XAA,0XF6,0X89,0XF6,0X88,0XFE,0X88,

156300XFE,0X68,0XFE,0X68,0XFE,0X68,0XFE,0X67,0XFE,0X67,0XFE,0X67,0XFE,0X68,0XFE,0X68,

156310XFE,0X68,0XFE,0X88,0XFE,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,0XF6,0X88,

156320XF6,0X88,0XF6,0X88,0XFE,0X89,0XEE,0X48,0XFE,0X8A,0XFE,0XEE,0XF6,0X8E,0XC5,0X4A,

156330X8B,0XA6,0X5A,0X83,0X62,0XA6,0X63,0X09,0X6B,0X8B,0X7C,0X0E,0X8C,0X70,0X94,0XD1,

156340XA5,0X13,0XAD,0X74,0XB5,0XB5,0XB5,0XD6,0XBE,0X16,0XC6,0X37,0XC6,0X58,0XCE,0X79,

156350XCE,0X99,0XD6,0XBA,0XDE,0XDB,0XDE,0XFB,0XDE,0XFC,0XE6,0XFC,0XE7,0X1C,0XE7,0X1C,

156360XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,

156370XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

156380XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

156390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,

156400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156420XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,

156430XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

156440XF7,0X9E,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

156450XE7,0X1C,0XDF,0X1B,0XDE,0XFA,0XDE,0XDA,0XD6,0X9A,0XD6,0X9A,0XCE,0X5A,0XCE,0X59,

156460XC6,0X38,0XBD,0XF7,0XB5,0XD6,0XB5,0XB5,0XAD,0X75,0XA5,0X35,0X9C,0XF4,0X9C,0XD3,

156470X9C,0XB2,0X8C,0X50,0X83,0XCE,0X83,0XCD,0X83,0X8B,0X73,0X07,0X83,0X88,0XB4,0XEB,

156480XEE,0X90,0XF6,0XAF,0XEE,0X6C,0XF6,0X8B,0XF6,0X8A,0XF6,0X68,0XF6,0X88,0XFE,0X88,

156490XFE,0X88,0XFE,0X87,0XFE,0X87,0XFE,0X67,0XFE,0X87,0XFE,0X87,0XFE,0X87,0XF6,0X87,

156500XF6,0X87,0XF6,0X87,0XF6,0XA8,0XF6,0XA8,0XEE,0X68,0XEE,0X88,0XF6,0X89,0XEE,0X89,

156510XF6,0XAB,0XFF,0X0D,0XF6,0X8D,0XBC,0XC9,0X72,0XC3,0X49,0X80,0X39,0X61,0X41,0XC5,

156520X39,0XC6,0X39,0XE6,0X3A,0X06,0X42,0X47,0X4A,0X88,0X52,0XCA,0X63,0X0C,0X6B,0X8E,

156530X7C,0X10,0X84,0X50,0X8C,0X71,0X94,0XD2,0XA5,0X34,0XAD,0X95,0XB5,0XB6,0XBD,0XD7,

156540XBD,0XF8,0XCE,0X39,0XCE,0X59,0XD6,0X7A,0XDE,0XBB,0XDE,0XDB,0XDE,0XDB,0XE6,0XFB,

156550XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,

156560XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,

156570XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

156580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,

156590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

156610XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,

156620XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

156630XEF,0X7D,0XEF,0X7D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,

156640XE7,0X1B,0XDE,0XFB,0XDE,0XDB,0XDE,0XDB,0XDE,0XBC,0XD6,0X9B,0XCE,0X7A,0XCE,0X58,

156650XBE,0X17,0XBD,0XF7,0XBD,0XD7,0XAD,0X96,0XA5,0X35,0X9C,0XF4,0X94,0XB2,0X8C,0X50,

156660X7B,0XCF,0X73,0X8E,0X73,0X6D,0X62,0XCA,0X52,0X46,0X52,0X44,0X62,0XA4,0X9C,0X49,

156670XCD,0XED,0XE6,0X8E,0XEE,0X8C,0XF6,0X8B,0XF6,0X8B,0XF6,0X6A,0XF6,0X69,0XF6,0X89,

156680XF6,0X89,0XF6,0X88,0XF6,0X68,0XEE,0X67,0XF6,0X87,0XEE,0X87,0XF6,0XA8,0XEE,0X88,

156690XEE,0X89,0XEE,0X8A,0XEE,0XAB,0XF6,0XCC,0XF6,0XED,0XF6,0XCD,0XE6,0X4C,0XA4,0X87,

156700X62,0X60,0X41,0X60,0X41,0X80,0X49,0XE4,0X4A,0X06,0X4A,0X08,0X52,0X49,0X52,0X8A,

156710X52,0XAA,0X52,0XCA,0X52,0XC9,0X52,0XCA,0X5A,0XEC,0X6B,0X4E,0X6B,0X8E,0X73,0XCF,

156720X7B,0XF0,0X7C,0X30,0X8C,0X71,0X94,0XB2,0X9C,0XD3,0XA5,0X13,0XAD,0X55,0XB5,0X96,

156730XBD,0XB7,0XBD,0XD8,0XC6,0X18,0XCE,0X18,0XCE,0X38,0XCE,0X79,0XD6,0XBA,0XD6,0XBA,

156740XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,

156750XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,

156760XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

156770XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156790XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,

156800XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

156810XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XEF,0X7D,

156820XEF,0X7D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5C,0XE7,0X5C,0XE7,0X3C,0XE7,0X1C,

156830XE7,0X1C,0XE6,0XFD,0XDE,0XDD,0XDE,0XDC,0XDE,0XDB,0XD6,0XBA,0XD6,0X99,0XCE,0X79,

156840XCE,0X79,0XC6,0X59,0XBE,0X18,0XB5,0XD7,0XB5,0XB5,0XB5,0X95,0XA5,0X54,0X9C,0XD3,

156850X8C,0X72,0X84,0X10,0X73,0X8D,0X6B,0X2A,0X5A,0X86,0X4A,0X22,0X4A,0X20,0X73,0X23,

156860XA4,0XA8,0XCD,0XCC,0XDE,0X2D,0XE6,0X4D,0XEE,0X4C,0XEE,0X6C,0XEE,0X6C,0XEE,0X8C,

156870XEE,0X8B,0XEE,0X8B,0XEE,0XAB,0XEE,0XAB,0XEE,0X8B,0XEE,0X8B,0XE6,0X8C,0XE6,0X6D,

156880XE6,0X4D,0XCD,0XCC,0XA4,0X88,0X7B,0X23,0X49,0XC0,0X39,0XA0,0X39,0X81,0X41,0XC3,

156890X4A,0X05,0X4A,0X26,0X52,0X47,0X5A,0XA9,0X62,0XCB,0X63,0X0B,0X6B,0X4C,0X6B,0X6C,

156900X6B,0X4C,0X6B,0X4D,0X6B,0X6E,0X73,0X8F,0X73,0XAF,0X7C,0X10,0X84,0X31,0X8C,0X71,

156910X94,0X92,0X94,0XB2,0X9C,0XF3,0XA5,0X14,0XA5,0X35,0XB5,0X76,0XBD,0X97,0XBD,0XB7,

156920XC5,0XF8,0XC6,0X18,0XC6,0X18,0XCE,0X59,0XCE,0X79,0XD6,0X9A,0XD6,0XBA,0XDE,0XDB,

156930XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,

156940XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

156950XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156960XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

156980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

156990XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

157000XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XEF,0X7D,

157010XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7C,0XEF,0X5C,0XE7,0X3C,0XE7,0X3D,0XE7,0X1D,

157020XE7,0X1D,0XE6,0XFD,0XDE,0XFC,0XDE,0XFB,0XDE,0XFB,0XDE,0XDB,0XDE,0XDB,0XD6,0XBB,

157030XD6,0XBA,0XCE,0X99,0XCE,0X79,0XCE,0X78,0XCE,0X79,0XC6,0X58,0XBD,0XF8,0XBD,0XD8,

157040XB5,0XB7,0XAD,0X75,0XA5,0X32,0XA5,0X10,0X9C,0XCE,0X8C,0X4B,0X8C,0X09,0X94,0X4A,

157050XAC,0XCB,0XC5,0X8E,0XCD,0XAE,0XD5,0XCE,0XD5,0XEE,0XDE,0X0D,0XDE,0X2D,0XDE,0X2D,

157060XD5,0XEC,0XCD,0XCB,0XC5,0X8B,0XBD,0X4A,0XAC,0XC9,0X93,0XE7,0X73,0X04,0X5A,0X42,

157070X51,0XE2,0X49,0XC2,0X4A,0X05,0X4A,0X26,0X52,0X47,0X52,0X88,0X5A,0XC9,0X63,0X0A,

157080X6B,0X2A,0X73,0X6B,0X73,0X6C,0X7B,0X6D,0X83,0XCE,0X8B,0XEF,0X8C,0X0F,0X8C,0X50,

157090X8C,0X52,0X8C,0X51,0X84,0X30,0X8C,0X51,0X94,0X92,0X94,0XD2,0X9C,0XF3,0XA5,0X13,

157100XA5,0X34,0XAD,0X55,0XAD,0X55,0XB5,0X96,0XBD,0XB7,0XBD,0XD7,0XC5,0XF8,0XC6,0X18,

157110XC6,0X38,0XCE,0X59,0XCE,0X79,0XD6,0X9A,0XD6,0XBA,0XD6,0XBA,0XDE,0XDB,0XDE,0XDB,

157120XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,

157130XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

157140XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

157150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157170XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,

157180XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

157190XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

157200XF7,0XBD,0XF7,0X9D,0XF7,0X9D,0XEF,0X7D,0XEF,0X7E,0XEF,0X5E,0XEF,0X5E,0XEF,0X5D,

157210XE7,0X3C,0XEF,0X3C,0XE7,0X3C,0XE7,0X1B,0XE7,0X1C,0XE7,0X1C,0XDE,0XFB,0XDE,0XFB,

157220XDE,0XFB,0XD6,0XDA,0XD6,0XDA,0XD6,0XDA,0XD6,0XBA,0XD6,0XBA,0XD6,0XBA,0XCE,0XB9,

157230XD6,0XD9,0XD6,0XD8,0XDE,0XF8,0XD6,0XB7,0XDE,0XD8,0XE6,0XD7,0XD6,0X55,0XCD,0XF3,

157240XCD,0XF3,0XCD,0XD2,0XCD,0XD2,0XCD,0XD1,0XCD,0XD1,0XC5,0XB0,0XC5,0X8F,0XBD,0X6F,

157250XB5,0X2E,0XB5,0X0E,0XA4,0X8E,0X94,0X2D,0X94,0X0E,0X9C,0X50,0X9C,0X50,0X8B,0XEF,

157260X8C,0X30,0X8C,0X51,0X94,0X71,0X94,0X71,0X94,0X91,0X9C,0XB0,0X9C,0XD0,0XA4,0XD0,

157270XA4,0XF1,0XAC,0XF2,0XAD,0X13,0XB5,0X34,0XB5,0X55,0XB5,0X95,0XB5,0X96,0XB5,0X75,

157280XAD,0X74,0XAD,0X74,0XAD,0X74,0XAD,0X95,0XB5,0X95,0XB5,0XB6,0XBD,0XD7,0XBD,0XD7,

157290XC5,0XF8,0XC6,0X18,0XCE,0X18,0XCE,0X39,0XD6,0X79,0XD6,0X79,0XD6,0X99,0XD6,0X9A,

157300XD6,0XBA,0XD6,0XBA,0XDE,0XDB,0XDE,0XFB,0XDE,0XFB,0XDE,0XFB,0XE7,0X1C,0XE7,0X1C,

157310XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,

157320XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,

157330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

157340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

157360XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

157370XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

157380XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

157390XF7,0XBE,0XF7,0X9E,0XF7,0X9F,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9D,0XF7,0X9D,

157400XEF,0X7C,0XEF,0X5C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5C,0XE7,0X3C,0XEF,0X5C,0XE7,0X5C,

157410XE7,0X5C,0XE7,0X3C,0XE7,0X3B,0XEF,0X5C,0XEF,0X9D,0XEF,0X9D,0XF7,0XBD,0XEF,0XBD,

157420XF7,0X9D,0XF7,0X9D,0XEF,0X7C,0XEF,0X3B,0XEF,0X1A,0XF7,0X5B,0XF7,0X5A,0XF7,0X3A,

157430XEF,0X19,0XEE,0XF9,0XE6,0XF8,0XE6,0XD7,0XE6,0XD7,0XE6,0XD8,0XE6,0XD8,0XE6,0XD8,

157440XE6,0XD9,0XE6,0XB9,0XE6,0XBA,0XDE,0X7A,0XE6,0X9B,0XEE,0XDC,0XDE,0X9A,0XDE,0XBA,

157450XDE,0XBB,0XD6,0X9A,0XD6,0X99,0XD6,0X98,0XD6,0X97,0XDE,0XB7,0XDE,0X98,0XDE,0X99,

157460XDE,0X9A,0XDE,0X9A,0XDE,0X99,0XDE,0XBA,0XDE,0XDA,0XDE,0XD9,0XDE,0XD9,0XD6,0X98,

157470XD6,0X78,0XCE,0X58,0XC6,0X38,0XCE,0X58,0XCE,0X79,0XCE,0X79,0XD6,0X7A,0XD6,0X7A,

157480XD6,0X9A,0XD6,0X9A,0XD6,0XBA,0XDE,0XDA,0XDE,0XDA,0XDE,0XDA,0XDE,0XFB,0XDE,0XFB,

157490XE7,0X1C,0XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,

157500XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,

157510XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XFF,

157520XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

157550XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,

157560XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

157570XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBF,

157580XF7,0XBF,0XF7,0XBF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBD,0XF7,0XBD,0XF7,0X9D,0XF7,0X9E,

157590XF7,0X9E,0XF7,0X7E,0XF7,0X7E,0XF7,0X7E,0XEF,0X5D,0XEF,0X5D,0XF7,0X7D,0XF7,0X9D,

157600XFF,0XBD,0XFF,0XFE,0XFF,0XFE,0XF7,0XDD,0XFF,0XDE,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

157610XFF,0XDE,0XFF,0XDE,0XFF,0XDD,0XFF,0XBC,0XF7,0X7C,0XF7,0X9C,0XFF,0XBD,0XFF,0XBD,

157620XFF,0XBC,0XFF,0X9C,0XF7,0X9B,0XF7,0X9B,0XF7,0X9B,0XF7,0X7B,0XF7,0X5B,0XEF,0X5B,

157630XFF,0X9C,0XFF,0XBD,0XF7,0X7C,0XEF,0X3B,0XF7,0X7C,0XF7,0X5C,0XF7,0X5C,0XF7,0X5C,

157640XF7,0X7C,0XF7,0X7C,0XF7,0X7C,0XF7,0X7C,0XF7,0X5C,0XF7,0X7D,0XF7,0X7D,0XF7,0X7C,

157650XF7,0X7C,0XF7,0X7B,0XF7,0X7B,0XF7,0X7C,0XFF,0X9D,0XF7,0X7C,0XEF,0X5C,0XE7,0X3C,

157660XDE,0XFB,0XDE,0XDB,0XDE,0XFB,0XE7,0X1C,0XE6,0XFC,0XE6,0XFC,0XE7,0X1C,0XE7,0X1C,

157670XE7,0X1C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XE7,0X3C,0XEF,0X5D,

157680XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,

157690XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,

157700XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

157710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

157740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

157760XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XBF,0XFF,0XDF,0XFF,0XDF,0XF7,0XDF,0XF7,0XDF,

157770XF7,0XDF,0XFF,0XDE,0XF7,0XDE,0XFF,0XDD,0XFF,0XDE,0XFF,0XDF,0XFF,0XBF,0XF7,0X9F,

157780XF7,0X9F,0XFF,0XBF,0XFF,0XBF,0XFF,0XBF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFE,0XFF,0XFE,

157790XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XF7,0XBF,0XF7,0XDF,0XFF,0XFF,0XFF,0XFF,

157800XFF,0XFF,0XFF,0XDE,0XFF,0XFE,0XFF,0XDE,0XFF,0XDE,0XFF,0XDE,0XFF,0XFE,0XFF,0XFE,

157810XFF,0XFE,0XFF,0XFE,0XFF,0XFD,0XFF,0XFE,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,0XFF,0XDD,

157820XFF,0XDC,0XFF,0XFD,0XFF,0XBD,0XFF,0XDE,0XFF,0XDE,0XFF,0XBD,0XFF,0XBD,0XFF,0XBD,

157830XFF,0XBE,0XFF,0XDE,0XFF,0XBE,0XFF,0XDE,0XFF,0XBE,0XFF,0XDE,0XFF,0XDD,0XFF,0XDD,

157840XFF,0XBD,0XFF,0XDD,0XFF,0XBE,0XFF,0XBE,0XFF,0XDE,0XFF,0XBE,0XEF,0X5D,0XE7,0X3C,

157850XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X5D,0XEF,0X7D,0XEF,0X5D,0XEF,0X7D,

157860XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

157870XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,

157880XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

157890XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XF7,0XBE,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

157900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157960XFF,0XFE,0XFF,0XFE,0XFF,0XFE,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

157970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

157990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158020XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0X9E,0XEF,0X7D,

158040XEF,0X7D,0XEF,0X7D,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0X9E,

158050XF7,0X9E,0XF7,0X9E,0XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

158060XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

158070XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

158080XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

158160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XF7,0X9E,0XF7,0X9E,

158230XF7,0X9E,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

158240XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,

158250XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

158260XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,

158270XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XF7,0XBE,0XF7,0XBE,0XFF,0XDF,

158420XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

158430XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,

158440XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,

158460XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158600XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,

158610XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158640XFF,0XFF,0XFF,0XFF,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XF7,0XBE,0XFF,0XFF,0XFF,0XFF,

158650XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158790XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158800XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158810XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158820XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158830XF7,0XBE,0XF7,0XBE,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158840XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158850XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158860XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158870XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158880XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158890XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158900XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158910XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158920XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158930XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158940XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158950XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158960XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158970XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158980XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

158990XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159000XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159010XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,

159020XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159030XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159040XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159050XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159060XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159070XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159080XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159090XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159100XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159110XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159120XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159130XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159140XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159150XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159160XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159170XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159180XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159190XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159200XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XDF,0XFF,0XFF,0XFF,0XDF,

159210XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159220XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159230XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159240XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159250XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159260XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159270XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159280XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159290XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159300XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159310XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159320XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159330XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159340XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159350XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159360XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159370XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159380XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159390XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XDF,0XFF,0XFF,0XFF,0XFF,

159400XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159410XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159420XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159430XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159440XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159450XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159460XFF,0XFF,0XFF,0XFE,0XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159470XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159480XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159490XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159500XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159510XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159520XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159530XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159540XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159550XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159560XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159570XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159580XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159590XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159600XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159610XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159620XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159630XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159640XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFE,

159650XFF,0XFE,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159660XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159670XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159680XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159690XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159700XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159710XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159720XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159730XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159740XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159750XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159760XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159770XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,

159780XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,0XFF,};

15979

15980#endif

15981

15982

15983

15984

gimage_9

const unsigned char gimage_9[51000]

Definition: at_start_f437/examples/xmc/lcd_8bit/inc/picture.h:9600

gimage_5

const unsigned char gimage_5[51000]

Definition: at_start_f437/examples/xmc/lcd_8bit/inc/picture.h:6410

gimage_8

const unsigned char gimage_8[51000]

Definition: at_start_f437/examples/xmc/lcd_8bit/inc/picture.h:3220

gimage_3

const unsigned char gimage_3[51000]

Definition: at_start_f437/examples/xmc/lcd_8bit/inc/picture.h:29

gimage_0

const unsigned char gimage_0[51000]

Definition: at_start_f437/examples/xmc/lcd_8bit/inc/picture.h:12790

Generated by 1.9.2


AT32F435/437 Firmwary Library: xmc_lcd.h File Reference

  • at_start_f437
  • examples
  • xmc
  • lcd_8bit
  • inc
Macros | Functions
at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h File Reference

xmc_lcd header file More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | XMC_LCD_COMMAND 0x60000000
#define | XMC_LCD_DATA 0x60000001
#define | LCD_RESET_HIGH gpio_bits_set(GPIOB,GPIO_PINS_9)
#define | LCD_RESET_LOW gpio_bits_reset(GPIOB,GPIO_PINS_9)
#define | WHITE 0xFFFF
#define | BLACK 0x0000
#define | BLUE 0x001F
#define | BRED 0xF81F
#define | GRED 0xFFE0
#define | GBLUE 0x07FF
#define | RED 0xF800
#define | MAGENTA 0xF81F
#define | GREEN 0x07E0
#define | CYAN 0x7FFF
#define | YELLOW 0xFFE0
#define | BROWN 0xBC40
#define | BRRED 0xFC07
#define | GRAY 0x8430

Functions

void | xmc_init (void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_init (void)
configures the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_wr_command (uint8_t command)
this function is write command to lcd. More...
void | lcd_wr_data (uint8_t data)
this function is write data to lcd. More...
void | lcd_setblock (uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd. More...
void | lcd_writeonepoint (uint16_t color)
this function is write one point to lcd. More...
void | lcd_drawpoint (uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd. More...
void | lcd_clear (uint16_t color)
this function is clear the lcd. More...
void | lcd_display_number (void)
this function is display number on the lcd. More...

Detailed Description

xmc_lcd header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h.


AT32F435/437 Firmwary Library: xmc_lcd.h Source File

  • at_start_f437
  • examples
  • xmc
  • lcd_8bit
  • inc
at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h
Go to the documentation of this file.
1
27#ifndef __XMC_LCD_H
28#define __XMC_LCD_H
29
30#include "at32f435_437_board.h"
31
40/* the address of write data & command (xmc_a0) */
41#define XMC_LCD_COMMAND 0x60000000
42#define XMC_LCD_DATA 0x60000001
43
52/* the lcd reset line */
53#define LCD_RESET_HIGH gpio_bits_set(GPIOB,GPIO_PINS_9)
54#define LCD_RESET_LOW gpio_bits_reset(GPIOB,GPIO_PINS_9)
55
60#define WHITE 0xFFFF
61#define BLACK 0x0000
62#define BLUE 0x001F
63#define BRED 0xF81F
64#define GRED 0xFFE0
65#define GBLUE 0x07FF
66#define RED 0xF800
67#define MAGENTA 0xF81F
68#define GREEN 0x07E0
69#define CYAN 0x7FFF
70#define YELLOW 0xFFE0
71#define BROWN 0xBC40
72#define BRRED 0xFC07
73#define GRAY 0x8430
74
79void xmc_init(void);
80void lcd_init(void);
81void lcd_wr_command(uint8_t command);
82void lcd_wr_data(uint8_t data);
83void lcd_setblock(uint16_t xstart,uint16_t ystart,uint16_t xend,uint16_t yend);
84void lcd_writeonepoint(uint16_t color);
85void lcd_drawpoint(uint16_t x,uint16_t y,uint16_t color);
86void lcd_clear(uint16_t color);
87void lcd_display_number(void);
88
101#endif
at32f435_437_board.h
lcd_setblock
void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:332
lcd_init
void lcd_init(void)
configures the lcd. this function must be called before any write/read operation on the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:165
lcd_drawpoint
void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:367
lcd_wr_command
void lcd_wr_command(uint16_t command)
this function is write command to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:300
lcd_clear
void lcd_clear(uint16_t color)
this function is clear the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:379
lcd_writeonepoint
void lcd_writeonepoint(uint16_t color)
this function is write one point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:357
lcd_wr_data
void lcd_wr_data(uint16_t data)
this function is write data to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:310
xmc_init
void xmc_init(void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write...
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:57
lcd_display_number
void lcd_display_number(void)
this function is display number on the lcd.
Definition: at_start_f437/examples/xmc/lcd_8bit/src/xmc_lcd.c:347


AT32F435/437 Firmwary Library: xmc_lcd.c File Reference

  • at_start_f437
  • examples
  • xmc
  • lcd_8bit
  • src
Functions
at_start_f437/examples/xmc/lcd_8bit/src/xmc_lcd.c File Reference

xmc_lcd config program More...

#include "at32f435_437_board.h"
#include "xmc_lcd.h"
#include "picture.h"

Go to the source code of this file.

Functions

void | xmc_init (void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_init (void)
configures the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_wr_command (uint8_t command)
this function is write command to lcd. More...
void | lcd_wr_data (uint8_t data)
this function is write data to lcd. More...
void | lcd_setblock (uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd. More...
void | lcd_writeonepoint (uint16_t color)
this function is write one point to lcd. More...
void | lcd_drawpoint (uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd. More...
void | lcd_clear (uint16_t color)
this function is clear the lcd. More...
void | lcd_display_number (void)
this function is display number on the lcd. More...

Detailed Description

xmc_lcd config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/xmc/lcd_8bit/src/xmc_lcd.c.


AT32F435/437 Firmwary Library: xmc_lcd.c Source File

  • at_start_f437
  • examples
  • xmc
  • lcd_8bit
  • src
at_start_f437/examples/xmc/lcd_8bit/src/xmc_lcd.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "xmc_lcd.h"
29#include "picture.h"
30
46void xmc_init(void)
47{
48 gpio_init_type gpio_init_struct = {0};
49 xmc_norsram_init_type xmc_norsram_init_struct;
50 xmc_norsram_timing_init_type rw_timing_struct, w_timing_struct;
51
52 /* enable the gpio clock */
53 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
54 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
55 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
56 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
57 crm_periph_clock_enable(CRM_GPIOF_PERIPH_CLOCK, TRUE);
58
59 /* enable the xmc clock */
60 crm_periph_clock_enable(CRM_XMC_PERIPH_CLOCK, TRUE);
61
62 /*-- gpio configuration ------------------------------------------------------*/
63 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_12);
64 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE5, GPIO_MUX_12);
65 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE7, GPIO_MUX_12);
66 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE0, GPIO_MUX_12);
67 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_12);
68 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE14, GPIO_MUX_12);
69 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE15, GPIO_MUX_12);
70 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE7, GPIO_MUX_12);
71 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE8, GPIO_MUX_12);
72 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE9, GPIO_MUX_12);
73 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE10, GPIO_MUX_12);
74 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE0, GPIO_MUX_12);
75
76 /* ne1/nwe/noe lines configuration */
77 gpio_init_struct.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_7 ;
78 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
79 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
80 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
81 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
82 gpio_init(GPIOD, &gpio_init_struct);
83
84 /* a0 lines configuration */
85 gpio_init_struct.gpio_pins = GPIO_PINS_0;
86 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
87 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
88 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
89 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
90 gpio_init(GPIOF, &gpio_init_struct);
91
92 /* data lines configuration */
93 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_14 | GPIO_PINS_15;
94 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
95 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
96 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
97 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
98 gpio_init(GPIOD, &gpio_init_struct);
99
100 gpio_init_struct.gpio_pins = GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10;
101 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
102 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
103 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
104 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
105 gpio_init(GPIOE, &gpio_init_struct);
106
107 /* lcd reset lines configuration */
108 gpio_init_struct.gpio_pins = GPIO_PINS_9;
109 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
110 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
111 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
112 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
113 gpio_init(GPIOB, &gpio_init_struct);
114
115 /*-- xmc configuration ------------------------------------------------------*/
116 xmc_norsram_default_para_init(&xmc_norsram_init_struct);
117 xmc_norsram_init_struct.subbank = XMC_BANK1_NOR_SRAM1;
118 xmc_norsram_init_struct.data_addr_multiplex = XMC_DATA_ADDR_MUX_DISABLE;
119 xmc_norsram_init_struct.device = XMC_DEVICE_SRAM;
120 xmc_norsram_init_struct.bus_type = XMC_BUSTYPE_8_BITS;
121 xmc_norsram_init_struct.burst_mode_enable = XMC_BURST_MODE_DISABLE;
122 xmc_norsram_init_struct.asynwait_enable = XMC_ASYN_WAIT_DISABLE;
123 xmc_norsram_init_struct.wait_signal_lv = XMC_WAIT_SIGNAL_LEVEL_LOW;
124 xmc_norsram_init_struct.wrapped_mode_enable = XMC_WRAPPED_MODE_DISABLE;
125 xmc_norsram_init_struct.wait_signal_config = XMC_WAIT_SIGNAL_SYN_BEFORE;
126 xmc_norsram_init_struct.write_enable = XMC_WRITE_OPERATION_ENABLE;
127 xmc_norsram_init_struct.wait_signal_enable = XMC_WAIT_SIGNAL_DISABLE;
128 xmc_norsram_init_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
129 xmc_norsram_init_struct.write_burst_syn = XMC_WRITE_BURST_SYN_DISABLE;
130 xmc_nor_sram_init(&xmc_norsram_init_struct);
131
132 /* timing configuration */
133 xmc_norsram_timing_default_para_init(&rw_timing_struct, &w_timing_struct);
134 rw_timing_struct.subbank = XMC_BANK1_NOR_SRAM1;
135 rw_timing_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
136 rw_timing_struct.addr_setup_time = 0x2;
137 rw_timing_struct.addr_hold_time = 0x0;
138 rw_timing_struct.data_setup_time = 0x2;
139 rw_timing_struct.bus_latency_time = 0x0;
140 rw_timing_struct.clk_psc = 0x0;
141 rw_timing_struct.data_latency_time = 0x0;
142 rw_timing_struct.mode = XMC_ACCESS_MODE_A;
143 w_timing_struct.subbank = XMC_BANK1_NOR_SRAM1;
144 w_timing_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
145 w_timing_struct.addr_setup_time = 0x2;
146 w_timing_struct.addr_hold_time = 0x0;
147 w_timing_struct.data_setup_time = 0x2;
148 w_timing_struct.bus_latency_time = 0x0;
149 w_timing_struct.clk_psc = 0x0;
150 w_timing_struct.data_latency_time = 0x0;
151 w_timing_struct.mode = XMC_ACCESS_MODE_A;
152 xmc_nor_sram_timing_config(&rw_timing_struct, &w_timing_struct);
153
154 /* bus turnaround phase for consecutive read duration and consecutive write duration */
155 xmc_ext_timing_config(XMC_BANK1_NOR_SRAM1, 0x08, 0x08);
156
157 /* enable xmc_bank1_nor_sram4 */
158 xmc_nor_sram_enable(XMC_BANK1_NOR_SRAM1, TRUE);
159}
160
168void lcd_init(void)
169{
170 /* init xmc */
171 xmc_init();
172 delay_ms(50);
173
174 /* reset lcd */
175 LCD_RESET_HIGH;
176 delay_ms(1);
177 LCD_RESET_LOW;
178 delay_ms(10);
179 LCD_RESET_HIGH;
180 delay_ms(120);
181 lcd_wr_command(0x36);
182 lcd_wr_data(0x00);
183 lcd_wr_command(0x3a);
184 lcd_wr_data(0x55);
185
186 /* 320*240 */
187 lcd_wr_command(0x2a);
188 lcd_wr_data(0x00);
189 lcd_wr_data(0x00);
190 lcd_wr_data(0x01);
191 lcd_wr_data(0x3f);
192 lcd_wr_command(0x2b);
193 lcd_wr_data(0x00);
194 lcd_wr_data(0x00);
195 lcd_wr_data(0x00);
196 lcd_wr_data(0xef);
197 lcd_wr_command(0xb2);
198 lcd_wr_data(0x0c);
199 lcd_wr_data(0x0c);
200 lcd_wr_data(0x00);
201 lcd_wr_data(0x33);
202 lcd_wr_data(0x33);
203 lcd_wr_command(0xb7);
204 lcd_wr_data(0x35);
205 lcd_wr_command(0xbb);
206 lcd_wr_data(0x30);
207 lcd_wr_command(0xc3);
208 lcd_wr_data(0x1c);
209 lcd_wr_command(0xc4);
210 lcd_wr_data(0x18);
211 lcd_wr_command(0xc6);
212 lcd_wr_data(0x0f);
213 lcd_wr_command(0xd0);
214 lcd_wr_data(0xa4);
215 lcd_wr_data(0xa2);
216 lcd_wr_command(0xe0);
217 lcd_wr_data(0xf0);
218 lcd_wr_data(0x00);
219 lcd_wr_data(0x0a);
220 lcd_wr_data(0x10);
221 lcd_wr_data(0x12);
222 lcd_wr_data(0x1b);
223 lcd_wr_data(0x39);
224 lcd_wr_data(0x44);
225 lcd_wr_data(0x47);
226 lcd_wr_data(0x28);
227 lcd_wr_data(0x12);
228 lcd_wr_data(0x10);
229 lcd_wr_data(0x16);
230 lcd_wr_data(0x1b);
231 lcd_wr_command(0xe1);
232 lcd_wr_data(0xf0);
233 lcd_wr_data(0x00);
234 lcd_wr_data(0x0a);
235 lcd_wr_data(0x10);
236 lcd_wr_data(0x11);
237 lcd_wr_data(0x1a);
238 lcd_wr_data(0x3b);
239 lcd_wr_data(0x34);
240 lcd_wr_data(0x4e);
241 lcd_wr_data(0x3a);
242 lcd_wr_data(0x17);
243 lcd_wr_data(0x16);
244 lcd_wr_data(0x21);
245 lcd_wr_data(0x22);
246 lcd_wr_command(0x3a);
247 lcd_wr_data(0x55);
248 lcd_wr_command(0x11);
249 delay_ms(120);
250
251 /* display on */
252 lcd_wr_command(0x29);
253}
254
260void lcd_wr_command(uint8_t command)
261{
262 *(__IO uint8_t *) XMC_LCD_COMMAND = command;
263}
264
270void lcd_wr_data(uint8_t data)
271{
272 *(__IO uint8_t *) XMC_LCD_DATA = data;
273}
274
283void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
284{
285 /* set row coordinates */
286 lcd_wr_command(0x2a);
287 lcd_wr_data(xstart >> 8);
288 lcd_wr_data(xstart);
289 lcd_wr_data(xend >> 8);
290 lcd_wr_data(xend);
291
292 /* set column coordinates */
293 lcd_wr_command(0x2b);
294 lcd_wr_data(ystart >> 8);
295 lcd_wr_data(ystart);
296 lcd_wr_data(yend >> 8);
297 lcd_wr_data(yend);
298 /* enable write menory */
299 lcd_wr_command(0x2c);
300}
301
307void lcd_writeonepoint(uint16_t color)
308{
309 lcd_wr_data(color >> 8);
310 lcd_wr_data(color);
311}
312
318void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
319{
320 lcd_setblock(x, y, x, y);
321
322 lcd_writeonepoint(color);
323}
324
330void lcd_clear(uint16_t color)
331{
332 uint32_t i;
333
334 lcd_setblock(0, 0, 240, 320);
335
336 for(i = 0; i < 76800; i++)
337 {
338 lcd_writeonepoint(color);
339 }
340}
341
347void lcd_display_number(void)
348{
349 int i;
350
351 lcd_setblock(50, 50, 199, 219);
352
353 for(i=0; i<sizeof(gimage_8); i++)
354 {
355 lcd_wr_data(gimage_8[i]);
356 }
357
358 delay_ms(1000);
359 lcd_setblock(50, 50, 199, 219);
360
361 for(i=0; i<sizeof(gimage_3); i++)
362 {
363 lcd_wr_data(gimage_3[i]);
364 }
365
366 delay_ms(1000);
367 lcd_setblock(50, 50, 199, 219);
368
369 for(i=0; i<sizeof(gimage_5); i++)
370 {
371 lcd_wr_data(gimage_5[i]);
372 }
373
374 delay_ms(1000);
375 lcd_setblock(50, 50, 199, 219);
376
377 for(i=0; i<sizeof(gimage_9); i++)
378 {
379 lcd_wr_data(gimage_9[i]);
380 }
381
382 delay_ms(1000);
383 lcd_setblock(50, 50, 199, 219);
384
385 for(i=0; i<sizeof(gimage_0); i++)
386 {
387 lcd_wr_data(gimage_0[i]);
388 }
389
390 delay_ms(1000);
391}
392
at32f435_437_board.h
gimage_9
const unsigned char gimage_9[51000]
Definition: at_start_f435/examples/xmc/lcd_8bit/inc/picture.h:9600
gimage_5
const unsigned char gimage_5[51000]
Definition: at_start_f435/examples/xmc/lcd_8bit/inc/picture.h:6410
gimage_8
const unsigned char gimage_8[51000]
Definition: at_start_f435/examples/xmc/lcd_8bit/inc/picture.h:3220
gimage_3
const unsigned char gimage_3[51000]
Definition: at_start_f435/examples/xmc/lcd_8bit/inc/picture.h:29
gimage_0
const unsigned char gimage_0[51000]
Definition: at_start_f435/examples/xmc/lcd_8bit/inc/picture.h:12790
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
lcd_setblock
void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:332
lcd_init
void lcd_init(void)
configures the lcd. this function must be called before any write/read operation on the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:165
lcd_drawpoint
void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:367
lcd_wr_command
void lcd_wr_command(uint16_t command)
this function is write command to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:300
lcd_clear
void lcd_clear(uint16_t color)
this function is clear the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:379
lcd_writeonepoint
void lcd_writeonepoint(uint16_t color)
this function is write one point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:357
lcd_wr_data
void lcd_wr_data(uint16_t data)
this function is write data to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:310
xmc_init
void xmc_init(void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write...
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:57
XMC_LCD_COMMAND
#define XMC_LCD_COMMAND
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:65
XMC_LCD_DATA
#define XMC_LCD_DATA
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:66
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_XMC_PERIPH_CLOCK
@ CRM_XMC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:123
CRM_GPIOF_PERIPH_CLOCK
@ CRM_GPIOF_PERIPH_CLOCK
Definition: at32f435_437_crm.h:110
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOF
#define GPIOF
Definition: at32f435_437_gpio.h:526
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
LCD_RESET_HIGH
#define LCD_RESET_HIGH
Definition: at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h:53
LCD_RESET_LOW
#define LCD_RESET_LOW
Definition: at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h:54
xmc_nor_sram_init
void xmc_nor_sram_init(xmc_norsram_init_type *xmc_norsram_init_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_norsraminitstruct.
Definition: at32f435_437_xmc.c:78
xmc_norsram_timing_default_para_init
void xmc_norsram_timing_default_para_init(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
fill each xmc_rw_timing_struct and xmc_w_timing_struct member with its default value.
Definition: at32f435_437_xmc.c:176
xmc_nor_sram_timing_config
void xmc_nor_sram_timing_config(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_rw_timing_struct a...
Definition: at32f435_437_xmc.c:113
xmc_ext_timing_config
void xmc_ext_timing_config(xmc_nor_sram_subbank_type xmc_sub_bank, uint16_t w2w_timing, uint16_t r2r_timing)
config the bus turnaround phase.
Definition: at32f435_437_xmc.c:227
xmc_norsram_default_para_init
void xmc_norsram_default_para_init(xmc_norsram_init_type *xmc_nor_sram_init_struct)
fill each xmc_nor_sram_init_struct member with its default value.
Definition: at32f435_437_xmc.c:150
xmc_nor_sram_enable
void xmc_nor_sram_enable(xmc_nor_sram_subbank_type xmc_subbank, confirm_state new_state)
enable or disable the specified nor/sram memory bank.
Definition: at32f435_437_xmc.c:210
XMC_WAIT_SIGNAL_DISABLE
@ XMC_WAIT_SIGNAL_DISABLE
Definition: at32f435_437_xmc.h:101
XMC_WAIT_SIGNAL_SYN_BEFORE
@ XMC_WAIT_SIGNAL_SYN_BEFORE
Definition: at32f435_437_xmc.h:196
XMC_WRITE_OPERATION_ENABLE
@ XMC_WRITE_OPERATION_ENABLE
Definition: at32f435_437_xmc.h:93
XMC_WRITE_BURST_SYN_DISABLE
@ XMC_WRITE_BURST_SYN_DISABLE
Definition: at32f435_437_xmc.h:110
XMC_BURST_MODE_DISABLE
@ XMC_BURST_MODE_DISABLE
Definition: at32f435_437_xmc.h:65
XMC_DATA_ADDR_MUX_DISABLE
@ XMC_DATA_ADDR_MUX_DISABLE
Definition: at32f435_437_xmc.h:56
XMC_BUSTYPE_8_BITS
@ XMC_BUSTYPE_8_BITS
Definition: at32f435_437_xmc.h:178
XMC_WRITE_TIMING_ENABLE
@ XMC_WRITE_TIMING_ENABLE
Definition: at32f435_437_xmc.h:120
XMC_BANK1_NOR_SRAM1
@ XMC_BANK1_NOR_SRAM1
Definition: at32f435_437_xmc.h:146
XMC_ASYN_WAIT_DISABLE
@ XMC_ASYN_WAIT_DISABLE
Definition: at32f435_437_xmc.h:74
XMC_WRAPPED_MODE_DISABLE
@ XMC_WRAPPED_MODE_DISABLE
Definition: at32f435_437_xmc.h:83
XMC_ACCESS_MODE_A
@ XMC_ACCESS_MODE_A
Definition: at32f435_437_xmc.h:205
XMC_WAIT_SIGNAL_LEVEL_LOW
@ XMC_WAIT_SIGNAL_LEVEL_LOW
Definition: at32f435_437_xmc.h:187
XMC_DEVICE_SRAM
@ XMC_DEVICE_SRAM
Definition: at32f435_437_xmc.h:168
lcd_display_number
void lcd_display_number(void)
this function is display number on the lcd.
Definition: at_start_f437/examples/xmc/lcd_8bit/src/xmc_lcd.c:347
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
xmc_norsram_init_type
xmc nor/sram init structure definition
Definition: at32f435_437_xmc.h:409
xmc_norsram_init_type::wait_signal_enable
xmc_wait_signal_type wait_signal_enable
Definition: at32f435_437_xmc.h:420
xmc_norsram_init_type::data_addr_multiplex
xmc_data_addr_mux_type data_addr_multiplex
Definition: at32f435_437_xmc.h:411
xmc_norsram_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:421
xmc_norsram_init_type::burst_mode_enable
xmc_burst_access_mode_type burst_mode_enable
Definition: at32f435_437_xmc.h:414
xmc_norsram_init_type::bus_type
xmc_data_width_type bus_type
Definition: at32f435_437_xmc.h:413
xmc_norsram_init_type::device
xmc_memory_type device
Definition: at32f435_437_xmc.h:412
xmc_norsram_init_type::wait_signal_lv
xmc_wait_signal_polarity_type wait_signal_lv
Definition: at32f435_437_xmc.h:416
xmc_norsram_init_type::wrapped_mode_enable
xmc_wrap_mode_type wrapped_mode_enable
Definition: at32f435_437_xmc.h:417
xmc_norsram_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:410
xmc_norsram_init_type::write_burst_syn
xmc_write_burst_type write_burst_syn
Definition: at32f435_437_xmc.h:422
xmc_norsram_init_type::asynwait_enable
xmc_asyn_wait_type asynwait_enable
Definition: at32f435_437_xmc.h:415
xmc_norsram_init_type::wait_signal_config
xmc_wait_timing_type wait_signal_config
Definition: at32f435_437_xmc.h:418
xmc_norsram_init_type::write_enable
xmc_write_operation_type write_enable
Definition: at32f435_437_xmc.h:419
xmc_norsram_timing_init_type
nor/sram banks timing parameters
Definition: at32f435_437_xmc.h:393
xmc_norsram_timing_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:395
xmc_norsram_timing_init_type::data_latency_time
uint32_t data_latency_time
Definition: at32f435_437_xmc.h:401
xmc_norsram_timing_init_type::addr_hold_time
uint32_t addr_hold_time
Definition: at32f435_437_xmc.h:397
xmc_norsram_timing_init_type::bus_latency_time
uint32_t bus_latency_time
Definition: at32f435_437_xmc.h:399
xmc_norsram_timing_init_type::addr_setup_time
uint32_t addr_setup_time
Definition: at32f435_437_xmc.h:396
xmc_norsram_timing_init_type::mode
xmc_access_mode_type mode
Definition: at32f435_437_xmc.h:402
xmc_norsram_timing_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:394
xmc_norsram_timing_init_type::clk_psc
uint32_t clk_psc
Definition: at32f435_437_xmc.h:400
xmc_norsram_timing_init_type::data_setup_time
uint32_t data_setup_time
Definition: at32f435_437_xmc.h:398


AT32F435/437 Firmwary Library: touch.h File Reference

  • at_start_f437
  • examples
  • xmc
  • lcd_touch_16bit
  • inc
Data Structures | Macros | Functions | Variables
at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h File Reference

this file contains all the functions prototypes for the touch firmware driver. More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Data Structures

struct touch_dev_type

Macros

#define | TCLK_HIGH gpio_bits_set(GPIOB,GPIO_PINS_13)
#define | TCLK_LOW gpio_bits_reset(GPIOB,GPIO_PINS_13)
#define | TDOUT gpio_input_data_bit_read(GPIOB,GPIO_PINS_8)
#define | TDIN_HIGH gpio_bits_set(GPIOA,GPIO_PINS_1)
#define | TDIN_LOW gpio_bits_reset(GPIOA,GPIO_PINS_1)
#define | PEN_HIGH gpio_input_data_bit_read(GPIOB,GPIO_PINS_11)
#define | TCS_HIGH gpio_bits_set(GPIOB,GPIO_PINS_12)
#define | TCS_LOW gpio_bits_reset(GPIOB,GPIO_PINS_12)

Functions

void | touch_pin_init (void)
this function is init touch pin. More...
void | touch_read_xy (uint16_t *x, uint16_t *y)
this function is read data from touch. More...
void | touch_scan (void)
this function is scanning the screen. More...
uint16_t | touch_read_x_or_y (uint8_t xy)
uint16_t | touch_read_ad (uint8_t xy)
this function is read data from touch. More...
void | touch_write_1byte (uint8_t cmd)
this function is write command to touch. More...
uint8_t | touch_read_1byte (void)
this function is read data from touch. More...
error_status | touch_adjust (void)
this function is adjust the screen. More...

Variables

touch_dev_type touch_dev_struct
touch_dev_type * touch_struct

Detailed Description

this file contains all the functions prototypes for the touch firmware driver.

Version
v2.0.9
Date
2022-06-28
        Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h.


AT32F435/437 Firmwary Library: touch.h Source File

  • at_start_f437
  • examples
  • xmc
  • lcd_touch_16bit
  • inc
at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h
Go to the documentation of this file.
1
29#ifndef __TOUCH_H
30#define __TOUCH_H
31
32#include "at32f435_437_board.h"
33
46typedef struct
47{
48 void (*init)(void);
49 void (*touch_read_xy)(uint16_t *x, uint16_t *y);
50 void (*touch_scan)(void);
51 error_status (*touch_adjust)(void);
52 uint16_t x_p[6];
53 uint16_t y_p[6];
54}touch_dev_type;
55
60extern touch_dev_type touch_dev_struct;
61extern touch_dev_type *touch_struct;
62
63#define TCLK_HIGH gpio_bits_set(GPIOB,GPIO_PINS_13)
64#define TCLK_LOW gpio_bits_reset(GPIOB,GPIO_PINS_13)
65
66#define TDOUT gpio_input_data_bit_read(GPIOB,GPIO_PINS_8)
67
68#define TDIN_HIGH gpio_bits_set(GPIOA,GPIO_PINS_1)
69#define TDIN_LOW gpio_bits_reset(GPIOA,GPIO_PINS_1)
70
71#define PEN_HIGH gpio_input_data_bit_read(GPIOB,GPIO_PINS_11)
72
73#define TCS_HIGH gpio_bits_set(GPIOB,GPIO_PINS_12)
74#define TCS_LOW gpio_bits_reset(GPIOB,GPIO_PINS_12)
75
80void touch_pin_init(void);
81void touch_read_xy(uint16_t *x, uint16_t *y);
82void touch_scan(void);
83uint16_t touch_read_x_or_y(uint8_t xy);
84uint16_t touch_read_ad(uint8_t xy);
85void touch_write_1byte(uint8_t cmd);
86uint8_t touch_read_1byte(void);
87 error_status touch_adjust(void);
88
104#endif
105
106
107
108
109
at32f435_437_board.h
touch_struct
touch_dev_type * touch_struct
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c:51
touch_dev_struct
touch_dev_type touch_dev_struct
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c:38
error_status
error_status
Definition: at32f435_437.h:380
touch_read_ad
uint16_t touch_read_ad(uint8_t xy)
this function is read data from touch.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:181
touch_scan
void touch_scan(void)
this function is scanning the screen.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:240
touch_write_1byte
void touch_write_1byte(uint8_t cmd)
this function is write command to touch.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:208
touch_read_xy
void touch_read_xy(uint16_t *x, uint16_t *y)
this function is read data from touch.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:120
touch_adjust
error_status touch_adjust(void)
this function is adjust the screen.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:263
touch_read_1byte
uint8_t touch_read_1byte(void)
this function is read data from touch.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:222
touch_read_x_or_y
uint16_t touch_read_x_or_y(uint8_t xy)
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:138
touch_pin_init
void touch_pin_init(void)
this function is init touch pin.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:58
touch_dev_type
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h:47


AT32F435/437 Firmwary Library: xmc_lcd.h File Reference

  • at_start_f437
  • examples
  • xmc
  • lcd_touch_16bit
  • inc
Data Structures | Macros | Functions | Variables
at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h File Reference

xmc_lcd program header More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Data Structures

struct lcd_dev_type

Macros

#define | XMC_LCD_COMMAND 0x6C000000
#define | XMC_LCD_DATA 0x6C000800
#define | LCD_BL_HIGH gpio_bits_set(GPIOC,GPIO_PINS_0)
#define | LCD_BL_LOW gpio_bits_reset(GPIOC,GPIO_PINS_0)
#define | WHITE 0xFFFF
#define | BLACK 0x0000
#define | BLUE 0x001F
#define | BRED 0xF81F
#define | GRED 0xFFE0
#define | GBLUE 0x07FF
#define | RED 0xF800
#define | MAGENTA 0xF81F
#define | GREEN 0x07E0
#define | CYAN 0x7FFF
#define | YELLOW 0xFFE0
#define | BROWN 0xBC40
#define | BRRED 0xFC07
#define | GRAY 0x8430

Functions

void | xmc_init (void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_init (void)
configures the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_wr_command (uint16_t command)
this function is write command to lcd. More...
void | lcd_wr_data (uint16_t data)
this function is write data to lcd. More...
uint16_t | lcd_rd_data (void)
void | lcd_setblock (uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd. More...
void | lcd_writeonepoint (uint16_t color)
this function is write one point to lcd. More...
void | lcd_drawpoint (uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd. More...
void | lcd_clear (uint16_t color)
this function is clear the lcd. More...

Variables

lcd_dev_type lcd_dev_struct
lcd_dev_type * lcd_struct
static uint16_t LCD_ID

Detailed Description

xmc_lcd program header

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h.


AT32F435/437 Firmwary Library: xmc_lcd.h Source File

  • at_start_f437
  • examples
  • xmc
  • lcd_touch_16bit
  • inc
at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
Go to the documentation of this file.
1
26#ifndef __XMC_LCD_H
27#define __XMC_LCD_H
28
29#include "at32f435_437_board.h"
30
43typedef struct
44{
45 uint16_t lcd_id;
46 void (*xmc_init)(void);
47 void (*lcd_init)(void);
48 void (*lcd_setblock)(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend);
49 void (*draw_point)(uint16_t x, uint16_t y, uint16_t color);
50 void (*lcd_clear)(uint16_t color);
51} lcd_dev_type;
52
57extern lcd_dev_type lcd_dev_struct;
58extern lcd_dev_type *lcd_struct;
59
64/* the address of write data & command (xmc_a10) */
65#define XMC_LCD_COMMAND 0x6C000000
66#define XMC_LCD_DATA 0x6C000800
79#define LCD_BL_HIGH gpio_bits_set(GPIOC,GPIO_PINS_0)
80#define LCD_BL_LOW gpio_bits_reset(GPIOC,GPIO_PINS_0)
81static uint16_t LCD_ID;
82#define WHITE 0xFFFF
83#define BLACK 0x0000
84#define BLUE 0x001F
85#define BRED 0xF81F
86#define GRED 0xFFE0
87#define GBLUE 0x07FF
88#define RED 0xF800
89#define MAGENTA 0xF81F
90#define GREEN 0x07E0
91#define CYAN 0x7FFF
92#define YELLOW 0xFFE0
93#define BROWN 0xBC40
94#define BRRED 0xFC07
95#define GRAY 0x8430
96
101void xmc_init(void);
102void lcd_init(void);
103void lcd_wr_command(uint16_t command);
104void lcd_wr_data(uint16_t data);
105uint16_t lcd_rd_data(void);
106void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend);
107void lcd_writeonepoint(uint16_t color);
108void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color);
109void lcd_clear(uint16_t color);
110
123#endif
124
125
at32f435_437_board.h
lcd_setblock
void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:332
lcd_init
void lcd_init(void)
configures the lcd. this function must be called before any write/read operation on the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:165
lcd_drawpoint
void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:367
lcd_wr_command
void lcd_wr_command(uint16_t command)
this function is write command to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:300
lcd_rd_data
uint16_t lcd_rd_data(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:315
lcd_clear
void lcd_clear(uint16_t color)
this function is clear the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:379
lcd_writeonepoint
void lcd_writeonepoint(uint16_t color)
this function is write one point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:357
lcd_wr_data
void lcd_wr_data(uint16_t data)
this function is write data to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:310
xmc_init
void xmc_init(void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write...
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:57
lcd_dev_struct
lcd_dev_type lcd_dev_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:38
LCD_ID
static uint16_t LCD_ID
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h:81
lcd_struct
lcd_dev_type * lcd_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:48
lcd_dev_type
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:44


AT32F435/437 Firmwary Library: touch.c File Reference

  • at_start_f437
  • examples
  • xmc
  • lcd_touch_16bit
  • src
Macros | Functions | Variables
at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c File Reference

this file contains all the functions prototypes for the touch firmware driver. More...

#include "touch.h"
#include "xmc_lcd.h"

Go to the source code of this file.

Macros

#define | READ_TIMES 5
this function is processing data that read from touch. More...
#define | LOST_VAL 1

Functions

void | touch_pin_init (void)
this function is init touch pin. More...
void | touch_read_xy (uint16_t *x, uint16_t *y)
this function is read data from touch. More...
uint16_t | touch_read_x_or_y (uint8_t xy)
uint16_t | touch_read_ad (uint8_t xy)
this function is read data from touch. More...
void | touch_write_1byte (uint8_t cmd)
this function is write command to touch. More...
uint8_t | touch_read_1byte (void)
this function is read data from touch. More...
void | touch_scan (void)
this function is scanning the screen. More...
error_status | touch_adjust (void)
this function is adjust the screen. More...

Variables

touch_dev_type touch_dev_struct
uint8_t | cmd_rdx = 0xd0
uint8_t | cmd_rdy = 0x90
touch_dev_type * touch_struct

Detailed Description

this file contains all the functions prototypes for the touch firmware driver.

Version
v2.0.9
Date
2022-06-28
        Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c.


AT32F435/437 Firmwary Library: touch.c Source File

  • at_start_f437
  • examples
  • xmc
  • lcd_touch_16bit
  • src
at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c
Go to the documentation of this file.
1
27#include "touch.h"
28#include "xmc_lcd.h"
29
38 touch_dev_type touch_dev_struct =
39{
40 touch_pin_init,
41 touch_read_xy,
42 touch_scan,
43 touch_adjust,
44 0,
45 0,
46};
47
48uint8_t cmd_rdx = 0xd0;
49uint8_t cmd_rdy = 0x90;
50
51 touch_dev_type *touch_struct;
52
58void touch_pin_init(void)
59{
60 gpio_init_type gpio_init_struct = {0};
61 spi_init_type spi_init_struct;
62
63 /* enable the gpio clock */
64 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
65 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_SPI4_PERIPH_CLOCK, TRUE);
67
68 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE13, GPIO_MUX_6);
69 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE8, GPIO_MUX_6);
70 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE1, GPIO_MUX_5);
71
72 gpio_init_struct.gpio_pins = GPIO_PINS_13 | GPIO_PINS_8;
73 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
74 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
75 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
76 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
77 gpio_init(GPIOB, &gpio_init_struct);
78
79 gpio_init_struct.gpio_pins = GPIO_PINS_1;
80 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
81 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
82 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
83 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
84 gpio_init(GPIOA, &gpio_init_struct);
85
86 gpio_init_struct.gpio_pins = GPIO_PINS_12;
87 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
88 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
89 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
90 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
91 gpio_init(GPIOB, &gpio_init_struct);
92
93 gpio_init_struct.gpio_pins = GPIO_PINS_11;
94 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
95 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
96 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
97 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
98 gpio_init(GPIOB, &gpio_init_struct);
99
100 gpio_bits_set(GPIOB, GPIO_PINS_11);
101
102 spi_default_para_init(&spi_init_struct);
103 spi_init_struct.transmission_mode = SPI_TRANSMIT_FULL_DUPLEX;
104 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
105 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_256;
106 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_MSB;
107 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
108 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_HIGH;
109 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
110 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
111 spi_init(SPI4, &spi_init_struct);
112 spi_enable(SPI4, TRUE);
113}
114
120void touch_read_xy(uint16_t *x, uint16_t *y)
121{
122 uint16_t xtemp, ytemp;
123 xtemp = touch_read_x_or_y(cmd_rdx);
124 ytemp = touch_read_x_or_y(cmd_rdy);
125
126 *x = xtemp;
127 *y = ytemp;
128}
129
135/* read five times, remove max and min, and then take the average */
136#define READ_TIMES 5
137#define LOST_VAL 1
138uint16_t touch_read_x_or_y(uint8_t xy)
139{
140 uint16_t i, j;
141 uint16_t buf[READ_TIMES];
142 uint16_t sum = 0;
143 uint16_t temp;
144
145 for(i = 0; i < READ_TIMES; i++)
146 {
147 buf[i] = touch_read_ad(xy);
148 }
149
150 for(i = 0; i < READ_TIMES - 1; i++)
151 {
152 for(j = i + 1; j < READ_TIMES; j++)
153 {
154 /* increase the sorting */
155 if(buf[i] > buf[j])
156 {
157 temp = buf[i];
158 buf[i] = buf[j];
159 buf[j] = temp;
160 }
161 }
162 }
163
164 sum = 0;
165
166 for(i = LOST_VAL; i < READ_TIMES - LOST_VAL; i++)
167 {
168 sum += buf[i];
169 }
170
171 temp = sum/(READ_TIMES - 2 * LOST_VAL);
172
173 return temp;
174}
175
181uint16_t touch_read_ad(uint8_t xy)
182{
183 uint16_t num = 0;
184
185 /* enable touch ic */
186 TCS_LOW;
187
188 /* send command */
189 touch_write_1byte(xy);
190
191 /* touch ic conversion timer */
192 delay_us(6);
193 num = touch_read_1byte();
194 num = num << 8;
195 num |= touch_read_1byte();
196 num >>= 3;
197
198 /* disable touch ic */
199 TCS_HIGH;
200 return(num);
201}
202
208void touch_write_1byte(uint8_t cmd)
209{
210 while(spi_i2s_flag_get(SPI4, SPI_I2S_TDBE_FLAG) == RESET);
211 spi_i2s_data_transmit(SPI4, cmd);
212
213 while(spi_i2s_flag_get(SPI4, SPI_I2S_RDBF_FLAG) == RESET);
214 SPI4->dt;
215}
216
222uint8_t touch_read_1byte(void)
223{
224 uint8_t touch;
225
226 while(spi_i2s_flag_get(SPI4, SPI_I2S_TDBE_FLAG) == RESET);
227 spi_i2s_data_transmit(SPI4, 0XFF);
228
229 while(spi_i2s_flag_get(SPI4, SPI_I2S_RDBF_FLAG) == RESET);
230 touch = spi_i2s_data_receive(SPI4);
231
232 return touch;
233}
234
240void touch_scan(void)
241{
242 uint16_t x, y;
243
244 if(gpio_input_data_bit_read(GPIOB, GPIO_PINS_11) == 0)
245 {
246 touch_dev_struct.touch_read_xy(&touch_dev_struct.x_p[1], &touch_dev_struct.y_p[1]);
247 x = (240 * touch_dev_struct.x_p[1]) / (0xed0);
248 y = (320 * touch_dev_struct.y_p[1]) / (0xe60);
249
250 lcd_drawpoint(x, y, RED);
251 lcd_drawpoint(x - 1, y, RED);
252 lcd_drawpoint(x + 1, y, RED);
253 lcd_drawpoint(x, y + 1, RED);
254 lcd_drawpoint(x, y - 1, RED);
255 }
256}
257
263 error_status touch_adjust(void)
264{
265 /* touch adjust code */
266 return SUCCESS;
267}
268
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
lcd_drawpoint
void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:367
RED
#define RED
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:90
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:40
cmd_rdy
uint8_t cmd_rdy
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:49
LOST_VAL
#define LOST_VAL
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:137
cmd_rdx
uint8_t cmd_rdx
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:48
TCS_HIGH
#define TCS_HIGH
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h:73
READ_TIMES
#define READ_TIMES
this function is processing data that read from touch.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:136
touch_struct
touch_dev_type * touch_struct
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:51
touch_dev_struct
touch_dev_type touch_dev_struct
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:38
TCS_LOW
#define TCS_LOW
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h:74
j
uint32_t j
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:44
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f435_437_board.c:306
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_SPI4_PERIPH_CLOCK
@ CRM_SPI4_PERIPH_CLOCK
Definition: at32f435_437_crm.h:162
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
error_status
error_status
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_input_data_bit_read
flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified input port pin.
Definition: at32f435_437_gpio.c:170
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f435_437_gpio.c:277
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f435_437_gpio.h:82
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f435_437_gpio.h:146
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_6
@ GPIO_MUX_6
Definition: at32f435_437_gpio.h:162
GPIO_MUX_5
@ GPIO_MUX_5
Definition: at32f435_437_gpio.h:161
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f435_437_gpio.h:64
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f435_437_spi.h:54
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f435_437_spi.h:53
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f435_437_spi.c:548
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f435_437_spi.c:583
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f435_437_spi.c:101
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f435_437_spi.c:81
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f435_437_spi.c:560
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f435_437_spi.c:321
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f435_437_spi.h:100
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f435_437_spi.h:118
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f435_437_spi.h:127
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f435_437_spi.h:153
SPI_CLOCK_POLARITY_HIGH
@ SPI_CLOCK_POLARITY_HIGH
Definition: at32f435_437_spi.h:109
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f435_437_spi.h:162
SPI_MCLK_DIV_256
@ SPI_MCLK_DIV_256
Definition: at32f435_437_spi.h:143
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f435_437_spi.h:90
SPI4
#define SPI4
Definition: at32f435_437_spi.h:456
touch_read_ad
uint16_t touch_read_ad(uint8_t xy)
this function is read data from touch.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:181
touch_scan
void touch_scan(void)
this function is scanning the screen.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:240
touch_write_1byte
void touch_write_1byte(uint8_t cmd)
this function is write command to touch.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:208
touch_read_xy
void touch_read_xy(uint16_t *x, uint16_t *y)
this function is read data from touch.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:120
touch_adjust
error_status touch_adjust(void)
this function is adjust the screen.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:263
touch_read_1byte
uint8_t touch_read_1byte(void)
this function is read data from touch.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:222
touch_read_x_or_y
uint16_t touch_read_x_or_y(uint8_t xy)
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:138
touch_pin_init
void touch_pin_init(void)
this function is init touch pin.
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c:58
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
spi_init_type
spi init type
Definition: at32f435_437_spi.h:259
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f435_437_spi.h:261
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f435_437_spi.h:263
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f435_437_spi.h:264
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:265
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f435_437_spi.h:267
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f435_437_spi.h:262
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f435_437_spi.h:260
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f435_437_spi.h:266
touch_dev_type
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h:47
touch_dev_type::touch_read_xy
void(* touch_read_xy)(uint16_t *x, uint16_t *y)
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h:49
touch_dev_type::y_p
uint16_t y_p[6]
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h:53
touch_dev_type::x_p
uint16_t x_p[6]
Definition: at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h:52


AT32F435/437 Firmwary Library: xmc_lcd.c File Reference

  • at_start_f437
  • examples
  • xmc
  • lcd_touch_16bit
  • src
Functions | Variables
at_start_f437/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c File Reference

xmc_lcd program file More...

#include "xmc_lcd.h"

Go to the source code of this file.

Functions

void | xmc_init (void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_init (void)
configures the lcd. this function must be called before any write/read operation on the lcd. More...
void | lcd_wr_command (uint16_t command)
this function is write command to lcd. More...
void | lcd_wr_data (uint16_t data)
this function is write data to lcd. More...
uint16_t | lcd_rd_data (void)
void | lcd_setblock (uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd. More...
void | lcd_writeonepoint (uint16_t color)
this function is write one point to lcd. More...
void | lcd_drawpoint (uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd. More...
void | lcd_clear (uint16_t color)
this function is clear the lcd. More...

Variables

lcd_dev_type lcd_dev_struct
lcd_dev_type * lcd_struct

Detailed Description

xmc_lcd program file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c.


AT32F435/437 Firmwary Library: xmc_lcd.c Source File

  • at_start_f437
  • examples
  • xmc
  • lcd_touch_16bit
  • src
at_start_f437/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c
Go to the documentation of this file.
1
27#include "xmc_lcd.h"
28
37 lcd_dev_type lcd_dev_struct =
38{
39 0,
40 xmc_init,
41 lcd_init,
42 lcd_setblock,
43 lcd_drawpoint,
44 lcd_clear,
45};
46
47 lcd_dev_type *lcd_struct;
48
56void xmc_init(void)
57{
58 gpio_init_type gpio_init_struct = {0};
59 xmc_norsram_init_type xmc_norsram_init_struct;
60 xmc_norsram_timing_init_type rw_timing_struct, w_timing_struct;
61
62 /* enable the gpio clock */
63// crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
64 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
65 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
67// crm_periph_clock_enable(CRM_GPIOF_PERIPH_CLOCK, TRUE);
68
69 /* enable the xmc clock */
70 crm_periph_clock_enable(CRM_XMC_PERIPH_CLOCK, TRUE);
71
72 /*-- gpio configuration ------------------------------------------------------*/
73 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE2, GPIO_MUX_14);
74 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE4, GPIO_MUX_14);
75 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE5, GPIO_MUX_14);
76 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE11, GPIO_MUX_14);
77 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE12, GPIO_MUX_14);
78 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE5, GPIO_MUX_10);
79 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE8, GPIO_MUX_12);
80 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE9, GPIO_MUX_12);
81 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE10, GPIO_MUX_12);
82 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE14, GPIO_MUX_12);
83 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE15, GPIO_MUX_12);
84
85 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE7, GPIO_MUX_12);
86 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE8, GPIO_MUX_12);
87 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE9, GPIO_MUX_12);
88 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE10, GPIO_MUX_12);
89 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE11, GPIO_MUX_12);
90 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE12, GPIO_MUX_12);
91 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE13, GPIO_MUX_12);
92 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE14, GPIO_MUX_12);
93 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE15, GPIO_MUX_12);
94
95 /* lcd data lines configuration */
96 gpio_init_struct.gpio_pins = GPIO_PINS_2 | GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_11| GPIO_PINS_12;
97 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
98 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
99 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
100 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
101 gpio_init(GPIOC, &gpio_init_struct);
102
103
104 gpio_init_struct.gpio_pins = GPIO_PINS_5 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_14 | GPIO_PINS_15;
105 gpio_init(GPIOD, &gpio_init_struct);
106
107 gpio_init_struct.gpio_pins = GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11 | GPIO_PINS_12 | GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
108 gpio_init(GPIOE, &gpio_init_struct);
109
110 /* lcd bl lines configuration */
111 gpio_init_struct.gpio_pins = GPIO_PINS_0;
112 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
113 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
114 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
115 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
116 gpio_init(GPIOC, &gpio_init_struct);
117
118
119 /*-- xmc configuration ------------------------------------------------------*/
120 xmc_norsram_default_para_init(&xmc_norsram_init_struct);
121 xmc_norsram_init_struct.subbank = XMC_BANK1_NOR_SRAM4;
122 xmc_norsram_init_struct.data_addr_multiplex = XMC_DATA_ADDR_MUX_DISABLE;
123 xmc_norsram_init_struct.device = XMC_DEVICE_SRAM;
124 xmc_norsram_init_struct.bus_type = XMC_BUSTYPE_16_BITS;
125 xmc_norsram_init_struct.burst_mode_enable = XMC_BURST_MODE_DISABLE;
126 xmc_norsram_init_struct.asynwait_enable = XMC_ASYN_WAIT_DISABLE;
127 xmc_norsram_init_struct.wait_signal_lv = XMC_WAIT_SIGNAL_LEVEL_LOW;
128 xmc_norsram_init_struct.wrapped_mode_enable = XMC_WRAPPED_MODE_DISABLE;
129 xmc_norsram_init_struct.wait_signal_config = XMC_WAIT_SIGNAL_SYN_BEFORE;
130 xmc_norsram_init_struct.write_enable = XMC_WRITE_OPERATION_ENABLE;
131 xmc_norsram_init_struct.wait_signal_enable = XMC_WAIT_SIGNAL_DISABLE;
132 xmc_norsram_init_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
133 xmc_norsram_init_struct.write_burst_syn = XMC_WRITE_BURST_SYN_DISABLE;
134 xmc_nor_sram_init(&xmc_norsram_init_struct);
135
136 /* timing configuration */
137 xmc_norsram_timing_default_para_init(&rw_timing_struct, &w_timing_struct);
138 rw_timing_struct.subbank = XMC_BANK1_NOR_SRAM4;
139 rw_timing_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
140 rw_timing_struct.addr_setup_time = 0x2;
141 rw_timing_struct.addr_hold_time = 0x0;
142 rw_timing_struct.data_setup_time = 0x2;
143 rw_timing_struct.bus_latency_time = 0x0;
144 rw_timing_struct.clk_psc = 0x0;
145 rw_timing_struct.data_latency_time = 0x0;
146 rw_timing_struct.mode = XMC_ACCESS_MODE_A;
147 w_timing_struct.subbank = XMC_BANK1_NOR_SRAM4;
148 w_timing_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
149 w_timing_struct.addr_setup_time = 0x2;
150 w_timing_struct.addr_hold_time = 0x0;
151 w_timing_struct.data_setup_time = 0x2;
152 w_timing_struct.bus_latency_time = 0x0;
153 w_timing_struct.clk_psc = 0x0;
154 w_timing_struct.data_latency_time = 0x0;
155 w_timing_struct.mode = XMC_ACCESS_MODE_A;
156 xmc_nor_sram_timing_config(&rw_timing_struct, &w_timing_struct);
157
158 /* bus turnaround phase for consecutive read duration and consecutive write duration */
159 xmc_ext_timing_config(XMC_BANK1_NOR_SRAM4, 0x08, 0x08);
160
161 /* enable xmc_bank1_nor_sram4 */
162 xmc_nor_sram_enable(XMC_BANK1_NOR_SRAM4, TRUE);
163}
164
172void lcd_init(void)
173{
174 /* init xmc */
175 lcd_struct->xmc_init();
176
177 delay_ms(50);
178
179 /* read id */
180 lcd_wr_command(0x0000);
181 delay_ms(5);
182
183 lcd_struct->lcd_id = lcd_rd_data();
184 lcd_wr_command(0xd3);
185
186 lcd_struct->lcd_id = lcd_rd_data();
187 lcd_struct->lcd_id = lcd_rd_data();
188 lcd_struct->lcd_id = lcd_rd_data();
189 lcd_struct->lcd_id = lcd_rd_data();
190 lcd_struct->lcd_id = lcd_struct->lcd_id << 8;
191 lcd_struct->lcd_id |= lcd_rd_data();
192
193 lcd_wr_command(0xcf);
194 lcd_wr_data(0x00);
195 lcd_wr_data(0xc1);
196 lcd_wr_data(0x30);
197 lcd_wr_command(0xed);
198 lcd_wr_data(0x64);
199 lcd_wr_data(0x03);
200 lcd_wr_data(0x12);
201 lcd_wr_data(0x81);
202 lcd_wr_command(0xe8);
203 lcd_wr_data(0x85);
204 lcd_wr_data(0x10);
205 lcd_wr_data(0x7a);
206 lcd_wr_command(0xcb);
207 lcd_wr_data(0x39);
208 lcd_wr_data(0x2c);
209 lcd_wr_data(0x00);
210 lcd_wr_data(0x34);
211 lcd_wr_data(0x02);
212 lcd_wr_command(0xf7);
213 lcd_wr_data(0x20);
214 lcd_wr_command(0xea);
215 lcd_wr_data(0x00);
216 lcd_wr_data(0x00);
217 lcd_wr_command(0xc0);
218 lcd_wr_data(0x1b);
219 lcd_wr_command(0xc1);
220 lcd_wr_data(0x01);
221 lcd_wr_command(0xc5);
222 lcd_wr_data(0x30);
223 lcd_wr_data(0x30);
224 lcd_wr_command(0xc7);
225 lcd_wr_data(0xb7);
226 lcd_wr_command(0x36);
227 lcd_wr_data(0x48);
228 lcd_wr_command(0x3a);
229 lcd_wr_data(0x55);
230 lcd_wr_command(0xb1);
231 lcd_wr_data(0x00);
232 lcd_wr_data(0x1a);
233 lcd_wr_command(0xb6);
234 lcd_wr_data(0x0a);
235 lcd_wr_data(0xa2);
236 lcd_wr_command(0xf2);
237 lcd_wr_data(0x00);
238 lcd_wr_command(0x26);
239 lcd_wr_data(0x01);
240 lcd_wr_command(0xe0);
241 lcd_wr_data(0x0f);
242 lcd_wr_data(0x2a);
243 lcd_wr_data(0x28);
244 lcd_wr_data(0x08);
245 lcd_wr_data(0x0e);
246 lcd_wr_data(0x08);
247 lcd_wr_data(0x54);
248 lcd_wr_data(0xa9);
249 lcd_wr_data(0x43);
250 lcd_wr_data(0x0a);
251 lcd_wr_data(0x0f);
252 lcd_wr_data(0x00);
253 lcd_wr_data(0x00);
254 lcd_wr_data(0x00);
255 lcd_wr_data(0x00);
256 lcd_wr_command(0xe1);
257 lcd_wr_data(0x00);
258 lcd_wr_data(0x15);
259 lcd_wr_data(0x17);
260 lcd_wr_data(0x07);
261 lcd_wr_data(0x11);
262 lcd_wr_data(0x06);
263 lcd_wr_data(0x2b);
264 lcd_wr_data(0x56);
265 lcd_wr_data(0x3c);
266 lcd_wr_data(0x05);
267 lcd_wr_data(0x10);
268 lcd_wr_data(0x0f);
269 lcd_wr_data(0x3f);
270 lcd_wr_data(0x3f);
271 lcd_wr_data(0x0f);
272 lcd_wr_command(0x2b);
273 lcd_wr_data(0x00);
274 lcd_wr_data(0x00);
275 lcd_wr_data(0x01);
276 lcd_wr_data(0x3f);
277 lcd_wr_command(0x2a);
278 lcd_wr_data(0x00);
279 lcd_wr_data(0x00);
280 lcd_wr_data(0x00);
281 lcd_wr_data(0xef);
282 lcd_wr_command(0x11);
283 delay_ms(120);
284 lcd_wr_command(0x29);
285 lcd_wr_command(0x36);
286 lcd_wr_data(0x08);
287 lcd_wr_command(0x2a);
288 lcd_wr_data(0x00);
289 lcd_wr_data(0x00);
290 lcd_wr_data(0xef >> 8);
291 lcd_wr_data(0xef & 0xff);
292 lcd_wr_command(0x2b);
293 lcd_wr_data(0x00);
294 lcd_wr_data(0x00);
295 lcd_wr_data(0x13f >> 8);
296 lcd_wr_data(0x13f & 0xff);
297 LCD_BL_HIGH;
298}
299
305void lcd_wr_command(uint16_t command)
306{
307 *(__IO uint16_t*) XMC_LCD_COMMAND = command;
308}
309
315void lcd_wr_data(uint16_t data)
316{
317 *(__IO uint16_t*) XMC_LCD_DATA = data;
318}
319
320uint16_t lcd_rd_data(void)
321{
322 uint16_t data;
323
324 data = *(uint16_t*)XMC_LCD_DATA;
325
326 return data;
327}
328
337void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
338{
339 /* set row coordinates */
340 lcd_wr_command(0x2a);
341 lcd_wr_data(xstart >> 8);
342 lcd_wr_data(xstart);
343 lcd_wr_data(xend >> 8);
344 lcd_wr_data(xend);
345
346 /* set column coordinates */
347 lcd_wr_command(0x2b);
348 lcd_wr_data(ystart >> 8);
349 lcd_wr_data(ystart);
350 lcd_wr_data(yend >> 8);
351 lcd_wr_data(yend);
352
353 /* enable write menory */
354 lcd_wr_command(0x2c);
355}
356
362void lcd_writeonepoint(uint16_t color)
363{
364 lcd_wr_data(color);
365}
366
372void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
373{
374 lcd_struct->lcd_setblock(x, y ,x ,y);
375
376 lcd_writeonepoint(color);
377}
378
384void lcd_clear(uint16_t color)
385{
386 uint32_t i;
387
388 lcd_struct->lcd_setblock(0, 0, 240, 320);
389
390 for(i = 0; i < 76800; i++)
391 {
392 lcd_writeonepoint(color);
393 }
394}
395
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
lcd_setblock
void lcd_setblock(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
this function is set row&column coordinates for lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:332
lcd_init
void lcd_init(void)
configures the lcd. this function must be called before any write/read operation on the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:165
lcd_drawpoint
void lcd_drawpoint(uint16_t x, uint16_t y, uint16_t color)
this function is draw point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:367
lcd_wr_command
void lcd_wr_command(uint16_t command)
this function is write command to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:300
lcd_rd_data
uint16_t lcd_rd_data(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:315
lcd_clear
void lcd_clear(uint16_t color)
this function is clear the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:379
lcd_writeonepoint
void lcd_writeonepoint(uint16_t color)
this function is write one point to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:357
lcd_wr_data
void lcd_wr_data(uint16_t data)
this function is write data to lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:310
LCD_BL_HIGH
#define LCD_BL_HIGH
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:81
xmc_init
void xmc_init(void)
configures the xmc and gpios to interface with the lcd. this function must be called before any write...
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:57
lcd_dev_struct
lcd_dev_type lcd_dev_struct
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c:37
lcd_struct
lcd_dev_type * lcd_struct
Definition: at_start_f437/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c:47
XMC_LCD_COMMAND
#define XMC_LCD_COMMAND
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:65
XMC_LCD_DATA
#define XMC_LCD_DATA
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:66
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_XMC_PERIPH_CLOCK
@ CRM_XMC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:123
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f435_437_gpio.h:146
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_10
@ GPIO_MUX_10
Definition: at32f435_437_gpio.h:166
GPIO_MUX_14
@ GPIO_MUX_14
Definition: at32f435_437_gpio.h:170
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f435_437_gpio.h:64
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
xmc_nor_sram_init
void xmc_nor_sram_init(xmc_norsram_init_type *xmc_norsram_init_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_norsraminitstruct.
Definition: at32f435_437_xmc.c:78
xmc_norsram_timing_default_para_init
void xmc_norsram_timing_default_para_init(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
fill each xmc_rw_timing_struct and xmc_w_timing_struct member with its default value.
Definition: at32f435_437_xmc.c:176
xmc_nor_sram_timing_config
void xmc_nor_sram_timing_config(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_rw_timing_struct a...
Definition: at32f435_437_xmc.c:113
xmc_ext_timing_config
void xmc_ext_timing_config(xmc_nor_sram_subbank_type xmc_sub_bank, uint16_t w2w_timing, uint16_t r2r_timing)
config the bus turnaround phase.
Definition: at32f435_437_xmc.c:227
xmc_norsram_default_para_init
void xmc_norsram_default_para_init(xmc_norsram_init_type *xmc_nor_sram_init_struct)
fill each xmc_nor_sram_init_struct member with its default value.
Definition: at32f435_437_xmc.c:150
xmc_nor_sram_enable
void xmc_nor_sram_enable(xmc_nor_sram_subbank_type xmc_subbank, confirm_state new_state)
enable or disable the specified nor/sram memory bank.
Definition: at32f435_437_xmc.c:210
XMC_WAIT_SIGNAL_DISABLE
@ XMC_WAIT_SIGNAL_DISABLE
Definition: at32f435_437_xmc.h:101
XMC_WAIT_SIGNAL_SYN_BEFORE
@ XMC_WAIT_SIGNAL_SYN_BEFORE
Definition: at32f435_437_xmc.h:196
XMC_WRITE_OPERATION_ENABLE
@ XMC_WRITE_OPERATION_ENABLE
Definition: at32f435_437_xmc.h:93
XMC_WRITE_BURST_SYN_DISABLE
@ XMC_WRITE_BURST_SYN_DISABLE
Definition: at32f435_437_xmc.h:110
XMC_BURST_MODE_DISABLE
@ XMC_BURST_MODE_DISABLE
Definition: at32f435_437_xmc.h:65
XMC_DATA_ADDR_MUX_DISABLE
@ XMC_DATA_ADDR_MUX_DISABLE
Definition: at32f435_437_xmc.h:56
XMC_BUSTYPE_16_BITS
@ XMC_BUSTYPE_16_BITS
Definition: at32f435_437_xmc.h:179
XMC_WRITE_TIMING_ENABLE
@ XMC_WRITE_TIMING_ENABLE
Definition: at32f435_437_xmc.h:120
XMC_BANK1_NOR_SRAM4
@ XMC_BANK1_NOR_SRAM4
Definition: at32f435_437_xmc.h:149
XMC_ASYN_WAIT_DISABLE
@ XMC_ASYN_WAIT_DISABLE
Definition: at32f435_437_xmc.h:74
XMC_WRAPPED_MODE_DISABLE
@ XMC_WRAPPED_MODE_DISABLE
Definition: at32f435_437_xmc.h:83
XMC_ACCESS_MODE_A
@ XMC_ACCESS_MODE_A
Definition: at32f435_437_xmc.h:205
XMC_WAIT_SIGNAL_LEVEL_LOW
@ XMC_WAIT_SIGNAL_LEVEL_LOW
Definition: at32f435_437_xmc.h:187
XMC_DEVICE_SRAM
@ XMC_DEVICE_SRAM
Definition: at32f435_437_xmc.h:168
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
lcd_dev_type
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:44
lcd_dev_type::lcd_setblock
void(* lcd_setblock)(uint16_t xstart, uint16_t ystart, uint16_t xend, uint16_t yend)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:48
lcd_dev_type::lcd_id
uint16_t lcd_id
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:45
lcd_dev_type::xmc_init
void(* xmc_init)(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:46
xmc_norsram_init_type
xmc nor/sram init structure definition
Definition: at32f435_437_xmc.h:409
xmc_norsram_init_type::wait_signal_enable
xmc_wait_signal_type wait_signal_enable
Definition: at32f435_437_xmc.h:420
xmc_norsram_init_type::data_addr_multiplex
xmc_data_addr_mux_type data_addr_multiplex
Definition: at32f435_437_xmc.h:411
xmc_norsram_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:421
xmc_norsram_init_type::burst_mode_enable
xmc_burst_access_mode_type burst_mode_enable
Definition: at32f435_437_xmc.h:414
xmc_norsram_init_type::bus_type
xmc_data_width_type bus_type
Definition: at32f435_437_xmc.h:413
xmc_norsram_init_type::device
xmc_memory_type device
Definition: at32f435_437_xmc.h:412
xmc_norsram_init_type::wait_signal_lv
xmc_wait_signal_polarity_type wait_signal_lv
Definition: at32f435_437_xmc.h:416
xmc_norsram_init_type::wrapped_mode_enable
xmc_wrap_mode_type wrapped_mode_enable
Definition: at32f435_437_xmc.h:417
xmc_norsram_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:410
xmc_norsram_init_type::write_burst_syn
xmc_write_burst_type write_burst_syn
Definition: at32f435_437_xmc.h:422
xmc_norsram_init_type::asynwait_enable
xmc_asyn_wait_type asynwait_enable
Definition: at32f435_437_xmc.h:415
xmc_norsram_init_type::wait_signal_config
xmc_wait_timing_type wait_signal_config
Definition: at32f435_437_xmc.h:418
xmc_norsram_init_type::write_enable
xmc_write_operation_type write_enable
Definition: at32f435_437_xmc.h:419
xmc_norsram_timing_init_type
nor/sram banks timing parameters
Definition: at32f435_437_xmc.h:393
xmc_norsram_timing_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:395
xmc_norsram_timing_init_type::data_latency_time
uint32_t data_latency_time
Definition: at32f435_437_xmc.h:401
xmc_norsram_timing_init_type::addr_hold_time
uint32_t addr_hold_time
Definition: at32f435_437_xmc.h:397
xmc_norsram_timing_init_type::bus_latency_time
uint32_t bus_latency_time
Definition: at32f435_437_xmc.h:399
xmc_norsram_timing_init_type::addr_setup_time
uint32_t addr_setup_time
Definition: at32f435_437_xmc.h:396
xmc_norsram_timing_init_type::mode
xmc_access_mode_type mode
Definition: at32f435_437_xmc.h:402
xmc_norsram_timing_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:394
xmc_norsram_timing_init_type::clk_psc
uint32_t clk_psc
Definition: at32f435_437_xmc.h:400
xmc_norsram_timing_init_type::data_setup_time
uint32_t data_setup_time
Definition: at32f435_437_xmc.h:398


AT32F435/437 Firmwary Library: xmc_ecc.h File Reference

  • at_start_f437
  • examples
  • xmc
  • nand_flash
  • ecc
  • inc
Data Structures | Macros | Functions | Variables
at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h File Reference

header file for the nand ecc configuration. More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Data Structures

struct | nand_id_type
struct | nand_address_type

Macros

#define | ROW_ADDRESS (address_struct.page + (address_struct.block + (address_struct.zone * NAND_ZONE_SIZE)) * NAND_BLOCK_SIZE)
#define | COL_ADDRESS address_struct.byte
#define | BUFFER_SIZE NAND_PAGE_SIZE
#define | XMC_Bank_NAND XMC_Bank2_NAND
#define | Bank_NAND_ADDR Bank2_NAND_ADDR
#define | Bank2_NAND_ADDR ((uint32_t)0x70000000)
#define | CMD_AREA (uint32_t)(1<<16)
#define | ADDR_AREA (uint32_t)(1<<17)
#define | DATA_AREA ((uint32_t)0x00000000)
#define | NAND_CMD_AREA_A ((uint8_t)0x00)
#define | NAND_CMD_AREA_B ((uint8_t)0x01)
#define | NAND_CMD_AREA_C ((uint8_t)0x50)
#define | NAND_CMD_AREA_TRUE1 ((uint8_t)0x30)
#define | NAND_CMD_WRITE0 ((uint8_t)0x80)
#define | NAND_CMD_WRITE_TRUE1 ((uint8_t)0x10)
#define | NAND_CMD_ERASE0 ((uint8_t)0x60)
#define | NAND_CMD_ERASE1 ((uint8_t)0xD0)
#define | NAND_CMD_READID ((uint8_t)0x90)
#define | NAND_CMD_STATUS ((uint8_t)0x70)
#define | NAND_CMD_LOCK_STATUS ((uint8_t)0x7A)
#define | NAND_CMD_RESET ((uint8_t)0xFF)
#define | NAND_VALID_ADDRESS ((uint32_t)0x00000100)
#define | NAND_INVALID_ADDRESS ((uint32_t)0x00000200)
#define | NAND_TIMEOUT_ERROR ((uint32_t)0x00000400)
#define | NAND_BUSY ((uint32_t)0x00000000)
#define | NAND_ERROR ((uint32_t)0x00000001)
#define | NAND_READY ((uint32_t)0x00000040)
#define | addr_1st_cycle(addr) (uint8_t)((addr) & 0xFF)
#define | addr_2nd_cycle(addr) (uint8_t)(((addr) & 0xFF00) >> 8)
#define | addr_3rd_cycle(addr) (uint8_t)(((addr) & 0xFF0000) >> 16)
#define | addr_4th_cycle(addr) (uint8_t)(((addr) & 0xFF000000) >> 24)

Functions

void | nand_init (void)
configures the xmc and gpios to interface with the nand memory. this function must be called before any write/read operation on the nand. More...
void | nand_read_id (nand_id_type *nand_id_struct)
reads nand memory's id. More...
uint32_t | nand_write_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write)
this routine is for writing one or several 512 bytes page size. More...
uint32_t | nand_read_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read)
this routine is for sequential read from one or several 512 bytes page size. More...
uint32_t | nand_write_spare_area (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write)
this routine write the spare area information for the specified pages addresses. More...
uint32_t | nand_read_spare_area (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read)
this routine read the spare area information from the specified pages addresses. More...
uint32_t | nand_erase_block (nand_address_type address_struct)
this routine erase complete block from nand flash More...
uint32_t | nand_reset (void)
this routine reset the nand flash. More...
uint32_t | nand_get_status (void)
get the nand operation status. More...
uint32_t | nand_read_status (void)
reads the nand memory status using the read status command. More...
uint32_t | nand_address_increment (nand_address_type *address_struct)
increment the nand memory address. More...

Variables

uint32_t | ecc_value_write
uint32_t | ecc_value_read

Detailed Description

header file for the nand ecc configuration.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h.


AT32F435/437 Firmwary Library: xmc_ecc.h Source File

  • at_start_f437
  • examples
  • xmc
  • nand_flash
  • ecc
  • inc
at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h
Go to the documentation of this file.
1
27#ifndef __XMC_ECC_H
28#define __XMC_ECC_H
29
30#include "at32f435_437_board.h"
31
44typedef struct
45{
46 uint8_t maker_id;
47 uint8_t device_id;
48 uint8_t third_id;
49 uint8_t fourth_id;
50 uint8_t fifth_id;
51 uint8_t sixth_id;
52} nand_id_type;
53
62typedef struct
63{
64 uint16_t zone;
65 uint16_t block;
66 uint16_t page;
67 uint16_t byte;
68} nand_address_type;
69
74#define ROW_ADDRESS (address_struct.page + (address_struct.block + (address_struct.zone * NAND_ZONE_SIZE)) * NAND_BLOCK_SIZE)
75#define COL_ADDRESS address_struct.byte
76
77#define BUFFER_SIZE NAND_PAGE_SIZE
78
79#define XMC_Bank_NAND XMC_Bank2_NAND
80#define Bank_NAND_ADDR Bank2_NAND_ADDR
81#define Bank2_NAND_ADDR ((uint32_t)0x70000000)
82
83#ifdef H27U1G8F2CTR
84#define NAND_AT_MakerID 0xAD
85#define NAND_AT_DeviceID 0xF1
86#elif defined K9GAG08U0E
87#define NAND_AT_MakerID 0xEC
88#define NAND_AT_DeviceID 0xD5
89#endif
90
95/* a16 = cle high */
96#define CMD_AREA (uint32_t)(1<<16)
97/* a17 = ale high */
98#define ADDR_AREA (uint32_t)(1<<17)
99
100#define DATA_AREA ((uint32_t)0x00000000)
101
110/*-- XMC NAND memory command -------------------------------------*/
111#define NAND_CMD_AREA_A ((uint8_t)0x00)
112#define NAND_CMD_AREA_B ((uint8_t)0x01)
113#define NAND_CMD_AREA_C ((uint8_t)0x50)
114#define NAND_CMD_AREA_TRUE1 ((uint8_t)0x30)
115
116#define NAND_CMD_WRITE0 ((uint8_t)0x80)
117#define NAND_CMD_WRITE_TRUE1 ((uint8_t)0x10)
118
119#define NAND_CMD_ERASE0 ((uint8_t)0x60)
120#define NAND_CMD_ERASE1 ((uint8_t)0xD0)
121
122#define NAND_CMD_READID ((uint8_t)0x90)
123#define NAND_CMD_STATUS ((uint8_t)0x70)
124#define NAND_CMD_LOCK_STATUS ((uint8_t)0x7A)
125#define NAND_CMD_RESET ((uint8_t)0xFF)
126
135/*-- nand memory status -------------------------------------*/
136#define NAND_VALID_ADDRESS ((uint32_t)0x00000100)
137#define NAND_INVALID_ADDRESS ((uint32_t)0x00000200)
138#define NAND_TIMEOUT_ERROR ((uint32_t)0x00000400)
139#define NAND_BUSY ((uint32_t)0x00000000)
140#define NAND_ERROR ((uint32_t)0x00000001)
141#define NAND_READY ((uint32_t)0x00000040)
142
151/*-- xmc nand memory parameters -------------------------------------*/
152#ifdef H27U1G8F2CTR
153 /* 2k bytes per page w/o Spare Area */
154 #define NAND_PAGE_SIZE ((uint16_t)0x0800)
155 /* 64x2k bytes pages per block */
156 #define NAND_BLOCK_SIZE ((uint16_t)0x0040)
157 /* 1024 block per zone */
158 #define NAND_ZONE_SIZE ((uint16_t)0x0400)
159 /* last 64 bytes as spare area */
160 #define NAND_SPARE_AREA_SIZE ((uint16_t)0x0040)
161 /* 1 zones of 1024 block */
162 #define NAND_MAX_ZONE ((uint16_t)0x0001)
163#elif defined K9GAG08U0E
164 /* 8k bytes per page w/o spare area */
165 #define NAND_PAGE_SIZE ((uint16_t)0x2000)
166 /* 128x8k bytes pages per block */
167 #define NAND_BLOCK_SIZE ((uint16_t)0x0080)
168 /* 2048 block per zone */
169 #define NAND_ZONE_SIZE ((uint16_t)0x0800)
170 /* last 436 bytes as spare area */
171 #define NAND_SPARE_AREA_SIZE ((uint16_t)0x01B4)
172 /* 1 zones of 1024 block */
173 #define NAND_MAX_ZONE ((uint16_t)0x0001)
174#endif
175
184/*-- xmc nand memory address computation -------------------------------------*/
185/* 1st addressing cycle */
186#define addr_1st_cycle(addr) (uint8_t)((addr) & 0xFF)
187/* 2nd addressing cycle */
188#define addr_2nd_cycle(addr) (uint8_t)(((addr) & 0xFF00) >> 8)
189/* 3rd addressing cycle */
190#define addr_3rd_cycle(addr) (uint8_t)(((addr) & 0xFF0000) >> 16)
191/* 4th addressing cycle */
192#define addr_4th_cycle(addr) (uint8_t)(((addr) & 0xFF000000) >> 24)
193
198extern uint32_t ecc_value_write;
199extern uint32_t ecc_value_read;
200
205void nand_init(void);
206void nand_read_id(nand_id_type* nand_id_struct);
207uint32_t nand_write_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write);
208uint32_t nand_read_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read);
209uint32_t nand_write_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write);
210uint32_t nand_read_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read);
211uint32_t nand_erase_block(nand_address_type address_struct);
212uint32_t nand_reset(void);
213uint32_t nand_get_status(void);
214uint32_t nand_read_status(void);
215uint32_t nand_address_increment(nand_address_type* address_struct);
216
229#endif
at32f435_437_board.h
ecc_value_read
uint32_t ecc_value_read
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:44
nand_id_struct
nand_id_type nand_id_struct
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:40
ecc_value_write
uint32_t ecc_value_write
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:44
nand_read_small_page
uint32_t nand_read_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read)
this routine is for sequential read from one or several 512 bytes page size.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:228
nand_read_id
void nand_read_id(nand_id_type *nand_id_struct)
reads nand memory's id.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:120
nand_init
void nand_init(void)
configures the xmc and gpios to interface with the nand memory. this function must be called before a...
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:44
nand_read_status
uint32_t nand_read_status(void)
reads the nand memory status using the read status command.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:471
nand_address_increment
uint32_t nand_address_increment(nand_address_type *address_struct)
increment the nand memory address.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:502
nand_reset
uint32_t nand_reset(void)
this routine reset the nand flash.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:426
nand_erase_block
uint32_t nand_erase_block(nand_address_type address_struct)
this routine erase complete block from nand flash
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:403
nand_read_spare_area
uint32_t nand_read_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read)
this routine read the spare area information from the specified pages addresses.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:353
nand_write_small_page
uint32_t nand_write_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write)
this routine is for writing one or several 512 bytes page size.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:161
nand_get_status
uint32_t nand_get_status(void)
get the nand operation status.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:441
nand_write_spare_area
uint32_t nand_write_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write)
this routine write the spare area information for the specified pages addresses.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:294
nand_address_type
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:63
nand_id_type
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:45


AT32F435/437 Firmwary Library: xmc_ecc.c File Reference

  • at_start_f437
  • examples
  • xmc
  • nand_flash
  • ecc
  • src
Functions
at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c File Reference

nand ecc configuration More...

#include "xmc_ecc.h"

Go to the source code of this file.

Functions

void | nand_init (void)
configures the xmc and gpios to interface with the nand memory. this function must be called before any write/read operation on the nand. More...
void | nand_read_id (nand_id_type *nand_id_struct)
reads nand memory's id. More...
uint32_t | nand_write_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write)
this routine is for writing one or several 512 bytes page size. More...
uint32_t | nand_read_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read)
this routine is for sequential read from one or several 512 bytes page size. More...
uint32_t | nand_write_spare_area (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write)
this routine write the spare area information for the specified pages addresses. More...
uint32_t | nand_read_spare_area (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read)
this routine read the spare area information from the specified pages addresses. More...
uint32_t | nand_erase_block (nand_address_type address_struct)
this routine erase complete block from nand flash More...
uint32_t | nand_reset (void)
this routine reset the nand flash. More...
uint32_t | nand_get_status (void)
get the nand operation status. More...
uint32_t | nand_read_status (void)
reads the nand memory status using the read status command. More...
uint32_t | nand_address_increment (nand_address_type *address_struct)
increment the nand memory address. More...

Detailed Description

nand ecc configuration

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c.


AT32F435/437 Firmwary Library: xmc_ecc.c Source File

  • at_start_f437
  • examples
  • xmc
  • nand_flash
  • ecc
  • src
at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c
Go to the documentation of this file.
1
27#include "xmc_ecc.h"
28
44void nand_init(void)
45{
46 gpio_init_type gpio_init_struct;
47 xmc_nand_init_type nand_init_struct;
48 xmc_nand_pccard_timinginit_type xmc_regular_spacetimingstruct;
49
50 /* enable the xmc clock */
51 crm_periph_clock_enable(CRM_XMC_PERIPH_CLOCK, TRUE);
52 /* enable gpiod/gpiob/gpioe clock */
53 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
54 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
55
56 /*-- gpio configuration ------------------------------------------------------*/
57 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE0, GPIO_MUX_12);
58 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_12);
59 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE11, GPIO_MUX_12);
60 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE12, GPIO_MUX_12);
61 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE14, GPIO_MUX_12);
62 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE15, GPIO_MUX_12);
63 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_12);
64 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE5, GPIO_MUX_12);
65 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE6, GPIO_MUX_12);
66 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE7, GPIO_MUX_12);
67 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE7, GPIO_MUX_12);
68 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE8, GPIO_MUX_12);
69 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE9, GPIO_MUX_12);
70 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE10, GPIO_MUX_12);
71
72 /* cle, ale, d0->d3, noe, nwe , nce2 and nwait nand pin configuration */
73 gpio_default_para_init(&gpio_init_struct);
74 gpio_init_struct.gpio_pins = GPIO_PINS_11 | GPIO_PINS_12 | GPIO_PINS_14 | GPIO_PINS_15 |
75 GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_4 | GPIO_PINS_5 |
76 GPIO_PINS_6 | GPIO_PINS_7;
77 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
78 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
79 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
80 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
81 gpio_init(GPIOD, &gpio_init_struct);
82
83 /* d4->d7 nand pin configuration */
84 gpio_init_struct.gpio_pins = GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10;
85 gpio_init(GPIOE, &gpio_init_struct);
86
87 /*-- xmc configuration ------------------------------------------------------*/
88 xmc_nand_default_para_init(&nand_init_struct);
89 nand_init_struct.nand_bank = XMC_BANK2_NAND;
90 nand_init_struct.wait_enable = XMC_WAIT_OPERATION_DISABLE;
91 nand_init_struct.bus_type = XMC_BUSTYPE_8_BITS;
92 nand_init_struct.ecc_enable = XMC_ECC_OPERATION_DISABLE;
93#ifdef H27U1G8F2CTR
94 nand_init_struct.ecc_pagesize = XMC_ECC_PAGESIZE_2048_BYTES;
95#elif defined K9GAG08U0E
96 nand_init_struct.ecc_pagesize = XMC_ECC_PAGESIZE_8192_BYTES;
97#endif
98 nand_init_struct.delay_time_cycle = 0x10;
99 nand_init_struct.delay_time_ar = 0x10;
100 xmc_nand_init(&nand_init_struct);
101
102 xmc_nand_timing_default_para_init(&xmc_regular_spacetimingstruct, &xmc_regular_spacetimingstruct);
103 xmc_regular_spacetimingstruct.class_bank = XMC_BANK2_NAND;
104 xmc_regular_spacetimingstruct.mem_setup_time = 254;
105 xmc_regular_spacetimingstruct.mem_hiz_time = 254;
106 xmc_regular_spacetimingstruct.mem_hold_time = 254;
107 xmc_regular_spacetimingstruct.mem_waite_time = 254;
108 xmc_nand_timing_config(&xmc_regular_spacetimingstruct, &xmc_regular_spacetimingstruct);
109
110 /* xmc nand bank cmd test */
111 xmc_nand_enable(XMC_BANK2_NAND, TRUE);
112}
113
120void nand_read_id(nand_id_type* nand_id_struct)
121{
122 uint32_t data = 0;
123
124 /* send command to the command area */
125 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = 0x90;
126 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = 0x00;
127
128#ifdef H27U1G8F2CTR
129 /* sequence to read id from nand flash */
130 data = *(__IO uint32_t *)(Bank_NAND_ADDR | DATA_AREA);
131 nand_id_struct->maker_id = addr_1st_cycle (data);
132 nand_id_struct->device_id = addr_2nd_cycle (data);
133 nand_id_struct->third_id = addr_3rd_cycle (data);
134 nand_id_struct->fourth_id = addr_4th_cycle (data);
135#elif defined K9GAG08U0E
136 /* sequence to read id from nand flash */
137 data = *(__IO uint32_t *)(Bank_NAND_ADDR | DATA_AREA);
138 nand_id_struct->maker_id = addr_1st_cycle (data);
139 nand_id_struct->device_id = addr_2nd_cycle (data);
140 nand_id_struct->third_id = addr_3rd_cycle (data);
141 nand_id_struct->fourth_id = addr_4th_cycle (data);
142 data = *(__IO uint16_t *)(Bank_NAND_ADDR | DATA_AREA);
143 nand_id_struct->fifth_id = addr_1st_cycle (data);
144 nand_id_struct->sixth_id = addr_2nd_cycle (data);
145#endif
146}
147
161uint32_t nand_write_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write)
162{
163 uint32_t index = 0x00, num_page_written = 0x00, address_status = NAND_VALID_ADDRESS;
164 uint32_t status = NAND_READY, size = 0x00;
165
166 while((num_page_to_write != 0x00) && (address_status == NAND_VALID_ADDRESS) && (status == NAND_READY))
167 {
168 /* page write command and address */
169 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_WRITE0;
170
171#ifdef H27U1G8F2CTR
172 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(COL_ADDRESS);
173 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(COL_ADDRESS);
174 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
175 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
176#elif defined K9GAG08U0E
177 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(COL_ADDRESS);
178 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(COL_ADDRESS);
179 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
180 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
181 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_3rd_cycle(ROW_ADDRESS);
182#endif
183
184 /* calculate the size */
185 size = NAND_PAGE_SIZE + (NAND_PAGE_SIZE * num_page_written);
186
187 /* write data */
188 for(index = 0x00; index < size; index++)
189 {
190 *(__IO uint8_t *)(Bank_NAND_ADDR | DATA_AREA) = pbuffer[index];
191 }
192 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_WRITE_TRUE1;
193
194 while(xmc_flag_status_get(XMC_BANK2_NAND,XMC_FEMPT_FLAG) == RESET);
195 ecc_value_write = xmc_ecc_get(XMC_BANK2_NAND);
196 xmc_nand_ecc_enable(XMC_BANK2_NAND, FALSE);
197
198 /* check status for successful operation */
199 status = nand_get_status();
200
201 if(status == NAND_READY)
202 {
203 num_page_written++;
204
205 num_page_to_write--;
206
207 /* calculate next small page address */
208 address_status = nand_address_increment(&address_struct);
209 }
210 }
211
212 return (status | address_status);
213}
214
228uint32_t nand_read_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read)
229{
230 uint32_t index = 0x00, num_page_read = 0x00, address_status = NAND_VALID_ADDRESS;
231 uint32_t status = NAND_READY, size = 0x00;
232
233 while((num_page_to_read != 0x0) && (address_status == NAND_VALID_ADDRESS))
234 {
235 /* page read command and page address */
236 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_AREA_A;
237
238#ifdef H27U1G8F2CTR
239 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(COL_ADDRESS);
240 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(COL_ADDRESS);
241 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
242 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
243#elif defined K9GAG08U0E
244 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(COL_ADDRESS);
245 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(COL_ADDRESS);
246 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
247 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
248 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_3rd_cycle(ROW_ADDRESS);
249#endif
250
251 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_AREA_TRUE1;
252
253 delay_ms(1);
254
255 /* calculate the size */
256 size = NAND_PAGE_SIZE + (NAND_PAGE_SIZE * num_page_read);
257
258 /* get data into buffer */
259 for(index = 0x00; index < size; index++)
260 {
261 pbuffer[index]= *(__IO uint8_t *)(Bank_NAND_ADDR | DATA_AREA);
262 }
263
264 ecc_value_read = xmc_ecc_get(XMC_BANK2_NAND);
265 xmc_nand_ecc_enable(XMC_BANK2_NAND, FALSE);
266
267 num_page_read++;
268
269 num_page_to_read--;
270
271 /* calculate page address */
272 address_status = nand_address_increment(&address_struct);
273 }
274
275 status = nand_get_status();
276
277 return (status | address_status);
278}
279
294uint32_t nand_write_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write)
295{
296 uint32_t index = 0x00, num_spare_area_written = 0x00, address_status = NAND_VALID_ADDRESS;
297 uint32_t status = NAND_READY, size = 0x00;
298
299 while((num_spare_area_to_write != 0x00) && (address_status == NAND_VALID_ADDRESS) && (status == NAND_READY))
300 {
301 /* page write spare area command and address */
302 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_AREA_C;
303 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_WRITE0;
304
305 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = 0x00;
306 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
307 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
308 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_3rd_cycle(ROW_ADDRESS);
309 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_4th_cycle(ROW_ADDRESS);
310
311 /* calculate the size */
312 size = NAND_SPARE_AREA_SIZE + (NAND_SPARE_AREA_SIZE * num_spare_area_written);
313
314 /* write the data */
315 for(index = 0x00; index < size; index++)
316 {
317 *(__IO uint8_t *)(Bank_NAND_ADDR | DATA_AREA) = pbuffer[index];
318 }
319
320 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_WRITE_TRUE1;
321
322 /* check status for successful operation */
323 status = nand_get_status();
324
325 if(status == NAND_READY)
326 {
327 num_spare_area_written++;
328
329 num_spare_area_to_write--;
330
331 /* calculate next page address */
332 address_status = nand_address_increment(&address_struct);
333 }
334 }
335
336 return (status | address_status);
337}
338
353uint32_t nand_read_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read)
354{
355 uint32_t num_spare_area_read = 0x00, index = 0x00, address_status = NAND_VALID_ADDRESS;
356 uint32_t status = NAND_READY, size = 0x00;
357
358 while((num_spare_area_to_read != 0x0) && (address_status == NAND_VALID_ADDRESS))
359 {
360 /* page read command and page address */
361 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_AREA_C;
362
363 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = 0x00;
364 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
365 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
366 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_3rd_cycle(ROW_ADDRESS);
367 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_4th_cycle(ROW_ADDRESS);
368
369 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_AREA_TRUE1;
370
371 delay_ms(1);
372
373 /* data read */
374 size = NAND_SPARE_AREA_SIZE + (NAND_SPARE_AREA_SIZE * num_spare_area_read);
375
376 /* get data into buffer */
377 for(index = 0x00 ;index < size; index++)
378 {
379 pbuffer[index] = *(__IO uint8_t *)(Bank_NAND_ADDR | DATA_AREA);
380 }
381
382 num_spare_area_read++;
383
384 num_spare_area_to_read--;
385
386 /* calculate page address */
387 address_status = nand_address_increment(&address_struct);
388 }
389
390 status = nand_get_status();
391
392 return (status | address_status);
393}
394
403uint32_t nand_erase_block(nand_address_type address_struct)
404{
405 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_ERASE0;
406
407#ifdef H27U1G8F2CTR
408 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
409 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
410#elif defined K9GAG08U0E
411 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
412 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
413 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_3rd_cycle(ROW_ADDRESS);
414#endif
415
416 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_ERASE1;
417
418 return (nand_get_status());
419}
420
426uint32_t nand_reset(void)
427{
428 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_RESET;
429
430 return (NAND_READY);
431}
432
441uint32_t nand_get_status(void)
442{
443 uint32_t timeout = 0x1000000, status = NAND_READY;
444
445 status = nand_read_status();
446
447 /* wait for a nand operation to complete or a timeout to occur */
448 while((status != NAND_READY) && ( timeout != 0x00))
449 {
450 status = nand_read_status();
451 timeout --;
452 }
453
454 if(timeout == 0x00)
455 {
456 status = NAND_TIMEOUT_ERROR;
457 }
458
459 /* return the operation status */
460 return (status);
461}
462
471uint32_t nand_read_status(void)
472{
473 uint32_t data = 0x00, status = NAND_BUSY;
474
475 /* read status operation */
476 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_STATUS;
477 data = *(__IO uint8_t *)(Bank_NAND_ADDR);
478
479 if((data & NAND_ERROR) == NAND_ERROR)
480 {
481 status = NAND_ERROR;
482 }
483 else if((data & NAND_READY) == NAND_READY)
484 {
485 status = NAND_READY;
486 }
487 else
488 {
489 status = NAND_BUSY;
490 }
491
492 return (status);
493}
494
502uint32_t nand_address_increment(nand_address_type* address_struct)
503{
504 uint32_t status = NAND_VALID_ADDRESS;
505
506 address_struct->page++;
507
508 if(address_struct->page == NAND_BLOCK_SIZE)
509 {
510 address_struct->page = 0;
511 address_struct->block++;
512
513 if(address_struct->block == NAND_ZONE_SIZE)
514 {
515 address_struct->block = 0;
516 address_struct->zone++;
517
518 if(address_struct->zone == NAND_MAX_ZONE)
519 {
520 status = NAND_INVALID_ADDRESS;
521 }
522 }
523 }
524
525 return (status);
526}
527
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
COL_ADDRESS
#define COL_ADDRESS
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:75
ecc_value_read
uint32_t ecc_value_read
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:44
Bank_NAND_ADDR
#define Bank_NAND_ADDR
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:80
nand_id_struct
nand_id_type nand_id_struct
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:40
ecc_value_write
uint32_t ecc_value_write
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:44
ROW_ADDRESS
#define ROW_ADDRESS
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:74
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_XMC_PERIPH_CLOCK
@ CRM_XMC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:123
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_MODERATE
@ GPIO_DRIVE_STRENGTH_MODERATE
Definition: at32f435_437_gpio.h:94
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
ADDR_AREA
#define ADDR_AREA
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:98
CMD_AREA
#define CMD_AREA
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:96
DATA_AREA
#define DATA_AREA
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:100
xmc_ecc_get
uint32_t xmc_ecc_get(xmc_class_bank_type xmc_bank)
return the error correction code register value.
Definition: at32f435_437_xmc.c:429
xmc_nand_init
void xmc_nand_init(xmc_nand_init_type *xmc_nand_init_struct)
initialize the xmc nand banks according to the specified parameters in the xmc_nandinitstruct.
Definition: at32f435_437_xmc.c:269
xmc_nand_timing_default_para_init
void xmc_nand_timing_default_para_init(xmc_nand_pccard_timinginit_type *xmc_common_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_attribute_spacetiming_struct)
fill each xmc_common_spacetiming_struct and xmc_attribute_spacetiming_struct member with its default ...
Definition: at32f435_437_xmc.c:360
xmc_nand_ecc_enable
void xmc_nand_ecc_enable(xmc_class_bank_type xmc_bank, confirm_state new_state)
enable or disable the xmc nand ecc feature.
Definition: at32f435_437_xmc.c:407
xmc_nand_default_para_init
void xmc_nand_default_para_init(xmc_nand_init_type *xmc_nand_init_struct)
fill each xmc_nand_init_struct member with its default value.
Definition: at32f435_437_xmc.c:340
xmc_nand_timing_config
void xmc_nand_timing_config(xmc_nand_pccard_timinginit_type *xmc_common_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_attribute_spacetiming_struct)
initialize the xmc nand banks according to the specified parameters in the xmc_nandinitstruct.
Definition: at32f435_437_xmc.c:305
xmc_nand_enable
void xmc_nand_enable(xmc_class_bank_type xmc_bank, confirm_state new_state)
enable or disable the specified nand memory bank.
Definition: at32f435_437_xmc.c:384
xmc_flag_status_get
flag_status xmc_flag_status_get(xmc_class_bank_type xmc_bank, xmc_interrupt_flag_type xmc_flag)
check whether the specified xmc flag is set or not.
Definition: at32f435_437_xmc.c:695
XMC_BANK2_NAND
@ XMC_BANK2_NAND
Definition: at32f435_437_xmc.h:157
XMC_BUSTYPE_8_BITS
@ XMC_BUSTYPE_8_BITS
Definition: at32f435_437_xmc.h:178
XMC_FEMPT_FLAG
@ XMC_FEMPT_FLAG
Definition: at32f435_437_xmc.h:243
XMC_WAIT_OPERATION_DISABLE
@ XMC_WAIT_OPERATION_DISABLE
Definition: at32f435_437_xmc.h:128
XMC_ECC_PAGESIZE_8192_BYTES
@ XMC_ECC_PAGESIZE_8192_BYTES
Definition: at32f435_437_xmc.h:221
XMC_ECC_PAGESIZE_2048_BYTES
@ XMC_ECC_PAGESIZE_2048_BYTES
Definition: at32f435_437_xmc.h:219
XMC_ECC_OPERATION_DISABLE
@ XMC_ECC_OPERATION_DISABLE
Definition: at32f435_437_xmc.h:137
addr_2nd_cycle
#define addr_2nd_cycle(addr)
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:188
addr_3rd_cycle
#define addr_3rd_cycle(addr)
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:190
addr_4th_cycle
#define addr_4th_cycle(addr)
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:192
addr_1st_cycle
#define addr_1st_cycle(addr)
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:186
nand_read_small_page
uint32_t nand_read_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read)
this routine is for sequential read from one or several 512 bytes page size.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:228
nand_read_id
void nand_read_id(nand_id_type *nand_id_struct)
reads nand memory's id.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:120
nand_init
void nand_init(void)
configures the xmc and gpios to interface with the nand memory. this function must be called before a...
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:44
nand_read_status
uint32_t nand_read_status(void)
reads the nand memory status using the read status command.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:471
nand_address_increment
uint32_t nand_address_increment(nand_address_type *address_struct)
increment the nand memory address.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:502
nand_reset
uint32_t nand_reset(void)
this routine reset the nand flash.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:426
nand_erase_block
uint32_t nand_erase_block(nand_address_type address_struct)
this routine erase complete block from nand flash
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:403
nand_read_spare_area
uint32_t nand_read_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read)
this routine read the spare area information from the specified pages addresses.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:353
nand_write_small_page
uint32_t nand_write_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write)
this routine is for writing one or several 512 bytes page size.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:161
nand_get_status
uint32_t nand_get_status(void)
get the nand operation status.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:441
nand_write_spare_area
uint32_t nand_write_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write)
this routine write the spare area information for the specified pages addresses.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:294
NAND_CMD_WRITE_TRUE1
#define NAND_CMD_WRITE_TRUE1
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:117
NAND_CMD_RESET
#define NAND_CMD_RESET
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:125
NAND_CMD_WRITE0
#define NAND_CMD_WRITE0
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:116
NAND_CMD_STATUS
#define NAND_CMD_STATUS
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:123
NAND_CMD_AREA_A
#define NAND_CMD_AREA_A
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:111
NAND_CMD_ERASE1
#define NAND_CMD_ERASE1
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:120
NAND_CMD_ERASE0
#define NAND_CMD_ERASE0
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:119
NAND_CMD_AREA_TRUE1
#define NAND_CMD_AREA_TRUE1
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:114
NAND_CMD_AREA_C
#define NAND_CMD_AREA_C
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:113
NAND_ERROR
#define NAND_ERROR
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:140
NAND_READY
#define NAND_READY
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:141
NAND_VALID_ADDRESS
#define NAND_VALID_ADDRESS
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:136
NAND_INVALID_ADDRESS
#define NAND_INVALID_ADDRESS
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:137
NAND_TIMEOUT_ERROR
#define NAND_TIMEOUT_ERROR
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:138
NAND_BUSY
#define NAND_BUSY
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:139
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
nand_address_type
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:63
nand_address_type::page
uint16_t page
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:66
nand_address_type::block
uint16_t block
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:65
nand_address_type::zone
uint16_t zone
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:64
nand_id_type
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:45
nand_id_type::sixth_id
uint8_t sixth_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:51
nand_id_type::device_id
uint8_t device_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:47
nand_id_type::fourth_id
uint8_t fourth_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:49
nand_id_type::fifth_id
uint8_t fifth_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:50
nand_id_type::third_id
uint8_t third_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:48
nand_id_type::maker_id
uint8_t maker_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:46
xmc_nand_init_type
xmc nand init structure definition
Definition: at32f435_437_xmc.h:443
xmc_nand_init_type::ecc_enable
xmc_ecc_enable_type ecc_enable
Definition: at32f435_437_xmc.h:447
xmc_nand_init_type::delay_time_cycle
uint32_t delay_time_cycle
Definition: at32f435_437_xmc.h:449
xmc_nand_init_type::nand_bank
xmc_class_bank_type nand_bank
Definition: at32f435_437_xmc.h:444
xmc_nand_init_type::wait_enable
xmc_nand_pccard_wait_type wait_enable
Definition: at32f435_437_xmc.h:445
xmc_nand_init_type::ecc_pagesize
xmc_ecc_pagesize_type ecc_pagesize
Definition: at32f435_437_xmc.h:448
xmc_nand_init_type::delay_time_ar
uint32_t delay_time_ar
Definition: at32f435_437_xmc.h:450
xmc_nand_init_type::bus_type
xmc_data_width_type bus_type
Definition: at32f435_437_xmc.h:446
xmc_nand_pccard_timinginit_type
nand and pccard timing parameters xmc
Definition: at32f435_437_xmc.h:430
xmc_nand_pccard_timinginit_type::class_bank
xmc_class_bank_type class_bank
Definition: at32f435_437_xmc.h:431
xmc_nand_pccard_timinginit_type::mem_waite_time
uint32_t mem_waite_time
Definition: at32f435_437_xmc.h:433
xmc_nand_pccard_timinginit_type::mem_hold_time
uint32_t mem_hold_time
Definition: at32f435_437_xmc.h:434
xmc_nand_pccard_timinginit_type::mem_hiz_time
uint32_t mem_hiz_time
Definition: at32f435_437_xmc.h:435
xmc_nand_pccard_timinginit_type::mem_setup_time
uint32_t mem_setup_time
Definition: at32f435_437_xmc.h:432


AT32F435/437 Firmwary Library: xmc_nand.h File Reference

  • at_start_f437
  • examples
  • xmc
  • nand_flash
  • nand
  • inc
Data Structures | Macros | Functions
at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h File Reference

header file for the nand configuration. More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Data Structures

struct | nand_id_type
struct | nand_address_type

Macros

#define | ROW_ADDRESS (address_struct.page + (address_struct.block + (address_struct.zone * NAND_ZONE_SIZE)) * NAND_BLOCK_SIZE)
#define | COL_ADDRESS address_struct.byte
#define | BUFFER_SIZE NAND_PAGE_SIZE
#define | XMC_Bank_NAND XMC_Bank2_NAND
#define | Bank_NAND_ADDR Bank2_NAND_ADDR
#define | Bank2_NAND_ADDR ((uint32_t)0x70000000)
#define | CMD_AREA (uint32_t)(1<<16)
#define | ADDR_AREA (uint32_t)(1<<17)
#define | DATA_AREA ((uint32_t)0x00000000)
#define | NAND_CMD_AREA_A ((uint8_t)0x00)
#define | NAND_CMD_AREA_B ((uint8_t)0x01)
#define | NAND_CMD_AREA_C ((uint8_t)0x50)
#define | NAND_CMD_AREA_TRUE1 ((uint8_t)0x30)
#define | NAND_CMD_WRITE0 ((uint8_t)0x80)
#define | NAND_CMD_WRITE_TRUE1 ((uint8_t)0x10)
#define | NAND_CMD_ERASE0 ((uint8_t)0x60)
#define | NAND_CMD_ERASE1 ((uint8_t)0xD0)
#define | NAND_CMD_READID ((uint8_t)0x90)
#define | NAND_CMD_STATUS ((uint8_t)0x70)
#define | NAND_CMD_LOCK_STATUS ((uint8_t)0x7A)
#define | NAND_CMD_RESET ((uint8_t)0xFF)
#define | NAND_VALID_ADDRESS ((uint32_t)0x00000100)
#define | NAND_INVALID_ADDRESS ((uint32_t)0x00000200)
#define | NAND_TIMEOUT_ERROR ((uint32_t)0x00000400)
#define | NAND_BUSY ((uint32_t)0x00000000)
#define | NAND_ERROR ((uint32_t)0x00000001)
#define | NAND_READY ((uint32_t)0x00000040)
#define | addr_1st_cycle(addr) (uint8_t)((addr) & (uint32_t)0x000000FF)
#define | addr_2nd_cycle(addr) (uint8_t)(((addr) & (uint32_t)0x0000FF00) >> 8)
#define | addr_3rd_cycle(addr) (uint8_t)(((addr) & (uint32_t)0x00FF0000) >> 16)
#define | addr_4th_cycle(addr) (uint8_t)(((addr) & (uint32_t)0xFF000000) >> 24)

Functions

void | nand_init (void)
configures the xmc and gpios to interface with the nand memory. this function must be called before any write/read operation on the nand. More...
void | nand_read_id (nand_id_type *nand_id_struct)
reads nand memory's id. More...
uint32_t | nand_write_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write)
this routine is for writing one or several 512 bytes page size. More...
uint32_t | nand_read_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read)
this routine is for sequential read from one or several 512 bytes page size. More...
uint32_t | nand_write_spare_area (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write)
this routine write the spare area information for the specified pages addresses. More...
uint32_t | nand_read_spare_area (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read)
this routine read the spare area information from the specified pages addresses. More...
uint32_t | nand_erase_block (nand_address_type address_struct)
this routine erase complete block from nand flash More...
uint32_t | nand_reset (void)
this routine reset the nand flash. More...
uint32_t | nand_get_status (void)
get the nand operation status. More...
uint32_t | nand_read_status (void)
reads the nand memory status using the read status command. More...
uint32_t | nand_address_increment (nand_address_type *address_struct)
increment the nand memory address. More...

Detailed Description

header file for the nand configuration.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h.


AT32F435/437 Firmwary Library: xmc_nand.h Source File

  • at_start_f437
  • examples
  • xmc
  • nand_flash
  • nand
  • inc
at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
Go to the documentation of this file.
1
27/*-- define to prevent recursive inclusion -------------------------------------*/
28#ifndef __XMC_NAND_H
29#define __XMC_NAND_H
30
31#include "at32f435_437_board.h"
32
45typedef struct
46{
47 uint8_t maker_id;
48 uint8_t device_id;
49 uint8_t third_id;
50 uint8_t fourth_id;
51 uint8_t fifth_id;
52 uint8_t sixth_id;
53} nand_id_type;
54
63typedef struct
64{
65 uint16_t zone;
66 uint16_t block;
67 uint16_t page;
68 uint16_t byte;
69} nand_address_type;
70
76#define ROW_ADDRESS (address_struct.page + (address_struct.block + (address_struct.zone * NAND_ZONE_SIZE)) * NAND_BLOCK_SIZE)
77#define COL_ADDRESS address_struct.byte
78
79#define BUFFER_SIZE NAND_PAGE_SIZE
80
81#define XMC_Bank_NAND XMC_Bank2_NAND
82#define Bank_NAND_ADDR Bank2_NAND_ADDR
83#define Bank2_NAND_ADDR ((uint32_t)0x70000000)
84
85#ifdef H27U1G8F2CTR
86#define NAND_AT_MakerID (uint8_t)0xAD
87#define NAND_AT_DeviceID (uint8_t)0xF1
88#elif defined K9GAG08U0E
89#define NAND_AT_MakerID (uint8_t)0xEC
90#define NAND_AT_DeviceID (uint8_t)0xD5
91#endif
92
96/* a16 = cle high */
97#define CMD_AREA (uint32_t)(1<<16)
98/* a17 = ale high */
99#define ADDR_AREA (uint32_t)(1<<17)
100
101#define DATA_AREA ((uint32_t)0x00000000)
102
111/*-- xmc nand memory command ------------------------------------*/
112#define NAND_CMD_AREA_A ((uint8_t)0x00)
113#define NAND_CMD_AREA_B ((uint8_t)0x01)
114#define NAND_CMD_AREA_C ((uint8_t)0x50)
115#define NAND_CMD_AREA_TRUE1 ((uint8_t)0x30)
116
117#define NAND_CMD_WRITE0 ((uint8_t)0x80)
118#define NAND_CMD_WRITE_TRUE1 ((uint8_t)0x10)
119
120#define NAND_CMD_ERASE0 ((uint8_t)0x60)
121#define NAND_CMD_ERASE1 ((uint8_t)0xD0)
122
123#define NAND_CMD_READID ((uint8_t)0x90)
124#define NAND_CMD_STATUS ((uint8_t)0x70)
125#define NAND_CMD_LOCK_STATUS ((uint8_t)0x7A)
126#define NAND_CMD_RESET ((uint8_t)0xFF)
127
136/*-- nand memory status ----------- -------------------------*/
137#define NAND_VALID_ADDRESS ((uint32_t)0x00000100)
138#define NAND_INVALID_ADDRESS ((uint32_t)0x00000200)
139#define NAND_TIMEOUT_ERROR ((uint32_t)0x00000400)
140#define NAND_BUSY ((uint32_t)0x00000000)
141#define NAND_ERROR ((uint32_t)0x00000001)
142#define NAND_READY ((uint32_t)0x00000040)
143
152/*-- xmc nand memory parameters ------------------------------------*/
153#ifdef H27U1G8F2CTR
154 /* 2k bytes per page w/o Spare Area */
155 #define NAND_PAGE_SIZE ((uint16_t)0x0800)
156 /* 64x2k bytes pages per block */
157 #define NAND_BLOCK_SIZE ((uint16_t)0x0040)
158 /* 1024 Block per zone */
159 #define NAND_ZONE_SIZE ((uint16_t)0x0400)
160 /* last 64 bytes as spare area */
161 #define NAND_SPARE_AREA_SIZE ((uint16_t)0x0040)
162 /* 1 zones of 1024 block */
163 #define NAND_MAX_ZONE ((uint16_t)0x0001)
164#elif defined K9GAG08U0E
165 /* 8k bytes per page w/o Spare Area */
166 #define NAND_PAGE_SIZE ((uint16_t)0x2000)
167 /* 128x8k bytes pages per block */
168 #define NAND_BLOCK_SIZE ((uint16_t)0x0080)
169 /* 2048 Block per zone */
170 #define NAND_ZONE_SIZE ((uint16_t)0x0800)
171 /* last 436 bytes as spare area */
172 #define NAND_SPARE_AREA_SIZE ((uint16_t)0x01B4)
173 /* 1 zones of 1024 block */
174 #define NAND_MAX_ZONE ((uint16_t)0x0001)
175#endif
176
185/*-- xmc nand memory address computation ------------------------------------*/
186/* 1st addressing cycle */
187#define addr_1st_cycle(addr) (uint8_t)((addr) & (uint32_t)0x000000FF)
188/* 2nd addressing cycle */
189#define addr_2nd_cycle(addr) (uint8_t)(((addr) & (uint32_t)0x0000FF00) >> 8)
190/* 3rd addressing cycle */
191#define addr_3rd_cycle(addr) (uint8_t)(((addr) & (uint32_t)0x00FF0000) >> 16)
192/* 4th addressing cycle */
193#define addr_4th_cycle(addr) (uint8_t)(((addr) & (uint32_t)0xFF000000) >> 24)
194
203void nand_init(void);
204void nand_read_id(nand_id_type* nand_id_struct);
205uint32_t nand_write_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write);
206uint32_t nand_read_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read);
207uint32_t nand_write_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write);
208uint32_t nand_read_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read);
209uint32_t nand_erase_block(nand_address_type address_struct);
210uint32_t nand_reset(void);
211uint32_t nand_get_status(void);
212uint32_t nand_read_status(void);
213uint32_t nand_address_increment(nand_address_type* address_struct);
214
227#endif
228
229
at32f435_437_board.h
nand_id_struct
nand_id_type nand_id_struct
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:40
nand_read_small_page
uint32_t nand_read_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read)
this routine is for sequential read from one or several 512 bytes page size.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:228
nand_read_id
void nand_read_id(nand_id_type *nand_id_struct)
reads nand memory's id.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:120
nand_init
void nand_init(void)
configures the xmc and gpios to interface with the nand memory. this function must be called before a...
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:44
nand_read_status
uint32_t nand_read_status(void)
reads the nand memory status using the read status command.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:471
nand_address_increment
uint32_t nand_address_increment(nand_address_type *address_struct)
increment the nand memory address.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:502
nand_reset
uint32_t nand_reset(void)
this routine reset the nand flash.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:426
nand_erase_block
uint32_t nand_erase_block(nand_address_type address_struct)
this routine erase complete block from nand flash
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:403
nand_read_spare_area
uint32_t nand_read_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read)
this routine read the spare area information from the specified pages addresses.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:353
nand_write_small_page
uint32_t nand_write_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write)
this routine is for writing one or several 512 bytes page size.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:161
nand_get_status
uint32_t nand_get_status(void)
get the nand operation status.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:441
nand_write_spare_area
uint32_t nand_write_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write)
this routine write the spare area information for the specified pages addresses.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:294
nand_address_type
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:63
nand_id_type
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:45


AT32F435/437 Firmwary Library: xmc_nand.c File Reference

  • at_start_f437
  • examples
  • xmc
  • nand_flash
  • nand
  • src
Functions
at_start_f437/examples/xmc/nand_flash/nand/src/xmc_nand.c File Reference

nand configuration More...

#include "xmc_nand.h"

Go to the source code of this file.

Functions

void | nand_init (void)
configures the xmc and gpios to interface with the nand memory. this function must be called before any write/read operation on the nand. More...
void | nand_read_id (nand_id_type *nand_id_struct)
reads nand memory's id. More...
uint32_t | nand_write_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write)
this routine is for writing one or several 512 bytes page size. More...
uint32_t | nand_read_small_page (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read)
this routine is for sequential read from one or several 512 bytes page size. More...
uint32_t | nand_write_spare_area (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write)
this routine write the spare area information for the specified pages addresses. More...
uint32_t | nand_read_spare_area (uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read)
this routine read the spare area information from the specified pages addresses. More...
uint32_t | nand_erase_block (nand_address_type address_struct)
this routine erase complete block from nand flash More...
uint32_t | nand_reset (void)
this routine reset the nand flash. More...
uint32_t | nand_get_status (void)
get the nand operation status. More...
uint32_t | nand_read_status (void)
reads the nand memory status using the read status command. More...
uint32_t | nand_address_increment (nand_address_type *address_struct)
increment the nand memory address. More...

Detailed Description

nand configuration

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/xmc/nand_flash/nand/src/xmc_nand.c.


AT32F435/437 Firmwary Library: xmc_nand.c Source File

  • at_start_f437
  • examples
  • xmc
  • nand_flash
  • nand
  • src
at_start_f437/examples/xmc/nand_flash/nand/src/xmc_nand.c
Go to the documentation of this file.
1
26#include "xmc_nand.h"
27
43void nand_init(void)
44{
45 gpio_init_type gpio_init_struct;
46 xmc_nand_init_type nand_init_struct;
47 xmc_nand_pccard_timinginit_type regular_spacetiming_struct, special_spacetiming_struct;
48
49 /* enable the xmc clock */
50 crm_periph_clock_enable(CRM_XMC_PERIPH_CLOCK, TRUE);
51
52 /* enable gpiod/gpiob/gpioe clock */
53 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
54 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
55
56 /*-- gpio configuration ------------------------------------------------------*/
57 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE0, GPIO_MUX_12);
58 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_12);
59 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE11, GPIO_MUX_12);
60 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE12, GPIO_MUX_12);
61 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE14, GPIO_MUX_12);
62 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE15, GPIO_MUX_12);
63 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_12);
64 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE5, GPIO_MUX_12);
65 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE6, GPIO_MUX_12);
66 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE7, GPIO_MUX_12);
67 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE7, GPIO_MUX_12);
68 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE8, GPIO_MUX_12);
69 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE9, GPIO_MUX_12);
70 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE10, GPIO_MUX_12);
71 /* cle, ale, d0->d3, noe, nwe , nce2 and nwait nand pin configuration */
72 gpio_default_para_init(&gpio_init_struct);
73 gpio_init_struct.gpio_pins = GPIO_PINS_11 | GPIO_PINS_12 | GPIO_PINS_14 | GPIO_PINS_15 |
74 GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_4 | GPIO_PINS_5 |
75 GPIO_PINS_6 | GPIO_PINS_7;
76 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
77 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
78 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
79 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
80 gpio_init(GPIOD, &gpio_init_struct);
81
82 /* d4->d7 nand pin configuration */
83 gpio_init_struct.gpio_pins = GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10;
84 gpio_init(GPIOE, &gpio_init_struct);
85
86 /* -- xmc configuration ------------------------------------------------------ */
87 xmc_nand_default_para_init(&nand_init_struct);
88 nand_init_struct.nand_bank = XMC_BANK2_NAND;
89 nand_init_struct.wait_enable = XMC_WAIT_OPERATION_DISABLE;
90 nand_init_struct.bus_type = XMC_BUSTYPE_8_BITS;
91 nand_init_struct.ecc_enable = XMC_ECC_OPERATION_DISABLE;
92#ifdef H27U1G8F2CTR
93 nand_init_struct.ecc_pagesize = XMC_ECC_PAGESIZE_2048_BYTES;
94#elif defined K9GAG08U0E
95 nand_init_struct.ecc_pagesize = XMC_ECC_PAGESIZE_8192_BYTES;
96#endif
97 nand_init_struct.delay_time_cycle = 0x00;
98 nand_init_struct.delay_time_ar = 0x00;
99 xmc_nand_init(&nand_init_struct);
100
101 xmc_nand_timing_default_para_init(&regular_spacetiming_struct, &special_spacetiming_struct);
102 regular_spacetiming_struct.class_bank = XMC_BANK2_NAND;
103 regular_spacetiming_struct.mem_setup_time = 254;
104 regular_spacetiming_struct.mem_hiz_time = 254;
105 regular_spacetiming_struct.mem_hold_time = 254;
106 regular_spacetiming_struct.mem_waite_time = 254;
107 special_spacetiming_struct.class_bank = XMC_BANK2_NAND;
108 special_spacetiming_struct.mem_setup_time = 254;
109 special_spacetiming_struct.mem_hiz_time = 254;
110 special_spacetiming_struct.mem_hold_time = 254;
111 special_spacetiming_struct.mem_waite_time = 254;
112 xmc_nand_timing_config(&regular_spacetiming_struct, &special_spacetiming_struct);
113
114 /* xmc nand bank cmd test */
115 xmc_nand_enable(XMC_BANK2_NAND, TRUE);
116}
117
124void nand_read_id(nand_id_type* nand_id_struct)
125{
126 uint32_t data = 0;
127
128 /* send command to the command area */
129 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = 0x90;
130 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = 0x00;
131
132#ifdef H27U1G8F2CTR
133 /* sequence to read id from nand flash */
134 data = *(__IO uint32_t *)(Bank_NAND_ADDR | DATA_AREA);
135 nand_id_struct->maker_id = addr_1st_cycle (data);
136 nand_id_struct->device_id = addr_2nd_cycle (data);
137 nand_id_struct->third_id = addr_3rd_cycle (data);
138 nand_id_struct->fourth_id = addr_4th_cycle (data);
139#elif defined K9GAG08U0E
140 /* sequence to read id from nand flash */
141 data = *(__IO uint32_t *)(Bank_NAND_ADDR | DATA_AREA);
142 nand_id_struct->maker_id = addr_1st_cycle (data);
143 nand_id_struct->device_id = addr_2nd_cycle (data);
144 nand_id_struct->third_id = addr_3rd_cycle (data);
145 nand_id_struct->fourth_id = addr_4th_cycle (data);
146 data = *(__IO uint16_t *)(Bank_NAND_ADDR | DATA_AREA);
147 nand_id_struct->fifth_id = addr_1st_cycle (data);
148 nand_id_struct->sixth_id = addr_2nd_cycle (data);
149#endif
150}
151
165uint32_t nand_write_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write)
166{
167 uint32_t index = 0x00, num_page_written = 0x00, address_status = NAND_VALID_ADDRESS;
168 uint32_t status = NAND_READY, size = 0x00;
169
170 while((num_page_to_write != 0x00) && (address_status == NAND_VALID_ADDRESS) && (status == NAND_READY))
171 {
172 /* page write command and address */
173 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_WRITE0;
174#ifdef H27U1G8F2CTR
175 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(COL_ADDRESS);
176 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(COL_ADDRESS);
177 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
178 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
179#elif defined K9GAG08U0E
180 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(COL_ADDRESS);
181 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(COL_ADDRESS);
182 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
183 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
184 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_3rd_cycle(ROW_ADDRESS);
185#endif
186
187 /* calculate the size */
188 size = NAND_PAGE_SIZE + (NAND_PAGE_SIZE * num_page_written);
189
190 /* write data */
191 for(index = 0; index < size; index++)
192 {
193 *(__IO uint8_t *)(Bank_NAND_ADDR | DATA_AREA) = pbuffer[index];
194 }
195
196 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_WRITE_TRUE1;
197
198 /* check status for successful operation */
199 status = nand_get_status();
200
201 if(status == NAND_READY)
202 {
203 num_page_written++;
204
205 num_page_to_write--;
206
207 /* calculate next small page address */
208 address_status = nand_address_increment(&address_struct);
209 }
210 }
211
212 return (status | address_status);
213}
214
228uint32_t nand_read_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read)
229{
230 uint32_t index = 0x00, num_page_read = 0x00, address_status = NAND_VALID_ADDRESS;
231 uint32_t status = NAND_READY, size = 0x00 ;
232
233 while((num_page_to_read != 0x0) && (address_status == NAND_VALID_ADDRESS))
234 {
235 /* page read command and page address */
236 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_AREA_A;
237
238#ifdef H27U1G8F2CTR
239 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(COL_ADDRESS);
240 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(COL_ADDRESS);
241 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
242 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
243#elif defined K9GAG08U0E
244 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(COL_ADDRESS);
245 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(COL_ADDRESS);
246 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
247 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
248 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_3rd_cycle(ROW_ADDRESS);
249#endif
250 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_AREA_TRUE1;
251
252 delay_ms(1);
253
254 /* calculate the size */
255 size = (NAND_PAGE_SIZE + NAND_SPARE_AREA_SIZE) + ((NAND_PAGE_SIZE + NAND_SPARE_AREA_SIZE) * num_page_read);
256
257 /* get data into buffer */
258 for(index = 0x00; index < size; index++)
259 {
260 pbuffer[index]= *(__IO uint8_t *)(Bank_NAND_ADDR | DATA_AREA);
261 }
262
263 num_page_read++;
264
265 num_page_to_read--;
266
267 /* calculate page address */
268 address_status = nand_address_increment(&address_struct);
269 }
270
271 status = nand_get_status();
272
273 return (status | address_status);
274}
275
290uint32_t nand_write_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write)
291{
292 uint32_t index = 0x00, num_spare_area_written = 0x00, address_status = NAND_VALID_ADDRESS;
293 uint32_t status = NAND_READY, size = 0x00;
294
295 while((num_spare_area_to_write != 0x00) && (address_status == NAND_VALID_ADDRESS) && (status == NAND_READY))
296 {
297 /* page write spare area command and address */
298 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_AREA_C;
299 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_WRITE0;
300
301 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(COL_ADDRESS);
302 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(COL_ADDRESS);
303 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
304 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
305
306 /* calculate the size */
307 size = NAND_SPARE_AREA_SIZE + (NAND_SPARE_AREA_SIZE * num_spare_area_written);
308
309 /* write the data */
310 for(index = 0x00; index < size; index++)
311 {
312 *(__IO uint8_t *)(Bank_NAND_ADDR | DATA_AREA) = pbuffer[index];
313 }
314
315 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_WRITE_TRUE1;
316
317 /* check status for successful operation */
318 status = nand_get_status();
319
320 if(status == NAND_READY)
321 {
322 num_spare_area_written++;
323
324 num_spare_area_to_write--;
325
326 /* calculate next page address */
327 address_status = nand_address_increment(&address_struct);
328 }
329 }
330
331 return (status | address_status);
332}
333
348uint32_t nand_read_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read)
349{
350 uint32_t num_spare_area_read = 0x00, index = 0x00, address_status = NAND_VALID_ADDRESS;
351 uint32_t status = NAND_READY, size = 0x00;
352
353 while((num_spare_area_to_read != 0x0) && (address_status == NAND_VALID_ADDRESS))
354 {
355 /* page read command and page address */
356 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_AREA_C;
357
358 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = 0x00;
359 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
360 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
361 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_3rd_cycle(ROW_ADDRESS);
362 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_4th_cycle(ROW_ADDRESS);
363
364 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_AREA_TRUE1;
365
366 delay_ms(1);
367
368 /* data read */
369 size = NAND_SPARE_AREA_SIZE + (NAND_SPARE_AREA_SIZE * num_spare_area_read);
370
371 /* get data into buffer */
372 for(index = 0x00 ;index < size; index++)
373 {
374 pbuffer[index] = *(__IO uint8_t *)(Bank_NAND_ADDR | DATA_AREA);
375 }
376
377 num_spare_area_read++;
378
379 num_spare_area_to_read--;
380
381 /* calculate page address */
382 address_status = nand_address_increment(&address_struct);
383 }
384
385 status = nand_get_status();
386
387 return (status | address_status);
388}
389
398uint32_t nand_erase_block(nand_address_type address_struct)
399{
400 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_ERASE0;
401
402#ifdef H27U1G8F2CTR
403 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
404 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
405#elif defined K9GAG08U0E
406 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_1st_cycle(ROW_ADDRESS);
407 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_2nd_cycle(ROW_ADDRESS);
408 *(__IO uint8_t *)(Bank_NAND_ADDR | ADDR_AREA) = addr_3rd_cycle(ROW_ADDRESS);
409#endif
410 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_ERASE1;
411
412 return (nand_get_status());
413}
414
420uint32_t nand_reset(void)
421{
422 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_RESET;
423
424 return (NAND_READY);
425}
426
435uint32_t nand_get_status(void)
436{
437 uint32_t timeout = 0x1000000, status = NAND_READY;
438
439 status = nand_read_status();
440
441 /* wait for a nand operation to complete or a timeout to occur */
442 while((status != NAND_READY) && ( timeout != 0x00))
443 {
444 status = nand_read_status();
445 timeout --;
446 }
447
448 if(timeout == 0x00)
449 {
450 status = NAND_TIMEOUT_ERROR;
451 }
452
453 /* return the operation status */
454 return (status);
455}
456
465uint32_t nand_read_status(void)
466{
467 uint32_t data = 0x00, status = NAND_BUSY;
468
469 /* read status operation ------------------------------------*/
470 *(__IO uint8_t *)(Bank_NAND_ADDR | CMD_AREA) = NAND_CMD_STATUS;
471 data = *(__IO uint8_t *)(Bank_NAND_ADDR);
472
473 if((data & NAND_ERROR) == NAND_ERROR)
474 {
475 status = NAND_ERROR;
476 }
477 else if((data & NAND_READY) == NAND_READY)
478 {
479 status = NAND_READY;
480 }
481 else
482 {
483 status = NAND_BUSY;
484 }
485
486 return (status);
487}
488
496uint32_t nand_address_increment(nand_address_type* address_struct)
497{
498 uint32_t status = NAND_VALID_ADDRESS;
499
500 address_struct->page++;
501
502 if(address_struct->page == NAND_BLOCK_SIZE)
503 {
504 address_struct->page = 0;
505 address_struct->block++;
506
507 if(address_struct->block == NAND_ZONE_SIZE)
508 {
509 address_struct->block = 0;
510 address_struct->zone++;
511
512 if(address_struct->zone == NAND_MAX_ZONE)
513 {
514 status = NAND_INVALID_ADDRESS;
515 }
516 }
517 }
518
519 return (status);
520}
521
522
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
COL_ADDRESS
#define COL_ADDRESS
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:75
Bank_NAND_ADDR
#define Bank_NAND_ADDR
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:80
nand_id_struct
nand_id_type nand_id_struct
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:40
ROW_ADDRESS
#define ROW_ADDRESS
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:74
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_XMC_PERIPH_CLOCK
@ CRM_XMC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:123
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_MODERATE
@ GPIO_DRIVE_STRENGTH_MODERATE
Definition: at32f435_437_gpio.h:94
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
ADDR_AREA
#define ADDR_AREA
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:98
CMD_AREA
#define CMD_AREA
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:96
DATA_AREA
#define DATA_AREA
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:100
xmc_nand_init
void xmc_nand_init(xmc_nand_init_type *xmc_nand_init_struct)
initialize the xmc nand banks according to the specified parameters in the xmc_nandinitstruct.
Definition: at32f435_437_xmc.c:269
xmc_nand_timing_default_para_init
void xmc_nand_timing_default_para_init(xmc_nand_pccard_timinginit_type *xmc_common_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_attribute_spacetiming_struct)
fill each xmc_common_spacetiming_struct and xmc_attribute_spacetiming_struct member with its default ...
Definition: at32f435_437_xmc.c:360
xmc_nand_default_para_init
void xmc_nand_default_para_init(xmc_nand_init_type *xmc_nand_init_struct)
fill each xmc_nand_init_struct member with its default value.
Definition: at32f435_437_xmc.c:340
xmc_nand_timing_config
void xmc_nand_timing_config(xmc_nand_pccard_timinginit_type *xmc_common_spacetiming_struct, xmc_nand_pccard_timinginit_type *xmc_attribute_spacetiming_struct)
initialize the xmc nand banks according to the specified parameters in the xmc_nandinitstruct.
Definition: at32f435_437_xmc.c:305
xmc_nand_enable
void xmc_nand_enable(xmc_class_bank_type xmc_bank, confirm_state new_state)
enable or disable the specified nand memory bank.
Definition: at32f435_437_xmc.c:384
XMC_BANK2_NAND
@ XMC_BANK2_NAND
Definition: at32f435_437_xmc.h:157
XMC_BUSTYPE_8_BITS
@ XMC_BUSTYPE_8_BITS
Definition: at32f435_437_xmc.h:178
XMC_WAIT_OPERATION_DISABLE
@ XMC_WAIT_OPERATION_DISABLE
Definition: at32f435_437_xmc.h:128
XMC_ECC_PAGESIZE_8192_BYTES
@ XMC_ECC_PAGESIZE_8192_BYTES
Definition: at32f435_437_xmc.h:221
XMC_ECC_PAGESIZE_2048_BYTES
@ XMC_ECC_PAGESIZE_2048_BYTES
Definition: at32f435_437_xmc.h:219
XMC_ECC_OPERATION_DISABLE
@ XMC_ECC_OPERATION_DISABLE
Definition: at32f435_437_xmc.h:137
addr_2nd_cycle
#define addr_2nd_cycle(addr)
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:188
addr_3rd_cycle
#define addr_3rd_cycle(addr)
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:190
addr_4th_cycle
#define addr_4th_cycle(addr)
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:192
addr_1st_cycle
#define addr_1st_cycle(addr)
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:186
nand_read_small_page
uint32_t nand_read_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_read)
this routine is for sequential read from one or several 512 bytes page size.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:228
nand_read_id
void nand_read_id(nand_id_type *nand_id_struct)
reads nand memory's id.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:120
nand_init
void nand_init(void)
configures the xmc and gpios to interface with the nand memory. this function must be called before a...
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:44
nand_read_status
uint32_t nand_read_status(void)
reads the nand memory status using the read status command.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:471
nand_address_increment
uint32_t nand_address_increment(nand_address_type *address_struct)
increment the nand memory address.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:502
nand_reset
uint32_t nand_reset(void)
this routine reset the nand flash.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:426
nand_erase_block
uint32_t nand_erase_block(nand_address_type address_struct)
this routine erase complete block from nand flash
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:403
nand_read_spare_area
uint32_t nand_read_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_read)
this routine read the spare area information from the specified pages addresses.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:353
nand_write_small_page
uint32_t nand_write_small_page(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_page_to_write)
this routine is for writing one or several 512 bytes page size.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:161
nand_get_status
uint32_t nand_get_status(void)
get the nand operation status.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:441
nand_write_spare_area
uint32_t nand_write_spare_area(uint8_t *pbuffer, nand_address_type address_struct, uint32_t num_spare_area_to_write)
this routine write the spare area information for the specified pages addresses.
Definition: at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c:294
NAND_CMD_WRITE_TRUE1
#define NAND_CMD_WRITE_TRUE1
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:117
NAND_CMD_RESET
#define NAND_CMD_RESET
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:125
NAND_CMD_WRITE0
#define NAND_CMD_WRITE0
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:116
NAND_CMD_STATUS
#define NAND_CMD_STATUS
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:123
NAND_CMD_AREA_A
#define NAND_CMD_AREA_A
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:111
NAND_CMD_ERASE1
#define NAND_CMD_ERASE1
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:120
NAND_CMD_ERASE0
#define NAND_CMD_ERASE0
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:119
NAND_CMD_AREA_TRUE1
#define NAND_CMD_AREA_TRUE1
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:114
NAND_CMD_AREA_C
#define NAND_CMD_AREA_C
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:113
NAND_ERROR
#define NAND_ERROR
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:140
NAND_READY
#define NAND_READY
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:141
NAND_VALID_ADDRESS
#define NAND_VALID_ADDRESS
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:136
NAND_INVALID_ADDRESS
#define NAND_INVALID_ADDRESS
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:137
NAND_TIMEOUT_ERROR
#define NAND_TIMEOUT_ERROR
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:138
NAND_BUSY
#define NAND_BUSY
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:139
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
nand_address_type
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:63
nand_address_type::page
uint16_t page
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:66
nand_address_type::block
uint16_t block
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:65
nand_address_type::zone
uint16_t zone
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:64
nand_id_type
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:45
nand_id_type::sixth_id
uint8_t sixth_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:51
nand_id_type::device_id
uint8_t device_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:47
nand_id_type::fourth_id
uint8_t fourth_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:49
nand_id_type::fifth_id
uint8_t fifth_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:50
nand_id_type::third_id
uint8_t third_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:48
nand_id_type::maker_id
uint8_t maker_id
Definition: at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h:46
xmc_nand_init_type
xmc nand init structure definition
Definition: at32f435_437_xmc.h:443
xmc_nand_init_type::ecc_enable
xmc_ecc_enable_type ecc_enable
Definition: at32f435_437_xmc.h:447
xmc_nand_init_type::delay_time_cycle
uint32_t delay_time_cycle
Definition: at32f435_437_xmc.h:449
xmc_nand_init_type::nand_bank
xmc_class_bank_type nand_bank
Definition: at32f435_437_xmc.h:444
xmc_nand_init_type::wait_enable
xmc_nand_pccard_wait_type wait_enable
Definition: at32f435_437_xmc.h:445
xmc_nand_init_type::ecc_pagesize
xmc_ecc_pagesize_type ecc_pagesize
Definition: at32f435_437_xmc.h:448
xmc_nand_init_type::delay_time_ar
uint32_t delay_time_ar
Definition: at32f435_437_xmc.h:450
xmc_nand_init_type::bus_type
xmc_data_width_type bus_type
Definition: at32f435_437_xmc.h:446
xmc_nand_pccard_timinginit_type
nand and pccard timing parameters xmc
Definition: at32f435_437_xmc.h:430
xmc_nand_pccard_timinginit_type::class_bank
xmc_class_bank_type class_bank
Definition: at32f435_437_xmc.h:431
xmc_nand_pccard_timinginit_type::mem_waite_time
uint32_t mem_waite_time
Definition: at32f435_437_xmc.h:433
xmc_nand_pccard_timinginit_type::mem_hold_time
uint32_t mem_hold_time
Definition: at32f435_437_xmc.h:434
xmc_nand_pccard_timinginit_type::mem_hiz_time
uint32_t mem_hiz_time
Definition: at32f435_437_xmc.h:435
xmc_nand_pccard_timinginit_type::mem_setup_time
uint32_t mem_setup_time
Definition: at32f435_437_xmc.h:432


AT32F435/437 Firmwary Library: xmc_nor.h File Reference

  • at_start_f437
  • examples
  • xmc
  • nor_flash
  • inc
Data Structures | Enumerations | Functions
at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h File Reference
#include "at32f435_437_board.h"

Go to the source code of this file.

Data Structures

struct nor_idtype

Enumerations

enum nor_status {
NOR_SUCCESS = 0 , NOR_ONGOING , NOR_ERROR , NOR_TIMEOUT ,
NOR_SUCCESS = 0 , NOR_ONGOING , NOR_ERROR , NOR_TIMEOUT
}

Functions

void | nor_init (void)
init nor flash interface More...
void | nor_readid (nor_idtype *nor_id)
reads nor memory's manufacturer and device code. More...
nor_status | nor_eraseblock (uint32_t blockaddr)
erases the specified nor memory block. More...
nor_status | nor_erasechip (void)
erases the entire chip. More...
nor_status | nor_writehalfword (uint32_t writeaddr, uint16_t data)
writes a half-word to the nor memory. More...
nor_status | nor_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc nor memory. More...
nor_status | nor_programbuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc nor memory. this function must be used only with s29gl128p nor memory. More...
uint16_t | nor_readhalfword (uint32_t readaddr)
reads a half-word from the nor memory. More...
void | nor_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc nor memory. More...
nor_status | nor_returntoreadmode (void)
returns the nor memory to read mode. More...
nor_status | nor_reset (void)
returns the nor memory to read mode and resets the errors in the nor memory status register. More...
nor_status | nor_getstatus (uint32_t timeout)
returns the nor operation status. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...

Enumeration Type Documentation

◆ nor_status

enum nor_status
Enumerator
NOR_SUCCESS
NOR_ONGOING
NOR_ERROR
NOR_TIMEOUT
NOR_SUCCESS
NOR_ONGOING
NOR_ERROR
NOR_TIMEOUT

Definition at line 41 of file at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h.


AT32F435/437 Firmwary Library: xmc_nor.h Source File

  • at_start_f437
  • examples
  • xmc
  • nor_flash
  • inc
at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
Go to the documentation of this file.
1
27#ifndef __XMC_SRAM_H
28#define __XMC_SRAM_H
29
30#include "at32f435_437_board.h"
31
32typedef struct
33{
34 uint16_t manufacturer_code;
35 uint16_t device_code1;
36 uint16_t device_code2;
37 uint16_t device_code3;
38}nor_idtype;
39
40/* nor status */
41typedef enum
42{
43 NOR_SUCCESS = 0,
44 NOR_ONGOING,
45 NOR_ERROR,
46 NOR_TIMEOUT
47}nor_status;
48
49void nor_init(void);
50void nor_readid(nor_idtype* nor_id);
51 nor_status nor_eraseblock(uint32_t blockaddr);
52 nor_status nor_erasechip(void);
53 nor_status nor_writehalfword(uint32_t writeaddr, uint16_t data);
54 nor_status nor_writebuffer(uint16_t* pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite);
55 nor_status nor_programbuffer(uint16_t* pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite);
56uint16_t nor_readhalfword(uint32_t readaddr);
57void nor_readbuffer(uint16_t* pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread);
58 nor_status nor_returntoreadmode(void);
59 nor_status nor_reset(void);
60 nor_status nor_getstatus(uint32_t timeout);
61void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset);
62
63#endif
at32f435_437_board.h
nor_status
nor_status
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:42
nor_status
nor_status
Definition: at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h:42
NOR_TIMEOUT
@ NOR_TIMEOUT
Definition: at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h:46
NOR_SUCCESS
@ NOR_SUCCESS
Definition: at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h:43
NOR_ONGOING
@ NOR_ONGOING
Definition: at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h:44
NOR_ERROR
@ NOR_ERROR
Definition: at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h:45
nor_readhalfword
uint16_t nor_readhalfword(uint32_t readaddr)
reads a half-word from the nor memory.
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:389
nor_eraseblock
nor_status nor_eraseblock(uint32_t blockaddr)
erases the specified nor memory block.
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:266
nor_writebuffer
nor_status nor_writebuffer(uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc nor memory.
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:322
nor_readid
void nor_readid(nor_idtype *nor_id)
reads nor memory's manufacturer and device code.
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:248
nor_id
nor_idtype nor_id
Definition: project/at_start_f435/examples/xmc/nor_flash/src/main.c:45
nor_programbuffer
nor_status nor_programbuffer(uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc nor memory. this function must be used only with s29gl128p nor m...
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:349
nor_init
void nor_init(void)
init nor flash interface
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:51
nor_writehalfword
nor_status nor_writehalfword(uint32_t writeaddr, uint16_t data)
writes a half-word to the nor memory.
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:303
fill_buffer
void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:520
nor_getstatus
nor_status nor_getstatus(uint32_t timeout)
returns the nor operation status.
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:453
nor_returntoreadmode
nor_status nor_returntoreadmode(void)
returns the nor memory to read mode.
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:425
nor_readbuffer
void nor_readbuffer(uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc nor memory.
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:406
nor_reset
nor_status nor_reset(void)
returns the nor memory to read mode and resets the errors in the nor memory status register.
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:438
nor_erasechip
nor_status nor_erasechip(void)
erases the entire chip.
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:284
nor_idtype
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:33


AT32F435/437 Firmwary Library: xmc_nor.c File Reference

  • at_start_f437
  • examples
  • xmc
  • nor_flash
  • src
Macros | Functions
at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c File Reference
#include "xmc_nor.h"

Go to the source code of this file.

Macros

#define | BANK1_NOR2_ADDR ((uint32_t)0x64000000)
#define | BLOCKERASE_TIMEOUT ((uint32_t)0x00A00000)
#define | CHIPERASE_TIMEOUT ((uint32_t)0x30000000)
#define | PROGRAM_TIMEOUT ((uint32_t)0x00001400)
#define | ADDR_SHIFT(A) (BANK1_NOR2_ADDR + (2 * (A)))
#define | NOR_WRITE(address, data) (*(__IO uint16_t *)(address) = (data))

Functions

void | nor_init (void)
init nor flash interface More...
void | nor_readid (nor_idtype *nor_id)
reads nor memory's manufacturer and device code. More...
nor_status | nor_eraseblock (uint32_t blockaddr)
erases the specified nor memory block. More...
nor_status | nor_erasechip (void)
erases the entire chip. More...
nor_status | nor_writehalfword (uint32_t writeaddr, uint16_t data)
writes a half-word to the nor memory. More...
nor_status | nor_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc nor memory. More...
nor_status | nor_programbuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc nor memory. this function must be used only with s29gl128p nor memory. More...
uint16_t | nor_readhalfword (uint32_t readaddr)
reads a half-word from the nor memory. More...
void | nor_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc nor memory. More...
nor_status | nor_returntoreadmode (void)
returns the nor memory to read mode. More...
nor_status | nor_reset (void)
returns the nor memory to read mode and resets the errors in the nor memory status register. More...
nor_status | nor_getstatus (uint32_t timeout)
returns the nor operation status. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...


AT32F435/437 Firmwary Library: xmc_nor.c Source File

  • at_start_f437
  • examples
  • xmc
  • nor_flash
  • src
at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c
Go to the documentation of this file.
1
27#include "xmc_nor.h"
28
37#define BANK1_NOR2_ADDR ((uint32_t)0x64000000)
38
39/* delay definition */
40#define BLOCKERASE_TIMEOUT ((uint32_t)0x00A00000)
41#define CHIPERASE_TIMEOUT ((uint32_t)0x30000000)
42#define PROGRAM_TIMEOUT ((uint32_t)0x00001400)
43
44#define ADDR_SHIFT(A) (BANK1_NOR2_ADDR + (2 * (A)))
45#define NOR_WRITE(address, data) (*(__IO uint16_t *)(address) = (data))
51void nor_init(void)
52{
53 gpio_init_type gpio_init_struct = {0};
54 xmc_norsram_init_type xmc_norsram_init_struct;
55 xmc_norsram_timing_init_type rw_timing_struct, w_timing_struct;
56
57 /* enable the gpio clock */
58 crm_periph_clock_enable(CRM_GPIOF_PERIPH_CLOCK, TRUE);
59 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
60 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
61 crm_periph_clock_enable(CRM_GPIOG_PERIPH_CLOCK, TRUE);
62 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
63
64 /* enable the xmc clock */
65 crm_periph_clock_enable(CRM_XMC_PERIPH_CLOCK, TRUE);
66
67 /*-- gpio configuration ------------------------------------------------------*/
68 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE0, GPIO_MUX_12);
69 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE1, GPIO_MUX_12);
70 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE2, GPIO_MUX_12);
71 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE3, GPIO_MUX_12);
72 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE4, GPIO_MUX_12);
73 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE5, GPIO_MUX_12);
74 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE12, GPIO_MUX_12);
75 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE13, GPIO_MUX_12);
76 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE14, GPIO_MUX_12);
77 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE15, GPIO_MUX_12);
78 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE0, GPIO_MUX_12);
79 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE1, GPIO_MUX_12);
80 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE2, GPIO_MUX_12);
81 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE3, GPIO_MUX_12);
82 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE4, GPIO_MUX_12);
83 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE5, GPIO_MUX_12);
84 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE13, GPIO_MUX_12);
85 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE14, GPIO_MUX_12);
86 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE9, GPIO_MUX_12);
87 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE11, GPIO_MUX_12);
88 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE12, GPIO_MUX_12);
89 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE13, GPIO_MUX_12);
90 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE0, GPIO_MUX_12);
91 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_12);
92 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE8, GPIO_MUX_12);
93 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE9, GPIO_MUX_12);
94 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE10, GPIO_MUX_12);
95 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE14, GPIO_MUX_12);
96 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE15, GPIO_MUX_12);
97 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_12);
98 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE5, GPIO_MUX_12);
99 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE6, GPIO_MUX_12);
100 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE3, GPIO_MUX_12);
101 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE4, GPIO_MUX_12);
102 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE5, GPIO_MUX_12);
103 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE6, GPIO_MUX_12);
104 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE2, GPIO_MUX_12);
105 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE13, GPIO_MUX_12);
106 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE7, GPIO_MUX_12);
107 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE8, GPIO_MUX_12);
108 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE9, GPIO_MUX_12);
109 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE10, GPIO_MUX_12);
110 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE11, GPIO_MUX_12);
111 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE12, GPIO_MUX_12);
112 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE14, GPIO_MUX_12);
113 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE15, GPIO_MUX_12);
114 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE0, GPIO_MUX_12);
115 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE1, GPIO_MUX_12);
116 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE7, GPIO_MUX_12);
117
118 /* address lines configuration */
119 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_2 | GPIO_PINS_3 | GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_12 | GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
120 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
121 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
122 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
123 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
124 gpio_init(GPIOF, &gpio_init_struct);
125
126 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_2 | GPIO_PINS_3 | GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_13 | GPIO_PINS_14;
127 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
128 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
129 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
130 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
131 gpio_init(GPIOG, &gpio_init_struct);
132
133 gpio_init_struct.gpio_pins = GPIO_PINS_11 | GPIO_PINS_12 | GPIO_PINS_13;
134 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
135 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
136 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
137 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
138 gpio_init(GPIOD, &gpio_init_struct);
139
140 gpio_init_struct.gpio_pins = GPIO_PINS_3 | GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6 | GPIO_PINS_2;
141 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
142 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
143 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
144 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
145 gpio_init(GPIOE, &gpio_init_struct);
146
147 /* data lines configuration */
148 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_14 | GPIO_PINS_15;
149 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
150 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
151 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
152 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
153 gpio_init(GPIOD, &gpio_init_struct);
154
155 gpio_init_struct.gpio_pins = GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11 | GPIO_PINS_12 | GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
156 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
157 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
158 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
159 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
160 gpio_init(GPIOE, &gpio_init_struct);
161
162 /* ne/noe/nwe/nbl0/nbl1/nwait lines configuration */
163 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
164 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
165 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
166 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
167 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
168 gpio_init(GPIOE, &gpio_init_struct);
169
170 gpio_init_struct.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5;
171 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
172 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
173 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
174 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
175 gpio_init(GPIOD, &gpio_init_struct);
176
177 gpio_init_struct.gpio_pins = GPIO_PINS_9;
178 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
179 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
180 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
181 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
182 gpio_init(GPIOG, &gpio_init_struct);
183
184 gpio_init_struct.gpio_pins = GPIO_PINS_6;
185 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
186 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
187 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
188 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
189 gpio_init(GPIOD, &gpio_init_struct);
190
191 gpio_init_struct.gpio_pins = GPIO_PINS_7;
192 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
193 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
194 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
195 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
196 gpio_init(GPIOB, &gpio_init_struct);
197
198
199 /*-- xmc configuration ------------------------------------------------------*/
200 xmc_norsram_default_para_init(&xmc_norsram_init_struct);
201 xmc_norsram_init_struct.subbank = XMC_BANK1_NOR_SRAM2;
202 xmc_norsram_init_struct.data_addr_multiplex = XMC_DATA_ADDR_MUX_DISABLE;
203 xmc_norsram_init_struct.device = XMC_DEVICE_NOR;
204 xmc_norsram_init_struct.bus_type = XMC_BUSTYPE_16_BITS;
205 xmc_norsram_init_struct.burst_mode_enable = XMC_BURST_MODE_DISABLE;
206 xmc_norsram_init_struct.asynwait_enable = XMC_ASYN_WAIT_DISABLE;
207 xmc_norsram_init_struct.wait_signal_lv = XMC_WAIT_SIGNAL_LEVEL_LOW;
208 xmc_norsram_init_struct.wrapped_mode_enable = XMC_WRAPPED_MODE_DISABLE;
209 xmc_norsram_init_struct.wait_signal_config = XMC_WAIT_SIGNAL_SYN_BEFORE;
210 xmc_norsram_init_struct.write_enable = XMC_WRITE_OPERATION_ENABLE;
211 xmc_norsram_init_struct.wait_signal_enable = XMC_WAIT_SIGNAL_DISABLE;
212 xmc_norsram_init_struct.write_timing_enable = XMC_WRITE_TIMING_DISABLE;
213 xmc_norsram_init_struct.write_burst_syn = XMC_WRITE_BURST_SYN_DISABLE;
214 xmc_nor_sram_init(&xmc_norsram_init_struct);
215
216 /* timing configuration */
217 xmc_norsram_timing_default_para_init(&rw_timing_struct, &w_timing_struct);
218 rw_timing_struct.subbank = XMC_BANK1_NOR_SRAM2;
219 rw_timing_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
220 rw_timing_struct.addr_setup_time = 0x8;
221 rw_timing_struct.addr_hold_time = 0x0;
222 rw_timing_struct.data_setup_time = 0x10;
223 rw_timing_struct.bus_latency_time = 0x0;
224 rw_timing_struct.clk_psc = 0x0;
225 rw_timing_struct.data_latency_time = 0x0;
226 rw_timing_struct.mode = XMC_ACCESS_MODE_B;
227 w_timing_struct.subbank = XMC_BANK1_NOR_SRAM2;
228 w_timing_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
229 w_timing_struct.addr_setup_time = 0x8;
230 w_timing_struct.addr_hold_time = 0x0;
231 w_timing_struct.data_setup_time = 0x10;
232 w_timing_struct.bus_latency_time = 0x0;
233 w_timing_struct.clk_psc = 0x0;
234 w_timing_struct.data_latency_time = 0x0;
235 w_timing_struct.mode = XMC_ACCESS_MODE_B;
236 xmc_nor_sram_timing_config(&rw_timing_struct, &w_timing_struct);
237
238 /* enable xmc_bank1_nor_sram2 */
239 xmc_nor_sram_enable(XMC_BANK1_NOR_SRAM2, TRUE);
240}
241
248void nor_readid(nor_idtype* nor_id)
249{
250 NOR_WRITE(ADDR_SHIFT(0x0555), 0x00AA);
251 NOR_WRITE(ADDR_SHIFT(0x02AA), 0x0055);
252 NOR_WRITE(ADDR_SHIFT(0x0555), 0x0090);
253
254 nor_id->manufacturer_code = *(__IO uint16_t *) ADDR_SHIFT(0x0000);
255 nor_id->device_code1 = *(__IO uint16_t *) ADDR_SHIFT(0x0001);
256 nor_id->device_code2 = *(__IO uint16_t *) ADDR_SHIFT(0x000E);
257 nor_id->device_code3 = *(__IO uint16_t *) ADDR_SHIFT(0x000F);
258}
259
266 nor_status nor_eraseblock(uint32_t blockaddr)
267{
268 NOR_WRITE(ADDR_SHIFT(0x0555), 0x00AA);
269 NOR_WRITE(ADDR_SHIFT(0x02AA), 0x0055);
270 NOR_WRITE(ADDR_SHIFT(0x0555), 0x0080);
271 NOR_WRITE(ADDR_SHIFT(0x0555), 0x00AA);
272 NOR_WRITE(ADDR_SHIFT(0x02AA), 0x0055);
273 NOR_WRITE((BANK1_NOR2_ADDR + blockaddr), 0x30);
274
275 return (nor_getstatus(BLOCKERASE_TIMEOUT));
276}
277
284 nor_status nor_erasechip(void)
285{
286 NOR_WRITE(ADDR_SHIFT(0x0555), 0x00AA);
287 NOR_WRITE(ADDR_SHIFT(0x02AA), 0x0055);
288 NOR_WRITE(ADDR_SHIFT(0x0555), 0x0080);
289 NOR_WRITE(ADDR_SHIFT(0x0555), 0x00AA);
290 NOR_WRITE(ADDR_SHIFT(0x02AA), 0x0055);
291 NOR_WRITE(ADDR_SHIFT(0x0555), 0x0010);
292
293 return (nor_getstatus(CHIPERASE_TIMEOUT));
294}
295
303 nor_status nor_writehalfword(uint32_t writeaddr, uint16_t data)
304{
305 NOR_WRITE(ADDR_SHIFT(0x0555), 0x00AA);
306 NOR_WRITE(ADDR_SHIFT(0x02AA), 0x0055);
307 NOR_WRITE(ADDR_SHIFT(0x0555), 0x00A0);
308 NOR_WRITE((BANK1_NOR2_ADDR + writeaddr), data);
309
310 return (nor_getstatus(PROGRAM_TIMEOUT));
311}
312
322 nor_status nor_writebuffer(uint16_t* pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
323{
324 nor_status status = NOR_ONGOING;
325
326 do
327 {
329 status = nor_writehalfword(writeaddr, *pbuffer++);
330 writeaddr = writeaddr + 2;
331 numhalfwordtowrite--;
332 }
333 while((status == NOR_SUCCESS) && (numhalfwordtowrite != 0));
334
335 return (status);
336}
337
349 nor_status nor_programbuffer(uint16_t* pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
350{
351 uint32_t lastloadedaddress = 0x00;
352 uint32_t currentaddress = 0x00;
353 uint32_t endaddress = 0x00;
354
356 currentaddress = writeaddr;
357 endaddress = writeaddr + numhalfwordtowrite - 1;
358 lastloadedaddress = writeaddr;
359
361 NOR_WRITE(ADDR_SHIFT(0x00555), 0x00AA);
362
363 NOR_WRITE(ADDR_SHIFT(0x02AA), 0x0055);
364
366 NOR_WRITE(ADDR_SHIFT(writeaddr), 0x0025);
367 NOR_WRITE(ADDR_SHIFT(writeaddr), (numhalfwordtowrite - 1));
368
370 while(currentaddress <= endaddress)
371 {
373 lastloadedaddress = currentaddress;
374
375 NOR_WRITE(ADDR_SHIFT(currentaddress), *pbuffer++);
376 currentaddress += 1;
377 }
378
379 NOR_WRITE(ADDR_SHIFT(lastloadedaddress), 0x29);
380
381 return(nor_getstatus(PROGRAM_TIMEOUT));
382}
383
389uint16_t nor_readhalfword(uint32_t readaddr)
390{
391 NOR_WRITE(ADDR_SHIFT(0x00555), 0x00AA);
392 NOR_WRITE(ADDR_SHIFT(0x002AA), 0x0055);
393 NOR_WRITE((BANK1_NOR2_ADDR + readaddr), 0x00F0 );
394
395 return (*(__IO uint16_t *)((BANK1_NOR2_ADDR + readaddr)));
396}
397
406void nor_readbuffer(uint16_t* pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
407{
408 NOR_WRITE(ADDR_SHIFT(0x0555), 0x00AA);
409 NOR_WRITE(ADDR_SHIFT(0x02AA), 0x0055);
410 NOR_WRITE((BANK1_NOR2_ADDR + readaddr), 0x00F0);
411
412 for(; numhalfwordtoread != 0x00; numhalfwordtoread--)
413 {
415 *pbuffer++ = *(__IO uint16_t *)((BANK1_NOR2_ADDR + readaddr));
416 readaddr = readaddr + 2;
417 }
418}
419
425 nor_status nor_returntoreadmode(void)
426{
427 NOR_WRITE(BANK1_NOR2_ADDR, 0x00F0);
428
429 return (NOR_SUCCESS);
430}
431
438 nor_status nor_reset(void)
439{
440 NOR_WRITE(ADDR_SHIFT(0x00555), 0x00AA);
441 NOR_WRITE(ADDR_SHIFT(0x002AA), 0x0055);
442 NOR_WRITE(BANK1_NOR2_ADDR, 0x00F0);
443
444 return (NOR_SUCCESS);
445}
446
453 nor_status nor_getstatus(uint32_t timeout)
454{
455 uint16_t val1 = 0x00, val2 = 0x00;
456 nor_status status = NOR_ONGOING;
457 uint32_t timeout1 = timeout;
458
460 while((gpio_input_data_bit_read(GPIOD, GPIO_PINS_6) != RESET) && (timeout1 > 0))
461 {
462 timeout1--;
463 }
464
465 timeout1 = timeout;
466
467 while((gpio_input_data_bit_read(GPIOD, GPIO_PINS_6) == RESET) && (timeout1 > 0))
468 {
469 timeout1--;
470 }
471
473 while((timeout != 0x00) && (status != NOR_SUCCESS))
474 {
475 timeout--;
476
478 val1 = *(__IO uint16_t *)(BANK1_NOR2_ADDR);
479 val2 = *(__IO uint16_t *)(BANK1_NOR2_ADDR);
480
482 if((val1 & 0x0040) == (val2 & 0x0040))
483 {
484 return NOR_SUCCESS;
485 }
486
487 if((val1 & 0x0020) != 0x0020)
488 {
489 status = NOR_ONGOING;
490 }
491
492 val1 = *(__IO uint16_t *)(BANK1_NOR2_ADDR);
493 val2 = *(__IO uint16_t *)(BANK1_NOR2_ADDR);
494
495 if((val1 & 0x0040) == (val2 & 0x0040))
496 {
497 return NOR_SUCCESS;
498 }
499 else if((val1 & 0x0020) == 0x0020)
500 {
501 return NOR_ERROR;
502 }
503 }
504
505 if(timeout == 0x00)
506 {
507 status = NOR_TIMEOUT;
508 }
509
511 return (status);
512}
513
520void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
521{
522 uint16_t indextmp = 0;
523
524 /* put in global buffer same values */
525 for (indextmp = 0; indextmp < bufferlenght; indextmp++ )
526 {
527 pbuffer[indextmp] = indextmp + offset;
528 }
529}
530
nor_status
nor_status
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:42
NOR_TIMEOUT
@ NOR_TIMEOUT
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:46
NOR_SUCCESS
@ NOR_SUCCESS
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:43
NOR_ONGOING
@ NOR_ONGOING
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:44
NOR_ERROR
@ NOR_ERROR
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:45
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
fill_buffer
void fill_buffer(uint8_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
Fill the global buffer.
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:55
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
nor_readhalfword
uint16_t nor_readhalfword(uint32_t readaddr)
reads a half-word from the nor memory.
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:389
NOR_WRITE
#define NOR_WRITE(address, data)
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:45
nor_eraseblock
nor_status nor_eraseblock(uint32_t blockaddr)
erases the specified nor memory block.
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:266
nor_writebuffer
nor_status nor_writebuffer(uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc nor memory.
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:322
ADDR_SHIFT
#define ADDR_SHIFT(A)
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:44
nor_readid
void nor_readid(nor_idtype *nor_id)
reads nor memory's manufacturer and device code.
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:248
nor_id
nor_idtype nor_id
Definition: project/at_start_f435/examples/xmc/nor_flash/src/main.c:45
nor_programbuffer
nor_status nor_programbuffer(uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc nor memory. this function must be used only with s29gl128p nor m...
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:349
nor_init
void nor_init(void)
init nor flash interface
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:51
nor_writehalfword
nor_status nor_writehalfword(uint32_t writeaddr, uint16_t data)
writes a half-word to the nor memory.
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:303
CHIPERASE_TIMEOUT
#define CHIPERASE_TIMEOUT
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:41
BANK1_NOR2_ADDR
#define BANK1_NOR2_ADDR
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:37
PROGRAM_TIMEOUT
#define PROGRAM_TIMEOUT
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:42
nor_getstatus
nor_status nor_getstatus(uint32_t timeout)
returns the nor operation status.
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:453
nor_returntoreadmode
nor_status nor_returntoreadmode(void)
returns the nor memory to read mode.
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:425
nor_readbuffer
void nor_readbuffer(uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc nor memory.
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:406
BLOCKERASE_TIMEOUT
#define BLOCKERASE_TIMEOUT
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:40
nor_reset
nor_status nor_reset(void)
returns the nor memory to read mode and resets the errors in the nor memory status register.
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:438
nor_erasechip
nor_status nor_erasechip(void)
erases the entire chip.
Definition: at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c:284
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_XMC_PERIPH_CLOCK
@ CRM_XMC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:123
CRM_GPIOF_PERIPH_CLOCK
@ CRM_GPIOF_PERIPH_CLOCK
Definition: at32f435_437_crm.h:110
CRM_GPIOG_PERIPH_CLOCK
@ CRM_GPIOG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:111
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_input_data_bit_read
flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified input port pin.
Definition: at32f435_437_gpio.c:170
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f435_437_gpio.h:146
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f435_437_gpio.h:64
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOG
#define GPIOG
Definition: at32f435_437_gpio.h:527
GPIOF
#define GPIOF
Definition: at32f435_437_gpio.h:526
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
xmc_nor_sram_init
void xmc_nor_sram_init(xmc_norsram_init_type *xmc_norsram_init_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_norsraminitstruct.
Definition: at32f435_437_xmc.c:78
xmc_norsram_timing_default_para_init
void xmc_norsram_timing_default_para_init(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
fill each xmc_rw_timing_struct and xmc_w_timing_struct member with its default value.
Definition: at32f435_437_xmc.c:176
xmc_nor_sram_timing_config
void xmc_nor_sram_timing_config(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_rw_timing_struct a...
Definition: at32f435_437_xmc.c:113
xmc_norsram_default_para_init
void xmc_norsram_default_para_init(xmc_norsram_init_type *xmc_nor_sram_init_struct)
fill each xmc_nor_sram_init_struct member with its default value.
Definition: at32f435_437_xmc.c:150
xmc_nor_sram_enable
void xmc_nor_sram_enable(xmc_nor_sram_subbank_type xmc_subbank, confirm_state new_state)
enable or disable the specified nor/sram memory bank.
Definition: at32f435_437_xmc.c:210
XMC_WAIT_SIGNAL_DISABLE
@ XMC_WAIT_SIGNAL_DISABLE
Definition: at32f435_437_xmc.h:101
XMC_WAIT_SIGNAL_SYN_BEFORE
@ XMC_WAIT_SIGNAL_SYN_BEFORE
Definition: at32f435_437_xmc.h:196
XMC_WRITE_OPERATION_ENABLE
@ XMC_WRITE_OPERATION_ENABLE
Definition: at32f435_437_xmc.h:93
XMC_WRITE_BURST_SYN_DISABLE
@ XMC_WRITE_BURST_SYN_DISABLE
Definition: at32f435_437_xmc.h:110
XMC_BURST_MODE_DISABLE
@ XMC_BURST_MODE_DISABLE
Definition: at32f435_437_xmc.h:65
XMC_DATA_ADDR_MUX_DISABLE
@ XMC_DATA_ADDR_MUX_DISABLE
Definition: at32f435_437_xmc.h:56
XMC_BUSTYPE_16_BITS
@ XMC_BUSTYPE_16_BITS
Definition: at32f435_437_xmc.h:179
XMC_WRITE_TIMING_ENABLE
@ XMC_WRITE_TIMING_ENABLE
Definition: at32f435_437_xmc.h:120
XMC_WRITE_TIMING_DISABLE
@ XMC_WRITE_TIMING_DISABLE
Definition: at32f435_437_xmc.h:119
XMC_BANK1_NOR_SRAM2
@ XMC_BANK1_NOR_SRAM2
Definition: at32f435_437_xmc.h:147
XMC_ASYN_WAIT_DISABLE
@ XMC_ASYN_WAIT_DISABLE
Definition: at32f435_437_xmc.h:74
XMC_WRAPPED_MODE_DISABLE
@ XMC_WRAPPED_MODE_DISABLE
Definition: at32f435_437_xmc.h:83
XMC_ACCESS_MODE_B
@ XMC_ACCESS_MODE_B
Definition: at32f435_437_xmc.h:206
XMC_WAIT_SIGNAL_LEVEL_LOW
@ XMC_WAIT_SIGNAL_LEVEL_LOW
Definition: at32f435_437_xmc.h:187
XMC_DEVICE_NOR
@ XMC_DEVICE_NOR
Definition: at32f435_437_xmc.h:170
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
nor_idtype
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:33
nor_idtype::manufacturer_code
uint16_t manufacturer_code
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:34
nor_idtype::device_code1
uint16_t device_code1
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:35
nor_idtype::device_code3
uint16_t device_code3
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:37
nor_idtype::device_code2
uint16_t device_code2
Definition: at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h:36
xmc_norsram_init_type
xmc nor/sram init structure definition
Definition: at32f435_437_xmc.h:409
xmc_norsram_init_type::wait_signal_enable
xmc_wait_signal_type wait_signal_enable
Definition: at32f435_437_xmc.h:420
xmc_norsram_init_type::data_addr_multiplex
xmc_data_addr_mux_type data_addr_multiplex
Definition: at32f435_437_xmc.h:411
xmc_norsram_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:421
xmc_norsram_init_type::burst_mode_enable
xmc_burst_access_mode_type burst_mode_enable
Definition: at32f435_437_xmc.h:414
xmc_norsram_init_type::bus_type
xmc_data_width_type bus_type
Definition: at32f435_437_xmc.h:413
xmc_norsram_init_type::device
xmc_memory_type device
Definition: at32f435_437_xmc.h:412
xmc_norsram_init_type::wait_signal_lv
xmc_wait_signal_polarity_type wait_signal_lv
Definition: at32f435_437_xmc.h:416
xmc_norsram_init_type::wrapped_mode_enable
xmc_wrap_mode_type wrapped_mode_enable
Definition: at32f435_437_xmc.h:417
xmc_norsram_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:410
xmc_norsram_init_type::write_burst_syn
xmc_write_burst_type write_burst_syn
Definition: at32f435_437_xmc.h:422
xmc_norsram_init_type::asynwait_enable
xmc_asyn_wait_type asynwait_enable
Definition: at32f435_437_xmc.h:415
xmc_norsram_init_type::wait_signal_config
xmc_wait_timing_type wait_signal_config
Definition: at32f435_437_xmc.h:418
xmc_norsram_init_type::write_enable
xmc_write_operation_type write_enable
Definition: at32f435_437_xmc.h:419
xmc_norsram_timing_init_type
nor/sram banks timing parameters
Definition: at32f435_437_xmc.h:393
xmc_norsram_timing_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:395
xmc_norsram_timing_init_type::data_latency_time
uint32_t data_latency_time
Definition: at32f435_437_xmc.h:401
xmc_norsram_timing_init_type::addr_hold_time
uint32_t addr_hold_time
Definition: at32f435_437_xmc.h:397
xmc_norsram_timing_init_type::bus_latency_time
uint32_t bus_latency_time
Definition: at32f435_437_xmc.h:399
xmc_norsram_timing_init_type::addr_setup_time
uint32_t addr_setup_time
Definition: at32f435_437_xmc.h:396
xmc_norsram_timing_init_type::mode
xmc_access_mode_type mode
Definition: at32f435_437_xmc.h:402
xmc_norsram_timing_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:394
xmc_norsram_timing_init_type::clk_psc
uint32_t clk_psc
Definition: at32f435_437_xmc.h:400
xmc_norsram_timing_init_type::data_setup_time
uint32_t data_setup_time
Definition: at32f435_437_xmc.h:398


AT32F435/437 Firmwary Library: xmc_psram.h File Reference

  • at_start_f437
  • examples
  • xmc
  • psram
  • inc
Functions
at_start_f437/examples/xmc/psram/inc/xmc_psram.h File Reference
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void | psram_init (void)
init psram interface More...
void | psram_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc psram memory. More...
void | psram_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc psram memory. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...


AT32F435/437 Firmwary Library: xmc_psram.h Source File

  • at_start_f437
  • examples
  • xmc
  • psram
  • inc
at_start_f437/examples/xmc/psram/inc/xmc_psram.h
Go to the documentation of this file.
1
27#ifndef __XMC_SRAM_H
28#define __XMC_SRAM_H
29
30#include "at32f435_437_board.h"
31
32void psram_init(void);
33void psram_writebuffer(uint16_t* pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite);
34void psram_readbuffer(uint16_t* pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread);
35void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset);
36
37#endif
at32f435_437_board.h
fill_buffer
void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:520
psram_init
void psram_init(void)
init psram interface
Definition: at_start_f435/examples/xmc/psram/src/xmc_psram.c:44
psram_readbuffer
void psram_readbuffer(uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc psram memory.
Definition: at_start_f435/examples/xmc/psram/src/xmc_psram.c:235
psram_writebuffer
void psram_writebuffer(uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc psram memory.
Definition: at_start_f435/examples/xmc/psram/src/xmc_psram.c:215


AT32F435/437 Firmwary Library: xmc_psram.c File Reference

  • at_start_f437
  • examples
  • xmc
  • psram
  • src
Macros | Functions
at_start_f437/examples/xmc/psram/src/xmc_psram.c File Reference

xmc_psram program More...

#include "xmc_psram.h"

Go to the source code of this file.

Macros

#define BANK1_SRAM3_ADDR (uint32_t)0x68000000

Functions

void | psram_init (void)
init psram interface More...
void | psram_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc psram memory. More...
void | psram_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc psram memory. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...

Detailed Description

xmc_psram program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/xmc/psram/src/xmc_psram.c.


AT32F435/437 Firmwary Library: xmc_psram.c Source File

  • at_start_f437
  • examples
  • xmc
  • psram
  • src
at_start_f437/examples/xmc/psram/src/xmc_psram.c
Go to the documentation of this file.
1
27#include "xmc_psram.h"
28
37#define BANK1_SRAM3_ADDR (uint32_t)0x68000000
38
44void psram_init(void)
45{
46 gpio_init_type gpio_init_struct = {0};
47 xmc_norsram_init_type xmc_norsram_init_struct;
48 xmc_norsram_timing_init_type rw_timing_struct, w_timing_struct;
49
50 /* enable the gpio clock */
51 crm_periph_clock_enable(CRM_GPIOF_PERIPH_CLOCK, TRUE);
52 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
53 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
54 crm_periph_clock_enable(CRM_GPIOG_PERIPH_CLOCK, TRUE);
55 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
56
57 /* enable the xmc clock */
58 crm_periph_clock_enable(CRM_XMC_PERIPH_CLOCK, TRUE);
59
60 /*-- gpio configuration ------------------------------------------------------*/
61 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE13, GPIO_MUX_12);
62 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE14, GPIO_MUX_12);
63 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE10, GPIO_MUX_12);
64 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE11, GPIO_MUX_12);
65 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE12, GPIO_MUX_12);
66 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE13, GPIO_MUX_12);
67 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE0, GPIO_MUX_12);
68 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_12);
69 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE8, GPIO_MUX_12);
70 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE9, GPIO_MUX_12);
71 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE10, GPIO_MUX_12);
72 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE14, GPIO_MUX_12);
73 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE15, GPIO_MUX_12);
74 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_12);
75 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE5, GPIO_MUX_12);
76 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE3, GPIO_MUX_12);
77 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE4, GPIO_MUX_12);
78 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE5, GPIO_MUX_12);
79 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE6, GPIO_MUX_12);
80 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE2, GPIO_MUX_12);
81 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE13, GPIO_MUX_12);
82 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE7, GPIO_MUX_12);
83 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE8, GPIO_MUX_12);
84 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE9, GPIO_MUX_12);
85 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE10, GPIO_MUX_12);
86 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE11, GPIO_MUX_12);
87 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE12, GPIO_MUX_12);
88 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE14, GPIO_MUX_12);
89 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE15, GPIO_MUX_12);
90 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE0, GPIO_MUX_12);
91 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE1, GPIO_MUX_12);
92 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE7, GPIO_MUX_12);
93
94 /* address lines configuration */
95 gpio_init_struct.gpio_pins = GPIO_PINS_13 | GPIO_PINS_14;
96 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
97 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
98 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
99 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
100 gpio_init(GPIOG, &gpio_init_struct);
101
102 gpio_init_struct.gpio_pins = GPIO_PINS_11 | GPIO_PINS_12 | GPIO_PINS_13;
103 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
104 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
105 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
106 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
107 gpio_init(GPIOD, &gpio_init_struct);
108
109 gpio_init_struct.gpio_pins = GPIO_PINS_3 | GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6 | GPIO_PINS_2;
110 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
111 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
112 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
113 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
114 gpio_init(GPIOE, &gpio_init_struct);
115
116 /* data lines configuration */
117 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_14 | GPIO_PINS_15;
118 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
119 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
120 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
121 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
122 gpio_init(GPIOD, &gpio_init_struct);
123
124 gpio_init_struct.gpio_pins = GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11 | GPIO_PINS_12 | GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
125 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
126 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
127 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
128 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
129 gpio_init(GPIOE, &gpio_init_struct);
130
131 /* ne/noe/nwe/nbl0/nbl1 lines configuration */
132 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
133 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
134 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
135 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
136 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
137 gpio_init(GPIOE, &gpio_init_struct);
138
139 gpio_init_struct.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5;
140 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
141 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
142 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
143 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
144 gpio_init(GPIOD, &gpio_init_struct);
145
146 gpio_init_struct.gpio_pins = GPIO_PINS_10;
147 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
148 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
149 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
150 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
151 gpio_init(GPIOG, &gpio_init_struct);
152
153 gpio_init_struct.gpio_pins = GPIO_PINS_7;
154 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
155 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
156 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
157 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
158 gpio_init(GPIOB, &gpio_init_struct);
159
160
161 /*-- xmc configuration ------------------------------------------------------*/
162 xmc_norsram_default_para_init(&xmc_norsram_init_struct);
163 xmc_norsram_init_struct.subbank = XMC_BANK1_NOR_SRAM3;
164 xmc_norsram_init_struct.data_addr_multiplex = XMC_DATA_ADDR_MUX_ENABLE;
165 xmc_norsram_init_struct.device = XMC_DEVICE_PSRAM;
166 xmc_norsram_init_struct.bus_type = XMC_BUSTYPE_16_BITS;
167 xmc_norsram_init_struct.burst_mode_enable = XMC_BURST_MODE_DISABLE;
168 xmc_norsram_init_struct.asynwait_enable = XMC_ASYN_WAIT_DISABLE;
169 xmc_norsram_init_struct.wait_signal_lv = XMC_WAIT_SIGNAL_LEVEL_LOW;
170 xmc_norsram_init_struct.wrapped_mode_enable = XMC_WRAPPED_MODE_DISABLE;
171 xmc_norsram_init_struct.wait_signal_config = XMC_WAIT_SIGNAL_SYN_BEFORE;
172 xmc_norsram_init_struct.write_enable = XMC_WRITE_OPERATION_ENABLE;
173 xmc_norsram_init_struct.wait_signal_enable = XMC_WAIT_SIGNAL_DISABLE;
174 xmc_norsram_init_struct.write_timing_enable = XMC_WRITE_TIMING_DISABLE;
175 xmc_norsram_init_struct.write_burst_syn = XMC_WRITE_BURST_SYN_DISABLE;
176 xmc_nor_sram_init(&xmc_norsram_init_struct);
177
178 /* timing configuration */
179 xmc_norsram_timing_default_para_init(&rw_timing_struct, &w_timing_struct);
180 rw_timing_struct.subbank = XMC_BANK1_NOR_SRAM3;
181 rw_timing_struct.write_timing_enable = XMC_WRITE_TIMING_DISABLE;
182 rw_timing_struct.addr_hold_time = 0x08;
183 rw_timing_struct.addr_setup_time = 0x09;
184 rw_timing_struct.data_setup_time = 0x0F;
185 rw_timing_struct.data_latency_time = 0x0;
186 rw_timing_struct.bus_latency_time = 0x0;
187 rw_timing_struct.clk_psc = 0x0;
188 rw_timing_struct.mode = XMC_ACCESS_MODE_A;
189 w_timing_struct.subbank = XMC_BANK1_NOR_SRAM3;
190 w_timing_struct.write_timing_enable = XMC_WRITE_TIMING_DISABLE;
191 w_timing_struct.addr_hold_time = 0x08;
192 w_timing_struct.addr_setup_time = 0x09;
193 w_timing_struct.data_setup_time = 0x0F;
194 w_timing_struct.data_latency_time = 0x0;
195 w_timing_struct.bus_latency_time = 0x0;
196 w_timing_struct.clk_psc = 0x0;
197 w_timing_struct.mode = XMC_ACCESS_MODE_A;
198 xmc_nor_sram_timing_config(&rw_timing_struct, &w_timing_struct);
199
200 /* bus turnaround phase for consecutive read duration and consecutive write duration */
201 xmc_ext_timing_config(XMC_BANK1_NOR_SRAM3, 0x08, 0x08);
202
203 /* enable xmc_bank1_nor_sram3 */
204 xmc_nor_sram_enable(XMC_BANK1_NOR_SRAM3, TRUE);
205}
206
215void psram_writebuffer(uint16_t* pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
216{
217 for(; numhalfwordtowrite != 0; numhalfwordtowrite--)
218 {
220 *(__IO uint16_t *) (BANK1_SRAM3_ADDR + writeaddr) = *pbuffer++;
221
223 writeaddr += 2;
224 }
225}
226
235void psram_readbuffer(uint16_t* pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
236{
237 for(; numhalfwordtoread != 0; numhalfwordtoread--)
238 {
240 *pbuffer++ = *(__IO uint16_t*) (BANK1_SRAM3_ADDR + readaddr);
241
243 readaddr += 2;
244 }
245}
246
253void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
254{
255 uint16_t indextmp = 0;
256
257 /* put in global buffer same values */
258 for (indextmp = 0; indextmp < bufferlenght; indextmp++ )
259 {
260 pbuffer[indextmp] = indextmp + offset;
261 }
262}
263
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
fill_buffer
void fill_buffer(uint8_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
Fill the global buffer.
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:55
psram_init
void psram_init(void)
init psram interface
Definition: at_start_f437/examples/xmc/psram/src/xmc_psram.c:44
BANK1_SRAM3_ADDR
#define BANK1_SRAM3_ADDR
Definition: at_start_f437/examples/xmc/psram/src/xmc_psram.c:37
psram_readbuffer
void psram_readbuffer(uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc psram memory.
Definition: at_start_f437/examples/xmc/psram/src/xmc_psram.c:235
psram_writebuffer
void psram_writebuffer(uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc psram memory.
Definition: at_start_f437/examples/xmc/psram/src/xmc_psram.c:215
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_XMC_PERIPH_CLOCK
@ CRM_XMC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:123
CRM_GPIOF_PERIPH_CLOCK
@ CRM_GPIOF_PERIPH_CLOCK
Definition: at32f435_437_crm.h:110
CRM_GPIOG_PERIPH_CLOCK
@ CRM_GPIOG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:111
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f435_437_gpio.h:146
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f435_437_gpio.h:64
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOG
#define GPIOG
Definition: at32f435_437_gpio.h:527
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
xmc_nor_sram_init
void xmc_nor_sram_init(xmc_norsram_init_type *xmc_norsram_init_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_norsraminitstruct.
Definition: at32f435_437_xmc.c:78
xmc_norsram_timing_default_para_init
void xmc_norsram_timing_default_para_init(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
fill each xmc_rw_timing_struct and xmc_w_timing_struct member with its default value.
Definition: at32f435_437_xmc.c:176
xmc_nor_sram_timing_config
void xmc_nor_sram_timing_config(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_rw_timing_struct a...
Definition: at32f435_437_xmc.c:113
xmc_ext_timing_config
void xmc_ext_timing_config(xmc_nor_sram_subbank_type xmc_sub_bank, uint16_t w2w_timing, uint16_t r2r_timing)
config the bus turnaround phase.
Definition: at32f435_437_xmc.c:227
xmc_norsram_default_para_init
void xmc_norsram_default_para_init(xmc_norsram_init_type *xmc_nor_sram_init_struct)
fill each xmc_nor_sram_init_struct member with its default value.
Definition: at32f435_437_xmc.c:150
xmc_nor_sram_enable
void xmc_nor_sram_enable(xmc_nor_sram_subbank_type xmc_subbank, confirm_state new_state)
enable or disable the specified nor/sram memory bank.
Definition: at32f435_437_xmc.c:210
XMC_WAIT_SIGNAL_DISABLE
@ XMC_WAIT_SIGNAL_DISABLE
Definition: at32f435_437_xmc.h:101
XMC_WAIT_SIGNAL_SYN_BEFORE
@ XMC_WAIT_SIGNAL_SYN_BEFORE
Definition: at32f435_437_xmc.h:196
XMC_WRITE_OPERATION_ENABLE
@ XMC_WRITE_OPERATION_ENABLE
Definition: at32f435_437_xmc.h:93
XMC_WRITE_BURST_SYN_DISABLE
@ XMC_WRITE_BURST_SYN_DISABLE
Definition: at32f435_437_xmc.h:110
XMC_BURST_MODE_DISABLE
@ XMC_BURST_MODE_DISABLE
Definition: at32f435_437_xmc.h:65
XMC_DATA_ADDR_MUX_ENABLE
@ XMC_DATA_ADDR_MUX_ENABLE
Definition: at32f435_437_xmc.h:57
XMC_BUSTYPE_16_BITS
@ XMC_BUSTYPE_16_BITS
Definition: at32f435_437_xmc.h:179
XMC_WRITE_TIMING_DISABLE
@ XMC_WRITE_TIMING_DISABLE
Definition: at32f435_437_xmc.h:119
XMC_BANK1_NOR_SRAM3
@ XMC_BANK1_NOR_SRAM3
Definition: at32f435_437_xmc.h:148
XMC_ASYN_WAIT_DISABLE
@ XMC_ASYN_WAIT_DISABLE
Definition: at32f435_437_xmc.h:74
XMC_WRAPPED_MODE_DISABLE
@ XMC_WRAPPED_MODE_DISABLE
Definition: at32f435_437_xmc.h:83
XMC_ACCESS_MODE_A
@ XMC_ACCESS_MODE_A
Definition: at32f435_437_xmc.h:205
XMC_WAIT_SIGNAL_LEVEL_LOW
@ XMC_WAIT_SIGNAL_LEVEL_LOW
Definition: at32f435_437_xmc.h:187
XMC_DEVICE_PSRAM
@ XMC_DEVICE_PSRAM
Definition: at32f435_437_xmc.h:169
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
xmc_norsram_init_type
xmc nor/sram init structure definition
Definition: at32f435_437_xmc.h:409
xmc_norsram_init_type::wait_signal_enable
xmc_wait_signal_type wait_signal_enable
Definition: at32f435_437_xmc.h:420
xmc_norsram_init_type::data_addr_multiplex
xmc_data_addr_mux_type data_addr_multiplex
Definition: at32f435_437_xmc.h:411
xmc_norsram_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:421
xmc_norsram_init_type::burst_mode_enable
xmc_burst_access_mode_type burst_mode_enable
Definition: at32f435_437_xmc.h:414
xmc_norsram_init_type::bus_type
xmc_data_width_type bus_type
Definition: at32f435_437_xmc.h:413
xmc_norsram_init_type::device
xmc_memory_type device
Definition: at32f435_437_xmc.h:412
xmc_norsram_init_type::wait_signal_lv
xmc_wait_signal_polarity_type wait_signal_lv
Definition: at32f435_437_xmc.h:416
xmc_norsram_init_type::wrapped_mode_enable
xmc_wrap_mode_type wrapped_mode_enable
Definition: at32f435_437_xmc.h:417
xmc_norsram_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:410
xmc_norsram_init_type::write_burst_syn
xmc_write_burst_type write_burst_syn
Definition: at32f435_437_xmc.h:422
xmc_norsram_init_type::asynwait_enable
xmc_asyn_wait_type asynwait_enable
Definition: at32f435_437_xmc.h:415
xmc_norsram_init_type::wait_signal_config
xmc_wait_timing_type wait_signal_config
Definition: at32f435_437_xmc.h:418
xmc_norsram_init_type::write_enable
xmc_write_operation_type write_enable
Definition: at32f435_437_xmc.h:419
xmc_norsram_timing_init_type
nor/sram banks timing parameters
Definition: at32f435_437_xmc.h:393
xmc_norsram_timing_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:395
xmc_norsram_timing_init_type::data_latency_time
uint32_t data_latency_time
Definition: at32f435_437_xmc.h:401
xmc_norsram_timing_init_type::addr_hold_time
uint32_t addr_hold_time
Definition: at32f435_437_xmc.h:397
xmc_norsram_timing_init_type::bus_latency_time
uint32_t bus_latency_time
Definition: at32f435_437_xmc.h:399
xmc_norsram_timing_init_type::addr_setup_time
uint32_t addr_setup_time
Definition: at32f435_437_xmc.h:396
xmc_norsram_timing_init_type::mode
xmc_access_mode_type mode
Definition: at32f435_437_xmc.h:402
xmc_norsram_timing_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:394
xmc_norsram_timing_init_type::clk_psc
uint32_t clk_psc
Definition: at32f435_437_xmc.h:400
xmc_norsram_timing_init_type::data_setup_time
uint32_t data_setup_time
Definition: at32f435_437_xmc.h:398


AT32F435/437 Firmwary Library: xmc_sdram.h File Reference

  • at_start_f437
  • examples
  • xmc
  • sdram_basic
  • inc
Macros | Functions
at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h File Reference

header file for the sdram configuration. More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | SDRAM_BURST_LEN_1 ((uint16_t)0x0000)
#define | SDRAM_BURST_LEN_2 ((uint16_t)0x0001)
#define | SDRAM_BURST_LEN_4 ((uint16_t)0x0002)
#define | SDRAM_BURST_LEN_8 ((uint16_t)0x0004)
#define | SDRAM_BURST_SEQUENTIAL ((uint16_t)0x0000)
#define | SDRAM_BURST_INTERLEAVED ((uint16_t)0x0008)
#define | SDRAM_CAS_LATENCY_1 ((uint16_t)0x0010)
#define | SDRAM_CAS_LATENCY_2 ((uint16_t)0x0020)
#define | SDRAM_CAS_LATENCY_3 ((uint16_t)0x0030)
#define | SDRAM_OPERATING_MODE_STANDARD ((uint16_t)0x0000)
#define | SDRAM_WR_BURST_PROGRAMMED ((uint16_t)0x0000)
#define | SDRAM_WR_BURST_SINGLE ((uint16_t)0x0200)

Functions

void | sdram_init (void)
init sdram interface More...
void | sdram_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the sdram memory. More...
void | sdram_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the sdram. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...

Detailed Description

header file for the sdram configuration.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h.

Macro Definition Documentation

◆ SDRAM_BURST_INTERLEAVED

#define SDRAM_BURST_INTERLEAVED ((uint16_t)0x0008)

Definition at line 37 of file at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h.

◆ SDRAM_BURST_LEN_1

#define SDRAM_BURST_LEN_1 ((uint16_t)0x0000)

Definition at line 32 of file at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h.

◆ SDRAM_BURST_LEN_2

#define SDRAM_BURST_LEN_2 ((uint16_t)0x0001)

Definition at line 33 of file at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h.

◆ SDRAM_BURST_LEN_4

#define SDRAM_BURST_LEN_4 ((uint16_t)0x0002)

Definition at line 34 of file at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h.

◆ SDRAM_BURST_LEN_8

#define SDRAM_BURST_LEN_8 ((uint16_t)0x0004)

Definition at line 35 of file at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h.

◆ SDRAM_BURST_SEQUENTIAL

#define SDRAM_BURST_SEQUENTIAL ((uint16_t)0x0000)

Definition at line 36 of file at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h.

◆ SDRAM_CAS_LATENCY_1

#define SDRAM_CAS_LATENCY_1 ((uint16_t)0x0010)

Definition at line 38 of file at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h.

◆ SDRAM_CAS_LATENCY_2

#define SDRAM_CAS_LATENCY_2 ((uint16_t)0x0020)

Definition at line 39 of file at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h.

◆ SDRAM_CAS_LATENCY_3

#define SDRAM_CAS_LATENCY_3 ((uint16_t)0x0030)

Definition at line 40 of file at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h.

◆ SDRAM_OPERATING_MODE_STANDARD

#define SDRAM_OPERATING_MODE_STANDARD ((uint16_t)0x0000)

Definition at line 41 of file at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h.

◆ SDRAM_WR_BURST_PROGRAMMED

#define SDRAM_WR_BURST_PROGRAMMED ((uint16_t)0x0000)

Definition at line 42 of file at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h.

◆ SDRAM_WR_BURST_SINGLE

#define SDRAM_WR_BURST_SINGLE ((uint16_t)0x0200)

Definition at line 43 of file at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h.


AT32F435/437 Firmwary Library: xmc_sdram.h Source File

  • at_start_f437
  • examples
  • xmc
  • sdram_basic
  • inc
at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h
Go to the documentation of this file.
1
27#ifndef __XMC_SDRAM_H
28#define __XMC_SDRAM_H
29
30#include "at32f435_437_board.h"
31
32#define SDRAM_BURST_LEN_1 ((uint16_t)0x0000)
33#define SDRAM_BURST_LEN_2 ((uint16_t)0x0001)
34#define SDRAM_BURST_LEN_4 ((uint16_t)0x0002)
35#define SDRAM_BURST_LEN_8 ((uint16_t)0x0004)
36#define SDRAM_BURST_SEQUENTIAL ((uint16_t)0x0000)
37#define SDRAM_BURST_INTERLEAVED ((uint16_t)0x0008)
38#define SDRAM_CAS_LATENCY_1 ((uint16_t)0x0010)
39#define SDRAM_CAS_LATENCY_2 ((uint16_t)0x0020)
40#define SDRAM_CAS_LATENCY_3 ((uint16_t)0x0030)
41#define SDRAM_OPERATING_MODE_STANDARD ((uint16_t)0x0000)
42#define SDRAM_WR_BURST_PROGRAMMED ((uint16_t)0x0000)
43#define SDRAM_WR_BURST_SINGLE ((uint16_t)0x0200)
44
45void sdram_init(void);
46void sdram_writebuffer(uint16_t* pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite);
47void sdram_readbuffer(uint16_t* pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread);
48void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset);
49
50#endif
at32f435_437_board.h
fill_buffer
void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:520
sdram_writebuffer
void sdram_writebuffer(uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the sdram memory.
Definition: at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c:248
sdram_init
void sdram_init(void)
init sdram interface
Definition: at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c:46
sdram_readbuffer
void sdram_readbuffer(uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the sdram.
Definition: at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c:268


AT32F435/437 Firmwary Library: xmc_sdram.c File Reference

  • at_start_f437
  • examples
  • xmc
  • sdram_basic
  • src
Macros | Functions
at_start_f437/examples/xmc/sdram_basic/src/xmc_sdram.c File Reference

sdram program. More...

#include "xmc_sdram.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define SDRAM_BANK1_ADDR ((uint32_t)0xC0000000)

Functions

void | sdram_init_sequence (xmc_cmd_bank1_2_type cmd_bank)
init sdram sequence More...
void | sdram_init (void)
init sdram interface More...
void | sdram_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the sdram memory. More...
void | sdram_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the sdram. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...

Detailed Description

sdram program.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/xmc/sdram_basic/src/xmc_sdram.c.


AT32F435/437 Firmwary Library: xmc_sdram.c Source File

  • at_start_f437
  • examples
  • xmc
  • sdram_basic
  • src
at_start_f437/examples/xmc/sdram_basic/src/xmc_sdram.c
Go to the documentation of this file.
1
27#include "xmc_sdram.h"
28#include "at32f435_437_board.h"
29
38#define SDRAM_BANK1_ADDR ((uint32_t)0xC0000000)
39void sdram_init_sequence(xmc_cmd_bank1_2_type cmd_bank);
40
46void sdram_init(void)
47{
48 gpio_init_type gpio_init_struct = {0};
49
50 xmc_sdram_init_type sdram_init_struct;
51 xmc_sdram_timing_type sdram_timing_struct;
52
53
54 /* enable the gpio clock */
55 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
56 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
57 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
58 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
59 crm_periph_clock_enable(CRM_GPIOF_PERIPH_CLOCK, TRUE);
60 crm_periph_clock_enable(CRM_GPIOG_PERIPH_CLOCK, TRUE);
61
62 /* enable the xmc clock */
63 crm_periph_clock_enable(CRM_XMC_PERIPH_CLOCK, TRUE);
64
65 /*-- gpio configuration ------------------------------------------------------*/
66
67 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE5, GPIO_MUX_12);
68 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE6, GPIO_MUX_12);
69
70 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE0, GPIO_MUX_12);
71 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE2, GPIO_MUX_12);
72 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE3, GPIO_MUX_12);
73
74 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE0, GPIO_MUX_12);
75 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_12);
76 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE8, GPIO_MUX_12);
77 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE9, GPIO_MUX_12);
78 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE10, GPIO_MUX_12);
79 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE14, GPIO_MUX_12);
80 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE15, GPIO_MUX_12);
81
82 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE0, GPIO_MUX_12);
83 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE1, GPIO_MUX_12);
84 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE7, GPIO_MUX_12);
85 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE8, GPIO_MUX_12);
86 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE9, GPIO_MUX_12);
87 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE10, GPIO_MUX_12);
88 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE11, GPIO_MUX_12);
89 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE12, GPIO_MUX_12);
90 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE13, GPIO_MUX_12);
91 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE14, GPIO_MUX_12);
92 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE15, GPIO_MUX_12);
93
94 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE0, GPIO_MUX_12);
95 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE1, GPIO_MUX_12);
96 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE2, GPIO_MUX_12);
97 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE3, GPIO_MUX_12);
98 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE4, GPIO_MUX_12);
99 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE5, GPIO_MUX_12);
100 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE11, GPIO_MUX_12);
101 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE12, GPIO_MUX_12);
102 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE13, GPIO_MUX_12);
103 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE14, GPIO_MUX_12);
104 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE15, GPIO_MUX_12);
105
106 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE0, GPIO_MUX_12);
107 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE1, GPIO_MUX_12);
108 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE2, GPIO_MUX_12);
109 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE4, GPIO_MUX_12);
110 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE5, GPIO_MUX_12);
111 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE8, GPIO_MUX_12);
112 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE15, GPIO_MUX_12);
113
114 /* address lines configuration */
115 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
116 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
117 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
118 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
119
120 gpio_init_struct.gpio_pins = GPIO_PINS_5 | GPIO_PINS_6;
121 gpio_init(GPIOB, &gpio_init_struct);
122
123 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_2 | GPIO_PINS_3;
124 gpio_init(GPIOC, &gpio_init_struct);
125
126 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_14 | GPIO_PINS_15;
127 gpio_init(GPIOD, &gpio_init_struct);
128
129 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_10 |
130 GPIO_PINS_9 | GPIO_PINS_11 | GPIO_PINS_11 | GPIO_PINS_12 |
131 GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
132 gpio_init(GPIOE, &gpio_init_struct);
133
134 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_2 | GPIO_PINS_3 |
135 GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_11 | GPIO_PINS_12 |
136 GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
137 gpio_init(GPIOF, &gpio_init_struct);
138
139 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_2 | GPIO_PINS_4 |
140 GPIO_PINS_5 | GPIO_PINS_8 | GPIO_PINS_15;
141 gpio_init(GPIOG, &gpio_init_struct);
142
143
144 /*-- xmc configuration ------------------------------------------------------*/
145 xmc_sdram_default_para_init(&sdram_init_struct, &sdram_timing_struct);
146
147 sdram_init_struct.sdram_bank = XMC_SDRAM_BANK1;
148 sdram_init_struct.internel_banks = XMC_INBK_4;
149 sdram_init_struct.clkdiv = XMC_CLKDIV_3;
150 sdram_init_struct.write_protection = FALSE;
151 sdram_init_struct.burst_read = FALSE;
152 sdram_init_struct.read_delay = XMC_READ_DELAY_1;
153 sdram_init_struct.column_address = XMC_COLUMN_9;
154 sdram_init_struct.row_address = XMC_ROW_13;
155 sdram_init_struct.cas = XMC_CAS_3;
156 sdram_init_struct.width = XMC_MEM_WIDTH_16;
157
158 sdram_timing_struct.tmrd = XMC_DELAY_CYCLE_2;
159 sdram_timing_struct.txsr = XMC_DELAY_CYCLE_11;
160 sdram_timing_struct.tras = XMC_DELAY_CYCLE_7;
161 sdram_timing_struct.trc = XMC_DELAY_CYCLE_9;
162 sdram_timing_struct.twr = XMC_DELAY_CYCLE_2;
163 sdram_timing_struct.trp = XMC_DELAY_CYCLE_3;
164 sdram_timing_struct.trcd = XMC_DELAY_CYCLE_3;
165
166
167 xmc_sdram_init(&sdram_init_struct, &sdram_timing_struct);
168
169 sdram_init_sequence(XMC_CMD_BANK1);
170
171}
172
178void sdram_init_sequence(xmc_cmd_bank1_2_type cmd_bank)
179{
180 xmc_sdram_cmd_type sdram_cmd_struct;
181 uint32_t timeout = 0xFFFF;
182
183 sdram_cmd_struct.cmd = XMC_CMD_CLK;
184 sdram_cmd_struct.auto_refresh = 1;
185 sdram_cmd_struct.cmd_banks = cmd_bank;
186 sdram_cmd_struct.data = 0;
187 xmc_sdram_cmd(&sdram_cmd_struct);
188
189 while((xmc_flag_status_get(XMC_BANK5_6_SDRAM, XMC_BUSY_FLAG) != RESET) && (timeout > 0))
190 {
191 timeout --;
192 }
193 delay_ms(100);
194
195 sdram_cmd_struct.cmd = XMC_CMD_PRECHARG_ALL;
196 sdram_cmd_struct.auto_refresh = 1;
197 sdram_cmd_struct.cmd_banks = cmd_bank;
198 sdram_cmd_struct.data = 0;
199 xmc_sdram_cmd(&sdram_cmd_struct);
200
201 timeout = 0xFFFF;
202 while((xmc_flag_status_get(XMC_BANK5_6_SDRAM, XMC_BUSY_FLAG) != RESET) && (timeout > 0))
203 {
204 timeout --;
205 }
206
207 /* counter = (refresh_count * 1000 * SDCLK) / row - 20 */
208 /* counter = (64ms * 1000 * 144MHz) / 2^13 - 20 */
209 xmc_sdram_refresh_counter_set(1105);
210
211 sdram_cmd_struct.cmd = XMC_CMD_AUTO_REFRESH;
212 sdram_cmd_struct.auto_refresh = 8;
213 sdram_cmd_struct.cmd_banks = cmd_bank;
214 sdram_cmd_struct.data = 0;
215 xmc_sdram_cmd(&sdram_cmd_struct);
216
217 timeout = 0xFFFF;
218 while((xmc_flag_status_get(XMC_BANK5_6_SDRAM, XMC_BUSY_FLAG) != RESET) && (timeout > 0))
219 {
220 timeout --;
221 }
222
223 sdram_cmd_struct.cmd = XMC_CMD_LOAD_MODE;
224 sdram_cmd_struct.auto_refresh = 1;
225 sdram_cmd_struct.cmd_banks = cmd_bank;
226 sdram_cmd_struct.data = (uint32_t)SDRAM_BURST_LEN_1 | SDRAM_BURST_SEQUENTIAL |
227 SDRAM_CAS_LATENCY_3 | SDRAM_OPERATING_MODE_STANDARD |
228 SDRAM_WR_BURST_SINGLE;
229 xmc_sdram_cmd(&sdram_cmd_struct);
230
231 timeout = 0xFFFF;
232 while((xmc_flag_status_get(XMC_BANK5_6_SDRAM, XMC_BUSY_FLAG) != RESET) && (timeout > 0))
233 {
234 timeout --;
235 }
236
237}
238
239
248void sdram_writebuffer(uint16_t* pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
249{
250 for(; numhalfwordtowrite != 0; numhalfwordtowrite--)
251 {
253 *(__IO uint16_t *) (SDRAM_BANK1_ADDR + writeaddr) = *pbuffer++;
254
256 writeaddr += 2;
257 }
258}
259
268void sdram_readbuffer(uint16_t* pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
269{
270 for(; numhalfwordtoread != 0; numhalfwordtoread--)
271 {
273 *pbuffer++ = *(__IO uint16_t*) (SDRAM_BANK1_ADDR + readaddr);
274
276 readaddr += 2;
277 }
278}
279
286void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
287{
288 uint16_t indextmp = 0;
289
290 /* put in global buffer same values */
291 for (indextmp = 0; indextmp < bufferlenght; indextmp++ )
292 {
293 pbuffer[indextmp] = indextmp + offset;
294 }
295}
296
at32f435_437_board.h
SDRAM_CAS_LATENCY_3
#define SDRAM_CAS_LATENCY_3
Definition: at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h:40
SDRAM_BURST_LEN_1
#define SDRAM_BURST_LEN_1
Definition: at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h:32
SDRAM_BURST_SEQUENTIAL
#define SDRAM_BURST_SEQUENTIAL
Definition: at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h:36
SDRAM_WR_BURST_SINGLE
#define SDRAM_WR_BURST_SINGLE
Definition: at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h:43
SDRAM_OPERATING_MODE_STANDARD
#define SDRAM_OPERATING_MODE_STANDARD
Definition: at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h:41
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
fill_buffer
void fill_buffer(uint8_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
Fill the global buffer.
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:55
sdram_writebuffer
void sdram_writebuffer(uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the sdram memory.
Definition: at_start_f437/examples/xmc/sdram_basic/src/xmc_sdram.c:248
sdram_init_sequence
void sdram_init_sequence(xmc_cmd_bank1_2_type cmd_bank)
init sdram sequence
Definition: at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c:178
sdram_init
void sdram_init(void)
init sdram interface
Definition: at_start_f437/examples/xmc/sdram_basic/src/xmc_sdram.c:46
sdram_readbuffer
void sdram_readbuffer(uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the sdram.
Definition: at_start_f437/examples/xmc/sdram_basic/src/xmc_sdram.c:268
SDRAM_BANK1_ADDR
#define SDRAM_BANK1_ADDR
Definition: at_start_f437/examples/xmc/sdram_basic/src/xmc_sdram.c:38
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_XMC_PERIPH_CLOCK
@ CRM_XMC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:123
CRM_GPIOF_PERIPH_CLOCK
@ CRM_GPIOF_PERIPH_CLOCK
Definition: at32f435_437_crm.h:110
CRM_GPIOG_PERIPH_CLOCK
@ CRM_GPIOG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:111
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f435_437_gpio.h:146
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f435_437_gpio.h:64
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOG
#define GPIOG
Definition: at32f435_437_gpio.h:527
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOF
#define GPIOF
Definition: at32f435_437_gpio.h:526
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
xmc_sdram_cmd
void xmc_sdram_cmd(xmc_sdram_cmd_type *xmc_sdram_cmd_struct)
sdram command confg
Definition: at32f435_437_xmc.c:561
xmc_sdram_refresh_counter_set
void xmc_sdram_refresh_counter_set(uint32_t counter)
set sdram refresh counter
Definition: at32f435_437_xmc.c:595
xmc_sdram_init
void xmc_sdram_init(xmc_sdram_init_type *xmc_sdram_init_struct, xmc_sdram_timing_type *xmc_sdram_timing_struct)
initialize the xmc sdram banks according to the specified parameters in the xmc_sdram_init_struct and...
Definition: at32f435_437_xmc.c:475
xmc_sdram_default_para_init
void xmc_sdram_default_para_init(xmc_sdram_init_type *xmc_sdram_init_struct, xmc_sdram_timing_type *xmc_sdram_timing_struct)
fill each xmc_sdram_init_struct member with its default value.
Definition: at32f435_437_xmc.c:532
xmc_flag_status_get
flag_status xmc_flag_status_get(xmc_class_bank_type xmc_bank, xmc_interrupt_flag_type xmc_flag)
check whether the specified xmc flag is set or not.
Definition: at32f435_437_xmc.c:695
xmc_cmd_bank1_2_type
xmc_cmd_bank1_2_type
xmc sdram command bank select type
Definition: at32f435_437_xmc.h:370
XMC_CMD_LOAD_MODE
@ XMC_CMD_LOAD_MODE
Definition: at32f435_437_xmc.h:361
XMC_CMD_CLK
@ XMC_CMD_CLK
Definition: at32f435_437_xmc.h:358
XMC_CMD_AUTO_REFRESH
@ XMC_CMD_AUTO_REFRESH
Definition: at32f435_437_xmc.h:360
XMC_CMD_PRECHARG_ALL
@ XMC_CMD_PRECHARG_ALL
Definition: at32f435_437_xmc.h:359
XMC_DELAY_CYCLE_9
@ XMC_DELAY_CYCLE_9
Definition: at32f435_437_xmc.h:341
XMC_DELAY_CYCLE_11
@ XMC_DELAY_CYCLE_11
Definition: at32f435_437_xmc.h:343
XMC_DELAY_CYCLE_7
@ XMC_DELAY_CYCLE_7
Definition: at32f435_437_xmc.h:339
XMC_DELAY_CYCLE_3
@ XMC_DELAY_CYCLE_3
Definition: at32f435_437_xmc.h:335
XMC_DELAY_CYCLE_2
@ XMC_DELAY_CYCLE_2
Definition: at32f435_437_xmc.h:334
XMC_BANK5_6_SDRAM
@ XMC_BANK5_6_SDRAM
Definition: at32f435_437_xmc.h:160
XMC_CLKDIV_3
@ XMC_CLKDIV_3
Definition: at32f435_437_xmc.h:304
XMC_SDRAM_BANK1
@ XMC_SDRAM_BANK1
Definition: at32f435_437_xmc.h:323
XMC_BUSY_FLAG
@ XMC_BUSY_FLAG
Definition: at32f435_437_xmc.h:245
XMC_ROW_13
@ XMC_ROW_13
Definition: at32f435_437_xmc.h:266
XMC_READ_DELAY_1
@ XMC_READ_DELAY_1
Definition: at32f435_437_xmc.h:314
XMC_INBK_4
@ XMC_INBK_4
Definition: at32f435_437_xmc.h:284
XMC_CAS_3
@ XMC_CAS_3
Definition: at32f435_437_xmc.h:294
XMC_CMD_BANK1
@ XMC_CMD_BANK1
Definition: at32f435_437_xmc.h:371
XMC_MEM_WIDTH_16
@ XMC_MEM_WIDTH_16
Definition: at32f435_437_xmc.h:275
XMC_COLUMN_9
@ XMC_COLUMN_9
Definition: at32f435_437_xmc.h:254
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
xmc_sdram_cmd_type
xmc sdram command structure definition
Definition: at32f435_437_xmc.h:502
xmc_sdram_cmd_type::cmd_banks
xmc_cmd_bank1_2_type cmd_banks
Definition: at32f435_437_xmc.h:504
xmc_sdram_cmd_type::auto_refresh
uint32_t auto_refresh
Definition: at32f435_437_xmc.h:505
xmc_sdram_cmd_type::data
uint32_t data
Definition: at32f435_437_xmc.h:506
xmc_sdram_cmd_type::cmd
xmc_command_type cmd
Definition: at32f435_437_xmc.h:503
xmc_sdram_init_type
xmc sdram init structure definition
Definition: at32f435_437_xmc.h:469
xmc_sdram_init_type::row_address
xmc_sdram_row_type row_address
Definition: at32f435_437_xmc.h:477
xmc_sdram_init_type::burst_read
uint8_t burst_read
Definition: at32f435_437_xmc.h:474
xmc_sdram_init_type::clkdiv
xmc_sdram_clkdiv_type clkdiv
Definition: at32f435_437_xmc.h:472
xmc_sdram_init_type::write_protection
uint8_t write_protection
Definition: at32f435_437_xmc.h:473
xmc_sdram_init_type::column_address
xmc_sdram_column_type column_address
Definition: at32f435_437_xmc.h:476
xmc_sdram_init_type::read_delay
uint8_t read_delay
Definition: at32f435_437_xmc.h:475
xmc_sdram_init_type::width
xmc_sdram_width_type width
Definition: at32f435_437_xmc.h:479
xmc_sdram_init_type::cas
xmc_sdram_cas_type cas
Definition: at32f435_437_xmc.h:478
xmc_sdram_init_type::sdram_bank
xmc_sdram_bank_type sdram_bank
Definition: at32f435_437_xmc.h:470
xmc_sdram_init_type::internel_banks
xmc_sdram_inbk_type internel_banks
Definition: at32f435_437_xmc.h:471
xmc_sdram_timing_type
xmc sdram timing structure definition
Definition: at32f435_437_xmc.h:487
xmc_sdram_timing_type::trcd
xmc_sdram_delay_type trcd
Definition: at32f435_437_xmc.h:494
xmc_sdram_timing_type::trc
xmc_sdram_delay_type trc
Definition: at32f435_437_xmc.h:491
xmc_sdram_timing_type::tmrd
xmc_sdram_delay_type tmrd
Definition: at32f435_437_xmc.h:488
xmc_sdram_timing_type::twr
xmc_sdram_delay_type twr
Definition: at32f435_437_xmc.h:492
xmc_sdram_timing_type::tras
xmc_sdram_delay_type tras
Definition: at32f435_437_xmc.h:490
xmc_sdram_timing_type::txsr
xmc_sdram_delay_type txsr
Definition: at32f435_437_xmc.h:489
xmc_sdram_timing_type::trp
xmc_sdram_delay_type trp
Definition: at32f435_437_xmc.h:493


AT32F435/437 Firmwary Library: xmc_sdram.h File Reference

  • at_start_f437
  • examples
  • xmc
  • sdram_dma
  • inc
Macros | Functions
at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h File Reference

header file for the sdram configuration. More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define | SDRAM_BURST_LEN_1 ((uint16_t)0x0000)
#define | SDRAM_BURST_LEN_2 ((uint16_t)0x0001)
#define | SDRAM_BURST_LEN_4 ((uint16_t)0x0002)
#define | SDRAM_BURST_LEN_8 ((uint16_t)0x0004)
#define | SDRAM_BURST_SEQUENTIAL ((uint16_t)0x0000)
#define | SDRAM_BURST_INTERLEAVED ((uint16_t)0x0008)
#define | SDRAM_CAS_LATENCY_1 ((uint16_t)0x0010)
#define | SDRAM_CAS_LATENCY_2 ((uint16_t)0x0020)
#define | SDRAM_CAS_LATENCY_3 ((uint16_t)0x0030)
#define | SDRAM_OPERATING_MODE_STANDARD ((uint16_t)0x0000)
#define | SDRAM_WR_BURST_PROGRAMMED ((uint16_t)0x0000)
#define | SDRAM_WR_BURST_SINGLE ((uint16_t)0x0200)

Functions

void | sdram_init (void)
init sdram interface More...
void | sdram_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the sdram memory. More...
void | sdram_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the sdram. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...
void | sdram_copy_to_sram_dma (uint16_t *buffer, uint32_t length)
copy sdram data to sram More...
void | sram_copy_to_sdram_dma (uint16_t *buffer, uint32_t length)
copy sram data copy to sdram More...

Detailed Description

header file for the sdram configuration.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h.

Macro Definition Documentation

◆ SDRAM_BURST_INTERLEAVED

#define SDRAM_BURST_INTERLEAVED ((uint16_t)0x0008)

Definition at line 37 of file at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h.

◆ SDRAM_BURST_LEN_1

#define SDRAM_BURST_LEN_1 ((uint16_t)0x0000)

Definition at line 32 of file at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h.

◆ SDRAM_BURST_LEN_2

#define SDRAM_BURST_LEN_2 ((uint16_t)0x0001)

Definition at line 33 of file at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h.

◆ SDRAM_BURST_LEN_4

#define SDRAM_BURST_LEN_4 ((uint16_t)0x0002)

Definition at line 34 of file at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h.

◆ SDRAM_BURST_LEN_8

#define SDRAM_BURST_LEN_8 ((uint16_t)0x0004)

Definition at line 35 of file at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h.

◆ SDRAM_BURST_SEQUENTIAL

#define SDRAM_BURST_SEQUENTIAL ((uint16_t)0x0000)

Definition at line 36 of file at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h.

◆ SDRAM_CAS_LATENCY_1

#define SDRAM_CAS_LATENCY_1 ((uint16_t)0x0010)

Definition at line 38 of file at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h.

◆ SDRAM_CAS_LATENCY_2

#define SDRAM_CAS_LATENCY_2 ((uint16_t)0x0020)

Definition at line 39 of file at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h.

◆ SDRAM_CAS_LATENCY_3

#define SDRAM_CAS_LATENCY_3 ((uint16_t)0x0030)

Definition at line 40 of file at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h.

◆ SDRAM_OPERATING_MODE_STANDARD

#define SDRAM_OPERATING_MODE_STANDARD ((uint16_t)0x0000)

Definition at line 41 of file at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h.

◆ SDRAM_WR_BURST_PROGRAMMED

#define SDRAM_WR_BURST_PROGRAMMED ((uint16_t)0x0000)

Definition at line 42 of file at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h.

◆ SDRAM_WR_BURST_SINGLE

#define SDRAM_WR_BURST_SINGLE ((uint16_t)0x0200)

Definition at line 43 of file at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h.


AT32F435/437 Firmwary Library: xmc_sdram.h Source File

  • at_start_f437
  • examples
  • xmc
  • sdram_dma
  • inc
at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
Go to the documentation of this file.
1
27#ifndef __XMC_SDRAM_H
28#define __XMC_SDRAM_H
29
30#include "at32f435_437_board.h"
31
32#define SDRAM_BURST_LEN_1 ((uint16_t)0x0000)
33#define SDRAM_BURST_LEN_2 ((uint16_t)0x0001)
34#define SDRAM_BURST_LEN_4 ((uint16_t)0x0002)
35#define SDRAM_BURST_LEN_8 ((uint16_t)0x0004)
36#define SDRAM_BURST_SEQUENTIAL ((uint16_t)0x0000)
37#define SDRAM_BURST_INTERLEAVED ((uint16_t)0x0008)
38#define SDRAM_CAS_LATENCY_1 ((uint16_t)0x0010)
39#define SDRAM_CAS_LATENCY_2 ((uint16_t)0x0020)
40#define SDRAM_CAS_LATENCY_3 ((uint16_t)0x0030)
41#define SDRAM_OPERATING_MODE_STANDARD ((uint16_t)0x0000)
42#define SDRAM_WR_BURST_PROGRAMMED ((uint16_t)0x0000)
43#define SDRAM_WR_BURST_SINGLE ((uint16_t)0x0200)
44
45void sdram_init(void);
46void sdram_writebuffer(uint16_t* pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite);
47void sdram_readbuffer(uint16_t* pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread);
48void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset);
49void sdram_copy_to_sram_dma(uint16_t *buffer, uint32_t length);
50void sram_copy_to_sdram_dma(uint16_t *buffer, uint32_t length);
51
52#endif
at32f435_437_board.h
buffer
uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:43
fill_buffer
void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:520
sdram_writebuffer
void sdram_writebuffer(uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the sdram memory.
Definition: at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c:248
sdram_init
void sdram_init(void)
init sdram interface
Definition: at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c:46
sdram_readbuffer
void sdram_readbuffer(uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the sdram.
Definition: at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c:268
sram_copy_to_sdram_dma
void sram_copy_to_sdram_dma(uint16_t *buffer, uint32_t length)
copy sram data copy to sdram
Definition: at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c:336
sdram_copy_to_sram_dma
void sdram_copy_to_sram_dma(uint16_t *buffer, uint32_t length)
copy sdram data to sram
Definition: at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c:305


AT32F435/437 Firmwary Library: xmc_sdram.c File Reference

  • at_start_f437
  • examples
  • xmc
  • sdram_dma
  • src
Macros | Functions | Variables
at_start_f437/examples/xmc/sdram_dma/src/xmc_sdram.c File Reference

sdram program. More...

#include "xmc_sdram.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Macros

#define SDRAM_BANK1_ADDR ((uint32_t)0xC0000000)

Functions

void | sdram_init_sequence (xmc_cmd_bank1_2_type cmd_bank)
init sdram sequence More...
void | sdram_init (void)
init sdram interface More...
void | sdram_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the sdram memory. More...
void | sdram_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the sdram. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...
void | sdram_copy_to_sram_dma (uint16_t *buffer, uint32_t length)
copy sdram data to sram More...
void | sram_copy_to_sdram_dma (uint16_t *buffer, uint32_t length)
copy sram data copy to sdram More...

Variables

dma_init_type dma_init_struct

Detailed Description

sdram program.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/xmc/sdram_dma/src/xmc_sdram.c.


AT32F435/437 Firmwary Library: xmc_sdram.c Source File

  • at_start_f437
  • examples
  • xmc
  • sdram_dma
  • src
at_start_f437/examples/xmc/sdram_dma/src/xmc_sdram.c
Go to the documentation of this file.
1
27#include "xmc_sdram.h"
28#include "at32f435_437_board.h"
29
38#define SDRAM_BANK1_ADDR ((uint32_t)0xC0000000)
39
40 dma_init_type dma_init_struct;
41void sdram_init_sequence(xmc_cmd_bank1_2_type cmd_bank);
42
48void sdram_init(void)
49{
50 gpio_init_type gpio_init_struct = {0};
51
52 xmc_sdram_init_type sdram_init_struct;
53 xmc_sdram_timing_type sdram_timing_struct;
54
55
56 /* enable the gpio clock */
57 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
58 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
59 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
60 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
61 crm_periph_clock_enable(CRM_GPIOF_PERIPH_CLOCK, TRUE);
62 crm_periph_clock_enable(CRM_GPIOG_PERIPH_CLOCK, TRUE);
63
64 /* enable the xmc clock */
65 crm_periph_clock_enable(CRM_XMC_PERIPH_CLOCK, TRUE);
66
67 /*-- gpio configuration ------------------------------------------------------*/
68
69 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE5, GPIO_MUX_12);
70 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE6, GPIO_MUX_12);
71
72 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE0, GPIO_MUX_12);
73 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE2, GPIO_MUX_12);
74 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE3, GPIO_MUX_12);
75
76 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE0, GPIO_MUX_12);
77 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_12);
78 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE8, GPIO_MUX_12);
79 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE9, GPIO_MUX_12);
80 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE10, GPIO_MUX_12);
81 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE14, GPIO_MUX_12);
82 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE15, GPIO_MUX_12);
83
84 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE0, GPIO_MUX_12);
85 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE1, GPIO_MUX_12);
86 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE7, GPIO_MUX_12);
87 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE8, GPIO_MUX_12);
88 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE9, GPIO_MUX_12);
89 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE10, GPIO_MUX_12);
90 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE11, GPIO_MUX_12);
91 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE12, GPIO_MUX_12);
92 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE13, GPIO_MUX_12);
93 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE14, GPIO_MUX_12);
94 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE15, GPIO_MUX_12);
95
96 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE0, GPIO_MUX_12);
97 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE1, GPIO_MUX_12);
98 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE2, GPIO_MUX_12);
99 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE3, GPIO_MUX_12);
100 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE4, GPIO_MUX_12);
101 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE5, GPIO_MUX_12);
102 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE11, GPIO_MUX_12);
103 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE12, GPIO_MUX_12);
104 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE13, GPIO_MUX_12);
105 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE14, GPIO_MUX_12);
106 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE15, GPIO_MUX_12);
107
108 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE0, GPIO_MUX_12);
109 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE1, GPIO_MUX_12);
110 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE2, GPIO_MUX_12);
111 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE4, GPIO_MUX_12);
112 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE5, GPIO_MUX_12);
113 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE8, GPIO_MUX_12);
114 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE15, GPIO_MUX_12);
115
116 /* address lines configuration */
117 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
118 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
119 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
120 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
121
122 gpio_init_struct.gpio_pins = GPIO_PINS_5 | GPIO_PINS_6;
123 gpio_init(GPIOB, &gpio_init_struct);
124
125 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_2 | GPIO_PINS_3;
126 gpio_init(GPIOC, &gpio_init_struct);
127
128 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_14 | GPIO_PINS_15;
129 gpio_init(GPIOD, &gpio_init_struct);
130
131 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_10 |
132 GPIO_PINS_9 | GPIO_PINS_11 | GPIO_PINS_11 | GPIO_PINS_12 |
133 GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
134 gpio_init(GPIOE, &gpio_init_struct);
135
136 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_2 | GPIO_PINS_3 |
137 GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_11 | GPIO_PINS_12 |
138 GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
139 gpio_init(GPIOF, &gpio_init_struct);
140
141 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_2 | GPIO_PINS_4 |
142 GPIO_PINS_5 | GPIO_PINS_8 | GPIO_PINS_15;
143 gpio_init(GPIOG, &gpio_init_struct);
144
145
146 /*-- xmc configuration ------------------------------------------------------*/
147 xmc_sdram_default_para_init(&sdram_init_struct, &sdram_timing_struct);
148
149 sdram_init_struct.sdram_bank = XMC_SDRAM_BANK1;
150 sdram_init_struct.internel_banks = XMC_INBK_4;
151 sdram_init_struct.clkdiv = XMC_CLKDIV_3;
152 sdram_init_struct.write_protection = FALSE;
153 sdram_init_struct.burst_read = FALSE;
154 sdram_init_struct.read_delay = XMC_READ_DELAY_1;
155 sdram_init_struct.column_address = XMC_COLUMN_9;
156 sdram_init_struct.row_address = XMC_ROW_13;
157 sdram_init_struct.cas = XMC_CAS_3;
158 sdram_init_struct.width = XMC_MEM_WIDTH_16;
159
160 sdram_timing_struct.tmrd = XMC_DELAY_CYCLE_2;
161 sdram_timing_struct.txsr = XMC_DELAY_CYCLE_11;
162 sdram_timing_struct.tras = XMC_DELAY_CYCLE_7;
163 sdram_timing_struct.trc = XMC_DELAY_CYCLE_9;
164 sdram_timing_struct.twr = XMC_DELAY_CYCLE_2;
165 sdram_timing_struct.trp = XMC_DELAY_CYCLE_3;
166 sdram_timing_struct.trcd = XMC_DELAY_CYCLE_3;
167
168 xmc_sdram_init(&sdram_init_struct, &sdram_timing_struct);
169
170 sdram_init_sequence(XMC_CMD_BANK1);
171
172}
173
179void sdram_init_sequence(xmc_cmd_bank1_2_type cmd_bank)
180{
181 xmc_sdram_cmd_type sdram_cmd_struct;
182 uint32_t timeout = 0xFFFF;
183
184 sdram_cmd_struct.cmd = XMC_CMD_CLK;
185 sdram_cmd_struct.auto_refresh = 1;
186 sdram_cmd_struct.cmd_banks = cmd_bank;
187 sdram_cmd_struct.data = 0;
188 xmc_sdram_cmd(&sdram_cmd_struct);
189
190 while((xmc_flag_status_get(XMC_BANK5_6_SDRAM, XMC_BUSY_FLAG) != RESET) && (timeout > 0))
191 {
192 timeout --;
193 }
194 delay_ms(100);
195
196 sdram_cmd_struct.cmd = XMC_CMD_PRECHARG_ALL;
197 sdram_cmd_struct.auto_refresh = 1;
198 sdram_cmd_struct.cmd_banks = cmd_bank;
199 sdram_cmd_struct.data = 0;
200 xmc_sdram_cmd(&sdram_cmd_struct);
201
202 timeout = 0xFFFF;
203 while((xmc_flag_status_get(XMC_BANK5_6_SDRAM, XMC_BUSY_FLAG) != RESET) && (timeout > 0))
204 {
205 timeout --;
206 }
207
208 /* counter = (refresh_count * 1000 * SDCLK) / row - 20 */
209 /* counter = (64ms * 1000 * 144MHz ) / 2^13 - 20 */
210 xmc_sdram_refresh_counter_set(1105);
211
212 sdram_cmd_struct.cmd = XMC_CMD_AUTO_REFRESH;
213 sdram_cmd_struct.auto_refresh = 8;
214 sdram_cmd_struct.cmd_banks = cmd_bank;
215 sdram_cmd_struct.data = 0;
216 xmc_sdram_cmd(&sdram_cmd_struct);
217
218 timeout = 0xFFFF;
219 while((xmc_flag_status_get(XMC_BANK5_6_SDRAM, XMC_BUSY_FLAG) != RESET) && (timeout > 0))
220 {
221 timeout --;
222 }
223
224 sdram_cmd_struct.cmd = XMC_CMD_LOAD_MODE;
225 sdram_cmd_struct.auto_refresh = 1;
226 sdram_cmd_struct.cmd_banks = cmd_bank;
227 sdram_cmd_struct.data = (uint32_t)SDRAM_BURST_LEN_1 | SDRAM_BURST_SEQUENTIAL |
228 SDRAM_CAS_LATENCY_3 | SDRAM_OPERATING_MODE_STANDARD |
229 SDRAM_WR_BURST_SINGLE;
230 xmc_sdram_cmd(&sdram_cmd_struct);
231
232 timeout = 0xFFFF;
233 while((xmc_flag_status_get(XMC_BANK5_6_SDRAM, XMC_BUSY_FLAG) != RESET) && (timeout > 0))
234 {
235 timeout --;
236 }
237
238}
239
240
249void sdram_writebuffer(uint16_t* pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
250{
251 for(; numhalfwordtowrite != 0; numhalfwordtowrite--)
252 {
254 *(__IO uint16_t *) (SDRAM_BANK1_ADDR + writeaddr) = *pbuffer++;
255
257 writeaddr += 2;
258 }
259}
260
269void sdram_readbuffer(uint16_t* pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
270{
271 for(; numhalfwordtoread != 0; numhalfwordtoread--)
272 {
274 *pbuffer++ = *(__IO uint16_t*) (SDRAM_BANK1_ADDR + readaddr);
275
277 readaddr += 2;
278 }
279}
280
288void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
289{
290 uint16_t indextmp = 0;
291
292 /* put in global buffer same values */
293 for (indextmp = 0; indextmp < bufferlenght; indextmp++ )
294 {
295 pbuffer[indextmp] = indextmp + offset;
296 }
297}
298
305void sdram_copy_to_sram_dma(uint16_t *buffer, uint32_t length)
306{
307 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
308 /* dma1 channel1 configuration */
309 dma_reset(DMA1_CHANNEL1);
310 dma_init_struct.buffer_size = length;
311 dma_init_struct.direction = DMA_DIR_MEMORY_TO_MEMORY;
312 dma_init_struct.memory_base_addr = (uint32_t)buffer;
313 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
314 dma_init_struct.memory_inc_enable = TRUE;
315 dma_init_struct.peripheral_base_addr = (uint32_t)SDRAM_BANK1_ADDR;
316 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
317 dma_init_struct.peripheral_inc_enable = TRUE;
318 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
319 dma_init_struct.loop_mode_enable = FALSE;
320 dma_init(DMA1_CHANNEL1, &dma_init_struct);
321 dma_channel_enable(DMA1_CHANNEL1, TRUE);
322
323 while(dma_flag_get(DMA1_FDT1_FLAG) == RESET)
324 {
325 }
326 dma_channel_enable(DMA1_CHANNEL1, FALSE);
327
328}
329
336void sram_copy_to_sdram_dma(uint16_t *buffer, uint32_t length)
337{
338 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
339 /* dma1 channel1 configuration */
340 dma_reset(DMA1_CHANNEL1);
341 dma_init_struct.buffer_size = length;
342 dma_init_struct.direction = DMA_DIR_MEMORY_TO_MEMORY;
343 dma_init_struct.memory_base_addr = (uint32_t)SDRAM_BANK1_ADDR;
344 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
345 dma_init_struct.memory_inc_enable = TRUE;
346 dma_init_struct.peripheral_base_addr = (uint32_t)buffer;
347 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
348 dma_init_struct.peripheral_inc_enable = TRUE;
349 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
350 dma_init_struct.loop_mode_enable = FALSE;
351 dma_init(DMA1_CHANNEL1, &dma_init_struct);
352 dma_channel_enable(DMA1_CHANNEL1, TRUE);
353
354 while(dma_flag_get(DMA1_FDT1_FLAG) == RESET)
355 {
356 }
357 dma_channel_enable(DMA1_CHANNEL1, FALSE);
358}
359
at32f435_437_board.h
SDRAM_CAS_LATENCY_3
#define SDRAM_CAS_LATENCY_3
Definition: at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h:40
SDRAM_BURST_LEN_1
#define SDRAM_BURST_LEN_1
Definition: at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h:32
SDRAM_BURST_SEQUENTIAL
#define SDRAM_BURST_SEQUENTIAL
Definition: at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h:36
SDRAM_WR_BURST_SINGLE
#define SDRAM_WR_BURST_SINGLE
Definition: at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h:43
SDRAM_OPERATING_MODE_STANDARD
#define SDRAM_OPERATING_MODE_STANDARD
Definition: at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h:41
buffer
uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:43
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
fill_buffer
void fill_buffer(uint8_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
Fill the global buffer.
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:55
sdram_writebuffer
void sdram_writebuffer(uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the sdram memory.
Definition: at_start_f437/examples/xmc/sdram_basic/src/xmc_sdram.c:248
sdram_init_sequence
void sdram_init_sequence(xmc_cmd_bank1_2_type cmd_bank)
init sdram sequence
Definition: at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c:178
sdram_init
void sdram_init(void)
init sdram interface
Definition: at_start_f437/examples/xmc/sdram_basic/src/xmc_sdram.c:46
sdram_readbuffer
void sdram_readbuffer(uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the sdram.
Definition: at_start_f437/examples/xmc/sdram_basic/src/xmc_sdram.c:268
dma_init_struct
dma_init_type dma_init_struct
Definition: at_start_f437/examples/xmc/sdram_dma/src/xmc_sdram.c:40
sram_copy_to_sdram_dma
void sram_copy_to_sdram_dma(uint16_t *buffer, uint32_t length)
copy sram data copy to sdram
Definition: at_start_f437/examples/xmc/sdram_dma/src/xmc_sdram.c:336
sdram_copy_to_sram_dma
void sdram_copy_to_sram_dma(uint16_t *buffer, uint32_t length)
copy sdram data to sram
Definition: at_start_f437/examples/xmc/sdram_dma/src/xmc_sdram.c:305
SDRAM_BANK1_ADDR
#define SDRAM_BANK1_ADDR
Definition: at_start_f437/examples/xmc/sdram_dma/src/xmc_sdram.c:38
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_XMC_PERIPH_CLOCK
@ CRM_XMC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:123
CRM_GPIOF_PERIPH_CLOCK
@ CRM_GPIOF_PERIPH_CLOCK
Definition: at32f435_437_crm.h:110
CRM_GPIOG_PERIPH_CLOCK
@ CRM_GPIOG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:111
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_DIR_MEMORY_TO_MEMORY
@ DMA_DIR_MEMORY_TO_MEMORY
Definition: at32f435_437_dma.h:154
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f435_437_dma.h:183
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f435_437_dma.h:66
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f435_437_gpio.h:146
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f435_437_gpio.h:64
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOG
#define GPIOG
Definition: at32f435_437_gpio.h:527
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOF
#define GPIOF
Definition: at32f435_437_gpio.h:526
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
xmc_sdram_cmd
void xmc_sdram_cmd(xmc_sdram_cmd_type *xmc_sdram_cmd_struct)
sdram command confg
Definition: at32f435_437_xmc.c:561
xmc_sdram_refresh_counter_set
void xmc_sdram_refresh_counter_set(uint32_t counter)
set sdram refresh counter
Definition: at32f435_437_xmc.c:595
xmc_sdram_init
void xmc_sdram_init(xmc_sdram_init_type *xmc_sdram_init_struct, xmc_sdram_timing_type *xmc_sdram_timing_struct)
initialize the xmc sdram banks according to the specified parameters in the xmc_sdram_init_struct and...
Definition: at32f435_437_xmc.c:475
xmc_sdram_default_para_init
void xmc_sdram_default_para_init(xmc_sdram_init_type *xmc_sdram_init_struct, xmc_sdram_timing_type *xmc_sdram_timing_struct)
fill each xmc_sdram_init_struct member with its default value.
Definition: at32f435_437_xmc.c:532
xmc_flag_status_get
flag_status xmc_flag_status_get(xmc_class_bank_type xmc_bank, xmc_interrupt_flag_type xmc_flag)
check whether the specified xmc flag is set or not.
Definition: at32f435_437_xmc.c:695
xmc_cmd_bank1_2_type
xmc_cmd_bank1_2_type
xmc sdram command bank select type
Definition: at32f435_437_xmc.h:370
XMC_CMD_LOAD_MODE
@ XMC_CMD_LOAD_MODE
Definition: at32f435_437_xmc.h:361
XMC_CMD_CLK
@ XMC_CMD_CLK
Definition: at32f435_437_xmc.h:358
XMC_CMD_AUTO_REFRESH
@ XMC_CMD_AUTO_REFRESH
Definition: at32f435_437_xmc.h:360
XMC_CMD_PRECHARG_ALL
@ XMC_CMD_PRECHARG_ALL
Definition: at32f435_437_xmc.h:359
XMC_DELAY_CYCLE_9
@ XMC_DELAY_CYCLE_9
Definition: at32f435_437_xmc.h:341
XMC_DELAY_CYCLE_11
@ XMC_DELAY_CYCLE_11
Definition: at32f435_437_xmc.h:343
XMC_DELAY_CYCLE_7
@ XMC_DELAY_CYCLE_7
Definition: at32f435_437_xmc.h:339
XMC_DELAY_CYCLE_3
@ XMC_DELAY_CYCLE_3
Definition: at32f435_437_xmc.h:335
XMC_DELAY_CYCLE_2
@ XMC_DELAY_CYCLE_2
Definition: at32f435_437_xmc.h:334
XMC_BANK5_6_SDRAM
@ XMC_BANK5_6_SDRAM
Definition: at32f435_437_xmc.h:160
XMC_CLKDIV_3
@ XMC_CLKDIV_3
Definition: at32f435_437_xmc.h:304
XMC_SDRAM_BANK1
@ XMC_SDRAM_BANK1
Definition: at32f435_437_xmc.h:323
XMC_BUSY_FLAG
@ XMC_BUSY_FLAG
Definition: at32f435_437_xmc.h:245
XMC_ROW_13
@ XMC_ROW_13
Definition: at32f435_437_xmc.h:266
XMC_READ_DELAY_1
@ XMC_READ_DELAY_1
Definition: at32f435_437_xmc.h:314
XMC_INBK_4
@ XMC_INBK_4
Definition: at32f435_437_xmc.h:284
XMC_CAS_3
@ XMC_CAS_3
Definition: at32f435_437_xmc.h:294
XMC_CMD_BANK1
@ XMC_CMD_BANK1
Definition: at32f435_437_xmc.h:371
XMC_MEM_WIDTH_16
@ XMC_MEM_WIDTH_16
Definition: at32f435_437_xmc.h:275
XMC_COLUMN_9
@ XMC_COLUMN_9
Definition: at32f435_437_xmc.h:254
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
xmc_sdram_cmd_type
xmc sdram command structure definition
Definition: at32f435_437_xmc.h:502
xmc_sdram_cmd_type::cmd_banks
xmc_cmd_bank1_2_type cmd_banks
Definition: at32f435_437_xmc.h:504
xmc_sdram_cmd_type::auto_refresh
uint32_t auto_refresh
Definition: at32f435_437_xmc.h:505
xmc_sdram_cmd_type::data
uint32_t data
Definition: at32f435_437_xmc.h:506
xmc_sdram_cmd_type::cmd
xmc_command_type cmd
Definition: at32f435_437_xmc.h:503
xmc_sdram_init_type
xmc sdram init structure definition
Definition: at32f435_437_xmc.h:469
xmc_sdram_init_type::row_address
xmc_sdram_row_type row_address
Definition: at32f435_437_xmc.h:477
xmc_sdram_init_type::burst_read
uint8_t burst_read
Definition: at32f435_437_xmc.h:474
xmc_sdram_init_type::clkdiv
xmc_sdram_clkdiv_type clkdiv
Definition: at32f435_437_xmc.h:472
xmc_sdram_init_type::write_protection
uint8_t write_protection
Definition: at32f435_437_xmc.h:473
xmc_sdram_init_type::column_address
xmc_sdram_column_type column_address
Definition: at32f435_437_xmc.h:476
xmc_sdram_init_type::read_delay
uint8_t read_delay
Definition: at32f435_437_xmc.h:475
xmc_sdram_init_type::width
xmc_sdram_width_type width
Definition: at32f435_437_xmc.h:479
xmc_sdram_init_type::cas
xmc_sdram_cas_type cas
Definition: at32f435_437_xmc.h:478
xmc_sdram_init_type::sdram_bank
xmc_sdram_bank_type sdram_bank
Definition: at32f435_437_xmc.h:470
xmc_sdram_init_type::internel_banks
xmc_sdram_inbk_type internel_banks
Definition: at32f435_437_xmc.h:471
xmc_sdram_timing_type
xmc sdram timing structure definition
Definition: at32f435_437_xmc.h:487
xmc_sdram_timing_type::trcd
xmc_sdram_delay_type trcd
Definition: at32f435_437_xmc.h:494
xmc_sdram_timing_type::trc
xmc_sdram_delay_type trc
Definition: at32f435_437_xmc.h:491
xmc_sdram_timing_type::tmrd
xmc_sdram_delay_type tmrd
Definition: at32f435_437_xmc.h:488
xmc_sdram_timing_type::twr
xmc_sdram_delay_type twr
Definition: at32f435_437_xmc.h:492
xmc_sdram_timing_type::tras
xmc_sdram_delay_type tras
Definition: at32f435_437_xmc.h:490
xmc_sdram_timing_type::txsr
xmc_sdram_delay_type txsr
Definition: at32f435_437_xmc.h:489
xmc_sdram_timing_type::trp
xmc_sdram_delay_type trp
Definition: at32f435_437_xmc.h:493


AT32F435/437 Firmwary Library: xmc_sram.h File Reference

  • at_start_f437
  • examples
  • xmc
  • sram
  • inc
Functions
at_start_f437/examples/xmc/sram/inc/xmc_sram.h File Reference

header file for the nand configuration. More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void | sram_init (void)
init sram interface More...
void | sram_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc sram memory. More...
void | sram_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc sram memory. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...

Detailed Description

header file for the nand configuration.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/xmc/sram/inc/xmc_sram.h.


AT32F435/437 Firmwary Library: xmc_sram.h Source File

  • at_start_f437
  • examples
  • xmc
  • sram
  • inc
at_start_f437/examples/xmc/sram/inc/xmc_sram.h
Go to the documentation of this file.
1
27#ifndef __XMC_SRAM_H
28#define __XMC_SRAM_H
29
30#include "at32f435_437_board.h"
31
32
33
34void sram_init(void);
35void sram_writebuffer(uint16_t* pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite);
36void sram_readbuffer(uint16_t* pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread);
37void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset);
38
39#endif
at32f435_437_board.h
fill_buffer
void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer
Definition: at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c:520
sram_init
void sram_init(void)
init sram interface
Definition: at_start_f435/examples/xmc/sram/src/xmc_sram.c:44
sram_readbuffer
void sram_readbuffer(uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc sram memory.
Definition: at_start_f435/examples/xmc/sram/src/xmc_sram.c:249
sram_writebuffer
void sram_writebuffer(uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc sram memory.
Definition: at_start_f435/examples/xmc/sram/src/xmc_sram.c:229


AT32F435/437 Firmwary Library: xmc_sram.c File Reference

  • at_start_f437
  • examples
  • xmc
  • sram
  • src
Macros | Functions
at_start_f437/examples/xmc/sram/src/xmc_sram.c File Reference

sram program. More...

#include "xmc_sram.h"

Go to the source code of this file.

Macros

#define BANK1_SRAM3_ADDR ((uint32_t)0x68000000)

Functions

void | sram_init (void)
init sram interface More...
void | sram_writebuffer (uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc sram memory. More...
void | sram_readbuffer (uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc sram memory. More...
void | fill_buffer (uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
fill the global buffer More...

Detailed Description

sram program.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at_start_f437/examples/xmc/sram/src/xmc_sram.c.


AT32F435/437 Firmwary Library: xmc_sram.c Source File

  • at_start_f437
  • examples
  • xmc
  • sram
  • src
at_start_f437/examples/xmc/sram/src/xmc_sram.c
Go to the documentation of this file.
1
27#include "xmc_sram.h"
28
37#define BANK1_SRAM3_ADDR ((uint32_t)0x68000000)
38
44void sram_init(void)
45{
46 gpio_init_type gpio_init_struct = {0};
47 xmc_norsram_init_type xmc_norsram_init_struct;
48 xmc_norsram_timing_init_type rw_timing_struct, w_timing_struct;
49
50 /* enable the gpio clock */
51 crm_periph_clock_enable(CRM_GPIOF_PERIPH_CLOCK, TRUE);
52 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
53 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
54 crm_periph_clock_enable(CRM_GPIOG_PERIPH_CLOCK, TRUE);
55
56 /* enable the xmc clock */
57 crm_periph_clock_enable(CRM_XMC_PERIPH_CLOCK, TRUE);
58
59 /*-- gpio configuration ------------------------------------------------------*/
60 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE0, GPIO_MUX_12);
61 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE1, GPIO_MUX_12);
62 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE2, GPIO_MUX_12);
63 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE3, GPIO_MUX_12);
64 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE4, GPIO_MUX_12);
65 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE5, GPIO_MUX_12);
66 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE12, GPIO_MUX_12);
67 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE13, GPIO_MUX_12);
68 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE14, GPIO_MUX_12);
69 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE15, GPIO_MUX_12);
70 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE0, GPIO_MUX_12);
71 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE1, GPIO_MUX_12);
72 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE2, GPIO_MUX_12);
73 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE3, GPIO_MUX_12);
74 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE4, GPIO_MUX_12);
75 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE5, GPIO_MUX_12);
76 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE13, GPIO_MUX_12);
77 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE14, GPIO_MUX_12);
78 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE10, GPIO_MUX_12);
79 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE11, GPIO_MUX_12);
80 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE12, GPIO_MUX_12);
81 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE13, GPIO_MUX_12);
82 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE0, GPIO_MUX_12);
83 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_12);
84 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE8, GPIO_MUX_12);
85 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE9, GPIO_MUX_12);
86 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE10, GPIO_MUX_12);
87 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE14, GPIO_MUX_12);
88 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE15, GPIO_MUX_12);
89 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_12);
90 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE5, GPIO_MUX_12);
91 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE3, GPIO_MUX_12);
92 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE4, GPIO_MUX_12);
93 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE5, GPIO_MUX_12);
94 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE6, GPIO_MUX_12);
95 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE2, GPIO_MUX_12);
96 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE13, GPIO_MUX_12);
97 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE7, GPIO_MUX_12);
98 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE8, GPIO_MUX_12);
99 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE9, GPIO_MUX_12);
100 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE10, GPIO_MUX_12);
101 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE11, GPIO_MUX_12);
102 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE12, GPIO_MUX_12);
103 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE14, GPIO_MUX_12);
104 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE15, GPIO_MUX_12);
105 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE0, GPIO_MUX_12);
106 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE1, GPIO_MUX_12);
107
108 /* address lines configuration */
109 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_2 | GPIO_PINS_3 | GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_12 | GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
110 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
111 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
112 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
113 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
114 gpio_init(GPIOF, &gpio_init_struct);
115
116 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_2 | GPIO_PINS_3 | GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_13 | GPIO_PINS_14;
117 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
118 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
119 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
120 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
121 gpio_init(GPIOG, &gpio_init_struct);
122
123 gpio_init_struct.gpio_pins = GPIO_PINS_11 | GPIO_PINS_12 | GPIO_PINS_13;
124 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
125 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
126 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
127 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
128 gpio_init(GPIOD, &gpio_init_struct);
129
130 gpio_init_struct.gpio_pins = GPIO_PINS_3 | GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6 | GPIO_PINS_2;
131 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
132 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
133 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
134 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
135 gpio_init(GPIOE, &gpio_init_struct);
136
137 /* data lines configuration */
138 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_14 | GPIO_PINS_15;
139 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
140 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
141 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
142 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
143 gpio_init(GPIOD, &gpio_init_struct);
144
145 gpio_init_struct.gpio_pins = GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11 | GPIO_PINS_12 | GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
146 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
147 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
148 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
149 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
150 gpio_init(GPIOE, &gpio_init_struct);
151
152 /* ne/noe/nwe/nbl0/nbl1 lines configuration */
153 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
154 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
155 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
156 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
157 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
158 gpio_init(GPIOE, &gpio_init_struct);
159
160 gpio_init_struct.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5;
161 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
162 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
163 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
164 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
165 gpio_init(GPIOD, &gpio_init_struct);
166
167 gpio_init_struct.gpio_pins = GPIO_PINS_10;
168 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
169 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
170 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
171 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
172 gpio_init(GPIOG, &gpio_init_struct);
173
174
175 /*-- xmc configuration ------------------------------------------------------*/
176 xmc_norsram_default_para_init(&xmc_norsram_init_struct);
177 xmc_norsram_init_struct.subbank = XMC_BANK1_NOR_SRAM3;
178 xmc_norsram_init_struct.data_addr_multiplex = XMC_DATA_ADDR_MUX_DISABLE;
179 xmc_norsram_init_struct.device = XMC_DEVICE_SRAM;
180 xmc_norsram_init_struct.bus_type = XMC_BUSTYPE_16_BITS;
181 xmc_norsram_init_struct.burst_mode_enable = XMC_BURST_MODE_DISABLE;
182 xmc_norsram_init_struct.asynwait_enable = XMC_ASYN_WAIT_DISABLE;
183 xmc_norsram_init_struct.wait_signal_lv = XMC_WAIT_SIGNAL_LEVEL_LOW;
184 xmc_norsram_init_struct.wrapped_mode_enable = XMC_WRAPPED_MODE_DISABLE;
185 xmc_norsram_init_struct.wait_signal_config = XMC_WAIT_SIGNAL_SYN_BEFORE;
186 xmc_norsram_init_struct.write_enable = XMC_WRITE_OPERATION_ENABLE;
187 xmc_norsram_init_struct.wait_signal_enable = XMC_WAIT_SIGNAL_DISABLE;
188 xmc_norsram_init_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
189 xmc_norsram_init_struct.write_burst_syn = XMC_WRITE_BURST_SYN_DISABLE;
190 xmc_nor_sram_init(&xmc_norsram_init_struct);
191
192 /* timing configuration */
193 xmc_norsram_timing_default_para_init(&rw_timing_struct, &w_timing_struct);
194 rw_timing_struct.subbank = XMC_BANK1_NOR_SRAM3;
195 rw_timing_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
196 rw_timing_struct.addr_setup_time = 0x2;
197 rw_timing_struct.addr_hold_time = 0x0;
198 rw_timing_struct.data_setup_time = 0xc;
199 rw_timing_struct.bus_latency_time = 0x0;
200 rw_timing_struct.clk_psc = 0x0;
201 rw_timing_struct.data_latency_time = 0x0;
202 rw_timing_struct.mode = XMC_ACCESS_MODE_A;
203 w_timing_struct.subbank = XMC_BANK1_NOR_SRAM3;
204 w_timing_struct.write_timing_enable = XMC_WRITE_TIMING_ENABLE;
205 w_timing_struct.addr_setup_time = 0x2;
206 w_timing_struct.addr_hold_time = 0x0;
207 w_timing_struct.data_setup_time = 0xc;
208 w_timing_struct.bus_latency_time = 0x0;
209 w_timing_struct.clk_psc = 0x0;
210 w_timing_struct.data_latency_time = 0x0;
211 w_timing_struct.mode = XMC_ACCESS_MODE_A;
212 xmc_nor_sram_timing_config(&rw_timing_struct, &w_timing_struct);
213
214 /* bus turnaround phase for consecutive read duration and consecutive write duration */
215 xmc_ext_timing_config(XMC_BANK1_NOR_SRAM3, 0x08, 0x08);
216
217 /* enable xmc_bank1_nor_sram3 */
218 xmc_nor_sram_enable(XMC_BANK1_NOR_SRAM3, TRUE);
219}
220
229void sram_writebuffer(uint16_t* pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
230{
231 for(; numhalfwordtowrite != 0; numhalfwordtowrite--)
232 {
234 *(__IO uint16_t *) (BANK1_SRAM3_ADDR + writeaddr) = *pbuffer++;
235
237 writeaddr += 2;
238 }
239}
240
249void sram_readbuffer(uint16_t* pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
250{
251 for(; numhalfwordtoread != 0; numhalfwordtoread--)
252 {
254 *pbuffer++ = *(__IO uint16_t*) (BANK1_SRAM3_ADDR + readaddr);
255
257 readaddr += 2;
258 }
259}
260
267void fill_buffer(uint16_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
268{
269 uint16_t indextmp = 0;
270
271 /* put in global buffer same values */
272 for (indextmp = 0; indextmp < bufferlenght; indextmp++ )
273 {
274 pbuffer[indextmp] = indextmp + offset;
275 }
276}
277
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
fill_buffer
void fill_buffer(uint8_t *pbuffer, uint16_t bufferlenght, uint32_t offset)
Fill the global buffer.
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:55
BANK1_SRAM3_ADDR
#define BANK1_SRAM3_ADDR
Definition: at_start_f437/examples/xmc/sram/src/xmc_sram.c:37
sram_init
void sram_init(void)
init sram interface
Definition: at_start_f437/examples/xmc/sram/src/xmc_sram.c:44
sram_readbuffer
void sram_readbuffer(uint16_t *pbuffer, uint32_t readaddr, uint32_t numhalfwordtoread)
reads a block of data from the xmc sram memory.
Definition: at_start_f437/examples/xmc/sram/src/xmc_sram.c:249
sram_writebuffer
void sram_writebuffer(uint16_t *pbuffer, uint32_t writeaddr, uint32_t numhalfwordtowrite)
writes a half-word buffer to the xmc sram memory.
Definition: at_start_f437/examples/xmc/sram/src/xmc_sram.c:229
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_XMC_PERIPH_CLOCK
@ CRM_XMC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:123
CRM_GPIOF_PERIPH_CLOCK
@ CRM_GPIOF_PERIPH_CLOCK
Definition: at32f435_437_crm.h:110
CRM_GPIOG_PERIPH_CLOCK
@ CRM_GPIOG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:111
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f435_437_gpio.h:146
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_12
@ GPIO_MUX_12
Definition: at32f435_437_gpio.h:168
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f435_437_gpio.h:64
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOG
#define GPIOG
Definition: at32f435_437_gpio.h:527
GPIOF
#define GPIOF
Definition: at32f435_437_gpio.h:526
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
xmc_nor_sram_init
void xmc_nor_sram_init(xmc_norsram_init_type *xmc_norsram_init_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_norsraminitstruct.
Definition: at32f435_437_xmc.c:78
xmc_norsram_timing_default_para_init
void xmc_norsram_timing_default_para_init(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
fill each xmc_rw_timing_struct and xmc_w_timing_struct member with its default value.
Definition: at32f435_437_xmc.c:176
xmc_nor_sram_timing_config
void xmc_nor_sram_timing_config(xmc_norsram_timing_init_type *xmc_rw_timing_struct, xmc_norsram_timing_init_type *xmc_w_timing_struct)
initialize the xmc nor/sram banks according to the specified parameters in the xmc_rw_timing_struct a...
Definition: at32f435_437_xmc.c:113
xmc_ext_timing_config
void xmc_ext_timing_config(xmc_nor_sram_subbank_type xmc_sub_bank, uint16_t w2w_timing, uint16_t r2r_timing)
config the bus turnaround phase.
Definition: at32f435_437_xmc.c:227
xmc_norsram_default_para_init
void xmc_norsram_default_para_init(xmc_norsram_init_type *xmc_nor_sram_init_struct)
fill each xmc_nor_sram_init_struct member with its default value.
Definition: at32f435_437_xmc.c:150
xmc_nor_sram_enable
void xmc_nor_sram_enable(xmc_nor_sram_subbank_type xmc_subbank, confirm_state new_state)
enable or disable the specified nor/sram memory bank.
Definition: at32f435_437_xmc.c:210
XMC_WAIT_SIGNAL_DISABLE
@ XMC_WAIT_SIGNAL_DISABLE
Definition: at32f435_437_xmc.h:101
XMC_WAIT_SIGNAL_SYN_BEFORE
@ XMC_WAIT_SIGNAL_SYN_BEFORE
Definition: at32f435_437_xmc.h:196
XMC_WRITE_OPERATION_ENABLE
@ XMC_WRITE_OPERATION_ENABLE
Definition: at32f435_437_xmc.h:93
XMC_WRITE_BURST_SYN_DISABLE
@ XMC_WRITE_BURST_SYN_DISABLE
Definition: at32f435_437_xmc.h:110
XMC_BURST_MODE_DISABLE
@ XMC_BURST_MODE_DISABLE
Definition: at32f435_437_xmc.h:65
XMC_DATA_ADDR_MUX_DISABLE
@ XMC_DATA_ADDR_MUX_DISABLE
Definition: at32f435_437_xmc.h:56
XMC_BUSTYPE_16_BITS
@ XMC_BUSTYPE_16_BITS
Definition: at32f435_437_xmc.h:179
XMC_WRITE_TIMING_ENABLE
@ XMC_WRITE_TIMING_ENABLE
Definition: at32f435_437_xmc.h:120
XMC_BANK1_NOR_SRAM3
@ XMC_BANK1_NOR_SRAM3
Definition: at32f435_437_xmc.h:148
XMC_ASYN_WAIT_DISABLE
@ XMC_ASYN_WAIT_DISABLE
Definition: at32f435_437_xmc.h:74
XMC_WRAPPED_MODE_DISABLE
@ XMC_WRAPPED_MODE_DISABLE
Definition: at32f435_437_xmc.h:83
XMC_ACCESS_MODE_A
@ XMC_ACCESS_MODE_A
Definition: at32f435_437_xmc.h:205
XMC_WAIT_SIGNAL_LEVEL_LOW
@ XMC_WAIT_SIGNAL_LEVEL_LOW
Definition: at32f435_437_xmc.h:187
XMC_DEVICE_SRAM
@ XMC_DEVICE_SRAM
Definition: at32f435_437_xmc.h:168
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
xmc_norsram_init_type
xmc nor/sram init structure definition
Definition: at32f435_437_xmc.h:409
xmc_norsram_init_type::wait_signal_enable
xmc_wait_signal_type wait_signal_enable
Definition: at32f435_437_xmc.h:420
xmc_norsram_init_type::data_addr_multiplex
xmc_data_addr_mux_type data_addr_multiplex
Definition: at32f435_437_xmc.h:411
xmc_norsram_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:421
xmc_norsram_init_type::burst_mode_enable
xmc_burst_access_mode_type burst_mode_enable
Definition: at32f435_437_xmc.h:414
xmc_norsram_init_type::bus_type
xmc_data_width_type bus_type
Definition: at32f435_437_xmc.h:413
xmc_norsram_init_type::device
xmc_memory_type device
Definition: at32f435_437_xmc.h:412
xmc_norsram_init_type::wait_signal_lv
xmc_wait_signal_polarity_type wait_signal_lv
Definition: at32f435_437_xmc.h:416
xmc_norsram_init_type::wrapped_mode_enable
xmc_wrap_mode_type wrapped_mode_enable
Definition: at32f435_437_xmc.h:417
xmc_norsram_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:410
xmc_norsram_init_type::write_burst_syn
xmc_write_burst_type write_burst_syn
Definition: at32f435_437_xmc.h:422
xmc_norsram_init_type::asynwait_enable
xmc_asyn_wait_type asynwait_enable
Definition: at32f435_437_xmc.h:415
xmc_norsram_init_type::wait_signal_config
xmc_wait_timing_type wait_signal_config
Definition: at32f435_437_xmc.h:418
xmc_norsram_init_type::write_enable
xmc_write_operation_type write_enable
Definition: at32f435_437_xmc.h:419
xmc_norsram_timing_init_type
nor/sram banks timing parameters
Definition: at32f435_437_xmc.h:393
xmc_norsram_timing_init_type::write_timing_enable
xmc_extended_mode_type write_timing_enable
Definition: at32f435_437_xmc.h:395
xmc_norsram_timing_init_type::data_latency_time
uint32_t data_latency_time
Definition: at32f435_437_xmc.h:401
xmc_norsram_timing_init_type::addr_hold_time
uint32_t addr_hold_time
Definition: at32f435_437_xmc.h:397
xmc_norsram_timing_init_type::bus_latency_time
uint32_t bus_latency_time
Definition: at32f435_437_xmc.h:399
xmc_norsram_timing_init_type::addr_setup_time
uint32_t addr_setup_time
Definition: at32f435_437_xmc.h:396
xmc_norsram_timing_init_type::mode
xmc_access_mode_type mode
Definition: at32f435_437_xmc.h:402
xmc_norsram_timing_init_type::subbank
xmc_nor_sram_subbank_type subbank
Definition: at32f435_437_xmc.h:394
xmc_norsram_timing_init_type::clk_psc
uint32_t clk_psc
Definition: at32f435_437_xmc.h:400
xmc_norsram_timing_init_type::data_setup_time
uint32_t data_setup_time
Definition: at32f435_437_xmc.h:398


AT32F435/437 Firmwary Library: audio_conf.h Source File

  • middlewares
  • usbd_class
  • audio
audio/audio_conf.h
Go to the documentation of this file.
1
27 /* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AUDIO_CONF_H
29#define __AUDIO_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
47#define AUDIO_SUPPORT_SPK 1
48#define AUDIO_SUPPORT_MIC 1
49#define AUDIO_SUPPORT_FEEDBACK 1
50
51#define AUDIO_SUPPORT_FREQ_16K 0
52#define AUDIO_SUPPORT_FREQ_48K 1
53
54
55#define AUDIO_SUPPORT_FREQ (AUDIO_SUPPORT_FREQ_16K + \
56 AUDIO_SUPPORT_FREQ_48K \
57 )
58
59#define AUDIO_FREQ_16K 16000
60#define AUDIO_FREQ_48K 48000
61#define AUDIO_BITW_16 16
62
63#define AUDIO_MIC_CHANEL_NUM 2
64#define AUDIO_MIC_DEFAULT_BITW AUDIO_BITW_16
65
66#define AUDIO_SPK_CHANEL_NUM 2
67#define AUDIO_SPK_DEFAULT_BITW AUDIO_BITW_16
68
69
70#define AUDIO_SUPPORT_MAX_FREQ 48
71#define AUDIO_DEFAULT_FREQ AUDIO_FREQ_48K
72#define AUDIO_DEFAULT_BITW AUDIO_BITW_16
73
85#ifdef __cplusplus
86}
87#endif
88
89#endif
90


AT32F435/437 Firmwary Library: audio_class.c Source File

  • middlewares
  • usbd_class
  • audio
audio_class.c
Go to the documentation of this file.
1
26#include "usbd_core.h"
27#include "audio_class.h"
28#include "audio_desc.h"
29#include "audio_codec.h"
30
44static usb_sts_type class_init_handler(void *udev);
45static usb_sts_type class_clear_handler(void *udev);
46static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
47static usb_sts_type class_ept0_tx_handler(void *udev);
48static usb_sts_type class_ept0_rx_handler(void *udev);
49static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
50static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
51static usb_sts_type class_sof_handler(void *udev);
52static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
53
54static void audio_inisoincom_event(void *udev);
55static void audio_req_get_cur(void *udev, usb_setup_type *setup);
56static void audio_req_set_cur(void *udev, usb_setup_type *setup);
57static void audio_req_get_min(void *udev, usb_setup_type *setup);
58static void audio_req_get_max(void *udev, usb_setup_type *setup);
59static void audio_req_get_res(void *udev, usb_setup_type *setup);
60static void audio_get_interface(void *udev, usb_setup_type *setup);
61static void audio_set_interface(void *udev, usb_setup_type *setup);
62
63 usb_audio_type audio_struct = {0, 0, 0, 0, 0, 0x1400, 0, 0, 0, {0x0000, 0x1400, 0x33}, {0x0000, 0x1400, 0x33}, 0, 0};
64
65/* usb device class handler */
66usbd_class_handler audio_class_handler =
67{
68 class_init_handler,
69 class_clear_handler,
70 class_setup_handler,
71 class_ept0_tx_handler,
72 class_ept0_rx_handler,
73 class_in_handler,
74 class_out_handler,
75 class_sof_handler,
76 class_event_handler,
77 &audio_struct
78};
79
85static usb_sts_type class_init_handler(void *udev)
86{
87 usb_sts_type status = USB_OK;
88 usbd_core_type *pudev = (usbd_core_type *)udev;
89 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
90
91 /* open microphone in endpoint */
92 usbd_ept_open(pudev, USBD_AUDIO_MIC_IN_EPT, EPT_ISO_TYPE, AUDIO_MIC_IN_MAXPACKET_SIZE);
93
94 /* open speaker out endpoint */
95 usbd_ept_open(pudev, USBD_AUDIO_SPK_OUT_EPT, EPT_ISO_TYPE, AUDIO_SPK_OUT_MAXPACKET_SIZE);
96#if AUDIO_SUPPORT_FEEDBACK
97 /* open speaker feedback endpoint */
98 usbd_ept_open(pudev, USBD_AUDIO_FEEDBACK_EPT, EPT_ISO_TYPE, AUDIO_FEEDBACK_MAXPACKET_SIZE);
99#endif
100 /* start receive speaker out data */
101 usbd_ept_recv(pudev, USBD_AUDIO_SPK_OUT_EPT, paudio->audio_spk_data, AUDIO_SPK_OUT_MAXPACKET_SIZE);
102
103 return status;
104}
105
111static usb_sts_type class_clear_handler(void *udev)
112{
113 usb_sts_type status = USB_OK;
114 usbd_core_type *pudev = (usbd_core_type *)udev;
115
116 /* close in endpoint */
117 usbd_ept_close(pudev, USBD_AUDIO_MIC_IN_EPT);
118
119#if AUDIO_SUPPORT_FEEDBACK
120 /* close in endpoint */
121 usbd_ept_close(pudev, USBD_AUDIO_FEEDBACK_EPT);
122#endif
123
124 /* close out endpoint */
125 usbd_ept_close(pudev, USBD_AUDIO_SPK_OUT_EPT);
126
127 return status;
128}
129
136static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
137{
138 usb_sts_type status = USB_OK;
139 usbd_core_type *pudev = (usbd_core_type *)udev;
140 uint16_t len;
141
142 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
143 {
144 /* class request */
145 case USB_REQ_TYPE_CLASS:
146 switch(setup->bRequest)
147 {
148 case AUDIO_REQ_GET_CUR:
149 audio_req_get_cur(pudev, setup);
150 break;
151
152 case AUDIO_REQ_SET_CUR:
153 audio_req_set_cur(pudev, setup);
154 break;
155
156 case AUDIO_REQ_GET_MIN:
157 audio_req_get_min(pudev, setup);
158 break;
159
160 case AUDIO_REQ_GET_MAX:
161 audio_req_get_max(pudev, setup);
162 break;
163
164 case AUDIO_REQ_GET_RES:
165 audio_req_get_res(pudev, setup);
166 break;
167
168 default:
169 usbd_ctrl_unsupport(pudev);
170 break;
171 }
172 break;
173 /* standard request */
174 case USB_REQ_TYPE_STANDARD:
175 switch(setup->bRequest)
176 {
177 case USB_STD_REQ_GET_DESCRIPTOR:
178 if((setup->wValue >> 8) == AUDIO_DESCRIPTOR_TYPE)
179 {
180 usbd_desc_t *config = pudev->desc_handler->get_device_configuration();
181 len = MIN(AUDIO_DESCRIPTOR_SIZE, setup->wLength);
182 usbd_ctrl_send(pudev, config->descriptor + 18, len);
183 }
184 else
185 {
186 usbd_ctrl_unsupport(pudev);
187 }
188 break;
189 case USB_STD_REQ_GET_INTERFACE:
190 audio_get_interface(udev, setup);
191 break;
192
193 case USB_STD_REQ_SET_INTERFACE:
194 audio_set_interface(udev, setup);
195 usbd_ctrl_send_status(pudev);
196 break;
197
198 default:
199 break;
200 }
201 break;
202
203 default:
204 usbd_ctrl_unsupport(pudev);
205 break;
206 }
207 return status;
208}
209
215static usb_sts_type class_ept0_tx_handler(void *udev)
216{
217 usb_sts_type status = USB_OK;
218
219 /* ...user code... */
220
221 return status;
222}
223
229static usb_sts_type class_ept0_rx_handler(void *udev)
230{
231 usb_sts_type status = USB_OK;
232 usbd_core_type *pudev = (usbd_core_type *)udev;
233 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
234 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
235 /* ...user code... */
236 if( paudio->audio_cmd == AUDIO_REQ_SET_CUR)
237 {
238 /* class process */
239 switch( paudio->request_no)
240 {
241 case AUDIO_VOLUME_CONTROL:
242 if( paudio->interface == AUDIO_SPK_FEATURE_UNIT_ID)
243 {
244 paudio->spk_volume = (uint16_t)( paudio->g_audio_cur[0] |
245 ( paudio->g_audio_cur[1] << 8));
246 /* set volume */
247 audio_codec_set_spk_volume(paudio->spk_volume*100/paudio->spk_volume_limits[1]);
248 }
249 else
250 {
251 paudio->mic_volume = (uint16_t)(paudio->g_audio_cur[0] |
252 (paudio->g_audio_cur[1] << 8));
253
254 audio_codec_set_mic_volume(paudio->mic_volume*256/paudio->mic_volume_limits[1]);
255 }
256 break;
257 case AUDIO_MUTE_CONTROL:
258 if(paudio->interface == AUDIO_SPK_FEATURE_UNIT_ID)
259 {
260 paudio->spk_mute = paudio->g_audio_cur[0];
261 audio_codec_set_spk_mute(paudio->spk_mute);
262 }
263 else
264 {
265 paudio->mic_mute = paudio->g_audio_cur[0];
266 audio_codec_set_mic_mute(paudio->mic_mute);
267 }
268
269 break;
270 case AUDIO_FREQ_SET_CONTROL:
271 if(paudio->enpd == USBD_AUDIO_MIC_IN_EPT)
272 {
273 paudio->mic_freq = (paudio->g_audio_cur[0] |
274 (paudio->g_audio_cur[1] << 8) |
275 (paudio->g_audio_cur[2] << 16));
276 audio_codec_set_mic_freq(paudio->mic_freq);
277 }
278 else
279 {
280 paudio->spk_freq = (paudio->g_audio_cur[0] |
281 (paudio->g_audio_cur[1] << 8) |
282 (paudio->g_audio_cur[2] << 16));
283 audio_codec_set_spk_freq(paudio->spk_freq);
284 }
285 break;
286 default:
287 break;
288 }
289 }
290
291 return status;
292}
293
300static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
301{
302 usb_sts_type status = USB_OK;
303 usbd_core_type *pudev = (usbd_core_type *)udev;
304 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
305 uint32_t len = 0;
306
307 /* ...user code...
308 trans next packet data
309 */
310 if((ept_num & 0x7F) == (USBD_AUDIO_MIC_IN_EPT & 0x7F))
311 {
312 len = audio_codec_mic_get_data(paudio->audio_mic_data);
313 usbd_flush_tx_fifo(udev, USBD_AUDIO_MIC_IN_EPT);
314 usbd_ept_send(udev, USBD_AUDIO_MIC_IN_EPT, paudio->audio_mic_data, len);
315 }
316
317 else if((ept_num & 0x7F) == (USBD_AUDIO_FEEDBACK_EPT & 0x7F))
318 {
319 paudio->audio_feedback_state = 0;
320 }
321
322 return status;
323}
324
331static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
332{
333 usb_sts_type status = USB_OK;
334 usbd_core_type *pudev = (usbd_core_type *)udev;
335 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
336 uint16_t g_rxlen;
337
338 /* get endpoint receive data length */
339 g_rxlen = usbd_get_recv_len(pudev, ept_num);
340
341 if((ept_num & 0x7F) == (USBD_AUDIO_SPK_OUT_EPT & 0x7F))
342 {
343 /* speaker data*/
344 audio_codec_spk_fifo_write(paudio->audio_spk_data, g_rxlen);
345 paudio->audio_spk_out_stage = 1;
346 /* get next data */
347 usbd_ept_recv(pudev, USBD_AUDIO_SPK_OUT_EPT, paudio->audio_spk_data, AUDIO_SPK_OUT_MAXPACKET_SIZE);
348 }
349
350 return status;
351}
352
358static usb_sts_type class_sof_handler(void *udev)
359{
360 usb_sts_type status = USB_OK;
361 usbd_core_type *pudev = (usbd_core_type *)udev;
362 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
363
364#if AUDIO_SUPPORT_FEEDBACK
365 if(paudio->audio_spk_out_stage & 2)
366 {
367 paudio->audio_spk_out_stage = 0;
368 }
369 else if( paudio->audio_spk_out_stage )
370 {
371 paudio->audio_spk_out_stage |= 2;
372
373 if( 0 == paudio->audio_feedback_state )
374 {
375 usbd_core_type *pudev = (usbd_core_type *)udev;
376 int len = audio_codec_spk_feedback(paudio->audio_feed_back);
377 usbd_ept_send(pudev, USBD_AUDIO_FEEDBACK_EPT, paudio->audio_feed_back, len);
378 paudio->audio_feedback_state = 1;
379 }
380 if( paudio->audio_feedback_state++ > (1<<FEEDBACK_REFRESH_TIME) ) //timeout
381 {
382 usbd_core_type *pudev = (usbd_core_type *)udev;
383 int len = audio_codec_spk_feedback(paudio->audio_feed_back);
384 usbd_flush_tx_fifo(pudev, USBD_AUDIO_FEEDBACK_EPT);
385 usbd_ept_send(pudev, USBD_AUDIO_FEEDBACK_EPT, paudio->audio_feed_back, len);
386 paudio->audio_feedback_state = 1;
387 }
388 }
389#endif
390 /* ...user code... */
391
392 return status;
393}
394
401static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
402{
403 usb_sts_type status = USB_OK;
404 usbd_core_type *pudev = (usbd_core_type *)udev;
405 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
406 switch(event)
407 {
408 case USBD_RESET_EVENT:
409
410 /* ...user code... */
411
412 break;
413 case USBD_SUSPEND_EVENT:
414 paudio->spk_alt_setting = 0;
415 audio_codec_spk_alt_setting(paudio->spk_alt_setting);
416 paudio->mic_alt_setting = 0;
417 audio_codec_mic_alt_setting(paudio->spk_alt_setting);
418 /* ...user code... */
419
420 break;
421 case USBD_WAKEUP_EVENT:
422 /* ...user code... */
423
424 break;
425 case USBD_INISOINCOM_EVENT:
426 audio_inisoincom_event(udev);
427 break;
428
429 default:
430 break;
431 }
432 return status;
433}
434
440static void audio_inisoincom_event(void *udev)
441{
442#if 0
443 usbd_core_type *pudev = (usbd_core_type *)udev;
444 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
445 uint32_t fnsof = OTG_DEVICE(pudev->usb_reg)->dsts_bit.soffn;
446 uint32_t epctl_fb = USB_INEPT(pudev->usb_reg, (USBD_AUDIO_FEEDBACK_EPT&0x7F))->diepctl_bit.dpid;
447 uint32_t epctl_in = USB_INEPT(pudev->usb_reg, (USBD_AUDIO_MIC_IN_EPT&0x7F))->diepctl_bit.dpid;
448 uint32_t len = 0;
449
450 if((fnsof & 0x1) == epctl_fb)
451 {
452 USB_INEPT(pudev->usb_reg, (USBD_AUDIO_FEEDBACK_EPT&0x7F))->diepctl_bit.eptdis = 1;
453 USB_INEPT(pudev->usb_reg, (USBD_AUDIO_FEEDBACK_EPT&0x7F))->diepctl_bit.snak = 1;
454 usb_flush_tx_fifo(pudev->usb_reg, USBD_AUDIO_FEEDBACK_EPT&0x7F);
455
456 usbd_ept_send(pudev, USBD_AUDIO_FEEDBACK_EPT, paudio->audio_feed_back, 3);
457 }
458
459 if((fnsof & 0x1) == epctl_in)
460 {
461 USB_INEPT(pudev->usb_reg, (USBD_AUDIO_MIC_IN_EPT&0x7F))->diepctl_bit.eptdis = 1;
462 USB_INEPT(pudev->usb_reg, (USBD_AUDIO_MIC_IN_EPT&0x7F))->diepctl_bit.snak = 1;
463 usb_flush_tx_fifo(pudev->usb_reg, USBD_AUDIO_MIC_IN_EPT&0x7F);
464
465 len = audio_codec_mic_get_data(paudio->audio_mic_data);
466 usbd_ept_send(pudev, USBD_AUDIO_MIC_IN_EPT, paudio->audio_mic_data, len);
467 }
468#endif
469}
470
477static void audio_req_get_cur(void *udev, usb_setup_type *setup)
478{
479 usbd_core_type *pudev = (usbd_core_type *)udev;
480 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
481 if(HBYTE(setup->wIndex) == AUDIO_SPK_FEATURE_UNIT_ID)
482 {
483 if(HBYTE(setup->wValue) == AUDIO_MUTE_CONTROL)
484 {
485 paudio->g_audio_cur[0] = paudio->spk_mute;
486 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
487 }
488 else
489 {
490 *((uint16_t *)paudio->g_audio_cur) = paudio->spk_volume;
491 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
492 }
493 }
494 else
495 {
496 if(HBYTE(setup->wValue) == AUDIO_MUTE_CONTROL)
497 {
498 paudio->g_audio_cur[0] = paudio->mic_mute;
499 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
500 }
501 else
502 {
503 *((uint16_t *)paudio->g_audio_cur) = paudio->mic_volume;
504 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
505 }
506
507 }
508}
509
516static void audio_req_set_cur(void *udev, usb_setup_type *setup)
517{
518 usbd_core_type *pudev = (usbd_core_type *)udev;
519 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
520 if(setup->wLength > 0)
521 {
522 usbd_ctrl_recv(pudev, paudio->g_audio_cur, setup->wLength);
523
524 paudio->audio_cmd = AUDIO_REQ_SET_CUR;
525 paudio->audio_cmd_len = setup->wLength;
526
527 switch(setup->bmRequestType & AUDIO_REQ_CONTROL_MASK)
528 {
529 case AUDIO_REQ_CONTROL_INTERFACE:
530 paudio->interface = HBYTE(setup->wIndex);
531 if(HBYTE(setup->wValue) == AUDIO_MUTE_CONTROL)
532 {
533 paudio->request_no = AUDIO_MUTE_CONTROL;
534 }
535 else
536 {
537 paudio->request_no = AUDIO_VOLUME_CONTROL;
538 }
539 break;
540 case AUDIO_REQ_CONTROL_ENDPOINT:
541 paudio->enpd = setup->wIndex;
542 paudio->request_no = AUDIO_FREQ_SET_CONTROL;
543 break;
544 default:
545 break;
546 }
547 }
548}
549
556static void audio_req_get_min(void *udev, usb_setup_type *setup)
557{
558 usbd_core_type *pudev = (usbd_core_type *)udev;
559 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
560 if(HBYTE(setup->wIndex) == AUDIO_SPK_FEATURE_UNIT_ID)
561 {
562 *((uint16_t *)paudio->g_audio_cur) = paudio->spk_volume_limits[0];
563 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
564 }
565 else
566 {
567 *((uint16_t *)paudio->g_audio_cur) = paudio->mic_volume_limits[0];
568 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
569 }
570}
571
578static void audio_req_get_max(void *udev, usb_setup_type *setup)
579{
580 usbd_core_type *pudev = (usbd_core_type *)udev;
581 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
582 if(HBYTE(setup->wIndex) == AUDIO_SPK_FEATURE_UNIT_ID)
583 {
584 *((uint16_t *)paudio->g_audio_cur) = paudio->spk_volume_limits[1];
585 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
586 }
587 else
588 {
589 *((uint16_t *)paudio->g_audio_cur) = paudio->mic_volume_limits[1];
590 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
591 }
592}
593
600static void audio_req_get_res(void *udev, usb_setup_type *setup)
601{
602 usbd_core_type *pudev = (usbd_core_type *)udev;
603 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
604 if(HBYTE(setup->wIndex) == AUDIO_SPK_FEATURE_UNIT_ID)
605 {
606 *((uint16_t *)paudio->g_audio_cur) = paudio->spk_volume_limits[2];
607 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
608 }
609 else
610 {
611 *((uint16_t *)paudio->g_audio_cur) = paudio->mic_volume_limits[2];
612 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
613 }
614}
615
622static void audio_set_interface(void *udev, usb_setup_type *setup)
623{
624 uint32_t len;
625 usbd_core_type *pudev = (usbd_core_type *)udev;
626 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
627 if(LBYTE(setup->wIndex) == AUDIO_SPK_INTERFACE_NUMBER)
628 {
629 paudio->spk_alt_setting = setup->wValue;
630 audio_codec_spk_alt_setting(paudio->spk_alt_setting);
631 if(paudio->spk_alt_setting )
632 {
633 usbd_ept_recv(pudev, USBD_AUDIO_SPK_OUT_EPT, paudio->audio_spk_data, AUDIO_SPK_OUT_MAXPACKET_SIZE);
634 }
635
636 }
637 else if(LBYTE(setup->wIndex) == AUDIO_MIC_INTERFACE_NUMBER)
638 {
639 paudio->mic_alt_setting = setup->wValue;
640 audio_codec_mic_alt_setting(paudio->mic_alt_setting);
641 if(paudio->mic_alt_setting)
642 {
643 len = audio_codec_mic_get_data(paudio->audio_mic_data);
644 usbd_ept_send(pudev, USBD_AUDIO_MIC_IN_EPT, paudio->audio_mic_data, len);
645 }
646 }
647
648}
649
650
657static void audio_get_interface(void *udev, usb_setup_type *setup)
658{
659 usbd_core_type *pudev = (usbd_core_type *)udev;
660 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
661 if(LBYTE(setup->wIndex) == AUDIO_SPK_INTERFACE_NUMBER)
662 {
663 usbd_ctrl_send(pudev, (uint8_t *)&paudio->spk_alt_setting, 1);
664 }
665 else if(LBYTE(setup->wIndex) == AUDIO_MIC_INTERFACE_NUMBER)
666 {
667 usbd_ctrl_send(pudev, (uint8_t *)&paudio->mic_alt_setting, 1);
668 }
669
670}
671
672
audio_class.h
usb audio class file
audio_desc.h
usb audio descriptor header file
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
AUDIO_DESCRIPTOR_TYPE
#define AUDIO_DESCRIPTOR_TYPE
audio descriptor type
Definition: audio_class.h:83
AUDIO_MIC_IN_MAXPACKET_SIZE
#define AUDIO_MIC_IN_MAXPACKET_SIZE
Definition: audio_class.h:62
AUDIO_MUTE_CONTROL
#define AUDIO_MUTE_CONTROL
audio set cur type define
Definition: audio_class.h:76
AUDIO_REQ_CONTROL_INTERFACE
#define AUDIO_REQ_CONTROL_INTERFACE
request type define
Definition: audio_class.h:69
AUDIO_SPK_OUT_MAXPACKET_SIZE
#define AUDIO_SPK_OUT_MAXPACKET_SIZE
Definition: audio_class.h:63
AUDIO_VOLUME_CONTROL
#define AUDIO_VOLUME_CONTROL
Definition: audio_class.h:77
AUDIO_FREQ_SET_CONTROL
#define AUDIO_FREQ_SET_CONTROL
Definition: audio_class.h:78
AUDIO_REQ_CONTROL_ENDPOINT
#define AUDIO_REQ_CONTROL_ENDPOINT
Definition: audio_class.h:70
FEEDBACK_REFRESH_TIME
#define FEEDBACK_REFRESH_TIME
Definition: audio_class.h:65
AUDIO_REQ_CONTROL_MASK
#define AUDIO_REQ_CONTROL_MASK
Definition: audio_class.h:71
USBD_AUDIO_SPK_OUT_EPT
#define USBD_AUDIO_SPK_OUT_EPT
Definition: audio_class.h:55
USBD_AUDIO_MIC_IN_EPT
#define USBD_AUDIO_MIC_IN_EPT
endpoint define
Definition: audio_class.h:54
AUDIO_DESCRIPTOR_SIZE
#define AUDIO_DESCRIPTOR_SIZE
Definition: audio_class.h:84
USBD_AUDIO_FEEDBACK_EPT
#define USBD_AUDIO_FEEDBACK_EPT
Definition: audio_class.h:56
AUDIO_FEEDBACK_MAXPACKET_SIZE
#define AUDIO_FEEDBACK_MAXPACKET_SIZE
Definition: audio_class.h:64
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: audio_class.c:358
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: audio_class.c:300
audio_inisoincom_event
static void audio_inisoincom_event(void *udev)
usb audio in iso incom event
Definition: audio_class.c:440
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: audio_class.c:111
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: audio_class.c:136
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: audio_class.c:215
audio_class_handler
usbd_class_handler audio_class_handler
Definition: audio_class.c:66
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: audio_class.c:229
audio_req_get_res
static void audio_req_get_res(void *udev, usb_setup_type *setup)
usb audio request get res
Definition: audio_class.c:600
audio_get_interface
static void audio_get_interface(void *udev, usb_setup_type *setup)
usb audio get interface
Definition: audio_class.c:657
audio_req_set_cur
static void audio_req_set_cur(void *udev, usb_setup_type *setup)
usb audio request set cur
Definition: audio_class.c:516
audio_struct
usb_audio_type audio_struct
Definition: audio_class.c:63
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: audio_class.c:401
audio_req_get_max
static void audio_req_get_max(void *udev, usb_setup_type *setup)
usb audio request get max
Definition: audio_class.c:578
audio_req_get_min
static void audio_req_get_min(void *udev, usb_setup_type *setup)
usb audio request get min
Definition: audio_class.c:556
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: audio_class.c:85
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: audio_class.c:331
audio_req_get_cur
static void audio_req_get_cur(void *udev, usb_setup_type *setup)
usb audio request get cur
Definition: audio_class.c:477
audio_set_interface
static void audio_set_interface(void *udev, usb_setup_type *setup)
usb audio set interface
Definition: audio_class.c:622
AUDIO_REQ_GET_CUR
#define AUDIO_REQ_GET_CUR
Definition: audio_desc.h:113
AUDIO_SPK_INTERFACE_NUMBER
#define AUDIO_SPK_INTERFACE_NUMBER
Definition: audio_desc.h:180
AUDIO_MIC_INTERFACE_NUMBER
#define AUDIO_MIC_INTERFACE_NUMBER
audio interface number
Definition: audio_desc.h:178
AUDIO_REQ_GET_MAX
#define AUDIO_REQ_GET_MAX
Definition: audio_desc.h:117
AUDIO_REQ_GET_MIN
#define AUDIO_REQ_GET_MIN
Definition: audio_desc.h:115
AUDIO_SPK_FEATURE_UNIT_ID
#define AUDIO_SPK_FEATURE_UNIT_ID
Definition: audio_desc.h:172
AUDIO_REQ_GET_RES
#define AUDIO_REQ_GET_RES
Definition: audio_desc.h:119
AUDIO_REQ_SET_CUR
#define AUDIO_REQ_SET_CUR
Definition: audio_desc.h:112
audio_codec_mic_alt_setting
void audio_codec_mic_alt_setting(uint32_t alt_seting)
audio codec microphone alt setting config
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:173
audio_codec_set_spk_volume
void audio_codec_set_spk_volume(uint16_t volume)
audio codec set speaker volume
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:221
audio_codec_set_spk_mute
void audio_codec_set_spk_mute(uint8_t mute)
audio codec set speaker mute
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:199
audio_codec_set_mic_freq
void audio_codec_set_mic_freq(uint32_t freq)
audio codec set microphone freq
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:125
audio_codec_mic_get_data
uint32_t audio_codec_mic_get_data(uint8_t *buffer)
codec microphone get data
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:286
audio_codec_set_mic_mute
void audio_codec_set_mic_mute(uint8_t mute)
audio codec set microphone mute
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:188
audio_codec_spk_fifo_write
void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
audio codec interface
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:248
audio_codec_spk_feedback
uint8_t audio_codec_spk_feedback(uint8_t *feedback)
codec speaker feedback
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:232
audio_codec_set_mic_volume
void audio_codec_set_mic_volume(uint16_t volume)
audio codec set microphone volume
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:210
audio_codec_spk_alt_setting
void audio_codec_spk_alt_setting(uint32_t alt_seting)
audio codec speaker alt setting config
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:158
audio_codec_set_spk_freq
void audio_codec_set_spk_freq(uint32_t freq)
audio codec set speaker freq
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:141
AUDIO_SUPPORT_FEEDBACK
#define AUDIO_SUPPORT_FEEDBACK
Definition: audio/audio_conf.h:49
EPT_ISO_TYPE
@ EPT_ISO_TYPE
Definition: at32f435_437_usb.h:347
usb_flush_tx_fifo
void usb_flush_tx_fifo(otg_global_type *usbx, uint32_t fifo_num)
flush tx fifo
Definition: at32f435_437_usb.c:124
OTG_DEVICE
#define OTG_DEVICE(usbx)
Definition: at32f435_437_usb.h:1331
USB_INEPT
#define USB_INEPT(usbx, eptn)
Definition: at32f435_437_usb.h:1334
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:254
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:63
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:81
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:86
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:66
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:85
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:64
USB_OK
@ USB_OK
Definition: usb_std.h:268
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:346
usbd_ctrl_send_status
void usbd_ctrl_send_status(usbd_core_type *udev)
usb control endpoint send in status
Definition: usbd_core.c:212
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint receive data
Definition: usbd_core.c:534
usbd_flush_tx_fifo
void usbd_flush_tx_fifo(usbd_core_type *udev, uint8_t ept_num)
usb device flush in endpoint fifo
Definition: usbd_core.c:650
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:314
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:177
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint send data
Definition: usbd_core.c:434
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
get endpoint receive data length
Definition: usbd_core.c:300
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint recv data
Definition: usbd_core.c:196
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:287
usb_audio_type
usb audio control struct
Definition: audio_class.h:90
usb_audio_type::mic_alt_setting
uint32_t mic_alt_setting
Definition: audio_class.h:106
usb_audio_type::enpd
uint8_t enpd
Definition: audio_class.h:91
usb_audio_type::mic_freq
uint32_t mic_freq
Definition: audio_class.h:99
usb_audio_type::spk_volume_limits
uint16_t spk_volume_limits[3]
Definition: audio_class.h:100
usb_audio_type::audio_spk_data
uint8_t audio_spk_data[(48 *2 *(16/8)+40)]
Definition: audio_class.h:108
usb_audio_type::mic_volume_limits
uint16_t mic_volume_limits[3]
Definition: audio_class.h:101
usb_audio_type::interface
uint8_t interface
Definition: audio_class.h:92
usb_audio_type::audio_cmd_len
uint32_t audio_cmd_len
Definition: audio_class.h:104
usb_audio_type::spk_alt_setting
uint32_t spk_alt_setting
Definition: audio_class.h:105
usb_audio_type::spk_volume
uint16_t spk_volume
Definition: audio_class.h:96
usb_audio_type::mic_volume
uint16_t mic_volume
Definition: audio_class.h:97
usb_audio_type::spk_freq
uint32_t spk_freq
Definition: audio_class.h:98
usb_audio_type::audio_mic_data
uint8_t audio_mic_data[(48 *2 *(16/8)+40)]
Definition: audio_class.h:109
usb_audio_type::g_audio_cur
uint8_t g_audio_cur[64]
Definition: audio_class.h:107
usb_audio_type::spk_mute
uint8_t spk_mute
Definition: audio_class.h:94
usb_audio_type::audio_spk_out_stage
__IO uint8_t audio_spk_out_stage
Definition: audio_class.h:113
usb_audio_type::request_no
uint8_t request_no
Definition: audio_class.h:93
usb_audio_type::audio_cmd
uint8_t audio_cmd
Definition: audio_class.h:103
usb_audio_type::audio_feedback_state
__IO uint16_t audio_feedback_state
Definition: audio_class.h:112
usb_audio_type::audio_feed_back
uint8_t audio_feed_back[0x3+1]
Definition: audio_class.h:110
usb_audio_type::mic_mute
uint8_t mic_mute
Definition: audio_class.h:95
usb_setup_type
format of usb setup data
Definition: usb_std.h:280
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:283
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:286
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:281
usb_setup_type::wIndex
uint16_t wIndex
Definition: usb_std.h:284
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:282
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: audio_class.h Source File

  • middlewares
  • usbd_class
  • audio
audio_class.h
Go to the documentation of this file.
1
27 /* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AUDIO_CLASS_H
29#define __AUDIO_CLASS_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "usb_std.h"
36#include "usbd_core.h"
37#include "audio_conf.h"
38
54#define USBD_AUDIO_MIC_IN_EPT 0x81
55#define USBD_AUDIO_SPK_OUT_EPT 0x02
56#define USBD_AUDIO_FEEDBACK_EPT 0x83
57
61#define AUDIO_REMAIN_SIZE 40
62#define AUDIO_MIC_IN_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_MIC_CHANEL_NUM * (AUDIO_MIC_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
63#define AUDIO_SPK_OUT_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_SPK_CHANEL_NUM * (AUDIO_SPK_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
64#define AUDIO_FEEDBACK_MAXPACKET_SIZE 0x3
65#define FEEDBACK_REFRESH_TIME 0x8
69#define AUDIO_REQ_CONTROL_INTERFACE 0x01
70#define AUDIO_REQ_CONTROL_ENDPOINT 0x02
71#define AUDIO_REQ_CONTROL_MASK 0x03
72
76#define AUDIO_MUTE_CONTROL 0x01
77#define AUDIO_VOLUME_CONTROL 0x02
78#define AUDIO_FREQ_SET_CONTROL 0x03
79
83#define AUDIO_DESCRIPTOR_TYPE 0x21
84#define AUDIO_DESCRIPTOR_SIZE 0x09
85
89typedef struct
90{
91 uint8_t enpd;
92 uint8_t interface;
93 uint8_t request_no;
94 uint8_t spk_mute;
95 uint8_t mic_mute;
96 uint16_t spk_volume;
97 uint16_t mic_volume;
98 uint32_t spk_freq;
99 uint32_t mic_freq;
100 uint16_t spk_volume_limits[3]; /*[0] is mininum value, [1] is maxnum value, [2] is volume resolution */
101 uint16_t mic_volume_limits[3]; /*[0] is mininum value, [1] is maxnum value, [2] is volume resolution */
102
103 uint8_t audio_cmd;
104 uint32_t audio_cmd_len;
105 uint32_t spk_alt_setting;
106 uint32_t mic_alt_setting;
107 uint8_t g_audio_cur[64];
108 uint8_t audio_spk_data[AUDIO_SPK_OUT_MAXPACKET_SIZE];
109 uint8_t audio_mic_data[AUDIO_MIC_IN_MAXPACKET_SIZE];
110 uint8_t audio_feed_back[AUDIO_FEEDBACK_MAXPACKET_SIZE+1];
111
112 __IO uint16_t audio_feedback_state;
113 __IO uint8_t audio_spk_out_stage;
114}usb_audio_type;
115
116extern usbd_class_handler audio_class_handler;
117
129#ifdef __cplusplus
130}
131#endif
132
133#endif
audio_conf.h
usb audio config
AUDIO_MIC_IN_MAXPACKET_SIZE
#define AUDIO_MIC_IN_MAXPACKET_SIZE
Definition: audio_class.h:62
audio_class_handler
usbd_class_handler audio_class_handler
Definition: audio_class.c:66
AUDIO_SPK_OUT_MAXPACKET_SIZE
#define AUDIO_SPK_OUT_MAXPACKET_SIZE
Definition: audio_class.h:63
AUDIO_FEEDBACK_MAXPACKET_SIZE
#define AUDIO_FEEDBACK_MAXPACKET_SIZE
Definition: audio_class.h:64
usb_audio_type
usb audio control struct
Definition: audio_class.h:90
usb_audio_type::mic_alt_setting
uint32_t mic_alt_setting
Definition: audio_class.h:106
usb_audio_type::enpd
uint8_t enpd
Definition: audio_class.h:91
usb_audio_type::mic_freq
uint32_t mic_freq
Definition: audio_class.h:99
usb_audio_type::interface
uint8_t interface
Definition: audio_class.h:92
usb_audio_type::audio_cmd_len
uint32_t audio_cmd_len
Definition: audio_class.h:104
usb_audio_type::spk_alt_setting
uint32_t spk_alt_setting
Definition: audio_class.h:105
usb_audio_type::spk_volume
uint16_t spk_volume
Definition: audio_class.h:96
usb_audio_type::mic_volume
uint16_t mic_volume
Definition: audio_class.h:97
usb_audio_type::spk_freq
uint32_t spk_freq
Definition: audio_class.h:98
usb_audio_type::spk_mute
uint8_t spk_mute
Definition: audio_class.h:94
usb_audio_type::audio_spk_out_stage
__IO uint8_t audio_spk_out_stage
Definition: audio_class.h:113
usb_audio_type::request_no
uint8_t request_no
Definition: audio_class.h:93
usb_audio_type::audio_cmd
uint8_t audio_cmd
Definition: audio_class.h:103
usb_audio_type::audio_feedback_state
__IO uint16_t audio_feedback_state
Definition: audio_class.h:112
usb_audio_type::mic_mute
uint8_t mic_mute
Definition: audio_class.h:95
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: audio_desc.c Source File

  • middlewares
  • usbd_class
  • audio
audio_desc.c
Go to the documentation of this file.
1
26#include "usb_std.h"
27#include "usbd_sdr.h"
28#include "usbd_core.h"
29#include "audio_desc.h"
30
43static usbd_desc_t *get_device_descriptor(void);
44static usbd_desc_t *get_device_qualifier(void);
45static usbd_desc_t *get_device_configuration(void);
46static usbd_desc_t *get_device_other_speed(void);
47static usbd_desc_t *get_device_lang_id(void);
48static usbd_desc_t *get_device_manufacturer_string(void);
49static usbd_desc_t *get_device_product_string(void);
50static usbd_desc_t *get_device_serial_string(void);
51static usbd_desc_t *get_device_interface_string(void);
52static usbd_desc_t *get_device_config_string(void);
53
54static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
55static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
56static void get_serial_num(void);
57static uint8_t g_usbd_desc_buffer[256];
58
62usbd_desc_handler audio_desc_handler =
63{
64 get_device_descriptor,
65 get_device_qualifier,
66 get_device_configuration,
67 get_device_other_speed,
68 get_device_lang_id,
69 get_device_manufacturer_string,
70 get_device_product_string,
71 get_device_serial_string,
72 get_device_interface_string,
73 get_device_config_string,
74};
75
79#if defined ( __ICCARM__ ) /* iar compiler */
80 #pragma data_alignment=4
81#endif
82ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
83{
84 USB_DEVICE_DESC_LEN, /* bLength */
85 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
86 0x00, /* bcdUSB */
87 0x02,
88 0x00, /* bDeviceClass */
89 0x00, /* bDeviceSubClass */
90 0x00, /* bDeviceProtocol */
91 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
92 LBYTE(USBD_AUDIO_VENDOR_ID), /* idVendor */
93 HBYTE(USBD_AUDIO_VENDOR_ID), /* idVendor */
94 LBYTE(USBD_AUDIO_PRODUCT_ID), /* idProduct */
95 HBYTE(USBD_AUDIO_PRODUCT_ID), /* idProduct */
96 0x00, /* bcdDevice rel. 2.00 */
97 0x02,
98 USB_MFC_STRING, /* Index of manufacturer string */
99 USB_PRODUCT_STRING, /* Index of product string */
100 USB_SERIAL_STRING, /* Index of serial number string */
101 0x01 /* bNumConfigurations */
102};
103
107#if defined ( __ICCARM__ ) /* iar compiler */
108 #pragma data_alignment=4
109#endif
110ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_AUDIO_CONFIG_DESC_SIZE] ALIGNED_TAIL =
111{
112 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
113 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
114 LBYTE(USBD_AUDIO_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
115 HBYTE(USBD_AUDIO_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
116 0x1 + AUDIO_INTERFACE_NUM, /* bNumInterfaces: n interface */
117 0x01, /* bConfigurationValue: configuration value */
118 0x00, /* iConfiguration: index of string descriptor describing
119 the configuration */
120 0xC0, /* bmAttributes: self powered */
121 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
122
123 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
124 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
125 0x00, /* bInterfaceNumber: number of interface */
126 0x00, /* bAlternateSetting: alternate set */
127 0x00, /* bNumEndpoints: number of endpoints */
128 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio class code */
129 AUDIO_SUBCLASS_AUDIOCONTROL, /* bInterfaceSubClass: audio control */
130 AUDIO_PROTOCOL_UNDEFINED, /* bInterfaceProtocol: undefined */
131 0x00, /* iInterface: index of string descriptor */
132
133 0x08+AUDIO_INTERFACE_NUM, /* bLength: size of this descriptor, in bytes 8+n */
134 AUDIO_CS_INTERFACE, /* bDescriptorType: cs interface descriptor type */
135 AUDIO_AC_HEADER, /* bDescriptorSubtype: Header function Descriptor*/
136 LBYTE(AUDIO_BCD_NUM),
137 HBYTE(AUDIO_BCD_NUM), /* bcdCDC: audio device class specification release number */
138 LBYTE(AUDIO_INTERFACE_LEN),
139 HBYTE(AUDIO_INTERFACE_LEN), /* wTotalLength: total number of bytes returned for the class-specific audio control interface */
140 AUDIO_INTERFACE_NUM, /* bInClollection: the number of audio streaming */
141#if (AUDIO_INTERFACE_NUM == 2) /* two interface */
142 0x02,
143 0x01,
144#else
145 0x01,
146#endif
147
148 /* usb microphone config */
149#if (AUDIO_SUPPORT_MIC == 1)
150 AUDIO_INPUT_TERMINAL_SIZE, /* bLength: descriptor size */
151 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
152 AUDIO_AC_INPUT_TERMINAL, /* bDescriptorSubtype: input_terminal type*/
153 AUDIO_MIC_INPUT_TERMINAL_ID, /* bTerminalID: id of this input terminal*/
154 LBYTE(AUDIO_INPUT_TERMINAL_MICROPHONE),
155 HBYTE(AUDIO_INPUT_TERMINAL_MICROPHONE),/* wTerminalType: terminal is microphone */
156 0x00, /* bAssocTerminal: no association */
157 AUDIO_MIC_CHR, /* bNrChannels: two channel */
158#if (AUDIO_MIC_CHR == 2)
159 0x03, /* wChannelConfig: left front and right front */
160#endif
161#if (AUDIO_MIC_CHR == 1)
162 0x00, /* wChannelConfig */
163#endif
164 0x00, /* wChannelConfig */
165 0x00, /* iChannelNames: unused */
166 0x00, /* iTerminal: unused */
167
168 AUDIO_FEATURE_UNIT_SIZE, /* bLength: descriptor size */
169 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
170 AUDIO_AC_FEATURE_UNIT, /* bDescriptorSubtype: feature unit type*/
171 AUDIO_MIC_FEATURE_UNIT_ID, /* bUnitID: id of this feature unit */
172 AUDIO_MIC_INPUT_TERMINAL_ID, /* bSourceID: from input terminal */
173 0x01, /* bControlSize: 1 byte */
174 0x01, /* bmaControls0: mute */
175 0x02, /* bmaControls1: volume */
176 0x00, /* iFeature: unused */
177
178 AUDIO_OUTPUT_TERMINAL_SIZE, /* bLength: descriptor size */
179 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
180 AUDIO_AC_OUTPUT_TERMINAL, /* bDescriptorSubtype: output_terminal type*/
181 AUDIO_MIC_OUTPUT_TERMINAL_ID, /* bTerminalID: id of this output terminal*/
182 LBYTE(AUDIO_TERMINAL_TYPE_STREAMING),
183 HBYTE(AUDIO_TERMINAL_TYPE_STREAMING), /* wTerminalType: usb streaming */
184 0x00, /* bAssocTerminal: unused */
185 AUDIO_MIC_FEATURE_UNIT_ID, /* bSourceID: from feature unit terminal */
186 0x00, /* iTerminal: unused */
187#endif
188
189#if (AUDIO_SUPPORT_SPK == 1)
190 /* speaker config */
191 AUDIO_INPUT_TERMINAL_SIZE, /* bLength: descriptor size */
192 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
193 AUDIO_AC_INPUT_TERMINAL, /* bDescriptorSubtype: input_terminal type*/
194 AUDIO_SPK_INPUT_TERMINAL_ID, /* bTerminalID: id of this input terminal*/
195 LBYTE(AUDIO_TERMINAL_TYPE_STREAMING), /* wTerminalType: usb streaming */
196 HBYTE(AUDIO_TERMINAL_TYPE_STREAMING), /* wTerminalType: usb streaming */
197 0x00, /* bAssocTerminal: no association */
198 AUDIO_SPK_CHR, /* bNrChannels: two channel */
199#if (AUDIO_SPK_CHR == 2)
200 0x03, /* wChannelConfig: left front and right front */
201#endif
202#if (AUDIO_SPK_CHR == 1)
203 0x00, /* wChannelConfig */
204#endif
205 0x00, /* wChannelConfig */
206 0x00, /* iChannelNames: unused */
207 0x00, /* iTerminal: unused */
208
209 AUDIO_FEATURE_UNIT_SIZE, /* bLength: descriptor size */
210 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
211 AUDIO_AC_FEATURE_UNIT, /* bDescriptorSubtype: feature unit type*/
212 AUDIO_SPK_FEATURE_UNIT_ID, /* bUnitID: id of this feature unit */
213 AUDIO_SPK_INPUT_TERMINAL_ID, /* bSourceID: from input terminal */
214 0x01, /* bControlSize: 1 byte */
215 0x01, /* bmaControls0: mute*/
216 0x02, /* bmaControls1: volume */
217 0x00, /* iFeature: unused */
218
219 AUDIO_OUTPUT_TERMINAL_SIZE, /* bLength: descriptor size */
220 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
221 AUDIO_AC_OUTPUT_TERMINAL, /* bDescriptorSubtype: output_terminal type*/
222 AUDIO_SPK_OUTPUT_TERMINAL_ID, /* bTerminalID: id of this output terminal*/
223 LBYTE(AUDIO_OUTPUT_TERMINAL_SPEAKER), /* wTerminalType: usb speaker */
224 HBYTE(AUDIO_OUTPUT_TERMINAL_SPEAKER), /* wTerminalType: usb speaker */
225 0x00, /* bAssocTerminal: unused */
226 AUDIO_SPK_FEATURE_UNIT_ID, /* bSourceID: from feature unit terminal */
227 0x00, /* iTerminal: unused */
228#endif
229
230#if (AUDIO_SUPPORT_MIC == 1)
231 /* microphone interface */
232 0x09, /* bLength: descriptor size */
233 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
234 AUDIO_MIC_INTERFACE_NUMBER, /* bInterfaceNumber: index of this interface */
235 0x00, /* bAlternateSetting: index of this setting */
236 0x00, /* bNumEndpoints: 0 endpoints */
237 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio */
238 AUDIO_SUBCLASS_AUDIOSTREAMING, /* bInterfaceSubclass: audio streaming */
239 0x00, /* bInterfaceProtocol: unused */
240 0x00, /* iInterface: unused */
241
242 0x09, /* bLength: descriptor size */
243 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
244 AUDIO_MIC_INTERFACE_NUMBER, /* bInterfaceNumber: index of this interface */
245 0x01, /* bAlternateSetting: index of this setting */
246 0x01, /* bNumEndpoints: 1 endpoints */
247 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio */
248 AUDIO_SUBCLASS_AUDIOSTREAMING, /* bInterfaceSubclass: audio streaming */
249 0x00, /* bInterfaceProtocol: unused */
250 0x00, /* iInterface: unused */
251
252 0x07, /* bLength: configuration descriptor size */
253 AUDIO_CS_INTERFACE, /* bDescriptorType: interface descriptor type */
254 AUDIO_AS_GENERAL, /* bDescriptorSubtype: general sub type*/
255 AUDIO_MIC_OUTPUT_TERMINAL_ID, /* bTerminalLink: unit id of the output terminal */
256 0x01, /* bDelay: interface delay */
257 0x01, /* wFormatTag: pcm format*/
258 0x00, /* wFormatTag: pcm format*/
259
260 0x08 + AUDIO_MIC_FREQ_SIZE * 3, /* bLength: descriptor size */
261 AUDIO_CS_INTERFACE, /* bDescriptorType: interface descriptor type */
262 AUDIO_AS_FORMAT_TYPE, /* bDescriptorSubtype: format subtype */
263 AUDIO_FORMAT_TYPE_I, /* bFormatType: format type 1 */
264 AUDIO_MIC_CHR, /* bNrChannels: channel number */
265 AUDIO_MIC_BITW / 8, /* bSubFrameSize: per audio subframe */
266 AUDIO_MIC_BITW, /* bBitResolution: n bits per sample */
267 AUDIO_MIC_FREQ_SIZE, /* bSamFreqType: n frequency supported */
268#if (AUDIO_SUPPORT_FREQ_16K == 1)
269 SAMPLE_FREQ(AT32_AUDIO_FREQ_16K), /* tSamFreq: 16000hz */
270#endif
271#if (AUDIO_SUPPORT_FREQ_48K == 1)
272 SAMPLE_FREQ(AT32_AUDIO_FREQ_48K), /* tSamFreq: 48000hz */
273#endif
274
275 0x09, /* bLength: size of endpoint descriptor in bytes */
276 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
277 USBD_AUDIO_MIC_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
278 USB_EPT_DESC_ISO | USB_ETP_DESC_ASYNC, /* bmAttributes: endpoint attributes */
279 LBYTE(AUDIO_MIC_IN_MAXPACKET_SIZE),
280 HBYTE(AUDIO_MIC_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
281 AUDIO_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
282 0x00, /* bRefresh: unused */
283 0x00, /* bSynchAddress: unused */
284
285 0x07, /* bLength: size of endpoint descriptor in bytes */
286 AUDIO_CS_ENDPOINT, /* bDescriptorType: cs endpoint descriptor type */
287 0x01, /* bDescriptorSubtype: general subtype */
288 0x01, /* bmAttributes */
289 0x00, /* bLockDelayUnits: unused */
290 0x00, /* wLockDelay: unused */
291 0x00, /* wLockDelay: unused */
292#endif
293
294#if (AUDIO_SUPPORT_SPK == 1)
295 /* speaker interface */
296 0x09, /* bLength: descriptor size */
297 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
298 AUDIO_SPK_INTERFACE_NUMBER, /* bInterfaceNumber: index of this interface */
299 0x00, /* bAlternateSetting: index of this setting */
300 0x00, /* bNumEndpoints: 0 endpoints */
301 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio */
302 AUDIO_SUBCLASS_AUDIOSTREAMING, /* bInterfaceSubclass: audio streaming */
303 0x00, /* bInterfaceProtocol: unused */
304 0x00, /* iInterface: unused */
305
306 0x09, /* bLength: descriptor size */
307 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
308 AUDIO_SPK_INTERFACE_NUMBER, /* bInterfaceNumber: index of this interface */
309 0x01, /* bAlternateSetting: index of this setting */
310 0x01 + AUDIO_SUPPORT_FEEDBACK, /* bNumEndpoints: endpoints */
311 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio */
312 AUDIO_SUBCLASS_AUDIOSTREAMING, /* bInterfaceSubclass: audio streaming */
313 0x00, /* bInterfaceProtocol: unused */
314 0x00, /* iInterface: unused */
315
316 0x07, /* bLength: configuration descriptor size */
317 AUDIO_CS_INTERFACE, /* bDescriptorType: interface descriptor type */
318 AUDIO_AS_GENERAL, /* bDescriptorSubtype: general sub type*/
319 AUDIO_SPK_INPUT_TERMINAL_ID, /* bTerminalLink: unit id of the input terminal */
320 0x01, /* bDelay: interface delay */
321 0x01, /* wFormatTag: pcm format*/
322 0x00, /* wFormatTag: pcm format*/
323
324 0x08 + AUDIO_SPK_FREQ_SIZE * 3, /* bLength: descriptor size */
325 AUDIO_CS_INTERFACE, /* bDescriptorType: interface descriptor type */
326 AUDIO_AS_FORMAT_TYPE, /* bDescriptorSubtype: format subtype */
327 AUDIO_FORMAT_TYPE_I, /* bFormatType: format type 1 */
328 AUDIO_SPK_CHR, /* bNrChannels: channel number */
329 AUDIO_SPK_BITW / 8, /* bSubFrameSize: per audio subframe */
330 AUDIO_SPK_BITW, /* bBitResolution: n bits per sample */
331 AUDIO_SPK_FREQ_SIZE, /* bSamFreqType: n frequency supported */
332#if (AUDIO_SUPPORT_FREQ_16K == 1)
333 SAMPLE_FREQ(AT32_AUDIO_FREQ_16K), /* tSamFreq: 16000hz */
334#endif
335#if (AUDIO_SUPPORT_FREQ_48K == 1)
336 SAMPLE_FREQ(AT32_AUDIO_FREQ_48K), /* tSamFreq: 48000hz */
337#endif
338
339 0x09, /* bLength: size of endpoint descriptor in bytes */
340 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
341 USBD_AUDIO_SPK_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
342 USB_EPT_DESC_ISO | USB_ETP_DESC_ASYNC, /* bmAttributes: endpoint attributes */
343 LBYTE(AUDIO_SPK_OUT_MAXPACKET_SIZE),
344 HBYTE(AUDIO_SPK_OUT_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
345 AUDIO_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
346 0x00, /* bRefresh: unused */
347#if (AUDIO_SUPPORT_FEEDBACK == 1)
348 USBD_AUDIO_FEEDBACK_EPT, /* bSynchAddress: feedback endpoint */
349#else
350 0x00, /* bSynchAddress: unused */
351#endif
352
353 0x07, /* bLength: size of endpoint descriptor in bytes */
354 AUDIO_CS_ENDPOINT, /* bDescriptorType: cs endpoint descriptor type */
355 0x01, /* bDescriptorSubtype: general subtype */
356 0x01, /* bmAttributes */
357 0x00, /* bLockDelayUnits: unused */
358 0x00, /* wLockDelay: unused */
359 0x00, /* wLockDelay: unused */
360
361#if (AUDIO_SUPPORT_FEEDBACK == 1)
362 0x09, /* bLength: size of endpoint descriptor in bytes */
363 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
364 USBD_AUDIO_FEEDBACK_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
365 0x11, /* bmAttributes: endpoint attributes */
366 LBYTE(AUDIO_FEEDBACK_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
367 HBYTE(AUDIO_FEEDBACK_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
368 1, /* bInterval: interval for polling endpoint for data transfers */
369 FEEDBACK_REFRESH_TIME, /* bRefresh: this field indicates the rate at which an iso syncronization
370 pipe provides new syncronization feedback data. this rate must be a power of
371 2, therefore only the power is reported back and the range of this field is from
372 1(2ms) to 9(512ms) */
373 0x00 /* bSynchAddress: 0x00*/
374#endif
375
376#endif
377};
378
382#if defined ( __ICCARM__ ) /* iar compiler */
383 #pragma data_alignment=4
384#endif
385ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_AUDIO_SIZ_STRING_LANGID] ALIGNED_TAIL =
386{
387 USBD_AUDIO_SIZ_STRING_LANGID,
388 USB_DESCIPTOR_TYPE_STRING,
389 0x09,
390 0x04,
391};
392
396#if defined ( __ICCARM__ ) /* iar compiler */
397 #pragma data_alignment=4
398#endif
399ALIGNED_HEAD static uint8_t g_string_serial[USBD_AUDIO_SIZ_STRING_SERIAL] ALIGNED_TAIL =
400{
401 USBD_AUDIO_SIZ_STRING_SERIAL,
402 USB_DESCIPTOR_TYPE_STRING,
403};
404
405
406/* device descriptor */
407static usbd_desc_t device_descriptor =
408{
409 USB_DEVICE_DESC_LEN,
410 g_usbd_descriptor
411};
412
413/* config descriptor */
414static usbd_desc_t config_descriptor =
415{
416 USBD_AUDIO_CONFIG_DESC_SIZE,
417 g_usbd_configuration
418};
419
420/* langid descriptor */
421static usbd_desc_t langid_descriptor =
422{
423 USBD_AUDIO_SIZ_STRING_LANGID,
424 g_string_lang_id
425};
426
427/* serial descriptor */
428static usbd_desc_t serial_descriptor =
429{
430 USBD_AUDIO_SIZ_STRING_SERIAL,
431 g_string_serial
432};
433
434static usbd_desc_t vp_desc;
435
442static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
443{
444 uint16_t str_len = 0, id_pos = 2;
445 uint8_t *tmp_str = string;
446
447 while(*tmp_str != '\0')
448 {
449 str_len ++;
450 unicode_buf[id_pos ++] = *tmp_str ++;
451 unicode_buf[id_pos ++] = 0x00;
452 }
453
454 str_len = str_len * 2 + 2;
455 unicode_buf[0] = str_len;
456 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
457
458 return str_len;
459}
460
468static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
469{
470 uint8_t idx = 0;
471
472 for( idx = 0 ; idx < len ; idx ++)
473 {
474 if( ((value >> 28)) < 0xA )
475 {
476 pbuf[2 * idx] = (value >> 28) + '0';
477 }
478 else
479 {
480 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
481 }
482
483 value = value << 4;
484
485 pbuf[2 * idx + 1] = 0;
486 }
487}
488
494static void get_serial_num(void)
495{
496 uint32_t serial0, serial1, serial2;
497
498 serial0 = *(uint32_t*)MCU_ID1;
499 serial1 = *(uint32_t*)MCU_ID2;
500 serial2 = *(uint32_t*)MCU_ID3;
501
502 serial0 += serial2;
503
504 if (serial0 != 0)
505 {
506 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
507 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
508 }
509}
510
516static usbd_desc_t *get_device_descriptor(void)
517{
518 return &device_descriptor;
519}
520
526static usbd_desc_t * get_device_qualifier(void)
527{
528 return NULL;
529}
530
536static usbd_desc_t *get_device_configuration(void)
537{
538 return &config_descriptor;
539}
540
546static usbd_desc_t *get_device_other_speed(void)
547{
548 return NULL;
549}
550
556static usbd_desc_t *get_device_lang_id(void)
557{
558 return &langid_descriptor;
559}
560
561
567static usbd_desc_t *get_device_manufacturer_string(void)
568{
569 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_AUDIO_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
570 vp_desc.descriptor = g_usbd_desc_buffer;
571 return &vp_desc;
572}
573
579static usbd_desc_t *get_device_product_string(void)
580{
581 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_AUDIO_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
582 vp_desc.descriptor = g_usbd_desc_buffer;
583 return &vp_desc;
584}
585
591static usbd_desc_t *get_device_serial_string(void)
592{
593 get_serial_num();
594 return &serial_descriptor;
595}
596
602static usbd_desc_t *get_device_interface_string(void)
603{
604 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_AUDIO_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
605 vp_desc.descriptor = g_usbd_desc_buffer;
606 return &vp_desc;
607}
608
614static usbd_desc_t *get_device_config_string(void)
615{
616 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_AUDIO_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
617 vp_desc.descriptor = g_usbd_desc_buffer;
618 return &vp_desc;
619}
620
audio_desc.h
usb audio descriptor header file
idx
uint32_t idx
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:46
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
AUDIO_MIC_IN_MAXPACKET_SIZE
#define AUDIO_MIC_IN_MAXPACKET_SIZE
Definition: audio_class.h:62
AUDIO_SPK_OUT_MAXPACKET_SIZE
#define AUDIO_SPK_OUT_MAXPACKET_SIZE
Definition: audio_class.h:63
FEEDBACK_REFRESH_TIME
#define FEEDBACK_REFRESH_TIME
Definition: audio_class.h:65
USBD_AUDIO_SPK_OUT_EPT
#define USBD_AUDIO_SPK_OUT_EPT
Definition: audio_class.h:55
USBD_AUDIO_MIC_IN_EPT
#define USBD_AUDIO_MIC_IN_EPT
endpoint define
Definition: audio_class.h:54
USBD_AUDIO_FEEDBACK_EPT
#define USBD_AUDIO_FEEDBACK_EPT
Definition: audio_class.h:56
AUDIO_FEEDBACK_MAXPACKET_SIZE
#define AUDIO_FEEDBACK_MAXPACKET_SIZE
Definition: audio_class.h:64
AUDIO_MIC_FEATURE_UNIT_ID
#define AUDIO_MIC_FEATURE_UNIT_ID
Definition: audio_desc.h:169
AUDIO_CS_ENDPOINT
#define AUDIO_CS_ENDPOINT
Definition: audio_desc.h:76
AUDIO_AC_HEADER
#define AUDIO_AC_HEADER
Definition: audio_desc.h:91
AUDIO_SUBCLASS_AUDIOCONTROL
#define AUDIO_SUBCLASS_AUDIOCONTROL
Definition: audio_desc.h:68
AUDIO_INPUT_TERMINAL_SIZE
#define AUDIO_INPUT_TERMINAL_SIZE
audio interface descriptor size define
Definition: audio_desc.h:161
AUDIO_TERMINAL_TYPE_STREAMING
#define AUDIO_TERMINAL_TYPE_STREAMING
Definition: audio_desc.h:138
AUDIO_SPK_CHR
#define AUDIO_SPK_CHR
Definition: audio_desc.h:202
USBD_AUDIO_DESC_PRODUCT_STRING
#define USBD_AUDIO_DESC_PRODUCT_STRING
Definition: audio_desc.h:60
AUDIO_SPK_INTERFACE_NUMBER
#define AUDIO_SPK_INTERFACE_NUMBER
Definition: audio_desc.h:180
AUDIO_MIC_OUTPUT_TERMINAL_ID
#define AUDIO_MIC_OUTPUT_TERMINAL_ID
Definition: audio_desc.h:170
AUDIO_MIC_INTERFACE_NUMBER
#define AUDIO_MIC_INTERFACE_NUMBER
audio interface number
Definition: audio_desc.h:178
USBD_AUDIO_PRODUCT_ID
#define USBD_AUDIO_PRODUCT_ID
Definition: audio_desc.h:54
USBD_AUDIO_CONFIG_DESC_SIZE
#define USBD_AUDIO_CONFIG_DESC_SIZE
Definition: audio_desc.h:208
AUDIO_BCD_NUM
#define AUDIO_BCD_NUM
Definition: audio_desc.h:51
SAMPLE_FREQ
#define SAMPLE_FREQ(frq)
Definition: audio_desc.h:213
AUDIO_MIC_FREQ_SIZE
#define AUDIO_MIC_FREQ_SIZE
audio microphone freq and channel config
Definition: audio_desc.h:194
AUDIO_SPK_FREQ_SIZE
#define AUDIO_SPK_FREQ_SIZE
audio speaker freq and channel config
Definition: audio_desc.h:201
AT32_AUDIO_FREQ_48K
#define AT32_AUDIO_FREQ_48K
Definition: audio_desc.h:189
AUDIO_FORMAT_TYPE_I
#define AUDIO_FORMAT_TYPE_I
audio format type 1
Definition: audio_desc.h:148
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:215
AUDIO_AS_GENERAL
#define AUDIO_AS_GENERAL
Definition: audio_desc.h:104
USBD_AUDIO_DESC_CONFIGURATION_STRING
#define USBD_AUDIO_DESC_CONFIGURATION_STRING
Definition: audio_desc.h:61
USBD_AUDIO_DESC_INTERFACE_STRING
#define USBD_AUDIO_DESC_INTERFACE_STRING
Definition: audio_desc.h:62
AUDIO_INTERFACE_NUM
#define AUDIO_INTERFACE_NUM
audio interface config
Definition: audio_desc.h:153
AUDIO_CS_INTERFACE
#define AUDIO_CS_INTERFACE
audio class-specific descriptor types
Definition: audio_desc.h:75
USBD_AUDIO_SIZ_STRING_SERIAL
#define USBD_AUDIO_SIZ_STRING_SERIAL
Definition: audio_desc.h:57
AUDIO_SPK_FEATURE_UNIT_ID
#define AUDIO_SPK_FEATURE_UNIT_ID
Definition: audio_desc.h:172
USBD_AUDIO_SIZ_STRING_LANGID
#define USBD_AUDIO_SIZ_STRING_LANGID
Definition: audio_desc.h:56
AUDIO_OUTPUT_TERMINAL_SIZE
#define AUDIO_OUTPUT_TERMINAL_SIZE
Definition: audio_desc.h:162
AUDIO_SPK_OUTPUT_TERMINAL_ID
#define AUDIO_SPK_OUTPUT_TERMINAL_ID
Definition: audio_desc.h:173
AUDIO_AC_INPUT_TERMINAL
#define AUDIO_AC_INPUT_TERMINAL
Definition: audio_desc.h:92
AUDIO_MIC_CHR
#define AUDIO_MIC_CHR
Definition: audio_desc.h:195
AUDIO_OUTPUT_TERMINAL_SPEAKER
#define AUDIO_OUTPUT_TERMINAL_SPEAKER
Definition: audio_desc.h:143
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:216
AT32_AUDIO_FREQ_16K
#define AT32_AUDIO_FREQ_16K
audio support freq
Definition: audio_desc.h:188
AUDIO_AS_FORMAT_TYPE
#define AUDIO_AS_FORMAT_TYPE
Definition: audio_desc.h:105
AUDIO_MIC_INPUT_TERMINAL_ID
#define AUDIO_MIC_INPUT_TERMINAL_ID
audio terminal id define
Definition: audio_desc.h:168
AUDIO_SPK_BITW
#define AUDIO_SPK_BITW
Definition: audio_desc.h:203
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:217
AUDIO_FEATURE_UNIT_SIZE
#define AUDIO_FEATURE_UNIT_SIZE
Definition: audio_desc.h:163
AUDIO_PROTOCOL_UNDEFINED
#define AUDIO_PROTOCOL_UNDEFINED
audio interface protocol codes
Definition: audio_desc.h:85
AUDIO_MIC_BITW
#define AUDIO_MIC_BITW
Definition: audio_desc.h:196
USBD_AUDIO_VENDOR_ID
#define USBD_AUDIO_VENDOR_ID
Definition: audio_desc.h:53
AUDIO_AC_FEATURE_UNIT
#define AUDIO_AC_FEATURE_UNIT
Definition: audio_desc.h:96
AUDIO_SPK_INPUT_TERMINAL_ID
#define AUDIO_SPK_INPUT_TERMINAL_ID
Definition: audio_desc.h:171
AUDIO_BINTERVAL_TIME
#define AUDIO_BINTERVAL_TIME
Definition: audio_desc.h:205
AUDIO_INTERFACE_LEN
#define AUDIO_INTERFACE_LEN
Definition: audio_desc.h:154
AUDIO_SUBCLASS_AUDIOSTREAMING
#define AUDIO_SUBCLASS_AUDIOSTREAMING
Definition: audio_desc.h:69
USBD_AUDIO_DESC_MANUFACTURER_STRING
#define USBD_AUDIO_DESC_MANUFACTURER_STRING
Definition: audio_desc.h:59
AUDIO_AC_OUTPUT_TERMINAL
#define AUDIO_AC_OUTPUT_TERMINAL
Definition: audio_desc.h:93
AUDIO_INPUT_TERMINAL_MICROPHONE
#define AUDIO_INPUT_TERMINAL_MICROPHONE
Definition: audio_desc.h:141
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: audio_desc.c:428
device_descriptor
static usbd_desc_t device_descriptor
Definition: audio_desc.c:407
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: audio_desc.c:536
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: audio_desc.c:421
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: audio_desc.c:516
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: audio_desc.c:567
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: audio_desc.c:526
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: audio_desc.c:602
g_usbd_desc_buffer
static uint8_t g_usbd_desc_buffer[256]
Definition: audio_desc.c:57
vp_desc
static usbd_desc_t vp_desc
Definition: audio_desc.c:434
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: audio_desc.c:546
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL
usb device standard descriptor
Definition: audio_desc.c:82
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: audio_desc.c:579
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: audio_desc.c:614
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: audio_desc.c:442
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: audio_desc.c:556
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: audio_desc.c:494
config_descriptor
static usbd_desc_t config_descriptor
Definition: audio_desc.c:414
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: audio_desc.c:591
audio_desc_handler
usbd_desc_handler audio_desc_handler
device descriptor handler structure
Definition: audio_desc.c:62
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: audio_desc.c:468
AUDIO_SUPPORT_FEEDBACK
#define AUDIO_SUPPORT_FEEDBACK
Definition: audio/audio_conf.h:49
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_EPT_DESC_ISO
#define USB_EPT_DESC_ISO
Definition: usb_std.h:176
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:93
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:96
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:152
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:151
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:94
USB_CLASS_CODE_AUDIO
#define USB_CLASS_CODE_AUDIO
usb class code
Definition: usb_std.h:161
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:95
USB_ETP_DESC_ASYNC
#define USB_ETP_DESC_ASYNC
Definition: usb_std.h:181
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h


AT32F435/437 Firmwary Library: audio_desc.h Source File

  • middlewares
  • usbd_class
  • audio
audio_desc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AUDIO_DESC_H
29#define __AUDIO_DESC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "audio_class.h"
36#include "usbd_core.h"
37#include "audio_conf.h"
38
51#define AUDIO_BCD_NUM 0x0100
52
53#define USBD_AUDIO_VENDOR_ID 0x2E3C
54#define USBD_AUDIO_PRODUCT_ID 0x5730
55
56#define USBD_AUDIO_SIZ_STRING_LANGID 4
57#define USBD_AUDIO_SIZ_STRING_SERIAL 0x1A
58
59#define USBD_AUDIO_DESC_MANUFACTURER_STRING "Artery"
60#define USBD_AUDIO_DESC_PRODUCT_STRING "AT32 Audio"
61#define USBD_AUDIO_DESC_CONFIGURATION_STRING "Audio Config"
62#define USBD_AUDIO_DESC_INTERFACE_STRING "Audio Interface"
63
67#define AUDIO_SUBCLASS_UNDEFINED 0x00
68#define AUDIO_SUBCLASS_AUDIOCONTROL 0x01
69#define AUDIO_SUBCLASS_AUDIOSTREAMING 0x02
70#define AUDIO_SUBCLASS_MIDISTREMING 0x03
71
75#define AUDIO_CS_INTERFACE 0x24
76#define AUDIO_CS_ENDPOINT 0x25
77#define AUDIO_CS_STRING 0x23
78#define AUDIO_CS_CONFIGURATION 0x22
79#define AUDIO_CS_DEVICE 0x21
80#define AUDIO_CS_UNDEFINED 0x20
81
85#define AUDIO_PROTOCOL_UNDEFINED 0x00
86
90#define AUDIO_AC_DESCRIPTOR_UNDEFINED 0x00
91#define AUDIO_AC_HEADER 0x01
92#define AUDIO_AC_INPUT_TERMINAL 0x02
93#define AUDIO_AC_OUTPUT_TERMINAL 0x03
94#define AUDIO_AC_MIXER_UNIT 0x04
95#define AUDIO_AC_SELECTOR_UNIT 0x05
96#define AUDIO_AC_FEATURE_UNIT 0x06
97#define AUDIO_AC_PROCESSING_UNIT 0x07
98#define AUDIO_AC_EXTENSION_UNIT 0x08
99
103#define AUDIO_AS_DESCRIPTOR_UNDEFINED 0x00
104#define AUDIO_AS_GENERAL 0x01
105#define AUDIO_AS_FORMAT_TYPE 0x02
106#define AUDIO_AS_FORMAT_SPECIFIC 0x03
107
111#define AUDIO_REQUEST_CODE_UNDEFINED 0x00
112#define AUDIO_REQ_SET_CUR 0x01
113#define AUDIO_REQ_GET_CUR 0x81
114#define AUDIO_REQ_SET_MIN 0x02
115#define AUDIO_REQ_GET_MIN 0x82
116#define AUDIO_REQ_SET_MAX 0x03
117#define AUDIO_REQ_GET_MAX 0x83
118#define AUDIO_REQ_SET_RES 0x04
119#define AUDIO_REQ_GET_RES 0x84
120#define AUDIO_REQ_SET_MEM 0x05
121#define AUDIO_REQ_GET_MEM 0x85
122#define AUDIO_REQ_GET_STAT 0xFF
123
127#define AUDIO_FU_CONTROL_UNDEFINED 0x00
128#define AUDIO_FU_MUTE_CONTROL 0x01
129#define AUDIO_FU_VOLUME_CONTROL 0x02
130#define AUDIO_FU_BASS_CONTROL 0x03
131#define AUDIO_FU_MID_CONTROL 0x04
132#define AUDIO_FU_TREBLE_CONTROL 0x05
133
137#define AUDIO_TERMINAL_TYPE_UNDEFINED 0x0100
138#define AUDIO_TERMINAL_TYPE_STREAMING 0x0101
139#define AUDIO_TERMINAL_TYPE_VENDOR 0x01FF
140#define AUDIO_INPUT_TERMINAL_UNDEFINED 0x0200
141#define AUDIO_INPUT_TERMINAL_MICROPHONE 0x0201
142#define AUDIO_OUTPUT_TERMINAL_UNDEFINED 0x0300
143#define AUDIO_OUTPUT_TERMINAL_SPEAKER 0x0301
144
148#define AUDIO_FORMAT_TYPE_I 0x01
149
153#define AUDIO_INTERFACE_NUM (AUDIO_SUPPORT_SPK + AUDIO_SUPPORT_MIC)
154#define AUDIO_INTERFACE_LEN ((0x08 + AUDIO_INTERFACE_NUM) + AUDIO_INTERFACE_NUM * 0x1E)
155#define AUDIO_MIC_INTERFACE 0x01
156#define AUDIO_SPK_INTERFACE 0x02
157
161#define AUDIO_INPUT_TERMINAL_SIZE 0x0C
162#define AUDIO_OUTPUT_TERMINAL_SIZE 0x09
163#define AUDIO_FEATURE_UNIT_SIZE 0x09
164
168#define AUDIO_MIC_INPUT_TERMINAL_ID 0x01
169#define AUDIO_MIC_FEATURE_UNIT_ID 0x02
170#define AUDIO_MIC_OUTPUT_TERMINAL_ID 0x03
171#define AUDIO_SPK_INPUT_TERMINAL_ID 0x04
172#define AUDIO_SPK_FEATURE_UNIT_ID 0x05
173#define AUDIO_SPK_OUTPUT_TERMINAL_ID 0x06
174
178#define AUDIO_MIC_INTERFACE_NUMBER 0x01
179#if (AUDIO_SUPPORT_MIC == 1)
180#define AUDIO_SPK_INTERFACE_NUMBER 0x02
181#else
182#define AUDIO_SPK_INTERFACE_NUMBER 0x01
183#endif
184
188#define AT32_AUDIO_FREQ_16K 16000
189#define AT32_AUDIO_FREQ_48K 48000
190
194#define AUDIO_MIC_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
195#define AUDIO_MIC_CHR AUDIO_MIC_CHANEL_NUM
196#define AUDIO_MIC_BITW (AUDIO_MIC_DEFAULT_BITW)
197
201#define AUDIO_SPK_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
202#define AUDIO_SPK_CHR AUDIO_SPK_CHANEL_NUM
203#define AUDIO_SPK_BITW (AUDIO_SPK_DEFAULT_BITW)
204
205#define AUDIO_BINTERVAL_TIME 0x01
206
207
208#define USBD_AUDIO_CONFIG_DESC_SIZE ( 0x12 + AUDIO_INTERFACE_LEN + \
209 + (0x31 + AUDIO_SPK_FREQ_SIZE * 3) \
210 + (0x31 + AUDIO_MIC_FREQ_SIZE * 3) \
211 + (9 * AUDIO_SUPPORT_FEEDBACK) \
212 )
213#define SAMPLE_FREQ(frq) (uint8_t)(frq), (uint8_t)((frq >> 8)), (uint8_t)((frq >> 16))
214
215#define MCU_ID1 (0x1FFFF7E8)
216#define MCU_ID2 (0x1FFFF7EC)
217#define MCU_ID3 (0x1FFFF7F0)
218
219extern usbd_desc_handler audio_desc_handler;
220
232#ifdef __cplusplus
233}
234#endif
235
236#endif
237
audio_class.h
usb audio class file
audio_conf.h
usb audio config
audio_desc_handler
usbd_desc_handler audio_desc_handler
device descriptor handler structure
Definition: audio_desc.c:62
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: audio_conf.h Source File

  • middlewares
  • usbd_class
  • audio_hid
audio_hid/audio_conf.h
Go to the documentation of this file.
1
27 /* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AUDIO_CONF_H
29#define __AUDIO_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
47#define AUDIO_SUPPORT_SPK 1
48#define AUDIO_SUPPORT_MIC 1
49#define AUDIO_SUPPORT_FEEDBACK 1
50
51#define AUDIO_SUPPORT_FREQ_16K 0
52#define AUDIO_SUPPORT_FREQ_48K 1
53
54
55#define AUDIO_SUPPORT_FREQ (AUDIO_SUPPORT_FREQ_16K + \
56 AUDIO_SUPPORT_FREQ_48K \
57 )
58
59#define AUDIO_FREQ_16K 16000
60#define AUDIO_FREQ_48K 48000
61#define AUDIO_BITW_16 16
62
63#define AUDIO_MIC_CHANEL_NUM 2
64#define AUDIO_MIC_DEFAULT_BITW AUDIO_BITW_16
65
66#define AUDIO_SPK_CHANEL_NUM 2
67#define AUDIO_SPK_DEFAULT_BITW AUDIO_BITW_16
68
69
70#define AUDIO_SUPPORT_MAX_FREQ 48
71#define AUDIO_DEFAULT_FREQ AUDIO_FREQ_48K
72#define AUDIO_DEFAULT_BITW AUDIO_BITW_16
73
85#ifdef __cplusplus
86}
87#endif
88
89#endif
90


AT32F435/437 Firmwary Library: audio_hid_class.c Source File

  • middlewares
  • usbd_class
  • audio_hid
audio_hid_class.c
Go to the documentation of this file.
1
26#include "usbd_core.h"
27#include "audio_hid_class.h"
28#include "audio_hid_desc.h"
29#include "audio_codec.h"
30
44static usb_sts_type class_init_handler(void *udev);
45static usb_sts_type class_clear_handler(void *udev);
46static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
47static usb_sts_type class_ept0_tx_handler(void *udev);
48static usb_sts_type class_ept0_rx_handler(void *udev);
49static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
50static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
51static usb_sts_type class_sof_handler(void *udev);
52static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
53
54static void audio_inisoincom_event(void *udev);
55static void audio_req_get_cur(void *udev, usb_setup_type *setup);
56static void audio_req_set_cur(void *udev, usb_setup_type *setup);
57static void audio_req_get_min(void *udev, usb_setup_type *setup);
58static void audio_req_get_max(void *udev, usb_setup_type *setup);
59static void audio_req_get_res(void *udev, usb_setup_type *setup);
60static void audio_get_interface(void *udev, usb_setup_type *setup);
61static void audio_set_interface(void *udev, usb_setup_type *setup);
62
63static void usb_hid_buf_process(void *udev, uint8_t *report, uint16_t len);
64 usb_audio_hid_type audio_hid_struct = {0, 0, 0, 0, 0, 0x1400, 0, 0, 0, {0x0000, 0x1400, 0x33}, {0x0000, 0x1400, 0x33}, 0, 0};
65
66usbd_class_handler audio_hid_class_handler =
67{
68 class_init_handler,
69 class_clear_handler,
70 class_setup_handler,
71 class_ept0_tx_handler,
72 class_ept0_rx_handler,
73 class_in_handler,
74 class_out_handler,
75 class_sof_handler,
76 class_event_handler,
77 &audio_hid_struct
78};
79
85static usb_sts_type class_init_handler(void *udev)
86{
87 usb_sts_type status = USB_OK;
88 usbd_core_type *pudev = (usbd_core_type *)udev;
89 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
90
91 /* open microphone in endpoint */
92 usbd_ept_open(pudev, USBD_AUHID_AUDIO_MIC_IN_EPT, EPT_ISO_TYPE, AUDIO_MIC_IN_MAXPACKET_SIZE);
93
94 /* open speaker out endpoint */
95 usbd_ept_open(pudev, USBD_AUHID_AUDIO_SPK_OUT_EPT, EPT_ISO_TYPE, AUDIO_SPK_OUT_MAXPACKET_SIZE);
96#if AUDIO_SUPPORT_FEEDBACK
97 /* open speaker feedback endpoint */
98 usbd_ept_open(pudev, USBD_AUHID_AUDIO_FEEDBACK_EPT, EPT_ISO_TYPE, AUDIO_FEEDBACK_MAXPACKET_SIZE);
99#endif
100 /* start receive speaker out data */
101 usbd_ept_recv(pudev, USBD_AUHID_AUDIO_SPK_OUT_EPT, paudio_hid->audio_spk_data, AUDIO_SPK_OUT_MAXPACKET_SIZE);
102
103 /*open hid endpoint */
104 /* open custom hid in endpoint */
105 usbd_ept_open(pudev, USBD_AUHID_HID_IN_EPT, EPT_INT_TYPE, USBD_AUHID_IN_MAXPACKET_SIZE);
106
107 /* open custom hid out endpoint */
108 usbd_ept_open(pudev, USBD_AUHID_HID_OUT_EPT, EPT_INT_TYPE, USBD_AUHID_OUT_MAXPACKET_SIZE);
109
110 /* set out endpoint to receive status */
111 usbd_ept_recv(pudev, USBD_AUHID_HID_OUT_EPT, paudio_hid->g_rxhid_buff, USBD_AUHID_OUT_MAXPACKET_SIZE);
112
113 return status;
114}
115
121static usb_sts_type class_clear_handler(void *udev)
122{
123 usb_sts_type status = USB_OK;
124 usbd_core_type *pudev = (usbd_core_type *)udev;
125
126 /* close in endpoint */
127 usbd_ept_close(pudev, USBD_AUHID_AUDIO_MIC_IN_EPT);
128
129#if AUDIO_SUPPORT_FEEDBACK
130 /* close in endpoint */
131 usbd_ept_close(pudev, USBD_AUHID_AUDIO_FEEDBACK_EPT);
132#endif
133
134 /* close out endpoint */
135 usbd_ept_close(pudev, USBD_AUHID_AUDIO_SPK_OUT_EPT);
136
137 /* close custom hid in endpoint */
138 usbd_ept_close(pudev, USBD_AUHID_HID_IN_EPT);
139
140 /* close custom hid out endpoint */
141 usbd_ept_close(pudev, USBD_AUHID_HID_OUT_EPT);
142
143 return status;
144}
145
146
153static usb_sts_type class_audio_setup_handler(void *udev, usb_setup_type *setup)
154{
155 usb_sts_type status = USB_OK;
156 usbd_core_type *pudev = (usbd_core_type *)udev;
157 uint16_t len;
158 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
159 {
160 /* class request */
161 case USB_REQ_TYPE_CLASS:
162 switch(setup->bRequest)
163 {
164 case AUDIO_REQ_GET_CUR:
165 audio_req_get_cur(pudev, setup);
166 break;
167
168 case AUDIO_REQ_SET_CUR:
169 audio_req_set_cur(pudev, setup);
170 break;
171
172 case AUDIO_REQ_GET_MIN:
173 audio_req_get_min(pudev, setup);
174 break;
175
176 case AUDIO_REQ_GET_MAX:
177 audio_req_get_max(pudev, setup);
178 break;
179
180 case AUDIO_REQ_GET_RES:
181 audio_req_get_res(pudev, setup);
182 break;
183
184 default:
185 usbd_ctrl_unsupport(pudev);
186 break;
187 }
188 break;
189 /* standard request */
190 case USB_REQ_TYPE_STANDARD:
191 switch(setup->bRequest)
192 {
193 case USB_STD_REQ_GET_DESCRIPTOR:
194 if((setup->wValue >> 8) == AUDIO_DESCRIPTOR_TYPE)
195 {
196 usbd_desc_t *config = pudev->desc_handler->get_device_configuration();
197 len = MIN(AUDIO_DESCRIPTOR_SIZE, setup->wLength);
198 usbd_ctrl_send(pudev, config->descriptor + 18, len);
199 }
200 else
201 {
202 usbd_ctrl_unsupport(pudev);
203 }
204 break;
205 case USB_STD_REQ_GET_INTERFACE:
206 audio_get_interface(udev, setup);
207 break;
208
209 case USB_STD_REQ_SET_INTERFACE:
210 audio_set_interface(udev, setup);
211 usbd_ctrl_send_status(pudev);
212 break;
213
214 default:
215 break;
216 }
217 break;
218
219 default:
220 usbd_ctrl_unsupport(pudev);
221 break;
222 }
223 return status;
224
225}
226
233static usb_sts_type class_hid_setup_handler(void *udev, usb_setup_type *setup)
234{
235 usb_sts_type status = USB_OK;
236 usbd_core_type *pudev = (usbd_core_type *)udev;
237 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
238 uint16_t len;
239 uint8_t *buf;
240
241 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
242 {
243 /* class request */
244 case USB_REQ_TYPE_CLASS:
245 switch(setup->bRequest)
246 {
247 case HID_REQ_SET_PROTOCOL:
248 paudio_hid->hid_protocol = (uint8_t)setup->wValue;
249 break;
250 case HID_REQ_GET_PROTOCOL:
251 usbd_ctrl_send(pudev, (uint8_t *)&paudio_hid->hid_protocol, 1);
252 break;
253 case HID_REQ_SET_IDLE:
254 paudio_hid->hid_set_idle = (uint8_t)(setup->wValue >> 8);
255 break;
256 case HID_REQ_GET_IDLE:
257 usbd_ctrl_send(pudev, (uint8_t *)&paudio_hid->hid_set_idle, 1);
258 break;
259 case HID_REQ_SET_REPORT:
260 paudio_hid->hid_state = HID_REQ_SET_REPORT;
261 usbd_ctrl_recv(pudev, paudio_hid->hid_set_report, setup->wLength);
262 break;
263 default:
264 usbd_ctrl_unsupport(pudev);
265 break;
266 }
267 break;
268 /* standard request */
269 case USB_REQ_TYPE_STANDARD:
270 switch(setup->bRequest)
271 {
272 case USB_STD_REQ_GET_DESCRIPTOR:
273 if(setup->wValue >> 8 == HID_REPORT_DESC)
274 {
275 len = MIN(USBD_AUHID_HID_SIZ_REPORT_DESC, setup->wLength);
276 buf = (uint8_t *)g_usbd_audio_hid_report;
277 }
278 else if(setup->wValue >> 8 == HID_DESCRIPTOR_TYPE)
279 {
280 len = MIN(9, setup->wLength);
281 buf = (uint8_t *)g_audio_hid_usb_desc;
282 }
283 usbd_ctrl_send(pudev, (uint8_t *)buf, len);
284 break;
285 case USB_STD_REQ_GET_INTERFACE:
286 usbd_ctrl_send(pudev, (uint8_t *)&paudio_hid->alt_setting, 1);
287 break;
288 case USB_STD_REQ_SET_INTERFACE:
289 paudio_hid->alt_setting = setup->wValue;
290 break;
291 default:
292 break;
293 }
294 break;
295 default:
296 usbd_ctrl_unsupport(pudev);
297 break;
298 }
299 return status;
300}
307static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
308{
309 usb_sts_type status = USB_OK;
310 usbd_core_type *pudev = (usbd_core_type *)udev;
311 switch(setup->bmRequestType & USB_REQ_RECIPIENT_MASK)
312 {
313 case USB_REQ_RECIPIENT_INTERFACE:
314 if(setup->wIndex == HID_INTERFACE_NUMBER)
315 {
316 class_hid_setup_handler(udev, setup);
317 }
318 else
319 {
320 class_audio_setup_handler(pudev, setup);
321 }
322 break;
323 case USB_REQ_RECIPIENT_ENDPOINT:
324 class_audio_setup_handler(pudev, setup);
325 break;
326
327 }
328 return status;
329
330
331}
332
338static usb_sts_type class_ept0_tx_handler(void *udev)
339{
340 usb_sts_type status = USB_OK;
341
342 /* ...user code... */
343
344 return status;
345}
346
352static usb_sts_type class_ept0_rx_handler(void *udev)
353{
354 usb_sts_type status = USB_OK;
355 usbd_core_type *pudev = (usbd_core_type *)udev;
356 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
357 usb_setup_type *setup = &pudev->setup;
358 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
359
360 /* ...user code... */
361 if(setup->wIndex == HID_INTERFACE_NUMBER)
362 {
363 if( paudio_hid->hid_state == HID_REQ_SET_REPORT)
364 {
365 /* hid buffer process */
366 usb_hid_buf_process(udev, paudio_hid->hid_set_report, recv_len);
367 paudio_hid->hid_state = 0;
368 }
369 }
370 else
371 {
372 /* ...user code... */
373 if( paudio_hid->audio_cmd == AUDIO_REQ_SET_CUR)
374 {
375 /* class process */
376 switch(paudio_hid->request_no)
377 {
378 case AUDIO_VOLUME_CONTROL:
379 if(paudio_hid->interface == AUDIO_SPK_FEATURE_UNIT_ID)
380 {
381 paudio_hid->spk_volume = (uint16_t)(paudio_hid->g_audio_cur[0] |
382 (paudio_hid->g_audio_cur[1] << 8));
383 /* set volume */
384 audio_codec_set_spk_volume(paudio_hid->spk_volume*100/paudio_hid->spk_volume_limits[1]);
385 }
386 else
387 {
388 paudio_hid->mic_volume = (uint16_t)(paudio_hid->g_audio_cur[0] |
389 (paudio_hid->g_audio_cur[1] << 8));
390
391 audio_codec_set_mic_volume(paudio_hid->mic_volume*256/paudio_hid->mic_volume_limits[1]);
392 }
393 break;
394 case AUDIO_MUTE_CONTROL:
395 if(paudio_hid->interface == AUDIO_SPK_FEATURE_UNIT_ID)
396 {
397 paudio_hid->spk_mute = paudio_hid->g_audio_cur[0];
398 audio_codec_set_spk_mute(paudio_hid->spk_mute);
399 }
400 else
401 {
402 paudio_hid->mic_mute = paudio_hid->g_audio_cur[0];
403 audio_codec_set_mic_mute(paudio_hid->mic_mute);
404 }
405
406 break;
407 case AUDIO_FREQ_SET_CONTROL:
408 if(paudio_hid->enpd == USBD_AUHID_AUDIO_MIC_IN_EPT)
409 {
410 paudio_hid->mic_freq = (paudio_hid->g_audio_cur[0] |
411 (paudio_hid->g_audio_cur[1] << 8) |
412 (paudio_hid->g_audio_cur[2] << 16));
413 audio_codec_set_mic_freq(paudio_hid->mic_freq);
414 }
415 else
416 {
417 paudio_hid->spk_freq = (paudio_hid->g_audio_cur[0] |
418 (paudio_hid->g_audio_cur[1] << 8) |
419 (paudio_hid->g_audio_cur[2] << 16));
420 audio_codec_set_spk_freq(paudio_hid->spk_freq);
421 }
422 break;
423 default:
424 break;
425 }
426 }
427 }
428
429 return status;
430}
431
438static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
439{
440 usb_sts_type status = USB_OK;
441 usbd_core_type *pudev = (usbd_core_type *)udev;
442 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
443 uint32_t len = 0;
444
445 /* ...user code...
446 trans next packet data
447 */
448 if((ept_num & 0x7F) == (USBD_AUHID_AUDIO_MIC_IN_EPT & 0x7F))
449 {
450 len = audio_codec_mic_get_data(paudio_hid->audio_mic_data);
451 usbd_flush_tx_fifo(udev, USBD_AUHID_AUDIO_MIC_IN_EPT);
452 usbd_ept_send(udev, USBD_AUHID_AUDIO_MIC_IN_EPT, paudio_hid->audio_mic_data, len);
453 }
454
455 else if((ept_num & 0x7F) == (USBD_AUHID_AUDIO_FEEDBACK_EPT & 0x7F))
456 {
457 paudio_hid->audio_feedback_state = 0;
458 }
459 else if((ept_num & 0x7F) == (USBD_AUHID_HID_IN_EPT & 0x7F))
460 {
461 usbd_flush_tx_fifo(udev, USBD_AUHID_HID_IN_EPT);
462 }
463
464 return status;
465}
466
473static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
474{
475 usb_sts_type status = USB_OK;
476 usbd_core_type *pudev = (usbd_core_type *)udev;
477 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
478 uint16_t g_rxlen;
479
480 /* get endpoint receive data length */
481 g_rxlen = usbd_get_recv_len(pudev, ept_num);
482
483 if((ept_num & 0x7F) == (USBD_AUHID_AUDIO_SPK_OUT_EPT & 0x7F))
484 {
485 /* speaker data*/
486 audio_codec_spk_fifo_write(paudio_hid->audio_spk_data, g_rxlen);
487 paudio_hid->audio_spk_out_stage = 1;
488 /* get next data */
489 usbd_ept_recv(pudev, USBD_AUHID_AUDIO_SPK_OUT_EPT, paudio_hid->audio_spk_data, AUDIO_SPK_OUT_MAXPACKET_SIZE);
490 }
491 else if((ept_num & 0x7F) == (USBD_AUHID_HID_OUT_EPT & 0x7F))
492 {
493 /* hid buffer process */
494 usb_hid_buf_process(udev, paudio_hid->g_rxhid_buff, g_rxlen);
495
496 /* start receive next packet */
497 usbd_ept_recv(pudev, USBD_AUHID_HID_OUT_EPT, paudio_hid->g_rxhid_buff, USBD_AUHID_OUT_MAXPACKET_SIZE);
498 }
499 return status;
500}
501
507static usb_sts_type class_sof_handler(void *udev)
508{
509 usb_sts_type status = USB_OK;
510 usbd_core_type *pudev = (usbd_core_type *)udev;
511 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
512
513#if AUDIO_SUPPORT_FEEDBACK
514 if(paudio_hid->audio_spk_out_stage & 2)
515 {
516 paudio_hid->audio_spk_out_stage = 0;
517 }
518 else if( paudio_hid->audio_spk_out_stage )
519 {
520 paudio_hid->audio_spk_out_stage |= 2;
521
522 if( 0 == paudio_hid->audio_feedback_state )
523 {
524 usbd_core_type *pudev = (usbd_core_type *)udev;
525 int len = audio_codec_spk_feedback(paudio_hid->audio_feed_back);
526 usbd_ept_send(pudev, USBD_AUHID_AUDIO_FEEDBACK_EPT, paudio_hid->audio_feed_back, len);
527 paudio_hid->audio_feedback_state = 1;
528 }
529 if( paudio_hid->audio_feedback_state++ > (1<<FEEDBACK_REFRESH_TIME) ) //timeout
530 {
531 usbd_core_type *pudev = (usbd_core_type *)udev;
532 int len = audio_codec_spk_feedback(paudio_hid->audio_feed_back);
533 usbd_flush_tx_fifo(pudev, USBD_AUHID_AUDIO_FEEDBACK_EPT);
534 usbd_ept_send(pudev, USBD_AUHID_AUDIO_FEEDBACK_EPT, paudio_hid->audio_feed_back, len);
535 paudio_hid->audio_feedback_state = 1;
536 }
537 }
538#endif
539 /* ...user code... */
540
541 return status;
542}
543
550static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
551{
552 usb_sts_type status = USB_OK;
553 usbd_core_type *pudev = (usbd_core_type *)udev;
554 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
555 switch(event)
556 {
557 case USBD_RESET_EVENT:
558
559 /* ...user code... */
560
561 break;
562 case USBD_SUSPEND_EVENT:
563 paudio_hid->spk_alt_setting = 0;
564 audio_codec_spk_alt_setting(paudio_hid->spk_alt_setting);
565 paudio_hid->mic_alt_setting = 0;
566 audio_codec_mic_alt_setting(paudio_hid->spk_alt_setting);
567 /* ...user code... */
568
569 break;
570 case USBD_WAKEUP_EVENT:
571 /* ...user code... */
572
573 break;
574 case USBD_INISOINCOM_EVENT:
575 audio_inisoincom_event(udev);
576 break;
577
578 default:
579 break;
580 }
581 return status;
582}
583
589static void audio_inisoincom_event(void *udev)
590{
591#if 0
592 usbd_core_type *pudev = (usbd_core_type *)udev;
593 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
594 uint32_t fnsof = OTG_DEVICE(pudev->usb_reg)->dsts_bit.soffn;
595 uint32_t epctl_fb = USB_INEPT(pudev->usb_reg, (USBD_AUHID_AUDIO_FEEDBACK_EPT&0x7F))->diepctl_bit.dpid;
596 uint32_t epctl_in = USB_INEPT(pudev->usb_reg, (USBD_AUHID_AUDIO_MIC_IN_EPT&0x7F))->diepctl_bit.dpid;
597 uint32_t len = 0;
598
599 if((fnsof & 0x1) == epctl_fb)
600 {
601 USB_INEPT(pudev->usb_reg, (USBD_AUHID_AUDIO_FEEDBACK_EPT&0x7F))->diepctl_bit.eptdis = 1;
602 USB_INEPT(pudev->usb_reg, (USBD_AUHID_AUDIO_FEEDBACK_EPT&0x7F))->diepctl_bit.snak = 1;
603 usb_flush_tx_fifo(pudev->usb_reg, USBD_AUHID_AUDIO_FEEDBACK_EPT&0x7F);
604
605 usbd_ept_send(pudev, USBD_AUHID_AUDIO_FEEDBACK_EPT, paudio_hid->audio_feed_back, 3);
606 }
607
608 if((fnsof & 0x1) == epctl_in)
609 {
610 USB_INEPT(pudev->usb_reg, (USBD_AUHID_AUDIO_MIC_IN_EPT&0x7F))->diepctl_bit.eptdis = 1;
611 USB_INEPT(pudev->usb_reg, (USBD_AUHID_AUDIO_MIC_IN_EPT&0x7F))->diepctl_bit.snak = 1;
612 usb_flush_tx_fifo(pudev->usb_reg, USBD_AUHID_AUDIO_MIC_IN_EPT&0x7F);
613
614 len = audio_codec_mic_get_data(paudio_hid->audio_mic_data);
615 usbd_ept_send(pudev, USBD_AUHID_AUDIO_MIC_IN_EPT, paudio_hid->audio_mic_data, len);
616 }
617#endif
618}
619
626static void audio_req_get_cur(void *udev, usb_setup_type *setup)
627{
628 usbd_core_type *pudev = (usbd_core_type *)udev;
629 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
630 if(HBYTE(setup->wIndex) == AUDIO_SPK_FEATURE_UNIT_ID)
631 {
632 if(HBYTE(setup->wValue) == AUDIO_MUTE_CONTROL)
633 {
634 paudio_hid->g_audio_cur[0] = paudio_hid->spk_mute;
635 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
636 }
637 else
638 {
639 *((uint16_t *)paudio_hid->g_audio_cur) = paudio_hid->spk_volume;
640 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
641 }
642 }
643 else
644 {
645 if(HBYTE(setup->wValue) == AUDIO_MUTE_CONTROL)
646 {
647 paudio_hid->g_audio_cur[0] = paudio_hid->mic_mute;
648 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
649 }
650 else
651 {
652 *((uint16_t *)paudio_hid->g_audio_cur) = paudio_hid->mic_volume;
653 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
654 }
655
656 }
657}
658
665static void audio_req_set_cur(void *udev, usb_setup_type *setup)
666{
667 usbd_core_type *pudev = (usbd_core_type *)udev;
668 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
669 if(setup->wLength > 0)
670 {
671 usbd_ctrl_recv(pudev, paudio_hid->g_audio_cur, setup->wLength);
672
673 paudio_hid->audio_cmd = AUDIO_REQ_SET_CUR;
674 paudio_hid->audio_cmd_len = setup->wLength;
675
676 switch(setup->bmRequestType & AUDIO_REQ_CONTROL_MASK)
677 {
678 case AUDIO_REQ_CONTROL_INTERFACE:
679 paudio_hid->interface = HBYTE(setup->wIndex);
680 if(HBYTE(setup->wValue) == AUDIO_MUTE_CONTROL)
681 {
682 paudio_hid->request_no = AUDIO_MUTE_CONTROL;
683 }
684 else
685 {
686 paudio_hid->request_no = AUDIO_VOLUME_CONTROL;
687 }
688 break;
689 case AUDIO_REQ_CONTROL_ENDPOINT:
690 paudio_hid->enpd = setup->wIndex;
691 paudio_hid->request_no = AUDIO_FREQ_SET_CONTROL;
692 break;
693 default:
694 break;
695 }
696 }
697}
698
705static void audio_req_get_min(void *udev, usb_setup_type *setup)
706{
707 usbd_core_type *pudev = (usbd_core_type *)udev;
708 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
709 if(HBYTE(setup->wIndex) == AUDIO_SPK_FEATURE_UNIT_ID)
710 {
711 *((uint16_t *)paudio_hid->g_audio_cur) = paudio_hid->spk_volume_limits[0];
712 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
713 }
714 else
715 {
716 *((uint16_t *)paudio_hid->g_audio_cur) = paudio_hid->mic_volume_limits[0];
717 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
718 }
719}
720
727static void audio_req_get_max(void *udev, usb_setup_type *setup)
728{
729 usbd_core_type *pudev = (usbd_core_type *)udev;
730 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
731 if(HBYTE(setup->wIndex) == AUDIO_SPK_FEATURE_UNIT_ID)
732 {
733 *((uint16_t *)paudio_hid->g_audio_cur) = paudio_hid->spk_volume_limits[1];
734 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
735 }
736 else
737 {
738 *((uint16_t *)paudio_hid->g_audio_cur) = paudio_hid->mic_volume_limits[1];
739 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
740 }
741}
742
749static void audio_req_get_res(void *udev, usb_setup_type *setup)
750{
751 usbd_core_type *pudev = (usbd_core_type *)udev;
752 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
753 if(HBYTE(setup->wIndex) == AUDIO_SPK_FEATURE_UNIT_ID)
754 {
755 *((uint16_t *)paudio_hid->g_audio_cur) = paudio_hid->spk_volume_limits[2];
756 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
757 }
758 else
759 {
760 *((uint16_t *)paudio_hid->g_audio_cur) = paudio_hid->mic_volume_limits[2];
761 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
762 }
763}
764
771static void audio_set_interface(void *udev, usb_setup_type *setup)
772{
773 uint32_t len;
774 usbd_core_type *pudev = (usbd_core_type *)udev;
775 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
776 if(LBYTE(setup->wIndex) == AUDIO_SPK_INTERFACE_NUMBER)
777 {
778 paudio_hid->spk_alt_setting = setup->wValue;
779 audio_codec_spk_alt_setting(paudio_hid->spk_alt_setting);
780 if(paudio_hid->spk_alt_setting )
781 {
782 usbd_ept_recv(pudev, USBD_AUHID_AUDIO_SPK_OUT_EPT, paudio_hid->audio_spk_data, AUDIO_SPK_OUT_MAXPACKET_SIZE);
783 }
784
785 }
786 else if(LBYTE(setup->wIndex) == AUDIO_MIC_INTERFACE_NUMBER)
787 {
788 paudio_hid->mic_alt_setting = setup->wValue;
789 audio_codec_mic_alt_setting(paudio_hid->mic_alt_setting);
790 if(paudio_hid->mic_alt_setting)
791 {
792 len = audio_codec_mic_get_data(paudio_hid->audio_mic_data);
793 usbd_ept_send(pudev, USBD_AUHID_AUDIO_MIC_IN_EPT, paudio_hid->audio_mic_data, len);
794 }
795 }
796
797}
798
805static void audio_get_interface(void *udev, usb_setup_type *setup)
806{
807 usbd_core_type *pudev = (usbd_core_type *)udev;
808 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
809 if(LBYTE(setup->wIndex) == AUDIO_SPK_INTERFACE_NUMBER)
810 {
811 usbd_ctrl_send(pudev, (uint8_t *)&paudio_hid->spk_alt_setting, 1);
812 }
813 else if(LBYTE(setup->wIndex) == AUDIO_MIC_INTERFACE_NUMBER)
814 {
815 usbd_ctrl_send(pudev, (uint8_t *)&paudio_hid->mic_alt_setting, 1);
816 }
817
818}
819
827 usb_sts_type audio_hid_class_send_report(void *udev, uint8_t *report, uint16_t len)
828{
829 usb_sts_type status = USB_OK;
830 usbd_core_type *pudev = (usbd_core_type *)udev;
831
832 if(usbd_connect_state_get(pudev) == USB_CONN_STATE_CONFIGURED)
833 usbd_ept_send(pudev, USBD_AUHID_HID_IN_EPT, report, len);
834
835 return status;
836}
837
838
846static void usb_hid_buf_process(void *udev, uint8_t *report, uint16_t len)
847{
848 uint32_t i_index;
849 usbd_core_type *pudev = (usbd_core_type *)udev;
850 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
851
852 switch(report[0])
853 {
854 case HID_REPORT_ID_2:
855 if(paudio_hid->g_rxhid_buff[1] == 0)
856 {
857 at32_led_off(LED2);
858 }
859 else
860 {
861 at32_led_on(LED2);
862 }
863 break;
864 case HID_REPORT_ID_3:
865 if(paudio_hid->g_rxhid_buff[1] == 0)
866 {
867 at32_led_off(LED3);
868 }
869 else
870 {
871 at32_led_on(LED3);
872 }
873 break;
874 case HID_REPORT_ID_4:
875 if(paudio_hid->g_rxhid_buff[1] == 0)
876 {
877 at32_led_off(LED4);
878 }
879 else
880 {
881 at32_led_on(LED4);
882 }
883 break;
884 case HID_REPORT_ID_6:
885 for(i_index = 0; i_index < len; i_index ++)
886 {
887 paudio_hid->g_txhid_buff[i_index] = report[i_index];
888 }
889 usbd_ept_send(pudev, USBD_AUHID_HID_IN_EPT, paudio_hid->g_txhid_buff, len);
890 break;
891 default:
892 break;
893 }
894
895}
896
897
audio_hid_class.h
audio_hid_desc.h
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
AUDIO_DESCRIPTOR_TYPE
#define AUDIO_DESCRIPTOR_TYPE
audio descriptor type
Definition: audio_class.h:83
AUDIO_MIC_IN_MAXPACKET_SIZE
#define AUDIO_MIC_IN_MAXPACKET_SIZE
Definition: audio_class.h:62
AUDIO_MUTE_CONTROL
#define AUDIO_MUTE_CONTROL
audio set cur type define
Definition: audio_class.h:76
AUDIO_REQ_CONTROL_INTERFACE
#define AUDIO_REQ_CONTROL_INTERFACE
request type define
Definition: audio_class.h:69
AUDIO_SPK_OUT_MAXPACKET_SIZE
#define AUDIO_SPK_OUT_MAXPACKET_SIZE
Definition: audio_class.h:63
AUDIO_VOLUME_CONTROL
#define AUDIO_VOLUME_CONTROL
Definition: audio_class.h:77
AUDIO_FREQ_SET_CONTROL
#define AUDIO_FREQ_SET_CONTROL
Definition: audio_class.h:78
AUDIO_REQ_CONTROL_ENDPOINT
#define AUDIO_REQ_CONTROL_ENDPOINT
Definition: audio_class.h:70
FEEDBACK_REFRESH_TIME
#define FEEDBACK_REFRESH_TIME
Definition: audio_class.h:65
AUDIO_REQ_CONTROL_MASK
#define AUDIO_REQ_CONTROL_MASK
Definition: audio_class.h:71
AUDIO_DESCRIPTOR_SIZE
#define AUDIO_DESCRIPTOR_SIZE
Definition: audio_class.h:84
AUDIO_FEEDBACK_MAXPACKET_SIZE
#define AUDIO_FEEDBACK_MAXPACKET_SIZE
Definition: audio_class.h:64
AUDIO_REQ_GET_CUR
#define AUDIO_REQ_GET_CUR
Definition: audio_desc.h:113
AUDIO_SPK_INTERFACE_NUMBER
#define AUDIO_SPK_INTERFACE_NUMBER
Definition: audio_desc.h:180
AUDIO_MIC_INTERFACE_NUMBER
#define AUDIO_MIC_INTERFACE_NUMBER
audio interface number
Definition: audio_desc.h:178
AUDIO_REQ_GET_MAX
#define AUDIO_REQ_GET_MAX
Definition: audio_desc.h:117
AUDIO_REQ_GET_MIN
#define AUDIO_REQ_GET_MIN
Definition: audio_desc.h:115
AUDIO_SPK_FEATURE_UNIT_ID
#define AUDIO_SPK_FEATURE_UNIT_ID
Definition: audio_desc.h:172
AUDIO_REQ_GET_RES
#define AUDIO_REQ_GET_RES
Definition: audio_desc.h:119
AUDIO_REQ_SET_CUR
#define AUDIO_REQ_SET_CUR
Definition: audio_desc.h:112
USBD_AUHID_AUDIO_MIC_IN_EPT
#define USBD_AUHID_AUDIO_MIC_IN_EPT
endpoint define
Definition: audio_hid_class.h:54
USBD_AUHID_HID_IN_EPT
#define USBD_AUHID_HID_IN_EPT
usb custom hid use endpoint define
Definition: audio_hid_class.h:61
USBD_AUHID_HID_OUT_EPT
#define USBD_AUHID_HID_OUT_EPT
Definition: audio_hid_class.h:62
USBD_AUHID_AUDIO_FEEDBACK_EPT
#define USBD_AUHID_AUDIO_FEEDBACK_EPT
Definition: audio_hid_class.h:56
USBD_AUHID_OUT_MAXPACKET_SIZE
#define USBD_AUHID_OUT_MAXPACKET_SIZE
Definition: audio_hid_class.h:68
USBD_AUHID_AUDIO_SPK_OUT_EPT
#define USBD_AUHID_AUDIO_SPK_OUT_EPT
Definition: audio_hid_class.h:55
USBD_AUHID_IN_MAXPACKET_SIZE
#define USBD_AUHID_IN_MAXPACKET_SIZE
usb custom hid in and out max packet size define
Definition: audio_hid_class.h:67
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: audio_hid_class.c:507
class_hid_setup_handler
static usb_sts_type class_hid_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: audio_hid_class.c:233
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: audio_hid_class.c:438
audio_inisoincom_event
static void audio_inisoincom_event(void *udev)
usb audio in iso incom event
Definition: audio_hid_class.c:589
audio_hid_class_send_report
usb_sts_type audio_hid_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: audio_hid_class.c:827
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: audio_hid_class.c:121
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: audio_hid_class.c:307
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: audio_hid_class.c:338
audio_hid_class_handler
usbd_class_handler audio_hid_class_handler
Definition: audio_hid_class.c:66
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: audio_hid_class.c:352
audio_req_get_res
static void audio_req_get_res(void *udev, usb_setup_type *setup)
usb audio request get res
Definition: audio_hid_class.c:749
audio_get_interface
static void audio_get_interface(void *udev, usb_setup_type *setup)
usb audio get interface
Definition: audio_hid_class.c:805
audio_req_set_cur
static void audio_req_set_cur(void *udev, usb_setup_type *setup)
usb audio request set cur
Definition: audio_hid_class.c:665
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: audio_hid_class.c:550
audio_req_get_max
static void audio_req_get_max(void *udev, usb_setup_type *setup)
usb audio request get max
Definition: audio_hid_class.c:727
usb_hid_buf_process
static void usb_hid_buf_process(void *udev, uint8_t *report, uint16_t len)
usb device report function
Definition: audio_hid_class.c:846
audio_req_get_min
static void audio_req_get_min(void *udev, usb_setup_type *setup)
usb audio request get min
Definition: audio_hid_class.c:705
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: audio_hid_class.c:85
class_audio_setup_handler
static usb_sts_type class_audio_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: audio_hid_class.c:153
audio_hid_struct
usb_audio_hid_type audio_hid_struct
Definition: audio_hid_class.c:64
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: audio_hid_class.c:473
audio_req_get_cur
static void audio_req_get_cur(void *udev, usb_setup_type *setup)
usb audio request get cur
Definition: audio_hid_class.c:626
audio_set_interface
static void audio_set_interface(void *udev, usb_setup_type *setup)
usb audio set interface
Definition: audio_hid_class.c:771
USBD_AUHID_HID_SIZ_REPORT_DESC
#define USBD_AUHID_HID_SIZ_REPORT_DESC
Definition: audio_hid_desc.h:236
HID_REPORT_ID_2
#define HID_REPORT_ID_2
Definition: audio_hid_desc.h:223
HID_REPORT_ID_4
#define HID_REPORT_ID_4
Definition: audio_hid_desc.h:225
HID_REPORT_ID_6
#define HID_REPORT_ID_6
Definition: audio_hid_desc.h:227
HID_REPORT_ID_3
#define HID_REPORT_ID_3
Definition: audio_hid_desc.h:224
g_audio_hid_usb_desc
uint8_t g_audio_hid_usb_desc[9]
usb hid descriptor
Definition: audio_hid_desc.c:525
g_usbd_audio_hid_report
uint8_t g_usbd_audio_hid_report[126]
usb hid report descriptor
Definition: audio_hid_desc.c:427
HID_INTERFACE_NUMBER
#define HID_INTERFACE_NUMBER
Definition: audio_hid_desc.h:183
audio_codec_mic_alt_setting
void audio_codec_mic_alt_setting(uint32_t alt_seting)
audio codec microphone alt setting config
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:173
audio_codec_set_spk_volume
void audio_codec_set_spk_volume(uint16_t volume)
audio codec set speaker volume
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:221
audio_codec_set_spk_mute
void audio_codec_set_spk_mute(uint8_t mute)
audio codec set speaker mute
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:199
audio_codec_set_mic_freq
void audio_codec_set_mic_freq(uint32_t freq)
audio codec set microphone freq
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:125
audio_codec_mic_get_data
uint32_t audio_codec_mic_get_data(uint8_t *buffer)
codec microphone get data
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:286
audio_codec_set_mic_mute
void audio_codec_set_mic_mute(uint8_t mute)
audio codec set microphone mute
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:188
audio_codec_spk_fifo_write
void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
audio codec interface
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:248
audio_codec_spk_feedback
uint8_t audio_codec_spk_feedback(uint8_t *feedback)
codec speaker feedback
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:232
audio_codec_set_mic_volume
void audio_codec_set_mic_volume(uint16_t volume)
audio codec set microphone volume
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:210
audio_codec_spk_alt_setting
void audio_codec_spk_alt_setting(uint32_t alt_seting)
audio codec speaker alt setting config
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:158
audio_codec_set_spk_freq
void audio_codec_set_spk_freq(uint32_t freq)
audio codec set speaker freq
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:141
AUDIO_SUPPORT_FEEDBACK
#define AUDIO_SUPPORT_FEEDBACK
Definition: audio/audio_conf.h:49
EPT_ISO_TYPE
@ EPT_ISO_TYPE
Definition: at32f435_437_usb.h:347
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f435_437_usb.h:349
usb_flush_tx_fifo
void usb_flush_tx_fifo(otg_global_type *usbx, uint32_t fifo_num)
flush tx fifo
Definition: at32f435_437_usb.c:124
OTG_DEVICE
#define OTG_DEVICE(usbx)
Definition: at32f435_437_usb.h:1331
USB_INEPT
#define USB_INEPT(usbx, eptn)
Definition: at32f435_437_usb.h:1334
HID_DESCRIPTOR_TYPE
#define HID_DESCRIPTOR_TYPE
Definition: usb_std.h:236
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
HID_REQ_GET_PROTOCOL
#define HID_REQ_GET_PROTOCOL
Definition: usb_std.h:231
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:254
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:63
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:81
HID_REQ_SET_PROTOCOL
#define HID_REQ_SET_PROTOCOL
usb hid class request code define
Definition: usb_std.h:230
HID_REPORT_DESC
#define HID_REPORT_DESC
Definition: usb_std.h:237
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
HID_REQ_SET_IDLE
#define HID_REQ_SET_IDLE
Definition: usb_std.h:232
HID_REQ_GET_IDLE
#define HID_REQ_GET_IDLE
Definition: usb_std.h:233
HID_REQ_SET_REPORT
#define HID_REQ_SET_REPORT
Definition: usb_std.h:234
USB_REQ_RECIPIENT_MASK
#define USB_REQ_RECIPIENT_MASK
Definition: usb_std.h:58
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:86
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:66
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:85
USB_REQ_RECIPIENT_ENDPOINT
#define USB_REQ_RECIPIENT_ENDPOINT
Definition: usb_std.h:56
USB_REQ_RECIPIENT_INTERFACE
#define USB_REQ_RECIPIENT_INTERFACE
Definition: usb_std.h:55
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:64
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:131
USB_OK
@ USB_OK
Definition: usb_std.h:268
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:597
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:346
usbd_ctrl_send_status
void usbd_ctrl_send_status(usbd_core_type *udev)
usb control endpoint send in status
Definition: usbd_core.c:212
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint receive data
Definition: usbd_core.c:534
usbd_flush_tx_fifo
void usbd_flush_tx_fifo(usbd_core_type *udev, uint8_t ept_num)
usb device flush in endpoint fifo
Definition: usbd_core.c:650
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:314
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:177
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint send data
Definition: usbd_core.c:434
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
get endpoint receive data length
Definition: usbd_core.c:300
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint recv data
Definition: usbd_core.c:196
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:287
usb_audio_hid_type
usb audio control struct
Definition: audio_hid_class.h:113
usb_audio_hid_type::spk_volume_limits
uint16_t spk_volume_limits[3]
Definition: audio_hid_class.h:124
usb_audio_hid_type::audio_cmd
uint8_t audio_cmd
Definition: audio_hid_class.h:127
usb_audio_hid_type::request_no
uint8_t request_no
Definition: audio_hid_class.h:117
usb_audio_hid_type::g_txhid_buff
uint8_t g_txhid_buff[0x40]
Definition: audio_hid_class.h:146
usb_audio_hid_type::mic_freq
uint32_t mic_freq
Definition: audio_hid_class.h:123
usb_audio_hid_type::interface
uint8_t interface
Definition: audio_hid_class.h:116
usb_audio_hid_type::audio_spk_data
uint8_t audio_spk_data[(48 *2 *(16/8)+40)]
Definition: audio_hid_class.h:132
usb_audio_hid_type::spk_volume
uint16_t spk_volume
Definition: audio_hid_class.h:120
usb_audio_hid_type::mic_alt_setting
uint32_t mic_alt_setting
Definition: audio_hid_class.h:130
usb_audio_hid_type::mic_volume
uint16_t mic_volume
Definition: audio_hid_class.h:121
usb_audio_hid_type::alt_setting
uint32_t alt_setting
Definition: audio_hid_class.h:142
usb_audio_hid_type::spk_alt_setting
uint32_t spk_alt_setting
Definition: audio_hid_class.h:129
usb_audio_hid_type::enpd
uint8_t enpd
Definition: audio_hid_class.h:115
usb_audio_hid_type::hid_state
uint8_t hid_state
Definition: audio_hid_class.h:143
usb_audio_hid_type::mic_mute
uint8_t mic_mute
Definition: audio_hid_class.h:119
usb_audio_hid_type::hid_set_idle
uint32_t hid_set_idle
Definition: audio_hid_class.h:141
usb_audio_hid_type::audio_feedback_state
__IO uint16_t audio_feedback_state
Definition: audio_hid_class.h:135
usb_audio_hid_type::mic_volume_limits
uint16_t mic_volume_limits[3]
Definition: audio_hid_class.h:125
usb_audio_hid_type::audio_feed_back
uint8_t audio_feed_back[0x3+1]
Definition: audio_hid_class.h:134
usb_audio_hid_type::audio_cmd_len
uint32_t audio_cmd_len
Definition: audio_hid_class.h:128
usb_audio_hid_type::g_rxhid_buff
uint8_t g_rxhid_buff[0x40]
Definition: audio_hid_class.h:145
usb_audio_hid_type::spk_freq
uint32_t spk_freq
Definition: audio_hid_class.h:122
usb_audio_hid_type::audio_spk_out_stage
__IO uint8_t audio_spk_out_stage
Definition: audio_hid_class.h:136
usb_audio_hid_type::audio_mic_data
uint8_t audio_mic_data[(48 *2 *(16/8)+40)]
Definition: audio_hid_class.h:133
usb_audio_hid_type::hid_set_report
uint8_t hid_set_report[64]
Definition: audio_hid_class.h:144
usb_audio_hid_type::g_audio_cur
uint8_t g_audio_cur[64]
Definition: audio_hid_class.h:131
usb_audio_hid_type::hid_protocol
uint32_t hid_protocol
Definition: audio_hid_class.h:140
usb_audio_hid_type::spk_mute
uint8_t spk_mute
Definition: audio_hid_class.h:118
usb_setup_type
format of usb setup data
Definition: usb_std.h:280
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:283
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:286
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:281
usb_setup_type::wIndex
uint16_t wIndex
Definition: usb_std.h:284
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:282
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: audio_hid_class.h Source File

  • middlewares
  • usbd_class
  • audio_hid
audio_hid_class.h
Go to the documentation of this file.
1
27 /* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AUDIO_HID_CLASS_H
29#define __AUDIO_HID_CLASS_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "usb_std.h"
36#include "usbd_core.h"
37#include "audio_conf.h"
38
54#define USBD_AUHID_AUDIO_MIC_IN_EPT 0x81
55#define USBD_AUHID_AUDIO_SPK_OUT_EPT 0x02
56#define USBD_AUHID_AUDIO_FEEDBACK_EPT 0x83
57
61#define USBD_AUHID_HID_IN_EPT 0x82
62#define USBD_AUHID_HID_OUT_EPT 0x01
63
67#define USBD_AUHID_IN_MAXPACKET_SIZE 0x40
68#define USBD_AUHID_OUT_MAXPACKET_SIZE 0x40
69
73#define AUDIO_REMAIN_SIZE 40
74#define AUDIO_MIC_IN_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_MIC_CHANEL_NUM * (AUDIO_MIC_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
75#define AUDIO_SPK_OUT_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_SPK_CHANEL_NUM * (AUDIO_SPK_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
76#define AUDIO_FEEDBACK_MAXPACKET_SIZE 0x3
77#define FEEDBACK_REFRESH_TIME 0x8
81#define AUDIO_REQ_CONTROL_INTERFACE 0x01
82#define AUDIO_REQ_CONTROL_ENDPOINT 0x02
83#define AUDIO_REQ_CONTROL_MASK 0x03
84
88#define AUDIO_MUTE_CONTROL 0x01
89#define AUDIO_VOLUME_CONTROL 0x02
90#define AUDIO_FREQ_SET_CONTROL 0x03
91
99#define AUDIO_MUTE_CONTROL 0x01
100#define AUDIO_VOLUME_CONTROL 0x02
101#define AUDIO_FREQ_SET_CONTROL 0x03
102
106#define AUDIO_DESCRIPTOR_TYPE 0x21
107#define AUDIO_DESCRIPTOR_SIZE 0x09
108
112typedef struct
113{
114 /* audio */
115 uint8_t enpd;
116 uint8_t interface;
117 uint8_t request_no;
118 uint8_t spk_mute;
119 uint8_t mic_mute;
120 uint16_t spk_volume;
121 uint16_t mic_volume;
122 uint32_t spk_freq;
123 uint32_t mic_freq;
124 uint16_t spk_volume_limits[3]; /*[0] is mininum value, [1] is maxnum value, [2] is volume resolution */
125 uint16_t mic_volume_limits[3]; /*[0] is mininum value, [1] is maxnum value, [2] is volume resolution */
126
127 uint8_t audio_cmd;
128 uint32_t audio_cmd_len;
129 uint32_t spk_alt_setting;
130 uint32_t mic_alt_setting;
131 uint8_t g_audio_cur[64];
132 uint8_t audio_spk_data[AUDIO_SPK_OUT_MAXPACKET_SIZE];
133 uint8_t audio_mic_data[AUDIO_MIC_IN_MAXPACKET_SIZE];
134 uint8_t audio_feed_back[AUDIO_FEEDBACK_MAXPACKET_SIZE+1];
135 __IO uint16_t audio_feedback_state;
136 __IO uint8_t audio_spk_out_stage;
137
138
139 /* hid */
140 uint32_t hid_protocol;
141 uint32_t hid_set_idle;
142 uint32_t alt_setting;
143 uint8_t hid_state;
144 uint8_t hid_set_report[64];
145 uint8_t g_rxhid_buff[USBD_AUHID_OUT_MAXPACKET_SIZE];
146 uint8_t g_txhid_buff[USBD_AUHID_IN_MAXPACKET_SIZE];
147}usb_audio_hid_type;
148
149
150extern usbd_class_handler audio_hid_class_handler;
151 usb_sts_type audio_hid_class_send_report(void *udev, uint8_t *report, uint16_t len);
152
164#ifdef __cplusplus
165}
166#endif
167
168#endif
audio_conf.h
usb audio config
audio_hid_class_send_report
usb_sts_type audio_hid_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: audio_hid_class.c:827
AUDIO_MIC_IN_MAXPACKET_SIZE
#define AUDIO_MIC_IN_MAXPACKET_SIZE
Definition: audio_hid_class.h:74
audio_hid_class_handler
usbd_class_handler audio_hid_class_handler
Definition: audio_hid_class.c:66
AUDIO_SPK_OUT_MAXPACKET_SIZE
#define AUDIO_SPK_OUT_MAXPACKET_SIZE
Definition: audio_hid_class.h:75
USBD_AUHID_OUT_MAXPACKET_SIZE
#define USBD_AUHID_OUT_MAXPACKET_SIZE
Definition: audio_hid_class.h:68
USBD_AUHID_IN_MAXPACKET_SIZE
#define USBD_AUHID_IN_MAXPACKET_SIZE
usb custom hid in and out max packet size define
Definition: audio_hid_class.h:67
AUDIO_FEEDBACK_MAXPACKET_SIZE
#define AUDIO_FEEDBACK_MAXPACKET_SIZE
Definition: audio_hid_class.h:76
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
usb_audio_hid_type
usb audio control struct
Definition: audio_hid_class.h:113
usb_audio_hid_type::audio_cmd
uint8_t audio_cmd
Definition: audio_hid_class.h:127
usb_audio_hid_type::request_no
uint8_t request_no
Definition: audio_hid_class.h:117
usb_audio_hid_type::mic_freq
uint32_t mic_freq
Definition: audio_hid_class.h:123
usb_audio_hid_type::interface
uint8_t interface
Definition: audio_hid_class.h:116
usb_audio_hid_type::spk_volume
uint16_t spk_volume
Definition: audio_hid_class.h:120
usb_audio_hid_type::mic_alt_setting
uint32_t mic_alt_setting
Definition: audio_hid_class.h:130
usb_audio_hid_type::mic_volume
uint16_t mic_volume
Definition: audio_hid_class.h:121
usb_audio_hid_type::alt_setting
uint32_t alt_setting
Definition: audio_hid_class.h:142
usb_audio_hid_type::spk_alt_setting
uint32_t spk_alt_setting
Definition: audio_hid_class.h:129
usb_audio_hid_type::enpd
uint8_t enpd
Definition: audio_hid_class.h:115
usb_audio_hid_type::hid_state
uint8_t hid_state
Definition: audio_hid_class.h:143
usb_audio_hid_type::mic_mute
uint8_t mic_mute
Definition: audio_hid_class.h:119
usb_audio_hid_type::hid_set_idle
uint32_t hid_set_idle
Definition: audio_hid_class.h:141
usb_audio_hid_type::audio_feedback_state
__IO uint16_t audio_feedback_state
Definition: audio_hid_class.h:135
usb_audio_hid_type::audio_cmd_len
uint32_t audio_cmd_len
Definition: audio_hid_class.h:128
usb_audio_hid_type::spk_freq
uint32_t spk_freq
Definition: audio_hid_class.h:122
usb_audio_hid_type::audio_spk_out_stage
__IO uint8_t audio_spk_out_stage
Definition: audio_hid_class.h:136
usb_audio_hid_type::hid_protocol
uint32_t hid_protocol
Definition: audio_hid_class.h:140
usb_audio_hid_type::spk_mute
uint8_t spk_mute
Definition: audio_hid_class.h:118
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: audio_hid_desc.c Source File

  • middlewares
  • usbd_class
  • audio_hid
audio_hid_desc.c
Go to the documentation of this file.
1
26#include "usb_std.h"
27#include "usbd_sdr.h"
28#include "usbd_core.h"
29#include "audio_hid_desc.h"
30
43static usbd_desc_t *get_device_descriptor(void);
44static usbd_desc_t *get_device_qualifier(void);
45static usbd_desc_t *get_device_configuration(void);
46static usbd_desc_t *get_device_other_speed(void);
47static usbd_desc_t *get_device_lang_id(void);
48static usbd_desc_t *get_device_manufacturer_string(void);
49static usbd_desc_t *get_device_product_string(void);
50static usbd_desc_t *get_device_serial_string(void);
51static usbd_desc_t *get_device_interface_string(void);
52static usbd_desc_t *get_device_config_string(void);
53
54static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
55static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
56static void get_serial_num(void);
57static uint8_t g_usbd_desc_buffer[256];
58
62usbd_desc_handler audio_hid_desc_handler =
63{
64 get_device_descriptor,
65 get_device_qualifier,
66 get_device_configuration,
67 get_device_other_speed,
68 get_device_lang_id,
69 get_device_manufacturer_string,
70 get_device_product_string,
71 get_device_serial_string,
72 get_device_interface_string,
73 get_device_config_string,
74};
75
79#if defined ( __ICCARM__ ) /* iar compiler */
80 #pragma data_alignment=4
81#endif
82ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
83{
84 USB_DEVICE_DESC_LEN, /* bLength */
85 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
86 0x00, /* bcdUSB */
87 0x02,
88 0x00, /* bDeviceClass */
89 0x00, /* bDeviceSubClass */
90 0x00, /* bDeviceProtocol */
91 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
92 LBYTE(USBD_AUHID_VENDOR_ID), /* idVendor */
93 HBYTE(USBD_AUHID_VENDOR_ID), /* idVendor */
94#if AUDIO_SUPPORT_FEEDBACK
95 LBYTE(USBD_AUHID_PRODUCT_ID), /* idProduct */
96 HBYTE(USBD_AUHID_PRODUCT_ID), /* idProduct */
97#else
98 LBYTE(USBD_AUHID_PRODUCT_ID+1), /* idProduct */
99 HBYTE(USBD_AUHID_PRODUCT_ID+1), /* idProduct */
100#endif
101 0x00, /* bcdDevice rel. 2.00 */
102 0x02,
103 USB_MFC_STRING, /* Index of manufacturer string */
104 USB_PRODUCT_STRING, /* Index of product string */
105 USB_SERIAL_STRING, /* Index of serial number string */
106 0x01 /* bNumConfigurations */
107};
108
112#if defined ( __ICCARM__ ) /* iar compiler */
113 #pragma data_alignment=4
114#endif
115ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_AUHID_CONFIG_DESC_SIZE] ALIGNED_TAIL =
116{
117 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
118 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
119 LBYTE(USBD_AUHID_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
120 HBYTE(USBD_AUHID_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
121 0x1 + AUDIO_INTERFACE_NUM + 0x1, /* bNumInterfaces: n interface */
122 0x01, /* bConfigurationValue: configuration value */
123 0x00, /* iConfiguration: index of string descriptor describing
124 the configuration */
125 0xC0, /* bmAttributes: self powered */
126 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
127
128 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
129 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
130 0x00, /* bInterfaceNumber: number of interface */
131 0x00, /* bAlternateSetting: alternate set */
132 0x00, /* bNumEndpoints: number of endpoints */
133 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio class code */
134 AUDIO_SUBCLASS_AUDIOCONTROL, /* bInterfaceSubClass: audio control */
135 AUDIO_PROTOCOL_UNDEFINED, /* bInterfaceProtocol: undefined */
136 0x00, /* iInterface: index of string descriptor */
137
138 0x08+AUDIO_INTERFACE_NUM, /* bLength: size of this descriptor, in bytes 8+n */
139 AUDIO_CS_INTERFACE, /* bDescriptorType: cs interface descriptor type */
140 AUDIO_AC_HEADER, /* bDescriptorSubtype: Header function Descriptor*/
141 LBYTE(AUHID_BCD_NUM),
142 HBYTE(AUHID_BCD_NUM), /* bcdCDC: audio device class specification release number */
143 LBYTE(AUDIO_INTERFACE_LEN),
144 HBYTE(AUDIO_INTERFACE_LEN), /* wTotalLength: total number of bytes returned for the class-specific audio control interface */
145 AUDIO_INTERFACE_NUM, /* bInClollection: the number of audio streaming */
146#if (AUDIO_INTERFACE_NUM == 2) /* two interface */
147 0x02,
148 0x01,
149#else
150 0x01,
151#endif
152
153 /* usb microphone config */
154#if (AUDIO_SUPPORT_MIC == 1)
155 AUDIO_INPUT_TERMINAL_SIZE, /* bLength: descriptor size */
156 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
157 AUDIO_AC_INPUT_TERMINAL, /* bDescriptorSubtype: input_terminal type*/
158 AUDIO_MIC_INPUT_TERMINAL_ID, /* bTerminalID: id of this input terminal*/
159 LBYTE(AUDIO_INPUT_TERMINAL_MICROPHONE),
160 HBYTE(AUDIO_INPUT_TERMINAL_MICROPHONE),/* wTerminalType: terminal is microphone */
161 AUDIO_MIC_OUTPUT_TERMINAL_ID, /* bAssocTerminal: no association */
162 AUDIO_MIC_CHR, /* bNrChannels: two channel */
163#if (AUDIO_MIC_CHR == 2)
164 0x03, /* wChannelConfig: left front and right front */
165#endif
166#if (AUDIO_MIC_CHR == 1)
167 0x00, /* wChannelConfig */
168#endif
169 0x00, /* wChannelConfig */
170 0x00, /* iChannelNames: unused */
171 0x00, /* iTerminal: unused */
172
173 AUDIO_FEATURE_UNIT_SIZE, /* bLength: descriptor size */
174 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
175 AUDIO_AC_FEATURE_UNIT, /* bDescriptorSubtype: feature unit type*/
176 AUDIO_MIC_FEATURE_UNIT_ID, /* bUnitID: id of this feature unit */
177 AUDIO_MIC_INPUT_TERMINAL_ID, /* bSourceID: from input terminal */
178 0x01, /* bControlSize: 1 byte */
179 0x01, /* bmaControls0: mute */
180 0x02, /* bmaControls1: volume */
181 0x00, /* iFeature: unused */
182
183 AUDIO_OUTPUT_TERMINAL_SIZE, /* bLength: descriptor size */
184 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
185 AUDIO_AC_OUTPUT_TERMINAL, /* bDescriptorSubtype: output_terminal type*/
186 AUDIO_MIC_OUTPUT_TERMINAL_ID, /* bTerminalID: id of this output terminal*/
187 LBYTE(AUDIO_TERMINAL_TYPE_STREAMING),
188 HBYTE(AUDIO_TERMINAL_TYPE_STREAMING), /* wTerminalType: usb streaming */
189 AUDIO_MIC_INPUT_TERMINAL_ID, /* bAssocTerminal: unused */
190 AUDIO_MIC_FEATURE_UNIT_ID, /* bSourceID: from feature unit terminal */
191 0x00, /* iTerminal: unused */
192#endif
193
194#if (AUDIO_SUPPORT_SPK == 1)
195 /* speaker config */
196 AUDIO_INPUT_TERMINAL_SIZE, /* bLength: descriptor size */
197 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
198 AUDIO_AC_INPUT_TERMINAL, /* bDescriptorSubtype: input_terminal type*/
199 AUDIO_SPK_INPUT_TERMINAL_ID, /* bTerminalID: id of this input terminal*/
200 LBYTE(AUDIO_TERMINAL_TYPE_STREAMING), /* wTerminalType: usb streaming */
201 HBYTE(AUDIO_TERMINAL_TYPE_STREAMING), /* wTerminalType: usb streaming */
202 AUDIO_SPK_OUTPUT_TERMINAL_ID, /* bAssocTerminal: no association */
203 AUDIO_SPK_CHR, /* bNrChannels: two channel */
204#if (AUDIO_SPK_CHR == 2)
205 0x03, /* wChannelConfig: left front and right front */
206#endif
207#if (AUDIO_SPK_CHR == 1)
208 0x00, /* wChannelConfig */
209#endif
210 0x00, /* wChannelConfig */
211 0x00, /* iChannelNames: unused */
212 0x00, /* iTerminal: unused */
213
214 AUDIO_FEATURE_UNIT_SIZE, /* bLength: descriptor size */
215 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
216 AUDIO_AC_FEATURE_UNIT, /* bDescriptorSubtype: feature unit type*/
217 AUDIO_SPK_FEATURE_UNIT_ID, /* bUnitID: id of this feature unit */
218 AUDIO_SPK_INPUT_TERMINAL_ID, /* bSourceID: from input terminal */
219 0x01, /* bControlSize: 1 byte */
220 0x01, /* bmaControls0: mute*/
221 0x02, /* bmaControls1: volume */
222 0x00, /* iFeature: unused */
223
224 AUDIO_OUTPUT_TERMINAL_SIZE, /* bLength: descriptor size */
225 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
226 AUDIO_AC_OUTPUT_TERMINAL, /* bDescriptorSubtype: output_terminal type*/
227 AUDIO_SPK_OUTPUT_TERMINAL_ID, /* bTerminalID: id of this output terminal*/
228 LBYTE(AUDIO_OUTPUT_TERMINAL_SPEAKER), /* wTerminalType: usb speaker */
229 HBYTE(AUDIO_OUTPUT_TERMINAL_SPEAKER), /* wTerminalType: usb speaker */
230 AUDIO_SPK_INPUT_TERMINAL_ID, /* bAssocTerminal: unused */
231 AUDIO_SPK_FEATURE_UNIT_ID, /* bSourceID: from feature unit terminal */
232 0x00, /* iTerminal: unused */
233#endif
234
235#if (AUDIO_SUPPORT_MIC == 1)
236 /* microphone interface */
237 0x09, /* bLength: descriptor size */
238 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
239 AUDIO_MIC_INTERFACE_NUMBER, /* bInterfaceNumber: index of this interface */
240 0x00, /* bAlternateSetting: index of this setting */
241 0x00, /* bNumEndpoints: 0 endpoints */
242 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio */
243 AUDIO_SUBCLASS_AUDIOSTREAMING, /* bInterfaceSubclass: audio streaming */
244 0x00, /* bInterfaceProtocol: unused */
245 0x00, /* iInterface: unused */
246
247 0x09, /* bLength: descriptor size */
248 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
249 AUDIO_MIC_INTERFACE_NUMBER, /* bInterfaceNumber: index of this interface */
250 0x01, /* bAlternateSetting: index of this setting */
251 0x01, /* bNumEndpoints: 1 endpoints */
252 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio */
253 AUDIO_SUBCLASS_AUDIOSTREAMING, /* bInterfaceSubclass: audio streaming */
254 0x00, /* bInterfaceProtocol: unused */
255 0x00, /* iInterface: unused */
256
257 0x07, /* bLength: configuration descriptor size */
258 AUDIO_CS_INTERFACE, /* bDescriptorType: interface descriptor type */
259 AUDIO_AS_GENERAL, /* bDescriptorSubtype: general sub type*/
260 AUDIO_MIC_OUTPUT_TERMINAL_ID, /* bTerminalLink: unit id of the output terminal */
261 0x01, /* bDelay: interface delay */
262 0x01, /* wFormatTag: pcm format*/
263 0x00, /* wFormatTag: pcm format*/
264
265 0x08 + AUDIO_MIC_FREQ_SIZE * 3, /* bLength: descriptor size */
266 AUDIO_CS_INTERFACE, /* bDescriptorType: interface descriptor type */
267 AUDIO_AS_FORMAT_TYPE, /* bDescriptorSubtype: format subtype */
268 AUDIO_FORMAT_TYPE_I, /* bFormatType: format type 1 */
269 AUDIO_MIC_CHR, /* bNrChannels: channel number */
270 AUDIO_MIC_BITW / 8, /* bSubFrameSize: per audio subframe */
271 AUDIO_MIC_BITW, /* bBitResolution: n bits per sample */
272 AUDIO_MIC_FREQ_SIZE, /* bSamFreqType: n frequency supported */
273#if (AUDIO_SUPPORT_FREQ_16K == 1)
274 SAMPLE_FREQ(AT32_AUDIO_FREQ_16K), /* tSamFreq: 16000hz */
275#endif
276#if (AUDIO_SUPPORT_FREQ_48K == 1)
277 SAMPLE_FREQ(AT32_AUDIO_FREQ_48K), /* tSamFreq: 48000hz */
278#endif
279
280 0x09, /* bLength: size of endpoint descriptor in bytes */
281 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
282 USBD_AUHID_AUDIO_MIC_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
283 USB_EPT_DESC_ISO | USB_ETP_DESC_ASYNC, /* bmAttributes: endpoint attributes */
284 LBYTE(AUDIO_MIC_IN_MAXPACKET_SIZE),
285 HBYTE(AUDIO_MIC_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
286 AUHID_HID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
287 0x00, /* bRefresh: unused */
288 0x00, /* bSynchAddress: unused */
289
290 0x07, /* bLength: size of endpoint descriptor in bytes */
291 AUDIO_CS_ENDPOINT, /* bDescriptorType: cs endpoint descriptor type */
292 0x01, /* bDescriptorSubtype: general subtype */
293 0x01, /* bmAttributes */
294 0x00, /* bLockDelayUnits: unused */
295 0x00, /* wLockDelay: unused */
296 0x00, /* wLockDelay: unused */
297#endif
298
299#if (AUDIO_SUPPORT_SPK == 1)
300 /* speaker interface */
301 0x09, /* bLength: descriptor size */
302 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
303 AUDIO_SPK_INTERFACE_NUMBER, /* bInterfaceNumber: index of this interface */
304 0x00, /* bAlternateSetting: index of this setting */
305 0x00, /* bNumEndpoints: 0 endpoints */
306 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio */
307 AUDIO_SUBCLASS_AUDIOSTREAMING, /* bInterfaceSubclass: audio streaming */
308 0x00, /* bInterfaceProtocol: unused */
309 0x00, /* iInterface: unused */
310
311 0x09, /* bLength: descriptor size */
312 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
313 AUDIO_SPK_INTERFACE_NUMBER, /* bInterfaceNumber: index of this interface */
314 0x01, /* bAlternateSetting: index of this setting */
315 0x01 + AUDIO_SUPPORT_FEEDBACK, /* bNumEndpoints: endpoints */
316 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio */
317 AUDIO_SUBCLASS_AUDIOSTREAMING, /* bInterfaceSubclass: audio streaming */
318 0x00, /* bInterfaceProtocol: unused */
319 0x00, /* iInterface: unused */
320
321 0x07, /* bLength: configuration descriptor size */
322 AUDIO_CS_INTERFACE, /* bDescriptorType: interface descriptor type */
323 AUDIO_AS_GENERAL, /* bDescriptorSubtype: general sub type*/
324 AUDIO_SPK_INPUT_TERMINAL_ID, /* bTerminalLink: unit id of the input terminal */
325 0x01, /* bDelay: interface delay */
326 0x01, /* wFormatTag: pcm format*/
327 0x00, /* wFormatTag: pcm format*/
328
329 0x08 + AUDIO_SPK_FREQ_SIZE * 3, /* bLength: descriptor size */
330 AUDIO_CS_INTERFACE, /* bDescriptorType: interface descriptor type */
331 AUDIO_AS_FORMAT_TYPE, /* bDescriptorSubtype: format subtype */
332 AUDIO_FORMAT_TYPE_I, /* bFormatType: format type 1 */
333 AUDIO_SPK_CHR, /* bNrChannels: channel number */
334 AUDIO_SPK_BITW / 8, /* bSubFrameSize: per audio subframe */
335 AUDIO_SPK_BITW, /* bBitResolution: n bits per sample */
336 AUDIO_SPK_FREQ_SIZE, /* bSamFreqType: n frequency supported */
337#if (AUDIO_SUPPORT_FREQ_16K == 1)
338 SAMPLE_FREQ(AT32_AUDIO_FREQ_16K), /* tSamFreq: 16000hz */
339#endif
340#if (AUDIO_SUPPORT_FREQ_48K == 1)
341 SAMPLE_FREQ(AT32_AUDIO_FREQ_48K), /* tSamFreq: 48000hz */
342#endif
343
344 0x09, /* bLength: size of endpoint descriptor in bytes */
345 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
346 USBD_AUHID_AUDIO_SPK_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
347 USB_EPT_DESC_ISO | USB_ETP_DESC_ASYNC, /* bmAttributes: endpoint attributes */
348 LBYTE(AUDIO_SPK_OUT_MAXPACKET_SIZE),
349 HBYTE(AUDIO_SPK_OUT_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
350 AUHID_HID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
351 0x00, /* bRefresh: unused */
352#if (AUDIO_SUPPORT_FEEDBACK == 1)
353 USBD_AUHID_AUDIO_FEEDBACK_EPT, /* bSynchAddress: feedback endpoint */
354#else
355 0x00, /* bSynchAddress: unused */
356#endif
357
358 0x07, /* bLength: size of endpoint descriptor in bytes */
359 AUDIO_CS_ENDPOINT, /* bDescriptorType: cs endpoint descriptor type */
360 0x01, /* bDescriptorSubtype: general subtype */
361 0x01, /* bmAttributes */
362 0x00, /* bLockDelayUnits: unused */
363 0x00, /* wLockDelay: unused */
364 0x00, /* wLockDelay: unused */
365
366#if (AUDIO_SUPPORT_FEEDBACK == 1)
367 0x09, /* bLength: size of endpoint descriptor in bytes */
368 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
369 USBD_AUHID_AUDIO_FEEDBACK_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
370 0x11, /* bmAttributes: endpoint attributes */
371 LBYTE(AUDIO_FEEDBACK_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
372 HBYTE(AUDIO_FEEDBACK_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
373 1, /* bInterval: interval for polling endpoint for data transfers */
374 FEEDBACK_REFRESH_TIME, /* bRefresh: this field indicates the rate at which an iso syncronization
375 pipe provides new syncronization feedback data. this rate must be a power of
376 2, therefore only the power is reported back and the range of this field is from
377 1(2ms) to 9(512ms) */
378 0x00, /* bSynchAddress: 0x00*/
379#endif
380
381#endif
382
383 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
384 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
385 HID_INTERFACE_NUMBER, /* bInterfaceNumber: number of interface */
386 0x00, /* bAlternateSetting: alternate set */
387 0x02, /* bNumEndpoints: number of endpoints */
388 USB_CLASS_CODE_HID, /* bInterfaceClass: class code hid */
389 0x00, /* bInterfaceSubClass: subclass code */
390 0x00, /* bInterfaceProtocol: protocol code */
391 0x00, /* iInterface: index of string descriptor */
392
393 0x09, /* bLength: size of HID descriptor in bytes */
394 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
395 LBYTE(AUHID_HID_BCD_NUM),
396 HBYTE(AUHID_HID_BCD_NUM), /* bcdHID: HID class specification release number */
397 0x00, /* bCountryCode: hardware target conutry */
398 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
399 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
400 LBYTE(sizeof(g_usbd_audio_hid_report)),
401 HBYTE(sizeof(g_usbd_audio_hid_report)), /* wDescriptorLength: total length of reprot descriptor */
402
403 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
404 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
405 USBD_AUHID_HID_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
406 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
407 LBYTE(USBD_AUHID_IN_MAXPACKET_SIZE),
408 HBYTE(USBD_AUHID_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
409 AUHID_HID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
410
411 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
412 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
413 USBD_AUHID_HID_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
414 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
415 LBYTE(USBD_AUHID_OUT_MAXPACKET_SIZE),
416 HBYTE(USBD_AUHID_OUT_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
417 AUHID_HID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
418};
419
420
424#if defined ( __ICCARM__ ) /* iar compiler */
425 #pragma data_alignment=4
426#endif
427ALIGNED_HEAD uint8_t g_usbd_audio_hid_report[USBD_AUHID_HID_SIZ_REPORT_DESC] ALIGNED_TAIL =
428{
429 0x06, 0xFF, 0x00, /* USAGE_PAGE(Vendor Page:0xFF00) */
430 0x09, 0x01, /* USAGE (Demo Kit) */
431 0xa1, 0x01, /* COLLECTION (Application) */
432 /* 7 */
433
434 /* Led 2 */
435 0x85, HID_REPORT_ID_2, /* REPORT_ID 2 */
436 0x09, 0x02, /* USAGE (LED 2) */
437 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
438 0x25, 0x01, /* LOGICAL_MAXIMUM (1) */
439 0x75, 0x08, /* REPORT_SIZE (8) */
440 0x95, 0x3F, /* REPORT_COUNT (1) */
441 0xB1, 0x82, /* FEATURE (Data,Var,Abs,Vol) */
442
443 0x85, 0x02, /* REPORT_ID (2) */
444 0x09, 0x02, /* USAGE (LED 2) */
445 0x91, 0x82, /* OUTPUT (Data,Var,Abs,Vol) */
446 /* 27 */
447
448 /* Led 3 */
449 0x85, HID_REPORT_ID_3, /* REPORT_ID (3) */
450 0x09, 0x03, /* USAGE (LED 3) */
451 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
452 0x25, 0x01, /* LOGICAL_MAXIMUM (1) */
453 0x75, 0x08, /* REPORT_SIZE (8) */
454 0x95, 0x3F, /* REPORT_COUNT (1) */
455 0xB1, 0x82, /* FEATURE (Data,Var,Abs,Vol) */
456
457 0x85, 0x03, /* REPORT_ID (3) */
458 0x09, 0x03, /* USAGE (LED 3) */
459 0x91, 0x82, /* OUTPUT (Data,Var,Abs,Vol) */
460 /* 47 */
461
462 /* Led 4 */
463 0x85, HID_REPORT_ID_4, /* REPORT_ID 4) */
464 0x09, 0x04, /* USAGE (LED 4) */
465 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
466 0x25, 0x01, /* LOGICAL_MAXIMUM (1) */
467 0x75, 0x08, /* REPORT_SIZE (8) */
468 0x95, 0x3F, /* REPORT_COUNT (1) */
469 0xB1, 0x82, /* FEATURE (Data,Var,Abs,Vol) */
470
471 0x85, 0x04, /* REPORT_ID (4) */
472 0x09, 0x04, /* USAGE (LED 4) */
473 0x91, 0x82, /* OUTPUT (Data,Var,Abs,Vol) */
474 /* 67 */
475
476 /* key Push Button */
477 0x85, HID_REPORT_ID_5, /* REPORT_ID (5) */
478 0x09, 0x05, /* USAGE (Push Button) */
479 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
480 0x25, 0x01, /* LOGICAL_MAXIMUM (1) */
481 0x75, 0x01, /* REPORT_SIZE (1) */
482 0x81, 0x82, /* INPUT (Data,Var,Abs,Vol) */
483
484 0x09, 0x05, /* USAGE (Push Button) */
485 0x75, 0x01, /* REPORT_SIZE (1) */
486 0xb1, 0x82, /* FEATURE (Data,Var,Abs,Vol) */
487
488 0x75, 0x07, /* REPORT_SIZE (7) */
489 0x81, 0x83, /* INPUT (Cnst,Var,Abs,Vol) */
490 0x85, 0x05, /* REPORT_ID (5) */
491
492 0x75, 0x07, /* REPORT_SIZE (7) */
493 0xb1, 0x83, /* FEATURE (Cnst,Var,Abs,Vol) */
494 /* 95 */
495
496 /* Data OUT */
497 0x85, HID_REPORT_ID_6, /* REPORT_ID (0xF0) */
498 0x09, 0x06, /* USAGE */
499 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
500 0x26, 0x00,0xff, /* LOGICAL_MAXIMUM (255) */
501 0x75, 0x08, /* REPORT_SIZE (8) */
502 0x95, 0x3F, /* REPORT_COUNT (64) */
503 0x91, 0x02, /* OUTPUT(Data,Var,Abs,Vol) */
504 /* 110 */
505
506 /* Data IN */
507 0x85, HID_REPORT_ID_6, /* REPORT_ID (0xF0) */
508 0x09, 0x07, /* USAGE */
509 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
510 0x26, 0x00,0xff, /* LOGICAL_MAXIMUM (255) */
511 0x75, 0x08, /* REPORT_SIZE (8) */
512 0x95, 0x3F, /* REPORT_COUNT (64) */
513 0x81, 0x82, /* INPUT(Data,Var,Abs,Vol) */
514
515 /* 125 */
516 0xc0 /* END_COLLECTION */
517};
518
522#if defined ( __ICCARM__ ) /* iar compiler */
523 #pragma data_alignment=4
524#endif
525ALIGNED_HEAD uint8_t g_audio_hid_usb_desc[9] ALIGNED_TAIL =
526{
527 0x09, /* bLength: size of HID descriptor in bytes */
528 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
529 LBYTE(AUHID_HID_BCD_NUM),
530 HBYTE(AUHID_HID_BCD_NUM), /* bcdHID: HID class specification release number */
531 0x00, /* bCountryCode: hardware target conutry */
532 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
533 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
534 LBYTE(sizeof(g_usbd_audio_hid_report)),
535 HBYTE(sizeof(g_usbd_audio_hid_report)), /* wDescriptorLength: total length of reprot descriptor */
536};
537
538
542#if defined ( __ICCARM__ ) /* iar compiler */
543 #pragma data_alignment=4
544#endif
545ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_AUHID_SIZ_STRING_LANGID] ALIGNED_TAIL =
546{
547 USBD_AUHID_SIZ_STRING_LANGID,
548 USB_DESCIPTOR_TYPE_STRING,
549 0x09,
550 0x04,
551};
552
556#if defined ( __ICCARM__ ) /* iar compiler */
557 #pragma data_alignment=4
558#endif
559ALIGNED_HEAD static uint8_t g_string_serial[USBD_AUHID_SIZ_STRING_SERIAL] ALIGNED_TAIL =
560{
561 USBD_AUHID_SIZ_STRING_SERIAL,
562 USB_DESCIPTOR_TYPE_STRING,
563};
564
565
566/* device descriptor */
567static usbd_desc_t device_descriptor =
568{
569 USB_DEVICE_DESC_LEN,
570 g_usbd_descriptor
571};
572
573/* config descriptor */
574static usbd_desc_t config_descriptor =
575{
576 USBD_AUHID_CONFIG_DESC_SIZE,
577 g_usbd_configuration
578};
579
580/* langid descriptor */
581static usbd_desc_t langid_descriptor =
582{
583 USBD_AUHID_SIZ_STRING_LANGID,
584 g_string_lang_id
585};
586
587/* serial descriptor */
588static usbd_desc_t serial_descriptor =
589{
590 USBD_AUHID_SIZ_STRING_SERIAL,
591 g_string_serial
592};
593
594static usbd_desc_t vp_desc;
595
602static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
603{
604 uint16_t str_len = 0, id_pos = 2;
605 uint8_t *tmp_str = string;
606
607 while(*tmp_str != '\0')
608 {
609 str_len ++;
610 unicode_buf[id_pos ++] = *tmp_str ++;
611 unicode_buf[id_pos ++] = 0x00;
612 }
613
614 str_len = str_len * 2 + 2;
615 unicode_buf[0] = str_len;
616 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
617
618 return str_len;
619}
620
628static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
629{
630 uint8_t idx = 0;
631
632 for( idx = 0 ; idx < len ; idx ++)
633 {
634 if( ((value >> 28)) < 0xA )
635 {
636 pbuf[2 * idx] = (value >> 28) + '0';
637 }
638 else
639 {
640 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
641 }
642
643 value = value << 4;
644
645 pbuf[2 * idx + 1] = 0;
646 }
647}
648
654static void get_serial_num(void)
655{
656 uint32_t serial0, serial1, serial2;
657
658 serial0 = *(uint32_t*)MCU_ID1;
659 serial1 = *(uint32_t*)MCU_ID2;
660 serial2 = *(uint32_t*)MCU_ID3;
661
662 serial0 += serial2;
663
664 if (serial0 != 0)
665 {
666 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
667 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
668 }
669}
670
676static usbd_desc_t *get_device_descriptor(void)
677{
678 return &device_descriptor;
679}
680
686static usbd_desc_t * get_device_qualifier(void)
687{
688 return NULL;
689}
690
696static usbd_desc_t *get_device_configuration(void)
697{
698 return &config_descriptor;
699}
700
706static usbd_desc_t *get_device_other_speed(void)
707{
708 return NULL;
709}
710
716static usbd_desc_t *get_device_lang_id(void)
717{
718 return &langid_descriptor;
719}
720
721
727static usbd_desc_t *get_device_manufacturer_string(void)
728{
729 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_AUHID_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
730 vp_desc.descriptor = g_usbd_desc_buffer;
731 return &vp_desc;
732}
733
739static usbd_desc_t *get_device_product_string(void)
740{
741 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_AUHID_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
742 vp_desc.descriptor = g_usbd_desc_buffer;
743 return &vp_desc;
744}
745
751static usbd_desc_t *get_device_serial_string(void)
752{
753 get_serial_num();
754 return &serial_descriptor;
755}
756
762static usbd_desc_t *get_device_interface_string(void)
763{
764 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_AUHID_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
765 vp_desc.descriptor = g_usbd_desc_buffer;
766 return &vp_desc;
767}
768
774static usbd_desc_t *get_device_config_string(void)
775{
776 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_AUHID_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
777 vp_desc.descriptor = g_usbd_desc_buffer;
778 return &vp_desc;
779}
780
audio_hid_desc.h
idx
uint32_t idx
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:46
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
AUDIO_MIC_IN_MAXPACKET_SIZE
#define AUDIO_MIC_IN_MAXPACKET_SIZE
Definition: audio_class.h:62
AUDIO_SPK_OUT_MAXPACKET_SIZE
#define AUDIO_SPK_OUT_MAXPACKET_SIZE
Definition: audio_class.h:63
FEEDBACK_REFRESH_TIME
#define FEEDBACK_REFRESH_TIME
Definition: audio_class.h:65
AUDIO_FEEDBACK_MAXPACKET_SIZE
#define AUDIO_FEEDBACK_MAXPACKET_SIZE
Definition: audio_class.h:64
AUDIO_MIC_FEATURE_UNIT_ID
#define AUDIO_MIC_FEATURE_UNIT_ID
Definition: audio_desc.h:169
AUDIO_CS_ENDPOINT
#define AUDIO_CS_ENDPOINT
Definition: audio_desc.h:76
AUDIO_AC_HEADER
#define AUDIO_AC_HEADER
Definition: audio_desc.h:91
AUDIO_SUBCLASS_AUDIOCONTROL
#define AUDIO_SUBCLASS_AUDIOCONTROL
Definition: audio_desc.h:68
AUDIO_INPUT_TERMINAL_SIZE
#define AUDIO_INPUT_TERMINAL_SIZE
audio interface descriptor size define
Definition: audio_desc.h:161
AUDIO_TERMINAL_TYPE_STREAMING
#define AUDIO_TERMINAL_TYPE_STREAMING
Definition: audio_desc.h:138
AUDIO_SPK_CHR
#define AUDIO_SPK_CHR
Definition: audio_desc.h:202
AUDIO_SPK_INTERFACE_NUMBER
#define AUDIO_SPK_INTERFACE_NUMBER
Definition: audio_desc.h:180
AUDIO_MIC_OUTPUT_TERMINAL_ID
#define AUDIO_MIC_OUTPUT_TERMINAL_ID
Definition: audio_desc.h:170
AUDIO_MIC_INTERFACE_NUMBER
#define AUDIO_MIC_INTERFACE_NUMBER
audio interface number
Definition: audio_desc.h:178
SAMPLE_FREQ
#define SAMPLE_FREQ(frq)
Definition: audio_desc.h:213
AUDIO_MIC_FREQ_SIZE
#define AUDIO_MIC_FREQ_SIZE
audio microphone freq and channel config
Definition: audio_desc.h:194
AUDIO_SPK_FREQ_SIZE
#define AUDIO_SPK_FREQ_SIZE
audio speaker freq and channel config
Definition: audio_desc.h:201
AT32_AUDIO_FREQ_48K
#define AT32_AUDIO_FREQ_48K
Definition: audio_desc.h:189
AUDIO_FORMAT_TYPE_I
#define AUDIO_FORMAT_TYPE_I
audio format type 1
Definition: audio_desc.h:148
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:215
AUDIO_AS_GENERAL
#define AUDIO_AS_GENERAL
Definition: audio_desc.h:104
AUDIO_INTERFACE_NUM
#define AUDIO_INTERFACE_NUM
audio interface config
Definition: audio_desc.h:153
AUDIO_CS_INTERFACE
#define AUDIO_CS_INTERFACE
audio class-specific descriptor types
Definition: audio_desc.h:75
AUDIO_SPK_FEATURE_UNIT_ID
#define AUDIO_SPK_FEATURE_UNIT_ID
Definition: audio_desc.h:172
AUDIO_OUTPUT_TERMINAL_SIZE
#define AUDIO_OUTPUT_TERMINAL_SIZE
Definition: audio_desc.h:162
AUDIO_SPK_OUTPUT_TERMINAL_ID
#define AUDIO_SPK_OUTPUT_TERMINAL_ID
Definition: audio_desc.h:173
AUDIO_AC_INPUT_TERMINAL
#define AUDIO_AC_INPUT_TERMINAL
Definition: audio_desc.h:92
AUDIO_MIC_CHR
#define AUDIO_MIC_CHR
Definition: audio_desc.h:195
AUDIO_OUTPUT_TERMINAL_SPEAKER
#define AUDIO_OUTPUT_TERMINAL_SPEAKER
Definition: audio_desc.h:143
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:216
AT32_AUDIO_FREQ_16K
#define AT32_AUDIO_FREQ_16K
audio support freq
Definition: audio_desc.h:188
AUDIO_AS_FORMAT_TYPE
#define AUDIO_AS_FORMAT_TYPE
Definition: audio_desc.h:105
AUDIO_MIC_INPUT_TERMINAL_ID
#define AUDIO_MIC_INPUT_TERMINAL_ID
audio terminal id define
Definition: audio_desc.h:168
AUDIO_SPK_BITW
#define AUDIO_SPK_BITW
Definition: audio_desc.h:203
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:217
AUDIO_FEATURE_UNIT_SIZE
#define AUDIO_FEATURE_UNIT_SIZE
Definition: audio_desc.h:163
AUDIO_PROTOCOL_UNDEFINED
#define AUDIO_PROTOCOL_UNDEFINED
audio interface protocol codes
Definition: audio_desc.h:85
AUDIO_MIC_BITW
#define AUDIO_MIC_BITW
Definition: audio_desc.h:196
AUDIO_AC_FEATURE_UNIT
#define AUDIO_AC_FEATURE_UNIT
Definition: audio_desc.h:96
AUDIO_SPK_INPUT_TERMINAL_ID
#define AUDIO_SPK_INPUT_TERMINAL_ID
Definition: audio_desc.h:171
AUDIO_INTERFACE_LEN
#define AUDIO_INTERFACE_LEN
Definition: audio_desc.h:154
AUDIO_SUBCLASS_AUDIOSTREAMING
#define AUDIO_SUBCLASS_AUDIOSTREAMING
Definition: audio_desc.h:69
AUDIO_AC_OUTPUT_TERMINAL
#define AUDIO_AC_OUTPUT_TERMINAL
Definition: audio_desc.h:93
AUDIO_INPUT_TERMINAL_MICROPHONE
#define AUDIO_INPUT_TERMINAL_MICROPHONE
Definition: audio_desc.h:141
USBD_AUHID_AUDIO_MIC_IN_EPT
#define USBD_AUHID_AUDIO_MIC_IN_EPT
endpoint define
Definition: audio_hid_class.h:54
USBD_AUHID_HID_IN_EPT
#define USBD_AUHID_HID_IN_EPT
usb custom hid use endpoint define
Definition: audio_hid_class.h:61
USBD_AUHID_HID_OUT_EPT
#define USBD_AUHID_HID_OUT_EPT
Definition: audio_hid_class.h:62
USBD_AUHID_AUDIO_FEEDBACK_EPT
#define USBD_AUHID_AUDIO_FEEDBACK_EPT
Definition: audio_hid_class.h:56
USBD_AUHID_OUT_MAXPACKET_SIZE
#define USBD_AUHID_OUT_MAXPACKET_SIZE
Definition: audio_hid_class.h:68
USBD_AUHID_AUDIO_SPK_OUT_EPT
#define USBD_AUHID_AUDIO_SPK_OUT_EPT
Definition: audio_hid_class.h:55
USBD_AUHID_IN_MAXPACKET_SIZE
#define USBD_AUHID_IN_MAXPACKET_SIZE
usb custom hid in and out max packet size define
Definition: audio_hid_class.h:67
USBD_AUHID_DESC_CONFIGURATION_STRING
#define USBD_AUHID_DESC_CONFIGURATION_STRING
Definition: audio_hid_desc.h:61
USBD_AUHID_DESC_MANUFACTURER_STRING
#define USBD_AUHID_DESC_MANUFACTURER_STRING
Definition: audio_hid_desc.h:59
USBD_AUHID_HID_SIZ_REPORT_DESC
#define USBD_AUHID_HID_SIZ_REPORT_DESC
Definition: audio_hid_desc.h:236
AUHID_BCD_NUM
#define AUHID_BCD_NUM
Definition: audio_hid_desc.h:51
HID_REPORT_ID_2
#define HID_REPORT_ID_2
Definition: audio_hid_desc.h:223
HID_REPORT_ID_4
#define HID_REPORT_ID_4
Definition: audio_hid_desc.h:225
AUHID_HID_BINTERVAL_TIME
#define AUHID_HID_BINTERVAL_TIME
Definition: audio_hid_desc.h:205
HID_REPORT_ID_6
#define HID_REPORT_ID_6
Definition: audio_hid_desc.h:227
USBD_AUHID_SIZ_STRING_LANGID
#define USBD_AUHID_SIZ_STRING_LANGID
Definition: audio_hid_desc.h:56
AUHID_HID_BCD_NUM
#define AUHID_HID_BCD_NUM
usb bcd number define
Definition: audio_hid_desc.h:210
USBD_AUHID_PRODUCT_ID
#define USBD_AUHID_PRODUCT_ID
Definition: audio_hid_desc.h:54
USBD_AUHID_CONFIG_DESC_SIZE
#define USBD_AUHID_CONFIG_DESC_SIZE
Definition: audio_hid_desc.h:238
USBD_AUHID_DESC_INTERFACE_STRING
#define USBD_AUHID_DESC_INTERFACE_STRING
Definition: audio_hid_desc.h:62
USBD_AUHID_DESC_PRODUCT_STRING
#define USBD_AUHID_DESC_PRODUCT_STRING
Definition: audio_hid_desc.h:60
USBD_AUHID_SIZ_STRING_SERIAL
#define USBD_AUHID_SIZ_STRING_SERIAL
Definition: audio_hid_desc.h:57
HID_REPORT_ID_3
#define HID_REPORT_ID_3
Definition: audio_hid_desc.h:224
g_audio_hid_usb_desc
uint8_t g_audio_hid_usb_desc[9]
usb hid descriptor
Definition: audio_hid_desc.c:525
g_usbd_audio_hid_report
uint8_t g_usbd_audio_hid_report[126]
usb hid report descriptor
Definition: audio_hid_desc.c:427
USBD_AUHID_VENDOR_ID
#define USBD_AUHID_VENDOR_ID
Definition: audio_hid_desc.h:53
HID_REPORT_ID_5
#define HID_REPORT_ID_5
Definition: audio_hid_desc.h:226
HID_INTERFACE_NUMBER
#define HID_INTERFACE_NUMBER
Definition: audio_hid_desc.h:183
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: audio_hid_desc.c:588
device_descriptor
static usbd_desc_t device_descriptor
Definition: audio_hid_desc.c:567
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: audio_hid_desc.c:696
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: audio_hid_desc.c:581
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: audio_hid_desc.c:676
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: audio_hid_desc.c:727
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: audio_hid_desc.c:686
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: audio_hid_desc.c:762
g_usbd_desc_buffer
static uint8_t g_usbd_desc_buffer[256]
Definition: audio_hid_desc.c:57
vp_desc
static usbd_desc_t vp_desc
Definition: audio_hid_desc.c:594
audio_hid_desc_handler
usbd_desc_handler audio_hid_desc_handler
device descriptor handler structure
Definition: audio_hid_desc.c:62
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: audio_hid_desc.c:706
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL
usb device standard descriptor
Definition: audio_hid_desc.c:82
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: audio_hid_desc.c:739
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: audio_hid_desc.c:774
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: audio_hid_desc.c:602
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: audio_hid_desc.c:716
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: audio_hid_desc.c:654
config_descriptor
static usbd_desc_t config_descriptor
Definition: audio_hid_desc.c:574
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: audio_hid_desc.c:751
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: audio_hid_desc.c:628
AUDIO_SUPPORT_FEEDBACK
#define AUDIO_SUPPORT_FEEDBACK
Definition: audio/audio_conf.h:49
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:153
USB_EPT_DESC_ISO
#define USB_EPT_DESC_ISO
Definition: usb_std.h:176
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:93
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: usb_std.h:223
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: usb_std.h:224
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:96
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:152
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:151
USB_EPT_DESC_INTERRUPT
#define USB_EPT_DESC_INTERRUPT
Definition: usb_std.h:178
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:94
USB_CLASS_CODE_AUDIO
#define USB_CLASS_CODE_AUDIO
usb class code
Definition: usb_std.h:161
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:95
USB_ETP_DESC_ASYNC
#define USB_ETP_DESC_ASYNC
Definition: usb_std.h:181
USB_CLASS_CODE_HID
#define USB_CLASS_CODE_HID
Definition: usb_std.h:163
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h


AT32F435/437 Firmwary Library: audio_hid_desc.h Source File

  • middlewares
  • usbd_class
  • audio_hid
audio_hid_desc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AUDIO_HID_DESC_H
29#define __AUDIO_HID_DESC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "audio_hid_class.h"
36#include "usbd_core.h"
37#include "audio_conf.h"
38
51#define AUHID_BCD_NUM 0x0100
52
53#define USBD_AUHID_VENDOR_ID 0x2E3C
54#define USBD_AUHID_PRODUCT_ID 0x5555
55
56#define USBD_AUHID_SIZ_STRING_LANGID 4
57#define USBD_AUHID_SIZ_STRING_SERIAL 0x1A
58
59#define USBD_AUHID_DESC_MANUFACTURER_STRING "Artery"
60#define USBD_AUHID_DESC_PRODUCT_STRING "AT32 Audio"
61#define USBD_AUHID_DESC_CONFIGURATION_STRING "Audio Config"
62#define USBD_AUHID_DESC_INTERFACE_STRING "Audio Interface"
66#define AUDIO_SUBCLASS_UNDEFINED 0x00
67#define AUDIO_SUBCLASS_AUDIOCONTROL 0x01
68#define AUDIO_SUBCLASS_AUDIOSTREAMING 0x02
69#define AUDIO_SUBCLASS_MIDISTREMING 0x03
70
74#define AUDIO_CS_INTERFACE 0x24
75#define AUDIO_CS_ENDPOINT 0x25
76#define AUDIO_CS_STRING 0x23
77#define AUDIO_CS_CONFIGURATION 0x22
78#define AUDIO_CS_DEVICE 0x21
79#define AUDIO_CS_UNDEFINED 0x20
80
84#define AUDIO_PROTOCOL_UNDEFINED 0x00
85
89#define AUDIO_AC_DESCRIPTOR_UNDEFINED 0x00
90#define AUDIO_AC_HEADER 0x01
91#define AUDIO_AC_INPUT_TERMINAL 0x02
92#define AUDIO_AC_OUTPUT_TERMINAL 0x03
93#define AUDIO_AC_MIXER_UNIT 0x04
94#define AUDIO_AC_SELECTOR_UNIT 0x05
95#define AUDIO_AC_FEATURE_UNIT 0x06
96#define AUDIO_AC_PROCESSING_UNIT 0x07
97#define AUDIO_AC_EXTENSION_UNIT 0x08
98
102#define AUDIO_AS_DESCRIPTOR_UNDEFINED 0x00
103#define AUDIO_AS_GENERAL 0x01
104#define AUDIO_AS_FORMAT_TYPE 0x02
105#define AUDIO_AS_FORMAT_SPECIFIC 0x03
106
110#define AUDIO_REQUEST_CODE_UNDEFINED 0x00
111#define AUDIO_REQ_SET_CUR 0x01
112#define AUDIO_REQ_GET_CUR 0x81
113#define AUDIO_REQ_SET_MIN 0x02
114#define AUDIO_REQ_GET_MIN 0x82
115#define AUDIO_REQ_SET_MAX 0x03
116#define AUDIO_REQ_GET_MAX 0x83
117#define AUDIO_REQ_SET_RES 0x04
118#define AUDIO_REQ_GET_RES 0x84
119#define AUDIO_REQ_SET_MEM 0x05
120#define AUDIO_REQ_GET_MEM 0x85
121#define AUDIO_REQ_GET_STAT 0xFF
122
126#define AUDIO_FU_CONTROL_UNDEFINED 0x00
127#define AUDIO_FU_MUTE_CONTROL 0x01
128#define AUDIO_FU_VOLUME_CONTROL 0x02
129#define AUDIO_FU_BASS_CONTROL 0x03
130#define AUDIO_FU_MID_CONTROL 0x04
131#define AUDIO_FU_TREBLE_CONTROL 0x05
132
136#define AUDIO_TERMINAL_TYPE_UNDEFINED 0x0100
137#define AUDIO_TERMINAL_TYPE_STREAMING 0x0101
138#define AUDIO_TERMINAL_TYPE_VENDOR 0x01FF
139#define AUDIO_INPUT_TERMINAL_UNDEFINED 0x0200
140#define AUDIO_INPUT_TERMINAL_MICROPHONE 0x0201
141#define AUDIO_OUTPUT_TERMINAL_UNDEFINED 0x0300
142#define AUDIO_OUTPUT_TERMINAL_SPEAKER 0x0301
143
147#define AUDIO_FORMAT_TYPE_I 0x01
148
152#define AUDIO_INTERFACE_NUM (AUDIO_SUPPORT_SPK + AUDIO_SUPPORT_MIC)
153#define AUDIO_INTERFACE_LEN ((0x08 + AUDIO_INTERFACE_NUM) + AUDIO_INTERFACE_NUM * 0x1E)
154#define AUDIO_MIC_INTERFACE 0x01
155#define AUDIO_SPK_INTERFACE 0x02
156
160#define AUDIO_INPUT_TERMINAL_SIZE 0x0C
161#define AUDIO_OUTPUT_TERMINAL_SIZE 0x09
162#define AUDIO_FEATURE_UNIT_SIZE 0x09
163
167#define AUDIO_MIC_INPUT_TERMINAL_ID 0x01
168#define AUDIO_MIC_FEATURE_UNIT_ID 0x02
169#define AUDIO_MIC_OUTPUT_TERMINAL_ID 0x03
170#define AUDIO_SPK_INPUT_TERMINAL_ID 0x04
171#define AUDIO_SPK_FEATURE_UNIT_ID 0x05
172#define AUDIO_SPK_OUTPUT_TERMINAL_ID 0x06
173
177#define AUDIO_MIC_INTERFACE_NUMBER 0x01
178#if (AUDIO_SUPPORT_MIC == 1)
179#define AUDIO_SPK_INTERFACE_NUMBER 0x02
180#else
181#define AUDIO_SPK_INTERFACE_NUMBER 0x01
182#endif
183#define HID_INTERFACE_NUMBER 0x03
184
188#define AT32_AUDIO_FREQ_16K 16000
189#define AT32_AUDIO_FREQ_48K 48000
190
194#define AUDIO_MIC_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
195#define AUDIO_MIC_CHR AUDIO_MIC_CHANEL_NUM
196#define AUDIO_MIC_BITW (AUDIO_MIC_DEFAULT_BITW)
197
201#define AUDIO_SPK_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
202#define AUDIO_SPK_CHR AUDIO_SPK_CHANEL_NUM
203#define AUDIO_SPK_BITW (AUDIO_SPK_DEFAULT_BITW)
204
205#define AUHID_HID_BINTERVAL_TIME 0x01
206
210#define AUHID_HID_BCD_NUM 0x0110
211
215#define HID_CLASS_DESC_HID 0x21
216#define HID_CLASS_DESC_REPORT 0x22
217#define HID_CLASS_DESC_PHYSICAL 0x23
218
222#define HID_REPORT_ID_1 0x01
223#define HID_REPORT_ID_2 0x02
224#define HID_REPORT_ID_3 0x03
225#define HID_REPORT_ID_4 0x04
226#define HID_REPORT_ID_5 0x05
227#define HID_REPORT_ID_6 0xF0
228
229#define MCU_ID1 (0x1FFFF7E8)
230#define MCU_ID2 (0x1FFFF7EC)
231#define MCU_ID3 (0x1FFFF7F0)
232
233
234#define SAMPLE_FREQ(frq) (uint8_t)(frq), (uint8_t)((frq >> 8)), (uint8_t)((frq >> 16))
235
236#define USBD_AUHID_HID_SIZ_REPORT_DESC 126
237#define USBD_AUHID_HID_DESC_SIZE 32
238#define USBD_AUHID_CONFIG_DESC_SIZE ( 0x12 + AUDIO_INTERFACE_LEN + \
239 + (0x31 + AUDIO_SPK_FREQ_SIZE * 3) \
240 + (0x31 + AUDIO_MIC_FREQ_SIZE * 3) \
241 + (9 * AUDIO_SUPPORT_FEEDBACK) \
242 + USBD_AUHID_HID_DESC_SIZE)
243
244extern uint8_t g_usbd_audio_hid_report[USBD_AUHID_HID_SIZ_REPORT_DESC];
245extern uint8_t g_audio_hid_usb_desc[9];
246
247extern usbd_desc_handler audio_hid_desc_handler;
248
260#ifdef __cplusplus
261}
262#endif
263
264#endif
265
audio_conf.h
usb audio config
audio_hid_class.h
USBD_AUHID_HID_SIZ_REPORT_DESC
#define USBD_AUHID_HID_SIZ_REPORT_DESC
Definition: audio_hid_desc.h:236
audio_hid_desc_handler
usbd_desc_handler audio_hid_desc_handler
device descriptor handler structure
Definition: audio_hid_desc.c:62
g_audio_hid_usb_desc
uint8_t g_audio_hid_usb_desc[9]
usb hid descriptor
Definition: audio_hid_desc.c:525
g_usbd_audio_hid_report
uint8_t g_usbd_audio_hid_report[126]
usb hid report descriptor
Definition: audio_hid_desc.c:427
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: hid_iap_user.h File Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • bootloader
  • inc
Macros | Functions
bootloader/inc/hid_iap_user.h File Reference

usb config header file More...

#include "hid_iap_class.h"

Go to the source code of this file.

Macros

#define FLASH_APP_ADDRESS 0x08005000

Functions

void | iap_init (void)
iap init. More...
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | iap_loop (void)
iap loop More...
void | jump_to_app (uint32_t address)
jump to app More...

Detailed Description

usb config header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file bootloader/inc/hid_iap_user.h.


AT32F435/437 Firmwary Library: hid_iap_user.h Source File

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • bootloader
  • inc
bootloader/inc/hid_iap_user.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __HID_IAP_USER_H
29#define __HID_IAP_USER_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "hid_iap_class.h"
36
45#define FLASH_APP_ADDRESS 0x08005000
46
47void iap_init(void);
48 iap_result_type iap_get_upgrade_flag(void);
49void iap_loop(void);
50void jump_to_app(uint32_t address);
51
52
60#ifdef __cplusplus
61}
62#endif
63
64#endif
iap_init
void iap_init(void)
iap init.
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c:61
jump_to_app
void jump_to_app(uint32_t address)
jump to app
Definition: project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c:350
iap_get_upgrade_flag
iap_result_type iap_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: app_led3_toggle/src/hid_iap_user.c:77
iap_loop
void iap_loop(void)
iap loop
Definition: bootloader/src/hid_iap_user.c:491
iap_result_type
iap_result_type
Definition: hid_iap_class.h:86
hid_iap_class.h
usb hid iap header file


AT32F435/437 Firmwary Library: usart.h File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • bootloader
  • inc
Data Structures | Macros | Functions | Variables
bootloader/inc/usart.h File Reference

usart header file More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Data Structures

struct usart_group_type
usart group type More...

Macros

#define USART_REC_LEN 1024

Functions

void uart_init (uint32_t baudrate)
initialize print usart More...

Variables

usart_group_type usart_group_struct

Detailed Description

usart header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file bootloader/inc/usart.h.


AT32F435/437 Firmwary Library: usart.h Source File

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • bootloader
  • inc
bootloader/inc/usart.h
Go to the documentation of this file.
1
27#ifndef __USART_H
28#define __USART_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "at32f435_437_board.h"
35
48#define USART_REC_LEN 1024
49
61typedef struct
62{
63 uint16_t buf[USART_REC_LEN];
64 uint16_t head;
65 uint16_t tail;
66 uint16_t count;
67} usart_group_type;
68
73extern usart_group_type usart_group_struct;
74
79void uart_init(uint32_t baudrate);
80
93#ifdef __cplusplus
94}
95#endif
96
97#endif
at32f435_437_board.h
USART_REC_LEN
#define USART_REC_LEN
Definition: bootloader/inc/usart.h:48
uart_init
void uart_init(uint32_t baudrate)
initialize print usart
Definition: project/at_start_f435/examples/edma/link_list_mode/src/main.c:137
usart_group_struct
usart_group_type usart_group_struct
Definition: bootloader/src/usart.c:38
usart_group_type
usart group type
Definition: bootloader/inc/usart.h:62
usart_group_type::tail
uint16_t tail
Definition: bootloader/inc/usart.h:65
usart_group_type::count
uint16_t count
Definition: bootloader/inc/usart.h:66
usart_group_type::head
uint16_t head
Definition: bootloader/inc/usart.h:64


AT32F435/437 Firmwary Library: hid_iap_user.c File Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • bootloader
  • src
Functions | Variables
bootloader/src/hid_iap_user.c File Reference

usb hid iap user file More...

#include "hid_iap_user.h"
#include "hid_iap_class.h"
#include "string.h"

Go to the source code of this file.

Functions

void | iap_clear_upgrade_flag (void)
clear iap upgrade flag More...
void | iap_set_upgrade_flag (void)
set iap upgrade complete flag More...
uint32_t | crc_cal (uint32_t addr, uint16_t nk)
crc cal More...
void | iap_idle (void)
iap idle function More...
void | iap_start (void)
iap start function More...
iap_result_type | iap_address (uint8_t *pdata, uint32_t len)
iap parse address More...
void | iap_finish (void)
iap_result_type | iap_data_write (uint8_t *pdata, uint32_t len)
void | iap_jump (void)
void | iap_respond (uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
void | jump_to_app (uint32_t address)
jump to app More...
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | iap_erase_sector (uint32_t address)
set iap upgrade complete flag More...
void | iap_init (void)
iap init More...
void | iap_crc (uint8_t *pdata, uint32_t len)
void | iap_get ()
iap_result_type | usbd_hid_iap_process (void *udev, uint8_t *pdata, uint16_t len)
usb device iap function More...
void | usbd_hid_iap_in_complete (void *udev)
usb device in transfer complete function More...
void | iap_loop (void)
iap loop More...

Variables

void(* pftarget )(void)

Detailed Description

usb hid iap user file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file bootloader/src/hid_iap_user.c.


AT32F435/437 Firmwary Library: hid_iap_user.c Source File

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • bootloader
  • src
bootloader/src/hid_iap_user.c
Go to the documentation of this file.
1
27#include "hid_iap_user.h"
28#include "hid_iap_class.h"
29#include "string.h"
30
39void (*pftarget)(void);
40void iap_clear_upgrade_flag(void);
41void iap_set_upgrade_flag(void);
42uint32_t crc_cal(uint32_t addr, uint16_t nk);
43
44void iap_idle(void);
45void iap_start(void);
46 iap_result_type iap_address(uint8_t *pdata, uint32_t len);
47void iap_finish(void);
48 iap_result_type iap_data_write(uint8_t *pdata, uint32_t len);
49void iap_jump(void);
50void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result);
51
57void jump_to_app(uint32_t address)
58{
59 uint32_t stkptr, jumpaddr;
60 stkptr = *(uint32_t *)address;
61 jumpaddr = *(uint32_t *)(address + sizeof(uint32_t));
62
63 /* disable nvic irq and periph clock, clear pending */
64 nvic_irq_disable(OTGFS1_IRQn);
65 nvic_irq_disable(OTGFS2_IRQn);
66
67 __NVIC_ClearPendingIRQ(OTGFS1_IRQn);
68 __NVIC_ClearPendingIRQ(OTGFS2_IRQn);
69
70 crm_periph_clock_enable(CRM_OTGFS1_PERIPH_CLOCK, FALSE);
71 crm_periph_clock_enable(CRM_OTGFS2_PERIPH_CLOCK, FALSE);
72
73 crm_periph_reset(CRM_OTGFS1_PERIPH_RESET, TRUE);
74 crm_periph_reset(CRM_OTGFS1_PERIPH_RESET, FALSE);
75
76 crm_periph_reset(CRM_OTGFS2_PERIPH_RESET, TRUE);
77 crm_periph_reset(CRM_OTGFS2_PERIPH_RESET, FALSE);
78
79 __set_MSP(stkptr);
80 pftarget = (void (*) (void))jumpaddr;
81 pftarget();
82}
83
89void iap_clear_upgrade_flag(void)
90{
91 flash_unlock();
92 flash_sector_erase(iap_info.flag_address);
93 flash_lock();
94}
95
101void iap_set_upgrade_flag(void)
102{
103 flash_unlock();
104 flash_word_program(iap_info.flag_address, IAP_UPGRADE_COMPLETE_FLAG);
105 flash_lock();
106}
107
113 iap_result_type iap_get_upgrade_flag(void)
114{
115 uint32_t flag_address = iap_info.flag_address;
116 if(*((uint32_t *)flag_address) == IAP_UPGRADE_COMPLETE_FLAG)
117 {
118 return IAP_SUCCESS;
119 }
120 else
121 {
122 return IAP_FAILED;
123 }
124}
125
131void iap_erase_sector(uint32_t address)
132{
133 flash_unlock();
134 if(iap_info.sector_size == SECTOR_SIZE_1K)
135 {
136 flash_sector_erase(address);
137 }
138 else if(iap_info.sector_size == SECTOR_SIZE_2K)
139 {
140 /* check the address is sector align */
141 if((address & (SECTOR_SIZE_2K-1)) == 0)
142 {
143 flash_sector_erase(address);
144 }
145 }
146 else if(iap_info.sector_size == SECTOR_SIZE_4K)
147 {
148 if((address & (SECTOR_SIZE_4K-1)) == 0)
149 {
150 flash_sector_erase(address);
151 }
152 }
153 flash_lock();
154}
155
162uint32_t crc_cal(uint32_t addr, uint16_t nk)
163{
164 uint32_t *paddr = (uint32_t *)addr;
165 uint32_t wlen = nk * 1024 / sizeof(uint32_t);
166 uint32_t value, i_index = 0;
167 crm_periph_clock_enable(CRM_CRC_PERIPH_CLOCK, TRUE);
168 crc_data_reset();
169
170 for(i_index = 0; i_index < wlen; i_index ++)
171 {
172 value = *paddr;
173 crc_one_word_calculate(CONVERT_ENDIAN(value));
174
175 paddr ++;
176 }
177 return crc_data_get();
178}
179
185void iap_init(void)
186{
187 uint32_t devid = (*((uint32_t *)DEBUG_BASE) & 0x00007000) >> 12;
188
189 switch(devid)
190 {
191 case 2:
192 iap_info.sector_size = SECTOR_SIZE_1K;
193 break;
194 case 3:
195 iap_info.sector_size = SECTOR_SIZE_2K;
196 break;
197 case 4:
198 iap_info.sector_size = SECTOR_SIZE_4K;
199 break;
200 default:
201 iap_info.sector_size = SECTOR_SIZE_2K;
202 break;
203 }
204
205 iap_info.flash_size = KB_TO_B(FLASH_SIZE_REG());
206
207 iap_info.flash_start_address = FLASH_BASE;
208 iap_info.flash_end_address = iap_info.flash_start_address + iap_info.flash_size;
209
210 iap_info.app_address = FLASH_APP_ADDRESS;
211 iap_info.flag_address = iap_info.app_address - iap_info.sector_size;
212
213 iap_info.fifo_length = 0;
214 iap_info.iap_address = 0;
215}
216
222void iap_idle(void)
223{
224 iap_info.state = IAP_STS_START;
225 iap_init();
226 iap_respond(iap_info.iap_tx, IAP_CMD_IDLE, IAP_ACK);
227}
228
234void iap_start(void)
235{
236 iap_info.state = IAP_STS_START;
237 iap_init();
238 iap_respond(iap_info.iap_tx, IAP_CMD_START, IAP_ACK);
239}
240
247 iap_result_type iap_address(uint8_t *pdata, uint32_t len)
248{
249 iap_result_type status = IAP_SUCCESS;
250 uint16_t result = IAP_ACK;
251 uint8_t *paddr = pdata + 2; /* skip iap cmd */
252 uint32_t address;
253
254 address = (paddr[0] << 24) |
255 (paddr[1] << 16) |
256 (paddr[2] << 8) |
257 paddr[3];
258
259 /* check the address is valid */
260 if(address < iap_info.app_address || address > iap_info.flash_end_address)
261 {
262 status = IAP_FAILED;
263 result = IAP_NACK;
264 }
265 else
266 {
267 iap_info.iap_address = address;
268
269 if(iap_info.state == IAP_STS_START)
270 {
271 iap_clear_upgrade_flag();
272 }
273 iap_erase_sector(iap_info.iap_address);
274 }
275
276 iap_info.state = IAP_STS_ADDR;
277
278 iap_respond(iap_info.iap_tx, IAP_CMD_ADDR, result);
279
280 return status;
281}
282/*
283 * @brief iap data write
284 * @param pdata: data buffer pointer.
285 * @param len: buffer length
286 * @retval the result of the address parse
287 */
288 iap_result_type iap_data_write(uint8_t *pdata, uint32_t len)
289{
290 uint32_t data_len = (pdata[2] << 8 | pdata[3]);
291 uint8_t *valid_data = pdata + 4;
292 uint32_t *pbuf;
293 uint32_t i_index = 0;
294
295 if(iap_info.state == IAP_STS_ADDR)
296 {
297 if(data_len + iap_info.fifo_length <= HID_IAP_BUFFER_LEN)
298 {
299 for(i_index = 0; i_index < data_len; i_index ++)
300 {
301 iap_info.iap_fifo[iap_info.fifo_length ++] = valid_data[i_index];
302 }
303 }
304 /* buffer full */
305 if(iap_info.fifo_length == HID_IAP_BUFFER_LEN)
306 {
307 flash_unlock();
308 pbuf = (uint32_t *)iap_info.iap_fifo;
309 for(i_index = 0; i_index < iap_info.fifo_length / sizeof(uint32_t); i_index ++)
310 {
311 flash_word_program(iap_info.iap_address, *pbuf ++);
312 iap_info.iap_address += 4;
313 }
314 flash_lock();
315
316 iap_info.fifo_length = 0;
317 iap_info.iap_address = 0;
318 iap_respond(iap_info.iap_tx, IAP_CMD_DATA, IAP_ACK);
319 }
320 }
321 else
322 {
323 iap_respond(iap_info.iap_tx, IAP_CMD_ADDR, IAP_NACK);
324 }
325 return IAP_SUCCESS;
326}
327
328/*
329 * @brief iap finish
330 * @param none
331 * @retval none
332 */
333void iap_finish()
334{
335 iap_info.state = IAP_STS_FINISH;
336 iap_set_upgrade_flag();
337 iap_respond(iap_info.iap_tx, IAP_CMD_FINISH, IAP_ACK);
338}
339
340/*
341 * @brief iap crc
342 * @param pdata: data buffer pointer.
343 * @param len: buffer length
344 * @retval the result of the address parse
345 */
346void iap_crc(uint8_t *pdata, uint32_t len)
347{
348 uint8_t *paddr = pdata + 2; /* skip iap cmd */
349 uint16_t crc_nk;
350 uint32_t crc_value;
351 uint32_t address = (paddr[0] << 24) |
352 (paddr[1] << 16) |
353 (paddr[2] << 8) |
354 paddr[3];
355 paddr = pdata + 6;
356
357 crc_nk = (paddr[0] << 16) | paddr[1];
358
359 crc_value = crc_cal(address, crc_nk);
360
361 iap_respond(iap_info.iap_tx, IAP_CMD_CRC, IAP_ACK);
362 iap_info.iap_tx[4] = (uint8_t)((crc_value >> 24) & 0xFF);
363 iap_info.iap_tx[5] = (uint8_t)((crc_value >> 16) & 0xFF);
364 iap_info.iap_tx[6] = (uint8_t)((crc_value >> 8) & 0xFF);
365 iap_info.iap_tx[7] = (uint8_t)((crc_value) & 0xFF);
366
367}
368
369/*
370 * @brief iap jump
371 * @param none
372 * @retval none
373 */
374void iap_jump()
375{
376 iap_info.state = IAP_STS_JMP_WAIT;
377 iap_respond(iap_info.iap_tx, IAP_CMD_JMP, IAP_ACK);
378}
379
380/*
381 * @brief iap get
382 * @param none
383 * @retval none
384 */
385void iap_get()
386{
387 iap_respond(iap_info.iap_tx, IAP_CMD_GET, IAP_ACK);
388 iap_info.iap_tx[4] = (uint8_t)((iap_info.app_address >> 24) & 0xFF);
389 iap_info.iap_tx[5] = (uint8_t)((iap_info.app_address >> 16) & 0xFF);
390 iap_info.iap_tx[6] = (uint8_t)((iap_info.app_address >> 8) & 0xFF);
391 iap_info.iap_tx[7] = (uint8_t)((iap_info.app_address) & 0xFF);
392}
393
394
395
396/*
397 * @brief iap respond
398 * @param res_buf: data buffer pointer.
399 * @param iap_cmd: iap command
400 * @param result: iap result
401 * @retval the result of the address parse
402 */
403void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
404{
405 res_buf[0] = (uint8_t)((iap_cmd >> 8) & 0xFF);
406 res_buf[1] = (uint8_t)((iap_cmd) & 0xFF);
407 res_buf[2] = (uint8_t)((result >> 8) & 0xFF);
408 res_buf[3] = (uint8_t)((result) & 0xFF);
409
410 iap_info.respond_flag = 1;
411}
412
420 iap_result_type usbd_hid_iap_process(void *udev, uint8_t *pdata, uint16_t len)
421{
422 iap_result_type status = IAP_SUCCESS;
423 uint16_t iap_cmd;
424
425 if(len < 2)
426 {
427 return IAP_FAILED;
428 }
429
430 iap_info.respond_flag = 0;
431
432 iap_cmd = (pdata[0] << 8) | pdata[1];
433
434 switch(iap_cmd)
435 {
436 case IAP_CMD_IDLE:
437 iap_idle();
438 break;
439 case IAP_CMD_START:
440 iap_start();
441 break;
442 case IAP_CMD_ADDR:
443 iap_address(pdata, len);
444 break;
445 case IAP_CMD_DATA:
446 iap_data_write(pdata, len);
447 break;
448 case IAP_CMD_FINISH:
449 iap_finish();
450 break;
451 case IAP_CMD_CRC:
452 iap_crc(pdata, len);
453 break;
454 case IAP_CMD_JMP:
455 iap_jump();
456 break;
457 case IAP_CMD_GET:
458 iap_get();
459 break;
460 default:
461 status = IAP_FAILED;
462 break;
463 }
464
465 if(iap_info.respond_flag)
466 {
467 usb_iap_class_send_report(udev, iap_info.iap_tx, 64);
468 }
469
470 return status;
471}
472
478void usbd_hid_iap_in_complete(void *udev)
479{
480 if(iap_info.state == IAP_STS_JMP_WAIT)
481 {
482 iap_info.state = IAP_STS_JMP;
483 }
484}
485
491void iap_loop(void)
492{
493 if(iap_info.state == IAP_STS_JMP)
494 {
495 delay_ms(100);
496 jump_to_app(iap_info.app_address);
497 }
498}
499
crc_value
__IO uint32_t crc_value
Definition: project/at_start_f435/examples/crc/calculation/src/main.c:64
FLASH_APP_ADDRESS
#define FLASH_APP_ADDRESS
Definition: app_led3_toggle/inc/hid_iap_user.h:46
data_len
uint16_t data_len
Definition: project/at_start_f435/examples/usb_device/virtual_comport/src/main.c:47
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
crc_data_reset
void crc_data_reset(void)
reset the crc data register.
Definition: at32f435_437_crc.c:49
crc_data_get
uint32_t crc_data_get(void)
return the current crc value.
Definition: at32f435_437_crc.c:89
crc_one_word_calculate
uint32_t crc_one_word_calculate(uint32_t data)
compute the 32-bit crc of a given data word(32-bit).
Definition: at32f435_437_crc.c:60
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f435_437_crm.c:251
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_OTGFS1_PERIPH_CLOCK
@ CRM_OTGFS1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:120
CRM_OTGFS2_PERIPH_CLOCK
@ CRM_OTGFS2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:117
CRM_CRC_PERIPH_CLOCK
@ CRM_CRC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:113
CRM_OTGFS1_PERIPH_RESET
@ CRM_OTGFS1_PERIPH_RESET
Definition: at32f435_437_crm.h:267
CRM_OTGFS2_PERIPH_RESET
@ CRM_OTGFS2_PERIPH_RESET
Definition: at32f435_437_crm.h:264
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f435_437_flash.c:357
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f435_437_flash.c:290
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f435_437_flash.c:608
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f435_437_flash.c:325
nvic_irq_disable
void nvic_irq_disable(IRQn_Type irqn)
disable nvic irq number
Definition: at32f435_437_misc.c:81
DEBUG_BASE
#define DEBUG_BASE
Definition: at32f435_437.h:427
FLASH_BASE
#define FLASH_BASE
Definition: at32f435_437.h:425
iap_set_upgrade_flag
void iap_set_upgrade_flag(void)
set iap upgrade complete flag
Definition: bootloader/src/hid_iap_user.c:101
iap_idle
void iap_idle(void)
iap idle function
Definition: bootloader/src/hid_iap_user.c:222
iap_respond
void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
Definition: bootloader/src/hid_iap_user.c:403
iap_data_write
iap_result_type iap_data_write(uint8_t *pdata, uint32_t len)
Definition: bootloader/src/hid_iap_user.c:288
iap_init
void iap_init(void)
iap init
Definition: bootloader/src/hid_iap_user.c:185
usbd_hid_iap_process
iap_result_type usbd_hid_iap_process(void *udev, uint8_t *pdata, uint16_t len)
usb device iap function
Definition: bootloader/src/hid_iap_user.c:420
jump_to_app
void jump_to_app(uint32_t address)
jump to app
Definition: bootloader/src/hid_iap_user.c:57
crc_cal
uint32_t crc_cal(uint32_t addr, uint16_t nk)
crc cal
Definition: bootloader/src/hid_iap_user.c:162
iap_get_upgrade_flag
iap_result_type iap_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: bootloader/src/hid_iap_user.c:113
iap_address
iap_result_type iap_address(uint8_t *pdata, uint32_t len)
iap parse address
Definition: bootloader/src/hid_iap_user.c:247
iap_finish
void iap_finish(void)
Definition: bootloader/src/hid_iap_user.c:333
iap_loop
void iap_loop(void)
iap loop
Definition: bootloader/src/hid_iap_user.c:491
iap_start
void iap_start(void)
iap start function
Definition: bootloader/src/hid_iap_user.c:234
iap_crc
void iap_crc(uint8_t *pdata, uint32_t len)
Definition: bootloader/src/hid_iap_user.c:346
pftarget
void(* pftarget)(void)
Definition: bootloader/src/hid_iap_user.c:39
iap_erase_sector
void iap_erase_sector(uint32_t address)
set iap upgrade complete flag
Definition: bootloader/src/hid_iap_user.c:131
iap_clear_upgrade_flag
void iap_clear_upgrade_flag(void)
clear iap upgrade flag
Definition: bootloader/src/hid_iap_user.c:89
iap_get
void iap_get()
Definition: bootloader/src/hid_iap_user.c:385
iap_jump
void iap_jump(void)
Definition: bootloader/src/hid_iap_user.c:374
usbd_hid_iap_in_complete
void usbd_hid_iap_in_complete(void *udev)
usb device in transfer complete function
Definition: bootloader/src/hid_iap_user.c:478
HID_IAP_BUFFER_LEN
#define HID_IAP_BUFFER_LEN
Definition: hid_iap_class.h:77
IAP_CMD_DATA
#define IAP_CMD_DATA
Definition: hid_iap_class.h:71
IAP_CMD_FINISH
#define IAP_CMD_FINISH
Definition: hid_iap_class.h:72
IAP_CMD_IDLE
#define IAP_CMD_IDLE
iap command
Definition: hid_iap_class.h:68
IAP_CMD_GET
#define IAP_CMD_GET
Definition: hid_iap_class.h:75
SECTOR_SIZE_1K
#define SECTOR_SIZE_1K
Definition: hid_iap_class.h:61
iap_result_type
iap_result_type
Definition: hid_iap_class.h:86
IAP_NACK
#define IAP_NACK
Definition: hid_iap_class.h:83
IAP_ACK
#define IAP_ACK
Definition: hid_iap_class.h:82
IAP_CMD_CRC
#define IAP_CMD_CRC
Definition: hid_iap_class.h:73
SECTOR_SIZE_2K
#define SECTOR_SIZE_2K
Definition: hid_iap_class.h:62
CONVERT_ENDIAN
#define CONVERT_ENDIAN(dwValue)
Definition: hid_iap_class.h:79
IAP_CMD_ADDR
#define IAP_CMD_ADDR
Definition: hid_iap_class.h:70
SECTOR_SIZE_4K
#define SECTOR_SIZE_4K
Definition: hid_iap_class.h:63
IAP_UPGRADE_COMPLETE_FLAG
#define IAP_UPGRADE_COMPLETE_FLAG
Definition: hid_iap_class.h:78
FLASH_SIZE_REG
#define FLASH_SIZE_REG()
Definition: hid_iap_class.h:58
IAP_CMD_START
#define IAP_CMD_START
Definition: hid_iap_class.h:69
IAP_CMD_JMP
#define IAP_CMD_JMP
Definition: hid_iap_class.h:74
KB_TO_B
#define KB_TO_B(kb)
Definition: hid_iap_class.h:59
IAP_FAILED
@ IAP_FAILED
Definition: hid_iap_class.h:89
IAP_SUCCESS
@ IAP_SUCCESS
Definition: hid_iap_class.h:87
IAP_STS_START
@ IAP_STS_START
Definition: hid_iap_class.h:95
IAP_STS_JMP
@ IAP_STS_JMP
Definition: hid_iap_class.h:101
IAP_STS_JMP_WAIT
@ IAP_STS_JMP_WAIT
Definition: hid_iap_class.h:100
IAP_STS_FINISH
@ IAP_STS_FINISH
Definition: hid_iap_class.h:98
IAP_STS_ADDR
@ IAP_STS_ADDR
Definition: hid_iap_class.h:96
iap_info
iap_info_type iap_info
Definition: hid_iap_class.c:54
usb_iap_class_send_report
usb_sts_type usb_iap_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: hid_iap_class.c:316
OTGFS2_IRQn
@ OTGFS2_IRQn
Definition: at32f435_437.h:220
OTGFS1_IRQn
@ OTGFS1_IRQn
Definition: at32f435_437.h:213
hid_iap_class.h
usb hid iap header file
iap_info_type::respond_flag
uint32_t respond_flag
Definition: hid_iap_class.h:124
iap_info_type::flag_address
uint32_t flag_address
Definition: hid_iap_class.h:116
iap_info_type::sector_size
uint32_t sector_size
Definition: hid_iap_class.h:121
iap_info_type::iap_address
uint32_t iap_address
Definition: hid_iap_class.h:115
iap_info_type::flash_start_address
uint32_t flash_start_address
Definition: hid_iap_class.h:118
iap_info_type::flash_end_address
uint32_t flash_end_address
Definition: hid_iap_class.h:119
iap_info_type::fifo_length
uint32_t fifo_length
Definition: hid_iap_class.h:111
iap_info_type::iap_fifo
uint8_t iap_fifo[1024]
Definition: hid_iap_class.h:107
iap_info_type::flash_size
uint32_t flash_size
Definition: hid_iap_class.h:122
iap_info_type::iap_tx
uint8_t iap_tx[0x40]
Definition: hid_iap_class.h:109
iap_info_type::app_address
uint32_t app_address
Definition: hid_iap_class.h:114
iap_info_type::state
iap_machine_state_type state
Definition: hid_iap_class.h:133


AT32F435/437 Firmwary Library: usart.c File Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • bootloader
  • src
Functions | Variables
bootloader/src/usart.c File Reference

usart program More...

#include "usart.h"
#include "tmr.h"

Go to the source code of this file.

Functions

void | uart_init (uint32_t baudrate)
init usart. More...
void | USART1_IRQHandler (void)
usart1 interrupt handler. More...

Variables

usart_group_type usart_group_struct

Detailed Description

usart program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file bootloader/src/usart.c.


AT32F435/437 Firmwary Library: usart.c Source File

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • bootloader
  • src
bootloader/src/usart.c
Go to the documentation of this file.
1
27#include "usart.h"
28#include "tmr.h"
29
38 usart_group_type usart_group_struct;
39
45void uart_init(uint32_t baudrate)
46{
47 gpio_init_type gpio_init_struct;
48 /* enable the usart and it's io clock */
49 crm_periph_clock_enable(CRM_USART1_PERIPH_CLOCK, TRUE);
50 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
51
52 /* set default parameter */
53 gpio_default_para_init(&gpio_init_struct);
54
55 /* configure the usart1_tx rx pa9 pa10 */
56 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
57 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
58 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
59 gpio_init_struct.gpio_pins = GPIO_PINS_9 | GPIO_PINS_10;
60 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
61 gpio_init(GPIOA, &gpio_init_struct);
62 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE9 ,GPIO_MUX_7);
63 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE10 ,GPIO_MUX_7);
64
65 /*configure usart nvic interrupt */
66 nvic_irq_enable(USART1_IRQn, 0, 0);
67
68 /*configure usart param*/
69 usart_init(USART1, baudrate, USART_DATA_8BITS, USART_STOP_1_BIT);
70 usart_transmitter_enable(USART1, TRUE);
71 usart_receiver_enable(USART1, TRUE);
72 usart_interrupt_enable(USART1, USART_RDBF_INT, TRUE);
73 usart_enable(USART1, TRUE);
74}
75
81void USART1_IRQHandler(void)
82{
83 uint16_t reval;
84 time_ira_cnt = 0; /* clear upgrade time out flag */
85 if(usart_flag_get(USART1, USART_RDBF_FLAG) != RESET)
86 {
87 reval = usart_data_receive(USART1);
88 if(usart_group_struct.count > (USART_REC_LEN - 1))
89 {
90 usart_group_struct.count = 0;
91 usart_group_struct.head = 0;
92 usart_group_struct.tail = 0;
93 }
94 else
95 {
96 usart_group_struct.count++;
97 usart_group_struct.buf[usart_group_struct.head++] = reval;
98 if(usart_group_struct.head > (USART_REC_LEN - 1))
99 {
100 usart_group_struct.head = 0;
101 }
102 }
103 }
104}
105
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_USART1_PERIPH_CLOCK
@ CRM_USART1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:156
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f435_437_usart.c:598
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f435_437_usart.c:209
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f435_437_usart.c:115
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f435_437_usart.c:196
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f435_437_usart.c:222
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f435_437_usart.c:287
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f435_437_usart.c:425
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f435_437_usart.h:159
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f435_437_usart.h:114
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f435_437_usart.h:57
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f435_437_usart.h:73
USART1
#define USART1
Definition: at32f435_437_usart.h:348
USART_REC_LEN
#define USART_REC_LEN
Definition: bootloader/inc/usart.h:48
time_ira_cnt
uint8_t time_ira_cnt
Definition: at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c:39
USART1_IRQHandler
void USART1_IRQHandler(void)
usart1 interrupt handler.
Definition: bootloader/src/usart.c:81
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: bootloader/src/usart.c:45
usart_group_struct
usart_group_type usart_group_struct
Definition: bootloader/src/usart.c:38
USART1_IRQn
@ USART1_IRQn
Definition: at32f435_437.h:185
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
usart_group_type
usart group type
Definition: bootloader/inc/usart.h:62
usart_group_type::tail
uint16_t tail
Definition: bootloader/inc/usart.h:65
usart_group_type::buf
uint16_t buf[1024]
Definition: bootloader/inc/usart.h:63
usart_group_type::count
uint16_t count
Definition: bootloader/inc/usart.h:66
usart_group_type::head
uint16_t head
Definition: bootloader/inc/usart.h:64


AT32F435/437 Firmwary Library: cdc_class.c Source File

  • middlewares
  • usbd_class
  • cdc
cdc_class.c
Go to the documentation of this file.
1
26#include "usbd_core.h"
27#include "cdc_class.h"
28#include "cdc_desc.h"
29
43static usb_sts_type class_init_handler(void *udev);
44static usb_sts_type class_clear_handler(void *udev);
45static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
46static usb_sts_type class_ept0_tx_handler(void *udev);
47static usb_sts_type class_ept0_rx_handler(void *udev);
48static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
49static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
50static usb_sts_type class_sof_handler(void *udev);
51static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
52
53static usb_sts_type cdc_struct_init(cdc_struct_type *pcdc);
54extern void usb_usart_config( linecoding_type linecoding);
55static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len);
56
57 linecoding_type linecoding =
58{
59 115200,
60 0,
61 0,
62 8
63};
64
65/* cdc data struct */
66 cdc_struct_type cdc_struct;
67
68/* usb device class handler */
69usbd_class_handler cdc_class_handler =
70{
71 class_init_handler,
72 class_clear_handler,
73 class_setup_handler,
74 class_ept0_tx_handler,
75 class_ept0_rx_handler,
76 class_in_handler,
77 class_out_handler,
78 class_sof_handler,
79 class_event_handler,
80 &cdc_struct
81};
87static usb_sts_type class_init_handler(void *udev)
88{
89 usb_sts_type status = USB_OK;
90 usbd_core_type *pudev = (usbd_core_type *)udev;
91 cdc_struct_type *pcdc = (cdc_struct_type *)pudev->class_handler->pdata;
92
93 /* init cdc struct */
94 cdc_struct_init(pcdc);
95
96 /* open in endpoint */
97 usbd_ept_open(pudev, USBD_CDC_INT_EPT, EPT_INT_TYPE, USBD_CDC_CMD_MAXPACKET_SIZE);
98
99 /* open in endpoint */
100 usbd_ept_open(pudev, USBD_CDC_BULK_IN_EPT, EPT_BULK_TYPE, USBD_CDC_IN_MAXPACKET_SIZE);
101
102 /* open out endpoint */
103 usbd_ept_open(pudev, USBD_CDC_BULK_OUT_EPT, EPT_BULK_TYPE, USBD_CDC_OUT_MAXPACKET_SIZE);
104
105 /* set out endpoint to receive status */
106 usbd_ept_recv(pudev, USBD_CDC_BULK_OUT_EPT, pcdc->g_rx_buff, USBD_CDC_OUT_MAXPACKET_SIZE);
107
108 return status;
109}
110
116static usb_sts_type class_clear_handler(void *udev)
117{
118 usb_sts_type status = USB_OK;
119 usbd_core_type *pudev = (usbd_core_type *)udev;
120
121 /* close in endpoint */
122 usbd_ept_close(pudev, USBD_CDC_INT_EPT);
123
124 /* close in endpoint */
125 usbd_ept_close(pudev, USBD_CDC_BULK_IN_EPT);
126
127 /* close out endpoint */
128 usbd_ept_close(pudev, USBD_CDC_BULK_OUT_EPT);
129
130 return status;
131}
132
139static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
140{
141 usb_sts_type status = USB_OK;
142 usbd_core_type *pudev = (usbd_core_type *)udev;
143 cdc_struct_type *pcdc = (cdc_struct_type *)pudev->class_handler->pdata;
144
145 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
146 {
147 /* class request */
148 case USB_REQ_TYPE_CLASS:
149 if(setup->wLength)
150 {
151 if(setup->bmRequestType & USB_REQ_DIR_DTH)
152 {
153 usb_vcp_cmd_process(udev, setup->bRequest, pcdc->g_cmd, setup->wLength);
154 usbd_ctrl_send(pudev, pcdc->g_cmd, setup->wLength);
155 }
156 else
157 {
158 pcdc->g_req = setup->bRequest;
159 pcdc->g_len = setup->wLength;
160 usbd_ctrl_recv(pudev, pcdc->g_cmd, pcdc->g_len);
161
162 }
163 }
164 break;
165 /* standard request */
166 case USB_REQ_TYPE_STANDARD:
167 switch(setup->bRequest)
168 {
169 case USB_STD_REQ_GET_DESCRIPTOR:
170 usbd_ctrl_unsupport(pudev);
171 break;
172 case USB_STD_REQ_GET_INTERFACE:
173 usbd_ctrl_send(pudev, (uint8_t *)&pcdc->alt_setting, 1);
174 break;
175 case USB_STD_REQ_SET_INTERFACE:
176 pcdc->alt_setting = setup->wValue;
177 break;
178 default:
179 break;
180 }
181 break;
182 default:
183 usbd_ctrl_unsupport(pudev);
184 break;
185 }
186 return status;
187}
188
194static usb_sts_type class_ept0_tx_handler(void *udev)
195{
196 usb_sts_type status = USB_OK;
197
198 /* ...user code... */
199
200 return status;
201}
202
208static usb_sts_type class_ept0_rx_handler(void *udev)
209{
210 usb_sts_type status = USB_OK;
211 usbd_core_type *pudev = (usbd_core_type *)udev;
212 cdc_struct_type *pcdc = (cdc_struct_type *)pudev->class_handler->pdata;
213 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
214 /* ...user code... */
215 if( pcdc->g_req == SET_LINE_CODING)
216 {
217 /* class process */
218 usb_vcp_cmd_process(udev, pcdc->g_req, pcdc->g_cmd, recv_len);
219 }
220
221 return status;
222}
223
230static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
231{
232 usbd_core_type *pudev = (usbd_core_type *)udev;
233 cdc_struct_type *pcdc = (cdc_struct_type *)pudev->class_handler->pdata;
234 usb_sts_type status = USB_OK;
235
236 /* ...user code...
237 trans next packet data
238 */
239 usbd_flush_tx_fifo(pudev, ept_num);
240 pcdc->g_tx_completed = 1;
241
242 return status;
243}
244
251static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
252{
253 usb_sts_type status = USB_OK;
254 usbd_core_type *pudev = (usbd_core_type *)udev;
255 cdc_struct_type *pcdc = (cdc_struct_type *)pudev->class_handler->pdata;
256
257 /* get endpoint receive data length */
258 pcdc->g_rxlen = usbd_get_recv_len(pudev, ept_num);
259
260 /*set recv flag*/
261 pcdc->g_rx_completed = 1;
262
263 return status;
264}
265
271static usb_sts_type class_sof_handler(void *udev)
272{
273 usb_sts_type status = USB_OK;
274
275 /* ...user code... */
276
277 return status;
278}
279
286static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
287{
288 usb_sts_type status = USB_OK;
289 switch(event)
290 {
291 case USBD_RESET_EVENT:
292
293 /* ...user code... */
294
295 break;
296 case USBD_SUSPEND_EVENT:
297
298 /* ...user code... */
299
300 break;
301 case USBD_WAKEUP_EVENT:
302 /* ...user code... */
303
304 break;
305 case USBD_INISOINCOM_EVENT:
306 break;
307 case USBD_OUTISOINCOM_EVENT:
308 break;
309
310 default:
311 break;
312 }
313 return status;
314}
315
321static usb_sts_type cdc_struct_init(cdc_struct_type *pcdc)
322{
323 pcdc->g_tx_completed = 1;
324 pcdc->g_rx_completed = 0;
325 pcdc->alt_setting = 0;
326 pcdc->linecoding.bitrate = linecoding.bitrate;
327 pcdc->linecoding.data = linecoding.data;
328 pcdc->linecoding.format = linecoding.format;
329 pcdc->linecoding.parity = linecoding.parity;
330 return USB_OK;
331}
332
339uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
340{
341 uint16_t i_index = 0;
342 uint16_t tmp_len = 0;
343 usbd_core_type *pudev = (usbd_core_type *)udev;
344 cdc_struct_type *pcdc = (cdc_struct_type *)pudev->class_handler->pdata;
345
346 if(pcdc->g_rx_completed == 0)
347 {
348 return 0;
349 }
350 pcdc->g_rx_completed = 0;
351 tmp_len = pcdc->g_rxlen;
352 for(i_index = 0; i_index < pcdc->g_rxlen; i_index ++)
353 {
354 recv_data[i_index] = pcdc->g_rx_buff[i_index];
355 }
356
357 usbd_ept_recv(pudev, USBD_CDC_BULK_OUT_EPT, pcdc->g_rx_buff, USBD_CDC_OUT_MAXPACKET_SIZE);
358
359 return tmp_len;
360}
361
369 error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
370{
371 error_status status = SUCCESS;
372 usbd_core_type *pudev = (usbd_core_type *)udev;
373 cdc_struct_type *pcdc = (cdc_struct_type *)pudev->class_handler->pdata;
374 if(pcdc->g_tx_completed)
375 {
376 pcdc->g_tx_completed = 0;
377 usbd_ept_send(pudev, USBD_CDC_BULK_IN_EPT, send_data, len);
378 }
379 else
380 {
381 status = ERROR;
382 }
383 return status;
384}
385
394static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
395{
396 usbd_core_type *pudev = (usbd_core_type *)udev;
397 cdc_struct_type *pcdc = (cdc_struct_type *)pudev->class_handler->pdata;
398 switch(cmd)
399 {
400 case SET_LINE_CODING:
401 pcdc->linecoding.bitrate = (uint32_t)(buff[0] | (buff[1] << 8) | (buff[2] << 16) | (buff[3] <<24));
402 pcdc->linecoding.format = buff[4];
403 pcdc->linecoding.parity = buff[5];
404 pcdc->linecoding.data = buff[6];
405#ifdef USB_VIRTUAL_COMPORT
406 /* set hardware usart */
407 usb_usart_config(pcdc->linecoding);
408#endif
409 break;
410
411 case GET_LINE_CODING:
412 buff[0] = (uint8_t)pcdc->linecoding.bitrate;
413 buff[1] = (uint8_t)(pcdc->linecoding.bitrate >> 8);
414 buff[2] = (uint8_t)(pcdc->linecoding.bitrate >> 16);
415 buff[3] = (uint8_t)(pcdc->linecoding.bitrate >> 24);
416 buff[4] = (uint8_t)(pcdc->linecoding.format);
417 buff[5] = (uint8_t)(pcdc->linecoding.parity);
418 buff[6] = (uint8_t)(pcdc->linecoding.data);
419 break;
420
421 default:
422 break;
423 }
424}
425
cdc_class.h
usb cdc class file
cdc_desc.h
usb cdc descriptor header file
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
USBD_CDC_CMD_MAXPACKET_SIZE
#define USBD_CDC_CMD_MAXPACKET_SIZE
Definition: cdc_class.h:62
USBD_CDC_BULK_OUT_EPT
#define USBD_CDC_BULK_OUT_EPT
Definition: cdc_class.h:55
USBD_CDC_INT_EPT
#define USBD_CDC_INT_EPT
usb cdc use endpoint define
Definition: cdc_class.h:53
USBD_CDC_BULK_IN_EPT
#define USBD_CDC_BULK_IN_EPT
Definition: cdc_class.h:54
USBD_CDC_OUT_MAXPACKET_SIZE
#define USBD_CDC_OUT_MAXPACKET_SIZE
Definition: cdc_class.h:61
USBD_CDC_IN_MAXPACKET_SIZE
#define USBD_CDC_IN_MAXPACKET_SIZE
usb cdc in and out max packet size define
Definition: cdc_class.h:60
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: cdc_class.c:271
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: cdc_class.c:230
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: cdc_class.c:116
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_class.c:139
usb_usart_config
void usb_usart_config(linecoding_type linecoding)
this function handles usart2 and linecoding config.
Definition: project/at_start_f435/examples/usb_device/virtual_comport/src/main.c:241
linecoding
linecoding_type linecoding
Definition: cdc_class.c:57
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: cdc_class.c:194
usb_vcp_get_rxdata
uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_class.c:339
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: cdc_class.c:208
cdc_struct_init
static usb_sts_type cdc_struct_init(cdc_struct_type *pcdc)
usb device cdc init
Definition: cdc_class.c:321
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: cdc_class.c:286
usb_vcp_cmd_process
static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device function
Definition: cdc_class.c:394
usb_vcp_send_data
error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_class.c:369
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: cdc_class.c:87
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: cdc_class.c:251
cdc_struct
cdc_struct_type cdc_struct
Definition: cdc_class.c:66
cdc_class_handler
usbd_class_handler cdc_class_handler
Definition: cdc_class.c:69
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f435_437_usb.h:349
EPT_BULK_TYPE
@ EPT_BULK_TYPE
Definition: at32f435_437_usb.h:348
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:63
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:81
GET_LINE_CODING
#define GET_LINE_CODING
Definition: usb_std.h:207
SET_LINE_CODING
#define SET_LINE_CODING
usb cdc class request code define
Definition: usb_std.h:206
USB_REQ_DIR_DTH
#define USB_REQ_DIR_DTH
Definition: usb_std.h:72
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:86
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:66
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:85
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:64
USB_OK
@ USB_OK
Definition: usb_std.h:268
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:346
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint receive data
Definition: usbd_core.c:534
usbd_flush_tx_fifo
void usbd_flush_tx_fifo(usbd_core_type *udev, uint8_t ept_num)
usb device flush in endpoint fifo
Definition: usbd_core.c:650
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:314
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:177
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint send data
Definition: usbd_core.c:434
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
get endpoint receive data length
Definition: usbd_core.c:300
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint recv data
Definition: usbd_core.c:196
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:287
cdc_struct_type
usb cdc class struct
Definition: cdc_class.h:76
cdc_struct_type::alt_setting
uint32_t alt_setting
Definition: cdc_class.h:77
cdc_struct_type::g_req
uint8_t g_req
Definition: cdc_class.h:80
cdc_struct_type::g_rxlen
uint16_t g_rxlen
Definition: cdc_class.h:81
cdc_struct_type::g_tx_completed
__IO uint8_t g_tx_completed
Definition: cdc_class.h:82
cdc_struct_type::linecoding
linecoding_type linecoding
Definition: cdc_class.h:83
cdc_struct_type::g_rx_completed
__IO uint8_t g_rx_completed
Definition: cdc_class.h:82
cdc_struct_type::g_cmd
uint8_t g_cmd[0x08]
Definition: cdc_class.h:79
cdc_struct_type::g_rx_buff
uint8_t g_rx_buff[0x40]
Definition: cdc_class.h:78
cdc_struct_type::g_len
uint16_t g_len
Definition: cdc_class.h:81
linecoding_type
usb cdc class set line coding struct
Definition: usb_std.h:213
linecoding_type::bitrate
uint32_t bitrate
Definition: usb_std.h:214
linecoding_type::data
uint8_t data
Definition: usb_std.h:217
linecoding_type::parity
uint8_t parity
Definition: usb_std.h:216
linecoding_type::format
uint8_t format
Definition: usb_std.h:215
usb_setup_type
format of usb setup data
Definition: usb_std.h:280
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:283
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:286
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:281
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:282
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: cdc_class.h Source File

  • middlewares
  • usbd_class
  • cdc
cdc_class.h
Go to the documentation of this file.
1
27 /* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __CDC_CLASS_H
29#define __CDC_CLASS_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "usb_std.h"
36#include "usbd_core.h"
37
53#define USBD_CDC_INT_EPT 0x82
54#define USBD_CDC_BULK_IN_EPT 0x81
55#define USBD_CDC_BULK_OUT_EPT 0x01
56
60#define USBD_CDC_IN_MAXPACKET_SIZE 0x40
61#define USBD_CDC_OUT_MAXPACKET_SIZE 0x40
62#define USBD_CDC_CMD_MAXPACKET_SIZE 0x08
63
75typedef struct
76{
77 uint32_t alt_setting;
78 uint8_t g_rx_buff[USBD_CDC_OUT_MAXPACKET_SIZE];
79 uint8_t g_cmd[USBD_CDC_CMD_MAXPACKET_SIZE];
80 uint8_t g_req;
81 uint16_t g_len, g_rxlen;
82 __IO uint8_t g_tx_completed, g_rx_completed;
83 linecoding_type linecoding;
84}cdc_struct_type;
85
86
94extern usbd_class_handler cdc_class_handler;
95uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data);
96 error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len);
97
109#ifdef __cplusplus
110}
111#endif
112
113#endif
114
115
116
117
error_status
error_status
Definition: at32f435_437.h:380
USBD_CDC_CMD_MAXPACKET_SIZE
#define USBD_CDC_CMD_MAXPACKET_SIZE
Definition: cdc_class.h:62
USBD_CDC_OUT_MAXPACKET_SIZE
#define USBD_CDC_OUT_MAXPACKET_SIZE
Definition: cdc_class.h:61
usb_vcp_get_rxdata
uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_class.c:339
usb_vcp_send_data
error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_class.c:369
cdc_class_handler
usbd_class_handler cdc_class_handler
Definition: cdc_class.c:69
cdc_struct_type
usb cdc class struct
Definition: cdc_class.h:76
cdc_struct_type::alt_setting
uint32_t alt_setting
Definition: cdc_class.h:77
cdc_struct_type::g_req
uint8_t g_req
Definition: cdc_class.h:80
cdc_struct_type::linecoding
linecoding_type linecoding
Definition: cdc_class.h:83
cdc_struct_type::g_rx_completed
__IO uint8_t g_rx_completed
Definition: cdc_class.h:82
cdc_struct_type::g_len
uint16_t g_len
Definition: cdc_class.h:81
linecoding_type
usb cdc class set line coding struct
Definition: usb_std.h:213
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: cdc_desc.c Source File

  • middlewares
  • usbd_class
  • cdc
cdc_desc.c
Go to the documentation of this file.
1
26#include "stdio.h"
27#include "usb_std.h"
28#include "usbd_sdr.h"
29#include "usbd_core.h"
30#include "cdc_desc.h"
31
45static usbd_desc_t *get_device_descriptor(void);
46static usbd_desc_t *get_device_qualifier(void);
47static usbd_desc_t *get_device_configuration(void);
48static usbd_desc_t *get_device_other_speed(void);
49static usbd_desc_t *get_device_lang_id(void);
50static usbd_desc_t *get_device_manufacturer_string(void);
51static usbd_desc_t *get_device_product_string(void);
52static usbd_desc_t *get_device_serial_string(void);
53static usbd_desc_t *get_device_interface_string(void);
54static usbd_desc_t *get_device_config_string(void);
55
56static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
57static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
58static void get_serial_num(void);
59static uint8_t g_usbd_desc_buffer[256];
60
64usbd_desc_handler cdc_desc_handler =
65{
66 get_device_descriptor,
67 get_device_qualifier,
68 get_device_configuration,
69 get_device_other_speed,
70 get_device_lang_id,
71 get_device_manufacturer_string,
72 get_device_product_string,
73 get_device_serial_string,
74 get_device_interface_string,
75 get_device_config_string,
76};
77
81#if defined ( __ICCARM__ ) /* iar compiler */
82 #pragma data_alignment=4
83#endif
84ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
85{
86 USB_DEVICE_DESC_LEN, /* bLength */
87 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
88 0x00, /* bcdUSB */
89 0x02,
90 0x02, /* bDeviceClass */
91 0x00, /* bDeviceSubClass */
92 0x00, /* bDeviceProtocol */
93 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
94 LBYTE(USBD_CDC_VENDOR_ID), /* idVendor */
95 HBYTE(USBD_CDC_VENDOR_ID), /* idVendor */
96 LBYTE(USBD_CDC_PRODUCT_ID), /* idProduct */
97 HBYTE(USBD_CDC_PRODUCT_ID), /* idProduct */
98 0x00, /* bcdDevice rel. 2.00 */
99 0x02,
100 USB_MFC_STRING, /* Index of manufacturer string */
101 USB_PRODUCT_STRING, /* Index of product string */
102 USB_SERIAL_STRING, /* Index of serial number string */
103 1 /* bNumConfigurations */
104};
105
109#if defined ( __ICCARM__ ) /* iar compiler */
110 #pragma data_alignment=4
111#endif
112ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_CDC_CONFIG_DESC_SIZE] ALIGNED_TAIL =
113{
114 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
115 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
116 LBYTE(USBD_CDC_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
117 HBYTE(USBD_CDC_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
118 0x02, /* bNumInterfaces: 2 interface */
119 0x01, /* bConfigurationValue: configuration value */
120 0x00, /* iConfiguration: index of string descriptor describing
121 the configuration */
122 0xC0, /* bmAttributes: self powered */
123 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
124
125 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
126 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
127 0x00, /* bInterfaceNumber: number of interface */
128 0x00, /* bAlternateSetting: alternate set */
129 0x01, /* bNumEndpoints: number of endpoints */
130 USB_CLASS_CODE_CDC, /* bInterfaceClass: CDC class code */
131 0x02, /* bInterfaceSubClass: subclass code, Abstract Control Model*/
132 0x01, /* bInterfaceProtocol: protocol code, AT Command */
133 0x00, /* iInterface: index of string descriptor */
134
135 0x05, /* bFunctionLength: size of this descriptor in bytes */
136 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
137 USBD_CDC_SUBTYPE_HEADER, /* bDescriptorSubtype: Header function Descriptor 0x00*/
138 LBYTE(CDC_BCD_NUM),
139 HBYTE(CDC_BCD_NUM), /* bcdCDC: USB class definitions for communications */
140
141 0x05, /* bFunctionLength: size of this descriptor in bytes */
142 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
143 USBD_CDC_SUBTYPE_CMF, /* bDescriptorSubtype: Call Management function descriptor subtype 0x01 */
144 0x00, /* bmCapabilities: 0x00*/
145 0x01, /* bDataInterface: interface number of data class interface optionally used for call management */
146
147 0x04, /* bFunctionLength: size of this descriptor in bytes */
148 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
149 USBD_CDC_SUBTYPE_ACM, /* bDescriptorSubtype: Abstract Control Management functional descriptor subtype 0x02 */
150 0x02, /* bmCapabilities: Support Set_Line_Coding and Get_Line_Coding 0x02 */
151
152 0x05, /* bFunctionLength: size of this descriptor in bytes */
153 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
154 USBD_CDC_SUBTYPE_UFD, /* bDescriptorSubtype: Union Function Descriptor subtype 0x06 */
155 0x00, /* bControlInterface: The interface number of the communications or data class interface 0x00 */
156 0x01, /* bSubordinateInterface0: interface number of first subordinate interface in the union */
157
158 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
159 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
160 USBD_CDC_INT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
161 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
162 LBYTE(USBD_CDC_CMD_MAXPACKET_SIZE),
163 HBYTE(USBD_CDC_CMD_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
164 CDC_HID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
165
166
167 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
168 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
169 0x01, /* bInterfaceNumber: number of interface */
170 0x00, /* bAlternateSetting: alternate set */
171 0x02, /* bNumEndpoints: number of endpoints */
172 USB_CLASS_CODE_CDCDATA, /* bInterfaceClass: CDC-data class code */
173 0x00, /* bInterfaceSubClass: Data interface subclass code 0x00*/
174 0x00, /* bInterfaceProtocol: data class protocol code 0x00 */
175 0x00, /* iInterface: index of string descriptor */
176
177 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
178 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
179 USBD_CDC_BULK_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
180 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
181 LBYTE(USBD_CDC_IN_MAXPACKET_SIZE),
182 HBYTE(USBD_CDC_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
183 0x00, /* bInterval: interval for polling endpoint for data transfers */
184
185 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
186 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
187 USBD_CDC_BULK_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
188 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
189 LBYTE(USBD_CDC_OUT_MAXPACKET_SIZE),
190 HBYTE(USBD_CDC_OUT_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
191 0x00, /* bInterval: interval for polling endpoint for data transfers */
192};
193
197#if defined ( __ICCARM__ ) /* iar compiler */
198 #pragma data_alignment=4
199#endif
200ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_CDC_SIZ_STRING_LANGID] ALIGNED_TAIL =
201{
202 USBD_CDC_SIZ_STRING_LANGID,
203 USB_DESCIPTOR_TYPE_STRING,
204 0x09,
205 0x04,
206};
207
211#if defined ( __ICCARM__ ) /* iar compiler */
212 #pragma data_alignment=4
213#endif
214ALIGNED_HEAD static uint8_t g_string_serial[USBD_CDC_SIZ_STRING_SERIAL] ALIGNED_TAIL =
215{
216 USBD_CDC_SIZ_STRING_SERIAL,
217 USB_DESCIPTOR_TYPE_STRING,
218};
219
220
221/* device descriptor */
222static usbd_desc_t device_descriptor =
223{
224 USB_DEVICE_DESC_LEN,
225 g_usbd_descriptor
226};
227
228/* config descriptor */
229static usbd_desc_t config_descriptor =
230{
231 USBD_CDC_CONFIG_DESC_SIZE,
232 g_usbd_configuration
233};
234
235/* langid descriptor */
236static usbd_desc_t langid_descriptor =
237{
238 USBD_CDC_SIZ_STRING_LANGID,
239 g_string_lang_id
240};
241
242/* serial descriptor */
243static usbd_desc_t serial_descriptor =
244{
245 USBD_CDC_SIZ_STRING_SERIAL,
246 g_string_serial
247};
248
249static usbd_desc_t vp_desc;
250
257static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
258{
259 uint16_t str_len = 0, id_pos = 2;
260 uint8_t *tmp_str = string;
261
262 while(*tmp_str != '\0')
263 {
264 str_len ++;
265 unicode_buf[id_pos ++] = *tmp_str ++;
266 unicode_buf[id_pos ++] = 0x00;
267 }
268
269 str_len = str_len * 2 + 2;
270 unicode_buf[0] = (uint8_t)str_len;
271 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
272
273 return str_len;
274}
275
283static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
284{
285 uint8_t idx = 0;
286
287 for( idx = 0 ; idx < len ; idx ++)
288 {
289 if( ((value >> 28)) < 0xA )
290 {
291 pbuf[ 2 * idx] = (value >> 28) + '0';
292 }
293 else
294 {
295 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
296 }
297
298 value = value << 4;
299
300 pbuf[2 * idx + 1] = 0;
301 }
302}
303
309static void get_serial_num(void)
310{
311 uint32_t serial0, serial1, serial2;
312
313 serial0 = *(uint32_t*)MCU_ID1;
314 serial1 = *(uint32_t*)MCU_ID2;
315 serial2 = *(uint32_t*)MCU_ID3;
316
317 serial0 += serial2;
318
319 if (serial0 != 0)
320 {
321 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
322 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
323 }
324}
325
331static usbd_desc_t *get_device_descriptor(void)
332{
333 return &device_descriptor;
334}
335
341static usbd_desc_t * get_device_qualifier(void)
342{
343 return NULL;
344}
345
351static usbd_desc_t *get_device_configuration(void)
352{
353 return &config_descriptor;
354}
355
361static usbd_desc_t *get_device_other_speed(void)
362{
363 return NULL;
364}
365
371static usbd_desc_t *get_device_lang_id(void)
372{
373 return &langid_descriptor;
374}
375
376
382static usbd_desc_t *get_device_manufacturer_string(void)
383{
384 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CDC_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
385 vp_desc.descriptor = g_usbd_desc_buffer;
386 return &vp_desc;
387}
388
394static usbd_desc_t *get_device_product_string(void)
395{
396 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CDC_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
397 vp_desc.descriptor = g_usbd_desc_buffer;
398 return &vp_desc;
399}
400
406static usbd_desc_t *get_device_serial_string(void)
407{
408 get_serial_num();
409 return &serial_descriptor;
410}
411
417static usbd_desc_t *get_device_interface_string(void)
418{
419 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CDC_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
420 vp_desc.descriptor = g_usbd_desc_buffer;
421 return &vp_desc;
422}
423
429static usbd_desc_t *get_device_config_string(void)
430{
431 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CDC_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
432 vp_desc.descriptor = g_usbd_desc_buffer;
433 return &vp_desc;
434}
435
cdc_desc.h
usb cdc descriptor header file
idx
uint32_t idx
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:46
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:215
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:216
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:217
USBD_CDC_CMD_MAXPACKET_SIZE
#define USBD_CDC_CMD_MAXPACKET_SIZE
Definition: cdc_class.h:62
USBD_CDC_BULK_OUT_EPT
#define USBD_CDC_BULK_OUT_EPT
Definition: cdc_class.h:55
USBD_CDC_INT_EPT
#define USBD_CDC_INT_EPT
usb cdc use endpoint define
Definition: cdc_class.h:53
USBD_CDC_BULK_IN_EPT
#define USBD_CDC_BULK_IN_EPT
Definition: cdc_class.h:54
USBD_CDC_OUT_MAXPACKET_SIZE
#define USBD_CDC_OUT_MAXPACKET_SIZE
Definition: cdc_class.h:61
USBD_CDC_IN_MAXPACKET_SIZE
#define USBD_CDC_IN_MAXPACKET_SIZE
usb cdc in and out max packet size define
Definition: cdc_class.h:60
CDC_BCD_NUM
#define CDC_BCD_NUM
usb bcd number define
Definition: cdc_desc.h:52
USBD_CDC_DESC_MANUFACTURER_STRING
#define USBD_CDC_DESC_MANUFACTURER_STRING
usb string define(vendor, product configuration, interface)
Definition: cdc_desc.h:70
USBD_CDC_DESC_CONFIGURATION_STRING
#define USBD_CDC_DESC_CONFIGURATION_STRING
Definition: cdc_desc.h:72
USBD_CDC_SIZ_STRING_LANGID
#define USBD_CDC_SIZ_STRING_LANGID
Definition: cdc_desc.h:64
USBD_CDC_PRODUCT_ID
#define USBD_CDC_PRODUCT_ID
Definition: cdc_desc.h:58
USBD_CDC_DESC_PRODUCT_STRING
#define USBD_CDC_DESC_PRODUCT_STRING
Definition: cdc_desc.h:71
USBD_CDC_VENDOR_ID
#define USBD_CDC_VENDOR_ID
usb vendor id and product id define
Definition: cdc_desc.h:57
CDC_HID_BINTERVAL_TIME
#define CDC_HID_BINTERVAL_TIME
usb endpoint interval define
Definition: cdc_desc.h:78
USBD_CDC_CONFIG_DESC_SIZE
#define USBD_CDC_CONFIG_DESC_SIZE
usb descriptor size define
Definition: cdc_desc.h:63
USBD_CDC_SIZ_STRING_SERIAL
#define USBD_CDC_SIZ_STRING_SERIAL
Definition: cdc_desc.h:65
USBD_CDC_DESC_INTERFACE_STRING
#define USBD_CDC_DESC_INTERFACE_STRING
Definition: cdc_desc.h:73
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: cdc_desc.c:243
device_descriptor
static usbd_desc_t device_descriptor
Definition: cdc_desc.c:222
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: cdc_desc.c:351
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: cdc_desc.c:236
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: cdc_desc.c:331
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: cdc_desc.c:382
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: cdc_desc.c:341
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: cdc_desc.c:417
g_usbd_desc_buffer
static uint8_t g_usbd_desc_buffer[256]
Definition: cdc_desc.c:59
vp_desc
static usbd_desc_t vp_desc
Definition: cdc_desc.c:249
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: cdc_desc.c:361
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL
usb device standard descriptor
Definition: cdc_desc.c:84
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: cdc_desc.c:394
cdc_desc_handler
usbd_desc_handler cdc_desc_handler
device descriptor handler structure
Definition: cdc_desc.c:64
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: cdc_desc.c:429
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: cdc_desc.c:257
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: cdc_desc.c:371
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: cdc_desc.c:309
config_descriptor
static usbd_desc_t config_descriptor
Definition: cdc_desc.c:229
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: cdc_desc.c:406
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: cdc_desc.c:283
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:153
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:93
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:96
USBD_CDC_SUBTYPE_CMF
#define USBD_CDC_SUBTYPE_CMF
Definition: usb_std.h:199
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_EPT_DESC_BULK
#define USB_EPT_DESC_BULK
Definition: usb_std.h:177
USBD_CDC_SUBTYPE_HEADER
#define USBD_CDC_SUBTYPE_HEADER
usb cdc class sub-type define
Definition: usb_std.h:198
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:152
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:151
USBD_CDC_CS_INTERFACE
#define USBD_CDC_CS_INTERFACE
usb cdc class descriptor define
Definition: usb_std.h:192
USB_EPT_DESC_INTERRUPT
#define USB_EPT_DESC_INTERRUPT
Definition: usb_std.h:178
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92
USB_CLASS_CODE_CDCDATA
#define USB_CLASS_CODE_CDCDATA
Definition: usb_std.h:167
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:94
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:95
USB_CLASS_CODE_CDC
#define USB_CLASS_CODE_CDC
Definition: usb_std.h:162
USBD_CDC_SUBTYPE_UFD
#define USBD_CDC_SUBTYPE_UFD
Definition: usb_std.h:201
USBD_CDC_SUBTYPE_ACM
#define USBD_CDC_SUBTYPE_ACM
Definition: usb_std.h:200
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h


AT32F435/437 Firmwary Library: cdc_desc.h Source File

  • middlewares
  • usbd_class
  • cdc
cdc_desc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __CDC_DESC_H
29#define __CDC_DESC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "cdc_class.h"
36#include "usbd_core.h"
37
52#define CDC_BCD_NUM 0x0110
53
57#define USBD_CDC_VENDOR_ID 0x2E3C
58#define USBD_CDC_PRODUCT_ID 0x5740
59
63#define USBD_CDC_CONFIG_DESC_SIZE 67
64#define USBD_CDC_SIZ_STRING_LANGID 4
65#define USBD_CDC_SIZ_STRING_SERIAL 0x1A
66
70#define USBD_CDC_DESC_MANUFACTURER_STRING "Artery"
71#define USBD_CDC_DESC_PRODUCT_STRING "AT32 Virtual Com Port "
72#define USBD_CDC_DESC_CONFIGURATION_STRING "Virtual ComPort Config"
73#define USBD_CDC_DESC_INTERFACE_STRING "Virtual ComPort Interface"
74
78#define CDC_HID_BINTERVAL_TIME 0xFF
79
83#define MCU_ID1 (0x1FFFF7E8)
84#define MCU_ID2 (0x1FFFF7EC)
85#define MCU_ID3 (0x1FFFF7F0)
90extern usbd_desc_handler cdc_desc_handler;
91
92
100#ifdef __cplusplus
101}
102#endif
103
104#endif
cdc_class.h
usb cdc class file
cdc_desc_handler
usbd_desc_handler cdc_desc_handler
device descriptor handler structure
Definition: cdc_desc.c:64
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: cdc_keyboard_class.c Source File

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
cdc_keyboard_class.c
Go to the documentation of this file.
1
26#include "usbd_core.h"
27#include "cdc_keyboard_class.h"
28#include "cdc_keyboard_desc.h"
29
43static usb_sts_type class_init_handler(void *udev);
44static usb_sts_type class_clear_handler(void *udev);
45static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
46static usb_sts_type class_ept0_tx_handler(void *udev);
47static usb_sts_type class_ept0_rx_handler(void *udev);
48static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
49static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
50static usb_sts_type class_sof_handler(void *udev);
51static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
52static usb_sts_type cdc_class_setup_handler(void *udev, usb_setup_type *setup);
53static usb_sts_type keyboard_class_setup_handler(void *udev, usb_setup_type *setup);
54
55static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len);
56
57 vcp_keyboard_type vcp_keyboard_struct;
58
59#define SHIFT 0x80
60const static unsigned char _asciimap[128] =
61{
62 0x00,// NUL
63 0x00,// SOH
64 0x00,// STX
65 0x00,// ETX
66 0x00,// EOT
67 0x00,// ENQ
68 0x00,// ACK
69 0x00,// BEL
70 0x2A,// BS Backspace
71 0x2B,// TAB Tab
72 0x28,// LF Enter
73 0x00,// VT
74 0x00,// FF
75 0x00,// CR
76 0x00,// SO
77 0x00,// SI
78 0x00,// DEL
79 0x00,// DC1
80 0x00,// DC2
81 0x00,// DC3
82 0x00,// DC4
83 0x00,// NAK
84 0x00,// SYN
85 0x00,// ETB
86 0x00,// CAN
87 0x00,// EM
88 0x00,// SUB
89 0x00,// ESC
90 0x00,// FS
91 0x00,// GS
92 0x00,// RS
93 0x00,// US
94
95 0x2C,// ' '
96 0x1E|SHIFT,// !
97 0x34|SHIFT,// "
98 0x20|SHIFT,// #
99 0x21|SHIFT,// $
100 0x22|SHIFT,// %
101 0x24|SHIFT,// &
102 0x34, // '
103 0x26|SHIFT,// (
104 0x27|SHIFT,// )
105 0x25|SHIFT,// *
106 0x2E|SHIFT,// +
107 0x36,// ,
108 0x2D,// -
109 0x37,// .
110 0x38,// /
111 0x27,// 0
112 0x1E,// 1
113 0x1F,// 2
114 0x20,// 3
115 0x21,// 4
116 0x22,// 5
117 0x23,// 6
118 0x24,// 7
119 0x25,// 8
120 0x26,// 9
121 0x33|SHIFT,// :
122 0x33, // ;
123 0x36|SHIFT,// <
124 0x2E, // =
125 0x37|SHIFT,// >
126 0x38|SHIFT,// ?
127 0x1F|SHIFT,// @
128 0x04|SHIFT,// A
129 0x05|SHIFT,// B
130 0x06|SHIFT,// C
131 0x07|SHIFT,// D
132 0x08|SHIFT,// E
133 0x09|SHIFT,// F
134 0x0A|SHIFT,// G
135 0x0B|SHIFT,// H
136 0x0C|SHIFT,// I
137 0x0D|SHIFT,// J
138 0x0E|SHIFT,// K
139 0x0F|SHIFT,// L
140 0x10|SHIFT,// M
141 0x11|SHIFT,// N
142 0x12|SHIFT,// O
143 0x13|SHIFT,// P
144 0x14|SHIFT,// Q
145 0x15|SHIFT,// R
146 0x16|SHIFT,// S
147 0x17|SHIFT,// T
148 0x18|SHIFT,// U
149 0x19|SHIFT,// V
150 0x1A|SHIFT,// W
151 0x1B|SHIFT,// X
152 0x1C|SHIFT,// Y
153 0x1D|SHIFT,// Z
154 0x2F, // [
155 0x31, // bslash
156 0x30, // ]
157 0x23|SHIFT,// ^
158 0x2D|SHIFT,// _
159 0x35, // `
160 0x04, // a
161 0x05, // b
162 0x06, // c
163 0x07, // d
164 0x08, // e
165 0x09, // f
166 0x0A, // g
167 0x0B, // h
168 0x0C, // i
169 0x0D, // j
170 0x0E, // k
171 0x0F, // l
172 0x10, // m
173 0x11, // n
174 0x12, // o
175 0x13, // p
176 0x14, // q
177 0x15, // r
178 0x16, // s
179 0x17, // t
180 0x18, // u
181 0x19, // v
182 0x1A, // w
183 0x1B, // x
184 0x1C, // y
185 0x1D, // z
186 0x2f|SHIFT,//
187 0x31|SHIFT,// |
188 0x30|SHIFT,// }
189 0x35|SHIFT,// ~
190 0 // DEL
191};
192
193 linecoding_type linecoding_vcpkybrd =
194{
195 115200,
196 0x00,
197 0x00,
198 0x08
199};
200
201/* static variable */
202
203
204/* usb device class handler */
205usbd_class_handler cdc_keyboard_class_handler =
206{
207 class_init_handler,
208 class_clear_handler,
209 class_setup_handler,
210 class_ept0_tx_handler,
211 class_ept0_rx_handler,
212 class_in_handler,
213 class_out_handler,
214 class_sof_handler,
215 class_event_handler,
216 &vcp_keyboard_struct
217};
218
224static usb_sts_type class_init_handler(void *udev)
225{
226 usb_sts_type status = USB_OK;
227 usbd_core_type *pudev = (usbd_core_type *)udev;
228 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
229
230 /* open in endpoint */
231 usbd_ept_open(pudev, USBD_VCPKYBRD_CDC_INT_EPT, EPT_INT_TYPE, USBD_VCPKYBRD_CMD_MAXPACKET_SIZE);
232
233 /* open in endpoint */
234 usbd_ept_open(pudev, USBD_VCPKYBRD_CDC_BULK_IN_EPT, EPT_BULK_TYPE, USBD_VCPKYBRD_IN_MAXPACKET_SIZE);
235
236 /* open out endpoint */
237 usbd_ept_open(pudev, USBD_VCPKYBRD_CDC_BULK_OUT_EPT, EPT_BULK_TYPE, USBD_VCPKYBRD_OUT_MAXPACKET_SIZE);
238
239 /* open hid in endpoint */
240 usbd_ept_open(pudev, USBD_VCPKYBRD_HID_IN_EPT, EPT_INT_TYPE, USBD_VCPKYBRD_IN_MAXPACKET_SIZE);
241
242 /* set out endpoint to receive status */
243 usbd_ept_recv(pudev, USBD_VCPKYBRD_CDC_BULK_OUT_EPT, vcpkybrd->g_rx_buff, USBD_VCPKYBRD_OUT_MAXPACKET_SIZE);
244
245 vcpkybrd->g_tx_completed = 1;
246 vcpkybrd->g_keyboard_tx_completed = 1;
247
248 vcpkybrd->linecoding.bitrate = linecoding_vcpkybrd.bitrate;
249 vcpkybrd->linecoding.data = linecoding_vcpkybrd.data;
250 vcpkybrd->linecoding.format = linecoding_vcpkybrd.format;
251 vcpkybrd->linecoding.parity = linecoding_vcpkybrd.parity;
252 return status;
253}
254
260static usb_sts_type class_clear_handler(void *udev)
261{
262 usb_sts_type status = USB_OK;
263 usbd_core_type *pudev = (usbd_core_type *)udev;
264
265 /* close in endpoint */
266 usbd_ept_close(pudev, USBD_VCPKYBRD_CDC_INT_EPT);
267
268 /* close in endpoint */
269 usbd_ept_close(pudev, USBD_VCPKYBRD_CDC_BULK_IN_EPT);
270
271 /* close out endpoint */
272 usbd_ept_close(pudev, USBD_VCPKYBRD_CDC_BULK_OUT_EPT);
273
274 /* close in endpoint */
275 usbd_ept_close(pudev, USBD_VCPKYBRD_HID_IN_EPT);
276
277 return status;
278}
279
286static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
287{
288 usb_sts_type status = USB_OK;
289 usbd_core_type *pudev = (usbd_core_type *)udev;
290 switch(setup->bmRequestType & USB_REQ_RECIPIENT_MASK)
291 {
292 case USB_REQ_RECIPIENT_INTERFACE:
293 if(setup->wIndex == VCPKYBRD_KEYBOARD_INTERFACE)
294 {
295 keyboard_class_setup_handler(udev, setup);
296 }
297 else
298 {
299 cdc_class_setup_handler(pudev, setup);
300 }
301 break;
302 case USB_REQ_RECIPIENT_ENDPOINT:
303 break;
304
305 }
306 return status;
307}
308
315static usb_sts_type cdc_class_setup_handler(void *udev, usb_setup_type *setup)
316{
317 usb_sts_type status = USB_OK;
318 usbd_core_type *pudev = (usbd_core_type *)udev;
319 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
320
321 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
322 {
323 /* class request */
324 case USB_REQ_TYPE_CLASS:
325 if(setup->wLength)
326 {
327 if(setup->bmRequestType & USB_REQ_DIR_DTH)
328 {
329 usb_vcp_cmd_process(udev, setup->bRequest, vcpkybrd->g_cmd, setup->wLength);
330 usbd_ctrl_send(pudev, vcpkybrd->g_cmd, setup->wLength);
331 }
332 else
333 {
334 vcpkybrd->g_req = setup->bRequest;
335 vcpkybrd->g_len = setup->wLength;
336 usbd_ctrl_recv(pudev, vcpkybrd->g_cmd, vcpkybrd->g_len);
337
338 }
339 }
340 break;
341 /* standard request */
342 case USB_REQ_TYPE_STANDARD:
343 switch(setup->bRequest)
344 {
345 case USB_STD_REQ_GET_DESCRIPTOR:
346 usbd_ctrl_unsupport(pudev);
347 break;
348 case USB_STD_REQ_GET_INTERFACE:
349 usbd_ctrl_send(pudev, (uint8_t *)&vcpkybrd->alt_setting, 1);
350 break;
351 case USB_STD_REQ_SET_INTERFACE:
352 vcpkybrd->alt_setting = setup->wValue;
353 break;
354 default:
355 break;
356 }
357 break;
358 default:
359 usbd_ctrl_unsupport(pudev);
360 break;
361 }
362 return status;
363}
364
371static usb_sts_type keyboard_class_setup_handler(void *udev, usb_setup_type *setup)
372{
373 usb_sts_type status = USB_OK;
374 usbd_core_type *pudev = (usbd_core_type *)udev;
375 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
376 uint16_t len;
377 uint8_t *buf;
378
379 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
380 {
381 /* class request */
382 case USB_REQ_TYPE_CLASS:
383 switch(setup->bRequest)
384 {
385 case HID_REQ_SET_PROTOCOL:
386 vcpkybrd->hid_protocol = (uint8_t)setup->wValue;
387 break;
388 case HID_REQ_GET_PROTOCOL:
389 usbd_ctrl_send(pudev, (uint8_t *)&vcpkybrd->hid_protocol, 1);
390 break;
391 case HID_REQ_SET_IDLE:
392 vcpkybrd->hid_set_idle = (uint8_t)(setup->wValue >> 8);
393 break;
394 case HID_REQ_GET_IDLE:
395 usbd_ctrl_send(pudev, (uint8_t *)&vcpkybrd->hid_set_idle, 1);
396 break;
397 case HID_REQ_SET_REPORT:
398 vcpkybrd->hid_state = HID_REQ_SET_REPORT;
399 usbd_ctrl_recv(pudev, vcpkybrd->hid_set_report, setup->wLength);
400 break;
401 default:
402 usbd_ctrl_unsupport(pudev);
403 break;
404 }
405 break;
406 /* standard request */
407 case USB_REQ_TYPE_STANDARD:
408 switch(setup->bRequest)
409 {
410 case USB_STD_REQ_GET_DESCRIPTOR:
411 if(setup->wValue >> 8 == HID_REPORT_DESC)
412 {
413 len = MIN(USBD_VCPKYBRD_HID_SIZ_REPORT_DESC, setup->wLength);
414 buf = (uint8_t *)g_usbd_vcpkybrd_hid_report;
415 }
416 else if(setup->wValue >> 8 == HID_DESCRIPTOR_TYPE)
417 {
418 len = MIN(9, setup->wLength);
419 buf = (uint8_t *)g_vcpkybrd_hid_usb_desc;
420 }
421 usbd_ctrl_send(pudev, (uint8_t *)buf, len);
422 break;
423 case USB_STD_REQ_GET_INTERFACE:
424 usbd_ctrl_send(pudev, (uint8_t *)&vcpkybrd->alt_setting, 1);
425 break;
426 case USB_STD_REQ_SET_INTERFACE:
427 vcpkybrd->alt_setting = setup->wValue;
428 break;
429 default:
430 break;
431 }
432 break;
433 default:
434 usbd_ctrl_unsupport(pudev);
435 break;
436 }
437 return status;
438}
439
445static usb_sts_type class_ept0_tx_handler(void *udev)
446{
447 usb_sts_type status = USB_OK;
448
449 /* ...user code... */
450
451 return status;
452}
453
459static usb_sts_type class_ept0_rx_handler(void *udev)
460{
461 usb_sts_type status = USB_OK;
462 usbd_core_type *pudev = (usbd_core_type *)udev;
463 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
464 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
465 /* ...user code... */
466 if( vcpkybrd->g_req == SET_LINE_CODING)
467 {
468 /* class process */
469 usb_vcp_cmd_process(udev, vcpkybrd->g_req, vcpkybrd->g_cmd, recv_len);
470 }
471
472 if( vcpkybrd->hid_state == HID_REQ_SET_REPORT)
473 {
474 /* hid buffer process */
475 vcpkybrd->hid_state = 0;
476 }
477 return status;
478}
479
486static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
487{
488 usb_sts_type status = USB_OK;
489 usbd_core_type *pudev = (usbd_core_type *)udev;
490 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
491
492 /* ...user code...
493 trans next packet data
494 */
495 if((ept_num & 0x7F) == (USBD_VCPKYBRD_CDC_BULK_IN_EPT & 0x7F))
496 {
497 vcpkybrd->g_tx_completed = 1;
498 }
499 if((ept_num & 0x7F) == (USBD_VCPKYBRD_HID_IN_EPT & 0x7F))
500 {
501 vcpkybrd->g_keyboard_tx_completed = 1;
502 }
503
504
505 return status;
506}
507
514static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
515{
516 usb_sts_type status = USB_OK;
517 usbd_core_type *pudev = (usbd_core_type *)udev;
518 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
519
520 /* get endpoint receive data length */
521 vcpkybrd->g_rxlen = usbd_get_recv_len(pudev, ept_num);
522
523 /*set recv flag*/
524 vcpkybrd->g_rx_completed = 1;
525
526 return status;
527}
528
534static usb_sts_type class_sof_handler(void *udev)
535{
536 usb_sts_type status = USB_OK;
537
538 /* ...user code... */
539
540 return status;
541}
542
549static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
550{
551 usb_sts_type status = USB_OK;
552 switch(event)
553 {
554 case USBD_RESET_EVENT:
555
556 /* ...user code... */
557
558 break;
559 case USBD_SUSPEND_EVENT:
560
561 /* ...user code... */
562
563 break;
564 case USBD_WAKEUP_EVENT:
565 /* ...user code... */
566
567 break;
568 default:
569 break;
570 }
571 return status;
572}
573
580uint16_t usb_vcpkybrd_vcp_get_rxdata(void *udev, uint8_t *recv_data)
581{
582 uint16_t i_index = 0;
583 usbd_core_type *pudev = (usbd_core_type *)udev;
584 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
585 uint16_t tmp_len = 0;
586 if(vcpkybrd->g_rx_completed == 0)
587 {
588 return 0;
589 }
590 vcpkybrd->g_rx_completed = 0;
591
592 tmp_len = vcpkybrd->g_rxlen;
593 for(i_index = 0; i_index < vcpkybrd->g_rxlen; i_index ++)
594 {
595 recv_data[i_index] = vcpkybrd->g_rx_buff[i_index];
596 }
597
598 usbd_ept_recv(pudev, USBD_VCPKYBRD_CDC_BULK_OUT_EPT, vcpkybrd->g_rx_buff, USBD_VCPKYBRD_OUT_MAXPACKET_SIZE);
599
600 return tmp_len;
601}
602
610 error_status usb_vcpkybrd_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
611{
612 error_status status = SUCCESS;
613 usbd_core_type *pudev = (usbd_core_type *)udev;
614 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
615 if(vcpkybrd->g_tx_completed)
616 {
617 vcpkybrd->g_tx_completed = 0;
618 usbd_ept_send(pudev, USBD_VCPKYBRD_CDC_BULK_IN_EPT, send_data, len);
619 }
620 else
621 {
622 status = ERROR;
623 }
624 return status;
625}
626
627
636static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
637{
638 usbd_core_type *pudev = (usbd_core_type *)udev;
639 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
640 switch(cmd)
641 {
642 case SET_LINE_CODING:
643 vcpkybrd->linecoding.bitrate = (uint32_t)(buff[0] | (buff[1] << 8) | (buff[2] << 16) | (buff[3] <<24));
644 vcpkybrd->linecoding.format = buff[4];
645 vcpkybrd->linecoding.parity = buff[5];
646 vcpkybrd->linecoding.data = buff[6];
647 break;
648
649 case GET_LINE_CODING:
650 buff[0] = (uint8_t)vcpkybrd->linecoding.bitrate;
651 buff[1] = (uint8_t)(vcpkybrd->linecoding.bitrate >> 8);
652 buff[2] = (uint8_t)(vcpkybrd->linecoding.bitrate >> 16);
653 buff[3] = (uint8_t)(vcpkybrd->linecoding.bitrate >> 24);
654 buff[4] = (uint8_t)(vcpkybrd->linecoding.format);
655 buff[5] = (uint8_t)(vcpkybrd->linecoding.parity);
656 buff[6] = (uint8_t)(vcpkybrd->linecoding.data);
657 break;
658
659 default:
660 break;
661 }
662}
663
671 usb_sts_type usb_vcpkybrd_class_send_report(void *udev, uint8_t *report, uint16_t len)
672{
673 usb_sts_type status = USB_OK;
674 usbd_core_type *pudev = (usbd_core_type *)udev;
675
676 if(usbd_connect_state_get(pudev) == USB_CONN_STATE_CONFIGURED)
677 usbd_ept_send(pudev, USBD_VCPKYBRD_HID_IN_EPT, report, len);
678
679 return status;
680}
681
682
689void usb_vcpkybrd_keyboard_send_char(void *udev, uint8_t ascii_code)
690{
691 uint8_t key_data = 0;
692 static uint8_t temp = 0;
693 static uint8_t keyboard_buf[8] = {0, 0, 6, 0, 0, 0, 0, 0};
694
695 if(ascii_code > 128)
696 {
697 ascii_code = 0;
698 }
699 else
700 {
701 ascii_code = _asciimap[ascii_code];
702 if(!ascii_code)
703 {
704 ascii_code = 0;
705 }
706
707 if(ascii_code & SHIFT)
708 {
709 key_data = 0x2;
710 ascii_code &= 0x7F;
711 }
712 }
713
714 if((temp == ascii_code) && (ascii_code != 0))
715 {
716 keyboard_buf[0] = 0;
717 keyboard_buf[2] = 0;
718 usb_vcpkybrd_class_send_report(udev, keyboard_buf, 8);
719 }
720 else
721 {
722 keyboard_buf[0] = key_data;
723 keyboard_buf[2] = ascii_code;
724 usb_vcpkybrd_class_send_report(udev, keyboard_buf, 8);
725 }
726}
727
cdc_keyboard_class.h
usb cdc and keyboard class file
cdc_keyboard_desc.h
usb cdc and keyboard descriptor header file
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
USBD_VCPKYBRD_CMD_MAXPACKET_SIZE
#define USBD_VCPKYBRD_CMD_MAXPACKET_SIZE
Definition: cdc_keyboard_class.h:63
USBD_VCPKYBRD_HID_IN_EPT
#define USBD_VCPKYBRD_HID_IN_EPT
Definition: cdc_keyboard_class.h:56
USBD_VCPKYBRD_IN_MAXPACKET_SIZE
#define USBD_VCPKYBRD_IN_MAXPACKET_SIZE
usb in and out max packet size define
Definition: cdc_keyboard_class.h:61
USBD_VCPKYBRD_OUT_MAXPACKET_SIZE
#define USBD_VCPKYBRD_OUT_MAXPACKET_SIZE
Definition: cdc_keyboard_class.h:62
USBD_VCPKYBRD_CDC_INT_EPT
#define USBD_VCPKYBRD_CDC_INT_EPT
usb use endpoint define
Definition: cdc_keyboard_class.h:53
USBD_VCPKYBRD_CDC_BULK_IN_EPT
#define USBD_VCPKYBRD_CDC_BULK_IN_EPT
Definition: cdc_keyboard_class.h:54
USBD_VCPKYBRD_CDC_BULK_OUT_EPT
#define USBD_VCPKYBRD_CDC_BULK_OUT_EPT
Definition: cdc_keyboard_class.h:55
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: cdc_keyboard_class.c:534
usb_vcpkybrd_vcp_send_data
error_status usb_vcpkybrd_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_keyboard_class.c:610
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: cdc_keyboard_class.c:486
usb_vcpkybrd_keyboard_send_char
void usb_vcpkybrd_keyboard_send_char(void *udev, uint8_t ascii_code)
usb keyoard send char
Definition: cdc_keyboard_class.c:689
usb_vcpkybrd_class_send_report
usb_sts_type usb_vcpkybrd_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: cdc_keyboard_class.c:671
_asciimap
static const unsigned char _asciimap[128]
Definition: cdc_keyboard_class.c:60
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: cdc_keyboard_class.c:260
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_keyboard_class.c:286
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: cdc_keyboard_class.c:445
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: cdc_keyboard_class.c:459
cdc_keyboard_class_handler
usbd_class_handler cdc_keyboard_class_handler
Definition: cdc_keyboard_class.c:205
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: cdc_keyboard_class.c:549
usb_vcp_cmd_process
static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device class request function
Definition: cdc_keyboard_class.c:636
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: cdc_keyboard_class.c:224
cdc_class_setup_handler
static usb_sts_type cdc_class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_keyboard_class.c:315
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: cdc_keyboard_class.c:514
SHIFT
#define SHIFT
Definition: cdc_keyboard_class.c:59
usb_vcpkybrd_vcp_get_rxdata
uint16_t usb_vcpkybrd_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_keyboard_class.c:580
vcp_keyboard_struct
vcp_keyboard_type vcp_keyboard_struct
Definition: cdc_keyboard_class.c:57
keyboard_class_setup_handler
static usb_sts_type keyboard_class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_keyboard_class.c:371
linecoding_vcpkybrd
linecoding_type linecoding_vcpkybrd
Definition: cdc_keyboard_class.c:193
VCPKYBRD_KEYBOARD_INTERFACE
#define VCPKYBRD_KEYBOARD_INTERFACE
Definition: cdc_keyboard_desc.h:88
USBD_VCPKYBRD_HID_SIZ_REPORT_DESC
#define USBD_VCPKYBRD_HID_SIZ_REPORT_DESC
Definition: cdc_keyboard_desc.h:66
g_usbd_vcpkybrd_hid_report
uint8_t g_usbd_vcpkybrd_hid_report[63]
usb hid keyboard report descriptor
Definition: cdc_keyboard_desc.c:263
g_vcpkybrd_hid_usb_desc
uint8_t g_vcpkybrd_hid_usb_desc[9]
usb hid descriptor
Definition: cdc_keyboard_desc.c:244
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f435_437_usb.h:349
EPT_BULK_TYPE
@ EPT_BULK_TYPE
Definition: at32f435_437_usb.h:348
HID_DESCRIPTOR_TYPE
#define HID_DESCRIPTOR_TYPE
Definition: usb_std.h:236
HID_REQ_GET_PROTOCOL
#define HID_REQ_GET_PROTOCOL
Definition: usb_std.h:231
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:254
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:63
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:81
HID_REQ_SET_PROTOCOL
#define HID_REQ_SET_PROTOCOL
usb hid class request code define
Definition: usb_std.h:230
HID_REPORT_DESC
#define HID_REPORT_DESC
Definition: usb_std.h:237
HID_REQ_SET_IDLE
#define HID_REQ_SET_IDLE
Definition: usb_std.h:232
GET_LINE_CODING
#define GET_LINE_CODING
Definition: usb_std.h:207
SET_LINE_CODING
#define SET_LINE_CODING
usb cdc class request code define
Definition: usb_std.h:206
HID_REQ_GET_IDLE
#define HID_REQ_GET_IDLE
Definition: usb_std.h:233
USB_REQ_DIR_DTH
#define USB_REQ_DIR_DTH
Definition: usb_std.h:72
HID_REQ_SET_REPORT
#define HID_REQ_SET_REPORT
Definition: usb_std.h:234
USB_REQ_RECIPIENT_MASK
#define USB_REQ_RECIPIENT_MASK
Definition: usb_std.h:58
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:86
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:66
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:85
USB_REQ_RECIPIENT_ENDPOINT
#define USB_REQ_RECIPIENT_ENDPOINT
Definition: usb_std.h:56
USB_REQ_RECIPIENT_INTERFACE
#define USB_REQ_RECIPIENT_INTERFACE
Definition: usb_std.h:55
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:64
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:131
USB_OK
@ USB_OK
Definition: usb_std.h:268
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:597
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:346
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint receive data
Definition: usbd_core.c:534
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:314
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:177
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint send data
Definition: usbd_core.c:434
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
get endpoint receive data length
Definition: usbd_core.c:300
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint recv data
Definition: usbd_core.c:196
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:287
linecoding_type
usb cdc class set line coding struct
Definition: usb_std.h:213
linecoding_type::bitrate
uint32_t bitrate
Definition: usb_std.h:214
linecoding_type::data
uint8_t data
Definition: usb_std.h:217
linecoding_type::parity
uint8_t parity
Definition: usb_std.h:216
linecoding_type::format
uint8_t format
Definition: usb_std.h:215
usb_setup_type
format of usb setup data
Definition: usb_std.h:280
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:283
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:286
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:281
usb_setup_type::wIndex
uint16_t wIndex
Definition: usb_std.h:284
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:282
vcp_keyboard_type
Definition: cdc_keyboard_class.h:75
vcp_keyboard_type::g_cmd
uint8_t g_cmd[0x08]
Definition: cdc_keyboard_class.h:82
vcp_keyboard_type::g_len
uint16_t g_len
Definition: cdc_keyboard_class.h:85
vcp_keyboard_type::hid_state
uint8_t hid_state
Definition: cdc_keyboard_class.h:84
vcp_keyboard_type::hid_set_idle
uint32_t hid_set_idle
Definition: cdc_keyboard_class.h:78
vcp_keyboard_type::alt_setting
uint32_t alt_setting
Definition: cdc_keyboard_class.h:76
vcp_keyboard_type::g_keyboard_tx_completed
__IO uint8_t g_keyboard_tx_completed
Definition: cdc_keyboard_class.h:88
vcp_keyboard_type::g_rxlen
uint16_t g_rxlen
Definition: cdc_keyboard_class.h:85
vcp_keyboard_type::g_tx_completed
__IO uint8_t g_tx_completed
Definition: cdc_keyboard_class.h:86
vcp_keyboard_type::g_rx_buff
uint8_t g_rx_buff[0x40]
Definition: cdc_keyboard_class.h:81
vcp_keyboard_type::g_req
uint8_t g_req
Definition: cdc_keyboard_class.h:83
vcp_keyboard_type::hid_set_report
uint8_t hid_set_report[64]
Definition: cdc_keyboard_class.h:80
vcp_keyboard_type::g_rx_completed
__IO uint8_t g_rx_completed
Definition: cdc_keyboard_class.h:87
vcp_keyboard_type::hid_protocol
uint32_t hid_protocol
Definition: cdc_keyboard_class.h:77
vcp_keyboard_type::linecoding
linecoding_type linecoding
Definition: cdc_keyboard_class.h:90
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: cdc_keyboard_class.h Source File

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
cdc_keyboard_class.h
Go to the documentation of this file.
1
27 /* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __CDC_KEYBOARD_CLASS_H
29#define __CDC_KEYBOARD_CLASS_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "usb_std.h"
36#include "usbd_core.h"
37
53#define USBD_VCPKYBRD_CDC_INT_EPT 0x82
54#define USBD_VCPKYBRD_CDC_BULK_IN_EPT 0x81
55#define USBD_VCPKYBRD_CDC_BULK_OUT_EPT 0x01
56#define USBD_VCPKYBRD_HID_IN_EPT 0x83
57
61#define USBD_VCPKYBRD_IN_MAXPACKET_SIZE 0x40
62#define USBD_VCPKYBRD_OUT_MAXPACKET_SIZE 0x40
63#define USBD_VCPKYBRD_CMD_MAXPACKET_SIZE 0x08
64
65
74typedef struct
75{
76 uint32_t alt_setting;
77 uint32_t hid_protocol;
78 uint32_t hid_set_idle;
79
80 uint8_t hid_set_report[64];
81 uint8_t g_rx_buff[USBD_VCPKYBRD_OUT_MAXPACKET_SIZE];
82 uint8_t g_cmd[USBD_VCPKYBRD_CMD_MAXPACKET_SIZE];
83 uint8_t g_req;
84 uint8_t hid_state;
85 uint16_t g_len, g_rxlen;
86 __IO uint8_t g_tx_completed;
87 __IO uint8_t g_rx_completed;
88 __IO uint8_t g_keyboard_tx_completed;
89
90 linecoding_type linecoding;
91}vcp_keyboard_type;
92
100extern usbd_class_handler cdc_keyboard_class_handler;
101uint16_t usb_vcpkybrd_vcp_get_rxdata(void *udev, uint8_t *recv_data);
102 error_status usb_vcpkybrd_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len);
103 usb_sts_type usb_vcpkybrd_class_send_report(void *udev, uint8_t *report, uint16_t len);
104void usb_vcpkybrd_keyboard_send_char(void *udev, uint8_t ascii_code);
105
117#ifdef __cplusplus
118}
119#endif
120
121#endif
122
123
124
125
error_status
error_status
Definition: at32f435_437.h:380
usb_vcpkybrd_vcp_send_data
error_status usb_vcpkybrd_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_keyboard_class.c:610
usb_vcpkybrd_keyboard_send_char
void usb_vcpkybrd_keyboard_send_char(void *udev, uint8_t ascii_code)
usb keyoard send char
Definition: cdc_keyboard_class.c:689
usb_vcpkybrd_class_send_report
usb_sts_type usb_vcpkybrd_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: cdc_keyboard_class.c:671
cdc_keyboard_class_handler
usbd_class_handler cdc_keyboard_class_handler
Definition: cdc_keyboard_class.c:205
usb_vcpkybrd_vcp_get_rxdata
uint16_t usb_vcpkybrd_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_keyboard_class.c:580
USBD_VCPKYBRD_CMD_MAXPACKET_SIZE
#define USBD_VCPKYBRD_CMD_MAXPACKET_SIZE
Definition: cdc_keyboard_class.h:63
USBD_VCPKYBRD_OUT_MAXPACKET_SIZE
#define USBD_VCPKYBRD_OUT_MAXPACKET_SIZE
Definition: cdc_keyboard_class.h:62
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
linecoding_type
usb cdc class set line coding struct
Definition: usb_std.h:213
vcp_keyboard_type
Definition: cdc_keyboard_class.h:75
vcp_keyboard_type::g_len
uint16_t g_len
Definition: cdc_keyboard_class.h:85
vcp_keyboard_type::hid_state
uint8_t hid_state
Definition: cdc_keyboard_class.h:84
vcp_keyboard_type::hid_set_idle
uint32_t hid_set_idle
Definition: cdc_keyboard_class.h:78
vcp_keyboard_type::alt_setting
uint32_t alt_setting
Definition: cdc_keyboard_class.h:76
vcp_keyboard_type::g_keyboard_tx_completed
__IO uint8_t g_keyboard_tx_completed
Definition: cdc_keyboard_class.h:88
vcp_keyboard_type::g_tx_completed
__IO uint8_t g_tx_completed
Definition: cdc_keyboard_class.h:86
vcp_keyboard_type::g_req
uint8_t g_req
Definition: cdc_keyboard_class.h:83
vcp_keyboard_type::g_rx_completed
__IO uint8_t g_rx_completed
Definition: cdc_keyboard_class.h:87
vcp_keyboard_type::hid_protocol
uint32_t hid_protocol
Definition: cdc_keyboard_class.h:77
vcp_keyboard_type::linecoding
linecoding_type linecoding
Definition: cdc_keyboard_class.h:90
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: cdc_keyboard_desc.c Source File

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
cdc_keyboard_desc.c
Go to the documentation of this file.
1
26#include "usb_std.h"
27#include "usbd_sdr.h"
28#include "usbd_core.h"
29#include "cdc_keyboard_desc.h"
43static usbd_desc_t *get_device_descriptor(void);
44static usbd_desc_t *get_device_qualifier(void);
45static usbd_desc_t *get_device_configuration(void);
46static usbd_desc_t *get_device_other_speed(void);
47static usbd_desc_t *get_device_lang_id(void);
48static usbd_desc_t *get_device_manufacturer_string(void);
49static usbd_desc_t *get_device_product_string(void);
50static usbd_desc_t *get_device_serial_string(void);
51static usbd_desc_t *get_device_interface_string(void);
52static usbd_desc_t *get_device_config_string(void);
53
54static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
55static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
56static void get_serial_num(void);
57static uint8_t g_usbd_desc_buffer[256];
58
62usbd_desc_handler cdc_keyboard_desc_handler =
63{
64 get_device_descriptor,
65 get_device_qualifier,
66 get_device_configuration,
67 get_device_other_speed,
68 get_device_lang_id,
69 get_device_manufacturer_string,
70 get_device_product_string,
71 get_device_serial_string,
72 get_device_interface_string,
73 get_device_config_string,
74};
75
79#if defined ( __ICCARM__ ) /* iar compiler */
80 #pragma data_alignment=4
81#endif
82ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
83{
84 USB_DEVICE_DESC_LEN, /* bLength */
85 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
86 0x00, /* bcdUSB */
87 0x02,
88 0xEF, /* bDeviceClass */
89 0x02, /* bDeviceSubClass */
90 0x01, /* bDeviceProtocol */
91 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
92 LBYTE(USBD_VCPKYBRD_VENDOR_ID), /* idVendor */
93 HBYTE(USBD_VCPKYBRD_VENDOR_ID), /* idVendor */
94 LBYTE(USBD_VCPKYBRD_PRODUCT_ID), /* idProduct */
95 HBYTE(USBD_VCPKYBRD_PRODUCT_ID), /* idProduct */
96 0x00, /* bcdDevice rel. 2.00 */
97 0x02,
98 USB_MFC_STRING, /* Index of manufacturer string */
99 USB_PRODUCT_STRING, /* Index of product string */
100 USB_SERIAL_STRING, /* Index of serial number string */
101 1 /* bNumConfigurations */
102};
103
107#if defined ( __ICCARM__ ) /* iar compiler */
108 #pragma data_alignment=4
109#endif
110ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_VCPKYBRD_CONFIG_DESC_SIZE] ALIGNED_TAIL =
111{
112 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
113 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
114 LBYTE(USBD_VCPKYBRD_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
115 HBYTE(USBD_VCPKYBRD_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
116 0x03, /* bNumInterfaces: 2 interface */
117 0x01, /* bConfigurationValue: configuration value */
118 0x00, /* iConfiguration: index of string descriptor describing
119 the configuration */
120 0xC0, /* bmAttributes: self powered */
121 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
122
123 0x08, /* bLength */
124 0x0B, /* bDescriptorType */
125 0x00, /* bFirstInterface */
126 0x02, /* bInterfaceCount */
127 0x02, /* bFunctionClass */
128 0x02, /* bFunctionSubClass */
129 0x01, /* bFunctionProtocol */
130 0x00, /* iFunction (Index of string descriptor describing this function) */
131
132 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
133 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
134 VCPKYBRD_CDC_INTERFACE, /* bInterfaceNumber: number of interface */
135 0x00, /* bAlternateSetting: alternate set */
136 0x01, /* bNumEndpoints: number of endpoints */
137 USB_CLASS_CODE_CDC, /* bInterfaceClass: CDC class code */
138 0x02, /* bInterfaceSubClass: subclass code, Abstract Control Model*/
139 0x01, /* bInterfaceProtocol: protocol code, AT Command */
140 0x00, /* iInterface: index of string descriptor */
141
142 0x05, /* bFunctionLength: size of this descriptor in bytes */
143 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
144 USBD_CDC_SUBTYPE_HEADER, /* bDescriptorSubtype: Header function Descriptor 0x00*/
145 LBYTE(VCPKYBRD_BCD_NUM),
146 HBYTE(VCPKYBRD_BCD_NUM), /* bcdCDC: USB class definitions for communications */
147
148 0x05, /* bFunctionLength: size of this descriptor in bytes */
149 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
150 USBD_CDC_SUBTYPE_CMF, /* bDescriptorSubtype: Call Management function descriptor subtype 0x01 */
151 0x00, /* bmCapabilities: 0x00*/
152 0x01, /* bDataInterface: interface number of data class interface optionally used for call management */
153
154 0x04, /* bFunctionLength: size of this descriptor in bytes */
155 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
156 USBD_CDC_SUBTYPE_ACM, /* bDescriptorSubtype: Abstract Control Management functional descriptor subtype 0x02 */
157 0x02, /* bmCapabilities: Support Set_Line_Coding and Get_Line_Coding 0x02 */
158
159 0x05, /* bFunctionLength: size of this descriptor in bytes */
160 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
161 USBD_CDC_SUBTYPE_UFD, /* bDescriptorSubtype: Union Function Descriptor subtype 0x06 */
162 0x00, /* bControlInterface: The interface number of the communications or data class interface 0x00 */
163 0x01, /* bSubordinateInterface0: interface number of first subordinate interface in the union */
164
165 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
166 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
167 USBD_VCPKYBRD_CDC_INT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
168 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
169 LBYTE(USBD_VCPKYBRD_CMD_MAXPACKET_SIZE),
170 HBYTE(USBD_VCPKYBRD_CMD_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
171 VCPKYBRD_HID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
172
173
174 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
175 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
176 VCPKYBRD_CDC_DATA_INTERFACE, /* bInterfaceNumber: number of interface */
177 0x00, /* bAlternateSetting: alternate set */
178 0x02, /* bNumEndpoints: number of endpoints */
179 USB_CLASS_CODE_CDCDATA, /* bInterfaceClass: CDC-data class code */
180 0x00, /* bInterfaceSubClass: Data interface subclass code 0x00*/
181 0x00, /* bInterfaceProtocol: data class protocol code 0x00 */
182 0x00, /* iInterface: index of string descriptor */
183
184 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
185 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
186 USBD_VCPKYBRD_CDC_BULK_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
187 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
188 LBYTE(USBD_VCPKYBRD_IN_MAXPACKET_SIZE),
189 HBYTE(USBD_VCPKYBRD_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
190 0x00, /* bInterval: interval for polling endpoint for data transfers */
191
192 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
193 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
194 USBD_VCPKYBRD_CDC_BULK_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
195 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
196 LBYTE(USBD_VCPKYBRD_OUT_MAXPACKET_SIZE),
197 HBYTE(USBD_VCPKYBRD_OUT_MAXPACKET_SIZE),/* wMaxPacketSize: maximum packe size this endpoint */
198 0x00, /* bInterval: interval for polling endpoint for data transfers */
199
200 0x08, /* bLength */
201 0x0B, /* bDescriptorType */
202 0x02, /* bFirstInterface */
203 0x01, /* bInterfaceCount */
204 0x03, /* bFunctionClass */
205 0x00, /* bFunctionSubClass */
206 0x01, /* bFunctionProtocol */
207 0x00, /* iFunction (Index of string descriptor describing this function) */
208
209 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
210 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
211 VCPKYBRD_KEYBOARD_INTERFACE, /* bInterfaceNumber: number of interface */
212 0x00, /* bAlternateSetting: alternate set */
213 0x01, /* bNumEndpoints: number of endpoints */
214 USB_CLASS_CODE_HID, /* bInterfaceClass: class code hid */
215 0x01, /* bInterfaceSubClass: subclass code */
216 0x01, /* bInterfaceProtocol: protocol code */
217 0x00, /* iInterface: index of string descriptor */
218
219 0x09, /* bLength: size of HID descriptor in bytes */
220 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
221 LBYTE(VCPKYBRD_BCD_NUM),
222 HBYTE(VCPKYBRD_BCD_NUM), /* bcdHID: HID class specification release number */
223 0x00, /* bCountryCode: hardware target conutry */
224 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
225 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
226 LBYTE(sizeof(g_usbd_vcpkybrd_hid_report)),
227 HBYTE(sizeof(g_usbd_vcpkybrd_hid_report)), /* wDescriptorLength: total length of reprot descriptor */
228
229 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
230 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
231 USBD_VCPKYBRD_HID_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
232 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
233 LBYTE(USBD_VCPKYBRD_IN_MAXPACKET_SIZE),
234 HBYTE(USBD_VCPKYBRD_IN_MAXPACKET_SIZE),/* wMaxPacketSize: maximum packe size this endpoint */
235 VCPKYBRD_HID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
236};
237
241#if defined ( __ICCARM__ ) /* iar compiler */
242 #pragma data_alignment=4
243#endif
244ALIGNED_HEAD uint8_t g_vcpkybrd_hid_usb_desc[9] ALIGNED_TAIL =
245{
246 0x09, /* bLength: size of HID descriptor in bytes */
247 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
248 LBYTE(VCPKYBRD_BCD_NUM),
249 HBYTE(VCPKYBRD_BCD_NUM), /* bcdHID: HID class specification release number */
250 0x00, /* bCountryCode: hardware target conutry */
251 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
252 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
253 LBYTE(sizeof(g_usbd_vcpkybrd_hid_report)),
254 HBYTE(sizeof(g_usbd_vcpkybrd_hid_report)), /* wDescriptorLength: total length of reprot descriptor */
255};
256
260#if defined ( __ICCARM__ ) /* iar compiler */
261 #pragma data_alignment=4
262#endif
263ALIGNED_HEAD uint8_t g_usbd_vcpkybrd_hid_report[USBD_VCPKYBRD_HID_SIZ_REPORT_DESC] ALIGNED_TAIL =
264{
265 0x05, 0x01, // USAGE_PAGE (Generic Desktop)
266 0x09, 0x06, // USAGE (Keyboard)
267 0xa1, 0x01, // COLLECTION (Application)
268 0x05, 0x07, // USAGE_PAGE (Keyboard)
269 0x19, 0xe0, // USAGE_MINIMUM (Keyboard LeftControl)
270 0x29, 0xe7, // USAGE_MAXIMUM (Keyboard Right GUI)
271 0x15, 0x00, // LOGICAL_MINIMUM (0)
272 0x25, 0x01, // LOGICAL_MAXIMUM (1)
273 0x75, 0x01, // REPORT_SIZE (1)
274 0x95, 0x08, // REPORT_COUNT (8)
275 0x81, 0x02, // INPUT (Data,Var,Abs)
276 0x95, 0x01, // REPORT_COUNT (1)
277 0x75, 0x08, // REPORT_SIZE (8)
278 0x81, 0x03, // INPUT (Cnst,Var,Abs)
279 0x95, 0x05, // REPORT_COUNT (5)
280 0x75, 0x01, // REPORT_SIZE (1)
281 0x05, 0x08, // USAGE_PAGE (LEDs)
282 0x19, 0x01, // USAGE_MINIMUM (Num Lock)
283 0x29, 0x05, // USAGE_MAXIMUM (Kana)
284 0x91, 0x02, // OUTPUT (Data,Var,Abs)
285 0x95, 0x01, // REPORT_COUNT (1)
286 0x75, 0x03, // REPORT_SIZE (3)
287 0x91, 0x03, // OUTPUT (Cnst,Var,Abs)
288 0x95, 0x06, // REPORT_COUNT (6)
289 0x75, 0x08, // REPORT_SIZE (8)
290 0x15, 0x00, // LOGICAL_MINIMUM (0)
291 0x25, 0xFF, // LOGICAL_MAXIMUM (255)
292 0x05, 0x07, // USAGE_PAGE (Keyboard)
293 0x19, 0x00, // USAGE_MINIMUM (Reserved (no event indicated))
294 0x29, 0x65, // USAGE_MAXIMUM (Keyboard Application)
295 0x81, 0x00, // INPUT (Data,Ary,Abs)
296 0xc0 // END_COLLECTION
297};
301#if defined ( __ICCARM__ ) /* iar compiler */
302 #pragma data_alignment=4
303#endif
304ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_VCPKYBRD_SIZ_STRING_LANGID] ALIGNED_TAIL =
305{
306 USBD_VCPKYBRD_SIZ_STRING_LANGID,
307 USB_DESCIPTOR_TYPE_STRING,
308 0x09,
309 0x04,
310};
311
315#if defined ( __ICCARM__ ) /* iar compiler */
316 #pragma data_alignment=4
317#endif
318ALIGNED_HEAD static uint8_t g_string_serial[USBD_VCPKYBRD_SIZ_STRING_SERIAL] ALIGNED_TAIL =
319{
320 USBD_VCPKYBRD_SIZ_STRING_SERIAL,
321 USB_DESCIPTOR_TYPE_STRING,
322};
323
324
325/* device descriptor */
326static usbd_desc_t device_descriptor =
327{
328 USB_DEVICE_DESC_LEN,
329 g_usbd_descriptor
330};
331
332/* config descriptor */
333static usbd_desc_t config_descriptor =
334{
335 USBD_VCPKYBRD_CONFIG_DESC_SIZE,
336 g_usbd_configuration
337};
338
339/* langid descriptor */
340static usbd_desc_t langid_descriptor =
341{
342 USBD_VCPKYBRD_SIZ_STRING_LANGID,
343 g_string_lang_id
344};
345
346/* serial descriptor */
347static usbd_desc_t serial_descriptor =
348{
349 USBD_VCPKYBRD_SIZ_STRING_SERIAL,
350 g_string_serial
351};
352
353static usbd_desc_t vp_desc;
354
361static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
362{
363 uint16_t str_len = 0, id_pos = 2;
364 uint8_t *tmp_str = string;
365
366 while(*tmp_str != '\0')
367 {
368 str_len ++;
369 unicode_buf[id_pos ++] = *tmp_str ++;
370 unicode_buf[id_pos ++] = 0x00;
371 }
372
373 str_len = str_len * 2 + 2;
374 unicode_buf[0] = str_len;
375 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
376
377 return str_len;
378}
379
387static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
388{
389 uint8_t idx = 0;
390
391 for( idx = 0 ; idx < len ; idx ++)
392 {
393 if( ((value >> 28)) < 0xA )
394 {
395 pbuf[ 2 * idx] = (value >> 28) + '0';
396 }
397 else
398 {
399 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
400 }
401
402 value = value << 4;
403
404 pbuf[2 * idx + 1] = 0;
405 }
406}
407
413static void get_serial_num(void)
414{
415 uint32_t serial0, serial1, serial2;
416
417 serial0 = *(uint32_t*)MCU_ID1;
418 serial1 = *(uint32_t*)MCU_ID2;
419 serial2 = *(uint32_t*)MCU_ID3;
420
421 serial0 += serial2;
422
423 if (serial0 != 0)
424 {
425 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
426 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
427 }
428}
429
435static usbd_desc_t *get_device_descriptor(void)
436{
437 return &device_descriptor;
438}
439
445static usbd_desc_t * get_device_qualifier(void)
446{
447 return NULL;
448}
449
455static usbd_desc_t *get_device_configuration(void)
456{
457 return &config_descriptor;
458}
459
465static usbd_desc_t *get_device_other_speed(void)
466{
467 return NULL;
468}
469
475static usbd_desc_t *get_device_lang_id(void)
476{
477 return &langid_descriptor;
478}
479
480
486static usbd_desc_t *get_device_manufacturer_string(void)
487{
488 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_VCPKYBRD_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
489 vp_desc.descriptor = g_usbd_desc_buffer;
490 return &vp_desc;
491}
492
498static usbd_desc_t *get_device_product_string(void)
499{
500 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_VCPKYBRD_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
501 vp_desc.descriptor = g_usbd_desc_buffer;
502 return &vp_desc;
503}
504
510static usbd_desc_t *get_device_serial_string(void)
511{
512 get_serial_num();
513 return &serial_descriptor;
514}
515
521static usbd_desc_t *get_device_interface_string(void)
522{
523 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_VCPKYBRD_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
524 vp_desc.descriptor = g_usbd_desc_buffer;
525 return &vp_desc;
526}
527
533static usbd_desc_t *get_device_config_string(void)
534{
535 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_VCPKYBRD_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
536 vp_desc.descriptor = g_usbd_desc_buffer;
537 return &vp_desc;
538}
539
cdc_keyboard_desc.h
usb cdc and keyboard descriptor header file
idx
uint32_t idx
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:46
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:215
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:216
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:217
USBD_VCPKYBRD_CMD_MAXPACKET_SIZE
#define USBD_VCPKYBRD_CMD_MAXPACKET_SIZE
Definition: cdc_keyboard_class.h:63
USBD_VCPKYBRD_HID_IN_EPT
#define USBD_VCPKYBRD_HID_IN_EPT
Definition: cdc_keyboard_class.h:56
USBD_VCPKYBRD_IN_MAXPACKET_SIZE
#define USBD_VCPKYBRD_IN_MAXPACKET_SIZE
usb in and out max packet size define
Definition: cdc_keyboard_class.h:61
USBD_VCPKYBRD_OUT_MAXPACKET_SIZE
#define USBD_VCPKYBRD_OUT_MAXPACKET_SIZE
Definition: cdc_keyboard_class.h:62
USBD_VCPKYBRD_CDC_INT_EPT
#define USBD_VCPKYBRD_CDC_INT_EPT
usb use endpoint define
Definition: cdc_keyboard_class.h:53
USBD_VCPKYBRD_CDC_BULK_IN_EPT
#define USBD_VCPKYBRD_CDC_BULK_IN_EPT
Definition: cdc_keyboard_class.h:54
USBD_VCPKYBRD_CDC_BULK_OUT_EPT
#define USBD_VCPKYBRD_CDC_BULK_OUT_EPT
Definition: cdc_keyboard_class.h:55
USBD_VCPKYBRD_DESC_INTERFACE_STRING
#define USBD_VCPKYBRD_DESC_INTERFACE_STRING
Definition: cdc_keyboard_desc.h:76
VCPKYBRD_CDC_INTERFACE
#define VCPKYBRD_CDC_INTERFACE
usb interface define
Definition: cdc_keyboard_desc.h:86
VCPKYBRD_KEYBOARD_INTERFACE
#define VCPKYBRD_KEYBOARD_INTERFACE
Definition: cdc_keyboard_desc.h:88
USBD_VCPKYBRD_HID_SIZ_REPORT_DESC
#define USBD_VCPKYBRD_HID_SIZ_REPORT_DESC
Definition: cdc_keyboard_desc.h:66
USBD_VCPKYBRD_DESC_MANUFACTURER_STRING
#define USBD_VCPKYBRD_DESC_MANUFACTURER_STRING
usb string define(vendor, product configuration, interface)
Definition: cdc_keyboard_desc.h:73
USBD_VCPKYBRD_PRODUCT_ID
#define USBD_VCPKYBRD_PRODUCT_ID
Definition: cdc_keyboard_desc.h:59
VCPKYBRD_BCD_NUM
#define VCPKYBRD_BCD_NUM
usb bcd number define
Definition: cdc_keyboard_desc.h:53
VCPKYBRD_CDC_DATA_INTERFACE
#define VCPKYBRD_CDC_DATA_INTERFACE
Definition: cdc_keyboard_desc.h:87
USBD_VCPKYBRD_DESC_CONFIGURATION_STRING
#define USBD_VCPKYBRD_DESC_CONFIGURATION_STRING
Definition: cdc_keyboard_desc.h:75
USBD_VCPKYBRD_CONFIG_DESC_SIZE
#define USBD_VCPKYBRD_CONFIG_DESC_SIZE
usb descriptor size define
Definition: cdc_keyboard_desc.h:65
VCPKYBRD_HID_BINTERVAL_TIME
#define VCPKYBRD_HID_BINTERVAL_TIME
usb endpoint interval define
Definition: cdc_keyboard_desc.h:81
USBD_VCPKYBRD_SIZ_STRING_SERIAL
#define USBD_VCPKYBRD_SIZ_STRING_SERIAL
Definition: cdc_keyboard_desc.h:68
USBD_VCPKYBRD_VENDOR_ID
#define USBD_VCPKYBRD_VENDOR_ID
usb vendor id and product id define
Definition: cdc_keyboard_desc.h:58
USBD_VCPKYBRD_SIZ_STRING_LANGID
#define USBD_VCPKYBRD_SIZ_STRING_LANGID
Definition: cdc_keyboard_desc.h:67
USBD_VCPKYBRD_DESC_PRODUCT_STRING
#define USBD_VCPKYBRD_DESC_PRODUCT_STRING
Definition: cdc_keyboard_desc.h:74
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: cdc_keyboard_desc.c:347
device_descriptor
static usbd_desc_t device_descriptor
Definition: cdc_keyboard_desc.c:326
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: cdc_keyboard_desc.c:455
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: cdc_keyboard_desc.c:340
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: cdc_keyboard_desc.c:435
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: cdc_keyboard_desc.c:486
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: cdc_keyboard_desc.c:445
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: cdc_keyboard_desc.c:521
g_usbd_desc_buffer
static uint8_t g_usbd_desc_buffer[256]
Definition: cdc_keyboard_desc.c:57
vp_desc
static usbd_desc_t vp_desc
Definition: cdc_keyboard_desc.c:353
g_usbd_vcpkybrd_hid_report
uint8_t g_usbd_vcpkybrd_hid_report[63]
usb hid keyboard report descriptor
Definition: cdc_keyboard_desc.c:263
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: cdc_keyboard_desc.c:465
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL
usb device standard descriptor
Definition: cdc_keyboard_desc.c:82
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: cdc_keyboard_desc.c:498
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: cdc_keyboard_desc.c:533
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: cdc_keyboard_desc.c:361
cdc_keyboard_desc_handler
usbd_desc_handler cdc_keyboard_desc_handler
device descriptor handler structure
Definition: cdc_keyboard_desc.c:62
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: cdc_keyboard_desc.c:475
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: cdc_keyboard_desc.c:413
g_vcpkybrd_hid_usb_desc
uint8_t g_vcpkybrd_hid_usb_desc[9]
usb hid descriptor
Definition: cdc_keyboard_desc.c:244
config_descriptor
static usbd_desc_t config_descriptor
Definition: cdc_keyboard_desc.c:333
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: cdc_keyboard_desc.c:510
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: cdc_keyboard_desc.c:387
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:153
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:93
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: usb_std.h:223
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: usb_std.h:224
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:96
USBD_CDC_SUBTYPE_CMF
#define USBD_CDC_SUBTYPE_CMF
Definition: usb_std.h:199
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_EPT_DESC_BULK
#define USB_EPT_DESC_BULK
Definition: usb_std.h:177
USBD_CDC_SUBTYPE_HEADER
#define USBD_CDC_SUBTYPE_HEADER
usb cdc class sub-type define
Definition: usb_std.h:198
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:152
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:151
USBD_CDC_CS_INTERFACE
#define USBD_CDC_CS_INTERFACE
usb cdc class descriptor define
Definition: usb_std.h:192
USB_EPT_DESC_INTERRUPT
#define USB_EPT_DESC_INTERRUPT
Definition: usb_std.h:178
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92
USB_CLASS_CODE_CDCDATA
#define USB_CLASS_CODE_CDCDATA
Definition: usb_std.h:167
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:94
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:95
USB_CLASS_CODE_CDC
#define USB_CLASS_CODE_CDC
Definition: usb_std.h:162
USB_CLASS_CODE_HID
#define USB_CLASS_CODE_HID
Definition: usb_std.h:163
USBD_CDC_SUBTYPE_UFD
#define USBD_CDC_SUBTYPE_UFD
Definition: usb_std.h:201
USBD_CDC_SUBTYPE_ACM
#define USBD_CDC_SUBTYPE_ACM
Definition: usb_std.h:200
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h


AT32F435/437 Firmwary Library: cdc_keyboard_desc.h Source File

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
cdc_keyboard_desc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __CDC_KEYBOARD_DESC_H
29#define __CDC_KEYBOARD_DESC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "cdc_keyboard_class.h"
36#include "usbd_core.h"
37
53#define VCPKYBRD_BCD_NUM 0x0110
54
58#define USBD_VCPKYBRD_VENDOR_ID 0x2E3C
59#define USBD_VCPKYBRD_PRODUCT_ID 0x5750
60
61
65#define USBD_VCPKYBRD_CONFIG_DESC_SIZE 108
66#define USBD_VCPKYBRD_HID_SIZ_REPORT_DESC 63
67#define USBD_VCPKYBRD_SIZ_STRING_LANGID 4
68#define USBD_VCPKYBRD_SIZ_STRING_SERIAL 0x1A
69
73#define USBD_VCPKYBRD_DESC_MANUFACTURER_STRING "Artery"
74#define USBD_VCPKYBRD_DESC_PRODUCT_STRING "AT32 Composite VCP and Keyboard"
75#define USBD_VCPKYBRD_DESC_CONFIGURATION_STRING "Composite VCP and Keyboard Config"
76#define USBD_VCPKYBRD_DESC_INTERFACE_STRING "Composite VCP and Keyboard Interface"
77
81#define VCPKYBRD_HID_BINTERVAL_TIME 0x0A
82
86#define VCPKYBRD_CDC_INTERFACE 0x00
87#define VCPKYBRD_CDC_DATA_INTERFACE 0x01
88#define VCPKYBRD_KEYBOARD_INTERFACE 0x02
89
93#define MCU_ID1 (0x1FFFF7E8)
94#define MCU_ID2 (0x1FFFF7EC)
95#define MCU_ID3 (0x1FFFF7F0)
96
100extern uint8_t g_usbd_vcpkybrd_hid_report[USBD_VCPKYBRD_HID_SIZ_REPORT_DESC];
101extern uint8_t g_vcpkybrd_hid_usb_desc[9];
102extern usbd_desc_handler cdc_keyboard_desc_handler;
103
104
112#ifdef __cplusplus
113}
114#endif
115
116#endif
cdc_keyboard_class.h
usb cdc and keyboard class file
USBD_VCPKYBRD_HID_SIZ_REPORT_DESC
#define USBD_VCPKYBRD_HID_SIZ_REPORT_DESC
Definition: cdc_keyboard_desc.h:66
g_usbd_vcpkybrd_hid_report
uint8_t g_usbd_vcpkybrd_hid_report[63]
usb hid keyboard report descriptor
Definition: cdc_keyboard_desc.c:263
g_vcpkybrd_hid_usb_desc
uint8_t g_vcpkybrd_hid_usb_desc[9]
usb hid descriptor
Definition: cdc_keyboard_desc.c:244
cdc_keyboard_desc_handler
usbd_desc_handler cdc_keyboard_desc_handler
device descriptor handler structure
Definition: cdc_keyboard_desc.c:62
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: cdc_msc_class.c Source File

  • middlewares
  • usbd_class
  • composite_cdc_msc
cdc_msc_class.c
Go to the documentation of this file.
1
26#include "usbd_core.h"
27#include "cdc_msc_class.h"
28#include "cdc_msc_desc.h"
29
43static usb_sts_type class_init_handler(void *udev);
44static usb_sts_type class_clear_handler(void *udev);
45static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
46static usb_sts_type class_ept0_tx_handler(void *udev);
47static usb_sts_type class_ept0_rx_handler(void *udev);
48static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
49static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
50static usb_sts_type class_sof_handler(void *udev);
51static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
52
53static usb_sts_type cdc_struct_init(cdc_msc_struct_type *pcdc);
54extern void usb_usart_config( linecoding_type linecoding);
55static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len);
56
57static usb_sts_type cdc_class_setup_handler(void *udev, usb_setup_type *setup);
58static usb_sts_type msc_class_setup_handler(void *udev, usb_setup_type *setup);
59
60 linecoding_type linecoding =
61{
62 115200,
63 0,
64 0,
65 8
66};
67
68/* cdc data struct */
69 cdc_msc_struct_type cdc_msc_struct;
70
71/* usb device class handler */
72usbd_class_handler cdc_msc_class_handler =
73{
74 class_init_handler,
75 class_clear_handler,
76 class_setup_handler,
77 class_ept0_tx_handler,
78 class_ept0_rx_handler,
79 class_in_handler,
80 class_out_handler,
81 class_sof_handler,
82 class_event_handler,
83 &cdc_msc_struct //cdc_struct
84};
90static usb_sts_type class_init_handler(void *udev)
91{
92 usb_sts_type status = USB_OK;
93 usbd_core_type *pudev = (usbd_core_type *)udev;
94 cdc_msc_struct_type *pcdcmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
95
96 /* init cdc struct */
97 cdc_struct_init(pcdcmsc);
98
99 /* open in endpoint */
100 usbd_ept_open(pudev, USBD_CDC_INT_EPT, EPT_INT_TYPE, USBD_CDC_CMD_MAXPACKET_SIZE);
101
102 /* open in endpoint */
103 usbd_ept_open(pudev, USBD_CDC_BULK_IN_EPT, EPT_BULK_TYPE, USBD_CDC_MSC_IN_MAXPACKET_SIZE);
104
105 /* open out endpoint */
106 usbd_ept_open(pudev, USBD_CDC_BULK_OUT_EPT, EPT_BULK_TYPE, USBD_CDC_MSC_OUT_MAXPACKET_SIZE);
107
108 /* set out endpoint to receive status */
109 usbd_ept_recv(pudev, USBD_CDC_BULK_OUT_EPT, pcdcmsc->g_rx_buff, USBD_CDC_MSC_OUT_MAXPACKET_SIZE);
110
111 /* open in endpoint */
112 usbd_ept_open(pudev, USBD_MSC_BULK_IN_EPT, EPT_BULK_TYPE, USBD_CDC_MSC_IN_MAXPACKET_SIZE);
113
114 /* open out endpoint */
115 usbd_ept_open(pudev, USBD_MSC_BULK_OUT_EPT, EPT_BULK_TYPE, USBD_CDC_MSC_OUT_MAXPACKET_SIZE);
116
117 bot_scsi_init(udev);
118
119 return status;
120}
121
127static usb_sts_type class_clear_handler(void *udev)
128{
129 usb_sts_type status = USB_OK;
130 usbd_core_type *pudev = (usbd_core_type *)udev;
131
132 /* close in endpoint */
133 usbd_ept_close(pudev, USBD_CDC_INT_EPT);
134
135 /* close in endpoint */
136 usbd_ept_close(pudev, USBD_CDC_BULK_IN_EPT);
137
138 /* close out endpoint */
139 usbd_ept_close(pudev, USBD_CDC_BULK_OUT_EPT);
140
141 /* close in endpoint */
142 usbd_ept_close(pudev, USBD_MSC_BULK_IN_EPT);
143
144 /* close out endpoint */
145 usbd_ept_close(pudev, USBD_MSC_BULK_OUT_EPT);
146
147 return status;
148}
149
156static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
157{
158 usb_sts_type status = USB_OK;
159 usbd_core_type *pudev = (usbd_core_type *)udev;
160 switch(setup->bmRequestType & USB_REQ_RECIPIENT_MASK)
161 {
162 case USB_REQ_RECIPIENT_INTERFACE:
163 if(setup->wIndex == VCPMSC_MSC_INTERFACE)
164 {
165 msc_class_setup_handler(udev, setup);
166 }
167 else
168 {
169 cdc_class_setup_handler(pudev, setup);
170 }
171 break;
172 case USB_REQ_RECIPIENT_ENDPOINT:
173 if(setup->wIndex == (USBD_MSC_BULK_IN_EPT | USBD_MSC_BULK_OUT_EPT))
174 {
175 msc_class_setup_handler(udev, setup);
176 }
177 else
178 {
179 cdc_class_setup_handler(pudev, setup);
180 }
181 break;
182
183 }
184 return status;
185}
186
193static usb_sts_type cdc_class_setup_handler(void *udev, usb_setup_type *setup)
194{
195 usb_sts_type status = USB_OK;
196 usbd_core_type *pudev = (usbd_core_type *)udev;
197 cdc_msc_struct_type *pcdc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
198
199 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
200 {
201 /* class request */
202 case USB_REQ_TYPE_CLASS:
203 if(setup->wLength)
204 {
205 if(setup->bmRequestType & USB_REQ_DIR_DTH)
206 {
207 usb_vcp_cmd_process(udev, setup->bRequest, pcdc->g_cmd, setup->wLength);
208 usbd_ctrl_send(pudev, pcdc->g_cmd, setup->wLength);
209 }
210 else
211 {
212 pcdc->g_req = setup->bRequest;
213 pcdc->g_len = setup->wLength;
214 usbd_ctrl_recv(pudev, pcdc->g_cmd, pcdc->g_len);
215
216 }
217 }
218 break;
219 /* standard request */
220 case USB_REQ_TYPE_STANDARD:
221 switch(setup->bRequest)
222 {
223 case USB_STD_REQ_GET_DESCRIPTOR:
224 usbd_ctrl_unsupport(pudev);
225 break;
226 case USB_STD_REQ_GET_INTERFACE:
227 usbd_ctrl_send(pudev, (uint8_t *)&pcdc->alt_setting, 1);
228 break;
229 case USB_STD_REQ_SET_INTERFACE:
230 pcdc->alt_setting = setup->wValue;
231 break;
232 default:
233 break;
234 }
235 break;
236 default:
237 usbd_ctrl_unsupport(pudev);
238 break;
239 }
240 return status;
241}
242
249static usb_sts_type msc_class_setup_handler(void *udev, usb_setup_type *setup)
250{
251 usb_sts_type status = USB_OK;
252 usbd_core_type *pudev = (usbd_core_type *)udev;
253 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
254 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
255 {
256 /* class request */
257 case USB_REQ_TYPE_CLASS:
258
259 switch(setup->bRequest)
260 {
261 case MSC_REQ_GET_MAX_LUN:
262 usbd_ctrl_send(pudev, (uint8_t *)&cdc_msc_struct.max_lun, 1);
263 break;
264 case MSC_REQ_BO_RESET:
265 bot_scsi_reset(udev);
266 usbd_ctrl_send_status(pudev);
267 break;
268 default:
269 usbd_ctrl_unsupport(pudev);
270 break;
271
272 }
273 break;
274 /* standard request */
275 case USB_REQ_TYPE_STANDARD:
276
277 switch(setup->bRequest)
278 {
279 case USB_STD_REQ_GET_DESCRIPTOR:
280 usbd_ctrl_unsupport(pudev);
281 break;
282 case USB_STD_REQ_GET_INTERFACE:
283 usbd_ctrl_send(pudev, (uint8_t *)&pmsc->alt_setting, 1);
284 break;
285 case USB_STD_REQ_SET_INTERFACE:
286 pmsc->alt_setting = setup->wValue;
287 break;
288 case USB_STD_REQ_CLEAR_FEATURE:
289 usbd_ept_close(pudev, (uint8_t)setup->wIndex);
290
291 if((setup->wIndex & 0x80) == 0x80)
292 {
293 usbd_flush_tx_fifo(pudev, setup->wIndex & 0x7F);
294 usbd_ept_open(pudev, (uint8_t)setup->wIndex, EPT_BULK_TYPE, USBD_CDC_MSC_IN_MAXPACKET_SIZE);
295 }
296 else
297 {
298 usbd_ept_open(pudev, (uint8_t)setup->wIndex, EPT_BULK_TYPE, USBD_CDC_MSC_OUT_MAXPACKET_SIZE);
299 }
300 bot_scsi_clear_feature(udev, setup->wIndex);
301 break;
302 default:
303 break;
304 }
305 break;
306 default:
307 usbd_ctrl_unsupport(pudev);
308 break;
309 }
310 return status;
311}
312
318static usb_sts_type class_ept0_tx_handler(void *udev)
319{
320 usb_sts_type status = USB_OK;
321
322 /* ...user code... */
323
324 return status;
325}
326
332static usb_sts_type class_ept0_rx_handler(void *udev)
333{
334 usb_sts_type status = USB_OK;
335 usbd_core_type *pudev = (usbd_core_type *)udev;
336 cdc_msc_struct_type *pcdc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
337 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
338 /* ...user code... */
339 if( pcdc->g_req == SET_LINE_CODING)
340 {
341 /* class process */
342 usb_vcp_cmd_process(udev, pcdc->g_req, pcdc->g_cmd, recv_len);
343 }
344
345 return status;
346}
347
354static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
355{
356 usbd_core_type *pudev = (usbd_core_type *)udev;
357 cdc_msc_struct_type *pcdcmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
358 usb_sts_type status = USB_OK;
359
360 /* ...user code...
361 trans next packet data
362 */
363 usbd_flush_tx_fifo(pudev, ept_num);
364
365 if((ept_num & 0x7F) == (USBD_CDC_BULK_IN_EPT & 0x7F))
366 {
367 pcdcmsc->g_tx_completed = 1;
368 }
369 if((ept_num & 0x7F) == (USBD_MSC_BULK_IN_EPT & 0x7F))
370 {
371 bot_scsi_datain_handler(udev, ept_num);
372 }
373
374 return status;
375}
376
383static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
384{
385 usb_sts_type status = USB_OK;
386 usbd_core_type *pudev = (usbd_core_type *)udev;
387 cdc_msc_struct_type *pcdcmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
388
389
390
391 if((ept_num & 0x7F) == (USBD_CDC_BULK_OUT_EPT & 0x7F))
392 {
393 /* get endpoint receive data length */
394 pcdcmsc->g_rxlen = usbd_get_recv_len(pudev, ept_num);
395
396 /*set recv flag*/
397 pcdcmsc->g_rx_completed = 1;
398 }
399 if((ept_num & 0x7F) == (USBD_MSC_BULK_OUT_EPT & 0x7F))
400 {
401 bot_scsi_dataout_handler(udev, ept_num);
402 }
403
404 return status;
405}
406
412static usb_sts_type class_sof_handler(void *udev)
413{
414 usb_sts_type status = USB_OK;
415
416 /* ...user code... */
417
418 return status;
419}
420
427static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
428{
429 usb_sts_type status = USB_OK;
430 switch(event)
431 {
432 case USBD_RESET_EVENT:
433
434 /* ...user code... */
435
436 break;
437 case USBD_SUSPEND_EVENT:
438
439 /* ...user code... */
440
441 break;
442 case USBD_WAKEUP_EVENT:
443 /* ...user code... */
444
445 break;
446 case USBD_INISOINCOM_EVENT:
447 break;
448 case USBD_OUTISOINCOM_EVENT:
449 break;
450
451 default:
452 break;
453 }
454 return status;
455}
456
462static usb_sts_type cdc_struct_init(cdc_msc_struct_type *pcdc)
463{
464 pcdc->g_tx_completed = 1;
465 pcdc->g_rx_completed = 0;
466 pcdc->alt_setting = 0;
467 pcdc->linecoding.bitrate = linecoding.bitrate;
468 pcdc->linecoding.data = linecoding.data;
469 pcdc->linecoding.format = linecoding.format;
470 pcdc->linecoding.parity = linecoding.parity;
471 return USB_OK;
472}
473
480uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
481{
482 uint16_t i_index = 0;
483 uint16_t tmp_len = 0;
484 usbd_core_type *pudev = (usbd_core_type *)udev;
485 cdc_msc_struct_type *pcdc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
486
487 if(pcdc->g_rx_completed == 0)
488 {
489 return 0;
490 }
491 pcdc->g_rx_completed = 0;
492 tmp_len = pcdc->g_rxlen;
493 for(i_index = 0; i_index < pcdc->g_rxlen; i_index ++)
494 {
495 recv_data[i_index] = pcdc->g_rx_buff[i_index];
496 }
497
498 usbd_ept_recv(pudev, USBD_CDC_BULK_OUT_EPT, pcdc->g_rx_buff, USBD_CDC_MSC_OUT_MAXPACKET_SIZE);
499
500 return tmp_len;
501}
502
510 error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
511{
512 error_status status = SUCCESS;
513 usbd_core_type *pudev = (usbd_core_type *)udev;
514 cdc_msc_struct_type *pcdc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
515 if(pcdc->g_tx_completed)
516 {
517 pcdc->g_tx_completed = 0;
518 usbd_ept_send(pudev, USBD_CDC_BULK_IN_EPT, send_data, len);
519 }
520 else
521 {
522 status = ERROR;
523 }
524 return status;
525}
526
535static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
536{
537 usbd_core_type *pudev = (usbd_core_type *)udev;
538 cdc_msc_struct_type *pcdc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
539 switch(cmd)
540 {
541 case SET_LINE_CODING:
542 pcdc->linecoding.bitrate = (uint32_t)(buff[0] | (buff[1] << 8) | (buff[2] << 16) | (buff[3] <<24));
543 pcdc->linecoding.format = buff[4];
544 pcdc->linecoding.parity = buff[5];
545 pcdc->linecoding.data = buff[6];
546#ifdef USB_VIRTUAL_COMPORT
547 /* set hardware usart */
548 usb_usart_config(pcdc->linecoding);
549#endif
550 break;
551
552 case GET_LINE_CODING:
553 buff[0] = (uint8_t)pcdc->linecoding.bitrate;
554 buff[1] = (uint8_t)(pcdc->linecoding.bitrate >> 8);
555 buff[2] = (uint8_t)(pcdc->linecoding.bitrate >> 16);
556 buff[3] = (uint8_t)(pcdc->linecoding.bitrate >> 24);
557 buff[4] = (uint8_t)(pcdc->linecoding.format);
558 buff[5] = (uint8_t)(pcdc->linecoding.parity);
559 buff[6] = (uint8_t)(pcdc->linecoding.data);
560 break;
561
562 default:
563 break;
564 }
565}
566
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: cdc_msc_class.c:412
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: cdc_msc_class.c:354
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: cdc_msc_class.c:127
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_msc_class.c:156
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: cdc_msc_class.c:318
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: cdc_msc_class.c:332
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: cdc_msc_class.c:427
usb_vcp_cmd_process
static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device function
Definition: cdc_msc_class.c:535
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: cdc_msc_class.c:90
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: cdc_msc_class.c:383
cdc_msc_class.h
usb cdc class file
cdc_msc_desc.h
usb cdc descriptor header file
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
cdc_msc_struct_type::g_tx_completed
__IO uint8_t g_tx_completed
Definition: cdc_msc_class.h:260
cdc_msc_struct_type::g_req
uint8_t g_req
Definition: cdc_msc_class.h:258
cdc_msc_struct_type::alt_setting
uint32_t alt_setting
Definition: cdc_msc_class.h:255
cdc_msc_struct_type::linecoding
linecoding_type linecoding
Definition: cdc_msc_class.h:261
cdc_msc_struct_type::g_rx_buff
uint8_t g_rx_buff[0x40]
Definition: cdc_msc_class.h:256
cdc_msc_struct_type::g_len
uint16_t g_len
Definition: cdc_msc_class.h:259
cdc_msc_struct_type::max_lun
uint32_t max_lun
Definition: cdc_msc_class.h:266
cdc_msc_struct_type::g_cmd
uint8_t g_cmd[0x08]
Definition: cdc_msc_class.h:257
cdc_msc_struct_type::g_rx_completed
__IO uint8_t g_rx_completed
Definition: cdc_msc_class.h:260
cdc_msc_struct_type::g_rxlen
uint16_t g_rxlen
Definition: cdc_msc_class.h:259
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
USBD_CDC_CMD_MAXPACKET_SIZE
#define USBD_CDC_CMD_MAXPACKET_SIZE
Definition: cdc_class.h:62
USBD_CDC_MSC_OUT_MAXPACKET_SIZE
#define USBD_CDC_MSC_OUT_MAXPACKET_SIZE
Definition: cdc_msc_class.h:65
USBD_CDC_BULK_OUT_EPT
#define USBD_CDC_BULK_OUT_EPT
Definition: cdc_class.h:55
USBD_CDC_MSC_IN_MAXPACKET_SIZE
#define USBD_CDC_MSC_IN_MAXPACKET_SIZE
usb cdc in and out max packet size define
Definition: cdc_msc_class.h:63
USBD_CDC_INT_EPT
#define USBD_CDC_INT_EPT
usb cdc use endpoint define
Definition: cdc_class.h:53
USBD_CDC_BULK_IN_EPT
#define USBD_CDC_BULK_IN_EPT
Definition: cdc_class.h:54
USBD_MSC_BULK_IN_EPT
#define USBD_MSC_BULK_IN_EPT
Definition: cdc_msc_class.h:57
USBD_MSC_BULK_OUT_EPT
#define USBD_MSC_BULK_OUT_EPT
Definition: cdc_msc_class.h:58
cdc_msc_struct
cdc_msc_struct_type cdc_msc_struct
Definition: cdc_msc_class.c:69
cdc_struct_init
static usb_sts_type cdc_struct_init(cdc_msc_struct_type *pcdc)
usb device cdc init
Definition: cdc_msc_class.c:462
msc_class_setup_handler
static usb_sts_type msc_class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_msc_class.c:249
usb_usart_config
void usb_usart_config(linecoding_type linecoding)
this function handles usart2 and linecoding config.
Definition: project/at_start_f435/examples/usb_device/virtual_comport/src/main.c:241
linecoding
linecoding_type linecoding
Definition: cdc_msc_class.c:60
usb_vcp_get_rxdata
uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_class.c:339
usb_vcp_send_data
error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_class.c:369
cdc_class_setup_handler
static usb_sts_type cdc_class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_msc_class.c:193
cdc_msc_class_handler
usbd_class_handler cdc_msc_class_handler
Definition: cdc_msc_class.c:72
VCPMSC_MSC_INTERFACE
#define VCPMSC_MSC_INTERFACE
usb interface define
Definition: cdc_msc_desc.h:84
bot_scsi_datain_handler
void bot_scsi_datain_handler(void *pudev, uint8_t ept_num)
bulk-only transport data in handler
Definition: msc/msc_bot_scsi.c:147
bot_scsi_reset
void bot_scsi_reset(void *udev)
reset bulk-only transport and scsi
Definition: msc/msc_bot_scsi.c:128
bot_scsi_init
void bot_scsi_init(void *udev)
initialize bulk-only transport and scsi
Definition: msc/msc_bot_scsi.c:104
bot_scsi_dataout_handler
void bot_scsi_dataout_handler(void *pudev, uint8_t ept_num)
bulk-only transport data out handler
Definition: msc/msc_bot_scsi.c:176
bot_scsi_clear_feature
void bot_scsi_clear_feature(void *udev, uint8_t ept_num)
clear feature
Definition: msc/msc_bot_scsi.c:733
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f435_437_usb.h:349
EPT_BULK_TYPE
@ EPT_BULK_TYPE
Definition: at32f435_437_usb.h:348
MSC_REQ_BO_RESET
#define MSC_REQ_BO_RESET
Definition: cdc_msc_class.h:104
MSC_REQ_GET_MAX_LUN
#define MSC_REQ_GET_MAX_LUN
Definition: cdc_msc_class.h:103
USB_STD_REQ_CLEAR_FEATURE
#define USB_STD_REQ_CLEAR_FEATURE
Definition: usb_std.h:78
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:63
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:81
GET_LINE_CODING
#define GET_LINE_CODING
Definition: usb_std.h:207
SET_LINE_CODING
#define SET_LINE_CODING
usb cdc class request code define
Definition: usb_std.h:206
USB_REQ_DIR_DTH
#define USB_REQ_DIR_DTH
Definition: usb_std.h:72
USB_REQ_RECIPIENT_MASK
#define USB_REQ_RECIPIENT_MASK
Definition: usb_std.h:58
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:86
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:66
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:85
USB_REQ_RECIPIENT_ENDPOINT
#define USB_REQ_RECIPIENT_ENDPOINT
Definition: usb_std.h:56
USB_REQ_RECIPIENT_INTERFACE
#define USB_REQ_RECIPIENT_INTERFACE
Definition: usb_std.h:55
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:64
USB_OK
@ USB_OK
Definition: usb_std.h:268
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:346
usbd_ctrl_send_status
void usbd_ctrl_send_status(usbd_core_type *udev)
usb control endpoint send in status
Definition: usbd_core.c:212
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint receive data
Definition: usbd_core.c:534
usbd_flush_tx_fifo
void usbd_flush_tx_fifo(usbd_core_type *udev, uint8_t ept_num)
usb device flush in endpoint fifo
Definition: usbd_core.c:650
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:314
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:177
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint send data
Definition: usbd_core.c:434
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
get endpoint receive data length
Definition: usbd_core.c:300
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint recv data
Definition: usbd_core.c:196
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:287
cdc_msc_struct_type
usb cdc class struct
Definition: cdc_msc_class.h:253
linecoding_type
usb cdc class set line coding struct
Definition: usb_std.h:213
linecoding_type::bitrate
uint32_t bitrate
Definition: usb_std.h:214
linecoding_type::data
uint8_t data
Definition: usb_std.h:217
linecoding_type::parity
uint8_t parity
Definition: usb_std.h:216
linecoding_type::format
uint8_t format
Definition: usb_std.h:215
usb_setup_type
format of usb setup data
Definition: usb_std.h:280
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:283
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:286
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:281
usb_setup_type::wIndex
uint16_t wIndex
Definition: usb_std.h:284
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:282
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: cdc_msc_class.h Source File

  • middlewares
  • usbd_class
  • composite_cdc_msc
cdc_msc_class.h
Go to the documentation of this file.
1
27 /* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __CDC_MSC_CLASS_H
29#define __CDC_MSC_CLASS_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "usb_std.h"
36#include "usbd_core.h"
37
53#define USBD_CDC_INT_EPT 0x82
54#define USBD_CDC_BULK_IN_EPT 0x83
55#define USBD_CDC_BULK_OUT_EPT 0x02
56
57#define USBD_MSC_BULK_IN_EPT 0x81
58#define USBD_MSC_BULK_OUT_EPT 0x01
59
63#define USBD_CDC_MSC_IN_MAXPACKET_SIZE 0x40
64
65#define USBD_CDC_MSC_OUT_MAXPACKET_SIZE 0x40
66#define USBD_CDC_CMD_MAXPACKET_SIZE 0x08
67
68
69
70
83#define MSC_SUPPORT_MAX_LUN 1
84#define MSC_MAX_DATA_BUF_LEN 4096
85
86#define MSC_CMD_FORMAT_UNIT 0x04
87#define MSC_CMD_INQUIRY 0x12
88#define MSC_CMD_START_STOP 0x1B
89#define MSC_CMD_MODE_SENSE6 0x1A
90#define MSC_CMD_MODE_SENSE10 0x5A
91#define MSC_CMD_ALLOW_MEDIUM_REMOVAL 0x1E
92#define MSC_CMD_READ_10 0x28
93#define MSC_CMD_READ_12 0xA8
94#define MSC_CMD_READ_CAPACITY 0x25
95#define MSC_CMD_READ_FORMAT_CAPACITY 0x23
96#define MSC_CMD_REQUEST_SENSE 0x03
97#define MSC_CMD_TEST_UNIT 0x00
98#define MSC_CMD_VERIFY 0x2F
99#define MSC_CMD_WRITE_10 0x2A
100#define MSC_CMD_WRITE_12 0xAA
101#define MSC_CMD_WRITE_VERIFY 0x2E
102
103#define MSC_REQ_GET_MAX_LUN 0xFE
104#define MSC_REQ_BO_RESET 0xFF
106#define SET_LINE_CODING 0x20
107#define GET_LINE_CODING 0x21
108
109#define CBW_CMD_LENGTH 31
110#define CBW_DCBWSIGNATURE 0x43425355
111#define CBW_BMCBWFLAGS_DIR_OUT 0x00
112#define CBW_BMCBWFLAGS_DIR_IN 0x80
113
114#define CSW_CMD_LENGTH 13
115#define CSW_DCSWSIGNATURE 0x53425355
116#define CSW_BCSWSTATUS_PASS 0x00
117#define CSW_BCSWSTATUS_FAILED 0x01
118#define CSW_BCSWSTATUS_PHASE_ERR 0x02
119
120#define MSC_STATE_MACHINE_CMD 0x00
121#define MSC_STATE_MACHINE_DATA_IN 0x01
122#define MSC_STATE_MACHINE_DATA_OUT 0x02
123#define MSC_STATE_MACHINE_SEND_DATA 0x03
124#define MSC_STATE_MACHINE_LAST_DATA 0x04
125#define MSC_STATE_MACHINE_STATUS 0x05
126#define MSC_STATE_MACHINE_FAILED 0x06
127#define MSC_STATE_MACHINE_IDLE 0x07
128
129#define MSC_BOT_STATE_IDLE 0x00
130#define MSC_BOT_STATE_RECOVERY 0x01
131#define MSC_BOT_STATE_ERROR 0x02
132
133#define REQ_SENSE_STANDARD_DATA_LEN 0x12
134#define SENSE_KEY_NO_SENSE 0x00
135#define SENSE_KEY_RECOVERED_ERROR 0x01
136#define SENSE_KEY_NOT_READY 0x02
137#define SENSE_KEY_MEDIUM_ERROR 0x03
138#define SENSE_KEY_HARDWARE_ERROR 0x04
139#define SENSE_KEY_ILLEGAL_REQUEST 0x05
140#define SENSE_KEY_UNIT_ATTENTION 0x06
141#define SENSE_KEY_DATA_PROTECT 0x07
142#define SENSE_KEY_BLANK_CHECK 0x08
143#define SENSE_KEY_VENDERO_SPECIFIC 0x09
144#define SENSE_KEY_ABORTED_COMMAND 0x0B
145#define SENSE_KEY_VOLUME_OVERFLOW 0x0D
146#define SENSE_KEY_MISCOMPARE 0x0E
147
148
149#define INVALID_COMMAND 0x20
150#define INVALID_FIELED_IN_COMMAND 0x24
151#define PARAMETER_LIST_LENGTH_ERROR 0x1A
152#define INVALID_FIELD_IN_PARAMETER_LIST 0x26
153#define ADDRESS_OUT_OF_RANGE 0x21
154#define MEDIUM_NOT_PRESENT 0x3A
155#define MEDIUM_HAVE_CHANGED 0x28
156
157#define SCSI_INQUIRY_DATA_LENGTH 36
158
162typedef struct
163{
164 uint8_t opcode;
165 uint8_t lun;
166 uint32_t address;
167 uint8_t reserved1;
168 uint32_t alloc_length;
169 uint16_t reserved2;
170}cbd_typical_type;
171
175typedef struct
176{
177 uint8_t opcode;
178 uint8_t lun;
179 uint32_t address;
180 uint8_t reserved1;
181 uint32_t alloc_length;
182 uint16_t reserved2;
183}cbd_extended_type;
184
188typedef struct
189{
190 uint32_t dCBWSignature;
191 uint32_t dCBWTage;
192 uint32_t dCBWDataTransferLength;
193 uint8_t bmCBWFlags;
194 uint8_t bCBWLUN;
195 uint8_t bCBWCBLength;
196 uint8_t CBWCB[16];
197}cbw_type;
198
202typedef struct
203{
204 uint32_t dCSWSignature;
205 uint32_t dCSWTag;
206 uint32_t dCSWDataResidue;
207 uint32_t bCSWStatus;
208}csw_type;
209
213typedef struct
214{
215 uint8_t err_code;
216 uint8_t reserved1;
217 uint8_t sense_key;
218 uint32_t information;
219 uint8_t as_length;
220 uint32_t reserved2;
221 uint8_t asc;
222 uint8_t ascq;
223 uint32_t reserved3;
224}sense_type;
225
226
227typedef struct
228{
229 uint8_t msc_state;
230 uint8_t bot_status;
231 uint32_t max_lun;
232
233 uint32_t blk_nbr[MSC_SUPPORT_MAX_LUN];
234 uint32_t blk_size[MSC_SUPPORT_MAX_LUN];
235
236 uint32_t blk_addr;
237 uint32_t blk_len;
238
239 uint32_t data_len;
240 uint8_t data[MSC_MAX_DATA_BUF_LEN];
241
242 uint32_t alt_setting;
243
244 cbw_type cbw_struct;
245 csw_type csw_struct;
246
247}msc_type;
248
252typedef struct
253{
254 //used for CDC
255 uint32_t alt_setting;
256 uint8_t g_rx_buff[USBD_CDC_MSC_OUT_MAXPACKET_SIZE];
257 uint8_t g_cmd[USBD_CDC_CMD_MAXPACKET_SIZE];
258 uint8_t g_req;
259 uint16_t g_len, g_rxlen;
260 __IO uint8_t g_tx_completed, g_rx_completed;
261 linecoding_type linecoding;
262
263 //used for MSC
264 uint8_t msc_state;
265 uint8_t bot_status;
266 uint32_t max_lun;
267
268 uint32_t blk_nbr[MSC_SUPPORT_MAX_LUN];
269 uint32_t blk_size[MSC_SUPPORT_MAX_LUN];
270
271 uint32_t blk_addr;
272 uint32_t blk_len;
273
274 uint32_t data_len;
275 uint8_t data[MSC_MAX_DATA_BUF_LEN];
276
277 cbw_type cbw_struct;
278 csw_type csw_struct;
279}cdc_msc_struct_type; //cdc_struct_type;
280
281
289extern usbd_class_handler cdc_msc_class_handler; //cdc_class_handler;
290uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data);
291 error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len);
292
293void bot_scsi_init(void *udev);
294void bot_scsi_reset(void *udev);
295void bot_scsi_datain_handler(void *pudev, uint8_t ept_num);
296void bot_scsi_dataout_handler(void *pudev, uint8_t ept_num);
297void bot_cbw_decode(void *udev);
298void bot_scsi_send_data(void *udev, uint8_t *buffer, uint32_t len);
299void bot_scsi_send_csw(void *udev, uint8_t status);
300void bot_scsi_sense_code(void *udev, uint8_t sense_key, uint8_t asc);
301 usb_sts_type bot_scsi_check_address(void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count);
302void bot_scsi_stall(void *udev);
303 usb_sts_type bot_scsi_cmd_process(void *udev);
304
305 usb_sts_type bot_scsi_test_unit(void *udev, uint8_t lun);
306 usb_sts_type bot_scsi_inquiry(void *udev, uint8_t lun);
307 usb_sts_type bot_scsi_start_stop(void *udev, uint8_t lun);
308 usb_sts_type bot_scsi_allow_medium_removal(void *udev, uint8_t lun);
309 usb_sts_type bot_scsi_mode_sense6(void *udev, uint8_t lun);
310 usb_sts_type bot_scsi_mode_sense10(void *udev, uint8_t lun);
311 usb_sts_type bot_scsi_read10(void *udev, uint8_t lun);
312 usb_sts_type bot_scsi_capacity(void *udev, uint8_t lun);
313 usb_sts_type bot_scsi_format_capacity(void *udev, uint8_t lun);
314 usb_sts_type bot_scsi_request_sense(void *udev, uint8_t lun);
315 usb_sts_type bot_scsi_verify(void *udev, uint8_t lun);
316 usb_sts_type bot_scsi_write10(void *udev, uint8_t lun);
317void bot_scsi_clear_feature(void *udev, uint8_t ept_num);
318
330#ifdef __cplusplus
331}
332#endif
333
334#endif
335
336
337
338
buffer
uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:43
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
cdc_msc_struct_type::cbw_struct
cbw_type cbw_struct
Definition: cdc_msc_class.h:277
cbd_typical_type::opcode
uint8_t opcode
Definition: cdc_msc_class.h:164
cbd_typical_type::address
uint32_t address
Definition: cdc_msc_class.h:166
cbd_typical_type::alloc_length
uint32_t alloc_length
Definition: cdc_msc_class.h:168
cbw_type::bCBWLUN
uint8_t bCBWLUN
Definition: cdc_msc_class.h:194
msc_type::cbw_struct
cbw_type cbw_struct
Definition: cdc_msc_class.h:244
sense_type::err_code
uint8_t err_code
Definition: cdc_msc_class.h:215
cdc_msc_struct_type::g_req
uint8_t g_req
Definition: cdc_msc_class.h:258
sense_type::ascq
uint8_t ascq
Definition: cdc_msc_class.h:222
cbw_type::bCBWCBLength
uint8_t bCBWCBLength
Definition: cdc_msc_class.h:195
cdc_msc_struct_type::alt_setting
uint32_t alt_setting
Definition: cdc_msc_class.h:255
cdc_msc_struct_type::msc_state
uint8_t msc_state
Definition: cdc_msc_class.h:264
csw_type::dCSWSignature
uint32_t dCSWSignature
Definition: cdc_msc_class.h:204
cbd_typical_type::reserved1
uint8_t reserved1
Definition: cdc_msc_class.h:167
sense_type::reserved3
uint32_t reserved3
Definition: cdc_msc_class.h:223
cbd_extended_type::alloc_length
uint32_t alloc_length
Definition: cdc_msc_class.h:181
csw_type::bCSWStatus
uint32_t bCSWStatus
Definition: cdc_msc_class.h:207
cdc_msc_struct_type::blk_len
uint32_t blk_len
Definition: cdc_msc_class.h:272
sense_type::asc
uint8_t asc
Definition: cdc_msc_class.h:221
csw_type::dCSWTag
uint32_t dCSWTag
Definition: cdc_msc_class.h:205
cbd_extended_type::opcode
uint8_t opcode
Definition: cdc_msc_class.h:177
csw_type::dCSWDataResidue
uint32_t dCSWDataResidue
Definition: cdc_msc_class.h:206
cbd_extended_type::address
uint32_t address
Definition: cdc_msc_class.h:179
cdc_msc_struct_type::csw_struct
csw_type csw_struct
Definition: cdc_msc_class.h:278
msc_type::csw_struct
csw_type csw_struct
Definition: cdc_msc_class.h:245
msc_type::blk_len
uint32_t blk_len
Definition: cdc_msc_class.h:237
sense_type::as_length
uint8_t as_length
Definition: cdc_msc_class.h:219
sense_type::reserved2
uint32_t reserved2
Definition: cdc_msc_class.h:220
msc_type::blk_addr
uint32_t blk_addr
Definition: cdc_msc_class.h:236
cbd_extended_type::reserved1
uint8_t reserved1
Definition: cdc_msc_class.h:180
cbd_extended_type::reserved2
uint16_t reserved2
Definition: cdc_msc_class.h:182
cdc_msc_struct_type::data_len
uint32_t data_len
Definition: cdc_msc_class.h:274
cdc_msc_struct_type::linecoding
linecoding_type linecoding
Definition: cdc_msc_class.h:261
sense_type::sense_key
uint8_t sense_key
Definition: cdc_msc_class.h:217
cbd_typical_type::lun
uint8_t lun
Definition: cdc_msc_class.h:165
cbd_typical_type::reserved2
uint16_t reserved2
Definition: cdc_msc_class.h:169
msc_type::max_lun
uint32_t max_lun
Definition: cdc_msc_class.h:231
msc_type::bot_status
uint8_t bot_status
Definition: cdc_msc_class.h:230
cbd_extended_type::lun
uint8_t lun
Definition: cdc_msc_class.h:178
msc_type::msc_state
uint8_t msc_state
Definition: cdc_msc_class.h:229
sense_type::reserved1
uint8_t reserved1
Definition: cdc_msc_class.h:216
msc_type::alt_setting
uint32_t alt_setting
Definition: cdc_msc_class.h:242
cdc_msc_struct_type::g_len
uint16_t g_len
Definition: cdc_msc_class.h:259
cbw_type::dCBWDataTransferLength
uint32_t dCBWDataTransferLength
Definition: cdc_msc_class.h:192
sense_type::information
uint32_t information
Definition: cdc_msc_class.h:218
msc_type::data_len
uint32_t data_len
Definition: cdc_msc_class.h:239
cdc_msc_struct_type::max_lun
uint32_t max_lun
Definition: cdc_msc_class.h:266
cdc_msc_struct_type::blk_addr
uint32_t blk_addr
Definition: cdc_msc_class.h:271
cbw_type::dCBWTage
uint32_t dCBWTage
Definition: cdc_msc_class.h:191
cbw_type::dCBWSignature
uint32_t dCBWSignature
Definition: cdc_msc_class.h:190
cdc_msc_struct_type::bot_status
uint8_t bot_status
Definition: cdc_msc_class.h:265
cdc_msc_struct_type::g_rx_completed
__IO uint8_t g_rx_completed
Definition: cdc_msc_class.h:260
cbw_type::bmCBWFlags
uint8_t bmCBWFlags
Definition: cdc_msc_class.h:193
error_status
error_status
Definition: at32f435_437.h:380
USBD_CDC_CMD_MAXPACKET_SIZE
#define USBD_CDC_CMD_MAXPACKET_SIZE
Definition: cdc_msc_class.h:66
USBD_CDC_MSC_OUT_MAXPACKET_SIZE
#define USBD_CDC_MSC_OUT_MAXPACKET_SIZE
Definition: cdc_msc_class.h:65
bot_scsi_format_capacity
usb_sts_type bot_scsi_format_capacity(void *udev, uint8_t lun)
bulk-only transport scsi command format capacity
Definition: msc/msc_bot_scsi.c:508
bot_scsi_datain_handler
void bot_scsi_datain_handler(void *pudev, uint8_t ept_num)
bulk-only transport data in handler
Definition: msc/msc_bot_scsi.c:147
bot_scsi_start_stop
usb_sts_type bot_scsi_start_stop(void *udev, uint8_t lun)
bulk-only transport scsi command start stop
Definition: msc/msc_bot_scsi.c:413
bot_scsi_request_sense
usb_sts_type bot_scsi_request_sense(void *udev, uint8_t lun)
bulk-only transport scsi command request sense
Definition: msc/msc_bot_scsi.c:543
usb_vcp_get_rxdata
uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_class.c:339
bot_scsi_read10
usb_sts_type bot_scsi_read10(void *udev, uint8_t lun)
bulk-only transport scsi command read10
Definition: msc/msc_bot_scsi.c:602
bot_scsi_check_address
usb_sts_type bot_scsi_check_address(void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address
Definition: msc/msc_bot_scsi.c:307
bot_scsi_write10
usb_sts_type bot_scsi_write10(void *udev, uint8_t lun)
bulk-only transport scsi command write10
Definition: msc/msc_bot_scsi.c:663
bot_scsi_reset
void bot_scsi_reset(void *udev)
reset bulk-only transport and scsi
Definition: msc/msc_bot_scsi.c:128
bot_scsi_mode_sense10
usb_sts_type bot_scsi_mode_sense10(void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10
Definition: msc/msc_bot_scsi.c:461
bot_scsi_sense_code
void bot_scsi_sense_code(void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code
Definition: msc/msc_bot_scsi.c:292
bot_cbw_decode
void bot_cbw_decode(void *udev)
bulk-only cbw decode
Definition: msc/msc_bot_scsi.c:200
bot_scsi_verify
usb_sts_type bot_scsi_verify(void *udev, uint8_t lun)
bulk-only transport scsi command verify
Definition: msc/msc_bot_scsi.c:574
bot_scsi_allow_medium_removal
usb_sts_type bot_scsi_allow_medium_removal(void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal
Definition: msc/msc_bot_scsi.c:427
usb_vcp_send_data
error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_class.c:369
bot_scsi_init
void bot_scsi_init(void *udev)
initialize bulk-only transport and scsi
Definition: msc/msc_bot_scsi.c:104
bot_scsi_cmd_process
usb_sts_type bot_scsi_cmd_process(void *udev)
bulk-only transport scsi command process
Definition: msc/msc_bot_scsi.c:753
bot_scsi_dataout_handler
void bot_scsi_dataout_handler(void *pudev, uint8_t ept_num)
bulk-only transport data out handler
Definition: msc/msc_bot_scsi.c:176
bot_scsi_mode_sense6
usb_sts_type bot_scsi_mode_sense6(void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6
Definition: msc/msc_bot_scsi.c:441
bot_scsi_stall
void bot_scsi_stall(void *udev)
bot endpoint stall
Definition: msc/msc_bot_scsi.c:324
bot_scsi_send_data
void bot_scsi_send_data(void *udev, uint8_t *buffer, uint32_t len)
send bot data
Definition: msc/msc_bot_scsi.c:247
bot_scsi_test_unit
usb_sts_type bot_scsi_test_unit(void *udev, uint8_t lun)
bulk-only transport scsi command test unit
Definition: msc/msc_bot_scsi.c:350
bot_scsi_inquiry
usb_sts_type bot_scsi_inquiry(void *udev, uint8_t lun)
bulk-only transport scsi command inquiry
Definition: msc/msc_bot_scsi.c:372
bot_scsi_capacity
usb_sts_type bot_scsi_capacity(void *udev, uint8_t lun)
bulk-only transport scsi command capacity
Definition: msc/msc_bot_scsi.c:481
cdc_msc_class_handler
usbd_class_handler cdc_msc_class_handler
Definition: cdc_msc_class.c:72
bot_scsi_clear_feature
void bot_scsi_clear_feature(void *udev, uint8_t ept_num)
clear feature
Definition: msc/msc_bot_scsi.c:733
bot_scsi_send_csw
void bot_scsi_send_csw(void *udev, uint8_t status)
send command status
Definition: msc/msc_bot_scsi.c:268
MSC_MAX_DATA_BUF_LEN
#define MSC_MAX_DATA_BUF_LEN
Definition: cdc_msc_class.h:84
MSC_SUPPORT_MAX_LUN
#define MSC_SUPPORT_MAX_LUN
Definition: cdc_msc_class.h:83
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
cbd_extended_type
extended command block description
Definition: cdc_msc_class.h:176
cbd_typical_type
typical command block description
Definition: cdc_msc_class.h:163
cbw_type
command block wrapper
Definition: cdc_msc_class.h:189
cdc_msc_struct_type
usb cdc class struct
Definition: cdc_msc_class.h:253
csw_type
command block wrapper
Definition: cdc_msc_class.h:203
linecoding_type
usb cdc class set line coding struct
Definition: usb_std.h:213
msc_type
Definition: cdc_msc_class.h:228
sense_type
request sense standard data
Definition: cdc_msc_class.h:214
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: cdc_msc_desc.c Source File

  • middlewares
  • usbd_class
  • composite_cdc_msc
cdc_msc_desc.c
Go to the documentation of this file.
1
26#include "stdio.h"
27#include "usb_std.h"
28#include "usbd_sdr.h"
29#include "usbd_core.h"
30#include "cdc_msc_desc.h"
31
45#define USB_INTERFACE_ASSOCIATION_TYPE 0x0B
46
47static usbd_desc_t *get_device_descriptor(void);
48static usbd_desc_t *get_device_qualifier(void);
49static usbd_desc_t *get_device_configuration(void);
50static usbd_desc_t *get_device_other_speed(void);
51static usbd_desc_t *get_device_lang_id(void);
52static usbd_desc_t *get_device_manufacturer_string(void);
53static usbd_desc_t *get_device_product_string(void);
54static usbd_desc_t *get_device_serial_string(void);
55static usbd_desc_t *get_device_interface_string(void);
56static usbd_desc_t *get_device_config_string(void);
57
58static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
59static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
60static void get_serial_num(void);
61static uint8_t g_usbd_desc_buffer[256];
62
66usbd_desc_handler cdc_msc_desc_handler =
67{
68 get_device_descriptor,
69 get_device_qualifier,
70 get_device_configuration,
71 get_device_other_speed,
72 get_device_lang_id,
73 get_device_manufacturer_string,
74 get_device_product_string,
75 get_device_serial_string,
76 get_device_interface_string,
77 get_device_config_string,
78};
79
83#if defined ( __ICCARM__ ) /* iar compiler */
84 #pragma data_alignment=4
85#endif
86ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
87{
88 USB_DEVICE_DESC_LEN, /* bLength */
89 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
90 0x00, /* bcdUSB */
91 0x02,
92 0xEF, /* bDeviceClass */
93 0x02, /* bDeviceSubClass */
94 0x01, /* bDeviceProtocol */
95 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
96 LBYTE(USBD_CDC_MSC_VENDOR_ID), /* idVendor */
97 HBYTE(USBD_CDC_MSC_VENDOR_ID), /* idVendor */
98 LBYTE(USBD_CDC_MSC_PRODUCT_ID), /* idProduct */
99 HBYTE(USBD_CDC_MSC_PRODUCT_ID), /* idProduct */
100 0x00, /* bcdDevice rel. 2.00 */
101 0x02,
102 USB_MFC_STRING, /* Index of manufacturer string */
103 USB_PRODUCT_STRING, /* Index of product string */
104 USB_SERIAL_STRING, /* Index of serial number string */
105 1 /* bNumConfigurations */
106};
107
111#if defined ( __ICCARM__ ) /* iar compiler */
112 #pragma data_alignment=4
113#endif
114ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_CDC_MSC_CONFIG_DESC_SIZE] ALIGNED_TAIL =
115{
116 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
117 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
118 LBYTE(USBD_CDC_MSC_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
119 HBYTE(USBD_CDC_MSC_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
120 0x03, /* bNumInterfaces: 3 interface */
121 0x01, /* bConfigurationValue: configuration value */
122 0x00, /* iConfiguration: index of string descriptor describing
123 the configuration */
124 0xC0, /* bmAttributes: self powered */
125 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
126
127 // IAD (Interface Association Descriptor) for MSC
128 0x08, /* bLength */
129 USB_INTERFACE_ASSOCIATION_TYPE, /* bDescriptorType */
130 0x00, /* bFirstInterface */
131 0x01, /* bInterfaceCount */
132 0x08, /* bFunctionClass */
133 0x06, /* bFunctionSubClass */
134 0x50, /* bFunctionProtocol */
135 0x00, /* iFunction (Index of string descriptor describing this function) */
136
137 // Configuration Descriptor for MSC
138 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
139 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
140 VCPMSC_MSC_INTERFACE, /* bInterfaceNumber: number of interface */
141 0x00, /* bAlternateSetting: alternate set */
142 0x02, /* bNumEndpoints: number of endpoints */
143 USB_CLASS_CODE_MSC, /* bInterfaceClass: msc class code */
144 0x06, /* bInterfaceSubClass: subclass code scsi */
145 0x50, /* bInterfaceProtocol: protocol code BBB */
146 0x00, /* iInterface: index of string descriptor */
147
148 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
149 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
150 USBD_MSC_BULK_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
151 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
152 LBYTE(USBD_CDC_MSC_IN_MAXPACKET_SIZE),
153 HBYTE(USBD_CDC_MSC_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
154 0x00, /* bInterval: interval for polling endpoint for data transfers */
155
156 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
157 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
158 USBD_MSC_BULK_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
159 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
160 LBYTE(USBD_CDC_MSC_OUT_MAXPACKET_SIZE),
161 HBYTE(USBD_CDC_MSC_OUT_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
162 0x00, /* bInterval: interval for polling endpoint for data transfers */
163
164 // IAD (Interface Association Descriptor) for CDC
165 0x08, /* bLength */
166 USB_INTERFACE_ASSOCIATION_TYPE, /* bDescriptorType */
167 0x01, /* bFirstInterface */
168 0x02, /* bInterfaceCount */
169 USB_CLASS_CODE_CDC, /* bFunctionClass */
170 0x02, /* bFunctionSubClass */
171 0x01, /* bFunctionProtocol */
172 0x00, /* iFunction (Index of string descriptor describing this function) */
173
174 // Configuration Descriptor for CDC
175 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
176 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
177 VCPMSC_CDC_INTERFACE, /* bInterfaceNumber: number of interface */
178 0x00, /* bAlternateSetting: alternate set */
179 0x01, /* bNumEndpoints: number of endpoints */
180 USB_CLASS_CODE_CDC, /* bInterfaceClass: CDC class code */
181 0x02, /* bInterfaceSubClass: subclass code, Abstract Control Model*/
182 0x01, /* bInterfaceProtocol: protocol code, AT Command */
183 0x00, /* iInterface: index of string descriptor */
184
185 0x05, /* bFunctionLength: size of this descriptor in bytes */
186 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
187 USBD_CDC_SUBTYPE_HEADER, /* bDescriptorSubtype: Header function Descriptor 0x00*/
188 LBYTE(CDC_BCD_NUM),
189 HBYTE(CDC_BCD_NUM), /* bcdCDC: USB class definitions for communications */
190
191 0x05, /* bFunctionLength: size of this descriptor in bytes */
192 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
193 USBD_CDC_SUBTYPE_CMF, /* bDescriptorSubtype: Call Management function descriptor subtype 0x01 */
194 0x00, /* bmCapabilities: 0x00*/
195 0x01, /* bDataInterface: interface number of data class interface optionally used for call management */
196
197 0x04, /* bFunctionLength: size of this descriptor in bytes */
198 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
199 USBD_CDC_SUBTYPE_ACM, /* bDescriptorSubtype: Abstract Control Management functional descriptor subtype 0x02 */
200 0x02, /* bmCapabilities: Support Set_Line_Coding and Get_Line_Coding 0x02 */
201
202 0x05, /* bFunctionLength: size of this descriptor in bytes */
203 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
204 USBD_CDC_SUBTYPE_UFD, /* bDescriptorSubtype: Union Function Descriptor subtype 0x06 */
205 0x00, /* bControlInterface: The interface number of the communications or data class interface 0x00 */
206 0x01, /* bSubordinateInterface0: interface number of first subordinate interface in the union */
207
208 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
209 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
210 USBD_CDC_INT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
211 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
212 LBYTE(USBD_CDC_CMD_MAXPACKET_SIZE),
213 HBYTE(USBD_CDC_CMD_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
214 CDC_HID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
215
216
217 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
218 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
219 VCPMSC_CDC_DATA_INTERFACE, /* bInterfaceNumber: number of interface */
220 0x00, /* bAlternateSetting: alternate set */
221 0x02, /* bNumEndpoints: number of endpoints */
222 USB_CLASS_CODE_CDCDATA, /* bInterfaceClass: CDC-data class code */
223 0x00, /* bInterfaceSubClass: Data interface subclass code 0x00*/
224 0x00, /* bInterfaceProtocol: data class protocol code 0x00 */
225 0x00, /* iInterface: index of string descriptor */
226
227 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
228 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
229 USBD_CDC_BULK_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
230 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
231 LBYTE(USBD_CDC_MSC_IN_MAXPACKET_SIZE),
232 HBYTE(USBD_CDC_MSC_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
233 0x00, /* bInterval: interval for polling endpoint for data transfers */
234
235 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
236 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
237 USBD_CDC_BULK_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
238 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
239 LBYTE(USBD_CDC_MSC_OUT_MAXPACKET_SIZE),
240 HBYTE(USBD_CDC_MSC_OUT_MAXPACKET_SIZE),/* wMaxPacketSize: maximum packe size this endpoint */
241 0x00, /* bInterval: interval for polling endpoint for data transfers */
242
243
244};
245
249#if defined ( __ICCARM__ ) /* iar compiler */
250 #pragma data_alignment=4
251#endif
252ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_CDC_SIZ_STRING_LANGID] ALIGNED_TAIL =
253{
254 USBD_CDC_SIZ_STRING_LANGID,
255 USB_DESCIPTOR_TYPE_STRING,
256 0x09,
257 0x04,
258};
259
263#if defined ( __ICCARM__ ) /* iar compiler */
264 #pragma data_alignment=4
265#endif
266ALIGNED_HEAD static uint8_t g_string_serial[USBD_CDC_SIZ_STRING_SERIAL] ALIGNED_TAIL =
267{
268 USBD_CDC_SIZ_STRING_SERIAL,
269 USB_DESCIPTOR_TYPE_STRING,
270};
271
272
273/* device descriptor */
274static usbd_desc_t device_descriptor =
275{
276 USB_DEVICE_DESC_LEN,
277 g_usbd_descriptor
278};
279
280/* config descriptor */
281static usbd_desc_t config_descriptor =
282{
283 USBD_CDC_MSC_CONFIG_DESC_SIZE,
284 g_usbd_configuration
285};
286
287/* langid descriptor */
288static usbd_desc_t langid_descriptor =
289{
290 USBD_CDC_SIZ_STRING_LANGID,
291 g_string_lang_id
292};
293
294/* serial descriptor */
295static usbd_desc_t serial_descriptor =
296{
297 USBD_CDC_SIZ_STRING_SERIAL,
298 g_string_serial
299};
300
301static usbd_desc_t vp_desc;
302
309static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
310{
311 uint16_t str_len = 0, id_pos = 2;
312 uint8_t *tmp_str = string;
313
314 while(*tmp_str != '\0')
315 {
316 str_len ++;
317 unicode_buf[id_pos ++] = *tmp_str ++;
318 unicode_buf[id_pos ++] = 0x00;
319 }
320
321 str_len = str_len * 2 + 2;
322 unicode_buf[0] = (uint8_t)str_len;
323 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
324
325 return str_len;
326}
327
335static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
336{
337 uint8_t idx = 0;
338
339 for( idx = 0 ; idx < len ; idx ++)
340 {
341 if( ((value >> 28)) < 0xA )
342 {
343 pbuf[ 2 * idx] = (value >> 28) + '0';
344 }
345 else
346 {
347 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
348 }
349
350 value = value << 4;
351
352 pbuf[2 * idx + 1] = 0;
353 }
354}
355
361static void get_serial_num(void)
362{
363 uint32_t serial0, serial1, serial2;
364
365 serial0 = *(uint32_t*)MCU_ID1;
366 serial1 = *(uint32_t*)MCU_ID2;
367 serial2 = *(uint32_t*)MCU_ID3;
368
369 serial0 += serial2;
370
371 if (serial0 != 0)
372 {
373 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
374 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
375 }
376}
377
383static usbd_desc_t *get_device_descriptor(void)
384{
385 return &device_descriptor;
386}
387
393static usbd_desc_t * get_device_qualifier(void)
394{
395 return NULL;
396}
397
403static usbd_desc_t *get_device_configuration(void)
404{
405 return &config_descriptor;
406}
407
413static usbd_desc_t *get_device_other_speed(void)
414{
415 return NULL;
416}
417
423static usbd_desc_t *get_device_lang_id(void)
424{
425 return &langid_descriptor;
426}
427
428
434static usbd_desc_t *get_device_manufacturer_string(void)
435{
436 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CDC_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
437 vp_desc.descriptor = g_usbd_desc_buffer;
438 return &vp_desc;
439}
440
446static usbd_desc_t *get_device_product_string(void)
447{
448 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CDC_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
449 vp_desc.descriptor = g_usbd_desc_buffer;
450 return &vp_desc;
451}
452
458static usbd_desc_t *get_device_serial_string(void)
459{
460 get_serial_num();
461 return &serial_descriptor;
462}
463
469static usbd_desc_t *get_device_interface_string(void)
470{
471 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CDC_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
472 vp_desc.descriptor = g_usbd_desc_buffer;
473 return &vp_desc;
474}
475
481static usbd_desc_t *get_device_config_string(void)
482{
483 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CDC_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
484 vp_desc.descriptor = g_usbd_desc_buffer;
485 return &vp_desc;
486}
487
cdc_msc_desc.h
usb cdc descriptor header file
idx
uint32_t idx
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:46
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:215
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:216
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:217
USBD_CDC_CMD_MAXPACKET_SIZE
#define USBD_CDC_CMD_MAXPACKET_SIZE
Definition: cdc_class.h:62
USBD_CDC_MSC_OUT_MAXPACKET_SIZE
#define USBD_CDC_MSC_OUT_MAXPACKET_SIZE
Definition: cdc_msc_class.h:65
USBD_CDC_BULK_OUT_EPT
#define USBD_CDC_BULK_OUT_EPT
Definition: cdc_class.h:55
USBD_CDC_MSC_IN_MAXPACKET_SIZE
#define USBD_CDC_MSC_IN_MAXPACKET_SIZE
usb cdc in and out max packet size define
Definition: cdc_msc_class.h:63
USBD_CDC_INT_EPT
#define USBD_CDC_INT_EPT
usb cdc use endpoint define
Definition: cdc_class.h:53
USBD_CDC_BULK_IN_EPT
#define USBD_CDC_BULK_IN_EPT
Definition: cdc_class.h:54
USBD_MSC_BULK_IN_EPT
#define USBD_MSC_BULK_IN_EPT
Definition: cdc_msc_class.h:57
USBD_MSC_BULK_OUT_EPT
#define USBD_MSC_BULK_OUT_EPT
Definition: cdc_msc_class.h:58
CDC_BCD_NUM
#define CDC_BCD_NUM
usb bcd number define
Definition: cdc_desc.h:52
USBD_CDC_DESC_MANUFACTURER_STRING
#define USBD_CDC_DESC_MANUFACTURER_STRING
usb string define(vendor, product configuration, interface)
Definition: cdc_desc.h:70
USBD_CDC_DESC_CONFIGURATION_STRING
#define USBD_CDC_DESC_CONFIGURATION_STRING
Definition: cdc_desc.h:72
USBD_CDC_SIZ_STRING_LANGID
#define USBD_CDC_SIZ_STRING_LANGID
Definition: cdc_desc.h:64
USBD_CDC_DESC_PRODUCT_STRING
#define USBD_CDC_DESC_PRODUCT_STRING
Definition: cdc_desc.h:71
VCPMSC_MSC_INTERFACE
#define VCPMSC_MSC_INTERFACE
usb interface define
Definition: cdc_msc_desc.h:84
USBD_CDC_MSC_CONFIG_DESC_SIZE
#define USBD_CDC_MSC_CONFIG_DESC_SIZE
usb descriptor size define
Definition: cdc_msc_desc.h:64
CDC_HID_BINTERVAL_TIME
#define CDC_HID_BINTERVAL_TIME
usb endpoint interval define
Definition: cdc_desc.h:78
VCPMSC_CDC_INTERFACE
#define VCPMSC_CDC_INTERFACE
Definition: cdc_msc_desc.h:85
USBD_CDC_SIZ_STRING_SERIAL
#define USBD_CDC_SIZ_STRING_SERIAL
Definition: cdc_desc.h:65
USBD_CDC_DESC_INTERFACE_STRING
#define USBD_CDC_DESC_INTERFACE_STRING
Definition: cdc_desc.h:73
USBD_CDC_MSC_PRODUCT_ID
#define USBD_CDC_MSC_PRODUCT_ID
Definition: cdc_msc_desc.h:58
VCPMSC_CDC_DATA_INTERFACE
#define VCPMSC_CDC_DATA_INTERFACE
Definition: cdc_msc_desc.h:86
USBD_CDC_MSC_VENDOR_ID
#define USBD_CDC_MSC_VENDOR_ID
usb vendor id and product id define
Definition: cdc_msc_desc.h:57
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: cdc_msc_desc.c:295
cdc_msc_desc_handler
usbd_desc_handler cdc_msc_desc_handler
device descriptor handler structure
Definition: cdc_msc_desc.c:66
USB_INTERFACE_ASSOCIATION_TYPE
#define USB_INTERFACE_ASSOCIATION_TYPE
Definition: cdc_msc_desc.c:45
device_descriptor
static usbd_desc_t device_descriptor
Definition: cdc_msc_desc.c:274
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: cdc_msc_desc.c:403
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: cdc_msc_desc.c:288
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: cdc_msc_desc.c:383
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: cdc_msc_desc.c:434
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: cdc_msc_desc.c:393
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: cdc_msc_desc.c:469
g_usbd_desc_buffer
static uint8_t g_usbd_desc_buffer[256]
Definition: cdc_msc_desc.c:61
vp_desc
static usbd_desc_t vp_desc
Definition: cdc_msc_desc.c:301
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: cdc_msc_desc.c:413
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL
usb device standard descriptor
Definition: cdc_msc_desc.c:86
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: cdc_msc_desc.c:446
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: cdc_msc_desc.c:481
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: cdc_msc_desc.c:309
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: cdc_msc_desc.c:423
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: cdc_msc_desc.c:361
config_descriptor
static usbd_desc_t config_descriptor
Definition: cdc_msc_desc.c:281
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: cdc_msc_desc.c:458
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: cdc_msc_desc.c:335
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:153
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:93
USB_CLASS_CODE_MSC
#define USB_CLASS_CODE_MSC
Definition: usb_std.h:165
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:96
USBD_CDC_SUBTYPE_CMF
#define USBD_CDC_SUBTYPE_CMF
Definition: usb_std.h:199
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_EPT_DESC_BULK
#define USB_EPT_DESC_BULK
Definition: usb_std.h:177
USBD_CDC_SUBTYPE_HEADER
#define USBD_CDC_SUBTYPE_HEADER
usb cdc class sub-type define
Definition: usb_std.h:198
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:152
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:151
USBD_CDC_CS_INTERFACE
#define USBD_CDC_CS_INTERFACE
usb cdc class descriptor define
Definition: usb_std.h:192
USB_EPT_DESC_INTERRUPT
#define USB_EPT_DESC_INTERRUPT
Definition: usb_std.h:178
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92
USB_CLASS_CODE_CDCDATA
#define USB_CLASS_CODE_CDCDATA
Definition: usb_std.h:167
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:94
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:95
USB_CLASS_CODE_CDC
#define USB_CLASS_CODE_CDC
Definition: usb_std.h:162
USBD_CDC_SUBTYPE_UFD
#define USBD_CDC_SUBTYPE_UFD
Definition: usb_std.h:201
USBD_CDC_SUBTYPE_ACM
#define USBD_CDC_SUBTYPE_ACM
Definition: usb_std.h:200
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h


AT32F435/437 Firmwary Library: cdc_msc_desc.h Source File

  • middlewares
  • usbd_class
  • composite_cdc_msc
cdc_msc_desc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __CDC_MSC_DESC_H
29#define __CDC_MSC_DESC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "cdc_msc_class.h"
36#include "usbd_core.h"
37
52#define CDC_BCD_NUM 0x0110
53
57#define USBD_CDC_MSC_VENDOR_ID 0x2E3C
58#define USBD_CDC_MSC_PRODUCT_ID 0x5760
59
64#define USBD_CDC_MSC_CONFIG_DESC_SIZE 106
65#define USBD_CDC_SIZ_STRING_LANGID 4
66#define USBD_CDC_SIZ_STRING_SERIAL 0x1A
67
71#define USBD_CDC_DESC_MANUFACTURER_STRING "Artery"
72#define USBD_CDC_DESC_PRODUCT_STRING "AT32 Composite VCP and MSC "
73#define USBD_CDC_DESC_CONFIGURATION_STRING "Composite VCP and MSC Config"
74#define USBD_CDC_DESC_INTERFACE_STRING "Composite VCP and MSC Interface"
75
79#define CDC_HID_BINTERVAL_TIME 0xFF
80
84#define VCPMSC_MSC_INTERFACE 0x00
85#define VCPMSC_CDC_INTERFACE 0x01
86#define VCPMSC_CDC_DATA_INTERFACE 0x02
87
88
92#define MCU_ID1 (0x1FFFF7E8)
93#define MCU_ID2 (0x1FFFF7EC)
94#define MCU_ID3 (0x1FFFF7F0)
99extern usbd_desc_handler cdc_msc_desc_handler;
100
101
109#ifdef __cplusplus
110}
111#endif
112
113#endif
cdc_msc_class.h
usb cdc class file
cdc_msc_desc_handler
usbd_desc_handler cdc_msc_desc_handler
device descriptor handler structure
Definition: cdc_msc_desc.c:66
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: msc_bot_scsi.c Source File

  • middlewares
  • usbd_class
  • composite_cdc_msc
composite_cdc_msc/msc_bot_scsi.c
Go to the documentation of this file.
1
26#include "cdc_msc_class.h"
27#include "msc_diskio.h"
28
43#if defined ( __ICCARM__ ) /* iar compiler */
44 #pragma data_alignment=4
45#endif
46ALIGNED_HEAD uint8_t page00_inquiry_data[] ALIGNED_TAIL = {
47 0x00,
48 0x00,
49 0x00,
50 0x00,
51 0x00,
52
53};
54#if defined ( __ICCARM__ ) /* iar compiler */
55 #pragma data_alignment=4
56#endif
57ALIGNED_HEAD sense_type sense_data ALIGNED_TAIL =
58{
59 0x70,
60 0x00,
61 SENSE_KEY_ILLEGAL_REQUEST,
62 0x00000000,
63 0x0A,
64 0x00000000,
65 0x20,
66 0x00,
67 0x00000000
68};
69
70#if defined ( __ICCARM__ ) /* iar compiler */
71 #pragma data_alignment=4
72#endif
73ALIGNED_HEAD uint8_t mode_sense6_data[8] ALIGNED_TAIL =
74{
75 0x00,
76 0x00,
77 0x00,
78 0x00,
79 0x00,
80 0x00,
81 0x00,
82 0x00
83};
84
85#if defined ( __ICCARM__ ) /* iar compiler */
86 #pragma data_alignment=4
87#endif
88ALIGNED_HEAD uint8_t mode_sense10_data[8] ALIGNED_TAIL =
89{
90 0x00,
91 0x06,
92 0x00,
93 0x00,
94 0x00,
95 0x00,
96 0x00,
97 0x00
98};
104void bot_scsi_init(void *udev)
105{
106 usbd_core_type *pudev = (usbd_core_type *)udev;
107 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
108 pmsc->msc_state = MSC_STATE_MACHINE_IDLE;
109 pmsc->bot_status = MSC_BOT_STATE_IDLE;
110 pmsc->max_lun = MSC_SUPPORT_MAX_LUN - 1;
111
112 pmsc->csw_struct.dCSWSignature = CSW_DCSWSIGNATURE;
113 pmsc->csw_struct.dCSWDataResidue = 0;
114 pmsc->csw_struct.dCSWSignature = 0;
115 pmsc->csw_struct.dCSWTag = CSW_BCSWSTATUS_PASS;
116
117 usbd_flush_tx_fifo(pudev, USBD_MSC_BULK_IN_EPT&0x7F);
118
119 /* set out endpoint to receive status */
120 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT, (uint8_t *)&pmsc->cbw_struct, CBW_CMD_LENGTH);
121}
122
128void bot_scsi_reset(void *udev)
129{
130 usbd_core_type *pudev = (usbd_core_type *)udev;
131 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
132 pmsc->msc_state = MSC_STATE_MACHINE_IDLE;
133 pmsc->bot_status = MSC_BOT_STATE_RECOVERY;
134 pmsc->max_lun = MSC_SUPPORT_MAX_LUN - 1;
135 usbd_flush_tx_fifo(pudev, USBD_MSC_BULK_IN_EPT&0x7F);
136
137 /* set out endpoint to receive status */
138 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT, (uint8_t *)&pmsc->cbw_struct, CBW_CMD_LENGTH);
139}
140
147void bot_scsi_datain_handler(void *udev, uint8_t ept_num)
148{
149 usbd_core_type *pudev = (usbd_core_type *)udev;
150 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
151 switch(pmsc->msc_state)
152 {
153 case MSC_STATE_MACHINE_DATA_IN:
154 if(bot_scsi_cmd_process(udev) != USB_OK)
155 {
156 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_FAILED);
157 }
158 break;
159
160 case MSC_STATE_MACHINE_LAST_DATA:
161 case MSC_STATE_MACHINE_SEND_DATA:
162 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_PASS);
163 break;
164
165 default:
166 break;
167 }
168}
169
176void bot_scsi_dataout_handler(void *udev, uint8_t ept_num)
177{
178 usbd_core_type *pudev = (usbd_core_type *)udev;
179 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
180 switch(pmsc->msc_state)
181 {
182 case MSC_STATE_MACHINE_IDLE:
183 bot_cbw_decode(udev);
184 break;
185
186 case MSC_STATE_MACHINE_DATA_OUT:
187 if(bot_scsi_cmd_process(udev) != USB_OK)
188 {
189 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_FAILED);
190 }
191 break;
192 }
193}
194
200void bot_cbw_decode(void *udev)
201{
202 usbd_core_type *pudev = (usbd_core_type *)udev;
203 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
204
205 pmsc->csw_struct.dCSWTag = pmsc->cbw_struct.dCBWTage;
206 pmsc->csw_struct.dCSWDataResidue = pmsc->cbw_struct.dCBWDataTransferLength;
207
208 /* check param */
209 if((pmsc->cbw_struct.dCBWSignature != CBW_DCBWSIGNATURE) ||
210 (usbd_get_recv_len(pudev, USBD_MSC_BULK_OUT_EPT) != CBW_CMD_LENGTH)
211 || (pmsc->cbw_struct.bCBWLUN > MSC_SUPPORT_MAX_LUN) ||
212 (pmsc->cbw_struct.bCBWCBLength < 1) || (pmsc->cbw_struct.bCBWCBLength > 16))
213 {
214 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
215 pmsc->bot_status = MSC_BOT_STATE_ERROR;
216 bot_scsi_stall(udev);
217 }
218 else
219 {
220 if(bot_scsi_cmd_process(udev) != USB_OK)
221 {
222 bot_scsi_stall(udev);
223 }
224 else if((pmsc->msc_state != MSC_STATE_MACHINE_DATA_IN) &&
225 (pmsc->msc_state != MSC_STATE_MACHINE_DATA_OUT) &&
226 (pmsc->msc_state != MSC_STATE_MACHINE_LAST_DATA))
227 {
228 if(pmsc->data_len == 0)
229 {
230 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_PASS);
231 }
232 else if(pmsc->data_len > 0)
233 {
234 bot_scsi_send_data(udev, pmsc->data, pmsc->data_len);
235 }
236 }
237 }
238}
239
247void bot_scsi_send_data(void *udev, uint8_t *buffer, uint32_t len)
248{
249 usbd_core_type *pudev = (usbd_core_type *)udev;
250 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
251 uint32_t data_len = MIN(len, pmsc->cbw_struct.dCBWDataTransferLength);
252
253 pmsc->csw_struct.dCSWDataResidue -= data_len;
254 pmsc->csw_struct.bCSWStatus = CSW_BCSWSTATUS_PASS;
255
256 pmsc->msc_state = MSC_STATE_MACHINE_SEND_DATA;
257
258 usbd_ept_send(pudev, USBD_MSC_BULK_IN_EPT,
259 buffer, data_len);
260}
261
268void bot_scsi_send_csw(void *udev, uint8_t status)
269{
270 usbd_core_type *pudev = (usbd_core_type *)udev;
271 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
272
273 pmsc->csw_struct.bCSWStatus = status;
274 pmsc->csw_struct.dCSWSignature = CSW_DCSWSIGNATURE;
275 pmsc->msc_state = MSC_STATE_MACHINE_IDLE;
276
277 usbd_ept_send(pudev, USBD_MSC_BULK_IN_EPT,
278 (uint8_t *)&pmsc->csw_struct, CSW_CMD_LENGTH);
279
280 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT,
281 (uint8_t *)&pmsc->cbw_struct, CBW_CMD_LENGTH);
282}
283
284
292void bot_scsi_sense_code(void *udev, uint8_t sense_key, uint8_t asc)
293{
294 sense_data.sense_key = sense_key;
295 sense_data.asc = asc;
296}
297
298
307 usb_sts_type bot_scsi_check_address(void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
308{
309 usbd_core_type *pudev = (usbd_core_type *)udev;
310 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
311 if((blk_offset + blk_count) > pmsc->blk_nbr[lun])
312 {
313 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, ADDRESS_OUT_OF_RANGE);
314 return USB_FAIL;
315 }
316 return USB_OK;
317}
318
324void bot_scsi_stall(void *udev)
325{
326 usbd_core_type *pudev = (usbd_core_type *)udev;
327 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
328
329 if((pmsc->cbw_struct.dCBWDataTransferLength != 0) &&
330 (pmsc->cbw_struct.bmCBWFlags == 0) &&
331 pmsc->bot_status == MSC_BOT_STATE_IDLE)
332 {
333 usbd_set_stall(pudev, USBD_MSC_BULK_OUT_EPT);
334 }
335 usbd_set_stall(pudev, USBD_MSC_BULK_IN_EPT);
336
337 if(pmsc->bot_status == MSC_BOT_STATE_ERROR)
338 {
339 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT,
340 (uint8_t *)&pmsc->cbw_struct, CBW_CMD_LENGTH);
341 }
342}
343
350 usb_sts_type bot_scsi_test_unit(void *udev, uint8_t lun)
351{
352 usb_sts_type status = USB_OK;
353 usbd_core_type *pudev = (usbd_core_type *)udev;
354 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
355
356 if(pmsc->cbw_struct.dCBWDataTransferLength != 0)
357 {
358 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
359 return USB_FAIL;
360 }
361
362 pmsc->data_len = 0;
363 return status;
364}
365
372 usb_sts_type bot_scsi_inquiry(void *udev, uint8_t lun)
373{
374 uint8_t *pdata;
375 uint32_t trans_len = 0;
376 usb_sts_type status = USB_OK;
377 usbd_core_type *pudev = (usbd_core_type *)udev;
378 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
379
380 if(pmsc->cbw_struct.CBWCB[1] & 0x01)
381 {
382 pdata = page00_inquiry_data;
383 trans_len = 5;
384 }
385 else
386 {
387 pdata = get_inquiry(lun);
388 if(pmsc->cbw_struct.dCBWDataTransferLength < SCSI_INQUIRY_DATA_LENGTH)
389 {
390 trans_len = pmsc->cbw_struct.dCBWDataTransferLength;
391 }
392 else
393 {
394 trans_len = SCSI_INQUIRY_DATA_LENGTH;
395 }
396 }
397
398 pmsc->data_len = trans_len;
399 while(trans_len)
400 {
401 trans_len --;
402 pmsc->data[trans_len] = pdata[trans_len];
403 }
404 return status;
405}
406
413 usb_sts_type bot_scsi_start_stop(void *udev, uint8_t lun)
414{
415 usbd_core_type *pudev = (usbd_core_type *)udev;
416 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
417 pmsc->data_len = 0;
418 return USB_OK;
419}
420
427 usb_sts_type bot_scsi_allow_medium_removal(void *udev, uint8_t lun)
428{
429 usbd_core_type *pudev = (usbd_core_type *)udev;
430 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
431 pmsc->data_len = 0;
432 return USB_OK;
433}
434
441 usb_sts_type bot_scsi_mode_sense6(void *udev, uint8_t lun)
442{
443 uint8_t data_len = 8;
444 usbd_core_type *pudev = (usbd_core_type *)udev;
445 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
446 pmsc->data_len = 8;
447 while(data_len)
448 {
449 data_len --;
450 pmsc->data[data_len] = mode_sense6_data[data_len];
451 };
452 return USB_OK;
453}
454
461 usb_sts_type bot_scsi_mode_sense10(void *udev, uint8_t lun)
462{
463 uint8_t data_len = 8;
464 usbd_core_type *pudev = (usbd_core_type *)udev;
465 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
466 pmsc->data_len = 8;
467 while(data_len)
468 {
469 data_len --;
470 pmsc->data[data_len] = mode_sense10_data[data_len];
471 };
472 return USB_OK;
473}
474
481 usb_sts_type bot_scsi_capacity(void *udev, uint8_t lun)
482{
483 usbd_core_type *pudev = (usbd_core_type *)udev;
484 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
485 uint8_t *pdata = pmsc->data;
486 msc_disk_capacity(lun, &pmsc->blk_nbr[lun], &pmsc->blk_size[lun]);
487
488 pdata[0] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 24);
489 pdata[1] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 16);
490 pdata[2] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 8);
491 pdata[3] = (uint8_t)((pmsc->blk_nbr[lun] - 1));
492
493 pdata[4] = (uint8_t)((pmsc->blk_size[lun]) >> 24);
494 pdata[5] = (uint8_t)((pmsc->blk_size[lun]) >> 16);
495 pdata[6] = (uint8_t)((pmsc->blk_size[lun]) >> 8);
496 pdata[7] = (uint8_t)((pmsc->blk_size[lun]));
497
498 pmsc->data_len = 8;
499 return USB_OK;
500}
501
508 usb_sts_type bot_scsi_format_capacity(void *udev, uint8_t lun)
509{
510 usbd_core_type *pudev = (usbd_core_type *)udev;
511 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
512 uint8_t *pdata = pmsc->data;
513
514 pdata[0] = 0;
515 pdata[1] = 0;
516 pdata[2] = 0;
517 pdata[3] = 0x08;
518
519 msc_disk_capacity(lun, &pmsc->blk_nbr[lun], &pmsc->blk_size[lun]);
520
521 pdata[4] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 24);
522 pdata[5] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 16);
523 pdata[6] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 8);
524 pdata[7] = (uint8_t)((pmsc->blk_nbr[lun] - 1));
525
526 pdata[8] = 0x02;
527
528 pdata[9] = (uint8_t)((pmsc->blk_size[lun]) >> 16);
529 pdata[10] = (uint8_t)((pmsc->blk_size[lun]) >> 8);
530 pdata[11] = (uint8_t)((pmsc->blk_size[lun]));
531
532 pmsc->data_len = 12;
533
534 return USB_OK;
535}
536
543 usb_sts_type bot_scsi_request_sense(void *udev, uint8_t lun)
544{
545 uint32_t trans_len = 0x12;
546 usbd_core_type *pudev = (usbd_core_type *)udev;
547 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
548 uint8_t *pdata = pmsc->data;
549 uint8_t *sdata = (uint8_t *)&sense_data;
550
551 while(trans_len)
552 {
553 trans_len --;
554 pdata[trans_len] = sdata[trans_len];
555 }
556
557 if(pmsc->cbw_struct.dCBWDataTransferLength < REQ_SENSE_STANDARD_DATA_LEN)
558 {
559 pmsc->data_len = pmsc->cbw_struct.dCBWDataTransferLength;
560 }
561 else
562 {
563 pmsc->data_len = REQ_SENSE_STANDARD_DATA_LEN;
564 }
565 return USB_OK;
566}
567
574 usb_sts_type bot_scsi_verify(void *udev, uint8_t lun)
575{
576 usbd_core_type *pudev = (usbd_core_type *)udev;
577 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
578 uint8_t *cmd = pmsc->cbw_struct.CBWCB;
579 if((pmsc->cbw_struct.CBWCB[1] & 0x02) == 0x02)
580 {
581 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_FIELED_IN_COMMAND);
582 return USB_FAIL;
583 }
584
585 pmsc->blk_addr = cmd[2] << 24 | cmd[3] << 16 | cmd[4] << 8 | cmd[5];
586 pmsc->blk_len = cmd[7] << 8 | cmd[8];
587
588 if(bot_scsi_check_address(udev, lun, pmsc->blk_addr, pmsc->blk_len) != USB_OK)
589 {
590 return USB_FAIL;
591 }
592 pmsc->data_len = 0;
593 return USB_OK;
594}
595
602 usb_sts_type bot_scsi_read10(void *udev, uint8_t lun)
603{
604 usbd_core_type *pudev = (usbd_core_type *)udev;
605 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
606 uint8_t *cmd = pmsc->cbw_struct.CBWCB;
607 uint32_t len;
608
609 if(pmsc->msc_state == MSC_STATE_MACHINE_IDLE)
610 {
611 if((pmsc->cbw_struct.bmCBWFlags & 0x80) != 0x80)
612 {
613 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
614 return USB_FAIL;
615 }
616
617 pmsc->blk_addr = cmd[2] << 24 | cmd[3] << 16 | cmd[4] << 8 | cmd[5];
618 pmsc->blk_len = cmd[7] << 8 | cmd[8];
619
620 if(bot_scsi_check_address(udev, lun, pmsc->blk_addr, pmsc->blk_len) != USB_OK)
621 {
622 return USB_FAIL;
623 }
624
625 pmsc->blk_addr *= pmsc->blk_size[lun];
626 pmsc->blk_len *= pmsc->blk_size[lun];
627
628 if(pmsc->cbw_struct.dCBWDataTransferLength != pmsc->blk_len)
629 {
630 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
631 return USB_FAIL;
632 }
633 pmsc->msc_state = MSC_STATE_MACHINE_DATA_IN;
634 }
635 pmsc->data_len = MSC_MAX_DATA_BUF_LEN;
636
637 len = MIN(pmsc->blk_len, MSC_MAX_DATA_BUF_LEN);
638 if( msc_disk_read(lun, pmsc->blk_addr, pmsc->data, len) != USB_OK)
639 {
640 bot_scsi_sense_code(udev, SENSE_KEY_HARDWARE_ERROR, MEDIUM_NOT_PRESENT);
641 return USB_FAIL;
642 }
643 usbd_ept_send(pudev, USBD_MSC_BULK_IN_EPT, pmsc->data, len);
644 pmsc->blk_addr += len;
645 pmsc->blk_len -= len;
646
647 pmsc->csw_struct.dCSWDataResidue -= len;
648 if(pmsc->blk_len == 0)
649 {
650 pmsc->msc_state = MSC_STATE_MACHINE_LAST_DATA;
651 }
652
653 return USB_OK;
654}
655
656
663 usb_sts_type bot_scsi_write10(void *udev, uint8_t lun)
664{
665 usbd_core_type *pudev = (usbd_core_type *)udev;
666 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
667 uint8_t *cmd = pmsc->cbw_struct.CBWCB;
668 uint32_t len;
669
670 if(pmsc->msc_state == MSC_STATE_MACHINE_IDLE)
671 {
672 if((pmsc->cbw_struct.bmCBWFlags & 0x80) == 0x80)
673 {
674 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
675 return USB_FAIL;
676 }
677
678 pmsc->blk_addr = cmd[2] << 24 | cmd[3] << 16 | cmd[4] << 8 | cmd[5];
679 pmsc->blk_len = cmd[7] << 8 | cmd[8];
680
681 if(bot_scsi_check_address(udev, lun, pmsc->blk_addr, pmsc->blk_len) != USB_OK)
682 {
683 return USB_FAIL;
684 }
685
686 pmsc->blk_addr *= pmsc->blk_size[lun];
687 pmsc->blk_len *= pmsc->blk_size[lun];
688
689 if(pmsc->cbw_struct.dCBWDataTransferLength != pmsc->blk_len)
690 {
691 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
692 return USB_FAIL;
693 }
694
695 pmsc->msc_state = MSC_STATE_MACHINE_DATA_OUT;
696 len = MIN(pmsc->blk_len, MSC_MAX_DATA_BUF_LEN);
697 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT, (uint8_t *)pmsc->data, len);
698
699 }
700 else
701 {
702 len = MIN(pmsc->blk_len, MSC_MAX_DATA_BUF_LEN);
703 if(msc_disk_write(lun, pmsc->blk_addr, pmsc->data, len) != USB_OK)
704 {
705 bot_scsi_sense_code(udev, SENSE_KEY_HARDWARE_ERROR, MEDIUM_NOT_PRESENT);
706 return USB_FAIL;
707 }
708
709 pmsc->blk_addr += len;
710 pmsc->blk_len -= len;
711
712 pmsc->csw_struct.dCSWDataResidue -= len;
713
714 if(pmsc->blk_len == 0)
715 {
716 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_PASS);
717 }
718 else
719 {
720 len = MIN(pmsc->blk_len, MSC_MAX_DATA_BUF_LEN);
721 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT, (uint8_t *)pmsc->data, len);
722 }
723 }
724 return USB_OK;
725}
726
733void bot_scsi_clear_feature(void *udev, uint8_t ept_num)
734{
735 usbd_core_type *pudev = (usbd_core_type *)udev;
736 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
737 if(pmsc->bot_status == MSC_BOT_STATE_ERROR)
738 {
739 usbd_set_stall(pudev, USBD_MSC_BULK_IN_EPT);
740 pmsc->bot_status = MSC_BOT_STATE_IDLE;
741 }
742 else if(((ept_num & 0x80) == 0x80) && (pmsc->bot_status != MSC_BOT_STATE_RECOVERY))
743 {
744 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_FAILED);
745 }
746}
747
753 usb_sts_type bot_scsi_cmd_process(void *udev)
754{
755 usb_sts_type status = USB_FAIL;
756 usbd_core_type *pudev = (usbd_core_type *)udev;
757 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
758 switch(pmsc->cbw_struct.CBWCB[0])
759 {
760 case MSC_CMD_INQUIRY:
761 status = bot_scsi_inquiry(udev, pmsc->cbw_struct.bCBWLUN);
762 break;
763
764 case MSC_CMD_START_STOP:
765 status = bot_scsi_start_stop(udev, pmsc->cbw_struct.bCBWLUN);
766 break;
767
768 case MSC_CMD_MODE_SENSE6:
769 status = bot_scsi_mode_sense6(udev, pmsc->cbw_struct.bCBWLUN);
770 break;
771
772 case MSC_CMD_MODE_SENSE10:
773 status = bot_scsi_mode_sense10(udev, pmsc->cbw_struct.bCBWLUN);
774 break;
775
776 case MSC_CMD_ALLOW_MEDIUM_REMOVAL:
777 status = bot_scsi_allow_medium_removal(udev, pmsc->cbw_struct.bCBWLUN);
778 break;
779
780 case MSC_CMD_READ_10:
781 status = bot_scsi_read10(udev, pmsc->cbw_struct.bCBWLUN);
782 break;
783
784 case MSC_CMD_READ_CAPACITY:
785 status = bot_scsi_capacity(udev, pmsc->cbw_struct.bCBWLUN);
786 break;
787
788 case MSC_CMD_REQUEST_SENSE:
789 status = bot_scsi_request_sense(udev, pmsc->cbw_struct.bCBWLUN);
790 break;
791
792 case MSC_CMD_TEST_UNIT:
793 status = bot_scsi_test_unit(udev, pmsc->cbw_struct.bCBWLUN);
794 break;
795
796 case MSC_CMD_VERIFY:
797 status = bot_scsi_verify(udev, pmsc->cbw_struct.bCBWLUN);
798 break;
799
800 case MSC_CMD_WRITE_10:
801 status = bot_scsi_write10(udev, pmsc->cbw_struct.bCBWLUN);
802 break;
803
804 case MSC_CMD_READ_FORMAT_CAPACITY:
805 status = bot_scsi_format_capacity(udev, pmsc->cbw_struct.bCBWLUN);
806 break;
807
808 default:
809 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
810 status = USB_FAIL;
811 break;
812 }
813 return status;
814}
815
cdc_msc_class.h
usb cdc class file
buffer
uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:43
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:106
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:75
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:144
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:59
data_len
uint16_t data_len
Definition: project/at_start_f435/examples/usb_device/virtual_comport/src/main.c:47
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
cdc_msc_struct_type::cbw_struct
cbw_type cbw_struct
Definition: cdc_msc_class.h:277
cdc_msc_struct_type::data
uint8_t data[4096]
Definition: cdc_msc_class.h:275
cbw_type::bCBWLUN
uint8_t bCBWLUN
Definition: cdc_msc_class.h:194
cbw_type::bCBWCBLength
uint8_t bCBWCBLength
Definition: cdc_msc_class.h:195
cdc_msc_struct_type::msc_state
uint8_t msc_state
Definition: cdc_msc_class.h:264
csw_type::dCSWSignature
uint32_t dCSWSignature
Definition: cdc_msc_class.h:204
cbw_type::CBWCB
uint8_t CBWCB[16]
Definition: cdc_msc_class.h:196
csw_type::bCSWStatus
uint32_t bCSWStatus
Definition: cdc_msc_class.h:207
cdc_msc_struct_type::blk_len
uint32_t blk_len
Definition: cdc_msc_class.h:272
csw_type::dCSWTag
uint32_t dCSWTag
Definition: cdc_msc_class.h:205
csw_type::dCSWDataResidue
uint32_t dCSWDataResidue
Definition: cdc_msc_class.h:206
cdc_msc_struct_type::blk_size
uint32_t blk_size[1]
Definition: cdc_msc_class.h:269
cdc_msc_struct_type::csw_struct
csw_type csw_struct
Definition: cdc_msc_class.h:278
cdc_msc_struct_type::data_len
uint32_t data_len
Definition: cdc_msc_class.h:274
cdc_msc_struct_type::blk_nbr
uint32_t blk_nbr[1]
Definition: cdc_msc_class.h:268
cbw_type::dCBWDataTransferLength
uint32_t dCBWDataTransferLength
Definition: cdc_msc_class.h:192
cdc_msc_struct_type::max_lun
uint32_t max_lun
Definition: cdc_msc_class.h:266
cdc_msc_struct_type::blk_addr
uint32_t blk_addr
Definition: cdc_msc_class.h:271
cbw_type::dCBWTage
uint32_t dCBWTage
Definition: cdc_msc_class.h:191
cbw_type::dCBWSignature
uint32_t dCBWSignature
Definition: cdc_msc_class.h:190
cdc_msc_struct_type::bot_status
uint8_t bot_status
Definition: cdc_msc_class.h:265
cbw_type::bmCBWFlags
uint8_t bmCBWFlags
Definition: cdc_msc_class.h:193
USBD_MSC_BULK_IN_EPT
#define USBD_MSC_BULK_IN_EPT
Definition: cdc_msc_class.h:57
USBD_MSC_BULK_OUT_EPT
#define USBD_MSC_BULK_OUT_EPT
Definition: cdc_msc_class.h:58
bot_scsi_format_capacity
usb_sts_type bot_scsi_format_capacity(void *udev, uint8_t lun)
bulk-only transport scsi command format capacity
Definition: composite_cdc_msc/msc_bot_scsi.c:508
bot_scsi_datain_handler
void bot_scsi_datain_handler(void *udev, uint8_t ept_num)
bulk-only transport data in handler
Definition: composite_cdc_msc/msc_bot_scsi.c:147
bot_scsi_start_stop
usb_sts_type bot_scsi_start_stop(void *udev, uint8_t lun)
bulk-only transport scsi command start stop
Definition: composite_cdc_msc/msc_bot_scsi.c:413
bot_scsi_request_sense
usb_sts_type bot_scsi_request_sense(void *udev, uint8_t lun)
bulk-only transport scsi command request sense
Definition: composite_cdc_msc/msc_bot_scsi.c:543
bot_scsi_read10
usb_sts_type bot_scsi_read10(void *udev, uint8_t lun)
bulk-only transport scsi command read10
Definition: composite_cdc_msc/msc_bot_scsi.c:602
bot_scsi_check_address
usb_sts_type bot_scsi_check_address(void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address
Definition: composite_cdc_msc/msc_bot_scsi.c:307
bot_scsi_write10
usb_sts_type bot_scsi_write10(void *udev, uint8_t lun)
bulk-only transport scsi command write10
Definition: composite_cdc_msc/msc_bot_scsi.c:663
bot_scsi_reset
void bot_scsi_reset(void *udev)
reset bulk-only transport and scsi
Definition: composite_cdc_msc/msc_bot_scsi.c:128
bot_scsi_mode_sense10
usb_sts_type bot_scsi_mode_sense10(void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10
Definition: composite_cdc_msc/msc_bot_scsi.c:461
bot_scsi_sense_code
void bot_scsi_sense_code(void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code
Definition: composite_cdc_msc/msc_bot_scsi.c:292
bot_cbw_decode
void bot_cbw_decode(void *udev)
bulk-only cbw decode
Definition: composite_cdc_msc/msc_bot_scsi.c:200
bot_scsi_verify
usb_sts_type bot_scsi_verify(void *udev, uint8_t lun)
bulk-only transport scsi command verify
Definition: composite_cdc_msc/msc_bot_scsi.c:574
bot_scsi_allow_medium_removal
usb_sts_type bot_scsi_allow_medium_removal(void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal
Definition: composite_cdc_msc/msc_bot_scsi.c:427
bot_scsi_init
void bot_scsi_init(void *udev)
initialize bulk-only transport and scsi
Definition: composite_cdc_msc/msc_bot_scsi.c:104
bot_scsi_cmd_process
usb_sts_type bot_scsi_cmd_process(void *udev)
bulk-only transport scsi command process
Definition: composite_cdc_msc/msc_bot_scsi.c:753
bot_scsi_dataout_handler
void bot_scsi_dataout_handler(void *udev, uint8_t ept_num)
bulk-only transport data out handler
Definition: composite_cdc_msc/msc_bot_scsi.c:176
bot_scsi_mode_sense6
usb_sts_type bot_scsi_mode_sense6(void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6
Definition: composite_cdc_msc/msc_bot_scsi.c:441
bot_scsi_stall
void bot_scsi_stall(void *udev)
bot endpoint stall
Definition: composite_cdc_msc/msc_bot_scsi.c:324
bot_scsi_send_data
void bot_scsi_send_data(void *udev, uint8_t *buffer, uint32_t len)
send bot data
Definition: composite_cdc_msc/msc_bot_scsi.c:247
bot_scsi_test_unit
usb_sts_type bot_scsi_test_unit(void *udev, uint8_t lun)
bulk-only transport scsi command test unit
Definition: composite_cdc_msc/msc_bot_scsi.c:350
bot_scsi_inquiry
usb_sts_type bot_scsi_inquiry(void *udev, uint8_t lun)
bulk-only transport scsi command inquiry
Definition: composite_cdc_msc/msc_bot_scsi.c:372
bot_scsi_capacity
usb_sts_type bot_scsi_capacity(void *udev, uint8_t lun)
bulk-only transport scsi command capacity
Definition: composite_cdc_msc/msc_bot_scsi.c:481
ALIGNED_TAIL
ALIGNED_HEAD uint8_t page00_inquiry_data[] ALIGNED_TAIL
Definition: composite_cdc_msc/msc_bot_scsi.c:46
bot_scsi_clear_feature
void bot_scsi_clear_feature(void *udev, uint8_t ept_num)
clear feature
Definition: composite_cdc_msc/msc_bot_scsi.c:733
bot_scsi_send_csw
void bot_scsi_send_csw(void *udev, uint8_t status)
send command status
Definition: composite_cdc_msc/msc_bot_scsi.c:268
MSC_STATE_MACHINE_DATA_IN
#define MSC_STATE_MACHINE_DATA_IN
Definition: cdc_msc_class.h:121
MSC_CMD_START_STOP
#define MSC_CMD_START_STOP
Definition: cdc_msc_class.h:88
MSC_CMD_VERIFY
#define MSC_CMD_VERIFY
Definition: cdc_msc_class.h:98
ADDRESS_OUT_OF_RANGE
#define ADDRESS_OUT_OF_RANGE
Definition: cdc_msc_class.h:153
SENSE_KEY_HARDWARE_ERROR
#define SENSE_KEY_HARDWARE_ERROR
Definition: cdc_msc_class.h:138
MEDIUM_NOT_PRESENT
#define MEDIUM_NOT_PRESENT
Definition: cdc_msc_class.h:154
MSC_CMD_MODE_SENSE6
#define MSC_CMD_MODE_SENSE6
Definition: cdc_msc_class.h:89
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:157
MSC_CMD_ALLOW_MEDIUM_REMOVAL
#define MSC_CMD_ALLOW_MEDIUM_REMOVAL
Definition: cdc_msc_class.h:91
CSW_CMD_LENGTH
#define CSW_CMD_LENGTH
Definition: cdc_msc_class.h:114
MSC_BOT_STATE_IDLE
#define MSC_BOT_STATE_IDLE
Definition: cdc_msc_class.h:129
MSC_MAX_DATA_BUF_LEN
#define MSC_MAX_DATA_BUF_LEN
Definition: cdc_msc_class.h:84
CSW_DCSWSIGNATURE
#define CSW_DCSWSIGNATURE
Definition: cdc_msc_class.h:115
MSC_CMD_INQUIRY
#define MSC_CMD_INQUIRY
Definition: cdc_msc_class.h:87
MSC_SUPPORT_MAX_LUN
#define MSC_SUPPORT_MAX_LUN
Definition: cdc_msc_class.h:83
INVALID_COMMAND
#define INVALID_COMMAND
Definition: cdc_msc_class.h:149
MSC_CMD_WRITE_10
#define MSC_CMD_WRITE_10
Definition: cdc_msc_class.h:99
MSC_STATE_MACHINE_IDLE
#define MSC_STATE_MACHINE_IDLE
Definition: cdc_msc_class.h:127
MSC_CMD_READ_FORMAT_CAPACITY
#define MSC_CMD_READ_FORMAT_CAPACITY
Definition: cdc_msc_class.h:95
MSC_CMD_MODE_SENSE10
#define MSC_CMD_MODE_SENSE10
Definition: cdc_msc_class.h:90
SENSE_KEY_ILLEGAL_REQUEST
#define SENSE_KEY_ILLEGAL_REQUEST
Definition: cdc_msc_class.h:139
MSC_STATE_MACHINE_DATA_OUT
#define MSC_STATE_MACHINE_DATA_OUT
Definition: cdc_msc_class.h:122
CSW_BCSWSTATUS_PASS
#define CSW_BCSWSTATUS_PASS
Definition: cdc_msc_class.h:116
INVALID_FIELED_IN_COMMAND
#define INVALID_FIELED_IN_COMMAND
Definition: cdc_msc_class.h:150
REQ_SENSE_STANDARD_DATA_LEN
#define REQ_SENSE_STANDARD_DATA_LEN
Definition: cdc_msc_class.h:133
MSC_STATE_MACHINE_SEND_DATA
#define MSC_STATE_MACHINE_SEND_DATA
Definition: cdc_msc_class.h:123
CBW_DCBWSIGNATURE
#define CBW_DCBWSIGNATURE
Definition: cdc_msc_class.h:110
MSC_CMD_READ_10
#define MSC_CMD_READ_10
Definition: cdc_msc_class.h:92
MSC_BOT_STATE_RECOVERY
#define MSC_BOT_STATE_RECOVERY
Definition: cdc_msc_class.h:130
CBW_CMD_LENGTH
#define CBW_CMD_LENGTH
Definition: cdc_msc_class.h:109
MSC_STATE_MACHINE_LAST_DATA
#define MSC_STATE_MACHINE_LAST_DATA
Definition: cdc_msc_class.h:124
MSC_CMD_TEST_UNIT
#define MSC_CMD_TEST_UNIT
Definition: cdc_msc_class.h:97
CSW_BCSWSTATUS_FAILED
#define CSW_BCSWSTATUS_FAILED
Definition: cdc_msc_class.h:117
MSC_CMD_READ_CAPACITY
#define MSC_CMD_READ_CAPACITY
Definition: cdc_msc_class.h:94
MSC_BOT_STATE_ERROR
#define MSC_BOT_STATE_ERROR
Definition: cdc_msc_class.h:131
MSC_CMD_REQUEST_SENSE
#define MSC_CMD_REQUEST_SENSE
Definition: cdc_msc_class.h:96
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:254
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_OK
@ USB_OK
Definition: usb_std.h:268
USB_FAIL
@ USB_FAIL
Definition: usb_std.h:269
usbd_set_stall
void usbd_set_stall(usbd_core_type *udev, uint8_t ept_addr)
usb set endpoint to stall status
Definition: usbd_core.c:262
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint receive data
Definition: usbd_core.c:534
usbd_flush_tx_fifo
void usbd_flush_tx_fifo(usbd_core_type *udev, uint8_t ept_num)
usb device flush in endpoint fifo
Definition: usbd_core.c:650
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint send data
Definition: usbd_core.c:434
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
get endpoint receive data length
Definition: usbd_core.c:300
cdc_msc_struct_type
usb cdc class struct
Definition: cdc_msc_class.h:253
sense_type
request sense standard data
Definition: cdc_msc_class.h:214


AT32F435/437 Firmwary Library: custom_hid_class.c Source File

  • middlewares
  • usbd_class
  • custom_hid
custom_hid_class.c
Go to the documentation of this file.
1
26#include "usbd_core.h"
27#include "custom_hid_class.h"
28#include "custom_hid_desc.h"
29
43static usb_sts_type class_init_handler(void *udev);
44static usb_sts_type class_clear_handler(void *udev);
45static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
46static usb_sts_type class_ept0_tx_handler(void *udev);
47static usb_sts_type class_ept0_rx_handler(void *udev);
48static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
49static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
50static usb_sts_type class_sof_handler(void *udev);
51static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
52
53static void usb_hid_buf_process(void *udev, uint8_t *report, uint16_t len);
54 custom_hid_type custom_hid_struct;
55
56/* usb device class handler */
57usbd_class_handler custom_hid_class_handler =
58{
59 class_init_handler,
60 class_clear_handler,
61 class_setup_handler,
62 class_ept0_tx_handler,
63 class_ept0_rx_handler,
64 class_in_handler,
65 class_out_handler,
66 class_sof_handler,
67 class_event_handler,
68 &custom_hid_struct
69};
70
76static usb_sts_type class_init_handler(void *udev)
77{
78 usb_sts_type status = USB_OK;
79 usbd_core_type *pudev = (usbd_core_type *)udev;
80 custom_hid_type *pcshid = (custom_hid_type *)pudev->class_handler->pdata;
81 /* open custom hid in endpoint */
82 usbd_ept_open(pudev, USBD_CUSTOM_HID_IN_EPT, EPT_INT_TYPE, USBD_CUSTOM_IN_MAXPACKET_SIZE);
83
84 /* open custom hid out endpoint */
85 usbd_ept_open(pudev, USBD_CUSTOM_HID_OUT_EPT, EPT_INT_TYPE, USBD_CUSTOM_OUT_MAXPACKET_SIZE);
86
87 /* set out endpoint to receive status */
88 usbd_ept_recv(pudev, USBD_CUSTOM_HID_OUT_EPT, pcshid->g_rxhid_buff, USBD_CUSTOM_OUT_MAXPACKET_SIZE);
89
90 return status;
91}
92
98static usb_sts_type class_clear_handler(void *udev)
99{
100 usb_sts_type status = USB_OK;
101 usbd_core_type *pudev = (usbd_core_type *)udev;
102
103 /* close custom hid in endpoint */
104 usbd_ept_close(pudev, USBD_CUSTOM_HID_IN_EPT);
105
106 /* close custom hid out endpoint */
107 usbd_ept_close(pudev, USBD_CUSTOM_HID_OUT_EPT);
108
109 return status;
110}
111
118static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
119{
120 usb_sts_type status = USB_OK;
121 usbd_core_type *pudev = (usbd_core_type *)udev;
122 custom_hid_type *pcshid = (custom_hid_type *)pudev->class_handler->pdata;
123 uint16_t len;
124 uint8_t *buf;
125
126 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
127 {
128 /* class request */
129 case USB_REQ_TYPE_CLASS:
130 switch(setup->bRequest)
131 {
132 case HID_REQ_SET_PROTOCOL:
133 pcshid->hid_protocol = (uint8_t)setup->wValue;
134 break;
135 case HID_REQ_GET_PROTOCOL:
136 usbd_ctrl_send(pudev, (uint8_t *)&pcshid->hid_protocol, 1);
137 break;
138 case HID_REQ_SET_IDLE:
139 pcshid->hid_set_idle = (uint8_t)(setup->wValue >> 8);
140 break;
141 case HID_REQ_GET_IDLE:
142 usbd_ctrl_send(pudev, (uint8_t *)&pcshid->hid_set_idle, 1);
143 break;
144 case HID_REQ_SET_REPORT:
145 pcshid->hid_state = HID_REQ_SET_REPORT;
146 usbd_ctrl_recv(pudev, pcshid->hid_set_report, setup->wLength);
147 break;
148 default:
149 usbd_ctrl_unsupport(pudev);
150 break;
151 }
152 break;
153 /* standard request */
154 case USB_REQ_TYPE_STANDARD:
155 switch(setup->bRequest)
156 {
157 case USB_STD_REQ_GET_DESCRIPTOR:
158 if(setup->wValue >> 8 == HID_REPORT_DESC)
159 {
160 len = MIN(USBD_CUSHID_SIZ_REPORT_DESC, setup->wLength);
161 buf = (uint8_t *)g_usbd_custom_hid_report;
162 }
163 else if(setup->wValue >> 8 == HID_DESCRIPTOR_TYPE)
164 {
165 len = MIN(9, setup->wLength);
166 buf = (uint8_t *)g_custom_hid_usb_desc;
167 }
168 usbd_ctrl_send(pudev, (uint8_t *)buf, len);
169 break;
170 case USB_STD_REQ_GET_INTERFACE:
171 usbd_ctrl_send(pudev, (uint8_t *)&pcshid->alt_setting, 1);
172 break;
173 case USB_STD_REQ_SET_INTERFACE:
174 pcshid->alt_setting = setup->wValue;
175 break;
176 default:
177 break;
178 }
179 break;
180 default:
181 usbd_ctrl_unsupport(pudev);
182 break;
183 }
184 return status;
185}
186
192static usb_sts_type class_ept0_tx_handler(void *udev)
193{
194 usb_sts_type status = USB_OK;
195
196 /* ...user code... */
197
198 return status;
199}
200
206static usb_sts_type class_ept0_rx_handler(void *udev)
207{
208 usb_sts_type status = USB_OK;
209 usbd_core_type *pudev = (usbd_core_type *)udev;
210 custom_hid_type *pcshid = (custom_hid_type *)pudev->class_handler->pdata;
211 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
212 /* ...user code... */
213 if( pcshid->hid_state == HID_REQ_SET_REPORT)
214 {
215 /* hid buffer process */
216 usb_hid_buf_process(udev, pcshid->hid_set_report, recv_len);
217 pcshid->hid_state = 0;
218 }
219
220 return status;
221}
222
229static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
230{
231 usb_sts_type status = USB_OK;
232
233 /* ...user code...
234 trans next packet data
235 */
236
237 return status;
238}
239
246static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
247{
248 usb_sts_type status = USB_OK;
249 usbd_core_type *pudev = (usbd_core_type *)udev;
250 custom_hid_type *pcshid = (custom_hid_type *)pudev->class_handler->pdata;
251
252 /* get endpoint receive data length */
253 uint32_t recv_len = usbd_get_recv_len(pudev, ept_num);
254
255 /* hid buffer process */
256 usb_hid_buf_process(udev, pcshid->g_rxhid_buff, recv_len);
257
258 /* start receive next packet */
259 usbd_ept_recv(pudev, USBD_CUSTOM_HID_OUT_EPT, pcshid->g_rxhid_buff, recv_len);
260
261 return status;
262}
263
269static usb_sts_type class_sof_handler(void *udev)
270{
271 usb_sts_type status = USB_OK;
272
273 /* ...user code... */
274
275 return status;
276}
277
284static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
285{
286 usb_sts_type status = USB_OK;
287 switch(event)
288 {
289 case USBD_RESET_EVENT:
290
291 /* ...user code... */
292
293 break;
294 case USBD_SUSPEND_EVENT:
295
296 /* ...user code... */
297
298 break;
299 case USBD_WAKEUP_EVENT:
300 /* ...user code... */
301
302 break;
303 default:
304 break;
305 }
306 return status;
307}
308
316 usb_sts_type custom_hid_class_send_report(void *udev, uint8_t *report, uint16_t len)
317{
318 usb_sts_type status = USB_OK;
319 usbd_core_type *pudev = (usbd_core_type *)udev;
320
321 if(usbd_connect_state_get(pudev) == USB_CONN_STATE_CONFIGURED)
322 usbd_ept_send(pudev, USBD_CUSTOM_HID_IN_EPT, report, len);
323
324 return status;
325}
326
334static void usb_hid_buf_process(void *udev, uint8_t *report, uint16_t len)
335{
336 uint32_t i_index;
337 usbd_core_type *pudev = (usbd_core_type *)udev;
338 custom_hid_type *pcshid = (custom_hid_type *)pudev->class_handler->pdata;
339
340 switch(report[0])
341 {
342 case HID_REPORT_ID_2:
343 if(pcshid->g_rxhid_buff[1] == 0)
344 {
345 at32_led_off(LED2);
346 }
347 else
348 {
349 at32_led_on(LED2);
350 }
351 break;
352 case HID_REPORT_ID_3:
353 if(pcshid->g_rxhid_buff[1] == 0)
354 {
355 at32_led_off(LED3);
356 }
357 else
358 {
359 at32_led_on(LED3);
360 }
361 break;
362 case HID_REPORT_ID_4:
363 if(pcshid->g_rxhid_buff[1] == 0)
364 {
365 at32_led_off(LED4);
366 }
367 else
368 {
369 at32_led_on(LED4);
370 }
371 break;
372 case HID_REPORT_ID_6:
373 for(i_index = 0; i_index < len; i_index ++)
374 {
375 pcshid->g_txhid_buff[i_index] = report[i_index];
376 }
377 usbd_ept_send(pudev, USBD_CUSTOM_HID_IN_EPT, pcshid->g_txhid_buff, len);
378 break;
379 default:
380 break;
381 }
382
383}
384
custom_hid_class.h
usb hid header file
custom_hid_desc.h
usb custom hid descriptor header file
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
HID_REPORT_ID_2
#define HID_REPORT_ID_2
Definition: audio_hid_desc.h:223
HID_REPORT_ID_4
#define HID_REPORT_ID_4
Definition: audio_hid_desc.h:225
HID_REPORT_ID_6
#define HID_REPORT_ID_6
Definition: audio_hid_desc.h:227
HID_REPORT_ID_3
#define HID_REPORT_ID_3
Definition: audio_hid_desc.h:224
USBD_CUSTOM_IN_MAXPACKET_SIZE
#define USBD_CUSTOM_IN_MAXPACKET_SIZE
usb custom hid in and out max packet size define
Definition: custom_hid_class.h:59
USBD_CUSTOM_HID_IN_EPT
#define USBD_CUSTOM_HID_IN_EPT
usb custom hid use endpoint define
Definition: custom_hid_class.h:53
USBD_CUSTOM_OUT_MAXPACKET_SIZE
#define USBD_CUSTOM_OUT_MAXPACKET_SIZE
Definition: custom_hid_class.h:60
USBD_CUSTOM_HID_OUT_EPT
#define USBD_CUSTOM_HID_OUT_EPT
Definition: custom_hid_class.h:54
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: custom_hid_class.c:269
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: custom_hid_class.c:229
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: custom_hid_class.c:98
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: custom_hid_class.c:118
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: custom_hid_class.c:192
custom_hid_class_send_report
usb_sts_type custom_hid_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: custom_hid_class.c:316
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: custom_hid_class.c:206
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: custom_hid_class.c:284
usb_hid_buf_process
static void usb_hid_buf_process(void *udev, uint8_t *report, uint16_t len)
usb device report function
Definition: custom_hid_class.c:334
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: custom_hid_class.c:76
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: custom_hid_class.c:246
custom_hid_class_handler
usbd_class_handler custom_hid_class_handler
Definition: custom_hid_class.c:57
custom_hid_struct
custom_hid_type custom_hid_struct
Definition: custom_hid_class.c:54
USBD_CUSHID_SIZ_REPORT_DESC
#define USBD_CUSHID_SIZ_REPORT_DESC
Definition: custom_hid_desc.h:66
g_custom_hid_usb_desc
uint8_t g_custom_hid_usb_desc[9]
usb hid descriptor
Definition: custom_hid_desc.c:264
g_usbd_custom_hid_report
uint8_t g_usbd_custom_hid_report[126]
usb hid report descriptor
Definition: custom_hid_desc.c:166
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f435_437_usb.h:349
HID_DESCRIPTOR_TYPE
#define HID_DESCRIPTOR_TYPE
Definition: usb_std.h:236
HID_REQ_GET_PROTOCOL
#define HID_REQ_GET_PROTOCOL
Definition: usb_std.h:231
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:254
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:63
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:81
HID_REQ_SET_PROTOCOL
#define HID_REQ_SET_PROTOCOL
usb hid class request code define
Definition: usb_std.h:230
HID_REPORT_DESC
#define HID_REPORT_DESC
Definition: usb_std.h:237
HID_REQ_SET_IDLE
#define HID_REQ_SET_IDLE
Definition: usb_std.h:232
HID_REQ_GET_IDLE
#define HID_REQ_GET_IDLE
Definition: usb_std.h:233
HID_REQ_SET_REPORT
#define HID_REQ_SET_REPORT
Definition: usb_std.h:234
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:86
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:66
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:85
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:64
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:131
USB_OK
@ USB_OK
Definition: usb_std.h:268
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:597
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:346
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint receive data
Definition: usbd_core.c:534
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:314
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:177
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint send data
Definition: usbd_core.c:434
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
get endpoint receive data length
Definition: usbd_core.c:300
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint recv data
Definition: usbd_core.c:196
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:287
custom_hid_type
Definition: custom_hid_class.h:71
custom_hid_type::g_txhid_buff
uint8_t g_txhid_buff[0x40]
Definition: custom_hid_class.h:73
custom_hid_type::alt_setting
uint32_t alt_setting
Definition: custom_hid_class.h:77
custom_hid_type::hid_set_report
uint8_t hid_set_report[64]
Definition: custom_hid_class.h:79
custom_hid_type::g_rxhid_buff
uint8_t g_rxhid_buff[0x40]
Definition: custom_hid_class.h:72
custom_hid_type::hid_set_idle
uint32_t hid_set_idle
Definition: custom_hid_class.h:76
custom_hid_type::hid_protocol
uint32_t hid_protocol
Definition: custom_hid_class.h:75
custom_hid_type::hid_state
uint8_t hid_state
Definition: custom_hid_class.h:78
usb_setup_type
format of usb setup data
Definition: usb_std.h:280
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:283
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:286
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:281
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:282
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: custom_hid_class.h Source File

  • middlewares
  • usbd_class
  • custom_hid
custom_hid_class.h
Go to the documentation of this file.
1
27 /* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __CUSTOM_HID_CLASS_H
29#define __CUSTOM_HID_CLASS_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "usb_std.h"
36#include "usbd_core.h"
37
53#define USBD_CUSTOM_HID_IN_EPT 0x81
54#define USBD_CUSTOM_HID_OUT_EPT 0x01
55
59#define USBD_CUSTOM_IN_MAXPACKET_SIZE 0x40
60#define USBD_CUSTOM_OUT_MAXPACKET_SIZE 0x40
61
70typedef struct
71{
72 uint8_t g_rxhid_buff[USBD_CUSTOM_OUT_MAXPACKET_SIZE];
73 uint8_t g_txhid_buff[USBD_CUSTOM_IN_MAXPACKET_SIZE];
74
75 uint32_t hid_protocol;
76 uint32_t hid_set_idle;
77 uint32_t alt_setting;
78 uint8_t hid_state;
79 uint8_t hid_set_report[64];
80}custom_hid_type;
81
89extern usbd_class_handler custom_hid_class_handler;
90 usb_sts_type custom_hid_class_send_report(void *udev, uint8_t *report, uint16_t len);
101#ifdef __cplusplus
102}
103#endif
104
105#endif
USBD_CUSTOM_IN_MAXPACKET_SIZE
#define USBD_CUSTOM_IN_MAXPACKET_SIZE
usb custom hid in and out max packet size define
Definition: custom_hid_class.h:59
USBD_CUSTOM_OUT_MAXPACKET_SIZE
#define USBD_CUSTOM_OUT_MAXPACKET_SIZE
Definition: custom_hid_class.h:60
custom_hid_class_send_report
usb_sts_type custom_hid_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: custom_hid_class.c:316
custom_hid_class_handler
usbd_class_handler custom_hid_class_handler
Definition: custom_hid_class.c:57
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
custom_hid_type
Definition: custom_hid_class.h:71
custom_hid_type::alt_setting
uint32_t alt_setting
Definition: custom_hid_class.h:77
custom_hid_type::hid_set_idle
uint32_t hid_set_idle
Definition: custom_hid_class.h:76
custom_hid_type::hid_protocol
uint32_t hid_protocol
Definition: custom_hid_class.h:75
custom_hid_type::hid_state
uint8_t hid_state
Definition: custom_hid_class.h:78
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: custom_hid_desc.c Source File

  • middlewares
  • usbd_class
  • custom_hid
custom_hid_desc.c
Go to the documentation of this file.
1
26#include "usb_std.h"
27#include "usbd_sdr.h"
28#include "usbd_core.h"
29#include "custom_hid_desc.h"
30
43static usbd_desc_t *get_device_descriptor(void);
44static usbd_desc_t *get_device_qualifier(void);
45static usbd_desc_t *get_device_configuration(void);
46static usbd_desc_t *get_device_other_speed(void);
47static usbd_desc_t *get_device_lang_id(void);
48static usbd_desc_t *get_device_manufacturer_string(void);
49static usbd_desc_t *get_device_product_string(void);
50static usbd_desc_t *get_device_serial_string(void);
51static usbd_desc_t *get_device_interface_string(void);
52static usbd_desc_t *get_device_config_string(void);
53
54static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
55static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
56static void get_serial_num(void);
57static uint8_t g_usbd_desc_buffer[256];
58
62usbd_desc_handler custom_hid_desc_handler =
63{
64 get_device_descriptor,
65 get_device_qualifier,
66 get_device_configuration,
67 get_device_other_speed,
68 get_device_lang_id,
69 get_device_manufacturer_string,
70 get_device_product_string,
71 get_device_serial_string,
72 get_device_interface_string,
73 get_device_config_string,
74};
75
79#if defined ( __ICCARM__ ) /* iar compiler */
80 #pragma data_alignment=4
81#endif
82ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
83{
84 USB_DEVICE_DESC_LEN, /* bLength */
85 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
86 0x00, /* bcdUSB */
87 0x02,
88 0x00, /* bDeviceClass */
89 0x00, /* bDeviceSubClass */
90 0x00, /* bDeviceProtocol */
91 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
92 LBYTE(USBD_CUSHID_VENDOR_ID), /* idVendor */
93 HBYTE(USBD_CUSHID_VENDOR_ID), /* idVendor */
94 LBYTE(USBD_CUSHID_PRODUCT_ID), /* idProduct */
95 HBYTE(USBD_CUSHID_PRODUCT_ID), /* idProduct */
96 0x00, /* bcdDevice rel. 2.00 */
97 0x02,
98 USB_MFC_STRING, /* Index of manufacturer string */
99 USB_PRODUCT_STRING, /* Index of product string */
100 USB_SERIAL_STRING, /* Index of serial number string */
101 1 /* bNumConfigurations */
102};
103
107#if defined ( __ICCARM__ ) /* iar compiler */
108 #pragma data_alignment=4
109#endif
110ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_CUSHID_CONFIG_DESC_SIZE] ALIGNED_TAIL =
111{
112 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
113 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
114 LBYTE(USBD_CUSHID_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
115 HBYTE(USBD_CUSHID_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
116 0x01, /* bNumInterfaces: 1 interface */
117 0x01, /* bConfigurationValue: configuration value */
118 0x00, /* iConfiguration: index of string descriptor describing
119 the configuration */
120 0xE0, /* bmAttributes: self powered and support remote wakeup */
121 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
122
123 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
124 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
125 0x00, /* bInterfaceNumber: number of interface */
126 0x00, /* bAlternateSetting: alternate set */
127 0x02, /* bNumEndpoints: number of endpoints */
128 USB_CLASS_CODE_HID, /* bInterfaceClass: class code hid */
129 0x00, /* bInterfaceSubClass: subclass code */
130 0x00, /* bInterfaceProtocol: protocol code */
131 0x00, /* iInterface: index of string descriptor */
132
133 0x09, /* bLength: size of HID descriptor in bytes */
134 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
135 LBYTE(CUSHID_BCD_NUM),
136 HBYTE(CUSHID_BCD_NUM), /* bcdHID: HID class specification release number */
137 0x00, /* bCountryCode: hardware target conutry */
138 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
139 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
140 LBYTE(sizeof(g_usbd_custom_hid_report)),
141 HBYTE(sizeof(g_usbd_custom_hid_report)), /* wDescriptorLength: total length of reprot descriptor */
142
143 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
144 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
145 USBD_CUSTOM_HID_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
146 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
147 LBYTE(USBD_CUSTOM_IN_MAXPACKET_SIZE),
148 HBYTE(USBD_CUSTOM_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
149 CUSHID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
150
151 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
152 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
153 USBD_CUSTOM_HID_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
154 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
155 LBYTE(USBD_CUSTOM_OUT_MAXPACKET_SIZE),
156 HBYTE(USBD_CUSTOM_OUT_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
157 CUSHID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
158};
159
163#if defined ( __ICCARM__ ) /* iar compiler */
164 #pragma data_alignment=4
165#endif
166ALIGNED_HEAD uint8_t g_usbd_custom_hid_report[USBD_CUSHID_SIZ_REPORT_DESC] ALIGNED_TAIL =
167{
168 0x06, 0xFF, 0x00, /* USAGE_PAGE(Vendor Page:0xFF00) */
169 0x09, 0x01, /* USAGE (Demo Kit) */
170 0xa1, 0x01, /* COLLECTION (Application) */
171 /* 7 */
172
173 /* Led 2 */
174 0x85, HID_REPORT_ID_2, /* REPORT_ID 2 */
175 0x09, 0x02, /* USAGE (LED 2) */
176 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
177 0x25, 0x01, /* LOGICAL_MAXIMUM (1) */
178 0x75, 0x08, /* REPORT_SIZE (8) */
179 0x95, 0x3F, /* REPORT_COUNT (1) */
180 0xB1, 0x82, /* FEATURE (Data,Var,Abs,Vol) */
181
182 0x85, 0x02, /* REPORT_ID (2) */
183 0x09, 0x02, /* USAGE (LED 2) */
184 0x91, 0x82, /* OUTPUT (Data,Var,Abs,Vol) */
185 /* 27 */
186
187 /* Led 3 */
188 0x85, HID_REPORT_ID_3, /* REPORT_ID (3) */
189 0x09, 0x03, /* USAGE (LED 3) */
190 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
191 0x25, 0x01, /* LOGICAL_MAXIMUM (1) */
192 0x75, 0x08, /* REPORT_SIZE (8) */
193 0x95, 0x3F, /* REPORT_COUNT (1) */
194 0xB1, 0x82, /* FEATURE (Data,Var,Abs,Vol) */
195
196 0x85, 0x03, /* REPORT_ID (3) */
197 0x09, 0x03, /* USAGE (LED 3) */
198 0x91, 0x82, /* OUTPUT (Data,Var,Abs,Vol) */
199 /* 47 */
200
201 /* Led 4 */
202 0x85, HID_REPORT_ID_4, /* REPORT_ID 4) */
203 0x09, 0x04, /* USAGE (LED 4) */
204 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
205 0x25, 0x01, /* LOGICAL_MAXIMUM (1) */
206 0x75, 0x08, /* REPORT_SIZE (8) */
207 0x95, 0x3F, /* REPORT_COUNT (1) */
208 0xB1, 0x82, /* FEATURE (Data,Var,Abs,Vol) */
209
210 0x85, 0x04, /* REPORT_ID (4) */
211 0x09, 0x04, /* USAGE (LED 4) */
212 0x91, 0x82, /* OUTPUT (Data,Var,Abs,Vol) */
213 /* 67 */
214
215 /* key Push Button */
216 0x85, HID_REPORT_ID_5, /* REPORT_ID (5) */
217 0x09, 0x05, /* USAGE (Push Button) */
218 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
219 0x25, 0x01, /* LOGICAL_MAXIMUM (1) */
220 0x75, 0x01, /* REPORT_SIZE (1) */
221 0x81, 0x82, /* INPUT (Data,Var,Abs,Vol) */
222
223 0x09, 0x05, /* USAGE (Push Button) */
224 0x75, 0x01, /* REPORT_SIZE (1) */
225 0xb1, 0x82, /* FEATURE (Data,Var,Abs,Vol) */
226
227 0x75, 0x07, /* REPORT_SIZE (7) */
228 0x81, 0x83, /* INPUT (Cnst,Var,Abs,Vol) */
229 0x85, 0x05, /* REPORT_ID (5) */
230
231 0x75, 0x07, /* REPORT_SIZE (7) */
232 0xb1, 0x83, /* FEATURE (Cnst,Var,Abs,Vol) */
233 /* 95 */
234
235 /* Data OUT */
236 0x85, HID_REPORT_ID_6, /* REPORT_ID (0xF0) */
237 0x09, 0x06, /* USAGE */
238 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
239 0x26, 0x00,0xff, /* LOGICAL_MAXIMUM (255) */
240 0x75, 0x08, /* REPORT_SIZE (8) */
241 0x95, 0x3F, /* REPORT_COUNT (64) */
242 0x91, 0x02, /* OUTPUT(Data,Var,Abs,Vol) */
243 /* 110 */
244
245 /* Data IN */
246 0x85, HID_REPORT_ID_6, /* REPORT_ID (0xF0) */
247 0x09, 0x07, /* USAGE */
248 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
249 0x26, 0x00,0xff, /* LOGICAL_MAXIMUM (255) */
250 0x75, 0x08, /* REPORT_SIZE (8) */
251 0x95, 0x3F, /* REPORT_COUNT (64) */
252 0x81, 0x82, /* INPUT(Data,Var,Abs,Vol) */
253
254 /* 125 */
255 0xc0 /* END_COLLECTION */
256};
257
261#if defined ( __ICCARM__ ) /* iar compiler */
262 #pragma data_alignment=4
263#endif
264ALIGNED_HEAD uint8_t g_custom_hid_usb_desc[9] ALIGNED_TAIL =
265{
266 0x09, /* bLength: size of HID descriptor in bytes */
267 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
268 LBYTE(CUSHID_BCD_NUM),
269 HBYTE(CUSHID_BCD_NUM), /* bcdHID: HID class specification release number */
270 0x00, /* bCountryCode: hardware target conutry */
271 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
272 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
273 LBYTE(sizeof(g_usbd_custom_hid_report)),
274 HBYTE(sizeof(g_usbd_custom_hid_report)), /* wDescriptorLength: total length of reprot descriptor */
275};
276
277
281#if defined ( __ICCARM__ ) /* iar compiler */
282 #pragma data_alignment=4
283#endif
284ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_CUSHID_SIZ_STRING_LANGID] ALIGNED_TAIL =
285{
286 USBD_CUSHID_SIZ_STRING_LANGID,
287 USB_DESCIPTOR_TYPE_STRING,
288 0x09,
289 0x04,
290};
291
295#if defined ( __ICCARM__ ) /* iar compiler */
296 #pragma data_alignment=4
297#endif
298ALIGNED_HEAD static uint8_t g_string_serial[USBD_CUSHID_SIZ_STRING_SERIAL] ALIGNED_TAIL =
299{
300 USBD_CUSHID_SIZ_STRING_SERIAL,
301 USB_DESCIPTOR_TYPE_STRING,
302};
303
304
305/* device descriptor */
306static usbd_desc_t device_descriptor =
307{
308 USB_DEVICE_DESC_LEN,
309 g_usbd_descriptor
310};
311
312/* config descriptor */
313static usbd_desc_t config_descriptor =
314{
315 USBD_CUSHID_CONFIG_DESC_SIZE,
316 g_usbd_configuration
317};
318
319/* langid descriptor */
320static usbd_desc_t langid_descriptor =
321{
322 USBD_CUSHID_SIZ_STRING_LANGID,
323 g_string_lang_id
324};
325
326/* serial descriptor */
327static usbd_desc_t serial_descriptor =
328{
329 USBD_CUSHID_SIZ_STRING_SERIAL,
330 g_string_serial
331};
332
333static usbd_desc_t vp_desc;
334
341static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
342{
343 uint16_t str_len = 0, id_pos = 2;
344 uint8_t *tmp_str = string;
345
346 while(*tmp_str != '\0')
347 {
348 str_len ++;
349 unicode_buf[id_pos ++] = *tmp_str ++;
350 unicode_buf[id_pos ++] = 0x00;
351 }
352
353 str_len = str_len * 2 + 2;
354 unicode_buf[0] = str_len;
355 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
356
357 return str_len;
358}
359
367static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
368{
369 uint8_t idx = 0;
370
371 for( idx = 0 ; idx < len ; idx ++)
372 {
373 if( ((value >> 28)) < 0xA )
374 {
375 pbuf[ 2 * idx] = (value >> 28) + '0';
376 }
377 else
378 {
379 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
380 }
381
382 value = value << 4;
383
384 pbuf[2 * idx + 1] = 0;
385 }
386}
387
393static void get_serial_num(void)
394{
395 uint32_t serial0, serial1, serial2;
396
397 serial0 = *(uint32_t*)MCU_ID1;
398 serial1 = *(uint32_t*)MCU_ID2;
399 serial2 = *(uint32_t*)MCU_ID3;
400
401 serial0 += serial2;
402
403 if (serial0 != 0)
404 {
405 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
406 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
407 }
408}
409
415static usbd_desc_t *get_device_descriptor(void)
416{
417 return &device_descriptor;
418}
419
425static usbd_desc_t * get_device_qualifier(void)
426{
427 return NULL;
428}
429
435static usbd_desc_t *get_device_configuration(void)
436{
437 return &config_descriptor;
438}
439
445static usbd_desc_t *get_device_other_speed(void)
446{
447 return NULL;
448}
449
455static usbd_desc_t *get_device_lang_id(void)
456{
457 return &langid_descriptor;
458}
459
460
466static usbd_desc_t *get_device_manufacturer_string(void)
467{
468 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CUSHID_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
469 vp_desc.descriptor = g_usbd_desc_buffer;
470 return &vp_desc;
471}
472
478static usbd_desc_t *get_device_product_string(void)
479{
480 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CUSHID_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
481 vp_desc.descriptor = g_usbd_desc_buffer;
482 return &vp_desc;
483}
484
490static usbd_desc_t *get_device_serial_string(void)
491{
492 get_serial_num();
493 return &serial_descriptor;
494}
495
501static usbd_desc_t *get_device_interface_string(void)
502{
503 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CUSHID_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
504 vp_desc.descriptor = g_usbd_desc_buffer;
505 return &vp_desc;
506}
507
513static usbd_desc_t *get_device_config_string(void)
514{
515 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CUSHID_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
516 vp_desc.descriptor = g_usbd_desc_buffer;
517 return &vp_desc;
518}
519
custom_hid_desc.h
usb custom hid descriptor header file
idx
uint32_t idx
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:46
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:215
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:216
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:217
HID_REPORT_ID_2
#define HID_REPORT_ID_2
Definition: audio_hid_desc.h:223
HID_REPORT_ID_4
#define HID_REPORT_ID_4
Definition: audio_hid_desc.h:225
HID_REPORT_ID_6
#define HID_REPORT_ID_6
Definition: audio_hid_desc.h:227
HID_REPORT_ID_3
#define HID_REPORT_ID_3
Definition: audio_hid_desc.h:224
HID_REPORT_ID_5
#define HID_REPORT_ID_5
Definition: audio_hid_desc.h:226
USBD_CUSTOM_IN_MAXPACKET_SIZE
#define USBD_CUSTOM_IN_MAXPACKET_SIZE
usb custom hid in and out max packet size define
Definition: custom_hid_class.h:59
USBD_CUSTOM_HID_IN_EPT
#define USBD_CUSTOM_HID_IN_EPT
usb custom hid use endpoint define
Definition: custom_hid_class.h:53
USBD_CUSTOM_OUT_MAXPACKET_SIZE
#define USBD_CUSTOM_OUT_MAXPACKET_SIZE
Definition: custom_hid_class.h:60
USBD_CUSTOM_HID_OUT_EPT
#define USBD_CUSTOM_HID_OUT_EPT
Definition: custom_hid_class.h:54
USBD_CUSHID_SIZ_STRING_SERIAL
#define USBD_CUSHID_SIZ_STRING_SERIAL
Definition: custom_hid_desc.h:68
USBD_CUSHID_VENDOR_ID
#define USBD_CUSHID_VENDOR_ID
usb vendor id and product id define
Definition: custom_hid_desc.h:59
USBD_CUSHID_DESC_CONFIGURATION_STRING
#define USBD_CUSHID_DESC_CONFIGURATION_STRING
Definition: custom_hid_desc.h:75
USBD_CUSHID_SIZ_REPORT_DESC
#define USBD_CUSHID_SIZ_REPORT_DESC
Definition: custom_hid_desc.h:66
CUSHID_BINTERVAL_TIME
#define CUSHID_BINTERVAL_TIME
Definition: custom_hid_desc.h:78
USBD_CUSHID_DESC_MANUFACTURER_STRING
#define USBD_CUSHID_DESC_MANUFACTURER_STRING
usb string define(vendor, product configuration, interface)
Definition: custom_hid_desc.h:73
USBD_CUSHID_CONFIG_DESC_SIZE
#define USBD_CUSHID_CONFIG_DESC_SIZE
usb descriptor size define
Definition: custom_hid_desc.h:65
USBD_CUSHID_DESC_INTERFACE_STRING
#define USBD_CUSHID_DESC_INTERFACE_STRING
Definition: custom_hid_desc.h:76
USBD_CUSHID_PRODUCT_ID
#define USBD_CUSHID_PRODUCT_ID
Definition: custom_hid_desc.h:60
USBD_CUSHID_SIZ_STRING_LANGID
#define USBD_CUSHID_SIZ_STRING_LANGID
Definition: custom_hid_desc.h:67
USBD_CUSHID_DESC_PRODUCT_STRING
#define USBD_CUSHID_DESC_PRODUCT_STRING
Definition: custom_hid_desc.h:74
CUSHID_BCD_NUM
#define CUSHID_BCD_NUM
usb bcd number define
Definition: custom_hid_desc.h:54
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: custom_hid_desc.c:327
device_descriptor
static usbd_desc_t device_descriptor
Definition: custom_hid_desc.c:306
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: custom_hid_desc.c:435
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: custom_hid_desc.c:320
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: custom_hid_desc.c:415
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: custom_hid_desc.c:466
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: custom_hid_desc.c:425
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: custom_hid_desc.c:501
g_usbd_desc_buffer
static uint8_t g_usbd_desc_buffer[256]
Definition: custom_hid_desc.c:57
vp_desc
static usbd_desc_t vp_desc
Definition: custom_hid_desc.c:333
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: custom_hid_desc.c:445
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL
usb device standard descriptor
Definition: custom_hid_desc.c:82
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: custom_hid_desc.c:478
custom_hid_desc_handler
usbd_desc_handler custom_hid_desc_handler
custom hid device descriptor handler structure
Definition: custom_hid_desc.c:62
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: custom_hid_desc.c:513
g_custom_hid_usb_desc
uint8_t g_custom_hid_usb_desc[9]
usb hid descriptor
Definition: custom_hid_desc.c:264
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: custom_hid_desc.c:341
g_usbd_custom_hid_report
uint8_t g_usbd_custom_hid_report[126]
usb hid report descriptor
Definition: custom_hid_desc.c:166
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: custom_hid_desc.c:455
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: custom_hid_desc.c:393
config_descriptor
static usbd_desc_t config_descriptor
Definition: custom_hid_desc.c:313
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: custom_hid_desc.c:490
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: custom_hid_desc.c:367
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:153
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:93
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: usb_std.h:223
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: usb_std.h:224
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:96
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:152
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:151
USB_EPT_DESC_INTERRUPT
#define USB_EPT_DESC_INTERRUPT
Definition: usb_std.h:178
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:94
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:95
USB_CLASS_CODE_HID
#define USB_CLASS_CODE_HID
Definition: usb_std.h:163
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h


AT32F435/437 Firmwary Library: custom_hid_desc.h Source File

  • middlewares
  • usbd_class
  • custom_hid
custom_hid_desc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __CUSTOM_HID_DESC_H
29#define __CUSTOM_HID_DESC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "custom_hid_class.h"
36#include "usbd_core.h"
37
54#define CUSHID_BCD_NUM 0x0110
55
59#define USBD_CUSHID_VENDOR_ID 0x2E3C
60#define USBD_CUSHID_PRODUCT_ID 0x5745
61
65#define USBD_CUSHID_CONFIG_DESC_SIZE 41
66#define USBD_CUSHID_SIZ_REPORT_DESC 126
67#define USBD_CUSHID_SIZ_STRING_LANGID 4
68#define USBD_CUSHID_SIZ_STRING_SERIAL 0x1A
69
73#define USBD_CUSHID_DESC_MANUFACTURER_STRING "Artery"
74#define USBD_CUSHID_DESC_PRODUCT_STRING "Custom HID"
75#define USBD_CUSHID_DESC_CONFIGURATION_STRING "Custom HID Config"
76#define USBD_CUSHID_DESC_INTERFACE_STRING "Custom HID Interface"
77
78#define CUSHID_BINTERVAL_TIME 0x0A
79
86#define HID_REPORT_ID_1 0x01
87#define HID_REPORT_ID_2 0x02
88#define HID_REPORT_ID_3 0x03
89#define HID_REPORT_ID_4 0x04
90#define HID_REPORT_ID_5 0x05
91#define HID_REPORT_ID_6 0xF0
92
96#define MCU_ID1 (0x1FFFF7E8)
97#define MCU_ID2 (0x1FFFF7EC)
98#define MCU_ID3 (0x1FFFF7F0)
99
103extern uint8_t g_usbd_custom_hid_report[USBD_CUSHID_SIZ_REPORT_DESC];
104extern uint8_t g_custom_hid_usb_desc[9];
105extern usbd_desc_handler custom_hid_desc_handler;
106
114#ifdef __cplusplus
115}
116#endif
117
118#endif
119
120
custom_hid_class.h
usb hid header file
USBD_CUSHID_SIZ_REPORT_DESC
#define USBD_CUSHID_SIZ_REPORT_DESC
Definition: custom_hid_desc.h:66
g_custom_hid_usb_desc
uint8_t g_custom_hid_usb_desc[9]
usb hid descriptor
Definition: custom_hid_desc.c:264
g_usbd_custom_hid_report
uint8_t g_usbd_custom_hid_report[126]
usb hid report descriptor
Definition: custom_hid_desc.c:166
custom_hid_desc_handler
usbd_desc_handler custom_hid_desc_handler
custom hid device descriptor handler structure
Definition: custom_hid_desc.c:62
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usart
  • irda
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usart/irda/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usart/irda/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
inc Directory Reference

Files

file | utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_clock.h [code]
header file of clock program
file | utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h [code]
iap header file
file | at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/tmr.h [code]
tmr header file
file | app_led3_toggle/inc/usart.h [code]
usart header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • spi
  • crc_transfer_polling
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usart
  • transfer_by_dma_interrupt
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • xmc
  • lcd_8bit
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f435/examples/xmc/lcd_8bit/inc/picture.h [code]
this file contains all the picture used for lcd display.
file | at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h [code]
xmc_lcd header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • spi
  • halfduplex_interrupt
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: wdt_standby Directory Reference

  • at_start_f435
  • examples
  • wdt
  • wdt_standby
wdt_standby Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: calculation Directory Reference

  • at_start_f435
  • examples
  • crc
  • calculation
calculation Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • scfg
  • mem_map_sel
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • dac
  • two_dac_trianglewave
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • adc
  • ordinary_preempt_oversampling
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • i2c
  • communication_dma
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • spi
  • halfduplex_interrupt
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/spi/halfduplex_interrupt/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • virtual_msc_iap
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h [code]
fat16 file system header file
file | at_start_f437/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h [code]
usb mass storage disk interface header file
file | project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: smartcard Directory Reference

  • at_start_f435
  • examples
  • usart
  • smartcard
smartcard Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: transfer_by_dma_polling Directory Reference

  • at_start_f437
  • examples
  • usart
  • transfer_by_dma_polling
transfer_by_dma_polling Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: idle_detection Directory Reference

  • at_start_f435
  • examples
  • usart
  • idle_detection
idle_detection Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_input
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: interrupt Directory Reference

  • at_start_f437
  • examples
  • usart
  • interrupt
interrupt Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • spi
  • halfduplex_transceiver_switch
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • pwc
  • standby_wakeup_pin
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/pwc/standby_wakeup_pin/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/pwc/standby_wakeup_pin/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • adc
  • software_trigger_repeat
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • xmc
  • nand_flash
  • nand
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c [code]
main program
file | at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c [code]
nand configuration


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • crc
  • calculation
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/crc/calculation/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/crc/calculation/src/main.c [code]
main program


AT32F435/437 Firmwary Library: debug Directory Reference

  • at_start_f435
  • examples
  • debug
debug Directory Reference

Directories

directory tmr1


AT32F435/437 Firmwary Library: oc_high Directory Reference

  • at_start_f435
  • examples
  • tmr
  • oc_high
oc_high Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: dmamux_synchronization_exint Directory Reference

  • at_start_f437
  • examples
  • dma
  • dmamux_synchronization_exint
dmamux_synchronization_exint Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • wdt
  • wdt_standby
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: fap_enable Directory Reference

  • at_start_f437
  • examples
  • flash
  • fap_enable
fap_enable Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usart
  • smartcard
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usart/smartcard/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usart/smartcard/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • crc
  • calculation
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/crc/calculation/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/crc/calculation/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/crc/calculation/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • encoder_tmr2
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • keil_flm
  • src
src Directory Reference

Files

file | FlashDev.c [code]
device description for new device flash
file | FlashPrg.c [code]
device algorithm for new device flash


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • virtual_msc_iap
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c [code]
main interrupt service routines.
file | at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c [code]
fat16 file system
file | project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c [code]
main program
file | at_start_f435/examples/usb_device/virtual_msc_iap/src/msc_diskio.c [code]
usb mass storage disk function


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • adc
  • resolution_6bit
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/adc/resolution_6bit/src/main.c [code]
main program


AT32F435/437 Firmwary Library: sdram_dma Directory Reference

  • at_start_f437
  • examples
  • xmc
  • sdram_dma
sdram_dma Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • crm
  • pll_parameter_calculate
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_tamper
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_sinewave
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: spii2s_switch_halfduplex_polling Directory Reference

  • at_start_f435
  • examples
  • i2s
  • spii2s_switch_halfduplex_polling
spii2s_switch_halfduplex_polling Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • cortex_m4
  • fpu
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f435/examples/cortex_m4/fpu/inc/julia_fpu.h [code]
julia_fpu header file


AT32F435/437 Firmwary Library: sleep_tmr2 Directory Reference

  • at_start_f437
  • examples
  • pwc
  • sleep_tmr2
sleep_tmr2 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: cortex_m4 Directory Reference

  • at_start_f435
  • examples
  • cortex_m4
cortex_m4 Directory Reference

Directories

directory | bit_band
directory | cmsis_dsp
directory | fpu
directory | systick_interrupt


AT32F435/437 Firmwary Library: lcd_touch_16bit Directory Reference

  • at_start_f437
  • examples
  • xmc
  • lcd_touch_16bit
lcd_touch_16bit Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: deepsleep_ertc_alarm Directory Reference

  • at_start_f437
  • examples
  • pwc
  • deepsleep_ertc_alarm
deepsleep_ertc_alarm Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: project Directory Reference

  • project
project Directory Reference

Directories

directory | at32f435_437_board
directory | at_start_f435
directory | at_start_f437


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • exint
  • exint_software_trigger
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • pwc
  • deepsleep_ertc_wakeup
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/src/main.c [code]
main program


AT32F435/437 Firmwary Library: two_dimension_mode Directory Reference

  • at_start_f435
  • examples
  • edma
  • two_dimension_mode
two_dimension_mode Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: interrupt Directory Reference

  • at_start_f435
  • examples
  • usart
  • interrupt
interrupt Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: pwm_input Directory Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_input
pwm_input Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: combine_mode_ordinary_shift_twoslave_dma3 Directory Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma3
combine_mode_ordinary_shift_twoslave_dma3 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: wake_on_lan Directory Reference

  • at_start_f437
  • examples
  • emac
  • wake_on_lan
wake_on_lan Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • exint
  • exint_config
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • adc
  • current_vref_value_check
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: tx_rx_swap Directory Reference

  • at_start_f437
  • examples
  • usart
  • tx_rx_swap
tx_rx_swap Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • adc
  • resolution_6bit
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: pwm_input_dma Directory Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_input_dma
pwm_input_dma Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • spi
  • fullduplex_polling
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • crm
  • sysclk_switch
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/crm/sysclk_switch/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • parallel_synchro
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: filter Directory Reference

  • at_start_f435
  • examples
  • can
  • filter
filter Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • i2s
  • halfduplex_dma
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c [code]
main program


AT32F435/437 Firmwary Library: io_toggle Directory Reference

  • at_start_f435
  • examples
  • gpio
  • io_toggle
io_toggle Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma5
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c [code]
main program


AT32F435/437 Firmwary Library: only_receive_mode_polling Directory Reference

  • at_start_f437
  • examples
  • spi
  • only_receive_mode_polling
only_receive_mode_polling Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: combine_mode_ordinary_smlt_oneslave_dma2 Directory Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_dma2
combine_mode_ordinary_smlt_oneslave_dma2 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_polling
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c [code]
main program
file | at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c [code]
qspi_cmd_esmt32m program


AT32F435/437 Firmwary Library: composite_audio_hid Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • composite_audio_hid
composite_audio_hid Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: parallel_synchro Directory Reference

  • at_start_f437
  • examples
  • tmr
  • parallel_synchro
parallel_synchro Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_interrupt
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: keil_flm Directory Reference

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • keil_flm
keil_flm Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • flash
  • fap_enable
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: usart Directory Reference

  • at_start_f435
  • examples
  • usart
usart Directory Reference

Directories

directory | half_duplex
directory | hw_flow_control
directory | idle_detection
directory | interrupt
directory | irda
directory | polling
directory | printf
directory | receiver_mute
directory | rs485
directory | smartcard
directory | synchronous
directory | transfer_by_dma_interrupt
directory | transfer_by_dma_polling
directory | tx_rx_swap


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c [code]
main program
file | at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c [code]
qspi_cmd_esmt32m program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • emac
  • mqtt_client
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h [code]
header file of emac config program.
file | project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h [code]
file | mqtt_client.h [code]
mqtt client header
file | project/at_start_f437/examples/emac/mqtt_client/inc/netconf.h [code]
This file contains all the functions prototypes for the netconf.c file.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • ertc
  • wakeup_timer
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/ertc/wakeup_timer/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • gpio
  • swjtag_mux
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/gpio/swjtag_mux/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • audio
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usb_device/audio/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c [code]
main interrupt service routines.
file | at_start_f435/examples/usb_device/audio/src/audio_codec.c [code]
audio codec function
file | project/at_start_f435/examples/usb_device/audio/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • i2s
  • spii2s_switch_halfduplex_polling
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_data_to_gpio
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usart
  • synchronous
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • pwc
  • ldo_set
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: hw_flow_control Directory Reference

  • at_start_f435
  • examples
  • usart
  • hw_flow_control
hw_flow_control Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: current_vref_value_check Directory Reference

  • at_start_f437
  • examples
  • adc
  • current_vref_value_check
current_vref_value_check Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • scfg
  • mem_map_sel
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/scfg/mem_map_sel/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/scfg/mem_map_sel/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/scfg/mem_map_sel/src/main.c [code]
main program


AT32F435/437 Firmwary Library: burst_mode Directory Reference

  • at_start_f437
  • examples
  • edma
  • burst_mode
burst_mode Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • keil_flm
  • inc
inc Directory Reference

Files

file | utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | FlashOS.h [code]


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • xmc
  • psram
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/xmc/psram/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/xmc/psram/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f435/examples/xmc/psram/inc/xmc_psram.h [code]


AT32F435/437 Firmwary Library: fullduplex_dma Directory Reference

  • at_start_f435
  • examples
  • i2s
  • fullduplex_dma
fullduplex_dma Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • cortex_m4
  • systick_interrupt
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • adc
  • vbat_monitor
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/adc/vbat_monitor/src/main.c [code]
main program


AT32F435/437 Firmwary Library: combine_mode_ordinary_shift_twoslave_dma4 Directory Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma4
combine_mode_ordinary_shift_twoslave_dma4 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: polling Directory Reference

  • at_start_f437
  • examples
  • usart
  • polling
polling Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: complementary_signals Directory Reference

  • at_start_f435
  • examples
  • tmr
  • complementary_signals
complementary_signals Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • edma
  • i2s_halfduplex_edma_doublebuffer
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • dma_burst
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: halfduplex_interrupt Directory Reference

  • at_start_f435
  • examples
  • i2s
  • halfduplex_interrupt
halfduplex_interrupt Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • pwc
  • sleep_tmr2
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: exint_config Directory Reference

  • at_start_f437
  • examples
  • exint
  • exint_config
exint_config Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • cascade_synchro
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/cascade_synchro/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usart
  • idle_detection
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usart/idle_detection/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usart/idle_detection/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usart/idle_detection/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • libraries
  • drivers
  • src
src Directory Reference

Files

file | at32f435_437_acc.c [code]
contains all the functions for the acc firmware library
file | at32f435_437_adc.c [code]
contains all the functions for the adc firmware library
file | at32f435_437_can.c [code]
contains all the functions for the can firmware library
file | at32f435_437_crc.c [code]
contains all the functions for the crc firmware library
file | at32f435_437_crm.c [code]
contains all the functions for the crm firmware library
file | at32f435_437_dac.c [code]
contains all the functions for the dac firmware library
file | at32f435_437_debug.c [code]
file | at32f435_437_dma.c [code]
contains all the functions for the dma firmware library
file | at32f435_437_dvp.c [code]
contains all the functions for the dvp firmware library
file | at32f435_437_edma.c [code]
contains all the functions for the edma firmware library
file | at32f435_437_emac.c [code]
contains all the functions for the emac firmware library
file | at32f435_437_ertc.c [code]
contains all the functions for the ertc firmware library
file | at32f435_437_exint.c [code]
contains all the functions for the exint firmware library
file | at32f435_437_flash.c [code]
contains all the functions for the flash firmware library
file | at32f435_437_gpio.c [code]
contains all the functions for the gpio firmware library
file | at32f435_437_i2c.c [code]
contains all the functions for the i2c firmware library
file | at32f435_437_misc.c [code]
contains all the functions for the misc firmware library
file | at32f435_437_pwc.c [code]
contains all the functions for the pwc firmware library
file | at32f435_437_qspi.c [code]
contain all the functions for qspi firmware library
file | at32f435_437_scfg.c [code]
contains all the functions for the system config firmware library
file | at32f435_437_sdio.c [code]
contains all the functions for the sdio firmware library
file | at32f435_437_spi.c [code]
contains all the functions for the spi firmware library
file | at32f435_437_tmr.c [code]
contains all the functions for the tmr firmware library
file | at32f435_437_usart.c [code]
contains all the functions for the usart firmware library
file | at32f435_437_usb.c [code]
contains all the functions for the usb firmware library
file | at32f435_437_wdt.c [code]
contains all the functions for the wdt firmware library
file | at32f435_437_wwdt.c [code]
contains all the functions for the wwdt firmware library
file | at32f435_437_xmc.c [code]
contains all the functions for the xmc firmware library


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • edma
  • flash_to_sram
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • adc
  • ordinary_preempt_oversampling
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • app_led3_toggle
  • src
src Directory Reference

Files

file | utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c [code]
emac config program
file | utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_clock.c [code]
system clock config program
file | utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c [code]
main interrupt service routines.
file | utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/flash.c [code]
flash program
file | at32f437_emac_iap_demo/source_code/app_led3_toggle/src/iap.c [code]
iap program
file | utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/main.c [code]
main program
file | utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c [code]
network connection configuration
file | at32f437_emac_iap_demo/source_code/app_led3_toggle/src/tmr.c [code]
tmr program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usart
  • smartcard
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f435/examples/usart/smartcard/inc/smartcard_config.h [code]
header file of clock program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • spi
  • w25q_flash
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h [code]
header file of spi_flash


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usart
  • half_duplex
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usart/half_duplex/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • adc
  • voltage_monitoring
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/adc/voltage_monitoring/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/adc/voltage_monitoring/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/adc/voltage_monitoring/src/main.c [code]
main program


AT32F435/437 Firmwary Library: dvp Directory Reference

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • dvp
dvp Directory Reference

Files

file | at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c [code]
dvp program
file | at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.h [code]
header file of dvp program


AT32F435/437 Firmwary Library: double_mode_dma_squarewave Directory Reference

  • at_start_f437
  • examples
  • dac
  • double_mode_dma_squarewave
double_mode_dma_squarewave Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • spi
  • use_jtagpin_hardwarecs_dma
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c [code]
main program


AT32F435/437 Firmwary Library: telnet Directory Reference

  • at_start_f437
  • examples
  • emac
  • telnet
telnet Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: sleep_usart1 Directory Reference

  • at_start_f435
  • examples
  • pwc
  • sleep_usart1
sleep_usart1 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: templates Directory Reference

  • at_start_f437
  • templates
templates Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: xip_port_write_read Directory Reference

  • at_start_f437
  • examples
  • qspi
  • xip_port_write_read
xip_port_write_read Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: examples Directory Reference

  • at_start_f437
  • examples
examples Directory Reference

Directories

directory | acc
directory | adc
directory | can
directory | cortex_m4
directory | crc
directory | crm
directory | dac
directory | debug
directory | dma
directory | dvp
directory | edma
directory | emac
directory | ertc
directory | exint
directory | flash
directory | gpio
directory | i2c
directory | i2s
directory | irtmr
directory | pwc
directory | qspi
directory | scfg
directory | sdio
directory | spi
directory | sram
directory | tmr
directory | usart
directory | usb_device
directory | usb_host
directory | wdt
directory | wwdt
directory | xmc


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usart
  • irda
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usart/irda/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usart/irda/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usart/irda/src/main.c [code]
main program


AT32F435/437 Firmwary Library: main_page Directory Reference

  • main_page
main_page Directory Reference

Files

file main_page.h [code]


AT32F435/437 Firmwary Library: src Directory Reference

  • utilities
  • at32f435_437_slib_demo
  • project_l1
  • src
src Directory Reference

Files

file | project_l1/src/arm_fir_data.c [code]
file | utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_clock.c [code]
system clock config program
file | utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c [code]
main interrupt service routines.
file | utilities/at32f435_437_slib_demo/project_l1/src/main.c [code]
main program
file | project_l1/src/math_helper.c [code]


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • timer_base
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/timer_base/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • app_led4_toggle
  • src
src Directory Reference

Files

file | utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_clock.c [code]
system clock config program
file | utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c [code]
main interrupt service routines.
file | app_led4_toggle/src/hid_iap_user.c [code]
usb hid iap user file
file | utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c [code]
main program


AT32F435/437 Firmwary Library: ov2640_capture Directory Reference

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
ov2640_capture Directory Reference

Directories

directory | hardware
directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • complementary_signals
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • sdio
  • sdio_fatfs
  • src
src Directory Reference

Files

file | at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c [code]
this file provides a set of functions needed to manage the sdio/mmc card memory.
file | project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c [code]
main interrupt service routines.
file | at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c [code]
file | project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c [code]
main program


AT32F435/437 Firmwary Library: dma_burst Directory Reference

  • at_start_f435
  • examples
  • tmr
  • dma_burst
dma_burst Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: synchronous Directory Reference

  • at_start_f437
  • examples
  • usart
  • synchronous
synchronous Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: can Directory Reference

  • at_start_f435
  • examples
  • can
can Directory Reference

Directories

directory | communication_mode
directory | filter
directory | loopback_mode


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • dma
  • flash_to_sram
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/dma/flash_to_sram/src/main.c [code]
main program


AT32F435/437 Firmwary Library: utilities Directory Reference

  • utilities
utilities Directory Reference

Directories

directory | at32f435_437_freertos_demo
directory | at32f435_437_gen_random_number_demo
directory | at32f435_437_qspi_algorithm_demo
directory | at32f435_437_slib_demo
directory | at32f435_437_usart_iap_demo
directory | at32f435_437_usb_iap_demo
directory | at32f437_emac_iap_demo


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_alarm
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: crm Directory Reference

  • at_start_f435
  • examples
  • crm
crm Directory Reference

Directories

directory | clock_failure_detection
directory | pll_parameter_calculate
directory | sysclk_switch


AT32F435/437 Firmwary Library: tamper Directory Reference

  • at_start_f435
  • examples
  • ertc
  • tamper
tamper Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usart
  • tx_rx_swap
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: source_code Directory Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
source_code Directory Reference

Directories

directory | app_led3_toggle
directory | app_led4_toggle
directory | bootloader


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • printer
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usart
  • receiver_mute
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_dma2
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: use_jtagpin_hardwarecs_dma Directory Reference

  • at_start_f437
  • examples
  • spi
  • use_jtagpin_hardwarecs_dma
use_jtagpin_hardwarecs_dma Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • edma
  • dmamux_synchronization_exint
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/main.c [code]
main program


AT32F435/437 Firmwary Library: usbh_msc Directory Reference

  • middlewares
  • usbh_class
  • usbh_msc
usbh_msc Directory Reference

Files

file | usbh_msc_bot_scsi.c [code]
usb host msc bulk-only transfer and scsi type
file | usbh_msc_bot_scsi.h [code]
usb host msc bulk-only transfer and scsi header file
file | usbh_msc_class.c [code]
usb host msc class type
file | usbh_msc_class.h [code]
usb host msc class header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • encoder_tmr2
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: lcd_8bit Directory Reference

  • at_start_f435
  • examples
  • xmc
  • lcd_8bit
lcd_8bit Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • templates
  • src
src Directory Reference

Files

file | project/at_start_f437/templates/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/templates/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/templates/src/main.c [code]
main program


AT32F435/437 Firmwary Library: sdio Directory Reference

  • at_start_f435
  • examples
  • sdio
sdio Directory Reference

Directories

directory | sd_mmc_card
directory | sdio_fatfs


AT32F435/437 Firmwary Library: w25q_flash Directory Reference

  • at_start_f437
  • examples
  • spi
  • w25q_flash
w25q_flash Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: composite_vcp_msc Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_msc
composite_vcp_msc Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • oc_high
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • bootloader
  • inc
inc Directory Reference

Files

file | utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h [code]
header file of emac config program.
file | utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_clock.h [code]
header file of clock program
file | utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/flash.h [code]
flash header file
file | utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h [code]
fsdata header file
file | httpserver.h [code]
httpserver header file
file | at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h [code]
iap header file
file | utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h [code]
file | utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/netconf.h [code]
This file contains all the functions prototypes for the netconf.c file.
file | tftpserver.h [code]
file | at32f437_emac_iap_demo/source_code/bootloader/inc/tmr.h [code]
tmr header file


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • oc_low
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/oc_low/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/oc_low/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/oc_low/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • scfg
  • mem_map_sel
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/scfg/mem_map_sel/src/main.c [code]
main program


AT32F435/437 Firmwary Library: sd_mmc_card Directory Reference

  • at_start_f437
  • examples
  • sdio
  • sd_mmc_card
sd_mmc_card Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • xmc
  • sdram_dma
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h [code]
header file for the sdram configuration.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usart
  • polling
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usart/polling/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usart/polling/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usart/polling/src/main.c [code]
main program


AT32F435/437 Firmwary Library: irtmr Directory Reference

  • at_start_f437
  • examples
  • irtmr
irtmr Directory Reference

Directories

directory irtmr_output


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usart
  • synchronous
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usart/synchronous/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usart/synchronous/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • gpio
  • led_toggle
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • emac
  • telnet
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/emac/telnet/src/at32_emac.c [code]
emac config program
file | project/at_start_f437/examples/emac/telnet/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/emac/telnet/src/main.c [code]
main program
file | project/at_start_f437/examples/emac/telnet/src/netconf.c [code]
network connection configuration
file | telnet.c [code]
telnet implement header file


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • xmc
  • sram
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/xmc/sram/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/xmc/sram/src/main.c [code]
main program
file | at_start_f435/examples/xmc/sram/src/xmc_sram.c [code]
sram program.


AT32F435/437 Firmwary Library: complementary_signals Directory Reference

  • at_start_f437
  • examples
  • tmr
  • complementary_signals
complementary_signals Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: command_port_using_dma Directory Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma
command_port_using_dma Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • crm
  • clock_failure_detection
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/crm/clock_failure_detection/src/main.c [code]
main program


AT32F435/437 Firmwary Library: wdt Directory Reference

  • at_start_f437
  • examples
  • wdt
wdt Directory Reference

Directories

directory | wdt_reset
directory | wdt_standby


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • edma
  • burst_mode
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • composite_vcp_keyboard
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • adc
  • edma_double_buffer
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/adc/edma_double_buffer/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/adc/edma_double_buffer/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/adc/edma_double_buffer/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • tmr2_32bit
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • i2s
  • halfduplex_dma
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_rdsr_sw
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c [code]
main program
file | at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c [code]
qspi_cmd_esmt32m program


AT32F435/437 Firmwary Library: tmr_trigger_automatic_preempted Directory Reference

  • at_start_f437
  • examples
  • adc
  • tmr_trigger_automatic_preempted
tmr_trigger_automatic_preempted Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: edma Directory Reference

  • at_start_f437
  • examples
  • edma
edma Directory Reference

Directories

directory | burst_mode
directory | dmamux_genertor_exint
directory | dmamux_synchronization_exint
directory | flash_to_sram
directory | i2s_halfduplex_edma_doublebuffer
directory | link_list_mode
directory | two_dimension_mode


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • xmc
  • lcd_touch_16bit
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h [code]
this file contains all the functions prototypes for the touch firmware driver.
file | at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h [code]
xmc_lcd program header


AT32F435/437 Firmwary Library: internal_temperature_sensor Directory Reference

  • at_start_f435
  • examples
  • adc
  • internal_temperature_sensor
internal_temperature_sensor Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • pwc
  • ldo_set
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/pwc/ldo_set/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/pwc/ldo_set/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/pwc/ldo_set/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • composite_audio_hid
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usb_device/composite_audio_hid/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c [code]
main interrupt service routines.
file | at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c [code]
audio codec function
file | project/at_start_f437/examples/usb_device/composite_audio_hid/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_output_simulate
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usb_host
  • hid_demo
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h [code]
usb config header file
file | at_start_f437/examples/usb_host/hid_demo/inc/usbh_user.h [code]
usb host user header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • i2s
  • fullduplex_dma
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: dmamux_synchronization_exint Directory Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_synchronization_exint
dmamux_synchronization_exint Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_and_pem
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: combine_mode_preempt_interltrig_twoslave Directory Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_preempt_interltrig_twoslave
combine_mode_preempt_interltrig_twoslave Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • xmc
  • sdram_dma
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/xmc/sdram_dma/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/xmc/sdram_dma/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/xmc/sdram_dma/src/main.c [code]
main program
file | at_start_f437/examples/xmc/sdram_dma/src/xmc_sdram.c [code]
sdram program.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usart
  • smartcard
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usart/smartcard/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usart/smartcard/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usart/smartcard/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_wakeup
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • tmr1_synchro
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/tmr1_synchro/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/tmr1_synchro/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/tmr1_synchro/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • xmc
  • nand_flash
  • nand
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h [code]
header file for the nand configuration.


AT32F435/437 Firmwary Library: otg1_host_otg2_device_demo Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
otg1_host_otg2_device_demo Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr3
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c [code]
main program


AT32F435/437 Firmwary Library: deepsleep_ertc_tamper Directory Reference

  • at_start_f437
  • examples
  • pwc
  • deepsleep_ertc_tamper
deepsleep_ertc_tamper Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: 6_steps Directory Reference

  • at_start_f435
  • examples
  • tmr
  • 6_steps
6_steps Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • hang_mode
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/dvp/ov5640_capture/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/dvp/ov5640_capture/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/dvp/ov5640_capture/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • debug
  • tmr1
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: tcp_server Directory Reference

  • at_start_f437
  • examples
  • emac
  • tcp_server
tcp_server Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: device_support Directory Reference

  • libraries
  • cmsis
  • cm4
  • device_support
device_support Directory Reference

Files

file | at32f435_437.h [code]
at32f435_437 header file
file | system_at32f435_437.c [code]
contains all the functions for cmsis cortex-m4 system source file
file | system_at32f435_437.h [code]
cmsis cortex-m4 system header file.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • virtual_msc_iap
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usb_device/virtual_msc_iap/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c [code]
main interrupt service routines.
file | at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c [code]
fat16 file system
file | project/at_start_f437/examples/usb_device/virtual_msc_iap/src/main.c [code]
main program
file | at_start_f437/examples/usb_device/virtual_msc_iap/src/msc_diskio.c [code]
usb mass storage disk function


AT32F435/437 Firmwary Library: two_otg_device_demo Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • two_otg_device_demo
two_otg_device_demo Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma5
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • pwc
  • deepsleep_ertc_tamper
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: drivers Directory Reference

  • libraries
  • drivers
drivers Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: vbat_monitor Directory Reference

  • at_start_f437
  • examples
  • adc
  • vbat_monitor
vbat_monitor Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: mouse Directory Reference

  • middlewares
  • usbd_class
  • mouse
mouse Directory Reference

Files

file | mouse_class.c [code]
usb hid mouse class type
file | mouse_class.h [code]
usb hid mouse header file
file | mouse_desc.c [code]
usb hid mouse device descriptor
file | mouse_desc.h [code]
usb mouse descriptor header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • adc
  • software_trigger_repeat
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • adc
  • resolution_6bit
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usart
  • irda
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usart/irda/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usart/irda/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: ordinary_preempt_oversampling Directory Reference

  • at_start_f435
  • examples
  • adc
  • ordinary_preempt_oversampling
ordinary_preempt_oversampling Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • i2s
  • fullduplex_dma
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/i2s/fullduplex_dma/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/i2s/fullduplex_dma/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • emac
  • wake_on_lan
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h [code]
header file of emac config program.
file | project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h [code]
file | project/at_start_f437/examples/emac/wake_on_lan/inc/netconf.h [code]
This file contains all the functions prototypes for the netconf.c file.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usart
  • receiver_mute
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usart/receiver_mute/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usart/receiver_mute/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usart/receiver_mute/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usart
  • tx_rx_swap
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usart/tx_rx_swap/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usb_host
  • msc_only_fat32
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h [code]
file | project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h [code]
usb config header file
file | at_start_f437/examples/usb_host/msc_only_fat32/inc/usbh_user.h [code]
usb host user header file


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • dma
  • dmamux_genertor_exint
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/dma/dmamux_genertor_exint/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/dma/dmamux_genertor_exint/src/main.c [code]
main program


AT32F435/437 Firmwary Library: one_cycle Directory Reference

  • at_start_f435
  • examples
  • tmr
  • one_cycle
one_cycle Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: command_port_using_interrupt Directory Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_interrupt
command_port_using_interrupt Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: sdio Directory Reference

  • at_start_f437
  • examples
  • sdio
sdio Directory Reference

Directories

directory | sd_mmc_card
directory | sdio_fatfs


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c [code]
main program
file | at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c [code]
usb user function
file | at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.h [code]
usb host user header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_dma
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/qspi/command_port_using_dma/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/qspi/command_port_using_dma/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/qspi/command_port_using_dma/src/main.c [code]
main program
file | at_start_f437/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c [code]
qspi_cmd_esmt32m program


AT32F435/437 Firmwary Library: tcp_client Directory Reference

  • at_start_f437
  • examples
  • emac
  • tcp_client
tcp_client Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_dma2
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr10
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: deepsleep_ertc_wakeup Directory Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_wakeup
deepsleep_ertc_wakeup Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • xmc
  • lcd_touch_16bit
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/xmc/lcd_touch_16bit/src/main.c [code]
main program
file | at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c [code]
this file contains all the functions prototypes for the touch firmware driver.
file | at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c [code]
xmc_lcd program file


AT32F435/437 Firmwary Library: vbat_monitor Directory Reference

  • at_start_f435
  • examples
  • adc
  • vbat_monitor
vbat_monitor Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: lcd_touch_16bit Directory Reference

  • at_start_f435
  • examples
  • xmc
  • lcd_touch_16bit
lcd_touch_16bit Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • input_capture
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usart
  • synchronous
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usart/synchronous/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usart/synchronous/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usart/synchronous/src/main.c [code]
main program


AT32F435/437 Firmwary Library: hw_flow_control Directory Reference

  • at_start_f437
  • examples
  • usart
  • hw_flow_control
hw_flow_control Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • oc_low
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/oc_low/src/main.c [code]
main program


AT32F435/437 Firmwary Library: fpu Directory Reference

  • at_start_f435
  • examples
  • cortex_m4
  • fpu
fpu Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: cmsis_dsp Directory Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
cmsis_dsp Directory Reference

Directories

directory | inc
directory | mdk_v5
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • spi
  • crc_transfer_polling
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_audio_hid
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c [code]
main interrupt service routines.
file | at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c [code]
audio codec function
file | project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c [code]
main program


AT32F435/437 Firmwary Library: link_list_mode Directory Reference

  • at_start_f437
  • examples
  • edma
  • link_list_mode
link_list_mode Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • i2c
  • eeprom
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/i2c/eeprom/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/i2c/eeprom/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/i2c/eeprom/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • cortex_m4
  • fpu
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f437/examples/cortex_m4/fpu/inc/julia_fpu.h [code]
julia_fpu header file


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • wdt
  • wdt_standby
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/wdt/wdt_standby/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • dma
  • dmamux_data_to_gpio
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/dvp/ov5640_capture/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • dma
  • flash_to_sram
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • gpio
  • led_toggle
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/gpio/led_toggle/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • spi
  • only_receive_mode_polling
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • emac
  • http_server
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/emac/http_server/src/at32_emac.c [code]
emac config program
file | project/at_start_f437/examples/emac/http_server/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c [code]
main interrupt service routines.
file | fs.c [code]
file | project/at_start_f437/examples/emac/http_server/src/fsdata.c [code]
file | httpd.c [code]
file | project/at_start_f437/examples/emac/http_server/src/main.c [code]
main program
file | project/at_start_f437/examples/emac/http_server/src/netconf.c [code]
network connection configuration


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • dma
  • dmamux_synchronization_exint
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/main.c [code]
main program


AT32F435/437 Firmwary Library: crc Directory Reference

  • at_start_f437
  • examples
  • crc
crc Directory Reference

Directories

directory calculation


AT32F435/437 Firmwary Library: power_voltage_monitor Directory Reference

  • at_start_f435
  • examples
  • pwc
  • power_voltage_monitor
power_voltage_monitor Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: tmr Directory Reference

  • at_start_f437
  • examples
  • tmr
tmr Directory Reference

Directories

directory | 6_steps
directory | 7_pwm_output
directory | cascade_synchro
directory | complementary_signals
directory | dma
directory | dma_burst
directory | encoder_tmr2
directory | external_clock
directory | hall_xor_tmr2
directory | hang_mode
directory | input_capture
directory | oc_high
directory | oc_low
directory | oc_toggle_tmr3
directory | oc_toggle_tmr9
directory | one_cycle
directory | parallel_synchro
directory | pwm_input
directory | pwm_input_dma
directory | pwm_output_simulate
directory | pwm_output_tmr10
directory | pwm_output_tmr3
directory | timer_base
directory | tmr1_synchro
directory | tmr2_32bit


AT32F435/437 Firmwary Library: half_duplex Directory Reference

  • at_start_f437
  • examples
  • usart
  • half_duplex
half_duplex Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • mouse
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usb_device/mouse/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usb_device/mouse/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usb_device/mouse/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • virtual_comport
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: nand_flash Directory Reference

  • at_start_f437
  • examples
  • xmc
  • nand_flash
nand_flash Directory Reference

Directories

directory | ecc
directory | nand


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • wwdt
  • wwdt_reset
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: software_trigger_repeat Directory Reference

  • at_start_f435
  • examples
  • adc
  • software_trigger_repeat
software_trigger_repeat Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: tmr1 Directory Reference

  • at_start_f435
  • examples
  • debug
  • tmr1
tmr1 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: pwm_input_dma Directory Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_input_dma
pwm_input_dma Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • cortex_m4
  • systick_interrupt
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • dma
  • flash_to_sram
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • dma
  • dmamux_data_to_gpio
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/dma/dmamux_data_to_gpio/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/dma/dmamux_data_to_gpio/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • bootloader
  • inc
inc Directory Reference

Files

file | utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_clock.h [code]
header file of clock program
file | utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | bootloader/inc/hid_iap_user.h [code]
usb config header file
file | utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: app_led3_toggle Directory Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led3_toggle
app_led3_toggle Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • ertc
  • wakeup_timer
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: exint_config Directory Reference

  • at_start_f435
  • examples
  • exint
  • exint_config
exint_config Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • pwc
  • ldo_set
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: composite_audio_hid Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_audio_hid
composite_audio_hid Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • spi
  • halfduplex_transceiver_switch
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • vcp_loopback
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: sdram_basic Directory Reference

  • at_start_f437
  • examples
  • xmc
  • sdram_basic
sdram_basic Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: dma Directory Reference

  • at_start_f435
  • examples
  • tmr
  • dma
dma Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: flash Directory Reference

  • at_start_f437
  • examples
  • flash
flash Directory Reference

Directories

directory | fap_enable
directory | flash_write_read


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • i2s
  • halfduplex_interrupt
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_simulate
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • adc
  • vbat_monitor
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: Objects Directory Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
Objects Directory Reference

Files

file | at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_board.d [code]
file | at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_clock.d [code]
file | at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_crm.d [code]
file | at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_gpio.d [code]
file | at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_int.d [code]
file | at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_misc.d [code]
file | at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_usart.d [code]
file | at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/basicmathfunctions.d [code]
file | at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/bayesfunctions.d [code]
file | at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/commontables.d [code]
file | at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/complexmathfunctions.d [code]
file | at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/controllerfunctions.d [code]
file | at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/distancefunctions.d [code]
file | at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/fastmathfunctions.d [code]
file | at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/filteringfunctions.d [code]
file | at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/main.d [code]
file | at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/matrixfunctions.d [code]
file | at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/startup_at32f435_437.d [code]
file | at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/statisticsfunctions.d [code]
file | at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/supportfunctions.d [code]
file | at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/svmfunctions.d [code]
file | at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/system_at32f435_437.d [code]
file | at_start_f435/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/transformfunctions.d [code]


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/main.c [code]
main program
file | at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c [code]
qspi_cmd_esmt32m program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • edma
  • burst_mode
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/edma/burst_mode/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/edma/burst_mode/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/edma/burst_mode/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/dvp/ov2640_capture/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/dvp/ov2640_capture/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/dvp/ov2640_capture/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_input
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/pwm_input/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/pwm_input/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/pwm_input/src/main.c [code]
main program


AT32F435/437 Firmwary Library: halfduplex_interrupt Directory Reference

  • at_start_f437
  • examples
  • i2s
  • halfduplex_interrupt
halfduplex_interrupt Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • pwc
  • ldo_set
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/pwc/ldo_set/src/main.c [code]
main program


AT32F435/437 Firmwary Library: hardware Directory Reference

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • hardware
hardware Directory Reference

Directories

directory | dvp
directory | lcd
directory | ov5640


AT32F435/437 Firmwary Library: pwc Directory Reference

  • at_start_f437
  • examples
  • pwc
pwc Directory Reference

Directories

directory | deepsleep_ertc_alarm
directory | deepsleep_ertc_tamper
directory | deepsleep_ertc_wakeup
directory | ldo_set
directory | power_voltage_monitor
directory | sleep_tmr2
directory | sleep_usart1
directory | standby_ertc_alarm
directory | standby_wakeup_pin


AT32F435/437 Firmwary Library: two_dac_trianglewave Directory Reference

  • at_start_f437
  • examples
  • dac
  • two_dac_trianglewave
two_dac_trianglewave Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_dma_and_pem
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/main.c [code]
main program
file | at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c [code]
qspi_cmd_esmt32m program


AT32F435/437 Firmwary Library: bpr_domain Directory Reference

  • at_start_f437
  • examples
  • ertc
  • bpr_domain
bpr_domain Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • ertc
  • tamper
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/ertc/tamper/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/ertc/tamper/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • i2c
  • communication_dma
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/i2c/communication_dma/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • xmc
  • nand_flash
  • ecc
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h [code]
header file for the nand ecc configuration.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_interrupt
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/qspi/command_port_using_interrupt/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/qspi/command_port_using_interrupt/src/main.c [code]
main program
file | at_start_f437/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c [code]
qspi_cmd_esmt32m program


AT32F435/437 Firmwary Library: led_toggle Directory Reference

  • at_start_f437
  • examples
  • gpio
  • led_toggle
led_toggle Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • cortex_m4
  • bit_band
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/cortex_m4/bit_band/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/cortex_m4/bit_band/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/cortex_m4/bit_band/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • crm
  • clock_failure_detection
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • audio
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f435/examples/usb_device/audio/inc/audio_codec.h [code]
audio codec header file
file | project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usart
  • interrupt
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usart/interrupt/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usart/interrupt/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usart/interrupt/src/main.c [code]
main program


AT32F435/437 Firmwary Library: source_code Directory Reference

  • utilities
  • at32f437_emac_iap_demo
  • source_code
source_code Directory Reference

Directories

directory | app_led3_toggle
directory | bootloader


AT32F435/437 Firmwary Library: sram Directory Reference

  • at_start_f437
  • examples
  • sram
sram Directory Reference

Directories

directory extend_sram


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • i2c
  • eeprom
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/i2c/eeprom/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • dma
  • dmamux_synchronization_exint
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • utilities
  • at32f435_437_slib_demo
  • project_l0
  • src
src Directory Reference

Files

file | project_l0/src/arm_fir_data.c [code]
file | arm_fir_init_f32.c [code]
file | utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_clock.c [code]
system clock config program
file | utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c [code]
main interrupt service routines.
file | fir_coefficient.c [code]
file | fir_filter.c [code]
file | utilities/at32f435_437_slib_demo/project_l0/src/main.c [code]
main program
file | project_l0/src/math_helper.c [code]


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • adc
  • edma_double_buffer
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • spi
  • fullduplex_polling
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/spi/fullduplex_polling/src/main.c [code]
main program


AT32F435/437 Firmwary Library: cm4 Directory Reference

  • libraries
  • cmsis
  • cm4
cm4 Directory Reference

Directories

directory device_support


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_and_pem
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c [code]
main program
file | at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c [code]
qspi_cmd_esmt32m program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usart
  • tx_rx_swap
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usart/tx_rx_swap/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usart/tx_rx_swap/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usart/tx_rx_swap/src/main.c [code]
main program


AT32F435/437 Firmwary Library: oc_toggle_tmr9 Directory Reference

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr9
oc_toggle_tmr9 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • hang_mode
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • i2c
  • eeprom
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • spi
  • halfduplex_interrupt
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • i2c
  • communication_int
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • cortex_m4
  • bit_band
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usb_host
  • two_otg_host_demo
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h [code]
file | project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h [code]
usb config header file
file | at_start_f437/examples/usb_host/two_otg_host_demo/inc/usbh_user.h [code]
usb host user header file


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • xmc
  • sdram_dma
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/xmc/sdram_dma/src/main.c [code]
main program
file | at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c [code]
sdram program.


AT32F435/437 Firmwary Library: scfg Directory Reference

  • at_start_f437
  • examples
  • scfg
scfg Directory Reference

Directories

directory mem_map_sel


AT32F435/437 Firmwary Library: resolution_6bit Directory Reference

  • at_start_f437
  • examples
  • adc
  • resolution_6bit
resolution_6bit Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_edma
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • edma
  • dmamux_synchronization_exint
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: printf Directory Reference

  • at_start_f435
  • examples
  • usart
  • printf
printf Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: eeprom Directory Reference

  • at_start_f435
  • examples
  • i2c
  • eeprom
eeprom Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_polling
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • irtmr
  • irtmr_output
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usart
  • polling
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usart/polling/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usart/polling/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • 7_pwm_output
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: keyboard Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • keyboard
keyboard Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: exint Directory Reference

  • at_start_f435
  • examples
  • exint
exint Directory Reference

Directories

directory | exint_config
directory | exint_software_trigger


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_msc
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h [code]
usb mass storage disk interface header file
file | project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: cmsis_dsp Directory Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
cmsis_dsp Directory Reference

Directories

directory | inc
directory | mdk_v5
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • one_cycle
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: crm Directory Reference

  • at_start_f437
  • examples
  • crm
crm Directory Reference

Directories

directory | clock_failure_detection
directory | pll_parameter_calculate
directory | sysclk_switch


AT32F435/437 Firmwary Library: src Directory Reference

  • utilities
  • at32f435_437_gen_random_number_demo
  • src
src Directory Reference

Files

file | utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_clock.c [code]
system clock config program
file | utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c [code]
main interrupt service routines.
file | utilities/at32f435_437_gen_random_number_demo/src/main.c [code]
main program
file | random.c [code]
set of firmware functions to random function


AT32F435/437 Firmwary Library: mqtt_client Directory Reference

  • at_start_f437
  • examples
  • emac
  • mqtt_client
mqtt_client Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: oc_high Directory Reference

  • at_start_f437
  • examples
  • tmr
  • oc_high
oc_high Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • adc
  • current_vref_value_check
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/adc/current_vref_value_check/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • adc
  • tmr_trigger_automatic_preempted
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: virtual_comport Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • virtual_comport
virtual_comport Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: transfer_by_dma_interrupt Directory Reference

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_interrupt
transfer_by_dma_interrupt Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • edma
  • dmamux_genertor_exint
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/edma/dmamux_genertor_exint/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/edma/dmamux_genertor_exint/src/main.c [code]
main program


AT32F435/437 Firmwary Library: msc Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • msc
msc Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • wdt
  • wdt_reset
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/dvp/ov2640_capture/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • dma
  • flash_to_sram
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/dma/flash_to_sram/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/dma/flash_to_sram/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/dma/flash_to_sram/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • bootloader
  • inc
inc Directory Reference

Files

file | utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_clock.h [code]
header file of clock program
file | utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/flash.h [code]
flash header file
file | at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h [code]
iap header file
file | at32f435_437_usart_iap_demo/source_code/bootloader/inc/tmr.h [code]
tmr header file
file | bootloader/inc/usart.h [code]
usart header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usart
  • half_duplex
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: nor_flash Directory Reference

  • at_start_f437
  • examples
  • xmc
  • nor_flash
nor_flash Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_preempt_interltrig_twoslave
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c [code]
main program


AT32F435/437 Firmwary Library: oc_toggle_tmr9 Directory Reference

  • at_start_f437
  • examples
  • tmr
  • oc_toggle_tmr9
oc_toggle_tmr9 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • wdt
  • wdt_standby
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • qspi
  • xip_port_write_read
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_polling
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: audio_hid Directory Reference

  • middlewares
  • usbd_class
  • audio_hid
audio_hid Directory Reference

Files

file | audio_hid/audio_conf.h [code]
usb audio config
file | audio_hid_class.c [code]
file | audio_hid_class.h [code]
file | audio_hid_desc.c [code]
file | audio_hid_desc.h [code]


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usart
  • transfer_by_dma_polling
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usart/transfer_by_dma_polling/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usart/transfer_by_dma_polling/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_input
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/pwm_input/src/main.c [code]
main program


AT32F435/437 Firmwary Library: acc Directory Reference

  • at_start_f435
  • examples
  • acc
acc Directory Reference

Directories

directory calibration


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_output_tmr3
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • adc
  • internal_temperature_sensor
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: halfduplex_interrupt Directory Reference

  • at_start_f435
  • examples
  • spi
  • halfduplex_interrupt
halfduplex_interrupt Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • ertc
  • lick_calibration
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • timer_base
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: mem_map_sel Directory Reference

  • at_start_f437
  • examples
  • scfg
  • mem_map_sel
mem_map_sel Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • edma
  • dmamux_synchronization_exint
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • adc
  • vbat_monitor
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: edma_double_buffer Directory Reference

  • at_start_f435
  • examples
  • adc
  • edma_double_buffer
edma_double_buffer Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: exint_trigger_partitioned Directory Reference

  • at_start_f437
  • examples
  • adc
  • exint_trigger_partitioned
exint_trigger_partitioned Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • cortex_m4
  • systick_interrupt
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/cortex_m4/systick_interrupt/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/cortex_m4/systick_interrupt/src/main.c [code]
main program


AT32F435/437 Firmwary Library: lcd_8bit Directory Reference

  • at_start_f437
  • examples
  • xmc
  • lcd_8bit
lcd_8bit Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: cmsis Directory Reference

  • libraries
  • cmsis
cmsis Directory Reference

Directories

directory cm4


AT32F435/437 Firmwary Library: dma Directory Reference

  • at_start_f437
  • examples
  • tmr
  • dma
dma Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • can
  • communication_mode
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: composite_vcp_keyboard Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • composite_vcp_keyboard
composite_vcp_keyboard Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: dvp Directory Reference

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • dvp
dvp Directory Reference

Files

file | at_start_f437/examples/dvp/ov2640_capture/hardware/dvp/dvp.c [code]
dvp program
file | at_start_f437/examples/dvp/ov2640_capture/hardware/dvp/dvp.h [code]
header file of dvp program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_dma2
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • virtual_comport
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usb_device/virtual_comport/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usb_device/virtual_comport/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usb_device/virtual_comport/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • pwc
  • standby_ertc_alarm
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/pwc/standby_ertc_alarm/src/main.c [code]
main program


AT32F435/437 Firmwary Library: loopback_mode Directory Reference

  • at_start_f435
  • examples
  • can
  • loopback_mode
loopback_mode Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • xmc
  • nor_flash
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h [code]


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • 6_steps
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/6_steps/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/6_steps/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/6_steps/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • gpio
  • io_toggle
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/gpio/io_toggle/src/main.c [code]
main program


AT32F435/437 Firmwary Library: one_dac_noisewave Directory Reference

  • at_start_f437
  • examples
  • dac
  • one_dac_noisewave
one_dac_noisewave Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • xmc
  • psram
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/xmc/psram/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/xmc/psram/src/main.c [code]
main program
file | at_start_f435/examples/xmc/psram/src/xmc_psram.c [code]
xmc_psram program


AT32F435/437 Firmwary Library: ov5640_capture Directory Reference

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
ov5640_capture Directory Reference

Directories

directory | hardware
directory | inc
directory | src


AT32F435/437 Firmwary Library: resolution_6bit Directory Reference

  • at_start_f435
  • examples
  • adc
  • resolution_6bit
resolution_6bit Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: sdram_dma Directory Reference

  • at_start_f435
  • examples
  • xmc
  • sdram_dma
sdram_dma Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: spii2s_switch_halfduplex_polling Directory Reference

  • at_start_f437
  • examples
  • i2s
  • spii2s_switch_halfduplex_polling
spii2s_switch_halfduplex_polling Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • cortex_m4
  • bit_band
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/cortex_m4/bit_band/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usb_host
  • msc_only_fat32
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usb_host/msc_only_fat32/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usb_host/msc_only_fat32/src/main.c [code]
main program
file | at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c [code]
usb mass storage disk io
file | at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c [code]
usb user function


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • oc_high
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/oc_high/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • utilities
  • at32f435_437_slib_demo
  • project_l1
  • inc
inc Directory Reference

Files

file | utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_clock.h [code]
header file of clock program
file | utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project_l1/inc/fir_filter.h [code]
file | project_l1/inc/math_helper.h [code]


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • vcp_loopback
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: standby_wakeup_pin Directory Reference

  • at_start_f435
  • examples
  • pwc
  • standby_wakeup_pin
standby_wakeup_pin Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: lcd Directory Reference

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • lcd
lcd Directory Reference

Files

file | at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h [code]
file | at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c [code]
xmc_lcd program file
file | at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h [code]
xmc_lcd program header


AT32F435/437 Firmwary Library: hardware Directory Reference

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • hardware
hardware Directory Reference

Directories

directory | dvp
directory | lcd
directory | ov5640


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usart
  • receiver_mute
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • adc
  • tmr_trigger_automatic_preempted
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c [code]
main program


AT32F435/437 Firmwary Library: oc_toggle_tmr3 Directory Reference

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr3
oc_toggle_tmr3 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • xmc
  • nor_flash
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/xmc/nor_flash/src/main.c [code]
main program
file | at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c [code]


AT32F435/437 Firmwary Library: tmr_trigger_automatic_preempted Directory Reference

  • at_start_f435
  • examples
  • adc
  • tmr_trigger_automatic_preempted
tmr_trigger_automatic_preempted Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: custom_hid Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • custom_hid
custom_hid Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • wwdt
  • wwdt_reset
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • emac
  • wake_on_lan
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/emac/wake_on_lan/src/at32_emac.c [code]
emac config program
file | project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/emac/wake_on_lan/src/main.c [code]
main program
file | project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c [code]
network connection configuration


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • tmr2_32bit
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/tmr2_32bit/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/tmr2_32bit/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/tmr2_32bit/src/main.c [code]
main program


AT32F435/437 Firmwary Library: sram Directory Reference

  • at_start_f435
  • examples
  • sram
sram Directory Reference

Directories

directory extend_sram


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • templates
  • inc
inc Directory Reference

Files

file | project/at_start_f437/templates/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/templates/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/templates/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • audio
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f437/examples/usb_device/audio/inc/audio_codec.h [code]
audio codec header file
file | project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: flash_to_sram Directory Reference

  • at_start_f435
  • examples
  • edma
  • flash_to_sram
flash_to_sram Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • can
  • loopback_mode
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/can/loopback_mode/src/main.c [code]
main program


AT32F435/437 Firmwary Library: wdt_reset Directory Reference

  • at_start_f437
  • examples
  • wdt
  • wdt_reset
wdt_reset Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • sdio
  • sdio_fatfs
  • inc
inc Directory Reference

Files

file | at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h [code]
this file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library.
file | project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h [code]


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • xmc
  • sdram_basic
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/xmc/sdram_basic/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/xmc/sdram_basic/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/xmc/sdram_basic/src/main.c [code]
main program
file | at_start_f437/examples/xmc/sdram_basic/src/xmc_sdram.c [code]
sdram program.


AT32F435/437 Firmwary Library: wwdt_reset Directory Reference

  • at_start_f437
  • examples
  • wwdt
  • wwdt_reset
wwdt_reset Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_output_tmr3
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/pwm_output_tmr3/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/pwm_output_tmr3/src/main.c [code]
main program


AT32F435/437 Firmwary Library: communication_smbus Directory Reference

  • at_start_f437
  • examples
  • i2c
  • communication_smbus
communication_smbus Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: composite_cdc_keyboard Directory Reference

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
composite_cdc_keyboard Directory Reference

Files

file | cdc_keyboard_class.c [code]
usb cdc and keyboard class type
file | cdc_keyboard_class.h [code]
usb cdc and keyboard class file
file | cdc_keyboard_desc.c [code]
usb cdc and keyboard device descriptor
file | cdc_keyboard_desc.h [code]
usb cdc and keyboard descriptor header file


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • i2c
  • communication_poll
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/i2c/communication_poll/src/main.c [code]
main program


AT32F435/437 Firmwary Library: receiver_mute Directory Reference

  • at_start_f435
  • examples
  • usart
  • receiver_mute
receiver_mute Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • exint
  • exint_software_trigger
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/exint/exint_software_trigger/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/exint/exint_software_trigger/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/exint/exint_software_trigger/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • ertc
  • wakeup_timer
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/ertc/wakeup_timer/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/ertc/wakeup_timer/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/ertc/wakeup_timer/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • edma
  • flash_to_sram
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/edma/flash_to_sram/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/edma/flash_to_sram/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/edma/flash_to_sram/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma4
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • i2s
  • halfduplex_interrupt
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/i2s/halfduplex_interrupt/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/i2s/halfduplex_interrupt/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • emac
  • mqtt_client
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/emac/mqtt_client/src/at32_emac.c [code]
emac config program
file | project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/emac/mqtt_client/src/main.c [code]
main program
file | mqtt_client.c [code]
mqtt client config program
file | project/at_start_f437/examples/emac/mqtt_client/src/netconf.c [code]
network connection configuration


AT32F435/437 Firmwary Library: hid_demo Directory Reference

  • at_start_f435
  • examples
  • usb_host
  • hid_demo
hid_demo Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • cascade_synchro
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/cascade_synchro/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/cascade_synchro/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/cascade_synchro/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • flash
  • fap_enable
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/flash/fap_enable/src/main.c [code]
main program


AT32F435/437 Firmwary Library: cdc Directory Reference

  • middlewares
  • usbd_class
  • cdc
cdc Directory Reference

Files

file | cdc_class.c [code]
usb cdc class type
file | cdc_class.h [code]
usb cdc class file
file | cdc_desc.c [code]
usb cdc device descriptor
file | cdc_desc.h [code]
usb cdc descriptor header file


AT32F435/437 Firmwary Library: command_port_using_dma_qpi_mode Directory Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
command_port_using_dma_qpi_mode Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma3
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • i2s
  • halfduplex_dma
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/i2s/halfduplex_dma/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/i2s/halfduplex_dma/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/i2s/halfduplex_dma/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • flash
  • flash_write_read
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f435/examples/flash/flash_write_read/inc/flash.h [code]
flash header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_input_dma
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • adc
  • software_trigger_repeat
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/adc/software_trigger_repeat/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/adc/software_trigger_repeat/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/adc/software_trigger_repeat/src/main.c [code]
main program


AT32F435/437 Firmwary Library: framework2 Directory Reference

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • iar_out
  • framework2
framework2 Directory Reference

Directories

directory template

Files

file | flash_loader.c [code]
file | flash_loader.h [code]
file | flash_loader_extra.h [code]


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • mouse
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • edma
  • i2s_halfduplex_edma_doublebuffer
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c [code]
main program


AT32F435/437 Firmwary Library: communication_smbus Directory Reference

  • at_start_f435
  • examples
  • i2c
  • communication_smbus
communication_smbus Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • adc
  • tmr_trigger_automatic_preempted
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • i2s
  • spii2s_switch_halfduplex_polling
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c [code]
main program


AT32F435/437 Firmwary Library: command_port_using_dma_qpi_mode Directory Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
command_port_using_dma_qpi_mode Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: at32f435_437_board Directory Reference

  • at32f435_437_board
at32f435_437_board Directory Reference

Files

file | at32f435_437_board.c [code]
set of firmware functions to manage leds and push-button. initialize delay function.
file | at32f435_437_board.h [code]


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • emac
  • tcp_server
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h [code]
header file of emac config program.
file | project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h [code]
file | project/at_start_f437/examples/emac/tcp_server/inc/netconf.h [code]
This file contains all the functions prototypes for the netconf.c file.
file | tcp_server.h [code]
tcp server header


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • keyboard
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: printf Directory Reference

  • at_start_f437
  • examples
  • usart
  • printf
printf Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: use_polling_get_conversion_data Directory Reference

  • at_start_f435
  • examples
  • adc
  • use_polling_get_conversion_data
use_polling_get_conversion_data Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: flash_to_sram Directory Reference

  • at_start_f437
  • examples
  • edma
  • flash_to_sram
flash_to_sram Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: wdt_standby Directory Reference

  • at_start_f437
  • examples
  • wdt
  • wdt_standby
wdt_standby Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usb_host
  • two_otg_host_demo
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h [code]
file | project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h [code]
usb config header file
file | at_start_f435/examples/usb_host/two_otg_host_demo/inc/usbh_user.h [code]
usb host user header file


AT32F435/437 Firmwary Library: usbh_class Directory Reference

  • middlewares
  • usbh_class
usbh_class Directory Reference

Directories

directory | usbh_hid
directory | usbh_msc


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • flash
  • fap_enable
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • dac
  • one_dac_noisewave
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: dac Directory Reference

  • at_start_f437
  • examples
  • dac
dac Directory Reference

Directories

directory | double_mode_dma_sinewave
directory | double_mode_dma_squarewave
directory | one_dac_dma_escalator
directory | one_dac_noisewave
directory | two_dac_trianglewave


AT32F435/437 Firmwary Library: exint_software_trigger Directory Reference

  • at_start_f437
  • examples
  • exint
  • exint_software_trigger
exint_software_trigger Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • complementary_signals
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: swjtag_mux Directory Reference

  • at_start_f437
  • examples
  • gpio
  • swjtag_mux
swjtag_mux Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usart
  • rs485
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usart/rs485/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usart/rs485/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_data_to_gpio
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • pwc
  • sleep_tmr2
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/pwc/sleep_tmr2/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • dma_burst
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/dma_burst/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/dma_burst/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/dma_burst/src/main.c [code]
main program


AT32F435/437 Firmwary Library: at_start_f435 Directory Reference

  • at_start_f435
at_start_f435 Directory Reference

Directories

directory | examples
directory | templates


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • 6_steps
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: msc_only_fat32 Directory Reference

  • at_start_f437
  • examples
  • usb_host
  • msc_only_fat32
msc_only_fat32 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • xmc
  • sdram_basic
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h [code]
header file for the sdram configuration.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • flash
  • flash_write_read
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/flash/flash_write_read/src/flash.c [code]
flash program
file | project/at_start_f435/examples/flash/flash_write_read/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_interrupt
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c [code]
main program


AT32F435/437 Firmwary Library: tmr1_synchro Directory Reference

  • at_start_f437
  • examples
  • tmr
  • tmr1_synchro
tmr1_synchro Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • dac
  • one_dac_noisewave
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/dac/one_dac_noisewave/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • audio
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usb_device/audio/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usb_device/audio/src/at32f435_437_int.c [code]
main interrupt service routines.
file | at_start_f437/examples/usb_device/audio/src/audio_codec.c [code]
audio codec function
file | project/at_start_f437/examples/usb_device/audio/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usart
  • transfer_by_dma_polling
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: clock_failure_detection Directory Reference

  • at_start_f437
  • examples
  • crm
  • clock_failure_detection
clock_failure_detection Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • cortex_m4
  • fpu
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c [code]
main interrupt service routines.
file | at_start_f435/examples/cortex_m4/fpu/src/julia_fpu.c [code]
julia_fpu source file
file | project/at_start_f435/examples/cortex_m4/fpu/src/main.c [code]
main program


AT32F435/437 Firmwary Library: templates Directory Reference

  • at_start_f435
  • templates
templates Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • adc
  • conversion_abort
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • cortex_m4
  • systick_interrupt
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/cortex_m4/systick_interrupt/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma3
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: emac Directory Reference

  • at_start_f437
  • examples
  • emac
emac Directory Reference

Directories

directory | dns_client
directory | http_server
directory | iperf
directory | mqtt_client
directory | tcp_client
directory | tcp_server
directory | telnet
directory | wake_on_lan


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • can
  • filter
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/can/filter/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/can/filter/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • ertc
  • time_stamp
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/ertc/time_stamp/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/ertc/time_stamp/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/ertc/time_stamp/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • ertc
  • lick_calibration
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/ertc/lick_calibration/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/ertc/lick_calibration/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/ertc/lick_calibration/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • wdt
  • wdt_standby
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/wdt/wdt_standby/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/wdt/wdt_standby/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/wdt/wdt_standby/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • pwc
  • deepsleep_ertc_tamper
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • pwc
  • standby_ertc_alarm
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_wakeup
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • ertc
  • tamper
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: ov5640 Directory Reference

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • ov5640
ov5640 Directory Reference

Files

file | at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c [code]
ov5640 program
file | at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h [code]
file | at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640af.h [code]
header file of ov5640af program
file | at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h [code]
header file of ov5640cfg program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • custom_hid
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: tmr1_synchro Directory Reference

  • at_start_f435
  • examples
  • tmr
  • tmr1_synchro
tmr1_synchro Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • xmc
  • nand_flash
  • ecc
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/xmc/nand_flash/ecc/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c [code]
main program
file | at_start_f437/examples/xmc/nand_flash/ecc/src/xmc_ecc.c [code]
nand ecc configuration


AT32F435/437 Firmwary Library: dma Directory Reference

  • at_start_f437
  • examples
  • dma
dma Directory Reference

Directories

directory | dmamux_data_to_gpio
directory | dmamux_genertor_exint
directory | dmamux_synchronization_exint
directory | flash_to_sram


AT32F435/437 Firmwary Library: dmamux_genertor_exint Directory Reference

  • at_start_f435
  • examples
  • edma
  • dmamux_genertor_exint
dmamux_genertor_exint Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • hall_xor_tmr2
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: cascade_synchro Directory Reference

  • at_start_f435
  • examples
  • tmr
  • cascade_synchro
cascade_synchro Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: mem_map_sel Directory Reference

  • at_start_f435
  • examples
  • scfg
  • mem_map_sel
mem_map_sel Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: irda Directory Reference

  • at_start_f435
  • examples
  • usart
  • irda
irda Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • xmc
  • lcd_touch_16bit
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/xmc/lcd_touch_16bit/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/xmc/lcd_touch_16bit/src/main.c [code]
main program
file | at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c [code]
this file contains all the functions prototypes for the touch firmware driver.
file | at_start_f437/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c [code]
xmc_lcd program file


AT32F435/437 Firmwary Library: nand_flash Directory Reference

  • at_start_f435
  • examples
  • xmc
  • nand_flash
nand_flash Directory Reference

Directories

directory | ecc
directory | nand


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • edma
  • dmamux_genertor_exint
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • can
  • filter
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/can/filter/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/can/filter/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • utilities
  • at32f435_437_freertos_demo
  • src
src Directory Reference

Files

file | utilities/at32f435_437_freertos_demo/src/at32f435_437_clock.c [code]
system clock config program
file | utilities/at32f435_437_freertos_demo/src/at32f435_437_int.c [code]
main interrupt service routines.
file | utilities/at32f435_437_freertos_demo/src/main.c [code]
main program


AT32F435/437 Firmwary Library: dvp Directory Reference

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • dvp
dvp Directory Reference

Files

file | at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c [code]
dvp program
file | at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.h [code]
header file of dvp program


AT32F435/437 Firmwary Library: acc Directory Reference

  • at_start_f437
  • examples
  • acc
acc Directory Reference

Directories

directory calibration


AT32F435/437 Firmwary Library: combine_mode_ordinary_smlt_twoslave_dma5 Directory Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma5
combine_mode_ordinary_smlt_twoslave_dma5 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • spi
  • only_receive_mode_polling
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • external_clock
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • adc
  • use_polling_get_conversion_data
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • can
  • communication_mode
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/can/communication_mode/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/can/communication_mode/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/can/communication_mode/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • xmc
  • sdram_dma
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h [code]
header file for the sdram configuration.


AT32F435/437 Firmwary Library: command_port_using_dma_and_pem Directory Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_and_pem
command_port_using_dma_and_pem Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • i2s
  • halfduplex_dma
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: command_port_using_rdsr_sw Directory Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_rdsr_sw
command_port_using_rdsr_sw Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: cortex_m4 Directory Reference

  • at_start_f437
  • examples
  • cortex_m4
cortex_m4 Directory Reference

Directories

directory | bit_band
directory | cmsis_dsp
directory | fpu
directory | systick_interrupt


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • adc
  • exint_trigger_partitioned
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/adc/exint_trigger_partitioned/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c [code]
main program


AT32F435/437 Firmwary Library: qspi Directory Reference

  • at_start_f437
  • examples
  • qspi
qspi Directory Reference

Directories

directory | command_port_using_dma
directory | command_port_using_dma_and_pem
directory | command_port_using_dma_qpi_mode
directory | command_port_using_interrupt
directory | command_port_using_polling
directory | command_port_using_rdsr_sw
directory | xip_port_write_read


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • virtual_comport
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usb_device/virtual_comport/src/main.c [code]
main program


AT32F435/437 Firmwary Library: edma_double_buffer Directory Reference

  • at_start_f437
  • examples
  • adc
  • edma_double_buffer
edma_double_buffer Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: bootloader Directory Reference

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • bootloader
bootloader Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: two_otg_device_demo Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • two_otg_device_demo
two_otg_device_demo Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: input_capture Directory Reference

  • at_start_f437
  • examples
  • tmr
  • input_capture
input_capture Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • composite_vcp_msc
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h [code]
usb mass storage disk interface header file
file | project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: dmamux_synchronization_exint Directory Reference

  • at_start_f435
  • examples
  • edma
  • dmamux_synchronization_exint
dmamux_synchronization_exint Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • crm
  • clock_failure_detection
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/crm/clock_failure_detection/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/crm/clock_failure_detection/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/crm/clock_failure_detection/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • acc
  • calibration
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/acc/calibration/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/acc/calibration/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f437/examples/acc/calibration/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • sdio
  • sdio_fatfs
  • inc
inc Directory Reference

Files

file | at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h [code]
this file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library.
file | project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h [code]


AT32F435/437 Firmwary Library: ldo_set Directory Reference

  • at_start_f437
  • examples
  • pwc
  • ldo_set
ldo_set Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: sram Directory Reference

  • at_start_f435
  • examples
  • xmc
  • sram
sram Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • i2c
  • communication_poll
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: oc_low Directory Reference

  • at_start_f435
  • examples
  • tmr
  • oc_low
oc_low Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • dac
  • double_mode_dma_sinewave
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/main.c [code]
main program


AT32F435/437 Firmwary Library: source_code Directory Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
source_code Directory Reference

Directories

directory | app_led3_toggle
directory | app_led4_toggle
directory | bootloader


AT32F435/437 Firmwary Library: app_led3_toggle Directory Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • app_led3_toggle
app_led3_toggle Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: crc_transfer_polling Directory Reference

  • at_start_f435
  • examples
  • spi
  • crc_transfer_polling
crc_transfer_polling Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • pwc
  • sleep_usart1
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_input_dma
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/pwm_input_dma/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/pwm_input_dma/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • debug
  • tmr1
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • mouse
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • scfg
  • mem_map_sel
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usart
  • idle_detection
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: deepsleep_ertc_wakeup Directory Reference

  • at_start_f437
  • examples
  • pwc
  • deepsleep_ertc_wakeup
deepsleep_ertc_wakeup Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • crm
  • pll_parameter_calculate
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/crm/pll_parameter_calculate/src/main.c [code]
main program


AT32F435/437 Firmwary Library: keyboard Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • keyboard
keyboard Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • vcp_loopback
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • tmr1_synchro
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • wdt
  • wdt_reset
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: combine_mode_ordinary_shift_twoslave_dma4 Directory Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma4
combine_mode_ordinary_shift_twoslave_dma4 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • timer_base
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/timer_base/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/timer_base/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/timer_base/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr9
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • edma
  • link_list_mode
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/edma/link_list_mode/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/edma/link_list_mode/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/edma/link_list_mode/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • ertc
  • time_stamp
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/ertc/time_stamp/src/main.c [code]
main program


AT32F435/437 Firmwary Library: ti_fullduplex_dma Directory Reference

  • at_start_f435
  • examples
  • spi
  • ti_fullduplex_dma
ti_fullduplex_dma Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • i2c
  • communication_int
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/i2c/communication_int/src/main.c [code]
main program


AT32F435/437 Firmwary Library: fullduplex_polling Directory Reference

  • at_start_f435
  • examples
  • spi
  • fullduplex_polling
fullduplex_polling Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: usb_drivers Directory Reference

  • middlewares
  • usb_drivers
usb_drivers Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • i2c
  • communication_smbus
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: power_voltage_monitor Directory Reference

  • at_start_f437
  • examples
  • pwc
  • power_voltage_monitor
power_voltage_monitor Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • xmc
  • sram
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/xmc/sram/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/xmc/sram/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/xmc/sram/src/main.c [code]
main program
file | at_start_f437/examples/xmc/sram/src/xmc_sram.c [code]
sram program.


AT32F435/437 Firmwary Library: mdk_v5 Directory Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
mdk_v5 Directory Reference

Directories

directory Objects


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • virtual_comport
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: src Directory Reference

  • middlewares
  • usb_drivers
  • src
src Directory Reference

Files

file | usb_core.c [code]
usb driver
file | usbd_core.c [code]
usb device driver
file | usbd_int.c [code]
usb interrupt request
file | usbd_sdr.c [code]
usb standard device request
file | usbh_core.c [code]
usb host driver
file | usbh_ctrl.c [code]
usb host control request
file | usbh_int.c [code]
usb host interrupt request


AT32F435/437 Firmwary Library: command_port_using_polling Directory Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_polling
command_port_using_polling Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • bootloader
  • src
src Directory Reference

Files

file | utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c [code]
emac config program
file | utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_clock.c [code]
system clock config program
file | utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_int.c [code]
main interrupt service routines.
file | utilities/at32f437_emac_iap_demo/source_code/bootloader/src/flash.c [code]
flash program
file | utilities/at32f437_emac_iap_demo/source_code/bootloader/src/fsdata.c [code]
fsdata
file | httpserver.c [code]
httpserver program
file | at32f437_emac_iap_demo/source_code/bootloader/src/iap.c [code]
iap program
file | utilities/at32f437_emac_iap_demo/source_code/bootloader/src/main.c [code]
main program
file | utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c [code]
network connection configuration
file | tftpserver.c [code]
basic tftp server implementation for IAP (only Write Req supported)
file | at32f437_emac_iap_demo/source_code/bootloader/src/tmr.c [code]
tmr program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usart
  • printf
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usart/printf/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usart/printf/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_dma_and_pem
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: audio Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • audio
audio Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • gpio
  • io_toggle
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/gpio/io_toggle/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/gpio/io_toggle/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/gpio/io_toggle/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • emac
  • http_server
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/emac/http_server/inc/at32_emac.h [code]
header file of emac config program.
file | project/at_start_f437/examples/emac/http_server/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/emac/http_server/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f437/examples/emac/http_server/inc/fsdata.h [code]
file | httpd_structs.h [code]
file | project/at_start_f437/examples/emac/http_server/inc/lwipopts.h [code]
file | project/at_start_f437/examples/emac/http_server/inc/netconf.h [code]
This file contains all the functions prototypes for the netconf.c file.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • virtual_msc_iap
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h [code]
fat16 file system header file
file | at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h [code]
usb mass storage disk interface header file
file | project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: bit_band Directory Reference

  • at_start_f435
  • examples
  • cortex_m4
  • bit_band
bit_band Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: communication_int Directory Reference

  • at_start_f435
  • examples
  • i2c
  • communication_int
communication_int Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • ertc
  • bpr_domain
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/ertc/bpr_domain/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/ertc/bpr_domain/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/ertc/bpr_domain/src/main.c [code]
main program


AT32F435/437 Firmwary Library: clock_failure_detection Directory Reference

  • at_start_f435
  • examples
  • crm
  • clock_failure_detection
clock_failure_detection Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • hall_xor_tmr2
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/hall_xor_tmr2/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/hall_xor_tmr2/src/main.c [code]
main program


AT32F435/437 Firmwary Library: pwm_output_tmr10 Directory Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr10
pwm_output_tmr10 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • edma
  • i2s_halfduplex_edma_doublebuffer
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • bootloader
  • src
src Directory Reference

Files

file | utilities/at32f435_437_usart_iap_demo/source_code/bootloader/src/at32f435_437_clock.c [code]
system clock config program
file | utilities/at32f435_437_usart_iap_demo/source_code/bootloader/src/at32f435_437_int.c [code]
main interrupt service routines.
file | utilities/at32f435_437_usart_iap_demo/source_code/bootloader/src/flash.c [code]
flash program
file | at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c [code]
iap program
file | utilities/at32f435_437_usart_iap_demo/source_code/bootloader/src/main.c [code]
main program
file | at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c [code]
tmr program
file | bootloader/src/usart.c [code]
usart program


AT32F435/437 Firmwary Library: qspi Directory Reference

  • at_start_f435
  • examples
  • qspi
qspi Directory Reference

Directories

directory | command_port_using_dma
directory | command_port_using_dma_and_pem
directory | command_port_using_dma_qpi_mode
directory | command_port_using_interrupt
directory | command_port_using_polling
directory | command_port_using_rdsr_sw
directory | xip_port_write_read


AT32F435/437 Firmwary Library: double_mode_dma_squarewave Directory Reference

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_squarewave
double_mode_dma_squarewave Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: two_otg_host_demo Directory Reference

  • at_start_f437
  • examples
  • usb_host
  • two_otg_host_demo
two_otg_host_demo Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: debug Directory Reference

  • at_start_f437
  • examples
  • debug
debug Directory Reference

Directories

directory tmr1


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usart
  • printf
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usart/printf/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usart/printf/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • templates
  • inc
inc Directory Reference

Files

file | project/at_start_f435/templates/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/templates/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/templates/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: input_capture Directory Reference

  • at_start_f435
  • examples
  • tmr
  • input_capture
input_capture Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: hid_iap Directory Reference

  • middlewares
  • usbd_class
  • hid_iap
hid_iap Directory Reference

Files

file | hid_iap_class.c [code]
usb hid iap class type
file | hid_iap_class.h [code]
usb hid iap header file
file | hid_iap_desc.c [code]
usb hid iap device descriptor
file | hid_iap_desc.h [code]
usb hid iap descriptor header file


AT32F435/437 Firmwary Library: sdio_fatfs Directory Reference

  • at_start_f435
  • examples
  • sdio
  • sdio_fatfs
sdio_fatfs Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usart
  • rs485
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usart/rs485/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usart/rs485/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usart/rs485/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • edma
  • dmamux_genertor_exint
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: dmamux_genertor_exint Directory Reference

  • at_start_f437
  • examples
  • edma
  • dmamux_genertor_exint
dmamux_genertor_exint Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: fullduplex_polling Directory Reference

  • at_start_f437
  • examples
  • spi
  • fullduplex_polling
fullduplex_polling Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: use_jtagpin_hardwarecs_dma Directory Reference

  • at_start_f435
  • examples
  • spi
  • use_jtagpin_hardwarecs_dma
use_jtagpin_hardwarecs_dma Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • pwc
  • power_voltage_monitor
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/pwc/power_voltage_monitor/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • tmr2_32bit
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_rdsr_sw
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: two_otg_host_demo Directory Reference

  • at_start_f435
  • examples
  • usb_host
  • two_otg_host_demo
two_otg_host_demo Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • complementary_signals
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/complementary_signals/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/complementary_signals/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/complementary_signals/src/main.c [code]
main program


AT32F435/437 Firmwary Library: middlewares Directory Reference

  • middlewares
middlewares Directory Reference

Directories

directory | i2c_application_library
directory | usb_drivers
directory | usbd_class
directory | usbh_class


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • xmc
  • lcd_8bit
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f437/examples/xmc/lcd_8bit/inc/picture.h [code]
this file contains all the picture used for lcd display.
file | at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h [code]
xmc_lcd header file


AT32F435/437 Firmwary Library: combine_mode_ordinary_smlt_oneslave_edma Directory Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_edma
combine_mode_ordinary_smlt_oneslave_edma Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • xmc
  • nor_flash
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/xmc/nor_flash/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/xmc/nor_flash/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/xmc/nor_flash/src/main.c [code]
main program
file | at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c [code]


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • spi
  • halfduplex_interrupt
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • vcp_loopback
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usb_device/vcp_loopback/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usb_device/vcp_loopback/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usb_device/vcp_loopback/src/main.c [code]
main program


AT32F435/437 Firmwary Library: flash_to_sram Directory Reference

  • at_start_f437
  • examples
  • dma
  • flash_to_sram
flash_to_sram Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma1
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • wdt
  • wdt_reset
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/wdt/wdt_reset/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/wdt/wdt_reset/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/wdt/wdt_reset/src/main.c [code]
main program


AT32F435/437 Firmwary Library: flash_to_sram Directory Reference

  • at_start_f435
  • examples
  • dma
  • flash_to_sram
flash_to_sram Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: audio Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • audio
audio Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • external_clock
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • printer
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usb_device/printer/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usb_device/printer/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usb_device/printer/src/main.c [code]
main program


AT32F435/437 Firmwary Library: ov2640 Directory Reference

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • ov2640
ov2640 Directory Reference

Files

file | at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c [code]
file | at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h [code]
file | at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h [code]
file | at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c [code]
file | at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h [code]


AT32F435/437 Firmwary Library: double_mode_dma_sinewave Directory Reference

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_sinewave
double_mode_dma_sinewave Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: wdt Directory Reference

  • at_start_f435
  • examples
  • wdt
wdt Directory Reference

Directories

directory | wdt_reset
directory | wdt_standby


AT32F435/437 Firmwary Library: app_led3_toggle Directory Reference

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • app_led3_toggle
app_led3_toggle Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: fap_enable Directory Reference

  • at_start_f435
  • examples
  • flash
  • fap_enable
fap_enable Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usart
  • idle_detection
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usart/idle_detection/src/main.c [code]
main program


AT32F435/437 Firmwary Library: encoder_tmr2 Directory Reference

  • at_start_f437
  • examples
  • tmr
  • encoder_tmr2
encoder_tmr2 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma4
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • adc
  • exint_trigger_partitioned
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • xmc
  • lcd_8bit
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/xmc/lcd_8bit/src/main.c [code]
main program
file | at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c [code]
xmc_lcd config program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • adc
  • current_vref_value_check
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/adc/current_vref_value_check/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/adc/current_vref_value_check/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/adc/current_vref_value_check/src/main.c [code]
main program


AT32F435/437 Firmwary Library: scfg Directory Reference

  • at_start_f435
  • examples
  • scfg
scfg Directory Reference

Directories

directory mem_map_sel


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • oc_toggle_tmr3
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/main.c [code]
main program


AT32F435/437 Firmwary Library: dmamux_genertor_exint Directory Reference

  • at_start_f437
  • examples
  • dma
  • dmamux_genertor_exint
dmamux_genertor_exint Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • wdt
  • wdt_reset
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/wdt/wdt_reset/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c [code]
main program
file | at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c [code]
qspi_cmd_esmt32m program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_interrupt
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usart
  • receiver_mute
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usart/receiver_mute/src/main.c [code]
main program


AT32F435/437 Firmwary Library: printer Directory Reference

  • middlewares
  • usbd_class
  • printer
printer Directory Reference

Files

file | printer_class.c [code]
usb printer class type
file | printer_class.h [code]
usb cdc class file
file | printer_desc.c [code]
usb printer device descriptor
file | printer_desc.h [code]
usb printer descriptor header file


AT32F435/437 Firmwary Library: dvp Directory Reference

  • at_start_f435
  • examples
  • dvp
dvp Directory Reference

Directories

directory | ov2640_capture
directory | ov5640_capture


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_interrupt
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c [code]
main program
file | at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c [code]
qspi_cmd_esmt32m program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_synchronization_exint
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • dma
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/dma/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/dma/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma3
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • gpio
  • io_toggle
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma1
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: rs485 Directory Reference

  • at_start_f435
  • examples
  • usart
  • rs485
rs485 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: dma_burst Directory Reference

  • at_start_f437
  • examples
  • tmr
  • dma_burst
dma_burst Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • pwc
  • sleep_tmr2
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • edma
  • link_list_mode
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/edma/link_list_mode/src/main.c [code]
main program


AT32F435/437 Firmwary Library: conversion_abort Directory Reference

  • at_start_f435
  • examples
  • adc
  • conversion_abort
conversion_abort Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • spi
  • fullduplex_polling
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/spi/fullduplex_polling/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/spi/fullduplex_polling/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/spi/fullduplex_polling/src/main.c [code]
main program


AT32F435/437 Firmwary Library: ti_fullduplex_dma Directory Reference

  • at_start_f437
  • examples
  • spi
  • ti_fullduplex_dma
ti_fullduplex_dma Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: hang_mode Directory Reference

  • at_start_f435
  • examples
  • tmr
  • hang_mode
hang_mode Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: tx_rx_swap Directory Reference

  • at_start_f435
  • examples
  • usart
  • tx_rx_swap
tx_rx_swap Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • crm
  • clock_failure_detection
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: msc_only_fat32 Directory Reference

  • at_start_f435
  • examples
  • usb_host
  • msc_only_fat32
msc_only_fat32 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • debug
  • tmr1
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/debug/tmr1/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/debug/tmr1/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • hang_mode
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/hang_mode/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • adc
  • current_vref_value_check
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: eeprom Directory Reference

  • at_start_f437
  • examples
  • i2c
  • eeprom
eeprom Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: sram Directory Reference

  • at_start_f437
  • examples
  • xmc
  • sram
sram Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: led_toggle Directory Reference

  • at_start_f435
  • examples
  • gpio
  • led_toggle
led_toggle Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_interrupt
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • can
  • loopback_mode
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: wakeup_timer Directory Reference

  • at_start_f437
  • examples
  • ertc
  • wakeup_timer
wakeup_timer Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • sram
  • extend_sram
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/sram/extend_sram/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/sram/extend_sram/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/sram/extend_sram/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usart
  • irda
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usart/irda/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usart/irda/src/main.c [code]
main program


AT32F435/437 Firmwary Library: pll_parameter_calculate Directory Reference

  • at_start_f435
  • examples
  • crm
  • pll_parameter_calculate
pll_parameter_calculate Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: audio Directory Reference

  • middlewares
  • usbd_class
  • audio
audio Directory Reference

Files

file | audio_class.c [code]
usb audio class type
file | audio_class.h [code]
usb audio class file
file | audio/audio_conf.h [code]
usb audio config
file | audio_desc.c [code]
usb audio device descriptor
file | audio_desc.h [code]
usb audio descriptor header file


AT32F435/437 Firmwary Library: dac Directory Reference

  • at_start_f435
  • examples
  • dac
dac Directory Reference

Directories

directory | double_mode_dma_sinewave
directory | double_mode_dma_squarewave
directory | one_dac_dma_escalator
directory | one_dac_noisewave
directory | two_dac_trianglewave


AT32F435/437 Firmwary Library: wdt_reset Directory Reference

  • at_start_f435
  • examples
  • wdt
  • wdt_reset
wdt_reset Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • pwc
  • power_voltage_monitor
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/pwc/power_voltage_monitor/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/pwc/power_voltage_monitor/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • irtmr
  • irtmr_output
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/irtmr/irtmr_output/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • keyboard
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usb_device/keyboard/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • external_clock
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/external_clock/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/external_clock/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/external_clock/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • ertc
  • lick_calibration
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/ertc/lick_calibration/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usart
  • transfer_by_dma_interrupt
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • sram
  • extend_sram
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • msc
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usb_device/msc/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usb_device/msc/src/main.c [code]
main program
file | at_start_f435/examples/usb_device/msc/src/msc_diskio.c [code]
usb mass storage disk function


AT32F435/437 Firmwary Library: w25q_flash Directory Reference

  • at_start_f435
  • examples
  • spi
  • w25q_flash
w25q_flash Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: xmc Directory Reference

  • at_start_f435
  • examples
  • xmc
xmc Directory Reference

Directories

directory | lcd_8bit
directory | lcd_touch_16bit
directory | nand_flash
directory | nor_flash
directory | psram
directory | sdram_basic
directory | sdram_dma
directory | sram


AT32F435/437 Firmwary Library: systick_interrupt Directory Reference

  • at_start_f435
  • examples
  • cortex_m4
  • systick_interrupt
systick_interrupt Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • adc
  • ordinary_preempt_oversampling
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c [code]
main program


AT32F435/437 Firmwary Library: custom_hid Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • custom_hid
custom_hid Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_dma
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: hardware Directory Reference

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • hardware
hardware Directory Reference

Directories

directory | dvp
directory | lcd
directory | ov2640


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • parallel_synchro
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/parallel_synchro/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/parallel_synchro/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/parallel_synchro/src/main.c [code]
main program


AT32F435/437 Firmwary Library: ov5640 Directory Reference

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • ov5640
ov5640 Directory Reference

Files

file | at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c [code]
ov5640 program
file | at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h [code]
file | at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640af.h [code]
header file of ov5640af program
file | at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h [code]
header file of ov5640cfg program


AT32F435/437 Firmwary Library: i2c Directory Reference

  • at_start_f437
  • examples
  • i2c
i2c Directory Reference

Directories

directory | communication_dma
directory | communication_int
directory | communication_poll
directory | communication_smbus
directory | eeprom


AT32F435/437 Firmwary Library: composite_vcp_keyboard Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_keyboard
composite_vcp_keyboard Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • xmc
  • psram
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/xmc/psram/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/xmc/psram/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/xmc/psram/src/main.c [code]
main program
file | at_start_f437/examples/xmc/psram/src/xmc_psram.c [code]
xmc_psram program


AT32F435/437 Firmwary Library: one_dac_dma_escalator Directory Reference

  • at_start_f437
  • examples
  • dac
  • one_dac_dma_escalator
one_dac_dma_escalator Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: composite_cdc_msc Directory Reference

  • middlewares
  • usbd_class
  • composite_cdc_msc
composite_cdc_msc Directory Reference

Files

file | cdc_msc_class.c [code]
usb cdc class type
file | cdc_msc_class.h [code]
usb cdc class file
file | cdc_msc_desc.c [code]
usb cdc device descriptor
file | cdc_msc_desc.h [code]
usb cdc descriptor header file
file | composite_cdc_msc/msc_bot_scsi.c [code]
usb mass storage bulk-only transport and scsi command


AT32F435/437 Firmwary Library: virtual_msc_iap Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • virtual_msc_iap
virtual_msc_iap Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: combine_mode_ordinary_shift_twoslave_dma3 Directory Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma3
combine_mode_ordinary_shift_twoslave_dma3 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_genertor_exint
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c [code]
main program


AT32F435/437 Firmwary Library: two_dimension_mode Directory Reference

  • at_start_f437
  • examples
  • edma
  • two_dimension_mode
two_dimension_mode Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: time_stamp Directory Reference

  • at_start_f435
  • examples
  • ertc
  • time_stamp
time_stamp Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • can
  • loopback_mode
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: mdk_v5 Directory Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
mdk_v5 Directory Reference

Directories

directory Objects


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • pwc
  • power_voltage_monitor
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • templates
  • src
src Directory Reference

Files

file | project/at_start_f435/templates/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/templates/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/templates/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: crc Directory Reference

  • at_start_f435
  • examples
  • crc
crc Directory Reference

Directories

directory calculation


AT32F435/437 Firmwary Library: lick_calibration Directory Reference

  • at_start_f437
  • examples
  • ertc
  • lick_calibration
lick_calibration Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: flash Directory Reference

  • at_start_f435
  • examples
  • flash
flash Directory Reference

Directories

directory | fap_enable
directory | flash_write_read


AT32F435/437 Firmwary Library: oc_toggle_tmr3 Directory Reference

  • at_start_f437
  • examples
  • tmr
  • oc_toggle_tmr3
oc_toggle_tmr3 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • adc
  • software_trigger_repeat
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_synchronization_exint
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_preempt_interltrig_twoslave
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • printer
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • edma
  • i2s_halfduplex_edma_doublebuffer
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • edma
  • two_dimension_mode
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: spi Directory Reference

  • at_start_f435
  • examples
  • spi
spi Directory Reference

Directories

directory | crc_transfer_polling
directory | fullduplex_polling
directory | halfduplex_interrupt
directory | halfduplex_transceiver_switch
directory | only_receive_mode_polling
directory | ti_fullduplex_dma
directory | use_jtagpin_hardwarecs_dma
directory | w25q_flash


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • exint
  • exint_software_trigger
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/exint/exint_software_trigger/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma4
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: app_led4_toggle Directory Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led4_toggle
app_led4_toggle Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_keyboard
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • acc
  • calibration
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/acc/calibration/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/acc/calibration/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f435/examples/acc/calibration/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: nor_flash Directory Reference

  • at_start_f435
  • examples
  • xmc
  • nor_flash
nor_flash Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_sinewave
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • pwc
  • standby_wakeup_pin
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • encoder_tmr2
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/encoder_tmr2/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/encoder_tmr2/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/encoder_tmr2/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma1
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • dma
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/dma/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/dma/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/dma/src/main.c [code]
main program


AT32F435/437 Firmwary Library: two_dac_trianglewave Directory Reference

  • at_start_f435
  • examples
  • dac
  • two_dac_trianglewave
two_dac_trianglewave Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • can
  • loopback_mode
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/can/loopback_mode/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/can/loopback_mode/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/can/loopback_mode/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • pwc
  • standby_ertc_alarm
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/pwc/standby_ertc_alarm/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/pwc/standby_ertc_alarm/src/main.c [code]
main program


AT32F435/437 Firmwary Library: extend_sram Directory Reference

  • at_start_f435
  • examples
  • sram
  • extend_sram
extend_sram Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: dmamux_genertor_exint Directory Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_genertor_exint
dmamux_genertor_exint Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • spi
  • fullduplex_polling
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: tmr Directory Reference

  • at_start_f435
  • examples
  • tmr
tmr Directory Reference

Directories

directory | 6_steps
directory | 7_pwm_output
directory | cascade_synchro
directory | complementary_signals
directory | dma
directory | dma_burst
directory | encoder_tmr2
directory | external_clock
directory | hall_xor_tmr2
directory | hang_mode
directory | input_capture
directory | oc_high
directory | oc_low
directory | oc_toggle_tmr3
directory | oc_toggle_tmr9
directory | one_cycle
directory | parallel_synchro
directory | pwm_input
directory | pwm_input_dma
directory | pwm_output_simulate
directory | pwm_output_tmr10
directory | pwm_output_tmr3
directory | timer_base
directory | tmr1_synchro
directory | tmr2_32bit


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • oc_low
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: at32f435_437_freertos_demo Directory Reference

  • utilities
  • at32f435_437_freertos_demo
at32f435_437_freertos_demo Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • adc
  • use_polling_get_conversion_data
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • pwc
  • standby_wakeup_pin
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/pwc/standby_wakeup_pin/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • crm
  • sysclk_switch
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: i2s_halfduplex_edma_doublebuffer Directory Reference

  • at_start_f437
  • examples
  • edma
  • i2s_halfduplex_edma_doublebuffer
i2s_halfduplex_edma_doublebuffer Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • ertc
  • time_stamp
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c [code]
main program


AT32F435/437 Firmwary Library: usb_host Directory Reference

  • at_start_f435
  • examples
  • usb_host
usb_host Directory Reference

Directories

directory | hid_demo
directory | msc_only_fat32
directory | two_otg_host_demo


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_alarm
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c [code]
main program


AT32F435/437 Firmwary Library: i2c_application_library Directory Reference

  • middlewares
  • i2c_application_library
i2c_application_library Directory Reference

Files

file | i2c_application.c [code]
the driver library of the i2c peripheral
file | i2c_application.h [code]
i2c application libray header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • oc_toggle_tmr3
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: dvp Directory Reference

  • at_start_f437
  • examples
  • dvp
dvp Directory Reference

Directories

directory | ov2640_capture
directory | ov5640_capture


AT32F435/437 Firmwary Library: xmc Directory Reference

  • at_start_f437
  • examples
  • xmc
xmc Directory Reference

Directories

directory | lcd_8bit
directory | lcd_touch_16bit
directory | nand_flash
directory | nor_flash
directory | psram
directory | sdram_basic
directory | sdram_dma
directory | sram


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr9
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: sdram_basic Directory Reference

  • at_start_f435
  • examples
  • xmc
  • sdram_basic
sdram_basic Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: irtmr_output Directory Reference

  • at_start_f435
  • examples
  • irtmr
  • irtmr_output
irtmr_output Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usb_host
  • msc_only_fat32
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usb_host/msc_only_fat32/src/main.c [code]
main program
file | at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c [code]
usb mass storage disk io
file | at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c [code]
usb user function


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • exint
  • exint_config
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/exint/exint_config/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/exint/exint_config/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/exint/exint_config/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • 7_pwm_output
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usart
  • synchronous
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • iar_out
  • src
src Directory Reference

Files

file qspi_algorithm.c [code]


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • cascade_synchro
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: keyboard Directory Reference

  • middlewares
  • usbd_class
  • keyboard
keyboard Directory Reference

Files

file | keyboard_class.c [code]
usb hid keyboard class type
file | keyboard_class.h [code]
usb hid keyboard header file
file | keyboard_desc.c [code]
usb hid keyboard device descriptor
file | keyboard_desc.h [code]
usb keyboard descriptor header file


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • adc
  • internal_temperature_sensor
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c [code]
main program


AT32F435/437 Firmwary Library: ldo_set Directory Reference

  • at_start_f435
  • examples
  • pwc
  • ldo_set
ldo_set Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • qspi
  • xip_port_write_read
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • ertc
  • calendar
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • i2c
  • communication_poll
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/i2c/communication_poll/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/i2c/communication_poll/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/i2c/communication_poll/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • sram
  • extend_sram
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • irtmr
  • irtmr_output
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/irtmr/irtmr_output/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/irtmr/irtmr_output/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/irtmr/irtmr_output/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • i2c
  • communication_smbus
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/i2c/communication_smbus/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/i2c/communication_smbus/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/i2c/communication_smbus/src/main.c [code]
main program


AT32F435/437 Firmwary Library: extend_sram Directory Reference

  • at_start_f437
  • examples
  • sram
  • extend_sram
extend_sram Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • ertc
  • calendar
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/ertc/calendar/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/ertc/calendar/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/ertc/calendar/src/main.c [code]
main program


AT32F435/437 Firmwary Library: pwm_output_tmr10 Directory Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_output_tmr10
pwm_output_tmr10 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: bootloader Directory Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • bootloader
bootloader Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: fullduplex_dma Directory Reference

  • at_start_f437
  • examples
  • i2s
  • fullduplex_dma
fullduplex_dma Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • hall_xor_tmr2
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usb_host
  • hid_demo
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usb_host/hid_demo/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usb_host/hid_demo/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usb_host/hid_demo/src/main.c [code]
main program
file | at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c [code]
usb user function


AT32F435/437 Firmwary Library: transfer_by_dma_polling Directory Reference

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_polling
transfer_by_dma_polling Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • ertc
  • calendar
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: nand Directory Reference

  • at_start_f435
  • examples
  • xmc
  • nand_flash
  • nand
nand Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • pwc
  • power_voltage_monitor
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • emac
  • iperf
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/emac/iperf/inc/at32_emac.h [code]
header file of emac config program.
file | project/at_start_f437/examples/emac/iperf/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/emac/iperf/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | iperf.h [code]
iperf tool header
file | project/at_start_f437/examples/emac/iperf/inc/lwipopts.h [code]
file | project/at_start_f437/examples/emac/iperf/inc/netconf.h [code]
This file contains all the functions prototypes for the netconf.c file.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usart
  • rs485
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usart/rs485/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usart/rs485/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: at32f435_437_qspi_algorithm_demo Directory Reference

  • utilities
  • at32f435_437_qspi_algorithm_demo
at32f435_437_qspi_algorithm_demo Directory Reference

Directories

directory | iar_out
directory | keil_flm


AT32F435/437 Firmwary Library: deepsleep_ertc_tamper Directory Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_tamper
deepsleep_ertc_tamper Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • xmc
  • lcd_8bit
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/xmc/lcd_8bit/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/xmc/lcd_8bit/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/xmc/lcd_8bit/src/main.c [code]
main program
file | at_start_f437/examples/xmc/lcd_8bit/src/xmc_lcd.c [code]
xmc_lcd config program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • ertc
  • lick_calibration
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usart
  • interrupt
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usart/interrupt/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usart/interrupt/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • 7_pwm_output
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/7_pwm_output/src/main.c [code]
main program


AT32F435/437 Firmwary Library: 6_steps Directory Reference

  • at_start_f437
  • examples
  • tmr
  • 6_steps
6_steps Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: fpu Directory Reference

  • at_start_f437
  • examples
  • cortex_m4
  • fpu
fpu Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • dac
  • two_dac_trianglewave
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/dac/two_dac_trianglewave/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/dac/two_dac_trianglewave/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • emac
  • telnet
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/emac/telnet/inc/at32_emac.h [code]
header file of emac config program.
file | project/at_start_f437/examples/emac/telnet/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/emac/telnet/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f437/examples/emac/telnet/inc/lwipopts.h [code]
file | project/at_start_f437/examples/emac/telnet/inc/netconf.h [code]
This file contains all the functions prototypes for the netconf.c file.
file | telnet.h [code]


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: at32f435_437_usart_iap_demo Directory Reference

  • utilities
  • at32f435_437_usart_iap_demo
at32f435_437_usart_iap_demo Directory Reference

Directories

directory source_code


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr3
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usart
  • printf
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usart/printf/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usart/printf/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usart/printf/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • emac
  • tcp_client
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h [code]
header file of emac config program.
file | project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h [code]
file | project/at_start_f437/examples/emac/tcp_client/inc/netconf.h [code]
This file contains all the functions prototypes for the netconf.c file.
file | tcp_client.h [code]
tcp client header


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • edma
  • two_dimension_mode
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/edma/two_dimension_mode/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/edma/two_dimension_mode/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/edma/two_dimension_mode/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • crm
  • sysclk_switch
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: irtmr_output Directory Reference

  • at_start_f437
  • examples
  • irtmr
  • irtmr_output
irtmr_output Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: project_l0 Directory Reference

  • utilities
  • at32f435_437_slib_demo
  • project_l0
project_l0 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_edma
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • hall_xor_tmr2
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c [code]
main program


AT32F435/437 Firmwary Library: timer_base Directory Reference

  • at_start_f435
  • examples
  • tmr
  • timer_base
timer_base Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • middlewares
  • usb_drivers
  • inc
inc Directory Reference

Files

file | usb_core.h [code]
usb core header file
file | usb_std.h [code]
usb standard header file
file | usbd_core.h [code]
usb device core header file
file | usbd_int.h [code]
usb interrupt header file
file | usbd_sdr.h [code]
file | usbh_core.h [code]
usb host core header file
file | usbh_ctrl.h [code]
usb header file
file | usbh_int.h [code]
usb header file


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • input_capture
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/input_capture/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • edma
  • flash_to_sram
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • sdio
  • sd_mmc_card
  • src
src Directory Reference

Files

file | at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c [code]
this file provides a set of functions needed to manage the sdio/mmc card memory.
file | project/at_start_f437/examples/sdio/sd_mmc_card/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/sdio/sd_mmc_card/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usb_host
  • two_otg_host_demo
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usb_host/two_otg_host_demo/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usb_host/two_otg_host_demo/src/main.c [code]
main program
file | at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c [code]
usb mass storage disk io
file | at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c [code]
usb user function


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr3
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • 7_pwm_output
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/7_pwm_output/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/7_pwm_output/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/7_pwm_output/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • xmc
  • nand_flash
  • nand
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/xmc/nand_flash/nand/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/xmc/nand_flash/nand/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c [code]
main program
file | at_start_f437/examples/xmc/nand_flash/nand/src/xmc_nand.c [code]
nand configuration


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • ertc
  • calendar
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/ertc/calendar/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/ertc/calendar/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • hang_mode
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/hang_mode/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/hang_mode/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/hang_mode/src/main.c [code]
main program


AT32F435/437 Firmwary Library: lick_calibration Directory Reference

  • at_start_f435
  • examples
  • ertc
  • lick_calibration
lick_calibration Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: edma Directory Reference

  • at_start_f435
  • examples
  • edma
edma Directory Reference

Directories

directory | burst_mode
directory | dmamux_genertor_exint
directory | dmamux_synchronization_exint
directory | flash_to_sram
directory | i2s_halfduplex_edma_doublebuffer
directory | link_list_mode
directory | two_dimension_mode


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • xmc
  • nor_flash
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h [code]


AT32F435/437 Firmwary Library: filter Directory Reference

  • at_start_f437
  • examples
  • can
  • filter
filter Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • dac
  • double_mode_dma_squarewave
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • adc
  • edma_double_buffer
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/adc/edma_double_buffer/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • dac
  • one_dac_dma_escalator
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/dac/one_dac_dma_escalator/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/dac/one_dac_dma_escalator/src/main.c [code]
main program


AT32F435/437 Firmwary Library: irda Directory Reference

  • at_start_f437
  • examples
  • usart
  • irda
irda Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • emac
  • iperf
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/emac/iperf/src/at32_emac.c [code]
emac config program
file | project/at_start_f437/examples/emac/iperf/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c [code]
main interrupt service routines.
file | iperf.c [code]
iperf tool
file | project/at_start_f437/examples/emac/iperf/src/main.c [code]
main program
file | project/at_start_f437/examples/emac/iperf/src/netconf.c [code]
network connection configuration


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • dac
  • two_dac_trianglewave
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: usart Directory Reference

  • at_start_f437
  • examples
  • usart
usart Directory Reference

Directories

directory | half_duplex
directory | hw_flow_control
directory | idle_detection
directory | interrupt
directory | irda
directory | polling
directory | printf
directory | receiver_mute
directory | rs485
directory | smartcard
directory | synchronous
directory | transfer_by_dma_interrupt
directory | transfer_by_dma_polling
directory | tx_rx_swap


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • cortex_m4
  • bit_band
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: at32f435_437_gen_random_number_demo Directory Reference

  • utilities
  • at32f435_437_gen_random_number_demo
at32f435_437_gen_random_number_demo Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: flash_write_read Directory Reference

  • at_start_f435
  • examples
  • flash
  • flash_write_read
flash_write_read Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • spi
  • only_receive_mode_polling
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • edma
  • burst_mode
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/edma/burst_mode/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • bootloader
  • src
src Directory Reference

Files

file | utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_clock.c [code]
system clock config program
file | utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c [code]
main interrupt service routines.
file | bootloader/src/hid_iap_user.c [code]
usb hid iap user file
file | utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c [code]
main program


AT32F435/437 Firmwary Library: ecc Directory Reference

  • at_start_f437
  • examples
  • xmc
  • nand_flash
  • ecc
ecc Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_input
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_edma
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • pwc
  • sleep_usart1
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/pwc/sleep_usart1/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • can
  • filter
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/can/filter/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/can/filter/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/can/filter/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • i2c
  • communication_smbus
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: burst_mode Directory Reference

  • at_start_f435
  • examples
  • edma
  • burst_mode
burst_mode Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usart
  • idle_detection
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usb_host
  • hid_demo
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usb_host/hid_demo/src/main.c [code]
main program
file | at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c [code]
usb user function


AT32F435/437 Firmwary Library: i2s Directory Reference

  • at_start_f435
  • examples
  • i2s
i2s Directory Reference

Directories

directory | fullduplex_dma
directory | halfduplex_dma
directory | halfduplex_interrupt
directory | spii2s_switch_halfduplex_polling


AT32F435/437 Firmwary Library: double_mode_dma_sinewave Directory Reference

  • at_start_f437
  • examples
  • dac
  • double_mode_dma_sinewave
double_mode_dma_sinewave Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • dma
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/dma/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/dma/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: bootloader Directory Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • bootloader
bootloader Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • i2c
  • communication_smbus
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/i2c/communication_smbus/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • exint
  • exint_software_trigger
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: software_trigger_repeat Directory Reference

  • at_start_f437
  • examples
  • adc
  • software_trigger_repeat
software_trigger_repeat Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: timer_base Directory Reference

  • at_start_f437
  • examples
  • tmr
  • timer_base
timer_base Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • input_capture
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/input_capture/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/input_capture/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/input_capture/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • adc
  • edma_double_buffer
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: time_stamp Directory Reference

  • at_start_f437
  • examples
  • ertc
  • time_stamp
time_stamp Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: app_led4_toggle Directory Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • app_led4_toggle
app_led4_toggle Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: exint_software_trigger Directory Reference

  • at_start_f435
  • examples
  • exint
  • exint_software_trigger
exint_software_trigger Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • dac
  • one_dac_noisewave
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • app_led3_toggle
  • inc
inc Directory Reference

Files

file | utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h [code]
header file of emac config program.
file | utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_clock.h [code]
header file of clock program
file | utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/flash.h [code]
flash header file
file | at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/iap.h [code]
iap header file
file | utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h [code]
file | utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/netconf.h [code]
This file contains all the functions prototypes for the netconf.c file.
file | at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/tmr.h [code]
tmr header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • edma
  • burst_mode
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: one_cycle Directory Reference

  • at_start_f437
  • examples
  • tmr
  • one_cycle
one_cycle Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • sdio
  • sdio_fatfs
  • src
src Directory Reference

Files

file | at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c [code]
this file provides a set of functions needed to manage the sdio/mmc card memory.
file | project/at_start_f437/examples/sdio/sdio_fatfs/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/sdio/sdio_fatfs/src/at32f435_437_int.c [code]
main interrupt service routines.
file | at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c [code]
file | project/at_start_f437/examples/sdio/sdio_fatfs/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • qspi
  • xip_port_write_read
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c [code]
main program
file | at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c [code]


AT32F435/437 Firmwary Library: dns_client Directory Reference

  • at_start_f437
  • examples
  • emac
  • dns_client
dns_client Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • spi
  • crc_transfer_polling
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/spi/crc_transfer_polling/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/spi/crc_transfer_polling/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c [code]
main program


AT32F435/437 Firmwary Library: composite_vcp_msc Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • composite_vcp_msc
composite_vcp_msc Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: xip_port_write_read Directory Reference

  • at_start_f435
  • examples
  • qspi
  • xip_port_write_read
xip_port_write_read Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • oc_high
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/oc_high/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/oc_high/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/oc_high/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • adc
  • use_polling_get_conversion_data
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c [code]
main program


AT32F435/437 Firmwary Library: examples Directory Reference

  • at_start_f435
  • examples
examples Directory Reference

Directories

directory | acc
directory | adc
directory | can
directory | cortex_m4
directory | crc
directory | crm
directory | dac
directory | debug
directory | dma
directory | dvp
directory | edma
directory | ertc
directory | exint
directory | flash
directory | gpio
directory | i2c
directory | i2s
directory | irtmr
directory | pwc
directory | qspi
directory | scfg
directory | sdio
directory | spi
directory | sram
directory | tmr
directory | usart
directory | usb_device
directory | usb_host
directory | wdt
directory | wwdt
directory | xmc


AT32F435/437 Firmwary Library: msc Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • msc
msc Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • tmr1_synchro
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: use_polling_get_conversion_data Directory Reference

  • at_start_f437
  • examples
  • adc
  • use_polling_get_conversion_data
use_polling_get_conversion_data Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: i2c Directory Reference

  • at_start_f435
  • examples
  • i2c
i2c Directory Reference

Directories

directory | communication_dma
directory | communication_int
directory | communication_poll
directory | communication_smbus
directory | eeprom


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • crc
  • calculation
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/crc/calculation/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/crc/calculation/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usart
  • printf
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usart/printf/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usart/printf/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: usbd_class Directory Reference

  • middlewares
  • usbd_class
usbd_class Directory Reference

Directories

directory | audio
directory | audio_hid
directory | cdc
directory | composite_cdc_keyboard
directory | composite_cdc_msc
directory | custom_hid
directory | hid_iap
directory | keyboard
directory | mouse
directory | msc
directory | printer


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usart
  • half_duplex
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usart/half_duplex/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usart/half_duplex/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usart/half_duplex/src/main.c [code]
main program


AT32F435/437 Firmwary Library: external_clock Directory Reference

  • at_start_f435
  • examples
  • tmr
  • external_clock
external_clock Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usart
  • half_duplex
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • emac
  • tcp_client
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/emac/tcp_client/src/at32_emac.c [code]
emac config program
file | project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/emac/tcp_client/src/main.c [code]
main program
file | project/at_start_f437/examples/emac/tcp_client/src/netconf.c [code]
network connection configuration
file | tcp_client.c [code]
implement tcp client


AT32F435/437 Firmwary Library: calibration Directory Reference

  • at_start_f435
  • examples
  • acc
  • calibration
calibration Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • two_otg_device_demo
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • ertc
  • tamper
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/ertc/tamper/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/ertc/tamper/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/ertc/tamper/src/main.c [code]
main program


AT32F435/437 Firmwary Library: oc_low Directory Reference

  • at_start_f437
  • examples
  • tmr
  • oc_low
oc_low Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: combine_mode_ordinary_smlt_oneslave_dma2 Directory Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_dma2
combine_mode_ordinary_smlt_oneslave_dma2 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • msc
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f437/examples/usb_device/msc/inc/msc_diskio.h [code]
usb mass storage disk interface header file
file | project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • xmc
  • nand_flash
  • ecc
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h [code]
header file for the nand ecc configuration.


AT32F435/437 Firmwary Library: systick_interrupt Directory Reference

  • at_start_f437
  • examples
  • cortex_m4
  • systick_interrupt
systick_interrupt Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: gpio Directory Reference

  • at_start_f437
  • examples
  • gpio
gpio Directory Reference

Directories

directory | io_toggle
directory | led_toggle
directory | swjtag_mux


AT32F435/437 Firmwary Library: calendar Directory Reference

  • at_start_f435
  • examples
  • ertc
  • calendar
calendar Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usb_host
  • msc_only_fat32
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h [code]
file | project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h [code]
usb config header file
file | at_start_f435/examples/usb_host/msc_only_fat32/inc/usbh_user.h [code]
usb host user header file


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • debug
  • tmr1
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/debug/tmr1/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/debug/tmr1/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/debug/tmr1/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • pwc
  • sleep_usart1
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/pwc/sleep_usart1/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/pwc/sleep_usart1/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/pwc/sleep_usart1/src/main.c [code]
main program


AT32F435/437 Firmwary Library: wakeup_timer Directory Reference

  • at_start_f435
  • examples
  • ertc
  • wakeup_timer
wakeup_timer Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • keyboard
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usb_device/keyboard/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usb_device/keyboard/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usb_device/keyboard/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • emac
  • dns_client
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/emac/dns_client/src/at32_emac.c [code]
emac config program
file | project/at_start_f437/examples/emac/dns_client/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/emac/dns_client/src/main.c [code]
main program
file | project/at_start_f437/examples/emac/dns_client/src/netconf.c [code]
network connection configuration


AT32F435/437 Firmwary Library: halfduplex_interrupt Directory Reference

  • at_start_f437
  • examples
  • spi
  • halfduplex_interrupt
halfduplex_interrupt Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • irtmr
  • irtmr_output
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: sleep_tmr2 Directory Reference

  • at_start_f435
  • examples
  • pwc
  • sleep_tmr2
sleep_tmr2 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: ov2640_capture Directory Reference

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
ov2640_capture Directory Reference

Directories

directory | hardware
directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • dma_burst
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/dma_burst/src/main.c [code]
main program


AT32F435/437 Firmwary Library: psram Directory Reference

  • at_start_f435
  • examples
  • xmc
  • psram
psram Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: irtmr Directory Reference

  • at_start_f435
  • examples
  • irtmr
irtmr Directory Reference

Directories

directory irtmr_output


AT32F435/437 Firmwary Library: exint Directory Reference

  • at_start_f437
  • examples
  • exint
exint Directory Reference

Directories

directory | exint_config
directory | exint_software_trigger


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usart
  • hw_flow_control
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usart/hw_flow_control/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usart/hw_flow_control/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usart/hw_flow_control/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_output_simulate
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/pwm_output_simulate/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/pwm_output_simulate/src/main.c [code]
main program


AT32F435/437 Firmwary Library: exint_trigger_partitioned Directory Reference

  • at_start_f435
  • examples
  • adc
  • exint_trigger_partitioned
exint_trigger_partitioned Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: pwm_output_tmr3 Directory Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr3
pwm_output_tmr3 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • cortex_m4
  • fpu
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/cortex_m4/fpu/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/cortex_m4/fpu/src/at32f435_437_int.c [code]
main interrupt service routines.
file | at_start_f437/examples/cortex_m4/fpu/src/julia_fpu.c [code]
julia_fpu source file
file | project/at_start_f437/examples/cortex_m4/fpu/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • sram
  • extend_sram
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/sram/extend_sram/src/main.c [code]
main program


AT32F435/437 Firmwary Library: bpr_domain Directory Reference

  • at_start_f435
  • examples
  • ertc
  • bpr_domain
bpr_domain Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: polling Directory Reference

  • at_start_f435
  • examples
  • usart
  • polling
polling Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • tmr2_32bit
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c [code]
main program


AT32F435/437 Firmwary Library: ov5640_capture Directory Reference

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
ov5640_capture Directory Reference

Directories

directory | hardware
directory | inc
directory | src


AT32F435/437 Firmwary Library: only_receive_mode_polling Directory Reference

  • at_start_f435
  • examples
  • spi
  • only_receive_mode_polling
only_receive_mode_polling Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
inc Directory Reference

Files

file | utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_clock.h [code]
header file of clock program
file | utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | app_led4_toggle/inc/hid_iap_user.h [code]
usb config header file
file | utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_polling
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • adc
  • internal_temperature_sensor
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/adc/internal_temperature_sensor/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/adc/internal_temperature_sensor/src/main.c [code]
main program


AT32F435/437 Firmwary Library: msc Directory Reference

  • middlewares
  • usbd_class
  • msc
msc Directory Reference

Files

file | msc/msc_bot_scsi.c [code]
usb mass storage bulk-only transport and scsi command
file | msc_bot_scsi.h [code]
usb mass storage bulk-only transport and scsi command header file
file | msc_class.c [code]
usb msc class type
file | msc_class.h [code]
usb msc class file
file | msc_desc.c [code]
usb msc device descriptor
file | msc_desc.h [code]
usb msc descriptor header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • keyboard
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • adc
  • internal_temperature_sensor
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: swjtag_mux Directory Reference

  • at_start_f435
  • examples
  • gpio
  • swjtag_mux
swjtag_mux Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • crm
  • sysclk_switch
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/crm/sysclk_switch/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/crm/sysclk_switch/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/crm/sysclk_switch/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • exint
  • exint_config
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_squarewave
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • dac
  • one_dac_dma_escalator
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • exint
  • exint_config
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/exint/exint_config/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/exint/exint_config/src/main.c [code]
main program


AT32F435/437 Firmwary Library: printer Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • printer
printer Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • wwdt
  • wwdt_reset
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/wwdt/wwdt_reset/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/wwdt/wwdt_reset/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/wwdt/wwdt_reset/src/main.c [code]
main program


AT32F435/437 Firmwary Library: standby_ertc_alarm Directory Reference

  • at_start_f435
  • examples
  • pwc
  • standby_ertc_alarm
standby_ertc_alarm Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: 7_pwm_output Directory Reference

  • at_start_f437
  • examples
  • tmr
  • 7_pwm_output
7_pwm_output Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: dvp Directory Reference

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • dvp
dvp Directory Reference

Files

file | at_start_f437/examples/dvp/ov5640_capture/hardware/dvp/dvp.c [code]
dvp program
file | at_start_f437/examples/dvp/ov5640_capture/hardware/dvp/dvp.h [code]
header file of dvp program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • edma
  • dmamux_genertor_exint
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • crm
  • pll_parameter_calculate
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/crm/pll_parameter_calculate/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/crm/pll_parameter_calculate/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • spi
  • w25q_flash
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/spi/w25q_flash/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/spi/w25q_flash/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/spi/w25q_flash/src/main.c [code]
main program
file | at_start_f437/examples/spi/w25q_flash/src/spi_flash.c [code]
spi_flash source code


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • xmc
  • nand_flash
  • ecc
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c [code]
main program
file | at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c [code]
nand ecc configuration


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • xmc
  • sram
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/xmc/sram/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/xmc/sram/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f437/examples/xmc/sram/inc/xmc_sram.h [code]
header file for the nand configuration.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: one_dac_dma_escalator Directory Reference

  • at_start_f435
  • examples
  • dac
  • one_dac_dma_escalator
one_dac_dma_escalator Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • one_cycle
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/one_cycle/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/one_cycle/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/one_cycle/src/main.c [code]
main program


AT32F435/437 Firmwary Library: tmr2_32bit Directory Reference

  • at_start_f435
  • examples
  • tmr
  • tmr2_32bit
tmr2_32bit Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: sd_mmc_card Directory Reference

  • at_start_f435
  • examples
  • sdio
  • sd_mmc_card
sd_mmc_card Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • one_cycle
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • pwc
  • deepsleep_ertc_alarm
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: one_dac_noisewave Directory Reference

  • at_start_f435
  • examples
  • dac
  • one_dac_noisewave
one_dac_noisewave Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • pwc
  • standby_ertc_alarm
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: ov2640 Directory Reference

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • ov2640
ov2640 Directory Reference

Files

file | at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c [code]
file | at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h [code]
file | at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h [code]
file | at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c [code]
file | at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h [code]


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • flash
  • flash_write_read
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/flash/flash_write_read/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/flash/flash_write_read/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/flash/flash_write_read/src/flash.c [code]
flash program
file | project/at_start_f437/examples/flash/flash_write_read/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • sdio
  • sd_mmc_card
  • src
src Directory Reference

Files

file | at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c [code]
this file provides a set of functions needed to manage the sdio/mmc card memory.
file | project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • cascade_synchro
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: calculation Directory Reference

  • at_start_f437
  • examples
  • crc
  • calculation
calculation Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: can Directory Reference

  • at_start_f437
  • examples
  • can
can Directory Reference

Directories

directory | communication_mode
directory | filter
directory | loopback_mode


AT32F435/437 Firmwary Library: src Directory Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • app_led3_toggle
  • src
src Directory Reference

Files

file | utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_clock.c [code]
system clock config program
file | utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c [code]
main interrupt service routines.
file | app_led3_toggle/src/hid_iap_user.c [code]
usb hid iap user file
file | utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c [code]
main program


AT32F435/437 Firmwary Library: deepsleep_ertc_alarm Directory Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_alarm
deepsleep_ertc_alarm Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr10
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c [code]
main program


AT32F435/437 Firmwary Library: template Directory Reference

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • iar_out
  • framework2
  • template
template Directory Reference

Files

file flash_loader_ram.c [code]


AT32F435/437 Firmwary Library: libraries Directory Reference

  • libraries
libraries Directory Reference

Directories

directory | cmsis
directory | drivers


AT32F435/437 Firmwary Library: gpio Directory Reference

  • at_start_f435
  • examples
  • gpio
gpio Directory Reference

Directories

directory | io_toggle
directory | led_toggle
directory | swjtag_mux


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usb_host
  • two_otg_host_demo
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c [code]
main program
file | at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c [code]
usb mass storage disk io
file | at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c [code]
usb user function


AT32F435/437 Firmwary Library: hall_xor_tmr2 Directory Reference

  • at_start_f437
  • examples
  • tmr
  • hall_xor_tmr2
hall_xor_tmr2 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • parallel_synchro
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • msc
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usb_device/msc/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usb_device/msc/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usb_device/msc/src/main.c [code]
main program
file | at_start_f437/examples/usb_device/msc/src/msc_diskio.c [code]
usb mass storage disk function


AT32F435/437 Firmwary Library: ecc Directory Reference

  • at_start_f435
  • examples
  • xmc
  • nand_flash
  • ecc
ecc Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usart
  • interrupt
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • ertc
  • time_stamp
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • flash
  • fap_enable
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/flash/fap_enable/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/flash/fap_enable/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/flash/fap_enable/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • can
  • communication_mode
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/can/communication_mode/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/can/communication_mode/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usart
  • interrupt
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • spi
  • w25q_flash
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/spi/w25q_flash/src/main.c [code]
main program
file | at_start_f435/examples/spi/w25q_flash/src/spi_flash.c [code]
spi_flash source code


AT32F435/437 Firmwary Library: halfduplex_transceiver_switch Directory Reference

  • at_start_f435
  • examples
  • spi
  • halfduplex_transceiver_switch
halfduplex_transceiver_switch Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • oc_low
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usart
  • polling
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usart/polling/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usart/polling/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • adc
  • voltage_monitoring
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • adc
  • ordinary_preempt_oversampling
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • spi
  • w25q_flash
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h [code]
header file of spi_flash


AT32F435/437 Firmwary Library: mouse Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • mouse
mouse Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: custom_hid Directory Reference

  • middlewares
  • usbd_class
  • custom_hid
custom_hid Directory Reference

Files

file | custom_hid_class.c [code]
usb custom hid class type
file | custom_hid_class.h [code]
usb hid header file
file | custom_hid_desc.c [code]
usb hid device descriptor
file | custom_hid_desc.h [code]
usb custom hid descriptor header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • iar_out
  • inc
inc Directory Reference

Files

file | utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | flash_config.h [code]


AT32F435/437 Firmwary Library: spi Directory Reference

  • at_start_f437
  • examples
  • spi
spi Directory Reference

Directories

directory | crc_transfer_polling
directory | fullduplex_polling
directory | halfduplex_interrupt
directory | halfduplex_transceiver_switch
directory | only_receive_mode_polling
directory | ti_fullduplex_dma
directory | use_jtagpin_hardwarecs_dma
directory | w25q_flash


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • sdio
  • sd_mmc_card
  • inc
inc Directory Reference

Files

file | at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h [code]
this file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library.
file | project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: hid_demo Directory Reference

  • at_start_f437
  • examples
  • usb_host
  • hid_demo
hid_demo Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_tamper
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma5
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c [code]
main program


AT32F435/437 Firmwary Library: conversion_abort Directory Reference

  • at_start_f437
  • examples
  • adc
  • conversion_abort
conversion_abort Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • one_cycle
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/one_cycle/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • utilities
  • at32f435_437_freertos_demo
  • inc
inc Directory Reference

Files

file | utilities/at32f435_437_freertos_demo/inc/at32f435_437_clock.h [code]
header file of clock program
file | utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | utilities/at32f435_437_freertos_demo/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | FreeRTOSConfig.h [code]


AT32F435/437 Firmwary Library: ertc Directory Reference

  • at_start_f437
  • examples
  • ertc
ertc Directory Reference

Directories

directory | bpr_domain
directory | calendar
directory | lick_calibration
directory | tamper
directory | time_stamp
directory | wakeup_timer


AT32F435/437 Firmwary Library: combine_mode_ordinary_smlt_twoslave_dma5 Directory Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma5
combine_mode_ordinary_smlt_twoslave_dma5 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • i2s
  • fullduplex_dma
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • xmc
  • nand_flash
  • nand
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h [code]
header file for the nand configuration.


AT32F435/437 Firmwary Library: link_list_mode Directory Reference

  • at_start_f435
  • examples
  • edma
  • link_list_mode
link_list_mode Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • emac
  • tcp_server
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/emac/tcp_server/src/at32_emac.c [code]
emac config program
file | project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/emac/tcp_server/src/main.c [code]
main program
file | project/at_start_f437/examples/emac/tcp_server/src/netconf.c [code]
network connection configuration
file | tcp_server.c [code]
implement tcp server


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • flash
  • flash_write_read
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f437/examples/flash/flash_write_read/inc/flash.h [code]
flash header file


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_dma2
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • spi
  • ti_fullduplex_dma
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: virtual_msc_iap Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • virtual_msc_iap
virtual_msc_iap Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: AT32F435_437_Firmware_Library_V2.0.9 Directory Reference

AT32F435_437_Firmware_Library_V2.0.9 Directory Reference

Directories

directory | libraries
directory | main_page
directory | middlewares
directory | project
directory | utilities


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • external_clock
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/external_clock/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • i2c
  • communication_int
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • spi
  • ti_fullduplex_dma
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/spi/ti_fullduplex_dma/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c [code]
main program


AT32F435/437 Firmwary Library: virtual_comport Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • virtual_comport
virtual_comport Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: wwdt_reset Directory Reference

  • at_start_f435
  • examples
  • wwdt
  • wwdt_reset
wwdt_reset Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: ertc Directory Reference

  • at_start_f435
  • examples
  • ertc
ertc Directory Reference

Directories

directory | bpr_domain
directory | calendar
directory | lick_calibration
directory | tamper
directory | time_stamp
directory | wakeup_timer


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usart
  • tx_rx_swap
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/main.c [code]
main program
file | at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c [code]
usb user function
file | at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.h [code]
usb host user header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr3
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_preempt_interltrig_twoslave
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma4
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • dac
  • one_dac_noisewave
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/dac/one_dac_noisewave/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/dac/one_dac_noisewave/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/dac/one_dac_noisewave/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • dac
  • double_mode_dma_squarewave
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/dac/double_mode_dma_squarewave/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/dac/double_mode_dma_squarewave/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • libraries
  • drivers
  • inc
inc Directory Reference

Files

file | at32f435_437_acc.h [code]
at32f435_437 acc header file
file | at32f435_437_adc.h [code]
at32f435_437 adc header file
file | at32f435_437_can.h [code]
at32f435_437 can header file
file | at32f435_437_crc.h [code]
at32f435_437 crc header file
file | at32f435_437_crm.h [code]
at32f435_437 crm header file
file | at32f435_437_dac.h [code]
at32f435_437 dac header file
file | at32f435_437_debug.h [code]
file | at32f435_437_def.h [code]
at32f435_437 macros header file
file | at32f435_437_dma.h [code]
at32f435_437 dma header file
file | at32f435_437_dvp.h [code]
at32f435_437 dvp header file
file | at32f435_437_edma.h [code]
at32f435_437 edma header file
file | at32f435_437_emac.h [code]
at32f435_437 eth header file
file | at32f435_437_ertc.h [code]
at32f435_437 ertc header file
file | at32f435_437_exint.h [code]
at32f435_437 exint header file
file | at32f435_437_flash.h [code]
at32f435_437 flash header file
file | at32f435_437_gpio.h [code]
at32f435_437 gpio header file
file | at32f435_437_i2c.h [code]
at32f435_437 i2c header file
file | at32f435_437_misc.h [code]
at32f435_437 misc header file
file | at32f435_437_pwc.h [code]
at32f435_437 pwr header file
file | at32f435_437_qspi.h [code]
at32f435_437 qspi header file
file | at32f435_437_scfg.h [code]
at32f435_437 system config header file
file | at32f435_437_sdio.h [code]
at32f435_437 sdio header file
file | at32f435_437_spi.h [code]
at32f435_437 spi header file
file | at32f435_437_tmr.h [code]
at32f435_437 tmr header file
file | at32f435_437_usart.h [code]
at32f435_437 usart header file
file | at32f435_437_usb.h [code]
at32f435_437 usb header file
file | at32f435_437_wdt.h [code]
at32f435_437 wdt header file
file | at32f435_437_wwdt.h [code]
at32f435_437 wwdt header file
file | at32f435_437_xmc.h [code]
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: receiver_mute Directory Reference

  • at_start_f437
  • examples
  • usart
  • receiver_mute
receiver_mute Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: tmr1 Directory Reference

  • at_start_f437
  • examples
  • debug
  • tmr1
tmr1 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • dac
  • two_dac_trianglewave
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/dac/two_dac_trianglewave/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma1
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • gpio
  • io_toggle
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: halfduplex_dma Directory Reference

  • at_start_f435
  • examples
  • i2s
  • halfduplex_dma
halfduplex_dma Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • adc
  • exint_trigger_partitioned
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: lcd Directory Reference

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • lcd
lcd Directory Reference

Files

file | at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/font.h [code]
file | at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c [code]
xmc_lcd program file
file | at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h [code]
xmc_lcd program header


AT32F435/437 Firmwary Library: at32f435_437_usb_iap_demo Directory Reference

  • utilities
  • at32f435_437_usb_iap_demo
at32f435_437_usb_iap_demo Directory Reference

Directories

directory source_code


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • ertc
  • bpr_domain
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • emac
  • dns_client
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h [code]
header file of emac config program.
file | project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h [code]
file | project/at_start_f437/examples/emac/dns_client/inc/netconf.h [code]
This file contains all the functions prototypes for the netconf.c file.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_rdsr_sw
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/main.c [code]
main program
file | at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c [code]
qspi_cmd_esmt32m program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • custom_hid
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: parallel_synchro Directory Reference

  • at_start_f435
  • examples
  • tmr
  • parallel_synchro
parallel_synchro Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: at32f437_emac_iap_demo Directory Reference

  • utilities
  • at32f437_emac_iap_demo
at32f437_emac_iap_demo Directory Reference

Directories

directory source_code


AT32F435/437 Firmwary Library: sdio_fatfs Directory Reference

  • at_start_f437
  • examples
  • sdio
  • sdio_fatfs
sdio_fatfs Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • gpio
  • led_toggle
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/gpio/led_toggle/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/gpio/led_toggle/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/gpio/led_toggle/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • i2c
  • communication_dma
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/i2c/communication_dma/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/i2c/communication_dma/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/i2c/communication_dma/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • crm
  • pll_parameter_calculate
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: combine_mode_ordinary_smlt_oneslave_edma Directory Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_edma
combine_mode_ordinary_smlt_oneslave_edma Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • composite_vcp_msc
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usb_device/composite_vcp_msc/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usb_device/composite_vcp_msc/src/main.c [code]
main program
file | at_start_f437/examples/usb_device/composite_vcp_msc/src/msc_diskio.c [code]
usb mass storage disk function


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • gpio
  • led_toggle
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: nand Directory Reference

  • at_start_f437
  • examples
  • xmc
  • nand_flash
  • nand
nand Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: adc Directory Reference

  • at_start_f435
  • examples
  • adc
adc Directory Reference

Directories

directory | combine_mode_ordinary_shift_twoslave_dma3
directory | combine_mode_ordinary_shift_twoslave_dma4
directory | combine_mode_ordinary_smlt_oneslave_dma2
directory | combine_mode_ordinary_smlt_oneslave_edma
directory | combine_mode_ordinary_smlt_twoslave_dma1
directory | combine_mode_ordinary_smlt_twoslave_dma5
directory | combine_mode_preempt_interltrig_twoslave
directory | conversion_abort
directory | current_vref_value_check
directory | edma_double_buffer
directory | exint_trigger_partitioned
directory | internal_temperature_sensor
directory | ordinary_preempt_oversampling
directory | resolution_6bit
directory | software_trigger_repeat
directory | tmr_trigger_automatic_preempted
directory | use_polling_get_conversion_data
directory | vbat_monitor
directory | voltage_monitoring


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • i2c
  • eeprom
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • dma
  • dmamux_genertor_exint
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_msc
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c [code]
main program
file | at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c [code]
usb mass storage disk function


AT32F435/437 Firmwary Library: voltage_monitoring Directory Reference

  • at_start_f435
  • examples
  • adc
  • voltage_monitoring
voltage_monitoring Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: otg1_host_otg2_device_demo Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
otg1_host_otg2_device_demo Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • adc
  • conversion_abort
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: command_port_using_rdsr_sw Directory Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_rdsr_sw
command_port_using_rdsr_sw Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: communication_mode Directory Reference

  • at_start_f437
  • examples
  • can
  • communication_mode
communication_mode Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: half_duplex Directory Reference

  • at_start_f435
  • examples
  • usart
  • half_duplex
half_duplex Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: dma Directory Reference

  • at_start_f435
  • examples
  • dma
dma Directory Reference

Directories

directory | dmamux_data_to_gpio
directory | dmamux_genertor_exint
directory | dmamux_synchronization_exint
directory | flash_to_sram


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • acc
  • calibration
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/acc/calibration/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • acc
  • calibration
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/acc/calibration/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/acc/calibration/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/acc/calibration/src/main.c [code]
main program


AT32F435/437 Firmwary Library: wwdt Directory Reference

  • at_start_f437
  • examples
  • wwdt
wwdt Directory Reference

Directories

directory wwdt_reset


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • edma
  • link_list_mode
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_preempt_interltrig_twoslave
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • timer_base
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • dma_burst
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: dmamux_data_to_gpio Directory Reference

  • at_start_f437
  • examples
  • dma
  • dmamux_data_to_gpio
dmamux_data_to_gpio Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: vcp_loopback Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • vcp_loopback
vcp_loopback Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: sleep_usart1 Directory Reference

  • at_start_f437
  • examples
  • pwc
  • sleep_usart1
sleep_usart1 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • adc
  • conversion_abort
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/adc/conversion_abort/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/adc/conversion_abort/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/adc/conversion_abort/src/main.c [code]
main program


AT32F435/437 Firmwary Library: command_port_using_dma_and_pem Directory Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_dma_and_pem
command_port_using_dma_and_pem Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • dac
  • one_dac_dma_escalator
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • can
  • filter
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/can/filter/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/can/filter/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/can/filter/src/main.c [code]
main program


AT32F435/437 Firmwary Library: usbh_hid Directory Reference

  • middlewares
  • usbh_class
  • usbh_hid
usbh_hid Directory Reference

Files

file | usbh_hid_class.c [code]
usb host hid class type
file | usbh_hid_class.h [code]
usb host hid class header file
file | usbh_hid_keyboard.c [code]
usb host hid keyboard type
file | usbh_hid_keyboard.h [code]
usb host hid keyboard header file
file | usbh_hid_mouse.c [code]
usb host hid mouse type
file | usbh_hid_mouse.h [code]
usb host hid mouse header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • 6_steps
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usart
  • hw_flow_control
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_polling
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • spi
  • only_receive_mode_polling
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/spi/only_receive_mode_polling/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • ertc
  • wakeup_timer
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usart
  • rs485
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usart/rs485/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usart/rs485/src/main.c [code]
main program


AT32F435/437 Firmwary Library: command_port_using_interrupt Directory Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_interrupt
command_port_using_interrupt Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • dac
  • one_dac_dma_escalator
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: sysclk_switch Directory Reference

  • at_start_f437
  • examples
  • crm
  • sysclk_switch
sysclk_switch Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_rdsr_sw
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • xmc
  • sdram_basic
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h [code]
header file for the sdram configuration.


AT32F435/437 Firmwary Library: at32f435_437_slib_demo Directory Reference

  • utilities
  • at32f435_437_slib_demo
at32f435_437_slib_demo Directory Reference

Directories

directory | project_l0
directory | project_l1


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • encoder_tmr2
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • utilities
  • at32f435_437_gen_random_number_demo
  • inc
inc Directory Reference

Files

file | utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_clock.h [code]
header file of clock program
file | utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | random.h [code]
at32f435_437 random header file


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usart
  • polling
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usart/polling/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usart/polling/src/main.c [code]
main program


AT32F435/437 Firmwary Library: cascade_synchro Directory Reference

  • at_start_f437
  • examples
  • tmr
  • cascade_synchro
cascade_synchro Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • dac
  • double_mode_dma_sinewave
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: project_l1 Directory Reference

  • utilities
  • at32f435_437_slib_demo
  • project_l1
project_l1 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: pwm_output_simulate Directory Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_output_simulate
pwm_output_simulate Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: tamper Directory Reference

  • at_start_f437
  • examples
  • ertc
  • tamper
tamper Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • adc
  • voltage_monitoring
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • composite_audio_hid
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h [code]
audio codec header file
file | project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usb_host
  • hid_demo
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h [code]
usb config header file
file | at_start_f435/examples/usb_host/hid_demo/inc/usbh_user.h [code]
usb host user header file


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • parallel_synchro
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/parallel_synchro/src/main.c [code]
main program


AT32F435/437 Firmwary Library: hardware Directory Reference

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • hardware
hardware Directory Reference

Directories

directory | dvp
directory | lcd
directory | ov2640


AT32F435/437 Firmwary Library: combine_mode_preempt_interltrig_twoslave Directory Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_preempt_interltrig_twoslave
combine_mode_preempt_interltrig_twoslave Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • dma
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/dma/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/dma/src/main.c [code]
main program


AT32F435/437 Firmwary Library: pwm_output_tmr3 Directory Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_output_tmr3
pwm_output_tmr3 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • wwdt
  • wwdt_reset
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/wwdt/wwdt_reset/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • spi
  • ti_fullduplex_dma
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • oc_high
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • custom_hid
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usb_device/custom_hid/src/main.c [code]
main program


AT32F435/437 Firmwary Library: iperf Directory Reference

  • at_start_f437
  • examples
  • emac
  • iperf
iperf Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_output_tmr10
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/pwm_output_tmr10/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/pwm_output_tmr10/src/main.c [code]
main program


AT32F435/437 Firmwary Library: calendar Directory Reference

  • at_start_f437
  • examples
  • ertc
  • calendar
calendar Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: standby_ertc_alarm Directory Reference

  • at_start_f437
  • examples
  • pwc
  • standby_ertc_alarm
standby_ertc_alarm Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_genertor_exint
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • pwc
  • sleep_usart1
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • i2c
  • communication_dma
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: lcd Directory Reference

  • at_start_f437
  • examples
  • dvp
  • ov2640_capture
  • hardware
  • lcd
lcd Directory Reference

Files

file | at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/font.h [code]
file | at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c [code]
xmc_lcd program file
file | at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h [code]
xmc_lcd program header


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • two_otg_device_demo
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usb_device/two_otg_device_demo/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usb_device/two_otg_device_demo/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • sdio
  • sd_mmc_card
  • inc
inc Directory Reference

Files

file | at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h [code]
this file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library.
file | project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • can
  • communication_mode
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: smartcard Directory Reference

  • at_start_f437
  • examples
  • usart
  • smartcard
smartcard Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: synchronous Directory Reference

  • at_start_f435
  • examples
  • usart
  • synchronous
synchronous Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • i2s
  • halfduplex_interrupt
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: communication_int Directory Reference

  • at_start_f437
  • examples
  • i2c
  • communication_int
communication_int Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • xmc
  • psram
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/xmc/psram/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/xmc/psram/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f437/examples/xmc/psram/inc/xmc_psram.h [code]


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • 6_steps
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/6_steps/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • utilities
  • at32f435_437_slib_demo
  • project_l0
  • inc
inc Directory Reference

Files

file | utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_clock.h [code]
header file of clock program
file | utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project_l0/inc/fir_filter.h [code]
file | project_l0/inc/math_helper.h [code]


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usart
  • hw_flow_control
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • spi
  • use_jtagpin_hardwarecs_dma
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c [code]
main program


AT32F435/437 Firmwary Library: adc Directory Reference

  • at_start_f437
  • examples
  • adc
adc Directory Reference

Directories

directory | combine_mode_ordinary_shift_twoslave_dma3
directory | combine_mode_ordinary_shift_twoslave_dma4
directory | combine_mode_ordinary_smlt_oneslave_dma2
directory | combine_mode_ordinary_smlt_oneslave_edma
directory | combine_mode_ordinary_smlt_twoslave_dma1
directory | combine_mode_ordinary_smlt_twoslave_dma5
directory | combine_mode_preempt_interltrig_twoslave
directory | conversion_abort
directory | current_vref_value_check
directory | edma_double_buffer
directory | exint_trigger_partitioned
directory | internal_temperature_sensor
directory | ordinary_preempt_oversampling
directory | resolution_6bit
directory | software_trigger_repeat
directory | tmr_trigger_automatic_preempted
directory | use_polling_get_conversion_data
directory | vbat_monitor
directory | voltage_monitoring


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • adc
  • tmr_trigger_automatic_preempted
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • msc
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f435/examples/usb_device/msc/inc/msc_diskio.h [code]
usb mass storage disk interface header file
file | project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • gpio
  • swjtag_mux
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: hall_xor_tmr2 Directory Reference

  • at_start_f435
  • examples
  • tmr
  • hall_xor_tmr2
hall_xor_tmr2 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • composite_vcp_keyboard
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usb_device/composite_vcp_keyboard/src/main.c [code]
main program


AT32F435/437 Firmwary Library: combine_mode_ordinary_smlt_twoslave_dma1 Directory Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma1
combine_mode_ordinary_smlt_twoslave_dma1 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: io_toggle Directory Reference

  • at_start_f437
  • examples
  • gpio
  • io_toggle
io_toggle Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: communication_dma Directory Reference

  • at_start_f435
  • examples
  • i2c
  • communication_dma
communication_dma Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • ertc
  • bpr_domain
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: usb_device Directory Reference

  • at_start_f437
  • examples
  • usb_device
usb_device Directory Reference

Directories

directory | audio
directory | composite_audio_hid
directory | composite_vcp_keyboard
directory | composite_vcp_msc
directory | custom_hid
directory | keyboard
directory | mouse
directory | msc
directory | otg1_host_otg2_device_demo
directory | printer
directory | two_otg_device_demo
directory | vcp_loopback
directory | virtual_comport
directory | virtual_msc_iap


AT32F435/437 Firmwary Library: flash_write_read Directory Reference

  • at_start_f437
  • examples
  • flash
  • flash_write_read
flash_write_read Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • crc
  • calculation
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/crc/calculation/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/crc/calculation/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_input_dma
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • gpio
  • swjtag_mux
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/gpio/swjtag_mux/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/gpio/swjtag_mux/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/gpio/swjtag_mux/src/main.c [code]
main program


AT32F435/437 Firmwary Library: halfduplex_dma Directory Reference

  • at_start_f437
  • examples
  • i2s
  • halfduplex_dma
halfduplex_dma Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • two_otg_device_demo
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • spi
  • halfduplex_transceiver_switch
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: crc_transfer_polling Directory Reference

  • at_start_f437
  • examples
  • spi
  • crc_transfer_polling
crc_transfer_polling Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
src Directory Reference

Files

file | utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/at32f435_437_clock.c [code]
system clock config program
file | utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c [code]
main interrupt service routines.
file | at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/iap.c [code]
iap program
file | utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/main.c [code]
main program
file | at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/tmr.c [code]
tmr program
file | app_led4_toggle/src/usart.c [code]
usart program


AT32F435/437 Firmwary Library: 7_pwm_output Directory Reference

  • at_start_f435
  • examples
  • tmr
  • 7_pwm_output
7_pwm_output Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • qspi
  • xip_port_write_read
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/qspi/xip_port_write_read/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/qspi/xip_port_write_read/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/qspi/xip_port_write_read/src/main.c [code]
main program
file | at_start_f437/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c [code]


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usart
  • smartcard
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f437/examples/usart/smartcard/inc/smartcard_config.h [code]
header file of clock program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_edma
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c [code]
main program


AT32F435/437 Firmwary Library: communication_dma Directory Reference

  • at_start_f437
  • examples
  • i2c
  • communication_dma
communication_dma Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: standby_wakeup_pin Directory Reference

  • at_start_f437
  • examples
  • pwc
  • standby_wakeup_pin
standby_wakeup_pin Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • adc
  • resolution_6bit
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/adc/resolution_6bit/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/adc/resolution_6bit/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/adc/resolution_6bit/src/main.c [code]
main program


AT32F435/437 Firmwary Library: i2s_halfduplex_edma_doublebuffer Directory Reference

  • at_start_f435
  • examples
  • edma
  • i2s_halfduplex_edma_doublebuffer
i2s_halfduplex_edma_doublebuffer Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma5
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: iar_out Directory Reference

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • iar_out
iar_out Directory Reference

Directories

directory | framework2
directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • edma
  • link_list_mode
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: lcd Directory Reference

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • hardware
  • lcd
lcd Directory Reference

Files

file | at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/font.h [code]
file | at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c [code]
xmc_lcd program file
file | at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h [code]
xmc_lcd program header


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • complementary_signals
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/complementary_signals/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • i2c
  • communication_int
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/i2c/communication_int/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/i2c/communication_int/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/i2c/communication_int/src/main.c [code]
main program


AT32F435/437 Firmwary Library: encoder_tmr2 Directory Reference

  • at_start_f435
  • examples
  • tmr
  • encoder_tmr2
encoder_tmr2 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: loopback_mode Directory Reference

  • at_start_f437
  • examples
  • can
  • loopback_mode
loopback_mode Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: current_vref_value_check Directory Reference

  • at_start_f435
  • examples
  • adc
  • current_vref_value_check
current_vref_value_check Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • gpio
  • swjtag_mux
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: command_port_using_dma Directory Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_dma
command_port_using_dma Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_squarewave
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • xmc
  • sram
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/xmc/sram/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/xmc/sram/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f435/examples/xmc/sram/inc/xmc_sram.h [code]
header file for the nand configuration.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma3
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: printer Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • printer
printer Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: wwdt Directory Reference

  • at_start_f435
  • examples
  • wwdt
wwdt Directory Reference

Directories

directory wwdt_reset


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • two_otg_device_demo
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c [code]
main program


AT32F435/437 Firmwary Library: at_start_f437 Directory Reference

  • at_start_f437
at_start_f437 Directory Reference

Directories

directory | examples
directory | templates


AT32F435/437 Firmwary Library: i2s Directory Reference

  • at_start_f437
  • examples
  • i2s
i2s Directory Reference

Directories

directory | fullduplex_dma
directory | halfduplex_dma
directory | halfduplex_interrupt
directory | spii2s_switch_halfduplex_polling


AT32F435/437 Firmwary Library: communication_mode Directory Reference

  • at_start_f435
  • examples
  • can
  • communication_mode
communication_mode Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_input_dma
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_keyboard
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • oc_toggle_tmr9
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • pwc
  • deepsleep_ertc_alarm
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • input_capture
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_simulate
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: halfduplex_transceiver_switch Directory Reference

  • at_start_f437
  • examples
  • spi
  • halfduplex_transceiver_switch
halfduplex_transceiver_switch Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: sysclk_switch Directory Reference

  • at_start_f435
  • examples
  • crm
  • sysclk_switch
sysclk_switch Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • ertc
  • bpr_domain
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/ertc/bpr_domain/src/main.c [code]
main program


AT32F435/437 Firmwary Library: mouse Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • mouse
mouse Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_audio_hid
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h [code]
audio codec header file
file | project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: communication_poll Directory Reference

  • at_start_f435
  • examples
  • i2c
  • communication_poll
communication_poll Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • dvp
  • ov5640_capture
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_output_tmr10
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • mouse
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usb_device/mouse/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • ertc
  • tamper
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: transfer_by_dma_interrupt Directory Reference

  • at_start_f437
  • examples
  • usart
  • transfer_by_dma_interrupt
transfer_by_dma_interrupt Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • xmc
  • lcd_touch_16bit
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h [code]
this file contains all the functions prototypes for the touch firmware driver.
file | at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h [code]
xmc_lcd program header


AT32F435/437 Firmwary Library: dmamux_synchronization_exint Directory Reference

  • at_start_f437
  • examples
  • edma
  • dmamux_synchronization_exint
dmamux_synchronization_exint Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
inc Directory Reference

Files

file | utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_clock.h [code]
header file of clock program
file | utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/iap.h [code]
iap header file
file | at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/tmr.h [code]
tmr header file
file | app_led4_toggle/inc/usart.h [code]
usart header file


AT32F435/437 Firmwary Library: pll_parameter_calculate Directory Reference

  • at_start_f437
  • examples
  • crm
  • pll_parameter_calculate
pll_parameter_calculate Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • spi
  • crc_transfer_polling
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: pwm_input Directory Reference

  • at_start_f437
  • examples
  • tmr
  • pwm_input
pwm_input Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • pwc
  • standby_wakeup_pin
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: internal_temperature_sensor Directory Reference

  • at_start_f437
  • examples
  • adc
  • internal_temperature_sensor
internal_temperature_sensor Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: idle_detection Directory Reference

  • at_start_f437
  • examples
  • usart
  • idle_detection
idle_detection Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: pwc Directory Reference

  • at_start_f435
  • examples
  • pwc
pwc Directory Reference

Directories

directory | deepsleep_ertc_alarm
directory | deepsleep_ertc_tamper
directory | deepsleep_ertc_wakeup
directory | ldo_set
directory | power_voltage_monitor
directory | sleep_tmr2
directory | sleep_usart1
directory | standby_ertc_alarm
directory | standby_wakeup_pin


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • tmr
  • tmr1_synchro
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c [code]
main program


AT32F435/437 Firmwary Library: communication_poll Directory Reference

  • at_start_f437
  • examples
  • i2c
  • communication_poll
communication_poll Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • i2s
  • fullduplex_dma
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c [code]
main program


AT32F435/437 Firmwary Library: http_server Directory Reference

  • at_start_f437
  • examples
  • emac
  • http_server
http_server Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • spi
  • ti_fullduplex_dma
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • i2c
  • communication_poll
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • adc
  • vbat_monitor
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/adc/vbat_monitor/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/adc/vbat_monitor/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/adc/vbat_monitor/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • edma
  • two_dimension_mode
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/edma/two_dimension_mode/src/main.c [code]
main program


AT32F435/437 Firmwary Library: usb_host Directory Reference

  • at_start_f437
  • examples
  • usb_host
usb_host Directory Reference

Directories

directory | hid_demo
directory | msc_only_fat32
directory | two_otg_host_demo


AT32F435/437 Firmwary Library: dmamux_data_to_gpio Directory Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_data_to_gpio
dmamux_data_to_gpio Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_polling
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/qspi/command_port_using_polling/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/qspi/command_port_using_polling/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/qspi/command_port_using_polling/src/main.c [code]
main program
file | at_start_f437/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c [code]
qspi_cmd_esmt32m program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • edma
  • two_dimension_mode
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • tmr
  • oc_toggle_tmr9
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • xmc
  • sdram_basic
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/xmc/sdram_basic/src/main.c [code]
main program
file | at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c [code]
sdram program.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • edma
  • dmamux_synchronization_exint
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • custom_hid
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/usb_device/custom_hid/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/usb_device/custom_hid/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/usb_device/custom_hid/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • adc
  • conversion_abort
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/adc/conversion_abort/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usart
  • hw_flow_control
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usart/hw_flow_control/src/main.c [code]
main program


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • usb_device
  • printer
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/usb_device/printer/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/usb_device/printer/src/main.c [code]
main program


AT32F435/437 Firmwary Library: rs485 Directory Reference

  • at_start_f437
  • examples
  • usart
  • rs485
rs485 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • adc
  • use_polling_get_conversion_data
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/adc/use_polling_get_conversion_data/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/adc/use_polling_get_conversion_data/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • utilities
  • at32f435_437_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
inc Directory Reference

Files

file | utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_clock.h [code]
header file of clock program
file | utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.
file | app_led3_toggle/inc/hid_iap_user.h [code]
usb config header file
file | utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h [code]
usb config header file


AT32F435/437 Firmwary Library: Objects Directory Reference

  • at_start_f437
  • examples
  • cortex_m4
  • cmsis_dsp
  • mdk_v5
  • Objects
Objects Directory Reference

Files

file | at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_board.d [code]
file | at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_clock.d [code]
file | at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_crm.d [code]
file | at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_gpio.d [code]
file | at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_int.d [code]
file | at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_misc.d [code]
file | at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/at32f435_437_usart.d [code]
file | at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/basicmathfunctions.d [code]
file | at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/bayesfunctions.d [code]
file | at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/commontables.d [code]
file | at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/complexmathfunctions.d [code]
file | at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/controllerfunctions.d [code]
file | at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/distancefunctions.d [code]
file | at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/fastmathfunctions.d [code]
file | at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/filteringfunctions.d [code]
file | at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/main.d [code]
file | at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/matrixfunctions.d [code]
file | at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/startup_at32f435_437.d [code]
file | at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/statisticsfunctions.d [code]
file | at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/supportfunctions.d [code]
file | at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/svmfunctions.d [code]
file | at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/system_at32f435_437.d [code]
file | at_start_f437/examples/cortex_m4/cmsis_dsp/mdk_v5/Objects/transformfunctions.d [code]


AT32F435/437 Firmwary Library: combine_mode_ordinary_smlt_twoslave_dma1 Directory Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma1
combine_mode_ordinary_smlt_twoslave_dma1 Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: pwm_output_simulate Directory Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_simulate
pwm_output_simulate Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: tmr2_32bit Directory Reference

  • at_start_f437
  • examples
  • tmr
  • tmr2_32bit
tmr2_32bit Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: voltage_monitoring Directory Reference

  • at_start_f437
  • examples
  • adc
  • voltage_monitoring
voltage_monitoring Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • utilities
  • at32f435_437_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
src Directory Reference

Files

file | utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_clock.c [code]
system clock config program
file | utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c [code]
main interrupt service routines.
file | at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c [code]
iap program
file | utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/main.c [code]
main program
file | at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/tmr.c [code]
tmr program
file | app_led3_toggle/src/usart.c [code]
usart program


AT32F435/437 Firmwary Library: usb_device Directory Reference

  • at_start_f435
  • examples
  • usb_device
usb_device Directory Reference

Directories

directory | audio
directory | composite_audio_hid
directory | composite_vcp_keyboard
directory | composite_vcp_msc
directory | custom_hid
directory | keyboard
directory | mouse
directory | msc
directory | otg1_host_otg2_device_demo
directory | printer
directory | two_otg_device_demo
directory | vcp_loopback
directory | virtual_comport
directory | virtual_msc_iap


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • spi
  • halfduplex_transceiver_switch
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c [code]
main program


AT32F435/437 Firmwary Library: calibration Directory Reference

  • at_start_f437
  • examples
  • acc
  • calibration
calibration Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: vcp_loopback Directory Reference

  • at_start_f437
  • examples
  • usb_device
  • vcp_loopback
vcp_loopback Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: command_port_using_polling Directory Reference

  • at_start_f437
  • examples
  • qspi
  • command_port_using_polling
command_port_using_polling Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: bit_band Directory Reference

  • at_start_f437
  • examples
  • cortex_m4
  • bit_band
bit_band Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: ordinary_preempt_oversampling Directory Reference

  • at_start_f437
  • examples
  • adc
  • ordinary_preempt_oversampling
ordinary_preempt_oversampling Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • i2s
  • halfduplex_interrupt
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • adc
  • voltage_monitoring
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/adc/voltage_monitoring/src/main.c [code]
main program


AT32F435/437 Firmwary Library: hang_mode Directory Reference

  • at_start_f437
  • examples
  • tmr
  • hang_mode
hang_mode Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f437
  • examples
  • pwc
  • deepsleep_ertc_wakeup
  • inc
inc Directory Reference

Files

file | project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: external_clock Directory Reference

  • at_start_f437
  • examples
  • tmr
  • external_clock
external_clock Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f437
  • examples
  • pwc
  • sleep_tmr2
  • src
src Directory Reference

Files

file | project/at_start_f437/examples/pwc/sleep_tmr2/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f437/examples/pwc/sleep_tmr2/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f437/examples/pwc/sleep_tmr2/src/main.c [code]
main program


AT32F435/437 Firmwary Library: psram Directory Reference

  • at_start_f437
  • examples
  • xmc
  • psram
psram Directory Reference

Directories

directory | inc
directory | src


AT32F435/437 Firmwary Library: src Directory Reference

  • at_start_f435
  • examples
  • edma
  • flash_to_sram
  • src
src Directory Reference

Files

file | project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_clock.c [code]
system clock config program
file | project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c [code]
main interrupt service routines.
file | project/at_start_f435/examples/edma/flash_to_sram/src/main.c [code]
main program


AT32F435/437 Firmwary Library: inc Directory Reference

  • at_start_f435
  • examples
  • adc
  • exint_trigger_partitioned
  • inc
inc Directory Reference

Files

file | project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_clock.h [code]
header file of clock program
file | project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h [code]
at32f435_437 config header file
file | project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h [code]
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: fir_coefficient.c File Reference

  • utilities
  • at32f435_437_slib_demo
  • project_l0
  • src
Macros | Variables
fir_coefficient.c File Reference
#include "at32f435_437.h"
#include "arm_math.h"
#include "fir_filter.h"

Go to the source code of this file.

Macros

#define NUM_TAPS 29

Variables

const float32_t firCoeffs32 [29]

Macro Definition Documentation

◆ NUM_TAPS

#define NUM_TAPS 29

Definition at line 51 of file fir_coefficient.c.

Variable Documentation

◆ firCoeffs32

const float32_t firCoeffs32[29]
Initial value:
= {
-0.0018225230f, -0.0015879294f, +0.0000000000f, +0.0036977508f, +0.0080754303f, +0.0085302217f, -0.0000000000f, -0.0173976984f,
-0.0341458607f, -0.0333591565f, +0.0000000000f, +0.0676308395f, +0.1522061835f, +0.2229246956f, +0.2504960933f, +0.2229246956f,
+0.1522061835f, +0.0676308395f, +0.0000000000f, -0.0333591565f, -0.0341458607f, -0.0173976984f, -0.0000000000f, +0.0085302217f,
+0.0080754303f, +0.0036977508f, +0.0000000000f, -0.0015879294f, -0.0018225230f
}

Definition at line 62 of file fir_coefficient.c.

Referenced by FIR_lowpass_filter().


AT32F435/437 Firmwary Library: fir_coefficient.c Source File

  • utilities
  • at32f435_437_slib_demo
  • project_l0
  • src
fir_coefficient.c
Go to the documentation of this file.
1/* ----------------------------------------------------------------------
2 * Copyright (C) 2010-2012 ARM Limited. All rights reserved.
3 *
4* $Date: 17. January 2013
5* $Revision: V1.4.0
6*
7* Project: CMSIS DSP Library
8 * Title: arm_fir_example_f32.c
9 *
10 * Description: Example code demonstrating how an FIR filter can be used
11 * as a low pass filter.
12 *
13 * Target Processor: Cortex-M4/Cortex-M3
14 *
15* Redistribution and use in source and binary forms, with or without
16* modification, are permitted provided that the following conditions
17* are met:
18* - Redistributions of source code must retain the above copyright
19* notice, this list of conditions and the following disclaimer.
20* - Redistributions in binary form must reproduce the above copyright
21* notice, this list of conditions and the following disclaimer in
22* the documentation and/or other materials provided with the
23* distribution.
24* - Neither the name of ARM LIMITED nor the names of its contributors
25* may be used to endorse or promote products derived from this
26* software without specific prior written permission.
27*
28* THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
29* "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
30* LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
31* FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
32* COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
33* INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
34* BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
35* LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
36* CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
37* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
38* ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
39* POSSIBILITY OF SUCH DAMAGE.
40* -------------------------------------------------------------------- */
41/* ----------------------------------------------------------------------
42** Include Files
43** ------------------------------------------------------------------- */
44#include "at32f435_437.h"
45#include "arm_math.h"
46#include "fir_filter.h"
47/* ----------------------------------------------------------------------
48** Macro Defines
49** ------------------------------------------------------------------- */
50
51#define NUM_TAPS 29
52
53/* ----------------------------------------------------------------------
54** FIR Coefficients buffer generated using fir1() MATLAB function.
55** fir1(28, 6/24)
56** ------------------------------------------------------------------- */
57//#if defined ( __ICCARM__ )
58//const float32_t firCoeffs32[NUM_TAPS] @ 0x08001000 ={
59//#elif defined ( __CC_ARM )
60//const float32_t firCoeffs32[NUM_TAPS] __attribute__((at(0x08001000))) = {
61//#endif
62const float32_t firCoeffs32[NUM_TAPS] = {
63 -0.0018225230f, -0.0015879294f, +0.0000000000f, +0.0036977508f, +0.0080754303f, +0.0085302217f, -0.0000000000f, -0.0173976984f,
64 -0.0341458607f, -0.0333591565f, +0.0000000000f, +0.0676308395f, +0.1522061835f, +0.2229246956f, +0.2504960933f, +0.2229246956f,
65 +0.1522061835f, +0.0676308395f, +0.0000000000f, -0.0333591565f, -0.0341458607f, -0.0173976984f, -0.0000000000f, +0.0085302217f,
66 +0.0080754303f, +0.0036977508f, +0.0000000000f, -0.0015879294f, -0.0018225230f
67};
68
at32f435_437.h
at32f435_437 header file
firCoeffs32
const float32_t firCoeffs32[29]
Definition: fir_coefficient.c:62
NUM_TAPS
#define NUM_TAPS
Definition: fir_coefficient.c:51


AT32F435/437 Firmwary Library: fir_filter.c File Reference

  • utilities
  • at32f435_437_slib_demo
  • project_l0
  • src
Macros | Functions | Variables
fir_filter.c File Reference
#include "at32f435_437.h"
#include "arm_math.h"
#include "fir_filter.h"

Go to the source code of this file.

Macros

#define | BLOCK_SIZE 32
#define | NUM_TAPS 29

Functions

void FIR_lowpass_filter (float32_t *pSrc, float32_t *pDst, uint32_t testlengthsamples)

Variables

const float32_t | firCoeffs32 []
static float32_t | firStateF32 [32+29 - 1]

Macro Definition Documentation

◆ BLOCK_SIZE

#define BLOCK_SIZE 32

Definition at line 53 of file fir_filter.c.

◆ NUM_TAPS

#define NUM_TAPS 29

Definition at line 54 of file fir_filter.c.

Function Documentation

◆ FIR_lowpass_filter()

void FIR_lowpass_filter | ( | float32_t * | pSrc,
 |  | float32_t * | pDst,
 |  | uint32_t | testlengthsamples
 | ) |  |

Definition at line 76 of file fir_filter.c.

Referenced by main().

Variable Documentation

◆ firCoeffs32

const float32_t firCoeffs32[]
extern

Definition at line 62 of file fir_coefficient.c.

Referenced by FIR_lowpass_filter().

◆ firStateF32

float32_t firStateF32[32+ 29 - 1]
static

Definition at line 66 of file fir_filter.c.

Referenced by FIR_lowpass_filter().


AT32F435/437 Firmwary Library: fir_filter.c Source File

  • utilities
  • at32f435_437_slib_demo
  • project_l0
  • src
fir_filter.c
Go to the documentation of this file.
1/* ----------------------------------------------------------------------
2 * Copyright (C) 2010-2012 ARM Limited. All rights reserved.
3 *
4* $Date: 17. January 2013
5* $Revision: V1.4.0
6*
7* Project: CMSIS DSP Library
8 * Title: arm_fir_example_f32.c
9 *
10 * Description: Example code demonstrating how an FIR filter can be used
11 * as a low pass filter.
12 *
13 * Target Processor: Cortex-M4/Cortex-M3
14 *
15* Redistribution and use in source and binary forms, with or without
16* modification, are permitted provided that the following conditions
17* are met:
18* - Redistributions of source code must retain the above copyright
19* notice, this list of conditions and the following disclaimer.
20* - Redistributions in binary form must reproduce the above copyright
21* notice, this list of conditions and the following disclaimer in
22* the documentation and/or other materials provided with the
23* distribution.
24* - Neither the name of ARM LIMITED nor the names of its contributors
25* may be used to endorse or promote products derived from this
26* software without specific prior written permission.
27*
28* THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
29* "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
30* LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
31* FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
32* COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
33* INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
34* BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
35* LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
36* CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
37* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
38* ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
39* POSSIBILITY OF SUCH DAMAGE.
40* -------------------------------------------------------------------- */
41/* ----------------------------------------------------------------------
42** Include Files
43** ------------------------------------------------------------------- */
44#include "at32f435_437.h"
45#include "arm_math.h"
46#include "fir_filter.h"
47
48extern const float32_t firCoeffs32[];
49
50/* ----------------------------------------------------------------------
51** Macro Defines
52** ------------------------------------------------------------------- */
53#define BLOCK_SIZE 32
54#define NUM_TAPS 29
55
56/* -------------------------------------------------------------------
57 * Declare State buffer of size (numTaps + blockSize - 1)
58 * ------------------------------------------------------------------- */
59
60
61//#if defined ( __ICCARM__ )
62//static float32_t firStateF32[BLOCK_SIZE + NUM_TAPS - 1] @ 0x2005F000 ;
63//#elif defined ( __CC_ARM )
64//static float32_t firStateF32[BLOCK_SIZE + NUM_TAPS - 1] __attribute__((at(0x2005F000)));
65//#endif
66static float32_t firStateF32[BLOCK_SIZE + NUM_TAPS - 1] ;
67
68/* ----------------------------------------------------------------------
69** FIR Coefficients buffer generated using fir1() MATLAB function.
70** fir1(28, 6/24)
71** ------------------------------------------------------------------- */
72
73/* ----------------------------------------------------------------------
74 * FIR LPF Example
75 * ------------------------------------------------------------------- */
76void FIR_lowpass_filter(float32_t * pSrc, float32_t * pDst, uint32_t testlengthsamples)
77{
78 uint32_t i;
79 uint32_t blockSize = BLOCK_SIZE;
80 uint32_t numBlocks = testlengthsamples/BLOCK_SIZE;
81 arm_fir_instance_f32 S;
82
83
84 /* Call FIR init function to initialize the instance structure. */
85 arm_fir_init_f32(&S, NUM_TAPS, (float32_t *)&firCoeffs32[0], &firStateF32[0], blockSize);
86 /* ----------------------------------------------------------------------
87 ** Call the FIR process function for every blockSize samples
88 ** ------------------------------------------------------------------- */
89 for(i=0; i < numBlocks; i++)
90 {
91 arm_fir_f32(&S, pSrc + (i * blockSize), pDst + (i * blockSize), blockSize);
92 }
93
94}
at32f435_437.h
at32f435_437 header file
firCoeffs32
const float32_t firCoeffs32[]
Definition: fir_coefficient.c:62
firStateF32
static float32_t firStateF32[32+29 - 1]
Definition: fir_filter.c:66
NUM_TAPS
#define NUM_TAPS
Definition: fir_filter.c:54
BLOCK_SIZE
#define BLOCK_SIZE
Definition: fir_filter.c:53
FIR_lowpass_filter
void FIR_lowpass_filter(float32_t *pSrc, float32_t *pDst, uint32_t testlengthsamples)
Definition: fir_filter.c:76
arm_fir_f32
void arm_fir_f32(const arm_fir_instance_f32 *S, const float32_t *pSrc, float32_t *pDst, uint32_t blockSize)
arm_fir_init_f32
void arm_fir_init_f32(arm_fir_instance_f32 *S, uint16_t numTaps, const float32_t *pCoeffs, float32_t *pState, uint32_t blockSize)
Initialization function for the floating-point FIR filter.
Definition: arm_fir_init_f32.c:59


AT32F435/437 Firmwary Library: flash_config.h File Reference

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • iar_out
  • inc
Macros
flash_config.h File Reference

Go to the source code of this file.

Macros

#define | USE_ARGC_ARGV 1
#define | MAX_ARGS 5
#define | MAX_ARG_SIZE 64
#define | CODE_ADDR_AS_VOID_PTR 1

Macro Definition Documentation

◆ CODE_ADDR_AS_VOID_PTR

#define CODE_ADDR_AS_VOID_PTR 1

Definition at line 22 of file flash_config.h.

◆ MAX_ARG_SIZE

#define MAX_ARG_SIZE 64

Definition at line 16 of file flash_config.h.

◆ MAX_ARGS

#define MAX_ARGS 5

Definition at line 13 of file flash_config.h.

◆ USE_ARGC_ARGV

#define USE_ARGC_ARGV 1

Definition at line 7 of file flash_config.h.


AT32F435/437 Firmwary Library: flash_config.h Source File

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • iar_out
  • inc
flash_config.h
Go to the documentation of this file.
1// You should create a copy of this file in your flash loader project
2// and configure it as described below
3
4// when this macro is non-zero, your FlashInit function should accept
5// extra 'argc' and 'argv' arguments as specified by the function
6// prototype in 'flash_loader.h'
7#define USE_ARGC_ARGV 1
8
9// You can customize the memory reserved for passing arguments to FlashInit
10// through argc and argv.
11#if USE_ARGC_ARGV
12// This specifies the maximum allowed number of arguments in argv
13#define MAX_ARGS 5
14// This specifies the maximum combined size of the arguments, including
15// a trailing null for each argument
16#define MAX_ARG_SIZE 64
17#endif
18
19// If this is true (non-zero), the parameter designating the code destination
20// in flash operations will be a 'void *', otherwise it will be a uint32_t.
21// Targets where void * is smaller than a code pointer should set this to 0.
22#define CODE_ADDR_AS_VOID_PTR 1
23


AT32F435/437 Firmwary Library: flash_loader.c File Reference

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • iar_out
  • framework2
Macros | Functions | Variables
flash_loader.c File Reference
#include "flash_loader.h"
#include "flash_loader_extra.h"

Go to the source code of this file.

Macros

#define | MAX_ARGS 7
#define | MAX_ARG_SIZE 64
#define | CODE_REF void *

Functions

void | Fl2FlashInitEntry (void)
void | Fl2FlashWriteEntry (void)
void | Fl2FlashEraseWriteEntry (void)
void | Fl2FlashChecksumEntry (void)
void | Fl2FlashSignoffEntry (void)
void | FlashBreak (void)
uint32_t | FlashChecksum (void const *begin, uint32_t count)
uint32_t | FlashSignoff ()
uint16_t | Crc16_helper (uint8_t const *p, uint32_t len, uint16_t sum)
uint16_t | Crc16 (uint8_t const *p, uint32_t len)

Variables

__root __no_init FlashParamsHolder | theFlashParams
__no_init int | __argc
__no_init char | __argvbuf [64]
__no_init const char * | __argv [7]

Macro Definition Documentation

◆ CODE_REF

#define CODE_REF void *

Definition at line 40 of file flash_loader.c.

◆ MAX_ARG_SIZE

#define MAX_ARG_SIZE 64

Definition at line 12 of file flash_loader.c.

◆ MAX_ARGS

#define MAX_ARGS 7

Definition at line 7 of file flash_loader.c.

Function Documentation

◆ Crc16()

uint16_t Crc16 | ( | uint8_t const * | p,
 |  | uint32_t | len
 | ) |  |

Definition at line 113 of file flash_loader.c.

Referenced by FlashChecksum().

◆ Crc16_helper()

uint16_t Crc16_helper | ( | uint8_t const * | p,
 |  | uint32_t | len,
 |  | uint16_t | sum
 | ) |  |

Definition at line 120 of file flash_loader.c.

Referenced by Crc16().

◆ Fl2FlashChecksumEntry()

void Fl2FlashChecksumEntry ( void )

Definition at line 101 of file flash_loader.c.

◆ Fl2FlashEraseWriteEntry()

void Fl2FlashEraseWriteEntry ( void )

Definition at line 72 of file flash_loader.c.

◆ Fl2FlashInitEntry()

void Fl2FlashInitEntry ( void )

Definition at line 45 of file flash_loader.c.

◆ Fl2FlashSignoffEntry()

void Fl2FlashSignoffEntry ( void )

Definition at line 107 of file flash_loader.c.

◆ Fl2FlashWriteEntry()

void Fl2FlashWriteEntry ( void )

Definition at line 63 of file flash_loader.c.

◆ FlashBreak()

__root void FlashBreak ( void )

Definition at line 142 of file flash_loader.c.

◆ FlashChecksum()

uint32_t FlashChecksum | ( | void const * | begin,
 |  | uint32_t | count
 | ) |  |

Definition at line 47 of file flash_loader_ram.c.

Referenced by Fl2FlashChecksumEntry().

Variable Documentation

◆ __argc

__no_init int __argc

Definition at line 34 of file flash_loader.c.

Referenced by Fl2FlashInitEntry().

◆ __argv

__no_init const char* __argv[7]

Definition at line 37 of file flash_loader.c.

Referenced by Fl2FlashInitEntry().

◆ __argvbuf

__no_init char __argvbuf[64]

Definition at line 35 of file flash_loader.c.

◆ theFlashParams

__root __no_init FlashParamsHolder theFlashParams

Definition at line 32 of file flash_loader.c.

Referenced by Fl2FlashChecksumEntry(), Fl2FlashEraseWriteEntry(), Fl2FlashInitEntry(), Fl2FlashSignoffEntry(), and Fl2FlashWriteEntry().


AT32F435/437 Firmwary Library: flash_loader.c Source File

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • iar_out
  • framework2
flash_loader.c
Go to the documentation of this file.
1// Wrapper for target-specific flash loader code
2
3#include "flash_loader.h"
4#include "flash_loader_extra.h"
5
6#ifndef MAX_ARGS
7#define MAX_ARGS 7
8#endif
9
10// Maximum combined size of arguments, including a trailing null for each argument.
11#ifndef MAX_ARG_SIZE
12#define MAX_ARG_SIZE 64
13#endif
14
15// Functions in this file, called from the assembly wrapper
16void Fl2FlashInitEntry(void);
17void Fl2FlashWriteEntry(void);
18void Fl2FlashEraseWriteEntry(void);
19void Fl2FlashChecksumEntry(void);
20void Fl2FlashSignoffEntry(void);
21void FlashBreak(void);
22
23#if CODE_ADDR_AS_VOID_PTR
24extern uint32_t FlashChecksum(void const *begin, uint32_t count);
25#else
26extern uint32_t FlashChecksum(uint32_t begin, uint32_t count);
27#endif
28extern uint32_t FlashSignoff();
29
30uint16_t Crc16_helper(uint8_t const *p, uint32_t len, uint16_t sum);
31
32__root __no_init FlashParamsHolder theFlashParams;
33
34__no_init int __argc;
35__no_init char __argvbuf[MAX_ARG_SIZE];
36#pragma required=__argvbuf
37__no_init const char* __argv[MAX_ARGS];
38
39#if CODE_ADDR_AS_VOID_PTR
40#define CODE_REF void *
41#else
42#define CODE_REF uint32_t
43#endif
44
45void Fl2FlashInitEntry()
46{
47#if USE_ARGC_ARGV
48 theFlashParams.count = FlashInit((CODE_REF)theFlashParams.base_ptr,
49 theFlashParams.block_size, // Image size
50 theFlashParams.offset_into_block,// link adr
51 theFlashParams.count, // flags
52 __argc,
53 __argv);
54#else
55 theFlashParams.count = FlashInit((CODE_REF)theFlashParams.base_ptr,
56 theFlashParams.block_size, // Image size
57 theFlashParams.offset_into_block,// link adr
58 theFlashParams.count); // flags
59#endif
60}
61
62// The normal flash write function ----------------------------------------------
63void Fl2FlashWriteEntry()
64{
65 theFlashParams.count = FlashWrite((CODE_REF)theFlashParams.base_ptr,
66 theFlashParams.offset_into_block,
67 theFlashParams.count,
68 theFlashParams.buffer);
69}
70
71// The erase-first flash write function -----------------------------------------
72void Fl2FlashEraseWriteEntry()
73{
74 uint32_t tmp = theFlashParams.block_size;
75 if (tmp == 0)
76 {
77 FlashEraseData *p = (FlashEraseData*)theFlashParams.buffer;
78 for (uint32_t i = 0; i < theFlashParams.count; ++i)
79 {
80 tmp = FlashErase((CODE_REF)p->start, p->length);
81 if (tmp != 0) break;
82 ++p;
83 }
84 }
85 else
86 {
87 tmp = FlashErase((CODE_REF)theFlashParams.base_ptr,
88 theFlashParams.block_size);
89 if (tmp == 0)
90 {
91 tmp = FlashWrite((CODE_REF)theFlashParams.base_ptr,
92 theFlashParams.offset_into_block,
93 theFlashParams.count,
94 theFlashParams.buffer);
95 }
96 }
97 theFlashParams.count = tmp;
98}
99
100
101void Fl2FlashChecksumEntry()
102{
103 theFlashParams.count = FlashChecksum((CODE_REF)theFlashParams.base_ptr,
104 theFlashParams.count);
105}
106
107void Fl2FlashSignoffEntry()
108{
109 theFlashParams.count = FlashSignoff();
110}
111
112
113uint16_t Crc16(uint8_t const *p, uint32_t len)
114{
115 uint8_t zero[2] = { 0, 0 };
116 uint16_t sum = Crc16_helper(p, len, 0);
117 return Crc16_helper(zero, 2, sum);
118}
119
120uint16_t Crc16_helper(uint8_t const *p, uint32_t len, uint16_t sum)
121{
122 while (len--)
123 {
124 int i;
125 uint8_t byte = *p++;
126
127 for (i = 0; i < 8; ++i)
128 {
129 uint32_t osum = sum;
130 sum <<= 1;
131 if (byte & 0x80)
132 sum |= 1 ;
133 if (osum & 0x8000)
134 sum ^= 0x1021;
135 byte <<= 1;
136 }
137 }
138 return sum;
139}
140
141#pragma optimize=no_inline
142__root void FlashBreak()
143{
144 while(1);
145}
Fl2FlashSignoffEntry
void Fl2FlashSignoffEntry(void)
Definition: flash_loader.c:107
Fl2FlashChecksumEntry
void Fl2FlashChecksumEntry(void)
Definition: flash_loader.c:101
__argv
__no_init const char * __argv[7]
Definition: flash_loader.c:37
theFlashParams
__root __no_init FlashParamsHolder theFlashParams
Definition: flash_loader.c:32
__argvbuf
__no_init char __argvbuf[64]
Definition: flash_loader.c:35
MAX_ARGS
#define MAX_ARGS
Definition: flash_loader.c:7
FlashBreak
void FlashBreak(void)
Definition: flash_loader.c:142
FlashChecksum
uint32_t FlashChecksum(void const *begin, uint32_t count)
Definition: flash_loader_ram.c:47
MAX_ARG_SIZE
#define MAX_ARG_SIZE
Definition: flash_loader.c:12
Fl2FlashEraseWriteEntry
void Fl2FlashEraseWriteEntry(void)
Definition: flash_loader.c:72
Fl2FlashInitEntry
void Fl2FlashInitEntry(void)
Definition: flash_loader.c:45
__argc
__no_init int __argc
Definition: flash_loader.c:34
CODE_REF
#define CODE_REF
Definition: flash_loader.c:40
Crc16
uint16_t Crc16(uint8_t const *p, uint32_t len)
Definition: flash_loader.c:113
Crc16_helper
uint16_t Crc16_helper(uint8_t const *p, uint32_t len, uint16_t sum)
Definition: flash_loader.c:120
Fl2FlashWriteEntry
void Fl2FlashWriteEntry(void)
Definition: flash_loader.c:63
flash_loader.h
flash_loader_extra.h
FlashInit
uint32_t FlashInit(void *base_of_flash, uint32_t image_size, uint32_t link_address, uint32_t flags)
Definition: qspi_algorithm.c:292
FlashWrite
uint32_t FlashWrite(void *block_start, uint32_t offset_into_block, uint32_t count, char const *buffer)
Definition: flash_loader_ram.c:22
FlashSignoff
uint32_t FlashSignoff()
Definition: flash_loader_ram.c:53
FlashErase
uint32_t FlashErase(void *block_start, uint32_t block_size)
Definition: flash_loader_ram.c:35
FlashEraseData
Definition: flash_loader_extra.h:20
FlashEraseData::start
uint32_t start
Definition: flash_loader_extra.h:21
FlashEraseData::length
uint32_t length
Definition: flash_loader_extra.h:22
FlashParamsHolder
Definition: flash_loader_extra.h:12
FlashParamsHolder::block_size
uint32_t block_size
Definition: flash_loader_extra.h:17
FlashParamsHolder::count
uint32_t count
Definition: flash_loader_extra.h:14
FlashParamsHolder::base_ptr
uint32_t base_ptr
Definition: flash_loader_extra.h:13
FlashParamsHolder::offset_into_block
uint32_t offset_into_block
Definition: flash_loader_extra.h:15
FlashParamsHolder::buffer
void * buffer
Definition: flash_loader_extra.h:16


AT32F435/437 Firmwary Library: flash_loader.h File Reference

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • iar_out
  • framework2
Macros | Functions
flash_loader.h File Reference
#include "flash_config.h"
#include <stdint.h>

Go to the source code of this file.

Macros

#define | RESULT_OK 0
#define | RESULT_ERROR 1
#define | RESULT_OVERRIDE_DEVICE 2
#define | RESULT_ERASE_DONE 3
#define | RESULT_CUSTOM_FIRST 100
#define | RESULT_CUSTOM_LAST 200
#define | FLAG_ERASE_ONLY 0x1
#define | CODE_ADDR_AS_VOID_PTR 1
#define | OPTIONAL_CHECKSUM _Pragma("required=FlashChecksumEntry") __root
#define | OPTIONAL_SIGNOFF _Pragma("required=FlashSignoffEntry") __root

Functions

uint32_t | FlashInit (void *base_of_flash, uint32_t image_size, uint32_t link_address, uint32_t flags)
uint32_t | FlashWrite (void *block_start, uint32_t offset_into_block, uint32_t count, char const *buffer)
uint32_t | FlashErase (void *block_start, uint32_t block_size)
uint32_t | FlashChecksum (void const *begin, uint32_t count)
uint32_t | FlashSignoff (void)
void | FlashChecksumEntry ()
void | FlashSignoffEntry ()
uint16_t | Crc16 (uint8_t const *p, uint32_t len)

Macro Definition Documentation

◆ CODE_ADDR_AS_VOID_PTR

#define CODE_ADDR_AS_VOID_PTR 1

Definition at line 15 of file flash_loader.h.

◆ FLAG_ERASE_ONLY

#define FLAG_ERASE_ONLY 0x1

Definition at line 12 of file flash_loader.h.

◆ OPTIONAL_CHECKSUM

#define OPTIONAL_CHECKSUM _Pragma("required=FlashChecksumEntry") __root

Definition at line 69 of file flash_loader.h.

◆ OPTIONAL_SIGNOFF

#define OPTIONAL_SIGNOFF _Pragma("required=FlashSignoffEntry") __root

Definition at line 70 of file flash_loader.h.

◆ RESULT_CUSTOM_FIRST

#define RESULT_CUSTOM_FIRST 100

Definition at line 9 of file flash_loader.h.

◆ RESULT_CUSTOM_LAST

#define RESULT_CUSTOM_LAST 200

Definition at line 10 of file flash_loader.h.

◆ RESULT_ERASE_DONE

#define RESULT_ERASE_DONE 3

Definition at line 8 of file flash_loader.h.

◆ RESULT_ERROR

#define RESULT_ERROR 1

Definition at line 6 of file flash_loader.h.

◆ RESULT_OK

#define RESULT_OK 0

Definition at line 5 of file flash_loader.h.

◆ RESULT_OVERRIDE_DEVICE

#define RESULT_OVERRIDE_DEVICE 2

Definition at line 7 of file flash_loader.h.

Function Documentation

◆ Crc16()

uint16_t Crc16 | ( | uint8_t const * | p,
 |  | uint32_t | len
 | ) |  |

Definition at line 113 of file flash_loader.c.

Referenced by FlashChecksum().

◆ FlashChecksum()

uint32_t FlashChecksum | ( | void const * | begin,
 |  | uint32_t | count
 | ) |  |

Definition at line 47 of file flash_loader_ram.c.

◆ FlashChecksumEntry()

void FlashChecksumEntry ( )

◆ FlashSignoffEntry()

void FlashSignoffEntry ( )


AT32F435/437 Firmwary Library: flash_loader.h Source File

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • iar_out
  • framework2
flash_loader.h
Go to the documentation of this file.
1
2#include "flash_config.h"
3#include <stdint.h>
4
5#define RESULT_OK 0
6#define RESULT_ERROR 1
7#define RESULT_OVERRIDE_DEVICE 2
8#define RESULT_ERASE_DONE 3
9#define RESULT_CUSTOM_FIRST 100
10#define RESULT_CUSTOM_LAST 200
11
12#define FLAG_ERASE_ONLY 0x1
13
14#ifndef CODE_ADDR_AS_VOID_PTR
15#define CODE_ADDR_AS_VOID_PTR 1
16#endif
17
18// These are functions you MUST implement -------------------------------
19#if CODE_ADDR_AS_VOID_PTR
20
21#if USE_ARGC_ARGV
22uint32_t FlashInit(void *base_of_flash, uint32_t image_size,
23 uint32_t link_address, uint32_t flags,
24 int argc, char const *argv[]);
25#else
26uint32_t FlashInit(void *base_of_flash, uint32_t image_size,
27 uint32_t link_address, uint32_t flags);
28#endif
29
30uint32_t FlashWrite(void *block_start,
31 uint32_t offset_into_block,
32 uint32_t count,
33 char const *buffer);
34
35uint32_t FlashErase(void *block_start,
36 uint32_t block_size);
37
38#else // !CODE_ADDR_AS_VOID_PTR
39
40#if USE_ARGC_ARGV
41uint32_t FlashInit(uint32_t base_of_flash, uint32_t image_size,
42 uint32_t link_address, uint32_t flags,
43 int argc, char const *argv[]);
44#else
45uint32_t FlashInit(uint32_t base_of_flash, uint32_t image_size,
46 uint32_t link_address, uint32_t flags);
47#endif
48
49uint32_t FlashWrite(uint32_t block_start,
50 uint32_t offset_into_block,
51 uint32_t count,
52 char const *buffer);
53
54uint32_t FlashErase(uint32_t block_start,
55 uint32_t block_size);
56
57#endif // CODE_ADDR_AS_VOID_PTR
58
59// These are functions you MAY implement --------------------------------
60
61#if CODE_ADDR_AS_VOID_PTR
62uint32_t FlashChecksum(void const *begin, uint32_t count);
63#else
64uint32_t FlashChecksum(uint32_t begin, uint32_t count);
65#endif
66
67uint32_t FlashSignoff(void);
68
69#define OPTIONAL_CHECKSUM _Pragma("required=FlashChecksumEntry") __root
70#define OPTIONAL_SIGNOFF _Pragma("required=FlashSignoffEntry") __root
71void FlashChecksumEntry();
72void FlashSignoffEntry();
73
74// These are functions you may call -------------------------------------
75
76// If your code cannot be accessed using data pointers, you will have to
77// write your own Crc16 function.
78uint16_t Crc16(uint8_t const *p, uint32_t len);
flash_config.h
FlashChecksumEntry
void FlashChecksumEntry()
FlashChecksum
uint32_t FlashChecksum(void const *begin, uint32_t count)
Definition: flash_loader_ram.c:47
FlashSignoffEntry
void FlashSignoffEntry()
Crc16
uint16_t Crc16(uint8_t const *p, uint32_t len)
Definition: flash_loader.c:113
buffer
uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:43
FlashInit
uint32_t FlashInit(void *base_of_flash, uint32_t image_size, uint32_t link_address, uint32_t flags)
Definition: qspi_algorithm.c:292
FlashWrite
uint32_t FlashWrite(void *block_start, uint32_t offset_into_block, uint32_t count, char const *buffer)
Definition: flash_loader_ram.c:22
FlashSignoff
uint32_t FlashSignoff(void)
Definition: flash_loader_ram.c:53
FlashErase
uint32_t FlashErase(void *block_start, uint32_t block_size)
Definition: flash_loader_ram.c:35


AT32F435/437 Firmwary Library: flash_loader_extra.h File Reference

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • iar_out
  • framework2
Data Structures | Macros | Variables
flash_loader_extra.h File Reference

Go to the source code of this file.

Data Structures

struct | FlashParamsHolder
struct | FlashEraseData

Macros

#define | OVERRIDE_LAYOUT 0x010000
#define | OVERRIDE_BUFSIZE 0x020000
#define | OVERRIDE_PAGESIZE 0x040000
#define | LAYOUT_OVERRIDE_BUFFER ((char*)theFlashParams.buffer)
#define | SET_BUFSIZE_OVERRIDE(new_size) theFlashParams.block_size = (new_size)
#define | SET_PAGESIZE_OVERRIDE(new_size) theFlashParams.offset_into_block = (new_size)

Variables

FlashParamsHolder theFlashParams
char | FlashBufferStart
char | FlashBufferEnd

Macro Definition Documentation

◆ LAYOUT_OVERRIDE_BUFFER

#define LAYOUT_OVERRIDE_BUFFER ((char*)theFlashParams.buffer)

Definition at line 7 of file flash_loader_extra.h.

◆ OVERRIDE_BUFSIZE

#define OVERRIDE_BUFSIZE 0x020000

Definition at line 4 of file flash_loader_extra.h.

◆ OVERRIDE_LAYOUT

#define OVERRIDE_LAYOUT 0x010000

Definition at line 3 of file flash_loader_extra.h.

◆ OVERRIDE_PAGESIZE

#define OVERRIDE_PAGESIZE 0x040000

Definition at line 5 of file flash_loader_extra.h.

◆ SET_BUFSIZE_OVERRIDE

#define SET_BUFSIZE_OVERRIDE ( new_size ) theFlashParams.block_size = (new_size)

Definition at line 8 of file flash_loader_extra.h.

◆ SET_PAGESIZE_OVERRIDE

#define SET_PAGESIZE_OVERRIDE ( new_size ) theFlashParams.offset_into_block = (new_size)

Definition at line 9 of file flash_loader_extra.h.

Variable Documentation

◆ FlashBufferEnd

char FlashBufferEnd
extern

◆ FlashBufferStart

char FlashBufferStart
extern

◆ theFlashParams

FlashParamsHolder theFlashParams
extern

Definition at line 32 of file flash_loader.c.

Referenced by Fl2FlashChecksumEntry(), Fl2FlashEraseWriteEntry(), Fl2FlashInitEntry(), Fl2FlashSignoffEntry(), and Fl2FlashWriteEntry().


AT32F435/437 Firmwary Library: flash_loader_extra.h Source File

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • iar_out
  • framework2
flash_loader_extra.h
Go to the documentation of this file.
1
2
3#define OVERRIDE_LAYOUT 0x010000
4#define OVERRIDE_BUFSIZE 0x020000
5#define OVERRIDE_PAGESIZE 0x040000
6
7#define LAYOUT_OVERRIDE_BUFFER ((char*)theFlashParams.buffer)
8#define SET_BUFSIZE_OVERRIDE(new_size) theFlashParams.block_size = (new_size)
9#define SET_PAGESIZE_OVERRIDE(new_size) theFlashParams.offset_into_block = (new_size)
10
11// parameter passing structure
12typedef struct {
13 uint32_t base_ptr;
14 uint32_t count;
15 uint32_t offset_into_block;
16 void *buffer;
17 uint32_t block_size;
18} FlashParamsHolder;
19
20typedef struct {
21 uint32_t start;
22 uint32_t length;
23} FlashEraseData;
24
25extern FlashParamsHolder theFlashParams;
26extern char FlashBufferStart;
27extern char FlashBufferEnd;
FlashBufferStart
char FlashBufferStart
theFlashParams
FlashParamsHolder theFlashParams
Definition: flash_loader.c:32
FlashBufferEnd
char FlashBufferEnd
FlashEraseData
Definition: flash_loader_extra.h:20
FlashEraseData::start
uint32_t start
Definition: flash_loader_extra.h:21
FlashEraseData::length
uint32_t length
Definition: flash_loader_extra.h:22
FlashParamsHolder
Definition: flash_loader_extra.h:12
FlashParamsHolder::block_size
uint32_t block_size
Definition: flash_loader_extra.h:17
FlashParamsHolder::count
uint32_t count
Definition: flash_loader_extra.h:14
FlashParamsHolder::base_ptr
uint32_t base_ptr
Definition: flash_loader_extra.h:13
FlashParamsHolder::offset_into_block
uint32_t offset_into_block
Definition: flash_loader_extra.h:15
FlashParamsHolder::buffer
void * buffer
Definition: flash_loader_extra.h:16


AT32F435/437 Firmwary Library: flash_loader_ram.c File Reference

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • iar_out
  • framework2
  • template
Functions
flash_loader_ram.c File Reference
#include "flash_loader.h"
#include "flash_loader_extra.h"

Go to the source code of this file.

Functions

void | strcopy (char *to, char *from)
uint32_t | FlashInit (void *base_of_flash, uint32_t image_size, uint32_t link_address, uint32_t flags, int argc, char const *argv[])
uint32_t | FlashWrite (void *block_start, uint32_t offset_into_block, uint32_t count, char const *buffer)
uint32_t | FlashErase (void *block_start, uint32_t block_size)
OPTIONAL_CHECKSUM uint32_t | FlashChecksum (void const *begin, uint32_t count)
OPTIONAL_SIGNOFF uint32_t | FlashSignoff (void)

Function Documentation

◆ FlashChecksum()

OPTIONAL_CHECKSUM uint32_t FlashChecksum | ( | void const * | begin,
 |  | uint32_t | count
 | ) |  |

Definition at line 47 of file flash_loader_ram.c.

Referenced by Fl2FlashChecksumEntry().

◆ FlashErase()

uint32_t FlashErase | ( | void * | block_start,
 |  | uint32_t | block_size
 | ) |  |

Definition at line 35 of file flash_loader_ram.c.

◆ FlashInit()

uint32_t FlashInit | ( | void * | base_of_flash,
 |  | uint32_t | image_size,
 |  | uint32_t | link_address,
 |  | uint32_t | flags,
 |  | int | argc,
 |  | char const * | argv[]
 | ) |  |

Definition at line 6 of file flash_loader_ram.c.

◆ FlashSignoff()

OPTIONAL_SIGNOFF uint32_t FlashSignoff ( void )

Definition at line 53 of file flash_loader_ram.c.

◆ FlashWrite()

uint32_t FlashWrite | ( | void * | block_start,
 |  | uint32_t | offset_into_block,
 |  | uint32_t | count,
 |  | char const * | buffer
 | ) |  |

Definition at line 22 of file flash_loader_ram.c.

◆ strcopy()

void strcopy | ( | char * | to,
 |  | char * | from
 | ) |  |

Definition at line 58 of file flash_loader_ram.c.


AT32F435/437 Firmwary Library: flash_loader_ram.c Source File

  • utilities
  • at32f435_437_qspi_algorithm_demo
  • iar_out
  • framework2
  • template
flash_loader_ram.c
Go to the documentation of this file.
1#include "flash_loader.h"
2#include "flash_loader_extra.h"
3
4void strcopy(char *to, char* from);
5
6uint32_t FlashInit(void *base_of_flash, uint32_t image_size,
7 uint32_t link_address, uint32_t flags,
8 int argc, char const *argv[])
9{
10// strcopy(LAYOUT_OVERRIDE_BUFFER,"2 0x100,7 0x200,7 0x1000");
11// SET_BUFSIZE_OVERRIDE(&FlashBufferEnd-&FlashBufferStart+1);
12// SET_PAGESIZE_OVERRIDE(128);
13// return OVERRIDE_LAYOUT | OVERRIDE_BUFEND | OVERRIDE_PAGESIZE;
14// if (flags & FLAG_ERASE_ONLY)
15// {
16// perform full erase
17// return RESULT_ERASE_DONE;
18// }
19 return RESULT_OK;
20}
21
22uint32_t FlashWrite(void *block_start,
23 uint32_t offset_into_block,
24 uint32_t count,
25 char const *buffer)
26{
27 char *to = (char*)block_start + offset_into_block;
28 while (count--)
29 {
30 *to++ = *buffer++;
31 }
32 return 0;
33}
34
35uint32_t FlashErase(void *block_start,
36 uint32_t block_size)
37{
38 char *p = (char*)block_start;
39 while (block_size--)
40 {
41 *p++ = 0;
42 }
43 return 0;
44}
45
46 OPTIONAL_CHECKSUM
47uint32_t FlashChecksum(void const *begin, uint32_t count)
48{
49 return Crc16((uint8_t const *)begin, count);
50}
51
52 OPTIONAL_SIGNOFF
53uint32_t FlashSignoff(void)
54{
55 return 0;
56}
57
58void strcopy(char *to, char* from)
59{
60 while (*to++ = *from++) ;
61}
62
63
64
Crc16
uint16_t Crc16(uint8_t const *p, uint32_t len)
Definition: flash_loader.c:113
flash_loader.h
OPTIONAL_SIGNOFF
#define OPTIONAL_SIGNOFF
Definition: flash_loader.h:70
RESULT_OK
#define RESULT_OK
Definition: flash_loader.h:5
OPTIONAL_CHECKSUM
#define OPTIONAL_CHECKSUM
Definition: flash_loader.h:69
flash_loader_extra.h
FlashChecksum
OPTIONAL_CHECKSUM uint32_t FlashChecksum(void const *begin, uint32_t count)
Definition: flash_loader_ram.c:47
strcopy
void strcopy(char *to, char *from)
Definition: flash_loader_ram.c:58
FlashWrite
uint32_t FlashWrite(void *block_start, uint32_t offset_into_block, uint32_t count, char const *buffer)
Definition: flash_loader_ram.c:22
FlashSignoff
OPTIONAL_SIGNOFF uint32_t FlashSignoff(void)
Definition: flash_loader_ram.c:53
FlashInit
uint32_t FlashInit(void *base_of_flash, uint32_t image_size, uint32_t link_address, uint32_t flags, int argc, char const *argv[])
Definition: flash_loader_ram.c:6
FlashErase
uint32_t FlashErase(void *block_start, uint32_t block_size)
Definition: flash_loader_ram.c:35
buffer
uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:43


AT32F435/437 Firmwary Library: fs.c File Reference

  • at_start_f437
  • examples
  • emac
  • http_server
  • src
Functions
fs.c File Reference
#include "lwip/apps/httpd_opts.h"
#include "lwip/def.h"
#include "lwip/apps/fs.h"
#include <string.h>
#include <HTTPD_FSDATA_FILE>

Go to the source code of this file.

Functions

err_t | fs_open (struct fs_file *file, const char *name)
void | fs_close (struct fs_file *file)
int | fs_bytes_left (struct fs_file *file)


AT32F435/437 Firmwary Library: fs.c Source File

  • at_start_f437
  • examples
  • emac
  • http_server
  • src
fs.c
Go to the documentation of this file.
1/*
2 * Copyright (c) 2001-2003 Swedish Institute of Computer Science.
3 * All rights reserved.
4 *
5 * Redistribution and use in source and binary forms, with or without modification,
6 * are permitted provided that the following conditions are met:
7 *
8 * 1. Redistributions of source code must retain the above copyright notice,
9 * this list of conditions and the following disclaimer.
10 * 2. Redistributions in binary form must reproduce the above copyright notice,
11 * this list of conditions and the following disclaimer in the documentation
12 * and/or other materials provided with the distribution.
13 * 3. The name of the author may not be used to endorse or promote products
14 * derived from this software without specific prior written permission.
15 *
16 * THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
17 * WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
18 * MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
19 * SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
20 * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT
21 * OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
22 * INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
23 * CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
24 * IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY
25 * OF SUCH DAMAGE.
26 *
27 * This file is part of the lwIP TCP/IP stack.
28 *
29 * Author: Adam Dunkels <adam@sics.se>
30 *
31 */
32
40#include "lwip/apps/httpd_opts.h"
41#include "lwip/def.h"
42#include "lwip/apps/fs.h"
43#include <string.h>
44
45
46#include HTTPD_FSDATA_FILE
50/*-----------------------------------------------------------------------------------*/
51
52#if LWIP_HTTPD_CUSTOM_FILES
53int fs_open_custom(struct fs_file *file, const char *name);
54void fs_close_custom(struct fs_file *file);
55#if LWIP_HTTPD_FS_ASYNC_READ
56uint8_t fs_canread_custom(struct fs_file *file);
57uint8_t fs_wait_read_custom(struct fs_file *file, fs_wait_cb callback_fn, void *callback_arg);
58int fs_read_async_custom(struct fs_file *file, char *buffer, int count, fs_wait_cb callback_fn, void *callback_arg);
59#else /* LWIP_HTTPD_FS_ASYNC_READ */
60int fs_read_custom(struct fs_file *file, char *buffer, int count);
61#endif /* LWIP_HTTPD_FS_ASYNC_READ */
62#endif /* LWIP_HTTPD_CUSTOM_FILES */
63
64/*-----------------------------------------------------------------------------------*/
65err_t
66 fs_open(struct fs_file *file, const char *name)
67{
68 const struct fsdata_file *f;
69
70 if ((file == NULL) || (name == NULL)) {
71 return ERR_ARG;
72 }
73
74#if LWIP_HTTPD_CUSTOM_FILES
75 if (fs_open_custom(file, name)) {
76 file->is_custom_file = 1;
77 return ERR_OK;
78 }
79 file->is_custom_file = 0;
80#endif /* LWIP_HTTPD_CUSTOM_FILES */
81
82 for (f = FS_ROOT; f != NULL; f = f->next) {
83 if (!strcmp(name, (const char *)f->name)) {
84 file->data = (const char *)f->data;
85 file->len = f->len;
86 file->index = f->len;
87 file->pextension = NULL;
88 file->flags = f->flags;
89#if HTTPD_PRECALCULATED_CHECKSUM
90 file->chksum_count = f->chksum_count;
91 file->chksum = f->chksum;
92#endif /* HTTPD_PRECALCULATED_CHECKSUM */
93#if LWIP_HTTPD_FILE_STATE
94 file->state = fs_state_init(file, name);
95#endif /* #if LWIP_HTTPD_FILE_STATE */
96 return ERR_OK;
97 }
98 }
99 /* file not found */
100 return ERR_VAL;
101}
102
103/*-----------------------------------------------------------------------------------*/
104void
105 fs_close(struct fs_file *file)
106{
107#if LWIP_HTTPD_CUSTOM_FILES
108 if (file->is_custom_file) {
109 fs_close_custom(file);
110 }
111#endif /* LWIP_HTTPD_CUSTOM_FILES */
112#if LWIP_HTTPD_FILE_STATE
113 fs_state_free(file, file->state);
114#endif /* #if LWIP_HTTPD_FILE_STATE */
115 LWIP_UNUSED_ARG(file);
116}
117/*-----------------------------------------------------------------------------------*/
118#if LWIP_HTTPD_DYNAMIC_FILE_READ
119#if LWIP_HTTPD_FS_ASYNC_READ
120int
121fs_read_async(struct fs_file *file, char *buffer, int count, fs_wait_cb callback_fn, void *callback_arg)
122#else /* LWIP_HTTPD_FS_ASYNC_READ */
123int
124fs_read(struct fs_file *file, char *buffer, int count)
125#endif /* LWIP_HTTPD_FS_ASYNC_READ */
126{
127 int read;
128 if (file->index == file->len) {
129 return FS_READ_EOF;
130 }
131#if LWIP_HTTPD_FS_ASYNC_READ
132 LWIP_UNUSED_ARG(callback_fn);
133 LWIP_UNUSED_ARG(callback_arg);
134#endif /* LWIP_HTTPD_FS_ASYNC_READ */
135#if LWIP_HTTPD_CUSTOM_FILES
136 if (file->is_custom_file) {
137#if LWIP_HTTPD_FS_ASYNC_READ
138 return fs_read_async_custom(file, buffer, count, callback_fn, callback_arg);
139#else /* LWIP_HTTPD_FS_ASYNC_READ */
140 return fs_read_custom(file, buffer, count);
141#endif /* LWIP_HTTPD_FS_ASYNC_READ */
142 }
143#endif /* LWIP_HTTPD_CUSTOM_FILES */
144
145 read = file->len - file->index;
146 if (read > count) {
147 read = count;
148 }
149
150 MEMCPY(buffer, (file->data + file->index), read);
151 file->index += read;
152
153 return (read);
154}
155#endif /* LWIP_HTTPD_DYNAMIC_FILE_READ */
156/*-----------------------------------------------------------------------------------*/
157#if LWIP_HTTPD_FS_ASYNC_READ
158int
159fs_is_file_ready(struct fs_file *file, fs_wait_cb callback_fn, void *callback_arg)
160{
161 if (file != NULL) {
162#if LWIP_HTTPD_FS_ASYNC_READ
163#if LWIP_HTTPD_CUSTOM_FILES
164 if (!fs_canread_custom(file)) {
165 if (fs_wait_read_custom(file, callback_fn, callback_arg)) {
166 return 0;
167 }
168 }
169#else /* LWIP_HTTPD_CUSTOM_FILES */
170 LWIP_UNUSED_ARG(callback_fn);
171 LWIP_UNUSED_ARG(callback_arg);
172#endif /* LWIP_HTTPD_CUSTOM_FILES */
173#endif /* LWIP_HTTPD_FS_ASYNC_READ */
174 }
175 return 1;
176}
177#endif /* LWIP_HTTPD_FS_ASYNC_READ */
178/*-----------------------------------------------------------------------------------*/
179int
180 fs_bytes_left(struct fs_file *file)
181{
182 return file->len - file->index;
183}
184
buffer
uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:43
file
FIL file
Definition: project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c:43
fs_bytes_left
int fs_bytes_left(struct fs_file *file)
Definition: fs.c:180
fs_open
err_t fs_open(struct fs_file *file, const char *name)
Definition: fs.c:66
fs_close
void fs_close(struct fs_file *file)
Definition: fs.c:105
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
FS_ROOT
#define FS_ROOT
Definition: project/at_start_f437/examples/emac/http_server/src/fsdata.c:514
fs_file
Definition: httpserver.h:41
fsdata_file
Definition: utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h:37
fsdata_file::next
const struct fsdata_file * next
Definition: utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h:38
fsdata_file::data
const char * data
Definition: utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h:40
fsdata_file::len
const int len
Definition: utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h:41
fsdata_file::name
const char * name
Definition: utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h:39
name
Definition: telnet.c:50


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- _ -

  • __ALIGNED() : project/at_start_f435/examples/edma/link_list_mode/src/main.c
  • __argc : flash_loader.c
  • __argv : flash_loader.c
  • __argvbuf : flash_loader.c
  • __AT32F435_437_LIBRARY_VERSION : at32f435_437.h
  • __AT32F435_437_LIBRARY_VERSION_MAJOR : at32f435_437.h
  • __AT32F435_437_LIBRARY_VERSION_MIDDLE : at32f435_437.h
  • __AT32F435_437_LIBRARY_VERSION_MINOR : at32f435_437.h
  • __AT32F435_437_LIBRARY_VERSION_RC : at32f435_437.h
  • __CM4_REV : at32f435_437.h
  • __FPU_PRESENT : at32f435_437.h
  • __MPU_PRESENT : at32f435_437.h
  • __NVIC_PRIO_BITS : at32f435_437.h
  • __Vendor_SysTickConfig : at32f435_437.h
  • _asciimap : cdc_keyboard_class.c, keyboard_class.c


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- a -

  • ACC : at32f435_437_acc.h
  • ACC_BASE : at32f435_437.h
  • acc_c2_value : project/at_start_f435/examples/acc/calibration/src/main.c, project/at_start_f437/examples/acc/calibration/src/main.c
  • ACC_CAL_HICKCAL : at32f435_437_acc.h
  • ACC_CAL_HICKTRIM : at32f435_437_acc.h
  • acc_calibration_mode_enable() : at32f435_437_acc.h, at32f435_437_acc.c
  • ACC_CALRDY_FLAG : at32f435_437_acc.h
  • ACC_CALRDYIEN_INT : at32f435_437_acc.h
  • ACC_EIEN_INT : at32f435_437_acc.h
  • acc_flag_clear() : at32f435_437_acc.h, at32f435_437_acc.c
  • acc_flag_get() : at32f435_437_acc.h, at32f435_437_acc.c
  • acc_hickcal_get() : at32f435_437_acc.h, at32f435_437_acc.c
  • acc_hicktrim_get() : at32f435_437_acc.h, at32f435_437_acc.c
  • acc_interrupt_enable() : at32f435_437_acc.h, at32f435_437_acc.c
  • ACC_IRQHandler() : project/at_start_f435/examples/acc/calibration/src/main.c
  • ACC_IRQn : at32f435_437.h
  • ACC_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • acc_read_c1() : at32f435_437_acc.h, at32f435_437_acc.c
  • acc_read_c2() : at32f435_437_acc.h, at32f435_437_acc.c
  • acc_read_c3() : at32f435_437_acc.h, at32f435_437_acc.c
  • ACC_RSLOST_FLAG : at32f435_437_acc.h
  • ACC_SOF_OTG1 : at32f435_437_acc.h
  • ACC_SOF_OTG2 : at32f435_437_acc.h
  • acc_sof_select() : at32f435_437_acc.h, at32f435_437_acc.c
  • acc_step_set() : at32f435_437_acc.h, at32f435_437_acc.c
  • ACC_TRIM : project/at_start_f435/examples/acc/calibration/src/main.c, project/at_start_f437/examples/acc/calibration/src/main.c
  • acc_write_c1() : at32f435_437_acc.h, at32f435_437_acc.c
  • acc_write_c2() : at32f435_437_acc.h, at32f435_437_acc.c
  • acc_write_c3() : at32f435_437_acc.h, at32f435_437_acc.c
  • ADC1 : at32f435_437_adc.h
  • ADC1_2_3_IRQHandler() : project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c, project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c
  • ADC1_2_3_IRQn : at32f435_437.h
  • ADC1_BASE : at32f435_437.h
  • adc1_ordinary_value : project/at_start_f435/examples/adc/current_vref_value_check/src/main.c, project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f435/examples/adc/vbat_monitor/src/main.c, project/at_start_f437/examples/adc/current_vref_value_check/src/main.c, project/at_start_f437/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f437/examples/adc/vbat_monitor/src/main.c
  • adc1_ordinary_valuetab : project/at_start_f435/examples/adc/conversion_abort/src/main.c, project/at_start_f435/examples/adc/edma_double_buffer/src/main.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f435/examples/adc/resolution_6bit/src/main.c, project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c, project/at_start_f435/examples/adc/voltage_monitoring/src/main.c, project/at_start_f437/examples/adc/conversion_abort/src/main.c, project/at_start_f437/examples/adc/edma_double_buffer/src/main.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f437/examples/adc/resolution_6bit/src/main.c, project/at_start_f437/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f437/examples/adc/use_polling_get_conversion_data/src/main.c, project/at_start_f437/examples/adc/voltage_monitoring/src/main.c
  • adc1_overflow_flag : project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/src/main.c, project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c, project/at_start_f435/examples/adc/current_vref_value_check/src/main.c, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/src/main.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/src/main.c, project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c, project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c, project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/vbat_monitor/src/main.c, project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f435/examples/adc/voltage_monitoring/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f437/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f437/examples/adc/conversion_abort/src/main.c, project/at_start_f437/examples/adc/current_vref_value_check/src/at32f435_437_int.c, project/at_start_f437/examples/adc/current_vref_value_check/src/main.c, project/at_start_f437/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f437/examples/adc/edma_double_buffer/src/main.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f437/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c, project/at_start_f437/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f437/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f437/examples/adc/resolution_6bit/src/main.c, project/at_start_f437/examples/adc/software_trigger_repeat/src/at32f435_437_int.c, project/at_start_f437/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f437/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c, project/at_start_f437/examples/adc/use_polling_get_conversion_data/src/main.c, project/at_start_f437/examples/adc/vbat_monitor/src/at32f435_437_int.c, project/at_start_f437/examples/adc/vbat_monitor/src/main.c, project/at_start_f437/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f437/examples/adc/voltage_monitoring/src/main.c
  • adc1_preempt_conversion_count : project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c
  • adc1_preempt_valuetab : project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c
  • ADC2 : at32f435_437_adc.h
  • ADC2_BASE : at32f435_437.h
  • adc2_overflow_flag : project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c
  • adc2_preempt_conversion_count : project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c
  • adc2_preempt_valuetab : project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c
  • ADC3 : at32f435_437_adc.h
  • ADC3_BASE : at32f435_437.h
  • adc3_overflow_flag : project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c
  • adc3_preempt_conversion_count : project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c
  • adc3_preempt_valuetab : project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c
  • adc_base_config() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_base_default_para_init() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_calibration_init() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_calibration_init_status_get() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_calibration_start() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_calibration_status_get() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_calibration_value_set() : at32f435_437_adc.h, at32f435_437_adc.c
  • ADC_CHANNEL_0 : at32f435_437_adc.h
  • ADC_CHANNEL_1 : at32f435_437_adc.h
  • ADC_CHANNEL_10 : at32f435_437_adc.h
  • ADC_CHANNEL_11 : at32f435_437_adc.h
  • ADC_CHANNEL_12 : at32f435_437_adc.h
  • ADC_CHANNEL_13 : at32f435_437_adc.h
  • ADC_CHANNEL_14 : at32f435_437_adc.h
  • ADC_CHANNEL_15 : at32f435_437_adc.h
  • ADC_CHANNEL_16 : at32f435_437_adc.h
  • ADC_CHANNEL_17 : at32f435_437_adc.h
  • ADC_CHANNEL_18 : at32f435_437_adc.h
  • ADC_CHANNEL_2 : at32f435_437_adc.h
  • ADC_CHANNEL_3 : at32f435_437_adc.h
  • ADC_CHANNEL_4 : at32f435_437_adc.h
  • ADC_CHANNEL_5 : at32f435_437_adc.h
  • ADC_CHANNEL_6 : at32f435_437_adc.h
  • ADC_CHANNEL_7 : at32f435_437_adc.h
  • ADC_CHANNEL_8 : at32f435_437_adc.h
  • ADC_CHANNEL_9 : at32f435_437_adc.h
  • adc_channel_select_type : at32f435_437_adc.h
  • adc_combine_mode_type : at32f435_437_adc.h
  • adc_combine_ordinary_conversion_data_get() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_common_config() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_common_default_para_init() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_common_dma_mode_type : at32f435_437_adc.h
  • ADC_COMMON_DMAMODE_1 : at32f435_437_adc.h
  • ADC_COMMON_DMAMODE_2 : at32f435_437_adc.h
  • ADC_COMMON_DMAMODE_3 : at32f435_437_adc.h
  • ADC_COMMON_DMAMODE_4 : at32f435_437_adc.h
  • ADC_COMMON_DMAMODE_5 : at32f435_437_adc.h
  • ADC_COMMON_DMAMODE_DISABLE : at32f435_437_adc.h
  • adc_config() : project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c, project/at_start_f435/examples/adc/conversion_abort/src/main.c, project/at_start_f435/examples/adc/current_vref_value_check/src/main.c, project/at_start_f435/examples/adc/edma_double_buffer/src/main.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f435/examples/adc/resolution_6bit/src/main.c, project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c, project/at_start_f435/examples/adc/vbat_monitor/src/main.c, project/at_start_f435/examples/adc/voltage_monitoring/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c, project/at_start_f437/examples/adc/conversion_abort/src/main.c, project/at_start_f437/examples/adc/current_vref_value_check/src/main.c, project/at_start_f437/examples/adc/edma_double_buffer/src/main.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f437/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f437/examples/adc/resolution_6bit/src/main.c, project/at_start_f437/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f437/examples/adc/use_polling_get_conversion_data/src/main.c, project/at_start_f437/examples/adc/vbat_monitor/src/main.c, project/at_start_f437/examples/adc/voltage_monitoring/src/main.c
  • adc_configuration() : project/at_start_f437/examples/emac/http_server/src/main.c
  • adc_conversion_stop() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_conversion_stop_status_get() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_data_align_type : at32f435_437_adc.h
  • adc_div_type : at32f435_437_adc.h
  • adc_dma_mode_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_dma_request_repeat_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_flag_clear() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_flag_get() : at32f435_437_adc.h, at32f435_437_adc.c
  • ADC_HCLK_DIV_10 : at32f435_437_adc.h
  • ADC_HCLK_DIV_11 : at32f435_437_adc.h
  • ADC_HCLK_DIV_12 : at32f435_437_adc.h
  • ADC_HCLK_DIV_13 : at32f435_437_adc.h
  • ADC_HCLK_DIV_14 : at32f435_437_adc.h
  • ADC_HCLK_DIV_15 : at32f435_437_adc.h
  • ADC_HCLK_DIV_16 : at32f435_437_adc.h
  • ADC_HCLK_DIV_17 : at32f435_437_adc.h
  • ADC_HCLK_DIV_2 : at32f435_437_adc.h
  • ADC_HCLK_DIV_3 : at32f435_437_adc.h
  • ADC_HCLK_DIV_4 : at32f435_437_adc.h
  • ADC_HCLK_DIV_5 : at32f435_437_adc.h
  • ADC_HCLK_DIV_6 : at32f435_437_adc.h
  • ADC_HCLK_DIV_7 : at32f435_437_adc.h
  • ADC_HCLK_DIV_8 : at32f435_437_adc.h
  • ADC_HCLK_DIV_9 : at32f435_437_adc.h
  • ADC_INDEPENDENT_MODE : at32f435_437_adc.h
  • adc_interrupt_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • ADC_LEFT_ALIGNMENT : at32f435_437_adc.h
  • ADC_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • adc_occe_each_conversion_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • ADC_OCCE_FLAG : at32f435_437_adc.h
  • ADC_OCCE_INT : at32f435_437_adc.h
  • ADC_OCCO_FLAG : at32f435_437_adc.h
  • ADC_OCCO_INT : at32f435_437_adc.h
  • ADC_OCCS_FLAG : at32f435_437_adc.h
  • adc_ordinary_channel_set() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_ordinary_conversion_data_get() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_ordinary_conversion_trigger_set() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_ordinary_oversample_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_ordinary_oversample_restart_set() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_ordinary_oversample_restart_type : at32f435_437_adc.h
  • adc_ordinary_oversample_trig_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_ordinary_part_count_set() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_ordinary_part_mode_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • ADC_ORDINARY_SHIFT_ONLY_ONESLAVE_MODE : at32f435_437_adc.h
  • ADC_ORDINARY_SHIFT_ONLY_TWOSLAVE_MODE : at32f435_437_adc.h
  • ADC_ORDINARY_SMLT_ONLY_ONESLAVE_MODE : at32f435_437_adc.h
  • ADC_ORDINARY_SMLT_ONLY_TWOSLAVE_MODE : at32f435_437_adc.h
  • ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_ONESLAVE_MODE : at32f435_437_adc.h
  • ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_TWOSLAVE_MODE : at32f435_437_adc.h
  • ADC_ORDINARY_SMLT_PREEMPT_SMLT_ONESLAVE_MODE : at32f435_437_adc.h
  • ADC_ORDINARY_SMLT_PREEMPT_SMLT_TWOSLAVE_MODE : at32f435_437_adc.h
  • adc_ordinary_software_trigger_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_ordinary_software_trigger_status_get() : at32f435_437_adc.h, at32f435_437_adc.c
  • ADC_ORDINARY_TRIG_EDGE_FALLING : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_EDGE_NONE : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_EDGE_RISING : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_EDGE_RISING_FALLING : at32f435_437_adc.h
  • adc_ordinary_trig_edge_type : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_EXINT11 : at32f435_437_adc.h
  • adc_ordinary_trig_select_type : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR1CH1 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR1CH2 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR1CH3 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR1TRGOUT : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR1TRGOUT2 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR20CH1 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR20CH2 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR20CH3 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR20TRGOUT : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR20TRGOUT2 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR2CH1 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR2CH2 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR2CH3 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR2CH4 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR2TRGOUT : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR3CH1 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR3CH4 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR3TRGOUT : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR4CH1 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR4CH4 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR4TRGOUT : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR5CH1 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR5CH2 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR5CH3 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR6TRGOUT : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR7TRGOUT : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR8CH1 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR8TRGOUT : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR8TRGOUT2 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_CONTINUE : at32f435_437_adc.h
  • ADC_OVERSAMPLE_RATIO_128 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_RATIO_16 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_RATIO_2 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_RATIO_256 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_RATIO_32 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_RATIO_4 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_RATIO_64 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_RATIO_8 : at32f435_437_adc.h
  • adc_oversample_ratio_shift_set() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_oversample_ratio_type : at32f435_437_adc.h
  • ADC_OVERSAMPLE_RESTART : at32f435_437_adc.h
  • ADC_OVERSAMPLE_SHIFT_0 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_SHIFT_1 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_SHIFT_2 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_SHIFT_3 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_SHIFT_4 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_SHIFT_5 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_SHIFT_6 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_SHIFT_7 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_SHIFT_8 : at32f435_437_adc.h
  • adc_oversample_shift_type : at32f435_437_adc.h
  • adc_page_name : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • ADC_PCCE_FLAG : at32f435_437_adc.h
  • ADC_PCCE_INT : at32f435_437_adc.h
  • ADC_PCCS_FLAG : at32f435_437_adc.h
  • adc_preempt_auto_mode_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • ADC_PREEMPT_CHANNEL_1 : at32f435_437_adc.h
  • ADC_PREEMPT_CHANNEL_2 : at32f435_437_adc.h
  • ADC_PREEMPT_CHANNEL_3 : at32f435_437_adc.h
  • ADC_PREEMPT_CHANNEL_4 : at32f435_437_adc.h
  • adc_preempt_channel_length_set() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_preempt_channel_set() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_preempt_channel_type : at32f435_437_adc.h
  • adc_preempt_conversion_data_get() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_preempt_conversion_trigger_set() : at32f435_437_adc.h, at32f435_437_adc.c
  • ADC_PREEMPT_INTERLTRIG_ONLY_ONESLAVE_MODE : at32f435_437_adc.h
  • ADC_PREEMPT_INTERLTRIG_ONLY_TWOSLAVE_MODE : at32f435_437_adc.h
  • adc_preempt_offset_value_set() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_preempt_oversample_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_preempt_part_mode_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • ADC_PREEMPT_SMLT_ONLY_ONESLAVE_MODE : at32f435_437_adc.h
  • ADC_PREEMPT_SMLT_ONLY_TWOSLAVE_MODE : at32f435_437_adc.h
  • adc_preempt_software_trigger_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_preempt_software_trigger_status_get() : at32f435_437_adc.h, at32f435_437_adc.c
  • ADC_PREEMPT_TRIG_EDGE_FALLING : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_EDGE_NONE : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_EDGE_RISING : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_EDGE_RISING_FALLING : at32f435_437_adc.h
  • adc_preempt_trig_edge_type : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_EXINT15 : at32f435_437_adc.h
  • adc_preempt_trig_select_type : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR1CH3 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR1CH4 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR1TRGOUT : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR1TRGOUT2 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR20CH2 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR20CH4 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR20TRGOUT : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR20TRGOUT2 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR2CH1 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR2TRGOUT : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR3CH1 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR3CH2 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR3CH3 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR3CH4 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR3TRGOUT : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR4CH1 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR4CH2 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR4CH3 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR4CH4 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR4TRGOUT : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR5CH4 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR5TRGOUT : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR6TRGOUT : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR7TRGOUT : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR8CH2 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR8CH3 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR8CH4 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR8TRGOUT : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR8TRGOUT2 : at32f435_437_adc.h
  • ADC_RDY_FLAG : at32f435_437_adc.h
  • adc_reset() : at32f435_437_adc.h, at32f435_437_adc.c
  • ADC_RESOLUTION_10B : at32f435_437_adc.h
  • ADC_RESOLUTION_12B : at32f435_437_adc.h
  • ADC_RESOLUTION_6B : at32f435_437_adc.h
  • ADC_RESOLUTION_8B : at32f435_437_adc.h
  • adc_resolution_set() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_resolution_type : at32f435_437_adc.h
  • ADC_RIGHT_ALIGNMENT : at32f435_437_adc.h
  • ADC_SAMPLETIME_12_5 : at32f435_437_adc.h
  • ADC_SAMPLETIME_247_5 : at32f435_437_adc.h
  • ADC_SAMPLETIME_24_5 : at32f435_437_adc.h
  • ADC_SAMPLETIME_2_5 : at32f435_437_adc.h
  • ADC_SAMPLETIME_47_5 : at32f435_437_adc.h
  • ADC_SAMPLETIME_640_5 : at32f435_437_adc.h
  • ADC_SAMPLETIME_6_5 : at32f435_437_adc.h
  • ADC_SAMPLETIME_92_5 : at32f435_437_adc.h
  • adc_sampletime_select_type : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_10CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_11CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_12CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_13CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_14CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_15CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_16CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_17CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_18CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_19CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_20CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_5CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_6CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_7CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_8CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_9CYCLES : at32f435_437_adc.h
  • adc_sampling_interval_type : at32f435_437_adc.h
  • ADC_TEMP_BASE : project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f437/examples/adc/internal_temperature_sensor/src/main.c
  • ADC_TEMP_SLOPE : project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f437/examples/adc/internal_temperature_sensor/src/main.c
  • ADC_VMONITOR_ALL_ORDINARY : at32f435_437_adc.h
  • ADC_VMONITOR_ALL_ORDINARY_PREEMPT : at32f435_437_adc.h
  • ADC_VMONITOR_ALL_PREEMPT : at32f435_437_adc.h
  • ADC_VMONITOR_NONE : at32f435_437_adc.h
  • ADC_VMONITOR_SINGLE_ORDINARY : at32f435_437_adc.h
  • ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT : at32f435_437_adc.h
  • ADC_VMONITOR_SINGLE_PREEMPT : at32f435_437_adc.h
  • ADC_VMOR_FLAG : at32f435_437_adc.h
  • ADC_VMOR_INT : at32f435_437_adc.h
  • adc_voltage_battery_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_voltage_monitor_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_voltage_monitor_single_channel_select() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_voltage_monitor_threshold_value_set() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_voltage_monitoring_type : at32f435_437_adc.h
  • ADC_VREF : project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f437/examples/adc/internal_temperature_sensor/src/main.c
  • ADCCOM : at32f435_437_adc.h
  • ADCCOM_BASE : at32f435_437.h
  • adccom_ordinary_valuetab : project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c
  • addr_1st_cycle : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • addr_2nd_cycle : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • addr_3rd_cycle : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • addr_4th_cycle : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • ADDR_AREA : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • ADDR_LENGTH : project/at_start_f437/examples/emac/dns_client/src/netconf.c, project/at_start_f437/examples/emac/http_server/src/netconf.c, project/at_start_f437/examples/emac/iperf/src/netconf.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_server/src/netconf.c, project/at_start_f437/examples/emac/telnet/src/netconf.c, project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • ADDR_SHIFT : at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c
  • ADDRESS_OUT_OF_RANGE : cdc_msc_class.h, msc_bot_scsi.h
  • AHBPERIPH1_BASE : at32f435_437.h
  • AHBPERIPH2_BASE : at32f435_437.h
  • AIRCR_VECTKEY_MASK : at32f435_437_misc.c
  • ALIGNED_TAIL : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, composite_cdc_msc/msc_bot_scsi.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc/msc_bot_scsi.c, msc_desc.c, printer_class.c, printer_desc.c, project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c, project/at_start_f437/examples/qspi/command_port_using_dma/src/main.c, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/main.c, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/main.c
  • APB1PERIPH_BASE : at32f435_437.h
  • APB2PERIPH_BASE : at32f435_437.h
  • APP_END_ADDR : at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h
  • APP_LAST_SECTOR_ADDR : at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h
  • app_load() : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h, at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c, at32f437_emac_iap_demo/source_code/bootloader/src/iap.c
  • app_loop() : app_led3_toggle/inc/hid_iap_user.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c
  • APP_START_ADDR : at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h, at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/iap.h, at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h, at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/iap.h
  • APP_START_SECTOR_ADDR : at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h
  • app_update_handle() : at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
  • arm_apply_guard_bits() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_calc_2pow() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_calc_guard_bits() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_clip_f32() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_compare_fixed_q15() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_compare_fixed_q31() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_fir_f32() : project_l0/inc/fir_filter.h, project_l1/inc/fir_filter.h
  • arm_fir_init_f32() : project_l0/inc/fir_filter.h, arm_fir_init_f32.c, project_l1/inc/fir_filter.h
  • arm_float_to_q12_20() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_float_to_q14() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_float_to_q28() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_float_to_q29() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_float_to_q30() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_provide_guard_bits_q15() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_provide_guard_bits_q31() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_provide_guard_bits_q7() : project_l0/src/math_helper.c, project_l1/src/math_helper.c
  • arm_snr_f32() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arp_timer : project/at_start_f437/examples/emac/dns_client/src/netconf.c, project/at_start_f437/examples/emac/http_server/src/netconf.c, project/at_start_f437/examples/emac/iperf/src/netconf.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_server/src/netconf.c, project/at_start_f437/examples/emac/telnet/src/netconf.c, project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • asc2_1206 : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/font.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/font.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/font.h
  • asc2_1608 : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/font.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/font.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/font.h
  • asc2_2412 : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/font.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/font.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/font.h
  • asc2_3216 : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/font.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/font.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/font.h
  • AT32_AUDIO_FREQ_16K : audio_desc.h, audio_hid_desc.h
  • AT32_AUDIO_FREQ_48K : audio_desc.h, audio_hid_desc.h
  • at32_board_init() : at32f435_437_board.c, at32f435_437_board.h
  • at32_button_init() : at32f435_437_board.c, at32f435_437_board.h
  • at32_button_press() : at32f435_437_board.c, at32f435_437_board.h
  • at32_button_state() : at32f435_437_board.c, at32f435_437_board.h
  • at32_led_init() : at32f435_437_board.c, at32f435_437_board.h
  • at32_led_off() : at32f435_437_board.c, at32f435_437_board.h
  • at32_led_on() : at32f435_437_board.c, at32f435_437_board.h
  • at32_led_toggle() : at32f435_437_board.c, at32f435_437_board.h
  • at32_mqtt_connection_cb() : mqtt_client.h, mqtt_client.c
  • at32_mqtt_incoming_data_cb() : mqtt_client.h, mqtt_client.c
  • at32_mqtt_incoming_publish_cb() : mqtt_client.h, mqtt_client.c
  • at32_mqtt_publish() : mqtt_client.h
  • at32_mqtt_request_cb() : mqtt_client.h, mqtt_client.c
  • at32_mqtt_subscribe() : mqtt_client.h, mqtt_client.c
  • atr_decode_status : project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • AUDIO_AC_DESCRIPTOR_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_EXTENSION_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_FEATURE_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_HEADER : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_INPUT_TERMINAL : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_MIXER_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_OUTPUT_TERMINAL : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_PROCESSING_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_SELECTOR_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AS_DESCRIPTOR_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_AS_FORMAT_SPECIFIC : audio_desc.h, audio_hid_desc.h
  • AUDIO_AS_FORMAT_TYPE : audio_desc.h, audio_hid_desc.h
  • AUDIO_AS_GENERAL : audio_desc.h, audio_hid_desc.h
  • AUDIO_BCD_NUM : audio_desc.h
  • AUDIO_BINTERVAL_TIME : audio_desc.h
  • AUDIO_BITW_16 : audio/audio_conf.h, audio_hid/audio_conf.h
  • audio_class_handler : audio_class.c, audio_class.h
  • audio_codec : at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_init() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_loop() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_mic_alt_setting() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_mic_get_data() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_modify_freq() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_set_mic_freq() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_set_mic_mute() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_set_mic_volume() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_set_spk_freq() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_set_spk_mute() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_set_spk_volume() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_spk_alt_setting() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_spk_feedback() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_spk_fifo_write() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • AUDIO_CS_CONFIGURATION : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_DEVICE : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_ENDPOINT : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_INTERFACE : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_STRING : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_DEFAULT_BITW : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_DEFAULT_FREQ : audio/audio_conf.h, audio_hid/audio_conf.h
  • audio_desc_handler : audio_desc.c, audio_desc.h
  • AUDIO_DESCRIPTOR_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_DESCRIPTOR_TYPE : audio_class.h, audio_hid_class.h
  • AUDIO_FEATURE_UNIT_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_FEEDBACK_MAXPACKET_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_FORMAT_TYPE_I : audio_desc.h, audio_hid_desc.h
  • AUDIO_FREQ_16K : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_FREQ_48K : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_FREQ_SET_CONTROL : audio_class.h, audio_hid_class.h
  • AUDIO_FU_BASS_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_CONTROL_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_MID_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_MUTE_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_TREBLE_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_VOLUME_CONTROL : audio_desc.h, audio_hid_desc.h
  • audio_get_interface() : audio_class.c, audio_hid_class.c
  • audio_hid_class_handler : audio_hid_class.c, audio_hid_class.h
  • audio_hid_class_send_report() : audio_hid_class.c, audio_hid_class.h
  • audio_hid_desc_handler : audio_hid_desc.c, audio_hid_desc.h
  • audio_hid_struct : audio_hid_class.c
  • audio_inisoincom_event() : audio_class.c, audio_hid_class.c
  • AUDIO_INPUT_TERMINAL_MICROPHONE : audio_desc.h, audio_hid_desc.h
  • AUDIO_INPUT_TERMINAL_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_INPUT_TERMINAL_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_INTERFACE_LEN : audio_desc.h, audio_hid_desc.h
  • AUDIO_INTERFACE_NUM : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_BITW : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_CHANEL_NUM : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_MIC_CHR : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_DEFAULT_BITW : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_MIC_FEATURE_UNIT_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_FREQ_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_IN_MAXPACKET_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_MIC_INPUT_TERMINAL_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_INTERFACE : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_INTERFACE_NUMBER : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_OUTPUT_TERMINAL_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_MUTE_CONTROL : audio_class.h, audio_hid_class.h
  • AUDIO_OUTPUT_TERMINAL_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_OUTPUT_TERMINAL_SPEAKER : audio_desc.h, audio_hid_desc.h
  • AUDIO_OUTPUT_TERMINAL_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_PROTOCOL_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_REMAIN_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_REQ_CONTROL_ENDPOINT : audio_class.h, audio_hid_class.h
  • AUDIO_REQ_CONTROL_INTERFACE : audio_class.h, audio_hid_class.h
  • AUDIO_REQ_CONTROL_MASK : audio_class.h, audio_hid_class.h
  • audio_req_get_cur() : audio_class.c, audio_hid_class.c
  • AUDIO_REQ_GET_CUR : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_GET_MAX : audio_desc.h, audio_hid_desc.h
  • audio_req_get_max() : audio_class.c, audio_hid_class.c
  • AUDIO_REQ_GET_MEM : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_GET_MIN : audio_desc.h, audio_hid_desc.h
  • audio_req_get_min() : audio_class.c, audio_hid_class.c
  • AUDIO_REQ_GET_RES : audio_desc.h, audio_hid_desc.h
  • audio_req_get_res() : audio_class.c, audio_hid_class.c
  • AUDIO_REQ_GET_STAT : audio_desc.h, audio_hid_desc.h
  • audio_req_set_cur() : audio_class.c, audio_hid_class.c
  • AUDIO_REQ_SET_CUR : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_MAX : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_MEM : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_MIN : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_RES : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQUEST_CODE_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • audio_set_interface() : audio_class.c, audio_hid_class.c
  • AUDIO_SPK_BITW : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_CHANEL_NUM : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SPK_CHR : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_DEFAULT_BITW : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SPK_FEATURE_UNIT_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_FREQ_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_INPUT_TERMINAL_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_INTERFACE : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_INTERFACE_NUMBER : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_OUT_MAXPACKET_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_SPK_OUTPUT_TERMINAL_ID : audio_desc.h, audio_hid_desc.h
  • audio_struct : audio_class.c
  • AUDIO_SUBCLASS_AUDIOCONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUBCLASS_AUDIOSTREAMING : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUBCLASS_MIDISTREMING : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUBCLASS_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUPPORT_FEEDBACK : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_FREQ : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_FREQ_16K : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_FREQ_48K : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_MAX_FREQ : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_MIC : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_SPK : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_TERMINAL_TYPE_STREAMING : audio_desc.h, audio_hid_desc.h
  • AUDIO_TERMINAL_TYPE_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_TERMINAL_TYPE_VENDOR : audio_desc.h, audio_hid_desc.h
  • AUDIO_VOLUME_CONTROL : audio_class.h, audio_hid_class.h
  • AUHID_BCD_NUM : audio_hid_desc.h
  • AUHID_HID_BCD_NUM : audio_hid_desc.h
  • AUHID_HID_BINTERVAL_TIME : audio_hid_desc.h


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- b -

  • back_err() : app_led3_toggle/inc/usart.h, app_led3_toggle/src/usart.c, app_led4_toggle/src/usart.c, at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h, at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
  • back_ok() : app_led3_toggle/inc/usart.h, app_led3_toggle/src/usart.c, app_led4_toggle/src/usart.c, at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h, at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
  • BANK1_NOR2_ADDR : at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c
  • BANK1_SRAM3_ADDR : at_start_f435/examples/xmc/psram/src/xmc_psram.c, at_start_f435/examples/xmc/sram/src/xmc_sram.c, at_start_f437/examples/xmc/psram/src/xmc_psram.c, at_start_f437/examples/xmc/sram/src/xmc_sram.c
  • Bank2_NAND_ADDR : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • Bank_NAND_ADDR : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • BLACK : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • BlankCheck() : FlashOS.h
  • BLOCK_SIZE : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c, fir_filter.c
  • BLOCKERASE_TIMEOUT : at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c
  • BLOCKS_NUMBER : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c
  • BLUE : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • bot_cbw_decode() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_allow_medium_removal() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_capacity() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_check_address() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_clear_feature() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_cmd_process() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_datain_handler() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_dataout_handler() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_format_capacity() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_init() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_inquiry() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_mode_sense10() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_mode_sense6() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_read10() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_request_sense() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_reset() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_send_csw() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_send_data() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_sense_code() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_stall() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_start_stop() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_test_unit() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_verify() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_write10() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • BOT_STATE_COMPLETE : usbh_msc_bot_scsi.h
  • BOT_STATE_DATA_IN : usbh_msc_bot_scsi.h
  • BOT_STATE_DATA_IN_WAIT : usbh_msc_bot_scsi.h
  • BOT_STATE_DATA_OUT : usbh_msc_bot_scsi.h
  • BOT_STATE_DATA_OUT_WAIT : usbh_msc_bot_scsi.h
  • BOT_STATE_ERROR_IN : usbh_msc_bot_scsi.h
  • BOT_STATE_ERROR_OUT : usbh_msc_bot_scsi.h
  • BOT_STATE_IDLE : usbh_msc_bot_scsi.h
  • BOT_STATE_RECV_CSW : usbh_msc_bot_scsi.h
  • BOT_STATE_RECV_CSW_WAIT : usbh_msc_bot_scsi.h
  • BOT_STATE_SEND_CBW : usbh_msc_bot_scsi.h
  • BOT_STATE_SEND_CBW_WAIT : usbh_msc_bot_scsi.h
  • bpr_addr_tab : project/at_start_f435/examples/ertc/bpr_domain/src/main.c, project/at_start_f435/examples/ertc/tamper/src/main.c, project/at_start_f437/examples/ertc/bpr_domain/src/main.c, project/at_start_f437/examples/ertc/tamper/src/main.c
  • bpr_reg_check() : project/at_start_f435/examples/ertc/bpr_domain/src/main.c, project/at_start_f435/examples/ertc/tamper/src/main.c
  • bpr_reg_write() : project/at_start_f435/examples/ertc/bpr_domain/src/main.c, project/at_start_f435/examples/ertc/tamper/src/main.c
  • BRED : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • BROWN : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • BRRED : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • BUF_SIZE : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f435/examples/spi/w25q_flash/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/spi/w25q_flash/src/main.c
  • buffer : project/at_start_f435/examples/cortex_m4/fpu/src/main.c, project/at_start_f437/examples/cortex_m4/fpu/src/main.c
  • buffer_cc1 : project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c
  • buffer_cc2 : project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c
  • buffer_compare() : project/at_start_f435/examples/dma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c, project/at_start_f435/examples/flash/flash_write_read/src/main.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f435/examples/spi/w25q_flash/src/main.c, project/at_start_f435/examples/usart/half_duplex/src/main.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c
  • buffer_compare_24bits() : project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c
  • buffer_read : project/at_start_f435/examples/flash/flash_write_read/src/main.c, project/at_start_f437/examples/flash/flash_write_read/src/main.c
  • buffer_rx : project/at_start_f435/examples/spi/w25q_flash/src/main.c, project/at_start_f437/examples/spi/w25q_flash/src/main.c
  • BUFFER_SIZE : project/at_start_f435/examples/crc/calculation/src/main.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/dma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/edma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/link_list_mode/src/main.c, project/at_start_f435/examples/edma/two_dimension_mode/src/main.c, project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f435/examples/usart/hw_flow_control/src/main.c, project/at_start_f435/examples/usart/receiver_mute/src/main.c, at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, project/at_start_f437/examples/crc/calculation/src/main.c, project/at_start_f437/examples/dma/dmamux_data_to_gpio/src/main.c, project/at_start_f437/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/dma/flash_to_sram/src/main.c, project/at_start_f437/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/edma/flash_to_sram/src/main.c, project/at_start_f437/examples/edma/link_list_mode/src/main.c, project/at_start_f437/examples/edma/two_dimension_mode/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f437/examples/usart/hw_flow_control/src/main.c, project/at_start_f437/examples/usart/receiver_mute/src/main.c, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • buffer_size : project/at_start_f435/examples/xmc/nor_flash/src/main.c, project/at_start_f435/examples/xmc/psram/src/main.c, project/at_start_f435/examples/xmc/sdram_basic/src/main.c, project/at_start_f435/examples/xmc/sdram_dma/src/main.c, project/at_start_f435/examples/xmc/sram/src/main.c, project/at_start_f437/examples/xmc/nor_flash/src/main.c, project/at_start_f437/examples/xmc/psram/src/main.c, project/at_start_f437/examples/xmc/sdram_basic/src/main.c, project/at_start_f437/examples/xmc/sdram_dma/src/main.c, project/at_start_f437/examples/xmc/sram/src/main.c
  • buffer_tx : project/at_start_f435/examples/spi/w25q_flash/src/main.c, project/at_start_f437/examples/spi/w25q_flash/src/main.c
  • buffer_write : project/at_start_f435/examples/flash/flash_write_read/src/main.c, project/at_start_f437/examples/flash/flash_write_read/src/main.c
  • BUFFERSIZE : project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c
  • BusFault_Handler() : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c, project/at_start_f435/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f435/examples/can/filter/src/at32f435_437_int.c, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c, project/at_start_f435/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c, project/at_start_f435/templates/inc/at32f435_437_int.h, project/at_start_f435/templates/src/at32f435_437_int.c, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f437/templates/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/src/at32f435_437_int.c, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_int.h, utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_int.c
  • BusFault_IRQn : at32f435_437.h
  • button_exint_init() : project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f435/examples/usb_device/keyboard/src/main.c, project/at_start_f435/examples/usb_device/mouse/src/main.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c, project/at_start_f435/examples/usb_host/hid_demo/src/main.c, project/at_start_f435/templates/src/main.c
  • button_isr() : project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c, project/at_start_f435/examples/usb_host/hid_demo/src/main.c, project/at_start_f435/templates/src/main.c
  • button_press : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f437/examples/usb_device/two_otg_device_demo/src/main.c
  • BUTTON_RELEASE : mouse_class.h
  • button_type : at32f435_437_board.h


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- c -

  • calculate_status : project/at_start_f435/examples/crm/pll_parameter_calculate/src/main.c, project/at_start_f437/examples/crm/pll_parameter_calculate/src/main.c
  • CAN1 : at32f435_437_can.h
  • CAN1_BASE : at32f435_437.h
  • CAN1_RX0_IRQHandler() : project/at_start_f435/examples/can/communication_mode/src/main.c, project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f435/examples/can/loopback_mode/src/main.c
  • CAN1_RX0_IRQn : at32f435_437.h
  • CAN1_RX1_IRQn : at32f435_437.h
  • CAN1_SE_IRQHandler() : project/at_start_f435/examples/can/communication_mode/src/main.c, project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f435/examples/can/loopback_mode/src/main.c
  • CAN1_SE_IRQn : at32f435_437.h
  • CAN1_TX_IRQn : at32f435_437.h
  • CAN2 : at32f435_437_can.h
  • CAN2_BASE : at32f435_437.h
  • CAN2_RX0_IRQn : at32f435_437.h
  • CAN2_RX1_IRQn : at32f435_437.h
  • CAN2_SE_IRQn : at32f435_437.h
  • CAN2_TX_IRQn : at32f435_437.h
  • can_base_init() : at32f435_437_can.h, at32f435_437_can.c
  • can_baudrate_default_para_init() : at32f435_437_can.h, at32f435_437_can.c
  • can_baudrate_set() : at32f435_437_can.h, at32f435_437_can.c
  • CAN_BOF_FLAG : at32f435_437_can.h
  • CAN_BOIEN_INT : at32f435_437_can.h
  • CAN_BTS1_10TQ : at32f435_437_can.h
  • CAN_BTS1_11TQ : at32f435_437_can.h
  • CAN_BTS1_12TQ : at32f435_437_can.h
  • CAN_BTS1_13TQ : at32f435_437_can.h
  • CAN_BTS1_14TQ : at32f435_437_can.h
  • CAN_BTS1_15TQ : at32f435_437_can.h
  • CAN_BTS1_16TQ : at32f435_437_can.h
  • CAN_BTS1_1TQ : at32f435_437_can.h
  • CAN_BTS1_2TQ : at32f435_437_can.h
  • CAN_BTS1_3TQ : at32f435_437_can.h
  • CAN_BTS1_4TQ : at32f435_437_can.h
  • CAN_BTS1_5TQ : at32f435_437_can.h
  • CAN_BTS1_6TQ : at32f435_437_can.h
  • CAN_BTS1_7TQ : at32f435_437_can.h
  • CAN_BTS1_8TQ : at32f435_437_can.h
  • CAN_BTS1_9TQ : at32f435_437_can.h
  • can_bts1_type : at32f435_437_can.h
  • CAN_BTS2_1TQ : at32f435_437_can.h
  • CAN_BTS2_2TQ : at32f435_437_can.h
  • CAN_BTS2_3TQ : at32f435_437_can.h
  • CAN_BTS2_4TQ : at32f435_437_can.h
  • CAN_BTS2_5TQ : at32f435_437_can.h
  • CAN_BTS2_6TQ : at32f435_437_can.h
  • CAN_BTS2_7TQ : at32f435_437_can.h
  • CAN_BTS2_8TQ : at32f435_437_can.h
  • can_bts2_type : at32f435_437_can.h
  • can_configuration() : project/at_start_f435/examples/can/communication_mode/src/main.c, project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f435/examples/can/loopback_mode/src/main.c, project/at_start_f437/examples/can/communication_mode/src/main.c, project/at_start_f437/examples/can/filter/src/main.c, project/at_start_f437/examples/can/loopback_mode/src/main.c
  • can_debug_transmission_prohibit() : at32f435_437_can.h, at32f435_437_can.c
  • can_default_para_init() : at32f435_437_can.h, at32f435_437_can.c
  • CAN_DISCARDING_FIRST_RECEIVED : at32f435_437_can.h
  • CAN_DISCARDING_LAST_RECEIVED : at32f435_437_can.h
  • can_doze_mode_enter() : at32f435_437_can.h, at32f435_437_can.c
  • can_doze_mode_exit() : at32f435_437_can.h, at32f435_437_can.c
  • CAN_EAF_FLAG : at32f435_437_can.h
  • CAN_EAIEN_INT : at32f435_437_can.h
  • CAN_EDZC_FLAG : at32f435_437_can.h
  • CAN_EDZIEN_INT : at32f435_437_can.h
  • CAN_ENTER_DOZE_FAILED : at32f435_437_can.h
  • can_enter_doze_status_type : at32f435_437_can.h
  • CAN_ENTER_DOZE_SUCCESSFUL : at32f435_437_can.h
  • CAN_EOIEN_INT : at32f435_437_can.h
  • CAN_EOIF_FLAG : at32f435_437_can.h
  • CAN_EPF_FLAG : at32f435_437_can.h
  • CAN_EPIEN_INT : at32f435_437_can.h
  • can_error_record_type : at32f435_437_can.h
  • can_error_type_record_get() : at32f435_437_can.h, at32f435_437_can.c
  • CAN_ERRORRECORD_ACKERR : at32f435_437_can.h
  • CAN_ERRORRECORD_BITDOMINANTERR : at32f435_437_can.h
  • CAN_ERRORRECORD_BITRECESSIVEERR : at32f435_437_can.h
  • CAN_ERRORRECORD_CRCERR : at32f435_437_can.h
  • CAN_ERRORRECORD_FORMERR : at32f435_437_can.h
  • CAN_ERRORRECORD_NOERR : at32f435_437_can.h
  • CAN_ERRORRECORD_SOFTWARESETERR : at32f435_437_can.h
  • CAN_ERRORRECORD_STUFFERR : at32f435_437_can.h
  • CAN_ETR_FLAG : at32f435_437_can.h
  • CAN_ETRIEN_INT : at32f435_437_can.h
  • CAN_FILTER_16BIT : at32f435_437_can.h
  • CAN_FILTER_32BIT : at32f435_437_can.h
  • can_filter_bit_width_type : at32f435_437_can.h
  • can_filter_default_para_init() : at32f435_437_can.h, at32f435_437_can.c
  • CAN_FILTER_FIFO0 : at32f435_437_can.h
  • CAN_FILTER_FIFO1 : at32f435_437_can.h
  • can_filter_fifo_type : at32f435_437_can.h
  • can_filter_init() : at32f435_437_can.h, at32f435_437_can.c
  • CAN_FILTER_MODE_ID_LIST : at32f435_437_can.h
  • CAN_FILTER_MODE_ID_MASK : at32f435_437_can.h
  • can_filter_mode_type : at32f435_437_can.h
  • can_flag_clear() : at32f435_437_can.h, at32f435_437_can.c
  • can_flag_get() : at32f435_437_can.h, at32f435_437_can.c
  • can_gpio_config() : project/at_start_f435/examples/can/communication_mode/src/main.c, project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f435/examples/can/loopback_mode/src/main.c, project/at_start_f437/examples/can/communication_mode/src/main.c, project/at_start_f437/examples/can/filter/src/main.c, project/at_start_f437/examples/can/loopback_mode/src/main.c
  • CAN_ID_EXTENDED : at32f435_437_can.h
  • CAN_ID_STANDARD : at32f435_437_can.h
  • can_identifier_type : at32f435_437_can.h
  • can_interrupt_enable() : at32f435_437_can.h, at32f435_437_can.c
  • can_message_receive() : at32f435_437_can.h, at32f435_437_can.c
  • can_message_transmit() : at32f435_437_can.h, at32f435_437_can.c
  • CAN_MODE_COMMUNICATE : at32f435_437_can.h
  • CAN_MODE_LISTENONLY : at32f435_437_can.h
  • CAN_MODE_LISTENONLY_LOOPBACK : at32f435_437_can.h
  • CAN_MODE_LOOPBACK : at32f435_437_can.h
  • can_mode_type : at32f435_437_can.h
  • CAN_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • can_msg_discarding_rule_type : at32f435_437_can.h
  • can_msg_sending_rule_type : at32f435_437_can.h
  • CAN_MSTS_EDZIF_VAL : at32f435_437_can.h
  • CAN_MSTS_EOIF_VAL : at32f435_437_can.h
  • CAN_MSTS_QDZIF_VAL : at32f435_437_can.h
  • can_operating_mode_set() : at32f435_437_can.h, at32f435_437_can.c
  • can_operating_mode_type : at32f435_437_can.h
  • CAN_OPERATINGMODE_COMMUNICATE : at32f435_437_can.h
  • CAN_OPERATINGMODE_DOZE : at32f435_437_can.h
  • CAN_OPERATINGMODE_FREEZE : at32f435_437_can.h
  • CAN_QDZIEN_INT : at32f435_437_can.h
  • CAN_QDZIF_FLAG : at32f435_437_can.h
  • CAN_QUIT_DOZE_FAILED : at32f435_437_can.h
  • can_quit_doze_status_type : at32f435_437_can.h
  • CAN_QUIT_DOZE_SUCCESSFUL : at32f435_437_can.h
  • can_receive_error_counter_get() : at32f435_437_can.h, at32f435_437_can.c
  • can_receive_fifo_release() : at32f435_437_can.h, at32f435_437_can.c
  • can_receive_message_pending_get() : at32f435_437_can.h, at32f435_437_can.c
  • can_reset() : at32f435_437_can.h, at32f435_437_can.c
  • CAN_RF0_RF0FF_VAL : at32f435_437_can.h
  • CAN_RF0_RF0OF_VAL : at32f435_437_can.h
  • CAN_RF0_RF0R_VAL : at32f435_437_can.h
  • CAN_RF0FF_FLAG : at32f435_437_can.h
  • CAN_RF0FIEN_INT : at32f435_437_can.h
  • CAN_RF0MIEN_INT : at32f435_437_can.h
  • CAN_RF0MN_FLAG : at32f435_437_can.h
  • CAN_RF0OF_FLAG : at32f435_437_can.h
  • CAN_RF0OIEN_INT : at32f435_437_can.h
  • CAN_RF1_RF1FF_VAL : at32f435_437_can.h
  • CAN_RF1_RF1OF_VAL : at32f435_437_can.h
  • CAN_RF1_RF1R_VAL : at32f435_437_can.h
  • CAN_RF1FF_FLAG : at32f435_437_can.h
  • CAN_RF1FIEN_INT : at32f435_437_can.h
  • CAN_RF1MIEN_INT : at32f435_437_can.h
  • CAN_RF1MN_FLAG : at32f435_437_can.h
  • CAN_RF1OF_FLAG : at32f435_437_can.h
  • CAN_RF1OIEN_INT : at32f435_437_can.h
  • CAN_RSAW_1TQ : at32f435_437_can.h
  • CAN_RSAW_2TQ : at32f435_437_can.h
  • CAN_RSAW_3TQ : at32f435_437_can.h
  • CAN_RSAW_4TQ : at32f435_437_can.h
  • can_rsaw_type : at32f435_437_can.h
  • CAN_RX_FIFO0 : at32f435_437_can.h
  • CAN_RX_FIFO1 : at32f435_437_can.h
  • can_rx_fifo_num_type : at32f435_437_can.h
  • CAN_SENDING_BY_ID : at32f435_437_can.h
  • CAN_SENDING_BY_REQUEST : at32f435_437_can.h
  • CAN_TCIEN_INT : at32f435_437_can.h
  • CAN_TFT_DATA : at32f435_437_can.h
  • CAN_TFT_REMOTE : at32f435_437_can.h
  • CAN_TM0TCF_FLAG : at32f435_437_can.h
  • CAN_TM1TCF_FLAG : at32f435_437_can.h
  • CAN_TM2TCF_FLAG : at32f435_437_can.h
  • CAN_TMEF_FLAG : at32f435_437_can.h
  • can_trans_frame_type : at32f435_437_can.h
  • can_transmit_cancel() : at32f435_437_can.h, at32f435_437_can.c
  • can_transmit_data() : project/at_start_f435/examples/can/communication_mode/src/main.c, project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f435/examples/can/loopback_mode/src/main.c, project/at_start_f437/examples/can/communication_mode/src/main.c, project/at_start_f437/examples/can/filter/src/main.c, project/at_start_f437/examples/can/loopback_mode/src/main.c
  • can_transmit_error_counter_get() : at32f435_437_can.h, at32f435_437_can.c
  • can_transmit_status_get() : at32f435_437_can.h, at32f435_437_can.c
  • can_transmit_status_type : at32f435_437_can.h
  • CAN_TSTS_TM0CT_VAL : at32f435_437_can.h
  • CAN_TSTS_TM0TCF_VAL : at32f435_437_can.h
  • CAN_TSTS_TM1CT_VAL : at32f435_437_can.h
  • CAN_TSTS_TM1TCF_VAL : at32f435_437_can.h
  • CAN_TSTS_TM2CT_VAL : at32f435_437_can.h
  • CAN_TSTS_TM2TCF_VAL : at32f435_437_can.h
  • can_ttc_mode_enable() : at32f435_437_can.h, at32f435_437_can.c
  • CAN_TX_MAILBOX0 : at32f435_437_can.h
  • CAN_TX_MAILBOX1 : at32f435_437_can.h
  • CAN_TX_MAILBOX2 : at32f435_437_can.h
  • can_tx_mailbox_num_type : at32f435_437_can.h
  • CAN_TX_STATUS_FAILED : at32f435_437_can.h
  • CAN_TX_STATUS_NO_EMPTY : at32f435_437_can.h
  • CAN_TX_STATUS_PENDING : at32f435_437_can.h
  • CAN_TX_STATUS_SUCCESSFUL : at32f435_437_can.h
  • capture : project/at_start_f435/examples/tmr/input_capture/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/input_capture/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c
  • capture_number : project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/lick_calibration/src/main.c, project/at_start_f437/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f437/examples/ertc/lick_calibration/src/main.c
  • capturenumber : project/at_start_f435/examples/tmr/input_capture/src/main.c, project/at_start_f437/examples/tmr/input_capture/src/main.c
  • card_inserted : project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c, project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/usart/smartcard/src/at32f435_437_int.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • card_protocol : project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • card_type : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c, at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • CBW_BMCBWFLAGS_DIR_IN : cdc_msc_class.h, msc_bot_scsi.h
  • CBW_BMCBWFLAGS_DIR_OUT : cdc_msc_class.h, msc_bot_scsi.h
  • CBW_CMD_LENGTH : cdc_msc_class.h, msc_bot_scsi.h
  • CBW_DCBWSIGNATURE : cdc_msc_class.h, msc_bot_scsi.h
  • ccr1_val : project/at_start_f435/examples/irtmr/irtmr_output/src/main.c, project/at_start_f435/examples/tmr/oc_high/src/main.c, project/at_start_f435/examples/tmr/oc_low/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c, project/at_start_f437/examples/irtmr/irtmr_output/src/main.c, project/at_start_f437/examples/tmr/oc_high/src/main.c, project/at_start_f437/examples/tmr/oc_low/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f437/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f437/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f437/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f437/examples/tmr/tmr2_32bit/src/main.c
  • ccr2_val : project/at_start_f435/examples/irtmr/irtmr_output/src/main.c, project/at_start_f435/examples/tmr/oc_high/src/main.c, project/at_start_f435/examples/tmr/oc_low/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c, project/at_start_f437/examples/irtmr/irtmr_output/src/main.c, project/at_start_f437/examples/tmr/oc_high/src/main.c, project/at_start_f437/examples/tmr/oc_low/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f437/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f437/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f437/examples/tmr/tmr2_32bit/src/main.c
  • ccr3_val : project/at_start_f435/examples/tmr/oc_high/src/main.c, project/at_start_f435/examples/tmr/oc_low/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c, project/at_start_f437/examples/tmr/oc_high/src/main.c, project/at_start_f437/examples/tmr/oc_low/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f437/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f437/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f437/examples/tmr/tmr2_32bit/src/main.c
  • ccr4_val : project/at_start_f435/examples/tmr/oc_high/src/main.c, project/at_start_f435/examples/tmr/oc_low/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c, project/at_start_f437/examples/tmr/oc_high/src/main.c, project/at_start_f437/examples/tmr/oc_low/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f437/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f437/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f437/examples/tmr/tmr2_32bit/src/main.c
  • CDC_BCD_NUM : cdc_desc.h, cdc_msc_desc.h
  • cdc_class_handler : cdc_class.c, cdc_class.h
  • cdc_class_setup_handler() : cdc_keyboard_class.c, cdc_msc_class.c
  • cdc_desc_handler : cdc_desc.c, cdc_desc.h
  • CDC_HID_BINTERVAL_TIME : cdc_desc.h, cdc_msc_desc.h
  • cdc_keyboard_class_handler : cdc_keyboard_class.c, cdc_keyboard_class.h
  • cdc_keyboard_desc_handler : cdc_keyboard_desc.c, cdc_keyboard_desc.h
  • cdc_msc_class_handler : cdc_msc_class.c, cdc_msc_class.h
  • cdc_msc_desc_handler : cdc_msc_desc.c, cdc_msc_desc.h
  • cdc_msc_struct : cdc_msc_class.c
  • cdc_struct : cdc_class.c
  • cdc_struct_init() : cdc_class.c, cdc_msc_class.c
  • channel1pulse : project/at_start_f435/examples/tmr/7_pwm_output/src/main.c, project/at_start_f435/examples/tmr/complementary_signals/src/main.c, project/at_start_f437/examples/tmr/7_pwm_output/src/main.c, project/at_start_f437/examples/tmr/complementary_signals/src/main.c
  • channel2pulse : project/at_start_f435/examples/tmr/7_pwm_output/src/main.c, project/at_start_f435/examples/tmr/complementary_signals/src/main.c, project/at_start_f437/examples/tmr/7_pwm_output/src/main.c, project/at_start_f437/examples/tmr/complementary_signals/src/main.c
  • channel3pulse : project/at_start_f435/examples/tmr/7_pwm_output/src/main.c, project/at_start_f435/examples/tmr/complementary_signals/src/main.c, project/at_start_f437/examples/tmr/7_pwm_output/src/main.c, project/at_start_f437/examples/tmr/complementary_signals/src/main.c
  • channel4pulse : project/at_start_f435/examples/tmr/7_pwm_output/src/main.c, project/at_start_f437/examples/tmr/7_pwm_output/src/main.c
  • check_card_programming() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • check_tcp_connect() : tcp_client.h, tcp_client.c
  • CHIPERASE_TIMEOUT : at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c
  • cid_table : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c, at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • class_audio_setup_handler() : audio_hid_class.c
  • class_clear_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_ept0_rx_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_ept0_tx_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_event_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_hid_setup_handler() : audio_hid_class.c
  • class_in_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_init_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_out_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_setup_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_sof_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • clkout_config() : project/at_start_f435/examples/crm/clock_failure_detection/src/main.c, project/at_start_f435/examples/crm/pll_parameter_calculate/src/main.c, project/at_start_f435/examples/crm/sysclk_switch/src/main.c, project/at_start_f437/examples/crm/clock_failure_detection/src/main.c, project/at_start_f437/examples/crm/sysclk_switch/src/main.c
  • clock_failure_detection_handler() : project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c, project/at_start_f435/examples/crm/clock_failure_detection/src/main.c, project/at_start_f437/examples/crm/clock_failure_detection/src/at32f435_437_int.c
  • cmd_addr_cnt : at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
  • CMD_AREA : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • CMD_CTR_APP : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • CMD_CTR_DONE : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • CMD_CTR_ERR : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • CMD_CTR_IDLE : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • CMD_CTR_INIT : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • cmd_ctr_step : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h, at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
  • cmd_ctr_step_type : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • CMD_DATA_ADDR : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • CMD_DATA_BUF : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • CMD_DATA_CHACK : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • cmd_data_cnt : at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
  • CMD_DATA_DONE : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • CMD_DATA_ERR : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • cmd_data_group_struct : at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
  • cmd_data_group_type_struct : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • CMD_DATA_IDLE : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • cmd_data_step : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h, at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
  • cmd_data_step_type : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • cmd_rdx : at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c, at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c
  • cmd_rdy : at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c, at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c
  • cmd_rst_ly68l6400_config() : at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c
  • cmd_rsten_ly68l6400_config() : at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c
  • CMD_STATE_SEND : usbh_msc_bot_scsi.h
  • CMD_STATE_WAIT : usbh_msc_bot_scsi.h
  • CODE_ADDR_AS_VOID_PTR : flash_loader.h, flash_config.h
  • CODE_REF : flash_loader.c
  • codec_i2s_init() : at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • codec_i2s_reset() : at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • COL_ADDRESS : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • command_error() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • command_handle() : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h, at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
  • command_rsp1_error() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • command_rsp2_error() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • command_rsp3_error() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • command_rsp4_error() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • command_rsp5_error() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • command_rsp6_error() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • command_rsp7_error() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • config_descriptor : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • config_flash_interrupt() : utilities/at32f435_437_slib_demo/project_l0/src/main.c, utilities/at32f435_437_slib_demo/project_l1/src/main.c
  • configASSERT : FreeRTOSConfig.h
  • configCPU_CLOCK_HZ : FreeRTOSConfig.h
  • configIDLE_SHOULD_YIELD : FreeRTOSConfig.h
  • configKERNEL_INTERRUPT_PRIORITY : FreeRTOSConfig.h
  • configLIBRARY_LOWEST_INTERRUPT_PRIORITY : FreeRTOSConfig.h
  • configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY : FreeRTOSConfig.h
  • configMAX_CO_ROUTINE_PRIORITIES : FreeRTOSConfig.h
  • configMAX_PRIORITIES : FreeRTOSConfig.h
  • configMAX_SYSCALL_INTERRUPT_PRIORITY : FreeRTOSConfig.h
  • configMAX_TASK_NAME_LEN : FreeRTOSConfig.h
  • configMINIMAL_STACK_SIZE : FreeRTOSConfig.h
  • configPRIO_BITS : FreeRTOSConfig.h
  • configSUPPORT_DYNAMIC_ALLOCATION : FreeRTOSConfig.h
  • configTICK_RATE_HZ : FreeRTOSConfig.h
  • configTOTAL_HEAP_SIZE : FreeRTOSConfig.h
  • configUSE_16_BIT_TICKS : FreeRTOSConfig.h
  • configUSE_CO_ROUTINES : FreeRTOSConfig.h
  • configUSE_IDLE_HOOK : FreeRTOSConfig.h
  • configUSE_PREEMPTION : FreeRTOSConfig.h
  • configUSE_TICK_HOOK : FreeRTOSConfig.h
  • confirm_state : at32f435_437.h
  • connect_flag : tcp_client.c
  • CONVERT_ENDIAN : hid_iap_class.h
  • convert_from_bytes_to_power_of_two() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • copy_buff() : at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • counter : project/at_start_f435/examples/debug/tmr1/src/main.c, project/at_start_f435/examples/edma/two_dimension_mode/src/main.c, project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/debug/tmr1/src/main.c, project/at_start_f437/examples/edma/two_dimension_mode/src/main.c, project/at_start_f437/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • COUNTOF : project/at_start_f435/examples/usart/half_duplex/src/main.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usart/half_duplex/src/main.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c
  • CRC : at32f435_437_crc.h
  • Crc16() : flash_loader.c, flash_loader.h
  • Crc16_helper() : flash_loader.c
  • crc1_value : project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c
  • crc2_value : project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c
  • CRC_BASE : at32f435_437.h
  • crc_block_calculate() : at32f435_437_crc.h, at32f435_437_crc.c
  • crc_cal() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • crc_common_data_set() : at32f435_437_crc.h, at32f435_437_crc.c
  • crc_common_date_get() : at32f435_437_crc.h, at32f435_437_crc.c
  • crc_data_get() : at32f435_437_crc.h, at32f435_437_crc.c
  • crc_data_reset() : at32f435_437_crc.h, at32f435_437_crc.c
  • crc_init_data_set() : at32f435_437_crc.h, at32f435_437_crc.c
  • CRC_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • crc_one_word_calculate() : at32f435_437_crc.h, at32f435_437_crc.c
  • CRC_REVERSE_INPUT_BY_BYTE : at32f435_437_crc.h
  • CRC_REVERSE_INPUT_BY_HALFWORD : at32f435_437_crc.h
  • CRC_REVERSE_INPUT_BY_WORD : at32f435_437_crc.h
  • crc_reverse_input_data_set() : at32f435_437_crc.h, at32f435_437_crc.c
  • CRC_REVERSE_INPUT_NO_AFFECTE : at32f435_437_crc.h
  • crc_reverse_input_type : at32f435_437_crc.h
  • CRC_REVERSE_OUTPUT_DATA : at32f435_437_crc.h
  • crc_reverse_output_data_set() : at32f435_437_crc.h, at32f435_437_crc.c
  • CRC_REVERSE_OUTPUT_NO_AFFECTE : at32f435_437_crc.h
  • crc_reverse_output_type : at32f435_437_crc.h
  • crc_value : project/at_start_f435/examples/crc/calculation/src/main.c, project/at_start_f437/examples/crc/calculation/src/main.c
  • CRLF : httpd.c
  • CRM : at32f435_437_crm.h
  • CRM_ACC_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_ACC_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_ACC_PERIPH_RESET : at32f435_437_crm.h
  • CRM_ADC1_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_ADC1_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_ADC2_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_ADC2_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_ADC3_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_ADC3_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_ADC_PERIPH_RESET : at32f435_437_crm.h
  • CRM_AHB_DIV_1 : at32f435_437_crm.h
  • CRM_AHB_DIV_128 : at32f435_437_crm.h
  • CRM_AHB_DIV_16 : at32f435_437_crm.h
  • CRM_AHB_DIV_2 : at32f435_437_crm.h
  • CRM_AHB_DIV_256 : at32f435_437_crm.h
  • CRM_AHB_DIV_4 : at32f435_437_crm.h
  • CRM_AHB_DIV_512 : at32f435_437_crm.h
  • CRM_AHB_DIV_64 : at32f435_437_crm.h
  • CRM_AHB_DIV_8 : at32f435_437_crm.h
  • crm_ahb_div_set() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_ahb_div_type : at32f435_437_crm.h
  • CRM_ALL_RESET_FLAG : at32f435_437_crm.h
  • CRM_APB1_DIV_1 : at32f435_437_crm.h
  • CRM_APB1_DIV_16 : at32f435_437_crm.h
  • CRM_APB1_DIV_2 : at32f435_437_crm.h
  • CRM_APB1_DIV_4 : at32f435_437_crm.h
  • CRM_APB1_DIV_8 : at32f435_437_crm.h
  • crm_apb1_div_set() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_apb1_div_type : at32f435_437_crm.h
  • CRM_APB2_DIV_1 : at32f435_437_crm.h
  • CRM_APB2_DIV_16 : at32f435_437_crm.h
  • CRM_APB2_DIV_2 : at32f435_437_crm.h
  • CRM_APB2_DIV_4 : at32f435_437_crm.h
  • CRM_APB2_DIV_8 : at32f435_437_crm.h
  • crm_apb2_div_set() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_apb2_div_type : at32f435_437_crm.h
  • CRM_AUTO_STEP_MODE_DISABLE : at32f435_437_crm.h
  • CRM_AUTO_STEP_MODE_ENABLE : at32f435_437_crm.h
  • crm_auto_step_mode_enable() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_auto_step_mode_type : at32f435_437_crm.h
  • CRM_BASE : at32f435_437.h
  • crm_battery_powered_domain_reset() : at32f435_437_crm.h, at32f435_437_crm.c
  • CRM_CAN1_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_CAN1_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_CAN1_PERIPH_RESET : at32f435_437_crm.h
  • CRM_CAN2_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_CAN2_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_CAN2_PERIPH_RESET : at32f435_437_crm.h
  • CRM_CLKOUT1_HEXT : at32f435_437_crm.h
  • CRM_CLKOUT1_HICK : at32f435_437_crm.h
  • CRM_CLKOUT1_LEXT : at32f435_437_crm.h
  • CRM_CLKOUT1_PLL : at32f435_437_crm.h
  • crm_clkout1_select_type : at32f435_437_crm.h
  • CRM_CLKOUT2_ADC : at32f435_437_crm.h
  • CRM_CLKOUT2_HEXT : at32f435_437_crm.h
  • CRM_CLKOUT2_HICK : at32f435_437_crm.h
  • CRM_CLKOUT2_LEXT : at32f435_437_crm.h
  • CRM_CLKOUT2_LICK : at32f435_437_crm.h
  • CRM_CLKOUT2_PLL : at32f435_437_crm.h
  • CRM_CLKOUT2_SCLK : at32f435_437_crm.h
  • crm_clkout2_select_type : at32f435_437_crm.h
  • CRM_CLKOUT2_USB : at32f435_437_crm.h
  • CRM_CLKOUT_DIV1_1 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV1_2 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV1_3 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV1_4 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV1_5 : at32f435_437_crm.h
  • crm_clkout_div1_type : at32f435_437_crm.h
  • CRM_CLKOUT_DIV2_1 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV2_128 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV2_16 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV2_2 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV2_256 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV2_4 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV2_512 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV2_64 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV2_8 : at32f435_437_crm.h
  • crm_clkout_div2_type : at32f435_437_crm.h
  • crm_clkout_div_set() : at32f435_437_crm.h, at32f435_437_crm.c
  • CRM_CLKOUT_INDEX_1 : at32f435_437_crm.h
  • CRM_CLKOUT_INDEX_2 : at32f435_437_crm.h
  • crm_clkout_index_type : at32f435_437_crm.h
  • crm_clkout_to_tmr10_enable() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_clock_failure_detection_enable() : at32f435_437_crm.h, at32f435_437_crm.c
  • CRM_CLOCK_FAILURE_INT : at32f435_437_crm.h
  • CRM_CLOCK_FAILURE_INT_FLAG : at32f435_437_crm.h
  • crm_clock_out1_set() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_clock_out2_set() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_clock_source_enable() : at32f435_437_crm.h, at32f435_437_crm.c
  • CRM_CLOCK_SOURCE_HEXT : at32f435_437_crm.h
  • CRM_CLOCK_SOURCE_HICK : at32f435_437_crm.h
  • CRM_CLOCK_SOURCE_LEXT : at32f435_437_crm.h
  • CRM_CLOCK_SOURCE_LICK : at32f435_437_crm.h
  • CRM_CLOCK_SOURCE_PLL : at32f435_437_crm.h
  • crm_clock_source_type : at32f435_437_crm.h
  • crm_clocks_freq_get() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_clocks_freq_struct : project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c, project/at_start_f435/examples/dac/two_dac_trianglewave/src/main.c, project/at_start_f435/examples/debug/tmr1/src/main.c, project/at_start_f435/examples/irtmr/irtmr_output/src/main.c, project/at_start_f435/examples/tmr/6_steps/src/main.c, project/at_start_f435/examples/tmr/7_pwm_output/src/main.c, project/at_start_f435/examples/tmr/cascade_synchro/src/main.c, project/at_start_f435/examples/tmr/complementary_signals/src/main.c, project/at_start_f435/examples/tmr/dma/src/main.c, project/at_start_f435/examples/tmr/dma_burst/src/main.c, project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f435/examples/tmr/external_clock/src/main.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f435/examples/tmr/hang_mode/src/main.c, project/at_start_f435/examples/tmr/input_capture/src/main.c, project/at_start_f435/examples/tmr/oc_high/src/main.c, project/at_start_f435/examples/tmr/oc_low/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f435/examples/tmr/one_cycle/src/main.c, project/at_start_f435/examples/tmr/parallel_synchro/src/main.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f435/examples/tmr/timer_base/src/main.c, project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/main.c, project/at_start_f437/examples/dac/one_dac_dma_escalator/src/main.c, project/at_start_f437/examples/dac/two_dac_trianglewave/src/main.c, project/at_start_f437/examples/debug/tmr1/src/main.c, project/at_start_f437/examples/irtmr/irtmr_output/src/main.c, project/at_start_f437/examples/tmr/6_steps/src/main.c, project/at_start_f437/examples/tmr/7_pwm_output/src/main.c, project/at_start_f437/examples/tmr/cascade_synchro/src/main.c, project/at_start_f437/examples/tmr/complementary_signals/src/main.c, project/at_start_f437/examples/tmr/dma/src/main.c, project/at_start_f437/examples/tmr/dma_burst/src/main.c, project/at_start_f437/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f437/examples/tmr/external_clock/src/main.c, project/at_start_f437/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f437/examples/tmr/hang_mode/src/main.c, project/at_start_f437/examples/tmr/input_capture/src/main.c, project/at_start_f437/examples/tmr/oc_high/src/main.c, project/at_start_f437/examples/tmr/oc_low/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f437/examples/tmr/one_cycle/src/main.c, project/at_start_f437/examples/tmr/parallel_synchro/src/main.c, project/at_start_f437/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f437/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f437/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f437/examples/tmr/timer_base/src/main.c, project/at_start_f437/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c
  • crm_configuration() : project/at_start_f435/examples/irtmr/irtmr_output/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f435/examples/tmr/one_cycle/src/main.c, project/at_start_f435/examples/tmr/parallel_synchro/src/main.c, project/at_start_f435/examples/tmr/pwm_input/src/main.c, project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c
  • CRM_CRC_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_CRC_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_CRC_PERIPH_RESET : at32f435_437_crm.h
  • CRM_DAC_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_DAC_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_DAC_PERIPH_RESET : at32f435_437_crm.h
  • CRM_DMA1_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_DMA1_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_DMA1_PERIPH_RESET : at32f435_437_crm.h
  • CRM_DMA2_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_DMA2_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_DMA2_PERIPH_RESET : at32f435_437_crm.h
  • CRM_DVP_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_DVP_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_DVP_PERIPH_RESET : at32f435_437_crm.h
  • CRM_EDMA_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_EDMA_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_EDMA_PERIPH_RESET : at32f435_437_crm.h
  • crm_emac_output_pulse_set() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_emac_output_pulse_type : at32f435_437_crm.h
  • CRM_EMAC_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_EMAC_PULSE_125MS : at32f435_437_crm.h
  • CRM_EMAC_PULSE_1SCLK : at32f435_437_crm.h
  • CRM_EMACPTP_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_EMACRX_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_EMACTX_PERIPH_LOWPOWER : at32f435_437_crm.h
  • crm_ertc_clock_enable() : at32f435_437_crm.h, at32f435_437_crm.c
  • CRM_ERTC_CLOCK_HEXT_DIV_10 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_11 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_12 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_13 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_14 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_15 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_16 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_17 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_18 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_19 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_2 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_20 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_21 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_22 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_23 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_24 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_25 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_26 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_27 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_28 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_29 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_3 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_30 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_31 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_4 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_5 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_6 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_7 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_8 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_9 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_LEXT : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_LICK : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_NOCLK : at32f435_437_crm.h
  • crm_ertc_clock_select() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_ertc_clock_type : at32f435_437_crm.h
  • crm_flag_clear() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_flag_get() : at32f435_437_crm.h, at32f435_437_crm.c
  • CRM_GPIOA_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_GPIOA_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_GPIOA_PERIPH_RESET : at32f435_437_crm.h
  • CRM_GPIOB_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_GPIOB_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_GPIOB_PERIPH_RESET : at32f435_437_crm.h
  • CRM_GPIOC_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_GPIOC_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_GPIOC_PERIPH_RESET : at32f435_437_crm.h
  • CRM_GPIOD_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_GPIOD_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_GPIOD_PERIPH_RESET : at32f435_437_crm.h
  • CRM_GPIOE_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_GPIOE_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_GPIOE_PERIPH_RESET : at32f435_437_crm.h
  • CRM_GPIOF_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_GPIOF_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_GPIOF_PERIPH_RESET : at32f435_437_crm.h
  • CRM_GPIOG_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_GPIOG_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_GPIOG_PERIPH_RESET : at32f435_437_crm.h
  • CRM_GPIOH_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_GPIOH_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_GPIOH_PERIPH_RESET : at32f435_437_crm.h
  • crm_hext_bypass() : at32f435_437_crm.h, at32f435_437_crm.c
  • CRM_HEXT_READY_INT_FLAG : at32f435_437_crm.h
  • CRM_HEXT_STABLE_FLAG : at32f435_437_crm.h
  • CRM_HEXT_STABLE_INT : at32f435_437_crm.h
  • crm_hext_stable_wait() : at32f435_437_crm.h, at32f435_437_crm.c
  • CRM_HICK48_DIV6 : at32f435_437_crm.h
  • CRM_HICK48_NODIV : at32f435_437_crm.h
  • crm_hick_clock_calibration_set() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_hick_clock_trimming_set() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_hick_div_6_type : at32f435_437_crm.h
  • crm_hick_divider_select() : at32f435_437_crm.h, at32f435_437_crm.c
  • CRM_HICK_READY_INT_FLAG : at32f435_437_crm.h
  • CRM_HICK_SCLK_48MHZ : at32f435_437_crm.h
  • CRM_HICK_SCLK_8MHZ : at32f435_437_crm.h
  • crm_hick_sclk_frequency_select() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_hick_sclk_frequency_type : at32f435_437_crm.h
  • CRM_HICK_STABLE_FLAG : at32f435_437_crm.h
  • CRM_HICK_STABLE_INT : at32f435_437_crm.h
  • CRM_I2C1_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_I2C1_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_I2C1_PERIPH_RESET : at32f435_437_crm.h
  • CRM_I2C2_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_I2C2_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_I2C2_PERIPH_RESET : at32f435_437_crm.h
  • CRM_I2C3_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_I2C3_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_I2C3_PERIPH_RESET : at32f435_437_crm.h
  • crm_interrupt_enable() : at32f435_437_crm.h, at32f435_437_crm.c
  • CRM_IRQn : at32f435_437.h
  • crm_lext_bypass() : at32f435_437_crm.h, at32f435_437_crm.c
  • CRM_LEXT_READY_INT_FLAG : at32f435_437_crm.h
  • CRM_LEXT_STABLE_FLAG : at32f435_437_crm.h
  • CRM_LEXT_STABLE_INT : at32f435_437_crm.h
  • CRM_LICK_READY_INT_FLAG : at32f435_437_crm.h
  • CRM_LICK_STABLE_FLAG : at32f435_437_crm.h
  • CRM_LICK_STABLE_INT : at32f435_437_crm.h
  • CRM_LOWPOWER_RESET_FLAG : at32f435_437_crm.h
  • CRM_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • CRM_NRST_RESET_FLAG : at32f435_437_crm.h
  • CRM_OTGFS1_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_OTGFS1_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_OTGFS1_PERIPH_RESET : at32f435_437_crm.h
  • CRM_OTGFS2_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_OTGFS2_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_OTGFS2_PERIPH_RESET : at32f435_437_crm.h
  • crm_periph_clock_enable() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_periph_clock_lowpower_type : at32f435_437_crm.h
  • crm_periph_clock_type : at32f435_437_crm.h
  • crm_periph_lowpower_mode_enable() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_periph_reset() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_periph_reset_type : at32f435_437_crm.h
  • crm_pll_clock_source_type : at32f435_437_crm.h
  • crm_pll_config() : at32f435_437_crm.h, at32f435_437_crm.c
  • CRM_PLL_FR_1 : at32f435_437_crm.h
  • CRM_PLL_FR_16 : at32f435_437_crm.h
  • CRM_PLL_FR_2 : at32f435_437_crm.h
  • CRM_PLL_FR_32 : at32f435_437_crm.h
  • CRM_PLL_FR_4 : at32f435_437_crm.h
  • CRM_PLL_FR_8 : at32f435_437_crm.h
  • crm_pll_fr_type : at32f435_437_crm.h
  • crm_pll_parameter_calculate() : at32f435_437_crm.h, at32f435_437_crm.c
  • CRM_PLL_READY_INT_FLAG : at32f435_437_crm.h
  • CRM_PLL_SOURCE_HEXT : at32f435_437_crm.h
  • CRM_PLL_SOURCE_HICK : at32f435_437_crm.h
  • CRM_PLL_STABLE_FLAG : at32f435_437_crm.h
  • CRM_PLL_STABLE_INT : at32f435_437_crm.h
  • CRM_POR_RESET_FLAG : at32f435_437_crm.h
  • CRM_PWC_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_PWC_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_PWC_PERIPH_RESET : at32f435_437_crm.h
  • CRM_QSPI1_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_QSPI1_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_QSPI1_PERIPH_RESET : at32f435_437_crm.h
  • CRM_QSPI2_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_QSPI2_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_QSPI2_PERIPH_RESET : at32f435_437_crm.h
  • CRM_REG : at32f435_437_crm.h
  • CRM_REG_BIT : at32f435_437_crm.h
  • crm_reset() : at32f435_437_crm.h, at32f435_437_crm.c
  • CRM_SCFG_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_SCFG_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_SCFG_PERIPH_RESET : at32f435_437_crm.h
  • CRM_SCLK_HEXT : at32f435_437_crm.h
  • CRM_SCLK_HICK : at32f435_437_crm.h
  • CRM_SCLK_PLL : at32f435_437_crm.h
  • crm_sclk_type : at32f435_437_crm.h
  • CRM_SDIO1_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_SDIO1_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_SDIO1_PERIPH_RESET : at32f435_437_crm.h
  • CRM_SDIO2_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_SDIO2_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_SDIO2_PERIPH_RESET : at32f435_437_crm.h
  • CRM_SPI1_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_SPI1_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_SPI1_PERIPH_RESET : at32f435_437_crm.h
  • CRM_SPI2_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_SPI2_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_SPI2_PERIPH_RESET : at32f435_437_crm.h
  • CRM_SPI3_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_SPI3_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_SPI3_PERIPH_RESET : at32f435_437_crm.h
  • CRM_SPI4_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_SPI4_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_SPI4_PERIPH_RESET : at32f435_437_crm.h
  • CRM_SW_RESET_FLAG : at32f435_437_crm.h
  • crm_sysclk_switch() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_sysclk_switch_status_get() : at32f435_437_crm.h, at32f435_437_crm.c
  • CRM_TMR10_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR10_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR10_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR11_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR11_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR11_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR12_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR12_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR12_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR13_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR13_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR13_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR14_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR14_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR14_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR1_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR1_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR1_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR20_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR20_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR20_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR2_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR2_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR2_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR3_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR3_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR3_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR4_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR4_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR4_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR5_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR5_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR5_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR6_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR6_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR6_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR7_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR7_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR7_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR8_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR8_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR8_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR9_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR9_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR9_PERIPH_RESET : at32f435_437_crm.h
  • CRM_UART4_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_UART4_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_UART4_PERIPH_RESET : at32f435_437_crm.h
  • CRM_UART5_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_UART5_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_UART5_PERIPH_RESET : at32f435_437_crm.h
  • CRM_UART7_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_UART7_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_UART7_PERIPH_RESET : at32f435_437_crm.h
  • CRM_UART8_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_UART8_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_UART8_PERIPH_RESET : at32f435_437_crm.h
  • CRM_USART1_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_USART1_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_USART1_PERIPH_RESET : at32f435_437_crm.h
  • CRM_USART2_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_USART2_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_USART2_PERIPH_RESET : at32f435_437_crm.h
  • CRM_USART3_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_USART3_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_USART3_PERIPH_RESET : at32f435_437_crm.h
  • CRM_USART6_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_USART6_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_USART6_PERIPH_RESET : at32f435_437_crm.h
  • crm_usb_clock_div_set() : at32f435_437_crm.h, at32f435_437_crm.c
  • CRM_USB_CLOCK_SOURCE_HICK : at32f435_437_crm.h
  • CRM_USB_CLOCK_SOURCE_PLL : at32f435_437_crm.h
  • crm_usb_clock_source_select() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_usb_clock_source_type : at32f435_437_crm.h
  • CRM_USB_DIV_1 : at32f435_437_crm.h
  • CRM_USB_DIV_1_5 : at32f435_437_crm.h
  • CRM_USB_DIV_2 : at32f435_437_crm.h
  • CRM_USB_DIV_2_5 : at32f435_437_crm.h
  • CRM_USB_DIV_3 : at32f435_437_crm.h
  • CRM_USB_DIV_3_5 : at32f435_437_crm.h
  • CRM_USB_DIV_4 : at32f435_437_crm.h
  • CRM_USB_DIV_4_5 : at32f435_437_crm.h
  • CRM_USB_DIV_5 : at32f435_437_crm.h
  • CRM_USB_DIV_5_5 : at32f435_437_crm.h
  • CRM_USB_DIV_6 : at32f435_437_crm.h
  • CRM_USB_DIV_6_5 : at32f435_437_crm.h
  • CRM_USB_DIV_7 : at32f435_437_crm.h
  • crm_usb_div_type : at32f435_437_crm.h
  • CRM_WDT_RESET_FLAG : at32f435_437_crm.h
  • CRM_WWDT_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_WWDT_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_WWDT_PERIPH_RESET : at32f435_437_crm.h
  • CRM_WWDT_RESET_FLAG : at32f435_437_crm.h
  • CRM_XMC_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_XMC_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_XMC_PERIPH_RESET : at32f435_437_crm.h
  • CRYSTAL_ON_PHY : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • csd_table : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c, at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • CSW_BCSWSTATUS_FAILED : cdc_msc_class.h, msc_bot_scsi.h
  • CSW_BCSWSTATUS_PASS : cdc_msc_class.h, msc_bot_scsi.h
  • CSW_BCSWSTATUS_PHASE_ERR : cdc_msc_class.h, msc_bot_scsi.h
  • CSW_CMD_LENGTH : cdc_msc_class.h, msc_bot_scsi.h
  • CSW_DCSWSIGNATURE : cdc_msc_class.h, msc_bot_scsi.h
  • CTRL_TIMEOUT : usbh_ctrl.c
  • CUSHID_BCD_NUM : custom_hid_desc.h
  • CUSHID_BINTERVAL_TIME : custom_hid_desc.h
  • custom_hid_class_handler : custom_hid_class.c, custom_hid_class.h
  • custom_hid_class_send_report() : custom_hid_class.c, custom_hid_class.h
  • custom_hid_desc_handler : custom_hid_desc.c, custom_hid_desc.h
  • custom_hid_struct : custom_hid_class.c
  • CUSTOM_HTTP_SERVER : httpd.c
  • custom_qspi_busy_check() : qspi_algorithm.c, FlashPrg.c
  • custom_qspi_chip_erase() : qspi_algorithm.c, FlashPrg.c
  • custom_qspi_rst() : qspi_algorithm.c, FlashPrg.c
  • custom_qspi_rsten() : qspi_algorithm.c, FlashPrg.c
  • custom_qspi_rstqpi() : qspi_algorithm.c, FlashPrg.c
  • custom_qspi_sector_erase() : qspi_algorithm.c, FlashPrg.c
  • custom_qspi_write_enable() : qspi_algorithm.c, FlashPrg.c
  • custom_qspi_xip_enable() : qspi_algorithm.c, FlashPrg.c
  • custom_xip_enable_config() : qspi_algorithm.c, FlashPrg.c
  • CYAN : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- d -

  • DAC : at32f435_437_dac.h
  • DAC1_12BIT_LEFT : at32f435_437_dac.h
  • DAC1_12BIT_RIGHT : at32f435_437_dac.h
  • DAC1_8BIT_RIGHT : at32f435_437_dac.h
  • dac1_aligned_data_type : at32f435_437_dac.h
  • DAC1_D1DMAUDRF : at32f435_437_dac.h
  • DAC1_SELECT : at32f435_437_dac.h
  • DAC2_12BIT_LEFT : at32f435_437_dac.h
  • DAC2_12BIT_RIGHT : at32f435_437_dac.h
  • DAC2_8BIT_RIGHT : at32f435_437_dac.h
  • dac2_aligned_data_type : at32f435_437_dac.h
  • DAC2_D2DMAUDRF : at32f435_437_dac.h
  • DAC2_SELECT : at32f435_437_dac.h
  • dac_1_data_set() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_2_data_set() : at32f435_437_dac.h, at32f435_437_dac.c
  • DAC_BASE : at32f435_437.h
  • dac_data_output_get() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_dma_enable() : at32f435_437_dac.h, at32f435_437_dac.c
  • DAC_DUAL_12BIT_LEFT : at32f435_437_dac.h
  • DAC_DUAL_12BIT_RIGHT : at32f435_437_dac.h
  • DAC_DUAL_8BIT_RIGHT : at32f435_437_dac.h
  • dac_dual_data_set() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_dual_data_type : at32f435_437_dac.h
  • dac_dual_software_trigger_generate() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_enable() : at32f435_437_dac.h, at32f435_437_dac.c
  • DAC_EXTERNAL_INTERRUPT_LINE_9 : at32f435_437_dac.h
  • DAC_LSFR_BIT0_AMPLITUDE_1 : at32f435_437_dac.h
  • DAC_LSFR_BIT10_AMPLITUDE_3 : at32f435_437_dac.h
  • DAC_LSFR_BIT20_AMPLITUDE_7 : at32f435_437_dac.h
  • DAC_LSFR_BIT30_AMPLITUDE_15 : at32f435_437_dac.h
  • DAC_LSFR_BIT40_AMPLITUDE_31 : at32f435_437_dac.h
  • DAC_LSFR_BIT50_AMPLITUDE_63 : at32f435_437_dac.h
  • DAC_LSFR_BIT60_AMPLITUDE_127 : at32f435_437_dac.h
  • DAC_LSFR_BIT70_AMPLITUDE_255 : at32f435_437_dac.h
  • DAC_LSFR_BIT80_AMPLITUDE_511 : at32f435_437_dac.h
  • DAC_LSFR_BIT90_AMPLITUDE_1023 : at32f435_437_dac.h
  • DAC_LSFR_BITA0_AMPLITUDE_2047 : at32f435_437_dac.h
  • DAC_LSFR_BITB0_AMPLITUDE_4095 : at32f435_437_dac.h
  • dac_mask_amplitude_select() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_mask_amplitude_type : at32f435_437_dac.h
  • DAC_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • dac_output_buffer_enable() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_reset() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_select_type : at32f435_437_dac.h
  • DAC_SOFTWARE_TRIGGER : at32f435_437_dac.h
  • dac_software_trigger_generate() : at32f435_437_dac.h, at32f435_437_dac.c
  • DAC_TMR2_TRGOUT_EVENT : at32f435_437_dac.h
  • DAC_TMR4_TRGOUT_EVENT : at32f435_437_dac.h
  • DAC_TMR5_TRGOUT_EVENT : at32f435_437_dac.h
  • DAC_TMR6_TRGOUT_EVENT : at32f435_437_dac.h
  • DAC_TMR7_TRGOUT_EVENT : at32f435_437_dac.h
  • DAC_TMR8_TRGOUT_EVENT : at32f435_437_dac.h
  • dac_trigger_enable() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_trigger_select() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_trigger_type : at32f435_437_dac.h
  • dac_udr_enable() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_udr_flag_clear() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_udr_flag_get() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_wave_generate() : at32f435_437_dac.h, at32f435_437_dac.c
  • DAC_WAVE_GENERATE_NOISE : at32f435_437_dac.h
  • DAC_WAVE_GENERATE_NONE : at32f435_437_dac.h
  • DAC_WAVE_GENERATE_TRIANGLE : at32f435_437_dac.h
  • dac_wave_type : at32f435_437_dac.h
  • DATA1_VAL : project/at_start_f435/examples/usart/receiver_mute/src/main.c, project/at_start_f437/examples/usart/receiver_mute/src/main.c
  • DATA2_VAL : project/at_start_f435/examples/usart/receiver_mute/src/main.c, project/at_start_f437/examples/usart/receiver_mute/src/main.c
  • DATA3_VAL : project/at_start_f435/examples/usart/receiver_mute/src/main.c, project/at_start_f437/examples/usart/receiver_mute/src/main.c
  • DATA4_VAL : project/at_start_f435/examples/usart/receiver_mute/src/main.c, project/at_start_f437/examples/usart/receiver_mute/src/main.c
  • data__404_html : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • data__img_sics_gif : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • DATA_AREA : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • data_AT32F437_html : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • data_AT32F437ADC_html : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • data_AT32F437LED_html : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • data_buffer : project/at_start_f435/examples/crc/calculation/src/main.c, project/at_start_f437/examples/crc/calculation/src/main.c
  • data_count : project/at_start_f435/examples/usart/half_duplex/src/main.c, project/at_start_f435/examples/usart/hw_flow_control/src/main.c, project/at_start_f437/examples/usart/half_duplex/src/main.c, project/at_start_f437/examples/usart/hw_flow_control/src/main.c
  • data_counter_end : project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/dma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/two_dimension_mode/src/main.c, project/at_start_f437/examples/dma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f437/examples/dma/flash_to_sram/src/main.c, project/at_start_f437/examples/edma/flash_to_sram/src/main.c, project/at_start_f437/examples/edma/two_dimension_mode/src/main.c
  • data_index_html : utilities/at32f437_emac_iap_demo/source_code/bootloader/src/fsdata.c
  • data_len : project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f437/examples/usb_device/virtual_comport/src/main.c
  • data_reset_html : utilities/at32f437_emac_iap_demo/source_code/bootloader/src/fsdata.c
  • data_take() : at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
  • data_upload_html : utilities/at32f437_emac_iap_demo/source_code/bootloader/src/fsdata.c
  • data_uploaddone_html : utilities/at32f437_emac_iap_demo/source_code/bootloader/src/fsdata.c
  • DCFG_PERFRINT_80 : at32f435_437_usb.h
  • DCFG_PERFRINT_85 : at32f435_437_usb.h
  • DCFG_PERFRINT_90 : at32f435_437_usb.h
  • DCFG_PERFRINT_95 : at32f435_437_usb.h
  • dcfg_perfrint_type : at32f435_437_usb.h
  • debug_apb1_periph_mode_set() : at32f435_437_debug.h, at32f435_437_debug.c
  • debug_apb2_periph_mode_set() : at32f435_437_debug.h, at32f435_437_debug.c
  • DEBUG_BASE : at32f435_437.h
  • DEBUG_CAN1_PAUSE : at32f435_437_debug.h
  • DEBUG_CAN2_PAUSE : at32f435_437_debug.h
  • DEBUG_DEEPSLEEP : at32f435_437_debug.h
  • debug_device_id_get() : at32f435_437_debug.h, at32f435_437_debug.c
  • DEBUG_ERTC_512_PAUSE : at32f435_437_debug.h
  • DEBUG_ERTC_PAUSE : at32f435_437_debug.h
  • DEBUG_I2C1_SMBUS_TIMEOUT : at32f435_437_debug.h
  • DEBUG_I2C2_SMBUS_TIMEOUT : at32f435_437_debug.h
  • DEBUG_I2C3_SMBUS_TIMEOUT : at32f435_437_debug.h
  • debug_low_power_mode_set() : at32f435_437_debug.h, at32f435_437_debug.c
  • DEBUG_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • DEBUG_SLEEP : at32f435_437_debug.h
  • DEBUG_STANDBY : at32f435_437_debug.h
  • DEBUG_TMR10_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR11_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR12_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR13_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR14_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR1_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR20_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR2_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR3_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR4_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR5_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR6_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR7_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR8_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR9_PAUSE : at32f435_437_debug.h
  • DEBUG_WDT_PAUSE : at32f435_437_debug.h
  • DEBUG_WWDT_PAUSE : at32f435_437_debug.h
  • DEBUGMCU : at32f435_437_debug.h
  • DebugMon_Handler() : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c, project/at_start_f435/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f435/examples/can/filter/src/at32f435_437_int.c, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c, project/at_start_f435/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c, project/at_start_f435/templates/inc/at32f435_437_int.h, project/at_start_f435/templates/src/at32f435_437_int.c, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f437/templates/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/src/at32f435_437_int.c, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_int.h, utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_int.c
  • DebugMonitor_IRQn : at32f435_437.h
  • DELAY : project/at_start_f435/examples/cortex_m4/systick_interrupt/src/main.c, project/at_start_f435/templates/src/main.c, project/at_start_f437/examples/cortex_m4/systick_interrupt/src/main.c, project/at_start_f437/examples/emac/dns_client/src/main.c, project/at_start_f437/examples/emac/http_server/src/main.c, project/at_start_f437/examples/emac/iperf/src/main.c, project/at_start_f437/examples/emac/mqtt_client/src/main.c, project/at_start_f437/examples/emac/tcp_client/src/main.c, project/at_start_f437/examples/emac/tcp_server/src/main.c, project/at_start_f437/examples/emac/telnet/src/main.c, project/at_start_f437/examples/emac/wake_on_lan/src/main.c, project/at_start_f437/templates/src/main.c
  • delay() : project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f435/examples/tmr/input_capture/src/main.c
  • delay_init() : at32f435_437_board.c, at32f435_437_board.h
  • delay_ms() : at32f435_437_board.c, at32f435_437_board.h
  • Delay_s() : tcp_client.c
  • delay_sec() : at32f435_437_board.c, at32f435_437_board.h
  • delay_us() : at32f435_437_board.c, at32f435_437_board.h
  • DEV_MMC : at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c, at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c
  • DEV_RAM : at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c, at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c
  • DEV_USB : at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c, at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c
  • device_descriptor : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • DEVICE_ID_ADDR1 : random.c
  • device_mode : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c, at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • disk_initialize() : at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c, at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c
  • disk_ioctl() : at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c, at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c
  • disk_read() : at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c, at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c
  • disk_status() : at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c, at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c
  • disk_write() : at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c, at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c
  • DM9162 : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • DMA1 : at32f435_437_dma.h
  • DMA1_BASE : at32f435_437.h
  • DMA1_CHANNEL1 : at32f435_437_dma.h
  • DMA1_CHANNEL1_BASE : at32f435_437.h
  • DMA1_Channel1_IRQHandler() : project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c
  • DMA1_Channel1_IRQn : at32f435_437.h
  • DMA1_CHANNEL2 : at32f435_437_dma.h
  • DMA1_CHANNEL2_BASE : at32f435_437.h
  • DMA1_Channel2_IRQHandler() : project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c
  • DMA1_Channel2_IRQn : at32f435_437.h
  • DMA1_CHANNEL3 : at32f435_437_dma.h
  • DMA1_CHANNEL3_BASE : at32f435_437.h
  • DMA1_Channel3_IRQHandler() : project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • DMA1_Channel3_IRQn : at32f435_437.h
  • DMA1_CHANNEL4 : at32f435_437_dma.h
  • DMA1_CHANNEL4_BASE : at32f435_437.h
  • DMA1_Channel4_IRQHandler() : project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • DMA1_Channel4_IRQn : at32f435_437.h
  • DMA1_CHANNEL5 : at32f435_437_dma.h
  • DMA1_CHANNEL5_BASE : at32f435_437.h
  • DMA1_Channel5_IRQn : at32f435_437.h
  • DMA1_CHANNEL6 : at32f435_437_dma.h
  • DMA1_CHANNEL6_BASE : at32f435_437.h
  • DMA1_Channel6_IRQn : at32f435_437.h
  • DMA1_CHANNEL7 : at32f435_437_dma.h
  • DMA1_CHANNEL7_BASE : at32f435_437.h
  • DMA1_Channel7_IRQn : at32f435_437.h
  • DMA1_DTERR1_FLAG : at32f435_437_dma.h
  • DMA1_DTERR2_FLAG : at32f435_437_dma.h
  • DMA1_DTERR3_FLAG : at32f435_437_dma.h
  • DMA1_DTERR4_FLAG : at32f435_437_dma.h
  • DMA1_DTERR5_FLAG : at32f435_437_dma.h
  • DMA1_DTERR6_FLAG : at32f435_437_dma.h
  • DMA1_DTERR7_FLAG : at32f435_437_dma.h
  • DMA1_FDT1_FLAG : at32f435_437_dma.h
  • DMA1_FDT2_FLAG : at32f435_437_dma.h
  • DMA1_FDT3_FLAG : at32f435_437_dma.h
  • DMA1_FDT4_FLAG : at32f435_437_dma.h
  • DMA1_FDT5_FLAG : at32f435_437_dma.h
  • DMA1_FDT6_FLAG : at32f435_437_dma.h
  • DMA1_FDT7_FLAG : at32f435_437_dma.h
  • DMA1_GL1_FLAG : at32f435_437_dma.h
  • DMA1_GL2_FLAG : at32f435_437_dma.h
  • DMA1_GL3_FLAG : at32f435_437_dma.h
  • DMA1_GL4_FLAG : at32f435_437_dma.h
  • DMA1_GL5_FLAG : at32f435_437_dma.h
  • DMA1_GL6_FLAG : at32f435_437_dma.h
  • DMA1_GL7_FLAG : at32f435_437_dma.h
  • DMA1_HDT1_FLAG : at32f435_437_dma.h
  • DMA1_HDT2_FLAG : at32f435_437_dma.h
  • DMA1_HDT3_FLAG : at32f435_437_dma.h
  • DMA1_HDT4_FLAG : at32f435_437_dma.h
  • DMA1_HDT5_FLAG : at32f435_437_dma.h
  • DMA1_HDT6_FLAG : at32f435_437_dma.h
  • DMA1_HDT7_FLAG : at32f435_437_dma.h
  • dma1_trans_complete_flag : project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c
  • DMA1MUX_BASE : at32f435_437.h
  • DMA1MUX_CHANNEL1 : at32f435_437_dma.h
  • DMA1MUX_CHANNEL1_BASE : at32f435_437.h
  • DMA1MUX_CHANNEL2 : at32f435_437_dma.h
  • DMA1MUX_CHANNEL2_BASE : at32f435_437.h
  • DMA1MUX_CHANNEL3 : at32f435_437_dma.h
  • DMA1MUX_CHANNEL3_BASE : at32f435_437.h
  • DMA1MUX_CHANNEL4 : at32f435_437_dma.h
  • DMA1MUX_CHANNEL4_BASE : at32f435_437.h
  • DMA1MUX_CHANNEL5 : at32f435_437_dma.h
  • DMA1MUX_CHANNEL5_BASE : at32f435_437.h
  • DMA1MUX_CHANNEL6 : at32f435_437_dma.h
  • DMA1MUX_CHANNEL6_BASE : at32f435_437.h
  • DMA1MUX_CHANNEL7 : at32f435_437_dma.h
  • DMA1MUX_CHANNEL7_BASE : at32f435_437.h
  • DMA1MUX_GENERATOR1 : at32f435_437_dma.h
  • DMA1MUX_GENERATOR1_BASE : at32f435_437.h
  • DMA1MUX_GENERATOR2 : at32f435_437_dma.h
  • DMA1MUX_GENERATOR2_BASE : at32f435_437.h
  • DMA1MUX_GENERATOR3 : at32f435_437_dma.h
  • DMA1MUX_GENERATOR3_BASE : at32f435_437.h
  • DMA1MUX_GENERATOR4 : at32f435_437_dma.h
  • DMA1MUX_GENERATOR4_BASE : at32f435_437.h
  • DMA2 : at32f435_437_dma.h
  • DMA2_BASE : at32f435_437.h
  • DMA2_CHANNEL1 : at32f435_437_dma.h
  • DMA2_CHANNEL1_BASE : at32f435_437.h
  • DMA2_Channel1_IRQHandler() : project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c
  • DMA2_Channel1_IRQn : at32f435_437.h
  • DMA2_CHANNEL2 : at32f435_437_dma.h
  • DMA2_CHANNEL2_BASE : at32f435_437.h
  • DMA2_Channel2_IRQn : at32f435_437.h
  • DMA2_CHANNEL3 : at32f435_437_dma.h
  • DMA2_CHANNEL3_BASE : at32f435_437.h
  • DMA2_Channel3_IRQn : at32f435_437.h
  • DMA2_CHANNEL4 : at32f435_437_dma.h
  • DMA2_CHANNEL4_BASE : at32f435_437.h
  • DMA2_Channel4_IRQHandler() : project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c
  • DMA2_Channel4_IRQn : at32f435_437.h
  • DMA2_CHANNEL5 : at32f435_437_dma.h
  • DMA2_CHANNEL5_BASE : at32f435_437.h
  • DMA2_Channel5_IRQn : at32f435_437.h
  • DMA2_CHANNEL6 : at32f435_437_dma.h
  • DMA2_CHANNEL6_BASE : at32f435_437.h
  • DMA2_Channel6_IRQn : at32f435_437.h
  • DMA2_CHANNEL7 : at32f435_437_dma.h
  • DMA2_CHANNEL7_BASE : at32f435_437.h
  • DMA2_Channel7_IRQn : at32f435_437.h
  • DMA2_DTERR1_FLAG : at32f435_437_dma.h
  • DMA2_DTERR2_FLAG : at32f435_437_dma.h
  • DMA2_DTERR3_FLAG : at32f435_437_dma.h
  • DMA2_DTERR4_FLAG : at32f435_437_dma.h
  • DMA2_DTERR5_FLAG : at32f435_437_dma.h
  • DMA2_DTERR6_FLAG : at32f435_437_dma.h
  • DMA2_DTERR7_FLAG : at32f435_437_dma.h
  • DMA2_FDT1_FLAG : at32f435_437_dma.h
  • DMA2_FDT2_FLAG : at32f435_437_dma.h
  • DMA2_FDT3_FLAG : at32f435_437_dma.h
  • DMA2_FDT4_FLAG : at32f435_437_dma.h
  • DMA2_FDT5_FLAG : at32f435_437_dma.h
  • DMA2_FDT6_FLAG : at32f435_437_dma.h
  • DMA2_FDT7_FLAG : at32f435_437_dma.h
  • DMA2_GL1_FLAG : at32f435_437_dma.h
  • DMA2_GL2_FLAG : at32f435_437_dma.h
  • DMA2_GL3_FLAG : at32f435_437_dma.h
  • DMA2_GL4_FLAG : at32f435_437_dma.h
  • DMA2_GL5_FLAG : at32f435_437_dma.h
  • DMA2_GL6_FLAG : at32f435_437_dma.h
  • DMA2_GL7_FLAG : at32f435_437_dma.h
  • DMA2_HDT1_FLAG : at32f435_437_dma.h
  • DMA2_HDT2_FLAG : at32f435_437_dma.h
  • DMA2_HDT3_FLAG : at32f435_437_dma.h
  • DMA2_HDT4_FLAG : at32f435_437_dma.h
  • DMA2_HDT5_FLAG : at32f435_437_dma.h
  • DMA2_HDT6_FLAG : at32f435_437_dma.h
  • DMA2_HDT7_FLAG : at32f435_437_dma.h
  • DMA2MUX_BASE : at32f435_437.h
  • DMA2MUX_CHANNEL1 : at32f435_437_dma.h
  • DMA2MUX_CHANNEL1_BASE : at32f435_437.h
  • DMA2MUX_CHANNEL2 : at32f435_437_dma.h
  • DMA2MUX_CHANNEL2_BASE : at32f435_437.h
  • DMA2MUX_CHANNEL3 : at32f435_437_dma.h
  • DMA2MUX_CHANNEL3_BASE : at32f435_437.h
  • DMA2MUX_CHANNEL4 : at32f435_437_dma.h
  • DMA2MUX_CHANNEL4_BASE : at32f435_437.h
  • DMA2MUX_CHANNEL5 : at32f435_437_dma.h
  • DMA2MUX_CHANNEL5_BASE : at32f435_437.h
  • DMA2MUX_CHANNEL6 : at32f435_437_dma.h
  • DMA2MUX_CHANNEL6_BASE : at32f435_437.h
  • DMA2MUX_CHANNEL7 : at32f435_437_dma.h
  • DMA2MUX_CHANNEL7_BASE : at32f435_437.h
  • DMA2MUX_GENERATOR1 : at32f435_437_dma.h
  • DMA2MUX_GENERATOR1_BASE : at32f435_437.h
  • DMA2MUX_GENERATOR2 : at32f435_437_dma.h
  • DMA2MUX_GENERATOR2_BASE : at32f435_437.h
  • DMA2MUX_GENERATOR3 : at32f435_437_dma.h
  • DMA2MUX_GENERATOR3_BASE : at32f435_437.h
  • DMA2MUX_GENERATOR4 : at32f435_437_dma.h
  • DMA2MUX_GENERATOR4_BASE : at32f435_437.h
  • DMA_BUFFER_SIZE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • dma_channel_enable() : at32f435_437_dma.h, at32f435_437_dma.c
  • dma_config() : project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f435/examples/adc/conversion_abort/src/main.c, project/at_start_f435/examples/adc/current_vref_value_check/src/main.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f435/examples/adc/resolution_6bit/src/main.c, project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f435/examples/adc/vbat_monitor/src/main.c, project/at_start_f435/examples/adc/voltage_monitoring/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f437/examples/adc/conversion_abort/src/main.c, project/at_start_f437/examples/adc/current_vref_value_check/src/main.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f437/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f437/examples/adc/resolution_6bit/src/main.c, project/at_start_f437/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f437/examples/adc/vbat_monitor/src/main.c, project/at_start_f437/examples/adc/voltage_monitoring/src/main.c
  • dma_configuration() : project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c
  • dma_data_number_get() : at32f435_437_dma.h, at32f435_437_dma.c
  • dma_data_number_set() : at32f435_437_dma.h, at32f435_437_dma.c
  • dma_default_para_init() : at32f435_437_dma.h, at32f435_437_dma.c
  • DMA_DIR_MEMORY_TO_MEMORY : at32f435_437_dma.h
  • DMA_DIR_MEMORY_TO_PERIPHERAL : at32f435_437_dma.h
  • DMA_DIR_PERIPHERAL_TO_MEMORY : at32f435_437_dma.h
  • dma_dir_type : at32f435_437_dma.h
  • DMA_DTERR_INT : at32f435_437_dma.h
  • DMA_FDT_INT : at32f435_437_dma.h
  • dma_flag_clear() : at32f435_437_dma.h, at32f435_437_dma.c
  • dma_flag_get() : at32f435_437_dma.h, at32f435_437_dma.c
  • dma_flexible_config() : at32f435_437_dma.h, at32f435_437_dma.c
  • DMA_GET_HT_FLAG : i2c_application.c
  • DMA_GET_REQUEST : i2c_application.c
  • DMA_GET_TC_FLAG : i2c_application.c
  • DMA_GET_TERR_FLAG : i2c_application.c
  • DMA_HDT_INT : at32f435_437_dma.h
  • dma_init() : at32f435_437_dma.h, at32f435_437_dma.c
  • dma_init_struct : project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/main.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/dma/flash_to_sram/src/main.c, project/at_start_f435/examples/tmr/dma/src/main.c, project/at_start_f435/examples/tmr/dma_burst/src/main.c, at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c, project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/main.c, project/at_start_f437/examples/dac/double_mode_dma_squarewave/src/main.c, project/at_start_f437/examples/dac/one_dac_dma_escalator/src/main.c, project/at_start_f437/examples/dma/dmamux_data_to_gpio/src/main.c, project/at_start_f437/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/dma/flash_to_sram/src/main.c, project/at_start_f437/examples/tmr/dma/src/main.c, project/at_start_f437/examples/tmr/dma_burst/src/main.c, at_start_f437/examples/xmc/sdram_dma/src/xmc_sdram.c
  • dma_init_structure : project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c
  • dma_interrupt_enable() : at32f435_437_dma.h, at32f435_437_dma.c
  • dma_memory_data_size_type : at32f435_437_dma.h
  • DMA_MEMORY_DATA_WIDTH_BYTE : at32f435_437_dma.h
  • DMA_MEMORY_DATA_WIDTH_HALFWORD : at32f435_437_dma.h
  • DMA_MEMORY_DATA_WIDTH_WORD : at32f435_437_dma.h
  • DMA_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • dma_peripheral_data_size_type : at32f435_437_dma.h
  • DMA_PERIPHERAL_DATA_WIDTH_BYTE : at32f435_437_dma.h
  • DMA_PERIPHERAL_DATA_WIDTH_HALFWORD : at32f435_437_dma.h
  • DMA_PERIPHERAL_DATA_WIDTH_WORD : at32f435_437_dma.h
  • DMA_PRIORITY_HIGH : at32f435_437_dma.h
  • dma_priority_level_type : at32f435_437_dma.h
  • DMA_PRIORITY_LOW : at32f435_437_dma.h
  • DMA_PRIORITY_MEDIUM : at32f435_437_dma.h
  • DMA_PRIORITY_VERY_HIGH : at32f435_437_dma.h
  • dma_reset() : at32f435_437_dma.h, at32f435_437_dma.c
  • dma_rx_desc_to_get : at32f435_437_emac.c
  • dma_trans_complete_flag : project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/src/main.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/src/main.c, project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c, project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f437/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f437/examples/adc/conversion_abort/src/main.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f437/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f437/examples/adc/resolution_6bit/src/main.c, project/at_start_f437/examples/adc/software_trigger_repeat/src/at32f435_437_int.c, project/at_start_f437/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c
  • dma_tx_desc_to_set : at32f435_437_emac.c
  • DMAMUX_DMAREQ_ID_ADC1 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_ADC2 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_ADC3 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_DAC1 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_DAC2 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_DVP : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_I2C1_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_I2C1_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_I2C2_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_I2C2_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_I2C3_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_I2C3_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_I2S2_EXT_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_I2S2_EXT_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_I2S3_EXT_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_I2S3_EXT_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_QSPI1 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_QSPI2 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_REQ_G1 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_REQ_G2 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_REQ_G3 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_REQ_G4 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_SDIO1 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_SDIO2 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_SPI1_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_SPI1_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_SPI2_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_SPI2_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_SPI3_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_SPI3_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_SPI4_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_SPI4_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR1_CH1 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR1_CH2 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR1_CH3 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR1_CH4 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR1_HALL : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR1_OVERFLOW : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR1_TRIG : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR20_CH1 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR20_CH2 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR20_CH3 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR20_CH4 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR20_HALL : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR20_OVERFLOW : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR20_TRIG : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR2_CH1 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR2_CH2 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR2_CH3 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR2_CH4 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR2_OVERFLOW : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR2_TRIG : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR3_CH1 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR3_CH2 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR3_CH3 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR3_CH4 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR3_OVERFLOW : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR3_TRIG : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR4_CH1 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR4_CH2 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR4_CH3 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR4_CH4 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR4_OVERFLOW : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR4_TRIG : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR5_CH1 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR5_CH2 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR5_CH3 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR5_CH4 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR5_OVERFLOW : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR5_TRIG : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR6_OVERFLOW : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR7_OVERFLOW : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR8_CH1 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR8_CH2 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR8_CH3 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR8_CH4 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR8_HALL : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR8_OVERFLOW : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR8_TRIG : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_UART4_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_UART4_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_UART5_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_UART5_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_UART7_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_UART7_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_UART8_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_UART8_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_USART1_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_USART1_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_USART2_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_USART2_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_USART3_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_USART3_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_USART6_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_USART6_TX : at32f435_437_dma.h
  • dmamux_enable() : at32f435_437_dma.h, at32f435_437_dma.c
  • DMAMUX_GEN_ID_DMAMUX_CH1_EVT : at32f435_437_dma.h
  • DMAMUX_GEN_ID_DMAMUX_CH2_EVT : at32f435_437_dma.h
  • DMAMUX_GEN_ID_DMAMUX_CH3_EVT : at32f435_437_dma.h
  • DMAMUX_GEN_ID_DMAMUX_CH4_EVT : at32f435_437_dma.h
  • DMAMUX_GEN_ID_DMAMUX_CH5_EVT : at32f435_437_dma.h
  • DMAMUX_GEN_ID_DMAMUX_CH6_EVT : at32f435_437_dma.h
  • DMAMUX_GEN_ID_DMAMUX_CH7_EVT : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT0 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT1 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT10 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT11 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT12 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT13 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT14 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT15 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT2 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT3 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT4 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT5 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT6 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT7 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT8 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT9 : at32f435_437_dma.h
  • dmamux_gen_id_sel_type : at32f435_437_dma.h
  • dmamux_gen_init_struct : project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/edma/dmamux_genertor_exint/src/main.c
  • dmamux_gen_pol_type : at32f435_437_dma.h
  • DMAMUX_GEN_POLARITY_DISABLE : at32f435_437_dma.h
  • DMAMUX_GEN_POLARITY_FALLING : at32f435_437_dma.h
  • DMAMUX_GEN_POLARITY_RISING : at32f435_437_dma.h
  • DMAMUX_GEN_POLARITY_RISING_FALLING : at32f435_437_dma.h
  • DMAMUX_GEN_TRIG_OV1_FLAG : at32f435_437_dma.h
  • DMAMUX_GEN_TRIG_OV2_FLAG : at32f435_437_dma.h
  • DMAMUX_GEN_TRIG_OV3_FLAG : at32f435_437_dma.h
  • DMAMUX_GEN_TRIG_OV4_FLAG : at32f435_437_dma.h
  • dmamux_generator_config() : at32f435_437_dma.h, at32f435_437_dma.c
  • dmamux_generator_default_para_init() : at32f435_437_dma.h, at32f435_437_dma.c
  • dmamux_generator_flag_clear() : at32f435_437_dma.h, at32f435_437_dma.c
  • dmamux_generator_flag_get() : at32f435_437_dma.h, at32f435_437_dma.c
  • dmamux_generator_interrupt_enable() : at32f435_437_dma.h, at32f435_437_dma.c
  • dmamux_init() : at32f435_437_dma.h, at32f435_437_dma.c
  • DMAMUX_IRQn : at32f435_437.h
  • dmamux_requst_id_sel_type : at32f435_437_dma.h
  • DMAMUX_SDIOx : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • dmamux_sync_config() : at32f435_437_dma.h, at32f435_437_dma.c
  • dmamux_sync_default_para_init() : at32f435_437_dma.h, at32f435_437_dma.c
  • dmamux_sync_flag_clear() : at32f435_437_dma.h, at32f435_437_dma.c
  • dmamux_sync_flag_get() : at32f435_437_dma.h, at32f435_437_dma.c
  • DMAMUX_SYNC_ID_DMAMUX_CH1_EVT : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_DMAMUX_CH2_EVT : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_DMAMUX_CH3_EVT : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_DMAMUX_CH4_EVT : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_DMAMUX_CH5_EVT : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_DMAMUX_CH6_EVT : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_DMAMUX_CH7_EVT : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT0 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT1 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT10 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT11 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT12 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT13 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT14 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT15 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT2 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT3 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT4 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT5 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT6 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT7 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT8 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT9 : at32f435_437_dma.h
  • dmamux_sync_id_sel_type : at32f435_437_dma.h
  • dmamux_sync_init_struct : project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/main.c
  • dmamux_sync_interrupt_enable() : at32f435_437_dma.h, at32f435_437_dma.c
  • DMAMUX_SYNC_OV1_FLAG : at32f435_437_dma.h
  • DMAMUX_SYNC_OV2_FLAG : at32f435_437_dma.h
  • DMAMUX_SYNC_OV3_FLAG : at32f435_437_dma.h
  • DMAMUX_SYNC_OV4_FLAG : at32f435_437_dma.h
  • DMAMUX_SYNC_OV5_FLAG : at32f435_437_dma.h
  • DMAMUX_SYNC_OV6_FLAG : at32f435_437_dma.h
  • DMAMUX_SYNC_OV7_FLAG : at32f435_437_dma.h
  • dmamux_sync_pol_type : at32f435_437_dma.h
  • DMAMUX_SYNC_POLARITY_DISABLE : at32f435_437_dma.h
  • DMAMUX_SYNC_POLARITY_FALLING : at32f435_437_dma.h
  • DMAMUX_SYNC_POLARITY_RISING : at32f435_437_dma.h
  • DMAMUX_SYNC_POLARITY_RISING_FALLING : at32f435_437_dma.h
  • DNS_DOES_NAME_CHECK : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • dns_test() : project/at_start_f437/examples/emac/dns_client/src/main.c
  • DOMAIN_NAME : project/at_start_f437/examples/emac/dns_client/src/main.c
  • double_adc1_ordinary_valuetab : project/at_start_f435/examples/adc/edma_double_buffer/src/main.c, project/at_start_f437/examples/adc/edma_double_buffer/src/main.c
  • double_buffer_is_useful : project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/src/main.c, project/at_start_f437/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f437/examples/adc/edma_double_buffer/src/main.c
  • DOWN_MOVE : mouse_class.h
  • dst_buffer : project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/dma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/edma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/two_dimension_mode/src/main.c, project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/dma/flash_to_sram/src/main.c, project/at_start_f437/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/edma/flash_to_sram/src/main.c, project/at_start_f437/examples/edma/two_dimension_mode/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • dualsine12bit : project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c, project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/main.c
  • dualsquare12bit : project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/main.c, project/at_start_f437/examples/dac/double_mode_dma_squarewave/src/main.c
  • duty_buffer : project/at_start_f435/examples/edma/burst_mode/src/main.c, project/at_start_f437/examples/edma/burst_mode/src/main.c
  • duty_result : project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c
  • dutycycle : project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input/src/main.c, project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f437/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/pwm_input/src/main.c, project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c
  • DVP : at32f435_437_dvp.h
  • DVP_BASE : at32f435_437.h
  • dvp_basic_frame_rate_control_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_basic_status_get() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • DVP_BFRC_ALL : at32f435_437_dvp.h
  • DVP_BFRC_HALF : at32f435_437_dvp.h
  • DVP_BFRC_QUARTER : at32f435_437_dvp.h
  • dvp_bfrc_type : at32f435_437_dvp.h
  • DVP_CAP_FUNC_MODE_CONTINUOUS : at32f435_437_dvp.h
  • DVP_CAP_FUNC_MODE_SINGLE : at32f435_437_dvp.h
  • dvp_capture_enable() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_capture_mode_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • DVP_CFD_EVT_FLAG : at32f435_437_dvp.h
  • DVP_CFD_INT : at32f435_437_dvp.h
  • DVP_CFD_INT_FLAG : at32f435_437_dvp.h
  • dvp_cfm_type : at32f435_437_dvp.h
  • dvp_ckp_type : at32f435_437_dvp.h
  • DVP_CLK_POLARITY_FALLING : at32f435_437_dvp.h
  • DVP_CLK_POLARITY_RISING : at32f435_437_dvp.h
  • dvp_config() : at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c
  • dvp_dma_burst_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_dma_init() : at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c
  • DVP_DMABT_BURST : at32f435_437_dvp.h
  • DVP_DMABT_SINGLE : at32f435_437_dvp.h
  • dvp_dmabt_type : at32f435_437_dvp.h
  • DVP_EFDF_BYPASS : at32f435_437_dvp.h
  • DVP_EFDF_RGB565_555 : at32f435_437_dvp.h
  • dvp_efdf_type : at32f435_437_dvp.h
  • DVP_EFDF_Y8 : at32f435_437_dvp.h
  • DVP_EFDF_YUV422_UYVY : at32f435_437_dvp.h
  • DVP_EFDF_YUV422_YUYV : at32f435_437_dvp.h
  • dvp_enable() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_enhanced_data_format_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_enhanced_framerate_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_enhanced_scaling_resize_enable() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_enhanced_scaling_resize_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • DVP_ESE_EVT_FLAG : at32f435_437_dvp.h
  • DVP_ESE_INT : at32f435_437_dvp.h
  • DVP_ESE_INT_FLAG : at32f435_437_dvp.h
  • dvp_flag_clear() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_flag_get() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_frame_done() : at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c
  • DVP_HS_EVT_FLAG : at32f435_437_dvp.h
  • DVP_HS_INT : at32f435_437_dvp.h
  • DVP_HS_INT_FLAG : at32f435_437_dvp.h
  • DVP_HSEID_LINE_END : at32f435_437_dvp.h
  • DVP_HSEID_LINE_START : at32f435_437_dvp.h
  • dvp_hseid_type : at32f435_437_dvp.h
  • dvp_hsp_type : at32f435_437_dvp.h
  • DVP_HSYNC_POLARITY_HIGH : at32f435_437_dvp.h
  • DVP_HSYNC_POLARITY_LOW : at32f435_437_dvp.h
  • dvp_hsync_polarity_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • DVP_IDUN_0 : at32f435_437_dvp.h
  • DVP_IDUN_2 : at32f435_437_dvp.h
  • DVP_IDUN_4 : at32f435_437_dvp.h
  • DVP_IDUN_6 : at32f435_437_dvp.h
  • dvp_idun_type : at32f435_437_dvp.h
  • DVP_IDUS_LSB : at32f435_437_dvp.h
  • DVP_IDUS_MSB : at32f435_437_dvp.h
  • dvp_idus_type : at32f435_437_dvp.h
  • dvp_input_data_unused_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_int_handler() : at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c
  • dvp_interrupt_enable() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_io_init() : at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c
  • DVP_IRQHandler() : at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c
  • DVP_IRQn : at32f435_437.h
  • dvp_jpeg_enable() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • DVP_LCDC_ALL : at32f435_437_dvp.h
  • DVP_LCDC_ONE_IN_TWO : at32f435_437_dvp.h
  • dvp_lcdc_type : at32f435_437_dvp.h
  • DVP_LCDS_CAP_FIRST : at32f435_437_dvp.h
  • DVP_LCDS_DROP_FIRST : at32f435_437_dvp.h
  • dvp_lcds_type : at32f435_437_dvp.h
  • DVP_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • dvp_monochrome_image_binarization_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • DVP_OVR_EVT_FLAG : at32f435_437_dvp.h
  • DVP_OVR_INT : at32f435_437_dvp.h
  • DVP_OVR_INT_FLAG : at32f435_437_dvp.h
  • DVP_PCDC_ALL : at32f435_437_dvp.h
  • DVP_PCDC_ONE_IN_FOUR : at32f435_437_dvp.h
  • DVP_PCDC_ONE_IN_TWO : at32f435_437_dvp.h
  • DVP_PCDC_TWO_IN_FOUR : at32f435_437_dvp.h
  • dvp_pcdc_type : at32f435_437_dvp.h
  • DVP_PCDES_CAP_FIRST : at32f435_437_dvp.h
  • DVP_PCDES_DROP_FIRST : at32f435_437_dvp.h
  • dvp_pcdes_type : at32f435_437_dvp.h
  • DVP_PCDS_CAP_FIRST : at32f435_437_dvp.h
  • DVP_PCDS_DROP_FIRST : at32f435_437_dvp.h
  • dvp_pcds_type : at32f435_437_dvp.h
  • dvp_pclk_polarity_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_pdl_type : at32f435_437_dvp.h
  • DVP_PIXEL_DATA_LENGTH_10 : at32f435_437_dvp.h
  • DVP_PIXEL_DATA_LENGTH_12 : at32f435_437_dvp.h
  • DVP_PIXEL_DATA_LENGTH_14 : at32f435_437_dvp.h
  • DVP_PIXEL_DATA_LENGTH_8 : at32f435_437_dvp.h
  • dvp_pixel_data_length_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_reset() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_sm_type : at32f435_437_dvp.h
  • dvp_start() : at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c
  • dvp_status_basic_type : at32f435_437_dvp.h
  • DVP_STATUS_HSYN : at32f435_437_dvp.h
  • DVP_STATUS_OFNE : at32f435_437_dvp.h
  • DVP_STATUS_VSYN : at32f435_437_dvp.h
  • dvp_stop() : at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c
  • dvp_sync_code_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_sync_event_interrupt_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • DVP_SYNC_MODE_EMBEDDED : at32f435_437_dvp.h
  • DVP_SYNC_MODE_HARDWARE : at32f435_437_dvp.h
  • dvp_sync_mode_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_sync_unmask_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • DVP_VS_EVT_FLAG : at32f435_437_dvp.h
  • DVP_VS_INT : at32f435_437_dvp.h
  • DVP_VS_INT_FLAG : at32f435_437_dvp.h
  • DVP_VSEID_FRAME_END : at32f435_437_dvp.h
  • DVP_VSEID_FRMAE_START : at32f435_437_dvp.h
  • dvp_vseid_type : at32f435_437_dvp.h
  • dvp_vsp_type : at32f435_437_dvp.h
  • DVP_VSYNC_POLARITY_HIGH : at32f435_437_dvp.h
  • DVP_VSYNC_POLARITY_LOW : at32f435_437_dvp.h
  • dvp_vsync_polarity_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_window_crop_enable() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_window_crop_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_zoomout_select() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_zoomout_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dw_end_sector : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • dw_inst_start_sector : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • dw_start_sector : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • DYMMY_BYTE : project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c
  • DZC_TIMEOUT : at32f435_437_can.h


AT32F435/437 Firmwary Library: Globals

- _ -

  • __AT32F435_437_LIBRARY_VERSION : at32f435_437.h
  • __AT32F435_437_LIBRARY_VERSION_MAJOR : at32f435_437.h
  • __AT32F435_437_LIBRARY_VERSION_MIDDLE : at32f435_437.h
  • __AT32F435_437_LIBRARY_VERSION_MINOR : at32f435_437.h
  • __AT32F435_437_LIBRARY_VERSION_RC : at32f435_437.h
  • __CM4_REV : at32f435_437.h
  • __FPU_PRESENT : at32f435_437.h
  • __MPU_PRESENT : at32f435_437.h
  • __NVIC_PRIO_BITS : at32f435_437.h
  • __Vendor_SysTickConfig : at32f435_437.h


AT32F435/437 Firmwary Library: Globals

- a -

  • ACC : at32f435_437_acc.h
  • ACC_BASE : at32f435_437.h
  • ACC_CAL_HICKCAL : at32f435_437_acc.h
  • ACC_CAL_HICKTRIM : at32f435_437_acc.h
  • ACC_CALRDY_FLAG : at32f435_437_acc.h
  • ACC_CALRDYIEN_INT : at32f435_437_acc.h
  • ACC_EIEN_INT : at32f435_437_acc.h
  • ACC_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • ACC_RSLOST_FLAG : at32f435_437_acc.h
  • ACC_SOF_OTG1 : at32f435_437_acc.h
  • ACC_SOF_OTG2 : at32f435_437_acc.h
  • ACC_TRIM : project/at_start_f435/examples/acc/calibration/src/main.c, project/at_start_f437/examples/acc/calibration/src/main.c
  • ADC1 : at32f435_437_adc.h
  • ADC1_BASE : at32f435_437.h
  • ADC2 : at32f435_437_adc.h
  • ADC2_BASE : at32f435_437.h
  • ADC3 : at32f435_437_adc.h
  • ADC3_BASE : at32f435_437.h
  • ADC_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • ADC_OCCE_FLAG : at32f435_437_adc.h
  • ADC_OCCE_INT : at32f435_437_adc.h
  • ADC_OCCO_FLAG : at32f435_437_adc.h
  • ADC_OCCO_INT : at32f435_437_adc.h
  • ADC_OCCS_FLAG : at32f435_437_adc.h
  • ADC_PCCE_FLAG : at32f435_437_adc.h
  • ADC_PCCE_INT : at32f435_437_adc.h
  • ADC_PCCS_FLAG : at32f435_437_adc.h
  • ADC_RDY_FLAG : at32f435_437_adc.h
  • ADC_TEMP_BASE : project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f437/examples/adc/internal_temperature_sensor/src/main.c
  • ADC_TEMP_SLOPE : project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f437/examples/adc/internal_temperature_sensor/src/main.c
  • ADC_VMOR_FLAG : at32f435_437_adc.h
  • ADC_VMOR_INT : at32f435_437_adc.h
  • ADC_VREF : project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f437/examples/adc/internal_temperature_sensor/src/main.c
  • ADCCOM : at32f435_437_adc.h
  • ADCCOM_BASE : at32f435_437.h
  • addr_1st_cycle : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • addr_2nd_cycle : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • addr_3rd_cycle : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • addr_4th_cycle : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • ADDR_AREA : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • ADDR_LENGTH : project/at_start_f437/examples/emac/dns_client/src/netconf.c, project/at_start_f437/examples/emac/http_server/src/netconf.c, project/at_start_f437/examples/emac/iperf/src/netconf.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_server/src/netconf.c, project/at_start_f437/examples/emac/telnet/src/netconf.c, project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • ADDR_SHIFT : at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c
  • ADDRESS_OUT_OF_RANGE : cdc_msc_class.h, msc_bot_scsi.h
  • AHBPERIPH1_BASE : at32f435_437.h
  • AHBPERIPH2_BASE : at32f435_437.h
  • AIRCR_VECTKEY_MASK : at32f435_437_misc.c
  • APB1PERIPH_BASE : at32f435_437.h
  • APB2PERIPH_BASE : at32f435_437.h
  • APP_END_ADDR : at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h
  • APP_LAST_SECTOR_ADDR : at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h
  • APP_START_ADDR : at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h, at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/iap.h, at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h, at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/iap.h
  • APP_START_SECTOR_ADDR : at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h
  • AT32_AUDIO_FREQ_16K : audio_desc.h, audio_hid_desc.h
  • AT32_AUDIO_FREQ_48K : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_DESCRIPTOR_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_EXTENSION_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_FEATURE_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_HEADER : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_INPUT_TERMINAL : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_MIXER_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_OUTPUT_TERMINAL : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_PROCESSING_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_SELECTOR_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AS_DESCRIPTOR_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_AS_FORMAT_SPECIFIC : audio_desc.h, audio_hid_desc.h
  • AUDIO_AS_FORMAT_TYPE : audio_desc.h, audio_hid_desc.h
  • AUDIO_AS_GENERAL : audio_desc.h, audio_hid_desc.h
  • AUDIO_BCD_NUM : audio_desc.h
  • AUDIO_BINTERVAL_TIME : audio_desc.h
  • AUDIO_BITW_16 : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_CS_CONFIGURATION : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_DEVICE : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_ENDPOINT : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_INTERFACE : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_STRING : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_DEFAULT_BITW : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_DEFAULT_FREQ : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_DESCRIPTOR_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_DESCRIPTOR_TYPE : audio_class.h, audio_hid_class.h
  • AUDIO_FEATURE_UNIT_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_FEEDBACK_MAXPACKET_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_FORMAT_TYPE_I : audio_desc.h, audio_hid_desc.h
  • AUDIO_FREQ_16K : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_FREQ_48K : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_FREQ_SET_CONTROL : audio_class.h, audio_hid_class.h
  • AUDIO_FU_BASS_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_CONTROL_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_MID_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_MUTE_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_TREBLE_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_VOLUME_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_INPUT_TERMINAL_MICROPHONE : audio_desc.h, audio_hid_desc.h
  • AUDIO_INPUT_TERMINAL_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_INPUT_TERMINAL_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_INTERFACE_LEN : audio_desc.h, audio_hid_desc.h
  • AUDIO_INTERFACE_NUM : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_BITW : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_CHANEL_NUM : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_MIC_CHR : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_DEFAULT_BITW : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_MIC_FEATURE_UNIT_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_FREQ_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_IN_MAXPACKET_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_MIC_INPUT_TERMINAL_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_INTERFACE : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_INTERFACE_NUMBER : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_OUTPUT_TERMINAL_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_MUTE_CONTROL : audio_class.h, audio_hid_class.h
  • AUDIO_OUTPUT_TERMINAL_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_OUTPUT_TERMINAL_SPEAKER : audio_desc.h, audio_hid_desc.h
  • AUDIO_OUTPUT_TERMINAL_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_PROTOCOL_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_REMAIN_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_REQ_CONTROL_ENDPOINT : audio_class.h, audio_hid_class.h
  • AUDIO_REQ_CONTROL_INTERFACE : audio_class.h, audio_hid_class.h
  • AUDIO_REQ_CONTROL_MASK : audio_class.h, audio_hid_class.h
  • AUDIO_REQ_GET_CUR : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_GET_MAX : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_GET_MEM : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_GET_MIN : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_GET_RES : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_GET_STAT : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_CUR : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_MAX : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_MEM : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_MIN : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_RES : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQUEST_CODE_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_BITW : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_CHANEL_NUM : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SPK_CHR : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_DEFAULT_BITW : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SPK_FEATURE_UNIT_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_FREQ_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_INPUT_TERMINAL_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_INTERFACE : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_INTERFACE_NUMBER : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_OUT_MAXPACKET_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_SPK_OUTPUT_TERMINAL_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUBCLASS_AUDIOCONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUBCLASS_AUDIOSTREAMING : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUBCLASS_MIDISTREMING : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUBCLASS_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUPPORT_FEEDBACK : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_FREQ : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_FREQ_16K : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_FREQ_48K : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_MAX_FREQ : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_MIC : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_SPK : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_TERMINAL_TYPE_STREAMING : audio_desc.h, audio_hid_desc.h
  • AUDIO_TERMINAL_TYPE_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_TERMINAL_TYPE_VENDOR : audio_desc.h, audio_hid_desc.h
  • AUDIO_VOLUME_CONTROL : audio_class.h, audio_hid_class.h
  • AUHID_BCD_NUM : audio_hid_desc.h
  • AUHID_HID_BCD_NUM : audio_hid_desc.h
  • AUHID_HID_BINTERVAL_TIME : audio_hid_desc.h


AT32F435/437 Firmwary Library: Globals

- b -

  • BANK1_NOR2_ADDR : at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c
  • BANK1_SRAM3_ADDR : at_start_f435/examples/xmc/psram/src/xmc_psram.c, at_start_f435/examples/xmc/sram/src/xmc_sram.c, at_start_f437/examples/xmc/psram/src/xmc_psram.c, at_start_f437/examples/xmc/sram/src/xmc_sram.c
  • Bank2_NAND_ADDR : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • Bank_NAND_ADDR : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • BLACK : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • BLOCK_SIZE : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c, fir_filter.c
  • BLOCKERASE_TIMEOUT : at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c
  • BLOCKS_NUMBER : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c
  • BLUE : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • BRED : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • BROWN : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • BRRED : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • BUF_SIZE : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f435/examples/spi/w25q_flash/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/spi/w25q_flash/src/main.c
  • BUFFER_SIZE : project/at_start_f435/examples/crc/calculation/src/main.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/dma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/edma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/link_list_mode/src/main.c, project/at_start_f435/examples/edma/two_dimension_mode/src/main.c, project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f435/examples/usart/hw_flow_control/src/main.c, project/at_start_f435/examples/usart/receiver_mute/src/main.c, at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, project/at_start_f437/examples/crc/calculation/src/main.c, project/at_start_f437/examples/dma/dmamux_data_to_gpio/src/main.c, project/at_start_f437/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/dma/flash_to_sram/src/main.c, project/at_start_f437/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/edma/flash_to_sram/src/main.c, project/at_start_f437/examples/edma/link_list_mode/src/main.c, project/at_start_f437/examples/edma/two_dimension_mode/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f437/examples/usart/hw_flow_control/src/main.c, project/at_start_f437/examples/usart/receiver_mute/src/main.c, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • buffer_size : project/at_start_f435/examples/xmc/nor_flash/src/main.c, project/at_start_f435/examples/xmc/psram/src/main.c, project/at_start_f435/examples/xmc/sdram_basic/src/main.c, project/at_start_f435/examples/xmc/sdram_dma/src/main.c, project/at_start_f435/examples/xmc/sram/src/main.c, project/at_start_f437/examples/xmc/nor_flash/src/main.c, project/at_start_f437/examples/xmc/psram/src/main.c, project/at_start_f437/examples/xmc/sdram_basic/src/main.c, project/at_start_f437/examples/xmc/sdram_dma/src/main.c, project/at_start_f437/examples/xmc/sram/src/main.c
  • BUFFERSIZE : project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c
  • BUTTON_RELEASE : mouse_class.h


AT32F435/437 Firmwary Library: Globals

- c -

  • CAN1 : at32f435_437_can.h
  • CAN1_BASE : at32f435_437.h
  • CAN2 : at32f435_437_can.h
  • CAN2_BASE : at32f435_437.h
  • CAN_BOF_FLAG : at32f435_437_can.h
  • CAN_BOIEN_INT : at32f435_437_can.h
  • CAN_EAF_FLAG : at32f435_437_can.h
  • CAN_EAIEN_INT : at32f435_437_can.h
  • CAN_EDZC_FLAG : at32f435_437_can.h
  • CAN_EDZIEN_INT : at32f435_437_can.h
  • CAN_EOIEN_INT : at32f435_437_can.h
  • CAN_EOIF_FLAG : at32f435_437_can.h
  • CAN_EPF_FLAG : at32f435_437_can.h
  • CAN_EPIEN_INT : at32f435_437_can.h
  • CAN_ETR_FLAG : at32f435_437_can.h
  • CAN_ETRIEN_INT : at32f435_437_can.h
  • CAN_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • CAN_MSTS_EDZIF_VAL : at32f435_437_can.h
  • CAN_MSTS_EOIF_VAL : at32f435_437_can.h
  • CAN_MSTS_QDZIF_VAL : at32f435_437_can.h
  • CAN_QDZIEN_INT : at32f435_437_can.h
  • CAN_QDZIF_FLAG : at32f435_437_can.h
  • CAN_RF0_RF0FF_VAL : at32f435_437_can.h
  • CAN_RF0_RF0OF_VAL : at32f435_437_can.h
  • CAN_RF0_RF0R_VAL : at32f435_437_can.h
  • CAN_RF0FF_FLAG : at32f435_437_can.h
  • CAN_RF0FIEN_INT : at32f435_437_can.h
  • CAN_RF0MIEN_INT : at32f435_437_can.h
  • CAN_RF0MN_FLAG : at32f435_437_can.h
  • CAN_RF0OF_FLAG : at32f435_437_can.h
  • CAN_RF0OIEN_INT : at32f435_437_can.h
  • CAN_RF1_RF1FF_VAL : at32f435_437_can.h
  • CAN_RF1_RF1OF_VAL : at32f435_437_can.h
  • CAN_RF1_RF1R_VAL : at32f435_437_can.h
  • CAN_RF1FF_FLAG : at32f435_437_can.h
  • CAN_RF1FIEN_INT : at32f435_437_can.h
  • CAN_RF1MIEN_INT : at32f435_437_can.h
  • CAN_RF1MN_FLAG : at32f435_437_can.h
  • CAN_RF1OF_FLAG : at32f435_437_can.h
  • CAN_RF1OIEN_INT : at32f435_437_can.h
  • CAN_TCIEN_INT : at32f435_437_can.h
  • CAN_TM0TCF_FLAG : at32f435_437_can.h
  • CAN_TM1TCF_FLAG : at32f435_437_can.h
  • CAN_TM2TCF_FLAG : at32f435_437_can.h
  • CAN_TMEF_FLAG : at32f435_437_can.h
  • CAN_TSTS_TM0CT_VAL : at32f435_437_can.h
  • CAN_TSTS_TM0TCF_VAL : at32f435_437_can.h
  • CAN_TSTS_TM1CT_VAL : at32f435_437_can.h
  • CAN_TSTS_TM1TCF_VAL : at32f435_437_can.h
  • CAN_TSTS_TM2CT_VAL : at32f435_437_can.h
  • CAN_TSTS_TM2TCF_VAL : at32f435_437_can.h
  • CBW_BMCBWFLAGS_DIR_IN : cdc_msc_class.h, msc_bot_scsi.h
  • CBW_BMCBWFLAGS_DIR_OUT : cdc_msc_class.h, msc_bot_scsi.h
  • CBW_CMD_LENGTH : cdc_msc_class.h, msc_bot_scsi.h
  • CBW_DCBWSIGNATURE : cdc_msc_class.h, msc_bot_scsi.h
  • CDC_BCD_NUM : cdc_desc.h, cdc_msc_desc.h
  • CDC_HID_BINTERVAL_TIME : cdc_desc.h, cdc_msc_desc.h
  • CHIPERASE_TIMEOUT : at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c
  • CMD_AREA : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • CODE_ADDR_AS_VOID_PTR : flash_loader.h, flash_config.h
  • CODE_REF : flash_loader.c
  • COL_ADDRESS : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • configASSERT : FreeRTOSConfig.h
  • configCPU_CLOCK_HZ : FreeRTOSConfig.h
  • configIDLE_SHOULD_YIELD : FreeRTOSConfig.h
  • configKERNEL_INTERRUPT_PRIORITY : FreeRTOSConfig.h
  • configLIBRARY_LOWEST_INTERRUPT_PRIORITY : FreeRTOSConfig.h
  • configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY : FreeRTOSConfig.h
  • configMAX_CO_ROUTINE_PRIORITIES : FreeRTOSConfig.h
  • configMAX_PRIORITIES : FreeRTOSConfig.h
  • configMAX_SYSCALL_INTERRUPT_PRIORITY : FreeRTOSConfig.h
  • configMAX_TASK_NAME_LEN : FreeRTOSConfig.h
  • configMINIMAL_STACK_SIZE : FreeRTOSConfig.h
  • configPRIO_BITS : FreeRTOSConfig.h
  • configSUPPORT_DYNAMIC_ALLOCATION : FreeRTOSConfig.h
  • configTICK_RATE_HZ : FreeRTOSConfig.h
  • configTOTAL_HEAP_SIZE : FreeRTOSConfig.h
  • configUSE_16_BIT_TICKS : FreeRTOSConfig.h
  • configUSE_CO_ROUTINES : FreeRTOSConfig.h
  • configUSE_IDLE_HOOK : FreeRTOSConfig.h
  • configUSE_PREEMPTION : FreeRTOSConfig.h
  • configUSE_TICK_HOOK : FreeRTOSConfig.h
  • CONVERT_ENDIAN : hid_iap_class.h
  • COUNTOF : project/at_start_f435/examples/usart/half_duplex/src/main.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usart/half_duplex/src/main.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c
  • CRC : at32f435_437_crc.h
  • CRC_BASE : at32f435_437.h
  • CRC_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • CRLF : httpd.c
  • CRM : at32f435_437_crm.h
  • CRM_ALL_RESET_FLAG : at32f435_437_crm.h
  • CRM_BASE : at32f435_437.h
  • CRM_CLOCK_FAILURE_INT : at32f435_437_crm.h
  • CRM_CLOCK_FAILURE_INT_FLAG : at32f435_437_crm.h
  • CRM_HEXT_READY_INT_FLAG : at32f435_437_crm.h
  • CRM_HEXT_STABLE_FLAG : at32f435_437_crm.h
  • CRM_HEXT_STABLE_INT : at32f435_437_crm.h
  • CRM_HICK_READY_INT_FLAG : at32f435_437_crm.h
  • CRM_HICK_STABLE_FLAG : at32f435_437_crm.h
  • CRM_HICK_STABLE_INT : at32f435_437_crm.h
  • CRM_LEXT_READY_INT_FLAG : at32f435_437_crm.h
  • CRM_LEXT_STABLE_FLAG : at32f435_437_crm.h
  • CRM_LEXT_STABLE_INT : at32f435_437_crm.h
  • CRM_LICK_READY_INT_FLAG : at32f435_437_crm.h
  • CRM_LICK_STABLE_FLAG : at32f435_437_crm.h
  • CRM_LICK_STABLE_INT : at32f435_437_crm.h
  • CRM_LOWPOWER_RESET_FLAG : at32f435_437_crm.h
  • CRM_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • CRM_NRST_RESET_FLAG : at32f435_437_crm.h
  • CRM_PLL_READY_INT_FLAG : at32f435_437_crm.h
  • CRM_PLL_STABLE_FLAG : at32f435_437_crm.h
  • CRM_PLL_STABLE_INT : at32f435_437_crm.h
  • CRM_POR_RESET_FLAG : at32f435_437_crm.h
  • CRM_REG : at32f435_437_crm.h
  • CRM_REG_BIT : at32f435_437_crm.h
  • CRM_SW_RESET_FLAG : at32f435_437_crm.h
  • CRM_WDT_RESET_FLAG : at32f435_437_crm.h
  • CRM_WWDT_RESET_FLAG : at32f435_437_crm.h
  • CRYSTAL_ON_PHY : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • CSW_BCSWSTATUS_FAILED : cdc_msc_class.h, msc_bot_scsi.h
  • CSW_BCSWSTATUS_PASS : cdc_msc_class.h, msc_bot_scsi.h
  • CSW_BCSWSTATUS_PHASE_ERR : cdc_msc_class.h, msc_bot_scsi.h
  • CSW_CMD_LENGTH : cdc_msc_class.h, msc_bot_scsi.h
  • CSW_DCSWSIGNATURE : cdc_msc_class.h, msc_bot_scsi.h
  • CTRL_TIMEOUT : usbh_ctrl.c
  • CUSHID_BCD_NUM : custom_hid_desc.h
  • CUSHID_BINTERVAL_TIME : custom_hid_desc.h
  • CUSTOM_HTTP_SERVER : httpd.c
  • CYAN : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h


AT32F435/437 Firmwary Library: Globals

- d -

  • DAC : at32f435_437_dac.h
  • DAC1_D1DMAUDRF : at32f435_437_dac.h
  • DAC2_D2DMAUDRF : at32f435_437_dac.h
  • DAC_BASE : at32f435_437.h
  • DAC_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • DATA1_VAL : project/at_start_f435/examples/usart/receiver_mute/src/main.c, project/at_start_f437/examples/usart/receiver_mute/src/main.c
  • DATA2_VAL : project/at_start_f435/examples/usart/receiver_mute/src/main.c, project/at_start_f437/examples/usart/receiver_mute/src/main.c
  • DATA3_VAL : project/at_start_f435/examples/usart/receiver_mute/src/main.c, project/at_start_f437/examples/usart/receiver_mute/src/main.c
  • DATA4_VAL : project/at_start_f435/examples/usart/receiver_mute/src/main.c, project/at_start_f437/examples/usart/receiver_mute/src/main.c
  • DATA_AREA : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • DEBUG_BASE : at32f435_437.h
  • DEBUG_CAN1_PAUSE : at32f435_437_debug.h
  • DEBUG_CAN2_PAUSE : at32f435_437_debug.h
  • DEBUG_DEEPSLEEP : at32f435_437_debug.h
  • DEBUG_ERTC_512_PAUSE : at32f435_437_debug.h
  • DEBUG_ERTC_PAUSE : at32f435_437_debug.h
  • DEBUG_I2C1_SMBUS_TIMEOUT : at32f435_437_debug.h
  • DEBUG_I2C2_SMBUS_TIMEOUT : at32f435_437_debug.h
  • DEBUG_I2C3_SMBUS_TIMEOUT : at32f435_437_debug.h
  • DEBUG_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • DEBUG_SLEEP : at32f435_437_debug.h
  • DEBUG_STANDBY : at32f435_437_debug.h
  • DEBUG_TMR10_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR11_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR12_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR13_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR14_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR1_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR20_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR2_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR3_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR4_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR5_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR6_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR7_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR8_PAUSE : at32f435_437_debug.h
  • DEBUG_TMR9_PAUSE : at32f435_437_debug.h
  • DEBUG_WDT_PAUSE : at32f435_437_debug.h
  • DEBUG_WWDT_PAUSE : at32f435_437_debug.h
  • DEBUGMCU : at32f435_437_debug.h
  • DELAY : project/at_start_f435/examples/cortex_m4/systick_interrupt/src/main.c, project/at_start_f435/templates/src/main.c, project/at_start_f437/examples/cortex_m4/systick_interrupt/src/main.c, project/at_start_f437/examples/emac/dns_client/src/main.c, project/at_start_f437/examples/emac/http_server/src/main.c, project/at_start_f437/examples/emac/iperf/src/main.c, project/at_start_f437/examples/emac/mqtt_client/src/main.c, project/at_start_f437/examples/emac/tcp_client/src/main.c, project/at_start_f437/examples/emac/tcp_server/src/main.c, project/at_start_f437/examples/emac/telnet/src/main.c, project/at_start_f437/examples/emac/wake_on_lan/src/main.c, project/at_start_f437/templates/src/main.c
  • DEV_MMC : at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c, at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c
  • DEV_RAM : at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c, at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c
  • DEV_USB : at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c, at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c
  • DEVICE_ID_ADDR1 : random.c
  • DM9162 : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • DMA1 : at32f435_437_dma.h
  • DMA1_BASE : at32f435_437.h
  • DMA1_CHANNEL1 : at32f435_437_dma.h
  • DMA1_CHANNEL1_BASE : at32f435_437.h
  • DMA1_CHANNEL2 : at32f435_437_dma.h
  • DMA1_CHANNEL2_BASE : at32f435_437.h
  • DMA1_CHANNEL3 : at32f435_437_dma.h
  • DMA1_CHANNEL3_BASE : at32f435_437.h
  • DMA1_CHANNEL4 : at32f435_437_dma.h
  • DMA1_CHANNEL4_BASE : at32f435_437.h
  • DMA1_CHANNEL5 : at32f435_437_dma.h
  • DMA1_CHANNEL5_BASE : at32f435_437.h
  • DMA1_CHANNEL6 : at32f435_437_dma.h
  • DMA1_CHANNEL6_BASE : at32f435_437.h
  • DMA1_CHANNEL7 : at32f435_437_dma.h
  • DMA1_CHANNEL7_BASE : at32f435_437.h
  • DMA1_DTERR1_FLAG : at32f435_437_dma.h
  • DMA1_DTERR2_FLAG : at32f435_437_dma.h
  • DMA1_DTERR3_FLAG : at32f435_437_dma.h
  • DMA1_DTERR4_FLAG : at32f435_437_dma.h
  • DMA1_DTERR5_FLAG : at32f435_437_dma.h
  • DMA1_DTERR6_FLAG : at32f435_437_dma.h
  • DMA1_DTERR7_FLAG : at32f435_437_dma.h
  • DMA1_FDT1_FLAG : at32f435_437_dma.h
  • DMA1_FDT2_FLAG : at32f435_437_dma.h
  • DMA1_FDT3_FLAG : at32f435_437_dma.h
  • DMA1_FDT4_FLAG : at32f435_437_dma.h
  • DMA1_FDT5_FLAG : at32f435_437_dma.h
  • DMA1_FDT6_FLAG : at32f435_437_dma.h
  • DMA1_FDT7_FLAG : at32f435_437_dma.h
  • DMA1_GL1_FLAG : at32f435_437_dma.h
  • DMA1_GL2_FLAG : at32f435_437_dma.h
  • DMA1_GL3_FLAG : at32f435_437_dma.h
  • DMA1_GL4_FLAG : at32f435_437_dma.h
  • DMA1_GL5_FLAG : at32f435_437_dma.h
  • DMA1_GL6_FLAG : at32f435_437_dma.h
  • DMA1_GL7_FLAG : at32f435_437_dma.h
  • DMA1_HDT1_FLAG : at32f435_437_dma.h
  • DMA1_HDT2_FLAG : at32f435_437_dma.h
  • DMA1_HDT3_FLAG : at32f435_437_dma.h
  • DMA1_HDT4_FLAG : at32f435_437_dma.h
  • DMA1_HDT5_FLAG : at32f435_437_dma.h
  • DMA1_HDT6_FLAG : at32f435_437_dma.h
  • DMA1_HDT7_FLAG : at32f435_437_dma.h
  • DMA1MUX_BASE : at32f435_437.h
  • DMA1MUX_CHANNEL1 : at32f435_437_dma.h
  • DMA1MUX_CHANNEL1_BASE : at32f435_437.h
  • DMA1MUX_CHANNEL2 : at32f435_437_dma.h
  • DMA1MUX_CHANNEL2_BASE : at32f435_437.h
  • DMA1MUX_CHANNEL3 : at32f435_437_dma.h
  • DMA1MUX_CHANNEL3_BASE : at32f435_437.h
  • DMA1MUX_CHANNEL4 : at32f435_437_dma.h
  • DMA1MUX_CHANNEL4_BASE : at32f435_437.h
  • DMA1MUX_CHANNEL5 : at32f435_437_dma.h
  • DMA1MUX_CHANNEL5_BASE : at32f435_437.h
  • DMA1MUX_CHANNEL6 : at32f435_437_dma.h
  • DMA1MUX_CHANNEL6_BASE : at32f435_437.h
  • DMA1MUX_CHANNEL7 : at32f435_437_dma.h
  • DMA1MUX_CHANNEL7_BASE : at32f435_437.h
  • DMA1MUX_GENERATOR1 : at32f435_437_dma.h
  • DMA1MUX_GENERATOR1_BASE : at32f435_437.h
  • DMA1MUX_GENERATOR2 : at32f435_437_dma.h
  • DMA1MUX_GENERATOR2_BASE : at32f435_437.h
  • DMA1MUX_GENERATOR3 : at32f435_437_dma.h
  • DMA1MUX_GENERATOR3_BASE : at32f435_437.h
  • DMA1MUX_GENERATOR4 : at32f435_437_dma.h
  • DMA1MUX_GENERATOR4_BASE : at32f435_437.h
  • DMA2 : at32f435_437_dma.h
  • DMA2_BASE : at32f435_437.h
  • DMA2_CHANNEL1 : at32f435_437_dma.h
  • DMA2_CHANNEL1_BASE : at32f435_437.h
  • DMA2_CHANNEL2 : at32f435_437_dma.h
  • DMA2_CHANNEL2_BASE : at32f435_437.h
  • DMA2_CHANNEL3 : at32f435_437_dma.h
  • DMA2_CHANNEL3_BASE : at32f435_437.h
  • DMA2_CHANNEL4 : at32f435_437_dma.h
  • DMA2_CHANNEL4_BASE : at32f435_437.h
  • DMA2_CHANNEL5 : at32f435_437_dma.h
  • DMA2_CHANNEL5_BASE : at32f435_437.h
  • DMA2_CHANNEL6 : at32f435_437_dma.h
  • DMA2_CHANNEL6_BASE : at32f435_437.h
  • DMA2_CHANNEL7 : at32f435_437_dma.h
  • DMA2_CHANNEL7_BASE : at32f435_437.h
  • DMA2_DTERR1_FLAG : at32f435_437_dma.h
  • DMA2_DTERR2_FLAG : at32f435_437_dma.h
  • DMA2_DTERR3_FLAG : at32f435_437_dma.h
  • DMA2_DTERR4_FLAG : at32f435_437_dma.h
  • DMA2_DTERR5_FLAG : at32f435_437_dma.h
  • DMA2_DTERR6_FLAG : at32f435_437_dma.h
  • DMA2_DTERR7_FLAG : at32f435_437_dma.h
  • DMA2_FDT1_FLAG : at32f435_437_dma.h
  • DMA2_FDT2_FLAG : at32f435_437_dma.h
  • DMA2_FDT3_FLAG : at32f435_437_dma.h
  • DMA2_FDT4_FLAG : at32f435_437_dma.h
  • DMA2_FDT5_FLAG : at32f435_437_dma.h
  • DMA2_FDT6_FLAG : at32f435_437_dma.h
  • DMA2_FDT7_FLAG : at32f435_437_dma.h
  • DMA2_GL1_FLAG : at32f435_437_dma.h
  • DMA2_GL2_FLAG : at32f435_437_dma.h
  • DMA2_GL3_FLAG : at32f435_437_dma.h
  • DMA2_GL4_FLAG : at32f435_437_dma.h
  • DMA2_GL5_FLAG : at32f435_437_dma.h
  • DMA2_GL6_FLAG : at32f435_437_dma.h
  • DMA2_GL7_FLAG : at32f435_437_dma.h
  • DMA2_HDT1_FLAG : at32f435_437_dma.h
  • DMA2_HDT2_FLAG : at32f435_437_dma.h
  • DMA2_HDT3_FLAG : at32f435_437_dma.h
  • DMA2_HDT4_FLAG : at32f435_437_dma.h
  • DMA2_HDT5_FLAG : at32f435_437_dma.h
  • DMA2_HDT6_FLAG : at32f435_437_dma.h
  • DMA2_HDT7_FLAG : at32f435_437_dma.h
  • DMA2MUX_BASE : at32f435_437.h
  • DMA2MUX_CHANNEL1 : at32f435_437_dma.h
  • DMA2MUX_CHANNEL1_BASE : at32f435_437.h
  • DMA2MUX_CHANNEL2 : at32f435_437_dma.h
  • DMA2MUX_CHANNEL2_BASE : at32f435_437.h
  • DMA2MUX_CHANNEL3 : at32f435_437_dma.h
  • DMA2MUX_CHANNEL3_BASE : at32f435_437.h
  • DMA2MUX_CHANNEL4 : at32f435_437_dma.h
  • DMA2MUX_CHANNEL4_BASE : at32f435_437.h
  • DMA2MUX_CHANNEL5 : at32f435_437_dma.h
  • DMA2MUX_CHANNEL5_BASE : at32f435_437.h
  • DMA2MUX_CHANNEL6 : at32f435_437_dma.h
  • DMA2MUX_CHANNEL6_BASE : at32f435_437.h
  • DMA2MUX_CHANNEL7 : at32f435_437_dma.h
  • DMA2MUX_CHANNEL7_BASE : at32f435_437.h
  • DMA2MUX_GENERATOR1 : at32f435_437_dma.h
  • DMA2MUX_GENERATOR1_BASE : at32f435_437.h
  • DMA2MUX_GENERATOR2 : at32f435_437_dma.h
  • DMA2MUX_GENERATOR2_BASE : at32f435_437.h
  • DMA2MUX_GENERATOR3 : at32f435_437_dma.h
  • DMA2MUX_GENERATOR3_BASE : at32f435_437.h
  • DMA2MUX_GENERATOR4 : at32f435_437_dma.h
  • DMA2MUX_GENERATOR4_BASE : at32f435_437.h
  • DMA_BUFFER_SIZE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • DMA_DTERR_INT : at32f435_437_dma.h
  • DMA_FDT_INT : at32f435_437_dma.h
  • DMA_GET_HT_FLAG : i2c_application.c
  • DMA_GET_REQUEST : i2c_application.c
  • DMA_GET_TC_FLAG : i2c_application.c
  • DMA_GET_TERR_FLAG : i2c_application.c
  • DMA_HDT_INT : at32f435_437_dma.h
  • DMA_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • DMAMUX_GEN_TRIG_OV1_FLAG : at32f435_437_dma.h
  • DMAMUX_GEN_TRIG_OV2_FLAG : at32f435_437_dma.h
  • DMAMUX_GEN_TRIG_OV3_FLAG : at32f435_437_dma.h
  • DMAMUX_GEN_TRIG_OV4_FLAG : at32f435_437_dma.h
  • DMAMUX_SDIOx : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • DMAMUX_SYNC_OV1_FLAG : at32f435_437_dma.h
  • DMAMUX_SYNC_OV2_FLAG : at32f435_437_dma.h
  • DMAMUX_SYNC_OV3_FLAG : at32f435_437_dma.h
  • DMAMUX_SYNC_OV4_FLAG : at32f435_437_dma.h
  • DMAMUX_SYNC_OV5_FLAG : at32f435_437_dma.h
  • DMAMUX_SYNC_OV6_FLAG : at32f435_437_dma.h
  • DMAMUX_SYNC_OV7_FLAG : at32f435_437_dma.h
  • DNS_DOES_NAME_CHECK : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • DOMAIN_NAME : project/at_start_f437/examples/emac/dns_client/src/main.c
  • DOWN_MOVE : mouse_class.h
  • DVP : at32f435_437_dvp.h
  • DVP_BASE : at32f435_437.h
  • DVP_CFD_EVT_FLAG : at32f435_437_dvp.h
  • DVP_CFD_INT : at32f435_437_dvp.h
  • DVP_CFD_INT_FLAG : at32f435_437_dvp.h
  • DVP_ESE_EVT_FLAG : at32f435_437_dvp.h
  • DVP_ESE_INT : at32f435_437_dvp.h
  • DVP_ESE_INT_FLAG : at32f435_437_dvp.h
  • DVP_HS_EVT_FLAG : at32f435_437_dvp.h
  • DVP_HS_INT : at32f435_437_dvp.h
  • DVP_HS_INT_FLAG : at32f435_437_dvp.h
  • DVP_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • DVP_OVR_EVT_FLAG : at32f435_437_dvp.h
  • DVP_OVR_INT : at32f435_437_dvp.h
  • DVP_OVR_INT_FLAG : at32f435_437_dvp.h
  • DVP_VS_EVT_FLAG : at32f435_437_dvp.h
  • DVP_VS_INT : at32f435_437_dvp.h
  • DVP_VS_INT_FLAG : at32f435_437_dvp.h
  • DYMMY_BYTE : project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c
  • DZC_TIMEOUT : at32f435_437_can.h


AT32F435/437 Firmwary Library: Globals

- e -

  • EDMA : at32f435_437_edma.h
  • EDMA_2D_BASE : at32f435_437.h
  • EDMA_BASE : at32f435_437.h
  • EDMA_DMERR1_FLAG : at32f435_437_edma.h
  • EDMA_DMERR2_FLAG : at32f435_437_edma.h
  • EDMA_DMERR3_FLAG : at32f435_437_edma.h
  • EDMA_DMERR4_FLAG : at32f435_437_edma.h
  • EDMA_DMERR5_FLAG : at32f435_437_edma.h
  • EDMA_DMERR6_FLAG : at32f435_437_edma.h
  • EDMA_DMERR7_FLAG : at32f435_437_edma.h
  • EDMA_DMERR8_FLAG : at32f435_437_edma.h
  • EDMA_DMERR_INT : at32f435_437_edma.h
  • EDMA_DTERR1_FLAG : at32f435_437_edma.h
  • EDMA_DTERR2_FLAG : at32f435_437_edma.h
  • EDMA_DTERR3_FLAG : at32f435_437_edma.h
  • EDMA_DTERR4_FLAG : at32f435_437_edma.h
  • EDMA_DTERR5_FLAG : at32f435_437_edma.h
  • EDMA_DTERR6_FLAG : at32f435_437_edma.h
  • EDMA_DTERR7_FLAG : at32f435_437_edma.h
  • EDMA_DTERR8_FLAG : at32f435_437_edma.h
  • EDMA_DTERR_INT : at32f435_437_edma.h
  • EDMA_FDT1_FLAG : at32f435_437_edma.h
  • EDMA_FDT2_FLAG : at32f435_437_edma.h
  • EDMA_FDT3_FLAG : at32f435_437_edma.h
  • EDMA_FDT4_FLAG : at32f435_437_edma.h
  • EDMA_FDT5_FLAG : at32f435_437_edma.h
  • EDMA_FDT6_FLAG : at32f435_437_edma.h
  • EDMA_FDT7_FLAG : at32f435_437_edma.h
  • EDMA_FDT8_FLAG : at32f435_437_edma.h
  • EDMA_FDT_INT : at32f435_437_edma.h
  • EDMA_FERR1_FLAG : at32f435_437_edma.h
  • EDMA_FERR2_FLAG : at32f435_437_edma.h
  • EDMA_FERR3_FLAG : at32f435_437_edma.h
  • EDMA_FERR4_FLAG : at32f435_437_edma.h
  • EDMA_FERR5_FLAG : at32f435_437_edma.h
  • EDMA_FERR6_FLAG : at32f435_437_edma.h
  • EDMA_FERR7_FLAG : at32f435_437_edma.h
  • EDMA_FERR8_FLAG : at32f435_437_edma.h
  • EDMA_FERR_INT : at32f435_437_edma.h
  • EDMA_HDT1_FLAG : at32f435_437_edma.h
  • EDMA_HDT2_FLAG : at32f435_437_edma.h
  • EDMA_HDT3_FLAG : at32f435_437_edma.h
  • EDMA_HDT4_FLAG : at32f435_437_edma.h
  • EDMA_HDT5_FLAG : at32f435_437_edma.h
  • EDMA_HDT6_FLAG : at32f435_437_edma.h
  • EDMA_HDT7_FLAG : at32f435_437_edma.h
  • EDMA_HDT8_FLAG : at32f435_437_edma.h
  • EDMA_HDT_INT : at32f435_437_edma.h
  • EDMA_LL_BASE : at32f435_437.h
  • EDMA_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • EDMA_STREAM1 : at32f435_437_edma.h
  • EDMA_STREAM1_2D : at32f435_437_edma.h
  • EDMA_STREAM1_2D_BASE : at32f435_437.h
  • EDMA_STREAM1_BASE : at32f435_437.h
  • EDMA_STREAM1_INT_MASK : at32f435_437_edma.h
  • EDMA_STREAM1_LL : at32f435_437_edma.h
  • EDMA_STREAM1_LL_BASE : at32f435_437.h
  • EDMA_STREAM2 : at32f435_437_edma.h
  • EDMA_STREAM2_2D : at32f435_437_edma.h
  • EDMA_STREAM2_2D_BASE : at32f435_437.h
  • EDMA_STREAM2_BASE : at32f435_437.h
  • EDMA_STREAM2_INT_MASK : at32f435_437_edma.h
  • EDMA_STREAM2_LL : at32f435_437_edma.h
  • EDMA_STREAM2_LL_BASE : at32f435_437.h
  • EDMA_STREAM3 : at32f435_437_edma.h
  • EDMA_STREAM3_2D : at32f435_437_edma.h
  • EDMA_STREAM3_2D_BASE : at32f435_437.h
  • EDMA_STREAM3_BASE : at32f435_437.h
  • EDMA_STREAM3_INT_MASK : at32f435_437_edma.h
  • EDMA_STREAM3_LL : at32f435_437_edma.h
  • EDMA_STREAM3_LL_BASE : at32f435_437.h
  • EDMA_STREAM4 : at32f435_437_edma.h
  • EDMA_STREAM4_2D : at32f435_437_edma.h
  • EDMA_STREAM4_2D_BASE : at32f435_437.h
  • EDMA_STREAM4_BASE : at32f435_437.h
  • EDMA_STREAM4_INT_MASK : at32f435_437_edma.h
  • EDMA_STREAM4_LL : at32f435_437_edma.h
  • EDMA_STREAM4_LL_BASE : at32f435_437.h
  • EDMA_STREAM5 : at32f435_437_edma.h
  • EDMA_STREAM5_2D : at32f435_437_edma.h
  • EDMA_STREAM5_2D_BASE : at32f435_437.h
  • EDMA_STREAM5_BASE : at32f435_437.h
  • EDMA_STREAM5_INT_MASK : at32f435_437_edma.h
  • EDMA_STREAM5_LL : at32f435_437_edma.h
  • EDMA_STREAM5_LL_BASE : at32f435_437.h
  • EDMA_STREAM6 : at32f435_437_edma.h
  • EDMA_STREAM6_2D : at32f435_437_edma.h
  • EDMA_STREAM6_2D_BASE : at32f435_437.h
  • EDMA_STREAM6_BASE : at32f435_437.h
  • EDMA_STREAM6_INT_MASK : at32f435_437_edma.h
  • EDMA_STREAM6_LL : at32f435_437_edma.h
  • EDMA_STREAM6_LL_BASE : at32f435_437.h
  • EDMA_STREAM7 : at32f435_437_edma.h
  • EDMA_STREAM7_2D : at32f435_437_edma.h
  • EDMA_STREAM7_2D_BASE : at32f435_437.h
  • EDMA_STREAM7_BASE : at32f435_437.h
  • EDMA_STREAM7_INT_MASK : at32f435_437_edma.h
  • EDMA_STREAM7_LL : at32f435_437_edma.h
  • EDMA_STREAM7_LL_BASE : at32f435_437.h
  • EDMA_STREAM8 : at32f435_437_edma.h
  • EDMA_STREAM8_2D : at32f435_437_edma.h
  • EDMA_STREAM8_2D_BASE : at32f435_437.h
  • EDMA_STREAM8_BASE : at32f435_437.h
  • EDMA_STREAM8_INT_MASK : at32f435_437_edma.h
  • EDMA_STREAM8_LL : at32f435_437_edma.h
  • EDMA_STREAM8_LL_BASE : at32f435_437.h
  • EDMAMUX_BASE : at32f435_437.h
  • EDMAMUX_CHANNEL1 : at32f435_437_edma.h
  • EDMAMUX_CHANNEL1_BASE : at32f435_437.h
  • EDMAMUX_CHANNEL2 : at32f435_437_edma.h
  • EDMAMUX_CHANNEL2_BASE : at32f435_437.h
  • EDMAMUX_CHANNEL3 : at32f435_437_edma.h
  • EDMAMUX_CHANNEL3_BASE : at32f435_437.h
  • EDMAMUX_CHANNEL4 : at32f435_437_edma.h
  • EDMAMUX_CHANNEL4_BASE : at32f435_437.h
  • EDMAMUX_CHANNEL5 : at32f435_437_edma.h
  • EDMAMUX_CHANNEL5_BASE : at32f435_437.h
  • EDMAMUX_CHANNEL6 : at32f435_437_edma.h
  • EDMAMUX_CHANNEL6_BASE : at32f435_437.h
  • EDMAMUX_CHANNEL7 : at32f435_437_edma.h
  • EDMAMUX_CHANNEL7_BASE : at32f435_437.h
  • EDMAMUX_CHANNEL8 : at32f435_437_edma.h
  • EDMAMUX_CHANNEL8_BASE : at32f435_437.h
  • EDMAMUX_GEN_TRIG_OV1_FLAG : at32f435_437_edma.h
  • EDMAMUX_GEN_TRIG_OV2_FLAG : at32f435_437_edma.h
  • EDMAMUX_GEN_TRIG_OV3_FLAG : at32f435_437_edma.h
  • EDMAMUX_GEN_TRIG_OV4_FLAG : at32f435_437_edma.h
  • EDMAMUX_GENERATOR1 : at32f435_437_edma.h
  • EDMAMUX_GENERATOR1_BASE : at32f435_437.h
  • EDMAMUX_GENERATOR2 : at32f435_437_edma.h
  • EDMAMUX_GENERATOR2_BASE : at32f435_437.h
  • EDMAMUX_GENERATOR3 : at32f435_437_edma.h
  • EDMAMUX_GENERATOR3_BASE : at32f435_437.h
  • EDMAMUX_GENERATOR4 : at32f435_437_edma.h
  • EDMAMUX_GENERATOR4_BASE : at32f435_437.h
  • EDMAMUX_SYNC_OV1_FLAG : at32f435_437_edma.h
  • EDMAMUX_SYNC_OV2_FLAG : at32f435_437_edma.h
  • EDMAMUX_SYNC_OV3_FLAG : at32f435_437_edma.h
  • EDMAMUX_SYNC_OV4_FLAG : at32f435_437_edma.h
  • EDMAMUX_SYNC_OV5_FLAG : at32f435_437_edma.h
  • EDMAMUX_SYNC_OV6_FLAG : at32f435_437_edma.h
  • EDMAMUX_SYNC_OV7_FLAG : at32f435_437_edma.h
  • EDMAMUX_SYNC_OV8_FLAG : at32f435_437_edma.h
  • EMAC : at32f435_437_emac.h
  • EMAC_CRC : at32f435_437_emac.h
  • EMAC_DMA : at32f435_437_emac.h
  • EMAC_DMA_AIS_FLAG : at32f435_437_emac.h
  • EMAC_DMA_ERI_FLAG : at32f435_437_emac.h
  • EMAC_DMA_ETI_FLAG : at32f435_437_emac.h
  • EMAC_DMA_FBEI_FLAG : at32f435_437_emac.h
  • EMAC_DMA_NIS_FLAG : at32f435_437_emac.h
  • EMAC_DMA_OVF_FLAG : at32f435_437_emac.h
  • EMAC_DMA_RBU_FLAG : at32f435_437_emac.h
  • EMAC_DMA_RI_FLAG : at32f435_437_emac.h
  • EMAC_DMA_RPS_FLAG : at32f435_437_emac.h
  • EMAC_DMA_RWT_FLAG : at32f435_437_emac.h
  • EMAC_DMA_TBU_FLAG : at32f435_437_emac.h
  • EMAC_DMA_TI_FLAG : at32f435_437_emac.h
  • EMAC_DMA_TJT_FLAG : at32f435_437_emac.h
  • EMAC_DMA_TPS_FLAG : at32f435_437_emac.h
  • EMAC_DMA_UNF_FLAG : at32f435_437_emac.h
  • EMAC_DMARXDESC_AFM : at32f435_437_emac.h
  • EMAC_DMARXDESC_B1AP : at32f435_437_emac.h
  • EMAC_DMARXDESC_B2AP : at32f435_437_emac.h
  • EMAC_DMARXDESC_CE : at32f435_437_emac.h
  • EMAC_DMARXDESC_DBE : at32f435_437_emac.h
  • EMAC_DMARXDESC_DE : at32f435_437_emac.h
  • EMAC_DMARXDESC_DIC : at32f435_437_emac.h
  • EMAC_DMARXDESC_ES : at32f435_437_emac.h
  • EMAC_DMARXDESC_FL : at32f435_437_emac.h
  • EMAC_DMARXDESC_FRAME_LENGTHSHIFT : at32f435_437_emac.h
  • EMAC_DMARXDESC_FS : at32f435_437_emac.h
  • EMAC_DMARXDESC_FT : at32f435_437_emac.h
  • EMAC_DMARXDESC_IPV4HCE : at32f435_437_emac.h
  • EMAC_DMARXDESC_LC : at32f435_437_emac.h
  • EMAC_DMARXDESC_LE : at32f435_437_emac.h
  • EMAC_DMARXDESC_LS : at32f435_437_emac.h
  • EMAC_DMARXDESC_MAMPCE : at32f435_437_emac.h
  • EMAC_DMARXDESC_OE : at32f435_437_emac.h
  • EMAC_DMARXDESC_OWN : at32f435_437_emac.h
  • EMAC_DMARXDESC_RBS1 : at32f435_437_emac.h
  • EMAC_DMARXDESC_RBS2 : at32f435_437_emac.h
  • EMAC_DMARXDESC_RCH : at32f435_437_emac.h
  • EMAC_DMARXDESC_RE : at32f435_437_emac.h
  • EMAC_DMARXDESC_RER : at32f435_437_emac.h
  • EMAC_DMARXDESC_RWT : at32f435_437_emac.h
  • EMAC_DMARXDESC_SAF : at32f435_437_emac.h
  • EMAC_DMARXDESC_VLAN : at32f435_437_emac.h
  • EMAC_DMATXDESC_B1AP : at32f435_437_emac.h
  • EMAC_DMATxDesc_B2AP : at32f435_437_emac.h
  • EMAC_DMATXDESC_CC : at32f435_437_emac.h
  • EMAC_DMATXDESC_CIC : at32f435_437_emac.h
  • EMAC_DMATXDESC_CIC_BYPASS : at32f435_437_emac.h
  • EMAC_DMATXDESC_CIC_IPV4HEADER : at32f435_437_emac.h
  • EMAC_DMATXDESC_CIC_TUI_FULL : at32f435_437_emac.h
  • EMAC_DMATXDESC_CIC_TUI_SEG : at32f435_437_emac.h
  • EMAC_DMATXDESC_DB : at32f435_437_emac.h
  • EMAC_DMATXDESC_DC : at32f435_437_emac.h
  • EMAC_DMATXDESC_DP : at32f435_437_emac.h
  • EMAC_DMATXDESC_EC : at32f435_437_emac.h
  • EMAC_DMATXDESC_ED : at32f435_437_emac.h
  • EMAC_DMATXDESC_ES : at32f435_437_emac.h
  • EMAC_DMATXDESC_FF : at32f435_437_emac.h
  • EMAC_DMATXDESC_FS : at32f435_437_emac.h
  • EMAC_DMATXDESC_IC : at32f435_437_emac.h
  • EMAC_DMATXDESC_IHE : at32f435_437_emac.h
  • EMAC_DMATXDESC_JT : at32f435_437_emac.h
  • EMAC_DMATXDESC_LCA : at32f435_437_emac.h
  • EMAC_DMATXDESC_LCO : at32f435_437_emac.h
  • EMAC_DMATXDESC_LS : at32f435_437_emac.h
  • EMAC_DMATXDESC_NC : at32f435_437_emac.h
  • EMAC_DMATXDESC_OWN : at32f435_437_emac.h
  • EMAC_DMATXDESC_PCE : at32f435_437_emac.h
  • EMAC_DMATXDESC_TBS1 : at32f435_437_emac.h
  • EMAC_DMATXDESC_TBS2 : at32f435_437_emac.h
  • EMAC_DMATXDESC_TCH : at32f435_437_emac.h
  • EMAC_DMATXDESC_TER : at32f435_437_emac.h
  • EMAC_DMATXDESC_TTSE : at32f435_437_emac.h
  • EMAC_DMATXDESC_TTSS : at32f435_437_emac.h
  • EMAC_DMATXDESC_UF : at32f435_437_emac.h
  • EMAC_DMATXDESC_VF : at32f435_437_emac.h
  • EMAC_EXTRA : at32f435_437_emac.h
  • EMAC_HCLK_BORDER_100MHZ : at32f435_437_emac.h
  • EMAC_HCLK_BORDER_150MHZ : at32f435_437_emac.h
  • EMAC_HCLK_BORDER_20MHZ : at32f435_437_emac.h
  • EMAC_HCLK_BORDER_250MHZ : at32f435_437_emac.h
  • EMAC_HCLK_BORDER_288MHZ : at32f435_437_emac.h
  • EMAC_HCLK_BORDER_35MHZ : at32f435_437_emac.h
  • EMAC_HCLK_BORDER_60MHZ : at32f435_437_emac.h
  • EMAC_HEADER : at32f435_437_emac.h
  • EMAC_MAX_PACKET_LENGTH : at32f435_437_emac.h
  • EMAC_MAX_PAYLOAD : at32f435_437_emac.h
  • EMAC_MIN_PAYLOAD : at32f435_437_emac.h
  • EMAC_MMC : at32f435_437_emac.h
  • EMAC_MMC_FLAG : at32f435_437_emac.h
  • EMAC_MMCR_FLAG : at32f435_437_emac.h
  • EMAC_MMCT_FLAG : at32f435_437_emac.h
  • EMAC_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • EMAC_PMT_FLAG : at32f435_437_emac.h
  • EMAC_PTP : at32f435_437_emac.h
  • EMAC_TST_FLAG : at32f435_437_emac.h
  • ENABLE_ERTC_ASSEED : random.h
  • ERASE_TIMEOUT : at32f435_437_flash.h
  • ERROR_ID_VAL : project/at_start_f435/examples/usart/receiver_mute/src/main.c, project/at_start_f437/examples/usart/receiver_mute/src/main.c
  • ERTC : at32f435_437_ertc.h
  • ERTC_ALA_INT : at32f435_437_ertc.h
  • ERTC_ALAF_FLAG : at32f435_437_ertc.h
  • ERTC_ALARM_MASK_ALL : at32f435_437_ertc.h
  • ERTC_ALARM_MASK_DATE_WEEK : at32f435_437_ertc.h
  • ERTC_ALARM_MASK_HOUR : at32f435_437_ertc.h
  • ERTC_ALARM_MASK_MIN : at32f435_437_ertc.h
  • ERTC_ALARM_MASK_NONE : at32f435_437_ertc.h
  • ERTC_ALARM_MASK_SEC : at32f435_437_ertc.h
  • ERTC_ALAWF_FLAG : at32f435_437_ertc.h
  • ERTC_ALB_INT : at32f435_437_ertc.h
  • ERTC_ALBF_FLAG : at32f435_437_ertc.h
  • ERTC_ALBWF_FLAG : at32f435_437_ertc.h
  • ERTC_BASE : at32f435_437.h
  • ERTC_BPR_DT_NUMBER : project/at_start_f435/examples/ertc/bpr_domain/src/main.c, project/at_start_f435/examples/ertc/tamper/src/main.c, project/at_start_f437/examples/ertc/bpr_domain/src/main.c, project/at_start_f437/examples/ertc/tamper/src/main.c
  • ERTC_CALUPDF_FLAG : at32f435_437_ertc.h
  • ERTC_CLOCK_SOURCE_LEXT : project/at_start_f435/examples/ertc/calendar/src/main.c, project/at_start_f437/examples/ertc/calendar/src/main.c
  • ERTC_IMF_FLAG : at32f435_437_ertc.h
  • ERTC_INITF_FLAG : at32f435_437_ertc.h
  • ERTC_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • ERTC_TADJF_FLAG : at32f435_437_ertc.h
  • ERTC_TIMEOUT : at32f435_437_ertc.c
  • ERTC_TP1F_FLAG : at32f435_437_ertc.h
  • ERTC_TP2F_FLAG : at32f435_437_ertc.h
  • ERTC_TP_INT : at32f435_437_ertc.h
  • ERTC_TS_INT : at32f435_437_ertc.h
  • ERTC_TSF_FLAG : at32f435_437_ertc.h
  • ERTC_TSOF_FLAG : at32f435_437_ertc.h
  • ERTC_UPDF_FLAG : at32f435_437_ertc.h
  • ERTC_WAT_CLK_CK_A_16BITS : at32f435_437_ertc.h
  • ERTC_WAT_CLK_CK_A_17BITS : at32f435_437_ertc.h
  • ERTC_WAT_INT : at32f435_437_ertc.h
  • ERTC_WATF_FLAG : at32f435_437_ertc.h
  • ERTC_WATWF_FLAG : at32f435_437_ertc.h
  • ETHARP_SUPPORT_STATIC_ENTRIES : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • EXINT : at32f435_437_exint.h
  • EXINT_BASE : at32f435_437.h
  • EXINT_LINE_0 : at32f435_437_exint.h
  • EXINT_LINE_1 : at32f435_437_exint.h
  • EXINT_LINE_10 : at32f435_437_exint.h
  • EXINT_LINE_11 : at32f435_437_exint.h
  • EXINT_LINE_12 : at32f435_437_exint.h
  • EXINT_LINE_13 : at32f435_437_exint.h
  • EXINT_LINE_14 : at32f435_437_exint.h
  • EXINT_LINE_15 : at32f435_437_exint.h
  • EXINT_LINE_16 : at32f435_437_exint.h
  • EXINT_LINE_17 : at32f435_437_exint.h
  • EXINT_LINE_18 : at32f435_437_exint.h
  • EXINT_LINE_19 : at32f435_437_exint.h
  • EXINT_LINE_2 : at32f435_437_exint.h
  • EXINT_LINE_20 : at32f435_437_exint.h
  • EXINT_LINE_21 : at32f435_437_exint.h
  • EXINT_LINE_22 : at32f435_437_exint.h
  • EXINT_LINE_3 : at32f435_437_exint.h
  • EXINT_LINE_4 : at32f435_437_exint.h
  • EXINT_LINE_5 : at32f435_437_exint.h
  • EXINT_LINE_6 : at32f435_437_exint.h
  • EXINT_LINE_7 : at32f435_437_exint.h
  • EXINT_LINE_8 : at32f435_437_exint.h
  • EXINT_LINE_9 : at32f435_437_exint.h
  • EXINT_LINE_NONE : at32f435_437_exint.h
  • EXINT_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • EXT16BIT : FlashOS.h
  • EXT32BIT : FlashOS.h
  • EXT8BIT : FlashOS.h
  • EXT_CSD_BUS_WIDTH : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_Clear_byte : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_CMD_SET_CPSECURE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_CMD_SET_NORMAL : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_CMD_SET_SECURE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_Command_set : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_HS_TIMING : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_Set_bit : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_Write_byte : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • EXTSPI : FlashOS.h


AT32F435/437 Firmwary Library: Globals

- f -

  • FAP_RELIEVE_KEY : at32f435_437_flash.h
  • FAST : project/at_start_f435/templates/src/main.c, project/at_start_f437/examples/emac/dns_client/src/main.c, project/at_start_f437/examples/emac/http_server/src/main.c, project/at_start_f437/examples/emac/iperf/src/main.c, project/at_start_f437/examples/emac/mqtt_client/src/main.c, project/at_start_f437/examples/emac/tcp_client/src/main.c, project/at_start_f437/examples/emac/tcp_server/src/main.c, project/at_start_f437/examples/emac/telnet/src/main.c, project/at_start_f437/examples/emac/wake_on_lan/src/main.c, project/at_start_f437/templates/src/main.c
  • FAT16_BYTE_PER_SIZE : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FAT16_DIR_SIZE : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FAT16_FILENAME_SIZE : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FAT16_SECTOR_SIZE : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • FAT16_TABLE_SIZE : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FEEDBACK_REFRESH_TIME : audio_class.h, audio_hid_class.h
  • FF_CODE_PAGE : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_FS_EXFAT : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_FS_LOCK : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_FS_MINIMIZE : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_FS_NOFSINFO : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_FS_NORTC : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_FS_READONLY : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_FS_REENTRANT : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_FS_RPATH : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_FS_TIMEOUT : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_FS_TINY : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_LBA64 : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_LFN_BUF : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_LFN_UNICODE : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_MAX_LFN : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_MAX_SS : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_MIN_GPT : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_MIN_SS : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_MULTI_PARTITION : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_NORTC_MDAY : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_NORTC_MON : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_NORTC_YEAR : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_PRINT_FLOAT : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_PRINT_LLI : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_SFN_BUF : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_STR_VOLUME_ID : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_STRF_ENCODE : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_SYNC_t : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_USE_CHMOD : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_USE_EXPAND : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_USE_FASTSEEK : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_USE_FIND : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_USE_FORWARD : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_USE_LABEL : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_USE_LFN : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_USE_MKFS : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_USE_STRFUNC : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_USE_TRIM : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_VOLUME_STRS : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_VOLUMES : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FFCONF_DEF : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • file_NULL : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • FILE_SUFFIX1_LEN : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FILE_SUFFIX1_NAME : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FILE_SUFFIX2_LEN : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FILE_SUFFIX2_NAME : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FILTER_EXT_ID1 : project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f437/examples/can/filter/src/main.c
  • FILTER_EXT_ID2 : project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f437/examples/can/filter/src/main.c
  • FILTER_EXT_ID3 : project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f437/examples/can/filter/src/main.c
  • FILTER_STD_ID1 : project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f437/examples/can/filter/src/main.c
  • FILTER_STD_ID2 : project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f437/examples/can/filter/src/main.c
  • FILTER_STD_ID3 : project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f437/examples/can/filter/src/main.c
  • FLAG_ERASE_ONLY : flash_loader.h
  • FLASH : at32f435_437_flash.h
  • FLASH_APP_ADDRESS : app_led3_toggle/inc/hid_iap_user.h, app_led4_toggle/inc/hid_iap_user.h, bootloader/inc/hid_iap_user.h
  • FLASH_APP_START_ADDR : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FLASH_BANK1_END_ADDR : at32f435_437_flash.h
  • FLASH_BANK1_EPPERR_FLAG : at32f435_437_flash.h
  • FLASH_BANK1_ERR_INT : at32f435_437_flash.h
  • FLASH_BANK1_OBF_FLAG : at32f435_437_flash.h
  • FLASH_BANK1_ODF_FLAG : at32f435_437_flash.h
  • FLASH_BANK1_ODF_INT : at32f435_437_flash.h
  • FLASH_BANK1_PRGMERR_FLAG : at32f435_437_flash.h
  • FLASH_BANK1_START_ADDR : at32f435_437_flash.h
  • FLASH_BANK2_END_ADDR : at32f435_437_flash.h
  • FLASH_BANK2_EPPERR_FLAG : at32f435_437_flash.h
  • FLASH_BANK2_ERR_INT : at32f435_437_flash.h
  • FLASH_BANK2_OBF_FLAG : at32f435_437_flash.h
  • FLASH_BANK2_ODF_FLAG : at32f435_437_flash.h
  • FLASH_BANK2_ODF_INT : at32f435_437_flash.h
  • FLASH_BANK2_PRGMERR_FLAG : at32f435_437_flash.h
  • FLASH_BANK2_START_ADDR : at32f435_437_flash.h
  • FLASH_BASE : at32f435_437.h
  • FLASH_BOOT_FROM_BANK1 : at32f435_437_flash.h
  • FLASH_BOOT_FROM_BANK2 : at32f435_437_flash.h
  • flash_clock_divider_set : at32f435_437_flash.h
  • FLASH_CS_HIGH : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • FLASH_CS_LOW : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • FLASH_DRV_VERS : FlashOS.h
  • FLASH_EPPERR_FLAG : at32f435_437_flash.h
  • FLASH_ERR_INT : at32f435_437_flash.h
  • FLASH_FAT16_1_ADDR : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FLASH_FAT16_2_ADDR : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FLASH_FAT16_BOOT_SECTOR_ADDR : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FLASH_FAT16_FILE_START_ADDR : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FLASH_FAT16_ROOT_ADDR : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FLASH_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • FLASH_OBF_FLAG : at32f435_437_flash.h
  • FLASH_ODF_FLAG : at32f435_437_flash.h
  • FLASH_ODF_INT : at32f435_437_flash.h
  • FLASH_PAGE_PROGRAM_SIZE : at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c, qspi_algorithm.c
  • FLASH_PRGMERR_FLAG : at32f435_437_flash.h
  • FLASH_REG_BASE : at32f435_437.h
  • FLASH_SECTOR_1K_ALLGNED : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FLASH_SECTOR_1K_SIZE : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FLASH_SECTOR_2K_ALLGNED : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FLASH_SECTOR_2K_SIZE : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FLASH_SECTOR_4K_ALLGNED : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FLASH_SECTOR_4K_SIZE : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FLASH_SECTOR_SIZE : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • FLASH_SIZE : utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/flash.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/flash.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/flash.h
  • FLASH_SIZE_REG : hid_iap_class.h
  • FLASH_SLIB_END_SECTOR : at32f435_437_flash.h
  • FLASH_SLIB_INST_START_SECTOR : at32f435_437_flash.h
  • FLASH_SLIB_START_SECTOR : at32f435_437_flash.h
  • FLASH_SPI_DUMMY_BYTE : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • FLASH_START_ADDR : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • FLASH_TEST_ADDR : project/at_start_f435/examples/spi/w25q_flash/src/main.c, project/at_start_f437/examples/spi/w25q_flash/src/main.c
  • FLASH_UNLOCK_KEY1 : at32f435_437_flash.h
  • FLASH_UNLOCK_KEY2 : at32f435_437_flash.h
  • FLASH_USDERR_FLAG : at32f435_437_flash.h
  • FS_FILE_FLAGS_HEADER_INCLUDED : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • FS_FILE_FLAGS_HEADER_PERSISTENT : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • FS_NUMFILES : project/at_start_f437/examples/emac/http_server/src/fsdata.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h
  • FS_ROOT : project/at_start_f437/examples/emac/http_server/src/fsdata.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h
  • FSDATA_ALIGN_POST : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • FSDATA_ALIGN_PRE : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • FSDATA_FILE_ALIGNMENT : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • FZC_TIMEOUT : at32f435_437_can.h


AT32F435/437 Firmwary Library: Globals

- g -

  • GBLUE : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • GET_LINE_CODING : usb_std.h, cdc_msc_class.h, msc_bot_scsi.h
  • GPIO_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • GPIO_PINS_0 : at32f435_437_gpio.h
  • GPIO_PINS_1 : at32f435_437_gpio.h
  • GPIO_PINS_10 : at32f435_437_gpio.h
  • GPIO_PINS_11 : at32f435_437_gpio.h
  • GPIO_PINS_12 : at32f435_437_gpio.h
  • GPIO_PINS_13 : at32f435_437_gpio.h
  • GPIO_PINS_14 : at32f435_437_gpio.h
  • GPIO_PINS_15 : at32f435_437_gpio.h
  • GPIO_PINS_2 : at32f435_437_gpio.h
  • GPIO_PINS_3 : at32f435_437_gpio.h
  • GPIO_PINS_4 : at32f435_437_gpio.h
  • GPIO_PINS_5 : at32f435_437_gpio.h
  • GPIO_PINS_6 : at32f435_437_gpio.h
  • GPIO_PINS_7 : at32f435_437_gpio.h
  • GPIO_PINS_8 : at32f435_437_gpio.h
  • GPIO_PINS_9 : at32f435_437_gpio.h
  • GPIO_PINS_ALL : at32f435_437_gpio.h
  • GPIOA : at32f435_437_gpio.h
  • GPIOA_BASE : at32f435_437.h
  • GPIOB : at32f435_437_gpio.h
  • GPIOB_BASE : at32f435_437.h
  • GPIOC : at32f435_437_gpio.h
  • GPIOC_BASE : at32f435_437.h
  • GPIOD : at32f435_437_gpio.h
  • GPIOD_BASE : at32f435_437.h
  • GPIOE : at32f435_437_gpio.h
  • GPIOE_BASE : at32f435_437.h
  • GPIOF : at32f435_437_gpio.h
  • GPIOF_BASE : at32f435_437.h
  • GPIOG : at32f435_437_gpio.h
  • GPIOG_BASE : at32f435_437.h
  • GPIOH : at32f435_437_gpio.h
  • GPIOH_BASE : at32f435_437.h
  • GRAY : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • GRED : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • GREEN : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • GREETING : telnet.c


AT32F435/437 Firmwary Library: Globals

- h -

  • HARDWARE_MODE : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • HBYTE : usb_std.h
  • HELLO : telnet.c
  • HEXT_STARTUP_TIMEOUT : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • HEXT_VALUE : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • HICK_VALUE : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • HID_CLASS_DESC_HID : usb_std.h, audio_hid_desc.h
  • HID_CLASS_DESC_PHYSICAL : usb_std.h, audio_hid_desc.h
  • HID_CLASS_DESC_REPORT : usb_std.h, audio_hid_desc.h
  • HID_DESCRIPTOR_TYPE : usb_std.h
  • HID_IAP_BUFFER_LEN : hid_iap_class.h
  • HID_INTERFACE_NUMBER : audio_hid_desc.h
  • HID_REPORT_DESC : usb_std.h
  • HID_REPORT_ID_1 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_2 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_3 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_4 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_5 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_6 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REQ_GET_IDLE : usb_std.h
  • HID_REQ_GET_PROTOCOL : usb_std.h
  • HID_REQ_GET_REPORT : usb_std.h
  • HID_REQ_SET_IDLE : usb_std.h
  • HID_REQ_SET_PROTOCOL : usb_std.h
  • HID_REQ_SET_REPORT : usb_std.h
  • HIDIAP_BCD_NUM : hid_iap_desc.h
  • HIDIAP_BINTERVAL_TIME : hid_iap_desc.h
  • HIST_LENGTH : project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • http_add_connection : httpd.c
  • HTTP_ALLOC_HTTP_STATE : httpd.c
  • HTTP_DATA_TO_SEND_BREAK : httpd.c
  • HTTP_DATA_TO_SEND_CONTINUE : httpd.c
  • HTTP_DATA_TO_SEND_FREED : httpd.c
  • http_find_error_file : httpd.c
  • HTTP_FREE_HTTP_STATE : httpd.c
  • HTTP_IS_DATA_VOLATILE : httpd.c
  • HTTP_IS_DYNAMIC_FILE : httpd.c
  • HTTP_IS_HDR_VOLATILE : httpd.c
  • HTTP_NO_DATA_TO_SEND : httpd.c
  • http_remove_connection : httpd.c


AT32F435/437 Firmwary Library: Globals

- i -

  • I2C1 : at32f435_437_i2c.h
  • I2C1_BASE : at32f435_437.h
  • I2C2 : at32f435_437_i2c.h
  • I2C2_BASE : at32f435_437.h
  • I2C3 : at32f435_437_i2c.h
  • I2C3_BASE : at32f435_437.h
  • I2C_ACKFAIL_FLAG : at32f435_437_i2c.h
  • I2C_ACKFIAL_INT : at32f435_437_i2c.h
  • I2C_ADDR_INT : at32f435_437_i2c.h
  • I2C_ADDRF_FLAG : at32f435_437_i2c.h
  • I2C_ALERTF_FLAG : at32f435_437_i2c.h
  • I2C_ARLOST_FLAG : at32f435_437_i2c.h
  • I2C_BUSERR_FLAG : at32f435_437_i2c.h
  • I2C_BUSYF_FLAG : at32f435_437_i2c.h
  • I2C_END : i2c_application.c
  • I2C_ERR_INT : at32f435_437_i2c.h
  • I2C_EVENT_CHECK_ACKFAIL : i2c_application.h
  • I2C_EVENT_CHECK_NONE : i2c_application.h
  • I2C_EVENT_CHECK_STOP : i2c_application.h
  • I2C_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • I2C_OUF_FLAG : at32f435_437_i2c.h
  • I2C_PECERR_FLAG : at32f435_437_i2c.h
  • I2C_RD_INT : at32f435_437_i2c.h
  • I2C_RDBF_FLAG : at32f435_437_i2c.h
  • I2C_SDIR_FLAG : at32f435_437_i2c.h
  • I2C_START : i2c_application.c
  • I2C_STOP_INT : at32f435_437_i2c.h
  • I2C_STOPF_FLAG : at32f435_437_i2c.h
  • I2C_TCRLD_FLAG : at32f435_437_i2c.h
  • I2C_TD_INT : at32f435_437_i2c.h
  • I2C_TDBE_FLAG : at32f435_437_i2c.h
  • I2C_TDC_FLAG : at32f435_437_i2c.h
  • I2C_TDC_INT : at32f435_437_i2c.h
  • I2C_TDIS_FLAG : at32f435_437_i2c.h
  • I2C_TIMEOUT : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2C_TMOUT_FLAG : at32f435_437_i2c.h
  • I2Cx_ADDRESS : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_CLK : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_CLKCTRL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_DMA : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_CLK : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_RX_Channel : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_RX_DMAMUX_Channel : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_RX_DMAREQ : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_RX_IRQHandler : project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/eeprom/src/at32f435_437_int.c
  • I2Cx_DMA_RX_IRQn : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_TX_Channel : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_TX_DMAMUX_Channel : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_TX_DMAREQ : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_TX_IRQHandler : project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/eeprom/src/at32f435_437_int.c
  • I2Cx_DMA_TX_IRQn : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • I2Cx_ERR_IRQHandler : project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/eeprom/src/at32f435_437_int.c
  • I2Cx_ERR_IRQn : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • I2Cx_EVT_IRQHandler : project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/eeprom/src/at32f435_437_int.c
  • I2Cx_EVT_IRQn : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • I2Cx_PORT : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_SCL_GPIO_AF : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c
  • I2Cx_SCL_GPIO_CLK : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_SCL_GPIO_MUX : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_SCL_GPIO_PIN : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_SCL_GPIO_PinsSource : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_SCL_GPIO_PORT : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_SDA_GPIO_AF : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c
  • I2Cx_SDA_GPIO_CLK : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_SDA_GPIO_MUX : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_SDA_GPIO_PIN : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_SDA_GPIO_PinsSource : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_SDA_GPIO_PORT : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2S1_CK_GPIO_MUX : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S1_CK_PIN : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S1_CK_PIN_SOURCE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S1_DT_ADDRESS : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S1_GPIO : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S1_GPIO_CRM_CLK : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S1_SD_GPIO_MUX : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S1_SD_PIN : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S1_SD_PIN_SOURCE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S1_WS_GPIO_MUX : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S1_WS_PIN : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S1_WS_PIN_SOURCE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2_CK_GPIO_MUX : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2_CK_PIN : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2_CK_PIN_SOURCE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2_DT_ADDRESS : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2_GPIO : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2_GPIO_CRM_CLK : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2_SD_GPIO_MUX : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2_SD_PIN : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2_SD_PIN_SOURCE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2_WS_GPIO_MUX : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2_WS_PIN : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2_WS_PIN_SOURCE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2EXT : at32f435_437_spi.h
  • I2S2EXT_BASE : at32f435_437.h
  • I2S3EXT : at32f435_437_spi.h
  • I2S3EXT_BASE : at32f435_437.h
  • I2S_ACS_FLAG : at32f435_437_spi.h
  • I2S_TUERR_FLAG : at32f435_437_spi.h
  • IAP_ACK : hid_iap_class.h
  • IAP_CMD_ADDR : hid_iap_class.h
  • IAP_CMD_CRC : hid_iap_class.h
  • IAP_CMD_DATA : hid_iap_class.h
  • IAP_CMD_FINISH : hid_iap_class.h
  • IAP_CMD_GET : hid_iap_class.h
  • IAP_CMD_IDLE : hid_iap_class.h
  • IAP_CMD_JMP : hid_iap_class.h
  • IAP_CMD_START : hid_iap_class.h
  • IAP_FAILED : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • IAP_NACK : hid_iap_class.h
  • IAP_REV_FLAG_5A : app_led3_toggle/inc/usart.h, app_led4_toggle/inc/usart.h
  • IAP_REV_FLAG_DONE : app_led3_toggle/inc/usart.h, app_led4_toggle/inc/usart.h
  • IAP_REV_FLAG_ERROR : app_led3_toggle/inc/usart.h, app_led4_toggle/inc/usart.h
  • IAP_REV_FLAG_NO : app_led3_toggle/inc/usart.h, app_led4_toggle/inc/usart.h
  • IAP_SUCCESS : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • IAP_UPGRADE_COMPLETE_FLAG : hid_iap_class.h, at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • IAP_UPGRADE_FLAG : at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h, at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/iap.h, at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h, at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/iap.h, at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h
  • IAP_UPGRADE_FLAG_ADDR : at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h, at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/iap.h, at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h, at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/iap.h, at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h
  • IMG_CONSTANT : at_start_f435/examples/cortex_m4/fpu/inc/julia_fpu.h, at_start_f437/examples/cortex_m4/fpu/inc/julia_fpu.h
  • INCLUDE_uxTaskPriorityGet : FreeRTOSConfig.h
  • INCLUDE_vTaskCleanUpResources : FreeRTOSConfig.h
  • INCLUDE_vTaskDelay : FreeRTOSConfig.h
  • INCLUDE_vTaskDelayUntil : FreeRTOSConfig.h
  • INCLUDE_vTaskDelete : FreeRTOSConfig.h
  • INCLUDE_vTaskPrioritySet : FreeRTOSConfig.h
  • INCLUDE_vTaskSuspend : FreeRTOSConfig.h
  • INCLUDE_xTaskGetCurrentTaskHandle : FreeRTOSConfig.h
  • INTERNAL_FLASH_LUN : at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h, at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h
  • INVAILD_OFFSET_ADDR : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • INVALID_COMMAND : cdc_msc_class.h, msc_bot_scsi.h
  • INVALID_FIELD_IN_PARAMETER_LIST : cdc_msc_class.h, msc_bot_scsi.h
  • INVALID_FIELED_IN_COMMAND : cdc_msc_class.h, msc_bot_scsi.h
  • ITERATION : at_start_f435/examples/cortex_m4/fpu/inc/julia_fpu.h, at_start_f437/examples/cortex_m4/fpu/inc/julia_fpu.h


AT32F435/437 Firmwary Library: Globals

- j -

  • JUMBO_FRAME_PAYLOAD : at32f435_437_emac.h


AT32F435/437 Firmwary Library: Globals

- k -

  • KB_TO_B : hid_iap_class.h
  • KEYBOARD_BCD_NUM : keyboard_desc.h
  • KEYBOARD_BINTERVAL_TIME : keyboard_desc.h
  • KEYBOARD_LEFT_ALT : usbh_hid_keyboard.h
  • KEYBOARD_LEFT_CTRL : usbh_hid_keyboard.h
  • KEYBOARD_LEFT_GUI : usbh_hid_keyboard.h
  • KEYBOARD_LEFT_SHIFT : usbh_hid_keyboard.h
  • KEYBOARD_MAX_NB_PRESSED : usbh_hid_keyboard.h
  • KEYBOARD_RIGHT_ALT : usbh_hid_keyboard.h
  • KEYBOARD_RIGHT_CTRL : usbh_hid_keyboard.h
  • KEYBOARD_RIGHT_GUI : usbh_hid_keyboard.h
  • KEYBOARD_RIGHT_SHIFT : usbh_hid_keyboard.h


AT32F435/437 Firmwary Library: Globals

- l -

  • LAYOUT_OVERRIDE_BUFFER : flash_loader_extra.h
  • LBYTE : usb_std.h
  • LCD_BL_HIGH : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • LCD_BL_LOW : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • LCD_H : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h
  • LCD_RESET_HIGH : at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h
  • LCD_RESET_LOW : at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h
  • LCD_W : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h
  • LED_NUM : at32f435_437_board.h
  • LEFT_BUTTON : mouse_class.h
  • LEFT_MOVE : mouse_class.h
  • LIGHT_SWITCH : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • LINK_DETECTION : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • LIST_COUNT : project/at_start_f435/examples/edma/link_list_mode/src/main.c, project/at_start_f437/examples/edma/link_list_mode/src/main.c
  • LOGIN_SIZE : httpserver.h
  • LOST_VAL : at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c, at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c
  • LWIP_DHCP : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_DNS : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_HAVE_LOOPIF : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_HTTPD_URI_BUF_LEN : httpd.c
  • LWIP_IGMP : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_IPV4 : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_MDNS_RESPONDER : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_MEM_ILLEGAL_FREE : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_NETBUF_RECVINFO : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_NETCONN : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_NETCONN_FULLDUPLEX : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_NETIF_LINK_CALLBACK : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_NUM_NETIF_CLIENT_DATA : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_SOCKET : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_TCP : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_WND_SCALE : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h


AT32F435/437 Firmwary Library: Globals

- m -

  • MAC_ADDR_LENGTH : project/at_start_f437/examples/emac/dns_client/src/netconf.c, project/at_start_f437/examples/emac/http_server/src/netconf.c, project/at_start_f437/examples/emac/iperf/src/netconf.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_server/src/netconf.c, project/at_start_f437/examples/emac/telnet/src/netconf.c, project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • MAGENTA : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • MAKE_VALUE : at32f435_437.h
  • MASTER_BOARD : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c
  • MATCH_ID_VAL : project/at_start_f435/examples/usart/receiver_mute/src/main.c, project/at_start_f437/examples/usart/receiver_mute/src/main.c
  • MAX : usb_std.h
  • MAX_ARG_SIZE : flash_loader.c, flash_config.h
  • MAX_ARGS : flash_loader.c, flash_config.h
  • MAX_NAME_SIZE : telnet.c
  • MAX_TRANSFER_CNT : at32f435_437_i2c.h
  • MCU_ID1 : audio_desc.h, audio_hid_desc.h, cdc_desc.h, cdc_keyboard_desc.h, cdc_msc_desc.h, custom_hid_desc.h, hid_iap_desc.h, keyboard_desc.h, mouse_desc.h, msc_desc.h, printer_desc.h
  • MCU_ID2 : audio_desc.h, audio_hid_desc.h, cdc_desc.h, cdc_keyboard_desc.h, cdc_msc_desc.h, custom_hid_desc.h, hid_iap_desc.h, keyboard_desc.h, mouse_desc.h, msc_desc.h, printer_desc.h
  • MCU_ID3 : audio_desc.h, audio_hid_desc.h, cdc_desc.h, cdc_keyboard_desc.h, cdc_msc_desc.h, custom_hid_desc.h, hid_iap_desc.h, keyboard_desc.h, mouse_desc.h, msc_desc.h, printer_desc.h
  • MEDIUM_HAVE_CHANGED : cdc_msc_class.h, msc_bot_scsi.h
  • MEDIUM_NOT_PRESENT : cdc_msc_class.h, msc_bot_scsi.h
  • MEM_ALIGNMENT : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • MEM_SIZE : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • MEMP_NUM_SYS_TIMEOUT : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • MEMP_NUM_TCP_SEG : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • MIB2_STATS : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • MIC_BUFFER_SIZE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • MIN : usb_std.h
  • MIN_REQ_LEN : httpd.c
  • MISC_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • MMC_RX_ALIGN_ERROR : at32f435_437_emac.h
  • MMC_RX_CRC_ERROR : at32f435_437_emac.h
  • MMC_RX_GOOD_UNICAST : at32f435_437_emac.h
  • MMC_SWITCH_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • MMC_TX_GOOD_FRAMES : at32f435_437_emac.h
  • MMC_TX_MULTIPLE_COL : at32f435_437_emac.h
  • MMC_TX_SINGLE_COL : at32f435_437_emac.h
  • MOUSE_BCD_NUM : mouse_desc.h
  • MOUSE_BINTERVAL_TIME : mouse_desc.h
  • MOUSE_BUTTON_LEFT : usbh_hid_mouse.h
  • MOUSE_BUTTON_MIDDLE : usbh_hid_mouse.h
  • MOUSE_BUTTON_RIGHT : usbh_hid_mouse.h
  • MOUSE_WINDOW_HEIGHT : usbh_hid_mouse.h
  • MOUSE_WINDOW_WIDTH : usbh_hid_mouse.h
  • MOUSE_WINDOW_X : usbh_hid_mouse.h
  • MOUSE_WINDOW_Y : usbh_hid_mouse.h
  • MOVE_STEP : mouse_class.h
  • MQTT_SERVER_ADDRESS : mqtt_client.h
  • MQTT_SERVER_PORT : mqtt_client.h
  • MS_TICK : project/at_start_f435/examples/cortex_m4/systick_interrupt/src/main.c, project/at_start_f437/examples/cortex_m4/systick_interrupt/src/main.c
  • MSC_BCD_NUM : msc_desc.h
  • MSC_BOT_STATE_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_BOT_STATE_IDLE : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_BOT_STATE_RECOVERY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CAPACITY10_CMD_LEN : usbh_msc_bot_scsi.h
  • MSC_CAPACITY10_DATA_LEN : usbh_msc_bot_scsi.h
  • MSC_CBW_CB_LEN : usbh_msc_bot_scsi.h
  • MSC_CBW_FLAG_IN : usbh_msc_bot_scsi.h
  • MSC_CBW_FLAG_OUT : usbh_msc_bot_scsi.h
  • MSC_CBW_LEN : usbh_msc_bot_scsi.h
  • MSC_CBW_SIGNATURE : usbh_msc_bot_scsi.h
  • MSC_CBW_TAG : usbh_msc_bot_scsi.h
  • MSC_CMD_ALLOW_MEDIUM_REMOVAL : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_FORMAT_UNIT : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_INQUIRY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_MODE_SENSE10 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_MODE_SENSE6 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_READ_10 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_READ_12 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_READ_CAPACITY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_READ_FORMAT_CAPACITY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_REQUEST_SENSE : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_START_STOP : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_TEST_UNIT : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_VERIFY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_WRITE_10 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_WRITE_12 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_WRITE_VERIFY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CSW_LEN : usbh_msc_bot_scsi.h
  • MSC_CSW_SIGNATURE : usbh_msc_bot_scsi.h
  • MSC_INQUIRY_CMD_LEN : usbh_msc_bot_scsi.h
  • MSC_INQUIRY_DATA_LEN : usbh_msc_bot_scsi.h
  • MSC_MAX_DATA_BUF_LEN : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_OPCODE_CAPACITY : usbh_msc_bot_scsi.h
  • MSC_OPCODE_INQUIRY : usbh_msc_bot_scsi.h
  • MSC_OPCODE_READ10 : usbh_msc_bot_scsi.h
  • MSC_OPCODE_REQUEST_SENSE : usbh_msc_bot_scsi.h
  • MSC_OPCODE_TEST_UNIT_READY : usbh_msc_bot_scsi.h
  • MSC_OPCODE_WRITE10 : usbh_msc_bot_scsi.h
  • MSC_PROTOCOL_BBB : usbh_msc_class.h
  • MSC_READ_CMD_LEN : usbh_msc_bot_scsi.h
  • MSC_REQ_BO_RESET : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_REQ_BOMSR : usbh_msc_class.h
  • MSC_REQ_GET_MAX_LUN : cdc_msc_class.h, msc_bot_scsi.h, usbh_msc_class.h
  • MSC_REQUEST_SENSE_CMD_LEN : usbh_msc_bot_scsi.h
  • MSC_REQUEST_SENSE_DATA_LEN : usbh_msc_bot_scsi.h
  • MSC_STATE_MACHINE_CMD : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_DATA_IN : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_DATA_OUT : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_FAILED : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_IDLE : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_LAST_DATA : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_SEND_DATA : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_STATUS : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_SUBCLASS_SCSI_TRANS : usbh_msc_class.h
  • MSC_SUPPORT_MAX_LUN : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_TEST_UNIT_READY_CMD_LEN : usbh_msc_bot_scsi.h
  • MSC_TEST_UNIT_READY_DATA_LEN : usbh_msc_bot_scsi.h
  • MSC_WRITE_CMD_LEN : usbh_msc_bot_scsi.h
  • MULTI_BUFFER_SIZE : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c


AT32F435/437 Firmwary Library: Globals

- n -

  • NAND_BUSY : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_CMD_AREA_A : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_CMD_AREA_B : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_CMD_AREA_C : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_CMD_AREA_TRUE1 : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_CMD_ERASE0 : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_CMD_ERASE1 : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_CMD_LOCK_STATUS : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_CMD_READID : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_CMD_RESET : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_CMD_STATUS : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_CMD_WRITE0 : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_CMD_WRITE_TRUE1 : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_ERROR : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_INVALID_ADDRESS : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_READY : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_TIMEOUT_ERROR : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_VALID_ADDRESS : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NO_SYS : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • NOR_WRITE : at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c
  • NULL : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • NUM_DEFAULT_FILENAMES : httpd.c
  • NUM_TAPS : fir_coefficient.c, fir_filter.c
  • NUMSTUDENTS : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • NUMSUBJECTS : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • NVIC_VECTTAB_FLASH : at32f435_437_misc.h
  • NVIC_VECTTAB_RAM : at32f435_437_misc.h


AT32F435/437 Firmwary Library: Globals

- o -

  • ONCHIP : FlashOS.h
  • OPERATION_TIMEOUT : at32f435_437_flash.h
  • OPTIONAL_CHECKSUM : flash_loader.h
  • OPTIONAL_SIGNOFF : flash_loader.h
  • OTG1_GLOBAL : at32f435_437_usb.h
  • OTG2_CLOCK : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_GLOBAL : at32f435_437_usb.h
  • OTG2_IRQ : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_IRQ_HANDLER : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_DM : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_DM_SOURCE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_DP : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_DP_SOURCE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_GPIO : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_GPIO_CLOCK : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_ID : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_ID_SOURCE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_MUX : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_POWER_SWITCH : project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_POWER_SWITCH_CLOCK : project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_POWER_SWITCH_GPIO : project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_SOF : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_SOF_GPIO : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_SOF_GPIO_CLOCK : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_SOF_SOURCE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_VBUS : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_VBUS_SOURCE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_WKUP_EXINT_LINE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_WKUP_HANDLER : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_WKUP_IRQ : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG_CLOCK : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_DEVICE : at32f435_437_usb.h
  • OTG_DEVICE_ADDR_OFFSET : at32f435_437_usb.h
  • OTG_DEVICE_EPTIN_ADDR_OFFSET : at32f435_437_usb.h
  • OTG_DEVICE_EPTOUT_ADDR_OFFSET : at32f435_437_usb.h
  • OTG_FIFO_ADDR_OFFSET : at32f435_437_usb.h
  • OTG_FIFO_SIZE : at32f435_437_usb.h
  • OTG_HOST : at32f435_437_usb.h
  • OTG_HOST_ADDR_OFFSET : at32f435_437_usb.h
  • OTG_HOST_CHANNEL_ADDR_OFFSET : at32f435_437_usb.h
  • OTG_IRQ : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_IRQ_HANDLER : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PCGCCTL : at32f435_437_usb.h
  • OTG_PCGCCTL_ADDR_OFFSET : at32f435_437_usb.h
  • OTG_PIN_DM : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_DM_SOURCE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_DP : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_DP_SOURCE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_GPIO : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_GPIO_CLOCK : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_ID : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_ID_SOURCE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_MUX : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_POWER_SWITCH : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG_PIN_POWER_SWITCH_CLOCK : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG_PIN_POWER_SWITCH_GPIO : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG_PIN_SOF : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_SOF_GPIO : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_SOF_GPIO_CLOCK : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_SOF_SOURCE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_VBUS : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_VBUS_SOURCE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_USB_ID : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_WKUP_EXINT_LINE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_WKUP_HANDLER : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_WKUP_IRQ : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTGFS1_BASE : at32f435_437.h
  • OTGFS2_BASE : at32f435_437.h
  • OTGFS_USB_DEVICE : at32f435_437_usb.h
  • OTGFS_USB_GLOBAL : at32f435_437_usb.h
  • OTGFS_USB_HOST : at32f435_437_usb.h
  • OV2640_ADDR : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_BPADDR : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_BPDATA : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_CTRL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_CTRL0 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_CTRL1 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_CTRL2 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_CTRL3 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_DPRP : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_HSIZE1 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_HSIZE2 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_IMAGE_MODE : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_MC_AH : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_MC_AL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_MC_BIST : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_MC_D : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_MS_SP : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_P_STATUS : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_Qs : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_R_BYPASS : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_R_DVP_SP : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_RA_DLMT : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_RESET : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_SIZEL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_SS_CTRL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_SS_ID : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_TEST : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_VHYX : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_VSIZE1 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_VSIZE2 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_XOFFL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_YOFFL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_ZMHH : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_ZMOH : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_ZMOW : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_MID : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_PID : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_PWRON_HIGH : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_PWRON_LOW : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_RST_HIGH : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_RST_LOW : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_ADDVHS : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_ADDVSL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_AEB : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_AEC : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_AEW : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_ARCOM2 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_BD50 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_BD60 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_CLKRC : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_COM1 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_COM10 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_COM19 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_COM2 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_COM22 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_COM25 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_COM3 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_COM4 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_COM7 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_COM8 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_COM9 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_FLH : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_FLL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_FRARL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_GAIN : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_HISTO_HIGH : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_HISTO_LOW : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_HREFEND : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_HREFST : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_MIDH : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_MIDL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_PIDH : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_PIDL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_REG04 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_REG08 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_REG2A : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_REG32 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_REG45 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_REG5D : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_REG5E : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_REG5F : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_REG60 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_VEND : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_VSTART : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_W : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_YAVG : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_ZOOMS : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV5640_ADDR : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • OV5640_CHIPIDH : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • OV5640_CHIPIDL : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • OV5640_ID : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • OV5640_RST_HIGH : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • OV5640_RST_LOW : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • OVERRIDE_BUFSIZE : flash_loader_extra.h
  • OVERRIDE_LAYOUT : flash_loader_extra.h
  • OVERRIDE_PAGESIZE : flash_loader_extra.h


AT32F435/437 Firmwary Library: Globals

- p -

  • PAGE_MAX : FlashOS.h
  • PARAMETER_LIST_LENGTH_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • PASSWORD : httpserver.h
  • PBUF_POOL_BUFSIZE : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • PBUF_POOL_SIZE : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • PEMOPC_RESET : at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c
  • PEMOPC_SET : at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c
  • PEN_HIGH : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h
  • PERIPH_BASE : at32f435_437.h
  • PERIPH_BB_BASE : at32f435_437.h
  • PERIPH_REG : at32f435_437.h
  • PERIPH_REG_BIT : at32f435_437.h
  • PERIPHERAL_BASE : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f437/examples/cortex_m4/bit_band/src/main.c
  • PERIPHERAL_BITBAND_BASE : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f437/examples/cortex_m4/bit_band/src/main.c
  • PERIPHERAL_RESET_BIT : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f437/examples/cortex_m4/bit_band/src/main.c
  • PERIPHERAL_SET_BIT : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f437/examples/cortex_m4/bit_band/src/main.c
  • PHY_ADDRESS : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_AUTO_NEGOTIATION_BIT : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_CONTROL_REG : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_FULL_DUPLEX_100MBPS_BIT : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_FULL_DUPLEX_10MBPS_BIT : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_HALF_DUPLEX_100MBPS_BIT : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_HALF_DUPLEX_10MBPS_BIT : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_LINKED_STATUS_BIT : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_LOOPBACK_BIT : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_NEGO_COMPLETE_BIT : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_RESET_BIT : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_SPECIFIED_CS_REG : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_STATUS_REG : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_TIMEOUT : at32f435_437_emac.h
  • PKTSTS_CHANNEL_STOP : at32f435_437_usb.h
  • PKTSTS_DATA_BIT_ERROR : at32f435_437_usb.h
  • PKTSTS_IN_DATA_PACKET_RECV : at32f435_437_usb.h
  • PKTSTS_IN_TRANSFER_COMPLETE : at32f435_437_usb.h
  • PRINT_UART : at32f435_437_board.h
  • PRINT_UART_CRM_CLK : at32f435_437_board.h
  • PRINT_UART_TX_GPIO : at32f435_437_board.h
  • PRINT_UART_TX_GPIO_CRM_CLK : at32f435_437_board.h
  • PRINT_UART_TX_PIN : at32f435_437_board.h
  • PRINT_UART_TX_PIN_MUX_NUM : at32f435_437_board.h
  • PRINT_UART_TX_PIN_SOURCE : at32f435_437_board.h
  • PRINTER_BCD_NUM : printer_desc.h
  • PRINTER_DEVICE_ID_LEN : printer_class.h
  • PRINTER_PROTOCOL_1284_4 : printer_desc.h
  • PRINTER_PROTOCOL_BI_DIRECTIONAL : printer_desc.h
  • PRINTER_PROTOCOL_UNIDIRECTIONAL : printer_desc.h
  • PRINTER_PROTOCOL_VENDOR_SPECIFIC : printer_desc.h
  • PROGRAM_TIMEOUT : at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c
  • PROGRAMMING_TIMEOUT : at32f435_437_flash.h
  • PUTCHAR_PROTOTYPE : at32f435_437_board.c
  • PWC : at32f435_437_pwc.h
  • PWC_BASE : at32f435_437.h
  • pwc_ldo_output_voltage_set : at32f435_437_pwc.h
  • PWC_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • PWC_PVM_OUTPUT_FLAG : at32f435_437_pwc.h
  • PWC_STANDBY_FLAG : at32f435_437_pwc.h
  • PWC_WAKEUP_FLAG : at32f435_437_pwc.h
  • PWC_WAKEUP_PIN_1 : at32f435_437_pwc.h
  • PWC_WAKEUP_PIN_2 : at32f435_437_pwc.h


AT32F435/437 Firmwary Library: Globals

- q -

  • QSPI1 : at32f435_437_qspi.h
  • QSPI1_MEM_BASE : at32f435_437.h
  • QSPI1_REG_BASE : at32f435_437.h
  • QSPI2 : at32f435_437_qspi.h
  • QSPI2_MEM_BASE : at32f435_437.h
  • QSPI2_REG_BASE : at32f435_437.h
  • QSPI_CMDSTS_FLAG : at32f435_437_qspi.h
  • QSPI_FIFO_DEPTH : at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c
  • QSPI_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • QSPI_RXFIFORDY_FLAG : at32f435_437_qspi.h
  • QSPI_TXFIFORDY_FLAG : at32f435_437_qspi.h
  • QUIZ_MESSAGE : tcp_server.h
  • QWERTY_KEYBOARD : usbh_hid_keyboard.h


AT32F435/437 Firmwary Library: Globals

- r -

  • RAM_BASE : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f437/examples/cortex_m4/bit_band/src/main.c
  • RAM_BITBAND_BASE : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f437/examples/cortex_m4/bit_band/src/main.c
  • READ_TIMES : at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c, at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c
  • REAL_CONSTANT : at_start_f435/examples/cortex_m4/fpu/inc/julia_fpu.h, at_start_f437/examples/cortex_m4/fpu/inc/julia_fpu.h
  • RED : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • REG16 : at32f435_437.h
  • REG32 : at32f435_437.h
  • REG8 : at32f435_437.h
  • REQ_SENSE_STANDARD_DATA_LEN : cdc_msc_class.h, msc_bot_scsi.h
  • RESULT_CUSTOM_FIRST : flash_loader.h
  • RESULT_CUSTOM_LAST : flash_loader.h
  • RESULT_ERASE_DONE : flash_loader.h
  • RESULT_ERROR : flash_loader.h
  • RESULT_OK : flash_loader.h
  • RESULT_OVERRIDE_DEVICE : flash_loader.h
  • RIGHT_BUTTON : mouse_class.h
  • RIGHT_MOVE : mouse_class.h
  • RMII_MODE : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • ROW_ADDRESS : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • RS485_BAUDRATE : project/at_start_f435/examples/usart/rs485/src/main.c, project/at_start_f437/examples/usart/rs485/src/main.c
  • RS485_BUFFER_SIZE : project/at_start_f435/examples/usart/rs485/src/main.c, project/at_start_f437/examples/usart/rs485/src/main.c
  • RX_REMAP : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • RXBUF_SIZE : project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c


AT32F435/437 Firmwary Library: Globals

- s -

  • SAMPLE_FREQ : audio_desc.h, audio_hid_desc.h
  • SAMPLING_NUM : project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c
  • SC_3_5V_CLK : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_3_5V_PIN : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_3_5V_PORT : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_CMDVCC_CLK : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_CMDVCC_PIN : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_CMDVCC_PORT : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_F_DIV_D : project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • SC_OFF_CLK : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_OFF_EXINT : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_OFF_EXINT_IRQ : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_OFF_PIN : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_OFF_PINSOURCE : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_OFF_PORT : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_OFF_PORTSOURCE : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_RECEIVE_TIMEOUT : project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • SC_RESET_CLK : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_RESET_PIN : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_RESET_PORT : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_USART : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_USART_CLK : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_USART_CLK_PIN : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_USART_CLK_PORT : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_USART_DIV_VAL : project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • SC_USART_GPIO_CLK : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_USART_IRQHandler : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_USART_IRQn : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_USART_TX_PIN : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_USART_TX_PORT : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SCCB_ID : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_READ_SDA : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_SCL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_SDA : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_SDA_IN : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_SDA_OUT : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCFG : at32f435_437_scfg.h
  • SCFG_BASE : at32f435_437.h
  • SCFG_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • SCFG_REG : at32f435_437_scfg.h
  • SCFG_REG_BIT : at32f435_437_scfg.h
  • SCREEN_X_SIZE : project/at_start_f435/examples/cortex_m4/fpu/src/main.c, project/at_start_f437/examples/cortex_m4/fpu/src/main.c
  • SCREEN_Y_SIZE : project/at_start_f435/examples/cortex_m4/fpu/src/main.c, project/at_start_f437/examples/cortex_m4/fpu/src/main.c
  • SCSI_INQUIRY_DATA_LENGTH : cdc_msc_class.h, msc_bot_scsi.h
  • SD_0TO7BITS : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_16TO23BITS : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_24TO31BITS : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_8TO15BITS : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_ALLZERO : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_LOCKED : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_PROGRAMMING : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_RECEIVING : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CCCC_ERASE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CCCC_LOCK_UNLOCK : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CCCC_WRITE_PROT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CHECK_PATTERN : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_ALL_SEND_CID : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_APP_CMD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_APP_SD_SET_BUSWIDTH : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_CLR_WRITE_PROT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_ERASE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_ERASE_GRP_END : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_ERASE_GRP_START : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_FAST_IO : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_GEN_CMD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_GO_IDLE_STATE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_GO_INACTIVE_STATE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_GO_IRQ_STATE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_HS_BUSTEST_READ : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_HS_BUSTEST_WRITE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_HS_SEND_EXT_CSD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_HS_SWITCH : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_LOCK_UNLOCK : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_NO_CMD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_PROG_CID : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_PROG_CSD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_READ_DAT_UNTIL_STOP : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_READ_MULT_BLOCK : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_READ_SINGLE_BLOCK : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_CHANGE_SECURE_AREA : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_GET_CER_RES1 : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_GET_CER_RN2 : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_GET_MID : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_GET_MKB : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_OP_COND : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SECURE_ERASE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SECURE_WRITE_MKB : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SEND_SCR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SET_CER_RES2 : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SET_CER_RN1 : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SET_CLR_CARD_DETECT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_STAUS : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_ERASE_GRP_END : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_ERASE_GRP_START : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SDIO_RW_DIRECT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SDIO_RW_EXTENDED : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SDIO_SEN_OP_COND : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEL_DESEL_CARD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_CID : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_CSD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_OP_COND : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_STATUS : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_WRITE_PROT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_BLOCK_COUNT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_BLOCKLEN : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_DSR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_REL_ADDR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_WRITE_PROT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_STOP_TRANSMISSION : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_WRITE_DAT_UNTIL_STOP : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_WRITE_MULT_BLOCK : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_WRITE_SINGLE_BLOCK : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_DATATIMEOUT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_HALFFIFO : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_HALFFIFOBYTES : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_HIGH_CAPACITY : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_LUN : at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h, at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h
  • SD_MAX_DATA_LENGTH : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_MAX_VOLT_TRIAL : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ADDR_MISALIGNED : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ADDR_OUT_OF_RANGE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_AKE_SEQ_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_BLK_LEN_ERR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CARD_CONTROLLER_ERR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CARD_ECC_DISABLED : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CARD_ECC_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CID_CSD_OVERWRIETE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CMD_CRC_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ERASE_RESET : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ERASE_SEQ_ERR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ERRORBITS : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_GENERAL_UNKNOWN_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ILLEGAL_CMD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_INVALID_ERASE_PARAM : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_LOCK_UNLOCK_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_STREAM_RD_UNDERRUN : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_STREAM_WR_OVERRUN : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_WP_ERASE_SKIP : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_WR_PROTECT_VIOLATION : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_R5_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_R5_FUNCTION_NUMBER : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_R5_OUT_OF_RANGE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_R6_CMD_CRC_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_R6_GENERAL_UNKNOWN_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_R6_ILLEGAL_CMD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_SINGLE_BUS_SUPPORT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_STD_CAPACITY : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_VOLTAGE_WINDOW_MMC : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_VOLTAGE_WINDOW_SD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_WIDE_BUS_SUPPORT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO1 : at32f435_437_sdio.h
  • SDIO1_BASE : at32f435_437.h
  • SDIO2 : at32f435_437_sdio.h
  • SDIO2_BASE : at32f435_437.h
  • SDIO_CMD0TIMEOUT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_CMDCMPL_FLAG : at32f435_437_sdio.h
  • SDIO_CMDCMPL_INT : at32f435_437_sdio.h
  • SDIO_CMDFAIL_FLAG : at32f435_437_sdio.h
  • SDIO_CMDFAIL_INT : at32f435_437_sdio.h
  • SDIO_CMDRSPCMPL_FLAG : at32f435_437_sdio.h
  • SDIO_CMDRSPCMPL_INT : at32f435_437_sdio.h
  • SDIO_CMDTIMEOUT_FLAG : at32f435_437_sdio.h
  • SDIO_CMDTIMEOUT_INT : at32f435_437_sdio.h
  • SDIO_DATATIMEOUT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_DOCMD_FLAG : at32f435_437_sdio.h
  • SDIO_DOCMD_INT : at32f435_437_sdio.h
  • SDIO_DORX_FLAG : at32f435_437_sdio.h
  • SDIO_DORX_INT : at32f435_437_sdio.h
  • SDIO_DOTX_FLAG : at32f435_437_sdio.h
  • SDIO_DOTX_INT : at32f435_437_sdio.h
  • SDIO_DTBLKCMPL_FLAG : at32f435_437_sdio.h
  • SDIO_DTBLKCMPL_INT : at32f435_437_sdio.h
  • SDIO_DTCMP_INT : at32f435_437_sdio.h
  • SDIO_DTCMPL_FLAG : at32f435_437_sdio.h
  • SDIO_DTFAIL_FLAG : at32f435_437_sdio.h
  • SDIO_DTFAIL_INT : at32f435_437_sdio.h
  • SDIO_DTTIMEOUT_FLAG : at32f435_437_sdio.h
  • SDIO_DTTIMEOUT_INT : at32f435_437_sdio.h
  • SDIO_FIFO_Address : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_INTR_STS_READ_MASK : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_INTR_STS_WRITE_MASK : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • SDIO_RXBUF_FLAG : at32f435_437_sdio.h
  • SDIO_RXBUF_INT : at32f435_437_sdio.h
  • SDIO_RXBUFE_FLAG : at32f435_437_sdio.h
  • SDIO_RXBUFE_INT : at32f435_437_sdio.h
  • SDIO_RXBUFF_FLAG : at32f435_437_sdio.h
  • SDIO_RXBUFF_INT : at32f435_437_sdio.h
  • SDIO_RXBUFH_FLAG : at32f435_437_sdio.h
  • SDIO_RXBUFH_INT : at32f435_437_sdio.h
  • SDIO_RXERRO_FLAG : at32f435_437_sdio.h
  • SDIO_RXERRO_INT : at32f435_437_sdio.h
  • SDIO_SBITERR_FLAG : at32f435_437_sdio.h
  • SDIO_SBITERR_INT : at32f435_437_sdio.h
  • SDIO_SDIOIF_FLAG : at32f435_437_sdio.h
  • SDIO_SDIOIF_INT : at32f435_437_sdio.h
  • SDIO_SEND_IF_COND : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_STATIC_FLAGS : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_TXBUF_FLAG : at32f435_437_sdio.h
  • SDIO_TXBUF_INT : at32f435_437_sdio.h
  • SDIO_TXBUFE_FLAG : at32f435_437_sdio.h
  • SDIO_TXBUFE_INT : at32f435_437_sdio.h
  • SDIO_TXBUFF_FLAG : at32f435_437_sdio.h
  • SDIO_TXBUFF_INT : at32f435_437_sdio.h
  • SDIO_TXBUFH_FLAG : at32f435_437_sdio.h
  • SDIO_TXBUFH_INT : at32f435_437_sdio.h
  • SDIO_TXERRU_FLAG : at32f435_437_sdio.h
  • SDIO_TXERRU_INT : at32f435_437_sdio.h
  • SDIOx : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDRAM_BANK1_ADDR : at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c, at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c, at_start_f437/examples/xmc/sdram_basic/src/xmc_sdram.c, at_start_f437/examples/xmc/sdram_dma/src/xmc_sdram.c
  • SDRAM_BURST_INTERLEAVED : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • SDRAM_BURST_LEN_1 : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • SDRAM_BURST_LEN_2 : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • SDRAM_BURST_LEN_4 : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • SDRAM_BURST_LEN_8 : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • SDRAM_BURST_SEQUENTIAL : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • SDRAM_CAS_LATENCY_1 : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • SDRAM_CAS_LATENCY_2 : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • SDRAM_CAS_LATENCY_3 : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • SDRAM_OPERATING_MODE_STANDARD : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • SDRAM_WR_BURST_PROGRAMMED : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • SDRAM_WR_BURST_SINGLE : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • SECTOR_END : FlashOS.h
  • SECTOR_NUM : FlashOS.h, utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • SECTOR_SIZE : project/at_start_f435/examples/flash/flash_write_read/src/flash.c, project/at_start_f437/examples/flash/flash_write_read/src/flash.c
  • SECTOR_SIZE_1K : hid_iap_class.h, at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/msc/inc/msc_diskio.h
  • SECTOR_SIZE_2K : hid_iap_class.h, at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/msc/inc/msc_diskio.h
  • SECTOR_SIZE_4K : hid_iap_class.h, at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/msc/inc/msc_diskio.h
  • SECTOR_SIZE_INDEX : utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/flash.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/flash.h
  • SECTOR_WORD_CNT : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • SENSE_KEY_ABORTED_COMMAND : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_BLANK_CHECK : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_DATA_PROTECT : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_HARDWARE_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_ILLEGAL_REQUEST : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_MEDIUM_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_MISCOMPARE : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_NO_SENSE : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_NOT_READY : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_RECOVERED_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_UNIT_ATTENTION : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_VENDERO_SPECIFIC : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_VOLUME_OVERFLOW : cdc_msc_class.h, msc_bot_scsi.h
  • SET_BUFSIZE_OVERRIDE : flash_loader_extra.h
  • SET_LINE_CODING : usb_std.h, cdc_msc_class.h, msc_bot_scsi.h
  • SET_PAGESIZE_OVERRIDE : flash_loader_extra.h
  • SETUP_LENGTH : project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • SHIFT : cdc_keyboard_class.c, keyboard_class.c
  • SLIB_END_ADDR : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • SLIB_INST_ADDR : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • SLIB_START_ADDR : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • SLIB_UNLOCK_KEY : at32f435_437_flash.h
  • SLOW : project/at_start_f435/templates/src/main.c, project/at_start_f437/examples/emac/dns_client/src/main.c, project/at_start_f437/examples/emac/http_server/src/main.c, project/at_start_f437/examples/emac/iperf/src/main.c, project/at_start_f437/examples/emac/mqtt_client/src/main.c, project/at_start_f437/examples/emac/tcp_client/src/main.c, project/at_start_f437/examples/emac/tcp_server/src/main.c, project/at_start_f437/examples/emac/telnet/src/main.c, project/at_start_f437/examples/emac/wake_on_lan/src/main.c, project/at_start_f437/templates/src/main.c
  • SNR_THRESHOLD_F32 : utilities/at32f435_437_slib_demo/project_l0/src/main.c, utilities/at32f435_437_slib_demo/project_l1/src/main.c
  • SPI1 : at32f435_437_spi.h
  • SPI1_BASE : at32f435_437.h
  • SPI1_TX_BUFFER_SIZE : project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c
  • SPI2 : at32f435_437_spi.h
  • SPI2_BASE : at32f435_437.h
  • SPI3 : at32f435_437_spi.h
  • SPI3_BASE : at32f435_437.h
  • SPI4 : at32f435_437_spi.h
  • SPI4_BASE : at32f435_437.h
  • SPI_CCERR_FLAG : at32f435_437_spi.h
  • SPI_CSPAS_FLAG : at32f435_437_spi.h
  • SPI_FLASH_LUN : at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h, at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h
  • SPI_I2S_BF_FLAG : at32f435_437_spi.h
  • SPI_I2S_ERROR_INT : at32f435_437_spi.h
  • SPI_I2S_RDBF_FLAG : at32f435_437_spi.h
  • SPI_I2S_RDBF_INT : at32f435_437_spi.h
  • SPI_I2S_ROERR_FLAG : at32f435_437_spi.h
  • SPI_I2S_TDBE_FLAG : at32f435_437_spi.h
  • SPI_I2S_TDBE_INT : at32f435_437_spi.h
  • SPI_MMERR_FLAG : at32f435_437_spi.h
  • SPI_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • SPI_TRANS_DMA : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_BLOCKERASE : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_CHIP_SIZE : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_CHIPERASE : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_DEVICEID : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_FASTREADDATA : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_FASTREADDUAL : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_JEDECDEVICEID : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_MANUFACTDEVICEID : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_PAGE_SIZE : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_PAGEPROGRAM : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_POWERDOWN : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_READDATA : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_READSTATUSREG1 : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_READSTATUSREG2 : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_READSTATUSREG3 : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_RELEASEPOWERDOWN : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_SECTOR_SIZE : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_SECTORERASE : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_WRITEDISABLE : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_WRITEENABLE : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_WRITESTATUSREG1 : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_WRITESTATUSREG2 : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_WRITESTATUSREG3 : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPK_BUFFER_SIZE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • SPK_TX_FIFO_SIZE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • SRAM_BASE : at32f435_437.h
  • SRAM_BB_BASE : at32f435_437.h
  • SRAM_SIZE : utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/flash.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/flash.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/flash.h
  • STEP_DELAY_MS : at32f435_437_board.c
  • STREAM_BUFFER_SIZE : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c
  • SWAPBYTE : usb_std.h
  • SYS_LIGHTWEIGHT_PROT : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • SystemCoreClock : system_at32f435_437.h
  • SYSTEMTICK_PERIOD_MS : project/at_start_f437/examples/emac/dns_client/src/netconf.c, project/at_start_f437/examples/emac/http_server/src/netconf.c, project/at_start_f437/examples/emac/iperf/src/netconf.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_server/src/netconf.c, project/at_start_f437/examples/emac/telnet/src/netconf.c, project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c


AT32F435/437 Firmwary Library: Globals

- t -

  • T0_PROTOCOL : project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • TCLK_HIGH : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h
  • TCLK_LOW : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h
  • TCP_CLIENT_TEST_DATA : project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h
  • TCP_LOCAL_PORT : tcp_client.h, tcp_server.h
  • TCP_MSS : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • TCP_RCV_SCALE : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • TCP_SERVER_IP : tcp_client.h
  • TCP_SERVER_PORT : tcp_client.h
  • TCP_SND_BUF : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • TCP_SND_QUEUELEN : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • TCP_TTL : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • TCP_WND : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • TCS_HIGH : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h
  • TCS_LOW : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h
  • TDIN_HIGH : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h
  • TDIN_LOW : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h
  • TDOUT : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h
  • TELNET_IP_ADDR_0 : telnet.h
  • TELNET_IP_ADDR_1 : telnet.h
  • TELNET_IP_ADDR_2 : telnet.h
  • TELNET_IP_ADDR_3 : telnet.h
  • TEST_BUFEER_SIZE : project/at_start_f435/examples/flash/flash_write_read/src/main.c, project/at_start_f437/examples/flash/flash_write_read/src/main.c
  • TEST_FLASH_ADDRESS_START : project/at_start_f435/examples/flash/flash_write_read/src/main.c, project/at_start_f437/examples/flash/flash_write_read/src/main.c
  • TEST_LENGTH_SAMPLES : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c, utilities/at32f435_437_slib_demo/project_l0/src/main.c, utilities/at32f435_437_slib_demo/project_l1/src/main.c
  • TEST_SIZE : project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c, project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c, project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c, project/at_start_f437/examples/qspi/command_port_using_dma/src/main.c, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/main.c, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/main.c, project/at_start_f437/examples/qspi/command_port_using_interrupt/src/main.c, project/at_start_f437/examples/qspi/command_port_using_polling/src/main.c, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/main.c, project/at_start_f437/examples/qspi/xip_port_write_read/src/main.c
  • TEST_SLIB_PSW : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • TFTP_ACK_PKT_LEN : tftpserver.h
  • TFTP_BLKNUM_LEN : tftpserver.h
  • TFTP_DATA_LEN_MAX : tftpserver.h
  • TFTP_DATA_PKT_HDR_LEN : tftpserver.h
  • TFTP_DATA_PKT_LEN_MAX : tftpserver.h
  • TFTP_ERR_PKT_HDR_LEN : tftpserver.h
  • TFTP_MAX_RETRIES : tftpserver.h
  • TFTP_OPCODE_LEN : tftpserver.h
  • TFTP_TIMEOUT_INTERVAL : tftpserver.h
  • TMR1 : at32f435_437_tmr.h
  • TMR10 : at32f435_437_tmr.h
  • TMR10_BASE : at32f435_437.h
  • TMR11 : at32f435_437_tmr.h
  • TMR11_BASE : at32f435_437.h
  • TMR12 : at32f435_437_tmr.h
  • TMR12_BASE : at32f435_437.h
  • TMR13 : at32f435_437_tmr.h
  • TMR13_BASE : at32f435_437.h
  • TMR14 : at32f435_437_tmr.h
  • TMR14_BASE : at32f435_437.h
  • TMR1_BASE : at32f435_437.h
  • tmr1_c1dt_address : project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c
  • tmr1_c2dt_address : project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c
  • TMR2 : at32f435_437_tmr.h
  • TMR20 : at32f435_437_tmr.h
  • TMR20_BASE : at32f435_437.h
  • TMR2_BASE : at32f435_437.h
  • TMR3 : at32f435_437_tmr.h
  • TMR3_BASE : at32f435_437.h
  • TMR4 : at32f435_437_tmr.h
  • TMR4_BASE : at32f435_437.h
  • TMR5 : at32f435_437_tmr.h
  • TMR5_BASE : at32f435_437.h
  • TMR6 : at32f435_437_tmr.h
  • TMR6_BASE : at32f435_437.h
  • TMR7 : at32f435_437_tmr.h
  • TMR7_BASE : at32f435_437.h
  • TMR8 : at32f435_437_tmr.h
  • TMR8_BASE : at32f435_437.h
  • TMR9 : at32f435_437_tmr.h
  • TMR9_BASE : at32f435_437.h
  • TMR_BRK_FLAG : at32f435_437_tmr.h
  • TMR_BRK_INT : at32f435_437_tmr.h
  • TMR_C1_FLAG : at32f435_437_tmr.h
  • TMR_C1_INT : at32f435_437_tmr.h
  • TMR_C1_RECAPTURE_FLAG : at32f435_437_tmr.h
  • TMR_C2_FLAG : at32f435_437_tmr.h
  • TMR_C2_INT : at32f435_437_tmr.h
  • TMR_C2_RECAPTURE_FLAG : at32f435_437_tmr.h
  • TMR_C3_FLAG : at32f435_437_tmr.h
  • TMR_C3_INT : at32f435_437_tmr.h
  • TMR_C3_RECAPTURE_FLAG : at32f435_437_tmr.h
  • TMR_C4_FLAG : at32f435_437_tmr.h
  • TMR_C4_INT : at32f435_437_tmr.h
  • TMR_C4_RECAPTURE_FLAG : at32f435_437_tmr.h
  • TMR_C5_FLAG : at32f435_437_tmr.h
  • TMR_HALL_FLAG : at32f435_437_tmr.h
  • TMR_HALL_INT : at32f435_437_tmr.h
  • TMR_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • TMR_OVF_FLAG : at32f435_437_tmr.h
  • TMR_OVF_INT : at32f435_437_tmr.h
  • TMR_TRIGGER_FLAG : at32f435_437_tmr.h
  • TMR_TRIGGER_INT : at32f435_437_tmr.h
  • TXBUF_SIZE : project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c


AT32F435/437 Firmwary Library: Globals

- u -

  • UART4 : at32f435_437_usart.h
  • UART4_BASE : at32f435_437.h
  • UART5 : at32f435_437_usart.h
  • UART5_BASE : at32f435_437.h
  • UART7 : at32f435_437_usart.h
  • UART7_BASE : at32f435_437.h
  • UART8 : at32f435_437_usart.h
  • UART8_BASE : at32f435_437.h
  • UNKNOWN : FlashOS.h
  • UNUSED : at32f435_437_def.h
  • UP_MOVE : mouse_class.h
  • USART1 : at32f435_437_usart.h
  • USART1_BASE : at32f435_437.h
  • USART2 : at32f435_437_usart.h
  • USART2_BASE : at32f435_437.h
  • USART2_TX_BUFFER_SIZE : project/at_start_f435/examples/usart/half_duplex/src/main.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usart/half_duplex/src/main.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c
  • USART3 : at32f435_437_usart.h
  • USART3_BASE : at32f435_437.h
  • USART3_TX_BUFFER_SIZE : project/at_start_f435/examples/usart/half_duplex/src/main.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usart/half_duplex/src/main.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c
  • USART6 : at32f435_437_usart.h
  • USART6_BASE : at32f435_437.h
  • USART_BF_INT : at32f435_437_usart.h
  • USART_BFF_FLAG : at32f435_437_usart.h
  • usart_buffer_size : project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f437/examples/usb_device/virtual_comport/src/main.c
  • USART_CTSCF_FLAG : at32f435_437_usart.h
  • USART_CTSCF_INT : at32f435_437_usart.h
  • USART_ERR_INT : at32f435_437_usart.h
  • USART_FERR_FLAG : at32f435_437_usart.h
  • USART_IDLE_INT : at32f435_437_usart.h
  • USART_IDLEF_FLAG : at32f435_437_usart.h
  • USART_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • USART_NERR_FLAG : at32f435_437_usart.h
  • USART_PERR_FLAG : at32f435_437_usart.h
  • USART_PERR_INT : at32f435_437_usart.h
  • USART_RDBF_FLAG : at32f435_437_usart.h
  • USART_RDBF_INT : at32f435_437_usart.h
  • USART_REC_LEN : bootloader/inc/usart.h
  • USART_ROERR_FLAG : at32f435_437_usart.h
  • USART_TDBE_FLAG : at32f435_437_usart.h
  • USART_TDBE_INT : at32f435_437_usart.h
  • USART_TDC_FLAG : at32f435_437_usart.h
  • USART_TDC_INT : at32f435_437_usart.h
  • USB2_ID : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • USB_CHL : at32f435_437_usb.h
  • USB_CLASS_CODE_AUDIO : usb_std.h
  • USB_CLASS_CODE_CCID : usb_std.h
  • USB_CLASS_CODE_CDC : usb_std.h
  • USB_CLASS_CODE_CDCDATA : usb_std.h
  • USB_CLASS_CODE_HID : usb_std.h
  • USB_CLASS_CODE_HUB : usb_std.h
  • USB_CLASS_CODE_MSC : usb_std.h
  • USB_CLASS_CODE_PRINTER : usb_std.h
  • USB_CLASS_CODE_VENDOR : usb_std.h
  • USB_CLASS_CODE_VIDEO : usb_std.h
  • USB_CONF_REMOTE_WAKEUP : usb_std.h
  • USB_CONF_SELF_POWERED : usb_std.h
  • USB_CONFIG_STRING : usb_std.h
  • USB_DCFG_FULL_SPEED : at32f435_437_usb.h
  • USB_DESCIPTOR_TYPE_CONFIGURATION : usb_std.h
  • USB_DESCIPTOR_TYPE_DEVICE : usb_std.h
  • USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER : usb_std.h
  • USB_DESCIPTOR_TYPE_ENDPOINT : usb_std.h
  • USB_DESCIPTOR_TYPE_INTERFACE : usb_std.h
  • USB_DESCIPTOR_TYPE_INTERFACE_POWER : usb_std.h
  • USB_DESCIPTOR_TYPE_OTHER_SPEED : usb_std.h
  • USB_DESCIPTOR_TYPE_STRING : usb_std.h
  • USB_DEVICE_CFG_DESC_LEN : usb_std.h
  • USB_DEVICE_DESC_LEN : usb_std.h
  • USB_DEVICE_EPT_LEN : usb_std.h
  • USB_DEVICE_IF_DESC_LEN : usb_std.h
  • USB_DEVICE_LANGID_STR_DESC_LEN : usb_std.h
  • USB_DEVICE_OTG_DESC_LEN : usb_std.h
  • USB_DEVICE_OTHER_SPEED_DESC_SIZ_LEN : usb_std.h
  • USB_DEVICE_QUALIFIER_DESC_LEN : usb_std.h
  • USB_EPT0_DATA_IN : usb_std.h
  • USB_EPT0_DATA_OUT : usb_std.h
  • USB_EPT0_IDLE : usb_std.h
  • USB_EPT0_MPS_16 : at32f435_437_usb.h
  • USB_EPT0_MPS_32 : at32f435_437_usb.h
  • USB_EPT0_MPS_64 : at32f435_437_usb.h
  • USB_EPT0_MPS_8 : at32f435_437_usb.h
  • USB_EPT0_SETUP : usb_std.h
  • USB_EPT0_STALL : usb_std.h
  • USB_EPT0_STATUS_IN : usb_std.h
  • USB_EPT0_STATUS_OUT : usb_std.h
  • USB_EPT_DESC_BULK : usb_std.h
  • USB_EPT_DESC_CONTROL : usb_std.h
  • USB_EPT_DESC_DATA_EPT : usb_std.h
  • USB_EPT_DESC_FD_EPT : usb_std.h
  • USB_EPT_DESC_FDDATA_EPT : usb_std.h
  • USB_EPT_DESC_INTERRUPT : usb_std.h
  • USB_EPT_DESC_ISO : usb_std.h
  • USB_EPT_DESC_NSYNC : usb_std.h
  • USB_ETP_DESC_ADAPTIVE : usb_std.h
  • USB_ETP_DESC_ASYNC : usb_std.h
  • USB_ETP_DESC_SYNC : usb_std.h
  • USB_FEATURE_EPT_HALT : usb_std.h
  • USB_FEATURE_REMOTE_WAKEUP : usb_std.h
  • USB_FEATURE_TEST_MODE : usb_std.h
  • USB_FIFO : at32f435_437_usb.h
  • USB_FLASH_ADDR_OFFSET : at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h, at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h
  • USB_HCFG_CLK_48M : at32f435_437_usb.h
  • USB_HCFG_CLK_60M : at32f435_437_usb.h
  • USB_HCFG_CLK_6M : at32f435_437_usb.h
  • USB_HID_GET_IDLE : usbh_hid_class.h, usbh_msc_class.h
  • USB_HID_GET_PROTOCOL : usbh_hid_class.h, usbh_msc_class.h
  • USB_HID_GET_REPORT : usbh_hid_class.h, usbh_msc_class.h
  • USB_HID_KEYBOARD_PROTOCOL_CODE : usbh_hid_class.h
  • USB_HID_MOUSE_PROTOCOL_CODE : usbh_hid_class.h
  • USB_HID_NONE_PROTOCOL_CODE : usbh_hid_class.h
  • USB_HID_SET_IDLE : usbh_hid_class.h, usbh_msc_class.h
  • USB_HID_SET_PROTOCOL : usbh_hid_class.h, usbh_msc_class.h
  • USB_HID_SET_REPORT : usbh_hid_class.h, usbh_msc_class.h
  • USB_ID : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USB_INEPT : at32f435_437_usb.h
  • USB_INTERFACE_ASSOCIATION_TYPE : cdc_msc_desc.c
  • USB_INTERFACE_STRING : usb_std.h
  • USB_LANGID_STRING : usb_std.h
  • USB_LOW_POWER_WAKUP : project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h
  • USB_MAX_DATA_LENGTH : at32f435_437_usb.h
  • USB_MAX_EP0_SIZE : usb_std.h
  • USB_MFC_STRING : usb_std.h
  • USB_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • USB_OTG_CONIDSCHG_FLAG : at32f435_437_usb.h
  • USB_OTG_CONIDSCHG_INT : at32f435_437_usb.h
  • USB_OTG_CURMODE : at32f435_437_usb.h
  • USB_OTG_DCTL_CGNPINNAK : at32f435_437_usb.h
  • USB_OTG_DCTL_CGOUTNAK : at32f435_437_usb.h
  • USB_OTG_DCTL_GNPINNAKSTS : at32f435_437_usb.h
  • USB_OTG_DCTL_GOUTNAKSTS : at32f435_437_usb.h
  • USB_OTG_DCTL_PWROPRGDNE : at32f435_437_usb.h
  • USB_OTG_DCTL_RWKUPSIG : at32f435_437_usb.h
  • USB_OTG_DCTL_SFTDISCON : at32f435_437_usb.h
  • USB_OTG_DCTL_SGNPINNAK : at32f435_437_usb.h
  • USB_OTG_DCTL_SGOUTNAK : at32f435_437_usb.h
  • USB_OTG_DIEPINT_EPTDISD_FLAG : at32f435_437_usb.h
  • USB_OTG_DIEPINT_INEPTNAK_FLAG : at32f435_437_usb.h
  • USB_OTG_DIEPINT_INTKNTXFEMP_FLAG : at32f435_437_usb.h
  • USB_OTG_DIEPINT_TIMEOUT_FLAG : at32f435_437_usb.h
  • USB_OTG_DIEPINT_TXFEMP_FLAG : at32f435_437_usb.h
  • USB_OTG_DIEPINT_XFERC_FLAG : at32f435_437_usb.h
  • USB_OTG_DISCON_FLAG : at32f435_437_usb.h
  • USB_OTG_DISCON_INT : at32f435_437_usb.h
  • USB_OTG_DOEPINT_B2BSTUP_FLAG : at32f435_437_usb.h
  • USB_OTG_DOEPINT_EPTDISD_FLAG : at32f435_437_usb.h
  • USB_OTG_DOEPINT_OUTTEPD_FLAG : at32f435_437_usb.h
  • USB_OTG_DOEPINT_SETUP_FLAG : at32f435_437_usb.h
  • USB_OTG_DOEPINT_XFERC_FLAG : at32f435_437_usb.h
  • USB_OTG_DTXFSTS_INEPTFSAV : at32f435_437_usb.h
  • USB_OTG_ENUMDONE_FLAG : at32f435_437_usb.h
  • USB_OTG_ENUMDONE_INT : at32f435_437_usb.h
  • USB_OTG_EOPF_FLAG : at32f435_437_usb.h
  • USB_OTG_EOPF_INT : at32f435_437_usb.h
  • USB_OTG_ERLYSUSP_FLAG : at32f435_437_usb.h
  • USB_OTG_ERLYSUSP_INT : at32f435_437_usb.h
  • USB_OTG_GINNAKEFF_FLAG : at32f435_437_usb.h
  • USB_OTG_GINNAKEFF_INT : at32f435_437_usb.h
  • USB_OTG_GOUTNAKEFF_FLAG : at32f435_437_usb.h
  • USB_OTG_GOUTNAKEFF_INT : at32f435_437_usb.h
  • USB_OTG_GRXSTSP_BCNT : at32f435_437_usb.h
  • USB_OTG_GRXSTSP_CHNUM : at32f435_437_usb.h
  • USB_OTG_GRXSTSP_DPID : at32f435_437_usb.h
  • USB_OTG_GRXSTSP_EPTNUM : at32f435_437_usb.h
  • USB_OTG_GRXSTSP_PKTSTS : at32f435_437_usb.h
  • USB_OTG_HC_ACK_FLAG : at32f435_437_usb.h
  • USB_OTG_HC_ACKM_INT : at32f435_437_usb.h
  • USB_OTG_HC_BBLERR_FLAG : at32f435_437_usb.h
  • USB_OTG_HC_BBLERRM_INT : at32f435_437_usb.h
  • USB_OTG_HC_CHHLTD_FLAG : at32f435_437_usb.h
  • USB_OTG_HC_CHHLTDM_INT : at32f435_437_usb.h
  • USB_OTG_HC_DTGLERR_FLAG : at32f435_437_usb.h
  • USB_OTG_HC_DTGLERRM_INT : at32f435_437_usb.h
  • USB_OTG_HC_FRMOVRRUN_FLAG : at32f435_437_usb.h
  • USB_OTG_HC_FRMOVRRUN_INT : at32f435_437_usb.h
  • USB_OTG_HC_NAK_FLAG : at32f435_437_usb.h
  • USB_OTG_HC_NAKM_INT : at32f435_437_usb.h
  • USB_OTG_HC_NYET_FLAG : at32f435_437_usb.h
  • USB_OTG_HC_NYETM_INT : at32f435_437_usb.h
  • USB_OTG_HC_STALL_FLAG : at32f435_437_usb.h
  • USB_OTG_HC_STALLM_INT : at32f435_437_usb.h
  • USB_OTG_HC_XACTERR_FLAG : at32f435_437_usb.h
  • USB_OTG_HC_XACTERRM_INT : at32f435_437_usb.h
  • USB_OTG_HC_XFERC_FLAG : at32f435_437_usb.h
  • USB_OTG_HC_XFERCM_INT : at32f435_437_usb.h
  • USB_OTG_HCCHAR_CHDIS : at32f435_437_usb.h
  • USB_OTG_HCCHAR_CHENA : at32f435_437_usb.h
  • USB_OTG_HCCHAR_DEVADDR : at32f435_437_usb.h
  • USB_OTG_HCCHAR_EPTDIR : at32f435_437_usb.h
  • USB_OTG_HCCHAR_EPTNUM : at32f435_437_usb.h
  • USB_OTG_HCCHAR_EPTYPE : at32f435_437_usb.h
  • USB_OTG_HCCHAR_LSPDDEV : at32f435_437_usb.h
  • USB_OTG_HCCHAR_MC : at32f435_437_usb.h
  • USB_OTG_HCCHAR_MPS : at32f435_437_usb.h
  • USB_OTG_HCCHAR_ODDFRM : at32f435_437_usb.h
  • USB_OTG_HCH_FLAG : at32f435_437_usb.h
  • USB_OTG_HCH_INT : at32f435_437_usb.h
  • USB_OTG_HCTSIZ_PID : at32f435_437_usb.h
  • USB_OTG_HCTSIZ_PKTCNT : at32f435_437_usb.h
  • USB_OTG_HCTSIZ_XFERSIZE : at32f435_437_usb.h
  • USB_OTG_HPRT_PRTCONDET : at32f435_437_usb.h
  • USB_OTG_HPRT_PRTCONSTS : at32f435_437_usb.h
  • USB_OTG_HPRT_PRTENA : at32f435_437_usb.h
  • USB_OTG_HPRT_PRTENCHNG : at32f435_437_usb.h
  • USB_OTG_HPRT_PRTLNSTS : at32f435_437_usb.h
  • USB_OTG_HPRT_PRTOVRCACT : at32f435_437_usb.h
  • USB_OTG_HPRT_PRTOVRCCHNG : at32f435_437_usb.h
  • USB_OTG_HPRT_PRTPWR : at32f435_437_usb.h
  • USB_OTG_HPRT_PRTRES : at32f435_437_usb.h
  • USB_OTG_HPRT_PRTRST : at32f435_437_usb.h
  • USB_OTG_HPRT_PRTSPD : at32f435_437_usb.h
  • USB_OTG_HPRT_PRTSUSP : at32f435_437_usb.h
  • USB_OTG_IEPT_FLAG : at32f435_437_usb.h
  • USB_OTG_IEPT_INT : at32f435_437_usb.h
  • USB_OTG_INCOMISOIN_FLAG : at32f435_437_usb.h
  • USB_OTG_INCOMISOIN_INT : at32f435_437_usb.h
  • USB_OTG_INCOMPIP_INCOMPISOOUT_FLAG : at32f435_437_usb.h
  • USB_OTG_INCOMPIP_INCOMPISOOUT_INT : at32f435_437_usb.h
  • USB_OTG_ISOOUTDROP_FLAG : at32f435_437_usb.h
  • USB_OTG_ISOOUTDROP_INT : at32f435_437_usb.h
  • USB_OTG_MODEMIS_FLAG : at32f435_437_usb.h
  • USB_OTG_MODEMIS_INT : at32f435_437_usb.h
  • USB_OTG_NPTXFEMP_FLAG : at32f435_437_usb.h
  • USB_OTG_NPTXFEMP_INT : at32f435_437_usb.h
  • USB_OTG_OEPT_FLAG : at32f435_437_usb.h
  • USB_OTG_OEPT_INT : at32f435_437_usb.h
  • USB_OTG_OTGINT_FLAG : at32f435_437_usb.h
  • USB_OTG_OTGINT_INT : at32f435_437_usb.h
  • USB_OTG_PRT_FLAG : at32f435_437_usb.h
  • USB_OTG_PRT_INT : at32f435_437_usb.h
  • USB_OTG_PTXFEMP_FLAG : at32f435_437_usb.h
  • USB_OTG_PTXFEMP_INT : at32f435_437_usb.h
  • USB_OTG_RXFLVL_FLAG : at32f435_437_usb.h
  • USB_OTG_RXFLVL_INT : at32f435_437_usb.h
  • USB_OTG_SOF_FLAG : at32f435_437_usb.h
  • USB_OTG_SOF_INT : at32f435_437_usb.h
  • USB_OTG_USBRST_FLAG : at32f435_437_usb.h
  • USB_OTG_USBRST_INT : at32f435_437_usb.h
  • USB_OTG_USBSUSP_FLAG : at32f435_437_usb.h
  • USB_OTG_USBSUSP_INT : at32f435_437_usb.h
  • USB_OTG_WKUP_FLAG : at32f435_437_usb.h
  • USB_OTG_WKUP_INT : at32f435_437_usb.h
  • USB_OUT_STS_COMP : at32f435_437_usb.h
  • USB_OUT_STS_DATA : at32f435_437_usb.h
  • USB_OUT_STS_NAK : at32f435_437_usb.h
  • USB_OUTEPT : at32f435_437_usb.h
  • USB_PRODUCT_STRING : usb_std.h
  • USB_PRTSPD_FULL_SPEED : at32f435_437_usb.h
  • USB_PRTSPD_HIGH_SPEED : at32f435_437_usb.h
  • USB_PRTSPD_LOW_SPEED : at32f435_437_usb.h
  • USB_REQ_DIR_DTH : usb_std.h
  • USB_REQ_DIR_HTD : usb_std.h
  • USB_REQ_RECIPIENT_DEVICE : usb_std.h
  • USB_REQ_RECIPIENT_ENDPOINT : usb_std.h
  • USB_REQ_RECIPIENT_INTERFACE : usb_std.h
  • USB_REQ_RECIPIENT_MASK : usb_std.h
  • USB_REQ_RECIPIENT_OTHER : usb_std.h
  • USB_REQ_TYPE_CLASS : usb_std.h
  • USB_REQ_TYPE_RESERVED : usb_std.h
  • USB_REQ_TYPE_STANDARD : usb_std.h
  • USB_REQ_TYPE_VENDOR : usb_std.h
  • USB_SERIAL_STRING : usb_std.h
  • USB_SETUP_STS_COMP : at32f435_437_usb.h
  • USB_SETUP_STS_DATA : at32f435_437_usb.h
  • USB_STD_REQ_CLEAR_FEATURE : usb_std.h
  • USB_STD_REQ_GET_CONFIGURATION : usb_std.h
  • USB_STD_REQ_GET_DESCRIPTOR : usb_std.h
  • USB_STD_REQ_GET_INTERFACE : usb_std.h
  • USB_STD_REQ_GET_STATUS : usb_std.h
  • USB_STD_REQ_SET_ADDRESS : usb_std.h
  • USB_STD_REQ_SET_CONFIGURATION : usb_std.h
  • USB_STD_REQ_SET_DESCRIPTOR : usb_std.h
  • USB_STD_REQ_SET_FEATURE : usb_std.h
  • USB_STD_REQ_SET_INTERFACE : usb_std.h
  • USB_STD_REQ_SYNCH_FRAME : usb_std.h
  • USB_TRDTIM_16 : at32f435_437_usb.h
  • USB_TRDTIM_8 : at32f435_437_usb.h
  • USB_VBUS_IGNORE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USB_VIRTUAL_COMPORT : project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h
  • USBD2_EP0_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD2_EP1_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD2_EP2_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD2_EP3_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD2_EP4_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD2_EP5_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD2_EP6_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD2_EP7_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD2_RX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD_AUDIO_CONFIG_DESC_SIZE : audio_desc.h
  • USBD_AUDIO_DESC_CONFIGURATION_STRING : audio_desc.h
  • USBD_AUDIO_DESC_INTERFACE_STRING : audio_desc.h
  • USBD_AUDIO_DESC_MANUFACTURER_STRING : audio_desc.h
  • USBD_AUDIO_DESC_PRODUCT_STRING : audio_desc.h
  • USBD_AUDIO_FEEDBACK_EPT : audio_class.h
  • USBD_AUDIO_MIC_IN_EPT : audio_class.h
  • USBD_AUDIO_PRODUCT_ID : audio_desc.h
  • USBD_AUDIO_SIZ_STRING_LANGID : audio_desc.h
  • USBD_AUDIO_SIZ_STRING_SERIAL : audio_desc.h
  • USBD_AUDIO_SPK_OUT_EPT : audio_class.h
  • USBD_AUDIO_VENDOR_ID : audio_desc.h
  • USBD_AUHID_AUDIO_FEEDBACK_EPT : audio_hid_class.h
  • USBD_AUHID_AUDIO_MIC_IN_EPT : audio_hid_class.h
  • USBD_AUHID_AUDIO_SPK_OUT_EPT : audio_hid_class.h
  • USBD_AUHID_CONFIG_DESC_SIZE : audio_hid_desc.h
  • USBD_AUHID_DESC_CONFIGURATION_STRING : audio_hid_desc.h
  • USBD_AUHID_DESC_INTERFACE_STRING : audio_hid_desc.h
  • USBD_AUHID_DESC_MANUFACTURER_STRING : audio_hid_desc.h
  • USBD_AUHID_DESC_PRODUCT_STRING : audio_hid_desc.h
  • USBD_AUHID_HID_DESC_SIZE : audio_hid_desc.h
  • USBD_AUHID_HID_IN_EPT : audio_hid_class.h
  • USBD_AUHID_HID_OUT_EPT : audio_hid_class.h
  • USBD_AUHID_HID_SIZ_REPORT_DESC : audio_hid_desc.h
  • USBD_AUHID_IN_MAXPACKET_SIZE : audio_hid_class.h
  • USBD_AUHID_OUT_MAXPACKET_SIZE : audio_hid_class.h
  • USBD_AUHID_PRODUCT_ID : audio_hid_desc.h
  • USBD_AUHID_SIZ_STRING_LANGID : audio_hid_desc.h
  • USBD_AUHID_SIZ_STRING_SERIAL : audio_hid_desc.h
  • USBD_AUHID_VENDOR_ID : audio_hid_desc.h
  • USBD_CDC_BULK_IN_EPT : cdc_class.h, cdc_msc_class.h
  • USBD_CDC_BULK_OUT_EPT : cdc_class.h, cdc_msc_class.h
  • USBD_CDC_CMD_MAXPACKET_SIZE : cdc_class.h, cdc_msc_class.h
  • USBD_CDC_CONFIG_DESC_SIZE : cdc_desc.h
  • USBD_CDC_CS_ENDPOINT : usb_std.h
  • USBD_CDC_CS_INTERFACE : usb_std.h
  • USBD_CDC_DESC_CONFIGURATION_STRING : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_DESC_INTERFACE_STRING : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_DESC_MANUFACTURER_STRING : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_DESC_PRODUCT_STRING : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_IN_MAXPACKET_SIZE : cdc_class.h
  • USBD_CDC_INT_EPT : cdc_class.h, cdc_msc_class.h
  • USBD_CDC_MSC_CONFIG_DESC_SIZE : cdc_msc_desc.h
  • USBD_CDC_MSC_IN_MAXPACKET_SIZE : cdc_msc_class.h
  • USBD_CDC_MSC_OUT_MAXPACKET_SIZE : cdc_msc_class.h
  • USBD_CDC_MSC_PRODUCT_ID : cdc_msc_desc.h
  • USBD_CDC_MSC_VENDOR_ID : cdc_msc_desc.h
  • USBD_CDC_OUT_MAXPACKET_SIZE : cdc_class.h
  • USBD_CDC_PRODUCT_ID : cdc_desc.h
  • USBD_CDC_SIZ_STRING_LANGID : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_SIZ_STRING_SERIAL : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_SUBTYPE_ACM : usb_std.h
  • USBD_CDC_SUBTYPE_CMF : usb_std.h
  • USBD_CDC_SUBTYPE_HEADER : usb_std.h
  • USBD_CDC_SUBTYPE_UFD : usb_std.h
  • USBD_CDC_VENDOR_ID : cdc_desc.h
  • USBD_CUSHID_CONFIG_DESC_SIZE : custom_hid_desc.h
  • USBD_CUSHID_DESC_CONFIGURATION_STRING : custom_hid_desc.h
  • USBD_CUSHID_DESC_INTERFACE_STRING : custom_hid_desc.h
  • USBD_CUSHID_DESC_MANUFACTURER_STRING : custom_hid_desc.h
  • USBD_CUSHID_DESC_PRODUCT_STRING : custom_hid_desc.h
  • USBD_CUSHID_PRODUCT_ID : custom_hid_desc.h
  • USBD_CUSHID_SIZ_REPORT_DESC : custom_hid_desc.h
  • USBD_CUSHID_SIZ_STRING_LANGID : custom_hid_desc.h
  • USBD_CUSHID_SIZ_STRING_SERIAL : custom_hid_desc.h
  • USBD_CUSHID_VENDOR_ID : custom_hid_desc.h
  • USBD_CUSTOM_HID_IN_EPT : custom_hid_class.h
  • USBD_CUSTOM_HID_OUT_EPT : custom_hid_class.h
  • USBD_CUSTOM_IN_MAXPACKET_SIZE : custom_hid_class.h
  • USBD_CUSTOM_OUT_MAXPACKET_SIZE : custom_hid_class.h
  • USBD_EP0_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD_EP1_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD_EP2_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD_EP3_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD_EP4_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD_EP5_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD_EP6_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD_EP7_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD_HIDIAP_CONFIG_DESC_SIZE : hid_iap_desc.h
  • USBD_HIDIAP_DESC_CONFIGURATION_STRING : hid_iap_desc.h
  • USBD_HIDIAP_DESC_INTERFACE_STRING : hid_iap_desc.h
  • USBD_HIDIAP_DESC_MANUFACTURER_STRING : hid_iap_desc.h
  • USBD_HIDIAP_DESC_PRODUCT_STRING : hid_iap_desc.h
  • USBD_HIDIAP_IN_EPT : hid_iap_class.h
  • USBD_HIDIAP_IN_MAXPACKET_SIZE : hid_iap_class.h
  • USBD_HIDIAP_OUT_EPT : hid_iap_class.h
  • USBD_HIDIAP_OUT_MAXPACKET_SIZE : hid_iap_class.h
  • USBD_HIDIAP_PRODUCT_ID : hid_iap_desc.h
  • USBD_HIDIAP_SIZ_REPORT_DESC : hid_iap_desc.h
  • USBD_HIDIAP_SIZ_STRING_LANGID : hid_iap_desc.h
  • USBD_HIDIAP_SIZ_STRING_SERIAL : hid_iap_desc.h
  • USBD_HIDIAP_VENDOR_ID : hid_iap_desc.h
  • USBD_IN_MAXPACKET_SIZE : msc_class.h
  • USBD_KEYBOARD_CONFIG_DESC_SIZE : keyboard_desc.h
  • USBD_KEYBOARD_DESC_CONFIGURATION_STRING : keyboard_desc.h
  • USBD_KEYBOARD_DESC_INTERFACE_STRING : keyboard_desc.h
  • USBD_KEYBOARD_DESC_MANUFACTURER_STRING : keyboard_desc.h
  • USBD_KEYBOARD_DESC_PRODUCT_STRING : keyboard_desc.h
  • USBD_KEYBOARD_IN_EPT : keyboard_class.h
  • USBD_KEYBOARD_IN_MAXPACKET_SIZE : keyboard_class.h
  • USBD_KEYBOARD_OUT_MAXPACKET_SIZE : keyboard_class.h
  • USBD_KEYBOARD_PRODUCT_ID : keyboard_desc.h
  • USBD_KEYBOARD_SIZ_REPORT_DESC : keyboard_desc.h
  • USBD_KEYBOARD_SIZ_STRING_LANGID : keyboard_desc.h
  • USBD_KEYBOARD_SIZ_STRING_SERIAL : keyboard_desc.h
  • USBD_KEYBOARD_VENDOR_ID : keyboard_desc.h
  • USBD_MOUSE_CONFIG_DESC_SIZE : mouse_desc.h
  • USBD_MOUSE_DESC_CONFIGURATION_STRING : mouse_desc.h
  • USBD_MOUSE_DESC_INTERFACE_STRING : mouse_desc.h
  • USBD_MOUSE_DESC_MANUFACTURER_STRING : mouse_desc.h
  • USBD_MOUSE_DESC_PRODUCT_STRING : mouse_desc.h
  • USBD_MOUSE_IN_EPT : mouse_class.h
  • USBD_MOUSE_IN_MAXPACKET_SIZE : mouse_class.h
  • USBD_MOUSE_PRODUCT_ID : mouse_desc.h
  • USBD_MOUSE_SIZ_REPORT_DESC : mouse_desc.h
  • USBD_MOUSE_SIZ_STRING_LANGID : mouse_desc.h
  • USBD_MOUSE_SIZ_STRING_SERIAL : mouse_desc.h
  • USBD_MOUSE_VENDOR_ID : mouse_desc.h
  • USBD_MSC_BULK_IN_EPT : cdc_msc_class.h, msc_class.h
  • USBD_MSC_BULK_OUT_EPT : cdc_msc_class.h, msc_class.h
  • USBD_MSC_CONFIG_DESC_SIZE : msc_desc.h
  • USBD_MSC_DESC_CONFIGURATION_STRING : msc_desc.h
  • USBD_MSC_DESC_INTERFACE_STRING : msc_desc.h
  • USBD_MSC_DESC_MANUFACTURER_STRING : msc_desc.h
  • USBD_MSC_DESC_PRODUCT_STRING : msc_desc.h
  • USBD_MSC_PRODUCT_ID : msc_desc.h
  • USBD_MSC_SIZ_STRING_LANGID : msc_desc.h
  • USBD_MSC_SIZ_STRING_SERIAL : msc_desc.h
  • USBD_MSC_VENDOR_ID : msc_desc.h
  • USBD_OUT_MAXPACKET_SIZE : msc_class.h
  • USBD_PRINTER_BULK_IN_EPT : printer_class.h
  • USBD_PRINTER_BULK_OUT_EPT : printer_class.h
  • USBD_PRINTER_CONFIG_DESC_SIZE : printer_desc.h
  • USBD_PRINTER_DESC_CONFIGURATION_STRING : printer_desc.h
  • USBD_PRINTER_DESC_INTERFACE_STRING : printer_desc.h
  • USBD_PRINTER_DESC_MANUFACTURER_STRING : printer_desc.h
  • USBD_PRINTER_DESC_PRODUCT_STRING : printer_desc.h
  • USBD_PRINTER_IN_MAXPACKET_SIZE : printer_class.h
  • USBD_PRINTER_OUT_MAXPACKET_SIZE : printer_class.h
  • USBD_PRINTER_PRODUCT_ID : printer_desc.h
  • USBD_PRINTER_SIZ_STRING_LANGID : printer_desc.h
  • USBD_PRINTER_SIZ_STRING_SERIAL : printer_desc.h
  • USBD_PRINTER_VENDOR_ID : printer_desc.h
  • USBD_RX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD_VCPKYBRD_CDC_BULK_IN_EPT : cdc_keyboard_class.h
  • USBD_VCPKYBRD_CDC_BULK_OUT_EPT : cdc_keyboard_class.h
  • USBD_VCPKYBRD_CDC_INT_EPT : cdc_keyboard_class.h
  • USBD_VCPKYBRD_CMD_MAXPACKET_SIZE : cdc_keyboard_class.h
  • USBD_VCPKYBRD_CONFIG_DESC_SIZE : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_DESC_CONFIGURATION_STRING : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_DESC_INTERFACE_STRING : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_DESC_MANUFACTURER_STRING : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_DESC_PRODUCT_STRING : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_HID_IN_EPT : cdc_keyboard_class.h
  • USBD_VCPKYBRD_HID_SIZ_REPORT_DESC : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_IN_MAXPACKET_SIZE : cdc_keyboard_class.h
  • USBD_VCPKYBRD_OUT_MAXPACKET_SIZE : cdc_keyboard_class.h
  • USBD_VCPKYBRD_PRODUCT_ID : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_SIZ_STRING_LANGID : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_SIZ_STRING_SERIAL : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_VENDOR_ID : cdc_keyboard_desc.h
  • USBH2_NP_TX_FIFO_SIZE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • USBH2_P_TX_FIFO_SIZE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • USBH2_RX_FIFO_SIZE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • USBH_5V_POWER_SWITCH : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • USBH_DEBUG : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • USBH_DEBUG_ENABLE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • USBH_NP_TX_FIFO_SIZE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • USBH_P_TX_FIFO_SIZE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • USBH_RX_FIFO_SIZE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • USBH_SUPPORT_MAX_LUN : usbh_msc_class.h
  • USD : at32f435_437_flash.h
  • USD_BASE : at32f435_437.h
  • USD_DEPSLP_NO_RST : at32f435_437_flash.h
  • USD_DEPSLP_RST : at32f435_437_flash.h
  • USD_STDBY_NO_RST : at32f435_437_flash.h
  • USD_STDBY_RST : at32f435_437_flash.h
  • USD_WDT_ATO_DISABLE : at32f435_437_flash.h
  • USD_WDT_ATO_ENABLE : at32f435_437_flash.h
  • USD_WDT_DEPSLP_CONTINUE : at32f435_437_flash.h
  • USD_WDT_DEPSLP_STOP : at32f435_437_flash.h
  • USD_WDT_STDBY_CONTINUE : at32f435_437_flash.h
  • USD_WDT_STDBY_STOP : at32f435_437_flash.h
  • USE_ARGC_ARGV : flash_config.h
  • USE_IAP_HTTP : at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h
  • USE_IAP_TFTP : at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h
  • USE_OTG_DEVICE_MODE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USE_OTG_HOST_MODE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • USE_SLIB_FUNCTION : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • USE_STATIC_INIT : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • USER_BUTTON_CRM_CLK : at32f435_437_board.h
  • USER_BUTTON_PIN : at32f435_437_board.h
  • USER_BUTTON_PORT : at32f435_437_board.h
  • USER_FLASH_END_ADDRESS : utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/flash.h
  • USERID : httpserver.h


AT32F435/437 Firmwary Library: Globals

- v -

  • VARIABLES_GET_BIT : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f437/examples/cortex_m4/bit_band/src/main.c
  • VARIABLES_RESET_BIT : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f437/examples/cortex_m4/bit_band/src/main.c
  • VARIABLES_SET_BIT : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f437/examples/cortex_m4/bit_band/src/main.c
  • VCPKYBRD_BCD_NUM : cdc_keyboard_desc.h
  • VCPKYBRD_CDC_DATA_INTERFACE : cdc_keyboard_desc.h
  • VCPKYBRD_CDC_INTERFACE : cdc_keyboard_desc.h
  • VCPKYBRD_HID_BINTERVAL_TIME : cdc_keyboard_desc.h
  • VCPKYBRD_KEYBOARD_INTERFACE : cdc_keyboard_desc.h
  • VCPMSC_CDC_DATA_INTERFACE : cdc_msc_desc.h
  • VCPMSC_CDC_INTERFACE : cdc_msc_desc.h
  • VCPMSC_MSC_INTERFACE : cdc_msc_desc.h
  • VECT_TAB_OFFSET : system_at32f435_437.c
  • VERS : FlashOS.h
  • VLAN_TAG : at32f435_437_emac.h
  • vPortSVCHandler : FreeRTOSConfig.h


AT32F435/437 Firmwary Library: Globals

- w -

  • W25Q128 : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • W25Q16 : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • W25Q32 : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • W25Q64 : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • W25Q80 : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • WDT : at32f435_437_wdt.h
  • WDT_BASE : at32f435_437.h
  • WDT_DIVF_UPDATE_FLAG : at32f435_437_wdt.h
  • WDT_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • WDT_RLDF_UPDATE_FLAG : at32f435_437_wdt.h
  • WDT_WINF_UPDATE_FLAG : at32f435_437_wdt.h
  • WHITE : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • WM8988_I2C_ADDR_CSB_HIGH : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_I2C_ADDR_CSB_LOW : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R0_LEFT_INPUT_VOLUME : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R10_LEFT_DAC_VOLUME : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R11_RIGHT_DAC_VOLUME : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R12_BASS_CONTROL : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R13_TREBLE_CONTROL : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R14_ : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R15_RESET : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R16_3D_CONTROL : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R17_ALC1 : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R18_ALC2 : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R19_ALC3 : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R1_RIGHT_INPUT_VOLUME : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R20_NOISE_GATE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R21_LEFT_ADC_VOLUME : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R22_RIGHT_ADC_VOLUME : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R23_ADDITIONAL_1_CONTROL : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R24_ADDITIONAL_2_CONTROL : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R25_PWR_1_MGMT : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R26_PWR_2_MGMT : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R27_ADDITIONAL_3_CONTROL : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R2_LOUT1_VOLUME : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R31_ADC_INPUT_MODE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R32_ADC_L_SIGNAL_PATH : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R33_ADC_R_SIGNAL_PATH : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R34_LEFT_OUT_MIX_1 : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R35_LEFT_OUT_MIX_2 : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R36_RIGHT_OUT_MIX_1 : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R37_RIGHT_OUT_MIX_2 : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R38_RESERVED : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R39_RESERVED : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R3_ROUT1_VOLUME : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R40_LOUT2_VOLUME : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R41_ROUT2_VOLUME : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R42_RESERVED : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R43_LOW_POWER_PALYBACK : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R4_RESERVED : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R5_ADC_DAC_CONTROL : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R6_RESERVED : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R7_AUDIO_INTERFACE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R8_SAMPLE_RATE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R9_RESERVED : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_REG_BITW16 : at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • WM8988_REG_FREQ16K : at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • WM8988_REG_FREQ48K : at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • write_read_addr : project/at_start_f435/examples/xmc/nor_flash/src/main.c, project/at_start_f435/examples/xmc/psram/src/main.c, project/at_start_f435/examples/xmc/sdram_basic/src/main.c, project/at_start_f435/examples/xmc/sdram_dma/src/main.c, project/at_start_f435/examples/xmc/sram/src/main.c, project/at_start_f437/examples/xmc/nor_flash/src/main.c, project/at_start_f437/examples/xmc/psram/src/main.c, project/at_start_f437/examples/xmc/sdram_basic/src/main.c, project/at_start_f437/examples/xmc/sdram_dma/src/main.c, project/at_start_f437/examples/xmc/sram/src/main.c
  • WWDT : at32f435_437_wwdt.h
  • WWDT_BASE : at32f435_437.h
  • WWDT_EN_BIT : at32f435_437_wwdt.h
  • WWDT_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h


AT32F435/437 Firmwary Library: Globals

- x -

  • XMC_BANK1 : at32f435_437_xmc.h
  • XMC_BANK1_REG_BASE : at32f435_437.h
  • XMC_BANK2 : at32f435_437_xmc.h
  • XMC_BANK2_REG_BASE : at32f435_437.h
  • XMC_BANK3 : at32f435_437_xmc.h
  • XMC_BANK3_REG_BASE : at32f435_437.h
  • XMC_BANK4 : at32f435_437_xmc.h
  • XMC_BANK4_REG_BASE : at32f435_437.h
  • XMC_Bank_NAND : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • XMC_CARD_MEM_BASE : at32f435_437.h
  • XMC_LCD_COMMAND : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • XMC_LCD_DATA : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • XMC_MEM_BASE : at32f435_437.h
  • XMC_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • XMC_REG_BASE : at32f435_437.h
  • XMC_SDRAM : at32f435_437_xmc.h
  • XMC_SDRAM_MEM_BASE : at32f435_437.h
  • XMC_SDRAM_REG_BASE : at32f435_437.h
  • xPortPendSVHandler : FreeRTOSConfig.h
  • xPortSysTickHandler : FreeRTOSConfig.h


AT32F435/437 Firmwary Library: Globals

- y -

  • YELLOW : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h


AT32F435/437 Firmwary Library: Globals

- z -

  • ZOOM : project/at_start_f435/examples/cortex_m4/fpu/src/main.c, project/at_start_f437/examples/cortex_m4/fpu/src/main.c


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- e -

  • ecc_value_read : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c
  • ecc_value_write : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c
  • ecc_value_write_last : project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c
  • EDMA : at32f435_437_edma.h
  • EDMA_2D_BASE : at32f435_437.h
  • edma_2d_enable() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_2d_init() : at32f435_437_edma.h, at32f435_437_edma.c
  • EDMA_BASE : at32f435_437.h
  • edma_config() : project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f435/examples/adc/edma_double_buffer/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f437/examples/adc/edma_double_buffer/src/main.c
  • edma_data_number_get() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_data_number_set() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_default_para_init() : at32f435_437_edma.h, at32f435_437_edma.c
  • EDMA_DIR_MEMORY_TO_MEMORY : at32f435_437_edma.h
  • EDMA_DIR_MEMORY_TO_PERIPHERAL : at32f435_437_edma.h
  • EDMA_DIR_PERIPHERAL_TO_MEMORY : at32f435_437_edma.h
  • edma_dir_type : at32f435_437_edma.h
  • EDMA_DMERR1_FLAG : at32f435_437_edma.h
  • EDMA_DMERR2_FLAG : at32f435_437_edma.h
  • EDMA_DMERR3_FLAG : at32f435_437_edma.h
  • EDMA_DMERR4_FLAG : at32f435_437_edma.h
  • EDMA_DMERR5_FLAG : at32f435_437_edma.h
  • EDMA_DMERR6_FLAG : at32f435_437_edma.h
  • EDMA_DMERR7_FLAG : at32f435_437_edma.h
  • EDMA_DMERR8_FLAG : at32f435_437_edma.h
  • EDMA_DMERR_INT : at32f435_437_edma.h
  • edma_double_buffer_mode_enable() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_double_buffer_mode_init() : at32f435_437_edma.h, at32f435_437_edma.c
  • EDMA_DTERR1_FLAG : at32f435_437_edma.h
  • EDMA_DTERR2_FLAG : at32f435_437_edma.h
  • EDMA_DTERR3_FLAG : at32f435_437_edma.h
  • EDMA_DTERR4_FLAG : at32f435_437_edma.h
  • EDMA_DTERR5_FLAG : at32f435_437_edma.h
  • EDMA_DTERR6_FLAG : at32f435_437_edma.h
  • EDMA_DTERR7_FLAG : at32f435_437_edma.h
  • EDMA_DTERR8_FLAG : at32f435_437_edma.h
  • EDMA_DTERR_INT : at32f435_437_edma.h
  • EDMA_FDT1_FLAG : at32f435_437_edma.h
  • EDMA_FDT2_FLAG : at32f435_437_edma.h
  • EDMA_FDT3_FLAG : at32f435_437_edma.h
  • EDMA_FDT4_FLAG : at32f435_437_edma.h
  • EDMA_FDT5_FLAG : at32f435_437_edma.h
  • EDMA_FDT6_FLAG : at32f435_437_edma.h
  • EDMA_FDT7_FLAG : at32f435_437_edma.h
  • EDMA_FDT8_FLAG : at32f435_437_edma.h
  • EDMA_FDT_INT : at32f435_437_edma.h
  • EDMA_FERR1_FLAG : at32f435_437_edma.h
  • EDMA_FERR2_FLAG : at32f435_437_edma.h
  • EDMA_FERR3_FLAG : at32f435_437_edma.h
  • EDMA_FERR4_FLAG : at32f435_437_edma.h
  • EDMA_FERR5_FLAG : at32f435_437_edma.h
  • EDMA_FERR6_FLAG : at32f435_437_edma.h
  • EDMA_FERR7_FLAG : at32f435_437_edma.h
  • EDMA_FERR8_FLAG : at32f435_437_edma.h
  • EDMA_FERR_INT : at32f435_437_edma.h
  • EDMA_FIFO_STATUS_1QUARTER : at32f435_437_edma.h
  • EDMA_FIFO_STATUS_3QUARTER : at32f435_437_edma.h
  • EDMA_FIFO_STATUS_EMPTY : at32f435_437_edma.h
  • EDMA_FIFO_STATUS_FULL : at32f435_437_edma.h
  • edma_fifo_status_get() : at32f435_437_edma.h, at32f435_437_edma.c
  • EDMA_FIFO_STATUS_HALF : at32f435_437_edma.h
  • EDMA_FIFO_STATUS_LESS_1QUARTER : at32f435_437_edma.h
  • edma_fifo_stutas_type : at32f435_437_edma.h
  • EDMA_FIFO_THRESHOLD_1QUARTER : at32f435_437_edma.h
  • EDMA_FIFO_THRESHOLD_3QUARTER : at32f435_437_edma.h
  • EDMA_FIFO_THRESHOLD_FULL : at32f435_437_edma.h
  • EDMA_FIFO_THRESHOLD_HALF : at32f435_437_edma.h
  • edma_fifo_threshold_type : at32f435_437_edma.h
  • edma_flag_clear() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_flag_get() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_flow_controller_enable() : at32f435_437_edma.h, at32f435_437_edma.c
  • EDMA_HDT1_FLAG : at32f435_437_edma.h
  • EDMA_HDT2_FLAG : at32f435_437_edma.h
  • EDMA_HDT3_FLAG : at32f435_437_edma.h
  • EDMA_HDT4_FLAG : at32f435_437_edma.h
  • EDMA_HDT5_FLAG : at32f435_437_edma.h
  • EDMA_HDT6_FLAG : at32f435_437_edma.h
  • EDMA_HDT7_FLAG : at32f435_437_edma.h
  • EDMA_HDT8_FLAG : at32f435_437_edma.h
  • EDMA_HDT_INT : at32f435_437_edma.h
  • edma_init() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_init_struct : at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.h, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.h, project/at_start_f435/examples/edma/burst_mode/src/main.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/edma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/two_dimension_mode/src/main.c, at_start_f437/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f437/examples/dvp/ov2640_capture/hardware/dvp/dvp.h, at_start_f437/examples/dvp/ov5640_capture/hardware/dvp/dvp.c, at_start_f437/examples/dvp/ov5640_capture/hardware/dvp/dvp.h, project/at_start_f437/examples/edma/burst_mode/src/main.c, project/at_start_f437/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/edma/flash_to_sram/src/main.c, project/at_start_f437/examples/edma/two_dimension_mode/src/main.c
  • edma_interrupt_enable() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_link_list_enable() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_link_list_init() : at32f435_437_edma.h, at32f435_437_edma.c
  • EDMA_LL_BASE : at32f435_437.h
  • EDMA_MEMORY_0 : at32f435_437_edma.h
  • EDMA_MEMORY_1 : at32f435_437_edma.h
  • edma_memory_addr_set() : at32f435_437_edma.h, at32f435_437_edma.c
  • EDMA_MEMORY_BURST_16 : at32f435_437_edma.h
  • EDMA_MEMORY_BURST_4 : at32f435_437_edma.h
  • EDMA_MEMORY_BURST_8 : at32f435_437_edma.h
  • edma_memory_burst_type : at32f435_437_edma.h
  • edma_memory_data_size_type : at32f435_437_edma.h
  • EDMA_MEMORY_DATA_WIDTH_BYTE : at32f435_437_edma.h
  • EDMA_MEMORY_DATA_WIDTH_HALFWORD : at32f435_437_edma.h
  • EDMA_MEMORY_DATA_WIDTH_WORD : at32f435_437_edma.h
  • EDMA_MEMORY_SINGLE : at32f435_437_edma.h
  • edma_memory_target_get() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_memory_type : at32f435_437_edma.h
  • EDMA_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • EDMA_PERIPHERAL_BURST_16 : at32f435_437_edma.h
  • EDMA_PERIPHERAL_BURST_4 : at32f435_437_edma.h
  • EDMA_PERIPHERAL_BURST_8 : at32f435_437_edma.h
  • edma_peripheral_burst_type : at32f435_437_edma.h
  • edma_peripheral_data_size_type : at32f435_437_edma.h
  • EDMA_PERIPHERAL_DATA_WIDTH_BYTE : at32f435_437_edma.h
  • EDMA_PERIPHERAL_DATA_WIDTH_HALFWORD : at32f435_437_edma.h
  • EDMA_PERIPHERAL_DATA_WIDTH_WORD : at32f435_437_edma.h
  • EDMA_PERIPHERAL_INC_4_BYTE : at32f435_437_edma.h
  • edma_peripheral_inc_offset_set() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_peripheral_inc_offset_type : at32f435_437_edma.h
  • EDMA_PERIPHERAL_INC_PSIZE : at32f435_437_edma.h
  • EDMA_PERIPHERAL_SINGLE : at32f435_437_edma.h
  • EDMA_PRIORITY_HIGH : at32f435_437_edma.h
  • edma_priority_level_type : at32f435_437_edma.h
  • EDMA_PRIORITY_LOW : at32f435_437_edma.h
  • EDMA_PRIORITY_MEDIUM : at32f435_437_edma.h
  • EDMA_PRIORITY_VERY_HIGH : at32f435_437_edma.h
  • edma_reset() : at32f435_437_edma.h, at32f435_437_edma.c
  • EDMA_STREAM1 : at32f435_437_edma.h
  • EDMA_STREAM1_2D : at32f435_437_edma.h
  • EDMA_STREAM1_2D_BASE : at32f435_437.h
  • EDMA_STREAM1_BASE : at32f435_437.h
  • EDMA_STREAM1_INT_MASK : at32f435_437_edma.h
  • EDMA_Stream1_IRQHandler() : project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/edma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c, project/at_start_f435/examples/edma/link_list_mode/src/main.c, project/at_start_f435/examples/edma/two_dimension_mode/src/main.c
  • EDMA_Stream1_IRQn : at32f435_437.h
  • EDMA_STREAM1_LL : at32f435_437_edma.h
  • EDMA_STREAM1_LL_BASE : at32f435_437.h
  • EDMA_STREAM2 : at32f435_437_edma.h
  • EDMA_STREAM2_2D : at32f435_437_edma.h
  • EDMA_STREAM2_2D_BASE : at32f435_437.h
  • EDMA_STREAM2_BASE : at32f435_437.h
  • EDMA_STREAM2_INT_MASK : at32f435_437_edma.h
  • EDMA_Stream2_IRQn : at32f435_437.h
  • EDMA_STREAM2_LL : at32f435_437_edma.h
  • EDMA_STREAM2_LL_BASE : at32f435_437.h
  • EDMA_STREAM3 : at32f435_437_edma.h
  • EDMA_STREAM3_2D : at32f435_437_edma.h
  • EDMA_STREAM3_2D_BASE : at32f435_437.h
  • EDMA_STREAM3_BASE : at32f435_437.h
  • EDMA_STREAM3_INT_MASK : at32f435_437_edma.h
  • EDMA_Stream3_IRQn : at32f435_437.h
  • EDMA_STREAM3_LL : at32f435_437_edma.h
  • EDMA_STREAM3_LL_BASE : at32f435_437.h
  • EDMA_STREAM4 : at32f435_437_edma.h
  • EDMA_STREAM4_2D : at32f435_437_edma.h
  • EDMA_STREAM4_2D_BASE : at32f435_437.h
  • EDMA_STREAM4_BASE : at32f435_437.h
  • EDMA_STREAM4_INT_MASK : at32f435_437_edma.h
  • EDMA_Stream4_IRQHandler() : at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c
  • EDMA_Stream4_IRQn : at32f435_437.h
  • EDMA_STREAM4_LL : at32f435_437_edma.h
  • EDMA_STREAM4_LL_BASE : at32f435_437.h
  • EDMA_STREAM5 : at32f435_437_edma.h
  • EDMA_STREAM5_2D : at32f435_437_edma.h
  • EDMA_STREAM5_2D_BASE : at32f435_437.h
  • EDMA_STREAM5_BASE : at32f435_437.h
  • EDMA_STREAM5_INT_MASK : at32f435_437_edma.h
  • EDMA_Stream5_IRQn : at32f435_437.h
  • EDMA_STREAM5_LL : at32f435_437_edma.h
  • EDMA_STREAM5_LL_BASE : at32f435_437.h
  • EDMA_STREAM6 : at32f435_437_edma.h
  • EDMA_STREAM6_2D : at32f435_437_edma.h
  • EDMA_STREAM6_2D_BASE : at32f435_437.h
  • EDMA_STREAM6_BASE : at32f435_437.h
  • EDMA_STREAM6_INT_MASK : at32f435_437_edma.h
  • EDMA_Stream6_IRQn : at32f435_437.h
  • EDMA_STREAM6_LL : at32f435_437_edma.h
  • EDMA_STREAM6_LL_BASE : at32f435_437.h
  • EDMA_STREAM7 : at32f435_437_edma.h
  • EDMA_STREAM7_2D : at32f435_437_edma.h
  • EDMA_STREAM7_2D_BASE : at32f435_437.h
  • EDMA_STREAM7_BASE : at32f435_437.h
  • EDMA_STREAM7_INT_MASK : at32f435_437_edma.h
  • EDMA_Stream7_IRQn : at32f435_437.h
  • EDMA_STREAM7_LL : at32f435_437_edma.h
  • EDMA_STREAM7_LL_BASE : at32f435_437.h
  • EDMA_STREAM8 : at32f435_437_edma.h
  • EDMA_STREAM8_2D : at32f435_437_edma.h
  • EDMA_STREAM8_2D_BASE : at32f435_437.h
  • EDMA_STREAM8_BASE : at32f435_437.h
  • EDMA_STREAM8_INT_MASK : at32f435_437_edma.h
  • EDMA_Stream8_IRQn : at32f435_437.h
  • EDMA_STREAM8_LL : at32f435_437_edma.h
  • EDMA_STREAM8_LL_BASE : at32f435_437.h
  • edma_stream_enable() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_stream_status_get() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_trans_complete_flag : project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f437/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f437/examples/adc/edma_double_buffer/src/main.c
  • EDMAMUX_BASE : at32f435_437.h
  • EDMAMUX_CHANNEL1 : at32f435_437_edma.h
  • EDMAMUX_CHANNEL1_BASE : at32f435_437.h
  • EDMAMUX_CHANNEL2 : at32f435_437_edma.h
  • EDMAMUX_CHANNEL2_BASE : at32f435_437.h
  • EDMAMUX_CHANNEL3 : at32f435_437_edma.h
  • EDMAMUX_CHANNEL3_BASE : at32f435_437.h
  • EDMAMUX_CHANNEL4 : at32f435_437_edma.h
  • EDMAMUX_CHANNEL4_BASE : at32f435_437.h
  • EDMAMUX_CHANNEL5 : at32f435_437_edma.h
  • EDMAMUX_CHANNEL5_BASE : at32f435_437.h
  • EDMAMUX_CHANNEL6 : at32f435_437_edma.h
  • EDMAMUX_CHANNEL6_BASE : at32f435_437.h
  • EDMAMUX_CHANNEL7 : at32f435_437_edma.h
  • EDMAMUX_CHANNEL7_BASE : at32f435_437.h
  • EDMAMUX_CHANNEL8 : at32f435_437_edma.h
  • EDMAMUX_CHANNEL8_BASE : at32f435_437.h
  • EDMAMUX_DMAREQ_ID_ADC1 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_ADC2 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_ADC3 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_DAC1 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_DAC2 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_DVP : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_I2C1_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_I2C1_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_I2C2_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_I2C2_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_I2C3_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_I2C3_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_I2S2_EXT_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_I2S2_EXT_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_I2S3_EXT_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_I2S3_EXT_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_QSPI1 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_QSPI2 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_REQ_G1 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_REQ_G2 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_REQ_G3 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_REQ_G4 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_SDIO1 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_SDIO2 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_SPI1_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_SPI1_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_SPI2_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_SPI2_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_SPI3_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_SPI3_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_SPI4_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_SPI4_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR1_CH1 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR1_CH2 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR1_CH3 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR1_CH4 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR1_HALL : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR1_OVERFLOW : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR1_TRIG : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR20_CH1 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR20_CH2 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR20_CH3 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR20_CH4 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR20_HALL : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR20_OVERFLOW : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR20_TRIG : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR2_CH1 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR2_CH2 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR2_CH3 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR2_CH4 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR2_OVERFLOW : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR2_TRIG : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR3_CH1 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR3_CH2 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR3_CH3 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR3_CH4 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR3_OVERFLOW : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR3_TRIG : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR4_CH1 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR4_CH2 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR4_CH3 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR4_CH4 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR4_OVERFLOW : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR4_TRIG : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR5_CH1 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR5_CH2 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR5_CH3 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR5_CH4 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR5_OVERFLOW : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR5_TRIG : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR6_OVERFLOW : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR7_OVERFLOW : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR8_CH1 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR8_CH2 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR8_CH3 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR8_CH4 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR8_HALL : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR8_OVERFLOW : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR8_TRIG : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_UART4_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_UART4_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_UART5_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_UART5_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_UART7_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_UART7_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_UART8_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_UART8_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_USART1_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_USART1_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_USART2_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_USART2_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_USART3_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_USART3_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_USART6_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_USART6_TX : at32f435_437_edma.h
  • edmamux_enable() : at32f435_437_edma.h, at32f435_437_edma.c
  • EDMAMUX_GEN_ID_DMAMUX_CH1_EVT : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_DMAMUX_CH2_EVT : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_DMAMUX_CH3_EVT : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_DMAMUX_CH4_EVT : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_DMAMUX_CH5_EVT : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_DMAMUX_CH6_EVT : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_DMAMUX_CH7_EVT : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_DMAMUX_CH8_EVT : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT0 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT1 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT10 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT11 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT12 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT13 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT14 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT15 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT2 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT3 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT4 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT5 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT6 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT7 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT8 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT9 : at32f435_437_edma.h
  • edmamux_gen_id_sel_type : at32f435_437_edma.h
  • edmamux_gen_pol_type : at32f435_437_edma.h
  • EDMAMUX_GEN_POLARITY_DISABLE : at32f435_437_edma.h
  • EDMAMUX_GEN_POLARITY_FALLING : at32f435_437_edma.h
  • EDMAMUX_GEN_POLARITY_RISING : at32f435_437_edma.h
  • EDMAMUX_GEN_POLARITY_RISING_FALLING : at32f435_437_edma.h
  • EDMAMUX_GEN_TRIG_OV1_FLAG : at32f435_437_edma.h
  • EDMAMUX_GEN_TRIG_OV2_FLAG : at32f435_437_edma.h
  • EDMAMUX_GEN_TRIG_OV3_FLAG : at32f435_437_edma.h
  • EDMAMUX_GEN_TRIG_OV4_FLAG : at32f435_437_edma.h
  • EDMAMUX_GENERATOR1 : at32f435_437_edma.h
  • EDMAMUX_GENERATOR1_BASE : at32f435_437.h
  • EDMAMUX_GENERATOR2 : at32f435_437_edma.h
  • EDMAMUX_GENERATOR2_BASE : at32f435_437.h
  • EDMAMUX_GENERATOR3 : at32f435_437_edma.h
  • EDMAMUX_GENERATOR3_BASE : at32f435_437.h
  • EDMAMUX_GENERATOR4 : at32f435_437_edma.h
  • EDMAMUX_GENERATOR4_BASE : at32f435_437.h
  • edmamux_generator_config() : at32f435_437_edma.h, at32f435_437_edma.c
  • edmamux_generator_default_para_init() : at32f435_437_edma.h, at32f435_437_edma.c
  • edmamux_generator_flag_clear() : at32f435_437_edma.h, at32f435_437_edma.c
  • edmamux_generator_flag_get() : at32f435_437_edma.h, at32f435_437_edma.c
  • edmamux_generator_interrupt_enable() : at32f435_437_edma.h, at32f435_437_edma.c
  • edmamux_init() : at32f435_437_edma.h, at32f435_437_edma.c
  • edmamux_requst_id_sel_type : at32f435_437_edma.h
  • edmamux_sync_config() : at32f435_437_edma.h, at32f435_437_edma.c
  • edmamux_sync_default_para_init() : at32f435_437_edma.h, at32f435_437_edma.c
  • edmamux_sync_flag_clear() : at32f435_437_edma.h, at32f435_437_edma.c
  • edmamux_sync_flag_get() : at32f435_437_edma.h, at32f435_437_edma.c
  • EDMAMUX_SYNC_ID_DMAMUX_CH1_EVT : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_DMAMUX_CH2_EVT : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_DMAMUX_CH3_EVT : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_DMAMUX_CH4_EVT : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_DMAMUX_CH5_EVT : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_DMAMUX_CH6_EVT : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_DMAMUX_CH7_EVT : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_DMAMUX_CH8_EVT : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT0 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT1 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT10 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT11 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT12 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT13 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT14 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT15 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT2 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT3 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT4 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT5 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT6 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT7 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT8 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT9 : at32f435_437_edma.h
  • edmamux_sync_id_sel_type : at32f435_437_edma.h
  • edmamux_sync_init_struct : project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/main.c
  • edmamux_sync_interrupt_enable() : at32f435_437_edma.h, at32f435_437_edma.c
  • EDMAMUX_SYNC_OV1_FLAG : at32f435_437_edma.h
  • EDMAMUX_SYNC_OV2_FLAG : at32f435_437_edma.h
  • EDMAMUX_SYNC_OV3_FLAG : at32f435_437_edma.h
  • EDMAMUX_SYNC_OV4_FLAG : at32f435_437_edma.h
  • EDMAMUX_SYNC_OV5_FLAG : at32f435_437_edma.h
  • EDMAMUX_SYNC_OV6_FLAG : at32f435_437_edma.h
  • EDMAMUX_SYNC_OV7_FLAG : at32f435_437_edma.h
  • EDMAMUX_SYNC_OV8_FLAG : at32f435_437_edma.h
  • edmamux_sync_pol_type : at32f435_437_edma.h
  • EDMAMUX_SYNC_POLARITY_DISABLE : at32f435_437_edma.h
  • EDMAMUX_SYNC_POLARITY_FALLING : at32f435_437_edma.h
  • EDMAMUX_SYNC_POLARITY_RISING : at32f435_437_edma.h
  • EDMAMUX_SYNC_POLARITY_RISING_FALLING : at32f435_437_edma.h
  • EMAC : at32f435_437_emac.h
  • EMAC_ADDRESS_FILTER_1 : at32f435_437_emac.h
  • EMAC_ADDRESS_FILTER_2 : at32f435_437_emac.h
  • EMAC_ADDRESS_FILTER_3 : at32f435_437_emac.h
  • emac_address_filter_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_address_filter_type : at32f435_437_emac.h
  • EMAC_ADDRESS_MASK_15H8 : at32f435_437_emac.h
  • EMAC_ADDRESS_MASK_15L8 : at32f435_437_emac.h
  • EMAC_ADDRESS_MASK_23L16 : at32f435_437_emac.h
  • EMAC_ADDRESS_MASK_31L24 : at32f435_437_emac.h
  • EMAC_ADDRESS_MASK_7H0 : at32f435_437_emac.h
  • EMAC_ADDRESS_MASK_8L0 : at32f435_437_emac.h
  • emac_address_mask_type : at32f435_437_emac.h
  • emac_address_type : at32f435_437_emac.h
  • EMAC_AUTO_NEGOTIATION_OFF : at32f435_437_emac.h
  • EMAC_AUTO_NEGOTIATION_ON : at32f435_437_emac.h
  • emac_auto_negotiation_type : at32f435_437_emac.h
  • emac_auto_pad_crc_stripping_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_BACKOFF_LIMIT_0 : at32f435_437_emac.h
  • EMAC_BACKOFF_LIMIT_1 : at32f435_437_emac.h
  • EMAC_BACKOFF_LIMIT_2 : at32f435_437_emac.h
  • EMAC_BACKOFF_LIMIT_3 : at32f435_437_emac.h
  • emac_backoff_limit_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_bol_type : at32f435_437_emac.h
  • emac_broadcast_frames_disable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_carrier_sense_disable() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_CLOCK_RANGE_100_TO_150 : at32f435_437_emac.h
  • EMAC_CLOCK_RANGE_150_TO_250 : at32f435_437_emac.h
  • EMAC_CLOCK_RANGE_20_TO_35 : at32f435_437_emac.h
  • EMAC_CLOCK_RANGE_250_TO_288 : at32f435_437_emac.h
  • EMAC_CLOCK_RANGE_35_TO_60 : at32f435_437_emac.h
  • EMAC_CLOCK_RANGE_60_TO_100 : at32f435_437_emac.h
  • emac_clock_range_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_clock_range_type : at32f435_437_emac.h
  • emac_control_config() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_CONTROL_FRAME_PASSING_ALL : at32f435_437_emac.h
  • EMAC_CONTROL_FRAME_PASSING_MATCH : at32f435_437_emac.h
  • EMAC_CONTROL_FRAME_PASSING_NO : at32f435_437_emac.h
  • emac_control_frames_filter_type : at32f435_437_emac.h
  • emac_control_para_init() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_CRC : at32f435_437_emac.h
  • emac_deferral_check_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_delay() : at32f435_437_emac.c
  • EMAC_DESTINATION_FILTER : at32f435_437_emac.h
  • EMAC_DMA : at32f435_437_emac.h
  • EMAC_DMA_1_RX_1_TX : at32f435_437_emac.h
  • EMAC_DMA_2_RX_1_TX : at32f435_437_emac.h
  • EMAC_DMA_3_RX_1_TX : at32f435_437_emac.h
  • EMAC_DMA_4_RX_1_TX : at32f435_437_emac.h
  • emac_dma_address_aligned_beats_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_DMA_AIS_FLAG : at32f435_437_emac.h
  • emac_dma_application_missing_frame_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_arbitation_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_config() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_controller_missing_frame_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_descriptor_list_address_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_descriptor_list_address_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_descriptor_skip_length_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_eight_pbl_mode_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_DMA_ERI_FLAG : at32f435_437_emac.h
  • EMAC_DMA_ETI_FLAG : at32f435_437_emac.h
  • EMAC_DMA_FBEI_FLAG : at32f435_437_emac.h
  • emac_dma_fifo_overflow_bit_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_flag_clear() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_flag_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_DMA_INTERRUPT_ABNORMAL_SUMMARY : at32f435_437_emac.h
  • emac_dma_interrupt_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_DMA_INTERRUPT_FATAL_BUS_ERROR : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_NORMAL_SUMMARY : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_RX : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_RX_EARLY : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_RX_OVERFLOW : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_RX_STOP : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_RX_TIMEOUT : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_RX_UNAVAILABLE : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_TX : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_TX_EARLY : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_TX_JABBER : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_TX_STOP : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_TX_UNAVAILABLE : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_TX_UNDERFLOW : at32f435_437_emac.h
  • emac_dma_interrupt_type : at32f435_437_emac.h
  • emac_dma_missing_overflow_bit_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_DMA_NIS_FLAG : at32f435_437_emac.h
  • emac_dma_operations_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_operations_type : at32f435_437_emac.h
  • EMAC_DMA_OPS_DROP_ERROR_DISABLE : at32f435_437_emac.h
  • EMAC_DMA_OPS_FLUSH_TRANSMIT_FIFO : at32f435_437_emac.h
  • EMAC_DMA_OPS_FORWARD_ERROR : at32f435_437_emac.h
  • EMAC_DMA_OPS_FORWARD_UNDERSIZED : at32f435_437_emac.h
  • EMAC_DMA_OPS_RECEIVE_FLUSH_DISABLE : at32f435_437_emac.h
  • EMAC_DMA_OPS_RECEIVE_STORE_FORWARD : at32f435_437_emac.h
  • EMAC_DMA_OPS_SECOND_FRAME : at32f435_437_emac.h
  • EMAC_DMA_OPS_START_STOP_RECEIVE : at32f435_437_emac.h
  • EMAC_DMA_OPS_START_STOP_TRANSMIT : at32f435_437_emac.h
  • EMAC_DMA_OPS_TRANSMIT_STORE_FORWARD : at32f435_437_emac.h
  • EMAC_DMA_OVF_FLAG : at32f435_437_emac.h
  • emac_dma_para_init() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_DMA_PBL_1 : at32f435_437_emac.h
  • EMAC_DMA_PBL_16 : at32f435_437_emac.h
  • EMAC_DMA_PBL_2 : at32f435_437_emac.h
  • EMAC_DMA_PBL_32 : at32f435_437_emac.h
  • EMAC_DMA_PBL_4 : at32f435_437_emac.h
  • EMAC_DMA_PBL_8 : at32f435_437_emac.h
  • emac_dma_pbl_type : at32f435_437_emac.h
  • emac_dma_poll_demand_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_poll_demand_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_DMA_RBU_FLAG : at32f435_437_emac.h
  • EMAC_DMA_RECEIVE : at32f435_437_emac.h
  • emac_dma_receive_process_status_type : at32f435_437_emac.h
  • emac_dma_receive_status_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_receive_threshold_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_receive_threshold_type : at32f435_437_emac.h
  • EMAC_DMA_RI_FLAG : at32f435_437_emac.h
  • EMAC_DMA_RPS_FLAG : at32f435_437_emac.h
  • EMAC_DMA_RWT_FLAG : at32f435_437_emac.h
  • EMAC_DMA_RX_BUFFER : at32f435_437_emac.h
  • EMAC_DMA_RX_CLOSE_DESCRIPTOR : at32f435_437_emac.h
  • emac_dma_rx_desc_interrupt_config() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_DMA_RX_DESCRIPTOR : at32f435_437_emac.h
  • EMAC_DMA_RX_DESCRIPTOR_UNAVAILABLE : at32f435_437_emac.h
  • EMAC_DMA_RX_FETCH_DESCRIPTOR : at32f435_437_emac.h
  • EMAC_DMA_RX_FIFO_TO_HOST : at32f435_437_emac.h
  • EMAC_DMA_RX_RESET_STOP_COMMAND : at32f435_437_emac.h
  • EMAC_DMA_RX_THRESHOLD_128_BYTES : at32f435_437_emac.h
  • EMAC_DMA_RX_THRESHOLD_32_BYTES : at32f435_437_emac.h
  • EMAC_DMA_RX_THRESHOLD_64_BYTES : at32f435_437_emac.h
  • EMAC_DMA_RX_THRESHOLD_96_BYTES : at32f435_437_emac.h
  • emac_dma_rx_tx_ratio_type : at32f435_437_emac.h
  • EMAC_DMA_RX_WAITING_PACKET : at32f435_437_emac.h
  • emac_dma_separate_pbl_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_software_reset_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_software_reset_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_tansfer_address_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_DMA_TBU_FLAG : at32f435_437_emac.h
  • EMAC_DMA_TI_FLAG : at32f435_437_emac.h
  • EMAC_DMA_TJT_FLAG : at32f435_437_emac.h
  • EMAC_DMA_TPS_FLAG : at32f435_437_emac.h
  • emac_dma_transfer_address_type : at32f435_437_emac.h
  • EMAC_DMA_TRANSMIT : at32f435_437_emac.h
  • emac_dma_transmit_process_status_type : at32f435_437_emac.h
  • emac_dma_transmit_status_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_transmit_threshold_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_transmit_threshold_type : at32f435_437_emac.h
  • EMAC_DMA_TX_BUFFER : at32f435_437_emac.h
  • EMAC_DMA_TX_CLOSE_DESCRIPTOR : at32f435_437_emac.h
  • EMAC_DMA_TX_DESCRIPTOR : at32f435_437_emac.h
  • EMAC_DMA_TX_DESCRIPTOR_UNAVAILABLE : at32f435_437_emac.h
  • EMAC_DMA_TX_FETCH_DESCRIPTOR : at32f435_437_emac.h
  • EMAC_DMA_TX_HOST_TO_FIFO : at32f435_437_emac.h
  • EMAC_DMA_TX_RESET_STOP_COMMAND : at32f435_437_emac.h
  • emac_dma_tx_rx_type : at32f435_437_emac.h
  • EMAC_DMA_TX_THRESHOLD_128_BYTES : at32f435_437_emac.h
  • EMAC_DMA_TX_THRESHOLD_16_BYTES : at32f435_437_emac.h
  • EMAC_DMA_TX_THRESHOLD_192_BYTES : at32f435_437_emac.h
  • EMAC_DMA_TX_THRESHOLD_24_BYTES : at32f435_437_emac.h
  • EMAC_DMA_TX_THRESHOLD_256_BYTES : at32f435_437_emac.h
  • EMAC_DMA_TX_THRESHOLD_32_BYTES : at32f435_437_emac.h
  • EMAC_DMA_TX_THRESHOLD_40_BYTES : at32f435_437_emac.h
  • EMAC_DMA_TX_THRESHOLD_64_BYTES : at32f435_437_emac.h
  • EMAC_DMA_TX_WAITING_FOR_STATUS : at32f435_437_emac.h
  • EMAC_DMA_UNF_FLAG : at32f435_437_emac.h
  • EMAC_DMARXDESC_AFM : at32f435_437_emac.h
  • EMAC_DMARXDESC_B1AP : at32f435_437_emac.h
  • EMAC_DMARXDESC_B2AP : at32f435_437_emac.h
  • EMAC_DMARXDESC_CE : at32f435_437_emac.h
  • EMAC_DMARXDESC_DBE : at32f435_437_emac.h
  • EMAC_DMARXDESC_DE : at32f435_437_emac.h
  • EMAC_DMARXDESC_DIC : at32f435_437_emac.h
  • EMAC_DMARXDESC_ES : at32f435_437_emac.h
  • EMAC_DMARXDESC_FL : at32f435_437_emac.h
  • emac_dmarxdesc_frame_length_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_DMARXDESC_FRAME_LENGTHSHIFT : at32f435_437_emac.h
  • EMAC_DMARXDESC_FS : at32f435_437_emac.h
  • EMAC_DMARXDESC_FT : at32f435_437_emac.h
  • EMAC_DMARXDESC_IPV4HCE : at32f435_437_emac.h
  • EMAC_DMARXDESC_LC : at32f435_437_emac.h
  • EMAC_DMARXDESC_LE : at32f435_437_emac.h
  • EMAC_DMARXDESC_LS : at32f435_437_emac.h
  • EMAC_DMARXDESC_MAMPCE : at32f435_437_emac.h
  • EMAC_DMARXDESC_OE : at32f435_437_emac.h
  • EMAC_DMARXDESC_OWN : at32f435_437_emac.h
  • EMAC_DMARXDESC_RBS1 : at32f435_437_emac.h
  • EMAC_DMARXDESC_RBS2 : at32f435_437_emac.h
  • EMAC_DMARXDESC_RCH : at32f435_437_emac.h
  • EMAC_DMARXDESC_RE : at32f435_437_emac.h
  • EMAC_DMARXDESC_RER : at32f435_437_emac.h
  • EMAC_DMARXDESC_RWT : at32f435_437_emac.h
  • EMAC_DMARXDESC_SAF : at32f435_437_emac.h
  • EMAC_DMARXDESC_VLAN : at32f435_437_emac.h
  • EMAC_DMATXDESC_B1AP : at32f435_437_emac.h
  • EMAC_DMATxDesc_B2AP : at32f435_437_emac.h
  • EMAC_DMATXDESC_CC : at32f435_437_emac.h
  • EMAC_DMATXDESC_CIC : at32f435_437_emac.h
  • EMAC_DMATXDESC_CIC_BYPASS : at32f435_437_emac.h
  • EMAC_DMATXDESC_CIC_IPV4HEADER : at32f435_437_emac.h
  • EMAC_DMATXDESC_CIC_TUI_FULL : at32f435_437_emac.h
  • EMAC_DMATXDESC_CIC_TUI_SEG : at32f435_437_emac.h
  • EMAC_DMATXDESC_DB : at32f435_437_emac.h
  • EMAC_DMATXDESC_DC : at32f435_437_emac.h
  • EMAC_DMATXDESC_DP : at32f435_437_emac.h
  • EMAC_DMATXDESC_EC : at32f435_437_emac.h
  • EMAC_DMATXDESC_ED : at32f435_437_emac.h
  • EMAC_DMATXDESC_ES : at32f435_437_emac.h
  • EMAC_DMATXDESC_FF : at32f435_437_emac.h
  • EMAC_DMATXDESC_FS : at32f435_437_emac.h
  • EMAC_DMATXDESC_IC : at32f435_437_emac.h
  • EMAC_DMATXDESC_IHE : at32f435_437_emac.h
  • EMAC_DMATXDESC_JT : at32f435_437_emac.h
  • EMAC_DMATXDESC_LCA : at32f435_437_emac.h
  • EMAC_DMATXDESC_LCO : at32f435_437_emac.h
  • EMAC_DMATXDESC_LS : at32f435_437_emac.h
  • EMAC_DMATXDESC_NC : at32f435_437_emac.h
  • EMAC_DMATXDESC_OWN : at32f435_437_emac.h
  • EMAC_DMATXDESC_PCE : at32f435_437_emac.h
  • EMAC_DMATXDESC_TBS1 : at32f435_437_emac.h
  • EMAC_DMATXDESC_TBS2 : at32f435_437_emac.h
  • EMAC_DMATXDESC_TCH : at32f435_437_emac.h
  • EMAC_DMATXDESC_TER : at32f435_437_emac.h
  • EMAC_DMATXDESC_TTSE : at32f435_437_emac.h
  • EMAC_DMATXDESC_TTSS : at32f435_437_emac.h
  • EMAC_DMATXDESC_UF : at32f435_437_emac.h
  • EMAC_DMATXDESC_VF : at32f435_437_emac.h
  • emac_dstaddr_inverse_filter_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_duplex_mode_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_duplex_type : at32f435_437_emac.h
  • EMAC_EXTRA : at32f435_437_emac.h
  • emac_fast_speed_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_fcb_bpa_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_FULL_DUPLEX : at32f435_437_emac.h
  • emac_global_unicast_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_HALF_DUPLEX : at32f435_437_emac.h
  • emac_hash_multicast_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_hash_perfect_filter_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_hash_table_high32bits_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_hash_table_low32bits_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_hash_unicast_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_HCLK_BORDER_100MHZ : at32f435_437_emac.h
  • EMAC_HCLK_BORDER_150MHZ : at32f435_437_emac.h
  • EMAC_HCLK_BORDER_20MHZ : at32f435_437_emac.h
  • EMAC_HCLK_BORDER_250MHZ : at32f435_437_emac.h
  • EMAC_HCLK_BORDER_288MHZ : at32f435_437_emac.h
  • EMAC_HCLK_BORDER_35MHZ : at32f435_437_emac.h
  • EMAC_HCLK_BORDER_60MHZ : at32f435_437_emac.h
  • EMAC_HEADER : at32f435_437_emac.h
  • EMAC_INTERFRAME_GAP_40BIT : at32f435_437_emac.h
  • EMAC_INTERFRAME_GAP_48BIT : at32f435_437_emac.h
  • EMAC_INTERFRAME_GAP_56BIT : at32f435_437_emac.h
  • EMAC_INTERFRAME_GAP_64BIT : at32f435_437_emac.h
  • EMAC_INTERFRAME_GAP_72BIT : at32f435_437_emac.h
  • EMAC_INTERFRAME_GAP_80BIT : at32f435_437_emac.h
  • EMAC_INTERFRAME_GAP_88BIT : at32f435_437_emac.h
  • EMAC_INTERFRAME_GAP_96BIT : at32f435_437_emac.h
  • emac_interframe_gap_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_intergrame_gap_type : at32f435_437_emac.h
  • emac_interrupt_mask_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_interrupt_mask_type : at32f435_437_emac.h
  • EMAC_INTERRUPT_PMT_MASK : at32f435_437_emac.h
  • emac_interrupt_status_read() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_INTERRUPT_TST_MASK : at32f435_437_emac.h
  • emac_ipv4_checksum_offload_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_IRQHandler() : project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c, project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c, project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_int.c
  • emac_jabber_disable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_layer2_configuration() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • emac_local_address_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_loopback_mode_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_magic_packet_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_MAX_PACKET_LENGTH : at32f435_437_emac.h
  • EMAC_MAX_PAYLOAD : at32f435_437_emac.h
  • emac_mii_busy_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_mii_write() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_MIN_PAYLOAD : at32f435_437_emac.h
  • EMAC_MMC : at32f435_437_emac.h
  • emac_mmc_counter_freeze() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_mmc_counter_reset() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_MMC_FLAG : at32f435_437_emac.h
  • emac_mmc_received_error_frames_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_mmc_received_interrupt_mask_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_mmc_received_status_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_mmc_reset_on_read_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_mmc_rollover_stop() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_mmc_transmit_good_frames_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_mmc_transmit_interrupt_mask_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_mmc_transmit_status_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_MMCR_FLAG : at32f435_437_emac.h
  • EMAC_MMCT_FLAG : at32f435_437_emac.h
  • EMAC_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • emac_nvic_configuration() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • emac_pass_all_multicasting_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_pass_control_frames_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_PAUSE_144_SLOT_TIME : at32f435_437_emac.h
  • EMAC_PAUSE_256_SLOT_TIME : at32f435_437_emac.h
  • EMAC_PAUSE_28_SLOT_TIME : at32f435_437_emac.h
  • EMAC_PAUSE_4_SLOT_TIME : at32f435_437_emac.h
  • emac_pause_low_threshold_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_pause_slot_threshold_type : at32f435_437_emac.h
  • emac_pause_time_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_phy_init() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • emac_phy_register_read() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_phy_register_reset() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • emac_phy_register_write() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_pins_configuration() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • EMAC_PMT_FLAG : at32f435_437_emac.h
  • emac_power_down_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_promiscuous_mode_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_PTP : at32f435_437_emac.h
  • emac_ptp_addend_register_update() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_PTP_BOUNDARY_CLOCK : at32f435_437_emac.h
  • emac_ptp_clock_node_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_clock_node_type : at32f435_437_emac.h
  • EMAC_PTP_END_TO_END_CLOCK : at32f435_437_emac.h
  • emac_ptp_interrupt_trigger_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_mac_address_filter_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_PTP_NORMAL_CLOCK : at32f435_437_emac.h
  • EMAC_PTP_PEER_TO_PEER_CLOCK : at32f435_437_emac.h
  • EMAC_PTP_PPS_1024HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_128HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_16384HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_16HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_1HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_2048HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_256HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_2HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_32768HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_32HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_4096HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_4HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_512HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_64HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_8192HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_8HZ : at32f435_437_emac.h
  • emac_ptp_pps_control_type : at32f435_437_emac.h
  • emac_ptp_pps_frequency_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_psv2_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_PTP_SECOND_OVERFLOW : at32f435_437_emac.h
  • emac_ptp_snapshot_emac_frames_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_snapshot_event_message_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_snapshot_ipv4_frames_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_snapshot_ipv6_frames_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_snapshot_master_event_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_snapshot_received_frames_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_subsecond_increment_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_subsecond_rollover_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_system_second_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_system_second_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_system_subsecond_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_system_subsecond_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_system_time_sign_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_system_time_sign_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_target_nanosecond_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_target_second_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_PTP_TARGET_TIME_REACH : at32f435_437_emac.h
  • emac_ptp_timestamp_addend_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_timestamp_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_timestamp_fine_update_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_timestamp_status_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_timestamp_status_type : at32f435_437_emac.h
  • emac_ptp_timestamp_system_time_init() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_timestamp_system_time_update() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_receive_all_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_receive_flow_control_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_receive_own_disable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_received_magic_packet_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_received_packet_size_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_received_wakeup_frame_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_receiver_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_reset() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_retry_disable() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_SOURCE_FILTER : at32f435_437_emac.h
  • EMAC_SPEED_100MBPS : at32f435_437_emac.h
  • EMAC_SPEED_10MBPS : at32f435_437_emac.h
  • emac_speed_config() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • emac_speed_type : at32f435_437_emac.h
  • emac_srcaddr_filter_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_srcaddr_inverse_filter_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_start() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_stop() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_system_init() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • emac_tmr_init() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • emac_transmit_flow_control_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_trasmitter_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_TST_FLAG : at32f435_437_emac.h
  • emac_unicast_pause_frame_detect() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_vlan_tag_comparison_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_vlan_tag_identifier_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_wake_on_lan_init() : project/at_start_f437/examples/emac/wake_on_lan/src/main.c
  • emac_wakeup_frame_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_wakeup_frame_filter_reset() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_wakeup_frame_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_wakeup_frame_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_watchdog_disable() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_WKUP_IRQHandler() : project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c
  • emac_zero_quanta_pause_disable() : at32f435_437_emac.h, at32f435_437_emac.c
  • ENABLE_ERTC_ASSEED : random.h
  • endpoint_dir_type : at32f435_437_usb.h
  • endpoint_trans_type : at32f435_437_usb.h
  • EPT_BULK_TYPE : at32f435_437_usb.h
  • EPT_CONTROL_TYPE : at32f435_437_usb.h
  • EPT_DIR_IN : at32f435_437_usb.h
  • EPT_DIR_OUT : at32f435_437_usb.h
  • EPT_INT_TYPE : at32f435_437_usb.h
  • EPT_ISO_TYPE : at32f435_437_usb.h
  • ERASE_TIMEOUT : at32f435_437_flash.h
  • EraseChip() : FlashOS.h, FlashPrg.c
  • EraseSector() : FlashOS.h, FlashPrg.c
  • ERROR : at32f435_437.h
  • error_handler() : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c
  • ERROR_ID_VAL : project/at_start_f435/examples/usart/receiver_mute/src/main.c, project/at_start_f437/examples/usart/receiver_mute/src/main.c
  • error_status : at32f435_437.h
  • ERTC : at32f435_437_ertc.h
  • ERTC_24H : at32f435_437_ertc.h
  • ERTC_ALA : at32f435_437_ertc.h
  • ERTC_ALA_INT : at32f435_437_ertc.h
  • ERTC_ALAF_FLAG : at32f435_437_ertc.h
  • ertc_alarm_config() : project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/main.c
  • ertc_alarm_enable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_alarm_get() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ERTC_ALARM_MASK_ALL : at32f435_437_ertc.h
  • ERTC_ALARM_MASK_DATE_WEEK : at32f435_437_ertc.h
  • ERTC_ALARM_MASK_HOUR : at32f435_437_ertc.h
  • ERTC_ALARM_MASK_MIN : at32f435_437_ertc.h
  • ERTC_ALARM_MASK_NONE : at32f435_437_ertc.h
  • ERTC_ALARM_MASK_SEC : at32f435_437_ertc.h
  • ertc_alarm_mask_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ERTC_ALARM_SBS_MASK_14 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_1 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_10 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_11 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_12 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_13 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_2 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_3 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_4 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_5 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_6 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_7 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_8 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_9 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_ALL : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_NONE : at32f435_437_ertc.h
  • ertc_alarm_sbs_mask_type : at32f435_437_ertc.h
  • ertc_alarm_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_alarm_show() : project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c
  • ertc_alarm_sub_second_get() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_alarm_sub_second_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_alarm_type : at32f435_437_ertc.h
  • ertc_alarm_value_set() : project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/main.c
  • ertc_alarm_week_date_select() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ERTC_ALAWF_FLAG : at32f435_437_ertc.h
  • ERTC_ALB : at32f435_437_ertc.h
  • ERTC_ALB_INT : at32f435_437_ertc.h
  • ERTC_ALBF_FLAG : at32f435_437_ertc.h
  • ERTC_ALBWF_FLAG : at32f435_437_ertc.h
  • ERTC_AM : at32f435_437_ertc.h
  • ertc_am_pm_type : at32f435_437_ertc.h
  • ERTC_BASE : at32f435_437.h
  • ertc_bcd_to_num() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_bpr_data_read() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_bpr_data_write() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ERTC_BPR_DT_NUMBER : project/at_start_f435/examples/ertc/bpr_domain/src/main.c, project/at_start_f435/examples/ertc/tamper/src/main.c, project/at_start_f437/examples/ertc/bpr_domain/src/main.c, project/at_start_f437/examples/ertc/tamper/src/main.c
  • ERTC_CAL_DIR_NEGATIVE : at32f435_437_ertc.h
  • ERTC_CAL_DIR_POSITIVE : at32f435_437_ertc.h
  • ertc_cal_direction_type : at32f435_437_ertc.h
  • ERTC_CAL_OUTPUT_1HZ : at32f435_437_ertc.h
  • ERTC_CAL_OUTPUT_512HZ : at32f435_437_ertc.h
  • ertc_cal_output_enable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_cal_output_select() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_cal_output_select_type : at32f435_437_ertc.h
  • ertc_calendar_get() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ERTC_CALUPDF_FLAG : at32f435_437_ertc.h
  • ertc_clk_div_a : project/at_start_f435/examples/ertc/calendar/src/main.c, project/at_start_f437/examples/ertc/calendar/src/main.c, random.c
  • ertc_clk_div_b : project/at_start_f435/examples/ertc/calendar/src/main.c, project/at_start_f437/examples/ertc/calendar/src/main.c, random.c
  • ERTC_CLOCK_SOURCE_LEXT : project/at_start_f435/examples/ertc/calendar/src/main.c, project/at_start_f437/examples/ertc/calendar/src/main.c
  • ertc_coarse_calibration_enable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_coarse_calibration_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_config() : project/at_start_f435/examples/ertc/bpr_domain/src/main.c, project/at_start_f435/examples/ertc/calendar/src/main.c, project/at_start_f435/examples/ertc/lick_calibration/src/main.c, project/at_start_f435/examples/ertc/tamper/src/main.c, project/at_start_f435/examples/ertc/time_stamp/src/main.c, project/at_start_f435/examples/ertc/wakeup_timer/src/main.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/main.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/main.c, project/at_start_f435/examples/pwc/ldo_set/src/main.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/main.c
  • ertc_date_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_daylight_bpr_get() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_daylight_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_direct_read_enable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_divider_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ERTC_DST_ADD_1H : at32f435_437_ertc.h
  • ERTC_DST_DEC_1H : at32f435_437_ertc.h
  • ertc_dst_operation_type : at32f435_437_ertc.h
  • ERTC_DST_SAVE_0 : at32f435_437_ertc.h
  • ERTC_DST_SAVE_1 : at32f435_437_ertc.h
  • ertc_dst_save_type : at32f435_437_ertc.h
  • ERTC_DT1 : at32f435_437_ertc.h
  • ERTC_DT10 : at32f435_437_ertc.h
  • ERTC_DT11 : at32f435_437_ertc.h
  • ERTC_DT12 : at32f435_437_ertc.h
  • ERTC_DT13 : at32f435_437_ertc.h
  • ERTC_DT14 : at32f435_437_ertc.h
  • ERTC_DT15 : at32f435_437_ertc.h
  • ERTC_DT16 : at32f435_437_ertc.h
  • ERTC_DT17 : at32f435_437_ertc.h
  • ERTC_DT18 : at32f435_437_ertc.h
  • ERTC_DT19 : at32f435_437_ertc.h
  • ERTC_DT2 : at32f435_437_ertc.h
  • ERTC_DT20 : at32f435_437_ertc.h
  • ERTC_DT3 : at32f435_437_ertc.h
  • ERTC_DT4 : at32f435_437_ertc.h
  • ERTC_DT5 : at32f435_437_ertc.h
  • ERTC_DT6 : at32f435_437_ertc.h
  • ERTC_DT7 : at32f435_437_ertc.h
  • ERTC_DT8 : at32f435_437_ertc.h
  • ERTC_DT9 : at32f435_437_ertc.h
  • ertc_dt_type : at32f435_437_ertc.h
  • ertc_flag_clear() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_flag_get() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ERTC_HOUR_MODE_12 : at32f435_437_ertc.h
  • ERTC_HOUR_MODE_24 : at32f435_437_ertc.h
  • ertc_hour_mode_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_hour_mode_set_type : at32f435_437_ertc.h
  • ERTC_IMF_FLAG : at32f435_437_ertc.h
  • ertc_init_mode_enter() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_init_mode_exit() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ERTC_INITF_FLAG : at32f435_437_ertc.h
  • ertc_interrupt_enable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_interrupt_get() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ERTC_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • ertc_num_to_bcd() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ERTC_OUTPUT_ALARM_A : at32f435_437_ertc.h
  • ERTC_OUTPUT_ALARM_B : at32f435_437_ertc.h
  • ERTC_OUTPUT_DISABLE : at32f435_437_ertc.h
  • ERTC_OUTPUT_POLARITY_HIGH : at32f435_437_ertc.h
  • ERTC_OUTPUT_POLARITY_LOW : at32f435_437_ertc.h
  • ertc_output_polarity_type : at32f435_437_ertc.h
  • ertc_output_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_output_source_type : at32f435_437_ertc.h
  • ertc_output_type : at32f435_437_ertc.h
  • ERTC_OUTPUT_TYPE_OPEN_DRAIN : at32f435_437_ertc.h
  • ERTC_OUTPUT_TYPE_PUSH_PULL : at32f435_437_ertc.h
  • ERTC_OUTPUT_WAKEUP : at32f435_437_ertc.h
  • ERTC_PIN_PA0 : at32f435_437_ertc.h
  • ERTC_PIN_PC13 : at32f435_437_ertc.h
  • ertc_pin_select_type : at32f435_437_ertc.h
  • ERTC_PM : at32f435_437_ertc.h
  • ertc_refer_clock_detect_enable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_reset() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ERTC_SLECT_DATE : at32f435_437_ertc.h
  • ERTC_SLECT_WEEK : at32f435_437_ertc.h
  • ERTC_SMOOTH_CAL_CLK_ADD_0 : at32f435_437_ertc.h
  • ERTC_SMOOTH_CAL_CLK_ADD_512 : at32f435_437_ertc.h
  • ertc_smooth_cal_clk_add_type : at32f435_437_ertc.h
  • ERTC_SMOOTH_CAL_PERIOD_16 : at32f435_437_ertc.h
  • ERTC_SMOOTH_CAL_PERIOD_32 : at32f435_437_ertc.h
  • ERTC_SMOOTH_CAL_PERIOD_8 : at32f435_437_ertc.h
  • ertc_smooth_cal_period_type : at32f435_437_ertc.h
  • ertc_smooth_calibration_config() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_sub_second_get() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ERTC_TADJF_FLAG : at32f435_437_ertc.h
  • ERTC_TAMPER_1 : at32f435_437_ertc.h
  • ertc_tamper_1_pin_select() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ERTC_TAMPER_2 : at32f435_437_ertc.h
  • ertc_tamper_config() : project/at_start_f435/examples/ertc/tamper/src/main.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/main.c, project/at_start_f435/examples/pwc/ldo_set/src/main.c
  • ertc_tamper_detect_freq_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_tamper_detect_freq_type : at32f435_437_ertc.h
  • ERTC_TAMPER_EDGE_FALLING : at32f435_437_ertc.h
  • ERTC_TAMPER_EDGE_HIGH : at32f435_437_ertc.h
  • ERTC_TAMPER_EDGE_LOW : at32f435_437_ertc.h
  • ERTC_TAMPER_EDGE_RISING : at32f435_437_ertc.h
  • ertc_tamper_enable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ERTC_TAMPER_FILTER_2 : at32f435_437_ertc.h
  • ERTC_TAMPER_FILTER_4 : at32f435_437_ertc.h
  • ERTC_TAMPER_FILTER_8 : at32f435_437_ertc.h
  • ERTC_TAMPER_FILTER_DISABLE : at32f435_437_ertc.h
  • ertc_tamper_filter_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_tamper_filter_type : at32f435_437_ertc.h
  • ERTC_TAMPER_FREQ_DIV_1024 : at32f435_437_ertc.h
  • ERTC_TAMPER_FREQ_DIV_16384 : at32f435_437_ertc.h
  • ERTC_TAMPER_FREQ_DIV_2048 : at32f435_437_ertc.h
  • ERTC_TAMPER_FREQ_DIV_256 : at32f435_437_ertc.h
  • ERTC_TAMPER_FREQ_DIV_32768 : at32f435_437_ertc.h
  • ERTC_TAMPER_FREQ_DIV_4096 : at32f435_437_ertc.h
  • ERTC_TAMPER_FREQ_DIV_512 : at32f435_437_ertc.h
  • ERTC_TAMPER_FREQ_DIV_8192 : at32f435_437_ertc.h
  • ERTC_TAMPER_PR_1_ERTCCLK : at32f435_437_ertc.h
  • ERTC_TAMPER_PR_2_ERTCCLK : at32f435_437_ertc.h
  • ERTC_TAMPER_PR_4_ERTCCLK : at32f435_437_ertc.h
  • ERTC_TAMPER_PR_8_ERTCCLK : at32f435_437_ertc.h
  • ertc_tamper_precharge_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_tamper_precharge_type : at32f435_437_ertc.h
  • ertc_tamper_pull_up_enable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_tamper_select_type : at32f435_437_ertc.h
  • ertc_tamper_timestamp_enable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_tamper_valid_edge_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_tamper_valid_edge_type : at32f435_437_ertc.h
  • ERTC_TIME_ADD_1S : at32f435_437_ertc.h
  • ERTC_TIME_ADD_NONE : at32f435_437_ertc.h
  • ertc_time_adjust() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_time_adjust_type : at32f435_437_ertc.h
  • ertc_time_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_time_show() : project/at_start_f435/examples/ertc/calendar/src/main.c, project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c
  • ERTC_TIMEOUT : at32f435_437_ertc.c
  • ertc_timestamp_config() : project/at_start_f435/examples/ertc/time_stamp/src/main.c
  • ERTC_TIMESTAMP_EDGE_FALLING : at32f435_437_ertc.h
  • ERTC_TIMESTAMP_EDGE_RISING : at32f435_437_ertc.h
  • ertc_timestamp_enable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_timestamp_get() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_timestamp_pin_select() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_timestamp_show() : project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c
  • ertc_timestamp_sub_second_get() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_timestamp_valid_edge_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_timestamp_valid_edge_type : at32f435_437_ertc.h
  • ERTC_TP1F_FLAG : at32f435_437_ertc.h
  • ERTC_TP2F_FLAG : at32f435_437_ertc.h
  • ERTC_TP_INT : at32f435_437_ertc.h
  • ERTC_TS_INT : at32f435_437_ertc.h
  • ERTC_TSF_FLAG : at32f435_437_ertc.h
  • ERTC_TSOF_FLAG : at32f435_437_ertc.h
  • ERTC_UPDF_FLAG : at32f435_437_ertc.h
  • ertc_wait_flag() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_wait_update() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_wakeup_clock_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_wakeup_clock_type : at32f435_437_ertc.h
  • ertc_wakeup_counter_get() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_wakeup_counter_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_wakeup_enable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_wakeup_show() : project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c
  • ertc_wakeup_timer_config() : project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/main.c
  • ERTC_WAT_CLK_CK_A_16BITS : at32f435_437_ertc.h
  • ERTC_WAT_CLK_CK_A_17BITS : at32f435_437_ertc.h
  • ERTC_WAT_CLK_CK_B_16BITS : at32f435_437_ertc.h
  • ERTC_WAT_CLK_CK_B_17BITS : at32f435_437_ertc.h
  • ERTC_WAT_CLK_ERTCCLK_DIV16 : at32f435_437_ertc.h
  • ERTC_WAT_CLK_ERTCCLK_DIV2 : at32f435_437_ertc.h
  • ERTC_WAT_CLK_ERTCCLK_DIV4 : at32f435_437_ertc.h
  • ERTC_WAT_CLK_ERTCCLK_DIV8 : at32f435_437_ertc.h
  • ERTC_WAT_INT : at32f435_437_ertc.h
  • ERTC_WATF_FLAG : at32f435_437_ertc.h
  • ERTC_WATWF_FLAG : at32f435_437_ertc.h
  • ertc_week_date_select_type : at32f435_437_ertc.h
  • ERTC_WKUP_IRQHandler() : project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c
  • ERTC_WKUP_IRQn : at32f435_437.h
  • ertc_write_protect_disable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_write_protect_enable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ERTCAlarm_IRQHandler() : project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c
  • ERTCAlarm_IRQn : at32f435_437.h
  • escalator8bit : project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c, project/at_start_f437/examples/dac/one_dac_dma_escalator/src/main.c
  • esmt32m_cmd_config : at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_erase_config() : at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_qpien_config() : at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_rdsr_config() : at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_read_config() : at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_read_pem_begin_config() : at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_read_pem_end_config() : at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_read_pem_keep_config() : at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_rst_config() : at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_rsten_config() : at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_rstqpi_config() : at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_send() : at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_wren_config() : at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_write_config() : at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c
  • esmt32m_qpi_mode_init() : project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c
  • ETHARP_SUPPORT_STATIC_ENTRIES : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • ethernetif_notify_conn_changed() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • ethernetif_set_link() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • ethernetif_update_config() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • EXINT : at32f435_437_exint.h
  • EXINT0_IRQHandler() : project/at_start_f435/examples/exint/exint_config/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f435/examples/usb_host/hid_demo/src/main.c, project/at_start_f435/templates/src/main.c
  • EXINT0_IRQn : at32f435_437.h
  • EXINT15_10_IRQn : at32f435_437.h
  • EXINT1_IRQHandler() : project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c
  • EXINT1_IRQn : at32f435_437.h
  • EXINT2_IRQn : at32f435_437.h
  • EXINT3_IRQn : at32f435_437.h
  • EXINT4_IRQHandler() : project/at_start_f435/examples/exint/exint_software_trigger/src/main.c
  • EXINT4_IRQn : at32f435_437.h
  • EXINT9_5_IRQHandler() : project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c
  • EXINT9_5_IRQn : at32f435_437.h
  • EXINT_BASE : at32f435_437.h
  • exint_config() : project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c
  • exint_default_para_init() : at32f435_437_exint.h, at32f435_437_exint.c
  • exint_event_enable() : at32f435_437_exint.h, at32f435_437_exint.c
  • exint_flag_clear() : at32f435_437_exint.h, at32f435_437_exint.c
  • exint_flag_get() : at32f435_437_exint.h, at32f435_437_exint.c
  • exint_init() : at32f435_437_exint.h, at32f435_437_exint.c
  • exint_init_struct : project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/main.c
  • exint_interrupt_enable() : at32f435_437_exint.h, at32f435_437_exint.c
  • exint_line0_config() : project/at_start_f435/examples/exint/exint_config/src/main.c
  • exint_line4_config() : project/at_start_f435/examples/exint/exint_software_trigger/src/main.c
  • EXINT_LINE_0 : at32f435_437_exint.h
  • EXINT_LINE_1 : at32f435_437_exint.h
  • EXINT_LINE_10 : at32f435_437_exint.h
  • EXINT_LINE_11 : at32f435_437_exint.h
  • EXINT_LINE_12 : at32f435_437_exint.h
  • EXINT_LINE_13 : at32f435_437_exint.h
  • EXINT_LINE_14 : at32f435_437_exint.h
  • EXINT_LINE_15 : at32f435_437_exint.h
  • EXINT_LINE_16 : at32f435_437_exint.h
  • EXINT_LINE_17 : at32f435_437_exint.h
  • EXINT_LINE_18 : at32f435_437_exint.h
  • EXINT_LINE_19 : at32f435_437_exint.h
  • EXINT_LINE_2 : at32f435_437_exint.h
  • EXINT_LINE_20 : at32f435_437_exint.h
  • EXINT_LINE_21 : at32f435_437_exint.h
  • EXINT_LINE_22 : at32f435_437_exint.h
  • EXINT_LINE_3 : at32f435_437_exint.h
  • EXINT_LINE_4 : at32f435_437_exint.h
  • EXINT_LINE_5 : at32f435_437_exint.h
  • EXINT_LINE_6 : at32f435_437_exint.h
  • EXINT_LINE_7 : at32f435_437_exint.h
  • EXINT_LINE_8 : at32f435_437_exint.h
  • EXINT_LINE_9 : at32f435_437_exint.h
  • EXINT_LINE_EVENT : at32f435_437_exint.h
  • EXINT_LINE_INTERRUPUT : at32f435_437_exint.h
  • exint_line_mode_type : at32f435_437_exint.h
  • EXINT_LINE_NONE : at32f435_437_exint.h
  • EXINT_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • exint_polarity_config_type : at32f435_437_exint.h
  • exint_reset() : at32f435_437_exint.h, at32f435_437_exint.c
  • exint_software_interrupt_event_generate() : at32f435_437_exint.h, at32f435_437_exint.c
  • EXINT_TRIGGER_BOTH_EDGE : at32f435_437_exint.h
  • EXINT_TRIGGER_FALLING_EDGE : at32f435_437_exint.h
  • EXINT_TRIGGER_RISING_EDGE : at32f435_437_exint.h
  • EXT16BIT : FlashOS.h
  • EXT32BIT : FlashOS.h
  • EXT8BIT : FlashOS.h
  • EXT_CSD_BUS_WIDTH : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_Clear_byte : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_CMD_SET_CPSECURE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_CMD_SET_NORMAL : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_CMD_SET_SECURE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_Command_set : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_HS_TIMING : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_Set_bit : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_Write_byte : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • extend_sram() : project/at_start_f435/examples/sram/extend_sram/src/main.c, project/at_start_f437/examples/sram/extend_sram/src/main.c
  • EXTSPI : FlashOS.h


AT32F435/437 Firmwary Library: Globals

- a -

  • adc_channel_select_type : at32f435_437_adc.h
  • adc_combine_mode_type : at32f435_437_adc.h
  • adc_common_dma_mode_type : at32f435_437_adc.h
  • adc_data_align_type : at32f435_437_adc.h
  • adc_div_type : at32f435_437_adc.h
  • adc_ordinary_oversample_restart_type : at32f435_437_adc.h
  • adc_ordinary_trig_edge_type : at32f435_437_adc.h
  • adc_ordinary_trig_select_type : at32f435_437_adc.h
  • adc_oversample_ratio_type : at32f435_437_adc.h
  • adc_oversample_shift_type : at32f435_437_adc.h
  • adc_preempt_channel_type : at32f435_437_adc.h
  • adc_preempt_trig_edge_type : at32f435_437_adc.h
  • adc_preempt_trig_select_type : at32f435_437_adc.h
  • adc_resolution_type : at32f435_437_adc.h
  • adc_sampletime_select_type : at32f435_437_adc.h
  • adc_sampling_interval_type : at32f435_437_adc.h
  • adc_voltage_monitoring_type : at32f435_437_adc.h


AT32F435/437 Firmwary Library: Globals

- b -

  • button_type : at32f435_437_board.h


AT32F435/437 Firmwary Library: Globals

- c -

  • can_bts1_type : at32f435_437_can.h
  • can_bts2_type : at32f435_437_can.h
  • can_enter_doze_status_type : at32f435_437_can.h
  • can_error_record_type : at32f435_437_can.h
  • can_filter_bit_width_type : at32f435_437_can.h
  • can_filter_fifo_type : at32f435_437_can.h
  • can_filter_mode_type : at32f435_437_can.h
  • can_identifier_type : at32f435_437_can.h
  • can_mode_type : at32f435_437_can.h
  • can_msg_discarding_rule_type : at32f435_437_can.h
  • can_msg_sending_rule_type : at32f435_437_can.h
  • can_operating_mode_type : at32f435_437_can.h
  • can_quit_doze_status_type : at32f435_437_can.h
  • can_rsaw_type : at32f435_437_can.h
  • can_rx_fifo_num_type : at32f435_437_can.h
  • can_trans_frame_type : at32f435_437_can.h
  • can_transmit_status_type : at32f435_437_can.h
  • can_tx_mailbox_num_type : at32f435_437_can.h
  • cmd_ctr_step_type : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • cmd_data_step_type : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • confirm_state : at32f435_437.h
  • crc_reverse_input_type : at32f435_437_crc.h
  • crc_reverse_output_type : at32f435_437_crc.h
  • crm_ahb_div_type : at32f435_437_crm.h
  • crm_apb1_div_type : at32f435_437_crm.h
  • crm_apb2_div_type : at32f435_437_crm.h
  • crm_auto_step_mode_type : at32f435_437_crm.h
  • crm_clkout1_select_type : at32f435_437_crm.h
  • crm_clkout2_select_type : at32f435_437_crm.h
  • crm_clkout_div1_type : at32f435_437_crm.h
  • crm_clkout_div2_type : at32f435_437_crm.h
  • crm_clkout_index_type : at32f435_437_crm.h
  • crm_clock_source_type : at32f435_437_crm.h
  • crm_emac_output_pulse_type : at32f435_437_crm.h
  • crm_ertc_clock_type : at32f435_437_crm.h
  • crm_hick_div_6_type : at32f435_437_crm.h
  • crm_hick_sclk_frequency_type : at32f435_437_crm.h
  • crm_periph_clock_lowpower_type : at32f435_437_crm.h
  • crm_periph_clock_type : at32f435_437_crm.h
  • crm_periph_reset_type : at32f435_437_crm.h
  • crm_pll_clock_source_type : at32f435_437_crm.h
  • crm_pll_fr_type : at32f435_437_crm.h
  • crm_sclk_type : at32f435_437_crm.h
  • crm_usb_clock_source_type : at32f435_437_crm.h
  • crm_usb_div_type : at32f435_437_crm.h


AT32F435/437 Firmwary Library: Globals

- d -

  • dac1_aligned_data_type : at32f435_437_dac.h
  • dac2_aligned_data_type : at32f435_437_dac.h
  • dac_dual_data_type : at32f435_437_dac.h
  • dac_mask_amplitude_type : at32f435_437_dac.h
  • dac_select_type : at32f435_437_dac.h
  • dac_trigger_type : at32f435_437_dac.h
  • dac_wave_type : at32f435_437_dac.h
  • dcfg_perfrint_type : at32f435_437_usb.h
  • dma_dir_type : at32f435_437_dma.h
  • dma_memory_data_size_type : at32f435_437_dma.h
  • dma_peripheral_data_size_type : at32f435_437_dma.h
  • dma_priority_level_type : at32f435_437_dma.h
  • dmamux_gen_id_sel_type : at32f435_437_dma.h
  • dmamux_gen_pol_type : at32f435_437_dma.h
  • dmamux_requst_id_sel_type : at32f435_437_dma.h
  • dmamux_sync_id_sel_type : at32f435_437_dma.h
  • dmamux_sync_pol_type : at32f435_437_dma.h
  • dvp_bfrc_type : at32f435_437_dvp.h
  • dvp_cfm_type : at32f435_437_dvp.h
  • dvp_ckp_type : at32f435_437_dvp.h
  • dvp_dmabt_type : at32f435_437_dvp.h
  • dvp_efdf_type : at32f435_437_dvp.h
  • dvp_hseid_type : at32f435_437_dvp.h
  • dvp_hsp_type : at32f435_437_dvp.h
  • dvp_idun_type : at32f435_437_dvp.h
  • dvp_idus_type : at32f435_437_dvp.h
  • dvp_lcdc_type : at32f435_437_dvp.h
  • dvp_lcds_type : at32f435_437_dvp.h
  • dvp_pcdc_type : at32f435_437_dvp.h
  • dvp_pcdes_type : at32f435_437_dvp.h
  • dvp_pcds_type : at32f435_437_dvp.h
  • dvp_pdl_type : at32f435_437_dvp.h
  • dvp_sm_type : at32f435_437_dvp.h
  • dvp_status_basic_type : at32f435_437_dvp.h
  • dvp_vseid_type : at32f435_437_dvp.h
  • dvp_vsp_type : at32f435_437_dvp.h


AT32F435/437 Firmwary Library: Globals

- e -

  • edma_dir_type : at32f435_437_edma.h
  • edma_fifo_stutas_type : at32f435_437_edma.h
  • edma_fifo_threshold_type : at32f435_437_edma.h
  • edma_memory_burst_type : at32f435_437_edma.h
  • edma_memory_data_size_type : at32f435_437_edma.h
  • edma_memory_type : at32f435_437_edma.h
  • edma_peripheral_burst_type : at32f435_437_edma.h
  • edma_peripheral_data_size_type : at32f435_437_edma.h
  • edma_peripheral_inc_offset_type : at32f435_437_edma.h
  • edma_priority_level_type : at32f435_437_edma.h
  • edmamux_gen_id_sel_type : at32f435_437_edma.h
  • edmamux_gen_pol_type : at32f435_437_edma.h
  • edmamux_requst_id_sel_type : at32f435_437_edma.h
  • edmamux_sync_id_sel_type : at32f435_437_edma.h
  • edmamux_sync_pol_type : at32f435_437_edma.h
  • emac_address_filter_type : at32f435_437_emac.h
  • emac_address_mask_type : at32f435_437_emac.h
  • emac_address_type : at32f435_437_emac.h
  • emac_auto_negotiation_type : at32f435_437_emac.h
  • emac_bol_type : at32f435_437_emac.h
  • emac_clock_range_type : at32f435_437_emac.h
  • emac_control_frames_filter_type : at32f435_437_emac.h
  • emac_dma_interrupt_type : at32f435_437_emac.h
  • emac_dma_operations_type : at32f435_437_emac.h
  • emac_dma_pbl_type : at32f435_437_emac.h
  • emac_dma_receive_process_status_type : at32f435_437_emac.h
  • emac_dma_receive_threshold_type : at32f435_437_emac.h
  • emac_dma_rx_tx_ratio_type : at32f435_437_emac.h
  • emac_dma_transfer_address_type : at32f435_437_emac.h
  • emac_dma_transmit_process_status_type : at32f435_437_emac.h
  • emac_dma_transmit_threshold_type : at32f435_437_emac.h
  • emac_dma_tx_rx_type : at32f435_437_emac.h
  • emac_duplex_type : at32f435_437_emac.h
  • emac_intergrame_gap_type : at32f435_437_emac.h
  • emac_interrupt_mask_type : at32f435_437_emac.h
  • emac_pause_slot_threshold_type : at32f435_437_emac.h
  • emac_ptp_clock_node_type : at32f435_437_emac.h
  • emac_ptp_pps_control_type : at32f435_437_emac.h
  • emac_ptp_timestamp_status_type : at32f435_437_emac.h
  • emac_speed_type : at32f435_437_emac.h
  • endpoint_dir_type : at32f435_437_usb.h
  • endpoint_trans_type : at32f435_437_usb.h
  • error_status : at32f435_437.h
  • ertc_alarm_sbs_mask_type : at32f435_437_ertc.h
  • ertc_alarm_type : at32f435_437_ertc.h
  • ertc_am_pm_type : at32f435_437_ertc.h
  • ertc_cal_direction_type : at32f435_437_ertc.h
  • ertc_cal_output_select_type : at32f435_437_ertc.h
  • ertc_dst_operation_type : at32f435_437_ertc.h
  • ertc_dst_save_type : at32f435_437_ertc.h
  • ertc_dt_type : at32f435_437_ertc.h
  • ertc_hour_mode_set_type : at32f435_437_ertc.h
  • ertc_output_polarity_type : at32f435_437_ertc.h
  • ertc_output_source_type : at32f435_437_ertc.h
  • ertc_output_type : at32f435_437_ertc.h
  • ertc_pin_select_type : at32f435_437_ertc.h
  • ertc_smooth_cal_clk_add_type : at32f435_437_ertc.h
  • ertc_smooth_cal_period_type : at32f435_437_ertc.h
  • ertc_tamper_detect_freq_type : at32f435_437_ertc.h
  • ertc_tamper_filter_type : at32f435_437_ertc.h
  • ertc_tamper_precharge_type : at32f435_437_ertc.h
  • ertc_tamper_select_type : at32f435_437_ertc.h
  • ertc_tamper_valid_edge_type : at32f435_437_ertc.h
  • ertc_time_adjust_type : at32f435_437_ertc.h
  • ertc_timestamp_valid_edge_type : at32f435_437_ertc.h
  • ertc_wakeup_clock_type : at32f435_437_ertc.h
  • ertc_week_date_select_type : at32f435_437_ertc.h
  • exint_line_mode_type : at32f435_437_exint.h
  • exint_polarity_config_type : at32f435_437_exint.h


AT32F435/437 Firmwary Library: Globals

- f -

  • flag_status : at32f435_437.h
  • flash_clock_divider_type : at32f435_437_flash.h
  • flash_status_type : at32f435_437_flash.h
  • flash_usd_eopb0_type : at32f435_437_flash.h


AT32F435/437 Firmwary Library: Globals

- g -

  • gpio_drive_type : at32f435_437_gpio.h
  • gpio_mode_type : at32f435_437_gpio.h
  • gpio_mux_sel_type : at32f435_437_gpio.h
  • gpio_output_type : at32f435_437_gpio.h
  • gpio_pins_source_type : at32f435_437_gpio.h
  • gpio_pull_type : at32f435_437_gpio.h


AT32F435/437 Firmwary Library: Globals

- i -

  • i2c_addr2_mask_type : at32f435_437_i2c.h
  • i2c_address_mode_type : at32f435_437_i2c.h
  • i2c_dma_request_type : at32f435_437_i2c.h
  • i2c_mode_type : i2c_application.h
  • i2c_reload_stop_mode_type : at32f435_437_i2c.h
  • i2c_smbus_alert_set_type : at32f435_437_i2c.h
  • i2c_smbus_mode_type : at32f435_437_i2c.h
  • i2c_start_mode_type : at32f435_437_i2c.h
  • i2c_status_type : i2c_application.h
  • i2c_timeout_detcet_type : at32f435_437_i2c.h
  • i2c_transfer_dir_type : at32f435_437_i2c.h
  • i2s_audio_protocol_type : at32f435_437_spi.h
  • i2s_audio_sampling_freq_type : at32f435_437_spi.h
  • i2s_clock_polarity_type : at32f435_437_spi.h
  • i2s_data_channel_format_type : at32f435_437_spi.h
  • i2s_operation_mode_type : at32f435_437_spi.h
  • iap_machine_state_type : hid_iap_class.h
  • iap_result_type : hid_iap_class.h
  • IRQn : at32f435_437.h


AT32F435/437 Firmwary Library: Globals

- l -

  • led_type : at32f435_437_board.h


AT32F435/437 Firmwary Library: Globals

- m -

  • msc_bot_state_type : usbh_msc_bot_scsi.h
  • msc_cmd_state_type : usbh_msc_bot_scsi.h
  • msc_error_type : usbh_msc_bot_scsi.h
  • msc_state_type : usbh_msc_bot_scsi.h
  • msc_usr_state : at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c


AT32F435/437 Firmwary Library: Globals

- n -

  • nor_status : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • nvic_lowpower_mode_type : at32f435_437_misc.h
  • nvic_priority_group_type : at32f435_437_misc.h


AT32F435/437 Firmwary Library: Globals

- o -

  • otg_id_type : at32f435_437_usb.h
  • otg_mode_type : at32f435_437_usb.h


AT32F435/437 Firmwary Library: Globals

- p -

  • pem_step_type : at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c
  • printer_req_type : printer_class.h
  • pwc_deep_sleep_enter_type : at32f435_437_pwc.h
  • pwc_ldo_output_voltage_type : at32f435_437_pwc.h
  • pwc_pvm_voltage_type : at32f435_437_pwc.h
  • pwc_regulator_type : at32f435_437_pwc.h
  • pwc_sleep_enter_type : at32f435_437_pwc.h


AT32F435/437 Firmwary Library: Globals

- q -

  • qspi_busy_pos_type : at32f435_437_qspi.h
  • qspi_clk_div_type : at32f435_437_qspi.h
  • qspi_clk_mode_type : at32f435_437_qspi.h
  • qspi_cmd_adrlen_type : at32f435_437_qspi.h
  • qspi_cmd_inslen_type : at32f435_437_qspi.h
  • qspi_dma_fifo_thod_type : at32f435_437_qspi.h
  • qspi_operate_mode_type : at32f435_437_qspi.h
  • qspi_read_status_conf_type : at32f435_437_qspi.h
  • qspi_xip_addrlen_type : at32f435_437_qspi.h
  • qspi_xip_read_sel_type : at32f435_437_qspi.h
  • qspi_xip_write_sel_type : at32f435_437_qspi.h


AT32F435/437 Firmwary Library: Globals

- s -

  • scfg_emac_interface_type : at32f435_437_scfg.h
  • scfg_ir_polarity_type : at32f435_437_scfg.h
  • scfg_ir_source_type : at32f435_437_scfg.h
  • scfg_mem_map_type : at32f435_437_scfg.h
  • scfg_pins_source_type : at32f435_437_scfg.h
  • scfg_port_source_type : at32f435_437_scfg.h
  • scfg_ultra_driven_pins_type : at32f435_437_scfg.h
  • scfg_xmc_swap_type : at32f435_437_scfg.h
  • sd_card_state_type : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sd_data_transfer_mode_type : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sd_error_status_type : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sd_memory_card_type : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sdio_block_size_type : at32f435_437_sdio.h
  • sdio_bus_width_type : at32f435_437_sdio.h
  • sdio_edge_phase_type : at32f435_437_sdio.h
  • sdio_power_state_type : at32f435_437_sdio.h
  • sdio_read_wait_mode_type : at32f435_437_sdio.h
  • sdio_reponse_type : at32f435_437_sdio.h
  • sdio_rsp_index_type : at32f435_437_sdio.h
  • sdio_transfer_direction_type : at32f435_437_sdio.h
  • sdio_transfer_mode_type : at32f435_437_sdio.h
  • sdio_wait_type : at32f435_437_sdio.h
  • spi_clock_phase_type : at32f435_437_spi.h
  • spi_clock_polarity_type : at32f435_437_spi.h
  • spi_crc_direction_type : at32f435_437_spi.h
  • spi_cs_mode_type : at32f435_437_spi.h
  • spi_first_bit_type : at32f435_437_spi.h
  • spi_frame_bit_num_type : at32f435_437_spi.h
  • spi_half_duplex_direction_type : at32f435_437_spi.h
  • spi_master_slave_mode_type : at32f435_437_spi.h
  • spi_mclk_freq_div_type : at32f435_437_spi.h
  • spi_software_cs_level_type : at32f435_437_spi.h
  • spi_transmission_mode_type : at32f435_437_spi.h
  • sub_tmr_input_sel_type : at32f435_437_tmr.h
  • systick_clock_source_type : at32f435_437_misc.h


AT32F435/437 Firmwary Library: Globals

- t -

  • test_result_type : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sdio_fatfs/src/main.c
  • tftp_errorcode : tftpserver.h
  • tftp_opcode : tftpserver.h
  • tmr_brk_polarity_type : at32f435_437_tmr.h
  • tmr_channel1_input_connected_type : at32f435_437_tmr.h
  • tmr_channel_input_divider_type : at32f435_437_tmr.h
  • tmr_channel_select_type : at32f435_437_tmr.h
  • tmr_clock_division_type : at32f435_437_tmr.h
  • tmr_count_mode_type : at32f435_437_tmr.h
  • tmr_dma_address_type : at32f435_437_tmr.h
  • tmr_dma_request_source_type : at32f435_437_tmr.h
  • tmr_dma_request_type : at32f435_437_tmr.h
  • tmr_dma_transfer_length_type : at32f435_437_tmr.h
  • tmr_encoder_mode_type : at32f435_437_tmr.h
  • tmr_event_trigger_type : at32f435_437_tmr.h
  • tmr_external_signal_divider_type : at32f435_437_tmr.h
  • tmr_external_signal_polarity_type : at32f435_437_tmr.h
  • tmr_force_output_type : at32f435_437_tmr.h
  • tmr_input_direction_mapped_type : at32f435_437_tmr.h
  • tmr_input_polarity_type : at32f435_437_tmr.h
  • tmr_input_remap_type : at32f435_437_tmr.h
  • tmr_output_control_mode_type : at32f435_437_tmr.h
  • tmr_output_polarity_type : at32f435_437_tmr.h
  • tmr_polarity_active_type : at32f435_437_tmr.h
  • tmr_primary_select_type : at32f435_437_tmr.h
  • tmr_sub_mode_select_type : at32f435_437_tmr.h
  • tmr_wp_level_type : at32f435_437_tmr.h


AT32F435/437 Firmwary Library: Globals

- u -

  • update_status_type : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • upgrade_status_type : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • usart_break_bit_num_type : at32f435_437_usart.h
  • usart_clock_phase_type : at32f435_437_usart.h
  • usart_clock_polarity_type : at32f435_437_usart.h
  • usart_data_bit_num_type : at32f435_437_usart.h
  • usart_de_polarity_type : at32f435_437_usart.h
  • usart_hardware_flow_control_type : at32f435_437_usart.h
  • usart_identification_bit_num_type : at32f435_437_usart.h
  • usart_lbcp_type : at32f435_437_usart.h
  • usart_parity_selection_type : at32f435_437_usart.h
  • usart_stop_bit_num_type : at32f435_437_usart.h
  • usart_wakeup_mode_type : at32f435_437_usart.h
  • usb_clk48_s : at32f435_437_usb.h
  • usb_endpoint_number_type : at32f435_437_usb.h
  • usb_hid_ctrl_state_type : usbh_hid_class.h
  • usb_hid_state_type : usbh_hid_class.h
  • usb_speed_type : usb_core.h
  • usb_sts_type : usb_std.h
  • usbd_conn_state : usb_std.h
  • usbh_msc_ctrl_state_type : usbh_msc_class.h


AT32F435/437 Firmwary Library: Globals

- w -

  • wdt_cmd_value_type : at32f435_437_wdt.h
  • wdt_division_type : at32f435_437_wdt.h
  • wwdt_division_type : at32f435_437_wwdt.h


AT32F435/437 Firmwary Library: Globals

- x -

  • xmc_access_mode_type : at32f435_437_xmc.h
  • xmc_asyn_wait_type : at32f435_437_xmc.h
  • xmc_bank_status_type : at32f435_437_xmc.h
  • xmc_burst_access_mode_type : at32f435_437_xmc.h
  • xmc_class_bank_type : at32f435_437_xmc.h
  • xmc_cmd_bank1_2_type : at32f435_437_xmc.h
  • xmc_command_type : at32f435_437_xmc.h
  • xmc_data_addr_mux_type : at32f435_437_xmc.h
  • xmc_data_width_type : at32f435_437_xmc.h
  • xmc_ecc_enable_type : at32f435_437_xmc.h
  • xmc_ecc_pagesize_type : at32f435_437_xmc.h
  • xmc_extended_mode_type : at32f435_437_xmc.h
  • xmc_interrupt_flag_type : at32f435_437_xmc.h
  • xmc_interrupt_sources_type : at32f435_437_xmc.h
  • xmc_memory_type : at32f435_437_xmc.h
  • xmc_nand_pccard_wait_type : at32f435_437_xmc.h
  • xmc_nor_sram_subbank_type : at32f435_437_xmc.h
  • xmc_sdram_bank_type : at32f435_437_xmc.h
  • xmc_sdram_cas_type : at32f435_437_xmc.h
  • xmc_sdram_clkdiv_type : at32f435_437_xmc.h
  • xmc_sdram_column_type : at32f435_437_xmc.h
  • xmc_sdram_delay_type : at32f435_437_xmc.h
  • xmc_sdram_inbk_type : at32f435_437_xmc.h
  • xmc_sdram_rd_delay_type : at32f435_437_xmc.h
  • xmc_sdram_row_type : at32f435_437_xmc.h
  • xmc_sdram_width_type : at32f435_437_xmc.h
  • xmc_wait_signal_polarity_type : at32f435_437_xmc.h
  • xmc_wait_signal_type : at32f435_437_xmc.h
  • xmc_wait_timing_type : at32f435_437_xmc.h
  • xmc_wrap_mode_type : at32f435_437_xmc.h
  • xmc_write_burst_type : at32f435_437_xmc.h
  • xmc_write_operation_type : at32f435_437_xmc.h


AT32F435/437 Firmwary Library: Globals

- a -

  • ACC_IRQn : at32f435_437.h
  • ADC1_2_3_IRQn : at32f435_437.h
  • ADC_CHANNEL_0 : at32f435_437_adc.h
  • ADC_CHANNEL_1 : at32f435_437_adc.h
  • ADC_CHANNEL_10 : at32f435_437_adc.h
  • ADC_CHANNEL_11 : at32f435_437_adc.h
  • ADC_CHANNEL_12 : at32f435_437_adc.h
  • ADC_CHANNEL_13 : at32f435_437_adc.h
  • ADC_CHANNEL_14 : at32f435_437_adc.h
  • ADC_CHANNEL_15 : at32f435_437_adc.h
  • ADC_CHANNEL_16 : at32f435_437_adc.h
  • ADC_CHANNEL_17 : at32f435_437_adc.h
  • ADC_CHANNEL_18 : at32f435_437_adc.h
  • ADC_CHANNEL_2 : at32f435_437_adc.h
  • ADC_CHANNEL_3 : at32f435_437_adc.h
  • ADC_CHANNEL_4 : at32f435_437_adc.h
  • ADC_CHANNEL_5 : at32f435_437_adc.h
  • ADC_CHANNEL_6 : at32f435_437_adc.h
  • ADC_CHANNEL_7 : at32f435_437_adc.h
  • ADC_CHANNEL_8 : at32f435_437_adc.h
  • ADC_CHANNEL_9 : at32f435_437_adc.h
  • ADC_COMMON_DMAMODE_1 : at32f435_437_adc.h
  • ADC_COMMON_DMAMODE_2 : at32f435_437_adc.h
  • ADC_COMMON_DMAMODE_3 : at32f435_437_adc.h
  • ADC_COMMON_DMAMODE_4 : at32f435_437_adc.h
  • ADC_COMMON_DMAMODE_5 : at32f435_437_adc.h
  • ADC_COMMON_DMAMODE_DISABLE : at32f435_437_adc.h
  • ADC_HCLK_DIV_10 : at32f435_437_adc.h
  • ADC_HCLK_DIV_11 : at32f435_437_adc.h
  • ADC_HCLK_DIV_12 : at32f435_437_adc.h
  • ADC_HCLK_DIV_13 : at32f435_437_adc.h
  • ADC_HCLK_DIV_14 : at32f435_437_adc.h
  • ADC_HCLK_DIV_15 : at32f435_437_adc.h
  • ADC_HCLK_DIV_16 : at32f435_437_adc.h
  • ADC_HCLK_DIV_17 : at32f435_437_adc.h
  • ADC_HCLK_DIV_2 : at32f435_437_adc.h
  • ADC_HCLK_DIV_3 : at32f435_437_adc.h
  • ADC_HCLK_DIV_4 : at32f435_437_adc.h
  • ADC_HCLK_DIV_5 : at32f435_437_adc.h
  • ADC_HCLK_DIV_6 : at32f435_437_adc.h
  • ADC_HCLK_DIV_7 : at32f435_437_adc.h
  • ADC_HCLK_DIV_8 : at32f435_437_adc.h
  • ADC_HCLK_DIV_9 : at32f435_437_adc.h
  • ADC_INDEPENDENT_MODE : at32f435_437_adc.h
  • ADC_LEFT_ALIGNMENT : at32f435_437_adc.h
  • ADC_ORDINARY_SHIFT_ONLY_ONESLAVE_MODE : at32f435_437_adc.h
  • ADC_ORDINARY_SHIFT_ONLY_TWOSLAVE_MODE : at32f435_437_adc.h
  • ADC_ORDINARY_SMLT_ONLY_ONESLAVE_MODE : at32f435_437_adc.h
  • ADC_ORDINARY_SMLT_ONLY_TWOSLAVE_MODE : at32f435_437_adc.h
  • ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_ONESLAVE_MODE : at32f435_437_adc.h
  • ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_TWOSLAVE_MODE : at32f435_437_adc.h
  • ADC_ORDINARY_SMLT_PREEMPT_SMLT_ONESLAVE_MODE : at32f435_437_adc.h
  • ADC_ORDINARY_SMLT_PREEMPT_SMLT_TWOSLAVE_MODE : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_EDGE_FALLING : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_EDGE_NONE : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_EDGE_RISING : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_EDGE_RISING_FALLING : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_EXINT11 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR1CH1 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR1CH2 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR1CH3 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR1TRGOUT : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR1TRGOUT2 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR20CH1 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR20CH2 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR20CH3 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR20TRGOUT : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR20TRGOUT2 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR2CH1 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR2CH2 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR2CH3 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR2CH4 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR2TRGOUT : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR3CH1 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR3CH4 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR3TRGOUT : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR4CH1 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR4CH4 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR4TRGOUT : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR5CH1 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR5CH2 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR5CH3 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR6TRGOUT : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR7TRGOUT : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR8CH1 : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR8TRGOUT : at32f435_437_adc.h
  • ADC_ORDINARY_TRIG_TMR8TRGOUT2 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_CONTINUE : at32f435_437_adc.h
  • ADC_OVERSAMPLE_RATIO_128 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_RATIO_16 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_RATIO_2 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_RATIO_256 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_RATIO_32 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_RATIO_4 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_RATIO_64 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_RATIO_8 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_RESTART : at32f435_437_adc.h
  • ADC_OVERSAMPLE_SHIFT_0 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_SHIFT_1 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_SHIFT_2 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_SHIFT_3 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_SHIFT_4 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_SHIFT_5 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_SHIFT_6 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_SHIFT_7 : at32f435_437_adc.h
  • ADC_OVERSAMPLE_SHIFT_8 : at32f435_437_adc.h
  • ADC_PREEMPT_CHANNEL_1 : at32f435_437_adc.h
  • ADC_PREEMPT_CHANNEL_2 : at32f435_437_adc.h
  • ADC_PREEMPT_CHANNEL_3 : at32f435_437_adc.h
  • ADC_PREEMPT_CHANNEL_4 : at32f435_437_adc.h
  • ADC_PREEMPT_INTERLTRIG_ONLY_ONESLAVE_MODE : at32f435_437_adc.h
  • ADC_PREEMPT_INTERLTRIG_ONLY_TWOSLAVE_MODE : at32f435_437_adc.h
  • ADC_PREEMPT_SMLT_ONLY_ONESLAVE_MODE : at32f435_437_adc.h
  • ADC_PREEMPT_SMLT_ONLY_TWOSLAVE_MODE : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_EDGE_FALLING : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_EDGE_NONE : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_EDGE_RISING : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_EDGE_RISING_FALLING : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_EXINT15 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR1CH3 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR1CH4 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR1TRGOUT : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR1TRGOUT2 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR20CH2 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR20CH4 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR20TRGOUT : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR20TRGOUT2 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR2CH1 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR2TRGOUT : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR3CH1 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR3CH2 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR3CH3 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR3CH4 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR3TRGOUT : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR4CH1 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR4CH2 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR4CH3 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR4CH4 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR4TRGOUT : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR5CH4 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR5TRGOUT : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR6TRGOUT : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR7TRGOUT : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR8CH2 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR8CH3 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR8CH4 : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR8TRGOUT : at32f435_437_adc.h
  • ADC_PREEMPT_TRIG_TMR8TRGOUT2 : at32f435_437_adc.h
  • ADC_RESOLUTION_10B : at32f435_437_adc.h
  • ADC_RESOLUTION_12B : at32f435_437_adc.h
  • ADC_RESOLUTION_6B : at32f435_437_adc.h
  • ADC_RESOLUTION_8B : at32f435_437_adc.h
  • ADC_RIGHT_ALIGNMENT : at32f435_437_adc.h
  • ADC_SAMPLETIME_12_5 : at32f435_437_adc.h
  • ADC_SAMPLETIME_247_5 : at32f435_437_adc.h
  • ADC_SAMPLETIME_24_5 : at32f435_437_adc.h
  • ADC_SAMPLETIME_2_5 : at32f435_437_adc.h
  • ADC_SAMPLETIME_47_5 : at32f435_437_adc.h
  • ADC_SAMPLETIME_640_5 : at32f435_437_adc.h
  • ADC_SAMPLETIME_6_5 : at32f435_437_adc.h
  • ADC_SAMPLETIME_92_5 : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_10CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_11CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_12CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_13CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_14CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_15CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_16CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_17CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_18CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_19CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_20CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_5CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_6CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_7CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_8CYCLES : at32f435_437_adc.h
  • ADC_SAMPLING_INTERVAL_9CYCLES : at32f435_437_adc.h
  • ADC_VMONITOR_ALL_ORDINARY : at32f435_437_adc.h
  • ADC_VMONITOR_ALL_ORDINARY_PREEMPT : at32f435_437_adc.h
  • ADC_VMONITOR_ALL_PREEMPT : at32f435_437_adc.h
  • ADC_VMONITOR_NONE : at32f435_437_adc.h
  • ADC_VMONITOR_SINGLE_ORDINARY : at32f435_437_adc.h
  • ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT : at32f435_437_adc.h
  • ADC_VMONITOR_SINGLE_PREEMPT : at32f435_437_adc.h


AT32F435/437 Firmwary Library: Globals

- b -

  • BOT_STATE_COMPLETE : usbh_msc_bot_scsi.h
  • BOT_STATE_DATA_IN : usbh_msc_bot_scsi.h
  • BOT_STATE_DATA_IN_WAIT : usbh_msc_bot_scsi.h
  • BOT_STATE_DATA_OUT : usbh_msc_bot_scsi.h
  • BOT_STATE_DATA_OUT_WAIT : usbh_msc_bot_scsi.h
  • BOT_STATE_ERROR_IN : usbh_msc_bot_scsi.h
  • BOT_STATE_ERROR_OUT : usbh_msc_bot_scsi.h
  • BOT_STATE_IDLE : usbh_msc_bot_scsi.h
  • BOT_STATE_RECV_CSW : usbh_msc_bot_scsi.h
  • BOT_STATE_RECV_CSW_WAIT : usbh_msc_bot_scsi.h
  • BOT_STATE_SEND_CBW : usbh_msc_bot_scsi.h
  • BOT_STATE_SEND_CBW_WAIT : usbh_msc_bot_scsi.h
  • BusFault_IRQn : at32f435_437.h


AT32F435/437 Firmwary Library: Globals

- c -

  • CAN1_RX0_IRQn : at32f435_437.h
  • CAN1_RX1_IRQn : at32f435_437.h
  • CAN1_SE_IRQn : at32f435_437.h
  • CAN1_TX_IRQn : at32f435_437.h
  • CAN2_RX0_IRQn : at32f435_437.h
  • CAN2_RX1_IRQn : at32f435_437.h
  • CAN2_SE_IRQn : at32f435_437.h
  • CAN2_TX_IRQn : at32f435_437.h
  • CAN_BTS1_10TQ : at32f435_437_can.h
  • CAN_BTS1_11TQ : at32f435_437_can.h
  • CAN_BTS1_12TQ : at32f435_437_can.h
  • CAN_BTS1_13TQ : at32f435_437_can.h
  • CAN_BTS1_14TQ : at32f435_437_can.h
  • CAN_BTS1_15TQ : at32f435_437_can.h
  • CAN_BTS1_16TQ : at32f435_437_can.h
  • CAN_BTS1_1TQ : at32f435_437_can.h
  • CAN_BTS1_2TQ : at32f435_437_can.h
  • CAN_BTS1_3TQ : at32f435_437_can.h
  • CAN_BTS1_4TQ : at32f435_437_can.h
  • CAN_BTS1_5TQ : at32f435_437_can.h
  • CAN_BTS1_6TQ : at32f435_437_can.h
  • CAN_BTS1_7TQ : at32f435_437_can.h
  • CAN_BTS1_8TQ : at32f435_437_can.h
  • CAN_BTS1_9TQ : at32f435_437_can.h
  • CAN_BTS2_1TQ : at32f435_437_can.h
  • CAN_BTS2_2TQ : at32f435_437_can.h
  • CAN_BTS2_3TQ : at32f435_437_can.h
  • CAN_BTS2_4TQ : at32f435_437_can.h
  • CAN_BTS2_5TQ : at32f435_437_can.h
  • CAN_BTS2_6TQ : at32f435_437_can.h
  • CAN_BTS2_7TQ : at32f435_437_can.h
  • CAN_BTS2_8TQ : at32f435_437_can.h
  • CAN_DISCARDING_FIRST_RECEIVED : at32f435_437_can.h
  • CAN_DISCARDING_LAST_RECEIVED : at32f435_437_can.h
  • CAN_ENTER_DOZE_FAILED : at32f435_437_can.h
  • CAN_ENTER_DOZE_SUCCESSFUL : at32f435_437_can.h
  • CAN_ERRORRECORD_ACKERR : at32f435_437_can.h
  • CAN_ERRORRECORD_BITDOMINANTERR : at32f435_437_can.h
  • CAN_ERRORRECORD_BITRECESSIVEERR : at32f435_437_can.h
  • CAN_ERRORRECORD_CRCERR : at32f435_437_can.h
  • CAN_ERRORRECORD_FORMERR : at32f435_437_can.h
  • CAN_ERRORRECORD_NOERR : at32f435_437_can.h
  • CAN_ERRORRECORD_SOFTWARESETERR : at32f435_437_can.h
  • CAN_ERRORRECORD_STUFFERR : at32f435_437_can.h
  • CAN_FILTER_16BIT : at32f435_437_can.h
  • CAN_FILTER_32BIT : at32f435_437_can.h
  • CAN_FILTER_FIFO0 : at32f435_437_can.h
  • CAN_FILTER_FIFO1 : at32f435_437_can.h
  • CAN_FILTER_MODE_ID_LIST : at32f435_437_can.h
  • CAN_FILTER_MODE_ID_MASK : at32f435_437_can.h
  • CAN_ID_EXTENDED : at32f435_437_can.h
  • CAN_ID_STANDARD : at32f435_437_can.h
  • CAN_MODE_COMMUNICATE : at32f435_437_can.h
  • CAN_MODE_LISTENONLY : at32f435_437_can.h
  • CAN_MODE_LISTENONLY_LOOPBACK : at32f435_437_can.h
  • CAN_MODE_LOOPBACK : at32f435_437_can.h
  • CAN_OPERATINGMODE_COMMUNICATE : at32f435_437_can.h
  • CAN_OPERATINGMODE_DOZE : at32f435_437_can.h
  • CAN_OPERATINGMODE_FREEZE : at32f435_437_can.h
  • CAN_QUIT_DOZE_FAILED : at32f435_437_can.h
  • CAN_QUIT_DOZE_SUCCESSFUL : at32f435_437_can.h
  • CAN_RSAW_1TQ : at32f435_437_can.h
  • CAN_RSAW_2TQ : at32f435_437_can.h
  • CAN_RSAW_3TQ : at32f435_437_can.h
  • CAN_RSAW_4TQ : at32f435_437_can.h
  • CAN_RX_FIFO0 : at32f435_437_can.h
  • CAN_RX_FIFO1 : at32f435_437_can.h
  • CAN_SENDING_BY_ID : at32f435_437_can.h
  • CAN_SENDING_BY_REQUEST : at32f435_437_can.h
  • CAN_TFT_DATA : at32f435_437_can.h
  • CAN_TFT_REMOTE : at32f435_437_can.h
  • CAN_TX_MAILBOX0 : at32f435_437_can.h
  • CAN_TX_MAILBOX1 : at32f435_437_can.h
  • CAN_TX_MAILBOX2 : at32f435_437_can.h
  • CAN_TX_STATUS_FAILED : at32f435_437_can.h
  • CAN_TX_STATUS_NO_EMPTY : at32f435_437_can.h
  • CAN_TX_STATUS_PENDING : at32f435_437_can.h
  • CAN_TX_STATUS_SUCCESSFUL : at32f435_437_can.h
  • CMD_CTR_APP : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • CMD_CTR_DONE : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • CMD_CTR_ERR : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • CMD_CTR_IDLE : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • CMD_CTR_INIT : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • CMD_DATA_ADDR : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • CMD_DATA_BUF : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • CMD_DATA_CHACK : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • CMD_DATA_DONE : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • CMD_DATA_ERR : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • CMD_DATA_IDLE : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • CMD_STATE_SEND : usbh_msc_bot_scsi.h
  • CMD_STATE_WAIT : usbh_msc_bot_scsi.h
  • CRC_REVERSE_INPUT_BY_BYTE : at32f435_437_crc.h
  • CRC_REVERSE_INPUT_BY_HALFWORD : at32f435_437_crc.h
  • CRC_REVERSE_INPUT_BY_WORD : at32f435_437_crc.h
  • CRC_REVERSE_INPUT_NO_AFFECTE : at32f435_437_crc.h
  • CRC_REVERSE_OUTPUT_DATA : at32f435_437_crc.h
  • CRC_REVERSE_OUTPUT_NO_AFFECTE : at32f435_437_crc.h
  • CRM_ACC_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_ACC_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_ACC_PERIPH_RESET : at32f435_437_crm.h
  • CRM_ADC1_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_ADC1_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_ADC2_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_ADC2_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_ADC3_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_ADC3_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_ADC_PERIPH_RESET : at32f435_437_crm.h
  • CRM_AHB_DIV_1 : at32f435_437_crm.h
  • CRM_AHB_DIV_128 : at32f435_437_crm.h
  • CRM_AHB_DIV_16 : at32f435_437_crm.h
  • CRM_AHB_DIV_2 : at32f435_437_crm.h
  • CRM_AHB_DIV_256 : at32f435_437_crm.h
  • CRM_AHB_DIV_4 : at32f435_437_crm.h
  • CRM_AHB_DIV_512 : at32f435_437_crm.h
  • CRM_AHB_DIV_64 : at32f435_437_crm.h
  • CRM_AHB_DIV_8 : at32f435_437_crm.h
  • CRM_APB1_DIV_1 : at32f435_437_crm.h
  • CRM_APB1_DIV_16 : at32f435_437_crm.h
  • CRM_APB1_DIV_2 : at32f435_437_crm.h
  • CRM_APB1_DIV_4 : at32f435_437_crm.h
  • CRM_APB1_DIV_8 : at32f435_437_crm.h
  • CRM_APB2_DIV_1 : at32f435_437_crm.h
  • CRM_APB2_DIV_16 : at32f435_437_crm.h
  • CRM_APB2_DIV_2 : at32f435_437_crm.h
  • CRM_APB2_DIV_4 : at32f435_437_crm.h
  • CRM_APB2_DIV_8 : at32f435_437_crm.h
  • CRM_AUTO_STEP_MODE_DISABLE : at32f435_437_crm.h
  • CRM_AUTO_STEP_MODE_ENABLE : at32f435_437_crm.h
  • CRM_CAN1_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_CAN1_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_CAN1_PERIPH_RESET : at32f435_437_crm.h
  • CRM_CAN2_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_CAN2_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_CAN2_PERIPH_RESET : at32f435_437_crm.h
  • CRM_CLKOUT1_HEXT : at32f435_437_crm.h
  • CRM_CLKOUT1_HICK : at32f435_437_crm.h
  • CRM_CLKOUT1_LEXT : at32f435_437_crm.h
  • CRM_CLKOUT1_PLL : at32f435_437_crm.h
  • CRM_CLKOUT2_ADC : at32f435_437_crm.h
  • CRM_CLKOUT2_HEXT : at32f435_437_crm.h
  • CRM_CLKOUT2_HICK : at32f435_437_crm.h
  • CRM_CLKOUT2_LEXT : at32f435_437_crm.h
  • CRM_CLKOUT2_LICK : at32f435_437_crm.h
  • CRM_CLKOUT2_PLL : at32f435_437_crm.h
  • CRM_CLKOUT2_SCLK : at32f435_437_crm.h
  • CRM_CLKOUT2_USB : at32f435_437_crm.h
  • CRM_CLKOUT_DIV1_1 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV1_2 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV1_3 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV1_4 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV1_5 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV2_1 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV2_128 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV2_16 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV2_2 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV2_256 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV2_4 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV2_512 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV2_64 : at32f435_437_crm.h
  • CRM_CLKOUT_DIV2_8 : at32f435_437_crm.h
  • CRM_CLKOUT_INDEX_1 : at32f435_437_crm.h
  • CRM_CLKOUT_INDEX_2 : at32f435_437_crm.h
  • CRM_CLOCK_SOURCE_HEXT : at32f435_437_crm.h
  • CRM_CLOCK_SOURCE_HICK : at32f435_437_crm.h
  • CRM_CLOCK_SOURCE_LEXT : at32f435_437_crm.h
  • CRM_CLOCK_SOURCE_LICK : at32f435_437_crm.h
  • CRM_CLOCK_SOURCE_PLL : at32f435_437_crm.h
  • CRM_CRC_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_CRC_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_CRC_PERIPH_RESET : at32f435_437_crm.h
  • CRM_DAC_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_DAC_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_DAC_PERIPH_RESET : at32f435_437_crm.h
  • CRM_DMA1_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_DMA1_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_DMA1_PERIPH_RESET : at32f435_437_crm.h
  • CRM_DMA2_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_DMA2_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_DMA2_PERIPH_RESET : at32f435_437_crm.h
  • CRM_DVP_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_DVP_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_DVP_PERIPH_RESET : at32f435_437_crm.h
  • CRM_EDMA_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_EDMA_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_EDMA_PERIPH_RESET : at32f435_437_crm.h
  • CRM_EMAC_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_EMAC_PULSE_125MS : at32f435_437_crm.h
  • CRM_EMAC_PULSE_1SCLK : at32f435_437_crm.h
  • CRM_EMACPTP_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_EMACRX_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_EMACTX_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_10 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_11 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_12 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_13 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_14 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_15 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_16 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_17 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_18 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_19 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_2 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_20 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_21 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_22 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_23 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_24 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_25 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_26 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_27 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_28 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_29 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_3 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_30 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_31 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_4 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_5 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_6 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_7 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_8 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_HEXT_DIV_9 : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_LEXT : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_LICK : at32f435_437_crm.h
  • CRM_ERTC_CLOCK_NOCLK : at32f435_437_crm.h
  • CRM_GPIOA_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_GPIOA_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_GPIOA_PERIPH_RESET : at32f435_437_crm.h
  • CRM_GPIOB_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_GPIOB_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_GPIOB_PERIPH_RESET : at32f435_437_crm.h
  • CRM_GPIOC_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_GPIOC_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_GPIOC_PERIPH_RESET : at32f435_437_crm.h
  • CRM_GPIOD_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_GPIOD_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_GPIOD_PERIPH_RESET : at32f435_437_crm.h
  • CRM_GPIOE_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_GPIOE_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_GPIOE_PERIPH_RESET : at32f435_437_crm.h
  • CRM_GPIOF_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_GPIOF_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_GPIOF_PERIPH_RESET : at32f435_437_crm.h
  • CRM_GPIOG_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_GPIOG_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_GPIOG_PERIPH_RESET : at32f435_437_crm.h
  • CRM_GPIOH_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_GPIOH_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_GPIOH_PERIPH_RESET : at32f435_437_crm.h
  • CRM_HICK48_DIV6 : at32f435_437_crm.h
  • CRM_HICK48_NODIV : at32f435_437_crm.h
  • CRM_HICK_SCLK_48MHZ : at32f435_437_crm.h
  • CRM_HICK_SCLK_8MHZ : at32f435_437_crm.h
  • CRM_I2C1_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_I2C1_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_I2C1_PERIPH_RESET : at32f435_437_crm.h
  • CRM_I2C2_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_I2C2_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_I2C2_PERIPH_RESET : at32f435_437_crm.h
  • CRM_I2C3_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_I2C3_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_I2C3_PERIPH_RESET : at32f435_437_crm.h
  • CRM_IRQn : at32f435_437.h
  • CRM_OTGFS1_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_OTGFS1_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_OTGFS1_PERIPH_RESET : at32f435_437_crm.h
  • CRM_OTGFS2_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_OTGFS2_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_OTGFS2_PERIPH_RESET : at32f435_437_crm.h
  • CRM_PLL_FR_1 : at32f435_437_crm.h
  • CRM_PLL_FR_16 : at32f435_437_crm.h
  • CRM_PLL_FR_2 : at32f435_437_crm.h
  • CRM_PLL_FR_32 : at32f435_437_crm.h
  • CRM_PLL_FR_4 : at32f435_437_crm.h
  • CRM_PLL_FR_8 : at32f435_437_crm.h
  • CRM_PLL_SOURCE_HEXT : at32f435_437_crm.h
  • CRM_PLL_SOURCE_HICK : at32f435_437_crm.h
  • CRM_PWC_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_PWC_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_PWC_PERIPH_RESET : at32f435_437_crm.h
  • CRM_QSPI1_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_QSPI1_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_QSPI1_PERIPH_RESET : at32f435_437_crm.h
  • CRM_QSPI2_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_QSPI2_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_QSPI2_PERIPH_RESET : at32f435_437_crm.h
  • CRM_SCFG_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_SCFG_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_SCFG_PERIPH_RESET : at32f435_437_crm.h
  • CRM_SCLK_HEXT : at32f435_437_crm.h
  • CRM_SCLK_HICK : at32f435_437_crm.h
  • CRM_SCLK_PLL : at32f435_437_crm.h
  • CRM_SDIO1_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_SDIO1_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_SDIO1_PERIPH_RESET : at32f435_437_crm.h
  • CRM_SDIO2_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_SDIO2_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_SDIO2_PERIPH_RESET : at32f435_437_crm.h
  • CRM_SPI1_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_SPI1_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_SPI1_PERIPH_RESET : at32f435_437_crm.h
  • CRM_SPI2_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_SPI2_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_SPI2_PERIPH_RESET : at32f435_437_crm.h
  • CRM_SPI3_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_SPI3_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_SPI3_PERIPH_RESET : at32f435_437_crm.h
  • CRM_SPI4_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_SPI4_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_SPI4_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR10_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR10_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR10_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR11_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR11_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR11_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR12_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR12_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR12_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR13_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR13_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR13_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR14_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR14_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR14_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR1_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR1_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR1_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR20_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR20_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR20_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR2_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR2_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR2_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR3_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR3_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR3_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR4_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR4_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR4_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR5_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR5_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR5_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR6_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR6_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR6_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR7_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR7_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR7_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR8_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR8_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR8_PERIPH_RESET : at32f435_437_crm.h
  • CRM_TMR9_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_TMR9_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_TMR9_PERIPH_RESET : at32f435_437_crm.h
  • CRM_UART4_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_UART4_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_UART4_PERIPH_RESET : at32f435_437_crm.h
  • CRM_UART5_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_UART5_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_UART5_PERIPH_RESET : at32f435_437_crm.h
  • CRM_UART7_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_UART7_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_UART7_PERIPH_RESET : at32f435_437_crm.h
  • CRM_UART8_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_UART8_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_UART8_PERIPH_RESET : at32f435_437_crm.h
  • CRM_USART1_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_USART1_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_USART1_PERIPH_RESET : at32f435_437_crm.h
  • CRM_USART2_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_USART2_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_USART2_PERIPH_RESET : at32f435_437_crm.h
  • CRM_USART3_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_USART3_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_USART3_PERIPH_RESET : at32f435_437_crm.h
  • CRM_USART6_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_USART6_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_USART6_PERIPH_RESET : at32f435_437_crm.h
  • CRM_USB_CLOCK_SOURCE_HICK : at32f435_437_crm.h
  • CRM_USB_CLOCK_SOURCE_PLL : at32f435_437_crm.h
  • CRM_USB_DIV_1 : at32f435_437_crm.h
  • CRM_USB_DIV_1_5 : at32f435_437_crm.h
  • CRM_USB_DIV_2 : at32f435_437_crm.h
  • CRM_USB_DIV_2_5 : at32f435_437_crm.h
  • CRM_USB_DIV_3 : at32f435_437_crm.h
  • CRM_USB_DIV_3_5 : at32f435_437_crm.h
  • CRM_USB_DIV_4 : at32f435_437_crm.h
  • CRM_USB_DIV_4_5 : at32f435_437_crm.h
  • CRM_USB_DIV_5 : at32f435_437_crm.h
  • CRM_USB_DIV_5_5 : at32f435_437_crm.h
  • CRM_USB_DIV_6 : at32f435_437_crm.h
  • CRM_USB_DIV_6_5 : at32f435_437_crm.h
  • CRM_USB_DIV_7 : at32f435_437_crm.h
  • CRM_WWDT_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_WWDT_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_WWDT_PERIPH_RESET : at32f435_437_crm.h
  • CRM_XMC_PERIPH_CLOCK : at32f435_437_crm.h
  • CRM_XMC_PERIPH_LOWPOWER : at32f435_437_crm.h
  • CRM_XMC_PERIPH_RESET : at32f435_437_crm.h


AT32F435/437 Firmwary Library: Globals

- d -

  • DAC1_12BIT_LEFT : at32f435_437_dac.h
  • DAC1_12BIT_RIGHT : at32f435_437_dac.h
  • DAC1_8BIT_RIGHT : at32f435_437_dac.h
  • DAC1_SELECT : at32f435_437_dac.h
  • DAC2_12BIT_LEFT : at32f435_437_dac.h
  • DAC2_12BIT_RIGHT : at32f435_437_dac.h
  • DAC2_8BIT_RIGHT : at32f435_437_dac.h
  • DAC2_SELECT : at32f435_437_dac.h
  • DAC_DUAL_12BIT_LEFT : at32f435_437_dac.h
  • DAC_DUAL_12BIT_RIGHT : at32f435_437_dac.h
  • DAC_DUAL_8BIT_RIGHT : at32f435_437_dac.h
  • DAC_EXTERNAL_INTERRUPT_LINE_9 : at32f435_437_dac.h
  • DAC_LSFR_BIT0_AMPLITUDE_1 : at32f435_437_dac.h
  • DAC_LSFR_BIT10_AMPLITUDE_3 : at32f435_437_dac.h
  • DAC_LSFR_BIT20_AMPLITUDE_7 : at32f435_437_dac.h
  • DAC_LSFR_BIT30_AMPLITUDE_15 : at32f435_437_dac.h
  • DAC_LSFR_BIT40_AMPLITUDE_31 : at32f435_437_dac.h
  • DAC_LSFR_BIT50_AMPLITUDE_63 : at32f435_437_dac.h
  • DAC_LSFR_BIT60_AMPLITUDE_127 : at32f435_437_dac.h
  • DAC_LSFR_BIT70_AMPLITUDE_255 : at32f435_437_dac.h
  • DAC_LSFR_BIT80_AMPLITUDE_511 : at32f435_437_dac.h
  • DAC_LSFR_BIT90_AMPLITUDE_1023 : at32f435_437_dac.h
  • DAC_LSFR_BITA0_AMPLITUDE_2047 : at32f435_437_dac.h
  • DAC_LSFR_BITB0_AMPLITUDE_4095 : at32f435_437_dac.h
  • DAC_SOFTWARE_TRIGGER : at32f435_437_dac.h
  • DAC_TMR2_TRGOUT_EVENT : at32f435_437_dac.h
  • DAC_TMR4_TRGOUT_EVENT : at32f435_437_dac.h
  • DAC_TMR5_TRGOUT_EVENT : at32f435_437_dac.h
  • DAC_TMR6_TRGOUT_EVENT : at32f435_437_dac.h
  • DAC_TMR7_TRGOUT_EVENT : at32f435_437_dac.h
  • DAC_TMR8_TRGOUT_EVENT : at32f435_437_dac.h
  • DAC_WAVE_GENERATE_NOISE : at32f435_437_dac.h
  • DAC_WAVE_GENERATE_NONE : at32f435_437_dac.h
  • DAC_WAVE_GENERATE_TRIANGLE : at32f435_437_dac.h
  • DCFG_PERFRINT_80 : at32f435_437_usb.h
  • DCFG_PERFRINT_85 : at32f435_437_usb.h
  • DCFG_PERFRINT_90 : at32f435_437_usb.h
  • DCFG_PERFRINT_95 : at32f435_437_usb.h
  • DebugMonitor_IRQn : at32f435_437.h
  • DMA1_Channel1_IRQn : at32f435_437.h
  • DMA1_Channel2_IRQn : at32f435_437.h
  • DMA1_Channel3_IRQn : at32f435_437.h
  • DMA1_Channel4_IRQn : at32f435_437.h
  • DMA1_Channel5_IRQn : at32f435_437.h
  • DMA1_Channel6_IRQn : at32f435_437.h
  • DMA1_Channel7_IRQn : at32f435_437.h
  • DMA2_Channel1_IRQn : at32f435_437.h
  • DMA2_Channel2_IRQn : at32f435_437.h
  • DMA2_Channel3_IRQn : at32f435_437.h
  • DMA2_Channel4_IRQn : at32f435_437.h
  • DMA2_Channel5_IRQn : at32f435_437.h
  • DMA2_Channel6_IRQn : at32f435_437.h
  • DMA2_Channel7_IRQn : at32f435_437.h
  • DMA_DIR_MEMORY_TO_MEMORY : at32f435_437_dma.h
  • DMA_DIR_MEMORY_TO_PERIPHERAL : at32f435_437_dma.h
  • DMA_DIR_PERIPHERAL_TO_MEMORY : at32f435_437_dma.h
  • DMA_MEMORY_DATA_WIDTH_BYTE : at32f435_437_dma.h
  • DMA_MEMORY_DATA_WIDTH_HALFWORD : at32f435_437_dma.h
  • DMA_MEMORY_DATA_WIDTH_WORD : at32f435_437_dma.h
  • DMA_PERIPHERAL_DATA_WIDTH_BYTE : at32f435_437_dma.h
  • DMA_PERIPHERAL_DATA_WIDTH_HALFWORD : at32f435_437_dma.h
  • DMA_PERIPHERAL_DATA_WIDTH_WORD : at32f435_437_dma.h
  • DMA_PRIORITY_HIGH : at32f435_437_dma.h
  • DMA_PRIORITY_LOW : at32f435_437_dma.h
  • DMA_PRIORITY_MEDIUM : at32f435_437_dma.h
  • DMA_PRIORITY_VERY_HIGH : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_ADC1 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_ADC2 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_ADC3 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_DAC1 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_DAC2 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_DVP : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_I2C1_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_I2C1_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_I2C2_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_I2C2_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_I2C3_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_I2C3_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_I2S2_EXT_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_I2S2_EXT_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_I2S3_EXT_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_I2S3_EXT_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_QSPI1 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_QSPI2 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_REQ_G1 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_REQ_G2 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_REQ_G3 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_REQ_G4 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_SDIO1 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_SDIO2 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_SPI1_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_SPI1_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_SPI2_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_SPI2_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_SPI3_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_SPI3_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_SPI4_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_SPI4_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR1_CH1 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR1_CH2 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR1_CH3 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR1_CH4 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR1_HALL : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR1_OVERFLOW : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR1_TRIG : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR20_CH1 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR20_CH2 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR20_CH3 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR20_CH4 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR20_HALL : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR20_OVERFLOW : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR20_TRIG : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR2_CH1 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR2_CH2 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR2_CH3 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR2_CH4 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR2_OVERFLOW : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR2_TRIG : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR3_CH1 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR3_CH2 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR3_CH3 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR3_CH4 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR3_OVERFLOW : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR3_TRIG : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR4_CH1 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR4_CH2 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR4_CH3 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR4_CH4 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR4_OVERFLOW : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR4_TRIG : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR5_CH1 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR5_CH2 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR5_CH3 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR5_CH4 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR5_OVERFLOW : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR5_TRIG : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR6_OVERFLOW : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR7_OVERFLOW : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR8_CH1 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR8_CH2 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR8_CH3 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR8_CH4 : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR8_HALL : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR8_OVERFLOW : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_TMR8_TRIG : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_UART4_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_UART4_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_UART5_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_UART5_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_UART7_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_UART7_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_UART8_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_UART8_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_USART1_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_USART1_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_USART2_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_USART2_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_USART3_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_USART3_TX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_USART6_RX : at32f435_437_dma.h
  • DMAMUX_DMAREQ_ID_USART6_TX : at32f435_437_dma.h
  • DMAMUX_GEN_ID_DMAMUX_CH1_EVT : at32f435_437_dma.h
  • DMAMUX_GEN_ID_DMAMUX_CH2_EVT : at32f435_437_dma.h
  • DMAMUX_GEN_ID_DMAMUX_CH3_EVT : at32f435_437_dma.h
  • DMAMUX_GEN_ID_DMAMUX_CH4_EVT : at32f435_437_dma.h
  • DMAMUX_GEN_ID_DMAMUX_CH5_EVT : at32f435_437_dma.h
  • DMAMUX_GEN_ID_DMAMUX_CH6_EVT : at32f435_437_dma.h
  • DMAMUX_GEN_ID_DMAMUX_CH7_EVT : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT0 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT1 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT10 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT11 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT12 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT13 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT14 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT15 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT2 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT3 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT4 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT5 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT6 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT7 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT8 : at32f435_437_dma.h
  • DMAMUX_GEN_ID_EXINT9 : at32f435_437_dma.h
  • DMAMUX_GEN_POLARITY_DISABLE : at32f435_437_dma.h
  • DMAMUX_GEN_POLARITY_FALLING : at32f435_437_dma.h
  • DMAMUX_GEN_POLARITY_RISING : at32f435_437_dma.h
  • DMAMUX_GEN_POLARITY_RISING_FALLING : at32f435_437_dma.h
  • DMAMUX_IRQn : at32f435_437.h
  • DMAMUX_SYNC_ID_DMAMUX_CH1_EVT : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_DMAMUX_CH2_EVT : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_DMAMUX_CH3_EVT : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_DMAMUX_CH4_EVT : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_DMAMUX_CH5_EVT : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_DMAMUX_CH6_EVT : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_DMAMUX_CH7_EVT : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT0 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT1 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT10 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT11 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT12 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT13 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT14 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT15 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT2 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT3 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT4 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT5 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT6 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT7 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT8 : at32f435_437_dma.h
  • DMAMUX_SYNC_ID_EXINT9 : at32f435_437_dma.h
  • DMAMUX_SYNC_POLARITY_DISABLE : at32f435_437_dma.h
  • DMAMUX_SYNC_POLARITY_FALLING : at32f435_437_dma.h
  • DMAMUX_SYNC_POLARITY_RISING : at32f435_437_dma.h
  • DMAMUX_SYNC_POLARITY_RISING_FALLING : at32f435_437_dma.h
  • DVP_BFRC_ALL : at32f435_437_dvp.h
  • DVP_BFRC_HALF : at32f435_437_dvp.h
  • DVP_BFRC_QUARTER : at32f435_437_dvp.h
  • DVP_CAP_FUNC_MODE_CONTINUOUS : at32f435_437_dvp.h
  • DVP_CAP_FUNC_MODE_SINGLE : at32f435_437_dvp.h
  • DVP_CLK_POLARITY_FALLING : at32f435_437_dvp.h
  • DVP_CLK_POLARITY_RISING : at32f435_437_dvp.h
  • DVP_DMABT_BURST : at32f435_437_dvp.h
  • DVP_DMABT_SINGLE : at32f435_437_dvp.h
  • DVP_EFDF_BYPASS : at32f435_437_dvp.h
  • DVP_EFDF_RGB565_555 : at32f435_437_dvp.h
  • DVP_EFDF_Y8 : at32f435_437_dvp.h
  • DVP_EFDF_YUV422_UYVY : at32f435_437_dvp.h
  • DVP_EFDF_YUV422_YUYV : at32f435_437_dvp.h
  • DVP_HSEID_LINE_END : at32f435_437_dvp.h
  • DVP_HSEID_LINE_START : at32f435_437_dvp.h
  • DVP_HSYNC_POLARITY_HIGH : at32f435_437_dvp.h
  • DVP_HSYNC_POLARITY_LOW : at32f435_437_dvp.h
  • DVP_IDUN_0 : at32f435_437_dvp.h
  • DVP_IDUN_2 : at32f435_437_dvp.h
  • DVP_IDUN_4 : at32f435_437_dvp.h
  • DVP_IDUN_6 : at32f435_437_dvp.h
  • DVP_IDUS_LSB : at32f435_437_dvp.h
  • DVP_IDUS_MSB : at32f435_437_dvp.h
  • DVP_IRQn : at32f435_437.h
  • DVP_LCDC_ALL : at32f435_437_dvp.h
  • DVP_LCDC_ONE_IN_TWO : at32f435_437_dvp.h
  • DVP_LCDS_CAP_FIRST : at32f435_437_dvp.h
  • DVP_LCDS_DROP_FIRST : at32f435_437_dvp.h
  • DVP_PCDC_ALL : at32f435_437_dvp.h
  • DVP_PCDC_ONE_IN_FOUR : at32f435_437_dvp.h
  • DVP_PCDC_ONE_IN_TWO : at32f435_437_dvp.h
  • DVP_PCDC_TWO_IN_FOUR : at32f435_437_dvp.h
  • DVP_PCDES_CAP_FIRST : at32f435_437_dvp.h
  • DVP_PCDES_DROP_FIRST : at32f435_437_dvp.h
  • DVP_PCDS_CAP_FIRST : at32f435_437_dvp.h
  • DVP_PCDS_DROP_FIRST : at32f435_437_dvp.h
  • DVP_PIXEL_DATA_LENGTH_10 : at32f435_437_dvp.h
  • DVP_PIXEL_DATA_LENGTH_12 : at32f435_437_dvp.h
  • DVP_PIXEL_DATA_LENGTH_14 : at32f435_437_dvp.h
  • DVP_PIXEL_DATA_LENGTH_8 : at32f435_437_dvp.h
  • DVP_STATUS_HSYN : at32f435_437_dvp.h
  • DVP_STATUS_OFNE : at32f435_437_dvp.h
  • DVP_STATUS_VSYN : at32f435_437_dvp.h
  • DVP_SYNC_MODE_EMBEDDED : at32f435_437_dvp.h
  • DVP_SYNC_MODE_HARDWARE : at32f435_437_dvp.h
  • DVP_VSEID_FRAME_END : at32f435_437_dvp.h
  • DVP_VSEID_FRMAE_START : at32f435_437_dvp.h
  • DVP_VSYNC_POLARITY_HIGH : at32f435_437_dvp.h
  • DVP_VSYNC_POLARITY_LOW : at32f435_437_dvp.h


AT32F435/437 Firmwary Library: Globals

- e -

  • EDMA_DIR_MEMORY_TO_MEMORY : at32f435_437_edma.h
  • EDMA_DIR_MEMORY_TO_PERIPHERAL : at32f435_437_edma.h
  • EDMA_DIR_PERIPHERAL_TO_MEMORY : at32f435_437_edma.h
  • EDMA_FIFO_STATUS_1QUARTER : at32f435_437_edma.h
  • EDMA_FIFO_STATUS_3QUARTER : at32f435_437_edma.h
  • EDMA_FIFO_STATUS_EMPTY : at32f435_437_edma.h
  • EDMA_FIFO_STATUS_FULL : at32f435_437_edma.h
  • EDMA_FIFO_STATUS_HALF : at32f435_437_edma.h
  • EDMA_FIFO_STATUS_LESS_1QUARTER : at32f435_437_edma.h
  • EDMA_FIFO_THRESHOLD_1QUARTER : at32f435_437_edma.h
  • EDMA_FIFO_THRESHOLD_3QUARTER : at32f435_437_edma.h
  • EDMA_FIFO_THRESHOLD_FULL : at32f435_437_edma.h
  • EDMA_FIFO_THRESHOLD_HALF : at32f435_437_edma.h
  • EDMA_MEMORY_0 : at32f435_437_edma.h
  • EDMA_MEMORY_1 : at32f435_437_edma.h
  • EDMA_MEMORY_BURST_16 : at32f435_437_edma.h
  • EDMA_MEMORY_BURST_4 : at32f435_437_edma.h
  • EDMA_MEMORY_BURST_8 : at32f435_437_edma.h
  • EDMA_MEMORY_DATA_WIDTH_BYTE : at32f435_437_edma.h
  • EDMA_MEMORY_DATA_WIDTH_HALFWORD : at32f435_437_edma.h
  • EDMA_MEMORY_DATA_WIDTH_WORD : at32f435_437_edma.h
  • EDMA_MEMORY_SINGLE : at32f435_437_edma.h
  • EDMA_PERIPHERAL_BURST_16 : at32f435_437_edma.h
  • EDMA_PERIPHERAL_BURST_4 : at32f435_437_edma.h
  • EDMA_PERIPHERAL_BURST_8 : at32f435_437_edma.h
  • EDMA_PERIPHERAL_DATA_WIDTH_BYTE : at32f435_437_edma.h
  • EDMA_PERIPHERAL_DATA_WIDTH_HALFWORD : at32f435_437_edma.h
  • EDMA_PERIPHERAL_DATA_WIDTH_WORD : at32f435_437_edma.h
  • EDMA_PERIPHERAL_INC_4_BYTE : at32f435_437_edma.h
  • EDMA_PERIPHERAL_INC_PSIZE : at32f435_437_edma.h
  • EDMA_PERIPHERAL_SINGLE : at32f435_437_edma.h
  • EDMA_PRIORITY_HIGH : at32f435_437_edma.h
  • EDMA_PRIORITY_LOW : at32f435_437_edma.h
  • EDMA_PRIORITY_MEDIUM : at32f435_437_edma.h
  • EDMA_PRIORITY_VERY_HIGH : at32f435_437_edma.h
  • EDMA_Stream1_IRQn : at32f435_437.h
  • EDMA_Stream2_IRQn : at32f435_437.h
  • EDMA_Stream3_IRQn : at32f435_437.h
  • EDMA_Stream4_IRQn : at32f435_437.h
  • EDMA_Stream5_IRQn : at32f435_437.h
  • EDMA_Stream6_IRQn : at32f435_437.h
  • EDMA_Stream7_IRQn : at32f435_437.h
  • EDMA_Stream8_IRQn : at32f435_437.h
  • EDMAMUX_DMAREQ_ID_ADC1 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_ADC2 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_ADC3 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_DAC1 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_DAC2 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_DVP : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_I2C1_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_I2C1_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_I2C2_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_I2C2_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_I2C3_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_I2C3_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_I2S2_EXT_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_I2S2_EXT_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_I2S3_EXT_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_I2S3_EXT_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_QSPI1 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_QSPI2 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_REQ_G1 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_REQ_G2 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_REQ_G3 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_REQ_G4 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_SDIO1 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_SDIO2 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_SPI1_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_SPI1_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_SPI2_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_SPI2_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_SPI3_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_SPI3_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_SPI4_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_SPI4_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR1_CH1 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR1_CH2 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR1_CH3 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR1_CH4 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR1_HALL : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR1_OVERFLOW : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR1_TRIG : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR20_CH1 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR20_CH2 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR20_CH3 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR20_CH4 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR20_HALL : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR20_OVERFLOW : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR20_TRIG : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR2_CH1 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR2_CH2 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR2_CH3 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR2_CH4 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR2_OVERFLOW : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR2_TRIG : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR3_CH1 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR3_CH2 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR3_CH3 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR3_CH4 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR3_OVERFLOW : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR3_TRIG : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR4_CH1 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR4_CH2 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR4_CH3 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR4_CH4 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR4_OVERFLOW : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR4_TRIG : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR5_CH1 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR5_CH2 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR5_CH3 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR5_CH4 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR5_OVERFLOW : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR5_TRIG : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR6_OVERFLOW : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR7_OVERFLOW : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR8_CH1 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR8_CH2 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR8_CH3 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR8_CH4 : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR8_HALL : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR8_OVERFLOW : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_TMR8_TRIG : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_UART4_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_UART4_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_UART5_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_UART5_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_UART7_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_UART7_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_UART8_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_UART8_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_USART1_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_USART1_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_USART2_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_USART2_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_USART3_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_USART3_TX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_USART6_RX : at32f435_437_edma.h
  • EDMAMUX_DMAREQ_ID_USART6_TX : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_DMAMUX_CH1_EVT : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_DMAMUX_CH2_EVT : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_DMAMUX_CH3_EVT : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_DMAMUX_CH4_EVT : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_DMAMUX_CH5_EVT : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_DMAMUX_CH6_EVT : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_DMAMUX_CH7_EVT : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_DMAMUX_CH8_EVT : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT0 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT1 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT10 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT11 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT12 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT13 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT14 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT15 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT2 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT3 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT4 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT5 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT6 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT7 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT8 : at32f435_437_edma.h
  • EDMAMUX_GEN_ID_EXINT9 : at32f435_437_edma.h
  • EDMAMUX_GEN_POLARITY_DISABLE : at32f435_437_edma.h
  • EDMAMUX_GEN_POLARITY_FALLING : at32f435_437_edma.h
  • EDMAMUX_GEN_POLARITY_RISING : at32f435_437_edma.h
  • EDMAMUX_GEN_POLARITY_RISING_FALLING : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_DMAMUX_CH1_EVT : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_DMAMUX_CH2_EVT : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_DMAMUX_CH3_EVT : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_DMAMUX_CH4_EVT : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_DMAMUX_CH5_EVT : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_DMAMUX_CH6_EVT : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_DMAMUX_CH7_EVT : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_DMAMUX_CH8_EVT : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT0 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT1 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT10 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT11 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT12 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT13 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT14 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT15 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT2 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT3 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT4 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT5 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT6 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT7 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT8 : at32f435_437_edma.h
  • EDMAMUX_SYNC_ID_EXINT9 : at32f435_437_edma.h
  • EDMAMUX_SYNC_POLARITY_DISABLE : at32f435_437_edma.h
  • EDMAMUX_SYNC_POLARITY_FALLING : at32f435_437_edma.h
  • EDMAMUX_SYNC_POLARITY_RISING : at32f435_437_edma.h
  • EDMAMUX_SYNC_POLARITY_RISING_FALLING : at32f435_437_edma.h
  • EMAC_ADDRESS_FILTER_1 : at32f435_437_emac.h
  • EMAC_ADDRESS_FILTER_2 : at32f435_437_emac.h
  • EMAC_ADDRESS_FILTER_3 : at32f435_437_emac.h
  • EMAC_ADDRESS_MASK_15H8 : at32f435_437_emac.h
  • EMAC_ADDRESS_MASK_15L8 : at32f435_437_emac.h
  • EMAC_ADDRESS_MASK_23L16 : at32f435_437_emac.h
  • EMAC_ADDRESS_MASK_31L24 : at32f435_437_emac.h
  • EMAC_ADDRESS_MASK_7H0 : at32f435_437_emac.h
  • EMAC_ADDRESS_MASK_8L0 : at32f435_437_emac.h
  • EMAC_AUTO_NEGOTIATION_OFF : at32f435_437_emac.h
  • EMAC_AUTO_NEGOTIATION_ON : at32f435_437_emac.h
  • EMAC_BACKOFF_LIMIT_0 : at32f435_437_emac.h
  • EMAC_BACKOFF_LIMIT_1 : at32f435_437_emac.h
  • EMAC_BACKOFF_LIMIT_2 : at32f435_437_emac.h
  • EMAC_BACKOFF_LIMIT_3 : at32f435_437_emac.h
  • EMAC_CLOCK_RANGE_100_TO_150 : at32f435_437_emac.h
  • EMAC_CLOCK_RANGE_150_TO_250 : at32f435_437_emac.h
  • EMAC_CLOCK_RANGE_20_TO_35 : at32f435_437_emac.h
  • EMAC_CLOCK_RANGE_250_TO_288 : at32f435_437_emac.h
  • EMAC_CLOCK_RANGE_35_TO_60 : at32f435_437_emac.h
  • EMAC_CLOCK_RANGE_60_TO_100 : at32f435_437_emac.h
  • EMAC_CONTROL_FRAME_PASSING_ALL : at32f435_437_emac.h
  • EMAC_CONTROL_FRAME_PASSING_MATCH : at32f435_437_emac.h
  • EMAC_CONTROL_FRAME_PASSING_NO : at32f435_437_emac.h
  • EMAC_DESTINATION_FILTER : at32f435_437_emac.h
  • EMAC_DMA_1_RX_1_TX : at32f435_437_emac.h
  • EMAC_DMA_2_RX_1_TX : at32f435_437_emac.h
  • EMAC_DMA_3_RX_1_TX : at32f435_437_emac.h
  • EMAC_DMA_4_RX_1_TX : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_ABNORMAL_SUMMARY : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_FATAL_BUS_ERROR : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_NORMAL_SUMMARY : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_RX : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_RX_EARLY : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_RX_OVERFLOW : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_RX_STOP : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_RX_TIMEOUT : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_RX_UNAVAILABLE : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_TX : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_TX_EARLY : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_TX_JABBER : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_TX_STOP : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_TX_UNAVAILABLE : at32f435_437_emac.h
  • EMAC_DMA_INTERRUPT_TX_UNDERFLOW : at32f435_437_emac.h
  • EMAC_DMA_OPS_DROP_ERROR_DISABLE : at32f435_437_emac.h
  • EMAC_DMA_OPS_FLUSH_TRANSMIT_FIFO : at32f435_437_emac.h
  • EMAC_DMA_OPS_FORWARD_ERROR : at32f435_437_emac.h
  • EMAC_DMA_OPS_FORWARD_UNDERSIZED : at32f435_437_emac.h
  • EMAC_DMA_OPS_RECEIVE_FLUSH_DISABLE : at32f435_437_emac.h
  • EMAC_DMA_OPS_RECEIVE_STORE_FORWARD : at32f435_437_emac.h
  • EMAC_DMA_OPS_SECOND_FRAME : at32f435_437_emac.h
  • EMAC_DMA_OPS_START_STOP_RECEIVE : at32f435_437_emac.h
  • EMAC_DMA_OPS_START_STOP_TRANSMIT : at32f435_437_emac.h
  • EMAC_DMA_OPS_TRANSMIT_STORE_FORWARD : at32f435_437_emac.h
  • EMAC_DMA_PBL_1 : at32f435_437_emac.h
  • EMAC_DMA_PBL_16 : at32f435_437_emac.h
  • EMAC_DMA_PBL_2 : at32f435_437_emac.h
  • EMAC_DMA_PBL_32 : at32f435_437_emac.h
  • EMAC_DMA_PBL_4 : at32f435_437_emac.h
  • EMAC_DMA_PBL_8 : at32f435_437_emac.h
  • EMAC_DMA_RECEIVE : at32f435_437_emac.h
  • EMAC_DMA_RX_BUFFER : at32f435_437_emac.h
  • EMAC_DMA_RX_CLOSE_DESCRIPTOR : at32f435_437_emac.h
  • EMAC_DMA_RX_DESCRIPTOR : at32f435_437_emac.h
  • EMAC_DMA_RX_DESCRIPTOR_UNAVAILABLE : at32f435_437_emac.h
  • EMAC_DMA_RX_FETCH_DESCRIPTOR : at32f435_437_emac.h
  • EMAC_DMA_RX_FIFO_TO_HOST : at32f435_437_emac.h
  • EMAC_DMA_RX_RESET_STOP_COMMAND : at32f435_437_emac.h
  • EMAC_DMA_RX_THRESHOLD_128_BYTES : at32f435_437_emac.h
  • EMAC_DMA_RX_THRESHOLD_32_BYTES : at32f435_437_emac.h
  • EMAC_DMA_RX_THRESHOLD_64_BYTES : at32f435_437_emac.h
  • EMAC_DMA_RX_THRESHOLD_96_BYTES : at32f435_437_emac.h
  • EMAC_DMA_RX_WAITING_PACKET : at32f435_437_emac.h
  • EMAC_DMA_TRANSMIT : at32f435_437_emac.h
  • EMAC_DMA_TX_BUFFER : at32f435_437_emac.h
  • EMAC_DMA_TX_CLOSE_DESCRIPTOR : at32f435_437_emac.h
  • EMAC_DMA_TX_DESCRIPTOR : at32f435_437_emac.h
  • EMAC_DMA_TX_DESCRIPTOR_UNAVAILABLE : at32f435_437_emac.h
  • EMAC_DMA_TX_FETCH_DESCRIPTOR : at32f435_437_emac.h
  • EMAC_DMA_TX_HOST_TO_FIFO : at32f435_437_emac.h
  • EMAC_DMA_TX_RESET_STOP_COMMAND : at32f435_437_emac.h
  • EMAC_DMA_TX_THRESHOLD_128_BYTES : at32f435_437_emac.h
  • EMAC_DMA_TX_THRESHOLD_16_BYTES : at32f435_437_emac.h
  • EMAC_DMA_TX_THRESHOLD_192_BYTES : at32f435_437_emac.h
  • EMAC_DMA_TX_THRESHOLD_24_BYTES : at32f435_437_emac.h
  • EMAC_DMA_TX_THRESHOLD_256_BYTES : at32f435_437_emac.h
  • EMAC_DMA_TX_THRESHOLD_32_BYTES : at32f435_437_emac.h
  • EMAC_DMA_TX_THRESHOLD_40_BYTES : at32f435_437_emac.h
  • EMAC_DMA_TX_THRESHOLD_64_BYTES : at32f435_437_emac.h
  • EMAC_DMA_TX_WAITING_FOR_STATUS : at32f435_437_emac.h
  • EMAC_FULL_DUPLEX : at32f435_437_emac.h
  • EMAC_HALF_DUPLEX : at32f435_437_emac.h
  • EMAC_INTERFRAME_GAP_40BIT : at32f435_437_emac.h
  • EMAC_INTERFRAME_GAP_48BIT : at32f435_437_emac.h
  • EMAC_INTERFRAME_GAP_56BIT : at32f435_437_emac.h
  • EMAC_INTERFRAME_GAP_64BIT : at32f435_437_emac.h
  • EMAC_INTERFRAME_GAP_72BIT : at32f435_437_emac.h
  • EMAC_INTERFRAME_GAP_80BIT : at32f435_437_emac.h
  • EMAC_INTERFRAME_GAP_88BIT : at32f435_437_emac.h
  • EMAC_INTERFRAME_GAP_96BIT : at32f435_437_emac.h
  • EMAC_INTERRUPT_PMT_MASK : at32f435_437_emac.h
  • EMAC_INTERRUPT_TST_MASK : at32f435_437_emac.h
  • EMAC_PAUSE_144_SLOT_TIME : at32f435_437_emac.h
  • EMAC_PAUSE_256_SLOT_TIME : at32f435_437_emac.h
  • EMAC_PAUSE_28_SLOT_TIME : at32f435_437_emac.h
  • EMAC_PAUSE_4_SLOT_TIME : at32f435_437_emac.h
  • EMAC_PTP_BOUNDARY_CLOCK : at32f435_437_emac.h
  • EMAC_PTP_END_TO_END_CLOCK : at32f435_437_emac.h
  • EMAC_PTP_NORMAL_CLOCK : at32f435_437_emac.h
  • EMAC_PTP_PEER_TO_PEER_CLOCK : at32f435_437_emac.h
  • EMAC_PTP_PPS_1024HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_128HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_16384HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_16HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_1HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_2048HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_256HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_2HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_32768HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_32HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_4096HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_4HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_512HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_64HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_8192HZ : at32f435_437_emac.h
  • EMAC_PTP_PPS_8HZ : at32f435_437_emac.h
  • EMAC_PTP_SECOND_OVERFLOW : at32f435_437_emac.h
  • EMAC_PTP_TARGET_TIME_REACH : at32f435_437_emac.h
  • EMAC_SOURCE_FILTER : at32f435_437_emac.h
  • EMAC_SPEED_100MBPS : at32f435_437_emac.h
  • EMAC_SPEED_10MBPS : at32f435_437_emac.h
  • EPT_BULK_TYPE : at32f435_437_usb.h
  • EPT_CONTROL_TYPE : at32f435_437_usb.h
  • EPT_DIR_IN : at32f435_437_usb.h
  • EPT_DIR_OUT : at32f435_437_usb.h
  • EPT_INT_TYPE : at32f435_437_usb.h
  • EPT_ISO_TYPE : at32f435_437_usb.h
  • ERROR : at32f435_437.h
  • ERTC_24H : at32f435_437_ertc.h
  • ERTC_ALA : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_1 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_10 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_11 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_12 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_13 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_2 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_3 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_4 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_5 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_6 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_7 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_8 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_14_9 : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_ALL : at32f435_437_ertc.h
  • ERTC_ALARM_SBS_MASK_NONE : at32f435_437_ertc.h
  • ERTC_ALB : at32f435_437_ertc.h
  • ERTC_AM : at32f435_437_ertc.h
  • ERTC_CAL_DIR_NEGATIVE : at32f435_437_ertc.h
  • ERTC_CAL_DIR_POSITIVE : at32f435_437_ertc.h
  • ERTC_CAL_OUTPUT_1HZ : at32f435_437_ertc.h
  • ERTC_CAL_OUTPUT_512HZ : at32f435_437_ertc.h
  • ERTC_DST_ADD_1H : at32f435_437_ertc.h
  • ERTC_DST_DEC_1H : at32f435_437_ertc.h
  • ERTC_DST_SAVE_0 : at32f435_437_ertc.h
  • ERTC_DST_SAVE_1 : at32f435_437_ertc.h
  • ERTC_DT1 : at32f435_437_ertc.h
  • ERTC_DT10 : at32f435_437_ertc.h
  • ERTC_DT11 : at32f435_437_ertc.h
  • ERTC_DT12 : at32f435_437_ertc.h
  • ERTC_DT13 : at32f435_437_ertc.h
  • ERTC_DT14 : at32f435_437_ertc.h
  • ERTC_DT15 : at32f435_437_ertc.h
  • ERTC_DT16 : at32f435_437_ertc.h
  • ERTC_DT17 : at32f435_437_ertc.h
  • ERTC_DT18 : at32f435_437_ertc.h
  • ERTC_DT19 : at32f435_437_ertc.h
  • ERTC_DT2 : at32f435_437_ertc.h
  • ERTC_DT20 : at32f435_437_ertc.h
  • ERTC_DT3 : at32f435_437_ertc.h
  • ERTC_DT4 : at32f435_437_ertc.h
  • ERTC_DT5 : at32f435_437_ertc.h
  • ERTC_DT6 : at32f435_437_ertc.h
  • ERTC_DT7 : at32f435_437_ertc.h
  • ERTC_DT8 : at32f435_437_ertc.h
  • ERTC_DT9 : at32f435_437_ertc.h
  • ERTC_HOUR_MODE_12 : at32f435_437_ertc.h
  • ERTC_HOUR_MODE_24 : at32f435_437_ertc.h
  • ERTC_OUTPUT_ALARM_A : at32f435_437_ertc.h
  • ERTC_OUTPUT_ALARM_B : at32f435_437_ertc.h
  • ERTC_OUTPUT_DISABLE : at32f435_437_ertc.h
  • ERTC_OUTPUT_POLARITY_HIGH : at32f435_437_ertc.h
  • ERTC_OUTPUT_POLARITY_LOW : at32f435_437_ertc.h
  • ERTC_OUTPUT_TYPE_OPEN_DRAIN : at32f435_437_ertc.h
  • ERTC_OUTPUT_TYPE_PUSH_PULL : at32f435_437_ertc.h
  • ERTC_OUTPUT_WAKEUP : at32f435_437_ertc.h
  • ERTC_PIN_PA0 : at32f435_437_ertc.h
  • ERTC_PIN_PC13 : at32f435_437_ertc.h
  • ERTC_PM : at32f435_437_ertc.h
  • ERTC_SLECT_DATE : at32f435_437_ertc.h
  • ERTC_SLECT_WEEK : at32f435_437_ertc.h
  • ERTC_SMOOTH_CAL_CLK_ADD_0 : at32f435_437_ertc.h
  • ERTC_SMOOTH_CAL_CLK_ADD_512 : at32f435_437_ertc.h
  • ERTC_SMOOTH_CAL_PERIOD_16 : at32f435_437_ertc.h
  • ERTC_SMOOTH_CAL_PERIOD_32 : at32f435_437_ertc.h
  • ERTC_SMOOTH_CAL_PERIOD_8 : at32f435_437_ertc.h
  • ERTC_TAMPER_1 : at32f435_437_ertc.h
  • ERTC_TAMPER_2 : at32f435_437_ertc.h
  • ERTC_TAMPER_EDGE_FALLING : at32f435_437_ertc.h
  • ERTC_TAMPER_EDGE_HIGH : at32f435_437_ertc.h
  • ERTC_TAMPER_EDGE_LOW : at32f435_437_ertc.h
  • ERTC_TAMPER_EDGE_RISING : at32f435_437_ertc.h
  • ERTC_TAMPER_FILTER_2 : at32f435_437_ertc.h
  • ERTC_TAMPER_FILTER_4 : at32f435_437_ertc.h
  • ERTC_TAMPER_FILTER_8 : at32f435_437_ertc.h
  • ERTC_TAMPER_FILTER_DISABLE : at32f435_437_ertc.h
  • ERTC_TAMPER_FREQ_DIV_1024 : at32f435_437_ertc.h
  • ERTC_TAMPER_FREQ_DIV_16384 : at32f435_437_ertc.h
  • ERTC_TAMPER_FREQ_DIV_2048 : at32f435_437_ertc.h
  • ERTC_TAMPER_FREQ_DIV_256 : at32f435_437_ertc.h
  • ERTC_TAMPER_FREQ_DIV_32768 : at32f435_437_ertc.h
  • ERTC_TAMPER_FREQ_DIV_4096 : at32f435_437_ertc.h
  • ERTC_TAMPER_FREQ_DIV_512 : at32f435_437_ertc.h
  • ERTC_TAMPER_FREQ_DIV_8192 : at32f435_437_ertc.h
  • ERTC_TAMPER_PR_1_ERTCCLK : at32f435_437_ertc.h
  • ERTC_TAMPER_PR_2_ERTCCLK : at32f435_437_ertc.h
  • ERTC_TAMPER_PR_4_ERTCCLK : at32f435_437_ertc.h
  • ERTC_TAMPER_PR_8_ERTCCLK : at32f435_437_ertc.h
  • ERTC_TIME_ADD_1S : at32f435_437_ertc.h
  • ERTC_TIME_ADD_NONE : at32f435_437_ertc.h
  • ERTC_TIMESTAMP_EDGE_FALLING : at32f435_437_ertc.h
  • ERTC_TIMESTAMP_EDGE_RISING : at32f435_437_ertc.h
  • ERTC_WAT_CLK_CK_B_16BITS : at32f435_437_ertc.h
  • ERTC_WAT_CLK_CK_B_17BITS : at32f435_437_ertc.h
  • ERTC_WAT_CLK_ERTCCLK_DIV16 : at32f435_437_ertc.h
  • ERTC_WAT_CLK_ERTCCLK_DIV2 : at32f435_437_ertc.h
  • ERTC_WAT_CLK_ERTCCLK_DIV4 : at32f435_437_ertc.h
  • ERTC_WAT_CLK_ERTCCLK_DIV8 : at32f435_437_ertc.h
  • ERTC_WKUP_IRQn : at32f435_437.h
  • ERTCAlarm_IRQn : at32f435_437.h
  • EXINT0_IRQn : at32f435_437.h
  • EXINT15_10_IRQn : at32f435_437.h
  • EXINT1_IRQn : at32f435_437.h
  • EXINT2_IRQn : at32f435_437.h
  • EXINT3_IRQn : at32f435_437.h
  • EXINT4_IRQn : at32f435_437.h
  • EXINT9_5_IRQn : at32f435_437.h
  • EXINT_LINE_EVENT : at32f435_437_exint.h
  • EXINT_LINE_INTERRUPUT : at32f435_437_exint.h
  • EXINT_TRIGGER_BOTH_EDGE : at32f435_437_exint.h
  • EXINT_TRIGGER_FALLING_EDGE : at32f435_437_exint.h
  • EXINT_TRIGGER_RISING_EDGE : at32f435_437_exint.h


AT32F435/437 Firmwary Library: Globals

- f -

  • FALSE : at32f435_437.h
  • FLASH_CLOCK_DIV_2 : at32f435_437_flash.h
  • FLASH_CLOCK_DIV_3 : at32f435_437_flash.h
  • FLASH_CLOCK_DIV_4 : at32f435_437_flash.h
  • FLASH_EOPB0_SRAM_128K : at32f435_437_flash.h
  • FLASH_EOPB0_SRAM_192K : at32f435_437_flash.h
  • FLASH_EOPB0_SRAM_256K : at32f435_437_flash.h
  • FLASH_EOPB0_SRAM_320K : at32f435_437_flash.h
  • FLASH_EOPB0_SRAM_384K : at32f435_437_flash.h
  • FLASH_EOPB0_SRAM_448K : at32f435_437_flash.h
  • FLASH_EOPB0_SRAM_512K : at32f435_437_flash.h
  • FLASH_EPP_ERROR : at32f435_437_flash.h
  • FLASH_IRQn : at32f435_437.h
  • FLASH_OPERATE_BUSY : at32f435_437_flash.h
  • FLASH_OPERATE_DONE : at32f435_437_flash.h
  • FLASH_OPERATE_TIMEOUT : at32f435_437_flash.h
  • FLASH_PROGRAM_ERROR : at32f435_437_flash.h
  • FPU_IRQn : at32f435_437.h


AT32F435/437 Firmwary Library: Globals

- g -

  • GPIO_DRIVE_STRENGTH_MODERATE : at32f435_437_gpio.h
  • GPIO_DRIVE_STRENGTH_STRONGER : at32f435_437_gpio.h
  • GPIO_MODE_ANALOG : at32f435_437_gpio.h
  • GPIO_MODE_INPUT : at32f435_437_gpio.h
  • GPIO_MODE_MUX : at32f435_437_gpio.h
  • GPIO_MODE_OUTPUT : at32f435_437_gpio.h
  • GPIO_MUX_0 : at32f435_437_gpio.h
  • GPIO_MUX_1 : at32f435_437_gpio.h
  • GPIO_MUX_10 : at32f435_437_gpio.h
  • GPIO_MUX_11 : at32f435_437_gpio.h
  • GPIO_MUX_12 : at32f435_437_gpio.h
  • GPIO_MUX_13 : at32f435_437_gpio.h
  • GPIO_MUX_14 : at32f435_437_gpio.h
  • GPIO_MUX_15 : at32f435_437_gpio.h
  • GPIO_MUX_2 : at32f435_437_gpio.h
  • GPIO_MUX_3 : at32f435_437_gpio.h
  • GPIO_MUX_4 : at32f435_437_gpio.h
  • GPIO_MUX_5 : at32f435_437_gpio.h
  • GPIO_MUX_6 : at32f435_437_gpio.h
  • GPIO_MUX_7 : at32f435_437_gpio.h
  • GPIO_MUX_8 : at32f435_437_gpio.h
  • GPIO_MUX_9 : at32f435_437_gpio.h
  • GPIO_OUTPUT_OPEN_DRAIN : at32f435_437_gpio.h
  • GPIO_OUTPUT_PUSH_PULL : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE0 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE1 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE10 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE11 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE12 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE13 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE14 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE15 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE2 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE3 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE4 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE5 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE6 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE7 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE8 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE9 : at32f435_437_gpio.h
  • GPIO_PULL_DOWN : at32f435_437_gpio.h
  • GPIO_PULL_NONE : at32f435_437_gpio.h
  • GPIO_PULL_UP : at32f435_437_gpio.h


AT32F435/437 Firmwary Library: Globals

- h -

  • HardFault_IRQn : at32f435_437.h


AT32F435/437 Firmwary Library: Globals

- i -

  • I2C1_ERR_IRQn : at32f435_437.h
  • I2C1_EVT_IRQn : at32f435_437.h
  • I2C2_ERR_IRQn : at32f435_437.h
  • I2C2_EVT_IRQn : at32f435_437.h
  • I2C3_ERR_IRQn : at32f435_437.h
  • I2C3_EVT_IRQn : at32f435_437.h
  • I2C_ADDR2_MASK01 : at32f435_437_i2c.h
  • I2C_ADDR2_MASK02 : at32f435_437_i2c.h
  • I2C_ADDR2_MASK03 : at32f435_437_i2c.h
  • I2C_ADDR2_MASK04 : at32f435_437_i2c.h
  • I2C_ADDR2_MASK05 : at32f435_437_i2c.h
  • I2C_ADDR2_MASK06 : at32f435_437_i2c.h
  • I2C_ADDR2_MASK07 : at32f435_437_i2c.h
  • I2C_ADDR2_NOMASK : at32f435_437_i2c.h
  • I2C_ADDRESS_MODE_10BIT : at32f435_437_i2c.h
  • I2C_ADDRESS_MODE_7BIT : at32f435_437_i2c.h
  • I2C_AUTO_STOP_MODE : at32f435_437_i2c.h
  • I2C_DIR_RECEIVE : at32f435_437_i2c.h
  • I2C_DIR_TRANSMIT : at32f435_437_i2c.h
  • I2C_DMA_MA_RX : i2c_application.h
  • I2C_DMA_MA_TX : i2c_application.h
  • I2C_DMA_REQUEST_RX : at32f435_437_i2c.h
  • I2C_DMA_REQUEST_TX : at32f435_437_i2c.h
  • I2C_DMA_SLA_RX : i2c_application.h
  • I2C_DMA_SLA_TX : i2c_application.h
  • I2C_ERR_ACKFAIL : i2c_application.h
  • I2C_ERR_ADDR : i2c_application.h
  • I2C_ERR_INTERRUPT : i2c_application.h
  • I2C_ERR_STEP_1 : i2c_application.h
  • I2C_ERR_STEP_10 : i2c_application.h
  • I2C_ERR_STEP_11 : i2c_application.h
  • I2C_ERR_STEP_12 : i2c_application.h
  • I2C_ERR_STEP_2 : i2c_application.h
  • I2C_ERR_STEP_3 : i2c_application.h
  • I2C_ERR_STEP_4 : i2c_application.h
  • I2C_ERR_STEP_5 : i2c_application.h
  • I2C_ERR_STEP_6 : i2c_application.h
  • I2C_ERR_STEP_7 : i2c_application.h
  • I2C_ERR_STEP_8 : i2c_application.h
  • I2C_ERR_STEP_9 : i2c_application.h
  • I2C_ERR_STOP : i2c_application.h
  • I2C_ERR_TCRLD : i2c_application.h
  • I2C_ERR_TDC : i2c_application.h
  • I2C_ERR_TIMEOUT : i2c_application.h
  • I2C_GEN_START_READ : at32f435_437_i2c.h
  • I2C_GEN_START_WRITE : at32f435_437_i2c.h
  • I2C_INT_MA_RX : i2c_application.h
  • I2C_INT_MA_TX : i2c_application.h
  • I2C_INT_SLA_RX : i2c_application.h
  • I2C_INT_SLA_TX : i2c_application.h
  • I2C_OK : i2c_application.h
  • I2C_RELOAD_MODE : at32f435_437_i2c.h
  • I2C_SMBUS_ALERT_HIGH : at32f435_437_i2c.h
  • I2C_SMBUS_ALERT_LOW : at32f435_437_i2c.h
  • I2C_SMBUS_MODE_DEVICE : at32f435_437_i2c.h
  • I2C_SMBUS_MODE_HOST : at32f435_437_i2c.h
  • I2C_SOFT_STOP_MODE : at32f435_437_i2c.h
  • I2C_TIMEOUT_DETCET_HIGH : at32f435_437_i2c.h
  • I2C_TIMEOUT_DETCET_LOW : at32f435_437_i2c.h
  • I2C_WITHOUT_START : at32f435_437_i2c.h
  • I2S_AUDIO_FREQUENCY_11_025K : at32f435_437_spi.h
  • I2S_AUDIO_FREQUENCY_16K : at32f435_437_spi.h
  • I2S_AUDIO_FREQUENCY_192K : at32f435_437_spi.h
  • I2S_AUDIO_FREQUENCY_22_05K : at32f435_437_spi.h
  • I2S_AUDIO_FREQUENCY_32K : at32f435_437_spi.h
  • I2S_AUDIO_FREQUENCY_44_1K : at32f435_437_spi.h
  • I2S_AUDIO_FREQUENCY_48K : at32f435_437_spi.h
  • I2S_AUDIO_FREQUENCY_8K : at32f435_437_spi.h
  • I2S_AUDIO_FREQUENCY_96K : at32f435_437_spi.h
  • I2S_AUDIO_FREQUENCY_DEFAULT : at32f435_437_spi.h
  • I2S_AUDIO_PROTOCOL_LSB : at32f435_437_spi.h
  • I2S_AUDIO_PROTOCOL_MSB : at32f435_437_spi.h
  • I2S_AUDIO_PROTOCOL_PCM_LONG : at32f435_437_spi.h
  • I2S_AUDIO_PROTOCOL_PCM_SHORT : at32f435_437_spi.h
  • I2S_AUDIO_PROTOCOL_PHILLIPS : at32f435_437_spi.h
  • I2S_CLOCK_POLARITY_HIGH : at32f435_437_spi.h
  • I2S_CLOCK_POLARITY_LOW : at32f435_437_spi.h
  • I2S_DATA_16BIT_CHANNEL_16BIT : at32f435_437_spi.h
  • I2S_DATA_16BIT_CHANNEL_32BIT : at32f435_437_spi.h
  • I2S_DATA_24BIT_CHANNEL_32BIT : at32f435_437_spi.h
  • I2S_DATA_32BIT_CHANNEL_32BIT : at32f435_437_spi.h
  • I2S_MODE_MASTER_RX : at32f435_437_spi.h
  • I2S_MODE_MASTER_TX : at32f435_437_spi.h
  • I2S_MODE_SLAVE_RX : at32f435_437_spi.h
  • I2S_MODE_SLAVE_TX : at32f435_437_spi.h
  • IAP_FAILED : hid_iap_class.h
  • IAP_STS_ADDR : hid_iap_class.h
  • IAP_STS_CRC : hid_iap_class.h
  • IAP_STS_DATA : hid_iap_class.h
  • IAP_STS_FINISH : hid_iap_class.h
  • IAP_STS_IDLE : hid_iap_class.h
  • IAP_STS_JMP : hid_iap_class.h
  • IAP_STS_JMP_WAIT : hid_iap_class.h
  • IAP_STS_START : hid_iap_class.h
  • IAP_SUCCESS : hid_iap_class.h
  • IAP_WAIT : hid_iap_class.h


AT32F435/437 Firmwary Library: Globals

- l -

  • LED2 : at32f435_437_board.h
  • LED3 : at32f435_437_board.h
  • LED4 : at32f435_437_board.h


AT32F435/437 Firmwary Library: Globals

- m -

  • MemoryManagement_IRQn : at32f435_437.h
  • MSC_ERROR : usbh_msc_bot_scsi.h
  • MSC_NOT_READY : usbh_msc_bot_scsi.h
  • MSC_OK : usbh_msc_bot_scsi.h


AT32F435/437 Firmwary Library: Globals

- n -

  • NO_BUTTON : at32f435_437_board.h
  • NonMaskableInt_IRQn : at32f435_437.h
  • NOR_ERROR : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • NOR_ONGOING : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • NOR_SUCCESS : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • NOR_TIMEOUT : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • NVIC_LP_SEVONPEND : at32f435_437_misc.h
  • NVIC_LP_SLEEPDEEP : at32f435_437_misc.h
  • NVIC_LP_SLEEPONEXIT : at32f435_437_misc.h
  • NVIC_PRIORITY_GROUP_0 : at32f435_437_misc.h
  • NVIC_PRIORITY_GROUP_1 : at32f435_437_misc.h
  • NVIC_PRIORITY_GROUP_2 : at32f435_437_misc.h
  • NVIC_PRIORITY_GROUP_3 : at32f435_437_misc.h
  • NVIC_PRIORITY_GROUP_4 : at32f435_437_misc.h


AT32F435/437 Firmwary Library: Globals

- o -

  • OTG_DEVICE_MODE : at32f435_437_usb.h
  • OTG_DRD_MODE : at32f435_437_usb.h
  • OTG_HOST_MODE : at32f435_437_usb.h
  • OTGFS1_IRQn : at32f435_437.h
  • OTGFS1_WKUP_IRQn : at32f435_437.h
  • OTGFS2_IRQn : at32f435_437.h
  • OTGFS2_WKUP_IRQn : at32f435_437.h


AT32F435/437 Firmwary Library: Globals

- p -

  • PEM_STEP_BEGIN : at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c
  • PEM_STEP_END : at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c
  • PEM_STEP_KEEP : at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c
  • PendSV_IRQn : at32f435_437.h
  • PRINTER_REQ_GET_DEVICE_ID : printer_class.h
  • PRINTER_REQ_GET_PORT_STATUS : printer_class.h
  • PRINTER_REQ_GET_SOFT_RESET : printer_class.h
  • PVM_IRQn : at32f435_437.h
  • PWC_DEEP_SLEEP_ENTER_WFE : at32f435_437_pwc.h
  • PWC_DEEP_SLEEP_ENTER_WFI : at32f435_437_pwc.h
  • PWC_LDO_OUTPUT_1V0 : at32f435_437_pwc.h
  • PWC_LDO_OUTPUT_1V1 : at32f435_437_pwc.h
  • PWC_LDO_OUTPUT_1V2 : at32f435_437_pwc.h
  • PWC_LDO_OUTPUT_1V3 : at32f435_437_pwc.h
  • PWC_PVM_VOLTAGE_2V3 : at32f435_437_pwc.h
  • PWC_PVM_VOLTAGE_2V4 : at32f435_437_pwc.h
  • PWC_PVM_VOLTAGE_2V5 : at32f435_437_pwc.h
  • PWC_PVM_VOLTAGE_2V6 : at32f435_437_pwc.h
  • PWC_PVM_VOLTAGE_2V7 : at32f435_437_pwc.h
  • PWC_PVM_VOLTAGE_2V8 : at32f435_437_pwc.h
  • PWC_PVM_VOLTAGE_2V9 : at32f435_437_pwc.h
  • PWC_REGULATOR_LOW_POWER : at32f435_437_pwc.h
  • PWC_REGULATOR_ON : at32f435_437_pwc.h
  • PWC_SLEEP_ENTER_WFE : at32f435_437_pwc.h
  • PWC_SLEEP_ENTER_WFI : at32f435_437_pwc.h


AT32F435/437 Firmwary Library: Globals

- q -

  • QSPI1_IRQn : at32f435_437.h
  • QSPI2_IRQn : at32f435_437.h
  • QSPI_BUSY_OFFSET_0 : at32f435_437_qspi.h
  • QSPI_BUSY_OFFSET_1 : at32f435_437_qspi.h
  • QSPI_BUSY_OFFSET_2 : at32f435_437_qspi.h
  • QSPI_BUSY_OFFSET_3 : at32f435_437_qspi.h
  • QSPI_BUSY_OFFSET_4 : at32f435_437_qspi.h
  • QSPI_BUSY_OFFSET_5 : at32f435_437_qspi.h
  • QSPI_BUSY_OFFSET_6 : at32f435_437_qspi.h
  • QSPI_BUSY_OFFSET_7 : at32f435_437_qspi.h
  • QSPI_CLK_DIV_10 : at32f435_437_qspi.h
  • QSPI_CLK_DIV_12 : at32f435_437_qspi.h
  • QSPI_CLK_DIV_2 : at32f435_437_qspi.h
  • QSPI_CLK_DIV_3 : at32f435_437_qspi.h
  • QSPI_CLK_DIV_4 : at32f435_437_qspi.h
  • QSPI_CLK_DIV_5 : at32f435_437_qspi.h
  • QSPI_CLK_DIV_6 : at32f435_437_qspi.h
  • QSPI_CLK_DIV_8 : at32f435_437_qspi.h
  • QSPI_CMD_ADRLEN_0_BYTE : at32f435_437_qspi.h
  • QSPI_CMD_ADRLEN_1_BYTE : at32f435_437_qspi.h
  • QSPI_CMD_ADRLEN_2_BYTE : at32f435_437_qspi.h
  • QSPI_CMD_ADRLEN_3_BYTE : at32f435_437_qspi.h
  • QSPI_CMD_ADRLEN_4_BYTE : at32f435_437_qspi.h
  • QSPI_CMD_INSLEN_0_BYTE : at32f435_437_qspi.h
  • QSPI_CMD_INSLEN_1_BYTE : at32f435_437_qspi.h
  • QSPI_CMD_INSLEN_2_BYTE : at32f435_437_qspi.h
  • QSPI_DMA_FIFO_THOD_WORD08 : at32f435_437_qspi.h
  • QSPI_DMA_FIFO_THOD_WORD16 : at32f435_437_qspi.h
  • QSPI_DMA_FIFO_THOD_WORD32 : at32f435_437_qspi.h
  • QSPI_OPERATE_MODE_111 : at32f435_437_qspi.h
  • QSPI_OPERATE_MODE_112 : at32f435_437_qspi.h
  • QSPI_OPERATE_MODE_114 : at32f435_437_qspi.h
  • QSPI_OPERATE_MODE_122 : at32f435_437_qspi.h
  • QSPI_OPERATE_MODE_144 : at32f435_437_qspi.h
  • QSPI_OPERATE_MODE_222 : at32f435_437_qspi.h
  • QSPI_OPERATE_MODE_444 : at32f435_437_qspi.h
  • QSPI_RSTSC_HW_AUTO : at32f435_437_qspi.h
  • QSPI_RSTSC_SW_ONCE : at32f435_437_qspi.h
  • QSPI_SCK_MODE_0 : at32f435_437_qspi.h
  • QSPI_SCK_MODE_3 : at32f435_437_qspi.h
  • QSPI_XIP_ADDRLEN_3_BYTE : at32f435_437_qspi.h
  • QSPI_XIP_ADDRLEN_4_BYTE : at32f435_437_qspi.h
  • QSPI_XIPR_SEL_MODED : at32f435_437_qspi.h
  • QSPI_XIPR_SEL_MODET : at32f435_437_qspi.h
  • QSPI_XIPW_SEL_MODED : at32f435_437_qspi.h
  • QSPI_XIPW_SEL_MODET : at32f435_437_qspi.h


AT32F435/437 Firmwary Library: Globals

- r -

  • RESET : at32f435_437.h
  • Reset_IRQn : at32f435_437.h


AT32F435/437 Firmwary Library: Globals

- s -

  • SCFG_EMAC_SELECT_MII : at32f435_437_scfg.h
  • SCFG_EMAC_SELECT_RMII : at32f435_437_scfg.h
  • SCFG_IR_POLARITY_NO_AFFECTE : at32f435_437_scfg.h
  • SCFG_IR_POLARITY_REVERSE : at32f435_437_scfg.h
  • SCFG_IR_SOURCE_TMR10 : at32f435_437_scfg.h
  • SCFG_IR_SOURCE_USART1 : at32f435_437_scfg.h
  • SCFG_IR_SOURCE_USART2 : at32f435_437_scfg.h
  • SCFG_MEM_MAP_BOOT_MEMORY : at32f435_437_scfg.h
  • SCFG_MEM_MAP_INTERNAL_SRAM : at32f435_437_scfg.h
  • SCFG_MEM_MAP_MAIN_MEMORY : at32f435_437_scfg.h
  • SCFG_MEM_MAP_XMC_BANK1 : at32f435_437_scfg.h
  • SCFG_MEM_MAP_XMC_SDRAM_BANK1 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE0 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE1 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE10 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE11 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE12 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE13 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE14 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE15 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE2 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE3 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE4 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE5 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE6 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE7 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE8 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE9 : at32f435_437_scfg.h
  • SCFG_PORT_SOURCE_GPIOA : at32f435_437_scfg.h
  • SCFG_PORT_SOURCE_GPIOB : at32f435_437_scfg.h
  • SCFG_PORT_SOURCE_GPIOC : at32f435_437_scfg.h
  • SCFG_PORT_SOURCE_GPIOD : at32f435_437_scfg.h
  • SCFG_PORT_SOURCE_GPIOE : at32f435_437_scfg.h
  • SCFG_PORT_SOURCE_GPIOF : at32f435_437_scfg.h
  • SCFG_PORT_SOURCE_GPIOG : at32f435_437_scfg.h
  • SCFG_PORT_SOURCE_GPIOH : at32f435_437_scfg.h
  • SCFG_ULTRA_DRIVEN_PB10 : at32f435_437_scfg.h
  • SCFG_ULTRA_DRIVEN_PB3 : at32f435_437_scfg.h
  • SCFG_ULTRA_DRIVEN_PB9 : at32f435_437_scfg.h
  • SCFG_ULTRA_DRIVEN_PD12 : at32f435_437_scfg.h
  • SCFG_ULTRA_DRIVEN_PD13 : at32f435_437_scfg.h
  • SCFG_ULTRA_DRIVEN_PD14 : at32f435_437_scfg.h
  • SCFG_ULTRA_DRIVEN_PD15 : at32f435_437_scfg.h
  • SCFG_ULTRA_DRIVEN_PF14 : at32f435_437_scfg.h
  • SCFG_ULTRA_DRIVEN_PF15 : at32f435_437_scfg.h
  • SCFG_XMC_SWAP_MODE1 : at32f435_437_scfg.h
  • SCFG_XMC_SWAP_MODE2 : at32f435_437_scfg.h
  • SCFG_XMC_SWAP_MODE3 : at32f435_437_scfg.h
  • SCFG_XMC_SWAP_NONE : at32f435_437_scfg.h
  • SD_ADDR_MISALIGNED : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_ADDR_OUT_OF_RANGE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_AKE_SEQ_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_BLK_LEN_ERR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_CONTROLLER_ERR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_DISCONNECTED : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_ECC_DISABLED : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_ECC_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_IDENTIFICATION : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_PROGRAMMING : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_READY : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_RECEIVING : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_SENDING : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_STANDBY : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_TRANSFER : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CID_CSD_OVERWRITE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_CRC_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_FAIL : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_OUT_OF_RANGE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_RSP_TIMEOUT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_DATA_FAIL : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_DATA_TIMEOUT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_ERASE_RESET : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_ERASE_SEQ_ERR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_GENERAL_UNKNOWN_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_ILLEGAL_CMD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_INTERNAL_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_INVALID_ERASE_PARAM : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_INVALID_PARAMETER : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_INVALID_VOLTRANGE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_LOCK_UNLOCK_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_NOT_CONFIGURED : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OK : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_REQ_NOT_APPLICABLE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_REQ_PENDING : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_RX_OVERRUN : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_SDIO_DISABLED : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_SDIO_FUNC_BUSY : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_SDIO_FUNC_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_SDIO_UNKNOWN_FUNC : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_START_BIT_ERR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_STREAM_RD_UNDERRUN : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_STREAM_WR_OVERRUN : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_SWITCH_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_TRANSFER_DMA_MODE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_TRANSFER_POLLING_MODE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_TX_UNDERRUN : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_UNSUPPORTED_FEATURE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_UNSUPPORTED_HW : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_WP_ERASE_SKIP : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_WR_PROTECT_VIOLATION : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO1_IRQn : at32f435_437.h
  • SDIO2_IRQn : at32f435_437.h
  • SDIO_BUS_WIDTH_D1 : at32f435_437_sdio.h
  • SDIO_BUS_WIDTH_D4 : at32f435_437_sdio.h
  • SDIO_BUS_WIDTH_D8 : at32f435_437_sdio.h
  • SDIO_CLOCK_EDGE_FALLING : at32f435_437_sdio.h
  • SDIO_CLOCK_EDGE_RISING : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_1024B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_128B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_16384B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_16B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_1B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_2048B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_256B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_2B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_32B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_4096B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_4B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_512B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_64B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_8192B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_8B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_TRANSFER : at32f435_437_sdio.h
  • SDIO_DATA_STREAM_TRANSFER : at32f435_437_sdio.h
  • SDIO_DATA_TRANSFER_TO_CARD : at32f435_437_sdio.h
  • SDIO_DATA_TRANSFER_TO_CONTROLLER : at32f435_437_sdio.h
  • SDIO_HIGH_CAPACITY_MMC_CARD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_HIGH_CAPACITY_SD_CARD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_HIGH_SPEED_MULTIMEDIA_CARD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_MULTIMEDIA_CARD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_POWER_OFF : at32f435_437_sdio.h
  • SDIO_POWER_ON : at32f435_437_sdio.h
  • SDIO_READ_WAIT_CONTROLLED_BY_CK : at32f435_437_sdio.h
  • SDIO_READ_WAIT_CONTROLLED_BY_D2 : at32f435_437_sdio.h
  • SDIO_RESPONSE_LONG : at32f435_437_sdio.h
  • SDIO_RESPONSE_NO : at32f435_437_sdio.h
  • SDIO_RESPONSE_SHORT : at32f435_437_sdio.h
  • SDIO_RSP1_INDEX : at32f435_437_sdio.h
  • SDIO_RSP2_INDEX : at32f435_437_sdio.h
  • SDIO_RSP3_INDEX : at32f435_437_sdio.h
  • SDIO_RSP4_INDEX : at32f435_437_sdio.h
  • SDIO_SDIO_CARD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_SECURE_DIGITAL_IO_CARD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_SECURE_DIGITAL_IO_COMBO_CARD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_STD_CAPACITY_SD_CARD_V1_1 : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_STD_CAPACITY_SD_CARD_V2_0 : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_WAIT_FOR_INT : at32f435_437_sdio.h
  • SDIO_WAIT_FOR_NO : at32f435_437_sdio.h
  • SDIO_WAIT_FOR_PEND : at32f435_437_sdio.h
  • SET : at32f435_437.h
  • SPI1_IRQn : at32f435_437.h
  • SPI2_I2S2EXT_IRQn : at32f435_437.h
  • SPI3_I2S3EXT_IRQn : at32f435_437.h
  • SPI4_IRQn : at32f435_437.h
  • SPI_CLOCK_PHASE_1EDGE : at32f435_437_spi.h
  • SPI_CLOCK_PHASE_2EDGE : at32f435_437_spi.h
  • SPI_CLOCK_POLARITY_HIGH : at32f435_437_spi.h
  • SPI_CLOCK_POLARITY_LOW : at32f435_437_spi.h
  • SPI_CRC_RX : at32f435_437_spi.h
  • SPI_CRC_TX : at32f435_437_spi.h
  • SPI_CS_HARDWARE_MODE : at32f435_437_spi.h
  • SPI_CS_SOFTWARE_MODE : at32f435_437_spi.h
  • SPI_FIRST_BIT_LSB : at32f435_437_spi.h
  • SPI_FIRST_BIT_MSB : at32f435_437_spi.h
  • SPI_FRAME_16BIT : at32f435_437_spi.h
  • SPI_FRAME_8BIT : at32f435_437_spi.h
  • SPI_HALF_DUPLEX_DIRECTION_RX : at32f435_437_spi.h
  • SPI_HALF_DUPLEX_DIRECTION_TX : at32f435_437_spi.h
  • SPI_MCLK_DIV_1024 : at32f435_437_spi.h
  • SPI_MCLK_DIV_128 : at32f435_437_spi.h
  • SPI_MCLK_DIV_16 : at32f435_437_spi.h
  • SPI_MCLK_DIV_2 : at32f435_437_spi.h
  • SPI_MCLK_DIV_256 : at32f435_437_spi.h
  • SPI_MCLK_DIV_3 : at32f435_437_spi.h
  • SPI_MCLK_DIV_32 : at32f435_437_spi.h
  • SPI_MCLK_DIV_4 : at32f435_437_spi.h
  • SPI_MCLK_DIV_512 : at32f435_437_spi.h
  • SPI_MCLK_DIV_64 : at32f435_437_spi.h
  • SPI_MCLK_DIV_8 : at32f435_437_spi.h
  • SPI_MODE_MASTER : at32f435_437_spi.h
  • SPI_MODE_SLAVE : at32f435_437_spi.h
  • SPI_SWCS_INTERNAL_LEVEL_HIGHT : at32f435_437_spi.h
  • SPI_SWCS_INTERNAL_LEVEL_LOW : at32f435_437_spi.h
  • SPI_TRANSMIT_FULL_DUPLEX : at32f435_437_spi.h
  • SPI_TRANSMIT_HALF_DUPLEX_RX : at32f435_437_spi.h
  • SPI_TRANSMIT_HALF_DUPLEX_TX : at32f435_437_spi.h
  • SPI_TRANSMIT_SIMPLEX_RX : at32f435_437_spi.h
  • SUCCESS : at32f435_437.h
  • SVCall_IRQn : at32f435_437.h
  • SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8 : at32f435_437_misc.h
  • SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV : at32f435_437_misc.h
  • SysTick_IRQn : at32f435_437.h


AT32F435/437 Firmwary Library: Globals

- t -

  • TAMP_STAMP_IRQn : at32f435_437.h
  • TEST_FAIL : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sdio_fatfs/src/main.c
  • TEST_SUCCESS : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sdio_fatfs/src/main.c
  • TFTP_ACK : tftpserver.h
  • TFTP_DATA : tftpserver.h
  • TFTP_ERR_ACCESS_VIOLATION : tftpserver.h
  • TFTP_ERR_DISKFULL : tftpserver.h
  • TFTP_ERR_FILE_ALREADY_EXISTS : tftpserver.h
  • TFTP_ERR_FILE_NOT_FOUND : tftpserver.h
  • TFTP_ERR_ILLEGALOP : tftpserver.h
  • TFTP_ERR_NO_SUCH_USER : tftpserver.h
  • TFTP_ERR_NOTDEFINED : tftpserver.h
  • TFTP_ERR_UKNOWN_TRANSFER_ID : tftpserver.h
  • TFTP_ERROR : tftpserver.h
  • TFTP_RRQ : tftpserver.h
  • TFTP_WRQ : tftpserver.h
  • TMR1_BRK_TMR9_IRQn : at32f435_437.h
  • TMR1_CH_IRQn : at32f435_437.h
  • TMR1_OVF_TMR10_IRQn : at32f435_437.h
  • TMR1_TRG_HALL_TMR11_IRQn : at32f435_437.h
  • TMR20_BRK_IRQn : at32f435_437.h
  • TMR20_CH_IRQn : at32f435_437.h
  • TMR20_OVF_IRQn : at32f435_437.h
  • TMR20_TRG_HALL_IRQn : at32f435_437.h
  • TMR2_GLOBAL_IRQn : at32f435_437.h
  • TMR2_OTG1FS_TMR5_LEXT : at32f435_437_tmr.h
  • TMR2_OTG2FS_TMR5_ERTC : at32f435_437_tmr.h
  • TMR2_PTP_TMR5_LICK : at32f435_437_tmr.h
  • TMR2_TMR8TRGOUT_TMR5_GPIO : at32f435_437_tmr.h
  • TMR3_GLOBAL_IRQn : at32f435_437.h
  • TMR4_GLOBAL_IRQn : at32f435_437.h
  • TMR5_GLOBAL_IRQn : at32f435_437.h
  • TMR6_DAC_GLOBAL_IRQn : at32f435_437.h
  • TMR7_GLOBAL_IRQn : at32f435_437.h
  • TMR8_BRK_TMR12_IRQn : at32f435_437.h
  • TMR8_CH_IRQn : at32f435_437.h
  • TMR8_OVF_TMR13_IRQn : at32f435_437.h
  • TMR8_TRG_HALL_TMR14_IRQn : at32f435_437.h
  • TMR_BRK_ADDRESS : at32f435_437_tmr.h
  • TMR_BRK_INPUT_ACTIVE_HIGH : at32f435_437_tmr.h
  • TMR_BRK_INPUT_ACTIVE_LOW : at32f435_437_tmr.h
  • TMR_BRK_SWTRIG : at32f435_437_tmr.h
  • TMR_C1_DMA_REQUEST : at32f435_437_tmr.h
  • TMR_C1_SWTRIG : at32f435_437_tmr.h
  • TMR_C1DT_ADDRESS : at32f435_437_tmr.h
  • TMR_C2_DMA_REQUEST : at32f435_437_tmr.h
  • TMR_C2_SWTRIG : at32f435_437_tmr.h
  • TMR_C2DT_ADDRESS : at32f435_437_tmr.h
  • TMR_C3_DMA_REQUEST : at32f435_437_tmr.h
  • TMR_C3_SWTRIG : at32f435_437_tmr.h
  • TMR_C3DT_ADDRESS : at32f435_437_tmr.h
  • TMR_C4_DMA_REQUEST : at32f435_437_tmr.h
  • TMR_C4_SWTRIG : at32f435_437_tmr.h
  • TMR_C4DT_ADDRESS : at32f435_437_tmr.h
  • TMR_CC_CHANNEL_MAPPED_DIRECT : at32f435_437_tmr.h
  • TMR_CC_CHANNEL_MAPPED_INDIRECT : at32f435_437_tmr.h
  • TMR_CC_CHANNEL_MAPPED_STI : at32f435_437_tmr.h
  • TMR_CCTRL_ADDRESS : at32f435_437_tmr.h
  • TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR : at32f435_437_tmr.h
  • TMR_CHANEL1_CONNECTED_C1IRAW : at32f435_437_tmr.h
  • TMR_CHANNEL_INPUT_DIV_1 : at32f435_437_tmr.h
  • TMR_CHANNEL_INPUT_DIV_2 : at32f435_437_tmr.h
  • TMR_CHANNEL_INPUT_DIV_4 : at32f435_437_tmr.h
  • TMR_CHANNEL_INPUT_DIV_8 : at32f435_437_tmr.h
  • TMR_CLOCK_DIV1 : at32f435_437_tmr.h
  • TMR_CLOCK_DIV2 : at32f435_437_tmr.h
  • TMR_CLOCK_DIV4 : at32f435_437_tmr.h
  • TMR_CM1_ADDRESS : at32f435_437_tmr.h
  • TMR_CM2_ADDRESS : at32f435_437_tmr.h
  • TMR_COUNT_DOWN : at32f435_437_tmr.h
  • TMR_COUNT_TWO_WAY_1 : at32f435_437_tmr.h
  • TMR_COUNT_TWO_WAY_2 : at32f435_437_tmr.h
  • TMR_COUNT_TWO_WAY_3 : at32f435_437_tmr.h
  • TMR_COUNT_UP : at32f435_437_tmr.h
  • TMR_CTRL1_ADDRESS : at32f435_437_tmr.h
  • TMR_CTRL2_ADDRESS : at32f435_437_tmr.h
  • TMR_CVAL_ADDRESS : at32f435_437_tmr.h
  • TMR_DIV_ADDRESS : at32f435_437_tmr.h
  • TMR_DMA_REQUEST_BY_CHANNEL : at32f435_437_tmr.h
  • TMR_DMA_REQUEST_BY_OVERFLOW : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_10BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_11BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_12BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_13BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_14BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_15BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_16BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_17BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_18BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_1BYTE : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_2BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_3BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_4BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_5BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_6BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_7BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_8BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_9BYTES : at32f435_437_tmr.h
  • TMR_DMACTRL_ADDRESS : at32f435_437_tmr.h
  • TMR_ENCODER_MODE_A : at32f435_437_tmr.h
  • TMR_ENCODER_MODE_B : at32f435_437_tmr.h
  • TMR_ENCODER_MODE_C : at32f435_437_tmr.h
  • TMR_ES_FREQUENCY_DIV_1 : at32f435_437_tmr.h
  • TMR_ES_FREQUENCY_DIV_2 : at32f435_437_tmr.h
  • TMR_ES_FREQUENCY_DIV_4 : at32f435_437_tmr.h
  • TMR_ES_FREQUENCY_DIV_8 : at32f435_437_tmr.h
  • TMR_ES_POLARITY_INVERTED : at32f435_437_tmr.h
  • TMR_ES_POLARITY_NON_INVERTED : at32f435_437_tmr.h
  • TMR_FORCE_OUTPUT_HIGH : at32f435_437_tmr.h
  • TMR_FORCE_OUTPUT_LOW : at32f435_437_tmr.h
  • TMR_HALL_DMA_REQUEST : at32f435_437_tmr.h
  • TMR_HALL_SWTRIG : at32f435_437_tmr.h
  • TMR_IDEN_ADDRESS : at32f435_437_tmr.h
  • TMR_INPUT_BOTH_EDGE : at32f435_437_tmr.h
  • TMR_INPUT_FALLING_EDGE : at32f435_437_tmr.h
  • TMR_INPUT_RISING_EDGE : at32f435_437_tmr.h
  • TMR_ISTS_ADDRESS : at32f435_437_tmr.h
  • TMR_OUTPUT_ACTIVE_HIGH : at32f435_437_tmr.h
  • TMR_OUTPUT_ACTIVE_LOW : at32f435_437_tmr.h
  • TMR_OUTPUT_CONTROL_FORCE_HIGH : at32f435_437_tmr.h
  • TMR_OUTPUT_CONTROL_FORCE_LOW : at32f435_437_tmr.h
  • TMR_OUTPUT_CONTROL_HIGH : at32f435_437_tmr.h
  • TMR_OUTPUT_CONTROL_LOW : at32f435_437_tmr.h
  • TMR_OUTPUT_CONTROL_OFF : at32f435_437_tmr.h
  • TMR_OUTPUT_CONTROL_PWM_MODE_A : at32f435_437_tmr.h
  • TMR_OUTPUT_CONTROL_PWM_MODE_B : at32f435_437_tmr.h
  • TMR_OUTPUT_CONTROL_SWITCH : at32f435_437_tmr.h
  • TMR_OVERFLOW_DMA_REQUEST : at32f435_437_tmr.h
  • TMR_OVERFLOW_SWTRIG : at32f435_437_tmr.h
  • TMR_POLARITY_ACTIVE_BOTH : at32f435_437_tmr.h
  • TMR_POLARITY_ACTIVE_HIGH : at32f435_437_tmr.h
  • TMR_POLARITY_ACTIVE_LOW : at32f435_437_tmr.h
  • TMR_PR_ADDRESS : at32f435_437_tmr.h
  • TMR_PRIMARY_SEL_C1ORAW : at32f435_437_tmr.h
  • TMR_PRIMARY_SEL_C2ORAW : at32f435_437_tmr.h
  • TMR_PRIMARY_SEL_C3ORAW : at32f435_437_tmr.h
  • TMR_PRIMARY_SEL_C4ORAW : at32f435_437_tmr.h
  • TMR_PRIMARY_SEL_COMPARE : at32f435_437_tmr.h
  • TMR_PRIMARY_SEL_ENABLE : at32f435_437_tmr.h
  • TMR_PRIMARY_SEL_OVERFLOW : at32f435_437_tmr.h
  • TMR_PRIMARY_SEL_RESET : at32f435_437_tmr.h
  • TMR_RPR_ADDRESS : at32f435_437_tmr.h
  • TMR_SELECT_CHANNEL_1 : at32f435_437_tmr.h
  • TMR_SELECT_CHANNEL_1C : at32f435_437_tmr.h
  • TMR_SELECT_CHANNEL_2 : at32f435_437_tmr.h
  • TMR_SELECT_CHANNEL_2C : at32f435_437_tmr.h
  • TMR_SELECT_CHANNEL_3 : at32f435_437_tmr.h
  • TMR_SELECT_CHANNEL_3C : at32f435_437_tmr.h
  • TMR_SELECT_CHANNEL_4 : at32f435_437_tmr.h
  • TMR_SELECT_CHANNEL_5 : at32f435_437_tmr.h
  • TMR_STCTRL_ADDRESS : at32f435_437_tmr.h
  • TMR_SUB_ENCODER_MODE_A : at32f435_437_tmr.h
  • TMR_SUB_ENCODER_MODE_B : at32f435_437_tmr.h
  • TMR_SUB_ENCODER_MODE_C : at32f435_437_tmr.h
  • TMR_SUB_EXTERNAL_CLOCK_MODE_A : at32f435_437_tmr.h
  • TMR_SUB_HANG_MODE : at32f435_437_tmr.h
  • TMR_SUB_INPUT_SEL_C1DF1 : at32f435_437_tmr.h
  • TMR_SUB_INPUT_SEL_C1INC : at32f435_437_tmr.h
  • TMR_SUB_INPUT_SEL_C2DF2 : at32f435_437_tmr.h
  • TMR_SUB_INPUT_SEL_EXTIN : at32f435_437_tmr.h
  • TMR_SUB_INPUT_SEL_IS0 : at32f435_437_tmr.h
  • TMR_SUB_INPUT_SEL_IS1 : at32f435_437_tmr.h
  • TMR_SUB_INPUT_SEL_IS2 : at32f435_437_tmr.h
  • TMR_SUB_INPUT_SEL_IS3 : at32f435_437_tmr.h
  • TMR_SUB_MODE_DIABLE : at32f435_437_tmr.h
  • TMR_SUB_RESET_MODE : at32f435_437_tmr.h
  • TMR_SUB_TRIGGER_MODE : at32f435_437_tmr.h
  • TMR_SWEVT_ADDRESS : at32f435_437_tmr.h
  • TMR_TRIGGER_DMA_REQUEST : at32f435_437_tmr.h
  • TMR_TRIGGER_SWTRIG : at32f435_437_tmr.h
  • TMR_WP_LEVEL_1 : at32f435_437_tmr.h
  • TMR_WP_LEVEL_2 : at32f435_437_tmr.h
  • TMR_WP_LEVEL_3 : at32f435_437_tmr.h
  • TMR_WP_OFF : at32f435_437_tmr.h
  • TRUE : at32f435_437.h


AT32F435/437 Firmwary Library: Globals

- u -

  • UART4_IRQn : at32f435_437.h
  • UART5_IRQn : at32f435_437.h
  • UART7_IRQn : at32f435_437.h
  • UART8_IRQn : at32f435_437.h
  • UPDATE_CLEAR_FLAG : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • UPDATE_DONE : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • UPDATE_ING : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • UPDATE_PRE : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • UPGRADE_DONE : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • UPGRADE_FAILED : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • UPGRADE_JUMP : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • UPGRADE_LARGE : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • UPGRADE_READY : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • UPGRADE_SUCCESS : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • UPGRADE_UNKNOWN : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • UPGRAGE_ONGOING : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • UsageFault_IRQn : at32f435_437.h
  • USART1_IRQn : at32f435_437.h
  • USART2_IRQn : at32f435_437.h
  • USART3_IRQn : at32f435_437.h
  • USART6_IRQn : at32f435_437.h
  • USART_BREAK_10BITS : at32f435_437_usart.h
  • USART_BREAK_11BITS : at32f435_437_usart.h
  • USART_CLOCK_LAST_BIT_NONE : at32f435_437_usart.h
  • USART_CLOCK_LAST_BIT_OUTPUT : at32f435_437_usart.h
  • USART_CLOCK_PHASE_1EDGE : at32f435_437_usart.h
  • USART_CLOCK_PHASE_2EDGE : at32f435_437_usart.h
  • USART_CLOCK_POLARITY_HIGH : at32f435_437_usart.h
  • USART_CLOCK_POLARITY_LOW : at32f435_437_usart.h
  • USART_DATA_7BITS : at32f435_437_usart.h
  • USART_DATA_8BITS : at32f435_437_usart.h
  • USART_DATA_9BITS : at32f435_437_usart.h
  • USART_DE_POLARITY_HIGH : at32f435_437_usart.h
  • USART_DE_POLARITY_LOW : at32f435_437_usart.h
  • USART_HARDWARE_FLOW_CTS : at32f435_437_usart.h
  • USART_HARDWARE_FLOW_NONE : at32f435_437_usart.h
  • USART_HARDWARE_FLOW_RTS : at32f435_437_usart.h
  • USART_HARDWARE_FLOW_RTS_CTS : at32f435_437_usart.h
  • USART_ID_FIXED_4_BIT : at32f435_437_usart.h
  • USART_ID_RELATED_DATA_BIT : at32f435_437_usart.h
  • USART_PARITY_EVEN : at32f435_437_usart.h
  • USART_PARITY_NONE : at32f435_437_usart.h
  • USART_PARITY_ODD : at32f435_437_usart.h
  • USART_STOP_0_5_BIT : at32f435_437_usart.h
  • USART_STOP_1_5_BIT : at32f435_437_usart.h
  • USART_STOP_1_BIT : at32f435_437_usart.h
  • USART_STOP_2_BIT : at32f435_437_usart.h
  • USART_WAKEUP_BY_IDLE_FRAME : at32f435_437_usart.h
  • USART_WAKEUP_BY_MATCHING_ID : at32f435_437_usart.h
  • USB_CLK_HEXT : at32f435_437_usb.h
  • USB_CLK_HICK : at32f435_437_usb.h
  • USB_CONN_STATE_ADDRESSED : usb_std.h
  • USB_CONN_STATE_CONFIGURED : usb_std.h
  • USB_CONN_STATE_DEFAULT : usb_std.h
  • USB_CONN_STATE_SUSPENDED : usb_std.h
  • USB_EPT0 : at32f435_437_usb.h
  • USB_EPT1 : at32f435_437_usb.h
  • USB_EPT2 : at32f435_437_usb.h
  • USB_EPT3 : at32f435_437_usb.h
  • USB_EPT4 : at32f435_437_usb.h
  • USB_EPT5 : at32f435_437_usb.h
  • USB_EPT6 : at32f435_437_usb.h
  • USB_EPT7 : at32f435_437_usb.h
  • USB_ERROR : usb_std.h
  • USB_FAIL : usb_std.h
  • USB_FULL_SPEED_CORE_ID : usb_core.h
  • USB_HID_BUSY : usbh_hid_class.h
  • USB_HID_ERROR : usbh_hid_class.h
  • USB_HID_GET : usbh_hid_class.h
  • USB_HID_INIT : usbh_hid_class.h
  • USB_HID_POLL : usbh_hid_class.h
  • USB_HID_SEND : usbh_hid_class.h
  • USB_HID_STATE_COMPLETE : usbh_hid_class.h
  • USB_HID_STATE_GET_DESC : usbh_hid_class.h
  • USB_HID_STATE_GET_REPORT : usbh_hid_class.h
  • USB_HID_STATE_IDLE : usbh_hid_class.h
  • USB_HID_STATE_SET_IDLE : usbh_hid_class.h
  • USB_HID_STATE_SET_PROTOCOL : usbh_hid_class.h
  • USB_HIGH_SPEED_CORE_ID : usb_core.h
  • USB_LOW_SPEED_CORE_ID : usb_core.h
  • USB_NOT_SUPPORT : usb_std.h
  • USB_OK : usb_std.h
  • USB_OTG1_ID : at32f435_437_usb.h
  • USB_OTG2_ID : at32f435_437_usb.h
  • USB_WAIT : usb_std.h
  • USBH_MSC_BUSY : usbh_msc_bot_scsi.h
  • USBH_MSC_ERROR : usbh_msc_bot_scsi.h
  • USBH_MSC_IDLE : usbh_msc_bot_scsi.h
  • USBH_MSC_INIT : usbh_msc_bot_scsi.h
  • USBH_MSC_INQUIRY : usbh_msc_bot_scsi.h
  • USBH_MSC_READ10 : usbh_msc_bot_scsi.h
  • USBH_MSC_READ_CAPACITY10 : usbh_msc_bot_scsi.h
  • USBH_MSC_REQUEST_SENSE : usbh_msc_bot_scsi.h
  • USBH_MSC_STATE_COMPLETE : usbh_msc_class.h
  • USBH_MSC_STATE_ERROR : usbh_msc_class.h
  • USBH_MSC_STATE_GET_LUN : usbh_msc_class.h
  • USBH_MSC_STATE_IDLE : usbh_msc_class.h
  • USBH_MSC_TEST_UNIT_READY : usbh_msc_bot_scsi.h
  • USBH_MSC_WRITE : usbh_msc_bot_scsi.h
  • USER_BUTTON : at32f435_437_board.h
  • USR_APP : at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • USR_FINISH : at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • USR_IDLE : at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c


AT32F435/437 Firmwary Library: Globals

- w -

  • WDT_CLK_DIV_128 : at32f435_437_wdt.h
  • WDT_CLK_DIV_16 : at32f435_437_wdt.h
  • WDT_CLK_DIV_256 : at32f435_437_wdt.h
  • WDT_CLK_DIV_32 : at32f435_437_wdt.h
  • WDT_CLK_DIV_4 : at32f435_437_wdt.h
  • WDT_CLK_DIV_64 : at32f435_437_wdt.h
  • WDT_CLK_DIV_8 : at32f435_437_wdt.h
  • WDT_CMD_ENABLE : at32f435_437_wdt.h
  • WDT_CMD_LOCK : at32f435_437_wdt.h
  • WDT_CMD_RELOAD : at32f435_437_wdt.h
  • WDT_CMD_UNLOCK : at32f435_437_wdt.h
  • WWDT_IRQn : at32f435_437.h
  • WWDT_PCLK1_DIV_16384 : at32f435_437_wwdt.h
  • WWDT_PCLK1_DIV_32768 : at32f435_437_wwdt.h
  • WWDT_PCLK1_DIV_4096 : at32f435_437_wwdt.h
  • WWDT_PCLK1_DIV_8192 : at32f435_437_wwdt.h


AT32F435/437 Firmwary Library: Globals

- x -

  • XMC_ACCESS_MODE_A : at32f435_437_xmc.h
  • XMC_ACCESS_MODE_B : at32f435_437_xmc.h
  • XMC_ACCESS_MODE_C : at32f435_437_xmc.h
  • XMC_ACCESS_MODE_D : at32f435_437_xmc.h
  • XMC_ASYN_WAIT_DISABLE : at32f435_437_xmc.h
  • XMC_ASYN_WAIT_ENABLE : at32f435_437_xmc.h
  • XMC_BANK1_NOR_SRAM1 : at32f435_437_xmc.h
  • XMC_BANK1_NOR_SRAM2 : at32f435_437_xmc.h
  • XMC_BANK1_NOR_SRAM3 : at32f435_437_xmc.h
  • XMC_BANK1_NOR_SRAM4 : at32f435_437_xmc.h
  • XMC_BANK2_NAND : at32f435_437_xmc.h
  • XMC_BANK3_NAND : at32f435_437_xmc.h
  • XMC_BANK4_PCCARD : at32f435_437_xmc.h
  • XMC_BANK5_6_SDRAM : at32f435_437_xmc.h
  • XMC_BURST_MODE_DISABLE : at32f435_437_xmc.h
  • XMC_BURST_MODE_ENABLE : at32f435_437_xmc.h
  • XMC_BUSTYPE_16_BITS : at32f435_437_xmc.h
  • XMC_BUSTYPE_8_BITS : at32f435_437_xmc.h
  • XMC_BUSY_FLAG : at32f435_437_xmc.h
  • XMC_CAS_1 : at32f435_437_xmc.h
  • XMC_CAS_2 : at32f435_437_xmc.h
  • XMC_CAS_3 : at32f435_437_xmc.h
  • XMC_CLKDIV_2 : at32f435_437_xmc.h
  • XMC_CLKDIV_3 : at32f435_437_xmc.h
  • XMC_CLKDIV_4 : at32f435_437_xmc.h
  • XMC_CMD_AUTO_REFRESH : at32f435_437_xmc.h
  • XMC_CMD_BANK1 : at32f435_437_xmc.h
  • XMC_CMD_BANK1_2 : at32f435_437_xmc.h
  • XMC_CMD_BANK2 : at32f435_437_xmc.h
  • XMC_CMD_CLK : at32f435_437_xmc.h
  • XMC_CMD_LOAD_MODE : at32f435_437_xmc.h
  • XMC_CMD_NORMAL : at32f435_437_xmc.h
  • XMC_CMD_POWER_DOWN : at32f435_437_xmc.h
  • XMC_CMD_PRECHARG_ALL : at32f435_437_xmc.h
  • XMC_CMD_SELF_REFRESH : at32f435_437_xmc.h
  • XMC_COLUMN_10 : at32f435_437_xmc.h
  • XMC_COLUMN_11 : at32f435_437_xmc.h
  • XMC_COLUMN_8 : at32f435_437_xmc.h
  • XMC_COLUMN_9 : at32f435_437_xmc.h
  • XMC_DATA_ADDR_MUX_DISABLE : at32f435_437_xmc.h
  • XMC_DATA_ADDR_MUX_ENABLE : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_1 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_10 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_11 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_12 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_13 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_14 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_15 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_16 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_2 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_3 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_4 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_5 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_6 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_7 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_8 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_9 : at32f435_437_xmc.h
  • XMC_DEVICE_NOR : at32f435_437_xmc.h
  • XMC_DEVICE_PSRAM : at32f435_437_xmc.h
  • XMC_DEVICE_SRAM : at32f435_437_xmc.h
  • XMC_ECC_OPERATION_DISABLE : at32f435_437_xmc.h
  • XMC_ECC_OPERATION_ENABLE : at32f435_437_xmc.h
  • XMC_ECC_PAGESIZE_1024_BYTES : at32f435_437_xmc.h
  • XMC_ECC_PAGESIZE_2048_BYTES : at32f435_437_xmc.h
  • XMC_ECC_PAGESIZE_256_BYTES : at32f435_437_xmc.h
  • XMC_ECC_PAGESIZE_4096_BYTES : at32f435_437_xmc.h
  • XMC_ECC_PAGESIZE_512_BYTES : at32f435_437_xmc.h
  • XMC_ECC_PAGESIZE_8192_BYTES : at32f435_437_xmc.h
  • XMC_ERR_FLAG : at32f435_437_xmc.h
  • XMC_FALLINGEDGE_FLAG : at32f435_437_xmc.h
  • XMC_FEMPT_FLAG : at32f435_437_xmc.h
  • XMC_INBK_2 : at32f435_437_xmc.h
  • XMC_INBK_4 : at32f435_437_xmc.h
  • XMC_INT_ERR : at32f435_437_xmc.h
  • XMC_INT_FALLING_EDGE : at32f435_437_xmc.h
  • XMC_INT_LEVEL : at32f435_437_xmc.h
  • XMC_INT_RISING_EDGE : at32f435_437_xmc.h
  • XMC_IRQn : at32f435_437.h
  • XMC_LEVEL_FLAG : at32f435_437_xmc.h
  • XMC_MEM_WIDTH_16 : at32f435_437_xmc.h
  • XMC_MEM_WIDTH_8 : at32f435_437_xmc.h
  • XMC_NO_CLK : at32f435_437_xmc.h
  • XMC_READ_DELAY_0 : at32f435_437_xmc.h
  • XMC_READ_DELAY_1 : at32f435_437_xmc.h
  • XMC_READ_DELAY_2 : at32f435_437_xmc.h
  • XMC_RISINGEDGE_FLAG : at32f435_437_xmc.h
  • XMC_ROW_11 : at32f435_437_xmc.h
  • XMC_ROW_12 : at32f435_437_xmc.h
  • XMC_ROW_13 : at32f435_437_xmc.h
  • XMC_SDRAM_BANK1 : at32f435_437_xmc.h
  • XMC_SDRAM_BANK2 : at32f435_437_xmc.h
  • XMC_STATUS_MASK : at32f435_437_xmc.h
  • XMC_STATUS_NORMAL : at32f435_437_xmc.h
  • XMC_STATUS_POWER_DOWN : at32f435_437_xmc.h
  • XMC_STATUS_SELF_REFRESH : at32f435_437_xmc.h
  • XMC_WAIT_OPERATION_DISABLE : at32f435_437_xmc.h
  • XMC_WAIT_OPERATION_ENABLE : at32f435_437_xmc.h
  • XMC_WAIT_SIGNAL_DISABLE : at32f435_437_xmc.h
  • XMC_WAIT_SIGNAL_ENABLE : at32f435_437_xmc.h
  • XMC_WAIT_SIGNAL_LEVEL_HIGH : at32f435_437_xmc.h
  • XMC_WAIT_SIGNAL_LEVEL_LOW : at32f435_437_xmc.h
  • XMC_WAIT_SIGNAL_SYN_BEFORE : at32f435_437_xmc.h
  • XMC_WAIT_SIGNAL_SYN_DURING : at32f435_437_xmc.h
  • XMC_WRAPPED_MODE_DISABLE : at32f435_437_xmc.h
  • XMC_WRAPPED_MODE_ENABLE : at32f435_437_xmc.h
  • XMC_WRITE_BURST_SYN_DISABLE : at32f435_437_xmc.h
  • XMC_WRITE_BURST_SYN_ENABLE : at32f435_437_xmc.h
  • XMC_WRITE_OPERATION_DISABLE : at32f435_437_xmc.h
  • XMC_WRITE_OPERATION_ENABLE : at32f435_437_xmc.h
  • XMC_WRITE_TIMING_DISABLE : at32f435_437_xmc.h
  • XMC_WRITE_TIMING_ENABLE : at32f435_437_xmc.h


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- f -

  • fac_ms : at32f435_437_board.c
  • fac_us : at32f435_437_board.c
  • FALSE : at32f435_437.h
  • FAP_RELIEVE_KEY : at32f435_437_flash.h
  • FAST : project/at_start_f435/templates/src/main.c, project/at_start_f437/examples/emac/dns_client/src/main.c, project/at_start_f437/examples/emac/http_server/src/main.c, project/at_start_f437/examples/emac/iperf/src/main.c, project/at_start_f437/examples/emac/mqtt_client/src/main.c, project/at_start_f437/examples/emac/tcp_client/src/main.c, project/at_start_f437/examples/emac/tcp_server/src/main.c, project/at_start_f437/examples/emac/telnet/src/main.c, project/at_start_f437/examples/emac/wake_on_lan/src/main.c, project/at_start_f437/templates/src/main.c
  • FAT16_BYTE_PER_SIZE : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FAT16_DIR_SIZE : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • fat16_file_name : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c, at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • FAT16_FILENAME_SIZE : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • fat16_memory_cmp() : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • fat16_memory_copy() : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • fat16_memory_memset() : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • fat16_root_dir_sector : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c, at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • fat16_sector : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c, at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • FAT16_SECTOR_SIZE : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • fat16_table_sector0 : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c, at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • FAT16_TABLE_SIZE : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • fatfs_test() : project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f437/examples/sdio/sdio_fatfs/src/main.c
  • FEEDBACK_REFRESH_TIME : audio_class.h, audio_hid_class.h
  • FF_CODE_PAGE : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_FS_EXFAT : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_FS_LOCK : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_FS_MINIMIZE : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_FS_NOFSINFO : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_FS_NORTC : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_FS_READONLY : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_FS_REENTRANT : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_FS_RPATH : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_FS_TIMEOUT : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_FS_TINY : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_LBA64 : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_LFN_BUF : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_LFN_UNICODE : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_MAX_LFN : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_MAX_SS : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_MIN_GPT : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_MIN_SS : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_MULTI_PARTITION : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_NORTC_MDAY : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_NORTC_MON : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_NORTC_YEAR : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_PRINT_FLOAT : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_PRINT_LLI : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_SFN_BUF : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_STR_VOLUME_ID : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_STRF_ENCODE : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_SYNC_t : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_USE_CHMOD : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_USE_EXPAND : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_USE_FASTSEEK : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_USE_FIND : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_USE_FORWARD : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_USE_LABEL : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_USE_LFN : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_USE_MKFS : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_USE_STRFUNC : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_USE_TRIM : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_VOLUME_STRS : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FF_VOLUMES : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • FFCONF_DEF : at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f435/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f435/examples/usb_host/two_otg_host_demo/inc/ffconf.h, at_start_f437/examples/sdio/sdio_fatfs/inc/ffconf.h, at_start_f437/examples/usb_host/msc_only_fat32/inc/ffconf.h, at_start_f437/examples/usb_host/two_otg_host_demo/inc/ffconf.h
  • file : project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, project/at_start_f437/examples/sdio/sdio_fatfs/src/main.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • file__404_html : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • file__img_sics_gif : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • file_AT32F437_html : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • file_AT32F437ADC_html : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • file_AT32F437LED_html : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • file_index_html : utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/fsdata.c
  • file_match : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c, at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • file_NULL : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • file_reset_html : utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/fsdata.c
  • FILE_SUFFIX1_LEN : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FILE_SUFFIX1_NAME : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FILE_SUFFIX2_LEN : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FILE_SUFFIX2_NAME : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • file_upload_html : utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/fsdata.c
  • file_uploaddone_html : utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/fsdata.c
  • file_write_nr : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c, at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • fill_buffer() : project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c, at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f435/examples/xmc/psram/inc/xmc_psram.h, at_start_f435/examples/xmc/psram/src/xmc_psram.c, at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c, at_start_f435/examples/xmc/sram/inc/xmc_sram.h, at_start_f435/examples/xmc/sram/src/xmc_sram.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f437/examples/xmc/psram/inc/xmc_psram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sram/inc/xmc_sram.h
  • FILTER_EXT_ID1 : project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f437/examples/can/filter/src/main.c
  • FILTER_EXT_ID2 : project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f437/examples/can/filter/src/main.c
  • FILTER_EXT_ID3 : project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f437/examples/can/filter/src/main.c
  • FILTER_STD_ID1 : project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f437/examples/can/filter/src/main.c
  • FILTER_STD_ID2 : project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f437/examples/can/filter/src/main.c
  • FILTER_STD_ID3 : project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f437/examples/can/filter/src/main.c
  • FIR_lowpass_filter() : project_l0/inc/fir_filter.h, fir_filter.c, project_l1/inc/fir_filter.h
  • firCoeffs32 : fir_coefficient.c, fir_filter.c
  • firStateF32 : fir_filter.c
  • Fl2FlashChecksumEntry() : flash_loader.c
  • Fl2FlashEraseWriteEntry() : flash_loader.c
  • Fl2FlashInitEntry() : flash_loader.c
  • Fl2FlashSignoffEntry() : flash_loader.c
  • Fl2FlashWriteEntry() : flash_loader.c
  • FLAG_ERASE_ONLY : flash_loader.h
  • flag_status : at32f435_437.h
  • FLASH : at32f435_437_flash.h
  • flash_2kb_write() : utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/flash.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/src/flash.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/flash.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/flash.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/flash.c
  • FLASH_APP_ADDRESS : app_led3_toggle/inc/hid_iap_user.h, app_led4_toggle/inc/hid_iap_user.h, bootloader/inc/hid_iap_user.h
  • FLASH_APP_START_ADDR : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FLASH_BANK1_END_ADDR : at32f435_437_flash.h
  • FLASH_BANK1_EPPERR_FLAG : at32f435_437_flash.h
  • flash_bank1_erase() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_BANK1_ERR_INT : at32f435_437_flash.h
  • flash_bank1_lock() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_BANK1_OBF_FLAG : at32f435_437_flash.h
  • FLASH_BANK1_ODF_FLAG : at32f435_437_flash.h
  • FLASH_BANK1_ODF_INT : at32f435_437_flash.h
  • flash_bank1_operation_status_get() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_bank1_operation_wait_for() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_BANK1_PRGMERR_FLAG : at32f435_437_flash.h
  • FLASH_BANK1_START_ADDR : at32f435_437_flash.h
  • flash_bank1_unlock() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_BANK2_END_ADDR : at32f435_437_flash.h
  • FLASH_BANK2_EPPERR_FLAG : at32f435_437_flash.h
  • flash_bank2_erase() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_BANK2_ERR_INT : at32f435_437_flash.h
  • flash_bank2_lock() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_BANK2_OBF_FLAG : at32f435_437_flash.h
  • FLASH_BANK2_ODF_FLAG : at32f435_437_flash.h
  • FLASH_BANK2_ODF_INT : at32f435_437_flash.h
  • flash_bank2_operation_status_get() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_bank2_operation_wait_for() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_BANK2_PRGMERR_FLAG : at32f435_437_flash.h
  • FLASH_BANK2_START_ADDR : at32f435_437_flash.h
  • flash_bank2_unlock() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_BASE : at32f435_437.h
  • flash_block_erase() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_BOOT_FROM_BANK1 : at32f435_437_flash.h
  • FLASH_BOOT_FROM_BANK2 : at32f435_437_flash.h
  • flash_buf : project/at_start_f435/examples/flash/flash_write_read/src/flash.c, project/at_start_f437/examples/flash/flash_write_read/src/flash.c
  • flash_byte_program() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_CLOCK_DIV_2 : at32f435_437_flash.h
  • FLASH_CLOCK_DIV_3 : at32f435_437_flash.h
  • FLASH_CLOCK_DIV_4 : at32f435_437_flash.h
  • flash_clock_divider_set : at32f435_437_flash.h
  • flash_clock_divider_type : at32f435_437_flash.h
  • flash_continue_read_enable() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_crc_calibrate() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_crc_check() : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • FLASH_CS_HIGH : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • FLASH_CS_LOW : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • FLASH_DRV_VERS : FlashOS.h
  • flash_eopb0_config() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_EOPB0_SRAM_128K : at32f435_437_flash.h
  • FLASH_EOPB0_SRAM_192K : at32f435_437_flash.h
  • FLASH_EOPB0_SRAM_256K : at32f435_437_flash.h
  • FLASH_EOPB0_SRAM_320K : at32f435_437_flash.h
  • FLASH_EOPB0_SRAM_384K : at32f435_437_flash.h
  • FLASH_EOPB0_SRAM_448K : at32f435_437_flash.h
  • FLASH_EOPB0_SRAM_512K : at32f435_437_flash.h
  • FLASH_EPP_ERROR : at32f435_437_flash.h
  • flash_epp_set() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_epp_status_get() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_EPPERR_FLAG : at32f435_437_flash.h
  • FLASH_ERR_INT : at32f435_437_flash.h
  • flash_fap_enable() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_fap_status_get() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_FAT16_1_ADDR : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FLASH_FAT16_2_ADDR : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • flash_fat16_addr_offset() : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • flash_fat16_boot_dir_write() : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • FLASH_FAT16_BOOT_SECTOR_ADDR : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • flash_fat16_clear_upgrade_flag() : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • FLASH_FAT16_FILE_START_ADDR : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • flash_fat16_get_upgrade_flag() : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • flash_fat16_init() : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • flash_fat16_loop_status() : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c
  • flash_fat16_read() : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • FLASH_FAT16_ROOT_ADDR : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • flash_fat16_sector_write() : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • flash_fat16_set_name() : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • flash_fat16_set_upgrade_flag() : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • flash_fat16_write() : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • flash_flag_clear() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_flag_get() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_halfword_program() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_iap : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • flash_if_write() : utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/flash.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/flash.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/flash.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/flash.c
  • flash_internal_all_erase() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_interrupt_enable() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_IRQHandler() : utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c
  • FLASH_IRQn : at32f435_437.h
  • flash_lock() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • flash_nzw_boost_enable() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_OBF_FLAG : at32f435_437_flash.h
  • FLASH_ODF_FLAG : at32f435_437_flash.h
  • FLASH_ODF_INT : at32f435_437_flash.h
  • FLASH_OPERATE_BUSY : at32f435_437_flash.h
  • FLASH_OPERATE_DONE : at32f435_437_flash.h
  • FLASH_OPERATE_TIMEOUT : at32f435_437_flash.h
  • flash_operation_status_get() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_operation_wait_for() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_PAGE_PROGRAM_SIZE : at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c, qspi_algorithm.c
  • FLASH_PRGMERR_FLAG : at32f435_437_flash.h
  • FLASH_PROGRAM_ERROR : at32f435_437_flash.h
  • flash_read() : project/at_start_f435/examples/flash/flash_write_read/inc/flash.h, project/at_start_f435/examples/flash/flash_write_read/src/flash.c
  • flash_read_data() : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • FLASH_REG_BASE : at32f435_437.h
  • FLASH_SECTOR_1K_ALLGNED : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FLASH_SECTOR_1K_SIZE : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FLASH_SECTOR_2K_ALLGNED : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FLASH_SECTOR_2K_SIZE : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FLASH_SECTOR_4K_ALLGNED : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • FLASH_SECTOR_4K_SIZE : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • flash_sector_erase() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_SECTOR_SIZE : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • FLASH_SIZE : utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/flash.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/flash.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/flash.h
  • FLASH_SIZE_REG : hid_iap_class.h
  • flash_slib_disable() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_slib_enable() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_SLIB_END_SECTOR : at32f435_437_flash.h
  • flash_slib_end_sector_get() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_SLIB_INST_START_SECTOR : at32f435_437_flash.h
  • flash_slib_inststart_sector_get() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_slib_remaining_count_get() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_SLIB_START_SECTOR : at32f435_437_flash.h
  • flash_slib_start_sector_get() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_slib_state_get() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_SPI_DUMMY_BYTE : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • flash_ssb_set() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_ssb_status_get() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_START_ADDR : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • flash_status_type : at32f435_437_flash.h
  • FLASH_TEST_ADDR : project/at_start_f435/examples/spi/w25q_flash/src/main.c, project/at_start_f437/examples/spi/w25q_flash/src/main.c
  • flash_unlock() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_UNLOCK_KEY1 : at32f435_437_flash.h
  • FLASH_UNLOCK_KEY2 : at32f435_437_flash.h
  • flash_upgrade_flag_read() : utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/flash.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/src/flash.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/flash.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/flash.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/flash.c
  • flash_usd_eopb0_type : at32f435_437_flash.h
  • FLASH_USDERR_FLAG : at32f435_437_flash.h
  • flash_user_system_data_erase() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_user_system_data_program() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_word_program() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_write() : project/at_start_f435/examples/flash/flash_write_read/inc/flash.h, project/at_start_f435/examples/flash/flash_write_read/src/flash.c
  • flash_write_data() : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • flash_write_nocheck() : project/at_start_f435/examples/flash/flash_write_read/inc/flash.h, project/at_start_f435/examples/flash/flash_write_read/src/flash.c
  • FlashBreak() : flash_loader.c
  • FlashBufferEnd : flash_loader_extra.h
  • FlashBufferStart : flash_loader_extra.h
  • FlashChecksum() : flash_loader.c, flash_loader.h, flash_loader_ram.c
  • FlashChecksumEntry() : flash_loader.h
  • FlashDevice : FlashDev.c
  • FlashErase() : flash_loader.h, flash_loader_ram.c, qspi_algorithm.c
  • FlashInit() : flash_loader.h, flash_loader_ram.c, qspi_algorithm.c
  • FlashSignoff() : flash_loader.c, flash_loader.h, flash_loader_ram.c, qspi_algorithm.c
  • FlashSignoffEntry() : flash_loader.h
  • FlashWrite() : flash_loader.h, flash_loader_ram.c, qspi_algorithm.c
  • FPU_IRQn : at32f435_437.h
  • fputc() : at32f435_437_board.c
  • freq_result : project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c
  • frequency : project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input/src/main.c, project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f437/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/pwm_input/src/main.c, project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c
  • fs : project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, project/at_start_f437/examples/sdio/sdio_fatfs/src/main.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • fs_bytes_left() : fs.c
  • fs_close() : fs.c
  • FS_FILE_FLAGS_HEADER_INCLUDED : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • FS_FILE_FLAGS_HEADER_PERSISTENT : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • FS_NUMFILES : project/at_start_f437/examples/emac/http_server/src/fsdata.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h
  • fs_open() : fs.c
  • FS_ROOT : project/at_start_f437/examples/emac/http_server/src/fsdata.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h
  • FSDATA_ALIGN_POST : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • FSDATA_ALIGN_PRE : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • FSDATA_FILE_ALIGNMENT : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • FZC_TIMEOUT : at32f435_437_can.h


AT32F435/437 Firmwary Library: Globals

- _ -

  • __ALIGNED() : project/at_start_f435/examples/edma/link_list_mode/src/main.c


AT32F435/437 Firmwary Library: Globals

- a -

  • acc_calibration_mode_enable() : at32f435_437_acc.h, at32f435_437_acc.c
  • acc_flag_clear() : at32f435_437_acc.h, at32f435_437_acc.c
  • acc_flag_get() : at32f435_437_acc.h, at32f435_437_acc.c
  • acc_hickcal_get() : at32f435_437_acc.h, at32f435_437_acc.c
  • acc_hicktrim_get() : at32f435_437_acc.h, at32f435_437_acc.c
  • acc_interrupt_enable() : at32f435_437_acc.h, at32f435_437_acc.c
  • ACC_IRQHandler() : project/at_start_f435/examples/acc/calibration/src/main.c
  • acc_read_c1() : at32f435_437_acc.h, at32f435_437_acc.c
  • acc_read_c2() : at32f435_437_acc.h, at32f435_437_acc.c
  • acc_read_c3() : at32f435_437_acc.h, at32f435_437_acc.c
  • acc_sof_select() : at32f435_437_acc.h, at32f435_437_acc.c
  • acc_step_set() : at32f435_437_acc.h, at32f435_437_acc.c
  • acc_write_c1() : at32f435_437_acc.h, at32f435_437_acc.c
  • acc_write_c2() : at32f435_437_acc.h, at32f435_437_acc.c
  • acc_write_c3() : at32f435_437_acc.h, at32f435_437_acc.c
  • ADC1_2_3_IRQHandler() : project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c, project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c
  • adc_base_config() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_base_default_para_init() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_calibration_init() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_calibration_init_status_get() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_calibration_start() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_calibration_status_get() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_calibration_value_set() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_combine_ordinary_conversion_data_get() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_common_config() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_common_default_para_init() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_config() : project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c, project/at_start_f435/examples/adc/conversion_abort/src/main.c, project/at_start_f435/examples/adc/current_vref_value_check/src/main.c, project/at_start_f435/examples/adc/edma_double_buffer/src/main.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f435/examples/adc/resolution_6bit/src/main.c, project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c, project/at_start_f435/examples/adc/vbat_monitor/src/main.c, project/at_start_f435/examples/adc/voltage_monitoring/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c, project/at_start_f437/examples/adc/conversion_abort/src/main.c, project/at_start_f437/examples/adc/current_vref_value_check/src/main.c, project/at_start_f437/examples/adc/edma_double_buffer/src/main.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f437/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f437/examples/adc/resolution_6bit/src/main.c, project/at_start_f437/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f437/examples/adc/use_polling_get_conversion_data/src/main.c, project/at_start_f437/examples/adc/vbat_monitor/src/main.c, project/at_start_f437/examples/adc/voltage_monitoring/src/main.c
  • adc_configuration() : project/at_start_f437/examples/emac/http_server/src/main.c
  • adc_conversion_stop() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_conversion_stop_status_get() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_dma_mode_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_dma_request_repeat_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_flag_clear() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_flag_get() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_interrupt_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_occe_each_conversion_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_ordinary_channel_set() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_ordinary_conversion_data_get() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_ordinary_conversion_trigger_set() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_ordinary_oversample_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_ordinary_oversample_restart_set() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_ordinary_oversample_trig_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_ordinary_part_count_set() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_ordinary_part_mode_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_ordinary_software_trigger_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_ordinary_software_trigger_status_get() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_oversample_ratio_shift_set() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_preempt_auto_mode_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_preempt_channel_length_set() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_preempt_channel_set() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_preempt_conversion_data_get() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_preempt_conversion_trigger_set() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_preempt_offset_value_set() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_preempt_oversample_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_preempt_part_mode_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_preempt_software_trigger_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_preempt_software_trigger_status_get() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_reset() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_resolution_set() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_voltage_battery_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_voltage_monitor_enable() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_voltage_monitor_single_channel_select() : at32f435_437_adc.h, at32f435_437_adc.c
  • adc_voltage_monitor_threshold_value_set() : at32f435_437_adc.h, at32f435_437_adc.c
  • app_load() : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h, at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c, at32f437_emac_iap_demo/source_code/bootloader/src/iap.c
  • app_loop() : app_led3_toggle/inc/hid_iap_user.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c
  • app_update_handle() : at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
  • arm_apply_guard_bits() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_calc_2pow() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_calc_guard_bits() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_clip_f32() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_compare_fixed_q15() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_compare_fixed_q31() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_fir_f32() : project_l0/inc/fir_filter.h, project_l1/inc/fir_filter.h
  • arm_fir_init_f32() : project_l0/inc/fir_filter.h, arm_fir_init_f32.c, project_l1/inc/fir_filter.h
  • arm_float_to_q12_20() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_float_to_q14() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_float_to_q28() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_float_to_q29() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_float_to_q30() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_provide_guard_bits_q15() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_provide_guard_bits_q31() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_provide_guard_bits_q7() : project_l0/src/math_helper.c, project_l1/src/math_helper.c
  • arm_snr_f32() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • at32_board_init() : at32f435_437_board.c, at32f435_437_board.h
  • at32_button_init() : at32f435_437_board.c, at32f435_437_board.h
  • at32_button_press() : at32f435_437_board.c, at32f435_437_board.h
  • at32_button_state() : at32f435_437_board.c, at32f435_437_board.h
  • at32_led_init() : at32f435_437_board.c, at32f435_437_board.h
  • at32_led_off() : at32f435_437_board.c, at32f435_437_board.h
  • at32_led_on() : at32f435_437_board.c, at32f435_437_board.h
  • at32_led_toggle() : at32f435_437_board.c, at32f435_437_board.h
  • at32_mqtt_connection_cb() : mqtt_client.h, mqtt_client.c
  • at32_mqtt_incoming_data_cb() : mqtt_client.h, mqtt_client.c
  • at32_mqtt_incoming_publish_cb() : mqtt_client.h, mqtt_client.c
  • at32_mqtt_publish() : mqtt_client.h
  • at32_mqtt_request_cb() : mqtt_client.h, mqtt_client.c
  • at32_mqtt_subscribe() : mqtt_client.h, mqtt_client.c
  • audio_codec_init() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_loop() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_mic_alt_setting() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_mic_get_data() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_modify_freq() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_set_mic_freq() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_set_mic_mute() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_set_mic_volume() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_set_spk_freq() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_set_spk_mute() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_set_spk_volume() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_spk_alt_setting() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_spk_feedback() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_codec_spk_fifo_write() : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_get_interface() : audio_class.c, audio_hid_class.c
  • audio_hid_class_send_report() : audio_hid_class.c, audio_hid_class.h
  • audio_inisoincom_event() : audio_class.c, audio_hid_class.c
  • audio_req_get_cur() : audio_class.c, audio_hid_class.c
  • audio_req_get_max() : audio_class.c, audio_hid_class.c
  • audio_req_get_min() : audio_class.c, audio_hid_class.c
  • audio_req_get_res() : audio_class.c, audio_hid_class.c
  • audio_req_set_cur() : audio_class.c, audio_hid_class.c
  • audio_set_interface() : audio_class.c, audio_hid_class.c


AT32F435/437 Firmwary Library: Globals

- b -

  • back_err() : app_led3_toggle/inc/usart.h, app_led3_toggle/src/usart.c, app_led4_toggle/src/usart.c, at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h, at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
  • back_ok() : app_led3_toggle/inc/usart.h, app_led3_toggle/src/usart.c, app_led4_toggle/src/usart.c, at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h, at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
  • BlankCheck() : FlashOS.h
  • bot_cbw_decode() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_allow_medium_removal() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_capacity() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_check_address() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_clear_feature() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_cmd_process() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_datain_handler() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_dataout_handler() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_format_capacity() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_init() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_inquiry() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_mode_sense10() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_mode_sense6() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_read10() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_request_sense() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_reset() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_send_csw() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_send_data() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_sense_code() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_stall() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_start_stop() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_test_unit() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_verify() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_write10() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bpr_reg_check() : project/at_start_f435/examples/ertc/bpr_domain/src/main.c, project/at_start_f435/examples/ertc/tamper/src/main.c
  • bpr_reg_write() : project/at_start_f435/examples/ertc/bpr_domain/src/main.c, project/at_start_f435/examples/ertc/tamper/src/main.c
  • buffer_compare() : project/at_start_f435/examples/dma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c, project/at_start_f435/examples/flash/flash_write_read/src/main.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f435/examples/spi/w25q_flash/src/main.c, project/at_start_f435/examples/usart/half_duplex/src/main.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c
  • buffer_compare_24bits() : project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c
  • BusFault_Handler() : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c, project/at_start_f435/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f435/examples/can/filter/src/at32f435_437_int.c, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c, project/at_start_f435/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c, project/at_start_f435/templates/inc/at32f435_437_int.h, project/at_start_f435/templates/src/at32f435_437_int.c, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f437/templates/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/src/at32f435_437_int.c, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_int.h, utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_int.c
  • button_exint_init() : project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f435/examples/usb_device/keyboard/src/main.c, project/at_start_f435/examples/usb_device/mouse/src/main.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c, project/at_start_f435/examples/usb_host/hid_demo/src/main.c, project/at_start_f435/templates/src/main.c
  • button_isr() : project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c, project/at_start_f435/examples/usb_host/hid_demo/src/main.c, project/at_start_f435/templates/src/main.c


AT32F435/437 Firmwary Library: Globals

- c -

  • CAN1_RX0_IRQHandler() : project/at_start_f435/examples/can/communication_mode/src/main.c, project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f435/examples/can/loopback_mode/src/main.c
  • CAN1_SE_IRQHandler() : project/at_start_f435/examples/can/communication_mode/src/main.c, project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f435/examples/can/loopback_mode/src/main.c
  • can_base_init() : at32f435_437_can.h, at32f435_437_can.c
  • can_baudrate_default_para_init() : at32f435_437_can.h, at32f435_437_can.c
  • can_baudrate_set() : at32f435_437_can.h, at32f435_437_can.c
  • can_configuration() : project/at_start_f435/examples/can/communication_mode/src/main.c, project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f435/examples/can/loopback_mode/src/main.c, project/at_start_f437/examples/can/communication_mode/src/main.c, project/at_start_f437/examples/can/filter/src/main.c, project/at_start_f437/examples/can/loopback_mode/src/main.c
  • can_debug_transmission_prohibit() : at32f435_437_can.h, at32f435_437_can.c
  • can_default_para_init() : at32f435_437_can.h, at32f435_437_can.c
  • can_doze_mode_enter() : at32f435_437_can.h, at32f435_437_can.c
  • can_doze_mode_exit() : at32f435_437_can.h, at32f435_437_can.c
  • can_error_type_record_get() : at32f435_437_can.h, at32f435_437_can.c
  • can_filter_default_para_init() : at32f435_437_can.h, at32f435_437_can.c
  • can_filter_init() : at32f435_437_can.h, at32f435_437_can.c
  • can_flag_clear() : at32f435_437_can.h, at32f435_437_can.c
  • can_flag_get() : at32f435_437_can.h, at32f435_437_can.c
  • can_gpio_config() : project/at_start_f435/examples/can/communication_mode/src/main.c, project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f435/examples/can/loopback_mode/src/main.c, project/at_start_f437/examples/can/communication_mode/src/main.c, project/at_start_f437/examples/can/filter/src/main.c, project/at_start_f437/examples/can/loopback_mode/src/main.c
  • can_interrupt_enable() : at32f435_437_can.h, at32f435_437_can.c
  • can_message_receive() : at32f435_437_can.h, at32f435_437_can.c
  • can_message_transmit() : at32f435_437_can.h, at32f435_437_can.c
  • can_operating_mode_set() : at32f435_437_can.h, at32f435_437_can.c
  • can_receive_error_counter_get() : at32f435_437_can.h, at32f435_437_can.c
  • can_receive_fifo_release() : at32f435_437_can.h, at32f435_437_can.c
  • can_receive_message_pending_get() : at32f435_437_can.h, at32f435_437_can.c
  • can_reset() : at32f435_437_can.h, at32f435_437_can.c
  • can_transmit_cancel() : at32f435_437_can.h, at32f435_437_can.c
  • can_transmit_data() : project/at_start_f435/examples/can/communication_mode/src/main.c, project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f435/examples/can/loopback_mode/src/main.c, project/at_start_f437/examples/can/communication_mode/src/main.c, project/at_start_f437/examples/can/filter/src/main.c, project/at_start_f437/examples/can/loopback_mode/src/main.c
  • can_transmit_error_counter_get() : at32f435_437_can.h, at32f435_437_can.c
  • can_transmit_status_get() : at32f435_437_can.h, at32f435_437_can.c
  • can_ttc_mode_enable() : at32f435_437_can.h, at32f435_437_can.c
  • cdc_class_setup_handler() : cdc_keyboard_class.c, cdc_msc_class.c
  • cdc_struct_init() : cdc_class.c, cdc_msc_class.c
  • check_card_programming() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • check_tcp_connect() : tcp_client.h, tcp_client.c
  • class_audio_setup_handler() : audio_hid_class.c
  • class_clear_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_ept0_rx_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_ept0_tx_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_event_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_hid_setup_handler() : audio_hid_class.c
  • class_in_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_init_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_out_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_setup_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_sof_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • clkout_config() : project/at_start_f435/examples/crm/clock_failure_detection/src/main.c, project/at_start_f435/examples/crm/pll_parameter_calculate/src/main.c, project/at_start_f435/examples/crm/sysclk_switch/src/main.c, project/at_start_f437/examples/crm/clock_failure_detection/src/main.c, project/at_start_f437/examples/crm/sysclk_switch/src/main.c
  • clock_failure_detection_handler() : project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c, project/at_start_f435/examples/crm/clock_failure_detection/src/main.c, project/at_start_f437/examples/crm/clock_failure_detection/src/at32f435_437_int.c
  • cmd_rst_ly68l6400_config() : at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c
  • cmd_rsten_ly68l6400_config() : at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c
  • codec_i2s_init() : at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • codec_i2s_reset() : at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • command_error() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • command_handle() : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h, at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
  • command_rsp1_error() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • command_rsp2_error() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • command_rsp3_error() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • command_rsp4_error() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • command_rsp5_error() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • command_rsp6_error() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • command_rsp7_error() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • config_flash_interrupt() : utilities/at32f435_437_slib_demo/project_l0/src/main.c, utilities/at32f435_437_slib_demo/project_l1/src/main.c
  • convert_from_bytes_to_power_of_two() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • copy_buff() : at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • Crc16() : flash_loader.c, flash_loader.h
  • Crc16_helper() : flash_loader.c
  • crc_block_calculate() : at32f435_437_crc.h, at32f435_437_crc.c
  • crc_cal() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • crc_common_data_set() : at32f435_437_crc.h, at32f435_437_crc.c
  • crc_common_date_get() : at32f435_437_crc.h, at32f435_437_crc.c
  • crc_data_get() : at32f435_437_crc.h, at32f435_437_crc.c
  • crc_data_reset() : at32f435_437_crc.h, at32f435_437_crc.c
  • crc_init_data_set() : at32f435_437_crc.h, at32f435_437_crc.c
  • crc_one_word_calculate() : at32f435_437_crc.h, at32f435_437_crc.c
  • crc_reverse_input_data_set() : at32f435_437_crc.h, at32f435_437_crc.c
  • crc_reverse_output_data_set() : at32f435_437_crc.h, at32f435_437_crc.c
  • crm_ahb_div_set() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_apb1_div_set() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_apb2_div_set() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_auto_step_mode_enable() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_battery_powered_domain_reset() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_clkout_div_set() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_clkout_to_tmr10_enable() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_clock_failure_detection_enable() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_clock_out1_set() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_clock_out2_set() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_clock_source_enable() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_clocks_freq_get() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_configuration() : project/at_start_f435/examples/irtmr/irtmr_output/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f435/examples/tmr/one_cycle/src/main.c, project/at_start_f435/examples/tmr/parallel_synchro/src/main.c, project/at_start_f435/examples/tmr/pwm_input/src/main.c, project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c
  • crm_emac_output_pulse_set() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_ertc_clock_enable() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_ertc_clock_select() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_flag_clear() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_flag_get() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_hext_bypass() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_hext_stable_wait() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_hick_clock_calibration_set() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_hick_clock_trimming_set() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_hick_divider_select() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_hick_sclk_frequency_select() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_interrupt_enable() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_lext_bypass() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_periph_clock_enable() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_periph_lowpower_mode_enable() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_periph_reset() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_pll_config() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_pll_parameter_calculate() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_reset() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_sysclk_switch() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_sysclk_switch_status_get() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_usb_clock_div_set() : at32f435_437_crm.h, at32f435_437_crm.c
  • crm_usb_clock_source_select() : at32f435_437_crm.h, at32f435_437_crm.c
  • custom_hid_class_send_report() : custom_hid_class.c, custom_hid_class.h
  • custom_qspi_busy_check() : qspi_algorithm.c, FlashPrg.c
  • custom_qspi_chip_erase() : qspi_algorithm.c, FlashPrg.c
  • custom_qspi_rst() : qspi_algorithm.c, FlashPrg.c
  • custom_qspi_rsten() : qspi_algorithm.c, FlashPrg.c
  • custom_qspi_rstqpi() : qspi_algorithm.c, FlashPrg.c
  • custom_qspi_sector_erase() : qspi_algorithm.c, FlashPrg.c
  • custom_qspi_write_enable() : qspi_algorithm.c, FlashPrg.c
  • custom_qspi_xip_enable() : qspi_algorithm.c, FlashPrg.c
  • custom_xip_enable_config() : qspi_algorithm.c, FlashPrg.c


AT32F435/437 Firmwary Library: Globals

- d -

  • dac_1_data_set() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_2_data_set() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_data_output_get() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_dma_enable() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_dual_data_set() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_dual_software_trigger_generate() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_enable() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_mask_amplitude_select() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_output_buffer_enable() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_reset() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_software_trigger_generate() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_trigger_enable() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_trigger_select() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_udr_enable() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_udr_flag_clear() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_udr_flag_get() : at32f435_437_dac.h, at32f435_437_dac.c
  • dac_wave_generate() : at32f435_437_dac.h, at32f435_437_dac.c
  • data_take() : at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
  • debug_apb1_periph_mode_set() : at32f435_437_debug.h, at32f435_437_debug.c
  • debug_apb2_periph_mode_set() : at32f435_437_debug.h, at32f435_437_debug.c
  • debug_device_id_get() : at32f435_437_debug.h, at32f435_437_debug.c
  • debug_low_power_mode_set() : at32f435_437_debug.h, at32f435_437_debug.c
  • DebugMon_Handler() : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c, project/at_start_f435/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f435/examples/can/filter/src/at32f435_437_int.c, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c, project/at_start_f435/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c, project/at_start_f435/templates/inc/at32f435_437_int.h, project/at_start_f435/templates/src/at32f435_437_int.c, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f437/templates/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/src/at32f435_437_int.c, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_int.h, utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_int.c
  • delay() : project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f435/examples/tmr/input_capture/src/main.c
  • delay_init() : at32f435_437_board.c, at32f435_437_board.h
  • delay_ms() : at32f435_437_board.c, at32f435_437_board.h
  • Delay_s() : tcp_client.c
  • delay_sec() : at32f435_437_board.c, at32f435_437_board.h
  • delay_us() : at32f435_437_board.c, at32f435_437_board.h
  • disk_initialize() : at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c, at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c
  • disk_ioctl() : at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c, at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c
  • disk_read() : at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c, at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c
  • disk_status() : at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c, at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c
  • disk_write() : at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c, at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c
  • DMA1_Channel1_IRQHandler() : project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c
  • DMA1_Channel2_IRQHandler() : project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c
  • DMA1_Channel3_IRQHandler() : project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • DMA1_Channel4_IRQHandler() : project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • DMA2_Channel1_IRQHandler() : project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c
  • DMA2_Channel4_IRQHandler() : project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c
  • dma_channel_enable() : at32f435_437_dma.h, at32f435_437_dma.c
  • dma_config() : project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f435/examples/adc/conversion_abort/src/main.c, project/at_start_f435/examples/adc/current_vref_value_check/src/main.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f435/examples/adc/resolution_6bit/src/main.c, project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f435/examples/adc/vbat_monitor/src/main.c, project/at_start_f435/examples/adc/voltage_monitoring/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f437/examples/adc/conversion_abort/src/main.c, project/at_start_f437/examples/adc/current_vref_value_check/src/main.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f437/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f437/examples/adc/resolution_6bit/src/main.c, project/at_start_f437/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f437/examples/adc/vbat_monitor/src/main.c, project/at_start_f437/examples/adc/voltage_monitoring/src/main.c
  • dma_configuration() : project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c
  • dma_data_number_get() : at32f435_437_dma.h, at32f435_437_dma.c
  • dma_data_number_set() : at32f435_437_dma.h, at32f435_437_dma.c
  • dma_default_para_init() : at32f435_437_dma.h, at32f435_437_dma.c
  • dma_flag_clear() : at32f435_437_dma.h, at32f435_437_dma.c
  • dma_flag_get() : at32f435_437_dma.h, at32f435_437_dma.c
  • dma_flexible_config() : at32f435_437_dma.h, at32f435_437_dma.c
  • dma_init() : at32f435_437_dma.h, at32f435_437_dma.c
  • dma_interrupt_enable() : at32f435_437_dma.h, at32f435_437_dma.c
  • dma_reset() : at32f435_437_dma.h, at32f435_437_dma.c
  • dmamux_enable() : at32f435_437_dma.h, at32f435_437_dma.c
  • dmamux_generator_config() : at32f435_437_dma.h, at32f435_437_dma.c
  • dmamux_generator_default_para_init() : at32f435_437_dma.h, at32f435_437_dma.c
  • dmamux_generator_flag_clear() : at32f435_437_dma.h, at32f435_437_dma.c
  • dmamux_generator_flag_get() : at32f435_437_dma.h, at32f435_437_dma.c
  • dmamux_generator_interrupt_enable() : at32f435_437_dma.h, at32f435_437_dma.c
  • dmamux_init() : at32f435_437_dma.h, at32f435_437_dma.c
  • dmamux_sync_config() : at32f435_437_dma.h, at32f435_437_dma.c
  • dmamux_sync_default_para_init() : at32f435_437_dma.h, at32f435_437_dma.c
  • dmamux_sync_flag_clear() : at32f435_437_dma.h, at32f435_437_dma.c
  • dmamux_sync_flag_get() : at32f435_437_dma.h, at32f435_437_dma.c
  • dmamux_sync_interrupt_enable() : at32f435_437_dma.h, at32f435_437_dma.c
  • dns_test() : project/at_start_f437/examples/emac/dns_client/src/main.c
  • dvp_basic_frame_rate_control_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_basic_status_get() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_capture_enable() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_capture_mode_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_config() : at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c
  • dvp_dma_burst_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_dma_init() : at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c
  • dvp_enable() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_enhanced_data_format_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_enhanced_framerate_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_enhanced_scaling_resize_enable() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_enhanced_scaling_resize_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_flag_clear() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_flag_get() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_frame_done() : at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c
  • dvp_hsync_polarity_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_input_data_unused_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_int_handler() : at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c
  • dvp_interrupt_enable() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_io_init() : at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c
  • DVP_IRQHandler() : at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c
  • dvp_jpeg_enable() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_monochrome_image_binarization_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_pclk_polarity_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_pixel_data_length_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_reset() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_start() : at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c
  • dvp_stop() : at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c
  • dvp_sync_code_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_sync_event_interrupt_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_sync_mode_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_sync_unmask_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_vsync_polarity_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_window_crop_enable() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_window_crop_set() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_zoomout_select() : at32f435_437_dvp.h, at32f435_437_dvp.c
  • dvp_zoomout_set() : at32f435_437_dvp.h, at32f435_437_dvp.c


AT32F435/437 Firmwary Library: Globals

- e -

  • edma_2d_enable() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_2d_init() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_config() : project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f435/examples/adc/edma_double_buffer/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f437/examples/adc/edma_double_buffer/src/main.c
  • edma_data_number_get() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_data_number_set() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_default_para_init() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_double_buffer_mode_enable() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_double_buffer_mode_init() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_fifo_status_get() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_flag_clear() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_flag_get() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_flow_controller_enable() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_init() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_interrupt_enable() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_link_list_enable() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_link_list_init() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_memory_addr_set() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_memory_target_get() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_peripheral_inc_offset_set() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_reset() : at32f435_437_edma.h, at32f435_437_edma.c
  • EDMA_Stream1_IRQHandler() : project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/edma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c, project/at_start_f435/examples/edma/link_list_mode/src/main.c, project/at_start_f435/examples/edma/two_dimension_mode/src/main.c
  • EDMA_Stream4_IRQHandler() : at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c
  • edma_stream_enable() : at32f435_437_edma.h, at32f435_437_edma.c
  • edma_stream_status_get() : at32f435_437_edma.h, at32f435_437_edma.c
  • edmamux_enable() : at32f435_437_edma.h, at32f435_437_edma.c
  • edmamux_generator_config() : at32f435_437_edma.h, at32f435_437_edma.c
  • edmamux_generator_default_para_init() : at32f435_437_edma.h, at32f435_437_edma.c
  • edmamux_generator_flag_clear() : at32f435_437_edma.h, at32f435_437_edma.c
  • edmamux_generator_flag_get() : at32f435_437_edma.h, at32f435_437_edma.c
  • edmamux_generator_interrupt_enable() : at32f435_437_edma.h, at32f435_437_edma.c
  • edmamux_init() : at32f435_437_edma.h, at32f435_437_edma.c
  • edmamux_sync_config() : at32f435_437_edma.h, at32f435_437_edma.c
  • edmamux_sync_default_para_init() : at32f435_437_edma.h, at32f435_437_edma.c
  • edmamux_sync_flag_clear() : at32f435_437_edma.h, at32f435_437_edma.c
  • edmamux_sync_flag_get() : at32f435_437_edma.h, at32f435_437_edma.c
  • edmamux_sync_interrupt_enable() : at32f435_437_edma.h, at32f435_437_edma.c
  • emac_address_filter_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_auto_pad_crc_stripping_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_backoff_limit_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_broadcast_frames_disable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_carrier_sense_disable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_clock_range_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_control_config() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_control_para_init() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_deferral_check_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_delay() : at32f435_437_emac.c
  • emac_dma_address_aligned_beats_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_application_missing_frame_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_arbitation_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_config() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_controller_missing_frame_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_descriptor_list_address_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_descriptor_list_address_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_descriptor_skip_length_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_eight_pbl_mode_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_fifo_overflow_bit_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_flag_clear() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_flag_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_interrupt_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_missing_overflow_bit_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_operations_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_para_init() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_poll_demand_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_poll_demand_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_receive_status_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_receive_threshold_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_rx_desc_interrupt_config() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_separate_pbl_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_software_reset_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_software_reset_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_tansfer_address_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_transmit_status_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dma_transmit_threshold_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dmarxdesc_frame_length_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_dstaddr_inverse_filter_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_duplex_mode_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_fast_speed_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_fcb_bpa_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_global_unicast_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_hash_multicast_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_hash_perfect_filter_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_hash_table_high32bits_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_hash_table_low32bits_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_hash_unicast_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_interframe_gap_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_interrupt_mask_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_interrupt_status_read() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ipv4_checksum_offload_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_IRQHandler() : project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c, project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c, project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_int.c
  • emac_jabber_disable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_layer2_configuration() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • emac_local_address_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_loopback_mode_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_magic_packet_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_mii_busy_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_mii_write() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_mmc_counter_freeze() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_mmc_counter_reset() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_mmc_received_error_frames_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_mmc_received_interrupt_mask_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_mmc_received_status_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_mmc_reset_on_read_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_mmc_rollover_stop() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_mmc_transmit_good_frames_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_mmc_transmit_interrupt_mask_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_mmc_transmit_status_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_nvic_configuration() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • emac_pass_all_multicasting_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_pass_control_frames_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_pause_low_threshold_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_pause_time_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_phy_init() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • emac_phy_register_read() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_phy_register_reset() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • emac_phy_register_write() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_pins_configuration() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • emac_power_down_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_promiscuous_mode_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_addend_register_update() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_clock_node_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_interrupt_trigger_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_mac_address_filter_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_pps_frequency_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_psv2_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_snapshot_emac_frames_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_snapshot_event_message_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_snapshot_ipv4_frames_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_snapshot_ipv6_frames_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_snapshot_master_event_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_snapshot_received_frames_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_subsecond_increment_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_subsecond_rollover_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_system_second_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_system_second_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_system_subsecond_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_system_subsecond_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_system_time_sign_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_system_time_sign_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_target_nanosecond_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_target_second_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_timestamp_addend_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_timestamp_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_timestamp_fine_update_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_timestamp_status_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_timestamp_system_time_init() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_ptp_timestamp_system_time_update() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_receive_all_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_receive_flow_control_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_receive_own_disable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_received_magic_packet_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_received_packet_size_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_received_wakeup_frame_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_receiver_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_reset() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_retry_disable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_speed_config() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • emac_srcaddr_filter_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_srcaddr_inverse_filter_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_start() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_stop() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_system_init() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • emac_tmr_init() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • emac_transmit_flow_control_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_trasmitter_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_unicast_pause_frame_detect() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_vlan_tag_comparison_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_vlan_tag_identifier_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_wake_on_lan_init() : project/at_start_f437/examples/emac/wake_on_lan/src/main.c
  • emac_wakeup_frame_enable() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_wakeup_frame_filter_reset() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_wakeup_frame_get() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_wakeup_frame_set() : at32f435_437_emac.h, at32f435_437_emac.c
  • emac_watchdog_disable() : at32f435_437_emac.h, at32f435_437_emac.c
  • EMAC_WKUP_IRQHandler() : project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c
  • emac_zero_quanta_pause_disable() : at32f435_437_emac.h, at32f435_437_emac.c
  • EraseChip() : FlashOS.h, FlashPrg.c
  • EraseSector() : FlashOS.h, FlashPrg.c
  • error_handler() : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c
  • ertc_alarm_config() : project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/main.c
  • ertc_alarm_enable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_alarm_get() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_alarm_mask_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_alarm_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_alarm_show() : project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c
  • ertc_alarm_sub_second_get() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_alarm_sub_second_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_alarm_value_set() : project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/main.c
  • ertc_alarm_week_date_select() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_bcd_to_num() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_bpr_data_read() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_bpr_data_write() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_cal_output_enable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_cal_output_select() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_calendar_get() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_coarse_calibration_enable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_coarse_calibration_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_config() : project/at_start_f435/examples/ertc/bpr_domain/src/main.c, project/at_start_f435/examples/ertc/calendar/src/main.c, project/at_start_f435/examples/ertc/lick_calibration/src/main.c, project/at_start_f435/examples/ertc/tamper/src/main.c, project/at_start_f435/examples/ertc/time_stamp/src/main.c, project/at_start_f435/examples/ertc/wakeup_timer/src/main.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/main.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/main.c, project/at_start_f435/examples/pwc/ldo_set/src/main.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/main.c
  • ertc_date_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_daylight_bpr_get() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_daylight_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_direct_read_enable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_divider_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_flag_clear() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_flag_get() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_hour_mode_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_init_mode_enter() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_init_mode_exit() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_interrupt_enable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_interrupt_get() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_num_to_bcd() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_output_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_refer_clock_detect_enable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_reset() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_smooth_calibration_config() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_sub_second_get() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_tamper_1_pin_select() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_tamper_config() : project/at_start_f435/examples/ertc/tamper/src/main.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/main.c, project/at_start_f435/examples/pwc/ldo_set/src/main.c
  • ertc_tamper_detect_freq_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_tamper_enable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_tamper_filter_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_tamper_precharge_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_tamper_pull_up_enable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_tamper_timestamp_enable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_tamper_valid_edge_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_time_adjust() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_time_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_time_show() : project/at_start_f435/examples/ertc/calendar/src/main.c, project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c
  • ertc_timestamp_config() : project/at_start_f435/examples/ertc/time_stamp/src/main.c
  • ertc_timestamp_enable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_timestamp_get() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_timestamp_pin_select() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_timestamp_show() : project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c
  • ertc_timestamp_sub_second_get() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_timestamp_valid_edge_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_wait_flag() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_wait_update() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_wakeup_clock_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_wakeup_counter_get() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_wakeup_counter_set() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_wakeup_enable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_wakeup_show() : project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c
  • ertc_wakeup_timer_config() : project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/main.c
  • ERTC_WKUP_IRQHandler() : project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c
  • ertc_write_protect_disable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ertc_write_protect_enable() : at32f435_437_ertc.h, at32f435_437_ertc.c
  • ERTCAlarm_IRQHandler() : project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c
  • esmt32m_cmd_erase_config() : at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_qpien_config() : at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_rdsr_config() : at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_read_config() : at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_read_pem_begin_config() : at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_read_pem_end_config() : at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_read_pem_keep_config() : at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_rst_config() : at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_rsten_config() : at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_rstqpi_config() : at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_send() : at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_wren_config() : at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c
  • esmt32m_cmd_write_config() : at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c
  • esmt32m_qpi_mode_init() : project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c
  • ethernetif_notify_conn_changed() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • ethernetif_set_link() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • ethernetif_update_config() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • EXINT0_IRQHandler() : project/at_start_f435/examples/exint/exint_config/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f435/examples/usb_host/hid_demo/src/main.c, project/at_start_f435/templates/src/main.c
  • EXINT1_IRQHandler() : project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c
  • EXINT4_IRQHandler() : project/at_start_f435/examples/exint/exint_software_trigger/src/main.c
  • EXINT9_5_IRQHandler() : project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c
  • exint_config() : project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c
  • exint_default_para_init() : at32f435_437_exint.h, at32f435_437_exint.c
  • exint_event_enable() : at32f435_437_exint.h, at32f435_437_exint.c
  • exint_flag_clear() : at32f435_437_exint.h, at32f435_437_exint.c
  • exint_flag_get() : at32f435_437_exint.h, at32f435_437_exint.c
  • exint_init() : at32f435_437_exint.h, at32f435_437_exint.c
  • exint_interrupt_enable() : at32f435_437_exint.h, at32f435_437_exint.c
  • exint_line0_config() : project/at_start_f435/examples/exint/exint_config/src/main.c
  • exint_line4_config() : project/at_start_f435/examples/exint/exint_software_trigger/src/main.c
  • exint_reset() : at32f435_437_exint.h, at32f435_437_exint.c
  • exint_software_interrupt_event_generate() : at32f435_437_exint.h, at32f435_437_exint.c
  • extend_sram() : project/at_start_f435/examples/sram/extend_sram/src/main.c, project/at_start_f437/examples/sram/extend_sram/src/main.c


AT32F435/437 Firmwary Library: Globals

- f -

  • fat16_memory_cmp() : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • fat16_memory_copy() : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • fat16_memory_memset() : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • fatfs_test() : project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f437/examples/sdio/sdio_fatfs/src/main.c
  • fill_buffer() : project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c, at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f435/examples/xmc/psram/inc/xmc_psram.h, at_start_f435/examples/xmc/psram/src/xmc_psram.c, at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c, at_start_f435/examples/xmc/sram/inc/xmc_sram.h, at_start_f435/examples/xmc/sram/src/xmc_sram.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f437/examples/xmc/psram/inc/xmc_psram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sram/inc/xmc_sram.h
  • FIR_lowpass_filter() : project_l0/inc/fir_filter.h, fir_filter.c, project_l1/inc/fir_filter.h
  • Fl2FlashChecksumEntry() : flash_loader.c
  • Fl2FlashEraseWriteEntry() : flash_loader.c
  • Fl2FlashInitEntry() : flash_loader.c
  • Fl2FlashSignoffEntry() : flash_loader.c
  • Fl2FlashWriteEntry() : flash_loader.c
  • flash_2kb_write() : utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/flash.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/src/flash.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/flash.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/flash.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/flash.c
  • flash_bank1_erase() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_bank1_lock() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_bank1_operation_status_get() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_bank1_operation_wait_for() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_bank1_unlock() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_bank2_erase() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_bank2_lock() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_bank2_operation_status_get() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_bank2_operation_wait_for() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_bank2_unlock() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_block_erase() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_byte_program() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_continue_read_enable() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_crc_calibrate() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_crc_check() : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • flash_eopb0_config() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_epp_set() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_epp_status_get() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_fap_enable() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_fap_status_get() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_fat16_addr_offset() : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • flash_fat16_boot_dir_write() : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • flash_fat16_clear_upgrade_flag() : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • flash_fat16_get_upgrade_flag() : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • flash_fat16_init() : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • flash_fat16_loop_status() : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c
  • flash_fat16_read() : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • flash_fat16_sector_write() : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • flash_fat16_set_name() : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • flash_fat16_set_upgrade_flag() : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • flash_fat16_write() : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • flash_flag_clear() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_flag_get() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_halfword_program() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_if_write() : utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/flash.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/flash.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/flash.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/flash.c
  • flash_internal_all_erase() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_interrupt_enable() : at32f435_437_flash.h, at32f435_437_flash.c
  • FLASH_IRQHandler() : utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c
  • flash_lock() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_nzw_boost_enable() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_operation_status_get() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_operation_wait_for() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_read() : project/at_start_f435/examples/flash/flash_write_read/inc/flash.h, project/at_start_f435/examples/flash/flash_write_read/src/flash.c
  • flash_read_data() : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • flash_sector_erase() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_slib_disable() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_slib_enable() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_slib_end_sector_get() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_slib_inststart_sector_get() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_slib_remaining_count_get() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_slib_start_sector_get() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_slib_state_get() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_ssb_set() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_ssb_status_get() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_unlock() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_upgrade_flag_read() : utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/flash.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/src/flash.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/flash.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/flash.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/flash.c
  • flash_user_system_data_erase() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_user_system_data_program() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_word_program() : at32f435_437_flash.h, at32f435_437_flash.c
  • flash_write() : project/at_start_f435/examples/flash/flash_write_read/inc/flash.h, project/at_start_f435/examples/flash/flash_write_read/src/flash.c
  • flash_write_data() : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • flash_write_nocheck() : project/at_start_f435/examples/flash/flash_write_read/inc/flash.h, project/at_start_f435/examples/flash/flash_write_read/src/flash.c
  • FlashBreak() : flash_loader.c
  • FlashChecksum() : flash_loader.c, flash_loader.h, flash_loader_ram.c
  • FlashChecksumEntry() : flash_loader.h
  • FlashErase() : flash_loader.h, flash_loader_ram.c, qspi_algorithm.c
  • FlashInit() : flash_loader.h, flash_loader_ram.c, qspi_algorithm.c
  • FlashSignoff() : flash_loader.c, flash_loader.h, flash_loader_ram.c, qspi_algorithm.c
  • FlashSignoffEntry() : flash_loader.h
  • FlashWrite() : flash_loader.h, flash_loader_ram.c, qspi_algorithm.c
  • fputc() : at32f435_437_board.c
  • fs_bytes_left() : fs.c
  • fs_close() : fs.c
  • fs_open() : fs.c


AT32F435/437 Firmwary Library: Globals

- g -

  • generate_julia_fpu() : at_start_f435/examples/cortex_m4/fpu/inc/julia_fpu.h, at_start_f435/examples/cortex_m4/fpu/src/julia_fpu.c
  • get_device_config_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_configuration() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_descriptor() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_interface_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_lang_id() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_manufacturer_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_other_speed() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_product_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_qualifier() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_serial_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_fattime() : at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c
  • get_inquiry() : at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c, at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h
  • get_serial_num() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_uid_for_seed() : random.c
  • gpio_bits_reset() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • gpio_bits_set() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • gpio_bits_write() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • gpio_config() : project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c, project/at_start_f435/examples/adc/conversion_abort/src/main.c, project/at_start_f435/examples/adc/edma_double_buffer/src/main.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f435/examples/adc/resolution_6bit/src/main.c, project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c, project/at_start_f435/examples/adc/voltage_monitoring/src/main.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c, project/at_start_f435/examples/gpio/io_toggle/src/main.c, project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c, project/at_start_f437/examples/adc/conversion_abort/src/main.c, project/at_start_f437/examples/adc/edma_double_buffer/src/main.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f437/examples/adc/resolution_6bit/src/main.c, project/at_start_f437/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f437/examples/adc/use_polling_get_conversion_data/src/main.c, project/at_start_f437/examples/adc/voltage_monitoring/src/main.c, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c, project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f437/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • gpio_configuration() : project/at_start_f435/examples/irtmr/irtmr_output/src/main.c, project/at_start_f435/examples/tmr/oc_high/src/main.c, project/at_start_f435/examples/tmr/oc_low/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f435/examples/tmr/one_cycle/src/main.c, project/at_start_f435/examples/tmr/parallel_synchro/src/main.c, project/at_start_f435/examples/tmr/pwm_input/src/main.c, project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c
  • gpio_default_para_init() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • gpio_init() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • gpio_input_data_bit_read() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • gpio_input_data_read() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • gpio_output_data_bit_read() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • gpio_output_data_read() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • gpio_pin_mux_config() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • gpio_pin_wp_config() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • gpio_pins_huge_driven_config() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • gpio_pins_toggle() : project/at_start_f435/examples/gpio/swjtag_mux/src/main.c
  • gpio_port_write() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • gpio_reset() : at32f435_437_gpio.h, at32f435_437_gpio.c


AT32F435/437 Firmwary Library: Globals

- h -

  • HardFault_Handler() : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c, project/at_start_f435/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f435/examples/can/filter/src/at32f435_437_int.c, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c, project/at_start_f435/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c, project/at_start_f435/templates/inc/at32f435_437_int.h, project/at_start_f435/templates/src/at32f435_437_int.c, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f437/templates/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/src/at32f435_437_int.c, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_int.h, utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_int.c
  • helloworld_accept() : telnet.c
  • helloworld_conn_err() : telnet.c
  • helloworld_init() : telnet.h, telnet.c
  • helloworld_recv() : telnet.c
  • http_accept() : httpd.c
  • http_check_eof() : httpd.c
  • http_close_conn() : httpd.c
  • http_close_or_abort_conn() : httpd.c
  • http_eof() : httpd.c
  • http_err() : httpd.c
  • http_poll() : httpd.c
  • http_recv() : httpd.c
  • http_send() : httpd.c
  • http_send_data_nonssi() : httpd.c
  • http_sent() : httpd.c
  • http_state_alloc() : httpd.c
  • http_state_eof() : httpd.c
  • http_state_free() : httpd.c
  • http_state_init() : httpd.c
  • http_write() : httpd.c
  • httpd_init() : httpd.c, telnet.h
  • httpd_init_pcb() : httpd.c


AT32F435/437 Firmwary Library: Globals

- i -

  • I2C1_ERR_IRQHandler() : project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c
  • I2C1_EVT_IRQHandler() : project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c
  • I2C2_ERR_IRQHandler() : project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c
  • I2C2_EVT_IRQHandler() : project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c
  • i2c_ack_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_addr10_header_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_addr10_mode_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_auto_stop_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_clock_stretch_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_cnt_set() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_config() : i2c_application.c, i2c_application.h
  • i2c_data_receive() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_data_send() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_dma_config() : i2c_application.c
  • i2c_dma_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_dma_rx_irq_handler() : i2c_application.c, i2c_application.h
  • i2c_dma_tx_irq_handler() : i2c_application.c, i2c_application.h
  • i2c_dma_tx_rx_irq_handler() : i2c_application.c
  • i2c_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_err_irq_handler() : i2c_application.c, i2c_application.h
  • i2c_evt_irq_handler() : i2c_application.c, i2c_application.h
  • i2c_ext_timeout_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_ext_timeout_set() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_flag_clear() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_flag_get() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_general_call_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_init() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_interrupt_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_interrupt_get() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_lowlevel_init() : i2c_application.c, i2c_application.h, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • i2c_master_irq_handler_dma() : i2c_application.c
  • i2c_master_irq_handler_int() : i2c_application.c
  • i2c_master_receive() : i2c_application.c, i2c_application.h
  • i2c_master_receive_dma() : i2c_application.c, i2c_application.h
  • i2c_master_receive_int() : i2c_application.c, i2c_application.h
  • i2c_master_transmit() : i2c_application.c, i2c_application.h
  • i2c_master_transmit_dma() : i2c_application.c, i2c_application.h
  • i2c_master_transmit_int() : i2c_application.c, i2c_application.h
  • i2c_matched_addr_get() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_memory_read() : i2c_application.c, i2c_application.h
  • i2c_memory_read_dma() : i2c_application.c, i2c_application.h
  • i2c_memory_read_int() : i2c_application.c, i2c_application.h
  • i2c_memory_write() : i2c_application.c, i2c_application.h
  • i2c_memory_write_dma() : i2c_application.c, i2c_application.h
  • i2c_memory_write_int() : i2c_application.c, i2c_application.h
  • i2c_own_address1_set() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_own_address2_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_own_address2_set() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_pec_calculate_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_pec_transmit_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_pec_value_get() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_refresh_txdt_register() : i2c_application.c
  • i2c_reload_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_reset() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_reset_ctrl2_register() : i2c_application.c, i2c_application.h
  • i2c_slave_data_ctrl_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_slave_irq_handler_dma() : i2c_application.c
  • i2c_slave_irq_handler_int() : i2c_application.c
  • i2c_slave_receive() : i2c_application.c, i2c_application.h
  • i2c_slave_receive_dma() : i2c_application.c, i2c_application.h
  • i2c_slave_receive_int() : i2c_application.c, i2c_application.h
  • i2c_slave_transmit() : i2c_application.c, i2c_application.h
  • i2c_slave_transmit_dma() : i2c_application.c, i2c_application.h
  • i2c_slave_transmit_int() : i2c_application.c, i2c_application.h
  • i2c_smbus_alert_set() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_smbus_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_smbus_master_receive() : i2c_application.c, i2c_application.h
  • i2c_smbus_master_transmit() : i2c_application.c, i2c_application.h
  • i2c_smbus_slave_receive() : i2c_application.c, i2c_application.h
  • i2c_smbus_slave_transmit() : i2c_application.c, i2c_application.h
  • i2c_start_generate() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_start_transfer() : i2c_application.c
  • i2c_start_transfer_dma() : i2c_application.c
  • i2c_stop_generate() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_timeout_detcet_set() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_timeout_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_timeout_set() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_transfer_addr_get() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_transfer_addr_set() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_transfer_dir_get() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_transfer_dir_set() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_transmit_set() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_wait_end() : i2c_application.c, i2c_application.h
  • i2c_wait_flag() : i2c_application.c, i2c_application.h
  • i2s_config() : project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c, project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c, project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f437/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • i2s_default_para_init() : at32f435_437_spi.h, at32f435_437_spi.c
  • i2s_enable() : at32f435_437_spi.h, at32f435_437_spi.c
  • i2s_init() : at32f435_437_spi.h, at32f435_437_spi.c
  • iap_address() : bootloader/src/hid_iap_user.c
  • iap_clear_upgrade_flag() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_command_handle() : at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h, at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c, at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/iap.c, at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/iap.h, at32f437_emac_iap_demo/source_code/app_led3_toggle/src/iap.c, at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h, at32f437_emac_iap_demo/source_code/bootloader/src/iap.c
  • iap_crc() : bootloader/src/hid_iap_user.c
  • iap_data_write() : bootloader/src/hid_iap_user.c
  • iap_erase_sector() : bootloader/src/hid_iap_user.c
  • iap_finish() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_get() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_get_upgrade_flag() : app_led3_toggle/inc/hid_iap_user.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/inc/hid_iap_user.h, bootloader/src/hid_iap_user.c
  • iap_httpd_init() : httpserver.h
  • iap_idle() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_init() : at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h, at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c, at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/iap.c, app_led3_toggle/inc/hid_iap_user.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/inc/hid_iap_user.h, bootloader/src/hid_iap_user.c, at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/iap.h, at32f437_emac_iap_demo/source_code/app_led3_toggle/src/iap.c, at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h, at32f437_emac_iap_demo/source_code/bootloader/src/iap.c
  • iap_jump() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_loop() : bootloader/inc/hid_iap_user.h, bootloader/src/hid_iap_user.c
  • iap_respond() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_set_upgrade_flag() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_start() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_tftpd_init() : tftpserver.h
  • iap_upgrade_app_handle() : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h, at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
  • Init() : FlashOS.h, FlashPrg.c
  • init_clk() : qspi_algorithm.c, FlashPrg.c
  • iperf_accept() : iperf.c
  • iperf_init() : iperf.h, iperf.c
  • iperf_recv() : iperf.c
  • is_bpr_reg_reset() : project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c


AT32F435/437 Firmwary Library: Globals

- j -

  • jpeg_data_process() : at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c
  • jump_to_app() : project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c, bootloader/inc/hid_iap_user.h, bootloader/src/hid_iap_user.c
  • jump_to_iap() : app_led3_toggle/inc/hid_iap_user.h


AT32F435/437 Firmwary Library: Globals

- k -

  • keyboard_class_setup_handler() : cdc_keyboard_class.c
  • keyboard_send_string() : project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f435/examples/usb_device/keyboard/src/main.c, project/at_start_f435/examples/usb_device/mouse/src/main.c


AT32F435/437 Firmwary Library: Globals

- l -

  • lcd_char_show() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c
  • lcd_clear() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c, at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c
  • lcd_color_fill() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c
  • lcd_display_number() : at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c
  • lcd_drawpoint() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c, at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c
  • lcd_fill() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c
  • lcd_init() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c, at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c
  • lcd_rd_data() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c
  • lcd_setblock() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c, at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c
  • lcd_string_show() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c
  • lcd_wr_command() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c, at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c
  • lcd_wr_data() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c, at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c
  • lcd_writeonepoint() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c, at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c
  • led2_task_function() : utilities/at32f435_437_freertos_demo/src/main.c
  • led3_task_function() : utilities/at32f435_437_freertos_demo/src/main.c
  • lick_frequency_get() : project/at_start_f435/examples/ertc/lick_calibration/src/main.c
  • link_update() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • lwip_periodic_handle() : project/at_start_f437/examples/emac/dns_client/inc/netconf.h, project/at_start_f437/examples/emac/dns_client/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/netconf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/netconf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • lwip_pkt_handle() : project/at_start_f437/examples/emac/dns_client/inc/netconf.h, project/at_start_f437/examples/emac/dns_client/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/netconf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/netconf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c


AT32F435/437 Firmwary Library: Globals

- m -

  • main() : project/at_start_f435/examples/acc/calibration/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c, project/at_start_f435/examples/adc/conversion_abort/src/main.c, project/at_start_f435/examples/adc/current_vref_value_check/src/main.c, project/at_start_f435/examples/adc/edma_double_buffer/src/main.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f435/examples/adc/resolution_6bit/src/main.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c, project/at_start_f435/examples/adc/vbat_monitor/src/main.c, project/at_start_f435/examples/adc/voltage_monitoring/src/main.c, project/at_start_f435/examples/can/communication_mode/src/main.c, project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f435/examples/can/loopback_mode/src/main.c, project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f435/examples/cortex_m4/fpu/src/main.c, project/at_start_f435/examples/cortex_m4/systick_interrupt/src/main.c, project/at_start_f435/examples/crc/calculation/src/main.c, project/at_start_f435/examples/crm/clock_failure_detection/src/main.c, project/at_start_f435/examples/crm/pll_parameter_calculate/src/main.c, project/at_start_f435/examples/crm/sysclk_switch/src/main.c, project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/main.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c, project/at_start_f435/examples/dac/one_dac_noisewave/src/main.c, project/at_start_f435/examples/dac/two_dac_trianglewave/src/main.c, project/at_start_f435/examples/debug/tmr1/src/main.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/dma/flash_to_sram/src/main.c, project/at_start_f435/examples/dvp/ov2640_capture/src/main.c, project/at_start_f435/examples/dvp/ov5640_capture/src/main.c, project/at_start_f435/examples/edma/burst_mode/src/main.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/edma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c, project/at_start_f435/examples/edma/link_list_mode/src/main.c, project/at_start_f435/examples/edma/two_dimension_mode/src/main.c, project/at_start_f435/examples/ertc/bpr_domain/src/main.c, project/at_start_f435/examples/ertc/calendar/src/main.c, project/at_start_f435/examples/ertc/lick_calibration/src/main.c, project/at_start_f435/examples/ertc/tamper/src/main.c, project/at_start_f435/examples/ertc/time_stamp/src/main.c, project/at_start_f435/examples/ertc/wakeup_timer/src/main.c, project/at_start_f435/examples/exint/exint_config/src/main.c, project/at_start_f435/examples/exint/exint_software_trigger/src/main.c, project/at_start_f435/examples/flash/fap_enable/src/main.c, project/at_start_f435/examples/flash/flash_write_read/src/main.c, project/at_start_f435/examples/gpio/io_toggle/src/main.c, project/at_start_f435/examples/gpio/led_toggle/src/main.c, project/at_start_f435/examples/gpio/swjtag_mux/src/main.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f435/examples/irtmr/irtmr_output/src/main.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/main.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/main.c, project/at_start_f435/examples/pwc/ldo_set/src/main.c, project/at_start_f435/examples/pwc/power_voltage_monitor/src/main.c, project/at_start_f435/examples/pwc/sleep_tmr2/src/main.c, project/at_start_f435/examples/pwc/sleep_usart1/src/main.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/main.c, project/at_start_f435/examples/pwc/standby_wakeup_pin/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c, project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c, project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c, project/at_start_f435/examples/scfg/mem_map_sel/src/main.c, project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f435/examples/spi/w25q_flash/src/main.c, project/at_start_f435/examples/sram/extend_sram/src/main.c, project/at_start_f435/examples/tmr/6_steps/src/main.c, project/at_start_f435/examples/tmr/7_pwm_output/src/main.c, project/at_start_f435/examples/tmr/cascade_synchro/src/main.c, project/at_start_f435/examples/tmr/complementary_signals/src/main.c, project/at_start_f435/examples/tmr/dma/src/main.c, project/at_start_f435/examples/tmr/dma_burst/src/main.c, project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f435/examples/tmr/external_clock/src/main.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f435/examples/tmr/hang_mode/src/main.c, project/at_start_f435/examples/tmr/input_capture/src/main.c, project/at_start_f435/examples/tmr/oc_high/src/main.c, project/at_start_f435/examples/tmr/oc_low/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f435/examples/tmr/one_cycle/src/main.c, project/at_start_f435/examples/tmr/parallel_synchro/src/main.c, project/at_start_f435/examples/tmr/pwm_input/src/main.c, project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f435/examples/tmr/timer_base/src/main.c, project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c, project/at_start_f435/examples/usart/half_duplex/src/main.c, project/at_start_f435/examples/usart/hw_flow_control/src/main.c, project/at_start_f435/examples/usart/idle_detection/src/main.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/irda/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/printf/src/main.c, project/at_start_f435/examples/usart/receiver_mute/src/main.c, project/at_start_f435/examples/usart/rs485/src/main.c, project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f435/examples/usb_device/audio/src/main.c, project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f435/examples/usb_device/custom_hid/src/main.c, project/at_start_f435/examples/usb_device/keyboard/src/main.c, project/at_start_f435/examples/usb_device/mouse/src/main.c, project/at_start_f435/examples/usb_device/msc/src/main.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/printer/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c, project/at_start_f435/examples/usb_host/hid_demo/src/main.c, project/at_start_f435/examples/usb_host/msc_only_fat32/src/main.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c, project/at_start_f435/examples/wdt/wdt_reset/src/main.c, project/at_start_f435/examples/wdt/wdt_standby/src/main.c, project/at_start_f435/examples/wwdt/wwdt_reset/src/main.c, project/at_start_f435/examples/xmc/lcd_8bit/src/main.c, project/at_start_f435/examples/xmc/lcd_touch_16bit/src/main.c, project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f435/examples/xmc/nor_flash/src/main.c, project/at_start_f435/examples/xmc/psram/src/main.c, project/at_start_f435/examples/xmc/sdram_basic/src/main.c, project/at_start_f435/examples/xmc/sdram_dma/src/main.c, project/at_start_f435/examples/xmc/sram/src/main.c, project/at_start_f435/templates/src/main.c, project/at_start_f437/examples/emac/dns_client/src/main.c, project/at_start_f437/examples/emac/http_server/src/main.c, project/at_start_f437/examples/emac/iperf/src/main.c, project/at_start_f437/examples/emac/mqtt_client/src/main.c, project/at_start_f437/examples/emac/tcp_client/src/main.c, project/at_start_f437/examples/emac/tcp_server/src/main.c, project/at_start_f437/examples/emac/telnet/src/main.c, project/at_start_f437/examples/emac/wake_on_lan/src/main.c, utilities/at32f435_437_freertos_demo/src/main.c, utilities/at32f435_437_gen_random_number_demo/src/main.c, utilities/at32f435_437_slib_demo/project_l0/src/main.c, utilities/at32f435_437_slib_demo/project_l1/src/main.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/main.c
  • mclk_tmr1_init() : at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • MemManage_Handler() : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c, project/at_start_f435/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f435/examples/can/filter/src/at32f435_437_int.c, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c, project/at_start_f435/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c, project/at_start_f435/templates/inc/at32f435_437_int.h, project/at_start_f435/templates/src/at32f435_437_int.c, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f437/templates/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/src/at32f435_437_int.c, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_int.h, utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_int.c
  • memset16_buffer() : at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • mmc_stream_read() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • mmc_stream_test() : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c
  • mmc_stream_write() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • mmc_switch() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • mqtt_client_init() : mqtt_client.h
  • mqtt_client_pub_request_cb() : mqtt_client.h, mqtt_client.c
  • mqtt_conn_sub_proc() : mqtt_client.c
  • mqtt_error_process_callback() : mqtt_client.c
  • msc_bot_scsi_init() : usbh_msc_bot_scsi.c, usbh_msc_class.h
  • msc_class_setup_handler() : cdc_msc_class.c
  • msc_disk_capacity() : at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c, at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h
  • msc_disk_read() : at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c, at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h
  • msc_disk_write() : at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c, at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h
  • my_memset() : arm_fir_init_f32.c


AT32F435/437 Firmwary Library: Globals

- n -

  • nand_address_increment() : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c
  • nand_ecc_correction() : project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c
  • nand_erase_block() : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c
  • nand_get_status() : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c
  • nand_init() : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c
  • nand_read_id() : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c
  • nand_read_small_page() : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c
  • nand_read_spare_area() : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c
  • nand_read_status() : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c
  • nand_reset() : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c
  • nand_write_small_page() : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c
  • nand_write_spare_area() : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c
  • NMI_Handler() : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c, project/at_start_f435/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f435/examples/can/filter/src/at32f435_437_int.c, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c, project/at_start_f435/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c, project/at_start_f435/templates/inc/at32f435_437_int.h, project/at_start_f435/templates/src/at32f435_437_int.c, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f437/templates/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/src/at32f435_437_int.c, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_int.h, utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_int.c
  • nor_eraseblock() : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • nor_erasechip() : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • nor_getstatus() : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • nor_init() : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • nor_programbuffer() : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • nor_readbuffer() : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • nor_readhalfword() : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • nor_readid() : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • nor_reset() : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • nor_returntoreadmode() : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • nor_writebuffer() : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • nor_writehalfword() : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • nvic_configuration() : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sdio_fatfs/src/main.c
  • nvic_irq_disable() : at32f435_437_misc.h, at32f435_437_misc.c
  • nvic_irq_enable() : at32f435_437_misc.h, at32f435_437_misc.c
  • nvic_lowpower_mode_config() : at32f435_437_misc.h, at32f435_437_misc.c
  • nvic_priority_group_config() : at32f435_437_misc.h, at32f435_437_misc.c
  • nvic_system_reset() : at32f435_437_misc.h, at32f435_437_misc.c
  • nvic_vector_table_set() : at32f435_437_misc.h, at32f435_437_misc.c


AT32F435/437 Firmwary Library: Globals

- o -

  • OTG2_IRQ_HANDLER() : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c
  • OTG_IRQ_HANDLER() : project/at_start_f435/examples/acc/calibration/src/main.c, project/at_start_f435/examples/usb_device/audio/src/main.c, project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f435/examples/usb_device/custom_hid/src/main.c, project/at_start_f435/examples/usb_device/keyboard/src/main.c, project/at_start_f435/examples/usb_device/mouse/src/main.c, project/at_start_f435/examples/usb_device/msc/src/main.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/printer/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c, project/at_start_f435/examples/usb_host/hid_demo/src/main.c, project/at_start_f435/examples/usb_host/msc_only_fat32/src/main.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c
  • ov2640_auto_exposure() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_brightness() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_capture() : project/at_start_f435/examples/dvp/ov2640_capture/src/main.c
  • ov2640_color_bar() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_color_saturation() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_contrast() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_i2c_init() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_imagesize_set() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_imagewin_set() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_init() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_jpeg_mode() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_light_mode() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_outsize_set() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_reg_read() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_reg_write() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_rgb565_mode() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_special_effects() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_window_set() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov5640_brightness() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_capture() : project/at_start_f435/examples/dvp/ov5640_capture/src/main.c
  • ov5640_color_saturation() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_contrast() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_exposure() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_flash_ctrl() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_focus_constant() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_focus_init() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_focus_single() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_i2c_init() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_imagewin_set() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_init() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_jpeg_mode() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_light_mode() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_outsize_set() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_reg_read() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_reg_write() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_rgb565_mode() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_sharpness() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_special_effects() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h


AT32F435/437 Firmwary Library: Globals

- p -

  • parsing_result() : project/at_start_f437/examples/emac/dns_client/src/main.c
  • PendSV_Handler() : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c, project/at_start_f435/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f435/examples/can/filter/src/at32f435_437_int.c, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c, project/at_start_f435/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c, project/at_start_f435/templates/inc/at32f435_437_int.h, project/at_start_f435/templates/src/at32f435_437_int.c, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f437/templates/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_int.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_int.h, utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_int.c
  • ProgramPage() : FlashOS.h, FlashPrg.c
  • psram_init() : at_start_f435/examples/xmc/psram/inc/xmc_psram.h, at_start_f435/examples/xmc/psram/src/xmc_psram.c, at_start_f437/examples/xmc/psram/inc/xmc_psram.h
  • psram_readbuffer() : at_start_f435/examples/xmc/psram/inc/xmc_psram.h, at_start_f435/examples/xmc/psram/src/xmc_psram.c, at_start_f437/examples/xmc/psram/inc/xmc_psram.h
  • psram_writebuffer() : at_start_f435/examples/xmc/psram/inc/xmc_psram.h, at_start_f435/examples/xmc/psram/src/xmc_psram.c, at_start_f437/examples/xmc/psram/inc/xmc_psram.h
  • pvm_exint_config() : project/at_start_f435/examples/pwc/power_voltage_monitor/src/main.c
  • PVM_IRQHandler() : project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c
  • pwc_battery_powered_domain_access() : at32f435_437_pwc.h, at32f435_437_pwc.c
  • pwc_deep_sleep_mode_enter() : at32f435_437_pwc.h, at32f435_437_pwc.c
  • pwc_flag_clear() : at32f435_437_pwc.h, at32f435_437_pwc.c
  • pwc_flag_get() : at32f435_437_pwc.h, at32f435_437_pwc.c
  • pwc_power_voltage_monitor_enable() : at32f435_437_pwc.h, at32f435_437_pwc.c
  • pwc_pvm_level_select() : at32f435_437_pwc.h, at32f435_437_pwc.c
  • pwc_reset() : at32f435_437_pwc.h, at32f435_437_pwc.c
  • pwc_sleep_mode_enter() : at32f435_437_pwc.h, at32f435_437_pwc.c
  • pwc_standby_mode_enter() : at32f435_437_pwc.h, at32f435_437_pwc.c
  • pwc_voltage_regulate_set() : at32f435_437_pwc.h, at32f435_437_pwc.c
  • pwc_wakeup_pin_enable() : at32f435_437_pwc.h, at32f435_437_pwc.c


AT32F435/437 Firmwary Library: Globals

- q -

  • QSPI1_IRQHandler() : at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c
  • qspi_busy_check() : at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c
  • qspi_busy_config() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_byte_read() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_byte_write() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_clk_division_set() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_cmd_init() : qspi_algorithm.c, FlashPrg.c
  • qspi_cmd_ly68l6400_send() : at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c
  • qspi_cmd_operation_kick() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_command_is_busy() : at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c
  • qspi_command_not_busy() : at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c
  • qspi_command_set_busy() : at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c
  • qspi_config() : project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c, project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c, project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c
  • qspi_data_once_write() : at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c
  • qspi_data_read() : project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c, project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c
  • qspi_data_write() : project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c, project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c
  • qspi_dma_enable() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_dma_rx_threshold_set() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_dma_set() : at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c
  • qspi_dma_tx_threshold_set() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_encryption_enable() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_erase() : project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c, project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c
  • qspi_flag_clear() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_flag_get() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_gpio_init() : qspi_algorithm.c, FlashPrg.c
  • qspi_half_word_read() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_half_word_write() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_interrupt_enable() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_read_data_using_pem() : at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c
  • qspi_sck_mode_set() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_word_read() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_word_write() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_write_enable() : at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c
  • qspi_xip_cache_bypass_set() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_xip_enable() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_xip_init() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_xip_init_ly68l6400() : project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c


AT32F435/437 Firmwary Library: Globals

- r -

  • randnum_test() : random.h, random.c
  • reset_phy() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/dns_client/src/at32_emac.c, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/src/at32_emac.c, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/src/at32_emac.c, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/src/at32_emac.c, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/src/at32_emac.c, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/src/at32_emac.c, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/src/at32_emac.c, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • result_error() : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c
  • rs485_config() : project/at_start_f435/examples/usart/rs485/src/main.c, project/at_start_f437/examples/usart/rs485/src/main.c
  • rs485_send_data() : project/at_start_f435/examples/usart/rs485/src/main.c, project/at_start_f437/examples/usart/rs485/src/main.c


AT32F435/437 Firmwary Library: Globals

- s -

  • sc_response_decode() : project/at_start_f435/examples/usart/smartcard/src/main.c
  • SC_USART_IRQHandler() : project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c
  • SCCB_Init() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_No_Ack() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_RD_Byte() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_RD_Reg() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_Start() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_Stop() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_WR_Byte() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_WR_Reg() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • scfg_emac_interface_set() : at32f435_437_scfg.h, at32f435_437_scfg.c
  • scfg_exint_line_config() : at32f435_437_scfg.h, at32f435_437_scfg.c
  • scfg_infrared_config() : at32f435_437_scfg.h, at32f435_437_scfg.c
  • scfg_mem_map_set() : at32f435_437_scfg.h, at32f435_437_scfg.c
  • scfg_pins_ultra_driven_enable() : at32f435_437_scfg.h, at32f435_437_scfg.c
  • scfg_reset() : at32f435_437_scfg.h, at32f435_437_scfg.c
  • scfg_xmc_mapping_swap_set() : at32f435_437_scfg.h, at32f435_437_scfg.c
  • sclk_288m_hick_config() : project/at_start_f435/examples/crm/clock_failure_detection/src/main.c, project/at_start_f437/examples/crm/clock_failure_detection/src/main.c
  • sclk_64m_hick_config() : project/at_start_f435/examples/crm/sysclk_switch/src/main.c, project/at_start_f437/examples/crm/sysclk_switch/src/main.c
  • sclk_96m_hext_config() : project/at_start_f435/examples/crm/sysclk_switch/src/main.c, project/at_start_f437/examples/crm/sysclk_switch/src/main.c
  • scr_find() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_block_read() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_block_write() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_blocks_erase() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_bus_wide_enable() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_card_info_get() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_card_init() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_deselect_select() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_device_mode_set() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_dma_config() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_init() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_irq_service() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_mult_blocks_read() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_mult_blocks_write() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_multiple_blocks_test() : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c
  • sd_power_off() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_power_on() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_read_disk() : at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c
  • sd_single_block_test() : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c
  • sd_state_get() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_status_send() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_switch() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_test_error() : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sdio_fatfs/src/main.c
  • sd_wide_bus_operation_config() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_write_disk() : at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c
  • SDIO1_IRQHandler() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • SDIO2_IRQHandler() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sdio_buffer_counter_get() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_bus_width_config() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_clock_bypass() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_clock_config() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_clock_enable() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_clock_set() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sdio_command_config() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_command_data_send() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sdio_command_response_get() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_command_state_machine_enable() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_data_config() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_data_counter_get() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_data_read() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_data_state_machine_enable() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_data_write() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_dma_enable() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_flag_clear() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_flag_get() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_flow_control_enable() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_interrupt_enable() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_io_function_enable() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_io_suspend_command_set() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_power_saving_mode_enable() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_power_set() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_power_status_get() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_read_wait_mode_set() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_read_wait_start() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_read_wait_stop() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_reset() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_response_get() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdram_copy_to_sram_dma() : at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • sdram_init() : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • sdram_init_sequence() : at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c, at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c
  • sdram_readbuffer() : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • sdram_writebuffer() : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • show_card_info() : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c
  • slib_enable() : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • speed_change() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • SPI2_I2S2EXT_IRQHandler() : project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c
  • SPI3_I2S3EXT_IRQHandler() : project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c
  • spi_byte_read() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spi_byte_write() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spi_bytes_read() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spi_bytes_write() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spi_config() : project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • spi_crc_enable() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_crc_next_transmit() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_crc_polynomial_get() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_crc_polynomial_set() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_crc_value_get() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_default_para_init() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_enable() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_frame_bit_num_set() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_half_duplex_direction_set() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_hardware_cs_output_enable() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_i2s_data_receive() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_i2s_data_transmit() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_i2s_dma_receiver_enable() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_i2s_dma_transmitter_enable() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_i2s_flag_clear() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_i2s_flag_get() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_i2s_interrupt_enable() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_i2s_reset() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_init() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_software_cs_internal_level_set() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_ti_mode_enable() : at32f435_437_spi.h, at32f435_437_spi.c
  • spiflash_init() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spiflash_page_write() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spiflash_read() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spiflash_read_id() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spiflash_read_sr1() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spiflash_sector_erase() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spiflash_wait_busy() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spiflash_write() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spiflash_write_enable() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spiflash_write_nocheck() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • sram_copy_to_sdram_dma() : at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • sram_init() : at_start_f435/examples/xmc/sram/inc/xmc_sram.h, at_start_f435/examples/xmc/sram/src/xmc_sram.c, at_start_f437/examples/xmc/sram/inc/xmc_sram.h
  • sram_readbuffer() : at_start_f435/examples/xmc/sram/inc/xmc_sram.h, at_start_f435/examples/xmc/sram/src/xmc_sram.c, at_start_f437/examples/xmc/sram/inc/xmc_sram.h
  • sram_writebuffer() : at_start_f435/examples/xmc/sram/inc/xmc_sram.h, at_start_f435/examples/xmc/sram/src/xmc_sram.c, at_start_f437/examples/xmc/sram/inc/xmc_sram.h
  • strcopy() : flash_loader_ram.c
  • SVC_Handler() : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c, project/at_start_f435/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f435/examples/can/filter/src/at32f435_437_int.c, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c, project/at_start_f435/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c, project/at_start_f435/templates/inc/at32f435_437_int.h, project/at_start_f435/templates/src/at32f435_437_int.c, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f437/templates/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_int.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_int.h, utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_int.c
  • switch_system_clock() : project/at_start_f435/examples/crm/sysclk_switch/src/main.c, project/at_start_f437/examples/crm/sysclk_switch/src/main.c
  • swj_dp_config() : project/at_start_f435/examples/gpio/swjtag_mux/src/main.c
  • system_clock_config() : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_clock.h, project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_clock.c, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_clock.h, project/at_start_f435/examples/can/communication_mode/src/at32f435_437_clock.c, project/at_start_f435/examples/can/filter/inc/at32f435_437_clock.h, project/at_start_f435/examples/can/filter/src/at32f435_437_clock.c, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_clock.h, project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_clock.c, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_clock.h, project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_clock.c, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_clock.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_clock.c, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_clock.h, project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_clock.c, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_clock.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_clock.c, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_clock.h, project/at_start_f435/examples/crc/calculation/src/at32f435_437_clock.c, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_clock.h, project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_clock.c, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_clock.h, project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_clock.c, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_clock.h, project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_clock.c, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_clock.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_clock.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_clock.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_clock.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_clock.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_clock.c, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_clock.h, project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_clock.c, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_clock.h, project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_clock.c, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_clock.h, project/at_start_f435/examples/debug/tmr1/src/at32f435_437_clock.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_clock.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_clock.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_clock.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_clock.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_clock.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_clock.c, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_clock.h, project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_clock.c, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_clock.h, project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_clock.c, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_clock.h, project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_clock.c, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_clock.h, project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_clock.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_clock.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_clock.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_clock.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_clock.c, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_clock.h, project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_clock.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_clock.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_clock.c, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_clock.h, project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_clock.c, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_clock.h, project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_clock.c, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_clock.h, project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_clock.c, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_clock.h, project/at_start_f435/examples/ertc/calendar/src/at32f435_437_clock.c, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_clock.h, project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_clock.c, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_clock.h, project/at_start_f435/examples/ertc/tamper/src/at32f435_437_clock.c, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_clock.h, project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_clock.c, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_clock.h, project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_clock.c, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_clock.h, project/at_start_f435/examples/exint/exint_config/src/at32f435_437_clock.c, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_clock.h, project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_clock.c, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_clock.h, project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_clock.c, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_clock.h, project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_clock.c, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_clock.h, project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_clock.c, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_clock.h, project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_clock.c, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_clock.h, project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_clock.c, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_clock.h, project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_clock.c, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_clock.h, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_clock.c, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_clock.h, project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_clock.c, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_clock.h, project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_clock.c, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_clock.h, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_clock.c, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_clock.h, project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_clock.c, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_clock.h, project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_clock.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_clock.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_clock.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_clock.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_clock.c, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_clock.h, project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_clock.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_clock.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_clock.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_clock.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_clock.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_clock.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_clock.c, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_clock.h, project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_clock.c, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_clock.h, project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_clock.c, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_clock.h, project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_clock.c, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_clock.h, project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_clock.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_clock.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_clock.c, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_clock.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_clock.c, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_clock.h, project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_clock.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_clock.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_clock.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_clock.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_clock.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_clock.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_clock.c, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_clock.h, project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_clock.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_clock.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_clock.c, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_clock.h, project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_clock.c, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_clock.h, project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_clock.c, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_clock.h, project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_clock.c, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_clock.h, project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_clock.c, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_clock.h, project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_clock.c, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_clock.h, project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_clock.c, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_clock.h, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_clock.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_clock.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_clock.c, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_clock.h, project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_clock.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_clock.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_clock.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_clock.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_clock.c, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_clock.h, project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_clock.c, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_clock.h, project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/dma/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/irda/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/irda/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/polling/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/polling/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/printf/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/printf/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/rs485/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/smartcard/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/synchronous/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/audio/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/msc/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/printer/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_clock.c, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_clock.h, project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_clock.c, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_clock.h, project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_clock.c, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_clock.h, project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_clock.c, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_clock.h, project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_clock.c, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_clock.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_clock.c, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_clock.h, project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_clock.c, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_clock.h, project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_clock.c, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_clock.h, project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_clock.c, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_clock.h, project/at_start_f435/examples/xmc/psram/src/at32f435_437_clock.c, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_clock.h, project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_clock.c, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_clock.h, project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_clock.c, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_clock.h, project/at_start_f435/examples/xmc/sram/src/at32f435_437_clock.c, project/at_start_f435/templates/inc/at32f435_437_clock.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_clock.h, project/at_start_f437/examples/acc/calibration/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/conversion_abort/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/current_vref_value_check/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/edma_double_buffer/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/internal_temperature_sensor/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/resolution_6bit/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/software_trigger_repeat/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/vbat_monitor/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/voltage_monitoring/src/at32f435_437_clock.c, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_clock.h, project/at_start_f437/examples/can/communication_mode/src/at32f435_437_clock.c, project/at_start_f437/examples/can/filter/inc/at32f435_437_clock.h, project/at_start_f437/examples/can/filter/src/at32f435_437_clock.c, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_clock.h, project/at_start_f437/examples/can/loopback_mode/src/at32f435_437_clock.c, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_clock.h, project/at_start_f437/examples/cortex_m4/bit_band/src/at32f435_437_clock.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_clock.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_clock.h, project/at_start_f437/examples/cortex_m4/fpu/src/at32f435_437_clock.c, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_clock.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/src/at32f435_437_clock.c, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_clock.h, project/at_start_f437/examples/crc/calculation/src/at32f435_437_clock.c, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_clock.h, project/at_start_f437/examples/crm/clock_failure_detection/src/at32f435_437_clock.c, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_clock.h, project/at_start_f437/examples/crm/pll_parameter_calculate/src/at32f435_437_clock.c, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_clock.h, project/at_start_f437/examples/crm/sysclk_switch/src/at32f435_437_clock.c, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_clock.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/at32f435_437_clock.c, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_clock.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/src/at32f435_437_clock.c, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_clock.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/src/at32f435_437_clock.c, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_clock.h, project/at_start_f437/examples/dac/one_dac_noisewave/src/at32f435_437_clock.c, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_clock.h, project/at_start_f437/examples/dac/two_dac_trianglewave/src/at32f435_437_clock.c, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_clock.h, project/at_start_f437/examples/debug/tmr1/src/at32f435_437_clock.c, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_clock.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/src/at32f435_437_clock.c, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_clock.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/src/at32f435_437_clock.c, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_clock.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/at32f435_437_clock.c, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_clock.h, project/at_start_f437/examples/dma/flash_to_sram/src/at32f435_437_clock.c, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_clock.h, project/at_start_f437/examples/dvp/ov2640_capture/src/at32f435_437_clock.c, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_clock.h, project/at_start_f437/examples/dvp/ov5640_capture/src/at32f435_437_clock.c, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_clock.h, project/at_start_f437/examples/edma/burst_mode/src/at32f435_437_clock.c, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_clock.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/src/at32f435_437_clock.c, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_clock.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/at32f435_437_clock.c, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_clock.h, project/at_start_f437/examples/edma/flash_to_sram/src/at32f435_437_clock.c, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_clock.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_clock.c, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_clock.h, project/at_start_f437/examples/edma/link_list_mode/src/at32f435_437_clock.c, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_clock.h, project/at_start_f437/examples/edma/two_dimension_mode/src/at32f435_437_clock.c, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_clock.h, project/at_start_f437/examples/emac/dns_client/src/at32f435_437_clock.c, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_clock.h, project/at_start_f437/examples/emac/http_server/src/at32f435_437_clock.c, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_clock.h, project/at_start_f437/examples/emac/iperf/src/at32f435_437_clock.c, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_clock.h, project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_clock.c, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_clock.h, project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_clock.c, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_clock.h, project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_clock.c, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_clock.h, project/at_start_f437/examples/emac/telnet/src/at32f435_437_clock.c, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_clock.h, project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_clock.c, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_clock.h, project/at_start_f437/examples/ertc/bpr_domain/src/at32f435_437_clock.c, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_clock.h, project/at_start_f437/examples/ertc/calendar/src/at32f435_437_clock.c, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_clock.h, project/at_start_f437/examples/ertc/lick_calibration/src/at32f435_437_clock.c, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_clock.h, project/at_start_f437/examples/ertc/tamper/src/at32f435_437_clock.c, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_clock.h, project/at_start_f437/examples/ertc/time_stamp/src/at32f435_437_clock.c, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_clock.h, project/at_start_f437/examples/ertc/wakeup_timer/src/at32f435_437_clock.c, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_clock.h, project/at_start_f437/examples/exint/exint_config/src/at32f435_437_clock.c, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_clock.h, project/at_start_f437/examples/exint/exint_software_trigger/src/at32f435_437_clock.c, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_clock.h, project/at_start_f437/examples/flash/fap_enable/src/at32f435_437_clock.c, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_clock.h, project/at_start_f437/examples/flash/flash_write_read/src/at32f435_437_clock.c, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_clock.h, project/at_start_f437/examples/gpio/io_toggle/src/at32f435_437_clock.c, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_clock.h, project/at_start_f437/examples/gpio/led_toggle/src/at32f435_437_clock.c, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_clock.h, project/at_start_f437/examples/gpio/swjtag_mux/src/at32f435_437_clock.c, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_clock.h, project/at_start_f437/examples/i2c/communication_dma/src/at32f435_437_clock.c, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_clock.h, project/at_start_f437/examples/i2c/communication_int/src/at32f435_437_clock.c, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_clock.h, project/at_start_f437/examples/i2c/communication_poll/src/at32f435_437_clock.c, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_clock.h, project/at_start_f437/examples/i2c/communication_smbus/src/at32f435_437_clock.c, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_clock.h, project/at_start_f437/examples/i2c/eeprom/src/at32f435_437_clock.c, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_clock.h, project/at_start_f437/examples/i2s/fullduplex_dma/src/at32f435_437_clock.c, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_clock.h, project/at_start_f437/examples/i2s/halfduplex_dma/src/at32f435_437_clock.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_clock.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/at32f435_437_clock.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_clock.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_clock.c, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_clock.h, project/at_start_f437/examples/irtmr/irtmr_output/src/at32f435_437_clock.c, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_clock.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_clock.c, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_clock.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_clock.c, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_clock.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_clock.c, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_clock.h, project/at_start_f437/examples/pwc/ldo_set/src/at32f435_437_clock.c, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_clock.h, project/at_start_f437/examples/pwc/power_voltage_monitor/src/at32f435_437_clock.c, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_clock.h, project/at_start_f437/examples/pwc/sleep_tmr2/src/at32f435_437_clock.c, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_clock.h, project/at_start_f437/examples/pwc/sleep_usart1/src/at32f435_437_clock.c, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_clock.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/src/at32f435_437_clock.c, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_clock.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/src/at32f435_437_clock.c, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_clock.h, project/at_start_f437/examples/qspi/command_port_using_dma/src/at32f435_437_clock.c, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_clock.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_clock.c, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_clock.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_clock.c, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_clock.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/src/at32f435_437_clock.c, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_clock.h, project/at_start_f437/examples/qspi/command_port_using_polling/src/at32f435_437_clock.c, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_clock.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_clock.c, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_clock.h, project/at_start_f437/examples/qspi/xip_port_write_read/src/at32f435_437_clock.c, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_clock.h, project/at_start_f437/examples/scfg/mem_map_sel/src/at32f435_437_clock.c, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_clock.h, project/at_start_f437/examples/sdio/sd_mmc_card/src/at32f435_437_clock.c, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_clock.h, project/at_start_f437/examples/sdio/sdio_fatfs/src/at32f435_437_clock.c, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_clock.h, project/at_start_f437/examples/spi/crc_transfer_polling/src/at32f435_437_clock.c, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_clock.h, project/at_start_f437/examples/spi/fullduplex_polling/src/at32f435_437_clock.c, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_clock.h, project/at_start_f437/examples/spi/halfduplex_interrupt/src/at32f435_437_clock.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_clock.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_clock.c, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_clock.h, project/at_start_f437/examples/spi/only_receive_mode_polling/src/at32f435_437_clock.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_clock.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/at32f435_437_clock.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_clock.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_clock.c, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_clock.h, project/at_start_f437/examples/spi/w25q_flash/src/at32f435_437_clock.c, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_clock.h, project/at_start_f437/examples/sram/extend_sram/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/6_steps/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/7_pwm_output/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/cascade_synchro/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/complementary_signals/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/dma/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/dma_burst/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/encoder_tmr2/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/external_clock/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/hang_mode/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/input_capture/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/oc_high/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/oc_low/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/one_cycle/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/parallel_synchro/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/pwm_input/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/pwm_input_dma/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/pwm_output_simulate/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/timer_base/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/tmr1_synchro/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/tmr2_32bit/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/half_duplex/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/hw_flow_control/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/idle_detection/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/interrupt/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/irda/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/irda/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/polling/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/polling/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/printf/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/printf/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/receiver_mute/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/rs485/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/smartcard/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/synchronous/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/tx_rx_swap/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/audio/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/composite_audio_hid/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/custom_hid/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/keyboard/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/mouse/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/msc/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/printer/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/vcp_loopback/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/virtual_comport/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_host/hid_demo/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_host/msc_only_fat32/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/src/at32f435_437_clock.c, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_clock.h, project/at_start_f437/examples/wdt/wdt_reset/src/at32f435_437_clock.c, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_clock.h, project/at_start_f437/examples/wdt/wdt_standby/src/at32f435_437_clock.c, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_clock.h, project/at_start_f437/examples/wwdt/wwdt_reset/src/at32f435_437_clock.c, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_clock.h, project/at_start_f437/examples/xmc/lcd_8bit/src/at32f435_437_clock.c, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_clock.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/src/at32f435_437_clock.c, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_clock.h, project/at_start_f437/examples/xmc/nand_flash/ecc/src/at32f435_437_clock.c, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_clock.h, project/at_start_f437/examples/xmc/nand_flash/nand/src/at32f435_437_clock.c, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_clock.h, project/at_start_f437/examples/xmc/nor_flash/src/at32f435_437_clock.c, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_clock.h, project/at_start_f437/examples/xmc/psram/src/at32f435_437_clock.c, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_clock.h, project/at_start_f437/examples/xmc/sdram_basic/src/at32f435_437_clock.c, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_clock.h, project/at_start_f437/examples/xmc/sdram_dma/src/at32f435_437_clock.c, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_clock.h, project/at_start_f437/examples/xmc/sram/src/at32f435_437_clock.c, project/at_start_f437/templates/inc/at32f435_437_clock.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_clock.h, utilities/at32f435_437_freertos_demo/src/at32f435_437_clock.c, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_clock.h, utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_clock.c, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_clock.h, utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_clock.c, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_clock.h, utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_clock.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_clock.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_clock.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_clock.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/at32f435_437_clock.c, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_clock.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/src/at32f435_437_clock.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_clock.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_clock.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_clock.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_clock.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_clock.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_clock.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_clock.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_clock.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_clock.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_clock.c
  • system_clock_config_200mhz() : project/at_start_f435/examples/crm/pll_parameter_calculate/src/main.c
  • system_clock_recover() : project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/main.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/main.c, project/at_start_f435/examples/pwc/ldo_set/src/main.c, project/at_start_f435/examples/usb_device/keyboard/src/main.c, project/at_start_f435/examples/usb_device/mouse/src/main.c
  • system_core_clock_update() : system_at32f435_437.c, system_at32f435_437.h
  • SystemInit() : system_at32f435_437.c, system_at32f435_437.h
  • systick_clock_source_config() : at32f435_437_misc.h, at32f435_437_misc.c
  • SysTick_Configuration() : project/at_start_f435/examples/tmr/6_steps/src/main.c
  • systick_handler() : project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/systick_interrupt/src/main.c, project/at_start_f437/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c
  • SysTick_Handler() : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c, project/at_start_f435/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f435/examples/can/filter/src/at32f435_437_int.c, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c, project/at_start_f435/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c, project/at_start_f435/templates/inc/at32f435_437_int.h, project/at_start_f435/templates/src/at32f435_437_int.c, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f437/templates/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_int.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_int.h, utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_int.c


AT32F435/437 Firmwary Library: Globals

- t -

  • TAMP_STAMP_IRQHandler() : project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c
  • tcp_client_init() : tcp_client.h, tcp_client.c
  • tcp_client_recv() : tcp_client.c
  • tcp_client_send_data() : tcp_client.h, tcp_client.c
  • tcp_connected() : tcp_client.c
  • tcp_server_accept() : tcp_server.c
  • tcp_server_init() : tcp_server.h, tcp_server.c
  • tcp_server_recv() : tcp_server.c
  • tcpip_stack_init() : project/at_start_f437/examples/emac/dns_client/inc/netconf.h, project/at_start_f437/examples/emac/dns_client/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/netconf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/netconf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • time_update() : project/at_start_f437/examples/emac/dns_client/inc/netconf.h, project/at_start_f437/examples/emac/dns_client/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/netconf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/netconf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • TMR1_BRK_TMR9_IRQHandler() : project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c
  • tmr1_config() : project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f435/examples/exint/exint_software_trigger/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f437/examples/exint/exint_software_trigger/src/main.c
  • TMR1_OVF_TMR10_IRQHandler() : project/at_start_f435/examples/debug/tmr1/src/main.c, project/at_start_f435/examples/edma/burst_mode/src/main.c, project/at_start_f435/examples/exint/exint_software_trigger/src/main.c, project/at_start_f435/examples/tmr/timer_base/src/main.c
  • TMR1_TRG_HALL_TMR11_IRQHandler() : project/at_start_f435/examples/tmr/6_steps/src/main.c
  • tmr2_config() : project/at_start_f435/examples/pwc/sleep_tmr2/src/main.c
  • TMR2_GLOBAL_IRQHandler() : project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c
  • TMR3_GLOBAL_IRQHandler() : project/at_start_f435/examples/tmr/input_capture/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/tmr.c, at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/tmr.c, at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c, at32f437_emac_iap_demo/source_code/app_led3_toggle/src/tmr.c, at32f437_emac_iap_demo/source_code/bootloader/src/tmr.c
  • TMR5_GLOBAL_IRQHandler() : project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c
  • TMR6_DAC_GLOBAL_IRQHandler() : project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c, project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c, project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_int.c
  • tmr_32_bit_function_enable() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_base_init() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_brkdt_config() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_brkdt_default_para_init() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_channel1_input_select() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_channel_buffer_enable() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_channel_dma_select() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_channel_enable() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_channel_value_get() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_channel_value_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_clock_source_div_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_cnt_dir_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_counter_enable() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_counter_value_get() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_counter_value_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_div_value_get() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_div_value_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_dma_control_config() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_dma_request_enable() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_encoder_mode_config() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_event_sw_trigger() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_external_clock_config() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_external_clock_mode1_config() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_external_clock_mode2_config() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_flag_clear() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_flag_get() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_force_output_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_hall_select() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_init() : at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/tmr.h, at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/tmr.c, at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/tmr.c, at32f435_437_usart_iap_demo/source_code/bootloader/inc/tmr.h, at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c, at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/tmr.h, at32f437_emac_iap_demo/source_code/app_led3_toggle/src/tmr.c, at32f437_emac_iap_demo/source_code/bootloader/src/tmr.c
  • tmr_input_channel_divider_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_input_channel_filter_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_input_channel_init() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_input_default_para_init() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_internal_clock_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_interrupt_enable() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_iremap_config() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_one_cycle_mode_enable() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_output_channel_buffer_enable() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_output_channel_config() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_output_channel_immediately_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_output_channel_mode_select() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_output_channel_polarity_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_output_channel_switch_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_output_default_para_init() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_output_enable() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_overflow_event_disable() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_overflow_request_source_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_period_buffer_enable() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_period_value_get() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_period_value_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_primary_mode_select() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_pwm_input_config() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_repetition_counter_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_reset() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_sub_mode_select() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_sub_sync_mode_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_trgout2_enable() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_trigger_input_select() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • touch_adjust() : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c
  • touch_pin_init() : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c
  • touch_read_1byte() : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c
  • touch_read_ad() : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c
  • touch_read_x_or_y() : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c
  • touch_read_xy() : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c
  • touch_scan() : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c
  • touch_write_1byte() : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c
  • tx_data_fill() : project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/w25q_flash/src/main.c


AT32F435/437 Firmwary Library: Globals

- u -

  • uart_init() : project/at_start_f435/examples/edma/link_list_mode/src/main.c, project/at_start_f435/examples/tmr/input_capture/src/main.c, app_led3_toggle/inc/usart.h, app_led3_toggle/src/usart.c, app_led4_toggle/src/usart.c, bootloader/inc/usart.h, bootloader/src/usart.c
  • uart_print_init() : at32f435_437_board.c, at32f435_437_board.h
  • uhost_init_handler() : usbh_hid_class.c, usbh_msc_class.c
  • uhost_process_handler() : usbh_hid_class.c, usbh_msc_class.c
  • uhost_request_handler() : usbh_hid_class.c, usbh_msc_class.c
  • uhost_reset_handler() : usbh_hid_class.c, usbh_msc_class.c
  • UnInit() : FlashOS.h, FlashPrg.c
  • uninit_clk() : qspi_algorithm.c, FlashPrg.c
  • UsageFault_Handler() : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c, project/at_start_f435/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f435/examples/can/filter/src/at32f435_437_int.c, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c, project/at_start_f435/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c, project/at_start_f435/templates/inc/at32f435_437_int.h, project/at_start_f435/templates/src/at32f435_437_int.c, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f437/templates/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/src/at32f435_437_int.c, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_int.h, utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_int.c
  • usart1_config() : project/at_start_f435/examples/pwc/sleep_usart1/src/main.c
  • USART1_IRQHandler() : project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c, app_led3_toggle/src/usart.c, app_led4_toggle/src/usart.c, bootloader/src/usart.c
  • USART2_IRQHandler() : project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/rs485/src/main.c, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c
  • USART3_IRQHandler() : project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c
  • usart_break_bit_num_set() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_break_send() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_clock_config() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_clock_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_configuration() : project/at_start_f435/examples/usart/half_duplex/src/main.c, project/at_start_f435/examples/usart/hw_flow_control/src/main.c, project/at_start_f435/examples/usart/idle_detection/src/main.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/irda/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/receiver_mute/src/main.c, project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c
  • usart_data_receive() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_data_transmit() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_de_polarity_set() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_dma_receiver_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_dma_transmitter_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_flag_clear() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_flag_get() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_gpio_config() : project/at_start_f435/examples/usb_device/virtual_comport/src/main.c
  • usart_hardware_flow_control_set() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_id_bit_num_set() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_init() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_interrupt_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_irda_low_power_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_irda_mode_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_irda_smartcard_division_set() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_lin_mode_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_parity_selection_config() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_receive_data() : project/at_start_f435/examples/usb_device/virtual_comport/src/main.c
  • usart_receiver_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_receiver_mute_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_reset() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_rs485_delay_time_config() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_rs485_mode_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_send_data() : project/at_start_f435/examples/usb_device/virtual_comport/src/main.c
  • usart_single_line_halfduplex_select() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_smartcard_guard_time_set() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_smartcard_mode_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_smartcard_nack_set() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_spi_configuration() : project/at_start_f435/examples/usart/synchronous/src/main.c
  • usart_transmit_receive_pin_swap() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_transmitter_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_wakeup_id_set() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_wakeup_mode_set() : at32f435_437_usart.h, at32f435_437_usart.c
  • usb_bot_request() : usbh_msc_bot_scsi.c, usbh_msc_bot_scsi.h
  • usb_clock48m_select() : project/at_start_f435/examples/acc/calibration/src/main.c, project/at_start_f435/examples/usb_device/audio/src/main.c, project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f435/examples/usb_device/custom_hid/src/main.c, project/at_start_f435/examples/usb_device/keyboard/src/main.c, project/at_start_f435/examples/usb_device/mouse/src/main.c, project/at_start_f435/examples/usb_device/msc/src/main.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/printer/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c, project/at_start_f435/examples/usb_host/hid_demo/src/main.c, project/at_start_f435/examples/usb_host/msc_only_fat32/src/main.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c
  • usb_connect() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_core_config() : usb_core.h, usb_core.c
  • usb_delay_ms() : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/acc/calibration/src/main.c, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c
  • usb_delay_us() : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/acc/calibration/src/main.c, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c
  • usb_disconnect() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_ept0_setup() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_ept0_start() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_ept_clear_stall() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_ept_close() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_ept_default_init() : usbd_core.c
  • usb_ept_in_clear() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_ept_in_interrupt() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_ept_open() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_ept_out_clear() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_ept_out_interrupt() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_ept_stall() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_flush_rx_fifo() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_flush_tx_fifo() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_get_all_in_interrupt() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_get_all_out_interrupt() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_global_clear_interrupt() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_global_get_all_interrupt() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_global_init() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_global_interrupt_enable() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_global_power_on() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_global_reset() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_global_select_core() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_global_set_mode() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_gpio_config() : project/at_start_f435/examples/acc/calibration/src/main.c, project/at_start_f435/examples/usb_device/audio/src/main.c, project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f435/examples/usb_device/custom_hid/src/main.c, project/at_start_f435/examples/usb_device/keyboard/src/main.c, project/at_start_f435/examples/usb_device/mouse/src/main.c, project/at_start_f435/examples/usb_device/msc/src/main.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/printer/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c, project/at_start_f435/examples/usb_host/hid_demo/src/main.c, project/at_start_f435/examples/usb_host/msc_only_fat32/src/main.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c
  • usb_hc_enable() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_hch_halt() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_hch_read_interrupt() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_hid_buf_process() : audio_hid_class.c, custom_hid_class.c
  • usb_hid_keyboard_send_char() : keyboard_class.c, keyboard_class.h
  • usb_hid_mouse_send() : mouse_class.c, mouse_class.h
  • usb_host_disable() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_iap_class_send_report() : hid_iap_class.c, hid_iap_class.h
  • usb_interrupt_disable() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_interrupt_enable() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_keyboard_class_send_report() : keyboard_class.c, keyboard_class.h
  • usb_low_power_wakeup_config() : project/at_start_f435/examples/acc/calibration/src/main.c, project/at_start_f435/examples/usb_device/audio/src/main.c, project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f435/examples/usb_device/custom_hid/src/main.c, project/at_start_f435/examples/usb_device/keyboard/src/main.c, project/at_start_f435/examples/usb_device/mouse/src/main.c, project/at_start_f435/examples/usb_device/msc/src/main.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/printer/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c, project/at_start_f435/examples/usb_host/hid_demo/src/main.c, project/at_start_f435/examples/usb_host/msc_only_fat32/src/main.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c
  • usb_mouse_class_send_report() : mouse_class.c, mouse_class.h
  • usb_open_phy_clk() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_port_power_on() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_printer_get_rxdata() : printer_class.h
  • usb_printer_send_data() : printer_class.c, printer_class.h
  • usb_re_connect() : project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c
  • usb_read_packet() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_remote_wkup_clear() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_remote_wkup_set() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_reset() : project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c
  • usb_set_address() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_set_rx_fifo() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_set_tx_fifo() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_stop_phy_clk() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_suspend_status_get() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_usart_config() : cdc_class.c, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c
  • usb_vcp_cmd_process() : cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c
  • usb_vcp_get_rxdata() : cdc_class.c, cdc_class.h, cdc_msc_class.h
  • usb_vcp_send_data() : cdc_class.c, cdc_class.h, cdc_msc_class.h
  • usb_vcpkybrd_class_send_report() : cdc_keyboard_class.c, cdc_keyboard_class.h
  • usb_vcpkybrd_keyboard_send_char() : cdc_keyboard_class.c, cdc_keyboard_class.h
  • usb_vcpkybrd_vcp_get_rxdata() : cdc_keyboard_class.c, cdc_keyboard_class.h
  • usb_vcpkybrd_vcp_send_data() : cdc_keyboard_class.c, cdc_keyboard_class.h
  • usb_write_empty_txfifo() : usbd_int.h, usbd_int.c
  • usb_write_packet() : at32f435_437_usb.h, at32f435_437_usb.c
  • usbd_clear_feature() : usbd_sdr.c
  • usbd_clear_stall() : usbd_core.c
  • usbd_connect() : usbd_core.c
  • usbd_connect_state_get() : usbd_core.c
  • usbd_core_in_handler() : usbd_core.c
  • usbd_core_init() : usbd_core.c
  • usbd_core_out_handler() : usbd_core.c
  • usbd_core_setup_handler() : usbd_core.c
  • usbd_ctrl_recv() : usbd_core.c
  • usbd_ctrl_recv_status() : usbd_core.c
  • usbd_ctrl_send() : usbd_core.c
  • usbd_ctrl_send_status() : usbd_core.c
  • usbd_ctrl_unsupport() : usbd_core.c
  • usbd_device_request() : usbd_sdr.h, usbd_sdr.c
  • usbd_discon_handler() : usbd_int.h, usbd_int.c
  • usbd_disconnect() : usbd_core.c
  • usbd_endpoint_request() : usbd_sdr.h, usbd_sdr.c
  • usbd_enter_suspend() : usbd_core.c
  • usbd_enumdone_handler() : usbd_int.h, usbd_int.c
  • usbd_ept_close() : usbd_core.c
  • usbd_ept_handler() : usbd_int.h
  • usbd_ept_open() : usbd_core.c
  • usbd_ept_recv() : usbd_core.c
  • usbd_ept_send() : usbd_core.c
  • usbd_fifo_alloc() : usbd_core.c
  • usbd_flush_tx_fifo() : usbd_core.c
  • usbd_get_configuration() : usbd_sdr.c
  • usbd_get_descriptor() : usbd_sdr.c
  • usbd_get_recv_len() : usbd_core.c
  • usbd_get_status() : usbd_sdr.c
  • usbd_hid_iap_in_complete() : hid_iap_class.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • usbd_hid_iap_process() : hid_iap_class.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • usbd_incomisioin_handler() : usbd_int.h, usbd_int.c
  • usbd_incomisoout_handler() : usbd_int.h, usbd_int.c
  • usbd_inept_handler() : usbd_int.h, usbd_int.c
  • usbd_int_to_unicode() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • usbd_interface_request() : usbd_sdr.h, usbd_sdr.c
  • usbd_irq_handler() : usbd_int.h, usbd_int.c
  • usbd_outept_handler() : usbd_int.h, usbd_int.c
  • usbd_remote_wakeup() : usbd_core.c
  • usbd_reset_handler() : usbd_int.h, usbd_int.c
  • usbd_rxflvl_handler() : usbd_int.h, usbd_int.c
  • usbd_set_address() : usbd_sdr.c
  • usbd_set_configuration() : usbd_sdr.c
  • usbd_set_device_addr() : usbd_core.c
  • usbd_set_feature() : usbd_sdr.c
  • usbd_set_stall() : usbd_core.c
  • usbd_setup_request_parse() : usbd_sdr.h, usbd_sdr.c
  • usbd_sof_handler() : usbd_int.h, usbd_int.c
  • usbd_suspend_handler() : usbd_int.h, usbd_int.c
  • usbd_unicode_convert() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • usbd_wakeup_handler() : usbd_int.h, usbd_int.c
  • usbh_active_vbus() : usbh_core.c
  • usbh_alloc_address() : usbh_core.c
  • usbh_alloc_channel() : usbh_core.c
  • usbh_attached() : usbh_core.c
  • usbh_bot_cbw() : usbh_msc_bot_scsi.c
  • usbh_bulk_recv() : usbh_core.c
  • usbh_bulk_send() : usbh_core.c
  • usbh_cfg_default_init() : usbh_core.c
  • usbh_ch_disable() : usbh_core.c
  • usbh_check_csw() : usbh_msc_bot_scsi.c
  • usbh_class() : usbh_core.c
  • usbh_class_request() : usbh_core.c
  • usbh_clear_dev_feature() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_clear_endpoint_feature() : usbh_hid_class.c
  • usbh_clear_ept_feature() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_cmd_capacity10() : usbh_msc_bot_scsi.c
  • usbh_cmd_inquiry() : usbh_msc_bot_scsi.c
  • usbh_cmd_read() : usbh_msc_bot_scsi.c
  • usbh_cmd_requset_sense() : usbh_msc_bot_scsi.c
  • usbh_cmd_test_unit_ready() : usbh_msc_bot_scsi.c
  • usbh_cmd_write() : usbh_msc_bot_scsi.c
  • usbh_core_init() : usbh_core.c
  • usbh_ctrl_complete_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_data_in_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_data_in_wait_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_data_out_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_data_out_wait_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_error_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_recv_data() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_request() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_result_check() : usbh_core.c
  • usbh_ctrl_send_data() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_send_setup() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_setup_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_setup_wait_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_stall_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_status_in_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_status_in_wait_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_status_out_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_status_out_wait_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_transfer_loop() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_disconnect() : usbh_core.c
  • usbh_disconnect_handler() : usbh_int.h, usbh_int.c
  • usbh_enter_suspend() : usbh_core.c
  • usbh_enum_handler() : usbh_core.c
  • usbh_enumeration() : usbh_core.c
  • usbh_find_interface() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_free_channel() : usbh_core.c
  • usbh_fsls_clksel() : at32f435_437_usb.h, at32f435_437_usb.c
  • usbh_get_configure_descriptor() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_get_descriptor() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_get_device_descriptor() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_get_frame() : at32f435_437_usb.h, at32f435_437_usb.c
  • usbh_get_free_channel() : usbh_core.c
  • usbh_get_next_header() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_get_sting_descriptor() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_get_urb_status() : usbh_core.c
  • usbh_hc_open() : usbh_core.c
  • usbh_hch_handler() : usbh_int.h, usbh_int.c
  • usbh_hch_in_handler() : usbh_int.h, usbh_int.c
  • usbh_hch_out_handler() : usbh_int.h, usbh_int.c
  • usbh_hid_get_desc() : usbh_hid_class.c
  • usbh_hid_get_report() : usbh_hid_class.c
  • usbh_hid_keyboard_decode() : usbh_hid_keyboard.c, usbh_hid_keyboard.h
  • usbh_hid_mouse_button_press() : usbh_hid_mouse.c
  • usbh_hid_mouse_button_release() : usbh_hid_mouse.c
  • usbh_hid_mouse_decode() : usbh_hid_mouse.c, usbh_hid_mouse.h
  • usbh_hid_mouse_position() : usbh_hid_mouse.c
  • usbh_hid_mouse_process() : usbh_hid_mouse.c
  • usbh_hid_set_idle() : usbh_hid_class.c
  • usbh_hid_set_protocol() : usbh_hid_class.c
  • usbh_in_out_request() : usbh_core.c
  • usbh_interrupt_recv() : usbh_core.c
  • usbh_interrupt_send() : usbh_core.c
  • usbh_irq_handler() : usbh_int.h, usbh_int.c
  • usbh_isoc_recv() : usbh_core.c
  • usbh_isoc_send() : usbh_core.c
  • usbh_loop_handler() : usbh_core.c
  • usbh_msc_bot_scsi_capacity() : usbh_msc_bot_scsi.c, usbh_msc_bot_scsi.h
  • usbh_msc_bot_scsi_get_inquiry() : usbh_msc_bot_scsi.c, usbh_msc_bot_scsi.h
  • usbh_msc_bot_scsi_read() : usbh_msc_bot_scsi.c, usbh_msc_bot_scsi.h
  • usbh_msc_bot_scsi_request_sense() : usbh_msc_bot_scsi.c, usbh_msc_bot_scsi.h
  • usbh_msc_bot_scsi_test_unit_ready() : usbh_msc_bot_scsi.c, usbh_msc_bot_scsi.h
  • usbh_msc_bot_scsi_write() : usbh_msc_bot_scsi.c, usbh_msc_bot_scsi.h
  • usbh_msc_clear_feature() : usbh_msc_class.c
  • usbh_msc_get_max_lun() : usbh_msc_class.c
  • usbh_msc_is_ready() : usbh_msc_class.c, usbh_msc_class.h
  • usbh_msc_read() : usbh_msc_class.c, usbh_msc_class.h
  • usbh_msc_rw_handle() : usbh_msc_class.c, usbh_msc_class.h
  • usbh_msc_write() : usbh_msc_class.c, usbh_msc_class.h
  • usbh_parse_configure_desc() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_parse_dev_desc() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_parse_endpoint_desc() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_parse_interface_desc() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_parse_string_desc() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_port_handler() : usbh_int.h, usbh_int.c
  • usbh_reset_port() : usbh_core.c
  • usbh_resume() : usbh_core.c
  • usbh_rx_qlvl_handler() : usbh_int.h, usbh_int.c
  • usbh_set_address() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_set_configuration() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_set_feature() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_set_interface() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_set_toggle() : usbh_core.c
  • usbh_sof_handler() : usbh_int.h, usbh_int.c
  • usbh_suspend() : usbh_core.c
  • usbh_user_active_vbus() : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_user_application() : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_user_attached() : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_user_disconnect() : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_user_enumeration_done() : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_user_init() : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_user_mfc_string() : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_user_not_support() : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_user_product_string() : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_user_reset() : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_user_serial_string() : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_user_speed() : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_wakeup() : usbh_core.c
  • usbh_wakeup_handler() : usbh_int.h, usbh_int.c


AT32F435/437 Firmwary Library: Globals

- v -

  • Verify() : FlashOS.h


AT32F435/437 Firmwary Library: Globals

- w -

  • wakeup_timer_config() : project/at_start_f435/examples/ertc/wakeup_timer/src/main.c
  • wdt_counter_reload() : at32f435_437_wdt.h, at32f435_437_wdt.c
  • wdt_divider_set() : at32f435_437_wdt.h, at32f435_437_wdt.c
  • wdt_enable() : at32f435_437_wdt.h, at32f435_437_wdt.c
  • wdt_flag_get() : at32f435_437_wdt.h, at32f435_437_wdt.c
  • wdt_register_write_enable() : at32f435_437_wdt.h, at32f435_437_wdt.c
  • wdt_reload_value_set() : at32f435_437_wdt.h, at32f435_437_wdt.c
  • wdt_window_counter_set() : at32f435_437_wdt.h, at32f435_437_wdt.c
  • wwdt_counter_set() : at32f435_437_wwdt.h, at32f435_437_wwdt.c
  • wwdt_divider_set() : at32f435_437_wwdt.h, at32f435_437_wwdt.c
  • wwdt_enable() : at32f435_437_wwdt.h, at32f435_437_wwdt.c
  • wwdt_flag_clear() : at32f435_437_wwdt.h, at32f435_437_wwdt.c
  • wwdt_flag_get() : at32f435_437_wwdt.h, at32f435_437_wwdt.c
  • wwdt_interrupt_enable() : at32f435_437_wwdt.h, at32f435_437_wwdt.c
  • wwdt_reset() : at32f435_437_wwdt.h, at32f435_437_wwdt.c
  • wwdt_window_counter_set() : at32f435_437_wwdt.h, at32f435_437_wwdt.c


AT32F435/437 Firmwary Library: Globals

- x -

  • xip_init_ly68l6400_config() : at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c
  • xmc_ecc_get() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_ext_timing_config() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_flag_clear() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_flag_status_get() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_init() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c, at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c
  • xmc_interrupt_enable() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_nand_default_para_init() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_nand_ecc_enable() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_nand_enable() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_nand_init() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_nand_reset() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_nand_timing_config() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_nand_timing_default_para_init() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_nor_sram_enable() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_nor_sram_init() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_nor_sram_reset() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_nor_sram_timing_config() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_norsram_default_para_init() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_norsram_timing_default_para_init() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_pccard_default_para_init() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_pccard_enable() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_pccard_init() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_pccard_reset() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_pccard_timing_config() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_pccard_timing_default_para_init() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_sdram_auto_refresh_set() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_sdram_cmd() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_sdram_default_para_init() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_sdram_init() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_sdram_refresh_counter_set() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_sdram_reset() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_sdram_status_get() : at32f435_437_xmc.h, at32f435_437_xmc.c


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- g -

  • g_audio_hid_usb_desc : audio_hid_desc.h
  • g_custom_hid_usb_desc : custom_hid_desc.h
  • g_file_attr : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c, at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • g_hidiap_usb_desc : hid_iap_desc.h
  • g_keyboard_usb_desc : keyboard_desc.h
  • g_mouse_usb_desc : mouse_desc.h
  • g_speed : project/at_start_f435/templates/src/main.c, project/at_start_f437/examples/emac/dns_client/src/main.c, project/at_start_f437/examples/emac/http_server/src/main.c, project/at_start_f437/examples/emac/iperf/src/main.c, project/at_start_f437/examples/emac/mqtt_client/src/main.c, project/at_start_f437/examples/emac/tcp_client/src/main.c, project/at_start_f437/examples/emac/tcp_server/src/main.c, project/at_start_f437/examples/emac/telnet/src/main.c, project/at_start_f437/examples/emac/wake_on_lan/src/main.c, project/at_start_f437/templates/src/main.c
  • g_usbd_audio_hid_report : audio_hid_desc.h
  • g_usbd_custom_hid_report : custom_hid_desc.h
  • g_usbd_desc_buffer : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • g_usbd_hidiap_report : hid_iap_desc.h
  • g_usbd_keyboard_report : keyboard_desc.h
  • g_usbd_mouse_report : mouse_desc.h
  • g_usbd_vcpkybrd_hid_report : cdc_keyboard_desc.h
  • g_vcpkybrd_hid_usb_desc : cdc_keyboard_desc.h
  • GBLUE : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • generate_julia_fpu() : at_start_f435/examples/cortex_m4/fpu/inc/julia_fpu.h, at_start_f435/examples/cortex_m4/fpu/src/julia_fpu.c
  • get_data_from_usart_flag : at32f435_437_usart_iap_demo/source_code/bootloader/inc/tmr.h, at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c
  • get_device_config_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_configuration() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_descriptor() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_interface_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_lang_id() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_manufacturer_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_other_speed() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_product_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_qualifier() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_serial_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_fattime() : at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c
  • get_inquiry() : at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c, at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h
  • GET_LINE_CODING : usb_std.h, cdc_msc_class.h, msc_bot_scsi.h
  • get_serial_num() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_uid_for_seed() : random.c
  • gimage_0 : at_start_f435/examples/xmc/lcd_8bit/inc/picture.h, at_start_f437/examples/xmc/lcd_8bit/inc/picture.h
  • gimage_3 : at_start_f435/examples/xmc/lcd_8bit/inc/picture.h, at_start_f437/examples/xmc/lcd_8bit/inc/picture.h
  • gimage_5 : at_start_f435/examples/xmc/lcd_8bit/inc/picture.h, at_start_f437/examples/xmc/lcd_8bit/inc/picture.h
  • gimage_8 : at_start_f435/examples/xmc/lcd_8bit/inc/picture.h, at_start_f437/examples/xmc/lcd_8bit/inc/picture.h
  • gimage_9 : at_start_f435/examples/xmc/lcd_8bit/inc/picture.h, at_start_f437/examples/xmc/lcd_8bit/inc/picture.h
  • gpio_bits_reset() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • gpio_bits_set() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • gpio_bits_write() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • gpio_config() : project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c, project/at_start_f435/examples/adc/conversion_abort/src/main.c, project/at_start_f435/examples/adc/edma_double_buffer/src/main.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f435/examples/adc/resolution_6bit/src/main.c, project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c, project/at_start_f435/examples/adc/voltage_monitoring/src/main.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c, project/at_start_f435/examples/gpio/io_toggle/src/main.c, project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c, project/at_start_f437/examples/adc/conversion_abort/src/main.c, project/at_start_f437/examples/adc/edma_double_buffer/src/main.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f437/examples/adc/resolution_6bit/src/main.c, project/at_start_f437/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f437/examples/adc/use_polling_get_conversion_data/src/main.c, project/at_start_f437/examples/adc/voltage_monitoring/src/main.c, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c, project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f437/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • gpio_configuration() : project/at_start_f435/examples/irtmr/irtmr_output/src/main.c, project/at_start_f435/examples/tmr/oc_high/src/main.c, project/at_start_f435/examples/tmr/oc_low/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f435/examples/tmr/one_cycle/src/main.c, project/at_start_f435/examples/tmr/parallel_synchro/src/main.c, project/at_start_f435/examples/tmr/pwm_input/src/main.c, project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c
  • gpio_default_para_init() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • GPIO_DRIVE_STRENGTH_MODERATE : at32f435_437_gpio.h
  • GPIO_DRIVE_STRENGTH_STRONGER : at32f435_437_gpio.h
  • gpio_drive_type : at32f435_437_gpio.h
  • gpio_init() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • gpio_init_struct : project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/main.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c, project/at_start_f435/examples/dac/one_dac_noisewave/src/main.c, project/at_start_f435/examples/dac/two_dac_trianglewave/src/main.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/dma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/burst_mode/src/main.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/tmr/6_steps/src/main.c, project/at_start_f435/examples/tmr/7_pwm_output/src/main.c, project/at_start_f435/examples/tmr/cascade_synchro/src/main.c, project/at_start_f435/examples/tmr/complementary_signals/src/main.c, project/at_start_f435/examples/tmr/dma/src/main.c, project/at_start_f435/examples/tmr/dma_burst/src/main.c, project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f435/examples/tmr/external_clock/src/main.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f435/examples/tmr/hang_mode/src/main.c, project/at_start_f435/examples/tmr/input_capture/src/main.c, project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/main.c, project/at_start_f437/examples/dac/double_mode_dma_squarewave/src/main.c, project/at_start_f437/examples/dac/one_dac_dma_escalator/src/main.c, project/at_start_f437/examples/dac/one_dac_noisewave/src/main.c, project/at_start_f437/examples/dac/two_dac_trianglewave/src/main.c, project/at_start_f437/examples/dma/dmamux_data_to_gpio/src/main.c, project/at_start_f437/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/dma/flash_to_sram/src/main.c, project/at_start_f437/examples/edma/burst_mode/src/main.c, project/at_start_f437/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/tmr/6_steps/src/main.c, project/at_start_f437/examples/tmr/7_pwm_output/src/main.c, project/at_start_f437/examples/tmr/cascade_synchro/src/main.c, project/at_start_f437/examples/tmr/complementary_signals/src/main.c, project/at_start_f437/examples/tmr/dma/src/main.c, project/at_start_f437/examples/tmr/dma_burst/src/main.c, project/at_start_f437/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f437/examples/tmr/external_clock/src/main.c, project/at_start_f437/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f437/examples/tmr/hang_mode/src/main.c, project/at_start_f437/examples/tmr/input_capture/src/main.c
  • gpio_input_data_bit_read() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • gpio_input_data_read() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • GPIO_MODE_ANALOG : at32f435_437_gpio.h
  • GPIO_MODE_INPUT : at32f435_437_gpio.h
  • GPIO_MODE_MUX : at32f435_437_gpio.h
  • GPIO_MODE_OUTPUT : at32f435_437_gpio.h
  • gpio_mode_type : at32f435_437_gpio.h
  • GPIO_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • GPIO_MUX_0 : at32f435_437_gpio.h
  • GPIO_MUX_1 : at32f435_437_gpio.h
  • GPIO_MUX_10 : at32f435_437_gpio.h
  • GPIO_MUX_11 : at32f435_437_gpio.h
  • GPIO_MUX_12 : at32f435_437_gpio.h
  • GPIO_MUX_13 : at32f435_437_gpio.h
  • GPIO_MUX_14 : at32f435_437_gpio.h
  • GPIO_MUX_15 : at32f435_437_gpio.h
  • GPIO_MUX_2 : at32f435_437_gpio.h
  • GPIO_MUX_3 : at32f435_437_gpio.h
  • GPIO_MUX_4 : at32f435_437_gpio.h
  • GPIO_MUX_5 : at32f435_437_gpio.h
  • GPIO_MUX_6 : at32f435_437_gpio.h
  • GPIO_MUX_7 : at32f435_437_gpio.h
  • GPIO_MUX_8 : at32f435_437_gpio.h
  • GPIO_MUX_9 : at32f435_437_gpio.h
  • gpio_mux_sel_type : at32f435_437_gpio.h
  • gpio_output_data_bit_read() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • gpio_output_data_read() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • GPIO_OUTPUT_OPEN_DRAIN : at32f435_437_gpio.h
  • GPIO_OUTPUT_PUSH_PULL : at32f435_437_gpio.h
  • gpio_output_type : at32f435_437_gpio.h
  • gpio_pin_mux_config() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • gpio_pin_wp_config() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • GPIO_PINS_0 : at32f435_437_gpio.h
  • GPIO_PINS_1 : at32f435_437_gpio.h
  • GPIO_PINS_10 : at32f435_437_gpio.h
  • GPIO_PINS_11 : at32f435_437_gpio.h
  • GPIO_PINS_12 : at32f435_437_gpio.h
  • GPIO_PINS_13 : at32f435_437_gpio.h
  • GPIO_PINS_14 : at32f435_437_gpio.h
  • GPIO_PINS_15 : at32f435_437_gpio.h
  • GPIO_PINS_2 : at32f435_437_gpio.h
  • GPIO_PINS_3 : at32f435_437_gpio.h
  • GPIO_PINS_4 : at32f435_437_gpio.h
  • GPIO_PINS_5 : at32f435_437_gpio.h
  • GPIO_PINS_6 : at32f435_437_gpio.h
  • GPIO_PINS_7 : at32f435_437_gpio.h
  • GPIO_PINS_8 : at32f435_437_gpio.h
  • GPIO_PINS_9 : at32f435_437_gpio.h
  • GPIO_PINS_ALL : at32f435_437_gpio.h
  • gpio_pins_huge_driven_config() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • GPIO_PINS_SOURCE0 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE1 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE10 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE11 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE12 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE13 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE14 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE15 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE2 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE3 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE4 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE5 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE6 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE7 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE8 : at32f435_437_gpio.h
  • GPIO_PINS_SOURCE9 : at32f435_437_gpio.h
  • gpio_pins_source_type : at32f435_437_gpio.h
  • gpio_pins_toggle() : project/at_start_f435/examples/gpio/swjtag_mux/src/main.c
  • gpio_port_write() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • GPIO_PULL_DOWN : at32f435_437_gpio.h
  • GPIO_PULL_NONE : at32f435_437_gpio.h
  • gpio_pull_type : at32f435_437_gpio.h
  • GPIO_PULL_UP : at32f435_437_gpio.h
  • gpio_reset() : at32f435_437_gpio.h, at32f435_437_gpio.c
  • GPIOA : at32f435_437_gpio.h
  • GPIOA_BASE : at32f435_437.h
  • GPIOB : at32f435_437_gpio.h
  • GPIOB_BASE : at32f435_437.h
  • GPIOC : at32f435_437_gpio.h
  • GPIOC_BASE : at32f435_437.h
  • GPIOD : at32f435_437_gpio.h
  • GPIOD_BASE : at32f435_437.h
  • GPIOE : at32f435_437_gpio.h
  • GPIOE_BASE : at32f435_437.h
  • GPIOF : at32f435_437_gpio.h
  • GPIOF_BASE : at32f435_437.h
  • GPIOG : at32f435_437_gpio.h
  • GPIOG_BASE : at32f435_437.h
  • GPIOH : at32f435_437_gpio.h
  • GPIOH_BASE : at32f435_437.h
  • GRAY : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • GRED : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • GREEN : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • GREETING : telnet.c


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- h -

  • HardFault_Handler() : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c, project/at_start_f435/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f435/examples/can/filter/src/at32f435_437_int.c, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c, project/at_start_f435/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c, project/at_start_f435/templates/inc/at32f435_437_int.h, project/at_start_f435/templates/src/at32f435_437_int.c, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f437/templates/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/src/at32f435_437_int.c, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_int.h, utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_int.c
  • HardFault_IRQn : at32f435_437.h
  • HARDWARE_MODE : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • HBYTE : usb_std.h
  • HELLO : telnet.c
  • helloworld_accept() : telnet.c
  • helloworld_conn_err() : telnet.c
  • helloworld_init() : telnet.h, telnet.c
  • helloworld_recv() : telnet.c
  • HEXT_STARTUP_TIMEOUT : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • HEXT_VALUE : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • hi2cx : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • HICK_VALUE : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • HID_CLASS_DESC_HID : usb_std.h, audio_hid_desc.h
  • HID_CLASS_DESC_PHYSICAL : usb_std.h, audio_hid_desc.h
  • HID_CLASS_DESC_REPORT : usb_std.h, audio_hid_desc.h
  • HID_DESCRIPTOR_TYPE : usb_std.h
  • HID_IAP_BUFFER_LEN : hid_iap_class.h
  • hid_iap_class_handler : hid_iap_class.c, hid_iap_class.h
  • hid_iap_desc_handler : hid_iap_desc.c, hid_iap_desc.h
  • HID_INTERFACE_NUMBER : audio_hid_desc.h
  • hid_keyboard_codes : usbh_hid_keyboard.c
  • hid_keyboard_key : usbh_hid_keyboard.c
  • hid_keyboard_key_shift : usbh_hid_keyboard.c
  • hid_mouse : usbh_hid_mouse.c
  • HID_REPORT_DESC : usb_std.h
  • HID_REPORT_ID_1 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_2 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_3 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_4 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_5 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_6 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REQ_GET_IDLE : usb_std.h
  • HID_REQ_GET_PROTOCOL : usb_std.h
  • HID_REQ_GET_REPORT : usb_std.h
  • HID_REQ_SET_IDLE : usb_std.h
  • HID_REQ_SET_PROTOCOL : usb_std.h
  • HID_REQ_SET_REPORT : usb_std.h
  • hid_suspend_flag : project/at_start_f435/examples/usb_device/keyboard/src/main.c, project/at_start_f437/examples/usb_device/keyboard/src/main.c
  • HIDIAP_BCD_NUM : hid_iap_desc.h
  • HIDIAP_BINTERVAL_TIME : hid_iap_desc.h
  • HIST_LENGTH : project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • html_tmp : httpd.c
  • http_accept() : httpd.c
  • http_add_connection : httpd.c
  • HTTP_ALLOC_HTTP_STATE : httpd.c
  • http_check_eof() : httpd.c
  • http_close_conn() : httpd.c
  • http_close_or_abort_conn() : httpd.c
  • HTTP_DATA_TO_SEND_BREAK : httpd.c
  • HTTP_DATA_TO_SEND_CONTINUE : httpd.c
  • HTTP_DATA_TO_SEND_FREED : httpd.c
  • http_eof() : httpd.c
  • http_err() : httpd.c
  • http_find_error_file : httpd.c
  • HTTP_FREE_HTTP_STATE : httpd.c
  • http_iap_flag : utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • HTTP_IS_DATA_VOLATILE : httpd.c
  • HTTP_IS_DYNAMIC_FILE : httpd.c
  • HTTP_IS_HDR_VOLATILE : httpd.c
  • HTTP_NO_DATA_TO_SEND : httpd.c
  • http_poll() : httpd.c
  • http_recv() : httpd.c
  • http_remove_connection : httpd.c
  • http_send() : httpd.c
  • http_send_data_nonssi() : httpd.c
  • http_sent() : httpd.c
  • http_state_alloc() : httpd.c
  • http_state_eof() : httpd.c
  • http_state_free() : httpd.c
  • http_state_init() : httpd.c
  • http_write() : httpd.c
  • httpd_init() : httpd.c, telnet.h
  • httpd_init_pcb() : httpd.c
  • hw_usart_read_index : project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f437/examples/usb_device/virtual_comport/src/main.c
  • hw_usart_rx_index : project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f437/examples/usb_device/virtual_comport/src/main.c


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- i -

  • I2C1 : at32f435_437_i2c.h
  • I2C1_BASE : at32f435_437.h
  • I2C1_ERR_IRQHandler() : project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c
  • I2C1_ERR_IRQn : at32f435_437.h
  • I2C1_EVT_IRQHandler() : project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c
  • I2C1_EVT_IRQn : at32f435_437.h
  • I2C2 : at32f435_437_i2c.h
  • I2C2_BASE : at32f435_437.h
  • I2C2_ERR_IRQHandler() : project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c
  • I2C2_ERR_IRQn : at32f435_437.h
  • I2C2_EVT_IRQHandler() : project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c
  • I2C2_EVT_IRQn : at32f435_437.h
  • I2C3 : at32f435_437_i2c.h
  • I2C3_BASE : at32f435_437.h
  • I2C3_ERR_IRQn : at32f435_437.h
  • I2C3_EVT_IRQn : at32f435_437.h
  • i2c_ack_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • I2C_ACKFAIL_FLAG : at32f435_437_i2c.h
  • I2C_ACKFIAL_INT : at32f435_437_i2c.h
  • i2c_addr10_header_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_addr10_mode_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • I2C_ADDR2_MASK01 : at32f435_437_i2c.h
  • I2C_ADDR2_MASK02 : at32f435_437_i2c.h
  • I2C_ADDR2_MASK03 : at32f435_437_i2c.h
  • I2C_ADDR2_MASK04 : at32f435_437_i2c.h
  • I2C_ADDR2_MASK05 : at32f435_437_i2c.h
  • I2C_ADDR2_MASK06 : at32f435_437_i2c.h
  • I2C_ADDR2_MASK07 : at32f435_437_i2c.h
  • i2c_addr2_mask_type : at32f435_437_i2c.h
  • I2C_ADDR2_NOMASK : at32f435_437_i2c.h
  • I2C_ADDR_INT : at32f435_437_i2c.h
  • I2C_ADDRESS_MODE_10BIT : at32f435_437_i2c.h
  • I2C_ADDRESS_MODE_7BIT : at32f435_437_i2c.h
  • i2c_address_mode_type : at32f435_437_i2c.h
  • I2C_ADDRF_FLAG : at32f435_437_i2c.h
  • I2C_ALERTF_FLAG : at32f435_437_i2c.h
  • I2C_ARLOST_FLAG : at32f435_437_i2c.h
  • i2c_auto_stop_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • I2C_AUTO_STOP_MODE : at32f435_437_i2c.h
  • I2C_BUSERR_FLAG : at32f435_437_i2c.h
  • I2C_BUSYF_FLAG : at32f435_437_i2c.h
  • i2c_clock_stretch_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_cnt_set() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_config() : i2c_application.c, i2c_application.h
  • i2c_data_receive() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_data_send() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • I2C_DIR_RECEIVE : at32f435_437_i2c.h
  • I2C_DIR_TRANSMIT : at32f435_437_i2c.h
  • i2c_dma_config() : i2c_application.c
  • i2c_dma_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • I2C_DMA_MA_RX : i2c_application.h
  • I2C_DMA_MA_TX : i2c_application.h
  • I2C_DMA_REQUEST_RX : at32f435_437_i2c.h
  • I2C_DMA_REQUEST_TX : at32f435_437_i2c.h
  • i2c_dma_request_type : at32f435_437_i2c.h
  • i2c_dma_rx_irq_handler() : i2c_application.c, i2c_application.h
  • I2C_DMA_SLA_RX : i2c_application.h
  • I2C_DMA_SLA_TX : i2c_application.h
  • i2c_dma_tx_irq_handler() : i2c_application.c, i2c_application.h
  • i2c_dma_tx_rx_irq_handler() : i2c_application.c
  • i2c_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • I2C_END : i2c_application.c
  • I2C_ERR_ACKFAIL : i2c_application.h
  • I2C_ERR_ADDR : i2c_application.h
  • I2C_ERR_INT : at32f435_437_i2c.h
  • I2C_ERR_INTERRUPT : i2c_application.h
  • i2c_err_irq_handler() : i2c_application.c, i2c_application.h
  • I2C_ERR_STEP_1 : i2c_application.h
  • I2C_ERR_STEP_10 : i2c_application.h
  • I2C_ERR_STEP_11 : i2c_application.h
  • I2C_ERR_STEP_12 : i2c_application.h
  • I2C_ERR_STEP_2 : i2c_application.h
  • I2C_ERR_STEP_3 : i2c_application.h
  • I2C_ERR_STEP_4 : i2c_application.h
  • I2C_ERR_STEP_5 : i2c_application.h
  • I2C_ERR_STEP_6 : i2c_application.h
  • I2C_ERR_STEP_7 : i2c_application.h
  • I2C_ERR_STEP_8 : i2c_application.h
  • I2C_ERR_STEP_9 : i2c_application.h
  • I2C_ERR_STOP : i2c_application.h
  • I2C_ERR_TCRLD : i2c_application.h
  • I2C_ERR_TDC : i2c_application.h
  • I2C_ERR_TIMEOUT : i2c_application.h
  • I2C_EVENT_CHECK_ACKFAIL : i2c_application.h
  • I2C_EVENT_CHECK_NONE : i2c_application.h
  • I2C_EVENT_CHECK_STOP : i2c_application.h
  • i2c_evt_irq_handler() : i2c_application.c, i2c_application.h
  • i2c_ext_timeout_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_ext_timeout_set() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_flag_clear() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_flag_get() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • I2C_GEN_START_READ : at32f435_437_i2c.h
  • I2C_GEN_START_WRITE : at32f435_437_i2c.h
  • i2c_general_call_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_init() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • I2C_INT_MA_RX : i2c_application.h
  • I2C_INT_MA_TX : i2c_application.h
  • I2C_INT_SLA_RX : i2c_application.h
  • I2C_INT_SLA_TX : i2c_application.h
  • i2c_interrupt_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_interrupt_get() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_lowlevel_init() : i2c_application.c, i2c_application.h, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • i2c_master_irq_handler_dma() : i2c_application.c
  • i2c_master_irq_handler_int() : i2c_application.c
  • i2c_master_receive() : i2c_application.c, i2c_application.h
  • i2c_master_receive_dma() : i2c_application.c, i2c_application.h
  • i2c_master_receive_int() : i2c_application.c, i2c_application.h
  • i2c_master_transmit() : i2c_application.c, i2c_application.h
  • i2c_master_transmit_dma() : i2c_application.c, i2c_application.h
  • i2c_master_transmit_int() : i2c_application.c, i2c_application.h
  • i2c_matched_addr_get() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_memory_read() : i2c_application.c, i2c_application.h
  • i2c_memory_read_dma() : i2c_application.c, i2c_application.h
  • i2c_memory_read_int() : i2c_application.c, i2c_application.h
  • i2c_memory_write() : i2c_application.c, i2c_application.h
  • i2c_memory_write_dma() : i2c_application.c, i2c_application.h
  • i2c_memory_write_int() : i2c_application.c, i2c_application.h
  • i2c_mode_type : i2c_application.h
  • I2C_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • I2C_OK : i2c_application.h
  • I2C_OUF_FLAG : at32f435_437_i2c.h
  • i2c_own_address1_set() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_own_address2_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_own_address2_set() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_pec_calculate_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_pec_transmit_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_pec_value_get() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • I2C_PECERR_FLAG : at32f435_437_i2c.h
  • I2C_RD_INT : at32f435_437_i2c.h
  • I2C_RDBF_FLAG : at32f435_437_i2c.h
  • i2c_refresh_txdt_register() : i2c_application.c
  • i2c_reload_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • I2C_RELOAD_MODE : at32f435_437_i2c.h
  • i2c_reload_stop_mode_type : at32f435_437_i2c.h
  • i2c_reset() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_reset_ctrl2_register() : i2c_application.c, i2c_application.h
  • I2C_SDIR_FLAG : at32f435_437_i2c.h
  • i2c_slave_data_ctrl_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_slave_irq_handler_dma() : i2c_application.c
  • i2c_slave_irq_handler_int() : i2c_application.c
  • i2c_slave_receive() : i2c_application.c, i2c_application.h
  • i2c_slave_receive_dma() : i2c_application.c, i2c_application.h
  • i2c_slave_receive_int() : i2c_application.c, i2c_application.h
  • i2c_slave_transmit() : i2c_application.c, i2c_application.h
  • i2c_slave_transmit_dma() : i2c_application.c, i2c_application.h
  • i2c_slave_transmit_int() : i2c_application.c, i2c_application.h
  • I2C_SMBUS_ALERT_HIGH : at32f435_437_i2c.h
  • I2C_SMBUS_ALERT_LOW : at32f435_437_i2c.h
  • i2c_smbus_alert_set() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_smbus_alert_set_type : at32f435_437_i2c.h
  • i2c_smbus_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_smbus_master_receive() : i2c_application.c, i2c_application.h
  • i2c_smbus_master_transmit() : i2c_application.c, i2c_application.h
  • I2C_SMBUS_MODE_DEVICE : at32f435_437_i2c.h
  • I2C_SMBUS_MODE_HOST : at32f435_437_i2c.h
  • i2c_smbus_mode_type : at32f435_437_i2c.h
  • i2c_smbus_slave_receive() : i2c_application.c, i2c_application.h
  • i2c_smbus_slave_transmit() : i2c_application.c, i2c_application.h
  • I2C_SOFT_STOP_MODE : at32f435_437_i2c.h
  • I2C_START : i2c_application.c
  • i2c_start_generate() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_start_mode_type : at32f435_437_i2c.h
  • i2c_start_transfer() : i2c_application.c
  • i2c_start_transfer_dma() : i2c_application.c
  • i2c_status_type : i2c_application.h
  • i2c_stop_generate() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • I2C_STOP_INT : at32f435_437_i2c.h
  • I2C_STOPF_FLAG : at32f435_437_i2c.h
  • I2C_TCRLD_FLAG : at32f435_437_i2c.h
  • I2C_TD_INT : at32f435_437_i2c.h
  • I2C_TDBE_FLAG : at32f435_437_i2c.h
  • I2C_TDC_FLAG : at32f435_437_i2c.h
  • I2C_TDC_INT : at32f435_437_i2c.h
  • I2C_TDIS_FLAG : at32f435_437_i2c.h
  • I2C_TIMEOUT : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2C_TIMEOUT_DETCET_HIGH : at32f435_437_i2c.h
  • I2C_TIMEOUT_DETCET_LOW : at32f435_437_i2c.h
  • i2c_timeout_detcet_set() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_timeout_detcet_type : at32f435_437_i2c.h
  • i2c_timeout_enable() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_timeout_set() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • I2C_TMOUT_FLAG : at32f435_437_i2c.h
  • i2c_transfer_addr_get() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_transfer_addr_set() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_transfer_dir_get() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_transfer_dir_set() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_transfer_dir_type : at32f435_437_i2c.h
  • i2c_transmit_set() : at32f435_437_i2c.h, at32f435_437_i2c.c
  • i2c_wait_end() : i2c_application.c, i2c_application.h
  • i2c_wait_flag() : i2c_application.c, i2c_application.h
  • I2C_WITHOUT_START : at32f435_437_i2c.h
  • I2Cx_ADDRESS : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_CLK : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_CLKCTRL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_DMA : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_CLK : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_RX_Channel : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_RX_DMAMUX_Channel : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_RX_DMAREQ : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_RX_IRQHandler : project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/eeprom/src/at32f435_437_int.c
  • I2Cx_DMA_RX_IRQn : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_TX_Channel : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_TX_DMAMUX_Channel : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_TX_DMAREQ : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_TX_IRQHandler : project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/eeprom/src/at32f435_437_int.c
  • I2Cx_DMA_TX_IRQn : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • I2Cx_ERR_IRQHandler : project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/eeprom/src/at32f435_437_int.c
  • I2Cx_ERR_IRQn : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • I2Cx_EVT_IRQHandler : project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/eeprom/src/at32f435_437_int.c
  • I2Cx_EVT_IRQn : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • I2Cx_PORT : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_SCL_GPIO_AF : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c
  • I2Cx_SCL_GPIO_CLK : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_SCL_GPIO_MUX : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_SCL_GPIO_PIN : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_SCL_GPIO_PinsSource : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_SCL_GPIO_PORT : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_SDA_GPIO_AF : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c
  • I2Cx_SDA_GPIO_CLK : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_SDA_GPIO_MUX : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_SDA_GPIO_PIN : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_SDA_GPIO_PinsSource : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2Cx_SDA_GPIO_PORT : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • I2S1_CK_GPIO_MUX : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S1_CK_PIN : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S1_CK_PIN_SOURCE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S1_DT_ADDRESS : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S1_GPIO : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S1_GPIO_CRM_CLK : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S1_SD_GPIO_MUX : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S1_SD_PIN : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S1_SD_PIN_SOURCE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S1_WS_GPIO_MUX : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S1_WS_PIN : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S1_WS_PIN_SOURCE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • i2s2_buffer1_rx : project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c
  • i2s2_buffer2_rx : project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c
  • i2s2_buffer_rx : project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f437/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • i2s2_buffer_tx : project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c
  • I2S2_CK_GPIO_MUX : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2_CK_PIN : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2_CK_PIN_SOURCE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2_DT_ADDRESS : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2_GPIO : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2_GPIO_CRM_CLK : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2_SD_GPIO_MUX : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2_SD_PIN : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2_SD_PIN_SOURCE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2_WS_GPIO_MUX : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2_WS_PIN : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2_WS_PIN_SOURCE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • I2S2EXT : at32f435_437_spi.h
  • I2S2EXT_BASE : at32f435_437.h
  • i2s3_buffer1_tx : project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c
  • i2s3_buffer2_tx : project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c
  • i2s3_buffer_rx : project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c
  • i2s3_buffer_tx : project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f437/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • I2S3EXT : at32f435_437_spi.h
  • I2S3EXT_BASE : at32f435_437.h
  • I2S_ACS_FLAG : at32f435_437_spi.h
  • I2S_AUDIO_FREQUENCY_11_025K : at32f435_437_spi.h
  • I2S_AUDIO_FREQUENCY_16K : at32f435_437_spi.h
  • I2S_AUDIO_FREQUENCY_192K : at32f435_437_spi.h
  • I2S_AUDIO_FREQUENCY_22_05K : at32f435_437_spi.h
  • I2S_AUDIO_FREQUENCY_32K : at32f435_437_spi.h
  • I2S_AUDIO_FREQUENCY_44_1K : at32f435_437_spi.h
  • I2S_AUDIO_FREQUENCY_48K : at32f435_437_spi.h
  • I2S_AUDIO_FREQUENCY_8K : at32f435_437_spi.h
  • I2S_AUDIO_FREQUENCY_96K : at32f435_437_spi.h
  • I2S_AUDIO_FREQUENCY_DEFAULT : at32f435_437_spi.h
  • I2S_AUDIO_PROTOCOL_LSB : at32f435_437_spi.h
  • I2S_AUDIO_PROTOCOL_MSB : at32f435_437_spi.h
  • I2S_AUDIO_PROTOCOL_PCM_LONG : at32f435_437_spi.h
  • I2S_AUDIO_PROTOCOL_PCM_SHORT : at32f435_437_spi.h
  • I2S_AUDIO_PROTOCOL_PHILLIPS : at32f435_437_spi.h
  • i2s_audio_protocol_type : at32f435_437_spi.h
  • i2s_audio_sampling_freq_type : at32f435_437_spi.h
  • I2S_CLOCK_POLARITY_HIGH : at32f435_437_spi.h
  • I2S_CLOCK_POLARITY_LOW : at32f435_437_spi.h
  • i2s_clock_polarity_type : at32f435_437_spi.h
  • i2s_config() : project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c, project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c, project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f437/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • I2S_DATA_16BIT_CHANNEL_16BIT : at32f435_437_spi.h
  • I2S_DATA_16BIT_CHANNEL_32BIT : at32f435_437_spi.h
  • I2S_DATA_24BIT_CHANNEL_32BIT : at32f435_437_spi.h
  • I2S_DATA_32BIT_CHANNEL_32BIT : at32f435_437_spi.h
  • i2s_data_channel_format_type : at32f435_437_spi.h
  • i2s_default_para_init() : at32f435_437_spi.h, at32f435_437_spi.c
  • i2s_enable() : at32f435_437_spi.h, at32f435_437_spi.c
  • i2s_init() : at32f435_437_spi.h, at32f435_437_spi.c
  • I2S_MODE_MASTER_RX : at32f435_437_spi.h
  • I2S_MODE_MASTER_TX : at32f435_437_spi.h
  • I2S_MODE_SLAVE_RX : at32f435_437_spi.h
  • I2S_MODE_SLAVE_TX : at32f435_437_spi.h
  • i2s_operation_mode_type : at32f435_437_spi.h
  • I2S_TUERR_FLAG : at32f435_437_spi.h
  • IAP_ACK : hid_iap_class.h
  • iap_address() : bootloader/src/hid_iap_user.c
  • iap_clear_upgrade_flag() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • IAP_CMD_ADDR : hid_iap_class.h
  • IAP_CMD_CRC : hid_iap_class.h
  • IAP_CMD_DATA : hid_iap_class.h
  • IAP_CMD_FINISH : hid_iap_class.h
  • IAP_CMD_GET : hid_iap_class.h
  • IAP_CMD_IDLE : hid_iap_class.h
  • IAP_CMD_JMP : hid_iap_class.h
  • IAP_CMD_START : hid_iap_class.h
  • iap_command_handle() : at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h, at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c, at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/iap.c, at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/iap.h, at32f437_emac_iap_demo/source_code/app_led3_toggle/src/iap.c, at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h, at32f437_emac_iap_demo/source_code/bootloader/src/iap.c
  • iap_crc() : bootloader/src/hid_iap_user.c
  • iap_data_write() : bootloader/src/hid_iap_user.c
  • iap_erase_sector() : bootloader/src/hid_iap_user.c
  • IAP_FAILED : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, hid_iap_class.h
  • iap_finish() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_flag : app_led3_toggle/inc/usart.h, app_led3_toggle/src/usart.c, app_led4_toggle/inc/usart.h, app_led4_toggle/src/usart.c
  • iap_get() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_get_upgrade_flag() : app_led3_toggle/inc/hid_iap_user.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/inc/hid_iap_user.h, bootloader/src/hid_iap_user.c
  • iap_httpd_init() : httpserver.h
  • iap_idle() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_info : hid_iap_class.c, hid_iap_class.h
  • iap_init() : at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h, at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c, at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/iap.c, app_led3_toggle/inc/hid_iap_user.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/inc/hid_iap_user.h, bootloader/src/hid_iap_user.c, at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/iap.h, at32f437_emac_iap_demo/source_code/app_led3_toggle/src/iap.c, at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h, at32f437_emac_iap_demo/source_code/bootloader/src/iap.c
  • iap_jump() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_loop() : bootloader/inc/hid_iap_user.h, bootloader/src/hid_iap_user.c
  • iap_machine_state_type : hid_iap_class.h
  • IAP_NACK : hid_iap_class.h
  • iap_respond() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_result_type : hid_iap_class.h
  • IAP_REV_FLAG_5A : app_led3_toggle/inc/usart.h, app_led4_toggle/inc/usart.h
  • IAP_REV_FLAG_DONE : app_led3_toggle/inc/usart.h, app_led4_toggle/inc/usart.h
  • IAP_REV_FLAG_ERROR : app_led3_toggle/inc/usart.h, app_led4_toggle/inc/usart.h
  • IAP_REV_FLAG_NO : app_led3_toggle/inc/usart.h, app_led4_toggle/inc/usart.h
  • iap_set_upgrade_flag() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_start() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • IAP_STS_ADDR : hid_iap_class.h
  • IAP_STS_CRC : hid_iap_class.h
  • IAP_STS_DATA : hid_iap_class.h
  • IAP_STS_FINISH : hid_iap_class.h
  • IAP_STS_IDLE : hid_iap_class.h
  • IAP_STS_JMP : hid_iap_class.h
  • IAP_STS_JMP_WAIT : hid_iap_class.h
  • IAP_STS_START : hid_iap_class.h
  • IAP_SUCCESS : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, hid_iap_class.h
  • iap_tftpd_init() : tftpserver.h
  • iap_upgrade_app_handle() : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h, at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
  • IAP_UPGRADE_COMPLETE_FLAG : hid_iap_class.h, at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • IAP_UPGRADE_FLAG : at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h, at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/iap.h, at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h, at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/iap.h, at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h
  • IAP_UPGRADE_FLAG_ADDR : at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/iap.h, at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/iap.h, at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h, at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/iap.h, at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h
  • IAP_WAIT : hid_iap_class.h
  • iapfun : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h, at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h
  • ic1value : project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c
  • ic2value : project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/pwm_input/src/at32f435_437_int.c
  • ic3readvalue1 : project/at_start_f435/examples/tmr/input_capture/src/main.c, project/at_start_f437/examples/tmr/input_capture/src/main.c
  • ic3readvalue2 : project/at_start_f435/examples/tmr/input_capture/src/main.c, project/at_start_f437/examples/tmr/input_capture/src/main.c
  • idx : project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c, project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/main.c
  • IMG_CONSTANT : at_start_f435/examples/cortex_m4/fpu/inc/julia_fpu.h, at_start_f437/examples/cortex_m4/fpu/inc/julia_fpu.h
  • INCLUDE_uxTaskPriorityGet : FreeRTOSConfig.h
  • INCLUDE_vTaskCleanUpResources : FreeRTOSConfig.h
  • INCLUDE_vTaskDelay : FreeRTOSConfig.h
  • INCLUDE_vTaskDelayUntil : FreeRTOSConfig.h
  • INCLUDE_vTaskDelete : FreeRTOSConfig.h
  • INCLUDE_vTaskPrioritySet : FreeRTOSConfig.h
  • INCLUDE_vTaskSuspend : FreeRTOSConfig.h
  • INCLUDE_xTaskGetCurrentTaskHandle : FreeRTOSConfig.h
  • Init() : FlashOS.h, FlashPrg.c
  • init_clk() : qspi_algorithm.c, FlashPrg.c
  • INT16 : at32f435_437.h
  • INT32 : at32f435_437.h
  • INT8 : at32f435_437.h
  • INTERNAL_FLASH_LUN : at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h, at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h
  • INVAILD_OFFSET_ADDR : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • INVALID_COMMAND : cdc_msc_class.h, msc_bot_scsi.h
  • INVALID_FIELD_IN_PARAMETER_LIST : cdc_msc_class.h, msc_bot_scsi.h
  • INVALID_FIELED_IN_COMMAND : cdc_msc_class.h, msc_bot_scsi.h
  • iperf_accept() : iperf.c
  • iperf_init() : iperf.h, iperf.c
  • iperf_recv() : iperf.c
  • IRQn : at32f435_437.h
  • IRQn_Type : at32f435_437.h
  • is_bpr_reg_reset() : project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c
  • ITERATION : at_start_f435/examples/cortex_m4/fpu/inc/julia_fpu.h, at_start_f437/examples/cortex_m4/fpu/inc/julia_fpu.h


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- j -

  • j : project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c
  • jpeg_data_process() : at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c
  • JUMBO_FRAME_PAYLOAD : at32f435_437_emac.h
  • jump_to_app : at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c, at32f437_emac_iap_demo/source_code/bootloader/src/iap.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c, bootloader/inc/hid_iap_user.h, bootloader/src/hid_iap_user.c
  • jump_to_iap() : app_led3_toggle/inc/hid_iap_user.h


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- k -

  • KB_TO_B : hid_iap_class.h
  • KEYBOARD_BCD_NUM : keyboard_desc.h
  • KEYBOARD_BINTERVAL_TIME : keyboard_desc.h
  • keyboard_class_handler : keyboard_class.c, keyboard_class.h
  • keyboard_class_setup_handler() : cdc_keyboard_class.c
  • keyboard_desc_handler : keyboard_desc.c, keyboard_desc.h
  • KEYBOARD_LEFT_ALT : usbh_hid_keyboard.h
  • KEYBOARD_LEFT_CTRL : usbh_hid_keyboard.h
  • KEYBOARD_LEFT_GUI : usbh_hid_keyboard.h
  • KEYBOARD_LEFT_SHIFT : usbh_hid_keyboard.h
  • KEYBOARD_MAX_NB_PRESSED : usbh_hid_keyboard.h
  • KEYBOARD_RIGHT_ALT : usbh_hid_keyboard.h
  • KEYBOARD_RIGHT_CTRL : usbh_hid_keyboard.h
  • KEYBOARD_RIGHT_GUI : usbh_hid_keyboard.h
  • KEYBOARD_RIGHT_SHIFT : usbh_hid_keyboard.h
  • keyboard_send_flag : project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/src/main.c
  • keyboard_send_string() : project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f435/examples/usb_device/keyboard/src/main.c, project/at_start_f435/examples/usb_device/mouse/src/main.c
  • keyboard_struct : keyboard_class.c


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- l -

  • langid_descriptor : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • LAYOUT_OVERRIDE_BUFFER : flash_loader_extra.h
  • LBYTE : usb_std.h
  • LCD_BL_HIGH : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • LCD_BL_LOW : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • lcd_char_show() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c
  • lcd_clear() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c, at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c
  • lcd_color_fill() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c
  • lcd_dev_struct : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c
  • lcd_display_number() : at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c
  • lcd_drawpoint() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c, at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c
  • lcd_fill() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c
  • LCD_H : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h
  • LCD_ID : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • lcd_init() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c, at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c
  • lcd_rd_data() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c
  • LCD_RESET_HIGH : at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h
  • LCD_RESET_LOW : at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h
  • lcd_setblock() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c, at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c
  • lcd_string_show() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c
  • lcd_struct : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c
  • LCD_W : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h
  • lcd_wr_command() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c, at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c
  • lcd_wr_data() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c, at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c
  • lcd_writeonepoint() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c, at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c
  • LED2 : at32f435_437_board.h
  • led2_handler : utilities/at32f435_437_freertos_demo/src/main.c
  • led2_task_function() : utilities/at32f435_437_freertos_demo/src/main.c
  • LED3 : at32f435_437_board.h
  • led3_handler : utilities/at32f435_437_freertos_demo/src/main.c
  • led3_task_function() : utilities/at32f435_437_freertos_demo/src/main.c
  • LED4 : at32f435_437_board.h
  • led_gpio_crm_clk : at32f435_437_board.c
  • led_gpio_pin : at32f435_437_board.c
  • led_gpio_port : at32f435_437_board.c
  • LED_NUM : at32f435_437_board.h
  • led_page_name : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • led_type : at32f435_437_board.h
  • LEFT_BUTTON : mouse_class.h
  • LEFT_MOVE : mouse_class.h
  • lick_freq : project/at_start_f435/examples/ertc/lick_calibration/src/main.c, project/at_start_f437/examples/ertc/lick_calibration/src/main.c
  • lick_frequency_get() : project/at_start_f435/examples/ertc/lick_calibration/src/main.c
  • LIGHT_SWITCH : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • linecoding : cdc_class.c, cdc_msc_class.c, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f437/examples/usb_device/virtual_comport/src/main.c
  • linecoding_vcpkybrd : cdc_keyboard_class.c
  • LINK_DETECTION : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • link_timer : project/at_start_f437/examples/emac/dns_client/src/netconf.c, project/at_start_f437/examples/emac/http_server/src/netconf.c, project/at_start_f437/examples/emac/iperf/src/netconf.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_server/src/netconf.c, project/at_start_f437/examples/emac/telnet/src/netconf.c, project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • link_update() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • LIST_COUNT : project/at_start_f435/examples/edma/link_list_mode/src/main.c, project/at_start_f437/examples/edma/link_list_mode/src/main.c
  • local_gw : project/at_start_f437/examples/emac/dns_client/src/netconf.c, project/at_start_f437/examples/emac/http_server/src/netconf.c, project/at_start_f437/examples/emac/iperf/src/netconf.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_server/src/netconf.c, project/at_start_f437/examples/emac/telnet/src/netconf.c, project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • local_ip : project/at_start_f437/examples/emac/dns_client/src/netconf.c, project/at_start_f437/examples/emac/http_server/src/netconf.c, project/at_start_f437/examples/emac/iperf/src/netconf.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_server/src/netconf.c, project/at_start_f437/examples/emac/telnet/src/netconf.c, project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • local_mask : project/at_start_f437/examples/emac/dns_client/src/netconf.c, project/at_start_f437/examples/emac/http_server/src/netconf.c, project/at_start_f437/examples/emac/iperf/src/netconf.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_server/src/netconf.c, project/at_start_f437/examples/emac/telnet/src/netconf.c, project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • local_time : project/at_start_f437/examples/emac/dns_client/src/main.c, project/at_start_f437/examples/emac/dns_client/src/netconf.c, project/at_start_f437/examples/emac/http_server/src/main.c, project/at_start_f437/examples/emac/http_server/src/netconf.c, project/at_start_f437/examples/emac/iperf/src/main.c, project/at_start_f437/examples/emac/iperf/src/netconf.c, project/at_start_f437/examples/emac/mqtt_client/src/main.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/main.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_server/src/main.c, project/at_start_f437/examples/emac/tcp_server/src/netconf.c, project/at_start_f437/examples/emac/telnet/src/main.c, project/at_start_f437/examples/emac/telnet/src/netconf.c, project/at_start_f437/examples/emac/wake_on_lan/src/main.c, project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/main.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • LOGIN_SIZE : httpserver.h
  • LOST_VAL : at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c, at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c
  • LWIP_DHCP : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_DNS : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_HAVE_LOOPIF : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_HTTPD_URI_BUF_LEN : httpd.c
  • LWIP_IGMP : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_IPV4 : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_MDNS_RESPONDER : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_MEM_ILLEGAL_FREE : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_NETBUF_RECVINFO : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_NETCONN : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_NETCONN_FULLDUPLEX : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_NETIF_LINK_CALLBACK : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_NUM_NETIF_CLIENT_DATA : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • lwip_periodic_handle() : project/at_start_f437/examples/emac/dns_client/inc/netconf.h, project/at_start_f437/examples/emac/dns_client/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/netconf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/netconf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • lwip_pkt_handle() : project/at_start_f437/examples/emac/dns_client/inc/netconf.h, project/at_start_f437/examples/emac/dns_client/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/netconf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/netconf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • LWIP_SOCKET : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_TCP : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • LWIP_WND_SCALE : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • ly68l6400_cmd_config : at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c, at_start_f437/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c
  • ly68l6400_xip_init : at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c, at_start_f437/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- m -

  • MAC_ADDR_LENGTH : project/at_start_f437/examples/emac/dns_client/src/netconf.c, project/at_start_f437/examples/emac/http_server/src/netconf.c, project/at_start_f437/examples/emac/iperf/src/netconf.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_server/src/netconf.c, project/at_start_f437/examples/emac/telnet/src/netconf.c, project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • mac_address : project/at_start_f437/examples/emac/dns_client/src/netconf.c, project/at_start_f437/examples/emac/http_server/src/netconf.c, project/at_start_f437/examples/emac/iperf/src/netconf.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_server/src/netconf.c, project/at_start_f437/examples/emac/telnet/src/netconf.c, project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • mac_control_para : project/at_start_f437/examples/emac/dns_client/src/at32_emac.c, project/at_start_f437/examples/emac/http_server/src/at32_emac.c, project/at_start_f437/examples/emac/iperf/src/at32_emac.c, project/at_start_f437/examples/emac/mqtt_client/src/at32_emac.c, project/at_start_f437/examples/emac/tcp_client/src/at32_emac.c, project/at_start_f437/examples/emac/tcp_server/src/at32_emac.c, project/at_start_f437/examples/emac/telnet/src/at32_emac.c, project/at_start_f437/examples/emac/wake_on_lan/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • MAGENTA : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • main() : project/at_start_f435/examples/acc/calibration/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c, project/at_start_f435/examples/adc/conversion_abort/src/main.c, project/at_start_f435/examples/adc/current_vref_value_check/src/main.c, project/at_start_f435/examples/adc/edma_double_buffer/src/main.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f435/examples/adc/resolution_6bit/src/main.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c, project/at_start_f435/examples/adc/vbat_monitor/src/main.c, project/at_start_f435/examples/adc/voltage_monitoring/src/main.c, project/at_start_f435/examples/can/communication_mode/src/main.c, project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f435/examples/can/loopback_mode/src/main.c, project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f435/examples/cortex_m4/fpu/src/main.c, project/at_start_f435/examples/cortex_m4/systick_interrupt/src/main.c, project/at_start_f435/examples/crc/calculation/src/main.c, project/at_start_f435/examples/crm/clock_failure_detection/src/main.c, project/at_start_f435/examples/crm/pll_parameter_calculate/src/main.c, project/at_start_f435/examples/crm/sysclk_switch/src/main.c, project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/main.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c, project/at_start_f435/examples/dac/one_dac_noisewave/src/main.c, project/at_start_f435/examples/dac/two_dac_trianglewave/src/main.c, project/at_start_f435/examples/debug/tmr1/src/main.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/dma/flash_to_sram/src/main.c, project/at_start_f435/examples/dvp/ov2640_capture/src/main.c, project/at_start_f435/examples/dvp/ov5640_capture/src/main.c, project/at_start_f435/examples/edma/burst_mode/src/main.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/edma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c, project/at_start_f435/examples/edma/link_list_mode/src/main.c, project/at_start_f435/examples/edma/two_dimension_mode/src/main.c, project/at_start_f435/examples/ertc/bpr_domain/src/main.c, project/at_start_f435/examples/ertc/calendar/src/main.c, project/at_start_f435/examples/ertc/lick_calibration/src/main.c, project/at_start_f435/examples/ertc/tamper/src/main.c, project/at_start_f435/examples/ertc/time_stamp/src/main.c, project/at_start_f435/examples/ertc/wakeup_timer/src/main.c, project/at_start_f435/examples/exint/exint_config/src/main.c, project/at_start_f435/examples/exint/exint_software_trigger/src/main.c, project/at_start_f435/examples/flash/fap_enable/src/main.c, project/at_start_f435/examples/flash/flash_write_read/src/main.c, project/at_start_f435/examples/gpio/io_toggle/src/main.c, project/at_start_f435/examples/gpio/led_toggle/src/main.c, project/at_start_f435/examples/gpio/swjtag_mux/src/main.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f435/examples/irtmr/irtmr_output/src/main.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/main.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/main.c, project/at_start_f435/examples/pwc/ldo_set/src/main.c, project/at_start_f435/examples/pwc/power_voltage_monitor/src/main.c, project/at_start_f435/examples/pwc/sleep_tmr2/src/main.c, project/at_start_f435/examples/pwc/sleep_usart1/src/main.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/main.c, project/at_start_f435/examples/pwc/standby_wakeup_pin/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c, project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c, project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c, project/at_start_f435/examples/scfg/mem_map_sel/src/main.c, project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f435/examples/spi/w25q_flash/src/main.c, project/at_start_f435/examples/sram/extend_sram/src/main.c, project/at_start_f435/examples/tmr/6_steps/src/main.c, project/at_start_f435/examples/tmr/7_pwm_output/src/main.c, project/at_start_f435/examples/tmr/cascade_synchro/src/main.c, project/at_start_f435/examples/tmr/complementary_signals/src/main.c, project/at_start_f435/examples/tmr/dma/src/main.c, project/at_start_f435/examples/tmr/dma_burst/src/main.c, project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f435/examples/tmr/external_clock/src/main.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f435/examples/tmr/hang_mode/src/main.c, project/at_start_f435/examples/tmr/input_capture/src/main.c, project/at_start_f435/examples/tmr/oc_high/src/main.c, project/at_start_f435/examples/tmr/oc_low/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f435/examples/tmr/one_cycle/src/main.c, project/at_start_f435/examples/tmr/parallel_synchro/src/main.c, project/at_start_f435/examples/tmr/pwm_input/src/main.c, project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f435/examples/tmr/timer_base/src/main.c, project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c, project/at_start_f435/examples/usart/half_duplex/src/main.c, project/at_start_f435/examples/usart/hw_flow_control/src/main.c, project/at_start_f435/examples/usart/idle_detection/src/main.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/irda/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/printf/src/main.c, project/at_start_f435/examples/usart/receiver_mute/src/main.c, project/at_start_f435/examples/usart/rs485/src/main.c, project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f435/examples/usb_device/audio/src/main.c, project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f435/examples/usb_device/custom_hid/src/main.c, project/at_start_f435/examples/usb_device/keyboard/src/main.c, project/at_start_f435/examples/usb_device/mouse/src/main.c, project/at_start_f435/examples/usb_device/msc/src/main.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/printer/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c, project/at_start_f435/examples/usb_host/hid_demo/src/main.c, project/at_start_f435/examples/usb_host/msc_only_fat32/src/main.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c, project/at_start_f435/examples/wdt/wdt_reset/src/main.c, project/at_start_f435/examples/wdt/wdt_standby/src/main.c, project/at_start_f435/examples/wwdt/wwdt_reset/src/main.c, project/at_start_f435/examples/xmc/lcd_8bit/src/main.c, project/at_start_f435/examples/xmc/lcd_touch_16bit/src/main.c, project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f435/examples/xmc/nor_flash/src/main.c, project/at_start_f435/examples/xmc/psram/src/main.c, project/at_start_f435/examples/xmc/sdram_basic/src/main.c, project/at_start_f435/examples/xmc/sdram_dma/src/main.c, project/at_start_f435/examples/xmc/sram/src/main.c, project/at_start_f435/templates/src/main.c, project/at_start_f437/examples/emac/dns_client/src/main.c, project/at_start_f437/examples/emac/http_server/src/main.c, project/at_start_f437/examples/emac/iperf/src/main.c, project/at_start_f437/examples/emac/mqtt_client/src/main.c, project/at_start_f437/examples/emac/tcp_client/src/main.c, project/at_start_f437/examples/emac/tcp_server/src/main.c, project/at_start_f437/examples/emac/telnet/src/main.c, project/at_start_f437/examples/emac/wake_on_lan/src/main.c, utilities/at32f435_437_freertos_demo/src/main.c, utilities/at32f435_437_gen_random_number_demo/src/main.c, utilities/at32f435_437_slib_demo/project_l0/src/main.c, utilities/at32f435_437_slib_demo/project_l1/src/main.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/main.c
  • main_page_name : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • MAKE_VALUE : at32f435_437.h
  • MASTER_BOARD : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c
  • MATCH_ID_VAL : project/at_start_f435/examples/usart/receiver_mute/src/main.c, project/at_start_f437/examples/usart/receiver_mute/src/main.c
  • MAX : usb_std.h
  • MAX_ARG_SIZE : flash_loader.c, flash_config.h
  • MAX_ARGS : flash_loader.c, flash_config.h
  • max_marks : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • MAX_NAME_SIZE : telnet.c
  • MAX_TRANSFER_CNT : at32f435_437_i2c.h
  • mblock_rbuffer : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c
  • mblock_tbuffer : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c
  • mclk_tmr1_init() : at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • MCU_ID1 : audio_desc.h, audio_hid_desc.h, cdc_desc.h, cdc_keyboard_desc.h, cdc_msc_desc.h, custom_hid_desc.h, hid_iap_desc.h, keyboard_desc.h, mouse_desc.h, msc_desc.h, printer_desc.h
  • MCU_ID2 : audio_desc.h, audio_hid_desc.h, cdc_desc.h, cdc_keyboard_desc.h, cdc_msc_desc.h, custom_hid_desc.h, hid_iap_desc.h, keyboard_desc.h, mouse_desc.h, msc_desc.h, printer_desc.h
  • MCU_ID3 : audio_desc.h, audio_hid_desc.h, cdc_desc.h, cdc_keyboard_desc.h, cdc_msc_desc.h, custom_hid_desc.h, hid_iap_desc.h, keyboard_desc.h, mouse_desc.h, msc_desc.h, printer_desc.h
  • mean : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • MEDIUM_HAVE_CHANGED : cdc_msc_class.h, msc_bot_scsi.h
  • MEDIUM_NOT_PRESENT : cdc_msc_class.h, msc_bot_scsi.h
  • MEM_ALIGNMENT : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • MEM_SIZE : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • MemManage_Handler() : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c, project/at_start_f435/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f435/examples/can/filter/src/at32f435_437_int.c, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c, project/at_start_f435/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c, project/at_start_f435/templates/inc/at32f435_437_int.h, project/at_start_f435/templates/src/at32f435_437_int.c, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f437/templates/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/src/at32f435_437_int.c, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_int.h, utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_int.c
  • MemoryManagement_IRQn : at32f435_437.h
  • MEMP_NUM_SYS_TIMEOUT : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • MEMP_NUM_TCP_SEG : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • memset16_buffer() : at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • message_cnt : project/at_start_f437/examples/emac/mqtt_client/src/netconf.c
  • message_test : project/at_start_f437/examples/emac/mqtt_client/src/netconf.c
  • MIB2_STATS : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • MIC_BUFFER_SIZE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • mic_dma_buffer : at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • MIN : usb_std.h
  • min_marks : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • MIN_REQ_LEN : httpd.c
  • MISC_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • MMC_RX_ALIGN_ERROR : at32f435_437_emac.h
  • MMC_RX_CRC_ERROR : at32f435_437_emac.h
  • MMC_RX_GOOD_UNICAST : at32f435_437_emac.h
  • mmc_stream_read() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • mmc_stream_test() : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c
  • mmc_stream_write() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • mmc_switch() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • MMC_SWITCH_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • MMC_TX_GOOD_FRAMES : at32f435_437_emac.h
  • MMC_TX_MULTIPLE_COL : at32f435_437_emac.h
  • MMC_TX_SINGLE_COL : at32f435_437_emac.h
  • MOUSE_BCD_NUM : mouse_desc.h
  • MOUSE_BINTERVAL_TIME : mouse_desc.h
  • MOUSE_BUTTON_LEFT : usbh_hid_mouse.h
  • MOUSE_BUTTON_MIDDLE : usbh_hid_mouse.h
  • MOUSE_BUTTON_RIGHT : usbh_hid_mouse.h
  • mouse_class_handler : mouse_class.c, mouse_class.h
  • mouse_desc_handler : mouse_desc.c, mouse_desc.h
  • mouse_struct : mouse_class.c
  • MOUSE_WINDOW_HEIGHT : usbh_hid_mouse.h
  • MOUSE_WINDOW_WIDTH : usbh_hid_mouse.h
  • MOUSE_WINDOW_X : usbh_hid_mouse.h
  • MOUSE_WINDOW_Y : usbh_hid_mouse.h
  • MOVE_STEP : mouse_class.h
  • mqtt_client_init() : mqtt_client.h
  • mqtt_client_pub_request_cb() : mqtt_client.h, mqtt_client.c
  • mqtt_conn_sub_proc() : mqtt_client.c
  • mqtt_error_process_callback() : mqtt_client.c
  • mqtt_send_timer : project/at_start_f437/examples/emac/mqtt_client/src/netconf.c
  • MQTT_SERVER_ADDRESS : mqtt_client.h
  • MQTT_SERVER_PORT : mqtt_client.h
  • MS_TICK : project/at_start_f435/examples/cortex_m4/systick_interrupt/src/main.c, project/at_start_f437/examples/cortex_m4/systick_interrupt/src/main.c
  • MSC_BCD_NUM : msc_desc.h
  • msc_bot_scsi_init() : usbh_msc_bot_scsi.c, usbh_msc_class.h
  • MSC_BOT_STATE_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_BOT_STATE_IDLE : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_BOT_STATE_RECOVERY : cdc_msc_class.h, msc_bot_scsi.h
  • msc_bot_state_type : usbh_msc_bot_scsi.h
  • MSC_CAPACITY10_CMD_LEN : usbh_msc_bot_scsi.h
  • MSC_CAPACITY10_DATA_LEN : usbh_msc_bot_scsi.h
  • MSC_CBW_CB_LEN : usbh_msc_bot_scsi.h
  • MSC_CBW_FLAG_IN : usbh_msc_bot_scsi.h
  • MSC_CBW_FLAG_OUT : usbh_msc_bot_scsi.h
  • MSC_CBW_LEN : usbh_msc_bot_scsi.h
  • MSC_CBW_SIGNATURE : usbh_msc_bot_scsi.h
  • MSC_CBW_TAG : usbh_msc_bot_scsi.h
  • msc_class_handler : msc_class.c, msc_class.h
  • msc_class_setup_handler() : cdc_msc_class.c
  • MSC_CMD_ALLOW_MEDIUM_REMOVAL : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_FORMAT_UNIT : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_INQUIRY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_MODE_SENSE10 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_MODE_SENSE6 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_READ_10 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_READ_12 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_READ_CAPACITY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_READ_FORMAT_CAPACITY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_REQUEST_SENSE : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_START_STOP : cdc_msc_class.h, msc_bot_scsi.h
  • msc_cmd_state_type : usbh_msc_bot_scsi.h
  • MSC_CMD_TEST_UNIT : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_VERIFY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_WRITE_10 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_WRITE_12 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_WRITE_VERIFY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CSW_LEN : usbh_msc_bot_scsi.h
  • MSC_CSW_SIGNATURE : usbh_msc_bot_scsi.h
  • msc_desc_handler : msc_desc.c, msc_desc.h
  • msc_disk_capacity() : at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c, at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h
  • msc_disk_read() : at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c, at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h
  • msc_disk_write() : at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c, at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h
  • MSC_ERROR : usbh_msc_bot_scsi.h
  • msc_error_type : usbh_msc_bot_scsi.h
  • msc_flash_size : at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c, at_start_f435/examples/usb_device/msc/src/msc_diskio.c, at_start_f437/examples/usb_device/composite_vcp_msc/src/msc_diskio.c, at_start_f437/examples/usb_device/msc/src/msc_diskio.c
  • MSC_INQUIRY_CMD_LEN : usbh_msc_bot_scsi.h
  • MSC_INQUIRY_DATA_LEN : usbh_msc_bot_scsi.h
  • MSC_MAX_DATA_BUF_LEN : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_NOT_READY : usbh_msc_bot_scsi.h
  • MSC_OK : usbh_msc_bot_scsi.h
  • MSC_OPCODE_CAPACITY : usbh_msc_bot_scsi.h
  • MSC_OPCODE_INQUIRY : usbh_msc_bot_scsi.h
  • MSC_OPCODE_READ10 : usbh_msc_bot_scsi.h
  • MSC_OPCODE_REQUEST_SENSE : usbh_msc_bot_scsi.h
  • MSC_OPCODE_TEST_UNIT_READY : usbh_msc_bot_scsi.h
  • MSC_OPCODE_WRITE10 : usbh_msc_bot_scsi.h
  • MSC_PROTOCOL_BBB : usbh_msc_class.h
  • MSC_READ_CMD_LEN : usbh_msc_bot_scsi.h
  • MSC_REQ_BO_RESET : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_REQ_BOMSR : usbh_msc_class.h
  • MSC_REQ_GET_MAX_LUN : cdc_msc_class.h, msc_bot_scsi.h, usbh_msc_class.h
  • MSC_REQUEST_SENSE_CMD_LEN : usbh_msc_bot_scsi.h
  • MSC_REQUEST_SENSE_DATA_LEN : usbh_msc_bot_scsi.h
  • MSC_STATE_MACHINE_CMD : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_DATA_IN : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_DATA_OUT : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_FAILED : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_IDLE : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_LAST_DATA : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_SEND_DATA : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_STATUS : cdc_msc_class.h, msc_bot_scsi.h
  • msc_state_type : usbh_msc_bot_scsi.h
  • msc_struct : msc_class.c
  • MSC_SUBCLASS_SCSI_TRANS : usbh_msc_class.h
  • MSC_SUPPORT_MAX_LUN : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_TEST_UNIT_READY_CMD_LEN : usbh_msc_bot_scsi.h
  • MSC_TEST_UNIT_READY_DATA_LEN : usbh_msc_bot_scsi.h
  • msc_usr_state : at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • MSC_WRITE_CMD_LEN : usbh_msc_bot_scsi.h
  • MULTI_BUFFER_SIZE : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c
  • my_memset() : arm_fir_init_f32.c


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- n -

  • nand_address_increment() : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c
  • NAND_BUSY : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_CMD_AREA_A : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_CMD_AREA_B : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_CMD_AREA_C : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_CMD_AREA_TRUE1 : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_CMD_ERASE0 : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_CMD_ERASE1 : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_CMD_LOCK_STATUS : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_CMD_READID : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_CMD_RESET : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_CMD_STATUS : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_CMD_WRITE0 : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_CMD_WRITE_TRUE1 : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • nand_ecc_correction() : project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c
  • nand_erase_block() : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c
  • NAND_ERROR : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • nand_get_status() : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c
  • nand_id_struct : project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c
  • nand_init() : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c
  • NAND_INVALID_ADDRESS : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • nand_read_id() : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c
  • nand_read_small_page() : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c
  • nand_read_spare_area() : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c
  • nand_read_status() : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c
  • NAND_READY : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • nand_reset() : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c
  • NAND_TIMEOUT_ERROR : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • NAND_VALID_ADDRESS : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • nand_write_small_page() : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c
  • nand_write_spare_area() : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/ecc/src/xmc_ecc.c, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f435/examples/xmc/nand_flash/nand/src/xmc_nand.c
  • netif : project/at_start_f437/examples/emac/dns_client/src/netconf.c, project/at_start_f437/examples/emac/http_server/src/netconf.c, project/at_start_f437/examples/emac/iperf/src/netconf.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_server/src/netconf.c, project/at_start_f437/examples/emac/telnet/src/netconf.c, project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • NMI_Handler() : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c, project/at_start_f435/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f435/examples/can/filter/src/at32f435_437_int.c, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c, project/at_start_f435/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c, project/at_start_f435/templates/inc/at32f435_437_int.h, project/at_start_f435/templates/src/at32f435_437_int.c, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f437/templates/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/src/at32f435_437_int.c, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_int.h, utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_int.c
  • NO_BUTTON : at32f435_437_board.h
  • NO_SYS : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • NonMaskableInt_IRQn : at32f435_437.h
  • nor_eraseblock() : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • nor_erasechip() : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • NOR_ERROR : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • nor_getstatus() : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • nor_id : project/at_start_f435/examples/xmc/nor_flash/src/main.c, project/at_start_f437/examples/xmc/nor_flash/src/main.c
  • nor_init() : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • NOR_ONGOING : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • nor_programbuffer() : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • nor_readbuffer() : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • nor_readhalfword() : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • nor_readid() : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • nor_reset() : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • nor_returntoreadmode() : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • nor_status : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • NOR_SUCCESS : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • NOR_TIMEOUT : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • NOR_WRITE : at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c
  • nor_writebuffer() : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • nor_writehalfword() : at_start_f435/examples/xmc/nor_flash/inc/xmc_nor.h, at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/inc/xmc_nor.h
  • NULL : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • NUM_DEFAULT_FILENAMES : httpd.c
  • NUM_TAPS : fir_coefficient.c, fir_filter.c
  • number : project/at_start_f435/examples/xmc/nor_flash/src/main.c, project/at_start_f435/examples/xmc/psram/src/main.c, project/at_start_f435/examples/xmc/sdram_basic/src/main.c, project/at_start_f435/examples/xmc/sdram_dma/src/main.c, project/at_start_f435/examples/xmc/sram/src/main.c, project/at_start_f437/examples/xmc/nor_flash/src/main.c, project/at_start_f437/examples/xmc/psram/src/main.c, project/at_start_f437/examples/xmc/sdram_basic/src/main.c, project/at_start_f437/examples/xmc/sdram_dma/src/main.c, project/at_start_f437/examples/xmc/sram/src/main.c
  • numStudents : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • NUMSTUDENTS : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • NUMSUBJECTS : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • numSubjects : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • nvic_configuration() : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sdio_fatfs/src/main.c
  • nvic_irq_disable() : at32f435_437_misc.h, at32f435_437_misc.c
  • nvic_irq_enable() : at32f435_437_misc.h, at32f435_437_misc.c
  • nvic_lowpower_mode_config() : at32f435_437_misc.h, at32f435_437_misc.c
  • nvic_lowpower_mode_type : at32f435_437_misc.h
  • NVIC_LP_SEVONPEND : at32f435_437_misc.h
  • NVIC_LP_SLEEPDEEP : at32f435_437_misc.h
  • NVIC_LP_SLEEPONEXIT : at32f435_437_misc.h
  • NVIC_PRIORITY_GROUP_0 : at32f435_437_misc.h
  • NVIC_PRIORITY_GROUP_1 : at32f435_437_misc.h
  • NVIC_PRIORITY_GROUP_2 : at32f435_437_misc.h
  • NVIC_PRIORITY_GROUP_3 : at32f435_437_misc.h
  • NVIC_PRIORITY_GROUP_4 : at32f435_437_misc.h
  • nvic_priority_group_config() : at32f435_437_misc.h, at32f435_437_misc.c
  • nvic_priority_group_type : at32f435_437_misc.h
  • nvic_system_reset() : at32f435_437_misc.h, at32f435_437_misc.c
  • nvic_vector_table_set() : at32f435_437_misc.h, at32f435_437_misc.c
  • NVIC_VECTTAB_FLASH : at32f435_437_misc.h
  • NVIC_VECTTAB_RAM : at32f435_437_misc.h


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- o -

  • ONCHIP : FlashOS.h
  • OPERATION_TIMEOUT : at32f435_437_flash.h
  • OPTIONAL_CHECKSUM : flash_loader.h
  • OPTIONAL_SIGNOFF : flash_loader.h
  • OTG1_GLOBAL : at32f435_437_usb.h
  • OTG2_CLOCK : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • otg2_core_struct : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f437/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f437/examples/usb_host/two_otg_host_demo/src/main.c
  • OTG2_GLOBAL : at32f435_437_usb.h
  • OTG2_IRQ : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_IRQ_HANDLER : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c
  • OTG2_PIN_DM : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_DM_SOURCE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_DP : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_DP_SOURCE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_GPIO : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_GPIO_CLOCK : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_ID : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_ID_SOURCE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_MUX : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_POWER_SWITCH : project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_POWER_SWITCH_CLOCK : project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_POWER_SWITCH_GPIO : project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_SOF : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_SOF_GPIO : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_SOF_GPIO_CLOCK : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_SOF_SOURCE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_VBUS : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_PIN_VBUS_SOURCE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_WKUP_EXINT_LINE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_WKUP_HANDLER : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG2_WKUP_IRQ : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG_CLOCK : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • otg_core_struct : project/at_start_f435/examples/acc/calibration/src/main.c, project/at_start_f435/examples/usb_device/audio/src/main.c, project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f435/examples/usb_device/custom_hid/src/main.c, project/at_start_f435/examples/usb_device/keyboard/src/main.c, project/at_start_f435/examples/usb_device/mouse/src/main.c, project/at_start_f435/examples/usb_device/msc/src/main.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/printer/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c, project/at_start_f435/examples/usb_host/hid_demo/src/main.c, project/at_start_f435/examples/usb_host/msc_only_fat32/src/main.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c, project/at_start_f437/examples/acc/calibration/src/main.c, project/at_start_f437/examples/usb_device/audio/src/main.c, project/at_start_f437/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f437/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f437/examples/usb_device/custom_hid/src/main.c, project/at_start_f437/examples/usb_device/keyboard/src/main.c, project/at_start_f437/examples/usb_device/mouse/src/main.c, project/at_start_f437/examples/usb_device/msc/src/main.c, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f437/examples/usb_device/printer/src/main.c, project/at_start_f437/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f437/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f437/examples/usb_device/virtual_comport/src/main.c, project/at_start_f437/examples/usb_device/virtual_msc_iap/src/main.c, project/at_start_f437/examples/usb_host/hid_demo/src/main.c, project/at_start_f437/examples/usb_host/msc_only_fat32/src/main.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, project/at_start_f437/examples/usb_host/two_otg_host_demo/src/main.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c
  • OTG_DEVICE : at32f435_437_usb.h
  • OTG_DEVICE_ADDR_OFFSET : at32f435_437_usb.h
  • OTG_DEVICE_EPTIN_ADDR_OFFSET : at32f435_437_usb.h
  • OTG_DEVICE_EPTOUT_ADDR_OFFSET : at32f435_437_usb.h
  • OTG_DEVICE_MODE : at32f435_437_usb.h
  • OTG_DRD_MODE : at32f435_437_usb.h
  • OTG_FIFO_ADDR_OFFSET : at32f435_437_usb.h
  • OTG_FIFO_SIZE : at32f435_437_usb.h
  • OTG_HOST : at32f435_437_usb.h
  • OTG_HOST_ADDR_OFFSET : at32f435_437_usb.h
  • OTG_HOST_CHANNEL_ADDR_OFFSET : at32f435_437_usb.h
  • OTG_HOST_MODE : at32f435_437_usb.h
  • otg_id_type : at32f435_437_usb.h
  • OTG_IRQ : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_IRQ_HANDLER : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h, project/at_start_f435/examples/acc/calibration/src/main.c, project/at_start_f435/examples/usb_device/audio/src/main.c, project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f435/examples/usb_device/custom_hid/src/main.c, project/at_start_f435/examples/usb_device/keyboard/src/main.c, project/at_start_f435/examples/usb_device/mouse/src/main.c, project/at_start_f435/examples/usb_device/msc/src/main.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/printer/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c, project/at_start_f435/examples/usb_host/hid_demo/src/main.c, project/at_start_f435/examples/usb_host/msc_only_fat32/src/main.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c
  • otg_mode_type : at32f435_437_usb.h
  • OTG_PCGCCTL : at32f435_437_usb.h
  • OTG_PCGCCTL_ADDR_OFFSET : at32f435_437_usb.h
  • OTG_PIN_DM : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_DM_SOURCE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_DP : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_DP_SOURCE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_GPIO : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_GPIO_CLOCK : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_ID : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_ID_SOURCE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_MUX : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_POWER_SWITCH : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG_PIN_POWER_SWITCH_CLOCK : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG_PIN_POWER_SWITCH_GPIO : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • OTG_PIN_SOF : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_SOF_GPIO : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_SOF_GPIO_CLOCK : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_SOF_SOURCE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_VBUS : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_PIN_VBUS_SOURCE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_USB_ID : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_WKUP_EXINT_LINE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_WKUP_HANDLER : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTG_WKUP_IRQ : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • OTGFS1_BASE : at32f435_437.h
  • OTGFS1_IRQn : at32f435_437.h
  • OTGFS1_WKUP_IRQn : at32f435_437.h
  • OTGFS2_BASE : at32f435_437.h
  • OTGFS2_IRQn : at32f435_437.h
  • OTGFS2_WKUP_IRQn : at32f435_437.h
  • OTGFS_USB_DEVICE : at32f435_437_usb.h
  • OTGFS_USB_GLOBAL : at32f435_437_usb.h
  • OTGFS_USB_HOST : at32f435_437_usb.h
  • OV2640_ADDR : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_auto_exposure() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_AUTOEXPOSURE_LEVEL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c
  • ov2640_brightness() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_capture() : project/at_start_f435/examples/dvp/ov2640_capture/src/main.c
  • ov2640_color_bar() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_color_saturation() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_contrast() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_BPADDR : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_BPDATA : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_CTRL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_CTRL0 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_CTRL1 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_CTRL2 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_CTRL3 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_DPRP : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_HSIZE1 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_HSIZE2 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_IMAGE_MODE : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_MC_AH : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_MC_AL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_MC_BIST : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_MC_D : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_MS_SP : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_P_STATUS : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_Qs : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_R_BYPASS : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_R_DVP_SP : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_RA_DLMT : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_RESET : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_SIZEL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_SS_CTRL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_SS_ID : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_TEST : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_VHYX : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_VSIZE1 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_VSIZE2 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_XOFFL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_YOFFL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_ZMHH : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_ZMOH : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_DSP_ZMOW : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_i2c_init() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_imagesize_set() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_imagewin_set() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_init() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_jpeg_mode() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_jpeg_reg_tbl : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h
  • ov2640_light_mode() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_MID : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_outsize_set() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_PID : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_PWRON_HIGH : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_PWRON_LOW : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_reg_read() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_reg_write() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_rgb565_mode() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_rgb565_reg_tbl : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h
  • OV2640_RST_HIGH : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_RST_LOW : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_ADDVHS : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_ADDVSL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_AEB : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_AEC : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_AEW : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_ARCOM2 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_BD50 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_BD60 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_CLKRC : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_COM1 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_COM10 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_COM19 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_COM2 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_COM22 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_COM25 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_COM3 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_COM4 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_COM7 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_COM8 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_COM9 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_FLH : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_FLL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_FRARL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_GAIN : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_HISTO_HIGH : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_HISTO_LOW : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_HREFEND : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_HREFST : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_MIDH : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_MIDL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_PIDH : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_PIDL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_REG04 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_REG08 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_REG2A : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_REG32 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_REG45 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_REG5D : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_REG5E : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_REG5F : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_REG60 : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_VEND : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_VSTART : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_W : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_YAVG : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • OV2640_SENSOR_ZOOMS : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_special_effects() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_svga_init_reg_tbl : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h
  • ov2640_sxga_init_reg_tbl : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h
  • ov2640_window_set() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.h
  • ov2640_yuv422_reg_tbl : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h
  • OV5640_ADDR : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • OV5640_AF_Config : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640af.h, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640af.h
  • ov5640_brightness() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_capture() : project/at_start_f435/examples/dvp/ov5640_capture/src/main.c
  • OV5640_CHIPIDH : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • OV5640_CHIPIDL : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_color_saturation() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_contrast() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • OV5640_EFFECTS_TBL : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c
  • ov5640_exposure() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • OV5640_EXPOSURE_TBL : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c
  • ov5640_flash_ctrl() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_focus_constant() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_focus_init() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_focus_single() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_i2c_init() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • OV5640_ID : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_imagewin_set() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_init() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_jpeg_mode() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • OV5640_jpeg_reg_tbl : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h
  • ov5640_light_mode() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • OV5640_LIGHTMODE_TBL : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c
  • ov5640_outsize_set() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_reg_read() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_reg_write() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_rgb565_mode() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_rgb565_reg_tbl : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h
  • OV5640_RST_HIGH : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • OV5640_RST_LOW : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • OV5640_SATURATION_TBL : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c
  • ov5640_sharpness() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_special_effects() : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.h
  • ov5640_uxga_init_reg_tbl : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h
  • ov_cnt : project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f437/examples/usb_device/virtual_comport/src/main.c
  • ov_frame : at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c, at_start_f437/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f437/examples/dvp/ov5640_capture/hardware/dvp/dvp.c
  • OVERRIDE_BUFSIZE : flash_loader_extra.h
  • OVERRIDE_LAYOUT : flash_loader_extra.h
  • OVERRIDE_PAGESIZE : flash_loader_extra.h


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- p -

  • p_adc1_ordinary : project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c, project/at_start_f437/examples/adc/use_polling_get_conversion_data/src/main.c
  • PAGE_MAX : FlashOS.h
  • page_number : project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c
  • pagenumber : project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c
  • PARAMETER_LIST_LENGTH_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • parsing_result() : project/at_start_f437/examples/emac/dns_client/src/main.c
  • PASSWORD : httpserver.h
  • PBUF_POOL_BUFSIZE : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • PBUF_POOL_SIZE : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • pcb : project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c
  • PEM_STEP_BEGIN : at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c
  • PEM_STEP_END : at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c
  • PEM_STEP_KEEP : at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c
  • pem_step_type : at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c
  • PEMOPC_RESET : at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c
  • PEMOPC_SET : at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c
  • PEN_HIGH : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h
  • PendSV_Handler() : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c, project/at_start_f435/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f435/examples/can/filter/src/at32f435_437_int.c, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c, project/at_start_f435/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c, project/at_start_f435/templates/inc/at32f435_437_int.h, project/at_start_f435/templates/src/at32f435_437_int.c, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f437/templates/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_int.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_int.h, utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_int.c
  • PendSV_IRQn : at32f435_437.h
  • period_value : project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/lick_calibration/src/main.c, project/at_start_f437/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f437/examples/ertc/lick_calibration/src/main.c
  • PERIPH_BASE : at32f435_437.h
  • PERIPH_BB_BASE : at32f435_437.h
  • PERIPH_REG : at32f435_437.h
  • PERIPH_REG_BIT : at32f435_437.h
  • PERIPHERAL_BASE : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f437/examples/cortex_m4/bit_band/src/main.c
  • PERIPHERAL_BITBAND_BASE : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f437/examples/cortex_m4/bit_band/src/main.c
  • PERIPHERAL_RESET_BIT : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f437/examples/cortex_m4/bit_band/src/main.c
  • PERIPHERAL_SET_BIT : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f437/examples/cortex_m4/bit_band/src/main.c
  • pftarget : project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c, project/at_start_f437/examples/usb_device/virtual_msc_iap/src/main.c, bootloader/src/hid_iap_user.c
  • PHY_ADDRESS : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_AUTO_NEGOTIATION_BIT : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_CONTROL_REG : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_FULL_DUPLEX_100MBPS_BIT : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_FULL_DUPLEX_10MBPS_BIT : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_HALF_DUPLEX_100MBPS_BIT : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_HALF_DUPLEX_10MBPS_BIT : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_LINKED_STATUS_BIT : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_LOOPBACK_BIT : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_NEGO_COMPLETE_BIT : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_RESET_BIT : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_SPECIFIED_CS_REG : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_STATUS_REG : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • PHY_TIMEOUT : at32f435_437_emac.h
  • PKTSTS_CHANNEL_STOP : at32f435_437_usb.h
  • PKTSTS_DATA_BIT_ERROR : at32f435_437_usb.h
  • PKTSTS_IN_DATA_PACKET_RECV : at32f435_437_usb.h
  • PKTSTS_IN_TRANSFER_COMPLETE : at32f435_437_usb.h
  • point_color : project/at_start_f435/examples/dvp/ov2640_capture/src/main.c, project/at_start_f435/examples/dvp/ov5640_capture/src/main.c, project/at_start_f435/examples/xmc/lcd_8bit/src/main.c, project/at_start_f435/examples/xmc/lcd_touch_16bit/src/main.c, project/at_start_f437/examples/dvp/ov2640_capture/src/main.c, project/at_start_f437/examples/dvp/ov5640_capture/src/main.c, project/at_start_f437/examples/xmc/lcd_8bit/src/main.c, project/at_start_f437/examples/xmc/lcd_touch_16bit/src/main.c
  • preempt_conversion_count : project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c
  • preempt_trigger_count : project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c
  • prescalervalue : project/at_start_f435/examples/irtmr/irtmr_output/src/main.c, project/at_start_f435/examples/tmr/oc_high/src/main.c, project/at_start_f435/examples/tmr/oc_low/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f435/examples/tmr/one_cycle/src/main.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f437/examples/irtmr/irtmr_output/src/main.c, project/at_start_f437/examples/tmr/oc_high/src/main.c, project/at_start_f437/examples/tmr/oc_low/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f437/examples/tmr/one_cycle/src/main.c, project/at_start_f437/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f437/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f437/examples/tmr/pwm_output_tmr3/src/main.c
  • press_mouse : project/at_start_f435/examples/usb_device/mouse/src/main.c, project/at_start_f437/examples/usb_device/mouse/src/main.c
  • PRINT_UART : at32f435_437_board.h
  • PRINT_UART_CRM_CLK : at32f435_437_board.h
  • PRINT_UART_TX_GPIO : at32f435_437_board.h
  • PRINT_UART_TX_GPIO_CRM_CLK : at32f435_437_board.h
  • PRINT_UART_TX_PIN : at32f435_437_board.h
  • PRINT_UART_TX_PIN_MUX_NUM : at32f435_437_board.h
  • PRINT_UART_TX_PIN_SOURCE : at32f435_437_board.h
  • PRINTER_BCD_NUM : printer_desc.h
  • printer_class_handler : printer_class.c, printer_class.h
  • printer_desc_handler : printer_desc.c, printer_desc.h
  • PRINTER_DEVICE_ID_LEN : printer_class.h
  • PRINTER_PROTOCOL_1284_4 : printer_desc.h
  • PRINTER_PROTOCOL_BI_DIRECTIONAL : printer_desc.h
  • PRINTER_PROTOCOL_UNIDIRECTIONAL : printer_desc.h
  • PRINTER_PROTOCOL_VENDOR_SPECIFIC : printer_desc.h
  • PRINTER_REQ_GET_DEVICE_ID : printer_class.h
  • PRINTER_REQ_GET_PORT_STATUS : printer_class.h
  • PRINTER_REQ_GET_SOFT_RESET : printer_class.h
  • printer_req_type : printer_class.h
  • printer_struct : printer_class.c
  • PROGRAM_TIMEOUT : at_start_f435/examples/xmc/nor_flash/src/xmc_nor.c, at_start_f437/examples/xmc/nor_flash/src/xmc_nor.c
  • PROGRAMMING_TIMEOUT : at32f435_437_flash.h
  • ProgramPage() : FlashOS.h, FlashPrg.c
  • psram_init() : at_start_f435/examples/xmc/psram/inc/xmc_psram.h, at_start_f435/examples/xmc/psram/src/xmc_psram.c, at_start_f437/examples/xmc/psram/inc/xmc_psram.h
  • psram_readbuffer() : at_start_f435/examples/xmc/psram/inc/xmc_psram.h, at_start_f435/examples/xmc/psram/src/xmc_psram.c, at_start_f437/examples/xmc/psram/inc/xmc_psram.h
  • psram_writebuffer() : at_start_f435/examples/xmc/psram/inc/xmc_psram.h, at_start_f435/examples/xmc/psram/src/xmc_psram.c, at_start_f437/examples/xmc/psram/inc/xmc_psram.h
  • PUTCHAR_PROTOTYPE : at32f435_437_board.c
  • pvm_exint_config() : project/at_start_f435/examples/pwc/power_voltage_monitor/src/main.c
  • PVM_IRQHandler() : project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c
  • PVM_IRQn : at32f435_437.h
  • PWC : at32f435_437_pwc.h
  • PWC_BASE : at32f435_437.h
  • pwc_battery_powered_domain_access() : at32f435_437_pwc.h, at32f435_437_pwc.c
  • pwc_deep_sleep_enter_type : at32f435_437_pwc.h
  • PWC_DEEP_SLEEP_ENTER_WFE : at32f435_437_pwc.h
  • PWC_DEEP_SLEEP_ENTER_WFI : at32f435_437_pwc.h
  • pwc_deep_sleep_mode_enter() : at32f435_437_pwc.h, at32f435_437_pwc.c
  • pwc_flag_clear() : at32f435_437_pwc.h, at32f435_437_pwc.c
  • pwc_flag_get() : at32f435_437_pwc.h, at32f435_437_pwc.c
  • PWC_LDO_OUTPUT_1V0 : at32f435_437_pwc.h
  • PWC_LDO_OUTPUT_1V1 : at32f435_437_pwc.h
  • PWC_LDO_OUTPUT_1V2 : at32f435_437_pwc.h
  • PWC_LDO_OUTPUT_1V3 : at32f435_437_pwc.h
  • pwc_ldo_output_voltage_set : at32f435_437_pwc.h
  • pwc_ldo_output_voltage_type : at32f435_437_pwc.h
  • PWC_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • pwc_power_voltage_monitor_enable() : at32f435_437_pwc.h, at32f435_437_pwc.c
  • pwc_pvm_level_select() : at32f435_437_pwc.h, at32f435_437_pwc.c
  • PWC_PVM_OUTPUT_FLAG : at32f435_437_pwc.h
  • PWC_PVM_VOLTAGE_2V3 : at32f435_437_pwc.h
  • PWC_PVM_VOLTAGE_2V4 : at32f435_437_pwc.h
  • PWC_PVM_VOLTAGE_2V5 : at32f435_437_pwc.h
  • PWC_PVM_VOLTAGE_2V6 : at32f435_437_pwc.h
  • PWC_PVM_VOLTAGE_2V7 : at32f435_437_pwc.h
  • PWC_PVM_VOLTAGE_2V8 : at32f435_437_pwc.h
  • PWC_PVM_VOLTAGE_2V9 : at32f435_437_pwc.h
  • pwc_pvm_voltage_type : at32f435_437_pwc.h
  • PWC_REGULATOR_LOW_POWER : at32f435_437_pwc.h
  • PWC_REGULATOR_ON : at32f435_437_pwc.h
  • pwc_regulator_type : at32f435_437_pwc.h
  • pwc_reset() : at32f435_437_pwc.h, at32f435_437_pwc.c
  • pwc_sleep_enter_type : at32f435_437_pwc.h
  • PWC_SLEEP_ENTER_WFE : at32f435_437_pwc.h
  • PWC_SLEEP_ENTER_WFI : at32f435_437_pwc.h
  • pwc_sleep_mode_enter() : at32f435_437_pwc.h, at32f435_437_pwc.c
  • PWC_STANDBY_FLAG : at32f435_437_pwc.h
  • pwc_standby_mode_enter() : at32f435_437_pwc.h, at32f435_437_pwc.c
  • pwc_voltage_regulate_set() : at32f435_437_pwc.h, at32f435_437_pwc.c
  • PWC_WAKEUP_FLAG : at32f435_437_pwc.h
  • PWC_WAKEUP_PIN_1 : at32f435_437_pwc.h
  • PWC_WAKEUP_PIN_2 : at32f435_437_pwc.h
  • pwc_wakeup_pin_enable() : at32f435_437_pwc.h, at32f435_437_pwc.c


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- q -

  • QSPI1 : at32f435_437_qspi.h
  • QSPI1_IRQHandler() : at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c
  • QSPI1_IRQn : at32f435_437.h
  • QSPI1_MEM_BASE : at32f435_437.h
  • QSPI1_REG_BASE : at32f435_437.h
  • QSPI2 : at32f435_437_qspi.h
  • QSPI2_IRQn : at32f435_437.h
  • QSPI2_MEM_BASE : at32f435_437.h
  • QSPI2_REG_BASE : at32f435_437.h
  • qspi_busy_check() : at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c
  • qspi_busy_config() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • QSPI_BUSY_OFFSET_0 : at32f435_437_qspi.h
  • QSPI_BUSY_OFFSET_1 : at32f435_437_qspi.h
  • QSPI_BUSY_OFFSET_2 : at32f435_437_qspi.h
  • QSPI_BUSY_OFFSET_3 : at32f435_437_qspi.h
  • QSPI_BUSY_OFFSET_4 : at32f435_437_qspi.h
  • QSPI_BUSY_OFFSET_5 : at32f435_437_qspi.h
  • QSPI_BUSY_OFFSET_6 : at32f435_437_qspi.h
  • QSPI_BUSY_OFFSET_7 : at32f435_437_qspi.h
  • qspi_busy_pos_type : at32f435_437_qspi.h
  • qspi_byte_read() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_byte_write() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • QSPI_CLK_DIV_10 : at32f435_437_qspi.h
  • QSPI_CLK_DIV_12 : at32f435_437_qspi.h
  • QSPI_CLK_DIV_2 : at32f435_437_qspi.h
  • QSPI_CLK_DIV_3 : at32f435_437_qspi.h
  • QSPI_CLK_DIV_4 : at32f435_437_qspi.h
  • QSPI_CLK_DIV_5 : at32f435_437_qspi.h
  • QSPI_CLK_DIV_6 : at32f435_437_qspi.h
  • QSPI_CLK_DIV_8 : at32f435_437_qspi.h
  • qspi_clk_div_type : at32f435_437_qspi.h
  • qspi_clk_division_set() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_clk_mode_type : at32f435_437_qspi.h
  • QSPI_CMD_ADRLEN_0_BYTE : at32f435_437_qspi.h
  • QSPI_CMD_ADRLEN_1_BYTE : at32f435_437_qspi.h
  • QSPI_CMD_ADRLEN_2_BYTE : at32f435_437_qspi.h
  • QSPI_CMD_ADRLEN_3_BYTE : at32f435_437_qspi.h
  • QSPI_CMD_ADRLEN_4_BYTE : at32f435_437_qspi.h
  • qspi_cmd_adrlen_type : at32f435_437_qspi.h
  • qspi_cmd_init() : qspi_algorithm.c, FlashPrg.c
  • QSPI_CMD_INSLEN_0_BYTE : at32f435_437_qspi.h
  • QSPI_CMD_INSLEN_1_BYTE : at32f435_437_qspi.h
  • QSPI_CMD_INSLEN_2_BYTE : at32f435_437_qspi.h
  • qspi_cmd_inslen_type : at32f435_437_qspi.h
  • qspi_cmd_ly68l6400_send() : at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c
  • qspi_cmd_operation_kick() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • QSPI_CMDSTS_FLAG : at32f435_437_qspi.h
  • qspi_command_is_busy() : at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c
  • qspi_command_not_busy() : at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c
  • qspi_command_set_busy() : at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c
  • qspi_config() : project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c, project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c, project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c
  • qspi_data_once_write() : at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c
  • qspi_data_read() : project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c, project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c
  • qspi_data_write() : project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c, project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c
  • qspi_dma_enable() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_dma_fifo_thod_type : at32f435_437_qspi.h
  • QSPI_DMA_FIFO_THOD_WORD08 : at32f435_437_qspi.h
  • QSPI_DMA_FIFO_THOD_WORD16 : at32f435_437_qspi.h
  • QSPI_DMA_FIFO_THOD_WORD32 : at32f435_437_qspi.h
  • qspi_dma_rx_threshold_set() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_dma_set() : at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c
  • qspi_dma_tx_threshold_set() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_encryption_enable() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_erase() : project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c, project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c
  • QSPI_FIFO_DEPTH : at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c
  • qspi_flag_clear() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_flag_get() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_gpio_init() : qspi_algorithm.c, FlashPrg.c
  • qspi_half_word_read() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_half_word_write() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_interrupt_enable() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • QSPI_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • QSPI_OPERATE_MODE_111 : at32f435_437_qspi.h
  • QSPI_OPERATE_MODE_112 : at32f435_437_qspi.h
  • QSPI_OPERATE_MODE_114 : at32f435_437_qspi.h
  • QSPI_OPERATE_MODE_122 : at32f435_437_qspi.h
  • QSPI_OPERATE_MODE_144 : at32f435_437_qspi.h
  • QSPI_OPERATE_MODE_222 : at32f435_437_qspi.h
  • QSPI_OPERATE_MODE_444 : at32f435_437_qspi.h
  • qspi_operate_mode_type : at32f435_437_qspi.h
  • qspi_read_data_using_pem() : at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c
  • qspi_read_status_conf_type : at32f435_437_qspi.h
  • QSPI_RSTSC_HW_AUTO : at32f435_437_qspi.h
  • QSPI_RSTSC_SW_ONCE : at32f435_437_qspi.h
  • QSPI_RXFIFORDY_FLAG : at32f435_437_qspi.h
  • QSPI_SCK_MODE_0 : at32f435_437_qspi.h
  • QSPI_SCK_MODE_3 : at32f435_437_qspi.h
  • qspi_sck_mode_set() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_state_is_busy : at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c
  • QSPI_TXFIFORDY_FLAG : at32f435_437_qspi.h
  • qspi_word_read() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_word_write() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_write_enable() : at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c
  • QSPI_XIP_ADDRLEN_3_BYTE : at32f435_437_qspi.h
  • QSPI_XIP_ADDRLEN_4_BYTE : at32f435_437_qspi.h
  • qspi_xip_addrlen_type : at32f435_437_qspi.h
  • qspi_xip_cache_bypass_set() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_xip_enable() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_xip_init() : at32f435_437_qspi.h, at32f435_437_qspi.c
  • qspi_xip_init_ly68l6400() : project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c
  • qspi_xip_read_sel_type : at32f435_437_qspi.h
  • qspi_xip_write_sel_type : at32f435_437_qspi.h
  • QSPI_XIPR_SEL_MODED : at32f435_437_qspi.h
  • QSPI_XIPR_SEL_MODET : at32f435_437_qspi.h
  • QSPI_XIPW_SEL_MODED : at32f435_437_qspi.h
  • QSPI_XIPW_SEL_MODET : at32f435_437_qspi.h
  • QUIZ_MESSAGE : tcp_server.h
  • QWERTY_KEYBOARD : usbh_hid_keyboard.h


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- r -

  • RAM_BASE : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f437/examples/cortex_m4/bit_band/src/main.c
  • RAM_BITBAND_BASE : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f437/examples/cortex_m4/bit_band/src/main.c
  • randnum_test() : random.h, random.c
  • rbuf : project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c, project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c, project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c, project/at_start_f437/examples/qspi/command_port_using_interrupt/src/main.c, project/at_start_f437/examples/qspi/command_port_using_polling/src/main.c, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/main.c, project/at_start_f437/examples/qspi/xip_port_write_read/src/main.c
  • rca : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c, at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • READ_TIMES : at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c, at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c
  • REAL_CONSTANT : at_start_f435/examples/cortex_m4/fpu/inc/julia_fpu.h, at_start_f437/examples/cortex_m4/fpu/inc/julia_fpu.h
  • RED : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • refOutput : project_l0/src/arm_fir_data.c, utilities/at32f435_437_slib_demo/project_l0/src/main.c, project_l1/src/arm_fir_data.c, utilities/at32f435_437_slib_demo/project_l1/src/main.c
  • REG16 : at32f435_437.h
  • REG32 : at32f435_437.h
  • REG8 : at32f435_437.h
  • reg_addr_data : at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • report_buf : project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f435/examples/usb_device/custom_hid/src/main.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f437/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f437/examples/usb_device/custom_hid/src/main.c, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f437/examples/usb_device/two_otg_device_demo/src/main.c
  • REQ_SENSE_STANDARD_DATA_LEN : cdc_msc_class.h, msc_bot_scsi.h
  • RESET : at32f435_437.h
  • Reset_IRQn : at32f435_437.h
  • reset_phy() : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/dns_client/src/at32_emac.c, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/src/at32_emac.c, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/src/at32_emac.c, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/src/at32_emac.c, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/src/at32_emac.c, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/src/at32_emac.c, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/src/at32_emac.c, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • RESULT_CUSTOM_FIRST : flash_loader.h
  • RESULT_CUSTOM_LAST : flash_loader.h
  • RESULT_ERASE_DONE : flash_loader.h
  • RESULT_ERROR : flash_loader.h
  • result_error() : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c
  • RESULT_OK : flash_loader.h
  • RESULT_OVERRIDE_DEVICE : flash_loader.h
  • RIGHT_BUTTON : mouse_class.h
  • RIGHT_MOVE : mouse_class.h
  • RMII_MODE : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • ROW_ADDRESS : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • RS485_BAUDRATE : project/at_start_f435/examples/usart/rs485/src/main.c, project/at_start_f437/examples/usart/rs485/src/main.c
  • rs485_buffer_rx : project/at_start_f435/examples/usart/rs485/src/main.c, project/at_start_f437/examples/usart/rs485/src/main.c
  • rs485_buffer_rx_cnt : project/at_start_f435/examples/usart/rs485/src/main.c, project/at_start_f437/examples/usart/rs485/src/main.c
  • RS485_BUFFER_SIZE : project/at_start_f435/examples/usart/rs485/src/main.c, project/at_start_f437/examples/usart/rs485/src/main.c
  • rs485_config() : project/at_start_f435/examples/usart/rs485/src/main.c, project/at_start_f437/examples/usart/rs485/src/main.c
  • rs485_send_data() : project/at_start_f435/examples/usart/rs485/src/main.c, project/at_start_f437/examples/usart/rs485/src/main.c
  • rx_buf : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c
  • rx_buf1 : project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • rx_buf2 : project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • rx_buf3 : project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • rx_buffer : project/at_start_f435/examples/usart/hw_flow_control/src/main.c, project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f437/examples/usart/hw_flow_control/src/main.c, project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c
  • rx_counter : project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f435/examples/usart/receiver_mute/src/main.c, project/at_start_f437/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f437/examples/usart/receiver_mute/src/main.c
  • rx_index : project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • RX_REMAP : project/at_start_f437/examples/emac/dns_client/inc/at32_emac.h, project/at_start_f437/examples/emac/http_server/inc/at32_emac.h, project/at_start_f437/examples/emac/iperf/inc/at32_emac.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h, project/at_start_f437/examples/emac/tcp_server/inc/at32_emac.h, project/at_start_f437/examples/emac/telnet/inc/at32_emac.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32_emac.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32_emac.h
  • RXBUF_SIZE : project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c
  • rxbuffer : project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f435/examples/xmc/nor_flash/src/main.c, project/at_start_f435/examples/xmc/psram/src/main.c, project/at_start_f435/examples/xmc/sdram_basic/src/main.c, project/at_start_f435/examples/xmc/sdram_dma/src/main.c, project/at_start_f435/examples/xmc/sram/src/main.c, project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f437/examples/xmc/nor_flash/src/main.c, project/at_start_f437/examples/xmc/psram/src/main.c, project/at_start_f437/examples/xmc/sdram_basic/src/main.c, project/at_start_f437/examples/xmc/sdram_dma/src/main.c, project/at_start_f437/examples/xmc/sram/src/main.c


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- s -

  • s16 : at32f435_437.h
  • s32 : at32f435_437.h
  • s8 : at32f435_437.h
  • s__mqtt_client_instance : mqtt_client.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c
  • SAMPLE_FREQ : audio_desc.h, audio_hid_desc.h
  • SAMPLING_NUM : project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c
  • sblock_rbuffer : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c
  • sblock_tbuffer : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c
  • sc16 : at32f435_437.h
  • sc32 : at32f435_437.h
  • sc8 : at32f435_437.h
  • SC_3_5V_CLK : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_3_5V_PIN : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_3_5V_PORT : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • sc_a2r_struct : project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • sc_baud_rate : project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • sc_clock_freq : project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • SC_CMDVCC_CLK : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_CMDVCC_PIN : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_CMDVCC_PORT : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_F_DIV_D : project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • SC_OFF_CLK : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_OFF_EXINT : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_OFF_EXINT_IRQ : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_OFF_PIN : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_OFF_PINSOURCE : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_OFF_PORT : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_OFF_PORTSOURCE : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_RECEIVE_TIMEOUT : project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • SC_RESET_CLK : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_RESET_PIN : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_RESET_PORT : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • sc_response_decode() : project/at_start_f435/examples/usart/smartcard/src/main.c
  • SC_USART : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_USART_CLK : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_USART_CLK_PIN : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_USART_CLK_PORT : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_USART_DIV_VAL : project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • SC_USART_GPIO_CLK : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_USART_IRQHandler : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h, project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c
  • SC_USART_IRQn : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_USART_TX_PIN : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SC_USART_TX_PORT : at_start_f435/examples/usart/smartcard/inc/smartcard_config.h, at_start_f437/examples/usart/smartcard/inc/smartcard_config.h
  • SCCB_ID : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_Init() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_No_Ack() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_RD_Byte() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_RD_Reg() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_READ_SDA : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_SCL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_SDA : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_SDA_IN : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_SDA_OUT : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_Start() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_Stop() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_WR_Byte() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCCB_WR_Reg() : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/sccb.h
  • SCFG : at32f435_437_scfg.h
  • SCFG_BASE : at32f435_437.h
  • scfg_emac_interface_set() : at32f435_437_scfg.h, at32f435_437_scfg.c
  • scfg_emac_interface_type : at32f435_437_scfg.h
  • SCFG_EMAC_SELECT_MII : at32f435_437_scfg.h
  • SCFG_EMAC_SELECT_RMII : at32f435_437_scfg.h
  • scfg_exint_line_config() : at32f435_437_scfg.h, at32f435_437_scfg.c
  • scfg_infrared_config() : at32f435_437_scfg.h, at32f435_437_scfg.c
  • SCFG_IR_POLARITY_NO_AFFECTE : at32f435_437_scfg.h
  • SCFG_IR_POLARITY_REVERSE : at32f435_437_scfg.h
  • scfg_ir_polarity_type : at32f435_437_scfg.h
  • SCFG_IR_SOURCE_TMR10 : at32f435_437_scfg.h
  • scfg_ir_source_type : at32f435_437_scfg.h
  • SCFG_IR_SOURCE_USART1 : at32f435_437_scfg.h
  • SCFG_IR_SOURCE_USART2 : at32f435_437_scfg.h
  • SCFG_MEM_MAP_BOOT_MEMORY : at32f435_437_scfg.h
  • SCFG_MEM_MAP_INTERNAL_SRAM : at32f435_437_scfg.h
  • SCFG_MEM_MAP_MAIN_MEMORY : at32f435_437_scfg.h
  • scfg_mem_map_set() : at32f435_437_scfg.h, at32f435_437_scfg.c
  • scfg_mem_map_type : at32f435_437_scfg.h
  • SCFG_MEM_MAP_XMC_BANK1 : at32f435_437_scfg.h
  • SCFG_MEM_MAP_XMC_SDRAM_BANK1 : at32f435_437_scfg.h
  • SCFG_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • SCFG_PINS_SOURCE0 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE1 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE10 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE11 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE12 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE13 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE14 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE15 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE2 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE3 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE4 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE5 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE6 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE7 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE8 : at32f435_437_scfg.h
  • SCFG_PINS_SOURCE9 : at32f435_437_scfg.h
  • scfg_pins_source_type : at32f435_437_scfg.h
  • scfg_pins_ultra_driven_enable() : at32f435_437_scfg.h, at32f435_437_scfg.c
  • SCFG_PORT_SOURCE_GPIOA : at32f435_437_scfg.h
  • SCFG_PORT_SOURCE_GPIOB : at32f435_437_scfg.h
  • SCFG_PORT_SOURCE_GPIOC : at32f435_437_scfg.h
  • SCFG_PORT_SOURCE_GPIOD : at32f435_437_scfg.h
  • SCFG_PORT_SOURCE_GPIOE : at32f435_437_scfg.h
  • SCFG_PORT_SOURCE_GPIOF : at32f435_437_scfg.h
  • SCFG_PORT_SOURCE_GPIOG : at32f435_437_scfg.h
  • SCFG_PORT_SOURCE_GPIOH : at32f435_437_scfg.h
  • scfg_port_source_type : at32f435_437_scfg.h
  • SCFG_REG : at32f435_437_scfg.h
  • SCFG_REG_BIT : at32f435_437_scfg.h
  • scfg_reset() : at32f435_437_scfg.h, at32f435_437_scfg.c
  • SCFG_ULTRA_DRIVEN_PB10 : at32f435_437_scfg.h
  • SCFG_ULTRA_DRIVEN_PB3 : at32f435_437_scfg.h
  • SCFG_ULTRA_DRIVEN_PB9 : at32f435_437_scfg.h
  • SCFG_ULTRA_DRIVEN_PD12 : at32f435_437_scfg.h
  • SCFG_ULTRA_DRIVEN_PD13 : at32f435_437_scfg.h
  • SCFG_ULTRA_DRIVEN_PD14 : at32f435_437_scfg.h
  • SCFG_ULTRA_DRIVEN_PD15 : at32f435_437_scfg.h
  • SCFG_ULTRA_DRIVEN_PF14 : at32f435_437_scfg.h
  • SCFG_ULTRA_DRIVEN_PF15 : at32f435_437_scfg.h
  • scfg_ultra_driven_pins_type : at32f435_437_scfg.h
  • scfg_xmc_mapping_swap_set() : at32f435_437_scfg.h, at32f435_437_scfg.c
  • SCFG_XMC_SWAP_MODE1 : at32f435_437_scfg.h
  • SCFG_XMC_SWAP_MODE2 : at32f435_437_scfg.h
  • SCFG_XMC_SWAP_MODE3 : at32f435_437_scfg.h
  • SCFG_XMC_SWAP_NONE : at32f435_437_scfg.h
  • scfg_xmc_swap_type : at32f435_437_scfg.h
  • sclk_288m_hick_config() : project/at_start_f435/examples/crm/clock_failure_detection/src/main.c, project/at_start_f437/examples/crm/clock_failure_detection/src/main.c
  • sclk_64m_hick_config() : project/at_start_f435/examples/crm/sysclk_switch/src/main.c, project/at_start_f437/examples/crm/sysclk_switch/src/main.c
  • sclk_96m_hext_config() : project/at_start_f435/examples/crm/sysclk_switch/src/main.c, project/at_start_f437/examples/crm/sysclk_switch/src/main.c
  • scr_find() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • SCREEN_X_SIZE : project/at_start_f435/examples/cortex_m4/fpu/src/main.c, project/at_start_f437/examples/cortex_m4/fpu/src/main.c
  • SCREEN_Y_SIZE : project/at_start_f435/examples/cortex_m4/fpu/src/main.c, project/at_start_f437/examples/cortex_m4/fpu/src/main.c
  • scsi_inquiry : at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c, at_start_f435/examples/usb_device/msc/src/msc_diskio.c, at_start_f435/examples/usb_device/virtual_msc_iap/src/msc_diskio.c, at_start_f437/examples/usb_device/composite_vcp_msc/src/msc_diskio.c, at_start_f437/examples/usb_device/msc/src/msc_diskio.c, at_start_f437/examples/usb_device/virtual_msc_iap/src/msc_diskio.c
  • SCSI_INQUIRY_DATA_LENGTH : cdc_msc_class.h, msc_bot_scsi.h
  • SD_0TO7BITS : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_16TO23BITS : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_24TO31BITS : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_8TO15BITS : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_ADDR_MISALIGNED : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_ADDR_OUT_OF_RANGE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_AKE_SEQ_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_ALLZERO : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_BLK_LEN_ERR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sd_block_read() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_block_write() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_blocks_erase() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_bus_wide_enable() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • SD_CARD_CONTROLLER_ERR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_DISCONNECTED : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_ECC_DISABLED : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_ECC_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_IDENTIFICATION : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sd_card_info : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_card_info_get() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_card_init() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • SD_CARD_LOCKED : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_PROGRAMMING : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_READY : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_RECEIVING : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_SENDING : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_STANDBY : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sd_card_state_type : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_TRANSFER : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CCCC_ERASE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CCCC_LOCK_UNLOCK : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CCCC_WRITE_PROT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CHECK_PATTERN : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CID_CSD_OVERWRITE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_ALL_SEND_CID : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_APP_CMD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_APP_SD_SET_BUSWIDTH : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_CLR_WRITE_PROT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_CRC_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_ERASE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_ERASE_GRP_END : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_ERASE_GRP_START : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_FAIL : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_FAST_IO : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_GEN_CMD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_GO_IDLE_STATE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_GO_INACTIVE_STATE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_GO_IRQ_STATE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_HS_BUSTEST_READ : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_HS_BUSTEST_WRITE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_HS_SEND_EXT_CSD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_HS_SWITCH : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_LOCK_UNLOCK : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_NO_CMD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_OUT_OF_RANGE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_PROG_CID : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_PROG_CSD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_READ_DAT_UNTIL_STOP : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_READ_MULT_BLOCK : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_READ_SINGLE_BLOCK : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_RSP_TIMEOUT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_CHANGE_SECURE_AREA : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_GET_CER_RES1 : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_GET_CER_RN2 : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_GET_MID : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_GET_MKB : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_OP_COND : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SECURE_ERASE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SECURE_WRITE_MKB : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SEND_SCR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SET_CER_RES2 : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SET_CER_RN1 : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SET_CLR_CARD_DETECT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_STAUS : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_ERASE_GRP_END : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_ERASE_GRP_START : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SDIO_RW_DIRECT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SDIO_RW_EXTENDED : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SDIO_SEN_OP_COND : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEL_DESEL_CARD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_CID : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_CSD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_OP_COND : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_STATUS : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_WRITE_PROT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_BLOCK_COUNT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_BLOCKLEN : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_DSR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_REL_ADDR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_WRITE_PROT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_STOP_TRANSMISSION : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_WRITE_DAT_UNTIL_STOP : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_WRITE_MULT_BLOCK : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_WRITE_SINGLE_BLOCK : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_DATA_FAIL : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_DATA_TIMEOUT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sd_data_transfer_mode_type : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_DATATIMEOUT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sd_deselect_select() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_device_mode_set() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_dma_config() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • SD_ERASE_RESET : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_ERASE_SEQ_ERR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sd_error_status_type : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_GENERAL_UNKNOWN_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_HALFFIFO : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_HALFFIFOBYTES : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_HIGH_CAPACITY : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_ILLEGAL_CMD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sd_init() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • SD_INTERNAL_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_INVALID_ERASE_PARAM : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_INVALID_PARAMETER : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_INVALID_VOLTRANGE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sd_irq_service() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • SD_LOCK_UNLOCK_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_LUN : at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h, at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h
  • SD_MAX_DATA_LENGTH : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_MAX_VOLT_TRIAL : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sd_memory_card_type : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sd_mult_blocks_read() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_mult_blocks_write() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_multiple_blocks_test() : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c
  • SD_NOT_CONFIGURED : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ADDR_MISALIGNED : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ADDR_OUT_OF_RANGE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_AKE_SEQ_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_BLK_LEN_ERR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CARD_CONTROLLER_ERR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CARD_ECC_DISABLED : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CARD_ECC_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CID_CSD_OVERWRIETE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CMD_CRC_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ERASE_RESET : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ERASE_SEQ_ERR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ERRORBITS : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_GENERAL_UNKNOWN_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ILLEGAL_CMD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_INVALID_ERASE_PARAM : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_LOCK_UNLOCK_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_STREAM_RD_UNDERRUN : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_STREAM_WR_OVERRUN : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_WP_ERASE_SKIP : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_WR_PROTECT_VIOLATION : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_OK : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sd_power_off() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_power_on() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • SD_R5_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_R5_FUNCTION_NUMBER : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_R5_OUT_OF_RANGE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_R6_CMD_CRC_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_R6_GENERAL_UNKNOWN_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_R6_ILLEGAL_CMD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sd_read_disk() : at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c
  • SD_REQ_NOT_APPLICABLE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_REQ_PENDING : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_RX_OVERRUN : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_SDIO_DISABLED : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_SDIO_FUNC_BUSY : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_SDIO_FUNC_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_SDIO_UNKNOWN_FUNC : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sd_single_block_test() : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c
  • SD_SINGLE_BUS_SUPPORT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_START_BIT_ERR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sd_state_get() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sd_status_send() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • SD_STD_CAPACITY : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_STREAM_RD_UNDERRUN : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_STREAM_WR_OVERRUN : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sd_switch() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • SD_SWITCH_ERROR : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sd_test_error() : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sdio_fatfs/src/main.c
  • SD_TRANSFER_DMA_MODE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_TRANSFER_POLLING_MODE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_TX_UNDERRUN : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_UNSUPPORTED_FEATURE : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_UNSUPPORTED_HW : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_VOLTAGE_WINDOW_MMC : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_VOLTAGE_WINDOW_SD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sd_wide_bus_operation_config() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • SD_WIDE_BUS_SUPPORT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_WP_ERASE_SKIP : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SD_WR_PROTECT_VIOLATION : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sd_write_disk() : at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c
  • SDIO1 : at32f435_437_sdio.h
  • SDIO1_BASE : at32f435_437.h
  • SDIO1_IRQHandler() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • SDIO1_IRQn : at32f435_437.h
  • SDIO2 : at32f435_437_sdio.h
  • SDIO2_BASE : at32f435_437.h
  • SDIO2_IRQHandler() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • SDIO2_IRQn : at32f435_437.h
  • sdio_block_size_type : at32f435_437_sdio.h
  • sdio_buffer_counter_get() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_bus_width_config() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • SDIO_BUS_WIDTH_D1 : at32f435_437_sdio.h
  • SDIO_BUS_WIDTH_D4 : at32f435_437_sdio.h
  • SDIO_BUS_WIDTH_D8 : at32f435_437_sdio.h
  • sdio_bus_width_type : at32f435_437_sdio.h
  • sdio_clock_bypass() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_clock_config() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • SDIO_CLOCK_EDGE_FALLING : at32f435_437_sdio.h
  • SDIO_CLOCK_EDGE_RISING : at32f435_437_sdio.h
  • sdio_clock_enable() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_clock_set() : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • SDIO_CMD0TIMEOUT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_CMDCMPL_FLAG : at32f435_437_sdio.h
  • SDIO_CMDCMPL_INT : at32f435_437_sdio.h
  • SDIO_CMDFAIL_FLAG : at32f435_437_sdio.h
  • SDIO_CMDFAIL_INT : at32f435_437_sdio.h
  • SDIO_CMDRSPCMPL_FLAG : at32f435_437_sdio.h
  • SDIO_CMDRSPCMPL_INT : at32f435_437_sdio.h
  • SDIO_CMDTIMEOUT_FLAG : at32f435_437_sdio.h
  • SDIO_CMDTIMEOUT_INT : at32f435_437_sdio.h
  • sdio_command_config() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_command_data_send() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sdio_command_init_struct : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c, at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sdio_command_response_get() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_command_state_machine_enable() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • SDIO_DATA_BLOCK_SIZE_1024B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_128B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_16384B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_16B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_1B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_2048B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_256B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_2B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_32B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_4096B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_4B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_512B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_64B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_8192B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_SIZE_8B : at32f435_437_sdio.h
  • SDIO_DATA_BLOCK_TRANSFER : at32f435_437_sdio.h
  • sdio_data_buffer : at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c
  • sdio_data_config() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_data_counter_get() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_data_init_struct : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c, at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sdio_data_read() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_data_state_machine_enable() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • SDIO_DATA_STREAM_TRANSFER : at32f435_437_sdio.h
  • SDIO_DATA_TRANSFER_TO_CARD : at32f435_437_sdio.h
  • SDIO_DATA_TRANSFER_TO_CONTROLLER : at32f435_437_sdio.h
  • sdio_data_write() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • SDIO_DATATIMEOUT : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sdio_dma_enable() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • SDIO_DOCMD_FLAG : at32f435_437_sdio.h
  • SDIO_DOCMD_INT : at32f435_437_sdio.h
  • SDIO_DORX_FLAG : at32f435_437_sdio.h
  • SDIO_DORX_INT : at32f435_437_sdio.h
  • SDIO_DOTX_FLAG : at32f435_437_sdio.h
  • SDIO_DOTX_INT : at32f435_437_sdio.h
  • SDIO_DTBLKCMPL_FLAG : at32f435_437_sdio.h
  • SDIO_DTBLKCMPL_INT : at32f435_437_sdio.h
  • SDIO_DTCMP_INT : at32f435_437_sdio.h
  • SDIO_DTCMPL_FLAG : at32f435_437_sdio.h
  • SDIO_DTFAIL_FLAG : at32f435_437_sdio.h
  • SDIO_DTFAIL_INT : at32f435_437_sdio.h
  • SDIO_DTTIMEOUT_FLAG : at32f435_437_sdio.h
  • SDIO_DTTIMEOUT_INT : at32f435_437_sdio.h
  • sdio_edge_phase_type : at32f435_437_sdio.h
  • SDIO_FIFO_Address : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sdio_flag_clear() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_flag_get() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_flow_control_enable() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • SDIO_HIGH_CAPACITY_MMC_CARD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_HIGH_CAPACITY_SD_CARD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_HIGH_SPEED_MULTIMEDIA_CARD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sdio_interrupt_enable() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • SDIO_INTR_STS_READ_MASK : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_INTR_STS_WRITE_MASK : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sdio_io_function_enable() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_io_suspend_command_set() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • SDIO_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • SDIO_MULTIMEDIA_CARD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_POWER_OFF : at32f435_437_sdio.h
  • SDIO_POWER_ON : at32f435_437_sdio.h
  • sdio_power_saving_mode_enable() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_power_set() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_power_state_type : at32f435_437_sdio.h
  • sdio_power_status_get() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • SDIO_READ_WAIT_CONTROLLED_BY_CK : at32f435_437_sdio.h
  • SDIO_READ_WAIT_CONTROLLED_BY_D2 : at32f435_437_sdio.h
  • sdio_read_wait_mode_set() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_read_wait_mode_type : at32f435_437_sdio.h
  • sdio_read_wait_start() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_read_wait_stop() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_reponse_type : at32f435_437_sdio.h
  • sdio_reset() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • sdio_response_get() : at32f435_437_sdio.h, at32f435_437_sdio.c
  • SDIO_RESPONSE_LONG : at32f435_437_sdio.h
  • SDIO_RESPONSE_NO : at32f435_437_sdio.h
  • SDIO_RESPONSE_SHORT : at32f435_437_sdio.h
  • SDIO_RSP1_INDEX : at32f435_437_sdio.h
  • SDIO_RSP2_INDEX : at32f435_437_sdio.h
  • SDIO_RSP3_INDEX : at32f435_437_sdio.h
  • SDIO_RSP4_INDEX : at32f435_437_sdio.h
  • sdio_rsp_index_type : at32f435_437_sdio.h
  • SDIO_RXBUF_FLAG : at32f435_437_sdio.h
  • SDIO_RXBUF_INT : at32f435_437_sdio.h
  • SDIO_RXBUFE_FLAG : at32f435_437_sdio.h
  • SDIO_RXBUFE_INT : at32f435_437_sdio.h
  • SDIO_RXBUFF_FLAG : at32f435_437_sdio.h
  • SDIO_RXBUFF_INT : at32f435_437_sdio.h
  • SDIO_RXBUFH_FLAG : at32f435_437_sdio.h
  • SDIO_RXBUFH_INT : at32f435_437_sdio.h
  • SDIO_RXERRO_FLAG : at32f435_437_sdio.h
  • SDIO_RXERRO_INT : at32f435_437_sdio.h
  • SDIO_SBITERR_FLAG : at32f435_437_sdio.h
  • SDIO_SBITERR_INT : at32f435_437_sdio.h
  • SDIO_SDIO_CARD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_SDIOIF_FLAG : at32f435_437_sdio.h
  • SDIO_SDIOIF_INT : at32f435_437_sdio.h
  • SDIO_SECURE_DIGITAL_IO_CARD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_SECURE_DIGITAL_IO_COMBO_CARD : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_SEND_IF_COND : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_STATIC_FLAGS : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_STD_CAPACITY_SD_CARD_V1_1 : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDIO_STD_CAPACITY_SD_CARD_V2_0 : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • sdio_transfer_direction_type : at32f435_437_sdio.h
  • sdio_transfer_mode_type : at32f435_437_sdio.h
  • SDIO_TXBUF_FLAG : at32f435_437_sdio.h
  • SDIO_TXBUF_INT : at32f435_437_sdio.h
  • SDIO_TXBUFE_FLAG : at32f435_437_sdio.h
  • SDIO_TXBUFE_INT : at32f435_437_sdio.h
  • SDIO_TXBUFF_FLAG : at32f435_437_sdio.h
  • SDIO_TXBUFF_INT : at32f435_437_sdio.h
  • SDIO_TXBUFH_FLAG : at32f435_437_sdio.h
  • SDIO_TXBUFH_INT : at32f435_437_sdio.h
  • SDIO_TXERRU_FLAG : at32f435_437_sdio.h
  • SDIO_TXERRU_INT : at32f435_437_sdio.h
  • SDIO_WAIT_FOR_INT : at32f435_437_sdio.h
  • SDIO_WAIT_FOR_NO : at32f435_437_sdio.h
  • SDIO_WAIT_FOR_PEND : at32f435_437_sdio.h
  • sdio_wait_type : at32f435_437_sdio.h
  • SDIOx : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h
  • SDRAM_BANK1_ADDR : at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c, at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c, at_start_f437/examples/xmc/sdram_basic/src/xmc_sdram.c, at_start_f437/examples/xmc/sdram_dma/src/xmc_sdram.c
  • SDRAM_BURST_INTERLEAVED : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • SDRAM_BURST_LEN_1 : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • SDRAM_BURST_LEN_2 : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • SDRAM_BURST_LEN_4 : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • SDRAM_BURST_LEN_8 : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • SDRAM_BURST_SEQUENTIAL : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • SDRAM_CAS_LATENCY_1 : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • SDRAM_CAS_LATENCY_2 : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • SDRAM_CAS_LATENCY_3 : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • sdram_copy_to_sram_dma() : at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • sdram_init() : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • sdram_init_sequence() : at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c, at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c
  • SDRAM_OPERATING_MODE_STANDARD : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • sdram_readbuffer() : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • SDRAM_WR_BURST_PROGRAMMED : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • SDRAM_WR_BURST_SINGLE : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • sdram_writebuffer() : at_start_f435/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_basic/src/xmc_sdram.c, at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c, at_start_f437/examples/xmc/sdram_basic/inc/xmc_sdram.h, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • SECTOR_END : FlashOS.h
  • SECTOR_NUM : FlashOS.h, utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • sector_size : at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c, at_start_f435/examples/usb_device/msc/src/msc_diskio.c, at_start_f437/examples/usb_device/composite_vcp_msc/src/msc_diskio.c, at_start_f437/examples/usb_device/msc/src/msc_diskio.c
  • SECTOR_SIZE : project/at_start_f435/examples/flash/flash_write_read/src/flash.c, project/at_start_f437/examples/flash/flash_write_read/src/flash.c
  • SECTOR_SIZE_1K : hid_iap_class.h, at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/msc/inc/msc_diskio.h
  • SECTOR_SIZE_2K : hid_iap_class.h, at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/msc/inc/msc_diskio.h
  • SECTOR_SIZE_4K : hid_iap_class.h, at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/msc/inc/msc_diskio.h
  • SECTOR_SIZE_INDEX : utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/flash.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/flash.h
  • SECTOR_WORD_CNT : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • SENSE_KEY_ABORTED_COMMAND : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_BLANK_CHECK : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_DATA_PROTECT : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_HARDWARE_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_ILLEGAL_REQUEST : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_MEDIUM_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_MISCOMPARE : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_NO_SENSE : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_NOT_READY : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_RECOVERED_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_UNIT_ATTENTION : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_VENDERO_SPECIFIC : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_VOLUME_OVERFLOW : cdc_msc_class.h, msc_bot_scsi.h
  • serial_descriptor : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • SET : at32f435_437.h
  • SET_BUFSIZE_OVERRIDE : flash_loader_extra.h
  • SET_LINE_CODING : usb_std.h, cdc_msc_class.h, msc_bot_scsi.h
  • SET_PAGESIZE_OVERRIDE : flash_loader_extra.h
  • SETUP_LENGTH : project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • SHIFT : cdc_keyboard_class.c, keyboard_class.c
  • show_card_info() : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c
  • sine12bit : project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c, project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/main.c
  • slib_enable() : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • SLIB_END_ADDR : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • SLIB_INST_ADDR : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • SLIB_START_ADDR : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • SLIB_UNLOCK_KEY : at32f435_437_flash.h
  • SLOW : project/at_start_f435/templates/src/main.c, project/at_start_f437/examples/emac/dns_client/src/main.c, project/at_start_f437/examples/emac/http_server/src/main.c, project/at_start_f437/examples/emac/iperf/src/main.c, project/at_start_f437/examples/emac/mqtt_client/src/main.c, project/at_start_f437/examples/emac/tcp_client/src/main.c, project/at_start_f437/examples/emac/tcp_server/src/main.c, project/at_start_f437/examples/emac/telnet/src/main.c, project/at_start_f437/examples/emac/wake_on_lan/src/main.c, project/at_start_f437/templates/src/main.c
  • SNR_THRESHOLD_F32 : utilities/at32f435_437_slib_demo/project_l0/src/main.c, utilities/at32f435_437_slib_demo/project_l1/src/main.c
  • speed_change() : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • SPI1 : at32f435_437_spi.h
  • SPI1_BASE : at32f435_437.h
  • SPI1_IRQn : at32f435_437.h
  • spi1_rx_buffer : project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c
  • spi1_rx_counter : project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c
  • spi1_tx_buffer : project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c
  • spi1_tx_buffer_size : project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c
  • SPI1_TX_BUFFER_SIZE : project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c
  • spi1_tx_counter : project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c
  • SPI2 : at32f435_437_spi.h
  • SPI2_BASE : at32f435_437.h
  • spi2_buffer_rx : project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • spi2_buffer_tx : project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • SPI2_I2S2EXT_IRQHandler() : project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c
  • SPI2_I2S2EXT_IRQn : at32f435_437.h
  • SPI3 : at32f435_437_spi.h
  • SPI3_BASE : at32f435_437.h
  • spi3_buffer_rx : project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • spi3_buffer_tx : project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • SPI3_I2S3EXT_IRQHandler() : project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c
  • SPI3_I2S3EXT_IRQn : at32f435_437.h
  • SPI4 : at32f435_437_spi.h
  • SPI4_BASE : at32f435_437.h
  • SPI4_IRQn : at32f435_437.h
  • spi_byte_read() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spi_byte_write() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spi_bytes_read() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spi_bytes_write() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • SPI_CCERR_FLAG : at32f435_437_spi.h
  • SPI_CLOCK_PHASE_1EDGE : at32f435_437_spi.h
  • SPI_CLOCK_PHASE_2EDGE : at32f435_437_spi.h
  • spi_clock_phase_type : at32f435_437_spi.h
  • SPI_CLOCK_POLARITY_HIGH : at32f435_437_spi.h
  • SPI_CLOCK_POLARITY_LOW : at32f435_437_spi.h
  • spi_clock_polarity_type : at32f435_437_spi.h
  • spi_config() : project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • spi_crc_direction_type : at32f435_437_spi.h
  • spi_crc_enable() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_crc_next_transmit() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_crc_polynomial_get() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_crc_polynomial_set() : at32f435_437_spi.h, at32f435_437_spi.c
  • SPI_CRC_RX : at32f435_437_spi.h
  • SPI_CRC_TX : at32f435_437_spi.h
  • spi_crc_value_get() : at32f435_437_spi.h, at32f435_437_spi.c
  • SPI_CS_HARDWARE_MODE : at32f435_437_spi.h
  • spi_cs_mode_type : at32f435_437_spi.h
  • SPI_CS_SOFTWARE_MODE : at32f435_437_spi.h
  • SPI_CSPAS_FLAG : at32f435_437_spi.h
  • spi_default_para_init() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_enable() : at32f435_437_spi.h, at32f435_437_spi.c
  • SPI_FIRST_BIT_LSB : at32f435_437_spi.h
  • SPI_FIRST_BIT_MSB : at32f435_437_spi.h
  • spi_first_bit_type : at32f435_437_spi.h
  • SPI_FLASH_LUN : at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h, at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h
  • SPI_FRAME_16BIT : at32f435_437_spi.h
  • SPI_FRAME_8BIT : at32f435_437_spi.h
  • spi_frame_bit_num_set() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_frame_bit_num_type : at32f435_437_spi.h
  • SPI_HALF_DUPLEX_DIRECTION_RX : at32f435_437_spi.h
  • spi_half_duplex_direction_set() : at32f435_437_spi.h, at32f435_437_spi.c
  • SPI_HALF_DUPLEX_DIRECTION_TX : at32f435_437_spi.h
  • spi_half_duplex_direction_type : at32f435_437_spi.h
  • spi_hardware_cs_output_enable() : at32f435_437_spi.h, at32f435_437_spi.c
  • SPI_I2S_BF_FLAG : at32f435_437_spi.h
  • spi_i2s_data_receive() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_i2s_data_transmit() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_i2s_dma_receiver_enable() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_i2s_dma_transmitter_enable() : at32f435_437_spi.h, at32f435_437_spi.c
  • SPI_I2S_ERROR_INT : at32f435_437_spi.h
  • spi_i2s_flag_clear() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_i2s_flag_get() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_i2s_interrupt_enable() : at32f435_437_spi.h, at32f435_437_spi.c
  • SPI_I2S_RDBF_FLAG : at32f435_437_spi.h
  • SPI_I2S_RDBF_INT : at32f435_437_spi.h
  • spi_i2s_reset() : at32f435_437_spi.h, at32f435_437_spi.c
  • SPI_I2S_ROERR_FLAG : at32f435_437_spi.h
  • SPI_I2S_TDBE_FLAG : at32f435_437_spi.h
  • SPI_I2S_TDBE_INT : at32f435_437_spi.h
  • spi_init() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_init_struct : project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • spi_master_slave_mode_type : at32f435_437_spi.h
  • SPI_MCLK_DIV_1024 : at32f435_437_spi.h
  • SPI_MCLK_DIV_128 : at32f435_437_spi.h
  • SPI_MCLK_DIV_16 : at32f435_437_spi.h
  • SPI_MCLK_DIV_2 : at32f435_437_spi.h
  • SPI_MCLK_DIV_256 : at32f435_437_spi.h
  • SPI_MCLK_DIV_3 : at32f435_437_spi.h
  • SPI_MCLK_DIV_32 : at32f435_437_spi.h
  • SPI_MCLK_DIV_4 : at32f435_437_spi.h
  • SPI_MCLK_DIV_512 : at32f435_437_spi.h
  • SPI_MCLK_DIV_64 : at32f435_437_spi.h
  • SPI_MCLK_DIV_8 : at32f435_437_spi.h
  • spi_mclk_freq_div_type : at32f435_437_spi.h
  • SPI_MMERR_FLAG : at32f435_437_spi.h
  • SPI_MODE_MASTER : at32f435_437_spi.h
  • SPI_MODE_SLAVE : at32f435_437_spi.h
  • SPI_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • spi_software_cs_internal_level_set() : at32f435_437_spi.h, at32f435_437_spi.c
  • spi_software_cs_level_type : at32f435_437_spi.h
  • SPI_SWCS_INTERNAL_LEVEL_HIGHT : at32f435_437_spi.h
  • SPI_SWCS_INTERNAL_LEVEL_LOW : at32f435_437_spi.h
  • spi_ti_mode_enable() : at32f435_437_spi.h, at32f435_437_spi.c
  • SPI_TRANS_DMA : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • spi_transmission_mode_type : at32f435_437_spi.h
  • SPI_TRANSMIT_FULL_DUPLEX : at32f435_437_spi.h
  • SPI_TRANSMIT_HALF_DUPLEX_RX : at32f435_437_spi.h
  • SPI_TRANSMIT_HALF_DUPLEX_TX : at32f435_437_spi.h
  • SPI_TRANSMIT_SIMPLEX_RX : at32f435_437_spi.h
  • SPIF_BLOCKERASE : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_CHIP_SIZE : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_CHIPERASE : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_DEVICEID : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_FASTREADDATA : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_FASTREADDUAL : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_JEDECDEVICEID : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_MANUFACTDEVICEID : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_PAGE_SIZE : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_PAGEPROGRAM : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_POWERDOWN : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_READDATA : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_READSTATUSREG1 : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_READSTATUSREG2 : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_READSTATUSREG3 : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_RELEASEPOWERDOWN : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_SECTOR_SIZE : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_SECTORERASE : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_WRITEDISABLE : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_WRITEENABLE : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_WRITESTATUSREG1 : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_WRITESTATUSREG2 : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • SPIF_WRITESTATUSREG3 : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • spiflash_init() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spiflash_page_write() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spiflash_read() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spiflash_read_id() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spiflash_read_sr1() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spiflash_sector_buf : at_start_f435/examples/spi/w25q_flash/src/spi_flash.c, at_start_f437/examples/spi/w25q_flash/src/spi_flash.c
  • spiflash_sector_erase() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spiflash_wait_busy() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spiflash_write() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spiflash_write_enable() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • spiflash_write_nocheck() : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f435/examples/spi/w25q_flash/src/spi_flash.c
  • SPK_BUFFER_SIZE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • spk_dma_buffer : at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • SPK_TX_FIFO_SIZE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • SRAM_BASE : at32f435_437.h
  • SRAM_BB_BASE : at32f435_437.h
  • sram_copy_to_sdram_dma() : at_start_f435/examples/xmc/sdram_dma/inc/xmc_sdram.h, at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c, at_start_f437/examples/xmc/sdram_dma/inc/xmc_sdram.h
  • sram_init() : at_start_f435/examples/xmc/sram/inc/xmc_sram.h, at_start_f435/examples/xmc/sram/src/xmc_sram.c, at_start_f437/examples/xmc/sram/inc/xmc_sram.h
  • sram_readbuffer() : at_start_f435/examples/xmc/sram/inc/xmc_sram.h, at_start_f435/examples/xmc/sram/src/xmc_sram.c, at_start_f437/examples/xmc/sram/inc/xmc_sram.h
  • SRAM_SIZE : utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/flash.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/flash.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/flash.h
  • sram_writebuffer() : at_start_f435/examples/xmc/sram/inc/xmc_sram.h, at_start_f435/examples/xmc/sram/src/xmc_sram.c, at_start_f437/examples/xmc/sram/inc/xmc_sram.h
  • src_buffer : project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/tmr/dma/src/main.c, project/at_start_f435/examples/tmr/dma_burst/src/main.c, project/at_start_f437/examples/dma/dmamux_data_to_gpio/src/main.c, project/at_start_f437/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/tmr/dma/src/main.c, project/at_start_f437/examples/tmr/dma_burst/src/main.c
  • src_const_buffer : project/at_start_f435/examples/dma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/two_dimension_mode/src/main.c, project/at_start_f437/examples/dma/flash_to_sram/src/main.c, project/at_start_f437/examples/edma/flash_to_sram/src/main.c, project/at_start_f437/examples/edma/two_dimension_mode/src/main.c
  • STA : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c
  • status : project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c
  • std : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • step : project/at_start_f435/examples/tmr/6_steps/src/main.c, project/at_start_f437/examples/tmr/6_steps/src/main.c
  • STEP_DELAY_MS : at32f435_437_board.c
  • stop_flag : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c, at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • strcopy() : flash_loader_ram.c
  • STREAM_BUFFER_SIZE : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c
  • stream_rbuffer : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c
  • stream_tbuffer : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c
  • student_num : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • sub_tmr_input_sel_type : at32f435_437_tmr.h
  • SUCCESS : at32f435_437.h
  • SVC_Handler() : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c, project/at_start_f435/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f435/examples/can/filter/src/at32f435_437_int.c, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c, project/at_start_f435/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c, project/at_start_f435/templates/inc/at32f435_437_int.h, project/at_start_f435/templates/src/at32f435_437_int.c, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f437/templates/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_int.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_int.h, utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_int.c
  • SVCall_IRQn : at32f435_437.h
  • SWAPBYTE : usb_std.h
  • switch_system_clock() : project/at_start_f435/examples/crm/sysclk_switch/src/main.c, project/at_start_f437/examples/crm/sysclk_switch/src/main.c
  • swj_dp_config() : project/at_start_f435/examples/gpio/swjtag_mux/src/main.c
  • sys_counter : project/at_start_f435/examples/tmr/input_capture/src/main.c, project/at_start_f437/examples/tmr/input_capture/src/main.c
  • SYS_LIGHTWEIGHT_PROT : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • system_clock_config() : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_clock.h, project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_clock.c, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_clock.h, project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_clock.c, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_clock.h, project/at_start_f435/examples/can/communication_mode/src/at32f435_437_clock.c, project/at_start_f435/examples/can/filter/inc/at32f435_437_clock.h, project/at_start_f435/examples/can/filter/src/at32f435_437_clock.c, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_clock.h, project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_clock.c, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_clock.h, project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_clock.c, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_clock.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_clock.c, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_clock.h, project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_clock.c, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_clock.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_clock.c, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_clock.h, project/at_start_f435/examples/crc/calculation/src/at32f435_437_clock.c, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_clock.h, project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_clock.c, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_clock.h, project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_clock.c, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_clock.h, project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_clock.c, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_clock.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_clock.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_clock.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_clock.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_clock.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_clock.c, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_clock.h, project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_clock.c, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_clock.h, project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_clock.c, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_clock.h, project/at_start_f435/examples/debug/tmr1/src/at32f435_437_clock.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_clock.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_clock.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_clock.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_clock.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_clock.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_clock.c, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_clock.h, project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_clock.c, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_clock.h, project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_clock.c, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_clock.h, project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_clock.c, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_clock.h, project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_clock.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_clock.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_clock.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_clock.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_clock.c, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_clock.h, project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_clock.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_clock.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_clock.c, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_clock.h, project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_clock.c, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_clock.h, project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_clock.c, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_clock.h, project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_clock.c, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_clock.h, project/at_start_f435/examples/ertc/calendar/src/at32f435_437_clock.c, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_clock.h, project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_clock.c, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_clock.h, project/at_start_f435/examples/ertc/tamper/src/at32f435_437_clock.c, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_clock.h, project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_clock.c, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_clock.h, project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_clock.c, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_clock.h, project/at_start_f435/examples/exint/exint_config/src/at32f435_437_clock.c, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_clock.h, project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_clock.c, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_clock.h, project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_clock.c, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_clock.h, project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_clock.c, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_clock.h, project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_clock.c, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_clock.h, project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_clock.c, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_clock.h, project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_clock.c, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_clock.h, project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_clock.c, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_clock.h, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_clock.c, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_clock.h, project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_clock.c, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_clock.h, project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_clock.c, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_clock.h, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_clock.c, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_clock.h, project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_clock.c, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_clock.h, project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_clock.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_clock.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_clock.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_clock.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_clock.c, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_clock.h, project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_clock.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_clock.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_clock.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_clock.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_clock.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_clock.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_clock.c, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_clock.h, project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_clock.c, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_clock.h, project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_clock.c, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_clock.h, project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_clock.c, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_clock.h, project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_clock.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_clock.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_clock.c, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_clock.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_clock.c, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_clock.h, project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_clock.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_clock.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_clock.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_clock.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_clock.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_clock.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_clock.c, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_clock.h, project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_clock.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_clock.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_clock.c, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_clock.h, project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_clock.c, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_clock.h, project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_clock.c, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_clock.h, project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_clock.c, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_clock.h, project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_clock.c, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_clock.h, project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_clock.c, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_clock.h, project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_clock.c, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_clock.h, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_clock.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_clock.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_clock.c, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_clock.h, project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_clock.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_clock.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_clock.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_clock.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_clock.c, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_clock.h, project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_clock.c, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_clock.h, project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/dma/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_clock.c, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_clock.h, project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/irda/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/irda/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/polling/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/polling/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/printf/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/printf/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/rs485/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/smartcard/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/synchronous/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_clock.c, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_clock.h, project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/audio/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/msc/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/printer/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_clock.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_clock.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_clock.c, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_clock.h, project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_clock.c, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_clock.h, project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_clock.c, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_clock.h, project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_clock.c, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_clock.h, project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_clock.c, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_clock.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_clock.c, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_clock.h, project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_clock.c, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_clock.h, project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_clock.c, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_clock.h, project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_clock.c, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_clock.h, project/at_start_f435/examples/xmc/psram/src/at32f435_437_clock.c, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_clock.h, project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_clock.c, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_clock.h, project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_clock.c, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_clock.h, project/at_start_f435/examples/xmc/sram/src/at32f435_437_clock.c, project/at_start_f435/templates/inc/at32f435_437_clock.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_clock.h, project/at_start_f437/examples/acc/calibration/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/conversion_abort/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/current_vref_value_check/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/edma_double_buffer/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/internal_temperature_sensor/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/resolution_6bit/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/software_trigger_repeat/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/vbat_monitor/src/at32f435_437_clock.c, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_clock.h, project/at_start_f437/examples/adc/voltage_monitoring/src/at32f435_437_clock.c, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_clock.h, project/at_start_f437/examples/can/communication_mode/src/at32f435_437_clock.c, project/at_start_f437/examples/can/filter/inc/at32f435_437_clock.h, project/at_start_f437/examples/can/filter/src/at32f435_437_clock.c, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_clock.h, project/at_start_f437/examples/can/loopback_mode/src/at32f435_437_clock.c, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_clock.h, project/at_start_f437/examples/cortex_m4/bit_band/src/at32f435_437_clock.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_clock.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_clock.h, project/at_start_f437/examples/cortex_m4/fpu/src/at32f435_437_clock.c, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_clock.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/src/at32f435_437_clock.c, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_clock.h, project/at_start_f437/examples/crc/calculation/src/at32f435_437_clock.c, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_clock.h, project/at_start_f437/examples/crm/clock_failure_detection/src/at32f435_437_clock.c, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_clock.h, project/at_start_f437/examples/crm/pll_parameter_calculate/src/at32f435_437_clock.c, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_clock.h, project/at_start_f437/examples/crm/sysclk_switch/src/at32f435_437_clock.c, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_clock.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/at32f435_437_clock.c, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_clock.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/src/at32f435_437_clock.c, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_clock.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/src/at32f435_437_clock.c, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_clock.h, project/at_start_f437/examples/dac/one_dac_noisewave/src/at32f435_437_clock.c, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_clock.h, project/at_start_f437/examples/dac/two_dac_trianglewave/src/at32f435_437_clock.c, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_clock.h, project/at_start_f437/examples/debug/tmr1/src/at32f435_437_clock.c, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_clock.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/src/at32f435_437_clock.c, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_clock.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/src/at32f435_437_clock.c, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_clock.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/at32f435_437_clock.c, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_clock.h, project/at_start_f437/examples/dma/flash_to_sram/src/at32f435_437_clock.c, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_clock.h, project/at_start_f437/examples/dvp/ov2640_capture/src/at32f435_437_clock.c, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_clock.h, project/at_start_f437/examples/dvp/ov5640_capture/src/at32f435_437_clock.c, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_clock.h, project/at_start_f437/examples/edma/burst_mode/src/at32f435_437_clock.c, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_clock.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/src/at32f435_437_clock.c, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_clock.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/at32f435_437_clock.c, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_clock.h, project/at_start_f437/examples/edma/flash_to_sram/src/at32f435_437_clock.c, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_clock.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_clock.c, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_clock.h, project/at_start_f437/examples/edma/link_list_mode/src/at32f435_437_clock.c, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_clock.h, project/at_start_f437/examples/edma/two_dimension_mode/src/at32f435_437_clock.c, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_clock.h, project/at_start_f437/examples/emac/dns_client/src/at32f435_437_clock.c, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_clock.h, project/at_start_f437/examples/emac/http_server/src/at32f435_437_clock.c, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_clock.h, project/at_start_f437/examples/emac/iperf/src/at32f435_437_clock.c, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_clock.h, project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_clock.c, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_clock.h, project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_clock.c, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_clock.h, project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_clock.c, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_clock.h, project/at_start_f437/examples/emac/telnet/src/at32f435_437_clock.c, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_clock.h, project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_clock.c, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_clock.h, project/at_start_f437/examples/ertc/bpr_domain/src/at32f435_437_clock.c, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_clock.h, project/at_start_f437/examples/ertc/calendar/src/at32f435_437_clock.c, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_clock.h, project/at_start_f437/examples/ertc/lick_calibration/src/at32f435_437_clock.c, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_clock.h, project/at_start_f437/examples/ertc/tamper/src/at32f435_437_clock.c, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_clock.h, project/at_start_f437/examples/ertc/time_stamp/src/at32f435_437_clock.c, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_clock.h, project/at_start_f437/examples/ertc/wakeup_timer/src/at32f435_437_clock.c, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_clock.h, project/at_start_f437/examples/exint/exint_config/src/at32f435_437_clock.c, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_clock.h, project/at_start_f437/examples/exint/exint_software_trigger/src/at32f435_437_clock.c, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_clock.h, project/at_start_f437/examples/flash/fap_enable/src/at32f435_437_clock.c, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_clock.h, project/at_start_f437/examples/flash/flash_write_read/src/at32f435_437_clock.c, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_clock.h, project/at_start_f437/examples/gpio/io_toggle/src/at32f435_437_clock.c, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_clock.h, project/at_start_f437/examples/gpio/led_toggle/src/at32f435_437_clock.c, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_clock.h, project/at_start_f437/examples/gpio/swjtag_mux/src/at32f435_437_clock.c, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_clock.h, project/at_start_f437/examples/i2c/communication_dma/src/at32f435_437_clock.c, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_clock.h, project/at_start_f437/examples/i2c/communication_int/src/at32f435_437_clock.c, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_clock.h, project/at_start_f437/examples/i2c/communication_poll/src/at32f435_437_clock.c, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_clock.h, project/at_start_f437/examples/i2c/communication_smbus/src/at32f435_437_clock.c, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_clock.h, project/at_start_f437/examples/i2c/eeprom/src/at32f435_437_clock.c, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_clock.h, project/at_start_f437/examples/i2s/fullduplex_dma/src/at32f435_437_clock.c, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_clock.h, project/at_start_f437/examples/i2s/halfduplex_dma/src/at32f435_437_clock.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_clock.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/at32f435_437_clock.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_clock.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_clock.c, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_clock.h, project/at_start_f437/examples/irtmr/irtmr_output/src/at32f435_437_clock.c, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_clock.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_clock.c, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_clock.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_clock.c, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_clock.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_clock.c, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_clock.h, project/at_start_f437/examples/pwc/ldo_set/src/at32f435_437_clock.c, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_clock.h, project/at_start_f437/examples/pwc/power_voltage_monitor/src/at32f435_437_clock.c, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_clock.h, project/at_start_f437/examples/pwc/sleep_tmr2/src/at32f435_437_clock.c, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_clock.h, project/at_start_f437/examples/pwc/sleep_usart1/src/at32f435_437_clock.c, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_clock.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/src/at32f435_437_clock.c, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_clock.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/src/at32f435_437_clock.c, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_clock.h, project/at_start_f437/examples/qspi/command_port_using_dma/src/at32f435_437_clock.c, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_clock.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_clock.c, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_clock.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_clock.c, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_clock.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/src/at32f435_437_clock.c, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_clock.h, project/at_start_f437/examples/qspi/command_port_using_polling/src/at32f435_437_clock.c, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_clock.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_clock.c, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_clock.h, project/at_start_f437/examples/qspi/xip_port_write_read/src/at32f435_437_clock.c, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_clock.h, project/at_start_f437/examples/scfg/mem_map_sel/src/at32f435_437_clock.c, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_clock.h, project/at_start_f437/examples/sdio/sd_mmc_card/src/at32f435_437_clock.c, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_clock.h, project/at_start_f437/examples/sdio/sdio_fatfs/src/at32f435_437_clock.c, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_clock.h, project/at_start_f437/examples/spi/crc_transfer_polling/src/at32f435_437_clock.c, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_clock.h, project/at_start_f437/examples/spi/fullduplex_polling/src/at32f435_437_clock.c, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_clock.h, project/at_start_f437/examples/spi/halfduplex_interrupt/src/at32f435_437_clock.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_clock.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_clock.c, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_clock.h, project/at_start_f437/examples/spi/only_receive_mode_polling/src/at32f435_437_clock.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_clock.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/at32f435_437_clock.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_clock.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_clock.c, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_clock.h, project/at_start_f437/examples/spi/w25q_flash/src/at32f435_437_clock.c, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_clock.h, project/at_start_f437/examples/sram/extend_sram/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/6_steps/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/7_pwm_output/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/cascade_synchro/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/complementary_signals/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/dma/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/dma_burst/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/encoder_tmr2/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/external_clock/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/hang_mode/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/input_capture/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/oc_high/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/oc_low/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/one_cycle/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/parallel_synchro/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/pwm_input/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/pwm_input_dma/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/pwm_output_simulate/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/timer_base/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/tmr1_synchro/src/at32f435_437_clock.c, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_clock.h, project/at_start_f437/examples/tmr/tmr2_32bit/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/half_duplex/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/hw_flow_control/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/idle_detection/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/interrupt/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/irda/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/irda/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/polling/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/polling/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/printf/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/printf/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/receiver_mute/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/rs485/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/smartcard/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/synchronous/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/src/at32f435_437_clock.c, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_clock.h, project/at_start_f437/examples/usart/tx_rx_swap/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/audio/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/composite_audio_hid/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/custom_hid/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/keyboard/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/mouse/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/msc/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/printer/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/vcp_loopback/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/virtual_comport/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_host/hid_demo/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_host/msc_only_fat32/src/at32f435_437_clock.c, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_clock.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/src/at32f435_437_clock.c, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_clock.h, project/at_start_f437/examples/wdt/wdt_reset/src/at32f435_437_clock.c, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_clock.h, project/at_start_f437/examples/wdt/wdt_standby/src/at32f435_437_clock.c, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_clock.h, project/at_start_f437/examples/wwdt/wwdt_reset/src/at32f435_437_clock.c, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_clock.h, project/at_start_f437/examples/xmc/lcd_8bit/src/at32f435_437_clock.c, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_clock.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/src/at32f435_437_clock.c, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_clock.h, project/at_start_f437/examples/xmc/nand_flash/ecc/src/at32f435_437_clock.c, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_clock.h, project/at_start_f437/examples/xmc/nand_flash/nand/src/at32f435_437_clock.c, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_clock.h, project/at_start_f437/examples/xmc/nor_flash/src/at32f435_437_clock.c, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_clock.h, project/at_start_f437/examples/xmc/psram/src/at32f435_437_clock.c, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_clock.h, project/at_start_f437/examples/xmc/sdram_basic/src/at32f435_437_clock.c, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_clock.h, project/at_start_f437/examples/xmc/sdram_dma/src/at32f435_437_clock.c, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_clock.h, project/at_start_f437/examples/xmc/sram/src/at32f435_437_clock.c, project/at_start_f437/templates/inc/at32f435_437_clock.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_clock.h, utilities/at32f435_437_freertos_demo/src/at32f435_437_clock.c, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_clock.h, utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_clock.c, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_clock.h, utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_clock.c, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_clock.h, utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_clock.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_clock.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_clock.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_clock.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/at32f435_437_clock.c, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_clock.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/src/at32f435_437_clock.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_clock.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_clock.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_clock.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_clock.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_clock.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_clock.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_clock.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_clock.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_clock.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_clock.c
  • system_clock_config_200mhz() : project/at_start_f435/examples/crm/pll_parameter_calculate/src/main.c
  • system_clock_recover() : project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/main.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/main.c, project/at_start_f435/examples/pwc/ldo_set/src/main.c, project/at_start_f435/examples/usb_device/keyboard/src/main.c, project/at_start_f435/examples/usb_device/mouse/src/main.c
  • system_core_clock : system_at32f435_437.c, system_at32f435_437.h
  • system_core_clock_update() : system_at32f435_437.c, system_at32f435_437.h
  • SystemCoreClock : system_at32f435_437.h
  • SystemInit() : system_at32f435_437.c, system_at32f435_437.h
  • SYSTEMTICK_PERIOD_MS : project/at_start_f437/examples/emac/dns_client/src/netconf.c, project/at_start_f437/examples/emac/http_server/src/netconf.c, project/at_start_f437/examples/emac/iperf/src/netconf.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_server/src/netconf.c, project/at_start_f437/examples/emac/telnet/src/netconf.c, project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8 : at32f435_437_misc.h
  • SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV : at32f435_437_misc.h
  • systick_clock_source_config() : at32f435_437_misc.h, at32f435_437_misc.c
  • systick_clock_source_type : at32f435_437_misc.h
  • SysTick_Configuration() : project/at_start_f435/examples/tmr/6_steps/src/main.c
  • systick_handler() : project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/systick_interrupt/src/main.c, project/at_start_f437/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c
  • SysTick_Handler() : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c, project/at_start_f435/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f435/examples/can/filter/src/at32f435_437_int.c, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c, project/at_start_f435/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c, project/at_start_f435/templates/inc/at32f435_437_int.h, project/at_start_f435/templates/src/at32f435_437_int.c, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f437/templates/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_int.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_int.h, utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_int.c
  • SysTick_IRQn : at32f435_437.h


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- t -

  • T0_PROTOCOL : project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • TAMP_STAMP_IRQHandler() : project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c
  • TAMP_STAMP_IRQn : at32f435_437.h
  • TCLK_HIGH : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h
  • TCLK_LOW : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h
  • tcp_active_pcbs : tcp_client.c
  • tcp_client_init() : tcp_client.h, tcp_client.c
  • tcp_client_pcb : tcp_client.h
  • tcp_client_recv() : tcp_client.c
  • tcp_client_send_data() : tcp_client.h, tcp_client.c
  • TCP_CLIENT_TEST_DATA : project/at_start_f437/examples/emac/tcp_client/inc/at32_emac.h
  • tcp_connected() : tcp_client.c
  • TCP_LOCAL_PORT : tcp_client.h, tcp_server.h
  • TCP_MSS : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • TCP_RCV_SCALE : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • tcp_send_timer : project/at_start_f437/examples/emac/tcp_client/src/netconf.c
  • tcp_server_accept() : tcp_server.c
  • tcp_server_init() : tcp_server.h, tcp_server.c
  • TCP_SERVER_IP : tcp_client.h
  • TCP_SERVER_PORT : tcp_client.h
  • tcp_server_recv() : tcp_server.c
  • TCP_SND_BUF : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • TCP_SND_QUEUELEN : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • tcp_timer : project/at_start_f437/examples/emac/dns_client/src/netconf.c, project/at_start_f437/examples/emac/http_server/src/netconf.c, project/at_start_f437/examples/emac/iperf/src/netconf.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_server/src/netconf.c, project/at_start_f437/examples/emac/telnet/src/netconf.c, project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • TCP_TTL : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • TCP_WND : project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h, project/at_start_f437/examples/emac/http_server/inc/lwipopts.h, project/at_start_f437/examples/emac/iperf/inc/lwipopts.h, project/at_start_f437/examples/emac/mqtt_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_client/inc/lwipopts.h, project/at_start_f437/examples/emac/tcp_server/inc/lwipopts.h, project/at_start_f437/examples/emac/telnet/inc/lwipopts.h, project/at_start_f437/examples/emac/wake_on_lan/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/lwipopts.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/lwipopts.h
  • tcpip_stack_init() : project/at_start_f437/examples/emac/dns_client/inc/netconf.h, project/at_start_f437/examples/emac/dns_client/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/netconf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/netconf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • TCS_HIGH : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h
  • TCS_LOW : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h
  • TDIN_HIGH : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h
  • TDIN_LOW : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h
  • TDOUT : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h
  • TELNET_IP_ADDR_0 : telnet.h
  • TELNET_IP_ADDR_1 : telnet.h
  • TELNET_IP_ADDR_2 : telnet.h
  • TELNET_IP_ADDR_3 : telnet.h
  • temp_buf : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • TEST_BUFEER_SIZE : project/at_start_f435/examples/flash/flash_write_read/src/main.c, project/at_start_f437/examples/flash/flash_write_read/src/main.c
  • TEST_FAIL : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sdio_fatfs/src/main.c
  • TEST_FLASH_ADDRESS_START : project/at_start_f435/examples/flash/flash_write_read/src/main.c, project/at_start_f437/examples/flash/flash_write_read/src/main.c
  • TEST_LENGTH_SAMPLES : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c, utilities/at32f435_437_slib_demo/project_l0/src/main.c, utilities/at32f435_437_slib_demo/project_l1/src/main.c
  • test_result : project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f437/examples/can/filter/src/main.c
  • test_result_type : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sdio_fatfs/src/main.c
  • TEST_SIZE : project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c, project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c, project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c, project/at_start_f437/examples/qspi/command_port_using_dma/src/main.c, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/main.c, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/main.c, project/at_start_f437/examples/qspi/command_port_using_interrupt/src/main.c, project/at_start_f437/examples/qspi/command_port_using_polling/src/main.c, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/main.c, project/at_start_f437/examples/qspi/xip_port_write_read/src/main.c
  • TEST_SLIB_PSW : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • TEST_SUCCESS : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sdio_fatfs/src/main.c
  • testInput_f32_1kHz_15kHz : project_l0/src/arm_fir_data.c, utilities/at32f435_437_slib_demo/project_l0/src/main.c, project_l1/src/arm_fir_data.c, utilities/at32f435_437_slib_demo/project_l1/src/main.c
  • testMarks_f32 : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • testOutput : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c, utilities/at32f435_437_slib_demo/project_l0/src/main.c, utilities/at32f435_437_slib_demo/project_l1/src/main.c
  • testUnity_f32 : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • TFTP_ACK : tftpserver.h
  • TFTP_ACK_PKT_LEN : tftpserver.h
  • TFTP_BLKNUM_LEN : tftpserver.h
  • TFTP_DATA : tftpserver.h
  • TFTP_DATA_LEN_MAX : tftpserver.h
  • TFTP_DATA_PKT_HDR_LEN : tftpserver.h
  • TFTP_DATA_PKT_LEN_MAX : tftpserver.h
  • TFTP_ERR_ACCESS_VIOLATION : tftpserver.h
  • TFTP_ERR_DISKFULL : tftpserver.h
  • TFTP_ERR_FILE_ALREADY_EXISTS : tftpserver.h
  • TFTP_ERR_FILE_NOT_FOUND : tftpserver.h
  • TFTP_ERR_ILLEGALOP : tftpserver.h
  • TFTP_ERR_NO_SUCH_USER : tftpserver.h
  • TFTP_ERR_NOTDEFINED : tftpserver.h
  • TFTP_ERR_PKT_HDR_LEN : tftpserver.h
  • TFTP_ERR_UKNOWN_TRANSFER_ID : tftpserver.h
  • TFTP_ERROR : tftpserver.h
  • tftp_errorcode : tftpserver.h
  • tftp_iap_flag : utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • TFTP_MAX_RETRIES : tftpserver.h
  • tftp_opcode : tftpserver.h
  • TFTP_OPCODE_LEN : tftpserver.h
  • TFTP_RRQ : tftpserver.h
  • TFTP_TIMEOUT_INTERVAL : tftpserver.h
  • TFTP_WRQ : tftpserver.h
  • theFlashParams : flash_loader.c, flash_loader_extra.h
  • time : random.c
  • time_cnt : project/at_start_f435/examples/usart/printf/src/main.c, project/at_start_f437/examples/usart/printf/src/main.c
  • time_ira_cnt : at32f435_437_usart_iap_demo/source_code/bootloader/inc/tmr.h, at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c
  • time_update() : project/at_start_f437/examples/emac/dns_client/inc/netconf.h, project/at_start_f437/examples/emac/dns_client/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/netconf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/netconf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • timerperiod : project/at_start_f435/examples/tmr/7_pwm_output/src/main.c, project/at_start_f435/examples/tmr/cascade_synchro/src/main.c, project/at_start_f435/examples/tmr/complementary_signals/src/main.c, project/at_start_f435/examples/tmr/dma/src/main.c, project/at_start_f435/examples/tmr/dma_burst/src/main.c, project/at_start_f435/examples/tmr/external_clock/src/main.c, project/at_start_f435/examples/tmr/hang_mode/src/main.c, project/at_start_f435/examples/tmr/parallel_synchro/src/main.c, project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f437/examples/tmr/7_pwm_output/src/main.c, project/at_start_f437/examples/tmr/cascade_synchro/src/main.c, project/at_start_f437/examples/tmr/complementary_signals/src/main.c, project/at_start_f437/examples/tmr/dma/src/main.c, project/at_start_f437/examples/tmr/dma_burst/src/main.c, project/at_start_f437/examples/tmr/external_clock/src/main.c, project/at_start_f437/examples/tmr/hang_mode/src/main.c, project/at_start_f437/examples/tmr/parallel_synchro/src/main.c, project/at_start_f437/examples/tmr/tmr1_synchro/src/main.c
  • tmp_c4 : project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f437/examples/ertc/lick_calibration/src/at32f435_437_int.c
  • TMR1 : at32f435_437_tmr.h
  • TMR10 : at32f435_437_tmr.h
  • TMR10_BASE : at32f435_437.h
  • TMR11 : at32f435_437_tmr.h
  • TMR11_BASE : at32f435_437.h
  • TMR12 : at32f435_437_tmr.h
  • TMR12_BASE : at32f435_437.h
  • TMR13 : at32f435_437_tmr.h
  • TMR13_BASE : at32f435_437.h
  • TMR14 : at32f435_437_tmr.h
  • TMR14_BASE : at32f435_437.h
  • TMR1_BASE : at32f435_437.h
  • TMR1_BRK_TMR9_IRQHandler() : project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c
  • TMR1_BRK_TMR9_IRQn : at32f435_437.h
  • tmr1_c1dt_address : project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c
  • tmr1_c2dt_address : project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c
  • TMR1_CH_IRQn : at32f435_437.h
  • tmr1_config() : project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f435/examples/exint/exint_software_trigger/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f437/examples/exint/exint_software_trigger/src/main.c
  • TMR1_OVF_TMR10_IRQHandler() : project/at_start_f435/examples/debug/tmr1/src/main.c, project/at_start_f435/examples/edma/burst_mode/src/main.c, project/at_start_f435/examples/exint/exint_software_trigger/src/main.c, project/at_start_f435/examples/tmr/timer_base/src/main.c
  • TMR1_OVF_TMR10_IRQn : at32f435_437.h
  • TMR1_TRG_HALL_TMR11_IRQHandler() : project/at_start_f435/examples/tmr/6_steps/src/main.c
  • TMR1_TRG_HALL_TMR11_IRQn : at32f435_437.h
  • TMR2 : at32f435_437_tmr.h
  • TMR20 : at32f435_437_tmr.h
  • TMR20_BASE : at32f435_437.h
  • TMR20_BRK_IRQn : at32f435_437.h
  • TMR20_CH_IRQn : at32f435_437.h
  • TMR20_OVF_IRQn : at32f435_437.h
  • TMR20_TRG_HALL_IRQn : at32f435_437.h
  • TMR2_BASE : at32f435_437.h
  • tmr2_config() : project/at_start_f435/examples/pwc/sleep_tmr2/src/main.c
  • TMR2_GLOBAL_IRQHandler() : project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c
  • TMR2_GLOBAL_IRQn : at32f435_437.h
  • TMR2_OTG1FS_TMR5_LEXT : at32f435_437_tmr.h
  • TMR2_OTG2FS_TMR5_ERTC : at32f435_437_tmr.h
  • TMR2_PTP_TMR5_LICK : at32f435_437_tmr.h
  • TMR2_TMR8TRGOUT_TMR5_GPIO : at32f435_437_tmr.h
  • TMR3 : at32f435_437_tmr.h
  • TMR3_BASE : at32f435_437.h
  • TMR3_GLOBAL_IRQHandler() : project/at_start_f435/examples/tmr/input_capture/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/tmr.c, at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/tmr.c, at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c, at32f437_emac_iap_demo/source_code/app_led3_toggle/src/tmr.c, at32f437_emac_iap_demo/source_code/bootloader/src/tmr.c
  • TMR3_GLOBAL_IRQn : at32f435_437.h
  • tmr3freq : project/at_start_f435/examples/tmr/input_capture/src/main.c, project/at_start_f437/examples/tmr/input_capture/src/main.c
  • TMR4 : at32f435_437_tmr.h
  • TMR4_BASE : at32f435_437.h
  • TMR4_GLOBAL_IRQn : at32f435_437.h
  • TMR5 : at32f435_437_tmr.h
  • TMR5_BASE : at32f435_437.h
  • TMR5_GLOBAL_IRQHandler() : project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c
  • TMR5_GLOBAL_IRQn : at32f435_437.h
  • TMR6 : at32f435_437_tmr.h
  • TMR6_BASE : at32f435_437.h
  • TMR6_DAC_GLOBAL_IRQHandler() : project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c, project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c, project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_int.c
  • TMR6_DAC_GLOBAL_IRQn : at32f435_437.h
  • TMR7 : at32f435_437_tmr.h
  • TMR7_BASE : at32f435_437.h
  • TMR7_GLOBAL_IRQn : at32f435_437.h
  • TMR8 : at32f435_437_tmr.h
  • TMR8_BASE : at32f435_437.h
  • TMR8_BRK_TMR12_IRQn : at32f435_437.h
  • TMR8_CH_IRQn : at32f435_437.h
  • TMR8_OVF_TMR13_IRQn : at32f435_437.h
  • TMR8_TRG_HALL_TMR14_IRQn : at32f435_437.h
  • TMR9 : at32f435_437_tmr.h
  • TMR9_BASE : at32f435_437.h
  • tmr_32_bit_function_enable() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_base_init() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • TMR_BRK_ADDRESS : at32f435_437_tmr.h
  • TMR_BRK_FLAG : at32f435_437_tmr.h
  • TMR_BRK_INPUT_ACTIVE_HIGH : at32f435_437_tmr.h
  • TMR_BRK_INPUT_ACTIVE_LOW : at32f435_437_tmr.h
  • TMR_BRK_INT : at32f435_437_tmr.h
  • tmr_brk_polarity_type : at32f435_437_tmr.h
  • TMR_BRK_SWTRIG : at32f435_437_tmr.h
  • tmr_brkdt_config() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_brkdt_config_struct : project/at_start_f435/examples/tmr/6_steps/src/main.c, project/at_start_f435/examples/tmr/complementary_signals/src/main.c, project/at_start_f437/examples/tmr/6_steps/src/main.c, project/at_start_f437/examples/tmr/complementary_signals/src/main.c
  • tmr_brkdt_default_para_init() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • TMR_C1_DMA_REQUEST : at32f435_437_tmr.h
  • TMR_C1_FLAG : at32f435_437_tmr.h
  • TMR_C1_INT : at32f435_437_tmr.h
  • TMR_C1_RECAPTURE_FLAG : at32f435_437_tmr.h
  • TMR_C1_SWTRIG : at32f435_437_tmr.h
  • TMR_C1DT_ADDRESS : at32f435_437_tmr.h
  • TMR_C2_DMA_REQUEST : at32f435_437_tmr.h
  • TMR_C2_FLAG : at32f435_437_tmr.h
  • TMR_C2_INT : at32f435_437_tmr.h
  • TMR_C2_RECAPTURE_FLAG : at32f435_437_tmr.h
  • TMR_C2_SWTRIG : at32f435_437_tmr.h
  • TMR_C2DT_ADDRESS : at32f435_437_tmr.h
  • TMR_C3_DMA_REQUEST : at32f435_437_tmr.h
  • TMR_C3_FLAG : at32f435_437_tmr.h
  • TMR_C3_INT : at32f435_437_tmr.h
  • TMR_C3_RECAPTURE_FLAG : at32f435_437_tmr.h
  • TMR_C3_SWTRIG : at32f435_437_tmr.h
  • TMR_C3DT_ADDRESS : at32f435_437_tmr.h
  • TMR_C4_DMA_REQUEST : at32f435_437_tmr.h
  • TMR_C4_FLAG : at32f435_437_tmr.h
  • TMR_C4_INT : at32f435_437_tmr.h
  • TMR_C4_RECAPTURE_FLAG : at32f435_437_tmr.h
  • TMR_C4_SWTRIG : at32f435_437_tmr.h
  • TMR_C4DT_ADDRESS : at32f435_437_tmr.h
  • TMR_C5_FLAG : at32f435_437_tmr.h
  • TMR_CC_CHANNEL_MAPPED_DIRECT : at32f435_437_tmr.h
  • TMR_CC_CHANNEL_MAPPED_INDIRECT : at32f435_437_tmr.h
  • TMR_CC_CHANNEL_MAPPED_STI : at32f435_437_tmr.h
  • TMR_CCTRL_ADDRESS : at32f435_437_tmr.h
  • TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR : at32f435_437_tmr.h
  • TMR_CHANEL1_CONNECTED_C1IRAW : at32f435_437_tmr.h
  • tmr_channel1_input_connected_type : at32f435_437_tmr.h
  • tmr_channel1_input_select() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_channel_buffer_enable() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_channel_dma_select() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_channel_enable() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • TMR_CHANNEL_INPUT_DIV_1 : at32f435_437_tmr.h
  • TMR_CHANNEL_INPUT_DIV_2 : at32f435_437_tmr.h
  • TMR_CHANNEL_INPUT_DIV_4 : at32f435_437_tmr.h
  • TMR_CHANNEL_INPUT_DIV_8 : at32f435_437_tmr.h
  • tmr_channel_input_divider_type : at32f435_437_tmr.h
  • tmr_channel_select_type : at32f435_437_tmr.h
  • tmr_channel_value_get() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_channel_value_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • TMR_CLOCK_DIV1 : at32f435_437_tmr.h
  • TMR_CLOCK_DIV2 : at32f435_437_tmr.h
  • TMR_CLOCK_DIV4 : at32f435_437_tmr.h
  • tmr_clock_division_type : at32f435_437_tmr.h
  • tmr_clock_source_div_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • TMR_CM1_ADDRESS : at32f435_437_tmr.h
  • TMR_CM2_ADDRESS : at32f435_437_tmr.h
  • tmr_cnt_dir_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • TMR_COUNT_DOWN : at32f435_437_tmr.h
  • tmr_count_mode_type : at32f435_437_tmr.h
  • TMR_COUNT_TWO_WAY_1 : at32f435_437_tmr.h
  • TMR_COUNT_TWO_WAY_2 : at32f435_437_tmr.h
  • TMR_COUNT_TWO_WAY_3 : at32f435_437_tmr.h
  • TMR_COUNT_UP : at32f435_437_tmr.h
  • tmr_counter_enable() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_counter_value_get() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_counter_value_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • TMR_CTRL1_ADDRESS : at32f435_437_tmr.h
  • TMR_CTRL2_ADDRESS : at32f435_437_tmr.h
  • TMR_CVAL_ADDRESS : at32f435_437_tmr.h
  • TMR_DIV_ADDRESS : at32f435_437_tmr.h
  • tmr_div_value_get() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_div_value_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_dma_address_type : at32f435_437_tmr.h
  • tmr_dma_control_config() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • TMR_DMA_REQUEST_BY_CHANNEL : at32f435_437_tmr.h
  • TMR_DMA_REQUEST_BY_OVERFLOW : at32f435_437_tmr.h
  • tmr_dma_request_enable() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_dma_request_source_type : at32f435_437_tmr.h
  • tmr_dma_request_type : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_10BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_11BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_12BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_13BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_14BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_15BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_16BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_17BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_18BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_1BYTE : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_2BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_3BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_4BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_5BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_6BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_7BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_8BYTES : at32f435_437_tmr.h
  • TMR_DMA_TRANSFER_9BYTES : at32f435_437_tmr.h
  • tmr_dma_transfer_length_type : at32f435_437_tmr.h
  • TMR_DMACTRL_ADDRESS : at32f435_437_tmr.h
  • TMR_ENCODER_MODE_A : at32f435_437_tmr.h
  • TMR_ENCODER_MODE_B : at32f435_437_tmr.h
  • TMR_ENCODER_MODE_C : at32f435_437_tmr.h
  • tmr_encoder_mode_config() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_encoder_mode_type : at32f435_437_tmr.h
  • TMR_ES_FREQUENCY_DIV_1 : at32f435_437_tmr.h
  • TMR_ES_FREQUENCY_DIV_2 : at32f435_437_tmr.h
  • TMR_ES_FREQUENCY_DIV_4 : at32f435_437_tmr.h
  • TMR_ES_FREQUENCY_DIV_8 : at32f435_437_tmr.h
  • TMR_ES_POLARITY_INVERTED : at32f435_437_tmr.h
  • TMR_ES_POLARITY_NON_INVERTED : at32f435_437_tmr.h
  • tmr_event_sw_trigger() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_event_trigger_type : at32f435_437_tmr.h
  • tmr_external_clock_config() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_external_clock_mode1_config() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_external_clock_mode2_config() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_external_signal_divider_type : at32f435_437_tmr.h
  • tmr_external_signal_polarity_type : at32f435_437_tmr.h
  • tmr_flag_clear() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_flag_get() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • TMR_FORCE_OUTPUT_HIGH : at32f435_437_tmr.h
  • TMR_FORCE_OUTPUT_LOW : at32f435_437_tmr.h
  • tmr_force_output_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_force_output_type : at32f435_437_tmr.h
  • TMR_HALL_DMA_REQUEST : at32f435_437_tmr.h
  • TMR_HALL_FLAG : at32f435_437_tmr.h
  • TMR_HALL_INT : at32f435_437_tmr.h
  • tmr_hall_select() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • TMR_HALL_SWTRIG : at32f435_437_tmr.h
  • tmr_ic_init_structure : project/at_start_f435/examples/tmr/one_cycle/src/main.c, project/at_start_f435/examples/tmr/pwm_input/src/main.c, project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f437/examples/tmr/one_cycle/src/main.c, project/at_start_f437/examples/tmr/pwm_input/src/main.c, project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c
  • TMR_IDEN_ADDRESS : at32f435_437_tmr.h
  • tmr_init() : at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/tmr.h, at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/tmr.c, at32f435_437_usart_iap_demo/source_code/app_led4_toggle/src/tmr.c, at32f435_437_usart_iap_demo/source_code/bootloader/inc/tmr.h, at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c, at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/tmr.h, at32f437_emac_iap_demo/source_code/app_led3_toggle/src/tmr.c, at32f437_emac_iap_demo/source_code/bootloader/src/tmr.c
  • TMR_INPUT_BOTH_EDGE : at32f435_437_tmr.h
  • tmr_input_channel_divider_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_input_channel_filter_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_input_channel_init() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_input_config_struct : project/at_start_f435/examples/tmr/external_clock/src/main.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f435/examples/tmr/hang_mode/src/main.c, project/at_start_f435/examples/tmr/input_capture/src/main.c, project/at_start_f437/examples/tmr/external_clock/src/main.c, project/at_start_f437/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f437/examples/tmr/hang_mode/src/main.c, project/at_start_f437/examples/tmr/input_capture/src/main.c
  • tmr_input_default_para_init() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_input_direction_mapped_type : at32f435_437_tmr.h
  • TMR_INPUT_FALLING_EDGE : at32f435_437_tmr.h
  • tmr_input_polarity_type : at32f435_437_tmr.h
  • tmr_input_remap_type : at32f435_437_tmr.h
  • TMR_INPUT_RISING_EDGE : at32f435_437_tmr.h
  • tmr_internal_clock_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_interrupt_enable() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_iremap_config() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • TMR_ISTS_ADDRESS : at32f435_437_tmr.h
  • TMR_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • tmr_oc_init_structure : project/at_start_f435/examples/irtmr/irtmr_output/src/main.c, project/at_start_f435/examples/tmr/oc_high/src/main.c, project/at_start_f435/examples/tmr/oc_low/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f435/examples/tmr/one_cycle/src/main.c, project/at_start_f435/examples/tmr/parallel_synchro/src/main.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c, project/at_start_f437/examples/irtmr/irtmr_output/src/main.c, project/at_start_f437/examples/tmr/oc_high/src/main.c, project/at_start_f437/examples/tmr/oc_low/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f437/examples/tmr/one_cycle/src/main.c, project/at_start_f437/examples/tmr/parallel_synchro/src/main.c, project/at_start_f437/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f437/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f437/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f437/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f437/examples/tmr/tmr2_32bit/src/main.c
  • tmr_one_cycle_mode_enable() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • TMR_OUTPUT_ACTIVE_HIGH : at32f435_437_tmr.h
  • TMR_OUTPUT_ACTIVE_LOW : at32f435_437_tmr.h
  • tmr_output_channel_buffer_enable() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_output_channel_config() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_output_channel_immediately_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_output_channel_mode_select() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_output_channel_polarity_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_output_channel_switch_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • TMR_OUTPUT_CONTROL_FORCE_HIGH : at32f435_437_tmr.h
  • TMR_OUTPUT_CONTROL_FORCE_LOW : at32f435_437_tmr.h
  • TMR_OUTPUT_CONTROL_HIGH : at32f435_437_tmr.h
  • TMR_OUTPUT_CONTROL_LOW : at32f435_437_tmr.h
  • tmr_output_control_mode_type : at32f435_437_tmr.h
  • TMR_OUTPUT_CONTROL_OFF : at32f435_437_tmr.h
  • TMR_OUTPUT_CONTROL_PWM_MODE_A : at32f435_437_tmr.h
  • TMR_OUTPUT_CONTROL_PWM_MODE_B : at32f435_437_tmr.h
  • TMR_OUTPUT_CONTROL_SWITCH : at32f435_437_tmr.h
  • tmr_output_default_para_init() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_output_enable() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_output_polarity_type : at32f435_437_tmr.h
  • tmr_output_struct : project/at_start_f435/examples/edma/burst_mode/src/main.c, project/at_start_f435/examples/tmr/6_steps/src/main.c, project/at_start_f435/examples/tmr/7_pwm_output/src/main.c, project/at_start_f435/examples/tmr/cascade_synchro/src/main.c, project/at_start_f435/examples/tmr/complementary_signals/src/main.c, project/at_start_f435/examples/tmr/dma/src/main.c, project/at_start_f435/examples/tmr/dma_burst/src/main.c, project/at_start_f435/examples/tmr/external_clock/src/main.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f435/examples/tmr/hang_mode/src/main.c, project/at_start_f437/examples/edma/burst_mode/src/main.c, project/at_start_f437/examples/tmr/6_steps/src/main.c, project/at_start_f437/examples/tmr/7_pwm_output/src/main.c, project/at_start_f437/examples/tmr/cascade_synchro/src/main.c, project/at_start_f437/examples/tmr/complementary_signals/src/main.c, project/at_start_f437/examples/tmr/dma/src/main.c, project/at_start_f437/examples/tmr/dma_burst/src/main.c, project/at_start_f437/examples/tmr/external_clock/src/main.c, project/at_start_f437/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f437/examples/tmr/hang_mode/src/main.c
  • TMR_OVERFLOW_DMA_REQUEST : at32f435_437_tmr.h
  • tmr_overflow_event_disable() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_overflow_request_source_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • TMR_OVERFLOW_SWTRIG : at32f435_437_tmr.h
  • TMR_OVF_FLAG : at32f435_437_tmr.h
  • TMR_OVF_INT : at32f435_437_tmr.h
  • tmr_period_buffer_enable() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_period_value_get() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_period_value_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • TMR_POLARITY_ACTIVE_BOTH : at32f435_437_tmr.h
  • TMR_POLARITY_ACTIVE_HIGH : at32f435_437_tmr.h
  • TMR_POLARITY_ACTIVE_LOW : at32f435_437_tmr.h
  • tmr_polarity_active_type : at32f435_437_tmr.h
  • TMR_PR_ADDRESS : at32f435_437_tmr.h
  • tmr_primary_mode_select() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • TMR_PRIMARY_SEL_C1ORAW : at32f435_437_tmr.h
  • TMR_PRIMARY_SEL_C2ORAW : at32f435_437_tmr.h
  • TMR_PRIMARY_SEL_C3ORAW : at32f435_437_tmr.h
  • TMR_PRIMARY_SEL_C4ORAW : at32f435_437_tmr.h
  • TMR_PRIMARY_SEL_COMPARE : at32f435_437_tmr.h
  • TMR_PRIMARY_SEL_ENABLE : at32f435_437_tmr.h
  • TMR_PRIMARY_SEL_OVERFLOW : at32f435_437_tmr.h
  • TMR_PRIMARY_SEL_RESET : at32f435_437_tmr.h
  • tmr_primary_select_type : at32f435_437_tmr.h
  • tmr_pwm_input_config() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_repetition_counter_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_reset() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • TMR_RPR_ADDRESS : at32f435_437_tmr.h
  • TMR_SELECT_CHANNEL_1 : at32f435_437_tmr.h
  • TMR_SELECT_CHANNEL_1C : at32f435_437_tmr.h
  • TMR_SELECT_CHANNEL_2 : at32f435_437_tmr.h
  • TMR_SELECT_CHANNEL_2C : at32f435_437_tmr.h
  • TMR_SELECT_CHANNEL_3 : at32f435_437_tmr.h
  • TMR_SELECT_CHANNEL_3C : at32f435_437_tmr.h
  • TMR_SELECT_CHANNEL_4 : at32f435_437_tmr.h
  • TMR_SELECT_CHANNEL_5 : at32f435_437_tmr.h
  • TMR_STCTRL_ADDRESS : at32f435_437_tmr.h
  • TMR_SUB_ENCODER_MODE_A : at32f435_437_tmr.h
  • TMR_SUB_ENCODER_MODE_B : at32f435_437_tmr.h
  • TMR_SUB_ENCODER_MODE_C : at32f435_437_tmr.h
  • TMR_SUB_EXTERNAL_CLOCK_MODE_A : at32f435_437_tmr.h
  • TMR_SUB_HANG_MODE : at32f435_437_tmr.h
  • TMR_SUB_INPUT_SEL_C1DF1 : at32f435_437_tmr.h
  • TMR_SUB_INPUT_SEL_C1INC : at32f435_437_tmr.h
  • TMR_SUB_INPUT_SEL_C2DF2 : at32f435_437_tmr.h
  • TMR_SUB_INPUT_SEL_EXTIN : at32f435_437_tmr.h
  • TMR_SUB_INPUT_SEL_IS0 : at32f435_437_tmr.h
  • TMR_SUB_INPUT_SEL_IS1 : at32f435_437_tmr.h
  • TMR_SUB_INPUT_SEL_IS2 : at32f435_437_tmr.h
  • TMR_SUB_INPUT_SEL_IS3 : at32f435_437_tmr.h
  • TMR_SUB_MODE_DIABLE : at32f435_437_tmr.h
  • tmr_sub_mode_select() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • tmr_sub_mode_select_type : at32f435_437_tmr.h
  • TMR_SUB_RESET_MODE : at32f435_437_tmr.h
  • tmr_sub_sync_mode_set() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • TMR_SUB_TRIGGER_MODE : at32f435_437_tmr.h
  • TMR_SWEVT_ADDRESS : at32f435_437_tmr.h
  • tmr_trgout2_enable() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • TMR_TRIGGER_DMA_REQUEST : at32f435_437_tmr.h
  • TMR_TRIGGER_FLAG : at32f435_437_tmr.h
  • tmr_trigger_input_select() : at32f435_437_tmr.h, at32f435_437_tmr.c
  • TMR_TRIGGER_INT : at32f435_437_tmr.h
  • TMR_TRIGGER_SWTRIG : at32f435_437_tmr.h
  • TMR_WP_LEVEL_1 : at32f435_437_tmr.h
  • TMR_WP_LEVEL_2 : at32f435_437_tmr.h
  • TMR_WP_LEVEL_3 : at32f435_437_tmr.h
  • tmr_wp_level_type : at32f435_437_tmr.h
  • TMR_WP_OFF : at32f435_437_tmr.h
  • touch_adjust() : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c
  • touch_dev_struct : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c, at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c
  • touch_pin_init() : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c
  • touch_read_1byte() : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c
  • touch_read_ad() : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c
  • touch_read_x_or_y() : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c
  • touch_read_xy() : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c
  • touch_scan() : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c
  • touch_struct : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c, at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c
  • touch_write_1byte() : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c
  • transfer_count : project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c
  • transfer_end : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c, at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • transfer_error : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c, at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • transfer_status : project/at_start_f435/examples/dma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/two_dimension_mode/src/main.c, project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f435/examples/spi/w25q_flash/src/main.c, project/at_start_f437/examples/dma/flash_to_sram/src/main.c, project/at_start_f437/examples/edma/flash_to_sram/src/main.c, project/at_start_f437/examples/edma/two_dimension_mode/src/main.c, project/at_start_f437/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f437/examples/spi/w25q_flash/src/main.c
  • transfer_status1 : project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • transfer_status2 : project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • transfer_status3 : project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c
  • transfer_status4 : project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c
  • TRUE : at32f435_437.h
  • tx_buf : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c
  • tx_buf1 : project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • tx_buf2 : project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • tx_buf3 : project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • tx_buffer : project/at_start_f435/examples/edma/link_list_mode/src/main.c, project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f437/examples/edma/link_list_mode/src/main.c, project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c
  • tx_counter : project/at_start_f435/examples/usart/receiver_mute/src/main.c, project/at_start_f437/examples/usart/receiver_mute/src/main.c
  • tx_data_fill() : project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/w25q_flash/src/main.c
  • tx_index : project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • TXBUF_SIZE : project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c
  • txbuffer : project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f435/examples/xmc/nor_flash/src/main.c, project/at_start_f435/examples/xmc/psram/src/main.c, project/at_start_f435/examples/xmc/sdram_basic/src/main.c, project/at_start_f435/examples/xmc/sdram_dma/src/main.c, project/at_start_f435/examples/xmc/sram/src/main.c, project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f437/examples/xmc/nor_flash/src/main.c, project/at_start_f437/examples/xmc/psram/src/main.c, project/at_start_f437/examples/xmc/sdram_basic/src/main.c, project/at_start_f437/examples/xmc/sdram_dma/src/main.c, project/at_start_f437/examples/xmc/sram/src/main.c


AT32F435/437 Firmwary Library: Globals

- i -

  • iapfun : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h, at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h
  • INT16 : at32f435_437.h
  • INT32 : at32f435_437.h
  • INT8 : at32f435_437.h
  • IRQn_Type : at32f435_437.h

- s -

  • s16 : at32f435_437.h
  • s32 : at32f435_437.h
  • s8 : at32f435_437.h
  • sc16 : at32f435_437.h
  • sc32 : at32f435_437.h
  • sc8 : at32f435_437.h

- u -

  • u16 : at32f435_437.h
  • u32 : at32f435_437.h
  • u8 : at32f435_437.h
  • uc16 : at32f435_437.h
  • uc32 : at32f435_437.h
  • uc8 : at32f435_437.h
  • UINT16 : at32f435_437.h
  • UINT32 : at32f435_437.h
  • UINT8 : at32f435_437.h
  • usb_reg_type : at32f435_437_usb.h

- v -

  • vs16 : at32f435_437.h
  • vs32 : at32f435_437.h
  • vs8 : at32f435_437.h
  • vsc16 : at32f435_437.h
  • vsc32 : at32f435_437.h
  • vsc8 : at32f435_437.h
  • vu16 : at32f435_437.h
  • vu32 : at32f435_437.h
  • vu8 : at32f435_437.h
  • vuc16 : at32f435_437.h
  • vuc32 : at32f435_437.h
  • vuc8 : at32f435_437.h


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- u -

  • u16 : at32f435_437.h
  • u32 : at32f435_437.h
  • u8 : at32f435_437.h
  • UART4 : at32f435_437_usart.h
  • UART4_BASE : at32f435_437.h
  • UART4_IRQn : at32f435_437.h
  • UART5 : at32f435_437_usart.h
  • UART5_BASE : at32f435_437.h
  • UART5_IRQn : at32f435_437.h
  • UART7 : at32f435_437_usart.h
  • UART7_BASE : at32f435_437.h
  • UART7_IRQn : at32f435_437.h
  • UART8 : at32f435_437_usart.h
  • UART8_BASE : at32f435_437.h
  • UART8_IRQn : at32f435_437.h
  • uart_init() : project/at_start_f435/examples/edma/link_list_mode/src/main.c, project/at_start_f435/examples/tmr/input_capture/src/main.c, app_led3_toggle/inc/usart.h, app_led3_toggle/src/usart.c, app_led4_toggle/src/usart.c, bootloader/inc/usart.h, bootloader/src/usart.c
  • uart_print_init() : at32f435_437_board.c, at32f435_437_board.h
  • uc16 : at32f435_437.h
  • uc32 : at32f435_437.h
  • uc8 : at32f435_437.h
  • uhost_hid_class_handler : usbh_hid_class.c, usbh_hid_class.h
  • uhost_init_handler() : usbh_hid_class.c, usbh_msc_class.c
  • uhost_msc_class_handler : usbh_msc_class.c, usbh_msc_class.h
  • uhost_process_handler() : usbh_hid_class.c, usbh_msc_class.c
  • uhost_request_handler() : usbh_hid_class.c, usbh_msc_class.c
  • uhost_reset_handler() : usbh_hid_class.c, usbh_msc_class.c
  • UINT16 : at32f435_437.h
  • UINT32 : at32f435_437.h
  • UINT8 : at32f435_437.h
  • UnInit() : FlashOS.h, FlashPrg.c
  • uninit_clk() : qspi_algorithm.c, FlashPrg.c
  • UNKNOWN : FlashOS.h
  • UNUSED : at32f435_437_def.h
  • UP_MOVE : mouse_class.h
  • UPDATE_CLEAR_FLAG : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • UPDATE_DONE : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • UPDATE_ING : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • UPDATE_PRE : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • update_status : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h, at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
  • update_status_type : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • UPGRADE_DONE : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • UPGRADE_FAILED : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • UPGRADE_JUMP : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • UPGRADE_LARGE : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • UPGRADE_READY : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • upgrade_status_type : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • UPGRADE_SUCCESS : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • UPGRADE_UNKNOWN : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • UPGRAGE_ONGOING : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h
  • UsageFault_Handler() : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c, project/at_start_f435/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f435/examples/can/filter/src/at32f435_437_int.c, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c, project/at_start_f435/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/printer/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/vcp_loopback/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_comport/src/at32f435_437_int.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/hid_demo/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/msc_only_fat32/src/at32f435_437_int.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f435/examples/wdt/wdt_standby/src/at32f435_437_int.c, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f435/examples/wwdt/wwdt_reset/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_8bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/ecc/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nand_flash/nand/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/nor_flash/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/psram/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_basic/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sdram_dma/src/at32f435_437_int.c, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f435/examples/xmc/sram/src/at32f435_437_int.c, project/at_start_f435/templates/inc/at32f435_437_int.h, project/at_start_f435/templates/src/at32f435_437_int.c, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_int.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_int.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_int.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/dns_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/http_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/iperf/src/at32f435_437_int.c, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/mqtt_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_client/src/at32f435_437_int.c, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/tcp_server/src/at32f435_437_int.c, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/telnet/src/at32f435_437_int.c, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_int.h, project/at_start_f437/examples/emac/wake_on_lan/src/at32f435_437_int.c, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_int.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_int.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_int.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_int.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_int.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_int.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_int.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_int.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_int.h, project/at_start_f437/templates/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_int.h, utilities/at32f435_437_freertos_demo/src/at32f435_437_int.c, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_int.h, utilities/at32f435_437_gen_random_number_demo/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l0/src/at32f435_437_int.c, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_int.h, utilities/at32f435_437_slib_demo/project_l1/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/at32f435_437_int.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32f435_437_int.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_int.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32f435_437_int.c
  • UsageFault_IRQn : at32f435_437.h
  • USART1 : at32f435_437_usart.h
  • USART1_BASE : at32f435_437.h
  • usart1_config() : project/at_start_f435/examples/pwc/sleep_usart1/src/main.c
  • usart1_index : project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c, project/at_start_f437/examples/pwc/sleep_usart1/src/at32f435_437_int.c
  • USART1_IRQHandler() : project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c, app_led3_toggle/src/usart.c, app_led4_toggle/src/usart.c, bootloader/src/usart.c
  • USART1_IRQn : at32f435_437.h
  • USART2 : at32f435_437_usart.h
  • USART2_BASE : at32f435_437.h
  • USART2_IRQHandler() : project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/rs485/src/main.c, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c
  • USART2_IRQn : at32f435_437.h
  • usart2_rx_buffer : project/at_start_f435/examples/usart/half_duplex/src/main.c, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usart/half_duplex/src/main.c, project/at_start_f437/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c
  • usart2_rx_counter : project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c
  • usart2_rx_dma_status : project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c
  • usart2_tx_buffer : project/at_start_f435/examples/usart/half_duplex/src/main.c, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/receiver_mute/src/main.c, project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usart/half_duplex/src/main.c, project/at_start_f437/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/receiver_mute/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c
  • usart2_tx_buffer_size : project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c
  • USART2_TX_BUFFER_SIZE : project/at_start_f435/examples/usart/half_duplex/src/main.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usart/half_duplex/src/main.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c
  • usart2_tx_counter : project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f437/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usb_device/virtual_comport/src/main.c
  • usart2_tx_dma_status : project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c
  • USART3 : at32f435_437_usart.h
  • USART3_BASE : at32f435_437.h
  • USART3_IRQHandler() : project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c
  • USART3_IRQn : at32f435_437.h
  • usart3_rx_buffer : project/at_start_f435/examples/usart/half_duplex/src/main.c, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f435/examples/usart/receiver_mute/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usart/half_duplex/src/main.c, project/at_start_f437/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f437/examples/usart/receiver_mute/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c
  • usart3_rx_counter : project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c
  • usart3_rx_dma_status : project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c
  • usart3_tx_buffer : project/at_start_f435/examples/usart/half_duplex/src/main.c, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usart/half_duplex/src/main.c, project/at_start_f437/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c
  • usart3_tx_buffer_size : project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c
  • USART3_TX_BUFFER_SIZE : project/at_start_f435/examples/usart/half_duplex/src/main.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usart/half_duplex/src/main.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c
  • usart3_tx_counter : project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c
  • usart3_tx_dma_status : project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c
  • USART6 : at32f435_437_usart.h
  • USART6_BASE : at32f435_437.h
  • USART6_IRQn : at32f435_437.h
  • USART_BF_INT : at32f435_437_usart.h
  • USART_BFF_FLAG : at32f435_437_usart.h
  • USART_BREAK_10BITS : at32f435_437_usart.h
  • USART_BREAK_11BITS : at32f435_437_usart.h
  • usart_break_bit_num_set() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_break_bit_num_type : at32f435_437_usart.h
  • usart_break_send() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_buffer_size : project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f437/examples/usb_device/virtual_comport/src/main.c
  • usart_clock_config() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_clock_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • USART_CLOCK_LAST_BIT_NONE : at32f435_437_usart.h
  • USART_CLOCK_LAST_BIT_OUTPUT : at32f435_437_usart.h
  • USART_CLOCK_PHASE_1EDGE : at32f435_437_usart.h
  • USART_CLOCK_PHASE_2EDGE : at32f435_437_usart.h
  • usart_clock_phase_type : at32f435_437_usart.h
  • USART_CLOCK_POLARITY_HIGH : at32f435_437_usart.h
  • USART_CLOCK_POLARITY_LOW : at32f435_437_usart.h
  • usart_clock_polarity_type : at32f435_437_usart.h
  • usart_configuration() : project/at_start_f435/examples/usart/half_duplex/src/main.c, project/at_start_f435/examples/usart/hw_flow_control/src/main.c, project/at_start_f435/examples/usart/idle_detection/src/main.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/irda/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/receiver_mute/src/main.c, project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c
  • USART_CTSCF_FLAG : at32f435_437_usart.h
  • USART_CTSCF_INT : at32f435_437_usart.h
  • USART_DATA_7BITS : at32f435_437_usart.h
  • USART_DATA_8BITS : at32f435_437_usart.h
  • USART_DATA_9BITS : at32f435_437_usart.h
  • usart_data_bit_num_type : at32f435_437_usart.h
  • usart_data_receive() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_data_transmit() : at32f435_437_usart.h, at32f435_437_usart.c
  • USART_DE_POLARITY_HIGH : at32f435_437_usart.h
  • USART_DE_POLARITY_LOW : at32f435_437_usart.h
  • usart_de_polarity_set() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_de_polarity_type : at32f435_437_usart.h
  • usart_dma_receiver_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_dma_transmitter_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • USART_ERR_INT : at32f435_437_usart.h
  • USART_FERR_FLAG : at32f435_437_usart.h
  • usart_flag_clear() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_flag_get() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_gpio_config() : project/at_start_f435/examples/usb_device/virtual_comport/src/main.c
  • usart_group_struct : bootloader/inc/usart.h, bootloader/src/usart.c
  • usart_hardware_flow_control_set() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_hardware_flow_control_type : at32f435_437_usart.h
  • USART_HARDWARE_FLOW_CTS : at32f435_437_usart.h
  • USART_HARDWARE_FLOW_NONE : at32f435_437_usart.h
  • USART_HARDWARE_FLOW_RTS : at32f435_437_usart.h
  • USART_HARDWARE_FLOW_RTS_CTS : at32f435_437_usart.h
  • usart_id_bit_num_set() : at32f435_437_usart.h, at32f435_437_usart.c
  • USART_ID_FIXED_4_BIT : at32f435_437_usart.h
  • USART_ID_RELATED_DATA_BIT : at32f435_437_usart.h
  • usart_identification_bit_num_type : at32f435_437_usart.h
  • USART_IDLE_INT : at32f435_437_usart.h
  • USART_IDLEF_FLAG : at32f435_437_usart.h
  • usart_init() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_interrupt_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_irda_low_power_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_irda_mode_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_irda_smartcard_division_set() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_lbcp_type : at32f435_437_usart.h
  • usart_lin_mode_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • USART_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • USART_NERR_FLAG : at32f435_437_usart.h
  • USART_PARITY_EVEN : at32f435_437_usart.h
  • USART_PARITY_NONE : at32f435_437_usart.h
  • USART_PARITY_ODD : at32f435_437_usart.h
  • usart_parity_selection_config() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_parity_selection_type : at32f435_437_usart.h
  • USART_PERR_FLAG : at32f435_437_usart.h
  • USART_PERR_INT : at32f435_437_usart.h
  • USART_RDBF_FLAG : at32f435_437_usart.h
  • USART_RDBF_INT : at32f435_437_usart.h
  • USART_REC_LEN : bootloader/inc/usart.h
  • usart_receive_data() : project/at_start_f435/examples/usb_device/virtual_comport/src/main.c
  • usart_receiver_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_receiver_mute_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_reset() : at32f435_437_usart.h, at32f435_437_usart.c
  • USART_ROERR_FLAG : at32f435_437_usart.h
  • usart_rs485_delay_time_config() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_rs485_mode_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_rx_buffer : project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f437/examples/usb_device/virtual_comport/src/main.c
  • usart_rx_data_len : project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f437/examples/usb_device/virtual_comport/src/main.c
  • usart_send_data() : project/at_start_f435/examples/usb_device/virtual_comport/src/main.c
  • usart_single_line_halfduplex_select() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_smartcard_guard_time_set() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_smartcard_mode_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_smartcard_nack_set() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_spi_configuration() : project/at_start_f435/examples/usart/synchronous/src/main.c
  • USART_STOP_0_5_BIT : at32f435_437_usart.h
  • USART_STOP_1_5_BIT : at32f435_437_usart.h
  • USART_STOP_1_BIT : at32f435_437_usart.h
  • USART_STOP_2_BIT : at32f435_437_usart.h
  • usart_stop_bit_num_type : at32f435_437_usart.h
  • USART_TDBE_FLAG : at32f435_437_usart.h
  • USART_TDBE_INT : at32f435_437_usart.h
  • USART_TDC_FLAG : at32f435_437_usart.h
  • USART_TDC_INT : at32f435_437_usart.h
  • usart_transmit_receive_pin_swap() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_transmitter_enable() : at32f435_437_usart.h, at32f435_437_usart.c
  • USART_WAKEUP_BY_IDLE_FRAME : at32f435_437_usart.h
  • USART_WAKEUP_BY_MATCHING_ID : at32f435_437_usart.h
  • usart_wakeup_id_set() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_wakeup_mode_set() : at32f435_437_usart.h, at32f435_437_usart.c
  • usart_wakeup_mode_type : at32f435_437_usart.h
  • USB2_ID : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • usb_bot_request() : usbh_msc_bot_scsi.c, usbh_msc_bot_scsi.h
  • usb_buffer : project/at_start_f435/examples/acc/calibration/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f437/examples/acc/calibration/src/main.c, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f437/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f437/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f437/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f437/examples/usb_device/virtual_comport/src/main.c
  • USB_CHL : at32f435_437_usb.h
  • USB_CLASS_CODE_AUDIO : usb_std.h
  • USB_CLASS_CODE_CCID : usb_std.h
  • USB_CLASS_CODE_CDC : usb_std.h
  • USB_CLASS_CODE_CDCDATA : usb_std.h
  • USB_CLASS_CODE_HID : usb_std.h
  • USB_CLASS_CODE_HUB : usb_std.h
  • USB_CLASS_CODE_MSC : usb_std.h
  • USB_CLASS_CODE_PRINTER : usb_std.h
  • USB_CLASS_CODE_VENDOR : usb_std.h
  • USB_CLASS_CODE_VIDEO : usb_std.h
  • usb_clk48_s : at32f435_437_usb.h
  • USB_CLK_HEXT : at32f435_437_usb.h
  • USB_CLK_HICK : at32f435_437_usb.h
  • usb_clock48m_select() : project/at_start_f435/examples/acc/calibration/src/main.c, project/at_start_f435/examples/usb_device/audio/src/main.c, project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f435/examples/usb_device/custom_hid/src/main.c, project/at_start_f435/examples/usb_device/keyboard/src/main.c, project/at_start_f435/examples/usb_device/mouse/src/main.c, project/at_start_f435/examples/usb_device/msc/src/main.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/printer/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c, project/at_start_f435/examples/usb_host/hid_demo/src/main.c, project/at_start_f435/examples/usb_host/msc_only_fat32/src/main.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c
  • USB_CONF_REMOTE_WAKEUP : usb_std.h
  • USB_CONF_SELF_POWERED : usb_std.h
  • USB_CONFIG_STRING : usb_std.h
  • USB_CONN_STATE_ADDRESSED : usb_std.h
  • USB_CONN_STATE_CONFIGURED : usb_std.h
  • USB_CONN_STATE_DEFAULT : usb_std.h
  • USB_CONN_STATE_SUSPENDED : usb_std.h
  • usb_connect() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_core_config() : usb_core.h, usb_core.c
  • USB_DCFG_FULL_SPEED : at32f435_437_usb.h
  • usb_delay_ms() : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/acc/calibration/src/main.c, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c
  • usb_delay_us() : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/acc/calibration/src/main.c, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c
  • USB_DESCIPTOR_TYPE_CONFIGURATION : usb_std.h
  • USB_DESCIPTOR_TYPE_DEVICE : usb_std.h
  • USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER : usb_std.h
  • USB_DESCIPTOR_TYPE_ENDPOINT : usb_std.h
  • USB_DESCIPTOR_TYPE_INTERFACE : usb_std.h
  • USB_DESCIPTOR_TYPE_INTERFACE_POWER : usb_std.h
  • USB_DESCIPTOR_TYPE_OTHER_SPEED : usb_std.h
  • USB_DESCIPTOR_TYPE_STRING : usb_std.h
  • USB_DEVICE_CFG_DESC_LEN : usb_std.h
  • USB_DEVICE_DESC_LEN : usb_std.h
  • USB_DEVICE_EPT_LEN : usb_std.h
  • USB_DEVICE_IF_DESC_LEN : usb_std.h
  • USB_DEVICE_LANGID_STR_DESC_LEN : usb_std.h
  • USB_DEVICE_OTG_DESC_LEN : usb_std.h
  • USB_DEVICE_OTHER_SPEED_DESC_SIZ_LEN : usb_std.h
  • USB_DEVICE_QUALIFIER_DESC_LEN : usb_std.h
  • usb_disconnect() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_endpoint_number_type : at32f435_437_usb.h
  • USB_EPT0 : at32f435_437_usb.h
  • USB_EPT0_DATA_IN : usb_std.h
  • USB_EPT0_DATA_OUT : usb_std.h
  • USB_EPT0_IDLE : usb_std.h
  • USB_EPT0_MPS_16 : at32f435_437_usb.h
  • USB_EPT0_MPS_32 : at32f435_437_usb.h
  • USB_EPT0_MPS_64 : at32f435_437_usb.h
  • USB_EPT0_MPS_8 : at32f435_437_usb.h
  • usb_ept0_setup() : at32f435_437_usb.h, at32f435_437_usb.c
  • USB_EPT0_SETUP : usb_std.h
  • USB_EPT0_STALL : usb_std.h
  • usb_ept0_start() : at32f435_437_usb.h, at32f435_437_usb.c
  • USB_EPT0_STATUS_IN : usb_std.h
  • USB_EPT0_STATUS_OUT : usb_std.h
  • USB_EPT1 : at32f435_437_usb.h
  • USB_EPT2 : at32f435_437_usb.h
  • USB_EPT3 : at32f435_437_usb.h
  • USB_EPT4 : at32f435_437_usb.h
  • USB_EPT5 : at32f435_437_usb.h
  • USB_EPT6 : at32f435_437_usb.h
  • USB_EPT7 : at32f435_437_usb.h
  • usb_ept_clear_stall() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_ept_close() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_ept_default_init() : usbd_core.c
  • USB_EPT_DESC_BULK : usb_std.h
  • USB_EPT_DESC_CONTROL : usb_std.h
  • USB_EPT_DESC_DATA_EPT : usb_std.h
  • USB_EPT_DESC_FD_EPT : usb_std.h
  • USB_EPT_DESC_FDDATA_EPT : usb_std.h
  • USB_EPT_DESC_INTERRUPT : usb_std.h
  • USB_EPT_DESC_ISO : usb_std.h
  • USB_EPT_DESC_NSYNC : usb_std.h
  • usb_ept_in_clear() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_ept_in_interrupt() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_ept_open() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_ept_out_clear() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_ept_out_interrupt() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_ept_stall() : at32f435_437_usb.h, at32f435_437_usb.c
  • USB_ERROR : usb_std.h
  • USB_ETP_DESC_ADAPTIVE : usb_std.h
  • USB_ETP_DESC_ASYNC : usb_std.h
  • USB_ETP_DESC_SYNC : usb_std.h
  • USB_FAIL : usb_std.h
  • USB_FEATURE_EPT_HALT : usb_std.h
  • USB_FEATURE_REMOTE_WAKEUP : usb_std.h
  • USB_FEATURE_TEST_MODE : usb_std.h
  • USB_FIFO : at32f435_437_usb.h
  • USB_FLASH_ADDR_OFFSET : at_start_f435/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/msc/inc/msc_diskio.h, at_start_f435/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h, at_start_f437/examples/usb_device/composite_vcp_msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/msc/inc/msc_diskio.h, at_start_f437/examples/usb_device/virtual_msc_iap/inc/msc_diskio.h
  • usb_flush_rx_fifo() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_flush_tx_fifo() : at32f435_437_usb.h, at32f435_437_usb.c
  • USB_FULL_SPEED_CORE_ID : usb_core.h
  • usb_get_all_in_interrupt() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_get_all_out_interrupt() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_global_clear_interrupt() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_global_get_all_interrupt() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_global_init() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_global_interrupt_enable() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_global_power_on() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_global_reset() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_global_select_core() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_global_set_mode() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_gpio_config() : project/at_start_f435/examples/acc/calibration/src/main.c, project/at_start_f435/examples/usb_device/audio/src/main.c, project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f435/examples/usb_device/custom_hid/src/main.c, project/at_start_f435/examples/usb_device/keyboard/src/main.c, project/at_start_f435/examples/usb_device/mouse/src/main.c, project/at_start_f435/examples/usb_device/msc/src/main.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/printer/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c, project/at_start_f435/examples/usb_host/hid_demo/src/main.c, project/at_start_f435/examples/usb_host/msc_only_fat32/src/main.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c
  • usb_hc_enable() : at32f435_437_usb.h, at32f435_437_usb.c
  • USB_HCFG_CLK_48M : at32f435_437_usb.h
  • USB_HCFG_CLK_60M : at32f435_437_usb.h
  • USB_HCFG_CLK_6M : at32f435_437_usb.h
  • usb_hch_halt() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_hch_read_interrupt() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_hid_buf_process() : audio_hid_class.c, custom_hid_class.c
  • USB_HID_BUSY : usbh_hid_class.h
  • usb_hid_ctrl_state_type : usbh_hid_class.h
  • USB_HID_ERROR : usbh_hid_class.h
  • USB_HID_GET : usbh_hid_class.h
  • USB_HID_GET_IDLE : usbh_hid_class.h, usbh_msc_class.h
  • USB_HID_GET_PROTOCOL : usbh_hid_class.h, usbh_msc_class.h
  • USB_HID_GET_REPORT : usbh_hid_class.h, usbh_msc_class.h
  • USB_HID_INIT : usbh_hid_class.h
  • USB_HID_KEYBOARD_PROTOCOL_CODE : usbh_hid_class.h
  • usb_hid_keyboard_send_char() : keyboard_class.c, keyboard_class.h
  • USB_HID_MOUSE_PROTOCOL_CODE : usbh_hid_class.h
  • usb_hid_mouse_send() : mouse_class.c, mouse_class.h
  • USB_HID_NONE_PROTOCOL_CODE : usbh_hid_class.h
  • USB_HID_POLL : usbh_hid_class.h
  • USB_HID_SEND : usbh_hid_class.h
  • USB_HID_SET_IDLE : usbh_hid_class.h, usbh_msc_class.h
  • USB_HID_SET_PROTOCOL : usbh_hid_class.h, usbh_msc_class.h
  • USB_HID_SET_REPORT : usbh_hid_class.h, usbh_msc_class.h
  • USB_HID_STATE_COMPLETE : usbh_hid_class.h
  • USB_HID_STATE_GET_DESC : usbh_hid_class.h
  • USB_HID_STATE_GET_REPORT : usbh_hid_class.h
  • USB_HID_STATE_IDLE : usbh_hid_class.h
  • USB_HID_STATE_SET_IDLE : usbh_hid_class.h
  • USB_HID_STATE_SET_PROTOCOL : usbh_hid_class.h
  • usb_hid_state_type : usbh_hid_class.h
  • USB_HIGH_SPEED_CORE_ID : usb_core.h
  • usb_host_disable() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_iap_class_send_report() : hid_iap_class.c, hid_iap_class.h
  • USB_ID : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USB_INEPT : at32f435_437_usb.h
  • USB_INTERFACE_ASSOCIATION_TYPE : cdc_msc_desc.c
  • USB_INTERFACE_STRING : usb_std.h
  • usb_interrupt_disable() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_interrupt_enable() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_keyboard_class_send_report() : keyboard_class.c, keyboard_class.h
  • USB_LANGID_STRING : usb_std.h
  • usb_low_power_wakeup_config() : project/at_start_f435/examples/acc/calibration/src/main.c, project/at_start_f435/examples/usb_device/audio/src/main.c, project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f435/examples/usb_device/custom_hid/src/main.c, project/at_start_f435/examples/usb_device/keyboard/src/main.c, project/at_start_f435/examples/usb_device/mouse/src/main.c, project/at_start_f435/examples/usb_device/msc/src/main.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/printer/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c, project/at_start_f435/examples/usb_host/hid_demo/src/main.c, project/at_start_f435/examples/usb_host/msc_only_fat32/src/main.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c
  • USB_LOW_POWER_WAKUP : project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h
  • USB_LOW_SPEED_CORE_ID : usb_core.h
  • USB_MAX_DATA_LENGTH : at32f435_437_usb.h
  • USB_MAX_EP0_SIZE : usb_std.h
  • USB_MFC_STRING : usb_std.h
  • USB_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • usb_mouse_class_send_report() : mouse_class.c, mouse_class.h
  • USB_NOT_SUPPORT : usb_std.h
  • USB_OK : usb_std.h
  • usb_open_phy_clk() : at32f435_437_usb.h, at32f435_437_usb.c
  • USB_OTG1_ID : at32f435_437_usb.h
  • USB_OTG2_ID : at32f435_437_usb.h
  • USB_OTG_CONIDSCHG_FLAG : at32f435_437_usb.h
  • USB_OTG_CONIDSCHG_INT : at32f435_437_usb.h
  • USB_OTG_CURMODE : at32f435_437_usb.h
  • USB_OTG_DCTL_CGNPINNAK : at32f435_437_usb.h
  • USB_OTG_DCTL_CGOUTNAK : at32f435_437_usb.h
  • USB_OTG_DCTL_GNPINNAKSTS : at32f435_437_usb.h
  • USB_OTG_DCTL_GOUTNAKSTS : at32f435_437_usb.h
  • USB_OTG_DCTL_PWROPRGDNE : at32f435_437_usb.h
  • USB_OTG_DCTL_RWKUPSIG : at32f435_437_usb.h
  • USB_OTG_DCTL_SFTDISCON : at32f435_437_usb.h
  • USB_OTG_DCTL_SGNPINNAK : at32f435_437_usb.h
  • USB_OTG_DCTL_SGOUTNAK : at32f435_437_usb.h
  • USB_OTG_DIEPINT_EPTDISD_FLAG : at32f435_437_usb.h
  • USB_OTG_DIEPINT_INEPTNAK_FLAG : at32f435_437_usb.h
  • USB_OTG_DIEPINT_INTKNTXFEMP_FLAG : at32f435_437_usb.h
  • USB_OTG_DIEPINT_TIMEOUT_FLAG : at32f435_437_usb.h
  • USB_OTG_DIEPINT_TXFEMP_FLAG : at32f435_437_usb.h
  • USB_OTG_DIEPINT_XFERC_FLAG : at32f435_437_usb.h
  • USB_OTG_DISCON_FLAG : at32f435_437_usb.h
  • USB_OTG_DISCON_INT : at32f435_437_usb.h
  • USB_OTG_DOEPINT_B2BSTUP_FLAG : at32f435_437_usb.h
  • USB_OTG_DOEPINT_EPTDISD_FLAG : at32f435_437_usb.h
  • USB_OTG_DOEPINT_OUTTEPD_FLAG : at32f435_437_usb.h
  • USB_OTG_DOEPINT_SETUP_FLAG : at32f435_437_usb.h
  • USB_OTG_DOEPINT_XFERC_FLAG : at32f435_437_usb.h
  • USB_OTG_DTXFSTS_INEPTFSAV : at32f435_437_usb.h
  • USB_OTG_ENUMDONE_FLAG : at32f435_437_usb.h
  • USB_OTG_ENUMDONE_INT : at32f435_437_usb.h
  • USB_OTG_EOPF_FLAG : at32f435_437_usb.h
  • USB_OTG_EOPF_INT : at32f435_437_usb.h
  • USB_OTG_ERLYSUSP_FLAG : at32f435_437_usb.h
  • USB_OTG_ERLYSUSP_INT : at32f435_437_usb.h
  • USB_OTG_GINNAKEFF_FLAG : at32f435_437_usb.h
  • USB_OTG_GINNAKEFF_INT : at32f435_437_usb.h
  • USB_OTG_GOUTNAKEFF_FLAG : at32f435_437_usb.h
  • USB_OTG_GOUTNAKEFF_INT : at32f435_437_usb.h
  • USB_OTG_GRXSTSP_BCNT : at32f435_437_usb.h
  • USB_OTG_GRXSTSP_CHNUM : at32f435_437_usb.h
  • USB_OTG_GRXSTSP_DPID : at32f435_437_usb.h
  • USB_OTG_GRXSTSP_EPTNUM : at32f435_437_usb.h
  • USB_OTG_GRXSTSP_PKTSTS : at32f435_437_usb.h
  • USB_OTG_HC_ACK_FLAG : at32f435_437_usb.h
  • USB_OTG_HC_ACKM_INT : at32f435_437_usb.h
  • USB_OTG_HC_BBLERR_FLAG : at32f435_437_usb.h
  • USB_OTG_HC_BBLERRM_INT : at32f435_437_usb.h
  • USB_OTG_HC_CHHLTD_FLAG : at32f435_437_usb.h
  • USB_OTG_HC_CHHLTDM_INT : at32f435_437_usb.h
  • USB_OTG_HC_DTGLERR_FLAG : at32f435_437_usb.h
  • USB_OTG_HC_DTGLERRM_INT : at32f435_437_usb.h
  • USB_OTG_HC_FRMOVRRUN_FLAG : at32f435_437_usb.h
  • USB_OTG_HC_FRMOVRRUN_INT : at32f435_437_usb.h
  • USB_OTG_HC_NAK_FLAG : at32f435_437_usb.h
  • USB_OTG_HC_NAKM_INT : at32f435_437_usb.h
  • USB_OTG_HC_NYET_FLAG : at32f435_437_usb.h
  • USB_OTG_HC_NYETM_INT : at32f435_437_usb.h
  • USB_OTG_HC_STALL_FLAG : at32f435_437_usb.h
  • USB_OTG_HC_STALLM_INT : at32f435_437_usb.h
  • USB_OTG_HC_XACTERR_FLAG : at32f435_437_usb.h
  • USB_OTG_HC_XACTERRM_INT : at32f435_437_usb.h
  • USB_OTG_HC_XFERC_FLAG : at32f435_437_usb.h
  • USB_OTG_HC_XFERCM_INT : at32f435_437_usb.h
  • USB_OTG_HCCHAR_CHDIS : at32f435_437_usb.h
  • USB_OTG_HCCHAR_CHENA : at32f435_437_usb.h
  • USB_OTG_HCCHAR_DEVADDR : at32f435_437_usb.h
  • USB_OTG_HCCHAR_EPTDIR : at32f435_437_usb.h
  • USB_OTG_HCCHAR_EPTNUM : at32f435_437_usb.h
  • USB_OTG_HCCHAR_EPTYPE : at32f435_437_usb.h
  • USB_OTG_HCCHAR_LSPDDEV : at32f435_437_usb.h
  • USB_OTG_HCCHAR_MC : at32f435_437_usb.h
  • USB_OTG_HCCHAR_MPS : at32f435_437_usb.h
  • USB_OTG_HCCHAR_ODDFRM : at32f435_437_usb.h
  • USB_OTG_HCH_FLAG : at32f435_437_usb.h
  • USB_OTG_HCH_INT : at32f435_437_usb.h
  • USB_OTG_HCTSIZ_PID : at32f435_437_usb.h
  • USB_OTG_HCTSIZ_PKTCNT : at32f435_437_usb.h
  • USB_OTG_HCTSIZ_XFERSIZE : at32f435_437_usb.h
  • USB_OTG_HPRT_PRTCONDET : at32f435_437_usb.h
  • USB_OTG_HPRT_PRTCONSTS : at32f435_437_usb.h
  • USB_OTG_HPRT_PRTENA : at32f435_437_usb.h
  • USB_OTG_HPRT_PRTENCHNG : at32f435_437_usb.h
  • USB_OTG_HPRT_PRTLNSTS : at32f435_437_usb.h
  • USB_OTG_HPRT_PRTOVRCACT : at32f435_437_usb.h
  • USB_OTG_HPRT_PRTOVRCCHNG : at32f435_437_usb.h
  • USB_OTG_HPRT_PRTPWR : at32f435_437_usb.h
  • USB_OTG_HPRT_PRTRES : at32f435_437_usb.h
  • USB_OTG_HPRT_PRTRST : at32f435_437_usb.h
  • USB_OTG_HPRT_PRTSPD : at32f435_437_usb.h
  • USB_OTG_HPRT_PRTSUSP : at32f435_437_usb.h
  • USB_OTG_IEPT_FLAG : at32f435_437_usb.h
  • USB_OTG_IEPT_INT : at32f435_437_usb.h
  • USB_OTG_INCOMISOIN_FLAG : at32f435_437_usb.h
  • USB_OTG_INCOMISOIN_INT : at32f435_437_usb.h
  • USB_OTG_INCOMPIP_INCOMPISOOUT_FLAG : at32f435_437_usb.h
  • USB_OTG_INCOMPIP_INCOMPISOOUT_INT : at32f435_437_usb.h
  • USB_OTG_ISOOUTDROP_FLAG : at32f435_437_usb.h
  • USB_OTG_ISOOUTDROP_INT : at32f435_437_usb.h
  • USB_OTG_MODEMIS_FLAG : at32f435_437_usb.h
  • USB_OTG_MODEMIS_INT : at32f435_437_usb.h
  • USB_OTG_NPTXFEMP_FLAG : at32f435_437_usb.h
  • USB_OTG_NPTXFEMP_INT : at32f435_437_usb.h
  • USB_OTG_OEPT_FLAG : at32f435_437_usb.h
  • USB_OTG_OEPT_INT : at32f435_437_usb.h
  • USB_OTG_OTGINT_FLAG : at32f435_437_usb.h
  • USB_OTG_OTGINT_INT : at32f435_437_usb.h
  • USB_OTG_PRT_FLAG : at32f435_437_usb.h
  • USB_OTG_PRT_INT : at32f435_437_usb.h
  • USB_OTG_PTXFEMP_FLAG : at32f435_437_usb.h
  • USB_OTG_PTXFEMP_INT : at32f435_437_usb.h
  • USB_OTG_RXFLVL_FLAG : at32f435_437_usb.h
  • USB_OTG_RXFLVL_INT : at32f435_437_usb.h
  • USB_OTG_SOF_FLAG : at32f435_437_usb.h
  • USB_OTG_SOF_INT : at32f435_437_usb.h
  • USB_OTG_USBRST_FLAG : at32f435_437_usb.h
  • USB_OTG_USBRST_INT : at32f435_437_usb.h
  • USB_OTG_USBSUSP_FLAG : at32f435_437_usb.h
  • USB_OTG_USBSUSP_INT : at32f435_437_usb.h
  • USB_OTG_WKUP_FLAG : at32f435_437_usb.h
  • USB_OTG_WKUP_INT : at32f435_437_usb.h
  • USB_OUT_STS_COMP : at32f435_437_usb.h
  • USB_OUT_STS_DATA : at32f435_437_usb.h
  • USB_OUT_STS_NAK : at32f435_437_usb.h
  • USB_OUTEPT : at32f435_437_usb.h
  • usb_port_power_on() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_printer_get_rxdata() : printer_class.h
  • usb_printer_send_data() : printer_class.c, printer_class.h
  • USB_PRODUCT_STRING : usb_std.h
  • USB_PRTSPD_FULL_SPEED : at32f435_437_usb.h
  • USB_PRTSPD_HIGH_SPEED : at32f435_437_usb.h
  • USB_PRTSPD_LOW_SPEED : at32f435_437_usb.h
  • usb_re_connect() : project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c
  • usb_read_packet() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_reg_type : at32f435_437_usb.h
  • usb_remote_wkup_clear() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_remote_wkup_set() : at32f435_437_usb.h, at32f435_437_usb.c
  • USB_REQ_DIR_DTH : usb_std.h
  • USB_REQ_DIR_HTD : usb_std.h
  • USB_REQ_RECIPIENT_DEVICE : usb_std.h
  • USB_REQ_RECIPIENT_ENDPOINT : usb_std.h
  • USB_REQ_RECIPIENT_INTERFACE : usb_std.h
  • USB_REQ_RECIPIENT_MASK : usb_std.h
  • USB_REQ_RECIPIENT_OTHER : usb_std.h
  • USB_REQ_TYPE_CLASS : usb_std.h
  • USB_REQ_TYPE_RESERVED : usb_std.h
  • USB_REQ_TYPE_STANDARD : usb_std.h
  • USB_REQ_TYPE_VENDOR : usb_std.h
  • usb_reset() : project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c
  • USB_SERIAL_STRING : usb_std.h
  • usb_set_address() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_set_rx_fifo() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_set_tx_fifo() : at32f435_437_usb.h, at32f435_437_usb.c
  • USB_SETUP_STS_COMP : at32f435_437_usb.h
  • USB_SETUP_STS_DATA : at32f435_437_usb.h
  • usb_speed_type : usb_core.h
  • USB_STD_REQ_CLEAR_FEATURE : usb_std.h
  • USB_STD_REQ_GET_CONFIGURATION : usb_std.h
  • USB_STD_REQ_GET_DESCRIPTOR : usb_std.h
  • USB_STD_REQ_GET_INTERFACE : usb_std.h
  • USB_STD_REQ_GET_STATUS : usb_std.h
  • USB_STD_REQ_SET_ADDRESS : usb_std.h
  • USB_STD_REQ_SET_CONFIGURATION : usb_std.h
  • USB_STD_REQ_SET_DESCRIPTOR : usb_std.h
  • USB_STD_REQ_SET_FEATURE : usb_std.h
  • USB_STD_REQ_SET_INTERFACE : usb_std.h
  • USB_STD_REQ_SYNCH_FRAME : usb_std.h
  • usb_stop_phy_clk() : at32f435_437_usb.h, at32f435_437_usb.c
  • usb_sts_type : usb_std.h
  • usb_suspend_status_get() : at32f435_437_usb.h, at32f435_437_usb.c
  • USB_TRDTIM_16 : at32f435_437_usb.h
  • USB_TRDTIM_8 : at32f435_437_usb.h
  • usb_usart_config() : cdc_class.c, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c
  • USB_VBUS_IGNORE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • usb_vcp_cmd_process() : cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c
  • usb_vcp_get_rxdata() : cdc_class.c, cdc_class.h, cdc_msc_class.h
  • usb_vcp_send_data() : cdc_class.c, cdc_class.h, cdc_msc_class.h
  • usb_vcpkybrd_class_send_report() : cdc_keyboard_class.c, cdc_keyboard_class.h
  • usb_vcpkybrd_keyboard_send_char() : cdc_keyboard_class.c, cdc_keyboard_class.h
  • usb_vcpkybrd_vcp_get_rxdata() : cdc_keyboard_class.c, cdc_keyboard_class.h
  • usb_vcpkybrd_vcp_send_data() : cdc_keyboard_class.c, cdc_keyboard_class.h
  • USB_VIRTUAL_COMPORT : project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h
  • USB_WAIT : usb_std.h
  • usb_write_empty_txfifo() : usbd_int.h, usbd_int.c
  • usb_write_packet() : at32f435_437_usb.h, at32f435_437_usb.c
  • USBD2_EP0_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD2_EP1_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD2_EP2_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD2_EP3_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD2_EP4_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD2_EP5_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD2_EP6_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD2_EP7_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD2_RX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD_AUDIO_CONFIG_DESC_SIZE : audio_desc.h
  • USBD_AUDIO_DESC_CONFIGURATION_STRING : audio_desc.h
  • USBD_AUDIO_DESC_INTERFACE_STRING : audio_desc.h
  • USBD_AUDIO_DESC_MANUFACTURER_STRING : audio_desc.h
  • USBD_AUDIO_DESC_PRODUCT_STRING : audio_desc.h
  • USBD_AUDIO_FEEDBACK_EPT : audio_class.h
  • USBD_AUDIO_MIC_IN_EPT : audio_class.h
  • USBD_AUDIO_PRODUCT_ID : audio_desc.h
  • USBD_AUDIO_SIZ_STRING_LANGID : audio_desc.h
  • USBD_AUDIO_SIZ_STRING_SERIAL : audio_desc.h
  • USBD_AUDIO_SPK_OUT_EPT : audio_class.h
  • USBD_AUDIO_VENDOR_ID : audio_desc.h
  • USBD_AUHID_AUDIO_FEEDBACK_EPT : audio_hid_class.h
  • USBD_AUHID_AUDIO_MIC_IN_EPT : audio_hid_class.h
  • USBD_AUHID_AUDIO_SPK_OUT_EPT : audio_hid_class.h
  • USBD_AUHID_CONFIG_DESC_SIZE : audio_hid_desc.h
  • USBD_AUHID_DESC_CONFIGURATION_STRING : audio_hid_desc.h
  • USBD_AUHID_DESC_INTERFACE_STRING : audio_hid_desc.h
  • USBD_AUHID_DESC_MANUFACTURER_STRING : audio_hid_desc.h
  • USBD_AUHID_DESC_PRODUCT_STRING : audio_hid_desc.h
  • USBD_AUHID_HID_DESC_SIZE : audio_hid_desc.h
  • USBD_AUHID_HID_IN_EPT : audio_hid_class.h
  • USBD_AUHID_HID_OUT_EPT : audio_hid_class.h
  • USBD_AUHID_HID_SIZ_REPORT_DESC : audio_hid_desc.h
  • USBD_AUHID_IN_MAXPACKET_SIZE : audio_hid_class.h
  • USBD_AUHID_OUT_MAXPACKET_SIZE : audio_hid_class.h
  • USBD_AUHID_PRODUCT_ID : audio_hid_desc.h
  • USBD_AUHID_SIZ_STRING_LANGID : audio_hid_desc.h
  • USBD_AUHID_SIZ_STRING_SERIAL : audio_hid_desc.h
  • USBD_AUHID_VENDOR_ID : audio_hid_desc.h
  • USBD_CDC_BULK_IN_EPT : cdc_class.h, cdc_msc_class.h
  • USBD_CDC_BULK_OUT_EPT : cdc_class.h, cdc_msc_class.h
  • USBD_CDC_CMD_MAXPACKET_SIZE : cdc_class.h, cdc_msc_class.h
  • USBD_CDC_CONFIG_DESC_SIZE : cdc_desc.h
  • USBD_CDC_CS_ENDPOINT : usb_std.h
  • USBD_CDC_CS_INTERFACE : usb_std.h
  • USBD_CDC_DESC_CONFIGURATION_STRING : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_DESC_INTERFACE_STRING : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_DESC_MANUFACTURER_STRING : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_DESC_PRODUCT_STRING : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_IN_MAXPACKET_SIZE : cdc_class.h
  • USBD_CDC_INT_EPT : cdc_class.h, cdc_msc_class.h
  • USBD_CDC_MSC_CONFIG_DESC_SIZE : cdc_msc_desc.h
  • USBD_CDC_MSC_IN_MAXPACKET_SIZE : cdc_msc_class.h
  • USBD_CDC_MSC_OUT_MAXPACKET_SIZE : cdc_msc_class.h
  • USBD_CDC_MSC_PRODUCT_ID : cdc_msc_desc.h
  • USBD_CDC_MSC_VENDOR_ID : cdc_msc_desc.h
  • USBD_CDC_OUT_MAXPACKET_SIZE : cdc_class.h
  • USBD_CDC_PRODUCT_ID : cdc_desc.h
  • USBD_CDC_SIZ_STRING_LANGID : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_SIZ_STRING_SERIAL : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_SUBTYPE_ACM : usb_std.h
  • USBD_CDC_SUBTYPE_CMF : usb_std.h
  • USBD_CDC_SUBTYPE_HEADER : usb_std.h
  • USBD_CDC_SUBTYPE_UFD : usb_std.h
  • USBD_CDC_VENDOR_ID : cdc_desc.h
  • usbd_clear_feature() : usbd_sdr.c
  • usbd_clear_stall() : usbd_core.c
  • usbd_conn_state : usb_std.h
  • usbd_connect() : usbd_core.c
  • usbd_connect_state_get() : usbd_core.c
  • usbd_core_in_handler() : usbd_core.c
  • usbd_core_init() : usbd_core.c
  • usbd_core_out_handler() : usbd_core.c
  • usbd_core_setup_handler() : usbd_core.c
  • usbd_ctrl_recv() : usbd_core.c
  • usbd_ctrl_recv_status() : usbd_core.c
  • usbd_ctrl_send() : usbd_core.c
  • usbd_ctrl_send_status() : usbd_core.c
  • usbd_ctrl_unsupport() : usbd_core.c
  • USBD_CUSHID_CONFIG_DESC_SIZE : custom_hid_desc.h
  • USBD_CUSHID_DESC_CONFIGURATION_STRING : custom_hid_desc.h
  • USBD_CUSHID_DESC_INTERFACE_STRING : custom_hid_desc.h
  • USBD_CUSHID_DESC_MANUFACTURER_STRING : custom_hid_desc.h
  • USBD_CUSHID_DESC_PRODUCT_STRING : custom_hid_desc.h
  • USBD_CUSHID_PRODUCT_ID : custom_hid_desc.h
  • USBD_CUSHID_SIZ_REPORT_DESC : custom_hid_desc.h
  • USBD_CUSHID_SIZ_STRING_LANGID : custom_hid_desc.h
  • USBD_CUSHID_SIZ_STRING_SERIAL : custom_hid_desc.h
  • USBD_CUSHID_VENDOR_ID : custom_hid_desc.h
  • USBD_CUSTOM_HID_IN_EPT : custom_hid_class.h
  • USBD_CUSTOM_HID_OUT_EPT : custom_hid_class.h
  • USBD_CUSTOM_IN_MAXPACKET_SIZE : custom_hid_class.h
  • USBD_CUSTOM_OUT_MAXPACKET_SIZE : custom_hid_class.h
  • usbd_device_request() : usbd_sdr.h, usbd_sdr.c
  • usbd_discon_handler() : usbd_int.h, usbd_int.c
  • usbd_disconnect() : usbd_core.c
  • usbd_endpoint_request() : usbd_sdr.h, usbd_sdr.c
  • usbd_enter_suspend() : usbd_core.c
  • usbd_enumdone_handler() : usbd_int.h, usbd_int.c
  • USBD_EP0_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD_EP1_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD_EP2_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD_EP3_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD_EP4_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD_EP5_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD_EP6_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USBD_EP7_TX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • usbd_ept_close() : usbd_core.c
  • usbd_ept_handler() : usbd_int.h
  • usbd_ept_open() : usbd_core.c
  • usbd_ept_recv() : usbd_core.c
  • usbd_ept_send() : usbd_core.c
  • usbd_fifo_alloc() : usbd_core.c
  • usbd_flush_tx_fifo() : usbd_core.c
  • usbd_get_configuration() : usbd_sdr.c
  • usbd_get_descriptor() : usbd_sdr.c
  • usbd_get_recv_len() : usbd_core.c
  • usbd_get_status() : usbd_sdr.c
  • usbd_hid_iap_in_complete() : hid_iap_class.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • usbd_hid_iap_process() : hid_iap_class.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • USBD_HIDIAP_CONFIG_DESC_SIZE : hid_iap_desc.h
  • USBD_HIDIAP_DESC_CONFIGURATION_STRING : hid_iap_desc.h
  • USBD_HIDIAP_DESC_INTERFACE_STRING : hid_iap_desc.h
  • USBD_HIDIAP_DESC_MANUFACTURER_STRING : hid_iap_desc.h
  • USBD_HIDIAP_DESC_PRODUCT_STRING : hid_iap_desc.h
  • USBD_HIDIAP_IN_EPT : hid_iap_class.h
  • USBD_HIDIAP_IN_MAXPACKET_SIZE : hid_iap_class.h
  • USBD_HIDIAP_OUT_EPT : hid_iap_class.h
  • USBD_HIDIAP_OUT_MAXPACKET_SIZE : hid_iap_class.h
  • USBD_HIDIAP_PRODUCT_ID : hid_iap_desc.h
  • USBD_HIDIAP_SIZ_REPORT_DESC : hid_iap_desc.h
  • USBD_HIDIAP_SIZ_STRING_LANGID : hid_iap_desc.h
  • USBD_HIDIAP_SIZ_STRING_SERIAL : hid_iap_desc.h
  • USBD_HIDIAP_VENDOR_ID : hid_iap_desc.h
  • USBD_IN_MAXPACKET_SIZE : msc_class.h
  • usbd_incomisioin_handler() : usbd_int.h, usbd_int.c
  • usbd_incomisoout_handler() : usbd_int.h, usbd_int.c
  • usbd_inept_handler() : usbd_int.h, usbd_int.c
  • usbd_int_to_unicode() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • usbd_interface_request() : usbd_sdr.h, usbd_sdr.c
  • usbd_irq_handler() : usbd_int.h, usbd_int.c
  • USBD_KEYBOARD_CONFIG_DESC_SIZE : keyboard_desc.h
  • USBD_KEYBOARD_DESC_CONFIGURATION_STRING : keyboard_desc.h
  • USBD_KEYBOARD_DESC_INTERFACE_STRING : keyboard_desc.h
  • USBD_KEYBOARD_DESC_MANUFACTURER_STRING : keyboard_desc.h
  • USBD_KEYBOARD_DESC_PRODUCT_STRING : keyboard_desc.h
  • USBD_KEYBOARD_IN_EPT : keyboard_class.h
  • USBD_KEYBOARD_IN_MAXPACKET_SIZE : keyboard_class.h
  • USBD_KEYBOARD_OUT_MAXPACKET_SIZE : keyboard_class.h
  • USBD_KEYBOARD_PRODUCT_ID : keyboard_desc.h
  • USBD_KEYBOARD_SIZ_REPORT_DESC : keyboard_desc.h
  • USBD_KEYBOARD_SIZ_STRING_LANGID : keyboard_desc.h
  • USBD_KEYBOARD_SIZ_STRING_SERIAL : keyboard_desc.h
  • USBD_KEYBOARD_VENDOR_ID : keyboard_desc.h
  • USBD_MOUSE_CONFIG_DESC_SIZE : mouse_desc.h
  • USBD_MOUSE_DESC_CONFIGURATION_STRING : mouse_desc.h
  • USBD_MOUSE_DESC_INTERFACE_STRING : mouse_desc.h
  • USBD_MOUSE_DESC_MANUFACTURER_STRING : mouse_desc.h
  • USBD_MOUSE_DESC_PRODUCT_STRING : mouse_desc.h
  • USBD_MOUSE_IN_EPT : mouse_class.h
  • USBD_MOUSE_IN_MAXPACKET_SIZE : mouse_class.h
  • USBD_MOUSE_PRODUCT_ID : mouse_desc.h
  • USBD_MOUSE_SIZ_REPORT_DESC : mouse_desc.h
  • USBD_MOUSE_SIZ_STRING_LANGID : mouse_desc.h
  • USBD_MOUSE_SIZ_STRING_SERIAL : mouse_desc.h
  • USBD_MOUSE_VENDOR_ID : mouse_desc.h
  • USBD_MSC_BULK_IN_EPT : cdc_msc_class.h, msc_class.h
  • USBD_MSC_BULK_OUT_EPT : cdc_msc_class.h, msc_class.h
  • USBD_MSC_CONFIG_DESC_SIZE : msc_desc.h
  • USBD_MSC_DESC_CONFIGURATION_STRING : msc_desc.h
  • USBD_MSC_DESC_INTERFACE_STRING : msc_desc.h
  • USBD_MSC_DESC_MANUFACTURER_STRING : msc_desc.h
  • USBD_MSC_DESC_PRODUCT_STRING : msc_desc.h
  • USBD_MSC_PRODUCT_ID : msc_desc.h
  • USBD_MSC_SIZ_STRING_LANGID : msc_desc.h
  • USBD_MSC_SIZ_STRING_SERIAL : msc_desc.h
  • USBD_MSC_VENDOR_ID : msc_desc.h
  • USBD_OUT_MAXPACKET_SIZE : msc_class.h
  • usbd_outept_handler() : usbd_int.h, usbd_int.c
  • USBD_PRINTER_BULK_IN_EPT : printer_class.h
  • USBD_PRINTER_BULK_OUT_EPT : printer_class.h
  • USBD_PRINTER_CONFIG_DESC_SIZE : printer_desc.h
  • USBD_PRINTER_DESC_CONFIGURATION_STRING : printer_desc.h
  • USBD_PRINTER_DESC_INTERFACE_STRING : printer_desc.h
  • USBD_PRINTER_DESC_MANUFACTURER_STRING : printer_desc.h
  • USBD_PRINTER_DESC_PRODUCT_STRING : printer_desc.h
  • USBD_PRINTER_IN_MAXPACKET_SIZE : printer_class.h
  • USBD_PRINTER_OUT_MAXPACKET_SIZE : printer_class.h
  • USBD_PRINTER_PRODUCT_ID : printer_desc.h
  • USBD_PRINTER_SIZ_STRING_LANGID : printer_desc.h
  • USBD_PRINTER_SIZ_STRING_SERIAL : printer_desc.h
  • USBD_PRINTER_VENDOR_ID : printer_desc.h
  • usbd_remote_wakeup() : usbd_core.c
  • usbd_reset_handler() : usbd_int.h, usbd_int.c
  • USBD_RX_SIZE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • usbd_rxflvl_handler() : usbd_int.h, usbd_int.c
  • usbd_set_address() : usbd_sdr.c
  • usbd_set_configuration() : usbd_sdr.c
  • usbd_set_device_addr() : usbd_core.c
  • usbd_set_feature() : usbd_sdr.c
  • usbd_set_stall() : usbd_core.c
  • usbd_setup_request_parse() : usbd_sdr.h, usbd_sdr.c
  • usbd_sof_handler() : usbd_int.h, usbd_int.c
  • usbd_suspend_handler() : usbd_int.h, usbd_int.c
  • usbd_unicode_convert() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • USBD_VCPKYBRD_CDC_BULK_IN_EPT : cdc_keyboard_class.h
  • USBD_VCPKYBRD_CDC_BULK_OUT_EPT : cdc_keyboard_class.h
  • USBD_VCPKYBRD_CDC_INT_EPT : cdc_keyboard_class.h
  • USBD_VCPKYBRD_CMD_MAXPACKET_SIZE : cdc_keyboard_class.h
  • USBD_VCPKYBRD_CONFIG_DESC_SIZE : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_DESC_CONFIGURATION_STRING : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_DESC_INTERFACE_STRING : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_DESC_MANUFACTURER_STRING : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_DESC_PRODUCT_STRING : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_HID_IN_EPT : cdc_keyboard_class.h
  • USBD_VCPKYBRD_HID_SIZ_REPORT_DESC : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_IN_MAXPACKET_SIZE : cdc_keyboard_class.h
  • USBD_VCPKYBRD_OUT_MAXPACKET_SIZE : cdc_keyboard_class.h
  • USBD_VCPKYBRD_PRODUCT_ID : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_SIZ_STRING_LANGID : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_SIZ_STRING_SERIAL : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_VENDOR_ID : cdc_keyboard_desc.h
  • usbd_wakeup_handler() : usbd_int.h, usbd_int.c
  • USBH2_NP_TX_FIFO_SIZE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • USBH2_P_TX_FIFO_SIZE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • USBH2_RX_FIFO_SIZE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • USBH_5V_POWER_SWITCH : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • usbh_active_vbus() : usbh_core.c
  • usbh_alloc_address() : usbh_core.c
  • usbh_alloc_channel() : usbh_core.c
  • usbh_attached() : usbh_core.c
  • usbh_bot_cbw() : usbh_msc_bot_scsi.c
  • usbh_bulk_recv() : usbh_core.c
  • usbh_bulk_send() : usbh_core.c
  • usbh_cfg_default_init() : usbh_core.c
  • usbh_ch_disable() : usbh_core.c
  • usbh_check_csw() : usbh_msc_bot_scsi.c
  • usbh_class() : usbh_core.c
  • usbh_class_request() : usbh_core.c
  • usbh_clear_dev_feature() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_clear_endpoint_feature() : usbh_hid_class.c
  • usbh_clear_ept_feature() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_cmd_capacity10() : usbh_msc_bot_scsi.c
  • usbh_cmd_inquiry() : usbh_msc_bot_scsi.c
  • usbh_cmd_read() : usbh_msc_bot_scsi.c
  • usbh_cmd_requset_sense() : usbh_msc_bot_scsi.c
  • usbh_cmd_test_unit_ready() : usbh_msc_bot_scsi.c
  • usbh_cmd_write() : usbh_msc_bot_scsi.c
  • usbh_core_init() : usbh_core.c
  • usbh_ctrl_complete_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_data_in_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_data_in_wait_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_data_out_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_data_out_wait_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_error_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_recv_data() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_request() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_result_check() : usbh_core.c
  • usbh_ctrl_send_data() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_send_setup() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_setup_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_setup_wait_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_stall_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_status_in_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_status_in_wait_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_status_out_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_status_out_wait_handler() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_ctrl_transfer_loop() : usbh_ctrl.h, usbh_ctrl.c
  • USBH_DEBUG : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • USBH_DEBUG_ENABLE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • usbh_disconnect() : usbh_core.c
  • usbh_disconnect_handler() : usbh_int.h, usbh_int.c
  • usbh_enter_suspend() : usbh_core.c
  • usbh_enum_handler() : usbh_core.c
  • usbh_enumeration() : usbh_core.c
  • usbh_find_interface() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_free_channel() : usbh_core.c
  • usbh_fsls_clksel() : at32f435_437_usb.h, at32f435_437_usb.c
  • usbh_get_configure_descriptor() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_get_descriptor() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_get_device_descriptor() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_get_frame() : at32f435_437_usb.h, at32f435_437_usb.c
  • usbh_get_free_channel() : usbh_core.c
  • usbh_get_next_header() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_get_sting_descriptor() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_get_urb_status() : usbh_core.c
  • usbh_hc_open() : usbh_core.c
  • usbh_hch_handler() : usbh_int.h, usbh_int.c
  • usbh_hch_in_handler() : usbh_int.h, usbh_int.c
  • usbh_hch_out_handler() : usbh_int.h, usbh_int.c
  • usbh_hid : usbh_hid_class.c
  • usbh_hid_get_desc() : usbh_hid_class.c
  • usbh_hid_get_report() : usbh_hid_class.c
  • usbh_hid_keyboard_decode() : usbh_hid_keyboard.c, usbh_hid_keyboard.h
  • usbh_hid_mouse_button_press() : usbh_hid_mouse.c
  • usbh_hid_mouse_button_release() : usbh_hid_mouse.c
  • usbh_hid_mouse_decode() : usbh_hid_mouse.c, usbh_hid_mouse.h
  • usbh_hid_mouse_position() : usbh_hid_mouse.c
  • usbh_hid_mouse_process() : usbh_hid_mouse.c
  • usbh_hid_set_idle() : usbh_hid_class.c
  • usbh_hid_set_protocol() : usbh_hid_class.c
  • usbh_in_out_request() : usbh_core.c
  • usbh_interrupt_recv() : usbh_core.c
  • usbh_interrupt_send() : usbh_core.c
  • usbh_irq_handler() : usbh_int.h, usbh_int.c
  • usbh_isoc_recv() : usbh_core.c
  • usbh_isoc_send() : usbh_core.c
  • usbh_loop_handler() : usbh_core.c
  • usbh_msc : usbh_msc_class.c, usbh_msc_class.h
  • usbh_msc_bot_scsi_capacity() : usbh_msc_bot_scsi.c, usbh_msc_bot_scsi.h
  • usbh_msc_bot_scsi_get_inquiry() : usbh_msc_bot_scsi.c, usbh_msc_bot_scsi.h
  • usbh_msc_bot_scsi_read() : usbh_msc_bot_scsi.c, usbh_msc_bot_scsi.h
  • usbh_msc_bot_scsi_request_sense() : usbh_msc_bot_scsi.c, usbh_msc_bot_scsi.h
  • usbh_msc_bot_scsi_test_unit_ready() : usbh_msc_bot_scsi.c, usbh_msc_bot_scsi.h
  • usbh_msc_bot_scsi_write() : usbh_msc_bot_scsi.c, usbh_msc_bot_scsi.h
  • USBH_MSC_BUSY : usbh_msc_bot_scsi.h
  • usbh_msc_clear_feature() : usbh_msc_class.c
  • usbh_msc_ctrl_state_type : usbh_msc_class.h
  • USBH_MSC_ERROR : usbh_msc_bot_scsi.h
  • usbh_msc_get_max_lun() : usbh_msc_class.c
  • USBH_MSC_IDLE : usbh_msc_bot_scsi.h
  • USBH_MSC_INIT : usbh_msc_bot_scsi.h
  • USBH_MSC_INQUIRY : usbh_msc_bot_scsi.h
  • usbh_msc_is_ready() : usbh_msc_class.c, usbh_msc_class.h
  • usbh_msc_read() : usbh_msc_class.c, usbh_msc_class.h
  • USBH_MSC_READ10 : usbh_msc_bot_scsi.h
  • USBH_MSC_READ_CAPACITY10 : usbh_msc_bot_scsi.h
  • USBH_MSC_REQUEST_SENSE : usbh_msc_bot_scsi.h
  • usbh_msc_rw_handle() : usbh_msc_class.c, usbh_msc_class.h
  • USBH_MSC_STATE_COMPLETE : usbh_msc_class.h
  • USBH_MSC_STATE_ERROR : usbh_msc_class.h
  • USBH_MSC_STATE_GET_LUN : usbh_msc_class.h
  • USBH_MSC_STATE_IDLE : usbh_msc_class.h
  • USBH_MSC_TEST_UNIT_READY : usbh_msc_bot_scsi.h
  • USBH_MSC_WRITE : usbh_msc_bot_scsi.h
  • usbh_msc_write() : usbh_msc_class.c, usbh_msc_class.h
  • USBH_NP_TX_FIFO_SIZE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • USBH_P_TX_FIFO_SIZE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • usbh_parse_configure_desc() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_parse_dev_desc() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_parse_endpoint_desc() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_parse_interface_desc() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_parse_string_desc() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_port_handler() : usbh_int.h, usbh_int.c
  • usbh_reset_port() : usbh_core.c
  • usbh_resume() : usbh_core.c
  • USBH_RX_FIFO_SIZE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • usbh_rx_qlvl_handler() : usbh_int.h, usbh_int.c
  • usbh_set_address() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_set_configuration() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_set_feature() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_set_interface() : usbh_ctrl.h, usbh_ctrl.c
  • usbh_set_toggle() : usbh_core.c
  • usbh_sof_handler() : usbh_int.h, usbh_int.c
  • USBH_SUPPORT_MAX_LUN : usbh_msc_class.h
  • usbh_suspend() : usbh_core.c
  • usbh_user_active_vbus() : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_user_application() : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_user_attached() : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_user_disconnect() : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_user_enumeration_done() : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_user_handle : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.h, at_start_f435/examples/usb_host/hid_demo/inc/usbh_user.h, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/inc/usbh_user.h, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/inc/usbh_user.h, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.h, at_start_f437/examples/usb_host/hid_demo/inc/usbh_user.h, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/inc/usbh_user.h, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/inc/usbh_user.h, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_user_init() : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_user_mfc_string() : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_user_not_support() : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_user_product_string() : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_user_reset() : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_user_serial_string() : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_user_speed() : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usbh_wakeup() : usbh_core.c
  • usbh_wakeup_handler() : usbh_int.h, usbh_int.c
  • USD : at32f435_437_flash.h
  • USD_BASE : at32f435_437.h
  • USD_DEPSLP_NO_RST : at32f435_437_flash.h
  • USD_DEPSLP_RST : at32f435_437_flash.h
  • USD_STDBY_NO_RST : at32f435_437_flash.h
  • USD_STDBY_RST : at32f435_437_flash.h
  • USD_WDT_ATO_DISABLE : at32f435_437_flash.h
  • USD_WDT_ATO_ENABLE : at32f435_437_flash.h
  • USD_WDT_DEPSLP_CONTINUE : at32f435_437_flash.h
  • USD_WDT_DEPSLP_STOP : at32f435_437_flash.h
  • USD_WDT_STDBY_CONTINUE : at32f435_437_flash.h
  • USD_WDT_STDBY_STOP : at32f435_437_flash.h
  • USE_ARGC_ARGV : flash_config.h
  • USE_IAP_HTTP : at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h
  • USE_IAP_TFTP : at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h
  • USE_OTG_DEVICE_MODE : project/at_start_f435/examples/acc/calibration/inc/usb_conf.h, project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, project/at_start_f437/examples/acc/calibration/inc/usb_conf.h, project/at_start_f437/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f437/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/usb_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USE_OTG_HOST_MODE : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/usb_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/usb_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/usb_conf.h
  • USE_SLIB_FUNCTION : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • USE_STATIC_INIT : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • USER_BUTTON : at32f435_437_board.h
  • USER_BUTTON_CRM_CLK : at32f435_437_board.h
  • USER_BUTTON_PIN : at32f435_437_board.h
  • USER_BUTTON_PORT : at32f435_437_board.h
  • USER_FLASH_END_ADDRESS : utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/flash.h
  • USERID : httpserver.h
  • USR_APP : at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • USR_FINISH : at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • USR_IDLE : at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usr_state : at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- v -

  • var : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • variables : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f437/examples/cortex_m4/bit_band/src/main.c
  • variables_addr : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f437/examples/cortex_m4/bit_band/src/main.c
  • variables_bit_val : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f437/examples/cortex_m4/bit_band/src/main.c
  • VARIABLES_GET_BIT : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f437/examples/cortex_m4/bit_band/src/main.c
  • VARIABLES_RESET_BIT : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f437/examples/cortex_m4/bit_band/src/main.c
  • VARIABLES_SET_BIT : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f437/examples/cortex_m4/bit_band/src/main.c
  • vcp_keyboard_struct : cdc_keyboard_class.c
  • VCPKYBRD_BCD_NUM : cdc_keyboard_desc.h
  • VCPKYBRD_CDC_DATA_INTERFACE : cdc_keyboard_desc.h
  • VCPKYBRD_CDC_INTERFACE : cdc_keyboard_desc.h
  • VCPKYBRD_HID_BINTERVAL_TIME : cdc_keyboard_desc.h
  • VCPKYBRD_KEYBOARD_INTERFACE : cdc_keyboard_desc.h
  • VCPMSC_CDC_DATA_INTERFACE : cdc_msc_desc.h
  • VCPMSC_CDC_INTERFACE : cdc_msc_desc.h
  • VCPMSC_MSC_INTERFACE : cdc_msc_desc.h
  • VECT_TAB_OFFSET : system_at32f435_437.c
  • Verify() : FlashOS.h
  • VERS : FlashOS.h
  • VLAN_TAG : at32f435_437_emac.h
  • vmor_flag_index : project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f435/examples/adc/voltage_monitoring/src/main.c, project/at_start_f437/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f437/examples/adc/voltage_monitoring/src/main.c
  • vp_desc : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • vPortSVCHandler : FreeRTOSConfig.h
  • vs16 : at32f435_437.h
  • vs32 : at32f435_437.h
  • vs8 : at32f435_437.h
  • vsc16 : at32f435_437.h
  • vsc32 : at32f435_437.h
  • vsc8 : at32f435_437.h
  • vu16 : at32f435_437.h
  • vu32 : at32f435_437.h
  • vu8 : at32f435_437.h
  • vuc16 : at32f435_437.h
  • vuc32 : at32f435_437.h
  • vuc8 : at32f435_437.h


AT32F435/437 Firmwary Library: Globals

- _ -

  • __argc : flash_loader.c
  • __argv : flash_loader.c
  • __argvbuf : flash_loader.c
  • _asciimap : cdc_keyboard_class.c, keyboard_class.c


AT32F435/437 Firmwary Library: Globals

- a -

  • acc_c2_value : project/at_start_f435/examples/acc/calibration/src/main.c, project/at_start_f437/examples/acc/calibration/src/main.c
  • adc1_ordinary_value : project/at_start_f435/examples/adc/current_vref_value_check/src/main.c, project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f435/examples/adc/vbat_monitor/src/main.c, project/at_start_f437/examples/adc/current_vref_value_check/src/main.c, project/at_start_f437/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f437/examples/adc/vbat_monitor/src/main.c
  • adc1_ordinary_valuetab : project/at_start_f435/examples/adc/conversion_abort/src/main.c, project/at_start_f435/examples/adc/edma_double_buffer/src/main.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f435/examples/adc/resolution_6bit/src/main.c, project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c, project/at_start_f435/examples/adc/voltage_monitoring/src/main.c, project/at_start_f437/examples/adc/conversion_abort/src/main.c, project/at_start_f437/examples/adc/edma_double_buffer/src/main.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f437/examples/adc/resolution_6bit/src/main.c, project/at_start_f437/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f437/examples/adc/use_polling_get_conversion_data/src/main.c, project/at_start_f437/examples/adc/voltage_monitoring/src/main.c
  • adc1_overflow_flag : project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/src/main.c, project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c, project/at_start_f435/examples/adc/current_vref_value_check/src/main.c, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/src/main.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/src/main.c, project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c, project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c, project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c, project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c, project/at_start_f435/examples/adc/vbat_monitor/src/main.c, project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f435/examples/adc/voltage_monitoring/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f437/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f437/examples/adc/conversion_abort/src/main.c, project/at_start_f437/examples/adc/current_vref_value_check/src/at32f435_437_int.c, project/at_start_f437/examples/adc/current_vref_value_check/src/main.c, project/at_start_f437/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f437/examples/adc/edma_double_buffer/src/main.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f437/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c, project/at_start_f437/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f437/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f437/examples/adc/resolution_6bit/src/main.c, project/at_start_f437/examples/adc/software_trigger_repeat/src/at32f435_437_int.c, project/at_start_f437/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f437/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c, project/at_start_f437/examples/adc/use_polling_get_conversion_data/src/main.c, project/at_start_f437/examples/adc/vbat_monitor/src/at32f435_437_int.c, project/at_start_f437/examples/adc/vbat_monitor/src/main.c, project/at_start_f437/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f437/examples/adc/voltage_monitoring/src/main.c
  • adc1_preempt_conversion_count : project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c
  • adc1_preempt_valuetab : project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c
  • adc2_overflow_flag : project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c
  • adc2_preempt_conversion_count : project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c
  • adc2_preempt_valuetab : project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c
  • adc3_overflow_flag : project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c
  • adc3_preempt_conversion_count : project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c
  • adc3_preempt_valuetab : project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c
  • adc_page_name : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • adccom_ordinary_valuetab : project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c
  • ALIGNED_TAIL : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, composite_cdc_msc/msc_bot_scsi.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc/msc_bot_scsi.c, msc_desc.c, printer_class.c, printer_desc.c, project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c, project/at_start_f437/examples/qspi/command_port_using_dma/src/main.c, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/main.c, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/main.c
  • arp_timer : project/at_start_f437/examples/emac/dns_client/src/netconf.c, project/at_start_f437/examples/emac/http_server/src/netconf.c, project/at_start_f437/examples/emac/iperf/src/netconf.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_server/src/netconf.c, project/at_start_f437/examples/emac/telnet/src/netconf.c, project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • asc2_1206 : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/font.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/font.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/font.h
  • asc2_1608 : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/font.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/font.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/font.h
  • asc2_2412 : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/font.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/font.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/font.h
  • asc2_3216 : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/font.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/font.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/font.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/font.h
  • atr_decode_status : project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • audio_class_handler : audio_class.c, audio_class.h
  • audio_codec : at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • audio_desc_handler : audio_desc.c, audio_desc.h
  • audio_hid_class_handler : audio_hid_class.c, audio_hid_class.h
  • audio_hid_desc_handler : audio_hid_desc.c, audio_hid_desc.h
  • audio_hid_struct : audio_hid_class.c
  • audio_struct : audio_class.c


AT32F435/437 Firmwary Library: Globals

- b -

  • bpr_addr_tab : project/at_start_f435/examples/ertc/bpr_domain/src/main.c, project/at_start_f435/examples/ertc/tamper/src/main.c, project/at_start_f437/examples/ertc/bpr_domain/src/main.c, project/at_start_f437/examples/ertc/tamper/src/main.c
  • buffer : project/at_start_f435/examples/cortex_m4/fpu/src/main.c, project/at_start_f437/examples/cortex_m4/fpu/src/main.c
  • buffer_cc1 : project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c
  • buffer_cc2 : project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c
  • buffer_read : project/at_start_f435/examples/flash/flash_write_read/src/main.c, project/at_start_f437/examples/flash/flash_write_read/src/main.c
  • buffer_rx : project/at_start_f435/examples/spi/w25q_flash/src/main.c, project/at_start_f437/examples/spi/w25q_flash/src/main.c
  • buffer_tx : project/at_start_f435/examples/spi/w25q_flash/src/main.c, project/at_start_f437/examples/spi/w25q_flash/src/main.c
  • buffer_write : project/at_start_f435/examples/flash/flash_write_read/src/main.c, project/at_start_f437/examples/flash/flash_write_read/src/main.c
  • button_press : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f437/examples/usb_device/two_otg_device_demo/src/main.c


AT32F435/437 Firmwary Library: Globals

- c -

  • calculate_status : project/at_start_f435/examples/crm/pll_parameter_calculate/src/main.c, project/at_start_f437/examples/crm/pll_parameter_calculate/src/main.c
  • capture : project/at_start_f435/examples/tmr/input_capture/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/input_capture/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c
  • capture_number : project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/lick_calibration/src/main.c, project/at_start_f437/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f437/examples/ertc/lick_calibration/src/main.c
  • capturenumber : project/at_start_f435/examples/tmr/input_capture/src/main.c, project/at_start_f437/examples/tmr/input_capture/src/main.c
  • card_inserted : project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c, project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/usart/smartcard/src/at32f435_437_int.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • card_protocol : project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • card_type : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c, at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • ccr1_val : project/at_start_f435/examples/irtmr/irtmr_output/src/main.c, project/at_start_f435/examples/tmr/oc_high/src/main.c, project/at_start_f435/examples/tmr/oc_low/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c, project/at_start_f437/examples/irtmr/irtmr_output/src/main.c, project/at_start_f437/examples/tmr/oc_high/src/main.c, project/at_start_f437/examples/tmr/oc_low/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f437/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f437/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f437/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f437/examples/tmr/tmr2_32bit/src/main.c
  • ccr2_val : project/at_start_f435/examples/irtmr/irtmr_output/src/main.c, project/at_start_f435/examples/tmr/oc_high/src/main.c, project/at_start_f435/examples/tmr/oc_low/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c, project/at_start_f437/examples/irtmr/irtmr_output/src/main.c, project/at_start_f437/examples/tmr/oc_high/src/main.c, project/at_start_f437/examples/tmr/oc_low/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f437/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f437/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f437/examples/tmr/tmr2_32bit/src/main.c
  • ccr3_val : project/at_start_f435/examples/tmr/oc_high/src/main.c, project/at_start_f435/examples/tmr/oc_low/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c, project/at_start_f437/examples/tmr/oc_high/src/main.c, project/at_start_f437/examples/tmr/oc_low/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f437/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f437/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f437/examples/tmr/tmr2_32bit/src/main.c
  • ccr4_val : project/at_start_f435/examples/tmr/oc_high/src/main.c, project/at_start_f435/examples/tmr/oc_low/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c, project/at_start_f437/examples/tmr/oc_high/src/main.c, project/at_start_f437/examples/tmr/oc_low/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f437/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f437/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f437/examples/tmr/tmr2_32bit/src/main.c
  • cdc_class_handler : cdc_class.c, cdc_class.h
  • cdc_desc_handler : cdc_desc.c, cdc_desc.h
  • cdc_keyboard_class_handler : cdc_keyboard_class.c, cdc_keyboard_class.h
  • cdc_keyboard_desc_handler : cdc_keyboard_desc.c, cdc_keyboard_desc.h
  • cdc_msc_class_handler : cdc_msc_class.c, cdc_msc_class.h
  • cdc_msc_desc_handler : cdc_msc_desc.c, cdc_msc_desc.h
  • cdc_msc_struct : cdc_msc_class.c
  • cdc_struct : cdc_class.c
  • channel1pulse : project/at_start_f435/examples/tmr/7_pwm_output/src/main.c, project/at_start_f435/examples/tmr/complementary_signals/src/main.c, project/at_start_f437/examples/tmr/7_pwm_output/src/main.c, project/at_start_f437/examples/tmr/complementary_signals/src/main.c
  • channel2pulse : project/at_start_f435/examples/tmr/7_pwm_output/src/main.c, project/at_start_f435/examples/tmr/complementary_signals/src/main.c, project/at_start_f437/examples/tmr/7_pwm_output/src/main.c, project/at_start_f437/examples/tmr/complementary_signals/src/main.c
  • channel3pulse : project/at_start_f435/examples/tmr/7_pwm_output/src/main.c, project/at_start_f435/examples/tmr/complementary_signals/src/main.c, project/at_start_f437/examples/tmr/7_pwm_output/src/main.c, project/at_start_f437/examples/tmr/complementary_signals/src/main.c
  • channel4pulse : project/at_start_f435/examples/tmr/7_pwm_output/src/main.c, project/at_start_f437/examples/tmr/7_pwm_output/src/main.c
  • cid_table : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c, at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • cmd_addr_cnt : at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
  • cmd_ctr_step : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h, at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
  • cmd_data_cnt : at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
  • cmd_data_group_struct : at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
  • cmd_data_group_type_struct : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h
  • cmd_data_step : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h, at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
  • cmd_rdx : at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c, at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c
  • cmd_rdy : at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c, at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c
  • config_descriptor : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • connect_flag : tcp_client.c
  • counter : project/at_start_f435/examples/debug/tmr1/src/main.c, project/at_start_f435/examples/edma/two_dimension_mode/src/main.c, project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/debug/tmr1/src/main.c, project/at_start_f437/examples/edma/two_dimension_mode/src/main.c, project/at_start_f437/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • crc1_value : project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c
  • crc2_value : project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c
  • crc_value : project/at_start_f435/examples/crc/calculation/src/main.c, project/at_start_f437/examples/crc/calculation/src/main.c
  • crm_clocks_freq_struct : project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c, project/at_start_f435/examples/dac/two_dac_trianglewave/src/main.c, project/at_start_f435/examples/debug/tmr1/src/main.c, project/at_start_f435/examples/irtmr/irtmr_output/src/main.c, project/at_start_f435/examples/tmr/6_steps/src/main.c, project/at_start_f435/examples/tmr/7_pwm_output/src/main.c, project/at_start_f435/examples/tmr/cascade_synchro/src/main.c, project/at_start_f435/examples/tmr/complementary_signals/src/main.c, project/at_start_f435/examples/tmr/dma/src/main.c, project/at_start_f435/examples/tmr/dma_burst/src/main.c, project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f435/examples/tmr/external_clock/src/main.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f435/examples/tmr/hang_mode/src/main.c, project/at_start_f435/examples/tmr/input_capture/src/main.c, project/at_start_f435/examples/tmr/oc_high/src/main.c, project/at_start_f435/examples/tmr/oc_low/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f435/examples/tmr/one_cycle/src/main.c, project/at_start_f435/examples/tmr/parallel_synchro/src/main.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f435/examples/tmr/timer_base/src/main.c, project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/main.c, project/at_start_f437/examples/dac/one_dac_dma_escalator/src/main.c, project/at_start_f437/examples/dac/two_dac_trianglewave/src/main.c, project/at_start_f437/examples/debug/tmr1/src/main.c, project/at_start_f437/examples/irtmr/irtmr_output/src/main.c, project/at_start_f437/examples/tmr/6_steps/src/main.c, project/at_start_f437/examples/tmr/7_pwm_output/src/main.c, project/at_start_f437/examples/tmr/cascade_synchro/src/main.c, project/at_start_f437/examples/tmr/complementary_signals/src/main.c, project/at_start_f437/examples/tmr/dma/src/main.c, project/at_start_f437/examples/tmr/dma_burst/src/main.c, project/at_start_f437/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f437/examples/tmr/external_clock/src/main.c, project/at_start_f437/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f437/examples/tmr/hang_mode/src/main.c, project/at_start_f437/examples/tmr/input_capture/src/main.c, project/at_start_f437/examples/tmr/oc_high/src/main.c, project/at_start_f437/examples/tmr/oc_low/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f437/examples/tmr/one_cycle/src/main.c, project/at_start_f437/examples/tmr/parallel_synchro/src/main.c, project/at_start_f437/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f437/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f437/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f437/examples/tmr/timer_base/src/main.c, project/at_start_f437/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c
  • csd_table : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c, at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • custom_hid_class_handler : custom_hid_class.c, custom_hid_class.h
  • custom_hid_desc_handler : custom_hid_desc.c, custom_hid_desc.h
  • custom_hid_struct : custom_hid_class.c


AT32F435/437 Firmwary Library: Globals

- d -

  • data__404_html : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • data__img_sics_gif : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • data_AT32F437_html : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • data_AT32F437ADC_html : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • data_AT32F437LED_html : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • data_buffer : project/at_start_f435/examples/crc/calculation/src/main.c, project/at_start_f437/examples/crc/calculation/src/main.c
  • data_count : project/at_start_f435/examples/usart/half_duplex/src/main.c, project/at_start_f435/examples/usart/hw_flow_control/src/main.c, project/at_start_f437/examples/usart/half_duplex/src/main.c, project/at_start_f437/examples/usart/hw_flow_control/src/main.c
  • data_counter_end : project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f435/examples/dma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/two_dimension_mode/src/main.c, project/at_start_f437/examples/dma/flash_to_sram/src/at32f435_437_int.c, project/at_start_f437/examples/dma/flash_to_sram/src/main.c, project/at_start_f437/examples/edma/flash_to_sram/src/main.c, project/at_start_f437/examples/edma/two_dimension_mode/src/main.c
  • data_index_html : utilities/at32f437_emac_iap_demo/source_code/bootloader/src/fsdata.c
  • data_len : project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f437/examples/usb_device/virtual_comport/src/main.c
  • data_reset_html : utilities/at32f437_emac_iap_demo/source_code/bootloader/src/fsdata.c
  • data_upload_html : utilities/at32f437_emac_iap_demo/source_code/bootloader/src/fsdata.c
  • data_uploaddone_html : utilities/at32f437_emac_iap_demo/source_code/bootloader/src/fsdata.c
  • device_descriptor : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • device_mode : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c, at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • dma1_trans_complete_flag : project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c
  • dma_init_struct : project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/main.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/dma/flash_to_sram/src/main.c, project/at_start_f435/examples/tmr/dma/src/main.c, project/at_start_f435/examples/tmr/dma_burst/src/main.c, at_start_f435/examples/xmc/sdram_dma/src/xmc_sdram.c, project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/main.c, project/at_start_f437/examples/dac/double_mode_dma_squarewave/src/main.c, project/at_start_f437/examples/dac/one_dac_dma_escalator/src/main.c, project/at_start_f437/examples/dma/dmamux_data_to_gpio/src/main.c, project/at_start_f437/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/dma/flash_to_sram/src/main.c, project/at_start_f437/examples/tmr/dma/src/main.c, project/at_start_f437/examples/tmr/dma_burst/src/main.c, at_start_f437/examples/xmc/sdram_dma/src/xmc_sdram.c
  • dma_init_structure : project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c
  • dma_rx_desc_to_get : at32f435_437_emac.c
  • dma_trans_complete_flag : project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f435/examples/adc/conversion_abort/src/main.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f435/examples/adc/resolution_6bit/src/main.c, project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c, project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f437/examples/adc/conversion_abort/src/at32f435_437_int.c, project/at_start_f437/examples/adc/conversion_abort/src/main.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f437/examples/adc/resolution_6bit/src/at32f435_437_int.c, project/at_start_f437/examples/adc/resolution_6bit/src/main.c, project/at_start_f437/examples/adc/software_trigger_repeat/src/at32f435_437_int.c, project/at_start_f437/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c
  • dma_tx_desc_to_set : at32f435_437_emac.c
  • dmamux_gen_init_struct : project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/edma/dmamux_genertor_exint/src/main.c
  • dmamux_sync_init_struct : project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/main.c
  • double_adc1_ordinary_valuetab : project/at_start_f435/examples/adc/edma_double_buffer/src/main.c, project/at_start_f437/examples/adc/edma_double_buffer/src/main.c
  • double_buffer_is_useful : project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/src/main.c, project/at_start_f437/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f437/examples/adc/edma_double_buffer/src/main.c
  • dst_buffer : project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/dma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/edma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/two_dimension_mode/src/main.c, project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/dma/flash_to_sram/src/main.c, project/at_start_f437/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/edma/flash_to_sram/src/main.c, project/at_start_f437/examples/edma/two_dimension_mode/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • dualsine12bit : project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c, project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/main.c
  • dualsquare12bit : project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/main.c, project/at_start_f437/examples/dac/double_mode_dma_squarewave/src/main.c
  • duty_buffer : project/at_start_f435/examples/edma/burst_mode/src/main.c, project/at_start_f437/examples/edma/burst_mode/src/main.c
  • duty_result : project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c
  • dutycycle : project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input/src/main.c, project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f437/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/pwm_input/src/main.c, project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c
  • dw_end_sector : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • dw_inst_start_sector : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • dw_start_sector : utilities/at32f435_437_slib_demo/project_l0/src/main.c


AT32F435/437 Firmwary Library: Globals

- e -

  • ecc_value_read : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c
  • ecc_value_write : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c
  • ecc_value_write_last : project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c
  • edma_init_struct : at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.h, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.h, project/at_start_f435/examples/edma/burst_mode/src/main.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/edma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/two_dimension_mode/src/main.c, at_start_f437/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f437/examples/dvp/ov2640_capture/hardware/dvp/dvp.h, at_start_f437/examples/dvp/ov5640_capture/hardware/dvp/dvp.c, at_start_f437/examples/dvp/ov5640_capture/hardware/dvp/dvp.h, project/at_start_f437/examples/edma/burst_mode/src/main.c, project/at_start_f437/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/edma/flash_to_sram/src/main.c, project/at_start_f437/examples/edma/two_dimension_mode/src/main.c
  • edma_trans_complete_flag : project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f435/examples/adc/edma_double_buffer/src/main.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c, project/at_start_f437/examples/adc/edma_double_buffer/src/at32f435_437_int.c, project/at_start_f437/examples/adc/edma_double_buffer/src/main.c
  • edmamux_sync_init_struct : project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/main.c
  • ertc_clk_div_a : project/at_start_f435/examples/ertc/calendar/src/main.c, project/at_start_f437/examples/ertc/calendar/src/main.c, random.c
  • ertc_clk_div_b : project/at_start_f435/examples/ertc/calendar/src/main.c, project/at_start_f437/examples/ertc/calendar/src/main.c, random.c
  • escalator8bit : project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c, project/at_start_f437/examples/dac/one_dac_dma_escalator/src/main.c
  • esmt32m_cmd_config : at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c
  • exint_init_struct : project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/main.c


AT32F435/437 Firmwary Library: Globals

- f -

  • fac_ms : at32f435_437_board.c
  • fac_us : at32f435_437_board.c
  • fat16_file_name : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c, at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • fat16_root_dir_sector : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c, at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • fat16_sector : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c, at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • fat16_table_sector0 : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c, at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • file : project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, project/at_start_f437/examples/sdio/sdio_fatfs/src/main.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • file__404_html : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • file__img_sics_gif : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • file_AT32F437_html : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • file_AT32F437ADC_html : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • file_AT32F437LED_html : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • file_index_html : utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/fsdata.c
  • file_match : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c, at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • file_reset_html : utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/fsdata.c
  • file_upload_html : utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/fsdata.c
  • file_uploaddone_html : utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/fsdata.c
  • file_write_nr : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c, at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • firCoeffs32 : fir_coefficient.c, fir_filter.c
  • firStateF32 : fir_filter.c
  • flash_buf : project/at_start_f435/examples/flash/flash_write_read/src/flash.c, project/at_start_f437/examples/flash/flash_write_read/src/flash.c
  • flash_iap : at_start_f435/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c, at_start_f437/examples/usb_device/virtual_msc_iap/inc/flash_fat16.h, at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • FlashBufferEnd : flash_loader_extra.h
  • FlashBufferStart : flash_loader_extra.h
  • FlashDevice : FlashDev.c
  • freq_result : project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c
  • frequency : project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f435/examples/tmr/pwm_input/src/main.c, project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f437/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/pwm_input/src/main.c, project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c
  • fs : project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, project/at_start_f437/examples/sdio/sdio_fatfs/src/main.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c


AT32F435/437 Firmwary Library: Globals

- g -

  • g_audio_hid_usb_desc : audio_hid_desc.h
  • g_custom_hid_usb_desc : custom_hid_desc.h
  • g_file_attr : at_start_f435/examples/usb_device/virtual_msc_iap/src/flash_fat16.c, at_start_f437/examples/usb_device/virtual_msc_iap/src/flash_fat16.c
  • g_hidiap_usb_desc : hid_iap_desc.h
  • g_keyboard_usb_desc : keyboard_desc.h
  • g_mouse_usb_desc : mouse_desc.h
  • g_speed : project/at_start_f435/templates/src/main.c, project/at_start_f437/examples/emac/dns_client/src/main.c, project/at_start_f437/examples/emac/http_server/src/main.c, project/at_start_f437/examples/emac/iperf/src/main.c, project/at_start_f437/examples/emac/mqtt_client/src/main.c, project/at_start_f437/examples/emac/tcp_client/src/main.c, project/at_start_f437/examples/emac/tcp_server/src/main.c, project/at_start_f437/examples/emac/telnet/src/main.c, project/at_start_f437/examples/emac/wake_on_lan/src/main.c, project/at_start_f437/templates/src/main.c
  • g_usbd_audio_hid_report : audio_hid_desc.h
  • g_usbd_custom_hid_report : custom_hid_desc.h
  • g_usbd_desc_buffer : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • g_usbd_hidiap_report : hid_iap_desc.h
  • g_usbd_keyboard_report : keyboard_desc.h
  • g_usbd_mouse_report : mouse_desc.h
  • g_usbd_vcpkybrd_hid_report : cdc_keyboard_desc.h
  • g_vcpkybrd_hid_usb_desc : cdc_keyboard_desc.h
  • get_data_from_usart_flag : at32f435_437_usart_iap_demo/source_code/bootloader/inc/tmr.h, at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c
  • gimage_0 : at_start_f435/examples/xmc/lcd_8bit/inc/picture.h, at_start_f437/examples/xmc/lcd_8bit/inc/picture.h
  • gimage_3 : at_start_f435/examples/xmc/lcd_8bit/inc/picture.h, at_start_f437/examples/xmc/lcd_8bit/inc/picture.h
  • gimage_5 : at_start_f435/examples/xmc/lcd_8bit/inc/picture.h, at_start_f437/examples/xmc/lcd_8bit/inc/picture.h
  • gimage_8 : at_start_f435/examples/xmc/lcd_8bit/inc/picture.h, at_start_f437/examples/xmc/lcd_8bit/inc/picture.h
  • gimage_9 : at_start_f435/examples/xmc/lcd_8bit/inc/picture.h, at_start_f437/examples/xmc/lcd_8bit/inc/picture.h
  • gpio_init_struct : project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c, project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/main.c, project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c, project/at_start_f435/examples/dac/one_dac_noisewave/src/main.c, project/at_start_f435/examples/dac/two_dac_trianglewave/src/main.c, project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/dma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/burst_mode/src/main.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/tmr/6_steps/src/main.c, project/at_start_f435/examples/tmr/7_pwm_output/src/main.c, project/at_start_f435/examples/tmr/cascade_synchro/src/main.c, project/at_start_f435/examples/tmr/complementary_signals/src/main.c, project/at_start_f435/examples/tmr/dma/src/main.c, project/at_start_f435/examples/tmr/dma_burst/src/main.c, project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f435/examples/tmr/external_clock/src/main.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f435/examples/tmr/hang_mode/src/main.c, project/at_start_f435/examples/tmr/input_capture/src/main.c, project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/main.c, project/at_start_f437/examples/dac/double_mode_dma_squarewave/src/main.c, project/at_start_f437/examples/dac/one_dac_dma_escalator/src/main.c, project/at_start_f437/examples/dac/one_dac_noisewave/src/main.c, project/at_start_f437/examples/dac/two_dac_trianglewave/src/main.c, project/at_start_f437/examples/dma/dmamux_data_to_gpio/src/main.c, project/at_start_f437/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/dma/flash_to_sram/src/main.c, project/at_start_f437/examples/edma/burst_mode/src/main.c, project/at_start_f437/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/tmr/6_steps/src/main.c, project/at_start_f437/examples/tmr/7_pwm_output/src/main.c, project/at_start_f437/examples/tmr/cascade_synchro/src/main.c, project/at_start_f437/examples/tmr/complementary_signals/src/main.c, project/at_start_f437/examples/tmr/dma/src/main.c, project/at_start_f437/examples/tmr/dma_burst/src/main.c, project/at_start_f437/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f437/examples/tmr/external_clock/src/main.c, project/at_start_f437/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f437/examples/tmr/hang_mode/src/main.c, project/at_start_f437/examples/tmr/input_capture/src/main.c


AT32F435/437 Firmwary Library: Globals

- h -

  • hi2cx : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f435/examples/i2c/eeprom/src/main.c, at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, project/at_start_f437/examples/i2c/communication_dma/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/at32f435_437_int.c, project/at_start_f437/examples/i2c/eeprom/src/main.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • hid_iap_class_handler : hid_iap_class.c, hid_iap_class.h
  • hid_iap_desc_handler : hid_iap_desc.c, hid_iap_desc.h
  • hid_keyboard_codes : usbh_hid_keyboard.c
  • hid_keyboard_key : usbh_hid_keyboard.c
  • hid_keyboard_key_shift : usbh_hid_keyboard.c
  • hid_mouse : usbh_hid_mouse.c
  • hid_suspend_flag : project/at_start_f435/examples/usb_device/keyboard/src/main.c, project/at_start_f437/examples/usb_device/keyboard/src/main.c
  • html_tmp : httpd.c
  • http_iap_flag : utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • hw_usart_read_index : project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f437/examples/usb_device/virtual_comport/src/main.c
  • hw_usart_rx_index : project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f437/examples/usb_device/virtual_comport/src/main.c


AT32F435/437 Firmwary Library: Globals

- i -

  • i2s2_buffer1_rx : project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c
  • i2s2_buffer2_rx : project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c
  • i2s2_buffer_rx : project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f437/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • i2s2_buffer_tx : project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c
  • i2s3_buffer1_tx : project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c
  • i2s3_buffer2_tx : project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c
  • i2s3_buffer_rx : project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c
  • i2s3_buffer_tx : project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f437/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • iap_flag : app_led3_toggle/inc/usart.h, app_led3_toggle/src/usart.c, app_led4_toggle/inc/usart.h, app_led4_toggle/src/usart.c
  • iap_info : hid_iap_class.c, hid_iap_class.h
  • ic1value : project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c
  • ic2value : project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c, project/at_start_f437/examples/tmr/pwm_input/src/at32f435_437_int.c
  • ic3readvalue1 : project/at_start_f435/examples/tmr/input_capture/src/main.c, project/at_start_f437/examples/tmr/input_capture/src/main.c
  • ic3readvalue2 : project/at_start_f435/examples/tmr/input_capture/src/main.c, project/at_start_f437/examples/tmr/input_capture/src/main.c
  • idx : project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c, project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/main.c


AT32F435/437 Firmwary Library: Globals

- j -

  • j : project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c
  • jump_to_app : at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c, at32f437_emac_iap_demo/source_code/bootloader/src/iap.c


AT32F435/437 Firmwary Library: Globals

- k -

  • keyboard_class_handler : keyboard_class.c, keyboard_class.h
  • keyboard_desc_handler : keyboard_desc.c, keyboard_desc.h
  • keyboard_send_flag : project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/src/main.c
  • keyboard_struct : keyboard_class.c


AT32F435/437 Firmwary Library: Globals

- l -

  • langid_descriptor : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • lcd_dev_struct : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c
  • LCD_ID : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • lcd_struct : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c
  • led2_handler : utilities/at32f435_437_freertos_demo/src/main.c
  • led3_handler : utilities/at32f435_437_freertos_demo/src/main.c
  • led_gpio_crm_clk : at32f435_437_board.c
  • led_gpio_pin : at32f435_437_board.c
  • led_gpio_port : at32f435_437_board.c
  • led_page_name : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • lick_freq : project/at_start_f435/examples/ertc/lick_calibration/src/main.c, project/at_start_f437/examples/ertc/lick_calibration/src/main.c
  • linecoding : cdc_class.c, cdc_msc_class.c, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f437/examples/usb_device/virtual_comport/src/main.c
  • linecoding_vcpkybrd : cdc_keyboard_class.c
  • link_timer : project/at_start_f437/examples/emac/dns_client/src/netconf.c, project/at_start_f437/examples/emac/http_server/src/netconf.c, project/at_start_f437/examples/emac/iperf/src/netconf.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_server/src/netconf.c, project/at_start_f437/examples/emac/telnet/src/netconf.c, project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • local_gw : project/at_start_f437/examples/emac/dns_client/src/netconf.c, project/at_start_f437/examples/emac/http_server/src/netconf.c, project/at_start_f437/examples/emac/iperf/src/netconf.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_server/src/netconf.c, project/at_start_f437/examples/emac/telnet/src/netconf.c, project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • local_ip : project/at_start_f437/examples/emac/dns_client/src/netconf.c, project/at_start_f437/examples/emac/http_server/src/netconf.c, project/at_start_f437/examples/emac/iperf/src/netconf.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_server/src/netconf.c, project/at_start_f437/examples/emac/telnet/src/netconf.c, project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • local_mask : project/at_start_f437/examples/emac/dns_client/src/netconf.c, project/at_start_f437/examples/emac/http_server/src/netconf.c, project/at_start_f437/examples/emac/iperf/src/netconf.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_server/src/netconf.c, project/at_start_f437/examples/emac/telnet/src/netconf.c, project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • local_time : project/at_start_f437/examples/emac/dns_client/src/main.c, project/at_start_f437/examples/emac/dns_client/src/netconf.c, project/at_start_f437/examples/emac/http_server/src/main.c, project/at_start_f437/examples/emac/http_server/src/netconf.c, project/at_start_f437/examples/emac/iperf/src/main.c, project/at_start_f437/examples/emac/iperf/src/netconf.c, project/at_start_f437/examples/emac/mqtt_client/src/main.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/main.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_server/src/main.c, project/at_start_f437/examples/emac/tcp_server/src/netconf.c, project/at_start_f437/examples/emac/telnet/src/main.c, project/at_start_f437/examples/emac/telnet/src/netconf.c, project/at_start_f437/examples/emac/wake_on_lan/src/main.c, project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/main.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • ly68l6400_cmd_config : at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c, at_start_f437/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c
  • ly68l6400_xip_init : at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c, at_start_f437/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c


AT32F435/437 Firmwary Library: Globals

- m -

  • mac_address : project/at_start_f437/examples/emac/dns_client/src/netconf.c, project/at_start_f437/examples/emac/http_server/src/netconf.c, project/at_start_f437/examples/emac/iperf/src/netconf.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_server/src/netconf.c, project/at_start_f437/examples/emac/telnet/src/netconf.c, project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • mac_control_para : project/at_start_f437/examples/emac/dns_client/src/at32_emac.c, project/at_start_f437/examples/emac/http_server/src/at32_emac.c, project/at_start_f437/examples/emac/iperf/src/at32_emac.c, project/at_start_f437/examples/emac/mqtt_client/src/at32_emac.c, project/at_start_f437/examples/emac/tcp_client/src/at32_emac.c, project/at_start_f437/examples/emac/tcp_server/src/at32_emac.c, project/at_start_f437/examples/emac/telnet/src/at32_emac.c, project/at_start_f437/examples/emac/wake_on_lan/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/at32_emac.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/at32_emac.c
  • main_page_name : project/at_start_f437/examples/emac/http_server/src/fsdata.c
  • max_marks : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • mblock_rbuffer : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c
  • mblock_tbuffer : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c
  • mean : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • message_cnt : project/at_start_f437/examples/emac/mqtt_client/src/netconf.c
  • message_test : project/at_start_f437/examples/emac/mqtt_client/src/netconf.c
  • mic_dma_buffer : at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • min_marks : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • mouse_class_handler : mouse_class.c, mouse_class.h
  • mouse_desc_handler : mouse_desc.c, mouse_desc.h
  • mouse_struct : mouse_class.c
  • mqtt_send_timer : project/at_start_f437/examples/emac/mqtt_client/src/netconf.c
  • msc_class_handler : msc_class.c, msc_class.h
  • msc_desc_handler : msc_desc.c, msc_desc.h
  • msc_flash_size : at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c, at_start_f435/examples/usb_device/msc/src/msc_diskio.c, at_start_f437/examples/usb_device/composite_vcp_msc/src/msc_diskio.c, at_start_f437/examples/usb_device/msc/src/msc_diskio.c
  • msc_struct : msc_class.c


AT32F435/437 Firmwary Library: Globals

- n -

  • nand_id_struct : project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c
  • netif : project/at_start_f437/examples/emac/dns_client/src/netconf.c, project/at_start_f437/examples/emac/http_server/src/netconf.c, project/at_start_f437/examples/emac/iperf/src/netconf.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_server/src/netconf.c, project/at_start_f437/examples/emac/telnet/src/netconf.c, project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • nor_id : project/at_start_f435/examples/xmc/nor_flash/src/main.c, project/at_start_f437/examples/xmc/nor_flash/src/main.c
  • number : project/at_start_f435/examples/xmc/nor_flash/src/main.c, project/at_start_f435/examples/xmc/psram/src/main.c, project/at_start_f435/examples/xmc/sdram_basic/src/main.c, project/at_start_f435/examples/xmc/sdram_dma/src/main.c, project/at_start_f435/examples/xmc/sram/src/main.c, project/at_start_f437/examples/xmc/nor_flash/src/main.c, project/at_start_f437/examples/xmc/psram/src/main.c, project/at_start_f437/examples/xmc/sdram_basic/src/main.c, project/at_start_f437/examples/xmc/sdram_dma/src/main.c, project/at_start_f437/examples/xmc/sram/src/main.c
  • numStudents : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • numSubjects : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c


AT32F435/437 Firmwary Library: Globals

- o -

  • otg2_core_struct : project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f437/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f437/examples/usb_host/two_otg_host_demo/src/main.c
  • otg_core_struct : project/at_start_f435/examples/acc/calibration/src/main.c, project/at_start_f435/examples/usb_device/audio/src/main.c, project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f435/examples/usb_device/custom_hid/src/main.c, project/at_start_f435/examples/usb_device/keyboard/src/main.c, project/at_start_f435/examples/usb_device/mouse/src/main.c, project/at_start_f435/examples/usb_device/msc/src/main.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/printer/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c, project/at_start_f435/examples/usb_host/hid_demo/src/main.c, project/at_start_f435/examples/usb_host/msc_only_fat32/src/main.c, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, project/at_start_f435/examples/usb_host/two_otg_host_demo/src/main.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c, project/at_start_f437/examples/acc/calibration/src/main.c, project/at_start_f437/examples/usb_device/audio/src/main.c, project/at_start_f437/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f437/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f437/examples/usb_device/custom_hid/src/main.c, project/at_start_f437/examples/usb_device/keyboard/src/main.c, project/at_start_f437/examples/usb_device/mouse/src/main.c, project/at_start_f437/examples/usb_device/msc/src/main.c, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f437/examples/usb_device/printer/src/main.c, project/at_start_f437/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f437/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f437/examples/usb_device/virtual_comport/src/main.c, project/at_start_f437/examples/usb_device/virtual_msc_iap/src/main.c, project/at_start_f437/examples/usb_host/hid_demo/src/main.c, project/at_start_f437/examples/usb_host/msc_only_fat32/src/main.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_msc_diskio.c, project/at_start_f437/examples/usb_host/two_otg_host_demo/src/main.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_msc_diskio.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/src/main.c
  • OV2640_AUTOEXPOSURE_LEVEL : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c
  • ov2640_jpeg_reg_tbl : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h
  • ov2640_rgb565_reg_tbl : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h
  • ov2640_svga_init_reg_tbl : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h
  • ov2640_sxga_init_reg_tbl : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h
  • ov2640_yuv422_reg_tbl : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640cfg.h
  • OV5640_AF_Config : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640af.h, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640af.h
  • OV5640_EFFECTS_TBL : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c
  • OV5640_EXPOSURE_TBL : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c
  • OV5640_jpeg_reg_tbl : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h
  • OV5640_LIGHTMODE_TBL : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c
  • ov5640_rgb565_reg_tbl : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h
  • OV5640_SATURATION_TBL : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c
  • ov5640_uxga_init_reg_tbl : at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640cfg.h
  • ov_cnt : project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f437/examples/usb_device/virtual_comport/src/main.c
  • ov_frame : at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f435/examples/dvp/ov5640_capture/hardware/dvp/dvp.c, at_start_f437/examples/dvp/ov2640_capture/hardware/dvp/dvp.c, at_start_f437/examples/dvp/ov5640_capture/hardware/dvp/dvp.c


AT32F435/437 Firmwary Library: Globals

- p -

  • p_adc1_ordinary : project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c, project/at_start_f437/examples/adc/use_polling_get_conversion_data/src/main.c
  • page_number : project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c
  • pagenumber : project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c
  • pcb : project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c
  • period_value : project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f435/examples/ertc/lick_calibration/src/main.c, project/at_start_f437/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f437/examples/ertc/lick_calibration/src/main.c
  • pftarget : project/at_start_f435/examples/usb_device/virtual_msc_iap/src/main.c, project/at_start_f437/examples/usb_device/virtual_msc_iap/src/main.c, bootloader/src/hid_iap_user.c
  • point_color : project/at_start_f435/examples/dvp/ov2640_capture/src/main.c, project/at_start_f435/examples/dvp/ov5640_capture/src/main.c, project/at_start_f435/examples/xmc/lcd_8bit/src/main.c, project/at_start_f435/examples/xmc/lcd_touch_16bit/src/main.c, project/at_start_f437/examples/dvp/ov2640_capture/src/main.c, project/at_start_f437/examples/dvp/ov5640_capture/src/main.c, project/at_start_f437/examples/xmc/lcd_8bit/src/main.c, project/at_start_f437/examples/xmc/lcd_touch_16bit/src/main.c
  • preempt_conversion_count : project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/src/main.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/src/main.c
  • preempt_trigger_count : project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c, project/at_start_f437/examples/adc/exint_trigger_partitioned/src/main.c
  • prescalervalue : project/at_start_f435/examples/irtmr/irtmr_output/src/main.c, project/at_start_f435/examples/tmr/oc_high/src/main.c, project/at_start_f435/examples/tmr/oc_low/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f435/examples/tmr/one_cycle/src/main.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f437/examples/irtmr/irtmr_output/src/main.c, project/at_start_f437/examples/tmr/oc_high/src/main.c, project/at_start_f437/examples/tmr/oc_low/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f437/examples/tmr/one_cycle/src/main.c, project/at_start_f437/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f437/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f437/examples/tmr/pwm_output_tmr3/src/main.c
  • press_mouse : project/at_start_f435/examples/usb_device/mouse/src/main.c, project/at_start_f437/examples/usb_device/mouse/src/main.c
  • printer_class_handler : printer_class.c, printer_class.h
  • printer_desc_handler : printer_desc.c, printer_desc.h
  • printer_struct : printer_class.c


AT32F435/437 Firmwary Library: Globals

- q -

  • qspi_state_is_busy : at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c, at_start_f437/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c


AT32F435/437 Firmwary Library: Globals

- r -

  • rbuf : project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c, project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c, project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c, project/at_start_f437/examples/qspi/command_port_using_interrupt/src/main.c, project/at_start_f437/examples/qspi/command_port_using_polling/src/main.c, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/main.c, project/at_start_f437/examples/qspi/xip_port_write_read/src/main.c
  • rca : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c, at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • refOutput : project_l0/src/arm_fir_data.c, utilities/at32f435_437_slib_demo/project_l0/src/main.c, project_l1/src/arm_fir_data.c, utilities/at32f435_437_slib_demo/project_l1/src/main.c
  • reg_addr_data : at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • report_buf : project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f435/examples/usb_device/custom_hid/src/main.c, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f437/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f437/examples/usb_device/custom_hid/src/main.c, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/main.c, project/at_start_f437/examples/usb_device/two_otg_device_demo/src/main.c
  • rs485_buffer_rx : project/at_start_f435/examples/usart/rs485/src/main.c, project/at_start_f437/examples/usart/rs485/src/main.c
  • rs485_buffer_rx_cnt : project/at_start_f435/examples/usart/rs485/src/main.c, project/at_start_f437/examples/usart/rs485/src/main.c
  • rx_buf : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c
  • rx_buf1 : project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • rx_buf2 : project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • rx_buf3 : project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • rx_buffer : project/at_start_f435/examples/usart/hw_flow_control/src/main.c, project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f437/examples/usart/hw_flow_control/src/main.c, project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c
  • rx_counter : project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f435/examples/usart/receiver_mute/src/main.c, project/at_start_f437/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f437/examples/usart/receiver_mute/src/main.c
  • rx_index : project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • rxbuffer : project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f435/examples/xmc/nor_flash/src/main.c, project/at_start_f435/examples/xmc/psram/src/main.c, project/at_start_f435/examples/xmc/sdram_basic/src/main.c, project/at_start_f435/examples/xmc/sdram_dma/src/main.c, project/at_start_f435/examples/xmc/sram/src/main.c, project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f437/examples/xmc/nor_flash/src/main.c, project/at_start_f437/examples/xmc/psram/src/main.c, project/at_start_f437/examples/xmc/sdram_basic/src/main.c, project/at_start_f437/examples/xmc/sdram_dma/src/main.c, project/at_start_f437/examples/xmc/sram/src/main.c


AT32F435/437 Firmwary Library: Globals

- s -

  • s__mqtt_client_instance : mqtt_client.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c
  • sblock_rbuffer : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c
  • sblock_tbuffer : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c
  • sc_a2r_struct : project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • sc_baud_rate : project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • sc_clock_freq : project/at_start_f435/examples/usart/smartcard/src/main.c, project/at_start_f437/examples/usart/smartcard/src/main.c
  • scsi_inquiry : at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c, at_start_f435/examples/usb_device/msc/src/msc_diskio.c, at_start_f435/examples/usb_device/virtual_msc_iap/src/msc_diskio.c, at_start_f437/examples/usb_device/composite_vcp_msc/src/msc_diskio.c, at_start_f437/examples/usb_device/msc/src/msc_diskio.c, at_start_f437/examples/usb_device/virtual_msc_iap/src/msc_diskio.c
  • sd_card_info : at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c, at_start_f437/examples/sdio/sd_mmc_card/inc/at32_sdio.h, at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f437/examples/sdio/sdio_fatfs/inc/at32_sdio.h, at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sdio_command_init_struct : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c, at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sdio_data_buffer : at_start_f435/examples/sdio/sdio_fatfs/src/diskio.c, at_start_f437/examples/sdio/sdio_fatfs/src/diskio.c
  • sdio_data_init_struct : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c, at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • sector_size : at_start_f435/examples/usb_device/composite_vcp_msc/src/msc_diskio.c, at_start_f435/examples/usb_device/msc/src/msc_diskio.c, at_start_f437/examples/usb_device/composite_vcp_msc/src/msc_diskio.c, at_start_f437/examples/usb_device/msc/src/msc_diskio.c
  • serial_descriptor : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • sine12bit : project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c, project/at_start_f437/examples/dac/double_mode_dma_sinewave/src/main.c
  • spi1_rx_buffer : project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c
  • spi1_rx_counter : project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c
  • spi1_tx_buffer : project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c
  • spi1_tx_buffer_size : project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c
  • spi1_tx_counter : project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c
  • spi2_buffer_rx : project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • spi2_buffer_tx : project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • spi3_buffer_rx : project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • spi3_buffer_tx : project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • spi_init_struct : project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • spiflash_sector_buf : at_start_f435/examples/spi/w25q_flash/src/spi_flash.c, at_start_f437/examples/spi/w25q_flash/src/spi_flash.c
  • spk_dma_buffer : at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • src_buffer : project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c, project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f435/examples/tmr/dma/src/main.c, project/at_start_f435/examples/tmr/dma_burst/src/main.c, project/at_start_f437/examples/dma/dmamux_data_to_gpio/src/main.c, project/at_start_f437/examples/dma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/dma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/edma/dmamux_genertor_exint/src/main.c, project/at_start_f437/examples/edma/dmamux_synchronization_exint/src/main.c, project/at_start_f437/examples/tmr/dma/src/main.c, project/at_start_f437/examples/tmr/dma_burst/src/main.c
  • src_const_buffer : project/at_start_f435/examples/dma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/two_dimension_mode/src/main.c, project/at_start_f437/examples/dma/flash_to_sram/src/main.c, project/at_start_f437/examples/edma/flash_to_sram/src/main.c, project/at_start_f437/examples/edma/two_dimension_mode/src/main.c
  • STA : at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c, at_start_f437/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c, at_start_f437/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c
  • status : project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c
  • std : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • step : project/at_start_f435/examples/tmr/6_steps/src/main.c, project/at_start_f437/examples/tmr/6_steps/src/main.c
  • stop_flag : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c, at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • stream_rbuffer : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c
  • stream_tbuffer : project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c
  • student_num : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • sys_counter : project/at_start_f435/examples/tmr/input_capture/src/main.c, project/at_start_f437/examples/tmr/input_capture/src/main.c
  • system_core_clock : system_at32f435_437.c, system_at32f435_437.h


AT32F435/437 Firmwary Library: Globals

- t -

  • tcp_active_pcbs : tcp_client.c
  • tcp_client_pcb : tcp_client.h
  • tcp_send_timer : project/at_start_f437/examples/emac/tcp_client/src/netconf.c
  • tcp_timer : project/at_start_f437/examples/emac/dns_client/src/netconf.c, project/at_start_f437/examples/emac/http_server/src/netconf.c, project/at_start_f437/examples/emac/iperf/src/netconf.c, project/at_start_f437/examples/emac/mqtt_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_client/src/netconf.c, project/at_start_f437/examples/emac/tcp_server/src/netconf.c, project/at_start_f437/examples/emac/telnet/src/netconf.c, project/at_start_f437/examples/emac/wake_on_lan/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/netconf.c, utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • temp_buf : utilities/at32f435_437_slib_demo/project_l0/src/main.c
  • test_result : project/at_start_f435/examples/can/filter/src/main.c, project/at_start_f437/examples/can/filter/src/main.c
  • testInput_f32_1kHz_15kHz : project_l0/src/arm_fir_data.c, utilities/at32f435_437_slib_demo/project_l0/src/main.c, project_l1/src/arm_fir_data.c, utilities/at32f435_437_slib_demo/project_l1/src/main.c
  • testMarks_f32 : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • testOutput : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c, utilities/at32f435_437_slib_demo/project_l0/src/main.c, utilities/at32f435_437_slib_demo/project_l1/src/main.c
  • testUnity_f32 : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • tftp_iap_flag : utilities/at32f437_emac_iap_demo/source_code/bootloader/src/netconf.c
  • theFlashParams : flash_loader.c, flash_loader_extra.h
  • time : random.c
  • time_cnt : project/at_start_f435/examples/usart/printf/src/main.c, project/at_start_f437/examples/usart/printf/src/main.c
  • time_ira_cnt : at32f435_437_usart_iap_demo/source_code/bootloader/inc/tmr.h, at32f435_437_usart_iap_demo/source_code/bootloader/src/tmr.c
  • timerperiod : project/at_start_f435/examples/tmr/7_pwm_output/src/main.c, project/at_start_f435/examples/tmr/cascade_synchro/src/main.c, project/at_start_f435/examples/tmr/complementary_signals/src/main.c, project/at_start_f435/examples/tmr/dma/src/main.c, project/at_start_f435/examples/tmr/dma_burst/src/main.c, project/at_start_f435/examples/tmr/external_clock/src/main.c, project/at_start_f435/examples/tmr/hang_mode/src/main.c, project/at_start_f435/examples/tmr/parallel_synchro/src/main.c, project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f437/examples/tmr/7_pwm_output/src/main.c, project/at_start_f437/examples/tmr/cascade_synchro/src/main.c, project/at_start_f437/examples/tmr/complementary_signals/src/main.c, project/at_start_f437/examples/tmr/dma/src/main.c, project/at_start_f437/examples/tmr/dma_burst/src/main.c, project/at_start_f437/examples/tmr/external_clock/src/main.c, project/at_start_f437/examples/tmr/hang_mode/src/main.c, project/at_start_f437/examples/tmr/parallel_synchro/src/main.c, project/at_start_f437/examples/tmr/tmr1_synchro/src/main.c
  • tmp_c4 : project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c, project/at_start_f437/examples/ertc/lick_calibration/src/at32f435_437_int.c
  • tmr3freq : project/at_start_f435/examples/tmr/input_capture/src/main.c, project/at_start_f437/examples/tmr/input_capture/src/main.c
  • tmr_brkdt_config_struct : project/at_start_f435/examples/tmr/6_steps/src/main.c, project/at_start_f435/examples/tmr/complementary_signals/src/main.c, project/at_start_f437/examples/tmr/6_steps/src/main.c, project/at_start_f437/examples/tmr/complementary_signals/src/main.c
  • tmr_ic_init_structure : project/at_start_f435/examples/tmr/one_cycle/src/main.c, project/at_start_f435/examples/tmr/pwm_input/src/main.c, project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f437/examples/tmr/one_cycle/src/main.c, project/at_start_f437/examples/tmr/pwm_input/src/main.c, project/at_start_f437/examples/tmr/pwm_input_dma/src/main.c
  • tmr_input_config_struct : project/at_start_f435/examples/tmr/external_clock/src/main.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f435/examples/tmr/hang_mode/src/main.c, project/at_start_f435/examples/tmr/input_capture/src/main.c, project/at_start_f437/examples/tmr/external_clock/src/main.c, project/at_start_f437/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f437/examples/tmr/hang_mode/src/main.c, project/at_start_f437/examples/tmr/input_capture/src/main.c
  • tmr_oc_init_structure : project/at_start_f435/examples/irtmr/irtmr_output/src/main.c, project/at_start_f435/examples/tmr/oc_high/src/main.c, project/at_start_f435/examples/tmr/oc_low/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f435/examples/tmr/one_cycle/src/main.c, project/at_start_f435/examples/tmr/parallel_synchro/src/main.c, project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c, project/at_start_f437/examples/irtmr/irtmr_output/src/main.c, project/at_start_f437/examples/tmr/oc_high/src/main.c, project/at_start_f437/examples/tmr/oc_low/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f437/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f437/examples/tmr/one_cycle/src/main.c, project/at_start_f437/examples/tmr/parallel_synchro/src/main.c, project/at_start_f437/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f437/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f437/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f437/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f437/examples/tmr/tmr2_32bit/src/main.c
  • tmr_output_struct : project/at_start_f435/examples/edma/burst_mode/src/main.c, project/at_start_f435/examples/tmr/6_steps/src/main.c, project/at_start_f435/examples/tmr/7_pwm_output/src/main.c, project/at_start_f435/examples/tmr/cascade_synchro/src/main.c, project/at_start_f435/examples/tmr/complementary_signals/src/main.c, project/at_start_f435/examples/tmr/dma/src/main.c, project/at_start_f435/examples/tmr/dma_burst/src/main.c, project/at_start_f435/examples/tmr/external_clock/src/main.c, project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f435/examples/tmr/hang_mode/src/main.c, project/at_start_f437/examples/edma/burst_mode/src/main.c, project/at_start_f437/examples/tmr/6_steps/src/main.c, project/at_start_f437/examples/tmr/7_pwm_output/src/main.c, project/at_start_f437/examples/tmr/cascade_synchro/src/main.c, project/at_start_f437/examples/tmr/complementary_signals/src/main.c, project/at_start_f437/examples/tmr/dma/src/main.c, project/at_start_f437/examples/tmr/dma_burst/src/main.c, project/at_start_f437/examples/tmr/external_clock/src/main.c, project/at_start_f437/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f437/examples/tmr/hang_mode/src/main.c
  • touch_dev_struct : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c, at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c
  • touch_struct : at_start_f435/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f435/examples/xmc/lcd_touch_16bit/src/touch.c, at_start_f437/examples/xmc/lcd_touch_16bit/inc/touch.h, at_start_f437/examples/xmc/lcd_touch_16bit/src/touch.c
  • transfer_count : project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c
  • transfer_end : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c, at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • transfer_error : at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f435/examples/sdio/sdio_fatfs/src/at32_sdio.c, at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c, at_start_f437/examples/sdio/sdio_fatfs/src/at32_sdio.c
  • transfer_status : project/at_start_f435/examples/dma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/flash_to_sram/src/main.c, project/at_start_f435/examples/edma/two_dimension_mode/src/main.c, project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f435/examples/spi/w25q_flash/src/main.c, project/at_start_f437/examples/dma/flash_to_sram/src/main.c, project/at_start_f437/examples/edma/flash_to_sram/src/main.c, project/at_start_f437/examples/edma/two_dimension_mode/src/main.c, project/at_start_f437/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f437/examples/spi/w25q_flash/src/main.c
  • transfer_status1 : project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • transfer_status2 : project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f437/examples/i2s/fullduplex_dma/src/main.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • transfer_status3 : project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c
  • transfer_status4 : project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c
  • tx_buf : project/at_start_f435/examples/i2c/communication_dma/src/main.c, project/at_start_f435/examples/i2c/communication_int/src/main.c, project/at_start_f435/examples/i2c/communication_poll/src/main.c, project/at_start_f435/examples/i2c/communication_smbus/src/main.c, project/at_start_f437/examples/i2c/communication_dma/src/main.c, project/at_start_f437/examples/i2c/communication_int/src/main.c, project/at_start_f437/examples/i2c/communication_poll/src/main.c, project/at_start_f437/examples/i2c/communication_smbus/src/main.c
  • tx_buf1 : project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • tx_buf2 : project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • tx_buf3 : project/at_start_f435/examples/i2c/eeprom/src/main.c, project/at_start_f437/examples/i2c/eeprom/src/main.c
  • tx_buffer : project/at_start_f435/examples/edma/link_list_mode/src/main.c, project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f437/examples/edma/link_list_mode/src/main.c, project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c
  • tx_counter : project/at_start_f435/examples/usart/receiver_mute/src/main.c, project/at_start_f437/examples/usart/receiver_mute/src/main.c
  • tx_index : project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f435/examples/spi/fullduplex_polling/src/main.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f437/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f437/examples/spi/fullduplex_polling/src/main.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f437/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f437/examples/spi/ti_fullduplex_dma/src/main.c, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • txbuffer : project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f435/examples/xmc/nor_flash/src/main.c, project/at_start_f435/examples/xmc/psram/src/main.c, project/at_start_f435/examples/xmc/sdram_basic/src/main.c, project/at_start_f435/examples/xmc/sdram_dma/src/main.c, project/at_start_f435/examples/xmc/sram/src/main.c, project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f437/examples/xmc/nor_flash/src/main.c, project/at_start_f437/examples/xmc/psram/src/main.c, project/at_start_f437/examples/xmc/sdram_basic/src/main.c, project/at_start_f437/examples/xmc/sdram_dma/src/main.c, project/at_start_f437/examples/xmc/sram/src/main.c


AT32F435/437 Firmwary Library: Globals

- u -

  • uhost_hid_class_handler : usbh_hid_class.c, usbh_hid_class.h
  • uhost_msc_class_handler : usbh_msc_class.c, usbh_msc_class.h
  • update_status : at32f435_437_usart_iap_demo/source_code/bootloader/inc/iap.h, at32f435_437_usart_iap_demo/source_code/bootloader/src/iap.c
  • usart1_index : project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c, project/at_start_f437/examples/pwc/sleep_usart1/src/at32f435_437_int.c
  • usart2_rx_buffer : project/at_start_f435/examples/usart/half_duplex/src/main.c, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usart/half_duplex/src/main.c, project/at_start_f437/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c
  • usart2_rx_counter : project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c
  • usart2_rx_dma_status : project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c
  • usart2_tx_buffer : project/at_start_f435/examples/usart/half_duplex/src/main.c, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/receiver_mute/src/main.c, project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usart/half_duplex/src/main.c, project/at_start_f437/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/receiver_mute/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c
  • usart2_tx_buffer_size : project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c
  • usart2_tx_counter : project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/synchronous/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f437/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/synchronous/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usb_device/virtual_comport/src/main.c
  • usart2_tx_dma_status : project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c
  • usart3_rx_buffer : project/at_start_f435/examples/usart/half_duplex/src/main.c, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f435/examples/usart/receiver_mute/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usart/half_duplex/src/main.c, project/at_start_f437/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/receiver_mute/src/at32f435_437_int.c, project/at_start_f437/examples/usart/receiver_mute/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c
  • usart3_rx_counter : project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c
  • usart3_rx_dma_status : project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c
  • usart3_tx_buffer : project/at_start_f435/examples/usart/half_duplex/src/main.c, project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usart/half_duplex/src/main.c, project/at_start_f437/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c
  • usart3_tx_buffer_size : project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c
  • usart3_tx_counter : project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/interrupt/src/main.c, project/at_start_f435/examples/usart/polling/src/main.c, project/at_start_f435/examples/usart/tx_rx_swap/src/main.c, project/at_start_f437/examples/usart/interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/interrupt/src/main.c, project/at_start_f437/examples/usart/polling/src/main.c, project/at_start_f437/examples/usart/tx_rx_swap/src/main.c
  • usart3_tx_dma_status : project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/src/main.c
  • usart_group_struct : bootloader/inc/usart.h, bootloader/src/usart.c
  • usart_rx_buffer : project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f437/examples/usb_device/virtual_comport/src/main.c
  • usart_rx_data_len : project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f437/examples/usb_device/virtual_comport/src/main.c
  • usb_buffer : project/at_start_f435/examples/acc/calibration/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f435/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f435/examples/usb_device/virtual_comport/src/main.c, project/at_start_f437/examples/acc/calibration/src/main.c, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f437/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f437/examples/usb_device/two_otg_device_demo/src/main.c, project/at_start_f437/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f437/examples/usb_device/virtual_comport/src/main.c
  • usbh_hid : usbh_hid_class.c
  • usbh_msc : usbh_msc_class.c, usbh_msc_class.h
  • usbh_user_handle : at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.h, at_start_f435/examples/usb_host/hid_demo/inc/usbh_user.h, at_start_f435/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f435/examples/usb_host/msc_only_fat32/inc/usbh_user.h, at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/inc/usbh_user.h, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.c, at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/src/usbh_user.h, at_start_f437/examples/usb_host/hid_demo/inc/usbh_user.h, at_start_f437/examples/usb_host/hid_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/inc/usbh_user.h, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/inc/usbh_user.h, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c
  • usr_state : at_start_f435/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f435/examples/usb_host/two_otg_host_demo/src/usbh_user.c, at_start_f437/examples/usb_host/msc_only_fat32/src/usbh_user.c, at_start_f437/examples/usb_host/two_otg_host_demo/src/usbh_user.c


AT32F435/437 Firmwary Library: Globals

- v -

  • var : project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f437/examples/cortex_m4/cmsis_dsp/src/main.c
  • variables : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f437/examples/cortex_m4/bit_band/src/main.c
  • variables_addr : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f437/examples/cortex_m4/bit_band/src/main.c
  • variables_bit_val : project/at_start_f435/examples/cortex_m4/bit_band/src/main.c, project/at_start_f437/examples/cortex_m4/bit_band/src/main.c
  • vcp_keyboard_struct : cdc_keyboard_class.c
  • vmor_flag_index : project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f435/examples/adc/voltage_monitoring/src/main.c, project/at_start_f437/examples/adc/voltage_monitoring/src/at32f435_437_int.c, project/at_start_f437/examples/adc/voltage_monitoring/src/main.c
  • vp_desc : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c


AT32F435/437 Firmwary Library: Globals

- w -

  • wbuf : project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c, project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c, project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c, project/at_start_f437/examples/qspi/command_port_using_interrupt/src/main.c, project/at_start_f437/examples/qspi/command_port_using_polling/src/main.c, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/main.c, project/at_start_f437/examples/qspi/xip_port_write_read/src/main.c
  • work : project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f437/examples/sdio/sdio_fatfs/src/main.c
  • write_read_addr_struct : project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c
  • writereadstatus : project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f435/examples/xmc/nor_flash/src/main.c, project/at_start_f435/examples/xmc/psram/src/main.c, project/at_start_f435/examples/xmc/sdram_basic/src/main.c, project/at_start_f435/examples/xmc/sdram_dma/src/main.c, project/at_start_f435/examples/xmc/sram/src/main.c, project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f437/examples/xmc/nor_flash/src/main.c, project/at_start_f437/examples/xmc/psram/src/main.c, project/at_start_f437/examples/xmc/sdram_basic/src/main.c, project/at_start_f437/examples/xmc/sdram_dma/src/main.c, project/at_start_f437/examples/xmc/sram/src/main.c


AT32F435/437 Firmwary Library: Globals

- x -

  • x_pos : usbh_hid_mouse.c


AT32F435/437 Firmwary Library: Globals

- y -

  • y_pos : usbh_hid_mouse.c


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- w -

  • W25Q128 : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • W25Q16 : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • W25Q32 : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • W25Q64 : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • W25Q80 : at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h, at_start_f437/examples/spi/w25q_flash/inc/spi_flash.h
  • wakeup_timer_config() : project/at_start_f435/examples/ertc/wakeup_timer/src/main.c
  • wbuf : project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c, project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c, project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c, project/at_start_f437/examples/qspi/command_port_using_interrupt/src/main.c, project/at_start_f437/examples/qspi/command_port_using_polling/src/main.c, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/src/main.c, project/at_start_f437/examples/qspi/xip_port_write_read/src/main.c
  • WDT : at32f435_437_wdt.h
  • WDT_BASE : at32f435_437.h
  • WDT_CLK_DIV_128 : at32f435_437_wdt.h
  • WDT_CLK_DIV_16 : at32f435_437_wdt.h
  • WDT_CLK_DIV_256 : at32f435_437_wdt.h
  • WDT_CLK_DIV_32 : at32f435_437_wdt.h
  • WDT_CLK_DIV_4 : at32f435_437_wdt.h
  • WDT_CLK_DIV_64 : at32f435_437_wdt.h
  • WDT_CLK_DIV_8 : at32f435_437_wdt.h
  • WDT_CMD_ENABLE : at32f435_437_wdt.h
  • WDT_CMD_LOCK : at32f435_437_wdt.h
  • WDT_CMD_RELOAD : at32f435_437_wdt.h
  • WDT_CMD_UNLOCK : at32f435_437_wdt.h
  • wdt_cmd_value_type : at32f435_437_wdt.h
  • wdt_counter_reload() : at32f435_437_wdt.h, at32f435_437_wdt.c
  • WDT_DIVF_UPDATE_FLAG : at32f435_437_wdt.h
  • wdt_divider_set() : at32f435_437_wdt.h, at32f435_437_wdt.c
  • wdt_division_type : at32f435_437_wdt.h
  • wdt_enable() : at32f435_437_wdt.h, at32f435_437_wdt.c
  • wdt_flag_get() : at32f435_437_wdt.h, at32f435_437_wdt.c
  • WDT_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • wdt_register_write_enable() : at32f435_437_wdt.h, at32f435_437_wdt.c
  • wdt_reload_value_set() : at32f435_437_wdt.h, at32f435_437_wdt.c
  • WDT_RLDF_UPDATE_FLAG : at32f435_437_wdt.h
  • wdt_window_counter_set() : at32f435_437_wdt.h, at32f435_437_wdt.c
  • WDT_WINF_UPDATE_FLAG : at32f435_437_wdt.h
  • WHITE : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • WM8988_I2C_ADDR_CSB_HIGH : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_I2C_ADDR_CSB_LOW : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R0_LEFT_INPUT_VOLUME : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R10_LEFT_DAC_VOLUME : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R11_RIGHT_DAC_VOLUME : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R12_BASS_CONTROL : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R13_TREBLE_CONTROL : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R14_ : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R15_RESET : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R16_3D_CONTROL : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R17_ALC1 : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R18_ALC2 : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R19_ALC3 : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R1_RIGHT_INPUT_VOLUME : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R20_NOISE_GATE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R21_LEFT_ADC_VOLUME : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R22_RIGHT_ADC_VOLUME : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R23_ADDITIONAL_1_CONTROL : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R24_ADDITIONAL_2_CONTROL : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R25_PWR_1_MGMT : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R26_PWR_2_MGMT : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R27_ADDITIONAL_3_CONTROL : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R2_LOUT1_VOLUME : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R31_ADC_INPUT_MODE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R32_ADC_L_SIGNAL_PATH : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R33_ADC_R_SIGNAL_PATH : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R34_LEFT_OUT_MIX_1 : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R35_LEFT_OUT_MIX_2 : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R36_RIGHT_OUT_MIX_1 : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R37_RIGHT_OUT_MIX_2 : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R38_RESERVED : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R39_RESERVED : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R3_ROUT1_VOLUME : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R40_LOUT2_VOLUME : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R41_ROUT2_VOLUME : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R42_RESERVED : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R43_LOW_POWER_PALYBACK : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R4_RESERVED : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R5_ADC_DAC_CONTROL : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R6_RESERVED : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R7_AUDIO_INTERFACE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R8_SAMPLE_RATE : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_R9_RESERVED : at_start_f435/examples/usb_device/audio/inc/audio_codec.h, at_start_f435/examples/usb_device/composite_audio_hid/inc/audio_codec.h, at_start_f437/examples/usb_device/audio/inc/audio_codec.h, at_start_f437/examples/usb_device/composite_audio_hid/inc/audio_codec.h
  • WM8988_REG_BITW16 : at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • WM8988_REG_FREQ16K : at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • WM8988_REG_FREQ48K : at_start_f435/examples/usb_device/audio/src/audio_codec.c, at_start_f435/examples/usb_device/composite_audio_hid/src/audio_codec.c, at_start_f437/examples/usb_device/audio/src/audio_codec.c, at_start_f437/examples/usb_device/composite_audio_hid/src/audio_codec.c
  • work : project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f437/examples/sdio/sdio_fatfs/src/main.c
  • write_read_addr : project/at_start_f435/examples/xmc/nor_flash/src/main.c, project/at_start_f435/examples/xmc/psram/src/main.c, project/at_start_f435/examples/xmc/sdram_basic/src/main.c, project/at_start_f435/examples/xmc/sdram_dma/src/main.c, project/at_start_f435/examples/xmc/sram/src/main.c, project/at_start_f437/examples/xmc/nor_flash/src/main.c, project/at_start_f437/examples/xmc/psram/src/main.c, project/at_start_f437/examples/xmc/sdram_basic/src/main.c, project/at_start_f437/examples/xmc/sdram_dma/src/main.c, project/at_start_f437/examples/xmc/sram/src/main.c
  • write_read_addr_struct : project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f437/examples/xmc/nand_flash/ecc/src/main.c, project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c
  • writereadstatus : project/at_start_f435/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f435/examples/xmc/nor_flash/src/main.c, project/at_start_f435/examples/xmc/psram/src/main.c, project/at_start_f435/examples/xmc/sdram_basic/src/main.c, project/at_start_f435/examples/xmc/sdram_dma/src/main.c, project/at_start_f435/examples/xmc/sram/src/main.c, project/at_start_f437/examples/xmc/nand_flash/nand/src/main.c, project/at_start_f437/examples/xmc/nor_flash/src/main.c, project/at_start_f437/examples/xmc/psram/src/main.c, project/at_start_f437/examples/xmc/sdram_basic/src/main.c, project/at_start_f437/examples/xmc/sdram_dma/src/main.c, project/at_start_f437/examples/xmc/sram/src/main.c
  • WWDT : at32f435_437_wwdt.h
  • WWDT_BASE : at32f435_437.h
  • wwdt_counter_set() : at32f435_437_wwdt.h, at32f435_437_wwdt.c
  • wwdt_divider_set() : at32f435_437_wwdt.h, at32f435_437_wwdt.c
  • wwdt_division_type : at32f435_437_wwdt.h
  • WWDT_EN_BIT : at32f435_437_wwdt.h
  • wwdt_enable() : at32f435_437_wwdt.h, at32f435_437_wwdt.c
  • wwdt_flag_clear() : at32f435_437_wwdt.h, at32f435_437_wwdt.c
  • wwdt_flag_get() : at32f435_437_wwdt.h, at32f435_437_wwdt.c
  • wwdt_interrupt_enable() : at32f435_437_wwdt.h, at32f435_437_wwdt.c
  • WWDT_IRQn : at32f435_437.h
  • WWDT_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • WWDT_PCLK1_DIV_16384 : at32f435_437_wwdt.h
  • WWDT_PCLK1_DIV_32768 : at32f435_437_wwdt.h
  • WWDT_PCLK1_DIV_4096 : at32f435_437_wwdt.h
  • WWDT_PCLK1_DIV_8192 : at32f435_437_wwdt.h
  • wwdt_reset() : at32f435_437_wwdt.h, at32f435_437_wwdt.c
  • wwdt_window_counter_set() : at32f435_437_wwdt.h, at32f435_437_wwdt.c


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- x -

  • x_pos : usbh_hid_mouse.c
  • xip_init_ly68l6400_config() : at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c
  • XMC_ACCESS_MODE_A : at32f435_437_xmc.h
  • XMC_ACCESS_MODE_B : at32f435_437_xmc.h
  • XMC_ACCESS_MODE_C : at32f435_437_xmc.h
  • XMC_ACCESS_MODE_D : at32f435_437_xmc.h
  • xmc_access_mode_type : at32f435_437_xmc.h
  • XMC_ASYN_WAIT_DISABLE : at32f435_437_xmc.h
  • XMC_ASYN_WAIT_ENABLE : at32f435_437_xmc.h
  • xmc_asyn_wait_type : at32f435_437_xmc.h
  • XMC_BANK1 : at32f435_437_xmc.h
  • XMC_BANK1_NOR_SRAM1 : at32f435_437_xmc.h
  • XMC_BANK1_NOR_SRAM2 : at32f435_437_xmc.h
  • XMC_BANK1_NOR_SRAM3 : at32f435_437_xmc.h
  • XMC_BANK1_NOR_SRAM4 : at32f435_437_xmc.h
  • XMC_BANK1_REG_BASE : at32f435_437.h
  • XMC_BANK2 : at32f435_437_xmc.h
  • XMC_BANK2_NAND : at32f435_437_xmc.h
  • XMC_BANK2_REG_BASE : at32f435_437.h
  • XMC_BANK3 : at32f435_437_xmc.h
  • XMC_BANK3_NAND : at32f435_437_xmc.h
  • XMC_BANK3_REG_BASE : at32f435_437.h
  • XMC_BANK4 : at32f435_437_xmc.h
  • XMC_BANK4_PCCARD : at32f435_437_xmc.h
  • XMC_BANK4_REG_BASE : at32f435_437.h
  • XMC_BANK5_6_SDRAM : at32f435_437_xmc.h
  • XMC_Bank_NAND : at_start_f435/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f435/examples/xmc/nand_flash/nand/inc/xmc_nand.h, at_start_f437/examples/xmc/nand_flash/ecc/inc/xmc_ecc.h, at_start_f437/examples/xmc/nand_flash/nand/inc/xmc_nand.h
  • xmc_bank_status_type : at32f435_437_xmc.h
  • xmc_burst_access_mode_type : at32f435_437_xmc.h
  • XMC_BURST_MODE_DISABLE : at32f435_437_xmc.h
  • XMC_BURST_MODE_ENABLE : at32f435_437_xmc.h
  • XMC_BUSTYPE_16_BITS : at32f435_437_xmc.h
  • XMC_BUSTYPE_8_BITS : at32f435_437_xmc.h
  • XMC_BUSY_FLAG : at32f435_437_xmc.h
  • XMC_CARD_MEM_BASE : at32f435_437.h
  • XMC_CAS_1 : at32f435_437_xmc.h
  • XMC_CAS_2 : at32f435_437_xmc.h
  • XMC_CAS_3 : at32f435_437_xmc.h
  • xmc_class_bank_type : at32f435_437_xmc.h
  • XMC_CLKDIV_2 : at32f435_437_xmc.h
  • XMC_CLKDIV_3 : at32f435_437_xmc.h
  • XMC_CLKDIV_4 : at32f435_437_xmc.h
  • XMC_CMD_AUTO_REFRESH : at32f435_437_xmc.h
  • XMC_CMD_BANK1 : at32f435_437_xmc.h
  • XMC_CMD_BANK1_2 : at32f435_437_xmc.h
  • xmc_cmd_bank1_2_type : at32f435_437_xmc.h
  • XMC_CMD_BANK2 : at32f435_437_xmc.h
  • XMC_CMD_CLK : at32f435_437_xmc.h
  • XMC_CMD_LOAD_MODE : at32f435_437_xmc.h
  • XMC_CMD_NORMAL : at32f435_437_xmc.h
  • XMC_CMD_POWER_DOWN : at32f435_437_xmc.h
  • XMC_CMD_PRECHARG_ALL : at32f435_437_xmc.h
  • XMC_CMD_SELF_REFRESH : at32f435_437_xmc.h
  • XMC_COLUMN_10 : at32f435_437_xmc.h
  • XMC_COLUMN_11 : at32f435_437_xmc.h
  • XMC_COLUMN_8 : at32f435_437_xmc.h
  • XMC_COLUMN_9 : at32f435_437_xmc.h
  • xmc_command_type : at32f435_437_xmc.h
  • XMC_DATA_ADDR_MUX_DISABLE : at32f435_437_xmc.h
  • XMC_DATA_ADDR_MUX_ENABLE : at32f435_437_xmc.h
  • xmc_data_addr_mux_type : at32f435_437_xmc.h
  • xmc_data_width_type : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_1 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_10 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_11 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_12 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_13 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_14 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_15 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_16 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_2 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_3 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_4 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_5 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_6 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_7 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_8 : at32f435_437_xmc.h
  • XMC_DELAY_CYCLE_9 : at32f435_437_xmc.h
  • XMC_DEVICE_NOR : at32f435_437_xmc.h
  • XMC_DEVICE_PSRAM : at32f435_437_xmc.h
  • XMC_DEVICE_SRAM : at32f435_437_xmc.h
  • xmc_ecc_enable_type : at32f435_437_xmc.h
  • xmc_ecc_get() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • XMC_ECC_OPERATION_DISABLE : at32f435_437_xmc.h
  • XMC_ECC_OPERATION_ENABLE : at32f435_437_xmc.h
  • XMC_ECC_PAGESIZE_1024_BYTES : at32f435_437_xmc.h
  • XMC_ECC_PAGESIZE_2048_BYTES : at32f435_437_xmc.h
  • XMC_ECC_PAGESIZE_256_BYTES : at32f435_437_xmc.h
  • XMC_ECC_PAGESIZE_4096_BYTES : at32f435_437_xmc.h
  • XMC_ECC_PAGESIZE_512_BYTES : at32f435_437_xmc.h
  • XMC_ECC_PAGESIZE_8192_BYTES : at32f435_437_xmc.h
  • xmc_ecc_pagesize_type : at32f435_437_xmc.h
  • XMC_ERR_FLAG : at32f435_437_xmc.h
  • xmc_ext_timing_config() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_extended_mode_type : at32f435_437_xmc.h
  • XMC_FALLINGEDGE_FLAG : at32f435_437_xmc.h
  • XMC_FEMPT_FLAG : at32f435_437_xmc.h
  • xmc_flag_clear() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_flag_status_get() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • XMC_INBK_2 : at32f435_437_xmc.h
  • XMC_INBK_4 : at32f435_437_xmc.h
  • xmc_init() : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.c, at_start_f435/examples/xmc/lcd_8bit/src/xmc_lcd.c, at_start_f435/examples/xmc/lcd_touch_16bit/src/xmc_lcd.c
  • XMC_INT_ERR : at32f435_437_xmc.h
  • XMC_INT_FALLING_EDGE : at32f435_437_xmc.h
  • XMC_INT_LEVEL : at32f435_437_xmc.h
  • XMC_INT_RISING_EDGE : at32f435_437_xmc.h
  • xmc_interrupt_enable() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_interrupt_flag_type : at32f435_437_xmc.h
  • xmc_interrupt_sources_type : at32f435_437_xmc.h
  • XMC_IRQn : at32f435_437.h
  • XMC_LCD_COMMAND : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • XMC_LCD_DATA : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h
  • XMC_LEVEL_FLAG : at32f435_437_xmc.h
  • XMC_MEM_BASE : at32f435_437.h
  • XMC_MEM_WIDTH_16 : at32f435_437_xmc.h
  • XMC_MEM_WIDTH_8 : at32f435_437_xmc.h
  • xmc_memory_type : at32f435_437_xmc.h
  • XMC_MODULE_ENABLED : project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f435/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f435/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f435/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f435/templates/inc/at32f435_437_conf.h, project/at_start_f437/examples/acc/calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/conversion_abort/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/resolution_6bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/vbat_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/communication_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/filter/inc/at32f435_437_conf.h, project/at_start_f437/examples/can/loopback_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/fpu/inc/at32f435_437_conf.h, project/at_start_f437/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/crc/calculation/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h, project/at_start_f437/examples/crm/sysclk_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h, project/at_start_f437/examples/debug/tmr1/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/dma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/burst_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/flash_to_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/link_list_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/dns_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/http_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/iperf/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/mqtt_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_client/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/tcp_server/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/telnet/inc/at32f435_437_conf.h, project/at_start_f437/examples/emac/wake_on_lan/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/bpr_domain/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/calendar/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/lick_calibration/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/time_stamp/inc/at32f435_437_conf.h, project/at_start_f437/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_config/inc/at32f435_437_conf.h, project/at_start_f437/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/fap_enable/inc/at32f435_437_conf.h, project/at_start_f437/examples/flash/flash_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/io_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/led_toggle/inc/at32f435_437_conf.h, project/at_start_f437/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_int/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_poll/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/communication_smbus/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2c/eeprom/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/ldo_set/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h, project/at_start_f437/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h, project/at_start_f437/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h, project/at_start_f437/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h, project/at_start_f437/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/spi/w25q_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/sram/extend_sram/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/6_steps/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/complementary_signals/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/dma_burst/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/external_clock/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/hang_mode/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/input_capture/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_high/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_low/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/one_cycle/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/timer_base/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h, project/at_start_f437/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/half_duplex/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/hw_flow_control/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/idle_detection/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/irda/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/printf/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/receiver_mute/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/rs485/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/smartcard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/synchronous/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h, project/at_start_f437/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/audio/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/custom_hid/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/keyboard/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/mouse/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/msc/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/printer/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/two_otg_device_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/vcp_loopback/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_comport/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_device/virtual_msc_iap/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/hid_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/msc_only_fat32/inc/at32f435_437_conf.h, project/at_start_f437/examples/usb_host/two_otg_host_demo/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/wdt/wdt_standby/inc/at32f435_437_conf.h, project/at_start_f437/examples/wwdt/wwdt_reset/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_8bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/lcd_touch_16bit/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/ecc/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nand_flash/nand/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/nor_flash/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/psram/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_basic/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sdram_dma/inc/at32f435_437_conf.h, project/at_start_f437/examples/xmc/sram/inc/at32f435_437_conf.h, project/at_start_f437/templates/inc/at32f435_437_conf.h, utilities/at32f435_437_freertos_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_gen_random_number_demo/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/iar_out/inc/at32f435_437_conf.h, utilities/at32f435_437_qspi_algorithm_demo/keil_flm/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l0/inc/at32f435_437_conf.h, utilities/at32f435_437_slib_demo/project_l1/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usart_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/app_led4_toggle/inc/at32f435_437_conf.h, utilities/at32f435_437_usb_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/inc/at32f435_437_conf.h, utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/at32f435_437_conf.h
  • xmc_nand_default_para_init() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_nand_ecc_enable() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_nand_enable() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_nand_init() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_nand_pccard_wait_type : at32f435_437_xmc.h
  • xmc_nand_reset() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_nand_timing_config() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_nand_timing_default_para_init() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • XMC_NO_CLK : at32f435_437_xmc.h
  • xmc_nor_sram_enable() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_nor_sram_init() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_nor_sram_reset() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_nor_sram_subbank_type : at32f435_437_xmc.h
  • xmc_nor_sram_timing_config() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_norsram_default_para_init() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_norsram_timing_default_para_init() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_pccard_default_para_init() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_pccard_enable() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_pccard_init() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_pccard_reset() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_pccard_timing_config() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_pccard_timing_default_para_init() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • XMC_READ_DELAY_0 : at32f435_437_xmc.h
  • XMC_READ_DELAY_1 : at32f435_437_xmc.h
  • XMC_READ_DELAY_2 : at32f435_437_xmc.h
  • XMC_REG_BASE : at32f435_437.h
  • XMC_RISINGEDGE_FLAG : at32f435_437_xmc.h
  • XMC_ROW_11 : at32f435_437_xmc.h
  • XMC_ROW_12 : at32f435_437_xmc.h
  • XMC_ROW_13 : at32f435_437_xmc.h
  • XMC_SDRAM : at32f435_437_xmc.h
  • xmc_sdram_auto_refresh_set() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • XMC_SDRAM_BANK1 : at32f435_437_xmc.h
  • XMC_SDRAM_BANK2 : at32f435_437_xmc.h
  • xmc_sdram_bank_type : at32f435_437_xmc.h
  • xmc_sdram_cas_type : at32f435_437_xmc.h
  • xmc_sdram_clkdiv_type : at32f435_437_xmc.h
  • xmc_sdram_cmd() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_sdram_column_type : at32f435_437_xmc.h
  • xmc_sdram_default_para_init() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_sdram_delay_type : at32f435_437_xmc.h
  • xmc_sdram_inbk_type : at32f435_437_xmc.h
  • xmc_sdram_init() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • XMC_SDRAM_MEM_BASE : at32f435_437.h
  • xmc_sdram_rd_delay_type : at32f435_437_xmc.h
  • xmc_sdram_refresh_counter_set() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • XMC_SDRAM_REG_BASE : at32f435_437.h
  • xmc_sdram_reset() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_sdram_row_type : at32f435_437_xmc.h
  • xmc_sdram_status_get() : at32f435_437_xmc.h, at32f435_437_xmc.c
  • xmc_sdram_width_type : at32f435_437_xmc.h
  • XMC_STATUS_MASK : at32f435_437_xmc.h
  • XMC_STATUS_NORMAL : at32f435_437_xmc.h
  • XMC_STATUS_POWER_DOWN : at32f435_437_xmc.h
  • XMC_STATUS_SELF_REFRESH : at32f435_437_xmc.h
  • XMC_WAIT_OPERATION_DISABLE : at32f435_437_xmc.h
  • XMC_WAIT_OPERATION_ENABLE : at32f435_437_xmc.h
  • XMC_WAIT_SIGNAL_DISABLE : at32f435_437_xmc.h
  • XMC_WAIT_SIGNAL_ENABLE : at32f435_437_xmc.h
  • XMC_WAIT_SIGNAL_LEVEL_HIGH : at32f435_437_xmc.h
  • XMC_WAIT_SIGNAL_LEVEL_LOW : at32f435_437_xmc.h
  • xmc_wait_signal_polarity_type : at32f435_437_xmc.h
  • XMC_WAIT_SIGNAL_SYN_BEFORE : at32f435_437_xmc.h
  • XMC_WAIT_SIGNAL_SYN_DURING : at32f435_437_xmc.h
  • xmc_wait_signal_type : at32f435_437_xmc.h
  • xmc_wait_timing_type : at32f435_437_xmc.h
  • xmc_wrap_mode_type : at32f435_437_xmc.h
  • XMC_WRAPPED_MODE_DISABLE : at32f435_437_xmc.h
  • XMC_WRAPPED_MODE_ENABLE : at32f435_437_xmc.h
  • XMC_WRITE_BURST_SYN_DISABLE : at32f435_437_xmc.h
  • XMC_WRITE_BURST_SYN_ENABLE : at32f435_437_xmc.h
  • xmc_write_burst_type : at32f435_437_xmc.h
  • XMC_WRITE_OPERATION_DISABLE : at32f435_437_xmc.h
  • XMC_WRITE_OPERATION_ENABLE : at32f435_437_xmc.h
  • xmc_write_operation_type : at32f435_437_xmc.h
  • XMC_WRITE_TIMING_DISABLE : at32f435_437_xmc.h
  • XMC_WRITE_TIMING_ENABLE : at32f435_437_xmc.h
  • xPortPendSVHandler : FreeRTOSConfig.h
  • xPortSysTickHandler : FreeRTOSConfig.h


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- y -

  • y_pos : usbh_hid_mouse.c
  • YELLOW : at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f435/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f435/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h, at_start_f437/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/dvp/ov5640_capture/hardware/lcd/xmc_lcd.h, at_start_f437/examples/xmc/lcd_8bit/inc/xmc_lcd.h, at_start_f437/examples/xmc/lcd_touch_16bit/inc/xmc_lcd.h


AT32F435/437 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- z -

  • ZOOM : project/at_start_f435/examples/cortex_m4/fpu/src/main.c, project/at_start_f437/examples/cortex_m4/fpu/src/main.c


AT32F435/437 Firmwary Library: hid_iap_class.c Source File

  • middlewares
  • usbd_class
  • hid_iap
hid_iap_class.c
Go to the documentation of this file.
1
26#include "usbd_core.h"
27#include "hid_iap_class.h"
28#include "hid_iap_desc.h"
29
44static usb_sts_type class_init_handler(void *udev);
45static usb_sts_type class_clear_handler(void *udev);
46static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
47static usb_sts_type class_ept0_tx_handler(void *udev);
48static usb_sts_type class_ept0_rx_handler(void *udev);
49static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
50static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
51static usb_sts_type class_sof_handler(void *udev);
52static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
53
54 iap_info_type iap_info;
55
56/* usb device class handler */
57usbd_class_handler hid_iap_class_handler =
58{
59 class_init_handler,
60 class_clear_handler,
61 class_setup_handler,
62 class_ept0_tx_handler,
63 class_ept0_rx_handler,
64 class_in_handler,
65 class_out_handler,
66 class_sof_handler,
67 class_event_handler,
68 &iap_info
69};
70
76static usb_sts_type class_init_handler(void *udev)
77{
78 usb_sts_type status = USB_OK;
79 usbd_core_type *pudev = (usbd_core_type *)udev;
80 iap_info_type *piap = (iap_info_type *)pudev->class_handler->pdata;
81 /* open hid iap in endpoint */
82 usbd_ept_open(pudev, USBD_HIDIAP_IN_EPT, EPT_INT_TYPE, USBD_HIDIAP_IN_MAXPACKET_SIZE);
83
84 /* open hid iap out endpoint */
85 usbd_ept_open(pudev, USBD_HIDIAP_OUT_EPT, EPT_INT_TYPE, USBD_HIDIAP_OUT_MAXPACKET_SIZE);
86
87 /* set out endpoint to receive status */
88 usbd_ept_recv(pudev, USBD_HIDIAP_OUT_EPT, piap->g_rxhid_buff, USBD_HIDIAP_OUT_MAXPACKET_SIZE);
89
90 return status;
91}
92
98static usb_sts_type class_clear_handler(void *udev)
99{
100 usb_sts_type status = USB_OK;
101 usbd_core_type *pudev = (usbd_core_type *)udev;
102
103 /* close hid iap in endpoint */
104 usbd_ept_close(pudev, USBD_HIDIAP_IN_EPT);
105
106 /* close hid iap out endpoint */
107 usbd_ept_close(pudev, USBD_HIDIAP_OUT_EPT);
108
109 return status;
110}
111
118static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
119{
120 usb_sts_type status = USB_OK;
121 usbd_core_type *pudev = (usbd_core_type *)udev;
122 iap_info_type *piap = (iap_info_type *)pudev->class_handler->pdata;
123 uint16_t len;
124 uint8_t *buf;
125
126 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
127 {
128 /* class request */
129 case USB_REQ_TYPE_CLASS:
130 switch(setup->bRequest)
131 {
132 case HID_REQ_SET_PROTOCOL:
133 piap->hid_protocol = (uint8_t)setup->wValue;
134 break;
135 case HID_REQ_GET_PROTOCOL:
136 usbd_ctrl_send(pudev, (uint8_t *)&piap->hid_protocol, 1);
137 break;
138 case HID_REQ_SET_IDLE:
139 piap->hid_set_idle = (uint8_t)(setup->wValue >> 8);
140 break;
141 case HID_REQ_GET_IDLE:
142 usbd_ctrl_send(pudev, (uint8_t *)&piap->hid_set_idle, 1);
143 break;
144 case HID_REQ_SET_REPORT:
145 piap->hid_state = HID_REQ_SET_REPORT;
146 usbd_ctrl_recv(pudev, piap->hid_set_report, setup->wLength);
147 break;
148 default:
149 usbd_ctrl_unsupport(pudev);
150 break;
151 }
152 break;
153 /* standard request */
154 case USB_REQ_TYPE_STANDARD:
155 switch(setup->bRequest)
156 {
157 case USB_STD_REQ_GET_DESCRIPTOR:
158 if(setup->wValue >> 8 == HID_REPORT_DESC)
159 {
160 len = MIN(USBD_HIDIAP_SIZ_REPORT_DESC, setup->wLength);
161 buf = (uint8_t *)g_usbd_hidiap_report;
162 }
163 else if(setup->wValue >> 8 == HID_DESCRIPTOR_TYPE)
164 {
165 len = MIN(9, setup->wLength);
166 buf = (uint8_t *)g_hidiap_usb_desc;
167 }
168 usbd_ctrl_send(pudev, (uint8_t *)buf, len);
169 break;
170 case USB_STD_REQ_GET_INTERFACE:
171 usbd_ctrl_send(pudev, (uint8_t *)&piap->alt_setting, 1);
172 break;
173 case USB_STD_REQ_SET_INTERFACE:
174 piap->alt_setting = setup->wValue;
175 break;
176 default:
177 break;
178 }
179 break;
180 default:
181 usbd_ctrl_unsupport(pudev);
182 break;
183 }
184 return status;
185}
186
192static usb_sts_type class_ept0_tx_handler(void *udev)
193{
194 usb_sts_type status = USB_OK;
195
196 /* ...user code... */
197
198 return status;
199}
200
206static usb_sts_type class_ept0_rx_handler(void *udev)
207{
208 usb_sts_type status = USB_OK;
209 usbd_core_type *pudev = (usbd_core_type *)udev;
210 iap_info_type *piap = (iap_info_type *)pudev->class_handler->pdata;
211 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
212 /* ...user code... */
213 if( piap->hid_state == HID_REQ_SET_REPORT)
214 {
215 /* hid buffer process */
216 piap->hid_state = 0;
217 }
218
219 return status;
220}
221
228static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
229{
230 usb_sts_type status = USB_OK;
231
232 /* ...user code...
233 trans next packet data
234 */
235 usbd_hid_iap_in_complete(udev);
236
237 return status;
238}
239
246static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
247{
248 usb_sts_type status = USB_OK;
249 usbd_core_type *pudev = (usbd_core_type *)udev;
250 iap_info_type *piap = (iap_info_type *)pudev->class_handler->pdata;
251
252 /* get endpoint receive data length */
253 uint32_t recv_len = usbd_get_recv_len(pudev, ept_num);
254
255 /* hid iap process */
256 usbd_hid_iap_process(udev, piap->g_rxhid_buff, recv_len);
257
258 /* start receive next packet */
259 usbd_ept_recv(pudev, USBD_HIDIAP_OUT_EPT, piap->g_rxhid_buff, USBD_HIDIAP_OUT_MAXPACKET_SIZE);
260
261 return status;
262}
263
269static usb_sts_type class_sof_handler(void *udev)
270{
271 usb_sts_type status = USB_OK;
272
273 /* ...user code... */
274
275 return status;
276}
277
284static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
285{
286 usb_sts_type status = USB_OK;
287 switch(event)
288 {
289 case USBD_RESET_EVENT:
290
291 /* ...user code... */
292
293 break;
294 case USBD_SUSPEND_EVENT:
295
296 /* ...user code... */
297
298 break;
299 case USBD_WAKEUP_EVENT:
300 /* ...user code... */
301
302 break;
303 default:
304 break;
305 }
306 return status;
307}
308
316 usb_sts_type usb_iap_class_send_report(void *udev, uint8_t *report, uint16_t len)
317{
318 usb_sts_type status = USB_OK;
319 usbd_core_type *pudev = (usbd_core_type *)udev;
320
321 if(usbd_connect_state_get(pudev) == USB_CONN_STATE_CONFIGURED)
322 usbd_ept_send(pudev, USBD_HIDIAP_IN_EPT, report, len);
323
324 return status;
325}
326
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f435_437_usb.h:349
USBD_HIDIAP_OUT_MAXPACKET_SIZE
#define USBD_HIDIAP_OUT_MAXPACKET_SIZE
Definition: hid_iap_class.h:56
usbd_hid_iap_process
iap_result_type usbd_hid_iap_process(void *udev, uint8_t *report, uint16_t len)
usb device iap function
Definition: app_led3_toggle/src/hid_iap_user.c:201
USBD_HIDIAP_IN_EPT
#define USBD_HIDIAP_IN_EPT
Definition: hid_iap_class.h:52
USBD_HIDIAP_OUT_EPT
#define USBD_HIDIAP_OUT_EPT
Definition: hid_iap_class.h:53
USBD_HIDIAP_IN_MAXPACKET_SIZE
#define USBD_HIDIAP_IN_MAXPACKET_SIZE
Definition: hid_iap_class.h:55
usbd_hid_iap_in_complete
void usbd_hid_iap_in_complete(void *udev)
usb device in transfer complete function
Definition: app_led3_toggle/src/hid_iap_user.c:247
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: hid_iap_class.c:269
iap_info
iap_info_type iap_info
Definition: hid_iap_class.c:54
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: hid_iap_class.c:228
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: hid_iap_class.c:98
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: hid_iap_class.c:118
usb_iap_class_send_report
usb_sts_type usb_iap_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: hid_iap_class.c:316
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: hid_iap_class.c:192
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: hid_iap_class.c:206
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: hid_iap_class.c:284
hid_iap_class_handler
usbd_class_handler hid_iap_class_handler
Definition: hid_iap_class.c:57
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: hid_iap_class.c:76
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: hid_iap_class.c:246
g_hidiap_usb_desc
uint8_t g_hidiap_usb_desc[9]
usb hid descriptor
Definition: hid_iap_desc.c:200
USBD_HIDIAP_SIZ_REPORT_DESC
#define USBD_HIDIAP_SIZ_REPORT_DESC
Definition: hid_iap_desc.h:57
g_usbd_hidiap_report
uint8_t g_usbd_hidiap_report[32]
usb hid report descriptor
Definition: hid_iap_desc.c:169
HID_DESCRIPTOR_TYPE
#define HID_DESCRIPTOR_TYPE
Definition: usb_std.h:236
HID_REQ_GET_PROTOCOL
#define HID_REQ_GET_PROTOCOL
Definition: usb_std.h:231
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:254
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:63
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:81
HID_REQ_SET_PROTOCOL
#define HID_REQ_SET_PROTOCOL
usb hid class request code define
Definition: usb_std.h:230
HID_REPORT_DESC
#define HID_REPORT_DESC
Definition: usb_std.h:237
HID_REQ_SET_IDLE
#define HID_REQ_SET_IDLE
Definition: usb_std.h:232
HID_REQ_GET_IDLE
#define HID_REQ_GET_IDLE
Definition: usb_std.h:233
HID_REQ_SET_REPORT
#define HID_REQ_SET_REPORT
Definition: usb_std.h:234
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:86
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:66
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:85
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:64
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:131
USB_OK
@ USB_OK
Definition: usb_std.h:268
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:597
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:346
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint receive data
Definition: usbd_core.c:534
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:314
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:177
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint send data
Definition: usbd_core.c:434
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
get endpoint receive data length
Definition: usbd_core.c:300
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint recv data
Definition: usbd_core.c:196
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:287
hid_iap_class.h
usb hid iap header file
hid_iap_desc.h
usb hid iap descriptor header file
iap_info_type
Definition: hid_iap_class.h:105
iap_info_type::hid_state
uint32_t hid_state
Definition: hid_iap_class.h:130
iap_info_type::hid_set_idle
uint32_t hid_set_idle
Definition: hid_iap_class.h:128
iap_info_type::hid_protocol
uint32_t hid_protocol
Definition: hid_iap_class.h:127
iap_info_type::hid_set_report
uint8_t hid_set_report[64]
Definition: hid_iap_class.h:131
iap_info_type::alt_setting
uint32_t alt_setting
Definition: hid_iap_class.h:129
iap_info_type::g_rxhid_buff
uint8_t g_rxhid_buff[0x40]
Definition: hid_iap_class.h:126
usb_setup_type
format of usb setup data
Definition: usb_std.h:280
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:283
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:286
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:281
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:282
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: hid_iap_class.h Source File

  • middlewares
  • usbd_class
  • hid_iap
hid_iap_class.h
Go to the documentation of this file.
1
27 /* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __HID_IAP_CLASS_H
29#define __HID_IAP_CLASS_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "usb_std.h"
36#include "usbd_core.h"
37
38
52#define USBD_HIDIAP_IN_EPT 0x81
53#define USBD_HIDIAP_OUT_EPT 0x01
54
55#define USBD_HIDIAP_IN_MAXPACKET_SIZE 0x40
56#define USBD_HIDIAP_OUT_MAXPACKET_SIZE 0x40
57
58#define FLASH_SIZE_REG() ((*(uint32_t *)0x1FFFF7E0) & 0xFFFF) /*Get Flash size*/
59#define KB_TO_B(kb) ((kb) << 10)
60
61#define SECTOR_SIZE_1K 0x400
62#define SECTOR_SIZE_2K 0x800
63#define SECTOR_SIZE_4K 0x1000
64
68#define IAP_CMD_IDLE 0x5AA0
69#define IAP_CMD_START 0x5AA1
70#define IAP_CMD_ADDR 0x5AA2
71#define IAP_CMD_DATA 0x5AA3
72#define IAP_CMD_FINISH 0x5AA4
73#define IAP_CMD_CRC 0x5AA5
74#define IAP_CMD_JMP 0x5AA6
75#define IAP_CMD_GET 0x5AA7
76
77#define HID_IAP_BUFFER_LEN 1024
78#define IAP_UPGRADE_COMPLETE_FLAG 0x41544B38
79#define CONVERT_ENDIAN(dwValue) ((dwValue >> 24) | ((dwValue >> 8) & 0xFF00) | \
80 ((dwValue << 8) & 0xFF0000) | (dwValue << 24) )
81
82#define IAP_ACK 0xFF00
83#define IAP_NACK 0x00FF
84
85typedef enum
86{
87 IAP_SUCCESS,
88 IAP_WAIT,
89 IAP_FAILED
90}iap_result_type;
91
92typedef enum
93{
94 IAP_STS_IDLE,
95 IAP_STS_START,
96 IAP_STS_ADDR,
97 IAP_STS_DATA,
98 IAP_STS_FINISH,
99 IAP_STS_CRC,
100 IAP_STS_JMP_WAIT,
101 IAP_STS_JMP,
102}iap_machine_state_type;
103
104typedef struct
105{
106
107 uint8_t iap_fifo[HID_IAP_BUFFER_LEN];
108 uint8_t iap_rx[USBD_HIDIAP_OUT_MAXPACKET_SIZE];
109 uint8_t iap_tx[USBD_HIDIAP_IN_MAXPACKET_SIZE];
110
111 uint32_t fifo_length;
112 uint32_t tx_length;
113
114 uint32_t app_address;
115 uint32_t iap_address;
116 uint32_t flag_address;
117
118 uint32_t flash_start_address;
119 uint32_t flash_end_address;
120
121 uint32_t sector_size;
122 uint32_t flash_size;
123
124 uint32_t respond_flag;
125
126 uint8_t g_rxhid_buff[USBD_HIDIAP_OUT_MAXPACKET_SIZE];
127 uint32_t hid_protocol;
128 uint32_t hid_set_idle;
129 uint32_t alt_setting;
130 uint32_t hid_state;
131 uint8_t hid_set_report[64];
132
133 iap_machine_state_type state;
134}iap_info_type;
135
136extern usbd_class_handler hid_iap_class_handler;
137extern iap_info_type iap_info;
138 usb_sts_type usb_iap_class_send_report(void *udev, uint8_t *report, uint16_t len);
139 iap_result_type usbd_hid_iap_process(void *udev, uint8_t *report, uint16_t len);
140void usbd_hid_iap_in_complete(void *udev);
141
153#ifdef __cplusplus
154}
155#endif
156
157#endif
158
159
iap_info
iap_info_type iap_info
Definition: hid_iap_class.c:54
HID_IAP_BUFFER_LEN
#define HID_IAP_BUFFER_LEN
Definition: hid_iap_class.h:77
USBD_HIDIAP_OUT_MAXPACKET_SIZE
#define USBD_HIDIAP_OUT_MAXPACKET_SIZE
Definition: hid_iap_class.h:56
usb_iap_class_send_report
usb_sts_type usb_iap_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: hid_iap_class.c:316
iap_result_type
iap_result_type
Definition: hid_iap_class.h:86
usbd_hid_iap_process
iap_result_type usbd_hid_iap_process(void *udev, uint8_t *report, uint16_t len)
usb device iap function
Definition: app_led3_toggle/src/hid_iap_user.c:201
hid_iap_class_handler
usbd_class_handler hid_iap_class_handler
Definition: hid_iap_class.c:57
iap_machine_state_type
iap_machine_state_type
Definition: hid_iap_class.h:93
USBD_HIDIAP_IN_MAXPACKET_SIZE
#define USBD_HIDIAP_IN_MAXPACKET_SIZE
Definition: hid_iap_class.h:55
usbd_hid_iap_in_complete
void usbd_hid_iap_in_complete(void *udev)
usb device in transfer complete function
Definition: app_led3_toggle/src/hid_iap_user.c:247
IAP_WAIT
@ IAP_WAIT
Definition: hid_iap_class.h:88
IAP_FAILED
@ IAP_FAILED
Definition: hid_iap_class.h:89
IAP_SUCCESS
@ IAP_SUCCESS
Definition: hid_iap_class.h:87
IAP_STS_START
@ IAP_STS_START
Definition: hid_iap_class.h:95
IAP_STS_JMP
@ IAP_STS_JMP
Definition: hid_iap_class.h:101
IAP_STS_DATA
@ IAP_STS_DATA
Definition: hid_iap_class.h:97
IAP_STS_JMP_WAIT
@ IAP_STS_JMP_WAIT
Definition: hid_iap_class.h:100
IAP_STS_IDLE
@ IAP_STS_IDLE
Definition: hid_iap_class.h:94
IAP_STS_FINISH
@ IAP_STS_FINISH
Definition: hid_iap_class.h:98
IAP_STS_ADDR
@ IAP_STS_ADDR
Definition: hid_iap_class.h:96
IAP_STS_CRC
@ IAP_STS_CRC
Definition: hid_iap_class.h:99
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
iap_info_type
Definition: hid_iap_class.h:105
iap_info_type::respond_flag
uint32_t respond_flag
Definition: hid_iap_class.h:124
iap_info_type::hid_state
uint32_t hid_state
Definition: hid_iap_class.h:130
iap_info_type::flag_address
uint32_t flag_address
Definition: hid_iap_class.h:116
iap_info_type::sector_size
uint32_t sector_size
Definition: hid_iap_class.h:121
iap_info_type::iap_address
uint32_t iap_address
Definition: hid_iap_class.h:115
iap_info_type::flash_start_address
uint32_t flash_start_address
Definition: hid_iap_class.h:118
iap_info_type::flash_end_address
uint32_t flash_end_address
Definition: hid_iap_class.h:119
iap_info_type::fifo_length
uint32_t fifo_length
Definition: hid_iap_class.h:111
iap_info_type::hid_set_idle
uint32_t hid_set_idle
Definition: hid_iap_class.h:128
iap_info_type::hid_protocol
uint32_t hid_protocol
Definition: hid_iap_class.h:127
iap_info_type::tx_length
uint32_t tx_length
Definition: hid_iap_class.h:112
iap_info_type::flash_size
uint32_t flash_size
Definition: hid_iap_class.h:122
iap_info_type::app_address
uint32_t app_address
Definition: hid_iap_class.h:114
iap_info_type::alt_setting
uint32_t alt_setting
Definition: hid_iap_class.h:129
iap_info_type::state
iap_machine_state_type state
Definition: hid_iap_class.h:133
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: hid_iap_desc.c Source File

  • middlewares
  • usbd_class
  • hid_iap
hid_iap_desc.c
Go to the documentation of this file.
1
26#include "usb_std.h"
27#include "usbd_sdr.h"
28#include "usbd_core.h"
29#include "hid_iap_desc.h"
30
31
46static usbd_desc_t *get_device_descriptor(void);
47static usbd_desc_t *get_device_qualifier(void);
48static usbd_desc_t *get_device_configuration(void);
49static usbd_desc_t *get_device_other_speed(void);
50static usbd_desc_t *get_device_lang_id(void);
51static usbd_desc_t *get_device_manufacturer_string(void);
52static usbd_desc_t *get_device_product_string(void);
53static usbd_desc_t *get_device_serial_string(void);
54static usbd_desc_t *get_device_interface_string(void);
55static usbd_desc_t *get_device_config_string(void);
56
57static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
58static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
59static void get_serial_num(void);
60static uint8_t g_usbd_desc_buffer[256];
61
65usbd_desc_handler hid_iap_desc_handler =
66{
67 get_device_descriptor,
68 get_device_qualifier,
69 get_device_configuration,
70 get_device_other_speed,
71 get_device_lang_id,
72 get_device_manufacturer_string,
73 get_device_product_string,
74 get_device_serial_string,
75 get_device_interface_string,
76 get_device_config_string,
77};
78
82#if defined ( __ICCARM__ ) /* iar compiler */
83 #pragma data_alignment=4
84#endif
85ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
86{
87 USB_DEVICE_DESC_LEN, /* bLength */
88 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
89 0x00, /* bcdUSB */
90 0x02,
91 0x00, /* bDeviceClass */
92 0x00, /* bDeviceSubClass */
93 0x00, /* bDeviceProtocol */
94 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
95 LBYTE(USBD_HIDIAP_VENDOR_ID), /* idVendor */
96 HBYTE(USBD_HIDIAP_VENDOR_ID), /* idVendor */
97 LBYTE(USBD_HIDIAP_PRODUCT_ID), /* idProduct */
98 HBYTE(USBD_HIDIAP_PRODUCT_ID), /* idProduct */
99 0x00, /* bcdDevice rel. 2.00 */
100 0x02,
101 USB_MFC_STRING, /* Index of manufacturer string */
102 USB_PRODUCT_STRING, /* Index of product string */
103 USB_SERIAL_STRING, /* Index of serial number string */
104 1 /* bNumConfigurations */
105};
106
110#if defined ( __ICCARM__ ) /* iar compiler */
111 #pragma data_alignment=4
112#endif
113ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_HIDIAP_CONFIG_DESC_SIZE] ALIGNED_TAIL =
114{
115 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
116 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
117 LBYTE(USBD_HIDIAP_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
118 HBYTE(USBD_HIDIAP_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
119 0x01, /* bNumInterfaces: 1 interface */
120 0x01, /* bConfigurationValue: configuration value */
121 0x00, /* iConfiguration: index of string descriptor describing
122 the configuration */
123 0xC0, /* bmAttributes: self powered */
124 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
125
126 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
127 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
128 0x00, /* bInterfaceNumber: number of interface */
129 0x00, /* bAlternateSetting: alternate set */
130 0x02, /* bNumEndpoints: number of endpoints */
131 USB_CLASS_CODE_HID, /* bInterfaceClass: class code hid */
132 0x00, /* bInterfaceSubClass: subclass code */
133 0x00, /* bInterfaceProtocol: protocol code */
134 0x00, /* iInterface: index of string descriptor */
135
136 0x09, /* bLength: size of HID descriptor in bytes */
137 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
138 LBYTE(HIDIAP_BCD_NUM),
139 HBYTE(HIDIAP_BCD_NUM), /* bcdHID: HID class specification release number */
140 0x00, /* bCountryCode: hardware target conutry */
141 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
142 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
143 LBYTE(sizeof(g_usbd_hidiap_report)),
144 HBYTE(sizeof(g_usbd_hidiap_report)), /* wDescriptorLength: total length of reprot descriptor */
145
146 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
147 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
148 USBD_HIDIAP_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
149 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
150 LBYTE(USBD_HIDIAP_IN_MAXPACKET_SIZE),
151 HBYTE(USBD_HIDIAP_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
152 HIDIAP_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
153
154 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
155 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
156 USBD_HIDIAP_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
157 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
158 LBYTE(USBD_HIDIAP_OUT_MAXPACKET_SIZE),
159 HBYTE(USBD_HIDIAP_OUT_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
160 HIDIAP_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
161};
162
166#if defined ( __ICCARM__ ) /* iar compiler */
167 #pragma data_alignment=4
168#endif
169ALIGNED_HEAD uint8_t g_usbd_hidiap_report[USBD_HIDIAP_SIZ_REPORT_DESC] ALIGNED_TAIL =
170{
171 0x06, 0xFF, 0x00, /* USAGE_PAGE(Vendor Page:0xFF00) */
172 0x09, 0x01, /* USAGE (Demo Kit) */
173 0xa1, 0x01, /* COLLECTION (Application) */
174
175 /* 6 */
176 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
177 0x25, 0xFF, /* LOGICAL_MAXIMUM (255) */
178 0x75, 0x08, /* REPORT_SIZE (8) */
179 0x95, 0x40, /* REPORT_COUNT (64) */
180
181 0x09, 0x01,
182 0x81, 0x02,
183 0x95, 0x40,
184
185 0x09, 0x01,
186 0x91, 0x02,
187 0x95, 0x01,
188
189 0x09, 0x01,
190 0xB1, 0x02,
191 0xC0
192};
193
197#if defined ( __ICCARM__ ) /* iar compiler */
198 #pragma data_alignment=4
199#endif
200ALIGNED_HEAD uint8_t g_hidiap_usb_desc[9] ALIGNED_TAIL =
201{
202 0x09, /* bLength: size of HID descriptor in bytes */
203 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
204 LBYTE(HIDIAP_BCD_NUM),
205 HBYTE(HIDIAP_BCD_NUM), /* bcdHID: HID class specification release number */
206 0x00, /* bCountryCode: hardware target conutry */
207 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
208 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
209 LBYTE(sizeof(g_usbd_hidiap_report)),
210 HBYTE(sizeof(g_usbd_hidiap_report)), /* wDescriptorLength: total length of reprot descriptor */
211};
212
213
217#if defined ( __ICCARM__ ) /* iar compiler */
218 #pragma data_alignment=4
219#endif
220ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_HIDIAP_SIZ_STRING_LANGID] ALIGNED_TAIL =
221{
222 USBD_HIDIAP_SIZ_STRING_LANGID,
223 USB_DESCIPTOR_TYPE_STRING,
224 0x09,
225 0x04,
226};
227
231#if defined ( __ICCARM__ ) /* iar compiler */
232 #pragma data_alignment=4
233#endif
234ALIGNED_HEAD static uint8_t g_string_serial[USBD_HIDIAP_SIZ_STRING_SERIAL] ALIGNED_TAIL =
235{
236 USBD_HIDIAP_SIZ_STRING_SERIAL,
237 USB_DESCIPTOR_TYPE_STRING,
238};
239
240
241/* device descriptor */
242static usbd_desc_t device_descriptor =
243{
244 USB_DEVICE_DESC_LEN,
245 g_usbd_descriptor
246};
247
248/* config descriptor */
249static usbd_desc_t config_descriptor =
250{
251 USBD_HIDIAP_CONFIG_DESC_SIZE,
252 g_usbd_configuration
253};
254
255/* langid descriptor */
256static usbd_desc_t langid_descriptor =
257{
258 USBD_HIDIAP_SIZ_STRING_LANGID,
259 g_string_lang_id
260};
261
262/* serial descriptor */
263static usbd_desc_t serial_descriptor =
264{
265 USBD_HIDIAP_SIZ_STRING_SERIAL,
266 g_string_serial
267};
268
269static usbd_desc_t vp_desc;
270
277static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
278{
279 uint16_t str_len = 0, id_pos = 2;
280 uint8_t *tmp_str = string;
281
282 while(*tmp_str != '\0')
283 {
284 str_len ++;
285 unicode_buf[id_pos ++] = *tmp_str ++;
286 unicode_buf[id_pos ++] = 0x00;
287 }
288
289 str_len = str_len * 2 + 2;
290 unicode_buf[0] = str_len;
291 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
292
293 return str_len;
294}
295
303static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
304{
305 uint8_t idx = 0;
306
307 for( idx = 0 ; idx < len ; idx ++)
308 {
309 if( ((value >> 28)) < 0xA )
310 {
311 pbuf[ 2 * idx] = (value >> 28) + '0';
312 }
313 else
314 {
315 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
316 }
317
318 value = value << 4;
319
320 pbuf[2 * idx + 1] = 0;
321 }
322}
323
329static void get_serial_num(void)
330{
331 uint32_t serial0, serial1, serial2;
332
333 serial0 = *(uint32_t*)MCU_ID1;
334 serial1 = *(uint32_t*)MCU_ID2;
335 serial2 = *(uint32_t*)MCU_ID3;
336
337 serial0 += serial2;
338
339 if (serial0 != 0)
340 {
341 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
342 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
343 }
344}
345
351static usbd_desc_t *get_device_descriptor(void)
352{
353 return &device_descriptor;
354}
355
361static usbd_desc_t * get_device_qualifier(void)
362{
363 return NULL;
364}
365
371static usbd_desc_t *get_device_configuration(void)
372{
373 return &config_descriptor;
374}
375
381static usbd_desc_t *get_device_other_speed(void)
382{
383 return NULL;
384}
385
391static usbd_desc_t *get_device_lang_id(void)
392{
393 return &langid_descriptor;
394}
395
396
402static usbd_desc_t *get_device_manufacturer_string(void)
403{
404 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_HIDIAP_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
405 vp_desc.descriptor = g_usbd_desc_buffer;
406 return &vp_desc;
407}
408
414static usbd_desc_t *get_device_product_string(void)
415{
416 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_HIDIAP_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
417 vp_desc.descriptor = g_usbd_desc_buffer;
418 return &vp_desc;
419}
420
426static usbd_desc_t *get_device_serial_string(void)
427{
428 get_serial_num();
429 return &serial_descriptor;
430}
431
437static usbd_desc_t *get_device_interface_string(void)
438{
439 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_HIDIAP_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
440 vp_desc.descriptor = g_usbd_desc_buffer;
441 return &vp_desc;
442}
443
449static usbd_desc_t *get_device_config_string(void)
450{
451 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_HIDIAP_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
452 vp_desc.descriptor = g_usbd_desc_buffer;
453 return &vp_desc;
454}
455
idx
uint32_t idx
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:46
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:215
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:216
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:217
USBD_HIDIAP_OUT_MAXPACKET_SIZE
#define USBD_HIDIAP_OUT_MAXPACKET_SIZE
Definition: hid_iap_class.h:56
USBD_HIDIAP_IN_EPT
#define USBD_HIDIAP_IN_EPT
Definition: hid_iap_class.h:52
USBD_HIDIAP_OUT_EPT
#define USBD_HIDIAP_OUT_EPT
Definition: hid_iap_class.h:53
USBD_HIDIAP_IN_MAXPACKET_SIZE
#define USBD_HIDIAP_IN_MAXPACKET_SIZE
Definition: hid_iap_class.h:55
USBD_HIDIAP_SIZ_STRING_LANGID
#define USBD_HIDIAP_SIZ_STRING_LANGID
Definition: hid_iap_desc.h:58
USBD_HIDIAP_SIZ_STRING_SERIAL
#define USBD_HIDIAP_SIZ_STRING_SERIAL
Definition: hid_iap_desc.h:59
USBD_HIDIAP_VENDOR_ID
#define USBD_HIDIAP_VENDOR_ID
Definition: hid_iap_desc.h:53
HIDIAP_BCD_NUM
#define HIDIAP_BCD_NUM
Definition: hid_iap_desc.h:51
g_hidiap_usb_desc
uint8_t g_hidiap_usb_desc[9]
usb hid descriptor
Definition: hid_iap_desc.c:200
USBD_HIDIAP_SIZ_REPORT_DESC
#define USBD_HIDIAP_SIZ_REPORT_DESC
Definition: hid_iap_desc.h:57
USBD_HIDIAP_DESC_INTERFACE_STRING
#define USBD_HIDIAP_DESC_INTERFACE_STRING
Definition: hid_iap_desc.h:64
HIDIAP_BINTERVAL_TIME
#define HIDIAP_BINTERVAL_TIME
Definition: hid_iap_desc.h:66
USBD_HIDIAP_DESC_CONFIGURATION_STRING
#define USBD_HIDIAP_DESC_CONFIGURATION_STRING
Definition: hid_iap_desc.h:63
USBD_HIDIAP_DESC_MANUFACTURER_STRING
#define USBD_HIDIAP_DESC_MANUFACTURER_STRING
Definition: hid_iap_desc.h:61
USBD_HIDIAP_DESC_PRODUCT_STRING
#define USBD_HIDIAP_DESC_PRODUCT_STRING
Definition: hid_iap_desc.h:62
USBD_HIDIAP_CONFIG_DESC_SIZE
#define USBD_HIDIAP_CONFIG_DESC_SIZE
Definition: hid_iap_desc.h:56
USBD_HIDIAP_PRODUCT_ID
#define USBD_HIDIAP_PRODUCT_ID
Definition: hid_iap_desc.h:54
g_usbd_hidiap_report
uint8_t g_usbd_hidiap_report[32]
usb hid report descriptor
Definition: hid_iap_desc.c:169
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: hid_iap_desc.c:263
device_descriptor
static usbd_desc_t device_descriptor
Definition: hid_iap_desc.c:242
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: hid_iap_desc.c:371
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: hid_iap_desc.c:256
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: hid_iap_desc.c:351
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: hid_iap_desc.c:402
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: hid_iap_desc.c:361
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: hid_iap_desc.c:437
g_usbd_desc_buffer
static uint8_t g_usbd_desc_buffer[256]
Definition: hid_iap_desc.c:60
vp_desc
static usbd_desc_t vp_desc
Definition: hid_iap_desc.c:269
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: hid_iap_desc.c:381
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL
usb device standard descriptor
Definition: hid_iap_desc.c:85
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: hid_iap_desc.c:414
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: hid_iap_desc.c:449
hid_iap_desc_handler
usbd_desc_handler hid_iap_desc_handler
hid device descriptor handler structure
Definition: hid_iap_desc.c:65
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: hid_iap_desc.c:277
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: hid_iap_desc.c:391
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: hid_iap_desc.c:329
config_descriptor
static usbd_desc_t config_descriptor
Definition: hid_iap_desc.c:249
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: hid_iap_desc.c:426
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: hid_iap_desc.c:303
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:153
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:93
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: usb_std.h:223
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: usb_std.h:224
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:96
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:152
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:151
USB_EPT_DESC_INTERRUPT
#define USB_EPT_DESC_INTERRUPT
Definition: usb_std.h:178
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:94
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:95
USB_CLASS_CODE_HID
#define USB_CLASS_CODE_HID
Definition: usb_std.h:163
hid_iap_desc.h
usb hid iap descriptor header file
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h


AT32F435/437 Firmwary Library: hid_iap_desc.h Source File

  • middlewares
  • usbd_class
  • hid_iap
hid_iap_desc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __HID_IAP_DESC_H
29#define __HID_IAP_DESC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "hid_iap_class.h"
36#include "usbd_core.h"
37
51#define HIDIAP_BCD_NUM 0x0110
52
53#define USBD_HIDIAP_VENDOR_ID 0x2E3C
54#define USBD_HIDIAP_PRODUCT_ID 0xAF01
55
56#define USBD_HIDIAP_CONFIG_DESC_SIZE 41
57#define USBD_HIDIAP_SIZ_REPORT_DESC 32
58#define USBD_HIDIAP_SIZ_STRING_LANGID 4
59#define USBD_HIDIAP_SIZ_STRING_SERIAL 0x1A
60
61#define USBD_HIDIAP_DESC_MANUFACTURER_STRING "Artery"
62#define USBD_HIDIAP_DESC_PRODUCT_STRING "HID IAP"
63#define USBD_HIDIAP_DESC_CONFIGURATION_STRING "HID IAP Config"
64#define USBD_HIDIAP_DESC_INTERFACE_STRING "HID IAP Interface"
65
66#define HIDIAP_BINTERVAL_TIME 0x01
67
68#define MCU_ID1 (0x1FFFF7E8)
69#define MCU_ID2 (0x1FFFF7EC)
70#define MCU_ID3 (0x1FFFF7F0)
71extern uint8_t g_usbd_hidiap_report[USBD_HIDIAP_SIZ_REPORT_DESC];
72extern uint8_t g_hidiap_usb_desc[9];
73
74extern usbd_desc_handler hid_iap_desc_handler;
75
76
89#ifdef __cplusplus
90}
91#endif
92
93#endif
94
g_hidiap_usb_desc
uint8_t g_hidiap_usb_desc[9]
usb hid descriptor
Definition: hid_iap_desc.c:200
USBD_HIDIAP_SIZ_REPORT_DESC
#define USBD_HIDIAP_SIZ_REPORT_DESC
Definition: hid_iap_desc.h:57
hid_iap_desc_handler
usbd_desc_handler hid_iap_desc_handler
hid device descriptor handler structure
Definition: hid_iap_desc.c:65
g_usbd_hidiap_report
uint8_t g_usbd_hidiap_report[32]
usb hid report descriptor
Definition: hid_iap_desc.c:169
hid_iap_class.h
usb hid iap header file
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: httpd.c File Reference

  • at_start_f437
  • examples
  • emac
  • http_server
  • src
Data Structures | Macros | Functions | Variables
httpd.c File Reference
#include "lwip/init.h"
#include "lwip/apps/httpd.h"
#include "lwip/debug.h"
#include "lwip/stats.h"
#include "lwip/apps/fs.h"
#include "httpd_structs.h"
#include "lwip/def.h"
#include "lwip/altcp.h"
#include "lwip/altcp_tcp.h"
#include <string.h>
#include <stdlib.h>
#include <stdio.h>
#include "at32f435_437_adc.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Data Structures

struct | default_filename
struct | http_state

Macros

#define | MIN_REQ_LEN 7
#define | CRLF "\r\n"
#define | HTTP_IS_DYNAMIC_FILE(hs) 0
#define | HTTP_IS_DATA_VOLATILE(hs) (HTTP_IS_DYNAMIC_FILE(hs) ? TCP_WRITE_FLAG_COPY : 0)
#define | HTTP_IS_HDR_VOLATILE(hs, ptr) 0
#define | HTTP_DATA_TO_SEND_FREED 3
#define | HTTP_DATA_TO_SEND_BREAK 2
#define | HTTP_DATA_TO_SEND_CONTINUE 1
#define | HTTP_NO_DATA_TO_SEND 0
#define | CUSTOM_HTTP_SERVER
#define | NUM_DEFAULT_FILENAMES LWIP_ARRAYSIZE(httpd_default_filenames)
#define | LWIP_HTTPD_URI_BUF_LEN LWIP_HTTPD_MAX_REQUEST_URI_LEN
#define | HTTP_ALLOC_HTTP_STATE() (struct http_state *)mem_malloc(sizeof(struct http_state))
#define | HTTP_FREE_HTTP_STATE(x) mem_free(x)
#define | http_add_connection(hs)
#define | http_remove_connection(hs)
#define | http_find_error_file(hs, error_nr) ERR_ARG

Functions

static err_t | http_close_conn (struct altcp_pcb *pcb, struct http_state *hs)
static err_t | http_close_or_abort_conn (struct altcp_pcb *pcb, struct http_state *hs, uint8_t abort_conn)
static err_t | http_poll (void *arg, struct altcp_pcb *pcb)
static uint8_t | http_check_eof (struct altcp_pcb *pcb, struct http_state *hs)
static void | http_state_init (struct http_state *hs)
static struct http_state * | http_state_alloc (void)
static void | http_state_eof (struct http_state *hs)
static void | http_state_free (struct http_state *hs)
static err_t | http_write (struct altcp_pcb *pcb, const void *ptr, uint16_t *length, uint8_t apiflags)
static void | http_eof (struct altcp_pcb *pcb, struct http_state *hs)
static uint8_t | http_send_data_nonssi (struct altcp_pcb *pcb, struct http_state *hs)
static uint8_t | http_send (struct altcp_pcb *pcb, struct http_state *hs)
static void | http_err (void *arg, err_t err)
static err_t | http_sent (void *arg, struct altcp_pcb *pcb, uint16_t len)
static err_t | http_recv (void *arg, struct altcp_pcb *pcb, struct pbuf *p, err_t err)
static err_t | http_accept (void *arg, struct altcp_pcb *pcb, err_t err)
static void | httpd_init_pcb (struct altcp_pcb *pcb, uint16_t port)
void | httpd_init (void)

Variables

char html_tmp [4096] = {0}

Detailed Description

LWIP HTTP server implementation

Definition in file httpd.c.


AT32F435/437 Firmwary Library: httpd.c Source File

  • at_start_f437
  • examples
  • emac
  • http_server
  • src
httpd.c
Go to the documentation of this file.
1
6/*
7 * Copyright (c) 2001-2003 Swedish Institute of Computer Science.
8 * All rights reserved.
9 *
10 * Redistribution and use in source and binary forms, with or without modification,
11 * are permitted provided that the following conditions are met:
12 *
13 * 1. Redistributions of source code must retain the above copyright notice,
14 * this list of conditions and the following disclaimer.
15 * 2. Redistributions in binary form must reproduce the above copyright notice,
16 * this list of conditions and the following disclaimer in the documentation
17 * and/or other materials provided with the distribution.
18 * 3. The name of the author may not be used to endorse or promote products
19 * derived from this software without specific prior written permission.
20 *
21 * THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
22 * WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
23 * MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
24 * SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
25 * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT
26 * OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
27 * INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
28 * CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
29 * IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY
30 * OF SUCH DAMAGE.
31 *
32 * This file is part of the lwIP TCP/IP stack.
33 *
34 * Author: Adam Dunkels <adam@sics.se>
35 * Simon Goldschmidt
36 *
37 */
38
39#include "lwip/init.h"
40#include "lwip/apps/httpd.h"
41#include "lwip/debug.h"
42#include "lwip/stats.h"
43#include "lwip/apps/fs.h"
44#include "httpd_structs.h"
45#include "lwip/def.h"
46
47#include "lwip/altcp.h"
48#include "lwip/altcp_tcp.h"
49#if HTTPD_ENABLE_HTTPS
50#include "lwip/altcp_tls.h"
51#endif
52#ifdef LWIP_HOOK_FILENAME
53#include LWIP_HOOK_FILENAME
54#endif
55#if LWIP_HTTPD_TIMING
56#include "lwip/sys.h"
57#endif /* LWIP_HTTPD_TIMING */
58
59#include <string.h> /* memset */
60#include <stdlib.h> /* atoi */
61#include <stdio.h>
62
63#include "at32f435_437_adc.h"
64#include "at32f435_437_board.h"
65
74#if LWIP_TCP && LWIP_CALLBACK_API
75
77#define MIN_REQ_LEN 7
78
79#define CRLF "\r\n"
80#if LWIP_HTTPD_SUPPORT_11_KEEPALIVE
81#define HTTP11_CONNECTIONKEEPALIVE "Connection: keep-alive"
82#define HTTP11_CONNECTIONKEEPALIVE2 "Connection: Keep-Alive"
83#endif
84
85#if LWIP_HTTPD_DYNAMIC_FILE_READ
86#define HTTP_IS_DYNAMIC_FILE(hs) ((hs)->buf != NULL)
87#else
88#define HTTP_IS_DYNAMIC_FILE(hs) 0
89#endif
90
91/* This defines checks whether tcp_write has to copy data or not */
92
93#ifndef HTTP_IS_DATA_VOLATILE
95#define HTTP_IS_DATA_VOLATILE(hs) (HTTP_IS_DYNAMIC_FILE(hs) ? TCP_WRITE_FLAG_COPY : 0)
96#endif
98#ifndef HTTP_IS_HDR_VOLATILE
99#define HTTP_IS_HDR_VOLATILE(hs, ptr) 0
100#endif
101
102/* Return values for http_send_*() */
103#define HTTP_DATA_TO_SEND_FREED 3
104#define HTTP_DATA_TO_SEND_BREAK 2
105#define HTTP_DATA_TO_SEND_CONTINUE 1
106#define HTTP_NO_DATA_TO_SEND 0
107
108#define CUSTOM_HTTP_SERVER
109
110typedef struct {
111 const char *name;
112 uint8_t shtml;
113} default_filename;
114
115char html_tmp[4096] = {0};
116
117#define NUM_DEFAULT_FILENAMES LWIP_ARRAYSIZE(httpd_default_filenames)
118
119#if LWIP_HTTPD_SUPPORT_REQUESTLIST
121//static char httpd_req_buf[LWIP_HTTPD_MAX_REQ_LENGTH + 1];
122#endif /* LWIP_HTTPD_SUPPORT_REQUESTLIST */
123
124#if LWIP_HTTPD_SUPPORT_POST
125#if LWIP_HTTPD_POST_MAX_RESPONSE_URI_LEN > LWIP_HTTPD_MAX_REQUEST_URI_LEN
126#define LWIP_HTTPD_URI_BUF_LEN LWIP_HTTPD_POST_MAX_RESPONSE_URI_LEN
127#endif
128#endif
129#ifndef LWIP_HTTPD_URI_BUF_LEN
130#define LWIP_HTTPD_URI_BUF_LEN LWIP_HTTPD_MAX_REQUEST_URI_LEN
131#endif
132
133#if LWIP_HTTPD_DYNAMIC_HEADERS
134/* The number of individual strings that comprise the headers sent before each
135 * requested file.
136 */
137#define NUM_FILE_HDR_STRINGS 5
138#define HDR_STRINGS_IDX_HTTP_STATUS 0 /* e.g. "HTTP/1.0 200 OK\r\n" */
139#define HDR_STRINGS_IDX_SERVER_NAME 1 /* e.g. "Server: "HTTPD_SERVER_AGENT"\r\n" */
140#define HDR_STRINGS_IDX_CONTENT_LEN_KEEPALIVE 2 /* e.g. "Content-Length: xy\r\n" and/or "Connection: keep-alive\r\n" */
141#define HDR_STRINGS_IDX_CONTENT_LEN_NR 3 /* the byte count, when content-length is used */
142#define HDR_STRINGS_IDX_CONTENT_TYPE 4 /* the content type (or default answer content type including default document) */
143
144/* The dynamically generated Content-Length buffer needs space for CRLF + NULL */
145#define LWIP_HTTPD_MAX_CONTENT_LEN_OFFSET 3
146#ifndef LWIP_HTTPD_MAX_CONTENT_LEN_SIZE
147/* The dynamically generated Content-Length buffer shall be able to work with
148 ~953 MB (9 digits) */
149#define LWIP_HTTPD_MAX_CONTENT_LEN_SIZE (9 + LWIP_HTTPD_MAX_CONTENT_LEN_OFFSET)
150#endif
151#endif /* LWIP_HTTPD_DYNAMIC_HEADERS */
152
153#if LWIP_HTTPD_SSI
154
155#define HTTPD_LAST_TAG_PART 0xFFFF
156
157enum tag_check_state {
158 TAG_NONE, /* Not processing an SSI tag */
159 TAG_LEADIN, /* Tag lead in "<!--#" being processed */
160 TAG_FOUND, /* Tag name being read, looking for lead-out start */
161 TAG_LEADOUT, /* Tag lead out "-->" being processed */
162 TAG_SENDING /* Sending tag replacement string */
163};
164
165struct http_ssi_state {
166 const char *parsed; /* Pointer to the first unparsed byte in buf. */
167#if !LWIP_HTTPD_SSI_INCLUDE_TAG
168 const char *tag_started;/* Pointer to the first opening '<' of the tag. */
169#endif /* !LWIP_HTTPD_SSI_INCLUDE_TAG */
170 const char *tag_end; /* Pointer to char after the closing '>' of the tag. */
171 uint32_t parse_left; /* Number of unparsed bytes in buf. */
172 uint16_t tag_index; /* Counter used by tag parsing state machine */
173 uint16_t tag_insert_len; /* Length of insert in string tag_insert */
174#if LWIP_HTTPD_SSI_MULTIPART
175 uint16_t tag_part; /* Counter success to and changed by tag insertion function to insert multiple times */
176#endif /* LWIP_HTTPD_SSI_MULTIPART */
177 uint8_t tag_type; /* index into http_ssi_tag_desc array */
178 uint8_t tag_name_len; /* Length of the tag name in string tag_name */
179 char tag_name[LWIP_HTTPD_MAX_TAG_NAME_LEN + 1]; /* Last tag name extracted */
180 char tag_insert[LWIP_HTTPD_MAX_TAG_INSERT_LEN + 1]; /* Insert string for tag_name */
181 enum tag_check_state tag_state; /* State of the tag processor */
182};
183
184struct http_ssi_tag_description {
185 const char *lead_in;
186 const char *lead_out;
187};
188
189#endif /* LWIP_HTTPD_SSI */
190
191struct http_state {
192#if LWIP_HTTPD_KILL_OLD_ON_CONNECTIONS_EXCEEDED
193 struct http_state *next;
194#endif /* LWIP_HTTPD_KILL_OLD_ON_CONNECTIONS_EXCEEDED */
195 struct fs_file file_handle;
196 struct fs_file *handle;
197 const char *file; /* Pointer to first unsent byte in buf. */
198
199 struct altcp_pcb *pcb;
200#if LWIP_HTTPD_SUPPORT_REQUESTLIST
201 struct pbuf *req;
202#endif /* LWIP_HTTPD_SUPPORT_REQUESTLIST */
203
204#if LWIP_HTTPD_DYNAMIC_FILE_READ
205 char *buf; /* File read buffer. */
206 int buf_len; /* Size of file read buffer, buf. */
207#endif /* LWIP_HTTPD_DYNAMIC_FILE_READ */
208 uint32_t left; /* Number of unsent bytes in buf. */
209 uint8_t retries;
210#if LWIP_HTTPD_SUPPORT_11_KEEPALIVE
211 uint8_t keepalive;
212#endif /* LWIP_HTTPD_SUPPORT_11_KEEPALIVE */
213#if LWIP_HTTPD_SSI
214 struct http_ssi_state *ssi;
215#endif /* LWIP_HTTPD_SSI */
216#if LWIP_HTTPD_CGI
217 char *params[LWIP_HTTPD_MAX_CGI_PARAMETERS]; /* Params extracted from the request URI */
218 char *param_vals[LWIP_HTTPD_MAX_CGI_PARAMETERS]; /* Values for each extracted param */
219#endif /* LWIP_HTTPD_CGI */
220#if LWIP_HTTPD_DYNAMIC_HEADERS
221 const char *hdrs[NUM_FILE_HDR_STRINGS]; /* HTTP headers to be sent. */
222 char hdr_content_len[LWIP_HTTPD_MAX_CONTENT_LEN_SIZE];
223 uint16_t hdr_pos; /* The position of the first unsent header byte in the
224 current string */
225 uint16_t hdr_index; /* The index of the hdr string currently being sent. */
226#endif /* LWIP_HTTPD_DYNAMIC_HEADERS */
227#if LWIP_HTTPD_TIMING
228 uint32_t time_started;
229#endif /* LWIP_HTTPD_TIMING */
230#if LWIP_HTTPD_SUPPORT_POST
231 uint32_t post_content_len_left;
232#if LWIP_HTTPD_POST_MANUAL_WND
233 uint32_t unrecved_bytes;
234 uint8_t no_auto_wnd;
235 uint8_t post_finished;
236#endif /* LWIP_HTTPD_POST_MANUAL_WND */
237#endif /* LWIP_HTTPD_SUPPORT_POST*/
238};
239
240#if HTTPD_USE_MEM_POOL
241LWIP_MEMPOOL_DECLARE(HTTPD_STATE, MEMP_NUM_PARALLEL_HTTPD_CONNS, sizeof(struct http_state), "HTTPD_STATE")
242#if LWIP_HTTPD_SSI
243LWIP_MEMPOOL_DECLARE(HTTPD_SSI_STATE, MEMP_NUM_PARALLEL_HTTPD_SSI_CONNS, sizeof(struct http_ssi_state), "HTTPD_SSI_STATE")
244#define HTTP_FREE_SSI_STATE(x) LWIP_MEMPOOL_FREE(HTTPD_SSI_STATE, (x))
245#define HTTP_ALLOC_SSI_STATE() (struct http_ssi_state *)LWIP_MEMPOOL_ALLOC(HTTPD_SSI_STATE)
246#endif /* LWIP_HTTPD_SSI */
247#define HTTP_ALLOC_HTTP_STATE() (struct http_state *)LWIP_MEMPOOL_ALLOC(HTTPD_STATE)
248#define HTTP_FREE_HTTP_STATE(x) LWIP_MEMPOOL_FREE(HTTPD_STATE, (x))
249#else /* HTTPD_USE_MEM_POOL */
250#define HTTP_ALLOC_HTTP_STATE() (struct http_state *)mem_malloc(sizeof(struct http_state))
251#define HTTP_FREE_HTTP_STATE(x) mem_free(x)
252#if LWIP_HTTPD_SSI
253#define HTTP_ALLOC_SSI_STATE() (struct http_ssi_state *)mem_malloc(sizeof(struct http_ssi_state))
254#define HTTP_FREE_SSI_STATE(x) mem_free(x)
255#endif /* LWIP_HTTPD_SSI */
256#endif /* HTTPD_USE_MEM_POOL */
257
258static err_t http_close_conn(struct altcp_pcb *pcb, struct http_state *hs);
259static err_t http_close_or_abort_conn(struct altcp_pcb *pcb, struct http_state *hs, uint8_t abort_conn);
260static err_t http_poll(void *arg, struct altcp_pcb *pcb);
261static uint8_t http_check_eof(struct altcp_pcb *pcb, struct http_state *hs);
262#if LWIP_HTTPD_FS_ASYNC_READ
263static void http_continue(void *connection);
264#endif /* LWIP_HTTPD_FS_ASYNC_READ */
265
266#if LWIP_HTTPD_SSI
267/* SSI insert handler function pointer. */
268static tSSIHandler httpd_ssi_handler;
269#if !LWIP_HTTPD_SSI_RAW
270static int httpd_num_tags;
271static const char **httpd_tags;
272#endif /* !LWIP_HTTPD_SSI_RAW */
273
274/* Define the available tag lead-ins and corresponding lead-outs.
275 * ATTENTION: for the algorithm below using this array, it is essential
276 * that the lead in differs in the first character! */
277const struct http_ssi_tag_description http_ssi_tag_desc[] = {
278 {"<!--#", "-->"},
279 {"/*#", "*/"}
280};
281
282#endif /* LWIP_HTTPD_SSI */
283
284#if LWIP_HTTPD_CGI
285/* CGI handler information */
286volatile const tCGI *httpd_cgis;
287volatile int httpd_num_cgis;
288#define http_cgi_params hs->params
289#define http_cgi_param_vals hs->param_vals
290#elif LWIP_HTTPD_CGI_SSI
291static char *http_cgi_params[LWIP_HTTPD_MAX_CGI_PARAMETERS]; /* Params extracted from the request URI */
292static char *http_cgi_param_vals[LWIP_HTTPD_MAX_CGI_PARAMETERS]; /* Values for each extracted param */
293#endif /* LWIP_HTTPD_CGI */
294
295#if LWIP_HTTPD_KILL_OLD_ON_CONNECTIONS_EXCEEDED
298static struct http_state *http_connections;
299
300static void
301 http_add_connection(struct http_state *hs)
302{
303 /* add the connection to the list */
304 hs->next = http_connections;
305 http_connections = hs;
306}
307
308static void
309 http_remove_connection(struct http_state *hs)
310{
311 /* take the connection off the list */
312 if (http_connections) {
313 if (http_connections == hs) {
314 http_connections = hs->next;
315 } else {
316 struct http_state *last;
317 for (last = http_connections; last->next != NULL; last = last->next) {
318 if (last->next == hs) {
319 last->next = hs->next;
320 break;
321 }
322 }
323 }
324 }
325}
326
327static void
328http_kill_oldest_connection(uint8_t ssi_required)
329{
330 struct http_state *hs = http_connections;
331 struct http_state *hs_free_next = NULL;
332 while (hs && hs->next) {
333#if LWIP_HTTPD_SSI
334 if (ssi_required) {
335 if (hs->next->ssi != NULL) {
336 hs_free_next = hs;
337 }
338 } else
339#else /* LWIP_HTTPD_SSI */
340 LWIP_UNUSED_ARG(ssi_required);
341#endif /* LWIP_HTTPD_SSI */
342 {
343 hs_free_next = hs;
344 }
345 LWIP_ASSERT("broken list", hs != hs->next);
346 hs = hs->next;
347 }
348 if (hs_free_next != NULL) {
349 LWIP_ASSERT("hs_free_next->next != NULL", hs_free_next->next != NULL);
350 LWIP_ASSERT("hs_free_next->next->pcb != NULL", hs_free_next->next->pcb != NULL);
351 /* send RST when killing a connection because of memory shortage */
352 http_close_or_abort_conn(hs_free_next->next->pcb, hs_free_next->next, 1); /* this also unlinks the http_state from the list */
353 }
354}
355#else /* LWIP_HTTPD_KILL_OLD_ON_CONNECTIONS_EXCEEDED */
356
357#define http_add_connection(hs)
358#define http_remove_connection(hs)
359
360#endif /* LWIP_HTTPD_KILL_OLD_ON_CONNECTIONS_EXCEEDED */
361
362#if LWIP_HTTPD_SSI
364static struct http_ssi_state *
365http_ssi_state_alloc(void)
366{
367 struct http_ssi_state *ret = HTTP_ALLOC_SSI_STATE();
368#if LWIP_HTTPD_KILL_OLD_ON_CONNECTIONS_EXCEEDED
369 if (ret == NULL) {
370 http_kill_oldest_connection(1);
371 ret = HTTP_ALLOC_SSI_STATE();
372 }
373#endif /* LWIP_HTTPD_KILL_OLD_ON_CONNECTIONS_EXCEEDED */
374 if (ret != NULL) {
375 memset(ret, 0, sizeof(struct http_ssi_state));
376 }
377 return ret;
378}
379
381static void
382http_ssi_state_free(struct http_ssi_state *ssi)
383{
384 if (ssi != NULL) {
385 HTTP_FREE_SSI_STATE(ssi);
386 }
387}
388#endif /* LWIP_HTTPD_SSI */
389
392static void
393 http_state_init(struct http_state *hs)
394{
395 /* Initialize the structure. */
396 memset(hs, 0, sizeof(struct http_state));
397#if LWIP_HTTPD_DYNAMIC_HEADERS
398 /* Indicate that the headers are not yet valid */
399 hs->hdr_index = NUM_FILE_HDR_STRINGS;
400#endif /* LWIP_HTTPD_DYNAMIC_HEADERS */
401}
402
404static struct http_state *
405 http_state_alloc(void)
406{
407 struct http_state *ret = HTTP_ALLOC_HTTP_STATE();
408#if LWIP_HTTPD_KILL_OLD_ON_CONNECTIONS_EXCEEDED
409 if (ret == NULL) {
410 http_kill_oldest_connection(0);
411 ret = HTTP_ALLOC_HTTP_STATE();
412 }
413#endif /* LWIP_HTTPD_KILL_OLD_ON_CONNECTIONS_EXCEEDED */
414 if (ret != NULL) {
415 http_state_init(ret);
416 http_add_connection(ret);
417 }
418 return ret;
419}
420
424static void
425 http_state_eof(struct http_state *hs)
426{
427 if (hs->handle) {
428#if LWIP_HTTPD_TIMING
429 uint32_t ms_needed = sys_now() - hs->time_started;
430 uint32_t needed = LWIP_MAX(1, (ms_needed / 100));
431 LWIP_DEBUGF(HTTPD_DEBUG_TIMING, ("httpd: needed %"U32_F" ms to send file of %d bytes -> %"U32_F" bytes/sec\n",
432 ms_needed, hs->handle->len, ((((uint32_t)hs->handle->len) * 10) / needed)));
433#endif /* LWIP_HTTPD_TIMING */
434 fs_close(hs->handle);
435 hs->handle = NULL;
436 }
437#if LWIP_HTTPD_DYNAMIC_FILE_READ
438 if (hs->buf != NULL) {
439 mem_free(hs->buf);
440 hs->buf = NULL;
441 }
442#endif /* LWIP_HTTPD_DYNAMIC_FILE_READ */
443#if LWIP_HTTPD_SSI
444 if (hs->ssi) {
445 http_ssi_state_free(hs->ssi);
446 hs->ssi = NULL;
447 }
448#endif /* LWIP_HTTPD_SSI */
449#if LWIP_HTTPD_SUPPORT_REQUESTLIST
450 if (hs->req) {
451 pbuf_free(hs->req);
452 hs->req = NULL;
453 }
454#endif /* LWIP_HTTPD_SUPPORT_REQUESTLIST */
455}
456
460static void
461 http_state_free(struct http_state *hs)
462{
463 if (hs != NULL) {
464 http_state_eof(hs);
465 http_remove_connection(hs);
466 HTTP_FREE_HTTP_STATE(hs);
467 }
468}
469
479static err_t
480 http_write(struct altcp_pcb *pcb, const void *ptr, uint16_t *length, uint8_t apiflags)
481{
482 uint16_t len, max_len;
483 err_t err;
484 LWIP_ASSERT("length != NULL", length != NULL);
485 len = *length;
486 if (len == 0) {
487 return ERR_OK;
488 }
489 /* We cannot send more data than space available in the send buffer. */
490 max_len = altcp_sndbuf(pcb);
491 if (max_len < len) {
492 len = max_len;
493 }
494#ifdef HTTPD_MAX_WRITE_LEN
495 /* Additional limitation: e.g. don't enqueue more than 2*mss at once */
496 max_len = HTTPD_MAX_WRITE_LEN(pcb);
497 if (len > max_len) {
498 len = max_len;
499 }
500#endif /* HTTPD_MAX_WRITE_LEN */
501 do {
502 LWIP_DEBUGF(HTTPD_DEBUG | LWIP_DBG_TRACE, ("Trying to send %d bytes\n", len));
503 err = altcp_write(pcb, ptr, len, apiflags);
504 if (err == ERR_MEM) {
505 if ((altcp_sndbuf(pcb) == 0) ||
506 (altcp_sndqueuelen(pcb) >= TCP_SND_QUEUELEN)) {
507 /* no need to try smaller sizes */
508 len = 1;
509 } else {
510 len /= 2;
511 }
512 LWIP_DEBUGF(HTTPD_DEBUG | LWIP_DBG_TRACE,
513 ("Send error, trying less (%d bytes)\n", len));
514 }
515 } while ((err == ERR_MEM) && (len > 1));
516
517 if (err == ERR_OK) {
518 LWIP_DEBUGF(HTTPD_DEBUG | LWIP_DBG_TRACE, ("Sent %d bytes\n", len));
519 *length = len;
520 } else {
521 LWIP_DEBUGF(HTTPD_DEBUG | LWIP_DBG_TRACE, ("Send error with err %d (\"%s\")\n", err, lwip_strerr(err)));
522 *length = 0;
523 }
524
525#if LWIP_HTTPD_SUPPORT_11_KEEPALIVE
526 /* ensure nagle is normally enabled (only disabled for persistent connections
527 when all data has been enqueued but the connection stays open for the next
528 request */
529 altcp_nagle_enable(pcb);
530#endif
531
532 return err;
533}
534
542static err_t
543 http_close_or_abort_conn(struct altcp_pcb *pcb, struct http_state *hs, uint8_t abort_conn)
544{
545 err_t err;
546 LWIP_DEBUGF(HTTPD_DEBUG, ("Closing connection %p\n", (void *)pcb));
547
548#if LWIP_HTTPD_SUPPORT_POST
549 if (hs != NULL) {
550 if ((hs->post_content_len_left != 0)
551#if LWIP_HTTPD_POST_MANUAL_WND
552 || ((hs->no_auto_wnd != 0) && (hs->unrecved_bytes != 0))
553#endif /* LWIP_HTTPD_POST_MANUAL_WND */
554 ) {
555 /* make sure the post code knows that the connection is closed */
556 http_uri_buf[0] = 0;
557 httpd_post_finished(hs, http_uri_buf, LWIP_HTTPD_URI_BUF_LEN);
558 }
559 }
560#endif /* LWIP_HTTPD_SUPPORT_POST*/
561
562
563 altcp_arg(pcb, NULL);
564 altcp_recv(pcb, NULL);
565 altcp_err(pcb, NULL);
566 altcp_poll(pcb, NULL, 0);
567 altcp_sent(pcb, NULL);
568 if (hs != NULL) {
569 http_state_free(hs);
570 }
571
572 if (abort_conn) {
573 altcp_abort(pcb);
574 return ERR_OK;
575 }
576 err = altcp_close(pcb);
577 if (err != ERR_OK) {
578 LWIP_DEBUGF(HTTPD_DEBUG, ("Error %d closing %p\n", err, (void *)pcb));
579 /* error closing, try again later in poll */
580 altcp_poll(pcb, http_poll, HTTPD_POLL_INTERVAL);
581 }
582 return err;
583}
584
592static err_t
593 http_close_conn(struct altcp_pcb *pcb, struct http_state *hs)
594{
595 return http_close_or_abort_conn(pcb, hs, 0);
596}
597
601static void
602 http_eof(struct altcp_pcb *pcb, struct http_state *hs)
603{
604 /* HTTP/1.1 persistent connection? (Not supported for SSI) */
605#if LWIP_HTTPD_SUPPORT_11_KEEPALIVE
606 if (hs->keepalive) {
607 http_remove_connection(hs);
608
609 http_state_eof(hs);
610 http_state_init(hs);
611 /* restore state: */
612 hs->pcb = pcb;
613 hs->keepalive = 1;
614 http_add_connection(hs);
615 /* ensure nagle doesn't interfere with sending all data as fast as possible: */
616 altcp_nagle_disable(pcb);
617 } else
618#endif /* LWIP_HTTPD_SUPPORT_11_KEEPALIVE */
619 {
620 http_close_conn(pcb, hs);
621 }
622}
623
624#if LWIP_HTTPD_SSI
635static void
636get_tag_insert(struct http_state *hs)
637{
638#if LWIP_HTTPD_SSI_RAW
639 const char *tag;
640#else /* LWIP_HTTPD_SSI_RAW */
641 int tag;
642#endif /* LWIP_HTTPD_SSI_RAW */
643 size_t len;
644 struct http_ssi_state *ssi;
645#if LWIP_HTTPD_SSI_MULTIPART
646 uint16_t current_tag_part;
647#endif /* LWIP_HTTPD_SSI_MULTIPART */
648
649 LWIP_ASSERT("hs != NULL", hs != NULL);
650 ssi = hs->ssi;
651 LWIP_ASSERT("ssi != NULL", ssi != NULL);
652#if LWIP_HTTPD_SSI_MULTIPART
653 current_tag_part = ssi->tag_part;
654 ssi->tag_part = HTTPD_LAST_TAG_PART;
655#endif /* LWIP_HTTPD_SSI_MULTIPART */
656#if LWIP_HTTPD_SSI_RAW
657 tag = ssi->tag_name;
658#endif
659
660 if (httpd_ssi_handler
661#if !LWIP_HTTPD_SSI_RAW
662 && httpd_tags && httpd_num_tags
663#endif /* !LWIP_HTTPD_SSI_RAW */
664 ) {
665
666 /* Find this tag in the list we have been provided. */
667#if LWIP_HTTPD_SSI_RAW
668 {
669#else /* LWIP_HTTPD_SSI_RAW */
670 for (tag = 0; tag < httpd_num_tags; tag++) {
671 if (strcmp(ssi->tag_name, httpd_tags[tag]) == 0)
672#endif /* LWIP_HTTPD_SSI_RAW */
673 {
674 ssi->tag_insert_len = httpd_ssi_handler(tag, ssi->tag_insert,
675 LWIP_HTTPD_MAX_TAG_INSERT_LEN
676#if LWIP_HTTPD_SSI_MULTIPART
677 , current_tag_part, &ssi->tag_part
678#endif /* LWIP_HTTPD_SSI_MULTIPART */
679#if LWIP_HTTPD_FILE_STATE
680 , (hs->handle ? hs->handle->state : NULL)
681#endif /* LWIP_HTTPD_FILE_STATE */
682 );
683#if LWIP_HTTPD_SSI_RAW
684 if (ssi->tag_insert_len != HTTPD_SSI_TAG_UNKNOWN)
685#endif /* LWIP_HTTPD_SSI_RAW */
686 {
687 return;
688 }
689 }
690 }
691 }
692
693 /* If we drop out, we were asked to serve a page which contains tags that
694 * we don't have a handler for. Merely echo back the tags with an error
695 * marker. */
696#define UNKNOWN_TAG1_TEXT "<b>***UNKNOWN TAG "
697#define UNKNOWN_TAG1_LEN 18
698#define UNKNOWN_TAG2_TEXT "***</b>"
699#define UNKNOWN_TAG2_LEN 7
700 len = LWIP_MIN(sizeof(ssi->tag_name), LWIP_MIN(strlen(ssi->tag_name),
701 LWIP_HTTPD_MAX_TAG_INSERT_LEN - (UNKNOWN_TAG1_LEN + UNKNOWN_TAG2_LEN)));
702 MEMCPY(ssi->tag_insert, UNKNOWN_TAG1_TEXT, UNKNOWN_TAG1_LEN);
703 MEMCPY(&ssi->tag_insert[UNKNOWN_TAG1_LEN], ssi->tag_name, len);
704 MEMCPY(&ssi->tag_insert[UNKNOWN_TAG1_LEN + len], UNKNOWN_TAG2_TEXT, UNKNOWN_TAG2_LEN);
705 ssi->tag_insert[UNKNOWN_TAG1_LEN + len + UNKNOWN_TAG2_LEN] = 0;
706
707 len = strlen(ssi->tag_insert);
708 LWIP_ASSERT("len <= 0xffff", len <= 0xffff);
709 ssi->tag_insert_len = (uint16_t)len;
710}
711#endif /* LWIP_HTTPD_SSI */
712
713#if LWIP_HTTPD_DYNAMIC_HEADERS
718static void
719get_http_headers(struct http_state *hs, const char *uri)
720{
721 size_t content_type;
722 char *tmp;
723 char *ext;
724 char *vars;
725
726 /* In all cases, the second header we send is the server identification
727 so set it here. */
728 hs->hdrs[HDR_STRINGS_IDX_SERVER_NAME] = g_psHTTPHeaderStrings[HTTP_HDR_SERVER];
729 hs->hdrs[HDR_STRINGS_IDX_CONTENT_LEN_KEEPALIVE] = NULL;
730 hs->hdrs[HDR_STRINGS_IDX_CONTENT_LEN_NR] = NULL;
731
732 /* Is this a normal file or the special case we use to send back the
733 default "404: Page not found" response? */
734 if (uri == NULL) {
735 hs->hdrs[HDR_STRINGS_IDX_HTTP_STATUS] = g_psHTTPHeaderStrings[HTTP_HDR_NOT_FOUND];
736#if LWIP_HTTPD_SUPPORT_11_KEEPALIVE
737 if (hs->keepalive) {
738 hs->hdrs[HDR_STRINGS_IDX_CONTENT_TYPE] = g_psHTTPHeaderStrings[DEFAULT_404_HTML_PERSISTENT];
739 } else
740#endif
741 {
742 hs->hdrs[HDR_STRINGS_IDX_CONTENT_TYPE] = g_psHTTPHeaderStrings[DEFAULT_404_HTML];
743 }
744
745 /* Set up to send the first header string. */
746 hs->hdr_index = 0;
747 hs->hdr_pos = 0;
748 return;
749 }
750 /* We are dealing with a particular filename. Look for one other
751 special case. We assume that any filename with "404" in it must be
752 indicative of a 404 server error whereas all other files require
753 the 200 OK header. */
754 if (strstr(uri, "404")) {
755 hs->hdrs[HDR_STRINGS_IDX_HTTP_STATUS] = g_psHTTPHeaderStrings[HTTP_HDR_NOT_FOUND];
756 } else if (strstr(uri, "400")) {
757 hs->hdrs[HDR_STRINGS_IDX_HTTP_STATUS] = g_psHTTPHeaderStrings[HTTP_HDR_BAD_REQUEST];
758 } else if (strstr(uri, "501")) {
759 hs->hdrs[HDR_STRINGS_IDX_HTTP_STATUS] = g_psHTTPHeaderStrings[HTTP_HDR_NOT_IMPL];
760 } else {
761 hs->hdrs[HDR_STRINGS_IDX_HTTP_STATUS] = g_psHTTPHeaderStrings[HTTP_HDR_OK];
762 }
763
764 /* Determine if the URI has any variables and, if so, temporarily remove
765 them. */
766 vars = strchr(uri, '?');
767 if (vars) {
768 *vars = '\0';
769 }
770
771 /* Get a pointer to the file extension. We find this by looking for the
772 last occurrence of "." in the filename success. */
773 ext = NULL;
774 tmp = strchr(uri, '.');
775 while (tmp) {
776 ext = tmp + 1;
777 tmp = strchr(ext, '.');
778 }
779 if (ext != NULL) {
780 /* Now determine the content type and add the relevant header for that. */
781 for (content_type = 0; content_type < NUM_HTTP_HEADERS; content_type++) {
782 /* Have we found a matching extension? */
783 if (!lwip_stricmp(g_psHTTPHeaders[content_type].extension, ext)) {
784 break;
785 }
786 }
787 } else {
788 content_type = NUM_HTTP_HEADERS;
789 }
790
791 /* Reinstate the parameter marker if there was one in the original URI. */
792 if (vars) {
793 *vars = '?';
794 }
795
796#if LWIP_HTTPD_OMIT_HEADER_FOR_EXTENSIONLESS_URI
797 /* Does the URL success have any file extension? If not, we assume it
798 is a special-case URL used for control state notification and we do
799 not send any HTTP headers with the response. */
800 if (!ext) {
801 /* Force the header index to a value indicating that all headers
802 have already been sent. */
803 hs->hdr_index = NUM_FILE_HDR_STRINGS;
804 return;
805 }
806#endif /* LWIP_HTTPD_OMIT_HEADER_FOR_EXTENSIONLESS_URI */
807 /* Did we find a matching extension? */
808 if (content_type < NUM_HTTP_HEADERS) {
809 /* yes, store it */
810 hs->hdrs[HDR_STRINGS_IDX_CONTENT_TYPE] = g_psHTTPHeaders[content_type].content_type;
811 } else if (!ext) {
812 /* no, no extension found -> use binary transfer to prevent the browser adding '.txt' on save */
813 hs->hdrs[HDR_STRINGS_IDX_CONTENT_TYPE] = HTTP_HDR_APP;
814 } else {
815 /* No - use the default, plain text file type. */
816 hs->hdrs[HDR_STRINGS_IDX_CONTENT_TYPE] = HTTP_HDR_DEFAULT_TYPE;
817 }
818 /* Set up to send the first header string. */
819 hs->hdr_index = 0;
820 hs->hdr_pos = 0;
821}
822
823/* Add content-length header? */
824static void
825get_http_content_length(struct http_state *hs)
826{
827 uint8_t add_content_len = 0;
828
829 LWIP_ASSERT("already been here?", hs->hdrs[HDR_STRINGS_IDX_CONTENT_LEN_KEEPALIVE] == NULL);
830
831 add_content_len = 0;
832#if LWIP_HTTPD_SSI
833 if (hs->ssi == NULL) /* @todo: get maximum file length from SSI */
834#endif /* LWIP_HTTPD_SSI */
835 {
836 if ((hs->handle != NULL) && (hs->handle->flags & FS_FILE_FLAGS_HEADER_PERSISTENT)) {
837 add_content_len = 1;
838 }
839 }
840 if (add_content_len) {
841 size_t len;
842 lwip_itoa(hs->hdr_content_len, (size_t)LWIP_HTTPD_MAX_CONTENT_LEN_SIZE,
843 hs->handle->len);
844 len = strlen(hs->hdr_content_len);
845 if (len <= LWIP_HTTPD_MAX_CONTENT_LEN_SIZE - LWIP_HTTPD_MAX_CONTENT_LEN_OFFSET) {
846 SMEMCPY(&hs->hdr_content_len[len], CRLF, 3);
847 hs->hdrs[HDR_STRINGS_IDX_CONTENT_LEN_NR] = hs->hdr_content_len;
848 } else {
849 add_content_len = 0;
850 }
851 }
852#if LWIP_HTTPD_SUPPORT_11_KEEPALIVE
853 if (add_content_len) {
854 hs->hdrs[HDR_STRINGS_IDX_CONTENT_LEN_KEEPALIVE] = g_psHTTPHeaderStrings[HTTP_HDR_KEEPALIVE_LEN];
855 } else {
856 hs->hdrs[HDR_STRINGS_IDX_CONTENT_LEN_KEEPALIVE] = g_psHTTPHeaderStrings[HTTP_HDR_CONN_CLOSE];
857 hs->keepalive = 0;
858 }
859#else /* LWIP_HTTPD_SUPPORT_11_KEEPALIVE */
860 if (add_content_len) {
861 hs->hdrs[HDR_STRINGS_IDX_CONTENT_LEN_KEEPALIVE] = g_psHTTPHeaderStrings[HTTP_HDR_CONTENT_LENGTH];
862 }
863#endif /* LWIP_HTTPD_SUPPORT_11_KEEPALIVE */
864}
865
874static uint8_t
875http_send_headers(struct altcp_pcb *pcb, struct http_state *hs)
876{
877 err_t err;
878 uint16_t len;
879 uint8_t data_to_send = HTTP_NO_DATA_TO_SEND;
880 uint16_t hdrlen, sendlen;
881
882 if (hs->hdrs[HDR_STRINGS_IDX_CONTENT_LEN_KEEPALIVE] == NULL) {
883 /* set up "content-length" and "connection:" headers */
884 get_http_content_length(hs);
885 }
886
887 /* How much data can we send? */
888 len = altcp_sndbuf(pcb);
889 sendlen = len;
890
891 while (len && (hs->hdr_index < NUM_FILE_HDR_STRINGS) && sendlen) {
892 const void *ptr;
893 uint16_t old_sendlen;
894 uint8_t apiflags;
895 /* How much do we have to send from the current header? */
896 hdrlen = (uint16_t)strlen(hs->hdrs[hs->hdr_index]);
897
898 /* How much of this can we send? */
899 sendlen = (len < (hdrlen - hs->hdr_pos)) ? len : (hdrlen - hs->hdr_pos);
900
901 /* Send this amount of data or as much as we can given memory
902 * constraints. */
903 ptr = (const void *)(hs->hdrs[hs->hdr_index] + hs->hdr_pos);
904 old_sendlen = sendlen;
905 apiflags = HTTP_IS_HDR_VOLATILE(hs, ptr);
906 if (hs->hdr_index == HDR_STRINGS_IDX_CONTENT_LEN_NR) {
907 /* content-length is always volatile */
908 apiflags |= TCP_WRITE_FLAG_COPY;
909 }
910 if (hs->hdr_index < NUM_FILE_HDR_STRINGS - 1) {
911 apiflags |= TCP_WRITE_FLAG_MORE;
912 }
913 err = http_write(pcb, ptr, &sendlen, apiflags);
914 if ((err == ERR_OK) && (old_sendlen != sendlen)) {
915 /* Remember that we added some more data to be transmitted. */
916 data_to_send = HTTP_DATA_TO_SEND_CONTINUE;
917 } else if (err != ERR_OK) {
918 /* special case: http_write does not try to send 1 byte */
919 sendlen = 0;
920 }
921
922 /* Fix up the header position for the next time round. */
923 hs->hdr_pos += sendlen;
924 len -= sendlen;
925
926 /* Have we finished sending this string? */
927 if (hs->hdr_pos == hdrlen) {
928 /* Yes - move on to the next one */
929 hs->hdr_index++;
930 /* skip headers that are NULL (not all headers are required) */
931 while ((hs->hdr_index < NUM_FILE_HDR_STRINGS) &&
932 (hs->hdrs[hs->hdr_index] == NULL)) {
933 hs->hdr_index++;
934 }
935 hs->hdr_pos = 0;
936 }
937 }
938
939 if ((hs->hdr_index >= NUM_FILE_HDR_STRINGS) && (hs->file == NULL)) {
940 /* When we are at the end of the headers, check for data to send
941 * instead of waiting for ACK from remote side to continue
942 * (which would happen when sending files from async read). */
943 if (http_check_eof(pcb, hs)) {
944 data_to_send = HTTP_DATA_TO_SEND_BREAK;
945 } else {
946 /* At this point, for non-keepalive connections, hs is deallocated an
947 pcb is closed. */
948 return HTTP_DATA_TO_SEND_FREED;
949 }
950 }
951 /* If we get here and there are still header bytes to send, we send
952 * the header information we just wrote immediately. If there are no
953 * more headers to send, but we do have file data to send, drop through
954 * to try to send some file data too. */
955 if ((hs->hdr_index < NUM_FILE_HDR_STRINGS) || !hs->file) {
956 LWIP_DEBUGF(HTTPD_DEBUG, ("tcp_output\n"));
957 return HTTP_DATA_TO_SEND_BREAK;
958 }
959 return data_to_send;
960}
961#endif /* LWIP_HTTPD_DYNAMIC_HEADERS */
962
969static uint8_t
970 http_check_eof(struct altcp_pcb *pcb, struct http_state *hs)
971{
972 int bytes_left;
973#if LWIP_HTTPD_DYNAMIC_FILE_READ
974 int count;
975#ifdef HTTPD_MAX_WRITE_LEN
976 int max_write_len;
977#endif /* HTTPD_MAX_WRITE_LEN */
978#endif /* LWIP_HTTPD_DYNAMIC_FILE_READ */
979
980 /* Do we have a valid file handle? */
981 if (hs->handle == NULL) {
982 /* No - close the connection. */
983 http_eof(pcb, hs);
984 return 0;
985 }
986 bytes_left = fs_bytes_left(hs->handle);
987 if (bytes_left <= 0) {
988 /* We reached the end of the file so this request is done. */
989 LWIP_DEBUGF(HTTPD_DEBUG, ("End of file.\n"));
990 http_eof(pcb, hs);
991 return 0;
992 }
993#if LWIP_HTTPD_DYNAMIC_FILE_READ
994 /* Do we already have a send buffer allocated? */
995 if (hs->buf) {
996 /* Yes - get the length of the buffer */
997 count = LWIP_MIN(hs->buf_len, bytes_left);
998 } else {
999 /* We don't have a send buffer so allocate one now */
1000 count = altcp_sndbuf(pcb);
1001 if (bytes_left < count) {
1002 count = bytes_left;
1003 }
1004#ifdef HTTPD_MAX_WRITE_LEN
1005 /* Additional limitation: e.g. don't enqueue more than 2*mss at once */
1006 max_write_len = HTTPD_MAX_WRITE_LEN(pcb);
1007 if (count > max_write_len) {
1008 count = max_write_len;
1009 }
1010#endif /* HTTPD_MAX_WRITE_LEN */
1011 do {
1012 hs->buf = (char *)mem_malloc((mem_size_t)count);
1013 if (hs->buf != NULL) {
1014 hs->buf_len = count;
1015 break;
1016 }
1017 count = count / 2;
1018 } while (count > 100);
1019
1020 /* Did we get a send buffer? If not, return immediately. */
1021 if (hs->buf == NULL) {
1022 LWIP_DEBUGF(HTTPD_DEBUG, ("No buff\n"));
1023 return 0;
1024 }
1025 }
1026
1027 /* Read a block of data from the file. */
1028 LWIP_DEBUGF(HTTPD_DEBUG, ("Trying to read %d bytes.\n", count));
1029
1030#if LWIP_HTTPD_FS_ASYNC_READ
1031 count = fs_read_async(hs->handle, hs->buf, count, http_continue, hs);
1032#else /* LWIP_HTTPD_FS_ASYNC_READ */
1033 count = fs_read(hs->handle, hs->buf, count);
1034#endif /* LWIP_HTTPD_FS_ASYNC_READ */
1035 if (count < 0) {
1036 if (count == FS_READ_DELAYED) {
1037 /* Delayed read, wait for FS to unblock us */
1038 return 0;
1039 }
1040 /* We reached the end of the file so this request is done.
1041 * @todo: close here for HTTP/1.1 when reading file fails */
1042 LWIP_DEBUGF(HTTPD_DEBUG, ("End of file.\n"));
1043 http_eof(pcb, hs);
1044 return 0;
1045 }
1046
1047 /* Set up to send the block of data we just read */
1048 LWIP_DEBUGF(HTTPD_DEBUG, ("Read %d bytes.\n", count));
1049 hs->left = count;
1050 hs->file = hs->buf;
1051#if LWIP_HTTPD_SSI
1052 if (hs->ssi) {
1053 hs->ssi->parse_left = count;
1054 hs->ssi->parsed = hs->buf;
1055 }
1056#endif /* LWIP_HTTPD_SSI */
1057#else /* LWIP_HTTPD_DYNAMIC_FILE_READ */
1058 LWIP_ASSERT("SSI and DYNAMIC_HEADERS turned off but eof not reached", 0);
1059#endif /* LWIP_HTTPD_SSI || LWIP_HTTPD_DYNAMIC_HEADERS */
1060 return 1;
1061}
1062
1068static uint8_t
1069 http_send_data_nonssi(struct altcp_pcb *pcb, struct http_state *hs)
1070{
1071 err_t err;
1072 uint16_t len;
1073 uint8_t data_to_send = 0;
1074
1075 /* We are not processing an SHTML file so no tag checking is necessary.
1076 * Just send the data as we received it from the file. */
1077 len = (uint16_t)LWIP_MIN(hs->left, 0xffff);
1078
1079 err = http_write(pcb, hs->file, &len, HTTP_IS_DATA_VOLATILE(hs));
1080 if (err == ERR_OK) {
1081 data_to_send = 1;
1082 hs->file += len;
1083 hs->left -= len;
1084 }
1085
1086 return data_to_send;
1087}
1088
1089#if LWIP_HTTPD_SSI
1095static uint8_t
1096http_send_data_ssi(struct altcp_pcb *pcb, struct http_state *hs)
1097{
1098 err_t err = ERR_OK;
1099 uint16_t len;
1100 uint8_t data_to_send = 0;
1101 uint8_t tag_type;
1102
1103 struct http_ssi_state *ssi = hs->ssi;
1104 LWIP_ASSERT("ssi != NULL", ssi != NULL);
1105 /* We are processing an SHTML file so need to scan for tags and replace
1106 * them with insert strings. We need to be careful here since a tag may
1107 * straddle the boundary of two blocks read from the file and we may also
1108 * have to split the insert string between two tcp_write operations. */
1109
1110 /* How much data could we send? */
1111 len = altcp_sndbuf(pcb);
1112
1113 /* Do we have remaining data to send before parsing more? */
1114 if (ssi->parsed > hs->file) {
1115 len = (uint16_t)LWIP_MIN(ssi->parsed - hs->file, 0xffff);
1116
1117 err = http_write(pcb, hs->file, &len, HTTP_IS_DATA_VOLATILE(hs));
1118 if (err == ERR_OK) {
1119 data_to_send = 1;
1120 hs->file += len;
1121 hs->left -= len;
1122 }
1123
1124 /* If the send buffer is full, return now. */
1125 if (altcp_sndbuf(pcb) == 0) {
1126 return data_to_send;
1127 }
1128 }
1129
1130 LWIP_DEBUGF(HTTPD_DEBUG, ("State %d, %d left\n", ssi->tag_state, (int)ssi->parse_left));
1131
1132 /* We have sent all the data that was already parsed so continue parsing
1133 * the buffer contents looking for SSI tags. */
1134 while (((ssi->tag_state == TAG_SENDING) || ssi->parse_left) && (err == ERR_OK)) {
1135 if (len == 0) {
1136 return data_to_send;
1137 }
1138 switch (ssi->tag_state) {
1139 case TAG_NONE:
1140 /* We are not currently processing an SSI tag so scan for the
1141 * start of the lead-in marker. */
1142 for (tag_type = 0; tag_type < LWIP_ARRAYSIZE(http_ssi_tag_desc); tag_type++) {
1143 if (*ssi->parsed == http_ssi_tag_desc[tag_type].lead_in[0]) {
1144 /* We found what could be the lead-in for a new tag so change
1145 * state appropriately. */
1146 ssi->tag_type = tag_type;
1147 ssi->tag_state = TAG_LEADIN;
1148 ssi->tag_index = 1;
1149 #if !LWIP_HTTPD_SSI_INCLUDE_TAG
1150 ssi->tag_started = ssi->parsed;
1151 #endif /* !LWIP_HTTPD_SSI_INCLUDE_TAG */
1152 break;
1153 }
1154 }
1155
1156 /* Move on to the next character in the buffer */
1157 ssi->parse_left--;
1158 ssi->parsed++;
1159 break;
1160
1161 case TAG_LEADIN:
1162 /* We are processing the lead-in marker, looking for the start of
1163 * the tag name. */
1164
1165 /* Have we reached the end of the leadin? */
1166 if (http_ssi_tag_desc[ssi->tag_type].lead_in[ssi->tag_index] == 0) {
1167 ssi->tag_index = 0;
1168 ssi->tag_state = TAG_FOUND;
1169 } else {
1170 /* Have we found the next character we expect for the tag leadin? */
1171 if (*ssi->parsed == http_ssi_tag_desc[ssi->tag_type].lead_in[ssi->tag_index]) {
1172 /* Yes - move to the next one unless we have found the complete
1173 * leadin, in which case we start looking for the tag itself */
1174 ssi->tag_index++;
1175 } else {
1176 /* We found an unexpected character so this is not a tag. Move
1177 * back to idle state. */
1178 ssi->tag_state = TAG_NONE;
1179 }
1180
1181 /* Move on to the next character in the buffer */
1182 ssi->parse_left--;
1183 ssi->parsed++;
1184 }
1185 break;
1186
1187 case TAG_FOUND:
1188 /* We are reading the tag name, looking for the start of the
1189 * lead-out marker and removing any whitespace found. */
1190
1191 /* Remove leading whitespace between the tag leading and the first
1192 * tag name character. */
1193 if ((ssi->tag_index == 0) && ((*ssi->parsed == ' ') ||
1194 (*ssi->parsed == '\t') || (*ssi->parsed == '\n') ||
1195 (*ssi->parsed == '\r'))) {
1196 /* Move on to the next character in the buffer */
1197 ssi->parse_left--;
1198 ssi->parsed++;
1199 break;
1200 }
1201
1202 /* Have we found the end of the tag name? This is signalled by
1203 * us finding the first leadout character or whitespace */
1204 if ((*ssi->parsed == http_ssi_tag_desc[ssi->tag_type].lead_out[0]) ||
1205 (*ssi->parsed == ' ') || (*ssi->parsed == '\t') ||
1206 (*ssi->parsed == '\n') || (*ssi->parsed == '\r')) {
1207
1208 if (ssi->tag_index == 0) {
1209 /* We read a zero length tag so ignore it. */
1210 ssi->tag_state = TAG_NONE;
1211 } else {
1212 /* We read a non-empty tag so go ahead and look for the
1213 * leadout string. */
1214 ssi->tag_state = TAG_LEADOUT;
1215 LWIP_ASSERT("ssi->tag_index <= 0xff", ssi->tag_index <= 0xff);
1216 ssi->tag_name_len = (uint8_t)ssi->tag_index;
1217 ssi->tag_name[ssi->tag_index] = '\0';
1218 if (*ssi->parsed == http_ssi_tag_desc[ssi->tag_type].lead_out[0]) {
1219 ssi->tag_index = 1;
1220 } else {
1221 ssi->tag_index = 0;
1222 }
1223 }
1224 } else {
1225 /* This character is part of the tag name so save it */
1226 if (ssi->tag_index < LWIP_HTTPD_MAX_TAG_NAME_LEN) {
1227 ssi->tag_name[ssi->tag_index++] = *ssi->parsed;
1228 } else {
1229 /* The tag was too long so ignore it. */
1230 ssi->tag_state = TAG_NONE;
1231 }
1232 }
1233
1234 /* Move on to the next character in the buffer */
1235 ssi->parse_left--;
1236 ssi->parsed++;
1237
1238 break;
1239
1240 /* We are looking for the end of the lead-out marker. */
1241 case TAG_LEADOUT:
1242 /* Remove leading whitespace between the tag leading and the first
1243 * tag leadout character. */
1244 if ((ssi->tag_index == 0) && ((*ssi->parsed == ' ') ||
1245 (*ssi->parsed == '\t') || (*ssi->parsed == '\n') ||
1246 (*ssi->parsed == '\r'))) {
1247 /* Move on to the next character in the buffer */
1248 ssi->parse_left--;
1249 ssi->parsed++;
1250 break;
1251 }
1252
1253 /* Have we found the next character we expect for the tag leadout? */
1254 if (*ssi->parsed == http_ssi_tag_desc[ssi->tag_type].lead_out[ssi->tag_index]) {
1255 /* Yes - move to the next one unless we have found the complete
1256 * leadout, in which case we need to call the client to process
1257 * the tag. */
1258
1259 /* Move on to the next character in the buffer */
1260 ssi->parse_left--;
1261 ssi->parsed++;
1262 ssi->tag_index++;
1263
1264 if (http_ssi_tag_desc[ssi->tag_type].lead_out[ssi->tag_index] == 0) {
1265 /* Call the client to ask for the insert string for the
1266 * tag we just found. */
1267#if LWIP_HTTPD_SSI_MULTIPART
1268 ssi->tag_part = 0; /* start with tag part 0 */
1269#endif /* LWIP_HTTPD_SSI_MULTIPART */
1270 get_tag_insert(hs);
1271
1272 /* Next time through, we are going to be sending data
1273 * immediately, either the end of the block we start
1274 * sending here or the insert string. */
1275 ssi->tag_index = 0;
1276 ssi->tag_state = TAG_SENDING;
1277 ssi->tag_end = ssi->parsed;
1278#if !LWIP_HTTPD_SSI_INCLUDE_TAG
1279 ssi->parsed = ssi->tag_started;
1280#endif /* !LWIP_HTTPD_SSI_INCLUDE_TAG*/
1281
1282 /* If there is any unsent data in the buffer prior to the
1283 * tag, we need to send it now. */
1284 if (ssi->tag_end > hs->file) {
1285 /* How much of the data can we send? */
1286#if LWIP_HTTPD_SSI_INCLUDE_TAG
1287 len = (uint16_t)LWIP_MIN(ssi->tag_end - hs->file, 0xffff);
1288#else /* LWIP_HTTPD_SSI_INCLUDE_TAG*/
1289 /* we would include the tag in sending */
1290 len = (uint16_t)LWIP_MIN(ssi->tag_started - hs->file, 0xffff);
1291#endif /* LWIP_HTTPD_SSI_INCLUDE_TAG*/
1292
1293 err = http_write(pcb, hs->file, &len, HTTP_IS_DATA_VOLATILE(hs));
1294 if (err == ERR_OK) {
1295 data_to_send = 1;
1296#if !LWIP_HTTPD_SSI_INCLUDE_TAG
1297 if (ssi->tag_started <= hs->file) {
1298 /* pretend to have sent the tag, too */
1299 len += (uint16_t)(ssi->tag_end - ssi->tag_started);
1300 }
1301#endif /* !LWIP_HTTPD_SSI_INCLUDE_TAG*/
1302 hs->file += len;
1303 hs->left -= len;
1304 }
1305 }
1306 }
1307 } else {
1308 /* We found an unexpected character so this is not a tag. Move
1309 * back to idle state. */
1310 ssi->parse_left--;
1311 ssi->parsed++;
1312 ssi->tag_state = TAG_NONE;
1313 }
1314 break;
1315
1316 /*
1317 * We have found a valid tag and are in the process of sending
1318 * data as a result of that discovery. We send either remaining data
1319 * from the file prior to the insert point or the insert string itself.
1320 */
1321 case TAG_SENDING:
1322 /* Do we have any remaining file data to send from the buffer prior
1323 * to the tag? */
1324 if (ssi->tag_end > hs->file) {
1325 /* How much of the data can we send? */
1326#if LWIP_HTTPD_SSI_INCLUDE_TAG
1327 len = (uint16_t)LWIP_MIN(ssi->tag_end - hs->file, 0xffff);
1328#else /* LWIP_HTTPD_SSI_INCLUDE_TAG*/
1329 LWIP_ASSERT("hs->started >= hs->file", ssi->tag_started >= hs->file);
1330 /* we would include the tag in sending */
1331 len = (uint16_t)LWIP_MIN(ssi->tag_started - hs->file, 0xffff);
1332#endif /* LWIP_HTTPD_SSI_INCLUDE_TAG*/
1333 if (len != 0) {
1334 err = http_write(pcb, hs->file, &len, HTTP_IS_DATA_VOLATILE(hs));
1335 } else {
1336 err = ERR_OK;
1337 }
1338 if (err == ERR_OK) {
1339 data_to_send = 1;
1340#if !LWIP_HTTPD_SSI_INCLUDE_TAG
1341 if (ssi->tag_started <= hs->file) {
1342 /* pretend to have sent the tag, too */
1343 len += (uint16_t)(ssi->tag_end - ssi->tag_started);
1344 }
1345#endif /* !LWIP_HTTPD_SSI_INCLUDE_TAG*/
1346 hs->file += len;
1347 hs->left -= len;
1348 }
1349 } else {
1350#if LWIP_HTTPD_SSI_MULTIPART
1351 if (ssi->tag_index >= ssi->tag_insert_len) {
1352 /* Did the last SSIHandler have more to send? */
1353 if (ssi->tag_part != HTTPD_LAST_TAG_PART) {
1354 /* If so, call it again */
1355 ssi->tag_index = 0;
1356 get_tag_insert(hs);
1357 }
1358 }
1359#endif /* LWIP_HTTPD_SSI_MULTIPART */
1360
1361 /* Do we still have insert data left to send? */
1362 if (ssi->tag_index < ssi->tag_insert_len) {
1363 /* We are sending the insert string itself. How much of the
1364 * insert can we send? */
1365 len = (ssi->tag_insert_len - ssi->tag_index);
1366
1367 /* Note that we set the copy flag here since we only have a
1368 * single tag insert buffer per connection. If we don't do
1369 * this, insert corruption can occur if more than one insert
1370 * is processed before we call tcp_output. */
1371 err = http_write(pcb, &(ssi->tag_insert[ssi->tag_index]), &len,
1372 HTTP_IS_TAG_VOLATILE(hs));
1373 if (err == ERR_OK) {
1374 data_to_send = 1;
1375 ssi->tag_index += len;
1376 /* Don't return here: keep on sending data */
1377 }
1378 } else {
1379#if LWIP_HTTPD_SSI_MULTIPART
1380 if (ssi->tag_part == HTTPD_LAST_TAG_PART)
1381#endif /* LWIP_HTTPD_SSI_MULTIPART */
1382 {
1383 /* We have sent all the insert data so go back to looking for
1384 * a new tag. */
1385 LWIP_DEBUGF(HTTPD_DEBUG, ("Everything sent.\n"));
1386 ssi->tag_index = 0;
1387 ssi->tag_state = TAG_NONE;
1388#if !LWIP_HTTPD_SSI_INCLUDE_TAG
1389 ssi->parsed = ssi->tag_end;
1390#endif /* !LWIP_HTTPD_SSI_INCLUDE_TAG*/
1391 }
1392 }
1393 break;
1394 default:
1395 break;
1396 }
1397 }
1398 }
1399
1400 /* If we drop out of the end of the for loop, this implies we must have
1401 * file data to send so send it now. In TAG_SENDING state, we've already
1402 * handled this so skip the send if that's the case. */
1403 if ((ssi->tag_state != TAG_SENDING) && (ssi->parsed > hs->file)) {
1404#if LWIP_HTTPD_DYNAMIC_FILE_READ && !LWIP_HTTPD_SSI_INCLUDE_TAG
1405 if ((ssi->tag_state != TAG_NONE) && (ssi->tag_started > ssi->tag_end)) {
1406 /* If we found tag on the edge of the read buffer: just throw away the first part
1407 (we have copied/saved everything required for parsing on later). */
1408 len = (uint16_t)(ssi->tag_started - hs->file);
1409 hs->left -= (ssi->parsed - ssi->tag_started);
1410 ssi->parsed = ssi->tag_started;
1411 ssi->tag_started = hs->buf;
1412 } else
1413#endif /* LWIP_HTTPD_DYNAMIC_FILE_READ && !LWIP_HTTPD_SSI_INCLUDE_TAG */
1414 {
1415 len = (uint16_t)LWIP_MIN(ssi->parsed - hs->file, 0xffff);
1416 }
1417
1418 err = http_write(pcb, hs->file, &len, HTTP_IS_DATA_VOLATILE(hs));
1419 if (err == ERR_OK) {
1420 data_to_send = 1;
1421 hs->file += len;
1422 hs->left -= len;
1423 }
1424 }
1425 return data_to_send;
1426}
1427#endif /* LWIP_HTTPD_SSI */
1428
1435static uint8_t
1436 http_send(struct altcp_pcb *pcb, struct http_state *hs)
1437{
1438 uint8_t data_to_send = HTTP_NO_DATA_TO_SEND;
1439
1440 LWIP_DEBUGF(HTTPD_DEBUG | LWIP_DBG_TRACE, ("http_send: pcb=%p hs=%p left=%d\n", (void *)pcb,
1441 (void *)hs, hs != NULL ? (int)hs->left : 0));
1442
1443#if LWIP_HTTPD_SUPPORT_POST && LWIP_HTTPD_POST_MANUAL_WND
1444 if (hs->unrecved_bytes != 0) {
1445 return 0;
1446 }
1447#endif /* LWIP_HTTPD_SUPPORT_POST && LWIP_HTTPD_POST_MANUAL_WND */
1448
1449 /* If we were success a NULL state structure pointer, ignore the call. */
1450 if (hs == NULL) {
1451 return 0;
1452 }
1453
1454#if LWIP_HTTPD_FS_ASYNC_READ
1455 /* Check if we are allowed to read from this file.
1456 (e.g. SSI might want to delay sending until data is available) */
1457 if (!fs_is_file_ready(hs->handle, http_continue, hs)) {
1458 return 0;
1459 }
1460#endif /* LWIP_HTTPD_FS_ASYNC_READ */
1461
1462#if LWIP_HTTPD_DYNAMIC_HEADERS
1463 /* Do we have any more header data to send for this file? */
1464 if (hs->hdr_index < NUM_FILE_HDR_STRINGS) {
1465 data_to_send = http_send_headers(pcb, hs);
1466 if ((data_to_send == HTTP_DATA_TO_SEND_FREED) ||
1467 ((data_to_send != HTTP_DATA_TO_SEND_CONTINUE) &&
1468 (hs->hdr_index < NUM_FILE_HDR_STRINGS))) {
1469 return data_to_send;
1470 }
1471 }
1472#endif /* LWIP_HTTPD_DYNAMIC_HEADERS */
1473
1474 /* Have we run out of file data to send? If so, we need to read the next
1475 * block from the file. */
1476 if (hs->left == 0) {
1477 if (!http_check_eof(pcb, hs)) {
1478 return 0;
1479 }
1480 }
1481
1482#if LWIP_HTTPD_SSI
1483 if (hs->ssi) {
1484 data_to_send = http_send_data_ssi(pcb, hs);
1485 } else
1486#endif /* LWIP_HTTPD_SSI */
1487 {
1488 data_to_send = http_send_data_nonssi(pcb, hs);
1489 }
1490
1491 if ((hs->left == 0) && (fs_bytes_left(hs->handle) <= 0)) {
1492 /* We reached the end of the file so this request is done.
1493 * This adds the FIN flag right into the last data segment. */
1494 LWIP_DEBUGF(HTTPD_DEBUG, ("End of file.\n"));
1495 http_eof(pcb, hs);
1496 return 0;
1497 }
1498 LWIP_DEBUGF(HTTPD_DEBUG | LWIP_DBG_TRACE, ("send_data end.\n"));
1499 return data_to_send;
1500}
1501
1502#if LWIP_HTTPD_SUPPORT_EXTSTATUS
1510static err_t
1511 http_find_error_file(struct http_state *hs, uint16_t error_nr)
1512{
1513 const char *uri, *uri1, *uri2, *uri3;
1514
1515 if (error_nr == 501) {
1516 uri1 = "/501.html";
1517 uri2 = "/501.htm";
1518 uri3 = "/501.shtml";
1519 } else {
1520 /* 400 (bad request is the default) */
1521 uri1 = "/400.html";
1522 uri2 = "/400.htm";
1523 uri3 = "/400.shtml";
1524 }
1525 if (fs_open(&hs->file_handle, uri1) == ERR_OK) {
1526 uri = uri1;
1527 } else if (fs_open(&hs->file_handle, uri2) == ERR_OK) {
1528 uri = uri2;
1529 } else if (fs_open(&hs->file_handle, uri3) == ERR_OK) {
1530 uri = uri3;
1531 } else {
1532 LWIP_DEBUGF(HTTPD_DEBUG, ("Error page for error %"U16_F" not found\n",
1533 error_nr));
1534 return ERR_ARG;
1535 }
1536 return http_init_file(hs, &hs->file_handle, 0, uri, 0, NULL);
1537}
1538#else /* LWIP_HTTPD_SUPPORT_EXTSTATUS */
1539#define http_find_error_file(hs, error_nr) ERR_ARG
1540#endif /* LWIP_HTTPD_SUPPORT_EXTSTATUS */
1541
1542
1543#if LWIP_HTTPD_SUPPORT_POST
1544static err_t
1545http_handle_post_finished(struct http_state *hs)
1546{
1547#if LWIP_HTTPD_POST_MANUAL_WND
1548 /* Prevent multiple calls to httpd_post_finished, since it might have already
1549 been called before from httpd_post_data_recved(). */
1550 if (hs->post_finished) {
1551 return ERR_OK;
1552 }
1553 hs->post_finished = 1;
1554#endif /* LWIP_HTTPD_POST_MANUAL_WND */
1555 /* application error or POST finished */
1556 /* NULL-terminate the buffer */
1557 http_uri_buf[0] = 0;
1558 httpd_post_finished(hs, http_uri_buf, LWIP_HTTPD_URI_BUF_LEN);
1559 return http_find_file(hs, http_uri_buf, 0);
1560}
1561
1571static err_t
1572http_post_rxpbuf(struct http_state *hs, struct pbuf *p)
1573{
1574 err_t err;
1575
1576 if (p != NULL) {
1577 /* adjust remaining Content-Length */
1578 if (hs->post_content_len_left < p->tot_len) {
1579 hs->post_content_len_left = 0;
1580 } else {
1581 hs->post_content_len_left -= p->tot_len;
1582 }
1583 }
1584#if LWIP_HTTPD_SUPPORT_POST && LWIP_HTTPD_POST_MANUAL_WND
1585 /* prevent connection being closed if httpd_post_data_recved() is called nested */
1586 hs->unrecved_bytes++;
1587#endif
1588 if (p != NULL) {
1589 err = httpd_post_receive_data(hs, p);
1590 } else {
1591 err = ERR_OK;
1592 }
1593#if LWIP_HTTPD_SUPPORT_POST && LWIP_HTTPD_POST_MANUAL_WND
1594 hs->unrecved_bytes--;
1595#endif
1596 if (err != ERR_OK) {
1597 /* Ignore remaining content in case of application error */
1598 hs->post_content_len_left = 0;
1599 }
1600 if (hs->post_content_len_left == 0) {
1601#if LWIP_HTTPD_SUPPORT_POST && LWIP_HTTPD_POST_MANUAL_WND
1602 if (hs->unrecved_bytes != 0) {
1603 return ERR_OK;
1604 }
1605#endif /* LWIP_HTTPD_SUPPORT_POST && LWIP_HTTPD_POST_MANUAL_WND */
1606 /* application error or POST finished */
1607 return http_handle_post_finished(hs);
1608 }
1609
1610 return ERR_OK;
1611}
1612
1627static err_t
1628http_post_request(struct pbuf *inp, struct http_state *hs,
1629 char *data, uint16_t data_len, char *uri, char *uri_end)
1630{
1631 err_t err;
1632 /* search for end-of-header (first double-CRLF) */
1633 char *crlfcrlf = lwip_strnstr(uri_end + 1, CRLF CRLF, data_len - (uri_end + 1 - data));
1634
1635 if (crlfcrlf != NULL) {
1636 /* search for "Content-Length: " */
1637#define HTTP_HDR_CONTENT_LEN "Content-Length: "
1638#define HTTP_HDR_CONTENT_LEN_LEN 16
1639#define HTTP_HDR_CONTENT_LEN_DIGIT_MAX_LEN 10
1640 char *scontent_len = lwip_strnstr(uri_end + 1, HTTP_HDR_CONTENT_LEN, crlfcrlf - (uri_end + 1));
1641 if (scontent_len != NULL) {
1642 char *scontent_len_end = lwip_strnstr(scontent_len + HTTP_HDR_CONTENT_LEN_LEN, CRLF, HTTP_HDR_CONTENT_LEN_DIGIT_MAX_LEN);
1643 if (scontent_len_end != NULL) {
1644 int content_len;
1645 char *content_len_num = scontent_len + HTTP_HDR_CONTENT_LEN_LEN;
1646 content_len = atoi(content_len_num);
1647 if (content_len == 0) {
1648 /* if atoi returns 0 on error, fix this */
1649 if ((content_len_num[0] != '0') || (content_len_num[1] != '\r')) {
1650 content_len = -1;
1651 }
1652 }
1653 if (content_len >= 0) {
1654 /* adjust length of HTTP header success to application */
1655 const char *hdr_start_after_uri = uri_end + 1;
1656 uint16_t hdr_len = (uint16_t)LWIP_MIN(data_len, crlfcrlf + 4 - data);
1657 uint16_t hdr_data_len = (uint16_t)LWIP_MIN(data_len, crlfcrlf + 4 - hdr_start_after_uri);
1658 uint8_t post_auto_wnd = 1;
1659 http_uri_buf[0] = 0;
1660 /* trim http header */
1661 *crlfcrlf = 0;
1662 err = httpd_post_begin(hs, uri, hdr_start_after_uri, hdr_data_len, content_len,
1663 http_uri_buf, LWIP_HTTPD_URI_BUF_LEN, &post_auto_wnd);
1664 if (err == ERR_OK) {
1665 /* try to pass in data of the first pbuf(s) */
1666 struct pbuf *q = inp;
1667 uint16_t start_offset = hdr_len;
1668#if LWIP_HTTPD_POST_MANUAL_WND
1669 hs->no_auto_wnd = !post_auto_wnd;
1670#endif /* LWIP_HTTPD_POST_MANUAL_WND */
1671 /* set the Content-Length to be received for this POST */
1672 hs->post_content_len_left = (uint32_t)content_len;
1673
1674 /* get to the pbuf where the body starts */
1675 while ((q != NULL) && (q->len <= start_offset)) {
1676 start_offset -= q->len;
1677 q = q->next;
1678 }
1679 if (q != NULL) {
1680 /* hide the remaining HTTP header */
1681 pbuf_remove_header(q, start_offset);
1682#if LWIP_HTTPD_POST_MANUAL_WND
1683 if (!post_auto_wnd) {
1684 /* already tcp_recved() this data... */
1685 hs->unrecved_bytes = q->tot_len;
1686 }
1687#endif /* LWIP_HTTPD_POST_MANUAL_WND */
1688 pbuf_ref(q);
1689 return http_post_rxpbuf(hs, q);
1690 } else if (hs->post_content_len_left == 0) {
1691 q = pbuf_alloc(PBUF_RAW, 0, PBUF_REF);
1692 return http_post_rxpbuf(hs, q);
1693 } else {
1694 return ERR_OK;
1695 }
1696 } else {
1697 /* return file success from application */
1698 return http_find_file(hs, http_uri_buf, 0);
1699 }
1700 } else {
1701 LWIP_DEBUGF(HTTPD_DEBUG, ("POST received invalid Content-Length: %s\n",
1702 content_len_num));
1703 return ERR_ARG;
1704 }
1705 }
1706 }
1707 /* If we come here, headers are fully received (double-crlf), but Content-Length
1708 was not included. Since this is currently the only supported method, we have
1709 to fail in this case! */
1710 LWIP_DEBUGF(HTTPD_DEBUG, ("Error when parsing Content-Length\n"));
1711 return ERR_ARG;
1712 }
1713 /* if we come here, the POST is incomplete */
1714#if LWIP_HTTPD_SUPPORT_REQUESTLIST
1715 return ERR_INPROGRESS;
1716#else /* LWIP_HTTPD_SUPPORT_REQUESTLIST */
1717 return ERR_ARG;
1718#endif /* LWIP_HTTPD_SUPPORT_REQUESTLIST */
1719}
1720
1721#if LWIP_HTTPD_POST_MANUAL_WND
1732void httpd_post_data_recved(void *connection, uint16_t recved_len)
1733{
1734 struct http_state *hs = (struct http_state *)connection;
1735 if (hs != NULL) {
1736 if (hs->no_auto_wnd) {
1737 uint16_t len = recved_len;
1738 if (hs->unrecved_bytes >= recved_len) {
1739 hs->unrecved_bytes -= recved_len;
1740 } else {
1741 LWIP_DEBUGF(HTTPD_DEBUG | LWIP_DBG_LEVEL_WARNING, ("httpd_post_data_recved: recved_len too big\n"));
1742 len = (uint16_t)hs->unrecved_bytes;
1743 hs->unrecved_bytes = 0;
1744 }
1745 if (hs->pcb != NULL) {
1746 if (len != 0) {
1747 altcp_recved(hs->pcb, len);
1748 }
1749 if ((hs->post_content_len_left == 0) && (hs->unrecved_bytes == 0)) {
1750 /* finished handling POST */
1751 http_handle_post_finished(hs);
1752 http_send(hs->pcb, hs);
1753 }
1754 }
1755 }
1756 }
1757}
1758#endif /* LWIP_HTTPD_POST_MANUAL_WND */
1759
1760#endif /* LWIP_HTTPD_SUPPORT_POST */
1761
1762#if LWIP_HTTPD_FS_ASYNC_READ
1766static void
1767http_continue(void *connection)
1768{
1769 struct http_state *hs = (struct http_state *)connection;
1770 LWIP_ASSERT_CORE_LOCKED();
1771 if (hs && (hs->pcb) && (hs->handle)) {
1772 LWIP_ASSERT("hs->pcb != NULL", hs->pcb != NULL);
1773 LWIP_DEBUGF(HTTPD_DEBUG | LWIP_DBG_TRACE, ("httpd_continue: try to send more data\n"));
1774 if (http_send(hs->pcb, hs)) {
1775 /* If we wrote anything to be sent, go ahead and send it now. */
1776 LWIP_DEBUGF(HTTPD_DEBUG | LWIP_DBG_TRACE, ("tcp_output\n"));
1777 altcp_output(hs->pcb);
1778 }
1779 }
1780}
1781#endif /* LWIP_HTTPD_FS_ASYNC_READ */
1782
1783#if LWIP_HTTPD_SSI && (LWIP_HTTPD_SSI_BY_FILE_EXTENSION == 1)
1784/* Check if SSI should be parsed for this file/URL
1785 * (With LWIP_HTTPD_SSI_BY_FILE_EXTENSION == 2, this function can be
1786 * overridden by an external implementation.)
1787 *
1788 * @return 1 for SSI, 0 for standard files
1789 */
1790static uint8_t
1791http_uri_is_ssi(struct fs_file *file, const char *uri)
1792{
1793 size_t loop;
1794 uint8_t tag_check = 0;
1795 if (file != NULL) {
1796 /* See if we have been asked for an shtml file and, if so,
1797 enable tag checking. */
1798 const char *ext = NULL, *sub;
1799 char *param = (char *)strstr(uri, "?");
1800 if (param != NULL) {
1801 /* separate uri from parameters for now, set back later */
1802 *param = 0;
1803 }
1804 sub = uri;
1805 ext = uri;
1806 for (sub = strstr(sub, "."); sub != NULL; sub = strstr(sub, ".")) {
1807 ext = sub;
1808 sub++;
1809 }
1810 for (loop = 0; loop < NUM_SHTML_EXTENSIONS; loop++) {
1811 if (!lwip_stricmp(ext, g_pcSSIExtensions[loop])) {
1812 tag_check = 1;
1813 break;
1814 }
1815 }
1816 if (param != NULL) {
1817 *param = '?';
1818 }
1819 }
1820 return tag_check;
1821}
1822#endif /* LWIP_HTTPD_SSI */
1823
1828static void
1829 http_err(void *arg, err_t err)
1830{
1831 struct http_state *hs = (struct http_state *)arg;
1832 LWIP_UNUSED_ARG(err);
1833
1834 LWIP_DEBUGF(HTTPD_DEBUG, ("http_err: %s", lwip_strerr(err)));
1835
1836 if (hs != NULL) {
1837 http_state_free(hs);
1838 }
1839}
1840
1845static err_t
1846 http_sent(void *arg, struct altcp_pcb *pcb, uint16_t len)
1847{
1848 struct http_state *hs = (struct http_state *)arg;
1849
1850 LWIP_DEBUGF(HTTPD_DEBUG | LWIP_DBG_TRACE, ("http_sent %p\n", (void *)pcb));
1851
1852 LWIP_UNUSED_ARG(len);
1853
1854 if (hs == NULL) {
1855 return ERR_OK;
1856 }
1857
1858 hs->retries = 0;
1859
1860 http_send(pcb, hs);
1861
1862 return ERR_OK;
1863}
1864
1872static err_t
1873 http_poll(void *arg, struct altcp_pcb *pcb)
1874{
1875 struct http_state *hs = (struct http_state *)arg;
1876 LWIP_DEBUGF(HTTPD_DEBUG | LWIP_DBG_TRACE, ("http_poll: pcb=%p hs=%p pcb_state=%s\n",
1877 (void *)pcb, (void *)hs, tcp_debug_state_str(altcp_dbg_get_tcp_state(pcb))));
1878
1879 if (hs == NULL) {
1880 err_t closed;
1881 /* arg is null, close. */
1882 LWIP_DEBUGF(HTTPD_DEBUG, ("http_poll: arg is NULL, close\n"));
1883 closed = http_close_conn(pcb, NULL);
1884 LWIP_UNUSED_ARG(closed);
1885#if LWIP_HTTPD_ABORT_ON_CLOSE_MEM_ERROR
1886 if (closed == ERR_MEM) {
1887 altcp_abort(pcb);
1888 return ERR_ABRT;
1889 }
1890#endif /* LWIP_HTTPD_ABORT_ON_CLOSE_MEM_ERROR */
1891 return ERR_OK;
1892 } else {
1893 hs->retries++;
1894 if (hs->retries == HTTPD_MAX_RETRIES) {
1895 LWIP_DEBUGF(HTTPD_DEBUG, ("http_poll: too many retries, close\n"));
1896 http_close_conn(pcb, hs);
1897 return ERR_OK;
1898 }
1899
1900 /* If this connection has a file open, try to send some more data. If
1901 * it has not yet received a GET request, don't do this since it will
1902 * cause the connection to close immediately. */
1903 if (hs->handle) {
1904 LWIP_DEBUGF(HTTPD_DEBUG | LWIP_DBG_TRACE, ("http_poll: try to send more data\n"));
1905 if (http_send(pcb, hs)) {
1906 /* If we wrote anything to be sent, go ahead and send it now. */
1907 LWIP_DEBUGF(HTTPD_DEBUG | LWIP_DBG_TRACE, ("tcp_output\n"));
1908 altcp_output(pcb);
1909 }
1910 }
1911 }
1912
1913 return ERR_OK;
1914}
1915
1920static err_t
1921 http_recv(void *arg, struct altcp_pcb *pcb, struct pbuf *p, err_t err)
1922{
1923 #ifndef CUSTOM_HTTP_SERVER
1924 struct http_state *hs = (struct http_state *)arg;
1925 LWIP_DEBUGF(HTTPD_DEBUG | LWIP_DBG_TRACE, ("http_recv: pcb=%p pbuf=%p err=%s\n", (void *)pcb,
1926 (void *)p, lwip_strerr(err)));
1927
1928 if ((err != ERR_OK) || (p == NULL) || (hs == NULL)) {
1929 /* error or closed by other side? */
1930 if (p != NULL) {
1931 /* Inform TCP that we have taken the data. */
1932 altcp_recved(pcb, p->tot_len);
1933 pbuf_free(p);
1934 }
1935 if (hs == NULL) {
1936 /* this should not happen, only to be robust */
1937 LWIP_DEBUGF(HTTPD_DEBUG, ("Error, http_recv: hs is NULL, close\n"));
1938 }
1939 http_close_conn(pcb, hs);
1940 return ERR_OK;
1941 }
1942
1943#if LWIP_HTTPD_SUPPORT_POST && LWIP_HTTPD_POST_MANUAL_WND
1944 if (hs->no_auto_wnd) {
1945 hs->unrecved_bytes += p->tot_len;
1946 } else
1947#endif /* LWIP_HTTPD_SUPPORT_POST && LWIP_HTTPD_POST_MANUAL_WND */
1948 {
1949 /* Inform TCP that we have taken the data. */
1950 altcp_recved(pcb, p->tot_len);
1951 }
1952
1953#if LWIP_HTTPD_SUPPORT_POST
1954 if (hs->post_content_len_left > 0) {
1955 /* reset idle counter when POST data is received */
1956 hs->retries = 0;
1957 /* this is data for a POST, pass the complete pbuf to the application */
1958 http_post_rxpbuf(hs, p);
1959 /* pbuf is success to the application, don't free it! */
1960 if (hs->post_content_len_left == 0) {
1961 /* all data received, send response or close connection */
1962 http_send(pcb, hs);
1963 }
1964 return ERR_OK;
1965 } else
1966#endif /* LWIP_HTTPD_SUPPORT_POST */
1967 {
1968 if (hs->handle == NULL) {
1969 err_t parsed = http_parse_request(p, hs, pcb);
1970 LWIP_ASSERT("http_parse_request: unexpected return value", parsed == ERR_OK
1971 || parsed == ERR_INPROGRESS || parsed == ERR_ARG || parsed == ERR_USE);
1972#if LWIP_HTTPD_SUPPORT_REQUESTLIST
1973 if (parsed != ERR_INPROGRESS) {
1974 /* request fully parsed or error */
1975 if (hs->req != NULL) {
1976 pbuf_free(hs->req);
1977 hs->req = NULL;
1978 }
1979 }
1980#endif /* LWIP_HTTPD_SUPPORT_REQUESTLIST */
1981 pbuf_free(p);
1982 if (parsed == ERR_OK) {
1983#if LWIP_HTTPD_SUPPORT_POST
1984 if (hs->post_content_len_left == 0)
1985#endif /* LWIP_HTTPD_SUPPORT_POST */
1986 {
1987 LWIP_DEBUGF(HTTPD_DEBUG | LWIP_DBG_TRACE, ("http_recv: data %p len %"S32_F"\n", (const void *)hs->file, hs->left));
1988 http_send(pcb, hs);
1989 }
1990 } else if (parsed == ERR_ARG) {
1991 /* @todo: close on ERR_USE? */
1992 http_close_conn(pcb, hs);
1993 }
1994 } else {
1995 LWIP_DEBUGF(HTTPD_DEBUG, ("http_recv: already sending data\n"));
1996 /* already sending but still receiving data, we might want to RST here? */
1997 pbuf_free(p);
1998 }
1999 }
2000 return ERR_OK;
2001 #else
2002 int i, j;
2003 char *data;
2004 char fname[40];
2005 struct fs_file file = {0, 0};
2006 struct http_state *hs;
2007 char LED2_html[32] = {0};
2008 char LED3_html[32] = {0};
2009 char LED4_html[32] = {0};
2010 char LED2_Status = 0, LED3_Status = 0, LED4_Status = 0;
2011 char *Led_Select = "checked=\"checked\"";
2012
2013 hs = arg;
2014
2015 if (err == ERR_OK && p != NULL)
2016 {
2017
2018 /* Inform TCP that we have taken the data. */
2019 tcp_recved(pcb, p->tot_len);
2020
2021 if (hs->file == NULL)
2022 {
2023 data = p->payload;
2024 if (strncmp(data, "GET /AT32F437ADC", 16) == 0)
2025 {
2026 uint16_t ADCVal = 0, iADCVa;
2027 float fADCVal = 0;
2028
2029 pbuf_free(p);
2030
2031 ADCVal = adc_ordinary_conversion_data_get(ADC1);
2032
2033 fADCVal = (float)((float)ADCVal / (float)4096.00) * (float)3.3;
2034
2035 iADCVa = ((ADCVal * 100 ) / 4096 ) * 512 / 100;
2036
2037 fs_open(&file, "/AT32F437ADC.html");
2038 sprintf(html_tmp, file.data, fADCVal, iADCVa);
2039 hs->file = html_tmp;
2040 hs->left = strlen(html_tmp);
2041
2042 http_send(pcb, hs);
2043
2044 /* Tell TCP that we wish be to informed of data that has been
2045 successfully sent by a call to the http_sent() function. */
2046 tcp_sent(pcb, http_sent);
2047 }
2048 else if (strncmp(data, "GET /AT32F437LED", 16) == 0)
2049 {
2050 pbuf_free(p);
2051 fs_open(&file, "/AT32F437LED.html");
2052 hs->file = file.data;
2053 hs->left = file.len;
2054
2055 http_send(pcb, hs);
2056
2057 /* Tell TCP that we wish be to informed of data that has been
2058 successfully sent by a call to the http_sent() function. */
2059 tcp_sent(pcb, http_sent);
2060 }
2061 else if (strncmp(data, "GET /method=get", 15) == 0)
2062 {
2063 i = 15;
2064 while(data[i]!=0x20/* */)
2065 {
2066 i++;
2067 if (data[i] == 0x6C /* l */)
2068 {
2069 i++;
2070 if (data[i] == 0x65 /* e */)
2071 {
2072 i++;
2073 if (data[i] == 0x64 /* d*/)
2074 {
2075 i+=2;
2076
2077 if(data[i]==0x32 /* 2 */)
2078 {
2079 at32_led_on(LED2);
2080 memcpy(LED2_html, Led_Select, strlen(Led_Select));
2081 LED2_Status = 1;
2082 }
2083
2084 if(data[i]==0x33 /* 3 */)
2085 {
2086 at32_led_on(LED3);
2087 memcpy(LED3_html, Led_Select, strlen(Led_Select));
2088 LED3_Status = 1;
2089 }
2090
2091 if(data[i]==0x34 /* 4 */)
2092 {
2093 at32_led_on(LED4);
2094 memcpy(LED4_html, Led_Select, strlen(Led_Select));
2095 LED4_Status = 1;
2096 }
2097 }
2098 }
2099 }
2100 }
2101 if ( LED2_Status == 0)
2102 {
2103 at32_led_off(LED2);
2104 }
2105 if ( LED3_Status == 0 )
2106 {
2107 at32_led_off(LED3);
2108 }
2109 if ( LED4_Status == 0 )
2110 {
2111 at32_led_off(LED4);
2112 }
2113 pbuf_free(p);
2114
2115 fs_open(&file, "/AT32F437LED.html");
2116 sprintf(html_tmp, file.data, LED2_html, LED3_html, LED4_html);
2117 hs->file = html_tmp;
2118 hs->left = strlen(html_tmp);
2119
2120 http_send(pcb, hs);
2121
2122 /* Tell TCP that we wish be to informed of data that has been
2123 successfully sent by a call to the http_sent() function. */
2124 tcp_sent(pcb, http_sent);
2125 }
2126 else if (strncmp(data, "GET ", 4) == 0)
2127 {
2128 for (i = 0; i < 40; i++)
2129 {
2130 if (((char *)data + 4)[i] == ' ' ||
2131 ((char *)data + 4)[i] == '\r' ||
2132 ((char *)data + 4)[i] == '\n')
2133 {
2134 ((char *)data + 4)[i] = 0;
2135 }
2136 }
2137
2138 i = 0;
2139 j = 0;
2140
2141 do
2142 {
2143 fname[i] = ((char *)data + 4)[j];
2144 j++;
2145 i++;
2146 } while (fname[i - 1] != 0 && i < 40);
2147
2148 pbuf_free(p);
2149
2150
2151 fs_open(&file, "/AT32F437.html");
2152
2153 hs->file = file.data;
2154 hs->left = file.len;
2155 http_send(pcb, hs);
2156
2157 /* Tell TCP that we wish be to informed of data that has been
2158 successfully sent by a call to the http_sent() function. */
2159 tcp_sent(pcb, http_sent);
2160 }
2161 else
2162 {
2163 http_close_conn(pcb, hs);
2164 }
2165 }
2166 else
2167 {
2168 pbuf_free(p);
2169 }
2170 }
2171
2172 if (err == ERR_OK && p == NULL)
2173 {
2174
2175 http_close_conn(pcb, hs);
2176 }
2177
2178 return ERR_OK;
2179 #endif
2180}
2181
2185static err_t
2186 http_accept(void *arg, struct altcp_pcb *pcb, err_t err)
2187{
2188 struct http_state *hs;
2189 LWIP_UNUSED_ARG(err);
2190 LWIP_UNUSED_ARG(arg);
2191 LWIP_DEBUGF(HTTPD_DEBUG, ("http_accept %p / %p\n", (void *)pcb, arg));
2192
2193 if ((err != ERR_OK) || (pcb == NULL)) {
2194 return ERR_VAL;
2195 }
2196
2197 /* Set priority */
2198 altcp_setprio(pcb, HTTPD_TCP_PRIO);
2199
2200 /* Allocate memory for the structure that holds the state of the
2201 connection - initialized by that function. */
2202 hs = http_state_alloc();
2203 if (hs == NULL) {
2204 LWIP_DEBUGF(HTTPD_DEBUG, ("http_accept: Out of memory, RST\n"));
2205 return ERR_MEM;
2206 }
2207 hs->pcb = pcb;
2208
2209 /* Tell TCP that this is the structure we wish to be success for our
2210 callbacks. */
2211 altcp_arg(pcb, hs);
2212
2213 /* Set up the various callback functions */
2214 altcp_recv(pcb, http_recv);
2215 altcp_err(pcb, http_err);
2216 altcp_poll(pcb, http_poll, HTTPD_POLL_INTERVAL);
2217 altcp_sent(pcb, http_sent);
2218
2219 return ERR_OK;
2220}
2221
2222static void
2223 httpd_init_pcb(struct altcp_pcb *pcb, uint16_t port)
2224{
2225 err_t err;
2226
2227 if (pcb) {
2228 altcp_setprio(pcb, HTTPD_TCP_PRIO);
2229 /* set SOF_REUSEADDR here to explicitly bind httpd to multiple interfaces */
2230 err = altcp_bind(pcb, IP_ANY_TYPE, port);
2231 LWIP_UNUSED_ARG(err); /* in case of LWIP_NOASSERT */
2232 LWIP_ASSERT("httpd_init: tcp_bind error", err == ERR_OK);
2233 pcb = altcp_listen(pcb);
2234 LWIP_ASSERT("httpd_init: tcp_listen error", pcb != NULL);
2235 altcp_accept(pcb, http_accept);
2236 }
2237}
2238
2243void
2244 httpd_init(void)
2245{
2246 struct altcp_pcb *pcb;
2247
2248#if HTTPD_USE_MEM_POOL
2249 LWIP_MEMPOOL_INIT(HTTPD_STATE);
2250#if LWIP_HTTPD_SSI
2251 LWIP_MEMPOOL_INIT(HTTPD_SSI_STATE);
2252#endif
2253#endif
2254 LWIP_DEBUGF(HTTPD_DEBUG, ("httpd_init\n"));
2255
2256 /* LWIP_ASSERT_CORE_LOCKED(); is checked by tcp_new() */
2257
2258 pcb = altcp_tcp_new_ip_type(IPADDR_TYPE_ANY);
2259 LWIP_ASSERT("httpd_init: tcp_new error", pcb != NULL);
2260 httpd_init_pcb(pcb, HTTPD_SERVER_PORT);
2261}
2262
2263#if HTTPD_ENABLE_HTTPS
2269void
2270httpd_inits(struct altcp_tls_config *conf)
2271{
2272#if LWIP_ALTCP_TLS
2273 struct altcp_pcb *pcb_tls = altcp_tls_new(conf, IPADDR_TYPE_ANY);
2274 LWIP_ASSERT("httpd_init: altcp_tls_new error", pcb_tls != NULL);
2275 httpd_init_pcb(pcb_tls, HTTPD_SERVER_PORT_HTTPS);
2276#else /* LWIP_ALTCP_TLS */
2277 LWIP_UNUSED_ARG(conf);
2278#endif /* LWIP_ALTCP_TLS */
2279}
2280#endif /* HTTPD_ENABLE_HTTPS */
2281
2282#if LWIP_HTTPD_SSI
2291void
2292http_set_ssi_handler(tSSIHandler ssi_handler, const char **tags, int num_tags)
2293{
2294 LWIP_DEBUGF(HTTPD_DEBUG, ("http_set_ssi_handler\n"));
2295
2296 LWIP_ASSERT("no ssi_handler given", ssi_handler != NULL);
2297 httpd_ssi_handler = ssi_handler;
2298
2299#if LWIP_HTTPD_SSI_RAW
2300 LWIP_UNUSED_ARG(tags);
2301 LWIP_UNUSED_ARG(num_tags);
2302#else /* LWIP_HTTPD_SSI_RAW */
2303 LWIP_ASSERT("no tags given", tags != NULL);
2304 LWIP_ASSERT("invalid number of tags", num_tags > 0);
2305
2306 httpd_tags = tags;
2307 httpd_num_tags = num_tags;
2308#endif /* !LWIP_HTTPD_SSI_RAW */
2309}
2310#endif /* LWIP_HTTPD_SSI */
2311
2312#if LWIP_HTTPD_CGI
2320void
2321http_set_cgi_handlers(const tCGI *cgis, int num_handlers)
2322{
2323 LWIP_ASSERT("no cgis given", cgis != NULL);
2324 LWIP_ASSERT("invalid number of handlers", num_handlers > 0);
2325
2326 httpd_cgis = cgis;
2327 httpd_num_cgis = num_handlers;
2328}
2329#endif /* LWIP_HTTPD_CGI */
2330
2331#endif /* LWIP_TCP && LWIP_CALLBACK_API */
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_board.h
html_tmp
char html_tmp[4096]
Definition: httpd.c:115
HTTP_DATA_TO_SEND_FREED
#define HTTP_DATA_TO_SEND_FREED
Definition: httpd.c:103
http_accept
static err_t http_accept(void *arg, struct altcp_pcb *pcb, err_t err)
Definition: httpd.c:2186
http_send_data_nonssi
static uint8_t http_send_data_nonssi(struct altcp_pcb *pcb, struct http_state *hs)
Definition: httpd.c:1069
HTTP_FREE_HTTP_STATE
#define HTTP_FREE_HTTP_STATE(x)
Definition: httpd.c:251
HTTP_ALLOC_HTTP_STATE
#define HTTP_ALLOC_HTTP_STATE()
Definition: httpd.c:250
http_poll
static err_t http_poll(void *arg, struct altcp_pcb *pcb)
Definition: httpd.c:1873
http_write
static err_t http_write(struct altcp_pcb *pcb, const void *ptr, uint16_t *length, uint8_t apiflags)
Definition: httpd.c:480
http_find_error_file
#define http_find_error_file(hs, error_nr)
Definition: httpd.c:1539
http_eof
static void http_eof(struct altcp_pcb *pcb, struct http_state *hs)
Definition: httpd.c:602
http_send
static uint8_t http_send(struct altcp_pcb *pcb, struct http_state *hs)
Definition: httpd.c:1436
http_recv
static err_t http_recv(void *arg, struct altcp_pcb *pcb, struct pbuf *p, err_t err)
Definition: httpd.c:1921
http_add_connection
#define http_add_connection(hs)
Definition: httpd.c:357
http_check_eof
static uint8_t http_check_eof(struct altcp_pcb *pcb, struct http_state *hs)
Definition: httpd.c:970
CRLF
#define CRLF
Definition: httpd.c:79
http_close_or_abort_conn
static err_t http_close_or_abort_conn(struct altcp_pcb *pcb, struct http_state *hs, uint8_t abort_conn)
Definition: httpd.c:543
LWIP_HTTPD_URI_BUF_LEN
#define LWIP_HTTPD_URI_BUF_LEN
Definition: httpd.c:130
http_close_conn
static err_t http_close_conn(struct altcp_pcb *pcb, struct http_state *hs)
Definition: httpd.c:593
HTTP_DATA_TO_SEND_CONTINUE
#define HTTP_DATA_TO_SEND_CONTINUE
Definition: httpd.c:105
http_err
static void http_err(void *arg, err_t err)
Definition: httpd.c:1829
HTTP_IS_DATA_VOLATILE
#define HTTP_IS_DATA_VOLATILE(hs)
Definition: httpd.c:95
HTTP_DATA_TO_SEND_BREAK
#define HTTP_DATA_TO_SEND_BREAK
Definition: httpd.c:104
HTTP_NO_DATA_TO_SEND
#define HTTP_NO_DATA_TO_SEND
Definition: httpd.c:106
http_state_eof
static void http_state_eof(struct http_state *hs)
Definition: httpd.c:425
http_state_init
static void http_state_init(struct http_state *hs)
Definition: httpd.c:393
httpd_init
void httpd_init(void)
Definition: httpd.c:2244
httpd_init_pcb
static void httpd_init_pcb(struct altcp_pcb *pcb, uint16_t port)
Definition: httpd.c:2223
http_state_alloc
static struct http_state * http_state_alloc(void)
Definition: httpd.c:405
http_remove_connection
#define http_remove_connection(hs)
Definition: httpd.c:358
HTTP_IS_HDR_VOLATILE
#define HTTP_IS_HDR_VOLATILE(hs, ptr)
Definition: httpd.c:99
http_sent
static err_t http_sent(void *arg, struct altcp_pcb *pcb, uint16_t len)
Definition: httpd.c:1846
http_state_free
static void http_state_free(struct http_state *hs)
Definition: httpd.c:461
file
FIL file
Definition: project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c:43
data_len
uint16_t data_len
Definition: project/at_start_f435/examples/usb_device/virtual_comport/src/main.c:47
j
uint32_t j
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:44
adc_ordinary_conversion_data_get
uint16_t adc_ordinary_conversion_data_get(adc_type *adc_x)
return the last conversion data for ordinary channel of the specified adc peripheral.
Definition: at32f435_437_adc.c:1009
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
fs_bytes_left
int fs_bytes_left(struct fs_file *file)
Definition: fs.c:180
fs_open
err_t fs_open(struct fs_file *file, const char *name)
Definition: fs.c:66
fs_close
void fs_close(struct fs_file *file)
Definition: fs.c:105
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
pcb
struct tcp_pcb * pcb
Definition: project/at_start_f437/examples/emac/mqtt_client/src/netconf.c:63
httpd_structs.h
TCP_SND_QUEUELEN
#define TCP_SND_QUEUELEN
Definition: project/at_start_f437/examples/emac/dns_client/inc/lwipopts.h:69
FS_FILE_FLAGS_HEADER_PERSISTENT
#define FS_FILE_FLAGS_HEADER_PERSISTENT
Definition: project/at_start_f437/examples/emac/http_server/src/fsdata.c:10
default_filename
Definition: httpd.c:110
default_filename::name
const char * name
Definition: httpd.c:111
default_filename::shtml
uint8_t shtml
Definition: httpd.c:112
fs_file
Definition: httpserver.h:41
fs_file::len
int len
Definition: httpserver.h:43
http_state
Definition: httpd.c:191
http_state::left
uint32_t left
Definition: httpd.c:208
http_state::file
const char * file
Definition: httpd.c:197
http_state::pcb
struct altcp_pcb * pcb
Definition: httpd.c:199
http_state::file_handle
struct fs_file file_handle
Definition: httpd.c:195
http_state::retries
uint8_t retries
Definition: httpd.c:209
http_state::handle
struct fs_file * handle
Definition: httpd.c:196


AT32F435/437 Firmwary Library: httpd_structs.h File Reference

  • at_start_f437
  • examples
  • emac
  • http_server
  • inc
httpd_structs.h File Reference
#include "lwip/apps/httpd.h"

Go to the source code of this file.


AT32F435/437 Firmwary Library: httpd_structs.h Source File

  • at_start_f437
  • examples
  • emac
  • http_server
  • inc
httpd_structs.h
Go to the documentation of this file.
1#ifndef LWIP_HTTPD_STRUCTS_H
2#define LWIP_HTTPD_STRUCTS_H
3
4#include "lwip/apps/httpd.h"
5
6#ifdef __cplusplus
7 extern "C" {
8#endif
9
10#if LWIP_HTTPD_DYNAMIC_HEADERS
30typedef struct {
31 const char *extension;
32 const char *content_type;
33} tHTTPHeader;
34
37static const char *const g_psHTTPHeaderStrings[] = {
38 "HTTP/1.0 200 OK\r\n",
39 "HTTP/1.0 404 File not found\r\n",
40 "HTTP/1.0 400 Bad Request\r\n",
41 "HTTP/1.0 501 Not Implemented\r\n",
42 "HTTP/1.1 200 OK\r\n",
43 "HTTP/1.1 404 File not found\r\n",
44 "HTTP/1.1 400 Bad Request\r\n",
45 "HTTP/1.1 501 Not Implemented\r\n",
46 "Content-Length: ",
47 "Connection: Close\r\n",
48 "Connection: keep-alive\r\n",
49 "Connection: keep-alive\r\nContent-Length: ",
50 "Server: "HTTPD_SERVER_AGENT"\r\n",
51 "\r\n<html><body><h2>404: The requested file cannot be found.</h2></body></html>\r\n"
52#if LWIP_HTTPD_SUPPORT_11_KEEPALIVE
53 , "Connection: keep-alive\r\nContent-Length: 77\r\n\r\n<html><body><h2>404: The requested file cannot be found.</h2></body></html>\r\n"
54#endif
55};
56
57/* Indexes into the g_psHTTPHeaderStrings array */
58#define HTTP_HDR_OK 0 /* 200 OK */
59#define HTTP_HDR_NOT_FOUND 1 /* 404 File not found */
60#define HTTP_HDR_BAD_REQUEST 2 /* 400 Bad request */
61#define HTTP_HDR_NOT_IMPL 3 /* 501 Not Implemented */
62#define HTTP_HDR_OK_11 4 /* 200 OK */
63#define HTTP_HDR_NOT_FOUND_11 5 /* 404 File not found */
64#define HTTP_HDR_BAD_REQUEST_11 6 /* 400 Bad request */
65#define HTTP_HDR_NOT_IMPL_11 7 /* 501 Not Implemented */
66#define HTTP_HDR_CONTENT_LENGTH 8 /* Content-Length: (HTTP 1.0)*/
67#define HTTP_HDR_CONN_CLOSE 9 /* Connection: Close (HTTP 1.1) */
68#define HTTP_HDR_CONN_KEEPALIVE 10 /* Connection: keep-alive (HTTP 1.1) */
69#define HTTP_HDR_KEEPALIVE_LEN 11 /* Connection: keep-alive + Content-Length: (HTTP 1.1)*/
70#define HTTP_HDR_SERVER 12 /* Server: HTTPD_SERVER_AGENT */
71#define DEFAULT_404_HTML 13 /* default 404 body */
72#if LWIP_HTTPD_SUPPORT_11_KEEPALIVE
73#define DEFAULT_404_HTML_PERSISTENT 14 /* default 404 body, but including Connection: keep-alive */
74#endif
75
76#define HTTP_CONTENT_TYPE(contenttype) "Content-Type: "contenttype"\r\n\r\n"
77#define HTTP_CONTENT_TYPE_ENCODING(contenttype, encoding) "Content-Type: "contenttype"\r\nContent-Encoding: "encoding"\r\n\r\n"
78
79#define HTTP_HDR_HTML HTTP_CONTENT_TYPE("text/html")
80#define HTTP_HDR_SSI HTTP_CONTENT_TYPE("text/html\r\nExpires: Fri, 10 Apr 2008 14:00:00 GMT\r\nPragma: no-cache")
81#define HTTP_HDR_GIF HTTP_CONTENT_TYPE("image/gif")
82#define HTTP_HDR_PNG HTTP_CONTENT_TYPE("image/png")
83#define HTTP_HDR_JPG HTTP_CONTENT_TYPE("image/jpeg")
84#define HTTP_HDR_BMP HTTP_CONTENT_TYPE("image/bmp")
85#define HTTP_HDR_ICO HTTP_CONTENT_TYPE("image/x-icon")
86#define HTTP_HDR_APP HTTP_CONTENT_TYPE("application/octet-stream")
87#define HTTP_HDR_JS HTTP_CONTENT_TYPE("application/javascript")
88#define HTTP_HDR_RA HTTP_CONTENT_TYPE("application/javascript")
89#define HTTP_HDR_CSS HTTP_CONTENT_TYPE("text/css")
90#define HTTP_HDR_SWF HTTP_CONTENT_TYPE("application/x-shockwave-flash")
91#define HTTP_HDR_XML HTTP_CONTENT_TYPE("text/xml")
92#define HTTP_HDR_PDF HTTP_CONTENT_TYPE("application/pdf")
93#define HTTP_HDR_JSON HTTP_CONTENT_TYPE("application/json")
94#define HTTP_HDR_CSV HTTP_CONTENT_TYPE("text/csv")
95#define HTTP_HDR_TSV HTTP_CONTENT_TYPE("text/tsv")
96#define HTTP_HDR_SVG HTTP_CONTENT_TYPE("image/svg+xml")
97#define HTTP_HDR_SVGZ HTTP_CONTENT_TYPE_ENCODING("image/svg+xml", "gzip")
98
99#define HTTP_HDR_DEFAULT_TYPE HTTP_CONTENT_TYPE("text/plain")
100
104static const tHTTPHeader g_psHTTPHeaders[] = {
105 { "html", HTTP_HDR_HTML},
106 { "htm", HTTP_HDR_HTML},
107 { "shtml", HTTP_HDR_SSI},
108 { "shtm", HTTP_HDR_SSI},
109 { "ssi", HTTP_HDR_SSI},
110 { "gif", HTTP_HDR_GIF},
111 { "png", HTTP_HDR_PNG},
112 { "jpg", HTTP_HDR_JPG},
113 { "bmp", HTTP_HDR_BMP},
114 { "ico", HTTP_HDR_ICO},
115 { "class", HTTP_HDR_APP},
116 { "cls", HTTP_HDR_APP},
117 { "js", HTTP_HDR_JS},
118 { "ram", HTTP_HDR_RA},
119 { "css", HTTP_HDR_CSS},
120 { "swf", HTTP_HDR_SWF},
121 { "xml", HTTP_HDR_XML},
122 { "xsl", HTTP_HDR_XML},
123 { "pdf", HTTP_HDR_PDF},
124 { "json", HTTP_HDR_JSON}
125#ifdef HTTPD_ADDITIONAL_CONTENT_TYPES
126 /* If you need to add content types not listed here:
127 * #define HTTPD_ADDITIONAL_CONTENT_TYPES {"ct1", HTTP_CONTENT_TYPE("text/ct1")}, {"exe", HTTP_CONTENT_TYPE("application/exe")}
128 */
129 , HTTPD_ADDITIONAL_CONTENT_TYPES
130#endif
131};
132
133#define NUM_HTTP_HEADERS LWIP_ARRAYSIZE(g_psHTTPHeaders)
134
135#endif /* LWIP_HTTPD_DYNAMIC_HEADERS */
136
137#if LWIP_HTTPD_SSI
138static const char *const g_pcSSIExtensions[] = {
139 ".shtml", ".shtm", ".ssi", ".xml", ".json"
140};
141#define NUM_SHTML_EXTENSIONS LWIP_ARRAYSIZE(g_pcSSIExtensions)
142#endif /* LWIP_HTTPD_SSI */
143
144#ifdef __cplusplus
145}
146#endif
147
148#endif /* LWIP_HTTPD_STRUCTS_H */


AT32F435/437 Firmwary Library: httpserver.c File Reference

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • bootloader
  • src
httpserver.c File Reference

httpserver program More...

#include "httpserver.h"
#include "lwip/tcp.h"
#include "fsdata.h"
#include "flash.h"
#include "iap.h"
#include <string.h>
#include <stdio.h>

Go to the source code of this file.

Detailed Description

httpserver program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file httpserver.c.


AT32F435/437 Firmwary Library: httpserver.c Source File

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • bootloader
  • src
httpserver.c
Go to the documentation of this file.
1
27#include "httpserver.h"
28#include "lwip/tcp.h"
29#include "fsdata.h"
30#include "flash.h"
31#include "iap.h"
32#include <string.h>
33#include <stdio.h>
34
35#ifdef USE_IAP_HTTP
36
37static vu32 dataflag = 0;
38static vu32 size = 0;
39static __IO uint32_t flashwriteaddress;
40static u32 totalreceived = 0;
41static char leftbytestab[4];
42static u8 leftbytes = 0;
43static __IO u8 resetpage = 0;
44static uint32_t contentlengthoffset = 0, browserflag = 0;
45static __IO uint32_t checklogin = 0;
46 flag_status http_iap_flag = RESET;
47
48struct http_state
49{
50 char *file;
51 u32_t left;
52};
53
54typedef enum
55{
56 LOGINPAGE = 0,
57 FILEUPLOADPAGE,
58 UPLOADDONEPAGE,
59 RESETDONEPAGE
60}htmlpageState;
61
62htmlpageState htmlpage;
63
64static const char http_crnl_2[4] =
65/* "\r\n--" */
66{0xd, 0xa,0x2d,0x2d};
67static const char octet_stream[14] =
68/* "octet-stream" */
69{0x6f, 0x63, 0x74, 0x65, 0x74, 0x2d, 0x73, 0x74, 0x72, 0x65, 0x61, 0x6d,0x0d, };
70static const char content_length[17] =
71/* Content Length */
72{0x43, 0x6f, 0x6e, 0x74, 0x65, 0x6e, 0x74, 0x2d, 0x4c, 0x65, 0x6e, 0x67,0x74, 0x68, 0x3a, 0x20, };
73/* Upgrade-Insecure-Requests: 1/r/n */
74static const char upgrade_insecure_request[30] =
75/* Content Length */
76{0x55, 0x70, 0x67, 0x72, 0x61, 0x64, 0x65, 0x2d, 0x49, 0x6e, 0x73, 0x65, 0x63, 0x75, 0x72, 0x65, 0x2d, 0x52, 0x65, 0x71, 0x75, 0x65, 0x73, 0x74, 0x73, 0x3a, 0x20, 0x31, 0x0d, 0x0a,};
77
78
79static uint32_t parse_content_length(char *data, uint32_t len);
80static void iap_http_writedata(char* data, uint32_t len);
81
82/* file must be allocated by caller and will be filled in
83 by the function. */
84static int fs_open(char *name, struct fs_file *file);
85
92static void conn_err(void *arg, err_t err)
93{
94 struct http_state *hs;
95
96 hs = arg;
97 mem_free(hs);
98}
99
106static void close_conn(struct tcp_pcb *pcb, struct http_state *hs)
107{
108 tcp_arg(pcb, NULL);
109 tcp_sent(pcb, NULL);
110 tcp_recv(pcb, NULL);
111 mem_free(hs);
112 tcp_close(pcb);
113}
114
121static void send_data(struct tcp_pcb *pcb, struct http_state *hs)
122{
123 err_t err;
124 u16_t len;
125
126 /* we cannot send more data than space available in the send buffer */
127 if (tcp_sndbuf(pcb) < hs->left)
128 {
129 len = tcp_sndbuf(pcb);
130 }
131 else
132 {
133 len = hs->left;
134 }
135 err = tcp_write(pcb, hs->file, len, 0);
136 if (err == ERR_OK)
137 {
138 hs->file += len;
139 hs->left -= len;
140 }
141}
142
149static err_t http_poll(void *arg, struct tcp_pcb *pcb)
150{
151 if (arg == NULL)
152 {
153 tcp_close(pcb);
154 }
155 else
156 {
157 send_data(pcb, (struct http_state *)arg);
158 }
159 return ERR_OK;
160}
161
169static err_t http_sent(void *arg, struct tcp_pcb *pcb, u16_t len)
170{
171 struct http_state *hs;
172
173 hs = arg;
174
175 if (hs->left > 0)
176 {
177 send_data(pcb, hs);
178 }
179 else
180 {
181 close_conn(pcb, hs);
182 if(resetpage ==1)
183 {
184 iap_init();
185 /* Generate a software reset */
186 NVIC_SystemReset();
187 while(1);
188 }
189
190 }
191 return ERR_OK;
192}
193
202static err_t http_recv(void *arg, struct tcp_pcb *pcb, struct pbuf *p, err_t err)
203{
204 int32_t i, len=0;
205 uint32_t dataoffset, filenameoffset, contentoffsetfirefox;
206 char *data, *ptr, login[LOGIN_SIZE];
207 volatile char filename[19];
208 struct fs_file file = {0, 0};
209 struct http_state *hs;
210 struct pbuf *ptmp = p;
211
212 hs = arg;
213
214 if (err == ERR_OK && p != NULL)
215 {
216 /* inform tcp that we have taken the data */
217 tcp_recved(pcb, p->tot_len);
218
219 if (hs->file == NULL)
220 {
221 data = p->payload;
222 len = p->tot_len;
223
224 /* process http get requests */
225 if (strncmp(data, "GET /", 5) == 0)
226 {
227 if ((strncmp(data, "GET /resetmcu.cgi", 17) ==0)&&(htmlpage == UPLOADDONEPAGE))
228 {
229 htmlpage = RESETDONEPAGE;
230 fs_open("/reset.html", &file);
231 hs->file = file.data;
232 hs->left = file.len;
233 pbuf_free(p);
234
235 /* send reset.html page */
236 send_data(pcb, hs);
237 resetpage = 1;
238
239 /* tell tcp that we wish be to informed of data that has been
240 successfully sent by a call to the http_sent() function. */
241 tcp_sent(pcb, http_sent);
242 }
243 else if ((strncmp(data, "GET /favicon.ico", 16) ==0))
244 {
245 /*send the login page (which is the index page) */
246 //htmlpage = LOGINPAGE;
247 fs_open("/index.html", &file);
248 hs->file = file.data;
249 hs->left = file.len;
250 pbuf_free(p);
251
252 /* send index.html page */
253 send_data(pcb, hs);
254
255 /* tell tcp that we wish be to informed of data that has been
256 successfully sent by a call to the http_sent() function. */
257 tcp_sent(pcb, http_sent);
258 }
259 else
260 {
261 /*send the login page (which is the index page) */
262 htmlpage = LOGINPAGE;
263 fs_open("/index.html", &file);
264 hs->file = file.data;
265 hs->left = file.len;
266 pbuf_free(p);
267
268 /* send index.html page */
269 send_data(pcb, hs);
270
271 /* tell tcp that we wish be to informed of data that has been
272 successfully sent by a call to the http_sent() function. */
273 tcp_sent(pcb, http_sent);
274 }
275 }
276
277 /* process post request for checking login */
278 else if ((strncmp(data, "POST /checklogin.cgi",20)==0)&&(htmlpage== LOGINPAGE))
279 {
280 /* parse packet for the username & password */
281 for (i=0;i<len;i++)
282 {
283 if (strncmp ((char*)(data+i), "username=", 9)==0)
284 {
285 sprintf(login,"username=%s&password=%s",USERID,PASSWORD);
286 if (strncmp((char*)(data+i), login ,LOGIN_SIZE)==0)
287 {
288 htmlpage = FILEUPLOADPAGE;
289 fs_open("/upload.html", &file);
290
291 }
292 else
293 {
294 htmlpage = LOGINPAGE;
295 /* reload index.html */
296 fs_open("/index.html", &file);
297 }
298 hs->file = file.data;
299 hs->left = file.len;
300
301 pbuf_free(p);
302
303 /* send index.html page */
304 send_data(pcb, hs);
305
306 /* tell tcp that we wish be to informed of data that has been
307 successfully sent by a call to the http_sent() function. */
308 tcp_sent(pcb, http_sent);
309 break;
310 }
311 }
312 }
313
314 /* process post request for file upload and incoming data packets after post request*/
315 else if (((strncmp(data, "POST /upload.cgi",16)==0)||(dataflag >=1))&&(htmlpage == FILEUPLOADPAGE))
316 {
317 dataoffset =0;
318 contentoffsetfirefox = 0;
319 http_iap_flag = SET;
320
321 /* post packet received */
322 if (dataflag ==0)
323 {
324 browserflag=0;
325 totalreceived =0;
326
327 /* parse packet for Content-length field */
328 size = parse_content_length(data, p->tot_len);
329
330 /* parse packet for the octet-stream field */
331 for (i=0;i<len;i++)
332 {
333 if (strncmp ((char*)(data+i), octet_stream, 13)==0)
334 {
335 dataoffset = i+16;
336 break;
337 }
338 }
339 /* case of msie8 : we do not receive data in the post packet*/
340 if (dataoffset==0)
341 {
342 dataflag++;
343 browserflag = 1;
344 pbuf_free(p);
345 return ERR_OK;
346 }
347 /* case of mozilla firefox v79.0 : we receive data in the post packet*/
348 else
349 {
350 /* parse packet for the upgrade-insecure-request field */
351 for(i = 0; i < len; i++)
352 {
353 if (strncmp ((char*)(data+i), upgrade_insecure_request, 30)==0)
354 {
355 contentoffsetfirefox = i + 32;
356 break;
357 }
358 }
359 totalreceived = len - contentoffsetfirefox;
360 }
361 }
362
363 if (((dataflag ==1)&&(browserflag==1)) || ((dataflag ==0)&&(browserflag==0)))
364 {
365 if ((dataflag ==0)&&(browserflag==0))
366 {
367 dataflag++;
368 }
369 else if ((dataflag ==1)&&(browserflag==1))
370 {
371 /* parse packet for the octet-stream field */
372 for (i=0;i<len;i++)
373 {
374 if (strncmp ((char*)(data+i), octet_stream, 13)==0)
375 {
376 dataoffset = i+16;
377 break;
378 }
379 }
380 totalreceived+=len;
381 dataflag++;
382 }
383
384 /* parse packet for the filename field */
385 filenameoffset = 0;
386 for (i=0;i<len;i++)
387 {
388 if (strncmp ((char*)(data+i), "filename=", 9)==0)
389 {
390 filenameoffset = i+10;
391 break;
392 }
393 }
394 i =0;
395 if (filenameoffset)
396 {
397 while((*(data+filenameoffset + i) != 0x22 )&&(i<40))
398 {
399 filename[i] = *(data+filenameoffset + i);
400 i++;
401 }
402 filename[i] = 0x0;
403 }
404
405 if (i==0)
406 {
407 htmlpage = FILEUPLOADPAGE;
408 /* no filename, in this case reload upload page */
409 fs_open("/upload.html", &file);
410 hs->file = file.data;
411 hs->left = file.len;
412 pbuf_free(p);
413
414 /* send index.html page */
415 send_data(pcb, hs);
416
417 /* tell tcp that we wish be to informed of data that has been
418 successfully sent by a call to the http_sent() function. */
419 tcp_sent(pcb, http_sent);
420 dataflag=0;
421 return ERR_OK;
422
423 }
424
425 flashwriteaddress = APP_START_SECTOR_ADDR;
426 }
427 /* dataflag >1 => the packet is data only */
428 else
429 {
430 totalreceived +=len;
431 }
432
433 ptr = (char*)(data + dataoffset);
434 len-= dataoffset;
435
436 /* update total data received counter */
437
438 /* check if last data packet */
439 if (totalreceived == size)
440 {
441 /* if last packet need to remove the http boundary tag */
442 /* parse packet for "\r\n--" starting from end of data */
443 i = 4;
444 while (strncmp ((char*)(data+ p->tot_len -i),http_crnl_2 , 4) && (p->tot_len -i > 0))
445 {
446 i++;
447 }
448 len -= i;
449
450 /* write data in flash */
451 len = ptmp->len;
452 len-= dataoffset;
453 while(ptmp != NULL)
454 {
455 if(len)
456 {
457 iap_http_writedata(ptr,len);
458 }
459 ptmp = ptmp->next;
460 len = ptmp->len;
461 ptr = ptmp->payload;
462 }
463
464 dataflag=0;
465 htmlpage = UPLOADDONEPAGE;
466 /* send uploaddone.html page */
467 fs_open("/uploaddone.html", &file);
468 hs->file = file.data;
469 hs->left = file.len;
470 send_data(pcb, hs);
471
472 /* tell tcp that we wish be to informed of data that has been
473 successfully sent by a call to the http_sent() function. */
474 tcp_sent(pcb, http_sent);
475 http_iap_flag = RESET;
476 }
477 /* not last data packet */
478 else
479 {
480 /* write data in flash */
481 len = ptmp->len;
482 len-= dataoffset;
483 while(ptmp != NULL)
484 {
485 if(len)
486 {
487 iap_http_writedata(ptr,len);
488 }
489 ptmp = ptmp->next;
490 len = ptmp->len;
491 ptr = ptmp->payload;
492 }
493 }
494 pbuf_free(p);
495 }
496 else
497 {
498 /* bad http requests */
499 pbuf_free(p);
500 close_conn(pcb, hs);
501 }
502 }
503 else
504 {
505 pbuf_free(p);
506 close_conn(pcb,hs);
507 }
508 }
509 if (err == ERR_OK && p == NULL)
510 {
511 /* received empty frame */
512 close_conn(pcb, hs);
513 }
514 return ERR_OK;
515}
516
524static err_t http_accept(void *arg, struct tcp_pcb *pcb, err_t err)
525{
526 struct http_state *hs;
527
528 /* allocate memory for the structure that holds the state of the connection */
529 hs = mem_malloc(sizeof(struct http_state));
530
531 if (hs == NULL)
532 {
533 return ERR_MEM;
534 }
535
536 /* initialize the structure. */
537 hs->file = NULL;
538 hs->left = 0;
539
540 /* tell tcp that this is the structure we wish to be passed for our
541 callbacks. */
542 tcp_arg(pcb, hs);
543
544 /* tell tcp that we wish to be informed of incoming data by a call
545 to the http_recv() function. */
546 tcp_recv(pcb, http_recv);
547
548 tcp_err(pcb, conn_err);
549
550 tcp_poll(pcb, http_poll, 10);
551 return ERR_OK;
552}
553
559void iap_httpd_init(void)
560{
561 struct tcp_pcb *pcb;
562 /*create new pcb*/
563 pcb = tcp_new();
564 /* bind http traffic to pcb */
565 tcp_bind(pcb, IP_ADDR_ANY, 80);
566 /* start listening on port 80 */
567 pcb = tcp_listen(pcb);
568 /* define callback function for tcp connection setup */
569 tcp_accept(pcb, http_accept);
570}
571
578static int fs_open(char *name, struct fs_file *file)
579{
580 struct fsdata_file_noconst *f;
581
582 for (f = (struct fsdata_file_noconst *)FS_ROOT; f != NULL; f = (struct fsdata_file_noconst *)f->next)
583 {
584 if (!strcmp(name, f->name))
585 {
586 file->data = f->data;
587 file->len = f->len;
588 return 1;
589 }
590 }
591 return 0;
592}
593
600static uint32_t parse_content_length(char *data, uint32_t len)
601{
602 uint32_t i=0,size=0, S=1;
603 int32_t j=0;
604 char sizestring[6], *ptr;
605
606 contentlengthoffset =0;
607
608 /* find content-length data in packet buffer */
609 for (i = 0; i < len; i++)
610 {
611 if (strncmp ((char*)(data+i), content_length, 16)==0)
612 {
613 contentlengthoffset = i+16;
614 break;
615 }
616 }
617 /* read content-length value */
618 if (contentlengthoffset)
619 {
620 i = 0;
621 ptr = (char*)(data + contentlengthoffset);
622 while(*(ptr+i)!=0x0d)
623 {
624 sizestring[i] = *(ptr+i);
625 i++;
626 contentlengthoffset++;
627 }
628 if (i>0)
629 {
630 /* transform string data into numeric format */
631 for(j=i-1;j>=0;j--)
632 {
633 size += (sizestring[j]-0x30)*S;
634 S=S*10;
635 }
636 }
637 }
638 return size;
639}
640
647static void iap_http_writedata(char * ptr, uint32_t len)
648{
649 uint32_t count, i = 0, j = 0;
650
651 /* check if any left bytes from previous packet transfer*/
652 /* if it is the case do a concat with new data to create a 32-bit word */
653 if (leftbytes)
654 {
655 while(leftbytes <= 3)
656 {
657 if(len > (j + 1))
658 {
659 leftbytestab[leftbytes++] = *(ptr+j);
660 }
661 else
662 {
663 leftbytestab[leftbytes++] = 0xFF;
664 }
665 j++;
666 }
667 flash_if_write(&flashwriteaddress, (u32*)(leftbytestab), 1);
668 leftbytes = 0;
669
670 /* update data pointer */
671 ptr = (char*)(ptr + j);
672 len = len - j;
673 }
674
675 /* write received bytes into flash */
676 count = len / 4;
677
678 /* check if remaining bytes < 4 */
679 i= len % 4;
680 if (i > 0)
681 {
682 if (totalreceived != size)
683 {
684 /* store bytes in leftbytestab */
685 leftbytes = 0;
686 for(; i > 0; i--)
687 leftbytestab[leftbytes++] = *(char*)(ptr+ len-i);
688 }
689 else count++;
690 }
691 flash_if_write(&flashwriteaddress, (u32*)ptr ,count);
692}
693#endif
http_accept
static err_t http_accept(void *arg, struct altcp_pcb *pcb, err_t err)
Definition: httpd.c:2186
http_poll
static err_t http_poll(void *arg, struct altcp_pcb *pcb)
Definition: httpd.c:1873
http_recv
static err_t http_recv(void *arg, struct altcp_pcb *pcb, struct pbuf *p, err_t err)
Definition: httpd.c:1921
http_sent
static err_t http_sent(void *arg, struct altcp_pcb *pcb, uint16_t len)
Definition: httpd.c:1846
file
FIL file
Definition: project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c:43
j
uint32_t j
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:44
vu32
__IO uint32_t vu32
Definition: at32f435_437.h:370
flag_status
flag_status
Definition: at32f435_437.h:378
u8
uint8_t u8
Definition: at32f435_437.h:364
u32
uint32_t u32
Definition: at32f435_437.h:362
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
fs_open
err_t fs_open(struct fs_file *file, const char *name)
Definition: fs.c:66
iap_init
void iap_init(void)
iap init.
Definition: at32f435_437_usart_iap_demo/source_code/app_led3_toggle/src/iap.c:61
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
flash_if_write
uint32_t flash_if_write(__IO uint32_t *flash_address, uint32_t *data, uint16_t data_length)
this function writes a data buffer in flash (data are 32-bit aligned).
Definition: utilities/at32f437_emac_iap_demo/source_code/app_led3_toggle/src/flash.c:83
APP_START_SECTOR_ADDR
#define APP_START_SECTOR_ADDR
Definition: at32f437_emac_iap_demo/source_code/bootloader/inc/iap.h:52
pcb
struct tcp_pcb * pcb
Definition: project/at_start_f437/examples/emac/mqtt_client/src/netconf.c:63
httpserver.h
httpserver header file
iap_httpd_init
void iap_httpd_init(void)
PASSWORD
#define PASSWORD
Definition: httpserver.h:38
USERID
#define USERID
Definition: httpserver.h:37
LOGIN_SIZE
#define LOGIN_SIZE
Definition: httpserver.h:39
FS_ROOT
#define FS_ROOT
Definition: project/at_start_f437/examples/emac/http_server/src/fsdata.c:514
fs_file
Definition: httpserver.h:41
fsdata_file_noconst
Definition: utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h:44
fsdata_file_noconst::len
int len
Definition: utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h:48
fsdata_file_noconst::next
struct fsdata_file * next
Definition: utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h:45
fsdata_file_noconst::data
char * data
Definition: utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h:47
fsdata_file_noconst::name
char * name
Definition: utilities/at32f437_emac_iap_demo/source_code/bootloader/inc/fsdata.h:46
http_state
Definition: httpd.c:191
http_state::left
uint32_t left
Definition: httpd.c:208
http_state::file
const char * file
Definition: httpd.c:197
name
Definition: telnet.c:50
http_iap_flag
flag_status http_iap_flag


AT32F435/437 Firmwary Library: httpserver.h File Reference

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • bootloader
  • inc
Data Structures | Macros | Functions
httpserver.h File Reference

httpserver header file More...

#include "lwip/def.h"
#include "fsdata.h"

Go to the source code of this file.

Data Structures

struct fs_file

Macros

#define | USERID "user"
#define | PASSWORD "at32"
#define | LOGIN_SIZE (15+ sizeof(USERID) + sizeof(PASSWORD))

Functions

void iap_httpd_init (void)

Detailed Description

httpserver header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file httpserver.h.

Macro Definition Documentation

◆ LOGIN_SIZE

#define LOGIN_SIZE (15+ sizeof(USERID) + sizeof(PASSWORD))

Definition at line 39 of file httpserver.h.

◆ PASSWORD

#define PASSWORD "at32"

Definition at line 38 of file httpserver.h.

◆ USERID

#define USERID "user"

Definition at line 37 of file httpserver.h.

Function Documentation

◆ iap_httpd_init()

void iap_httpd_init ( void )

Referenced by main().


AT32F435/437 Firmwary Library: httpserver.h Source File

  • utilities
  • at32f437_emac_iap_demo
  • source_code
  • bootloader
  • inc
httpserver.h
Go to the documentation of this file.
1
27#ifndef __HTTPSERVER_H__
28#define __HTTPSERVER_H__
29
30#ifdef __cplusplus
31 extern "C" {
32#endif
33
34#include "lwip/def.h"
35#include "fsdata.h"
36
37#define USERID "user"
38#define PASSWORD "at32"
39#define LOGIN_SIZE (15+ sizeof(USERID) + sizeof(PASSWORD))
40
41struct fs_file {
42 char *data;
43 int len;
44};
45
46void iap_httpd_init(void);
47
48#ifdef __cplusplus
49}
50#endif
51
52#endif
iap_httpd_init
void iap_httpd_init(void)
fs_file
Definition: httpserver.h:41
fs_file::data
char * data
Definition: httpserver.h:42
fs_file::len
int len
Definition: httpserver.h:43
fsdata.h
fsdata header file


AT32F435/437 Firmwary Library: i2c_application.c Source File

  • middlewares
  • i2c_application_library
i2c_application.c
Go to the documentation of this file.
1
27#include "i2c_application.h"
28
32#define DMA_GET_REQUEST(DMA_CHANNEL) \
33(((uint32_t)(DMA_CHANNEL) == ((uint32_t)hi2c->dma_tx_channel)) ? I2C_DMA_REQUEST_TX : I2C_DMA_REQUEST_RX)
34
38#define DMA_GET_TC_FLAG(DMA_CHANNEL) \
39(((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL1))? DMA1_FDT1_FLAG : \
40 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL2))? DMA1_FDT2_FLAG : \
41 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL3))? DMA1_FDT3_FLAG : \
42 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL4))? DMA1_FDT4_FLAG : \
43 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL5))? DMA1_FDT5_FLAG : \
44 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL6))? DMA1_FDT6_FLAG : \
45 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL7))? DMA1_FDT7_FLAG : \
46 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL1))? DMA2_FDT1_FLAG : \
47 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL2))? DMA2_FDT2_FLAG : \
48 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL3))? DMA2_FDT3_FLAG : \
49 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL4))? DMA2_FDT4_FLAG : \
50 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL5))? DMA2_FDT5_FLAG : \
51 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL6))? DMA2_FDT6_FLAG : \
52 DMA2_FDT7_FLAG)
53
57#define DMA_GET_HT_FLAG(DMA_CHANNEL) \
58(((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL1))? DMA1_HDT1_FLAG : \
59 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL2))? DMA1_HDT2_FLAG : \
60 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL3))? DMA1_HDT3_FLAG : \
61 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL4))? DMA1_HDT4_FLAG : \
62 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL5))? DMA1_HDT5_FLAG : \
63 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL6))? DMA1_HDT6_FLAG : \
64 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL7))? DMA1_HDT7_FLAG : \
65 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL1))? DMA2_HDT1_FLAG : \
66 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL2))? DMA2_HDT2_FLAG : \
67 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL3))? DMA2_HDT3_FLAG : \
68 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL4))? DMA2_HDT4_FLAG : \
69 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL5))? DMA2_HDT5_FLAG : \
70 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL6))? DMA2_HDT6_FLAG : \
71 DMA2_HDT7_FLAG)
72
76#define DMA_GET_TERR_FLAG(DMA_CHANNEL) \
77(((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL1))? DMA1_DTERR1_FLAG : \
78 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL2))? DMA1_DTERR2_FLAG : \
79 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL3))? DMA1_DTERR3_FLAG : \
80 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL4))? DMA1_DTERR4_FLAG : \
81 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL5))? DMA1_DTERR5_FLAG : \
82 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL6))? DMA1_DTERR6_FLAG : \
83 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL7))? DMA1_DTERR7_FLAG : \
84 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL1))? DMA2_DTERR1_FLAG : \
85 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL2))? DMA2_DTERR2_FLAG : \
86 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL3))? DMA2_DTERR3_FLAG : \
87 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL4))? DMA2_DTERR4_FLAG : \
88 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL5))? DMA2_DTERR5_FLAG : \
89 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL6))? DMA2_DTERR6_FLAG : \
90 DMA2_DTERR7_FLAG)
91
95#define I2C_START 0
96#define I2C_END 1
97
103__WEAK void i2c_lowlevel_init(i2c_handle_type* hi2c)
104{
105
106}
107
113void i2c_config(i2c_handle_type* hi2c)
114{
115 /* reset i2c peripheral */
116 i2c_reset(hi2c->i2cx);
117
118 /* i2c peripheral initialization */
119 i2c_lowlevel_init(hi2c);
120
121 /* i2c peripheral enable */
122 i2c_enable(hi2c->i2cx, TRUE);
123}
124
130void i2c_refresh_txdt_register(i2c_handle_type* hi2c)
131{
132 /* clear tdis flag */
133 if (i2c_flag_get(hi2c->i2cx, I2C_TDIS_FLAG) != RESET)
134 {
135 hi2c->i2cx->txdt = 0x00;
136 }
137
138 /* refresh txdt register*/
139 if (i2c_flag_get(hi2c->i2cx, I2C_TDBE_FLAG) == RESET)
140 {
141 hi2c->i2cx->sts_bit.tdbe = 1;
142 }
143}
144
150void i2c_reset_ctrl2_register(i2c_handle_type* hi2c)
151{
152 hi2c->i2cx->ctrl2_bit.saddr = 0;
153 hi2c->i2cx->ctrl2_bit.readh10 = 0;
154 hi2c->i2cx->ctrl2_bit.cnt = 0;
155 hi2c->i2cx->ctrl2_bit.rlden = 0;
156 hi2c->i2cx->ctrl2_bit.dir = 0;
157}
158
165 i2c_status_type i2c_wait_end(i2c_handle_type* hi2c, uint32_t timeout)
166{
167 while(hi2c->status != I2C_END)
168 {
169 /* check timeout */
170 if((timeout--) == 0)
171 {
172 return I2C_ERR_TIMEOUT;
173 }
174 }
175
176 if(hi2c->error_code != I2C_OK)
177 {
178 return hi2c->error_code;
179 }
180
181 return I2C_OK;
182}
183
214 i2c_status_type i2c_wait_flag(i2c_handle_type* hi2c, uint32_t flag, uint32_t event_check, uint32_t timeout)
215{
216 if(flag == I2C_BUSYF_FLAG)
217 {
218 while(i2c_flag_get(hi2c->i2cx, flag) != RESET)
219 {
220 /* check timeout */
221 if((timeout--) == 0)
222 {
223 hi2c->error_code = I2C_ERR_TIMEOUT;
224
225 return I2C_ERR_TIMEOUT;
226 }
227 }
228 }
229 else
230 {
231 while(i2c_flag_get(hi2c->i2cx, flag) == RESET)
232 {
233 /* check the ack fail flag */
234 if(event_check & I2C_EVENT_CHECK_ACKFAIL)
235 {
236 if(i2c_flag_get(hi2c->i2cx, I2C_ACKFAIL_FLAG) != RESET)
237 {
238 /* clear ack fail flag */
239 i2c_flag_clear(hi2c->i2cx, I2C_ACKFAIL_FLAG);
240
241 hi2c->error_code = I2C_ERR_ACKFAIL;
242
243 return I2C_ERR_ACKFAIL;
244 }
245 }
246
247 /* check the stop flag */
248 if(event_check & I2C_EVENT_CHECK_STOP)
249 {
250 if(i2c_flag_get(hi2c->i2cx, I2C_STOPF_FLAG) != RESET)
251 {
252 /* clear stop flag */
253 i2c_flag_clear(hi2c->i2cx, I2C_STOPF_FLAG);
254
255 i2c_reset_ctrl2_register(hi2c);
256
257 hi2c->error_code = I2C_ERR_STOP;
258
259 return I2C_ERR_STOP;
260 }
261 }
262
263 /* check timeout */
264 if((timeout--) == 0)
265 {
266 hi2c->error_code = I2C_ERR_TIMEOUT;
267
268 return I2C_ERR_TIMEOUT;
269 }
270 }
271 }
272
273 return I2C_OK;
274}
275
284void i2c_dma_config(i2c_handle_type* hi2c, dma_channel_type* dma_channel, uint8_t* pdata, uint16_t size)
285{
286 /* disable the dma channel */
287 dma_channel_enable(dma_channel, FALSE);
288
289 /* disable the transfer complete interrupt */
290 dma_interrupt_enable(dma_channel, DMA_FDT_INT, FALSE);
291
292 /* configure the dma channel with the buffer address and the buffer size */
293 hi2c->dma_init_struct.memory_base_addr = (uint32_t)pdata;
294 hi2c->dma_init_struct.direction = (dma_channel == hi2c->dma_tx_channel) ? DMA_DIR_MEMORY_TO_PERIPHERAL : DMA_DIR_PERIPHERAL_TO_MEMORY;
295 hi2c->dma_init_struct.peripheral_base_addr = (dma_channel == hi2c->dma_tx_channel) ? (uint32_t)&hi2c->i2cx->txdt : (uint32_t)&hi2c->i2cx->rxdt;
296 hi2c->dma_init_struct.buffer_size = (uint32_t)size;
297 dma_init(dma_channel, &hi2c->dma_init_struct);
298
299 /* enable the transfer complete interrupt */
300 dma_interrupt_enable(dma_channel, DMA_FDT_INT, TRUE);
301
302 /* enable the dma channel */
303 dma_channel_enable(dma_channel, TRUE);
304}
305
317void i2c_start_transfer(i2c_handle_type* hi2c, uint16_t address, i2c_start_mode_type start)
318{
319 if (hi2c->pcount > MAX_TRANSFER_CNT)
320 {
321 hi2c->psize = MAX_TRANSFER_CNT;
322
323 i2c_transmit_set(hi2c->i2cx, address, hi2c->psize, I2C_RELOAD_MODE, start);
324 }
325 else
326 {
327 hi2c->psize = hi2c->pcount;
328
329 i2c_transmit_set(hi2c->i2cx, address, hi2c->psize, I2C_AUTO_STOP_MODE, start);
330 }
331}
332
344void i2c_start_transfer_dma(i2c_handle_type* hi2c, dma_channel_type* dma_channelx, uint16_t address, i2c_start_mode_type start)
345{
346 if (hi2c->pcount > MAX_TRANSFER_CNT)
347 {
348 hi2c->psize = MAX_TRANSFER_CNT;
349
350 /* config dma */
351 i2c_dma_config(hi2c, dma_channelx, hi2c->pbuff, hi2c->psize);
352
353 i2c_transmit_set(hi2c->i2cx, address, hi2c->psize, I2C_RELOAD_MODE, start);
354 }
355 else
356 {
357 hi2c->psize = hi2c->pcount;
358
359 /* config dma */
360 i2c_dma_config(hi2c, dma_channelx, hi2c->pbuff, hi2c->psize);
361
362 i2c_transmit_set(hi2c->i2cx, address, hi2c->psize, I2C_AUTO_STOP_MODE, start);
363 }
364}
365
375 i2c_status_type i2c_master_transmit(i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout)
376{
377 /* initialization parameters */
378 hi2c->pbuff = pdata;
379 hi2c->pcount = size;
380
381 hi2c->error_code = I2C_OK;
382
383 /* wait for the busy flag to be reset */
384 if (i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
385 {
386 return I2C_ERR_STEP_1;
387 }
388
389 /* start transfer */
390 i2c_start_transfer(hi2c, address, I2C_GEN_START_WRITE);
391
392 while (hi2c->pcount > 0)
393 {
394 /* wait for the tdis flag to be set */
395 if(i2c_wait_flag(hi2c, I2C_TDIS_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
396 {
397 return I2C_ERR_STEP_2;
398 }
399
400 /* send data */
401 i2c_data_send(hi2c->i2cx, *hi2c->pbuff++);
402 hi2c->psize--;
403 hi2c->pcount--;
404
405 if ((hi2c->psize == 0) && (hi2c->pcount != 0))
406 {
407 /* wait for the tcrld flag to be set */
408 if (i2c_wait_flag(hi2c, I2C_TCRLD_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
409 {
410 return I2C_ERR_STEP_3;
411 }
412
413 /* continue transfer */
414 i2c_start_transfer(hi2c, address, I2C_WITHOUT_START);
415 }
416 }
417
418 /* wait for the stop flag to be set */
419 if(i2c_wait_flag(hi2c, I2C_STOPF_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
420 {
421 return I2C_ERR_STEP_4;
422 }
423
424 /* clear stop flag */
425 i2c_flag_clear(hi2c->i2cx, I2C_STOPF_FLAG);
426
427 /* reset ctrl2 register */
428 i2c_reset_ctrl2_register(hi2c);
429
430 return I2C_OK;
431}
432
441 i2c_status_type i2c_slave_receive(i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout)
442{
443 /* initialization parameters */
444 hi2c->pbuff = pdata;
445 hi2c->pcount = size;
446
447 hi2c->error_code = I2C_OK;
448
449 /* wait for the busy flag to be reset */
450 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
451 {
452 return I2C_ERR_STEP_1;
453 }
454
455 /* enable acknowledge */
456 i2c_ack_enable(hi2c->i2cx, TRUE);
457
458 /* wait for the addr flag to be set */
459 if (i2c_wait_flag(hi2c, I2C_ADDRF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
460 {
461 return I2C_ERR_STEP_2;
462 }
463
464 /* clear addr flag */
465 i2c_flag_clear(hi2c->i2cx, I2C_ADDRF_FLAG);
466
467 while (hi2c->pcount > 0)
468 {
469 /* wait for the rdbf flag to be set */
470 if(i2c_wait_flag(hi2c, I2C_RDBF_FLAG, I2C_EVENT_CHECK_STOP, timeout) != I2C_OK)
471 {
472 /* disable acknowledge */
473 i2c_ack_enable(hi2c->i2cx, FALSE);
474
475 /* if data is received, read data */
476 if (i2c_flag_get(hi2c->i2cx, I2C_RDBF_FLAG) == SET)
477 {
478 /* read data */
479 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
480 hi2c->pcount--;
481 }
482
483 return I2C_ERR_STEP_4;
484 }
485
486 /* read data */
487 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
488 hi2c->pcount--;
489 }
490
491 /* wait for the stop flag to be set */
492 if(i2c_wait_flag(hi2c, I2C_STOPF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
493 {
494 /* disable acknowledge */
495 i2c_ack_enable(hi2c->i2cx, FALSE);
496
497 return I2C_ERR_STEP_5;
498 }
499
500 /* clear stop flag */
501 i2c_flag_clear(hi2c->i2cx, I2C_STOPF_FLAG);
502
503 /* wait for the busy flag to be reset */
504 if (i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
505 {
506 /* disable acknowledge */
507 i2c_ack_enable(hi2c->i2cx, FALSE);
508
509 return I2C_ERR_STEP_6;
510 }
511
512 return I2C_OK;
513}
514
524 i2c_status_type i2c_master_receive(i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout)
525{
526 /* initialization parameters */
527 hi2c->pbuff = pdata;
528 hi2c->pcount = size;
529
530 hi2c->error_code = I2C_OK;
531
532 /* wait for the busy flag to be reset */
533 if (i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
534 {
535 return I2C_ERR_STEP_1;
536 }
537
538 /* start transfer */
539 i2c_start_transfer(hi2c, address, I2C_GEN_START_READ);
540
541 while (hi2c->pcount > 0)
542 {
543 /* wait for the rdbf flag to be set */
544 if(i2c_wait_flag(hi2c, I2C_RDBF_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
545 {
546 return I2C_ERR_STEP_2;
547 }
548
549 /* read data */
550 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
551 hi2c->pcount--;
552 hi2c->psize--;
553
554 if ((hi2c->psize == 0) && (hi2c->pcount != 0))
555 {
556 /* wait for the tcrld flag to be set */
557 if (i2c_wait_flag(hi2c, I2C_TCRLD_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
558 {
559 return I2C_ERR_STEP_3;
560 }
561
562 /* continue transfer */
563 i2c_start_transfer(hi2c, address, I2C_WITHOUT_START);
564 }
565 }
566
567 /* wait for the stop flag to be set */
568 if(i2c_wait_flag(hi2c, I2C_STOPF_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
569 {
570 return I2C_ERR_STEP_4;
571 }
572
573 /* clear stop flag */
574 i2c_flag_clear(hi2c->i2cx, I2C_STOPF_FLAG);
575
576 /* reset ctrl2 register */
577 i2c_reset_ctrl2_register(hi2c);
578
579 return I2C_OK;
580}
581
590 i2c_status_type i2c_slave_transmit(i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout)
591{
592 /* initialization parameters */
593 hi2c->pbuff = pdata;
594 hi2c->pcount = size;
595
596 hi2c->error_code = I2C_OK;
597
598 /* wait for the busy flag to be reset */
599 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
600 {
601 return I2C_ERR_STEP_1;
602 }
603
604 /* enable acknowledge */
605 i2c_ack_enable(hi2c->i2cx, TRUE);
606
607 /* wait for the addr flag to be set */
608 if (i2c_wait_flag(hi2c, I2C_ADDRF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
609 {
610 /* disable acknowledge */
611 i2c_ack_enable(hi2c->i2cx, FALSE);
612 return I2C_ERR_STEP_2;
613 }
614
615 /* clear addr flag */
616 i2c_flag_clear(hi2c->i2cx, I2C_ADDRF_FLAG);
617
618 /* if 10-bit address mode is used */
619 if (hi2c->i2cx->ctrl2_bit.addr10 != RESET)
620 {
621 /* wait for the addr flag to be set */
622 if (i2c_wait_flag(hi2c, I2C_ADDRF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
623 {
624 /* disable acknowledge */
625 i2c_ack_enable(hi2c->i2cx, FALSE);
626
627 return I2C_ERR_STEP_3;
628 }
629
630 /* clear addr flag */
631 i2c_flag_clear(hi2c->i2cx, I2C_ADDRF_FLAG);
632 }
633
634 while (hi2c->pcount > 0)
635 {
636 /* wait for the tdis flag to be set */
637 if(i2c_wait_flag(hi2c, I2C_TDIS_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
638 {
639 /* disable acknowledge */
640 i2c_ack_enable(hi2c->i2cx, FALSE);
641
642 return I2C_ERR_STEP_5;
643 }
644
645 /* send data */
646 i2c_data_send(hi2c->i2cx, *hi2c->pbuff++);
647 hi2c->pcount--;
648 }
649
650 /* wait for the ackfail flag to be set */
651 if(i2c_wait_flag(hi2c, I2C_ACKFAIL_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
652 {
653 return I2C_ERR_STEP_6;
654 }
655
656 /* clear ack fail flag */
657 i2c_flag_clear(hi2c->i2cx, I2C_ACKFAIL_FLAG);
658
659 /* wait for the stop flag to be set */
660 if(i2c_wait_flag(hi2c, I2C_STOPF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
661 {
662 /* disable acknowledge */
663 i2c_ack_enable(hi2c->i2cx, FALSE);
664
665 return I2C_ERR_STEP_7;
666 }
667
668 /* clear stop flag */
669 i2c_flag_clear(hi2c->i2cx, I2C_STOPF_FLAG);
670
671 /* wait for the busy flag to be reset */
672 if (i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
673 {
674 /* disable acknowledge */
675 i2c_ack_enable(hi2c->i2cx, FALSE);
676
677 return I2C_ERR_STEP_8;
678 }
679
680 /* refresh tx dt register */
681 i2c_refresh_txdt_register(hi2c);
682
683 return I2C_OK;
684}
685
695 i2c_status_type i2c_master_transmit_int(i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout)
696{
697 /* initialization parameters */
698 hi2c->mode = I2C_INT_MA_TX;
699 hi2c->status = I2C_START;
700
701 hi2c->pbuff = pdata;
702 hi2c->pcount = size;
703
704 hi2c->error_code = I2C_OK;
705
706 /* wait for the busy flag to be reset */
707 if (i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
708 {
709 return I2C_ERR_STEP_1;
710 }
711
712 /* start transfer */
713 i2c_start_transfer(hi2c, address, I2C_GEN_START_WRITE);
714
715 /* enable interrupt */
716 i2c_interrupt_enable(hi2c->i2cx, I2C_ERR_INT | I2C_TDC_INT | I2C_STOP_INT | I2C_ACKFIAL_INT | I2C_TD_INT, TRUE);
717
718 return I2C_OK;
719}
720
729 i2c_status_type i2c_slave_receive_int(i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout)
730{
731 /* initialization parameters */
732 hi2c->mode = I2C_INT_SLA_RX;
733 hi2c->status = I2C_START;
734
735 hi2c->pbuff = pdata;
736 hi2c->pcount = size;
737
738 hi2c->error_code = I2C_OK;
739
740 /* wait for the busy flag to be reset */
741 if (i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
742 {
743 return I2C_ERR_STEP_1;
744 }
745
746 /* enable acknowledge */
747 i2c_ack_enable(hi2c->i2cx, TRUE);
748
749 /* enable interrupt */
750 i2c_interrupt_enable(hi2c->i2cx, I2C_ERR_INT | I2C_TDC_INT | I2C_STOP_INT | I2C_ACKFIAL_INT | I2C_ADDR_INT | I2C_RD_INT, TRUE);
751
752 return I2C_OK;
753}
754
764 i2c_status_type i2c_master_receive_int(i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout)
765{
766 /* initialization parameters */
767 hi2c->mode = I2C_INT_MA_RX;
768 hi2c->status = I2C_START;
769
770 hi2c->pbuff = pdata;
771 hi2c->pcount = size;
772
773 hi2c->error_code = I2C_OK;
774
775 /* wait for the busy flag to be reset */
776 if (i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
777 {
778 return I2C_ERR_STEP_1;
779 }
780
781 /* start transfer */
782 i2c_start_transfer(hi2c, address, I2C_GEN_START_READ);
783
784 /* enable interrupt */
785 i2c_interrupt_enable(hi2c->i2cx, I2C_ERR_INT | I2C_TDC_INT | I2C_STOP_INT | I2C_ACKFIAL_INT | I2C_RD_INT, TRUE);
786
787 return I2C_OK;
788}
789
798 i2c_status_type i2c_slave_transmit_int(i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout)
799{
800 /* initialization parameters */
801 hi2c->mode = I2C_INT_SLA_TX;
802 hi2c->status = I2C_START;
803
804 hi2c->pbuff = pdata;
805 hi2c->pcount = size;
806
807 hi2c->error_code = I2C_OK;
808
809 /* wait for the busy flag to be reset */
810 if (i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
811 {
812 return I2C_ERR_STEP_1;
813 }
814
815 /* enable acknowledge */
816 i2c_ack_enable(hi2c->i2cx, TRUE);
817
818 /* enable interrupt */
819 i2c_interrupt_enable(hi2c->i2cx, I2C_ERR_INT | I2C_TDC_INT | I2C_STOP_INT | I2C_ACKFIAL_INT | I2C_ADDR_INT | I2C_TD_INT, TRUE);
820
821 i2c_refresh_txdt_register(hi2c);
822
823 return I2C_OK;
824}
825
835 i2c_status_type i2c_master_transmit_dma(i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout)
836{
837 /* initialization parameters */
838 hi2c->mode = I2C_DMA_MA_TX;
839 hi2c->status = I2C_START;
840
841 hi2c->pbuff = pdata;
842 hi2c->pcount = size;
843
844 hi2c->error_code = I2C_OK;
845
846 /* wait for the busy flag to be reset */
847 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
848 {
849 return I2C_ERR_STEP_1;
850 }
851
852 /* disable dma request */
853 i2c_dma_enable(hi2c->i2cx, I2C_DMA_REQUEST_TX, FALSE);
854
855 /* start transfer */
856 i2c_start_transfer_dma(hi2c, hi2c->dma_tx_channel, address, I2C_GEN_START_WRITE);
857
858 /* enable i2c interrupt */
859 i2c_interrupt_enable(hi2c->i2cx, I2C_ERR_INT | I2C_ACKFIAL_INT, TRUE);
860
861 /* enable dma request */
862 i2c_dma_enable(hi2c->i2cx, I2C_DMA_REQUEST_TX, TRUE);
863
864 return I2C_OK;
865}
866
875 i2c_status_type i2c_slave_receive_dma(i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout)
876{
877 /* initialization parameters */
878 hi2c->mode = I2C_DMA_SLA_RX;
879 hi2c->status = I2C_START;
880
881 hi2c->pbuff = pdata;
882 hi2c->pcount = size;
883
884 hi2c->error_code = I2C_OK;
885
886 /* wait for the busy flag to be reset */
887 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
888 {
889 return I2C_ERR_STEP_1;
890 }
891
892 /* disable dma request */
893 i2c_dma_enable(hi2c->i2cx, I2C_DMA_REQUEST_RX, FALSE);
894
895 /* config dma */
896 i2c_dma_config(hi2c, hi2c->dma_rx_channel, hi2c->pbuff, size);
897
898 /* enable acknowledge */
899 i2c_ack_enable(hi2c->i2cx, TRUE);
900
901 /* enable i2c interrupt */
902 i2c_interrupt_enable(hi2c->i2cx, I2C_ADDR_INT | I2C_STOP_INT | I2C_ACKFIAL_INT | I2C_ERR_INT, TRUE);
903
904 /* enable dma request */
905 i2c_dma_enable(hi2c->i2cx, I2C_DMA_REQUEST_RX, TRUE);
906
907 return I2C_OK;
908}
909
919 i2c_status_type i2c_master_receive_dma(i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout)
920{
921 /* initialization parameters */
922 hi2c->mode = I2C_DMA_MA_RX;
923 hi2c->status = I2C_START;
924
925 hi2c->pbuff = pdata;
926 hi2c->pcount = size;
927
928 hi2c->error_code = I2C_OK;
929
930 /* wait for the busy flag to be reset */
931 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
932 {
933 return I2C_ERR_STEP_1;
934 }
935
936 /* disable dma request */
937 i2c_dma_enable(hi2c->i2cx, I2C_DMA_REQUEST_RX, FALSE);
938
939 /* start transfer */
940 i2c_start_transfer_dma(hi2c, hi2c->dma_rx_channel, address, I2C_GEN_START_READ);
941
942 /* enable i2c interrupt */
943 i2c_interrupt_enable(hi2c->i2cx, I2C_ERR_INT | I2C_ACKFIAL_INT, TRUE);
944
945 /* enable dma request */
946 i2c_dma_enable(hi2c->i2cx, I2C_DMA_REQUEST_RX, TRUE);
947
948 return I2C_OK;
949}
950
959 i2c_status_type i2c_slave_transmit_dma(i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout)
960{
961 /* initialization parameters */
962 hi2c->mode = I2C_DMA_SLA_TX;
963 hi2c->status = I2C_START;
964
965 hi2c->pbuff = pdata;
966 hi2c->pcount = size;
967
968 hi2c->error_code = I2C_OK;
969
970 /* wait for the busy flag to be reset */
971 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
972 {
973 return I2C_ERR_STEP_1;
974 }
975
976 /* disable dma request */
977 i2c_dma_enable(hi2c->i2cx, I2C_DMA_REQUEST_TX, FALSE);
978
979 /* config dma */
980 i2c_dma_config(hi2c, hi2c->dma_tx_channel, hi2c->pbuff, size);
981
982 /* enable acknowledge */
983 i2c_ack_enable(hi2c->i2cx, TRUE);
984
985 /* enable i2c interrupt */
986 i2c_interrupt_enable(hi2c->i2cx, I2C_ADDR_INT | I2C_STOP_INT | I2C_ACKFIAL_INT | I2C_ERR_INT, TRUE);
987
988 /* enable dma request */
989 i2c_dma_enable(hi2c->i2cx, I2C_DMA_REQUEST_TX, TRUE);
990
991 return I2C_OK;
992}
993
1004 i2c_status_type i2c_memory_write(i2c_handle_type* hi2c, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout)
1005{
1006 /* initialization parameters */
1007 hi2c->pbuff = pdata;
1008 hi2c->pcount = size + 1;
1009
1010 hi2c->error_code = I2C_OK;
1011
1012 /* wait for the busy flag to be reset */
1013 if (i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1014 {
1015 return I2C_ERR_STEP_1;
1016 }
1017
1018 /* start transfer */
1019 i2c_start_transfer(hi2c, address, I2C_GEN_START_WRITE);
1020
1021 /* wait for the tdis flag to be set */
1022 if(i2c_wait_flag(hi2c, I2C_TDIS_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1023 {
1024 return I2C_ERR_STEP_2;
1025 }
1026
1027 /* send memory address */
1028 i2c_data_send(hi2c->i2cx, mem_address);
1029
1030 hi2c->psize--;
1031 hi2c->pcount--;
1032
1033 while (hi2c->pcount > 0)
1034 {
1035 /* wait for the tdis flag to be set */
1036 if(i2c_wait_flag(hi2c, I2C_TDIS_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1037 {
1038 return I2C_ERR_STEP_3;
1039 }
1040
1041 /* send data */
1042 i2c_data_send(hi2c->i2cx, *hi2c->pbuff++);
1043 hi2c->psize--;
1044 hi2c->pcount--;
1045
1046 if ((hi2c->psize == 0) && (hi2c->pcount != 0))
1047 {
1048 /* wait for the tcrld flag to be set */
1049 if (i2c_wait_flag(hi2c, I2C_TCRLD_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1050 {
1051 return I2C_ERR_STEP_4;
1052 }
1053
1054 /* continue transfer */
1055 i2c_start_transfer(hi2c, address, I2C_WITHOUT_START);
1056 }
1057 }
1058
1059 /* wait for the stop flag to be set */
1060 if(i2c_wait_flag(hi2c, I2C_STOPF_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1061 {
1062 return I2C_ERR_STEP_5;
1063 }
1064
1065 /* clear stop flag */
1066 i2c_flag_clear(hi2c->i2cx, I2C_STOPF_FLAG);
1067
1068 /* reset ctrl2 register */
1069 i2c_reset_ctrl2_register(hi2c);
1070
1071 return I2C_OK;
1072}
1073
1084 i2c_status_type i2c_memory_read(i2c_handle_type* hi2c, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout)
1085{
1086 /* initialization parameters */
1087 hi2c->pbuff = pdata;
1088 hi2c->pcount = size;
1089
1090 hi2c->error_code = I2C_OK;
1091
1092 /* wait for the busy flag to be reset */
1093 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1094 {
1095 return I2C_ERR_STEP_1;
1096 }
1097
1098 /* start transfer */
1099 i2c_transmit_set(hi2c->i2cx, address, 1, I2C_SOFT_STOP_MODE, I2C_GEN_START_WRITE);
1100
1101 /* wait for the tdis flag to be set */
1102 if(i2c_wait_flag(hi2c, I2C_TDIS_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1103 {
1104 return I2C_ERR_STEP_2;
1105 }
1106
1107 /* send memory address */
1108 i2c_data_send(hi2c->i2cx, mem_address);
1109
1110 /* wait for the tdc flag to be set */
1111 if (i2c_wait_flag(hi2c, I2C_TDC_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1112 {
1113 return I2C_ERR_STEP_3;
1114 }
1115
1116 /* start transfer */
1117 i2c_start_transfer(hi2c, address, I2C_GEN_START_READ);
1118
1119 while (hi2c->pcount > 0)
1120 {
1121 /* wait for the rdbf flag to be set */
1122 if (i2c_wait_flag(hi2c, I2C_RDBF_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1123 {
1124 return I2C_ERR_STEP_4;
1125 }
1126
1127 /* read data */
1128 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
1129 hi2c->pcount--;
1130 hi2c->psize--;
1131
1132 if ((hi2c->psize == 0) && (hi2c->pcount != 0))
1133 {
1134 /* wait for the tcrld flag to be set */
1135 if (i2c_wait_flag(hi2c, I2C_TCRLD_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1136 {
1137 return I2C_ERR_STEP_5;
1138 }
1139
1140 /* continue transfer */
1141 i2c_start_transfer(hi2c, address, I2C_WITHOUT_START);
1142 }
1143 }
1144
1145 /* wait for the stop flag to be set */
1146 if (i2c_wait_flag(hi2c, I2C_STOPF_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1147 {
1148 return I2C_ERR_STEP_6;
1149 }
1150
1151 /* clear stop flag */
1152 i2c_flag_clear(hi2c->i2cx, I2C_STOPF_FLAG);
1153
1154 /* reset ctrl2 register */
1155 i2c_reset_ctrl2_register(hi2c);
1156
1157 return I2C_OK;
1158}
1159
1170 i2c_status_type i2c_memory_write_int(i2c_handle_type* hi2c, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout)
1171{
1172 /* initialization parameters */
1173 hi2c->mode = I2C_INT_MA_TX;
1174 hi2c->status = I2C_START;
1175
1176 hi2c->pbuff = pdata;
1177 hi2c->pcount = size + 1;
1178
1179 hi2c->error_code = I2C_OK;
1180
1181 /* wait for the busy flag to be reset */
1182 if (i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1183 {
1184 return I2C_ERR_STEP_1;
1185 }
1186
1187 /* start transfer */
1188 i2c_start_transfer(hi2c, address, I2C_GEN_START_WRITE);
1189
1190 /* wait for the tdis flag to be set */
1191 if(i2c_wait_flag(hi2c, I2C_TDIS_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1192 {
1193 return I2C_ERR_STEP_2;
1194 }
1195
1196 /* send memory address */
1197 i2c_data_send(hi2c->i2cx, mem_address);
1198 hi2c->psize--;
1199 hi2c->pcount--;
1200
1201 /* enable interrupt */
1202 i2c_interrupt_enable(hi2c->i2cx, I2C_ERR_INT | I2C_TDC_INT | I2C_STOP_INT | I2C_ACKFIAL_INT | I2C_TD_INT, TRUE);
1203
1204 return I2C_OK;
1205}
1206
1217 i2c_status_type i2c_memory_read_int(i2c_handle_type* hi2c, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout)
1218{
1219 /* initialization parameters */
1220 hi2c->mode = I2C_INT_MA_RX;
1221 hi2c->status = I2C_START;
1222
1223 hi2c->pbuff = pdata;
1224 hi2c->pcount = size;
1225
1226 hi2c->error_code = I2C_OK;
1227
1228 /* wait for the busy flag to be reset */
1229 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1230 {
1231 return I2C_ERR_STEP_1;
1232 }
1233
1234 /* start transfer */
1235 i2c_transmit_set(hi2c->i2cx, address, 1, I2C_SOFT_STOP_MODE, I2C_GEN_START_WRITE);
1236
1237 /* wait for the tdis flag to be set */
1238 if(i2c_wait_flag(hi2c, I2C_TDIS_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1239 {
1240 return I2C_ERR_STEP_2;
1241 }
1242
1243 /* send memory address */
1244 i2c_data_send(hi2c->i2cx, mem_address);
1245
1246 /* wait for the tdc flag to be set */
1247 if (i2c_wait_flag(hi2c, I2C_TDC_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1248 {
1249 return I2C_ERR_STEP_3;
1250 }
1251
1252 /* start transfer */
1253 i2c_start_transfer(hi2c, address, I2C_GEN_START_READ);
1254
1255 /* enable i2c interrupt */
1256 i2c_interrupt_enable(hi2c->i2cx, I2C_ERR_INT | I2C_TDC_INT | I2C_STOP_INT | I2C_ACKFIAL_INT | I2C_RD_INT, TRUE);
1257
1258 return I2C_OK;
1259}
1260
1271 i2c_status_type i2c_memory_write_dma(i2c_handle_type* hi2c, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout)
1272{
1273 /* initialization parameters */
1274 hi2c->mode = I2C_DMA_MA_TX;
1275 hi2c->status = I2C_START;
1276
1277 hi2c->pbuff = pdata;
1278 hi2c->pcount = size;
1279
1280 hi2c->error_code = I2C_OK;
1281
1282 /* disable dma request */
1283 i2c_dma_enable(hi2c->i2cx, I2C_DMA_REQUEST_TX, FALSE);
1284
1285 /* wait for the busy flag to be reset */
1286 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1287 {
1288 return I2C_ERR_STEP_1;
1289 }
1290
1291 /* transfer config */
1292 i2c_transmit_set(hi2c->i2cx, address, 1, I2C_RELOAD_MODE, I2C_GEN_START_WRITE);
1293
1294 /* wait for the tdis flag to be set */
1295 if(i2c_wait_flag(hi2c, I2C_TDIS_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1296 {
1297 return I2C_ERR_STEP_2;
1298 }
1299
1300 /* send memory address */
1301 i2c_data_send(hi2c->i2cx, mem_address);
1302
1303 /* wait for the tcrld flag to be set */
1304 if (i2c_wait_flag(hi2c, I2C_TCRLD_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1305 {
1306 return I2C_ERR_STEP_3;
1307 }
1308
1309 /* start transfer */
1310 i2c_start_transfer_dma(hi2c, hi2c->dma_tx_channel, address, I2C_WITHOUT_START);
1311
1312 /* enable i2c interrupt */
1313 i2c_interrupt_enable(hi2c->i2cx, I2C_ERR_INT | I2C_ACKFIAL_INT, TRUE);
1314
1315 /* enable dma request */
1316 i2c_dma_enable(hi2c->i2cx, I2C_DMA_REQUEST_TX, TRUE);
1317
1318 return I2C_OK;
1319}
1320
1331 i2c_status_type i2c_memory_read_dma(i2c_handle_type* hi2c, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout)
1332{
1333 /* initialization parameters */
1334 hi2c->mode = I2C_DMA_MA_RX;
1335 hi2c->status = I2C_START;
1336
1337 hi2c->pbuff = pdata;
1338 hi2c->pcount = size;
1339
1340 hi2c->error_code = I2C_OK;
1341
1342 /* wait for the busy flag to be reset */
1343 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1344 {
1345 return I2C_ERR_STEP_1;
1346 }
1347
1348 /* start transfer */
1349 i2c_transmit_set(hi2c->i2cx, address, 1, I2C_SOFT_STOP_MODE, I2C_GEN_START_WRITE);
1350
1351 /* wait for the tdis flag to be set */
1352 if(i2c_wait_flag(hi2c, I2C_TDIS_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1353 {
1354 return I2C_ERR_STEP_2;
1355 }
1356
1357 /* send memory address */
1358 i2c_data_send(hi2c->i2cx, mem_address);
1359
1360 /* wait for the tdc flag to be set */
1361 if (i2c_wait_flag(hi2c, I2C_TDC_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1362 {
1363 return I2C_ERR_STEP_3;
1364 }
1365
1366 /* disable dma request */
1367 i2c_dma_enable(hi2c->i2cx, I2C_DMA_REQUEST_RX, FALSE);
1368
1369 /* start transfer */
1370 i2c_start_transfer_dma(hi2c, hi2c->dma_rx_channel, address, I2C_GEN_START_READ);
1371
1372 /* enable i2c interrupt */
1373 i2c_interrupt_enable(hi2c->i2cx, I2C_ERR_INT | I2C_ACKFIAL_INT, TRUE);
1374
1375 /* enable dma request */
1376 i2c_dma_enable(hi2c->i2cx, I2C_DMA_REQUEST_RX, TRUE);
1377
1378 return I2C_OK;
1379}
1380
1390 i2c_status_type i2c_smbus_master_transmit(i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout)
1391{
1392 /* initialization parameters */
1393 hi2c->pbuff = pdata;
1394 hi2c->pcount = size;
1395
1396 hi2c->error_code = I2C_OK;
1397
1398 /* wait for the busy flag to be reset */
1399 if (i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1400 {
1401 return I2C_ERR_STEP_1;
1402 }
1403
1404 /* enable pec calculation */
1405 i2c_pec_calculate_enable(hi2c->i2cx, TRUE);
1406
1407 /* enable pec transmit request */
1408 i2c_pec_transmit_enable(hi2c->i2cx, TRUE);
1409
1410 /* start transfer */
1411 i2c_start_transfer(hi2c, address, I2C_GEN_START_WRITE);
1412
1413 hi2c->pcount--;
1414
1415 while (hi2c->pcount > 0)
1416 {
1417 /* wait for the tdis flag to be set */
1418 if(i2c_wait_flag(hi2c, I2C_TDIS_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1419 {
1420 return I2C_ERR_STEP_2;
1421 }
1422
1423 /* send data */
1424 i2c_data_send(hi2c->i2cx, *hi2c->pbuff++);
1425 hi2c->psize--;
1426 hi2c->pcount--;
1427
1428 if ((hi2c->psize == 0) && (hi2c->pcount != 0))
1429 {
1430 /* wait for the tcrld flag to be set */
1431 if (i2c_wait_flag(hi2c, I2C_TCRLD_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1432 {
1433 return I2C_ERR_STEP_3;
1434 }
1435
1436 /* continue transfer */
1437 i2c_start_transfer(hi2c, address, I2C_WITHOUT_START);
1438 }
1439 }
1440
1441 /* wait for the stop flag to be set */
1442 if(i2c_wait_flag(hi2c, I2C_STOPF_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1443 {
1444 return I2C_ERR_STEP_4;
1445 }
1446
1447 /* clear stop flag */
1448 i2c_flag_clear(hi2c->i2cx, I2C_STOPF_FLAG);
1449
1450 /* reset ctrl2 register */
1451 i2c_reset_ctrl2_register(hi2c);
1452
1453 return I2C_OK;
1454}
1455
1464 i2c_status_type i2c_smbus_slave_receive(i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout)
1465{
1466 /* initialization parameters */
1467 hi2c->pbuff = pdata;
1468 hi2c->pcount = size;
1469
1470 hi2c->error_code = I2C_OK;
1471
1472 /* enable pec calculation */
1473 i2c_pec_calculate_enable(hi2c->i2cx, TRUE);
1474
1475 /* enable slave data control mode */
1476 i2c_slave_data_ctrl_enable(hi2c->i2cx, TRUE);
1477
1478 /* enable acknowledge */
1479 i2c_ack_enable(hi2c->i2cx, TRUE);
1480
1481 /* wait for the addr flag to be set */
1482 if (i2c_wait_flag(hi2c, I2C_ADDRF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1483 {
1484 return I2C_ERR_STEP_1;
1485 }
1486
1487 /* enable pec transmit request */
1488 i2c_pec_transmit_enable(hi2c->i2cx, TRUE);
1489
1490 /* configure the number of bytes to be transmitted */
1491 i2c_cnt_set(hi2c->i2cx, hi2c->pcount);
1492
1493 /* clear addr flag */
1494 i2c_flag_clear(hi2c->i2cx, I2C_ADDRF_FLAG);
1495
1496 while (hi2c->pcount > 0)
1497 {
1498 /* wait for the rdbf flag to be set */
1499 if(i2c_wait_flag(hi2c, I2C_RDBF_FLAG, I2C_EVENT_CHECK_STOP, timeout) != I2C_OK)
1500 {
1501 /* disable acknowledge */
1502 i2c_ack_enable(hi2c->i2cx, FALSE);
1503
1504 /* if data is received, read data */
1505 if (i2c_flag_get(hi2c->i2cx, I2C_RDBF_FLAG) == SET)
1506 {
1507 /* read data */
1508 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
1509 hi2c->pcount--;
1510 }
1511
1512 return I2C_ERR_STEP_3;
1513 }
1514
1515 /* read data */
1516 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
1517 hi2c->pcount--;
1518 }
1519
1520 /* wait for the stop flag to be set */
1521 if(i2c_wait_flag(hi2c, I2C_STOPF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1522 {
1523 /* disable acknowledge */
1524 i2c_ack_enable(hi2c->i2cx, FALSE);
1525
1526 return I2C_ERR_STEP_4;
1527 }
1528
1529 /* clear stop flag */
1530 i2c_flag_clear(hi2c->i2cx, I2C_STOPF_FLAG);
1531
1532 /* wait for the busy flag to be reset */
1533 if (i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1534 {
1535 /* disable acknowledge */
1536 i2c_ack_enable(hi2c->i2cx, FALSE);
1537
1538 return I2C_ERR_STEP_5;
1539 }
1540
1541 /* disable slave data control mode */
1542 i2c_slave_data_ctrl_enable(hi2c->i2cx, FALSE);
1543
1544 return I2C_OK;
1545}
1546
1556 i2c_status_type i2c_smbus_master_receive(i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout)
1557{
1558 /* initialization parameters */
1559 hi2c->pbuff = pdata;
1560 hi2c->pcount = size;
1561
1562 hi2c->error_code = I2C_OK;
1563
1564 /* wait for the busy flag to be reset */
1565 if (i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1566 {
1567 return I2C_ERR_STEP_1;
1568 }
1569
1570 /* enable pec calculation */
1571 i2c_pec_calculate_enable(hi2c->i2cx, TRUE);
1572
1573 /* enable pec transmit request */
1574 i2c_pec_transmit_enable(hi2c->i2cx, TRUE);
1575
1576 /* start transfer */
1577 i2c_start_transfer(hi2c, address, I2C_GEN_START_READ);
1578
1579 while (hi2c->pcount > 0)
1580 {
1581 /* wait for the rdbf flag to be set */
1582 if(i2c_wait_flag(hi2c, I2C_RDBF_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1583 {
1584 return I2C_ERR_STEP_2;
1585 }
1586
1587 /* read data */
1588 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
1589 hi2c->pcount--;
1590 hi2c->psize--;
1591
1592 if ((hi2c->psize == 0) && (hi2c->pcount != 0))
1593 {
1594 /* wait for the tcrld flag to be set */
1595 if (i2c_wait_flag(hi2c, I2C_TCRLD_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1596 {
1597 return I2C_ERR_STEP_3;
1598 }
1599
1600 /* continue transfer */
1601 i2c_start_transfer(hi2c, address, I2C_WITHOUT_START);
1602 }
1603 }
1604
1605 /* wait for the stop flag to be set */
1606 if(i2c_wait_flag(hi2c, I2C_STOPF_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1607 {
1608 return I2C_ERR_STEP_4;
1609 }
1610
1611 /* clear stop flag */
1612 i2c_flag_clear(hi2c->i2cx, I2C_STOPF_FLAG);
1613
1614 /* reset ctrl2 register */
1615 i2c_reset_ctrl2_register(hi2c);
1616
1617 return I2C_OK;
1618}
1619
1628 i2c_status_type i2c_smbus_slave_transmit(i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout)
1629{
1630 /* initialization parameters */
1631 hi2c->pbuff = pdata;
1632 hi2c->pcount = size;
1633
1634 hi2c->error_code = I2C_OK;
1635
1636 /* enable pec calculation */
1637 i2c_pec_calculate_enable(hi2c->i2cx, TRUE);
1638
1639 /* enable slave data control mode */
1640 i2c_slave_data_ctrl_enable(hi2c->i2cx, TRUE);
1641
1642 /* enable acknowledge */
1643 i2c_ack_enable(hi2c->i2cx, TRUE);
1644
1645 /* wait for the addr flag to be set */
1646 if (i2c_wait_flag(hi2c, I2C_ADDRF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1647 {
1648 /* disable acknowledge */
1649 i2c_ack_enable(hi2c->i2cx, FALSE);
1650 return I2C_ERR_STEP_1;
1651 }
1652
1653 /* if 7-bit address mode is selected */
1654 if (hi2c->i2cx->ctrl2_bit.addr10 == 0)
1655 {
1656 /* enable pec transmit request */
1657 i2c_pec_transmit_enable(hi2c->i2cx, TRUE);
1658
1659 /* configure the number of bytes to be transmitted */
1660 i2c_cnt_set(hi2c->i2cx, hi2c->pcount);
1661 }
1662
1663 /* clear addr flag */
1664 i2c_flag_clear(hi2c->i2cx, I2C_ADDRF_FLAG);
1665
1666 /* if 10-bit address mode is used */
1667 if (hi2c->i2cx->ctrl2_bit.addr10 != RESET)
1668 {
1669 /* wait for the addr flag to be set */
1670 if (i2c_wait_flag(hi2c, I2C_ADDRF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1671 {
1672 /* disable acknowledge */
1673 i2c_ack_enable(hi2c->i2cx, FALSE);
1674
1675 return I2C_ERR_STEP_2;
1676 }
1677
1678 /* enable pec transmit request */
1679 i2c_pec_transmit_enable(hi2c->i2cx, TRUE);
1680
1681 /* configure the number of bytes to be transmitted */
1682 i2c_cnt_set(hi2c->i2cx, hi2c->pcount);
1683
1684 /* clear addr flag */
1685 i2c_flag_clear(hi2c->i2cx, I2C_ADDRF_FLAG);
1686 }
1687
1688 hi2c->pcount--;
1689
1690 while (hi2c->pcount > 0)
1691 {
1692 /* wait for the tdis flag to be set */
1693 if(i2c_wait_flag(hi2c, I2C_TDIS_FLAG, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1694 {
1695 /* disable acknowledge */
1696 i2c_ack_enable(hi2c->i2cx, FALSE);
1697
1698 return I2C_ERR_STEP_4;
1699 }
1700
1701 /* send data */
1702 i2c_data_send(hi2c->i2cx, *hi2c->pbuff++);
1703 hi2c->pcount--;
1704 }
1705
1706 /* wait for the ackfail flag to be set */
1707 if(i2c_wait_flag(hi2c, I2C_ACKFAIL_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1708 {
1709 return I2C_ERR_STEP_5;
1710 }
1711
1712 /* clear ack fail flag */
1713 i2c_flag_clear(hi2c->i2cx, I2C_ACKFAIL_FLAG);
1714
1715 /* wait for the stop flag to be set */
1716 if(i2c_wait_flag(hi2c, I2C_STOPF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1717 {
1718 /* disable acknowledge */
1719 i2c_ack_enable(hi2c->i2cx, FALSE);
1720
1721 return I2C_ERR_STEP_6;
1722 }
1723
1724 /* clear stop flag */
1725 i2c_flag_clear(hi2c->i2cx, I2C_STOPF_FLAG);
1726
1727 /* wait for the busy flag to be reset */
1728 if (i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1729 {
1730 /* disable acknowledge */
1731 i2c_ack_enable(hi2c->i2cx, FALSE);
1732
1733 return I2C_ERR_STEP_7;
1734 }
1735
1736 /* reset ctrl2 register */
1737 i2c_reset_ctrl2_register(hi2c);
1738
1739 /* refresh tx dt register */
1740 i2c_refresh_txdt_register(hi2c);
1741
1742 /* disable slave data control mode */
1743 i2c_slave_data_ctrl_enable(hi2c->i2cx, FALSE);
1744
1745 return I2C_OK;
1746}
1747
1753 i2c_status_type i2c_master_irq_handler_int(i2c_handle_type* hi2c)
1754{
1755 if (i2c_flag_get(hi2c->i2cx, I2C_ACKFAIL_FLAG) != RESET)
1756 {
1757 /* clear ackfail flag */
1758 i2c_flag_clear(hi2c->i2cx, I2C_ACKFAIL_FLAG);
1759
1760 /* refresh tx register */
1761 i2c_refresh_txdt_register(hi2c);
1762
1763 if(hi2c->pcount != 0)
1764 {
1765 hi2c->error_code = I2C_ERR_ACKFAIL;
1766 }
1767 }
1768 else if (i2c_flag_get(hi2c->i2cx, I2C_TDIS_FLAG) != RESET)
1769 {
1770 /* send data */
1771 i2c_data_send(hi2c->i2cx, *hi2c->pbuff++);
1772 hi2c->pcount--;
1773 hi2c->psize--;
1774 }
1775 else if (i2c_flag_get(hi2c->i2cx, I2C_TCRLD_FLAG) != RESET)
1776 {
1777 if ((hi2c->psize == 0) && (hi2c->pcount != 0))
1778 {
1779 /* continue transfer */
1780 i2c_start_transfer(hi2c, i2c_transfer_addr_get(hi2c->i2cx), I2C_WITHOUT_START);
1781 }
1782 else
1783 {
1784 return I2C_ERR_TCRLD;
1785 }
1786 }
1787 else if (i2c_flag_get(hi2c->i2cx, I2C_RDBF_FLAG) != RESET)
1788 {
1789 /* read data */
1790 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
1791 hi2c->pcount--;
1792 hi2c->psize--;
1793 }
1794 else if (i2c_flag_get(hi2c->i2cx, I2C_TDC_FLAG) != RESET)
1795 {
1796 if (hi2c->pcount == 0)
1797 {
1798 if (hi2c->i2cx->ctrl2_bit.astopen == 0)
1799 {
1800 /* generate stop condtion */
1801 i2c_stop_generate(hi2c->i2cx);
1802 }
1803 }
1804 else
1805 {
1806 return I2C_ERR_TDC;
1807 }
1808 }
1809 else if (i2c_flag_get(hi2c->i2cx, I2C_STOPF_FLAG) != RESET)
1810 {
1811 /* clear stop flag */
1812 i2c_flag_clear(hi2c->i2cx, I2C_STOPF_FLAG);
1813
1814 /* reset ctrl2 register */
1815 i2c_reset_ctrl2_register(hi2c);
1816
1817 if (i2c_flag_get(hi2c->i2cx, I2C_ACKFAIL_FLAG) != RESET)
1818 {
1819 /* clear ackfail flag */
1820 i2c_flag_clear(hi2c->i2cx, I2C_ACKFAIL_FLAG);
1821 }
1822
1823 /* refresh tx dt register */
1824 i2c_refresh_txdt_register(hi2c);
1825
1826 /* disable interrupts */
1827 i2c_interrupt_enable(hi2c->i2cx, I2C_ERR_INT | I2C_TDC_INT | I2C_STOP_INT | I2C_ACKFIAL_INT | I2C_TD_INT | I2C_RD_INT, FALSE);
1828
1829 /* transfer complete */
1830 hi2c->status = I2C_END;
1831 }
1832
1833 return I2C_OK;
1834}
1835
1841 i2c_status_type i2c_slave_irq_handler_int(i2c_handle_type* hi2c)
1842{
1843 if (i2c_flag_get(hi2c->i2cx, I2C_ACKFAIL_FLAG) != RESET)
1844 {
1845 /* transfer complete */
1846 if (hi2c->pcount == 0)
1847 {
1848 i2c_refresh_txdt_register(hi2c);
1849
1850 /* clear ackfail flag */
1851 i2c_flag_clear(hi2c->i2cx, I2C_ACKFAIL_FLAG);
1852 }
1853 /* the transfer has not been completed */
1854 else
1855 {
1856 /* clear ackfail flag */
1857 i2c_flag_clear(hi2c->i2cx, I2C_ACKFAIL_FLAG);
1858 }
1859 }
1860 else if (i2c_flag_get(hi2c->i2cx, I2C_ADDRF_FLAG) != RESET)
1861 {
1862 /* clear addr flag */
1863 i2c_flag_clear(hi2c->i2cx, I2C_ADDRF_FLAG);
1864 }
1865 else if (i2c_flag_get(hi2c->i2cx, I2C_TDIS_FLAG) != RESET)
1866 {
1867 if (hi2c->pcount > 0)
1868 {
1869 /* send data */
1870 hi2c->i2cx->txdt = (*(hi2c->pbuff++));
1871 hi2c->psize--;
1872 hi2c->pcount--;
1873 }
1874 }
1875 else if (i2c_flag_get(hi2c->i2cx, I2C_RDBF_FLAG) != RESET)
1876 {
1877 if (hi2c->pcount > 0)
1878 {
1879 /* read data */
1880 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
1881 hi2c->pcount--;
1882 hi2c->psize--;
1883 }
1884 }
1885 else if (i2c_flag_get(hi2c->i2cx, I2C_STOPF_FLAG) != RESET)
1886 {
1887 /* clear stop flag */
1888 i2c_flag_clear(hi2c->i2cx, I2C_STOPF_FLAG);
1889
1890 /* disable interrupts */
1891 i2c_interrupt_enable(hi2c->i2cx, I2C_ADDR_INT | I2C_STOP_INT | I2C_ACKFIAL_INT | I2C_ERR_INT | I2C_TDC_INT | I2C_TD_INT | I2C_RD_INT, FALSE);
1892
1893 /* reset ctrl2 register */
1894 i2c_reset_ctrl2_register(hi2c);
1895
1896 /* refresh tx dt register */
1897 i2c_refresh_txdt_register(hi2c);
1898
1899 /* if data is received, read data */
1900 if (i2c_flag_get(hi2c->i2cx, I2C_RDBF_FLAG) != RESET)
1901 {
1902 /* read data */
1903 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
1904
1905 if ((hi2c->psize > 0))
1906 {
1907 hi2c->pcount--;
1908 hi2c->psize--;
1909 }
1910 }
1911
1912 /* transfer complete */
1913 hi2c->status = I2C_END;
1914 }
1915
1916 return I2C_OK;
1917}
1918
1924 i2c_status_type i2c_master_irq_handler_dma(i2c_handle_type* hi2c)
1925{
1926 if (i2c_flag_get(hi2c->i2cx, I2C_ACKFAIL_FLAG) != RESET)
1927 {
1928 /* clear ackfail flag */
1929 i2c_flag_clear(hi2c->i2cx, I2C_ACKFAIL_FLAG);
1930
1931 /* enable stop interrupt to wait for stop generate stop */
1932 i2c_interrupt_enable(hi2c->i2cx, I2C_STOP_INT, TRUE);
1933
1934 /* refresh tx dt register */
1935 i2c_refresh_txdt_register(hi2c);
1936
1937 if(hi2c->pcount != 0)
1938 {
1939 hi2c->error_code = I2C_ERR_ACKFAIL;
1940 }
1941 }
1942 else if (i2c_flag_get(hi2c->i2cx, I2C_TCRLD_FLAG) != RESET)
1943 {
1944 /* disable tdc interrupt */
1945 i2c_interrupt_enable(hi2c->i2cx, I2C_TDC_INT, FALSE);
1946
1947 if (hi2c->pcount != 0)
1948 {
1949 /* continue transfer */
1950 i2c_start_transfer(hi2c, i2c_transfer_addr_get(hi2c->i2cx), I2C_WITHOUT_START);
1951
1952 /* enable dma request */
1953 if (hi2c->dma_init_struct.direction == DMA_DIR_MEMORY_TO_PERIPHERAL)
1954 {
1955 i2c_dma_enable(hi2c->i2cx, I2C_DMA_REQUEST_TX, TRUE);
1956 }
1957 else
1958 {
1959 i2c_dma_enable(hi2c->i2cx, I2C_DMA_REQUEST_RX, TRUE);
1960 }
1961 }
1962 else
1963 {
1964 return I2C_ERR_TCRLD;
1965 }
1966 }
1967 else if (i2c_flag_get(hi2c->i2cx, I2C_STOPF_FLAG) != RESET)
1968 {
1969 /* clear stop flag */
1970 i2c_flag_clear(hi2c->i2cx, I2C_STOPF_FLAG);
1971
1972 /* reset ctrl2 register */
1973 i2c_reset_ctrl2_register(hi2c);
1974
1975 if (i2c_flag_get(hi2c->i2cx, I2C_ACKFAIL_FLAG) != RESET)
1976 {
1977 /* clear ackfail flag */
1978 i2c_flag_clear(hi2c->i2cx, I2C_ACKFAIL_FLAG);
1979 }
1980
1981 /* refresh tx dt register */
1982 i2c_refresh_txdt_register(hi2c);
1983
1984 /* disable interrupts */
1985 i2c_interrupt_enable(hi2c->i2cx, I2C_ERR_INT | I2C_TDC_INT | I2C_STOP_INT | I2C_ACKFIAL_INT | I2C_TD_INT | I2C_RD_INT, FALSE);
1986
1987 /* transfer complete */
1988 hi2c->status = I2C_END;
1989 }
1990
1991 return I2C_OK;
1992}
1993
1999 i2c_status_type i2c_slave_irq_handler_dma(i2c_handle_type* hi2c)
2000{
2001 if (i2c_flag_get(hi2c->i2cx, I2C_ACKFAIL_FLAG) != RESET)
2002 {
2003 /* clear ackfail flag */
2004 i2c_flag_clear(hi2c->i2cx, I2C_ACKFAIL_FLAG);
2005 }
2006 else if (i2c_flag_get(hi2c->i2cx, I2C_ADDRF_FLAG) != RESET)
2007 {
2008 /* clear addr flag */
2009 i2c_flag_clear(hi2c->i2cx, I2C_ADDRF_FLAG);
2010 }
2011 else if (i2c_flag_get(hi2c->i2cx, I2C_STOPF_FLAG) != RESET)
2012 {
2013 /* clear stop flag */
2014 i2c_flag_clear(hi2c->i2cx, I2C_STOPF_FLAG);
2015
2016 /* disable interrupts */
2017 i2c_interrupt_enable(hi2c->i2cx, I2C_ADDR_INT | I2C_STOP_INT | I2C_ACKFIAL_INT | I2C_ERR_INT | I2C_TDC_INT | I2C_TD_INT | I2C_RD_INT, FALSE);
2018
2019 /* reset ctrl2 register */
2020 i2c_reset_ctrl2_register(hi2c);
2021
2022 /* refresh tx dt register */
2023 i2c_refresh_txdt_register(hi2c);
2024
2025 /* if data is received, read data */
2026 if (i2c_flag_get(hi2c->i2cx, I2C_RDBF_FLAG) != RESET)
2027 {
2028 /* read data */
2029 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
2030
2031 if ((hi2c->psize > 0))
2032 {
2033 hi2c->pcount--;
2034 hi2c->psize--;
2035 }
2036 }
2037
2038 /* transfer complete */
2039 hi2c->status = I2C_END;
2040 }
2041
2042 return I2C_OK;
2043}
2044
2050void i2c_dma_tx_rx_irq_handler(i2c_handle_type* hi2c, dma_channel_type* dma_channel)
2051{
2052 /* transfer complete */
2053 if (dma_flag_get(DMA_GET_TC_FLAG(dma_channel)) != RESET)
2054 {
2055 /* disable the transfer complete interrupt */
2056 dma_interrupt_enable(dma_channel, DMA_FDT_INT, FALSE);
2057
2058 /* clear the transfer complete flag */
2059 dma_flag_clear(DMA_GET_TC_FLAG(dma_channel));
2060
2061 /* disable dma request */
2062 i2c_dma_enable(hi2c->i2cx, DMA_GET_REQUEST(dma_channel), FALSE);
2063
2064 /* disable dma channel */
2065 dma_channel_enable(dma_channel, FALSE);
2066
2067 switch(hi2c->mode)
2068 {
2069 case I2C_DMA_MA_TX:
2070 case I2C_DMA_MA_RX:
2071 {
2072 /* update the number of transfers */
2073 hi2c->pcount -= hi2c->psize;
2074
2075 /* transfer complete */
2076 if (hi2c->pcount == 0)
2077 {
2078 /* enable stop interrupt */
2079 i2c_interrupt_enable(hi2c->i2cx, I2C_STOP_INT, TRUE);
2080 }
2081 /* the transfer has not been completed */
2082 else
2083 {
2084 /* update the buffer pointer of transfers */
2085 hi2c->pbuff += hi2c->psize;
2086
2087 /* set the number to be transferred */
2088 if (hi2c->pcount > MAX_TRANSFER_CNT)
2089 {
2090 hi2c->psize = MAX_TRANSFER_CNT;
2091 }
2092 else
2093 {
2094 hi2c->psize = hi2c->pcount;
2095 }
2096
2097 /* config dma channel, continue to transfer data */
2098 i2c_dma_config(hi2c, dma_channel, hi2c->pbuff, hi2c->psize);
2099
2100 /* enable tdc interrupt */
2101 i2c_interrupt_enable(hi2c->i2cx, I2C_TDC_INT, TRUE);
2102 }
2103 }break;
2104 case I2C_DMA_SLA_TX:
2105 case I2C_DMA_SLA_RX:
2106 {
2107
2108 }break;
2109
2110 default:break;
2111 }
2112 }
2113}
2114
2120void i2c_dma_tx_irq_handler(i2c_handle_type* hi2c)
2121{
2122 i2c_dma_tx_rx_irq_handler(hi2c, hi2c->dma_tx_channel);
2123}
2124
2130void i2c_dma_rx_irq_handler(i2c_handle_type* hi2c)
2131{
2132 i2c_dma_tx_rx_irq_handler(hi2c, hi2c->dma_rx_channel);
2133}
2134
2140void i2c_evt_irq_handler(i2c_handle_type* hi2c)
2141{
2142 switch(hi2c->mode)
2143 {
2144 case I2C_INT_MA_TX:
2145 case I2C_INT_MA_RX:
2146 {
2147 i2c_master_irq_handler_int(hi2c);
2148 }break;
2149 case I2C_INT_SLA_TX:
2150 case I2C_INT_SLA_RX:
2151 {
2152 i2c_slave_irq_handler_int(hi2c);
2153 }break;
2154 case I2C_DMA_MA_TX:
2155 case I2C_DMA_MA_RX:
2156 {
2157 i2c_master_irq_handler_dma(hi2c);
2158 }break;
2159 case I2C_DMA_SLA_TX:
2160 case I2C_DMA_SLA_RX:
2161 {
2162 i2c_slave_irq_handler_dma(hi2c);
2163 }break;
2164
2165 default:break;
2166 }
2167}
2168
2174void i2c_err_irq_handler(i2c_handle_type* hi2c)
2175{
2176 hi2c->error_code = I2C_ERR_INTERRUPT;
2177
2178 /* buserr */
2179 if (i2c_flag_get(hi2c->i2cx, I2C_BUSERR_FLAG) != RESET)
2180 {
2181 i2c_flag_clear(hi2c->i2cx, I2C_BUSERR_FLAG);
2182 }
2183
2184 /* arlost */
2185 if (i2c_flag_get(hi2c->i2cx, I2C_ARLOST_FLAG) != RESET)
2186 {
2187 i2c_flag_clear(hi2c->i2cx, I2C_ARLOST_FLAG);
2188 }
2189
2190 /* ouf */
2191 if (i2c_flag_get(hi2c->i2cx, I2C_OUF_FLAG) != RESET)
2192 {
2193 i2c_flag_clear(hi2c->i2cx, I2C_OUF_FLAG);
2194 }
2195
2196 /* pecerr */
2197 if (i2c_flag_get(hi2c->i2cx, I2C_PECERR_FLAG) != RESET)
2198 {
2199 i2c_flag_clear(hi2c->i2cx, I2C_PECERR_FLAG);
2200 }
2201
2202 /* timeout */
2203 if (i2c_flag_get(hi2c->i2cx, I2C_TMOUT_FLAG) != RESET)
2204 {
2205 i2c_flag_clear(hi2c->i2cx, I2C_TMOUT_FLAG);
2206 }
2207
2208 /* alertf */
2209 if (i2c_flag_get(hi2c->i2cx, I2C_ALERTF_FLAG) != RESET)
2210 {
2211 i2c_flag_clear(hi2c->i2cx, I2C_ALERTF_FLAG);
2212 }
2213
2214 /* disable interrupts */
2215 i2c_interrupt_enable(hi2c->i2cx, I2C_ERR_INT, FALSE);
2216}
2217
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
i2c_pec_transmit_enable
void i2c_pec_transmit_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable pec transfer.
Definition: at32f435_437_i2c.c:422
i2c_slave_data_ctrl_enable
void i2c_slave_data_ctrl_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable slave data control.
Definition: at32f435_437_i2c.c:396
i2c_data_receive
uint8_t i2c_data_receive(i2c_type *i2c_x)
receive a byte through the i2c periph.
Definition: at32f435_437_i2c.c:671
i2c_reset
void i2c_reset(i2c_type *i2c_x)
reset the i2c register
Definition: at32f435_437_i2c.c:51
i2c_ack_enable
void i2c_ack_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable ack.
Definition: at32f435_437_i2c.c:214
i2c_transfer_addr_get
uint16_t i2c_transfer_addr_get(i2c_type *i2c_x)
get the slave address to be transmitted.
Definition: at32f435_437_i2c.c:252
i2c_cnt_set
void i2c_cnt_set(i2c_type *i2c_x, uint8_t cnt)
config the transfer cnt .
Definition: at32f435_437_i2c.c:340
i2c_pec_calculate_enable
void i2c_pec_calculate_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable pec calculate.
Definition: at32f435_437_i2c.c:409
i2c_stop_generate
void i2c_stop_generate(i2c_type *i2c_x)
generate stop condition.
Definition: at32f435_437_i2c.c:646
i2c_enable
void i2c_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable peripheral.
Definition: at32f435_437_i2c.c:188
i2c_flag_get
flag_status i2c_flag_get(i2c_type *i2c_x, uint32_t flag)
get flag status.
Definition: at32f435_437_i2c.c:701
i2c_flag_clear
void i2c_flag_clear(i2c_type *i2c_x, uint32_t flag)
clear flag status
Definition: at32f435_437_i2c.c:731
i2c_data_send
void i2c_data_send(i2c_type *i2c_x, uint8_t data)
send a byte through the i2c periph.
Definition: at32f435_437_i2c.c:659
i2c_dma_enable
void i2c_dma_enable(i2c_type *i2c_x, i2c_dma_request_type dma_req, confirm_state new_state)
enable or disable dma requests.
Definition: at32f435_437_i2c.c:576
i2c_transmit_set
void i2c_transmit_set(i2c_type *i2c_x, uint16_t address, uint8_t cnt, i2c_reload_stop_mode_type rld_stop, i2c_start_mode_type start)
config data transfer.
Definition: at32f435_437_i2c.c:607
i2c_interrupt_enable
void i2c_interrupt_enable(i2c_type *i2c_x, uint32_t source, confirm_state new_state)
enable or disable interrupts.
Definition: at32f435_437_i2c.c:524
i2c_start_mode_type
i2c_start_mode_type
i2c start mode
Definition: at32f435_437_i2c.h:182
I2C_AUTO_STOP_MODE
@ I2C_AUTO_STOP_MODE
Definition: at32f435_437_i2c.h:173
I2C_SOFT_STOP_MODE
@ I2C_SOFT_STOP_MODE
Definition: at32f435_437_i2c.h:174
I2C_RELOAD_MODE
@ I2C_RELOAD_MODE
Definition: at32f435_437_i2c.h:175
I2C_GEN_START_READ
@ I2C_GEN_START_READ
Definition: at32f435_437_i2c.h:184
I2C_WITHOUT_START
@ I2C_WITHOUT_START
Definition: at32f435_437_i2c.h:183
I2C_GEN_START_WRITE
@ I2C_GEN_START_WRITE
Definition: at32f435_437_i2c.h:185
I2C_DMA_REQUEST_TX
@ I2C_DMA_REQUEST_TX
Definition: at32f435_437_i2c.h:131
I2C_DMA_REQUEST_RX
@ I2C_DMA_REQUEST_RX
Definition: at32f435_437_i2c.h:132
I2C_ADDRF_FLAG
#define I2C_ADDRF_FLAG
Definition: at32f435_437_i2c.h:77
I2C_TMOUT_FLAG
#define I2C_TMOUT_FLAG
Definition: at32f435_437_i2c.h:86
I2C_ALERTF_FLAG
#define I2C_ALERTF_FLAG
Definition: at32f435_437_i2c.h:87
I2C_BUSERR_FLAG
#define I2C_BUSERR_FLAG
Definition: at32f435_437_i2c.h:82
I2C_ACKFAIL_FLAG
#define I2C_ACKFAIL_FLAG
Definition: at32f435_437_i2c.h:78
I2C_BUSYF_FLAG
#define I2C_BUSYF_FLAG
Definition: at32f435_437_i2c.h:88
I2C_OUF_FLAG
#define I2C_OUF_FLAG
Definition: at32f435_437_i2c.h:84
I2C_ARLOST_FLAG
#define I2C_ARLOST_FLAG
Definition: at32f435_437_i2c.h:83
I2C_STOPF_FLAG
#define I2C_STOPF_FLAG
Definition: at32f435_437_i2c.h:79
I2C_TDC_FLAG
#define I2C_TDC_FLAG
Definition: at32f435_437_i2c.h:80
I2C_TDBE_FLAG
#define I2C_TDBE_FLAG
Definition: at32f435_437_i2c.h:74
I2C_TCRLD_FLAG
#define I2C_TCRLD_FLAG
Definition: at32f435_437_i2c.h:81
I2C_TDIS_FLAG
#define I2C_TDIS_FLAG
Definition: at32f435_437_i2c.h:75
I2C_RDBF_FLAG
#define I2C_RDBF_FLAG
Definition: at32f435_437_i2c.h:76
I2C_PECERR_FLAG
#define I2C_PECERR_FLAG
Definition: at32f435_437_i2c.h:85
I2C_RD_INT
#define I2C_RD_INT
Definition: at32f435_437_i2c.h:58
I2C_STOP_INT
#define I2C_STOP_INT
Definition: at32f435_437_i2c.h:61
I2C_ERR_INT
#define I2C_ERR_INT
Definition: at32f435_437_i2c.h:63
I2C_ACKFIAL_INT
#define I2C_ACKFIAL_INT
Definition: at32f435_437_i2c.h:60
I2C_TD_INT
#define I2C_TD_INT
Definition: at32f435_437_i2c.h:57
I2C_TDC_INT
#define I2C_TDC_INT
Definition: at32f435_437_i2c.h:62
I2C_ADDR_INT
#define I2C_ADDR_INT
Definition: at32f435_437_i2c.h:59
I2C_EVENT_CHECK_STOP
#define I2C_EVENT_CHECK_STOP
Definition: i2c_application.h:49
I2C_EVENT_CHECK_NONE
#define I2C_EVENT_CHECK_NONE
Definition: i2c_application.h:47
I2C_EVENT_CHECK_ACKFAIL
#define I2C_EVENT_CHECK_ACKFAIL
Definition: i2c_application.h:48
i2c_wait_flag
i2c_status_type i2c_wait_flag(i2c_handle_type *hi2c, uint32_t flag, uint32_t event_check, uint32_t timeout)
wait for the flag to be set or reset, only BUSYF flag is waiting to be reset, and other flags are wai...
Definition: i2c_application.c:214
i2c_wait_end
i2c_status_type i2c_wait_end(i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end.
Definition: i2c_application.c:165
i2c_evt_irq_handler
void i2c_evt_irq_handler(i2c_handle_type *hi2c)
interrupt procession function.
Definition: i2c_application.c:2140
i2c_slave_transmit_int
i2c_status_type i2c_slave_transmit_int(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through interrupt mode.
Definition: i2c_application.c:798
i2c_err_irq_handler
void i2c_err_irq_handler(i2c_handle_type *hi2c)
dma reveive complete interrupt function.
Definition: i2c_application.c:2174
i2c_smbus_slave_receive
i2c_status_type i2c_smbus_slave_receive(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through SMBus mode.
Definition: i2c_application.c:1464
i2c_dma_rx_irq_handler
void i2c_dma_rx_irq_handler(i2c_handle_type *hi2c)
dma reveive complete interrupt function.
Definition: i2c_application.c:2130
i2c_slave_receive
i2c_status_type i2c_slave_receive(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through polling mode.
Definition: i2c_application.c:441
i2c_slave_transmit_dma
i2c_status_type i2c_slave_transmit_dma(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through dma mode.
Definition: i2c_application.c:959
i2c_memory_read
i2c_status_type i2c_memory_read(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode.
Definition: i2c_application.c:1084
i2c_memory_write_int
i2c_status_type i2c_memory_write_int(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through interrupt mode.
Definition: i2c_application.c:1170
i2c_memory_write
i2c_status_type i2c_memory_write(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through polling mode.
Definition: i2c_application.c:1004
i2c_master_receive_int
i2c_status_type i2c_master_receive_int(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through interrupt mode.
Definition: i2c_application.c:764
i2c_smbus_master_transmit
i2c_status_type i2c_smbus_master_transmit(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through SMBus mode.
Definition: i2c_application.c:1390
i2c_smbus_slave_transmit
i2c_status_type i2c_smbus_slave_transmit(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through SMBus mode.
Definition: i2c_application.c:1628
i2c_memory_write_dma
i2c_status_type i2c_memory_write_dma(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through dma mode.
Definition: i2c_application.c:1271
i2c_reset_ctrl2_register
void i2c_reset_ctrl2_register(i2c_handle_type *hi2c)
reset ctrl2 register.
Definition: i2c_application.c:150
i2c_master_transmit_dma
i2c_status_type i2c_master_transmit_dma(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through dma mode.
Definition: i2c_application.c:835
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:113
i2c_dma_tx_irq_handler
void i2c_dma_tx_irq_handler(i2c_handle_type *hi2c)
dma transmission complete interrupt function.
Definition: i2c_application.c:2120
i2c_lowlevel_init
__WEAK void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: i2c_application.c:103
i2c_slave_receive_dma
i2c_status_type i2c_slave_receive_dma(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through dma mode.
Definition: i2c_application.c:875
i2c_master_transmit_int
i2c_status_type i2c_master_transmit_int(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through interrupt mode.
Definition: i2c_application.c:695
i2c_memory_read_int
i2c_status_type i2c_memory_read_int(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through interrupt mode.
Definition: i2c_application.c:1217
i2c_master_receive
i2c_status_type i2c_master_receive(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through polling mode.
Definition: i2c_application.c:524
i2c_smbus_master_receive
i2c_status_type i2c_smbus_master_receive(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through SMBus mode.
Definition: i2c_application.c:1556
i2c_master_receive_dma
i2c_status_type i2c_master_receive_dma(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through dma mode.
Definition: i2c_application.c:919
i2c_slave_receive_int
i2c_status_type i2c_slave_receive_int(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through interrupt mode.
Definition: i2c_application.c:729
i2c_master_transmit
i2c_status_type i2c_master_transmit(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode.
Definition: i2c_application.c:375
i2c_slave_transmit
i2c_status_type i2c_slave_transmit(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through polling mode.
Definition: i2c_application.c:590
i2c_memory_read_dma
i2c_status_type i2c_memory_read_dma(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode.
Definition: i2c_application.c:1331
i2c_status_type
i2c_status_type
Definition: i2c_application.h:80
I2C_ERR_STEP_1
@ I2C_ERR_STEP_1
Definition: i2c_application.h:82
I2C_ERR_TIMEOUT
@ I2C_ERR_TIMEOUT
Definition: i2c_application.h:99
I2C_ERR_TCRLD
@ I2C_ERR_TCRLD
Definition: i2c_application.h:94
I2C_ERR_INTERRUPT
@ I2C_ERR_INTERRUPT
Definition: i2c_application.h:100
I2C_ERR_STEP_3
@ I2C_ERR_STEP_3
Definition: i2c_application.h:84
I2C_ERR_STEP_6
@ I2C_ERR_STEP_6
Definition: i2c_application.h:87
I2C_ERR_STEP_5
@ I2C_ERR_STEP_5
Definition: i2c_application.h:86
I2C_ERR_STEP_7
@ I2C_ERR_STEP_7
Definition: i2c_application.h:88
I2C_ERR_STOP
@ I2C_ERR_STOP
Definition: i2c_application.h:97
I2C_ERR_STEP_8
@ I2C_ERR_STEP_8
Definition: i2c_application.h:89
I2C_ERR_ACKFAIL
@ I2C_ERR_ACKFAIL
Definition: i2c_application.h:98
I2C_ERR_STEP_2
@ I2C_ERR_STEP_2
Definition: i2c_application.h:83
I2C_OK
@ I2C_OK
Definition: i2c_application.h:81
I2C_ERR_STEP_4
@ I2C_ERR_STEP_4
Definition: i2c_application.h:85
I2C_ERR_TDC
@ I2C_ERR_TDC
Definition: i2c_application.h:95
I2C_DMA_MA_RX
@ I2C_DMA_MA_RX
Definition: i2c_application.h:66
I2C_DMA_SLA_RX
@ I2C_DMA_SLA_RX
Definition: i2c_application.h:68
I2C_INT_SLA_RX
@ I2C_INT_SLA_RX
Definition: i2c_application.h:64
I2C_DMA_MA_TX
@ I2C_DMA_MA_TX
Definition: i2c_application.h:65
I2C_INT_MA_RX
@ I2C_INT_MA_RX
Definition: i2c_application.h:62
I2C_INT_SLA_TX
@ I2C_INT_SLA_TX
Definition: i2c_application.h:63
I2C_INT_MA_TX
@ I2C_INT_MA_TX
Definition: i2c_application.h:61
I2C_DMA_SLA_TX
@ I2C_DMA_SLA_TX
Definition: i2c_application.h:67
MAX_TRANSFER_CNT
#define MAX_TRANSFER_CNT
maximum number of single transfers
Definition: at32f435_437_i2c.h:50
DMA_GET_REQUEST
#define DMA_GET_REQUEST(DMA_CHANNEL)
get the dma transfer direction flag through the channel
Definition: i2c_application.c:32
i2c_refresh_txdt_register
void i2c_refresh_txdt_register(i2c_handle_type *hi2c)
refresh i2c register.
Definition: i2c_application.c:130
I2C_START
#define I2C_START
i2c transmission status
Definition: i2c_application.c:95
i2c_start_transfer_dma
void i2c_start_transfer_dma(i2c_handle_type *hi2c, dma_channel_type *dma_channelx, uint16_t address, i2c_start_mode_type start)
start transfer in dma mode.
Definition: i2c_application.c:344
i2c_slave_irq_handler_int
i2c_status_type i2c_slave_irq_handler_int(i2c_handle_type *hi2c)
slave interrupt processing function in interrupt mode.
Definition: i2c_application.c:1841
i2c_start_transfer
void i2c_start_transfer(i2c_handle_type *hi2c, uint16_t address, i2c_start_mode_type start)
start transfer in poll mode or interrupt mode.
Definition: i2c_application.c:317
i2c_dma_config
void i2c_dma_config(i2c_handle_type *hi2c, dma_channel_type *dma_channel, uint8_t *pdata, uint16_t size)
dma transfer cofiguration.
Definition: i2c_application.c:284
I2C_END
#define I2C_END
Definition: i2c_application.c:96
i2c_master_irq_handler_dma
i2c_status_type i2c_master_irq_handler_dma(i2c_handle_type *hi2c)
master interrupt processing function in dma mode.
Definition: i2c_application.c:1924
DMA_GET_TC_FLAG
#define DMA_GET_TC_FLAG(DMA_CHANNEL)
get the dma transfer complete flag through the channel
Definition: i2c_application.c:38
i2c_dma_tx_rx_irq_handler
void i2c_dma_tx_rx_irq_handler(i2c_handle_type *hi2c, dma_channel_type *dma_channel)
dma processing function.
Definition: i2c_application.c:2050
i2c_master_irq_handler_int
i2c_status_type i2c_master_irq_handler_int(i2c_handle_type *hi2c)
master interrupt processing function in interrupt mode.
Definition: i2c_application.c:1753
i2c_slave_irq_handler_dma
i2c_status_type i2c_slave_irq_handler_dma(i2c_handle_type *hi2c)
slave interrupt processing function in dma mode.
Definition: i2c_application.c:1999
i2c_application.h
i2c application libray header file
dma_channel_type
type define dma channel register all
Definition: at32f435_437_dma.h:576
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
i2c_handle_type
Definition: i2c_application.h:112
i2c_handle_type::dma_rx_channel
dma_channel_type * dma_rx_channel
Definition: i2c_application.h:121
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:113
i2c_handle_type::status
__IO uint32_t status
Definition: i2c_application.h:118
i2c_handle_type::psize
__IO uint16_t psize
Definition: i2c_application.h:115
i2c_handle_type::pbuff
uint8_t * pbuff
Definition: i2c_application.h:114
i2c_handle_type::mode
__IO uint32_t mode
Definition: i2c_application.h:117
i2c_handle_type::dma_init_struct
dma_init_type dma_init_struct
Definition: i2c_application.h:122
i2c_handle_type::error_code
__IO i2c_status_type error_code
Definition: i2c_application.h:119
i2c_handle_type::dma_tx_channel
dma_channel_type * dma_tx_channel
Definition: i2c_application.h:120
i2c_handle_type::pcount
__IO uint16_t pcount
Definition: i2c_application.h:116
i2c_type::txdt
__IO uint32_t txdt
Definition: at32f435_437_i2c.h:400
i2c_type::rxdt
__IO uint32_t rxdt
Definition: at32f435_437_i2c.h:387
i2c_type::rlden
__IO uint32_t rlden
Definition: at32f435_437_i2c.h:241
i2c_type::saddr
__IO uint32_t saddr
Definition: at32f435_437_i2c.h:233
i2c_type::dir
__IO uint32_t dir
Definition: at32f435_437_i2c.h:234
i2c_type::tdbe
__IO uint32_t tdbe
Definition: at32f435_437_i2c.h:324
i2c_type::sts_bit
struct i2c_type::@874::@890 sts_bit
i2c_type::cnt
__IO uint32_t cnt
Definition: at32f435_437_i2c.h:240
i2c_type::astopen
__IO uint32_t astopen
Definition: at32f435_437_i2c.h:242
i2c_type::ctrl2_bit
struct i2c_type::@864::@885 ctrl2_bit
i2c_type::addr10
__IO uint32_t addr10
Definition: at32f435_437_i2c.h:235
i2c_type::readh10
__IO uint32_t readh10
Definition: at32f435_437_i2c.h:236


AT32F435/437 Firmwary Library: i2c_application.h Source File

  • middlewares
  • i2c_application_library
i2c_application.h
Go to the documentation of this file.
1
28#ifndef __I2C_APPLICATION_H
29#define __I2C_APPLICATION_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
47#define I2C_EVENT_CHECK_NONE ((uint32_t)0x00000000)
48#define I2C_EVENT_CHECK_ACKFAIL ((uint32_t)0x00000001)
49#define I2C_EVENT_CHECK_STOP ((uint32_t)0x00000002)
59typedef enum
60{
61 I2C_INT_MA_TX = 0,
62 I2C_INT_MA_RX,
63 I2C_INT_SLA_TX,
64 I2C_INT_SLA_RX,
65 I2C_DMA_MA_TX,
66 I2C_DMA_MA_RX,
67 I2C_DMA_SLA_TX,
68 I2C_DMA_SLA_RX,
69} i2c_mode_type;
70
79typedef enum
80{
81 I2C_OK = 0,
82 I2C_ERR_STEP_1,
83 I2C_ERR_STEP_2,
84 I2C_ERR_STEP_3,
85 I2C_ERR_STEP_4,
86 I2C_ERR_STEP_5,
87 I2C_ERR_STEP_6,
88 I2C_ERR_STEP_7,
89 I2C_ERR_STEP_8,
90 I2C_ERR_STEP_9,
91 I2C_ERR_STEP_10,
92 I2C_ERR_STEP_11,
93 I2C_ERR_STEP_12,
94 I2C_ERR_TCRLD,
95 I2C_ERR_TDC,
96 I2C_ERR_ADDR,
97 I2C_ERR_STOP,
98 I2C_ERR_ACKFAIL,
99 I2C_ERR_TIMEOUT,
100 I2C_ERR_INTERRUPT,
101} i2c_status_type;
102
111typedef struct
112{
113 i2c_type *i2cx;
114 uint8_t *pbuff;
115 __IO uint16_t psize;
116 __IO uint16_t pcount;
117 __IO uint32_t mode;
118 __IO uint32_t status;
119 __IO i2c_status_type error_code;
120 dma_channel_type *dma_tx_channel;
121 dma_channel_type *dma_rx_channel;
122 dma_init_type dma_init_struct;
123} i2c_handle_type;
124
133void i2c_config (i2c_handle_type* hi2c);
134void i2c_lowlevel_init (i2c_handle_type* hi2c);
135void i2c_reset_ctrl2_register (i2c_handle_type* hi2c);
136 i2c_status_type i2c_wait_end (i2c_handle_type* hi2c, uint32_t timeout);
137 i2c_status_type i2c_wait_flag (i2c_handle_type* hi2c, uint32_t flag, uint32_t event_check, uint32_t timeout);
138
139 i2c_status_type i2c_master_transmit (i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout);
140 i2c_status_type i2c_master_receive (i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout);
141 i2c_status_type i2c_slave_transmit (i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout);
142 i2c_status_type i2c_slave_receive (i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout);
143
144 i2c_status_type i2c_master_transmit_int (i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout);
145 i2c_status_type i2c_master_receive_int (i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout);
146 i2c_status_type i2c_slave_transmit_int (i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout);
147 i2c_status_type i2c_slave_receive_int (i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout);
148
149 i2c_status_type i2c_master_transmit_dma (i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout);
150 i2c_status_type i2c_master_receive_dma (i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout);
151 i2c_status_type i2c_slave_transmit_dma (i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout);
152 i2c_status_type i2c_slave_receive_dma (i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout);
153
154 i2c_status_type i2c_smbus_master_transmit (i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout);
155 i2c_status_type i2c_smbus_master_receive (i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout);
156 i2c_status_type i2c_smbus_slave_transmit (i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout);
157 i2c_status_type i2c_smbus_slave_receive (i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout);
158
159 i2c_status_type i2c_memory_write (i2c_handle_type* hi2c, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout);
160 i2c_status_type i2c_memory_write_int (i2c_handle_type* hi2c, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout);
161 i2c_status_type i2c_memory_write_dma (i2c_handle_type* hi2c, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout);
162 i2c_status_type i2c_memory_read (i2c_handle_type* hi2c, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout);
163 i2c_status_type i2c_memory_read_int (i2c_handle_type* hi2c, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout);
164 i2c_status_type i2c_memory_read_dma (i2c_handle_type* hi2c, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout);
165
166void i2c_evt_irq_handler (i2c_handle_type* hi2c);
167void i2c_err_irq_handler (i2c_handle_type* hi2c);
168void i2c_dma_tx_irq_handler (i2c_handle_type* hi2c);
169void i2c_dma_rx_irq_handler (i2c_handle_type* hi2c);
170
179#ifdef __cplusplus
180}
181#endif
182
183#endif
at32f435_437.h
at32f435_437 header file
i2c_wait_flag
i2c_status_type i2c_wait_flag(i2c_handle_type *hi2c, uint32_t flag, uint32_t event_check, uint32_t timeout)
wait for the flag to be set or reset, only BUSYF flag is waiting to be reset, and other flags are wai...
Definition: i2c_application.c:214
i2c_wait_end
i2c_status_type i2c_wait_end(i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end.
Definition: i2c_application.c:165
i2c_evt_irq_handler
void i2c_evt_irq_handler(i2c_handle_type *hi2c)
interrupt procession function.
Definition: i2c_application.c:2140
i2c_slave_transmit_int
i2c_status_type i2c_slave_transmit_int(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through interrupt mode.
Definition: i2c_application.c:798
i2c_err_irq_handler
void i2c_err_irq_handler(i2c_handle_type *hi2c)
dma reveive complete interrupt function.
Definition: i2c_application.c:2174
i2c_smbus_slave_receive
i2c_status_type i2c_smbus_slave_receive(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through SMBus mode.
Definition: i2c_application.c:1464
i2c_dma_rx_irq_handler
void i2c_dma_rx_irq_handler(i2c_handle_type *hi2c)
dma reveive complete interrupt function.
Definition: i2c_application.c:2130
i2c_slave_receive
i2c_status_type i2c_slave_receive(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through polling mode.
Definition: i2c_application.c:441
i2c_slave_transmit_dma
i2c_status_type i2c_slave_transmit_dma(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through dma mode.
Definition: i2c_application.c:959
i2c_memory_read
i2c_status_type i2c_memory_read(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode.
Definition: i2c_application.c:1084
i2c_memory_write_int
i2c_status_type i2c_memory_write_int(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through interrupt mode.
Definition: i2c_application.c:1170
i2c_memory_write
i2c_status_type i2c_memory_write(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through polling mode.
Definition: i2c_application.c:1004
i2c_master_receive_int
i2c_status_type i2c_master_receive_int(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through interrupt mode.
Definition: i2c_application.c:764
i2c_smbus_master_transmit
i2c_status_type i2c_smbus_master_transmit(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through SMBus mode.
Definition: i2c_application.c:1390
i2c_smbus_slave_transmit
i2c_status_type i2c_smbus_slave_transmit(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through SMBus mode.
Definition: i2c_application.c:1628
i2c_memory_write_dma
i2c_status_type i2c_memory_write_dma(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through dma mode.
Definition: i2c_application.c:1271
i2c_reset_ctrl2_register
void i2c_reset_ctrl2_register(i2c_handle_type *hi2c)
reset ctrl2 register.
Definition: i2c_application.c:150
i2c_master_transmit_dma
i2c_status_type i2c_master_transmit_dma(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through dma mode.
Definition: i2c_application.c:835
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:113
i2c_dma_tx_irq_handler
void i2c_dma_tx_irq_handler(i2c_handle_type *hi2c)
dma transmission complete interrupt function.
Definition: i2c_application.c:2120
i2c_lowlevel_init
void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: i2c_application.c:103
i2c_slave_receive_dma
i2c_status_type i2c_slave_receive_dma(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through dma mode.
Definition: i2c_application.c:875
i2c_master_transmit_int
i2c_status_type i2c_master_transmit_int(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through interrupt mode.
Definition: i2c_application.c:695
i2c_memory_read_int
i2c_status_type i2c_memory_read_int(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through interrupt mode.
Definition: i2c_application.c:1217
i2c_master_receive
i2c_status_type i2c_master_receive(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through polling mode.
Definition: i2c_application.c:524
i2c_smbus_master_receive
i2c_status_type i2c_smbus_master_receive(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through SMBus mode.
Definition: i2c_application.c:1556
i2c_master_receive_dma
i2c_status_type i2c_master_receive_dma(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through dma mode.
Definition: i2c_application.c:919
i2c_slave_receive_int
i2c_status_type i2c_slave_receive_int(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through interrupt mode.
Definition: i2c_application.c:729
i2c_master_transmit
i2c_status_type i2c_master_transmit(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode.
Definition: i2c_application.c:375
i2c_slave_transmit
i2c_status_type i2c_slave_transmit(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through polling mode.
Definition: i2c_application.c:590
i2c_memory_read_dma
i2c_status_type i2c_memory_read_dma(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode.
Definition: i2c_application.c:1331
i2c_status_type
i2c_status_type
Definition: i2c_application.h:80
I2C_ERR_STEP_1
@ I2C_ERR_STEP_1
Definition: i2c_application.h:82
I2C_ERR_TIMEOUT
@ I2C_ERR_TIMEOUT
Definition: i2c_application.h:99
I2C_ERR_TCRLD
@ I2C_ERR_TCRLD
Definition: i2c_application.h:94
I2C_ERR_STEP_11
@ I2C_ERR_STEP_11
Definition: i2c_application.h:92
I2C_ERR_INTERRUPT
@ I2C_ERR_INTERRUPT
Definition: i2c_application.h:100
I2C_ERR_STEP_3
@ I2C_ERR_STEP_3
Definition: i2c_application.h:84
I2C_ERR_STEP_6
@ I2C_ERR_STEP_6
Definition: i2c_application.h:87
I2C_ERR_STEP_5
@ I2C_ERR_STEP_5
Definition: i2c_application.h:86
I2C_ERR_STEP_9
@ I2C_ERR_STEP_9
Definition: i2c_application.h:90
I2C_ERR_STEP_7
@ I2C_ERR_STEP_7
Definition: i2c_application.h:88
I2C_ERR_STOP
@ I2C_ERR_STOP
Definition: i2c_application.h:97
I2C_ERR_STEP_8
@ I2C_ERR_STEP_8
Definition: i2c_application.h:89
I2C_ERR_ACKFAIL
@ I2C_ERR_ACKFAIL
Definition: i2c_application.h:98
I2C_ERR_ADDR
@ I2C_ERR_ADDR
Definition: i2c_application.h:96
I2C_ERR_STEP_12
@ I2C_ERR_STEP_12
Definition: i2c_application.h:93
I2C_ERR_STEP_2
@ I2C_ERR_STEP_2
Definition: i2c_application.h:83
I2C_OK
@ I2C_OK
Definition: i2c_application.h:81
I2C_ERR_STEP_10
@ I2C_ERR_STEP_10
Definition: i2c_application.h:91
I2C_ERR_STEP_4
@ I2C_ERR_STEP_4
Definition: i2c_application.h:85
I2C_ERR_TDC
@ I2C_ERR_TDC
Definition: i2c_application.h:95
i2c_mode_type
i2c_mode_type
Definition: i2c_application.h:60
I2C_DMA_MA_RX
@ I2C_DMA_MA_RX
Definition: i2c_application.h:66
I2C_DMA_SLA_RX
@ I2C_DMA_SLA_RX
Definition: i2c_application.h:68
I2C_INT_SLA_RX
@ I2C_INT_SLA_RX
Definition: i2c_application.h:64
I2C_DMA_MA_TX
@ I2C_DMA_MA_TX
Definition: i2c_application.h:65
I2C_INT_MA_RX
@ I2C_INT_MA_RX
Definition: i2c_application.h:62
I2C_INT_SLA_TX
@ I2C_INT_SLA_TX
Definition: i2c_application.h:63
I2C_INT_MA_TX
@ I2C_INT_MA_TX
Definition: i2c_application.h:61
I2C_DMA_SLA_TX
@ I2C_DMA_SLA_TX
Definition: i2c_application.h:67
dma_channel_type
type define dma channel register all
Definition: at32f435_437_dma.h:576
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
i2c_handle_type
Definition: i2c_application.h:112
i2c_handle_type::dma_rx_channel
dma_channel_type * dma_rx_channel
Definition: i2c_application.h:121
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:113
i2c_handle_type::status
__IO uint32_t status
Definition: i2c_application.h:118
i2c_handle_type::psize
__IO uint16_t psize
Definition: i2c_application.h:115
i2c_handle_type::pbuff
uint8_t * pbuff
Definition: i2c_application.h:114
i2c_handle_type::mode
__IO uint32_t mode
Definition: i2c_application.h:117
i2c_handle_type::dma_init_struct
dma_init_type dma_init_struct
Definition: i2c_application.h:122
i2c_handle_type::error_code
__IO i2c_status_type error_code
Definition: i2c_application.h:119
i2c_handle_type::dma_tx_channel
dma_channel_type * dma_tx_channel
Definition: i2c_application.h:120
i2c_handle_type::pcount
__IO uint16_t pcount
Definition: i2c_application.h:116
i2c_type
type define i2c register all
Definition: at32f435_437_i2c.h:192


AT32F435/437 Firmwary Library: iperf.c File Reference

  • at_start_f437
  • examples
  • emac
  • iperf
  • src
Functions
iperf.c File Reference

iperf tool More...

#include "iperf.h"
#include "lwip/opt.h"
#include "lwip/tcp.h"

Go to the source code of this file.

Functions

static err_t | iperf_recv (void *arg, struct tcp_pcb *pcb, struct pbuf *p, err_t err)
iperf receive callback More...
static err_t | iperf_accept (void *arg, struct tcp_pcb *pcb, err_t err)
accept iperf connection More...
void | iperf_init (void)
initialize iperf server More...

Detailed Description

iperf tool

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file iperf.c.


AT32F435/437 Firmwary Library: iperf.c Source File

  • at_start_f437
  • examples
  • emac
  • iperf
  • src
iperf.c
Go to the documentation of this file.
1
27#include "iperf.h"
28
29#include "lwip/opt.h"
30#include "lwip/tcp.h"
31
48static err_t iperf_recv(void *arg, struct tcp_pcb *pcb, struct pbuf *p, err_t err)
49{
50 LWIP_UNUSED_ARG(arg);
51
52 if (err == ERR_OK && p != NULL) {
53 tcp_recved(pcb, p->tot_len);
54 pbuf_free(p);
55 } else
56 if (err != ERR_OK && p != NULL) {
57 pbuf_free(p);
58 }
59
60 if (err == ERR_OK && p == NULL) {
61 tcp_arg(pcb, NULL);
62 tcp_sent(pcb, NULL);
63 tcp_recv(pcb, NULL);
64 tcp_close(pcb);
65 }
66 return ERR_OK;
67}
68
76static err_t iperf_accept(void *arg, struct tcp_pcb *pcb, err_t err)
77{
78 LWIP_UNUSED_ARG(arg);
79 LWIP_UNUSED_ARG(err);
80
81 tcp_arg(pcb, NULL);
82 tcp_sent(pcb, NULL);
83 tcp_recv(pcb, iperf_recv);
84 return ERR_OK;
85}
86
92void iperf_init(void)
93{
94 struct tcp_pcb *pcb;
95 pcb = tcp_new();
96 tcp_bind(pcb, IP_ADDR_ANY, 5001); /* bind to iperf port */
97 pcb = tcp_listen(pcb);
98 tcp_accept(pcb, iperf_accept);
99}
100
iperf_recv
static err_t iperf_recv(void *arg, struct tcp_pcb *pcb, struct pbuf *p, err_t err)
iperf receive callback
Definition: iperf.c:48
iperf_accept
static err_t iperf_accept(void *arg, struct tcp_pcb *pcb, err_t err)
accept iperf connection
Definition: iperf.c:76
iperf_init
void iperf_init(void)
initialize iperf server
Definition: iperf.c:92
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
pcb
struct tcp_pcb * pcb
Definition: project/at_start_f437/examples/emac/mqtt_client/src/netconf.c:63
iperf.h
iperf tool header


AT32F435/437 Firmwary Library: iperf.h File Reference

  • at_start_f437
  • examples
  • emac
  • iperf
  • inc
Functions
iperf.h File Reference

iperf tool header More...

Go to the source code of this file.

Functions

void iperf_init (void)
initialize iperf server More...

Detailed Description

iperf tool header

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file iperf.h.


AT32F435/437 Firmwary Library: iperf.h Source File

  • at_start_f437
  • examples
  • emac
  • iperf
  • inc
iperf.h
Go to the documentation of this file.
1
27#ifndef __IPERF_H__
28#define __IPERF_H__
29
30#ifdef __cplusplus
31 extern "C" {
32#endif
33
45void iperf_init(void);
46
55#ifdef __cplusplus
56}
57#endif
58
59#endif /* __IPERF_H__ */
iperf_init
void iperf_init(void)
initialize iperf server
Definition: iperf.c:92


AT32F435/437 Firmwary Library: keyboard_class.c Source File

  • middlewares
  • usbd_class
  • keyboard
keyboard_class.c
Go to the documentation of this file.
1
26#include "usbd_core.h"
27#include "keyboard_class.h"
28#include "keyboard_desc.h"
29
43static usb_sts_type class_init_handler(void *udev);
44static usb_sts_type class_clear_handler(void *udev);
45static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
46static usb_sts_type class_ept0_tx_handler(void *udev);
47static usb_sts_type class_ept0_rx_handler(void *udev);
48static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
49static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
50static usb_sts_type class_sof_handler(void *udev);
51static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
52
53 keyboard_type keyboard_struct;
54#define SHIFT 0x80
55const static unsigned char _asciimap[128] =
56{
57 0x00,// NUL
58 0x00,// SOH
59 0x00,// STX
60 0x00,// ETX
61 0x00,// EOT
62 0x00,// ENQ
63 0x00,// ACK
64 0x00,// BEL
65 0x2A,// BS Backspace
66 0x2B,// TAB Tab
67 0x28,// LF Enter
68 0x00,// VT
69 0x00,// FF
70 0x00,// CR
71 0x00,// SO
72 0x00,// SI
73 0x00,// DEL
74 0x00,// DC1
75 0x00,// DC2
76 0x00,// DC3
77 0x00,// DC4
78 0x00,// NAK
79 0x00,// SYN
80 0x00,// ETB
81 0x00,// CAN
82 0x00,// EM
83 0x00,// SUB
84 0x00,// ESC
85 0x00,// FS
86 0x00,// GS
87 0x00,// RS
88 0x00,// US
89
90 0x2C,// ' '
91 0x1E|SHIFT,// !
92 0x34|SHIFT,// "
93 0x20|SHIFT,// #
94 0x21|SHIFT,// $
95 0x22|SHIFT,// %
96 0x24|SHIFT,// &
97 0x34, // '
98 0x26|SHIFT,// (
99 0x27|SHIFT,// )
100 0x25|SHIFT,// *
101 0x2E|SHIFT,// +
102 0x36,// ,
103 0x2D,// -
104 0x37,// .
105 0x38,// /
106 0x27,// 0
107 0x1E,// 1
108 0x1F,// 2
109 0x20,// 3
110 0x21,// 4
111 0x22,// 5
112 0x23,// 6
113 0x24,// 7
114 0x25,// 8
115 0x26,// 9
116 0x33|SHIFT,// :
117 0x33, // ;
118 0x36|SHIFT,// <
119 0x2E, // =
120 0x37|SHIFT,// >
121 0x38|SHIFT,// ?
122 0x1F|SHIFT,// @
123 0x04|SHIFT,// A
124 0x05|SHIFT,// B
125 0x06|SHIFT,// C
126 0x07|SHIFT,// D
127 0x08|SHIFT,// E
128 0x09|SHIFT,// F
129 0x0A|SHIFT,// G
130 0x0B|SHIFT,// H
131 0x0C|SHIFT,// I
132 0x0D|SHIFT,// J
133 0x0E|SHIFT,// K
134 0x0F|SHIFT,// L
135 0x10|SHIFT,// M
136 0x11|SHIFT,// N
137 0x12|SHIFT,// O
138 0x13|SHIFT,// P
139 0x14|SHIFT,// Q
140 0x15|SHIFT,// R
141 0x16|SHIFT,// S
142 0x17|SHIFT,// T
143 0x18|SHIFT,// U
144 0x19|SHIFT,// V
145 0x1A|SHIFT,// W
146 0x1B|SHIFT,// X
147 0x1C|SHIFT,// Y
148 0x1D|SHIFT,// Z
149 0x2F, // [
150 0x31, // bslash
151 0x30, // ]
152 0x23|SHIFT,// ^
153 0x2D|SHIFT,// _
154 0x35, // `
155 0x04, // a
156 0x05, // b
157 0x06, // c
158 0x07, // d
159 0x08, // e
160 0x09, // f
161 0x0A, // g
162 0x0B, // h
163 0x0C, // i
164 0x0D, // j
165 0x0E, // k
166 0x0F, // l
167 0x10, // m
168 0x11, // n
169 0x12, // o
170 0x13, // p
171 0x14, // q
172 0x15, // r
173 0x16, // s
174 0x17, // t
175 0x18, // u
176 0x19, // v
177 0x1A, // w
178 0x1B, // x
179 0x1C, // y
180 0x1D, // z
181 0x2f|SHIFT,//
182 0x31|SHIFT,// |
183 0x30|SHIFT,// }
184 0x35|SHIFT,// ~
185 0 // DEL
186};
187
188/* usb device class handler */
189usbd_class_handler keyboard_class_handler =
190{
191 class_init_handler,
192 class_clear_handler,
193 class_setup_handler,
194 class_ept0_tx_handler,
195 class_ept0_rx_handler,
196 class_in_handler,
197 class_out_handler,
198 class_sof_handler,
199 class_event_handler,
200 &keyboard_struct
201};
202
208static usb_sts_type class_init_handler(void *udev)
209{
210 usb_sts_type status = USB_OK;
211 usbd_core_type *pudev = (usbd_core_type *)udev;
212 keyboard_type *pkeyboard = (keyboard_type *)pudev->class_handler->pdata;
213
214 /* open hid in endpoint */
215 usbd_ept_open(pudev, USBD_KEYBOARD_IN_EPT, EPT_INT_TYPE, USBD_KEYBOARD_IN_MAXPACKET_SIZE);
216
217 pkeyboard->g_u8tx_completed = 1;
218
219 return status;
220}
221
227static usb_sts_type class_clear_handler(void *udev)
228{
229 usb_sts_type status = USB_OK;
230 usbd_core_type *pudev = (usbd_core_type *)udev;
231
232 /* close hid in endpoint */
233 usbd_ept_close(pudev, USBD_KEYBOARD_IN_EPT);
234
235 return status;
236}
237
244static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
245{
246 usb_sts_type status = USB_OK;
247 usbd_core_type *pudev = (usbd_core_type *)udev;
248 keyboard_type *pkeyboard = (keyboard_type *)pudev->class_handler->pdata;
249 uint16_t len;
250 uint8_t *buf;
251
252 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
253 {
254 /* class request */
255 case USB_REQ_TYPE_CLASS:
256 switch(setup->bRequest)
257 {
258 case HID_REQ_SET_PROTOCOL:
259 pkeyboard->hid_protocol = (uint8_t)setup->wValue;
260 break;
261 case HID_REQ_GET_PROTOCOL:
262 usbd_ctrl_send(pudev, (uint8_t *)&pkeyboard->hid_protocol, 1);
263 break;
264 case HID_REQ_SET_IDLE:
265 pkeyboard->hid_set_idle = (uint8_t)(setup->wValue >> 8);
266 break;
267 case HID_REQ_GET_IDLE:
268 usbd_ctrl_send(pudev, (uint8_t *)&pkeyboard->hid_set_idle, 1);
269 break;
270 case HID_REQ_SET_REPORT:
271 pkeyboard->hid_state = HID_REQ_SET_REPORT;
272 usbd_ctrl_recv(pudev, pkeyboard->hid_set_report, setup->wLength);
273 break;
274 default:
275 usbd_ctrl_unsupport(pudev);
276 break;
277 }
278 break;
279 /* standard request */
280 case USB_REQ_TYPE_STANDARD:
281 switch(setup->bRequest)
282 {
283 case USB_STD_REQ_GET_DESCRIPTOR:
284 if(setup->wValue >> 8 == HID_REPORT_DESC)
285 {
286 len = MIN(USBD_KEYBOARD_SIZ_REPORT_DESC, setup->wLength);
287 buf = (uint8_t *)g_usbd_keyboard_report;
288 }
289 else if(setup->wValue >> 8 == HID_DESCRIPTOR_TYPE)
290 {
291 len = MIN(9, setup->wLength);
292 buf = (uint8_t *)g_keyboard_usb_desc;
293 }
294 usbd_ctrl_send(pudev, (uint8_t *)buf, len);
295 break;
296 case USB_STD_REQ_GET_INTERFACE:
297 usbd_ctrl_send(pudev, (uint8_t *)&pkeyboard->alt_setting, 1);
298 break;
299 case USB_STD_REQ_SET_INTERFACE:
300 pkeyboard->alt_setting = setup->wValue;
301 break;
302 default:
303 break;
304 }
305 break;
306 default:
307 usbd_ctrl_unsupport(pudev);
308 break;
309 }
310 return status;
311}
312
318static usb_sts_type class_ept0_tx_handler(void *udev)
319{
320 usb_sts_type status = USB_OK;
321
322 /* ...user code... */
323
324 return status;
325}
326
332static usb_sts_type class_ept0_rx_handler(void *udev)
333{
334 usb_sts_type status = USB_OK;
335 usbd_core_type *pudev = (usbd_core_type *)udev;
336 keyboard_type *pkeyboard = (keyboard_type *)pudev->class_handler->pdata;
337 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
338 /* ...user code... */
339 if( pkeyboard->hid_state == HID_REQ_SET_REPORT)
340 {
341 /* hid buffer process */
342 pkeyboard->hid_state = 0;
343 }
344
345 return status;
346}
347
354static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
355{
356 usb_sts_type status = USB_OK;
357 usbd_core_type *pudev = (usbd_core_type *)udev;
358 keyboard_type *pkeyboard = (keyboard_type *)pudev->class_handler->pdata;
359
360 /* ...user code...
361 trans next packet data
362 */
363 pkeyboard->g_u8tx_completed = 1;
364
365 return status;
366}
367
374static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
375{
376 usb_sts_type status = USB_OK;
377
378 return status;
379}
380
386static usb_sts_type class_sof_handler(void *udev)
387{
388 usb_sts_type status = USB_OK;
389
390 /* ...user code... */
391
392 return status;
393}
394
401static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
402{
403 usb_sts_type status = USB_OK;
404 usbd_core_type *pudev = (usbd_core_type *)udev;
405 keyboard_type *pkeyboard = (keyboard_type *)pudev->class_handler->pdata;
406 switch(event)
407 {
408 case USBD_RESET_EVENT:
409
410 /* ...user code... */
411
412 break;
413 case USBD_SUSPEND_EVENT:
414 pkeyboard->hid_suspend_flag = 1;
415 /* ...user code... */
416
417 break;
418 case USBD_WAKEUP_EVENT:
419 /* ...user code... */
420
421 break;
422 default:
423 break;
424 }
425 return status;
426}
427
435 usb_sts_type usb_keyboard_class_send_report(void *udev, uint8_t *report, uint16_t len)
436{
437 usb_sts_type status = USB_OK;
438 usbd_core_type *pudev = (usbd_core_type *)udev;
439
440 if(usbd_connect_state_get(pudev) == USB_CONN_STATE_CONFIGURED)
441 usbd_ept_send(pudev, USBD_KEYBOARD_IN_EPT, report, len);
442
443 return status;
444}
445
446
453void usb_hid_keyboard_send_char(void *udev, uint8_t ascii_code)
454{
455 uint8_t key_data = 0;
456 usbd_core_type *pudev = (usbd_core_type *)udev;
457 keyboard_type *pkeyboard = (keyboard_type *)pudev->class_handler->pdata;
458
459 if(ascii_code > 128)
460 {
461 ascii_code = 0;
462 }
463 else
464 {
465 ascii_code = _asciimap[ascii_code];
466 if(!ascii_code)
467 {
468 ascii_code = 0;
469 }
470
471 if(ascii_code & SHIFT)
472 {
473 key_data = 0x2;
474 ascii_code &= 0x7F;
475 }
476 }
477
478 if((pkeyboard->temp == ascii_code) && (ascii_code != 0))
479 {
480 pkeyboard->keyboard_buf[0] = 0;
481 pkeyboard->keyboard_buf[2] = 0;
482 usb_keyboard_class_send_report(udev, pkeyboard->keyboard_buf, 8);
483 }
484 else
485 {
486 pkeyboard->keyboard_buf[0] = key_data;
487 pkeyboard->keyboard_buf[2] = ascii_code;
488 usb_keyboard_class_send_report(udev, pkeyboard->keyboard_buf, 8);
489 }
490}
491
492
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f435_437_usb.h:349
USBD_KEYBOARD_IN_MAXPACKET_SIZE
#define USBD_KEYBOARD_IN_MAXPACKET_SIZE
usb hid in and out max packet size define
Definition: keyboard_class.h:58
USBD_KEYBOARD_IN_EPT
#define USBD_KEYBOARD_IN_EPT
usb hid use endpoint define
Definition: keyboard_class.h:53
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: keyboard_class.c:386
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: keyboard_class.c:354
keyboard_struct
keyboard_type keyboard_struct
Definition: keyboard_class.c:53
_asciimap
static const unsigned char _asciimap[128]
Definition: keyboard_class.c:55
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: keyboard_class.c:227
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: keyboard_class.c:244
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: keyboard_class.c:318
usb_hid_keyboard_send_char
void usb_hid_keyboard_send_char(void *udev, uint8_t ascii_code)
usb device class report function
Definition: keyboard_class.c:453
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: keyboard_class.c:332
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: keyboard_class.c:401
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: keyboard_class.c:208
usb_keyboard_class_send_report
usb_sts_type usb_keyboard_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: keyboard_class.c:435
keyboard_class_handler
usbd_class_handler keyboard_class_handler
Definition: keyboard_class.c:189
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: keyboard_class.c:374
SHIFT
#define SHIFT
Definition: keyboard_class.c:54
USBD_KEYBOARD_SIZ_REPORT_DESC
#define USBD_KEYBOARD_SIZ_REPORT_DESC
Definition: keyboard_desc.h:65
g_usbd_keyboard_report
uint8_t g_usbd_keyboard_report[63]
usb mouse report descriptor
Definition: keyboard_desc.c:159
g_keyboard_usb_desc
uint8_t g_keyboard_usb_desc[9]
usb hid descriptor
Definition: keyboard_desc.c:201
HID_DESCRIPTOR_TYPE
#define HID_DESCRIPTOR_TYPE
Definition: usb_std.h:236
HID_REQ_GET_PROTOCOL
#define HID_REQ_GET_PROTOCOL
Definition: usb_std.h:231
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:254
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:63
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:81
HID_REQ_SET_PROTOCOL
#define HID_REQ_SET_PROTOCOL
usb hid class request code define
Definition: usb_std.h:230
HID_REPORT_DESC
#define HID_REPORT_DESC
Definition: usb_std.h:237
HID_REQ_SET_IDLE
#define HID_REQ_SET_IDLE
Definition: usb_std.h:232
HID_REQ_GET_IDLE
#define HID_REQ_GET_IDLE
Definition: usb_std.h:233
HID_REQ_SET_REPORT
#define HID_REQ_SET_REPORT
Definition: usb_std.h:234
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:86
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:66
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:85
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:64
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:131
USB_OK
@ USB_OK
Definition: usb_std.h:268
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:597
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:346
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:314
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:177
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint send data
Definition: usbd_core.c:434
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
get endpoint receive data length
Definition: usbd_core.c:300
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint recv data
Definition: usbd_core.c:196
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:287
keyboard_class.h
usb hid keyboard header file
keyboard_desc.h
usb keyboard descriptor header file
keyboard_type
Definition: keyboard_class.h:67
keyboard_type::keyboard_buf
uint8_t keyboard_buf[8]
Definition: keyboard_class.h:72
keyboard_type::hid_set_report
uint8_t hid_set_report[64]
Definition: keyboard_class.h:71
keyboard_type::hid_set_idle
uint32_t hid_set_idle
Definition: keyboard_class.h:69
keyboard_type::alt_setting
uint32_t alt_setting
Definition: keyboard_class.h:70
keyboard_type::temp
uint8_t temp
Definition: keyboard_class.h:77
keyboard_type::hid_state
uint8_t hid_state
Definition: keyboard_class.h:76
keyboard_type::g_u8tx_completed
__IO uint8_t g_u8tx_completed
Definition: keyboard_class.h:75
keyboard_type::hid_protocol
uint32_t hid_protocol
Definition: keyboard_class.h:68
keyboard_type::hid_suspend_flag
__IO uint8_t hid_suspend_flag
Definition: keyboard_class.h:74
usb_setup_type
format of usb setup data
Definition: usb_std.h:280
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:283
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:286
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:281
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:282
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: keyboard_class.h Source File

  • middlewares
  • usbd_class
  • keyboard
keyboard_class.h
Go to the documentation of this file.
1
27 /* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __KEYBOARD_CLASS_H
29#define __KEYBOARD_CLASS_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "usb_std.h"
36#include "usbd_core.h"
37
53#define USBD_KEYBOARD_IN_EPT 0x81
54
58#define USBD_KEYBOARD_IN_MAXPACKET_SIZE 0x40
59#define USBD_KEYBOARD_OUT_MAXPACKET_SIZE 0x40
60
66typedef struct
67{
68 uint32_t hid_protocol;
69 uint32_t hid_set_idle;
70 uint32_t alt_setting;
71 uint8_t hid_set_report[64];
72 uint8_t keyboard_buf[8];
73
74 __IO uint8_t hid_suspend_flag;
75 __IO uint8_t g_u8tx_completed;
76 uint8_t hid_state;
77 uint8_t temp;
78
79}keyboard_type;
80
84extern usbd_class_handler keyboard_class_handler;
85
86 usb_sts_type usb_keyboard_class_send_report(void *udev, uint8_t *report, uint16_t len);
87void usb_hid_keyboard_send_char(void *udev, uint8_t ascii_code);
99#ifdef __cplusplus
100}
101#endif
102
103#endif
usb_hid_keyboard_send_char
void usb_hid_keyboard_send_char(void *udev, uint8_t ascii_code)
usb device class report function
Definition: keyboard_class.c:453
usb_keyboard_class_send_report
usb_sts_type usb_keyboard_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: keyboard_class.c:435
keyboard_class_handler
usbd_class_handler keyboard_class_handler
Definition: keyboard_class.c:189
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
keyboard_type
Definition: keyboard_class.h:67
keyboard_type::hid_set_idle
uint32_t hid_set_idle
Definition: keyboard_class.h:69
keyboard_type::alt_setting
uint32_t alt_setting
Definition: keyboard_class.h:70
keyboard_type::temp
uint8_t temp
Definition: keyboard_class.h:77
keyboard_type::hid_state
uint8_t hid_state
Definition: keyboard_class.h:76
keyboard_type::g_u8tx_completed
__IO uint8_t g_u8tx_completed
Definition: keyboard_class.h:75
keyboard_type::hid_protocol
uint32_t hid_protocol
Definition: keyboard_class.h:68
keyboard_type::hid_suspend_flag
__IO uint8_t hid_suspend_flag
Definition: keyboard_class.h:74
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: keyboard_desc.c Source File

  • middlewares
  • usbd_class
  • keyboard
keyboard_desc.c
Go to the documentation of this file.
1
26#include "usb_std.h"
27#include "usbd_sdr.h"
28#include "usbd_core.h"
29#include "keyboard_desc.h"
30
44static usbd_desc_t *get_device_descriptor(void);
45static usbd_desc_t *get_device_qualifier(void);
46static usbd_desc_t *get_device_configuration(void);
47static usbd_desc_t *get_device_other_speed(void);
48static usbd_desc_t *get_device_lang_id(void);
49static usbd_desc_t *get_device_manufacturer_string(void);
50static usbd_desc_t *get_device_product_string(void);
51static usbd_desc_t *get_device_serial_string(void);
52static usbd_desc_t *get_device_interface_string(void);
53static usbd_desc_t *get_device_config_string(void);
54
55static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
56static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
57static void get_serial_num(void);
58static uint8_t g_usbd_desc_buffer[256];
59
63usbd_desc_handler keyboard_desc_handler =
64{
65 get_device_descriptor,
66 get_device_qualifier,
67 get_device_configuration,
68 get_device_other_speed,
69 get_device_lang_id,
70 get_device_manufacturer_string,
71 get_device_product_string,
72 get_device_serial_string,
73 get_device_interface_string,
74 get_device_config_string,
75};
76
80#if defined ( __ICCARM__ ) /* iar compiler */
81 #pragma data_alignment=4
82#endif
83ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
84{
85 USB_DEVICE_DESC_LEN, /* bLength */
86 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
87 0x00, /* bcdUSB */
88 0x02,
89 0x00, /* bDeviceClass */
90 0x00, /* bDeviceSubClass */
91 0x00, /* bDeviceProtocol */
92 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
93 LBYTE(USBD_KEYBOARD_VENDOR_ID), /* idVendor */
94 HBYTE(USBD_KEYBOARD_VENDOR_ID), /* idVendor */
95 LBYTE(USBD_KEYBOARD_PRODUCT_ID), /* idProduct */
96 HBYTE(USBD_KEYBOARD_PRODUCT_ID), /* idProduct */
97 0x00, /* bcdDevice rel. 2.00 */
98 0x02,
99 USB_MFC_STRING, /* Index of manufacturer string */
100 USB_PRODUCT_STRING, /* Index of product string */
101 USB_SERIAL_STRING, /* Index of serial number string */
102 1 /* bNumConfigurations */
103};
104
108#if defined ( __ICCARM__ ) /* iar compiler */
109 #pragma data_alignment=4
110#endif
111ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_KEYBOARD_CONFIG_DESC_SIZE] ALIGNED_TAIL =
112{
113 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
114 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
115 LBYTE(USBD_KEYBOARD_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
116 HBYTE(USBD_KEYBOARD_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
117 0x01, /* bNumInterfaces: 1 interface */
118 0x01, /* bConfigurationValue: configuration value */
119 0x00, /* iConfiguration: index of string descriptor describing
120 the configuration */
121 0xE0, /* bmAttributes: self powered and support remote wakeup*/
122 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
123
124 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
125 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
126 0x00, /* bInterfaceNumber: number of interface */
127 0x00, /* bAlternateSetting: alternate set */
128 0x01, /* bNumEndpoints: number of endpoints */
129 USB_CLASS_CODE_HID, /* bInterfaceClass: class code hid */
130 0x01, /* bInterfaceSubClass: subclass code */
131 0x01, /* bInterfaceProtocol: protocol code */
132 0x00, /* iInterface: index of string descriptor */
133
134 0x09, /* bLength: size of HID descriptor in bytes */
135 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
136 LBYTE(KEYBOARD_BCD_NUM),
137 HBYTE(KEYBOARD_BCD_NUM), /* bcdHID: HID class specification release number */
138 0x00, /* bCountryCode: hardware target conutry */
139 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
140 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
141 LBYTE(sizeof(g_usbd_keyboard_report)),
142 HBYTE(sizeof(g_usbd_keyboard_report)), /* wDescriptorLength: total length of reprot descriptor */
143
144 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
145 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
146 USBD_KEYBOARD_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
147 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
148 LBYTE(USBD_KEYBOARD_IN_MAXPACKET_SIZE),
149 HBYTE(USBD_KEYBOARD_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
150 KEYBOARD_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
151};
152
156#if defined ( __ICCARM__ ) /* iar compiler */
157 #pragma data_alignment=4
158#endif
159ALIGNED_HEAD uint8_t g_usbd_keyboard_report[USBD_KEYBOARD_SIZ_REPORT_DESC] ALIGNED_TAIL =
160{
161 0x05, 0x01, // USAGE_PAGE (Generic Desktop)
162 0x09, 0x06, // USAGE (Keyboard)
163 0xa1, 0x01, // COLLECTION (Application)
164 0x05, 0x07, // USAGE_PAGE (Keyboard)
165 0x19, 0xe0, // USAGE_MINIMUM (Keyboard LeftControl)
166 0x29, 0xe7, // USAGE_MAXIMUM (Keyboard Right GUI)
167 0x15, 0x00, // LOGICAL_MINIMUM (0)
168 0x25, 0x01, // LOGICAL_MAXIMUM (1)
169 0x75, 0x01, // REPORT_SIZE (1)
170 0x95, 0x08, // REPORT_COUNT (8)
171 0x81, 0x02, // INPUT (Data,Var,Abs)
172 0x95, 0x01, // REPORT_COUNT (1)
173 0x75, 0x08, // REPORT_SIZE (8)
174 0x81, 0x03, // INPUT (Cnst,Var,Abs)
175 0x95, 0x05, // REPORT_COUNT (5)
176 0x75, 0x01, // REPORT_SIZE (1)
177 0x05, 0x08, // USAGE_PAGE (LEDs)
178 0x19, 0x01, // USAGE_MINIMUM (Num Lock)
179 0x29, 0x05, // USAGE_MAXIMUM (Kana)
180 0x91, 0x02, // OUTPUT (Data,Var,Abs)
181 0x95, 0x01, // REPORT_COUNT (1)
182 0x75, 0x03, // REPORT_SIZE (3)
183 0x91, 0x03, // OUTPUT (Cnst,Var,Abs)
184 0x95, 0x06, // REPORT_COUNT (6)
185 0x75, 0x08, // REPORT_SIZE (8)
186 0x15, 0x00, // LOGICAL_MINIMUM (0)
187 0x25, 0xFF, // LOGICAL_MAXIMUM (255)
188 0x05, 0x07, // USAGE_PAGE (Keyboard)
189 0x19, 0x00, // USAGE_MINIMUM (Reserved (no event indicated))
190 0x29, 0x65, // USAGE_MAXIMUM (Keyboard Application)
191 0x81, 0x00, // INPUT (Data,Ary,Abs)
192 0xc0 // END_COLLECTION
193};
194
198#if defined ( __ICCARM__ ) /* iar compiler */
199 #pragma data_alignment=4
200#endif
201ALIGNED_HEAD uint8_t g_keyboard_usb_desc[9] ALIGNED_TAIL =
202{
203 0x09, /* bLength: size of HID descriptor in bytes */
204 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
205 LBYTE(KEYBOARD_BCD_NUM),
206 HBYTE(KEYBOARD_BCD_NUM), /* bcdHID: HID class specification release number */
207 0x00, /* bCountryCode: hardware target conutry */
208 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
209 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
210 LBYTE(sizeof(g_usbd_keyboard_report)),
211 HBYTE(sizeof(g_usbd_keyboard_report)), /* wDescriptorLength: total length of reprot descriptor */
212};
213
214
218#if defined ( __ICCARM__ ) /* iar compiler */
219 #pragma data_alignment=4
220#endif
221ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_KEYBOARD_SIZ_STRING_LANGID] ALIGNED_TAIL =
222{
223 USBD_KEYBOARD_SIZ_STRING_LANGID,
224 USB_DESCIPTOR_TYPE_STRING,
225 0x09,
226 0x04,
227};
228
232#if defined ( __ICCARM__ ) /* iar compiler */
233 #pragma data_alignment=4
234#endif
235ALIGNED_HEAD static uint8_t g_string_serial[USBD_KEYBOARD_SIZ_STRING_SERIAL] ALIGNED_TAIL =
236{
237 USBD_KEYBOARD_SIZ_STRING_SERIAL,
238 USB_DESCIPTOR_TYPE_STRING,
239};
240
241
242/* device descriptor */
243static usbd_desc_t device_descriptor =
244{
245 USB_DEVICE_DESC_LEN,
246 g_usbd_descriptor
247};
248
249/* config descriptor */
250static usbd_desc_t config_descriptor =
251{
252 USBD_KEYBOARD_CONFIG_DESC_SIZE,
253 g_usbd_configuration
254};
255
256/* langid descriptor */
257static usbd_desc_t langid_descriptor =
258{
259 USBD_KEYBOARD_SIZ_STRING_LANGID,
260 g_string_lang_id
261};
262
263/* serial descriptor */
264static usbd_desc_t serial_descriptor =
265{
266 USBD_KEYBOARD_SIZ_STRING_SERIAL,
267 g_string_serial
268};
269
270static usbd_desc_t vp_desc;
271
278static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
279{
280 uint16_t str_len = 0, id_pos = 2;
281 uint8_t *tmp_str = string;
282
283 while(*tmp_str != '\0')
284 {
285 str_len ++;
286 unicode_buf[id_pos ++] = *tmp_str ++;
287 unicode_buf[id_pos ++] = 0x00;
288 }
289
290 str_len = str_len * 2 + 2;
291 unicode_buf[0] = str_len;
292 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
293
294 return str_len;
295}
296
304static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
305{
306 uint8_t idx = 0;
307
308 for( idx = 0 ; idx < len ; idx ++)
309 {
310 if( ((value >> 28)) < 0xA )
311 {
312 pbuf[ 2 * idx] = (value >> 28) + '0';
313 }
314 else
315 {
316 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
317 }
318
319 value = value << 4;
320
321 pbuf[2 * idx + 1] = 0;
322 }
323}
324
330static void get_serial_num(void)
331{
332 uint32_t serial0, serial1, serial2;
333
334 serial0 = *(uint32_t*)MCU_ID1;
335 serial1 = *(uint32_t*)MCU_ID2;
336 serial2 = *(uint32_t*)MCU_ID3;
337
338 serial0 += serial2;
339
340 if (serial0 != 0)
341 {
342 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
343 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
344 }
345}
346
352static usbd_desc_t *get_device_descriptor(void)
353{
354 return &device_descriptor;
355}
356
362static usbd_desc_t * get_device_qualifier(void)
363{
364 return NULL;
365}
366
372static usbd_desc_t *get_device_configuration(void)
373{
374 return &config_descriptor;
375}
376
382static usbd_desc_t *get_device_other_speed(void)
383{
384 return NULL;
385}
386
392static usbd_desc_t *get_device_lang_id(void)
393{
394 return &langid_descriptor;
395}
396
397
403static usbd_desc_t *get_device_manufacturer_string(void)
404{
405 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_KEYBOARD_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
406 vp_desc.descriptor = g_usbd_desc_buffer;
407 return &vp_desc;
408}
409
415static usbd_desc_t *get_device_product_string(void)
416{
417 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_KEYBOARD_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
418 vp_desc.descriptor = g_usbd_desc_buffer;
419 return &vp_desc;
420}
421
427static usbd_desc_t *get_device_serial_string(void)
428{
429 get_serial_num();
430 return &serial_descriptor;
431}
432
438static usbd_desc_t *get_device_interface_string(void)
439{
440 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_KEYBOARD_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
441 vp_desc.descriptor = g_usbd_desc_buffer;
442 return &vp_desc;
443}
444
450static usbd_desc_t *get_device_config_string(void)
451{
452 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_KEYBOARD_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
453 vp_desc.descriptor = g_usbd_desc_buffer;
454 return &vp_desc;
455}
456
idx
uint32_t idx
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:46
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:215
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:216
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:217
USBD_KEYBOARD_IN_MAXPACKET_SIZE
#define USBD_KEYBOARD_IN_MAXPACKET_SIZE
usb hid in and out max packet size define
Definition: keyboard_class.h:58
USBD_KEYBOARD_IN_EPT
#define USBD_KEYBOARD_IN_EPT
usb hid use endpoint define
Definition: keyboard_class.h:53
USBD_KEYBOARD_VENDOR_ID
#define USBD_KEYBOARD_VENDOR_ID
usb vendor id and product id define
Definition: keyboard_desc.h:58
USBD_KEYBOARD_DESC_CONFIGURATION_STRING
#define USBD_KEYBOARD_DESC_CONFIGURATION_STRING
Definition: keyboard_desc.h:74
USBD_KEYBOARD_CONFIG_DESC_SIZE
#define USBD_KEYBOARD_CONFIG_DESC_SIZE
usb descriptor size define
Definition: keyboard_desc.h:64
USBD_KEYBOARD_SIZ_STRING_LANGID
#define USBD_KEYBOARD_SIZ_STRING_LANGID
Definition: keyboard_desc.h:66
USBD_KEYBOARD_DESC_MANUFACTURER_STRING
#define USBD_KEYBOARD_DESC_MANUFACTURER_STRING
usb string define(vendor, product configuration, interface)
Definition: keyboard_desc.h:72
USBD_KEYBOARD_SIZ_REPORT_DESC
#define USBD_KEYBOARD_SIZ_REPORT_DESC
Definition: keyboard_desc.h:65
KEYBOARD_BCD_NUM
#define KEYBOARD_BCD_NUM
usb bcd number define
Definition: keyboard_desc.h:53
KEYBOARD_BINTERVAL_TIME
#define KEYBOARD_BINTERVAL_TIME
usb hid endpoint interval define
Definition: keyboard_desc.h:80
USBD_KEYBOARD_DESC_PRODUCT_STRING
#define USBD_KEYBOARD_DESC_PRODUCT_STRING
Definition: keyboard_desc.h:73
USBD_KEYBOARD_SIZ_STRING_SERIAL
#define USBD_KEYBOARD_SIZ_STRING_SERIAL
Definition: keyboard_desc.h:67
USBD_KEYBOARD_PRODUCT_ID
#define USBD_KEYBOARD_PRODUCT_ID
Definition: keyboard_desc.h:59
USBD_KEYBOARD_DESC_INTERFACE_STRING
#define USBD_KEYBOARD_DESC_INTERFACE_STRING
Definition: keyboard_desc.h:75
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: keyboard_desc.c:264
device_descriptor
static usbd_desc_t device_descriptor
Definition: keyboard_desc.c:243
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: keyboard_desc.c:372
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: keyboard_desc.c:257
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: keyboard_desc.c:352
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: keyboard_desc.c:403
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: keyboard_desc.c:362
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: keyboard_desc.c:438
g_usbd_keyboard_report
uint8_t g_usbd_keyboard_report[63]
usb mouse report descriptor
Definition: keyboard_desc.c:159
g_usbd_desc_buffer
static uint8_t g_usbd_desc_buffer[256]
Definition: keyboard_desc.c:58
vp_desc
static usbd_desc_t vp_desc
Definition: keyboard_desc.c:270
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: keyboard_desc.c:382
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL
usb device standard descriptor
Definition: keyboard_desc.c:83
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: keyboard_desc.c:415
keyboard_desc_handler
usbd_desc_handler keyboard_desc_handler
keyboard device descriptor handler structure
Definition: keyboard_desc.c:63
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: keyboard_desc.c:450
g_keyboard_usb_desc
uint8_t g_keyboard_usb_desc[9]
usb hid descriptor
Definition: keyboard_desc.c:201
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: keyboard_desc.c:278
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: keyboard_desc.c:392
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: keyboard_desc.c:330
config_descriptor
static usbd_desc_t config_descriptor
Definition: keyboard_desc.c:250
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: keyboard_desc.c:427
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: keyboard_desc.c:304
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:153
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:93
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: usb_std.h:223
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: usb_std.h:224
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:96
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:152
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:151
USB_EPT_DESC_INTERRUPT
#define USB_EPT_DESC_INTERRUPT
Definition: usb_std.h:178
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:94
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:95
USB_CLASS_CODE_HID
#define USB_CLASS_CODE_HID
Definition: usb_std.h:163
keyboard_desc.h
usb keyboard descriptor header file
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h


AT32F435/437 Firmwary Library: keyboard_desc.h Source File

  • middlewares
  • usbd_class
  • keyboard
keyboard_desc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __KEYBOARD_DESC_H
29#define __KEYBOARD_DESC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "keyboard_class.h"
36#include "usbd_core.h"
37
53#define KEYBOARD_BCD_NUM 0x0110
54
58#define USBD_KEYBOARD_VENDOR_ID 0x2E3C
59#define USBD_KEYBOARD_PRODUCT_ID 0x6040
60
64#define USBD_KEYBOARD_CONFIG_DESC_SIZE 34
65#define USBD_KEYBOARD_SIZ_REPORT_DESC 63
66#define USBD_KEYBOARD_SIZ_STRING_LANGID 4
67#define USBD_KEYBOARD_SIZ_STRING_SERIAL 0x1A
68
72#define USBD_KEYBOARD_DESC_MANUFACTURER_STRING "Artery"
73#define USBD_KEYBOARD_DESC_PRODUCT_STRING "Keyboard"
74#define USBD_KEYBOARD_DESC_CONFIGURATION_STRING "Keyboard Config"
75#define USBD_KEYBOARD_DESC_INTERFACE_STRING "Keyboard Interface"
76
80#define KEYBOARD_BINTERVAL_TIME 0x0A
81
85#define MCU_ID1 (0x1FFFF7E8)
86#define MCU_ID2 (0x1FFFF7EC)
87#define MCU_ID3 (0x1FFFF7F0)
88
92extern uint8_t g_usbd_keyboard_report[USBD_KEYBOARD_SIZ_REPORT_DESC];
93extern uint8_t g_keyboard_usb_desc[9];
94extern usbd_desc_handler keyboard_desc_handler;
95
103#ifdef __cplusplus
104}
105#endif
106
107#endif
108
109
USBD_KEYBOARD_SIZ_REPORT_DESC
#define USBD_KEYBOARD_SIZ_REPORT_DESC
Definition: keyboard_desc.h:65
g_usbd_keyboard_report
uint8_t g_usbd_keyboard_report[63]
usb mouse report descriptor
Definition: keyboard_desc.c:159
g_keyboard_usb_desc
uint8_t g_keyboard_usb_desc[9]
usb hid descriptor
Definition: keyboard_desc.c:201
keyboard_desc_handler
usbd_desc_handler keyboard_desc_handler
keyboard device descriptor handler structure
Definition: keyboard_desc.c:63
keyboard_class.h
usb hid keyboard header file
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: main_page.h Source File

  • main_page
main_page.h
Go to the documentation of this file.
1


AT32F435/437 Firmwary Library: mouse_class.c Source File

  • middlewares
  • usbd_class
  • mouse
mouse_class.c
Go to the documentation of this file.
1
26#include "usbd_core.h"
27#include "mouse_class.h"
28#include "mouse_desc.h"
29
43static usb_sts_type class_init_handler(void *udev);
44static usb_sts_type class_clear_handler(void *udev);
45static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
46static usb_sts_type class_ept0_tx_handler(void *udev);
47static usb_sts_type class_ept0_rx_handler(void *udev);
48static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
49static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
50static usb_sts_type class_sof_handler(void *udev);
51static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
52
53 mouse_type mouse_struct;
54
55/* usb device class handler */
56usbd_class_handler mouse_class_handler =
57{
58 class_init_handler,
59 class_clear_handler,
60 class_setup_handler,
61 class_ept0_tx_handler,
62 class_ept0_rx_handler,
63 class_in_handler,
64 class_out_handler,
65 class_sof_handler,
66 class_event_handler,
67 &mouse_struct
68};
69
75static usb_sts_type class_init_handler(void *udev)
76{
77 usb_sts_type status = USB_OK;
78 usbd_core_type *pudev = (usbd_core_type *)udev;
79
80 /* open hid in endpoint */
81 usbd_ept_open(pudev, USBD_MOUSE_IN_EPT, EPT_INT_TYPE, USBD_MOUSE_IN_MAXPACKET_SIZE);
82
83 return status;
84}
85
91static usb_sts_type class_clear_handler(void *udev)
92{
93 usb_sts_type status = USB_OK;
94 usbd_core_type *pudev = (usbd_core_type *)udev;
95
96 /* close hid in endpoint */
97 usbd_ept_close(pudev, USBD_MOUSE_IN_EPT);
98
99 return status;
100}
101
108static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
109{
110 usb_sts_type status = USB_OK;
111 usbd_core_type *pudev = (usbd_core_type *)udev;
112 mouse_type *pmouse = (mouse_type *)pudev->class_handler->pdata;
113 uint16_t len;
114 uint8_t *buf;
115
116 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
117 {
118 /* class request */
119 case USB_REQ_TYPE_CLASS:
120 switch(setup->bRequest)
121 {
122 case HID_REQ_SET_PROTOCOL:
123 pmouse->hid_protocol = (uint8_t)setup->wValue;
124 break;
125 case HID_REQ_GET_PROTOCOL:
126 usbd_ctrl_send(pudev, (uint8_t *)&pmouse->hid_protocol, 1);
127 break;
128 case HID_REQ_SET_IDLE:
129 pmouse->hid_set_idle = (uint8_t)(setup->wValue >> 8);
130 break;
131 case HID_REQ_GET_IDLE:
132 usbd_ctrl_send(pudev, (uint8_t *)&pmouse->hid_set_idle, 1);
133 break;
134 case HID_REQ_SET_REPORT:
135 pmouse->hid_state = HID_REQ_SET_REPORT;
136 usbd_ctrl_recv(pudev, pmouse->hid_set_report, setup->wLength);
137 break;
138 default:
139 usbd_ctrl_unsupport(pudev);
140 break;
141 }
142 break;
143 /* standard request */
144 case USB_REQ_TYPE_STANDARD:
145 switch(setup->bRequest)
146 {
147 case USB_STD_REQ_GET_DESCRIPTOR:
148 if(setup->wValue >> 8 == HID_REPORT_DESC)
149 {
150 len = MIN(USBD_MOUSE_SIZ_REPORT_DESC, setup->wLength);
151 buf = (uint8_t *)g_usbd_mouse_report;
152 }
153 else if(setup->wValue >> 8 == HID_DESCRIPTOR_TYPE)
154 {
155 len = MIN(9, setup->wLength);
156 buf = (uint8_t *)g_mouse_usb_desc;
157 }
158 usbd_ctrl_send(pudev, (uint8_t *)buf, len);
159 break;
160 case USB_STD_REQ_GET_INTERFACE:
161 usbd_ctrl_send(pudev, (uint8_t *)&pmouse->alt_setting, 1);
162 break;
163 case USB_STD_REQ_SET_INTERFACE:
164 pmouse->alt_setting = setup->wValue;
165 break;
166 }
167 break;
168 default:
169 usbd_ctrl_unsupport(pudev);
170 break;
171 }
172 return status;
173}
174
180static usb_sts_type class_ept0_tx_handler(void *udev)
181{
182 usb_sts_type status = USB_OK;
183
184 /* ...user code... */
185
186 return status;
187}
188
194static usb_sts_type class_ept0_rx_handler(void *udev)
195{
196 usb_sts_type status = USB_OK;
197 usbd_core_type *pudev = (usbd_core_type *)udev;
198 mouse_type *pmouse = (mouse_type *)pudev->class_handler->pdata;
199 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
200 /* ...user code... */
201 if( pmouse->hid_state == HID_REQ_SET_REPORT)
202 {
203 /* hid buffer process */
204 pmouse->hid_state = 0;
205 }
206
207 return status;
208}
209
216static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
217{
218 usb_sts_type status = USB_OK;
219
220 /* ...user code...
221 trans next packet data
222 */
223
224 return status;
225}
226
233static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
234{
235 usb_sts_type status = USB_OK;
236
237 return status;
238}
239
245static usb_sts_type class_sof_handler(void *udev)
246{
247 usb_sts_type status = USB_OK;
248
249 /* ...user code... */
250
251 return status;
252}
253
260static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
261{
262 usb_sts_type status = USB_OK;
263 usbd_core_type *pudev = (usbd_core_type *)udev;
264 mouse_type *pmouse = (mouse_type *)pudev->class_handler->pdata;
265 switch(event)
266 {
267 case USBD_RESET_EVENT:
268
269 /* ...user code... */
270
271 break;
272 case USBD_SUSPEND_EVENT:
273 pmouse->hid_suspend_flag = 1;
274 /* ...user code... */
275
276 break;
277 case USBD_WAKEUP_EVENT:
278 /* ...user code... */
279
280 break;
281 default:
282 break;
283 }
284 return status;
285}
286
294 usb_sts_type usb_mouse_class_send_report(void *udev, uint8_t *report, uint16_t len)
295{
296 usb_sts_type status = USB_OK;
297 usbd_core_type *pudev = (usbd_core_type *)udev;
298
299 if(usbd_connect_state_get(pudev) == USB_CONN_STATE_CONFIGURED)
300 {
301 usbd_flush_tx_fifo(pudev, USBD_MOUSE_IN_EPT);
302 usbd_ept_send(pudev, USBD_MOUSE_IN_EPT, report, len);
303 }
304
305 return status;
306}
307
314void usb_hid_mouse_send(void *udev, uint8_t op)
315{
316 usbd_core_type *pudev = (usbd_core_type *)udev;
317 mouse_type *pmouse = (mouse_type *)pudev->class_handler->pdata;
318 int8_t posx = 0, posy = 0, button = 0;
319 switch(op)
320 {
321 case LEFT_BUTTON:
322 button = 0x01;
323 break;
324
325 case RIGHT_BUTTON:
326 button = 0x2;
327 break;
328
329 case UP_MOVE:
330 posy -= MOVE_STEP;
331 break;
332
333 case DOWN_MOVE:
334 posy += MOVE_STEP;
335 break;
336
337 case LEFT_MOVE:
338 posx -= MOVE_STEP;
339 break;
340
341 case RIGHT_MOVE:
342 posx += MOVE_STEP;
343 break;
344
345 default:
346 break;
347 }
348 pmouse->mouse_buffer[0] = button;
349 pmouse->mouse_buffer[1] = posx;
350 pmouse->mouse_buffer[2] = posy;
351
352 usb_mouse_class_send_report(udev, pmouse->mouse_buffer, 4);
353}
354
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f435_437_usb.h:349
USBD_MOUSE_IN_EPT
#define USBD_MOUSE_IN_EPT
usb hid use endpoint define
Definition: mouse_class.h:53
USBD_MOUSE_IN_MAXPACKET_SIZE
#define USBD_MOUSE_IN_MAXPACKET_SIZE
usb hid in and out max packet size define
Definition: mouse_class.h:58
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: mouse_class.c:245
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: mouse_class.c:216
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: mouse_class.c:91
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: mouse_class.c:108
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: mouse_class.c:180
usb_mouse_class_send_report
usb_sts_type usb_mouse_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: mouse_class.c:294
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: mouse_class.c:194
mouse_struct
mouse_type mouse_struct
Definition: mouse_class.c:53
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: mouse_class.c:260
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: mouse_class.c:75
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: mouse_class.c:233
mouse_class_handler
usbd_class_handler mouse_class_handler
Definition: mouse_class.c:56
usb_hid_mouse_send
void usb_hid_mouse_send(void *udev, uint8_t op)
usb device class report function
Definition: mouse_class.c:314
MOVE_STEP
#define MOVE_STEP
usb hid mouse operation
Definition: mouse_class.h:72
LEFT_MOVE
#define LEFT_MOVE
Definition: mouse_class.h:77
DOWN_MOVE
#define DOWN_MOVE
Definition: mouse_class.h:80
RIGHT_MOVE
#define RIGHT_MOVE
Definition: mouse_class.h:78
LEFT_BUTTON
#define LEFT_BUTTON
Definition: mouse_class.h:75
RIGHT_BUTTON
#define RIGHT_BUTTON
Definition: mouse_class.h:76
UP_MOVE
#define UP_MOVE
Definition: mouse_class.h:79
USBD_MOUSE_SIZ_REPORT_DESC
#define USBD_MOUSE_SIZ_REPORT_DESC
Definition: mouse_desc.h:65
g_usbd_mouse_report
uint8_t g_usbd_mouse_report[74]
usb mouse report descriptor
Definition: mouse_desc.c:159
g_mouse_usb_desc
uint8_t g_mouse_usb_desc[9]
usb hid descriptor
Definition: mouse_desc.c:215
HID_DESCRIPTOR_TYPE
#define HID_DESCRIPTOR_TYPE
Definition: usb_std.h:236
HID_REQ_GET_PROTOCOL
#define HID_REQ_GET_PROTOCOL
Definition: usb_std.h:231
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:254
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:63
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:81
HID_REQ_SET_PROTOCOL
#define HID_REQ_SET_PROTOCOL
usb hid class request code define
Definition: usb_std.h:230
HID_REPORT_DESC
#define HID_REPORT_DESC
Definition: usb_std.h:237
HID_REQ_SET_IDLE
#define HID_REQ_SET_IDLE
Definition: usb_std.h:232
HID_REQ_GET_IDLE
#define HID_REQ_GET_IDLE
Definition: usb_std.h:233
HID_REQ_SET_REPORT
#define HID_REQ_SET_REPORT
Definition: usb_std.h:234
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:86
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:66
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:85
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:64
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:131
USB_OK
@ USB_OK
Definition: usb_std.h:268
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:597
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:346
usbd_flush_tx_fifo
void usbd_flush_tx_fifo(usbd_core_type *udev, uint8_t ept_num)
usb device flush in endpoint fifo
Definition: usbd_core.c:650
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:314
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:177
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint send data
Definition: usbd_core.c:434
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
get endpoint receive data length
Definition: usbd_core.c:300
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint recv data
Definition: usbd_core.c:196
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:287
mouse_class.h
usb hid mouse header file
mouse_desc.h
usb mouse descriptor header file
mouse_type
Definition: mouse_class.h:83
mouse_type::hid_suspend_flag
__IO uint8_t hid_suspend_flag
Definition: mouse_class.h:91
mouse_type::hid_protocol
uint32_t hid_protocol
Definition: mouse_class.h:84
mouse_type::hid_set_idle
uint32_t hid_set_idle
Definition: mouse_class.h:85
mouse_type::mouse_buffer
uint8_t mouse_buffer[4]
Definition: mouse_class.h:89
mouse_type::hid_set_report
uint8_t hid_set_report[64]
Definition: mouse_class.h:88
mouse_type::alt_setting
uint32_t alt_setting
Definition: mouse_class.h:86
mouse_type::hid_state
uint8_t hid_state
Definition: mouse_class.h:90
usb_setup_type
format of usb setup data
Definition: usb_std.h:280
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:283
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:286
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:281
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:282
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: mouse_class.h Source File

  • middlewares
  • usbd_class
  • mouse
mouse_class.h
Go to the documentation of this file.
1
27 /* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __MOUSE_CLASS_H
29#define __MOUSE_CLASS_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "usb_std.h"
36#include "usbd_core.h"
37
53#define USBD_MOUSE_IN_EPT 0x81
54
58#define USBD_MOUSE_IN_MAXPACKET_SIZE 0x40
59
72#define MOVE_STEP 20
73
74#define BUTTON_RELEASE 0
75#define LEFT_BUTTON 1
76#define RIGHT_BUTTON 2
77#define LEFT_MOVE 3
78#define RIGHT_MOVE 4
79#define UP_MOVE 5
80#define DOWN_MOVE 6
81
82typedef struct
83{
84 uint32_t hid_protocol;
85 uint32_t hid_set_idle;
86 uint32_t alt_setting;
87
88 uint8_t hid_set_report[64];
89 uint8_t mouse_buffer[4];
90 uint8_t hid_state;
91 __IO uint8_t hid_suspend_flag;
92}mouse_type;
93
101extern usbd_class_handler mouse_class_handler;
102 usb_sts_type usb_mouse_class_send_report(void *udev, uint8_t *report, uint16_t len);
103void usb_hid_mouse_send(void *udev, uint8_t op);
115#ifdef __cplusplus
116}
117#endif
118
119#endif
usb_mouse_class_send_report
usb_sts_type usb_mouse_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: mouse_class.c:294
mouse_class_handler
usbd_class_handler mouse_class_handler
Definition: mouse_class.c:56
usb_hid_mouse_send
void usb_hid_mouse_send(void *udev, uint8_t op)
usb device class report function
Definition: mouse_class.c:314
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
mouse_type
Definition: mouse_class.h:83
mouse_type::hid_suspend_flag
__IO uint8_t hid_suspend_flag
Definition: mouse_class.h:91
mouse_type::hid_protocol
uint32_t hid_protocol
Definition: mouse_class.h:84
mouse_type::hid_set_idle
uint32_t hid_set_idle
Definition: mouse_class.h:85
mouse_type::alt_setting
uint32_t alt_setting
Definition: mouse_class.h:86
mouse_type::hid_state
uint8_t hid_state
Definition: mouse_class.h:90
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: mouse_desc.c Source File

  • middlewares
  • usbd_class
  • mouse
mouse_desc.c
Go to the documentation of this file.
1
26#include "usb_std.h"
27#include "usbd_sdr.h"
28#include "usbd_core.h"
29#include "mouse_desc.h"
30
44static usbd_desc_t *get_device_descriptor(void);
45static usbd_desc_t *get_device_qualifier(void);
46static usbd_desc_t *get_device_configuration(void);
47static usbd_desc_t *get_device_other_speed(void);
48static usbd_desc_t *get_device_lang_id(void);
49static usbd_desc_t *get_device_manufacturer_string(void);
50static usbd_desc_t *get_device_product_string(void);
51static usbd_desc_t *get_device_serial_string(void);
52static usbd_desc_t *get_device_interface_string(void);
53static usbd_desc_t *get_device_config_string(void);
54
55static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
56static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
57static void get_serial_num(void);
58static uint8_t g_usbd_desc_buffer[256];
59
63usbd_desc_handler mouse_desc_handler =
64{
65 get_device_descriptor,
66 get_device_qualifier,
67 get_device_configuration,
68 get_device_other_speed,
69 get_device_lang_id,
70 get_device_manufacturer_string,
71 get_device_product_string,
72 get_device_serial_string,
73 get_device_interface_string,
74 get_device_config_string,
75};
76
80#if defined ( __ICCARM__ ) /* iar compiler */
81 #pragma data_alignment=4
82#endif
83ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
84{
85 USB_DEVICE_DESC_LEN, /* bLength */
86 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
87 0x00, /* bcdUSB */
88 0x02,
89 0x00, /* bDeviceClass */
90 0x00, /* bDeviceSubClass */
91 0x00, /* bDeviceProtocol */
92 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
93 LBYTE(USBD_MOUSE_VENDOR_ID), /* idVendor */
94 HBYTE(USBD_MOUSE_VENDOR_ID), /* idVendor */
95 LBYTE(USBD_MOUSE_PRODUCT_ID), /* idProduct */
96 HBYTE(USBD_MOUSE_PRODUCT_ID), /* idProduct */
97 0x00, /* bcdDevice rel. 2.00 */
98 0x02,
99 USB_MFC_STRING, /* Index of manufacturer string */
100 USB_PRODUCT_STRING, /* Index of product string */
101 USB_SERIAL_STRING, /* Index of serial number string */
102 1 /* bNumConfigurations */
103};
104
108#if defined ( __ICCARM__ ) /* iar compiler */
109 #pragma data_alignment=4
110#endif
111ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_MOUSE_CONFIG_DESC_SIZE] ALIGNED_TAIL =
112{
113 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
114 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
115 LBYTE(USBD_MOUSE_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
116 HBYTE(USBD_MOUSE_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
117 0x01, /* bNumInterfaces: 1 interface */
118 0x01, /* bConfigurationValue: configuration value */
119 0x00, /* iConfiguration: index of string descriptor describing
120 the configuration */
121 0xE0, /* bmAttributes: self powered and support remote wakeup*/
122 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
123
124 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
125 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
126 0x00, /* bInterfaceNumber: number of interface */
127 0x00, /* bAlternateSetting: alternate set */
128 0x01, /* bNumEndpoints: number of endpoints */
129 USB_CLASS_CODE_HID, /* bInterfaceClass: class code hid */
130 0x01, /* bInterfaceSubClass: subclass code */
131 0x02, /* bInterfaceProtocol: protocol code */
132 0x00, /* iInterface: index of string descriptor */
133
134 0x09, /* bLength: size of HID descriptor in bytes */
135 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
136 LBYTE(MOUSE_BCD_NUM),
137 HBYTE(MOUSE_BCD_NUM), /* bcdHID: HID class specification release number */
138 0x00, /* bCountryCode: hardware target conutry */
139 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
140 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
141 LBYTE(sizeof(g_usbd_mouse_report)),
142 HBYTE(sizeof(g_usbd_mouse_report)), /* wDescriptorLength: total length of reprot descriptor */
143
144 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
145 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
146 USBD_MOUSE_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
147 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
148 LBYTE(USBD_MOUSE_IN_MAXPACKET_SIZE),
149 HBYTE(USBD_MOUSE_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
150 MOUSE_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
151};
152
156#if defined ( __ICCARM__ ) /* iar compiler */
157 #pragma data_alignment=4
158#endif
159ALIGNED_HEAD uint8_t g_usbd_mouse_report[USBD_MOUSE_SIZ_REPORT_DESC] ALIGNED_TAIL =
160{
161 0x05,0x01,
162 0x09,0x02,
163 0xA1,0x01,
164 0x09,0x01,
165
166 0xA1,0x00,
167 0x05,0x09,
168 0x19,0x01,
169 0x29,0x03,
170
171 0x15,0x00,
172 0x25,0x01,
173 0x95,0x03,
174 0x75,0x01,
175
176 0x81,0x02,
177 0x95,0x01,
178 0x75,0x05,
179 0x81,0x01,
180
181 0x05,0x01,
182 0x09,0x30,
183 0x09,0x31,
184 0x09,0x38,
185
186 0x15,0x81,
187 0x25,0x7F,
188 0x75,0x08,
189 0x95,0x03,
190
191 0x81,0x06,
192 0xC0,0x09,
193 0x3c,0x05,
194 0xff,0x09,
195
196 0x01,0x15,
197 0x00,0x25,
198 0x01,0x75,
199 0x01,0x95,
200
201 0x02,0xb1,
202 0x22,0x75,
203 0x06,0x95,
204 0x01,0xb1,
205
206 0x01,0xc0
207};
208
212#if defined ( __ICCARM__ ) /* iar compiler */
213 #pragma data_alignment=4
214#endif
215ALIGNED_HEAD uint8_t g_mouse_usb_desc[9] ALIGNED_TAIL =
216{
217 0x09, /* bLength: size of HID descriptor in bytes */
218 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
219 LBYTE(MOUSE_BCD_NUM),
220 HBYTE(MOUSE_BCD_NUM), /* bcdHID: HID class specification release number */
221 0x00, /* bCountryCode: hardware target conutry */
222 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
223 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
224 LBYTE(sizeof(g_usbd_mouse_report)),
225 HBYTE(sizeof(g_usbd_mouse_report)), /* wDescriptorLength: total length of reprot descriptor */
226};
227
228
232#if defined ( __ICCARM__ ) /* iar compiler */
233 #pragma data_alignment=4
234#endif
235ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_MOUSE_SIZ_STRING_LANGID] ALIGNED_TAIL =
236{
237 USBD_MOUSE_SIZ_STRING_LANGID,
238 USB_DESCIPTOR_TYPE_STRING,
239 0x09,
240 0x04,
241};
242
246#if defined ( __ICCARM__ ) /* iar compiler */
247 #pragma data_alignment=4
248#endif
249ALIGNED_HEAD static uint8_t g_string_serial[USBD_MOUSE_SIZ_STRING_SERIAL] ALIGNED_TAIL =
250{
251 USBD_MOUSE_SIZ_STRING_SERIAL,
252 USB_DESCIPTOR_TYPE_STRING,
253};
254
255
256/* device descriptor */
257static usbd_desc_t device_descriptor =
258{
259 USB_DEVICE_DESC_LEN,
260 g_usbd_descriptor
261};
262
263/* config descriptor */
264static usbd_desc_t config_descriptor =
265{
266 USBD_MOUSE_CONFIG_DESC_SIZE,
267 g_usbd_configuration
268};
269
270/* langid descriptor */
271static usbd_desc_t langid_descriptor =
272{
273 USBD_MOUSE_SIZ_STRING_LANGID,
274 g_string_lang_id
275};
276
277/* serial descriptor */
278static usbd_desc_t serial_descriptor =
279{
280 USBD_MOUSE_SIZ_STRING_SERIAL,
281 g_string_serial
282};
283
284static usbd_desc_t vp_desc;
285
292static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
293{
294 uint16_t str_len = 0, id_pos = 2;
295 uint8_t *tmp_str = string;
296
297 while(*tmp_str != '\0')
298 {
299 str_len ++;
300 unicode_buf[id_pos ++] = *tmp_str ++;
301 unicode_buf[id_pos ++] = 0x00;
302 }
303
304 str_len = str_len * 2 + 2;
305 unicode_buf[0] = str_len;
306 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
307
308 return str_len;
309}
310
318static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
319{
320 uint8_t idx = 0;
321
322 for( idx = 0 ; idx < len ; idx ++)
323 {
324 if( ((value >> 28)) < 0xA )
325 {
326 pbuf[ 2 * idx] = (value >> 28) + '0';
327 }
328 else
329 {
330 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
331 }
332
333 value = value << 4;
334
335 pbuf[2 * idx + 1] = 0;
336 }
337}
338
344static void get_serial_num(void)
345{
346 uint32_t serial0, serial1, serial2;
347
348 serial0 = *(uint32_t*)MCU_ID1;
349 serial1 = *(uint32_t*)MCU_ID2;
350 serial2 = *(uint32_t*)MCU_ID3;
351
352 serial0 += serial2;
353
354 if (serial0 != 0)
355 {
356 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
357 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
358 }
359}
360
366static usbd_desc_t *get_device_descriptor(void)
367{
368 return &device_descriptor;
369}
370
376static usbd_desc_t * get_device_qualifier(void)
377{
378 return NULL;
379}
380
386static usbd_desc_t *get_device_configuration(void)
387{
388 return &config_descriptor;
389}
390
396static usbd_desc_t *get_device_other_speed(void)
397{
398 return NULL;
399}
400
406static usbd_desc_t *get_device_lang_id(void)
407{
408 return &langid_descriptor;
409}
410
411
417static usbd_desc_t *get_device_manufacturer_string(void)
418{
419 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_MOUSE_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
420 vp_desc.descriptor = g_usbd_desc_buffer;
421 return &vp_desc;
422}
423
429static usbd_desc_t *get_device_product_string(void)
430{
431 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_MOUSE_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
432 vp_desc.descriptor = g_usbd_desc_buffer;
433 return &vp_desc;
434}
435
441static usbd_desc_t *get_device_serial_string(void)
442{
443 get_serial_num();
444 return &serial_descriptor;
445}
446
452static usbd_desc_t *get_device_interface_string(void)
453{
454 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_MOUSE_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
455 vp_desc.descriptor = g_usbd_desc_buffer;
456 return &vp_desc;
457}
458
464static usbd_desc_t *get_device_config_string(void)
465{
466 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_MOUSE_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
467 vp_desc.descriptor = g_usbd_desc_buffer;
468 return &vp_desc;
469}
470
idx
uint32_t idx
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:46
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:215
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:216
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:217
USBD_MOUSE_IN_EPT
#define USBD_MOUSE_IN_EPT
usb hid use endpoint define
Definition: mouse_class.h:53
USBD_MOUSE_IN_MAXPACKET_SIZE
#define USBD_MOUSE_IN_MAXPACKET_SIZE
usb hid in and out max packet size define
Definition: mouse_class.h:58
USBD_MOUSE_DESC_INTERFACE_STRING
#define USBD_MOUSE_DESC_INTERFACE_STRING
Definition: mouse_desc.h:75
USBD_MOUSE_SIZ_REPORT_DESC
#define USBD_MOUSE_SIZ_REPORT_DESC
Definition: mouse_desc.h:65
USBD_MOUSE_DESC_CONFIGURATION_STRING
#define USBD_MOUSE_DESC_CONFIGURATION_STRING
Definition: mouse_desc.h:74
USBD_MOUSE_SIZ_STRING_LANGID
#define USBD_MOUSE_SIZ_STRING_LANGID
Definition: mouse_desc.h:66
USBD_MOUSE_VENDOR_ID
#define USBD_MOUSE_VENDOR_ID
usb vendor id and product id define
Definition: mouse_desc.h:58
USBD_MOUSE_CONFIG_DESC_SIZE
#define USBD_MOUSE_CONFIG_DESC_SIZE
usb descriptor size define
Definition: mouse_desc.h:64
MOUSE_BINTERVAL_TIME
#define MOUSE_BINTERVAL_TIME
usb hid endpoint interval define
Definition: mouse_desc.h:80
USBD_MOUSE_PRODUCT_ID
#define USBD_MOUSE_PRODUCT_ID
Definition: mouse_desc.h:59
USBD_MOUSE_DESC_PRODUCT_STRING
#define USBD_MOUSE_DESC_PRODUCT_STRING
Definition: mouse_desc.h:73
USBD_MOUSE_SIZ_STRING_SERIAL
#define USBD_MOUSE_SIZ_STRING_SERIAL
Definition: mouse_desc.h:67
USBD_MOUSE_DESC_MANUFACTURER_STRING
#define USBD_MOUSE_DESC_MANUFACTURER_STRING
usb string define(vendor, product configuration, interface)
Definition: mouse_desc.h:72
MOUSE_BCD_NUM
#define MOUSE_BCD_NUM
usb bcd number define
Definition: mouse_desc.h:53
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: mouse_desc.c:278
device_descriptor
static usbd_desc_t device_descriptor
Definition: mouse_desc.c:257
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: mouse_desc.c:386
mouse_desc_handler
usbd_desc_handler mouse_desc_handler
mouse device descriptor handler structure
Definition: mouse_desc.c:63
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: mouse_desc.c:271
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: mouse_desc.c:366
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: mouse_desc.c:417
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: mouse_desc.c:376
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: mouse_desc.c:452
g_usbd_desc_buffer
static uint8_t g_usbd_desc_buffer[256]
Definition: mouse_desc.c:58
vp_desc
static usbd_desc_t vp_desc
Definition: mouse_desc.c:284
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: mouse_desc.c:396
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL
usb device standard descriptor
Definition: mouse_desc.c:83
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: mouse_desc.c:429
g_usbd_mouse_report
uint8_t g_usbd_mouse_report[74]
usb mouse report descriptor
Definition: mouse_desc.c:159
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: mouse_desc.c:464
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: mouse_desc.c:292
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: mouse_desc.c:406
g_mouse_usb_desc
uint8_t g_mouse_usb_desc[9]
usb hid descriptor
Definition: mouse_desc.c:215
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: mouse_desc.c:344
config_descriptor
static usbd_desc_t config_descriptor
Definition: mouse_desc.c:264
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: mouse_desc.c:441
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: mouse_desc.c:318
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:153
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:93
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: usb_std.h:223
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: usb_std.h:224
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:96
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:152
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:151
USB_EPT_DESC_INTERRUPT
#define USB_EPT_DESC_INTERRUPT
Definition: usb_std.h:178
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:94
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:95
USB_CLASS_CODE_HID
#define USB_CLASS_CODE_HID
Definition: usb_std.h:163
mouse_desc.h
usb mouse descriptor header file
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h


AT32F435/437 Firmwary Library: mouse_desc.h Source File

  • middlewares
  • usbd_class
  • mouse
mouse_desc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __MOUSE_DESC_H
29#define __MOUSE_DESC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "mouse_class.h"
36#include "usbd_core.h"
37
53#define MOUSE_BCD_NUM 0x0110
54
58#define USBD_MOUSE_VENDOR_ID 0x2E3C
59#define USBD_MOUSE_PRODUCT_ID 0x5710
60
64#define USBD_MOUSE_CONFIG_DESC_SIZE 34
65#define USBD_MOUSE_SIZ_REPORT_DESC 74
66#define USBD_MOUSE_SIZ_STRING_LANGID 4
67#define USBD_MOUSE_SIZ_STRING_SERIAL 0x1A
68
72#define USBD_MOUSE_DESC_MANUFACTURER_STRING "Artery"
73#define USBD_MOUSE_DESC_PRODUCT_STRING "Mouse"
74#define USBD_MOUSE_DESC_CONFIGURATION_STRING "Mouse Config"
75#define USBD_MOUSE_DESC_INTERFACE_STRING "Mouse Interface"
76
80#define MOUSE_BINTERVAL_TIME 0x0A
81
85#define MCU_ID1 (0x1FFFF7E8)
86#define MCU_ID2 (0x1FFFF7EC)
87#define MCU_ID3 (0x1FFFF7F0)
88
92extern uint8_t g_usbd_mouse_report[USBD_MOUSE_SIZ_REPORT_DESC];
93extern uint8_t g_mouse_usb_desc[9];
94extern usbd_desc_handler mouse_desc_handler;
95
103#ifdef __cplusplus
104}
105#endif
106
107#endif
108
109
USBD_MOUSE_SIZ_REPORT_DESC
#define USBD_MOUSE_SIZ_REPORT_DESC
Definition: mouse_desc.h:65
g_usbd_mouse_report
uint8_t g_usbd_mouse_report[74]
usb mouse report descriptor
Definition: mouse_desc.c:159
g_mouse_usb_desc
uint8_t g_mouse_usb_desc[9]
usb hid descriptor
Definition: mouse_desc.c:215
mouse_desc_handler
usbd_desc_handler mouse_desc_handler
mouse device descriptor handler structure
Definition: mouse_desc.c:63
mouse_class.h
usb hid mouse header file
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: mqtt_client.c File Reference

  • at_start_f437
  • examples
  • emac
  • mqtt_client
  • src
Functions | Variables
mqtt_client.c File Reference

mqtt client config program More...

#include "mqtt_client.h"
#include "string.h"
#include "at32f435_437_board.h"
#include "lwip/pbuf.h"
#include "lwip/apps/mqtt.h"
#include "lwip/apps/mqtt_priv.h"
#include "lwip/netif.h"

Go to the source code of this file.

Functions

__weak void | mqtt_conn_sub_proc (mqtt_client_t *client, void *arg)
mqtt connection subscription process More...
__weak void | mqtt_error_process_callback (mqtt_client_t *client, void *arg)
mqtt error process callback More...
static void | at32_mqtt_connection_cb (mqtt_client_t *client, void *arg, mqtt_connection_status_t status)
mqtt connection status callback More...
err_t | mqtt_client_init (void)
connect to mqtt server More...
static void | at32_mqtt_incoming_data_cb (void *arg, const u8_t *data, u16_t len, u8_t flags)
mqtt received data callback More...
static void | at32_mqtt_incoming_publish_cb (void *arg, const char *topic, u32_t tot_len)
mqtt received publish callback More...
static void | mqtt_client_pub_request_cb (void *arg, err_t result)
mqtt send data callback More...
err_t | at32_mqtt_publish (mqtt_client_t *client, char *pub_topic, char *pub_buf, uint16_t data_len, uint8_t qos, uint8_t retain)
mqtt send data to server More...
static void | at32_mqtt_request_cb (void *arg, err_t err)
mqtt request callback More...
static err_t | at32_mqtt_subscribe (mqtt_client_t *mqtt_client, char *sub_topic, uint8_t qos)
mqtt subscribe More...

Variables

mqtt_client_t * s__mqtt_client_instance

Detailed Description

mqtt client config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file mqtt_client.c.

Function Documentation

◆ at32_mqtt_connection_cb()

static void at32_mqtt_connection_cb | ( | mqtt_client_t * | client,
 |  | void * | arg,
 |  | mqtt_connection_status_t | status
 | ) |  |
static

mqtt connection status callback

Parameters
client | mqtt connection handle
arg | mqtt connection parameter point
status | mqtt connection status
Return values
none

Definition at line 77 of file mqtt_client.c.

Referenced by mqtt_client_init().

◆ at32_mqtt_incoming_data_cb()

static void at32_mqtt_incoming_data_cb | ( | void * | arg,
 |  | const u8_t * | data,
 |  | u16_t | len,
 |  | u8_t | flags
 | ) |  |
static

mqtt received data callback

Parameters
arg | mqtt connection parameter point
data | data
len | data length
flags | data flag
Return values
none

Definition at line 157 of file mqtt_client.c.

Referenced by at32_mqtt_connection_cb().

◆ at32_mqtt_incoming_publish_cb()

static void at32_mqtt_incoming_publish_cb | ( | void * | arg,
 |  | const char * | topic,
 |  | u32_t | tot_len
 | ) |  |
static

mqtt received publish callback

Parameters
arg | mqtt connection parameter point
topic | mqtt topic
tot_len | data total length
Return values
none

Definition at line 177 of file mqtt_client.c.

Referenced by at32_mqtt_connection_cb().

◆ at32_mqtt_request_cb()

static void at32_mqtt_request_cb | ( | void * | arg,
 |  | err_t | err
 | ) |  |
static

mqtt request callback

Parameters
arg | mqtt connection parameter point
err | error status
Return values
none

Definition at line 263 of file mqtt_client.c.

Referenced by at32_mqtt_subscribe().

◆ at32_mqtt_subscribe()

static err_t at32_mqtt_subscribe | ( | mqtt_client_t * | mqtt_client,
 |  | char * | sub_topic,
 |  | uint8_t | qos
 | ) |  |
static

mqtt subscribe

Parameters
client | mqtt connection handle
sub_topic | mqtt subscribe topic
qos£ºquality | of service, 0 1 or 2
Return values
subscribe status

Definition at line 292 of file mqtt_client.c.

Referenced by mqtt_conn_sub_proc().

◆ mqtt_client_pub_request_cb()

static void mqtt_client_pub_request_cb | ( | void * | arg,
 |  | err_t | result
 | ) |  |
static

mqtt send data callback

Parameters
arg | mqtt connection parameter point
result | send data result
Return values
none

Definition at line 195 of file mqtt_client.c.

Referenced by at32_mqtt_publish().


AT32F435/437 Firmwary Library: mqtt_client.c Source File

  • at_start_f437
  • examples
  • emac
  • mqtt_client
  • src
mqtt_client.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "mqtt_client.h"
29#include "string.h"
30#include "at32f435_437_board.h"
31#include "lwip/pbuf.h"
32#include "lwip/apps/mqtt.h"
33#include "lwip/apps/mqtt_priv.h"
34#include "lwip/netif.h"
35
44mqtt_client_t *s__mqtt_client_instance;
45
52__weak void mqtt_conn_sub_proc(mqtt_client_t *client, void *arg)
53{
54 /* topic name */
55 char test_sub_topic[] = "at_sub_topic";
56 at32_mqtt_subscribe(client, test_sub_topic, 0);
57}
58
65__weak void mqtt_error_process_callback(mqtt_client_t *client, void *arg)
66{
67 /* user code */
68}
69
77static void at32_mqtt_connection_cb(mqtt_client_t *client, void *arg, mqtt_connection_status_t status)
78{
79 if (client == NULL)
80 {
81 printf("at32_mqtt_connection_cb: condition error @entry\r\n");
82 return;
83 }
84
85 /* Successfully connected */
86 if (status == MQTT_CONNECT_ACCEPTED)
87 {
88 printf("at32_mqtt_connection_cb: Successfully connected\r\n");
89
90 mqtt_set_inpub_callback(client, at32_mqtt_incoming_publish_cb, at32_mqtt_incoming_data_cb, arg);
91
92 mqtt_conn_sub_proc(client, arg);
93 }
94 else
95 {
96 printf("at32_mqtt_connection_cb: Fail connected, status = %s\r\n", lwip_strerr(status));
97
98 mqtt_error_process_callback(client, arg);
99 }
100}
101
106err_t mqtt_client_init(void)
107{
108 err_t ret;
109 struct mqtt_connect_client_info_t mqtt_connect_info =
110 {
111
112 "AT_MQTT_Test",
113 NULL,
114 NULL,
115 60,
116 "at_pub_topic",
117 "Offline_pls_check",
118 0,
119 0
120 };
121
122 ip_addr_t server_ip;
123 /* mqtt server port */
124 uint16_t server_port = MQTT_SERVER_PORT;
125 /* mqtt server ip */
126 ip4_addr_set_u32(&server_ip, ipaddr_addr(MQTT_SERVER_ADDRESS));
127
128 printf("at32_mqtt_connect: Enter!\r\n");
129
130 if (s__mqtt_client_instance == NULL)
131 {
132 s__mqtt_client_instance = mqtt_client_new();
133 }
134
135 if (s__mqtt_client_instance == NULL)
136 {
137 printf("at32_mqtt_connect: s__mqtt_client_instance malloc fail @@!!!\r\n");
138 return ERR_MEM;
139 }
140
141 ret = mqtt_client_connect(s__mqtt_client_instance, &server_ip, server_port, \
142 at32_mqtt_connection_cb, NULL, &mqtt_connect_info);
143
144 printf("at32_mqtt_connect: connect to mqtt %s\r\n", lwip_strerr(ret));
145
146 return ret;
147}
148
157static void at32_mqtt_incoming_data_cb(void *arg, const u8_t *data, u16_t len, u8_t flags)
158{
159 if ((data == NULL) || (len == 0))
160 {
161 printf("mqtt_client_incoming_data_cb: condition error @entry\r\n");
162 return;
163 }
164
165 printf("recv_buffer = %s\r\n", data);
166
167 printf("mqtt_client_incoming_data_cb:reveiving incomming data.\r\n");
168}
169
177static void at32_mqtt_incoming_publish_cb(void *arg, const char *topic, u32_t tot_len)
178{
179 if ((topic == NULL) || (tot_len == 0))
180 {
181 printf("at32_mqtt_incoming_publish_cb: condition error @entry\r\n");
182 return;
183 }
184
185 printf("at32_mqtt_incoming_publish_cb: topic = %s.\r\n", topic);
186 printf("at32_mqtt_incoming_publish_cb: tot_len = %d.\r\n", tot_len);
187}
188
195static void mqtt_client_pub_request_cb(void *arg, err_t result)
196{
197 mqtt_client_t *client = (mqtt_client_t *)arg;
198
199 if (result != ERR_OK)
200 {
201 printf("mqtt_client_pub_request_cb: c002: Publish FAIL, result = %s\r\n", lwip_strerr(result));
202
203 mqtt_error_process_callback(client, arg);
204 }
205 else
206 {
207 printf("mqtt_client_pub_request_cb: c005: Publish complete!\r\n");
208 }
209}
210
221err_t at32_mqtt_publish(mqtt_client_t *client, char *pub_topic, char *pub_buf, uint16_t data_len, uint8_t qos, uint8_t retain)
222{
223 err_t err;
224
225 if ((client == NULL) || (pub_topic == NULL) || (pub_buf == NULL) || (data_len == 0) || (qos > 2) || (retain > 1))
226 {
227 printf("at32_mqtt_publish: input error@@");
228 return ERR_VAL;
229 }
230
231#ifdef USE_MQTT_MUTEX
232
233 if (s__mqtt_publish_mutex == NULL)
234 {
235 printf("at32_mqtt_publish: create mqtt mutex ! \r\n");
236 s__mqtt_publish_mutex = xSemaphoreCreateMutex();
237 }
238
239 if (xSemaphoreTake(s__mqtt_publish_mutex, portMAX_DELAY) == pdPASS)
240#endif /* USE_MQTT_MUTEX */
241 {
242 err = mqtt_publish(client, pub_topic, pub_buf, data_len, \
243 qos, retain, mqtt_client_pub_request_cb, (void *)client);
244 if(err != ERR_OK)
245 {
246 printf("at32_mqtt_publish: mqtt_publish err = %s\r\n", lwip_strerr(err));
247 }
248#ifdef USE_MQTT_MUTEX
249 printf("at32_mqtt_publish: mqtt_publish xSemaphoreTake\r\n");
250 xSemaphoreGive(s__mqtt_publish_mutex);
251#endif /* USE_MQTT_MUTEX */
252 }
253
254 return err;
255}
256
263static void at32_mqtt_request_cb(void *arg, err_t err)
264{
265 mqtt_client_t *client = (mqtt_client_t *)arg;
266
267 if (arg == NULL)
268 {
269 printf("at32_mqtt_request_cb: input error@@\r\n");
270 return;
271 }
272
273 if (err != ERR_OK)
274 {
275 printf("at32_mqtt_request_cb: FAIL sub, sub again, err = %s\r\n", lwip_strerr(err));
276
277 mqtt_error_process_callback(client, arg);
278 }
279 else
280 {
281 printf("at32_mqtt_request_cb: sub SUCCESS!\r\n");
282 }
283}
284
292static err_t at32_mqtt_subscribe(mqtt_client_t *mqtt_client, char *sub_topic, uint8_t qos)
293{
294 err_t err;
295 printf("at32_mqtt_subscribe: Enter\r\n");
296
297 if ((mqtt_client == NULL) || (sub_topic == NULL) || (qos > 2))
298 {
299 printf("at32_mqtt_subscribe: input error@@\r\n");
300 return ERR_VAL;
301 }
302
303 if (mqtt_client_is_connected(mqtt_client) != 1)
304 {
305 printf("at32_mqtt_subscribe: mqtt is not connected, return ERR_CLSD.\r\n");
306 return ERR_CLSD;
307 }
308
309 err = mqtt_subscribe(mqtt_client, sub_topic, qos, at32_mqtt_request_cb, (void *)mqtt_client);
310
311 if (err != ERR_OK)
312 {
313 printf("at32_mqtt_subscribe: mqtt_subscribe Fail, return:%s \r\n", lwip_strerr(err));
314 }
315 else
316 {
317 printf("at32_mqtt_subscribe: mqtt_subscribe SUCCESS, reason: %s\r\n", lwip_strerr(err));
318 }
319
320 return err;
321}
322
at32f435_437_board.h
MQTT_SERVER_PORT
#define MQTT_SERVER_PORT
Definition: mqtt_client.h:51
s__mqtt_client_instance
mqtt_client_t * s__mqtt_client_instance
Definition: mqtt_client.c:44
MQTT_SERVER_ADDRESS
#define MQTT_SERVER_ADDRESS
Definition: mqtt_client.h:50
mqtt_conn_sub_proc
__weak void mqtt_conn_sub_proc(mqtt_client_t *client, void *arg)
mqtt connection subscription process
Definition: mqtt_client.c:52
at32_mqtt_publish
err_t at32_mqtt_publish(mqtt_client_t *client, char *pub_topic, char *pub_buf, uint16_t data_len, uint8_t qos, uint8_t retain)
mqtt send data to server
Definition: mqtt_client.c:221
mqtt_client_init
err_t mqtt_client_init(void)
connect to mqtt server
Definition: mqtt_client.c:106
mqtt_error_process_callback
__weak void mqtt_error_process_callback(mqtt_client_t *client, void *arg)
mqtt error process callback
Definition: mqtt_client.c:65
data_len
uint16_t data_len
Definition: project/at_start_f435/examples/usb_device/virtual_comport/src/main.c:47
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
at32_mqtt_incoming_publish_cb
static void at32_mqtt_incoming_publish_cb(void *arg, const char *topic, u32_t tot_len)
mqtt received publish callback
Definition: mqtt_client.c:177
mqtt_client_pub_request_cb
static void mqtt_client_pub_request_cb(void *arg, err_t result)
mqtt send data callback
Definition: mqtt_client.c:195
at32_mqtt_request_cb
static void at32_mqtt_request_cb(void *arg, err_t err)
mqtt request callback
Definition: mqtt_client.c:263
at32_mqtt_subscribe
static err_t at32_mqtt_subscribe(mqtt_client_t *mqtt_client, char *sub_topic, uint8_t qos)
mqtt subscribe
Definition: mqtt_client.c:292
at32_mqtt_incoming_data_cb
static void at32_mqtt_incoming_data_cb(void *arg, const u8_t *data, u16_t len, u8_t flags)
mqtt received data callback
Definition: mqtt_client.c:157
at32_mqtt_connection_cb
static void at32_mqtt_connection_cb(mqtt_client_t *client, void *arg, mqtt_connection_status_t status)
mqtt connection status callback
Definition: mqtt_client.c:77
mqtt_client.h
mqtt client header


AT32F435/437 Firmwary Library: mqtt_client.h File Reference

  • at_start_f437
  • examples
  • emac
  • mqtt_client
  • inc
Macros | Functions
mqtt_client.h File Reference

mqtt client header More...

#include "lwip/pbuf.h"
#include "lwip/apps/mqtt.h"
#include "lwip/apps/mqtt_priv.h"
#include "lwip/netif.h"

Go to the source code of this file.

Macros

#define | MQTT_SERVER_ADDRESS "192.168.81.1"
#define | MQTT_SERVER_PORT 1883

Functions

err_t | mqtt_client_init (void)
connect to mqtt server More...
static void | at32_mqtt_connection_cb (mqtt_client_t *client, void *arg, mqtt_connection_status_t status)
static void | at32_mqtt_incoming_data_cb (void *arg, const u8_t *data, u16_t len, u8_t flags)
static void | at32_mqtt_incoming_publish_cb (void *arg, const char *topic, u32_t tot_len)
static void | mqtt_client_pub_request_cb (void *arg, err_t result)
err_t | at32_mqtt_publish (mqtt_client_t *client, char *pub_topic, char *pub_buf, uint16_t data_len, uint8_t qos, uint8_t retain)
mqtt send data to server More...
static void | at32_mqtt_request_cb (void *arg, err_t err)
static err_t | at32_mqtt_subscribe (mqtt_client_t *mqtt_client, char *sub_topic, uint8_t qos)

Detailed Description

mqtt client header

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file mqtt_client.h.


AT32F435/437 Firmwary Library: mqtt_client.h Source File

  • at_start_f437
  • examples
  • emac
  • mqtt_client
  • inc
mqtt_client.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef _MQTT_CLIENT_H_
29#define _MQTT_CLIENT_H_
30
31#ifdef __cplusplus
32 extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "lwip/pbuf.h"
37#include "lwip/apps/mqtt.h"
38#include "lwip/apps/mqtt_priv.h"
39#include "lwip/netif.h"
40
49/* mqtt server address and port configuration */
50#define MQTT_SERVER_ADDRESS "192.168.81.1"
51#define MQTT_SERVER_PORT 1883
52
53err_t mqtt_client_init(void);
54static void at32_mqtt_connection_cb(mqtt_client_t *client, void *arg, mqtt_connection_status_t status);
55static void at32_mqtt_incoming_data_cb(void *arg, const u8_t *data, u16_t len, u8_t flags);
56static void at32_mqtt_incoming_publish_cb(void *arg, const char *topic, u32_t tot_len);
57static void mqtt_client_pub_request_cb(void *arg, err_t result);
58err_t at32_mqtt_publish(mqtt_client_t *client, char *pub_topic, char *pub_buf, uint16_t data_len, uint8_t qos, uint8_t retain);
59static void at32_mqtt_request_cb(void *arg, err_t err);
60static err_t at32_mqtt_subscribe(mqtt_client_t *mqtt_client, char *sub_topic, uint8_t qos);
61
62
71#ifdef __cplusplus
72}
73#endif
74
75#endif
at32_mqtt_incoming_publish_cb
static void at32_mqtt_incoming_publish_cb(void *arg, const char *topic, u32_t tot_len)
mqtt_client_pub_request_cb
static void mqtt_client_pub_request_cb(void *arg, err_t result)
at32_mqtt_request_cb
static void at32_mqtt_request_cb(void *arg, err_t err)
at32_mqtt_subscribe
static err_t at32_mqtt_subscribe(mqtt_client_t *mqtt_client, char *sub_topic, uint8_t qos)
at32_mqtt_incoming_data_cb
static void at32_mqtt_incoming_data_cb(void *arg, const u8_t *data, u16_t len, u8_t flags)
at32_mqtt_publish
err_t at32_mqtt_publish(mqtt_client_t *client, char *pub_topic, char *pub_buf, uint16_t data_len, uint8_t qos, uint8_t retain)
mqtt send data to server
Definition: mqtt_client.c:221
at32_mqtt_connection_cb
static void at32_mqtt_connection_cb(mqtt_client_t *client, void *arg, mqtt_connection_status_t status)
mqtt_client_init
err_t mqtt_client_init(void)
connect to mqtt server
Definition: mqtt_client.c:106
data_len
uint16_t data_len
Definition: project/at_start_f435/examples/usb_device/virtual_comport/src/main.c:47
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43


AT32F435/437 Firmwary Library: msc_bot_scsi.c Source File

  • middlewares
  • usbd_class
  • msc
msc/msc_bot_scsi.c
Go to the documentation of this file.
1
26#include "msc_bot_scsi.h"
27#include "msc_diskio.h"
28
43#if defined ( __ICCARM__ ) /* iar compiler */
44 #pragma data_alignment=4
45#endif
46ALIGNED_HEAD uint8_t page00_inquiry_data[] ALIGNED_TAIL = {
47 0x00,
48 0x00,
49 0x00,
50 0x00,
51 0x00,
52
53};
54#if defined ( __ICCARM__ ) /* iar compiler */
55 #pragma data_alignment=4
56#endif
57ALIGNED_HEAD sense_type sense_data ALIGNED_TAIL =
58{
59 0x70,
60 0x00,
61 SENSE_KEY_ILLEGAL_REQUEST,
62 0x00000000,
63 0x0A,
64 0x00000000,
65 0x20,
66 0x00,
67 0x00000000
68};
69
70#if defined ( __ICCARM__ ) /* iar compiler */
71 #pragma data_alignment=4
72#endif
73ALIGNED_HEAD uint8_t mode_sense6_data[8] ALIGNED_TAIL =
74{
75 0x00,
76 0x00,
77 0x00,
78 0x00,
79 0x00,
80 0x00,
81 0x00,
82 0x00
83};
84
85#if defined ( __ICCARM__ ) /* iar compiler */
86 #pragma data_alignment=4
87#endif
88ALIGNED_HEAD uint8_t mode_sense10_data[8] ALIGNED_TAIL =
89{
90 0x00,
91 0x06,
92 0x00,
93 0x00,
94 0x00,
95 0x00,
96 0x00,
97 0x00
98};
104void bot_scsi_init(void *udev)
105{
106 usbd_core_type *pudev = (usbd_core_type *)udev;
107 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
108 pmsc->msc_state = MSC_STATE_MACHINE_IDLE;
109 pmsc->bot_status = MSC_BOT_STATE_IDLE;
110 pmsc->max_lun = MSC_SUPPORT_MAX_LUN - 1;
111
112 pmsc->csw_struct.dCSWSignature = CSW_DCSWSIGNATURE;
113 pmsc->csw_struct.dCSWDataResidue = 0;
114 pmsc->csw_struct.dCSWSignature = 0;
115 pmsc->csw_struct.dCSWTag = CSW_BCSWSTATUS_PASS;
116
117 usbd_flush_tx_fifo(pudev, USBD_MSC_BULK_IN_EPT&0x7F);
118
119 /* set out endpoint to receive status */
120 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT, (uint8_t *)&pmsc->cbw_struct, CBW_CMD_LENGTH);
121}
122
128void bot_scsi_reset(void *udev)
129{
130 usbd_core_type *pudev = (usbd_core_type *)udev;
131 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
132 pmsc->msc_state = MSC_STATE_MACHINE_IDLE;
133 pmsc->bot_status = MSC_BOT_STATE_RECOVERY;
134 pmsc->max_lun = MSC_SUPPORT_MAX_LUN - 1;
135 usbd_flush_tx_fifo(pudev, USBD_MSC_BULK_IN_EPT&0x7F);
136
137 /* set out endpoint to receive status */
138 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT, (uint8_t *)&pmsc->cbw_struct, CBW_CMD_LENGTH);
139}
140
147void bot_scsi_datain_handler(void *udev, uint8_t ept_num)
148{
149 usbd_core_type *pudev = (usbd_core_type *)udev;
150 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
151 switch(pmsc->msc_state)
152 {
153 case MSC_STATE_MACHINE_DATA_IN:
154 if(bot_scsi_cmd_process(udev) != USB_OK)
155 {
156 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_FAILED);
157 }
158 break;
159
160 case MSC_STATE_MACHINE_LAST_DATA:
161 case MSC_STATE_MACHINE_SEND_DATA:
162 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_PASS);
163 break;
164
165 default:
166 break;
167 }
168}
169
176void bot_scsi_dataout_handler(void *udev, uint8_t ept_num)
177{
178 usbd_core_type *pudev = (usbd_core_type *)udev;
179 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
180 switch(pmsc->msc_state)
181 {
182 case MSC_STATE_MACHINE_IDLE:
183 bot_cbw_decode(udev);
184 break;
185
186 case MSC_STATE_MACHINE_DATA_OUT:
187 if(bot_scsi_cmd_process(udev) != USB_OK)
188 {
189 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_FAILED);
190 }
191 break;
192 }
193}
194
200void bot_cbw_decode(void *udev)
201{
202 usbd_core_type *pudev = (usbd_core_type *)udev;
203 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
204
205 pmsc->csw_struct.dCSWTag = pmsc->cbw_struct.dCBWTage;
206 pmsc->csw_struct.dCSWDataResidue = pmsc->cbw_struct.dCBWDataTransferLength;
207
208 /* check param */
209 if((pmsc->cbw_struct.dCBWSignature != CBW_DCBWSIGNATURE) ||
210 (usbd_get_recv_len(pudev, USBD_MSC_BULK_OUT_EPT) != CBW_CMD_LENGTH)
211 || (pmsc->cbw_struct.bCBWLUN > MSC_SUPPORT_MAX_LUN) ||
212 (pmsc->cbw_struct.bCBWCBLength < 1) || (pmsc->cbw_struct.bCBWCBLength > 16))
213 {
214 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
215 pmsc->bot_status = MSC_BOT_STATE_ERROR;
216 bot_scsi_stall(udev);
217 }
218 else
219 {
220 if(bot_scsi_cmd_process(udev) != USB_OK)
221 {
222 bot_scsi_stall(udev);
223 }
224 else if((pmsc->msc_state != MSC_STATE_MACHINE_DATA_IN) &&
225 (pmsc->msc_state != MSC_STATE_MACHINE_DATA_OUT) &&
226 (pmsc->msc_state != MSC_STATE_MACHINE_LAST_DATA))
227 {
228 if(pmsc->data_len == 0)
229 {
230 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_PASS);
231 }
232 else if(pmsc->data_len > 0)
233 {
234 bot_scsi_send_data(udev, pmsc->data, pmsc->data_len);
235 }
236 }
237 }
238}
239
247void bot_scsi_send_data(void *udev, uint8_t *buffer, uint32_t len)
248{
249 usbd_core_type *pudev = (usbd_core_type *)udev;
250 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
251 uint32_t data_len = MIN(len, pmsc->cbw_struct.dCBWDataTransferLength);
252
253 pmsc->csw_struct.dCSWDataResidue -= data_len;
254 pmsc->csw_struct.bCSWStatus = CSW_BCSWSTATUS_PASS;
255
256 pmsc->msc_state = MSC_STATE_MACHINE_SEND_DATA;
257
258 usbd_ept_send(pudev, USBD_MSC_BULK_IN_EPT,
259 buffer, data_len);
260}
261
268void bot_scsi_send_csw(void *udev, uint8_t status)
269{
270 usbd_core_type *pudev = (usbd_core_type *)udev;
271 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
272
273 pmsc->csw_struct.bCSWStatus = status;
274 pmsc->csw_struct.dCSWSignature = CSW_DCSWSIGNATURE;
275 pmsc->msc_state = MSC_STATE_MACHINE_IDLE;
276
277 usbd_ept_send(pudev, USBD_MSC_BULK_IN_EPT,
278 (uint8_t *)&pmsc->csw_struct, CSW_CMD_LENGTH);
279
280 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT,
281 (uint8_t *)&pmsc->cbw_struct, CBW_CMD_LENGTH);
282}
283
284
292void bot_scsi_sense_code(void *udev, uint8_t sense_key, uint8_t asc)
293{
294 sense_data.sense_key = sense_key;
295 sense_data.asc = asc;
296}
297
298
307 usb_sts_type bot_scsi_check_address(void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
308{
309 usbd_core_type *pudev = (usbd_core_type *)udev;
310 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
311 if((blk_offset + blk_count) > pmsc->blk_nbr[lun])
312 {
313 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, ADDRESS_OUT_OF_RANGE);
314 return USB_FAIL;
315 }
316 return USB_OK;
317}
318
324void bot_scsi_stall(void *udev)
325{
326 usbd_core_type *pudev = (usbd_core_type *)udev;
327 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
328
329 if((pmsc->cbw_struct.dCBWDataTransferLength != 0) &&
330 (pmsc->cbw_struct.bmCBWFlags == 0) &&
331 pmsc->bot_status == MSC_BOT_STATE_IDLE)
332 {
333 usbd_set_stall(pudev, USBD_MSC_BULK_OUT_EPT);
334 }
335 usbd_set_stall(pudev, USBD_MSC_BULK_IN_EPT);
336
337 if(pmsc->bot_status == MSC_BOT_STATE_ERROR)
338 {
339 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT,
340 (uint8_t *)&pmsc->cbw_struct, CBW_CMD_LENGTH);
341 }
342}
343
350 usb_sts_type bot_scsi_test_unit(void *udev, uint8_t lun)
351{
352 usb_sts_type status = USB_OK;
353 usbd_core_type *pudev = (usbd_core_type *)udev;
354 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
355
356 if(pmsc->cbw_struct.dCBWDataTransferLength != 0)
357 {
358 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
359 return USB_FAIL;
360 }
361
362 pmsc->data_len = 0;
363 return status;
364}
365
372 usb_sts_type bot_scsi_inquiry(void *udev, uint8_t lun)
373{
374 uint8_t *pdata;
375 uint32_t trans_len = 0;
376 usb_sts_type status = USB_OK;
377 usbd_core_type *pudev = (usbd_core_type *)udev;
378 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
379
380 if(pmsc->cbw_struct.CBWCB[1] & 0x01)
381 {
382 pdata = page00_inquiry_data;
383 trans_len = 5;
384 }
385 else
386 {
387 pdata = get_inquiry(lun);
388 if(pmsc->cbw_struct.dCBWDataTransferLength < SCSI_INQUIRY_DATA_LENGTH)
389 {
390 trans_len = pmsc->cbw_struct.dCBWDataTransferLength;
391 }
392 else
393 {
394 trans_len = SCSI_INQUIRY_DATA_LENGTH;
395 }
396 }
397
398 pmsc->data_len = trans_len;
399 while(trans_len)
400 {
401 trans_len --;
402 pmsc->data[trans_len] = pdata[trans_len];
403 }
404 return status;
405}
406
413 usb_sts_type bot_scsi_start_stop(void *udev, uint8_t lun)
414{
415 usbd_core_type *pudev = (usbd_core_type *)udev;
416 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
417 pmsc->data_len = 0;
418 return USB_OK;
419}
420
427 usb_sts_type bot_scsi_allow_medium_removal(void *udev, uint8_t lun)
428{
429 usbd_core_type *pudev = (usbd_core_type *)udev;
430 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
431 pmsc->data_len = 0;
432 return USB_OK;
433}
434
441 usb_sts_type bot_scsi_mode_sense6(void *udev, uint8_t lun)
442{
443 uint8_t data_len = 8;
444 usbd_core_type *pudev = (usbd_core_type *)udev;
445 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
446 pmsc->data_len = 8;
447 while(data_len)
448 {
449 data_len --;
450 pmsc->data[data_len] = mode_sense6_data[data_len];
451 };
452 return USB_OK;
453}
454
461 usb_sts_type bot_scsi_mode_sense10(void *udev, uint8_t lun)
462{
463 uint8_t data_len = 8;
464 usbd_core_type *pudev = (usbd_core_type *)udev;
465 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
466 pmsc->data_len = 8;
467 while(data_len)
468 {
469 data_len --;
470 pmsc->data[data_len] = mode_sense10_data[data_len];
471 };
472 return USB_OK;
473}
474
481 usb_sts_type bot_scsi_capacity(void *udev, uint8_t lun)
482{
483 usbd_core_type *pudev = (usbd_core_type *)udev;
484 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
485 uint8_t *pdata = pmsc->data;
486 msc_disk_capacity(lun, &pmsc->blk_nbr[lun], &pmsc->blk_size[lun]);
487
488 pdata[0] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 24);
489 pdata[1] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 16);
490 pdata[2] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 8);
491 pdata[3] = (uint8_t)((pmsc->blk_nbr[lun] - 1));
492
493 pdata[4] = (uint8_t)((pmsc->blk_size[lun]) >> 24);
494 pdata[5] = (uint8_t)((pmsc->blk_size[lun]) >> 16);
495 pdata[6] = (uint8_t)((pmsc->blk_size[lun]) >> 8);
496 pdata[7] = (uint8_t)((pmsc->blk_size[lun]));
497
498 pmsc->data_len = 8;
499 return USB_OK;
500}
501
508 usb_sts_type bot_scsi_format_capacity(void *udev, uint8_t lun)
509{
510 usbd_core_type *pudev = (usbd_core_type *)udev;
511 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
512 uint8_t *pdata = pmsc->data;
513
514 pdata[0] = 0;
515 pdata[1] = 0;
516 pdata[2] = 0;
517 pdata[3] = 0x08;
518
519 msc_disk_capacity(lun, &pmsc->blk_nbr[lun], &pmsc->blk_size[lun]);
520
521 pdata[4] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 24);
522 pdata[5] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 16);
523 pdata[6] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 8);
524 pdata[7] = (uint8_t)((pmsc->blk_nbr[lun] - 1));
525
526 pdata[8] = 0x02;
527
528 pdata[9] = (uint8_t)((pmsc->blk_size[lun]) >> 16);
529 pdata[10] = (uint8_t)((pmsc->blk_size[lun]) >> 8);
530 pdata[11] = (uint8_t)((pmsc->blk_size[lun]));
531
532 pmsc->data_len = 12;
533
534 return USB_OK;
535}
536
543 usb_sts_type bot_scsi_request_sense(void *udev, uint8_t lun)
544{
545 uint32_t trans_len = 0x12;
546 usbd_core_type *pudev = (usbd_core_type *)udev;
547 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
548 uint8_t *pdata = pmsc->data;
549 uint8_t *sdata = (uint8_t *)&sense_data;
550
551 while(trans_len)
552 {
553 trans_len --;
554 pdata[trans_len] = sdata[trans_len];
555 }
556
557 if(pmsc->cbw_struct.dCBWDataTransferLength < REQ_SENSE_STANDARD_DATA_LEN)
558 {
559 pmsc->data_len = pmsc->cbw_struct.dCBWDataTransferLength;
560 }
561 else
562 {
563 pmsc->data_len = REQ_SENSE_STANDARD_DATA_LEN;
564 }
565 return USB_OK;
566}
567
574 usb_sts_type bot_scsi_verify(void *udev, uint8_t lun)
575{
576 usbd_core_type *pudev = (usbd_core_type *)udev;
577 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
578 uint8_t *cmd = pmsc->cbw_struct.CBWCB;
579 if((pmsc->cbw_struct.CBWCB[1] & 0x02) == 0x02)
580 {
581 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_FIELED_IN_COMMAND);
582 return USB_FAIL;
583 }
584
585 pmsc->blk_addr = cmd[2] << 24 | cmd[3] << 16 | cmd[4] << 8 | cmd[5];
586 pmsc->blk_len = cmd[7] << 8 | cmd[8];
587
588 if(bot_scsi_check_address(udev, lun, pmsc->blk_addr, pmsc->blk_len) != USB_OK)
589 {
590 return USB_FAIL;
591 }
592 pmsc->data_len = 0;
593 return USB_OK;
594}
595
602 usb_sts_type bot_scsi_read10(void *udev, uint8_t lun)
603{
604 usbd_core_type *pudev = (usbd_core_type *)udev;
605 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
606 uint8_t *cmd = pmsc->cbw_struct.CBWCB;
607 uint32_t len;
608
609 if(pmsc->msc_state == MSC_STATE_MACHINE_IDLE)
610 {
611 if((pmsc->cbw_struct.bmCBWFlags & 0x80) != 0x80)
612 {
613 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
614 return USB_FAIL;
615 }
616
617 pmsc->blk_addr = cmd[2] << 24 | cmd[3] << 16 | cmd[4] << 8 | cmd[5];
618 pmsc->blk_len = cmd[7] << 8 | cmd[8];
619
620 if(bot_scsi_check_address(udev, lun, pmsc->blk_addr, pmsc->blk_len) != USB_OK)
621 {
622 return USB_FAIL;
623 }
624
625 pmsc->blk_addr *= pmsc->blk_size[lun];
626 pmsc->blk_len *= pmsc->blk_size[lun];
627
628 if(pmsc->cbw_struct.dCBWDataTransferLength != pmsc->blk_len)
629 {
630 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
631 return USB_FAIL;
632 }
633 pmsc->msc_state = MSC_STATE_MACHINE_DATA_IN;
634 }
635 pmsc->data_len = MSC_MAX_DATA_BUF_LEN;
636
637 len = MIN(pmsc->blk_len, MSC_MAX_DATA_BUF_LEN);
638 if( msc_disk_read(lun, pmsc->blk_addr, pmsc->data, len) != USB_OK)
639 {
640 bot_scsi_sense_code(udev, SENSE_KEY_HARDWARE_ERROR, MEDIUM_NOT_PRESENT);
641 return USB_FAIL;
642 }
643 usbd_ept_send(pudev, USBD_MSC_BULK_IN_EPT, pmsc->data, len);
644 pmsc->blk_addr += len;
645 pmsc->blk_len -= len;
646
647 pmsc->csw_struct.dCSWDataResidue -= len;
648 if(pmsc->blk_len == 0)
649 {
650 pmsc->msc_state = MSC_STATE_MACHINE_LAST_DATA;
651 }
652
653 return USB_OK;
654}
655
656
663 usb_sts_type bot_scsi_write10(void *udev, uint8_t lun)
664{
665 usbd_core_type *pudev = (usbd_core_type *)udev;
666 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
667 uint8_t *cmd = pmsc->cbw_struct.CBWCB;
668 uint32_t len;
669
670 if(pmsc->msc_state == MSC_STATE_MACHINE_IDLE)
671 {
672 if((pmsc->cbw_struct.bmCBWFlags & 0x80) == 0x80)
673 {
674 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
675 return USB_FAIL;
676 }
677
678 pmsc->blk_addr = cmd[2] << 24 | cmd[3] << 16 | cmd[4] << 8 | cmd[5];
679 pmsc->blk_len = cmd[7] << 8 | cmd[8];
680
681 if(bot_scsi_check_address(udev, lun, pmsc->blk_addr, pmsc->blk_len) != USB_OK)
682 {
683 return USB_FAIL;
684 }
685
686 pmsc->blk_addr *= pmsc->blk_size[lun];
687 pmsc->blk_len *= pmsc->blk_size[lun];
688
689 if(pmsc->cbw_struct.dCBWDataTransferLength != pmsc->blk_len)
690 {
691 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
692 return USB_FAIL;
693 }
694
695 pmsc->msc_state = MSC_STATE_MACHINE_DATA_OUT;
696 len = MIN(pmsc->blk_len, MSC_MAX_DATA_BUF_LEN);
697 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT, (uint8_t *)pmsc->data, len);
698
699 }
700 else
701 {
702 len = MIN(pmsc->blk_len, MSC_MAX_DATA_BUF_LEN);
703 if(msc_disk_write(lun, pmsc->blk_addr, pmsc->data, len) != USB_OK)
704 {
705 bot_scsi_sense_code(udev, SENSE_KEY_HARDWARE_ERROR, MEDIUM_NOT_PRESENT);
706 return USB_FAIL;
707 }
708
709 pmsc->blk_addr += len;
710 pmsc->blk_len -= len;
711
712 pmsc->csw_struct.dCSWDataResidue -= len;
713
714 if(pmsc->blk_len == 0)
715 {
716 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_PASS);
717 }
718 else
719 {
720 len = MIN(pmsc->blk_len, MSC_MAX_DATA_BUF_LEN);
721 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT, (uint8_t *)pmsc->data, len);
722 }
723 }
724 return USB_OK;
725}
726
733void bot_scsi_clear_feature(void *udev, uint8_t ept_num)
734{
735 usbd_core_type *pudev = (usbd_core_type *)udev;
736 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
737 if(pmsc->bot_status == MSC_BOT_STATE_ERROR)
738 {
739 usbd_set_stall(pudev, USBD_MSC_BULK_IN_EPT);
740 pmsc->bot_status = MSC_BOT_STATE_IDLE;
741 }
742 else if(((ept_num & 0x80) == 0x80) && (pmsc->bot_status != MSC_BOT_STATE_RECOVERY))
743 {
744 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_FAILED);
745 }
746}
747
753 usb_sts_type bot_scsi_cmd_process(void *udev)
754{
755 usb_sts_type status = USB_FAIL;
756 usbd_core_type *pudev = (usbd_core_type *)udev;
757 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
758 switch(pmsc->cbw_struct.CBWCB[0])
759 {
760 case MSC_CMD_INQUIRY:
761 status = bot_scsi_inquiry(udev, pmsc->cbw_struct.bCBWLUN);
762 break;
763
764 case MSC_CMD_START_STOP:
765 status = bot_scsi_start_stop(udev, pmsc->cbw_struct.bCBWLUN);
766 break;
767
768 case MSC_CMD_MODE_SENSE6:
769 status = bot_scsi_mode_sense6(udev, pmsc->cbw_struct.bCBWLUN);
770 break;
771
772 case MSC_CMD_MODE_SENSE10:
773 status = bot_scsi_mode_sense10(udev, pmsc->cbw_struct.bCBWLUN);
774 break;
775
776 case MSC_CMD_ALLOW_MEDIUM_REMOVAL:
777 status = bot_scsi_allow_medium_removal(udev, pmsc->cbw_struct.bCBWLUN);
778 break;
779
780 case MSC_CMD_READ_10:
781 status = bot_scsi_read10(udev, pmsc->cbw_struct.bCBWLUN);
782 break;
783
784 case MSC_CMD_READ_CAPACITY:
785 status = bot_scsi_capacity(udev, pmsc->cbw_struct.bCBWLUN);
786 break;
787
788 case MSC_CMD_REQUEST_SENSE:
789 status = bot_scsi_request_sense(udev, pmsc->cbw_struct.bCBWLUN);
790 break;
791
792 case MSC_CMD_TEST_UNIT:
793 status = bot_scsi_test_unit(udev, pmsc->cbw_struct.bCBWLUN);
794 break;
795
796 case MSC_CMD_VERIFY:
797 status = bot_scsi_verify(udev, pmsc->cbw_struct.bCBWLUN);
798 break;
799
800 case MSC_CMD_WRITE_10:
801 status = bot_scsi_write10(udev, pmsc->cbw_struct.bCBWLUN);
802 break;
803
804 case MSC_CMD_READ_FORMAT_CAPACITY:
805 status = bot_scsi_format_capacity(udev, pmsc->cbw_struct.bCBWLUN);
806 break;
807
808 default:
809 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
810 status = USB_FAIL;
811 break;
812 }
813 return status;
814}
815
buffer
uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:43
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:106
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:75
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:144
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: at_start_f435/examples/usb_device/msc/src/msc_diskio.c:59
data_len
uint16_t data_len
Definition: project/at_start_f435/examples/usb_device/virtual_comport/src/main.c:47
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
cbw_type::bCBWLUN
uint8_t bCBWLUN
Definition: cdc_msc_class.h:194
msc_type::cbw_struct
cbw_type cbw_struct
Definition: cdc_msc_class.h:244
cbw_type::bCBWCBLength
uint8_t bCBWCBLength
Definition: cdc_msc_class.h:195
csw_type::dCSWSignature
uint32_t dCSWSignature
Definition: cdc_msc_class.h:204
cbw_type::CBWCB
uint8_t CBWCB[16]
Definition: cdc_msc_class.h:196
msc_type::blk_size
uint32_t blk_size[1]
Definition: cdc_msc_class.h:234
csw_type::bCSWStatus
uint32_t bCSWStatus
Definition: cdc_msc_class.h:207
csw_type::dCSWTag
uint32_t dCSWTag
Definition: cdc_msc_class.h:205
csw_type::dCSWDataResidue
uint32_t dCSWDataResidue
Definition: cdc_msc_class.h:206
msc_type::csw_struct
csw_type csw_struct
Definition: cdc_msc_class.h:245
msc_type::blk_len
uint32_t blk_len
Definition: cdc_msc_class.h:237
msc_type::data
uint8_t data[4096]
Definition: cdc_msc_class.h:240
msc_type::blk_addr
uint32_t blk_addr
Definition: cdc_msc_class.h:236
msc_type::max_lun
uint32_t max_lun
Definition: cdc_msc_class.h:231
msc_type::bot_status
uint8_t bot_status
Definition: cdc_msc_class.h:230
msc_type::msc_state
uint8_t msc_state
Definition: cdc_msc_class.h:229
cbw_type::dCBWDataTransferLength
uint32_t dCBWDataTransferLength
Definition: cdc_msc_class.h:192
msc_type::data_len
uint32_t data_len
Definition: cdc_msc_class.h:239
cbw_type::dCBWTage
uint32_t dCBWTage
Definition: cdc_msc_class.h:191
cbw_type::dCBWSignature
uint32_t dCBWSignature
Definition: cdc_msc_class.h:190
msc_type::blk_nbr
uint32_t blk_nbr[1]
Definition: cdc_msc_class.h:233
cbw_type::bmCBWFlags
uint8_t bmCBWFlags
Definition: cdc_msc_class.h:193
USBD_MSC_BULK_IN_EPT
#define USBD_MSC_BULK_IN_EPT
Definition: cdc_msc_class.h:57
USBD_MSC_BULK_OUT_EPT
#define USBD_MSC_BULK_OUT_EPT
Definition: cdc_msc_class.h:58
bot_scsi_format_capacity
usb_sts_type bot_scsi_format_capacity(void *udev, uint8_t lun)
bulk-only transport scsi command format capacity
Definition: msc/msc_bot_scsi.c:508
bot_scsi_datain_handler
void bot_scsi_datain_handler(void *pudev, uint8_t ept_num)
bulk-only transport data in handler
Definition: msc/msc_bot_scsi.c:147
bot_scsi_start_stop
usb_sts_type bot_scsi_start_stop(void *udev, uint8_t lun)
bulk-only transport scsi command start stop
Definition: msc/msc_bot_scsi.c:413
bot_scsi_request_sense
usb_sts_type bot_scsi_request_sense(void *udev, uint8_t lun)
bulk-only transport scsi command request sense
Definition: msc/msc_bot_scsi.c:543
bot_scsi_read10
usb_sts_type bot_scsi_read10(void *udev, uint8_t lun)
bulk-only transport scsi command read10
Definition: msc/msc_bot_scsi.c:602
bot_scsi_check_address
usb_sts_type bot_scsi_check_address(void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address
Definition: msc/msc_bot_scsi.c:307
bot_scsi_write10
usb_sts_type bot_scsi_write10(void *udev, uint8_t lun)
bulk-only transport scsi command write10
Definition: msc/msc_bot_scsi.c:663
bot_scsi_reset
void bot_scsi_reset(void *udev)
reset bulk-only transport and scsi
Definition: msc/msc_bot_scsi.c:128
bot_scsi_mode_sense10
usb_sts_type bot_scsi_mode_sense10(void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10
Definition: msc/msc_bot_scsi.c:461
bot_scsi_sense_code
void bot_scsi_sense_code(void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code
Definition: msc/msc_bot_scsi.c:292
bot_cbw_decode
void bot_cbw_decode(void *udev)
bulk-only cbw decode
Definition: msc/msc_bot_scsi.c:200
bot_scsi_verify
usb_sts_type bot_scsi_verify(void *udev, uint8_t lun)
bulk-only transport scsi command verify
Definition: msc/msc_bot_scsi.c:574
bot_scsi_allow_medium_removal
usb_sts_type bot_scsi_allow_medium_removal(void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal
Definition: msc/msc_bot_scsi.c:427
bot_scsi_init
void bot_scsi_init(void *udev)
initialize bulk-only transport and scsi
Definition: msc/msc_bot_scsi.c:104
bot_scsi_cmd_process
usb_sts_type bot_scsi_cmd_process(void *udev)
bulk-only transport scsi command process
Definition: msc/msc_bot_scsi.c:753
bot_scsi_dataout_handler
void bot_scsi_dataout_handler(void *pudev, uint8_t ept_num)
bulk-only transport data out handler
Definition: msc/msc_bot_scsi.c:176
bot_scsi_mode_sense6
usb_sts_type bot_scsi_mode_sense6(void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6
Definition: msc/msc_bot_scsi.c:441
bot_scsi_stall
void bot_scsi_stall(void *udev)
bot endpoint stall
Definition: msc/msc_bot_scsi.c:324
bot_scsi_send_data
void bot_scsi_send_data(void *udev, uint8_t *buffer, uint32_t len)
send bot data
Definition: msc/msc_bot_scsi.c:247
bot_scsi_test_unit
usb_sts_type bot_scsi_test_unit(void *udev, uint8_t lun)
bulk-only transport scsi command test unit
Definition: msc/msc_bot_scsi.c:350
bot_scsi_inquiry
usb_sts_type bot_scsi_inquiry(void *udev, uint8_t lun)
bulk-only transport scsi command inquiry
Definition: msc/msc_bot_scsi.c:372
bot_scsi_capacity
usb_sts_type bot_scsi_capacity(void *udev, uint8_t lun)
bulk-only transport scsi command capacity
Definition: msc/msc_bot_scsi.c:481
bot_scsi_clear_feature
void bot_scsi_clear_feature(void *udev, uint8_t ept_num)
clear feature
Definition: msc/msc_bot_scsi.c:733
bot_scsi_send_csw
void bot_scsi_send_csw(void *udev, uint8_t status)
send command status
Definition: msc/msc_bot_scsi.c:268
ALIGNED_TAIL
ALIGNED_HEAD uint8_t page00_inquiry_data[] ALIGNED_TAIL
Definition: msc/msc_bot_scsi.c:46
MSC_STATE_MACHINE_DATA_IN
#define MSC_STATE_MACHINE_DATA_IN
Definition: cdc_msc_class.h:121
MSC_CMD_START_STOP
#define MSC_CMD_START_STOP
Definition: cdc_msc_class.h:88
MSC_CMD_VERIFY
#define MSC_CMD_VERIFY
Definition: cdc_msc_class.h:98
ADDRESS_OUT_OF_RANGE
#define ADDRESS_OUT_OF_RANGE
Definition: cdc_msc_class.h:153
SENSE_KEY_HARDWARE_ERROR
#define SENSE_KEY_HARDWARE_ERROR
Definition: cdc_msc_class.h:138
MEDIUM_NOT_PRESENT
#define MEDIUM_NOT_PRESENT
Definition: cdc_msc_class.h:154
MSC_CMD_MODE_SENSE6
#define MSC_CMD_MODE_SENSE6
Definition: cdc_msc_class.h:89
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:157
MSC_CMD_ALLOW_MEDIUM_REMOVAL
#define MSC_CMD_ALLOW_MEDIUM_REMOVAL
Definition: cdc_msc_class.h:91
CSW_CMD_LENGTH
#define CSW_CMD_LENGTH
Definition: cdc_msc_class.h:114
MSC_BOT_STATE_IDLE
#define MSC_BOT_STATE_IDLE
Definition: cdc_msc_class.h:129
MSC_MAX_DATA_BUF_LEN
#define MSC_MAX_DATA_BUF_LEN
Definition: cdc_msc_class.h:84
CSW_DCSWSIGNATURE
#define CSW_DCSWSIGNATURE
Definition: cdc_msc_class.h:115
MSC_CMD_INQUIRY
#define MSC_CMD_INQUIRY
Definition: cdc_msc_class.h:87
MSC_SUPPORT_MAX_LUN
#define MSC_SUPPORT_MAX_LUN
Definition: cdc_msc_class.h:83
INVALID_COMMAND
#define INVALID_COMMAND
Definition: cdc_msc_class.h:149
MSC_CMD_WRITE_10
#define MSC_CMD_WRITE_10
Definition: cdc_msc_class.h:99
MSC_STATE_MACHINE_IDLE
#define MSC_STATE_MACHINE_IDLE
Definition: cdc_msc_class.h:127
MSC_CMD_READ_FORMAT_CAPACITY
#define MSC_CMD_READ_FORMAT_CAPACITY
Definition: cdc_msc_class.h:95
MSC_CMD_MODE_SENSE10
#define MSC_CMD_MODE_SENSE10
Definition: cdc_msc_class.h:90
SENSE_KEY_ILLEGAL_REQUEST
#define SENSE_KEY_ILLEGAL_REQUEST
Definition: cdc_msc_class.h:139
MSC_STATE_MACHINE_DATA_OUT
#define MSC_STATE_MACHINE_DATA_OUT
Definition: cdc_msc_class.h:122
CSW_BCSWSTATUS_PASS
#define CSW_BCSWSTATUS_PASS
Definition: cdc_msc_class.h:116
INVALID_FIELED_IN_COMMAND
#define INVALID_FIELED_IN_COMMAND
Definition: cdc_msc_class.h:150
REQ_SENSE_STANDARD_DATA_LEN
#define REQ_SENSE_STANDARD_DATA_LEN
Definition: cdc_msc_class.h:133
MSC_STATE_MACHINE_SEND_DATA
#define MSC_STATE_MACHINE_SEND_DATA
Definition: cdc_msc_class.h:123
CBW_DCBWSIGNATURE
#define CBW_DCBWSIGNATURE
Definition: cdc_msc_class.h:110
MSC_CMD_READ_10
#define MSC_CMD_READ_10
Definition: cdc_msc_class.h:92
MSC_BOT_STATE_RECOVERY
#define MSC_BOT_STATE_RECOVERY
Definition: cdc_msc_class.h:130
CBW_CMD_LENGTH
#define CBW_CMD_LENGTH
Definition: cdc_msc_class.h:109
MSC_STATE_MACHINE_LAST_DATA
#define MSC_STATE_MACHINE_LAST_DATA
Definition: cdc_msc_class.h:124
MSC_CMD_TEST_UNIT
#define MSC_CMD_TEST_UNIT
Definition: cdc_msc_class.h:97
CSW_BCSWSTATUS_FAILED
#define CSW_BCSWSTATUS_FAILED
Definition: cdc_msc_class.h:117
MSC_CMD_READ_CAPACITY
#define MSC_CMD_READ_CAPACITY
Definition: cdc_msc_class.h:94
MSC_BOT_STATE_ERROR
#define MSC_BOT_STATE_ERROR
Definition: cdc_msc_class.h:131
MSC_CMD_REQUEST_SENSE
#define MSC_CMD_REQUEST_SENSE
Definition: cdc_msc_class.h:96
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:254
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_OK
@ USB_OK
Definition: usb_std.h:268
USB_FAIL
@ USB_FAIL
Definition: usb_std.h:269
usbd_set_stall
void usbd_set_stall(usbd_core_type *udev, uint8_t ept_addr)
usb set endpoint to stall status
Definition: usbd_core.c:262
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint receive data
Definition: usbd_core.c:534
usbd_flush_tx_fifo
void usbd_flush_tx_fifo(usbd_core_type *udev, uint8_t ept_num)
usb device flush in endpoint fifo
Definition: usbd_core.c:650
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint send data
Definition: usbd_core.c:434
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
get endpoint receive data length
Definition: usbd_core.c:300
msc_bot_scsi.h
usb mass storage bulk-only transport and scsi command header file
msc_type
Definition: cdc_msc_class.h:228
sense_type
request sense standard data
Definition: cdc_msc_class.h:214


AT32F435/437 Firmwary Library: msc_bot_scsi.h Source File

  • middlewares
  • usbd_class
  • msc
msc_bot_scsi.h
Go to the documentation of this file.
1
26/* define to prevent recursive inclusion -------------------------------------*/
27#ifndef __MSC_BOT_SCSI_H
28#define __MSC_BOT_SCSI_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "msc_class.h"
35#include "usbd_core.h"
36
49#define MSC_SUPPORT_MAX_LUN 1
50#define MSC_MAX_DATA_BUF_LEN 4096
51
52#define MSC_CMD_FORMAT_UNIT 0x04
53#define MSC_CMD_INQUIRY 0x12
54#define MSC_CMD_START_STOP 0x1B
55#define MSC_CMD_MODE_SENSE6 0x1A
56#define MSC_CMD_MODE_SENSE10 0x5A
57#define MSC_CMD_ALLOW_MEDIUM_REMOVAL 0x1E
58#define MSC_CMD_READ_10 0x28
59#define MSC_CMD_READ_12 0xA8
60#define MSC_CMD_READ_CAPACITY 0x25
61#define MSC_CMD_READ_FORMAT_CAPACITY 0x23
62#define MSC_CMD_REQUEST_SENSE 0x03
63#define MSC_CMD_TEST_UNIT 0x00
64#define MSC_CMD_VERIFY 0x2F
65#define MSC_CMD_WRITE_10 0x2A
66#define MSC_CMD_WRITE_12 0xAA
67#define MSC_CMD_WRITE_VERIFY 0x2E
68
69#define MSC_REQ_GET_MAX_LUN 0xFE
70#define MSC_REQ_BO_RESET 0xFF
72#define SET_LINE_CODING 0x20
73#define GET_LINE_CODING 0x21
74
75#define CBW_CMD_LENGTH 31
76#define CBW_DCBWSIGNATURE 0x43425355
77#define CBW_BMCBWFLAGS_DIR_OUT 0x00
78#define CBW_BMCBWFLAGS_DIR_IN 0x80
79
80#define CSW_CMD_LENGTH 13
81#define CSW_DCSWSIGNATURE 0x53425355
82#define CSW_BCSWSTATUS_PASS 0x00
83#define CSW_BCSWSTATUS_FAILED 0x01
84#define CSW_BCSWSTATUS_PHASE_ERR 0x02
85
86#define MSC_STATE_MACHINE_CMD 0x00
87#define MSC_STATE_MACHINE_DATA_IN 0x01
88#define MSC_STATE_MACHINE_DATA_OUT 0x02
89#define MSC_STATE_MACHINE_SEND_DATA 0x03
90#define MSC_STATE_MACHINE_LAST_DATA 0x04
91#define MSC_STATE_MACHINE_STATUS 0x05
92#define MSC_STATE_MACHINE_FAILED 0x06
93#define MSC_STATE_MACHINE_IDLE 0x07
94
95#define MSC_BOT_STATE_IDLE 0x00
96#define MSC_BOT_STATE_RECOVERY 0x01
97#define MSC_BOT_STATE_ERROR 0x02
98
99#define REQ_SENSE_STANDARD_DATA_LEN 0x12
100#define SENSE_KEY_NO_SENSE 0x00
101#define SENSE_KEY_RECOVERED_ERROR 0x01
102#define SENSE_KEY_NOT_READY 0x02
103#define SENSE_KEY_MEDIUM_ERROR 0x03
104#define SENSE_KEY_HARDWARE_ERROR 0x04
105#define SENSE_KEY_ILLEGAL_REQUEST 0x05
106#define SENSE_KEY_UNIT_ATTENTION 0x06
107#define SENSE_KEY_DATA_PROTECT 0x07
108#define SENSE_KEY_BLANK_CHECK 0x08
109#define SENSE_KEY_VENDERO_SPECIFIC 0x09
110#define SENSE_KEY_ABORTED_COMMAND 0x0B
111#define SENSE_KEY_VOLUME_OVERFLOW 0x0D
112#define SENSE_KEY_MISCOMPARE 0x0E
113
114
115#define INVALID_COMMAND 0x20
116#define INVALID_FIELED_IN_COMMAND 0x24
117#define PARAMETER_LIST_LENGTH_ERROR 0x1A
118#define INVALID_FIELD_IN_PARAMETER_LIST 0x26
119#define ADDRESS_OUT_OF_RANGE 0x21
120#define MEDIUM_NOT_PRESENT 0x3A
121#define MEDIUM_HAVE_CHANGED 0x28
122
123#define SCSI_INQUIRY_DATA_LENGTH 36
124
128typedef struct
129{
130 uint8_t opcode;
131 uint8_t lun;
132 uint32_t address;
133 uint8_t reserved1;
134 uint32_t alloc_length;
135 uint16_t reserved2;
136}cbd_typical_type;
137
141typedef struct
142{
143 uint8_t opcode;
144 uint8_t lun;
145 uint32_t address;
146 uint8_t reserved1;
147 uint32_t alloc_length;
148 uint16_t reserved2;
149}cbd_extended_type;
150
154typedef struct
155{
156 uint32_t dCBWSignature;
157 uint32_t dCBWTage;
158 uint32_t dCBWDataTransferLength;
159 uint8_t bmCBWFlags;
160 uint8_t bCBWLUN;
161 uint8_t bCBWCBLength;
162 uint8_t CBWCB[16];
163}cbw_type;
164
168typedef struct
169{
170 uint32_t dCSWSignature;
171 uint32_t dCSWTag;
172 uint32_t dCSWDataResidue;
173 uint32_t bCSWStatus;
174}csw_type;
175
179typedef struct
180{
181 uint8_t err_code;
182 uint8_t reserved1;
183 uint8_t sense_key;
184 uint32_t information;
185 uint8_t as_length;
186 uint32_t reserved2;
187 uint8_t asc;
188 uint8_t ascq;
189 uint32_t reserved3;
190}sense_type;
191
192
193typedef struct
194{
195 uint8_t msc_state;
196 uint8_t bot_status;
197 uint32_t max_lun;
198
199 uint32_t blk_nbr[MSC_SUPPORT_MAX_LUN];
200 uint32_t blk_size[MSC_SUPPORT_MAX_LUN];
201
202 uint32_t blk_addr;
203 uint32_t blk_len;
204
205 uint32_t data_len;
206 uint8_t data[MSC_MAX_DATA_BUF_LEN];
207
208 uint32_t alt_setting;
209
210 cbw_type cbw_struct;
211 csw_type csw_struct;
212
213}msc_type;
214
215void bot_scsi_init(void *udev);
216void bot_scsi_reset(void *udev);
217void bot_scsi_datain_handler(void *pudev, uint8_t ept_num);
218void bot_scsi_dataout_handler(void *pudev, uint8_t ept_num);
219void bot_cbw_decode(void *udev);
220void bot_scsi_send_data(void *udev, uint8_t *buffer, uint32_t len);
221void bot_scsi_send_csw(void *udev, uint8_t status);
222void bot_scsi_sense_code(void *udev, uint8_t sense_key, uint8_t asc);
223 usb_sts_type bot_scsi_check_address(void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count);
224void bot_scsi_stall(void *udev);
225 usb_sts_type bot_scsi_cmd_process(void *udev);
226
227 usb_sts_type bot_scsi_test_unit(void *udev, uint8_t lun);
228 usb_sts_type bot_scsi_inquiry(void *udev, uint8_t lun);
229 usb_sts_type bot_scsi_start_stop(void *udev, uint8_t lun);
230 usb_sts_type bot_scsi_allow_medium_removal(void *udev, uint8_t lun);
231 usb_sts_type bot_scsi_mode_sense6(void *udev, uint8_t lun);
232 usb_sts_type bot_scsi_mode_sense10(void *udev, uint8_t lun);
233 usb_sts_type bot_scsi_read10(void *udev, uint8_t lun);
234 usb_sts_type bot_scsi_capacity(void *udev, uint8_t lun);
235 usb_sts_type bot_scsi_format_capacity(void *udev, uint8_t lun);
236 usb_sts_type bot_scsi_request_sense(void *udev, uint8_t lun);
237 usb_sts_type bot_scsi_verify(void *udev, uint8_t lun);
238 usb_sts_type bot_scsi_write10(void *udev, uint8_t lun);
239void bot_scsi_clear_feature(void *udev, uint8_t ept_num);
240
252#ifdef __cplusplus
253}
254#endif
255
256#endif
buffer
uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:43
data_len
uint16_t data_len
Definition: project/at_start_f435/examples/usb_device/virtual_comport/src/main.c:47
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
bot_scsi_format_capacity
usb_sts_type bot_scsi_format_capacity(void *udev, uint8_t lun)
bulk-only transport scsi command format capacity
Definition: composite_cdc_msc/msc_bot_scsi.c:508
bot_scsi_start_stop
usb_sts_type bot_scsi_start_stop(void *udev, uint8_t lun)
bulk-only transport scsi command start stop
Definition: composite_cdc_msc/msc_bot_scsi.c:413
bot_scsi_request_sense
usb_sts_type bot_scsi_request_sense(void *udev, uint8_t lun)
bulk-only transport scsi command request sense
Definition: composite_cdc_msc/msc_bot_scsi.c:543
bot_scsi_dataout_handler
void bot_scsi_dataout_handler(void *pudev, uint8_t ept_num)
bulk-only transport data out handler
Definition: composite_cdc_msc/msc_bot_scsi.c:176
MSC_MAX_DATA_BUF_LEN
#define MSC_MAX_DATA_BUF_LEN
Definition: msc_bot_scsi.h:50
bot_scsi_read10
usb_sts_type bot_scsi_read10(void *udev, uint8_t lun)
bulk-only transport scsi command read10
Definition: composite_cdc_msc/msc_bot_scsi.c:602
bot_scsi_check_address
usb_sts_type bot_scsi_check_address(void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address
Definition: composite_cdc_msc/msc_bot_scsi.c:307
MSC_SUPPORT_MAX_LUN
#define MSC_SUPPORT_MAX_LUN
Definition: msc_bot_scsi.h:49
bot_scsi_write10
usb_sts_type bot_scsi_write10(void *udev, uint8_t lun)
bulk-only transport scsi command write10
Definition: composite_cdc_msc/msc_bot_scsi.c:663
bot_scsi_reset
void bot_scsi_reset(void *udev)
reset bulk-only transport and scsi
Definition: composite_cdc_msc/msc_bot_scsi.c:128
bot_scsi_mode_sense10
usb_sts_type bot_scsi_mode_sense10(void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10
Definition: composite_cdc_msc/msc_bot_scsi.c:461
bot_scsi_sense_code
void bot_scsi_sense_code(void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code
Definition: composite_cdc_msc/msc_bot_scsi.c:292
bot_cbw_decode
void bot_cbw_decode(void *udev)
bulk-only cbw decode
Definition: composite_cdc_msc/msc_bot_scsi.c:200
bot_scsi_verify
usb_sts_type bot_scsi_verify(void *udev, uint8_t lun)
bulk-only transport scsi command verify
Definition: composite_cdc_msc/msc_bot_scsi.c:574
bot_scsi_allow_medium_removal
usb_sts_type bot_scsi_allow_medium_removal(void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal
Definition: composite_cdc_msc/msc_bot_scsi.c:427
bot_scsi_init
void bot_scsi_init(void *udev)
initialize bulk-only transport and scsi
Definition: composite_cdc_msc/msc_bot_scsi.c:104
bot_scsi_cmd_process
usb_sts_type bot_scsi_cmd_process(void *udev)
bulk-only transport scsi command process
Definition: composite_cdc_msc/msc_bot_scsi.c:753
bot_scsi_datain_handler
void bot_scsi_datain_handler(void *pudev, uint8_t ept_num)
bulk-only transport data in handler
Definition: composite_cdc_msc/msc_bot_scsi.c:147
bot_scsi_mode_sense6
usb_sts_type bot_scsi_mode_sense6(void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6
Definition: composite_cdc_msc/msc_bot_scsi.c:441
bot_scsi_stall
void bot_scsi_stall(void *udev)
bot endpoint stall
Definition: composite_cdc_msc/msc_bot_scsi.c:324
bot_scsi_send_data
void bot_scsi_send_data(void *udev, uint8_t *buffer, uint32_t len)
send bot data
Definition: composite_cdc_msc/msc_bot_scsi.c:247
bot_scsi_test_unit
usb_sts_type bot_scsi_test_unit(void *udev, uint8_t lun)
bulk-only transport scsi command test unit
Definition: composite_cdc_msc/msc_bot_scsi.c:350
bot_scsi_inquiry
usb_sts_type bot_scsi_inquiry(void *udev, uint8_t lun)
bulk-only transport scsi command inquiry
Definition: composite_cdc_msc/msc_bot_scsi.c:372
bot_scsi_capacity
usb_sts_type bot_scsi_capacity(void *udev, uint8_t lun)
bulk-only transport scsi command capacity
Definition: composite_cdc_msc/msc_bot_scsi.c:481
bot_scsi_clear_feature
void bot_scsi_clear_feature(void *udev, uint8_t ept_num)
clear feature
Definition: composite_cdc_msc/msc_bot_scsi.c:733
bot_scsi_send_csw
void bot_scsi_send_csw(void *udev, uint8_t status)
send command status
Definition: composite_cdc_msc/msc_bot_scsi.c:268
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
msc_class.h
usb msc class file
cbd_extended_type
extended command block description
Definition: cdc_msc_class.h:176
cbd_typical_type
typical command block description
Definition: cdc_msc_class.h:163
cbw_type
command block wrapper
Definition: cdc_msc_class.h:189
csw_type
command block wrapper
Definition: cdc_msc_class.h:203
msc_type
Definition: cdc_msc_class.h:228
sense_type
request sense standard data
Definition: cdc_msc_class.h:214
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: msc_class.c Source File

  • middlewares
  • usbd_class
  • msc
msc_class.c
Go to the documentation of this file.
1
26#include "usbd_core.h"
27#include "msc_class.h"
28#include "msc_desc.h"
29#include "msc_bot_scsi.h"
30
44static usb_sts_type class_init_handler(void *udev);
45static usb_sts_type class_clear_handler(void *udev);
46static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
47static usb_sts_type class_ept0_tx_handler(void *udev);
48static usb_sts_type class_ept0_rx_handler(void *udev);
49static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
50static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
51static usb_sts_type class_sof_handler(void *udev);
52static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
53
54 msc_type msc_struct;
55
56/* usb device class handler */
57usbd_class_handler msc_class_handler =
58{
59 class_init_handler,
60 class_clear_handler,
61 class_setup_handler,
62 class_ept0_tx_handler,
63 class_ept0_rx_handler,
64 class_in_handler,
65 class_out_handler,
66 class_sof_handler,
67 class_event_handler,
68 &msc_struct
69};
70
76static usb_sts_type class_init_handler(void *udev)
77{
78 usb_sts_type status = USB_OK;
79 usbd_core_type *pudev = (usbd_core_type *)udev;
80
81 /* open in endpoint */
82 usbd_ept_open(pudev, USBD_MSC_BULK_IN_EPT, EPT_BULK_TYPE, USBD_OUT_MAXPACKET_SIZE);
83
84 /* open out endpoint */
85 usbd_ept_open(pudev, USBD_MSC_BULK_OUT_EPT, EPT_BULK_TYPE, USBD_OUT_MAXPACKET_SIZE);
86
87 bot_scsi_init(udev);
88
89 return status;
90}
91
97static usb_sts_type class_clear_handler(void *udev)
98{
99 usb_sts_type status = USB_OK;
100 usbd_core_type *pudev = (usbd_core_type *)udev;
101
102 /* close in endpoint */
103 usbd_ept_close(pudev, USBD_MSC_BULK_IN_EPT);
104
105 /* close out endpoint */
106 usbd_ept_close(pudev, USBD_MSC_BULK_OUT_EPT);
107
108 return status;
109}
110
117static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
118{
119 usb_sts_type status = USB_OK;
120 usbd_core_type *pudev = (usbd_core_type *)udev;
121 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
122 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
123 {
124 /* class request */
125 case USB_REQ_TYPE_CLASS:
126
127 switch(setup->bRequest)
128 {
129 case MSC_REQ_GET_MAX_LUN:
130 usbd_ctrl_send(pudev, (uint8_t *)&pmsc->max_lun, 1);
131 break;
132 case MSC_REQ_BO_RESET:
133 bot_scsi_reset(udev);
134 usbd_ctrl_send_status(pudev);
135 break;
136 default:
137 usbd_ctrl_unsupport(pudev);
138 break;
139
140 }
141 break;
142 /* standard request */
143 case USB_REQ_TYPE_STANDARD:
144
145 switch(setup->bRequest)
146 {
147 case USB_STD_REQ_GET_DESCRIPTOR:
148 usbd_ctrl_unsupport(pudev);
149 break;
150 case USB_STD_REQ_GET_INTERFACE:
151 usbd_ctrl_send(pudev, (uint8_t *)&pmsc->alt_setting, 1);
152 break;
153 case USB_STD_REQ_SET_INTERFACE:
154 pmsc->alt_setting = setup->wValue;
155 break;
156 case USB_STD_REQ_CLEAR_FEATURE:
157 usbd_ept_close(pudev, (uint8_t)setup->wIndex);
158
159 if((setup->wIndex & 0x80) == 0x80)
160 {
161 usbd_flush_tx_fifo(pudev, setup->wIndex & 0x7F);
162 usbd_ept_open(pudev, (uint8_t)setup->wIndex, EPT_BULK_TYPE, USBD_IN_MAXPACKET_SIZE);
163 }
164 else
165 {
166 usbd_ept_open(pudev, (uint8_t)setup->wIndex, EPT_BULK_TYPE, USBD_OUT_MAXPACKET_SIZE);
167 }
168 bot_scsi_clear_feature(udev, setup->wIndex);
169 break;
170 default:
171 break;
172 }
173 break;
174 default:
175 usbd_ctrl_unsupport(pudev);
176 break;
177 }
178 return status;
179}
180
186static usb_sts_type class_ept0_tx_handler(void *udev)
187{
188 usb_sts_type status = USB_OK;
189
190 /* ...user code... */
191
192 return status;
193}
194
200static usb_sts_type class_ept0_rx_handler(void *udev)
201{
202 usb_sts_type status = USB_OK;
203 usbd_core_type *pudev = (usbd_core_type *)udev;
204 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
205 /* ...user code... */
206 return status;
207}
208
215static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
216{
217 usb_sts_type status = USB_OK;
218 usbd_core_type *pudev = (usbd_core_type *)udev;
219 usbd_flush_tx_fifo(pudev, ept_num&0x7F);
220 bot_scsi_datain_handler(udev, ept_num);
221 return status;
222}
223
230static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
231{
232 usb_sts_type status = USB_OK;
233
234 bot_scsi_dataout_handler(udev, ept_num);
235 return status;
236}
237
243static usb_sts_type class_sof_handler(void *udev)
244{
245 usb_sts_type status = USB_OK;
246
247 /* ...user code... */
248
249 return status;
250}
251
258static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
259{
260 usb_sts_type status = USB_OK;
261 switch(event)
262 {
263 case USBD_RESET_EVENT:
264
265 /* ...user code... */
266
267 break;
268 case USBD_SUSPEND_EVENT:
269
270 /* ...user code... */
271
272 break;
273 case USBD_WAKEUP_EVENT:
274 /* ...user code... */
275
276 break;
277
278 default:
279 break;
280 }
281 return status;
282}
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
msc_type::max_lun
uint32_t max_lun
Definition: cdc_msc_class.h:231
msc_type::alt_setting
uint32_t alt_setting
Definition: cdc_msc_class.h:242
USBD_MSC_BULK_IN_EPT
#define USBD_MSC_BULK_IN_EPT
Definition: cdc_msc_class.h:57
USBD_MSC_BULK_OUT_EPT
#define USBD_MSC_BULK_OUT_EPT
Definition: cdc_msc_class.h:58
bot_scsi_datain_handler
void bot_scsi_datain_handler(void *pudev, uint8_t ept_num)
bulk-only transport data in handler
Definition: msc/msc_bot_scsi.c:147
bot_scsi_reset
void bot_scsi_reset(void *udev)
reset bulk-only transport and scsi
Definition: msc/msc_bot_scsi.c:128
bot_scsi_init
void bot_scsi_init(void *udev)
initialize bulk-only transport and scsi
Definition: msc/msc_bot_scsi.c:104
bot_scsi_dataout_handler
void bot_scsi_dataout_handler(void *pudev, uint8_t ept_num)
bulk-only transport data out handler
Definition: msc/msc_bot_scsi.c:176
bot_scsi_clear_feature
void bot_scsi_clear_feature(void *udev, uint8_t ept_num)
clear feature
Definition: msc/msc_bot_scsi.c:733
EPT_BULK_TYPE
@ EPT_BULK_TYPE
Definition: at32f435_437_usb.h:348
MSC_REQ_BO_RESET
#define MSC_REQ_BO_RESET
Definition: cdc_msc_class.h:104
MSC_REQ_GET_MAX_LUN
#define MSC_REQ_GET_MAX_LUN
Definition: cdc_msc_class.h:103
USBD_OUT_MAXPACKET_SIZE
#define USBD_OUT_MAXPACKET_SIZE
Definition: msc_class.h:53
USBD_IN_MAXPACKET_SIZE
#define USBD_IN_MAXPACKET_SIZE
Definition: msc_class.h:52
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: msc_class.c:243
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: msc_class.c:215
msc_struct
msc_type msc_struct
Definition: msc_class.c:54
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: msc_class.c:97
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: msc_class.c:117
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: msc_class.c:186
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: msc_class.c:200
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: msc_class.c:258
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: msc_class.c:76
msc_class_handler
usbd_class_handler msc_class_handler
Definition: msc_class.c:57
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: msc_class.c:230
USB_STD_REQ_CLEAR_FEATURE
#define USB_STD_REQ_CLEAR_FEATURE
Definition: usb_std.h:78
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:63
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:81
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:86
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:66
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:85
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:64
USB_OK
@ USB_OK
Definition: usb_std.h:268
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:346
usbd_ctrl_send_status
void usbd_ctrl_send_status(usbd_core_type *udev)
usb control endpoint send in status
Definition: usbd_core.c:212
usbd_flush_tx_fifo
void usbd_flush_tx_fifo(usbd_core_type *udev, uint8_t ept_num)
usb device flush in endpoint fifo
Definition: usbd_core.c:650
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:314
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:177
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
get endpoint receive data length
Definition: usbd_core.c:300
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:287
msc_bot_scsi.h
usb mass storage bulk-only transport and scsi command header file
msc_class.h
usb msc class file
msc_desc.h
usb msc descriptor header file
msc_type
Definition: cdc_msc_class.h:228
usb_setup_type
format of usb setup data
Definition: usb_std.h:280
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:283
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:281
usb_setup_type::wIndex
uint16_t wIndex
Definition: usb_std.h:284
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:282
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: msc_class.h Source File

  • middlewares
  • usbd_class
  • msc
msc_class.h
Go to the documentation of this file.
1
26 /* define to prevent recursive inclusion -------------------------------------*/
27#ifndef __MSC_CLASS_H
28#define __MSC_CLASS_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "usb_std.h"
35#include "usbd_core.h"
36
49#define USBD_MSC_BULK_IN_EPT 0x81
50#define USBD_MSC_BULK_OUT_EPT 0x01
51
52#define USBD_IN_MAXPACKET_SIZE 0x40
53#define USBD_OUT_MAXPACKET_SIZE 0x40
54
55
56extern usbd_class_handler msc_class_handler;
68#ifdef __cplusplus
69}
70#endif
71
72#endif
msc_class_handler
usbd_class_handler msc_class_handler
Definition: msc_class.c:57
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: msc_desc.c Source File

  • middlewares
  • usbd_class
  • msc
msc_desc.c
Go to the documentation of this file.
1
26#include "stdio.h"
27#include "usb_std.h"
28#include "usbd_sdr.h"
29#include "usbd_core.h"
30#include "msc_desc.h"
31
45static usbd_desc_t *get_device_descriptor(void);
46static usbd_desc_t *get_device_qualifier(void);
47static usbd_desc_t *get_device_configuration(void);
48static usbd_desc_t *get_device_other_speed(void);
49static usbd_desc_t *get_device_lang_id(void);
50static usbd_desc_t *get_device_manufacturer_string(void);
51static usbd_desc_t *get_device_product_string(void);
52static usbd_desc_t *get_device_serial_string(void);
53static usbd_desc_t *get_device_interface_string(void);
54static usbd_desc_t *get_device_config_string(void);
55
56static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
57static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
58static void get_serial_num(void);
59static uint8_t g_usbd_desc_buffer[256];
60
64usbd_desc_handler msc_desc_handler =
65{
66 get_device_descriptor,
67 get_device_qualifier,
68 get_device_configuration,
69 get_device_other_speed,
70 get_device_lang_id,
71 get_device_manufacturer_string,
72 get_device_product_string,
73 get_device_serial_string,
74 get_device_interface_string,
75 get_device_config_string,
76};
77
81#if defined ( __ICCARM__ ) /* iar compiler */
82 #pragma data_alignment=4
83#endif
84ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
85{
86 USB_DEVICE_DESC_LEN, /* bLength */
87 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
88 0x00, /* bcdUSB */
89 0x02,
90 0x00, /* bDeviceClass */
91 0x00, /* bDeviceSubClass */
92 0x00, /* bDeviceProtocol */
93 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
94 LBYTE(USBD_MSC_VENDOR_ID), /* idVendor */
95 HBYTE(USBD_MSC_VENDOR_ID), /* idVendor */
96 LBYTE(USBD_MSC_PRODUCT_ID), /* idProduct */
97 HBYTE(USBD_MSC_PRODUCT_ID), /* idProduct */
98 0x00, /* bcdDevice rel. 2.00 */
99 0x02,
100 USB_MFC_STRING, /* Index of manufacturer string */
101 USB_PRODUCT_STRING, /* Index of product string */
102 USB_SERIAL_STRING, /* Index of serial number string */
103 1 /* bNumConfigurations */
104};
105
109#if defined ( __ICCARM__ ) /* iar compiler */
110 #pragma data_alignment=4
111#endif
112ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_MSC_CONFIG_DESC_SIZE] ALIGNED_TAIL =
113{
114 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
115 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
116 LBYTE(USBD_MSC_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
117 HBYTE(USBD_MSC_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
118 0x01, /* bNumInterfaces: 2 interface */
119 0x01, /* bConfigurationValue: configuration value */
120 0x04, /* iConfiguration: index of string descriptor describing
121 the configuration */
122 0xC0, /* bmAttributes: self powered */
123 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
124
125 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
126 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
127 0x00, /* bInterfaceNumber: number of interface */
128 0x00, /* bAlternateSetting: alternate set */
129 0x02, /* bNumEndpoints: number of endpoints */
130 USB_CLASS_CODE_MSC, /* bInterfaceClass: msc class code */
131 0x06, /* bInterfaceSubClass: subclass code scsi */
132 0x50, /* bInterfaceProtocol: protocol code BBB */
133 0x05, /* iInterface: index of string descriptor */
134
135 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
136 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
137 USBD_MSC_BULK_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
138 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
139 LBYTE(USBD_IN_MAXPACKET_SIZE),
140 HBYTE(USBD_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
141 0x00, /* bInterval: interval for polling endpoint for data transfers */
142
143 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
144 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
145 USBD_MSC_BULK_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
146 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
147 LBYTE(USBD_OUT_MAXPACKET_SIZE),
148 HBYTE(USBD_OUT_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
149 0x00, /* bInterval: interval for polling endpoint for data transfers */
150};
151
155#if defined ( __ICCARM__ ) /* iar compiler */
156 #pragma data_alignment=4
157#endif
158ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_MSC_SIZ_STRING_LANGID] ALIGNED_TAIL =
159{
160 USBD_MSC_SIZ_STRING_LANGID,
161 USB_DESCIPTOR_TYPE_STRING,
162 0x09,
163 0x04,
164};
165
169#if defined ( __ICCARM__ ) /* iar compiler */
170 #pragma data_alignment=4
171#endif
172ALIGNED_HEAD static uint8_t g_string_serial[USBD_MSC_SIZ_STRING_SERIAL] ALIGNED_TAIL =
173{
174 USBD_MSC_SIZ_STRING_SERIAL,
175 USB_DESCIPTOR_TYPE_STRING,
176};
177
178
179/* device descriptor */
180static usbd_desc_t device_descriptor =
181{
182 USB_DEVICE_DESC_LEN,
183 g_usbd_descriptor
184};
185
186/* config descriptor */
187static usbd_desc_t config_descriptor =
188{
189 USBD_MSC_CONFIG_DESC_SIZE,
190 g_usbd_configuration
191};
192
193/* langid descriptor */
194static usbd_desc_t langid_descriptor =
195{
196 USBD_MSC_SIZ_STRING_LANGID,
197 g_string_lang_id
198};
199
200/* serial descriptor */
201static usbd_desc_t serial_descriptor =
202{
203 USBD_MSC_SIZ_STRING_SERIAL,
204 g_string_serial
205};
206
207static usbd_desc_t vp_desc;
208
215static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
216{
217 uint16_t str_len = 0, id_pos = 2;
218 uint8_t *tmp_str = string;
219
220 while(*tmp_str != '\0')
221 {
222 str_len ++;
223 unicode_buf[id_pos ++] = *tmp_str ++;
224 unicode_buf[id_pos ++] = 0x00;
225 }
226
227 str_len = str_len * 2 + 2;
228 unicode_buf[0] = (uint8_t)str_len;
229 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
230
231 return str_len;
232}
233
241static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
242{
243 uint8_t idx = 0;
244
245 for( idx = 0 ; idx < len ; idx ++)
246 {
247 if( ((value >> 28)) < 0xA )
248 {
249 pbuf[ 2 * idx] = (value >> 28) + '0';
250 }
251 else
252 {
253 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
254 }
255
256 value = value << 4;
257
258 pbuf[2 * idx + 1] = 0;
259 }
260}
261
267static void get_serial_num(void)
268{
269 uint32_t serial0, serial1, serial2;
270
271 serial0 = *(uint32_t*)MCU_ID1;
272 serial1 = *(uint32_t*)MCU_ID2;
273 serial2 = *(uint32_t*)MCU_ID3;
274
275 serial0 += serial2;
276
277 if (serial0 != 0)
278 {
279 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
280 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
281 }
282}
283
289static usbd_desc_t *get_device_descriptor(void)
290{
291 return &device_descriptor;
292}
293
299static usbd_desc_t * get_device_qualifier(void)
300{
301 return NULL;
302}
303
309static usbd_desc_t *get_device_configuration(void)
310{
311 return &config_descriptor;
312}
313
319static usbd_desc_t *get_device_other_speed(void)
320{
321 return NULL;
322}
323
329static usbd_desc_t *get_device_lang_id(void)
330{
331 return &langid_descriptor;
332}
333
334
340static usbd_desc_t *get_device_manufacturer_string(void)
341{
342 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_MSC_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
343 vp_desc.descriptor = g_usbd_desc_buffer;
344 return &vp_desc;
345}
346
352static usbd_desc_t *get_device_product_string(void)
353{
354 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_MSC_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
355 vp_desc.descriptor = g_usbd_desc_buffer;
356 return &vp_desc;
357}
358
364static usbd_desc_t *get_device_serial_string(void)
365{
366 get_serial_num();
367 return &serial_descriptor;
368}
369
375static usbd_desc_t *get_device_interface_string(void)
376{
377 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_MSC_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
378 vp_desc.descriptor = g_usbd_desc_buffer;
379 return &vp_desc;
380}
381
387static usbd_desc_t *get_device_config_string(void)
388{
389 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_MSC_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
390 vp_desc.descriptor = g_usbd_desc_buffer;
391 return &vp_desc;
392}
393
idx
uint32_t idx
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:46
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:215
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:216
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:217
USBD_MSC_BULK_IN_EPT
#define USBD_MSC_BULK_IN_EPT
Definition: cdc_msc_class.h:57
USBD_MSC_BULK_OUT_EPT
#define USBD_MSC_BULK_OUT_EPT
Definition: cdc_msc_class.h:58
USBD_OUT_MAXPACKET_SIZE
#define USBD_OUT_MAXPACKET_SIZE
Definition: msc_class.h:53
USBD_IN_MAXPACKET_SIZE
#define USBD_IN_MAXPACKET_SIZE
Definition: msc_class.h:52
USBD_MSC_SIZ_STRING_SERIAL
#define USBD_MSC_SIZ_STRING_SERIAL
Definition: msc_desc.h:57
USBD_MSC_DESC_PRODUCT_STRING
#define USBD_MSC_DESC_PRODUCT_STRING
Definition: msc_desc.h:60
USBD_MSC_DESC_CONFIGURATION_STRING
#define USBD_MSC_DESC_CONFIGURATION_STRING
Definition: msc_desc.h:61
USBD_MSC_DESC_INTERFACE_STRING
#define USBD_MSC_DESC_INTERFACE_STRING
Definition: msc_desc.h:62
USBD_MSC_CONFIG_DESC_SIZE
#define USBD_MSC_CONFIG_DESC_SIZE
Definition: msc_desc.h:55
USBD_MSC_PRODUCT_ID
#define USBD_MSC_PRODUCT_ID
Definition: msc_desc.h:53
USBD_MSC_SIZ_STRING_LANGID
#define USBD_MSC_SIZ_STRING_LANGID
Definition: msc_desc.h:56
USBD_MSC_VENDOR_ID
#define USBD_MSC_VENDOR_ID
Definition: msc_desc.h:52
USBD_MSC_DESC_MANUFACTURER_STRING
#define USBD_MSC_DESC_MANUFACTURER_STRING
Definition: msc_desc.h:59
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: msc_desc.c:201
device_descriptor
static usbd_desc_t device_descriptor
Definition: msc_desc.c:180
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: msc_desc.c:309
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: msc_desc.c:194
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: msc_desc.c:289
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: msc_desc.c:340
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: msc_desc.c:299
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: msc_desc.c:375
g_usbd_desc_buffer
static uint8_t g_usbd_desc_buffer[256]
Definition: msc_desc.c:59
vp_desc
static usbd_desc_t vp_desc
Definition: msc_desc.c:207
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: msc_desc.c:319
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL
usb device standard descriptor
Definition: msc_desc.c:84
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: msc_desc.c:352
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: msc_desc.c:387
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: msc_desc.c:215
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: msc_desc.c:329
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: msc_desc.c:267
config_descriptor
static usbd_desc_t config_descriptor
Definition: msc_desc.c:187
msc_desc_handler
usbd_desc_handler msc_desc_handler
device descriptor handler structure
Definition: msc_desc.c:64
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: msc_desc.c:364
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: msc_desc.c:241
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:153
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:93
USB_CLASS_CODE_MSC
#define USB_CLASS_CODE_MSC
Definition: usb_std.h:165
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:96
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_EPT_DESC_BULK
#define USB_EPT_DESC_BULK
Definition: usb_std.h:177
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:152
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:151
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:94
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:95
msc_desc.h
usb msc descriptor header file
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h


AT32F435/437 Firmwary Library: msc_desc.h Source File

  • middlewares
  • usbd_class
  • msc
msc_desc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __MSC_DESC_H
29#define __MSC_DESC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "msc_class.h"
36#include "usbd_core.h"
37
50#define MSC_BCD_NUM 0x0110
51
52#define USBD_MSC_VENDOR_ID 0x2E3C
53#define USBD_MSC_PRODUCT_ID 0x5720
54
55#define USBD_MSC_CONFIG_DESC_SIZE 32
56#define USBD_MSC_SIZ_STRING_LANGID 4
57#define USBD_MSC_SIZ_STRING_SERIAL 0x1A
58
59#define USBD_MSC_DESC_MANUFACTURER_STRING "Artery"
60#define USBD_MSC_DESC_PRODUCT_STRING "AT32 Mass Storage"
61#define USBD_MSC_DESC_CONFIGURATION_STRING "Mass Storage Config"
62#define USBD_MSC_DESC_INTERFACE_STRING "Mass Storage Interface"
63
64#define MCU_ID1 (0x1FFFF7E8)
65#define MCU_ID2 (0x1FFFF7EC)
66#define MCU_ID3 (0x1FFFF7F0)
67
68extern usbd_desc_handler msc_desc_handler;
69
81#ifdef __cplusplus
82}
83#endif
84
85#endif
msc_desc_handler
usbd_desc_handler msc_desc_handler
device descriptor handler structure
Definition: msc_desc.c:64
msc_class.h
usb msc class file
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: printer_class.c Source File

  • middlewares
  • usbd_class
  • printer
printer_class.c
Go to the documentation of this file.
1
26#include "usbd_core.h"
27#include "printer_class.h"
28#include "printer_desc.h"
29
43static usb_sts_type class_init_handler(void *udev);
44static usb_sts_type class_clear_handler(void *udev);
45static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
46static usb_sts_type class_ept0_tx_handler(void *udev);
47static usb_sts_type class_ept0_rx_handler(void *udev);
48static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
49static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
50static usb_sts_type class_sof_handler(void *udev);
51static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
52
53ALIGNED_HEAD static uint8_t printer_device_id[PRINTER_DEVICE_ID_LEN] ALIGNED_TAIL=
54{
55 0x00, 0x16,
56 'M', 'F', 'G',':','A','r','t','e', 'r', 'y' ,' ',
57 'C','M', 'D', ':', 'E', 'S', 'C', 'P', 'O', 'S',' ',
58};
59
60/* static variable */
61 printer_type printer_struct;
62
63/* usb device class handler */
64usbd_class_handler printer_class_handler =
65{
66 class_init_handler,
67 class_clear_handler,
68 class_setup_handler,
69 class_ept0_tx_handler,
70 class_ept0_rx_handler,
71 class_in_handler,
72 class_out_handler,
73 class_sof_handler,
74 class_event_handler,
75 &printer_struct
76};
77
83static usb_sts_type class_init_handler(void *udev)
84{
85 usb_sts_type status = USB_OK;
86 usbd_core_type *pudev = (usbd_core_type *)udev;
87 printer_type *pprter = (printer_type *)pudev->class_handler->pdata;
88
89 /* open in endpoint */
90 usbd_ept_open(pudev, USBD_PRINTER_BULK_IN_EPT, EPT_BULK_TYPE, USBD_PRINTER_IN_MAXPACKET_SIZE);
91
92 /* open out endpoint */
93 usbd_ept_open(pudev, USBD_PRINTER_BULK_OUT_EPT, EPT_BULK_TYPE, USBD_PRINTER_OUT_MAXPACKET_SIZE);
94
95 /* set out endpoint to receive status */
96 usbd_ept_recv(pudev, USBD_PRINTER_BULK_OUT_EPT, pprter->g_rx_buff, USBD_PRINTER_OUT_MAXPACKET_SIZE);
97
98 pprter->g_tx_completed = 1;
99 pprter->g_printer_port_status = 0x18;
100
101 return status;
102}
103
109static usb_sts_type class_clear_handler(void *udev)
110{
111 usb_sts_type status = USB_OK;
112 usbd_core_type *pudev = (usbd_core_type *)udev;
113
114 /* close in endpoint */
115 usbd_ept_close(pudev, USBD_PRINTER_BULK_IN_EPT);
116
117 /* close out endpoint */
118 usbd_ept_close(pudev, USBD_PRINTER_BULK_OUT_EPT);
119
120 return status;
121}
122
129static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
130{
131 usb_sts_type status = USB_OK;
132 usbd_core_type *pudev = (usbd_core_type *)udev;
133 printer_type *pprter = (printer_type *)pudev->class_handler->pdata;
134
135 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
136 {
137 /* class request */
138 case USB_REQ_TYPE_CLASS:
139 switch(setup->bRequest)
140 {
141 case PRINTER_REQ_GET_DEVICE_ID:
142 usbd_ctrl_send(pudev, printer_device_id, PRINTER_DEVICE_ID_LEN);
143 break;
144 case PRINTER_REQ_GET_PORT_STATUS:
145 usbd_ctrl_send(pudev, (uint8_t *)&pprter->g_printer_port_status, 1);
146 break;
147 case PRINTER_REQ_GET_SOFT_RESET:
148 usbd_ctrl_recv(pudev, pprter->g_printer_data, USBD_PRINTER_OUT_MAXPACKET_SIZE);
149 break;
150 default:
151 usbd_ctrl_unsupport(pudev);
152 break;
153 }
154 break;
155 /* standard request */
156 case USB_REQ_TYPE_STANDARD:
157 switch(setup->bRequest)
158 {
159 case USB_STD_REQ_GET_DESCRIPTOR:
160 usbd_ctrl_unsupport(pudev);
161 break;
162 case USB_STD_REQ_GET_INTERFACE:
163 usbd_ctrl_send(pudev, (uint8_t *)&pprter->alt_setting, 1);
164 break;
165 case USB_STD_REQ_SET_INTERFACE:
166 pprter->alt_setting = setup->wValue;
167 break;
168 default:
169 break;
170 }
171 break;
172 default:
173 usbd_ctrl_unsupport(pudev);
174 break;
175 }
176 return status;
177}
178
184static usb_sts_type class_ept0_tx_handler(void *udev)
185{
186 usb_sts_type status = USB_OK;
187
188 /* ...user code... */
189
190 return status;
191}
192
198static usb_sts_type class_ept0_rx_handler(void *udev)
199{
200 usb_sts_type status = USB_OK;
201
202 /* ...user code... */
203
204 return status;
205}
206
213static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
214{
215 usbd_core_type *pudev = (usbd_core_type *)udev;
216 printer_type *pprter = (printer_type *)pudev->class_handler->pdata;
217 usb_sts_type status = USB_OK;
218
219 /* ...user code...
220 trans next packet data
221 */
222 usbd_flush_tx_fifo(pudev, ept_num);
223 pprter->g_tx_completed = 1;
224
225 return status;
226}
227
234static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
235{
236 usb_sts_type status = USB_OK;
237 usbd_core_type *pudev = (usbd_core_type *)udev;
238 printer_type *pprter = (printer_type *)pudev->class_handler->pdata;
239
240 /*set recv flag*/
241 pprter->g_rx_completed = 1;
242
243 return status;
244}
245
251static usb_sts_type class_sof_handler(void *udev)
252{
253 usb_sts_type status = USB_OK;
254
255 /* ...user code... */
256
257 return status;
258}
259
266static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
267{
268 usb_sts_type status = USB_OK;
269 switch(event)
270 {
271 case USBD_RESET_EVENT:
272
273 /* ...user code... */
274
275 break;
276 case USBD_SUSPEND_EVENT:
277
278 /* ...user code... */
279
280 break;
281 case USBD_WAKEUP_EVENT:
282 /* ...user code... */
283
284 break;
285 case USBD_INISOINCOM_EVENT:
286 break;
287 case USBD_OUTISOINCOM_EVENT:
288 break;
289
290 default:
291 break;
292 }
293 return status;
294}
295
303 error_status usb_printer_send_data(void *udev, uint8_t *send_data, uint16_t len)
304{
305 error_status status = SUCCESS;
306 usbd_core_type *pudev = (usbd_core_type *)udev;
307 printer_type *pprter = (printer_type *)pudev->class_handler->pdata;
308 if(pprter->g_tx_completed)
309 {
310 pprter->g_tx_completed = 0;
311 usbd_ept_send(pudev, USBD_PRINTER_BULK_IN_EPT, send_data, len);
312 }
313 else
314 {
315 status = ERROR;
316 }
317 return status;
318}
319
320
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
EPT_BULK_TYPE
@ EPT_BULK_TYPE
Definition: at32f435_437_usb.h:348
USBD_PRINTER_OUT_MAXPACKET_SIZE
#define USBD_PRINTER_OUT_MAXPACKET_SIZE
Definition: printer_class.h:55
USBD_PRINTER_IN_MAXPACKET_SIZE
#define USBD_PRINTER_IN_MAXPACKET_SIZE
Definition: printer_class.h:54
PRINTER_DEVICE_ID_LEN
#define PRINTER_DEVICE_ID_LEN
Definition: printer_class.h:57
USBD_PRINTER_BULK_OUT_EPT
#define USBD_PRINTER_BULK_OUT_EPT
Definition: printer_class.h:51
USBD_PRINTER_BULK_IN_EPT
#define USBD_PRINTER_BULK_IN_EPT
Definition: printer_class.h:50
PRINTER_REQ_GET_SOFT_RESET
@ PRINTER_REQ_GET_SOFT_RESET
Definition: printer_class.h:63
PRINTER_REQ_GET_PORT_STATUS
@ PRINTER_REQ_GET_PORT_STATUS
Definition: printer_class.h:62
PRINTER_REQ_GET_DEVICE_ID
@ PRINTER_REQ_GET_DEVICE_ID
Definition: printer_class.h:61
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: printer_class.c:251
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: printer_class.c:213
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: printer_class.c:109
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: printer_class.c:129
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: printer_class.c:184
printer_class_handler
usbd_class_handler printer_class_handler
Definition: printer_class.c:64
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: printer_class.c:198
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: printer_class.c:266
usb_printer_send_data
error_status usb_printer_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: printer_class.c:303
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: printer_class.c:83
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: printer_class.c:234
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t printer_device_id[24] ALIGNED_TAIL
Definition: printer_class.c:53
printer_struct
printer_type printer_struct
Definition: printer_class.c:61
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:63
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:81
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:86
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:66
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:267
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:85
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:64
USB_OK
@ USB_OK
Definition: usb_std.h:268
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:346
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint receive data
Definition: usbd_core.c:534
usbd_flush_tx_fifo
void usbd_flush_tx_fifo(usbd_core_type *udev, uint8_t ept_num)
usb device flush in endpoint fifo
Definition: usbd_core.c:650
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:314
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:177
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
endpoint send data
Definition: usbd_core.c:434
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint recv data
Definition: usbd_core.c:196
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:287
printer_class.h
usb cdc class file
printer_desc.h
usb printer descriptor header file
printer_type
Definition: printer_class.h:68
printer_type::g_printer_data
uint8_t g_printer_data[0x40]
Definition: printer_class.h:72
printer_type::g_rx_completed
__IO uint8_t g_rx_completed
Definition: printer_class.h:74
printer_type::g_printer_port_status
uint32_t g_printer_port_status
Definition: printer_class.h:70
printer_type::g_rx_buff
uint8_t g_rx_buff[0x40]
Definition: printer_class.h:71
printer_type::g_tx_completed
__IO uint8_t g_tx_completed
Definition: printer_class.h:73
printer_type::alt_setting
uint32_t alt_setting
Definition: printer_class.h:69
usb_setup_type
format of usb setup data
Definition: usb_std.h:280
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:283
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:281
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:282
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: printer_class.h Source File

  • middlewares
  • usbd_class
  • printer
printer_class.h
Go to the documentation of this file.
1
27 /* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __PRINTER_CLASS_H
29#define __PRINTER_CLASS_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "usb_std.h"
36#include "usbd_core.h"
37
50#define USBD_PRINTER_BULK_IN_EPT 0x81
51#define USBD_PRINTER_BULK_OUT_EPT 0x01
52
53
54#define USBD_PRINTER_IN_MAXPACKET_SIZE 0x40
55#define USBD_PRINTER_OUT_MAXPACKET_SIZE 0x40
56
57#define PRINTER_DEVICE_ID_LEN 24
58
59typedef enum
60{
61 PRINTER_REQ_GET_DEVICE_ID = 0x00,
62 PRINTER_REQ_GET_PORT_STATUS = 0x01,
63 PRINTER_REQ_GET_SOFT_RESET = 0x02
64}printer_req_type;
65
66
67typedef struct
68{
69 uint32_t alt_setting;
70 uint32_t g_printer_port_status;
71 uint8_t g_rx_buff[USBD_PRINTER_OUT_MAXPACKET_SIZE];
72 uint8_t g_printer_data[USBD_PRINTER_OUT_MAXPACKET_SIZE];
73 __IO uint8_t g_tx_completed;
74 __IO uint8_t g_rx_completed;
75}printer_type;
76
77extern usbd_class_handler printer_class_handler;
78uint16_t usb_printer_get_rxdata(void *udev, uint8_t *recv_data);
79 error_status usb_printer_send_data(void *udev, uint8_t *send_data, uint16_t len);
91#ifdef __cplusplus
92}
93#endif
94
95#endif
error_status
error_status
Definition: at32f435_437.h:380
printer_req_type
printer_req_type
Definition: printer_class.h:60
USBD_PRINTER_OUT_MAXPACKET_SIZE
#define USBD_PRINTER_OUT_MAXPACKET_SIZE
Definition: printer_class.h:55
usb_printer_get_rxdata
uint16_t usb_printer_get_rxdata(void *udev, uint8_t *recv_data)
printer_class_handler
usbd_class_handler printer_class_handler
Definition: printer_class.c:64
usb_printer_send_data
error_status usb_printer_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: printer_class.c:303
PRINTER_REQ_GET_SOFT_RESET
@ PRINTER_REQ_GET_SOFT_RESET
Definition: printer_class.h:63
PRINTER_REQ_GET_PORT_STATUS
@ PRINTER_REQ_GET_PORT_STATUS
Definition: printer_class.h:62
PRINTER_REQ_GET_DEVICE_ID
@ PRINTER_REQ_GET_DEVICE_ID
Definition: printer_class.h:61
printer_type
Definition: printer_class.h:68
printer_type::g_rx_completed
__IO uint8_t g_rx_completed
Definition: printer_class.h:74
printer_type::g_printer_port_status
uint32_t g_printer_port_status
Definition: printer_class.h:70
printer_type::g_tx_completed
__IO uint8_t g_tx_completed
Definition: printer_class.h:73
printer_type::alt_setting
uint32_t alt_setting
Definition: printer_class.h:69
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: printer_desc.c Source File

  • middlewares
  • usbd_class
  • printer
printer_desc.c
Go to the documentation of this file.
1
26#include "stdio.h"
27#include "usb_std.h"
28#include "usbd_sdr.h"
29#include "usbd_core.h"
30#include "printer_desc.h"
31
45static usbd_desc_t *get_device_descriptor(void);
46static usbd_desc_t *get_device_qualifier(void);
47static usbd_desc_t *get_device_configuration(void);
48static usbd_desc_t *get_device_other_speed(void);
49static usbd_desc_t *get_device_lang_id(void);
50static usbd_desc_t *get_device_manufacturer_string(void);
51static usbd_desc_t *get_device_product_string(void);
52static usbd_desc_t *get_device_serial_string(void);
53static usbd_desc_t *get_device_interface_string(void);
54static usbd_desc_t *get_device_config_string(void);
55
56static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
57static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
58static void get_serial_num(void);
59static uint8_t g_usbd_desc_buffer[256];
60
64usbd_desc_handler printer_desc_handler =
65{
66 get_device_descriptor,
67 get_device_qualifier,
68 get_device_configuration,
69 get_device_other_speed,
70 get_device_lang_id,
71 get_device_manufacturer_string,
72 get_device_product_string,
73 get_device_serial_string,
74 get_device_interface_string,
75 get_device_config_string,
76};
77
81#if defined ( __ICCARM__ ) /* iar compiler */
82 #pragma data_alignment=4
83#endif
84ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
85{
86 USB_DEVICE_DESC_LEN, /* bLength */
87 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
88 0x00, /* bcdUSB */
89 0x02,
90 0x00, /* bDeviceClass */
91 0x00, /* bDeviceSubClass */
92 0x00, /* bDeviceProtocol */
93 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
94 LBYTE(USBD_PRINTER_VENDOR_ID), /* idVendor */
95 HBYTE(USBD_PRINTER_VENDOR_ID), /* idVendor */
96 LBYTE(USBD_PRINTER_PRODUCT_ID), /* idProduct */
97 HBYTE(USBD_PRINTER_PRODUCT_ID), /* idProduct */
98 0x00, /* bcdDevice rel. 2.00 */
99 0x02,
100 USB_MFC_STRING, /* Index of manufacturer string */
101 USB_PRODUCT_STRING, /* Index of product string */
102 USB_SERIAL_STRING, /* Index of serial number string */
103 1 /* bNumConfigurations */
104};
105
109#if defined ( __ICCARM__ ) /* iar compiler */
110 #pragma data_alignment=4
111#endif
112ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_PRINTER_CONFIG_DESC_SIZE] ALIGNED_TAIL =
113{
114 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
115 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
116 LBYTE(USBD_PRINTER_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
117 HBYTE(USBD_PRINTER_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
118 0x01, /* bNumInterfaces: 1 interface */
119 0x01, /* bConfigurationValue: configuration value */
120 0x00, /* iConfiguration: index of string descriptor describing
121 the configuration */
122 0xC0, /* bmAttributes: self powered */
123 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
124
125 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
126 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
127 0x00, /* bInterfaceNumber: number of interface */
128 0x00, /* bAlternateSetting: alternate set */
129 0x02, /* bNumEndpoints: number of endpoints */
130 USB_CLASS_CODE_PRINTER, /* bInterfaceClass: printer class code */
131 0x01, /* bInterfaceSubClass: subclass code*/
132 PRINTER_PROTOCOL_BI_DIRECTIONAL, /* bInterfaceProtocol: printer interface type */
133 0x00, /* iInterface: index of string descriptor */
134
135 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
136 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
137 USBD_PRINTER_BULK_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
138 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
139 LBYTE(USBD_PRINTER_IN_MAXPACKET_SIZE),
140 HBYTE(USBD_PRINTER_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
141 0x00, /* bInterval: interval for polling endpoint for data transfers */
142
143 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
144 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
145 USBD_PRINTER_BULK_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
146 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
147 LBYTE(USBD_PRINTER_OUT_MAXPACKET_SIZE),
148 HBYTE(USBD_PRINTER_OUT_MAXPACKET_SIZE),/* wMaxPacketSize: maximum packe size this endpoint */
149 0x00, /* bInterval: interval for polling endpoint for data transfers */
150};
151
155#if defined ( __ICCARM__ ) /* iar compiler */
156 #pragma data_alignment=4
157#endif
158ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_PRINTER_SIZ_STRING_LANGID] ALIGNED_TAIL =
159{
160 USBD_PRINTER_SIZ_STRING_LANGID,
161 USB_DESCIPTOR_TYPE_STRING,
162 0x09,
163 0x04,
164};
165
169#if defined ( __ICCARM__ ) /* iar compiler */
170 #pragma data_alignment=4
171#endif
172ALIGNED_HEAD static uint8_t g_string_serial[USBD_PRINTER_SIZ_STRING_SERIAL] ALIGNED_TAIL =
173{
174 USBD_PRINTER_SIZ_STRING_SERIAL,
175 USB_DESCIPTOR_TYPE_STRING,
176};
177
178
179/* device descriptor */
180static usbd_desc_t device_descriptor =
181{
182 USB_DEVICE_DESC_LEN,
183 g_usbd_descriptor
184};
185
186/* config descriptor */
187static usbd_desc_t config_descriptor =
188{
189 USBD_PRINTER_CONFIG_DESC_SIZE,
190 g_usbd_configuration
191};
192
193/* langid descriptor */
194static usbd_desc_t langid_descriptor =
195{
196 USBD_PRINTER_SIZ_STRING_LANGID,
197 g_string_lang_id
198};
199
200/* serial descriptor */
201static usbd_desc_t serial_descriptor =
202{
203 USBD_PRINTER_SIZ_STRING_SERIAL,
204 g_string_serial
205};
206
207static usbd_desc_t vp_desc;
208
215static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
216{
217 uint16_t str_len = 0, id_pos = 2;
218 uint8_t *tmp_str = string;
219
220 while(*tmp_str != '\0')
221 {
222 str_len ++;
223 unicode_buf[id_pos ++] = *tmp_str ++;
224 unicode_buf[id_pos ++] = 0x00;
225 }
226
227 str_len = str_len * 2 + 2;
228 unicode_buf[0] = (uint8_t)str_len;
229 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
230
231 return str_len;
232}
233
241static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
242{
243 uint8_t idx = 0;
244
245 for( idx = 0 ; idx < len ; idx ++)
246 {
247 if( ((value >> 28)) < 0xA )
248 {
249 pbuf[ 2 * idx] = (value >> 28) + '0';
250 }
251 else
252 {
253 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
254 }
255
256 value = value << 4;
257
258 pbuf[2 * idx + 1] = 0;
259 }
260}
261
267static void get_serial_num(void)
268{
269 uint32_t serial0, serial1, serial2;
270
271 serial0 = *(uint32_t*)MCU_ID1;
272 serial1 = *(uint32_t*)MCU_ID2;
273 serial2 = *(uint32_t*)MCU_ID3;
274
275 serial0 += serial2;
276
277 if (serial0 != 0)
278 {
279 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
280 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
281 }
282}
283
289static usbd_desc_t *get_device_descriptor(void)
290{
291 return &device_descriptor;
292}
293
299static usbd_desc_t * get_device_qualifier(void)
300{
301 return NULL;
302}
303
309static usbd_desc_t *get_device_configuration(void)
310{
311 return &config_descriptor;
312}
313
319static usbd_desc_t *get_device_other_speed(void)
320{
321 return NULL;
322}
323
329static usbd_desc_t *get_device_lang_id(void)
330{
331 return &langid_descriptor;
332}
333
334
340static usbd_desc_t *get_device_manufacturer_string(void)
341{
342 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_PRINTER_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
343 vp_desc.descriptor = g_usbd_desc_buffer;
344 return &vp_desc;
345}
346
352static usbd_desc_t *get_device_product_string(void)
353{
354 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_PRINTER_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
355 vp_desc.descriptor = g_usbd_desc_buffer;
356 return &vp_desc;
357}
358
364static usbd_desc_t *get_device_serial_string(void)
365{
366 get_serial_num();
367 return &serial_descriptor;
368}
369
375static usbd_desc_t *get_device_interface_string(void)
376{
377 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_PRINTER_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
378 vp_desc.descriptor = g_usbd_desc_buffer;
379 return &vp_desc;
380}
381
387static usbd_desc_t *get_device_config_string(void)
388{
389 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_PRINTER_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
390 vp_desc.descriptor = g_usbd_desc_buffer;
391 return &vp_desc;
392}
393
idx
uint32_t idx
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:46
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:215
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:216
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:217
USBD_PRINTER_OUT_MAXPACKET_SIZE
#define USBD_PRINTER_OUT_MAXPACKET_SIZE
Definition: printer_class.h:55
USBD_PRINTER_IN_MAXPACKET_SIZE
#define USBD_PRINTER_IN_MAXPACKET_SIZE
Definition: printer_class.h:54
USBD_PRINTER_BULK_OUT_EPT
#define USBD_PRINTER_BULK_OUT_EPT
Definition: printer_class.h:51
USBD_PRINTER_BULK_IN_EPT
#define USBD_PRINTER_BULK_IN_EPT
Definition: printer_class.h:50
USBD_PRINTER_DESC_PRODUCT_STRING
#define USBD_PRINTER_DESC_PRODUCT_STRING
Definition: printer_desc.h:60
USBD_PRINTER_CONFIG_DESC_SIZE
#define USBD_PRINTER_CONFIG_DESC_SIZE
Definition: printer_desc.h:55
USBD_PRINTER_DESC_CONFIGURATION_STRING
#define USBD_PRINTER_DESC_CONFIGURATION_STRING
Definition: printer_desc.h:61
PRINTER_PROTOCOL_BI_DIRECTIONAL
#define PRINTER_PROTOCOL_BI_DIRECTIONAL
Definition: printer_desc.h:65
USBD_PRINTER_DESC_INTERFACE_STRING
#define USBD_PRINTER_DESC_INTERFACE_STRING
Definition: printer_desc.h:62
USBD_PRINTER_DESC_MANUFACTURER_STRING
#define USBD_PRINTER_DESC_MANUFACTURER_STRING
Definition: printer_desc.h:59
USBD_PRINTER_PRODUCT_ID
#define USBD_PRINTER_PRODUCT_ID
Definition: printer_desc.h:53
USBD_PRINTER_SIZ_STRING_SERIAL
#define USBD_PRINTER_SIZ_STRING_SERIAL
Definition: printer_desc.h:57
USBD_PRINTER_SIZ_STRING_LANGID
#define USBD_PRINTER_SIZ_STRING_LANGID
Definition: printer_desc.h:56
USBD_PRINTER_VENDOR_ID
#define USBD_PRINTER_VENDOR_ID
Definition: printer_desc.h:52
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: printer_desc.c:201
device_descriptor
static usbd_desc_t device_descriptor
Definition: printer_desc.c:180
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: printer_desc.c:309
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: printer_desc.c:194
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: printer_desc.c:289
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: printer_desc.c:340
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: printer_desc.c:299
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: printer_desc.c:375
g_usbd_desc_buffer
static uint8_t g_usbd_desc_buffer[256]
Definition: printer_desc.c:59
vp_desc
static usbd_desc_t vp_desc
Definition: printer_desc.c:207
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: printer_desc.c:319
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL
usb device standard descriptor
Definition: printer_desc.c:84
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: printer_desc.c:352
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: printer_desc.c:387
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: printer_desc.c:215
printer_desc_handler
usbd_desc_handler printer_desc_handler
device descriptor handler structure
Definition: printer_desc.c:64
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: printer_desc.c:329
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: printer_desc.c:267
config_descriptor
static usbd_desc_t config_descriptor
Definition: printer_desc.c:187
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: printer_desc.c:364
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: printer_desc.c:241
USB_CLASS_CODE_PRINTER
#define USB_CLASS_CODE_PRINTER
Definition: usb_std.h:164
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:153
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:93
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:96
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_EPT_DESC_BULK
#define USB_EPT_DESC_BULK
Definition: usb_std.h:177
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:152
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:151
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:94
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:95
printer_desc.h
usb printer descriptor header file
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h


AT32F435/437 Firmwary Library: printer_desc.h Source File

  • middlewares
  • usbd_class
  • printer
printer_desc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __PRINTER_DESC_H
29#define __PRINTER_DESC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "printer_class.h"
36#include "usbd_core.h"
37
50#define PRINTER_BCD_NUM 0x0110
51
52#define USBD_PRINTER_VENDOR_ID 0x2E3C
53#define USBD_PRINTER_PRODUCT_ID 0x57FF
54
55#define USBD_PRINTER_CONFIG_DESC_SIZE 32
56#define USBD_PRINTER_SIZ_STRING_LANGID 4
57#define USBD_PRINTER_SIZ_STRING_SERIAL 0x1A
58
59#define USBD_PRINTER_DESC_MANUFACTURER_STRING "Artery"
60#define USBD_PRINTER_DESC_PRODUCT_STRING "AT32 Printer"
61#define USBD_PRINTER_DESC_CONFIGURATION_STRING "Printer Config"
62#define USBD_PRINTER_DESC_INTERFACE_STRING "Printer Interface"
63
64#define PRINTER_PROTOCOL_UNIDIRECTIONAL 0x01
65#define PRINTER_PROTOCOL_BI_DIRECTIONAL 0x02
66#define PRINTER_PROTOCOL_1284_4 0x03
67#define PRINTER_PROTOCOL_VENDOR_SPECIFIC 0xFF
68
69
70#define MCU_ID1 (0x1FFFF7E8)
71#define MCU_ID2 (0x1FFFF7EC)
72#define MCU_ID3 (0x1FFFF7F0)
73
74
75extern usbd_desc_handler printer_desc_handler;
76
88#ifdef __cplusplus
89}
90#endif
91
92#endif
printer_desc_handler
usbd_desc_handler printer_desc_handler
device descriptor handler structure
Definition: printer_desc.c:64
printer_class.h
usb cdc class file
usbd_core.h
usb device core header file


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • acc
  • calibration
  • inc
project/at_start_f435/examples/acc/calibration/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • acc
  • calibration
  • inc
project/at_start_f435/examples/acc/calibration/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • acc
  • calibration
  • inc
project/at_start_f435/examples/acc/calibration/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c:95
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c:56
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c:69
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c:108
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c:126
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c:47
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c:82
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c:135
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c:117


AT32F435/437 Firmwary Library: usb_conf.h Source File

  • at_start_f435
  • examples
  • acc
  • calibration
  • inc
project/at_start_f435/examples/acc/calibration/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f435_437_usb.h"
36#include "at32f435_437.h"
37#include "stdio.h"
38
50#define USE_OTG_DEVICE_MODE
51
55/* #define USE_OTG_HOST_MODE */
56
61/* use otgfs1 */
62#define OTG_USB_ID 1
63
64/* use otgfs2 */
65//#define OTG_USB_ID 2
66
67#if (OTG_USB_ID == 1)
68#define USB_ID 0
69#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
70#define OTG_IRQ OTGFS1_IRQn
71#define OTG_IRQ_HANDLER OTGFS1_IRQHandler
72#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
73#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
74#define OTG_WKUP_EXINT_LINE EXINT_LINE_18
75
76#define OTG_PIN_GPIO GPIOA
77#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
78
79#define OTG_PIN_DP GPIO_PINS_12
80#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
81
82#define OTG_PIN_DM GPIO_PINS_11
83#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
84
85#define OTG_PIN_VBUS GPIO_PINS_9
86#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
87
88#define OTG_PIN_ID GPIO_PINS_10
89#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
90
91#define OTG_PIN_SOF_GPIO GPIOA
92#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
93#define OTG_PIN_SOF GPIO_PINS_8
94#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
95
96#define OTG_PIN_MUX GPIO_MUX_10
97#endif
98
99#if (OTG_USB_ID == 2)
100#define USB_ID 1
101#define OTG_CLOCK CRM_OTGFS2_PERIPH_CLOCK
102#define OTG_IRQ OTGFS2_IRQn
103#define OTG_IRQ_HANDLER OTGFS2_IRQHandler
104#define OTG_WKUP_IRQ OTGFS2_WKUP_IRQn
105#define OTG_WKUP_HANDLER OTGFS2_WKUP_IRQHandler
106#define OTG_WKUP_EXINT_LINE EXINT_LINE_20
107
108#define OTG_PIN_GPIO GPIOB
109#define OTG_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK
110
111#define OTG_PIN_DP GPIO_PINS_15
112#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE15
113
114#define OTG_PIN_DM GPIO_PINS_14
115#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE14
116
117#define OTG_PIN_VBUS GPIO_PINS_13
118#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13
119
120#define OTG_PIN_ID GPIO_PINS_12
121#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
122
123#define OTG_PIN_SOF_GPIO GPIOA
124#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
125#define OTG_PIN_SOF GPIO_PINS_4
126#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE4
127
128#define OTG_PIN_MUX GPIO_MUX_12
129#endif
130
134#ifdef USE_OTG_DEVICE_MODE
138/* otg1 device fifo */
139#define USBD_RX_SIZE 128
140#define USBD_EP0_TX_SIZE 24
141#define USBD_EP1_TX_SIZE 20
142#define USBD_EP2_TX_SIZE 20
143#define USBD_EP3_TX_SIZE 20
144#define USBD_EP4_TX_SIZE 20
145#define USBD_EP5_TX_SIZE 20
146#define USBD_EP6_TX_SIZE 20
147#define USBD_EP7_TX_SIZE 20
148
149/* otg2 device fifo */
150#define USBD2_RX_SIZE 128
151#define USBD2_EP0_TX_SIZE 24
152#define USBD2_EP1_TX_SIZE 20
153#define USBD2_EP2_TX_SIZE 20
154#define USBD2_EP3_TX_SIZE 20
155#define USBD2_EP4_TX_SIZE 20
156#define USBD2_EP5_TX_SIZE 20
157#define USBD2_EP6_TX_SIZE 20
158#define USBD2_EP7_TX_SIZE 20
159
163#ifndef USB_EPT_MAX_NUM
164#define USB_EPT_MAX_NUM 8
165#endif
166#endif
167
171#ifdef USE_OTG_HOST_MODE
172#ifndef USB_HOST_CHANNEL_NUM
173#define USB_HOST_CHANNEL_NUM 16
174#endif
175
179/* otg1 host fifo */
180#define USBH_RX_FIFO_SIZE 128
181#define USBH_NP_TX_FIFO_SIZE 96
182#define USBH_P_TX_FIFO_SIZE 96
183
184/* otg2 host fifo */
185#define USBH2_RX_FIFO_SIZE 128
186#define USBH2_NP_TX_FIFO_SIZE 96
187#define USBH2_P_TX_FIFO_SIZE 96
188#endif
189
193/* #define USB_SOF_OUTPUT_ENABLE */
194
198#define USB_VBUS_IGNORE
199
203/* #define USB_LOW_POWER_WAKUP */
204
205void usb_delay_ms(uint32_t ms);
206void usb_delay_us(uint32_t us);
207#endif
at32f435_437.h
at32f435_437 header file
at32f435_437_usb.h
at32f435_437 usb header file
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb low power wakeup handler enable
Definition: project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c:304
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c:315


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • acc
  • calibration
  • src
Functions
project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 49 of file project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • acc
  • calibration
  • src
project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • acc
  • calibration
  • src
Functions
project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • acc
  • calibration
  • src
project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while (1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while (1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while (1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while (1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • acc
  • calibration
  • src
Macros | Functions | Variables
project/at_start_f435/examples/acc/calibration/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include "usb_conf.h"
#include "usb_core.h"
#include "usbd_int.h"
#include "cdc_class.h"
#include "cdc_desc.h"

Go to the source code of this file.

Macros

#define ACC_TRIM

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...
void | ACC_IRQHandler (void)
acc interrupt handler More...
int | main (void)
main function. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

otg_core_type otg_core_struct
uint8_t | usb_buffer [256]
uint32_t | acc_c2_value = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/acc/calibration/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • acc
  • calibration
  • src
project/at_start_f435/examples/acc/calibration/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
30#include "usb_conf.h"
31#include "usb_core.h"
32#include "usbd_int.h"
33#include "cdc_class.h"
34#include "cdc_desc.h"
35
44/* usb global struct define */
45 otg_core_type otg_core_struct;
46uint8_t usb_buffer[256];
47
48void usb_clock48m_select(usb_clk48_s clk_s);
49void usb_gpio_config(void);
50void usb_low_power_wakeup_config(void);
51
52//#define ACC_CAL
53#define ACC_TRIM
54
55uint32_t acc_c2_value = 0;
56
62void usb_gpio_config(void)
63{
64 gpio_init_type gpio_init_struct;
65
66 crm_periph_clock_enable(OTG_PIN_GPIO_CLOCK, TRUE);
67 gpio_default_para_init(&gpio_init_struct);
68
69 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
70 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
71 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
72 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
73
74 /* dp and dm */
75 gpio_init_struct.gpio_pins = OTG_PIN_DP | OTG_PIN_DM;
76 gpio_init(OTG_PIN_GPIO, &gpio_init_struct);
77
78 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_DP_SOURCE, OTG_PIN_MUX);
79 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_DM_SOURCE, OTG_PIN_MUX);
80
81#ifdef USB_SOF_OUTPUT_ENABLE
82 crm_periph_clock_enable(OTG_PIN_SOF_GPIO_CLOCK, TRUE);
83 gpio_init_struct.gpio_pins = OTG_PIN_SOF;
84 gpio_init(OTG_PIN_SOF_GPIO, &gpio_init_struct);
85 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_SOF_SOURCE, OTG_PIN_MUX);
86#endif
87
88 /* otgfs use vbus pin */
89#ifndef USB_VBUS_IGNORE
90 gpio_init_struct.gpio_pins = OTG_PIN_VBUS;
91 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
92 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_VBUS_SOURCE, OTG_PIN_MUX);
93 gpio_init(OTG_PIN_GPIO, &gpio_init_struct);
94#endif
95}
96#ifdef USB_LOW_POWER_WAKUP
102void usb_low_power_wakeup_config(void)
103{
104 exint_init_type exint_init_struct;
105
106 crm_periph_clock_enable(CRM_SCFG_PERIPH_CLOCK, TRUE);
107 exint_default_para_init(&exint_init_struct);
108
109 exint_init_struct.line_enable = TRUE;
110 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
111 exint_init_struct.line_select = OTG_WKUP_EXINT_LINE;
112 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
113 exint_init(&exint_init_struct);
114
115 nvic_irq_enable(OTG_WKUP_IRQ, 0, 0);
116}
117
123void OTG_WKUP_HANDLER(void)
124{
125 exint_flag_clear(OTG_WKUP_EXINT_LINE);
126}
127
128#endif
129
135void OTG_IRQ_HANDLER(void)
136{
137 usbd_irq_handler(&otg_core_struct);
138}
144void ACC_IRQHandler(void)
145{
146 if(acc_flag_get(ACC_CALRDY_FLAG) != RESET)
147 {
148 at32_led_toggle(LED2);
149
150 /* clear acc calibration ready flag */
151 acc_flag_clear(ACC_CALRDY_FLAG);
152 }
153 if(acc_flag_get(ACC_RSLOST_FLAG) != RESET)
154 {
155 at32_led_toggle(LED3);
156
157 /* clear acc reference signal lost flag */
158 acc_flag_clear(ACC_RSLOST_FLAG);
159 }
160}
161
167int main(void)
168{
169 uint16_t data_len;
170
171 uint8_t send_zero_packet = 0;
172
173 uint32_t timeout;
174
175 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
176
177 system_clock_config();
178
179 at32_board_init();
180
181 usb_gpio_config();
182#ifdef USB_LOW_POWER_WAKUP
183 usb_low_power_wakeup_config();
184#endif
185
186 /* enable otgfs clock */
187 crm_periph_clock_enable(OTG_CLOCK, TRUE);
188
189 /* select usb 48m clcok source */
190 usb_clock48m_select(USB_CLK_HICK);
191
192 /* enable otgfs irq */
193 nvic_irq_enable(OTG_IRQ, 0, 0);
194
195 /* init usb */
196 usbd_init(&otg_core_struct,
197 USB_FULL_SPEED_CORE_ID,
198 USB_ID,
199 &cdc_class_handler,
200 &cdc_desc_handler);
201
202
203 /* acc config */
204 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
205
206 /* enable the acc calibration ready interrupt */
207 acc_interrupt_enable(ACC_CALRDYIEN_INT, TRUE);
208
209 /* enable the acc reference signal lost interrupt */
210 acc_interrupt_enable(ACC_EIEN_INT, TRUE);
211
212 /* config nvic for acc int */
213 nvic_irq_enable(ACC_IRQn, 1, 0);
214
215 /* update the c1\c2\c3 value */
216 acc_c2_value = 8000;
217 #ifdef ACC_CAL
218 acc_write_c1(acc_c2_value - 20);
219 acc_write_c2(acc_c2_value);
220 acc_write_c3(acc_c2_value + 20);
221 #else
222 acc_write_c1(acc_c2_value - 10);
223 acc_write_c2(acc_c2_value);
224 acc_write_c3(acc_c2_value + 10);
225 #endif
226
227 #if (USB_ID == 0)
228 acc_sof_select(ACC_SOF_OTG1);
229#else
230 acc_sof_select(ACC_SOF_OTG2);
231#endif
232
233 /* open acc calibration */
234 #if defined(ACC_CAL)
235 acc_calibration_mode_enable(ACC_CAL_HICKCAL, TRUE);
236 #elif defined(ACC_TRIM)
237 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
238 #endif
239
240 while(1)
241 {
242 /* get usb vcp receive data */
243 data_len = usb_vcp_get_rxdata(&otg_core_struct.dev, usb_buffer);
244
245 if(data_len > 0 || send_zero_packet == 1)
246 {
247
248 /* bulk transfer is complete when the endpoint does one of the following
249 1 has transferred exactly the amount of data expected
250 2 transfers a packet with a payload size less than wMaxPacketSize or transfers a zero-length packet
251 */
252 if(data_len > 0)
253 send_zero_packet = 1;
254
255 if(data_len == 0)
256 send_zero_packet = 0;
257
258 timeout = 5000000;
259 do
260 {
261 /* send data to host */
262 if(usb_vcp_send_data(&otg_core_struct.dev, usb_buffer, data_len) == SUCCESS)
263 {
264 break;
265 }
266 }while(timeout --);
267 }
268 }
269}
270
276void usb_clock48m_select(usb_clk48_s clk_s)
277{
278 if(clk_s == USB_CLK_HICK)
279 {
280 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
281 }
282 else
283 {
284 switch(system_core_clock)
285 {
286 /* 48MHz */
287 case 48000000:
288 crm_usb_clock_div_set(CRM_USB_DIV_1);
289 break;
290
291 /* 72MHz */
292 case 72000000:
293 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
294 break;
295
296 /* 96MHz */
297 case 96000000:
298 crm_usb_clock_div_set(CRM_USB_DIV_2);
299 break;
300
301 /* 120MHz */
302 case 120000000:
303 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
304 break;
305
306 /* 144MHz */
307 case 144000000:
308 crm_usb_clock_div_set(CRM_USB_DIV_3);
309 break;
310
311 /* 168MHz */
312 case 168000000:
313 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
314 break;
315
316 /* 192MHz */
317 case 192000000:
318 crm_usb_clock_div_set(CRM_USB_DIV_4);
319 break;
320
321 /* 216MHz */
322 case 216000000:
323 crm_usb_clock_div_set(CRM_USB_DIV_4_5);
324 break;
325
326 /* 240MHz */
327 case 240000000:
328 crm_usb_clock_div_set(CRM_USB_DIV_5);
329 break;
330
331 /* 264MHz */
332 case 264000000:
333 crm_usb_clock_div_set(CRM_USB_DIV_5_5);
334 break;
335
336 /* 288MHz */
337 case 288000000:
338 crm_usb_clock_div_set(CRM_USB_DIV_6);
339 break;
340
341 default:
342 break;
343
344 }
345 }
346}
347
353void usb_delay_ms(uint32_t ms)
354{
355 /* user can define self delay function */
356 delay_ms(ms);
357}
358
364void usb_delay_us(uint32_t us)
365{
366 delay_us(us);
367}
368
at32f435_437_board.h
cdc_class.h
usb cdc class file
cdc_desc.h
usb cdc descriptor header file
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f435/examples/acc/calibration/src/main.c:276
ACC_IRQHandler
void ACC_IRQHandler(void)
acc interrupt handler
Definition: project/at_start_f435/examples/acc/calibration/src/main.c:144
main
int main(void)
main function.
Definition: project/at_start_f435/examples/acc/calibration/src/main.c:167
usb_low_power_wakeup_config
void usb_low_power_wakeup_config(void)
usb_gpio_config
void usb_gpio_config(void)
this function config gpio.
Definition: project/at_start_f435/examples/acc/calibration/src/main.c:62
OTG_IRQ_HANDLER
void OTG_IRQ_HANDLER(void)
this function handles otgfs interrupt.
Definition: project/at_start_f435/examples/acc/calibration/src/main.c:135
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f435/examples/acc/calibration/src/main.c:353
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f435/examples/acc/calibration/src/main.c:364
usb_buffer
uint8_t usb_buffer[256]
Definition: project/at_start_f435/examples/acc/calibration/src/main.c:46
otg_core_struct
otg_core_type otg_core_struct
Definition: project/at_start_f435/examples/acc/calibration/src/main.c:45
acc_c2_value
uint32_t acc_c2_value
Definition: project/at_start_f435/examples/acc/calibration/src/main.c:55
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:41
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
OTG_PIN_VBUS
#define OTG_PIN_VBUS
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:85
OTG_PIN_DM
#define OTG_PIN_DM
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:82
OTG_PIN_DP
#define OTG_PIN_DP
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:79
OTG_PIN_SOF
#define OTG_PIN_SOF
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:93
OTG_WKUP_IRQ
#define OTG_WKUP_IRQ
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:72
OTG_PIN_DP_SOURCE
#define OTG_PIN_DP_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:80
OTG_PIN_GPIO
#define OTG_PIN_GPIO
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:76
OTG_IRQ
#define OTG_IRQ
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:70
OTG_PIN_SOF_GPIO
#define OTG_PIN_SOF_GPIO
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:91
OTG_WKUP_HANDLER
#define OTG_WKUP_HANDLER
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:73
OTG_CLOCK
#define OTG_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:69
OTG_PIN_GPIO_CLOCK
#define OTG_PIN_GPIO_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:77
OTG_PIN_SOF_SOURCE
#define OTG_PIN_SOF_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:94
OTG_PIN_VBUS_SOURCE
#define OTG_PIN_VBUS_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:86
USB_ID
#define USB_ID
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:68
OTG_PIN_DM_SOURCE
#define OTG_PIN_DM_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:83
OTG_PIN_MUX
#define OTG_PIN_MUX
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:96
OTG_WKUP_EXINT_LINE
#define OTG_WKUP_EXINT_LINE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:74
OTG_PIN_SOF_GPIO_CLOCK
#define OTG_PIN_SOF_GPIO_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:92
data_len
uint16_t data_len
Definition: project/at_start_f435/examples/usb_device/virtual_comport/src/main.c:47
ACC_CAL_HICKCAL
#define ACC_CAL_HICKCAL
Definition: at32f435_437_acc.h:51
ACC_RSLOST_FLAG
#define ACC_RSLOST_FLAG
Definition: at32f435_437_acc.h:54
ACC_EIEN_INT
#define ACC_EIEN_INT
Definition: at32f435_437_acc.h:58
ACC_SOF_OTG2
#define ACC_SOF_OTG2
Definition: at32f435_437_acc.h:61
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f435_437_acc.h:52
ACC_CALRDYIEN_INT
#define ACC_CALRDYIEN_INT
Definition: at32f435_437_acc.h:57
ACC_CALRDY_FLAG
#define ACC_CALRDY_FLAG
Definition: at32f435_437_acc.h:55
ACC_SOF_OTG1
#define ACC_SOF_OTG1
Definition: at32f435_437_acc.h:60
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f435_437_acc.c:145
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f435_437_acc.c:155
acc_interrupt_enable
void acc_interrupt_enable(uint16_t acc_int, confirm_state new_state)
enable or disable the specified acc interrupts.
Definition: at32f435_437_acc.c:98
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f435_437_acc.c:135
acc_flag_get
flag_status acc_flag_get(uint16_t acc_flag)
check whether the specified acc flag is set or not.
Definition: at32f435_437_acc.c:198
acc_sof_select
void acc_sof_select(uint16_t sof_sel)
select sof sourse for acc in acc's ctrl1 register.
Definition: at32f435_437_acc.c:84
acc_flag_clear
void acc_flag_clear(uint16_t acc_flag)
clear the specified acc flag is set or not.
Definition: at32f435_437_acc.c:214
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f435_437_acc.c:53
system_core_clock
unsigned int system_core_clock
Definition: system_at32f435_437.c:48
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f435_437_board.c:306
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type value)
set usb division
Definition: at32f435_437_crm.c:521
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f435_437_crm.c:594
CRM_SCFG_PERIPH_CLOCK
@ CRM_SCFG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:163
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:168
CRM_USB_DIV_5
@ CRM_USB_DIV_5
Definition: at32f435_437_crm.h:620
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f435_437_crm.h:616
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f435_437_crm.h:611
CRM_USB_DIV_5_5
@ CRM_USB_DIV_5_5
Definition: at32f435_437_crm.h:619
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f435_437_crm.h:618
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f435_437_crm.h:615
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f435_437_crm.h:614
CRM_USB_DIV_6
@ CRM_USB_DIV_6
Definition: at32f435_437_crm.h:622
CRM_USB_DIV_4_5
@ CRM_USB_DIV_4_5
Definition: at32f435_437_crm.h:617
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f435_437_crm.h:612
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f435_437_crm.h:613
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f435_437_crm.h:763
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f435_437_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
usb_vcp_get_rxdata
uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_class.c:339
usb_vcp_send_data
error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_class.c:369
cdc_class_handler
usbd_class_handler cdc_class_handler
Definition: cdc_class.c:69
cdc_desc_handler
usbd_desc_handler cdc_desc_handler
device descriptor handler structure
Definition: cdc_desc.c:64
USB_FULL_SPEED_CORE_ID
@ USB_FULL_SPEED_CORE_ID
Definition: usb_core.h:64
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f435_437_usb.h:402
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f435_437_usb.h:403
usbd_irq_handler
void usbd_irq_handler(otg_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
ACC_IRQn
@ ACC_IRQn
Definition: at32f435_437.h:230
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
otg_core_type
usb otg core struct type
Definition: usb_core.h:92
usb_core.h
usb core header file
usbd_int.h
usb interrupt header file
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma3
  • inc
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma3
  • inc
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma3
  • inc
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma3
  • src
Functions
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 49 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma3
  • src
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_clock.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma3
  • src
Functions | Variables
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...

Variables

__IO uint32_t | dma1_trans_complete_flag
__IO uint32_t | adc1_overflow_flag
__IO uint32_t | adc2_overflow_flag
__IO uint32_t | adc3_overflow_flag

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma3
  • src
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
38extern __IO uint32_t dma1_trans_complete_flag;
39extern __IO uint32_t adc1_overflow_flag;
40extern __IO uint32_t adc2_overflow_flag;
41extern __IO uint32_t adc3_overflow_flag;
42
48void NMI_Handler(void)
49{
50}
51
57void HardFault_Handler(void)
58{
59 /* go to infinite loop when hard fault exception occurs */
60 while(1)
61 {
62 }
63}
64
70void MemManage_Handler(void)
71{
72 /* go to infinite loop when memory manage exception occurs */
73 while(1)
74 {
75 }
76}
77
83void BusFault_Handler(void)
84{
85 /* go to infinite loop when bus fault exception occurs */
86 while(1)
87 {
88 }
89}
90
96void UsageFault_Handler(void)
97{
98 /* go to infinite loop when usage fault exception occurs */
99 while(1)
100 {
101 }
102}
103
109void SVC_Handler(void)
110{
111}
112
118void DebugMon_Handler(void)
119{
120}
121
127void PendSV_Handler(void)
128{
129}
130
136void SysTick_Handler(void)
137{
138}
139
145void DMA1_Channel1_IRQHandler(void)
146{
147 if(dma_flag_get(DMA1_FDT1_FLAG) != RESET)
148 {
149 dma_flag_clear(DMA1_FDT1_FLAG);
150 dma1_trans_complete_flag = 1;
151 }
152}
153
159void ADC1_2_3_IRQHandler(void)
160{
161 if(adc_flag_get(ADC1, ADC_OCCO_FLAG) != RESET)
162 {
163 adc_flag_clear(ADC1, ADC_OCCO_FLAG);
164 adc1_overflow_flag++;
165 }
166 if(adc_flag_get(ADC2, ADC_OCCO_FLAG) != RESET)
167 {
168 adc_flag_clear(ADC2, ADC_OCCO_FLAG);
169 adc2_overflow_flag++;
170 }
171 if(adc_flag_get(ADC3, ADC_OCCO_FLAG) != RESET)
172 {
173 adc_flag_clear(ADC3, ADC_OCCO_FLAG);
174 adc3_overflow_flag++;
175 }
176}
177
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c:96
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c:57
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c:70
adc3_overflow_flag
__IO uint32_t adc3_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:42
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c:109
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:40
ADC1_2_3_IRQHandler
void ADC1_2_3_IRQHandler(void)
this function handles adc1_2_3 handler.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c:159
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c:127
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c:48
dma1_trans_complete_flag
__IO uint32_t dma1_trans_complete_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:39
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1_channel1 handler.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c:145
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c:83
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c:136
adc2_overflow_flag
__IO uint32_t adc2_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:41
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c:118
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1106
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
ADC_OCCO_FLAG
#define ADC_OCCO_FLAG
Definition: at32f435_437_adc.h:72
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
ADC2
#define ADC2
Definition: at32f435_437_adc.h:867
ADC3
#define ADC3
Definition: at32f435_437_adc.h:868
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f435_437_dma.h:66
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma3
  • src
Functions | Variables
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | tmr1_config (void)
tmr1 configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adccom_ordinary_valuetab [6]
__IO uint32_t | dma1_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint32_t | adc2_overflow_flag = 0
__IO uint32_t | adc3_overflow_flag = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma3
  • src
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38__IO uint16_t adccom_ordinary_valuetab[6];
39__IO uint32_t dma1_trans_complete_flag = 0;
40__IO uint32_t adc1_overflow_flag = 0;
41__IO uint32_t adc2_overflow_flag = 0;
42__IO uint32_t adc3_overflow_flag = 0;
43
44static void gpio_config(void);
45static void tmr1_config(void);
46static void dma_config(void);
47static void adc_config(void);
48
54static void gpio_config(void)
55{
56 gpio_init_type gpio_initstructure;
57 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
58 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
59 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
60
61 gpio_default_para_init(&gpio_initstructure);
62
63 /* config adc pin as analog input mode */
64 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
65 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_7;
66 gpio_init(GPIOA, &gpio_initstructure);
67
68 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
69 gpio_initstructure.gpio_pins = GPIO_PINS_0;
70 gpio_init(GPIOC, &gpio_initstructure);
71}
72
78static void tmr1_config(void)
79{
80 crm_clocks_freq_type crm_clocks_freq_struct = {0};
81
82 /* get system clock */
83 crm_clocks_freq_get(&crm_clocks_freq_struct);
84
85 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
86
87 /* (systemclock/(systemclock/10000))/1000 = 10Hz(100ms) */
88 tmr_base_init(TMR1, 999, (crm_clocks_freq_struct.sclk_freq/10000 - 1));
89 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
90 tmr_clock_source_div_set(TMR1, TMR_CLOCK_DIV1);
91 tmr_primary_mode_select(TMR1, TMR_PRIMARY_SEL_OVERFLOW);
92}
93
99static void dma_config(void)
100{
101 dma_init_type dma_init_struct;
102 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
103 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
104
105 dma_reset(DMA1_CHANNEL1);
106 dma_default_para_init(&dma_init_struct);
107 dma_init_struct.buffer_size = 6;
108 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
109 dma_init_struct.memory_base_addr = (uint32_t)adccom_ordinary_valuetab;
110 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
111 dma_init_struct.memory_inc_enable = TRUE;
112 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADCCOM->codt);
113 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
114 dma_init_struct.peripheral_inc_enable = FALSE;
115 dma_init_struct.priority = DMA_PRIORITY_HIGH;
116 dma_init_struct.loop_mode_enable = FALSE;
117 dma_init(DMA1_CHANNEL1, &dma_init_struct);
118
119 dmamux_enable(DMA1, TRUE);
120 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_ADC1);
121
122 /* enable dma transfer complete interrupt */
123 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
124 dma_channel_enable(DMA1_CHANNEL1, TRUE);
125}
126
132static void adc_config(void)
133{
134 adc_common_config_type adc_common_struct;
135 adc_base_config_type adc_base_struct;
136 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
137 crm_periph_clock_enable(CRM_ADC2_PERIPH_CLOCK, TRUE);
138 crm_periph_clock_enable(CRM_ADC3_PERIPH_CLOCK, TRUE);
139 nvic_irq_enable(ADC1_2_3_IRQn, 0, 0);
140
141 adc_common_default_para_init(&adc_common_struct);
142
143 /* config combine mode */
144 adc_common_struct.combine_mode = ADC_ORDINARY_SHIFT_ONLY_TWOSLAVE_MODE;
145
146 /* config division,adcclk is division by hclk */
147 adc_common_struct.div = ADC_HCLK_DIV_4;
148
149 /* config common dma mode,it's useful for ordinary group in combine mode */
150 adc_common_struct.common_dma_mode = ADC_COMMON_DMAMODE_3;
151
152 /* config common dma request repeat */
153 adc_common_struct.common_dma_request_repeat_state = FALSE;
154
155 /* config adjacent adc sampling interval,it's useful for ordinary shifting mode */
156 adc_common_struct.sampling_interval = ADC_SAMPLING_INTERVAL_20CYCLES;
157
158 /* config inner temperature sensor and vintrv */
159 adc_common_struct.tempervintrv_state = FALSE;
160
161 /* config voltage battery */
162 adc_common_struct.vbat_state = FALSE;
163 adc_common_config(&adc_common_struct);
164
165 adc_base_default_para_init(&adc_base_struct);
166
167 adc_base_struct.sequence_mode = FALSE;
168 adc_base_struct.repeat_mode = FALSE;
169 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
170 adc_base_struct.ordinary_channel_length = 1;
171 adc_base_config(ADC1, &adc_base_struct);
172
173 adc_resolution_set(ADC1, ADC_RESOLUTION_12B);
174
175 /* config ordinary channel */
176 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_2_5);
177
178 /* config ordinary trigger source and trigger edge */
179 adc_ordinary_conversion_trigger_set(ADC1, ADC_ORDINARY_TRIG_TMR1TRGOUT, ADC_ORDINARY_TRIG_EDGE_RISING);
180
181 /* config dma mode,it's not useful when common dma mode is use */
182 adc_dma_mode_enable(ADC1, FALSE);
183
184 /* config dma request repeat,it's not useful when common dma mode is use */
185 adc_dma_request_repeat_enable(ADC1, FALSE);
186
187 /* enable adc overflow interrupt */
188 adc_interrupt_enable(ADC1, ADC_OCCO_INT, TRUE);
189
190 adc_base_config(ADC2, &adc_base_struct);
191 adc_resolution_set(ADC2, ADC_RESOLUTION_12B);
192 adc_ordinary_channel_set(ADC2, ADC_CHANNEL_7, 1, ADC_SAMPLETIME_2_5);
193 adc_ordinary_conversion_trigger_set(ADC2, ADC_ORDINARY_TRIG_TMR1TRGOUT, ADC_ORDINARY_TRIG_EDGE_NONE);
194 adc_dma_mode_enable(ADC2, FALSE);
195 adc_dma_request_repeat_enable(ADC2, FALSE);
196 adc_interrupt_enable(ADC2, ADC_OCCO_INT, TRUE);
197
198 adc_base_config(ADC3, &adc_base_struct);
199 adc_resolution_set(ADC3, ADC_RESOLUTION_12B);
200 adc_ordinary_channel_set(ADC3, ADC_CHANNEL_10, 1, ADC_SAMPLETIME_2_5);
201 adc_ordinary_conversion_trigger_set(ADC3, ADC_ORDINARY_TRIG_TMR1TRGOUT, ADC_ORDINARY_TRIG_EDGE_NONE);
202 adc_dma_mode_enable(ADC3, FALSE);
203 adc_dma_request_repeat_enable(ADC3, FALSE);
204 adc_interrupt_enable(ADC3, ADC_OCCO_INT, TRUE);
205
206 /* adc enable */
207 adc_enable(ADC1, TRUE);
208 adc_enable(ADC2, TRUE);
209 adc_enable(ADC3, TRUE);
210 while(adc_flag_get(ADC1, ADC_RDY_FLAG) == RESET);
211 while(adc_flag_get(ADC2, ADC_RDY_FLAG) == RESET);
212 while(adc_flag_get(ADC3, ADC_RDY_FLAG) == RESET);
213
214 /* adc calibration */
215 adc_calibration_init(ADC1);
216 while(adc_calibration_init_status_get(ADC1));
217 adc_calibration_start(ADC1);
218 while(adc_calibration_status_get(ADC1));
219 adc_calibration_init(ADC2);
220 while(adc_calibration_init_status_get(ADC2));
221 adc_calibration_start(ADC2);
222 while(adc_calibration_status_get(ADC2));
223 adc_calibration_init(ADC3);
224 while(adc_calibration_init_status_get(ADC3));
225 adc_calibration_start(ADC3);
226 while(adc_calibration_status_get(ADC3));
227
228 /*set resolution to 8bit.this because calibration must perform at 12 bit resolution */
229 adc_resolution_set(ADC1,ADC_RESOLUTION_8B);
230 adc_resolution_set(ADC2,ADC_RESOLUTION_8B);
231 adc_resolution_set(ADC3,ADC_RESOLUTION_8B);
232 while(adc_flag_get(ADC1, ADC_RDY_FLAG) == RESET);
233 while(adc_flag_get(ADC2, ADC_RDY_FLAG) == RESET);
234 while(adc_flag_get(ADC3, ADC_RDY_FLAG) == RESET);
235}
236
242int main(void)
243{
244 __IO uint32_t index = 0;
245 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
246
247 /* config the system clock */
248 system_clock_config();
249
250 /* init at start board */
251 at32_board_init();
252 at32_led_off(LED2);
253 at32_led_off(LED3);
254 at32_led_off(LED4);
255 uart_print_init(115200);
256 gpio_config();
257 tmr1_config();
258 dma_config();
259 adc_config();
260 printf("combine_mode_ordinary_shift_twoslave_dma3 \r\n");
261 tmr_counter_enable(TMR1, TRUE);
262 while(dma1_trans_complete_flag == 0);
263 tmr_counter_enable(TMR1, FALSE);
264 if((adc1_overflow_flag != 0) || (adc2_overflow_flag != 0) || (adc3_overflow_flag != 0))
265 {
266 /* printf flag when error occur */
267 at32_led_on(LED3);
268 at32_led_on(LED4);
269 printf("error occur\r\n");
270 printf("adc1_overflow_flag = %d\r\n",adc1_overflow_flag);
271 printf("adc2_overflow_flag = %d\r\n",adc2_overflow_flag);
272 printf("adc3_overflow_flag = %d\r\n",adc3_overflow_flag);
273 }
274 else
275 {
276 /* printf data when conversion end without error */
277 printf("conversion end without error\r\n");
278 for(index = 0; index < 6; index++)
279 {
280 printf("adccom_ordinary_valuetab[%d] = 0x%x\r\n",index, adccom_ordinary_valuetab[index]);
281 }
282 printf("\r\n");
283 }
284 at32_led_on(LED2);
285 while(1)
286 {
287 }
288}
289
at32f435_437_board.h
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:99
adc3_overflow_flag
__IO uint32_t adc3_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:42
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:40
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:132
adccom_ordinary_valuetab
__IO uint16_t adccom_ordinary_valuetab[6]
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:38
dma1_trans_complete_flag
__IO uint32_t dma1_trans_complete_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:242
tmr1_config
static void tmr1_config(void)
tmr1 configuration.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:78
adc2_overflow_flag
__IO uint32_t adc2_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:41
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:54
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:40
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc ...
Definition: at32f435_437_adc.c:742
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f435_437_adc.c:110
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f435_437_adc.c:64
adc_common_config
void adc_common_config(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:203
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f435_437_adc.c:294
adc_resolution_set
void adc_resolution_set(adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral.
Definition: at32f435_437_adc.c:235
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f435_437_adc.c:84
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f435_437_adc.c:359
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f435_437_adc.c:371
adc_dma_request_repeat_enable
void adc_dma_request_repeat_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat.
Definition: at32f435_437_adc.c:274
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f435_437_adc.c:328
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f435_437_adc.c:340
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f435_437_adc.c:260
adc_common_default_para_init
void adc_common_default_para_init(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:155
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f435_437_adc.c:472
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f435_437_adc.h:178
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f435_437_adc.h:191
ADC_CHANNEL_10
@ ADC_CHANNEL_10
Definition: at32f435_437_adc.h:197
ADC_CHANNEL_7
@ ADC_CHANNEL_7
Definition: at32f435_437_adc.h:194
ADC_SAMPLETIME_2_5
@ ADC_SAMPLETIME_2_5
Definition: at32f435_437_adc.h:213
ADC_SAMPLING_INTERVAL_20CYCLES
@ ADC_SAMPLING_INTERVAL_20CYCLES
Definition: at32f435_437_adc.h:159
ADC_COMMON_DMAMODE_3
@ ADC_COMMON_DMAMODE_3
Definition: at32f435_437_adc.h:134
ADC_ORDINARY_SHIFT_ONLY_TWOSLAVE_MODE
@ ADC_ORDINARY_SHIFT_ONLY_TWOSLAVE_MODE
Definition: at32f435_437_adc.h:122
ADC_ORDINARY_TRIG_TMR1TRGOUT
@ ADC_ORDINARY_TRIG_TMR1TRGOUT
Definition: at32f435_437_adc.h:255
ADC_ORDINARY_TRIG_EDGE_RISING
@ ADC_ORDINARY_TRIG_EDGE_RISING
Definition: at32f435_437_adc.h:266
ADC_ORDINARY_TRIG_EDGE_NONE
@ ADC_ORDINARY_TRIG_EDGE_NONE
Definition: at32f435_437_adc.h:265
ADC_RESOLUTION_12B
@ ADC_RESOLUTION_12B
Definition: at32f435_437_adc.h:167
ADC_RESOLUTION_8B
@ ADC_RESOLUTION_8B
Definition: at32f435_437_adc.h:169
ADC_HCLK_DIV_4
@ ADC_HCLK_DIV_4
Definition: at32f435_437_adc.h:90
ADC_RDY_FLAG
#define ADC_RDY_FLAG
Definition: at32f435_437_adc.h:73
ADC_OCCO_INT
#define ADC_OCCO_INT
Definition: at32f435_437_adc.h:56
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
ADC2
#define ADC2
Definition: at32f435_437_adc.h:867
ADC3
#define ADC3
Definition: at32f435_437_adc.h:868
ADCCOM
#define ADCCOM
Definition: at32f435_437_adc.h:869
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_ADC3_PERIPH_CLOCK
@ CRM_ADC3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:160
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:158
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:154
CRM_ADC2_PERIPH_CLOCK
@ CRM_ADC2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:159
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_ADC1
@ DMAMUX_DMAREQ_ID_ADC1
Definition: at32f435_437_dma.h:197
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f435_437_gpio.h:85
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_primary_mode_select
void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode
Definition: at32f435_437_tmr.c:1222
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f435_437_tmr.h:97
TMR_PRIMARY_SEL_OVERFLOW
@ TMR_PRIMARY_SEL_OVERFLOW
Definition: at32f435_437_tmr.h:121
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f435_437.h:204
ADC1_2_3_IRQn
@ ADC1_2_3_IRQn
Definition: at32f435_437.h:166
adc_base_config_type
adc base config type
Definition: at32f435_437_adc.h:402
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f435_437_adc.h:405
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f435_437_adc.h:404
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f435_437_adc.h:403
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f435_437_adc.h:406
adc_common_config_type
adc common config type
Definition: at32f435_437_adc.h:388
adc_common_config_type::sampling_interval
adc_sampling_interval_type sampling_interval
Definition: at32f435_437_adc.h:393
adc_common_config_type::tempervintrv_state
confirm_state tempervintrv_state
Definition: at32f435_437_adc.h:394
adc_common_config_type::div
adc_div_type div
Definition: at32f435_437_adc.h:390
adc_common_config_type::common_dma_mode
adc_common_dma_mode_type common_dma_mode
Definition: at32f435_437_adc.h:391
adc_common_config_type::common_dma_request_repeat_state
confirm_state common_dma_request_repeat_state
Definition: at32f435_437_adc.h:392
adc_common_config_type::combine_mode
adc_combine_mode_type combine_mode
Definition: at32f435_437_adc.h:389
adc_common_config_type::vbat_state
confirm_state vbat_state
Definition: at32f435_437_adc.h:395
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f435_437_crm.h:789
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma4
  • inc
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma4
  • inc
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma4
  • inc
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma4
  • src
Functions
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 49 of file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma4
  • src
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_clock.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma4
  • src
Functions | Variables
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...

Variables

__IO uint32_t | dma1_trans_complete_flag
__IO uint32_t | adc1_overflow_flag
__IO uint32_t | adc2_overflow_flag
__IO uint32_t | adc3_overflow_flag

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma4
  • src
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
38extern __IO uint32_t dma1_trans_complete_flag;
39extern __IO uint32_t adc1_overflow_flag;
40extern __IO uint32_t adc2_overflow_flag;
41extern __IO uint32_t adc3_overflow_flag;
42
48void NMI_Handler(void)
49{
50}
51
57void HardFault_Handler(void)
58{
59 /* go to infinite loop when hard fault exception occurs */
60 while(1)
61 {
62 }
63}
64
70void MemManage_Handler(void)
71{
72 /* go to infinite loop when memory manage exception occurs */
73 while(1)
74 {
75 }
76}
77
83void BusFault_Handler(void)
84{
85 /* go to infinite loop when bus fault exception occurs */
86 while(1)
87 {
88 }
89}
90
96void UsageFault_Handler(void)
97{
98 /* go to infinite loop when usage fault exception occurs */
99 while(1)
100 {
101 }
102}
103
109void SVC_Handler(void)
110{
111}
112
118void DebugMon_Handler(void)
119{
120}
121
127void PendSV_Handler(void)
128{
129}
130
136void SysTick_Handler(void)
137{
138}
139
145void DMA1_Channel1_IRQHandler(void)
146{
147 if(dma_flag_get(DMA1_FDT1_FLAG) != RESET)
148 {
149 dma_flag_clear(DMA1_FDT1_FLAG);
150 dma1_trans_complete_flag = 1;
151 }
152}
153
159void ADC1_2_3_IRQHandler(void)
160{
161 if(adc_flag_get(ADC1, ADC_OCCO_FLAG) != RESET)
162 {
163 adc_flag_clear(ADC1, ADC_OCCO_FLAG);
164 adc1_overflow_flag++;
165 }
166 if(adc_flag_get(ADC2, ADC_OCCO_FLAG) != RESET)
167 {
168 adc_flag_clear(ADC2, ADC_OCCO_FLAG);
169 adc2_overflow_flag++;
170 }
171 if(adc_flag_get(ADC3, ADC_OCCO_FLAG) != RESET)
172 {
173 adc_flag_clear(ADC3, ADC_OCCO_FLAG);
174 adc3_overflow_flag++;
175 }
176}
177
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c:96
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c:57
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c:70
adc3_overflow_flag
__IO uint32_t adc3_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:42
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c:109
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:40
ADC1_2_3_IRQHandler
void ADC1_2_3_IRQHandler(void)
this function handles adc1_2_3 handler.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c:159
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c:127
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c:48
dma1_trans_complete_flag
__IO uint32_t dma1_trans_complete_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:39
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1_channel1 handler.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c:145
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c:83
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c:136
adc2_overflow_flag
__IO uint32_t adc2_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:41
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/at32f435_437_int.c:118
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1106
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
ADC_OCCO_FLAG
#define ADC_OCCO_FLAG
Definition: at32f435_437_adc.h:72
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
ADC2
#define ADC2
Definition: at32f435_437_adc.h:867
ADC3
#define ADC3
Definition: at32f435_437_adc.h:868
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f435_437_dma.h:66
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma4
  • src
Functions | Variables
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | tmr1_config (void)
tmr1 configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | adccom_ordinary_valuetab [5]
__IO uint32_t | dma1_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint32_t | adc2_overflow_flag = 0
__IO uint32_t | adc3_overflow_flag = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_shift_twoslave_dma4
  • src
project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38__IO uint32_t adccom_ordinary_valuetab[5];
39__IO uint32_t dma1_trans_complete_flag = 0;
40__IO uint32_t adc1_overflow_flag = 0;
41__IO uint32_t adc2_overflow_flag = 0;
42__IO uint32_t adc3_overflow_flag = 0;
43
44static void gpio_config(void);
45static void tmr1_config(void);
46static void dma_config(void);
47static void adc_config(void);
48
54static void gpio_config(void)
55{
56 gpio_init_type gpio_initstructure;
57 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
58 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
59 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
60
61 gpio_default_para_init(&gpio_initstructure);
62
63 /* config adc pin as analog input mode */
64 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
65 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_7;
66 gpio_init(GPIOA, &gpio_initstructure);
67
68 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
69 gpio_initstructure.gpio_pins = GPIO_PINS_0;
70 gpio_init(GPIOC, &gpio_initstructure);
71}
72
78static void tmr1_config(void)
79{
80 crm_clocks_freq_type crm_clocks_freq_struct = {0};
81
82 /* get system clock */
83 crm_clocks_freq_get(&crm_clocks_freq_struct);
84
85 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
86
87 /* (systemclock/(systemclock/10000))/1000 = 10Hz(100ms) */
88 tmr_base_init(TMR1, 999, (crm_clocks_freq_struct.sclk_freq/10000 - 1));
89 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
90 tmr_clock_source_div_set(TMR1, TMR_CLOCK_DIV1);
91 tmr_primary_mode_select(TMR1, TMR_PRIMARY_SEL_OVERFLOW);
92}
93
99static void dma_config(void)
100{
101 dma_init_type dma_init_struct;
102 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
103 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
104
105 dma_reset(DMA1_CHANNEL1);
106 dma_default_para_init(&dma_init_struct);
107 dma_init_struct.buffer_size = 5;
108 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
109 dma_init_struct.memory_base_addr = (uint32_t)adccom_ordinary_valuetab;
110 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_WORD;
111 dma_init_struct.memory_inc_enable = TRUE;
112 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADCCOM->codt);
113 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_WORD;
114 dma_init_struct.peripheral_inc_enable = FALSE;
115 dma_init_struct.priority = DMA_PRIORITY_HIGH;
116 dma_init_struct.loop_mode_enable = FALSE;
117 dma_init(DMA1_CHANNEL1, &dma_init_struct);
118
119 dmamux_enable(DMA1, TRUE);
120 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_ADC1);
121
122 /* enable dma transfer complete interrupt */
123 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
124 dma_channel_enable(DMA1_CHANNEL1, TRUE);
125}
126
132static void adc_config(void)
133{
134 adc_common_config_type adc_common_struct;
135 adc_base_config_type adc_base_struct;
136 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
137 crm_periph_clock_enable(CRM_ADC2_PERIPH_CLOCK, TRUE);
138 crm_periph_clock_enable(CRM_ADC3_PERIPH_CLOCK, TRUE);
139 nvic_irq_enable(ADC1_2_3_IRQn, 0, 0);
140
141 adc_common_default_para_init(&adc_common_struct);
142
143 /* config combine mode */
144 adc_common_struct.combine_mode = ADC_ORDINARY_SHIFT_ONLY_TWOSLAVE_MODE;
145
146 /* config division,adcclk is division by hclk */
147 adc_common_struct.div = ADC_HCLK_DIV_4;
148
149 /* config common dma mode,it's useful for ordinary group in combine mode */
150 adc_common_struct.common_dma_mode = ADC_COMMON_DMAMODE_4;
151
152 /* config common dma request repeat */
153 adc_common_struct.common_dma_request_repeat_state = FALSE;
154
155 /* config adjacent adc sampling interval,it's useful for ordinary shifting mode */
156 adc_common_struct.sampling_interval = ADC_SAMPLING_INTERVAL_20CYCLES;
157
158 /* config inner temperature sensor and vintrv */
159 adc_common_struct.tempervintrv_state = FALSE;
160
161 /* config voltage battery */
162 adc_common_struct.vbat_state = FALSE;
163 adc_common_config(&adc_common_struct);
164
165 adc_base_default_para_init(&adc_base_struct);
166
167 adc_base_struct.sequence_mode = FALSE;
168 adc_base_struct.repeat_mode = FALSE;
169 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
170 adc_base_struct.ordinary_channel_length = 1;
171 adc_base_config(ADC1, &adc_base_struct);
172 adc_resolution_set(ADC1, ADC_RESOLUTION_12B);
173
174 /* config ordinary channel */
175 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_2_5);
176
177 /* config ordinary trigger source and trigger edge */
178 adc_ordinary_conversion_trigger_set(ADC1, ADC_ORDINARY_TRIG_TMR1TRGOUT, ADC_ORDINARY_TRIG_EDGE_RISING);
179
180 /* config dma mode,it's not useful when common dma mode is use */
181 adc_dma_mode_enable(ADC1, FALSE);
182
183 /* config dma request repeat,it's not useful when common dma mode is use */
184 adc_dma_request_repeat_enable(ADC1, FALSE);
185
186 /* enable adc overflow interrupt */
187 adc_interrupt_enable(ADC1, ADC_OCCO_INT, TRUE);
188
189 adc_base_config(ADC2, &adc_base_struct);
190 adc_resolution_set(ADC2, ADC_RESOLUTION_12B);
191 adc_ordinary_channel_set(ADC2, ADC_CHANNEL_7, 1, ADC_SAMPLETIME_2_5);
192 adc_ordinary_conversion_trigger_set(ADC2, ADC_ORDINARY_TRIG_TMR1TRGOUT, ADC_ORDINARY_TRIG_EDGE_NONE);
193 adc_dma_mode_enable(ADC2, FALSE);
194 adc_dma_request_repeat_enable(ADC2, FALSE);
195 adc_interrupt_enable(ADC2, ADC_OCCO_INT, TRUE);
196
197 adc_base_config(ADC3, &adc_base_struct);
198 adc_resolution_set(ADC3, ADC_RESOLUTION_12B);
199 adc_ordinary_channel_set(ADC3, ADC_CHANNEL_10, 1, ADC_SAMPLETIME_2_5);
200 adc_ordinary_conversion_trigger_set(ADC3, ADC_ORDINARY_TRIG_TMR1TRGOUT, ADC_ORDINARY_TRIG_EDGE_NONE);
201 adc_dma_mode_enable(ADC3, FALSE);
202 adc_dma_request_repeat_enable(ADC3, FALSE);
203 adc_interrupt_enable(ADC3, ADC_OCCO_INT, TRUE);
204
205 /* adc enable */
206 adc_enable(ADC1, TRUE);
207 adc_enable(ADC2, TRUE);
208 adc_enable(ADC3, TRUE);
209 while(adc_flag_get(ADC1, ADC_RDY_FLAG) == RESET);
210 while(adc_flag_get(ADC2, ADC_RDY_FLAG) == RESET);
211 while(adc_flag_get(ADC3, ADC_RDY_FLAG) == RESET);
212
213 /* adc calibration */
214 adc_calibration_init(ADC1);
215 while(adc_calibration_init_status_get(ADC1));
216 adc_calibration_start(ADC1);
217 while(adc_calibration_status_get(ADC1));
218 adc_calibration_init(ADC2);
219 while(adc_calibration_init_status_get(ADC2));
220 adc_calibration_start(ADC2);
221 while(adc_calibration_status_get(ADC2));
222 adc_calibration_init(ADC3);
223 while(adc_calibration_init_status_get(ADC3));
224 adc_calibration_start(ADC3);
225 while(adc_calibration_status_get(ADC3));
226
227 /*set resolution to 8bit.this because calibration must perform at 12 bit resolution */
228 adc_resolution_set(ADC1,ADC_RESOLUTION_8B);
229 adc_resolution_set(ADC2,ADC_RESOLUTION_8B);
230 adc_resolution_set(ADC3,ADC_RESOLUTION_8B);
231 while(adc_flag_get(ADC1, ADC_RDY_FLAG) == RESET);
232 while(adc_flag_get(ADC2, ADC_RDY_FLAG) == RESET);
233 while(adc_flag_get(ADC3, ADC_RDY_FLAG) == RESET);
234}
235
241int main(void)
242{
243 __IO uint32_t index = 0;
244 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
245
246 /* config the system clock */
247 system_clock_config();
248
249 /* init at start board */
250 at32_board_init();
251 at32_led_off(LED2);
252 at32_led_off(LED3);
253 at32_led_off(LED4);
254 uart_print_init(115200);
255 gpio_config();
256 tmr1_config();
257 dma_config();
258 adc_config();
259 printf("combine_mode_ordinary_shift_twoslave_dma4 \r\n");
260 tmr_counter_enable(TMR1, TRUE);
261 while(dma1_trans_complete_flag == 0);
262 tmr_counter_enable(TMR1, FALSE);
263 if((adc1_overflow_flag != 0) || (adc2_overflow_flag != 0) || (adc3_overflow_flag != 0))
264 {
265 /* printf flag when error occur */
266 at32_led_on(LED3);
267 at32_led_on(LED4);
268 printf("error occur\r\n");
269 printf("adc1_overflow_flag = %d\r\n",adc1_overflow_flag);
270 printf("adc2_overflow_flag = %d\r\n",adc2_overflow_flag);
271 printf("adc3_overflow_flag = %d\r\n",adc3_overflow_flag);
272 }
273 else
274 {
275 /* printf data when conversion end without error */
276 printf("conversion end without error\r\n");
277 for(index = 0; index < 5; index++)
278 {
279 printf("adccom_ordinary_valuetab[%d] = 0x%x\r\n",index, adccom_ordinary_valuetab[index]);
280 }
281 printf("\r\n");
282 }
283 at32_led_on(LED2);
284 while(1)
285 {
286 }
287}
288
at32f435_437_board.h
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c:99
adc3_overflow_flag
__IO uint32_t adc3_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c:42
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c:40
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c:132
dma1_trans_complete_flag
__IO uint32_t dma1_trans_complete_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c:241
tmr1_config
static void tmr1_config(void)
tmr1 configuration.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c:78
adc2_overflow_flag
__IO uint32_t adc2_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c:41
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c:54
adccom_ordinary_valuetab
__IO uint32_t adccom_ordinary_valuetab[5]
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma4/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:40
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc ...
Definition: at32f435_437_adc.c:742
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f435_437_adc.c:110
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f435_437_adc.c:64
adc_common_config
void adc_common_config(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:203
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f435_437_adc.c:294
adc_resolution_set
void adc_resolution_set(adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral.
Definition: at32f435_437_adc.c:235
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f435_437_adc.c:84
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f435_437_adc.c:359
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f435_437_adc.c:371
adc_dma_request_repeat_enable
void adc_dma_request_repeat_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat.
Definition: at32f435_437_adc.c:274
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f435_437_adc.c:328
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f435_437_adc.c:340
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f435_437_adc.c:260
adc_common_default_para_init
void adc_common_default_para_init(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:155
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f435_437_adc.c:472
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f435_437_adc.h:178
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f435_437_adc.h:191
ADC_CHANNEL_10
@ ADC_CHANNEL_10
Definition: at32f435_437_adc.h:197
ADC_CHANNEL_7
@ ADC_CHANNEL_7
Definition: at32f435_437_adc.h:194
ADC_SAMPLETIME_2_5
@ ADC_SAMPLETIME_2_5
Definition: at32f435_437_adc.h:213
ADC_SAMPLING_INTERVAL_20CYCLES
@ ADC_SAMPLING_INTERVAL_20CYCLES
Definition: at32f435_437_adc.h:159
ADC_COMMON_DMAMODE_4
@ ADC_COMMON_DMAMODE_4
Definition: at32f435_437_adc.h:135
ADC_ORDINARY_SHIFT_ONLY_TWOSLAVE_MODE
@ ADC_ORDINARY_SHIFT_ONLY_TWOSLAVE_MODE
Definition: at32f435_437_adc.h:122
ADC_ORDINARY_TRIG_TMR1TRGOUT
@ ADC_ORDINARY_TRIG_TMR1TRGOUT
Definition: at32f435_437_adc.h:255
ADC_ORDINARY_TRIG_EDGE_RISING
@ ADC_ORDINARY_TRIG_EDGE_RISING
Definition: at32f435_437_adc.h:266
ADC_ORDINARY_TRIG_EDGE_NONE
@ ADC_ORDINARY_TRIG_EDGE_NONE
Definition: at32f435_437_adc.h:265
ADC_RESOLUTION_12B
@ ADC_RESOLUTION_12B
Definition: at32f435_437_adc.h:167
ADC_RESOLUTION_8B
@ ADC_RESOLUTION_8B
Definition: at32f435_437_adc.h:169
ADC_HCLK_DIV_4
@ ADC_HCLK_DIV_4
Definition: at32f435_437_adc.h:90
ADC_RDY_FLAG
#define ADC_RDY_FLAG
Definition: at32f435_437_adc.h:73
ADC_OCCO_INT
#define ADC_OCCO_INT
Definition: at32f435_437_adc.h:56
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
ADC2
#define ADC2
Definition: at32f435_437_adc.h:867
ADC3
#define ADC3
Definition: at32f435_437_adc.h:868
ADCCOM
#define ADCCOM
Definition: at32f435_437_adc.h:869
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_ADC3_PERIPH_CLOCK
@ CRM_ADC3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:160
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:158
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:154
CRM_ADC2_PERIPH_CLOCK
@ CRM_ADC2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:159
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:164
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:174
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_ADC1
@ DMAMUX_DMAREQ_ID_ADC1
Definition: at32f435_437_dma.h:197
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f435_437_gpio.h:85
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_primary_mode_select
void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode
Definition: at32f435_437_tmr.c:1222
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f435_437_tmr.h:97
TMR_PRIMARY_SEL_OVERFLOW
@ TMR_PRIMARY_SEL_OVERFLOW
Definition: at32f435_437_tmr.h:121
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f435_437.h:204
ADC1_2_3_IRQn
@ ADC1_2_3_IRQn
Definition: at32f435_437.h:166
adc_base_config_type
adc base config type
Definition: at32f435_437_adc.h:402
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f435_437_adc.h:405
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f435_437_adc.h:404
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f435_437_adc.h:403
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f435_437_adc.h:406
adc_common_config_type
adc common config type
Definition: at32f435_437_adc.h:388
adc_common_config_type::sampling_interval
adc_sampling_interval_type sampling_interval
Definition: at32f435_437_adc.h:393
adc_common_config_type::tempervintrv_state
confirm_state tempervintrv_state
Definition: at32f435_437_adc.h:394
adc_common_config_type::div
adc_div_type div
Definition: at32f435_437_adc.h:390
adc_common_config_type::common_dma_mode
adc_common_dma_mode_type common_dma_mode
Definition: at32f435_437_adc.h:391
adc_common_config_type::common_dma_request_repeat_state
confirm_state common_dma_request_repeat_state
Definition: at32f435_437_adc.h:392
adc_common_config_type::combine_mode
adc_combine_mode_type combine_mode
Definition: at32f435_437_adc.h:389
adc_common_config_type::vbat_state
confirm_state vbat_state
Definition: at32f435_437_adc.h:395
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f435_437_crm.h:789
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_dma2
  • inc
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_dma2
  • inc
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_dma2
  • inc
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_dma2
  • src
Functions
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 49 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_dma2
  • src
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_clock.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_dma2
  • src
Functions | Variables
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...

Variables

__IO uint32_t | dma1_trans_complete_flag
__IO uint32_t | adc1_overflow_flag
__IO uint32_t | adc2_overflow_flag

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_dma2
  • src
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
38extern __IO uint32_t dma1_trans_complete_flag;
39extern __IO uint32_t adc1_overflow_flag;
40extern __IO uint32_t adc2_overflow_flag;
41
47void NMI_Handler(void)
48{
49}
50
56void HardFault_Handler(void)
57{
58 /* go to infinite loop when hard fault exception occurs */
59 while(1)
60 {
61 }
62}
63
69void MemManage_Handler(void)
70{
71 /* go to infinite loop when memory manage exception occurs */
72 while(1)
73 {
74 }
75}
76
82void BusFault_Handler(void)
83{
84 /* go to infinite loop when bus fault exception occurs */
85 while(1)
86 {
87 }
88}
89
95void UsageFault_Handler(void)
96{
97 /* go to infinite loop when usage fault exception occurs */
98 while(1)
99 {
100 }
101}
102
108void SVC_Handler(void)
109{
110}
111
117void DebugMon_Handler(void)
118{
119}
120
126void PendSV_Handler(void)
127{
128}
129
135void SysTick_Handler(void)
136{
137}
138
144void DMA1_Channel1_IRQHandler(void)
145{
146 if(dma_flag_get(DMA1_FDT1_FLAG) != RESET)
147 {
148 dma_flag_clear(DMA1_FDT1_FLAG);
149 dma1_trans_complete_flag = 1;
150 }
151}
152
158void ADC1_2_3_IRQHandler(void)
159{
160 if(adc_flag_get(ADC1, ADC_OCCO_FLAG) != RESET)
161 {
162 adc_flag_clear(ADC1, ADC_OCCO_FLAG);
163 adc1_overflow_flag++;
164 }
165 if(adc_flag_get(ADC2, ADC_OCCO_FLAG) != RESET)
166 {
167 adc_flag_clear(ADC2, ADC_OCCO_FLAG);
168 adc2_overflow_flag++;
169 }
170}
171
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c:95
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c:56
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c:69
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c:108
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:40
ADC1_2_3_IRQHandler
void ADC1_2_3_IRQHandler(void)
this function handles adc1_2_3 handler.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c:158
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c:126
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c:47
dma1_trans_complete_flag
__IO uint32_t dma1_trans_complete_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:39
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1_channel1 handler.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c:144
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c:82
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c:135
adc2_overflow_flag
__IO uint32_t adc2_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:41
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/at32f435_437_int.c:117
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1106
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
ADC_OCCO_FLAG
#define ADC_OCCO_FLAG
Definition: at32f435_437_adc.h:72
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
ADC2
#define ADC2
Definition: at32f435_437_adc.h:867
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f435_437_dma.h:66
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_dma2
  • src
Functions | Variables
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | adccom_ordinary_valuetab [5][3]
__IO uint32_t | dma1_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint32_t | adc2_overflow_flag = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_dma2
  • src
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38__IO uint32_t adccom_ordinary_valuetab[5][3];
39__IO uint32_t dma1_trans_complete_flag = 0;
40__IO uint32_t adc1_overflow_flag = 0;
41__IO uint32_t adc2_overflow_flag = 0;
42
43static void gpio_config(void);
44static void dma_config(void);
45static void adc_config(void);
46
52static void gpio_config(void)
53{
54 gpio_init_type gpio_initstructure;
55 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
56 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
57
58 gpio_default_para_init(&gpio_initstructure);
59
60 /* config adc pin as analog input mode */
61 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
62 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6 | GPIO_PINS_7;
63 gpio_init(GPIOA, &gpio_initstructure);
64
65 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
66 gpio_initstructure.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
67 gpio_init(GPIOB, &gpio_initstructure);
68}
69
75static void dma_config(void)
76{
77 dma_init_type dma_init_struct;
78 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
79 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
80
81 dma_reset(DMA1_CHANNEL1);
82 dma_default_para_init(&dma_init_struct);
83 dma_init_struct.buffer_size = 15;
84 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
85 dma_init_struct.memory_base_addr = (uint32_t)adccom_ordinary_valuetab;
86 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_WORD;
87 dma_init_struct.memory_inc_enable = TRUE;
88 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADCCOM->codt);
89 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_WORD;
90 dma_init_struct.peripheral_inc_enable = FALSE;
91 dma_init_struct.priority = DMA_PRIORITY_HIGH;
92 dma_init_struct.loop_mode_enable = FALSE;
93 dma_init(DMA1_CHANNEL1, &dma_init_struct);
94
95 dmamux_enable(DMA1, TRUE);
96 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_ADC1);
97
98 /* enable dma transfer complete interrupt */
99 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
100 dma_channel_enable(DMA1_CHANNEL1, TRUE);
101}
102
108static void adc_config(void)
109{
110 adc_common_config_type adc_common_struct;
111 adc_base_config_type adc_base_struct;
112 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
113 crm_periph_clock_enable(CRM_ADC2_PERIPH_CLOCK, TRUE);
114 nvic_irq_enable(ADC1_2_3_IRQn, 0, 0);
115
116 adc_common_default_para_init(&adc_common_struct);
117
118 /* config combine mode */
119 adc_common_struct.combine_mode = ADC_ORDINARY_SMLT_ONLY_ONESLAVE_MODE;
120
121 /* config division,adcclk is division by hclk */
122 adc_common_struct.div = ADC_HCLK_DIV_4;
123
124 /* config common dma mode,it's useful for ordinary group in combine mode */
125 adc_common_struct.common_dma_mode = ADC_COMMON_DMAMODE_2;
126
127 /* config common dma request repeat */
128 adc_common_struct.common_dma_request_repeat_state = FALSE;
129
130 /* config adjacent adc sampling interval,it's useful for ordinary shifting mode */
131 adc_common_struct.sampling_interval = ADC_SAMPLING_INTERVAL_5CYCLES;
132
133 /* config inner temperature sensor and vintrv */
134 adc_common_struct.tempervintrv_state = FALSE;
135
136 /* config voltage battery */
137 adc_common_struct.vbat_state = FALSE;
138 adc_common_config(&adc_common_struct);
139
140 adc_base_default_para_init(&adc_base_struct);
141
142 adc_base_struct.sequence_mode = TRUE;
143 adc_base_struct.repeat_mode = FALSE;
144 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
145 adc_base_struct.ordinary_channel_length = 3;
146 adc_base_config(ADC1, &adc_base_struct);
147 adc_resolution_set(ADC1, ADC_RESOLUTION_12B);
148
149 /* config ordinary channel */
150 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_640_5);
151 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_640_5);
152 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_640_5);
153
154 /* config ordinary trigger source and trigger edge */
155 adc_ordinary_conversion_trigger_set(ADC1, ADC_ORDINARY_TRIG_TMR1CH1, ADC_ORDINARY_TRIG_EDGE_NONE);
156
157 /* config dma mode,it's not useful when common dma mode is use */
158 adc_dma_mode_enable(ADC1, FALSE);
159
160 /* config dma request repeat,it's not useful when common dma mode is use */
161 adc_dma_request_repeat_enable(ADC1, FALSE);
162
163 /* enable adc overflow interrupt */
164 adc_interrupt_enable(ADC1, ADC_OCCO_INT, TRUE);
165
166 adc_base_config(ADC2, &adc_base_struct);
167 adc_resolution_set(ADC2, ADC_RESOLUTION_12B);
168 adc_ordinary_channel_set(ADC2, ADC_CHANNEL_7, 1, ADC_SAMPLETIME_640_5);
169 adc_ordinary_channel_set(ADC2, ADC_CHANNEL_8, 2, ADC_SAMPLETIME_640_5);
170 adc_ordinary_channel_set(ADC2, ADC_CHANNEL_9, 3, ADC_SAMPLETIME_640_5);
171 adc_ordinary_conversion_trigger_set(ADC2, ADC_ORDINARY_TRIG_TMR1CH1, ADC_ORDINARY_TRIG_EDGE_NONE);
172 adc_dma_mode_enable(ADC2, FALSE);
173 adc_dma_request_repeat_enable(ADC2, FALSE);
174 adc_interrupt_enable(ADC2, ADC_OCCO_INT, TRUE);
175
176 /* adc enable */
177 adc_enable(ADC1, TRUE);
178 adc_enable(ADC2, TRUE);
179 while(adc_flag_get(ADC1, ADC_RDY_FLAG) == RESET);
180 while(adc_flag_get(ADC2, ADC_RDY_FLAG) == RESET);
181
182 /* adc calibration */
183 adc_calibration_init(ADC1);
184 while(adc_calibration_init_status_get(ADC1));
185 adc_calibration_start(ADC1);
186 while(adc_calibration_status_get(ADC1));
187 adc_calibration_init(ADC2);
188 while(adc_calibration_init_status_get(ADC2));
189 adc_calibration_start(ADC2);
190 while(adc_calibration_status_get(ADC2));
191}
192
198int main(void)
199{
200 __IO uint32_t index = 0;
201 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
202
203 /* config the system clock */
204 system_clock_config();
205
206 /* init at start board */
207 at32_board_init();
208 at32_led_off(LED2);
209 at32_led_off(LED3);
210 at32_led_off(LED4);
211 uart_print_init(115200);
212 gpio_config();
213 dma_config();
214 adc_config();
215 printf("combine_mode_ordinary_smlt_oneslave_dma2 \r\n");
216
217 /* adc1 software trigger start conversion */
218 for(index = 0; index < 5; index++)
219 {
220 adc_ordinary_software_trigger_enable(ADC1, TRUE);
221 delay_ms(100);
222 }
223
224 if((dma1_trans_complete_flag == 0) || (adc1_overflow_flag != 0) || (adc2_overflow_flag != 0))
225 {
226 /* printf flag when error occur */
227 at32_led_on(LED3);
228 at32_led_on(LED4);
229 printf("error occur\r\n");
230 printf("dma1_trans_complete_flag = %d\r\n",dma1_trans_complete_flag);
231 printf("adc1_overflow_flag = %d\r\n",adc1_overflow_flag);
232 printf("adc2_overflow_flag = %d\r\n",adc2_overflow_flag);
233 }
234 else
235 {
236 /* printf data when conversion end without error */
237 printf("conversion end without error\r\n");
238 for(index = 0; index < 5; index++)
239 {
240 printf("adc1_ordinary_channel4[%d] = 0x%x\r\n",index, adccom_ordinary_valuetab[index][0] & 0xFFFF);
241 printf("adc1_ordinary_channel5[%d] = 0x%x\r\n",index, adccom_ordinary_valuetab[index][1] & 0xFFFF);
242 printf("adc1_ordinary_channel6[%d] = 0x%x\r\n",index, adccom_ordinary_valuetab[index][2] & 0xFFFF);
243 printf("adc2_ordinary_channel7[%d] = 0x%x\r\n",index, (adccom_ordinary_valuetab[index][0] >> 16) & 0xFFFF);
244 printf("adc2_ordinary_channel8[%d] = 0x%x\r\n",index, (adccom_ordinary_valuetab[index][1] >> 16) & 0xFFFF);
245 printf("adc2_ordinary_channel9[%d] = 0x%x\r\n",index, (adccom_ordinary_valuetab[index][2] >> 16) & 0xFFFF);
246 printf("\r\n");
247 }
248 }
249 at32_led_on(LED2);
250 while(1)
251 {
252 }
253}
254
at32f435_437_board.h
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c:75
adccom_ordinary_valuetab
__IO uint32_t adccom_ordinary_valuetab[5][3]
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c:38
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c:40
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c:108
dma1_trans_complete_flag
__IO uint32_t dma1_trans_complete_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c:198
adc2_overflow_flag
__IO uint32_t adc2_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c:41
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_dma2/src/main.c:52
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:945
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc ...
Definition: at32f435_437_adc.c:742
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f435_437_adc.c:110
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f435_437_adc.c:64
adc_common_config
void adc_common_config(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:203
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f435_437_adc.c:294
adc_resolution_set
void adc_resolution_set(adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral.
Definition: at32f435_437_adc.c:235
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f435_437_adc.c:84
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f435_437_adc.c:359
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f435_437_adc.c:371
adc_dma_request_repeat_enable
void adc_dma_request_repeat_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat.
Definition: at32f435_437_adc.c:274
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f435_437_adc.c:328
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f435_437_adc.c:340
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f435_437_adc.c:260
adc_common_default_para_init
void adc_common_default_para_init(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:155
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f435_437_adc.c:472
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f435_437_adc.h:178
ADC_CHANNEL_9
@ ADC_CHANNEL_9
Definition: at32f435_437_adc.h:196
ADC_CHANNEL_8
@ ADC_CHANNEL_8
Definition: at32f435_437_adc.h:195
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f435_437_adc.h:191
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f435_437_adc.h:193
ADC_CHANNEL_7
@ ADC_CHANNEL_7
Definition: at32f435_437_adc.h:194
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f435_437_adc.h:192
ADC_SAMPLETIME_640_5
@ ADC_SAMPLETIME_640_5
Definition: at32f435_437_adc.h:220
ADC_SAMPLING_INTERVAL_5CYCLES
@ ADC_SAMPLING_INTERVAL_5CYCLES
Definition: at32f435_437_adc.h:144
ADC_COMMON_DMAMODE_2
@ ADC_COMMON_DMAMODE_2
Definition: at32f435_437_adc.h:133
ADC_ORDINARY_SMLT_ONLY_ONESLAVE_MODE
@ ADC_ORDINARY_SMLT_ONLY_ONESLAVE_MODE
Definition: at32f435_437_adc.h:115
ADC_ORDINARY_TRIG_TMR1CH1
@ ADC_ORDINARY_TRIG_TMR1CH1
Definition: at32f435_437_adc.h:228
ADC_ORDINARY_TRIG_EDGE_NONE
@ ADC_ORDINARY_TRIG_EDGE_NONE
Definition: at32f435_437_adc.h:265
ADC_RESOLUTION_12B
@ ADC_RESOLUTION_12B
Definition: at32f435_437_adc.h:167
ADC_HCLK_DIV_4
@ ADC_HCLK_DIV_4
Definition: at32f435_437_adc.h:90
ADC_RDY_FLAG
#define ADC_RDY_FLAG
Definition: at32f435_437_adc.h:73
ADC_OCCO_INT
#define ADC_OCCO_INT
Definition: at32f435_437_adc.h:56
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
ADC2
#define ADC2
Definition: at32f435_437_adc.h:867
ADCCOM
#define ADCCOM
Definition: at32f435_437_adc.h:869
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:158
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
CRM_ADC2_PERIPH_CLOCK
@ CRM_ADC2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:159
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:164
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:174
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_ADC1
@ DMAMUX_DMAREQ_ID_ADC1
Definition: at32f435_437_dma.h:197
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f435_437_gpio.h:85
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f435_437.h:204
ADC1_2_3_IRQn
@ ADC1_2_3_IRQn
Definition: at32f435_437.h:166
adc_base_config_type
adc base config type
Definition: at32f435_437_adc.h:402
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f435_437_adc.h:405
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f435_437_adc.h:404
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f435_437_adc.h:403
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f435_437_adc.h:406
adc_common_config_type
adc common config type
Definition: at32f435_437_adc.h:388
adc_common_config_type::sampling_interval
adc_sampling_interval_type sampling_interval
Definition: at32f435_437_adc.h:393
adc_common_config_type::tempervintrv_state
confirm_state tempervintrv_state
Definition: at32f435_437_adc.h:394
adc_common_config_type::div
adc_div_type div
Definition: at32f435_437_adc.h:390
adc_common_config_type::common_dma_mode
adc_common_dma_mode_type common_dma_mode
Definition: at32f435_437_adc.h:391
adc_common_config_type::common_dma_request_repeat_state
confirm_state common_dma_request_repeat_state
Definition: at32f435_437_adc.h:392
adc_common_config_type::combine_mode
adc_combine_mode_type combine_mode
Definition: at32f435_437_adc.h:389
adc_common_config_type::vbat_state
confirm_state vbat_state
Definition: at32f435_437_adc.h:395
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_edma
  • inc
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_edma
  • inc
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_edma
  • inc
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_edma
  • src
Functions
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 49 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_edma
  • src
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_clock.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_edma
  • src
Functions | Variables
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | EDMA_Stream1_IRQHandler (void)
this function handles edma_stream1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...

Variables

__IO uint32_t | edma_trans_complete_flag
__IO uint32_t | adc1_overflow_flag
__IO uint32_t | adc2_overflow_flag

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_edma
  • src
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
38extern __IO uint32_t edma_trans_complete_flag;
39extern __IO uint32_t adc1_overflow_flag;
40extern __IO uint32_t adc2_overflow_flag;
41
47void NMI_Handler(void)
48{
49}
50
56void HardFault_Handler(void)
57{
58 /* go to infinite loop when hard fault exception occurs */
59 while(1)
60 {
61 }
62}
63
69void MemManage_Handler(void)
70{
71 /* go to infinite loop when memory manage exception occurs */
72 while(1)
73 {
74 }
75}
76
82void BusFault_Handler(void)
83{
84 /* go to infinite loop when bus fault exception occurs */
85 while(1)
86 {
87 }
88}
89
95void UsageFault_Handler(void)
96{
97 /* go to infinite loop when usage fault exception occurs */
98 while(1)
99 {
100 }
101}
102
108void SVC_Handler(void)
109{
110}
111
117void DebugMon_Handler(void)
118{
119}
120
126void PendSV_Handler(void)
127{
128}
129
135void SysTick_Handler(void)
136{
137}
138
144void EDMA_Stream1_IRQHandler(void)
145{
146 if(edma_flag_get(EDMA_FDT1_FLAG) != RESET)
147 {
148 edma_flag_clear(EDMA_FDT1_FLAG);
149 edma_trans_complete_flag = 1;
150 }
151}
152
158void ADC1_2_3_IRQHandler(void)
159{
160 if(adc_flag_get(ADC1, ADC_OCCO_FLAG) != RESET)
161 {
162 adc_flag_clear(ADC1, ADC_OCCO_FLAG);
163 adc1_overflow_flag++;
164 }
165 if(adc_flag_get(ADC2, ADC_OCCO_FLAG) != RESET)
166 {
167 adc_flag_clear(ADC2, ADC_OCCO_FLAG);
168 adc2_overflow_flag++;
169 }
170}
171
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c:95
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c:56
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c:69
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c:108
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:40
ADC1_2_3_IRQHandler
void ADC1_2_3_IRQHandler(void)
this function handles adc1_2_3 handler.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c:158
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c:126
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c:47
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c:82
EDMA_Stream1_IRQHandler
void EDMA_Stream1_IRQHandler(void)
this function handles edma_stream1 handler.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c:144
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c:135
adc2_overflow_flag
__IO uint32_t adc2_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:41
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/at32f435_437_int.c:117
edma_trans_complete_flag
__IO uint32_t edma_trans_complete_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c:39
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1106
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
ADC_OCCO_FLAG
#define ADC_OCCO_FLAG
Definition: at32f435_437_adc.h:72
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
ADC2
#define ADC2
Definition: at32f435_437_adc.h:867
edma_flag_get
flag_status edma_flag_get(uint32_t edma_flag)
get the edma flag.
Definition: at32f435_437_edma.c:512
edma_flag_clear
void edma_flag_clear(uint32_t edma_flag)
clear the edma flag.
Definition: at32f435_437_edma.c:549
EDMA_FDT1_FLAG
#define EDMA_FDT1_FLAG
Definition: at32f435_437_edma.h:71
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_edma
  • src
Functions | Variables
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | edma_config (void)
edma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | adccom_ordinary_valuetab [5][3]
__IO uint32_t | edma_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint32_t | adc2_overflow_flag = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_oneslave_edma
  • src
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38__IO uint32_t adccom_ordinary_valuetab[5][3];
39__IO uint32_t edma_trans_complete_flag = 0;
40__IO uint32_t adc1_overflow_flag = 0;
41__IO uint32_t adc2_overflow_flag = 0;
42
43static void gpio_config(void);
44static void edma_config(void);
45static void adc_config(void);
46
52static void gpio_config(void)
53{
54 gpio_init_type gpio_initstructure;
55 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
56 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
57
58 gpio_default_para_init(&gpio_initstructure);
59
60 /* config adc pin as analog input mode */
61 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
62 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6 | GPIO_PINS_7;
63 gpio_init(GPIOA, &gpio_initstructure);
64
65 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
66 gpio_initstructure.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
67 gpio_init(GPIOB, &gpio_initstructure);
68}
69
75static void edma_config(void)
76{
77 edma_init_type edma_init_struct;
78 crm_periph_clock_enable(CRM_EDMA_PERIPH_CLOCK, TRUE);
79 nvic_irq_enable(EDMA_Stream1_IRQn, 0, 0);
80
81 edma_reset(EDMA_STREAM1);
82 edma_default_para_init(&edma_init_struct);
83 edma_init_struct.buffer_size = 15;
84 edma_init_struct.direction = EDMA_DIR_PERIPHERAL_TO_MEMORY;
85 edma_init_struct.memory0_base_addr = (uint32_t)adccom_ordinary_valuetab;
86 edma_init_struct.memory_burst_mode = EDMA_MEMORY_SINGLE;
87 edma_init_struct.memory_data_width = EDMA_MEMORY_DATA_WIDTH_WORD;
88 edma_init_struct.memory_inc_enable = TRUE;
89 edma_init_struct.peripheral_base_addr = (uint32_t)&(ADCCOM->codt);
90 edma_init_struct.peripheral_burst_mode = EDMA_PERIPHERAL_SINGLE;
91 edma_init_struct.peripheral_data_width = EDMA_PERIPHERAL_DATA_WIDTH_WORD;
92 edma_init_struct.peripheral_inc_enable = FALSE;
93 edma_init_struct.priority = EDMA_PRIORITY_VERY_HIGH;
94 edma_init_struct.loop_mode_enable = FALSE;
95 edma_init_struct.fifo_threshold = EDMA_FIFO_THRESHOLD_1QUARTER;
96 edma_init_struct.fifo_mode_enable = FALSE;
97 edma_init(EDMA_STREAM1, &edma_init_struct);
98
99 /* edmamux init and enable */
100 edmamux_enable(TRUE);
101 edmamux_init(EDMAMUX_CHANNEL1, EDMAMUX_DMAREQ_ID_ADC1);
102
103 /* enable edma full data transfer intterrupt */
104 edma_interrupt_enable(EDMA_STREAM1, EDMA_FDT_INT, TRUE);
105 edma_stream_enable(EDMA_STREAM1, TRUE);
106}
107
113static void adc_config(void)
114{
115 adc_common_config_type adc_common_struct;
116 adc_base_config_type adc_base_struct;
117 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
118 crm_periph_clock_enable(CRM_ADC2_PERIPH_CLOCK, TRUE);
119 nvic_irq_enable(ADC1_2_3_IRQn, 0, 0);
120
121 adc_common_default_para_init(&adc_common_struct);
122
123 /* config combine mode */
124 adc_common_struct.combine_mode = ADC_ORDINARY_SMLT_ONLY_ONESLAVE_MODE;
125
126 /* config division,adcclk is division by hclk */
127 adc_common_struct.div = ADC_HCLK_DIV_4;
128
129 /* config common dma mode,it's useful for ordinary group in combine mode */
130 adc_common_struct.common_dma_mode = ADC_COMMON_DMAMODE_2;
131
132 /* config common dma request repeat */
133 adc_common_struct.common_dma_request_repeat_state = FALSE;
134
135 /* config adjacent adc sampling interval,it's useful for ordinary shifting mode */
136 adc_common_struct.sampling_interval = ADC_SAMPLING_INTERVAL_5CYCLES;
137
138 /* config inner temperature sensor and vintrv */
139 adc_common_struct.tempervintrv_state = FALSE;
140
141 /* config voltage battery */
142 adc_common_struct.vbat_state = FALSE;
143 adc_common_config(&adc_common_struct);
144
145 adc_base_default_para_init(&adc_base_struct);
146
147 adc_base_struct.sequence_mode = TRUE;
148 adc_base_struct.repeat_mode = FALSE;
149 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
150 adc_base_struct.ordinary_channel_length = 3;
151 adc_base_config(ADC1, &adc_base_struct);
152 adc_resolution_set(ADC1, ADC_RESOLUTION_12B);
153
154 /* config ordinary channel */
155 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_640_5);
156 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_640_5);
157 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_640_5);
158
159 /* config ordinary trigger source and trigger edge */
160 adc_ordinary_conversion_trigger_set(ADC1, ADC_ORDINARY_TRIG_TMR1CH1, ADC_ORDINARY_TRIG_EDGE_NONE);
161
162 /* config dma mode,it's not useful when common dma mode is use */
163 adc_dma_mode_enable(ADC1, FALSE);
164
165 /* config dma request repeat,it's not useful when common dma mode is use */
166 adc_dma_request_repeat_enable(ADC1, FALSE);
167
168 /* enable adc overflow interrupt */
169 adc_interrupt_enable(ADC1, ADC_OCCO_INT, TRUE);
170
171 adc_base_config(ADC2, &adc_base_struct);
172 adc_resolution_set(ADC2, ADC_RESOLUTION_12B);
173 adc_ordinary_channel_set(ADC2, ADC_CHANNEL_7, 1, ADC_SAMPLETIME_640_5);
174 adc_ordinary_channel_set(ADC2, ADC_CHANNEL_8, 2, ADC_SAMPLETIME_640_5);
175 adc_ordinary_channel_set(ADC2, ADC_CHANNEL_9, 3, ADC_SAMPLETIME_640_5);
176 adc_ordinary_conversion_trigger_set(ADC2, ADC_ORDINARY_TRIG_TMR1CH1, ADC_ORDINARY_TRIG_EDGE_NONE);
177 adc_dma_mode_enable(ADC2, FALSE);
178 adc_dma_request_repeat_enable(ADC2, FALSE);
179 adc_interrupt_enable(ADC2, ADC_OCCO_INT, TRUE);
180
181 /* adc enable */
182 adc_enable(ADC1, TRUE);
183 adc_enable(ADC2, TRUE);
184 while(adc_flag_get(ADC1, ADC_RDY_FLAG) == RESET);
185 while(adc_flag_get(ADC2, ADC_RDY_FLAG) == RESET);
186
187 /* adc calibration */
188 adc_calibration_init(ADC1);
189 while(adc_calibration_init_status_get(ADC1));
190 adc_calibration_start(ADC1);
191 while(adc_calibration_status_get(ADC1));
192 adc_calibration_init(ADC2);
193 while(adc_calibration_init_status_get(ADC2));
194 adc_calibration_start(ADC2);
195 while(adc_calibration_status_get(ADC2));
196}
197
203int main(void)
204{
205 __IO uint32_t index = 0;
206 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
207
208 /* config the system clock */
209 system_clock_config();
210
211 /* init at start board */
212 at32_board_init();
213 at32_led_off(LED2);
214 at32_led_off(LED3);
215 at32_led_off(LED4);
216 uart_print_init(115200);
217 gpio_config();
218 edma_config();
219 adc_config();
220 printf("combine_mode_ordinary_simult \r\n");
221
222 /* adc1 software trigger start conversion */
223 for(index = 0; index < 5; index++)
224 {
225 adc_ordinary_software_trigger_enable(ADC1, TRUE);
226 delay_ms(100);
227 }
228
229 if((edma_trans_complete_flag == 0) || (adc1_overflow_flag != 0) || (adc2_overflow_flag != 0))
230 {
231 /* printf flag when error occur */
232 at32_led_on(LED3);
233 at32_led_on(LED4);
234 printf("error occur\r\n");
235 printf("edma_trans_complete_flag = %d\r\n",edma_trans_complete_flag);
236 printf("adc1_overflow_flag = %d\r\n",adc1_overflow_flag);
237 printf("adc2_overflow_flag = %d\r\n",adc2_overflow_flag);
238 }
239 else
240 {
241 /* printf data when conversion end without error */
242 printf("conversion end without error\r\n");
243 for(index = 0; index < 5; index++)
244 {
245 printf("adc1_ordinary_channel4[%d] = 0x%x\r\n",index, adccom_ordinary_valuetab[index][0] & 0xFFFF);
246 printf("adc1_ordinary_channel5[%d] = 0x%x\r\n",index, adccom_ordinary_valuetab[index][1] & 0xFFFF);
247 printf("adc1_ordinary_channel6[%d] = 0x%x\r\n",index, adccom_ordinary_valuetab[index][2] & 0xFFFF);
248 printf("adc2_ordinary_channel7[%d] = 0x%x\r\n",index, (adccom_ordinary_valuetab[index][0] >> 16) & 0xFFFF);
249 printf("adc2_ordinary_channel8[%d] = 0x%x\r\n",index, (adccom_ordinary_valuetab[index][1] >> 16) & 0xFFFF);
250 printf("adc2_ordinary_channel9[%d] = 0x%x\r\n",index, (adccom_ordinary_valuetab[index][2] >> 16) & 0xFFFF);
251 printf("\r\n");
252 }
253 }
254 at32_led_on(LED2);
255 while(1)
256 {
257 }
258}
259
at32f435_437_board.h
adccom_ordinary_valuetab
__IO uint32_t adccom_ordinary_valuetab[5][3]
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c:38
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c:40
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c:113
main
int main(void)
main function.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c:203
adc2_overflow_flag
__IO uint32_t adc2_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c:41
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c:52
edma_config
static void edma_config(void)
edma configuration.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c:75
edma_trans_complete_flag
__IO uint32_t edma_trans_complete_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c:39
edma_init_struct
edma_init_type edma_init_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:40
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:945
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc ...
Definition: at32f435_437_adc.c:742
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f435_437_adc.c:110
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f435_437_adc.c:64
adc_common_config
void adc_common_config(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:203
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f435_437_adc.c:294
adc_resolution_set
void adc_resolution_set(adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral.
Definition: at32f435_437_adc.c:235
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f435_437_adc.c:84
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f435_437_adc.c:359
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f435_437_adc.c:371
adc_dma_request_repeat_enable
void adc_dma_request_repeat_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat.
Definition: at32f435_437_adc.c:274
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f435_437_adc.c:328
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f435_437_adc.c:340
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f435_437_adc.c:260
adc_common_default_para_init
void adc_common_default_para_init(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:155
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f435_437_adc.c:472
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f435_437_adc.h:178
ADC_CHANNEL_9
@ ADC_CHANNEL_9
Definition: at32f435_437_adc.h:196
ADC_CHANNEL_8
@ ADC_CHANNEL_8
Definition: at32f435_437_adc.h:195
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f435_437_adc.h:191
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f435_437_adc.h:193
ADC_CHANNEL_7
@ ADC_CHANNEL_7
Definition: at32f435_437_adc.h:194
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f435_437_adc.h:192
ADC_SAMPLETIME_640_5
@ ADC_SAMPLETIME_640_5
Definition: at32f435_437_adc.h:220
ADC_SAMPLING_INTERVAL_5CYCLES
@ ADC_SAMPLING_INTERVAL_5CYCLES
Definition: at32f435_437_adc.h:144
ADC_COMMON_DMAMODE_2
@ ADC_COMMON_DMAMODE_2
Definition: at32f435_437_adc.h:133
ADC_ORDINARY_SMLT_ONLY_ONESLAVE_MODE
@ ADC_ORDINARY_SMLT_ONLY_ONESLAVE_MODE
Definition: at32f435_437_adc.h:115
ADC_ORDINARY_TRIG_TMR1CH1
@ ADC_ORDINARY_TRIG_TMR1CH1
Definition: at32f435_437_adc.h:228
ADC_ORDINARY_TRIG_EDGE_NONE
@ ADC_ORDINARY_TRIG_EDGE_NONE
Definition: at32f435_437_adc.h:265
ADC_RESOLUTION_12B
@ ADC_RESOLUTION_12B
Definition: at32f435_437_adc.h:167
ADC_HCLK_DIV_4
@ ADC_HCLK_DIV_4
Definition: at32f435_437_adc.h:90
ADC_RDY_FLAG
#define ADC_RDY_FLAG
Definition: at32f435_437_adc.h:73
ADC_OCCO_INT
#define ADC_OCCO_INT
Definition: at32f435_437_adc.h:56
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
ADC2
#define ADC2
Definition: at32f435_437_adc.h:867
ADCCOM
#define ADCCOM
Definition: at32f435_437_adc.h:869
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_EDMA_PERIPH_CLOCK
@ CRM_EDMA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:114
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:158
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_ADC2_PERIPH_CLOCK
@ CRM_ADC2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:159
edmamux_init
void edmamux_init(edmamux_channel_type *edmamux_channelx, edmamux_requst_id_sel_type edmamux_req_id)
edmamux init.
Definition: at32f435_437_edma.c:718
edma_init
void edma_init(edma_stream_type *edma_streamx, edma_init_type *edma_init_struct)
edma init.
Definition: at32f435_437_edma.c:115
edma_stream_enable
void edma_stream_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx.
Definition: at32f435_437_edma.c:198
edma_reset
void edma_reset(edma_stream_type *edma_streamx)
reset edma_streamx channely register.
Definition: at32f435_437_edma.c:58
edmamux_enable
void edmamux_enable(confirm_state new_state)
enable or disable the edma edmamux.
Definition: at32f435_437_edma.c:673
edma_interrupt_enable
void edma_interrupt_enable(edma_stream_type *edma_streamx, uint32_t edma_int, confirm_state new_state)
enable or disable the edma streamx interrupts.
Definition: at32f435_437_edma.c:225
edma_default_para_init
void edma_default_para_init(edma_init_type *edma_init_struct)
edma init struct config with its default value.
Definition: at32f435_437_edma.c:165
EDMA_PRIORITY_VERY_HIGH
@ EDMA_PRIORITY_VERY_HIGH
Definition: at32f435_437_edma.h:192
EDMA_PERIPHERAL_DATA_WIDTH_WORD
@ EDMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_edma.h:171
EDMA_MEMORY_DATA_WIDTH_WORD
@ EDMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f435_437_edma.h:181
EDMA_MEMORY_SINGLE
@ EDMA_MEMORY_SINGLE
Definition: at32f435_437_edma.h:224
EDMA_PERIPHERAL_SINGLE
@ EDMA_PERIPHERAL_SINGLE
Definition: at32f435_437_edma.h:235
EDMA_FIFO_THRESHOLD_1QUARTER
@ EDMA_FIFO_THRESHOLD_1QUARTER
Definition: at32f435_437_edma.h:200
EDMA_DIR_PERIPHERAL_TO_MEMORY
@ EDMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_edma.h:159
EDMAMUX_DMAREQ_ID_ADC1
@ EDMAMUX_DMAREQ_ID_ADC1
Definition: at32f435_437_edma.h:259
EDMA_FDT_INT
#define EDMA_FDT_INT
Definition: at32f435_437_edma.h:55
EDMA_STREAM1
#define EDMA_STREAM1
Definition: at32f435_437_edma.h:962
EDMAMUX_CHANNEL1
#define EDMAMUX_CHANNEL1
Definition: at32f435_437_edma.h:989
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f435_437_gpio.h:85
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
EDMA_Stream1_IRQn
@ EDMA_Stream1_IRQn
Definition: at32f435_437.h:157
ADC1_2_3_IRQn
@ ADC1_2_3_IRQn
Definition: at32f435_437.h:166
adc_base_config_type
adc base config type
Definition: at32f435_437_adc.h:402
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f435_437_adc.h:405
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f435_437_adc.h:404
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f435_437_adc.h:403
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f435_437_adc.h:406
adc_common_config_type
adc common config type
Definition: at32f435_437_adc.h:388
adc_common_config_type::sampling_interval
adc_sampling_interval_type sampling_interval
Definition: at32f435_437_adc.h:393
adc_common_config_type::tempervintrv_state
confirm_state tempervintrv_state
Definition: at32f435_437_adc.h:394
adc_common_config_type::div
adc_div_type div
Definition: at32f435_437_adc.h:390
adc_common_config_type::common_dma_mode
adc_common_dma_mode_type common_dma_mode
Definition: at32f435_437_adc.h:391
adc_common_config_type::common_dma_request_repeat_state
confirm_state common_dma_request_repeat_state
Definition: at32f435_437_adc.h:392
adc_common_config_type::combine_mode
adc_combine_mode_type combine_mode
Definition: at32f435_437_adc.h:389
adc_common_config_type::vbat_state
confirm_state vbat_state
Definition: at32f435_437_adc.h:395
edma_init_type
edma init type
Definition: at32f435_437_edma.h:440
edma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_edma.h:441
edma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_edma.h:444
edma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_edma.h:446
edma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_edma.h:445
edma_init_type::direction
edma_dir_type direction
Definition: at32f435_437_edma.h:443
edma_init_type::fifo_mode_enable
confirm_state fifo_mode_enable
Definition: at32f435_437_edma.h:451
edma_init_type::peripheral_data_width
edma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_edma.h:447
edma_init_type::fifo_threshold
edma_fifo_threshold_type fifo_threshold
Definition: at32f435_437_edma.h:452
edma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_edma.h:449
edma_init_type::priority
edma_priority_level_type priority
Definition: at32f435_437_edma.h:450
edma_init_type::memory0_base_addr
uint32_t memory0_base_addr
Definition: at32f435_437_edma.h:442
edma_init_type::peripheral_burst_mode
edma_peripheral_burst_type peripheral_burst_mode
Definition: at32f435_437_edma.h:454
edma_init_type::memory_data_width
edma_memory_data_size_type memory_data_width
Definition: at32f435_437_edma.h:448
edma_init_type::memory_burst_mode
edma_memory_burst_type memory_burst_mode
Definition: at32f435_437_edma.h:453
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma1
  • inc
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma1
  • inc
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma1
  • inc
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma1
  • src
Functions
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 49 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma1
  • src
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_clock.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma1
  • src
Functions | Variables
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...

Variables

__IO uint32_t | dma1_trans_complete_flag
__IO uint32_t | adc1_overflow_flag
__IO uint32_t | adc2_overflow_flag
__IO uint32_t | adc3_overflow_flag

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma1
  • src
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
38extern __IO uint32_t dma1_trans_complete_flag;
39extern __IO uint32_t adc1_overflow_flag;
40extern __IO uint32_t adc2_overflow_flag;
41extern __IO uint32_t adc3_overflow_flag;
42
48void NMI_Handler(void)
49{
50}
51
57void HardFault_Handler(void)
58{
59 /* go to infinite loop when hard fault exception occurs */
60 while(1)
61 {
62 }
63}
64
70void MemManage_Handler(void)
71{
72 /* go to infinite loop when memory manage exception occurs */
73 while(1)
74 {
75 }
76}
77
83void BusFault_Handler(void)
84{
85 /* go to infinite loop when bus fault exception occurs */
86 while(1)
87 {
88 }
89}
90
96void UsageFault_Handler(void)
97{
98 /* go to infinite loop when usage fault exception occurs */
99 while(1)
100 {
101 }
102}
103
109void SVC_Handler(void)
110{
111}
112
118void DebugMon_Handler(void)
119{
120}
121
127void PendSV_Handler(void)
128{
129}
130
136void SysTick_Handler(void)
137{
138}
139
145void DMA1_Channel1_IRQHandler(void)
146{
147 if(dma_flag_get(DMA1_FDT1_FLAG) != RESET)
148 {
149 dma_flag_clear(DMA1_FDT1_FLAG);
150 dma1_trans_complete_flag = 1;
151 }
152}
153
159void ADC1_2_3_IRQHandler(void)
160{
161 if(adc_flag_get(ADC1, ADC_OCCO_FLAG) != RESET)
162 {
163 adc_flag_clear(ADC1, ADC_OCCO_FLAG);
164 adc1_overflow_flag++;
165 }
166 if(adc_flag_get(ADC2, ADC_OCCO_FLAG) != RESET)
167 {
168 adc_flag_clear(ADC2, ADC_OCCO_FLAG);
169 adc2_overflow_flag++;
170 }
171 if(adc_flag_get(ADC3, ADC_OCCO_FLAG) != RESET)
172 {
173 adc_flag_clear(ADC3, ADC_OCCO_FLAG);
174 adc3_overflow_flag++;
175 }
176}
177
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c:96
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c:57
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c:70
adc3_overflow_flag
__IO uint32_t adc3_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:42
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c:109
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:40
ADC1_2_3_IRQHandler
void ADC1_2_3_IRQHandler(void)
this function handles adc1_2_3 handler.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c:159
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c:127
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c:48
dma1_trans_complete_flag
__IO uint32_t dma1_trans_complete_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:39
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1_channel1 handler.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c:145
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c:83
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c:136
adc2_overflow_flag
__IO uint32_t adc2_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:41
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/at32f435_437_int.c:118
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1106
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
ADC_OCCO_FLAG
#define ADC_OCCO_FLAG
Definition: at32f435_437_adc.h:72
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
ADC2
#define ADC2
Definition: at32f435_437_adc.h:867
ADC3
#define ADC3
Definition: at32f435_437_adc.h:868
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f435_437_dma.h:66
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma1
  • src
Functions | Variables
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | tmr1_config (void)
tmr1 configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adccom_ordinary_valuetab [3][3][3]
__IO uint32_t | dma1_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint32_t | adc2_overflow_flag = 0
__IO uint32_t | adc3_overflow_flag = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma1
  • src
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38__IO uint16_t adccom_ordinary_valuetab[3][3][3];
39__IO uint32_t dma1_trans_complete_flag = 0;
40__IO uint32_t adc1_overflow_flag = 0;
41__IO uint32_t adc2_overflow_flag = 0;
42__IO uint32_t adc3_overflow_flag = 0;
43
44static void gpio_config(void);
45static void tmr1_config(void);
46static void dma_config(void);
47static void adc_config(void);
48
54static void gpio_config(void)
55{
56 gpio_init_type gpio_initstructure;
57 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
58 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
59 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
60
61 gpio_default_para_init(&gpio_initstructure);
62
63 /* config adc pin as analog input mode */
64 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
65 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6 | GPIO_PINS_7;
66 gpio_init(GPIOA, &gpio_initstructure);
67
68 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
69 gpio_initstructure.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
70 gpio_init(GPIOB, &gpio_initstructure);
71
72 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
73 gpio_initstructure.gpio_pins = GPIO_PINS_0 | GPIO_PINS_2 | GPIO_PINS_3;
74 gpio_init(GPIOC, &gpio_initstructure);
75}
76
82static void tmr1_config(void)
83{
84 gpio_init_type gpio_initstructure;
85 tmr_output_config_type tmr_oc_init_structure;
86 crm_clocks_freq_type crm_clocks_freq_struct = {0};
87 crm_periph_clock_enable(CRM_GPIOE_PERIPH_CLOCK, TRUE);
88 gpio_pin_mux_config(GPIOE, GPIO_PINS_SOURCE14, GPIO_MUX_1);
89
90 gpio_default_para_init(&gpio_initstructure);
91 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
92 gpio_initstructure.gpio_pins = GPIO_PINS_14;
93 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
94 gpio_initstructure.gpio_pull = GPIO_PULL_NONE;
95 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
96 gpio_init(GPIOE, &gpio_initstructure);
97
98 /* get system clock */
99 crm_clocks_freq_get(&crm_clocks_freq_struct);
100
101 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
102
103 /* (systemclock/(systemclock/10000))/1000 = 10Hz(100ms) */
104 tmr_base_init(TMR1, 999, (crm_clocks_freq_struct.sclk_freq/10000 - 1));
105 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
106 tmr_clock_source_div_set(TMR1, TMR_CLOCK_DIV1);
107
108 tmr_output_default_para_init(&tmr_oc_init_structure);
109 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
110 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
111 tmr_oc_init_structure.oc_output_state = TRUE;
112 tmr_oc_init_structure.oc_idle_state = FALSE;
113 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_4, &tmr_oc_init_structure);
114 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_4, 500);
115 tmr_trgout2_enable(TMR1, TRUE);
116 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_4, TRUE);
117 tmr_output_enable(TMR1, TRUE);
118 tmr_primary_mode_select(TMR1, TMR_PRIMARY_SEL_C4ORAW);
119}
120
126static void dma_config(void)
127{
128 dma_init_type dma_init_struct;
129 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
130 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
131
132 dma_reset(DMA1_CHANNEL1);
133 dma_default_para_init(&dma_init_struct);
134 dma_init_struct.buffer_size = 27;
135 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
136 dma_init_struct.memory_base_addr = (uint32_t)adccom_ordinary_valuetab;
137 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
138 dma_init_struct.memory_inc_enable = TRUE;
139 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADCCOM->codt);
140 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
141 dma_init_struct.peripheral_inc_enable = FALSE;
142 dma_init_struct.priority = DMA_PRIORITY_HIGH;
143 dma_init_struct.loop_mode_enable = FALSE;
144 dma_init(DMA1_CHANNEL1, &dma_init_struct);
145
146 dmamux_enable(DMA1, TRUE);
147 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_ADC1);
148
149 /* enable dma transfer complete interrupt */
150 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
151 dma_channel_enable(DMA1_CHANNEL1, TRUE);
152}
153
159static void adc_config(void)
160{
161 adc_common_config_type adc_common_struct;
162 adc_base_config_type adc_base_struct;
163 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
164 crm_periph_clock_enable(CRM_ADC2_PERIPH_CLOCK, TRUE);
165 crm_periph_clock_enable(CRM_ADC3_PERIPH_CLOCK, TRUE);
166 nvic_irq_enable(ADC1_2_3_IRQn, 0, 0);
167
168 adc_common_default_para_init(&adc_common_struct);
169
170 /* config combine mode */
171 adc_common_struct.combine_mode = ADC_ORDINARY_SMLT_ONLY_TWOSLAVE_MODE;
172
173 /* config division,adcclk is division by hclk */
174 adc_common_struct.div = ADC_HCLK_DIV_4;
175
176 /* config common dma mode,it's useful for ordinary group in combine mode */
177 adc_common_struct.common_dma_mode = ADC_COMMON_DMAMODE_1;
178
179 /* config common dma request repeat */
180 adc_common_struct.common_dma_request_repeat_state = FALSE;
181
182 /* config adjacent adc sampling interval,it's useful for ordinary shifting mode */
183 adc_common_struct.sampling_interval = ADC_SAMPLING_INTERVAL_5CYCLES;
184
185 /* config inner temperature sensor and vintrv */
186 adc_common_struct.tempervintrv_state = FALSE;
187
188 /* config voltage battery */
189 adc_common_struct.vbat_state = FALSE;
190 adc_common_config(&adc_common_struct);
191
192 adc_base_default_para_init(&adc_base_struct);
193
194 adc_base_struct.sequence_mode = TRUE;
195 adc_base_struct.repeat_mode = FALSE;
196 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
197 adc_base_struct.ordinary_channel_length = 3;
198 adc_base_config(ADC1, &adc_base_struct);
199 adc_resolution_set(ADC1, ADC_RESOLUTION_12B);
200
201 /* config ordinary channel */
202 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_47_5);
203 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_47_5);
204 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_47_5);
205
206 /* config ordinary trigger source and trigger edge */
207 adc_ordinary_conversion_trigger_set(ADC1, ADC_ORDINARY_TRIG_TMR1TRGOUT2, ADC_ORDINARY_TRIG_EDGE_RISING);
208
209 /* config dma mode,it's not useful when common dma mode is use */
210 adc_dma_mode_enable(ADC1, FALSE);
211
212 /* config dma request repeat,it's not useful when common dma mode is use */
213 adc_dma_request_repeat_enable(ADC1, FALSE);
214
215 /* enable adc overflow interrupt */
216 adc_interrupt_enable(ADC1, ADC_OCCO_INT, TRUE);
217
218 adc_base_config(ADC2, &adc_base_struct);
219 adc_resolution_set(ADC2, ADC_RESOLUTION_12B);
220 adc_ordinary_channel_set(ADC2, ADC_CHANNEL_7, 1, ADC_SAMPLETIME_47_5);
221 adc_ordinary_channel_set(ADC2, ADC_CHANNEL_8, 2, ADC_SAMPLETIME_47_5);
222 adc_ordinary_channel_set(ADC2, ADC_CHANNEL_9, 3, ADC_SAMPLETIME_47_5);
223 adc_ordinary_conversion_trigger_set(ADC2, ADC_ORDINARY_TRIG_TMR1TRGOUT2, ADC_ORDINARY_TRIG_EDGE_NONE);
224 adc_dma_mode_enable(ADC2, FALSE);
225 adc_dma_request_repeat_enable(ADC2, FALSE);
226 adc_interrupt_enable(ADC2, ADC_OCCO_INT, TRUE);
227
228 adc_base_config(ADC3, &adc_base_struct);
229 adc_resolution_set(ADC3, ADC_RESOLUTION_12B);
230 adc_ordinary_channel_set(ADC3, ADC_CHANNEL_10, 1, ADC_SAMPLETIME_47_5);
231 adc_ordinary_channel_set(ADC3, ADC_CHANNEL_12, 2, ADC_SAMPLETIME_47_5);
232 adc_ordinary_channel_set(ADC3, ADC_CHANNEL_13, 3, ADC_SAMPLETIME_47_5);
233 adc_ordinary_conversion_trigger_set(ADC3, ADC_ORDINARY_TRIG_TMR1TRGOUT2, ADC_ORDINARY_TRIG_EDGE_NONE);
234 adc_dma_mode_enable(ADC3, FALSE);
235 adc_dma_request_repeat_enable(ADC3, FALSE);
236 adc_interrupt_enable(ADC3, ADC_OCCO_INT, TRUE);
237
238 /* adc enable */
239 adc_enable(ADC1, TRUE);
240 adc_enable(ADC2, TRUE);
241 adc_enable(ADC3, TRUE);
242 while(adc_flag_get(ADC1, ADC_RDY_FLAG) == RESET);
243 while(adc_flag_get(ADC2, ADC_RDY_FLAG) == RESET);
244 while(adc_flag_get(ADC3, ADC_RDY_FLAG) == RESET);
245
246 /* adc calibration */
247 adc_calibration_init(ADC1);
248 while(adc_calibration_init_status_get(ADC1));
249 adc_calibration_start(ADC1);
250 while(adc_calibration_status_get(ADC1));
251 adc_calibration_init(ADC2);
252 while(adc_calibration_init_status_get(ADC2));
253 adc_calibration_start(ADC2);
254 while(adc_calibration_status_get(ADC2));
255 adc_calibration_init(ADC3);
256 while(adc_calibration_init_status_get(ADC3));
257 adc_calibration_start(ADC3);
258 while(adc_calibration_status_get(ADC3));
259}
260
266int main(void)
267{
268 __IO uint32_t index1 = 0;
269 __IO uint32_t index2 = 0;
270 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
271
272 /* config the system clock */
273 system_clock_config();
274
275 /* init at start board */
276 at32_board_init();
277 at32_led_off(LED2);
278 at32_led_off(LED3);
279 at32_led_off(LED4);
280 uart_print_init(115200);
281 gpio_config();
282 tmr1_config();
283 dma_config();
284 adc_config();
285 printf("combine_mode_ordinary_smlt_twoslave_dma1 \r\n");
286 tmr_counter_enable(TMR1, TRUE);
287 while(dma1_trans_complete_flag == 0);
288 tmr_counter_enable(TMR1, FALSE);
289 if((adc1_overflow_flag != 0) || (adc2_overflow_flag != 0) || (adc3_overflow_flag != 0))
290 {
291 /* printf flag when error occur */
292 at32_led_on(LED3);
293 at32_led_on(LED4);
294 printf("error occur\r\n");
295 printf("adc1_overflow_flag = %d\r\n",adc1_overflow_flag);
296 printf("adc2_overflow_flag = %d\r\n",adc2_overflow_flag);
297 printf("adc3_overflow_flag = %d\r\n",adc3_overflow_flag);
298 }
299 else
300 {
301 /* printf data when conversion end without error */
302 printf("conversion end without error\r\n");
303 for(index1 = 0; index1 < 3; index1++)
304 {
305 for(index2 = 0; index2 < 3; index2++)
306 {
307 printf("adccom_ordinary_valuetab[%d][%d][0] = 0x%x\r\n",index1, index2, adccom_ordinary_valuetab[index1][index2][0]);
308 printf("adccom_ordinary_valuetab[%d][%d][1] = 0x%x\r\n",index1, index2, adccom_ordinary_valuetab[index1][index2][1]);
309 printf("adccom_ordinary_valuetab[%d][%d][2] = 0x%x\r\n",index1, index2, adccom_ordinary_valuetab[index1][index2][2]);
310 }
311 printf("\r\n");
312 }
313 }
314 at32_led_on(LED2);
315 while(1)
316 {
317 }
318}
319
at32f435_437_board.h
adccom_ordinary_valuetab
__IO uint16_t adccom_ordinary_valuetab[3][3][3]
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c:38
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c:126
adc3_overflow_flag
__IO uint32_t adc3_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c:42
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c:40
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c:159
dma1_trans_complete_flag
__IO uint32_t dma1_trans_complete_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c:266
tmr1_config
static void tmr1_config(void)
tmr1 configuration.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c:82
adc2_overflow_flag
__IO uint32_t adc2_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c:41
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma1/src/main.c:54
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:40
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc ...
Definition: at32f435_437_adc.c:742
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f435_437_adc.c:110
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f435_437_adc.c:64
adc_common_config
void adc_common_config(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:203
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f435_437_adc.c:294
adc_resolution_set
void adc_resolution_set(adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral.
Definition: at32f435_437_adc.c:235
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f435_437_adc.c:84
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f435_437_adc.c:359
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f435_437_adc.c:371
adc_dma_request_repeat_enable
void adc_dma_request_repeat_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat.
Definition: at32f435_437_adc.c:274
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f435_437_adc.c:328
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f435_437_adc.c:340
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f435_437_adc.c:260
adc_common_default_para_init
void adc_common_default_para_init(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:155
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f435_437_adc.c:472
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f435_437_adc.h:178
ADC_CHANNEL_9
@ ADC_CHANNEL_9
Definition: at32f435_437_adc.h:196
ADC_CHANNEL_8
@ ADC_CHANNEL_8
Definition: at32f435_437_adc.h:195
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f435_437_adc.h:191
ADC_CHANNEL_12
@ ADC_CHANNEL_12
Definition: at32f435_437_adc.h:199
ADC_CHANNEL_10
@ ADC_CHANNEL_10
Definition: at32f435_437_adc.h:197
ADC_CHANNEL_13
@ ADC_CHANNEL_13
Definition: at32f435_437_adc.h:200
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f435_437_adc.h:193
ADC_CHANNEL_7
@ ADC_CHANNEL_7
Definition: at32f435_437_adc.h:194
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f435_437_adc.h:192
ADC_SAMPLETIME_47_5
@ ADC_SAMPLETIME_47_5
Definition: at32f435_437_adc.h:217
ADC_SAMPLING_INTERVAL_5CYCLES
@ ADC_SAMPLING_INTERVAL_5CYCLES
Definition: at32f435_437_adc.h:144
ADC_COMMON_DMAMODE_1
@ ADC_COMMON_DMAMODE_1
Definition: at32f435_437_adc.h:132
ADC_ORDINARY_SMLT_ONLY_TWOSLAVE_MODE
@ ADC_ORDINARY_SMLT_ONLY_TWOSLAVE_MODE
Definition: at32f435_437_adc.h:121
ADC_ORDINARY_TRIG_TMR1TRGOUT2
@ ADC_ORDINARY_TRIG_TMR1TRGOUT2
Definition: at32f435_437_adc.h:250
ADC_ORDINARY_TRIG_EDGE_RISING
@ ADC_ORDINARY_TRIG_EDGE_RISING
Definition: at32f435_437_adc.h:266
ADC_ORDINARY_TRIG_EDGE_NONE
@ ADC_ORDINARY_TRIG_EDGE_NONE
Definition: at32f435_437_adc.h:265
ADC_RESOLUTION_12B
@ ADC_RESOLUTION_12B
Definition: at32f435_437_adc.h:167
ADC_HCLK_DIV_4
@ ADC_HCLK_DIV_4
Definition: at32f435_437_adc.h:90
ADC_RDY_FLAG
#define ADC_RDY_FLAG
Definition: at32f435_437_adc.h:73
ADC_OCCO_INT
#define ADC_OCCO_INT
Definition: at32f435_437_adc.h:56
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
ADC2
#define ADC2
Definition: at32f435_437_adc.h:867
ADC3
#define ADC3
Definition: at32f435_437_adc.h:868
ADCCOM
#define ADCCOM
Definition: at32f435_437_adc.h:869
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_ADC3_PERIPH_CLOCK
@ CRM_ADC3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:160
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:158
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
CRM_GPIOE_PERIPH_CLOCK
@ CRM_GPIOE_PERIPH_CLOCK
Definition: at32f435_437_crm.h:109
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:154
CRM_ADC2_PERIPH_CLOCK
@ CRM_ADC2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:159
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_ADC1
@ DMAMUX_DMAREQ_ID_ADC1
Definition: at32f435_437_dma.h:197
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f435_437_gpio.h:85
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_1
@ GPIO_MUX_1
Definition: at32f435_437_gpio.h:157
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
GPIOE
#define GPIOE
Definition: at32f435_437_gpio.h:525
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f435_437_tmr.c:1499
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_trgout2_enable
void tmr_trgout2_enable(tmr_type *tmr_x, confirm_state new_state)
select tmr trgout2
Definition: at32f435_437_tmr.c:1300
tmr_primary_mode_select
void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode
Definition: at32f435_437_tmr.c:1222
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_enable
void tmr_channel_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable
Definition: at32f435_437_tmr.c:940
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f435_437_tmr.h:223
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f435_437_tmr.h:97
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f435_437_tmr.h:180
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f435_437_tmr.h:199
TMR_PRIMARY_SEL_C4ORAW
@ TMR_PRIMARY_SEL_C4ORAW
Definition: at32f435_437_tmr.h:126
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f435_437.h:204
ADC1_2_3_IRQn
@ ADC1_2_3_IRQn
Definition: at32f435_437.h:166
adc_base_config_type
adc base config type
Definition: at32f435_437_adc.h:402
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f435_437_adc.h:405
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f435_437_adc.h:404
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f435_437_adc.h:403
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f435_437_adc.h:406
adc_common_config_type
adc common config type
Definition: at32f435_437_adc.h:388
adc_common_config_type::sampling_interval
adc_sampling_interval_type sampling_interval
Definition: at32f435_437_adc.h:393
adc_common_config_type::tempervintrv_state
confirm_state tempervintrv_state
Definition: at32f435_437_adc.h:394
adc_common_config_type::div
adc_div_type div
Definition: at32f435_437_adc.h:390
adc_common_config_type::common_dma_mode
adc_common_dma_mode_type common_dma_mode
Definition: at32f435_437_adc.h:391
adc_common_config_type::common_dma_request_repeat_state
confirm_state common_dma_request_repeat_state
Definition: at32f435_437_adc.h:392
adc_common_config_type::combine_mode
adc_combine_mode_type combine_mode
Definition: at32f435_437_adc.h:389
adc_common_config_type::vbat_state
confirm_state vbat_state
Definition: at32f435_437_adc.h:395
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f435_437_crm.h:789
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma5
  • inc
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma5
  • inc
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma5
  • inc
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma5
  • src
Functions
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 49 of file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma5
  • src
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_clock.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma5
  • src
Functions | Variables
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...

Variables

__IO uint32_t | dma1_trans_complete_flag
__IO uint32_t | adc1_overflow_flag
__IO uint32_t | adc2_overflow_flag
__IO uint32_t | adc3_overflow_flag

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma5
  • src
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
38extern __IO uint32_t dma1_trans_complete_flag;
39extern __IO uint32_t adc1_overflow_flag;
40extern __IO uint32_t adc2_overflow_flag;
41extern __IO uint32_t adc3_overflow_flag;
42
48void NMI_Handler(void)
49{
50}
51
57void HardFault_Handler(void)
58{
59 /* go to infinite loop when hard fault exception occurs */
60 while(1)
61 {
62 }
63}
64
70void MemManage_Handler(void)
71{
72 /* go to infinite loop when memory manage exception occurs */
73 while(1)
74 {
75 }
76}
77
83void BusFault_Handler(void)
84{
85 /* go to infinite loop when bus fault exception occurs */
86 while(1)
87 {
88 }
89}
90
96void UsageFault_Handler(void)
97{
98 /* go to infinite loop when usage fault exception occurs */
99 while(1)
100 {
101 }
102}
103
109void SVC_Handler(void)
110{
111}
112
118void DebugMon_Handler(void)
119{
120}
121
127void PendSV_Handler(void)
128{
129}
130
136void SysTick_Handler(void)
137{
138}
139
145void DMA1_Channel1_IRQHandler(void)
146{
147 if(dma_flag_get(DMA1_FDT1_FLAG) != RESET)
148 {
149 dma_flag_clear(DMA1_FDT1_FLAG);
150 dma1_trans_complete_flag = 1;
151 }
152}
153
159void ADC1_2_3_IRQHandler(void)
160{
161 if(adc_flag_get(ADC1, ADC_OCCO_FLAG) != RESET)
162 {
163 adc_flag_clear(ADC1, ADC_OCCO_FLAG);
164 adc1_overflow_flag++;
165 }
166 if(adc_flag_get(ADC2, ADC_OCCO_FLAG) != RESET)
167 {
168 adc_flag_clear(ADC2, ADC_OCCO_FLAG);
169 adc2_overflow_flag++;
170 }
171 if(adc_flag_get(ADC3, ADC_OCCO_FLAG) != RESET)
172 {
173 adc_flag_clear(ADC3, ADC_OCCO_FLAG);
174 adc3_overflow_flag++;
175 }
176}
177
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c:96
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c:57
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c:70
adc3_overflow_flag
__IO uint32_t adc3_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:42
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c:109
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:40
ADC1_2_3_IRQHandler
void ADC1_2_3_IRQHandler(void)
this function handles adc1_2_3 handler.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c:159
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c:127
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c:48
dma1_trans_complete_flag
__IO uint32_t dma1_trans_complete_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:39
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1_channel1 handler.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c:145
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c:83
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c:136
adc2_overflow_flag
__IO uint32_t adc2_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:41
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/at32f435_437_int.c:118
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1106
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
ADC_OCCO_FLAG
#define ADC_OCCO_FLAG
Definition: at32f435_437_adc.h:72
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
ADC2
#define ADC2
Definition: at32f435_437_adc.h:867
ADC3
#define ADC3
Definition: at32f435_437_adc.h:868
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f435_437_dma.h:66
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma5
  • src
Functions | Variables
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | tmr1_config (void)
tmr1 configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | adccom_ordinary_valuetab [3][3][2]
__IO uint32_t | dma1_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0
__IO uint32_t | adc2_overflow_flag = 0
__IO uint32_t | adc3_overflow_flag = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_ordinary_smlt_twoslave_dma5
  • src
project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38__IO uint32_t adccom_ordinary_valuetab[3][3][2];
39__IO uint32_t dma1_trans_complete_flag = 0;
40__IO uint32_t adc1_overflow_flag = 0;
41__IO uint32_t adc2_overflow_flag = 0;
42__IO uint32_t adc3_overflow_flag = 0;
43
44static void gpio_config(void);
45static void tmr1_config(void);
46static void dma_config(void);
47static void adc_config(void);
48
54static void gpio_config(void)
55{
56 gpio_init_type gpio_initstructure;
57 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
58 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
59 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
60
61 gpio_default_para_init(&gpio_initstructure);
62
63 /* config adc pin as analog input mode */
64 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
65 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6 | GPIO_PINS_7;
66 gpio_init(GPIOA, &gpio_initstructure);
67
68 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
69 gpio_initstructure.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
70 gpio_init(GPIOB, &gpio_initstructure);
71
72 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
73 gpio_initstructure.gpio_pins = GPIO_PINS_0 | GPIO_PINS_2 | GPIO_PINS_3;
74 gpio_init(GPIOC, &gpio_initstructure);
75}
76
82static void tmr1_config(void)
83{
84 gpio_init_type gpio_initstructure;
85 tmr_output_config_type tmr_oc_init_structure;
86 crm_clocks_freq_type crm_clocks_freq_struct = {0};
87 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
88
89 gpio_default_para_init(&gpio_initstructure);
90 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
91 gpio_initstructure.gpio_pins = GPIO_PINS_8;
92 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
93 gpio_initstructure.gpio_pull = GPIO_PULL_NONE;
94 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
95 gpio_init(GPIOA, &gpio_initstructure);
96 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE8, GPIO_MUX_1);
97
98 /* get system clock */
99 crm_clocks_freq_get(&crm_clocks_freq_struct);
100
101 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
102
103 /* (systemclock/(systemclock/10000))/1000 = 10Hz(100ms) */
104 tmr_base_init(TMR1, 999, (crm_clocks_freq_struct.sclk_freq/10000 - 1));
105 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
106 tmr_clock_source_div_set(TMR1, TMR_CLOCK_DIV1);
107
108 tmr_output_default_para_init(&tmr_oc_init_structure);
109 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
110 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
111 tmr_oc_init_structure.oc_output_state = TRUE;
112 tmr_oc_init_structure.oc_idle_state = FALSE;
113 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
114 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, 500);
115 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1, TRUE);
116 tmr_output_enable(TMR1, TRUE);
117}
118
124static void dma_config(void)
125{
126 dma_init_type dma_init_struct;
127 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
128 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
129
130 dma_reset(DMA1_CHANNEL1);
131 dma_default_para_init(&dma_init_struct);
132 dma_init_struct.buffer_size = 18;
133 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
134 dma_init_struct.memory_base_addr = (uint32_t)adccom_ordinary_valuetab;
135 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_WORD;
136 dma_init_struct.memory_inc_enable = TRUE;
137 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADCCOM->codt);
138 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_WORD;
139 dma_init_struct.peripheral_inc_enable = FALSE;
140 dma_init_struct.priority = DMA_PRIORITY_HIGH;
141 dma_init_struct.loop_mode_enable = FALSE;
142 dma_init(DMA1_CHANNEL1, &dma_init_struct);
143
144 dmamux_enable(DMA1, TRUE);
145 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_ADC1);
146
147 /* enable dma transfer complete interrupt */
148 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
149 dma_channel_enable(DMA1_CHANNEL1, TRUE);
150}
151
157static void adc_config(void)
158{
159 adc_common_config_type adc_common_struct;
160 adc_base_config_type adc_base_struct;
161 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
162 crm_periph_clock_enable(CRM_ADC2_PERIPH_CLOCK, TRUE);
163 crm_periph_clock_enable(CRM_ADC3_PERIPH_CLOCK, TRUE);
164 nvic_irq_enable(ADC1_2_3_IRQn, 0, 0);
165
166 adc_common_default_para_init(&adc_common_struct);
167
168 /* config combine mode */
169 adc_common_struct.combine_mode = ADC_ORDINARY_SMLT_ONLY_TWOSLAVE_MODE;
170
171 /* config division,adcclk is division by hclk */
172 adc_common_struct.div = ADC_HCLK_DIV_4;
173
174 /* config common dma mode,it's useful for ordinary group in combine mode */
175 adc_common_struct.common_dma_mode = ADC_COMMON_DMAMODE_5;
176
177 /* config common dma request repeat */
178 adc_common_struct.common_dma_request_repeat_state = FALSE;
179
180 /* config adjacent adc sampling interval,it's useful for ordinary shifting mode */
181 adc_common_struct.sampling_interval = ADC_SAMPLING_INTERVAL_5CYCLES;
182
183 /* config inner temperature sensor and vintrv */
184 adc_common_struct.tempervintrv_state = FALSE;
185
186 /* config voltage battery */
187 adc_common_struct.vbat_state = FALSE;
188 adc_common_config(&adc_common_struct);
189
190 adc_base_default_para_init(&adc_base_struct);
191
192 adc_base_struct.sequence_mode = TRUE;
193 adc_base_struct.repeat_mode = FALSE;
194 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
195 adc_base_struct.ordinary_channel_length = 3;
196 adc_base_config(ADC1, &adc_base_struct);
197 adc_resolution_set(ADC1, ADC_RESOLUTION_12B);
198
199 /* config ordinary channel */
200 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_47_5);
201 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_47_5);
202 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_47_5);
203
204 /* config ordinary trigger source and trigger edge */
205 adc_ordinary_conversion_trigger_set(ADC1, ADC_ORDINARY_TRIG_TMR1CH1, ADC_ORDINARY_TRIG_EDGE_RISING);
206
207 /* config dma mode,it's not useful when common dma mode is use */
208 adc_dma_mode_enable(ADC1, FALSE);
209
210 /* config dma request repeat,it's not useful when common dma mode is use */
211 adc_dma_request_repeat_enable(ADC1, FALSE);
212
213 /* enable adc overflow interrupt */
214 adc_interrupt_enable(ADC1, ADC_OCCO_INT, TRUE);
215
216 adc_base_config(ADC2, &adc_base_struct);
217 adc_resolution_set(ADC2, ADC_RESOLUTION_12B);
218 adc_ordinary_channel_set(ADC2, ADC_CHANNEL_7, 1, ADC_SAMPLETIME_47_5);
219 adc_ordinary_channel_set(ADC2, ADC_CHANNEL_8, 2, ADC_SAMPLETIME_47_5);
220 adc_ordinary_channel_set(ADC2, ADC_CHANNEL_9, 3, ADC_SAMPLETIME_47_5);
221 adc_ordinary_conversion_trigger_set(ADC2, ADC_ORDINARY_TRIG_TMR1CH1, ADC_ORDINARY_TRIG_EDGE_NONE);
222 adc_dma_mode_enable(ADC2, FALSE);
223 adc_dma_request_repeat_enable(ADC2, FALSE);
224 adc_interrupt_enable(ADC2, ADC_OCCO_INT, TRUE);
225
226 adc_base_config(ADC3, &adc_base_struct);
227 adc_resolution_set(ADC3, ADC_RESOLUTION_12B);
228 adc_ordinary_channel_set(ADC3, ADC_CHANNEL_10, 1, ADC_SAMPLETIME_47_5);
229 adc_ordinary_channel_set(ADC3, ADC_CHANNEL_12, 2, ADC_SAMPLETIME_47_5);
230 adc_ordinary_channel_set(ADC3, ADC_CHANNEL_13, 3, ADC_SAMPLETIME_47_5);
231 adc_ordinary_conversion_trigger_set(ADC3, ADC_ORDINARY_TRIG_TMR1CH1, ADC_ORDINARY_TRIG_EDGE_NONE);
232 adc_dma_mode_enable(ADC3, FALSE);
233 adc_dma_request_repeat_enable(ADC3, FALSE);
234 adc_interrupt_enable(ADC3, ADC_OCCO_INT, TRUE);
235
236 /* adc enable */
237 adc_enable(ADC1, TRUE);
238 adc_enable(ADC2, TRUE);
239 adc_enable(ADC3, TRUE);
240 while(adc_flag_get(ADC1, ADC_RDY_FLAG) == RESET);
241 while(adc_flag_get(ADC2, ADC_RDY_FLAG) == RESET);
242 while(adc_flag_get(ADC3, ADC_RDY_FLAG) == RESET);
243
244 /* adc calibration */
245 adc_calibration_init(ADC1);
246 while(adc_calibration_init_status_get(ADC1));
247 adc_calibration_start(ADC1);
248 while(adc_calibration_status_get(ADC1));
249 adc_calibration_init(ADC2);
250 while(adc_calibration_init_status_get(ADC2));
251 adc_calibration_start(ADC2);
252 while(adc_calibration_status_get(ADC2));
253 adc_calibration_init(ADC3);
254 while(adc_calibration_init_status_get(ADC3));
255 adc_calibration_start(ADC3);
256 while(adc_calibration_status_get(ADC3));
257}
258
264int main(void)
265{
266 __IO uint32_t index1 = 0;
267 __IO uint32_t index2 = 0;
268 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
269
270 /* config the system clock */
271 system_clock_config();
272
273 /* init at start board */
274 at32_board_init();
275 at32_led_off(LED2);
276 at32_led_off(LED3);
277 at32_led_off(LED4);
278 uart_print_init(115200);
279 gpio_config();
280 tmr1_config();
281 dma_config();
282 adc_config();
283 printf("combine_mode_ordinary_smlt_twoslave_dma5 \r\n");
284 tmr_counter_enable(TMR1, TRUE);
285 while(dma1_trans_complete_flag == 0);
286 tmr_counter_enable(TMR1, FALSE);
287 if((adc1_overflow_flag != 0) || (adc2_overflow_flag != 0) || (adc3_overflow_flag != 0))
288 {
289 /* printf flag when error occur */
290 at32_led_on(LED3);
291 at32_led_on(LED4);
292 printf("error occur\r\n");
293 printf("adc1_overflow_flag = %d\r\n",adc1_overflow_flag);
294 printf("adc2_overflow_flag = %d\r\n",adc2_overflow_flag);
295 printf("adc3_overflow_flag = %d\r\n",adc3_overflow_flag);
296 }
297 else
298 {
299 /* printf data when conversion end without error */
300 printf("conversion end without error\r\n");
301 for(index1 = 0; index1 < 3; index1++)
302 {
303 for(index2 = 0; index2 < 3; index2++)
304 {
305 printf("adccom_ordinary_valuetab[%d][%d][0] = 0x%x\r\n",index1, index2, adccom_ordinary_valuetab[index1][index2][0]);
306 printf("adccom_ordinary_valuetab[%d][%d][1] = 0x%x\r\n",index1, index2, adccom_ordinary_valuetab[index1][index2][1]);
307 }
308 printf("\r\n");
309 }
310 }
311 at32_led_on(LED2);
312 while(1)
313 {
314 }
315}
316
at32f435_437_board.h
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c:124
adc3_overflow_flag
__IO uint32_t adc3_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c:42
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c:40
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c:157
dma1_trans_complete_flag
__IO uint32_t dma1_trans_complete_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c:264
tmr1_config
static void tmr1_config(void)
tmr1 configuration.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c:82
adc2_overflow_flag
__IO uint32_t adc2_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c:41
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c:54
adccom_ordinary_valuetab
__IO uint32_t adccom_ordinary_valuetab[3][3][2]
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_twoslave_dma5/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:40
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc ...
Definition: at32f435_437_adc.c:742
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f435_437_adc.c:110
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f435_437_adc.c:64
adc_common_config
void adc_common_config(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:203
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f435_437_adc.c:294
adc_resolution_set
void adc_resolution_set(adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral.
Definition: at32f435_437_adc.c:235
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f435_437_adc.c:84
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f435_437_adc.c:359
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f435_437_adc.c:371
adc_dma_request_repeat_enable
void adc_dma_request_repeat_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat.
Definition: at32f435_437_adc.c:274
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f435_437_adc.c:328
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f435_437_adc.c:340
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f435_437_adc.c:260
adc_common_default_para_init
void adc_common_default_para_init(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:155
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f435_437_adc.c:472
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f435_437_adc.h:178
ADC_CHANNEL_9
@ ADC_CHANNEL_9
Definition: at32f435_437_adc.h:196
ADC_CHANNEL_8
@ ADC_CHANNEL_8
Definition: at32f435_437_adc.h:195
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f435_437_adc.h:191
ADC_CHANNEL_12
@ ADC_CHANNEL_12
Definition: at32f435_437_adc.h:199
ADC_CHANNEL_10
@ ADC_CHANNEL_10
Definition: at32f435_437_adc.h:197
ADC_CHANNEL_13
@ ADC_CHANNEL_13
Definition: at32f435_437_adc.h:200
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f435_437_adc.h:193
ADC_CHANNEL_7
@ ADC_CHANNEL_7
Definition: at32f435_437_adc.h:194
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f435_437_adc.h:192
ADC_SAMPLETIME_47_5
@ ADC_SAMPLETIME_47_5
Definition: at32f435_437_adc.h:217
ADC_SAMPLING_INTERVAL_5CYCLES
@ ADC_SAMPLING_INTERVAL_5CYCLES
Definition: at32f435_437_adc.h:144
ADC_COMMON_DMAMODE_5
@ ADC_COMMON_DMAMODE_5
Definition: at32f435_437_adc.h:136
ADC_ORDINARY_SMLT_ONLY_TWOSLAVE_MODE
@ ADC_ORDINARY_SMLT_ONLY_TWOSLAVE_MODE
Definition: at32f435_437_adc.h:121
ADC_ORDINARY_TRIG_TMR1CH1
@ ADC_ORDINARY_TRIG_TMR1CH1
Definition: at32f435_437_adc.h:228
ADC_ORDINARY_TRIG_EDGE_RISING
@ ADC_ORDINARY_TRIG_EDGE_RISING
Definition: at32f435_437_adc.h:266
ADC_ORDINARY_TRIG_EDGE_NONE
@ ADC_ORDINARY_TRIG_EDGE_NONE
Definition: at32f435_437_adc.h:265
ADC_RESOLUTION_12B
@ ADC_RESOLUTION_12B
Definition: at32f435_437_adc.h:167
ADC_HCLK_DIV_4
@ ADC_HCLK_DIV_4
Definition: at32f435_437_adc.h:90
ADC_RDY_FLAG
#define ADC_RDY_FLAG
Definition: at32f435_437_adc.h:73
ADC_OCCO_INT
#define ADC_OCCO_INT
Definition: at32f435_437_adc.h:56
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
ADC2
#define ADC2
Definition: at32f435_437_adc.h:867
ADC3
#define ADC3
Definition: at32f435_437_adc.h:868
ADCCOM
#define ADCCOM
Definition: at32f435_437_adc.h:869
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_ADC3_PERIPH_CLOCK
@ CRM_ADC3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:160
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:158
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:154
CRM_ADC2_PERIPH_CLOCK
@ CRM_ADC2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:159
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:164
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:174
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_ADC1
@ DMAMUX_DMAREQ_ID_ADC1
Definition: at32f435_437_dma.h:197
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f435_437_gpio.h:85
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_1
@ GPIO_MUX_1
Definition: at32f435_437_gpio.h:157
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f435_437_tmr.c:1499
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_enable
void tmr_channel_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable
Definition: at32f435_437_tmr.c:940
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f435_437_tmr.h:97
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f435_437_tmr.h:180
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f435_437_tmr.h:199
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f435_437.h:204
ADC1_2_3_IRQn
@ ADC1_2_3_IRQn
Definition: at32f435_437.h:166
adc_base_config_type
adc base config type
Definition: at32f435_437_adc.h:402
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f435_437_adc.h:405
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f435_437_adc.h:404
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f435_437_adc.h:403
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f435_437_adc.h:406
adc_common_config_type
adc common config type
Definition: at32f435_437_adc.h:388
adc_common_config_type::sampling_interval
adc_sampling_interval_type sampling_interval
Definition: at32f435_437_adc.h:393
adc_common_config_type::tempervintrv_state
confirm_state tempervintrv_state
Definition: at32f435_437_adc.h:394
adc_common_config_type::div
adc_div_type div
Definition: at32f435_437_adc.h:390
adc_common_config_type::common_dma_mode
adc_common_dma_mode_type common_dma_mode
Definition: at32f435_437_adc.h:391
adc_common_config_type::common_dma_request_repeat_state
confirm_state common_dma_request_repeat_state
Definition: at32f435_437_adc.h:392
adc_common_config_type::combine_mode
adc_combine_mode_type combine_mode
Definition: at32f435_437_adc.h:389
adc_common_config_type::vbat_state
confirm_state vbat_state
Definition: at32f435_437_adc.h:395
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f435_437_crm.h:789
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_preempt_interltrig_twoslave
  • inc
project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_preempt_interltrig_twoslave
  • inc
project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_preempt_interltrig_twoslave
  • inc
project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_preempt_interltrig_twoslave
  • src
Functions
project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 49 of file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_preempt_interltrig_twoslave
  • src
project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_clock.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_preempt_interltrig_twoslave
  • src
Functions | Variables
project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...

Variables

__IO uint16_t | adc1_preempt_valuetab [2][3]
__IO uint16_t | adc2_preempt_valuetab [2][3]
__IO uint16_t | adc3_preempt_valuetab [2][3]
__IO uint16_t | adc1_preempt_conversion_count
__IO uint16_t | adc2_preempt_conversion_count
__IO uint16_t | adc3_preempt_conversion_count

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_preempt_interltrig_twoslave
  • src
project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
38extern __IO uint16_t adc1_preempt_valuetab[2][3];
39extern __IO uint16_t adc2_preempt_valuetab[2][3];
40extern __IO uint16_t adc3_preempt_valuetab[2][3];
41extern __IO uint16_t adc1_preempt_conversion_count;
42extern __IO uint16_t adc2_preempt_conversion_count;
43extern __IO uint16_t adc3_preempt_conversion_count;
44
45
51void NMI_Handler(void)
52{
53}
54
60void HardFault_Handler(void)
61{
62 /* go to infinite loop when hard fault exception occurs */
63 while(1)
64 {
65 }
66}
67
73void MemManage_Handler(void)
74{
75 /* go to infinite loop when memory manage exception occurs */
76 while(1)
77 {
78 }
79}
80
86void BusFault_Handler(void)
87{
88 /* go to infinite loop when bus fault exception occurs */
89 while(1)
90 {
91 }
92}
93
99void UsageFault_Handler(void)
100{
101 /* go to infinite loop when usage fault exception occurs */
102 while(1)
103 {
104 }
105}
106
112void SVC_Handler(void)
113{
114}
115
121void DebugMon_Handler(void)
122{
123}
124
130void PendSV_Handler(void)
131{
132}
133
139void SysTick_Handler(void)
140{
141}
142
148void ADC1_2_3_IRQHandler(void)
149{
150 if(adc_flag_get(ADC1, ADC_PCCE_FLAG) != RESET)
151 {
152 adc_flag_clear(ADC1, ADC_PCCE_FLAG);
153 if(adc1_preempt_conversion_count < 2)
154 {
155 adc1_preempt_valuetab[adc1_preempt_conversion_count][0] = adc_preempt_conversion_data_get(ADC1, ADC_PREEMPT_CHANNEL_1);
156 adc1_preempt_valuetab[adc1_preempt_conversion_count][1] = adc_preempt_conversion_data_get(ADC1, ADC_PREEMPT_CHANNEL_2);
157 adc1_preempt_valuetab[adc1_preempt_conversion_count][2] = adc_preempt_conversion_data_get(ADC1, ADC_PREEMPT_CHANNEL_3);
158 adc1_preempt_conversion_count++;
159 }
160 }
161 if(adc_flag_get(ADC2, ADC_PCCE_FLAG) != RESET)
162 {
163 adc_flag_clear(ADC2, ADC_PCCE_FLAG);
164 if(adc2_preempt_conversion_count < 2)
165 {
166 adc2_preempt_valuetab[adc2_preempt_conversion_count][0] = adc_preempt_conversion_data_get(ADC2, ADC_PREEMPT_CHANNEL_1);
167 adc2_preempt_valuetab[adc2_preempt_conversion_count][1] = adc_preempt_conversion_data_get(ADC2, ADC_PREEMPT_CHANNEL_2);
168 adc2_preempt_valuetab[adc2_preempt_conversion_count][2] = adc_preempt_conversion_data_get(ADC2, ADC_PREEMPT_CHANNEL_3);
169 adc2_preempt_conversion_count++;
170 }
171 }
172 if(adc_flag_get(ADC3, ADC_PCCE_FLAG) != RESET)
173 {
174 adc_flag_clear(ADC3, ADC_PCCE_FLAG);
175 if(adc3_preempt_conversion_count < 2)
176 {
177 adc3_preempt_valuetab[adc3_preempt_conversion_count][0] = adc_preempt_conversion_data_get(ADC3, ADC_PREEMPT_CHANNEL_1);
178 adc3_preempt_valuetab[adc3_preempt_conversion_count][1] = adc_preempt_conversion_data_get(ADC3, ADC_PREEMPT_CHANNEL_2);
179 adc3_preempt_valuetab[adc3_preempt_conversion_count][2] = adc_preempt_conversion_data_get(ADC3, ADC_PREEMPT_CHANNEL_3);
180 adc3_preempt_conversion_count++;
181 }
182 }
183}
184
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c:99
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c:60
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c:73
adc1_preempt_conversion_count
__IO uint16_t adc1_preempt_conversion_count
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c:41
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c:112
adc3_preempt_conversion_count
__IO uint16_t adc3_preempt_conversion_count
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c:43
ADC1_2_3_IRQHandler
void ADC1_2_3_IRQHandler(void)
this function handles adc1_2_3 handler.
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c:148
adc3_preempt_valuetab
__IO uint16_t adc3_preempt_valuetab[2][3]
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c:40
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c:130
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c:51
adc2_preempt_valuetab
__IO uint16_t adc2_preempt_valuetab[2][3]
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c:39
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c:86
adc2_preempt_conversion_count
__IO uint16_t adc2_preempt_conversion_count
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c:42
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c:139
adc1_preempt_valuetab
__IO uint16_t adc1_preempt_valuetab[2][3]
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c:38
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/at32f435_437_int.c:121
adc_preempt_conversion_data_get
uint16_t adc_preempt_conversion_data_get(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral.
Definition: at32f435_437_adc.c:1036
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1106
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
ADC_PREEMPT_CHANNEL_3
@ ADC_PREEMPT_CHANNEL_3
Definition: at32f435_437_adc.h:326
ADC_PREEMPT_CHANNEL_2
@ ADC_PREEMPT_CHANNEL_2
Definition: at32f435_437_adc.h:325
ADC_PREEMPT_CHANNEL_1
@ ADC_PREEMPT_CHANNEL_1
Definition: at32f435_437_adc.h:324
ADC_PCCE_FLAG
#define ADC_PCCE_FLAG
Definition: at32f435_437_adc.h:69
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
ADC2
#define ADC2
Definition: at32f435_437_adc.h:867
ADC3
#define ADC3
Definition: at32f435_437_adc.h:868
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • adc
  • combine_mode_preempt_interltrig_twoslave
  • src
Functions | Variables
project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_preempt_valuetab [2][3] = {0}
__IO uint16_t | adc2_preempt_valuetab [2][3] = {0}
__IO uint16_t | adc3_preempt_valuetab [2][3] = {0}
__IO uint16_t | adc1_preempt_conversion_count = 0
__IO uint16_t | adc2_preempt_conversion_count = 0
__IO uint16_t | adc3_preempt_conversion_count = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • adc
  • combine_mode_preempt_interltrig_twoslave
  • src
project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38__IO uint16_t adc1_preempt_valuetab[2][3] = {0};
39__IO uint16_t adc2_preempt_valuetab[2][3] = {0};
40__IO uint16_t adc3_preempt_valuetab[2][3] = {0};
41__IO uint16_t adc1_preempt_conversion_count = 0;
42__IO uint16_t adc2_preempt_conversion_count = 0;
43__IO uint16_t adc3_preempt_conversion_count = 0;
44
45static void gpio_config(void);
46static void adc_config(void);
47
53static void gpio_config(void)
54{
55 gpio_init_type gpio_initstructure;
56 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
57 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
58 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
59
60 gpio_default_para_init(&gpio_initstructure);
61
62 /* config adc pin as analog input mode */
63 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
64 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6 | GPIO_PINS_7;
65 gpio_init(GPIOA, &gpio_initstructure);
66
67 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
68 gpio_initstructure.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
69 gpio_init(GPIOB, &gpio_initstructure);
70
71 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
72 gpio_initstructure.gpio_pins = GPIO_PINS_0 | GPIO_PINS_2 | GPIO_PINS_3;
73 gpio_init(GPIOC, &gpio_initstructure);
74}
75
81static void adc_config(void)
82{
83 adc_common_config_type adc_common_struct;
84 adc_base_config_type adc_base_struct;
85 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
86 crm_periph_clock_enable(CRM_ADC2_PERIPH_CLOCK, TRUE);
87 crm_periph_clock_enable(CRM_ADC3_PERIPH_CLOCK, TRUE);
88 nvic_irq_enable(ADC1_2_3_IRQn, 0, 0);
89
90 adc_common_default_para_init(&adc_common_struct);
91
92 /* config combine mode */
93 adc_common_struct.combine_mode = ADC_PREEMPT_INTERLTRIG_ONLY_TWOSLAVE_MODE;
94
95 /* config division,adcclk is division by hclk */
96 adc_common_struct.div = ADC_HCLK_DIV_4;
97
98 /* config common dma mode,it's not useful in independent mode */
99 adc_common_struct.common_dma_mode = ADC_COMMON_DMAMODE_DISABLE;
100
101 /* config common dma request repeat */
102 adc_common_struct.common_dma_request_repeat_state = FALSE;
103
104 /* config adjacent adc sampling interval,it's useful for ordinary shifting mode */
105 adc_common_struct.sampling_interval = ADC_SAMPLING_INTERVAL_5CYCLES;
106
107 /* config inner temperature sensor and vintrv */
108 adc_common_struct.tempervintrv_state = FALSE;
109
110 /* config voltage battery */
111 adc_common_struct.vbat_state = FALSE;
112 adc_common_config(&adc_common_struct);
113
114 adc_base_default_para_init(&adc_base_struct);
115
116 adc_base_struct.sequence_mode = TRUE;
117 adc_base_struct.repeat_mode = FALSE;
118 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
119 adc_base_struct.ordinary_channel_length = 3;
120 adc_base_config(ADC1, &adc_base_struct);
121 adc_resolution_set(ADC1, ADC_RESOLUTION_12B);
122
123 /* config ordinary trigger source and trigger edge */
124 adc_ordinary_conversion_trigger_set(ADC1, ADC_ORDINARY_TRIG_TMR1CH1, ADC_ORDINARY_TRIG_EDGE_NONE);
125
126 /* config dma mode,it's not useful when common dma mode is use */
127 adc_dma_mode_enable(ADC1, FALSE);
128
129 /* config dma request repeat,it's not useful when common dma mode is use */
130 adc_dma_request_repeat_enable(ADC1, FALSE);
131
132 /* config preempt channel */
133 adc_preempt_channel_length_set(ADC1, 3);
134 adc_preempt_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_47_5);
135 adc_preempt_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_47_5);
136 adc_preempt_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_47_5);
137
138 /* config preempt trigger source and trigger edge */
139 adc_preempt_conversion_trigger_set(ADC1, ADC_PREEMPT_TRIG_TMR1CH4, ADC_PREEMPT_TRIG_EDGE_NONE);
140
141 /* disable preempt group automatic conversion after ordinary group */
142 adc_preempt_auto_mode_enable(ADC1, FALSE);
143
144 /* enable adc preempt channels conversion end interrupt */
145 adc_interrupt_enable(ADC1, ADC_PCCE_INT, TRUE);
146
147 adc_base_config(ADC2, &adc_base_struct);
148 adc_resolution_set(ADC2, ADC_RESOLUTION_12B);
149 adc_ordinary_conversion_trigger_set(ADC2, ADC_ORDINARY_TRIG_TMR1TRGOUT2, ADC_ORDINARY_TRIG_EDGE_NONE);
150 adc_dma_mode_enable(ADC2, FALSE);
151 adc_dma_request_repeat_enable(ADC2, FALSE);
152 adc_preempt_channel_length_set(ADC2, 3);
153 adc_preempt_channel_set(ADC2, ADC_CHANNEL_7, 1, ADC_SAMPLETIME_47_5);
154 adc_preempt_channel_set(ADC2, ADC_CHANNEL_8, 2, ADC_SAMPLETIME_47_5);
155 adc_preempt_channel_set(ADC2, ADC_CHANNEL_9, 3, ADC_SAMPLETIME_47_5);
156 adc_preempt_conversion_trigger_set(ADC2, ADC_PREEMPT_TRIG_TMR1CH4, ADC_PREEMPT_TRIG_EDGE_NONE);
157 adc_preempt_auto_mode_enable(ADC2, FALSE);
158 adc_interrupt_enable(ADC2, ADC_PCCE_INT, TRUE);
159
160 adc_base_config(ADC3, &adc_base_struct);
161 adc_resolution_set(ADC3, ADC_RESOLUTION_12B);
162 adc_ordinary_conversion_trigger_set(ADC3, ADC_ORDINARY_TRIG_TMR1TRGOUT2, ADC_ORDINARY_TRIG_EDGE_NONE);
163 adc_dma_mode_enable(ADC3, FALSE);
164 adc_dma_request_repeat_enable(ADC3, FALSE);
165 adc_preempt_channel_length_set(ADC3, 3);
166 adc_preempt_channel_set(ADC3, ADC_CHANNEL_10, 1, ADC_SAMPLETIME_47_5);
167 adc_preempt_channel_set(ADC3, ADC_CHANNEL_12, 2, ADC_SAMPLETIME_47_5);
168 adc_preempt_channel_set(ADC3, ADC_CHANNEL_13, 3, ADC_SAMPLETIME_47_5);
169 adc_preempt_conversion_trigger_set(ADC3, ADC_PREEMPT_TRIG_TMR1CH4, ADC_PREEMPT_TRIG_EDGE_NONE);
170 adc_preempt_auto_mode_enable(ADC3, FALSE);
171 adc_interrupt_enable(ADC3, ADC_PCCE_INT, TRUE);
172
173 /* adc enable */
174 adc_enable(ADC1, TRUE);
175 adc_enable(ADC2, TRUE);
176 adc_enable(ADC3, TRUE);
177 while(adc_flag_get(ADC1, ADC_RDY_FLAG) == RESET);
178 while(adc_flag_get(ADC2, ADC_RDY_FLAG) == RESET);
179 while(adc_flag_get(ADC3, ADC_RDY_FLAG) == RESET);
180
181 /* adc calibration */
182 adc_calibration_init(ADC1);
183 while(adc_calibration_init_status_get(ADC1));
184 adc_calibration_start(ADC1);
185 while(adc_calibration_status_get(ADC1));
186 adc_calibration_init(ADC2);
187 while(adc_calibration_init_status_get(ADC2));
188 adc_calibration_start(ADC2);
189 while(adc_calibration_status_get(ADC2));
190 adc_calibration_init(ADC3);
191 while(adc_calibration_init_status_get(ADC3));
192 adc_calibration_start(ADC3);
193 while(adc_calibration_status_get(ADC3));
194}
195
201int main(void)
202{
203 __IO uint32_t index = 0;
204 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
205
206 /* config the system clock */
207 system_clock_config();
208
209 /* init at start board */
210 at32_board_init();
211 at32_led_off(LED2);
212 at32_led_off(LED3);
213 at32_led_off(LED4);
214 uart_print_init(115200);
215 gpio_config();
216 adc_config();
217 printf("combine_mode_preempt_interltrig_twoslave \r\n");
218
219 /* adc1 software trigger start conversion */
220 for(index = 0; index < 6; index++)
221 {
222 adc_preempt_software_trigger_enable(ADC1, TRUE);
223 delay_sec(1);
224 }
225 if((adc1_preempt_conversion_count != 2) || (adc2_preempt_conversion_count != 2) || (adc3_preempt_conversion_count != 2))
226 {
227 /* printf flag when error occur */
228 at32_led_on(LED3);
229 at32_led_on(LED4);
230 printf("error occur\r\n");
231 printf("adc1_preempt_conversion_count = %d\r\n",adc1_preempt_conversion_count);
232 printf("adc2_preempt_conversion_count = %d\r\n",adc2_preempt_conversion_count);
233 printf("adc3_preempt_conversion_count = %d\r\n",adc3_preempt_conversion_count);
234 }
235 else
236 {
237 /* printf data when conversion end without error */
238 printf("conversion end without error\r\n");
239 for(index = 0; index < 2; index++)
240 {
241 printf("adc1_preempt_valuetab[%d][0] = 0x%x\r\n", index, adc1_preempt_valuetab[index][0]);
242 printf("adc1_preempt_valuetab[%d][1] = 0x%x\r\n", index, adc1_preempt_valuetab[index][1]);
243 printf("adc1_preempt_valuetab[%d][2] = 0x%x\r\n", index, adc1_preempt_valuetab[index][2]);
244 printf("adc2_preempt_valuetab[%d][0] = 0x%x\r\n", index, adc2_preempt_valuetab[index][0]);
245 printf("adc2_preempt_valuetab[%d][1] = 0x%x\r\n", index, adc2_preempt_valuetab[index][1]);
246 printf("adc2_preempt_valuetab[%d][2] = 0x%x\r\n", index, adc2_preempt_valuetab[index][2]);
247 printf("adc3_preempt_valuetab[%d][0] = 0x%x\r\n", index, adc3_preempt_valuetab[index][0]);
248 printf("adc3_preempt_valuetab[%d][1] = 0x%x\r\n", index, adc3_preempt_valuetab[index][1]);
249 printf("adc3_preempt_valuetab[%d][2] = 0x%x\r\n", index, adc3_preempt_valuetab[index][2]);
250 printf("\r\n");
251 }
252 }
253 at32_led_on(LED2);
254 while(1)
255 {
256 }
257}
258
at32f435_437_board.h
adc1_preempt_conversion_count
__IO uint16_t adc1_preempt_conversion_count
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c:41
adc3_preempt_conversion_count
__IO uint16_t adc3_preempt_conversion_count
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c:43
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c:81
adc3_preempt_valuetab
__IO uint16_t adc3_preempt_valuetab[2][3]
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c:40
adc2_preempt_valuetab
__IO uint16_t adc2_preempt_valuetab[2][3]
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c:201
adc2_preempt_conversion_count
__IO uint16_t adc2_preempt_conversion_count
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c:42
adc1_preempt_valuetab
__IO uint16_t adc1_preempt_valuetab[2][3]
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c:38
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c:53
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc ...
Definition: at32f435_437_adc.c:742
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f435_437_adc.c:110
adc_preempt_auto_mode_enable
void adc_preempt_auto_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable automatic preempt group conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:886
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f435_437_adc.c:64
adc_preempt_conversion_trigger_set
void adc_preempt_conversion_trigger_set(adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, adc_preempt_trig_edge_type adc_preempt_trig_edge)
enable or disable the preempt channel's external trigger and set external trigger event of the specif...
Definition: at32f435_437_adc.c:781
adc_common_config
void adc_common_config(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:203
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f435_437_adc.c:294
adc_resolution_set
void adc_resolution_set(adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral.
Definition: at32f435_437_adc.c:235
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f435_437_adc.c:84
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f435_437_adc.c:359
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f435_437_adc.c:371
adc_dma_request_repeat_enable
void adc_dma_request_repeat_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat.
Definition: at32f435_437_adc.c:274
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f435_437_adc.c:328
adc_preempt_channel_set
void adc_preempt_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc ...
Definition: at32f435_437_adc.c:633
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f435_437_adc.c:340
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f435_437_adc.c:260
adc_preempt_channel_length_set
void adc_preempt_channel_length_set(adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral.
Definition: at32f435_437_adc.c:601
adc_common_default_para_init
void adc_common_default_para_init(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:155
adc_preempt_software_trigger_enable
void adc_preempt_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable preempt software start conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:978
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f435_437_adc.h:178
ADC_CHANNEL_9
@ ADC_CHANNEL_9
Definition: at32f435_437_adc.h:196
ADC_CHANNEL_8
@ ADC_CHANNEL_8
Definition: at32f435_437_adc.h:195
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f435_437_adc.h:191
ADC_CHANNEL_12
@ ADC_CHANNEL_12
Definition: at32f435_437_adc.h:199
ADC_CHANNEL_10
@ ADC_CHANNEL_10
Definition: at32f435_437_adc.h:197
ADC_CHANNEL_13
@ ADC_CHANNEL_13
Definition: at32f435_437_adc.h:200
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f435_437_adc.h:193
ADC_CHANNEL_7
@ ADC_CHANNEL_7
Definition: at32f435_437_adc.h:194
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f435_437_adc.h:192
ADC_SAMPLETIME_47_5
@ ADC_SAMPLETIME_47_5
Definition: at32f435_437_adc.h:217
ADC_SAMPLING_INTERVAL_5CYCLES
@ ADC_SAMPLING_INTERVAL_5CYCLES
Definition: at32f435_437_adc.h:144
ADC_COMMON_DMAMODE_DISABLE
@ ADC_COMMON_DMAMODE_DISABLE
Definition: at32f435_437_adc.h:131
ADC_PREEMPT_TRIG_TMR1CH4
@ ADC_PREEMPT_TRIG_TMR1CH4
Definition: at32f435_437_adc.h:276
ADC_PREEMPT_INTERLTRIG_ONLY_TWOSLAVE_MODE
@ ADC_PREEMPT_INTERLTRIG_ONLY_TWOSLAVE_MODE
Definition: at32f435_437_adc.h:123
ADC_ORDINARY_TRIG_TMR1CH1
@ ADC_ORDINARY_TRIG_TMR1CH1
Definition: at32f435_437_adc.h:228
ADC_ORDINARY_TRIG_TMR1TRGOUT2
@ ADC_ORDINARY_TRIG_TMR1TRGOUT2
Definition: at32f435_437_adc.h:250
ADC_PREEMPT_TRIG_EDGE_NONE
@ ADC_PREEMPT_TRIG_EDGE_NONE
Definition: at32f435_437_adc.h:313
ADC_ORDINARY_TRIG_EDGE_NONE
@ ADC_ORDINARY_TRIG_EDGE_NONE
Definition: at32f435_437_adc.h:265
ADC_RESOLUTION_12B
@ ADC_RESOLUTION_12B
Definition: at32f435_437_adc.h:167
ADC_HCLK_DIV_4
@ ADC_HCLK_DIV_4
Definition: at32f435_437_adc.h:90
ADC_RDY_FLAG
#define ADC_RDY_FLAG
Definition: at32f435_437_adc.h:73
ADC_PCCE_INT
#define ADC_PCCE_INT
Definition: at32f435_437_adc.h:55
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
ADC2
#define ADC2
Definition: at32f435_437_adc.h:867
ADC3
#define ADC3
Definition: at32f435_437_adc.h:868
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_ADC3_PERIPH_CLOCK
@ CRM_ADC3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:160
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:158
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_ADC2_PERIPH_CLOCK
@ CRM_ADC2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:159
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f435_437_gpio.h:85
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
ADC1_2_3_IRQn
@ ADC1_2_3_IRQn
Definition: at32f435_437.h:166
adc_base_config_type
adc base config type
Definition: at32f435_437_adc.h:402
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f435_437_adc.h:405
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f435_437_adc.h:404
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f435_437_adc.h:403
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f435_437_adc.h:406
adc_common_config_type
adc common config type
Definition: at32f435_437_adc.h:388
adc_common_config_type::sampling_interval
adc_sampling_interval_type sampling_interval
Definition: at32f435_437_adc.h:393
adc_common_config_type::tempervintrv_state
confirm_state tempervintrv_state
Definition: at32f435_437_adc.h:394
adc_common_config_type::div
adc_div_type div
Definition: at32f435_437_adc.h:390
adc_common_config_type::common_dma_mode
adc_common_dma_mode_type common_dma_mode
Definition: at32f435_437_adc.h:391
adc_common_config_type::common_dma_request_repeat_state
confirm_state common_dma_request_repeat_state
Definition: at32f435_437_adc.h:392
adc_common_config_type::combine_mode
adc_combine_mode_type combine_mode
Definition: at32f435_437_adc.h:389
adc_common_config_type::vbat_state
confirm_state vbat_state
Definition: at32f435_437_adc.h:395
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • adc
  • conversion_abort
  • inc
project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • adc
  • conversion_abort
  • inc
project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • adc
  • conversion_abort
  • inc
project/at_start_f435/examples/adc/conversion_abort/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • adc
  • conversion_abort
  • src
Functions
project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 49 of file project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • adc
  • conversion_abort
  • src
project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_clock.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • adc
  • conversion_abort
  • src
Functions | Variables
project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...

Variables

__IO uint16_t | dma_trans_complete_flag
__IO uint32_t | adc1_overflow_flag

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • adc
  • conversion_abort
  • src
project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
38extern __IO uint16_t dma_trans_complete_flag;
39extern __IO uint32_t adc1_overflow_flag;
40
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
143void DMA1_Channel1_IRQHandler(void)
144{
145 if(dma_flag_get(DMA1_FDT1_FLAG) != RESET)
146 {
147 dma_flag_clear(DMA1_FDT1_FLAG);
148 dma_trans_complete_flag = 1;
149 }
150}
151
157void ADC1_2_3_IRQHandler(void)
158{
159 if(adc_flag_get(ADC1, ADC_OCCO_FLAG) != RESET)
160 {
161 adc_flag_clear(ADC1, ADC_OCCO_FLAG);
162 adc1_overflow_flag++;
163 }
164}
165
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f435/examples/adc/conversion_abort/src/main.c:39
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c:107
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:40
ADC1_2_3_IRQHandler
void ADC1_2_3_IRQHandler(void)
this function handles adc1_2_3 handler.
Definition: project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c:157
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c:46
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1_channel1 handler.
Definition: project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c:143
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c:81
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c:134
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/adc/conversion_abort/src/at32f435_437_int.c:116
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1106
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
ADC_OCCO_FLAG
#define ADC_OCCO_FLAG
Definition: at32f435_437_adc.h:72
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f435_437_dma.h:66
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • adc
  • conversion_abort
  • src
Functions | Variables
project/at_start_f435/examples/adc/conversion_abort/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [10][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/conversion_abort/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • adc
  • conversion_abort
  • src
project/at_start_f435/examples/adc/conversion_abort/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38__IO uint16_t adc1_ordinary_valuetab[10][3] = {0};
39__IO uint16_t dma_trans_complete_flag = 0;
40__IO uint32_t adc1_overflow_flag = 0;
41
42static void gpio_config(void);
43static void dma_config(void);
44static void adc_config(void);
45
51static void gpio_config(void)
52{
53 gpio_init_type gpio_initstructure;
54 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
55
56 gpio_default_para_init(&gpio_initstructure);
57
58 /* config adc pin as analog input mode */
59 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
60 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6;
61 gpio_init(GPIOA, &gpio_initstructure);
62}
63
69static void dma_config(void)
70{
71 dma_init_type dma_init_struct;
72 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
73 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
74
75 dma_reset(DMA1_CHANNEL1);
76 dma_default_para_init(&dma_init_struct);
77 dma_init_struct.buffer_size = 30;
78 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
79 dma_init_struct.memory_base_addr = (uint32_t)adc1_ordinary_valuetab;
80 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
81 dma_init_struct.memory_inc_enable = TRUE;
82 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
83 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
84 dma_init_struct.peripheral_inc_enable = FALSE;
85 dma_init_struct.priority = DMA_PRIORITY_HIGH;
86 dma_init_struct.loop_mode_enable = FALSE;
87 dma_init(DMA1_CHANNEL1, &dma_init_struct);
88
89 dmamux_enable(DMA1, TRUE);
90 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_ADC1);
91
92 /* enable dma transfer complete interrupt */
93 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
94 dma_channel_enable(DMA1_CHANNEL1, TRUE);
95}
96
102static void adc_config(void)
103{
104 adc_common_config_type adc_common_struct;
105 adc_base_config_type adc_base_struct;
106 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
107 nvic_irq_enable(ADC1_2_3_IRQn, 0, 0);
108
109 adc_common_default_para_init(&adc_common_struct);
110
111 /* config combine mode */
112 adc_common_struct.combine_mode = ADC_INDEPENDENT_MODE;
113
114 /* config division,adcclk is division by hclk */
115 adc_common_struct.div = ADC_HCLK_DIV_4;
116
117 /* config common dma mode,it's not useful in independent mode */
118 adc_common_struct.common_dma_mode = ADC_COMMON_DMAMODE_DISABLE;
119
120 /* config common dma request repeat */
121 adc_common_struct.common_dma_request_repeat_state = FALSE;
122
123 /* config adjacent adc sampling interval,it's useful for ordinary shifting mode */
124 adc_common_struct.sampling_interval = ADC_SAMPLING_INTERVAL_5CYCLES;
125
126 /* config inner temperature sensor and vintrv */
127 adc_common_struct.tempervintrv_state = FALSE;
128
129 /* config voltage battery */
130 adc_common_struct.vbat_state = FALSE;
131 adc_common_config(&adc_common_struct);
132
133 adc_base_default_para_init(&adc_base_struct);
134
135 adc_base_struct.sequence_mode = TRUE;
136 adc_base_struct.repeat_mode = FALSE;
137 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
138 adc_base_struct.ordinary_channel_length = 3;
139 adc_base_config(ADC1, &adc_base_struct);
140 adc_resolution_set(ADC1, ADC_RESOLUTION_12B);
141
142 /* config ordinary channel */
143 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_92_5);
144 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_92_5);
145 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_92_5);
146
147 /* config ordinary trigger source and trigger edge */
148 adc_ordinary_conversion_trigger_set(ADC1, ADC_ORDINARY_TRIG_TMR1CH1, ADC_ORDINARY_TRIG_EDGE_NONE);
149
150 /* config dma mode,it's not useful when common dma mode is use */
151 adc_dma_mode_enable(ADC1, TRUE);
152
153 /* config dma request repeat,it's not useful when common dma mode is use */
154 adc_dma_request_repeat_enable(ADC1, FALSE);
155
156 /* enable adc overflow interrupt */
157 adc_interrupt_enable(ADC1, ADC_OCCO_INT, TRUE);
158
159 /* adc enable */
160 adc_enable(ADC1, TRUE);
161 while(adc_flag_get(ADC1, ADC_RDY_FLAG) == RESET);
162
163 /* adc calibration */
164 adc_calibration_init(ADC1);
165 while(adc_calibration_init_status_get(ADC1));
166 adc_calibration_start(ADC1);
167 while(adc_calibration_status_get(ADC1));
168}
169
175int main(void)
176{
177 __IO uint32_t index = 0;
178 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
179
180 /* config the system clock */
181 system_clock_config();
182
183 /* init at start board */
184 at32_board_init();
185 at32_led_off(LED2);
186 at32_led_off(LED3);
187 at32_led_off(LED4);
188 uart_print_init(115200);
189 gpio_config();
190 dma_config();
191 adc_config();
192 printf("software_trigger_repeat \r\n");
193 for(index = 0; index < 20; index++)
194 {
195 adc_ordinary_software_trigger_enable(ADC1, TRUE);
196 if(index%2 == 0)
197 {
198 adc_conversion_stop(ADC1);
199 while(adc_conversion_stop_status_get(ADC1));
200 }
201 delay_ms(500);
202 }
203 if((dma_trans_complete_flag == 0) || (adc1_overflow_flag != 0))
204 {
205 /* printf flag when error occur */
206 at32_led_on(LED3);
207 at32_led_on(LED4);
208 printf("error occur\r\n");
209 printf("adc1_overflow_flag = %d\r\n",adc1_overflow_flag);
210 printf("dma_trans_complete_flag = %d\r\n",dma_trans_complete_flag);
211 }
212 else
213 {
214 /* printf data when conversion end without error */
215 printf("conversion end without error\r\n");
216 for(index = 0; index < 10; index++)
217 {
218 printf("adc1_ordinary_valuetab[%d][0] = 0x%x\r\n",index, adc1_ordinary_valuetab[index][0]);
219 printf("adc1_ordinary_valuetab[%d][1] = 0x%x\r\n",index, adc1_ordinary_valuetab[index][1]);
220 printf("adc1_ordinary_valuetab[%d][2] = 0x%x\r\n",index, adc1_ordinary_valuetab[index][2]);
221 printf("\r\n");
222 }
223 }
224 at32_led_on(LED2);
225 while(1)
226 {
227 }
228}
229
at32f435_437_board.h
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f435/examples/adc/conversion_abort/src/main.c:39
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f435/examples/adc/conversion_abort/src/main.c:69
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/conversion_abort/src/main.c:40
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f435/examples/adc/conversion_abort/src/main.c:102
main
int main(void)
main function.
Definition: project/at_start_f435/examples/adc/conversion_abort/src/main.c:175
adc1_ordinary_valuetab
__IO uint16_t adc1_ordinary_valuetab[10][3]
Definition: project/at_start_f435/examples/adc/conversion_abort/src/main.c:38
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/adc/conversion_abort/src/main.c:51
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:945
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc ...
Definition: at32f435_437_adc.c:742
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f435_437_adc.c:110
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f435_437_adc.c:64
adc_common_config
void adc_common_config(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:203
adc_conversion_stop_status_get
flag_status adc_conversion_stop_status_get(adc_type *adc_x)
get stop conversion's status of the specified adc peripheral.
Definition: at32f435_437_adc.c:910
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f435_437_adc.c:294
adc_resolution_set
void adc_resolution_set(adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral.
Definition: at32f435_437_adc.c:235
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f435_437_adc.c:84
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f435_437_adc.c:359
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f435_437_adc.c:371
adc_dma_request_repeat_enable
void adc_dma_request_repeat_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat.
Definition: at32f435_437_adc.c:274
adc_conversion_stop
void adc_conversion_stop(adc_type *adc_x)
stop the ongoing conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:898
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f435_437_adc.c:328
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f435_437_adc.c:340
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f435_437_adc.c:260
adc_common_default_para_init
void adc_common_default_para_init(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:155
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f435_437_adc.c:472
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f435_437_adc.h:178
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f435_437_adc.h:191
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f435_437_adc.h:193
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f435_437_adc.h:192
ADC_SAMPLETIME_92_5
@ ADC_SAMPLETIME_92_5
Definition: at32f435_437_adc.h:218
ADC_SAMPLING_INTERVAL_5CYCLES
@ ADC_SAMPLING_INTERVAL_5CYCLES
Definition: at32f435_437_adc.h:144
ADC_COMMON_DMAMODE_DISABLE
@ ADC_COMMON_DMAMODE_DISABLE
Definition: at32f435_437_adc.h:131
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f435_437_adc.h:111
ADC_ORDINARY_TRIG_TMR1CH1
@ ADC_ORDINARY_TRIG_TMR1CH1
Definition: at32f435_437_adc.h:228
ADC_ORDINARY_TRIG_EDGE_NONE
@ ADC_ORDINARY_TRIG_EDGE_NONE
Definition: at32f435_437_adc.h:265
ADC_RESOLUTION_12B
@ ADC_RESOLUTION_12B
Definition: at32f435_437_adc.h:167
ADC_HCLK_DIV_4
@ ADC_HCLK_DIV_4
Definition: at32f435_437_adc.h:90
ADC_RDY_FLAG
#define ADC_RDY_FLAG
Definition: at32f435_437_adc.h:73
ADC_OCCO_INT
#define ADC_OCCO_INT
Definition: at32f435_437_adc.h:56
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:158
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_ADC1
@ DMAMUX_DMAREQ_ID_ADC1
Definition: at32f435_437_dma.h:197
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f435_437_gpio.h:85
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f435_437.h:204
ADC1_2_3_IRQn
@ ADC1_2_3_IRQn
Definition: at32f435_437.h:166
adc_base_config_type
adc base config type
Definition: at32f435_437_adc.h:402
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f435_437_adc.h:405
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f435_437_adc.h:404
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f435_437_adc.h:403
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f435_437_adc.h:406
adc_common_config_type
adc common config type
Definition: at32f435_437_adc.h:388
adc_common_config_type::sampling_interval
adc_sampling_interval_type sampling_interval
Definition: at32f435_437_adc.h:393
adc_common_config_type::tempervintrv_state
confirm_state tempervintrv_state
Definition: at32f435_437_adc.h:394
adc_common_config_type::div
adc_div_type div
Definition: at32f435_437_adc.h:390
adc_common_config_type::common_dma_mode
adc_common_dma_mode_type common_dma_mode
Definition: at32f435_437_adc.h:391
adc_common_config_type::common_dma_request_repeat_state
confirm_state common_dma_request_repeat_state
Definition: at32f435_437_adc.h:392
adc_common_config_type::combine_mode
adc_combine_mode_type combine_mode
Definition: at32f435_437_adc.h:389
adc_common_config_type::vbat_state
confirm_state vbat_state
Definition: at32f435_437_adc.h:395
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • adc
  • current_vref_value_check
  • inc
project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • adc
  • current_vref_value_check
  • inc
project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • adc
  • current_vref_value_check
  • inc
project/at_start_f435/examples/adc/current_vref_value_check/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • adc
  • current_vref_value_check
  • src
Functions
project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 49 of file project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • adc
  • current_vref_value_check
  • src
project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_clock.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • adc
  • current_vref_value_check
  • src
Functions | Variables
project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...

Variables

__IO uint32_t adc1_overflow_flag

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • adc
  • current_vref_value_check
  • src
project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
39extern __IO uint32_t adc1_overflow_flag;
40
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
143void ADC1_2_3_IRQHandler(void)
144{
145 if(adc_flag_get(ADC1, ADC_OCCO_FLAG) != RESET)
146 {
147 adc_flag_clear(ADC1, ADC_OCCO_FLAG);
148 adc1_overflow_flag++;
149 }
150}
151
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c:107
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:40
ADC1_2_3_IRQHandler
void ADC1_2_3_IRQHandler(void)
this function handles adc1_2_3 handler.
Definition: project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c:143
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c:46
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c:81
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c:134
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/adc/current_vref_value_check/src/at32f435_437_int.c:116
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1106
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
ADC_OCCO_FLAG
#define ADC_OCCO_FLAG
Definition: at32f435_437_adc.h:72
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • adc
  • current_vref_value_check
  • src
Functions | Variables
project/at_start_f435/examples/adc/current_vref_value_check/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_value = 0
__IO uint32_t | adc1_overflow_flag = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/current_vref_value_check/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • adc
  • current_vref_value_check
  • src
project/at_start_f435/examples/adc/current_vref_value_check/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38__IO uint16_t adc1_ordinary_value = 0;
39__IO uint32_t adc1_overflow_flag = 0;
40
41static void dma_config(void);
42static void adc_config(void);
43
49static void dma_config(void)
50{
51 dma_init_type dma_init_struct;
52 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
53 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
54
55 dma_reset(DMA1_CHANNEL1);
56 dma_default_para_init(&dma_init_struct);
57 dma_init_struct.buffer_size = 1;
58 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
59 dma_init_struct.memory_base_addr = (uint32_t)&adc1_ordinary_value;
60 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
61 dma_init_struct.memory_inc_enable = FALSE;
62 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
63 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
64 dma_init_struct.peripheral_inc_enable = FALSE;
65 dma_init_struct.priority = DMA_PRIORITY_HIGH;
66 dma_init_struct.loop_mode_enable = TRUE;
67 dma_init(DMA1_CHANNEL1, &dma_init_struct);
68
69 dmamux_enable(DMA1, TRUE);
70 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_ADC1);
71
72 /* disable dma transfer complete interrupt */
73 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, FALSE);
74 dma_channel_enable(DMA1_CHANNEL1, TRUE);
75}
76
82static void adc_config(void)
83{
84 adc_common_config_type adc_common_struct;
85 adc_base_config_type adc_base_struct;
86 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
87 nvic_irq_enable(ADC1_2_3_IRQn, 0, 0);
88
89 adc_common_default_para_init(&adc_common_struct);
90
91 /* config combine mode */
92 adc_common_struct.combine_mode = ADC_INDEPENDENT_MODE;
93
94 /* config division,adcclk is division by hclk */
95 adc_common_struct.div = ADC_HCLK_DIV_4;
96
97 /* config common dma mode,it's not useful in independent mode */
98 adc_common_struct.common_dma_mode = ADC_COMMON_DMAMODE_DISABLE;
99
100 /* config common dma request repeat */
101 adc_common_struct.common_dma_request_repeat_state = FALSE;
102
103 /* config adjacent adc sampling interval,it's useful for ordinary shifting mode */
104 adc_common_struct.sampling_interval = ADC_SAMPLING_INTERVAL_5CYCLES;
105
106 /* config inner temperature sensor and vintrv */
107 adc_common_struct.tempervintrv_state = TRUE;
108
109 /* config voltage battery */
110 adc_common_struct.vbat_state = FALSE;
111 adc_common_config(&adc_common_struct);
112
113 adc_base_default_para_init(&adc_base_struct);
114
115 adc_base_struct.sequence_mode = FALSE;
116 adc_base_struct.repeat_mode = FALSE;
117 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
118 adc_base_struct.ordinary_channel_length = 1;
119 adc_base_config(ADC1, &adc_base_struct);
120 adc_resolution_set(ADC1, ADC_RESOLUTION_12B);
121
122 /* config ordinary channel */
123 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_17, 1, ADC_SAMPLETIME_92_5);
124
125 /* config ordinary trigger source and trigger edge */
126 adc_ordinary_conversion_trigger_set(ADC1, ADC_ORDINARY_TRIG_TMR1CH1, ADC_ORDINARY_TRIG_EDGE_NONE);
127
128 /* config dma mode,it's not useful when common dma mode is use */
129 adc_dma_mode_enable(ADC1, TRUE);
130
131 /* config dma request repeat,it's not useful when common dma mode is use */
132 adc_dma_request_repeat_enable(ADC1, TRUE);
133
134 /* enable adc overflow interrupt */
135 adc_interrupt_enable(ADC1, ADC_OCCO_INT, TRUE);
136
137 /* adc enable */
138 adc_enable(ADC1, TRUE);
139 while(adc_flag_get(ADC1, ADC_RDY_FLAG) == RESET);
140
141 /* adc calibration */
142 adc_calibration_init(ADC1);
143 while(adc_calibration_init_status_get(ADC1));
144 adc_calibration_start(ADC1);
145 while(adc_calibration_status_get(ADC1));
146}
147
153int main(void)
154{
155 __IO uint32_t index = 0;
156 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
157
158 /* config the system clock */
159 system_clock_config();
160
161 /* init at start board */
162 at32_board_init();
163 at32_led_off(LED2);
164 at32_led_off(LED3);
165 at32_led_off(LED4);
166 uart_print_init(115200);
167 dma_config();
168 adc_config();
169 printf("adc1_vref_check \r\n");
170
171 while(1)
172 {
173 at32_led_toggle(LED2);
174 delay_sec(1);
175 /* adc1 software trigger start conversion */
176 adc_ordinary_software_trigger_enable(ADC1, TRUE);
177 while(dma_flag_get(DMA1_FDT1_FLAG) == RESET);
178 dma_flag_clear(DMA1_FDT1_FLAG);
179 printf("vref_value = %f V\r\n", ((double)1.2 * 4095) / adc1_ordinary_value);
180 if(adc1_overflow_flag != 0)
181 {
182 /* printf flag when error occur */
183 at32_led_on(LED3);
184 at32_led_on(LED4);
185 printf("error occur\r\n");
186 printf("adc1_overflow_flag = %d\r\n",adc1_overflow_flag);
187 }
188 }
189}
190
at32f435_437_board.h
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f435/examples/adc/current_vref_value_check/src/main.c:49
adc1_ordinary_value
__IO uint16_t adc1_ordinary_value
Definition: project/at_start_f435/examples/adc/current_vref_value_check/src/main.c:38
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/current_vref_value_check/src/main.c:39
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f435/examples/adc/current_vref_value_check/src/main.c:82
main
int main(void)
main function.
Definition: project/at_start_f435/examples/adc/current_vref_value_check/src/main.c:153
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:945
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc ...
Definition: at32f435_437_adc.c:742
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f435_437_adc.c:110
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f435_437_adc.c:64
adc_common_config
void adc_common_config(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:203
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f435_437_adc.c:294
adc_resolution_set
void adc_resolution_set(adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral.
Definition: at32f435_437_adc.c:235
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f435_437_adc.c:84
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f435_437_adc.c:359
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f435_437_adc.c:371
adc_dma_request_repeat_enable
void adc_dma_request_repeat_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat.
Definition: at32f435_437_adc.c:274
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f435_437_adc.c:328
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f435_437_adc.c:340
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f435_437_adc.c:260
adc_common_default_para_init
void adc_common_default_para_init(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:155
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f435_437_adc.c:472
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f435_437_adc.h:178
ADC_CHANNEL_17
@ ADC_CHANNEL_17
Definition: at32f435_437_adc.h:204
ADC_SAMPLETIME_92_5
@ ADC_SAMPLETIME_92_5
Definition: at32f435_437_adc.h:218
ADC_SAMPLING_INTERVAL_5CYCLES
@ ADC_SAMPLING_INTERVAL_5CYCLES
Definition: at32f435_437_adc.h:144
ADC_COMMON_DMAMODE_DISABLE
@ ADC_COMMON_DMAMODE_DISABLE
Definition: at32f435_437_adc.h:131
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f435_437_adc.h:111
ADC_ORDINARY_TRIG_TMR1CH1
@ ADC_ORDINARY_TRIG_TMR1CH1
Definition: at32f435_437_adc.h:228
ADC_ORDINARY_TRIG_EDGE_NONE
@ ADC_ORDINARY_TRIG_EDGE_NONE
Definition: at32f435_437_adc.h:265
ADC_RESOLUTION_12B
@ ADC_RESOLUTION_12B
Definition: at32f435_437_adc.h:167
ADC_HCLK_DIV_4
@ ADC_HCLK_DIV_4
Definition: at32f435_437_adc.h:90
ADC_RDY_FLAG
#define ADC_RDY_FLAG
Definition: at32f435_437_adc.h:73
ADC_OCCO_INT
#define ADC_OCCO_INT
Definition: at32f435_437_adc.h:56
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:158
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_ADC1
@ DMAMUX_DMAREQ_ID_ADC1
Definition: at32f435_437_dma.h:197
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f435_437_dma.h:66
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f435_437.h:204
ADC1_2_3_IRQn
@ ADC1_2_3_IRQn
Definition: at32f435_437.h:166
adc_base_config_type
adc base config type
Definition: at32f435_437_adc.h:402
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f435_437_adc.h:405
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f435_437_adc.h:404
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f435_437_adc.h:403
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f435_437_adc.h:406
adc_common_config_type
adc common config type
Definition: at32f435_437_adc.h:388
adc_common_config_type::sampling_interval
adc_sampling_interval_type sampling_interval
Definition: at32f435_437_adc.h:393
adc_common_config_type::tempervintrv_state
confirm_state tempervintrv_state
Definition: at32f435_437_adc.h:394
adc_common_config_type::div
adc_div_type div
Definition: at32f435_437_adc.h:390
adc_common_config_type::common_dma_mode
adc_common_dma_mode_type common_dma_mode
Definition: at32f435_437_adc.h:391
adc_common_config_type::common_dma_request_repeat_state
confirm_state common_dma_request_repeat_state
Definition: at32f435_437_adc.h:392
adc_common_config_type::combine_mode
adc_combine_mode_type combine_mode
Definition: at32f435_437_adc.h:389
adc_common_config_type::vbat_state
confirm_state vbat_state
Definition: at32f435_437_adc.h:395
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • adc
  • edma_double_buffer
  • inc
project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • adc
  • edma_double_buffer
  • inc
project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • adc
  • edma_double_buffer
  • inc
project/at_start_f435/examples/adc/edma_double_buffer/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • adc
  • edma_double_buffer
  • src
Functions
project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 49 of file project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • adc
  • edma_double_buffer
  • src
project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_clock.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • adc
  • edma_double_buffer
  • src
Functions | Variables
project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | EDMA_Stream1_IRQHandler (void)
this function handles edma_stream1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...

Variables

__IO uint16_t | edma_trans_complete_flag
__IO uint16_t | double_buffer_is_useful
__IO uint32_t | adc1_overflow_flag

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • adc
  • edma_double_buffer
  • src
project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
39extern __IO uint16_t edma_trans_complete_flag;
40extern __IO uint16_t double_buffer_is_useful;
41extern __IO uint32_t adc1_overflow_flag;
42
48void NMI_Handler(void)
49{
50}
51
57void HardFault_Handler(void)
58{
59 /* go to infinite loop when hard fault exception occurs */
60 while(1)
61 {
62 }
63}
64
70void MemManage_Handler(void)
71{
72 /* go to infinite loop when memory manage exception occurs */
73 while(1)
74 {
75 }
76}
77
83void BusFault_Handler(void)
84{
85 /* go to infinite loop when bus fault exception occurs */
86 while(1)
87 {
88 }
89}
90
96void UsageFault_Handler(void)
97{
98 /* go to infinite loop when usage fault exception occurs */
99 while(1)
100 {
101 }
102}
103
109void SVC_Handler(void)
110{
111}
112
118void DebugMon_Handler(void)
119{
120}
121
127void PendSV_Handler(void)
128{
129}
130
136void SysTick_Handler(void)
137{
138}
139
145void EDMA_Stream1_IRQHandler(void)
146{
147 if(edma_flag_get(EDMA_FDT1_FLAG) != RESET)
148 {
149 if(edma_memory_target_get(EDMA_STREAM1))
150 {
151 double_buffer_is_useful = 0;
152 }
153 else
154 {
155 double_buffer_is_useful = 1;
156 }
157 edma_flag_clear(EDMA_FDT1_FLAG);
158 edma_trans_complete_flag = 1;
159 }
160}
161
167void ADC1_2_3_IRQHandler(void)
168{
169 if(adc_flag_get(ADC1, ADC_OCCO_FLAG) != RESET)
170 {
171 adc_flag_clear(ADC1, ADC_OCCO_FLAG);
172 adc1_overflow_flag++;
173 }
174}
175
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c:96
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c:57
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c:70
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c:109
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:40
double_buffer_is_useful
__IO uint16_t double_buffer_is_useful
Definition: project/at_start_f435/examples/adc/edma_double_buffer/src/main.c:41
ADC1_2_3_IRQHandler
void ADC1_2_3_IRQHandler(void)
this function handles adc1_2_3 handler.
Definition: project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c:167
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c:127
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c:48
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c:83
edma_trans_complete_flag
__IO uint16_t edma_trans_complete_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_smlt_oneslave_edma/src/main.c:39
EDMA_Stream1_IRQHandler
void EDMA_Stream1_IRQHandler(void)
this function handles edma_stream1 handler.
Definition: project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c:145
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c:136
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/adc/edma_double_buffer/src/at32f435_437_int.c:118
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1106
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
ADC_OCCO_FLAG
#define ADC_OCCO_FLAG
Definition: at32f435_437_adc.h:72
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
edma_flag_get
flag_status edma_flag_get(uint32_t edma_flag)
get the edma flag.
Definition: at32f435_437_edma.c:512
edma_flag_clear
void edma_flag_clear(uint32_t edma_flag)
clear the edma flag.
Definition: at32f435_437_edma.c:549
edma_memory_target_get
edma_memory_type edma_memory_target_get(edma_stream_type *edma_streamx)
get the current memory target.
Definition: at32f435_437_edma.c:442
EDMA_FDT1_FLAG
#define EDMA_FDT1_FLAG
Definition: at32f435_437_edma.h:71
EDMA_STREAM1
#define EDMA_STREAM1
Definition: at32f435_437_edma.h:962
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • adc
  • edma_double_buffer
  • src
Functions | Variables
project/at_start_f435/examples/adc/edma_double_buffer/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | edma_config (void)
edma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [3] = {0}
__IO uint16_t | double_adc1_ordinary_valuetab [3] = {0}
__IO uint16_t | edma_trans_complete_flag = 0
__IO uint16_t | double_buffer_is_useful = 0
__IO uint32_t | adc1_overflow_flag = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/edma_double_buffer/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • adc
  • edma_double_buffer
  • src
project/at_start_f435/examples/adc/edma_double_buffer/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38__IO uint16_t adc1_ordinary_valuetab[3] = {0};
39__IO uint16_t double_adc1_ordinary_valuetab[3] = {0};
40__IO uint16_t edma_trans_complete_flag = 0;
41__IO uint16_t double_buffer_is_useful = 0;
42__IO uint32_t adc1_overflow_flag = 0;
43
44static void gpio_config(void);
45static void edma_config(void);
46static void adc_config(void);
47
53static void gpio_config(void)
54{
55 gpio_init_type gpio_initstructure;
56 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
57
58 gpio_default_para_init(&gpio_initstructure);
59
60 /* config adc pin as analog input mode */
61 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
62 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6;
63 gpio_init(GPIOA, &gpio_initstructure);
64}
65
71static void edma_config(void)
72{
73 edma_init_type edma_init_struct;
74 crm_periph_clock_enable(CRM_EDMA_PERIPH_CLOCK, TRUE);
75 nvic_irq_enable(EDMA_Stream1_IRQn, 0, 0);
76
77 edma_reset(EDMA_STREAM1);
78 edma_default_para_init(&edma_init_struct);
79 edma_init_struct.buffer_size = 3;
80 edma_init_struct.direction = EDMA_DIR_PERIPHERAL_TO_MEMORY;
81 edma_init_struct.memory0_base_addr = (uint32_t)adc1_ordinary_valuetab;
82 edma_init_struct.memory_burst_mode = EDMA_MEMORY_SINGLE;
83 edma_init_struct.memory_data_width = EDMA_MEMORY_DATA_WIDTH_HALFWORD;
84 edma_init_struct.memory_inc_enable = TRUE;
85 edma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
86 edma_init_struct.peripheral_burst_mode = EDMA_PERIPHERAL_SINGLE;
87 edma_init_struct.peripheral_data_width = EDMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
88 edma_init_struct.peripheral_inc_enable = FALSE;
89 edma_init_struct.priority = EDMA_PRIORITY_VERY_HIGH;
90 edma_init_struct.loop_mode_enable = FALSE;
91 edma_init_struct.fifo_threshold = EDMA_FIFO_THRESHOLD_1QUARTER;
92 edma_init_struct.fifo_mode_enable = FALSE;
93 edma_init(EDMA_STREAM1, &edma_init_struct);
94
95 /* edmamux init and enable */
96 edmamux_enable(TRUE);
97 edmamux_init(EDMAMUX_CHANNEL1, EDMAMUX_DMAREQ_ID_ADC1);
98
99 /* config double buffer mode */
100 edma_double_buffer_mode_init(EDMA_STREAM1, (uint32_t)double_adc1_ordinary_valuetab, EDMA_MEMORY_0);
101
102 /* enable the double memory mode */
103 edma_double_buffer_mode_enable(EDMA_STREAM1, TRUE);
104
105 /* enable edma full data transfer intterrupt */
106 edma_interrupt_enable(EDMA_STREAM1, EDMA_FDT_INT, TRUE);
107 edma_stream_enable(EDMA_STREAM1, TRUE);
108}
109
115static void adc_config(void)
116{
117 adc_common_config_type adc_common_struct;
118 adc_base_config_type adc_base_struct;
119 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
120 nvic_irq_enable(ADC1_2_3_IRQn, 0, 0);
121
122 adc_common_default_para_init(&adc_common_struct);
123
124 /* config combine mode */
125 adc_common_struct.combine_mode = ADC_INDEPENDENT_MODE;
126
127 /* config division,adcclk is division by hclk */
128 adc_common_struct.div = ADC_HCLK_DIV_17;
129
130 /* config common dma mode,it's not useful in independent mode */
131 adc_common_struct.common_dma_mode = ADC_COMMON_DMAMODE_DISABLE;
132
133 /* config common dma request repeat */
134 adc_common_struct.common_dma_request_repeat_state = FALSE;
135
136 /* config adjacent adc sampling interval,it's useful for ordinary shifting mode */
137 adc_common_struct.sampling_interval = ADC_SAMPLING_INTERVAL_5CYCLES;
138
139 /* config inner temperature sensor and vintrv */
140 adc_common_struct.tempervintrv_state = FALSE;
141
142 /* config voltage battery */
143 adc_common_struct.vbat_state = FALSE;
144 adc_common_config(&adc_common_struct);
145
146 adc_base_default_para_init(&adc_base_struct);
147
148 adc_base_struct.sequence_mode = TRUE;
149 adc_base_struct.repeat_mode = FALSE;
150 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
151 adc_base_struct.ordinary_channel_length = 3;
152 adc_base_config(ADC1, &adc_base_struct);
153
154 adc_resolution_set(ADC1, ADC_RESOLUTION_12B);
155
156 /* config ordinary channel */
157 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_640_5);
158 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_640_5);
159 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_640_5);
160
161 /* config ordinary trigger source and trigger edge */
162 adc_ordinary_conversion_trigger_set(ADC1, ADC_ORDINARY_TRIG_TMR1CH1, ADC_ORDINARY_TRIG_EDGE_NONE);
163
164 /* config dma mode,it's not useful when common dma mode is use */
165 adc_dma_mode_enable(ADC1, TRUE);
166
167 /* config dma request repeat,it's not useful when common dma mode is use */
168 adc_dma_request_repeat_enable(ADC1, TRUE);
169
170 /* enable adc overflow interrupt */
171 adc_interrupt_enable(ADC1, ADC_OCCO_INT, TRUE);
172
173 /* adc enable */
174 adc_enable(ADC1, TRUE);
175 while(adc_flag_get(ADC1, ADC_RDY_FLAG) == RESET);
176
177 /* adc calibration */
178 adc_calibration_init(ADC1);
179 while(adc_calibration_init_status_get(ADC1));
180 adc_calibration_start(ADC1);
181 while(adc_calibration_status_get(ADC1));
182}
183
189int main(void)
190{
191 __IO uint32_t index = 0;
192 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
193
194 /* config the system clock */
195 system_clock_config();
196
197 /* init at start board */
198 at32_board_init();
199 at32_led_off(LED2);
200 at32_led_off(LED3);
201 at32_led_off(LED4);
202 uart_print_init(115200);
203 gpio_config();
204 edma_config();
205 adc_config();
206 printf("edma_double_buffer \r\n");
207 while(1)
208 {
209 adc_ordinary_software_trigger_enable(ADC1, TRUE);
210 while(edma_trans_complete_flag == 0);
211 edma_trans_complete_flag = 0;
212 if(adc1_overflow_flag != 0)
213 {
214 /* printf flag when error occur */
215 at32_led_on(LED4);
216 printf("error occur\r\n");
217 printf("adc1_overflow_flag = %d\r\n",adc1_overflow_flag);
218 }
219 else
220 {
221 printf("conversion end without error\r\n");
222 /* printf data when conversion end without error */
223 if(double_buffer_is_useful == 1)
224 {
225 printf("double_adc1_ordinary_valuetab[0] = 0x%x\r\n", double_adc1_ordinary_valuetab[0]);
226 printf("double_adc1_ordinary_valuetab[1] = 0x%x\r\n", double_adc1_ordinary_valuetab[1]);
227 printf("double_adc1_ordinary_valuetab[2] = 0x%x\r\n", double_adc1_ordinary_valuetab[2]);
228 }
229 else
230 {
231 printf("adc1_ordinary_valuetab[0] = 0x%x\r\n", adc1_ordinary_valuetab[0]);
232 printf("adc1_ordinary_valuetab[1] = 0x%x\r\n", adc1_ordinary_valuetab[1]);
233 printf("adc1_ordinary_valuetab[2] = 0x%x\r\n", adc1_ordinary_valuetab[2]);
234 }
235 }
236 printf("\r\n");
237 delay_sec(1);
238 }
239}
240
at32f435_437_board.h
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/edma_double_buffer/src/main.c:42
double_buffer_is_useful
__IO uint16_t double_buffer_is_useful
Definition: project/at_start_f435/examples/adc/edma_double_buffer/src/main.c:41
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f435/examples/adc/edma_double_buffer/src/main.c:115
main
int main(void)
main function.
Definition: project/at_start_f435/examples/adc/edma_double_buffer/src/main.c:189
adc1_ordinary_valuetab
__IO uint16_t adc1_ordinary_valuetab[3]
Definition: project/at_start_f435/examples/adc/edma_double_buffer/src/main.c:38
edma_trans_complete_flag
__IO uint16_t edma_trans_complete_flag
Definition: project/at_start_f435/examples/adc/edma_double_buffer/src/main.c:40
double_adc1_ordinary_valuetab
__IO uint16_t double_adc1_ordinary_valuetab[3]
Definition: project/at_start_f435/examples/adc/edma_double_buffer/src/main.c:39
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/adc/edma_double_buffer/src/main.c:53
edma_config
static void edma_config(void)
edma configuration.
Definition: project/at_start_f435/examples/adc/edma_double_buffer/src/main.c:71
edma_init_struct
edma_init_type edma_init_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:40
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:945
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc ...
Definition: at32f435_437_adc.c:742
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f435_437_adc.c:110
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f435_437_adc.c:64
adc_common_config
void adc_common_config(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:203
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f435_437_adc.c:294
adc_resolution_set
void adc_resolution_set(adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral.
Definition: at32f435_437_adc.c:235
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f435_437_adc.c:84
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f435_437_adc.c:359
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f435_437_adc.c:371
adc_dma_request_repeat_enable
void adc_dma_request_repeat_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat.
Definition: at32f435_437_adc.c:274
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f435_437_adc.c:328
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f435_437_adc.c:340
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f435_437_adc.c:260
adc_common_default_para_init
void adc_common_default_para_init(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:155
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f435_437_adc.c:472
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f435_437_adc.h:178
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f435_437_adc.h:191
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f435_437_adc.h:193
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f435_437_adc.h:192
ADC_SAMPLETIME_640_5
@ ADC_SAMPLETIME_640_5
Definition: at32f435_437_adc.h:220
ADC_SAMPLING_INTERVAL_5CYCLES
@ ADC_SAMPLING_INTERVAL_5CYCLES
Definition: at32f435_437_adc.h:144
ADC_COMMON_DMAMODE_DISABLE
@ ADC_COMMON_DMAMODE_DISABLE
Definition: at32f435_437_adc.h:131
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f435_437_adc.h:111
ADC_ORDINARY_TRIG_TMR1CH1
@ ADC_ORDINARY_TRIG_TMR1CH1
Definition: at32f435_437_adc.h:228
ADC_ORDINARY_TRIG_EDGE_NONE
@ ADC_ORDINARY_TRIG_EDGE_NONE
Definition: at32f435_437_adc.h:265
ADC_RESOLUTION_12B
@ ADC_RESOLUTION_12B
Definition: at32f435_437_adc.h:167
ADC_HCLK_DIV_17
@ ADC_HCLK_DIV_17
Definition: at32f435_437_adc.h:103
ADC_RDY_FLAG
#define ADC_RDY_FLAG
Definition: at32f435_437_adc.h:73
ADC_OCCO_INT
#define ADC_OCCO_INT
Definition: at32f435_437_adc.h:56
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_EDMA_PERIPH_CLOCK
@ CRM_EDMA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:114
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:158
edma_double_buffer_mode_init
void edma_double_buffer_mode_init(edma_stream_type *edma_streamx, uint32_t memory1_addr, edma_memory_type current_memory)
config the the double buffer mode.
Definition: at32f435_437_edma.c:354
edmamux_init
void edmamux_init(edmamux_channel_type *edmamux_channelx, edmamux_requst_id_sel_type edmamux_req_id)
edmamux init.
Definition: at32f435_437_edma.c:718
edma_init
void edma_init(edma_stream_type *edma_streamx, edma_init_type *edma_init_struct)
edma init.
Definition: at32f435_437_edma.c:115
edma_double_buffer_mode_enable
void edma_double_buffer_mode_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the double memory mode.
Definition: at32f435_437_edma.c:383
edma_stream_enable
void edma_stream_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx.
Definition: at32f435_437_edma.c:198
edma_reset
void edma_reset(edma_stream_type *edma_streamx)
reset edma_streamx channely register.
Definition: at32f435_437_edma.c:58
edmamux_enable
void edmamux_enable(confirm_state new_state)
enable or disable the edma edmamux.
Definition: at32f435_437_edma.c:673
edma_interrupt_enable
void edma_interrupt_enable(edma_stream_type *edma_streamx, uint32_t edma_int, confirm_state new_state)
enable or disable the edma streamx interrupts.
Definition: at32f435_437_edma.c:225
edma_default_para_init
void edma_default_para_init(edma_init_type *edma_init_struct)
edma init struct config with its default value.
Definition: at32f435_437_edma.c:165
EDMA_PRIORITY_VERY_HIGH
@ EDMA_PRIORITY_VERY_HIGH
Definition: at32f435_437_edma.h:192
EDMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ EDMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_edma.h:170
EDMA_MEMORY_DATA_WIDTH_HALFWORD
@ EDMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_edma.h:180
EDMA_MEMORY_SINGLE
@ EDMA_MEMORY_SINGLE
Definition: at32f435_437_edma.h:224
EDMA_PERIPHERAL_SINGLE
@ EDMA_PERIPHERAL_SINGLE
Definition: at32f435_437_edma.h:235
EDMA_FIFO_THRESHOLD_1QUARTER
@ EDMA_FIFO_THRESHOLD_1QUARTER
Definition: at32f435_437_edma.h:200
EDMA_MEMORY_0
@ EDMA_MEMORY_0
Definition: at32f435_437_edma.h:150
EDMA_DIR_PERIPHERAL_TO_MEMORY
@ EDMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_edma.h:159
EDMAMUX_DMAREQ_ID_ADC1
@ EDMAMUX_DMAREQ_ID_ADC1
Definition: at32f435_437_edma.h:259
EDMA_FDT_INT
#define EDMA_FDT_INT
Definition: at32f435_437_edma.h:55
EDMA_STREAM1
#define EDMA_STREAM1
Definition: at32f435_437_edma.h:962
EDMAMUX_CHANNEL1
#define EDMAMUX_CHANNEL1
Definition: at32f435_437_edma.h:989
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f435_437_gpio.h:85
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
EDMA_Stream1_IRQn
@ EDMA_Stream1_IRQn
Definition: at32f435_437.h:157
ADC1_2_3_IRQn
@ ADC1_2_3_IRQn
Definition: at32f435_437.h:166
adc_base_config_type
adc base config type
Definition: at32f435_437_adc.h:402
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f435_437_adc.h:405
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f435_437_adc.h:404
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f435_437_adc.h:403
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f435_437_adc.h:406
adc_common_config_type
adc common config type
Definition: at32f435_437_adc.h:388
adc_common_config_type::sampling_interval
adc_sampling_interval_type sampling_interval
Definition: at32f435_437_adc.h:393
adc_common_config_type::tempervintrv_state
confirm_state tempervintrv_state
Definition: at32f435_437_adc.h:394
adc_common_config_type::div
adc_div_type div
Definition: at32f435_437_adc.h:390
adc_common_config_type::common_dma_mode
adc_common_dma_mode_type common_dma_mode
Definition: at32f435_437_adc.h:391
adc_common_config_type::common_dma_request_repeat_state
confirm_state common_dma_request_repeat_state
Definition: at32f435_437_adc.h:392
adc_common_config_type::combine_mode
adc_combine_mode_type combine_mode
Definition: at32f435_437_adc.h:389
adc_common_config_type::vbat_state
confirm_state vbat_state
Definition: at32f435_437_adc.h:395
edma_init_type
edma init type
Definition: at32f435_437_edma.h:440
edma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_edma.h:441
edma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_edma.h:444
edma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_edma.h:446
edma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_edma.h:445
edma_init_type::direction
edma_dir_type direction
Definition: at32f435_437_edma.h:443
edma_init_type::fifo_mode_enable
confirm_state fifo_mode_enable
Definition: at32f435_437_edma.h:451
edma_init_type::peripheral_data_width
edma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_edma.h:447
edma_init_type::fifo_threshold
edma_fifo_threshold_type fifo_threshold
Definition: at32f435_437_edma.h:452
edma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_edma.h:449
edma_init_type::priority
edma_priority_level_type priority
Definition: at32f435_437_edma.h:450
edma_init_type::memory0_base_addr
uint32_t memory0_base_addr
Definition: at32f435_437_edma.h:442
edma_init_type::peripheral_burst_mode
edma_peripheral_burst_type peripheral_burst_mode
Definition: at32f435_437_edma.h:454
edma_init_type::memory_data_width
edma_memory_data_size_type memory_data_width
Definition: at32f435_437_edma.h:448
edma_init_type::memory_burst_mode
edma_memory_burst_type memory_burst_mode
Definition: at32f435_437_edma.h:453
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • adc
  • exint_trigger_partitioned
  • inc
project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • adc
  • exint_trigger_partitioned
  • inc
project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • adc
  • exint_trigger_partitioned
  • inc
project/at_start_f435/examples/adc/exint_trigger_partitioned/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • adc
  • exint_trigger_partitioned
  • src
Functions
project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 49 of file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • adc
  • exint_trigger_partitioned
  • src
project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_clock.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • adc
  • exint_trigger_partitioned
  • src
Functions | Variables
project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...

Variables

__IO uint16_t | adc1_preempt_valuetab [3][3]
__IO uint16_t | dma_trans_complete_flag
__IO uint16_t | preempt_trigger_count
__IO uint32_t | adc1_overflow_flag

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • adc
  • exint_trigger_partitioned
  • src
project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
39extern __IO uint16_t adc1_preempt_valuetab[3][3];
40extern __IO uint16_t dma_trans_complete_flag;
41extern __IO uint16_t preempt_trigger_count;
42extern __IO uint32_t adc1_overflow_flag;
43
49void NMI_Handler(void)
50{
51}
52
58void HardFault_Handler(void)
59{
60 /* go to infinite loop when hard fault exception occurs */
61 while(1)
62 {
63 }
64}
65
71void MemManage_Handler(void)
72{
73 /* go to infinite loop when memory manage exception occurs */
74 while(1)
75 {
76 }
77}
78
84void BusFault_Handler(void)
85{
86 /* go to infinite loop when bus fault exception occurs */
87 while(1)
88 {
89 }
90}
91
97void UsageFault_Handler(void)
98{
99 /* go to infinite loop when usage fault exception occurs */
100 while(1)
101 {
102 }
103}
104
110void SVC_Handler(void)
111{
112}
113
119void DebugMon_Handler(void)
120{
121}
122
128void PendSV_Handler(void)
129{
130}
131
137void SysTick_Handler(void)
138{
139}
140
146void DMA1_Channel1_IRQHandler(void)
147{
148 if(dma_flag_get(DMA1_FDT1_FLAG) != RESET)
149 {
150 dma_flag_clear(DMA1_FDT1_FLAG);
151 dma_trans_complete_flag = 1;
152 }
153}
154
160void ADC1_2_3_IRQHandler(void)
161{
162 if(adc_flag_get(ADC1, ADC_OCCO_FLAG) != RESET)
163 {
164 adc_flag_clear(ADC1, ADC_OCCO_FLAG);
165 adc1_overflow_flag++;
166 }
167 if(adc_flag_get(ADC1, ADC_PCCE_FLAG) != RESET)
168 {
169 adc_flag_clear(ADC1, ADC_PCCE_FLAG);
170 if(preempt_trigger_count < 3)
171 {
172 adc1_preempt_valuetab[preempt_trigger_count][0] = adc_preempt_conversion_data_get(ADC1, ADC_PREEMPT_CHANNEL_1);
173 adc1_preempt_valuetab[preempt_trigger_count][1] = adc_preempt_conversion_data_get(ADC1, ADC_PREEMPT_CHANNEL_2);
174 adc1_preempt_valuetab[preempt_trigger_count][2] = adc_preempt_conversion_data_get(ADC1, ADC_PREEMPT_CHANNEL_3);
175 preempt_trigger_count++;
176 }
177 }
178}
179
adc1_preempt_valuetab
__IO uint16_t adc1_preempt_valuetab[3][3]
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c:38
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f435/examples/adc/conversion_abort/src/main.c:39
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c:97
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c:58
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c:71
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c:110
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:40
ADC1_2_3_IRQHandler
void ADC1_2_3_IRQHandler(void)
this function handles adc1_2_3 handler.
Definition: project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c:160
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c:128
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c:49
preempt_trigger_count
__IO uint16_t preempt_trigger_count
Definition: project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c:41
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1_channel1 handler.
Definition: project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c:146
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c:84
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c:137
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/adc/exint_trigger_partitioned/src/at32f435_437_int.c:119
adc_preempt_conversion_data_get
uint16_t adc_preempt_conversion_data_get(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral.
Definition: at32f435_437_adc.c:1036
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1106
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
ADC_PREEMPT_CHANNEL_3
@ ADC_PREEMPT_CHANNEL_3
Definition: at32f435_437_adc.h:326
ADC_PREEMPT_CHANNEL_2
@ ADC_PREEMPT_CHANNEL_2
Definition: at32f435_437_adc.h:325
ADC_PREEMPT_CHANNEL_1
@ ADC_PREEMPT_CHANNEL_1
Definition: at32f435_437_adc.h:324
ADC_PCCE_FLAG
#define ADC_PCCE_FLAG
Definition: at32f435_437_adc.h:69
ADC_OCCO_FLAG
#define ADC_OCCO_FLAG
Definition: at32f435_437_adc.h:72
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f435_437_dma.h:66
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • adc
  • exint_trigger_partitioned
  • src
Functions | Variables
project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | exint_config (void)
exint configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [3][3] = {0}
__IO uint16_t | adc1_preempt_valuetab [3][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint16_t | preempt_trigger_count = 0
__IO uint32_t | adc1_overflow_flag = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • adc
  • exint_trigger_partitioned
  • src
project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38__IO uint16_t adc1_ordinary_valuetab[3][3] = {0};
39__IO uint16_t adc1_preempt_valuetab[3][3] = {0};
40__IO uint16_t dma_trans_complete_flag = 0;
41__IO uint16_t preempt_trigger_count = 0;
42__IO uint32_t adc1_overflow_flag = 0;
43
44static void gpio_config(void);
45static void exint_config(void);
46static void dma_config(void);
47static void adc_config(void);
48
54static void gpio_config(void)
55{
56 gpio_init_type gpio_initstructure;
57 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
58 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
59
60 gpio_default_para_init(&gpio_initstructure);
61
62 /* config adc pin as analog input mode */
63 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
64 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6 | GPIO_PINS_7;
65 gpio_init(GPIOA, &gpio_initstructure);
66
67 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
68 gpio_initstructure.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
69 gpio_init(GPIOB, &gpio_initstructure);
70}
71
77static void exint_config(void)
78{
79 gpio_init_type gpio_initstructure;
80 exint_init_type exint_init_struct;
81
82 crm_periph_clock_enable(CRM_SCFG_PERIPH_CLOCK, TRUE);
83 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
84 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
85
86 gpio_default_para_init(&gpio_initstructure);
87
88 /* config exint line 11 and line 15 */
89 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
90 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
91 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
92 gpio_initstructure.gpio_pins = GPIO_PINS_11;
93 gpio_init(GPIOC, &gpio_initstructure);
94 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
95 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
96 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
97 gpio_initstructure.gpio_pins = GPIO_PINS_15;
98 gpio_init(GPIOA, &gpio_initstructure);
99
100 scfg_exint_line_config(SCFG_PORT_SOURCE_GPIOC, SCFG_PINS_SOURCE11);
101 scfg_exint_line_config(SCFG_PORT_SOURCE_GPIOA, SCFG_PINS_SOURCE15);
102
103 exint_default_para_init(&exint_init_struct);
104 exint_init_struct.line_enable = TRUE;
105 exint_init_struct.line_mode = EXINT_LINE_EVENT;
106 exint_init_struct.line_select = EXINT_LINE_11;
107 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
108 exint_init(&exint_init_struct);
109
110 exint_init_struct.line_select = EXINT_LINE_15;
111 exint_init(&exint_init_struct);
112}
113
119static void dma_config(void)
120{
121 dma_init_type dma_init_struct;
122 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
123 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
124
125 dma_reset(DMA1_CHANNEL1);
126 dma_default_para_init(&dma_init_struct);
127 dma_init_struct.buffer_size = 9;
128 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
129 dma_init_struct.memory_base_addr = (uint32_t)adc1_ordinary_valuetab;
130 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
131 dma_init_struct.memory_inc_enable = TRUE;
132 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
133 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
134 dma_init_struct.peripheral_inc_enable = FALSE;
135 dma_init_struct.priority = DMA_PRIORITY_HIGH;
136 dma_init_struct.loop_mode_enable = FALSE;
137 dma_init(DMA1_CHANNEL1, &dma_init_struct);
138
139 dmamux_enable(DMA1, TRUE);
140 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_ADC1);
141
142 /* enable dma transfer complete interrupt */
143 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
144 dma_channel_enable(DMA1_CHANNEL1, TRUE);
145}
146
152static void adc_config(void)
153{
154 adc_common_config_type adc_common_struct;
155 adc_base_config_type adc_base_struct;
156 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
157 nvic_irq_enable(ADC1_2_3_IRQn, 0, 0);
158
159 adc_common_default_para_init(&adc_common_struct);
160
161 /* config combine mode */
162 adc_common_struct.combine_mode = ADC_INDEPENDENT_MODE;
163
164 /* config division,adcclk is division by hclk */
165 adc_common_struct.div = ADC_HCLK_DIV_4;
166
167 /* config common dma mode,it's not useful in independent mode */
168 adc_common_struct.common_dma_mode = ADC_COMMON_DMAMODE_DISABLE;
169
170 /* config common dma request repeat */
171 adc_common_struct.common_dma_request_repeat_state = FALSE;
172
173 /* config adjacent adc sampling interval,it's useful for ordinary shifting mode */
174 adc_common_struct.sampling_interval = ADC_SAMPLING_INTERVAL_5CYCLES;
175
176 /* config inner temperature sensor and vintrv */
177 adc_common_struct.tempervintrv_state = FALSE;
178
179 /* config voltage battery */
180 adc_common_struct.vbat_state = FALSE;
181 adc_common_config(&adc_common_struct);
182
183 adc_base_default_para_init(&adc_base_struct);
184
185 adc_base_struct.sequence_mode = TRUE;
186 adc_base_struct.repeat_mode = FALSE;
187 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
188 adc_base_struct.ordinary_channel_length = 3;
189 adc_base_config(ADC1, &adc_base_struct);
190 adc_resolution_set(ADC1, ADC_RESOLUTION_12B);
191
192 /* config ordinary channel */
193 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_47_5);
194 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_47_5);
195 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_47_5);
196
197 /* config ordinary trigger source and trigger edge */
198 adc_ordinary_conversion_trigger_set(ADC1, ADC_ORDINARY_TRIG_EXINT11, ADC_ORDINARY_TRIG_EDGE_RISING);
199
200 /* config dma mode,it's not useful when common dma mode is use */
201 adc_dma_mode_enable(ADC1, TRUE);
202
203 /* config dma request repeat,it's not useful when common dma mode is use */
204 adc_dma_request_repeat_enable(ADC1, FALSE);
205
206 /* set partitioned mode channel count */
207 adc_ordinary_part_count_set(ADC1, 1);
208
209 /* enable the partitioned mode on ordinary channel */
210 adc_ordinary_part_mode_enable(ADC1, TRUE);
211
212 /* config preempt channel */
213 adc_preempt_channel_length_set(ADC1, 3);
214 adc_preempt_channel_set(ADC1, ADC_CHANNEL_7, 1, ADC_SAMPLETIME_47_5);
215 adc_preempt_channel_set(ADC1, ADC_CHANNEL_8, 2, ADC_SAMPLETIME_47_5);
216 adc_preempt_channel_set(ADC1, ADC_CHANNEL_9, 3, ADC_SAMPLETIME_47_5);
217
218 /* config preempt trigger source and trigger edge */
219 adc_preempt_conversion_trigger_set(ADC1, ADC_PREEMPT_TRIG_EXINT15, ADC_PREEMPT_TRIG_EDGE_RISING);
220
221 /* enable adc overflow interrupt */
222 adc_interrupt_enable(ADC1, ADC_OCCO_INT, TRUE);
223
224 /* enable adc preempt channels conversion end interrupt */
225 adc_interrupt_enable(ADC1, ADC_PCCE_INT, TRUE);
226
227 /* adc enable */
228 adc_enable(ADC1, TRUE);
229 while(adc_flag_get(ADC1, ADC_RDY_FLAG) == RESET);
230
231 /* adc calibration */
232 adc_calibration_init(ADC1);
233 while(adc_calibration_init_status_get(ADC1));
234 adc_calibration_start(ADC1);
235 while(adc_calibration_status_get(ADC1));
236}
237
243int main(void)
244{
245 __IO uint32_t index = 0;
246 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
247
248 /* config the system clock */
249 system_clock_config();
250
251 /* init at start board */
252 at32_board_init();
253 at32_led_off(LED2);
254 at32_led_off(LED3);
255 at32_led_off(LED4);
256 uart_print_init(115200);
257 gpio_config();
258 exint_config();
259 dma_config();
260 adc_config();
261 printf("exint_trigger_partitioned \r\n");
262
263 while(dma_trans_complete_flag == 0);
264 while(preempt_trigger_count != 3);
265 if(adc1_overflow_flag != 0)
266 {
267 /* printf flag when error occur */
268 at32_led_on(LED3);
269 at32_led_on(LED4);
270 printf("error occur\r\n");
271 printf("adc1_overflow_flag = %d\r\n",adc1_overflow_flag);
272 }
273 else
274 {
275 /* printf data when conversion end without error */
276 printf("conversion end without error\r\n");
277 for(index = 0; index < 3; index++)
278 {
279 printf("adc1_ordinary_valuetab[%d][0] = 0x%x\r\n",index, adc1_ordinary_valuetab[index][0]);
280 printf("adc1_ordinary_valuetab[%d][1] = 0x%x\r\n",index, adc1_ordinary_valuetab[index][1]);
281 printf("adc1_ordinary_valuetab[%d][2] = 0x%x\r\n",index, adc1_ordinary_valuetab[index][2]);
282 printf("adc1_preempt_valuetab[%d][0] = 0x%x\r\n",index, adc1_preempt_valuetab[index][0]);
283 printf("adc1_preempt_valuetab[%d][1] = 0x%x\r\n",index, adc1_preempt_valuetab[index][1]);
284 printf("adc1_preempt_valuetab[%d][2] = 0x%x\r\n",index, adc1_preempt_valuetab[index][2]);
285 printf("\r\n");
286 }
287 }
288 at32_led_on(LED2);
289 while(1)
290 {
291 }
292}
293
at32f435_437_board.h
adc1_preempt_valuetab
__IO uint16_t adc1_preempt_valuetab[3][3]
Definition: project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c:39
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c:40
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c:119
exint_config
static void exint_config(void)
exint configuration.
Definition: project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c:77
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c:42
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c:152
adc1_ordinary_valuetab
__IO uint16_t adc1_ordinary_valuetab[3][3]
Definition: project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c:38
preempt_trigger_count
__IO uint16_t preempt_trigger_count
Definition: project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c:41
main
int main(void)
main function.
Definition: project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c:243
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/adc/exint_trigger_partitioned/src/main.c:54
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:41
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc ...
Definition: at32f435_437_adc.c:742
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f435_437_adc.c:110
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f435_437_adc.c:64
adc_ordinary_part_count_set
void adc_ordinary_part_count_set(adc_type *adc_x, uint8_t adc_channel_count)
set partitioned mode channel count of the specified adc peripheral.
Definition: at32f435_437_adc.c:843
adc_preempt_conversion_trigger_set
void adc_preempt_conversion_trigger_set(adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, adc_preempt_trig_edge_type adc_preempt_trig_edge)
enable or disable the preempt channel's external trigger and set external trigger event of the specif...
Definition: at32f435_437_adc.c:781
adc_common_config
void adc_common_config(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:203
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f435_437_adc.c:294
adc_resolution_set
void adc_resolution_set(adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral.
Definition: at32f435_437_adc.c:235
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f435_437_adc.c:84
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f435_437_adc.c:359
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f435_437_adc.c:371
adc_dma_request_repeat_enable
void adc_dma_request_repeat_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat.
Definition: at32f435_437_adc.c:274
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f435_437_adc.c:328
adc_preempt_channel_set
void adc_preempt_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc ...
Definition: at32f435_437_adc.c:633
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f435_437_adc.c:340
adc_ordinary_part_mode_enable
void adc_ordinary_part_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on ordinary channel of the specified adc peripheral.
Definition: at32f435_437_adc.c:858
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f435_437_adc.c:260
adc_preempt_channel_length_set
void adc_preempt_channel_length_set(adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral.
Definition: at32f435_437_adc.c:601
adc_common_default_para_init
void adc_common_default_para_init(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:155
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f435_437_adc.c:472
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f435_437_adc.h:178
ADC_CHANNEL_9
@ ADC_CHANNEL_9
Definition: at32f435_437_adc.h:196
ADC_CHANNEL_8
@ ADC_CHANNEL_8
Definition: at32f435_437_adc.h:195
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f435_437_adc.h:191
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f435_437_adc.h:193
ADC_CHANNEL_7
@ ADC_CHANNEL_7
Definition: at32f435_437_adc.h:194
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f435_437_adc.h:192
ADC_SAMPLETIME_47_5
@ ADC_SAMPLETIME_47_5
Definition: at32f435_437_adc.h:217
ADC_SAMPLING_INTERVAL_5CYCLES
@ ADC_SAMPLING_INTERVAL_5CYCLES
Definition: at32f435_437_adc.h:144
ADC_COMMON_DMAMODE_DISABLE
@ ADC_COMMON_DMAMODE_DISABLE
Definition: at32f435_437_adc.h:131
ADC_PREEMPT_TRIG_EXINT15
@ ADC_PREEMPT_TRIG_EXINT15
Definition: at32f435_437_adc.h:291
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f435_437_adc.h:111
ADC_ORDINARY_TRIG_EXINT11
@ ADC_ORDINARY_TRIG_EXINT11
Definition: at32f435_437_adc.h:243
ADC_PREEMPT_TRIG_EDGE_RISING
@ ADC_PREEMPT_TRIG_EDGE_RISING
Definition: at32f435_437_adc.h:314
ADC_ORDINARY_TRIG_EDGE_RISING
@ ADC_ORDINARY_TRIG_EDGE_RISING
Definition: at32f435_437_adc.h:266
ADC_RESOLUTION_12B
@ ADC_RESOLUTION_12B
Definition: at32f435_437_adc.h:167
ADC_HCLK_DIV_4
@ ADC_HCLK_DIV_4
Definition: at32f435_437_adc.h:90
ADC_RDY_FLAG
#define ADC_RDY_FLAG
Definition: at32f435_437_adc.h:73
ADC_PCCE_INT
#define ADC_PCCE_INT
Definition: at32f435_437_adc.h:55
ADC_OCCO_INT
#define ADC_OCCO_INT
Definition: at32f435_437_adc.h:56
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_SCFG_PERIPH_CLOCK
@ CRM_SCFG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:163
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:158
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_ADC1
@ DMAMUX_DMAREQ_ID_ADC1
Definition: at32f435_437_dma.h:197
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f435_437_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_EVENT
@ EXINT_LINE_EVENT
Definition: at32f435_437_exint.h:90
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
EXINT_LINE_15
#define EXINT_LINE_15
Definition: at32f435_437_exint.h:67
EXINT_LINE_11
#define EXINT_LINE_11
Definition: at32f435_437_exint.h:63
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f435_437_gpio.h:85
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f435_437_gpio.h:82
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
scfg_exint_line_config
void scfg_exint_line_config(scfg_port_source_type port_source, scfg_pins_source_type pin_source)
select the gpio pin used as exint line.
Definition: at32f435_437_scfg.c:152
SCFG_PINS_SOURCE15
@ SCFG_PINS_SOURCE15
Definition: at32f435_437_scfg.h:116
SCFG_PINS_SOURCE11
@ SCFG_PINS_SOURCE11
Definition: at32f435_437_scfg.h:112
SCFG_PORT_SOURCE_GPIOC
@ SCFG_PORT_SOURCE_GPIOC
Definition: at32f435_437_scfg.h:126
SCFG_PORT_SOURCE_GPIOA
@ SCFG_PORT_SOURCE_GPIOA
Definition: at32f435_437_scfg.h:124
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f435_437.h:204
ADC1_2_3_IRQn
@ ADC1_2_3_IRQn
Definition: at32f435_437.h:166
adc_base_config_type
adc base config type
Definition: at32f435_437_adc.h:402
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f435_437_adc.h:405
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f435_437_adc.h:404
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f435_437_adc.h:403
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f435_437_adc.h:406
adc_common_config_type
adc common config type
Definition: at32f435_437_adc.h:388
adc_common_config_type::sampling_interval
adc_sampling_interval_type sampling_interval
Definition: at32f435_437_adc.h:393
adc_common_config_type::tempervintrv_state
confirm_state tempervintrv_state
Definition: at32f435_437_adc.h:394
adc_common_config_type::div
adc_div_type div
Definition: at32f435_437_adc.h:390
adc_common_config_type::common_dma_mode
adc_common_dma_mode_type common_dma_mode
Definition: at32f435_437_adc.h:391
adc_common_config_type::common_dma_request_repeat_state
confirm_state common_dma_request_repeat_state
Definition: at32f435_437_adc.h:392
adc_common_config_type::combine_mode
adc_combine_mode_type combine_mode
Definition: at32f435_437_adc.h:389
adc_common_config_type::vbat_state
confirm_state vbat_state
Definition: at32f435_437_adc.h:395
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • adc
  • internal_temperature_sensor
  • inc
project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • adc
  • internal_temperature_sensor
  • inc
project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • adc
  • internal_temperature_sensor
  • inc
project/at_start_f435/examples/adc/internal_temperature_sensor/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • adc
  • internal_temperature_sensor
  • src
Functions
project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 49 of file project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • adc
  • internal_temperature_sensor
  • src
project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_clock.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • adc
  • internal_temperature_sensor
  • src
Functions | Variables
project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...

Variables

__IO uint32_t adc1_overflow_flag

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • adc
  • internal_temperature_sensor
  • src
project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
39extern __IO uint32_t adc1_overflow_flag;
40
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
143void ADC1_2_3_IRQHandler(void)
144{
145 if(adc_flag_get(ADC1, ADC_OCCO_FLAG) != RESET)
146 {
147 adc_flag_clear(ADC1, ADC_OCCO_FLAG);
148 adc1_overflow_flag++;
149 }
150}
151
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c:107
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:40
ADC1_2_3_IRQHandler
void ADC1_2_3_IRQHandler(void)
this function handles adc1_2_3 handler.
Definition: project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c:143
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c:46
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c:81
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c:134
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/adc/internal_temperature_sensor/src/at32f435_437_int.c:116
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1106
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
ADC_OCCO_FLAG
#define ADC_OCCO_FLAG
Definition: at32f435_437_adc.h:72
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • adc
  • internal_temperature_sensor
  • src
Macros | Functions | Variables
project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define | ADC_VREF (3.3)
#define | ADC_TEMP_BASE (1.26)
#define | ADC_TEMP_SLOPE (-0.00423)

Functions

static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_value = 0
__IO uint32_t | adc1_overflow_flag = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c.

Macro Definition Documentation

◆ ADC_TEMP_BASE

#define ADC_TEMP_BASE (1.26)

Definition at line 31 of file project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c.

◆ ADC_TEMP_SLOPE

#define ADC_TEMP_SLOPE (-0.00423)

Definition at line 32 of file project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c.

◆ ADC_VREF

#define ADC_VREF (3.3)

Definition at line 30 of file project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • adc
  • internal_temperature_sensor
  • src
project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
30#define ADC_VREF (3.3)
31#define ADC_TEMP_BASE (1.26)
32#define ADC_TEMP_SLOPE (-0.00423)
33
42__IO uint16_t adc1_ordinary_value = 0;
43__IO uint32_t adc1_overflow_flag = 0;
44
45static void dma_config(void);
46static void adc_config(void);
47
53static void dma_config(void)
54{
55 dma_init_type dma_init_struct;
56 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
57 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
58
59 dma_reset(DMA1_CHANNEL1);
60 dma_default_para_init(&dma_init_struct);
61 dma_init_struct.buffer_size = 1;
62 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
63 dma_init_struct.memory_base_addr = (uint32_t)&adc1_ordinary_value;
64 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
65 dma_init_struct.memory_inc_enable = FALSE;
66 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
67 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
68 dma_init_struct.peripheral_inc_enable = FALSE;
69 dma_init_struct.priority = DMA_PRIORITY_HIGH;
70 dma_init_struct.loop_mode_enable = TRUE;
71 dma_init(DMA1_CHANNEL1, &dma_init_struct);
72
73 dmamux_enable(DMA1, TRUE);
74 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_ADC1);
75
76 /* disable dma transfer complete interrupt */
77 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, FALSE);
78 dma_channel_enable(DMA1_CHANNEL1, TRUE);
79}
80
86static void adc_config(void)
87{
88 adc_common_config_type adc_common_struct;
89 adc_base_config_type adc_base_struct;
90 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
91 nvic_irq_enable(ADC1_2_3_IRQn, 0, 0);
92
93 adc_common_default_para_init(&adc_common_struct);
94
95 /* config combine mode */
96 adc_common_struct.combine_mode = ADC_INDEPENDENT_MODE;
97
98 /* config division,adcclk is division by hclk */
99 adc_common_struct.div = ADC_HCLK_DIV_4;
100
101 /* config common dma mode,it's not useful in independent mode */
102 adc_common_struct.common_dma_mode = ADC_COMMON_DMAMODE_DISABLE;
103
104 /* config common dma request repeat */
105 adc_common_struct.common_dma_request_repeat_state = FALSE;
106
107 /* config adjacent adc sampling interval,it's useful for ordinary shifting mode */
108 adc_common_struct.sampling_interval = ADC_SAMPLING_INTERVAL_5CYCLES;
109
110 /* config inner temperature sensor and vintrv */
111 adc_common_struct.tempervintrv_state = TRUE;
112
113 /* config voltage battery */
114 adc_common_struct.vbat_state = FALSE;
115 adc_common_config(&adc_common_struct);
116
117 adc_base_default_para_init(&adc_base_struct);
118
119 adc_base_struct.sequence_mode = FALSE;
120 adc_base_struct.repeat_mode = FALSE;
121 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
122 adc_base_struct.ordinary_channel_length = 1;
123 adc_base_config(ADC1, &adc_base_struct);
124 adc_resolution_set(ADC1, ADC_RESOLUTION_12B);
125
126 /* config ordinary channel */
127 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_16, 1, ADC_SAMPLETIME_640_5);
128
129 /* config ordinary trigger source and trigger edge */
130 adc_ordinary_conversion_trigger_set(ADC1, ADC_ORDINARY_TRIG_TMR1CH1, ADC_ORDINARY_TRIG_EDGE_NONE);
131
132 /* config dma mode,it's not useful when common dma mode is use */
133 adc_dma_mode_enable(ADC1, TRUE);
134
135 /* config dma request repeat,it's not useful when common dma mode is use */
136 adc_dma_request_repeat_enable(ADC1, TRUE);
137
138 /* enable adc overflow interrupt */
139 adc_interrupt_enable(ADC1, ADC_OCCO_INT, TRUE);
140
141 /* adc enable */
142 adc_enable(ADC1, TRUE);
143 while(adc_flag_get(ADC1, ADC_RDY_FLAG) == RESET);
144
145 /* adc calibration */
146 adc_calibration_init(ADC1);
147 while(adc_calibration_init_status_get(ADC1));
148 adc_calibration_start(ADC1);
149 while(adc_calibration_status_get(ADC1));
150}
151
157int main(void)
158{
159 __IO uint32_t index = 0;
160 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
161
162 /* config the system clock */
163 system_clock_config();
164
165 /* init at start board */
166 at32_board_init();
167 at32_led_off(LED2);
168 at32_led_off(LED3);
169 at32_led_off(LED4);
170 uart_print_init(115200);
171 dma_config();
172 adc_config();
173 printf("internal_temperature_sensor \r\n");
174
175 while(1)
176 {
177 at32_led_toggle(LED2);
178 delay_sec(1);
179 /* adc1 software trigger start conversion */
180 adc_ordinary_software_trigger_enable(ADC1, TRUE);
181 while(dma_flag_get(DMA1_FDT1_FLAG) == RESET);
182 dma_flag_clear(DMA1_FDT1_FLAG);
183 printf("internal_temperature = %f deg C\r\n",(ADC_TEMP_BASE-(double)adc1_ordinary_value*ADC_VREF/4096)/ADC_TEMP_SLOPE+25);
184 if(adc1_overflow_flag != 0)
185 {
186 /* printf flag when error occur */
187 at32_led_on(LED3);
188 at32_led_on(LED4);
189 printf("error occur\r\n");
190 printf("adc1_overflow_flag = %d\r\n",adc1_overflow_flag);
191 }
192 }
193}
194
at32f435_437_board.h
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c:53
adc1_ordinary_value
__IO uint16_t adc1_ordinary_value
Definition: project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c:42
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c:43
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c:86
main
int main(void)
main function.
Definition: project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c:157
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:945
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc ...
Definition: at32f435_437_adc.c:742
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f435_437_adc.c:110
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f435_437_adc.c:64
adc_common_config
void adc_common_config(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:203
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f435_437_adc.c:294
adc_resolution_set
void adc_resolution_set(adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral.
Definition: at32f435_437_adc.c:235
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f435_437_adc.c:84
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f435_437_adc.c:359
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f435_437_adc.c:371
adc_dma_request_repeat_enable
void adc_dma_request_repeat_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat.
Definition: at32f435_437_adc.c:274
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f435_437_adc.c:328
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f435_437_adc.c:340
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f435_437_adc.c:260
adc_common_default_para_init
void adc_common_default_para_init(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:155
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f435_437_adc.c:472
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f435_437_adc.h:178
ADC_CHANNEL_16
@ ADC_CHANNEL_16
Definition: at32f435_437_adc.h:203
ADC_SAMPLETIME_640_5
@ ADC_SAMPLETIME_640_5
Definition: at32f435_437_adc.h:220
ADC_SAMPLING_INTERVAL_5CYCLES
@ ADC_SAMPLING_INTERVAL_5CYCLES
Definition: at32f435_437_adc.h:144
ADC_COMMON_DMAMODE_DISABLE
@ ADC_COMMON_DMAMODE_DISABLE
Definition: at32f435_437_adc.h:131
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f435_437_adc.h:111
ADC_ORDINARY_TRIG_TMR1CH1
@ ADC_ORDINARY_TRIG_TMR1CH1
Definition: at32f435_437_adc.h:228
ADC_ORDINARY_TRIG_EDGE_NONE
@ ADC_ORDINARY_TRIG_EDGE_NONE
Definition: at32f435_437_adc.h:265
ADC_RESOLUTION_12B
@ ADC_RESOLUTION_12B
Definition: at32f435_437_adc.h:167
ADC_HCLK_DIV_4
@ ADC_HCLK_DIV_4
Definition: at32f435_437_adc.h:90
ADC_RDY_FLAG
#define ADC_RDY_FLAG
Definition: at32f435_437_adc.h:73
ADC_OCCO_INT
#define ADC_OCCO_INT
Definition: at32f435_437_adc.h:56
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:158
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_ADC1
@ DMAMUX_DMAREQ_ID_ADC1
Definition: at32f435_437_dma.h:197
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f435_437_dma.h:66
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f435_437.h:204
ADC1_2_3_IRQn
@ ADC1_2_3_IRQn
Definition: at32f435_437.h:166
ADC_VREF
#define ADC_VREF
Definition: project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c:30
ADC_TEMP_SLOPE
#define ADC_TEMP_SLOPE
Definition: project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c:32
ADC_TEMP_BASE
#define ADC_TEMP_BASE
Definition: project/at_start_f435/examples/adc/internal_temperature_sensor/src/main.c:31
adc_base_config_type
adc base config type
Definition: at32f435_437_adc.h:402
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f435_437_adc.h:405
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f435_437_adc.h:404
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f435_437_adc.h:403
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f435_437_adc.h:406
adc_common_config_type
adc common config type
Definition: at32f435_437_adc.h:388
adc_common_config_type::sampling_interval
adc_sampling_interval_type sampling_interval
Definition: at32f435_437_adc.h:393
adc_common_config_type::tempervintrv_state
confirm_state tempervintrv_state
Definition: at32f435_437_adc.h:394
adc_common_config_type::div
adc_div_type div
Definition: at32f435_437_adc.h:390
adc_common_config_type::common_dma_mode
adc_common_dma_mode_type common_dma_mode
Definition: at32f435_437_adc.h:391
adc_common_config_type::common_dma_request_repeat_state
confirm_state common_dma_request_repeat_state
Definition: at32f435_437_adc.h:392
adc_common_config_type::combine_mode
adc_combine_mode_type combine_mode
Definition: at32f435_437_adc.h:389
adc_common_config_type::vbat_state
confirm_state vbat_state
Definition: at32f435_437_adc.h:395
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • adc
  • ordinary_preempt_oversampling
  • inc
project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • adc
  • ordinary_preempt_oversampling
  • inc
project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • adc
  • ordinary_preempt_oversampling
  • inc
project/at_start_f435/examples/adc/ordinary_preempt_oversampling/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • adc
  • ordinary_preempt_oversampling
  • src
Functions
project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 49 of file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • adc
  • ordinary_preempt_oversampling
  • src
project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_clock.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • adc
  • ordinary_preempt_oversampling
  • src
Functions | Variables
project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...

Variables

__IO uint16_t | adc1_preempt_valuetab [5][3]
__IO uint16_t | dma_trans_complete_flag
__IO uint16_t | preempt_conversion_count
__IO uint32_t | adc1_overflow_flag

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • adc
  • ordinary_preempt_oversampling
  • src
project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
39extern __IO uint16_t adc1_preempt_valuetab[5][3];
40extern __IO uint16_t dma_trans_complete_flag;
41extern __IO uint16_t preempt_conversion_count;
42extern __IO uint32_t adc1_overflow_flag;
43
49void NMI_Handler(void)
50{
51}
52
58void HardFault_Handler(void)
59{
60 /* go to infinite loop when hard fault exception occurs */
61 while(1)
62 {
63 }
64}
65
71void MemManage_Handler(void)
72{
73 /* go to infinite loop when memory manage exception occurs */
74 while(1)
75 {
76 }
77}
78
84void BusFault_Handler(void)
85{
86 /* go to infinite loop when bus fault exception occurs */
87 while(1)
88 {
89 }
90}
91
97void UsageFault_Handler(void)
98{
99 /* go to infinite loop when usage fault exception occurs */
100 while(1)
101 {
102 }
103}
104
110void SVC_Handler(void)
111{
112}
113
119void DebugMon_Handler(void)
120{
121}
122
128void PendSV_Handler(void)
129{
130}
131
137void SysTick_Handler(void)
138{
139}
140
146void DMA1_Channel1_IRQHandler(void)
147{
148 if(dma_flag_get(DMA1_FDT1_FLAG) != RESET)
149 {
150 dma_flag_clear(DMA1_FDT1_FLAG);
151 dma_trans_complete_flag = 1;
152 }
153}
154
160void ADC1_2_3_IRQHandler(void)
161{
162 if(adc_flag_get(ADC1, ADC_OCCO_FLAG) != RESET)
163 {
164 adc_flag_clear(ADC1, ADC_OCCO_FLAG);
165 adc1_overflow_flag++;
166 }
167 if(adc_flag_get(ADC1, ADC_PCCE_FLAG) != RESET)
168 {
169 adc_flag_clear(ADC1, ADC_PCCE_FLAG);
170 if(preempt_conversion_count < 5)
171 {
172 adc1_preempt_valuetab[preempt_conversion_count][0] = adc_preempt_conversion_data_get(ADC1, ADC_PREEMPT_CHANNEL_1);
173 adc1_preempt_valuetab[preempt_conversion_count][1] = adc_preempt_conversion_data_get(ADC1, ADC_PREEMPT_CHANNEL_2);
174 adc1_preempt_valuetab[preempt_conversion_count][2] = adc_preempt_conversion_data_get(ADC1, ADC_PREEMPT_CHANNEL_3);
175 preempt_conversion_count++;
176 }
177 }
178}
179
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f435/examples/adc/conversion_abort/src/main.c:39
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c:97
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c:58
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c:71
adc1_preempt_valuetab
__IO uint16_t adc1_preempt_valuetab[5][3]
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c:38
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c:110
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:40
ADC1_2_3_IRQHandler
void ADC1_2_3_IRQHandler(void)
this function handles adc1_2_3 handler.
Definition: project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c:160
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c:128
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c:49
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1_channel1 handler.
Definition: project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c:146
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c:84
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c:137
preempt_conversion_count
__IO uint16_t preempt_conversion_count
Definition: project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c:41
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/at32f435_437_int.c:119
adc_preempt_conversion_data_get
uint16_t adc_preempt_conversion_data_get(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral.
Definition: at32f435_437_adc.c:1036
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1106
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
ADC_PREEMPT_CHANNEL_3
@ ADC_PREEMPT_CHANNEL_3
Definition: at32f435_437_adc.h:326
ADC_PREEMPT_CHANNEL_2
@ ADC_PREEMPT_CHANNEL_2
Definition: at32f435_437_adc.h:325
ADC_PREEMPT_CHANNEL_1
@ ADC_PREEMPT_CHANNEL_1
Definition: at32f435_437_adc.h:324
ADC_PCCE_FLAG
#define ADC_PCCE_FLAG
Definition: at32f435_437_adc.h:69
ADC_OCCO_FLAG
#define ADC_OCCO_FLAG
Definition: at32f435_437_adc.h:72
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f435_437_dma.h:66
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • adc
  • ordinary_preempt_oversampling
  • src
Functions | Variables
project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [5][3] = {0}
__IO uint16_t | adc1_preempt_valuetab [5][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint16_t | preempt_conversion_count = 0
__IO uint32_t | adc1_overflow_flag = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • adc
  • ordinary_preempt_oversampling
  • src
project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38__IO uint16_t adc1_ordinary_valuetab[5][3] = {0};
39__IO uint16_t adc1_preempt_valuetab[5][3] = {0};
40__IO uint16_t dma_trans_complete_flag = 0;
41__IO uint16_t preempt_conversion_count = 0;
42__IO uint32_t adc1_overflow_flag = 0;
43
44static void gpio_config(void);
45static void dma_config(void);
46static void adc_config(void);
47
53static void gpio_config(void)
54{
55 gpio_init_type gpio_initstructure;
56 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
57 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
58
59 gpio_default_para_init(&gpio_initstructure);
60
61 /* config adc pin as analog input mode */
62 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
63 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6 | GPIO_PINS_7;
64 gpio_init(GPIOA, &gpio_initstructure);
65
66 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
67 gpio_initstructure.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
68 gpio_init(GPIOB, &gpio_initstructure);
69}
70
76static void dma_config(void)
77{
78 dma_init_type dma_init_struct;
79 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
80 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
81
82 dma_reset(DMA1_CHANNEL1);
83 dma_default_para_init(&dma_init_struct);
84 dma_init_struct.buffer_size = 15;
85 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
86 dma_init_struct.memory_base_addr = (uint32_t)adc1_ordinary_valuetab;
87 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
88 dma_init_struct.memory_inc_enable = TRUE;
89 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
90 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
91 dma_init_struct.peripheral_inc_enable = FALSE;
92 dma_init_struct.priority = DMA_PRIORITY_HIGH;
93 dma_init_struct.loop_mode_enable = FALSE;
94 dma_init(DMA1_CHANNEL1, &dma_init_struct);
95
96 dmamux_enable(DMA1, TRUE);
97 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_ADC1);
98
99 /* enable dma transfer complete interrupt */
100 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
101 dma_channel_enable(DMA1_CHANNEL1, TRUE);
102}
103
109static void adc_config(void)
110{
111 adc_common_config_type adc_common_struct;
112 adc_base_config_type adc_base_struct;
113 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
114 nvic_irq_enable(ADC1_2_3_IRQn, 0, 0);
115
116 adc_common_default_para_init(&adc_common_struct);
117
118 /* config combine mode */
119 adc_common_struct.combine_mode = ADC_INDEPENDENT_MODE;
120
121 /* config division,adcclk is division by hclk */
122 adc_common_struct.div = ADC_HCLK_DIV_4;
123
124 /* config common dma mode,it's not useful in independent mode */
125 adc_common_struct.common_dma_mode = ADC_COMMON_DMAMODE_DISABLE;
126
127 /* config common dma request repeat */
128 adc_common_struct.common_dma_request_repeat_state = FALSE;
129
130 /* config adjacent adc sampling interval,it's useful for ordinary shifting mode */
131 adc_common_struct.sampling_interval = ADC_SAMPLING_INTERVAL_5CYCLES;
132
133 /* config inner temperature sensor and vintrv */
134 adc_common_struct.tempervintrv_state = FALSE;
135
136 /* config voltage battery */
137 adc_common_struct.vbat_state = FALSE;
138 adc_common_config(&adc_common_struct);
139
140 adc_base_default_para_init(&adc_base_struct);
141
142 adc_base_struct.sequence_mode = TRUE;
143 adc_base_struct.repeat_mode = FALSE;
144 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
145 adc_base_struct.ordinary_channel_length = 3;
146 adc_base_config(ADC1, &adc_base_struct);
147 adc_resolution_set(ADC1, ADC_RESOLUTION_12B);
148
149 /* config ordinary channel */
150 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_6_5);
151 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_6_5);
152 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_6_5);
153
154 /* config ordinary trigger source and trigger edge */
155 adc_ordinary_conversion_trigger_set(ADC1, ADC_ORDINARY_TRIG_TMR1CH1, ADC_ORDINARY_TRIG_EDGE_NONE);
156
157 /* config dma mode,it's not useful when common dma mode is use */
158 adc_dma_mode_enable(ADC1, TRUE);
159
160 /* config dma request repeat,it's not useful when common dma mode is use */
161 adc_dma_request_repeat_enable(ADC1, FALSE);
162
163 /* config preempt channel */
164 adc_preempt_channel_length_set(ADC1, 3);
165 adc_preempt_channel_set(ADC1, ADC_CHANNEL_7, 1, ADC_SAMPLETIME_6_5);
166 adc_preempt_channel_set(ADC1, ADC_CHANNEL_8, 2, ADC_SAMPLETIME_6_5);
167 adc_preempt_channel_set(ADC1, ADC_CHANNEL_9, 3, ADC_SAMPLETIME_6_5);
168
169 /* config preempt trigger source and trigger edge */
170 adc_preempt_conversion_trigger_set(ADC1, ADC_PREEMPT_TRIG_TMR1CH4, ADC_PREEMPT_TRIG_EDGE_NONE);
171
172 /* disable preempt group automatic conversion after ordinary group */
173 adc_preempt_auto_mode_enable(ADC1, FALSE);
174
175 /* enable adc overflow interrupt */
176 adc_interrupt_enable(ADC1, ADC_OCCO_INT, TRUE);
177
178 /* enable adc preempt channels conversion end interrupt */
179 adc_interrupt_enable(ADC1, ADC_PCCE_INT, TRUE);
180
181 /* set oversampling ratio and shift */
182 adc_oversample_ratio_shift_set(ADC1, ADC_OVERSAMPLE_RATIO_8, ADC_OVERSAMPLE_SHIFT_3);
183
184 /* disable ordinary oversampling trigger mode */
185 adc_ordinary_oversample_trig_enable(ADC1, FALSE);
186
187 /* set ordinary oversample restart mode */
188 adc_ordinary_oversample_restart_set(ADC1, ADC_OVERSAMPLE_CONTINUE);
189
190 /* enable ordinary oversampling */
191 adc_ordinary_oversample_enable(ADC1, TRUE);
192
193 /* enable preempt oversampling */
194 adc_preempt_oversample_enable(ADC1, TRUE);
195
196 /* adc enable */
197 adc_enable(ADC1, TRUE);
198 while(adc_flag_get(ADC1, ADC_RDY_FLAG) == RESET);
199
200 /* adc calibration */
201 adc_calibration_init(ADC1);
202 while(adc_calibration_init_status_get(ADC1));
203 adc_calibration_start(ADC1);
204 while(adc_calibration_status_get(ADC1));
205}
206
212int main(void)
213{
214 __IO uint32_t index = 0;
215 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
216
217 /* config the system clock */
218 system_clock_config();
219
220 /* init at start board */
221 at32_board_init();
222 at32_led_off(LED2);
223 at32_led_off(LED3);
224 at32_led_off(LED4);
225 uart_print_init(115200);
226 gpio_config();
227 dma_config();
228 adc_config();
229 printf("tmr_trigger_automatic_preempt \r\n");
230
231 /* adc1 software trigger start conversion */
232 for(index = 0; index < 5; index++)
233 {
234 adc_ordinary_software_trigger_enable(ADC1, TRUE);
235 adc_preempt_software_trigger_enable(ADC1, TRUE);
236 delay_sec(1);
237 }
238 if((dma_trans_complete_flag == 0) || (adc1_overflow_flag != 0))
239 {
240 /* printf flag when error occur */
241 at32_led_on(LED3);
242 at32_led_on(LED4);
243 printf("error occur\r\n");
244 printf("adc1_overflow_flag = %d\r\n",adc1_overflow_flag);
245 printf("dma_trans_complete_flag = %d\r\n",dma_trans_complete_flag);
246 }
247 else
248 {
249 /* printf data when conversion end without error */
250 printf("conversion end without error\r\n");
251 for(index = 0; index < 5; index++)
252 {
253 printf("adc1_ordinary_valuetab[%d][0] = 0x%x\r\n", index, adc1_ordinary_valuetab[index][0]);
254 printf("adc1_ordinary_valuetab[%d][1] = 0x%x\r\n", index, adc1_ordinary_valuetab[index][1]);
255 printf("adc1_ordinary_valuetab[%d][2] = 0x%x\r\n", index, adc1_ordinary_valuetab[index][2]);
256 printf("adc1_preempt_valuetab[%d][0] = 0x%x\r\n", index, adc1_preempt_valuetab[index][0]);
257 printf("adc1_preempt_valuetab[%d][1] = 0x%x\r\n", index, adc1_preempt_valuetab[index][1]);
258 printf("adc1_preempt_valuetab[%d][2] = 0x%x\r\n", index, adc1_preempt_valuetab[index][2]);
259 printf("\r\n");
260 }
261 }
262 at32_led_on(LED2);
263 while(1)
264 {
265 }
266}
267
at32f435_437_board.h
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c:40
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c:76
adc1_preempt_valuetab
__IO uint16_t adc1_preempt_valuetab[5][3]
Definition: project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c:39
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c:42
adc1_ordinary_valuetab
__IO uint16_t adc1_ordinary_valuetab[5][3]
Definition: project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c:38
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c:109
main
int main(void)
main function.
Definition: project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c:212
preempt_conversion_count
__IO uint16_t preempt_conversion_count
Definition: project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c:41
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c:53
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:945
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc ...
Definition: at32f435_437_adc.c:742
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f435_437_adc.c:110
adc_preempt_auto_mode_enable
void adc_preempt_auto_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable automatic preempt group conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:886
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f435_437_adc.c:64
adc_ordinary_oversample_enable
void adc_ordinary_oversample_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the ordinary oversampling of the specified adc peripheral.
Definition: at32f435_437_adc.c:1120
adc_oversample_ratio_shift_set
void adc_oversample_ratio_shift_set(adc_type *adc_x, adc_oversample_ratio_type adc_oversample_ratio, adc_oversample_shift_type adc_oversample_shift)
config the oversampling ratio and shift of the specified adc peripheral.
Definition: at32f435_437_adc.c:1167
adc_preempt_oversample_enable
void adc_preempt_oversample_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the preempt oversampling of the specified adc peripheral.
Definition: at32f435_437_adc.c:1134
adc_preempt_conversion_trigger_set
void adc_preempt_conversion_trigger_set(adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, adc_preempt_trig_edge_type adc_preempt_trig_edge)
enable or disable the preempt channel's external trigger and set external trigger event of the specif...
Definition: at32f435_437_adc.c:781
adc_common_config
void adc_common_config(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:203
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f435_437_adc.c:294
adc_resolution_set
void adc_resolution_set(adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral.
Definition: at32f435_437_adc.c:235
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f435_437_adc.c:84
adc_ordinary_oversample_trig_enable
void adc_ordinary_oversample_trig_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the ordinary oversampling trigger mode of the specified adc peripheral.
Definition: at32f435_437_adc.c:1182
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f435_437_adc.c:359
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f435_437_adc.c:371
adc_dma_request_repeat_enable
void adc_dma_request_repeat_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat.
Definition: at32f435_437_adc.c:274
adc_ordinary_oversample_restart_set
void adc_ordinary_oversample_restart_set(adc_type *adc_x, adc_ordinary_oversample_restart_type adc_ordinary_oversample_restart)
set ordinary oversample restart mode of the specified adc peripheral.
Definition: at32f435_437_adc.c:1198
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f435_437_adc.c:328
adc_preempt_channel_set
void adc_preempt_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc ...
Definition: at32f435_437_adc.c:633
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f435_437_adc.c:340
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f435_437_adc.c:260
adc_preempt_channel_length_set
void adc_preempt_channel_length_set(adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral.
Definition: at32f435_437_adc.c:601
adc_common_default_para_init
void adc_common_default_para_init(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:155
adc_preempt_software_trigger_enable
void adc_preempt_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable preempt software start conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:978
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f435_437_adc.c:472
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f435_437_adc.h:178
ADC_CHANNEL_9
@ ADC_CHANNEL_9
Definition: at32f435_437_adc.h:196
ADC_CHANNEL_8
@ ADC_CHANNEL_8
Definition: at32f435_437_adc.h:195
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f435_437_adc.h:191
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f435_437_adc.h:193
ADC_CHANNEL_7
@ ADC_CHANNEL_7
Definition: at32f435_437_adc.h:194
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f435_437_adc.h:192
ADC_SAMPLETIME_6_5
@ ADC_SAMPLETIME_6_5
Definition: at32f435_437_adc.h:214
ADC_SAMPLING_INTERVAL_5CYCLES
@ ADC_SAMPLING_INTERVAL_5CYCLES
Definition: at32f435_437_adc.h:144
ADC_OVERSAMPLE_SHIFT_3
@ ADC_OVERSAMPLE_SHIFT_3
Definition: at32f435_437_adc.h:367
ADC_COMMON_DMAMODE_DISABLE
@ ADC_COMMON_DMAMODE_DISABLE
Definition: at32f435_437_adc.h:131
ADC_PREEMPT_TRIG_TMR1CH4
@ ADC_PREEMPT_TRIG_TMR1CH4
Definition: at32f435_437_adc.h:276
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f435_437_adc.h:111
ADC_ORDINARY_TRIG_TMR1CH1
@ ADC_ORDINARY_TRIG_TMR1CH1
Definition: at32f435_437_adc.h:228
ADC_PREEMPT_TRIG_EDGE_NONE
@ ADC_PREEMPT_TRIG_EDGE_NONE
Definition: at32f435_437_adc.h:313
ADC_OVERSAMPLE_RATIO_8
@ ADC_OVERSAMPLE_RATIO_8
Definition: at32f435_437_adc.h:351
ADC_ORDINARY_TRIG_EDGE_NONE
@ ADC_ORDINARY_TRIG_EDGE_NONE
Definition: at32f435_437_adc.h:265
ADC_RESOLUTION_12B
@ ADC_RESOLUTION_12B
Definition: at32f435_437_adc.h:167
ADC_OVERSAMPLE_CONTINUE
@ ADC_OVERSAMPLE_CONTINUE
Definition: at32f435_437_adc.h:380
ADC_HCLK_DIV_4
@ ADC_HCLK_DIV_4
Definition: at32f435_437_adc.h:90
ADC_RDY_FLAG
#define ADC_RDY_FLAG
Definition: at32f435_437_adc.h:73
ADC_PCCE_INT
#define ADC_PCCE_INT
Definition: at32f435_437_adc.h:55
ADC_OCCO_INT
#define ADC_OCCO_INT
Definition: at32f435_437_adc.h:56
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:158
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_ADC1
@ DMAMUX_DMAREQ_ID_ADC1
Definition: at32f435_437_dma.h:197
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f435_437_gpio.h:85
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f435_437.h:204
ADC1_2_3_IRQn
@ ADC1_2_3_IRQn
Definition: at32f435_437.h:166
adc_base_config_type
adc base config type
Definition: at32f435_437_adc.h:402
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f435_437_adc.h:405
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f435_437_adc.h:404
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f435_437_adc.h:403
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f435_437_adc.h:406
adc_common_config_type
adc common config type
Definition: at32f435_437_adc.h:388
adc_common_config_type::sampling_interval
adc_sampling_interval_type sampling_interval
Definition: at32f435_437_adc.h:393
adc_common_config_type::tempervintrv_state
confirm_state tempervintrv_state
Definition: at32f435_437_adc.h:394
adc_common_config_type::div
adc_div_type div
Definition: at32f435_437_adc.h:390
adc_common_config_type::common_dma_mode
adc_common_dma_mode_type common_dma_mode
Definition: at32f435_437_adc.h:391
adc_common_config_type::common_dma_request_repeat_state
confirm_state common_dma_request_repeat_state
Definition: at32f435_437_adc.h:392
adc_common_config_type::combine_mode
adc_combine_mode_type combine_mode
Definition: at32f435_437_adc.h:389
adc_common_config_type::vbat_state
confirm_state vbat_state
Definition: at32f435_437_adc.h:395
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • adc
  • resolution_6bit
  • inc
project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • adc
  • resolution_6bit
  • inc
project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • adc
  • resolution_6bit
  • inc
project/at_start_f435/examples/adc/resolution_6bit/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • adc
  • resolution_6bit
  • src
Functions
project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 49 of file project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • adc
  • resolution_6bit
  • src
project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_clock.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • adc
  • resolution_6bit
  • src
Functions | Variables
project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...

Variables

__IO uint16_t | dma_trans_complete_flag
__IO uint32_t | adc1_overflow_flag

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • adc
  • resolution_6bit
  • src
project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
39extern __IO uint16_t dma_trans_complete_flag;
40extern __IO uint32_t adc1_overflow_flag;
41
47void NMI_Handler(void)
48{
49}
50
56void HardFault_Handler(void)
57{
58 /* go to infinite loop when hard fault exception occurs */
59 while(1)
60 {
61 }
62}
63
69void MemManage_Handler(void)
70{
71 /* go to infinite loop when memory manage exception occurs */
72 while(1)
73 {
74 }
75}
76
82void BusFault_Handler(void)
83{
84 /* go to infinite loop when bus fault exception occurs */
85 while(1)
86 {
87 }
88}
89
95void UsageFault_Handler(void)
96{
97 /* go to infinite loop when usage fault exception occurs */
98 while(1)
99 {
100 }
101}
102
108void SVC_Handler(void)
109{
110}
111
117void DebugMon_Handler(void)
118{
119}
120
126void PendSV_Handler(void)
127{
128}
129
135void SysTick_Handler(void)
136{
137}
138
144void DMA1_Channel1_IRQHandler(void)
145{
146 if(dma_flag_get(DMA1_FDT1_FLAG) != RESET)
147 {
148 dma_flag_clear(DMA1_FDT1_FLAG);
149 dma_trans_complete_flag = 1;
150 }
151}
152
158void ADC1_2_3_IRQHandler(void)
159{
160 if(adc_flag_get(ADC1, ADC_OCCO_FLAG) != RESET)
161 {
162 adc_flag_clear(ADC1, ADC_OCCO_FLAG);
163 adc1_overflow_flag++;
164 }
165}
166
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f435/examples/adc/conversion_abort/src/main.c:39
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c:95
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c:56
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c:69
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c:108
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:40
ADC1_2_3_IRQHandler
void ADC1_2_3_IRQHandler(void)
this function handles adc1_2_3 handler.
Definition: project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c:158
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c:126
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c:47
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1_channel1 handler.
Definition: project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c:144
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c:82
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c:135
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/adc/resolution_6bit/src/at32f435_437_int.c:117
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1106
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
ADC_OCCO_FLAG
#define ADC_OCCO_FLAG
Definition: at32f435_437_adc.h:72
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f435_437_dma.h:66
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • adc
  • resolution_6bit
  • src
Functions | Variables
project/at_start_f435/examples/adc/resolution_6bit/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [10][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/resolution_6bit/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • adc
  • resolution_6bit
  • src
project/at_start_f435/examples/adc/resolution_6bit/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38__IO uint16_t adc1_ordinary_valuetab[10][3] = {0};
39__IO uint16_t dma_trans_complete_flag = 0;
40__IO uint32_t adc1_overflow_flag = 0;
41
42static void gpio_config(void);
43static void dma_config(void);
44static void adc_config(void);
45
51static void gpio_config(void)
52{
53 gpio_init_type gpio_initstructure;
54 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
55
56 gpio_default_para_init(&gpio_initstructure);
57
58 /* config adc pin as analog input mode */
59 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
60 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6;
61 gpio_init(GPIOA, &gpio_initstructure);
62}
63
69static void dma_config(void)
70{
71 dma_init_type dma_init_struct;
72 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
73 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
74
75 dma_reset(DMA1_CHANNEL1);
76 dma_default_para_init(&dma_init_struct);
77 dma_init_struct.buffer_size = 30;
78 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
79 dma_init_struct.memory_base_addr = (uint32_t)adc1_ordinary_valuetab;
80 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
81 dma_init_struct.memory_inc_enable = TRUE;
82 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
83 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
84 dma_init_struct.peripheral_inc_enable = FALSE;
85 dma_init_struct.priority = DMA_PRIORITY_HIGH;
86 dma_init_struct.loop_mode_enable = FALSE;
87 dma_init(DMA1_CHANNEL1, &dma_init_struct);
88
89 dmamux_enable(DMA1, TRUE);
90 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_ADC1);
91
92 /* enable dma transfer complete interrupt */
93 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
94 dma_channel_enable(DMA1_CHANNEL1, TRUE);
95}
96
102static void adc_config(void)
103{
104 adc_common_config_type adc_common_struct;
105 adc_base_config_type adc_base_struct;
106 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
107 nvic_irq_enable(ADC1_2_3_IRQn, 0, 0);
108
109 adc_common_default_para_init(&adc_common_struct);
110
111 /* config combine mode */
112 adc_common_struct.combine_mode = ADC_INDEPENDENT_MODE;
113
114 /* config division,adcclk is division by hclk */
115 adc_common_struct.div = ADC_HCLK_DIV_4;
116
117 /* config common dma mode,it's not useful in independent mode */
118 adc_common_struct.common_dma_mode = ADC_COMMON_DMAMODE_DISABLE;
119
120 /* config common dma request repeat */
121 adc_common_struct.common_dma_request_repeat_state = FALSE;
122
123 /* config adjacent adc sampling interval,it's useful for ordinary shifting mode */
124 adc_common_struct.sampling_interval = ADC_SAMPLING_INTERVAL_5CYCLES;
125
126 /* config inner temperature sensor and vintrv */
127 adc_common_struct.tempervintrv_state = FALSE;
128
129 /* config voltage battery */
130 adc_common_struct.vbat_state = FALSE;
131 adc_common_config(&adc_common_struct);
132
133 adc_base_default_para_init(&adc_base_struct);
134
135 adc_base_struct.sequence_mode = TRUE;
136 adc_base_struct.repeat_mode = TRUE;
137 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
138 adc_base_struct.ordinary_channel_length = 3;
139 adc_base_config(ADC1, &adc_base_struct);
140 adc_resolution_set(ADC1, ADC_RESOLUTION_12B);
141
142 /* config ordinary channel */
143 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_47_5);
144 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_47_5);
145 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_47_5);
146
147 /* config ordinary trigger source and trigger edge */
148 adc_ordinary_conversion_trigger_set(ADC1, ADC_ORDINARY_TRIG_TMR1CH1, ADC_ORDINARY_TRIG_EDGE_NONE);
149
150 /* config dma mode,it's not useful when common dma mode is use */
151 adc_dma_mode_enable(ADC1, TRUE);
152
153 /* config dma request repeat,it's not useful when common dma mode is use */
154 adc_dma_request_repeat_enable(ADC1, FALSE);
155
156 /* enable adc overflow interrupt */
157 adc_interrupt_enable(ADC1, ADC_OCCO_INT, TRUE);
158
159 /* adc enable */
160 adc_enable(ADC1, TRUE);
161 while(adc_flag_get(ADC1, ADC_RDY_FLAG) == RESET);
162
163 /* adc calibration */
164 adc_calibration_init(ADC1);
165 while(adc_calibration_init_status_get(ADC1));
166 adc_calibration_start(ADC1);
167 while(adc_calibration_status_get(ADC1));
168
169 /*set resolution to 6bit.this because calibration must perform at 12 bit resolution */
170 adc_resolution_set(ADC1,ADC_RESOLUTION_6B);
171 while(adc_flag_get(ADC1, ADC_RDY_FLAG) == RESET);
172}
173
179int main(void)
180{
181 __IO uint32_t index = 0;
182 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
183
184 /* config the system clock */
185 system_clock_config();
186
187 /* init at start board */
188 at32_board_init();
189 at32_led_off(LED2);
190 at32_led_off(LED3);
191 at32_led_off(LED4);
192 uart_print_init(115200);
193 gpio_config();
194 dma_config();
195 adc_config();
196 printf("resolution_6bit \r\n");
197 adc_ordinary_software_trigger_enable(ADC1, TRUE);
198 while(dma_trans_complete_flag == 0);
199 if(adc1_overflow_flag != 0)
200 {
201 /* printf flag when error occur */
202 at32_led_on(LED3);
203 at32_led_on(LED4);
204 printf("error occur\r\n");
205 printf("adc1_overflow_flag = %d\r\n",adc1_overflow_flag);
206 }
207 else
208 {
209 /* printf data when conversion end without error */
210 printf("conversion end without error\r\n");
211 for(index = 0; index < 10; index++)
212 {
213 printf("adc1_ordinary_valuetab[%d][0] = 0x%x\r\n",index, adc1_ordinary_valuetab[index][0]);
214 printf("adc1_ordinary_valuetab[%d][1] = 0x%x\r\n",index, adc1_ordinary_valuetab[index][1]);
215 printf("adc1_ordinary_valuetab[%d][2] = 0x%x\r\n",index, adc1_ordinary_valuetab[index][2]);
216 printf("\r\n");
217 }
218 }
219 at32_led_on(LED2);
220 while(1)
221 {
222 }
223}
224
at32f435_437_board.h
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f435/examples/adc/resolution_6bit/src/main.c:39
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f435/examples/adc/resolution_6bit/src/main.c:69
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/resolution_6bit/src/main.c:40
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f435/examples/adc/resolution_6bit/src/main.c:102
main
int main(void)
main function.
Definition: project/at_start_f435/examples/adc/resolution_6bit/src/main.c:179
adc1_ordinary_valuetab
__IO uint16_t adc1_ordinary_valuetab[10][3]
Definition: project/at_start_f435/examples/adc/resolution_6bit/src/main.c:38
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/adc/resolution_6bit/src/main.c:51
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:945
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc ...
Definition: at32f435_437_adc.c:742
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f435_437_adc.c:110
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f435_437_adc.c:64
adc_common_config
void adc_common_config(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:203
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f435_437_adc.c:294
adc_resolution_set
void adc_resolution_set(adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral.
Definition: at32f435_437_adc.c:235
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f435_437_adc.c:84
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f435_437_adc.c:359
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f435_437_adc.c:371
adc_dma_request_repeat_enable
void adc_dma_request_repeat_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat.
Definition: at32f435_437_adc.c:274
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f435_437_adc.c:328
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f435_437_adc.c:340
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f435_437_adc.c:260
adc_common_default_para_init
void adc_common_default_para_init(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:155
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f435_437_adc.c:472
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f435_437_adc.h:178
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f435_437_adc.h:191
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f435_437_adc.h:193
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f435_437_adc.h:192
ADC_SAMPLETIME_47_5
@ ADC_SAMPLETIME_47_5
Definition: at32f435_437_adc.h:217
ADC_SAMPLING_INTERVAL_5CYCLES
@ ADC_SAMPLING_INTERVAL_5CYCLES
Definition: at32f435_437_adc.h:144
ADC_COMMON_DMAMODE_DISABLE
@ ADC_COMMON_DMAMODE_DISABLE
Definition: at32f435_437_adc.h:131
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f435_437_adc.h:111
ADC_ORDINARY_TRIG_TMR1CH1
@ ADC_ORDINARY_TRIG_TMR1CH1
Definition: at32f435_437_adc.h:228
ADC_ORDINARY_TRIG_EDGE_NONE
@ ADC_ORDINARY_TRIG_EDGE_NONE
Definition: at32f435_437_adc.h:265
ADC_RESOLUTION_6B
@ ADC_RESOLUTION_6B
Definition: at32f435_437_adc.h:170
ADC_RESOLUTION_12B
@ ADC_RESOLUTION_12B
Definition: at32f435_437_adc.h:167
ADC_HCLK_DIV_4
@ ADC_HCLK_DIV_4
Definition: at32f435_437_adc.h:90
ADC_RDY_FLAG
#define ADC_RDY_FLAG
Definition: at32f435_437_adc.h:73
ADC_OCCO_INT
#define ADC_OCCO_INT
Definition: at32f435_437_adc.h:56
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:158
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_ADC1
@ DMAMUX_DMAREQ_ID_ADC1
Definition: at32f435_437_dma.h:197
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f435_437_gpio.h:85
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f435_437.h:204
ADC1_2_3_IRQn
@ ADC1_2_3_IRQn
Definition: at32f435_437.h:166
adc_base_config_type
adc base config type
Definition: at32f435_437_adc.h:402
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f435_437_adc.h:405
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f435_437_adc.h:404
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f435_437_adc.h:403
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f435_437_adc.h:406
adc_common_config_type
adc common config type
Definition: at32f435_437_adc.h:388
adc_common_config_type::sampling_interval
adc_sampling_interval_type sampling_interval
Definition: at32f435_437_adc.h:393
adc_common_config_type::tempervintrv_state
confirm_state tempervintrv_state
Definition: at32f435_437_adc.h:394
adc_common_config_type::div
adc_div_type div
Definition: at32f435_437_adc.h:390
adc_common_config_type::common_dma_mode
adc_common_dma_mode_type common_dma_mode
Definition: at32f435_437_adc.h:391
adc_common_config_type::common_dma_request_repeat_state
confirm_state common_dma_request_repeat_state
Definition: at32f435_437_adc.h:392
adc_common_config_type::combine_mode
adc_combine_mode_type combine_mode
Definition: at32f435_437_adc.h:389
adc_common_config_type::vbat_state
confirm_state vbat_state
Definition: at32f435_437_adc.h:395
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • adc
  • software_trigger_repeat
  • inc
project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • adc
  • software_trigger_repeat
  • inc
project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • adc
  • software_trigger_repeat
  • inc
project/at_start_f435/examples/adc/software_trigger_repeat/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • adc
  • software_trigger_repeat
  • src
Functions
project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 49 of file project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • adc
  • software_trigger_repeat
  • src
project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_clock.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • adc
  • software_trigger_repeat
  • src
Functions | Variables
project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...

Variables

__IO uint16_t | dma_trans_complete_flag
__IO uint32_t | adc1_overflow_flag

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • adc
  • software_trigger_repeat
  • src
project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
39extern __IO uint16_t dma_trans_complete_flag;
40extern __IO uint32_t adc1_overflow_flag;
41
47void NMI_Handler(void)
48{
49}
50
56void HardFault_Handler(void)
57{
58 /* go to infinite loop when hard fault exception occurs */
59 while(1)
60 {
61 }
62}
63
69void MemManage_Handler(void)
70{
71 /* go to infinite loop when memory manage exception occurs */
72 while(1)
73 {
74 }
75}
76
82void BusFault_Handler(void)
83{
84 /* go to infinite loop when bus fault exception occurs */
85 while(1)
86 {
87 }
88}
89
95void UsageFault_Handler(void)
96{
97 /* go to infinite loop when usage fault exception occurs */
98 while(1)
99 {
100 }
101}
102
108void SVC_Handler(void)
109{
110}
111
117void DebugMon_Handler(void)
118{
119}
120
126void PendSV_Handler(void)
127{
128}
129
135void SysTick_Handler(void)
136{
137}
138
144void DMA1_Channel1_IRQHandler(void)
145{
146 if(dma_flag_get(DMA1_FDT1_FLAG) != RESET)
147 {
148 dma_flag_clear(DMA1_FDT1_FLAG);
149 dma_trans_complete_flag = 1;
150 }
151}
152
158void ADC1_2_3_IRQHandler(void)
159{
160 if(adc_flag_get(ADC1, ADC_OCCO_FLAG) != RESET)
161 {
162 adc_flag_clear(ADC1, ADC_OCCO_FLAG);
163 adc1_overflow_flag++;
164 }
165}
166
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c:95
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c:56
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c:69
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c:108
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c:126
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c:47
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c:82
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c:135
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/at32f435_437_int.c:117
ADC1_2_3_IRQHandler
void ADC1_2_3_IRQHandler(void)
this function handles adc1_2_3 handler.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c:159
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1_channel1 handler.
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/at32f435_437_int.c:145
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f435/examples/adc/conversion_abort/src/main.c:39
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:40
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1106
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
ADC_OCCO_FLAG
#define ADC_OCCO_FLAG
Definition: at32f435_437_adc.h:72
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f435_437_dma.h:66
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • adc
  • software_trigger_repeat
  • src
Functions | Variables
project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [10][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint32_t | adc1_overflow_flag = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c.

Function Documentation

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< ordinary channel conversion overflow interrupt

< adc ready to conversion flag

Definition at line 102 of file project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 69 of file project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

Definition at line 51 of file project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • adc
  • software_trigger_repeat
  • src
project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38__IO uint16_t adc1_ordinary_valuetab[10][3] = {0};
39__IO uint16_t dma_trans_complete_flag = 0;
40__IO uint32_t adc1_overflow_flag = 0;
41
42static void gpio_config(void);
43static void dma_config(void);
44static void adc_config(void);
45
51static void gpio_config(void)
52{
53 gpio_init_type gpio_initstructure;
54 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
55
56 gpio_default_para_init(&gpio_initstructure);
57
58 /* config adc pin as analog input mode */
59 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
60 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6;
61 gpio_init(GPIOA, &gpio_initstructure);
62}
63
69static void dma_config(void)
70{
71 dma_init_type dma_init_struct;
72 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
73 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
74
75 dma_reset(DMA1_CHANNEL1);
76 dma_default_para_init(&dma_init_struct);
77 dma_init_struct.buffer_size = 30;
78 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
79 dma_init_struct.memory_base_addr = (uint32_t)adc1_ordinary_valuetab;
80 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
81 dma_init_struct.memory_inc_enable = TRUE;
82 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
83 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
84 dma_init_struct.peripheral_inc_enable = FALSE;
85 dma_init_struct.priority = DMA_PRIORITY_HIGH;
86 dma_init_struct.loop_mode_enable = FALSE;
87 dma_init(DMA1_CHANNEL1, &dma_init_struct);
88
89 dmamux_enable(DMA1, TRUE);
90 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_ADC1);
91
92 /* enable dma transfer complete interrupt */
93 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
94 dma_channel_enable(DMA1_CHANNEL1, TRUE);
95}
96
102static void adc_config(void)
103{
104 adc_common_config_type adc_common_struct;
105 adc_base_config_type adc_base_struct;
106 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
107 nvic_irq_enable(ADC1_2_3_IRQn, 0, 0);
108
109 adc_common_default_para_init(&adc_common_struct);
110
111 /* config combine mode */
112 adc_common_struct.combine_mode = ADC_INDEPENDENT_MODE;
113
114 /* config division,adcclk is division by hclk */
115 adc_common_struct.div = ADC_HCLK_DIV_4;
116
117 /* config common dma mode,it's not useful in independent mode */
118 adc_common_struct.common_dma_mode = ADC_COMMON_DMAMODE_DISABLE;
119
120 /* config common dma request repeat */
121 adc_common_struct.common_dma_request_repeat_state = FALSE;
122
123 /* config adjacent adc sampling interval,it's useful for ordinary shifting mode */
124 adc_common_struct.sampling_interval = ADC_SAMPLING_INTERVAL_5CYCLES;
125
126 /* config inner temperature sensor and vintrv */
127 adc_common_struct.tempervintrv_state = FALSE;
128
129 /* config voltage battery */
130 adc_common_struct.vbat_state = FALSE;
131 adc_common_config(&adc_common_struct);
132
133 adc_base_default_para_init(&adc_base_struct);
134
135 adc_base_struct.sequence_mode = TRUE;
136 adc_base_struct.repeat_mode = TRUE;
137 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
138 adc_base_struct.ordinary_channel_length = 3;
139 adc_base_config(ADC1, &adc_base_struct);
140 adc_resolution_set(ADC1, ADC_RESOLUTION_12B);
141
142 /* config ordinary channel */
143 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_47_5);
144 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_47_5);
145 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_47_5);
146
147 /* config ordinary trigger source and trigger edge */
148 adc_ordinary_conversion_trigger_set(ADC1, ADC_ORDINARY_TRIG_TMR1CH1, ADC_ORDINARY_TRIG_EDGE_NONE);
149
150 /* config dma mode,it's not useful when common dma mode is use */
151 adc_dma_mode_enable(ADC1, TRUE);
152
153 /* config dma request repeat,it's not useful when common dma mode is use */
154 adc_dma_request_repeat_enable(ADC1, FALSE);
155
156 /* enable adc overflow interrupt */
157 adc_interrupt_enable(ADC1, ADC_OCCO_INT, TRUE);
158
159 /* adc enable */
160 adc_enable(ADC1, TRUE);
161 while(adc_flag_get(ADC1, ADC_RDY_FLAG) == RESET);
162
163 /* adc calibration */
164 adc_calibration_init(ADC1);
165 while(adc_calibration_init_status_get(ADC1));
166 adc_calibration_start(ADC1);
167 while(adc_calibration_status_get(ADC1));
168}
169
175int main(void)
176{
177 __IO uint32_t index = 0;
178 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
179
180 /* config the system clock */
181 system_clock_config();
182
183 /* init at start board */
184 at32_board_init();
185 at32_led_off(LED2);
186 at32_led_off(LED3);
187 at32_led_off(LED4);
188 uart_print_init(115200);
189 gpio_config();
190 dma_config();
191 adc_config();
192 printf("software_trigger_repeat \r\n");
193 adc_ordinary_software_trigger_enable(ADC1, TRUE);
194 while(dma_trans_complete_flag == 0);
195 if(adc1_overflow_flag != 0)
196 {
197 /* printf flag when error occur */
198 at32_led_on(LED3);
199 at32_led_on(LED4);
200 printf("error occur\r\n");
201 printf("adc1_overflow_flag = %d\r\n",adc1_overflow_flag);
202 }
203 else
204 {
205 /* printf data when conversion end without error */
206 printf("conversion end without error\r\n");
207 for(index = 0; index < 10; index++)
208 {
209 printf("adc1_ordinary_valuetab[%d][0] = 0x%x\r\n",index, adc1_ordinary_valuetab[index][0]);
210 printf("adc1_ordinary_valuetab[%d][1] = 0x%x\r\n",index, adc1_ordinary_valuetab[index][1]);
211 printf("adc1_ordinary_valuetab[%d][2] = 0x%x\r\n",index, adc1_ordinary_valuetab[index][2]);
212 printf("\r\n");
213 }
214 }
215 at32_led_on(LED2);
216 while(1)
217 {
218 }
219}
220
at32f435_437_board.h
main
int main(void)
main function.
Definition: project/at_start_f435/examples/acc/calibration/src/main.c:167
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c:39
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c:40
adc1_ordinary_valuetab
__IO uint16_t adc1_ordinary_valuetab[10][3]
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:945
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc ...
Definition: at32f435_437_adc.c:742
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f435_437_adc.c:110
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f435_437_adc.c:64
adc_common_config
void adc_common_config(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:203
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f435_437_adc.c:294
adc_resolution_set
void adc_resolution_set(adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral.
Definition: at32f435_437_adc.c:235
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f435_437_adc.c:84
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f435_437_adc.c:359
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f435_437_adc.c:371
adc_dma_request_repeat_enable
void adc_dma_request_repeat_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat.
Definition: at32f435_437_adc.c:274
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f435_437_adc.c:328
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f435_437_adc.c:340
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f435_437_adc.c:260
adc_common_default_para_init
void adc_common_default_para_init(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:155
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f435_437_adc.c:472
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f435_437_adc.h:178
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f435_437_adc.h:191
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f435_437_adc.h:193
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f435_437_adc.h:192
ADC_SAMPLETIME_47_5
@ ADC_SAMPLETIME_47_5
Definition: at32f435_437_adc.h:217
ADC_SAMPLING_INTERVAL_5CYCLES
@ ADC_SAMPLING_INTERVAL_5CYCLES
Definition: at32f435_437_adc.h:144
ADC_COMMON_DMAMODE_DISABLE
@ ADC_COMMON_DMAMODE_DISABLE
Definition: at32f435_437_adc.h:131
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f435_437_adc.h:111
ADC_ORDINARY_TRIG_TMR1CH1
@ ADC_ORDINARY_TRIG_TMR1CH1
Definition: at32f435_437_adc.h:228
ADC_ORDINARY_TRIG_EDGE_NONE
@ ADC_ORDINARY_TRIG_EDGE_NONE
Definition: at32f435_437_adc.h:265
ADC_RESOLUTION_12B
@ ADC_RESOLUTION_12B
Definition: at32f435_437_adc.h:167
ADC_HCLK_DIV_4
@ ADC_HCLK_DIV_4
Definition: at32f435_437_adc.h:90
ADC_RDY_FLAG
#define ADC_RDY_FLAG
Definition: at32f435_437_adc.h:73
ADC_OCCO_INT
#define ADC_OCCO_INT
Definition: at32f435_437_adc.h:56
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:158
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_ADC1
@ DMAMUX_DMAREQ_ID_ADC1
Definition: at32f435_437_dma.h:197
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f435_437_gpio.h:85
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f435_437.h:204
ADC1_2_3_IRQn
@ ADC1_2_3_IRQn
Definition: at32f435_437.h:166
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c:69
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c:102
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/adc/software_trigger_repeat/src/main.c:51
adc_base_config_type
adc base config type
Definition: at32f435_437_adc.h:402
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f435_437_adc.h:405
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f435_437_adc.h:404
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f435_437_adc.h:403
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f435_437_adc.h:406
adc_common_config_type
adc common config type
Definition: at32f435_437_adc.h:388
adc_common_config_type::sampling_interval
adc_sampling_interval_type sampling_interval
Definition: at32f435_437_adc.h:393
adc_common_config_type::tempervintrv_state
confirm_state tempervintrv_state
Definition: at32f435_437_adc.h:394
adc_common_config_type::div
adc_div_type div
Definition: at32f435_437_adc.h:390
adc_common_config_type::common_dma_mode
adc_common_dma_mode_type common_dma_mode
Definition: at32f435_437_adc.h:391
adc_common_config_type::common_dma_request_repeat_state
confirm_state common_dma_request_repeat_state
Definition: at32f435_437_adc.h:392
adc_common_config_type::combine_mode
adc_combine_mode_type combine_mode
Definition: at32f435_437_adc.h:389
adc_common_config_type::vbat_state
confirm_state vbat_state
Definition: at32f435_437_adc.h:395
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • adc
  • tmr_trigger_automatic_preempted
  • inc
project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • adc
  • tmr_trigger_automatic_preempted
  • inc
project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • adc
  • tmr_trigger_automatic_preempted
  • inc
project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • adc
  • tmr_trigger_automatic_preempted
  • src
Functions
project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 49 of file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • adc
  • tmr_trigger_automatic_preempted
  • src
project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_clock.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • adc
  • tmr_trigger_automatic_preempted
  • src
Functions | Variables
project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [5][3]
__IO uint16_t | adc1_preempt_valuetab [5][3]
__IO uint16_t | dma_trans_complete_flag
__IO uint16_t | preempt_conversion_count
__IO uint32_t | adc1_overflow_flag

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • adc
  • tmr_trigger_automatic_preempted
  • src
project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
39extern __IO uint16_t adc1_ordinary_valuetab[5][3];
40extern __IO uint16_t adc1_preempt_valuetab[5][3];
41extern __IO uint16_t dma_trans_complete_flag;
42extern __IO uint16_t preempt_conversion_count;
43extern __IO uint32_t adc1_overflow_flag;
44
50void NMI_Handler(void)
51{
52}
53
59void HardFault_Handler(void)
60{
61 /* go to infinite loop when hard fault exception occurs */
62 while(1)
63 {
64 }
65}
66
72void MemManage_Handler(void)
73{
74 /* go to infinite loop when memory manage exception occurs */
75 while(1)
76 {
77 }
78}
79
85void BusFault_Handler(void)
86{
87 /* go to infinite loop when bus fault exception occurs */
88 while(1)
89 {
90 }
91}
92
98void UsageFault_Handler(void)
99{
100 /* go to infinite loop when usage fault exception occurs */
101 while(1)
102 {
103 }
104}
105
111void SVC_Handler(void)
112{
113}
114
120void DebugMon_Handler(void)
121{
122}
123
129void PendSV_Handler(void)
130{
131}
132
138void SysTick_Handler(void)
139{
140}
141
147void DMA1_Channel1_IRQHandler(void)
148{
149 if(dma_flag_get(DMA1_FDT1_FLAG) != RESET)
150 {
151 dma_flag_clear(DMA1_FDT1_FLAG);
152 dma_trans_complete_flag = 1;
153 }
154}
155
161void ADC1_2_3_IRQHandler(void)
162{
163 if(adc_flag_get(ADC1, ADC_OCCO_FLAG) != RESET)
164 {
165 adc_flag_clear(ADC1, ADC_OCCO_FLAG);
166 adc1_overflow_flag++;
167 }
168 if(adc_flag_get(ADC1, ADC_PCCE_FLAG) != RESET)
169 {
170 adc_flag_clear(ADC1, ADC_PCCE_FLAG);
171 if(preempt_conversion_count < 5)
172 {
173 adc1_preempt_valuetab[preempt_conversion_count][0] = adc_preempt_conversion_data_get(ADC1, ADC_PREEMPT_CHANNEL_1);
174 adc1_preempt_valuetab[preempt_conversion_count][1] = adc_preempt_conversion_data_get(ADC1, ADC_PREEMPT_CHANNEL_2);
175 adc1_preempt_valuetab[preempt_conversion_count][2] = adc_preempt_conversion_data_get(ADC1, ADC_PREEMPT_CHANNEL_3);
176 preempt_conversion_count++;
177 }
178 }
179}
180
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f435/examples/adc/conversion_abort/src/main.c:39
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c:98
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c:59
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c:72
adc1_preempt_valuetab
__IO uint16_t adc1_preempt_valuetab[5][3]
Definition: project/at_start_f435/examples/adc/combine_mode_preempt_interltrig_twoslave/src/main.c:38
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c:111
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:40
adc1_ordinary_valuetab
__IO uint16_t adc1_ordinary_valuetab[5][3]
Definition: project/at_start_f435/examples/adc/conversion_abort/src/main.c:38
ADC1_2_3_IRQHandler
void ADC1_2_3_IRQHandler(void)
this function handles adc1_2_3 handler.
Definition: project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c:161
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c:129
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c:50
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1_channel1 handler.
Definition: project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c:147
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c:85
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c:138
preempt_conversion_count
__IO uint16_t preempt_conversion_count
Definition: project/at_start_f435/examples/adc/ordinary_preempt_oversampling/src/main.c:41
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/at32f435_437_int.c:120
adc_preempt_conversion_data_get
uint16_t adc_preempt_conversion_data_get(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral.
Definition: at32f435_437_adc.c:1036
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1106
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
ADC_PREEMPT_CHANNEL_3
@ ADC_PREEMPT_CHANNEL_3
Definition: at32f435_437_adc.h:326
ADC_PREEMPT_CHANNEL_2
@ ADC_PREEMPT_CHANNEL_2
Definition: at32f435_437_adc.h:325
ADC_PREEMPT_CHANNEL_1
@ ADC_PREEMPT_CHANNEL_1
Definition: at32f435_437_adc.h:324
ADC_PCCE_FLAG
#define ADC_PCCE_FLAG
Definition: at32f435_437_adc.h:69
ADC_OCCO_FLAG
#define ADC_OCCO_FLAG
Definition: at32f435_437_adc.h:72
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f435_437_dma.h:66
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • adc
  • tmr_trigger_automatic_preempted
  • src
Functions | Variables
project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | tmr1_config (void)
tmr1 configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [5][3] = {0}
__IO uint16_t | adc1_preempt_valuetab [5][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint16_t | preempt_conversion_count = 0
__IO uint32_t | adc1_overflow_flag = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • adc
  • tmr_trigger_automatic_preempted
  • src
project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38__IO uint16_t adc1_ordinary_valuetab[5][3] = {0};
39__IO uint16_t adc1_preempt_valuetab[5][3] = {0};
40__IO uint16_t dma_trans_complete_flag = 0;
41__IO uint16_t preempt_conversion_count = 0;
42__IO uint32_t adc1_overflow_flag = 0;
43
44static void gpio_config(void);
45static void tmr1_config(void);
46static void dma_config(void);
47static void adc_config(void);
48
54static void gpio_config(void)
55{
56 gpio_init_type gpio_initstructure;
57 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
58 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
59
60 gpio_default_para_init(&gpio_initstructure);
61
62 /* config adc pin as analog input mode */
63 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
64 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6 | GPIO_PINS_7;
65 gpio_init(GPIOA, &gpio_initstructure);
66
67 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
68 gpio_initstructure.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
69 gpio_init(GPIOB, &gpio_initstructure);
70}
71
77static void dma_config(void)
78{
79 dma_init_type dma_init_struct;
80 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
81 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
82
83 dma_reset(DMA1_CHANNEL1);
84 dma_default_para_init(&dma_init_struct);
85 dma_init_struct.buffer_size = 15;
86 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
87 dma_init_struct.memory_base_addr = (uint32_t)adc1_ordinary_valuetab;
88 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
89 dma_init_struct.memory_inc_enable = TRUE;
90 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
91 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
92 dma_init_struct.peripheral_inc_enable = FALSE;
93 dma_init_struct.priority = DMA_PRIORITY_HIGH;
94 dma_init_struct.loop_mode_enable = FALSE;
95 dma_init(DMA1_CHANNEL1, &dma_init_struct);
96
97 dmamux_enable(DMA1, TRUE);
98 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_ADC1);
99
100 /* enable dma transfer complete interrupt */
101 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
102 dma_channel_enable(DMA1_CHANNEL1, TRUE);
103}
104
110static void tmr1_config(void)
111{
112 gpio_init_type gpio_initstructure;
113 tmr_output_config_type tmr_oc_init_structure;
114 crm_clocks_freq_type crm_clocks_freq_struct = {0};
115 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
116
117 gpio_default_para_init(&gpio_initstructure);
118 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
119 gpio_initstructure.gpio_pins = GPIO_PINS_8;
120 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
121 gpio_initstructure.gpio_pull = GPIO_PULL_NONE;
122 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
123 gpio_init(GPIOA, &gpio_initstructure);
124 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE8, GPIO_MUX_1);
125
126 /* get system clock */
127 crm_clocks_freq_get(&crm_clocks_freq_struct);
128
129 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
130
131 /* (systemclock/(systemclock/10000))/1000 = 10Hz(100ms) */
132 tmr_base_init(TMR1, 999, (crm_clocks_freq_struct.sclk_freq/10000 - 1));
133 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
134 tmr_clock_source_div_set(TMR1, TMR_CLOCK_DIV1);
135
136 tmr_output_default_para_init(&tmr_oc_init_structure);
137 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
138 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
139 tmr_oc_init_structure.oc_output_state = TRUE;
140 tmr_oc_init_structure.oc_idle_state = FALSE;
141 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
142 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, 500);
143 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1, TRUE);
144 tmr_output_enable(TMR1, TRUE);
145}
146
152static void adc_config(void)
153{
154 adc_common_config_type adc_common_struct;
155 adc_base_config_type adc_base_struct;
156 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
157 nvic_irq_enable(ADC1_2_3_IRQn, 0, 0);
158
159 adc_common_default_para_init(&adc_common_struct);
160
161 /* config combine mode */
162 adc_common_struct.combine_mode = ADC_INDEPENDENT_MODE;
163
164 /* config division,adcclk is division by hclk */
165 adc_common_struct.div = ADC_HCLK_DIV_4;
166
167 /* config common dma mode,it's not useful in independent mode */
168 adc_common_struct.common_dma_mode = ADC_COMMON_DMAMODE_DISABLE;
169
170 /* config common dma request repeat */
171 adc_common_struct.common_dma_request_repeat_state = FALSE;
172
173 /* config adjacent adc sampling interval,it's useful for ordinary shifting mode */
174 adc_common_struct.sampling_interval = ADC_SAMPLING_INTERVAL_5CYCLES;
175
176 /* config inner temperature sensor and vintrv */
177 adc_common_struct.tempervintrv_state = FALSE;
178
179 /* config voltage battery */
180 adc_common_struct.vbat_state = FALSE;
181 adc_common_config(&adc_common_struct);
182
183 adc_base_default_para_init(&adc_base_struct);
184
185 adc_base_struct.sequence_mode = TRUE;
186 adc_base_struct.repeat_mode = FALSE;
187 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
188 adc_base_struct.ordinary_channel_length = 3;
189 adc_base_config(ADC1, &adc_base_struct);
190 adc_resolution_set(ADC1, ADC_RESOLUTION_12B);
191
192 /* config ordinary channel */
193 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_47_5);
194 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_47_5);
195 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_47_5);
196
197 /* config ordinary trigger source and trigger edge */
198 adc_ordinary_conversion_trigger_set(ADC1, ADC_ORDINARY_TRIG_TMR1CH1, ADC_ORDINARY_TRIG_EDGE_RISING);
199
200 /* config dma mode,it's not useful when common dma mode is use */
201 adc_dma_mode_enable(ADC1, TRUE);
202
203 /* config dma request repeat,it's not useful when common dma mode is use */
204 adc_dma_request_repeat_enable(ADC1, FALSE);
205
206 /* config preempt channel */
207 adc_preempt_channel_length_set(ADC1, 3);
208 adc_preempt_channel_set(ADC1, ADC_CHANNEL_7, 1, ADC_SAMPLETIME_47_5);
209 adc_preempt_channel_set(ADC1, ADC_CHANNEL_8, 2, ADC_SAMPLETIME_47_5);
210 adc_preempt_channel_set(ADC1, ADC_CHANNEL_9, 3, ADC_SAMPLETIME_47_5);
211
212 /* config preempt trigger source and trigger edge */
213 adc_preempt_conversion_trigger_set(ADC1, ADC_PREEMPT_TRIG_TMR1CH4, ADC_PREEMPT_TRIG_EDGE_NONE);
214
215 /* preempt group automatic conversion after ordinary group */
216 adc_preempt_auto_mode_enable(ADC1, TRUE);
217
218 /* enable adc overflow interrupt */
219 adc_interrupt_enable(ADC1, ADC_OCCO_INT, TRUE);
220
221 /* enable adc preempt channels conversion end interrupt */
222 adc_interrupt_enable(ADC1, ADC_PCCE_INT, TRUE);
223
224 /* adc enable */
225 adc_enable(ADC1, TRUE);
226 while(adc_flag_get(ADC1, ADC_RDY_FLAG) == RESET);
227
228 /* adc calibration */
229 adc_calibration_init(ADC1);
230 while(adc_calibration_init_status_get(ADC1));
231 adc_calibration_start(ADC1);
232 while(adc_calibration_status_get(ADC1));
233}
234
240int main(void)
241{
242 __IO uint32_t index = 0;
243 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
244
245 /* config the system clock */
246 system_clock_config();
247
248 /* init at start board */
249 at32_board_init();
250 at32_led_off(LED2);
251 at32_led_off(LED3);
252 at32_led_off(LED4);
253 uart_print_init(115200);
254 gpio_config();
255 tmr1_config();
256 dma_config();
257 adc_config();
258 printf("tmr_trigger_automatic_preempt \r\n");
259 tmr_counter_enable(TMR1, TRUE);
260 while(preempt_conversion_count < 5);
261 while(dma_trans_complete_flag == 0);
262 tmr_counter_enable(TMR1, FALSE);
263 if(adc1_overflow_flag != 0)
264 {
265 /* printf flag when error occur */
266 at32_led_on(LED3);
267 at32_led_on(LED4);
268 printf("error occur\r\n");
269 printf("adc1_overflow_flag = %d\r\n",adc1_overflow_flag);
270 }
271 else
272 {
273 /* printf data when conversion end without error */
274 printf("conversion end without error\r\n");
275 for(index = 0; index < 5; index++)
276 {
277 printf("adc1_ordinary_valuetab[%d][0] = 0x%x\r\n", index, adc1_ordinary_valuetab[index][0]);
278 printf("adc1_ordinary_valuetab[%d][1] = 0x%x\r\n", index, adc1_ordinary_valuetab[index][1]);
279 printf("adc1_ordinary_valuetab[%d][2] = 0x%x\r\n", index, adc1_ordinary_valuetab[index][2]);
280 printf("adc1_preempt_valuetab[%d][0] = 0x%x\r\n", index, adc1_preempt_valuetab[index][0]);
281 printf("adc1_preempt_valuetab[%d][1] = 0x%x\r\n", index, adc1_preempt_valuetab[index][1]);
282 printf("adc1_preempt_valuetab[%d][2] = 0x%x\r\n", index, adc1_preempt_valuetab[index][2]);
283 printf("\r\n");
284 }
285 }
286 at32_led_on(LED2);
287 while(1)
288 {
289 }
290}
291
at32f435_437_board.h
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c:40
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c:77
adc1_preempt_valuetab
__IO uint16_t adc1_preempt_valuetab[5][3]
Definition: project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c:39
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c:42
adc1_ordinary_valuetab
__IO uint16_t adc1_ordinary_valuetab[5][3]
Definition: project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c:38
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c:152
main
int main(void)
main function.
Definition: project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c:240
tmr1_config
static void tmr1_config(void)
tmr1 configuration.
Definition: project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c:110
preempt_conversion_count
__IO uint16_t preempt_conversion_count
Definition: project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c:41
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/adc/tmr_trigger_automatic_preempted/src/main.c:54
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:40
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc ...
Definition: at32f435_437_adc.c:742
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f435_437_adc.c:110
adc_preempt_auto_mode_enable
void adc_preempt_auto_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable automatic preempt group conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:886
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f435_437_adc.c:64
adc_preempt_conversion_trigger_set
void adc_preempt_conversion_trigger_set(adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, adc_preempt_trig_edge_type adc_preempt_trig_edge)
enable or disable the preempt channel's external trigger and set external trigger event of the specif...
Definition: at32f435_437_adc.c:781
adc_common_config
void adc_common_config(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:203
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f435_437_adc.c:294
adc_resolution_set
void adc_resolution_set(adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral.
Definition: at32f435_437_adc.c:235
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f435_437_adc.c:84
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f435_437_adc.c:359
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f435_437_adc.c:371
adc_dma_request_repeat_enable
void adc_dma_request_repeat_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat.
Definition: at32f435_437_adc.c:274
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f435_437_adc.c:328
adc_preempt_channel_set
void adc_preempt_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc ...
Definition: at32f435_437_adc.c:633
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f435_437_adc.c:340
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f435_437_adc.c:260
adc_preempt_channel_length_set
void adc_preempt_channel_length_set(adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral.
Definition: at32f435_437_adc.c:601
adc_common_default_para_init
void adc_common_default_para_init(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:155
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f435_437_adc.c:472
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f435_437_adc.h:178
ADC_CHANNEL_9
@ ADC_CHANNEL_9
Definition: at32f435_437_adc.h:196
ADC_CHANNEL_8
@ ADC_CHANNEL_8
Definition: at32f435_437_adc.h:195
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f435_437_adc.h:191
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f435_437_adc.h:193
ADC_CHANNEL_7
@ ADC_CHANNEL_7
Definition: at32f435_437_adc.h:194
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f435_437_adc.h:192
ADC_SAMPLETIME_47_5
@ ADC_SAMPLETIME_47_5
Definition: at32f435_437_adc.h:217
ADC_SAMPLING_INTERVAL_5CYCLES
@ ADC_SAMPLING_INTERVAL_5CYCLES
Definition: at32f435_437_adc.h:144
ADC_COMMON_DMAMODE_DISABLE
@ ADC_COMMON_DMAMODE_DISABLE
Definition: at32f435_437_adc.h:131
ADC_PREEMPT_TRIG_TMR1CH4
@ ADC_PREEMPT_TRIG_TMR1CH4
Definition: at32f435_437_adc.h:276
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f435_437_adc.h:111
ADC_ORDINARY_TRIG_TMR1CH1
@ ADC_ORDINARY_TRIG_TMR1CH1
Definition: at32f435_437_adc.h:228
ADC_PREEMPT_TRIG_EDGE_NONE
@ ADC_PREEMPT_TRIG_EDGE_NONE
Definition: at32f435_437_adc.h:313
ADC_ORDINARY_TRIG_EDGE_RISING
@ ADC_ORDINARY_TRIG_EDGE_RISING
Definition: at32f435_437_adc.h:266
ADC_RESOLUTION_12B
@ ADC_RESOLUTION_12B
Definition: at32f435_437_adc.h:167
ADC_HCLK_DIV_4
@ ADC_HCLK_DIV_4
Definition: at32f435_437_adc.h:90
ADC_RDY_FLAG
#define ADC_RDY_FLAG
Definition: at32f435_437_adc.h:73
ADC_PCCE_INT
#define ADC_PCCE_INT
Definition: at32f435_437_adc.h:55
ADC_OCCO_INT
#define ADC_OCCO_INT
Definition: at32f435_437_adc.h:56
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:158
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:154
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_ADC1
@ DMAMUX_DMAREQ_ID_ADC1
Definition: at32f435_437_dma.h:197
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f435_437_gpio.h:85
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_1
@ GPIO_MUX_1
Definition: at32f435_437_gpio.h:157
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f435_437_tmr.c:1499
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_enable
void tmr_channel_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable
Definition: at32f435_437_tmr.c:940
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f435_437_tmr.h:97
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f435_437_tmr.h:180
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f435_437_tmr.h:199
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f435_437.h:204
ADC1_2_3_IRQn
@ ADC1_2_3_IRQn
Definition: at32f435_437.h:166
adc_base_config_type
adc base config type
Definition: at32f435_437_adc.h:402
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f435_437_adc.h:405
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f435_437_adc.h:404
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f435_437_adc.h:403
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f435_437_adc.h:406
adc_common_config_type
adc common config type
Definition: at32f435_437_adc.h:388
adc_common_config_type::sampling_interval
adc_sampling_interval_type sampling_interval
Definition: at32f435_437_adc.h:393
adc_common_config_type::tempervintrv_state
confirm_state tempervintrv_state
Definition: at32f435_437_adc.h:394
adc_common_config_type::div
adc_div_type div
Definition: at32f435_437_adc.h:390
adc_common_config_type::common_dma_mode
adc_common_dma_mode_type common_dma_mode
Definition: at32f435_437_adc.h:391
adc_common_config_type::common_dma_request_repeat_state
confirm_state common_dma_request_repeat_state
Definition: at32f435_437_adc.h:392
adc_common_config_type::combine_mode
adc_combine_mode_type combine_mode
Definition: at32f435_437_adc.h:389
adc_common_config_type::vbat_state
confirm_state vbat_state
Definition: at32f435_437_adc.h:395
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f435_437_crm.h:789
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • adc
  • use_polling_get_conversion_data
  • inc
project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • adc
  • use_polling_get_conversion_data
  • inc
project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • adc
  • use_polling_get_conversion_data
  • inc
project/at_start_f435/examples/adc/use_polling_get_conversion_data/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • adc
  • use_polling_get_conversion_data
  • src
Functions
project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 49 of file project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • adc
  • use_polling_get_conversion_data
  • src
project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_clock.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • adc
  • use_polling_get_conversion_data
  • src
Functions | Variables
project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...

Variables

__IO uint32_t adc1_overflow_flag

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • adc
  • use_polling_get_conversion_data
  • src
project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
39extern __IO uint32_t adc1_overflow_flag;
40
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
143void ADC1_2_3_IRQHandler(void)
144{
145 if(adc_flag_get(ADC1, ADC_OCCO_FLAG) != RESET)
146 {
147 adc_flag_clear(ADC1, ADC_OCCO_FLAG);
148 adc1_overflow_flag++;
149 }
150}
151
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c:107
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:40
ADC1_2_3_IRQHandler
void ADC1_2_3_IRQHandler(void)
this function handles adc1_2_3 handler.
Definition: project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c:143
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c:46
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c:81
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c:134
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/at32f435_437_int.c:116
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1106
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
ADC_OCCO_FLAG
#define ADC_OCCO_FLAG
Definition: at32f435_437_adc.h:72
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • adc
  • use_polling_get_conversion_data
  • src
Functions | Variables
project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [3] = {0}
__IO uint16_t * | p_adc1_ordinary = adc1_ordinary_valuetab
__IO uint32_t | adc1_overflow_flag = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • adc
  • use_polling_get_conversion_data
  • src
project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38__IO uint16_t adc1_ordinary_valuetab[3] = {0};
39__IO uint16_t *p_adc1_ordinary = adc1_ordinary_valuetab;
40__IO uint32_t adc1_overflow_flag = 0;
41
42static void gpio_config(void);
43static void adc_config(void);
44
50static void gpio_config(void)
51{
52 gpio_init_type gpio_initstructure;
53 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
54
55 gpio_default_para_init(&gpio_initstructure);
56
57 /* config adc pin as analog input mode */
58 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
59 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6;
60 gpio_init(GPIOA, &gpio_initstructure);
61}
62
68static void adc_config(void)
69{
70 adc_common_config_type adc_common_struct;
71 adc_base_config_type adc_base_struct;
72 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
73 nvic_irq_enable(ADC1_2_3_IRQn, 0, 0);
74
75 adc_common_default_para_init(&adc_common_struct);
76
77 /* config combine mode */
78 adc_common_struct.combine_mode = ADC_INDEPENDENT_MODE;
79
80 /* config division,adcclk is division by hclk */
81 adc_common_struct.div = ADC_HCLK_DIV_4;
82
83 /* config common dma mode,it's not useful in independent mode */
84 adc_common_struct.common_dma_mode = ADC_COMMON_DMAMODE_DISABLE;
85
86 /* config common dma request repeat */
87 adc_common_struct.common_dma_request_repeat_state = FALSE;
88
89 /* config adjacent adc sampling interval,it's useful for ordinary shifting mode */
90 adc_common_struct.sampling_interval = ADC_SAMPLING_INTERVAL_5CYCLES;
91
92 /* config inner temperature sensor and vintrv */
93 adc_common_struct.tempervintrv_state = FALSE;
94
95 /* config voltage battery */
96 adc_common_struct.vbat_state = FALSE;
97 adc_common_config(&adc_common_struct);
98
99 adc_base_default_para_init(&adc_base_struct);
100
101 adc_base_struct.sequence_mode = TRUE;
102 adc_base_struct.repeat_mode = FALSE;
103 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
104 adc_base_struct.ordinary_channel_length = 3;
105 adc_base_config(ADC1, &adc_base_struct);
106 adc_resolution_set(ADC1, ADC_RESOLUTION_12B);
107
108 /* config ordinary channel */
109 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_640_5);
110 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_640_5);
111 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_640_5);
112
113 /* config ordinary trigger source and trigger edge */
114 adc_ordinary_conversion_trigger_set(ADC1, ADC_ORDINARY_TRIG_TMR1CH1, ADC_ORDINARY_TRIG_EDGE_NONE);
115
116 /* config dma mode,it's not useful when common dma mode is use */
117 adc_dma_mode_enable(ADC1, FALSE);
118
119 /* config dma request repeat,it's not useful when common dma mode is use */
120 adc_dma_request_repeat_enable(ADC1, FALSE);
121
122 /* each ordinary channel conversion set occe flag */
123 adc_occe_each_conversion_enable(ADC1, TRUE);
124
125 /* enable adc overflow interrupt */
126 adc_interrupt_enable(ADC1, ADC_OCCO_INT, TRUE);
127
128 /* adc enable */
129 adc_enable(ADC1, TRUE);
130 while(adc_flag_get(ADC1, ADC_RDY_FLAG) == RESET);
131
132 /* adc calibration */
133 adc_calibration_init(ADC1);
134 while(adc_calibration_init_status_get(ADC1));
135 adc_calibration_start(ADC1);
136 while(adc_calibration_status_get(ADC1));
137}
138
144int main(void)
145{
146 __IO uint32_t index = 0;
147 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
148
149 /* config the system clock */
150 system_clock_config();
151
152 /* init at start board */
153 at32_board_init();
154 at32_led_off(LED2);
155 at32_led_off(LED3);
156 at32_led_off(LED4);
157 p_adc1_ordinary = adc1_ordinary_valuetab;
158 uart_print_init(115200);
159 gpio_config();
160 adc_config();
161 printf("use_polling_get_conversion_data \r\n");
162 adc_ordinary_software_trigger_enable(ADC1, TRUE);
163 while(1)
164 {
165 while(adc_flag_get(ADC1, ADC_OCCE_FLAG) == RESET);
166 *(p_adc1_ordinary++) = adc_ordinary_conversion_data_get(ADC1);
167 index++;
168 if(adc1_overflow_flag != 0)
169 {
170 /* printf flag when error occur */
171 at32_led_on(LED3);
172 at32_led_on(LED4);
173 printf("error occur\r\n");
174 printf("adc1_overflow_flag = %d\r\n",adc1_overflow_flag);
175 while(1);
176 }
177 if(index%3 == 0)
178 {
179 printf("conversion end without error\r\n");
180 printf("adc1_ordinary_valuetab[0] = 0x%x\r\n", adc1_ordinary_valuetab[0]);
181 printf("adc1_ordinary_valuetab[1] = 0x%x\r\n", adc1_ordinary_valuetab[1]);
182 printf("adc1_ordinary_valuetab[2] = 0x%x\r\n", adc1_ordinary_valuetab[2]);
183 printf("\r\n");
184 delay_sec(1);
185 p_adc1_ordinary = adc1_ordinary_valuetab;
186 adc_ordinary_software_trigger_enable(ADC1, TRUE);
187 }
188 }
189}
190
at32f435_437_board.h
p_adc1_ordinary
__IO uint16_t * p_adc1_ordinary
Definition: project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c:39
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c:40
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c:68
main
int main(void)
main function.
Definition: project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c:144
adc1_ordinary_valuetab
__IO uint16_t adc1_ordinary_valuetab[3]
Definition: project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c:38
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/adc/use_polling_get_conversion_data/src/main.c:50
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:945
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc ...
Definition: at32f435_437_adc.c:742
adc_ordinary_conversion_data_get
uint16_t adc_ordinary_conversion_data_get(adc_type *adc_x)
return the last conversion data for ordinary channel of the specified adc peripheral.
Definition: at32f435_437_adc.c:1009
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f435_437_adc.c:110
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f435_437_adc.c:64
adc_common_config
void adc_common_config(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:203
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f435_437_adc.c:294
adc_resolution_set
void adc_resolution_set(adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral.
Definition: at32f435_437_adc.c:235
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f435_437_adc.c:84
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f435_437_adc.c:359
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f435_437_adc.c:371
adc_dma_request_repeat_enable
void adc_dma_request_repeat_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat.
Definition: at32f435_437_adc.c:274
adc_occe_each_conversion_enable
void adc_occe_each_conversion_enable(adc_type *adc_x, confirm_state new_state)
enable or disable each ordinary channel conversion set occe flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:931
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f435_437_adc.c:328
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f435_437_adc.c:340
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f435_437_adc.c:260
adc_common_default_para_init
void adc_common_default_para_init(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:155
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f435_437_adc.c:472
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f435_437_adc.h:178
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f435_437_adc.h:191
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f435_437_adc.h:193
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f435_437_adc.h:192
ADC_SAMPLETIME_640_5
@ ADC_SAMPLETIME_640_5
Definition: at32f435_437_adc.h:220
ADC_SAMPLING_INTERVAL_5CYCLES
@ ADC_SAMPLING_INTERVAL_5CYCLES
Definition: at32f435_437_adc.h:144
ADC_COMMON_DMAMODE_DISABLE
@ ADC_COMMON_DMAMODE_DISABLE
Definition: at32f435_437_adc.h:131
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f435_437_adc.h:111
ADC_ORDINARY_TRIG_TMR1CH1
@ ADC_ORDINARY_TRIG_TMR1CH1
Definition: at32f435_437_adc.h:228
ADC_ORDINARY_TRIG_EDGE_NONE
@ ADC_ORDINARY_TRIG_EDGE_NONE
Definition: at32f435_437_adc.h:265
ADC_RESOLUTION_12B
@ ADC_RESOLUTION_12B
Definition: at32f435_437_adc.h:167
ADC_HCLK_DIV_4
@ ADC_HCLK_DIV_4
Definition: at32f435_437_adc.h:90
ADC_OCCE_FLAG
#define ADC_OCCE_FLAG
Definition: at32f435_437_adc.h:68
ADC_RDY_FLAG
#define ADC_RDY_FLAG
Definition: at32f435_437_adc.h:73
ADC_OCCO_INT
#define ADC_OCCO_INT
Definition: at32f435_437_adc.h:56
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:158
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f435_437_gpio.h:85
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
ADC1_2_3_IRQn
@ ADC1_2_3_IRQn
Definition: at32f435_437.h:166
adc_base_config_type
adc base config type
Definition: at32f435_437_adc.h:402
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f435_437_adc.h:405
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f435_437_adc.h:404
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f435_437_adc.h:403
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f435_437_adc.h:406
adc_common_config_type
adc common config type
Definition: at32f435_437_adc.h:388
adc_common_config_type::sampling_interval
adc_sampling_interval_type sampling_interval
Definition: at32f435_437_adc.h:393
adc_common_config_type::tempervintrv_state
confirm_state tempervintrv_state
Definition: at32f435_437_adc.h:394
adc_common_config_type::div
adc_div_type div
Definition: at32f435_437_adc.h:390
adc_common_config_type::common_dma_mode
adc_common_dma_mode_type common_dma_mode
Definition: at32f435_437_adc.h:391
adc_common_config_type::common_dma_request_repeat_state
confirm_state common_dma_request_repeat_state
Definition: at32f435_437_adc.h:392
adc_common_config_type::combine_mode
adc_combine_mode_type combine_mode
Definition: at32f435_437_adc.h:389
adc_common_config_type::vbat_state
confirm_state vbat_state
Definition: at32f435_437_adc.h:395
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • adc
  • vbat_monitor
  • inc
project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • adc
  • vbat_monitor
  • inc
project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • adc
  • vbat_monitor
  • inc
project/at_start_f435/examples/adc/vbat_monitor/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • adc
  • vbat_monitor
  • src
Functions
project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 49 of file project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • adc
  • vbat_monitor
  • src
project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_clock.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • adc
  • vbat_monitor
  • src
Functions | Variables
project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...

Variables

__IO uint32_t adc1_overflow_flag

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • adc
  • vbat_monitor
  • src
project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
39extern __IO uint32_t adc1_overflow_flag;
40
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
143void ADC1_2_3_IRQHandler(void)
144{
145 if(adc_flag_get(ADC1, ADC_OCCO_FLAG) != RESET)
146 {
147 adc_flag_clear(ADC1, ADC_OCCO_FLAG);
148 adc1_overflow_flag++;
149 }
150}
151
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c:107
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:40
ADC1_2_3_IRQHandler
void ADC1_2_3_IRQHandler(void)
this function handles adc1_2_3 handler.
Definition: project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c:143
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c:46
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c:81
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c:134
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/adc/vbat_monitor/src/at32f435_437_int.c:116
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1106
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
ADC_OCCO_FLAG
#define ADC_OCCO_FLAG
Definition: at32f435_437_adc.h:72
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • adc
  • vbat_monitor
  • src
Functions | Variables
project/at_start_f435/examples/adc/vbat_monitor/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_value = 0
__IO uint32_t | adc1_overflow_flag = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/vbat_monitor/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • adc
  • vbat_monitor
  • src
project/at_start_f435/examples/adc/vbat_monitor/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38__IO uint16_t adc1_ordinary_value = 0;
39__IO uint32_t adc1_overflow_flag = 0;
40
41static void dma_config(void);
42static void adc_config(void);
43
49static void dma_config(void)
50{
51 dma_init_type dma_init_struct;
52 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
53 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
54
55 dma_reset(DMA1_CHANNEL1);
56 dma_default_para_init(&dma_init_struct);
57 dma_init_struct.buffer_size = 1;
58 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
59 dma_init_struct.memory_base_addr = (uint32_t)&adc1_ordinary_value;
60 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
61 dma_init_struct.memory_inc_enable = FALSE;
62 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
63 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
64 dma_init_struct.peripheral_inc_enable = FALSE;
65 dma_init_struct.priority = DMA_PRIORITY_HIGH;
66 dma_init_struct.loop_mode_enable = TRUE;
67 dma_init(DMA1_CHANNEL1, &dma_init_struct);
68
69 dmamux_enable(DMA1, TRUE);
70 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_ADC1);
71
72 /* disable dma transfer complete interrupt */
73 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, FALSE);
74 dma_channel_enable(DMA1_CHANNEL1, TRUE);
75}
76
82static void adc_config(void)
83{
84 adc_common_config_type adc_common_struct;
85 adc_base_config_type adc_base_struct;
86 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
87 nvic_irq_enable(ADC1_2_3_IRQn, 0, 0);
88
89 adc_common_default_para_init(&adc_common_struct);
90
91 /* config combine mode */
92 adc_common_struct.combine_mode = ADC_INDEPENDENT_MODE;
93
94 /* config division,adcclk is division by hclk */
95 adc_common_struct.div = ADC_HCLK_DIV_4;
96
97 /* config common dma mode,it's not useful in independent mode */
98 adc_common_struct.common_dma_mode = ADC_COMMON_DMAMODE_DISABLE;
99
100 /* config common dma request repeat */
101 adc_common_struct.common_dma_request_repeat_state = FALSE;
102
103 /* config adjacent adc sampling interval,it's useful for ordinary shifting mode */
104 adc_common_struct.sampling_interval = ADC_SAMPLING_INTERVAL_5CYCLES;
105
106 /* config inner temperature sensor and vintrv */
107 adc_common_struct.tempervintrv_state = FALSE;
108
109 /* config voltage battery */
110 adc_common_struct.vbat_state = TRUE;
111 adc_common_config(&adc_common_struct);
112
113 adc_base_default_para_init(&adc_base_struct);
114
115 adc_base_struct.sequence_mode = FALSE;
116 adc_base_struct.repeat_mode = FALSE;
117 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
118 adc_base_struct.ordinary_channel_length = 1;
119 adc_base_config(ADC1, &adc_base_struct);
120 adc_resolution_set(ADC1, ADC_RESOLUTION_12B);
121
122 /* config ordinary channel */
123 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_18, 1, ADC_SAMPLETIME_47_5);
124
125 /* config ordinary trigger source and trigger edge */
126 adc_ordinary_conversion_trigger_set(ADC1, ADC_ORDINARY_TRIG_TMR1CH1, ADC_ORDINARY_TRIG_EDGE_NONE);
127
128 /* config dma mode,it's not useful when common dma mode is use */
129 adc_dma_mode_enable(ADC1, TRUE);
130
131 /* config dma request repeat,it's not useful when common dma mode is use */
132 adc_dma_request_repeat_enable(ADC1, TRUE);
133
134 /* enable adc overflow interrupt */
135 adc_interrupt_enable(ADC1, ADC_OCCO_INT, TRUE);
136
137 /* adc enable */
138 adc_enable(ADC1, TRUE);
139 while(adc_flag_get(ADC1, ADC_RDY_FLAG) == RESET);
140
141 /* adc calibration */
142 adc_calibration_init(ADC1);
143 while(adc_calibration_init_status_get(ADC1));
144 adc_calibration_start(ADC1);
145 while(adc_calibration_status_get(ADC1));
146}
147
153int main(void)
154{
155 __IO uint32_t index = 0;
156 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
157
158 /* config the system clock */
159 system_clock_config();
160
161 /* init at start board */
162 at32_board_init();
163 at32_led_off(LED2);
164 at32_led_off(LED3);
165 at32_led_off(LED4);
166 uart_print_init(115200);
167 dma_config();
168 adc_config();
169 printf("adc1_vbat_monitor \r\n");
170
171 while(1)
172 {
173 at32_led_toggle(LED2);
174
175 /* adc1 software trigger start conversion */
176 adc_ordinary_software_trigger_enable(ADC1, TRUE);
177
178 while(dma_flag_get(DMA1_FDT1_FLAG) == RESET);
179
180 /* adc voltage battery disable */
181 adc_voltage_battery_enable(FALSE);
182
183 dma_flag_clear(DMA1_FDT1_FLAG);
184 printf("vbat_value = %f V\r\n", ((double)3.3 * 4 * adc1_ordinary_value) / 4095);
185 if(adc1_overflow_flag != 0)
186 {
187 /* printf flag when error occur */
188 at32_led_on(LED3);
189 at32_led_on(LED4);
190 printf("error occur\r\n");
191 printf("adc1_overflow_flag = %d\r\n",adc1_overflow_flag);
192 }
193 delay_sec(1);
194
195 /* adc voltage battery enable */
196 adc_voltage_battery_enable(TRUE);
197 }
198}
199
at32f435_437_board.h
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f435/examples/adc/vbat_monitor/src/main.c:49
adc1_ordinary_value
__IO uint16_t adc1_ordinary_value
Definition: project/at_start_f435/examples/adc/vbat_monitor/src/main.c:38
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/vbat_monitor/src/main.c:39
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f435/examples/adc/vbat_monitor/src/main.c:82
main
int main(void)
main function.
Definition: project/at_start_f435/examples/adc/vbat_monitor/src/main.c:153
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:945
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc ...
Definition: at32f435_437_adc.c:742
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f435_437_adc.c:110
adc_voltage_battery_enable
void adc_voltage_battery_enable(confirm_state new_state)
enable or disable the adc voltage battery.
Definition: at32f435_437_adc.c:246
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f435_437_adc.c:64
adc_common_config
void adc_common_config(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:203
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f435_437_adc.c:294
adc_resolution_set
void adc_resolution_set(adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral.
Definition: at32f435_437_adc.c:235
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f435_437_adc.c:84
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f435_437_adc.c:359
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f435_437_adc.c:371
adc_dma_request_repeat_enable
void adc_dma_request_repeat_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat.
Definition: at32f435_437_adc.c:274
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f435_437_adc.c:328
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f435_437_adc.c:340
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f435_437_adc.c:260
adc_common_default_para_init
void adc_common_default_para_init(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:155
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f435_437_adc.c:472
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f435_437_adc.h:178
ADC_CHANNEL_18
@ ADC_CHANNEL_18
Definition: at32f435_437_adc.h:205
ADC_SAMPLETIME_47_5
@ ADC_SAMPLETIME_47_5
Definition: at32f435_437_adc.h:217
ADC_SAMPLING_INTERVAL_5CYCLES
@ ADC_SAMPLING_INTERVAL_5CYCLES
Definition: at32f435_437_adc.h:144
ADC_COMMON_DMAMODE_DISABLE
@ ADC_COMMON_DMAMODE_DISABLE
Definition: at32f435_437_adc.h:131
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f435_437_adc.h:111
ADC_ORDINARY_TRIG_TMR1CH1
@ ADC_ORDINARY_TRIG_TMR1CH1
Definition: at32f435_437_adc.h:228
ADC_ORDINARY_TRIG_EDGE_NONE
@ ADC_ORDINARY_TRIG_EDGE_NONE
Definition: at32f435_437_adc.h:265
ADC_RESOLUTION_12B
@ ADC_RESOLUTION_12B
Definition: at32f435_437_adc.h:167
ADC_HCLK_DIV_4
@ ADC_HCLK_DIV_4
Definition: at32f435_437_adc.h:90
ADC_RDY_FLAG
#define ADC_RDY_FLAG
Definition: at32f435_437_adc.h:73
ADC_OCCO_INT
#define ADC_OCCO_INT
Definition: at32f435_437_adc.h:56
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:158
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_ADC1
@ DMAMUX_DMAREQ_ID_ADC1
Definition: at32f435_437_dma.h:197
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f435_437_dma.h:66
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f435_437.h:204
ADC1_2_3_IRQn
@ ADC1_2_3_IRQn
Definition: at32f435_437.h:166
adc_base_config_type
adc base config type
Definition: at32f435_437_adc.h:402
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f435_437_adc.h:405
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f435_437_adc.h:404
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f435_437_adc.h:403
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f435_437_adc.h:406
adc_common_config_type
adc common config type
Definition: at32f435_437_adc.h:388
adc_common_config_type::sampling_interval
adc_sampling_interval_type sampling_interval
Definition: at32f435_437_adc.h:393
adc_common_config_type::tempervintrv_state
confirm_state tempervintrv_state
Definition: at32f435_437_adc.h:394
adc_common_config_type::div
adc_div_type div
Definition: at32f435_437_adc.h:390
adc_common_config_type::common_dma_mode
adc_common_dma_mode_type common_dma_mode
Definition: at32f435_437_adc.h:391
adc_common_config_type::common_dma_request_repeat_state
confirm_state common_dma_request_repeat_state
Definition: at32f435_437_adc.h:392
adc_common_config_type::combine_mode
adc_combine_mode_type combine_mode
Definition: at32f435_437_adc.h:389
adc_common_config_type::vbat_state
confirm_state vbat_state
Definition: at32f435_437_adc.h:395
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • adc
  • voltage_monitoring
  • inc
project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • adc
  • voltage_monitoring
  • inc
project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • adc
  • voltage_monitoring
  • inc
project/at_start_f435/examples/adc/voltage_monitoring/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • adc
  • voltage_monitoring
  • src
Functions
project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 49 of file project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • adc
  • voltage_monitoring
  • src
project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_clock.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • adc
  • voltage_monitoring
  • src
Functions | Variables
project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ADC1_2_3_IRQHandler (void)
this function handles adc1_2_3 handler. More...

Variables

__IO uint32_t | vmor_flag_index
__IO uint32_t | adc1_overflow_flag

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • adc
  • voltage_monitoring
  • src
project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
39extern __IO uint32_t vmor_flag_index;
40extern __IO uint32_t adc1_overflow_flag;
41
47void NMI_Handler(void)
48{
49}
50
56void HardFault_Handler(void)
57{
58 /* go to infinite loop when hard fault exception occurs */
59 while(1)
60 {
61 }
62}
63
69void MemManage_Handler(void)
70{
71 /* go to infinite loop when memory manage exception occurs */
72 while(1)
73 {
74 }
75}
76
82void BusFault_Handler(void)
83{
84 /* go to infinite loop when bus fault exception occurs */
85 while(1)
86 {
87 }
88}
89
95void UsageFault_Handler(void)
96{
97 /* go to infinite loop when usage fault exception occurs */
98 while(1)
99 {
100 }
101}
102
108void SVC_Handler(void)
109{
110}
111
117void DebugMon_Handler(void)
118{
119}
120
126void PendSV_Handler(void)
127{
128}
129
135void SysTick_Handler(void)
136{
137}
138
144void ADC1_2_3_IRQHandler(void)
145{
146 if(adc_flag_get(ADC1, ADC_OCCO_FLAG) != RESET)
147 {
148 adc_flag_clear(ADC1, ADC_OCCO_FLAG);
149 adc1_overflow_flag++;
150 }
151 if(adc_flag_get(ADC1, ADC_VMOR_FLAG) != RESET)
152 {
153 adc_flag_clear(ADC1, ADC_VMOR_FLAG);
154 vmor_flag_index++;
155 }
156}
157
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c:95
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c:56
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c:69
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c:108
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/combine_mode_ordinary_shift_twoslave_dma3/src/main.c:40
ADC1_2_3_IRQHandler
void ADC1_2_3_IRQHandler(void)
this function handles adc1_2_3 handler.
Definition: project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c:144
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c:126
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c:47
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c:82
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c:135
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/adc/voltage_monitoring/src/at32f435_437_int.c:117
vmor_flag_index
__IO uint32_t vmor_flag_index
Definition: project/at_start_f435/examples/adc/voltage_monitoring/src/main.c:39
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1106
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
ADC_OCCO_FLAG
#define ADC_OCCO_FLAG
Definition: at32f435_437_adc.h:72
ADC_VMOR_FLAG
#define ADC_VMOR_FLAG
Definition: at32f435_437_adc.h:67
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • adc
  • voltage_monitoring
  • src
Functions | Variables
project/at_start_f435/examples/adc/voltage_monitoring/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [3] = {0}
__IO uint32_t | vmor_flag_index = 0
__IO uint32_t | adc1_overflow_flag = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/adc/voltage_monitoring/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • adc
  • voltage_monitoring
  • src
project/at_start_f435/examples/adc/voltage_monitoring/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38__IO uint16_t adc1_ordinary_valuetab[3] = {0};
39__IO uint32_t vmor_flag_index = 0;
40__IO uint32_t adc1_overflow_flag = 0;
41
42static void gpio_config(void);
43static void dma_config(void);
44static void adc_config(void);
45
51static void gpio_config(void)
52{
53 gpio_init_type gpio_initstructure;
54 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
55
56 gpio_default_para_init(&gpio_initstructure);
57
58 /* config adc pin as analog input mode */
59 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
60 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6;
61 gpio_init(GPIOA, &gpio_initstructure);
62}
63
69static void dma_config(void)
70{
71 dma_init_type dma_init_struct;
72 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
73 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
74
75 dma_reset(DMA1_CHANNEL1);
76 dma_default_para_init(&dma_init_struct);
77 dma_init_struct.buffer_size = 3;
78 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
79 dma_init_struct.memory_base_addr = (uint32_t)adc1_ordinary_valuetab;
80 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
81 dma_init_struct.memory_inc_enable = TRUE;
82 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
83 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
84 dma_init_struct.peripheral_inc_enable = FALSE;
85 dma_init_struct.priority = DMA_PRIORITY_HIGH;
86 dma_init_struct.loop_mode_enable = TRUE;
87 dma_init(DMA1_CHANNEL1, &dma_init_struct);
88
89 dmamux_enable(DMA1, TRUE);
90 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_ADC1);
91
92 /* enable dma transfer complete interrupt */
93 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, FALSE);
94 dma_channel_enable(DMA1_CHANNEL1, TRUE);
95}
96
102static void adc_config(void)
103{
104 adc_common_config_type adc_common_struct;
105 adc_base_config_type adc_base_struct;
106 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
107 nvic_irq_enable(ADC1_2_3_IRQn, 0, 0);
108
109 adc_common_default_para_init(&adc_common_struct);
110
111 /* config combine mode */
112 adc_common_struct.combine_mode = ADC_INDEPENDENT_MODE;
113
114 /* config division,adcclk is division by hclk */
115 adc_common_struct.div = ADC_HCLK_DIV_4;
116
117 /* config common dma mode,it's not useful in independent mode */
118 adc_common_struct.common_dma_mode = ADC_COMMON_DMAMODE_DISABLE;
119
120 /* config common dma request repeat */
121 adc_common_struct.common_dma_request_repeat_state = FALSE;
122
123 /* config adjacent adc sampling interval,it's useful for ordinary shifting mode */
124 adc_common_struct.sampling_interval = ADC_SAMPLING_INTERVAL_5CYCLES;
125
126 /* config inner temperature sensor and vintrv */
127 adc_common_struct.tempervintrv_state = FALSE;
128
129 /* config voltage battery */
130 adc_common_struct.vbat_state = FALSE;
131 adc_common_config(&adc_common_struct);
132
133 adc_base_default_para_init(&adc_base_struct);
134
135 adc_base_struct.sequence_mode = TRUE;
136 adc_base_struct.repeat_mode = FALSE;
137 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
138 adc_base_struct.ordinary_channel_length = 3;
139 adc_base_config(ADC1, &adc_base_struct);
140 adc_resolution_set(ADC1, ADC_RESOLUTION_12B);
141
142 /* config ordinary channel */
143 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_47_5);
144 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_47_5);
145 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_47_5);
146
147 /* config ordinary trigger source and trigger edge */
148 adc_ordinary_conversion_trigger_set(ADC1, ADC_ORDINARY_TRIG_TMR1CH1, ADC_ORDINARY_TRIG_EDGE_NONE);
149
150 /* config dma mode,it's not useful when common dma mode is use */
151 adc_dma_mode_enable(ADC1, TRUE);
152
153 /* config dma request repeat,it's not useful when common dma mode is use */
154 adc_dma_request_repeat_enable(ADC1, TRUE);
155
156 /* config voltage_monitoring */
157 adc_voltage_monitor_threshold_value_set(ADC1, 0x100, 0x000);
158 adc_voltage_monitor_single_channel_select(ADC1, ADC_CHANNEL_5);
159 adc_voltage_monitor_enable(ADC1, ADC_VMONITOR_SINGLE_ORDINARY);
160
161 /* enable adc overflow interrupt */
162 adc_interrupt_enable(ADC1, ADC_OCCO_INT, TRUE);
163
164 /* enable voltage monitoring out of range interrupt */
165 adc_interrupt_enable(ADC1, ADC_VMOR_INT, TRUE);
166
167 /* adc enable */
168 adc_enable(ADC1, TRUE);
169 while(adc_flag_get(ADC1, ADC_RDY_FLAG) == RESET);
170
171 /* adc calibration */
172 adc_calibration_init(ADC1);
173 while(adc_calibration_init_status_get(ADC1));
174 adc_calibration_start(ADC1);
175 while(adc_calibration_status_get(ADC1));
176}
177
183int main(void)
184{
185 __IO uint32_t index = 0;
186 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
187
188 /* config the system clock */
189 system_clock_config();
190
191 /* init at start board */
192 at32_board_init();
193 at32_led_off(LED2);
194 at32_led_off(LED3);
195 at32_led_off(LED4);
196 uart_print_init(115200);
197 gpio_config();
198 dma_config();
199 adc_config();
200 printf("voltage_monitoring \r\n");
201 while(1)
202 {
203 at32_led_toggle(LED2);
204 delay_sec(1);
205 if((adc1_overflow_flag != 0) || (vmor_flag_index != 0))
206 {
207 /* printf flag when error occur */
208 at32_led_on(LED3);
209 at32_led_on(LED4);
210 printf("error occur\r\n");
211 printf("vmor_flag_index = %d\r\n",vmor_flag_index);
212 printf("adc1_overflow_flag = %d\r\n",adc1_overflow_flag);
213 printf("out of range:adc1_channel_5 value is = 0x%x!\r\n", adc1_ordinary_valuetab[1]);
214 }
215 adc_ordinary_software_trigger_enable(ADC1, TRUE);
216 }
217}
218
at32f435_437_board.h
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f435/examples/adc/voltage_monitoring/src/main.c:69
adc1_overflow_flag
__IO uint32_t adc1_overflow_flag
Definition: project/at_start_f435/examples/adc/voltage_monitoring/src/main.c:40
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f435/examples/adc/voltage_monitoring/src/main.c:102
main
int main(void)
main function.
Definition: project/at_start_f435/examples/adc/voltage_monitoring/src/main.c:183
adc1_ordinary_valuetab
__IO uint16_t adc1_ordinary_valuetab[3]
Definition: project/at_start_f435/examples/adc/voltage_monitoring/src/main.c:38
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/adc/voltage_monitoring/src/main.c:51
vmor_flag_index
__IO uint32_t vmor_flag_index
Definition: project/at_start_f435/examples/adc/voltage_monitoring/src/main.c:39
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f435_437_adc.c:945
adc_voltage_monitor_enable
void adc_voltage_monitor_enable(adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring)
enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified ...
Definition: at32f435_437_adc.c:399
adc_voltage_monitor_single_channel_select
void adc_voltage_monitor_single_channel_select(adc_type *adc_x, adc_channel_select_type adc_channel)
select the voltage monitoring's channel of the specified adc peripheral.
Definition: at32f435_437_adc.c:440
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, adc_ordinary_trig_edge_type adc_ordinary_trig_edge)
set the ordinary channel's external trigger edge and set external trigger event of the specified adc ...
Definition: at32f435_437_adc.c:742
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f435_437_adc.c:110
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f435_437_adc.c:64
adc_common_config
void adc_common_config(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:203
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f435_437_adc.c:294
adc_resolution_set
void adc_resolution_set(adc_type *adc_x, adc_resolution_type resolution)
set resolution of the specified adc peripheral.
Definition: at32f435_437_adc.c:235
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f435_437_adc.c:84
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f435_437_adc.c:359
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f435_437_adc.c:371
adc_dma_request_repeat_enable
void adc_dma_request_repeat_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma request repeat.
Definition: at32f435_437_adc.c:274
adc_voltage_monitor_threshold_value_set
void adc_voltage_monitor_threshold_value_set(adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold)
set voltage monitoring's high and low thresholds value of the specified adc peripheral.
Definition: at32f435_437_adc.c:420
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f435_437_adc.c:1075
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f435_437_adc.c:328
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f435_437_adc.c:340
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f435_437_adc.c:260
adc_common_default_para_init
void adc_common_default_para_init(adc_common_config_type *adc_common_struct)
adc common default para init.
Definition: at32f435_437_adc.c:155
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f435_437_adc.c:472
ADC_VMONITOR_SINGLE_ORDINARY
@ ADC_VMONITOR_SINGLE_ORDINARY
Definition: at32f435_437_adc.h:335
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f435_437_adc.h:178
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f435_437_adc.h:191
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f435_437_adc.h:193
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f435_437_adc.h:192
ADC_SAMPLETIME_47_5
@ ADC_SAMPLETIME_47_5
Definition: at32f435_437_adc.h:217
ADC_SAMPLING_INTERVAL_5CYCLES
@ ADC_SAMPLING_INTERVAL_5CYCLES
Definition: at32f435_437_adc.h:144
ADC_COMMON_DMAMODE_DISABLE
@ ADC_COMMON_DMAMODE_DISABLE
Definition: at32f435_437_adc.h:131
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f435_437_adc.h:111
ADC_ORDINARY_TRIG_TMR1CH1
@ ADC_ORDINARY_TRIG_TMR1CH1
Definition: at32f435_437_adc.h:228
ADC_ORDINARY_TRIG_EDGE_NONE
@ ADC_ORDINARY_TRIG_EDGE_NONE
Definition: at32f435_437_adc.h:265
ADC_RESOLUTION_12B
@ ADC_RESOLUTION_12B
Definition: at32f435_437_adc.h:167
ADC_HCLK_DIV_4
@ ADC_HCLK_DIV_4
Definition: at32f435_437_adc.h:90
ADC_RDY_FLAG
#define ADC_RDY_FLAG
Definition: at32f435_437_adc.h:73
ADC_OCCO_INT
#define ADC_OCCO_INT
Definition: at32f435_437_adc.h:56
ADC_VMOR_INT
#define ADC_VMOR_INT
Definition: at32f435_437_adc.h:54
ADC1
#define ADC1
Definition: at32f435_437_adc.h:866
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:158
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_ADC1
@ DMAMUX_DMAREQ_ID_ADC1
Definition: at32f435_437_dma.h:197
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f435_437_gpio.h:85
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f435_437.h:204
ADC1_2_3_IRQn
@ ADC1_2_3_IRQn
Definition: at32f435_437.h:166
adc_base_config_type
adc base config type
Definition: at32f435_437_adc.h:402
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f435_437_adc.h:405
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f435_437_adc.h:404
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f435_437_adc.h:403
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f435_437_adc.h:406
adc_common_config_type
adc common config type
Definition: at32f435_437_adc.h:388
adc_common_config_type::sampling_interval
adc_sampling_interval_type sampling_interval
Definition: at32f435_437_adc.h:393
adc_common_config_type::tempervintrv_state
confirm_state tempervintrv_state
Definition: at32f435_437_adc.h:394
adc_common_config_type::div
adc_div_type div
Definition: at32f435_437_adc.h:390
adc_common_config_type::common_dma_mode
adc_common_dma_mode_type common_dma_mode
Definition: at32f435_437_adc.h:391
adc_common_config_type::common_dma_request_repeat_state
confirm_state common_dma_request_repeat_state
Definition: at32f435_437_adc.h:392
adc_common_config_type::combine_mode
adc_combine_mode_type combine_mode
Definition: at32f435_437_adc.h:389
adc_common_config_type::vbat_state
confirm_state vbat_state
Definition: at32f435_437_adc.h:395
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • can
  • communication_mode
  • inc
project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • can
  • communication_mode
  • inc
project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • can
  • communication_mode
  • inc
project/at_start_f435/examples/can/communication_mode/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • can
  • communication_mode
  • src
Functions
project/at_start_f435/examples/can/communication_mode/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/can/communication_mode/src/at32f435_437_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 49 of file project/at_start_f435/examples/can/communication_mode/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • can
  • communication_mode
  • src
project/at_start_f435/examples/can/communication_mode/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/can/communication_mode/src/at32f435_437_clock.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • can
  • communication_mode
  • src
Functions
project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • can
  • communication_mode
  • src
project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/can/communication_mode/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • can
  • communication_mode
  • src
Functions
project/at_start_f435/examples/can/communication_mode/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | can_gpio_config (void)
can gpio config More...
static void | can_configuration (void)
can configiguration. More...
static void | can_transmit_data (void)
can transmit data More...
void | CAN1_RX0_IRQHandler (void)
can1 interrupt function rx0 More...
void | CAN1_SE_IRQHandler (void)
can1 interrupt function se More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/can/communication_mode/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • can
  • communication_mode
  • src
project/at_start_f435/examples/can/communication_mode/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
43static void can_gpio_config(void)
44{
45 gpio_init_type gpio_init_struct;
46 /* enable the gpio clock */
47 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
48
49 gpio_default_para_init(&gpio_init_struct);
50
51 /* configure the can tx, rx pin */
52 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
53 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
54 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
55 gpio_init_struct.gpio_pins = GPIO_PINS_9 | GPIO_PINS_8;
56 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
57 gpio_init(GPIOB, &gpio_init_struct);
58
59 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE9, GPIO_MUX_9);
60 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE8, GPIO_MUX_9);
61}
62
68static void can_configuration(void)
69{
70 can_base_type can_base_struct;
71 can_baudrate_type can_baudrate_struct;
72 can_filter_init_type can_filter_init_struct;
73 /* enable the can clock */
74 crm_periph_clock_enable(CRM_CAN1_PERIPH_CLOCK, TRUE);
75
76 /* can base init */
77 can_default_para_init(&can_base_struct);
78 can_base_struct.mode_selection = CAN_MODE_COMMUNICATE;
79 can_base_struct.ttc_enable = FALSE;
80 can_base_struct.aebo_enable = TRUE;
81 can_base_struct.aed_enable = TRUE;
82 can_base_struct.prsf_enable = FALSE;
83 can_base_struct.mdrsel_selection = CAN_DISCARDING_FIRST_RECEIVED;
84 can_base_struct.mmssr_selection = CAN_SENDING_BY_ID;
85 can_base_init(CAN1, &can_base_struct);
86
87 /* can baudrate, set boudrate = pclk/(baudrate_div *(1 + bts1_size + bts2_size)) */
88 can_baudrate_struct.baudrate_div = 12;
89 can_baudrate_struct.rsaw_size = CAN_RSAW_3TQ;
90 can_baudrate_struct.bts1_size = CAN_BTS1_8TQ;
91 can_baudrate_struct.bts2_size = CAN_BTS2_3TQ;
92 can_baudrate_set(CAN1, &can_baudrate_struct);
93
94 /* can filter init */
95 can_filter_init_struct.filter_activate_enable = TRUE;
96 can_filter_init_struct.filter_mode = CAN_FILTER_MODE_ID_MASK;
97 can_filter_init_struct.filter_fifo = CAN_FILTER_FIFO0;
98 can_filter_init_struct.filter_number = 0;
99 can_filter_init_struct.filter_bit = CAN_FILTER_32BIT;
100 can_filter_init_struct.filter_id_high = 0;
101 can_filter_init_struct.filter_id_low = 0;
102 can_filter_init_struct.filter_mask_high = 0;
103 can_filter_init_struct.filter_mask_low = 0;
104 can_filter_init(CAN1, &can_filter_init_struct);
105
106 /* can interrupt config */
107 nvic_irq_enable(CAN1_SE_IRQn, 0x00, 0x00);
108 nvic_irq_enable(CAN1_RX0_IRQn, 0x00, 0x00);
109 can_interrupt_enable(CAN1, CAN_RF0MIEN_INT, TRUE);
110
111 /* error interrupt enable */
112 can_interrupt_enable(CAN1, CAN_ETRIEN_INT, TRUE);
113 can_interrupt_enable(CAN1, CAN_EOIEN_INT, TRUE);
114}
115
121static void can_transmit_data(void)
122{
123 uint8_t transmit_mailbox;
124 can_tx_message_type tx_message_struct;
125 tx_message_struct.standard_id = 0x400;
126 tx_message_struct.extended_id = 0;
127 tx_message_struct.id_type = CAN_ID_STANDARD;
128 tx_message_struct.frame_type = CAN_TFT_DATA;
129 tx_message_struct.dlc = 8;
130 tx_message_struct.data[0] = 0x11;
131 tx_message_struct.data[1] = 0x22;
132 tx_message_struct.data[2] = 0x33;
133 tx_message_struct.data[3] = 0x44;
134 tx_message_struct.data[4] = 0x55;
135 tx_message_struct.data[5] = 0x66;
136 tx_message_struct.data[6] = 0x77;
137 tx_message_struct.data[7] = 0x88;
138 transmit_mailbox = can_message_transmit(CAN1, &tx_message_struct);
139 while(can_transmit_status_get(CAN1, (can_tx_mailbox_num_type)transmit_mailbox) != CAN_TX_STATUS_SUCCESSFUL);
140}
141
147void CAN1_RX0_IRQHandler(void)
148{
149 can_rx_message_type rx_message_struct;
150 if(can_flag_get(CAN1,CAN_RF0MN_FLAG) != RESET)
151 {
152 can_message_receive(CAN1, CAN_RX_FIFO0, &rx_message_struct);
153 if(rx_message_struct.standard_id == 0x400)
154 at32_led_toggle(LED2);
155 else
156 at32_led_toggle(LED3);
157 }
158}
159
165void CAN1_SE_IRQHandler(void)
166{
167 __IO uint32_t err_index = 0;
168 if(can_flag_get(CAN1,CAN_ETR_FLAG) != RESET)
169 {
170 err_index = CAN1->ests & 0x70;
171 can_flag_clear(CAN1, CAN_ETR_FLAG);
172 /* error type is stuff error */
173 if(err_index == 0x00000010)
174 {
175 /* when stuff error occur: in order to ensure communication normally,
176 user must restart can or send a frame of highest priority message here */
177 }
178 }
179}
180
186int main(void)
187{
188 system_clock_config();
189 at32_board_init();
190 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
191 can_gpio_config();
192 can_configuration();
193 while(1)
194 {
195 can_transmit_data();
196
197 at32_led_toggle(LED4);
198
199 delay_sec(1);
200 }
201}
202
at32f435_437_board.h
CAN1_SE_IRQHandler
void CAN1_SE_IRQHandler(void)
can1 interrupt function se
Definition: project/at_start_f435/examples/can/communication_mode/src/main.c:165
CAN1_RX0_IRQHandler
void CAN1_RX0_IRQHandler(void)
can1 interrupt function rx0
Definition: project/at_start_f435/examples/can/communication_mode/src/main.c:147
can_transmit_data
static void can_transmit_data(void)
can transmit data
Definition: project/at_start_f435/examples/can/communication_mode/src/main.c:121
main
int main(void)
main function.
Definition: project/at_start_f435/examples/can/communication_mode/src/main.c:186
can_gpio_config
static void can_gpio_config(void)
can gpio config
Definition: project/at_start_f435/examples/can/communication_mode/src/main.c:43
can_configuration
static void can_configuration(void)
can configiguration.
Definition: project/at_start_f435/examples/can/communication_mode/src/main.c:68
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
can_base_init
error_status can_base_init(can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct.
Definition: at32f435_437_can.c:194
can_transmit_status_get
can_transmit_status_type can_transmit_status_get(can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral.
Definition: at32f435_437_can.c:514
can_message_transmit
uint8_t can_message_transmit(can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral.
Definition: at32f435_437_can.c:440
can_message_receive
void can_message_receive(can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral.
Definition: at32f435_437_can.c:619
can_interrupt_enable
void can_interrupt_enable(can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral.
Definition: at32f435_437_can.c:924
can_flag_get
flag_status can_flag_get(can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral.
Definition: at32f435_437_can.c:964
can_flag_clear
void can_flag_clear(can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral.
Definition: at32f435_437_can.c:1087
can_baudrate_set
error_status can_baudrate_set(can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral
Definition: at32f435_437_can.c:99
can_filter_init
void can_filter_init(can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct.
Definition: at32f435_437_can.c:304
can_default_para_init
void can_default_para_init(can_base_type *can_base_struct)
fill each can_init_struct member with its default value.
Definition: at32f435_437_can.c:157
can_tx_mailbox_num_type
can_tx_mailbox_num_type
can tx mailboxes
Definition: at32f435_437_can.h:252
CAN_FILTER_FIFO0
@ CAN_FILTER_FIFO0
Definition: at32f435_437_can.h:138
CAN_TX_STATUS_SUCCESSFUL
@ CAN_TX_STATUS_SUCCESSFUL
Definition: at32f435_437_can.h:273
CAN_DISCARDING_FIRST_RECEIVED
@ CAN_DISCARDING_FIRST_RECEIVED
Definition: at32f435_437_can.h:301
CAN_BTS2_3TQ
@ CAN_BTS2_3TQ
Definition: at32f435_437_can.h:222
CAN_TFT_DATA
@ CAN_TFT_DATA
Definition: at32f435_437_can.h:244
CAN_BTS1_8TQ
@ CAN_BTS1_8TQ
Definition: at32f435_437_can.h:204
CAN_FILTER_MODE_ID_MASK
@ CAN_FILTER_MODE_ID_MASK
Definition: at32f435_437_can.h:147
CAN_SENDING_BY_ID
@ CAN_SENDING_BY_ID
Definition: at32f435_437_can.h:310
CAN_FILTER_32BIT
@ CAN_FILTER_32BIT
Definition: at32f435_437_can.h:157
CAN_RX_FIFO0
@ CAN_RX_FIFO0
Definition: at32f435_437_can.h:263
CAN_ID_STANDARD
@ CAN_ID_STANDARD
Definition: at32f435_437_can.h:235
CAN_MODE_COMMUNICATE
@ CAN_MODE_COMMUNICATE
Definition: at32f435_437_can.h:165
CAN_RSAW_3TQ
@ CAN_RSAW_3TQ
Definition: at32f435_437_can.h:188
CAN_RF0MN_FLAG
#define CAN_RF0MN_FLAG
Definition: at32f435_437_can.h:72
CAN_ETR_FLAG
#define CAN_ETR_FLAG
Definition: at32f435_437_can.h:67
CAN_RF0MIEN_INT
#define CAN_RF0MIEN_INT
Definition: at32f435_437_can.h:92
CAN_EOIEN_INT
#define CAN_EOIEN_INT
Definition: at32f435_437_can.h:102
CAN_ETRIEN_INT
#define CAN_ETRIEN_INT
Definition: at32f435_437_can.h:101
CAN1
#define CAN1
Definition: at32f435_437_can.h:994
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_CAN1_PERIPH_CLOCK
@ CRM_CAN1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:147
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_9
@ GPIO_MUX_9
Definition: at32f435_437_gpio.h:165
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
CAN1_RX0_IRQn
@ CAN1_RX0_IRQn
Definition: at32f435_437.h:168
CAN1_SE_IRQn
@ CAN1_SE_IRQn
Definition: at32f435_437.h:170
can_base_type
can init structure definition
Definition: at32f435_437_can.h:333
can_base_type::prsf_enable
confirm_state prsf_enable
Definition: at32f435_437_can.h:342
can_base_type::mdrsel_selection
can_msg_discarding_rule_type mdrsel_selection
Definition: at32f435_437_can.h:344
can_base_type::aed_enable
confirm_state aed_enable
Definition: at32f435_437_can.h:340
can_base_type::mmssr_selection
can_msg_sending_rule_type mmssr_selection
Definition: at32f435_437_can.h:346
can_base_type::ttc_enable
confirm_state ttc_enable
Definition: at32f435_437_can.h:336
can_base_type::mode_selection
can_mode_type mode_selection
Definition: at32f435_437_can.h:334
can_base_type::aebo_enable
confirm_state aebo_enable
Definition: at32f435_437_can.h:338
can_baudrate_type
can baudrate structure definition
Definition: at32f435_437_can.h:354
can_baudrate_type::baudrate_div
uint16_t baudrate_div
Definition: at32f435_437_can.h:355
can_baudrate_type::rsaw_size
can_rsaw_type rsaw_size
Definition: at32f435_437_can.h:357
can_baudrate_type::bts2_size
can_bts2_type bts2_size
Definition: at32f435_437_can.h:361
can_baudrate_type::bts1_size
can_bts1_type bts1_size
Definition: at32f435_437_can.h:359
can_filter_init_type
can filter init structure definition
Definition: at32f435_437_can.h:369
can_filter_init_type::filter_mask_low
uint16_t filter_mask_low
Definition: at32f435_437_can.h:389
can_filter_init_type::filter_number
uint8_t filter_number
Definition: at32f435_437_can.h:376
can_filter_init_type::filter_fifo
can_filter_fifo_type filter_fifo
Definition: at32f435_437_can.h:374
can_filter_init_type::filter_bit
can_filter_bit_width_type filter_bit
Definition: at32f435_437_can.h:378
can_filter_init_type::filter_mode
can_filter_mode_type filter_mode
Definition: at32f435_437_can.h:372
can_filter_init_type::filter_activate_enable
confirm_state filter_activate_enable
Definition: at32f435_437_can.h:370
can_filter_init_type::filter_mask_high
uint16_t filter_mask_high
Definition: at32f435_437_can.h:386
can_filter_init_type::filter_id_high
uint16_t filter_id_high
Definition: at32f435_437_can.h:380
can_filter_init_type::filter_id_low
uint16_t filter_id_low
Definition: at32f435_437_can.h:383
can_rx_message_type
can rx message structure definition
Definition: at32f435_437_can.h:419
can_rx_message_type::standard_id
uint32_t standard_id
Definition: at32f435_437_can.h:420
can_tx_message_type
can tx message structure definition
Definition: at32f435_437_can.h:397
can_tx_message_type::extended_id
uint32_t extended_id
Definition: at32f435_437_can.h:401
can_tx_message_type::frame_type
can_trans_frame_type frame_type
Definition: at32f435_437_can.h:406
can_tx_message_type::data
uint8_t data[8]
Definition: at32f435_437_can.h:411
can_tx_message_type::dlc
uint8_t dlc
Definition: at32f435_437_can.h:408
can_tx_message_type::id_type
can_identifier_type id_type
Definition: at32f435_437_can.h:404
can_tx_message_type::standard_id
uint32_t standard_id
Definition: at32f435_437_can.h:398
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • can
  • filter
  • inc
project/at_start_f435/examples/can/filter/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • can
  • filter
  • inc
project/at_start_f435/examples/can/filter/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • can
  • filter
  • inc
project/at_start_f435/examples/can/filter/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • can
  • filter
  • src
Functions
project/at_start_f435/examples/can/filter/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/can/filter/src/at32f435_437_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 49 of file project/at_start_f435/examples/can/filter/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • can
  • filter
  • src
project/at_start_f435/examples/can/filter/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/can/filter/src/at32f435_437_clock.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • can
  • filter
  • src
Functions
project/at_start_f435/examples/can/filter/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/can/filter/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • can
  • filter
  • src
project/at_start_f435/examples/can/filter/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/can/filter/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/can/filter/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/can/filter/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/can/filter/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/can/filter/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/can/filter/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/can/filter/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/can/filter/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/can/filter/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • can
  • filter
  • src
Macros | Functions | Variables
project/at_start_f435/examples/can/filter/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define | FILTER_EXT_ID1 ((uint32_t)0x18F5F100)
#define | FILTER_EXT_ID2 ((uint32_t)0x18F5F200)
#define | FILTER_EXT_ID3 ((uint32_t)0x18F5F300)
#define | FILTER_STD_ID1 ((uint16_t)0x04F6)
#define | FILTER_STD_ID2 ((uint16_t)0x04F7)
#define | FILTER_STD_ID3 ((uint16_t)0x04F8)

Functions

static void | can_gpio_config (void)
can gpio config More...
static void | can_configuration (void)
can configiguration. More...
static void | can_transmit_data (void)
can transmit data More...
void | CAN1_RX0_IRQHandler (void)
can1 interrupt function rx0 More...
void | CAN1_SE_IRQHandler (void)
can1 interrupt function se More...
int | main (void)
main function. More...

Variables

uint8_t test_result = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/can/filter/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • can
  • filter
  • src
project/at_start_f435/examples/can/filter/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38/* extended identifier */
39#define FILTER_EXT_ID1 ((uint32_t)0x18F5F100)
40#define FILTER_EXT_ID2 ((uint32_t)0x18F5F200)
41#define FILTER_EXT_ID3 ((uint32_t)0x18F5F300)
42
43/* standard identifier */
44#define FILTER_STD_ID1 ((uint16_t)0x04F6)
45#define FILTER_STD_ID2 ((uint16_t)0x04F7)
46#define FILTER_STD_ID3 ((uint16_t)0x04F8)
47
48uint8_t test_result = 0;
54static void can_gpio_config(void)
55{
56 gpio_init_type gpio_init_struct;
57 /* enable the gpio clock */
58 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
59
60 gpio_default_para_init(&gpio_init_struct);
61
62 /* configure the can tx, rx pin */
63 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
64 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
65 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
66 gpio_init_struct.gpio_pins = GPIO_PINS_9 | GPIO_PINS_8;
67 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
68 gpio_init(GPIOB, &gpio_init_struct);
69
70 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE9, GPIO_MUX_9);
71 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE8, GPIO_MUX_9);
72}
73
79static void can_configuration(void)
80{
81 can_base_type can_base_struct;
82 can_baudrate_type can_baudrate_struct;
83 can_filter_init_type can_filter_init_struct;
84 /* enable the can clock */
85 crm_periph_clock_enable(CRM_CAN1_PERIPH_CLOCK, TRUE);
86
87 /* can base init */
88 can_default_para_init(&can_base_struct);
89 can_base_struct.mode_selection = CAN_MODE_COMMUNICATE;
90 can_base_struct.ttc_enable = FALSE;
91 can_base_struct.aebo_enable = TRUE;
92 can_base_struct.aed_enable = TRUE;
93 can_base_struct.prsf_enable = FALSE;
94 can_base_struct.mdrsel_selection = CAN_DISCARDING_FIRST_RECEIVED;
95 can_base_struct.mmssr_selection = CAN_SENDING_BY_ID;
96 can_base_init(CAN1, &can_base_struct);
97
98 /* can baudrate, set boudrate = pclk/(baudrate_div *(1 + bts1_size + bts2_size)) */
99 can_baudrate_struct.baudrate_div = 12;
100 can_baudrate_struct.rsaw_size = CAN_RSAW_3TQ;
101 can_baudrate_struct.bts1_size = CAN_BTS1_8TQ;
102 can_baudrate_struct.bts2_size = CAN_BTS2_3TQ;
103 can_baudrate_set(CAN1, &can_baudrate_struct);
104
105 /* can filter 0 config */
106 can_filter_init_struct.filter_activate_enable = TRUE;
107 can_filter_init_struct.filter_mode = CAN_FILTER_MODE_ID_LIST;
108 can_filter_init_struct.filter_fifo = CAN_FILTER_FIFO0;
109 can_filter_init_struct.filter_number = 0;
110 can_filter_init_struct.filter_bit = CAN_FILTER_32BIT;
111 can_filter_init_struct.filter_id_high = (((FILTER_EXT_ID1 << 3) >> 16) & 0xFFFF); /* extended identifier is 29 bit */
112 can_filter_init_struct.filter_id_low = ((FILTER_EXT_ID1 << 3) & 0xFFFF) | 0x04;
113 can_filter_init_struct.filter_mask_high = ((FILTER_EXT_ID2 << 3) >> 16) & 0xFFFF; /* extended identifier is 29 bit */
114 can_filter_init_struct.filter_mask_low = ((FILTER_EXT_ID2 << 3) & 0xFFFF) | 0x04;
115 can_filter_init(CAN1, &can_filter_init_struct);
116
117 /* can filter 1 config */
118 can_filter_init_struct.filter_activate_enable = TRUE;
119 can_filter_init_struct.filter_mode = CAN_FILTER_MODE_ID_LIST;
120 can_filter_init_struct.filter_fifo = CAN_FILTER_FIFO0;
121 can_filter_init_struct.filter_number = 1;
122 can_filter_init_struct.filter_bit = CAN_FILTER_32BIT;
123 can_filter_init_struct.filter_id_high = FILTER_STD_ID1 << 5; /* standard identifier is 11 bit */
124 can_filter_init_struct.filter_id_low = 0;
125 can_filter_init_struct.filter_mask_high = FILTER_STD_ID2 << 5;/* standard identifier is 11 bit */
126 can_filter_init_struct.filter_mask_low = 0;
127 can_filter_init(CAN1, &can_filter_init_struct);
128
129 /* can interrupt config */
130 nvic_irq_enable(CAN1_SE_IRQn, 0x00, 0x00);
131 nvic_irq_enable(CAN1_RX0_IRQn, 0x00, 0x00);
132 can_interrupt_enable(CAN1, CAN_RF0MIEN_INT, TRUE);
133
134 /* error interrupt enable */
135 can_interrupt_enable(CAN1, CAN_ETRIEN_INT, TRUE);
136 can_interrupt_enable(CAN1, CAN_EOIEN_INT, TRUE);
137}
138
144static void can_transmit_data(void)
145{
146 uint8_t transmit_mailbox;
147 can_tx_message_type tx_message_struct;
148
149 /* transmit FILTER_STD_ID1 */
150 tx_message_struct.standard_id = FILTER_STD_ID1;
151 tx_message_struct.extended_id = 0;
152 tx_message_struct.id_type = CAN_ID_STANDARD;
153 tx_message_struct.frame_type = CAN_TFT_DATA;
154 tx_message_struct.dlc = 8;
155 tx_message_struct.data[0] = 0x11;
156 tx_message_struct.data[1] = 0x22;
157 tx_message_struct.data[2] = 0x33;
158 tx_message_struct.data[3] = 0x44;
159 tx_message_struct.data[4] = 0x55;
160 tx_message_struct.data[5] = 0x66;
161 tx_message_struct.data[6] = 0x77;
162 tx_message_struct.data[7] = 0x88;
163 transmit_mailbox = can_message_transmit(CAN1, &tx_message_struct);
164 while(can_transmit_status_get(CAN1, (can_tx_mailbox_num_type)transmit_mailbox) != CAN_TX_STATUS_SUCCESSFUL);
165
166 /* transmit FILTER_STD_ID2 */
167 tx_message_struct.standard_id = FILTER_STD_ID2;
168 tx_message_struct.extended_id = 0;
169 tx_message_struct.id_type = CAN_ID_STANDARD;
170 tx_message_struct.frame_type = CAN_TFT_DATA;
171 tx_message_struct.dlc = 8;
172 tx_message_struct.data[0] = 0x11;
173 tx_message_struct.data[1] = 0x22;
174 tx_message_struct.data[2] = 0x33;
175 tx_message_struct.data[3] = 0x44;
176 tx_message_struct.data[4] = 0x55;
177 tx_message_struct.data[5] = 0x66;
178 tx_message_struct.data[6] = 0x77;
179 tx_message_struct.data[7] = 0x88;
180 transmit_mailbox = can_message_transmit(CAN1, &tx_message_struct);
181 while(can_transmit_status_get(CAN1, (can_tx_mailbox_num_type)transmit_mailbox) != CAN_TX_STATUS_SUCCESSFUL);
182
183 /* transmit FILTER_STD_ID3 */
184 tx_message_struct.standard_id = FILTER_STD_ID3;
185 tx_message_struct.extended_id = 0;
186 tx_message_struct.id_type = CAN_ID_STANDARD;
187 tx_message_struct.frame_type = CAN_TFT_DATA;
188 tx_message_struct.dlc = 8;
189 tx_message_struct.data[0] = 0x11;
190 tx_message_struct.data[1] = 0x22;
191 tx_message_struct.data[2] = 0x33;
192 tx_message_struct.data[3] = 0x44;
193 tx_message_struct.data[4] = 0x55;
194 tx_message_struct.data[5] = 0x66;
195 tx_message_struct.data[6] = 0x77;
196 tx_message_struct.data[7] = 0x88;
197 transmit_mailbox = can_message_transmit(CAN1, &tx_message_struct);
198 while(can_transmit_status_get(CAN1, (can_tx_mailbox_num_type)transmit_mailbox) != CAN_TX_STATUS_SUCCESSFUL);
199
200 /* transmit FILTER_EXT_ID1 */
201 tx_message_struct.standard_id = 0;
202 tx_message_struct.extended_id = FILTER_EXT_ID1;
203 tx_message_struct.id_type = CAN_ID_EXTENDED;
204 tx_message_struct.frame_type = CAN_TFT_DATA;
205 tx_message_struct.dlc = 8;
206 tx_message_struct.data[0] = 0x11;
207 tx_message_struct.data[1] = 0x22;
208 tx_message_struct.data[2] = 0x33;
209 tx_message_struct.data[3] = 0x44;
210 tx_message_struct.data[4] = 0x55;
211 tx_message_struct.data[5] = 0x66;
212 tx_message_struct.data[6] = 0x77;
213 tx_message_struct.data[7] = 0x88;
214 transmit_mailbox = can_message_transmit(CAN1, &tx_message_struct);
215 while(can_transmit_status_get(CAN1, (can_tx_mailbox_num_type)transmit_mailbox) != CAN_TX_STATUS_SUCCESSFUL);
216
217 /* transmit FILTER_EXT_ID2 */
218 tx_message_struct.standard_id = 0;
219 tx_message_struct.extended_id = FILTER_EXT_ID2;
220 tx_message_struct.id_type = CAN_ID_EXTENDED;
221 tx_message_struct.frame_type = CAN_TFT_DATA;
222 tx_message_struct.dlc = 8;
223 tx_message_struct.data[0] = 0x11;
224 tx_message_struct.data[1] = 0x22;
225 tx_message_struct.data[2] = 0x33;
226 tx_message_struct.data[3] = 0x44;
227 tx_message_struct.data[4] = 0x55;
228 tx_message_struct.data[5] = 0x66;
229 tx_message_struct.data[6] = 0x77;
230 tx_message_struct.data[7] = 0x88;
231 transmit_mailbox = can_message_transmit(CAN1, &tx_message_struct);
232 while(can_transmit_status_get(CAN1, (can_tx_mailbox_num_type)transmit_mailbox) != CAN_TX_STATUS_SUCCESSFUL);
233
234 /* transmit FILTER_EXT_ID3 */
235 tx_message_struct.standard_id = 0;
236 tx_message_struct.extended_id = FILTER_EXT_ID3;
237 tx_message_struct.id_type = CAN_ID_EXTENDED;
238 tx_message_struct.frame_type = CAN_TFT_DATA;
239 tx_message_struct.dlc = 8;
240 tx_message_struct.data[0] = 0x11;
241 tx_message_struct.data[1] = 0x22;
242 tx_message_struct.data[2] = 0x33;
243 tx_message_struct.data[3] = 0x44;
244 tx_message_struct.data[4] = 0x55;
245 tx_message_struct.data[5] = 0x66;
246 tx_message_struct.data[6] = 0x77;
247 tx_message_struct.data[7] = 0x88;
248 transmit_mailbox = can_message_transmit(CAN1, &tx_message_struct);
249 while(can_transmit_status_get(CAN1, (can_tx_mailbox_num_type)transmit_mailbox) != CAN_TX_STATUS_SUCCESSFUL);
250}
251
257void CAN1_RX0_IRQHandler(void)
258{
259 can_rx_message_type rx_message_struct;
260 if(can_flag_get(CAN1,CAN_RF0MN_FLAG) != RESET)
261 {
262 if(test_result == 4)
263 {
264 test_result = 0;
265 }
266
267 can_message_receive(CAN1, CAN_RX_FIFO0, &rx_message_struct);
268
269 if((rx_message_struct.id_type == CAN_ID_STANDARD) && (rx_message_struct.standard_id == FILTER_STD_ID1))
270 test_result++;
271 else if((rx_message_struct.id_type == CAN_ID_STANDARD) && (rx_message_struct.standard_id == FILTER_STD_ID2))
272 test_result++;
273 else if((rx_message_struct.id_type == CAN_ID_EXTENDED) && (rx_message_struct.extended_id == FILTER_EXT_ID1))
274 test_result++;
275 else if((rx_message_struct.id_type == CAN_ID_EXTENDED) && (rx_message_struct.extended_id == FILTER_EXT_ID2))
276 test_result++;
277 }
278}
279
285void CAN1_SE_IRQHandler(void)
286{
287 __IO uint32_t err_index = 0;
288 if(can_flag_get(CAN1,CAN_ETR_FLAG) != RESET)
289 {
290 err_index = CAN1->ests & 0x70;
291 can_flag_clear(CAN1, CAN_ETR_FLAG);
292 /* error type is stuff error */
293 if(err_index == 0x00000010)
294 {
295 /* when stuff error occur: in order to ensure communication normally,
296 user must restart can or send a frame of highest priority message here */
297 }
298 }
299}
300
306int main(void)
307{
308 system_clock_config();
309 at32_board_init();
310 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
311 can_gpio_config();
312 can_configuration();
313 can_transmit_data();
314 while(1)
315 {
316 if(test_result == 4)
317 {
318 at32_led_toggle(LED2);
319 at32_led_toggle(LED3);
320 at32_led_toggle(LED4);
321 delay_sec(1);
322 }
323 }
324}
325
at32f435_437_board.h
CAN1_SE_IRQHandler
void CAN1_SE_IRQHandler(void)
can1 interrupt function se
Definition: project/at_start_f435/examples/can/filter/src/main.c:285
FILTER_EXT_ID3
#define FILTER_EXT_ID3
Definition: project/at_start_f435/examples/can/filter/src/main.c:41
FILTER_EXT_ID1
#define FILTER_EXT_ID1
Definition: project/at_start_f435/examples/can/filter/src/main.c:39
FILTER_STD_ID2
#define FILTER_STD_ID2
Definition: project/at_start_f435/examples/can/filter/src/main.c:45
CAN1_RX0_IRQHandler
void CAN1_RX0_IRQHandler(void)
can1 interrupt function rx0
Definition: project/at_start_f435/examples/can/filter/src/main.c:257
can_transmit_data
static void can_transmit_data(void)
can transmit data
Definition: project/at_start_f435/examples/can/filter/src/main.c:144
main
int main(void)
main function.
Definition: project/at_start_f435/examples/can/filter/src/main.c:306
FILTER_EXT_ID2
#define FILTER_EXT_ID2
Definition: project/at_start_f435/examples/can/filter/src/main.c:40
FILTER_STD_ID3
#define FILTER_STD_ID3
Definition: project/at_start_f435/examples/can/filter/src/main.c:46
FILTER_STD_ID1
#define FILTER_STD_ID1
Definition: project/at_start_f435/examples/can/filter/src/main.c:44
can_gpio_config
static void can_gpio_config(void)
can gpio config
Definition: project/at_start_f435/examples/can/filter/src/main.c:54
can_configuration
static void can_configuration(void)
can configiguration.
Definition: project/at_start_f435/examples/can/filter/src/main.c:79
test_result
uint8_t test_result
Definition: project/at_start_f435/examples/can/filter/src/main.c:48
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
can_base_init
error_status can_base_init(can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct.
Definition: at32f435_437_can.c:194
can_transmit_status_get
can_transmit_status_type can_transmit_status_get(can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral.
Definition: at32f435_437_can.c:514
can_message_transmit
uint8_t can_message_transmit(can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral.
Definition: at32f435_437_can.c:440
can_message_receive
void can_message_receive(can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral.
Definition: at32f435_437_can.c:619
can_interrupt_enable
void can_interrupt_enable(can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral.
Definition: at32f435_437_can.c:924
can_flag_get
flag_status can_flag_get(can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral.
Definition: at32f435_437_can.c:964
can_flag_clear
void can_flag_clear(can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral.
Definition: at32f435_437_can.c:1087
can_baudrate_set
error_status can_baudrate_set(can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral
Definition: at32f435_437_can.c:99
can_filter_init
void can_filter_init(can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct.
Definition: at32f435_437_can.c:304
can_default_para_init
void can_default_para_init(can_base_type *can_base_struct)
fill each can_init_struct member with its default value.
Definition: at32f435_437_can.c:157
can_tx_mailbox_num_type
can_tx_mailbox_num_type
can tx mailboxes
Definition: at32f435_437_can.h:252
CAN_FILTER_FIFO0
@ CAN_FILTER_FIFO0
Definition: at32f435_437_can.h:138
CAN_TX_STATUS_SUCCESSFUL
@ CAN_TX_STATUS_SUCCESSFUL
Definition: at32f435_437_can.h:273
CAN_DISCARDING_FIRST_RECEIVED
@ CAN_DISCARDING_FIRST_RECEIVED
Definition: at32f435_437_can.h:301
CAN_BTS2_3TQ
@ CAN_BTS2_3TQ
Definition: at32f435_437_can.h:222
CAN_TFT_DATA
@ CAN_TFT_DATA
Definition: at32f435_437_can.h:244
CAN_BTS1_8TQ
@ CAN_BTS1_8TQ
Definition: at32f435_437_can.h:204
CAN_FILTER_MODE_ID_LIST
@ CAN_FILTER_MODE_ID_LIST
Definition: at32f435_437_can.h:148
CAN_SENDING_BY_ID
@ CAN_SENDING_BY_ID
Definition: at32f435_437_can.h:310
CAN_FILTER_32BIT
@ CAN_FILTER_32BIT
Definition: at32f435_437_can.h:157
CAN_RX_FIFO0
@ CAN_RX_FIFO0
Definition: at32f435_437_can.h:263
CAN_ID_STANDARD
@ CAN_ID_STANDARD
Definition: at32f435_437_can.h:235
CAN_ID_EXTENDED
@ CAN_ID_EXTENDED
Definition: at32f435_437_can.h:236
CAN_MODE_COMMUNICATE
@ CAN_MODE_COMMUNICATE
Definition: at32f435_437_can.h:165
CAN_RSAW_3TQ
@ CAN_RSAW_3TQ
Definition: at32f435_437_can.h:188
CAN_RF0MN_FLAG
#define CAN_RF0MN_FLAG
Definition: at32f435_437_can.h:72
CAN_ETR_FLAG
#define CAN_ETR_FLAG
Definition: at32f435_437_can.h:67
CAN_RF0MIEN_INT
#define CAN_RF0MIEN_INT
Definition: at32f435_437_can.h:92
CAN_EOIEN_INT
#define CAN_EOIEN_INT
Definition: at32f435_437_can.h:102
CAN_ETRIEN_INT
#define CAN_ETRIEN_INT
Definition: at32f435_437_can.h:101
CAN1
#define CAN1
Definition: at32f435_437_can.h:994
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_CAN1_PERIPH_CLOCK
@ CRM_CAN1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:147
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_9
@ GPIO_MUX_9
Definition: at32f435_437_gpio.h:165
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
CAN1_RX0_IRQn
@ CAN1_RX0_IRQn
Definition: at32f435_437.h:168
CAN1_SE_IRQn
@ CAN1_SE_IRQn
Definition: at32f435_437.h:170
can_base_type
can init structure definition
Definition: at32f435_437_can.h:333
can_base_type::prsf_enable
confirm_state prsf_enable
Definition: at32f435_437_can.h:342
can_base_type::mdrsel_selection
can_msg_discarding_rule_type mdrsel_selection
Definition: at32f435_437_can.h:344
can_base_type::aed_enable
confirm_state aed_enable
Definition: at32f435_437_can.h:340
can_base_type::mmssr_selection
can_msg_sending_rule_type mmssr_selection
Definition: at32f435_437_can.h:346
can_base_type::ttc_enable
confirm_state ttc_enable
Definition: at32f435_437_can.h:336
can_base_type::mode_selection
can_mode_type mode_selection
Definition: at32f435_437_can.h:334
can_base_type::aebo_enable
confirm_state aebo_enable
Definition: at32f435_437_can.h:338
can_baudrate_type
can baudrate structure definition
Definition: at32f435_437_can.h:354
can_baudrate_type::baudrate_div
uint16_t baudrate_div
Definition: at32f435_437_can.h:355
can_baudrate_type::rsaw_size
can_rsaw_type rsaw_size
Definition: at32f435_437_can.h:357
can_baudrate_type::bts2_size
can_bts2_type bts2_size
Definition: at32f435_437_can.h:361
can_baudrate_type::bts1_size
can_bts1_type bts1_size
Definition: at32f435_437_can.h:359
can_filter_init_type
can filter init structure definition
Definition: at32f435_437_can.h:369
can_filter_init_type::filter_mask_low
uint16_t filter_mask_low
Definition: at32f435_437_can.h:389
can_filter_init_type::filter_number
uint8_t filter_number
Definition: at32f435_437_can.h:376
can_filter_init_type::filter_fifo
can_filter_fifo_type filter_fifo
Definition: at32f435_437_can.h:374
can_filter_init_type::filter_bit
can_filter_bit_width_type filter_bit
Definition: at32f435_437_can.h:378
can_filter_init_type::filter_mode
can_filter_mode_type filter_mode
Definition: at32f435_437_can.h:372
can_filter_init_type::filter_activate_enable
confirm_state filter_activate_enable
Definition: at32f435_437_can.h:370
can_filter_init_type::filter_mask_high
uint16_t filter_mask_high
Definition: at32f435_437_can.h:386
can_filter_init_type::filter_id_high
uint16_t filter_id_high
Definition: at32f435_437_can.h:380
can_filter_init_type::filter_id_low
uint16_t filter_id_low
Definition: at32f435_437_can.h:383
can_rx_message_type
can rx message structure definition
Definition: at32f435_437_can.h:419
can_rx_message_type::standard_id
uint32_t standard_id
Definition: at32f435_437_can.h:420
can_rx_message_type::id_type
can_identifier_type id_type
Definition: at32f435_437_can.h:426
can_rx_message_type::extended_id
uint32_t extended_id
Definition: at32f435_437_can.h:423
can_tx_message_type
can tx message structure definition
Definition: at32f435_437_can.h:397
can_tx_message_type::extended_id
uint32_t extended_id
Definition: at32f435_437_can.h:401
can_tx_message_type::frame_type
can_trans_frame_type frame_type
Definition: at32f435_437_can.h:406
can_tx_message_type::data
uint8_t data[8]
Definition: at32f435_437_can.h:411
can_tx_message_type::dlc
uint8_t dlc
Definition: at32f435_437_can.h:408
can_tx_message_type::id_type
can_identifier_type id_type
Definition: at32f435_437_can.h:404
can_tx_message_type::standard_id
uint32_t standard_id
Definition: at32f435_437_can.h:398
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • can
  • loopback_mode
  • inc
project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • can
  • loopback_mode
  • inc
project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • can
  • loopback_mode
  • inc
project/at_start_f435/examples/can/loopback_mode/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • can
  • loopback_mode
  • src
Functions
project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 49 of file project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • can
  • loopback_mode
  • src
project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_clock.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • can
  • loopback_mode
  • src
Functions
project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • can
  • loopback_mode
  • src
project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/can/loopback_mode/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • can
  • loopback_mode
  • src
Functions
project/at_start_f435/examples/can/loopback_mode/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | can_gpio_config (void)
can gpio config More...
static void | can_configuration (void)
can configiguration. More...
static void | can_transmit_data (void)
can transmit data More...
void | CAN1_RX0_IRQHandler (void)
can1 interrupt function rx0 More...
void | CAN1_SE_IRQHandler (void)
can1 interrupt function se More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/can/loopback_mode/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • can
  • loopback_mode
  • src
project/at_start_f435/examples/can/loopback_mode/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
43static void can_gpio_config(void)
44{
45 gpio_init_type gpio_init_struct;
46 /* enable the gpio clock */
47 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
48
49 gpio_default_para_init(&gpio_init_struct);
50
51 /* configure the can tx, rx pin */
52 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
53 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
54 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
55 gpio_init_struct.gpio_pins = GPIO_PINS_9 | GPIO_PINS_8;
56 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
57 gpio_init(GPIOB, &gpio_init_struct);
58
59 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE9, GPIO_MUX_9);
60 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE8, GPIO_MUX_9);
61}
62
68static void can_configuration(void)
69{
70 can_base_type can_base_struct;
71 can_baudrate_type can_baudrate_struct;
72 can_filter_init_type can_filter_init_struct;
73 /* enable the can clock */
74 crm_periph_clock_enable(CRM_CAN1_PERIPH_CLOCK, TRUE);
75
76 /* can base init */
77 can_default_para_init(&can_base_struct);
78 can_base_struct.mode_selection = CAN_MODE_LOOPBACK;
79 can_base_struct.ttc_enable = FALSE;
80 can_base_struct.aebo_enable = TRUE;
81 can_base_struct.aed_enable = TRUE;
82 can_base_struct.prsf_enable = FALSE;
83 can_base_struct.mdrsel_selection = CAN_DISCARDING_FIRST_RECEIVED;
84 can_base_struct.mmssr_selection = CAN_SENDING_BY_ID;
85 can_base_init(CAN1, &can_base_struct);
86
87 /* can baudrate, set boudrate = pclk/(baudrate_div *(1 + bts1_size + bts2_size)) */
88 can_baudrate_struct.baudrate_div = 12;
89 can_baudrate_struct.rsaw_size = CAN_RSAW_3TQ;
90 can_baudrate_struct.bts1_size = CAN_BTS1_8TQ;
91 can_baudrate_struct.bts2_size = CAN_BTS2_3TQ;
92 can_baudrate_set(CAN1, &can_baudrate_struct);
93
94 /* can filter init */
95 can_filter_init_struct.filter_activate_enable = TRUE;
96 can_filter_init_struct.filter_mode = CAN_FILTER_MODE_ID_MASK;
97 can_filter_init_struct.filter_fifo = CAN_FILTER_FIFO0;
98 can_filter_init_struct.filter_number = 0;
99 can_filter_init_struct.filter_bit = CAN_FILTER_32BIT;
100 can_filter_init_struct.filter_id_high = 0;
101 can_filter_init_struct.filter_id_low = 0;
102 can_filter_init_struct.filter_mask_high = 0;
103 can_filter_init_struct.filter_mask_low = 0;
104 can_filter_init(CAN1, &can_filter_init_struct);
105
106 /* can interrupt config */
107 nvic_irq_enable(CAN1_SE_IRQn, 0x00, 0x00);
108 nvic_irq_enable(CAN1_RX0_IRQn, 0x00, 0x00);
109 can_interrupt_enable(CAN1, CAN_RF0MIEN_INT, TRUE);
110
111 /* error interrupt enable */
112 can_interrupt_enable(CAN1, CAN_ETRIEN_INT, TRUE);
113 can_interrupt_enable(CAN1, CAN_EOIEN_INT, TRUE);
114}
115
121static void can_transmit_data(void)
122{
123 uint8_t transmit_mailbox;
124 can_tx_message_type tx_message_struct;
125 tx_message_struct.standard_id = 0x400;
126 tx_message_struct.extended_id = 0;
127 tx_message_struct.id_type = CAN_ID_STANDARD;
128 tx_message_struct.frame_type = CAN_TFT_DATA;
129 tx_message_struct.dlc = 8;
130 tx_message_struct.data[0] = 0x11;
131 tx_message_struct.data[1] = 0x22;
132 tx_message_struct.data[2] = 0x33;
133 tx_message_struct.data[3] = 0x44;
134 tx_message_struct.data[4] = 0x55;
135 tx_message_struct.data[5] = 0x66;
136 tx_message_struct.data[6] = 0x77;
137 tx_message_struct.data[7] = 0x88;
138 transmit_mailbox = can_message_transmit(CAN1, &tx_message_struct);
139 while(can_transmit_status_get(CAN1, (can_tx_mailbox_num_type)transmit_mailbox) != CAN_TX_STATUS_SUCCESSFUL);
140}
141
147void CAN1_RX0_IRQHandler(void)
148{
149 can_rx_message_type rx_message_struct;
150 if(can_flag_get(CAN1,CAN_RF0MN_FLAG) != RESET)
151 {
152 can_message_receive(CAN1, CAN_RX_FIFO0, &rx_message_struct);
153 if(rx_message_struct.standard_id == 0x400)
154 at32_led_toggle(LED2);
155 }
156}
157
163void CAN1_SE_IRQHandler(void)
164{
165 __IO uint32_t err_index = 0;
166 if(can_flag_get(CAN1,CAN_ETR_FLAG) != RESET)
167 {
168 err_index = CAN1->ests & 0x70;
169 can_flag_clear(CAN1, CAN_ETR_FLAG);
170 /* error type is stuff error */
171 if(err_index == 0x00000010)
172 {
173 /* when stuff error occur: in order to ensure communication normally,
174 user must restart can or send a frame of highest priority message here */
175 }
176 }
177}
178
179
185int main(void)
186{
187 system_clock_config();
188 at32_board_init();
189 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
190 can_gpio_config();
191 can_configuration();
192 while(1)
193 {
194 can_transmit_data();
195
196 at32_led_toggle(LED4);
197
198 delay_sec(1);
199 }
200}
201
at32f435_437_board.h
CAN1_SE_IRQHandler
void CAN1_SE_IRQHandler(void)
can1 interrupt function se
Definition: project/at_start_f435/examples/can/loopback_mode/src/main.c:163
CAN1_RX0_IRQHandler
void CAN1_RX0_IRQHandler(void)
can1 interrupt function rx0
Definition: project/at_start_f435/examples/can/loopback_mode/src/main.c:147
can_transmit_data
static void can_transmit_data(void)
can transmit data
Definition: project/at_start_f435/examples/can/loopback_mode/src/main.c:121
main
int main(void)
main function.
Definition: project/at_start_f435/examples/can/loopback_mode/src/main.c:185
can_gpio_config
static void can_gpio_config(void)
can gpio config
Definition: project/at_start_f435/examples/can/loopback_mode/src/main.c:43
can_configuration
static void can_configuration(void)
can configiguration.
Definition: project/at_start_f435/examples/can/loopback_mode/src/main.c:68
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
can_base_init
error_status can_base_init(can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct.
Definition: at32f435_437_can.c:194
can_transmit_status_get
can_transmit_status_type can_transmit_status_get(can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral.
Definition: at32f435_437_can.c:514
can_message_transmit
uint8_t can_message_transmit(can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral.
Definition: at32f435_437_can.c:440
can_message_receive
void can_message_receive(can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral.
Definition: at32f435_437_can.c:619
can_interrupt_enable
void can_interrupt_enable(can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral.
Definition: at32f435_437_can.c:924
can_flag_get
flag_status can_flag_get(can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral.
Definition: at32f435_437_can.c:964
can_flag_clear
void can_flag_clear(can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral.
Definition: at32f435_437_can.c:1087
can_baudrate_set
error_status can_baudrate_set(can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral
Definition: at32f435_437_can.c:99
can_filter_init
void can_filter_init(can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct.
Definition: at32f435_437_can.c:304
can_default_para_init
void can_default_para_init(can_base_type *can_base_struct)
fill each can_init_struct member with its default value.
Definition: at32f435_437_can.c:157
can_tx_mailbox_num_type
can_tx_mailbox_num_type
can tx mailboxes
Definition: at32f435_437_can.h:252
CAN_FILTER_FIFO0
@ CAN_FILTER_FIFO0
Definition: at32f435_437_can.h:138
CAN_TX_STATUS_SUCCESSFUL
@ CAN_TX_STATUS_SUCCESSFUL
Definition: at32f435_437_can.h:273
CAN_DISCARDING_FIRST_RECEIVED
@ CAN_DISCARDING_FIRST_RECEIVED
Definition: at32f435_437_can.h:301
CAN_BTS2_3TQ
@ CAN_BTS2_3TQ
Definition: at32f435_437_can.h:222
CAN_TFT_DATA
@ CAN_TFT_DATA
Definition: at32f435_437_can.h:244
CAN_BTS1_8TQ
@ CAN_BTS1_8TQ
Definition: at32f435_437_can.h:204
CAN_FILTER_MODE_ID_MASK
@ CAN_FILTER_MODE_ID_MASK
Definition: at32f435_437_can.h:147
CAN_SENDING_BY_ID
@ CAN_SENDING_BY_ID
Definition: at32f435_437_can.h:310
CAN_FILTER_32BIT
@ CAN_FILTER_32BIT
Definition: at32f435_437_can.h:157
CAN_RX_FIFO0
@ CAN_RX_FIFO0
Definition: at32f435_437_can.h:263
CAN_ID_STANDARD
@ CAN_ID_STANDARD
Definition: at32f435_437_can.h:235
CAN_MODE_LOOPBACK
@ CAN_MODE_LOOPBACK
Definition: at32f435_437_can.h:166
CAN_RSAW_3TQ
@ CAN_RSAW_3TQ
Definition: at32f435_437_can.h:188
CAN_RF0MN_FLAG
#define CAN_RF0MN_FLAG
Definition: at32f435_437_can.h:72
CAN_ETR_FLAG
#define CAN_ETR_FLAG
Definition: at32f435_437_can.h:67
CAN_RF0MIEN_INT
#define CAN_RF0MIEN_INT
Definition: at32f435_437_can.h:92
CAN_EOIEN_INT
#define CAN_EOIEN_INT
Definition: at32f435_437_can.h:102
CAN_ETRIEN_INT
#define CAN_ETRIEN_INT
Definition: at32f435_437_can.h:101
CAN1
#define CAN1
Definition: at32f435_437_can.h:994
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_CAN1_PERIPH_CLOCK
@ CRM_CAN1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:147
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_9
@ GPIO_MUX_9
Definition: at32f435_437_gpio.h:165
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
CAN1_RX0_IRQn
@ CAN1_RX0_IRQn
Definition: at32f435_437.h:168
CAN1_SE_IRQn
@ CAN1_SE_IRQn
Definition: at32f435_437.h:170
can_base_type
can init structure definition
Definition: at32f435_437_can.h:333
can_base_type::prsf_enable
confirm_state prsf_enable
Definition: at32f435_437_can.h:342
can_base_type::mdrsel_selection
can_msg_discarding_rule_type mdrsel_selection
Definition: at32f435_437_can.h:344
can_base_type::aed_enable
confirm_state aed_enable
Definition: at32f435_437_can.h:340
can_base_type::mmssr_selection
can_msg_sending_rule_type mmssr_selection
Definition: at32f435_437_can.h:346
can_base_type::ttc_enable
confirm_state ttc_enable
Definition: at32f435_437_can.h:336
can_base_type::mode_selection
can_mode_type mode_selection
Definition: at32f435_437_can.h:334
can_base_type::aebo_enable
confirm_state aebo_enable
Definition: at32f435_437_can.h:338
can_baudrate_type
can baudrate structure definition
Definition: at32f435_437_can.h:354
can_baudrate_type::baudrate_div
uint16_t baudrate_div
Definition: at32f435_437_can.h:355
can_baudrate_type::rsaw_size
can_rsaw_type rsaw_size
Definition: at32f435_437_can.h:357
can_baudrate_type::bts2_size
can_bts2_type bts2_size
Definition: at32f435_437_can.h:361
can_baudrate_type::bts1_size
can_bts1_type bts1_size
Definition: at32f435_437_can.h:359
can_filter_init_type
can filter init structure definition
Definition: at32f435_437_can.h:369
can_filter_init_type::filter_mask_low
uint16_t filter_mask_low
Definition: at32f435_437_can.h:389
can_filter_init_type::filter_number
uint8_t filter_number
Definition: at32f435_437_can.h:376
can_filter_init_type::filter_fifo
can_filter_fifo_type filter_fifo
Definition: at32f435_437_can.h:374
can_filter_init_type::filter_bit
can_filter_bit_width_type filter_bit
Definition: at32f435_437_can.h:378
can_filter_init_type::filter_mode
can_filter_mode_type filter_mode
Definition: at32f435_437_can.h:372
can_filter_init_type::filter_activate_enable
confirm_state filter_activate_enable
Definition: at32f435_437_can.h:370
can_filter_init_type::filter_mask_high
uint16_t filter_mask_high
Definition: at32f435_437_can.h:386
can_filter_init_type::filter_id_high
uint16_t filter_id_high
Definition: at32f435_437_can.h:380
can_filter_init_type::filter_id_low
uint16_t filter_id_low
Definition: at32f435_437_can.h:383
can_rx_message_type
can rx message structure definition
Definition: at32f435_437_can.h:419
can_rx_message_type::standard_id
uint32_t standard_id
Definition: at32f435_437_can.h:420
can_tx_message_type
can tx message structure definition
Definition: at32f435_437_can.h:397
can_tx_message_type::extended_id
uint32_t extended_id
Definition: at32f435_437_can.h:401
can_tx_message_type::frame_type
can_trans_frame_type frame_type
Definition: at32f435_437_can.h:406
can_tx_message_type::data
uint8_t data[8]
Definition: at32f435_437_can.h:411
can_tx_message_type::dlc
uint8_t dlc
Definition: at32f435_437_can.h:408
can_tx_message_type::id_type
can_identifier_type id_type
Definition: at32f435_437_can.h:404
can_tx_message_type::standard_id
uint32_t standard_id
Definition: at32f435_437_can.h:398
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • cortex_m4
  • bit_band
  • inc
project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • cortex_m4
  • bit_band
  • inc
project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • cortex_m4
  • bit_band
  • inc
project/at_start_f435/examples/cortex_m4/bit_band/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • bit_band
  • src
Functions
project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = (hext * pll_ns)/(pll_ms * pll_fr)
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 288000000
  • ahbdiv = 1
  • ahbclk = 288000000
  • apb2div = 2
  • apb2clk = 144000000
  • apb1div = 2
  • apb1clk = 144000000
  • pll_ns = 72
  • pll_ms = 1
  • pll_fr = 2
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 49 of file project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • cortex_m4
  • bit_band
  • src
project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_clock.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • bit_band
  • src
Functions
project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • cortex_m4
  • bit_band
  • src
project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/cortex_m4/bit_band/src/at32f435_437_int.c:114
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • bit_band
  • src
Macros | Functions | Variables
project/at_start_f435/examples/cortex_m4/bit_band/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define | RAM_BASE 0x20000000
#define | RAM_BITBAND_BASE 0x22000000
#define | VARIABLES_RESET_BIT(variables_addr, bit_number) (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 0)
#define | VARIABLES_SET_BIT(variables_addr, bit_number) (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 1)
#define | VARIABLES_GET_BIT(variables_addr, bit_number) (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)))
#define | PERIPHERAL_BASE 0x40000000
#define | PERIPHERAL_BITBAND_BASE 0x42000000
#define | PERIPHERAL_RESET_BIT(peripheral_addr, bit_number) (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 0)
#define | PERIPHERAL_SET_BIT(peripheral_addr, bit_number) (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 1)

Functions

void | result_error (void)
led4 flick for error. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | variables
__IO uint32_t | variables_addr = 0
__IO uint32_t | variables_bit_val = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/cortex_m4/bit_band/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • cortex_m4
  • bit_band
  • src
project/at_start_f435/examples/cortex_m4/bit_band/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
39/* bit band for sram */
40#define RAM_BASE 0x20000000
41#define RAM_BITBAND_BASE 0x22000000
42
43#define VARIABLES_RESET_BIT(variables_addr, bit_number) \
44 (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 0)
45
46#define VARIABLES_SET_BIT(variables_addr, bit_number) \
47 (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 1)
48
49#define VARIABLES_GET_BIT(variables_addr, bit_number) \
50 (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)))
51
52/* bit band for peripheral */
53#define PERIPHERAL_BASE 0x40000000
54#define PERIPHERAL_BITBAND_BASE 0x42000000
55
56#define PERIPHERAL_RESET_BIT(peripheral_addr, bit_number) \
57 (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 0)
58
59#define PERIPHERAL_SET_BIT(peripheral_addr, bit_number) \
60 (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 1)
61
62__IO uint32_t variables, variables_addr = 0, variables_bit_val = 0;
63
69void result_error(void)
70{
71 while(1)
72 {
73 at32_led_toggle(LED4);
74 delay_sec(1);
75 }
76}
77
83int main(void)
84{
85 system_clock_config();
86 at32_board_init();
87 variables = 0xA5A5A5A5;
88
89 /* get the variables address */
90 variables_addr = (uint32_t)&variables;
91
92 /* modify variables bit0 and check result */
93 VARIABLES_RESET_BIT(variables_addr, 0);
94 if((variables != 0xA5A5A5A4) || (VARIABLES_GET_BIT(variables_addr, 0) != 0))
95 {
96 result_error();
97 }
98
99 /* modify variables bit0 and check result */
100 VARIABLES_SET_BIT(variables_addr, 0);
101 if((variables != 0xA5A5A5A5) || (VARIABLES_GET_BIT(variables_addr, 0) != 1))
102 {
103 result_error();
104 }
105
106 /* modify variables bit16 and check result */
107 VARIABLES_RESET_BIT(variables_addr, 16);
108 if((variables != 0xA5A4A5A5) || (VARIABLES_GET_BIT(variables_addr, 16) != 0))
109 {
110 result_error();
111 }
112
113 /* modify variables bit16 and check result */
114 VARIABLES_SET_BIT(variables_addr, 16);
115 if((variables != 0xA5A5A5A5) || (VARIABLES_GET_BIT(variables_addr, 16) != 1))
116 {
117 result_error();
118 }
119
120 /* modify variables bit31 and check result */
121 VARIABLES_RESET_BIT(variables_addr, 31);
122 if((variables != 0x25A5A5A5) || (VARIABLES_GET_BIT(variables_addr, 31) != 0))
123 {
124 result_error();
125 }
126
127 /* modify variables bit31 and check result */
128 VARIABLES_SET_BIT(variables_addr, 31);
129 if((variables != 0xA5A5A5A5) || (VARIABLES_GET_BIT(variables_addr, 31) != 1))
130 {
131 result_error();
132 }
133
134 while(1)
135 {
136 /* led2 toggle */
137 PERIPHERAL_RESET_BIT((uint32_t)&LED2_GPIO->odt, 13);
138 delay_ms(500);
139 PERIPHERAL_SET_BIT((uint32_t)&LED2_GPIO->odt, 13);
140 delay_ms(500);
141 }
142}
143
at32f435_437_board.h
variables
__IO uint32_t variables
Definition: project/at_start_f435/examples/cortex_m4/bit_band/src/main.c:62
variables_addr
__IO uint32_t variables_addr
Definition: project/at_start_f435/examples/cortex_m4/bit_band/src/main.c:62
variables_bit_val
__IO uint32_t variables_bit_val
Definition: project/at_start_f435/examples/cortex_m4/bit_band/src/main.c:62
PERIPHERAL_SET_BIT
#define PERIPHERAL_SET_BIT(peripheral_addr, bit_number)
Definition: project/at_start_f435/examples/cortex_m4/bit_band/src/main.c:59
main
int main(void)
main function.
Definition: project/at_start_f435/examples/cortex_m4/bit_band/src/main.c:83
result_error
void result_error(void)
led4 flick for error.
Definition: project/at_start_f435/examples/cortex_m4/bit_band/src/main.c:69
VARIABLES_SET_BIT
#define VARIABLES_SET_BIT(variables_addr, bit_number)
Definition: project/at_start_f435/examples/cortex_m4/bit_band/src/main.c:46
PERIPHERAL_RESET_BIT
#define PERIPHERAL_RESET_BIT(peripheral_addr, bit_number)
Definition: project/at_start_f435/examples/cortex_m4/bit_band/src/main.c:56
VARIABLES_RESET_BIT
#define VARIABLES_RESET_BIT(variables_addr, bit_number)
Definition: project/at_start_f435/examples/cortex_m4/bit_band/src/main.c:43
VARIABLES_GET_BIT
#define VARIABLES_GET_BIT(variables_addr, bit_number)
Definition: project/at_start_f435/examples/cortex_m4/bit_band/src/main.c:49
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED4
@ LED4
Definition: at32f435_437_board.h:67
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • inc
project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • inc
project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
52#if !defined HEXT_VALUE
53#define HEXT_VALUE ((uint32_t)8000000)
54#endif
55
60#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
61#define HICK_VALUE ((uint32_t)8000000)
63/* module define -------------------------------------------------------------*/
64#define CRM_MODULE_ENABLED
65#define TMR_MODULE_ENABLED
66#define ERTC_MODULE_ENABLED
67#define GPIO_MODULE_ENABLED
68#define I2C_MODULE_ENABLED
69#define USART_MODULE_ENABLED
70#define PWC_MODULE_ENABLED
71#define CAN_MODULE_ENABLED
72#define ADC_MODULE_ENABLED
73#define DAC_MODULE_ENABLED
74#define SPI_MODULE_ENABLED
75#define EDMA_MODULE_ENABLED
76#define DMA_MODULE_ENABLED
77#define DEBUG_MODULE_ENABLED
78#define FLASH_MODULE_ENABLED
79#define CRC_MODULE_ENABLED
80#define WWDT_MODULE_ENABLED
81#define WDT_MODULE_ENABLED
82#define EXINT_MODULE_ENABLED
83#define SDIO_MODULE_ENABLED
84#define XMC_MODULE_ENABLED
85#define USB_MODULE_ENABLED
86#define ACC_MODULE_ENABLED
87#define MISC_MODULE_ENABLED
88#define QSPI_MODULE_ENABLED
89#define DVP_MODULE_ENABLED
90#define SCFG_MODULE_ENABLED
91#define EMAC_MODULE_ENABLED
92
93/* includes ------------------------------------------------------------------*/
94#ifdef CRM_MODULE_ENABLED
95#include "at32f435_437_crm.h"
96#endif
97#ifdef TMR_MODULE_ENABLED
98#include "at32f435_437_tmr.h"
99#endif
100#ifdef ERTC_MODULE_ENABLED
101#include "at32f435_437_ertc.h"
102#endif
103#ifdef GPIO_MODULE_ENABLED
104#include "at32f435_437_gpio.h"
105#endif
106#ifdef I2C_MODULE_ENABLED
107#include "at32f435_437_i2c.h"
108#endif
109#ifdef USART_MODULE_ENABLED
110#include "at32f435_437_usart.h"
111#endif
112#ifdef PWC_MODULE_ENABLED
113#include "at32f435_437_pwc.h"
114#endif
115#ifdef CAN_MODULE_ENABLED
116#include "at32f435_437_can.h"
117#endif
118#ifdef ADC_MODULE_ENABLED
119#include "at32f435_437_adc.h"
120#endif
121#ifdef DAC_MODULE_ENABLED
122#include "at32f435_437_dac.h"
123#endif
124#ifdef SPI_MODULE_ENABLED
125#include "at32f435_437_spi.h"
126#endif
127#ifdef DMA_MODULE_ENABLED
128#include "at32f435_437_dma.h"
129#endif
130#ifdef DEBUG_MODULE_ENABLED
131#include "at32f435_437_debug.h"
132#endif
133#ifdef FLASH_MODULE_ENABLED
134#include "at32f435_437_flash.h"
135#endif
136#ifdef CRC_MODULE_ENABLED
137#include "at32f435_437_crc.h"
138#endif
139#ifdef WWDT_MODULE_ENABLED
140#include "at32f435_437_wwdt.h"
141#endif
142#ifdef WDT_MODULE_ENABLED
143#include "at32f435_437_wdt.h"
144#endif
145#ifdef EXINT_MODULE_ENABLED
146#include "at32f435_437_exint.h"
147#endif
148#ifdef SDIO_MODULE_ENABLED
149#include "at32f435_437_sdio.h"
150#endif
151#ifdef XMC_MODULE_ENABLED
152#include "at32f435_437_xmc.h"
153#endif
154#ifdef ACC_MODULE_ENABLED
155#include "at32f435_437_acc.h"
156#endif
157#ifdef MISC_MODULE_ENABLED
158#include "at32f435_437_misc.h"
159#endif
160#ifdef EDMA_MODULE_ENABLED
161#include "at32f435_437_edma.h"
162#endif
163#ifdef QSPI_MODULE_ENABLED
164#include "at32f435_437_qspi.h"
165#endif
166#ifdef SCFG_MODULE_ENABLED
167#include "at32f435_437_scfg.h"
168#endif
169#ifdef EMAC_MODULE_ENABLED
170#include "at32f435_437_emac.h"
171#endif
172#ifdef DVP_MODULE_ENABLED
173#include "at32f435_437_dvp.h"
174#endif
175#ifdef USB_MODULE_ENABLED
176#include "at32f435_437_usb.h"
177#endif
178
187#ifdef __cplusplus
188}
189#endif
190
191#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • inc
project/at_start_f435/examples/cortex_m4/cmsis_dsp/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • src
Functions
project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • src
project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
57void system_clock_config(void)
58{
59 /* enable pwc periph clock */
60 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
61
62 /* config ldo voltage */
63 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
64
65 /* set the flash clock divider */
66 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
67
68 /* reset crm */
69 crm_reset();
70
71 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
72
73 /* wait till hext is ready */
74 while(crm_hext_stable_wait() == ERROR)
75 {
76 }
77
78 /* config pll clock resource
79 common frequency config list: pll source selected hick or hext(8mhz)
80 _______________________________________________________________________________________
81 | | | | | | | | | |
82 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
83 |________|_________|_________|_________|_________|_________|_________|_________________|
84 | | | | | | | | | |
85 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
86 | | | | | | | | | |
87 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
88 | | | | | | | | | |
89 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
90 |________|_________|_________|_________|_________|_________|_________|________|________|
91
92 if pll clock source selects hext with other frequency values, or configure pll to other
93 frequency values, please use the at32 new clock configuration tool for configuration. */
94 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
95
96 /* enable pll */
97 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
98
99 /* wait till pll is ready */
100 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
101 {
102 }
103
104 /* config ahbclk */
105 crm_ahb_div_set(CRM_AHB_DIV_1);
106
107 /* config apb2clk */
108 crm_apb2_div_set(CRM_APB2_DIV_2);
109
110 /* config apb1clk */
111 crm_apb1_div_set(CRM_APB1_DIV_2);
112
113 /* enable auto step mode */
114 crm_auto_step_mode_enable(TRUE);
115
116 /* select pll as system clock source */
117 crm_sysclk_switch(CRM_SCLK_PLL);
118
119 /* wait till pll is used as system clock source */
120 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
121 {
122 }
123
124 /* disable auto step mode */
125 crm_auto_step_mode_enable(FALSE);
126
127 /* update system_core_clock global variable */
128 system_core_clock_update();
129}
130
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_clock.c:57
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • src
Functions
project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • src
project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • src
Macros | Functions | Variables
project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include "arm_math.h"

Go to the source code of this file.

Macros

#define | USE_STATIC_INIT
#define | TEST_LENGTH_SAMPLES (20*4)
#define | NUMSTUDENTS 20
#define | NUMSUBJECTS 4

Functions

int32_t main ()
main function. More...

Variables

const float32_t | testMarks_f32 [(20 *4)]
const float32_t | testUnity_f32 [4]
static float32_t | testOutput [(20 *4)]
uint32_t | numStudents = 20
uint32_t | numSubjects = 4
float32_t | max_marks
float32_t | min_marks
float32_t | mean
float32_t | std
float32_t | var
uint32_t | student_num

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • cortex_m4
  • cmsis_dsp
  • src
project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include "arm_math.h"
30
39#define USE_STATIC_INIT
40
41 /* Global defines */
42
43#define TEST_LENGTH_SAMPLES (20*4)
44
45/* List of Marks scored by 20 students for 4 subjects */
46const float32_t testMarks_f32[TEST_LENGTH_SAMPLES] =
47{
48 42.000000, 37.000000, 81.000000, 28.000000,
49 83.000000, 72.000000, 36.000000, 38.000000,
50 32.000000, 51.000000, 63.000000, 64.000000,
51 97.000000, 82.000000, 95.000000, 90.000000,
52 66.000000, 51.000000, 54.000000, 42.000000,
53 67.000000, 56.000000, 45.000000, 57.000000,
54 67.000000, 69.000000, 35.000000, 52.000000,
55 29.000000, 81.000000, 58.000000, 47.000000,
56 38.000000, 76.000000, 100.000000, 29.000000,
57 33.000000, 47.000000, 29.000000, 50.000000,
58 34.000000, 41.000000, 61.000000, 46.000000,
59 52.000000, 50.000000, 48.000000, 36.000000,
60 47.000000, 55.000000, 44.000000, 40.000000,
61 100.000000, 94.000000, 84.000000, 37.000000,
62 32.000000, 71.000000, 47.000000, 77.000000,
63 31.000000, 50.000000, 49.000000, 35.000000,
64 63.000000, 67.000000, 40.000000, 31.000000,
65 29.000000, 68.000000, 61.000000, 38.000000,
66 31.000000, 28.000000, 28.000000, 76.000000,
67 55.000000, 33.000000, 29.000000, 39.000000
68};
69
70
71/* Number of subjects X 1 */
72const float32_t testUnity_f32[4] =
73{
74 1.000, 1.000, 1.000, 1.000
75};
76
77
78/* f32 Output buffer */
79static float32_t testOutput[TEST_LENGTH_SAMPLES];
80
81
82/* Global defines */
83#define NUMSTUDENTS 20
84#define NUMSUBJECTS 4
85
86/* Global variables */
87
88uint32_t numStudents = 20;
89uint32_t numSubjects = 4;
90float32_t max_marks, min_marks, mean, std, var;
91uint32_t student_num;
92
98int32_t main()
99{
100 system_clock_config();
101
102 uart_print_init(115200);
103
104#ifndef USE_STATIC_INIT
105
106 arm_matrix_instance_f32 srcA;
107 arm_matrix_instance_f32 srcB;
108 arm_matrix_instance_f32 dstC;
109
110 /* Input and output matrices initializations */
111 arm_mat_init_f32(&srcA, numStudents, numSubjects, (float32_t *)testMarks_f32);
112 arm_mat_init_f32(&srcB, numSubjects, 1, (float32_t *)testUnity_f32);
113 arm_mat_init_f32(&dstC, numStudents, 1, testOutput);
114
115#else
116
117 /* Static Initializations of Input and output matrix sizes and array */
118 arm_matrix_instance_f32 srcA = {NUMSTUDENTS, NUMSUBJECTS, (float32_t *)testMarks_f32};
119 arm_matrix_instance_f32 srcB = {NUMSUBJECTS, 1, (float32_t *)testUnity_f32};
120 arm_matrix_instance_f32 dstC = {NUMSTUDENTS, 1, testOutput};
121
122#endif
123
124 /* Call the Matrix multiplication process function */
125 arm_mat_mult_f32(&srcA, &srcB, &dstC);
126
127 /* Call the Max function to calculate max marks among numStudents */
128 arm_max_f32(testOutput, numStudents, &max_marks, &student_num);
129
130 /* Call the Min function to calculate min marks among numStudents */
131 arm_min_f32(testOutput, numStudents, &min_marks, &student_num);
132
133 /* Call the Mean function to calculate mean */
134 arm_mean_f32(testOutput, numStudents, &mean);
135
136 /* Call the std function to calculate standard deviation */
137 arm_std_f32(testOutput, numStudents, &std);
138
139 /* Call the var function to calculate variance */
140 arm_var_f32(testOutput, numStudents, &var);
141
142 printf("max_marks = %f, min_marks = %f, mean = %f, std = %f, var = %f\n", max_marks, min_marks, mean, std, var);
143
144 while (1);
145}
146
at32f435_437_board.h
testMarks_f32
const float32_t testMarks_f32[(20 *4)]
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c:46
std
float32_t std
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c:90
main
int32_t main()
main function.
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c:98
var
float32_t var
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c:90
numSubjects
uint32_t numSubjects
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c:89
student_num
uint32_t student_num
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c:91
NUMSUBJECTS
#define NUMSUBJECTS
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c:84
testUnity_f32
const float32_t testUnity_f32[4]
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c:72
NUMSTUDENTS
#define NUMSTUDENTS
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c:83
max_marks
float32_t max_marks
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c:90
numStudents
uint32_t numStudents
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c:88
min_marks
float32_t min_marks
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c:90
TEST_LENGTH_SAMPLES
#define TEST_LENGTH_SAMPLES
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c:43
mean
float32_t mean
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c:90
testOutput
static float32_t testOutput[(20 *4)]
Definition: project/at_start_f435/examples/cortex_m4/cmsis_dsp/src/main.c:79
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • cortex_m4
  • fpu
  • inc
project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • cortex_m4
  • fpu
  • inc
project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • cortex_m4
  • fpu
  • inc
project/at_start_f435/examples/cortex_m4/fpu/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • fpu
  • src
Functions
project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • cortex_m4
  • fpu
  • src
project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • fpu
  • src
Functions
project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • cortex_m4
  • fpu
  • src
project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • fpu
  • src
Macros | Functions | Variables
project/at_start_f435/examples/cortex_m4/fpu/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include "julia_fpu.h"

Go to the source code of this file.

Macros

#define | SCREEN_X_SIZE ((uint16_t)320)
#define | SCREEN_Y_SIZE ((uint16_t)240)
#define | ZOOM ((uint16_t)100)

Functions

int main (void)
main function. More...

Variables

uint8_t buffer [((uint16_t) 320) *((uint16_t) 240)]

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/cortex_m4/fpu/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • cortex_m4
  • fpu
  • src
project/at_start_f435/examples/cortex_m4/fpu/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include "julia_fpu.h"
30
39#define SCREEN_X_SIZE ((uint16_t)320)
40#define SCREEN_Y_SIZE ((uint16_t)240)
41#define ZOOM ((uint16_t)100)
42
43uint8_t buffer[SCREEN_X_SIZE * SCREEN_Y_SIZE];
44
50int main(void)
51{
52 system_clock_config();
53
54 at32_board_init();
55
56 while(1)
57 {
58 at32_led_toggle(LED4);
59
60 generate_julia_fpu(SCREEN_X_SIZE, SCREEN_Y_SIZE, SCREEN_X_SIZE / 2, SCREEN_Y_SIZE / 2, ZOOM, buffer);
61 }
62}
63
at32f435_437_board.h
SCREEN_X_SIZE
#define SCREEN_X_SIZE
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:50
buffer
uint8_t buffer[((uint16_t) 320) *((uint16_t) 240)]
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:43
ZOOM
#define ZOOM
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:41
SCREEN_Y_SIZE
#define SCREEN_Y_SIZE
Definition: project/at_start_f435/examples/cortex_m4/fpu/src/main.c:40
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
generate_julia_fpu
void generate_julia_fpu(uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable
Definition: at_start_f437/examples/cortex_m4/fpu/src/julia_fpu.c:48
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • cortex_m4
  • systick_interrupt
  • inc
project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • cortex_m4
  • systick_interrupt
  • inc
project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • cortex_m4
  • systick_interrupt
  • inc
project/at_start_f435/examples/cortex_m4/systick_interrupt/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • systick_interrupt
  • src
Functions
project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • cortex_m4
  • systick_interrupt
  • src
project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • systick_interrupt
  • src
Functions
project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | systick_handler (void)
systick interrupt handler. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • cortex_m4
  • systick_interrupt
  • src
project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
30extern void systick_handler(void);
31
45void NMI_Handler(void)
46{
47}
48
54void HardFault_Handler(void)
55{
56 /* go to infinite loop when hard fault exception occurs */
57 while(1)
58 {
59 }
60}
61
67void MemManage_Handler(void)
68{
69 /* go to infinite loop when memory manage exception occurs */
70 while(1)
71 {
72 }
73}
74
80void BusFault_Handler(void)
81{
82 /* go to infinite loop when bus fault exception occurs */
83 while(1)
84 {
85 }
86}
87
93void UsageFault_Handler(void)
94{
95 /* go to infinite loop when usage fault exception occurs */
96 while(1)
97 {
98 }
99}
100
106void SVC_Handler(void)
107{
108}
109
115void DebugMon_Handler(void)
116{
117}
118
124void PendSV_Handler(void)
125{
126}
127
133void SysTick_Handler(void)
134{
135 systick_handler();
136}
137
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c:93
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c:54
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c:67
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c:106
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c:124
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c:45
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c:80
systick_handler
void systick_handler(void)
systick interrupt handler.
Definition: project/at_start_f437/examples/cortex_m4/systick_interrupt/src/main.c:45
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c:133
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/cortex_m4/systick_interrupt/src/at32f435_437_int.c:115
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • cortex_m4
  • systick_interrupt
  • src
Macros | Functions
project/at_start_f435/examples/cortex_m4/systick_interrupt/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define | MS_TICK (system_core_clock / 1000U)
#define | DELAY 200 /* 200 ms ticks */

Functions

void | systick_handler (void)
systick interrupt handler. More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/cortex_m4/systick_interrupt/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • cortex_m4
  • systick_interrupt
  • src
project/at_start_f435/examples/cortex_m4/systick_interrupt/src/main.c
Go to the documentation of this file.
1
26#include "at32f435_437_board.h"
27#include "at32f435_437_clock.h"
28
37#define MS_TICK (system_core_clock / 1000U)
38#define DELAY 200 /* 200 ms ticks */
39
45void systick_handler(void)
46{
47 static uint32_t ticks = 0;
48
49 ticks ++;
50
51 /* toggle led */
52 if(ticks > DELAY)
53 {
54 at32_led_toggle(LED2);
55 ticks = 0;
56 }
57}
58
64int main(void)
65{
66 system_clock_config();
67
68 /* config systick clock source */
69 systick_clock_source_config(SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV);
70
71 /* config systick reload value and enable interrupt */
72 SysTick_Config(MS_TICK);
73
74 /* configure led */
75 at32_led_init(LED2);
76
77 while(1)
78 {
79 }
80}
81
at32f435_437_board.h
MS_TICK
#define MS_TICK
Definition: project/at_start_f435/examples/cortex_m4/systick_interrupt/src/main.c:37
DELAY
#define DELAY
Definition: project/at_start_f435/examples/cortex_m4/systick_interrupt/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f435/examples/cortex_m4/systick_interrupt/src/main.c:64
systick_handler
void systick_handler(void)
systick interrupt handler.
Definition: project/at_start_f435/examples/cortex_m4/systick_interrupt/src/main.c:45
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED2
@ LED2
Definition: at32f435_437_board.h:65
at32_led_init
void at32_led_init(led_type led)
configure led gpio
Definition: at32f435_437_board.c:218
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
systick_clock_source_config
void systick_clock_source_config(systick_clock_source_type source)
config systick clock source
Definition: at32f435_437_misc.c:147
SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
@ SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
Definition: at32f435_437_misc.h:90
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • crc
  • calculation
  • inc
project/at_start_f435/examples/crc/calculation/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • crc
  • calculation
  • inc
project/at_start_f435/examples/crc/calculation/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • crc
  • calculation
  • inc
project/at_start_f435/examples/crc/calculation/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • crc
  • calculation
  • src
Functions
project/at_start_f435/examples/crc/calculation/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/crc/calculation/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • crc
  • calculation
  • src
project/at_start_f435/examples/crc/calculation/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/crc/calculation/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • crc
  • calculation
  • src
Functions
project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • crc
  • calculation
  • src
project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/crc/calculation/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • crc
  • calculation
  • src
Macros | Functions | Variables
project/at_start_f435/examples/crc/calculation/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 120

Functions

int main (void)
main function. More...

Variables

static const uint32_t | data_buffer [120]
__IO uint32_t | crc_value = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/crc/calculation/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • crc
  • calculation
  • src
project/at_start_f435/examples/crc/calculation/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define BUFFER_SIZE 120
39
40static const uint32_t data_buffer[BUFFER_SIZE] =
41{
42 0xc33dd31c, 0xe37ff35e, 0x129022f3, 0x32d24235, 0x52146277, 0x7256b5ea,
43 0x4a755a54, 0x6a377a16, 0x0af11ad0, 0x2ab33a92, 0xed0fdd6c, 0xcd4dbdaa,
44 0xbb3bab1a, 0x6ca67c87, 0x5cc52c22, 0x3c030c60, 0x1c41edae, 0xfd8fcdec,
45 0xad8b9de8, 0x8dc97c26, 0x5c644c45, 0x3ca22c83, 0x1ce00cc1, 0xef1fff3e,
46 0x95a88589, 0xf56ee54f, 0xd52cc50d, 0x34e224c3, 0x04817466, 0x64475424,
47 0x78066827, 0x18c008e1, 0x28a3cb7d, 0xdb5ceb3f, 0xfb1e8bf9, 0x9bd8abbb,
48 0xdf7caf9b, 0xbfba8fd9, 0x9ff86e17, 0x7e364e55, 0x2e933eb2, 0x0ed11ef0,
49 0xa35ad3bd, 0xc39cf3ff, 0xe3de2462, 0x34430420, 0x64e674c7, 0x44a45485,
50 0xad2abd0b, 0x8d689d49, 0x7e976eb6, 0x5ed54ef4, 0x2e321e51, 0x0e70ff9f,
51 0xefbedfdd, 0xcffcbf1b, 0x9f598f78, 0x918881a9, 0xb1caa1eb, 0xd10cc12d,
52 0xe16f1080, 0x00a130c2, 0x20e35004, 0x40257046, 0x83b99398, 0xa3fbb3da,
53 0x00001021, 0x20423063, 0x408450a5, 0x60c670e7, 0x9129a14a, 0xb16bc18c,
54 0x569546b4, 0xb75ba77a, 0x97198738, 0xf7dfe7fe, 0xc7bc48c4, 0x58e56886,
55 0x4405a7db, 0xb7fa8799, 0xe75ff77e, 0xc71dd73c, 0x26d336f2, 0x069116b0,
56 0x76764615, 0x5634d94c, 0xc96df90e, 0xe92f99c8, 0xb98aa9ab, 0x58444865,
57 0x78a70840, 0x18612802, 0xc9ccd9ed, 0xe98ef9af, 0x89489969, 0xa90ab92b,
58 0xd1ade1ce, 0xf1ef1231, 0x32732252, 0x52b54294, 0x72f762d6, 0x93398318,
59 0xa56ab54b, 0x85289509, 0xf5cfc5ac, 0xd58d3653, 0x26721611, 0x063076d7,
60 0x8d689d49, 0xf7dfe7fe, 0xe98ef9af, 0x063076d7, 0x93398318, 0xb98aa9ab,
61 0x4ad47ab7, 0x6a961a71, 0x0a503a33, 0x2a12dbfd, 0xfbbfeb9e, 0x9b798b58
62};
63
64__IO uint32_t crc_value = 0;
65
71int main(void)
72{
73 system_clock_config();
74
75 at32_board_init();
76
77 /* enable crc clock */
78 crm_periph_clock_enable(CRM_CRC_PERIPH_CLOCK, TRUE);
79
80 crc_data_reset();
81
82 /* compute the crc of "data_buffer" */
83 crc_value = crc_block_calculate((uint32_t *)data_buffer, BUFFER_SIZE);
84
85 if(crc_value == 0xE5DFCF6D)
86 {
87 /* turn on led3 */
88 at32_led_on(LED3);
89 }
90 else
91 {
92 /* turn on led4 */
93 at32_led_on(LED4);
94 }
95
96 while(1)
97 {
98 }
99}
100
at32f435_437_board.h
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f435/examples/crc/calculation/src/main.c:38
data_buffer
static const uint32_t data_buffer[120]
Definition: project/at_start_f435/examples/crc/calculation/src/main.c:40
main
int main(void)
main function.
Definition: project/at_start_f435/examples/crc/calculation/src/main.c:71
crc_value
__IO uint32_t crc_value
Definition: project/at_start_f435/examples/crc/calculation/src/main.c:64
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crc_block_calculate
uint32_t crc_block_calculate(uint32_t *pbuffer, uint32_t length)
compute the 32-bit crc of a given buffer of data word(32-bit).
Definition: at32f435_437_crc.c:72
crc_data_reset
void crc_data_reset(void)
reset the crc data register.
Definition: at32f435_437_crc.c:49
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_CRC_PERIPH_CLOCK
@ CRM_CRC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:113
TRUE
@ TRUE
Definition: at32f435_437.h:379
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • crm
  • clock_failure_detection
  • inc
project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • crm
  • clock_failure_detection
  • inc
project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • crm
  • clock_failure_detection
  • inc
project/at_start_f435/examples/crm/clock_failure_detection/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • crm
  • clock_failure_detection
  • src
Functions
project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • crm
  • clock_failure_detection
  • src
project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • crm
  • clock_failure_detection
  • src
Functions
project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | clock_failure_detection_handler (void)
clock failure detection handler. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • crm
  • clock_failure_detection
  • src
project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
30extern void clock_failure_detection_handler(void);
31
45void NMI_Handler(void)
46{
47 clock_failure_detection_handler();
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c:107
clock_failure_detection_handler
void clock_failure_detection_handler(void)
clock failure detection handler.
Definition: project/at_start_f435/examples/crm/clock_failure_detection/src/main.c:76
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c:45
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c:81
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c:134
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/crm/clock_failure_detection/src/at32f435_437_int.c:116
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • crm
  • clock_failure_detection
  • src
Functions
project/at_start_f435/examples/crm/clock_failure_detection/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | clkout_config (void)
clkout configuration. More...
static void | sclk_288m_hick_config (void)
system clock config program More...
void | clock_failure_detection_handler (void)
clock failure detection handler. More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/crm/clock_failure_detection/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • crm
  • clock_failure_detection
  • src
project/at_start_f435/examples/crm/clock_failure_detection/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38static void clkout_config(void);
39static void sclk_288m_hick_config(void);
40void clock_failure_detection_handler(void);
41
47static void clkout_config(void)
48{
49 gpio_init_type gpio_init_struct;
50
51 /* enable gpio port clock */
52 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
53
54 /* set default parameter */
55 gpio_default_para_init(&gpio_init_struct);
56
57 /* clkout gpio init */
58 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
59 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
60 gpio_init_struct.gpio_pins = GPIO_PINS_8;
61 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
62 gpio_init(GPIOA, &gpio_init_struct);
63
64 /* config clkout division */
65 crm_clkout_div_set(CRM_CLKOUT_INDEX_1, CRM_CLKOUT_DIV1_4, CRM_CLKOUT_DIV2_1);
66
67 /* config clkout1 clock */
68 crm_clock_out1_set(CRM_CLKOUT1_PLL);
69}
70
76void clock_failure_detection_handler(void)
77{
78 /* check clock failure detection flag */
79 if(crm_flag_get(CRM_CLOCK_FAILURE_INT_FLAG) != RESET)
80 {
81 /* disable clock failure detection */
82 crm_clock_failure_detection_enable(FALSE);
83
84 /* config system clock */
85 sclk_288m_hick_config();
86
87 /* clear clock failure detection flag */
88 crm_flag_clear(CRM_CLOCK_FAILURE_INT_FLAG);
89 }
90}
91
111static void sclk_288m_hick_config(void)
112{
113 /* enable pwc periph clock */
114 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
115
116 /* config ldo voltage */
117 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
118
119 /* set the flash clock divider */
120 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
121
122 /* reset crm */
123 crm_reset();
124
125 crm_clock_source_enable(CRM_CLOCK_SOURCE_HICK, TRUE);
126
127 /* wait till hick is ready */
128 while(crm_flag_get(CRM_HICK_STABLE_FLAG) != SET)
129 {
130 }
131
132 /* config pll clock resource */
133 crm_pll_config(CRM_PLL_SOURCE_HICK, 72, 1, CRM_PLL_FR_2);
134
135 /* enable pll */
136 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
137
138 /* wait till pll is ready */
139 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
140 {
141 }
142
143 /* config ahbclk */
144 crm_ahb_div_set(CRM_AHB_DIV_1);
145
146 /* config apb2clk */
147 crm_apb2_div_set(CRM_APB2_DIV_2);
148
149 /* config apb1clk */
150 crm_apb1_div_set(CRM_APB1_DIV_2);
151
152 /* enable auto step mode */
153 crm_auto_step_mode_enable(TRUE);
154
155 /* select pll as system clock source */
156 crm_sysclk_switch(CRM_SCLK_PLL);
157
158 /* wait till pll is used as system clock source */
159 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
160 {
161 }
162
163 /* disable auto step mode */
164 crm_auto_step_mode_enable(FALSE);
165
166 /* update system_core_clock global variable */
167 system_core_clock_update();
168
169 /* config systick delay */
170 delay_init();
171
172 /* config clkout */
173 clkout_config();
174}
175
181int main(void)
182{
183 system_clock_config();
184
185 at32_board_init();
186
187 /* clkout config */
188 clkout_config();
189
190 /* enable clock failure detection */
191 crm_clock_failure_detection_enable(TRUE);
192
193 while(1)
194 {
195 at32_led_toggle(LED2);
196 delay_ms(200);
197 }
198}
199
at32f435_437_board.h
clkout_config
static void clkout_config(void)
clkout configuration.
Definition: project/at_start_f435/examples/crm/clock_failure_detection/src/main.c:47
clock_failure_detection_handler
void clock_failure_detection_handler(void)
clock failure detection handler.
Definition: project/at_start_f435/examples/crm/clock_failure_detection/src/main.c:76
sclk_288m_hick_config
static void sclk_288m_hick_config(void)
system clock config program
Definition: project/at_start_f435/examples/crm/clock_failure_detection/src/main.c:111
main
int main(void)
main function.
Definition: project/at_start_f435/examples/crm/clock_failure_detection/src/main.c:181
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
LED2
@ LED2
Definition: at32f435_437_board.h:65
delay_init
void delay_init()
initialize delay function
Definition: at32f435_437_board.c:293
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_clkout_div_set
void crm_clkout_div_set(crm_clkout_index_type index, crm_clkout_div1_type div1, crm_clkout_div2_type div2)
set crm clkout1 division1
Definition: at32f435_437_crm.c:831
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_clock_out1_set
void crm_clock_out1_set(crm_clkout1_select_type clkout)
set crm clkout1
Definition: at32f435_437_crm.c:773
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_flag_clear
void crm_flag_clear(uint32_t flag)
clear the crm reset flags
Definition: at32f435_437_crm.c:358
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_clock_failure_detection_enable
void crm_clock_failure_detection_enable(confirm_state new_state)
enable or disable clock failure detection
Definition: at32f435_437_crm.c:531
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_HICK
@ CRM_CLOCK_SOURCE_HICK
Definition: at32f435_437_crm.h:559
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLKOUT_DIV1_4
@ CRM_CLKOUT_DIV1_4
Definition: at32f435_437_crm.h:728
CRM_PLL_SOURCE_HICK
@ CRM_PLL_SOURCE_HICK
Definition: at32f435_437_crm.h:537
CRM_CLKOUT_DIV2_1
@ CRM_CLKOUT_DIV2_1
Definition: at32f435_437_crm.h:737
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_CLKOUT1_PLL
@ CRM_CLKOUT1_PLL
Definition: at32f435_437_crm.h:702
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_CLKOUT_INDEX_1
@ CRM_CLKOUT_INDEX_1
Definition: at32f435_437_crm.h:690
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
CRM_CLOCK_FAILURE_INT_FLAG
#define CRM_CLOCK_FAILURE_INT_FLAG
Definition: at32f435_437_crm.h:72
CRM_HICK_STABLE_FLAG
#define CRM_HICK_STABLE_FLAG
Definition: at32f435_437_crm.h:55
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • crm
  • pll_parameter_calculate
  • inc
project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • crm
  • pll_parameter_calculate
  • inc
project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • crm
  • pll_parameter_calculate
  • inc
project/at_start_f435/examples/crm/pll_parameter_calculate/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • crm
  • pll_parameter_calculate
  • src
Functions
project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • crm
  • pll_parameter_calculate
  • src
project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • crm
  • pll_parameter_calculate
  • src
Functions
project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • crm
  • pll_parameter_calculate
  • src
project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/crm/pll_parameter_calculate/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • crm
  • pll_parameter_calculate
  • src
Functions | Variables
project/at_start_f435/examples/crm/pll_parameter_calculate/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | clkout_config (void)
clkout configuration. More...
void | system_clock_config_200mhz (void)
system clock config 200mhz More...
int | main (void)
main function. More...

Variables

error_status calculate_status = ERROR

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/crm/pll_parameter_calculate/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • crm
  • pll_parameter_calculate
  • src
project/at_start_f435/examples/crm/pll_parameter_calculate/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 error_status calculate_status = ERROR;
39
45void clkout_config(void)
46{
47 gpio_init_type gpio_init_struct;
48
49 /* enable gpio port clock */
50 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
51
52 /* set default parameter */
53 gpio_default_para_init(&gpio_init_struct);
54
55 /* clkout gpio init */
56 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
57 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
58 gpio_init_struct.gpio_pins = GPIO_PINS_8;
59 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
60 gpio_init(GPIOA, &gpio_init_struct);
61
62 /* config clkout division */
63 crm_clkout_div_set(CRM_CLKOUT_INDEX_1, CRM_CLKOUT_DIV1_4, CRM_CLKOUT_DIV2_1);
64
65 /* config clkout1 clock */
66 crm_clock_out1_set(CRM_CLKOUT1_PLL);
67}
68
86void system_clock_config_200mhz(void)
87{
88 uint16_t pll_ns, pll_ms, pll_fr;
89
90 /* enable pwc periph clock */
91 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
92
93 /* config ldo voltage */
94 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
95
96 /* set the flash clock divider */
97 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
98
99 /* reset crm */
100 crm_reset();
101
102 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
103
104 /* wait till hext is ready */
105 while(crm_hext_stable_wait() == ERROR)
106 {
107 }
108
109 /* calculate pll parameter according to the function */
110 calculate_status = crm_pll_parameter_calculate(CRM_PLL_SOURCE_HEXT, 200000000, &pll_ms, &pll_ns, &pll_fr);
111
112 /* config pll clock resource */
113 crm_pll_config(CRM_PLL_SOURCE_HEXT, pll_ns, pll_ms, (crm_pll_fr_type)pll_fr);
114
115 /* enable pll */
116 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
117
118 /* wait till pll is ready */
119 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
120 {
121 }
122
123 /* config ahbclk */
124 crm_ahb_div_set(CRM_AHB_DIV_1);
125
126 /* config apb2clk */
127 crm_apb2_div_set(CRM_APB2_DIV_2);
128
129 /* config apb1clk */
130 crm_apb1_div_set(CRM_APB1_DIV_2);
131
132 /* enable auto step mode */
133 crm_auto_step_mode_enable(TRUE);
134
135 /* select pll as system clock source */
136 crm_sysclk_switch(CRM_SCLK_PLL);
137
138 /* wait till pll is used as system clock source */
139 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
140 {
141 }
142
143 /* disable auto step mode */
144 crm_auto_step_mode_enable(FALSE);
145
146 /* update system_core_clock global variable */
147 system_core_clock_update();
148}
149
155int main(void)
156{
157 system_clock_config_200mhz();
158
159 at32_board_init();
160
161 clkout_config();
162
163 while(1)
164 {
165 if(calculate_status == ERROR)
166 {
167 at32_led_toggle(LED2);
168 }
169 else
170 {
171 at32_led_toggle(LED4);
172 }
173 delay_ms(500);
174 }
175}
176
at32f435_437_board.h
clkout_config
void clkout_config(void)
clkout configuration.
Definition: project/at_start_f435/examples/crm/pll_parameter_calculate/src/main.c:45
calculate_status
error_status calculate_status
Definition: project/at_start_f435/examples/crm/pll_parameter_calculate/src/main.c:38
system_clock_config_200mhz
void system_clock_config_200mhz(void)
system clock config 200mhz
Definition: project/at_start_f435/examples/crm/pll_parameter_calculate/src/main.c:86
main
int main(void)
main function.
Definition: project/at_start_f435/examples/crm/pll_parameter_calculate/src/main.c:155
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_clkout_div_set
void crm_clkout_div_set(crm_clkout_index_type index, crm_clkout_div1_type div1, crm_clkout_div2_type div2)
set crm clkout1 division1
Definition: at32f435_437_crm.c:831
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_pll_parameter_calculate
error_status crm_pll_parameter_calculate(crm_pll_clock_source_type pll_rcs, uint32_t target_sclk_freq, uint16_t *ret_ms, uint16_t *ret_ns, uint16_t *ret_fr)
calculate the pll parameters with pll reference clock and target pll output frequency....
Definition: at32f435_437_crm.c:904
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_clock_out1_set
void crm_clock_out1_set(crm_clkout1_select_type clkout)
set crm clkout1
Definition: at32f435_437_crm.c:773
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
crm_pll_fr_type
crm_pll_fr_type
crm pll fr
Definition: at32f435_437_crm.h:545
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_CLKOUT_DIV1_4
@ CRM_CLKOUT_DIV1_4
Definition: at32f435_437_crm.h:728
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_CLKOUT_DIV2_1
@ CRM_CLKOUT_DIV2_1
Definition: at32f435_437_crm.h:737
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_CLKOUT1_PLL
@ CRM_CLKOUT1_PLL
Definition: at32f435_437_crm.h:702
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_CLKOUT_INDEX_1
@ CRM_CLKOUT_INDEX_1
Definition: at32f435_437_crm.h:690
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • crm
  • sysclk_switch
  • inc
project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • crm
  • sysclk_switch
  • inc
project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • crm
  • sysclk_switch
  • inc
project/at_start_f435/examples/crm/sysclk_switch/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • crm
  • sysclk_switch
  • src
Functions
project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • crm
  • sysclk_switch
  • src
project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • crm
  • sysclk_switch
  • src
Functions
project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • crm
  • sysclk_switch
  • src
project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/crm/sysclk_switch/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • crm
  • sysclk_switch
  • src
Functions
project/at_start_f435/examples/crm/sysclk_switch/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | clkout_config (void)
clkout configuration. More...
static void | sclk_64m_hick_config (void)
config sclk 64 mhz with hick clock source. More...
static void | sclk_96m_hext_config (void)
config sclk 96 mhz with hext clock source. More...
static void | switch_system_clock (void)
sclk switch function. More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/crm/sysclk_switch/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • crm
  • sysclk_switch
  • src
project/at_start_f435/examples/crm/sysclk_switch/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38static void clkout_config(void);
39static void sclk_64m_hick_config(void);
40static void sclk_96m_hext_config(void);
41static void switch_system_clock(void);
42
48void clkout_config(void)
49{
50 gpio_init_type gpio_init_struct;
51
52 /* enable gpio port clock */
53 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
54
55 /* set default parameter */
56 gpio_default_para_init(&gpio_init_struct);
57
58 /* clkout gpio init */
59 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
60 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
61 gpio_init_struct.gpio_pins = GPIO_PINS_8;
62 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
63 gpio_init(GPIOA, &gpio_init_struct);
64
65 /* config clkout division */
66 crm_clkout_div_set(CRM_CLKOUT_INDEX_1, CRM_CLKOUT_DIV1_4, CRM_CLKOUT_DIV2_1);
67
68 /* config clkout1 clock */
69 crm_clock_out1_set(CRM_CLKOUT1_PLL);
70}
71
77static void switch_system_clock(void)
78{
79 if(CRM->pllcfg_bit.pllrcs == RESET)
80 {
81 sclk_96m_hext_config();
82 }
83 else
84 {
85 sclk_64m_hick_config();
86 }
87}
88
108static void sclk_64m_hick_config(void)
109{
110 /* enable pwc periph clock */
111 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
112
113 /* config ldo voltage */
114 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
115
116 /* set the flash clock divider */
117 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
118
119 /* reset crm */
120 crm_reset();
121
122 crm_clock_source_enable(CRM_CLOCK_SOURCE_HICK, TRUE);
123
124 /* wait till hick is ready */
125 while(crm_flag_get(CRM_HICK_STABLE_FLAG) != SET)
126 {
127 }
128
129 /* config pll clock resource */
130 crm_pll_config(CRM_PLL_SOURCE_HICK, 64, 1, CRM_PLL_FR_8);
131
132 /* enable pll */
133 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
134
135 /* wait till pll is ready */
136 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
137 {
138 }
139
140 /* config ahbclk */
141 crm_ahb_div_set(CRM_AHB_DIV_1);
142
143 /* config apb2clk */
144 crm_apb2_div_set(CRM_APB2_DIV_2);
145
146 /* config apb1clk */
147 crm_apb1_div_set(CRM_APB1_DIV_2);
148
149 /* enable auto step mode */
150 crm_auto_step_mode_enable(TRUE);
151
152 /* select pll as system clock source */
153 crm_sysclk_switch(CRM_SCLK_PLL);
154
155 /* wait till pll is used as system clock source */
156 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
157 {
158 }
159
160 /* disable auto step mode */
161 crm_auto_step_mode_enable(FALSE);
162
163 /* update system_core_clock global variable */
164 system_core_clock_update();
165
166 /* set the flash clock divider */
167 flash_clock_divider_set(FLASH_CLOCK_DIV_2);
168
169 /* config systick delay */
170 delay_init();
171
172 /* config clkout */
173 clkout_config();
174}
175
195static void sclk_96m_hext_config(void)
196{
197 /* enable pwc periph clock */
198 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
199
200 /* config ldo voltage */
201 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
202
203 /* set the flash clock divider */
204 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
205
206 /* reset crm */
207 crm_reset();
208
209 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
210
211 /* wait till hext is ready */
212 while(crm_hext_stable_wait() == ERROR)
213 {
214 }
215
216 /* config pll clock resource */
217 crm_pll_config(CRM_PLL_SOURCE_HEXT, 96, 1, CRM_PLL_FR_8);
218
219 /* enable pll */
220 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
221
222 /* wait till pll is ready */
223 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
224 {
225 }
226
227 /* config ahbclk */
228 crm_ahb_div_set(CRM_AHB_DIV_1);
229
230 /* config apb2clk */
231 crm_apb2_div_set(CRM_APB2_DIV_2);
232
233 /* config apb1clk */
234 crm_apb1_div_set(CRM_APB1_DIV_2);
235
236 /* enable auto step mode */
237 crm_auto_step_mode_enable(TRUE);
238
239 /* select pll as system clock source */
240 crm_sysclk_switch(CRM_SCLK_PLL);
241
242 /* wait till pll is used as system clock source */
243 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
244 {
245 }
246
247 /* disable auto step mode */
248 crm_auto_step_mode_enable(FALSE);
249
250 /* update system_core_clock global variable */
251 system_core_clock_update();
252
253 /* set the flash clock divider */
254 flash_clock_divider_set(FLASH_CLOCK_DIV_2);
255
256 /* config systick delay */
257 delay_init();
258
259 /* config clkout */
260 clkout_config();
261}
262
268int main(void)
269{
270 system_clock_config();
271
272 at32_board_init();
273
274 clkout_config();
275
276 while(1)
277 {
278 if(at32_button_press() == USER_BUTTON)
279 {
280 switch_system_clock();
281 at32_led_toggle(LED4);
282 }
283 at32_led_toggle(LED2);
284 delay_ms(100);
285 }
286}
287
at32f435_437_board.h
clkout_config
static void clkout_config(void)
clkout configuration.
Definition: project/at_start_f435/examples/crm/sysclk_switch/src/main.c:48
sclk_96m_hext_config
static void sclk_96m_hext_config(void)
config sclk 96 mhz with hext clock source.
Definition: project/at_start_f435/examples/crm/sysclk_switch/src/main.c:195
main
int main(void)
main function.
Definition: project/at_start_f435/examples/crm/sysclk_switch/src/main.c:268
sclk_64m_hick_config
static void sclk_64m_hick_config(void)
config sclk 64 mhz with hick clock source.
Definition: project/at_start_f435/examples/crm/sysclk_switch/src/main.c:108
switch_system_clock
static void switch_system_clock(void)
sclk switch function.
Definition: project/at_start_f435/examples/crm/sysclk_switch/src/main.c:77
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
USER_BUTTON
@ USER_BUTTON
Definition: at32f435_437_board.h:98
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f435_437_board.c:194
delay_init
void delay_init()
initialize delay function
Definition: at32f435_437_board.c:293
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_clkout_div_set
void crm_clkout_div_set(crm_clkout_index_type index, crm_clkout_div1_type div1, crm_clkout_div2_type div2)
set crm clkout1 division1
Definition: at32f435_437_crm.c:831
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_clock_out1_set
void crm_clock_out1_set(crm_clkout1_select_type clkout)
set crm clkout1
Definition: at32f435_437_crm.c:773
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_HICK
@ CRM_CLOCK_SOURCE_HICK
Definition: at32f435_437_crm.h:559
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_CLKOUT_DIV1_4
@ CRM_CLKOUT_DIV1_4
Definition: at32f435_437_crm.h:728
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_PLL_SOURCE_HICK
@ CRM_PLL_SOURCE_HICK
Definition: at32f435_437_crm.h:537
CRM_CLKOUT_DIV2_1
@ CRM_CLKOUT_DIV2_1
Definition: at32f435_437_crm.h:737
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_CLKOUT1_PLL
@ CRM_CLKOUT1_PLL
Definition: at32f435_437_crm.h:702
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_8
@ CRM_PLL_FR_8
Definition: at32f435_437_crm.h:549
CRM_CLKOUT_INDEX_1
@ CRM_CLKOUT_INDEX_1
Definition: at32f435_437_crm.h:690
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
CRM_HICK_STABLE_FLAG
#define CRM_HICK_STABLE_FLAG
Definition: at32f435_437_crm.h:55
CRM
#define CRM
Definition: at32f435_437_crm.h:1506
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_2
@ FLASH_CLOCK_DIV_2
Definition: at32f435_437_flash.h:190
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_sinewave
  • inc
project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_sinewave
  • inc
project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_sinewave
  • inc
project/at_start_f435/examples/dac/double_mode_dma_sinewave/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_sinewave
  • src
Functions
project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_sinewave
  • src
project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_sinewave
  • src
Functions
project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_sinewave
  • src
project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while (1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while (1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while (1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while (1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_sinewave
  • src
Functions | Variables
project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
dma_init_type dma_init_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
const uint16_t | sine12bit [32]
uint32_t | dualsine12bit [32]
uint32_t | idx = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_sinewave
  • src
project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 dma_init_type dma_init_struct;
40 crm_clocks_freq_type crm_clocks_freq_struct = {0};
41const uint16_t sine12bit[32] = {2047, 2447, 2831, 3185, 3498, 3750, 3939, 4056,
42 4095, 4056, 3939, 3750, 3495, 3185, 2831, 2447,
43 2047, 1647, 1263, 909, 599, 344, 155, 38,
44 0, 38, 155, 344, 599, 909, 1263, 1647};
45uint32_t dualsine12bit[32];
46uint32_t idx = 0;
47
53int main(void)
54{
55 system_clock_config();
56
57 at32_board_init();
58
59 /* turn led2/led3/led4 on */
60 at32_led_on(LED2);
61 at32_led_on(LED3);
62 at32_led_on(LED4);
63
64 /* enable dac/tmr2/gpioa clock */
65 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_DAC_PERIPH_CLOCK, TRUE);
67 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
68 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
69
70 /* once the dac is enabled, the corresponding gpio pin is automatically
71 connected to the dac converter. in order to avoid parasitic consumption,
72 the gpio pin should be configured in analog */
73 gpio_init_struct.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5;
74 gpio_init_struct.gpio_mode = GPIO_MODE_ANALOG;
75 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
76 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
77 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
78 gpio_init(GPIOA, &gpio_init_struct);
79
80 /* get system clock */
81 crm_clocks_freq_get(&crm_clocks_freq_struct);
82
83 /* (systemclock/(systemclock/1000000))/100 = 10KHz */
84 tmr_base_init(TMR2, 99, (crm_clocks_freq_struct.sclk_freq/1000000 - 1));
85 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
86
87 /* primary tmr2 output selection */
88 tmr_primary_mode_select(TMR2, TMR_PRIMARY_SEL_OVERFLOW);
89
90 /* dac1 and dac2 configuration */
91 dac_trigger_select(DAC1_SELECT, DAC_TMR2_TRGOUT_EVENT);
92 dac_trigger_select(DAC2_SELECT, DAC_TMR2_TRGOUT_EVENT);
93
94 dac_trigger_enable(DAC1_SELECT, TRUE);
95 dac_trigger_enable(DAC2_SELECT, TRUE);
96
97 dac_wave_generate(DAC1_SELECT, DAC_WAVE_GENERATE_NONE);
98 dac_wave_generate(DAC2_SELECT, DAC_WAVE_GENERATE_NONE);
99
100 dac_output_buffer_enable(DAC1_SELECT, FALSE);
101 dac_output_buffer_enable(DAC2_SELECT, FALSE);
102
103 dac_dma_enable(DAC1_SELECT, TRUE);
104 dac_dma_enable(DAC2_SELECT, TRUE);
105
106 /* fill sine32bit table */
107 for(idx = 0; idx < 32; idx++)
108 {
109 dualsine12bit[idx] = (sine12bit[idx] << 16) + (sine12bit[idx]);
110 }
111
112 /* dma1 channel1 configuration */
113 dma_reset(DMA1_CHANNEL1);
114 dma_init_struct.buffer_size = 32;
115 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
116 dma_init_struct.memory_base_addr = (uint32_t)dualsine12bit;
117 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_WORD;
118 dma_init_struct.memory_inc_enable = TRUE;
119 dma_init_struct.peripheral_base_addr = (uint32_t)0x40007420;
120 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_WORD;
121 dma_init_struct.peripheral_inc_enable = FALSE;
122 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
123 dma_init_struct.loop_mode_enable = TRUE;
124 dma_init(DMA1_CHANNEL1, &dma_init_struct);
125
126 /* enable dmamux function */
127 dmamux_enable(DMA1, TRUE);
128 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_DAC2);
129
130 dma_channel_enable(DMA1_CHANNEL1, TRUE);
131
132 /* enable dac1: once the dac1 is enabled, pa.04 is
133 automatically connected to the dac converter. */
134 dac_enable(DAC1_SELECT, TRUE);
135
136 /* enable dac2: once the dac2 is enabled, pa.05 is
137 automatically connected to the dac converter. */
138 dac_enable(DAC2_SELECT, TRUE);
139
140 /* enable tmr2 */
141 tmr_counter_enable(TMR2, TRUE);
142
143 while(1)
144 {
145 }
146}
147
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
idx
uint32_t idx
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:46
sine12bit
const uint16_t sine12bit[32]
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:41
main
int main(void)
main function.
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:53
dualsine12bit
uint32_t dualsine12bit[32]
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:45
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:40
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_DAC_PERIPH_CLOCK
@ CRM_DAC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:150
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:128
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
dac_output_buffer_enable
void dac_output_buffer_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac output buffer
Definition: at32f435_437_dac.c:88
dac_dma_enable
void dac_dma_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac dma
Definition: at32f435_437_dac.c:268
dac_wave_generate
void dac_wave_generate(dac_select_type dac_select, dac_wave_type dac_wave)
generate dac wave
Definition: at32f435_437_dac.c:207
dac_trigger_select
void dac_trigger_select(dac_select_type dac_select, dac_trigger_type dac_trigger_source)
select dac trigger
Definition: at32f435_437_dac.c:146
dac_enable
void dac_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac
Definition: at32f435_437_dac.c:64
dac_trigger_enable
void dac_trigger_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac trigger
Definition: at32f435_437_dac.c:113
DAC2_SELECT
@ DAC2_SELECT
Definition: at32f435_437_dac.h:60
DAC1_SELECT
@ DAC1_SELECT
Definition: at32f435_437_dac.h:59
DAC_WAVE_GENERATE_NONE
@ DAC_WAVE_GENERATE_NONE
Definition: at32f435_437_dac.h:83
DAC_TMR2_TRGOUT_EVENT
@ DAC_TMR2_TRGOUT_EVENT
Definition: at32f435_437_dac.h:72
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:164
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:174
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f435_437_dma.h:183
DMAMUX_DMAREQ_ID_DAC2
@ DMAMUX_DMAREQ_ID_DAC2
Definition: at32f435_437_dma.h:201
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f435_437_gpio.h:85
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_primary_mode_select
void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode
Definition: at32f435_437_tmr.c:1222
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_PRIMARY_SEL_OVERFLOW
@ TMR_PRIMARY_SEL_OVERFLOW
Definition: at32f435_437_tmr.h:121
TMR2
#define TMR2
Definition: at32f435_437_tmr.h:896
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f435_437_crm.h:789
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_squarewave
  • inc
project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_squarewave
  • inc
project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_squarewave
  • inc
project/at_start_f435/examples/dac/double_mode_dma_squarewave/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_squarewave
  • src
Functions
project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_squarewave
  • src
project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_squarewave
  • src
Functions
project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_squarewave
  • src
project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while (1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while (1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while (1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while (1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_squarewave
  • src
Functions | Variables
project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
dma_init_type dma_init_struct
uint32_t | dualsquare12bit [2] = {(0xfff | (0xfff << 16)), 0}

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • dac
  • double_mode_dma_squarewave
  • src
project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 dma_init_type dma_init_struct;
40
41uint32_t dualsquare12bit[2] = {(0xfff | (0xfff << 16)), 0};
42
48int main(void)
49{
50 system_clock_config();
51
52 at32_board_init();
53
54 /* turn led2/led3/led4 on */
55 at32_led_on(LED2);
56 at32_led_on(LED3);
57 at32_led_on(LED4);
58
59 /* enable dac/dma1/gpioa clock */
60 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
61 crm_periph_clock_enable(CRM_DAC_PERIPH_CLOCK, TRUE);
62 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
63
64 /* once the dac is enabled, the corresponding gpio pin is automatically
65 connected to the dac converter. in order to avoid parasitic consumption,
66 the gpio pin should be configured in analog */
67 gpio_init_struct.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5;
68 gpio_init_struct.gpio_mode = GPIO_MODE_ANALOG;
69 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
70 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
71 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
72 gpio_init(GPIOA, &gpio_init_struct);
73
74 /* dac1 and dac2 configuration */
75 dac_trigger_select(DAC1_SELECT, DAC_SOFTWARE_TRIGGER);
76 dac_trigger_select(DAC2_SELECT, DAC_SOFTWARE_TRIGGER);
77
78 dac_trigger_enable(DAC1_SELECT, TRUE);
79 dac_trigger_enable(DAC2_SELECT, TRUE);
80
81 dac_wave_generate(DAC1_SELECT, DAC_WAVE_GENERATE_NONE);
82 dac_wave_generate(DAC2_SELECT, DAC_WAVE_GENERATE_NONE);
83
84 dac_output_buffer_enable(DAC1_SELECT, TRUE);
85 dac_output_buffer_enable(DAC2_SELECT, TRUE);
86
87 dac_dma_enable(DAC1_SELECT, TRUE);
88 dac_dma_enable(DAC2_SELECT, TRUE);
89
90 /* dma1 channel1 configuration */
91 dma_reset(DMA1_CHANNEL1);
92 dma_init_struct.buffer_size = 2;
93 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
94 dma_init_struct.memory_base_addr = (uint32_t)dualsquare12bit;
95 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_WORD;
96 dma_init_struct.memory_inc_enable = TRUE;
97 dma_init_struct.peripheral_base_addr = (uint32_t)0x40007420;
98 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_WORD;
99 dma_init_struct.peripheral_inc_enable = FALSE;
100 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
101 dma_init_struct.loop_mode_enable = TRUE;
102 dma_init(DMA1_CHANNEL1, &dma_init_struct);
103
104 /* enable dmamux function */
105 dmamux_enable(DMA1, TRUE);
106 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_DAC2);
107
108 dma_channel_enable(DMA1_CHANNEL1, TRUE);
109
110 /* enable dac1: once the dac1 is enabled, pa.04 is
111 automatically connected to the dac converter. */
112 dac_enable(DAC1_SELECT, TRUE);
113
114 /* enable dac2: once the dac2 is enabled, pa.05 is
115 automatically connected to the dac converter. */
116 dac_enable(DAC2_SELECT, TRUE);
117
118 while(1)
119 {
120 delay_us(100);
121 dac_software_trigger_generate(DAC1_SELECT);
122 dac_software_trigger_generate(DAC2_SELECT);
123 }
124}
125
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/main.c:48
dualsquare12bit
uint32_t dualsquare12bit[2]
Definition: project/at_start_f435/examples/dac/double_mode_dma_squarewave/src/main.c:41
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f435_437_board.c:306
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_DAC_PERIPH_CLOCK
@ CRM_DAC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:150
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
dac_output_buffer_enable
void dac_output_buffer_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac output buffer
Definition: at32f435_437_dac.c:88
dac_dma_enable
void dac_dma_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac dma
Definition: at32f435_437_dac.c:268
dac_wave_generate
void dac_wave_generate(dac_select_type dac_select, dac_wave_type dac_wave)
generate dac wave
Definition: at32f435_437_dac.c:207
dac_software_trigger_generate
void dac_software_trigger_generate(dac_select_type dac_select)
generate dac software trigger
Definition: at32f435_437_dac.c:169
dac_trigger_select
void dac_trigger_select(dac_select_type dac_select, dac_trigger_type dac_trigger_source)
select dac trigger
Definition: at32f435_437_dac.c:146
dac_enable
void dac_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac
Definition: at32f435_437_dac.c:64
dac_trigger_enable
void dac_trigger_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac trigger
Definition: at32f435_437_dac.c:113
DAC2_SELECT
@ DAC2_SELECT
Definition: at32f435_437_dac.h:60
DAC1_SELECT
@ DAC1_SELECT
Definition: at32f435_437_dac.h:59
DAC_WAVE_GENERATE_NONE
@ DAC_WAVE_GENERATE_NONE
Definition: at32f435_437_dac.h:83
DAC_SOFTWARE_TRIGGER
@ DAC_SOFTWARE_TRIGGER
Definition: at32f435_437_dac.h:75
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:164
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:174
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f435_437_dma.h:183
DMAMUX_DMAREQ_ID_DAC2
@ DMAMUX_DMAREQ_ID_DAC2
Definition: at32f435_437_dma.h:201
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f435_437_gpio.h:85
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • dac
  • one_dac_dma_escalator
  • inc
project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • dac
  • one_dac_dma_escalator
  • inc
project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • dac
  • one_dac_dma_escalator
  • inc
project/at_start_f435/examples/dac/one_dac_dma_escalator/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • dac
  • one_dac_dma_escalator
  • src
Functions
project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • dac
  • one_dac_dma_escalator
  • src
project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • dac
  • one_dac_dma_escalator
  • src
Functions
project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • dac
  • one_dac_dma_escalator
  • src
project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while (1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while (1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while (1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while (1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/dac/one_dac_dma_escalator/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • dac
  • one_dac_dma_escalator
  • src
Functions | Variables
project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
dma_init_type dma_init_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
const uint8_t | escalator8bit [6] = {0x0, 0x33, 0x66, 0x99, 0xCC, 0xFF}

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • dac
  • one_dac_dma_escalator
  • src
project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 dma_init_type dma_init_struct;
40 crm_clocks_freq_type crm_clocks_freq_struct = {0};
41const uint8_t escalator8bit[6] = {0x0, 0x33, 0x66, 0x99, 0xCC, 0xFF};
42
48int main(void)
49{
50 system_clock_config();
51
52 at32_board_init();
53
54 /* turn led2/led3/led4 on */
55 at32_led_on(LED2);
56 at32_led_on(LED3);
57 at32_led_on(LED4);
58
59 /* enable dac/dma1/gpioa/tmr2 clock */
60 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
61 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
62 crm_periph_clock_enable(CRM_DAC_PERIPH_CLOCK, TRUE);
63 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
64
65 /* once the dac is enabled, the corresponding gpio pin is automatically
66 connected to the dac converter. in order to avoid parasitic consumption,
67 the gpio pin should be configured in analog */
68 gpio_init_struct.gpio_pins = GPIO_PINS_4;
69 gpio_init_struct.gpio_mode = GPIO_MODE_ANALOG;
70 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
71 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
72 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
73 gpio_init(GPIOA, &gpio_init_struct);
74
75 /* get system clock */
76 crm_clocks_freq_get(&crm_clocks_freq_struct);
77
78 /* (systemclock/(systemclock/1000000))/1000 = 1KHz */
79 tmr_base_init(TMR2, 999, (crm_clocks_freq_struct.sclk_freq/1000000 - 1));
80 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
81
82 /* primary tmr2 output selection */
83 tmr_primary_mode_select(TMR2, TMR_PRIMARY_SEL_OVERFLOW);
84
85 /* dac1 configuration */
86 dac_trigger_select(DAC1_SELECT, DAC_TMR2_TRGOUT_EVENT);
87
88 dac_trigger_enable(DAC1_SELECT, TRUE);
89
90 dac_wave_generate(DAC1_SELECT, DAC_WAVE_GENERATE_NONE);
91
92 dac_output_buffer_enable(DAC1_SELECT, FALSE);
93
94 dac_dma_enable(DAC1_SELECT, TRUE);
95
96 /* dma1 channel2 configuration */
97 dma_reset(DMA1_CHANNEL2);
98 dma_init_struct.buffer_size = 6;
99 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
100 dma_init_struct.memory_base_addr = (uint32_t)escalator8bit;
101 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
102 dma_init_struct.memory_inc_enable = TRUE;
103 dma_init_struct.peripheral_base_addr = (uint32_t)0x40007410;
104 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
105 dma_init_struct.peripheral_inc_enable = FALSE;
106 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
107 dma_init_struct.loop_mode_enable = TRUE;
108 dma_init(DMA1_CHANNEL2, &dma_init_struct);
109
110 /* enable dmamux function */
111 dmamux_enable(DMA1, TRUE);
112 dmamux_init(DMA1MUX_CHANNEL2, DMAMUX_DMAREQ_ID_DAC1);
113
114 dma_channel_enable(DMA1_CHANNEL2, TRUE);
115
116 /* enable dac1: once the dac1 is enabled, pa.04 is
117 automatically connected to the dac converter. */
118 dac_enable(DAC1_SELECT, TRUE);
119
120 /* enable tmr2 */
121 tmr_counter_enable(TMR2, TRUE);
122 while(1)
123 {
124 }
125}
126
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c:39
escalator8bit
const uint8_t escalator8bit[6]
Definition: project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c:41
main
int main(void)
main function.
Definition: project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c:48
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/dac/one_dac_dma_escalator/src/main.c:40
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_DAC_PERIPH_CLOCK
@ CRM_DAC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:150
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:128
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
dac_output_buffer_enable
void dac_output_buffer_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac output buffer
Definition: at32f435_437_dac.c:88
dac_dma_enable
void dac_dma_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac dma
Definition: at32f435_437_dac.c:268
dac_wave_generate
void dac_wave_generate(dac_select_type dac_select, dac_wave_type dac_wave)
generate dac wave
Definition: at32f435_437_dac.c:207
dac_trigger_select
void dac_trigger_select(dac_select_type dac_select, dac_trigger_type dac_trigger_source)
select dac trigger
Definition: at32f435_437_dac.c:146
dac_enable
void dac_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac
Definition: at32f435_437_dac.c:64
dac_trigger_enable
void dac_trigger_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac trigger
Definition: at32f435_437_dac.c:113
DAC1_SELECT
@ DAC1_SELECT
Definition: at32f435_437_dac.h:59
DAC_WAVE_GENERATE_NONE
@ DAC_WAVE_GENERATE_NONE
Definition: at32f435_437_dac.h:83
DAC_TMR2_TRGOUT_EVENT
@ DAC_TMR2_TRGOUT_EVENT
Definition: at32f435_437_dac.h:72
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:162
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:172
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f435_437_dma.h:183
DMAMUX_DMAREQ_ID_DAC1
@ DMAMUX_DMAREQ_ID_DAC1
Definition: at32f435_437_dma.h:200
DMA1MUX_CHANNEL2
#define DMA1MUX_CHANNEL2
Definition: at32f435_437_dma.h:705
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f435_437_dma.h:697
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f435_437_gpio.h:85
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_primary_mode_select
void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode
Definition: at32f435_437_tmr.c:1222
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_PRIMARY_SEL_OVERFLOW
@ TMR_PRIMARY_SEL_OVERFLOW
Definition: at32f435_437_tmr.h:121
TMR2
#define TMR2
Definition: at32f435_437_tmr.h:896
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f435_437_crm.h:789
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • dac
  • one_dac_noisewave
  • inc
project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • dac
  • one_dac_noisewave
  • inc
project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • dac
  • one_dac_noisewave
  • inc
project/at_start_f435/examples/dac/one_dac_noisewave/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • dac
  • one_dac_noisewave
  • src
Functions
project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • dac
  • one_dac_noisewave
  • src
project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • dac
  • one_dac_noisewave
  • src
Functions
project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • dac
  • one_dac_noisewave
  • src
project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while (1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while (1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while (1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while (1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/dac/one_dac_noisewave/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • dac
  • one_dac_noisewave
  • src
Functions | Variables
project/at_start_f435/examples/dac/one_dac_noisewave/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type gpio_init_struct = {0}

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/one_dac_noisewave/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • dac
  • one_dac_noisewave
  • src
project/at_start_f435/examples/dac/one_dac_noisewave/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39
45int main(void)
46{
47 system_clock_config();
48
49 at32_board_init();
50
51 /* turn led2/led3/led4 on */
52 at32_led_on(LED2);
53 at32_led_on(LED3);
54 at32_led_on(LED4);
55
56 /* enable dac/gpioa clock */
57 crm_periph_clock_enable(CRM_DAC_PERIPH_CLOCK, TRUE);
58 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
59
60 /* once the dac is enabled, the corresponding gpio pin is automatically
61 connected to the dac converter. in order to avoid parasitic consumption,
62 the gpio pin should be configured in analog */
63 gpio_init_struct.gpio_pins = GPIO_PINS_4;
64 gpio_init_struct.gpio_mode = GPIO_MODE_ANALOG;
65 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
66 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
67 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
68 gpio_init(GPIOA, &gpio_init_struct);
69
70 /* dac1 configuration */
71 dac_trigger_select(DAC1_SELECT, DAC_SOFTWARE_TRIGGER);
72
73 dac_trigger_enable(DAC1_SELECT, TRUE);
74
75 dac_wave_generate(DAC1_SELECT, DAC_WAVE_GENERATE_NOISE);
76
77 dac_mask_amplitude_select(DAC1_SELECT, DAC_LSFR_BITB0_AMPLITUDE_4095);
78
79 dac_output_buffer_enable(DAC1_SELECT, TRUE);
80
81 /* enable dac1: once the dac1 is enabled, pa.04 is
82 automatically connected to the dac converter. */
83 dac_enable(DAC1_SELECT, TRUE);
84
85 while(1)
86 {
87 dac_software_trigger_generate(DAC1_SELECT);
88 delay_us(1);
89 }
90}
91
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/one_dac_noisewave/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f435/examples/dac/one_dac_noisewave/src/main.c:45
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f435_437_board.c:306
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_DAC_PERIPH_CLOCK
@ CRM_DAC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:150
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
dac_output_buffer_enable
void dac_output_buffer_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac output buffer
Definition: at32f435_437_dac.c:88
dac_wave_generate
void dac_wave_generate(dac_select_type dac_select, dac_wave_type dac_wave)
generate dac wave
Definition: at32f435_437_dac.c:207
dac_software_trigger_generate
void dac_software_trigger_generate(dac_select_type dac_select)
generate dac software trigger
Definition: at32f435_437_dac.c:169
dac_mask_amplitude_select
void dac_mask_amplitude_select(dac_select_type dac_select, dac_mask_amplitude_type dac_mask_amplitude)
select dac mask amplitude
Definition: at32f435_437_dac.c:244
dac_trigger_select
void dac_trigger_select(dac_select_type dac_select, dac_trigger_type dac_trigger_source)
select dac trigger
Definition: at32f435_437_dac.c:146
dac_enable
void dac_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac
Definition: at32f435_437_dac.c:64
dac_trigger_enable
void dac_trigger_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac trigger
Definition: at32f435_437_dac.c:113
DAC1_SELECT
@ DAC1_SELECT
Definition: at32f435_437_dac.h:59
DAC_WAVE_GENERATE_NOISE
@ DAC_WAVE_GENERATE_NOISE
Definition: at32f435_437_dac.h:84
DAC_LSFR_BITB0_AMPLITUDE_4095
@ DAC_LSFR_BITB0_AMPLITUDE_4095
Definition: at32f435_437_dac.h:104
DAC_SOFTWARE_TRIGGER
@ DAC_SOFTWARE_TRIGGER
Definition: at32f435_437_dac.h:75
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f435_437_gpio.h:85
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • dac
  • two_dac_trianglewave
  • inc
project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • dac
  • two_dac_trianglewave
  • inc
project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • dac
  • two_dac_trianglewave
  • inc
project/at_start_f435/examples/dac/two_dac_trianglewave/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • dac
  • two_dac_trianglewave
  • src
Functions
project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • dac
  • two_dac_trianglewave
  • src
project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • dac
  • two_dac_trianglewave
  • src
Functions
project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • dac
  • two_dac_trianglewave
  • src
project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while (1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while (1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while (1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while (1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/dac/two_dac_trianglewave/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • dac
  • two_dac_trianglewave
  • src
Functions | Variables
project/at_start_f435/examples/dac/two_dac_trianglewave/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dac/two_dac_trianglewave/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • dac
  • two_dac_trianglewave
  • src
project/at_start_f435/examples/dac/two_dac_trianglewave/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
45int main(void)
46{
47 system_clock_config();
48
49 at32_board_init();
50
51 /* turn led2/led3/led4 on */
52 at32_led_on(LED2);
53 at32_led_on(LED3);
54 at32_led_on(LED4);
55
56 /* enable dac/tmr2/gpioa clock */
57 crm_periph_clock_enable(CRM_DAC_PERIPH_CLOCK, TRUE);
58 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
59 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
60
61 /* once the dac is enabled, the corresponding gpio pin is automatically
62 connected to the dac converter. in order to avoid parasitic consumption,
63 the gpio pin should be configured in analog */
64 gpio_init_struct.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5;
65 gpio_init_struct.gpio_mode = GPIO_MODE_ANALOG;
66 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
67 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
68 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
69 gpio_init(GPIOA, &gpio_init_struct);
70
71 /* get system clock */
72 crm_clocks_freq_get(&crm_clocks_freq_struct);
73
74 /* (systemclock/(systemclock/1000000))/100 = 10KHz */
75 tmr_base_init(TMR2, 99, (crm_clocks_freq_struct.sclk_freq/1000000 - 1));
76 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
77
78 /* primary tmr2 output selection */
79 tmr_primary_mode_select(TMR2, TMR_PRIMARY_SEL_OVERFLOW);
80
81 /* dac1 and dac2 configuration */
82 dac_trigger_select(DAC1_SELECT, DAC_TMR2_TRGOUT_EVENT);
83 dac_trigger_select(DAC2_SELECT, DAC_TMR2_TRGOUT_EVENT);
84
85 dac_trigger_enable(DAC1_SELECT, TRUE);
86 dac_trigger_enable(DAC2_SELECT, TRUE);
87
88 dac_wave_generate(DAC1_SELECT, DAC_WAVE_GENERATE_TRIANGLE);
89 dac_wave_generate(DAC2_SELECT, DAC_WAVE_GENERATE_TRIANGLE);
90
91 dac_mask_amplitude_select(DAC1_SELECT, DAC_LSFR_BIT90_AMPLITUDE_1023);
92 dac_mask_amplitude_select(DAC2_SELECT, DAC_LSFR_BITA0_AMPLITUDE_2047);
93
94 dac_output_buffer_enable(DAC1_SELECT, FALSE);
95 dac_output_buffer_enable(DAC2_SELECT, FALSE);
96
97 dac_dma_enable(DAC1_SELECT, TRUE);
98 dac_dma_enable(DAC2_SELECT, TRUE);
99
100 /* enable dac1: once the dac1 is enabled, pa.04 is
101 automatically connected to the dac converter. */
102 dac_enable(DAC1_SELECT, TRUE);
103
104 /* enable dac2: once the dac2 is enabled, pa.05 is
105 automatically connected to the dac converter. */
106 dac_enable(DAC2_SELECT, TRUE);
107
108 dac_dual_data_set(DAC_DUAL_12BIT_RIGHT, 0x100, 0x100);
109
110 /* enable tmr2 */
111 tmr_counter_enable(TMR2, TRUE);
112
113 while(1)
114 {
115 }
116}
117
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/two_dac_trianglewave/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f435/examples/dac/two_dac_trianglewave/src/main.c:45
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/dac/two_dac_trianglewave/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_DAC_PERIPH_CLOCK
@ CRM_DAC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:150
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:128
dac_output_buffer_enable
void dac_output_buffer_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac output buffer
Definition: at32f435_437_dac.c:88
dac_dma_enable
void dac_dma_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac dma
Definition: at32f435_437_dac.c:268
dac_wave_generate
void dac_wave_generate(dac_select_type dac_select, dac_wave_type dac_wave)
generate dac wave
Definition: at32f435_437_dac.c:207
dac_mask_amplitude_select
void dac_mask_amplitude_select(dac_select_type dac_select, dac_mask_amplitude_type dac_mask_amplitude)
select dac mask amplitude
Definition: at32f435_437_dac.c:244
dac_trigger_select
void dac_trigger_select(dac_select_type dac_select, dac_trigger_type dac_trigger_source)
select dac trigger
Definition: at32f435_437_dac.c:146
dac_enable
void dac_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac
Definition: at32f435_437_dac.c:64
dac_dual_data_set
void dac_dual_data_set(dac_dual_data_type dac_dual, uint16_t data1, uint16_t data2)
set dac dual data
Definition: at32f435_437_dac.c:349
dac_trigger_enable
void dac_trigger_enable(dac_select_type dac_select, confirm_state new_state)
enable or disable dac trigger
Definition: at32f435_437_dac.c:113
DAC2_SELECT
@ DAC2_SELECT
Definition: at32f435_437_dac.h:60
DAC1_SELECT
@ DAC1_SELECT
Definition: at32f435_437_dac.h:59
DAC_WAVE_GENERATE_TRIANGLE
@ DAC_WAVE_GENERATE_TRIANGLE
Definition: at32f435_437_dac.h:85
DAC_LSFR_BIT90_AMPLITUDE_1023
@ DAC_LSFR_BIT90_AMPLITUDE_1023
Definition: at32f435_437_dac.h:102
DAC_LSFR_BITA0_AMPLITUDE_2047
@ DAC_LSFR_BITA0_AMPLITUDE_2047
Definition: at32f435_437_dac.h:103
DAC_TMR2_TRGOUT_EVENT
@ DAC_TMR2_TRGOUT_EVENT
Definition: at32f435_437_dac.h:72
DAC_DUAL_12BIT_RIGHT
@ DAC_DUAL_12BIT_RIGHT
Definition: at32f435_437_dac.h:132
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f435_437_gpio.h:85
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_primary_mode_select
void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode
Definition: at32f435_437_tmr.c:1222
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_PRIMARY_SEL_OVERFLOW
@ TMR_PRIMARY_SEL_OVERFLOW
Definition: at32f435_437_tmr.h:121
TMR2
#define TMR2
Definition: at32f435_437_tmr.h:896
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f435_437_crm.h:789
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • debug
  • tmr1
  • inc
project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • debug
  • tmr1
  • inc
project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • debug
  • tmr1
  • inc
project/at_start_f435/examples/debug/tmr1/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • debug
  • tmr1
  • src
Functions
project/at_start_f435/examples/debug/tmr1/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/debug/tmr1/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • debug
  • tmr1
  • src
project/at_start_f435/examples/debug/tmr1/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/debug/tmr1/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • debug
  • tmr1
  • src
Functions
project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • debug
  • tmr1
  • src
project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while (1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while (1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while (1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while (1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/debug/tmr1/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • debug
  • tmr1
  • src
Functions | Variables
project/at_start_f435/examples/debug/tmr1/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | TMR1_OVF_TMR10_IRQHandler (void)
this function handles tmr1 overflow handler. More...
int | main (void)
main function. More...

Variables

crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | counter = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/debug/tmr1/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • debug
  • tmr1
  • src
project/at_start_f435/examples/debug/tmr1/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 crm_clocks_freq_type crm_clocks_freq_struct = {0};
39uint16_t counter = 0;
40
46void TMR1_OVF_TMR10_IRQHandler(void)
47{
48 if(tmr_flag_get(TMR1, TMR_OVF_FLAG) != RESET)
49 {
50 /* add user code... */
51 at32_led_toggle(LED3);
52 tmr_flag_clear(TMR1, TMR_OVF_FLAG);
53 }
54}
55
61int main(void)
62{
63 system_clock_config();
64
65 at32_board_init();
66
67 /* get system clock */
68 crm_clocks_freq_get(&crm_clocks_freq_struct);
69
70 /* turn led2/led3/led4 on */
71 at32_led_on(LED2);
72 at32_led_on(LED3);
73 at32_led_on(LED4);
74
75 /* enable tmr1 clock */
76 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
77
78 /* enable tmr1 debug mode */
79 debug_apb2_periph_mode_set(DEBUG_TMR1_PAUSE, TRUE);
80
81 /* tmr1 configuration */
82 tmr_base_init(TMR1, 10000, 0);
83 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
84
85 /* overflow interrupt enable */
86 tmr_interrupt_enable(TMR1, TMR_OVF_INT, TRUE);
87
88 /* tmr1 interrupt nvic init */
89 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
90 nvic_irq_enable(TMR1_OVF_TMR10_IRQn, 1, 0);
91
92 /* enable tmr1 */
93 tmr_counter_enable(TMR1, TRUE);
94
95 while(1)
96 {
97 /* in debug mode,tmr1 counter will pause */
98 counter = tmr_counter_value_get(TMR1);
99 counter = tmr_counter_value_get(TMR1);
100 counter = tmr_counter_value_get(TMR1);
101 counter = tmr_counter_value_get(TMR1);
102 counter = tmr_counter_value_get(TMR1);
103 }
104}
105
at32f435_437_board.h
main
int main(void)
main function.
Definition: project/at_start_f435/examples/debug/tmr1/src/main.c:61
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/debug/tmr1/src/main.c:38
TMR1_OVF_TMR10_IRQHandler
void TMR1_OVF_TMR10_IRQHandler(void)
this function handles tmr1 overflow handler.
Definition: project/at_start_f435/examples/debug/tmr1/src/main.c:46
counter
uint16_t counter
Definition: project/at_start_f435/examples/debug/tmr1/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:154
debug_apb2_periph_mode_set
void debug_apb2_periph_mode_set(uint32_t apb2_periph, confirm_state new_state)
set apb2 periph debug mode
Definition: at32f435_437_debug.c:111
DEBUG_TMR1_PAUSE
#define DEBUG_TMR1_PAUSE
Definition: at32f435_437_debug.h:77
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f435_437_tmr.c:1463
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_counter_value_get
uint32_t tmr_counter_value_get(tmr_type *tmr_x)
get tmr counter value
Definition: at32f435_437_tmr.c:299
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f435_437_tmr.c:1424
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f435_437_tmr.c:1389
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_OVF_FLAG
#define TMR_OVF_FLAG
Definition: at32f435_437_tmr.h:52
TMR_OVF_INT
#define TMR_OVF_INT
Definition: at32f435_437_tmr.h:75
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
TMR1_OVF_TMR10_IRQn
@ TMR1_OVF_TMR10_IRQn
Definition: at32f435_437.h:173
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • dma
  • dmamux_data_to_gpio
  • inc
project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • dma
  • dmamux_data_to_gpio
  • inc
project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • dma
  • dmamux_data_to_gpio
  • inc
project/at_start_f435/examples/dma/dmamux_data_to_gpio/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_data_to_gpio
  • src
Functions
project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • dma
  • dmamux_data_to_gpio
  • src
project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_data_to_gpio
  • src
Functions
project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA2_Channel1_IRQHandler (void)
this function handles dma2 channel1 handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • dma
  • dmamux_data_to_gpio
  • src
project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29#include "at32f435_437_board.h"
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while (1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while (1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while (1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while (1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
141void DMA2_Channel1_IRQHandler(void)
142{
143 if(dma_flag_get(DMA2_FDT1_FLAG) != RESET)
144 {
145 /* turn led2/led3/led4 on */
146 at32_led_on(LED2);
147 at32_led_on(LED3);
148 at32_led_on(LED4);
149 dma_flag_clear(DMA2_FDT1_FLAG);
150 }
151}
152
at32f435_437_board.h
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c:105
DMA2_Channel1_IRQHandler
void DMA2_Channel1_IRQHandler(void)
this function handles dma2 channel1 handler.
Definition: project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c:141
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/at32f435_437_int.c:114
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
DMA2_FDT1_FLAG
#define DMA2_FDT1_FLAG
Definition: at32f435_437_dma.h:95
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_data_to_gpio
  • src
Macros | Functions | Variables
project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 16

Functions

int main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
dma_init_type dma_init_struct
uint16_t | src_buffer [16]

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • dma
  • dmamux_data_to_gpio
  • src
project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 dma_init_type dma_init_struct;
40
41#define BUFFER_SIZE 16
42uint16_t src_buffer[BUFFER_SIZE] = {0x0001, 0x0002, 0x0003, 0x0004, 0x0005, 0x0006, 0x0007, 0x0008,
43 0x0009, 0x000a, 0x000b, 0x000c, 0x000d, 0x000e, 0x000f, 0x0010};
44
50int main(void)
51{
52 /* initial system clock */
53 system_clock_config();
54
55 /* at board initial */
56 at32_board_init();
57
58 /* enable dma2/gpioc/tmr2 clock */
59 crm_periph_clock_enable(CRM_DMA2_PERIPH_CLOCK, TRUE);
60 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
61 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
62
63 /* config gpioc pin for output mode */
64 gpio_init_struct.gpio_pins = GPIO_PINS_ALL;
65 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
66 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
67 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
68 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
69 gpio_init(GPIOC, &gpio_init_struct);
70
71 tmr_base_init(TMR2, 0xFF, 0);
72 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
73
74 /* enable tmr2 overflow dma request */
75 tmr_dma_request_enable(TMR2, TMR_OVERFLOW_DMA_REQUEST, TRUE);
76
77 /* dma2 channel1 configuration */
78 dma_reset(DMA2_CHANNEL1);
79 dma_init_struct.buffer_size = BUFFER_SIZE;
80 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
81 dma_init_struct.memory_base_addr = (uint32_t)src_buffer;
82 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
83 dma_init_struct.memory_inc_enable = TRUE;
84 dma_init_struct.peripheral_base_addr = (uint32_t)&GPIOC->odt;
85 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
86 dma_init_struct.peripheral_inc_enable = FALSE;
87 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
88 dma_init_struct.loop_mode_enable = FALSE;
89 dma_init(DMA2_CHANNEL1, &dma_init_struct);
90
91 /* enable transfer full data intterrupt */
92 dma_interrupt_enable(DMA2_CHANNEL1, DMA_FDT_INT, TRUE);
93
94 /* dma2 channel1 interrupt nvic init */
95 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
96 nvic_irq_enable(DMA2_Channel1_IRQn, 1, 0);
97
98 /* tmr2 dmamux function enable */
99 dmamux_enable(DMA2, TRUE);
100 dmamux_init(DMA2MUX_CHANNEL1, DMAMUX_DMAREQ_ID_TMR2_OVERFLOW);
101
102 /* enable dma channel */
103 dma_channel_enable(DMA2_CHANNEL1, TRUE);
104
105 /* enable tmr2 */
106 tmr_counter_enable(TMR2, TRUE);
107
108 while(1)
109 {
110 }
111}
112
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c:39
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c:41
main
int main(void)
main function.
Definition: project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c:50
src_buffer
uint16_t src_buffer[16]
Definition: project/at_start_f435/examples/dma/dmamux_data_to_gpio/src/main.c:42
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:128
CRM_DMA2_PERIPH_CLOCK
@ CRM_DMA2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:116
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f435_437_dma.h:183
DMAMUX_DMAREQ_ID_TMR2_OVERFLOW
@ DMAMUX_DMAREQ_ID_TMR2_OVERFLOW
Definition: at32f435_437_dma.h:260
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA2MUX_CHANNEL1
#define DMA2MUX_CHANNEL1
Definition: at32f435_437_dma.h:726
DMA2
#define DMA2
Definition: at32f435_437_dma.h:717
DMA2_CHANNEL1
#define DMA2_CHANNEL1
Definition: at32f435_437_dma.h:718
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_PINS_ALL
#define GPIO_PINS_ALL
Definition: at32f435_437_gpio.h:67
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
tmr_dma_request_enable
void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request
Definition: at32f435_437_tmr.c:1358
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
TMR_OVERFLOW_DMA_REQUEST
@ TMR_OVERFLOW_DMA_REQUEST
Definition: at32f435_437_tmr.h:271
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR2
#define TMR2
Definition: at32f435_437_tmr.h:896
DMA2_Channel1_IRQn
@ DMA2_Channel1_IRQn
Definition: at32f435_437.h:235
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • dma
  • dmamux_genertor_exint
  • inc
project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • dma
  • dmamux_genertor_exint
  • inc
project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • dma
  • dmamux_genertor_exint
  • inc
project/at_start_f435/examples/dma/dmamux_genertor_exint/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_genertor_exint
  • src
Functions
project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • dma
  • dmamux_genertor_exint
  • src
project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_genertor_exint
  • src
Functions
project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA2_Channel4_IRQHandler (void)
this function handles DMA2 channel1 handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • dma
  • dmamux_genertor_exint
  • src
project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29#include "at32f435_437_board.h"
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while (1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while (1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while (1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while (1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
141void DMA2_Channel4_IRQHandler(void)
142{
143 if(dma_flag_get(DMA2_FDT4_FLAG) != RESET)
144 {
145 /* turn led2/led3/led4 on */
146 at32_led_on(LED2);
147 at32_led_on(LED3);
148 at32_led_on(LED4);
149 dma_flag_clear(DMA2_FDT4_FLAG);
150 }
151}
152
at32f435_437_board.h
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c:79
DMA2_Channel4_IRQHandler
void DMA2_Channel4_IRQHandler(void)
this function handles DMA2 channel1 handler.
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c:141
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/at32f435_437_int.c:114
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
DMA2_FDT4_FLAG
#define DMA2_FDT4_FLAG
Definition: at32f435_437_dma.h:107
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_genertor_exint
  • src
Macros | Functions | Variables
project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 16

Functions

void | EXINT1_IRQHandler (void)
exint1 interrupt handler More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
dma_init_type dma_init_struct
dmamux_gen_init_type dmamux_gen_init_struct
exint_init_type exint_init_struct
uint16_t | src_buffer [16]
uint16_t | dst_buffer [16]

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • dma
  • dmamux_genertor_exint
  • src
project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 dma_init_type dma_init_struct;
40 dmamux_gen_init_type dmamux_gen_init_struct;
41 exint_init_type exint_init_struct;
42#define BUFFER_SIZE 16
43uint16_t src_buffer[BUFFER_SIZE] = {0x0001, 0x0002, 0x0003, 0x0004, 0x0005, 0x0006, 0x0007, 0x0008,
44 0x0009, 0x000a, 0x000b, 0x000c, 0x000d, 0x000e, 0x000f, 0x0010};
45
46uint16_t dst_buffer[BUFFER_SIZE];
47
53void EXINT1_IRQHandler(void)
54{
55 if(exint_flag_get(EXINT_LINE_1) != RESET)
56 {
57 at32_led_toggle(LED2);
58 exint_flag_clear(EXINT_LINE_1);
59 }
60}
66int main(void)
67{
68 /* initial system clock */
69 system_clock_config();
70
71 /* at board initial */
72 at32_board_init();
73
74 /* enable dma2/gpioa clock */
75 crm_periph_clock_enable(CRM_DMA2_PERIPH_CLOCK, TRUE);
76 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
77
78 /* config pa1 for input mode */
79 gpio_init_struct.gpio_pins = GPIO_PINS_1;
80 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
81 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
82 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
83 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
84 gpio_init(GPIOA, &gpio_init_struct);
85
86 scfg_exint_line_config(SCFG_PORT_SOURCE_GPIOA, SCFG_PINS_SOURCE1);
87
88 exint_default_para_init(&exint_init_struct);
89 exint_init_struct.line_enable = TRUE;
90 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
91 exint_init_struct.line_select = EXINT_LINE_1;
92 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
93 exint_init(&exint_init_struct);
94
95 /* exint line1 interrupt nvic init */
96 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
97 nvic_irq_enable(EXINT1_IRQn, 1, 0);
98
99 /* dma2 channel4 configuration */
100 dma_reset(DMA2_CHANNEL4);
101 dma_init_struct.buffer_size = BUFFER_SIZE;
102 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
103 dma_init_struct.memory_base_addr = (uint32_t)dst_buffer;
104 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
105 dma_init_struct.memory_inc_enable = TRUE;
106 dma_init_struct.peripheral_base_addr = (uint32_t)src_buffer;
107 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
108 dma_init_struct.peripheral_inc_enable = TRUE;
109 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
110 dma_init_struct.loop_mode_enable = FALSE;
111 dma_init(DMA2_CHANNEL4, &dma_init_struct);
112
113 /* genertor1 configuration */
114 dmamux_generator_default_para_init(&dmamux_gen_init_struct);
115 dmamux_gen_init_struct.gen_polarity = DMAMUX_GEN_POLARITY_RISING;
116 dmamux_gen_init_struct.gen_request_number = 4;
117 dmamux_gen_init_struct.gen_signal_sel = DMAMUX_GEN_ID_EXINT1;
118 dmamux_gen_init_struct.gen_enable = TRUE;
119 dmamux_generator_config(DMA2MUX_GENERATOR1, &dmamux_gen_init_struct);
120
121 /* enable transfer full data intterrupt */
122 dma_interrupt_enable(DMA2_CHANNEL4, DMA_FDT_INT, TRUE);
123
124 /* dma2 channel4 interrupt nvic init */
125 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
126 nvic_irq_enable(DMA2_Channel4_IRQn, 1, 0);
127
128 /* dmamux function enable */
129 dmamux_enable(DMA2, TRUE);
130 dmamux_init(DMA2MUX_CHANNEL4, DMAMUX_DMAREQ_ID_REQ_G1);
131
132 /* enable dma channe4 */
133 dma_channel_enable(DMA2_CHANNEL4, TRUE);
134
135 while(1)
136 {
137 }
138}
139
140
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:39
EXINT1_IRQHandler
void EXINT1_IRQHandler(void)
exint1 interrupt handler
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:53
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:42
dst_buffer
uint16_t dst_buffer[16]
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:46
dmamux_gen_init_struct
dmamux_gen_init_type dmamux_gen_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:40
main
int main(void)
main function.
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:66
src_buffer
uint16_t src_buffer[16]
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:43
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:41
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED2
@ LED2
Definition: at32f435_437_board.h:65
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_DMA2_PERIPH_CLOCK
@ CRM_DMA2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:116
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dmamux_generator_config
void dmamux_generator_config(dmamux_generator_type *dmamux_gen_x, dmamux_gen_init_type *dmamux_gen_init_struct)
dmamux request generator init.
Definition: at32f435_437_dma.c:519
dmamux_generator_default_para_init
void dmamux_generator_default_para_init(dmamux_gen_init_type *dmamux_gen_init_struct)
dmamux request generator init struct config with its default value.
Definition: at32f435_437_dma.c:496
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMAMUX_GEN_POLARITY_RISING
@ DMAMUX_GEN_POLARITY_RISING
Definition: at32f435_437_dma.h:367
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMAMUX_GEN_ID_EXINT1
@ DMAMUX_GEN_ID_EXINT1
Definition: at32f435_437_dma.h:337
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f435_437_dma.h:183
DMAMUX_DMAREQ_ID_REQ_G1
@ DMAMUX_DMAREQ_ID_REQ_G1
Definition: at32f435_437_dma.h:193
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA2MUX_CHANNEL4
#define DMA2MUX_CHANNEL4
Definition: at32f435_437_dma.h:729
DMA2
#define DMA2
Definition: at32f435_437_dma.h:717
DMA2MUX_GENERATOR1
#define DMA2MUX_GENERATOR1
Definition: at32f435_437_dma.h:734
DMA2_CHANNEL4
#define DMA2_CHANNEL4
Definition: at32f435_437_dma.h:721
exint_flag_get
flag_status exint_flag_get(uint32_t exint_line)
get exint flag
Definition: at32f435_437_exint.c:142
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f435_437_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
EXINT_LINE_1
#define EXINT_LINE_1
Definition: at32f435_437_exint.h:53
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f435_437_gpio.h:82
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
scfg_exint_line_config
void scfg_exint_line_config(scfg_port_source_type port_source, scfg_pins_source_type pin_source)
select the gpio pin used as exint line.
Definition: at32f435_437_scfg.c:152
SCFG_PINS_SOURCE1
@ SCFG_PINS_SOURCE1
Definition: at32f435_437_scfg.h:102
SCFG_PORT_SOURCE_GPIOA
@ SCFG_PORT_SOURCE_GPIOA
Definition: at32f435_437_scfg.h:124
DMA2_Channel4_IRQn
@ DMA2_Channel4_IRQn
Definition: at32f435_437.h:238
EXINT1_IRQn
@ EXINT1_IRQn
Definition: at32f435_437.h:153
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
dmamux_gen_init_type
dmamux generator init type
Definition: at32f435_437_dma.h:405
dmamux_gen_init_type::gen_enable
confirm_state gen_enable
Definition: at32f435_437_dma.h:409
dmamux_gen_init_type::gen_request_number
uint32_t gen_request_number
Definition: at32f435_437_dma.h:408
dmamux_gen_init_type::gen_signal_sel
dmamux_gen_id_sel_type gen_signal_sel
Definition: at32f435_437_dma.h:406
dmamux_gen_init_type::gen_polarity
dmamux_gen_pol_type gen_polarity
Definition: at32f435_437_dma.h:407
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • dma
  • dmamux_synchronization_exint
  • inc
project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • dma
  • dmamux_synchronization_exint
  • inc
project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • dma
  • dmamux_synchronization_exint
  • inc
project/at_start_f435/examples/dma/dmamux_synchronization_exint/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_synchronization_exint
  • src
Functions
project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • dma
  • dmamux_synchronization_exint
  • src
project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_synchronization_exint
  • src
Functions
project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA2_Channel4_IRQHandler (void)
this function handles dma2 channel4 handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • dma
  • dmamux_synchronization_exint
  • src
project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29#include "at32f435_437_board.h"
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while (1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while (1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while (1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while (1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
141void DMA2_Channel4_IRQHandler(void)
142{
143 if(dma_flag_get(DMA2_FDT4_FLAG) != RESET)
144 {
145 /* turn led2/led3/led4 on */
146 at32_led_on(LED2);
147 at32_led_on(LED3);
148 at32_led_on(LED4);
149 dma_flag_clear(DMA2_FDT4_FLAG);
150 }
151}
at32f435_437_board.h
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c:79
DMA2_Channel4_IRQHandler
void DMA2_Channel4_IRQHandler(void)
this function handles dma2 channel4 handler.
Definition: project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c:141
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/at32f435_437_int.c:114
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
DMA2_FDT4_FLAG
#define DMA2_FDT4_FLAG
Definition: at32f435_437_dma.h:107
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • dma
  • dmamux_synchronization_exint
  • src
Macros | Functions | Variables
project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 16

Functions

void | EXINT1_IRQHandler (void)
exint1 interrupt handler More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
dma_init_type dma_init_struct
dmamux_sync_init_type dmamux_sync_init_struct
exint_init_type exint_init_struct
uint16_t | src_buffer [16]
uint16_t | dst_buffer [16]

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • dma
  • dmamux_synchronization_exint
  • src
project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 dma_init_type dma_init_struct;
40 dmamux_sync_init_type dmamux_sync_init_struct;
41 exint_init_type exint_init_struct;
42#define BUFFER_SIZE 16
43uint16_t src_buffer[BUFFER_SIZE] = {0x0001, 0x0002, 0x0003, 0x0004, 0x0005, 0x0006, 0x0007, 0x0008,
44 0x0009, 0x000a, 0x000b, 0x000c, 0x000d, 0x000e, 0x000f, 0x0010};
45
46uint16_t dst_buffer[BUFFER_SIZE];
47
48
54void EXINT1_IRQHandler(void)
55{
56 if(exint_flag_get(EXINT_LINE_1) != RESET)
57 {
58 at32_led_toggle(LED2);
59 exint_flag_clear(EXINT_LINE_1);
60 }
61}
67int main(void)
68{
69 /* initial system clock */
70 system_clock_config();
71
72 /* at board initial */
73 at32_board_init();
74
75 /* enable dma2/gpioa clock */
76 crm_periph_clock_enable(CRM_DMA2_PERIPH_CLOCK, TRUE);
77 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
78 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
79
80 /* config pa1 for input mode */
81 gpio_init_struct.gpio_pins = GPIO_PINS_1;
82 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
83 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
84 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
85 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
86 gpio_init(GPIOA, &gpio_init_struct);
87
88 scfg_exint_line_config(SCFG_PORT_SOURCE_GPIOA, SCFG_PINS_SOURCE1);
89
90 exint_default_para_init(&exint_init_struct);
91 exint_init_struct.line_enable = TRUE;
92 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
93 exint_init_struct.line_select = EXINT_LINE_1;
94 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
95 exint_init(&exint_init_struct);
96
97 /* exint line1 interrupt nvic init */
98 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
99 nvic_irq_enable(EXINT1_IRQn, 1, 0);
100
101 /* dma2 channel4 configuration */
102 dma_reset(DMA2_CHANNEL4);
103 dma_init_struct.buffer_size = BUFFER_SIZE;
104 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
105 dma_init_struct.memory_base_addr = (uint32_t)dst_buffer;
106 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
107 dma_init_struct.memory_inc_enable = TRUE;
108 dma_init_struct.peripheral_base_addr = (uint32_t)src_buffer;
109 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
110 dma_init_struct.peripheral_inc_enable = TRUE;
111 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
112 dma_init_struct.loop_mode_enable = FALSE;
113 dma_init(DMA2_CHANNEL4, &dma_init_struct);
114
115 dmamux_sync_default_para_init(&dmamux_sync_init_struct);
116 dmamux_sync_init_struct.sync_request_number = 4;
117 dmamux_sync_init_struct.sync_signal_sel = DMAMUX_SYNC_ID_EXINT1;
118 dmamux_sync_init_struct.sync_polarity = DMAMUX_SYNC_POLARITY_RISING;
119 dmamux_sync_init_struct.sync_event_enable = TRUE;
120 dmamux_sync_init_struct.sync_enable = TRUE;
121 dmamux_sync_config(DMA2MUX_CHANNEL4, &dmamux_sync_init_struct);
122
123 /* enable transfer full data intterrupt */
124 dma_interrupt_enable(DMA2_CHANNEL4, DMA_FDT_INT, TRUE);
125
126 /* dma2 channel4 interrupt nvic init */
127 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
128 nvic_irq_enable(DMA2_Channel4_IRQn, 1, 0);
129
130 /* dmamux function enable */
131 dmamux_enable(DMA2, TRUE);
132 dmamux_init(DMA2MUX_CHANNEL4, DMAMUX_DMAREQ_ID_TMR1_OVERFLOW);
133
134 /* enable dma channe4 */
135 dma_channel_enable(DMA2_CHANNEL4, TRUE);
136
137 /* tmr1 configuration */
138 tmr_base_init(TMR1, 5000, 0);
139 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
140
141 /* enable tmr1 overflow edam request */
142 tmr_dma_request_enable(TMR1, TMR_OVERFLOW_DMA_REQUEST, TRUE);
143
144 /* enable tmr1 */
145 tmr_counter_enable(TMR1, TRUE);
146 while(1)
147 {
148 }
149}
150
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c:39
EXINT1_IRQHandler
void EXINT1_IRQHandler(void)
exint1 interrupt handler
Definition: project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c:54
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c:42
dst_buffer
uint16_t dst_buffer[16]
Definition: project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c:46
main
int main(void)
main function.
Definition: project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c:67
dmamux_sync_init_struct
dmamux_sync_init_type dmamux_sync_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c:40
src_buffer
uint16_t src_buffer[16]
Definition: project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c:43
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_synchronization_exint/src/main.c:41
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED2
@ LED2
Definition: at32f435_437_board.h:65
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_DMA2_PERIPH_CLOCK
@ CRM_DMA2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:116
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:154
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dmamux_sync_config
void dmamux_sync_config(dmamux_channel_type *dmamux_channelx, dmamux_sync_init_type *dmamux_sync_init_struct)
dmamux synchronization config.
Definition: at32f435_437_dma.c:482
dmamux_sync_default_para_init
void dmamux_sync_default_para_init(dmamux_sync_init_type *dmamux_sync_init_struct)
dmamux sync init struct config with its default value.
Definition: at32f435_437_dma.c:452
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMAMUX_SYNC_POLARITY_RISING
@ DMAMUX_SYNC_POLARITY_RISING
Definition: at32f435_437_dma.h:326
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f435_437_dma.h:183
DMAMUX_SYNC_ID_EXINT1
@ DMAMUX_SYNC_ID_EXINT1
Definition: at32f435_437_dma.h:296
DMAMUX_DMAREQ_ID_TMR1_OVERFLOW
@ DMAMUX_DMAREQ_ID_TMR1_OVERFLOW
Definition: at32f435_437_dma.h:246
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA2MUX_CHANNEL4
#define DMA2MUX_CHANNEL4
Definition: at32f435_437_dma.h:729
DMA2
#define DMA2
Definition: at32f435_437_dma.h:717
DMA2_CHANNEL4
#define DMA2_CHANNEL4
Definition: at32f435_437_dma.h:721
exint_flag_get
flag_status exint_flag_get(uint32_t exint_line)
get exint flag
Definition: at32f435_437_exint.c:142
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f435_437_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
EXINT_LINE_1
#define EXINT_LINE_1
Definition: at32f435_437_exint.h:53
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f435_437_gpio.h:82
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
scfg_exint_line_config
void scfg_exint_line_config(scfg_port_source_type port_source, scfg_pins_source_type pin_source)
select the gpio pin used as exint line.
Definition: at32f435_437_scfg.c:152
SCFG_PINS_SOURCE1
@ SCFG_PINS_SOURCE1
Definition: at32f435_437_scfg.h:102
SCFG_PORT_SOURCE_GPIOA
@ SCFG_PORT_SOURCE_GPIOA
Definition: at32f435_437_scfg.h:124
tmr_dma_request_enable
void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request
Definition: at32f435_437_tmr.c:1358
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
TMR_OVERFLOW_DMA_REQUEST
@ TMR_OVERFLOW_DMA_REQUEST
Definition: at32f435_437_tmr.h:271
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
DMA2_Channel4_IRQn
@ DMA2_Channel4_IRQn
Definition: at32f435_437.h:238
EXINT1_IRQn
@ EXINT1_IRQn
Definition: at32f435_437.h:153
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
dmamux_sync_init_type
dmamux sync init type
Definition: at32f435_437_dma.h:393
dmamux_sync_init_type::sync_enable
confirm_state sync_enable
Definition: at32f435_437_dma.h:398
dmamux_sync_init_type::sync_request_number
uint32_t sync_request_number
Definition: at32f435_437_dma.h:396
dmamux_sync_init_type::sync_event_enable
confirm_state sync_event_enable
Definition: at32f435_437_dma.h:397
dmamux_sync_init_type::sync_polarity
uint32_t sync_polarity
Definition: at32f435_437_dma.h:395
dmamux_sync_init_type::sync_signal_sel
dmamux_sync_id_sel_type sync_signal_sel
Definition: at32f435_437_dma.h:394
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • dma
  • flash_to_sram
  • inc
project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • dma
  • flash_to_sram
  • inc
project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • dma
  • flash_to_sram
  • inc
project/at_start_f435/examples/dma/flash_to_sram/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • dma
  • flash_to_sram
  • src
Functions
project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • dma
  • flash_to_sram
  • src
project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • dma
  • flash_to_sram
  • src
Functions | Variables
project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1 channel1 handler. More...

Variables

__IO uint32_t data_counter_end

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • dma
  • flash_to_sram
  • src
project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29#include "at32f435_437_board.h"
30
31extern __IO uint32_t data_counter_end;
32
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while (1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while (1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while (1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while (1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
143void DMA1_Channel1_IRQHandler(void)
144{
145 if(dma_flag_get(DMA1_FDT1_FLAG) != RESET)
146 {
147 data_counter_end = 0;
148 dma_flag_clear(DMA1_FDT1_FLAG);
149 }
150}
151
152
at32f435_437_board.h
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c:107
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c:125
data_counter_end
__IO uint32_t data_counter_end
Definition: project/at_start_f435/examples/dma/flash_to_sram/src/main.c:51
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c:46
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1 channel1 handler.
Definition: project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c:143
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c:81
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c:134
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/dma/flash_to_sram/src/at32f435_437_int.c:116
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f435_437_dma.h:66
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • dma
  • flash_to_sram
  • src
Macros | Functions | Variables
project/at_start_f435/examples/dma/flash_to_sram/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 32

Functions

error_status | buffer_compare (const uint32_t *pbuffer, uint32_t *pbuffer1, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

const uint32_t | src_const_buffer [32]
uint32_t | dst_buffer [32]
gpio_init_type | gpio_init_struct = {0}
dma_init_type dma_init_struct
__IO uint32_t | data_counter_end = 0x01
error_status transfer_status = ERROR

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dma/flash_to_sram/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • dma
  • flash_to_sram
  • src
project/at_start_f435/examples/dma/flash_to_sram/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define BUFFER_SIZE 32
39
40const uint32_t src_const_buffer[BUFFER_SIZE]= {0x01020304, 0x05060708, 0x090A0B0C, 0x0D0E0F10,
41 0x11121314, 0x15161718, 0x191A1B1C, 0x1D1E1F20,
42 0x21222324, 0x25262728, 0x292A2B2C, 0x2D2E2F30,
43 0x31323334, 0x35363738, 0x393A3B3C, 0x3D3E3F40,
44 0x41424344, 0x45464748, 0x494A4B4C, 0x4D4E4F50,
45 0x51525354, 0x55565758, 0x595A5B5C, 0x5D5E5F60,
46 0x61626364, 0x65666768, 0x696A6B6C, 0x6D6E6F70,
47 0x71727374, 0x75767778, 0x797A7B7C, 0x7D7E7F80};
48uint32_t dst_buffer[BUFFER_SIZE];
49 gpio_init_type gpio_init_struct = {0};
50 dma_init_type dma_init_struct;
51__IO uint32_t data_counter_end = 0x01; /* this variable should not be initialized to 0 */
52 error_status transfer_status = ERROR;
53
61 error_status buffer_compare(const uint32_t* pbuffer, uint32_t* pbuffer1, uint16_t buffer_length)
62{
63 while(buffer_length--)
64 {
65 if(*pbuffer != *pbuffer1)
66 {
67 return ERROR;
68 }
69
70 pbuffer++;
71 pbuffer1++;
72 }
73
74 return SUCCESS;
75}
76
82int main(void)
83{
84 /* initial system clock */
85 system_clock_config();
86
87 /* at board initial */
88 at32_board_init();
89
90 /* enable dma1 clock */
91 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
92
93 /* dma1 channel1 configuration */
94 dma_reset(DMA1_CHANNEL1);
95 dma_init_struct.buffer_size = BUFFER_SIZE;
96 dma_init_struct.direction = DMA_DIR_MEMORY_TO_MEMORY;
97 dma_init_struct.memory_base_addr = (uint32_t)dst_buffer;
98 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_WORD;
99 dma_init_struct.memory_inc_enable = TRUE;
100 dma_init_struct.peripheral_base_addr = (uint32_t)src_const_buffer;
101 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_WORD;
102 dma_init_struct.peripheral_inc_enable = TRUE;
103 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
104 dma_init_struct.loop_mode_enable = FALSE;
105 dma_init(DMA1_CHANNEL1, &dma_init_struct);
106
107 /* enable transfer full data intterrupt */
108 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
109
110 /* dma1 channel1 interrupt nvic init */
111 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
112 nvic_irq_enable(DMA1_Channel1_IRQn, 1, 0);
113
114 dma_channel_enable(DMA1_CHANNEL1, TRUE);
115
116 /* wait the end of transmission */
117 while(data_counter_end != 0)
118 {
119 }
120
121 /* check if the transmitted and received data are equal */
122 transfer_status = buffer_compare(src_const_buffer, dst_buffer, BUFFER_SIZE);
123
124 /* transfer_status = success, if the transmitted and received data are the same
125 transfer_status = error, if the transmitted and received data are different */
126 if(transfer_status == SUCCESS)
127 {
128 /* turn led2/led3/led4 on */
129 at32_led_on(LED2);
130 at32_led_on(LED3);
131 at32_led_on(LED4);
132 }
133
134 while(1)
135 {
136 }
137}
138
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dma/flash_to_sram/src/main.c:49
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dma/flash_to_sram/src/main.c:50
src_const_buffer
const uint32_t src_const_buffer[32]
Definition: project/at_start_f435/examples/dma/flash_to_sram/src/main.c:40
data_counter_end
__IO uint32_t data_counter_end
Definition: project/at_start_f435/examples/dma/flash_to_sram/src/main.c:51
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f435/examples/dma/flash_to_sram/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f435/examples/dma/flash_to_sram/src/main.c:82
dst_buffer
uint32_t dst_buffer[32]
Definition: project/at_start_f435/examples/dma/flash_to_sram/src/main.c:48
buffer_compare
error_status buffer_compare(const uint32_t *pbuffer, uint32_t *pbuffer1, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f435/examples/dma/flash_to_sram/src/main.c:61
transfer_status
error_status transfer_status
Definition: project/at_start_f435/examples/dma/flash_to_sram/src/main.c:52
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:164
DMA_DIR_MEMORY_TO_MEMORY
@ DMA_DIR_MEMORY_TO_MEMORY
Definition: at32f435_437_dma.h:154
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f435_437_dma.h:174
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f435_437_dma.h:183
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f435_437.h:204
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • inc
project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • inc
project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • inc
project/at_start_f435/examples/dvp/ov2640_capture/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • src
Functions
project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • src
project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 *(__IO uint32_t*)0x40023C60 &= 0xFFFFFFFC;
120 *(__IO uint32_t*)0x40023C60 |= 0x00000001;
121 while ((*(__IO uint32_t*)0x40023C60 & 0x30) != 0x10)
122 {
123 }
124
125 /* update system_core_clock global variable */
126 system_core_clock_update();
127}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • src
Functions
project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • src
project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/dvp/ov2640_capture/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • src
Functions | Variables
project/at_start_f435/examples/dvp/ov2640_capture/src/main.c File Reference

main program More...

#include "at32f435_437.h"
#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include "xmc_lcd.h"
#include "ov2640.h"
#include "dvp.h"

Go to the source code of this file.

Functions

void | ov2640_capture (void)
int | main (void)
main function. More...

Variables

uint16_t point_color

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dvp/ov2640_capture/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • dvp
  • ov2640_capture
  • src
project/at_start_f435/examples/dvp/ov2640_capture/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437.h"
28#include "at32f435_437_board.h"
29#include "at32f435_437_clock.h"
30#include "xmc_lcd.h"
31#include "ov2640.h"
32#include "dvp.h"
33
42uint16_t point_color;
43void ov2640_capture(void);
44
50int main(void)
51{
52 lcd_struct = &lcd_dev_struct;
53 system_clock_config();
54
55 at32_board_init();
56 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
57 lcd_struct->lcd_init();
58 point_color = WHITE;
59 lcd_struct->lcd_clear(point_color);
60
61 lcd_string_show(30, 50, 200, 16, 16, (uint8_t *)"Artery AT32F435/F437");
62 lcd_string_show(30, 70, 200, 16, 16, (uint8_t *)"OV2640 TEST");
63 lcd_string_show(30, 90, 200, 16, 16, (uint8_t *)"2021/6/21");
64
65 delay_ms(500);
66 while(ov2640_init() != SUCCESS)
67 {
68 lcd_string_show(30, 130, 240, 16, 16, (uint8_t *)"OV2640 ERR");
69 delay_ms(200);
70 lcd_fill(30, 130, 239, 170, WHITE);
71 delay_ms(200);
72 at32_led_toggle(LED2);
73 }
74
75 lcd_string_show(30, 130, 200, 16, 16, (uint8_t *)"OV2640 OK");
76
77 delay_ms(500);
78 ov2640_capture();
79 while(1)
80 {
81
82 }
83}
84
85void ov2640_capture(void)
86{
87 lcd_clear(WHITE);
88
89 lcd_string_show(30, 50, 200, 16, 16, (uint8_t *)"Artery AT32F435/F437");
90 lcd_string_show(30, 70, 200, 16, 16, (uint8_t *)"OV2640 RGB565 Mode");
91 lcd_string_show(30, 90, 200, 16, 16, (uint8_t *)"DVP Initializing...");
92
93 ov2640_rgb565_mode();
94 ov2640_light_mode(3);
95 ov2640_color_saturation(2);
96 ov2640_brightness(4);
97 ov2640_contrast(2);
98
99 dvp_config();
100
101 dvp_dma_init((uint32_t)XMC_LCD_DATA, 0, 38400);
102
103 delay_ms(100);
104 lcd_clear(BLACK);
105 ov2640_outsize_set(LCD_W, LCD_H);
106 dvp_start();
107}
108
at32f435_437.h
at32f435_437 header file
at32f435_437_board.h
ov2640_init
error_status ov2640_init(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:84
LCD_H
#define LCD_H
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:79
ov2640_capture
void ov2640_capture(void)
Definition: project/at_start_f435/examples/dvp/ov2640_capture/src/main.c:85
lcd_dev_struct
lcd_dev_type lcd_dev_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:38
dvp_start
void dvp_start(void)
start dvp transmission
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:169
ov2640_light_mode
void ov2640_light_mode(u8 mode)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:210
lcd_string_show
void lcd_string_show(uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p)
this function is show string to lcd
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:474
lcd_fill
void lcd_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color)
this function is fill in lcd with concolorous
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:508
BLACK
#define BLACK
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:85
ov2640_brightness
void ov2640_brightness(u8 bright)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:265
main
int main(void)
main function.
Definition: project/at_start_f435/examples/dvp/ov2640_capture/src/main.c:50
WHITE
#define WHITE
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:84
ov2640_outsize_set
u8 ov2640_outsize_set(u16 width, u16 height)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:389
LCD_W
#define LCD_W
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:78
point_color
uint16_t point_color
Definition: project/at_start_f435/examples/dvp/ov2640_capture/src/main.c:42
ov2640_rgb565_mode
void ov2640_rgb565_mode(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:151
lcd_clear
void lcd_clear(uint16_t color)
this function is clear the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:379
dvp_dma_init
void dvp_dma_init(uint32_t mem0addr, uint32_t mem1addr, uint16_t memsize)
initialize dma for dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:129
ov2640_contrast
void ov2640_contrast(u8 contrast)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:280
lcd_struct
lcd_dev_type * lcd_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:48
dvp_config
void dvp_config(void)
configure dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:60
ov2640_color_saturation
void ov2640_color_saturation(u8 sat)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:249
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
XMC_LCD_DATA
#define XMC_LCD_DATA
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
lcd_dev_type::lcd_clear
void(* lcd_clear)(uint16_t color)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:50
lcd_dev_type::lcd_init
void(* lcd_init)(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:47
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • inc
project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • inc
project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • inc
project/at_start_f435/examples/dvp/ov5640_capture/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • src
Functions
project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • src
project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 *(__IO uint32_t*)0x40023C60 &= 0xFFFFFFFC;
120 *(__IO uint32_t*)0x40023C60 |= 0x00000001;
121 while ((*(__IO uint32_t*)0x40023C60 & 0x30) != 0x10)
122 {
123 }
124
125 /* update system_core_clock global variable */
126 system_core_clock_update();
127}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • src
Functions
project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • src
project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/dvp/ov5640_capture/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • src
Functions | Variables
project/at_start_f435/examples/dvp/ov5640_capture/src/main.c File Reference

main program More...

#include "at32f435_437.h"
#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include "xmc_lcd.h"
#include "ov5640.h"
#include "dvp.h"

Go to the source code of this file.

Functions

void | ov5640_capture (void)
int | main (void)
main function. More...

Variables

uint16_t point_color

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/dvp/ov5640_capture/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • dvp
  • ov5640_capture
  • src
project/at_start_f435/examples/dvp/ov5640_capture/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437.h"
28#include "at32f435_437_board.h"
29#include "at32f435_437_clock.h"
30#include "xmc_lcd.h"
31#include "ov5640.h"
32#include "dvp.h"
33
42uint16_t point_color;
43void ov5640_capture(void);
44
50int main(void)
51{
52 lcd_struct = &lcd_dev_struct;
53 system_clock_config();
54
55 at32_board_init();
56 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
57 lcd_struct->lcd_init();
58 point_color = WHITE;
59 lcd_struct->lcd_clear(point_color);
60
61 lcd_string_show(30, 50, 200, 16, 16, (uint8_t *)"Artery AT32F435/F437");
62 lcd_string_show(30, 70, 200, 16, 16, (uint8_t *)"OV5640 TEST");
63 lcd_string_show(30, 90, 200, 16, 16, (uint8_t *)"2021/6/21");
64
65 delay_ms(500);
66 while(ov5640_init() != SUCCESS)
67 {
68 lcd_string_show(30, 130, 240, 16, 16, (uint8_t *)"OV5640 ERR");
69 delay_ms(200);
70 lcd_fill(30, 130, 239, 170, WHITE);
71 delay_ms(200);
72 at32_led_toggle(LED2);
73 }
74
75 lcd_string_show(30, 130, 200, 16, 16, (uint8_t *)"OV5640 OK");
76
77 delay_ms(500);
78 ov5640_capture();
79 while(1)
80 {
81
82 }
83}
84
85void ov5640_capture(void)
86{
87 uint8_t reg_val = 0;
88 lcd_clear(WHITE);
89
90 lcd_string_show(30, 50, 200, 16, 16, (uint8_t *)"Artery AT32F435/F437");
91 lcd_string_show(30, 70, 200, 16, 16, (uint8_t *)"OV5640 RGB565 Mode");
92 lcd_string_show(30, 90, 200, 16, 16, (uint8_t *)"DVP Initializing...");
93
94 ov5640_rgb565_mode();
95 ov5640_focus_init();
96 ov5640_light_mode(0);
97 ov5640_color_saturation(3);
98 ov5640_brightness(4);
99 ov5640_contrast(3);
100 ov5640_sharpness(33);
101 ov5640_focus_constant();
102
103 dvp_config();
104
105 dvp_dma_init((uint32_t)XMC_LCD_DATA, 0, 38400);
106
107 delay_ms(100);
108 ov5640_outsize_set(0, 0, LCD_W, LCD_H);
109 ov5640_reg_read(0x4730, &reg_val);
110 dvp_start();
111}
112
at32f435_437.h
at32f435_437 header file
at32f435_437_board.h
LCD_H
#define LCD_H
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:79
lcd_dev_struct
lcd_dev_type lcd_dev_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:38
dvp_start
void dvp_start(void)
start dvp transmission
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:169
lcd_string_show
void lcd_string_show(uint16_t x, uint16_t y, uint16_t width, uint16_t height, uint8_t size, uint8_t *p)
this function is show string to lcd
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:474
lcd_fill
void lcd_fill(uint16_t sx, uint16_t sy, uint16_t ex, uint16_t ey, uint16_t color)
this function is fill in lcd with concolorous
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:508
WHITE
#define WHITE
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:84
LCD_W
#define LCD_W
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:78
lcd_clear
void lcd_clear(uint16_t color)
this function is clear the lcd.
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:379
dvp_dma_init
void dvp_dma_init(uint32_t mem0addr, uint32_t mem1addr, uint16_t memsize)
initialize dma for dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:129
lcd_struct
lcd_dev_type * lcd_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.c:48
dvp_config
void dvp_config(void)
configure dvp
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:60
ov5640_init
error_status ov5640_init(void)
initialize ov5640
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:160
ov5640_outsize_set
void ov5640_outsize_set(uint16_t offx, uint16_t offy, uint16_t width, uint16_t height)
ov5640 output size set
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:459
ov5640_light_mode
void ov5640_light_mode(uint8_t mode)
this function is draw point to lcd
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:269
ov5640_focus_constant
error_status ov5640_focus_constant(void)
ov5640 focus constant
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:587
ov5640_brightness
void ov5640_brightness(uint8_t bright)
ov5640 brightness configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:312
ov5640_reg_read
error_status ov5640_reg_read(uint16_t reg, uint8_t *data)
read register from ov5640
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:136
ov5640_color_saturation
void ov5640_color_saturation(uint8_t sat)
ov5640 color saturation configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:288
ov5640_rgb565_mode
void ov5640_rgb565_mode(void)
ov5640 rgb565 mode configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:231
ov5640_sharpness
void ov5640_sharpness(uint8_t sharp)
ov5640 sharpness configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:393
main
int main(void)
main function.
Definition: project/at_start_f435/examples/dvp/ov5640_capture/src/main.c:50
point_color
uint16_t point_color
Definition: project/at_start_f435/examples/dvp/ov5640_capture/src/main.c:42
ov5640_focus_init
error_status ov5640_focus_init(void)
initialize ov5640 focus function
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:510
ov5640_capture
void ov5640_capture(void)
Definition: project/at_start_f435/examples/dvp/ov5640_capture/src/main.c:85
ov5640_contrast
void ov5640_contrast(uint8_t contrast)
ov5640 contrast configure
Definition: at_start_f435/examples/dvp/ov5640_capture/hardware/ov5640/ov5640.c:346
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
XMC_LCD_DATA
#define XMC_LCD_DATA
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
lcd_dev_type::lcd_clear
void(* lcd_clear)(uint16_t color)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:50
lcd_dev_type::lcd_init
void(* lcd_init)(void)
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/lcd/xmc_lcd.h:47
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • edma
  • burst_mode
  • inc
project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • edma
  • burst_mode
  • inc
project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • edma
  • burst_mode
  • inc
project/at_start_f435/examples/edma/burst_mode/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • edma
  • burst_mode
  • src
Functions
project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • edma
  • burst_mode
  • src
project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • edma
  • burst_mode
  • src
Functions
project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • edma
  • burst_mode
  • src
project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while (1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while (1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while (1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while (1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
135
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/edma/burst_mode/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • edma
  • burst_mode
  • src
Functions | Variables
project/at_start_f435/examples/edma/burst_mode/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

int | main (void)
main function. More...
void | TMR1_OVF_TMR10_IRQHandler (void)
this function handles timer1 overflow handler. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
edma_init_type edma_init_struct
uint32_t | duty_buffer [4] = {10,10,10,10}

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/burst_mode/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • edma
  • burst_mode
  • src
project/at_start_f435/examples/edma/burst_mode/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 tmr_output_config_type tmr_output_struct;
40 edma_init_type edma_init_struct;
41
42uint32_t duty_buffer[4] = {10,10,10,10};
43
49int main(void)
50{
51 system_clock_config();
52
53 at32_board_init();
54
55 /* turn led2/led3/led4 on */
56 at32_led_on(LED2);
57 at32_led_on(LED3);
58 at32_led_on(LED4);
59
60 /* enable tmr1/gpioa clock */
61 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
62 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
63
64 /* enable dma1 clock */
65 crm_periph_clock_enable(CRM_EDMA_PERIPH_CLOCK, TRUE);
66
67 /* timer1 output pin Configuration */
68 gpio_init_struct.gpio_pins = GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11;
69 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
70 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
71 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
72 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
73 gpio_init(GPIOA, &gpio_init_struct);
74
75 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE8, GPIO_MUX_1);
76 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE9, GPIO_MUX_1);
77 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE10, GPIO_MUX_1);
78 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE11, GPIO_MUX_1);
79
80 /* i2s2_rx:edma stream1 configuration */
81 edma_default_para_init(&edma_init_struct);
82 edma_init_struct.direction = EDMA_DIR_MEMORY_TO_PERIPHERAL;
83 edma_init_struct.buffer_size = (uint32_t)4;
84 edma_init_struct.peripheral_data_width = EDMA_PERIPHERAL_DATA_WIDTH_WORD;
85 edma_init_struct.peripheral_base_addr = (uint32_t)&(TMR1->c1dt);
86 edma_init_struct.peripheral_inc_enable = TRUE;
87 edma_init_struct.memory_data_width = EDMA_MEMORY_DATA_WIDTH_WORD;
88 edma_init_struct.memory0_base_addr = (uint32_t)duty_buffer;
89 edma_init_struct.memory_inc_enable = TRUE;
90 edma_init_struct.peripheral_burst_mode = EDMA_PERIPHERAL_BURST_4;
91 edma_init_struct.memory_burst_mode = EDMA_MEMORY_BURST_4;
92 edma_init_struct.fifo_mode_enable = TRUE;
93 edma_init_struct.fifo_threshold = EDMA_FIFO_THRESHOLD_FULL;
94 edma_init_struct.priority = EDMA_PRIORITY_HIGH;
95 edma_init_struct.loop_mode_enable = TRUE;
96 edma_init(EDMA_STREAM1, &edma_init_struct);
97
98 /* edmamux init */
99 edmamux_enable(TRUE);
100 edmamux_init(EDMAMUX_CHANNEL1, EDMAMUX_DMAREQ_ID_TMR1_OVERFLOW);
101
102 /* enable stream */
103 edma_stream_enable(EDMA_STREAM1, TRUE);
104
105 /* tmr1 configuration */
106 tmr_base_init(TMR1, 500, 0);
107 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
108
109 /* channel 1, 2, 3 and 4 configuration in output mode */
110 tmr_output_default_para_init(&tmr_output_struct);
111 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_B;
112 tmr_output_struct.oc_output_state = TRUE;
113 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
114 tmr_output_struct.oc_idle_state = TRUE;
115 tmr_output_struct.occ_output_state = FALSE;
116 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_HIGH;
117 tmr_output_struct.occ_idle_state = FALSE;
118
119 /* channel 1 */
120 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
121 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, duty_buffer[0]);
122
123 /* channel 2 */
124 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_2, &tmr_output_struct);
125 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_2, duty_buffer[1]);
126
127 /* channel 3 */
128 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_3, &tmr_output_struct);
129 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_3, duty_buffer[2]);
130
131 /* channel 4 */
132 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_4, &tmr_output_struct);
133 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_4, duty_buffer[3]);
134
135 /* tmr1 output enable */
136 tmr_output_enable(TMR1, TRUE);
137
138 /* enable tmr1 overflow edam request */
139 tmr_dma_request_enable(TMR1, TMR_OVERFLOW_DMA_REQUEST, TRUE);
140
141 /* overflow interrupt enable */
142 tmr_interrupt_enable(TMR1, TMR_OVF_INT, TRUE);
143
144 /* tmr1 overflow interrupt nvic init */
145 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
146 nvic_irq_enable(TMR1_OVF_TMR10_IRQn, 1, 0);
147
148 /* enable tmr1 */
149 tmr_counter_enable(TMR1, TRUE);
150
151 while(1)
152 {
153 }
154}
155
161void TMR1_OVF_TMR10_IRQHandler(void)
162{
163 if(tmr_flag_get(TMR1, TMR_OVF_FLAG) == SET)
164 {
165 /* change duty_buffer data value */
166 duty_buffer[0] += 10;
167 duty_buffer[1] += 10;
168 duty_buffer[2] += 10;
169 duty_buffer[3] += 10;
170
171 if(duty_buffer[0] >= 500)
172 {
173 duty_buffer[0] = 10;
174 duty_buffer[1] = 10;
175 duty_buffer[2] = 10;
176 duty_buffer[3] = 10;
177 }
178
179 /* clear tmr1 overflow flag */
180 tmr_flag_clear(TMR1, TMR_OVF_FLAG);
181 }
182}
183
184
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/edma/burst_mode/src/main.c:38
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f435/examples/edma/burst_mode/src/main.c:39
edma_init_struct
edma_init_type edma_init_struct
Definition: project/at_start_f435/examples/edma/burst_mode/src/main.c:40
duty_buffer
uint32_t duty_buffer[4]
Definition: project/at_start_f435/examples/edma/burst_mode/src/main.c:42
main
int main(void)
main function.
Definition: project/at_start_f435/examples/edma/burst_mode/src/main.c:49
TMR1_OVF_TMR10_IRQHandler
void TMR1_OVF_TMR10_IRQHandler(void)
this function handles timer1 overflow handler.
Definition: project/at_start_f435/examples/edma/burst_mode/src/main.c:161
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_EDMA_PERIPH_CLOCK
@ CRM_EDMA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:114
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:154
edmamux_init
void edmamux_init(edmamux_channel_type *edmamux_channelx, edmamux_requst_id_sel_type edmamux_req_id)
edmamux init.
Definition: at32f435_437_edma.c:718
edma_init
void edma_init(edma_stream_type *edma_streamx, edma_init_type *edma_init_struct)
edma init.
Definition: at32f435_437_edma.c:115
edma_stream_enable
void edma_stream_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx.
Definition: at32f435_437_edma.c:198
edmamux_enable
void edmamux_enable(confirm_state new_state)
enable or disable the edma edmamux.
Definition: at32f435_437_edma.c:673
edma_default_para_init
void edma_default_para_init(edma_init_type *edma_init_struct)
edma init struct config with its default value.
Definition: at32f435_437_edma.c:165
EDMA_PRIORITY_HIGH
@ EDMA_PRIORITY_HIGH
Definition: at32f435_437_edma.h:191
EDMA_PERIPHERAL_DATA_WIDTH_WORD
@ EDMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_edma.h:171
EDMA_MEMORY_DATA_WIDTH_WORD
@ EDMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f435_437_edma.h:181
EDMA_MEMORY_BURST_4
@ EDMA_MEMORY_BURST_4
Definition: at32f435_437_edma.h:225
EDMA_PERIPHERAL_BURST_4
@ EDMA_PERIPHERAL_BURST_4
Definition: at32f435_437_edma.h:236
EDMA_FIFO_THRESHOLD_FULL
@ EDMA_FIFO_THRESHOLD_FULL
Definition: at32f435_437_edma.h:203
EDMA_DIR_MEMORY_TO_PERIPHERAL
@ EDMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_edma.h:160
EDMAMUX_DMAREQ_ID_TMR1_OVERFLOW
@ EDMAMUX_DMAREQ_ID_TMR1_OVERFLOW
Definition: at32f435_437_edma.h:308
EDMA_STREAM1
#define EDMA_STREAM1
Definition: at32f435_437_edma.h:962
EDMAMUX_CHANNEL1
#define EDMAMUX_CHANNEL1
Definition: at32f435_437_edma.h:989
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_1
@ GPIO_MUX_1
Definition: at32f435_437_gpio.h:157
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f435_437_tmr.c:1463
tmr_dma_request_enable
void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request
Definition: at32f435_437_tmr.c:1358
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f435_437_tmr.c:1424
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f435_437_tmr.c:1499
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f435_437_tmr.c:1389
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_OVERFLOW_DMA_REQUEST
@ TMR_OVERFLOW_DMA_REQUEST
Definition: at32f435_437_tmr.h:271
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f435_437_tmr.h:221
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f435_437_tmr.h:223
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f435_437_tmr.h:219
TMR_OUTPUT_CONTROL_PWM_MODE_B
@ TMR_OUTPUT_CONTROL_PWM_MODE_B
Definition: at32f435_437_tmr.h:181
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:198
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f435_437_tmr.h:199
TMR_OVF_FLAG
#define TMR_OVF_FLAG
Definition: at32f435_437_tmr.h:52
TMR_OVF_INT
#define TMR_OVF_INT
Definition: at32f435_437_tmr.h:75
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
TMR1_OVF_TMR10_IRQn
@ TMR1_OVF_TMR10_IRQn
Definition: at32f435_437.h:173
edma_init_type
edma init type
Definition: at32f435_437_edma.h:440
edma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_edma.h:441
edma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_edma.h:444
edma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_edma.h:446
edma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_edma.h:445
edma_init_type::direction
edma_dir_type direction
Definition: at32f435_437_edma.h:443
edma_init_type::fifo_mode_enable
confirm_state fifo_mode_enable
Definition: at32f435_437_edma.h:451
edma_init_type::peripheral_data_width
edma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_edma.h:447
edma_init_type::fifo_threshold
edma_fifo_threshold_type fifo_threshold
Definition: at32f435_437_edma.h:452
edma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_edma.h:449
edma_init_type::priority
edma_priority_level_type priority
Definition: at32f435_437_edma.h:450
edma_init_type::memory0_base_addr
uint32_t memory0_base_addr
Definition: at32f435_437_edma.h:442
edma_init_type::peripheral_burst_mode
edma_peripheral_burst_type peripheral_burst_mode
Definition: at32f435_437_edma.h:454
edma_init_type::memory_data_width
edma_memory_data_size_type memory_data_width
Definition: at32f435_437_edma.h:448
edma_init_type::memory_burst_mode
edma_memory_burst_type memory_burst_mode
Definition: at32f435_437_edma.h:453
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f435_437_tmr.h:418
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f435_437_tmr.h:416
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f435_437_tmr.h:414
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • edma
  • dmamux_genertor_exint
  • inc
project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • edma
  • dmamux_genertor_exint
  • inc
project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • edma
  • dmamux_genertor_exint
  • inc
project/at_start_f435/examples/edma/dmamux_genertor_exint/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • edma
  • dmamux_genertor_exint
  • src
Functions
project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • edma
  • dmamux_genertor_exint
  • src
project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • edma
  • dmamux_genertor_exint
  • src
Functions
project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • edma
  • dmamux_genertor_exint
  • src
project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while (1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while (1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while (1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while (1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/edma/dmamux_genertor_exint/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • edma
  • dmamux_genertor_exint
  • src
Macros | Functions | Variables
project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 16

Functions

void | EDMA_Stream4_IRQHandler (void)
this function handles edma stream4 handler. More...
void | EXINT1_IRQHandler (void)
exint1 interrupt handler More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
edma_init_type edma_init_struct
edmamux_gen_init_type dmamux_gen_init_struct
exint_init_type exint_init_struct
uint16_t | src_buffer [16]
uint16_t | dst_buffer [16]

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • edma
  • dmamux_genertor_exint
  • src
project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 edma_init_type edma_init_struct;
40 edmamux_gen_init_type dmamux_gen_init_struct;
41 exint_init_type exint_init_struct;
42
43#define BUFFER_SIZE 16
44uint16_t src_buffer[BUFFER_SIZE] = {0x0001, 0x0002, 0x0003, 0x0004, 0x0005, 0x0006, 0x0007, 0x0008,
45 0x0009, 0x000a, 0x000b, 0x000c, 0x000d, 0x000e, 0x000f, 0x0010};
46
47uint16_t dst_buffer[BUFFER_SIZE];
48
54void EDMA_Stream4_IRQHandler(void)
55{
56 if(edma_flag_get(EDMA_FDT4_FLAG) != RESET)
57 {
58 /* turn led2/led3/led4 on */
59 at32_led_on(LED2);
60 at32_led_on(LED3);
61 at32_led_on(LED4);
62 edma_flag_clear(EDMA_FDT4_FLAG);
63 }
64}
65
71void EXINT1_IRQHandler(void)
72{
73 if(exint_flag_get(EXINT_LINE_1) != RESET)
74 {
75 at32_led_toggle(LED2);
76 exint_flag_clear(EXINT_LINE_1);
77 }
78}
84int main(void)
85{
86 system_clock_config();
87
88 at32_board_init();
89
90 /* enable edma/gpioa clock */
91 crm_periph_clock_enable(CRM_EDMA_PERIPH_CLOCK, TRUE);
92 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
93
94 /* config pa1 for input mode */
95 gpio_init_struct.gpio_pins = GPIO_PINS_1;
96 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
97 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
98 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
99 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
100 gpio_init(GPIOA, &gpio_init_struct);
101
102 scfg_exint_line_config(SCFG_PORT_SOURCE_GPIOA, SCFG_PINS_SOURCE1);
103
104 exint_default_para_init(&exint_init_struct);
105 exint_init_struct.line_enable = TRUE;
106 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
107 exint_init_struct.line_select = EXINT_LINE_1;
108 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
109 exint_init(&exint_init_struct);
110
111 /* exint line1 interrupt nvic init */
112 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
113 nvic_irq_enable(EXINT1_IRQn, 1, 0);
114
115 /* edma stream4 configuration */
116 edma_default_para_init(&edma_init_struct);
117 edma_init_struct.direction = EDMA_DIR_PERIPHERAL_TO_MEMORY;
118 edma_init_struct.buffer_size = (uint32_t)16;
119 edma_init_struct.peripheral_data_width = EDMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
120 edma_init_struct.peripheral_base_addr = (uint32_t)src_buffer;
121 edma_init_struct.peripheral_inc_enable = TRUE;
122 edma_init_struct.memory_data_width = EDMA_MEMORY_DATA_WIDTH_HALFWORD;
123 edma_init_struct.memory0_base_addr = (uint32_t)dst_buffer;
124 edma_init_struct.memory_inc_enable = TRUE;
125 edma_init_struct.peripheral_burst_mode = EDMA_PERIPHERAL_SINGLE;
126 edma_init_struct.memory_burst_mode = EDMA_MEMORY_SINGLE;
127 edma_init_struct.fifo_mode_enable = FALSE;
128 edma_init_struct.fifo_threshold = EDMA_FIFO_THRESHOLD_1QUARTER;
129 edma_init_struct.priority = EDMA_PRIORITY_HIGH;
130 edma_init_struct.loop_mode_enable = FALSE;
131 edma_init(EDMA_STREAM4, &edma_init_struct);
132
133 /* genertor1 configuration */
134 edmamux_generator_default_para_init(&dmamux_gen_init_struct);
135 dmamux_gen_init_struct.gen_polarity = EDMAMUX_GEN_POLARITY_RISING;
136 dmamux_gen_init_struct.gen_request_number = 4;
137 dmamux_gen_init_struct.gen_signal_sel = EDMAMUX_GEN_ID_EXINT1;
138 dmamux_gen_init_struct.gen_enable = TRUE;
139 edmamux_generator_config(EDMAMUX_GENERATOR1, &dmamux_gen_init_struct);
140
141 /* enable transfer full data intterrupt */
142 edma_interrupt_enable(EDMA_STREAM4, EDMA_FDT_INT, TRUE);
143
144 /* edma stream4 interrupt nvic init */
145 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
146 nvic_irq_enable(EDMA_Stream4_IRQn, 1, 0);
147
148 /* dmamux function enable */
149 edmamux_enable(TRUE);
150 edmamux_init(EDMAMUX_CHANNEL4, EDMAMUX_DMAREQ_ID_REQ_G1);
151
152 /* enable edma stream4 */
153 edma_stream_enable(EDMA_STREAM4, TRUE);
154
155 while(1)
156 {
157 }
158}
159
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c:38
edma_init_struct
edma_init_type edma_init_struct
Definition: project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c:39
EXINT1_IRQHandler
void EXINT1_IRQHandler(void)
exint1 interrupt handler
Definition: project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c:71
dmamux_gen_init_struct
edmamux_gen_init_type dmamux_gen_init_struct
Definition: project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c:40
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c:43
dst_buffer
uint16_t dst_buffer[16]
Definition: project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c:47
main
int main(void)
main function.
Definition: project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c:84
src_buffer
uint16_t src_buffer[16]
Definition: project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c:44
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c:41
EDMA_Stream4_IRQHandler
void EDMA_Stream4_IRQHandler(void)
this function handles edma stream4 handler.
Definition: project/at_start_f435/examples/edma/dmamux_genertor_exint/src/main.c:54
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_EDMA_PERIPH_CLOCK
@ CRM_EDMA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:114
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
edma_flag_get
flag_status edma_flag_get(uint32_t edma_flag)
get the edma flag.
Definition: at32f435_437_edma.c:512
edma_flag_clear
void edma_flag_clear(uint32_t edma_flag)
clear the edma flag.
Definition: at32f435_437_edma.c:549
edmamux_init
void edmamux_init(edmamux_channel_type *edmamux_channelx, edmamux_requst_id_sel_type edmamux_req_id)
edmamux init.
Definition: at32f435_437_edma.c:718
edmamux_generator_default_para_init
void edmamux_generator_default_para_init(edmamux_gen_init_type *edmamux_gen_init_struct)
edmamux request generator init struct config with its default value.
Definition: at32f435_437_edma.c:766
edma_init
void edma_init(edma_stream_type *edma_streamx, edma_init_type *edma_init_struct)
edma init.
Definition: at32f435_437_edma.c:115
edmamux_generator_config
void edmamux_generator_config(edmamux_generator_type *edmamux_gen_x, edmamux_gen_init_type *edmamux_gen_init_struct)
edmamux request generator init.
Definition: at32f435_437_edma.c:779
edma_stream_enable
void edma_stream_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx.
Definition: at32f435_437_edma.c:198
edmamux_enable
void edmamux_enable(confirm_state new_state)
enable or disable the edma edmamux.
Definition: at32f435_437_edma.c:673
edma_interrupt_enable
void edma_interrupt_enable(edma_stream_type *edma_streamx, uint32_t edma_int, confirm_state new_state)
enable or disable the edma streamx interrupts.
Definition: at32f435_437_edma.c:225
edma_default_para_init
void edma_default_para_init(edma_init_type *edma_init_struct)
edma init struct config with its default value.
Definition: at32f435_437_edma.c:165
EDMA_PRIORITY_HIGH
@ EDMA_PRIORITY_HIGH
Definition: at32f435_437_edma.h:191
EDMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ EDMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_edma.h:170
EDMA_MEMORY_DATA_WIDTH_HALFWORD
@ EDMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_edma.h:180
EDMA_MEMORY_SINGLE
@ EDMA_MEMORY_SINGLE
Definition: at32f435_437_edma.h:224
EDMAMUX_GEN_ID_EXINT1
@ EDMAMUX_GEN_ID_EXINT1
Definition: at32f435_437_edma.h:400
EDMA_PERIPHERAL_SINGLE
@ EDMA_PERIPHERAL_SINGLE
Definition: at32f435_437_edma.h:235
EDMA_FIFO_THRESHOLD_1QUARTER
@ EDMA_FIFO_THRESHOLD_1QUARTER
Definition: at32f435_437_edma.h:200
EDMAMUX_GEN_POLARITY_RISING
@ EDMAMUX_GEN_POLARITY_RISING
Definition: at32f435_437_edma.h:431
EDMA_DIR_PERIPHERAL_TO_MEMORY
@ EDMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_edma.h:159
EDMAMUX_DMAREQ_ID_REQ_G1
@ EDMAMUX_DMAREQ_ID_REQ_G1
Definition: at32f435_437_edma.h:255
EDMA_FDT4_FLAG
#define EDMA_FDT4_FLAG
Definition: at32f435_437_edma.h:86
EDMA_FDT_INT
#define EDMA_FDT_INT
Definition: at32f435_437_edma.h:55
EDMA_STREAM4
#define EDMA_STREAM4
Definition: at32f435_437_edma.h:965
EDMAMUX_GENERATOR1
#define EDMAMUX_GENERATOR1
Definition: at32f435_437_edma.h:998
EDMAMUX_CHANNEL4
#define EDMAMUX_CHANNEL4
Definition: at32f435_437_edma.h:992
exint_flag_get
flag_status exint_flag_get(uint32_t exint_line)
get exint flag
Definition: at32f435_437_exint.c:142
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f435_437_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
EXINT_LINE_1
#define EXINT_LINE_1
Definition: at32f435_437_exint.h:53
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f435_437_gpio.h:82
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
scfg_exint_line_config
void scfg_exint_line_config(scfg_port_source_type port_source, scfg_pins_source_type pin_source)
select the gpio pin used as exint line.
Definition: at32f435_437_scfg.c:152
SCFG_PINS_SOURCE1
@ SCFG_PINS_SOURCE1
Definition: at32f435_437_scfg.h:102
SCFG_PORT_SOURCE_GPIOA
@ SCFG_PORT_SOURCE_GPIOA
Definition: at32f435_437_scfg.h:124
EXINT1_IRQn
@ EXINT1_IRQn
Definition: at32f435_437.h:153
EDMA_Stream4_IRQn
@ EDMA_Stream4_IRQn
Definition: at32f435_437.h:160
edma_init_type
edma init type
Definition: at32f435_437_edma.h:440
edma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_edma.h:441
edma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_edma.h:444
edma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_edma.h:446
edma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_edma.h:445
edma_init_type::direction
edma_dir_type direction
Definition: at32f435_437_edma.h:443
edma_init_type::fifo_mode_enable
confirm_state fifo_mode_enable
Definition: at32f435_437_edma.h:451
edma_init_type::peripheral_data_width
edma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_edma.h:447
edma_init_type::fifo_threshold
edma_fifo_threshold_type fifo_threshold
Definition: at32f435_437_edma.h:452
edma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_edma.h:449
edma_init_type::priority
edma_priority_level_type priority
Definition: at32f435_437_edma.h:450
edma_init_type::memory0_base_addr
uint32_t memory0_base_addr
Definition: at32f435_437_edma.h:442
edma_init_type::peripheral_burst_mode
edma_peripheral_burst_type peripheral_burst_mode
Definition: at32f435_437_edma.h:454
edma_init_type::memory_data_width
edma_memory_data_size_type memory_data_width
Definition: at32f435_437_edma.h:448
edma_init_type::memory_burst_mode
edma_memory_burst_type memory_burst_mode
Definition: at32f435_437_edma.h:453
edmamux_gen_init_type
edmamux generator init type
Definition: at32f435_437_edma.h:473
edmamux_gen_init_type::gen_enable
confirm_state gen_enable
Definition: at32f435_437_edma.h:477
edmamux_gen_init_type::gen_request_number
uint32_t gen_request_number
Definition: at32f435_437_edma.h:476
edmamux_gen_init_type::gen_signal_sel
edmamux_gen_id_sel_type gen_signal_sel
Definition: at32f435_437_edma.h:474
edmamux_gen_init_type::gen_polarity
edmamux_gen_pol_type gen_polarity
Definition: at32f435_437_edma.h:475
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • edma
  • dmamux_synchronization_exint
  • inc
project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • edma
  • dmamux_synchronization_exint
  • inc
project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • edma
  • dmamux_synchronization_exint
  • inc
project/at_start_f435/examples/edma/dmamux_synchronization_exint/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • edma
  • dmamux_synchronization_exint
  • src
Functions
project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • edma
  • dmamux_synchronization_exint
  • src
project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • edma
  • dmamux_synchronization_exint
  • src
Functions
project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • edma
  • dmamux_synchronization_exint
  • src
project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while (1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while (1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while (1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while (1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • edma
  • dmamux_synchronization_exint
  • src
Macros | Functions | Variables
project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 16

Functions

void | EDMA_Stream4_IRQHandler (void)
this function handles edma stream4 handler. More...
void | EXINT1_IRQHandler (void)
exint1 interrupt handler More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
edma_init_type edma_init_struct
edmamux_sync_init_type edmamux_sync_init_struct
exint_init_type exint_init_struct
uint16_t | src_buffer [16]
uint16_t | dst_buffer [16]

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • edma
  • dmamux_synchronization_exint
  • src
project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 edma_init_type edma_init_struct;
40 edmamux_sync_init_type edmamux_sync_init_struct;
41 exint_init_type exint_init_struct;
42#define BUFFER_SIZE 16
43uint16_t src_buffer[BUFFER_SIZE] = {0x0001, 0x0002, 0x0003, 0x0004, 0x0005, 0x0006, 0x0007, 0x0008,
44 0x0009, 0x000a, 0x000b, 0x000c, 0x000d, 0x000e, 0x000f, 0x0010};
45
46uint16_t dst_buffer[BUFFER_SIZE];
47
53void EDMA_Stream4_IRQHandler(void)
54{
55 if(edma_flag_get(EDMA_FDT4_FLAG) != RESET)
56 {
57 /* turn led2/led3/led4 on */
58 at32_led_on(LED2);
59 at32_led_on(LED3);
60 at32_led_on(LED4);
61 edma_flag_clear(EDMA_FDT4_FLAG);
62 }
63}
64
70void EXINT1_IRQHandler(void)
71{
72 if(exint_flag_get(EXINT_LINE_1) != RESET)
73 {
74 at32_led_toggle(LED2);
75 exint_flag_clear(EXINT_LINE_1);
76 }
77}
78
84int main(void)
85{
86 system_clock_config();
87
88 at32_board_init();
89
90 /* enable edma/gpioa/tmr1 clock */
91 crm_periph_clock_enable(CRM_EDMA_PERIPH_CLOCK, TRUE);
92 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
93 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
94
95 /* config pa1 for input mode */
96 gpio_init_struct.gpio_pins = GPIO_PINS_1;
97 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
98 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
99 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
100 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
101 gpio_init(GPIOA, &gpio_init_struct);
102
103 scfg_exint_line_config(SCFG_PORT_SOURCE_GPIOA, SCFG_PINS_SOURCE1);
104
105 exint_default_para_init(&exint_init_struct);
106 exint_init_struct.line_enable = TRUE;
107 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
108 exint_init_struct.line_select = EXINT_LINE_1;
109 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
110 exint_init(&exint_init_struct);
111
112 /* exint line1 interrupt nvic init */
113 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
114 nvic_irq_enable(EXINT1_IRQn, 1, 0);
115
116 /* edma stream4 configuration */
117 edma_default_para_init(&edma_init_struct);
118 edma_init_struct.direction = EDMA_DIR_PERIPHERAL_TO_MEMORY;
119 edma_init_struct.buffer_size = (uint32_t)16;
120 edma_init_struct.peripheral_data_width = EDMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
121 edma_init_struct.peripheral_base_addr = (uint32_t)src_buffer;
122 edma_init_struct.peripheral_inc_enable = TRUE;
123 edma_init_struct.memory_data_width = EDMA_MEMORY_DATA_WIDTH_HALFWORD;
124 edma_init_struct.memory0_base_addr = (uint32_t)dst_buffer;
125 edma_init_struct.memory_inc_enable = TRUE;
126 edma_init_struct.peripheral_burst_mode = EDMA_PERIPHERAL_SINGLE;
127 edma_init_struct.memory_burst_mode = EDMA_MEMORY_SINGLE;
128 edma_init_struct.fifo_mode_enable = FALSE;
129 edma_init_struct.fifo_threshold = EDMA_FIFO_THRESHOLD_1QUARTER;
130 edma_init_struct.priority = EDMA_PRIORITY_HIGH;
131 edma_init_struct.loop_mode_enable = FALSE;
132 edma_init(EDMA_STREAM4, &edma_init_struct);
133
134 /* edmamux synchronization configuration */
135 edmamux_sync_default_para_init(&edmamux_sync_init_struct);
136 edmamux_sync_init_struct.sync_enable = TRUE;
137 edmamux_sync_init_struct.sync_event_enable = TRUE;
138 edmamux_sync_init_struct.sync_polarity = EDMAMUX_SYNC_POLARITY_RISING;
139 edmamux_sync_init_struct.sync_request_number = 4;
140 edmamux_sync_init_struct.sync_signal_sel = EDMAMUX_SYNC_ID_EXINT1;
141 edmamux_sync_config(EDMAMUX_CHANNEL4, &edmamux_sync_init_struct);
142
143 /* enable transfer full data intterrupt */
144 edma_interrupt_enable(EDMA_STREAM4, EDMA_FDT_INT, TRUE);
145
146 /* edma stream4 interrupt nvic init */
147 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
148 nvic_irq_enable(EDMA_Stream4_IRQn, 1, 0);
149
150 /* dmamux function enable */
151 edmamux_enable(TRUE);
152 edmamux_init(EDMAMUX_CHANNEL4, EDMAMUX_DMAREQ_ID_TMR1_OVERFLOW);
153
154 /* enable edma stream4 */
155 edma_stream_enable(EDMA_STREAM4, TRUE);
156
157 /* tmr1 configuration */
158 tmr_base_init(TMR1, 5000, 0);
159 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
160
161 /* enable tmr1 overflow edam request */
162 tmr_dma_request_enable(TMR1, TMR_OVERFLOW_DMA_REQUEST, TRUE);
163
164 /* enable tmr1 */
165 tmr_counter_enable(TMR1, TRUE);
166
167 while(1)
168 {
169 }
170}
171
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c:38
edma_init_struct
edma_init_type edma_init_struct
Definition: project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c:39
EXINT1_IRQHandler
void EXINT1_IRQHandler(void)
exint1 interrupt handler
Definition: project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c:70
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c:42
dst_buffer
uint16_t dst_buffer[16]
Definition: project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c:46
main
int main(void)
main function.
Definition: project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c:84
src_buffer
uint16_t src_buffer[16]
Definition: project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c:43
edmamux_sync_init_struct
edmamux_sync_init_type edmamux_sync_init_struct
Definition: project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c:40
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c:41
EDMA_Stream4_IRQHandler
void EDMA_Stream4_IRQHandler(void)
this function handles edma stream4 handler.
Definition: project/at_start_f435/examples/edma/dmamux_synchronization_exint/src/main.c:53
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_EDMA_PERIPH_CLOCK
@ CRM_EDMA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:114
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:154
edma_flag_get
flag_status edma_flag_get(uint32_t edma_flag)
get the edma flag.
Definition: at32f435_437_edma.c:512
edma_flag_clear
void edma_flag_clear(uint32_t edma_flag)
clear the edma flag.
Definition: at32f435_437_edma.c:549
edmamux_init
void edmamux_init(edmamux_channel_type *edmamux_channelx, edmamux_requst_id_sel_type edmamux_req_id)
edmamux init.
Definition: at32f435_437_edma.c:718
edma_init
void edma_init(edma_stream_type *edma_streamx, edma_init_type *edma_init_struct)
edma init.
Definition: at32f435_437_edma.c:115
edmamux_sync_default_para_init
void edmamux_sync_default_para_init(edmamux_sync_init_type *edmamux_sync_init_struct)
edmamux sync init struct config with its default value.
Definition: at32f435_437_edma.c:728
edma_stream_enable
void edma_stream_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx.
Definition: at32f435_437_edma.c:198
edmamux_sync_config
void edmamux_sync_config(edmamux_channel_type *edmamux_channelx, edmamux_sync_init_type *edmamux_sync_init_struct)
edmamux synchronization config.
Definition: at32f435_437_edma.c:752
edmamux_enable
void edmamux_enable(confirm_state new_state)
enable or disable the edma edmamux.
Definition: at32f435_437_edma.c:673
edma_interrupt_enable
void edma_interrupt_enable(edma_stream_type *edma_streamx, uint32_t edma_int, confirm_state new_state)
enable or disable the edma streamx interrupts.
Definition: at32f435_437_edma.c:225
edma_default_para_init
void edma_default_para_init(edma_init_type *edma_init_struct)
edma init struct config with its default value.
Definition: at32f435_437_edma.c:165
EDMA_PRIORITY_HIGH
@ EDMA_PRIORITY_HIGH
Definition: at32f435_437_edma.h:191
EDMAMUX_SYNC_ID_EXINT1
@ EDMAMUX_SYNC_ID_EXINT1
Definition: at32f435_437_edma.h:358
EDMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ EDMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_edma.h:170
EDMA_MEMORY_DATA_WIDTH_HALFWORD
@ EDMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_edma.h:180
EDMA_MEMORY_SINGLE
@ EDMA_MEMORY_SINGLE
Definition: at32f435_437_edma.h:224
EDMA_PERIPHERAL_SINGLE
@ EDMA_PERIPHERAL_SINGLE
Definition: at32f435_437_edma.h:235
EDMA_FIFO_THRESHOLD_1QUARTER
@ EDMA_FIFO_THRESHOLD_1QUARTER
Definition: at32f435_437_edma.h:200
EDMA_DIR_PERIPHERAL_TO_MEMORY
@ EDMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_edma.h:159
EDMAMUX_SYNC_POLARITY_RISING
@ EDMAMUX_SYNC_POLARITY_RISING
Definition: at32f435_437_edma.h:389
EDMAMUX_DMAREQ_ID_TMR1_OVERFLOW
@ EDMAMUX_DMAREQ_ID_TMR1_OVERFLOW
Definition: at32f435_437_edma.h:308
EDMA_FDT4_FLAG
#define EDMA_FDT4_FLAG
Definition: at32f435_437_edma.h:86
EDMA_FDT_INT
#define EDMA_FDT_INT
Definition: at32f435_437_edma.h:55
EDMA_STREAM4
#define EDMA_STREAM4
Definition: at32f435_437_edma.h:965
EDMAMUX_CHANNEL4
#define EDMAMUX_CHANNEL4
Definition: at32f435_437_edma.h:992
exint_flag_get
flag_status exint_flag_get(uint32_t exint_line)
get exint flag
Definition: at32f435_437_exint.c:142
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f435_437_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
EXINT_LINE_1
#define EXINT_LINE_1
Definition: at32f435_437_exint.h:53
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f435_437_gpio.h:82
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
scfg_exint_line_config
void scfg_exint_line_config(scfg_port_source_type port_source, scfg_pins_source_type pin_source)
select the gpio pin used as exint line.
Definition: at32f435_437_scfg.c:152
SCFG_PINS_SOURCE1
@ SCFG_PINS_SOURCE1
Definition: at32f435_437_scfg.h:102
SCFG_PORT_SOURCE_GPIOA
@ SCFG_PORT_SOURCE_GPIOA
Definition: at32f435_437_scfg.h:124
tmr_dma_request_enable
void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request
Definition: at32f435_437_tmr.c:1358
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
TMR_OVERFLOW_DMA_REQUEST
@ TMR_OVERFLOW_DMA_REQUEST
Definition: at32f435_437_tmr.h:271
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
EXINT1_IRQn
@ EXINT1_IRQn
Definition: at32f435_437.h:153
EDMA_Stream4_IRQn
@ EDMA_Stream4_IRQn
Definition: at32f435_437.h:160
edma_init_type
edma init type
Definition: at32f435_437_edma.h:440
edma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_edma.h:441
edma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_edma.h:444
edma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_edma.h:446
edma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_edma.h:445
edma_init_type::direction
edma_dir_type direction
Definition: at32f435_437_edma.h:443
edma_init_type::fifo_mode_enable
confirm_state fifo_mode_enable
Definition: at32f435_437_edma.h:451
edma_init_type::peripheral_data_width
edma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_edma.h:447
edma_init_type::fifo_threshold
edma_fifo_threshold_type fifo_threshold
Definition: at32f435_437_edma.h:452
edma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_edma.h:449
edma_init_type::priority
edma_priority_level_type priority
Definition: at32f435_437_edma.h:450
edma_init_type::memory0_base_addr
uint32_t memory0_base_addr
Definition: at32f435_437_edma.h:442
edma_init_type::peripheral_burst_mode
edma_peripheral_burst_type peripheral_burst_mode
Definition: at32f435_437_edma.h:454
edma_init_type::memory_data_width
edma_memory_data_size_type memory_data_width
Definition: at32f435_437_edma.h:448
edma_init_type::memory_burst_mode
edma_memory_burst_type memory_burst_mode
Definition: at32f435_437_edma.h:453
edmamux_sync_init_type
edmamux sync init type
Definition: at32f435_437_edma.h:461
edmamux_sync_init_type::sync_signal_sel
edmamux_sync_id_sel_type sync_signal_sel
Definition: at32f435_437_edma.h:462
edmamux_sync_init_type::sync_polarity
edmamux_sync_pol_type sync_polarity
Definition: at32f435_437_edma.h:463
edmamux_sync_init_type::sync_event_enable
confirm_state sync_event_enable
Definition: at32f435_437_edma.h:465
edmamux_sync_init_type::sync_enable
confirm_state sync_enable
Definition: at32f435_437_edma.h:466
edmamux_sync_init_type::sync_request_number
uint32_t sync_request_number
Definition: at32f435_437_edma.h:464
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • edma
  • flash_to_sram
  • inc
project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • edma
  • flash_to_sram
  • inc
project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • edma
  • flash_to_sram
  • inc
project/at_start_f435/examples/edma/flash_to_sram/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • edma
  • flash_to_sram
  • src
Functions
project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • edma
  • flash_to_sram
  • src
project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • edma
  • flash_to_sram
  • src
Functions
project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • edma
  • flash_to_sram
  • src
project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while (1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while (1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while (1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while (1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/edma/flash_to_sram/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • edma
  • flash_to_sram
  • src
Macros | Functions | Variables
project/at_start_f435/examples/edma/flash_to_sram/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 32

Functions

error_status | buffer_compare (const uint32_t *pbuffer, uint32_t *pbuffer1, uint16_t buffer_length)
compares two buffers. More...
void | EDMA_Stream1_IRQHandler (void)
this function handles edma stream1 handler. More...
int | main (void)
main function. More...

Variables

const uint32_t | src_const_buffer [32]
uint32_t | dst_buffer [32]
edma_init_type edma_init_struct
__IO uint32_t | data_counter_end = 0x01
error_status transfer_status = ERROR

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/flash_to_sram/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • edma
  • flash_to_sram
  • src
project/at_start_f435/examples/edma/flash_to_sram/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define BUFFER_SIZE 32
39
40const uint32_t src_const_buffer[BUFFER_SIZE]= {0x01020304, 0x05060708, 0x090A0B0C, 0x0D0E0F10,
41 0x11121314, 0x15161718, 0x191A1B1C, 0x1D1E1F20,
42 0x21222324, 0x25262728, 0x292A2B2C, 0x2D2E2F30,
43 0x31323334, 0x35363738, 0x393A3B3C, 0x3D3E3F40,
44 0x41424344, 0x45464748, 0x494A4B4C, 0x4D4E4F50,
45 0x51525354, 0x55565758, 0x595A5B5C, 0x5D5E5F60,
46 0x61626364, 0x65666768, 0x696A6B6C, 0x6D6E6F70,
47 0x71727374, 0x75767778, 0x797A7B7C, 0x7D7E7F80};
48uint32_t dst_buffer[BUFFER_SIZE];
49 edma_init_type edma_init_struct;
50__IO uint32_t data_counter_end = 0x01; /* this variable should not be initialized to 0 */
51 error_status transfer_status = ERROR;
52
53 error_status buffer_compare(const uint32_t* pbuffer, uint32_t* pbuffer1, uint16_t buffer_length);
54
60void EDMA_Stream1_IRQHandler(void)
61{
62 if(edma_flag_get(EDMA_FDT1_FLAG) != RESET)
63 {
64 data_counter_end = 0;
65 edma_flag_clear(EDMA_FDT1_FLAG);
66 }
67}
68
76 error_status buffer_compare(const uint32_t* pbuffer, uint32_t* pbuffer1, uint16_t buffer_length)
77{
78 while(buffer_length--)
79 {
80 if(*pbuffer != *pbuffer1)
81 {
82 return ERROR;
83 }
84
85 pbuffer++;
86 pbuffer1++;
87 }
88
89 return SUCCESS;
90}
91
97int main(void)
98{
99 system_clock_config();
100
101 at32_board_init();
102
103 /* enable dma1 clock */
104 crm_periph_clock_enable(CRM_EDMA_PERIPH_CLOCK, TRUE);
105
106 /* edma stream1 configuration */
107 edma_default_para_init(&edma_init_struct);
108 edma_init_struct.direction = EDMA_DIR_MEMORY_TO_MEMORY;
109 edma_init_struct.buffer_size = (uint32_t)BUFFER_SIZE;
110 edma_init_struct.peripheral_data_width = EDMA_PERIPHERAL_DATA_WIDTH_WORD;
111 edma_init_struct.peripheral_base_addr = (uint32_t)src_const_buffer;
112 edma_init_struct.peripheral_inc_enable = TRUE;
113 edma_init_struct.memory_data_width = EDMA_MEMORY_DATA_WIDTH_WORD;
114 edma_init_struct.memory0_base_addr = (uint32_t)dst_buffer;
115 edma_init_struct.memory_inc_enable = TRUE;
116 edma_init_struct.peripheral_burst_mode = EDMA_PERIPHERAL_SINGLE;
117 edma_init_struct.memory_burst_mode = EDMA_MEMORY_SINGLE;
118 edma_init_struct.fifo_mode_enable = FALSE;
119 edma_init_struct.fifo_threshold = EDMA_FIFO_THRESHOLD_1QUARTER;
120 edma_init_struct.priority = EDMA_PRIORITY_HIGH;
121 edma_init_struct.loop_mode_enable = FALSE;
122 edma_init(EDMA_STREAM1, &edma_init_struct);
123
124 /* enable transfer full data intterrupt */
125 edma_interrupt_enable(EDMA_STREAM1, EDMA_FDT_INT, TRUE);
126
127 /* edma stream1 interrupt nvic init */
128 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
129 nvic_irq_enable(EDMA_Stream1_IRQn, 1, 0);
130
131 edma_stream_enable(EDMA_STREAM1, TRUE);
132
133 /* wait the end of transmission */
134 while(data_counter_end != 0)
135 {
136 }
137
138 /* check if the transmitted and received data are equal */
139 transfer_status = buffer_compare(src_const_buffer, dst_buffer, BUFFER_SIZE);
140
141 /* transfer_status = success, if the transmitted and received data are the same
142 transfer_status = error, if the transmitted and received data are different */
143 if(transfer_status == SUCCESS)
144 {
145 /* turn led2/led3/led4 on */
146 at32_led_on(LED2);
147 at32_led_on(LED3);
148 at32_led_on(LED4);
149 }
150
151 while(1)
152 {
153 }
154}
155
at32f435_437_board.h
edma_init_struct
edma_init_type edma_init_struct
Definition: project/at_start_f435/examples/edma/flash_to_sram/src/main.c:49
src_const_buffer
const uint32_t src_const_buffer[32]
Definition: project/at_start_f435/examples/edma/flash_to_sram/src/main.c:40
data_counter_end
__IO uint32_t data_counter_end
Definition: project/at_start_f435/examples/edma/flash_to_sram/src/main.c:50
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f435/examples/edma/flash_to_sram/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f435/examples/edma/flash_to_sram/src/main.c:97
EDMA_Stream1_IRQHandler
void EDMA_Stream1_IRQHandler(void)
this function handles edma stream1 handler.
Definition: project/at_start_f435/examples/edma/flash_to_sram/src/main.c:60
dst_buffer
uint32_t dst_buffer[32]
Definition: project/at_start_f435/examples/edma/flash_to_sram/src/main.c:48
buffer_compare
error_status buffer_compare(const uint32_t *pbuffer, uint32_t *pbuffer1, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f435/examples/edma/flash_to_sram/src/main.c:76
transfer_status
error_status transfer_status
Definition: project/at_start_f435/examples/edma/flash_to_sram/src/main.c:51
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_EDMA_PERIPH_CLOCK
@ CRM_EDMA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:114
edma_flag_get
flag_status edma_flag_get(uint32_t edma_flag)
get the edma flag.
Definition: at32f435_437_edma.c:512
edma_flag_clear
void edma_flag_clear(uint32_t edma_flag)
clear the edma flag.
Definition: at32f435_437_edma.c:549
edma_init
void edma_init(edma_stream_type *edma_streamx, edma_init_type *edma_init_struct)
edma init.
Definition: at32f435_437_edma.c:115
edma_stream_enable
void edma_stream_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx.
Definition: at32f435_437_edma.c:198
edma_interrupt_enable
void edma_interrupt_enable(edma_stream_type *edma_streamx, uint32_t edma_int, confirm_state new_state)
enable or disable the edma streamx interrupts.
Definition: at32f435_437_edma.c:225
edma_default_para_init
void edma_default_para_init(edma_init_type *edma_init_struct)
edma init struct config with its default value.
Definition: at32f435_437_edma.c:165
EDMA_PRIORITY_HIGH
@ EDMA_PRIORITY_HIGH
Definition: at32f435_437_edma.h:191
EDMA_PERIPHERAL_DATA_WIDTH_WORD
@ EDMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_edma.h:171
EDMA_MEMORY_DATA_WIDTH_WORD
@ EDMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f435_437_edma.h:181
EDMA_MEMORY_SINGLE
@ EDMA_MEMORY_SINGLE
Definition: at32f435_437_edma.h:224
EDMA_PERIPHERAL_SINGLE
@ EDMA_PERIPHERAL_SINGLE
Definition: at32f435_437_edma.h:235
EDMA_FIFO_THRESHOLD_1QUARTER
@ EDMA_FIFO_THRESHOLD_1QUARTER
Definition: at32f435_437_edma.h:200
EDMA_DIR_MEMORY_TO_MEMORY
@ EDMA_DIR_MEMORY_TO_MEMORY
Definition: at32f435_437_edma.h:161
EDMA_FDT1_FLAG
#define EDMA_FDT1_FLAG
Definition: at32f435_437_edma.h:71
EDMA_FDT_INT
#define EDMA_FDT_INT
Definition: at32f435_437_edma.h:55
EDMA_STREAM1
#define EDMA_STREAM1
Definition: at32f435_437_edma.h:962
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
EDMA_Stream1_IRQn
@ EDMA_Stream1_IRQn
Definition: at32f435_437.h:157
edma_init_type
edma init type
Definition: at32f435_437_edma.h:440
edma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_edma.h:441
edma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_edma.h:444
edma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_edma.h:446
edma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_edma.h:445
edma_init_type::direction
edma_dir_type direction
Definition: at32f435_437_edma.h:443
edma_init_type::fifo_mode_enable
confirm_state fifo_mode_enable
Definition: at32f435_437_edma.h:451
edma_init_type::peripheral_data_width
edma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_edma.h:447
edma_init_type::fifo_threshold
edma_fifo_threshold_type fifo_threshold
Definition: at32f435_437_edma.h:452
edma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_edma.h:449
edma_init_type::priority
edma_priority_level_type priority
Definition: at32f435_437_edma.h:450
edma_init_type::memory0_base_addr
uint32_t memory0_base_addr
Definition: at32f435_437_edma.h:442
edma_init_type::peripheral_burst_mode
edma_peripheral_burst_type peripheral_burst_mode
Definition: at32f435_437_edma.h:454
edma_init_type::memory_data_width
edma_memory_data_size_type memory_data_width
Definition: at32f435_437_edma.h:448
edma_init_type::memory_burst_mode
edma_memory_burst_type memory_burst_mode
Definition: at32f435_437_edma.h:453
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • edma
  • i2s_halfduplex_edma_doublebuffer
  • inc
project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • edma
  • i2s_halfduplex_edma_doublebuffer
  • inc
project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • edma
  • i2s_halfduplex_edma_doublebuffer
  • inc
project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • edma
  • i2s_halfduplex_edma_doublebuffer
  • src
Functions
project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • edma
  • i2s_halfduplex_edma_doublebuffer
  • src
project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • edma
  • i2s_halfduplex_edma_doublebuffer
  • src
Functions
project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • edma
  • i2s_halfduplex_edma_doublebuffer
  • src
project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while (1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while (1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while (1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while (1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • edma
  • i2s_halfduplex_edma_doublebuffer
  • src
Functions | Variables
project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | i2s_config (void)
i2s configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function. More...
void | EDMA_Stream1_IRQHandler (void)
this function handles edma stream1 handler. More...
int | main (void)
main function. More...

Variables

uint16_t | i2s3_buffer1_tx [32]
uint16_t | i2s3_buffer2_tx [32]
uint16_t | i2s2_buffer1_rx [32]
uint16_t | i2s2_buffer2_rx [32]
volatile int | transfer_count = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • edma
  • i2s_halfduplex_edma_doublebuffer
  • src
project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38uint16_t i2s3_buffer1_tx[32] = {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C,
39 0x0D0E, 0x0F10, 0x1112, 0x1314, 0x1516, 0x1718,
40 0x191A, 0x1B1C, 0x1D1E, 0x1F20, 0x2122, 0x2324,
41 0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
42 0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C,
43 0x3D3E, 0x3F40};
44uint16_t i2s3_buffer2_tx[32] = {0x4142, 0x4344, 0x4546, 0x4748, 0x494A, 0x4B4C,
45 0x4D4E, 0x4F50, 0x5152, 0x5354, 0x5556, 0x5758,
46 0x595A, 0x5B5C, 0x5D5E, 0x5F60, 0x6162, 0x6364,
47 0x6566, 0x6768, 0x696A, 0x6B6C, 0x6D6E, 0x6F70,
48 0x7172, 0x7374, 0x7576, 0x7778, 0x797A, 0x7B7C,
49 0x7D7E, 0x7F80};
50uint16_t i2s2_buffer1_rx[32];
51uint16_t i2s2_buffer2_rx[32];
52volatile int transfer_count = 0;
53
54static void gpio_config(void);
55static void i2s_config(void);
56 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length);
57
63 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length)
64{
65 while(buffer_length--)
66 {
67 if(*pbuffer1 != *pbuffer2)
68 {
69 return ERROR;
70 }
71
72 pbuffer1++;
73 pbuffer2++;
74 }
75 return SUCCESS;
76}
77
83void EDMA_Stream1_IRQHandler(void)
84{
85 if(edma_flag_get(EDMA_FDT1_FLAG) != RESET)
86 {
87 if(transfer_count == 0)
88 {
89 if(buffer_compare(i2s3_buffer1_tx, i2s2_buffer1_rx, 32) == SUCCESS)
90 {
91 transfer_count = 1;
92 }
93 else
94 {
95 /* some error */
96 at32_led_off(LED2);
97 at32_led_off(LED3);
98 at32_led_off(LED4);
99 }
100 }
101 if(transfer_count == 1)
102 {
103 if(buffer_compare(i2s3_buffer2_tx, i2s2_buffer2_rx, 32) == SUCCESS)
104 {
105 /* edma double buffer mode transfer data pass */
106 at32_led_on(LED2);
107 at32_led_on(LED3);
108 at32_led_on(LED4);
109 /* end of transfer,close edma stream */
110 edma_stream_enable(EDMA_STREAM1, FALSE);
111 edma_stream_enable(EDMA_STREAM2, FALSE);
112 }
113 else
114 {
115 /* some error */
116 at32_led_off(LED2);
117 at32_led_off(LED3);
118 at32_led_off(LED4);
119 }
120 }
121 edma_flag_clear(EDMA_FDT1_FLAG);
122 }
123}
124
130static void i2s_config(void)
131{
132 edma_init_type edma_init_struct;
133 i2s_init_type i2s_init_struct;
134
135 /* enable dma1 clock */
136 crm_periph_clock_enable(CRM_EDMA_PERIPH_CLOCK, TRUE);
137
138 /* i2s2_rx:edma stream1 configuration */
139 edma_default_para_init(&edma_init_struct);
140 edma_init_struct.direction = EDMA_DIR_PERIPHERAL_TO_MEMORY;
141 edma_init_struct.buffer_size = (uint32_t)32;
142 edma_init_struct.peripheral_data_width = EDMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
143 edma_init_struct.peripheral_base_addr = (uint32_t)&(SPI2->dt);
144 edma_init_struct.peripheral_inc_enable = FALSE;
145 edma_init_struct.memory_data_width = EDMA_MEMORY_DATA_WIDTH_HALFWORD;
146 edma_init_struct.memory0_base_addr = (uint32_t)i2s2_buffer1_rx;
147 edma_init_struct.memory_inc_enable = TRUE;
148 edma_init_struct.peripheral_burst_mode = EDMA_PERIPHERAL_SINGLE;
149 edma_init_struct.memory_burst_mode = EDMA_MEMORY_SINGLE;
150 edma_init_struct.fifo_mode_enable = FALSE;
151 edma_init_struct.fifo_threshold = EDMA_FIFO_THRESHOLD_1QUARTER;
152 edma_init_struct.priority = EDMA_PRIORITY_HIGH;
153 edma_init_struct.loop_mode_enable = TRUE;
154 edma_init(EDMA_STREAM1, &edma_init_struct);
155
156 /* edma stream1 double buffer mode init */
157 edma_double_buffer_mode_init(EDMA_STREAM1, (uint32_t)i2s2_buffer2_rx, EDMA_MEMORY_0);
158 edma_double_buffer_mode_enable(EDMA_STREAM1, TRUE);
159
160 /* i2s3_tx:edma stream2 configuration */
161 edma_init_struct.direction = EDMA_DIR_MEMORY_TO_PERIPHERAL;
162 edma_init_struct.peripheral_base_addr = (uint32_t)&(SPI3->dt);
163 edma_init_struct.memory0_base_addr = (uint32_t)i2s3_buffer1_tx;
164 edma_init(EDMA_STREAM2, &edma_init_struct);
165
166 /* edma stream2 double buffer mode init */
167 edma_double_buffer_mode_init(EDMA_STREAM2, (uint32_t)i2s3_buffer2_tx, EDMA_MEMORY_0);
168 edma_double_buffer_mode_enable(EDMA_STREAM2, TRUE);
169
170 /* enable transfer full data intterrupt */
171 edma_interrupt_enable(EDMA_STREAM1, EDMA_FDT_INT, TRUE);
172
173 /* edma stream1 interrupt nvic init */
174 nvic_irq_enable(EDMA_Stream1_IRQn, 1, 0);
175
176 /* edmamux init */
177 edmamux_enable(TRUE);
178 edmamux_init(EDMAMUX_CHANNEL1, EDMAMUX_DMAREQ_ID_SPI2_RX);
179 edmamux_init(EDMAMUX_CHANNEL2, EDMAMUX_DMAREQ_ID_SPI3_TX);
180
181 crm_periph_clock_enable(CRM_SPI3_PERIPH_CLOCK, TRUE);
182 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
183 i2s_default_para_init(&i2s_init_struct);
184 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
185 i2s_init_struct.data_channel_format = I2S_DATA_16BIT_CHANNEL_32BIT;
186 i2s_init_struct.mclk_output_enable = TRUE;
187 i2s_init_struct.audio_sampling_freq = I2S_AUDIO_FREQUENCY_48K;
188 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
189 i2s_init_struct.operation_mode = I2S_MODE_MASTER_TX;
190 i2s_init(SPI3, &i2s_init_struct);
191
192 i2s_init_struct.operation_mode =I2S_MODE_SLAVE_RX;
193 i2s_init(SPI2, &i2s_init_struct);
194
195 edma_stream_enable(EDMA_STREAM1, TRUE);
196 edma_stream_enable(EDMA_STREAM2, TRUE);
197 spi_i2s_dma_receiver_enable(SPI2, TRUE);
198
199 spi_i2s_dma_transmitter_enable(SPI3, TRUE);
200
201 i2s_enable(SPI2, TRUE);
202
203 i2s_enable(SPI3, TRUE);
204}
205
211static void gpio_config(void)
212{
213 gpio_init_type gpio_initstructure;
214 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
215 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
216 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
217
218 /* master ws pin */
219 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
220 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
221 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
222 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
223 gpio_initstructure.gpio_pins = GPIO_PINS_4;
224 gpio_init(GPIOA, &gpio_initstructure);
225 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE4, GPIO_MUX_6);
226
227 /* master ck pin */
228 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
229 gpio_initstructure.gpio_pins = GPIO_PINS_10;
230 gpio_init(GPIOC, &gpio_initstructure);
231 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE10, GPIO_MUX_6);
232
233 /* master sd pin */
234 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
235 gpio_initstructure.gpio_pins = GPIO_PINS_12;
236 gpio_init(GPIOC, &gpio_initstructure);
237 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE12, GPIO_MUX_6);
238
239 /* master mck pin */
240 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
241 gpio_initstructure.gpio_pins = GPIO_PINS_7;
242 gpio_init(GPIOC, &gpio_initstructure);
243 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE7, GPIO_MUX_6);
244
245 /* slave ws pin */
246 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
247 gpio_initstructure.gpio_pins = GPIO_PINS_0;
248 gpio_init(GPIOD, &gpio_initstructure);
249 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE0, GPIO_MUX_7);
250
251 /* slave ck pin */
252 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
253 gpio_initstructure.gpio_pins = GPIO_PINS_1;
254 gpio_init(GPIOD, &gpio_initstructure);
255 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_6);
256
257 /* slave sd pin */
258 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
259 gpio_initstructure.gpio_pins = GPIO_PINS_4;
260 gpio_init(GPIOD, &gpio_initstructure);
261 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_6);
262}
263
269int main(void)
270{
271 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
272 system_clock_config();
273 at32_board_init();
274
275 gpio_config();
276 i2s_config();
277
278
279 while(1)
280 {
281 }
282}
283
at32f435_437_board.h
edma_init_struct
edma_init_type edma_init_struct
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/dvp/dvp.c:40
buffer_compare
error_status buffer_compare(uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function.
Definition: project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c:63
i2s3_buffer1_tx
uint16_t i2s3_buffer1_tx[32]
Definition: project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c:38
i2s_config
static void i2s_config(void)
i2s configuration.
Definition: project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c:130
main
int main(void)
main function.
Definition: project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c:269
EDMA_Stream1_IRQHandler
void EDMA_Stream1_IRQHandler(void)
this function handles edma stream1 handler.
Definition: project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c:83
i2s3_buffer2_tx
uint16_t i2s3_buffer2_tx[32]
Definition: project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c:44
i2s2_buffer2_rx
uint16_t i2s2_buffer2_rx[32]
Definition: project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c:51
transfer_count
volatile int transfer_count
Definition: project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c:52
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c:211
i2s2_buffer1_rx
uint16_t i2s2_buffer1_rx[32]
Definition: project/at_start_f435/examples/edma/i2s_halfduplex_edma_doublebuffer/src/main.c:50
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_SPI3_PERIPH_CLOCK
@ CRM_SPI3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:139
CRM_EDMA_PERIPH_CLOCK
@ CRM_EDMA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:114
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:138
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
edma_flag_get
flag_status edma_flag_get(uint32_t edma_flag)
get the edma flag.
Definition: at32f435_437_edma.c:512
edma_flag_clear
void edma_flag_clear(uint32_t edma_flag)
clear the edma flag.
Definition: at32f435_437_edma.c:549
edma_double_buffer_mode_init
void edma_double_buffer_mode_init(edma_stream_type *edma_streamx, uint32_t memory1_addr, edma_memory_type current_memory)
config the the double buffer mode.
Definition: at32f435_437_edma.c:354
edmamux_init
void edmamux_init(edmamux_channel_type *edmamux_channelx, edmamux_requst_id_sel_type edmamux_req_id)
edmamux init.
Definition: at32f435_437_edma.c:718
edma_init
void edma_init(edma_stream_type *edma_streamx, edma_init_type *edma_init_struct)
edma init.
Definition: at32f435_437_edma.c:115
edma_double_buffer_mode_enable
void edma_double_buffer_mode_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the double memory mode.
Definition: at32f435_437_edma.c:383
edma_stream_enable
void edma_stream_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx.
Definition: at32f435_437_edma.c:198
edmamux_enable
void edmamux_enable(confirm_state new_state)
enable or disable the edma edmamux.
Definition: at32f435_437_edma.c:673
edma_interrupt_enable
void edma_interrupt_enable(edma_stream_type *edma_streamx, uint32_t edma_int, confirm_state new_state)
enable or disable the edma streamx interrupts.
Definition: at32f435_437_edma.c:225
edma_default_para_init
void edma_default_para_init(edma_init_type *edma_init_struct)
edma init struct config with its default value.
Definition: at32f435_437_edma.c:165
EDMA_PRIORITY_HIGH
@ EDMA_PRIORITY_HIGH
Definition: at32f435_437_edma.h:191
EDMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ EDMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_edma.h:170
EDMA_MEMORY_DATA_WIDTH_HALFWORD
@ EDMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_edma.h:180
EDMA_MEMORY_SINGLE
@ EDMA_MEMORY_SINGLE
Definition: at32f435_437_edma.h:224
EDMA_PERIPHERAL_SINGLE
@ EDMA_PERIPHERAL_SINGLE
Definition: at32f435_437_edma.h:235
EDMA_FIFO_THRESHOLD_1QUARTER
@ EDMA_FIFO_THRESHOLD_1QUARTER
Definition: at32f435_437_edma.h:200
EDMA_MEMORY_0
@ EDMA_MEMORY_0
Definition: at32f435_437_edma.h:150
EDMA_DIR_MEMORY_TO_PERIPHERAL
@ EDMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_edma.h:160
EDMA_DIR_PERIPHERAL_TO_MEMORY
@ EDMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_edma.h:159
EDMAMUX_DMAREQ_ID_SPI2_RX
@ EDMAMUX_DMAREQ_ID_SPI2_RX
Definition: at32f435_437_edma.h:268
EDMAMUX_DMAREQ_ID_SPI3_TX
@ EDMAMUX_DMAREQ_ID_SPI3_TX
Definition: at32f435_437_edma.h:271
EDMA_FDT1_FLAG
#define EDMA_FDT1_FLAG
Definition: at32f435_437_edma.h:71
EDMA_FDT_INT
#define EDMA_FDT_INT
Definition: at32f435_437_edma.h:55
EDMAMUX_CHANNEL2
#define EDMAMUX_CHANNEL2
Definition: at32f435_437_edma.h:990
EDMA_STREAM1
#define EDMA_STREAM1
Definition: at32f435_437_edma.h:962
EDMA_STREAM2
#define EDMA_STREAM2
Definition: at32f435_437_edma.h:963
EDMAMUX_CHANNEL1
#define EDMAMUX_CHANNEL1
Definition: at32f435_437_edma.h:989
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_6
@ GPIO_MUX_6
Definition: at32f435_437_gpio.h:162
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f435_437_spi.c:350
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f435_437_spi.c:533
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f435_437_spi.c:479
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f435_437_spi.c:332
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f435_437_spi.c:519
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f435_437_spi.h:251
I2S_DATA_16BIT_CHANNEL_32BIT
@ I2S_DATA_16BIT_CHANNEL_32BIT
Definition: at32f435_437_spi.h:230
I2S_AUDIO_FREQUENCY_48K
@ I2S_AUDIO_FREQUENCY_48K
Definition: at32f435_437_spi.h:219
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f435_437_spi.h:200
I2S_MODE_MASTER_TX
@ I2S_MODE_MASTER_TX
Definition: at32f435_437_spi.h:242
I2S_MODE_SLAVE_RX
@ I2S_MODE_SLAVE_RX
Definition: at32f435_437_spi.h:241
SPI3
#define SPI3
Definition: at32f435_437_spi.h:455
SPI2
#define SPI2
Definition: at32f435_437_spi.h:454
EDMA_Stream1_IRQn
@ EDMA_Stream1_IRQn
Definition: at32f435_437.h:157
edma_init_type
edma init type
Definition: at32f435_437_edma.h:440
edma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_edma.h:441
edma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_edma.h:444
edma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_edma.h:446
edma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_edma.h:445
edma_init_type::direction
edma_dir_type direction
Definition: at32f435_437_edma.h:443
edma_init_type::fifo_mode_enable
confirm_state fifo_mode_enable
Definition: at32f435_437_edma.h:451
edma_init_type::peripheral_data_width
edma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_edma.h:447
edma_init_type::fifo_threshold
edma_fifo_threshold_type fifo_threshold
Definition: at32f435_437_edma.h:452
edma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_edma.h:449
edma_init_type::priority
edma_priority_level_type priority
Definition: at32f435_437_edma.h:450
edma_init_type::memory0_base_addr
uint32_t memory0_base_addr
Definition: at32f435_437_edma.h:442
edma_init_type::peripheral_burst_mode
edma_peripheral_burst_type peripheral_burst_mode
Definition: at32f435_437_edma.h:454
edma_init_type::memory_data_width
edma_memory_data_size_type memory_data_width
Definition: at32f435_437_edma.h:448
edma_init_type::memory_burst_mode
edma_memory_burst_type memory_burst_mode
Definition: at32f435_437_edma.h:453
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
i2s_init_type
i2s init type
Definition: at32f435_437_spi.h:274
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f435_437_spi.h:277
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f435_437_spi.h:278
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f435_437_spi.h:280
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f435_437_spi.h:276
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f435_437_spi.h:275
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:279
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • edma
  • link_list_mode
  • inc
project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • edma
  • link_list_mode
  • inc
project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • edma
  • link_list_mode
  • inc
project/at_start_f435/examples/edma/link_list_mode/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • edma
  • link_list_mode
  • src
Functions
project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • edma
  • link_list_mode
  • src
project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • edma
  • link_list_mode
  • src
Functions
project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • edma
  • link_list_mode
  • src
project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while (1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while (1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while (1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while (1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/edma/link_list_mode/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • edma
  • link_list_mode
  • src
Data Structures | Macros | Functions | Variables
project/at_start_f435/examples/edma/link_list_mode/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Data Structures

struct ll_descriptors_type

Macros

#define | LIST_COUNT 3
#define | BUFFER_SIZE 35

Functions

__ALIGNED (16)
edma link list descriptor init function. More...
int | main (void)
main function. More...
void | uart_init (uint32_t bound)
initialize print usart More...
void | EDMA_Stream1_IRQHandler (void)
this function handles edma stream1 handler. More...

Variables

const int8_t tx_buffer [3][35]

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/link_list_mode/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • edma
  • link_list_mode
  • src
project/at_start_f435/examples/edma/link_list_mode/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define LIST_COUNT 3
39#define BUFFER_SIZE 35
40
41/* link list descriptors struct type */
42typedef struct
43{
44 uint32_t ctrl_dtcnt;
45 uint32_t paddr;
46 uint32_t m0addr;
47 uint32_t llp;
48} ll_descriptors_type;
49
50/* tx data buffer */
51const int8_t tx_buffer[LIST_COUNT][BUFFER_SIZE] ={
52 {'T','h','i','s',' ','i','s',' ','E','D','M','A',' '},
53 {'L','i','n','k',' ','L','i','s','t',' ','M','o','d','e',' ','t','e','s','t','!'},
54 {'\r','\n','T','h','i','s',' ','t','e','s','t',' ','c','a','s','e',' ','u','s','e',' ','U','s','a','r','t','1','_','T','X','!','\r','\n'}
55};
56
57/* link list descriptor array, start address must be aligned by 16 bytes */
58 __ALIGNED(16) ll_descriptors_type edma_ll_descriptors_tx[LIST_COUNT];
59
60/* declared private functions */
61void uart_init(uint32_t bound);
62void edma_ll_descriptors_init(void);
63
69void edma_ll_descriptors_init(void)
70{
71 uint32_t index = 0;
72
73 for(index = 0; index < LIST_COUNT; index ++)
74 {
75 edma_ll_descriptors_tx[index].ctrl_dtcnt = 0x20090000 | sizeof(tx_buffer[index]);
76 edma_ll_descriptors_tx[index].paddr = (uint32_t)(&USART1->dt);
77 edma_ll_descriptors_tx[index].m0addr = (uint32_t)(&tx_buffer[index][0]);
78 if(index == (LIST_COUNT - 1))
79 {
80 edma_ll_descriptors_tx[index].llp = 0;
81 }
82 else
83 {
84 edma_ll_descriptors_tx[index].llp = (uint32_t)(&edma_ll_descriptors_tx[index + 1]);
85 }
86 }
87}
88
94int main(void)
95{
96 system_clock_config();
97
98 at32_board_init();
99
100 /* usart1 configuration */
101 uart_init(115200);
102
103 /* enable dma1 clock */
104 crm_periph_clock_enable(CRM_EDMA_PERIPH_CLOCK, TRUE);
105
106 /* edma link list descriptor init */
107 edma_ll_descriptors_init();
108
109 /* edma stream1 link list mode configuration */
110 edma_link_list_enable(EDMA_STREAM1_LL, TRUE);
111 edma_link_list_init(EDMA_STREAM1_LL, (uint32_t)edma_ll_descriptors_tx);
112
113 /* edmamux configuration */
114 edmamux_enable(TRUE);
115 edmamux_init(EDMAMUX_CHANNEL1, EDMAMUX_DMAREQ_ID_USART1_TX);
116
117 /* enable transfer full data intterrupt */
118 edma_interrupt_enable(EDMA_STREAM1, EDMA_FDT_INT, TRUE);
119
120 /* edma stream1 interrupt nvic init */
121 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
122 nvic_irq_enable(EDMA_Stream1_IRQn, 1, 0);
123
124 /* enable edma stream1 */
125 edma_stream_enable(EDMA_STREAM1, TRUE);
126
127 while(1)
128 {
129 }
130}
131
137void uart_init(uint32_t bound)
138{
139 gpio_init_type gpio_init_struct;
140
141 /* enable the uart clock */
142 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
143 crm_periph_clock_enable(CRM_USART1_PERIPH_CLOCK, TRUE);
144
145 /* set default parameter */
146 gpio_default_para_init(&gpio_init_struct);
147
148 /* configure uart tx gpio */
149 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
150 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
151 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
152 gpio_init_struct.gpio_pins = GPIO_PINS_9;
153 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
154 gpio_init(GPIOA, &gpio_init_struct);
155 /* configure uart rx gpio */
156 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
157 gpio_init_struct.gpio_pins = GPIO_PINS_10;
158 gpio_init(GPIOA, &gpio_init_struct);
159
160 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE9, GPIO_MUX_7);
161 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE10, GPIO_MUX_7);
162
163 /* configure usart */
164 usart_init(USART1, bound, USART_DATA_8BITS, USART_STOP_1_BIT);
165 usart_parity_selection_config(USART1, USART_PARITY_NONE);
166 usart_transmitter_enable(USART1, TRUE);
167 usart_receiver_enable(USART1, TRUE);
168 usart_dma_transmitter_enable(USART1, TRUE);
169 usart_enable(USART1, TRUE);
170}
171
177void EDMA_Stream1_IRQHandler(void)
178{
179 if(edma_flag_get(EDMA_FDT1_FLAG) != RESET)
180 {
181 /* led2/3/4 on */
182 at32_led_on(LED2);
183 at32_led_on(LED3);
184 at32_led_on(LED4);
185 edma_flag_clear(EDMA_FDT1_FLAG);
186 }
187}
188
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
LIST_COUNT
#define LIST_COUNT
Definition: project/at_start_f435/examples/edma/link_list_mode/src/main.c:38
__ALIGNED
__ALIGNED(16)
edma link list descriptor init function.
Definition: project/at_start_f435/examples/edma/link_list_mode/src/main.c:58
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f435/examples/edma/link_list_mode/src/main.c:39
tx_buffer
const int8_t tx_buffer[3][35]
Definition: project/at_start_f435/examples/edma/link_list_mode/src/main.c:51
main
int main(void)
main function.
Definition: project/at_start_f435/examples/edma/link_list_mode/src/main.c:94
uart_init
void uart_init(uint32_t bound)
initialize print usart
Definition: project/at_start_f435/examples/edma/link_list_mode/src/main.c:137
EDMA_Stream1_IRQHandler
void EDMA_Stream1_IRQHandler(void)
this function handles edma stream1 handler.
Definition: project/at_start_f435/examples/edma/link_list_mode/src/main.c:177
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_EDMA_PERIPH_CLOCK
@ CRM_EDMA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:114
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_USART1_PERIPH_CLOCK
@ CRM_USART1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:156
edma_flag_get
flag_status edma_flag_get(uint32_t edma_flag)
get the edma flag.
Definition: at32f435_437_edma.c:512
edma_flag_clear
void edma_flag_clear(uint32_t edma_flag)
clear the edma flag.
Definition: at32f435_437_edma.c:549
edmamux_init
void edmamux_init(edmamux_channel_type *edmamux_channelx, edmamux_requst_id_sel_type edmamux_req_id)
edmamux init.
Definition: at32f435_437_edma.c:718
edma_link_list_init
void edma_link_list_init(edma_stream_link_list_type *edma_streamx_ll, uint32_t pointer)
initialize the edma link list.
Definition: at32f435_437_edma.c:632
edma_stream_enable
void edma_stream_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx.
Definition: at32f435_437_edma.c:198
edmamux_enable
void edmamux_enable(confirm_state new_state)
enable or disable the edma edmamux.
Definition: at32f435_437_edma.c:673
edma_link_list_enable
void edma_link_list_enable(edma_stream_link_list_type *edma_streamx_ll, confirm_state new_state)
enable or disable the edma stream link list mode.
Definition: at32f435_437_edma.c:652
edma_interrupt_enable
void edma_interrupt_enable(edma_stream_type *edma_streamx, uint32_t edma_int, confirm_state new_state)
enable or disable the edma streamx interrupts.
Definition: at32f435_437_edma.c:225
EDMAMUX_DMAREQ_ID_USART1_TX
@ EDMAMUX_DMAREQ_ID_USART1_TX
Definition: at32f435_437_edma.h:285
EDMA_FDT1_FLAG
#define EDMA_FDT1_FLAG
Definition: at32f435_437_edma.h:71
EDMA_FDT_INT
#define EDMA_FDT_INT
Definition: at32f435_437_edma.h:55
EDMA_STREAM1_LL
#define EDMA_STREAM1_LL
Definition: at32f435_437_edma.h:980
EDMA_STREAM1
#define EDMA_STREAM1
Definition: at32f435_437_edma.h:962
EDMAMUX_CHANNEL1
#define EDMAMUX_CHANNEL1
Definition: at32f435_437_edma.h:989
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
usart_parity_selection_config
void usart_parity_selection_config(usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config.
Definition: at32f435_437_usart.c:168
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f435_437_usart.c:209
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f435_437_usart.c:115
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f435_437_usart.c:196
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f435_437_usart.c:222
usart_dma_transmitter_enable
void usart_dma_transmitter_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface.
Definition: at32f435_437_usart.c:304
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f435_437_usart.h:159
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f435_437_usart.h:114
USART_PARITY_NONE
@ USART_PARITY_NONE
Definition: at32f435_437_usart.h:94
USART1
#define USART1
Definition: at32f435_437_usart.h:348
EDMA_Stream1_IRQn
@ EDMA_Stream1_IRQn
Definition: at32f435_437.h:157
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
ll_descriptors_type
Definition: project/at_start_f435/examples/edma/link_list_mode/src/main.c:43
ll_descriptors_type::ctrl_dtcnt
uint32_t ctrl_dtcnt
Definition: project/at_start_f435/examples/edma/link_list_mode/src/main.c:44
ll_descriptors_type::llp
uint32_t llp
Definition: project/at_start_f435/examples/edma/link_list_mode/src/main.c:47
ll_descriptors_type::paddr
uint32_t paddr
Definition: project/at_start_f435/examples/edma/link_list_mode/src/main.c:45
ll_descriptors_type::m0addr
uint32_t m0addr
Definition: project/at_start_f435/examples/edma/link_list_mode/src/main.c:46
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • edma
  • two_dimension_mode
  • inc
project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • edma
  • two_dimension_mode
  • inc
project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • edma
  • two_dimension_mode
  • inc
project/at_start_f435/examples/edma/two_dimension_mode/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • edma
  • two_dimension_mode
  • src
Functions
project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • edma
  • two_dimension_mode
  • src
project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • edma
  • two_dimension_mode
  • src
Functions
project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • edma
  • two_dimension_mode
  • src
project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while (1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while (1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while (1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while (1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/edma/two_dimension_mode/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • edma
  • two_dimension_mode
  • src
Macros | Functions | Variables
project/at_start_f435/examples/edma/two_dimension_mode/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 32

Functions

void | EDMA_Stream1_IRQHandler (void)
this function handles edma stream1 handler. More...
int | main (void)
main function. More...

Variables

const uint32_t | src_const_buffer [32]
uint32_t | dst_buffer [32]
edma_init_type edma_init_struct
__IO uint32_t | data_counter_end = 0x01
error_status transfer_status = ERROR
uint16_t | counter = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/edma/two_dimension_mode/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • edma
  • two_dimension_mode
  • src
project/at_start_f435/examples/edma/two_dimension_mode/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define BUFFER_SIZE 32
39
40const uint32_t src_const_buffer[BUFFER_SIZE]= {0x01020304, 0x05060708, 0x090A0B0C, 0x0D0E0F10,
41 0x11121314, 0x15161718, 0x191A1B1C, 0x1D1E1F20,
42 0x21222324, 0x25262728, 0x292A2B2C, 0x2D2E2F30,
43 0x31323334, 0x35363738, 0x393A3B3C, 0x3D3E3F40,
44 0x41424344, 0x45464748, 0x494A4B4C, 0x4D4E4F50,
45 0x51525354, 0x55565758, 0x595A5B5C, 0x5D5E5F60,
46 0x61626364, 0x65666768, 0x696A6B6C, 0x6D6E6F70,
47 0x71727374, 0x75767778, 0x797A7B7C, 0x7D7E7F80};
48uint32_t dst_buffer[BUFFER_SIZE];
49 edma_init_type edma_init_struct;
50__IO uint32_t data_counter_end = 0x01; /* this variable should not be initialized to 0 */
51 error_status transfer_status = ERROR;
52uint16_t counter = 0;
53
54
60void EDMA_Stream1_IRQHandler(void)
61{
62 if(edma_flag_get(EDMA_FDT1_FLAG) != RESET)
63 {
64 data_counter_end = 0;
65 edma_flag_clear(EDMA_FDT1_FLAG);
66 }
67}
68
74int main(void)
75{
76 int index;
77 system_clock_config();
78
79 at32_board_init();
80
81 uart_print_init(115200);
82
83 /* enable dma1 clock */
84 crm_periph_clock_enable(CRM_EDMA_PERIPH_CLOCK, TRUE);
85
86 /* edma stream1 configuration */
87 edma_default_para_init(&edma_init_struct);
88 edma_init_struct.direction = EDMA_DIR_MEMORY_TO_MEMORY;
89 edma_init_struct.buffer_size = (uint32_t)BUFFER_SIZE;
90 edma_init_struct.peripheral_data_width = EDMA_PERIPHERAL_DATA_WIDTH_WORD;
91 edma_init_struct.peripheral_base_addr = (uint32_t)src_const_buffer;
92 edma_init_struct.peripheral_inc_enable = TRUE;
93 edma_init_struct.memory_data_width = EDMA_MEMORY_DATA_WIDTH_WORD;
94 edma_init_struct.memory0_base_addr = (uint32_t)dst_buffer;
95 edma_init_struct.memory_inc_enable = TRUE;
96 edma_init_struct.peripheral_burst_mode = EDMA_PERIPHERAL_SINGLE;
97 edma_init_struct.memory_burst_mode = EDMA_MEMORY_SINGLE;
98 edma_init_struct.fifo_mode_enable = TRUE;
99 edma_init_struct.fifo_threshold = EDMA_FIFO_THRESHOLD_FULL;
100 edma_init_struct.priority = EDMA_PRIORITY_HIGH;
101 edma_init_struct.loop_mode_enable = FALSE;
102 edma_init(EDMA_STREAM1, &edma_init_struct);
103
104 /* enable transfer full data intterrupt */
105 edma_interrupt_enable(EDMA_STREAM1, EDMA_FDT_INT, TRUE);
106
107 /* edma stream1 interrupt nvic init */
108 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
109 nvic_irq_enable(EDMA_Stream1_IRQn, 1, 0);
110
111 /* two dimension mode init */
112 /* source stride = 0x10, destination stride = 0x8, xcnt = 0x2, ycnt = 0x8 */
113 edma_2d_init(EDMA_STREAM1_2D, 0x10, 0x8, 0x2, 0x8);
114 edma_2d_enable(EDMA_STREAM1_2D, TRUE);
115
116 edma_stream_enable(EDMA_STREAM1, TRUE);
117
118 /* wait the end of transmission */
119 while(data_counter_end != 0)
120 {
121 }
122
123 printf("source buffer:\r\n");
124 for(counter = 0; counter < BUFFER_SIZE; counter ++)
125 {
126 printf("%x ",src_const_buffer[counter]);
127 index ++;
128 if(index == 4)
129 {
130 printf("\r\n");
131 index = 0;
132 }
133 }
134
135 printf("destination buffer:\r\n");
136 for(counter = 0; counter < BUFFER_SIZE/2; counter ++)
137 {
138 printf("%x ",dst_buffer[counter]);
139 index ++;
140 if(index == 2)
141 {
142 printf("\r\n");
143 index = 0;
144 }
145 }
146
147 while(1)
148 {
149 }
150}
151
at32f435_437_board.h
edma_init_struct
edma_init_type edma_init_struct
Definition: project/at_start_f435/examples/edma/two_dimension_mode/src/main.c:49
src_const_buffer
const uint32_t src_const_buffer[32]
Definition: project/at_start_f435/examples/edma/two_dimension_mode/src/main.c:40
data_counter_end
__IO uint32_t data_counter_end
Definition: project/at_start_f435/examples/edma/two_dimension_mode/src/main.c:50
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f435/examples/edma/two_dimension_mode/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f435/examples/edma/two_dimension_mode/src/main.c:74
EDMA_Stream1_IRQHandler
void EDMA_Stream1_IRQHandler(void)
this function handles edma stream1 handler.
Definition: project/at_start_f435/examples/edma/two_dimension_mode/src/main.c:60
dst_buffer
uint32_t dst_buffer[32]
Definition: project/at_start_f435/examples/edma/two_dimension_mode/src/main.c:48
transfer_status
error_status transfer_status
Definition: project/at_start_f435/examples/edma/two_dimension_mode/src/main.c:51
counter
uint16_t counter
Definition: project/at_start_f435/examples/edma/two_dimension_mode/src/main.c:52
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_EDMA_PERIPH_CLOCK
@ CRM_EDMA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:114
edma_flag_get
flag_status edma_flag_get(uint32_t edma_flag)
get the edma flag.
Definition: at32f435_437_edma.c:512
edma_flag_clear
void edma_flag_clear(uint32_t edma_flag)
clear the edma flag.
Definition: at32f435_437_edma.c:549
edma_init
void edma_init(edma_stream_type *edma_streamx, edma_init_type *edma_init_struct)
edma init.
Definition: at32f435_437_edma.c:115
edma_2d_init
void edma_2d_init(edma_stream_2d_type *edma_streamx_2d, int16_t src_stride, int16_t dst_stride, uint16_t xcnt, uint16_t ycnt)
initialize the edma 2d mode.
Definition: at32f435_437_edma.c:579
edma_2d_enable
void edma_2d_enable(edma_stream_2d_type *edma_streamx_2d, confirm_state new_state)
enable or disable the edma 2d mode.
Definition: at32f435_437_edma.c:601
edma_stream_enable
void edma_stream_enable(edma_stream_type *edma_streamx, confirm_state new_state)
enable or disable the edma streamx.
Definition: at32f435_437_edma.c:198
edma_interrupt_enable
void edma_interrupt_enable(edma_stream_type *edma_streamx, uint32_t edma_int, confirm_state new_state)
enable or disable the edma streamx interrupts.
Definition: at32f435_437_edma.c:225
edma_default_para_init
void edma_default_para_init(edma_init_type *edma_init_struct)
edma init struct config with its default value.
Definition: at32f435_437_edma.c:165
EDMA_PRIORITY_HIGH
@ EDMA_PRIORITY_HIGH
Definition: at32f435_437_edma.h:191
EDMA_PERIPHERAL_DATA_WIDTH_WORD
@ EDMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f435_437_edma.h:171
EDMA_MEMORY_DATA_WIDTH_WORD
@ EDMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f435_437_edma.h:181
EDMA_MEMORY_SINGLE
@ EDMA_MEMORY_SINGLE
Definition: at32f435_437_edma.h:224
EDMA_PERIPHERAL_SINGLE
@ EDMA_PERIPHERAL_SINGLE
Definition: at32f435_437_edma.h:235
EDMA_FIFO_THRESHOLD_FULL
@ EDMA_FIFO_THRESHOLD_FULL
Definition: at32f435_437_edma.h:203
EDMA_DIR_MEMORY_TO_MEMORY
@ EDMA_DIR_MEMORY_TO_MEMORY
Definition: at32f435_437_edma.h:161
EDMA_FDT1_FLAG
#define EDMA_FDT1_FLAG
Definition: at32f435_437_edma.h:71
EDMA_FDT_INT
#define EDMA_FDT_INT
Definition: at32f435_437_edma.h:55
EDMA_STREAM1
#define EDMA_STREAM1
Definition: at32f435_437_edma.h:962
EDMA_STREAM1_2D
#define EDMA_STREAM1_2D
Definition: at32f435_437_edma.h:971
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
EDMA_Stream1_IRQn
@ EDMA_Stream1_IRQn
Definition: at32f435_437.h:157
edma_init_type
edma init type
Definition: at32f435_437_edma.h:440
edma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_edma.h:441
edma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_edma.h:444
edma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_edma.h:446
edma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_edma.h:445
edma_init_type::direction
edma_dir_type direction
Definition: at32f435_437_edma.h:443
edma_init_type::fifo_mode_enable
confirm_state fifo_mode_enable
Definition: at32f435_437_edma.h:451
edma_init_type::peripheral_data_width
edma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_edma.h:447
edma_init_type::fifo_threshold
edma_fifo_threshold_type fifo_threshold
Definition: at32f435_437_edma.h:452
edma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_edma.h:449
edma_init_type::priority
edma_priority_level_type priority
Definition: at32f435_437_edma.h:450
edma_init_type::memory0_base_addr
uint32_t memory0_base_addr
Definition: at32f435_437_edma.h:442
edma_init_type::peripheral_burst_mode
edma_peripheral_burst_type peripheral_burst_mode
Definition: at32f435_437_edma.h:454
edma_init_type::memory_data_width
edma_memory_data_size_type memory_data_width
Definition: at32f435_437_edma.h:448
edma_init_type::memory_burst_mode
edma_memory_burst_type memory_burst_mode
Definition: at32f435_437_edma.h:453
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • ertc
  • bpr_domain
  • inc
project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • ertc
  • bpr_domain
  • inc
project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • ertc
  • bpr_domain
  • inc
project/at_start_f435/examples/ertc/bpr_domain/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • ertc
  • bpr_domain
  • src
Functions
project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • ertc
  • bpr_domain
  • src
project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • ertc
  • bpr_domain
  • src
Functions
project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • ertc
  • bpr_domain
  • src
project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/ertc/bpr_domain/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • ertc
  • bpr_domain
  • src
Macros | Functions | Variables
project/at_start_f435/examples/ertc/bpr_domain/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define ERTC_BPR_DT_NUMBER 20

Functions

void | ertc_config (void)
configure the ertc peripheral. More...
void | bpr_reg_write (void)
write data to bpr dt register. More...
uint32_t | bpr_reg_check (void)
checks if the bpr dt register values are correct or not. More...
int | main (void)
main function. More...

Variables

ertc_dt_type bpr_addr_tab [20]

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/bpr_domain/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • ertc
  • bpr_domain
  • src
project/at_start_f435/examples/ertc/bpr_domain/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define ERTC_BPR_DT_NUMBER 20
39
40 ertc_dt_type bpr_addr_tab[ERTC_BPR_DT_NUMBER] =
41{
42 ERTC_DT1, ERTC_DT2, ERTC_DT3, ERTC_DT4, ERTC_DT5,
43 ERTC_DT6, ERTC_DT7, ERTC_DT8, ERTC_DT9, ERTC_DT10,
44 ERTC_DT11, ERTC_DT12, ERTC_DT13, ERTC_DT14, ERTC_DT15,
45 ERTC_DT16, ERTC_DT17, ERTC_DT18, ERTC_DT19, ERTC_DT20
46};
47
48void ertc_config(void);
49void bpr_reg_write(void);
50uint32_t bpr_reg_check(void);
51
57int main(void)
58{
59 uint32_t temp = 0;
60 ertc_time_type time;
61
62 /* initial system clock */
63 system_clock_config();
64
65 /* initial the nvic priority group */
66 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
67
68 /* initialize uart */
69 uart_print_init(115200);
70
71 printf("\r\nertc bpr domain example\r\n\r\n");
72
73 /* enable the pwc clock interface */
74 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
75
76 /* allow access to bpr domain */
77 pwc_battery_powered_domain_access(TRUE);
78
79 /* check data from bpr dt register */
80 if(bpr_reg_check() == FALSE)
81 {
82 printf("bpr reg => reset\r\n\r\n");
83
84 /* ertc configuration */
85 ertc_config();
86
87 /* write to ertc bpr data registers */
88 bpr_reg_write();
89 }
90 else
91 {
92 printf("bpr reg => none reset\r\n\r\n");
93
94 /* wait for ertc registers update */
95 ertc_wait_update();
96 }
97
98 while(1)
99 {
100 /* get the current time */
101 ertc_calendar_get(&time);
102
103 if(temp != time.sec)
104 {
105 temp = time.sec;
106
107 /* display date format : year-month-day */
108 printf("%02d-%02d-%02d ",time.year, time.month, time.day);
109
110 /* display time format : hour:min:sec */
111 printf("%02d:%02d:%02d\r\n",time.hour, time.min, time.sec);
112 }
113 }
114}
115
121void ertc_config(void)
122{
123 /* allow access to ertc */
124 pwc_battery_powered_domain_access(TRUE);
125
126 /* reset ertc domain */
127 crm_battery_powered_domain_reset(TRUE);
128 crm_battery_powered_domain_reset(FALSE);
129
130 /* enable the lext osc */
131 crm_clock_source_enable(CRM_CLOCK_SOURCE_LEXT, TRUE);
132
133 /* wait till lext is ready */
134 while(crm_flag_get(CRM_LEXT_STABLE_FLAG) == RESET)
135 {
136 }
137
138 /* select the ertc clock source */
139 crm_ertc_clock_select(CRM_ERTC_CLOCK_LEXT);
140
141 /* enable the ertc clock */
142 crm_ertc_clock_enable(TRUE);
143
144 /* deinitializes the ertc registers */
145 ertc_reset();
146
147 /* wait for ertc apb registers update */
148 ertc_wait_update();
149
150 /* configure the ertc divider */
151 /* ertc second(1hz) = ertc_clk / (div_a + 1) * (div_b + 1) */
152 ertc_divider_set(127, 255);
153
154 /* configure the ertc hour mode */
155 ertc_hour_mode_set(ERTC_HOUR_MODE_24);
156
157 /* set date: 2021-05-01 */
158 ertc_date_set(21, 5, 1, 5);
159
160 /* set time: 12:00:00 */
161 ertc_time_set(12, 0, 0, ERTC_AM);
162}
163
169void bpr_reg_write(void)
170{
171 uint32_t index = 0;
172
173 for (index = 0; index < ERTC_BPR_DT_NUMBER; index++)
174 {
175 ertc_bpr_data_write(bpr_addr_tab[index], 0x5A00 + (index * 0x5A));
176 }
177}
178
187uint32_t bpr_reg_check(void)
188{
189 uint32_t index = 0;
190
191 for (index = 0; index < ERTC_BPR_DT_NUMBER; index++)
192 {
193 if (ertc_bpr_data_read(bpr_addr_tab[index]) != (0x5A00 + (index * 0x5A)))
194 {
195 return FALSE;
196 }
197 }
198
199 return TRUE;
200}
201
at32f435_437_board.h
ERTC_BPR_DT_NUMBER
#define ERTC_BPR_DT_NUMBER
Definition: project/at_start_f435/examples/ertc/bpr_domain/src/main.c:38
bpr_addr_tab
ertc_dt_type bpr_addr_tab[20]
Definition: project/at_start_f435/examples/ertc/bpr_domain/src/main.c:40
bpr_reg_write
void bpr_reg_write(void)
write data to bpr dt register.
Definition: project/at_start_f435/examples/ertc/bpr_domain/src/main.c:169
main
int main(void)
main function.
Definition: project/at_start_f435/examples/ertc/bpr_domain/src/main.c:57
bpr_reg_check
uint32_t bpr_reg_check(void)
checks if the bpr dt register values are correct or not.
Definition: project/at_start_f435/examples/ertc/bpr_domain/src/main.c:187
ertc_config
void ertc_config(void)
configure the ertc peripheral.
Definition: project/at_start_f435/examples/ertc/bpr_domain/src/main.c:121
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_ertc_clock_select
void crm_ertc_clock_select(crm_ertc_clock_type value)
select ertc clock
Definition: at32f435_437_crm.c:434
crm_ertc_clock_enable
void crm_ertc_clock_enable(confirm_state new_state)
enable or disable ertc
Definition: at32f435_437_crm.c:445
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_battery_powered_domain_reset
void crm_battery_powered_domain_reset(confirm_state new_state)
battery powered domain software reset
Definition: at32f435_437_crm.c:541
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_CLOCK_SOURCE_LEXT
@ CRM_CLOCK_SOURCE_LEXT
Definition: at32f435_437_crm.h:562
CRM_ERTC_CLOCK_LEXT
@ CRM_ERTC_CLOCK_LEXT
Definition: at32f435_437_crm.h:632
CRM_LEXT_STABLE_FLAG
#define CRM_LEXT_STABLE_FLAG
Definition: at32f435_437_crm.h:58
ertc_hour_mode_set
error_status ertc_hour_mode_set(ertc_hour_mode_set_type mode)
ertc hour mode set.
Definition: at32f435_437_ertc.c:283
ertc_wait_update
error_status ertc_wait_update(void)
ertc wait register update finish.
Definition: at32f435_437_ertc.c:97
ertc_time_set
error_status ertc_time_set(uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
set time.
Definition: at32f435_437_ertc.c:363
ertc_reset
error_status ertc_reset(void)
ertc reset all register.
Definition: at32f435_437_ertc.c:207
ertc_date_set
error_status ertc_date_set(uint8_t year, uint8_t month, uint8_t date, uint8_t week)
set date.
Definition: at32f435_437_ertc.c:314
ertc_bpr_data_read
uint32_t ertc_bpr_data_read(ertc_dt_type dt)
read data from bpr register.
Definition: at32f435_437_ertc.c:1550
ertc_calendar_get
void ertc_calendar_get(ertc_time_type *time)
get calendar
Definition: at32f435_437_ertc.c:404
ertc_divider_set
error_status ertc_divider_set(uint16_t div_a, uint16_t div_b)
ertc division set.
Definition: at32f435_437_ertc.c:251
ertc_bpr_data_write
void ertc_bpr_data_write(ertc_dt_type dt, uint32_t data)
write data to the bpr register.
Definition: at32f435_437_ertc.c:1524
ertc_dt_type
ertc_dt_type
ertc bpr register
Definition: at32f435_437_ertc.h:356
ERTC_HOUR_MODE_24
@ ERTC_HOUR_MODE_24
Definition: at32f435_437_ertc.h:116
ERTC_DT11
@ ERTC_DT11
Definition: at32f435_437_ertc.h:367
ERTC_DT13
@ ERTC_DT13
Definition: at32f435_437_ertc.h:369
ERTC_DT2
@ ERTC_DT2
Definition: at32f435_437_ertc.h:358
ERTC_DT1
@ ERTC_DT1
Definition: at32f435_437_ertc.h:357
ERTC_DT15
@ ERTC_DT15
Definition: at32f435_437_ertc.h:371
ERTC_DT18
@ ERTC_DT18
Definition: at32f435_437_ertc.h:374
ERTC_DT19
@ ERTC_DT19
Definition: at32f435_437_ertc.h:375
ERTC_DT6
@ ERTC_DT6
Definition: at32f435_437_ertc.h:362
ERTC_DT7
@ ERTC_DT7
Definition: at32f435_437_ertc.h:363
ERTC_DT20
@ ERTC_DT20
Definition: at32f435_437_ertc.h:376
ERTC_DT17
@ ERTC_DT17
Definition: at32f435_437_ertc.h:373
ERTC_DT3
@ ERTC_DT3
Definition: at32f435_437_ertc.h:359
ERTC_DT4
@ ERTC_DT4
Definition: at32f435_437_ertc.h:360
ERTC_DT8
@ ERTC_DT8
Definition: at32f435_437_ertc.h:364
ERTC_DT5
@ ERTC_DT5
Definition: at32f435_437_ertc.h:361
ERTC_DT10
@ ERTC_DT10
Definition: at32f435_437_ertc.h:366
ERTC_DT9
@ ERTC_DT9
Definition: at32f435_437_ertc.h:365
ERTC_DT16
@ ERTC_DT16
Definition: at32f435_437_ertc.h:372
ERTC_DT12
@ ERTC_DT12
Definition: at32f435_437_ertc.h:368
ERTC_DT14
@ ERTC_DT14
Definition: at32f435_437_ertc.h:370
ERTC_AM
@ ERTC_AM
Definition: at32f435_437_ertc.h:126
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
time
ertc_time_type * time
Definition: random.c:41
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f435_437_pwc.c:61
ertc_time_type
ertc time
Definition: at32f435_437_ertc.h:383
ertc_time_type::year
uint8_t year
Definition: at32f435_437_ertc.h:384
ertc_time_type::day
uint8_t day
Definition: at32f435_437_ertc.h:386
ertc_time_type::hour
uint8_t hour
Definition: at32f435_437_ertc.h:387
ertc_time_type::min
uint8_t min
Definition: at32f435_437_ertc.h:388
ertc_time_type::month
uint8_t month
Definition: at32f435_437_ertc.h:385
ertc_time_type::sec
uint8_t sec
Definition: at32f435_437_ertc.h:389
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • ertc
  • calendar
  • inc
project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • ertc
  • calendar
  • inc
project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • ertc
  • calendar
  • inc
project/at_start_f435/examples/ertc/calendar/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • ertc
  • calendar
  • src
Functions
project/at_start_f435/examples/ertc/calendar/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/calendar/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • ertc
  • calendar
  • src
project/at_start_f435/examples/ertc/calendar/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/ertc/calendar/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • ertc
  • calendar
  • src
Functions
project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void | ertc_alarm_show (void)
display the current alarm. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ERTCAlarm_IRQHandler (void)
this function handles ertc alarms interrupt request. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • ertc
  • calendar
  • src
project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29#include "at32f435_437_board.h"
30
39extern void ertc_alarm_show(void);
40
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
143void ERTCAlarm_IRQHandler(void)
144{
145 if(ertc_flag_get(ERTC_ALAF_FLAG) != RESET)
146 {
147 /* display the alarm */
148 ertc_alarm_show();
149
150 at32_led_on(LED2);
151
152 /* clear alarm flag */
153 ertc_flag_clear(ERTC_ALAF_FLAG);
154
155 /* clear exint flag */
156 exint_flag_clear(EXINT_LINE_17);
157 }
158}
159
at32f435_437_board.h
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c:107
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c:46
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c:81
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c:134
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c:116
ERTCAlarm_IRQHandler
void ERTCAlarm_IRQHandler(void)
this function handles ertc alarms interrupt request.
Definition: project/at_start_f435/examples/ertc/calendar/src/at32f435_437_int.c:143
ertc_alarm_show
void ertc_alarm_show(void)
display the current alarm.
Definition: project/at_start_f435/examples/ertc/calendar/src/main.c:247
LED2
@ LED2
Definition: at32f435_437_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
ertc_flag_get
flag_status ertc_flag_get(uint32_t flag)
get flag status.
Definition: at32f435_437_ertc.c:1474
ertc_flag_clear
void ertc_flag_clear(uint32_t flag)
clear flag status
Definition: at32f435_437_ertc.c:1507
ERTC_ALAF_FLAG
#define ERTC_ALAF_FLAG
Definition: at32f435_437_ertc.h:74
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
EXINT_LINE_17
#define EXINT_LINE_17
Definition: at32f435_437_exint.h:69
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • ertc
  • calendar
  • src
Macros | Functions | Variables
project/at_start_f435/examples/ertc/calendar/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define ERTC_CLOCK_SOURCE_LEXT /* select lext as the ertc clock */

Functions

void | ertc_config (void)
configure the ertc peripheral by selecting the clock source. More...
void | ertc_alarm_show (void)
display the current alarm. More...
void | ertc_time_show (void)
display the current time. More...
int | main (void)
main program More...

Variables

__IO uint16_t | ertc_clk_div_a = 0
__IO uint16_t | ertc_clk_div_b = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/calendar/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • ertc
  • calendar
  • src
project/at_start_f435/examples/ertc/calendar/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38/* select the ertc clock source */
39#define ERTC_CLOCK_SOURCE_LEXT /* select lext as the ertc clock */
40//#define ERTC_CLOCK_SOURCE_LICK /* select lick as the ertc clock */
41
42__IO uint16_t ertc_clk_div_a = 0;
43__IO uint16_t ertc_clk_div_b = 0;
44
45void ertc_config(void);
46void ertc_alarm_show(void);
47void ertc_time_show(void);
48
54int main(void)
55{
56 exint_init_type exint_init_struct;
57 ertc_time_type time;
58 uint32_t temp = 0;
59
60 /* initial system clock */
61 system_clock_config();
62
63 /* initial the nvic priority group */
64 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
65
66 /* at board initial */
67 at32_board_init();
68
69 /* initialize uart */
70 uart_print_init(115200);
71
72 /* enable the pwc clock interface */
73 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
74
75 /* allow access to ertc */
76 pwc_battery_powered_domain_access(TRUE);
77
78 if (ertc_bpr_data_read(ERTC_DT1) != 0x1234)
79 {
80 /* printf ertc status */
81 printf("ertc has not been initialized\r\n\r\n");
82
83 /* ertc configuration */
84 ertc_config();
85 }
86 else
87 {
88 /* printf ertc status */
89 printf("ertc has been initialized\r\n\r\n");
90
91 /* wait for ertc registers update */
92 ertc_wait_update();
93
94 /* clear the ertc alarm flag */
95 ertc_flag_clear(ERTC_ALAF_FLAG);
96
97 /* clear the exint line 17 pending bit */
98 exint_flag_clear(EXINT_LINE_17);
99 }
100
101 /* display the ertc alarm and time */
102 ertc_time_show();
103 ertc_alarm_show();
104
105 printf("\r\n");
106
107 /* ertc alarm interrupt configuration */
108 exint_default_para_init(&exint_init_struct);
109 exint_init_struct.line_enable = TRUE;
110 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
111 exint_init_struct.line_select = EXINT_LINE_17;
112 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
113 exint_init(&exint_init_struct);
114
115 /* enable the ertc interrupt */
116 nvic_irq_enable(ERTCAlarm_IRQn, 0, 1);
117
118 while(1)
119 {
120 /* get the current time */
121 ertc_calendar_get(&time);
122
123 if(temp != time.sec)
124 {
125 temp = time.sec;
126
127 /* display date format : year-month-day */
128 printf("%02d-%02d-%02d ",time.year, time.month, time.day);
129
130 /* display time format : hour:min:sec */
131 printf("%02d:%02d:%02d\r\n",time.hour, time.min, time.sec);
132 }
133 }
134}
135
141void ertc_config(void)
142{
143 /* enable the pwc clock interface */
144 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
145
146 /* allow access to ertc */
147 pwc_battery_powered_domain_access(TRUE);
148
149 /* reset ertc domain */
150 crm_battery_powered_domain_reset(TRUE);
151 crm_battery_powered_domain_reset(FALSE);
152
153#if defined (ERTC_CLOCK_SOURCE_LICK)
154 /* enable the lick osc */
155 crm_clock_source_enable(CRM_CLOCK_SOURCE_LICK, TRUE);
156
157 /* wait till lick is ready */
158 while(crm_flag_get(CRM_LICK_STABLE_FLAG) == RESET)
159 {
160 }
161
162 /* select the ertc clock source */
163 crm_ertc_clock_select(CRM_ERTC_CLOCK_LICK);
164
165 /* ertc second(1hz) = ertc_clk(lick) / (ertc_clk_div_a + 1) * (ertc_clk_div_b + 1) */
166 ertc_clk_div_b = 255;
167 ertc_clk_div_a = 127;
168#elif defined (ERTC_CLOCK_SOURCE_LEXT)
169 /* enable the lext osc */
170 crm_clock_source_enable(CRM_CLOCK_SOURCE_LEXT, TRUE);
171
172 /* wait till lext is ready */
173 while(crm_flag_get(CRM_LEXT_STABLE_FLAG) == RESET)
174 {
175 }
176
177 /* select the ertc clock source */
178 crm_ertc_clock_select(CRM_ERTC_CLOCK_LEXT);
179
180 /* ertc second(1hz) = ertc_clk / (ertc_clk_div_a + 1) * (ertc_clk_div_b + 1) */
181 ertc_clk_div_b = 255;
182 ertc_clk_div_a = 127;
183#endif
184
185 /* enable the ertc clock */
186 crm_ertc_clock_enable(TRUE);
187
188 /* deinitializes the ertc registers */
189 ertc_reset();
190
191 /* wait for ertc registers update */
192 ertc_wait_update();
193
194 /* configure the ertc divider */
195 ertc_divider_set(ertc_clk_div_a, ertc_clk_div_b);
196
197 /* configure the ertc hour mode */
198 ertc_hour_mode_set(ERTC_HOUR_MODE_24);
199
200 /* set date: 2021-05-01 */
201 ertc_date_set(21, 5, 1, 5);
202
203 /* set time: 12:00:00 */
204 ertc_time_set(12, 0, 0, ERTC_AM);
205
206 /* set the alarm 12:00:10 */
207 ertc_alarm_mask_set(ERTC_ALA, ERTC_ALARM_MASK_DATE_WEEK);
208 ertc_alarm_week_date_select(ERTC_ALA, ERTC_SLECT_DATE);
209 ertc_alarm_set(ERTC_ALA, 1, 12, 0, 10, ERTC_AM);
210
211 /* enable ertc alarm a interrupt */
212 ertc_interrupt_enable(ERTC_ALA_INT, TRUE);
213
214 /* enable the alarm */
215 ertc_alarm_enable(ERTC_ALA, TRUE);
216
217 ertc_flag_clear(ERTC_ALAF_FLAG);
218
219 /* indicator for the ertc configuration */
220 ertc_bpr_data_write(ERTC_DT1, 0x1234);
221}
222
228void ertc_time_show(void)
229{
230 ertc_time_type time;
231
232 /* get the current time */
233 ertc_calendar_get(&time);
234
235 /* display date format : year-month-day */
236 printf("Time: %02d-%02d-%02d ",time.year, time.month, time.day);
237
238 /* display time format : hour:min:sec */
239 printf("%02d:%02d:%02d\r\n",time.hour, time.min, time.sec);
240}
241
247void ertc_alarm_show(void)
248{
249 ertc_alarm_value_type alarm;
250
251 /* get the current alarm */
252 ertc_alarm_get(ERTC_ALA, &alarm);
253
254 /* display alarm format : hour:min:sec */
255 printf("Alarm: %02d:%02d:%02d\r\n",alarm.hour, alarm.min, alarm.sec);
256}
257
at32f435_437_board.h
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:41
ertc_time_show
void ertc_time_show(void)
display the current time.
Definition: project/at_start_f435/examples/ertc/calendar/src/main.c:228
ertc_clk_div_a
__IO uint16_t ertc_clk_div_a
Definition: project/at_start_f435/examples/ertc/calendar/src/main.c:42
main
int main(void)
main program
Definition: project/at_start_f435/examples/ertc/calendar/src/main.c:54
ertc_config
void ertc_config(void)
configure the ertc peripheral by selecting the clock source.
Definition: project/at_start_f435/examples/ertc/calendar/src/main.c:141
ertc_clk_div_b
__IO uint16_t ertc_clk_div_b
Definition: project/at_start_f435/examples/ertc/calendar/src/main.c:43
ertc_alarm_show
void ertc_alarm_show(void)
display the current alarm.
Definition: project/at_start_f435/examples/ertc/calendar/src/main.c:247
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_ertc_clock_select
void crm_ertc_clock_select(crm_ertc_clock_type value)
select ertc clock
Definition: at32f435_437_crm.c:434
crm_ertc_clock_enable
void crm_ertc_clock_enable(confirm_state new_state)
enable or disable ertc
Definition: at32f435_437_crm.c:445
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_battery_powered_domain_reset
void crm_battery_powered_domain_reset(confirm_state new_state)
battery powered domain software reset
Definition: at32f435_437_crm.c:541
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_CLOCK_SOURCE_LEXT
@ CRM_CLOCK_SOURCE_LEXT
Definition: at32f435_437_crm.h:562
CRM_CLOCK_SOURCE_LICK
@ CRM_CLOCK_SOURCE_LICK
Definition: at32f435_437_crm.h:563
CRM_ERTC_CLOCK_LICK
@ CRM_ERTC_CLOCK_LICK
Definition: at32f435_437_crm.h:633
CRM_ERTC_CLOCK_LEXT
@ CRM_ERTC_CLOCK_LEXT
Definition: at32f435_437_crm.h:632
CRM_LICK_STABLE_FLAG
#define CRM_LICK_STABLE_FLAG
Definition: at32f435_437_crm.h:59
CRM_LEXT_STABLE_FLAG
#define CRM_LEXT_STABLE_FLAG
Definition: at32f435_437_crm.h:58
ertc_alarm_get
void ertc_alarm_get(ertc_alarm_type alarm_x, ertc_alarm_value_type *alarm)
get alarm value.
Definition: at32f435_437_ertc.c:674
ertc_hour_mode_set
error_status ertc_hour_mode_set(ertc_hour_mode_set_type mode)
ertc hour mode set.
Definition: at32f435_437_ertc.c:283
ertc_wait_update
error_status ertc_wait_update(void)
ertc wait register update finish.
Definition: at32f435_437_ertc.c:97
ertc_time_set
error_status ertc_time_set(uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
set time.
Definition: at32f435_437_ertc.c:363
ertc_reset
error_status ertc_reset(void)
ertc reset all register.
Definition: at32f435_437_ertc.c:207
ertc_alarm_mask_set
void ertc_alarm_mask_set(ertc_alarm_type alarm_x, uint32_t mask)
set which bits are irrelevant to the alarm match.
Definition: at32f435_437_ertc.c:458
ertc_interrupt_enable
void ertc_interrupt_enable(uint32_t source, confirm_state new_state)
enable or disable interrupt.
Definition: at32f435_437_ertc.c:1386
ertc_alarm_week_date_select
void ertc_alarm_week_date_select(ertc_alarm_type alarm_x, ertc_week_date_select_type wk)
alarm week or date mode select.
Definition: at32f435_437_ertc.c:500
ertc_date_set
error_status ertc_date_set(uint8_t year, uint8_t month, uint8_t date, uint8_t week)
set date.
Definition: at32f435_437_ertc.c:314
ertc_flag_clear
void ertc_flag_clear(uint32_t flag)
clear flag status
Definition: at32f435_437_ertc.c:1507
ertc_bpr_data_read
uint32_t ertc_bpr_data_read(ertc_dt_type dt)
read data from bpr register.
Definition: at32f435_437_ertc.c:1550
ertc_alarm_set
void ertc_alarm_set(ertc_alarm_type alarm_x, uint8_t week_date, uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
set alarm.
Definition: at32f435_437_ertc.c:538
ertc_calendar_get
void ertc_calendar_get(ertc_time_type *time)
get calendar
Definition: at32f435_437_ertc.c:404
ertc_divider_set
error_status ertc_divider_set(uint16_t div_a, uint16_t div_b)
ertc division set.
Definition: at32f435_437_ertc.c:251
ertc_bpr_data_write
void ertc_bpr_data_write(ertc_dt_type dt, uint32_t data)
write data to the bpr register.
Definition: at32f435_437_ertc.c:1524
ertc_alarm_enable
error_status ertc_alarm_enable(ertc_alarm_type alarm_x, confirm_state new_state)
enable or disable alarm clock.
Definition: at32f435_437_ertc.c:629
ERTC_SLECT_DATE
@ ERTC_SLECT_DATE
Definition: at32f435_437_ertc.h:135
ERTC_HOUR_MODE_24
@ ERTC_HOUR_MODE_24
Definition: at32f435_437_ertc.h:116
ERTC_DT1
@ ERTC_DT1
Definition: at32f435_437_ertc.h:357
ERTC_ALA
@ ERTC_ALA
Definition: at32f435_437_ertc.h:144
ERTC_AM
@ ERTC_AM
Definition: at32f435_437_ertc.h:126
ERTC_ALARM_MASK_DATE_WEEK
#define ERTC_ALARM_MASK_DATE_WEEK
Definition: at32f435_437_ertc.h:90
ERTC_ALAF_FLAG
#define ERTC_ALAF_FLAG
Definition: at32f435_437_ertc.h:74
ERTC_ALA_INT
#define ERTC_ALA_INT
Definition: at32f435_437_ertc.h:53
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f435_437_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
EXINT_LINE_17
#define EXINT_LINE_17
Definition: at32f435_437_exint.h:69
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
time
ertc_time_type * time
Definition: random.c:41
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f435_437_pwc.c:61
ERTCAlarm_IRQn
@ ERTCAlarm_IRQn
Definition: at32f435_437.h:189
ertc_alarm_value_type
ertc alarm
Definition: at32f435_437_ertc.h:398
ertc_alarm_value_type::min
uint8_t min
Definition: at32f435_437_ertc.h:401
ertc_alarm_value_type::sec
uint8_t sec
Definition: at32f435_437_ertc.h:402
ertc_alarm_value_type::hour
uint8_t hour
Definition: at32f435_437_ertc.h:400
ertc_time_type
ertc time
Definition: at32f435_437_ertc.h:383
ertc_time_type::year
uint8_t year
Definition: at32f435_437_ertc.h:384
ertc_time_type::day
uint8_t day
Definition: at32f435_437_ertc.h:386
ertc_time_type::hour
uint8_t hour
Definition: at32f435_437_ertc.h:387
ertc_time_type::min
uint8_t min
Definition: at32f435_437_ertc.h:388
ertc_time_type::month
uint8_t month
Definition: at32f435_437_ertc.h:385
ertc_time_type::sec
uint8_t sec
Definition: at32f435_437_ertc.h:389
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • ertc
  • lick_calibration
  • inc
project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • ertc
  • lick_calibration
  • inc
project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • ertc
  • lick_calibration
  • inc
project/at_start_f435/examples/ertc/lick_calibration/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • ertc
  • lick_calibration
  • src
Functions
project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • ertc
  • lick_calibration
  • src
project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • ertc
  • lick_calibration
  • src
Functions | Variables
project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR5_GLOBAL_IRQHandler (void)
this function handles tmr5 global interrupt request. More...

Variables

__IO uint32_t | period_value
__IO uint32_t | capture_number
uint16_t | tmp_c4 [2] = {0, 0}

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • ertc
  • lick_calibration
  • src
project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29#include "at32f435_437_board.h"
30
39extern __IO uint32_t period_value;
40extern __IO uint32_t capture_number;
41uint16_t tmp_c4[2] = {0, 0};
42
48void NMI_Handler(void)
49{
50}
51
57void HardFault_Handler(void)
58{
59 /* go to infinite loop when hard fault exception occurs */
60 while(1)
61 {
62 }
63}
64
70void MemManage_Handler(void)
71{
72 /* go to infinite loop when memory manage exception occurs */
73 while(1)
74 {
75 }
76}
77
83void BusFault_Handler(void)
84{
85 /* go to infinite loop when bus fault exception occurs */
86 while(1)
87 {
88 }
89}
90
96void UsageFault_Handler(void)
97{
98 /* go to infinite loop when usage fault exception occurs */
99 while(1)
100 {
101 }
102}
103
109void SVC_Handler(void)
110{
111}
112
118void DebugMon_Handler(void)
119{
120}
121
127void PendSV_Handler(void)
128{
129}
130
136void SysTick_Handler(void)
137{
138}
139
145void TMR5_GLOBAL_IRQHandler(void)
146{
147 if (tmr_flag_get(TMR5, TMR_C4_FLAG) != RESET)
148 {
149 /* get the input capture value */
150 tmp_c4[capture_number++] = tmr_channel_value_get(TMR5, TMR_SELECT_CHANNEL_4);
151
152 /* clear c4 interrupt pending bit */
153 tmr_flag_clear(TMR5, TMR_C4_FLAG);
154
155 if (capture_number >= 2)
156 {
157 /* compute the period length */
158 period_value = (uint16_t)(0xFFFF - tmp_c4[0] + tmp_c4[1] + 1);
159 }
160 }
161}
162
at32f435_437_board.h
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c:96
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c:57
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c:70
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c:109
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c:127
capture_number
__IO uint32_t capture_number
Definition: project/at_start_f435/examples/ertc/lick_calibration/src/main.c:39
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c:48
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c:83
TMR5_GLOBAL_IRQHandler
void TMR5_GLOBAL_IRQHandler(void)
this function handles tmr5 global interrupt request.
Definition: project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c:145
period_value
__IO uint32_t period_value
Definition: project/at_start_f435/examples/ertc/lick_calibration/src/main.c:40
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c:136
tmp_c4
uint16_t tmp_c4[2]
Definition: project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c:41
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/ertc/lick_calibration/src/at32f435_437_int.c:118
RESET
@ RESET
Definition: at32f435_437.h:378
tmr_channel_value_get
uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value
Definition: at32f435_437_tmr.c:593
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f435_437_tmr.c:1463
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f435_437_tmr.c:1424
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f435_437_tmr.h:223
TMR_C4_FLAG
#define TMR_C4_FLAG
Definition: at32f435_437_tmr.h:56
TMR5
#define TMR5
Definition: at32f435_437_tmr.h:899
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • ertc
  • lick_calibration
  • src
Functions | Variables
project/at_start_f435/examples/ertc/lick_calibration/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | ertc_config (void)
configures the ertc peripheral by selecting the clock source. More...
uint32_t | lick_frequency_get (void)
configures tmr5 to measure the lick oscillator frequency. More...
int | main (void)
main program More...

Variables

__IO uint32_t | lick_freq = 0
__IO uint32_t | capture_number = 0
__IO uint32_t | period_value = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/lick_calibration/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • ertc
  • lick_calibration
  • src
project/at_start_f435/examples/ertc/lick_calibration/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38__IO uint32_t lick_freq = 0;
39__IO uint32_t capture_number = 0;
40__IO uint32_t period_value = 0;
41
42void ertc_config(void);
43uint32_t lick_frequency_get(void);
44
50int main(void)
51{
52 ertc_time_type time;
53 uint32_t temp = 0;
54
55 /* initial system clock */
56 system_clock_config();
57
58 /* initial the nvic priority group */
59 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
60
61 /* at board initial */
62 at32_board_init();
63
64 /* initialize uart */
65 uart_print_init(115200);
66
67 /* ertc configuration */
68 ertc_config();
69
70 /* get the lick frequency: tmr5 is used to measure the lick frequency */
71 lick_freq = lick_frequency_get();
72
73 /* configure the ertc divider */
74 /* ertc second(1hz) = ertc_clk(lick) / (div_a + 1) * (div_b + 1) */
75 ertc_divider_set(127, (lick_freq / 128) - 1);
76
77 printf("lick_freq = %d\r\n", lick_freq);
78 printf("div_a = %d\r\n", 127);
79 printf("div_b = %d\r\n", (lick_freq / 128) - 1);
80 printf("\r\n");
81
82 while(1)
83 {
84 /* get the current time */
85 ertc_calendar_get(&time);
86
87 if(temp != time.sec)
88 {
89 temp = time.sec;
90
91 /* display date format : year-month-day */
92 printf("%02d-%02d-%02d ",time.year, time.month, time.day);
93
94 /* display time format : hour:min:sec */
95 printf("%02d:%02d:%02d\r\n",time.hour, time.min, time.sec);
96 }
97 }
98}
99
105void ertc_config(void)
106{
107 /* enable the pwc clock */
108 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
109
110 /* allow access to ertc */
111 pwc_battery_powered_domain_access(TRUE);
112
113 /* reset ertc domain */
114 crm_battery_powered_domain_reset(TRUE);
115 crm_battery_powered_domain_reset(FALSE);
116
117 /* enable the lick osc */
118 crm_clock_source_enable(CRM_CLOCK_SOURCE_LICK, TRUE);
119
120 /* wait till lick is ready */
121 while(crm_flag_get(CRM_LICK_STABLE_FLAG) == RESET)
122 {
123 }
124
125 /* select the ertc clock source */
126 crm_ertc_clock_select(CRM_ERTC_CLOCK_LICK);
127
128 /* enable the ertc clock */
129 crm_ertc_clock_enable(TRUE);
130
131 /* deinitializes the ertc registers */
132 ertc_reset();
133
134 /* wait for ertc apb registers update */
135 ertc_wait_update();
136
137 /* configure the ertc divider */
138 ertc_divider_set(0x7F, 0xFF);
139
140 /* configure the ertc hour mode */
141 ertc_hour_mode_set(ERTC_HOUR_MODE_24);
142
143 /* set date: 2021-05-01 */
144 ertc_date_set(21, 5, 1, 5);
145
146 /* set time: 12:00:00 */
147 ertc_time_set(12, 0, 0, ERTC_AM);
148}
149
155uint32_t lick_frequency_get(void)
156{
157 tmr_input_config_type tmr_input_config_struct;
158 crm_clocks_freq_type crm_clock_freq;
159
160 /* enable tmr5 apb1 clocks */
161 crm_periph_clock_enable(CRM_TMR5_PERIPH_CLOCK, TRUE);
162
163 /* connect internally the tmr5_ch4 to the lick clock output */
164 tmr_iremap_config(TMR5, TMR2_PTP_TMR5_LICK);
165
166 /* configure tmr5 divider */
167 tmr_div_value_set(TMR5, 0);
168 tmr_event_sw_trigger(TMR5, TMR_OVERFLOW_SWTRIG);
169
170 /* tmr5 channel4 input capture mode configuration */
171 tmr_input_config_struct.input_channel_select = TMR_SELECT_CHANNEL_4;
172 tmr_input_config_struct.input_mapped_select = TMR_CC_CHANNEL_MAPPED_DIRECT;
173 tmr_input_config_struct.input_polarity_select = TMR_INPUT_RISING_EDGE;
174 tmr_input_config_struct.input_filter_value = 0;
175 tmr_input_channel_init(TMR5, &tmr_input_config_struct, TMR_CHANNEL_INPUT_DIV_1);
176 tmr_input_channel_divider_set(TMR5, TMR_SELECT_CHANNEL_4, TMR_CHANNEL_INPUT_DIV_8);
177
178 /* enable tmr5 interrupt channel */
179 nvic_irq_enable(TMR5_GLOBAL_IRQn, 0, 0);
180
181 /* enable tmr5 counter */
182 tmr_counter_enable(TMR5, TRUE);
183
184 /* reset the flags */
185 TMR5->swevt = 0;
186
187 /* enable the cc4 interrupt request */
188 tmr_interrupt_enable(TMR5, TMR_C4_INT, TRUE);
189
190 /* wait the tmr5 measuring operation to be completed */
191 while(capture_number != 2);
192
193 /* deinitialize the tmr5 peripheral */
194 tmr_reset(TMR5);
195
196 /* get the frequency value */
197 crm_clocks_freq_get(&crm_clock_freq);
198
199 /* get pclk1 divider */
200 if ((CRM->cfg_bit.apb1div) > 0)
201 {
202 /* pclk1 divider different from 1 => timclk = 2 * pclk1 */
203 return (((2 * crm_clock_freq.apb1_freq) / period_value) * 8) ;
204 }
205 else
206 {
207 /* pclk1 divider equal to 1 => timclk = pclk1 */
208 return ((crm_clock_freq.apb1_freq / period_value) * 8);
209 }
210}
211
at32f435_437_board.h
capture_number
__IO uint32_t capture_number
Definition: project/at_start_f435/examples/ertc/lick_calibration/src/main.c:39
main
int main(void)
main program
Definition: project/at_start_f435/examples/ertc/lick_calibration/src/main.c:50
lick_freq
__IO uint32_t lick_freq
Definition: project/at_start_f435/examples/ertc/lick_calibration/src/main.c:38
ertc_config
void ertc_config(void)
configures the ertc peripheral by selecting the clock source.
Definition: project/at_start_f435/examples/ertc/lick_calibration/src/main.c:105
period_value
__IO uint32_t period_value
Definition: project/at_start_f435/examples/ertc/lick_calibration/src/main.c:40
lick_frequency_get
uint32_t lick_frequency_get(void)
configures tmr5 to measure the lick oscillator frequency.
Definition: project/at_start_f435/examples/ertc/lick_calibration/src/main.c:155
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
tmr_input_config_struct
tmr_input_config_type tmr_input_config_struct
Definition: project/at_start_f435/examples/tmr/external_clock/src/main.c:41
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_ertc_clock_select
void crm_ertc_clock_select(crm_ertc_clock_type value)
select ertc clock
Definition: at32f435_437_crm.c:434
crm_ertc_clock_enable
void crm_ertc_clock_enable(confirm_state new_state)
enable or disable ertc
Definition: at32f435_437_crm.c:445
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_battery_powered_domain_reset
void crm_battery_powered_domain_reset(confirm_state new_state)
battery powered domain software reset
Definition: at32f435_437_crm.c:541
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_TMR5_PERIPH_CLOCK
@ CRM_TMR5_PERIPH_CLOCK
Definition: at32f435_437_crm.h:131
CRM_CLOCK_SOURCE_LICK
@ CRM_CLOCK_SOURCE_LICK
Definition: at32f435_437_crm.h:563
CRM_ERTC_CLOCK_LICK
@ CRM_ERTC_CLOCK_LICK
Definition: at32f435_437_crm.h:633
CRM_LICK_STABLE_FLAG
#define CRM_LICK_STABLE_FLAG
Definition: at32f435_437_crm.h:59
CRM
#define CRM
Definition: at32f435_437_crm.h:1506
ertc_hour_mode_set
error_status ertc_hour_mode_set(ertc_hour_mode_set_type mode)
ertc hour mode set.
Definition: at32f435_437_ertc.c:283
ertc_wait_update
error_status ertc_wait_update(void)
ertc wait register update finish.
Definition: at32f435_437_ertc.c:97
ertc_time_set
error_status ertc_time_set(uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
set time.
Definition: at32f435_437_ertc.c:363
ertc_reset
error_status ertc_reset(void)
ertc reset all register.
Definition: at32f435_437_ertc.c:207
ertc_date_set
error_status ertc_date_set(uint8_t year, uint8_t month, uint8_t date, uint8_t week)
set date.
Definition: at32f435_437_ertc.c:314
ertc_calendar_get
void ertc_calendar_get(ertc_time_type *time)
get calendar
Definition: at32f435_437_ertc.c:404
ertc_divider_set
error_status ertc_divider_set(uint16_t div_a, uint16_t div_b)
ertc division set.
Definition: at32f435_437_ertc.c:251
ERTC_HOUR_MODE_24
@ ERTC_HOUR_MODE_24
Definition: at32f435_437_ertc.h:116
ERTC_AM
@ ERTC_AM
Definition: at32f435_437_ertc.h:126
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
time
ertc_time_type * time
Definition: random.c:41
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f435_437_pwc.c:61
tmr_input_channel_divider_set
void tmr_input_channel_divider_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_channel_input_divider_type divider_factor)
set tmr input channel divider
Definition: at32f435_437_tmr.c:1175
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_input_channel_init
void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel
Definition: at32f435_437_tmr.c:872
tmr_div_value_set
void tmr_div_value_set(tmr_type *tmr_x, uint32_t tmr_div_value)
set tmr div value
Definition: at32f435_437_tmr.c:314
tmr_iremap_config
void tmr_iremap_config(tmr_type *tmr_x, tmr_input_remap_type input_remap)
set tmr2/tmr5 input channel remap
Definition: at32f435_437_tmr.c:1824
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f435_437_tmr.c:1486
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f435_437_tmr.c:1389
tmr_reset
void tmr_reset(tmr_type *tmr_x)
tmr reset by crm reset register
Definition: at32f435_437_tmr.c:52
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f435_437_tmr.h:207
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f435_437_tmr.h:223
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f435_437_tmr.h:241
TMR_OVERFLOW_SWTRIG
@ TMR_OVERFLOW_SWTRIG
Definition: at32f435_437_tmr.h:285
TMR2_PTP_TMR5_LICK
@ TMR2_PTP_TMR5_LICK
Definition: at32f435_437_tmr.h:402
TMR_CHANNEL_INPUT_DIV_8
@ TMR_CHANNEL_INPUT_DIV_8
Definition: at32f435_437_tmr.h:254
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f435_437_tmr.h:251
TMR_C4_INT
#define TMR_C4_INT
Definition: at32f435_437_tmr.h:79
TMR5
#define TMR5
Definition: at32f435_437_tmr.h:899
TMR5_GLOBAL_IRQn
@ TMR5_GLOBAL_IRQn
Definition: at32f435_437.h:198
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f435_437_crm.h:792
ertc_time_type
ertc time
Definition: at32f435_437_ertc.h:383
ertc_time_type::year
uint8_t year
Definition: at32f435_437_ertc.h:384
ertc_time_type::day
uint8_t day
Definition: at32f435_437_ertc.h:386
ertc_time_type::hour
uint8_t hour
Definition: at32f435_437_ertc.h:387
ertc_time_type::min
uint8_t min
Definition: at32f435_437_ertc.h:388
ertc_time_type::month
uint8_t month
Definition: at32f435_437_ertc.h:385
ertc_time_type::sec
uint8_t sec
Definition: at32f435_437_ertc.h:389
tmr_input_config_type
tmr input capture config type
Definition: at32f435_437_tmr.h:425
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f435_437_tmr.h:428
tmr_input_config_type::input_filter_value
uint8_t input_filter_value
Definition: at32f435_437_tmr.h:429
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f435_437_tmr.h:427
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f435_437_tmr.h:426
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • ertc
  • tamper
  • inc
project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • ertc
  • tamper
  • inc
project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • ertc
  • tamper
  • inc
project/at_start_f435/examples/ertc/tamper/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • ertc
  • tamper
  • src
Functions
project/at_start_f435/examples/ertc/tamper/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/tamper/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • ertc
  • tamper
  • src
project/at_start_f435/examples/ertc/tamper/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/ertc/tamper/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • ertc
  • tamper
  • src
Functions
project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

uint32_t | is_bpr_reg_reset (void)
checks if the ertc bpr dtx registers are reset or not. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TAMP_STAMP_IRQHandler (void)
this function handles ertc tamper and time stamp interrupts requests. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • ertc
  • tamper
  • src
project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29#include "at32f435_437_board.h"
30
39extern uint32_t is_bpr_reg_reset(void);
40
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
143void TAMP_STAMP_IRQHandler(void)
144{
145 if(ertc_flag_get(ERTC_TP1F_FLAG) != RESET)
146 {
147 /* check if ertc backup data registers are cleared */
148 if(is_bpr_reg_reset() == 0)
149 {
150 printf("tamper: bpr data registers are cleared\r\n");
151 }
152 else
153 {
154 printf("tamper: bpr data registers are not reset\r\n");
155 }
156
157 /* clear tamper 1 pin event pending flag */
158 ertc_flag_clear(ERTC_TP1F_FLAG);
159
160 /* clear exint flag */
161 exint_flag_clear(EXINT_LINE_21);
162 }
163}
164
at32f435_437_board.h
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c:68
is_bpr_reg_reset
uint32_t is_bpr_reg_reset(void)
checks if the ertc bpr dtx registers are reset or not.
Definition: project/at_start_f435/examples/ertc/tamper/src/main.c:232
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c:107
TAMP_STAMP_IRQHandler
void TAMP_STAMP_IRQHandler(void)
this function handles ertc tamper and time stamp interrupts requests.
Definition: project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c:143
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c:46
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c:81
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c:134
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/ertc/tamper/src/at32f435_437_int.c:116
ertc_flag_get
flag_status ertc_flag_get(uint32_t flag)
get flag status.
Definition: at32f435_437_ertc.c:1474
ertc_flag_clear
void ertc_flag_clear(uint32_t flag)
clear flag status
Definition: at32f435_437_ertc.c:1507
ERTC_TP1F_FLAG
#define ERTC_TP1F_FLAG
Definition: at32f435_437_ertc.h:79
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
EXINT_LINE_21
#define EXINT_LINE_21
Definition: at32f435_437_exint.h:73
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • ertc
  • tamper
  • src
Macros | Functions | Variables
project/at_start_f435/examples/ertc/tamper/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define ERTC_BPR_DT_NUMBER 20

Functions

void | ertc_config (void)
configure the ertc peripheral by selecting the clock source. More...
void | bpr_reg_write (void)
write data to bpr dt register. More...
uint32_t | bpr_reg_check (void)
checks if the bpr dt register values are correct or not. More...
uint32_t | is_bpr_reg_reset (void)
checks if the ertc bpr dtx registers are reset or not. More...
void | ertc_tamper_config (void)
configure the ertc tamper. More...
int | main (void)
main program More...

Variables

ertc_dt_type bpr_addr_tab [20]

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/tamper/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • ertc
  • tamper
  • src
project/at_start_f435/examples/ertc/tamper/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define ERTC_BPR_DT_NUMBER 20
39
40 ertc_dt_type bpr_addr_tab[ERTC_BPR_DT_NUMBER] =
41{
42 ERTC_DT1, ERTC_DT2, ERTC_DT3, ERTC_DT4, ERTC_DT5,
43 ERTC_DT6, ERTC_DT7, ERTC_DT8, ERTC_DT9, ERTC_DT10,
44 ERTC_DT11, ERTC_DT12, ERTC_DT13, ERTC_DT14, ERTC_DT15,
45 ERTC_DT16, ERTC_DT17, ERTC_DT18, ERTC_DT19, ERTC_DT20,
46};
47
48void ertc_config(void);
49void bpr_reg_write(void);
50uint32_t bpr_reg_check(void);
51uint32_t is_bpr_reg_reset(void);
52void ertc_tamper_config(void);
53
59int main(void)
60{
61 /* initial system clock */
62 system_clock_config();
63
64 /* initial the nvic priority group */
65 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
66
67 /* at board initial */
68 at32_board_init();
69
70 /* initialize uart */
71 uart_print_init(115200);
72
73 /* ertc configuration */
74 ertc_config();
75
76 /* ertc tamper configuration */
77 ertc_tamper_config();
78
79 /* write to ertc bpr data registers */
80 bpr_reg_write();
81
82 /* check if the written data are correct */
83 if(bpr_reg_check() == TRUE)
84 {
85 printf("init: bpr data registers are not reset\r\n");
86 }
87 else
88 {
89 printf("init: bpr data registers are cleared\r\n");
90 }
91
92 while(1)
93 {
94 }
95}
96
102void ertc_config(void)
103{
104 /* enable the pwc clock */
105 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
106
107 /* allow access to ertc */
108 pwc_battery_powered_domain_access(TRUE);
109
110 /* reset bpr domain */
111 crm_battery_powered_domain_reset(TRUE);
112 crm_battery_powered_domain_reset(FALSE);
113
114 /* enable the lext osc */
115 crm_clock_source_enable(CRM_CLOCK_SOURCE_LEXT, TRUE);
116
117 /* wait till lext is ready */
118 while(crm_flag_get(CRM_LEXT_STABLE_FLAG) == RESET)
119 {
120 }
121
122 /* select the ertc clock source */
123 crm_ertc_clock_select(CRM_ERTC_CLOCK_LEXT);
124
125 /* enable the ertc clock */
126 crm_ertc_clock_enable(TRUE);
127
128 /* deinitializes the ertc registers */
129 ertc_reset();
130
131 /* wait for ertc apb registers update */
132 ertc_wait_update();
133
134 /* configure the ertc divider */
135 /* ertc second(1hz) = ertc_clk / (div_a + 1) * (div_b + 1) */
136 ertc_divider_set(127, 255);
137
138 /* configure the ertc hour mode */
139 ertc_hour_mode_set(ERTC_HOUR_MODE_24);
140
141 /* set date: 2021-05-01 */
142 ertc_date_set(21, 5, 1, 5);
143
144 /* set time: 12:00:00 */
145 ertc_time_set(12, 0, 0, ERTC_AM);
146}
147
153void ertc_tamper_config(void)
154{
155 exint_init_type exint_init_struct;
156
157 /* enable the external line 21 interrupt */
158 exint_default_para_init(&exint_init_struct);
159 exint_init_struct.line_enable = TRUE;
160 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
161 exint_init_struct.line_select = EXINT_LINE_21;
162 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
163 exint_init(&exint_init_struct);
164
165 /* enable tamper interrupt */
166 nvic_irq_enable(TAMP_STAMP_IRQn, 0, 0);
167
168 /* disable the tamper 1 detection */
169 ertc_tamper_enable(ERTC_TAMPER_1, FALSE);
170
171 /* clear tamper 1 pin event(tamp1f) pending flag */
172 ertc_flag_clear(ERTC_TP1F_FLAG);
173
174 /* configure the tamper 1 trigger */
175 ertc_tamper_valid_edge_set(ERTC_TAMPER_1, ERTC_TAMPER_EDGE_RISING);
176
177 /* enable the tamper interrupt */
178 ertc_interrupt_enable(ERTC_TP_INT, TRUE);
179
180 /* clear tamper 1 pin interrupt pending bit */
181 ertc_flag_clear(ERTC_TP1F_FLAG);
182
183 /* enable the tamper 1 detection */
184 ertc_tamper_enable(ERTC_TAMPER_1, TRUE);
185}
186
192void bpr_reg_write(void)
193{
194 uint32_t index = 0;
195
196 for (index = 0; index < ERTC_BPR_DT_NUMBER; index++)
197 {
198 ertc_bpr_data_write(bpr_addr_tab[index], 0x5A00 + (index * 0x5A));
199 }
200}
201
210uint32_t bpr_reg_check(void)
211{
212 uint32_t index = 0;
213
214 for (index = 0; index < ERTC_BPR_DT_NUMBER; index++)
215 {
216 if (ertc_bpr_data_read(bpr_addr_tab[index]) != (0x5A00 + (index * 0x5A)))
217 {
218 return FALSE;
219 }
220 }
221
222 return TRUE;
223}
224
232uint32_t is_bpr_reg_reset(void)
233{
234 uint32_t index = 0;
235
236 for (index = 0; index < ERTC_BPR_DT_NUMBER; index++)
237 {
238 /* read from bpr data register */
239 if (ertc_bpr_data_read(bpr_addr_tab[index]) != 0)
240 {
241 return (index + 1);
242 }
243 }
244 return 0;
245}
246
at32f435_437_board.h
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:41
ERTC_BPR_DT_NUMBER
#define ERTC_BPR_DT_NUMBER
Definition: project/at_start_f435/examples/ertc/tamper/src/main.c:38
is_bpr_reg_reset
uint32_t is_bpr_reg_reset(void)
checks if the ertc bpr dtx registers are reset or not.
Definition: project/at_start_f435/examples/ertc/tamper/src/main.c:232
bpr_addr_tab
ertc_dt_type bpr_addr_tab[20]
Definition: project/at_start_f435/examples/ertc/tamper/src/main.c:40
ertc_tamper_config
void ertc_tamper_config(void)
configure the ertc tamper.
Definition: project/at_start_f435/examples/ertc/tamper/src/main.c:153
bpr_reg_write
void bpr_reg_write(void)
write data to bpr dt register.
Definition: project/at_start_f435/examples/ertc/tamper/src/main.c:192
main
int main(void)
main program
Definition: project/at_start_f435/examples/ertc/tamper/src/main.c:59
bpr_reg_check
uint32_t bpr_reg_check(void)
checks if the bpr dt register values are correct or not.
Definition: project/at_start_f435/examples/ertc/tamper/src/main.c:210
ertc_config
void ertc_config(void)
configure the ertc peripheral by selecting the clock source.
Definition: project/at_start_f435/examples/ertc/tamper/src/main.c:102
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_ertc_clock_select
void crm_ertc_clock_select(crm_ertc_clock_type value)
select ertc clock
Definition: at32f435_437_crm.c:434
crm_ertc_clock_enable
void crm_ertc_clock_enable(confirm_state new_state)
enable or disable ertc
Definition: at32f435_437_crm.c:445
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_battery_powered_domain_reset
void crm_battery_powered_domain_reset(confirm_state new_state)
battery powered domain software reset
Definition: at32f435_437_crm.c:541
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_CLOCK_SOURCE_LEXT
@ CRM_CLOCK_SOURCE_LEXT
Definition: at32f435_437_crm.h:562
CRM_ERTC_CLOCK_LEXT
@ CRM_ERTC_CLOCK_LEXT
Definition: at32f435_437_crm.h:632
CRM_LEXT_STABLE_FLAG
#define CRM_LEXT_STABLE_FLAG
Definition: at32f435_437_crm.h:58
ertc_hour_mode_set
error_status ertc_hour_mode_set(ertc_hour_mode_set_type mode)
ertc hour mode set.
Definition: at32f435_437_ertc.c:283
ertc_wait_update
error_status ertc_wait_update(void)
ertc wait register update finish.
Definition: at32f435_437_ertc.c:97
ertc_time_set
error_status ertc_time_set(uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
set time.
Definition: at32f435_437_ertc.c:363
ertc_reset
error_status ertc_reset(void)
ertc reset all register.
Definition: at32f435_437_ertc.c:207
ertc_interrupt_enable
void ertc_interrupt_enable(uint32_t source, confirm_state new_state)
enable or disable interrupt.
Definition: at32f435_437_ertc.c:1386
ertc_date_set
error_status ertc_date_set(uint8_t year, uint8_t month, uint8_t date, uint8_t week)
set date.
Definition: at32f435_437_ertc.c:314
ertc_tamper_enable
void ertc_tamper_enable(ertc_tamper_select_type tamper_x, confirm_state new_state)
enable or disable tamper.
Definition: at32f435_437_ertc.c:1356
ertc_flag_clear
void ertc_flag_clear(uint32_t flag)
clear flag status
Definition: at32f435_437_ertc.c:1507
ertc_bpr_data_read
uint32_t ertc_bpr_data_read(ertc_dt_type dt)
read data from bpr register.
Definition: at32f435_437_ertc.c:1550
ertc_tamper_valid_edge_set
void ertc_tamper_valid_edge_set(ertc_tamper_select_type tamper_x, ertc_tamper_valid_edge_type trigger)
set the tamper trigger.
Definition: at32f435_437_ertc.c:1313
ertc_divider_set
error_status ertc_divider_set(uint16_t div_a, uint16_t div_b)
ertc division set.
Definition: at32f435_437_ertc.c:251
ertc_bpr_data_write
void ertc_bpr_data_write(ertc_dt_type dt, uint32_t data)
write data to the bpr register.
Definition: at32f435_437_ertc.c:1524
ertc_dt_type
ertc_dt_type
ertc bpr register
Definition: at32f435_437_ertc.h:356
ERTC_TAMPER_EDGE_RISING
@ ERTC_TAMPER_EDGE_RISING
Definition: at32f435_437_ertc.h:346
ERTC_HOUR_MODE_24
@ ERTC_HOUR_MODE_24
Definition: at32f435_437_ertc.h:116
ERTC_TAMPER_1
@ ERTC_TAMPER_1
Definition: at32f435_437_ertc.h:300
ERTC_DT11
@ ERTC_DT11
Definition: at32f435_437_ertc.h:367
ERTC_DT13
@ ERTC_DT13
Definition: at32f435_437_ertc.h:369
ERTC_DT2
@ ERTC_DT2
Definition: at32f435_437_ertc.h:358
ERTC_DT1
@ ERTC_DT1
Definition: at32f435_437_ertc.h:357
ERTC_DT15
@ ERTC_DT15
Definition: at32f435_437_ertc.h:371
ERTC_DT18
@ ERTC_DT18
Definition: at32f435_437_ertc.h:374
ERTC_DT19
@ ERTC_DT19
Definition: at32f435_437_ertc.h:375
ERTC_DT6
@ ERTC_DT6
Definition: at32f435_437_ertc.h:362
ERTC_DT7
@ ERTC_DT7
Definition: at32f435_437_ertc.h:363
ERTC_DT20
@ ERTC_DT20
Definition: at32f435_437_ertc.h:376
ERTC_DT17
@ ERTC_DT17
Definition: at32f435_437_ertc.h:373
ERTC_DT3
@ ERTC_DT3
Definition: at32f435_437_ertc.h:359
ERTC_DT4
@ ERTC_DT4
Definition: at32f435_437_ertc.h:360
ERTC_DT8
@ ERTC_DT8
Definition: at32f435_437_ertc.h:364
ERTC_DT5
@ ERTC_DT5
Definition: at32f435_437_ertc.h:361
ERTC_DT10
@ ERTC_DT10
Definition: at32f435_437_ertc.h:366
ERTC_DT9
@ ERTC_DT9
Definition: at32f435_437_ertc.h:365
ERTC_DT16
@ ERTC_DT16
Definition: at32f435_437_ertc.h:372
ERTC_DT12
@ ERTC_DT12
Definition: at32f435_437_ertc.h:368
ERTC_DT14
@ ERTC_DT14
Definition: at32f435_437_ertc.h:370
ERTC_AM
@ ERTC_AM
Definition: at32f435_437_ertc.h:126
ERTC_TP1F_FLAG
#define ERTC_TP1F_FLAG
Definition: at32f435_437_ertc.h:79
ERTC_TP_INT
#define ERTC_TP_INT
Definition: at32f435_437_ertc.h:52
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f435_437_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
EXINT_LINE_21
#define EXINT_LINE_21
Definition: at32f435_437_exint.h:73
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f435_437_pwc.c:61
TAMP_STAMP_IRQn
@ TAMP_STAMP_IRQn
Definition: at32f435_437.h:148
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • ertc
  • time_stamp
  • inc
project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • ertc
  • time_stamp
  • inc
project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • ertc
  • time_stamp
  • inc
project/at_start_f435/examples/ertc/time_stamp/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • ertc
  • time_stamp
  • src
Functions
project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • ertc
  • time_stamp
  • src
project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • ertc
  • time_stamp
  • src
Functions
project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void | ertc_time_show (void)
display the current date. More...
void | ertc_timestamp_show (void)
display the current timestamp. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TAMP_STAMP_IRQHandler (void)
this function handles external lines 15 to 10 interrupt request. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • ertc
  • time_stamp
  • src
project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29#include "at32f435_437_board.h"
30
39extern void ertc_time_show(void);
40extern void ertc_timestamp_show(void);
41
47void NMI_Handler(void)
48{
49}
50
56void HardFault_Handler(void)
57{
58 /* go to infinite loop when hard fault exception occurs */
59 while(1)
60 {
61 }
62}
63
69void MemManage_Handler(void)
70{
71 /* go to infinite loop when memory manage exception occurs */
72 while(1)
73 {
74 }
75}
76
82void BusFault_Handler(void)
83{
84 /* go to infinite loop when bus fault exception occurs */
85 while(1)
86 {
87 }
88}
89
95void UsageFault_Handler(void)
96{
97 /* go to infinite loop when usage fault exception occurs */
98 while(1)
99 {
100 }
101}
102
108void SVC_Handler(void)
109{
110}
111
117void DebugMon_Handler(void)
118{
119}
120
126void PendSV_Handler(void)
127{
128}
129
135void SysTick_Handler(void)
136{
137}
138
144void TAMP_STAMP_IRQHandler(void)
145{
146 if(ertc_flag_get(ERTC_TSF_FLAG))
147 {
148 /* display the timestamp */
149 ertc_timestamp_show();
150
151 /* display the date / time */
152 ertc_time_show();
153
154 /* clear exint flag */
155 exint_flag_clear(EXINT_LINE_21);
156
157 /* clear timestamp flag */
158 ertc_flag_clear(ERTC_TSF_FLAG);
159 }
160}
161
at32f435_437_board.h
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c:95
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c:56
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c:69
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c:108
TAMP_STAMP_IRQHandler
void TAMP_STAMP_IRQHandler(void)
this function handles external lines 15 to 10 interrupt request.
Definition: project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c:144
ertc_time_show
void ertc_time_show(void)
display the current date.
Definition: project/at_start_f435/examples/ertc/time_stamp/src/main.c:161
ertc_timestamp_show
void ertc_timestamp_show(void)
display the current timestamp.
Definition: project/at_start_f435/examples/ertc/time_stamp/src/main.c:183
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c:126
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c:47
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c:82
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c:135
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/ertc/time_stamp/src/at32f435_437_int.c:117
ertc_flag_get
flag_status ertc_flag_get(uint32_t flag)
get flag status.
Definition: at32f435_437_ertc.c:1474
ertc_flag_clear
void ertc_flag_clear(uint32_t flag)
clear flag status
Definition: at32f435_437_ertc.c:1507
ERTC_TSF_FLAG
#define ERTC_TSF_FLAG
Definition: at32f435_437_ertc.h:77
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
EXINT_LINE_21
#define EXINT_LINE_21
Definition: at32f435_437_exint.h:73
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • ertc
  • time_stamp
  • src
Functions
project/at_start_f435/examples/ertc/time_stamp/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | ertc_time_show (void)
display the current date. More...
void | ertc_timestamp_show (void)
display the current timestamp. More...
void | ertc_config (void)
configure the ertc peripheral by selecting the clock source. More...
void | ertc_timestamp_config (void)
configure the ertc timestamp. More...
int | main (void)
main program More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/time_stamp/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • ertc
  • time_stamp
  • src
project/at_start_f435/examples/ertc/time_stamp/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38void ertc_time_show(void);
39void ertc_timestamp_show(void);
40void ertc_config(void);
41void ertc_timestamp_config(void);
42
48int main(void)
49{
50 /* initial system clock */
51 system_clock_config();
52
53 /* initial the nvic priority group */
54 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
55
56 /* at board initial */
57 at32_board_init();
58
59 /* initialize uart */
60 uart_print_init(115200);
61
62 /* ertc configuration */
63 ertc_config();
64
65 /* configure the timestamp register */
66 ertc_timestamp_config();
67
68 /* display the date and time */
69 ertc_time_show();
70
71 while(1)
72 {
73
74 }
75}
76
82void ertc_config(void)
83{
84 /* enable the pwc clock */
85 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
86
87 /* allow access to ertc */
88 pwc_battery_powered_domain_access(TRUE);
89
90 /* reset ertc bpr domain */
91 crm_battery_powered_domain_reset(TRUE);
92 crm_battery_powered_domain_reset(FALSE);
93
94 /* enable the lext osc */
95 crm_clock_source_enable(CRM_CLOCK_SOURCE_LEXT, TRUE);
96
97 /* wait till lext is ready */
98 while(crm_flag_get(CRM_LEXT_STABLE_FLAG) == RESET)
99 {
100 }
101
102 /* select the ertc clock source */
103 crm_ertc_clock_select(CRM_ERTC_CLOCK_LEXT);
104
105 /* enable the ertc clock */
106 crm_ertc_clock_enable(TRUE);
107
108 /* deinitializes the ertc registers */
109 ertc_reset();
110
111 /* wait for ertc apb registers update */
112 ertc_wait_update();
113
114 /* configure the ertc divider */
115 /* ertc second(1hz) = ertc_clk / (div_a + 1) * (div_b + 1) */
116 ertc_divider_set(127, 255);
117
118 /* configure the ertc hour mode */
119 ertc_hour_mode_set(ERTC_HOUR_MODE_24);
120
121 /* set date: 2021-05-01 */
122 ertc_date_set(21, 5, 1, 5);
123
124 /* set time: 12:00:00 */
125 ertc_time_set(12, 0, 0, ERTC_AM);
126}
127
133void ertc_timestamp_config(void)
134{
135 exint_init_type exint_init_struct;
136
137 /* configure nvic */
138 nvic_irq_enable(TAMP_STAMP_IRQn, 0, 0);
139
140 /* configure exint */
141 exint_default_para_init(&exint_init_struct);
142 exint_init_struct.line_enable = TRUE;
143 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
144 exint_init_struct.line_select = EXINT_LINE_21;
145 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
146 exint_init(&exint_init_struct);
147
148 /* enable the timestamp */
149 ertc_timestamp_valid_edge_set(ERTC_TIMESTAMP_EDGE_FALLING);
150 ertc_timestamp_enable(TRUE);
151
152 /* enable the timestamp int */
153 ertc_interrupt_enable(ERTC_TS_INT, TRUE);
154}
155
161void ertc_time_show(void)
162{
163 ertc_time_type time;
164
165 /* get the current time */
166 ertc_calendar_get(&time);
167
168 /* display the curent time */
169 printf("current time: ");
170
171 /* display date format : year-month-day */
172 printf("%02d-%02d-%02d ",time.year, time.month, time.day);
173
174 /* display time format : hour:min:sec */
175 printf("%02d:%02d:%02d\r\n\r\n",time.hour, time.min, time.sec);
176}
177
183void ertc_timestamp_show(void)
184{
185 ertc_time_type time;
186
187 /* get the current timestamp */
188 ertc_timestamp_get(&time);
189
190 /* display the current timestamp */
191 printf("timestamp: ");
192
193 /* display date format : month-day */
194 printf(" %02d-%02d ", time.month, time.day);
195
196 /* display time format : hour:min:sec */
197 printf("%02d:%02d:%02d\r\n", time.hour, time.min, time.sec);
198}
199
at32f435_437_board.h
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:41
ertc_time_show
void ertc_time_show(void)
display the current time.
Definition: project/at_start_f435/examples/ertc/calendar/src/main.c:228
ertc_timestamp_show
void ertc_timestamp_show(void)
display the current timestamp.
Definition: project/at_start_f435/examples/ertc/time_stamp/src/main.c:183
ertc_timestamp_config
void ertc_timestamp_config(void)
configure the ertc timestamp.
Definition: project/at_start_f435/examples/ertc/time_stamp/src/main.c:133
main
int main(void)
main program
Definition: project/at_start_f435/examples/ertc/time_stamp/src/main.c:48
ertc_config
void ertc_config(void)
configure the ertc peripheral by selecting the clock source.
Definition: project/at_start_f435/examples/ertc/time_stamp/src/main.c:82
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_ertc_clock_select
void crm_ertc_clock_select(crm_ertc_clock_type value)
select ertc clock
Definition: at32f435_437_crm.c:434
crm_ertc_clock_enable
void crm_ertc_clock_enable(confirm_state new_state)
enable or disable ertc
Definition: at32f435_437_crm.c:445
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_battery_powered_domain_reset
void crm_battery_powered_domain_reset(confirm_state new_state)
battery powered domain software reset
Definition: at32f435_437_crm.c:541
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_CLOCK_SOURCE_LEXT
@ CRM_CLOCK_SOURCE_LEXT
Definition: at32f435_437_crm.h:562
CRM_ERTC_CLOCK_LEXT
@ CRM_ERTC_CLOCK_LEXT
Definition: at32f435_437_crm.h:632
CRM_LEXT_STABLE_FLAG
#define CRM_LEXT_STABLE_FLAG
Definition: at32f435_437_crm.h:58
ertc_hour_mode_set
error_status ertc_hour_mode_set(ertc_hour_mode_set_type mode)
ertc hour mode set.
Definition: at32f435_437_ertc.c:283
ertc_wait_update
error_status ertc_wait_update(void)
ertc wait register update finish.
Definition: at32f435_437_ertc.c:97
ertc_timestamp_valid_edge_set
void ertc_timestamp_valid_edge_set(ertc_timestamp_valid_edge_type edge)
set the timestamp valid edge.
Definition: at32f435_437_ertc.c:1135
ertc_time_set
error_status ertc_time_set(uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
set time.
Definition: at32f435_437_ertc.c:363
ertc_reset
error_status ertc_reset(void)
ertc reset all register.
Definition: at32f435_437_ertc.c:207
ertc_interrupt_enable
void ertc_interrupt_enable(uint32_t source, confirm_state new_state)
enable or disable interrupt.
Definition: at32f435_437_ertc.c:1386
ertc_date_set
error_status ertc_date_set(uint8_t year, uint8_t month, uint8_t date, uint8_t week)
set date.
Definition: at32f435_437_ertc.c:314
ertc_timestamp_get
void ertc_timestamp_get(ertc_time_type *time)
get the timestamp.
Definition: at32f435_437_ertc.c:1168
ertc_timestamp_enable
void ertc_timestamp_enable(confirm_state new_state)
enable or disable timestamp.
Definition: at32f435_437_ertc.c:1151
ertc_calendar_get
void ertc_calendar_get(ertc_time_type *time)
get calendar
Definition: at32f435_437_ertc.c:404
ertc_divider_set
error_status ertc_divider_set(uint16_t div_a, uint16_t div_b)
ertc division set.
Definition: at32f435_437_ertc.c:251
ERTC_HOUR_MODE_24
@ ERTC_HOUR_MODE_24
Definition: at32f435_437_ertc.h:116
ERTC_TIMESTAMP_EDGE_FALLING
@ ERTC_TIMESTAMP_EDGE_FALLING
Definition: at32f435_437_ertc.h:292
ERTC_AM
@ ERTC_AM
Definition: at32f435_437_ertc.h:126
ERTC_TS_INT
#define ERTC_TS_INT
Definition: at32f435_437_ertc.h:56
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f435_437_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
EXINT_LINE_21
#define EXINT_LINE_21
Definition: at32f435_437_exint.h:73
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
time
ertc_time_type * time
Definition: random.c:41
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f435_437_pwc.c:61
TAMP_STAMP_IRQn
@ TAMP_STAMP_IRQn
Definition: at32f435_437.h:148
ertc_time_type
ertc time
Definition: at32f435_437_ertc.h:383
ertc_time_type::year
uint8_t year
Definition: at32f435_437_ertc.h:384
ertc_time_type::day
uint8_t day
Definition: at32f435_437_ertc.h:386
ertc_time_type::hour
uint8_t hour
Definition: at32f435_437_ertc.h:387
ertc_time_type::min
uint8_t min
Definition: at32f435_437_ertc.h:388
ertc_time_type::month
uint8_t month
Definition: at32f435_437_ertc.h:385
ertc_time_type::sec
uint8_t sec
Definition: at32f435_437_ertc.h:389
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • ertc
  • wakeup_timer
  • inc
project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • ertc
  • wakeup_timer
  • inc
project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • ertc
  • wakeup_timer
  • inc
project/at_start_f435/examples/ertc/wakeup_timer/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • ertc
  • wakeup_timer
  • src
Functions
project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • ertc
  • wakeup_timer
  • src
project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • ertc
  • wakeup_timer
  • src
Functions
project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void | ertc_wakeup_show (void)
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ERTC_WKUP_IRQHandler (void)
this function handles ertc wakeup timer interrupt request. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • ertc
  • wakeup_timer
  • src
project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29#include "at32f435_437_board.h"
30
39extern void ertc_wakeup_show(void);
40
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
143void ERTC_WKUP_IRQHandler(void)
144{
145 if(ertc_flag_get(ERTC_WATF_FLAG) != RESET)
146 {
147 printf("wakeup\r\n");
148
149 at32_led_on(LED2);
150
151 /* clear wakeup timer flag */
152 ertc_flag_clear(ERTC_WATF_FLAG);
153
154 /* clear exint flag */
155 exint_flag_clear(EXINT_LINE_22);
156 }
157}
158
at32f435_437_board.h
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c:94
ertc_wakeup_show
void ertc_wakeup_show(void)
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c:107
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c:46
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c:81
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c:134
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c:116
ERTC_WKUP_IRQHandler
void ERTC_WKUP_IRQHandler(void)
this function handles ertc wakeup timer interrupt request.
Definition: project/at_start_f435/examples/ertc/wakeup_timer/src/at32f435_437_int.c:143
LED2
@ LED2
Definition: at32f435_437_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
ertc_flag_get
flag_status ertc_flag_get(uint32_t flag)
get flag status.
Definition: at32f435_437_ertc.c:1474
ertc_flag_clear
void ertc_flag_clear(uint32_t flag)
clear flag status
Definition: at32f435_437_ertc.c:1507
ERTC_WATF_FLAG
#define ERTC_WATF_FLAG
Definition: at32f435_437_ertc.h:76
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
EXINT_LINE_22
#define EXINT_LINE_22
Definition: at32f435_437_exint.h:74
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • ertc
  • wakeup_timer
  • src
Functions
project/at_start_f435/examples/ertc/wakeup_timer/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | ertc_config (void)
configure the ertc peripheral by selecting the clock source. More...
void | wakeup_timer_config (void)
configure the ertc peripheral by selecting the clock source. More...
int | main (void)
main program More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/ertc/wakeup_timer/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • ertc
  • wakeup_timer
  • src
project/at_start_f435/examples/ertc/wakeup_timer/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38void ertc_config(void);
39void wakeup_timer_config(void);
40
46int main(void)
47{
48 ertc_time_type time;
49 uint32_t temp = 0;
50
51 /* initial system clock */
52 system_clock_config();
53
54 /* initial the nvic priority group */
55 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
56
57 /* at board initial */
58 at32_board_init();
59
60 /* initialize uart */
61 uart_print_init(115200);
62
63 /* ertc configuration */
64 ertc_config();
65
66 /* ertc wakeup timer configuration */
67 wakeup_timer_config();
68
69 while(1)
70 {
71 /* get the current time */
72 ertc_calendar_get(&time);
73
74 if(temp != time.sec)
75 {
76 temp = time.sec;
77
78 /* display date format : year-month-day */
79 printf("%02d-%02d-%02d ",time.year, time.month, time.day);
80
81 /* display time format : hour:min:sec */
82 printf("%02d:%02d:%02d\r\n",time.hour, time.min, time.sec);
83 }
84 }
85}
86
92void ertc_config(void)
93{
94 /* enable the pwc clock interface */
95 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
96
97 /* allow access to ertc */
98 pwc_battery_powered_domain_access(TRUE);
99
100 /* reset ertc domain */
101 crm_battery_powered_domain_reset(TRUE);
102 crm_battery_powered_domain_reset(FALSE);
103
104 /* enable the lext osc */
105 crm_clock_source_enable(CRM_CLOCK_SOURCE_LEXT, TRUE);
106
107 /* wait till lext is ready */
108 while(crm_flag_get(CRM_LEXT_STABLE_FLAG) == RESET)
109 {
110 }
111
112 /* select the ertc clock source */
113 crm_ertc_clock_select(CRM_ERTC_CLOCK_LEXT);
114
115 /* enable the ertc clock */
116 crm_ertc_clock_enable(TRUE);
117
118 /* deinitializes the ertc registers */
119 ertc_reset();
120
121 /* wait for ertc apb registers update */
122 ertc_wait_update();
123
124 /* configure the ertc divider */
125 /* ertc second(1hz) = ertc_clk / (div_a + 1) * (div_b + 1) */
126 ertc_divider_set(127, 255);
127
128 /* configure the ertc hour mode */
129 ertc_hour_mode_set(ERTC_HOUR_MODE_24);
130
131 /* set date: 2021-05-01 */
132 ertc_date_set(21, 5, 1, 5);
133
134 /* set time: 12:00:00 */
135 ertc_time_set(12, 0, 0, ERTC_AM);
136}
137
138
144void wakeup_timer_config(void)
145{
146 exint_init_type exint_init_struct;
147
148 /* select the wakeup timer clock source */
149 ertc_wakeup_clock_set(ERTC_WAT_CLK_CK_B_16BITS);
150
151 /* set wakeup time: 5s */
152 ertc_wakeup_counter_set(5 - 1);
153
154 /* enable ertc wakeup timer interrupt */
155 ertc_interrupt_enable(ERTC_WAT_INT, TRUE);
156
157 /* enable the wakeup timer */
158 ertc_wakeup_enable(TRUE);
159
160 /* ertc wakeup timer interrupt configuration */
161 /* exint configuration */
162 exint_default_para_init(&exint_init_struct);
163 exint_init_struct.line_enable = TRUE;
164 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
165 exint_init_struct.line_select = EXINT_LINE_22;
166 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
167 exint_init(&exint_init_struct);
168
169 /* enable the ertc interrupt */
170 nvic_irq_enable(ERTC_WKUP_IRQn, 0, 1);
171}
172
at32f435_437_board.h
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:41
wakeup_timer_config
void wakeup_timer_config(void)
configure the ertc peripheral by selecting the clock source.
Definition: project/at_start_f435/examples/ertc/wakeup_timer/src/main.c:144
main
int main(void)
main program
Definition: project/at_start_f435/examples/ertc/wakeup_timer/src/main.c:46
ertc_config
void ertc_config(void)
configure the ertc peripheral by selecting the clock source.
Definition: project/at_start_f435/examples/ertc/wakeup_timer/src/main.c:92
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_ertc_clock_select
void crm_ertc_clock_select(crm_ertc_clock_type value)
select ertc clock
Definition: at32f435_437_crm.c:434
crm_ertc_clock_enable
void crm_ertc_clock_enable(confirm_state new_state)
enable or disable ertc
Definition: at32f435_437_crm.c:445
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_battery_powered_domain_reset
void crm_battery_powered_domain_reset(confirm_state new_state)
battery powered domain software reset
Definition: at32f435_437_crm.c:541
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_CLOCK_SOURCE_LEXT
@ CRM_CLOCK_SOURCE_LEXT
Definition: at32f435_437_crm.h:562
CRM_ERTC_CLOCK_LEXT
@ CRM_ERTC_CLOCK_LEXT
Definition: at32f435_437_crm.h:632
CRM_LEXT_STABLE_FLAG
#define CRM_LEXT_STABLE_FLAG
Definition: at32f435_437_crm.h:58
ertc_hour_mode_set
error_status ertc_hour_mode_set(ertc_hour_mode_set_type mode)
ertc hour mode set.
Definition: at32f435_437_ertc.c:283
ertc_wakeup_clock_set
void ertc_wakeup_clock_set(ertc_wakeup_clock_type clock)
set wakeup timer clock.
Definition: at32f435_437_ertc.c:731
ertc_wait_update
error_status ertc_wait_update(void)
ertc wait register update finish.
Definition: at32f435_437_ertc.c:97
ertc_wakeup_counter_set
void ertc_wakeup_counter_set(uint32_t counter)
set wakeup counter.
Definition: at32f435_437_ertc.c:747
ertc_time_set
error_status ertc_time_set(uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
set time.
Definition: at32f435_437_ertc.c:363
ertc_reset
error_status ertc_reset(void)
ertc reset all register.
Definition: at32f435_437_ertc.c:207
ertc_interrupt_enable
void ertc_interrupt_enable(uint32_t source, confirm_state new_state)
enable or disable interrupt.
Definition: at32f435_437_ertc.c:1386
ertc_wakeup_enable
error_status ertc_wakeup_enable(confirm_state new_state)
enable or disable wakeup timer.
Definition: at32f435_437_ertc.c:773
ertc_date_set
error_status ertc_date_set(uint8_t year, uint8_t month, uint8_t date, uint8_t week)
set date.
Definition: at32f435_437_ertc.c:314
ertc_calendar_get
void ertc_calendar_get(ertc_time_type *time)
get calendar
Definition: at32f435_437_ertc.c:404
ertc_divider_set
error_status ertc_divider_set(uint16_t div_a, uint16_t div_b)
ertc division set.
Definition: at32f435_437_ertc.c:251
ERTC_HOUR_MODE_24
@ ERTC_HOUR_MODE_24
Definition: at32f435_437_ertc.h:116
ERTC_WAT_CLK_CK_B_16BITS
@ ERTC_WAT_CLK_CK_B_16BITS
Definition: at32f435_437_ertc.h:180
ERTC_AM
@ ERTC_AM
Definition: at32f435_437_ertc.h:126
ERTC_WAT_INT
#define ERTC_WAT_INT
Definition: at32f435_437_ertc.h:55
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f435_437_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
EXINT_LINE_22
#define EXINT_LINE_22
Definition: at32f435_437_exint.h:74
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
time
ertc_time_type * time
Definition: random.c:41
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f435_437_pwc.c:61
ERTC_WKUP_IRQn
@ ERTC_WKUP_IRQn
Definition: at32f435_437.h:149
ertc_time_type
ertc time
Definition: at32f435_437_ertc.h:383
ertc_time_type::year
uint8_t year
Definition: at32f435_437_ertc.h:384
ertc_time_type::day
uint8_t day
Definition: at32f435_437_ertc.h:386
ertc_time_type::hour
uint8_t hour
Definition: at32f435_437_ertc.h:387
ertc_time_type::min
uint8_t min
Definition: at32f435_437_ertc.h:388
ertc_time_type::month
uint8_t month
Definition: at32f435_437_ertc.h:385
ertc_time_type::sec
uint8_t sec
Definition: at32f435_437_ertc.h:389
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • exint
  • exint_config
  • inc
project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • exint
  • exint_config
  • inc
project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • exint
  • exint_config
  • inc
project/at_start_f435/examples/exint/exint_config/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • exint
  • exint_config
  • src
Functions
project/at_start_f435/examples/exint/exint_config/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/exint/exint_config/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • exint
  • exint_config
  • src
project/at_start_f435/examples/exint/exint_config/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/exint/exint_config/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • exint
  • exint_config
  • src
Functions
project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • exint
  • exint_config
  • src
project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/exint/exint_config/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • exint
  • exint_config
  • src
Functions
project/at_start_f435/examples/exint/exint_config/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | exint_line0_config (void)
exint line0 config. configure pa0 in interrupt mode More...
void | EXINT0_IRQHandler (void)
exint0 interrupt handler More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/exint/exint_config/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • exint
  • exint_config
  • src
project/at_start_f435/examples/exint/exint_config/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38void exint_line0_config(void);
39
45void exint_line0_config(void)
46{
47 exint_init_type exint_init_struct;
48
49 crm_periph_clock_enable(CRM_SCFG_PERIPH_CLOCK, TRUE);
50 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
51
52 scfg_exint_line_config(SCFG_PORT_SOURCE_GPIOA, SCFG_PINS_SOURCE0);
53
54 exint_default_para_init(&exint_init_struct);
55 exint_init_struct.line_enable = TRUE;
56 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
57 exint_init_struct.line_select = EXINT_LINE_0;
58 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
59 exint_init(&exint_init_struct);
60
61 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
62 nvic_irq_enable(EXINT0_IRQn, 1, 0);
63}
64
70void EXINT0_IRQHandler(void)
71{
72 if(exint_flag_get(EXINT_LINE_0) != RESET)
73 {
74 at32_led_toggle(LED2);
75 at32_led_toggle(LED3);
76 at32_led_toggle(LED4);
77 exint_flag_clear(EXINT_LINE_0);
78 }
79}
80
86int main(void)
87{
88 system_clock_config();
89
90 at32_board_init();
91
92 /* turn led2/led3/led4 on */
93 at32_led_on(LED2);
94 at32_led_on(LED3);
95 at32_led_on(LED4);
96
97 /* configure pa0 in interrupt mode */
98 exint_line0_config();
99
100 while(1)
101 {
102 }
103}
104
at32f435_437_board.h
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:41
main
int main(void)
main function.
Definition: project/at_start_f435/examples/exint/exint_config/src/main.c:86
EXINT0_IRQHandler
void EXINT0_IRQHandler(void)
exint0 interrupt handler
Definition: project/at_start_f435/examples/exint/exint_config/src/main.c:70
exint_line0_config
void exint_line0_config(void)
exint line0 config. configure pa0 in interrupt mode
Definition: project/at_start_f435/examples/exint/exint_config/src/main.c:45
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_SCFG_PERIPH_CLOCK
@ CRM_SCFG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:163
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
exint_flag_get
flag_status exint_flag_get(uint32_t exint_line)
get exint flag
Definition: at32f435_437_exint.c:142
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f435_437_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
EXINT_LINE_0
#define EXINT_LINE_0
Definition: at32f435_437_exint.h:52
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
scfg_exint_line_config
void scfg_exint_line_config(scfg_port_source_type port_source, scfg_pins_source_type pin_source)
select the gpio pin used as exint line.
Definition: at32f435_437_scfg.c:152
SCFG_PINS_SOURCE0
@ SCFG_PINS_SOURCE0
Definition: at32f435_437_scfg.h:101
SCFG_PORT_SOURCE_GPIOA
@ SCFG_PORT_SOURCE_GPIOA
Definition: at32f435_437_scfg.h:124
EXINT0_IRQn
@ EXINT0_IRQn
Definition: at32f435_437.h:152
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • exint
  • exint_software_trigger
  • inc
project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • exint
  • exint_software_trigger
  • inc
project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • exint
  • exint_software_trigger
  • inc
project/at_start_f435/examples/exint/exint_software_trigger/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • exint
  • exint_software_trigger
  • src
Functions
project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • exint
  • exint_software_trigger
  • src
project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • exint
  • exint_software_trigger
  • src
Functions
project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • exint
  • exint_software_trigger
  • src
project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/exint/exint_software_trigger/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • exint
  • exint_software_trigger
  • src
Functions
project/at_start_f435/examples/exint/exint_software_trigger/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | exint_line4_config (void)
exint line4 config. configure pa0 in interrupt mode More...
static void | tmr1_config (void)
tmr1 configuration. More...
void | TMR1_OVF_TMR10_IRQHandler (void)
tmr1 interrupt handler More...
void | EXINT4_IRQHandler (void)
exint4 interrupt handler More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/exint/exint_software_trigger/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • exint
  • exint_software_trigger
  • src
project/at_start_f435/examples/exint/exint_software_trigger/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38void exint_line4_config(void);
39static void tmr1_config(void);
40
46void exint_line4_config(void)
47{
48 exint_init_type exint_init_struct;
49
50 crm_periph_clock_enable(CRM_SCFG_PERIPH_CLOCK, TRUE);
51
52 exint_default_para_init(&exint_init_struct);
53 exint_init_struct.line_enable = TRUE;
54 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
55 exint_init_struct.line_select = EXINT_LINE_4;
56 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
57 exint_init(&exint_init_struct);
58 exint_flag_clear(EXINT_LINE_4);
59 nvic_irq_enable(EXINT4_IRQn, 1, 0);
60}
61
67static void tmr1_config(void)
68{
69 crm_clocks_freq_type crm_clocks_freq_struct = {0};
70
71 /* get system clock */
72 crm_clocks_freq_get(&crm_clocks_freq_struct);
73
74 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
75
76 /* (systemclock / (system_core_clock/10000)) / 10000 = 1Hz(1s) */
77 tmr_base_init(TMR1, 10000-1, system_core_clock/10000-1);
78 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
79 tmr_clock_source_div_set(TMR1, TMR_CLOCK_DIV1);
80 tmr_interrupt_enable(TMR1, TMR_OVF_INT, TRUE);
81 nvic_irq_enable(TMR1_OVF_TMR10_IRQn, 0, 0);
82}
83
89void TMR1_OVF_TMR10_IRQHandler(void)
90{
91 if(tmr_flag_get(TMR1,TMR_OVF_FLAG) != RESET)
92 {
93 at32_led_toggle(LED2);
94 exint_software_interrupt_event_generate(EXINT_LINE_4);
95 tmr_flag_clear(TMR1,TMR_OVF_FLAG);
96 }
97}
98
104void EXINT4_IRQHandler(void)
105{
106 if(exint_flag_get(EXINT_LINE_4) != RESET)
107 {
108 at32_led_toggle(LED3);
109 at32_led_toggle(LED4);
110 exint_flag_clear(EXINT_LINE_4);
111 }
112}
113
119int main(void)
120{
121 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
122 system_clock_config();
123
124 at32_board_init();
125
126 /* turn led2/led3/led4 on */
127 at32_led_on(LED2);
128 at32_led_on(LED3);
129 at32_led_on(LED4);
130 tmr1_config();
131 exint_line4_config();
132 tmr_counter_enable(TMR1, TRUE);
133 while(1)
134 {
135 }
136}
137
at32f435_437_board.h
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:40
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:41
exint_line4_config
void exint_line4_config(void)
exint line4 config. configure pa0 in interrupt mode
Definition: project/at_start_f435/examples/exint/exint_software_trigger/src/main.c:46
main
int main(void)
main function.
Definition: project/at_start_f435/examples/exint/exint_software_trigger/src/main.c:119
tmr1_config
static void tmr1_config(void)
tmr1 configuration.
Definition: project/at_start_f435/examples/exint/exint_software_trigger/src/main.c:67
EXINT4_IRQHandler
void EXINT4_IRQHandler(void)
exint4 interrupt handler
Definition: project/at_start_f435/examples/exint/exint_software_trigger/src/main.c:104
TMR1_OVF_TMR10_IRQHandler
void TMR1_OVF_TMR10_IRQHandler(void)
tmr1 interrupt handler
Definition: project/at_start_f435/examples/exint/exint_software_trigger/src/main.c:89
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
system_core_clock
unsigned int system_core_clock
Definition: system_at32f435_437.c:48
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_SCFG_PERIPH_CLOCK
@ CRM_SCFG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:163
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:154
exint_flag_get
flag_status exint_flag_get(uint32_t exint_line)
get exint flag
Definition: at32f435_437_exint.c:142
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f435_437_exint.c:64
exint_software_interrupt_event_generate
void exint_software_interrupt_event_generate(uint32_t exint_line)
generate exint software interrupt event
Definition: at32f435_437_exint.c:169
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
EXINT_LINE_4
#define EXINT_LINE_4
Definition: at32f435_437_exint.h:56
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f435_437_tmr.c:1463
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f435_437_tmr.c:1424
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f435_437_tmr.c:1389
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f435_437_tmr.h:97
TMR_OVF_FLAG
#define TMR_OVF_FLAG
Definition: at32f435_437_tmr.h:52
TMR_OVF_INT
#define TMR_OVF_INT
Definition: at32f435_437_tmr.h:75
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
TMR1_OVF_TMR10_IRQn
@ TMR1_OVF_TMR10_IRQn
Definition: at32f435_437.h:173
EXINT4_IRQn
@ EXINT4_IRQn
Definition: at32f435_437.h:156
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • flash
  • fap_enable
  • inc
project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • flash
  • fap_enable
  • inc
project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • flash
  • fap_enable
  • inc
project/at_start_f435/examples/flash/fap_enable/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • flash
  • fap_enable
  • src
Functions
project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • flash
  • fap_enable
  • src
project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • flash
  • fap_enable
  • src
Functions
project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • flash
  • fap_enable
  • src
project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/flash/fap_enable/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • flash
  • fap_enable
  • src
Functions
project/at_start_f435/examples/flash/fap_enable/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/flash/fap_enable/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • flash
  • fap_enable
  • src
project/at_start_f435/examples/flash/fap_enable/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
43int main(void)
44{
45 flash_status_type status = FLASH_OPERATE_DONE;
46 system_clock_config();
47 at32_board_init();
48 if(flash_fap_status_get() == RESET)
49 {
50 flash_unlock();
51 /* wait for operation to be completed */
52 status = flash_operation_wait_for(OPERATION_TIMEOUT);
53
54 if(status != FLASH_OPERATE_TIMEOUT)
55 {
56 if((status == FLASH_PROGRAM_ERROR) || (status == FLASH_EPP_ERROR))
57 flash_flag_clear(FLASH_PRGMERR_FLAG | FLASH_EPPERR_FLAG);
58
59 status = flash_fap_enable(TRUE);
60 if(status == FLASH_OPERATE_DONE)
61 nvic_system_reset();
62 }
63 }else
64 {
65 at32_led_on(LED2);
66 at32_led_on(LED3);
67 at32_led_on(LED4);
68 }
69 while(1)
70 {
71 }
72}
73
74
at32f435_437_board.h
main
int main(void)
main function.
Definition: project/at_start_f435/examples/flash/fap_enable/src/main.c:43
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
OPERATION_TIMEOUT
#define OPERATION_TIMEOUT
Definition: at32f435_437_flash.h:151
FLASH_PRGMERR_FLAG
#define FLASH_PRGMERR_FLAG
Definition: at32f435_437_flash.h:81
FLASH_EPPERR_FLAG
#define FLASH_EPPERR_FLAG
Definition: at32f435_437_flash.h:82
flash_fap_status_get
flag_status flash_fap_status_get(void)
check the flash access protection status.
Definition: at32f435_437_flash.c:895
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f435_437_flash.c:290
flash_fap_enable
flash_status_type flash_fap_enable(confirm_state new_state)
enable or disable the flash access protection.
Definition: at32f435_437_flash.c:848
flash_operation_wait_for
flash_status_type flash_operation_wait_for(uint32_t time_out)
wait for flash operation complete or timeout.
Definition: at32f435_437_flash.c:216
flash_flag_clear
void flash_flag_clear(uint32_t flash_flag)
clear the flash flag.
Definition: at32f435_437_flash.c:105
flash_status_type
flash_status_type
flash status type
Definition: at32f435_437_flash.h:199
FLASH_OPERATE_DONE
@ FLASH_OPERATE_DONE
Definition: at32f435_437_flash.h:203
FLASH_OPERATE_TIMEOUT
@ FLASH_OPERATE_TIMEOUT
Definition: at32f435_437_flash.h:204
FLASH_PROGRAM_ERROR
@ FLASH_PROGRAM_ERROR
Definition: at32f435_437_flash.h:201
FLASH_EPP_ERROR
@ FLASH_EPP_ERROR
Definition: at32f435_437_flash.h:202
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f435_437_misc.c:52
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • flash
  • flash_write_read
  • inc
project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • flash
  • flash_write_read
  • inc
project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • flash
  • flash_write_read
  • inc
project/at_start_f435/examples/flash/flash_write_read/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: flash.h File Reference

  • at_start_f435
  • examples
  • flash
  • flash_write_read
  • inc
Functions
project/at_start_f435/examples/flash/flash_write_read/inc/flash.h File Reference

flash header file More...

#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void | flash_read (uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read)
read data using halfword mode More...
error_status | flash_write_nocheck (uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode without checking More...
error_status | flash_write (uint32_t write_addr, uint16_t *p_Buffer, uint16_t num_write)
write data using halfword mode with checking More...

Detailed Description

flash header file

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/flash/flash_write_read/inc/flash.h.


AT32F435/437 Firmwary Library: flash.h Source File

  • at_start_f435
  • examples
  • flash
  • flash_write_read
  • inc
project/at_start_f435/examples/flash/flash_write_read/inc/flash.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __FLASH_H__
29#define __FLASH_H__
30
31#include "at32f435_437_board.h"
32
46void flash_read(uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read);
47 error_status flash_write_nocheck(uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write);
48 error_status flash_write(uint32_t write_addr,uint16_t *p_Buffer, uint16_t num_write);
49
63#endif
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
at32f435_437_board.h
error_status
error_status
Definition: at32f435_437.h:380
flash_write
error_status flash_write(uint32_t write_addr, uint16_t *p_Buffer, uint16_t num_write)
write data using halfword mode with checking
Definition: project/at_start_f437/examples/flash/flash_write_read/src/flash.c:87
flash_read
void flash_read(uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read)
read data using halfword mode
Definition: project/at_start_f437/examples/flash/flash_write_read/src/flash.c:49
flash_write_nocheck
error_status flash_write_nocheck(uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode without checking
Definition: project/at_start_f437/examples/flash/flash_write_read/src/flash.c:66


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • flash
  • flash_write_read
  • src
Functions
project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • flash
  • flash_write_read
  • src
project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • flash
  • flash_write_read
  • src
Functions
project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • flash
  • flash_write_read
  • src
project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/flash/flash_write_read/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: flash.c File Reference

  • at_start_f435
  • examples
  • flash
  • flash_write_read
  • src
Macros | Functions | Variables
project/at_start_f435/examples/flash/flash_write_read/src/flash.c File Reference

flash program More...

#include "at32f435_437_board.h"
#include "flash.h"

Go to the source code of this file.

Macros

#define SECTOR_SIZE 4096 /* this parameter depends on the specific model of the chip */

Functions

void | flash_read (uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read)
read data using halfword mode More...
error_status | flash_write_nocheck (uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode without checking More...
error_status | flash_write (uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode with checking More...

Variables

uint16_t flash_buf [4096/2]

Detailed Description

flash program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/flash/flash_write_read/src/flash.c.


AT32F435/437 Firmwary Library: flash.c Source File

  • at_start_f435
  • examples
  • flash
  • flash_write_read
  • src
project/at_start_f435/examples/flash/flash_write_read/src/flash.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "flash.h"
29
38#define SECTOR_SIZE 4096 /* this parameter depends on the specific model of the chip */
39
40uint16_t flash_buf[SECTOR_SIZE / 2];
41
49void flash_read(uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read)
50{
51 uint16_t i;
52 for(i = 0; i < num_read; i++)
53 {
54 p_buffer[i] = *(uint16_t*)(read_addr);
55 read_addr += 2;
56 }
57}
58
66 error_status flash_write_nocheck(uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
67{
68 uint16_t i;
69 flash_status_type status = FLASH_OPERATE_DONE;
70 for(i = 0; i < num_write; i++)
71 {
72 status = flash_halfword_program(write_addr, p_buffer[i]);
73 if(status != FLASH_OPERATE_DONE)
74 return ERROR;
75 write_addr += 2;
76 }
77 return SUCCESS;
78}
79
87 error_status flash_write(uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
88{
89 uint32_t offset_addr;
90 uint32_t sector_position;
91 uint16_t sector_offset;
92 uint16_t sector_remain;
93 uint16_t i;
94 flash_status_type status = FLASH_OPERATE_DONE;
95
96 flash_unlock();
97 offset_addr = write_addr - FLASH_BASE;
98 sector_position = offset_addr / SECTOR_SIZE;
99 sector_offset = (offset_addr % SECTOR_SIZE) / 2;
100 sector_remain = SECTOR_SIZE / 2 - sector_offset;
101 if(num_write <= sector_remain)
102 sector_remain = num_write;
103 while(1)
104 {
105 flash_read(sector_position * SECTOR_SIZE + FLASH_BASE, flash_buf, SECTOR_SIZE / 2);
106 for(i = 0; i < sector_remain; i++)
107 {
108 if(flash_buf[sector_offset + i] != 0xFFFF)
109 break;
110 }
111 if(i < sector_remain)
112 {
113 /* wait for operation to be completed */
114 status = flash_operation_wait_for(ERASE_TIMEOUT);
115
116 if((status == FLASH_PROGRAM_ERROR) || (status == FLASH_EPP_ERROR))
117 flash_flag_clear(FLASH_PRGMERR_FLAG | FLASH_EPPERR_FLAG);
118 else if(status == FLASH_OPERATE_TIMEOUT)
119 return ERROR;
120 status = flash_sector_erase(sector_position * SECTOR_SIZE + FLASH_BASE);
121 if(status != FLASH_OPERATE_DONE)
122 return ERROR;
123 for(i = 0; i < sector_remain; i++)
124 {
125 flash_buf[i + sector_offset] = p_buffer[i];
126 }
127 if(flash_write_nocheck(sector_position * SECTOR_SIZE + FLASH_BASE, flash_buf, SECTOR_SIZE / 2) != SUCCESS)
128 return ERROR;
129 }
130 else
131 {
132 if(flash_write_nocheck(write_addr, p_buffer, sector_remain) != SUCCESS)
133 return ERROR;
134 }
135 if(num_write == sector_remain)
136 break;
137 else
138 {
139 sector_position++;
140 sector_offset = 0;
141 p_buffer += sector_remain;
142 write_addr += (sector_remain * 2);
143 num_write -= sector_remain;
144 if(num_write > (SECTOR_SIZE / 2))
145 sector_remain = SECTOR_SIZE / 2;
146 else
147 sector_remain = num_write;
148 }
149 }
150 flash_lock();
151 return SUCCESS;
152}
153
154
155
at32f435_437_board.h
flash_write
error_status flash_write(uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode with checking
Definition: project/at_start_f435/examples/flash/flash_write_read/src/flash.c:87
SECTOR_SIZE
#define SECTOR_SIZE
Definition: project/at_start_f435/examples/flash/flash_write_read/src/flash.c:38
flash_read
void flash_read(uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read)
read data using halfword mode
Definition: project/at_start_f435/examples/flash/flash_write_read/src/flash.c:49
flash_buf
uint16_t flash_buf[4096/2]
Definition: project/at_start_f435/examples/flash/flash_write_read/src/flash.c:40
flash_write_nocheck
error_status flash_write_nocheck(uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode without checking
Definition: project/at_start_f435/examples/flash/flash_write_read/src/flash.c:66
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
ERASE_TIMEOUT
#define ERASE_TIMEOUT
flash timeout definition
Definition: at32f435_437_flash.h:149
FLASH_PRGMERR_FLAG
#define FLASH_PRGMERR_FLAG
Definition: at32f435_437_flash.h:81
FLASH_EPPERR_FLAG
#define FLASH_EPPERR_FLAG
Definition: at32f435_437_flash.h:82
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f435_437_flash.c:357
flash_halfword_program
flash_status_type flash_halfword_program(uint32_t address, uint16_t data)
program a halfword at a specified address.
Definition: at32f435_437_flash.c:643
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f435_437_flash.c:290
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f435_437_flash.c:325
flash_operation_wait_for
flash_status_type flash_operation_wait_for(uint32_t time_out)
wait for flash operation complete or timeout.
Definition: at32f435_437_flash.c:216
flash_flag_clear
void flash_flag_clear(uint32_t flash_flag)
clear the flash flag.
Definition: at32f435_437_flash.c:105
flash_status_type
flash_status_type
flash status type
Definition: at32f435_437_flash.h:199
FLASH_OPERATE_DONE
@ FLASH_OPERATE_DONE
Definition: at32f435_437_flash.h:203
FLASH_OPERATE_TIMEOUT
@ FLASH_OPERATE_TIMEOUT
Definition: at32f435_437_flash.h:204
FLASH_PROGRAM_ERROR
@ FLASH_PROGRAM_ERROR
Definition: at32f435_437_flash.h:201
FLASH_EPP_ERROR
@ FLASH_EPP_ERROR
Definition: at32f435_437_flash.h:202
FLASH_BASE
#define FLASH_BASE
Definition: at32f435_437.h:425


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • flash
  • flash_write_read
  • src
Macros | Functions | Variables
project/at_start_f435/examples/flash/flash_write_read/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include "flash.h"

Go to the source code of this file.

Macros

#define | TEST_BUFEER_SIZE 3000
#define | TEST_FLASH_ADDRESS_START (0x08000000 + 1024 * 10)

Functions

error_status | buffer_compare (uint16_t *p_buffer1, uint16_t *p_buffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint16_t | buffer_write [3000]
uint16_t | buffer_read [3000]

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/flash/flash_write_read/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • flash
  • flash_write_read
  • src
project/at_start_f435/examples/flash/flash_write_read/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include "flash.h"
30
39#define TEST_BUFEER_SIZE 3000
40#define TEST_FLASH_ADDRESS_START (0x08000000 + 1024 * 10)
41
42uint16_t buffer_write[TEST_BUFEER_SIZE];
43uint16_t buffer_read[TEST_BUFEER_SIZE];
44
45 error_status buffer_compare(uint16_t* p_buffer1, uint16_t* p_buffer2, uint16_t buffer_length);
46
54 error_status buffer_compare(uint16_t* p_buffer1, uint16_t* p_buffer2, uint16_t buffer_length)
55{
56 while(buffer_length--)
57 {
58 if(*p_buffer1 != *p_buffer2)
59 {
60 return ERROR;
61 }
62 p_buffer1++;
63 p_buffer2++;
64 }
65 return SUCCESS;
66}
67
73int main(void)
74{
75 uint32_t index=0;
76 error_status err_status;
77 system_clock_config();
78 at32_board_init();
79 /* fill buffer_write data to test */
80 for(index = 0; index < TEST_BUFEER_SIZE; index++)
81 {
82 buffer_write[index] = index;
83 }
84
85 /* write data to flash */
86 err_status = flash_write(TEST_FLASH_ADDRESS_START, buffer_write, TEST_BUFEER_SIZE);
87
88 /* read data from flash */
89 flash_read(TEST_FLASH_ADDRESS_START, buffer_read, TEST_BUFEER_SIZE);
90
91 /* compare the buffer */
92 if((buffer_compare(buffer_write, buffer_read, TEST_BUFEER_SIZE) == SUCCESS) && (err_status == SUCCESS))
93 {
94 at32_led_on(LED2);
95 at32_led_on(LED3);
96 at32_led_on(LED4);
97 }
98
99 while(1)
100 {
101 }
102}
103
104
at32f435_437_board.h
TEST_BUFEER_SIZE
#define TEST_BUFEER_SIZE
Definition: project/at_start_f435/examples/flash/flash_write_read/src/main.c:39
buffer_read
uint16_t buffer_read[3000]
Definition: project/at_start_f435/examples/flash/flash_write_read/src/main.c:43
TEST_FLASH_ADDRESS_START
#define TEST_FLASH_ADDRESS_START
Definition: project/at_start_f435/examples/flash/flash_write_read/src/main.c:40
buffer_compare
error_status buffer_compare(uint16_t *p_buffer1, uint16_t *p_buffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f435/examples/flash/flash_write_read/src/main.c:54
main
int main(void)
main function.
Definition: project/at_start_f435/examples/flash/flash_write_read/src/main.c:73
buffer_write
uint16_t buffer_write[3000]
Definition: project/at_start_f435/examples/flash/flash_write_read/src/main.c:42
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
flash_write
error_status flash_write(uint32_t write_addr, uint16_t *p_Buffer, uint16_t num_write)
write data using halfword mode with checking
Definition: project/at_start_f437/examples/flash/flash_write_read/src/flash.c:87
flash_read
void flash_read(uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read)
read data using halfword mode
Definition: project/at_start_f437/examples/flash/flash_write_read/src/flash.c:49
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • gpio
  • io_toggle
  • inc
project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • gpio
  • io_toggle
  • inc
project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • gpio
  • io_toggle
  • inc
project/at_start_f435/examples/gpio/io_toggle/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • gpio
  • io_toggle
  • src
Functions
project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • gpio
  • io_toggle
  • src
project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • gpio
  • io_toggle
  • src
Functions
project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • gpio
  • io_toggle
  • src
project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/gpio/io_toggle/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • gpio
  • io_toggle
  • src
Functions
project/at_start_f435/examples/gpio/io_toggle/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | gpio_config (void)
pa.01 gpio configuration. More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/gpio/io_toggle/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • gpio
  • io_toggle
  • src
project/at_start_f435/examples/gpio/io_toggle/src/main.c
Go to the documentation of this file.
1
27/* includes */
28#include "at32f435_437_board.h"
29#include "at32f435_437_clock.h"
30
44void gpio_config(void)
45{
46 gpio_init_type gpio_init_struct;
47
48 /* enable the gpioa clock */
49 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
50
51 /* set default parameter */
52 gpio_default_para_init(&gpio_init_struct);
53
54 /* configure the gpio */
55 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
56 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
57 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
58 gpio_init_struct.gpio_pins = GPIO_PINS_1;
59 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
60 gpio_init(GPIOA, &gpio_init_struct);
61}
62
68int main(void)
69{
70 system_clock_config();
71
72 gpio_config();
73
74 while(1)
75 {
76 /* set pa.01 */
77 GPIOA->scr = GPIO_PINS_1;
78 /* reset pa.01 */
79 GPIOA->clr = GPIO_PINS_1;
80
81 /* set pa.01 */
82 GPIOA->scr = GPIO_PINS_1;
83 /* reset pa.01 */
84 GPIOA->clr = GPIO_PINS_1;
85
86 /* set pa.01 */
87 GPIOA->scr = GPIO_PINS_1;
88 /* reset pa.01 */
89 GPIOA->clr = GPIO_PINS_1;
90
91 /* set pa.01 */
92 GPIOA->scr = GPIO_PINS_1;
93 /* reset pa.01 */
94 GPIOA->clr = GPIO_PINS_1;
95
96 /* set pa.01 */
97 GPIOA->scr = GPIO_PINS_1;
98 /* reset pa.01 */
99 GPIOA->clr = GPIO_PINS_1;
100
101 /* set pa.01 */
102 GPIOA->scr = GPIO_PINS_1;
103 /* reset pa.01 */
104 GPIOA->clr = GPIO_PINS_1;
105 }
106}
107
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f435/examples/gpio/io_toggle/src/main.c:68
gpio_config
void gpio_config(void)
pa.01 gpio configuration.
Definition: project/at_start_f435/examples/gpio/io_toggle/src/main.c:44
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • gpio
  • led_toggle
  • inc
project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • gpio
  • led_toggle
  • inc
project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • gpio
  • led_toggle
  • inc
project/at_start_f435/examples/gpio/led_toggle/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • gpio
  • led_toggle
  • src
Functions
project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • gpio
  • led_toggle
  • src
project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • gpio
  • led_toggle
  • src
Functions
project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • gpio
  • led_toggle
  • src
project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/gpio/led_toggle/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • gpio
  • led_toggle
  • src
Functions
project/at_start_f435/examples/gpio/led_toggle/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/gpio/led_toggle/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • gpio
  • led_toggle
  • src
project/at_start_f435/examples/gpio/led_toggle/src/main.c
Go to the documentation of this file.
1
27/* includes */
28#include "at32f435_437_board.h"
29#include "at32f435_437_clock.h"
30
44int main(void)
45{
46 system_clock_config();
47
48 at32_board_init();
49
50 while(1)
51 {
52 at32_led_toggle(LED2);
53 delay_ms(200);
54 at32_led_toggle(LED3);
55 delay_ms(200);
56 at32_led_toggle(LED4);
57 delay_ms(200);
58 }
59}
60
at32f435_437_board.h
main
int main(void)
main function.
Definition: project/at_start_f435/examples/gpio/led_toggle/src/main.c:44
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • gpio
  • swjtag_mux
  • inc
project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • gpio
  • swjtag_mux
  • inc
project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • gpio
  • swjtag_mux
  • inc
project/at_start_f435/examples/gpio/swjtag_mux/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • gpio
  • swjtag_mux
  • src
Functions
project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • gpio
  • swjtag_mux
  • src
project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • gpio
  • swjtag_mux
  • src
Functions
project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • gpio
  • swjtag_mux
  • src
project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/gpio/swjtag_mux/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • gpio
  • swjtag_mux
  • src
Functions
project/at_start_f435/examples/gpio/swjtag_mux/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | swj_dp_config (void)
configure the gpio of swj-dp. More...
void | gpio_pins_toggle (gpio_type *gpio_x, uint16_t gpio_pin)
toggles the specified gpio pin More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/gpio/swjtag_mux/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • gpio
  • swjtag_mux
  • src
project/at_start_f435/examples/gpio/swjtag_mux/src/main.c
Go to the documentation of this file.
1
27/* includes */
28#include "at32f435_437_board.h"
29#include "at32f435_437_clock.h"
30
39void swj_dp_config(void);
40void gpio_pins_toggle(gpio_type* gpio_x, uint16_t gpio_pin);
41
47void swj_dp_config(void)
48{
49 gpio_init_type gpio_init_struct;
50
51 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
52 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
53
54 gpio_default_para_init(&gpio_init_struct);
55
56 /* configure pa13 (jtms/swdat) as general output push-pull */
57 gpio_init_struct.gpio_pins = GPIO_PINS_13;
58 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
59 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
60 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
61 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
62 gpio_init(GPIOA, &gpio_init_struct);
63
64 /* configure pa14 (jtck/swclk) as mux usart2 tx */
65 gpio_init_struct.gpio_pins = GPIO_PINS_14;
66 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
67 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
68 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
69 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
70 gpio_init(GPIOA, &gpio_init_struct);
71 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE14, GPIO_MUX_8);
72
73 /* configure usart2 param */
74 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
75 usart_transmitter_enable(USART2, TRUE);
76 usart_enable(USART2, TRUE);
77}
78
85void gpio_pins_toggle(gpio_type* gpio_x, uint16_t gpio_pin)
86{
87 gpio_x->odt ^= gpio_pin;
88}
89
95int main(void)
96{
97 static uint8_t data = 0;
98 system_clock_config();
99 at32_board_init();
100 swj_dp_config();
101 while(1)
102 {
103 /* pa13 pin toggle */
104 gpio_pins_toggle(GPIOA, GPIO_PINS_13);
105 delay_ms(500);
106 /* pa14 pin send usart char */
107 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
108 usart_data_transmit(USART2, data++);
109 }
110}
111
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
gpio_pins_toggle
void gpio_pins_toggle(gpio_type *gpio_x, uint16_t gpio_pin)
toggles the specified gpio pin
Definition: project/at_start_f435/examples/gpio/swjtag_mux/src/main.c:85
main
int main(void)
main function.
Definition: project/at_start_f435/examples/gpio/swjtag_mux/src/main.c:95
swj_dp_config
void swj_dp_config(void)
configure the gpio of swj-dp.
Definition: project/at_start_f435/examples/gpio/swjtag_mux/src/main.c:47
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:140
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_8
@ GPIO_MUX_8
Definition: at32f435_437_gpio.h:164
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f435_437_gpio.h:64
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f435_437_usart.c:413
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f435_437_usart.c:598
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f435_437_usart.c:209
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f435_437_usart.c:115
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f435_437_usart.c:196
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f435_437_usart.h:159
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f435_437_usart.h:114
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f435_437_usart.h:59
USART2
#define USART2
Definition: at32f435_437_usart.h:349
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
gpio_type
type define gpio register all
Definition: at32f435_437_gpio.h:178
gpio_type::odt
__IO uint32_t odt
Definition: at32f435_437_gpio.h:321
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • i2c
  • communication_dma
  • inc
project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • i2c
  • communication_dma
  • inc
project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • i2c
  • communication_dma
  • inc
project/at_start_f435/examples/i2c/communication_dma/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • i2c
  • communication_dma
  • src
Functions
project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • i2c
  • communication_dma
  • src
project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • i2c
  • communication_dma
  • src
Macros | Functions | Variables
project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"
#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | I2Cx_DMA_TX_IRQHandler DMA1_Channel1_IRQHandler
#define | I2Cx_DMA_RX_IRQHandler DMA1_Channel2_IRQHandler
#define | I2Cx_EVT_IRQHandler I2C1_EVT_IRQHandler
#define | I2Cx_ERR_IRQHandler I2C1_ERR_IRQHandler

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel2_IRQHandler (void)
this function handles dma interrupt request. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma interrupt request. More...
void | I2C1_EVT_IRQHandler (void)
this function handles i2c event interrupt request. More...
void | I2C1_ERR_IRQHandler (void)
this function handles i2c error interrupt request. More...

Variables

i2c_handle_type hi2cx

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • i2c
  • communication_dma
  • src
project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29#include "i2c_application.h"
30
39extern i2c_handle_type hi2cx;
40
41#define I2Cx_DMA_TX_IRQHandler DMA1_Channel1_IRQHandler
42#define I2Cx_DMA_RX_IRQHandler DMA1_Channel2_IRQHandler
43#define I2Cx_EVT_IRQHandler I2C1_EVT_IRQHandler
44#define I2Cx_ERR_IRQHandler I2C1_ERR_IRQHandler
45
51void NMI_Handler(void)
52{
53}
54
60void HardFault_Handler(void)
61{
62 /* go to infinite loop when hard fault exception occurs */
63 while(1)
64 {
65 }
66}
67
73void MemManage_Handler(void)
74{
75 /* go to infinite loop when memory manage exception occurs */
76 while(1)
77 {
78 }
79}
80
86void BusFault_Handler(void)
87{
88 /* go to infinite loop when bus fault exception occurs */
89 while(1)
90 {
91 }
92}
93
99void UsageFault_Handler(void)
100{
101 /* go to infinite loop when usage fault exception occurs */
102 while(1)
103 {
104 }
105}
106
112void SVC_Handler(void)
113{
114}
115
121void DebugMon_Handler(void)
122{
123}
124
130void PendSV_Handler(void)
131{
132}
133
139void SysTick_Handler(void)
140{
141}
142
143
149void I2Cx_DMA_RX_IRQHandler(void)
150{
151 i2c_dma_rx_irq_handler(&hi2cx);
152}
153
159void I2Cx_DMA_TX_IRQHandler(void)
160{
161 i2c_dma_tx_irq_handler(&hi2cx);
162}
163
169void I2Cx_EVT_IRQHandler(void)
170{
171 i2c_evt_irq_handler(&hi2cx);
172}
173
179void I2Cx_ERR_IRQHandler(void)
180{
181 i2c_err_irq_handler(&hi2cx);
182}
183
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c:99
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c:60
I2Cx_EVT_IRQHandler
#define I2Cx_EVT_IRQHandler
Definition: project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c:43
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c:73
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c:112
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c:130
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c:51
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c:86
hi2cx
i2c_handle_type hi2cx
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:37
I2Cx_ERR_IRQHandler
#define I2Cx_ERR_IRQHandler
Definition: project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c:44
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c:139
I2Cx_DMA_TX_IRQHandler
#define I2Cx_DMA_TX_IRQHandler
Definition: project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c:41
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c:121
I2Cx_DMA_RX_IRQHandler
#define I2Cx_DMA_RX_IRQHandler
Definition: project/at_start_f435/examples/i2c/communication_dma/src/at32f435_437_int.c:42
i2c_evt_irq_handler
void i2c_evt_irq_handler(i2c_handle_type *hi2c)
interrupt procession function.
Definition: i2c_application.c:2140
i2c_err_irq_handler
void i2c_err_irq_handler(i2c_handle_type *hi2c)
dma reveive complete interrupt function.
Definition: i2c_application.c:2174
i2c_dma_rx_irq_handler
void i2c_dma_rx_irq_handler(i2c_handle_type *hi2c)
dma reveive complete interrupt function.
Definition: i2c_application.c:2130
i2c_dma_tx_irq_handler
void i2c_dma_tx_irq_handler(i2c_handle_type *hi2c)
dma transmission complete interrupt function.
Definition: i2c_application.c:2120
i2c_application.h
i2c application libray header file
i2c_handle_type
Definition: i2c_application.h:112
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • i2c
  • communication_dma
  • src
Macros | Functions | Variables
project/at_start_f435/examples/i2c/communication_dma/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0xFFFFFFF
#define | I2Cx_CLKCTRL 0x80504C4E
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_DMA DMA1
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_MUX GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_MUX GPIO_MUX_4
#define | I2Cx_DMA_TX_Channel DMA1_CHANNEL1
#define | I2Cx_DMA_TX_DMAMUX_Channel DMA1MUX_CHANNEL1
#define | I2Cx_DMA_TX_DMAREQ DMAMUX_DMAREQ_ID_I2C1_TX
#define | I2Cx_DMA_TX_IRQn DMA1_Channel1_IRQn
#define | I2Cx_DMA_RX_Channel DMA1_CHANNEL2
#define | I2Cx_DMA_RX_DMAMUX_Channel DMA1MUX_CHANNEL2
#define | I2Cx_DMA_RX_DMAREQ DMAMUX_DMAREQ_ID_I2C1_RX
#define | I2Cx_DMA_RX_IRQn DMA1_Channel2_IRQn
#define | I2Cx_EVT_IRQn I2C1_EVT_IRQn
#define | I2Cx_ERR_IRQn I2C1_ERR_IRQn
#define | BUF_SIZE 8
#define | MASTER_BOARD

Functions

void | error_handler (uint32_t error_code)
error handler program More...
uint32_t | buffer_compare (uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal. More...
int | main (void)
main function. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...

Variables

uint8_t | tx_buf [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | rx_buf [8] = {0}
i2c_handle_type hi2cx

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/communication_dma/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • i2c
  • communication_dma
  • src
project/at_start_f435/examples/i2c/communication_dma/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include "i2c_application.h"
30
39#define I2C_TIMEOUT 0xFFFFFFF
40
41//#define I2Cx_CLKCTRL 0xB170FFFF //10K
42//#define I2Cx_CLKCTRL 0xC0E06969 //50K
43#define I2Cx_CLKCTRL 0x80504C4E //100K
44//#define I2Cx_CLKCTRL 0x30F03C6B //200K
45
46#define I2Cx_ADDRESS 0xA0
47
48#define I2Cx_PORT I2C1
49#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
50#define I2Cx_DMA DMA1
51#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
52
53#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
54#define I2Cx_SCL_GPIO_PIN GPIO_PINS_6
55#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
56#define I2Cx_SCL_GPIO_PORT GPIOB
57#define I2Cx_SCL_GPIO_MUX GPIO_MUX_4
58
59#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
60#define I2Cx_SDA_GPIO_PIN GPIO_PINS_7
61#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
62#define I2Cx_SDA_GPIO_PORT GPIOB
63#define I2Cx_SDA_GPIO_MUX GPIO_MUX_4
64
65#define I2Cx_DMA_TX_Channel DMA1_CHANNEL1
66#define I2Cx_DMA_TX_DMAMUX_Channel DMA1MUX_CHANNEL1
67#define I2Cx_DMA_TX_DMAREQ DMAMUX_DMAREQ_ID_I2C1_TX
68#define I2Cx_DMA_TX_IRQn DMA1_Channel1_IRQn
69
70#define I2Cx_DMA_RX_Channel DMA1_CHANNEL2
71#define I2Cx_DMA_RX_DMAMUX_Channel DMA1MUX_CHANNEL2
72#define I2Cx_DMA_RX_DMAREQ DMAMUX_DMAREQ_ID_I2C1_RX
73#define I2Cx_DMA_RX_IRQn DMA1_Channel2_IRQn
74
75#define I2Cx_EVT_IRQn I2C1_EVT_IRQn
76#define I2Cx_ERR_IRQn I2C1_ERR_IRQn
77
78#define BUF_SIZE 8
79#define MASTER_BOARD
80
81uint8_t tx_buf[BUF_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08};
82uint8_t rx_buf[BUF_SIZE] = {0};
83
84 i2c_handle_type hi2cx;
85
91void error_handler(uint32_t error_code)
92{
93 while(1)
94 {
95 at32_led_toggle(LED2);
96 delay_ms(500);
97 }
98}
99
107uint32_t buffer_compare(uint8_t* buffer1, uint8_t* buffer2, uint32_t len)
108{
109 uint32_t i;
110
111 for(i = 0; i < len; i++)
112 {
113 if(buffer1[i] != buffer2[i])
114 {
115 return 1;
116 }
117 }
118
119 return 0;
120}
121
127int main(void)
128{
129 i2c_status_type i2c_status;
130
131 /* initial system clock */
132 system_clock_config();
133
134 /* config nvic priority group */
135 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
136
137 /* at board initial */
138 at32_board_init();
139
140 hi2cx.i2cx = I2Cx_PORT;
141
142 /* i2c config */
143 i2c_config(&hi2cx);
144
145 while(1)
146 {
147
148 #if defined (MASTER_BOARD)
149
150 /* wait for key USER_BUTTON press before starting the communication */
151 while(at32_button_press() != USER_BUTTON)
152 {
153 }
154
155 /* start the request reception process */
156 if((i2c_status = i2c_master_transmit_dma(&hi2cx, I2Cx_ADDRESS, tx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
157 {
158 error_handler(i2c_status);
159 }
160
161 /* wait for the communication to end */
162 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
163 {
164 error_handler(i2c_status);
165 }
166
167 delay_ms(10);
168
169 /* start the request reception process */
170 if((i2c_status = i2c_master_receive_dma(&hi2cx, I2Cx_ADDRESS, rx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
171 {
172 error_handler(i2c_status);
173 }
174
175 /* wait for the communication to end */
176 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
177 {
178 error_handler(i2c_status);
179 }
180
181 if(buffer_compare(tx_buf, rx_buf, BUF_SIZE) == 0)
182 {
183 at32_led_on(LED3);
184 }
185 else
186 {
187 error_handler(i2c_status);
188 }
189
190 #else
191
192 /* wait for key USER_BUTTON press before starting the communication */
193 while(at32_button_press() != USER_BUTTON)
194 {
195 }
196
197 /* start the transmission process */
198 if((i2c_status = i2c_slave_receive_dma(&hi2cx, rx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
199 {
200 error_handler(i2c_status);
201 }
202
203 /* wait for the communication to end */
204 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
205 {
206 error_handler(i2c_status);
207 }
208
209 if((i2c_status = i2c_slave_transmit_dma(&hi2cx, tx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
210 {
211 error_handler(i2c_status);
212 }
213
214 /* wait for the communication to end */
215 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
216 {
217 error_handler(i2c_status);
218 }
219
220 if(buffer_compare(tx_buf, rx_buf, BUF_SIZE) == 0)
221 {
222 at32_led_on(LED3);
223 }
224 else
225 {
226 error_handler(i2c_status);
227 }
228
229 #endif
230
231 }
232}
233
239void i2c_lowlevel_init(i2c_handle_type* hi2c)
240{
241 gpio_init_type gpio_init_structure;
242
243 if(hi2c->i2cx == I2Cx_PORT)
244 {
245 /* i2c periph clock enable */
246 crm_periph_clock_enable(I2Cx_CLK, TRUE);
247 crm_periph_clock_enable(I2Cx_SCL_GPIO_CLK, TRUE);
248 crm_periph_clock_enable(I2Cx_SDA_GPIO_CLK, TRUE);
249
250 /* gpio configuration */
251 gpio_pin_mux_config(I2Cx_SCL_GPIO_PORT, I2Cx_SCL_GPIO_PinsSource, I2Cx_SCL_GPIO_MUX);
252
253 gpio_pin_mux_config(I2Cx_SDA_GPIO_PORT, I2Cx_SDA_GPIO_PinsSource, I2Cx_SDA_GPIO_MUX);
254
255 /* configure i2c pins: scl */
256 gpio_init_structure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
257 gpio_init_structure.gpio_mode = GPIO_MODE_MUX;
258 gpio_init_structure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
259 gpio_init_structure.gpio_pull = GPIO_PULL_UP;
260
261 gpio_init_structure.gpio_pins = I2Cx_SCL_GPIO_PIN;
262 gpio_init(I2Cx_SCL_GPIO_PORT, &gpio_init_structure);
263
264 /* configure i2c pins: sda */
265 gpio_init_structure.gpio_pins = I2Cx_SDA_GPIO_PIN;
266 gpio_init(I2Cx_SDA_GPIO_PORT, &gpio_init_structure);
267
268 /* configure and enable i2c interrupt */
269 nvic_irq_enable(I2Cx_EVT_IRQn, 0, 0);
270 nvic_irq_enable(I2Cx_ERR_IRQn, 0, 0);
271
272 /* configure and enable i2c dma channel interrupt */
273 nvic_irq_enable(I2Cx_DMA_TX_IRQn, 0, 0);
274 nvic_irq_enable(I2Cx_DMA_RX_IRQn, 0, 0);
275
276 /* i2c dma tx and rx channels configuration */
277 /* enable the dma clock */
278 crm_periph_clock_enable(I2Cx_DMA_CLK, TRUE);
279
280 /* i2c dma channel configuration */
281 dma_reset(hi2c->dma_tx_channel);
282 dma_reset(hi2c->dma_rx_channel);
283
284 hi2c->dma_tx_channel = I2Cx_DMA_TX_Channel;
285 hi2c->dma_rx_channel = I2Cx_DMA_RX_Channel;
286
287 hi2c->dma_init_struct.peripheral_base_addr = (uint32_t)&hi2c->i2cx->txdt;
288 hi2c->dma_init_struct.memory_base_addr = 0;
289 hi2c->dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
290 hi2c->dma_init_struct.buffer_size = 0xFFFF;
291 hi2c->dma_init_struct.peripheral_inc_enable = FALSE;
292 hi2c->dma_init_struct.memory_inc_enable = TRUE;
293 hi2c->dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
294 hi2c->dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
295 hi2c->dma_init_struct.loop_mode_enable = FALSE;
296 hi2c->dma_init_struct.priority = DMA_PRIORITY_LOW;
297
298 dma_init(hi2c->dma_tx_channel, &hi2c->dma_init_struct);
299 dma_init(hi2c->dma_rx_channel, &hi2c->dma_init_struct);
300
301 dmamux_init(I2Cx_DMA_TX_DMAMUX_Channel, I2Cx_DMA_TX_DMAREQ);
302 dmamux_init(I2Cx_DMA_RX_DMAMUX_Channel, I2Cx_DMA_RX_DMAREQ);
303
304 dmamux_enable(I2Cx_DMA, TRUE);
305
306 /* config i2c */
307 i2c_init(hi2c->i2cx, 0x0F, I2Cx_CLKCTRL);
308
309 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
310 }
311}
312
at32f435_437_board.h
rx_buf
uint8_t rx_buf[8]
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:82
I2Cx_DMA_TX_Channel
#define I2Cx_DMA_TX_Channel
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:65
I2Cx_DMA
#define I2Cx_DMA
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:50
I2Cx_DMA_TX_DMAMUX_Channel
#define I2Cx_DMA_TX_DMAMUX_Channel
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:66
tx_buf
uint8_t tx_buf[8]
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:81
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:46
I2Cx_SDA_GPIO_PIN
#define I2Cx_SDA_GPIO_PIN
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:60
I2Cx_DMA_RX_IRQn
#define I2Cx_DMA_RX_IRQn
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:73
I2Cx_SDA_GPIO_MUX
#define I2Cx_SDA_GPIO_MUX
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:63
I2Cx_CLKCTRL
#define I2Cx_CLKCTRL
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:43
I2Cx_CLK
#define I2Cx_CLK
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:49
I2Cx_SCL_GPIO_PinsSource
#define I2Cx_SCL_GPIO_PinsSource
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:55
I2Cx_DMA_RX_DMAREQ
#define I2Cx_DMA_RX_DMAREQ
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:72
BUF_SIZE
#define BUF_SIZE
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:78
I2Cx_DMA_RX_Channel
#define I2Cx_DMA_RX_Channel
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:70
main
int main(void)
main function.
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:127
hi2cx
i2c_handle_type hi2cx
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:84
I2Cx_SCL_GPIO_MUX
#define I2Cx_SCL_GPIO_MUX
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:57
I2Cx_SDA_GPIO_PORT
#define I2Cx_SDA_GPIO_PORT
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:62
buffer_compare
uint32_t buffer_compare(uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal.
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:107
I2Cx_SDA_GPIO_PinsSource
#define I2Cx_SDA_GPIO_PinsSource
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:61
I2Cx_DMA_CLK
#define I2Cx_DMA_CLK
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:51
I2Cx_SDA_GPIO_CLK
#define I2Cx_SDA_GPIO_CLK
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:59
I2Cx_ERR_IRQn
#define I2Cx_ERR_IRQn
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:76
error_handler
void error_handler(uint32_t error_code)
error handler program
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:91
i2c_lowlevel_init
void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:239
I2Cx_DMA_RX_DMAMUX_Channel
#define I2Cx_DMA_RX_DMAMUX_Channel
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:71
I2Cx_PORT
#define I2Cx_PORT
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:48
I2Cx_SCL_GPIO_PIN
#define I2Cx_SCL_GPIO_PIN
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:54
I2Cx_SCL_GPIO_CLK
#define I2Cx_SCL_GPIO_CLK
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:53
I2Cx_DMA_TX_DMAREQ
#define I2Cx_DMA_TX_DMAREQ
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:67
I2Cx_DMA_TX_IRQn
#define I2Cx_DMA_TX_IRQn
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:68
I2Cx_EVT_IRQn
#define I2Cx_EVT_IRQn
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:75
I2Cx_SCL_GPIO_PORT
#define I2Cx_SCL_GPIO_PORT
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:56
I2C_TIMEOUT
#define I2C_TIMEOUT
Definition: project/at_start_f435/examples/i2c/communication_dma/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
USER_BUTTON
@ USER_BUTTON
Definition: at32f435_437_board.h:98
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f435_437_board.c:194
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:162
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:172
DMA_PRIORITY_LOW
@ DMA_PRIORITY_LOW
Definition: at32f435_437_dma.h:182
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f435_437_gpio.h:103
i2c_init
void i2c_init(i2c_type *i2c_x, uint8_t dfilters, uint32_t clk)
init i2c digit filters and clock control register.
Definition: at32f435_437_i2c.c:79
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config i2c own address 1.
Definition: at32f435_437_i2c.c:103
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f435_437_i2c.h:113
i2c_wait_end
i2c_status_type i2c_wait_end(i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end.
Definition: i2c_application.c:165
i2c_slave_transmit_dma
i2c_status_type i2c_slave_transmit_dma(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through dma mode.
Definition: i2c_application.c:959
i2c_master_transmit_dma
i2c_status_type i2c_master_transmit_dma(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through dma mode.
Definition: i2c_application.c:835
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:113
i2c_slave_receive_dma
i2c_status_type i2c_slave_receive_dma(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through dma mode.
Definition: i2c_application.c:875
i2c_master_receive_dma
i2c_status_type i2c_master_receive_dma(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through dma mode.
Definition: i2c_application.c:919
i2c_status_type
i2c_status_type
Definition: i2c_application.h:80
I2C_OK
@ I2C_OK
Definition: i2c_application.h:81
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
i2c_application.h
i2c application libray header file
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
i2c_handle_type
Definition: i2c_application.h:112
i2c_handle_type::dma_rx_channel
dma_channel_type * dma_rx_channel
Definition: i2c_application.h:121
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:113
i2c_handle_type::dma_init_struct
dma_init_type dma_init_struct
Definition: i2c_application.h:122
i2c_handle_type::dma_tx_channel
dma_channel_type * dma_tx_channel
Definition: i2c_application.h:120
i2c_type::txdt
__IO uint32_t txdt
Definition: at32f435_437_i2c.h:400
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • i2c
  • communication_int
  • inc
project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • i2c
  • communication_int
  • inc
project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • i2c
  • communication_int
  • inc
project/at_start_f435/examples/i2c/communication_int/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • i2c
  • communication_int
  • src
Functions
project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • i2c
  • communication_int
  • src
project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • i2c
  • communication_int
  • src
Macros | Functions | Variables
project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"
#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | I2Cx_EVT_IRQHandler I2C1_EVT_IRQHandler
#define | I2Cx_ERR_IRQHandler I2C1_ERR_IRQHandler

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | I2C1_EVT_IRQHandler (void)
this function handles i2c event interrupt request. More...
void | I2C1_ERR_IRQHandler (void)
this function handles i2c error interrupt request. More...

Variables

i2c_handle_type hi2cx

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • i2c
  • communication_int
  • src
project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29#include "i2c_application.h"
30
39extern i2c_handle_type hi2cx;
40
41#define I2Cx_EVT_IRQHandler I2C1_EVT_IRQHandler
42#define I2Cx_ERR_IRQHandler I2C1_ERR_IRQHandler
43
49void NMI_Handler(void)
50{
51}
52
58void HardFault_Handler(void)
59{
60 /* go to infinite loop when hard fault exception occurs */
61 while(1)
62 {
63 }
64}
65
71void MemManage_Handler(void)
72{
73 /* go to infinite loop when memory manage exception occurs */
74 while(1)
75 {
76 }
77}
78
84void BusFault_Handler(void)
85{
86 /* go to infinite loop when bus fault exception occurs */
87 while(1)
88 {
89 }
90}
91
97void UsageFault_Handler(void)
98{
99 /* go to infinite loop when usage fault exception occurs */
100 while(1)
101 {
102 }
103}
104
110void SVC_Handler(void)
111{
112}
113
119void DebugMon_Handler(void)
120{
121}
122
128void PendSV_Handler(void)
129{
130}
131
137void SysTick_Handler(void)
138{
139}
140
146void I2Cx_EVT_IRQHandler(void)
147{
148 i2c_evt_irq_handler(&hi2cx);
149}
150
156void I2Cx_ERR_IRQHandler(void)
157{
158 i2c_err_irq_handler(&hi2cx);
159}
160
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c:97
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c:58
I2Cx_EVT_IRQHandler
#define I2Cx_EVT_IRQHandler
Definition: project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c:41
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c:71
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c:110
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c:128
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c:49
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c:84
hi2cx
i2c_handle_type hi2cx
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:37
I2Cx_ERR_IRQHandler
#define I2Cx_ERR_IRQHandler
Definition: project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c:42
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c:137
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/i2c/communication_int/src/at32f435_437_int.c:119
i2c_evt_irq_handler
void i2c_evt_irq_handler(i2c_handle_type *hi2c)
interrupt procession function.
Definition: i2c_application.c:2140
i2c_err_irq_handler
void i2c_err_irq_handler(i2c_handle_type *hi2c)
dma reveive complete interrupt function.
Definition: i2c_application.c:2174
i2c_application.h
i2c application libray header file
i2c_handle_type
Definition: i2c_application.h:112
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • i2c
  • communication_int
  • src
Macros | Functions | Variables
project/at_start_f435/examples/i2c/communication_int/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0xFFFFFFF
#define | I2Cx_CLKCTRL 0x80504C4E
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_MUX GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_MUX GPIO_MUX_4
#define | I2Cx_EVT_IRQn I2C1_EVT_IRQn
#define | I2Cx_ERR_IRQn I2C1_ERR_IRQn
#define | BUF_SIZE 8
#define | MASTER_BOARD

Functions

void | error_handler (uint32_t error_code)
error handler program More...
uint32_t | buffer_compare (uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal. More...
int | main (void)
main function. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...

Variables

uint8_t | tx_buf [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | rx_buf [8] = {0}
i2c_handle_type hi2cx

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/communication_int/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • i2c
  • communication_int
  • src
project/at_start_f435/examples/i2c/communication_int/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include "i2c_application.h"
30
39#define I2C_TIMEOUT 0xFFFFFFF
40
41//#define I2Cx_CLKCTRL 0xB170FFFF //10K
42//#define I2Cx_CLKCTRL 0xC0E06969 //50K
43#define I2Cx_CLKCTRL 0x80504C4E //100K
44//#define I2Cx_CLKCTRL 0x30F03C6B //200K
45
46#define I2Cx_ADDRESS 0xA0
47
48#define I2Cx_PORT I2C1
49#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
50
51#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
52#define I2Cx_SCL_GPIO_PIN GPIO_PINS_6
53#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
54#define I2Cx_SCL_GPIO_PORT GPIOB
55#define I2Cx_SCL_GPIO_MUX GPIO_MUX_4
56
57#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
58#define I2Cx_SDA_GPIO_PIN GPIO_PINS_7
59#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
60#define I2Cx_SDA_GPIO_PORT GPIOB
61#define I2Cx_SDA_GPIO_MUX GPIO_MUX_4
62
63#define I2Cx_EVT_IRQn I2C1_EVT_IRQn
64#define I2Cx_ERR_IRQn I2C1_ERR_IRQn
65
66#define BUF_SIZE 8
67#define MASTER_BOARD
68
69uint8_t tx_buf[BUF_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08};
70uint8_t rx_buf[BUF_SIZE] = {0};
71
72 i2c_handle_type hi2cx;
73
79void error_handler(uint32_t error_code)
80{
81 while(1)
82 {
83 at32_led_toggle(LED2);
84 delay_ms(500);
85 }
86}
87
95uint32_t buffer_compare(uint8_t* buffer1, uint8_t* buffer2, uint32_t len)
96{
97 uint32_t i;
98
99 for(i = 0; i < len; i++)
100 {
101 if(buffer1[i] != buffer2[i])
102 {
103 return 1;
104 }
105 }
106
107 return 0;
108}
109
115int main(void)
116{
117 i2c_status_type i2c_status;
118
119 /* initial system clock */
120 system_clock_config();
121
122 /* config nvic priority group */
123 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
124
125 /* at board initial */
126 at32_board_init();
127
128 hi2cx.i2cx = I2Cx_PORT;
129
130 /* i2c config */
131 i2c_config(&hi2cx);
132
133 while(1)
134 {
135
136 #if defined (MASTER_BOARD)
137
138 /* wait for key USER_BUTTON press before starting the communication */
139 while(at32_button_press() != USER_BUTTON)
140 {
141 }
142
143 /* start the request reception process */
144 if((i2c_status = i2c_master_transmit_int(&hi2cx, I2Cx_ADDRESS, tx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
145 {
146 error_handler(i2c_status);
147 }
148
149 /* wait for the communication to end */
150 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
151 {
152 error_handler(i2c_status);
153 }
154
155 delay_ms(10);
156
157 /* start the request reception process */
158 if((i2c_status = i2c_master_receive_int(&hi2cx, I2Cx_ADDRESS, rx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
159 {
160 error_handler(i2c_status);
161 }
162
163 /* wait for the communication to end */
164 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
165 {
166 error_handler(i2c_status);
167 }
168
169 if(buffer_compare(tx_buf, rx_buf, BUF_SIZE) == 0)
170 {
171 at32_led_on(LED3);
172 }
173 else
174 {
175 error_handler(i2c_status);
176 }
177
178 #else
179
180 /* wait for key USER_BUTTON press before starting the communication */
181 while(at32_button_press() != USER_BUTTON)
182 {
183 }
184
185 /* start the transmission process */
186 if((i2c_status = i2c_slave_receive_int(&hi2cx, rx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
187 {
188 error_handler(i2c_status);
189 }
190
191 /* wait for the communication to end */
192 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
193 {
194 error_handler(i2c_status);
195 }
196
197 if((i2c_status = i2c_slave_transmit_int(&hi2cx, tx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
198 {
199 error_handler(i2c_status);
200 }
201
202 /* wait for the communication to end */
203 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
204 {
205 error_handler(i2c_status);
206 }
207
208 if(buffer_compare(tx_buf, rx_buf, BUF_SIZE) == 0)
209 {
210 at32_led_on(LED3);
211 }
212 else
213 {
214 error_handler(i2c_status);
215 }
216 #endif
217
218 }
219}
220
226void i2c_lowlevel_init(i2c_handle_type* hi2c)
227{
228 gpio_init_type gpio_init_structure;
229
230 if(hi2c->i2cx == I2Cx_PORT)
231 {
232 /* i2c periph clock enable */
233 crm_periph_clock_enable(I2Cx_CLK, TRUE);
234 crm_periph_clock_enable(I2Cx_SCL_GPIO_CLK, TRUE);
235 crm_periph_clock_enable(I2Cx_SDA_GPIO_CLK, TRUE);
236
237 /* gpio configuration */
238 gpio_pin_mux_config(I2Cx_SCL_GPIO_PORT, I2Cx_SCL_GPIO_PinsSource, I2Cx_SCL_GPIO_MUX);
239
240 gpio_pin_mux_config(I2Cx_SDA_GPIO_PORT, I2Cx_SDA_GPIO_PinsSource, I2Cx_SDA_GPIO_MUX);
241
242 /* configure i2c pins: scl */
243 gpio_init_structure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
244 gpio_init_structure.gpio_mode = GPIO_MODE_MUX;
245 gpio_init_structure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
246 gpio_init_structure.gpio_pull = GPIO_PULL_UP;
247
248 gpio_init_structure.gpio_pins = I2Cx_SCL_GPIO_PIN;
249 gpio_init(I2Cx_SCL_GPIO_PORT, &gpio_init_structure);
250
251 /* configure i2c pins: sda */
252 gpio_init_structure.gpio_pins = I2Cx_SDA_GPIO_PIN;
253 gpio_init(I2Cx_SDA_GPIO_PORT, &gpio_init_structure);
254
255 /* configure and enable i2c interrupt */
256 nvic_irq_enable(I2Cx_EVT_IRQn, 0, 0);
257 nvic_irq_enable(I2Cx_ERR_IRQn, 0, 0);
258
259 /* config i2c */
260 i2c_init(hi2c->i2cx, 0x0F, I2Cx_CLKCTRL);
261
262 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
263 }
264}
265
at32f435_437_board.h
rx_buf
uint8_t rx_buf[8]
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:70
tx_buf
uint8_t tx_buf[8]
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:69
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:46
I2Cx_SDA_GPIO_PIN
#define I2Cx_SDA_GPIO_PIN
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:58
I2Cx_SDA_GPIO_MUX
#define I2Cx_SDA_GPIO_MUX
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:61
I2Cx_CLKCTRL
#define I2Cx_CLKCTRL
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:43
I2Cx_CLK
#define I2Cx_CLK
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:49
I2Cx_SCL_GPIO_PinsSource
#define I2Cx_SCL_GPIO_PinsSource
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:53
BUF_SIZE
#define BUF_SIZE
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:66
main
int main(void)
main function.
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:115
hi2cx
i2c_handle_type hi2cx
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:72
I2Cx_SCL_GPIO_MUX
#define I2Cx_SCL_GPIO_MUX
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:55
I2Cx_SDA_GPIO_PORT
#define I2Cx_SDA_GPIO_PORT
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:60
buffer_compare
uint32_t buffer_compare(uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal.
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:95
I2Cx_SDA_GPIO_PinsSource
#define I2Cx_SDA_GPIO_PinsSource
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:59
I2Cx_SDA_GPIO_CLK
#define I2Cx_SDA_GPIO_CLK
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:57
I2Cx_ERR_IRQn
#define I2Cx_ERR_IRQn
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:64
error_handler
void error_handler(uint32_t error_code)
error handler program
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:79
i2c_lowlevel_init
void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:226
I2Cx_PORT
#define I2Cx_PORT
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:48
I2Cx_SCL_GPIO_PIN
#define I2Cx_SCL_GPIO_PIN
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:52
I2Cx_SCL_GPIO_CLK
#define I2Cx_SCL_GPIO_CLK
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:51
I2Cx_EVT_IRQn
#define I2Cx_EVT_IRQn
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:63
I2Cx_SCL_GPIO_PORT
#define I2Cx_SCL_GPIO_PORT
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:54
I2C_TIMEOUT
#define I2C_TIMEOUT
Definition: project/at_start_f435/examples/i2c/communication_int/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
USER_BUTTON
@ USER_BUTTON
Definition: at32f435_437_board.h:98
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f435_437_board.c:194
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f435_437_gpio.h:103
i2c_init
void i2c_init(i2c_type *i2c_x, uint8_t dfilters, uint32_t clk)
init i2c digit filters and clock control register.
Definition: at32f435_437_i2c.c:79
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config i2c own address 1.
Definition: at32f435_437_i2c.c:103
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f435_437_i2c.h:113
i2c_wait_end
i2c_status_type i2c_wait_end(i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end.
Definition: i2c_application.c:165
i2c_slave_transmit_int
i2c_status_type i2c_slave_transmit_int(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through interrupt mode.
Definition: i2c_application.c:798
i2c_master_receive_int
i2c_status_type i2c_master_receive_int(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through interrupt mode.
Definition: i2c_application.c:764
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:113
i2c_master_transmit_int
i2c_status_type i2c_master_transmit_int(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through interrupt mode.
Definition: i2c_application.c:695
i2c_slave_receive_int
i2c_status_type i2c_slave_receive_int(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through interrupt mode.
Definition: i2c_application.c:729
i2c_status_type
i2c_status_type
Definition: i2c_application.h:80
I2C_OK
@ I2C_OK
Definition: i2c_application.h:81
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
i2c_application.h
i2c application libray header file
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
i2c_handle_type
Definition: i2c_application.h:112
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:113
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • i2c
  • communication_poll
  • inc
project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • i2c
  • communication_poll
  • inc
project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • i2c
  • communication_poll
  • inc
project/at_start_f435/examples/i2c/communication_poll/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • i2c
  • communication_poll
  • src
Functions
project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • i2c
  • communication_poll
  • src
project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • i2c
  • communication_poll
  • src
Functions
project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"
#include "i2c_application.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • i2c
  • communication_poll
  • src
project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29#include "i2c_application.h"
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/i2c/communication_poll/src/at32f435_437_int.c:114
i2c_application.h
i2c application libray header file
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • i2c
  • communication_poll
  • src
Macros | Functions | Variables
project/at_start_f435/examples/i2c/communication_poll/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0xFFFFFFF
#define | I2Cx_CLKCTRL 0x80504C4E
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_DMA DMA1
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_MUX GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_MUX GPIO_MUX_4
#define | BUF_SIZE 8
#define | MASTER_BOARD

Functions

void | error_handler (uint32_t error_code)
error handler program More...
uint32_t | buffer_compare (uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal. More...
int | main (void)
main function. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...

Variables

uint8_t | tx_buf [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | rx_buf [8] = {0}
i2c_handle_type hi2cx

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/communication_poll/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • i2c
  • communication_poll
  • src
project/at_start_f435/examples/i2c/communication_poll/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include "i2c_application.h"
30
39#define I2C_TIMEOUT 0xFFFFFFF
40
41//#define I2Cx_CLKCTRL 0xB170FFFF //10K
42//#define I2Cx_CLKCTRL 0xC0E06969 //50K
43#define I2Cx_CLKCTRL 0x80504C4E //100K
44//#define I2Cx_CLKCTRL 0x30F03C6B //200K
45
46#define I2Cx_ADDRESS 0xA0
47
48#define I2Cx_PORT I2C1
49#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
50#define I2Cx_DMA DMA1
51#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
52
53#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
54#define I2Cx_SCL_GPIO_PIN GPIO_PINS_6
55#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
56#define I2Cx_SCL_GPIO_PORT GPIOB
57#define I2Cx_SCL_GPIO_MUX GPIO_MUX_4
58
59#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
60#define I2Cx_SDA_GPIO_PIN GPIO_PINS_7
61#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
62#define I2Cx_SDA_GPIO_PORT GPIOB
63#define I2Cx_SDA_GPIO_MUX GPIO_MUX_4
64
65#define BUF_SIZE 8
66#define MASTER_BOARD
67
68uint8_t tx_buf[BUF_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08};
69uint8_t rx_buf[BUF_SIZE] = {0};
70
71 i2c_handle_type hi2cx;
72
78void error_handler(uint32_t error_code)
79{
80 while(1)
81 {
82 at32_led_toggle(LED2);
83 delay_ms(500);
84 }
85}
86
94uint32_t buffer_compare(uint8_t* buffer1, uint8_t* buffer2, uint32_t len)
95{
96 uint32_t i;
97
98 for(i = 0; i < len; i++)
99 {
100 if(buffer1[i] != buffer2[i])
101 {
102 return 1;
103 }
104 }
105
106 return 0;
107}
108
114int main(void)
115{
116 i2c_status_type i2c_status;
117
118 /* initial system clock */
119 system_clock_config();
120
121 /* config nvic priority group */
122 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
123
124 /* at board initial */
125 at32_board_init();
126
127 hi2cx.i2cx = I2Cx_PORT;
128
129 /* i2c config */
130 i2c_config(&hi2cx);
131
132 while(1)
133 {
134
135 #if defined (MASTER_BOARD)
136
137 /* wait for key USER_BUTTON press before starting the communication */
138 while(at32_button_press() != USER_BUTTON)
139 {
140 }
141
142 /* start the request reception process */
143 if((i2c_status = i2c_master_transmit(&hi2cx, I2Cx_ADDRESS, tx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
144 {
145 error_handler(i2c_status);
146 }
147
148 delay_ms(10);
149
150 /* start the request reception process */
151 if((i2c_status = i2c_master_receive(&hi2cx, I2Cx_ADDRESS, rx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
152 {
153 error_handler(i2c_status);
154 }
155
156 if(buffer_compare(tx_buf, rx_buf, BUF_SIZE) == 0)
157 {
158 at32_led_on(LED3);
159 }
160 else
161 {
162 error_handler(i2c_status);
163 }
164 #else
165
166 /* wait for key USER_BUTTON press before starting the communication */
167 while(at32_button_press() != USER_BUTTON)
168 {
169 }
170
171 /* start the transmission process */
172 if((i2c_status = i2c_slave_receive(&hi2cx, rx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
173 {
174 error_handler(i2c_status);
175 }
176
177 if((i2c_status = i2c_slave_transmit(&hi2cx, tx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
178 {
179 error_handler(i2c_status);
180 }
181
182 if(buffer_compare(tx_buf, rx_buf, BUF_SIZE) == 0)
183 {
184 at32_led_on(LED3);
185 }
186 else
187 {
188 error_handler(i2c_status);
189 }
190 #endif
191
192 }
193}
194
200void i2c_lowlevel_init(i2c_handle_type* hi2c)
201{
202 gpio_init_type gpio_init_structure;
203
204 if(hi2c->i2cx == I2Cx_PORT)
205 {
206 /* i2c periph clock enable */
207 crm_periph_clock_enable(I2Cx_CLK, TRUE);
208 crm_periph_clock_enable(I2Cx_SCL_GPIO_CLK, TRUE);
209 crm_periph_clock_enable(I2Cx_SDA_GPIO_CLK, TRUE);
210
211 /* gpio configuration */
212 gpio_pin_mux_config(I2Cx_SCL_GPIO_PORT, I2Cx_SCL_GPIO_PinsSource, I2Cx_SCL_GPIO_MUX);
213
214 gpio_pin_mux_config(I2Cx_SDA_GPIO_PORT, I2Cx_SDA_GPIO_PinsSource, I2Cx_SDA_GPIO_MUX);
215
216 /* configure i2c pins: scl */
217 gpio_init_structure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
218 gpio_init_structure.gpio_mode = GPIO_MODE_MUX;
219 gpio_init_structure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
220 gpio_init_structure.gpio_pull = GPIO_PULL_UP;
221
222 gpio_init_structure.gpio_pins = I2Cx_SCL_GPIO_PIN;
223 gpio_init(I2Cx_SCL_GPIO_PORT, &gpio_init_structure);
224
225 /* configure i2c pins: sda */
226 gpio_init_structure.gpio_pins = I2Cx_SDA_GPIO_PIN;
227 gpio_init(I2Cx_SDA_GPIO_PORT, &gpio_init_structure);
228
229 /* config i2c */
230 i2c_init(hi2c->i2cx, 0x0F, I2Cx_CLKCTRL);
231
232 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
233 }
234}
235
at32f435_437_board.h
rx_buf
uint8_t rx_buf[8]
Definition: project/at_start_f435/examples/i2c/communication_poll/src/main.c:69
tx_buf
uint8_t tx_buf[8]
Definition: project/at_start_f435/examples/i2c/communication_poll/src/main.c:68
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: project/at_start_f435/examples/i2c/communication_poll/src/main.c:46
I2Cx_SDA_GPIO_PIN
#define I2Cx_SDA_GPIO_PIN
Definition: project/at_start_f435/examples/i2c/communication_poll/src/main.c:60
I2Cx_SDA_GPIO_MUX
#define I2Cx_SDA_GPIO_MUX
Definition: project/at_start_f435/examples/i2c/communication_poll/src/main.c:63
I2Cx_CLKCTRL
#define I2Cx_CLKCTRL
Definition: project/at_start_f435/examples/i2c/communication_poll/src/main.c:43
I2Cx_CLK
#define I2Cx_CLK
Definition: project/at_start_f435/examples/i2c/communication_poll/src/main.c:49
I2Cx_SCL_GPIO_PinsSource
#define I2Cx_SCL_GPIO_PinsSource
Definition: project/at_start_f435/examples/i2c/communication_poll/src/main.c:55
BUF_SIZE
#define BUF_SIZE
Definition: project/at_start_f435/examples/i2c/communication_poll/src/main.c:65
main
int main(void)
main function.
Definition: project/at_start_f435/examples/i2c/communication_poll/src/main.c:114
hi2cx
i2c_handle_type hi2cx
Definition: project/at_start_f435/examples/i2c/communication_poll/src/main.c:71
I2Cx_SCL_GPIO_MUX
#define I2Cx_SCL_GPIO_MUX
Definition: project/at_start_f435/examples/i2c/communication_poll/src/main.c:57
I2Cx_SDA_GPIO_PORT
#define I2Cx_SDA_GPIO_PORT
Definition: project/at_start_f435/examples/i2c/communication_poll/src/main.c:62
buffer_compare
uint32_t buffer_compare(uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal.
Definition: project/at_start_f435/examples/i2c/communication_poll/src/main.c:94
I2Cx_SDA_GPIO_PinsSource
#define I2Cx_SDA_GPIO_PinsSource
Definition: project/at_start_f435/examples/i2c/communication_poll/src/main.c:61
I2Cx_SDA_GPIO_CLK
#define I2Cx_SDA_GPIO_CLK
Definition: project/at_start_f435/examples/i2c/communication_poll/src/main.c:59
error_handler
void error_handler(uint32_t error_code)
error handler program
Definition: project/at_start_f435/examples/i2c/communication_poll/src/main.c:78
i2c_lowlevel_init
void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: project/at_start_f435/examples/i2c/communication_poll/src/main.c:200
I2Cx_PORT
#define I2Cx_PORT
Definition: project/at_start_f435/examples/i2c/communication_poll/src/main.c:48
I2Cx_SCL_GPIO_PIN
#define I2Cx_SCL_GPIO_PIN
Definition: project/at_start_f435/examples/i2c/communication_poll/src/main.c:54
I2Cx_SCL_GPIO_CLK
#define I2Cx_SCL_GPIO_CLK
Definition: project/at_start_f435/examples/i2c/communication_poll/src/main.c:53
I2Cx_SCL_GPIO_PORT
#define I2Cx_SCL_GPIO_PORT
Definition: project/at_start_f435/examples/i2c/communication_poll/src/main.c:56
I2C_TIMEOUT
#define I2C_TIMEOUT
Definition: project/at_start_f435/examples/i2c/communication_poll/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
USER_BUTTON
@ USER_BUTTON
Definition: at32f435_437_board.h:98
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f435_437_board.c:194
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f435_437_gpio.h:103
i2c_init
void i2c_init(i2c_type *i2c_x, uint8_t dfilters, uint32_t clk)
init i2c digit filters and clock control register.
Definition: at32f435_437_i2c.c:79
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config i2c own address 1.
Definition: at32f435_437_i2c.c:103
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f435_437_i2c.h:113
i2c_slave_receive
i2c_status_type i2c_slave_receive(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through polling mode.
Definition: i2c_application.c:441
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:113
i2c_master_receive
i2c_status_type i2c_master_receive(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through polling mode.
Definition: i2c_application.c:524
i2c_master_transmit
i2c_status_type i2c_master_transmit(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode.
Definition: i2c_application.c:375
i2c_slave_transmit
i2c_status_type i2c_slave_transmit(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through polling mode.
Definition: i2c_application.c:590
i2c_status_type
i2c_status_type
Definition: i2c_application.h:80
I2C_OK
@ I2C_OK
Definition: i2c_application.h:81
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
i2c_application.h
i2c application libray header file
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
i2c_handle_type
Definition: i2c_application.h:112
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:113
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • i2c
  • communication_smbus
  • inc
project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • i2c
  • communication_smbus
  • inc
project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • i2c
  • communication_smbus
  • inc
project/at_start_f435/examples/i2c/communication_smbus/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • i2c
  • communication_smbus
  • src
Functions
project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • i2c
  • communication_smbus
  • src
project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • i2c
  • communication_smbus
  • src
Functions
project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"
#include "i2c_application.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • i2c
  • communication_smbus
  • src
project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29#include "i2c_application.h"
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/at32f435_437_int.c:114
i2c_application.h
i2c application libray header file
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • i2c
  • communication_smbus
  • src
Macros | Functions | Variables
project/at_start_f435/examples/i2c/communication_smbus/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0xFFFFFFF
#define | I2Cx_CLKCTRL 0x80504C4E
#define | I2Cx_ADDRESS 0xA2
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_DMA DMA1
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_MUX GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_MUX GPIO_MUX_4
#define | BUF_SIZE 9
#define | MASTER_BOARD

Functions

void | error_handler (uint32_t error_code)
error handler program More...
uint32_t | buffer_compare (uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal. More...
int | main (void)
main function. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...

Variables

uint8_t | tx_buf [9] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08, 0x00}
uint8_t | rx_buf [9] = {0}
i2c_handle_type hi2cx

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/communication_smbus/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • i2c
  • communication_smbus
  • src
project/at_start_f435/examples/i2c/communication_smbus/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include "i2c_application.h"
30
39#define I2C_TIMEOUT 0xFFFFFFF
40
41//#define I2Cx_CLKCTRL 0xB170FFFF //10K
42//#define I2Cx_CLKCTRL 0xC0E06969 //50K
43#define I2Cx_CLKCTRL 0x80504C4E //100K
44//#define I2Cx_CLKCTRL 0x30F03C6B //200K
45
46#define I2Cx_ADDRESS 0xA2
47
48#define I2Cx_PORT I2C1
49#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
50#define I2Cx_DMA DMA1
51#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
52
53#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
54#define I2Cx_SCL_GPIO_PIN GPIO_PINS_6
55#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE6
56#define I2Cx_SCL_GPIO_PORT GPIOB
57#define I2Cx_SCL_GPIO_MUX GPIO_MUX_4
58
59#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
60#define I2Cx_SDA_GPIO_PIN GPIO_PINS_7
61#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE7
62#define I2Cx_SDA_GPIO_PORT GPIOB
63#define I2Cx_SDA_GPIO_MUX GPIO_MUX_4
64
65#define BUF_SIZE 9
66#define MASTER_BOARD
67
68uint8_t tx_buf[BUF_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08, 0x00};
69uint8_t rx_buf[BUF_SIZE] = {0};
70
71 i2c_handle_type hi2cx;
72
78void error_handler(uint32_t error_code)
79{
80 while(1)
81 {
82 at32_led_toggle(LED2);
83 delay_ms(500);
84 }
85}
86
94uint32_t buffer_compare(uint8_t* buffer1, uint8_t* buffer2, uint32_t len)
95{
96 uint32_t i;
97
98 for(i = 0; i < len; i++)
99 {
100 if(buffer1[i] != buffer2[i])
101 {
102 return 1;
103 }
104 }
105
106 return 0;
107}
108
114int main(void)
115{
116 i2c_status_type i2c_status;
117
118 /* initial system clock */
119 system_clock_config();
120
121 /* config nvic priority group */
122 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
123
124 /* at board initial */
125 at32_board_init();
126
127 hi2cx.i2cx = I2Cx_PORT;
128
129 /* i2c config */
130 i2c_config(&hi2cx);
131
132 while(1)
133 {
134
135 #if defined (MASTER_BOARD)
136
137 /* wait for key USER_BUTTON press before starting the communication */
138 while(at32_button_press() != USER_BUTTON)
139 {
140 }
141
142 /* start the request reception process */
143 if((i2c_status = i2c_smbus_master_transmit(&hi2cx, I2Cx_ADDRESS, tx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
144 {
145 error_handler(i2c_status);
146 }
147
148 delay_ms(10);
149
150 /* start the request reception process */
151 if((i2c_status = i2c_smbus_master_receive(&hi2cx, I2Cx_ADDRESS, rx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
152 {
153 error_handler(i2c_status);
154 }
155
156 if(buffer_compare(tx_buf, rx_buf, BUF_SIZE - 1) == 0)
157 {
158 at32_led_on(LED3);
159 }
160 else
161 {
162 error_handler(i2c_status);
163 }
164 #else
165
166 /* wait for key USER_BUTTON press before starting the communication */
167 while(at32_button_press() != USER_BUTTON)
168 {
169 }
170
171 /* start the transmission process */
172 if((i2c_status = i2c_smbus_slave_receive(&hi2cx, rx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
173 {
174 error_handler(i2c_status);
175 }
176
177 if((i2c_status = i2c_smbus_slave_transmit(&hi2cx, tx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
178 {
179 error_handler(i2c_status);
180 }
181
182 if(buffer_compare(tx_buf, rx_buf, BUF_SIZE - 1) == 0)
183 {
184 at32_led_on(LED3);
185 }
186 else
187 {
188 error_handler(i2c_status);
189 }
190 #endif
191
192 }
193}
194
200void i2c_lowlevel_init(i2c_handle_type* hi2c)
201{
202 gpio_init_type gpio_init_structure;
203
204 if(hi2c->i2cx == I2Cx_PORT)
205 {
206 /* i2c periph clock enable */
207 crm_periph_clock_enable(I2Cx_CLK, TRUE);
208 crm_periph_clock_enable(I2Cx_SCL_GPIO_CLK, TRUE);
209 crm_periph_clock_enable(I2Cx_SDA_GPIO_CLK, TRUE);
210
211 /* gpio configuration */
212 gpio_pin_mux_config(I2Cx_SCL_GPIO_PORT, I2Cx_SCL_GPIO_PinsSource, I2Cx_SCL_GPIO_MUX);
213
214 gpio_pin_mux_config(I2Cx_SDA_GPIO_PORT, I2Cx_SDA_GPIO_PinsSource, I2Cx_SDA_GPIO_MUX);
215
216 /* configure i2c pins: scl */
217 gpio_init_structure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
218 gpio_init_structure.gpio_mode = GPIO_MODE_MUX;
219 gpio_init_structure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
220 gpio_init_structure.gpio_pull = GPIO_PULL_UP;
221
222 gpio_init_structure.gpio_pins = I2Cx_SCL_GPIO_PIN;
223 gpio_init(I2Cx_SCL_GPIO_PORT, &gpio_init_structure);
224
225 /* configure i2c pins: sda */
226 gpio_init_structure.gpio_pins = I2Cx_SDA_GPIO_PIN;
227 gpio_init(I2Cx_SDA_GPIO_PORT, &gpio_init_structure);
228
229 /* config i2c */
230 i2c_init(hi2c->i2cx, 0x0F, I2Cx_CLKCTRL);
231
232 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
233 }
234}
235
at32f435_437_board.h
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/main.c:46
I2Cx_SDA_GPIO_PIN
#define I2Cx_SDA_GPIO_PIN
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/main.c:60
I2Cx_SDA_GPIO_MUX
#define I2Cx_SDA_GPIO_MUX
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/main.c:63
I2Cx_CLKCTRL
#define I2Cx_CLKCTRL
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/main.c:43
I2Cx_CLK
#define I2Cx_CLK
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/main.c:49
I2Cx_SCL_GPIO_PinsSource
#define I2Cx_SCL_GPIO_PinsSource
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/main.c:55
BUF_SIZE
#define BUF_SIZE
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/main.c:65
main
int main(void)
main function.
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/main.c:114
rx_buf
uint8_t rx_buf[9]
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/main.c:69
hi2cx
i2c_handle_type hi2cx
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/main.c:71
I2Cx_SCL_GPIO_MUX
#define I2Cx_SCL_GPIO_MUX
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/main.c:57
I2Cx_SDA_GPIO_PORT
#define I2Cx_SDA_GPIO_PORT
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/main.c:62
buffer_compare
uint32_t buffer_compare(uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal.
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/main.c:94
I2Cx_SDA_GPIO_PinsSource
#define I2Cx_SDA_GPIO_PinsSource
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/main.c:61
I2Cx_SDA_GPIO_CLK
#define I2Cx_SDA_GPIO_CLK
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/main.c:59
error_handler
void error_handler(uint32_t error_code)
error handler program
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/main.c:78
i2c_lowlevel_init
void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/main.c:200
I2Cx_PORT
#define I2Cx_PORT
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/main.c:48
I2Cx_SCL_GPIO_PIN
#define I2Cx_SCL_GPIO_PIN
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/main.c:54
I2Cx_SCL_GPIO_CLK
#define I2Cx_SCL_GPIO_CLK
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/main.c:53
tx_buf
uint8_t tx_buf[9]
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/main.c:68
I2Cx_SCL_GPIO_PORT
#define I2Cx_SCL_GPIO_PORT
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/main.c:56
I2C_TIMEOUT
#define I2C_TIMEOUT
Definition: project/at_start_f435/examples/i2c/communication_smbus/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
USER_BUTTON
@ USER_BUTTON
Definition: at32f435_437_board.h:98
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f435_437_board.c:194
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f435_437_gpio.h:103
i2c_init
void i2c_init(i2c_type *i2c_x, uint8_t dfilters, uint32_t clk)
init i2c digit filters and clock control register.
Definition: at32f435_437_i2c.c:79
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config i2c own address 1.
Definition: at32f435_437_i2c.c:103
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f435_437_i2c.h:113
i2c_smbus_slave_receive
i2c_status_type i2c_smbus_slave_receive(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through SMBus mode.
Definition: i2c_application.c:1464
i2c_smbus_master_transmit
i2c_status_type i2c_smbus_master_transmit(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through SMBus mode.
Definition: i2c_application.c:1390
i2c_smbus_slave_transmit
i2c_status_type i2c_smbus_slave_transmit(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through SMBus mode.
Definition: i2c_application.c:1628
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:113
i2c_smbus_master_receive
i2c_status_type i2c_smbus_master_receive(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through SMBus mode.
Definition: i2c_application.c:1556
i2c_status_type
i2c_status_type
Definition: i2c_application.h:80
I2C_OK
@ I2C_OK
Definition: i2c_application.h:81
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
i2c_application.h
i2c application libray header file
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
i2c_handle_type
Definition: i2c_application.h:112
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:113
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • i2c
  • eeprom
  • inc
project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • i2c
  • eeprom
  • inc
project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • i2c
  • eeprom
  • inc
project/at_start_f435/examples/i2c/eeprom/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • i2c
  • eeprom
  • src
Functions
project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • i2c
  • eeprom
  • src
project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • i2c
  • eeprom
  • src
Macros | Functions | Variables
project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"
#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | I2Cx_DMA_TX_IRQHandler DMA1_Channel1_IRQHandler
#define | I2Cx_DMA_RX_IRQHandler DMA1_Channel2_IRQHandler
#define | I2Cx_EVT_IRQHandler I2C2_EVT_IRQHandler
#define | I2Cx_ERR_IRQHandler I2C2_ERR_IRQHandler

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel2_IRQHandler (void)
this function handles dma interrupt request. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma interrupt request. More...
void | I2C2_EVT_IRQHandler (void)
this function handles i2c event interrupt request. More...
void | I2C2_ERR_IRQHandler (void)
this function handles i2c error interrupt request. More...

Variables

i2c_handle_type hi2cx

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • i2c
  • eeprom
  • src
project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29#include "i2c_application.h"
30
39extern i2c_handle_type hi2cx;
40
41#define I2Cx_DMA_TX_IRQHandler DMA1_Channel1_IRQHandler
42#define I2Cx_DMA_RX_IRQHandler DMA1_Channel2_IRQHandler
43#define I2Cx_EVT_IRQHandler I2C2_EVT_IRQHandler
44#define I2Cx_ERR_IRQHandler I2C2_ERR_IRQHandler
45
51void NMI_Handler(void)
52{
53}
54
60void HardFault_Handler(void)
61{
62 /* go to infinite loop when hard fault exception occurs */
63 while(1)
64 {
65 }
66}
67
73void MemManage_Handler(void)
74{
75 /* go to infinite loop when memory manage exception occurs */
76 while(1)
77 {
78 }
79}
80
86void BusFault_Handler(void)
87{
88 /* go to infinite loop when bus fault exception occurs */
89 while(1)
90 {
91 }
92}
93
99void UsageFault_Handler(void)
100{
101 /* go to infinite loop when usage fault exception occurs */
102 while(1)
103 {
104 }
105}
106
112void SVC_Handler(void)
113{
114}
115
121void DebugMon_Handler(void)
122{
123}
124
130void PendSV_Handler(void)
131{
132}
133
139void SysTick_Handler(void)
140{
141}
142
148void I2Cx_DMA_RX_IRQHandler(void)
149{
150 i2c_dma_rx_irq_handler(&hi2cx);
151}
152
158void I2Cx_DMA_TX_IRQHandler(void)
159{
160 i2c_dma_tx_irq_handler(&hi2cx);
161}
162
168void I2Cx_EVT_IRQHandler(void)
169{
170 i2c_evt_irq_handler(&hi2cx);
171}
172
178void I2Cx_ERR_IRQHandler(void)
179{
180 i2c_err_irq_handler(&hi2cx);
181}
182
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c:99
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c:60
I2Cx_EVT_IRQHandler
#define I2Cx_EVT_IRQHandler
Definition: project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c:43
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c:73
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c:112
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c:130
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c:51
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c:86
hi2cx
i2c_handle_type hi2cx
Definition: at_start_f435/examples/dvp/ov2640_capture/hardware/ov2640/ov2640.c:37
I2Cx_ERR_IRQHandler
#define I2Cx_ERR_IRQHandler
Definition: project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c:44
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c:139
I2Cx_DMA_TX_IRQHandler
#define I2Cx_DMA_TX_IRQHandler
Definition: project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c:41
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c:121
I2Cx_DMA_RX_IRQHandler
#define I2Cx_DMA_RX_IRQHandler
Definition: project/at_start_f435/examples/i2c/eeprom/src/at32f435_437_int.c:42
i2c_evt_irq_handler
void i2c_evt_irq_handler(i2c_handle_type *hi2c)
interrupt procession function.
Definition: i2c_application.c:2140
i2c_err_irq_handler
void i2c_err_irq_handler(i2c_handle_type *hi2c)
dma reveive complete interrupt function.
Definition: i2c_application.c:2174
i2c_dma_rx_irq_handler
void i2c_dma_rx_irq_handler(i2c_handle_type *hi2c)
dma reveive complete interrupt function.
Definition: i2c_application.c:2130
i2c_dma_tx_irq_handler
void i2c_dma_tx_irq_handler(i2c_handle_type *hi2c)
dma transmission complete interrupt function.
Definition: i2c_application.c:2120
i2c_application.h
i2c application libray header file
i2c_handle_type
Definition: i2c_application.h:112
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • i2c
  • eeprom
  • src
Macros | Functions | Variables
project/at_start_f435/examples/i2c/eeprom/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0xFFFFFFF
#define | I2Cx_CLKCTRL 0x80504C4E
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C2
#define | I2Cx_CLK CRM_I2C2_PERIPH_CLOCK
#define | I2Cx_DMA DMA1
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SCL_GPIO_PIN GPIO_PINS_10
#define | I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE10
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_MUX GPIO_MUX_4
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_GPIO_PIN GPIO_PINS_11
#define | I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE11
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_MUX GPIO_MUX_4
#define | I2Cx_DMA_TX_Channel DMA1_CHANNEL1
#define | I2Cx_DMA_TX_DMAMUX_Channel DMA1MUX_CHANNEL1
#define | I2Cx_DMA_TX_DMAREQ DMAMUX_DMAREQ_ID_I2C2_TX
#define | I2Cx_DMA_TX_IRQn DMA1_Channel1_IRQn
#define | I2Cx_DMA_RX_Channel DMA1_CHANNEL2
#define | I2Cx_DMA_RX_DMAMUX_Channel DMA1MUX_CHANNEL2
#define | I2Cx_DMA_RX_DMAREQ DMAMUX_DMAREQ_ID_I2C2_RX
#define | I2Cx_DMA_RX_IRQn DMA1_Channel2_IRQn
#define | I2Cx_EVT_IRQn I2C2_EVT_IRQn
#define | I2Cx_ERR_IRQn I2C2_ERR_IRQn
#define | BUF_SIZE 8

Functions

void | error_handler (uint32_t error_code)
error handler program More...
uint32_t | buffer_compare (uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal. More...
int | main (void)
main function. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...

Variables

uint8_t | tx_buf1 [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | tx_buf2 [8] = {0x10, 0x20, 0x30, 0x40, 0x50, 0x60, 0x70, 0x80}
uint8_t | tx_buf3 [8] = {0x11, 0x22, 0x33, 0x44, 0x55, 0x66, 0x77, 0x88}
uint8_t | rx_buf1 [8] = {0}
uint8_t | rx_buf2 [8] = {0}
uint8_t | rx_buf3 [8] = {0}
i2c_handle_type hi2cx

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2c/eeprom/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • i2c
  • eeprom
  • src
project/at_start_f435/examples/i2c/eeprom/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include "i2c_application.h"
30
39#define I2C_TIMEOUT 0xFFFFFFF
40
41//#define I2Cx_CLKCTRL 0xB170FFFF //10K
42//#define I2Cx_CLKCTRL 0xC0E06969 //50K
43#define I2Cx_CLKCTRL 0x80504C4E //100K
44//#define I2Cx_CLKCTRL 0x30F03C6B //200K
45
46#define I2Cx_ADDRESS 0xA0
47
48#define I2Cx_PORT I2C2
49#define I2Cx_CLK CRM_I2C2_PERIPH_CLOCK
50#define I2Cx_DMA DMA1
51#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
52
53#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
54#define I2Cx_SCL_GPIO_PIN GPIO_PINS_10
55#define I2Cx_SCL_GPIO_PinsSource GPIO_PINS_SOURCE10
56#define I2Cx_SCL_GPIO_PORT GPIOB
57#define I2Cx_SCL_GPIO_MUX GPIO_MUX_4
58
59#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
60#define I2Cx_SDA_GPIO_PIN GPIO_PINS_11
61#define I2Cx_SDA_GPIO_PinsSource GPIO_PINS_SOURCE11
62#define I2Cx_SDA_GPIO_PORT GPIOB
63#define I2Cx_SDA_GPIO_MUX GPIO_MUX_4
64
65#define I2Cx_DMA_TX_Channel DMA1_CHANNEL1
66#define I2Cx_DMA_TX_DMAMUX_Channel DMA1MUX_CHANNEL1
67#define I2Cx_DMA_TX_DMAREQ DMAMUX_DMAREQ_ID_I2C2_TX
68#define I2Cx_DMA_TX_IRQn DMA1_Channel1_IRQn
69
70#define I2Cx_DMA_RX_Channel DMA1_CHANNEL2
71#define I2Cx_DMA_RX_DMAMUX_Channel DMA1MUX_CHANNEL2
72#define I2Cx_DMA_RX_DMAREQ DMAMUX_DMAREQ_ID_I2C2_RX
73#define I2Cx_DMA_RX_IRQn DMA1_Channel2_IRQn
74
75#define I2Cx_EVT_IRQn I2C2_EVT_IRQn
76#define I2Cx_ERR_IRQn I2C2_ERR_IRQn
77
78#define BUF_SIZE 8
79
80uint8_t tx_buf1[BUF_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08};
81uint8_t tx_buf2[BUF_SIZE] = {0x10, 0x20, 0x30, 0x40, 0x50, 0x60, 0x70, 0x80};
82uint8_t tx_buf3[BUF_SIZE] = {0x11, 0x22, 0x33, 0x44, 0x55, 0x66, 0x77, 0x88};
83uint8_t rx_buf1[BUF_SIZE] = {0};
84uint8_t rx_buf2[BUF_SIZE] = {0};
85uint8_t rx_buf3[BUF_SIZE] = {0};
86
87 i2c_handle_type hi2cx;
88
94void error_handler(uint32_t error_code)
95{
96 while(1)
97 {
98 at32_led_toggle(LED2);
99 delay_ms(500);
100 }
101}
102
110uint32_t buffer_compare(uint8_t* buffer1, uint8_t* buffer2, uint32_t len)
111{
112 uint32_t i;
113
114 for(i = 0; i < len; i++)
115 {
116 if(buffer1[i] != buffer2[i])
117 {
118 return 1;
119 }
120 }
121
122 return 0;
123}
124
130int main(void)
131{
132 i2c_status_type i2c_status;
133
134 /* initial system clock */
135 system_clock_config();
136
137 /* config nvic priority group */
138 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
139
140 /* at board initial */
141 at32_board_init();
142
143 hi2cx.i2cx = I2Cx_PORT;
144
145 /* i2c config */
146 i2c_config(&hi2cx);
147
148 while(1)
149 {
150 /* wait for key USER_BUTTON press before starting the communication */
151 while(at32_button_press() != USER_BUTTON)
152 {
153 }
154
155 /* write data to memory device */
156 if((i2c_status = i2c_memory_write(&hi2cx, I2Cx_ADDRESS, 0, tx_buf1, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
157 {
158 error_handler(i2c_status);
159 }
160
161 delay_ms(5);
162
163 /* read data from memory device */
164 if((i2c_status = i2c_memory_read(&hi2cx, I2Cx_ADDRESS, 0, rx_buf1, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
165 {
166 error_handler(i2c_status);
167 }
168
169 /* write data to memory device */
170 if((i2c_status = i2c_memory_write_int(&hi2cx, I2Cx_ADDRESS, 0, tx_buf2, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
171 {
172 error_handler(i2c_status);
173 }
174
175 /* wait for the communication to end */
176 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
177 {
178 error_handler(i2c_status);
179 }
180
181 delay_ms(5);
182
183 /* read data from memory device */
184 if((i2c_status = i2c_memory_read_int(&hi2cx, I2Cx_ADDRESS, 0, rx_buf2, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
185 {
186 error_handler(i2c_status);
187 }
188
189 /* wait for the communication to end */
190 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
191 {
192 error_handler(i2c_status);
193 }
194
195 /* write data to memory device */
196 if((i2c_status = i2c_memory_write_dma(&hi2cx, I2Cx_ADDRESS, 0, tx_buf3, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
197 {
198 error_handler(i2c_status);
199 }
200
201 /* wait for the communication to end */
202 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
203 {
204 error_handler(i2c_status);
205 }
206
207 delay_ms(5);
208
209 /* read data from memory device */
210 if((i2c_status = i2c_memory_read_dma(&hi2cx, I2Cx_ADDRESS, 0, rx_buf3, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
211 {
212 error_handler(i2c_status);
213 }
214
215 /* wait for the communication to end */
216 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
217 {
218 error_handler(i2c_status);
219 }
220
221 if((buffer_compare(tx_buf1, rx_buf1, BUF_SIZE) == 0) &&
222 (buffer_compare(tx_buf2, rx_buf2, BUF_SIZE) == 0) &&
223 (buffer_compare(tx_buf3, rx_buf3, BUF_SIZE) == 0))
224 {
225 at32_led_on(LED3);
226 }
227 else
228 {
229 error_handler(i2c_status);
230 }
231
232 }
233}
234
240void i2c_lowlevel_init(i2c_handle_type* hi2c)
241{
242 gpio_init_type gpio_init_structure;
243
244 if(hi2c->i2cx == I2Cx_PORT)
245 {
246 /* i2c periph clock enable */
247 crm_periph_clock_enable(I2Cx_CLK, TRUE);
248 crm_periph_clock_enable(I2Cx_SCL_GPIO_CLK, TRUE);
249 crm_periph_clock_enable(I2Cx_SDA_GPIO_CLK, TRUE);
250
251 /* gpio configuration */
252 gpio_pin_mux_config(I2Cx_SCL_GPIO_PORT, I2Cx_SCL_GPIO_PinsSource, I2Cx_SCL_GPIO_MUX);
253
254 gpio_pin_mux_config(I2Cx_SDA_GPIO_PORT, I2Cx_SDA_GPIO_PinsSource, I2Cx_SDA_GPIO_MUX);
255
256 /* configure i2c pins: scl */
257 gpio_init_structure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
258 gpio_init_structure.gpio_mode = GPIO_MODE_MUX;
259 gpio_init_structure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
260 gpio_init_structure.gpio_pull = GPIO_PULL_UP;
261
262 gpio_init_structure.gpio_pins = I2Cx_SCL_GPIO_PIN;
263 gpio_init(I2Cx_SCL_GPIO_PORT, &gpio_init_structure);
264
265 /* configure i2c pins: sda */
266 gpio_init_structure.gpio_pins = I2Cx_SDA_GPIO_PIN;
267 gpio_init(I2Cx_SDA_GPIO_PORT, &gpio_init_structure);
268
269 /* configure and enable i2c interrupt */
270 nvic_irq_enable(I2Cx_EVT_IRQn, 0, 0);
271 nvic_irq_enable(I2Cx_ERR_IRQn, 0, 0);
272
273 /* configure and enable i2c dma channel interrupt */
274 nvic_irq_enable(I2Cx_DMA_TX_IRQn, 0, 0);
275 nvic_irq_enable(I2Cx_DMA_RX_IRQn, 0, 0);
276
277 /* i2c dma tx and rx channels configuration */
278 /* enable the dma clock */
279 crm_periph_clock_enable(I2Cx_DMA_CLK, TRUE);
280
281 /* i2c dma channel configuration */
282 dma_reset(hi2c->dma_tx_channel);
283 dma_reset(hi2c->dma_rx_channel);
284
285 hi2c->dma_tx_channel = I2Cx_DMA_TX_Channel;
286 hi2c->dma_rx_channel = I2Cx_DMA_RX_Channel;
287
288 hi2c->dma_init_struct.peripheral_base_addr = (uint32_t)&hi2c->i2cx->txdt;
289 hi2c->dma_init_struct.memory_base_addr = 0;
290 hi2c->dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
291 hi2c->dma_init_struct.buffer_size = 0xFFFF;
292 hi2c->dma_init_struct.peripheral_inc_enable = FALSE;
293 hi2c->dma_init_struct.memory_inc_enable = TRUE;
294 hi2c->dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
295 hi2c->dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
296 hi2c->dma_init_struct.loop_mode_enable = FALSE;
297 hi2c->dma_init_struct.priority = DMA_PRIORITY_LOW;
298
299 dma_init(hi2c->dma_tx_channel, &hi2c->dma_init_struct);
300 dma_init(hi2c->dma_rx_channel, &hi2c->dma_init_struct);
301
302 dmamux_init(I2Cx_DMA_TX_DMAMUX_Channel, I2Cx_DMA_TX_DMAREQ);
303 dmamux_init(I2Cx_DMA_RX_DMAMUX_Channel, I2Cx_DMA_RX_DMAREQ);
304
305 dmamux_enable(I2Cx_DMA, TRUE);
306
307 /* config i2c */
308 i2c_init(hi2c->i2cx, 0x0F, I2Cx_CLKCTRL);
309
310 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
311 }
312}
313
at32f435_437_board.h
I2Cx_DMA_TX_Channel
#define I2Cx_DMA_TX_Channel
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:65
I2Cx_DMA
#define I2Cx_DMA
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:50
I2Cx_DMA_TX_DMAMUX_Channel
#define I2Cx_DMA_TX_DMAMUX_Channel
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:66
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:46
I2Cx_SDA_GPIO_PIN
#define I2Cx_SDA_GPIO_PIN
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:60
I2Cx_DMA_RX_IRQn
#define I2Cx_DMA_RX_IRQn
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:73
I2Cx_SDA_GPIO_MUX
#define I2Cx_SDA_GPIO_MUX
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:63
I2Cx_CLKCTRL
#define I2Cx_CLKCTRL
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:43
I2Cx_CLK
#define I2Cx_CLK
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:49
tx_buf3
uint8_t tx_buf3[8]
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:82
I2Cx_SCL_GPIO_PinsSource
#define I2Cx_SCL_GPIO_PinsSource
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:55
I2Cx_DMA_RX_DMAREQ
#define I2Cx_DMA_RX_DMAREQ
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:72
BUF_SIZE
#define BUF_SIZE
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:78
rx_buf1
uint8_t rx_buf1[8]
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:83
I2Cx_DMA_RX_Channel
#define I2Cx_DMA_RX_Channel
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:70
main
int main(void)
main function.
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:130
hi2cx
i2c_handle_type hi2cx
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:87
I2Cx_SCL_GPIO_MUX
#define I2Cx_SCL_GPIO_MUX
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:57
I2Cx_SDA_GPIO_PORT
#define I2Cx_SDA_GPIO_PORT
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:62
buffer_compare
uint32_t buffer_compare(uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal.
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:110
I2Cx_SDA_GPIO_PinsSource
#define I2Cx_SDA_GPIO_PinsSource
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:61
I2Cx_DMA_CLK
#define I2Cx_DMA_CLK
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:51
I2Cx_SDA_GPIO_CLK
#define I2Cx_SDA_GPIO_CLK
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:59
rx_buf2
uint8_t rx_buf2[8]
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:84
I2Cx_ERR_IRQn
#define I2Cx_ERR_IRQn
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:76
error_handler
void error_handler(uint32_t error_code)
error handler program
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:94
i2c_lowlevel_init
void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:240
I2Cx_DMA_RX_DMAMUX_Channel
#define I2Cx_DMA_RX_DMAMUX_Channel
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:71
I2Cx_PORT
#define I2Cx_PORT
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:48
I2Cx_SCL_GPIO_PIN
#define I2Cx_SCL_GPIO_PIN
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:54
rx_buf3
uint8_t rx_buf3[8]
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:85
tx_buf2
uint8_t tx_buf2[8]
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:81
I2Cx_SCL_GPIO_CLK
#define I2Cx_SCL_GPIO_CLK
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:53
I2Cx_DMA_TX_DMAREQ
#define I2Cx_DMA_TX_DMAREQ
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:67
I2Cx_DMA_TX_IRQn
#define I2Cx_DMA_TX_IRQn
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:68
tx_buf1
uint8_t tx_buf1[8]
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:80
I2Cx_EVT_IRQn
#define I2Cx_EVT_IRQn
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:75
I2Cx_SCL_GPIO_PORT
#define I2Cx_SCL_GPIO_PORT
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:56
I2C_TIMEOUT
#define I2C_TIMEOUT
Definition: project/at_start_f435/examples/i2c/eeprom/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
USER_BUTTON
@ USER_BUTTON
Definition: at32f435_437_board.h:98
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f435_437_board.c:194
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:162
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:172
DMA_PRIORITY_LOW
@ DMA_PRIORITY_LOW
Definition: at32f435_437_dma.h:182
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f435_437_gpio.h:103
i2c_init
void i2c_init(i2c_type *i2c_x, uint8_t dfilters, uint32_t clk)
init i2c digit filters and clock control register.
Definition: at32f435_437_i2c.c:79
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config i2c own address 1.
Definition: at32f435_437_i2c.c:103
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f435_437_i2c.h:113
i2c_wait_end
i2c_status_type i2c_wait_end(i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end.
Definition: i2c_application.c:165
i2c_memory_read
i2c_status_type i2c_memory_read(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode.
Definition: i2c_application.c:1084
i2c_memory_write_int
i2c_status_type i2c_memory_write_int(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through interrupt mode.
Definition: i2c_application.c:1170
i2c_memory_write
i2c_status_type i2c_memory_write(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through polling mode.
Definition: i2c_application.c:1004
i2c_memory_write_dma
i2c_status_type i2c_memory_write_dma(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through dma mode.
Definition: i2c_application.c:1271
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:113
i2c_memory_read_int
i2c_status_type i2c_memory_read_int(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through interrupt mode.
Definition: i2c_application.c:1217
i2c_memory_read_dma
i2c_status_type i2c_memory_read_dma(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode.
Definition: i2c_application.c:1331
i2c_status_type
i2c_status_type
Definition: i2c_application.h:80
I2C_OK
@ I2C_OK
Definition: i2c_application.h:81
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
i2c_application.h
i2c application libray header file
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
i2c_handle_type
Definition: i2c_application.h:112
i2c_handle_type::dma_rx_channel
dma_channel_type * dma_rx_channel
Definition: i2c_application.h:121
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:113
i2c_handle_type::dma_init_struct
dma_init_type dma_init_struct
Definition: i2c_application.h:122
i2c_handle_type::dma_tx_channel
dma_channel_type * dma_tx_channel
Definition: i2c_application.h:120
i2c_type::txdt
__IO uint32_t txdt
Definition: at32f435_437_i2c.h:400
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • i2s
  • fullduplex_dma
  • inc
project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • i2s
  • fullduplex_dma
  • inc
project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • i2s
  • fullduplex_dma
  • inc
project/at_start_f435/examples/i2s/fullduplex_dma/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • i2s
  • fullduplex_dma
  • src
Functions
project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • i2s
  • fullduplex_dma
  • src
project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • i2s
  • fullduplex_dma
  • src
Functions
project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • i2s
  • fullduplex_dma
  • src
project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • i2s
  • fullduplex_dma
  • src
Macros | Functions | Variables
project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define | TXBUF_SIZE 32
#define | RXBUF_SIZE TXBUF_SIZE

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | i2s_config (void)
i2s configuration. More...
void | tx_data_fill (void)
transfer data fill. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

uint16_t | i2s2_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
uint16_t | i2s3_buffer_tx [32]
uint16_t | i2s3_buffer_rx [32]
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • i2s
  • fullduplex_dma
  • src
project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define TXBUF_SIZE 32
39#define RXBUF_SIZE TXBUF_SIZE
40
41uint16_t i2s2_buffer_tx[TXBUF_SIZE];
42uint16_t i2s2_buffer_rx[RXBUF_SIZE];
43uint16_t i2s3_buffer_tx[TXBUF_SIZE];
44uint16_t i2s3_buffer_rx[RXBUF_SIZE];
45volatile error_status transfer_status1 = ERROR, transfer_status2 = ERROR;
46
47static void gpio_config(void);
48static void i2s_config(void);
49void tx_data_fill(void);
50 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length);
51
57 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length)
58{
59 while(buffer_length--)
60 {
61 if(*pbuffer1 != *pbuffer2)
62 {
63 return ERROR;
64 }
65
66 pbuffer1++;
67 pbuffer2++;
68 }
69 return SUCCESS;
70}
71
77void tx_data_fill(void)
78{
79 uint32_t data_index = 0;
80 for(data_index = 0; data_index < TXBUF_SIZE; data_index++)
81 {
82 i2s2_buffer_tx[data_index] = data_index;
83 i2s3_buffer_tx[data_index] = TXBUF_SIZE - data_index;
84 }
85}
86
92static void i2s_config(void)
93{
94 dma_init_type dma_init_struct;
95 i2s_init_type i2s_init_struct;
96
97 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
98 dma_reset(DMA1_CHANNEL1);
99 dma_reset(DMA1_CHANNEL2);
100 dma_reset(DMA1_CHANNEL3);
101 dma_reset(DMA1_CHANNEL4);
102 dmamux_enable(DMA1, TRUE);
103 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_SPI2_TX);
104 dmamux_init(DMA1MUX_CHANNEL2, DMAMUX_DMAREQ_ID_I2S2_EXT_RX);
105 dmamux_init(DMA1MUX_CHANNEL3, DMAMUX_DMAREQ_ID_SPI3_RX);
106 dmamux_init(DMA1MUX_CHANNEL4, DMAMUX_DMAREQ_ID_I2S3_EXT_TX);
107
108 dma_default_para_init(&dma_init_struct);
109 dma_init_struct.buffer_size = TXBUF_SIZE;
110 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
111 dma_init_struct.memory_inc_enable = TRUE;
112 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
113 dma_init_struct.peripheral_inc_enable = FALSE;
114 dma_init_struct.priority = DMA_PRIORITY_HIGH;
115 dma_init_struct.loop_mode_enable = FALSE;
116
117 dma_init_struct.memory_base_addr = (uint32_t)i2s2_buffer_tx;
118 dma_init_struct.peripheral_base_addr = (uint32_t)&(SPI2->dt);
119 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
120 dma_init(DMA1_CHANNEL1, &dma_init_struct);
121
122 dma_init_struct.memory_base_addr = (uint32_t)i2s2_buffer_rx;
123 dma_init_struct.peripheral_base_addr = (uint32_t)&(I2S2EXT->dt);
124 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
125 dma_init(DMA1_CHANNEL2, &dma_init_struct);
126
127 dma_init_struct.memory_base_addr = (uint32_t)i2s3_buffer_rx;
128 dma_init_struct.peripheral_base_addr = (uint32_t)&(SPI3->dt);
129 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
130 dma_init(DMA1_CHANNEL3, &dma_init_struct);
131
132 dma_init_struct.memory_base_addr = (uint32_t)i2s3_buffer_tx;
133 dma_init_struct.peripheral_base_addr = (uint32_t)&(I2S3EXT->dt);
134 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
135 dma_init(DMA1_CHANNEL4, &dma_init_struct);
136
137 crm_periph_clock_enable(CRM_SPI3_PERIPH_CLOCK, TRUE);
138 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
139 i2s_default_para_init(&i2s_init_struct);
140 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
141 i2s_init_struct.data_channel_format = I2S_DATA_16BIT_CHANNEL_32BIT;
142 i2s_init_struct.mclk_output_enable = FALSE;
143 i2s_init_struct.audio_sampling_freq = I2S_AUDIO_FREQUENCY_48K;
144 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
145
146 i2s_init_struct.operation_mode = I2S_MODE_MASTER_TX;
147 i2s_init(SPI2, &i2s_init_struct);
148 i2s_init_struct.operation_mode =I2S_MODE_SLAVE_RX;
149 i2s_init(I2S2EXT, &i2s_init_struct);
150
151 i2s_init_struct.operation_mode = I2S_MODE_SLAVE_RX;
152 i2s_init(SPI3, &i2s_init_struct);
153 i2s_init_struct.operation_mode =I2S_MODE_SLAVE_TX;
154 i2s_init(I2S3EXT, &i2s_init_struct);
155
156 dma_channel_enable(DMA1_CHANNEL1, TRUE);
157 dma_channel_enable(DMA1_CHANNEL2, TRUE);
158 dma_channel_enable(DMA1_CHANNEL3, TRUE);
159 dma_channel_enable(DMA1_CHANNEL4, TRUE);
160 spi_i2s_dma_transmitter_enable(SPI2, TRUE);
161 spi_i2s_dma_receiver_enable(I2S2EXT, TRUE);
162 spi_i2s_dma_receiver_enable(SPI3, TRUE);
163 spi_i2s_dma_transmitter_enable(I2S3EXT, TRUE);
164}
165
171static void gpio_config(void)
172{
173 gpio_init_type gpio_initstructure;
174 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
175 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
176 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
177
178 /* master ws pin */
179 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
180 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
181 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
182 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
183 gpio_initstructure.gpio_pins = GPIO_PINS_0;
184 gpio_init(GPIOD, &gpio_initstructure);
185 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE0, GPIO_MUX_7);
186
187 /* master ck pin */
188 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
189 gpio_initstructure.gpio_pins = GPIO_PINS_1;
190 gpio_init(GPIOD, &gpio_initstructure);
191 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_6);
192
193 /* master ext_sd pin */
194 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
195 gpio_initstructure.gpio_pins = GPIO_PINS_2;
196 gpio_init(GPIOC, &gpio_initstructure);
197 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE2, GPIO_MUX_6);
198
199 /* master sd pin */
200 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
201 gpio_initstructure.gpio_pins = GPIO_PINS_4;
202 gpio_init(GPIOD, &gpio_initstructure);
203 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_6);
204
205 /* slave ws pin */
206 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
207 gpio_initstructure.gpio_pins = GPIO_PINS_4;
208 gpio_init(GPIOA, &gpio_initstructure);
209 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE4, GPIO_MUX_6);
210
211 /* slave ck pin */
212 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
213 gpio_initstructure.gpio_pins = GPIO_PINS_10;
214 gpio_init(GPIOC, &gpio_initstructure);
215 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE10, GPIO_MUX_6);
216
217 /* slave ext_sd pin */
218 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
219 gpio_initstructure.gpio_pins = GPIO_PINS_11;
220 gpio_init(GPIOC, &gpio_initstructure);
221 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE11, GPIO_MUX_5);
222
223 /* slave sd pin */
224 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
225 gpio_initstructure.gpio_pins = GPIO_PINS_12;
226 gpio_init(GPIOC, &gpio_initstructure);
227 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE12, GPIO_MUX_6);
228}
229
235int main(void)
236{
237 system_clock_config();
238 at32_board_init();
239 at32_led_off(LED2);
240 at32_led_off(LED3);
241 at32_led_off(LED4);
242 tx_data_fill();
243 gpio_config();
244 i2s_config();
245 i2s_enable(SPI3, TRUE);
246 i2s_enable(I2S3EXT, TRUE);
247 i2s_enable(I2S2EXT, TRUE);
248 i2s_enable(SPI2, TRUE);
249
250 while(dma_flag_get(DMA1_FDT2_FLAG) == RESET);
251
252 /* test result:the data check */
253 transfer_status1 = buffer_compare(i2s2_buffer_rx, i2s3_buffer_tx, TXBUF_SIZE);
254 transfer_status2 = buffer_compare(i2s3_buffer_rx, i2s2_buffer_tx, TXBUF_SIZE);
255
256 /* test result indicate:if success ,led2 lights */
257 if((transfer_status1 == SUCCESS) &&(transfer_status2 == SUCCESS))
258 {
259 at32_led_on(LED2);
260 }
261 else
262 {
263 at32_led_off(LED2);
264 }
265 while(1)
266 {
267 }
268}
269
at32f435_437_board.h
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
i2s3_buffer_tx
uint16_t i2s3_buffer_tx[32]
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c:43
i2s2_buffer_tx
uint16_t i2s2_buffer_tx[32]
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c:41
buffer_compare
error_status buffer_compare(uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer compare function.
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c:57
i2s_config
static void i2s_config(void)
i2s configuration.
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c:92
i2s2_buffer_rx
uint16_t i2s2_buffer_rx[32]
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c:42
RXBUF_SIZE
#define RXBUF_SIZE
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c:39
transfer_status1
volatile error_status transfer_status1
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c:45
transfer_status2
volatile error_status transfer_status2
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c:45
main
int main(void)
main function.
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c:235
TXBUF_SIZE
#define TXBUF_SIZE
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c:38
i2s3_buffer_rx
uint16_t i2s3_buffer_rx[32]
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c:44
tx_data_fill
void tx_data_fill(void)
transfer data fill.
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c:77
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c:171
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_SPI3_PERIPH_CLOCK
@ CRM_SPI3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:139
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:138
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_SPI2_TX
@ DMAMUX_DMAREQ_ID_SPI2_TX
Definition: at32f435_437_dma.h:207
DMAMUX_DMAREQ_ID_SPI3_RX
@ DMAMUX_DMAREQ_ID_SPI3_RX
Definition: at32f435_437_dma.h:208
DMAMUX_DMAREQ_ID_I2S3_EXT_TX
@ DMAMUX_DMAREQ_ID_I2S3_EXT_TX
Definition: at32f435_437_dma.h:215
DMAMUX_DMAREQ_ID_I2S2_EXT_RX
@ DMAMUX_DMAREQ_ID_I2S2_EXT_RX
Definition: at32f435_437_dma.h:212
DMA1_FDT2_FLAG
#define DMA1_FDT2_FLAG
Definition: at32f435_437_dma.h:70
DMA1MUX_CHANNEL2
#define DMA1MUX_CHANNEL2
Definition: at32f435_437_dma.h:705
DMA1MUX_CHANNEL3
#define DMA1MUX_CHANNEL3
Definition: at32f435_437_dma.h:706
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f435_437_dma.h:698
DMA1MUX_CHANNEL4
#define DMA1MUX_CHANNEL4
Definition: at32f435_437_dma.h:707
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f435_437_dma.h:699
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f435_437_dma.h:697
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_6
@ GPIO_MUX_6
Definition: at32f435_437_gpio.h:162
GPIO_MUX_5
@ GPIO_MUX_5
Definition: at32f435_437_gpio.h:161
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f435_437_spi.c:350
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f435_437_spi.c:533
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f435_437_spi.c:479
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f435_437_spi.c:332
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f435_437_spi.c:519
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f435_437_spi.h:251
I2S_DATA_16BIT_CHANNEL_32BIT
@ I2S_DATA_16BIT_CHANNEL_32BIT
Definition: at32f435_437_spi.h:230
I2S_AUDIO_FREQUENCY_48K
@ I2S_AUDIO_FREQUENCY_48K
Definition: at32f435_437_spi.h:219
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f435_437_spi.h:200
I2S_MODE_MASTER_TX
@ I2S_MODE_MASTER_TX
Definition: at32f435_437_spi.h:242
I2S_MODE_SLAVE_RX
@ I2S_MODE_SLAVE_RX
Definition: at32f435_437_spi.h:241
I2S_MODE_SLAVE_TX
@ I2S_MODE_SLAVE_TX
Definition: at32f435_437_spi.h:240
I2S3EXT
#define I2S3EXT
Definition: at32f435_437_spi.h:458
SPI3
#define SPI3
Definition: at32f435_437_spi.h:455
I2S2EXT
#define I2S2EXT
Definition: at32f435_437_spi.h:457
SPI2
#define SPI2
Definition: at32f435_437_spi.h:454
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
i2s_init_type
i2s init type
Definition: at32f435_437_spi.h:274
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f435_437_spi.h:277
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f435_437_spi.h:278
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f435_437_spi.h:280
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f435_437_spi.h:276
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f435_437_spi.h:275
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:279
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • i2s
  • halfduplex_dma
  • inc
project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • i2s
  • halfduplex_dma
  • inc
project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • i2s
  • halfduplex_dma
  • inc
project/at_start_f435/examples/i2s/halfduplex_dma/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • i2s
  • halfduplex_dma
  • src
Functions
project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • i2s
  • halfduplex_dma
  • src
project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • i2s
  • halfduplex_dma
  • src
Functions
project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • i2s
  • halfduplex_dma
  • src
project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/i2s/halfduplex_dma/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • i2s
  • halfduplex_dma
  • src
Functions | Variables
project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | i2s_config (void)
i2s configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function. More...
int | main (void)
main function. More...

Variables

uint16_t | i2s3_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
volatile error_status | transfer_status = ERROR

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • i2s
  • halfduplex_dma
  • src
project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38uint16_t i2s3_buffer_tx[32] = {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C,
39 0x0D0E, 0x0F10, 0x1112, 0x1314, 0x1516, 0x1718,
40 0x191A, 0x1B1C, 0x1D1E, 0x1F20, 0x2122, 0x2324,
41 0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
42 0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C,
43 0x3D3E, 0x3F40};
44uint16_t i2s2_buffer_rx[32];
45volatile error_status transfer_status = ERROR;
46
47static void gpio_config(void);
48static void i2s_config(void);
49 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length);
50
56 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length)
57{
58 while(buffer_length--)
59 {
60 if(*pbuffer1 != *pbuffer2)
61 {
62 return ERROR;
63 }
64
65 pbuffer1++;
66 pbuffer2++;
67 }
68 return SUCCESS;
69}
70
76static void i2s_config(void)
77{
78 dma_init_type dma_init_struct;
79 i2s_init_type i2s_init_struct;
80
81 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
82 dmamux_enable(DMA1, TRUE);
83 dma_reset(DMA1_CHANNEL1);
84 dma_reset(DMA1_CHANNEL2);
85 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_SPI2_RX);
86 dmamux_init(DMA1MUX_CHANNEL2, DMAMUX_DMAREQ_ID_SPI3_TX);
87
88 dma_default_para_init(&dma_init_struct);
89 dma_init_struct.buffer_size = 32;
90 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
91 dma_init_struct.memory_inc_enable = TRUE;
92 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
93 dma_init_struct.peripheral_inc_enable = FALSE;
94 dma_init_struct.priority = DMA_PRIORITY_HIGH;
95 dma_init_struct.loop_mode_enable = FALSE;
96
97 dma_init_struct.memory_base_addr = (uint32_t)i2s3_buffer_tx;
98 dma_init_struct.peripheral_base_addr = (uint32_t)&(SPI3->dt);
99 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
100 dma_init(DMA1_CHANNEL2, &dma_init_struct);
101
102 dma_init_struct.memory_base_addr = (uint32_t)i2s2_buffer_rx;
103 dma_init_struct.peripheral_base_addr = (uint32_t)&(SPI2->dt);
104 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
105 dma_init(DMA1_CHANNEL1, &dma_init_struct);
106
107 crm_periph_clock_enable(CRM_SPI3_PERIPH_CLOCK, TRUE);
108 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
109 i2s_default_para_init(&i2s_init_struct);
110 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
111 i2s_init_struct.data_channel_format = I2S_DATA_16BIT_CHANNEL_32BIT;
112 i2s_init_struct.mclk_output_enable = TRUE;
113 i2s_init_struct.audio_sampling_freq = I2S_AUDIO_FREQUENCY_48K;
114 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
115 i2s_init_struct.operation_mode = I2S_MODE_MASTER_TX;
116 i2s_init(SPI3, &i2s_init_struct);
117
118 i2s_init_struct.operation_mode =I2S_MODE_SLAVE_RX;
119 i2s_init(SPI2, &i2s_init_struct);
120
121 dma_channel_enable(DMA1_CHANNEL1, TRUE);
122 dma_channel_enable(DMA1_CHANNEL2, TRUE);
123 spi_i2s_dma_receiver_enable(SPI2, TRUE);
124 spi_i2s_dma_transmitter_enable(SPI3, TRUE);
125 i2s_enable(SPI2, TRUE);
126}
127
133static void gpio_config(void)
134{
135 gpio_init_type gpio_initstructure;
136 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
137 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
138 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
139
140 /* master ws pin */
141 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
142 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
143 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
144 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
145 gpio_initstructure.gpio_pins = GPIO_PINS_4;
146 gpio_init(GPIOA, &gpio_initstructure);
147 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE4, GPIO_MUX_6);
148
149 /* master ck pin */
150 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
151 gpio_initstructure.gpio_pins = GPIO_PINS_10;
152 gpio_init(GPIOC, &gpio_initstructure);
153 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE10, GPIO_MUX_6);
154
155 /* master sd pin */
156 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
157 gpio_initstructure.gpio_pins = GPIO_PINS_12;
158 gpio_init(GPIOC, &gpio_initstructure);
159 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE12, GPIO_MUX_6);
160
161 /* master mck pin */
162 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
163 gpio_initstructure.gpio_pins = GPIO_PINS_7;
164 gpio_init(GPIOC, &gpio_initstructure);
165 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE7, GPIO_MUX_6);
166
167 /* slave ws pin */
168 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
169 gpio_initstructure.gpio_pins = GPIO_PINS_0;
170 gpio_init(GPIOD, &gpio_initstructure);
171 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE0, GPIO_MUX_7);
172
173 /* slave ck pin */
174 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
175 gpio_initstructure.gpio_pins = GPIO_PINS_1;
176 gpio_init(GPIOD, &gpio_initstructure);
177 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_6);
178
179 /* slave sd pin */
180 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
181 gpio_initstructure.gpio_pins = GPIO_PINS_4;
182 gpio_init(GPIOD, &gpio_initstructure);
183 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_6);
184}
185
191int main(void)
192{
193 system_clock_config();
194 at32_board_init();
195 at32_led_off(LED2);
196 at32_led_off(LED3);
197 at32_led_off(LED4);
198 gpio_config();
199 i2s_config();
200 i2s_enable(SPI3, TRUE);
201
202 while(dma_flag_get(DMA1_FDT1_FLAG) == RESET);
203
204 /* test result:the data check */
205 transfer_status = buffer_compare(i2s2_buffer_rx, i2s3_buffer_tx, 32);
206
207 /* test result indicate:if success ,led2 lights */
208 if(transfer_status==SUCCESS)
209 {
210 at32_led_on(LED2);
211 }
212 else
213 {
214 at32_led_off(LED2);
215 }
216 while(1)
217 {
218 }
219}
220
at32f435_437_board.h
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
i2s3_buffer_tx
uint16_t i2s3_buffer_tx[32]
Definition: project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c:38
buffer_compare
error_status buffer_compare(uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function.
Definition: project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c:56
i2s_config
static void i2s_config(void)
i2s configuration.
Definition: project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c:76
main
int main(void)
main function.
Definition: project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c:191
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c:133
transfer_status
volatile error_status transfer_status
Definition: project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c:45
i2s2_buffer_rx
uint16_t i2s2_buffer_rx[32]
Definition: project/at_start_f435/examples/i2s/halfduplex_dma/src/main.c:44
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_SPI3_PERIPH_CLOCK
@ CRM_SPI3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:139
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:138
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_SPI2_RX
@ DMAMUX_DMAREQ_ID_SPI2_RX
Definition: at32f435_437_dma.h:206
DMAMUX_DMAREQ_ID_SPI3_TX
@ DMAMUX_DMAREQ_ID_SPI3_TX
Definition: at32f435_437_dma.h:209
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f435_437_dma.h:66
DMA1MUX_CHANNEL2
#define DMA1MUX_CHANNEL2
Definition: at32f435_437_dma.h:705
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f435_437_dma.h:697
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_6
@ GPIO_MUX_6
Definition: at32f435_437_gpio.h:162
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f435_437_spi.c:350
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f435_437_spi.c:533
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f435_437_spi.c:479
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f435_437_spi.c:332
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f435_437_spi.c:519
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f435_437_spi.h:251
I2S_DATA_16BIT_CHANNEL_32BIT
@ I2S_DATA_16BIT_CHANNEL_32BIT
Definition: at32f435_437_spi.h:230
I2S_AUDIO_FREQUENCY_48K
@ I2S_AUDIO_FREQUENCY_48K
Definition: at32f435_437_spi.h:219
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f435_437_spi.h:200
I2S_MODE_MASTER_TX
@ I2S_MODE_MASTER_TX
Definition: at32f435_437_spi.h:242
I2S_MODE_SLAVE_RX
@ I2S_MODE_SLAVE_RX
Definition: at32f435_437_spi.h:241
SPI3
#define SPI3
Definition: at32f435_437_spi.h:455
SPI2
#define SPI2
Definition: at32f435_437_spi.h:454
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
i2s_init_type
i2s init type
Definition: at32f435_437_spi.h:274
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f435_437_spi.h:277
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f435_437_spi.h:278
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f435_437_spi.h:280
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f435_437_spi.h:276
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f435_437_spi.h:275
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:279
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • i2s
  • halfduplex_interrupt
  • inc
project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • i2s
  • halfduplex_interrupt
  • inc
project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • i2s
  • halfduplex_interrupt
  • inc
project/at_start_f435/examples/i2s/halfduplex_interrupt/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • i2s
  • halfduplex_interrupt
  • src
Functions
project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • i2s
  • halfduplex_interrupt
  • src
project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • i2s
  • halfduplex_interrupt
  • src
Functions | Variables
project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | SPI2_I2S2EXT_IRQHandler (void)
This function handles the spi2 interrupt request. More...
void | SPI3_I2S3EXT_IRQHandler (void)
This function handles the spi3 interrupt request. More...

Variables

uint16_t | i2s3_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
__IO uint32_t | tx_index
__IO uint32_t | rx_index

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • i2s
  • halfduplex_interrupt
  • src
project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
38extern uint16_t i2s3_buffer_tx[32];
39extern uint16_t i2s2_buffer_rx[32];
40extern __IO uint32_t tx_index, rx_index;
41
47void NMI_Handler(void)
48{
49}
50
56void HardFault_Handler(void)
57{
58 /* go to infinite loop when hard fault exception occurs */
59 while(1)
60 {
61 }
62}
63
69void MemManage_Handler(void)
70{
71 /* go to infinite loop when memory manage exception occurs */
72 while(1)
73 {
74 }
75}
76
82void BusFault_Handler(void)
83{
84 /* go to infinite loop when bus fault exception occurs */
85 while(1)
86 {
87 }
88}
89
95void UsageFault_Handler(void)
96{
97 /* go to infinite loop when usage fault exception occurs */
98 while(1)
99 {
100 }
101}
102
108void SVC_Handler(void)
109{
110}
111
117void DebugMon_Handler(void)
118{
119}
120
126void PendSV_Handler(void)
127{
128}
129
135void SysTick_Handler(void)
136{
137}
138
144 void SPI2_I2S2EXT_IRQHandler(void)
145{
146 if(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) != RESET)
147 {
148 i2s2_buffer_rx[rx_index++] = spi_i2s_data_receive(SPI2);
149 }
150}
151
157void SPI3_I2S3EXT_IRQHandler(void)
158{
159 if(spi_i2s_flag_get(SPI3, SPI_I2S_TDBE_FLAG) != RESET)
160 {
161 spi_i2s_data_transmit(SPI3, i2s3_buffer_tx[tx_index++]);
162 if(tx_index == 32)
163 {
164 spi_i2s_interrupt_enable(SPI3, SPI_I2S_TDBE_INT, FALSE);
165 }
166 }
167}
168
i2s3_buffer_tx
uint16_t i2s3_buffer_tx[32]
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c:43
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c:95
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c:56
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c:69
tx_index
__IO uint32_t tx_index
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c:45
SPI3_I2S3EXT_IRQHandler
void SPI3_I2S3EXT_IRQHandler(void)
This function handles the spi3 interrupt request.
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c:157
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c:108
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c:126
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c:47
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c:82
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c:135
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c:117
SPI2_I2S2EXT_IRQHandler
void SPI2_I2S2EXT_IRQHandler(void)
This function handles the spi2 interrupt request.
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c:144
rx_index
__IO uint32_t rx_index
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c:40
i2s2_buffer_rx
uint16_t i2s2_buffer_rx[32]
Definition: project/at_start_f435/examples/i2s/fullduplex_dma/src/main.c:42
FALSE
@ FALSE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f435_437_spi.h:54
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f435_437_spi.h:53
SPI_I2S_TDBE_INT
#define SPI_I2S_TDBE_INT
Definition: at32f435_437_spi.h:75
spi_i2s_interrupt_enable
void spi_i2s_interrupt_enable(spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts.
Definition: at32f435_437_spi.c:498
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f435_437_spi.c:548
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f435_437_spi.c:583
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f435_437_spi.c:560
SPI3
#define SPI3
Definition: at32f435_437_spi.h:455
SPI2
#define SPI2
Definition: at32f435_437_spi.h:454
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • i2s
  • halfduplex_interrupt
  • src
Functions | Variables
project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | i2s_config (i2s_data_channel_format_type format, i2s_audio_sampling_freq_type freq)
i2s configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function. More...
error_status | buffer_compare_24bits (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare_24bits function. More...
int | main (void)
main function. More...

Variables

uint16_t | i2s3_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
__IO uint32_t | tx_index = 0
__IO uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • i2s
  • halfduplex_interrupt
  • src
project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38uint16_t i2s3_buffer_tx[32] = {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C,
39 0x0D0E, 0x0F10, 0x1112, 0x1314, 0x1516, 0x1718,
40 0x191A, 0x1B1C, 0x1D1E, 0x1F20, 0x2122, 0x2324,
41 0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
42 0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C,
43 0x3D3E, 0x3F40};
44uint16_t i2s2_buffer_rx[32];
45__IO uint32_t tx_index = 0, rx_index = 0;
46volatile error_status transfer_status1 = ERROR, transfer_status2 = ERROR;
47
48static void gpio_config(void);
49static void i2s_config(i2s_data_channel_format_type format, i2s_audio_sampling_freq_type freq);
50 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length);
51 error_status buffer_compare_24bits(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length);
52
58 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length)
59{
60 while(buffer_length--)
61 {
62 if(*pbuffer1 != *pbuffer2)
63 {
64 return ERROR;
65 }
66
67 pbuffer1++;
68 pbuffer2++;
69 }
70 return SUCCESS;
71}
72
78 error_status buffer_compare_24bits(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length)
79{
80 while(buffer_length--)
81 {
82 if(*pbuffer1 != *pbuffer2)
83 {
84 if(*pbuffer1 != (*pbuffer2 & 0xFF00))
85 {
86 return ERROR;
87 }
88 }
89
90 pbuffer1++;
91 pbuffer2++;
92 }
93 return SUCCESS;
94}
95
101static void i2s_config(i2s_data_channel_format_type format, i2s_audio_sampling_freq_type freq)
102{
103 i2s_init_type i2s_init_struct;
104
105 crm_periph_clock_enable(CRM_SPI3_PERIPH_CLOCK, TRUE);
106 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
107
108 nvic_irq_enable(SPI3_I2S3EXT_IRQn, 0, 0);
109 nvic_irq_enable(SPI2_I2S2EXT_IRQn, 0, 0);
110 spi_i2s_reset(SPI2);
111 spi_i2s_reset(SPI3);
112 i2s_default_para_init(&i2s_init_struct);
113 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
114 i2s_init_struct.data_channel_format = format;
115 i2s_init_struct.mclk_output_enable = TRUE;
116 i2s_init_struct.audio_sampling_freq = freq;
117 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
118 i2s_init_struct.operation_mode = I2S_MODE_MASTER_TX;
119 i2s_init(SPI3, &i2s_init_struct);
120
121 i2s_init_struct.operation_mode =I2S_MODE_SLAVE_RX;
122 i2s_init(SPI2, &i2s_init_struct);
123
124 spi_i2s_interrupt_enable(SPI2, SPI_I2S_RDBF_INT, TRUE);
125 spi_i2s_interrupt_enable(SPI3, SPI_I2S_TDBE_INT, TRUE);
126 i2s_enable(SPI2, TRUE);
127 i2s_enable(SPI3, TRUE);
128}
129
135static void gpio_config(void)
136{
137 gpio_init_type gpio_initstructure;
138 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
139 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
140 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
141 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
142
143 /* master ws pin */
144 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
145 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
146 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
147 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
148 gpio_initstructure.gpio_pins = GPIO_PINS_15;
149 gpio_init(GPIOA, &gpio_initstructure);
150 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE15, GPIO_MUX_6);
151
152 /* master ck pin */
153 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
154 gpio_initstructure.gpio_pins = GPIO_PINS_3;
155 gpio_init(GPIOB, &gpio_initstructure);
156 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE3, GPIO_MUX_6);
157
158 /* master sd pin */
159 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
160 gpio_initstructure.gpio_pins = GPIO_PINS_5;
161 gpio_init(GPIOB, &gpio_initstructure);
162 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE5, GPIO_MUX_6);
163
164 /* master mck pin */
165 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
166 gpio_initstructure.gpio_pins = GPIO_PINS_7;
167 gpio_init(GPIOC, &gpio_initstructure);
168 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE7, GPIO_MUX_6);
169
170 /* slave ws pin */
171 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
172 gpio_initstructure.gpio_pins = GPIO_PINS_0;
173 gpio_init(GPIOD, &gpio_initstructure);
174 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE0, GPIO_MUX_7);
175
176 /* slave ck pin */
177 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
178 gpio_initstructure.gpio_pins = GPIO_PINS_1;
179 gpio_init(GPIOD, &gpio_initstructure);
180 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_6);
181
182 /* slave sd pin */
183 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
184 gpio_initstructure.gpio_pins = GPIO_PINS_4;
185 gpio_init(GPIOD, &gpio_initstructure);
186 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_6);
187}
188
194int main(void)
195{
196 __IO uint32_t index = 0;
197 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
198 system_clock_config();
199 at32_board_init();
200 at32_led_off(LED2);
201 at32_led_off(LED3);
202 at32_led_off(LED4);
203 gpio_config();
204 i2s_config(I2S_DATA_16BIT_CHANNEL_32BIT, I2S_AUDIO_FREQUENCY_48K);
205 while(rx_index < 32);
206
207 /* test result:the data check */
208 transfer_status1 = buffer_compare(i2s2_buffer_rx, i2s3_buffer_tx, 32);
209
210 for(index = 0; index < 32; index++) i2s2_buffer_rx[index] = 0;
211 tx_index = 0;
212 rx_index = 0;
213
214 i2s_config(I2S_DATA_24BIT_CHANNEL_32BIT, I2S_AUDIO_FREQUENCY_16K);
215 while(rx_index < 32);
216
217 /* test result:the data check */
218 transfer_status2 = buffer_compare_24bits(i2s2_buffer_rx, i2s3_buffer_tx, 32);
219
220 /* test result indicate:if success ,led2 lights */
221 if((transfer_status1 == SUCCESS) && (transfer_status2 == SUCCESS))
222 {
223 at32_led_on(LED2);
224 }
225 else
226 {
227 at32_led_off(LED2);
228 }
229
230 while(1)
231 {
232 }
233}
234
at32f435_437_board.h
i2s3_buffer_tx
uint16_t i2s3_buffer_tx[32]
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c:38
buffer_compare
error_status buffer_compare(uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function.
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c:58
tx_index
__IO uint32_t tx_index
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c:45
transfer_status1
volatile error_status transfer_status1
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c:46
i2s_config
static void i2s_config(i2s_data_channel_format_type format, i2s_audio_sampling_freq_type freq)
i2s configuration.
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c:101
transfer_status2
volatile error_status transfer_status2
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c:46
main
int main(void)
main function.
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c:194
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c:135
buffer_compare_24bits
error_status buffer_compare_24bits(uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare_24bits function.
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c:78
rx_index
__IO uint32_t rx_index
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c:45
i2s2_buffer_rx
uint16_t i2s2_buffer_rx[32]
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c:44
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_SPI3_PERIPH_CLOCK
@ CRM_SPI3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:139
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:138
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_6
@ GPIO_MUX_6
Definition: at32f435_437_gpio.h:162
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
SPI_I2S_TDBE_INT
#define SPI_I2S_TDBE_INT
Definition: at32f435_437_spi.h:75
SPI_I2S_RDBF_INT
#define SPI_I2S_RDBF_INT
Definition: at32f435_437_spi.h:74
spi_i2s_interrupt_enable
void spi_i2s_interrupt_enable(spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts.
Definition: at32f435_437_spi.c:498
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f435_437_spi.c:350
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f435_437_spi.c:479
spi_i2s_reset
void spi_i2s_reset(spi_type *spi_x)
spi reset by crm reset register
Definition: at32f435_437_spi.c:51
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f435_437_spi.c:332
i2s_data_channel_format_type
i2s_data_channel_format_type
i2s data bit num and channel bit num type
Definition: at32f435_437_spi.h:228
i2s_audio_sampling_freq_type
i2s_audio_sampling_freq_type
i2s audio frequency type
Definition: at32f435_437_spi.h:211
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f435_437_spi.h:251
I2S_DATA_24BIT_CHANNEL_32BIT
@ I2S_DATA_24BIT_CHANNEL_32BIT
Definition: at32f435_437_spi.h:231
I2S_DATA_16BIT_CHANNEL_32BIT
@ I2S_DATA_16BIT_CHANNEL_32BIT
Definition: at32f435_437_spi.h:230
I2S_AUDIO_FREQUENCY_48K
@ I2S_AUDIO_FREQUENCY_48K
Definition: at32f435_437_spi.h:219
I2S_AUDIO_FREQUENCY_16K
@ I2S_AUDIO_FREQUENCY_16K
Definition: at32f435_437_spi.h:215
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f435_437_spi.h:200
I2S_MODE_MASTER_TX
@ I2S_MODE_MASTER_TX
Definition: at32f435_437_spi.h:242
I2S_MODE_SLAVE_RX
@ I2S_MODE_SLAVE_RX
Definition: at32f435_437_spi.h:241
SPI3
#define SPI3
Definition: at32f435_437_spi.h:455
SPI2
#define SPI2
Definition: at32f435_437_spi.h:454
SPI2_I2S2EXT_IRQn
@ SPI2_I2S2EXT_IRQn
Definition: at32f435_437.h:184
SPI3_I2S3EXT_IRQn
@ SPI3_I2S3EXT_IRQn
Definition: at32f435_437.h:199
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
i2s_init_type
i2s init type
Definition: at32f435_437_spi.h:274
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f435_437_spi.h:277
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f435_437_spi.h:278
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f435_437_spi.h:280
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f435_437_spi.h:276
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f435_437_spi.h:275
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:279
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • i2s
  • spii2s_switch_halfduplex_polling
  • src
Functions
project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • i2s
  • spii2s_switch_halfduplex_polling
  • src
project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • i2s
  • spii2s_switch_halfduplex_polling
  • src
Functions
project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • i2s
  • spii2s_switch_halfduplex_polling
  • src
project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • i2s
  • spii2s_switch_halfduplex_polling
  • src
Functions | Variables
project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
static void | i2s_config (i2s_operation_mode_type i2s3_mode, i2s_operation_mode_type i2s2_mode)
i2s configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function. More...
int | main (void)
main function. More...

Variables

uint16_t | i2s3_buffer_tx [32]
uint16_t | spi3_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
uint16_t | spi2_buffer_rx [32]
__IO uint32_t | tx_index = 0
__IO uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR
volatile error_status | transfer_status3 = ERROR

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • i2s
  • spii2s_switch_halfduplex_polling
  • src
project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38uint16_t i2s3_buffer_tx[32] = {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C,
39 0x0D0E, 0x0F10, 0x1112, 0x1314, 0x1516, 0x1718,
40 0x191A, 0x1B1C, 0x1D1E, 0x1F20, 0x2122, 0x2324,
41 0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
42 0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C,
43 0x3D3E, 0x3F40
44 };
45uint16_t spi3_buffer_tx[32] = {0x5152, 0x5354, 0x5556, 0x5758, 0x595A, 0x5B5C,
46 0x5D5E, 0x5F60, 0x6162, 0x6364, 0x6566, 0x6768,
47 0x696A, 0x6B6C, 0x6D6E, 0x6F70, 0x7172, 0x7374,
48 0x7576, 0x7778, 0x797A, 0x7B7C, 0x7D7E, 0x7F80,
49 0x8182, 0x8384, 0x8586, 0x8788, 0x898A, 0x8B8C,
50 0x8D8E, 0x8F90
51 };
52uint16_t i2s2_buffer_rx[32];
53uint16_t spi2_buffer_rx[32];
54__IO uint32_t tx_index = 0, rx_index = 0;
55volatile error_status transfer_status1 = ERROR, transfer_status2 = ERROR, transfer_status3 = ERROR;
56
57static void gpio_config(void);
58static void spi_config(void);
59static void i2s_config(i2s_operation_mode_type i2s3_mode, i2s_operation_mode_type i2s2_mode);
60 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length);
61
67 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length)
68{
69 while(buffer_length--)
70 {
71 if(*pbuffer1 != *pbuffer2)
72 {
73 return ERROR;
74 }
75
76 pbuffer1++;
77 pbuffer2++;
78 }
79 return SUCCESS;
80}
81
87static void i2s_config(i2s_operation_mode_type i2s3_mode, i2s_operation_mode_type i2s2_mode)
88{
89 i2s_init_type i2s_init_struct;
90
91 crm_periph_clock_enable(CRM_SPI3_PERIPH_CLOCK, TRUE);
92 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
93
94 spi_i2s_reset(SPI2);
95 spi_i2s_reset(SPI3);
96 i2s_default_para_init(&i2s_init_struct);
97 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
98 i2s_init_struct.data_channel_format = I2S_DATA_16BIT_CHANNEL_32BIT;
99 i2s_init_struct.mclk_output_enable = FALSE;
100 i2s_init_struct.audio_sampling_freq = I2S_AUDIO_FREQUENCY_48K;
101 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
102 i2s_init_struct.operation_mode = i2s3_mode;
103 i2s_init(SPI3, &i2s_init_struct);
104
105 i2s_init_struct.operation_mode =i2s2_mode;
106 i2s_init(SPI2, &i2s_init_struct);
107}
108
114static void spi_config(void)
115{
116 spi_init_type spi_init_struct;
117 crm_periph_clock_enable(CRM_SPI3_PERIPH_CLOCK, TRUE);
118 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
119
120 spi_i2s_reset(SPI2);
121 spi_i2s_reset(SPI3);
122 spi_default_para_init(&spi_init_struct);
123 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_TX;
124 spi_init_struct.master_slave_mode =SPI_MODE_MASTER;
125 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_8;
126 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_MSB;
127 spi_init_struct.frame_bit_num = SPI_FRAME_16BIT;
128 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_LOW;
129 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
130 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
131 spi_init(SPI3, &spi_init_struct);
132
133 spi_init_struct.transmission_mode = SPI_TRANSMIT_SIMPLEX_RX;
134 spi_init_struct.master_slave_mode =SPI_MODE_SLAVE;
135 spi_init(SPI2, &spi_init_struct);
136
137 spi_enable(SPI2, TRUE);
138 spi_enable(SPI3, TRUE);
139}
140
146static void gpio_config(void)
147{
148 gpio_init_type gpio_initstructure;
149 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
150 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
151 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
152
153 /* spi3/i2s3 ws pin */
154 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
155 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
156 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
157 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
158 gpio_initstructure.gpio_pins = GPIO_PINS_15;
159 gpio_init(GPIOA, &gpio_initstructure);
160 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE15, GPIO_MUX_6);
161
162 /* spi3/i2s3 ck pin */
163 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
164 gpio_initstructure.gpio_pins = GPIO_PINS_3;
165 gpio_init(GPIOB, &gpio_initstructure);
166 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE3, GPIO_MUX_6);
167
168 /* spi3/i2s3 sd pin */
169 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
170 gpio_initstructure.gpio_pins = GPIO_PINS_5;
171 gpio_init(GPIOB, &gpio_initstructure);
172 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE5, GPIO_MUX_6);
173
174 /* spi2/i2s2 ws pin */
175 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
176 gpio_initstructure.gpio_pins = GPIO_PINS_0;
177 gpio_init(GPIOD, &gpio_initstructure);
178 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE0, GPIO_MUX_7);
179
180 /* spi2/i2s2 ck pin */
181 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
182 gpio_initstructure.gpio_pins = GPIO_PINS_1;
183 gpio_init(GPIOD, &gpio_initstructure);
184 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_6);
185
186 /* spi2/i2s2 sd pin */
187 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
188 gpio_initstructure.gpio_pins = GPIO_PINS_4;
189 gpio_init(GPIOD, &gpio_initstructure);
190 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_6);
191}
192
198int main(void)
199{
200 __IO uint32_t index = 0;
201 system_clock_config();
202 at32_board_init();
203 at32_led_off(LED2);
204 at32_led_off(LED3);
205 at32_led_off(LED4);
206 gpio_config();
207 i2s_config(I2S_MODE_MASTER_TX, I2S_MODE_SLAVE_RX);
208 i2s_enable(SPI2, TRUE);
209 i2s_enable(SPI3, TRUE);
210 while(rx_index < 32)
211 {
212 while(spi_i2s_flag_get(SPI3, SPI_I2S_TDBE_FLAG) == RESET);
213 spi_i2s_data_transmit(SPI3, i2s3_buffer_tx[tx_index++]);
214 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
215 i2s2_buffer_rx[rx_index++] = spi_i2s_data_receive(SPI2);
216 }
217
218 /* test result:the data check */
219 transfer_status1 = buffer_compare(i2s2_buffer_rx, i2s3_buffer_tx, 32);
220
221 tx_index = 0;
222 rx_index = 0;
223 spi_config();
224 while(rx_index < 32)
225 {
226 while(spi_i2s_flag_get(SPI3, SPI_I2S_TDBE_FLAG) == RESET);
227 spi_i2s_data_transmit(SPI3, spi3_buffer_tx[tx_index++]);
228 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
229 spi2_buffer_rx[rx_index++] = spi_i2s_data_receive(SPI2);
230 }
231
232 /* test result:the data check */
233 transfer_status2 = buffer_compare(spi2_buffer_rx, spi3_buffer_tx, 32);
234
235 for(index = 0; index < 32; index++) i2s2_buffer_rx[index] = 0;
236 tx_index = 0;
237 rx_index = 0;
238 i2s_config(I2S_MODE_SLAVE_TX, I2S_MODE_MASTER_RX);
239 while(spi_i2s_flag_get(SPI3, SPI_I2S_TDBE_FLAG) == RESET);
240 spi_i2s_data_transmit(SPI3, i2s3_buffer_tx[tx_index++]);
241 i2s_enable(SPI3, TRUE);
242 i2s_enable(SPI2, TRUE);
243 while(rx_index < 32)
244 {
245 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
246 i2s2_buffer_rx[rx_index++] = spi_i2s_data_receive(SPI2);
247 while(spi_i2s_flag_get(SPI3, SPI_I2S_TDBE_FLAG) == RESET);
248 spi_i2s_data_transmit(SPI3, i2s3_buffer_tx[tx_index++]);
249 }
250
251 /* test result:the data check */
252 transfer_status3 = buffer_compare(i2s2_buffer_rx, i2s3_buffer_tx, 32);
253
254 /* test result indicate:if success ,led2 lights */
255 if((transfer_status1 == SUCCESS) && (transfer_status2 == SUCCESS) && (transfer_status3 == SUCCESS))
256 {
257 at32_led_on(LED2);
258 }
259 else
260 {
261 at32_led_off(LED2);
262 }
263 while(1)
264 {
265 }
266}
267
at32f435_437_board.h
i2s3_buffer_tx
uint16_t i2s3_buffer_tx[32]
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:38
buffer_compare
error_status buffer_compare(uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function.
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:67
tx_index
__IO uint32_t tx_index
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:54
transfer_status3
volatile error_status transfer_status3
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:55
spi3_buffer_tx
uint16_t spi3_buffer_tx[32]
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:45
spi_config
static void spi_config(void)
spi configuration.
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:114
transfer_status1
volatile error_status transfer_status1
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:55
transfer_status2
volatile error_status transfer_status2
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:55
main
int main(void)
main function.
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:198
i2s_config
static void i2s_config(i2s_operation_mode_type i2s3_mode, i2s_operation_mode_type i2s2_mode)
i2s configuration.
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:87
spi2_buffer_rx
uint16_t spi2_buffer_rx[32]
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:53
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:146
rx_index
__IO uint32_t rx_index
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:54
i2s2_buffer_rx
uint16_t i2s2_buffer_rx[32]
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:52
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:40
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_SPI3_PERIPH_CLOCK
@ CRM_SPI3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:139
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:138
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_6
@ GPIO_MUX_6
Definition: at32f435_437_gpio.h:162
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f435_437_spi.h:54
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f435_437_spi.h:53
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f435_437_spi.c:350
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f435_437_spi.c:548
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f435_437_spi.c:583
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f435_437_spi.c:479
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f435_437_spi.c:101
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f435_437_spi.c:81
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f435_437_spi.c:560
spi_i2s_reset
void spi_i2s_reset(spi_type *spi_x)
spi reset by crm reset register
Definition: at32f435_437_spi.c:51
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f435_437_spi.c:332
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f435_437_spi.c:321
i2s_operation_mode_type
i2s_operation_mode_type
i2s operation mode type
Definition: at32f435_437_spi.h:239
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f435_437_spi.h:251
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f435_437_spi.h:99
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f435_437_spi.h:100
I2S_DATA_16BIT_CHANNEL_32BIT
@ I2S_DATA_16BIT_CHANNEL_32BIT
Definition: at32f435_437_spi.h:230
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f435_437_spi.h:118
I2S_AUDIO_FREQUENCY_48K
@ I2S_AUDIO_FREQUENCY_48K
Definition: at32f435_437_spi.h:219
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f435_437_spi.h:127
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f435_437_spi.h:153
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f435_437_spi.h:108
SPI_TRANSMIT_HALF_DUPLEX_TX
@ SPI_TRANSMIT_HALF_DUPLEX_TX
Definition: at32f435_437_spi.h:165
SPI_TRANSMIT_SIMPLEX_RX
@ SPI_TRANSMIT_SIMPLEX_RX
Definition: at32f435_437_spi.h:163
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f435_437_spi.h:200
SPI_MCLK_DIV_8
@ SPI_MCLK_DIV_8
Definition: at32f435_437_spi.h:138
SPI_FRAME_16BIT
@ SPI_FRAME_16BIT
Definition: at32f435_437_spi.h:91
I2S_MODE_MASTER_TX
@ I2S_MODE_MASTER_TX
Definition: at32f435_437_spi.h:242
I2S_MODE_MASTER_RX
@ I2S_MODE_MASTER_RX
Definition: at32f435_437_spi.h:243
I2S_MODE_SLAVE_RX
@ I2S_MODE_SLAVE_RX
Definition: at32f435_437_spi.h:241
I2S_MODE_SLAVE_TX
@ I2S_MODE_SLAVE_TX
Definition: at32f435_437_spi.h:240
SPI3
#define SPI3
Definition: at32f435_437_spi.h:455
SPI2
#define SPI2
Definition: at32f435_437_spi.h:454
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
i2s_init_type
i2s init type
Definition: at32f435_437_spi.h:274
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f435_437_spi.h:277
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f435_437_spi.h:278
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f435_437_spi.h:280
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f435_437_spi.h:276
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f435_437_spi.h:275
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:279
spi_init_type
spi init type
Definition: at32f435_437_spi.h:259
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f435_437_spi.h:261
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f435_437_spi.h:263
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f435_437_spi.h:264
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:265
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f435_437_spi.h:267
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f435_437_spi.h:262
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f435_437_spi.h:260
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f435_437_spi.h:266
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • irtmr
  • irtmr_output
  • inc
project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • irtmr
  • irtmr_output
  • inc
project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • irtmr
  • irtmr_output
  • inc
project/at_start_f435/examples/irtmr/irtmr_output/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • irtmr
  • irtmr_output
  • src
Functions
project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • irtmr
  • irtmr_output
  • src
project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • irtmr
  • irtmr_output
  • src
Functions
project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • irtmr
  • irtmr_output
  • src
project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • irtmr
  • irtmr_output
  • src
Functions | Variables
project/at_start_f435/examples/irtmr/irtmr_output/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different system clocks. More...
void | gpio_configuration (void)
configure the tmr10 pin and irtmr pin. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | ccr1_val = 249
uint16_t | ccr2_val = 24
uint16_t | prescalervalue = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/irtmr/irtmr_output/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • irtmr
  • irtmr_output
  • src
project/at_start_f435/examples/irtmr/irtmr_output/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 tmr_output_config_type tmr_oc_init_structure;
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40
41uint16_t ccr1_val = 249;
42uint16_t ccr2_val = 24;
43uint16_t prescalervalue = 0;
44
45void crm_configuration(void);
46void gpio_configuration(void);
47
53int main(void)
54{
55 system_clock_config();
56
57 /* system clocks configuration */
58 crm_configuration();
59
60 /* get system clock */
61 crm_clocks_freq_get(&crm_clocks_freq_struct);
62
63 /* gpio configuration */
64 gpio_configuration();
65
66 /* irtmr configuration */
67 scfg_infrared_config(SCFG_IR_SOURCE_TMR10, SCFG_IR_POLARITY_NO_AFFECTE);
68
69 /* compute the prescaler value */
70 prescalervalue = (uint16_t) ((crm_clocks_freq_struct.apb1_freq * 2) / 1000000) - 1;
71
72 /* tmr10 time base configuration */
73 tmr_base_init(TMR10, 665, prescalervalue);
74 tmr_cnt_dir_set(TMR10, TMR_COUNT_UP);
75 tmr_clock_source_div_set(TMR10, TMR_CLOCK_DIV1);
76
77 tmr_output_default_para_init(&tmr_oc_init_structure);
78 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
79 tmr_oc_init_structure.oc_idle_state = FALSE;
80 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
81 tmr_oc_init_structure.oc_output_state = TRUE;
82 tmr_output_channel_config(TMR10, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
83 tmr_channel_value_set(TMR10, TMR_SELECT_CHANNEL_1, ccr1_val);
84 tmr_output_channel_buffer_enable(TMR10, TMR_SELECT_CHANNEL_1, TRUE);
85
86 tmr_period_buffer_enable(TMR10, TRUE);
87
88 /* tmr11 time base configuration */
89 tmr_base_init(TMR11, 65, prescalervalue);
90 tmr_cnt_dir_set(TMR11, TMR_COUNT_UP);
91 tmr_clock_source_div_set(TMR11, TMR_CLOCK_DIV1);
92
93 tmr_output_default_para_init(&tmr_oc_init_structure);
94 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
95 tmr_oc_init_structure.oc_idle_state = FALSE;
96 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
97 tmr_oc_init_structure.oc_output_state = TRUE;
98 tmr_output_channel_config(TMR11, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
99 tmr_channel_value_set(TMR11, TMR_SELECT_CHANNEL_1, ccr2_val);
100 tmr_output_channel_buffer_enable(TMR11, TMR_SELECT_CHANNEL_1, TRUE);
101
102 tmr_period_buffer_enable(TMR11, TRUE);
103
104 /* tmr enable counter */
105 tmr_counter_enable(TMR10, TRUE);
106 tmr_counter_enable(TMR11, TRUE);
107
108 while(1)
109 {
110 }
111}
112
118void gpio_configuration(void)
119{
120 gpio_init_type gpio_init_struct;
121
122 gpio_default_para_init(&gpio_init_struct);
123
124 gpio_init_struct.gpio_pins = GPIO_PINS_8 | GPIO_PINS_9;
125 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
126 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
127 gpio_init(GPIOB, &gpio_init_struct);
128
129 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE8, GPIO_MUX_3);
130 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE9, GPIO_MUX_0);
131}
132
138void crm_configuration(void)
139{
140 /* tmr10 clock enable */
141 crm_periph_clock_enable(CRM_TMR10_PERIPH_CLOCK, TRUE);
142
143 /* tmr11 clock enable */
144 crm_periph_clock_enable(CRM_TMR11_PERIPH_CLOCK, TRUE);
145
146 /* gpioa gpiob clock enable */
147 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
148
149 /* gpioa scfg clock enable */
150 crm_periph_clock_enable(CRM_SCFG_PERIPH_CLOCK, TRUE);
151}
152
153
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
ccr1_val
uint16_t ccr1_val
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/main.c:41
prescalervalue
uint16_t prescalervalue
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/main.c:43
ccr2_val
uint16_t ccr2_val
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/main.c:42
main
int main(void)
main function.
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/main.c:53
gpio_configuration
void gpio_configuration(void)
configure the tmr10 pin and irtmr pin.
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/main.c:118
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/main.c:38
crm_configuration
void crm_configuration(void)
configures the different system clocks.
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/main.c:138
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_TMR10_PERIPH_CLOCK
@ CRM_TMR10_PERIPH_CLOCK
Definition: at32f435_437_crm.h:165
CRM_SCFG_PERIPH_CLOCK
@ CRM_SCFG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:163
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_TMR11_PERIPH_CLOCK
@ CRM_TMR11_PERIPH_CLOCK
Definition: at32f435_437_crm.h:166
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_MUX_0
@ GPIO_MUX_0
Definition: at32f435_437_gpio.h:156
GPIO_MUX_3
@ GPIO_MUX_3
Definition: at32f435_437_gpio.h:159
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
scfg_infrared_config
void scfg_infrared_config(scfg_ir_source_type source, scfg_ir_polarity_type polarity)
scfg infrared config
Definition: at32f435_437_scfg.c:83
SCFG_IR_SOURCE_TMR10
@ SCFG_IR_SOURCE_TMR10
Definition: at32f435_437_scfg.h:70
SCFG_IR_POLARITY_NO_AFFECTE
@ SCFG_IR_POLARITY_NO_AFFECTE
Definition: at32f435_437_scfg.h:80
tmr_period_buffer_enable
void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
set tmr period buffer
Definition: at32f435_437_tmr.c:638
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_output_channel_buffer_enable
void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel buffer
Definition: at32f435_437_tmr.c:660
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f435_437_tmr.h:97
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f435_437_tmr.h:180
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:198
TMR10
#define TMR10
Definition: at32f435_437_tmr.h:904
TMR11
#define TMR11
Definition: at32f435_437_tmr.h:905
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f435_437_crm.h:792
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_alarm
  • inc
project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_alarm
  • inc
project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_alarm
  • inc
project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_alarm
  • src
Functions
project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_alarm
  • src
project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_alarm
  • src
Functions
project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ERTCAlarm_IRQHandler (void)
this function handles ertc alarms interrupt request. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_alarm
  • src
project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29#include "at32f435_437_board.h"
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
141void ERTCAlarm_IRQHandler(void)
142{
143 if(ertc_flag_get(ERTC_ALAF_FLAG) != RESET)
144 {
145 /* clear ertc alarm flag */
146 ertc_flag_clear(ERTC_ALAF_FLAG);
147
148 /* clear exint line flag */
149 exint_flag_clear(EXINT_LINE_17);
150
151 /* toggle led */
152 at32_led_toggle(LED4);
153 }
154}
155
at32f435_437_board.h
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c:114
ERTCAlarm_IRQHandler
void ERTCAlarm_IRQHandler(void)
this function handles ertc alarms interrupt request.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/at32f435_437_int.c:141
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
ertc_flag_get
flag_status ertc_flag_get(uint32_t flag)
get flag status.
Definition: at32f435_437_ertc.c:1474
ertc_flag_clear
void ertc_flag_clear(uint32_t flag)
clear flag status
Definition: at32f435_437_ertc.c:1507
ERTC_ALAF_FLAG
#define ERTC_ALAF_FLAG
Definition: at32f435_437_ertc.h:74
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
EXINT_LINE_17
#define EXINT_LINE_17
Definition: at32f435_437_exint.h:69
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_alarm
  • src
Functions
project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | ertc_config (void)
ertc configuration. More...
void | ertc_alarm_config (void)
ertc alarm configuration. More...
void | ertc_alarm_value_set (uint32_t alam_index)
ertc alarm value set. More...
void | system_clock_recover (void)
system clock recover. More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_alarm
  • src
project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
43void ertc_config(void)
44{
45 /* enable the pwc clock interface */
46 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
47
48 /* allow access to ertc */
49 pwc_battery_powered_domain_access(TRUE);
50
51 /* reset ertc domain */
52 crm_battery_powered_domain_reset(TRUE);
53 crm_battery_powered_domain_reset(FALSE);
54
55 /* enable the lext osc */
56 crm_clock_source_enable(CRM_CLOCK_SOURCE_LEXT, TRUE);
57
58 /* wait till lext is ready */
59 while(crm_flag_get(CRM_LEXT_STABLE_FLAG) == RESET);
60
61 /* select the ertc clock source */
62 crm_ertc_clock_select(CRM_ERTC_CLOCK_LEXT);
63
64 /* enable the ertc clock */
65 crm_ertc_clock_enable(TRUE);
66
67 /* deinitializes the ertc registers */
68 ertc_reset();
69
70 /* wait for ertc apb registers synchronisation */
71 ertc_wait_update();
72
73 /* configure the ertc data register and ertc prescaler
74 ck_spre(1hz) = ertcclk(lext) /(ertc_clk_div_a + 1)*(ertc_clk_div_b + 1)*/
75 ertc_divider_set(127, 255);
76
77 /* configure the hour format is 24-hour format*/
78 ertc_hour_mode_set(ERTC_HOUR_MODE_24);
79
80 /* set the date: friday june 11th 2021 */
81 ertc_date_set(21, 6, 11, 5);
82
83 /* set the time to 06h 20mn 00s am */
84 ertc_time_set(6, 20, 0, ERTC_AM);
85}
86
92void ertc_alarm_config(void)
93{
94 exint_init_type exint_init_struct;
95
96 /* config the exint line of the ertc alarm */
97 exint_init_struct.line_select = EXINT_LINE_17;
98 exint_init_struct.line_enable = TRUE;
99 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
100 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
101 exint_init(&exint_init_struct);
102
103 /* set the alarm 05h:20min:10s */
104 ertc_alarm_mask_set(ERTC_ALA, ERTC_ALARM_MASK_DATE_WEEK | ERTC_ALARM_MASK_HOUR | ERTC_ALARM_MASK_MIN);
105 ertc_alarm_week_date_select(ERTC_ALA, ERTC_SLECT_DATE);
106 ertc_alarm_set(ERTC_ALA, 31, 6, 20, 5, ERTC_AM);
107
108 /* enable the ertc interrupt */
109 nvic_irq_enable(ERTCAlarm_IRQn, 0, 0);
110
111 /* enable ertc alarm a interrupt */
112 ertc_interrupt_enable(ERTC_ALA_INT, TRUE);
113
114 /* enable the alarm */
115 ertc_alarm_enable(ERTC_ALA, TRUE);
116}
117
123void ertc_alarm_value_set(uint32_t alam_index)
124{
125 ertc_time_type ertc_time_struct;
126
127 /* disable the alarm */
128 ertc_alarm_enable(ERTC_ALA, FALSE);
129 ertc_calendar_get(&ertc_time_struct);
130 ertc_alarm_set(ERTC_ALA, ertc_time_struct.day, ertc_time_struct.hour, ertc_time_struct.min, (ertc_time_struct.sec + alam_index)% 60, ertc_time_struct.ampm);
131
132 /* disable the alarm */
133 ertc_alarm_enable(ERTC_ALA, TRUE);
134}
135
141void system_clock_recover(void)
142{
143 /* enable external high-speed crystal oscillator - hext */
144 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
145
146 /* wait till hext is ready */
147 while(crm_hext_stable_wait() == ERROR);
148
149 /* enable pll */
150 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
151
152 /* wait till pll is ready */
153 while(crm_flag_get(CRM_PLL_STABLE_FLAG) == RESET);
154
155 /* enable auto step mode */
156 crm_auto_step_mode_enable(TRUE);
157
158 /* select pll as system clock source */
159 crm_sysclk_switch(CRM_SCLK_PLL);
160
161 /* wait till pll is used as system clock source */
162 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL);
163}
164
170int main(void)
171{
172 __IO uint32_t systick_index = 0;
173 __IO uint32_t delay_index = 0;
174
175 /* congfig the system clock */
176 system_clock_config();
177
178 /* init at start board */
179 at32_board_init();
180
181 /* config priority group */
182 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
183
184 /* enable pwc and bpr clock */
185 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
186
187 /* config ertc */
188 ertc_config();
189
190 /* set the wakeup time: 06h:20min:5s */
191 ertc_alarm_config();
192
193 while(1)
194 {
195 /* turn off the led light */
196 at32_led_off(LED2);
197
198 /* save systick register configuration */
199 systick_index = SysTick->CTRL;
200 systick_index &= ~((uint32_t)0xFFFFFFFE);
201
202 /* disable systick */
203 SysTick->CTRL &= (uint32_t)0xFFFFFFFE;
204
205 ertc_alarm_value_set(1);
206
207 /* select system clock source as hick before ldo set */
208 crm_sysclk_switch(CRM_SCLK_HICK);
209
210 /* wait till hick is used as system clock source */
211 while(crm_sysclk_switch_status_get() != CRM_SCLK_HICK)
212 {
213 }
214
215 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V0);
216
217 /* congfig the voltage regulator mode */
218 pwc_voltage_regulate_set(PWC_REGULATOR_LOW_POWER);
219
220 /* enter deep sleep mode */
221 pwc_deep_sleep_mode_enter(PWC_DEEP_SLEEP_ENTER_WFI);
222
223 /* wake up from deep sleep mode, restore systick register configuration */
224 SysTick->CTRL |= systick_index;
225
226 /* turn on the led light */
227 at32_led_on(LED2);
228
229 /* wait clock stable */
230 for(delay_index = 0; delay_index < 600; delay_index++)
231 {
232 __NOP();
233 }
234
235 /* resume ldo before system clock source enhance */
236 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
237
238 /* congfig the system clock */
239 system_clock_recover();
240
241 delay_ms(500);
242 }
243}
244
at32f435_437_board.h
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:41
main
int main(void)
main function.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c:170
ertc_config
void ertc_config(void)
ertc configuration.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c:43
ertc_alarm_value_set
void ertc_alarm_value_set(uint32_t alam_index)
ertc alarm value set.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c:123
system_clock_recover
void system_clock_recover(void)
system clock recover.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c:141
ertc_alarm_config
void ertc_alarm_config(void)
ertc alarm configuration.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c:92
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED2
@ LED2
Definition: at32f435_437_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_ertc_clock_select
void crm_ertc_clock_select(crm_ertc_clock_type value)
select ertc clock
Definition: at32f435_437_crm.c:434
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_ertc_clock_enable
void crm_ertc_clock_enable(confirm_state new_state)
enable or disable ertc
Definition: at32f435_437_crm.c:445
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
crm_battery_powered_domain_reset
void crm_battery_powered_domain_reset(confirm_state new_state)
battery powered domain software reset
Definition: at32f435_437_crm.c:541
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_LEXT
@ CRM_CLOCK_SOURCE_LEXT
Definition: at32f435_437_crm.h:562
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_SCLK_HICK
@ CRM_SCLK_HICK
Definition: at32f435_437_crm.h:680
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_ERTC_CLOCK_LEXT
@ CRM_ERTC_CLOCK_LEXT
Definition: at32f435_437_crm.h:632
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
CRM_LEXT_STABLE_FLAG
#define CRM_LEXT_STABLE_FLAG
Definition: at32f435_437_crm.h:58
ertc_hour_mode_set
error_status ertc_hour_mode_set(ertc_hour_mode_set_type mode)
ertc hour mode set.
Definition: at32f435_437_ertc.c:283
ertc_wait_update
error_status ertc_wait_update(void)
ertc wait register update finish.
Definition: at32f435_437_ertc.c:97
ertc_time_set
error_status ertc_time_set(uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
set time.
Definition: at32f435_437_ertc.c:363
ertc_reset
error_status ertc_reset(void)
ertc reset all register.
Definition: at32f435_437_ertc.c:207
ertc_alarm_mask_set
void ertc_alarm_mask_set(ertc_alarm_type alarm_x, uint32_t mask)
set which bits are irrelevant to the alarm match.
Definition: at32f435_437_ertc.c:458
ertc_interrupt_enable
void ertc_interrupt_enable(uint32_t source, confirm_state new_state)
enable or disable interrupt.
Definition: at32f435_437_ertc.c:1386
ertc_alarm_week_date_select
void ertc_alarm_week_date_select(ertc_alarm_type alarm_x, ertc_week_date_select_type wk)
alarm week or date mode select.
Definition: at32f435_437_ertc.c:500
ertc_date_set
error_status ertc_date_set(uint8_t year, uint8_t month, uint8_t date, uint8_t week)
set date.
Definition: at32f435_437_ertc.c:314
ertc_alarm_set
void ertc_alarm_set(ertc_alarm_type alarm_x, uint8_t week_date, uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
set alarm.
Definition: at32f435_437_ertc.c:538
ertc_calendar_get
void ertc_calendar_get(ertc_time_type *time)
get calendar
Definition: at32f435_437_ertc.c:404
ertc_divider_set
error_status ertc_divider_set(uint16_t div_a, uint16_t div_b)
ertc division set.
Definition: at32f435_437_ertc.c:251
ertc_alarm_enable
error_status ertc_alarm_enable(ertc_alarm_type alarm_x, confirm_state new_state)
enable or disable alarm clock.
Definition: at32f435_437_ertc.c:629
ERTC_SLECT_DATE
@ ERTC_SLECT_DATE
Definition: at32f435_437_ertc.h:135
ERTC_HOUR_MODE_24
@ ERTC_HOUR_MODE_24
Definition: at32f435_437_ertc.h:116
ERTC_ALA
@ ERTC_ALA
Definition: at32f435_437_ertc.h:144
ERTC_AM
@ ERTC_AM
Definition: at32f435_437_ertc.h:126
ERTC_ALARM_MASK_DATE_WEEK
#define ERTC_ALARM_MASK_DATE_WEEK
Definition: at32f435_437_ertc.h:90
ERTC_ALARM_MASK_HOUR
#define ERTC_ALARM_MASK_HOUR
Definition: at32f435_437_ertc.h:89
ERTC_ALARM_MASK_MIN
#define ERTC_ALARM_MASK_MIN
Definition: at32f435_437_ertc.h:88
ERTC_ALA_INT
#define ERTC_ALA_INT
Definition: at32f435_437_ertc.h:53
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
EXINT_LINE_17
#define EXINT_LINE_17
Definition: at32f435_437_exint.h:69
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f435_437_pwc.c:61
pwc_voltage_regulate_set
void pwc_voltage_regulate_set(pwc_regulator_type pwc_regulator)
regulate low power consumption in the deep sleep mode
Definition: at32f435_437_pwc.c:214
pwc_deep_sleep_mode_enter
void pwc_deep_sleep_mode_enter(pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode
Definition: at32f435_437_pwc.c:190
PWC_REGULATOR_LOW_POWER
@ PWC_REGULATOR_LOW_POWER
Definition: at32f435_437_pwc.h:130
PWC_DEEP_SLEEP_ENTER_WFI
@ PWC_DEEP_SLEEP_ENTER_WFI
Definition: at32f435_437_pwc.h:120
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
PWC_LDO_OUTPUT_1V0
@ PWC_LDO_OUTPUT_1V0
Definition: at32f435_437_pwc.h:103
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
ERTCAlarm_IRQn
@ ERTCAlarm_IRQn
Definition: at32f435_437.h:189
ertc_time_type
ertc time
Definition: at32f435_437_ertc.h:383
ertc_time_type::ampm
ertc_am_pm_type ampm
Definition: at32f435_437_ertc.h:391
ertc_time_type::day
uint8_t day
Definition: at32f435_437_ertc.h:386
ertc_time_type::hour
uint8_t hour
Definition: at32f435_437_ertc.h:387
ertc_time_type::min
uint8_t min
Definition: at32f435_437_ertc.h:388
ertc_time_type::sec
uint8_t sec
Definition: at32f435_437_ertc.h:389
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_tamper
  • inc
project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_tamper
  • inc
project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_tamper
  • inc
project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_tamper
  • src
Functions
project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_tamper
  • src
project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_tamper
  • src
Functions
project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TAMP_STAMP_IRQHandler (void)
this function handles ertc tamper interrupt request. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_tamper
  • src
project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29#include "at32f435_437_board.h"
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
141void TAMP_STAMP_IRQHandler(void)
142{
143 if(ertc_flag_get(ERTC_TP1F_FLAG) != RESET)
144 {
145 /* clear ertc alarm flag */
146 ertc_flag_clear(ERTC_TP1F_FLAG);
147
148 /* clear exint line flag */
149 exint_flag_clear(EXINT_LINE_21);
150
151 /* toggle led */
152 at32_led_toggle(LED4);
153 }
154}
155
at32f435_437_board.h
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c:105
TAMP_STAMP_IRQHandler
void TAMP_STAMP_IRQHandler(void)
this function handles ertc tamper interrupt request.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c:141
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/at32f435_437_int.c:114
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
ertc_flag_get
flag_status ertc_flag_get(uint32_t flag)
get flag status.
Definition: at32f435_437_ertc.c:1474
ertc_flag_clear
void ertc_flag_clear(uint32_t flag)
clear flag status
Definition: at32f435_437_ertc.c:1507
ERTC_TP1F_FLAG
#define ERTC_TP1F_FLAG
Definition: at32f435_437_ertc.h:79
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
EXINT_LINE_21
#define EXINT_LINE_21
Definition: at32f435_437_exint.h:73
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_tamper
  • src
Functions
project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | ertc_config (void)
ertc configuration. More...
void | ertc_tamper_config (void)
ertc tamper configuration. More...
void | system_clock_recover (void)
system clock recover. More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_tamper
  • src
project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
43void ertc_config(void)
44{
45 /* enable the pwc clock interface */
46 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
47
48 /* allow access to ertc */
49 pwc_battery_powered_domain_access(TRUE);
50
51 /* reset ertc domain */
52 crm_battery_powered_domain_reset(TRUE);
53 crm_battery_powered_domain_reset(FALSE);
54
55 /* enable the lext osc */
56 crm_clock_source_enable(CRM_CLOCK_SOURCE_LEXT, TRUE);
57
58 /* wait till lext is ready */
59 while(crm_flag_get(CRM_LEXT_STABLE_FLAG) == RESET);
60
61 /* select the ertc clock source */
62 crm_ertc_clock_select(CRM_ERTC_CLOCK_LEXT);
63
64 /* enable the ertc clock */
65 crm_ertc_clock_enable(TRUE);
66
67 /* deinitializes the ertc registers */
68 ertc_reset();
69}
70
76void ertc_tamper_config(void)
77{
78 exint_init_type exint_init_struct;
79
80 /* config the exint line of the ertc tamper */
81 exint_init_struct.line_select = EXINT_LINE_21;
82 exint_init_struct.line_enable = TRUE;
83 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
84 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
85 exint_init(&exint_init_struct);
86
87 /* enable tamper irqchannel */
88 nvic_irq_enable(TAMP_STAMP_IRQn, 0, 0);
89
90 /* disable the tamper 1 detection */
91 ertc_tamper_enable(ERTC_TAMPER_1, FALSE);
92
93 /* clear tamper 1 pin event(tamp1f) pending flag */
94 ertc_flag_clear(ERTC_TP1F_FLAG);
95
96 /* configure the tamper 1 trigger */
97 ertc_tamper_valid_edge_set(ERTC_TAMPER_1, ERTC_TAMPER_EDGE_RISING);
98
99 /* enable the tamper interrupt */
100 ertc_interrupt_enable(ERTC_TP_INT, TRUE);
101
102 /* enable the tamper 1 detection */
103 ertc_tamper_enable(ERTC_TAMPER_1, TRUE);
104}
105
111void system_clock_recover(void)
112{
113 /* enable external high-speed crystal oscillator - hext */
114 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
115
116 /* wait till hext is ready */
117 while(crm_hext_stable_wait() == ERROR);
118
119 /* enable pll */
120 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
121
122 /* wait till pll is ready */
123 while(crm_flag_get(CRM_PLL_STABLE_FLAG) == RESET);
124
125 /* enable auto step mode */
126 crm_auto_step_mode_enable(TRUE);
127
128 /* select pll as system clock source */
129 crm_sysclk_switch(CRM_SCLK_PLL);
130
131 /* wait till pll is used as system clock source */
132 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL);
133}
134
140int main(void)
141{
142 __IO uint32_t systick_index = 0;
143 __IO uint32_t delay_index = 0;
144
145 /* congfig the system clock */
146 system_clock_config();
147
148 /* init at start board */
149 at32_board_init();
150
151 /* config priority group */
152 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
153
154 /* enable pwc and bpr clock */
155 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
156
157 /* turn on the led light */
158 at32_led_on(LED2);
159
160 /* config ertc */
161 ertc_config();
162
163 /* set the wakeup time: 06h:20min:5s */
164 ertc_tamper_config();
165
166 /* save systick register configuration */
167 systick_index = SysTick->CTRL;
168 systick_index &= ~((uint32_t)0xFFFFFFFE);
169
170 /* disable systick */
171 SysTick->CTRL &= (uint32_t)0xFFFFFFFE;
172
173 /* select system clock source as hick before ldo set */
174 crm_sysclk_switch(CRM_SCLK_HICK);
175
176 /* wait till hick is used as system clock source */
177 while(crm_sysclk_switch_status_get() != CRM_SCLK_HICK)
178 {
179 }
180
181 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V0);
182
183 /* congfig the voltage regulator mode */
184 pwc_voltage_regulate_set(PWC_REGULATOR_LOW_POWER);
185
186 /* enter deep sleep mode */
187 pwc_deep_sleep_mode_enter(PWC_DEEP_SLEEP_ENTER_WFI);
188
189 /* wake up from deep sleep mode, restore systick register configuration */
190 SysTick->CTRL |= systick_index;
191
192 /* turn on the led light */
193 at32_led_on(LED3);
194
195 /* wait clock stable */
196 for(delay_index = 0; delay_index < 600; delay_index++)
197 {
198 __NOP();
199 }
200
201 /* resume ldo before system clock source enhance */
202 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
203
204 /* congfig the system clock */
205 system_clock_recover();
206
207 while(1)
208 {
209 }
210}
211
at32f435_437_board.h
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:41
ertc_tamper_config
void ertc_tamper_config(void)
ertc tamper configuration.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/main.c:76
main
int main(void)
main function.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/main.c:140
ertc_config
void ertc_config(void)
ertc configuration.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/main.c:43
system_clock_recover
void system_clock_recover(void)
system clock recover.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_tamper/src/main.c:111
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_ertc_clock_select
void crm_ertc_clock_select(crm_ertc_clock_type value)
select ertc clock
Definition: at32f435_437_crm.c:434
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_ertc_clock_enable
void crm_ertc_clock_enable(confirm_state new_state)
enable or disable ertc
Definition: at32f435_437_crm.c:445
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
crm_battery_powered_domain_reset
void crm_battery_powered_domain_reset(confirm_state new_state)
battery powered domain software reset
Definition: at32f435_437_crm.c:541
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_LEXT
@ CRM_CLOCK_SOURCE_LEXT
Definition: at32f435_437_crm.h:562
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_SCLK_HICK
@ CRM_SCLK_HICK
Definition: at32f435_437_crm.h:680
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_ERTC_CLOCK_LEXT
@ CRM_ERTC_CLOCK_LEXT
Definition: at32f435_437_crm.h:632
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
CRM_LEXT_STABLE_FLAG
#define CRM_LEXT_STABLE_FLAG
Definition: at32f435_437_crm.h:58
ertc_reset
error_status ertc_reset(void)
ertc reset all register.
Definition: at32f435_437_ertc.c:207
ertc_interrupt_enable
void ertc_interrupt_enable(uint32_t source, confirm_state new_state)
enable or disable interrupt.
Definition: at32f435_437_ertc.c:1386
ertc_tamper_enable
void ertc_tamper_enable(ertc_tamper_select_type tamper_x, confirm_state new_state)
enable or disable tamper.
Definition: at32f435_437_ertc.c:1356
ertc_flag_clear
void ertc_flag_clear(uint32_t flag)
clear flag status
Definition: at32f435_437_ertc.c:1507
ertc_tamper_valid_edge_set
void ertc_tamper_valid_edge_set(ertc_tamper_select_type tamper_x, ertc_tamper_valid_edge_type trigger)
set the tamper trigger.
Definition: at32f435_437_ertc.c:1313
ERTC_TAMPER_EDGE_RISING
@ ERTC_TAMPER_EDGE_RISING
Definition: at32f435_437_ertc.h:346
ERTC_TAMPER_1
@ ERTC_TAMPER_1
Definition: at32f435_437_ertc.h:300
ERTC_TP1F_FLAG
#define ERTC_TP1F_FLAG
Definition: at32f435_437_ertc.h:79
ERTC_TP_INT
#define ERTC_TP_INT
Definition: at32f435_437_ertc.h:52
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
EXINT_LINE_21
#define EXINT_LINE_21
Definition: at32f435_437_exint.h:73
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f435_437_pwc.c:61
pwc_voltage_regulate_set
void pwc_voltage_regulate_set(pwc_regulator_type pwc_regulator)
regulate low power consumption in the deep sleep mode
Definition: at32f435_437_pwc.c:214
pwc_deep_sleep_mode_enter
void pwc_deep_sleep_mode_enter(pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode
Definition: at32f435_437_pwc.c:190
PWC_REGULATOR_LOW_POWER
@ PWC_REGULATOR_LOW_POWER
Definition: at32f435_437_pwc.h:130
PWC_DEEP_SLEEP_ENTER_WFI
@ PWC_DEEP_SLEEP_ENTER_WFI
Definition: at32f435_437_pwc.h:120
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
PWC_LDO_OUTPUT_1V0
@ PWC_LDO_OUTPUT_1V0
Definition: at32f435_437_pwc.h:103
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
TAMP_STAMP_IRQn
@ TAMP_STAMP_IRQn
Definition: at32f435_437.h:148
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_wakeup
  • inc
project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_wakeup
  • inc
project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_wakeup
  • inc
project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_wakeup
  • src
Functions
project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_wakeup
  • src
project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_wakeup
  • src
Functions
project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ERTC_WKUP_IRQHandler (void)
this function handles ertc wakeup timer interrupt request. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_wakeup
  • src
project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29#include "at32f435_437_board.h"
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
141void ERTC_WKUP_IRQHandler(void)
142{
143 if(ertc_flag_get(ERTC_WATF_FLAG) != RESET)
144 {
145 /* clear ertc wakeup timer flag */
146 ertc_flag_clear(ERTC_WATF_FLAG);
147
148 /* clear exint line flag */
149 exint_flag_clear(EXINT_LINE_22);
150
151 /* toggle led */
152 at32_led_toggle(LED4);
153 }
154}
155
at32f435_437_board.h
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c:114
ERTC_WKUP_IRQHandler
void ERTC_WKUP_IRQHandler(void)
this function handles ertc wakeup timer interrupt request.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/at32f435_437_int.c:141
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
ertc_flag_get
flag_status ertc_flag_get(uint32_t flag)
get flag status.
Definition: at32f435_437_ertc.c:1474
ertc_flag_clear
void ertc_flag_clear(uint32_t flag)
clear flag status
Definition: at32f435_437_ertc.c:1507
ERTC_WATF_FLAG
#define ERTC_WATF_FLAG
Definition: at32f435_437_ertc.h:76
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
EXINT_LINE_22
#define EXINT_LINE_22
Definition: at32f435_437_exint.h:74
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_wakeup
  • src
Functions
project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | ertc_config (void)
ertc configuration. More...
void | ertc_wakeup_timer_config (void)
ertc wakeup timer configuration. More...
void | system_clock_recover (void)
system clock recover. More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • pwc
  • deepsleep_ertc_wakeup
  • src
project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
43void ertc_config(void)
44{
45 /* enable the pwc clock interface */
46 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
47
48 /* allow access to ertc */
49 pwc_battery_powered_domain_access(TRUE);
50
51 /* reset ertc domain */
52 crm_battery_powered_domain_reset(TRUE);
53 crm_battery_powered_domain_reset(FALSE);
54
55 /* enable the lext osc */
56 crm_clock_source_enable(CRM_CLOCK_SOURCE_LEXT, TRUE);
57
58 /* wait till lext is ready */
59 while(crm_flag_get(CRM_LEXT_STABLE_FLAG) == RESET);
60
61 /* select the ertc clock source */
62 crm_ertc_clock_select(CRM_ERTC_CLOCK_LEXT);
63
64 /* enable the ertc clock */
65 crm_ertc_clock_enable(TRUE);
66
67 /* deinitializes the ertc registers */
68 ertc_reset();
69
70 /* wait for ertc apb registers synchronisation */
71 ertc_wait_update();
72
73 /* configure the ertc data register and ertc prescaler
74 ck_spre(1hz) = ertcclk(lext) /(ertc_clk_div_a + 1)*(ertc_clk_div_b + 1)*/
75 ertc_divider_set(127, 255);
76
77 /* configure the hour format is 24-hour format*/
78 ertc_hour_mode_set(ERTC_HOUR_MODE_24);
79
80 /* set the date: friday june 11th 2021 */
81 ertc_date_set(21, 6, 11, 5);
82
83 /* set the time to 06h 20mn 00s am */
84 ertc_time_set(6, 20, 0, ERTC_AM);
85}
86
92void ertc_wakeup_timer_config(void)
93{
94 exint_init_type exint_init_struct;
95
96 /* config the exint line of the ertc wakeup timer */
97 exint_init_struct.line_select = EXINT_LINE_22;
98 exint_init_struct.line_enable = TRUE;
99 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
100 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
101 exint_init(&exint_init_struct);
102
103 /* set wakeup timer clock 1hz */
104 ertc_wakeup_clock_set(ERTC_WAT_CLK_CK_B_16BITS);
105
106 /* set the wakeup time to 5s */
107 ertc_wakeup_counter_set(5 - 1);
108
109 /* enable the ertc interrupt */
110 nvic_irq_enable(ERTC_WKUP_IRQn, 0, 0);
111
112 /* enable ertc wakeup timer a interrupt */
113 ertc_interrupt_enable(ERTC_WAT_INT, TRUE);
114
115 /* enable the wakeup timer */
116 ertc_wakeup_enable(TRUE);
117}
118
124void system_clock_recover(void)
125{
126 /* enable external high-speed crystal oscillator - hext */
127 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
128
129 /* wait till hext is ready */
130 while(crm_hext_stable_wait() == ERROR);
131
132 /* enable pll */
133 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
134
135 /* wait till pll is ready */
136 while(crm_flag_get(CRM_PLL_STABLE_FLAG) == RESET);
137
138 /* enable auto step mode */
139 crm_auto_step_mode_enable(TRUE);
140
141 /* select pll as system clock source */
142 crm_sysclk_switch(CRM_SCLK_PLL);
143
144 /* wait till pll is used as system clock source */
145 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL);
146}
147
153int main(void)
154{
155 __IO uint32_t systick_index = 0;
156 __IO uint32_t delay_index = 0;
157
158 /* congfig the system clock */
159 system_clock_config();
160
161 /* init at start board */
162 at32_board_init();
163
164 /* config priority group */
165 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
166
167 /* enable pwc and bpr clock */
168 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
169
170 /* turn on the led light */
171 at32_led_on(LED2);
172
173 /* config ertc */
174 ertc_config();
175
176 /* config the wakeup timer */
177 ertc_wakeup_timer_config();
178
179 /* save systick register configuration */
180 systick_index = SysTick->CTRL;
181 systick_index &= ~((uint32_t)0xFFFFFFFE);
182
183 /* disable systick */
184 SysTick->CTRL &= (uint32_t)0xFFFFFFFE;
185
186 /* select system clock source as hick before ldo set */
187 crm_sysclk_switch(CRM_SCLK_HICK);
188
189 /* wait till hick is used as system clock source */
190 while(crm_sysclk_switch_status_get() != CRM_SCLK_HICK)
191 {
192 }
193
194 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V0);
195
196 /* congfig the voltage regulator mode */
197 pwc_voltage_regulate_set(PWC_REGULATOR_LOW_POWER);
198
199 /* enter deep sleep mode */
200 pwc_deep_sleep_mode_enter(PWC_DEEP_SLEEP_ENTER_WFI);
201
202 /* wake up from deep sleep mode, restore systick register configuration */
203 SysTick->CTRL |= systick_index;
204
205 /* turn on the led light */
206 at32_led_on(LED3);
207
208 /* wait clock stable */
209 for(delay_index = 0; delay_index < 600; delay_index++)
210 {
211 __NOP();
212 }
213
214 /* resume ldo before system clock source enhance */
215 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
216
217 /* congfig the system clock */
218 system_clock_recover();
219
220 while(1)
221 {
222 }
223}
224
at32f435_437_board.h
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:41
main
int main(void)
main function.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/main.c:153
ertc_config
void ertc_config(void)
ertc configuration.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/main.c:43
ertc_wakeup_timer_config
void ertc_wakeup_timer_config(void)
ertc wakeup timer configuration.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/main.c:92
system_clock_recover
void system_clock_recover(void)
system clock recover.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_wakeup/src/main.c:124
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_ertc_clock_select
void crm_ertc_clock_select(crm_ertc_clock_type value)
select ertc clock
Definition: at32f435_437_crm.c:434
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_ertc_clock_enable
void crm_ertc_clock_enable(confirm_state new_state)
enable or disable ertc
Definition: at32f435_437_crm.c:445
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
crm_battery_powered_domain_reset
void crm_battery_powered_domain_reset(confirm_state new_state)
battery powered domain software reset
Definition: at32f435_437_crm.c:541
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_LEXT
@ CRM_CLOCK_SOURCE_LEXT
Definition: at32f435_437_crm.h:562
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_SCLK_HICK
@ CRM_SCLK_HICK
Definition: at32f435_437_crm.h:680
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_ERTC_CLOCK_LEXT
@ CRM_ERTC_CLOCK_LEXT
Definition: at32f435_437_crm.h:632
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
CRM_LEXT_STABLE_FLAG
#define CRM_LEXT_STABLE_FLAG
Definition: at32f435_437_crm.h:58
ertc_hour_mode_set
error_status ertc_hour_mode_set(ertc_hour_mode_set_type mode)
ertc hour mode set.
Definition: at32f435_437_ertc.c:283
ertc_wakeup_clock_set
void ertc_wakeup_clock_set(ertc_wakeup_clock_type clock)
set wakeup timer clock.
Definition: at32f435_437_ertc.c:731
ertc_wait_update
error_status ertc_wait_update(void)
ertc wait register update finish.
Definition: at32f435_437_ertc.c:97
ertc_wakeup_counter_set
void ertc_wakeup_counter_set(uint32_t counter)
set wakeup counter.
Definition: at32f435_437_ertc.c:747
ertc_time_set
error_status ertc_time_set(uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
set time.
Definition: at32f435_437_ertc.c:363
ertc_reset
error_status ertc_reset(void)
ertc reset all register.
Definition: at32f435_437_ertc.c:207
ertc_interrupt_enable
void ertc_interrupt_enable(uint32_t source, confirm_state new_state)
enable or disable interrupt.
Definition: at32f435_437_ertc.c:1386
ertc_wakeup_enable
error_status ertc_wakeup_enable(confirm_state new_state)
enable or disable wakeup timer.
Definition: at32f435_437_ertc.c:773
ertc_date_set
error_status ertc_date_set(uint8_t year, uint8_t month, uint8_t date, uint8_t week)
set date.
Definition: at32f435_437_ertc.c:314
ertc_divider_set
error_status ertc_divider_set(uint16_t div_a, uint16_t div_b)
ertc division set.
Definition: at32f435_437_ertc.c:251
ERTC_HOUR_MODE_24
@ ERTC_HOUR_MODE_24
Definition: at32f435_437_ertc.h:116
ERTC_WAT_CLK_CK_B_16BITS
@ ERTC_WAT_CLK_CK_B_16BITS
Definition: at32f435_437_ertc.h:180
ERTC_AM
@ ERTC_AM
Definition: at32f435_437_ertc.h:126
ERTC_WAT_INT
#define ERTC_WAT_INT
Definition: at32f435_437_ertc.h:55
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
EXINT_LINE_22
#define EXINT_LINE_22
Definition: at32f435_437_exint.h:74
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f435_437_pwc.c:61
pwc_voltage_regulate_set
void pwc_voltage_regulate_set(pwc_regulator_type pwc_regulator)
regulate low power consumption in the deep sleep mode
Definition: at32f435_437_pwc.c:214
pwc_deep_sleep_mode_enter
void pwc_deep_sleep_mode_enter(pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode
Definition: at32f435_437_pwc.c:190
PWC_REGULATOR_LOW_POWER
@ PWC_REGULATOR_LOW_POWER
Definition: at32f435_437_pwc.h:130
PWC_DEEP_SLEEP_ENTER_WFI
@ PWC_DEEP_SLEEP_ENTER_WFI
Definition: at32f435_437_pwc.h:120
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
PWC_LDO_OUTPUT_1V0
@ PWC_LDO_OUTPUT_1V0
Definition: at32f435_437_pwc.h:103
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
ERTC_WKUP_IRQn
@ ERTC_WKUP_IRQn
Definition: at32f435_437.h:149
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • pwc
  • ldo_set
  • inc
project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • pwc
  • ldo_set
  • inc
project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • pwc
  • ldo_set
  • inc
project/at_start_f435/examples/pwc/ldo_set/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • pwc
  • ldo_set
  • src
Functions
project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • pwc
  • ldo_set
  • src
project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • pwc
  • ldo_set
  • src
Functions
project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TAMP_STAMP_IRQHandler (void)
this function handles ertc tamper interrupt request. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • pwc
  • ldo_set
  • src
project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29#include "at32f435_437_board.h"
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
141void TAMP_STAMP_IRQHandler(void)
142{
143 if(ertc_flag_get(ERTC_TP1F_FLAG) != RESET)
144 {
145 /* clear ertc alarm flag */
146 ertc_flag_clear(ERTC_TP1F_FLAG);
147
148 /* clear exint line flag */
149 exint_flag_clear(EXINT_LINE_21);
150
151 /* toggle led */
152 at32_led_toggle(LED4);
153 }
154}
155
at32f435_437_board.h
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c:105
TAMP_STAMP_IRQHandler
void TAMP_STAMP_IRQHandler(void)
this function handles ertc tamper interrupt request.
Definition: project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c:141
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/pwc/ldo_set/src/at32f435_437_int.c:114
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
ertc_flag_get
flag_status ertc_flag_get(uint32_t flag)
get flag status.
Definition: at32f435_437_ertc.c:1474
ertc_flag_clear
void ertc_flag_clear(uint32_t flag)
clear flag status
Definition: at32f435_437_ertc.c:1507
ERTC_TP1F_FLAG
#define ERTC_TP1F_FLAG
Definition: at32f435_437_ertc.h:79
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
EXINT_LINE_21
#define EXINT_LINE_21
Definition: at32f435_437_exint.h:73
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • pwc
  • ldo_set
  • src
Functions
project/at_start_f435/examples/pwc/ldo_set/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | ertc_config (void)
ertc configuration. More...
void | ertc_tamper_config (void)
ertc tamper configuration. More...
void | system_clock_recover (void)
system clock recover. More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/ldo_set/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • pwc
  • ldo_set
  • src
project/at_start_f435/examples/pwc/ldo_set/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
43void ertc_config(void)
44{
45 /* enable the pwc clock interface */
46 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
47
48 /* allow access to ertc */
49 pwc_battery_powered_domain_access(TRUE);
50
51 /* reset ertc domain */
52 crm_battery_powered_domain_reset(TRUE);
53 crm_battery_powered_domain_reset(FALSE);
54
55 /* enable the lext osc */
56 crm_clock_source_enable(CRM_CLOCK_SOURCE_LEXT, TRUE);
57
58 /* wait till lext is ready */
59 while(crm_flag_get(CRM_LEXT_STABLE_FLAG) == RESET);
60
61 /* select the ertc clock source */
62 crm_ertc_clock_select(CRM_ERTC_CLOCK_LEXT);
63
64 /* enable the ertc clock */
65 crm_ertc_clock_enable(TRUE);
66
67 /* deinitializes the ertc registers */
68 ertc_reset();
69}
70
76void ertc_tamper_config(void)
77{
78 exint_init_type exint_init_struct;
79
80 /* config the exint line of the ertc tamper */
81 exint_init_struct.line_select = EXINT_LINE_21;
82 exint_init_struct.line_enable = TRUE;
83 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
84 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
85 exint_init(&exint_init_struct);
86
87 /* enable tamper irqchannel */
88 nvic_irq_enable(TAMP_STAMP_IRQn, 0, 0);
89
90 /* disable the tamper 1 detection */
91 ertc_tamper_enable(ERTC_TAMPER_1, FALSE);
92
93 /* clear tamper 1 pin event(tamp1f) pending flag */
94 ertc_flag_clear(ERTC_TP1F_FLAG);
95
96 /* configure the tamper 1 trigger */
97 ertc_tamper_valid_edge_set(ERTC_TAMPER_1, ERTC_TAMPER_EDGE_RISING);
98
99 /* enable the tamper interrupt */
100 ertc_interrupt_enable(ERTC_TP_INT, TRUE);
101
102 /* enable the tamper 1 detection */
103 ertc_tamper_enable(ERTC_TAMPER_1, TRUE);
104}
105
111void system_clock_recover(void)
112{
113 /* enable external high-speed crystal oscillator - hext */
114 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
115
116 /* wait till hext is ready */
117 while(crm_hext_stable_wait() == ERROR);
118
119 /* enable pll */
120 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
121
122 /* wait till pll is ready */
123 while(crm_flag_get(CRM_PLL_STABLE_FLAG) == RESET);
124
125 /* enable auto step mode */
126 crm_auto_step_mode_enable(TRUE);
127
128 /* select pll as system clock source */
129 crm_sysclk_switch(CRM_SCLK_PLL);
130
131 /* wait till pll is used as system clock source */
132 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL);
133}
134
135
141int main(void)
142{
143 __IO uint32_t systick_index = 0;
144 __IO uint32_t delay_index = 0;
145
146 /* congfig the system clock */
147 system_clock_config();
148
149 /* init at start board */
150 at32_board_init();
151
152 /* config priority group */
153 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
154
155 /* turn on the led light */
156 at32_led_on(LED2);
157 at32_led_on(LED3);
158 at32_led_on(LED4);
159
160 /* enable pwc clock */
161 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
162
163 /* config ertc */
164 ertc_config();
165
166 /* set the wakeup time: 06h:20min:5s */
167 ertc_tamper_config();
168
169 while(1)
170 {
171 at32_led_toggle(LED3);
172
173 /* save systick register configuration */
174 systick_index = SysTick->CTRL;
175 systick_index &= ~((uint32_t)0xFFFFFFFE);
176
177 /* disable systick */
178 SysTick->CTRL &= (uint32_t)0xFFFFFFFE;
179
180 /* select system clock source as hick before ldo set */
181 crm_sysclk_switch(CRM_SCLK_HICK);
182
183 /* wait till hick is used as system clock source */
184 while(crm_sysclk_switch_status_get() != CRM_SCLK_HICK)
185 {
186 }
187
188 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V0);
189
190 /* congfig the voltage regulator mode */
191 pwc_voltage_regulate_set(PWC_REGULATOR_LOW_POWER);
192
193 /* enter deep sleep mode */
194 pwc_deep_sleep_mode_enter(PWC_DEEP_SLEEP_ENTER_WFI);
195
196 /* wake up from deep sleep mode, restore systick register configuration */
197 SysTick->CTRL |= systick_index;
198
199 /* wait clock stable */
200 for(delay_index = 0; delay_index < 600; delay_index++)
201 {
202 __NOP();
203 }
204
205 /* resume ldo before system clock source enhance */
206 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
207
208 /* congfig the system clock */
209 system_clock_recover();
210
211 }
212}
213
at32f435_437_board.h
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:41
ertc_tamper_config
void ertc_tamper_config(void)
ertc tamper configuration.
Definition: project/at_start_f435/examples/pwc/ldo_set/src/main.c:76
main
int main(void)
main function.
Definition: project/at_start_f435/examples/pwc/ldo_set/src/main.c:141
ertc_config
void ertc_config(void)
ertc configuration.
Definition: project/at_start_f435/examples/pwc/ldo_set/src/main.c:43
system_clock_recover
void system_clock_recover(void)
system clock recover.
Definition: project/at_start_f435/examples/pwc/ldo_set/src/main.c:111
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_ertc_clock_select
void crm_ertc_clock_select(crm_ertc_clock_type value)
select ertc clock
Definition: at32f435_437_crm.c:434
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_ertc_clock_enable
void crm_ertc_clock_enable(confirm_state new_state)
enable or disable ertc
Definition: at32f435_437_crm.c:445
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
crm_battery_powered_domain_reset
void crm_battery_powered_domain_reset(confirm_state new_state)
battery powered domain software reset
Definition: at32f435_437_crm.c:541
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_LEXT
@ CRM_CLOCK_SOURCE_LEXT
Definition: at32f435_437_crm.h:562
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_SCLK_HICK
@ CRM_SCLK_HICK
Definition: at32f435_437_crm.h:680
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_ERTC_CLOCK_LEXT
@ CRM_ERTC_CLOCK_LEXT
Definition: at32f435_437_crm.h:632
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
CRM_LEXT_STABLE_FLAG
#define CRM_LEXT_STABLE_FLAG
Definition: at32f435_437_crm.h:58
ertc_reset
error_status ertc_reset(void)
ertc reset all register.
Definition: at32f435_437_ertc.c:207
ertc_interrupt_enable
void ertc_interrupt_enable(uint32_t source, confirm_state new_state)
enable or disable interrupt.
Definition: at32f435_437_ertc.c:1386
ertc_tamper_enable
void ertc_tamper_enable(ertc_tamper_select_type tamper_x, confirm_state new_state)
enable or disable tamper.
Definition: at32f435_437_ertc.c:1356
ertc_flag_clear
void ertc_flag_clear(uint32_t flag)
clear flag status
Definition: at32f435_437_ertc.c:1507
ertc_tamper_valid_edge_set
void ertc_tamper_valid_edge_set(ertc_tamper_select_type tamper_x, ertc_tamper_valid_edge_type trigger)
set the tamper trigger.
Definition: at32f435_437_ertc.c:1313
ERTC_TAMPER_EDGE_RISING
@ ERTC_TAMPER_EDGE_RISING
Definition: at32f435_437_ertc.h:346
ERTC_TAMPER_1
@ ERTC_TAMPER_1
Definition: at32f435_437_ertc.h:300
ERTC_TP1F_FLAG
#define ERTC_TP1F_FLAG
Definition: at32f435_437_ertc.h:79
ERTC_TP_INT
#define ERTC_TP_INT
Definition: at32f435_437_ertc.h:52
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
EXINT_LINE_21
#define EXINT_LINE_21
Definition: at32f435_437_exint.h:73
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f435_437_pwc.c:61
pwc_voltage_regulate_set
void pwc_voltage_regulate_set(pwc_regulator_type pwc_regulator)
regulate low power consumption in the deep sleep mode
Definition: at32f435_437_pwc.c:214
pwc_deep_sleep_mode_enter
void pwc_deep_sleep_mode_enter(pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode
Definition: at32f435_437_pwc.c:190
PWC_REGULATOR_LOW_POWER
@ PWC_REGULATOR_LOW_POWER
Definition: at32f435_437_pwc.h:130
PWC_DEEP_SLEEP_ENTER_WFI
@ PWC_DEEP_SLEEP_ENTER_WFI
Definition: at32f435_437_pwc.h:120
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
PWC_LDO_OUTPUT_1V0
@ PWC_LDO_OUTPUT_1V0
Definition: at32f435_437_pwc.h:103
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
TAMP_STAMP_IRQn
@ TAMP_STAMP_IRQn
Definition: at32f435_437.h:148
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • pwc
  • power_voltage_monitor
  • inc
project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • pwc
  • power_voltage_monitor
  • inc
project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • pwc
  • power_voltage_monitor
  • inc
project/at_start_f435/examples/pwc/power_voltage_monitor/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • pwc
  • power_voltage_monitor
  • src
Functions
project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • pwc
  • power_voltage_monitor
  • src
project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • pwc
  • power_voltage_monitor
  • src
Functions
project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | PVM_IRQHandler (void)
This function handles the power voltage monitoring output interrupt request. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • pwc
  • power_voltage_monitor
  • src
project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29#include "at32f435_437_board.h"
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
141void PVM_IRQHandler(void)
142{
143 if(exint_flag_get(EXINT_LINE_16) != RESET)
144 {
145 /* clear exint line flag */
146 exint_flag_clear(EXINT_LINE_16);
147
148 /* toggle led */
149 at32_led_toggle(LED2);
150 at32_led_toggle(LED3);
151 at32_led_toggle(LED4);
152 }
153}
154
at32f435_437_board.h
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c:132
PVM_IRQHandler
void PVM_IRQHandler(void)
This function handles the power voltage monitoring output interrupt request.
Definition: project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c:141
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/pwc/power_voltage_monitor/src/at32f435_437_int.c:114
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
exint_flag_get
flag_status exint_flag_get(uint32_t exint_line)
get exint flag
Definition: at32f435_437_exint.c:142
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
EXINT_LINE_16
#define EXINT_LINE_16
Definition: at32f435_437_exint.h:68
RESET
@ RESET
Definition: at32f435_437.h:378
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • pwc
  • power_voltage_monitor
  • src
Functions
project/at_start_f435/examples/pwc/power_voltage_monitor/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | pvm_exint_config (void)
power voltage monitor exint configuration. More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/power_voltage_monitor/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • pwc
  • power_voltage_monitor
  • src
project/at_start_f435/examples/pwc/power_voltage_monitor/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
43void pvm_exint_config(void)
44{
45 exint_init_type exint_init_struct;
46
47 /* config the exint line of the power voltage monitor */
48 exint_init_struct.line_select = EXINT_LINE_16;
49 exint_init_struct.line_enable = TRUE;
50 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
51 exint_init_struct.line_polarity = EXINT_TRIGGER_BOTH_EDGE;
52 exint_init(&exint_init_struct);
53}
54
60int main(void)
61{
62 __IO uint32_t index = 0;
63
64 /* congfig the system clock */
65 system_clock_config();
66
67 /* init at start board */
68 at32_board_init();
69
70 /* config priority group */
71 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
72
73 /* turn on the led light */
74 at32_led_on(LED2);
75 at32_led_on(LED3);
76 at32_led_on(LED4);
77
78 /* enable pwc clock */
79 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
80
81 /* set the threshold voltage to 2.9v */
82 pwc_pvm_level_select(PWC_PVM_VOLTAGE_2V9);
83
84 /* enable power voltage monitor */
85 pwc_power_voltage_monitor_enable(TRUE);
86
87 /* config the exint line of the power voltage monitor */
88 pvm_exint_config();
89
90 /* enable power voltage monitor interrupt */
91 nvic_irq_enable(PVM_IRQn, 0, 0);
92
93 while(1)
94 {
95 }
96}
97
at32f435_437_board.h
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:41
pvm_exint_config
void pvm_exint_config(void)
power voltage monitor exint configuration.
Definition: project/at_start_f435/examples/pwc/power_voltage_monitor/src/main.c:43
main
int main(void)
main function.
Definition: project/at_start_f435/examples/pwc/power_voltage_monitor/src/main.c:60
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_BOTH_EDGE
@ EXINT_TRIGGER_BOTH_EDGE
Definition: at32f435_437_exint.h:100
EXINT_LINE_16
#define EXINT_LINE_16
Definition: at32f435_437_exint.h:68
TRUE
@ TRUE
Definition: at32f435_437.h:379
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
pwc_power_voltage_monitor_enable
void pwc_power_voltage_monitor_enable(confirm_state new_state)
enable or disable pwc power voltage monitor (pvm)
Definition: at32f435_437_pwc.c:90
pwc_pvm_level_select
void pwc_pvm_level_select(pwc_pvm_voltage_type pvm_voltage)
select the voltage threshold detected by the power voltage detector.
Definition: at32f435_437_pwc.c:79
PWC_PVM_VOLTAGE_2V9
@ PWC_PVM_VOLTAGE_2V9
Definition: at32f435_437_pwc.h:92
PVM_IRQn
@ PVM_IRQn
Definition: at32f435_437.h:147
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • pwc
  • sleep_tmr2
  • inc
project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • pwc
  • sleep_tmr2
  • inc
project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • pwc
  • sleep_tmr2
  • inc
project/at_start_f435/examples/pwc/sleep_tmr2/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • pwc
  • sleep_tmr2
  • src
Functions
project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • pwc
  • sleep_tmr2
  • src
project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • pwc
  • sleep_tmr2
  • src
Functions
project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR2_GLOBAL_IRQHandler (void)
This function handles the power voltage monitoring output interrupt request. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • pwc
  • sleep_tmr2
  • src
project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29#include "at32f435_437_board.h"
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
141void TMR2_GLOBAL_IRQHandler(void)
142{
143 if(tmr_flag_get(TMR2, TMR_OVF_FLAG) != RESET)
144 {
145 /* clear timer 2 ovf flag */
146 tmr_flag_clear(TMR2, TMR_OVF_FLAG);
147
148 /* toggle led */
149 at32_led_toggle(LED4);
150 }
151}
152
at32f435_437_board.h
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c:105
TMR2_GLOBAL_IRQHandler
void TMR2_GLOBAL_IRQHandler(void)
This function handles the power voltage monitoring output interrupt request.
Definition: project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c:141
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/pwc/sleep_tmr2/src/at32f435_437_int.c:114
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
RESET
@ RESET
Definition: at32f435_437.h:378
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f435_437_tmr.c:1463
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f435_437_tmr.c:1424
TMR_OVF_FLAG
#define TMR_OVF_FLAG
Definition: at32f435_437_tmr.h:52
TMR2
#define TMR2
Definition: at32f435_437_tmr.h:896
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • pwc
  • sleep_tmr2
  • src
Functions
project/at_start_f435/examples/pwc/sleep_tmr2/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | tmr2_config (void)
tmr2 configuration. More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/sleep_tmr2/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • pwc
  • sleep_tmr2
  • src
project/at_start_f435/examples/pwc/sleep_tmr2/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
43void tmr2_config(void)
44{
45 crm_clocks_freq_type crm_clocks_freq_struct = {0};
46
47 /* enable tmr 2 clock */
48 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
49
50 /* get system clock */
51 crm_clocks_freq_get(&crm_clocks_freq_struct);
52
53 /* (systemclock/(systemclock/10000))/10000 = 1Hz(1s) */
54 tmr_base_init(TMR2, 9999, (crm_clocks_freq_struct.sclk_freq/10000 - 1));
55
56 /* config the counting direction */
57 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
58
59 /* config the clock divider value */
60 tmr_clock_source_div_set(TMR2, TMR_CLOCK_DIV1);
61
62 /* enable tmr 2 interrupt */
63 tmr_interrupt_enable(TMR2, TMR_OVF_INT, TRUE);
64
65 /* config tmr 2 nvic */
66 nvic_irq_enable(TMR2_GLOBAL_IRQn, 0, 0);
67
68 /* enable tmr 2 */
69 tmr_counter_enable(TMR2, TRUE);
70}
71
77int main(void)
78{
79 __IO uint32_t index = 0;
80 __IO uint32_t systick_index = 0;
81
82 /* congfig the system clock */
83 system_clock_config();
84
85 /* init at start board */
86 at32_board_init();
87
88 /* config priority group */
89 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
90
91 /* turn on the led light */
92 at32_led_on(LED2);
93 at32_led_on(LED3);
94 at32_led_on(LED4);
95
96 /* enable pwc clock */
97 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
98
99 /* config tmr 2 */
100 tmr2_config();
101
102 while(1)
103 {
104 at32_led_off(LED2);
105
106 /* save systick register configuration */
107 systick_index = SysTick->CTRL;
108 systick_index &= ~((uint32_t)0xFFFFFFFE);
109
110 /* disable systick */
111 SysTick->CTRL &= (uint32_t)0xFFFFFFFE;
112
113 /* enter sleep mode */
114 pwc_sleep_mode_enter(PWC_SLEEP_ENTER_WFI);
115
116 /* restore systick register configuration */
117 SysTick->CTRL |= systick_index;
118
119 /* wake up from sleep mode */
120 at32_led_on(LED2);
121 for(index = 0; index < 500000; index++);
122 }
123}
124
at32f435_437_board.h
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:40
tmr2_config
void tmr2_config(void)
tmr2 configuration.
Definition: project/at_start_f435/examples/pwc/sleep_tmr2/src/main.c:43
main
int main(void)
main function.
Definition: project/at_start_f435/examples/pwc/sleep_tmr2/src/main.c:77
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:128
TRUE
@ TRUE
Definition: at32f435_437.h:379
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
pwc_sleep_mode_enter
void pwc_sleep_mode_enter(pwc_sleep_enter_type pwc_sleep_enter)
enter pwc sleep mode
Definition: at32f435_437_pwc.c:167
PWC_SLEEP_ENTER_WFI
@ PWC_SLEEP_ENTER_WFI
Definition: at32f435_437_pwc.h:111
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f435_437_tmr.c:1389
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f435_437_tmr.h:97
TMR_OVF_INT
#define TMR_OVF_INT
Definition: at32f435_437_tmr.h:75
TMR2
#define TMR2
Definition: at32f435_437_tmr.h:896
TMR2_GLOBAL_IRQn
@ TMR2_GLOBAL_IRQn
Definition: at32f435_437.h:176
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f435_437_crm.h:789
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • pwc
  • sleep_usart1
  • inc
project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • pwc
  • sleep_usart1
  • inc
project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • pwc
  • sleep_usart1
  • inc
project/at_start_f435/examples/pwc/sleep_usart1/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • pwc
  • sleep_usart1
  • src
Functions
project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • pwc
  • sleep_usart1
  • src
project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • pwc
  • sleep_usart1
  • src
Functions | Variables
project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | USART1_IRQHandler (void)
this function handles the usatt interrupt request. More...

Variables

uint16_t usart1_index = 0

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • pwc
  • sleep_usart1
  • src
project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29#include "at32f435_437_board.h"
30
39uint16_t usart1_index = 0;
45void NMI_Handler(void)
46{
47}
48
54void HardFault_Handler(void)
55{
56 /* go to infinite loop when hard fault exception occurs */
57 while(1)
58 {
59 }
60}
61
67void MemManage_Handler(void)
68{
69 /* go to infinite loop when memory manage exception occurs */
70 while(1)
71 {
72 }
73}
74
80void BusFault_Handler(void)
81{
82 /* go to infinite loop when bus fault exception occurs */
83 while(1)
84 {
85 }
86}
87
93void UsageFault_Handler(void)
94{
95 /* go to infinite loop when usage fault exception occurs */
96 while(1)
97 {
98 }
99}
100
106void SVC_Handler(void)
107{
108}
109
115void DebugMon_Handler(void)
116{
117}
118
124void PendSV_Handler(void)
125{
126}
127
133void SysTick_Handler(void)
134{
135}
136
142void USART1_IRQHandler(void)
143{
144 if(usart_flag_get(USART1, USART_RDBF_FLAG) != RESET)
145 {
146 /* clear rdbf flag */
147 usart1_index = usart_data_receive(USART1);
148
149 /* toggle led */
150 at32_led_toggle(LED4);
151 }
152}
153
at32f435_437_board.h
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c:93
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c:54
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c:67
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c:106
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c:124
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c:45
USART1_IRQHandler
void USART1_IRQHandler(void)
this function handles the usatt interrupt request.
Definition: project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c:142
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c:80
usart1_index
uint16_t usart1_index
Definition: project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c:39
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c:133
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/pwc/sleep_usart1/src/at32f435_437_int.c:115
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
RESET
@ RESET
Definition: at32f435_437.h:378
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f435_437_usart.c:598
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f435_437_usart.c:425
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f435_437_usart.h:57
USART1
#define USART1
Definition: at32f435_437_usart.h:348
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • pwc
  • sleep_usart1
  • src
Functions
project/at_start_f435/examples/pwc/sleep_usart1/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | usart1_config (uint32_t baudrate)
usart1 configuration. More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/sleep_usart1/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • pwc
  • sleep_usart1
  • src
project/at_start_f435/examples/pwc/sleep_usart1/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
43void usart1_config(uint32_t baudrate)
44{
45 gpio_init_type gpio_init_struct;
46
47 /* enable the uart1 and gpio clock */
48 crm_periph_clock_enable(CRM_USART1_PERIPH_CLOCK, TRUE);
49 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
50
51 gpio_default_para_init(&gpio_init_struct);
52
53 /* configure the uart1 tx pin */
54 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
55 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
56 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
57 gpio_init_struct.gpio_pins = GPIO_PINS_9;
58 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
59 gpio_init(GPIOA, &gpio_init_struct);
60 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE9, GPIO_MUX_7);
61
62 /* configure the uart1 rx pin */
63 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
64 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
65 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
66 gpio_init_struct.gpio_pins = GPIO_PINS_10;
67 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
68 gpio_init(GPIOA, &gpio_init_struct);
69 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE10, GPIO_MUX_7);
70
71 nvic_irq_enable(USART1_IRQn, 0, 0);
72
73 /* configure uart param */
74 usart_init(USART1, baudrate, USART_DATA_8BITS, USART_STOP_1_BIT);
75 usart_parity_selection_config(USART1, USART_PARITY_NONE);
76 usart_transmitter_enable(USART1, TRUE);
77 usart_receiver_enable(USART1, TRUE);
78 usart_hardware_flow_control_set(USART1,USART_HARDWARE_FLOW_NONE);
79 usart_interrupt_enable(USART1, USART_RDBF_INT, TRUE);
80 usart_enable(USART1, TRUE);
81}
82
88int main(void)
89{
90 __IO uint32_t index = 0;
91 __IO uint32_t systick_index = 0;
92
93 /* congfig the system clock */
94 system_clock_config();
95
96 /* init at start board */
97 at32_board_init();
98
99 /* config priority group */
100 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
101
102 /* turn on the led light */
103 at32_led_on(LED2);
104 at32_led_on(LED3);
105 at32_led_on(LED4);
106
107 /* enable pwc clock */
108 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
109
110 /* config usart1 */
111 usart1_config(115200);
112
113 printf("exit sleep mode by usart1 rdbf interrupt \r\n");
114
115 while(1)
116 {
117 at32_led_off(LED2);
118 at32_led_off(LED3);
119 printf("now enter sleep mode \r\n");
120
121 /* save systick register configuration */
122 systick_index = SysTick->CTRL;
123 systick_index &= ~((uint32_t)0xFFFFFFFE);
124
125 /* disable systick */
126 SysTick->CTRL &= (uint32_t)0xFFFFFFFE;
127
128 /* enter sleep mode */
129 pwc_sleep_mode_enter(PWC_SLEEP_ENTER_WFI);
130
131 /* restore systick register configuration */
132 SysTick->CTRL |= systick_index;
133
134 /* wake up from sleep mode */
135 printf("now exit sleep mode by usart1 rdbf interrupt \r\n");
136 printf("\r\n");
137 at32_led_on(LED2);
138 for(index = 0; index < 500000; index++);
139 }
140}
141
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f435/examples/pwc/sleep_usart1/src/main.c:88
usart1_config
void usart1_config(uint32_t baudrate)
usart1 configuration.
Definition: project/at_start_f435/examples/pwc/sleep_usart1/src/main.c:43
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_USART1_PERIPH_CLOCK
@ CRM_USART1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:156
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
pwc_sleep_mode_enter
void pwc_sleep_mode_enter(pwc_sleep_enter_type pwc_sleep_enter)
enter pwc sleep mode
Definition: at32f435_437_pwc.c:167
PWC_SLEEP_ENTER_WFI
@ PWC_SLEEP_ENTER_WFI
Definition: at32f435_437_pwc.h:111
usart_parity_selection_config
void usart_parity_selection_config(usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config.
Definition: at32f435_437_usart.c:168
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f435_437_usart.c:209
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f435_437_usart.c:115
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f435_437_usart.c:196
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f435_437_usart.c:222
usart_hardware_flow_control_set
void usart_hardware_flow_control_set(usart_type *usart_x, usart_hardware_flow_control_type flow_state)
configure the usart's hardware flow control.
Definition: at32f435_437_usart.c:555
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f435_437_usart.c:287
USART_HARDWARE_FLOW_NONE
@ USART_HARDWARE_FLOW_NONE
Definition: at32f435_437_usart.h:170
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f435_437_usart.h:159
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f435_437_usart.h:114
USART_PARITY_NONE
@ USART_PARITY_NONE
Definition: at32f435_437_usart.h:94
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f435_437_usart.h:73
USART1
#define USART1
Definition: at32f435_437_usart.h:348
USART1_IRQn
@ USART1_IRQn
Definition: at32f435_437.h:185
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • pwc
  • standby_ertc_alarm
  • inc
project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • pwc
  • standby_ertc_alarm
  • inc
project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • pwc
  • standby_ertc_alarm
  • inc
project/at_start_f435/examples/pwc/standby_ertc_alarm/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • pwc
  • standby_ertc_alarm
  • src
Functions
project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • pwc
  • standby_ertc_alarm
  • src
project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • pwc
  • standby_ertc_alarm
  • src
Functions
project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • pwc
  • standby_ertc_alarm
  • src
project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/pwc/standby_ertc_alarm/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • pwc
  • standby_ertc_alarm
  • src
Functions
project/at_start_f435/examples/pwc/standby_ertc_alarm/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | ertc_config (void)
ertc configuration. More...
void | ertc_alarm_config (void)
ertc alarm configuration. More...
void | ertc_alarm_value_set (uint32_t alam_index)
ertc alarm value set. More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/standby_ertc_alarm/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • pwc
  • standby_ertc_alarm
  • src
project/at_start_f435/examples/pwc/standby_ertc_alarm/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
43void ertc_config(void)
44{
45 /* enable the pwc clock interface */
46 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
47
48 /* allow access to ertc */
49 pwc_battery_powered_domain_access(TRUE);
50
51 /* reset ertc domain */
52 crm_battery_powered_domain_reset(TRUE);
53 crm_battery_powered_domain_reset(FALSE);
54
55 /* enable the lext osc */
56 crm_clock_source_enable(CRM_CLOCK_SOURCE_LEXT, TRUE);
57
58 /* wait till lext is ready */
59 while(crm_flag_get(CRM_LEXT_STABLE_FLAG) == RESET);
60
61 /* select the ertc clock source */
62 crm_ertc_clock_select(CRM_ERTC_CLOCK_LEXT);
63
64 /* enable the ertc clock */
65 crm_ertc_clock_enable(TRUE);
66
67 /* deinitializes the ertc registers */
68 ertc_reset();
69
70 /* wait for ertc apb registers synchronisation */
71 ertc_wait_update();
72
73 /* configure the ertc data register and ertc prescaler
74 ck_spre(1hz) = ertcclk(lext) /(ertc_clk_div_a + 1)*(ertc_clk_div_b + 1)*/
75 ertc_divider_set(127, 255);
76
77 /* configure the hour format is 24-hour format*/
78 ertc_hour_mode_set(ERTC_HOUR_MODE_24);
79
80 /* set the date: friday june 11th 2021 */
81 ertc_date_set(21, 6, 11, 5);
82
83 /* set the time to 06h 20mn 00s am */
84 ertc_time_set(6, 20, 0, ERTC_AM);
85}
86
92void ertc_alarm_config(void)
93{
94 /* set the alarm 05h:20min:10s */
95 ertc_alarm_mask_set(ERTC_ALA, ERTC_ALARM_MASK_DATE_WEEK | ERTC_ALARM_MASK_HOUR | ERTC_ALARM_MASK_MIN);
96 ertc_alarm_week_date_select(ERTC_ALA, ERTC_SLECT_DATE);
97
98 /* enable ertc alarm a interrupt */
99 ertc_interrupt_enable(ERTC_ALA_INT, TRUE);
100}
101
107void ertc_alarm_value_set(uint32_t alam_index)
108{
109 ertc_time_type ertc_time_struct;
110
111 /* disable the alarm */
112 ertc_alarm_enable(ERTC_ALA, FALSE);
113 ertc_calendar_get(&ertc_time_struct);
114 ertc_alarm_set(ERTC_ALA, ertc_time_struct.day, ertc_time_struct.hour, ertc_time_struct.min, (ertc_time_struct.sec + alam_index)% 60, ertc_time_struct.ampm);
115
116 /* disable the alarm */
117 ertc_alarm_enable(ERTC_ALA, TRUE);
118}
119
125int main(void)
126{
127 __IO uint32_t index = 0;
128
129 /* congfig the system clock */
130 system_clock_config();
131
132 /* init at start board */
133 at32_board_init();
134
135 /* enable pwc and bpr clock */
136 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
137
138 if(pwc_flag_get(PWC_STANDBY_FLAG) != RESET)
139 {
140 /* wakeup from standby */
141 pwc_flag_clear(PWC_STANDBY_FLAG);
142 at32_led_on(LED2);
143 }
144 if(pwc_flag_get(PWC_WAKEUP_FLAG) != RESET)
145 {
146 /* wakeup event occurs */
147 pwc_flag_clear(PWC_WAKEUP_FLAG);
148 at32_led_on(LED3);
149 }
150 delay_sec(1);
151 /* config ertc */
152 ertc_config();
153 at32_led_on(LED4);
154 ertc_alarm_config();
155 delay_sec(1);
156 ertc_alarm_value_set(3);
157
158 /* enter standby mode */
159 pwc_standby_mode_enter();
160 while(1)
161 {
162 }
163}
164
at32f435_437_board.h
main
int main(void)
main function.
Definition: project/at_start_f435/examples/pwc/standby_ertc_alarm/src/main.c:125
ertc_config
void ertc_config(void)
ertc configuration.
Definition: project/at_start_f435/examples/pwc/standby_ertc_alarm/src/main.c:43
ertc_alarm_value_set
void ertc_alarm_value_set(uint32_t alam_index)
ertc alarm value set.
Definition: project/at_start_f435/examples/pwc/standby_ertc_alarm/src/main.c:107
ertc_alarm_config
void ertc_alarm_config(void)
ertc alarm configuration.
Definition: project/at_start_f435/examples/pwc/standby_ertc_alarm/src/main.c:92
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_ertc_clock_select
void crm_ertc_clock_select(crm_ertc_clock_type value)
select ertc clock
Definition: at32f435_437_crm.c:434
crm_ertc_clock_enable
void crm_ertc_clock_enable(confirm_state new_state)
enable or disable ertc
Definition: at32f435_437_crm.c:445
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_battery_powered_domain_reset
void crm_battery_powered_domain_reset(confirm_state new_state)
battery powered domain software reset
Definition: at32f435_437_crm.c:541
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_CLOCK_SOURCE_LEXT
@ CRM_CLOCK_SOURCE_LEXT
Definition: at32f435_437_crm.h:562
CRM_ERTC_CLOCK_LEXT
@ CRM_ERTC_CLOCK_LEXT
Definition: at32f435_437_crm.h:632
CRM_LEXT_STABLE_FLAG
#define CRM_LEXT_STABLE_FLAG
Definition: at32f435_437_crm.h:58
ertc_hour_mode_set
error_status ertc_hour_mode_set(ertc_hour_mode_set_type mode)
ertc hour mode set.
Definition: at32f435_437_ertc.c:283
ertc_wait_update
error_status ertc_wait_update(void)
ertc wait register update finish.
Definition: at32f435_437_ertc.c:97
ertc_time_set
error_status ertc_time_set(uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
set time.
Definition: at32f435_437_ertc.c:363
ertc_reset
error_status ertc_reset(void)
ertc reset all register.
Definition: at32f435_437_ertc.c:207
ertc_alarm_mask_set
void ertc_alarm_mask_set(ertc_alarm_type alarm_x, uint32_t mask)
set which bits are irrelevant to the alarm match.
Definition: at32f435_437_ertc.c:458
ertc_interrupt_enable
void ertc_interrupt_enable(uint32_t source, confirm_state new_state)
enable or disable interrupt.
Definition: at32f435_437_ertc.c:1386
ertc_alarm_week_date_select
void ertc_alarm_week_date_select(ertc_alarm_type alarm_x, ertc_week_date_select_type wk)
alarm week or date mode select.
Definition: at32f435_437_ertc.c:500
ertc_date_set
error_status ertc_date_set(uint8_t year, uint8_t month, uint8_t date, uint8_t week)
set date.
Definition: at32f435_437_ertc.c:314
ertc_alarm_set
void ertc_alarm_set(ertc_alarm_type alarm_x, uint8_t week_date, uint8_t hour, uint8_t min, uint8_t sec, ertc_am_pm_type ampm)
set alarm.
Definition: at32f435_437_ertc.c:538
ertc_calendar_get
void ertc_calendar_get(ertc_time_type *time)
get calendar
Definition: at32f435_437_ertc.c:404
ertc_divider_set
error_status ertc_divider_set(uint16_t div_a, uint16_t div_b)
ertc division set.
Definition: at32f435_437_ertc.c:251
ertc_alarm_enable
error_status ertc_alarm_enable(ertc_alarm_type alarm_x, confirm_state new_state)
enable or disable alarm clock.
Definition: at32f435_437_ertc.c:629
ERTC_SLECT_DATE
@ ERTC_SLECT_DATE
Definition: at32f435_437_ertc.h:135
ERTC_HOUR_MODE_24
@ ERTC_HOUR_MODE_24
Definition: at32f435_437_ertc.h:116
ERTC_ALA
@ ERTC_ALA
Definition: at32f435_437_ertc.h:144
ERTC_AM
@ ERTC_AM
Definition: at32f435_437_ertc.h:126
ERTC_ALARM_MASK_DATE_WEEK
#define ERTC_ALARM_MASK_DATE_WEEK
Definition: at32f435_437_ertc.h:90
ERTC_ALARM_MASK_HOUR
#define ERTC_ALARM_MASK_HOUR
Definition: at32f435_437_ertc.h:89
ERTC_ALARM_MASK_MIN
#define ERTC_ALARM_MASK_MIN
Definition: at32f435_437_ertc.h:88
ERTC_ALA_INT
#define ERTC_ALA_INT
Definition: at32f435_437_ertc.h:53
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f435_437_pwc.c:61
pwc_standby_mode_enter
void pwc_standby_mode_enter(void)
enter pwc standby mode
Definition: at32f435_437_pwc.c:224
pwc_flag_get
flag_status pwc_flag_get(uint32_t pwc_flag)
get flag of pwc
Definition: at32f435_437_pwc.c:145
pwc_flag_clear
void pwc_flag_clear(uint32_t pwc_flag)
clear flag of pwc
Definition: at32f435_437_pwc.c:128
PWC_STANDBY_FLAG
#define PWC_STANDBY_FLAG
Definition: at32f435_437_pwc.h:53
PWC_WAKEUP_FLAG
#define PWC_WAKEUP_FLAG
Definition: at32f435_437_pwc.h:52
ertc_time_type
ertc time
Definition: at32f435_437_ertc.h:383
ertc_time_type::ampm
ertc_am_pm_type ampm
Definition: at32f435_437_ertc.h:391
ertc_time_type::day
uint8_t day
Definition: at32f435_437_ertc.h:386
ertc_time_type::hour
uint8_t hour
Definition: at32f435_437_ertc.h:387
ertc_time_type::min
uint8_t min
Definition: at32f435_437_ertc.h:388
ertc_time_type::sec
uint8_t sec
Definition: at32f435_437_ertc.h:389
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • pwc
  • standby_wakeup_pin
  • inc
project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • pwc
  • standby_wakeup_pin
  • inc
project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • pwc
  • standby_wakeup_pin
  • inc
project/at_start_f435/examples/pwc/standby_wakeup_pin/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • pwc
  • standby_wakeup_pin
  • src
Functions
project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • pwc
  • standby_wakeup_pin
  • src
project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • pwc
  • standby_wakeup_pin
  • src
Functions
project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • pwc
  • standby_wakeup_pin
  • src
project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/pwc/standby_wakeup_pin/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • pwc
  • standby_wakeup_pin
  • src
Functions
project/at_start_f435/examples/pwc/standby_wakeup_pin/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/pwc/standby_wakeup_pin/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • pwc
  • standby_wakeup_pin
  • src
project/at_start_f435/examples/pwc/standby_wakeup_pin/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
43int main(void)
44{
45 __IO uint32_t index = 0;
46
47 /* congfig the system clock */
48 system_clock_config();
49
50 /* init at start board */
51 at32_board_init();
52
53 /* config priority group */
54 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
55
56 /* turn on the led light */
57 at32_led_off(LED2);
58 at32_led_off(LED3);
59 at32_led_off(LED4);
60
61 /* enable pwc clock */
62 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
63
64 if(pwc_flag_get(PWC_STANDBY_FLAG) != RESET)
65 {
66 /* wakeup from standby */
67 pwc_flag_clear(PWC_STANDBY_FLAG);
68 at32_led_on(LED2);
69 }
70
71 if(pwc_flag_get(PWC_WAKEUP_FLAG) != RESET)
72 {
73 /* wakeup event occurs */
74 pwc_flag_clear(PWC_WAKEUP_FLAG);
75 at32_led_on(LED3);
76 }
77
78 at32_led_on(LED4);
79 for(index = 0; index < 0xFFFFFF; index++);
80
81 /* enable wakeup pin1(pa0), pin2(pc13) */
82 pwc_wakeup_pin_enable(PWC_WAKEUP_PIN_1 | PWC_WAKEUP_PIN_2, TRUE);
83
84 /* enter standby mode */
85 pwc_standby_mode_enter();
86
87 while(1)
88 {
89 }
90}
91
at32f435_437_board.h
main
int main(void)
main function.
Definition: project/at_start_f435/examples/pwc/standby_wakeup_pin/src/main.c:43
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
pwc_standby_mode_enter
void pwc_standby_mode_enter(void)
enter pwc standby mode
Definition: at32f435_437_pwc.c:224
pwc_flag_get
flag_status pwc_flag_get(uint32_t pwc_flag)
get flag of pwc
Definition: at32f435_437_pwc.c:145
pwc_flag_clear
void pwc_flag_clear(uint32_t pwc_flag)
clear flag of pwc
Definition: at32f435_437_pwc.c:128
pwc_wakeup_pin_enable
void pwc_wakeup_pin_enable(uint32_t pin_num, confirm_state new_state)
enable or disable pwc standby wakeup pin
Definition: at32f435_437_pwc.c:107
PWC_STANDBY_FLAG
#define PWC_STANDBY_FLAG
Definition: at32f435_437_pwc.h:53
PWC_WAKEUP_FLAG
#define PWC_WAKEUP_FLAG
Definition: at32f435_437_pwc.h:52
PWC_WAKEUP_PIN_2
#define PWC_WAKEUP_PIN_2
Definition: at32f435_437_pwc.h:64
PWC_WAKEUP_PIN_1
#define PWC_WAKEUP_PIN_1
pwc wakeup pin num definition
Definition: at32f435_437_pwc.h:63
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma
  • inc
project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma
  • inc
project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma
  • inc
project/at_start_f435/examples/qspi/command_port_using_dma/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma
  • src
Functions
project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma
  • src
project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma
  • src
Functions
project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma
  • src
project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma
  • src
Macros | Functions | Variables
project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include <string.h>

Go to the source code of this file.

Macros

#define TEST_SIZE 4096

Functions

void | qspi_data_read (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data More...
void | qspi_data_write (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data More...
void | qspi_erase (uint32_t sec_addr)
qspi erase data More...
void | qspi_config (void)
qspi config More...
int | main (void)
main function. More...

Variables

ALIGNED_HEAD uint8_t wbuf[4096] ALIGNED_TAIL

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma
  • src
project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include <string.h>
30
39extern void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t* buf);
40extern void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t* buf);
41extern void qspi_erase(uint32_t sec_addr);
42
43#define TEST_SIZE 4096
44/* use dma transmit must align at word */
45#if defined ( __ICCARM__ ) /* iar compiler */
46 #pragma data_alignment=4
47#endif
48ALIGNED_HEAD uint8_t wbuf[TEST_SIZE] ALIGNED_TAIL;
49
50#if defined ( __ICCARM__ ) /* iar compiler */
51 #pragma data_alignment=4
52#endif
53ALIGNED_HEAD uint8_t rbuf[TEST_SIZE] ALIGNED_TAIL;
54
60void qspi_config(void)
61{
62 gpio_init_type gpio_init_struct;
63 /* enable the dma clock */
64 crm_periph_clock_enable(CRM_DMA2_PERIPH_CLOCK, TRUE);
65
66 /* enable the qspi clock */
67 crm_periph_clock_enable(CRM_QSPI1_PERIPH_CLOCK, TRUE);
68
69 /* enable the pin clock */
70 crm_periph_clock_enable(CRM_GPIOF_PERIPH_CLOCK, TRUE);
71 crm_periph_clock_enable(CRM_GPIOG_PERIPH_CLOCK, TRUE);
72
73 /* set default parameter */
74 gpio_default_para_init(&gpio_init_struct);
75
76 /* configure the io0 gpio */
77 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
78 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
79 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
80 gpio_init_struct.gpio_pins = GPIO_PINS_8;
81 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
82 gpio_init(GPIOF, &gpio_init_struct);
83 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE8, GPIO_MUX_10);
84
85 /* configure the io1 gpio */
86 gpio_init_struct.gpio_pins = GPIO_PINS_9;
87 gpio_init(GPIOF, &gpio_init_struct);
88 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE9, GPIO_MUX_10);
89
90 /* configure the io2 gpio */
91 gpio_init_struct.gpio_pins = GPIO_PINS_7;
92 gpio_init(GPIOF, &gpio_init_struct);
93 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE7, GPIO_MUX_9);
94
95 /* configure the io3 gpio */
96 gpio_init_struct.gpio_pins = GPIO_PINS_6;
97 gpio_init(GPIOF, &gpio_init_struct);
98 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE6, GPIO_MUX_9);
99
100 /* configure the sck gpio */
101 gpio_init_struct.gpio_pins = GPIO_PINS_10;
102 gpio_init(GPIOF, &gpio_init_struct);
103 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE10, GPIO_MUX_9);
104
105 /* configure the cs gpio */
106 gpio_init_struct.gpio_pins = GPIO_PINS_6;
107 gpio_init(GPIOG, &gpio_init_struct);
108 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE6, GPIO_MUX_10);
109}
110
116int main(void)
117{
118 uint16_t i, err = 0;
119
120 system_clock_config();
121 at32_board_init();
122
123 for(i = 0; i < TEST_SIZE; i++)
124 {
125 wbuf[i] = (uint8_t)i;
126 rbuf[i] = 0;
127 }
128 /* qspi config */
129 qspi_config();
130
131 /* switch to cmd port */
132 qspi_xip_enable(QSPI1, FALSE);
133
134 /* set sclk */
135 qspi_clk_division_set(QSPI1, QSPI_CLK_DIV_4);
136
137 /* set sck idle mode 0 */
138 qspi_sck_mode_set(QSPI1, QSPI_SCK_MODE_0);
139
140 /* set wip in bit 0 */
141 qspi_busy_config(QSPI1, QSPI_BUSY_OFFSET_0);
142
143 /* erase */
144 qspi_erase(0);
145
146 /* read */
147 qspi_data_read(0, TEST_SIZE, rbuf);
148
149 for(i = 0; i < TEST_SIZE; i++)
150 {
151 if(rbuf[i] != 0xFF)
152 {
153 err = 1;
154 break;
155 }
156 }
157
158 /* program */
159 qspi_data_write(0, TEST_SIZE, wbuf);
160
161 /* read */
162 qspi_data_read(0, TEST_SIZE, rbuf);
163
164 if(memcmp(rbuf, wbuf, TEST_SIZE))
165 {
166 err = 1;
167 }
168
169 while(1)
170 {
171 if(err == 0)
172 {
173 at32_led_toggle(LED3);
174 delay_ms(300);
175 }
176 else
177 {
178 at32_led_toggle(LED2);
179 delay_ms(300);
180 }
181 }
182}
183
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
ALIGNED_TAIL
ALIGNED_HEAD uint8_t wbuf[4096] ALIGNED_TAIL
Definition: project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c:48
qspi_erase
void qspi_erase(uint32_t sec_addr)
qspi erase data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:281
qspi_config
void qspi_config(void)
qspi config
Definition: project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c:60
main
int main(void)
main function.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c:116
TEST_SIZE
#define TEST_SIZE
Definition: project/at_start_f435/examples/qspi/command_port_using_dma/src/main.c:43
qspi_data_read
void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:192
qspi_data_write
void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data
Definition: at_start_f435/examples/qspi/command_port_using_dma/src/qspi_cmd_esmt32m.c:256
wbuf
uint8_t wbuf[4096]
Definition: project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c:44
rbuf
uint8_t rbuf[4096]
Definition: project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c:45
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOF_PERIPH_CLOCK
@ CRM_GPIOF_PERIPH_CLOCK
Definition: at32f435_437_crm.h:110
CRM_GPIOG_PERIPH_CLOCK
@ CRM_GPIOG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:111
CRM_QSPI1_PERIPH_CLOCK
@ CRM_QSPI1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:124
CRM_DMA2_PERIPH_CLOCK
@ CRM_DMA2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:116
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_9
@ GPIO_MUX_9
Definition: at32f435_437_gpio.h:165
GPIO_MUX_10
@ GPIO_MUX_10
Definition: at32f435_437_gpio.h:166
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOG
#define GPIOG
Definition: at32f435_437_gpio.h:527
GPIOF
#define GPIOF
Definition: at32f435_437_gpio.h:526
qspi_sck_mode_set
void qspi_sck_mode_set(qspi_type *qspi_x, qspi_clk_mode_type new_mode)
set qspi sck mode.
Definition: at32f435_437_qspi.c:70
qspi_xip_enable
void qspi_xip_enable(qspi_type *qspi_x, confirm_state new_state)
enable xip mode or command-port mode.
Definition: at32f435_437_qspi.c:254
qspi_busy_config
void qspi_busy_config(qspi_type *qspi_x, qspi_busy_pos_type busy_pos)
set wip position in status register of flash
Definition: at32f435_437_qspi.c:241
qspi_clk_division_set
void qspi_clk_division_set(qspi_type *qspi_x, qspi_clk_div_type new_clkdiv)
set qspi clock division
Definition: at32f435_437_qspi.c:93
QSPI_BUSY_OFFSET_0
@ QSPI_BUSY_OFFSET_0
Definition: at32f435_437_qspi.h:87
QSPI_SCK_MODE_0
@ QSPI_SCK_MODE_0
Definition: at32f435_437_qspi.h:171
QSPI_CLK_DIV_4
@ QSPI_CLK_DIV_4
Definition: at32f435_437_qspi.h:126
QSPI1
#define QSPI1
Definition: at32f435_437_qspi.h:512
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_and_pem
  • inc
project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_and_pem
  • inc
project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_and_pem
  • inc
project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_and_pem
  • src
Functions
project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_and_pem
  • src
project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_and_pem
  • src
Functions
project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_and_pem
  • src
project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_and_pem
  • src
Macros | Functions | Variables
project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include <string.h>

Go to the source code of this file.

Macros

#define TEST_SIZE 4096

Functions

void | qspi_data_read (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data More...
void | qspi_data_write (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data More...
void | qspi_erase (uint32_t sec_addr)
qspi erase data More...
void | qspi_config (void)
qspi config More...
int | main (void)
main function. More...

Variables

ALIGNED_HEAD uint8_t wbuf[4096] ALIGNED_TAIL

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_and_pem
  • src
project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include <string.h>
30
39extern void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t* buf);
40extern void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t* buf);
41extern void qspi_erase(uint32_t sec_addr);
42
43#define TEST_SIZE 4096
44/* use dma transmit must align at word */
45#if defined ( __ICCARM__ ) /* iar compiler */
46 #pragma data_alignment=4
47#endif
48ALIGNED_HEAD uint8_t wbuf[TEST_SIZE] ALIGNED_TAIL;
49
50#if defined ( __ICCARM__ ) /* iar compiler */
51 #pragma data_alignment=4
52#endif
53ALIGNED_HEAD uint8_t rbuf[TEST_SIZE] ALIGNED_TAIL;
54
60void qspi_config(void)
61{
62 gpio_init_type gpio_init_struct;
63 /* enable the dma clock */
64 crm_periph_clock_enable(CRM_DMA2_PERIPH_CLOCK, TRUE);
65
66 /* enable the qspi clock */
67 crm_periph_clock_enable(CRM_QSPI1_PERIPH_CLOCK, TRUE);
68
69 /* enable the pin clock */
70 crm_periph_clock_enable(CRM_GPIOF_PERIPH_CLOCK, TRUE);
71 crm_periph_clock_enable(CRM_GPIOG_PERIPH_CLOCK, TRUE);
72
73 /* set default parameter */
74 gpio_default_para_init(&gpio_init_struct);
75
76 /* configure the io0 gpio */
77 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
78 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
79 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
80 gpio_init_struct.gpio_pins = GPIO_PINS_8;
81 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
82 gpio_init(GPIOF, &gpio_init_struct);
83 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE8, GPIO_MUX_10);
84
85 /* configure the io1 gpio */
86 gpio_init_struct.gpio_pins = GPIO_PINS_9;
87 gpio_init(GPIOF, &gpio_init_struct);
88 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE9, GPIO_MUX_10);
89
90 /* configure the io2 gpio */
91 gpio_init_struct.gpio_pins = GPIO_PINS_7;
92 gpio_init(GPIOF, &gpio_init_struct);
93 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE7, GPIO_MUX_9);
94
95 /* configure the io3 gpio */
96 gpio_init_struct.gpio_pins = GPIO_PINS_6;
97 gpio_init(GPIOF, &gpio_init_struct);
98 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE6, GPIO_MUX_9);
99
100 /* configure the sck gpio */
101 gpio_init_struct.gpio_pins = GPIO_PINS_10;
102 gpio_init(GPIOF, &gpio_init_struct);
103 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE10, GPIO_MUX_9);
104
105 /* configure the cs gpio */
106 gpio_init_struct.gpio_pins = GPIO_PINS_6;
107 gpio_init(GPIOG, &gpio_init_struct);
108 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE6, GPIO_MUX_10);
109}
110
116int main(void)
117{
118 uint16_t i, err = 0;
119
120 system_clock_config();
121 at32_board_init();
122
123 for(i = 0; i < TEST_SIZE; i++)
124 {
125 wbuf[i] = (uint8_t)i;
126 rbuf[i] = 0;
127 }
128 /* qspi config */
129 qspi_config();
130
131 /* switch to cmd port */
132 qspi_xip_enable(QSPI1, FALSE);
133
134 /* set sclk */
135 qspi_clk_division_set(QSPI1, QSPI_CLK_DIV_4);
136
137 /* set sck idle mode 0 */
138 qspi_sck_mode_set(QSPI1, QSPI_SCK_MODE_0);
139
140 /* set wip in bit 0 */
141 qspi_busy_config(QSPI1, QSPI_BUSY_OFFSET_0);
142
143 /* erase */
144 qspi_erase(0);
145
146 /* read */
147 qspi_data_read(0, TEST_SIZE, rbuf);
148
149 for(i = 0; i < TEST_SIZE; i++)
150 {
151 if(rbuf[i] != 0xFF)
152 {
153 err = 1;
154 break;
155 }
156 }
157
158 /* program */
159 qspi_data_write(0, TEST_SIZE, wbuf);
160
161 /* read */
162 qspi_data_read(0, TEST_SIZE, rbuf);
163
164 if(memcmp(rbuf, wbuf, TEST_SIZE))
165 {
166 err = 1;
167 }
168
169 while(1)
170 {
171 if(err == 0)
172 {
173 at32_led_toggle(LED3);
174 delay_ms(300);
175 }
176 else
177 {
178 at32_led_toggle(LED2);
179 delay_ms(300);
180 }
181 }
182}
183
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
ALIGNED_TAIL
ALIGNED_HEAD uint8_t wbuf[4096] ALIGNED_TAIL
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c:48
qspi_erase
void qspi_erase(uint32_t sec_addr)
qspi erase data
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:373
qspi_config
void qspi_config(void)
qspi config
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c:60
main
int main(void)
main function.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c:116
TEST_SIZE
#define TEST_SIZE
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/main.c:43
qspi_data_read
void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:288
qspi_data_write
void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data
Definition: at_start_f435/examples/qspi/command_port_using_dma_and_pem/src/qspi_cmd_esmt32m.c:348
wbuf
uint8_t wbuf[4096]
Definition: project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c:44
rbuf
uint8_t rbuf[4096]
Definition: project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c:45
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOF_PERIPH_CLOCK
@ CRM_GPIOF_PERIPH_CLOCK
Definition: at32f435_437_crm.h:110
CRM_GPIOG_PERIPH_CLOCK
@ CRM_GPIOG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:111
CRM_QSPI1_PERIPH_CLOCK
@ CRM_QSPI1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:124
CRM_DMA2_PERIPH_CLOCK
@ CRM_DMA2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:116
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_9
@ GPIO_MUX_9
Definition: at32f435_437_gpio.h:165
GPIO_MUX_10
@ GPIO_MUX_10
Definition: at32f435_437_gpio.h:166
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOG
#define GPIOG
Definition: at32f435_437_gpio.h:527
GPIOF
#define GPIOF
Definition: at32f435_437_gpio.h:526
qspi_sck_mode_set
void qspi_sck_mode_set(qspi_type *qspi_x, qspi_clk_mode_type new_mode)
set qspi sck mode.
Definition: at32f435_437_qspi.c:70
qspi_xip_enable
void qspi_xip_enable(qspi_type *qspi_x, confirm_state new_state)
enable xip mode or command-port mode.
Definition: at32f435_437_qspi.c:254
qspi_busy_config
void qspi_busy_config(qspi_type *qspi_x, qspi_busy_pos_type busy_pos)
set wip position in status register of flash
Definition: at32f435_437_qspi.c:241
qspi_clk_division_set
void qspi_clk_division_set(qspi_type *qspi_x, qspi_clk_div_type new_clkdiv)
set qspi clock division
Definition: at32f435_437_qspi.c:93
QSPI_BUSY_OFFSET_0
@ QSPI_BUSY_OFFSET_0
Definition: at32f435_437_qspi.h:87
QSPI_SCK_MODE_0
@ QSPI_SCK_MODE_0
Definition: at32f435_437_qspi.h:171
QSPI_CLK_DIV_4
@ QSPI_CLK_DIV_4
Definition: at32f435_437_qspi.h:126
QSPI1
#define QSPI1
Definition: at32f435_437_qspi.h:512
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
  • inc
project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
  • inc
project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
  • inc
project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
  • src
Functions
project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
  • src
project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
  • src
Functions
project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
  • src
project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
  • src
Macros | Functions | Variables
project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include <string.h>

Go to the source code of this file.

Macros

#define TEST_SIZE 4096

Functions

void | qspi_data_read (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data More...
void | qspi_data_write (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data More...
void | qspi_erase (uint32_t sec_addr)
qspi erase data More...
void | esmt32m_qpi_mode_init (void)
switch QSPI to cmd port and setup to qpi mode More...
void | qspi_config (void)
qspi config More...
int | main (void)
main function. More...

Variables

ALIGNED_HEAD uint8_t wbuf[4096] ALIGNED_TAIL

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_dma_qpi_mode
  • src
project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include <string.h>
30
39extern void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t* buf);
40extern void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t* buf);
41extern void qspi_erase(uint32_t sec_addr);
42extern void esmt32m_qpi_mode_init(void);
43
44#define TEST_SIZE 4096
45/* use dma transmit must align at word */
46#if defined ( __ICCARM__ ) /* iar compiler */
47 #pragma data_alignment=4
48#endif
49ALIGNED_HEAD uint8_t wbuf[TEST_SIZE] ALIGNED_TAIL;
50
51#if defined ( __ICCARM__ ) /* iar compiler */
52 #pragma data_alignment=4
53#endif
54ALIGNED_HEAD uint8_t rbuf[TEST_SIZE] ALIGNED_TAIL;
55
61void qspi_config(void)
62{
63 gpio_init_type gpio_init_struct;
64 /* enable the dma clock */
65 crm_periph_clock_enable(CRM_DMA2_PERIPH_CLOCK, TRUE);
66
67 /* enable the qspi clock */
68 crm_periph_clock_enable(CRM_QSPI1_PERIPH_CLOCK, TRUE);
69
70 /* enable the pin clock */
71 crm_periph_clock_enable(CRM_GPIOF_PERIPH_CLOCK, TRUE);
72 crm_periph_clock_enable(CRM_GPIOG_PERIPH_CLOCK, TRUE);
73
74 /* set default parameter */
75 gpio_default_para_init(&gpio_init_struct);
76
77 /* configure the io0 gpio */
78 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
79 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
80 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
81 gpio_init_struct.gpio_pins = GPIO_PINS_8;
82 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
83 gpio_init(GPIOF, &gpio_init_struct);
84 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE8, GPIO_MUX_10);
85
86 /* configure the io1 gpio */
87 gpio_init_struct.gpio_pins = GPIO_PINS_9;
88 gpio_init(GPIOF, &gpio_init_struct);
89 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE9, GPIO_MUX_10);
90
91 /* configure the io2 gpio */
92 gpio_init_struct.gpio_pins = GPIO_PINS_7;
93 gpio_init(GPIOF, &gpio_init_struct);
94 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE7, GPIO_MUX_9);
95
96 /* configure the io3 gpio */
97 gpio_init_struct.gpio_pins = GPIO_PINS_6;
98 gpio_init(GPIOF, &gpio_init_struct);
99 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE6, GPIO_MUX_9);
100
101 /* configure the sck gpio */
102 gpio_init_struct.gpio_pins = GPIO_PINS_10;
103 gpio_init(GPIOF, &gpio_init_struct);
104 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE10, GPIO_MUX_9);
105
106 /* configure the cs gpio */
107 gpio_init_struct.gpio_pins = GPIO_PINS_6;
108 gpio_init(GPIOG, &gpio_init_struct);
109 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE6, GPIO_MUX_10);
110}
111
117int main(void)
118{
119 uint16_t i, err = 0;
120
121 system_clock_config();
122 at32_board_init();
123
124 for(i = 0; i < TEST_SIZE; i++)
125 {
126 wbuf[i] = (uint8_t)i;
127 rbuf[i] = 0;
128 }
129 /* qspi config */
130 qspi_config();
131
132 /* switch to cmd port */
133 qspi_xip_enable(QSPI1, FALSE);
134
135 /* set sclk */
136 qspi_clk_division_set(QSPI1, QSPI_CLK_DIV_4);
137
138 /* set sck idle mode 0 */
139 qspi_sck_mode_set(QSPI1, QSPI_SCK_MODE_0);
140
141 /* set wip in bit 0 */
142 qspi_busy_config(QSPI1, QSPI_BUSY_OFFSET_0);
143
144 esmt32m_qpi_mode_init();
145
146 /* erase */
147 qspi_erase(0);
148
149 /* read */
150 qspi_data_read(0, TEST_SIZE, rbuf);
151
152 for(i = 0; i < TEST_SIZE; i++)
153 {
154 if(rbuf[i] != 0xFF)
155 {
156 err = 1;
157 break;
158 }
159 }
160
161 /* program */
162 qspi_data_write(0, TEST_SIZE, wbuf);
163
164 /* read */
165 qspi_data_read(0, TEST_SIZE, rbuf);
166
167 if(memcmp(rbuf, wbuf, TEST_SIZE))
168 {
169 err = 1;
170 }
171
172 while(1)
173 {
174 if(err == 0)
175 {
176 at32_led_toggle(LED3);
177 delay_ms(300);
178 }
179 else
180 {
181 at32_led_toggle(LED2);
182 delay_ms(300);
183 }
184 }
185}
186
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
ALIGNED_TAIL
ALIGNED_HEAD uint8_t wbuf[4096] ALIGNED_TAIL
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c:49
qspi_erase
void qspi_erase(uint32_t sec_addr)
qspi erase data
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:281
qspi_config
void qspi_config(void)
qspi config
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c:61
main
int main(void)
main function.
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c:117
TEST_SIZE
#define TEST_SIZE
Definition: project/at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/main.c:44
qspi_data_read
void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:192
qspi_data_write
void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:256
esmt32m_qpi_mode_init
void esmt32m_qpi_mode_init(void)
switch QSPI to cmd port and setup to qpi mode
Definition: at_start_f435/examples/qspi/command_port_using_dma_qpi_mode/src/qspi_cmd_esmt32m.c:427
wbuf
uint8_t wbuf[4096]
Definition: project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c:44
rbuf
uint8_t rbuf[4096]
Definition: project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c:45
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOF_PERIPH_CLOCK
@ CRM_GPIOF_PERIPH_CLOCK
Definition: at32f435_437_crm.h:110
CRM_GPIOG_PERIPH_CLOCK
@ CRM_GPIOG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:111
CRM_QSPI1_PERIPH_CLOCK
@ CRM_QSPI1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:124
CRM_DMA2_PERIPH_CLOCK
@ CRM_DMA2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:116
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_9
@ GPIO_MUX_9
Definition: at32f435_437_gpio.h:165
GPIO_MUX_10
@ GPIO_MUX_10
Definition: at32f435_437_gpio.h:166
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOG
#define GPIOG
Definition: at32f435_437_gpio.h:527
GPIOF
#define GPIOF
Definition: at32f435_437_gpio.h:526
qspi_sck_mode_set
void qspi_sck_mode_set(qspi_type *qspi_x, qspi_clk_mode_type new_mode)
set qspi sck mode.
Definition: at32f435_437_qspi.c:70
qspi_xip_enable
void qspi_xip_enable(qspi_type *qspi_x, confirm_state new_state)
enable xip mode or command-port mode.
Definition: at32f435_437_qspi.c:254
qspi_busy_config
void qspi_busy_config(qspi_type *qspi_x, qspi_busy_pos_type busy_pos)
set wip position in status register of flash
Definition: at32f435_437_qspi.c:241
qspi_clk_division_set
void qspi_clk_division_set(qspi_type *qspi_x, qspi_clk_div_type new_clkdiv)
set qspi clock division
Definition: at32f435_437_qspi.c:93
QSPI_BUSY_OFFSET_0
@ QSPI_BUSY_OFFSET_0
Definition: at32f435_437_qspi.h:87
QSPI_SCK_MODE_0
@ QSPI_SCK_MODE_0
Definition: at32f435_437_qspi.h:171
QSPI_CLK_DIV_4
@ QSPI_CLK_DIV_4
Definition: at32f435_437_qspi.h:126
QSPI1
#define QSPI1
Definition: at32f435_437_qspi.h:512
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_interrupt
  • inc
project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_interrupt
  • inc
project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_interrupt
  • inc
project/at_start_f435/examples/qspi/command_port_using_interrupt/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_interrupt
  • src
Functions
project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_interrupt
  • src
project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_interrupt
  • src
Functions
project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_interrupt
  • src
project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_interrupt/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_interrupt
  • src
Macros | Functions | Variables
project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include <string.h>

Go to the source code of this file.

Macros

#define TEST_SIZE 4096

Functions

void | qspi_data_read (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data More...
void | qspi_data_write (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data More...
void | qspi_erase (uint32_t sec_addr)
qspi erase data More...
void | qspi_config (void)
qspi config More...
int | main (void)
main function. More...

Variables

uint8_t | wbuf [4096]
uint8_t | rbuf [4096]

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_interrupt
  • src
project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include <string.h>
30
39extern void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t* buf);
40extern void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t* buf);
41extern void qspi_erase(uint32_t sec_addr);
42
43#define TEST_SIZE 4096
44uint8_t wbuf[TEST_SIZE];
45uint8_t rbuf[TEST_SIZE];
46
52void qspi_config(void)
53{
54 gpio_init_type gpio_init_struct;
55
56 /* enable the qspi clock */
57 crm_periph_clock_enable(CRM_QSPI1_PERIPH_CLOCK, TRUE);
58
59 /* enable the pin clock */
60 crm_periph_clock_enable(CRM_GPIOF_PERIPH_CLOCK, TRUE);
61 crm_periph_clock_enable(CRM_GPIOG_PERIPH_CLOCK, TRUE);
62
63 /* set default parameter */
64 gpio_default_para_init(&gpio_init_struct);
65
66 /* configure the io0 gpio */
67 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
68 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
69 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
70 gpio_init_struct.gpio_pins = GPIO_PINS_8;
71 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
72 gpio_init(GPIOF, &gpio_init_struct);
73 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE8, GPIO_MUX_10);
74
75 /* configure the io1 gpio */
76 gpio_init_struct.gpio_pins = GPIO_PINS_9;
77 gpio_init(GPIOF, &gpio_init_struct);
78 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE9, GPIO_MUX_10);
79
80 /* configure the io2 gpio */
81 gpio_init_struct.gpio_pins = GPIO_PINS_7;
82 gpio_init(GPIOF, &gpio_init_struct);
83 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE7, GPIO_MUX_9);
84
85 /* configure the io3 gpio */
86 gpio_init_struct.gpio_pins = GPIO_PINS_6;
87 gpio_init(GPIOF, &gpio_init_struct);
88 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE6, GPIO_MUX_9);
89
90 /* configure the sck gpio */
91 gpio_init_struct.gpio_pins = GPIO_PINS_10;
92 gpio_init(GPIOF, &gpio_init_struct);
93 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE10, GPIO_MUX_9);
94
95 /* configure the cs gpio */
96 gpio_init_struct.gpio_pins = GPIO_PINS_6;
97 gpio_init(GPIOG, &gpio_init_struct);
98 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE6, GPIO_MUX_10);
99}
100
106int main(void)
107{
108 uint16_t i, err = 0;
109
110 system_clock_config();
111 at32_board_init();
112
113 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
114
115 for(i = 0; i < TEST_SIZE; i++)
116 {
117 wbuf[i] = (uint8_t)i;
118 rbuf[i] = 0;
119 }
120 /* qspi config */
121 qspi_config();
122
123 /* switch to cmd port */
124 qspi_xip_enable(QSPI1, FALSE);
125
126 /* set sclk */
127 qspi_clk_division_set(QSPI1, QSPI_CLK_DIV_4);
128
129 /* set sck idle mode 0 */
130 qspi_sck_mode_set(QSPI1, QSPI_SCK_MODE_0);
131
132 /* set wip in bit 0 */
133 qspi_busy_config(QSPI1, QSPI_BUSY_OFFSET_0);
134
135 nvic_irq_enable(QSPI1_IRQn, 0, 0);
136 qspi_interrupt_enable(QSPI1, TRUE);
137
138 /* erase */
139 qspi_erase(0);
140
141 /* read */
142 qspi_data_read(0, TEST_SIZE, rbuf);
143
144 for(i = 0; i < TEST_SIZE; i++)
145 {
146 if(rbuf[i] != 0xFF)
147 {
148 err = 1;
149 break;
150 }
151 }
152
153 /* program */
154 qspi_data_write(0, TEST_SIZE, wbuf);
155
156 /* read */
157 qspi_data_read(0, TEST_SIZE, rbuf);
158
159 if(memcmp(rbuf, wbuf, TEST_SIZE))
160 {
161 err = 1;
162 }
163
164 while(1)
165 {
166 if(err == 0)
167 {
168 at32_led_toggle(LED3);
169 delay_ms(300);
170 }
171 else
172 {
173 at32_led_toggle(LED2);
174 delay_ms(300);
175 }
176 }
177}
178
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
qspi_erase
void qspi_erase(uint32_t sec_addr)
qspi erase data
Definition: at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:289
qspi_config
void qspi_config(void)
qspi config
Definition: project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c:52
main
int main(void)
main function.
Definition: project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c:106
TEST_SIZE
#define TEST_SIZE
Definition: project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c:43
qspi_data_read
void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data
Definition: at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:207
qspi_data_write
void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data
Definition: at_start_f435/examples/qspi/command_port_using_interrupt/src/qspi_cmd_esmt32m.c:247
wbuf
uint8_t wbuf[4096]
Definition: project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c:44
rbuf
uint8_t rbuf[4096]
Definition: project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c:45
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOF_PERIPH_CLOCK
@ CRM_GPIOF_PERIPH_CLOCK
Definition: at32f435_437_crm.h:110
CRM_GPIOG_PERIPH_CLOCK
@ CRM_GPIOG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:111
CRM_QSPI1_PERIPH_CLOCK
@ CRM_QSPI1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:124
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_9
@ GPIO_MUX_9
Definition: at32f435_437_gpio.h:165
GPIO_MUX_10
@ GPIO_MUX_10
Definition: at32f435_437_gpio.h:166
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOG
#define GPIOG
Definition: at32f435_437_gpio.h:527
GPIOF
#define GPIOF
Definition: at32f435_437_gpio.h:526
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
qspi_sck_mode_set
void qspi_sck_mode_set(qspi_type *qspi_x, qspi_clk_mode_type new_mode)
set qspi sck mode.
Definition: at32f435_437_qspi.c:70
qspi_interrupt_enable
void qspi_interrupt_enable(qspi_type *qspi_x, confirm_state new_state)
enable/disable interrupt when command is completed
Definition: at32f435_437_qspi.c:121
qspi_xip_enable
void qspi_xip_enable(qspi_type *qspi_x, confirm_state new_state)
enable xip mode or command-port mode.
Definition: at32f435_437_qspi.c:254
qspi_busy_config
void qspi_busy_config(qspi_type *qspi_x, qspi_busy_pos_type busy_pos)
set wip position in status register of flash
Definition: at32f435_437_qspi.c:241
qspi_clk_division_set
void qspi_clk_division_set(qspi_type *qspi_x, qspi_clk_div_type new_clkdiv)
set qspi clock division
Definition: at32f435_437_qspi.c:93
QSPI_BUSY_OFFSET_0
@ QSPI_BUSY_OFFSET_0
Definition: at32f435_437_qspi.h:87
QSPI_SCK_MODE_0
@ QSPI_SCK_MODE_0
Definition: at32f435_437_qspi.h:171
QSPI_CLK_DIV_4
@ QSPI_CLK_DIV_4
Definition: at32f435_437_qspi.h:126
QSPI1
#define QSPI1
Definition: at32f435_437_qspi.h:512
QSPI1_IRQn
@ QSPI1_IRQn
Definition: at32f435_437.h:227
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_polling
  • inc
project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_polling
  • inc
project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_polling
  • inc
project/at_start_f435/examples/qspi/command_port_using_polling/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_polling
  • src
Functions
project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_polling
  • src
project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_polling
  • src
Functions
project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_polling
  • src
project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_polling/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_polling
  • src
Macros | Functions | Variables
project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include <string.h>

Go to the source code of this file.

Macros

#define TEST_SIZE 4096

Functions

void | qspi_data_read (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data More...
void | qspi_data_write (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data More...
void | qspi_erase (uint32_t sec_addr)
qspi erase data More...
void | qspi_config (void)
qspi config More...
int | main (void)
main function. More...

Variables

uint8_t | wbuf [4096]
uint8_t | rbuf [4096]

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_polling
  • src
project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include <string.h>
30
39extern void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t* buf);
40extern void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t* buf);
41extern void qspi_erase(uint32_t sec_addr);
42
43#define TEST_SIZE 4096
44uint8_t wbuf[TEST_SIZE];
45uint8_t rbuf[TEST_SIZE];
46
52void qspi_config(void)
53{
54 gpio_init_type gpio_init_struct;
55
56 /* enable the qspi clock */
57 crm_periph_clock_enable(CRM_QSPI1_PERIPH_CLOCK, TRUE);
58
59 /* enable the pin clock */
60 crm_periph_clock_enable(CRM_GPIOF_PERIPH_CLOCK, TRUE);
61 crm_periph_clock_enable(CRM_GPIOG_PERIPH_CLOCK, TRUE);
62
63 /* set default parameter */
64 gpio_default_para_init(&gpio_init_struct);
65
66 /* configure the io0 gpio */
67 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
68 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
69 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
70 gpio_init_struct.gpio_pins = GPIO_PINS_8;
71 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
72 gpio_init(GPIOF, &gpio_init_struct);
73 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE8, GPIO_MUX_10);
74
75 /* configure the io1 gpio */
76 gpio_init_struct.gpio_pins = GPIO_PINS_9;
77 gpio_init(GPIOF, &gpio_init_struct);
78 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE9, GPIO_MUX_10);
79
80 /* configure the io2 gpio */
81 gpio_init_struct.gpio_pins = GPIO_PINS_7;
82 gpio_init(GPIOF, &gpio_init_struct);
83 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE7, GPIO_MUX_9);
84
85 /* configure the io3 gpio */
86 gpio_init_struct.gpio_pins = GPIO_PINS_6;
87 gpio_init(GPIOF, &gpio_init_struct);
88 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE6, GPIO_MUX_9);
89
90 /* configure the sck gpio */
91 gpio_init_struct.gpio_pins = GPIO_PINS_10;
92 gpio_init(GPIOF, &gpio_init_struct);
93 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE10, GPIO_MUX_9);
94
95 /* configure the cs gpio */
96 gpio_init_struct.gpio_pins = GPIO_PINS_6;
97 gpio_init(GPIOG, &gpio_init_struct);
98 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE6, GPIO_MUX_10);
99}
100
106int main(void)
107{
108 uint16_t i, err = 0;
109
110 system_clock_config();
111 at32_board_init();
112
113 for(i = 0; i < TEST_SIZE; i++)
114 {
115 wbuf[i] = (uint8_t)i;
116 rbuf[i] = 0;
117 }
118 /* qspi config */
119 qspi_config();
120
121 /* switch to cmd port */
122 qspi_xip_enable(QSPI1, FALSE);
123
124 /* set sclk */
125 qspi_clk_division_set(QSPI1, QSPI_CLK_DIV_4);
126
127 /* set sck idle mode 0 */
128 qspi_sck_mode_set(QSPI1, QSPI_SCK_MODE_0);
129
130 /* set wip in bit 0 */
131 qspi_busy_config(QSPI1, QSPI_BUSY_OFFSET_0);
132
133 /* erase */
134 qspi_erase(0);
135
136 /* read */
137 qspi_data_read(0, TEST_SIZE, rbuf);
138
139 for(i = 0; i < TEST_SIZE; i++)
140 {
141 if(rbuf[i] != 0xFF)
142 {
143 err = 1;
144 break;
145 }
146 }
147
148 /* program */
149 qspi_data_write(0, TEST_SIZE, wbuf);
150
151 /* read */
152 qspi_data_read(0, TEST_SIZE, rbuf);
153
154 if(memcmp(rbuf, wbuf, TEST_SIZE))
155 {
156 err = 1;
157 }
158
159 while(1)
160 {
161 if(err == 0)
162 {
163 at32_led_toggle(LED3);
164 delay_ms(300);
165 }
166 else
167 {
168 at32_led_toggle(LED2);
169 delay_ms(300);
170 }
171 }
172}
173
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
qspi_erase
void qspi_erase(uint32_t sec_addr)
qspi erase data
Definition: at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c:240
qspi_config
void qspi_config(void)
qspi config
Definition: project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c:52
rbuf
uint8_t rbuf[4096]
Definition: project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c:45
main
int main(void)
main function.
Definition: project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c:106
TEST_SIZE
#define TEST_SIZE
Definition: project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c:43
qspi_data_read
void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data
Definition: at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c:162
qspi_data_write
void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data
Definition: at_start_f435/examples/qspi/command_port_using_polling/src/qspi_cmd_esmt32m.c:200
wbuf
uint8_t wbuf[4096]
Definition: project/at_start_f435/examples/qspi/command_port_using_polling/src/main.c:44
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOF_PERIPH_CLOCK
@ CRM_GPIOF_PERIPH_CLOCK
Definition: at32f435_437_crm.h:110
CRM_GPIOG_PERIPH_CLOCK
@ CRM_GPIOG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:111
CRM_QSPI1_PERIPH_CLOCK
@ CRM_QSPI1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:124
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_9
@ GPIO_MUX_9
Definition: at32f435_437_gpio.h:165
GPIO_MUX_10
@ GPIO_MUX_10
Definition: at32f435_437_gpio.h:166
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOG
#define GPIOG
Definition: at32f435_437_gpio.h:527
GPIOF
#define GPIOF
Definition: at32f435_437_gpio.h:526
qspi_sck_mode_set
void qspi_sck_mode_set(qspi_type *qspi_x, qspi_clk_mode_type new_mode)
set qspi sck mode.
Definition: at32f435_437_qspi.c:70
qspi_xip_enable
void qspi_xip_enable(qspi_type *qspi_x, confirm_state new_state)
enable xip mode or command-port mode.
Definition: at32f435_437_qspi.c:254
qspi_busy_config
void qspi_busy_config(qspi_type *qspi_x, qspi_busy_pos_type busy_pos)
set wip position in status register of flash
Definition: at32f435_437_qspi.c:241
qspi_clk_division_set
void qspi_clk_division_set(qspi_type *qspi_x, qspi_clk_div_type new_clkdiv)
set qspi clock division
Definition: at32f435_437_qspi.c:93
QSPI_BUSY_OFFSET_0
@ QSPI_BUSY_OFFSET_0
Definition: at32f435_437_qspi.h:87
QSPI_SCK_MODE_0
@ QSPI_SCK_MODE_0
Definition: at32f435_437_qspi.h:171
QSPI_CLK_DIV_4
@ QSPI_CLK_DIV_4
Definition: at32f435_437_qspi.h:126
QSPI1
#define QSPI1
Definition: at32f435_437_qspi.h:512
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_rdsr_sw
  • inc
project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_rdsr_sw
  • inc
project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_rdsr_sw
  • inc
project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_rdsr_sw
  • src
Functions
project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_rdsr_sw
  • src
project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_rdsr_sw
  • src
Functions
project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_rdsr_sw
  • src
project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • qspi
  • command_port_using_rdsr_sw
  • src
Macros | Functions | Variables
project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include <string.h>

Go to the source code of this file.

Macros

#define TEST_SIZE 4096

Functions

void | qspi_data_read (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data More...
void | qspi_data_write (uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data More...
void | qspi_erase (uint32_t sec_addr)
qspi erase data More...
void | qspi_config (void)
qspi config More...
int | main (void)
main function. More...

Variables

uint8_t | wbuf [4096]
uint8_t | rbuf [4096]

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • qspi
  • command_port_using_rdsr_sw
  • src
project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include <string.h>
30
39extern void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t* buf);
40extern void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t* buf);
41extern void qspi_erase(uint32_t sec_addr);
42
43#define TEST_SIZE 4096
44uint8_t wbuf[TEST_SIZE];
45uint8_t rbuf[TEST_SIZE];
46
52void qspi_config(void)
53{
54 gpio_init_type gpio_init_struct;
55
56 /* enable the qspi clock */
57 crm_periph_clock_enable(CRM_QSPI1_PERIPH_CLOCK, TRUE);
58
59 /* enable the pin clock */
60 crm_periph_clock_enable(CRM_GPIOF_PERIPH_CLOCK, TRUE);
61 crm_periph_clock_enable(CRM_GPIOG_PERIPH_CLOCK, TRUE);
62
63 /* set default parameter */
64 gpio_default_para_init(&gpio_init_struct);
65
66 /* configure the io0 gpio */
67 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
68 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
69 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
70 gpio_init_struct.gpio_pins = GPIO_PINS_8;
71 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
72 gpio_init(GPIOF, &gpio_init_struct);
73 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE8, GPIO_MUX_10);
74
75 /* configure the io1 gpio */
76 gpio_init_struct.gpio_pins = GPIO_PINS_9;
77 gpio_init(GPIOF, &gpio_init_struct);
78 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE9, GPIO_MUX_10);
79
80 /* configure the io2 gpio */
81 gpio_init_struct.gpio_pins = GPIO_PINS_7;
82 gpio_init(GPIOF, &gpio_init_struct);
83 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE7, GPIO_MUX_9);
84
85 /* configure the io3 gpio */
86 gpio_init_struct.gpio_pins = GPIO_PINS_6;
87 gpio_init(GPIOF, &gpio_init_struct);
88 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE6, GPIO_MUX_9);
89
90 /* configure the sck gpio */
91 gpio_init_struct.gpio_pins = GPIO_PINS_10;
92 gpio_init(GPIOF, &gpio_init_struct);
93 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE10, GPIO_MUX_9);
94
95 /* configure the cs gpio */
96 gpio_init_struct.gpio_pins = GPIO_PINS_6;
97 gpio_init(GPIOG, &gpio_init_struct);
98 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE6, GPIO_MUX_10);
99}
100
106int main(void)
107{
108 uint16_t i, err = 0;
109
110 system_clock_config();
111 at32_board_init();
112
113 for(i = 0; i < TEST_SIZE; i++)
114 {
115 wbuf[i] = (uint8_t)i;
116 rbuf[i] = 0;
117 }
118 /* qspi config */
119 qspi_config();
120
121 /* switch to cmd port */
122 qspi_xip_enable(QSPI1, FALSE);
123
124 /* set sclk */
125 qspi_clk_division_set(QSPI1, QSPI_CLK_DIV_4);
126
127 /* set sck idle mode 0 */
128 qspi_sck_mode_set(QSPI1, QSPI_SCK_MODE_0);
129
130 /* set wip in bit 0 */
131 qspi_busy_config(QSPI1, QSPI_BUSY_OFFSET_0);
132
133 /* erase */
134 qspi_erase(0);
135
136 /* read */
137 qspi_data_read(0, TEST_SIZE, rbuf);
138
139 for(i = 0; i < TEST_SIZE; i++)
140 {
141 if(rbuf[i] != 0xFF)
142 {
143 err = 1;
144 break;
145 }
146 }
147
148 /* program */
149 qspi_data_write(0, TEST_SIZE, wbuf);
150
151 /* read */
152 qspi_data_read(0, TEST_SIZE, rbuf);
153
154 if(memcmp(rbuf, wbuf, TEST_SIZE))
155 {
156 err = 1;
157 }
158
159 while(1)
160 {
161 if(err == 0)
162 {
163 at32_led_toggle(LED3);
164 delay_ms(300);
165 }
166 else
167 {
168 at32_led_toggle(LED2);
169 delay_ms(300);
170 }
171 }
172}
173
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
qspi_erase
void qspi_erase(uint32_t sec_addr)
qspi erase data
Definition: at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c:240
qspi_config
void qspi_config(void)
qspi config
Definition: project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c:52
rbuf
uint8_t rbuf[4096]
Definition: project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c:45
main
int main(void)
main function.
Definition: project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c:106
TEST_SIZE
#define TEST_SIZE
Definition: project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c:43
qspi_data_read
void qspi_data_read(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi read data
Definition: at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c:162
qspi_data_write
void qspi_data_write(uint32_t addr, uint32_t total_len, uint8_t *buf)
qspi write data
Definition: at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/qspi_cmd_esmt32m.c:200
wbuf
uint8_t wbuf[4096]
Definition: project/at_start_f435/examples/qspi/command_port_using_rdsr_sw/src/main.c:44
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOF_PERIPH_CLOCK
@ CRM_GPIOF_PERIPH_CLOCK
Definition: at32f435_437_crm.h:110
CRM_GPIOG_PERIPH_CLOCK
@ CRM_GPIOG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:111
CRM_QSPI1_PERIPH_CLOCK
@ CRM_QSPI1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:124
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_9
@ GPIO_MUX_9
Definition: at32f435_437_gpio.h:165
GPIO_MUX_10
@ GPIO_MUX_10
Definition: at32f435_437_gpio.h:166
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOG
#define GPIOG
Definition: at32f435_437_gpio.h:527
GPIOF
#define GPIOF
Definition: at32f435_437_gpio.h:526
qspi_sck_mode_set
void qspi_sck_mode_set(qspi_type *qspi_x, qspi_clk_mode_type new_mode)
set qspi sck mode.
Definition: at32f435_437_qspi.c:70
qspi_xip_enable
void qspi_xip_enable(qspi_type *qspi_x, confirm_state new_state)
enable xip mode or command-port mode.
Definition: at32f435_437_qspi.c:254
qspi_busy_config
void qspi_busy_config(qspi_type *qspi_x, qspi_busy_pos_type busy_pos)
set wip position in status register of flash
Definition: at32f435_437_qspi.c:241
qspi_clk_division_set
void qspi_clk_division_set(qspi_type *qspi_x, qspi_clk_div_type new_clkdiv)
set qspi clock division
Definition: at32f435_437_qspi.c:93
QSPI_BUSY_OFFSET_0
@ QSPI_BUSY_OFFSET_0
Definition: at32f435_437_qspi.h:87
QSPI_SCK_MODE_0
@ QSPI_SCK_MODE_0
Definition: at32f435_437_qspi.h:171
QSPI_CLK_DIV_4
@ QSPI_CLK_DIV_4
Definition: at32f435_437_qspi.h:126
QSPI1
#define QSPI1
Definition: at32f435_437_qspi.h:512
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • qspi
  • xip_port_write_read
  • inc
project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • qspi
  • xip_port_write_read
  • inc
project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • qspi
  • xip_port_write_read
  • inc
project/at_start_f435/examples/qspi/xip_port_write_read/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • qspi
  • xip_port_write_read
  • src
Functions
project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • qspi
  • xip_port_write_read
  • src
project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • qspi
  • xip_port_write_read
  • src
Functions
project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • qspi
  • xip_port_write_read
  • src
project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/qspi/xip_port_write_read/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • qspi
  • xip_port_write_read
  • src
Macros | Functions | Variables
project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include <string.h>

Go to the source code of this file.

Macros

#define TEST_SIZE 4096

Functions

void | qspi_xip_init_ly68l6400 (void)
void | qspi_config (void)
qspi config More...
int | main (void)
main function. More...

Variables

uint8_t | wbuf [4096]
uint8_t | rbuf [4096]

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • qspi
  • xip_port_write_read
  • src
project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include <string.h>
30
39extern void qspi_xip_init_ly68l6400(void);
40
41#define TEST_SIZE 4096
42uint8_t wbuf[TEST_SIZE];
43uint8_t rbuf[TEST_SIZE];
44
50void qspi_config(void)
51{
52 gpio_init_type gpio_init_struct;
53
54 /* enable the qspi clock */
55 crm_periph_clock_enable(CRM_QSPI1_PERIPH_CLOCK, TRUE);
56
57 /* enable the pin clock */
58 crm_periph_clock_enable(CRM_GPIOF_PERIPH_CLOCK, TRUE);
59 crm_periph_clock_enable(CRM_GPIOG_PERIPH_CLOCK, TRUE);
60
61 /* set default parameter */
62 gpio_default_para_init(&gpio_init_struct);
63
64 /* configure the io0 gpio */
65 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
66 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
67 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
68 gpio_init_struct.gpio_pins = GPIO_PINS_8;
69 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
70 gpio_init(GPIOF, &gpio_init_struct);
71 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE8, GPIO_MUX_10);
72
73 /* configure the io1 gpio */
74 gpio_init_struct.gpio_pins = GPIO_PINS_9;
75 gpio_init(GPIOF, &gpio_init_struct);
76 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE9, GPIO_MUX_10);
77
78 /* configure the io2 gpio */
79 gpio_init_struct.gpio_pins = GPIO_PINS_7;
80 gpio_init(GPIOF, &gpio_init_struct);
81 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE7, GPIO_MUX_9);
82
83 /* configure the io3 gpio */
84 gpio_init_struct.gpio_pins = GPIO_PINS_6;
85 gpio_init(GPIOF, &gpio_init_struct);
86 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE6, GPIO_MUX_9);
87
88 /* configure the sck gpio */
89 gpio_init_struct.gpio_pins = GPIO_PINS_10;
90 gpio_init(GPIOF, &gpio_init_struct);
91 gpio_pin_mux_config(GPIOF, GPIO_PINS_SOURCE10, GPIO_MUX_9);
92
93 /* configure the cs gpio */
94 gpio_init_struct.gpio_pins = GPIO_PINS_6;
95 gpio_init(GPIOG, &gpio_init_struct);
96 gpio_pin_mux_config(GPIOG, GPIO_PINS_SOURCE6, GPIO_MUX_10);
97}
98
104int main(void)
105{
106 uint16_t i, err = 0;
107 uint8_t *qspi1_mem_addr;
108
109 system_clock_config();
110 at32_board_init();
111
112 for(i = 0; i < TEST_SIZE; i++)
113 {
114 wbuf[i] = (uint8_t)i;
115 rbuf[i] = 0;
116 }
117 /* qspi config */
118 qspi_config();
119
120 /* switch to cmd port */
121 qspi_xip_enable(QSPI1, FALSE);
122
123 /* set sclk */
124 qspi_clk_division_set(QSPI1, QSPI_CLK_DIV_4);
125
126 /* set sck idle mode 0 */
127 qspi_sck_mode_set(QSPI1, QSPI_SCK_MODE_0);
128
129 /* set wip in bit 0 */
130 qspi_busy_config(QSPI1, QSPI_BUSY_OFFSET_0);
131
132 qspi_xip_init_ly68l6400();
133
134 qspi1_mem_addr = (uint8_t*)QSPI1_MEM_BASE;
135
136 memcpy(qspi1_mem_addr, wbuf, TEST_SIZE);
137
138 memcpy(rbuf, qspi1_mem_addr, TEST_SIZE);
139
140 if(memcmp(rbuf, wbuf, TEST_SIZE))
141 {
142 err = 1;
143 }
144
145 while(1)
146 {
147 if(err == 0)
148 {
149 at32_led_toggle(LED3);
150 delay_ms(300);
151 }
152 else
153 {
154 at32_led_toggle(LED2);
155 delay_ms(300);
156 }
157 }
158}
159
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
qspi_config
void qspi_config(void)
qspi config
Definition: project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c:50
qspi_xip_init_ly68l6400
void qspi_xip_init_ly68l6400(void)
Definition: at_start_f435/examples/qspi/xip_port_write_read/src/qspi_xip_ly68l6400.c:114
rbuf
uint8_t rbuf[4096]
Definition: project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c:43
main
int main(void)
main function.
Definition: project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c:104
TEST_SIZE
#define TEST_SIZE
Definition: project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c:41
wbuf
uint8_t wbuf[4096]
Definition: project/at_start_f435/examples/qspi/xip_port_write_read/src/main.c:42
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOF_PERIPH_CLOCK
@ CRM_GPIOF_PERIPH_CLOCK
Definition: at32f435_437_crm.h:110
CRM_GPIOG_PERIPH_CLOCK
@ CRM_GPIOG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:111
CRM_QSPI1_PERIPH_CLOCK
@ CRM_QSPI1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:124
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_9
@ GPIO_MUX_9
Definition: at32f435_437_gpio.h:165
GPIO_MUX_10
@ GPIO_MUX_10
Definition: at32f435_437_gpio.h:166
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOG
#define GPIOG
Definition: at32f435_437_gpio.h:527
GPIOF
#define GPIOF
Definition: at32f435_437_gpio.h:526
QSPI1_MEM_BASE
#define QSPI1_MEM_BASE
Definition: at32f435_437.h:418
qspi_sck_mode_set
void qspi_sck_mode_set(qspi_type *qspi_x, qspi_clk_mode_type new_mode)
set qspi sck mode.
Definition: at32f435_437_qspi.c:70
qspi_xip_enable
void qspi_xip_enable(qspi_type *qspi_x, confirm_state new_state)
enable xip mode or command-port mode.
Definition: at32f435_437_qspi.c:254
qspi_busy_config
void qspi_busy_config(qspi_type *qspi_x, qspi_busy_pos_type busy_pos)
set wip position in status register of flash
Definition: at32f435_437_qspi.c:241
qspi_clk_division_set
void qspi_clk_division_set(qspi_type *qspi_x, qspi_clk_div_type new_clkdiv)
set qspi clock division
Definition: at32f435_437_qspi.c:93
QSPI_BUSY_OFFSET_0
@ QSPI_BUSY_OFFSET_0
Definition: at32f435_437_qspi.h:87
QSPI_SCK_MODE_0
@ QSPI_SCK_MODE_0
Definition: at32f435_437_qspi.h:171
QSPI_CLK_DIV_4
@ QSPI_CLK_DIV_4
Definition: at32f435_437_qspi.h:126
QSPI1
#define QSPI1
Definition: at32f435_437_qspi.h:512
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • scfg
  • mem_map_sel
  • inc
project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • scfg
  • mem_map_sel
  • inc
project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • scfg
  • mem_map_sel
  • inc
project/at_start_f435/examples/scfg/mem_map_sel/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • scfg
  • mem_map_sel
  • src
Functions
project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • scfg
  • mem_map_sel
  • src
project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • scfg
  • mem_map_sel
  • src
Functions
project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • scfg
  • mem_map_sel
  • src
project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/scfg/mem_map_sel/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • scfg
  • mem_map_sel
  • src
Functions
project/at_start_f435/examples/scfg/mem_map_sel/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/scfg/mem_map_sel/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • scfg
  • mem_map_sel
  • src
project/at_start_f435/examples/scfg/mem_map_sel/src/main.c
Go to the documentation of this file.
1
27/* includes */
28#include "at32f435_437_board.h"
29#include "at32f435_437_clock.h"
30
44int main(void)
45{
46 system_clock_config();
47
48 at32_board_init();
49
50 /* enable the scfg clock */
51 crm_periph_clock_enable(CRM_SCFG_PERIPH_CLOCK, TRUE);
52
53 scfg_mem_map_set(SCFG_MEM_MAP_BOOT_MEMORY);
54
55 if((*(__IO uint32_t *)0x00000000) == (*(__IO uint32_t *)0x1FFF0000))
56 {
57 at32_led_on(LED2);
58 at32_led_on(LED3);
59 at32_led_on(LED4);
60 }
61 while(1)
62 {
63 }
64}
65
at32f435_437_board.h
main
int main(void)
main function.
Definition: project/at_start_f435/examples/scfg/mem_map_sel/src/main.c:44
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_SCFG_PERIPH_CLOCK
@ CRM_SCFG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:163
TRUE
@ TRUE
Definition: at32f435_437.h:379
scfg_mem_map_set
void scfg_mem_map_set(scfg_mem_map_type mem_map)
scfg memory address mapping set
Definition: at32f435_437_scfg.c:100
SCFG_MEM_MAP_BOOT_MEMORY
@ SCFG_MEM_MAP_BOOT_MEMORY
Definition: at32f435_437_scfg.h:90
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • sdio
  • sd_mmc_card
  • inc
project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • sdio
  • sd_mmc_card
  • inc
project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • sdio
  • sd_mmc_card
  • inc
project/at_start_f435/examples/sdio/sd_mmc_card/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • sdio
  • sd_mmc_card
  • src
Functions
project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • sdio
  • sd_mmc_card
  • src
project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • sdio
  • sd_mmc_card
  • src
Functions
project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • sdio
  • sd_mmc_card
  • src
project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • sdio
  • sd_mmc_card
  • src
Macros | Enumerations | Functions | Variables
project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c File Reference

main program More...

#include <stdbool.h>
#include <string.h>
#include "at32_sdio.h"
#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define | BLOCK_SIZE (512)
#define | BLOCKS_NUMBER (64)
#define | MULTI_BUFFER_SIZE (BLOCK_SIZE * BLOCKS_NUMBER)
#define | STREAM_BUFFER_SIZE (4096)

Enumerations

enum test_result_type {
TEST_FAIL = 0 , TEST_SUCCESS , TEST_FAIL = 0 , TEST_SUCCESS ,
TEST_FAIL = 0 , TEST_SUCCESS , TEST_FAIL = 0 , TEST_SUCCESS
}

Functions

static test_result_type | sd_single_block_test (void)
sd card single block read/write test. More...
static test_result_type | sd_multiple_blocks_test (void)
sd card multiple blocks read/write test. More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
static void | sd_test_error (void)
LED2 on off every 300ms for sd test error. More...
static void | nvic_configuration (void)
configures sdio1 irq channel. More...
static test_result_type | mmc_stream_test (void)
mmc card data stream read/write test. More...
void | show_card_info (void)
show sd/mmc card info. More...
int | main (void)
main function. More...

Variables

static uint8_t | sblock_tbuffer [(512)]
static uint8_t | sblock_rbuffer [(512)]
static uint8_t | mblock_tbuffer [((512) *(64))]
static uint8_t | mblock_rbuffer [((512) *(64))]
static uint8_t | stream_tbuffer [(4096)]
static uint8_t | stream_rbuffer [(4096)]

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • sdio
  • sd_mmc_card
  • src
project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c
Go to the documentation of this file.
1
27#include <stdbool.h>
28#include <string.h>
29#include "at32_sdio.h"
30#include "at32f435_437_board.h"
31#include "at32f435_437_clock.h"
32
41#define BLOCK_SIZE (512)
42#define BLOCKS_NUMBER (64)
43#define MULTI_BUFFER_SIZE (BLOCK_SIZE * BLOCKS_NUMBER)
44#define STREAM_BUFFER_SIZE (4096)
45
46static uint8_t sblock_tbuffer[BLOCK_SIZE], sblock_rbuffer[BLOCK_SIZE];
47static uint8_t mblock_tbuffer[MULTI_BUFFER_SIZE], mblock_rbuffer[MULTI_BUFFER_SIZE];
48static uint8_t stream_tbuffer[STREAM_BUFFER_SIZE], stream_rbuffer[STREAM_BUFFER_SIZE];
49
53typedef enum
54{
55 TEST_FAIL = 0,
56 TEST_SUCCESS,
57} test_result_type;
58
59static test_result_type sd_single_block_test(void);
60static test_result_type sd_multiple_blocks_test(void);
61uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length);
62static void sd_test_error(void);
63static void nvic_configuration(void);
64
71static test_result_type sd_single_block_test(void)
72{
73 sd_error_status_type status = SD_OK;
74 uint8_t bus_width;
75
76 /* test 1-bit and 4-bit width */
77 for(bus_width = 0; bus_width < 2; bus_width++)
78 {
79 memset(sblock_tbuffer, bus_width + 0xAB, BLOCK_SIZE);
80 memset(sblock_rbuffer, 0, BLOCK_SIZE);
81
82 /* set data width */
83 status = sd_wide_bus_operation_config((sdio_bus_width_type)bus_width);
84 if(status != SD_OK)
85 {
86 return TEST_FAIL;
87 }
88
89 /* write block of 512 bytes on address 0 */
90 status = sd_block_write(sblock_tbuffer, 0x00, BLOCK_SIZE);
91 if(status != SD_OK)
92 {
93 return TEST_FAIL;
94 }
95
96 /* read block of 512 bytes from address 0 */
97 status = sd_block_read(sblock_rbuffer, 0x00, BLOCK_SIZE);
98 if(status != SD_OK)
99 {
100 return TEST_FAIL;
101 }
102
103 if(!buffer_compare(sblock_tbuffer, sblock_rbuffer, BLOCK_SIZE))
104 {
105 return TEST_FAIL;
106 }
107 }
108
109 return TEST_SUCCESS;
110}
111
118static test_result_type sd_multiple_blocks_test(void)
119{
120 sd_error_status_type status = SD_OK;
121 uint8_t bus_width;
122
123 /* test 1-bit and 4-bit width */
124 for(bus_width = 0; bus_width < 2; bus_width++)
125 {
126 memset(mblock_tbuffer, bus_width + 0x3C, MULTI_BUFFER_SIZE);
127 memset(mblock_rbuffer, 0, MULTI_BUFFER_SIZE);
128
129 /* set data width */
130 status = sd_wide_bus_operation_config((sdio_bus_width_type)bus_width);
131 if(status != SD_OK)
132 {
133 return TEST_FAIL;
134 }
135
136 /* write multiple block of many bytes on address 0 */
137 status = sd_mult_blocks_write(mblock_tbuffer, 0x00, BLOCK_SIZE, BLOCKS_NUMBER);
138 if(status != SD_OK)
139 {
140 return TEST_FAIL;
141 }
142
143 /* read block of many bytes from address 0 */
144 status = sd_mult_blocks_read(mblock_rbuffer, 0x00, BLOCK_SIZE, BLOCKS_NUMBER);
145 if(status != SD_OK)
146 {
147 return TEST_FAIL;
148 }
149
150 /* check the correctness of written data */
151 if(!buffer_compare(mblock_tbuffer, mblock_rbuffer, MULTI_BUFFER_SIZE))
152 {
153 return TEST_FAIL;
154 }
155 }
156
157 return TEST_SUCCESS;
158}
159
166static test_result_type mmc_stream_test(void)
167{
168 sd_error_status_type status = SD_OK;
169 uint8_t bus_width;
170
171 /* only test 1-bit width */
172 for(bus_width = 0; bus_width < 1; bus_width++)
173 {
174 memset(stream_tbuffer, bus_width+0x5A, STREAM_BUFFER_SIZE);
175 memset(stream_rbuffer, 0, STREAM_BUFFER_SIZE);
176
177 /* set data width */
178 status = sd_wide_bus_operation_config((sdio_bus_width_type)bus_width);
179 if(status != SD_OK)
180 {
181 return TEST_FAIL;
182 }
183
184 /* write stream of many bytes on address 0 */
185 status = mmc_stream_write(stream_tbuffer, 0x00, STREAM_BUFFER_SIZE);
186 if (status != SD_OK)
187 {
188 return TEST_FAIL;
189 }
190
191 /* read stream of many bytes from address 0 */
192 status = mmc_stream_read(stream_rbuffer, 0x00, STREAM_BUFFER_SIZE);
193 if (status != SD_OK)
194 {
195 return TEST_FAIL;
196 }
197
198 /* check the correctness of written data */
199 if(!buffer_compare(stream_tbuffer, stream_rbuffer, STREAM_BUFFER_SIZE))
200 {
201 return TEST_FAIL;
202 }
203 }
204
205 return TEST_SUCCESS;
206}
207
215uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
216{
217 while(buffer_length--)
218 {
219 if(*pbuffer1 != *pbuffer2)
220 {
221 return 0;
222 }
223 pbuffer1++;
224 pbuffer2++;
225 }
226 return 1;
227}
228
234static void sd_test_error(void)
235{
236 at32_led_on(LED2);
237 delay_ms(300);
238 at32_led_off(LED2);
239 delay_ms(300);
240}
241
247static void nvic_configuration(void)
248{
249 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
250 nvic_irq_enable(SDIO1_IRQn, 1, 0);
251}
252
258void show_card_info(void)
259{
260 printf("---------------------\r\n");
261 switch(sd_card_info.card_type)
262 {
263 case SDIO_STD_CAPACITY_SD_CARD_V1_1: printf("card type: SDSC V1.1\r\n");break;
264 case SDIO_STD_CAPACITY_SD_CARD_V2_0: printf("card type: SDSC V2.0\r\n");break;
265 case SDIO_HIGH_CAPACITY_SD_CARD: printf("card type: SDHC V2.0\r\n");break;
266 case SDIO_MULTIMEDIA_CARD: printf("card type: MMC Card\r\n");break;
267 }
268 printf("card manufacturer_id: %d\r\n", sd_card_info.sd_cid_reg.manufacturer_id);
269 printf("card rca: 0x%X\r\n", sd_card_info.rca);
270 printf("card c_size = %u\r\n", sd_card_info.sd_csd_reg.device_size);
271 printf("card capacity: %uMB %uKB\r\n", (uint32_t)(sd_card_info.card_capacity>>20), (uint32_t)(sd_card_info.card_capacity>>10));
272 printf("card block_size: %d\r\n", sd_card_info.card_blk_size);
273 printf("---------------------\r\n");
274}
275
276/* gloable functions ---------------------------------------------------------*/
282int main(void)
283{
284 system_clock_config();
285
286 at32_board_init();
287
288 nvic_configuration();
289
290 uart_print_init(115200);
291 printf("start test..\r\n");
292
293 /* sdio init */
294 if(SD_OK != sd_init())
295 {
296 printf("sdio init fail\r\n");
297 while(1)
298 {
299 sd_test_error();
300 }
301 }
302 printf("sdio init ok\r\n");
303 show_card_info();
304
305 /* sd card single block test */
306 if(TEST_SUCCESS != sd_single_block_test())
307 {
308 printf("sd card single block test fail\r\n");
309 /* single block test fail, led2 fresh */
310 while(1)
311 {
312 sd_test_error();
313 }
314 }
315 printf("sd card single block test ok\r\n");
316
317 /* sd card multiple blocks test */
318 if(TEST_SUCCESS != sd_multiple_blocks_test())
319 {
320 printf("sd card multiple blocks test fail\r\n");
321 /* multiple blocks test fail, led2 fresh */
322 while(1)
323 {
324 sd_test_error();
325 }
326 }
327 printf("sd card multiple blocks test ok\r\n");
328
329 /* mmc card stream data transfer test */
330 if(sd_card_info.card_type == SDIO_MULTIMEDIA_CARD)
331 {
332 if(TEST_SUCCESS != mmc_stream_test())
333 {
334 printf("mmc card stream data test fail\r\n");
335 /* mmc card stream data test fail, led2 fresh */
336 while(1)
337 {
338 sd_test_error();
339 }
340 }
341 printf("mmc card stream data test ok\r\n");
342 }
343
344 /* all tests pass, led3 and led4 fresh */
345 while(1)
346 {
347 at32_led_toggle(LED3);
348 at32_led_toggle(LED4);
349 delay_ms(300);
350 }
351}
352
at32f435_437_board.h
STREAM_BUFFER_SIZE
#define STREAM_BUFFER_SIZE
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c:44
mblock_rbuffer
static uint8_t mblock_rbuffer[((512) *(64))]
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c:47
stream_tbuffer
static uint8_t stream_tbuffer[(4096)]
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c:48
sd_multiple_blocks_test
static test_result_type sd_multiple_blocks_test(void)
sd card multiple blocks read/write test.
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c:118
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c:215
sd_test_error
static void sd_test_error(void)
LED2 on off every 300ms for sd test error.
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c:234
BLOCKS_NUMBER
#define BLOCKS_NUMBER
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c:42
mblock_tbuffer
static uint8_t mblock_tbuffer[((512) *(64))]
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c:47
sblock_rbuffer
static uint8_t sblock_rbuffer[(512)]
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c:46
stream_rbuffer
static uint8_t stream_rbuffer[(4096)]
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c:48
test_result_type
test_result_type
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c:54
show_card_info
void show_card_info(void)
show sd/mmc card info.
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c:258
sblock_tbuffer
static uint8_t sblock_tbuffer[(512)]
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c:46
MULTI_BUFFER_SIZE
#define MULTI_BUFFER_SIZE
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c:43
nvic_configuration
static void nvic_configuration(void)
configures sdio1 irq channel.
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c:247
main
int main(void)
main function.
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c:282
sd_single_block_test
static test_result_type sd_single_block_test(void)
sd card single block read/write test.
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c:71
BLOCK_SIZE
#define BLOCK_SIZE
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c:41
mmc_stream_test
static test_result_type mmc_stream_test(void)
mmc card data stream read/write test.
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c:166
TEST_FAIL
@ TEST_FAIL
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c:55
TEST_SUCCESS
@ TEST_SUCCESS
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c:56
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
status
uint32_t status
Definition: project/at_start_f435/examples/xmc/nand_flash/ecc/src/main.c:43
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
mmc_stream_write
sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1700
sd_block_read
sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma ...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1188
sd_mult_blocks_write
sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed ...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1489
sd_block_write
sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be manag...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1367
sd_init
sd_error_status_type sd_init(void)
initializes the sd card and put it into standby state (ready for data transfer).
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:72
mmc_stream_read
sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1653
sd_mult_blocks_read
sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mod...
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:1277
sd_wide_bus_operation_config
sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card.
Definition: at_start_f437/examples/sdio/sd_mmc_card/src/at32_sdio.c:743
sd_card_info
sd_card_info_struct_type sd_card_info
Definition: at_start_f435/examples/sdio/sd_mmc_card/src/at32_sdio.c:48
sd_error_status_type
sd_error_status_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:75
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f435_437_sdio.h:139
SD_OK
@ SD_OK
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:120
SDIO_HIGH_CAPACITY_SD_CARD
@ SDIO_HIGH_CAPACITY_SD_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:207
SDIO_STD_CAPACITY_SD_CARD_V1_1
@ SDIO_STD_CAPACITY_SD_CARD_V1_1
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:205
SDIO_STD_CAPACITY_SD_CARD_V2_0
@ SDIO_STD_CAPACITY_SD_CARD_V2_0
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:206
SDIO_MULTIMEDIA_CARD
@ SDIO_MULTIMEDIA_CARD
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:208
SDIO1_IRQn
@ SDIO1_IRQn
Definition: at32f435_437.h:197
sd_card_info_struct_type::card_capacity
long long card_capacity
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:242
sd_card_info_struct_type::sd_cid_reg
sd_cid_struct_type sd_cid_reg
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:240
sd_card_info_struct_type::sd_csd_reg
sd_csd_struct_type sd_csd_reg
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:239
sd_card_info_struct_type::card_blk_size
uint32_t card_blk_size
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:243
sd_card_info_struct_type::rca
uint16_t rca
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:244
sd_card_info_struct_type::card_type
uint8_t card_type
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:245
sd_cid_struct_type::manufacturer_id
uint8_t manufacturer_id
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:172
sd_csd_struct_type::device_size
uint32_t device_size
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:141
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • sdio
  • sdio_fatfs
  • inc
project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • sdio
  • sdio_fatfs
  • inc
project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • sdio
  • sdio_fatfs
  • inc
project/at_start_f435/examples/sdio/sdio_fatfs/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • sdio
  • sdio_fatfs
  • src
Functions
project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • sdio
  • sdio_fatfs
  • src
project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • sdio
  • sdio_fatfs
  • src
Functions
project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • sdio
  • sdio_fatfs
  • src
project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/sdio/sdio_fatfs/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • sdio
  • sdio_fatfs
  • src
Enumerations | Functions | Variables
project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c File Reference

main program More...

#include <stdbool.h>
#include <string.h>
#include "at32_sdio.h"
#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include "ff.h"

Go to the source code of this file.

Enumerations

enum test_result_type {
TEST_FAIL = 0 , TEST_SUCCESS , TEST_FAIL = 0 , TEST_SUCCESS ,
TEST_FAIL = 0 , TEST_SUCCESS , TEST_FAIL = 0 , TEST_SUCCESS
}

Functions

uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
static void | sd_test_error (void)
led2 on off every 300ms for sd test error. More...
static void | nvic_configuration (void)
configures sdio1 irq channel. More...
static test_result_type | fatfs_test (void)
fatfs file read/write test. More...
int | main (void)
main function. More...

Variables

FATFS | fs
FIL | file
BYTE | work [FF_MAX_SS]

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • sdio
  • sdio_fatfs
  • src
project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c
Go to the documentation of this file.
1
27#include <stdbool.h>
28#include <string.h>
29#include "at32_sdio.h"
30#include "at32f435_437_board.h"
31#include "at32f435_437_clock.h"
32#include "ff.h"
33
42FATFS fs;
43FIL file;
44BYTE work[FF_MAX_SS];
45
49typedef enum
50{
51 TEST_FAIL = 0,
52 TEST_SUCCESS,
53} test_result_type;
54
55uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length);
56static void sd_test_error(void);
57static void nvic_configuration(void);
58
66uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
67{
68 while(buffer_length--)
69 {
70 if(*pbuffer1 != *pbuffer2)
71 {
72 return 0;
73 }
74 pbuffer1++;
75 pbuffer2++;
76 }
77 return 1;
78}
79
85static void sd_test_error(void)
86{
87 at32_led_on(LED2);
88 delay_ms(300);
89 at32_led_off(LED2);
90 delay_ms(300);
91}
92
98static void nvic_configuration(void)
99{
100 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
101 nvic_irq_enable(SDIO1_IRQn, 1, 0);
102}
103
110static test_result_type fatfs_test(void)
111{
112 FRESULT ret;
113 char filename[] = "1:/test1.txt";
114 const char wbuf[] = "this is my file for test fatfs!\r\n";
115 char rbuf[50];
116 UINT bytes_written = 0;
117 UINT bytes_read = 0;
118 DWORD fre_clust, fre_sect, tot_sect;
119 FATFS* pt_fs;
120
121 ret = f_mount(&fs, "1:", 1);
122 if(ret){
123 printf("fs mount err:%d.\r\n", ret);
124 if(ret == FR_NO_FILESYSTEM){
125 printf("create fatfs..\r\n");
126 ret = f_mkfs("1:", 0, work, sizeof(work));
127 if(ret){
128 printf("creates fatfs err:%d.\r\n", ret);
129 return TEST_FAIL;
130 }
131 else{
132 printf("creates fatfs ok.\r\n");
133 }
134 ret = f_mount(NULL, "1:", 1);
135 ret = f_mount(&fs, "1:", 1);
136 if(ret){
137 printf("fs mount err:%d.\r\n", ret);
138 return TEST_FAIL;
139 }
140 else{
141 printf("fs mount ok.\r\n");
142 }
143 }
144 else{
145 return TEST_FAIL;
146 }
147 }
148 else{
149 printf("fs mount ok.\r\n");
150 }
151
152 ret = f_open(&file, filename, FA_READ | FA_WRITE | FA_CREATE_ALWAYS);
153 if(ret){
154 printf("open file err:%d.\r\n", ret);
155 }
156 else{
157 printf("open file ok.\r\n");
158 }
159 ret = f_write(&file, wbuf, sizeof(wbuf), &bytes_written);
160 if(ret){
161 printf("write file err:%d.\r\n", ret);
162 }
163 else{
164 printf("write file ok, byte:%u.\r\n", bytes_written);
165 }
166 f_lseek(&file, 0);
167 ret = f_read(&file, rbuf, sizeof(rbuf), &bytes_read);
168 if(ret){
169 printf("read file err:%d.\r\n", ret);
170 }
171 else{
172 printf("read file ok, byte:%u.\r\n", bytes_read);
173 }
174 ret = f_close(&file);
175 if(ret){
176 printf("close file err:%d.\r\n", ret);
177 }
178 else{
179 printf("close file ok.\r\n");
180 }
181
182 pt_fs = &fs;
183 /* get volume information and free clusters of drive 1 */
184 ret = f_getfree("1:", &fre_clust, &pt_fs);
185 if(ret == FR_OK)
186 {
187 /* get total sectors and free sectors */
188 tot_sect = (pt_fs->n_fatent - 2) * pt_fs->csize;
189 fre_sect = fre_clust * pt_fs->csize;
190
191 /* print the free space (assuming 512 bytes/sector) */
192 printf("%10u KiB total drive space.\r\n%10u KiB available.\r\n", tot_sect / 2, fre_sect / 2);
193 }
194
195 ret = f_mount(NULL, "1:", 1);
196
197 if(1 == buffer_compare((uint8_t*)rbuf, (uint8_t*)wbuf, sizeof(wbuf))){
198 printf("r/w file data test ok.\r\n");
199 }
200 else{
201 printf("r/w file data test fail.\r\n");
202 return TEST_FAIL;
203 }
204
205 return TEST_SUCCESS;
206}
207
208/* gloable functions ---------------------------------------------------------*/
214int main(void)
215{
216 system_clock_config();
217
218 at32_board_init();
219
220 nvic_configuration();
221
222 uart_print_init(115200);
223 printf("start test fatfs r0.14b..\r\n");
224
225 if(TEST_SUCCESS != fatfs_test())
226 {
227 while(1)
228 {
229 sd_test_error();
230 }
231 }
232
233 /* all tests pass, led3 and led4 fresh */
234 while(1)
235 {
236 at32_led_toggle(LED3);
237 at32_led_toggle(LED4);
238 delay_ms(300);
239 }
240}
241
at32f435_437_board.h
FF_MAX_SS
#define FF_MAX_SS
Definition: at_start_f435/examples/sdio/sdio_fatfs/inc/ffconf.h:197
wbuf
uint8_t wbuf[4096]
Definition: project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c:44
rbuf
uint8_t rbuf[4096]
Definition: project/at_start_f435/examples/qspi/command_port_using_interrupt/src/main.c:45
test_result_type
test_result_type
Definition: project/at_start_f435/examples/sdio/sd_mmc_card/src/main.c:54
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c:66
file
FIL file
Definition: project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c:43
sd_test_error
static void sd_test_error(void)
led2 on off every 300ms for sd test error.
Definition: project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c:85
test_result_type
test_result_type
Definition: project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c:50
work
BYTE work[FF_MAX_SS]
Definition: project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c:44
nvic_configuration
static void nvic_configuration(void)
configures sdio1 irq channel.
Definition: project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c:98
main
int main(void)
main function.
Definition: project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c:214
fs
FATFS fs
Definition: project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c:42
fatfs_test
static test_result_type fatfs_test(void)
fatfs file read/write test.
Definition: project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c:110
TEST_FAIL
@ TEST_FAIL
Definition: project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c:51
TEST_SUCCESS
@ TEST_SUCCESS
Definition: project/at_start_f435/examples/sdio/sdio_fatfs/src/main.c:52
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
NULL
#define NULL
Definition: at_start_f435/examples/sdio/sd_mmc_card/inc/at32_sdio.h:342
SDIO1_IRQn
@ SDIO1_IRQn
Definition: at32f435_437.h:197
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • spi
  • crc_transfer_polling
  • inc
project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • spi
  • crc_transfer_polling
  • inc
project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • spi
  • crc_transfer_polling
  • inc
project/at_start_f435/examples/spi/crc_transfer_polling/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • spi
  • crc_transfer_polling
  • src
Functions
project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • spi
  • crc_transfer_polling
  • src
project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • spi
  • crc_transfer_polling
  • src
Functions
project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • spi
  • crc_transfer_polling
  • src
project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • spi
  • crc_transfer_polling
  • src
Macros | Functions | Variables
project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 32

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

uint16_t | spi3_buffer_tx [32]
uint16_t | spi2_buffer_tx [32]
uint16_t | spi3_buffer_rx [32]
uint16_t | spi2_buffer_rx [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
__IO uint16_t | crc1_value = 0
__IO uint16_t | crc2_value = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • spi
  • crc_transfer_polling
  • src
project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define BUFFER_SIZE 32
39
40uint16_t spi3_buffer_tx[BUFFER_SIZE] = {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C, 0x0D0E, 0x0F10,
41 0x1112, 0x1314, 0x1516, 0x1718, 0x191A, 0x1B1C, 0x1D1E, 0x1F20,
42 0x2122, 0x2324, 0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
43 0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C, 0x3D3E, 0x3F40};
44uint16_t spi2_buffer_tx[BUFFER_SIZE] = {0x5152, 0x5354, 0x5556, 0x5758, 0x595A, 0x5B5C, 0x5D5E, 0x5F60,
45 0x6162, 0x6364, 0x6566, 0x6768, 0x696A, 0x6B6C, 0x6D6E, 0x6F70,
46 0x7172, 0x7374, 0x7576, 0x7778, 0x797A, 0x7B7C, 0x7D7E, 0x7F80,
47 0x8182, 0x8384, 0x8586, 0x8788, 0x898A, 0x8B8C, 0x8D8E, 0x8F90};
48uint16_t spi3_buffer_rx[BUFFER_SIZE], spi2_buffer_rx[BUFFER_SIZE];
49uint32_t tx_index = 0, rx_index = 0;
50__IO uint16_t crc1_value = 0, crc2_value = 0;
51volatile error_status transfer_status1 = ERROR, transfer_status2 = ERROR;
52
53static void gpio_config(void);
54static void spi_config(void);
55 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length);
56
63 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length)
64{
65 while(buffer_length--)
66 {
67 if(*pbuffer1 != *pbuffer2)
68 {
69 return ERROR;
70 }
71 pbuffer1++;
72 pbuffer2++;
73 }
74 return SUCCESS;
75}
76
82static void spi_config(void)
83{
84 spi_init_type spi_init_struct;
85 crm_periph_clock_enable(CRM_SPI3_PERIPH_CLOCK, TRUE);
86 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
87 spi_default_para_init(&spi_init_struct);
88 spi_init_struct.transmission_mode = SPI_TRANSMIT_FULL_DUPLEX;
89 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
90 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_8;
91 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_MSB;
92 spi_init_struct.frame_bit_num = SPI_FRAME_16BIT;
93 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_LOW;
94 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
95 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
96 spi_init(SPI3, &spi_init_struct);
97
98 spi_init_struct.master_slave_mode = SPI_MODE_SLAVE;
99 spi_init(SPI2, &spi_init_struct);
100
101 spi_crc_polynomial_set(SPI3, 7);
102 spi_crc_polynomial_set(SPI2, 7);
103 spi_crc_enable(SPI3, TRUE);
104 spi_crc_enable(SPI2, TRUE);
105 spi_enable(SPI3, TRUE);
106 spi_enable(SPI2, TRUE);
107}
108
114static void gpio_config(void)
115{
116 gpio_init_type gpio_initstructure;
117 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
118 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
119
120 /* master sck pin */
121 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
122 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
123 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
124 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
125 gpio_initstructure.gpio_pins = GPIO_PINS_10;
126 gpio_init(GPIOC, &gpio_initstructure);
127 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE10, GPIO_MUX_6);
128
129 /* master miso pin */
130 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
131 gpio_initstructure.gpio_pins = GPIO_PINS_11;
132 gpio_init(GPIOC, &gpio_initstructure);
133 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE11, GPIO_MUX_6);
134
135 /* master mosi pin */
136 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
137 gpio_initstructure.gpio_pins = GPIO_PINS_12;
138 gpio_init(GPIOC, &gpio_initstructure);
139 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE12, GPIO_MUX_6);
140
141 /* slave sck pin */
142 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
143 gpio_initstructure.gpio_pins = GPIO_PINS_1;
144 gpio_init(GPIOD, &gpio_initstructure);
145 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_6);
146
147 /* slave miso pin */
148 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
149 gpio_initstructure.gpio_pins = GPIO_PINS_2;
150 gpio_init(GPIOC, &gpio_initstructure);
151 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE2, GPIO_MUX_5);
152
153 /* slave mosi pin */
154 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
155 gpio_initstructure.gpio_pins = GPIO_PINS_4;
156 gpio_init(GPIOD, &gpio_initstructure);
157 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_6);
158}
159
165int main(void)
166{
167 system_clock_config();
168 at32_board_init();
169 gpio_config();
170 spi_config();
171
172 /* transfer procedure:the "BUFFER_SIZE-1" data transfer */
173 while(tx_index < BUFFER_SIZE - 1)
174 {
175 while(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) == RESET);
176 spi_i2s_data_transmit(SPI2, spi2_buffer_tx[tx_index]);
177 while(spi_i2s_flag_get(SPI3, SPI_I2S_TDBE_FLAG) == RESET);
178 spi_i2s_data_transmit(SPI3, spi3_buffer_tx[tx_index++]);
179 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
180 spi2_buffer_rx[rx_index] = spi_i2s_data_receive(SPI2);
181 while(spi_i2s_flag_get(SPI3, SPI_I2S_RDBF_FLAG) == RESET);
182 spi3_buffer_rx[rx_index++] = spi_i2s_data_receive(SPI3);
183 }
184 while(spi_i2s_flag_get(SPI3, SPI_I2S_TDBE_FLAG) == RESET);
185 while(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) == RESET);
186
187 /* transfer procedure:the last data and crc transfer */
188 spi_i2s_data_transmit(SPI2, spi2_buffer_tx[tx_index]);
189 spi_crc_next_transmit(SPI2);
190 spi_i2s_data_transmit(SPI3, spi3_buffer_tx[tx_index]);
191 spi_crc_next_transmit(SPI3);
192 while(spi_i2s_flag_get(SPI3, SPI_I2S_RDBF_FLAG) == RESET);
193 spi3_buffer_rx[rx_index] = spi_i2s_data_receive(SPI3);
194 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
195 spi2_buffer_rx[rx_index] = spi_i2s_data_receive(SPI2);
196 while(spi_i2s_flag_get(SPI3, SPI_I2S_RDBF_FLAG) == RESET);
197 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
198
199 /* test result:the data and crc check */
200 transfer_status1 = buffer_compare(spi2_buffer_rx, spi3_buffer_tx, BUFFER_SIZE);
201 transfer_status2 = buffer_compare(spi3_buffer_rx, spi2_buffer_tx, BUFFER_SIZE);
202 if((spi_i2s_flag_get(SPI3, SPI_CCERR_FLAG)) != RESET)
203 {
204 spi_i2s_flag_clear(SPI3, SPI_CCERR_FLAG);
205 transfer_status2 = ERROR;
206 }
207 if((spi_i2s_flag_get(SPI2, SPI_CCERR_FLAG)) != RESET)
208 {
209 spi_i2s_flag_clear(SPI2, SPI_CCERR_FLAG);
210 transfer_status1 = ERROR;
211 }
212 crc1_value = spi_i2s_data_receive(SPI3);
213 crc2_value = spi_i2s_data_receive(SPI2);
214
215 /* test result indicate:if success ,led2 lights */
216 if((transfer_status1 == SUCCESS) && (transfer_status2 == SUCCESS))
217 {
218 at32_led_on(LED2);
219 }
220 else
221 {
222 at32_led_off(LED2);
223 }
224 while(1)
225 {
226 }
227}
228
at32f435_437_board.h
buffer_compare
error_status buffer_compare(uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer compare function.
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c:63
spi2_buffer_tx
uint16_t spi2_buffer_tx[32]
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c:44
spi3_buffer_tx
uint16_t spi3_buffer_tx[32]
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c:40
spi_config
static void spi_config(void)
spi configuration.
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c:82
transfer_status1
volatile error_status transfer_status1
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c:51
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c:38
crc2_value
__IO uint16_t crc2_value
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c:50
transfer_status2
volatile error_status transfer_status2
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c:51
spi3_buffer_rx
uint16_t spi3_buffer_rx[32]
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c:48
main
int main(void)
main function.
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c:165
rx_index
uint32_t rx_index
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c:49
spi2_buffer_rx
uint16_t spi2_buffer_rx[32]
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c:48
tx_index
uint32_t tx_index
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c:49
crc1_value
__IO uint16_t crc1_value
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c:50
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c:114
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:40
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED2
@ LED2
Definition: at32f435_437_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_SPI3_PERIPH_CLOCK
@ CRM_SPI3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:139
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:138
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_6
@ GPIO_MUX_6
Definition: at32f435_437_gpio.h:162
GPIO_MUX_5
@ GPIO_MUX_5
Definition: at32f435_437_gpio.h:161
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
SPI_CCERR_FLAG
#define SPI_CCERR_FLAG
Definition: at32f435_437_spi.h:57
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f435_437_spi.h:54
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f435_437_spi.h:53
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f435_437_spi.c:548
spi_crc_enable
void spi_crc_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the hardware crc calculation for the spi peripheral.
Definition: at32f435_437_spi.c:225
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f435_437_spi.c:583
spi_crc_next_transmit
void spi_crc_next_transmit(spi_type *spi_x)
spi next transmit crc for the spi peripheral.
Definition: at32f435_437_spi.c:186
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f435_437_spi.c:101
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f435_437_spi.c:81
spi_crc_polynomial_set
void spi_crc_polynomial_set(spi_type *spi_x, uint16_t crc_poly)
set the crc polynomial value for the spi peripheral.
Definition: at32f435_437_spi.c:199
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f435_437_spi.c:560
spi_i2s_flag_clear
void spi_i2s_flag_clear(spi_type *spi_x, uint32_t spi_i2s_flag)
clear flag of the specified spi/i2s peripheral.
Definition: at32f435_437_spi.c:616
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f435_437_spi.c:321
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f435_437_spi.h:99
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f435_437_spi.h:100
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f435_437_spi.h:118
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f435_437_spi.h:127
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f435_437_spi.h:153
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f435_437_spi.h:108
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f435_437_spi.h:162
SPI_MCLK_DIV_8
@ SPI_MCLK_DIV_8
Definition: at32f435_437_spi.h:138
SPI_FRAME_16BIT
@ SPI_FRAME_16BIT
Definition: at32f435_437_spi.h:91
SPI3
#define SPI3
Definition: at32f435_437_spi.h:455
SPI2
#define SPI2
Definition: at32f435_437_spi.h:454
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
spi_init_type
spi init type
Definition: at32f435_437_spi.h:259
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f435_437_spi.h:261
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f435_437_spi.h:263
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f435_437_spi.h:264
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:265
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f435_437_spi.h:267
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f435_437_spi.h:262
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f435_437_spi.h:260
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f435_437_spi.h:266
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • spi
  • fullduplex_polling
  • inc
project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • spi
  • fullduplex_polling
  • inc
project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • spi
  • fullduplex_polling
  • inc
project/at_start_f435/examples/spi/fullduplex_polling/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • spi
  • fullduplex_polling
  • src
Functions
project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • spi
  • fullduplex_polling
  • src
project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • spi
  • fullduplex_polling
  • src
Functions
project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • spi
  • fullduplex_polling
  • src
project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • spi
  • fullduplex_polling
  • src
Macros | Functions | Variables
project/at_start_f435/examples/spi/fullduplex_polling/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 32

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t bufferlength)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi3_buffer_tx [32]
uint8_t | spi2_buffer_tx [32]
uint8_t | spi3_buffer_rx [32]
uint8_t | spi2_buffer_rx [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR
volatile error_status | transfer_status3 = ERROR
volatile error_status | transfer_status4 = ERROR

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/fullduplex_polling/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • spi
  • fullduplex_polling
  • src
project/at_start_f435/examples/spi/fullduplex_polling/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define BUFFER_SIZE 32
39
40 spi_init_type spi_init_struct;
41uint8_t spi3_buffer_tx[BUFFER_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
42 0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
43 0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
44 0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20};
45uint8_t spi2_buffer_tx[BUFFER_SIZE] = {0x51, 0x52, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58,
46 0x59, 0x5A, 0x5B, 0x5C, 0x5D, 0x5E, 0x5F, 0x60,
47 0x61, 0x62, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68,
48 0x69, 0x6A, 0x6B, 0x6C, 0x6D, 0x6E, 0x6F, 0x70};
49uint8_t spi3_buffer_rx[BUFFER_SIZE], spi2_buffer_rx[BUFFER_SIZE];
50uint32_t tx_index = 0, rx_index = 0;
51volatile error_status transfer_status1 = ERROR, transfer_status2 = ERROR;
52volatile error_status transfer_status3 = ERROR, transfer_status4 = ERROR;
53
54static void gpio_config(void);
55static void spi_config(void);
56 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t bufferlength);
57
64 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t bufferlength)
65{
66 while(bufferlength--)
67 {
68 if(*pbuffer1 != *pbuffer2)
69 {
70 return ERROR;
71 }
72
73 pbuffer1++;
74 pbuffer2++;
75 }
76 return SUCCESS;
77}
78
84static void spi_config(void)
85{
86 crm_periph_clock_enable(CRM_SPI3_PERIPH_CLOCK, TRUE);
87 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
88 spi_default_para_init(&spi_init_struct);
89 spi_init_struct.transmission_mode = SPI_TRANSMIT_FULL_DUPLEX;
90 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
91 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_8;
92 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_LSB;
93 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
94 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_LOW;
95 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
96 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
97 spi_init(SPI3, &spi_init_struct);
98
99 spi_init_struct.master_slave_mode = SPI_MODE_SLAVE;
100 spi_init(SPI2, &spi_init_struct);
101
102 spi_enable(SPI3, TRUE);
103 spi_enable(SPI2, TRUE);
104}
105
111static void gpio_config(void)
112{
113 gpio_init_type gpio_initstructure;
114 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
115 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
116 gpio_default_para_init(&gpio_initstructure);
117 /* spi3 sck pin */
118 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
119 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
120 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
121 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
122 gpio_initstructure.gpio_pins = GPIO_PINS_10;
123 gpio_init(GPIOC, &gpio_initstructure);
124 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE10, GPIO_MUX_6);
125
126 /* spi3 miso pin */
127 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
128 gpio_initstructure.gpio_pins = GPIO_PINS_11;
129 gpio_init(GPIOC, &gpio_initstructure);
130 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE11, GPIO_MUX_6);
131
132 /* spi3 mosi pin */
133 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
134 gpio_initstructure.gpio_pins = GPIO_PINS_12;
135 gpio_init(GPIOC, &gpio_initstructure);
136 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE12, GPIO_MUX_6);
137
138 /* spi2 sck pin */
139 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
140 gpio_initstructure.gpio_pins = GPIO_PINS_1;
141 gpio_init(GPIOD, &gpio_initstructure);
142 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_6);
143
144 /* spi2 miso pin */
145 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
146 gpio_initstructure.gpio_pins = GPIO_PINS_2;
147 gpio_init(GPIOC, &gpio_initstructure);
148 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE2, GPIO_MUX_5);
149
150 /* spi2 mosi pin */
151 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
152 gpio_initstructure.gpio_pins = GPIO_PINS_4;
153 gpio_init(GPIOD, &gpio_initstructure);
154 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_6);
155}
156
162int main(void)
163{
164 __IO uint32_t index = 0;
165 system_clock_config();
166 at32_board_init();
167 gpio_config();
168 spi_config();
169
170 /* transfer procedure:the "BUFFER_SIZE" data transfer */
171 while(tx_index < BUFFER_SIZE)
172 {
173 while(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) == RESET);
174 spi_i2s_data_transmit(SPI2, spi2_buffer_tx[tx_index]);
175 while(spi_i2s_flag_get(SPI3, SPI_I2S_TDBE_FLAG) == RESET);
176 spi_i2s_data_transmit(SPI3, spi3_buffer_tx[tx_index++]);
177 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
178 spi2_buffer_rx[rx_index] = spi_i2s_data_receive(SPI2);
179 while(spi_i2s_flag_get(SPI3, SPI_I2S_RDBF_FLAG) == RESET);
180 spi3_buffer_rx[rx_index++] = spi_i2s_data_receive(SPI3);
181 }
182
183 /* test result:the data check */
184 transfer_status1 = buffer_compare(spi2_buffer_rx, spi3_buffer_tx, BUFFER_SIZE);
185 transfer_status2 = buffer_compare(spi3_buffer_rx, spi2_buffer_tx, BUFFER_SIZE);
186
187 /* master &slave mode switch */
188 spi_enable(SPI3, FALSE);
189 spi_enable(SPI2, FALSE);
190 spi_init_struct.master_slave_mode =SPI_MODE_SLAVE;
191 spi_init(SPI3, &spi_init_struct);
192
193 spi_init_struct.master_slave_mode =SPI_MODE_MASTER;
194 spi_init(SPI2, &spi_init_struct);
195
196 tx_index = 0;
197 rx_index = 0;
198 for(index = 0; index < BUFFER_SIZE; index++)
199 spi3_buffer_rx[index] = 0;
200 for(index = 0; index < BUFFER_SIZE; index++)
201 spi2_buffer_rx[index] = 0;
202
203 spi_enable(SPI2, TRUE);
204 spi_enable(SPI3, TRUE);
205
206 /* transfer procedure:the "BUFFER_SIZE" data transfer */
207 while(tx_index < BUFFER_SIZE)
208 {
209 while(spi_i2s_flag_get(SPI3, SPI_I2S_TDBE_FLAG) == RESET);
210 spi_i2s_data_transmit(SPI3, spi3_buffer_tx[tx_index]);
211 while(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) == RESET);
212 spi_i2s_data_transmit(SPI2, spi2_buffer_tx[tx_index++]);
213 while(spi_i2s_flag_get(SPI3, SPI_I2S_RDBF_FLAG) == RESET);
214 spi3_buffer_rx[rx_index] = spi_i2s_data_receive(SPI3);
215 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
216 spi2_buffer_rx[rx_index++] = spi_i2s_data_receive(SPI2);
217 }
218
219 /* test result:the data check */
220 transfer_status3 = buffer_compare(spi2_buffer_rx, spi3_buffer_tx, BUFFER_SIZE);
221 transfer_status4 = buffer_compare(spi3_buffer_rx, spi2_buffer_tx, BUFFER_SIZE);
222
223 /* test result indicate:if success ,led2 lights */
224 if((transfer_status1 == SUCCESS) && (transfer_status2 == SUCCESS) && \
225 (transfer_status3 == SUCCESS) && (transfer_status4 == SUCCESS))
226 {
227 at32_led_on(LED2);
228 }
229 else
230 {
231 at32_led_off(LED2);
232 }
233 while(1)
234 {
235 }
236}
237
at32f435_437_board.h
spi2_buffer_tx
uint8_t spi2_buffer_tx[32]
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:45
spi3_buffer_rx
uint8_t spi3_buffer_rx[32]
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:49
buffer_compare
error_status buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t bufferlength)
buffer compare function.
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:64
spi2_buffer_rx
uint8_t spi2_buffer_rx[32]
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:49
transfer_status3
volatile error_status transfer_status3
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:52
spi_config
static void spi_config(void)
spi configuration.
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:84
transfer_status1
volatile error_status transfer_status1
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:51
transfer_status4
volatile error_status transfer_status4
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:52
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:38
transfer_status2
volatile error_status transfer_status2
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:51
main
int main(void)
main function.
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:162
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:40
rx_index
uint32_t rx_index
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:50
tx_index
uint32_t tx_index
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:50
spi3_buffer_tx
uint8_t spi3_buffer_tx[32]
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:41
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:111
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED2
@ LED2
Definition: at32f435_437_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_SPI3_PERIPH_CLOCK
@ CRM_SPI3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:139
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:138
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_6
@ GPIO_MUX_6
Definition: at32f435_437_gpio.h:162
GPIO_MUX_5
@ GPIO_MUX_5
Definition: at32f435_437_gpio.h:161
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f435_437_spi.h:54
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f435_437_spi.h:53
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f435_437_spi.c:548
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f435_437_spi.c:583
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f435_437_spi.c:101
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f435_437_spi.c:81
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f435_437_spi.c:560
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f435_437_spi.c:321
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f435_437_spi.h:99
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f435_437_spi.h:100
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f435_437_spi.h:118
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f435_437_spi.h:127
SPI_FIRST_BIT_LSB
@ SPI_FIRST_BIT_LSB
Definition: at32f435_437_spi.h:154
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f435_437_spi.h:108
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f435_437_spi.h:162
SPI_MCLK_DIV_8
@ SPI_MCLK_DIV_8
Definition: at32f435_437_spi.h:138
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f435_437_spi.h:90
SPI3
#define SPI3
Definition: at32f435_437_spi.h:455
SPI2
#define SPI2
Definition: at32f435_437_spi.h:454
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
spi_init_type
spi init type
Definition: at32f435_437_spi.h:259
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f435_437_spi.h:261
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f435_437_spi.h:263
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f435_437_spi.h:264
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:265
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f435_437_spi.h:267
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f435_437_spi.h:262
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f435_437_spi.h:260
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f435_437_spi.h:266
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • spi
  • halfduplex_interrupt
  • inc
project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • spi
  • halfduplex_interrupt
  • inc
project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • spi
  • halfduplex_interrupt
  • inc
project/at_start_f435/examples/spi/halfduplex_interrupt/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • spi
  • halfduplex_interrupt
  • src
Functions
project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • spi
  • halfduplex_interrupt
  • src
project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • spi
  • halfduplex_interrupt
  • src
Macros | Functions | Variables
project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Macros

#define BUFFERSIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | SPI3_I2S3EXT_IRQHandler (void)
This function handles the spi3 interrupt request. More...
void | SPI2_I2S2EXT_IRQHandler (void)
This function handles the spi2 interrupt request. More...

Variables

uint8_t | spi3_buffer_tx [32]
uint8_t | spi2_buffer_rx [32]
uint32_t | tx_index
uint32_t | rx_index

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • spi
  • halfduplex_interrupt
  • src
project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
38#define BUFFERSIZE 32
39
40extern uint8_t spi3_buffer_tx[BUFFERSIZE];
41extern uint8_t spi2_buffer_rx[BUFFERSIZE];
42extern uint32_t tx_index;
43extern uint32_t rx_index;
44
50void NMI_Handler(void)
51{
52}
53
59void HardFault_Handler(void)
60{
61 /* go to infinite loop when hard fault exception occurs */
62 while(1)
63 {
64 }
65}
66
72void MemManage_Handler(void)
73{
74 /* go to infinite loop when memory manage exception occurs */
75 while(1)
76 {
77 }
78}
79
85void BusFault_Handler(void)
86{
87 /* go to infinite loop when bus fault exception occurs */
88 while(1)
89 {
90 }
91}
92
98void UsageFault_Handler(void)
99{
100 /* go to infinite loop when usage fault exception occurs */
101 while(1)
102 {
103 }
104}
105
111void SVC_Handler(void)
112{
113}
114
120void DebugMon_Handler(void)
121{
122}
123
129void PendSV_Handler(void)
130{
131}
132
138void SysTick_Handler(void)
139{
140}
141
147 void SPI3_I2S3EXT_IRQHandler(void)
148{
149 if(spi_i2s_flag_get(SPI3, SPI_I2S_TDBE_FLAG) != RESET)
150 {
151 spi_i2s_data_transmit(SPI3, spi3_buffer_tx[tx_index++]);
152 if(tx_index == BUFFERSIZE)
153 {
154 spi_i2s_interrupt_enable(SPI3, SPI_I2S_TDBE_INT, FALSE);
155 }
156 }
157}
158
164 void SPI2_I2S2EXT_IRQHandler(void)
165{
166 if(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) != RESET)
167 {
168 spi2_buffer_rx[rx_index++] = spi_i2s_data_receive(SPI2);
169 }
170}
171
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c:98
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c:59
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c:72
SPI3_I2S3EXT_IRQHandler
void SPI3_I2S3EXT_IRQHandler(void)
This function handles the spi3 interrupt request.
Definition: project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c:147
spi2_buffer_rx
uint8_t spi2_buffer_rx[32]
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:53
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c:111
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c:129
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c:50
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c:85
rx_index
uint32_t rx_index
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c:40
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c:138
tx_index
uint32_t tx_index
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c:45
BUFFERSIZE
#define BUFFERSIZE
Definition: project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c:38
spi3_buffer_tx
uint8_t spi3_buffer_tx[32]
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:45
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c:120
SPI2_I2S2EXT_IRQHandler
void SPI2_I2S2EXT_IRQHandler(void)
This function handles the spi2 interrupt request.
Definition: project/at_start_f435/examples/spi/halfduplex_interrupt/src/at32f435_437_int.c:164
FALSE
@ FALSE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f435_437_spi.h:54
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f435_437_spi.h:53
SPI_I2S_TDBE_INT
#define SPI_I2S_TDBE_INT
Definition: at32f435_437_spi.h:75
spi_i2s_interrupt_enable
void spi_i2s_interrupt_enable(spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts.
Definition: at32f435_437_spi.c:498
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f435_437_spi.c:548
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f435_437_spi.c:583
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f435_437_spi.c:560
SPI3
#define SPI3
Definition: at32f435_437_spi.h:455
SPI2
#define SPI2
Definition: at32f435_437_spi.h:454
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • spi
  • halfduplex_interrupt
  • src
Macros | Functions | Variables
project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 32

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi3_buffer_tx [32]
uint8_t | spi2_buffer_rx [32]
volatile uint32_t | tx_index = 0
volatile uint32_t | rx_index = 0
volatile error_status | transfer_status = ERROR

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • spi
  • halfduplex_interrupt
  • src
project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define BUFFER_SIZE 32
39
40 spi_init_type spi_init_struct;
41
42uint8_t spi3_buffer_tx[BUFFER_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
43 0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
44 0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
45 0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20};
46uint8_t spi2_buffer_rx[BUFFER_SIZE];
47volatile uint32_t tx_index = 0, rx_index = 0;
48volatile error_status transfer_status = ERROR;
49
50static void gpio_config(void);
51static void spi_config(void);
52 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length);
53
60 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
61{
62 while(buffer_length--)
63 {
64 if(*pbuffer1 != *pbuffer2)
65 {
66 return ERROR;
67 }
68
69 pbuffer1++;
70 pbuffer2++;
71 }
72 return SUCCESS;
73}
74
80static void spi_config(void)
81{
82 crm_periph_clock_enable(CRM_SPI3_PERIPH_CLOCK, TRUE);
83 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
84 spi_default_para_init(&spi_init_struct);
85 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_TX;
86 spi_init_struct.master_slave_mode =SPI_MODE_MASTER;
87 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_8;
88 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_MSB;
89 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
90 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_LOW;
91 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
92 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
93 spi_init(SPI3, &spi_init_struct);
94
95 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_RX;
96 spi_init_struct.master_slave_mode =SPI_MODE_SLAVE;
97 spi_init(SPI2, &spi_init_struct);
98
99 nvic_irq_enable(SPI3_I2S3EXT_IRQn, 0, 0);
100 nvic_irq_enable(SPI2_I2S2EXT_IRQn, 0, 0);
101 spi_i2s_interrupt_enable(SPI3, SPI_I2S_TDBE_INT, TRUE);
102 spi_i2s_interrupt_enable(SPI2, SPI_I2S_RDBF_INT, TRUE);
103
104 spi_enable(SPI2, TRUE);
105 spi_enable(SPI3, TRUE);
106}
107
113static void gpio_config(void)
114{
115 gpio_init_type gpio_initstructure;
116 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
117 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
118
119 /* master sck pin */
120 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
121 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
122 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
123 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
124 gpio_initstructure.gpio_pins = GPIO_PINS_10;
125 gpio_init(GPIOC, &gpio_initstructure);
126 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE10, GPIO_MUX_6);
127
128 /* master mosi pin */
129 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
130 gpio_initstructure.gpio_pins = GPIO_PINS_12;
131 gpio_init(GPIOC, &gpio_initstructure);
132 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE12, GPIO_MUX_6);
133
134 /* slave sck pin */
135 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
136 gpio_initstructure.gpio_pins = GPIO_PINS_1;
137 gpio_init(GPIOD, &gpio_initstructure);
138 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_6);
139
140 /* slave miso pin */
141 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
142 gpio_initstructure.gpio_pins = GPIO_PINS_2;
143 gpio_init(GPIOC, &gpio_initstructure);
144 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE2, GPIO_MUX_5);
145}
146
152int main(void)
153{
154 system_clock_config();
155 at32_board_init();
156 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
157 gpio_config();
158 /* config spi1 send spi2 receive */
159 spi_config();
160 while(rx_index < BUFFER_SIZE);
161
162 /* test result:the data check */
163 transfer_status = buffer_compare(spi2_buffer_rx, spi3_buffer_tx, BUFFER_SIZE);
164
165 /* test result indicate:if success ,led2 lights */
166 if(transfer_status==SUCCESS)
167 {
168 at32_led_on(LED2);
169 }
170 else
171 {
172 at32_led_off(LED2);
173 }
174 while(1)
175 {
176 }
177}
178
at32f435_437_board.h
buffer_compare
error_status buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function.
Definition: project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c:60
tx_index
volatile uint32_t tx_index
Definition: project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c:47
spi2_buffer_rx
uint8_t spi2_buffer_rx[32]
Definition: project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c:46
spi_config
static void spi_config(void)
spi configuration.
Definition: project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c:80
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c:152
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c:40
rx_index
volatile uint32_t rx_index
Definition: project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c:47
spi3_buffer_tx
uint8_t spi3_buffer_tx[32]
Definition: project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c:42
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c:113
transfer_status
volatile error_status transfer_status
Definition: project/at_start_f435/examples/spi/halfduplex_interrupt/src/main.c:48
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED2
@ LED2
Definition: at32f435_437_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_SPI3_PERIPH_CLOCK
@ CRM_SPI3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:139
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:138
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_6
@ GPIO_MUX_6
Definition: at32f435_437_gpio.h:162
GPIO_MUX_5
@ GPIO_MUX_5
Definition: at32f435_437_gpio.h:161
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
SPI_I2S_TDBE_INT
#define SPI_I2S_TDBE_INT
Definition: at32f435_437_spi.h:75
SPI_I2S_RDBF_INT
#define SPI_I2S_RDBF_INT
Definition: at32f435_437_spi.h:74
spi_i2s_interrupt_enable
void spi_i2s_interrupt_enable(spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts.
Definition: at32f435_437_spi.c:498
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f435_437_spi.c:101
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f435_437_spi.c:81
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f435_437_spi.c:321
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f435_437_spi.h:99
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f435_437_spi.h:100
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f435_437_spi.h:118
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f435_437_spi.h:127
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f435_437_spi.h:153
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f435_437_spi.h:108
SPI_TRANSMIT_HALF_DUPLEX_RX
@ SPI_TRANSMIT_HALF_DUPLEX_RX
Definition: at32f435_437_spi.h:164
SPI_TRANSMIT_HALF_DUPLEX_TX
@ SPI_TRANSMIT_HALF_DUPLEX_TX
Definition: at32f435_437_spi.h:165
SPI_MCLK_DIV_8
@ SPI_MCLK_DIV_8
Definition: at32f435_437_spi.h:138
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f435_437_spi.h:90
SPI3
#define SPI3
Definition: at32f435_437_spi.h:455
SPI2
#define SPI2
Definition: at32f435_437_spi.h:454
SPI2_I2S2EXT_IRQn
@ SPI2_I2S2EXT_IRQn
Definition: at32f435_437.h:184
SPI3_I2S3EXT_IRQn
@ SPI3_I2S3EXT_IRQn
Definition: at32f435_437.h:199
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
spi_init_type
spi init type
Definition: at32f435_437_spi.h:259
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f435_437_spi.h:261
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f435_437_spi.h:263
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f435_437_spi.h:264
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:265
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f435_437_spi.h:267
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f435_437_spi.h:262
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f435_437_spi.h:260
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f435_437_spi.h:266
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • spi
  • halfduplex_transceiver_switch
  • inc
project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • spi
  • halfduplex_transceiver_switch
  • inc
project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • spi
  • halfduplex_transceiver_switch
  • inc
project/at_start_f435/examples/spi/halfduplex_transceiver_switch/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • spi
  • halfduplex_transceiver_switch
  • src
Functions
project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • spi
  • halfduplex_transceiver_switch
  • src
project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • spi
  • halfduplex_transceiver_switch
  • src
Macros | Functions | Variables
project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Macros

#define BUFFERSIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | SPI3_I2S3EXT_IRQHandler (void)
This function handles the spi3 interrupt request. More...
void | SPI2_I2S2EXT_IRQHandler (void)
This function handles the spi2 interrupt request. More...

Variables

uint8_t | spi3_buffer_tx [32]
uint8_t | spi2_buffer_tx [32]
uint8_t | spi3_buffer_rx [32]
uint8_t | spi2_buffer_rx [32]
uint32_t | tx_index
uint32_t | rx_index

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • spi
  • halfduplex_transceiver_switch
  • src
project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
38#define BUFFERSIZE 32
39
40extern uint8_t spi3_buffer_tx[BUFFERSIZE];
41extern uint8_t spi2_buffer_tx[BUFFERSIZE];
42extern uint8_t spi3_buffer_rx[BUFFERSIZE];
43extern uint8_t spi2_buffer_rx[BUFFERSIZE];
44extern uint32_t tx_index;
45extern uint32_t rx_index;
46
52void NMI_Handler(void)
53{
54}
55
61void HardFault_Handler(void)
62{
63 /* go to infinite loop when hard fault exception occurs */
64 while(1)
65 {
66 }
67}
68
74void MemManage_Handler(void)
75{
76 /* go to infinite loop when memory manage exception occurs */
77 while(1)
78 {
79 }
80}
81
87void BusFault_Handler(void)
88{
89 /* go to infinite loop when bus fault exception occurs */
90 while(1)
91 {
92 }
93}
94
100void UsageFault_Handler(void)
101{
102 /* go to infinite loop when usage fault exception occurs */
103 while(1)
104 {
105 }
106}
107
113void SVC_Handler(void)
114{
115}
116
122void DebugMon_Handler(void)
123{
124}
125
131void PendSV_Handler(void)
132{
133}
134
140void SysTick_Handler(void)
141{
142}
143
149 void SPI3_I2S3EXT_IRQHandler(void)
150{
151 if(SPI3->ctrl2_bit.tdbeie != RESET)
152 {
153 if(spi_i2s_flag_get(SPI3, SPI_I2S_TDBE_FLAG) != RESET)
154 {
155 spi_i2s_data_transmit(SPI3, spi3_buffer_tx[tx_index++]);
156 if(tx_index == BUFFERSIZE)
157 {
158 spi_i2s_interrupt_enable(SPI3, SPI_I2S_TDBE_INT, FALSE);
159 }
160 }
161 }
162 if(SPI3->ctrl2_bit.rdbfie != RESET)
163 {
164 if(spi_i2s_flag_get(SPI3, SPI_I2S_RDBF_FLAG) != RESET)
165 {
166 spi_enable(SPI3, FALSE);
167 spi3_buffer_rx[rx_index++] = spi_i2s_data_receive(SPI3);
168 spi_enable(SPI3, TRUE);
169 if(rx_index == BUFFERSIZE)
170 {
171 spi_i2s_interrupt_enable(SPI3, SPI_I2S_RDBF_INT, FALSE);
172 }
173 }
174 }
175}
176
182 void SPI2_I2S2EXT_IRQHandler(void)
183{
184 if(SPI2->ctrl2_bit.tdbeie != RESET)
185 {
186 if(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) != RESET)
187 {
188 spi_i2s_data_transmit(SPI2, spi2_buffer_tx[tx_index++]);
189 if(tx_index == BUFFERSIZE)
190 {
191 spi_i2s_interrupt_enable(SPI2, SPI_I2S_TDBE_INT, FALSE);
192 }
193 }
194 }
195 if(SPI2->ctrl2_bit.rdbfie != RESET)
196 {
197 if(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) != RESET)
198 {
199 spi2_buffer_rx[rx_index++] = spi_i2s_data_receive(SPI2);
200 }
201 }
202}
203
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c:100
spi2_buffer_tx
uint8_t spi2_buffer_tx[32]
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c:44
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c:61
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c:74
SPI3_I2S3EXT_IRQHandler
void SPI3_I2S3EXT_IRQHandler(void)
This function handles the spi3 interrupt request.
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c:149
spi3_buffer_rx
uint8_t spi3_buffer_rx[32]
Definition: project/at_start_f435/examples/spi/crc_transfer_polling/src/main.c:48
spi2_buffer_rx
uint8_t spi2_buffer_rx[32]
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:53
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c:113
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c:131
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c:52
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c:87
rx_index
uint32_t rx_index
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/at32f435_437_int.c:40
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c:140
tx_index
uint32_t tx_index
Definition: project/at_start_f435/examples/i2s/halfduplex_interrupt/src/main.c:45
BUFFERSIZE
#define BUFFERSIZE
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c:38
spi3_buffer_tx
uint8_t spi3_buffer_tx[32]
Definition: project/at_start_f435/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:45
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c:122
SPI2_I2S2EXT_IRQHandler
void SPI2_I2S2EXT_IRQHandler(void)
This function handles the spi2 interrupt request.
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/at32f435_437_int.c:182
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f435_437_spi.h:54
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f435_437_spi.h:53
SPI_I2S_TDBE_INT
#define SPI_I2S_TDBE_INT
Definition: at32f435_437_spi.h:75
SPI_I2S_RDBF_INT
#define SPI_I2S_RDBF_INT
Definition: at32f435_437_spi.h:74
spi_i2s_interrupt_enable
void spi_i2s_interrupt_enable(spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts.
Definition: at32f435_437_spi.c:498
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f435_437_spi.c:548
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f435_437_spi.c:583
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f435_437_spi.c:560
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f435_437_spi.c:321
SPI3
#define SPI3
Definition: at32f435_437_spi.h:455
SPI2
#define SPI2
Definition: at32f435_437_spi.h:454
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • spi
  • halfduplex_transceiver_switch
  • src
Macros | Functions | Variables
project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 32

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi3_buffer_tx [32]
uint8_t | spi2_buffer_tx [32]
uint8_t | spi3_buffer_rx [32]
uint8_t | spi2_buffer_rx [32]
volatile uint32_t | tx_index = 0
volatile uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • spi
  • halfduplex_transceiver_switch
  • src
project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define BUFFER_SIZE 32
39
40 spi_init_type spi_init_struct;
41uint8_t spi3_buffer_tx[BUFFER_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
42 0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
43 0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
44 0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20};
45uint8_t spi2_buffer_tx[BUFFER_SIZE] = {0x51, 0x52, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58,
46 0x59, 0x5A, 0x5B, 0x5C, 0x5D, 0x5E, 0x5F, 0x60,
47 0x61, 0x62, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68,
48 0x69, 0x6A, 0x6B, 0x6C, 0x6D, 0x6E, 0x6F, 0x70};
49uint8_t spi3_buffer_rx[BUFFER_SIZE], spi2_buffer_rx[BUFFER_SIZE];
50volatile uint32_t tx_index = 0, rx_index = 0;
51volatile error_status transfer_status1 = ERROR, transfer_status2 = ERROR;
52
53static void gpio_config(void);
54static void spi_config(void);
55 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length);
56
63 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
64{
65 while(buffer_length--)
66 {
67 if(*pbuffer1 != *pbuffer2)
68 {
69 return ERROR;
70 }
71
72 pbuffer1++;
73 pbuffer2++;
74 }
75 return SUCCESS;
76}
77
83static void spi_config(void)
84{
85 crm_periph_clock_enable(CRM_SPI3_PERIPH_CLOCK, TRUE);
86 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
87 spi_default_para_init(&spi_init_struct);
88 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_TX;
89 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
90 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_256;
91 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_MSB;
92 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
93 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_LOW;
94 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
95 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
96 spi_init(SPI3, &spi_init_struct);
97
98 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_RX;
99 spi_init_struct.master_slave_mode = SPI_MODE_SLAVE;
100 spi_init(SPI2, &spi_init_struct);
101
102 nvic_irq_enable(SPI3_I2S3EXT_IRQn, 0, 0);
103 nvic_irq_enable(SPI2_I2S2EXT_IRQn, 0, 0);
104 spi_i2s_interrupt_enable(SPI3, SPI_I2S_TDBE_INT, TRUE);
105 spi_i2s_interrupt_enable(SPI2, SPI_I2S_RDBF_INT, TRUE);
106
107 spi_enable(SPI3, TRUE);
108 spi_enable(SPI2, TRUE);
109}
110
116static void gpio_config(void)
117{
118 gpio_init_type gpio_initstructure;
119 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
120 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
121
122 /* master sck pin */
123 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
124 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
125 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
126 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
127 gpio_initstructure.gpio_pins = GPIO_PINS_10;
128 gpio_init(GPIOC, &gpio_initstructure);
129 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE10, GPIO_MUX_6);
130
131 /* master mosi pin */
132 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
133 gpio_initstructure.gpio_pins = GPIO_PINS_12;
134 gpio_init(GPIOC, &gpio_initstructure);
135 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE12, GPIO_MUX_6);
136
137 /* slave sck pin */
138 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
139 gpio_initstructure.gpio_pins = GPIO_PINS_1;
140 gpio_init(GPIOD, &gpio_initstructure);
141 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_6);
142
143 /* slave miso pin */
144 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
145 gpio_initstructure.gpio_pins = GPIO_PINS_2;
146 gpio_init(GPIOC, &gpio_initstructure);
147 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE2, GPIO_MUX_5);
148
149 while(gpio_input_data_bit_read(GPIOD, GPIO_PINS_1)!=RESET);
150}
151
157int main(void)
158{
159 system_clock_config();
160 at32_board_init();
161 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
162 gpio_config();
163 /* config spi1 send spi2 receive */
164 spi_config();
165 while(rx_index < BUFFER_SIZE);
166
167 /* test result:the data check */
168 transfer_status1 = buffer_compare(spi2_buffer_rx, spi3_buffer_tx, BUFFER_SIZE);
169
170 /* config spi2 send spi1 receive */
171 spi_enable(SPI3, FALSE);
172 spi_enable(SPI2, FALSE);
173 rx_index = 0;
174 tx_index = 0;
175 spi_i2s_interrupt_enable(SPI3, SPI_I2S_TDBE_INT, FALSE);
176 spi_i2s_interrupt_enable(SPI2, SPI_I2S_RDBF_INT, FALSE);
177
178 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_RX;
179 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
180 spi_init(SPI3, &spi_init_struct);
181
182 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_TX;
183 spi_init_struct.master_slave_mode = SPI_MODE_SLAVE;
184 spi_init(SPI2, &spi_init_struct);
185
186 spi_i2s_interrupt_enable(SPI3, SPI_I2S_RDBF_INT, TRUE);
187 spi_i2s_interrupt_enable(SPI2, SPI_I2S_TDBE_INT, TRUE);
188 spi_enable(SPI2, TRUE);
189 spi_enable(SPI3, TRUE);
190 while(rx_index < BUFFER_SIZE);
191
192 /* test result:the data check */
193 transfer_status2 = buffer_compare(spi3_buffer_rx, spi2_buffer_tx, BUFFER_SIZE);
194
195 /* test result indicate:if success ,led2 lights */
196 if((transfer_status1 == SUCCESS) && (transfer_status2 == SUCCESS))
197 {
198 at32_led_on(LED2);
199 }
200 else
201 {
202 at32_led_off(LED2);
203 }
204 while(1)
205 {
206 }
207}
208
at32f435_437_board.h
buffer_compare
error_status buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function.
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c:63
spi2_buffer_tx
uint8_t spi2_buffer_tx[32]
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c:45
tx_index
volatile uint32_t tx_index
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c:50
spi3_buffer_rx
uint8_t spi3_buffer_rx[32]
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c:49
spi2_buffer_rx
uint8_t spi2_buffer_rx[32]
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c:49
spi_config
static void spi_config(void)
spi configuration.
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c:83
transfer_status1
volatile error_status transfer_status1
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c:51
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c:38
transfer_status2
volatile error_status transfer_status2
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c:51
main
int main(void)
main function.
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c:157
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c:40
rx_index
volatile uint32_t rx_index
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c:50
spi3_buffer_tx
uint8_t spi3_buffer_tx[32]
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c:41
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/spi/halfduplex_transceiver_switch/src/main.c:116
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED2
@ LED2
Definition: at32f435_437_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_SPI3_PERIPH_CLOCK
@ CRM_SPI3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:139
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:138
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_input_data_bit_read
flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified input port pin.
Definition: at32f435_437_gpio.c:170
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_6
@ GPIO_MUX_6
Definition: at32f435_437_gpio.h:162
GPIO_MUX_5
@ GPIO_MUX_5
Definition: at32f435_437_gpio.h:161
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
SPI_I2S_TDBE_INT
#define SPI_I2S_TDBE_INT
Definition: at32f435_437_spi.h:75
SPI_I2S_RDBF_INT
#define SPI_I2S_RDBF_INT
Definition: at32f435_437_spi.h:74
spi_i2s_interrupt_enable
void spi_i2s_interrupt_enable(spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts.
Definition: at32f435_437_spi.c:498
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f435_437_spi.c:101
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f435_437_spi.c:81
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f435_437_spi.c:321
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f435_437_spi.h:99
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f435_437_spi.h:100
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f435_437_spi.h:118
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f435_437_spi.h:127
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f435_437_spi.h:153
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f435_437_spi.h:108
SPI_TRANSMIT_HALF_DUPLEX_RX
@ SPI_TRANSMIT_HALF_DUPLEX_RX
Definition: at32f435_437_spi.h:164
SPI_TRANSMIT_HALF_DUPLEX_TX
@ SPI_TRANSMIT_HALF_DUPLEX_TX
Definition: at32f435_437_spi.h:165
SPI_MCLK_DIV_256
@ SPI_MCLK_DIV_256
Definition: at32f435_437_spi.h:143
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f435_437_spi.h:90
SPI3
#define SPI3
Definition: at32f435_437_spi.h:455
SPI2
#define SPI2
Definition: at32f435_437_spi.h:454
SPI2_I2S2EXT_IRQn
@ SPI2_I2S2EXT_IRQn
Definition: at32f435_437.h:184
SPI3_I2S3EXT_IRQn
@ SPI3_I2S3EXT_IRQn
Definition: at32f435_437.h:199
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
spi_init_type
spi init type
Definition: at32f435_437_spi.h:259
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f435_437_spi.h:261
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f435_437_spi.h:263
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f435_437_spi.h:264
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:265
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f435_437_spi.h:267
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f435_437_spi.h:262
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f435_437_spi.h:260
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f435_437_spi.h:266
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • spi
  • only_receive_mode_polling
  • inc
project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • spi
  • only_receive_mode_polling
  • inc
project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • spi
  • only_receive_mode_polling
  • inc
project/at_start_f435/examples/spi/only_receive_mode_polling/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • spi
  • only_receive_mode_polling
  • src
Functions
project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • spi
  • only_receive_mode_polling
  • src
project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • spi
  • only_receive_mode_polling
  • src
Functions
project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • spi
  • only_receive_mode_polling
  • src
project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/spi/only_receive_mode_polling/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • spi
  • only_receive_mode_polling
  • src
Macros | Functions | Variables
project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 32

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi3_buffer_tx [32]
uint8_t | spi2_buffer_rx [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
volatile error_status | transfer_status = ERROR

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • spi
  • only_receive_mode_polling
  • src
project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define BUFFER_SIZE 32
39
40 spi_init_type spi_init_struct;
41uint8_t spi3_buffer_tx[BUFFER_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
42 0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
43 0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
44 0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20};
45uint8_t spi2_buffer_rx[BUFFER_SIZE];
46uint32_t tx_index = 0, rx_index = 0;
47volatile error_status transfer_status = ERROR;
48
49static void gpio_config(void);
50static void spi_config(void);
51 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length);
52
59 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
60{
61 while(buffer_length--)
62 {
63 if(*pbuffer1 != *pbuffer2)
64 {
65 return ERROR;
66 }
67
68 pbuffer1++;
69 pbuffer2++;
70 }
71 return SUCCESS;
72}
73
79static void spi_config(void)
80{
81 crm_periph_clock_enable(CRM_SPI3_PERIPH_CLOCK, TRUE);
82 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
83 spi_default_para_init(&spi_init_struct);
84 spi_init_struct.transmission_mode = SPI_TRANSMIT_FULL_DUPLEX;
85 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
86 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_8;
87 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_LSB;
88 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
89 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_LOW;
90 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
91 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
92 spi_init(SPI3, &spi_init_struct);
93
94 spi_init_struct.transmission_mode = SPI_TRANSMIT_SIMPLEX_RX;
95 spi_init_struct.master_slave_mode = SPI_MODE_SLAVE;
96 spi_init(SPI2, &spi_init_struct);
97
98 spi_enable(SPI3, TRUE);
99 spi_enable(SPI2, TRUE);
100}
101
107static void gpio_config(void)
108{
109 gpio_init_type gpio_initstructure;
110 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
111 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
112 gpio_default_para_init(&gpio_initstructure);
113 /* spi3 sck pin */
114 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
115 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
116 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
117 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
118 gpio_initstructure.gpio_pins = GPIO_PINS_10;
119 gpio_init(GPIOC, &gpio_initstructure);
120 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE10, GPIO_MUX_6);
121
122 /* spi3 mosi pin */
123 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
124 gpio_initstructure.gpio_pins = GPIO_PINS_12;
125 gpio_init(GPIOC, &gpio_initstructure);
126 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE12, GPIO_MUX_6);
127
128 /* spi2 sck pin */
129 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
130 gpio_initstructure.gpio_pins = GPIO_PINS_1;
131 gpio_init(GPIOD, &gpio_initstructure);
132 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_6);
133
134 /* spi2 mosi pin */
135 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
136 gpio_initstructure.gpio_pins = GPIO_PINS_4;
137 gpio_init(GPIOD, &gpio_initstructure);
138 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_6);
139
140 while(gpio_input_data_bit_read(GPIOD, GPIO_PINS_1) != RESET);
141}
142
148int main(void)
149{
150 system_clock_config();
151 at32_board_init();
152 gpio_config();
153 spi_config();
154
155 /* transfer procedure:the "BUFFER_SIZE" data transfer */
156 while(tx_index < BUFFER_SIZE)
157 {
158 while(spi_i2s_flag_get(SPI3, SPI_I2S_TDBE_FLAG) == RESET);
159 spi_i2s_data_transmit(SPI3, spi3_buffer_tx[tx_index++]);
160 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
161 spi2_buffer_rx[rx_index++] = spi_i2s_data_receive(SPI2);
162 }
163
164 /* test result:the data check */
165 transfer_status = buffer_compare(spi2_buffer_rx, spi3_buffer_tx, BUFFER_SIZE);
166
167 /* test result indicate:if success ,led2 lights */
168 if(transfer_status == SUCCESS)
169 {
170 at32_led_on(LED2);
171 }
172 else
173 {
174 at32_led_off(LED2);
175 }
176 while(1)
177 {
178 }
179}
180
at32f435_437_board.h
buffer_compare
error_status buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function.
Definition: project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c:59
spi2_buffer_rx
uint8_t spi2_buffer_rx[32]
Definition: project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c:45
spi_config
static void spi_config(void)
spi configuration.
Definition: project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c:79
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c:148
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c:40
rx_index
uint32_t rx_index
Definition: project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c:46
tx_index
uint32_t tx_index
Definition: project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c:46
spi3_buffer_tx
uint8_t spi3_buffer_tx[32]
Definition: project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c:41
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c:107
transfer_status
volatile error_status transfer_status
Definition: project/at_start_f435/examples/spi/only_receive_mode_polling/src/main.c:47
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED2
@ LED2
Definition: at32f435_437_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_SPI3_PERIPH_CLOCK
@ CRM_SPI3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:139
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:138
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_input_data_bit_read
flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified input port pin.
Definition: at32f435_437_gpio.c:170
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_6
@ GPIO_MUX_6
Definition: at32f435_437_gpio.h:162
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f435_437_spi.h:54
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f435_437_spi.h:53
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f435_437_spi.c:548
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f435_437_spi.c:583
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f435_437_spi.c:101
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f435_437_spi.c:81
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f435_437_spi.c:560
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f435_437_spi.c:321
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f435_437_spi.h:99
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f435_437_spi.h:100
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f435_437_spi.h:118
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f435_437_spi.h:127
SPI_FIRST_BIT_LSB
@ SPI_FIRST_BIT_LSB
Definition: at32f435_437_spi.h:154
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f435_437_spi.h:108
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f435_437_spi.h:162
SPI_TRANSMIT_SIMPLEX_RX
@ SPI_TRANSMIT_SIMPLEX_RX
Definition: at32f435_437_spi.h:163
SPI_MCLK_DIV_8
@ SPI_MCLK_DIV_8
Definition: at32f435_437_spi.h:138
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f435_437_spi.h:90
SPI3
#define SPI3
Definition: at32f435_437_spi.h:455
SPI2
#define SPI2
Definition: at32f435_437_spi.h:454
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
spi_init_type
spi init type
Definition: at32f435_437_spi.h:259
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f435_437_spi.h:261
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f435_437_spi.h:263
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f435_437_spi.h:264
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:265
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f435_437_spi.h:267
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f435_437_spi.h:262
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f435_437_spi.h:260
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f435_437_spi.h:266
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • spi
  • ti_fullduplex_dma
  • inc
project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • spi
  • ti_fullduplex_dma
  • inc
project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • spi
  • ti_fullduplex_dma
  • inc
project/at_start_f435/examples/spi/ti_fullduplex_dma/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • spi
  • ti_fullduplex_dma
  • src
Functions
project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • spi
  • ti_fullduplex_dma
  • src
project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • spi
  • ti_fullduplex_dma
  • src
Functions
project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • spi
  • ti_fullduplex_dma
  • src
project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/spi/ti_fullduplex_dma/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • spi
  • ti_fullduplex_dma
  • src
Macros | Functions | Variables
project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 32

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t bufferlength)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi3_buffer_tx [32]
uint8_t | spi2_buffer_tx [32]
uint8_t | spi3_buffer_rx [32]
uint8_t | spi2_buffer_rx [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • spi
  • ti_fullduplex_dma
  • src
project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define BUFFER_SIZE 32
39
40 spi_init_type spi_init_struct;
41uint8_t spi3_buffer_tx[BUFFER_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
42 0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
43 0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
44 0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20};
45uint8_t spi2_buffer_tx[BUFFER_SIZE] = {0x51, 0x52, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58,
46 0x59, 0x5A, 0x5B, 0x5C, 0x5D, 0x5E, 0x5F, 0x60,
47 0x61, 0x62, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68,
48 0x69, 0x6A, 0x6B, 0x6C, 0x6D, 0x6E, 0x6F, 0x70};
49uint8_t spi3_buffer_rx[BUFFER_SIZE], spi2_buffer_rx[BUFFER_SIZE];
50uint32_t tx_index = 0, rx_index = 0;
51volatile error_status transfer_status1 = ERROR, transfer_status2 = ERROR;
52
53static void gpio_config(void);
54static void spi_config(void);
55 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t bufferlength);
56
63 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t bufferlength)
64{
65 while(bufferlength--)
66 {
67 if(*pbuffer1 != *pbuffer2)
68 {
69 return ERROR;
70 }
71
72 pbuffer1++;
73 pbuffer2++;
74 }
75 return SUCCESS;
76}
77
83static void spi_config(void)
84{
85 dma_init_type dma_init_struct;
86
87 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
88 dma_reset(DMA1_CHANNEL1);
89 dma_reset(DMA1_CHANNEL2);
90 dma_reset(DMA1_CHANNEL3);
91 dma_reset(DMA1_CHANNEL4);
92 dmamux_enable(DMA1, TRUE);
93
94 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_SPI2_TX);
95 dmamux_init(DMA1MUX_CHANNEL2, DMAMUX_DMAREQ_ID_SPI2_RX);
96 dmamux_init(DMA1MUX_CHANNEL3, DMAMUX_DMAREQ_ID_SPI3_TX);
97 dmamux_init(DMA1MUX_CHANNEL4, DMAMUX_DMAREQ_ID_SPI3_RX);
98
99 dma_default_para_init(&dma_init_struct);
100 dma_init_struct.buffer_size = BUFFER_SIZE;
101 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
102 dma_init_struct.memory_inc_enable = TRUE;
103 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
104 dma_init_struct.peripheral_inc_enable = FALSE;
105 dma_init_struct.priority = DMA_PRIORITY_HIGH;
106 dma_init_struct.loop_mode_enable = FALSE;
107
108 dma_init_struct.memory_base_addr = (uint32_t)spi2_buffer_tx;
109 dma_init_struct.peripheral_base_addr = (uint32_t)&(SPI2->dt);
110 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
111 dma_init(DMA1_CHANNEL1, &dma_init_struct);
112
113 dma_init_struct.memory_base_addr = (uint32_t)spi2_buffer_rx;
114 dma_init_struct.peripheral_base_addr = (uint32_t)&(SPI2->dt);
115 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
116 dma_init(DMA1_CHANNEL2, &dma_init_struct);
117
118 dma_init_struct.memory_base_addr = (uint32_t)spi3_buffer_tx;
119 dma_init_struct.peripheral_base_addr = (uint32_t)&(SPI3->dt);
120 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
121 dma_init(DMA1_CHANNEL3, &dma_init_struct);
122
123 dma_init_struct.memory_base_addr = (uint32_t)spi3_buffer_rx;
124 dma_init_struct.peripheral_base_addr = (uint32_t)&(SPI3->dt);
125 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
126 dma_init(DMA1_CHANNEL4, &dma_init_struct);
127
128 crm_periph_clock_enable(CRM_SPI3_PERIPH_CLOCK, TRUE);
129 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
130 spi_default_para_init(&spi_init_struct);
131 spi_init_struct.transmission_mode = SPI_TRANSMIT_FULL_DUPLEX;
132 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
133 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_8;
134 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_MSB;
135 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
136 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_LOW;
137 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
138 spi_init_struct.cs_mode_selection = SPI_CS_HARDWARE_MODE;
139 spi_init(SPI3, &spi_init_struct);
140
141 spi_init_struct.master_slave_mode = SPI_MODE_SLAVE;
142 spi_init(SPI2, &spi_init_struct);
143
144 spi_i2s_dma_transmitter_enable(SPI2,TRUE);
145 spi_i2s_dma_transmitter_enable(SPI3,TRUE);
146 spi_i2s_dma_receiver_enable(SPI2,TRUE);
147 spi_i2s_dma_receiver_enable(SPI3,TRUE);
148
149 /* enable ti mode,at this time,the setting in clock_polarity/clock_phase/cs_mode_selection invalid */
150 spi_ti_mode_enable(SPI3, TRUE);
151 spi_ti_mode_enable(SPI2, TRUE);
152 spi_enable(SPI2, TRUE);
153 spi_enable(SPI3, TRUE);
154}
155
161static void gpio_config(void)
162{
163 gpio_init_type gpio_initstructure;
164 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
165 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
166 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
167 gpio_default_para_init(&gpio_initstructure);
168 /* spi3 cs pin */
169 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
170 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
171 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
172 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
173 gpio_initstructure.gpio_pins = GPIO_PINS_4;
174 gpio_init(GPIOA, &gpio_initstructure);
175 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE4, GPIO_MUX_6);
176
177 /* spi3 sck pin */
178 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
179 gpio_initstructure.gpio_pins = GPIO_PINS_10;
180 gpio_init(GPIOC, &gpio_initstructure);
181 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE10, GPIO_MUX_6);
182
183 /* spi3 miso pin */
184 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
185 gpio_initstructure.gpio_pins = GPIO_PINS_11;
186 gpio_init(GPIOC, &gpio_initstructure);
187 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE11, GPIO_MUX_6);
188
189 /* spi3 mosi pin */
190 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
191 gpio_initstructure.gpio_pins = GPIO_PINS_12;
192 gpio_init(GPIOC, &gpio_initstructure);
193 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE12, GPIO_MUX_6);
194
195 /* spi2 cs pin */
196 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
197 gpio_initstructure.gpio_pins = GPIO_PINS_0;
198 gpio_init(GPIOD, &gpio_initstructure);
199 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE0, GPIO_MUX_7);
200
201 /* spi2 sck pin */
202 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
203 gpio_initstructure.gpio_pins = GPIO_PINS_1;
204 gpio_init(GPIOD, &gpio_initstructure);
205 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_6);
206
207 /* spi2 miso pin */
208 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
209 gpio_initstructure.gpio_pins = GPIO_PINS_2;
210 gpio_init(GPIOC, &gpio_initstructure);
211 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE2, GPIO_MUX_5);
212
213 /* spi2 mosi pin */
214 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
215 gpio_initstructure.gpio_pins = GPIO_PINS_4;
216 gpio_init(GPIOD, &gpio_initstructure);
217 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_6);
218}
219
225int main(void)
226{
227 __IO uint32_t index = 0;
228 system_clock_config();
229 at32_board_init();
230 gpio_config();
231 spi_config();
232
233 dma_channel_enable(DMA1_CHANNEL1, TRUE);
234 dma_channel_enable(DMA1_CHANNEL2, TRUE);
235 dma_channel_enable(DMA1_CHANNEL3, TRUE);
236 dma_channel_enable(DMA1_CHANNEL4, TRUE);
237 while(dma_flag_get(DMA1_FDT2_FLAG) == RESET);
238
239 /* test result:the data check */
240 transfer_status1 = buffer_compare(spi2_buffer_rx, spi3_buffer_tx, BUFFER_SIZE);
241 transfer_status2 = buffer_compare(spi3_buffer_rx, spi2_buffer_tx, BUFFER_SIZE);
242
243 /* test result indicate:if success ,led2 lights */
244 if((transfer_status1 == SUCCESS) && (transfer_status2 == SUCCESS))
245 {
246 at32_led_on(LED2);
247 }
248 else
249 {
250 at32_led_off(LED2);
251 }
252 while(1)
253 {
254 }
255}
256
at32f435_437_board.h
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
spi2_buffer_tx
uint8_t spi2_buffer_tx[32]
Definition: project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c:45
spi3_buffer_rx
uint8_t spi3_buffer_rx[32]
Definition: project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c:49
buffer_compare
error_status buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t bufferlength)
buffer compare function.
Definition: project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c:63
spi2_buffer_rx
uint8_t spi2_buffer_rx[32]
Definition: project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c:49
spi_config
static void spi_config(void)
spi configuration.
Definition: project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c:83
transfer_status1
volatile error_status transfer_status1
Definition: project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c:51
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c:38
transfer_status2
volatile error_status transfer_status2
Definition: project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c:51
main
int main(void)
main function.
Definition: project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c:225
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c:40
rx_index
uint32_t rx_index
Definition: project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c:50
tx_index
uint32_t tx_index
Definition: project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c:50
spi3_buffer_tx
uint8_t spi3_buffer_tx[32]
Definition: project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c:41
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/spi/ti_fullduplex_dma/src/main.c:161
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED2
@ LED2
Definition: at32f435_437_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_SPI3_PERIPH_CLOCK
@ CRM_SPI3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:139
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:138
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:162
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:172
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_SPI2_TX
@ DMAMUX_DMAREQ_ID_SPI2_TX
Definition: at32f435_437_dma.h:207
DMAMUX_DMAREQ_ID_SPI3_RX
@ DMAMUX_DMAREQ_ID_SPI3_RX
Definition: at32f435_437_dma.h:208
DMAMUX_DMAREQ_ID_SPI2_RX
@ DMAMUX_DMAREQ_ID_SPI2_RX
Definition: at32f435_437_dma.h:206
DMAMUX_DMAREQ_ID_SPI3_TX
@ DMAMUX_DMAREQ_ID_SPI3_TX
Definition: at32f435_437_dma.h:209
DMA1_FDT2_FLAG
#define DMA1_FDT2_FLAG
Definition: at32f435_437_dma.h:70
DMA1MUX_CHANNEL2
#define DMA1MUX_CHANNEL2
Definition: at32f435_437_dma.h:705
DMA1MUX_CHANNEL3
#define DMA1MUX_CHANNEL3
Definition: at32f435_437_dma.h:706
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f435_437_dma.h:698
DMA1MUX_CHANNEL4
#define DMA1MUX_CHANNEL4
Definition: at32f435_437_dma.h:707
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f435_437_dma.h:699
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f435_437_dma.h:697
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_6
@ GPIO_MUX_6
Definition: at32f435_437_gpio.h:162
GPIO_MUX_5
@ GPIO_MUX_5
Definition: at32f435_437_gpio.h:161
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f435_437_spi.c:533
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f435_437_spi.c:101
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f435_437_spi.c:81
spi_ti_mode_enable
void spi_ti_mode_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the ti mode for the spi peripheral.
Definition: at32f435_437_spi.c:174
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f435_437_spi.c:321
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f435_437_spi.c:519
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f435_437_spi.h:99
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f435_437_spi.h:100
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f435_437_spi.h:118
SPI_CS_HARDWARE_MODE
@ SPI_CS_HARDWARE_MODE
Definition: at32f435_437_spi.h:126
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f435_437_spi.h:153
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f435_437_spi.h:108
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f435_437_spi.h:162
SPI_MCLK_DIV_8
@ SPI_MCLK_DIV_8
Definition: at32f435_437_spi.h:138
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f435_437_spi.h:90
SPI3
#define SPI3
Definition: at32f435_437_spi.h:455
SPI2
#define SPI2
Definition: at32f435_437_spi.h:454
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
spi_init_type
spi init type
Definition: at32f435_437_spi.h:259
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f435_437_spi.h:261
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f435_437_spi.h:263
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f435_437_spi.h:264
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:265
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f435_437_spi.h:267
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f435_437_spi.h:262
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f435_437_spi.h:260
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f435_437_spi.h:266
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • spi
  • use_jtagpin_hardwarecs_dma
  • src
Functions
project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • spi
  • use_jtagpin_hardwarecs_dma
  • src
project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • spi
  • use_jtagpin_hardwarecs_dma
  • src
Functions
project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • spi
  • use_jtagpin_hardwarecs_dma
  • src
project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • spi
  • use_jtagpin_hardwarecs_dma
  • src
Macros | Functions | Variables
project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 32

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t bufferlength)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi3_buffer_tx [32]
uint8_t | spi2_buffer_tx [32]
uint8_t | spi3_buffer_rx [32]
uint8_t | spi2_buffer_rx [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • spi
  • use_jtagpin_hardwarecs_dma
  • src
project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define BUFFER_SIZE 32
39
40 spi_init_type spi_init_struct;
41uint8_t spi3_buffer_tx[BUFFER_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
42 0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
43 0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
44 0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20};
45uint8_t spi2_buffer_tx[BUFFER_SIZE] = {0x51, 0x52, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58,
46 0x59, 0x5A, 0x5B, 0x5C, 0x5D, 0x5E, 0x5F, 0x60,
47 0x61, 0x62, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68,
48 0x69, 0x6A, 0x6B, 0x6C, 0x6D, 0x6E, 0x6F, 0x70};
49uint8_t spi3_buffer_rx[BUFFER_SIZE], spi2_buffer_rx[BUFFER_SIZE];
50uint32_t tx_index = 0, rx_index = 0;
51volatile error_status transfer_status1 = ERROR, transfer_status2 = ERROR;
52
53static void gpio_config(void);
54static void spi_config(void);
55 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t bufferlength);
56
63 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t bufferlength)
64{
65 while(bufferlength--)
66 {
67 if(*pbuffer1 != *pbuffer2)
68 {
69 return ERROR;
70 }
71
72 pbuffer1++;
73 pbuffer2++;
74 }
75 return SUCCESS;
76}
77
83static void spi_config(void)
84{
85 dma_init_type dma_init_struct;
86
87 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
88 dma_reset(DMA1_CHANNEL1);
89 dma_reset(DMA1_CHANNEL2);
90 dma_reset(DMA1_CHANNEL3);
91 dma_reset(DMA1_CHANNEL4);
92 dmamux_enable(DMA1, TRUE);
93 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_SPI2_TX);
94 dmamux_init(DMA1MUX_CHANNEL2, DMAMUX_DMAREQ_ID_SPI2_RX);
95 dmamux_init(DMA1MUX_CHANNEL3, DMAMUX_DMAREQ_ID_SPI3_TX);
96 dmamux_init(DMA1MUX_CHANNEL4, DMAMUX_DMAREQ_ID_SPI3_RX);
97
98 dma_default_para_init(&dma_init_struct);
99 dma_init_struct.buffer_size = BUFFER_SIZE;
100 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
101 dma_init_struct.memory_inc_enable = TRUE;
102 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
103 dma_init_struct.peripheral_inc_enable = FALSE;
104 dma_init_struct.priority = DMA_PRIORITY_HIGH;
105 dma_init_struct.loop_mode_enable = FALSE;
106
107 dma_init_struct.memory_base_addr = (uint32_t)spi2_buffer_tx;
108 dma_init_struct.peripheral_base_addr = (uint32_t)&(SPI2->dt);
109 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
110 dma_init(DMA1_CHANNEL1, &dma_init_struct);
111
112 dma_init_struct.memory_base_addr = (uint32_t)spi2_buffer_rx;
113 dma_init_struct.peripheral_base_addr = (uint32_t)&(SPI2->dt);
114 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
115 dma_init(DMA1_CHANNEL2, &dma_init_struct);
116
117 dma_init_struct.memory_base_addr = (uint32_t)spi3_buffer_tx;
118 dma_init_struct.peripheral_base_addr = (uint32_t)&(SPI3->dt);
119 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
120 dma_init(DMA1_CHANNEL3, &dma_init_struct);
121
122 dma_init_struct.memory_base_addr = (uint32_t)spi3_buffer_rx;
123 dma_init_struct.peripheral_base_addr = (uint32_t)&(SPI3->dt);
124 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
125 dma_init(DMA1_CHANNEL4, &dma_init_struct);
126
127 crm_periph_clock_enable(CRM_SPI3_PERIPH_CLOCK, TRUE);
128 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
129 spi_default_para_init(&spi_init_struct);
130 spi_init_struct.transmission_mode = SPI_TRANSMIT_FULL_DUPLEX;
131 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
132 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_8;
133 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_MSB;
134 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
135 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_LOW;
136 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
137 spi_init_struct.cs_mode_selection = SPI_CS_HARDWARE_MODE;
138 spi_init(SPI3, &spi_init_struct);
139
140 spi_init_struct.master_slave_mode = SPI_MODE_SLAVE;
141 spi_init(SPI2, &spi_init_struct);
142
143 spi_hardware_cs_output_enable(SPI3, TRUE);
144
145 spi_i2s_dma_transmitter_enable(SPI2,TRUE);
146 spi_i2s_dma_transmitter_enable(SPI3,TRUE);
147 spi_i2s_dma_receiver_enable(SPI2,TRUE);
148 spi_i2s_dma_receiver_enable(SPI3,TRUE);
149
150 spi_enable(SPI3, TRUE);
151 spi_enable(SPI2, TRUE);
152}
153
159static void gpio_config(void)
160{
161 gpio_init_type gpio_initstructure;
162 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
163 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
164 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
165 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
166 gpio_default_para_init(&gpio_initstructure);
167
168 /* spi3 cs pin */
169 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
170 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
171 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
172 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
173 gpio_initstructure.gpio_pins = GPIO_PINS_15;
174 gpio_init(GPIOA, &gpio_initstructure);
175 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE15, GPIO_MUX_6);
176
177 /* spi3 sck pin */
178 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
179 gpio_initstructure.gpio_pins = GPIO_PINS_3;
180 gpio_init(GPIOB, &gpio_initstructure);
181 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE3, GPIO_MUX_6);
182
183 /* spi3 miso pin */
184 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
185 gpio_initstructure.gpio_pins = GPIO_PINS_13;
186 gpio_init(GPIOA, &gpio_initstructure);
187 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE13, GPIO_MUX_6);
188
189 /* spi3 mosi pin */
190 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
191 gpio_initstructure.gpio_pins = GPIO_PINS_14;
192 gpio_init(GPIOA, &gpio_initstructure);
193 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE14, GPIO_MUX_6);
194
195 /* spi2 cs pin */
196 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
197 gpio_initstructure.gpio_pins = GPIO_PINS_0;
198 gpio_init(GPIOD, &gpio_initstructure);
199 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE0, GPIO_MUX_7);
200
201 /* spi2 sck pin */
202 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
203 gpio_initstructure.gpio_pins = GPIO_PINS_1;
204 gpio_init(GPIOD, &gpio_initstructure);
205 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE1, GPIO_MUX_6);
206
207 /* spi2 miso pin */
208 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
209 gpio_initstructure.gpio_pins = GPIO_PINS_2;
210 gpio_init(GPIOC, &gpio_initstructure);
211 gpio_pin_mux_config(GPIOC, GPIO_PINS_SOURCE2, GPIO_MUX_5);
212
213 /* spi2 mosi pin */
214 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
215 gpio_initstructure.gpio_pins = GPIO_PINS_4;
216 gpio_init(GPIOD, &gpio_initstructure);
217 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_6);
218}
219
225int main(void)
226{
227 __IO uint32_t index = 0;
228 system_clock_config();
229 at32_board_init();
230
231 /* button press:ensure code canbe download normally */
232 while(at32_button_press() == NO_BUTTON);
233
234 gpio_config();
235 spi_config();
236
237 dma_channel_enable(DMA1_CHANNEL1, TRUE);
238 dma_channel_enable(DMA1_CHANNEL2, TRUE);
239
240 dma_channel_enable(DMA1_CHANNEL4, TRUE);
241 dma_channel_enable(DMA1_CHANNEL3, TRUE);
242 while(dma_flag_get(DMA1_FDT2_FLAG) == RESET);
243
244 /* test result:the data check */
245 transfer_status1 = buffer_compare(spi2_buffer_rx, spi3_buffer_tx, BUFFER_SIZE);
246 transfer_status2 = buffer_compare(spi3_buffer_rx, spi2_buffer_tx, BUFFER_SIZE);
247
248 /* test result indicate:if success ,led2 lights */
249 if((transfer_status1 == SUCCESS) && (transfer_status2 == SUCCESS))
250 {
251 at32_led_on(LED2);
252 }
253 else
254 {
255 at32_led_off(LED2);
256 }
257 while(1)
258 {
259 }
260}
261
at32f435_437_board.h
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
spi2_buffer_tx
uint8_t spi2_buffer_tx[32]
Definition: project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:45
spi3_buffer_rx
uint8_t spi3_buffer_rx[32]
Definition: project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:49
buffer_compare
error_status buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t bufferlength)
buffer compare function.
Definition: project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:63
spi2_buffer_rx
uint8_t spi2_buffer_rx[32]
Definition: project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:49
spi_config
static void spi_config(void)
spi configuration.
Definition: project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:83
transfer_status1
volatile error_status transfer_status1
Definition: project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:51
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:38
transfer_status2
volatile error_status transfer_status2
Definition: project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:51
main
int main(void)
main function.
Definition: project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:225
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:40
rx_index
uint32_t rx_index
Definition: project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:50
tx_index
uint32_t tx_index
Definition: project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:50
spi3_buffer_tx
uint8_t spi3_buffer_tx[32]
Definition: project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:41
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f435/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:159
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED2
@ LED2
Definition: at32f435_437_board.h:65
NO_BUTTON
@ NO_BUTTON
Definition: at32f435_437_board.h:99
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f435_437_board.c:194
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_SPI3_PERIPH_CLOCK
@ CRM_SPI3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:139
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:138
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:162
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:172
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_SPI2_TX
@ DMAMUX_DMAREQ_ID_SPI2_TX
Definition: at32f435_437_dma.h:207
DMAMUX_DMAREQ_ID_SPI3_RX
@ DMAMUX_DMAREQ_ID_SPI3_RX
Definition: at32f435_437_dma.h:208
DMAMUX_DMAREQ_ID_SPI2_RX
@ DMAMUX_DMAREQ_ID_SPI2_RX
Definition: at32f435_437_dma.h:206
DMAMUX_DMAREQ_ID_SPI3_TX
@ DMAMUX_DMAREQ_ID_SPI3_TX
Definition: at32f435_437_dma.h:209
DMA1_FDT2_FLAG
#define DMA1_FDT2_FLAG
Definition: at32f435_437_dma.h:70
DMA1MUX_CHANNEL2
#define DMA1MUX_CHANNEL2
Definition: at32f435_437_dma.h:705
DMA1MUX_CHANNEL3
#define DMA1MUX_CHANNEL3
Definition: at32f435_437_dma.h:706
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f435_437_dma.h:698
DMA1MUX_CHANNEL4
#define DMA1MUX_CHANNEL4
Definition: at32f435_437_dma.h:707
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f435_437_dma.h:699
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f435_437_dma.h:697
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f435_437_gpio.h:146
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_6
@ GPIO_MUX_6
Definition: at32f435_437_gpio.h:162
GPIO_MUX_5
@ GPIO_MUX_5
Definition: at32f435_437_gpio.h:161
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f435_437_gpio.h:64
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f435_437_spi.c:533
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f435_437_spi.c:101
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f435_437_spi.c:81
spi_hardware_cs_output_enable
void spi_hardware_cs_output_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the hardware cs output for the spi peripheral.
Definition: at32f435_437_spi.c:258
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f435_437_spi.c:321
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f435_437_spi.c:519
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f435_437_spi.h:99
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f435_437_spi.h:100
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f435_437_spi.h:118
SPI_CS_HARDWARE_MODE
@ SPI_CS_HARDWARE_MODE
Definition: at32f435_437_spi.h:126
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f435_437_spi.h:153
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f435_437_spi.h:108
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f435_437_spi.h:162
SPI_MCLK_DIV_8
@ SPI_MCLK_DIV_8
Definition: at32f435_437_spi.h:138
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f435_437_spi.h:90
SPI3
#define SPI3
Definition: at32f435_437_spi.h:455
SPI2
#define SPI2
Definition: at32f435_437_spi.h:454
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
spi_init_type
spi init type
Definition: at32f435_437_spi.h:259
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f435_437_spi.h:261
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f435_437_spi.h:263
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f435_437_spi.h:264
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:265
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f435_437_spi.h:267
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f435_437_spi.h:262
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f435_437_spi.h:260
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f435_437_spi.h:266
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • spi
  • w25q_flash
  • inc
project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • spi
  • w25q_flash
  • inc
project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • spi
  • w25q_flash
  • inc
project/at_start_f435/examples/spi/w25q_flash/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • spi
  • w25q_flash
  • src
Functions
project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • spi
  • w25q_flash
  • src
project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • spi
  • w25q_flash
  • src
Functions
project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • spi
  • w25q_flash
  • src
project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/spi/w25q_flash/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • spi
  • w25q_flash
  • src
Macros | Functions | Variables
project/at_start_f435/examples/spi/w25q_flash/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include "spi_flash.h"

Go to the source code of this file.

Macros

#define | FLASH_TEST_ADDR 0x1000
#define | BUF_SIZE 0x256

Functions

void | tx_data_fill (void)
transfer data fill. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

uint8_t | buffer_tx [0x256]
uint8_t | buffer_rx [0x256]
volatile error_status | transfer_status = ERROR

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/spi/w25q_flash/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • spi
  • w25q_flash
  • src
project/at_start_f435/examples/spi/w25q_flash/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include "spi_flash.h"
30
39#define FLASH_TEST_ADDR 0x1000
40#define BUF_SIZE 0x256
41
42uint8_t buffer_tx[BUF_SIZE];
43uint8_t buffer_rx[BUF_SIZE];
44volatile error_status transfer_status = ERROR;
45
46void tx_data_fill(void);
47 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length);
48
54void tx_data_fill(void)
55{
56 uint32_t data_index = 0;
57 for(data_index = 0; data_index < BUF_SIZE; data_index++)
58 {
59 buffer_tx[data_index] = data_index;
60 }
61}
62
69 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
70{
71 while(buffer_length--)
72 {
73 if(*pbuffer1 != *pbuffer2)
74 {
75 return ERROR;
76 }
77
78 pbuffer1++;
79 pbuffer2++;
80 }
81 return SUCCESS;
82}
83
89int main(void)
90{
91 __IO uint32_t index = 0;
92 __IO uint32_t flash_id_index = 0;
93 system_clock_config();
94 at32_board_init();
95 tx_data_fill();
96 uart_print_init(115200);
97 spiflash_init();
98 flash_id_index = spiflash_read_id();
99 if((flash_id_index != W25Q128)&&(flash_id_index != W25Q80)&&(flash_id_index != W25Q16)&&(flash_id_index != W25Q32)&&(flash_id_index != W25Q64))
100 {
101 printf("flash id check error!\r\n");
102 for(index = 0; index < 50; index++)
103 {
104 at32_led_toggle(LED2);
105 at32_led_toggle(LED3);
106 delay_ms(200);
107 }
108 return 1;
109 }
110 else
111 {
112 printf("flash id check success! id: %x\r\n", flash_id_index);
113 }
114
115 /* erase sector */
116 spiflash_sector_erase(FLASH_TEST_ADDR / SPIF_SECTOR_SIZE);
117
118 /* write data */
119 spiflash_write(buffer_tx, FLASH_TEST_ADDR, BUF_SIZE);
120
121 /* read data */
122 spiflash_read(buffer_rx, FLASH_TEST_ADDR, BUF_SIZE);
123
124 /* printf read data */
125 printf("Read Data: ");
126 for(index = 0; index < BUF_SIZE; index++)
127 {
128 printf("%x ", buffer_rx[index]);
129 }
130
131 /* test result:the data check */
132 transfer_status = buffer_compare(buffer_rx, buffer_tx, BUF_SIZE);
133
134 /* test result indicate:if success ,led2 lights */
135 if(transfer_status == SUCCESS)
136 {
137 printf("\r\nflash data read write success!\r\n");
138 at32_led_on(LED2);
139 }
140 else
141 {
142 printf("\r\nflash data read write ERROR!\r\n");
143 at32_led_off(LED2);
144 }
145
146 while(1)
147 {
148 }
149}
150
at32f435_437_board.h
buffer_compare
error_status buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function.
Definition: project/at_start_f435/examples/spi/w25q_flash/src/main.c:69
buffer_rx
uint8_t buffer_rx[0x256]
Definition: project/at_start_f435/examples/spi/w25q_flash/src/main.c:43
FLASH_TEST_ADDR
#define FLASH_TEST_ADDR
Definition: project/at_start_f435/examples/spi/w25q_flash/src/main.c:39
buffer_tx
uint8_t buffer_tx[0x256]
Definition: project/at_start_f435/examples/spi/w25q_flash/src/main.c:42
BUF_SIZE
#define BUF_SIZE
Definition: project/at_start_f435/examples/spi/w25q_flash/src/main.c:40
main
int main(void)
main function.
Definition: project/at_start_f435/examples/spi/w25q_flash/src/main.c:89
tx_data_fill
void tx_data_fill(void)
transfer data fill.
Definition: project/at_start_f435/examples/spi/w25q_flash/src/main.c:54
transfer_status
volatile error_status transfer_status
Definition: project/at_start_f435/examples/spi/w25q_flash/src/main.c:44
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
spiflash_init
void spiflash_init(void)
spi configuration.
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:45
spiflash_write
void spiflash_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:103
spiflash_sector_erase
void spiflash_sector_erase(uint32_t erase_addr)
erase a sector data
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:207
spiflash_read
void spiflash_read(uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:191
spiflash_read_id
uint16_t spiflash_read_id(void)
read device id
Definition: at_start_f437/examples/spi/w25q_flash/src/spi_flash.c:478
W25Q128
#define W25Q128
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:67
W25Q16
#define W25Q16
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:63
W25Q32
#define W25Q32
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:64
W25Q80
#define W25Q80
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:62
W25Q64
#define W25Q64
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:65
SPIF_SECTOR_SIZE
#define SPIF_SECTOR_SIZE
Definition: at_start_f435/examples/spi/w25q_flash/inc/spi_flash.h:78
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • sram
  • extend_sram
  • inc
project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • sram
  • extend_sram
  • inc
project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • sram
  • extend_sram
  • inc
project/at_start_f435/examples/sram/extend_sram/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • sram
  • extend_sram
  • src
Functions
project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • sram
  • extend_sram
  • src
project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • sram
  • extend_sram
  • src
Functions
project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • sram
  • extend_sram
  • src
project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/sram/extend_sram/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • sram
  • extend_sram
  • src
Functions
project/at_start_f435/examples/sram/extend_sram/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | extend_sram (void)
to extend sram size More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/sram/extend_sram/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • sram
  • extend_sram
  • src
project/at_start_f435/examples/sram/extend_sram/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34void extend_sram(void);
35
36#ifdef __cplusplus
37}
38#endif
39
53void extend_sram(void)
54{
55 /* check if ram has been set to expectant size, if not, change eopb0 */
56 if(((USD->eopb0) & 0x07) != EXTEND_SRAM)
57 {
58 flash_unlock();
59 /* erase user system data bytes */
60 flash_user_system_data_erase();
61
62 /* change sram size */
63 flash_eopb0_config(EXTEND_SRAM);
64
65 /* system reset */
66 nvic_system_reset();
67 }
68}
69
75int main(void)
76{
77 system_clock_config();
78 at32_board_init();
79
80 /* check eopb0 */
81 if(((USD->eopb0) & 0x07) == EXTEND_SRAM)
82 {
83 at32_led_on(LED4);
84 }
85
86 while(1)
87 {
88 }
89}
90
at32f435_437_board.h
main
int main(void)
main function.
Definition: project/at_start_f435/examples/sram/extend_sram/src/main.c:75
extend_sram
void extend_sram(void)
to extend sram size
Definition: project/at_start_f435/examples/sram/extend_sram/src/main.c:53
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f435_437_flash.c:290
flash_eopb0_config
flash_status_type flash_eopb0_config(flash_usd_eopb0_type data)
config the extend sram byte eopb0 in user system data.
Definition: at32f435_437_flash.c:576
flash_user_system_data_erase
flash_status_type flash_user_system_data_erase(void)
erase the flash user system data.
Definition: at32f435_437_flash.c:516
USD
#define USD
Definition: at32f435_437_flash.h:659
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f435_437_misc.c:52
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • cascade_synchro
  • inc
project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • cascade_synchro
  • inc
project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • cascade_synchro
  • inc
project/at_start_f435/examples/tmr/cascade_synchro/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • cascade_synchro
  • src
Functions
project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • cascade_synchro
  • src
project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • cascade_synchro
  • src
Functions
project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • cascade_synchro
  • src
project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133 /* trigger TMR1 hall event */
134 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
135}
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/cascade_synchro/src/at32f435_437_int.c:113
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f435_437_tmr.c:1486
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f435_437_tmr.h:290
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • cascade_synchro
  • src
Functions | Variables
project/at_start_f435/examples/tmr/cascade_synchro/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timerperiod = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/cascade_synchro/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • cascade_synchro
  • src
project/at_start_f435/examples/tmr/cascade_synchro/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 tmr_output_config_type tmr_output_struct;
40 crm_clocks_freq_type crm_clocks_freq_struct = {0};
41
42uint16_t timerperiod = 0;
43
49int main(void)
50{
51 system_clock_config();
52
53 /* get system clock */
54 crm_clocks_freq_get(&crm_clocks_freq_struct);
55
56 at32_board_init();
57
58 /* turn led2/led3/led4 on */
59 at32_led_on(LED2);
60 at32_led_on(LED3);
61 at32_led_on(LED4);
62
63 /* enable tmr2/tmr3/tmr4/gpioa/gpiob clock */
64 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
65 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_TMR4_PERIPH_CLOCK, TRUE);
67 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
68 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
69
70 /* timer1 output pin Configuration */
71 gpio_init_struct.gpio_pins = GPIO_PINS_6 | GPIO_PINS_0;
72 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
73 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
74 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
75 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
76 gpio_init(GPIOA, &gpio_init_struct);
77
78 gpio_init_struct.gpio_pins = GPIO_PINS_6;
79 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
80 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
81 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
82 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
83 gpio_init(GPIOB, &gpio_init_struct);
84
85 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE0, GPIO_MUX_1);
86 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE6, GPIO_MUX_2);
87 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE6, GPIO_MUX_2);
88
89
90 /* timers synchronisation in cascade mode ----------------------------
91 1/tmr2 is configured as primary timer:
92 - pwm mode is used
93 - the tmr2 update event is used as trigger output
94
95 2/tmr3 is sub for tmr2 and primary for tmr4,
96 - pwm mode is used
97 - the itr1(tmr2) is used as input trigger
98 - gated mode is used, so start and stop of sub counter
99 are controlled by the master trigger output signal(tmr2 update event).
100 - the tmr3 update event is used as trigger output.
101
102 3/tmr4 is slave for tmr3,
103 - pwm mode is used
104 - the itr2(tmr3) is used as input trigger
105 - gated mode is used, so start and stop of sub counter
106 are controlled by the master trigger output signal(tmr3 overflow event).
107
108 the primary timer tmr2 is running at tmr2 frequency :
109 tim2 frequency = (tmr2 counter clock)/ (tmr2 period + 1) = 1 mhz
110 and the duty cycle = tmr2_ccr1/(tmr2_arr + 1) = 50%.
111
112 the tmr3 is running at:
113 (tmr2 frequency)/ (tmr3 period + 1) = 100 khz and a duty cycle equal
114 to tmr3_ccr1/(tmr3_arr + 1) = 50%
115
116 the tmr4 is running at:
117 (tmr3 frequency)/ (tmr4 period + 1) = 10 khz and a duty cycle equal
118 to tmr4_ccr1/(tmr4_arr + 1) = 50%
119 -------------------------------------------------------------------- */
120
121 timerperiod = ((crm_clocks_freq_struct.apb1_freq * 2) / 1000000) - 1;
122
123 tmr_base_init(TMR2, timerperiod, 0);
124 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
125
126 tmr_base_init(TMR3, 9, 0);
127 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
128
129 tmr_base_init(TMR4, 9, 0);
130 tmr_cnt_dir_set(TMR4, TMR_COUNT_UP);
131
132 /* channelx Configuration in output mode */
133 tmr_output_default_para_init(&tmr_output_struct);
134 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
135 tmr_output_struct.oc_output_state = TRUE;
136 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
137 tmr_output_struct.oc_idle_state = TRUE;
138 tmr_output_struct.occ_output_state = FALSE;
139 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_HIGH;
140 tmr_output_struct.occ_idle_state = FALSE;
141 /* timer2 channel 1 */
142 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
143 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_1, timerperiod/2);
144
145 /* timer2 select enable signal to sub timer */
146 tmr_primary_mode_select(TMR2, TMR_PRIMARY_SEL_OVERFLOW);
147 tmr_sub_sync_mode_set(TMR2, TRUE);
148
149 /* timer3 channel 1 */
150 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
151 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_1, 5);
152
153 /* sub mode selection: tmr3 */
154 tmr_sub_mode_select(TMR3, TMR_SUB_HANG_MODE);
155 tmr_trigger_input_select(TMR3, TMR_SUB_INPUT_SEL_IS1);
156
157 /* timer3 select enable signal to sub timer */
158 tmr_primary_mode_select(TMR3, TMR_PRIMARY_SEL_OVERFLOW);
159 tmr_sub_sync_mode_set(TMR3, TRUE);
160
161 /* timer4 channel 1 */
162 tmr_output_channel_config(TMR4, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
163 tmr_channel_value_set(TMR4, TMR_SELECT_CHANNEL_1, 5);
164
165 /* sub mode selection: tmr4 */
166 tmr_sub_mode_select(TMR4, TMR_SUB_HANG_MODE);
167 tmr_trigger_input_select(TMR4, TMR_SUB_INPUT_SEL_IS2);
168
169 /* enable tmr2/tmr3/tmr4 */
170 tmr_counter_enable(TMR2, TRUE);
171 tmr_counter_enable(TMR3, TRUE);
172 tmr_counter_enable(TMR4, TRUE);
173
174 while(1)
175 {}
176}
177
at32f435_437_board.h
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/tmr/cascade_synchro/src/main.c:38
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f435/examples/tmr/cascade_synchro/src/main.c:39
timerperiod
uint16_t timerperiod
Definition: project/at_start_f435/examples/tmr/cascade_synchro/src/main.c:42
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/cascade_synchro/src/main.c:49
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/tmr/cascade_synchro/src/main.c:40
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:128
CRM_TMR4_PERIPH_CLOCK
@ CRM_TMR4_PERIPH_CLOCK
Definition: at32f435_437_crm.h:130
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:129
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_2
@ GPIO_MUX_2
Definition: at32f435_437_gpio.h:158
GPIO_MUX_1
@ GPIO_MUX_1
Definition: at32f435_437_gpio.h:157
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f435_437_tmr.c:1245
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_sub_sync_mode_set
void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode
Definition: at32f435_437_tmr.c:1335
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f435_437_tmr.c:1322
tmr_primary_mode_select
void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode
Definition: at32f435_437_tmr.c:1222
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f435_437_tmr.h:180
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:198
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f435_437_tmr.h:199
TMR_SUB_INPUT_SEL_IS2
@ TMR_SUB_INPUT_SEL_IS2
Definition: at32f435_437_tmr.h:136
TMR_SUB_INPUT_SEL_IS1
@ TMR_SUB_INPUT_SEL_IS1
Definition: at32f435_437_tmr.h:135
TMR_SUB_HANG_MODE
@ TMR_SUB_HANG_MODE
Definition: at32f435_437_tmr.h:154
TMR_PRIMARY_SEL_OVERFLOW
@ TMR_PRIMARY_SEL_OVERFLOW
Definition: at32f435_437_tmr.h:121
TMR3
#define TMR3
Definition: at32f435_437_tmr.h:897
TMR2
#define TMR2
Definition: at32f435_437_tmr.h:896
TMR4
#define TMR4
Definition: at32f435_437_tmr.h:898
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f435_437_crm.h:792
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f435_437_tmr.h:418
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f435_437_tmr.h:416
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f435_437_tmr.h:414
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • complementary_signals
  • inc
project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • complementary_signals
  • inc
project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • complementary_signals
  • inc
project/at_start_f435/examples/tmr/complementary_signals/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • complementary_signals
  • src
Functions
project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • complementary_signals
  • src
project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • complementary_signals
  • src
Functions
project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • complementary_signals
  • src
project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133 /* trigger TMR1 hall event */
134 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
135}
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/complementary_signals/src/at32f435_437_int.c:113
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f435_437_tmr.c:1486
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f435_437_tmr.h:290
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • complementary_signals
  • src
Functions | Variables
project/at_start_f435/examples/tmr/complementary_signals/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_brkdt_config_type | tmr_brkdt_config_struct = {0}
uint16_t | timerperiod = 0
uint16_t | channel1pulse = 0
uint16_t | channel2pulse = 0
uint16_t | channel3pulse = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/complementary_signals/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • complementary_signals
  • src
project/at_start_f435/examples/tmr/complementary_signals/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 tmr_output_config_type tmr_output_struct;
40 crm_clocks_freq_type crm_clocks_freq_struct = {0};
41 tmr_brkdt_config_type tmr_brkdt_config_struct = {0};
42
43uint16_t timerperiod = 0;
44uint16_t channel1pulse = 0, channel2pulse = 0, channel3pulse = 0;
45
51int main(void)
52{
53 system_clock_config();
54
55 at32_board_init();
56
57 /* get system clock */
58 crm_clocks_freq_get(&crm_clocks_freq_struct);
59
60 /* turn led2/led3/led4 on */
61 at32_led_on(LED2);
62 at32_led_on(LED3);
63 at32_led_on(LED4);
64
65 /* enable tmr1/gpioa/gpiob clock */
66 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
67 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
68 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
69
70 /* timer1 output pin configuration */
71 gpio_init_struct.gpio_pins = GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10;
72 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
73 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
74 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
75 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
76 gpio_init(GPIOA, &gpio_init_struct);
77
78 gpio_init_struct.gpio_pins = GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
79 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
80 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
81 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
82 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
83 gpio_init(GPIOB, &gpio_init_struct);
84
85 gpio_init_struct.gpio_pins = GPIO_PINS_12;
86 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
87 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
88 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
89 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
90 gpio_init(GPIOB, &gpio_init_struct);
91
92 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE8, GPIO_MUX_1);
93 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE9, GPIO_MUX_1);
94 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE10, GPIO_MUX_1);
95 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE13, GPIO_MUX_1);
96 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE14, GPIO_MUX_1);
97 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE15, GPIO_MUX_1);
98 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE12, GPIO_MUX_1);
99
100 /* -----------------------------------------------------------------------
101 tmr1 configuration to:
102
103 1/ generate 3 complementary pwm signals with 3 different duty cycles:
104 tmr1clk is fixed to apb2_freq*2, the tmr1 prescaler is equal to 0 so the
105 tmr1 counter clock used is apb2_freq*2.
106
107 the objective is to generate pwm signal at 17.57 khz:
108 - tmr1_period = (apb2_freq*2 / 17570) - 1
109
110 the three duty cycles are computed as the following description:
111
112 the channel 1 duty cycle is set to 50% so channel 1n is set to 50%.
113 the channel 2 duty cycle is set to 25% so channel 2n is set to 75%.
114 the channel 3 duty cycle is set to 12.5% so channel 3n is set to 87.5%.
115 the timer pulse is calculated as follows:
116 - channelxpulse = dutycycle * (tmr1_period - 1) / 100
117
118 2/ insert a dead time equal to 11/apb2_freq*2 ns
119 3/ configure the break feature, active at high level, and using the automatic
120 output enable feature
121 4/ use the locking parameters level1.
122 ----------------------------------------------------------------------- */
123 /* compute the value to be set in arr regiter to generate signal frequency at 17.57 khz */
124 timerperiod = ((crm_clocks_freq_struct.apb2_freq * 2) / 17570 ) - 1;
125 /* compute ccr1 value to generate a duty cycle at 50% for channel 1 and 1n */
126 channel1pulse = (uint16_t) (((uint32_t) 5 * (timerperiod - 1)) / 10);
127 /* compute ccr2 value to generate a duty cycle at 25% for channel 2 and 2n */
128 channel2pulse = (uint16_t) (((uint32_t) 25 * (timerperiod - 1)) / 100);
129 /* compute ccr3 value to generate a duty cycle at 12.5% for channel 3 and 3n */
130 channel3pulse = (uint16_t) (((uint32_t) 125 * (timerperiod - 1)) / 1000);
131
132 tmr_base_init(TMR1, timerperiod, 0);
133 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
134
135 /* channel 1, 2, 3 and 4 Configuration in output mode */
136 tmr_output_default_para_init(&tmr_output_struct);
137 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_B;
138 tmr_output_struct.oc_output_state = TRUE;
139 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
140 tmr_output_struct.oc_idle_state = TRUE;
141 tmr_output_struct.occ_output_state = TRUE;
142 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_LOW;
143 tmr_output_struct.occ_idle_state = FALSE;
144 /* channel 1 */
145 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
146 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, channel1pulse);
147 /* channel 2 */
148 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_2, &tmr_output_struct);
149 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_2, channel2pulse);
150 /* channel 3 */
151 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_3, &tmr_output_struct);
152 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_3, channel3pulse);
153
154 /* automatic output enable, stop, dead time and lock configuration*/
155 tmr_brkdt_default_para_init(&tmr_brkdt_config_struct);
156 tmr_brkdt_config_struct.brk_enable = TRUE;
157 tmr_brkdt_config_struct.auto_output_enable = TRUE;
158 tmr_brkdt_config_struct.deadtime = 11;
159 tmr_brkdt_config_struct.fcsodis_state = TRUE;
160 tmr_brkdt_config_struct.fcsoen_state = TRUE;
161 tmr_brkdt_config_struct.brk_polarity = TMR_BRK_INPUT_ACTIVE_HIGH;
162 tmr_brkdt_config_struct.wp_level = TMR_WP_LEVEL_3;
163 tmr_brkdt_config(TMR1, &tmr_brkdt_config_struct);
164
165 /* tmr1 output enable */
166 tmr_output_enable(TMR1, TRUE);
167 /* enable tmr1 */
168 tmr_counter_enable(TMR1, TRUE);
169
170 while(1)
171 {}
172}
173
at32f435_437_board.h
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/tmr/complementary_signals/src/main.c:38
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f435/examples/tmr/complementary_signals/src/main.c:39
channel1pulse
uint16_t channel1pulse
Definition: project/at_start_f435/examples/tmr/complementary_signals/src/main.c:44
timerperiod
uint16_t timerperiod
Definition: project/at_start_f435/examples/tmr/complementary_signals/src/main.c:43
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/complementary_signals/src/main.c:51
channel2pulse
uint16_t channel2pulse
Definition: project/at_start_f435/examples/tmr/complementary_signals/src/main.c:44
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/tmr/complementary_signals/src/main.c:40
channel3pulse
uint16_t channel3pulse
Definition: project/at_start_f435/examples/tmr/complementary_signals/src/main.c:44
tmr_brkdt_config_struct
tmr_brkdt_config_type tmr_brkdt_config_struct
Definition: project/at_start_f435/examples/tmr/complementary_signals/src/main.c:41
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:154
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f435_437_gpio.h:146
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_1
@ GPIO_MUX_1
Definition: at32f435_437_gpio.h:157
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f435_437_gpio.h:64
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_brkdt_default_para_init
void tmr_brkdt_default_para_init(tmr_brkdt_config_type *tmr_brkdt_struct)
init tmr brkdt default para
Definition: at32f435_437_tmr.c:183
tmr_brkdt_config
void tmr_brkdt_config(tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
config tmr break mode and dead-time
Definition: at32f435_437_tmr.c:1801
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f435_437_tmr.c:1499
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f435_437_tmr.h:221
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f435_437_tmr.h:219
TMR_WP_LEVEL_3
@ TMR_WP_LEVEL_3
Definition: at32f435_437_tmr.h:391
TMR_BRK_INPUT_ACTIVE_HIGH
@ TMR_BRK_INPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:382
TMR_OUTPUT_CONTROL_PWM_MODE_B
@ TMR_OUTPUT_CONTROL_PWM_MODE_B
Definition: at32f435_437_tmr.h:181
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f435_437_tmr.h:199
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::apb2_freq
uint32_t apb2_freq
Definition: at32f435_437_crm.h:791
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_brkdt_config_type
tmr brkdt config type
Definition: at32f435_437_tmr.h:436
tmr_brkdt_config_type::brk_enable
confirm_state brk_enable
Definition: at32f435_437_tmr.h:443
tmr_brkdt_config_type::deadtime
uint8_t deadtime
Definition: at32f435_437_tmr.h:437
tmr_brkdt_config_type::auto_output_enable
confirm_state auto_output_enable
Definition: at32f435_437_tmr.h:440
tmr_brkdt_config_type::wp_level
tmr_wp_level_type wp_level
Definition: at32f435_437_tmr.h:439
tmr_brkdt_config_type::fcsoen_state
confirm_state fcsoen_state
Definition: at32f435_437_tmr.h:441
tmr_brkdt_config_type::fcsodis_state
confirm_state fcsodis_state
Definition: at32f435_437_tmr.h:442
tmr_brkdt_config_type::brk_polarity
tmr_brk_polarity_type brk_polarity
Definition: at32f435_437_tmr.h:438
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f435_437_tmr.h:418
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f435_437_tmr.h:416
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f435_437_tmr.h:414
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • dma
  • inc
project/at_start_f435/examples/tmr/dma/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • dma
  • inc
project/at_start_f435/examples/tmr/dma/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • dma
  • inc
project/at_start_f435/examples/tmr/dma/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • dma
  • src
Functions
project/at_start_f435/examples/tmr/dma/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/dma/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • dma
  • src
project/at_start_f435/examples/tmr/dma/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/dma/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • dma
  • src
Functions
project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • dma
  • src
project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133 /* trigger TMR1 hall event */
134 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
135}
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/dma/src/at32f435_437_int.c:113
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f435_437_tmr.c:1486
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f435_437_tmr.h:290
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • dma
  • src
Functions | Variables
project/at_start_f435/examples/tmr/dma/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
dma_init_type dma_init_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timerperiod = 0
uint16_t | src_buffer [3] = {0, 0, 0}

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/dma/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • dma
  • src
project/at_start_f435/examples/tmr/dma/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 tmr_output_config_type tmr_output_struct;
40 dma_init_type dma_init_struct;
41 crm_clocks_freq_type crm_clocks_freq_struct = {0};
42
43uint16_t timerperiod = 0;
44uint16_t src_buffer[3] = {0, 0, 0};
45
51int main(void)
52{
53 system_clock_config();
54
55 at32_board_init();
56
57 /* get system clock */
58 crm_clocks_freq_get(&crm_clocks_freq_struct);
59
60 /* turn led2/led3/led4 on */
61 at32_led_on(LED2);
62 at32_led_on(LED3);
63 at32_led_on(LED4);
64
65 /* enable tmr1/gpioa/gpiob/dma clock */
66 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
67 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
68 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
69 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
70
71 /* timer1 output pin Configuration */
72 gpio_init_struct.gpio_pins = GPIO_PINS_10;
73 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
74 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
75 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
76 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
77 gpio_init(GPIOA, &gpio_init_struct);
78
79 gpio_init_struct.gpio_pins = GPIO_PINS_15;
80 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
81 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
82 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
83 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
84 gpio_init(GPIOB, &gpio_init_struct);
85
86 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE10, GPIO_MUX_1);
87 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE15, GPIO_MUX_1);
88
89 /* tmr1 dma transfer example -------------------------------------------------
90 tmr1clk = apb2_freq*2, prescaler = 0, tmr1 counter clock = apb2_freq*2
91
92 the objective is to configure tmr1 channel 3 to generate complementary pwm
93 signal with a frequency equal to 17.57 khz:
94 - tmr1_period = (apb2_freq * 2 / 17570) - 1
95 and a variable duty cycle that is changed by the dma after a specific number of
96 update dma request.
97
98 the number of this repetitive requests is defined by the tmr1 repetition counter,
99 each 3 update requests, the tmr1 channel 3 duty cycle changes to the next new
100 value defined by the src_buffer .
101 -----------------------------------------------------------------------------*/
102 /* compute the value to be set in arr regiter to generate signal frequency at 17.57 khz */
103 timerperiod = ((crm_clocks_freq_struct.apb2_freq * 2) / 17570 ) - 1;
104 /* compute c1dt value to generate a duty cycle at 50% */
105 src_buffer[0] = (uint16_t) (((uint32_t) 5 * (timerperiod - 1)) / 10);
106 /* compute c1dt value to generate a duty cycle at 37.5% */
107 src_buffer[1] = (uint16_t) (((uint32_t) 375 * (timerperiod - 1)) / 1000);
108 /* compute c1dt value to generate a duty cycle at 25% */
109 src_buffer[2] = (uint16_t) (((uint32_t) 25 * (timerperiod - 1)) / 100);
110
111 tmr_base_init(TMR1, timerperiod, 0);
112 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
113
114 /* channel 3 configuration in output mode */
115 tmr_output_default_para_init(&tmr_output_struct);
116 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_B;
117 tmr_output_struct.oc_output_state = TRUE;
118 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
119 tmr_output_struct.oc_idle_state = TRUE;
120 tmr_output_struct.occ_output_state = TRUE;
121 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_LOW;
122 tmr_output_struct.occ_idle_state = FALSE;
123 /* channel 3 */
124 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_3, &tmr_output_struct);
125 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_3, src_buffer[0]);
126
127 /* enable tmr1 overflow dma request */
128 tmr_dma_request_enable(TMR1, TMR_OVERFLOW_DMA_REQUEST, TRUE);
129
130 /* dma config for tmr1 overflow dma request */
131 /* dma1 channel5 configuration */
132 dma_reset(DMA1_CHANNEL1);
133 dma_init_struct.buffer_size = 3;
134 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
135 dma_init_struct.memory_base_addr = (uint32_t)src_buffer;
136 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
137 dma_init_struct.memory_inc_enable = TRUE;
138 dma_init_struct.peripheral_base_addr = (uint32_t)0x4001003C;
139 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
140 dma_init_struct.peripheral_inc_enable = FALSE;
141 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
142 dma_init_struct.loop_mode_enable = TRUE;
143 dma_init(DMA1_CHANNEL1, &dma_init_struct);
144
145 dmamux_enable(DMA1, TRUE);
146 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_TMR1_OVERFLOW);
147 dma_channel_enable(DMA1_CHANNEL1, TRUE);
148
149 /* tmr1 output enable */
150 tmr_output_enable(TMR1, TRUE);
151 /* enable tmr1 */
152 tmr_counter_enable(TMR1, TRUE);
153
154 while(1)
155 {}
156}
157
at32f435_437_board.h
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/tmr/dma/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/tmr/dma/src/main.c:40
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f435/examples/tmr/dma/src/main.c:39
src_buffer
uint16_t src_buffer[3]
Definition: project/at_start_f435/examples/tmr/dma/src/main.c:44
timerperiod
uint16_t timerperiod
Definition: project/at_start_f435/examples/tmr/dma/src/main.c:43
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/dma/src/main.c:51
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/tmr/dma/src/main.c:41
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:154
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f435_437_dma.h:183
DMAMUX_DMAREQ_ID_TMR1_OVERFLOW
@ DMAMUX_DMAREQ_ID_TMR1_OVERFLOW
Definition: at32f435_437_dma.h:246
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_1
@ GPIO_MUX_1
Definition: at32f435_437_gpio.h:157
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
tmr_dma_request_enable
void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request
Definition: at32f435_437_tmr.c:1358
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f435_437_tmr.c:1499
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_OVERFLOW_DMA_REQUEST
@ TMR_OVERFLOW_DMA_REQUEST
Definition: at32f435_437_tmr.h:271
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f435_437_tmr.h:221
TMR_OUTPUT_CONTROL_PWM_MODE_B
@ TMR_OUTPUT_CONTROL_PWM_MODE_B
Definition: at32f435_437_tmr.h:181
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f435_437_tmr.h:199
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::apb2_freq
uint32_t apb2_freq
Definition: at32f435_437_crm.h:791
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f435_437_tmr.h:418
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f435_437_tmr.h:416
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f435_437_tmr.h:414
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • dma_burst
  • inc
project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • dma_burst
  • inc
project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • dma_burst
  • inc
project/at_start_f435/examples/tmr/dma_burst/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • dma_burst
  • src
Functions
project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • dma_burst
  • src
project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • dma_burst
  • src
Functions
project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • dma_burst
  • src
project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133 /* trigger TMR1 hall event */
134 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
135}
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/dma_burst/src/at32f435_437_int.c:113
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f435_437_tmr.c:1486
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f435_437_tmr.h:290
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • dma_burst
  • src
Functions | Variables
project/at_start_f435/examples/tmr/dma_burst/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
dma_init_type dma_init_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timerperiod = 0
uint16_t | src_buffer [3] = {0x0FFF, 0x0000, 0x0555}

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/dma_burst/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • dma_burst
  • src
project/at_start_f435/examples/tmr/dma_burst/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 tmr_output_config_type tmr_output_struct;
40 dma_init_type dma_init_struct;
41 crm_clocks_freq_type crm_clocks_freq_struct = {0};
42
43uint16_t timerperiod = 0;
44uint16_t src_buffer[3] = {0x0FFF, 0x0000, 0x0555};
45
51int main(void)
52{
53 system_clock_config();
54
55 at32_board_init();
56
57 /* get system clock */
58 crm_clocks_freq_get(&crm_clocks_freq_struct);
59
60 /* turn led2/led3/led4 on */
61 at32_led_on(LED2);
62 at32_led_on(LED3);
63 at32_led_on(LED4);
64
65 /* enable tmr1/gpioa/gpiob/dma clock */
66 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
67 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
68 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
69 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
70
71 /* timer1 output pin Configuration */
72 gpio_init_struct.gpio_pins = GPIO_PINS_8;
73 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
74 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
75 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
76 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
77 gpio_init(GPIOA, &gpio_init_struct);
78
79 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE8, GPIO_MUX_1);
80
81 /* -----------------------------------------------------------------------
82 tmr1 configuration: generate 1 pwm signal using the dma burst mode:
83 the tmr1clk frequency is set to apb2_freq * 2 (hz), to get tmr1 counter
84 clock at 24 mhz the prescaler is computed as following:
85 - prescaler = (tim1clk / tmr1 counter clock) - 1
86 the tmr1 period is 5.86 khz: tmr1 frequency = tmr1 counter clock/(arr + 1)
87 = 288mhz / 4096 = 70.31khz
88 tmr1 channel1 duty cycle = (tim1_ccr1/ tmr1_arr)* 100 = 33.33%
89 ----------------------------------------------------------------------- */
90
91 tmr_base_init(TMR1, 0xFFFF, 0);
92 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
93
94 /* channel 3 configuration in output mode */
95 tmr_output_default_para_init(&tmr_output_struct);
96 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_B;
97 tmr_output_struct.oc_output_state = TRUE;
98 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
99 tmr_output_struct.oc_idle_state = TRUE;
100 tmr_output_struct.occ_output_state = FALSE;
101 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_LOW;
102 tmr_output_struct.occ_idle_state = FALSE;
103 /* channel 3 */
104 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
105 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, 0xFFF);
106
107 /* enable tmr1 overflow dma request */
108 tmr_dma_request_enable(TMR1, TMR_OVERFLOW_DMA_REQUEST, TRUE);
109 tmr_dma_control_config(TMR1, TMR_DMA_TRANSFER_3BYTES, TMR_PR_ADDRESS);
110
111 /* dma config for tmr1 overflow dma request */
112 /* dma1 channel5 configuration */
113 dma_reset(DMA1_CHANNEL1);
114 dma_init_struct.buffer_size = 3;
115 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
116 dma_init_struct.memory_base_addr = (uint32_t)src_buffer;
117 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
118 dma_init_struct.memory_inc_enable = TRUE;
119 dma_init_struct.peripheral_base_addr = (uint32_t)0x4001004C;
120 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
121 dma_init_struct.peripheral_inc_enable = FALSE;
122 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
123 dma_init_struct.loop_mode_enable = FALSE;
124 dma_init(DMA1_CHANNEL1, &dma_init_struct);
125
126 dmamux_enable(DMA1, TRUE);
127 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_TMR1_OVERFLOW);
128 dma_channel_enable(DMA1_CHANNEL1, TRUE);
129
130 /* tmr1 output enable */
131 tmr_output_enable(TMR1, TRUE);
132 /* enable tmr1 */
133 tmr_counter_enable(TMR1, TRUE);
134
135 while(1)
136 {}
137}
138
at32f435_437_board.h
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/tmr/dma_burst/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/tmr/dma_burst/src/main.c:40
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f435/examples/tmr/dma_burst/src/main.c:39
src_buffer
uint16_t src_buffer[3]
Definition: project/at_start_f435/examples/tmr/dma_burst/src/main.c:44
timerperiod
uint16_t timerperiod
Definition: project/at_start_f435/examples/tmr/dma_burst/src/main.c:43
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/dma_burst/src/main.c:51
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/tmr/dma_burst/src/main.c:41
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:154
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f435_437_dma.h:183
DMAMUX_DMAREQ_ID_TMR1_OVERFLOW
@ DMAMUX_DMAREQ_ID_TMR1_OVERFLOW
Definition: at32f435_437_dma.h:246
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_1
@ GPIO_MUX_1
Definition: at32f435_437_gpio.h:157
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
tmr_dma_control_config
void tmr_dma_control_config(tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, tmr_dma_address_type dma_base_address)
config tmr dma control
Definition: at32f435_437_tmr.c:1785
tmr_dma_request_enable
void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request
Definition: at32f435_437_tmr.c:1358
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f435_437_tmr.c:1499
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_OVERFLOW_DMA_REQUEST
@ TMR_OVERFLOW_DMA_REQUEST
Definition: at32f435_437_tmr.h:271
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_PR_ADDRESS
@ TMR_PR_ADDRESS
Definition: at32f435_437_tmr.h:366
TMR_OUTPUT_CONTROL_PWM_MODE_B
@ TMR_OUTPUT_CONTROL_PWM_MODE_B
Definition: at32f435_437_tmr.h:181
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f435_437_tmr.h:199
TMR_DMA_TRANSFER_3BYTES
@ TMR_DMA_TRANSFER_3BYTES
Definition: at32f435_437_tmr.h:332
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f435_437_tmr.h:418
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f435_437_tmr.h:416
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f435_437_tmr.h:414
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • encoder_tmr2
  • inc
project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • encoder_tmr2
  • inc
project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • encoder_tmr2
  • inc
project/at_start_f435/examples/tmr/encoder_tmr2/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • encoder_tmr2
  • src
Functions
project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • encoder_tmr2
  • src
project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • encoder_tmr2
  • src
Functions
project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • encoder_tmr2
  • src
project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133 /* trigger TMR1 hall event */
134 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
135}
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/encoder_tmr2/src/at32f435_437_int.c:113
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f435_437_tmr.c:1486
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f435_437_tmr.h:290
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • encoder_tmr2
  • src
Functions | Variables
project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | delay (uint32_t time)
delay function More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint32_t | counter

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • encoder_tmr2
  • src
project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40
41void delay(uint32_t time);
42uint32_t counter;
48int main(void)
49{
50 system_clock_config();
51
52 at32_board_init();
53
54 /* get system clock */
55 crm_clocks_freq_get(&crm_clocks_freq_struct);
56
57 /* turn led2/led3/led4 on */
58 at32_led_on(LED2);
59 at32_led_on(LED3);
60 at32_led_on(LED4);
61
62 /* enable tmr2/gpioa clock */
63 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
64 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
65
66 /* timer1 output pin Configuration */
67 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
68 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
69 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
70 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
71 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
72 gpio_init(GPIOA, &gpio_init_struct);
73
74 gpio_init_struct.gpio_pins = GPIO_PINS_2 | GPIO_PINS_3;
75 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
76 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
77 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
78 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
79 gpio_init(GPIOA, &gpio_init_struct);
80
81 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE0, GPIO_MUX_1);
82 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE1, GPIO_MUX_1);
83
84 /* tmr2 encoder mode configuration--------------------------
85 tmr2 ti1pf1 ,ti2fp2 as encoder input pin, tmr2 counter
86 changed each signal edge.
87 ------------------------------------------------------------ */
88 /* enable tmr2 32bit function */
89 tmr_32_bit_function_enable(TMR2, TRUE);
90
91 tmr_base_init(TMR2, 0xFFFFFFFF, 0);
92 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
93
94 /* config encoder mode */
95 tmr_encoder_mode_config(TMR2, TMR_ENCODER_MODE_C, TMR_INPUT_RISING_EDGE, TMR_INPUT_RISING_EDGE);
96
97 /* enable TMR2 */
98 tmr_counter_enable(TMR2, TRUE);
99
100 while(1)
101 {
102 /* generate encoder signal */
103 gpio_bits_set(GPIOA, GPIO_PINS_2);
104 delay(150);
105 gpio_bits_set(GPIOA, GPIO_PINS_3);
106 delay(150);
107 gpio_bits_reset(GPIOA, GPIO_PINS_2);
108 delay(150);
109 gpio_bits_reset(GPIOA, GPIO_PINS_3);
110 delay(150);
111
112 /* get current counter value */
113 counter = tmr_counter_value_get(TMR2);
114 }
115}
116
122void delay(uint32_t time)
123{
124 uint32_t i;
125
126 for(i = 0; i < time; i++);
127}
128
at32f435_437_board.h
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c:38
delay
void delay(uint32_t time)
delay function
Definition: project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c:122
counter
uint32_t counter
Definition: project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c:42
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c:48
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/tmr/encoder_tmr2/src/main.c:39
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:128
TRUE
@ TRUE
Definition: at32f435_437.h:379
time
ertc_time_type * time
Definition: random.c:41
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f435_437_gpio.c:308
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f435_437_gpio.c:277
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_1
@ GPIO_MUX_1
Definition: at32f435_437_gpio.h:157
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_counter_value_get
uint32_t tmr_counter_value_get(tmr_type *tmr_x)
get tmr counter value
Definition: at32f435_437_tmr.c:299
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_32_bit_function_enable
void tmr_32_bit_function_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode)
Definition: at32f435_437_tmr.c:819
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_encoder_mode_config
void tmr_encoder_mode_config(tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type ic1_polarity, tmr_input_polarity_type ic2_polarity)
config tmr encoder mode
Definition: at32f435_437_tmr.c:1678
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f435_437_tmr.h:207
TMR_ENCODER_MODE_C
@ TMR_ENCODER_MODE_C
Definition: at32f435_437_tmr.h:166
TMR2
#define TMR2
Definition: at32f435_437_tmr.h:896
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • external_clock
  • inc
project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • external_clock
  • inc
project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • external_clock
  • inc
project/at_start_f435/examples/tmr/external_clock/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • external_clock
  • src
Functions
project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • external_clock
  • src
project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • external_clock
  • src
Functions
project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • external_clock
  • src
project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133 /* trigger TMR1 hall event */
134 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
135}
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/external_clock/src/at32f435_437_int.c:113
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f435_437_tmr.c:1486
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f435_437_tmr.h:290
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • external_clock
  • src
Functions | Variables
project/at_start_f435/examples/tmr/external_clock/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_input_config_type tmr_input_config_struct
uint16_t | timerperiod = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/external_clock/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • external_clock
  • src
project/at_start_f435/examples/tmr/external_clock/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40 tmr_output_config_type tmr_output_struct;
41 tmr_input_config_type tmr_input_config_struct;
42uint16_t timerperiod = 0;
43
49int main(void)
50{
51 system_clock_config();
52
53 at32_board_init();
54
55 /* get system clock */
56 crm_clocks_freq_get(&crm_clocks_freq_struct);
57
58 /* turn led2/led3/led4 on */
59 at32_led_on(LED2);
60 at32_led_on(LED3);
61 at32_led_on(LED4);
62
63 /* enable tmr2/tmr3/gpioa/gpiob clock */
64 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
65 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
67 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
68
69 /* timer2 and timer3 output pin Configuration */
70 gpio_init_struct.gpio_pins = GPIO_PINS_0;
71 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
72 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
73 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
74 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
75 gpio_init(GPIOA, &gpio_init_struct);
76 gpio_init(GPIOB, &gpio_init_struct);
77
78 gpio_init_struct.gpio_pins = GPIO_PINS_7;
79 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
80 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
81 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
82 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
83 gpio_init(GPIOA, &gpio_init_struct);
84
85 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE0, GPIO_MUX_1);
86 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE7, GPIO_MUX_2);
87 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE0, GPIO_MUX_2);
88
89 /* use tmr2 generate clock to drive tmr3--------------------
90 tmr2 pwm frequency = 288000000(apb1_freq*2)/240(period+1)/1000(div+1) = 1 khz
91 tmr3 pwm frequency = 1000(tmr2 pwm frequency)/100(period+1)/1(div+1) = 10 hz
92 ------------------------------------------------------------ */
93 /* tmr2 and tmr3 counter mode configuration */
94
95 timerperiod = ((crm_clocks_freq_struct.apb1_freq * 2) / 1000000) - 1;
96 tmr_base_init(TMR2, timerperiod, 999);
97 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
98
99 tmr_base_init(TMR3, 99, 0);
100 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
101
102 /* tmr2 and tmr3 output mode configuration */
103 tmr_output_default_para_init(&tmr_output_struct);
104 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
105 tmr_output_struct.oc_output_state = TRUE;
106 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
107 tmr_output_struct.oc_idle_state = TRUE;
108 tmr_output_struct.occ_output_state = FALSE;
109 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_HIGH;
110 tmr_output_struct.occ_idle_state = FALSE;
111 /* tmr2 channel 1 */
112 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
113 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_1, timerperiod/2);
114 /* tmr3 channel 3 */
115 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_3, &tmr_output_struct);
116 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_3, 50);
117
118 /* configure tmr3 channel2 to get clock signal */
119 tmr_input_config_struct.input_channel_select = TMR_SELECT_CHANNEL_2;
120 tmr_input_config_struct.input_mapped_select = TMR_CC_CHANNEL_MAPPED_DIRECT;
121 tmr_input_config_struct.input_polarity_select = TMR_INPUT_RISING_EDGE;
122 tmr_input_channel_init(TMR3, &tmr_input_config_struct, TMR_CHANNEL_INPUT_DIV_1);
123
124 /* select the tmr3 input trigger: C2IF2 */
125 tmr_trigger_input_select(TMR3, TMR_SUB_INPUT_SEL_C2DF2);
126
127 /* select the slave mode: external mode a*/
128 tmr_sub_mode_select(TMR3, TMR_SUB_EXTERNAL_CLOCK_MODE_A);
129
130 /* enable tmr2 */
131 tmr_counter_enable(TMR2, TRUE);
132
133 /* enable tmr3 */
134 tmr_counter_enable(TMR3, TRUE);
135
136 while(1)
137 {
138 }
139}
140
at32f435_437_board.h
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/tmr/external_clock/src/main.c:38
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f435/examples/tmr/external_clock/src/main.c:40
timerperiod
uint16_t timerperiod
Definition: project/at_start_f435/examples/tmr/external_clock/src/main.c:42
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/external_clock/src/main.c:49
tmr_input_config_struct
tmr_input_config_type tmr_input_config_struct
Definition: project/at_start_f435/examples/tmr/external_clock/src/main.c:41
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/tmr/external_clock/src/main.c:39
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:128
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:129
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_2
@ GPIO_MUX_2
Definition: at32f435_437_gpio.h:158
GPIO_MUX_1
@ GPIO_MUX_1
Definition: at32f435_437_gpio.h:157
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_input_channel_init
void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel
Definition: at32f435_437_tmr.c:872
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f435_437_tmr.c:1245
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f435_437_tmr.c:1322
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f435_437_tmr.h:207
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f435_437_tmr.h:221
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f435_437_tmr.h:219
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f435_437_tmr.h:241
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f435_437_tmr.h:180
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:198
TMR_SUB_INPUT_SEL_C2DF2
@ TMR_SUB_INPUT_SEL_C2DF2
Definition: at32f435_437_tmr.h:140
TMR_SUB_EXTERNAL_CLOCK_MODE_A
@ TMR_SUB_EXTERNAL_CLOCK_MODE_A
Definition: at32f435_437_tmr.h:156
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f435_437_tmr.h:251
TMR3
#define TMR3
Definition: at32f435_437_tmr.h:897
TMR2
#define TMR2
Definition: at32f435_437_tmr.h:896
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f435_437_crm.h:792
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_input_config_type
tmr input capture config type
Definition: at32f435_437_tmr.h:425
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f435_437_tmr.h:428
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f435_437_tmr.h:427
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f435_437_tmr.h:426
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f435_437_tmr.h:418
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f435_437_tmr.h:416
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f435_437_tmr.h:414
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • hall_xor_tmr2
  • inc
project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • hall_xor_tmr2
  • inc
project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • hall_xor_tmr2
  • inc
project/at_start_f435/examples/tmr/hall_xor_tmr2/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • hall_xor_tmr2
  • src
Functions
project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • hall_xor_tmr2
  • src
project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • hall_xor_tmr2
  • src
Functions
project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • hall_xor_tmr2
  • src
project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133 /* trigger TMR1 hall event */
134 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
135}
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/hall_xor_tmr2/src/at32f435_437_int.c:113
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f435_437_tmr.c:1486
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f435_437_tmr.h:290
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • hall_xor_tmr2
  • src
Functions | Variables
project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

int | main (void)
main function. More...
void | TMR2_GLOBAL_IRQHandler (void)
this function handles TMR2 trigger exception. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_input_config_type tmr_input_config_struct

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • hall_xor_tmr2
  • src
project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40 tmr_output_config_type tmr_output_struct;
41 tmr_input_config_type tmr_input_config_struct;
42
48int main(void)
49{
50 system_clock_config();
51
52 at32_board_init();
53
54 /* get system clock */
55 crm_clocks_freq_get(&crm_clocks_freq_struct);
56
57 /* turn led2/led3/led4 on */
58 at32_led_on(LED2);
59 at32_led_on(LED3);
60 at32_led_on(LED4);
61
62 /* enable tmr2/tmr3/gpioa/gpiob clock */
63 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
64 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
65
66 /* tmr2 channel1 ,channel2 and channel3 configuration */
67 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_2;
68 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
69 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
70 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
71 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
72 gpio_init(GPIOA, &gpio_init_struct);
73
74 /* hall signal (pa3 ,pa6 ,pa7) and trigger flag signal(pa8) configuration */
75 gpio_init_struct.gpio_pins = GPIO_PINS_3 | GPIO_PINS_6 | GPIO_PINS_7 | GPIO_PINS_8;
76 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
77 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
78 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
79 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
80 gpio_init(GPIOA, &gpio_init_struct);
81
82 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE0, GPIO_MUX_1);
83 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE1, GPIO_MUX_1);
84 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE2, GPIO_MUX_1);
85
86 /* tmr2 xor mode configuration--------------------------------------------
87 tmr2 channel1 ,channel2 and channel3 as hall signal input channel, trigger
88 generated each signal edge.
89 ------------------------------------------------------------ */
90 /* tmr2 and tmr3 counter mode configuration */
91 tmr_32_bit_function_enable(TMR2, TRUE);
92
93 tmr_base_init(TMR2, 0xFFFFFFFF, 0);
94 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
95
96 /* config ti1 trc as input source */
97 tmr_input_config_struct.input_channel_select = TMR_SELECT_CHANNEL_1;
98 tmr_input_config_struct.input_mapped_select = TMR_CC_CHANNEL_MAPPED_STI;
99 tmr_input_config_struct.input_polarity_select = TMR_INPUT_RISING_EDGE;
100 tmr_input_channel_init(TMR2, &tmr_input_config_struct, TMR_CHANNEL_INPUT_DIV_1);
101
102 /* xor funtion enable */
103 tmr_channel1_input_select(TMR2, TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR);
104
105 /* select the tmr2 input trigger: C1INC */
106 tmr_trigger_input_select(TMR2, TMR_SUB_INPUT_SEL_C1INC);
107
108 /* select the slave mode: reset mode */
109 tmr_sub_mode_select(TMR2, TMR_SUB_RESET_MODE);
110
111 tmr_interrupt_enable(TMR2, TMR_TRIGGER_INT, TRUE);
112
113 /* tmr2 trigger interrupt nvic init */
114 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
115 nvic_irq_enable(TMR2_GLOBAL_IRQn, 1, 0);
116
117 /* enable tmr2 */
118 tmr_counter_enable(TMR2, TRUE);
119
120 while(1)
121 {
122 /* generate hall signal */
123 gpio_bits_set(GPIOA, GPIO_PINS_3);
124 delay_us(10);
125 gpio_bits_set(GPIOA, GPIO_PINS_6);
126 delay_us(10);
127 gpio_bits_set(GPIOA, GPIO_PINS_7);
128 delay_us(10);
129 gpio_bits_reset(GPIOA, GPIO_PINS_3);
130 delay_us(10);
131 gpio_bits_reset(GPIOA, GPIO_PINS_6);
132 delay_us(10);
133 gpio_bits_reset(GPIOA, GPIO_PINS_7);
134 delay_us(10);
135 }
136}
137
143void TMR2_GLOBAL_IRQHandler(void)
144{
145 if(tmr_flag_get(TMR2, TMR_TRIGGER_FLAG) == SET)
146 {
147 GPIOA->odt ^= GPIO_PINS_8;
148 tmr_flag_clear(TMR2, TMR_TRIGGER_FLAG);
149 }
150}
151
at32f435_437_board.h
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c:38
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c:40
TMR2_GLOBAL_IRQHandler
void TMR2_GLOBAL_IRQHandler(void)
this function handles TMR2 trigger exception.
Definition: project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c:143
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c:48
tmr_input_config_struct
tmr_input_config_type tmr_input_config_struct
Definition: project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c:41
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/tmr/hall_xor_tmr2/src/main.c:39
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f435_437_board.c:306
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:128
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f435_437_gpio.c:308
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f435_437_gpio.c:277
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_1
@ GPIO_MUX_1
Definition: at32f435_437_gpio.h:157
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f435_437_tmr.c:1463
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_input_channel_init
void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel
Definition: at32f435_437_tmr.c:872
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f435_437_tmr.c:1245
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f435_437_tmr.c:1424
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_channel1_input_select
void tmr_channel1_input_select(tmr_type *tmr_x, tmr_channel1_input_connected_type ch1_connect)
select tmr channel1 input
Definition: at32f435_437_tmr.c:1150
tmr_32_bit_function_enable
void tmr_32_bit_function_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode)
Definition: at32f435_437_tmr.c:819
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f435_437_tmr.c:1322
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f435_437_tmr.c:1389
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f435_437_tmr.h:207
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR
@ TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR
Definition: at32f435_437_tmr.h:233
TMR_CC_CHANNEL_MAPPED_STI
@ TMR_CC_CHANNEL_MAPPED_STI
Definition: at32f435_437_tmr.h:243
TMR_SUB_INPUT_SEL_C1INC
@ TMR_SUB_INPUT_SEL_C1INC
Definition: at32f435_437_tmr.h:138
TMR_SUB_RESET_MODE
@ TMR_SUB_RESET_MODE
Definition: at32f435_437_tmr.h:153
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f435_437_tmr.h:251
TMR_TRIGGER_FLAG
#define TMR_TRIGGER_FLAG
Definition: at32f435_437_tmr.h:59
TMR_TRIGGER_INT
#define TMR_TRIGGER_INT
Definition: at32f435_437_tmr.h:81
TMR2
#define TMR2
Definition: at32f435_437_tmr.h:896
TMR2_GLOBAL_IRQn
@ TMR2_GLOBAL_IRQn
Definition: at32f435_437.h:176
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_input_config_type
tmr input capture config type
Definition: at32f435_437_tmr.h:425
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f435_437_tmr.h:428
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f435_437_tmr.h:427
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f435_437_tmr.h:426
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • hang_mode
  • inc
project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • hang_mode
  • inc
project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • hang_mode
  • inc
project/at_start_f435/examples/tmr/hang_mode/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • hang_mode
  • src
Functions
project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • hang_mode
  • src
project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • hang_mode
  • src
Functions
project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • hang_mode
  • src
project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133 /* trigger TMR1 hall event */
134 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
135}
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/hang_mode/src/at32f435_437_int.c:113
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f435_437_tmr.c:1486
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f435_437_tmr.h:290
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • hang_mode
  • src
Functions | Variables
project/at_start_f435/examples/tmr/hang_mode/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_input_config_type tmr_input_config_struct
uint16_t | timerperiod = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/hang_mode/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • hang_mode
  • src
project/at_start_f435/examples/tmr/hang_mode/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40 tmr_output_config_type tmr_output_struct;
41 tmr_input_config_type tmr_input_config_struct;
42uint16_t timerperiod = 0;
43
49int main(void)
50{
51 system_clock_config();
52
53 at32_board_init();
54
55 /* get system clock */
56 crm_clocks_freq_get(&crm_clocks_freq_struct);
57
58 /* turn led2/led3/led4 on */
59 at32_led_on(LED2);
60 at32_led_on(LED3);
61 at32_led_on(LED4);
62
63 /* enable tmr1/gpioa clock */
64 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
65 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
66
67 /* timer1 output pin configuration */
68 gpio_init_struct.gpio_pins = GPIO_PINS_8;
69 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
70 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
71 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
72 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
73 gpio_init(GPIOA, &gpio_init_struct);
74
75 gpio_init_struct.gpio_pins = GPIO_PINS_9;
76 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
77 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
78 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
79 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
80 gpio_init(GPIOA, &gpio_init_struct);
81
82 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE8, GPIO_MUX_1);
83 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE9, GPIO_MUX_1);
84
85 /* hang mode test -----
86 1/tmr1 is configured as master timer:
87 - toggle mode is used
88
89 2/tmr1 is configured as slave timer for an external trigger connected
90 to tmr1 ti2 pin (tmr1 ch2 configured as input pin):
91 - the tmr1 ti2fp2 is used as trigger input
92 - rising edge is used to start and stop the tmr1: hang mode.
93
94 * the timxclk is fixed to apb2_freq*2, the three timers are running at:
95 tmrx frequency = tmrx clock counter/ (timx_period + 1) = 500 khz.
96 */
97 /* tmr2 and tmr3 counter mode configuration */
98 timerperiod = ((crm_clocks_freq_struct.apb2_freq * 2) / 500000 ) - 1;
99 tmr_base_init(TMR1, timerperiod, 0);
100 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
101
102 /* tmr1 output mode configuration */
103 tmr_output_default_para_init(&tmr_output_struct);
104 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
105 tmr_output_struct.oc_output_state = TRUE;
106 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
107 tmr_output_struct.oc_idle_state = TRUE;
108 tmr_output_struct.occ_output_state = FALSE;
109 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_HIGH;
110 tmr_output_struct.occ_idle_state = FALSE;
111 /* tmr1 channel 1 */
112 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
113 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, timerperiod/2);
114
115 /* configure tmr1 channel2 to get hang signal */
116 tmr_input_default_para_init(&tmr_input_config_struct);
117 tmr_input_config_struct.input_channel_select = TMR_SELECT_CHANNEL_2;
118 tmr_input_config_struct.input_mapped_select = TMR_CC_CHANNEL_MAPPED_DIRECT;
119 tmr_input_config_struct.input_polarity_select = TMR_INPUT_RISING_EDGE;
120 tmr_input_channel_init(TMR1, &tmr_input_config_struct, TMR_CHANNEL_INPUT_DIV_1);
121
122 /* select the tmr1 input trigger: C2IF2 */
123 tmr_trigger_input_select(TMR1, TMR_SUB_INPUT_SEL_C2DF2);
124
125 /* select the slave mode: hang mode */
126 tmr_sub_mode_select(TMR1, TMR_SUB_HANG_MODE);
127
128 /* tmr1 output enable */
129 tmr_output_enable(TMR1, TRUE);
130
131 /* enable tmr1 */
132 tmr_counter_enable(TMR1, TRUE);
133
134 while(1)
135 {
136 }
137}
138
at32f435_437_board.h
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/tmr/hang_mode/src/main.c:38
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f435/examples/tmr/hang_mode/src/main.c:40
timerperiod
uint16_t timerperiod
Definition: project/at_start_f435/examples/tmr/hang_mode/src/main.c:42
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/hang_mode/src/main.c:49
tmr_input_config_struct
tmr_input_config_type tmr_input_config_struct
Definition: project/at_start_f435/examples/tmr/hang_mode/src/main.c:41
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/tmr/hang_mode/src/main.c:39
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:154
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_1
@ GPIO_MUX_1
Definition: at32f435_437_gpio.h:157
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_input_channel_init
void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel
Definition: at32f435_437_tmr.c:872
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f435_437_tmr.c:1245
tmr_input_default_para_init
void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct)
init tmr input default para
Definition: at32f435_437_tmr.c:169
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f435_437_tmr.c:1499
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f435_437_tmr.c:1322
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f435_437_tmr.h:207
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f435_437_tmr.h:219
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f435_437_tmr.h:241
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f435_437_tmr.h:180
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:198
TMR_SUB_INPUT_SEL_C2DF2
@ TMR_SUB_INPUT_SEL_C2DF2
Definition: at32f435_437_tmr.h:140
TMR_SUB_HANG_MODE
@ TMR_SUB_HANG_MODE
Definition: at32f435_437_tmr.h:154
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f435_437_tmr.h:251
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::apb2_freq
uint32_t apb2_freq
Definition: at32f435_437_crm.h:791
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_input_config_type
tmr input capture config type
Definition: at32f435_437_tmr.h:425
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f435_437_tmr.h:428
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f435_437_tmr.h:427
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f435_437_tmr.h:426
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f435_437_tmr.h:418
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f435_437_tmr.h:416
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f435_437_tmr.h:414
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • input_capture
  • inc
project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • input_capture
  • inc
project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • input_capture
  • inc
project/at_start_f435/examples/tmr/input_capture/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • input_capture
  • src
Functions
project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • input_capture
  • src
project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • input_capture
  • src
Functions
project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • input_capture
  • src
project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133 /* trigger TMR1 hall event */
134 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
135}
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/input_capture/src/at32f435_437_int.c:113
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f435_437_tmr.c:1486
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f435_437_tmr.h:290
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • input_capture
  • src
Functions | Variables
project/at_start_f435/examples/tmr/input_capture/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | delay (uint32_t time)
delay function More...
void | uart_init (uint32_t bound)
initialize print usart More...
int | main (void)
main function. More...
void | TMR3_GLOBAL_IRQHandler (void)
this function handles tmr3 trigger exception. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_input_config_type tmr_input_config_struct
__IO uint32_t | tmr3freq = 0
__IO uint32_t | sys_counter = 0
__IO uint16_t | capturenumber = 0
__IO uint16_t | ic3readvalue1 = 0
__IO uint16_t | ic3readvalue2 = 0
__IO uint32_t | capture = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/input_capture/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • input_capture
  • src
project/at_start_f435/examples/tmr/input_capture/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40 tmr_input_config_type tmr_input_config_struct;
41void delay(uint32_t time);
42void uart_init(uint32_t bound);
43__IO uint32_t tmr3freq = 0;
44__IO uint32_t sys_counter = 0;
45__IO uint16_t capturenumber = 0;
46__IO uint16_t ic3readvalue1 = 0, ic3readvalue2 = 0;
47__IO uint32_t capture = 0;
48
54int main(void)
55{
56 system_clock_config();
57
58 at32_board_init();
59
60 uart_print_init(115200);
61
62 /* get system clock */
63 crm_clocks_freq_get(&crm_clocks_freq_struct);
64
65 /* turn led2/led3/led4 on */
66 at32_led_on(LED2);
67 at32_led_on(LED3);
68 at32_led_on(LED4);
69
70 /* enable tmr3/gpioa clock */
71 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
72 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
73
74 /* timer3 input pin Configuration */
75 gpio_init_struct.gpio_pins = GPIO_PINS_7;
76 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
77 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
78 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
79 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
80 gpio_init(GPIOA, &gpio_init_struct);
81
82 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE7, GPIO_MUX_2);
83
84 /* tmr3 configuration: input capture mode ---------------------
85 the external signal is connected to tmr3 ch2 pin (pa.07)
86 the rising edge is used as active edge,
87 the tmr3 c2dt is used to compute the frequency value
88 ------------------------------------------------------------ */
89 /* tmr3 counter mode configuration */
90 tmr_base_init(TMR3, 0xFFFF, 0);
91 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
92
93 /* configure tmr3 channel2 to get clock signal */
94 tmr_input_config_struct.input_channel_select = TMR_SELECT_CHANNEL_2;
95 tmr_input_config_struct.input_mapped_select = TMR_CC_CHANNEL_MAPPED_DIRECT;
96 tmr_input_config_struct.input_polarity_select = TMR_INPUT_RISING_EDGE;
97 tmr_input_channel_init(TMR3, &tmr_input_config_struct, TMR_CHANNEL_INPUT_DIV_1);
98
99 tmr_interrupt_enable(TMR3, TMR_C2_INT, TRUE);
100
101 /* tmr2 trigger interrupt nvic init */
102 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
103 nvic_irq_enable(TMR3_GLOBAL_IRQn, 1, 0);
104
105 /* enable tmr3 */
106 tmr_counter_enable(TMR3, TRUE);
107
108 while(1)
109 {
110 delay(10000);
111 printf("The external signal frequece is : %d\r\n",tmr3freq);
112 tmr3freq = 0;
113 }
114}
120void delay(uint32_t time)
121{
122 uint32_t i;
123
124 for(i = 0; i < time; i++);
125}
126
132void TMR3_GLOBAL_IRQHandler(void)
133{
134 if(tmr_flag_get(TMR3, TMR_C2_FLAG) == SET)
135 {
136 tmr_flag_clear(TMR3, TMR_C2_FLAG);
137 if(capturenumber == 0)
138 {
139 /* get the Input Capture value */
140 ic3readvalue1 = tmr_channel_value_get(TMR3, TMR_SELECT_CHANNEL_2);
141 capturenumber = 1;
142 }
143 else if(capturenumber == 1)
144 {
145 /* get the Input Capture value */
146 ic3readvalue2 = tmr_channel_value_get(TMR3, TMR_SELECT_CHANNEL_2);
147
148 /* capture computation */
149 if (ic3readvalue2 > ic3readvalue1)
150 {
151 capture = (ic3readvalue2 - ic3readvalue1);
152 }
153 else
154 {
155 capture = ((0xFFFF - ic3readvalue1) + ic3readvalue2);
156 }
157 /* frequency computation */
158 tmr3freq = (uint32_t) crm_clocks_freq_struct.sclk_freq / capture;
159 capturenumber = 0;
160 }
161 }
162}
163
at32f435_437_board.h
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/tmr/input_capture/src/main.c:38
delay
void delay(uint32_t time)
delay function
Definition: project/at_start_f435/examples/tmr/input_capture/src/main.c:120
ic3readvalue2
__IO uint16_t ic3readvalue2
Definition: project/at_start_f435/examples/tmr/input_capture/src/main.c:46
tmr3freq
__IO uint32_t tmr3freq
Definition: project/at_start_f435/examples/tmr/input_capture/src/main.c:43
uart_init
void uart_init(uint32_t bound)
initialize print usart
Definition: project/at_start_f435/examples/edma/link_list_mode/src/main.c:137
capturenumber
__IO uint16_t capturenumber
Definition: project/at_start_f435/examples/tmr/input_capture/src/main.c:45
TMR3_GLOBAL_IRQHandler
void TMR3_GLOBAL_IRQHandler(void)
this function handles tmr3 trigger exception.
Definition: project/at_start_f435/examples/tmr/input_capture/src/main.c:132
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/input_capture/src/main.c:54
tmr_input_config_struct
tmr_input_config_type tmr_input_config_struct
Definition: project/at_start_f435/examples/tmr/input_capture/src/main.c:40
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/tmr/input_capture/src/main.c:39
ic3readvalue1
__IO uint16_t ic3readvalue1
Definition: project/at_start_f435/examples/tmr/input_capture/src/main.c:46
sys_counter
__IO uint32_t sys_counter
Definition: project/at_start_f435/examples/tmr/input_capture/src/main.c:44
capture
__IO uint32_t capture
Definition: project/at_start_f435/examples/tmr/input_capture/src/main.c:47
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:129
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
time
ertc_time_type * time
Definition: random.c:41
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_2
@ GPIO_MUX_2
Definition: at32f435_437_gpio.h:158
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
tmr_channel_value_get
uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value
Definition: at32f435_437_tmr.c:593
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f435_437_tmr.c:1463
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_input_channel_init
void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel
Definition: at32f435_437_tmr.c:872
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f435_437_tmr.c:1424
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f435_437_tmr.c:1389
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f435_437_tmr.h:207
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f435_437_tmr.h:219
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f435_437_tmr.h:241
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f435_437_tmr.h:251
TMR_C2_FLAG
#define TMR_C2_FLAG
Definition: at32f435_437_tmr.h:54
TMR_C2_INT
#define TMR_C2_INT
Definition: at32f435_437_tmr.h:77
TMR3
#define TMR3
Definition: at32f435_437_tmr.h:897
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f435_437.h:177
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f435_437_crm.h:789
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_input_config_type
tmr input capture config type
Definition: at32f435_437_tmr.h:425
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f435_437_tmr.h:428
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f435_437_tmr.h:427
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f435_437_tmr.h:426
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • oc_high
  • inc
project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • oc_high
  • inc
project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • oc_high
  • inc
project/at_start_f435/examples/tmr/oc_high/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • oc_high
  • src
Functions
project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • oc_high
  • src
project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • oc_high
  • src
Functions
project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR2_GLOBAL_IRQHandler (void)
this function handles tmr2 global interrupt request. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • oc_high
  • src
project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
140void TMR2_GLOBAL_IRQHandler(void)
141{
142 if (tmr_flag_get(TMR2, TMR_C1_FLAG) != RESET)
143 {
144 /* clear tmr2 channel1 interrupt pending bit*/
145 tmr_flag_clear(TMR2, TMR_C1_FLAG);
146
147 /* pc.06 turnoff after 1000 ms */
148 gpio_bits_reset(GPIOC, GPIO_PINS_6);
149 }
150 else if (tmr_flag_get(TMR2, TMR_C2_FLAG) != RESET)
151 {
152 /* clear tmr2 channel2 interrupt pending bit*/
153 tmr_flag_clear(TMR2, TMR_C2_FLAG);
154
155 /* pc.07 turnoff after 500 ms */
156 gpio_bits_reset(GPIOC, GPIO_PINS_7);
157 }
158 else if (tmr_flag_get(TMR2, TMR_C3_FLAG) != RESET)
159 {
160 /* clear tmr2 channel3 interrupt pending bit*/
161 tmr_flag_clear(TMR2, TMR_C3_FLAG);
162
163 /* pc.08 turnoff after 250 ms */
164 gpio_bits_reset(GPIOC, GPIO_PINS_8);
165 }
166 else
167 {
168 /* clear tmr2 channel4 interrupt pending bit*/
169 tmr_flag_clear(TMR2, TMR_C4_FLAG);
170
171 /* pc.09 turnoff after 125 ms */
172 gpio_bits_reset(GPIOC, GPIO_PINS_9);
173 }
174}
175
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c:104
TMR2_GLOBAL_IRQHandler
void TMR2_GLOBAL_IRQHandler(void)
this function handles tmr2 global interrupt request.
Definition: project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c:140
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/oc_high/src/at32f435_437_int.c:113
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f435_437_gpio.c:308
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f435_437_tmr.c:1463
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f435_437_tmr.c:1424
TMR_C1_FLAG
#define TMR_C1_FLAG
Definition: at32f435_437_tmr.h:53
TMR_C2_FLAG
#define TMR_C2_FLAG
Definition: at32f435_437_tmr.h:54
TMR_C3_FLAG
#define TMR_C3_FLAG
Definition: at32f435_437_tmr.h:55
TMR_C4_FLAG
#define TMR_C4_FLAG
Definition: at32f435_437_tmr.h:56
TMR2
#define TMR2
Definition: at32f435_437_tmr.h:896
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • oc_high
  • src
Functions | Variables
project/at_start_f435/examples/tmr/oc_high/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | gpio_configuration (void)
configure the gpioc pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | ccr1_val = 1000
uint16_t | ccr2_val = 500
uint16_t | ccr3_val = 250
uint16_t | ccr4_val = 125
uint16_t | prescalervalue = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/oc_high/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • oc_high
  • src
project/at_start_f435/examples/tmr/oc_high/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 tmr_output_config_type tmr_oc_init_structure;
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40uint16_t ccr1_val = 1000;
41uint16_t ccr2_val = 500;
42uint16_t ccr3_val = 250;
43uint16_t ccr4_val = 125;
44uint16_t prescalervalue = 0;
45
46void gpio_configuration(void);
47
53int main(void)
54{
55 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
56
57 system_clock_config();
58
59 at32_board_init();
60
61 crm_apb1_div_set(CRM_APB1_DIV_16);
62
63 /* get system clock */
64 crm_clocks_freq_get(&crm_clocks_freq_struct);
65
66 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
67 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
68
69 nvic_irq_enable(TMR2_GLOBAL_IRQn, 0, 1);
70
71 gpio_configuration();
72
73 /* compute the prescaler value */
74 prescalervalue = (uint16_t) ((crm_clocks_freq_struct.apb1_freq * 2) / 1000) - 1;
75
76 /* tmr2 time base configuration */
77 tmr_base_init(TMR2, 0xFFFF, prescalervalue);
78 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
79 tmr_clock_source_div_set(TMR2, TMR_CLOCK_DIV1);
80
81 tmr_output_default_para_init(&tmr_oc_init_structure);
82 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_HIGH;
83 tmr_oc_init_structure.oc_idle_state = FALSE;
84 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
85 tmr_oc_init_structure.oc_output_state = TRUE;
86 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
87 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_1, ccr1_val);
88
89 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_2, &tmr_oc_init_structure);
90 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_2, ccr2_val);
91
92 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_3, &tmr_oc_init_structure);
93 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_3, ccr3_val);
94
95 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_4, &tmr_oc_init_structure);
96 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_4, ccr4_val);
97
98 tmr_period_buffer_enable(TMR2, TRUE);
99
100 /* tmr2 int enable */
101 tmr_interrupt_enable(TMR2, TMR_C1_INT | TMR_C2_INT | TMR_C3_INT | TMR_C4_INT, TRUE);
102
103 /* set pc.06, pc.07, pc.08 and pc.09 pins */
104 gpio_bits_set(GPIOC, GPIO_PINS_6 | GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9);
105
106 /* tmr2 enable counter */
107 tmr_counter_enable(TMR2, TRUE);
108
109 while(1)
110 {
111 }
112}
113
119void gpio_configuration(void)
120{
121 gpio_init_type gpio_init_struct;
122
123 gpio_default_para_init(&gpio_init_struct);
124 /* gpioc configuration: pin6, 7, 8 and 9 as output push-pull */
125 gpio_init_struct.gpio_pins = GPIO_PINS_6 | GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9;
126 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
127 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
128 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
129 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
130
131 gpio_init(GPIOC, &gpio_init_struct);
132}
133
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
ccr1_val
uint16_t ccr1_val
Definition: project/at_start_f435/examples/tmr/oc_high/src/main.c:40
prescalervalue
uint16_t prescalervalue
Definition: project/at_start_f435/examples/tmr/oc_high/src/main.c:44
ccr2_val
uint16_t ccr2_val
Definition: project/at_start_f435/examples/tmr/oc_high/src/main.c:41
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/oc_high/src/main.c:53
gpio_configuration
void gpio_configuration(void)
configure the gpioc pins.
Definition: project/at_start_f435/examples/tmr/oc_high/src/main.c:119
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f435/examples/tmr/oc_high/src/main.c:38
ccr4_val
uint16_t ccr4_val
Definition: project/at_start_f435/examples/tmr/oc_high/src/main.c:43
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/tmr/oc_high/src/main.c:39
ccr3_val
uint16_t ccr3_val
Definition: project/at_start_f435/examples/tmr/oc_high/src/main.c:42
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:128
CRM_APB1_DIV_16
@ CRM_APB1_DIV_16
Definition: at32f435_437_crm.h:591
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f435_437_gpio.c:277
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
tmr_period_buffer_enable
void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
set tmr period buffer
Definition: at32f435_437_tmr.c:638
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f435_437_tmr.c:1389
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f435_437_tmr.h:221
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f435_437_tmr.h:223
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f435_437_tmr.h:219
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f435_437_tmr.h:97
TMR_OUTPUT_CONTROL_HIGH
@ TMR_OUTPUT_CONTROL_HIGH
Definition: at32f435_437_tmr.h:175
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:198
TMR_C3_INT
#define TMR_C3_INT
Definition: at32f435_437_tmr.h:78
TMR_C4_INT
#define TMR_C4_INT
Definition: at32f435_437_tmr.h:79
TMR_C1_INT
#define TMR_C1_INT
Definition: at32f435_437_tmr.h:76
TMR_C2_INT
#define TMR_C2_INT
Definition: at32f435_437_tmr.h:77
TMR2
#define TMR2
Definition: at32f435_437_tmr.h:896
TMR2_GLOBAL_IRQn
@ TMR2_GLOBAL_IRQn
Definition: at32f435_437.h:176
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f435_437_crm.h:792
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • oc_low
  • inc
project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • oc_low
  • inc
project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • oc_low
  • inc
project/at_start_f435/examples/tmr/oc_low/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • oc_low
  • src
Functions
project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • oc_low
  • src
project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • oc_low
  • src
Functions
project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR2_GLOBAL_IRQHandler (void)
this function handles tmr2 global interrupt request. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • oc_low
  • src
project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
140void TMR2_GLOBAL_IRQHandler(void)
141{
142 if (tmr_flag_get(TMR2, TMR_C1_FLAG) != RESET)
143 {
144 /* clear tmr2 channel1 interrupt pending bit*/
145 tmr_flag_clear(TMR2, TMR_C1_FLAG);
146
147 /* pc.06 turnoff after 1000 ms */
148 gpio_bits_reset(GPIOC, GPIO_PINS_6);
149 }
150 else if (tmr_flag_get(TMR2, TMR_C2_FLAG) != RESET)
151 {
152 /* clear tmr2 channel2 interrupt pending bit*/
153 tmr_flag_clear(TMR2, TMR_C2_FLAG);
154
155 /* pc.07 turnoff after 500 ms */
156 gpio_bits_reset(GPIOC, GPIO_PINS_7);
157 }
158 else if (tmr_flag_get(TMR2, TMR_C3_FLAG) != RESET)
159 {
160 /* clear tmr2 channel3 interrupt pending bit*/
161 tmr_flag_clear(TMR2, TMR_C3_FLAG);
162
163 /* pc.08 turnoff after 250 ms */
164 gpio_bits_reset(GPIOC, GPIO_PINS_8);
165 }
166 else
167 {
168 /* clear tmr2 channel4 interrupt pending bit*/
169 tmr_flag_clear(TMR2, TMR_C4_FLAG);
170
171 /* pc.09 turnoff after 125 ms */
172 gpio_bits_reset(GPIOC, GPIO_PINS_9);
173 }
174}
175
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c:104
TMR2_GLOBAL_IRQHandler
void TMR2_GLOBAL_IRQHandler(void)
this function handles tmr2 global interrupt request.
Definition: project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c:140
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/oc_low/src/at32f435_437_int.c:113
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f435_437_gpio.c:308
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f435_437_tmr.c:1463
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f435_437_tmr.c:1424
TMR_C1_FLAG
#define TMR_C1_FLAG
Definition: at32f435_437_tmr.h:53
TMR_C2_FLAG
#define TMR_C2_FLAG
Definition: at32f435_437_tmr.h:54
TMR_C3_FLAG
#define TMR_C3_FLAG
Definition: at32f435_437_tmr.h:55
TMR_C4_FLAG
#define TMR_C4_FLAG
Definition: at32f435_437_tmr.h:56
TMR2
#define TMR2
Definition: at32f435_437_tmr.h:896
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • oc_low
  • src
Functions | Variables
project/at_start_f435/examples/tmr/oc_low/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | gpio_configuration (void)
configure the gpioc pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | ccr1_val = 1000
uint16_t | ccr2_val = 500
uint16_t | ccr3_val = 250
uint16_t | ccr4_val = 125
uint16_t | prescalervalue = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/oc_low/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • oc_low
  • src
project/at_start_f435/examples/tmr/oc_low/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 tmr_output_config_type tmr_oc_init_structure;
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40uint16_t ccr1_val = 1000;
41uint16_t ccr2_val = 500;
42uint16_t ccr3_val = 250;
43uint16_t ccr4_val = 125;
44uint16_t prescalervalue = 0;
45
46void gpio_configuration(void);
47
53int main(void)
54{
55 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
56
57 system_clock_config();
58
59 at32_board_init();
60
61 crm_apb1_div_set(CRM_APB1_DIV_16);
62
63 /* get system clock */
64 crm_clocks_freq_get(&crm_clocks_freq_struct);
65
66 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
67 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
68
69 nvic_irq_enable(TMR2_GLOBAL_IRQn, 0, 1);
70
71 gpio_configuration();
72
73 /* compute the prescaler value */
74 prescalervalue = (uint16_t) ((crm_clocks_freq_struct.apb1_freq * 2) / 1000) - 1;
75
76 /* tmr2 time base configuration */
77 tmr_base_init(TMR2, 65535, prescalervalue);
78 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
79 tmr_clock_source_div_set(TMR2, TMR_CLOCK_DIV1);
80
81 tmr_output_default_para_init(&tmr_oc_init_structure);
82 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_LOW;
83 tmr_oc_init_structure.oc_idle_state = FALSE;
84 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
85 tmr_oc_init_structure.oc_output_state = TRUE;
86 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
87 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_1, ccr1_val);
88
89 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_2, &tmr_oc_init_structure);
90 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_2, ccr2_val);
91
92 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_3, &tmr_oc_init_structure);
93 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_3, ccr3_val);
94
95 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_4, &tmr_oc_init_structure);
96 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_4, ccr4_val);
97
98 tmr_period_buffer_enable(TMR2, TRUE);
99
100 /* tmr2 int enable */
101 tmr_interrupt_enable(TMR2, TMR_C1_INT | TMR_C2_INT | TMR_C3_INT | TMR_C4_INT, TRUE);
102
103 /* set pc.06, pc.07, pc.08 and pc.09 pins */
104 gpio_bits_set(GPIOC, GPIO_PINS_6 | GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9);
105
106 /* tmr2 enable counter */
107 tmr_counter_enable(TMR2, TRUE);
108
109 while(1)
110 {
111
112 }
113}
114
120void gpio_configuration(void)
121{
122 gpio_init_type gpio_init_struct;
123
124 /* gpioc configuration: pin6, 7, 8 and 9 as output push-pull */
125 gpio_default_para_init(&gpio_init_struct);
126 gpio_init_struct.gpio_pins = GPIO_PINS_6 | GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9;
127 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
128 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
129 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
130 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
131
132 gpio_init(GPIOC, &gpio_init_struct);
133}
134
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
ccr1_val
uint16_t ccr1_val
Definition: project/at_start_f435/examples/tmr/oc_low/src/main.c:40
prescalervalue
uint16_t prescalervalue
Definition: project/at_start_f435/examples/tmr/oc_low/src/main.c:44
ccr2_val
uint16_t ccr2_val
Definition: project/at_start_f435/examples/tmr/oc_low/src/main.c:41
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/oc_low/src/main.c:53
gpio_configuration
void gpio_configuration(void)
configure the gpioc pins.
Definition: project/at_start_f435/examples/tmr/oc_low/src/main.c:120
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f435/examples/tmr/oc_low/src/main.c:38
ccr4_val
uint16_t ccr4_val
Definition: project/at_start_f435/examples/tmr/oc_low/src/main.c:43
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/tmr/oc_low/src/main.c:39
ccr3_val
uint16_t ccr3_val
Definition: project/at_start_f435/examples/tmr/oc_low/src/main.c:42
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:128
CRM_APB1_DIV_16
@ CRM_APB1_DIV_16
Definition: at32f435_437_crm.h:591
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f435_437_gpio.c:277
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
tmr_period_buffer_enable
void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
set tmr period buffer
Definition: at32f435_437_tmr.c:638
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f435_437_tmr.c:1389
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f435_437_tmr.h:221
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f435_437_tmr.h:223
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f435_437_tmr.h:219
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f435_437_tmr.h:97
TMR_OUTPUT_CONTROL_LOW
@ TMR_OUTPUT_CONTROL_LOW
Definition: at32f435_437_tmr.h:176
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:198
TMR_C3_INT
#define TMR_C3_INT
Definition: at32f435_437_tmr.h:78
TMR_C4_INT
#define TMR_C4_INT
Definition: at32f435_437_tmr.h:79
TMR_C1_INT
#define TMR_C1_INT
Definition: at32f435_437_tmr.h:76
TMR_C2_INT
#define TMR_C2_INT
Definition: at32f435_437_tmr.h:77
TMR2
#define TMR2
Definition: at32f435_437_tmr.h:896
TMR2_GLOBAL_IRQn
@ TMR2_GLOBAL_IRQn
Definition: at32f435_437.h:176
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f435_437_crm.h:792
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr3
  • inc
project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr3
  • inc
project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr3
  • inc
project/at_start_f435/examples/tmr/oc_toggle_tmr3/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr3
  • src
Functions
project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr3
  • src
project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr3
  • src
Functions | Variables
project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR3_GLOBAL_IRQHandler (void)
this function handles tmr3 global interrupt request. More...

Variables

uint32_t | capture = 0
__IO uint16_t | ccr1_val
__IO uint16_t | ccr2_val
__IO uint16_t | ccr3_val
__IO uint16_t | ccr4_val

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr3
  • src
project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
38uint32_t capture = 0;
39extern __IO uint16_t ccr1_val;
40extern __IO uint16_t ccr2_val;
41extern __IO uint16_t ccr3_val;
42extern __IO uint16_t ccr4_val;
43
49void NMI_Handler(void)
50{
51}
52
58void HardFault_Handler(void)
59{
60 /* go to infinite loop when hard fault exception occurs */
61 while(1)
62 {
63 }
64}
65
71void MemManage_Handler(void)
72{
73 /* go to infinite loop when memory manage exception occurs */
74 while(1)
75 {
76 }
77}
78
84void BusFault_Handler(void)
85{
86 /* go to infinite loop when bus fault exception occurs */
87 while(1)
88 {
89 }
90}
91
97void UsageFault_Handler(void)
98{
99 /* go to infinite loop when usage fault exception occurs */
100 while(1)
101 {
102 }
103}
104
110void SVC_Handler(void)
111{
112}
113
119void DebugMon_Handler(void)
120{
121}
122
128void PendSV_Handler(void)
129{
130}
131
137void SysTick_Handler(void)
138{
139}
140
146void TMR3_GLOBAL_IRQHandler(void)
147{
148 /* TMR3_CH1 toggling with frequency = 183.1 Hz */
149 if (tmr_flag_get(TMR3, TMR_C1_FLAG) != RESET)
150 {
151 tmr_flag_clear(TMR3, TMR_C1_FLAG );
152 capture = tmr_channel_value_get(TMR3, TMR_SELECT_CHANNEL_1);
153 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_1, capture + ccr1_val);
154 }
155
156 /* TMR3_CH2 toggling with frequency = 366.2 Hz */
157 if (tmr_flag_get(TMR3, TMR_C2_FLAG) != RESET)
158 {
159 tmr_flag_clear(TMR3, TMR_C2_FLAG);
160 capture = tmr_channel_value_get(TMR3, TMR_SELECT_CHANNEL_2);
161 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_2, capture + ccr2_val);
162 }
163
164 /* TMR3_CH3 toggling with frequency = 732.4 Hz */
165 if (tmr_flag_get(TMR3, TMR_C3_FLAG) != RESET)
166 {
167 tmr_flag_clear(TMR3, TMR_C3_FLAG);
168 capture = tmr_channel_value_get(TMR3, TMR_SELECT_CHANNEL_3);
169 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_3, capture + ccr3_val);
170 }
171
172 /* TMR3_CH4 toggling with frequency = 1464.8 Hz */
173 if (tmr_flag_get(TMR3, TMR_C4_FLAG) != RESET)
174 {
175 tmr_flag_clear(TMR3, TMR_C4_FLAG);
176 capture = tmr_channel_value_get(TMR3, TMR_SELECT_CHANNEL_4);
177 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_4, capture + ccr4_val);
178 }
179}
180
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c:97
ccr2_val
__IO uint16_t ccr2_val
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/main.c:42
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c:58
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c:71
ccr3_val
__IO uint16_t ccr3_val
Definition: project/at_start_f435/examples/tmr/oc_high/src/main.c:42
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c:110
ccr1_val
__IO uint16_t ccr1_val
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/main.c:41
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c:128
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c:49
TMR3_GLOBAL_IRQHandler
void TMR3_GLOBAL_IRQHandler(void)
this function handles tmr3 global interrupt request.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c:146
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c:84
ccr4_val
__IO uint16_t ccr4_val
Definition: project/at_start_f435/examples/tmr/oc_high/src/main.c:43
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c:137
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c:119
capture
uint32_t capture
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/at32f435_437_int.c:38
RESET
@ RESET
Definition: at32f435_437.h:378
tmr_channel_value_get
uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value
Definition: at32f435_437_tmr.c:593
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f435_437_tmr.c:1463
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f435_437_tmr.c:1424
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f435_437_tmr.h:221
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f435_437_tmr.h:223
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f435_437_tmr.h:219
TMR_C1_FLAG
#define TMR_C1_FLAG
Definition: at32f435_437_tmr.h:53
TMR_C2_FLAG
#define TMR_C2_FLAG
Definition: at32f435_437_tmr.h:54
TMR_C3_FLAG
#define TMR_C3_FLAG
Definition: at32f435_437_tmr.h:55
TMR_C4_FLAG
#define TMR_C4_FLAG
Definition: at32f435_437_tmr.h:56
TMR3
#define TMR3
Definition: at32f435_437_tmr.h:897
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr3
  • src
Functions | Variables
project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
void | nvic_configuration (void)
configures sdio1 irq channel. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
__IO uint16_t | ccr1_val = 32768
__IO uint16_t | ccr2_val = 16384
__IO uint16_t | ccr3_val = 8192
__IO uint16_t | ccr4_val = 4096
uint16_t | prescalervalue = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr3
  • src
project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 tmr_output_config_type tmr_oc_init_structure;
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40__IO uint16_t ccr1_val = 32768;
41__IO uint16_t ccr2_val = 16384;
42__IO uint16_t ccr3_val = 8192;
43__IO uint16_t ccr4_val = 4096;
44uint16_t prescalervalue = 0;
45
46void crm_configuration(void);
47void gpio_configuration(void);
48void nvic_configuration(void);
49
55int main(void)
56{
57 system_clock_config();
58
59 /* system peripheral configuration */
60 crm_configuration();
61
62 /* get system clock */
63 crm_clocks_freq_get(&crm_clocks_freq_struct);
64
65 /* nvic configuration */
66 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
67 nvic_irq_enable(TMR3_GLOBAL_IRQn, 1, 0);
68
69 /* gpio configuration */
70 gpio_configuration();
71
72 /* ---------------------------------------------------------------------------
73 tmr3 configuration: output compare toggle mode:
74 tmr3clk = apb1_freq * 2,
75 the objective is to get tmr3 counter clock at 24 mhz:
76 - prescaler = (tmr3clk / tmr3 counter clock) - 1
77 cc1 update rate = tmr3 counter clock / ccr1_val / 2 = 366.2 hz
78 cc2 update rate = tmr3 counter clock / ccr2_val / 2 = 732.4 hz
79 cc3 update rate = tmr3 counter clock / ccr3_val / 2 = 1464.8 hz
80 cc4 update rate = tmr3 counter clock / ccr4_val / 2 = 2929.6 hz
81 ----------------------------------------------------------------------------*/
82 /* compute the prescaler value */
83 prescalervalue = (uint16_t) ((crm_clocks_freq_struct.apb1_freq * 2) / 24000000) - 1;
84
85 /* tmre base configuration */
86 tmr_base_init(TMR3, 65535, prescalervalue);
87 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
88 tmr_clock_source_div_set(TMR3, TMR_CLOCK_DIV1);
89
90 /* output compare toggle mode configuration: channel1 */
91 tmr_output_default_para_init(&tmr_oc_init_structure);
92 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_SWITCH;
93 tmr_oc_init_structure.oc_idle_state = FALSE;
94 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
95 tmr_oc_init_structure.oc_output_state = TRUE;
96 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
97 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_1, ccr1_val);
98
99 /* output compare toggle mode configuration: channel2 */
100 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_2, &tmr_oc_init_structure);
101 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_2, ccr2_val);
102
103 /* output compare toggle mode configuration: channel3 */
104 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_3, &tmr_oc_init_structure);
105 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_3, ccr3_val);
106
107 /* output compare toggle mode configuration: channel4 */
108 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_4, &tmr_oc_init_structure);
109 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_4, ccr4_val);
110
111 /* tmr enable counter */
112 tmr_counter_enable(TMR3, TRUE);
113
114 /* tmr it enable */
115 tmr_interrupt_enable(TMR3, TMR_C1_INT | TMR_C2_INT | TMR_C3_INT | TMR_C4_INT, TRUE);
116
117 while(1)
118 {}
119}
120
126void gpio_configuration(void)
127{
128 gpio_init_type gpio_init_struct;
129
130 /* gpioa configuration:tmr3 channel1, 2, 3 and 4 as alternate function push-pull */
131 gpio_default_para_init(&gpio_init_struct);
132 gpio_init_struct.gpio_pins = GPIO_PINS_6 | GPIO_PINS_7;
133 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
134 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
135 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
136 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
137
138 gpio_init(GPIOA, &gpio_init_struct);
139
140 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
141 gpio_init(GPIOB, &gpio_init_struct);
142
143 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE6, GPIO_MUX_2);
144 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE7, GPIO_MUX_2);
145 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE0, GPIO_MUX_2);
146 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE1, GPIO_MUX_2);
147}
148
154void crm_configuration(void)
155{
156 /* tmr3 clock enable */
157 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
158
159 /* gpioa clock enable */
160 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
161 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
162}
163
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
ccr2_val
__IO uint16_t ccr2_val
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c:41
ccr3_val
__IO uint16_t ccr3_val
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c:42
ccr1_val
__IO uint16_t ccr1_val
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c:40
prescalervalue
uint16_t prescalervalue
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c:44
nvic_configuration
void nvic_configuration(void)
configures sdio1 irq channel.
Definition: project/at_start_f437/examples/sdio/sd_mmc_card/src/main.c:247
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c:55
gpio_configuration
void gpio_configuration(void)
configure the tmr3 pins.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c:126
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c:38
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c:154
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c:39
ccr4_val
__IO uint16_t ccr4_val
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr3/src/main.c:43
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:129
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_2
@ GPIO_MUX_2
Definition: at32f435_437_gpio.h:158
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f435_437_tmr.c:1389
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f435_437_tmr.h:221
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f435_437_tmr.h:223
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f435_437_tmr.h:219
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f435_437_tmr.h:97
TMR_OUTPUT_CONTROL_SWITCH
@ TMR_OUTPUT_CONTROL_SWITCH
Definition: at32f435_437_tmr.h:177
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f435_437_tmr.h:199
TMR_C3_INT
#define TMR_C3_INT
Definition: at32f435_437_tmr.h:78
TMR_C4_INT
#define TMR_C4_INT
Definition: at32f435_437_tmr.h:79
TMR_C1_INT
#define TMR_C1_INT
Definition: at32f435_437_tmr.h:76
TMR_C2_INT
#define TMR_C2_INT
Definition: at32f435_437_tmr.h:77
TMR3
#define TMR3
Definition: at32f435_437_tmr.h:897
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f435_437.h:177
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f435_437_crm.h:792
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr9
  • inc
project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr9
  • inc
project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr9
  • inc
project/at_start_f435/examples/tmr/oc_toggle_tmr9/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr9
  • src
Functions
project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr9
  • src
project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr9
  • src
Functions | Variables
project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR1_BRK_TMR9_IRQHandler (void)
this function handles TMR9 global interrupt request. More...

Variables

uint16_t | capture = 0
__IO uint16_t | ccr1_val
__IO uint16_t | ccr2_val

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr9
  • src
project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
38uint16_t capture = 0;
39extern __IO uint16_t ccr1_val;
40extern __IO uint16_t ccr2_val;
41
47void NMI_Handler(void)
48{
49}
50
56void HardFault_Handler(void)
57{
58 /* go to infinite loop when hard fault exception occurs */
59 while(1)
60 {
61 }
62}
63
69void MemManage_Handler(void)
70{
71 /* go to infinite loop when memory manage exception occurs */
72 while(1)
73 {
74 }
75}
76
82void BusFault_Handler(void)
83{
84 /* go to infinite loop when bus fault exception occurs */
85 while(1)
86 {
87 }
88}
89
95void UsageFault_Handler(void)
96{
97 /* go to infinite loop when usage fault exception occurs */
98 while(1)
99 {
100 }
101}
102
108void SVC_Handler(void)
109{
110}
111
117void DebugMon_Handler(void)
118{
119}
120
126void PendSV_Handler(void)
127{
128}
129
135void SysTick_Handler(void)
136{
137}
138
144void TMR1_BRK_TMR9_IRQHandler(void)
145{
146 /* TMR9_CH1 toggling with frequency = 366.2 Hz */
147 if (tmr_flag_get(TMR9, TMR_C1_FLAG) != RESET)
148 {
149 tmr_flag_clear(TMR9, TMR_C1_FLAG );
150 capture = tmr_channel_value_get(TMR9, TMR_SELECT_CHANNEL_1);
151 tmr_channel_value_set(TMR9, TMR_SELECT_CHANNEL_1, capture + ccr1_val);
152 }
153
154 /* TMR9_CH2 toggling with frequency = 732.4 Hz */
155 if (tmr_flag_get(TMR9, TMR_C2_FLAG) != RESET)
156 {
157 tmr_flag_clear(TMR9, TMR_C2_FLAG);
158 capture = tmr_channel_value_get(TMR9, TMR_SELECT_CHANNEL_2);
159 tmr_channel_value_set(TMR9, TMR_SELECT_CHANNEL_2, capture + ccr2_val);
160 }
161}
162
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c:95
ccr2_val
__IO uint16_t ccr2_val
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/main.c:42
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c:56
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c:69
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c:108
ccr1_val
__IO uint16_t ccr1_val
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/main.c:41
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c:126
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c:47
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c:82
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c:135
TMR1_BRK_TMR9_IRQHandler
void TMR1_BRK_TMR9_IRQHandler(void)
this function handles TMR9 global interrupt request.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c:144
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c:117
capture
uint16_t capture
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/at32f435_437_int.c:38
RESET
@ RESET
Definition: at32f435_437.h:378
tmr_channel_value_get
uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value
Definition: at32f435_437_tmr.c:593
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f435_437_tmr.c:1463
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f435_437_tmr.c:1424
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f435_437_tmr.h:219
TMR_C1_FLAG
#define TMR_C1_FLAG
Definition: at32f435_437_tmr.h:53
TMR_C2_FLAG
#define TMR_C2_FLAG
Definition: at32f435_437_tmr.h:54
TMR9
#define TMR9
Definition: at32f435_437_tmr.h:903
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr9
  • src
Functions | Variables
project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr9 pins. More...
void | nvic_configuration (void)
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
__IO uint16_t | ccr1_val = 32768
__IO uint16_t | ccr2_val = 16384
uint16_t | prescalervalue = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • oc_toggle_tmr9
  • src
project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 tmr_output_config_type tmr_oc_init_structure;
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40__IO uint16_t ccr1_val = 32768;
41__IO uint16_t ccr2_val = 16384;
42uint16_t prescalervalue = 0;
43
44void crm_configuration(void);
45void gpio_configuration(void);
46void nvic_configuration(void);
47
53int main(void)
54{
55 system_clock_config();
56
57 /* system peripheral configuration */
58 crm_configuration();
59
60 /* get system clock */
61 crm_clocks_freq_get(&crm_clocks_freq_struct);
62
63 /* nvic configuration */
64 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
65 nvic_irq_enable(TMR1_BRK_TMR9_IRQn, 1, 0);
66
67 /* gpio configuration */
68 gpio_configuration();
69
70 /* ---------------------------------------------------------------------------
71 tmr9 configuration: output compare toggle mode:
72 tmr9clk = system_core_clock (240mhz),
73 the objective is to get tmr9 counter clock at 24 mhz:
74 - prescalervalue = (tmr9clk / tmr9 counter clock) - 1
75 cc1 update rate = tmr9 counter clock / ccr1val / 2 = 366.2 hz
76 cc2 update rate = tmr9 counter clock / ccr2val / 2 = 732.4 hz
77 ----------------------------------------------------------------------------*/
78 /* compute the prescaler value */
79 prescalervalue = (uint16_t) ((crm_clocks_freq_struct.apb1_freq * 2) / 24000000) - 1;
80
81 /* tmr base configuration */
82 tmr_base_init(TMR9, 65535, prescalervalue);
83 tmr_cnt_dir_set(TMR9, TMR_COUNT_UP);
84 tmr_clock_source_div_set(TMR9, TMR_CLOCK_DIV1);
85
86 /* output compare toggle mode configuration: channel1 */
87 tmr_output_default_para_init(&tmr_oc_init_structure);
88 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_SWITCH;
89 tmr_oc_init_structure.oc_idle_state = FALSE;
90 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
91 tmr_oc_init_structure.oc_output_state = TRUE;
92 tmr_output_channel_config(TMR9, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
93 tmr_channel_value_set(TMR9, TMR_SELECT_CHANNEL_1, ccr1_val);
94
95 /* output toggle mode configuration: channel2 */
96 tmr_output_channel_config(TMR9, TMR_SELECT_CHANNEL_2, &tmr_oc_init_structure);
97 tmr_channel_value_set(TMR9, TMR_SELECT_CHANNEL_2, ccr2_val);
98
99 /* tmr enable counter */
100 tmr_counter_enable(TMR9, TRUE);
101
102 /* tmr interrupt enable */
103 tmr_interrupt_enable(TMR9, TMR_C1_INT | TMR_C2_INT | TMR_C3_INT | TMR_C4_INT, TRUE);
104
105 while(1)
106 {}
107}
108
114void gpio_configuration(void)
115{
116 gpio_init_type gpio_init_struct;
117
118 /* gpioa configuration:tmr9 channel1 and 2 as alternate function push-pull */
119 gpio_default_para_init(&gpio_init_struct);
120 gpio_init_struct.gpio_pins = GPIO_PINS_2 | GPIO_PINS_3;
121 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
122 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
123 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
124 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
125
126 gpio_init(GPIOA, &gpio_init_struct);
127 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE2, GPIO_MUX_3);
128 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE3, GPIO_MUX_3);
129}
130
136void crm_configuration(void)
137{
138 /* tmr9 clock enable */
139 crm_periph_clock_enable(CRM_TMR9_PERIPH_CLOCK, TRUE);
140
141 /* gpioa clock enable */
142 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
143}
144
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
ccr2_val
__IO uint16_t ccr2_val
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c:41
ccr1_val
__IO uint16_t ccr1_val
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c:40
prescalervalue
uint16_t prescalervalue
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c:42
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c:53
gpio_configuration
void gpio_configuration(void)
configure the tmr9 pins.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c:114
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c:38
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c:136
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/tmr/oc_toggle_tmr9/src/main.c:39
nvic_configuration
void nvic_configuration(void)
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_TMR9_PERIPH_CLOCK
@ CRM_TMR9_PERIPH_CLOCK
Definition: at32f435_437_crm.h:164
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_3
@ GPIO_MUX_3
Definition: at32f435_437_gpio.h:159
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f435_437_tmr.c:1389
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f435_437_tmr.h:219
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f435_437_tmr.h:97
TMR_OUTPUT_CONTROL_SWITCH
@ TMR_OUTPUT_CONTROL_SWITCH
Definition: at32f435_437_tmr.h:177
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f435_437_tmr.h:199
TMR_C3_INT
#define TMR_C3_INT
Definition: at32f435_437_tmr.h:78
TMR_C4_INT
#define TMR_C4_INT
Definition: at32f435_437_tmr.h:79
TMR_C1_INT
#define TMR_C1_INT
Definition: at32f435_437_tmr.h:76
TMR_C2_INT
#define TMR_C2_INT
Definition: at32f435_437_tmr.h:77
TMR9
#define TMR9
Definition: at32f435_437_tmr.h:903
TMR1_BRK_TMR9_IRQn
@ TMR1_BRK_TMR9_IRQn
Definition: at32f435_437.h:172
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f435_437_crm.h:792
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • one_cycle
  • inc
project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • one_cycle
  • inc
project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • one_cycle
  • inc
project/at_start_f435/examples/tmr/one_cycle/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • one_cycle
  • src
Functions
project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • one_cycle
  • src
project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • one_cycle
  • src
Functions
project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • one_cycle
  • src
project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/one_cycle/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • one_cycle
  • src
Functions | Variables
project/at_start_f435/examples/tmr/one_cycle/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
tmr_input_config_type tmr_ic_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | prescalervalue = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/one_cycle/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • one_cycle
  • src
project/at_start_f435/examples/tmr/one_cycle/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 tmr_output_config_type tmr_oc_init_structure;
39 tmr_input_config_type tmr_ic_init_structure;
40 crm_clocks_freq_type crm_clocks_freq_struct = {0};
41uint16_t prescalervalue = 0;
42
43void crm_configuration(void);
44void gpio_configuration(void);
45
51int main(void)
52{
53 system_clock_config();
54
55 /* system peripheral configuration */
56 crm_configuration();
57
58 /* get system clock */
59 crm_clocks_freq_get(&crm_clocks_freq_struct);
60
61 /* gpio configuration */
62 gpio_configuration();
63
64 /* compute the prescaler value */
65 prescalervalue = (uint16_t) ((crm_clocks_freq_struct.apb1_freq * 2) / 24000000) - 1;
66
67 /* tmr base configuration */
68 tmr_base_init(TMR4, 65535, prescalervalue);
69 tmr_cnt_dir_set(TMR4, TMR_COUNT_UP);
70 tmr_clock_source_div_set(TMR4, TMR_CLOCK_DIV1);
71
72 /* output compare toggle mode configuration: channel1 */
73 tmr_output_default_para_init(&tmr_oc_init_structure);
74 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_B;
75 tmr_oc_init_structure.oc_idle_state = FALSE;
76 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
77 tmr_oc_init_structure.oc_output_state = TRUE;
78 tmr_output_channel_config(TMR4, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
79 tmr_channel_value_set(TMR4, TMR_SELECT_CHANNEL_1, 16383);
80
81 tmr_input_default_para_init(&tmr_ic_init_structure);
82 tmr_ic_init_structure.input_filter_value = 0;
83 tmr_ic_init_structure.input_channel_select = TMR_SELECT_CHANNEL_2;
84 tmr_ic_init_structure.input_mapped_select = TMR_CC_CHANNEL_MAPPED_DIRECT;
85 tmr_ic_init_structure.input_polarity_select = TMR_INPUT_RISING_EDGE;
86 tmr_input_channel_init(TMR4, &tmr_ic_init_structure, TMR_CHANNEL_INPUT_DIV_1);
87
88 /* one cycle mode selection */
89 tmr_one_cycle_mode_enable(TMR4, TRUE);
90
91 /* input trigger selection */
92 tmr_trigger_input_select(TMR4, TMR_SUB_INPUT_SEL_C2DF2);
93
94 /* slave mode selection: trigger mode */
95 tmr_sub_mode_select(TMR4, TMR_SUB_TRIGGER_MODE);
96
97 while(1)
98 {}
99}
100
106void gpio_configuration(void)
107{
108 gpio_init_type gpio_init_struct;
109
110 gpio_default_para_init(&gpio_init_struct);
111 /* tmr4_ch2 pin (pb.07) configuration */
112 gpio_init_struct.gpio_pins = GPIO_PINS_7;
113 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
114 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
115 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
116 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
117 gpio_init(GPIOB, &gpio_init_struct);
118
119 /* tmr4_ch1 pin (pb.06) configuration */
120 gpio_init_struct.gpio_pins = GPIO_PINS_6;
121 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
122 gpio_init(GPIOB, &gpio_init_struct);
123
124 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE6, GPIO_MUX_2);
125 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE7, GPIO_MUX_2);
126}
127
133void crm_configuration(void)
134{
135 /* tmr3 clock enable */
136 crm_periph_clock_enable(CRM_TMR4_PERIPH_CLOCK, TRUE);
137
138 /* gpioa clock enable */
139 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
140}
141
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
prescalervalue
uint16_t prescalervalue
Definition: project/at_start_f435/examples/tmr/one_cycle/src/main.c:41
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/one_cycle/src/main.c:51
gpio_configuration
void gpio_configuration(void)
configure the tmr3 pins.
Definition: project/at_start_f435/examples/tmr/one_cycle/src/main.c:106
tmr_ic_init_structure
tmr_input_config_type tmr_ic_init_structure
Definition: project/at_start_f435/examples/tmr/one_cycle/src/main.c:39
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f435/examples/tmr/one_cycle/src/main.c:38
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f435/examples/tmr/one_cycle/src/main.c:133
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/tmr/one_cycle/src/main.c:40
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_TMR4_PERIPH_CLOCK
@ CRM_TMR4_PERIPH_CLOCK
Definition: at32f435_437_crm.h:130
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_2
@ GPIO_MUX_2
Definition: at32f435_437_gpio.h:158
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_input_channel_init
void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel
Definition: at32f435_437_tmr.c:872
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f435_437_tmr.c:1245
tmr_input_default_para_init
void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct)
init tmr input default para
Definition: at32f435_437_tmr.c:169
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f435_437_tmr.c:1322
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_one_cycle_mode_enable
void tmr_one_cycle_mode_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr one cycle mode
Definition: at32f435_437_tmr.c:805
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f435_437_tmr.h:207
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f435_437_tmr.h:219
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f435_437_tmr.h:241
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f435_437_tmr.h:97
TMR_OUTPUT_CONTROL_PWM_MODE_B
@ TMR_OUTPUT_CONTROL_PWM_MODE_B
Definition: at32f435_437_tmr.h:181
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:198
TMR_SUB_INPUT_SEL_C2DF2
@ TMR_SUB_INPUT_SEL_C2DF2
Definition: at32f435_437_tmr.h:140
TMR_SUB_TRIGGER_MODE
@ TMR_SUB_TRIGGER_MODE
Definition: at32f435_437_tmr.h:155
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f435_437_tmr.h:251
TMR4
#define TMR4
Definition: at32f435_437_tmr.h:898
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f435_437_crm.h:792
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_input_config_type
tmr input capture config type
Definition: at32f435_437_tmr.h:425
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f435_437_tmr.h:428
tmr_input_config_type::input_filter_value
uint8_t input_filter_value
Definition: at32f435_437_tmr.h:429
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f435_437_tmr.h:427
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f435_437_tmr.h:426
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • parallel_synchro
  • inc
project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • parallel_synchro
  • inc
project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • parallel_synchro
  • inc
project/at_start_f435/examples/tmr/parallel_synchro/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • parallel_synchro
  • src
Functions
project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • parallel_synchro
  • src
project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • parallel_synchro
  • src
Functions
project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • parallel_synchro
  • src
project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/parallel_synchro/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • parallel_synchro
  • src
Functions | Variables
project/at_start_f435/examples/tmr/parallel_synchro/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timerperiod = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/parallel_synchro/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • parallel_synchro
  • src
project/at_start_f435/examples/tmr/parallel_synchro/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 tmr_output_config_type tmr_oc_init_structure;
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40uint16_t timerperiod = 0;
41
42void crm_configuration(void);
43void gpio_configuration(void);
44
50int main(void)
51{
52 system_clock_config();
53
54 /* system peripheral configuration */
55 crm_configuration();
56
57 /* get system clock */
58 crm_clocks_freq_get(&crm_clocks_freq_struct);
59
60 /* gpio configuration */
61 gpio_configuration();
62
63 /* tmr base configuration */
64 timerperiod = ((crm_clocks_freq_struct.apb1_freq * 2) / 750000 ) - 1;
65 tmr_base_init(TMR2, timerperiod, 0);
66 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
67 tmr_clock_source_div_set(TMR2, TMR_CLOCK_DIV1);
68 tmr_base_init(TMR3, 9, 0);
69 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
70 tmr_clock_source_div_set(TMR3, TMR_CLOCK_DIV1);
71 tmr_base_init(TMR4, 4, 0);
72 tmr_cnt_dir_set(TMR4, TMR_COUNT_UP);
73 tmr_clock_source_div_set(TMR4, TMR_CLOCK_DIV1);
74
75 /* output compare toggle mode configuration: channel1 */
76 tmr_output_default_para_init(&tmr_oc_init_structure);
77 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
78 tmr_oc_init_structure.oc_idle_state = FALSE;
79 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
80 tmr_oc_init_structure.oc_output_state = TRUE;
81 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
82 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_1, timerperiod/5);
83
84 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
85 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_1, 3);
86
87 tmr_output_channel_config(TMR4, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
88 tmr_channel_value_set(TMR4, TMR_SELECT_CHANNEL_1, 3);
89
90 /* primary mode selection: TMR2 */
91 tmr_sub_sync_mode_set(TMR2, TRUE);
92 tmr_primary_mode_select(TMR2, TMR_PRIMARY_SEL_OVERFLOW);
93
94 /* subordinate mode selection: TMR3 */
95 tmr_sub_mode_select(TMR3, TMR_SUB_HANG_MODE);
96 tmr_trigger_input_select(TMR3, TMR_SUB_INPUT_SEL_IS1);
97 /* subordinate mode selection: TMR4 */
98 tmr_sub_mode_select(TMR4, TMR_SUB_HANG_MODE);
99 tmr_trigger_input_select(TMR4, TMR_SUB_INPUT_SEL_IS1);
100
101 /* tmr enable counter */
102 tmr_counter_enable(TMR2, TRUE);
103 tmr_counter_enable(TMR3, TRUE);
104 tmr_counter_enable(TMR4, TRUE);
105
106 while(1)
107 {}
108}
109
115void gpio_configuration(void)
116{
117 gpio_init_type gpio_init_struct;
118
119 gpio_default_para_init(&gpio_init_struct);
120
121 gpio_init_struct.gpio_pins = GPIO_PINS_6 | GPIO_PINS_0;
122 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
123 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
124 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
125 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
126 gpio_init(GPIOA, &gpio_init_struct);
127
128 gpio_init_struct.gpio_pins = GPIO_PINS_6;
129 gpio_init(GPIOB, &gpio_init_struct);
130
131 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE0, GPIO_MUX_1);
132 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE6, GPIO_MUX_2);
133 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE6, GPIO_MUX_2);
134}
135
141void crm_configuration(void)
142{
143 /* tmr3 clock enable */
144 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
145 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
146 crm_periph_clock_enable(CRM_TMR4_PERIPH_CLOCK, TRUE);
147
148 /* gpios clock enable */
149 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
150 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
151 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
152}
153
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
timerperiod
uint16_t timerperiod
Definition: project/at_start_f435/examples/tmr/parallel_synchro/src/main.c:40
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/parallel_synchro/src/main.c:50
gpio_configuration
void gpio_configuration(void)
configure the tmr3 pins.
Definition: project/at_start_f435/examples/tmr/parallel_synchro/src/main.c:115
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f435/examples/tmr/parallel_synchro/src/main.c:38
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f435/examples/tmr/parallel_synchro/src/main.c:141
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/tmr/parallel_synchro/src/main.c:39
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:128
CRM_TMR4_PERIPH_CLOCK
@ CRM_TMR4_PERIPH_CLOCK
Definition: at32f435_437_crm.h:130
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:129
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_2
@ GPIO_MUX_2
Definition: at32f435_437_gpio.h:158
GPIO_MUX_1
@ GPIO_MUX_1
Definition: at32f435_437_gpio.h:157
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f435_437_tmr.c:1245
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_sub_sync_mode_set
void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode
Definition: at32f435_437_tmr.c:1335
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f435_437_tmr.c:1322
tmr_primary_mode_select
void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode
Definition: at32f435_437_tmr.c:1222
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f435_437_tmr.h:97
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f435_437_tmr.h:180
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:198
TMR_SUB_INPUT_SEL_IS1
@ TMR_SUB_INPUT_SEL_IS1
Definition: at32f435_437_tmr.h:135
TMR_SUB_HANG_MODE
@ TMR_SUB_HANG_MODE
Definition: at32f435_437_tmr.h:154
TMR_PRIMARY_SEL_OVERFLOW
@ TMR_PRIMARY_SEL_OVERFLOW
Definition: at32f435_437_tmr.h:121
TMR3
#define TMR3
Definition: at32f435_437_tmr.h:897
TMR2
#define TMR2
Definition: at32f435_437_tmr.h:896
TMR4
#define TMR4
Definition: at32f435_437_tmr.h:898
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f435_437_crm.h:792
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_input
  • inc
project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_input
  • inc
project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_input
  • inc
project/at_start_f435/examples/tmr/pwm_input/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_input
  • src
Functions
project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_input
  • src
project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_input
  • src
Functions | Variables
project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR3_GLOBAL_IRQHandler (void)
this function handles tmr3 global interrupt request. More...

Variables

__IO uint16_t | ic2value = 0
uint16_t | dutycycle
uint32_t | frequency

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_input
  • src
project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
38__IO uint16_t ic2value = 0;
39extern uint16_t dutycycle;
40extern uint32_t frequency;
41
47void NMI_Handler(void)
48{
49}
50
56void HardFault_Handler(void)
57{
58 /* go to infinite loop when hard fault exception occurs */
59 while(1)
60 {
61 }
62}
63
69void MemManage_Handler(void)
70{
71 /* go to infinite loop when memory manage exception occurs */
72 while(1)
73 {
74 }
75}
76
82void BusFault_Handler(void)
83{
84 /* go to infinite loop when bus fault exception occurs */
85 while(1)
86 {
87 }
88}
89
95void UsageFault_Handler(void)
96{
97 /* go to infinite loop when usage fault exception occurs */
98 while(1)
99 {
100 }
101}
102
108void SVC_Handler(void)
109{
110}
111
117void DebugMon_Handler(void)
118{
119}
120
126void PendSV_Handler(void)
127{
128}
129
135void SysTick_Handler(void)
136{
137}
138
144void TMR3_GLOBAL_IRQHandler(void)
145{
146 /* clear tmr3 channel interrupt pending bit */
147 tmr_flag_clear(TMR3, TMR_C2_FLAG);
148
149 /* get the input channel data value */
150 ic2value = tmr_channel_value_get(TMR3, TMR_SELECT_CHANNEL_2);
151
152 if (ic2value != 0)
153 {
154 /* duty cycle computation */
155 dutycycle = (tmr_channel_value_get(TMR3, TMR_SELECT_CHANNEL_1) * 100) / ic2value;
156
157 /* frequency computation */
158 frequency = system_core_clock / ic2value;
159 }
160 else
161 {
162 dutycycle = 0;
163 frequency = 0;
164 }
165}
166
dutycycle
uint16_t dutycycle
Definition: project/at_start_f435/examples/tmr/pwm_input/src/main.c:40
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c:95
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c:56
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c:69
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c:108
ic2value
__IO uint16_t ic2value
Definition: project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c:38
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c:126
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c:47
TMR3_GLOBAL_IRQHandler
void TMR3_GLOBAL_IRQHandler(void)
this function handles tmr3 global interrupt request.
Definition: project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c:144
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c:82
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c:135
frequency
uint32_t frequency
Definition: project/at_start_f435/examples/tmr/pwm_input/src/main.c:41
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/pwm_input/src/at32f435_437_int.c:117
system_core_clock
unsigned int system_core_clock
Definition: system_at32f435_437.c:48
tmr_channel_value_get
uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value
Definition: at32f435_437_tmr.c:593
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f435_437_tmr.c:1463
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f435_437_tmr.h:219
TMR_C2_FLAG
#define TMR_C2_FLAG
Definition: at32f435_437_tmr.h:54
TMR3
#define TMR3
Definition: at32f435_437_tmr.h:897
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_input
  • src
Functions | Variables
project/at_start_f435/examples/tmr/pwm_input/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
Configure the TMR3 Pins. More...
int | main (void)
main function. More...

Variables

tmr_input_config_type tmr_ic_init_structure
__IO uint16_t | dutycycle = 0
__IO uint32_t | frequency = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_input/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_input
  • src
project/at_start_f435/examples/tmr/pwm_input/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 tmr_input_config_type tmr_ic_init_structure;
39
40__IO uint16_t dutycycle = 0;
41__IO uint32_t frequency = 0;
42
43void crm_configuration(void);
44void gpio_configuration(void);
45
51int main(void)
52{
53 system_clock_config();
54
55 /* system peripheral configuration */
56 crm_configuration();
57
58 /* nvic configuration */
59 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
60 nvic_irq_enable(TMR3_GLOBAL_IRQn, 1, 0);
61
62 /* gpio configuration */
63 gpio_configuration();
64
65 uart_print_init(115200);
66
67 tmr_input_default_para_init(&tmr_ic_init_structure);
68 tmr_ic_init_structure.input_filter_value = 0;
69 tmr_ic_init_structure.input_channel_select = TMR_SELECT_CHANNEL_2;
70 tmr_ic_init_structure.input_mapped_select = TMR_CC_CHANNEL_MAPPED_DIRECT;
71 tmr_ic_init_structure.input_polarity_select = TMR_INPUT_RISING_EDGE;
72
73 tmr_pwm_input_config(TMR3, &tmr_ic_init_structure, TMR_CHANNEL_INPUT_DIV_1);
74
75 /* select the tmr3 input trigger: C2IF2 */
76 tmr_trigger_input_select(TMR3, TMR_SUB_INPUT_SEL_C2DF2);
77
78 /* select the sub mode: reset mode */
79 tmr_sub_mode_select(TMR3, TMR_SUB_RESET_MODE);
80
81 /* enable the sub sync mode */
82 tmr_sub_sync_mode_set(TMR3, TRUE);
83
84 /* tmr enable counter */
85 tmr_counter_enable(TMR3, TRUE);
86
87 /* enable the c2 interrupt request */
88 tmr_interrupt_enable(TMR3, TMR_C2_INT, TRUE);
89
90 while(1)
91 {
92 printf("Frequency = %dHZ,Dutycycle = %d%%\r\n", frequency, dutycycle);
93 }
94}
95
101void gpio_configuration(void)
102{
103 gpio_init_type gpio_init_struct;
104
105 gpio_default_para_init(&gpio_init_struct);
106
107 gpio_init_struct.gpio_pins = GPIO_PINS_7;
108 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
109 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
110 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
111 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
112 gpio_init(GPIOA, &gpio_init_struct);
113
114 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE7, GPIO_MUX_2);
115}
116
122void crm_configuration(void)
123{
124 /* tmr3 clock enable */
125 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
126
127 /* gpioa clock enable */
128 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
129}
130
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/pwm_input/src/main.c:51
gpio_configuration
void gpio_configuration(void)
Configure the TMR3 Pins.
Definition: project/at_start_f435/examples/tmr/pwm_input/src/main.c:101
tmr_ic_init_structure
tmr_input_config_type tmr_ic_init_structure
Definition: project/at_start_f435/examples/tmr/pwm_input/src/main.c:38
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f435/examples/tmr/pwm_input/src/main.c:122
frequency
__IO uint32_t frequency
Definition: project/at_start_f435/examples/tmr/pwm_input/src/main.c:41
dutycycle
__IO uint16_t dutycycle
Definition: project/at_start_f435/examples/tmr/pwm_input/src/main.c:40
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:129
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_2
@ GPIO_MUX_2
Definition: at32f435_437_gpio.h:158
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f435_437_tmr.c:1245
tmr_input_default_para_init
void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct)
init tmr input default para
Definition: at32f435_437_tmr.c:169
tmr_sub_sync_mode_set
void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode
Definition: at32f435_437_tmr.c:1335
tmr_pwm_input_config
void tmr_pwm_input_config(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
config tmr pwm input
Definition: at32f435_437_tmr.c:1042
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f435_437_tmr.c:1322
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f435_437_tmr.c:1389
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f435_437_tmr.h:207
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f435_437_tmr.h:219
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f435_437_tmr.h:241
TMR_SUB_INPUT_SEL_C2DF2
@ TMR_SUB_INPUT_SEL_C2DF2
Definition: at32f435_437_tmr.h:140
TMR_SUB_RESET_MODE
@ TMR_SUB_RESET_MODE
Definition: at32f435_437_tmr.h:153
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f435_437_tmr.h:251
TMR_C2_INT
#define TMR_C2_INT
Definition: at32f435_437_tmr.h:77
TMR3
#define TMR3
Definition: at32f435_437_tmr.h:897
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f435_437.h:177
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_input_config_type
tmr input capture config type
Definition: at32f435_437_tmr.h:425
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f435_437_tmr.h:428
tmr_input_config_type::input_filter_value
uint8_t input_filter_value
Definition: at32f435_437_tmr.h:429
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f435_437_tmr.h:427
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f435_437_tmr.h:426
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_input_dma
  • inc
project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_input_dma
  • inc
project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_input_dma
  • inc
project/at_start_f435/examples/tmr/pwm_input_dma/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_input_dma
  • src
Functions
project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_input_dma
  • src
project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_input_dma
  • src
Functions
project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_input_dma
  • src
project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_input_dma
  • src
Macros | Functions | Variables
project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define | tmr1_c1dt_address 0x40010034
#define | tmr1_c2dt_address 0x40010038
#define | SAMPLING_NUM 1000

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...
void | DMA1_Channel2_IRQHandler (void)

Variables

tmr_input_config_type tmr_ic_init_structure
dma_init_type dma_init_structure
__IO uint16_t | buffer_cc1 [1000]
__IO uint16_t | buffer_cc2 [1000]
__IO uint16_t | ic1value = 0
__IO uint32_t | frequency = 0
__IO float | dutycycle = 0
uint32_t | freq_result
float | duty_result

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_input_dma
  • src
project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define tmr1_c1dt_address 0x40010034
39#define tmr1_c2dt_address 0x40010038
40
41#define SAMPLING_NUM 1000
42
43 tmr_input_config_type tmr_ic_init_structure;
44 dma_init_type dma_init_structure;
45
46__IO uint16_t buffer_cc1[1000];
47__IO uint16_t buffer_cc2[1000];
48
49__IO uint16_t ic1value = 0;
50__IO uint32_t frequency = 0;
51__IO float dutycycle = 0;
52
53uint32_t freq_result;
54float duty_result;
55
56void crm_configuration(void);
57void gpio_configuration(void);
58
64int main(void)
65{
66 system_clock_config();
67
68 /* system peripheral configuration */
69 crm_configuration();
70
71 /* nvic configuration */
72 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
73 nvic_irq_enable(DMA1_Channel2_IRQn, 1, 0);
74
75 /* gpio configuration */
76 gpio_configuration();
77
78 uart_print_init(115200);
79
80 dma_reset(DMA1_CHANNEL2);
81 dma_default_para_init(&dma_init_structure);
82 dma_init_structure.peripheral_base_addr = (uint32_t)tmr1_c1dt_address;
83 dma_init_structure.memory_base_addr = (uint32_t)buffer_cc1;
84 dma_init_structure.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
85 dma_init_structure.buffer_size = SAMPLING_NUM;
86 dma_init_structure.peripheral_inc_enable = FALSE;
87 dma_init_structure.memory_inc_enable = TRUE;
88 dma_init_structure.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
89 dma_init_structure.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
90 dma_init_structure.loop_mode_enable = TRUE;
91 dma_init_structure.priority = DMA_PRIORITY_HIGH;
92 dma_init(DMA1_CHANNEL2, &dma_init_structure);
93
94 dma_reset(DMA1_CHANNEL3);
95 dma_init_structure.peripheral_base_addr = (uint32_t)tmr1_c2dt_address;
96 dma_init_structure.memory_base_addr = (uint32_t)buffer_cc2;
97 dma_init(DMA1_CHANNEL3, &dma_init_structure);
98
99 dma_interrupt_enable(DMA1_CHANNEL2, DMA_FDT_INT, TRUE);
100
101 dmamux_enable(DMA1, TRUE);
102 dmamux_init(DMA1MUX_CHANNEL2, DMAMUX_DMAREQ_ID_TMR1_CH1);
103 dmamux_init(DMA1MUX_CHANNEL3, DMAMUX_DMAREQ_ID_TMR1_CH2);
104
105 dma_channel_enable(DMA1_CHANNEL2, TRUE);
106 dma_channel_enable(DMA1_CHANNEL3, TRUE);
107
108 tmr_input_default_para_init(&tmr_ic_init_structure);
109 tmr_ic_init_structure.input_filter_value = 0;
110 tmr_ic_init_structure.input_channel_select = TMR_SELECT_CHANNEL_1;
111 tmr_ic_init_structure.input_mapped_select = TMR_CC_CHANNEL_MAPPED_DIRECT;
112 tmr_ic_init_structure.input_polarity_select = TMR_INPUT_RISING_EDGE;
113
114 tmr_pwm_input_config(TMR1, &tmr_ic_init_structure, TMR_CHANNEL_INPUT_DIV_1);
115
116 /* select the TMR1 input trigger: C2IF2 */
117 tmr_trigger_input_select(TMR1, TMR_SUB_INPUT_SEL_C1DF1);
118
119 /* select the sub mode: reset mode */
120 tmr_sub_mode_select(TMR1, TMR_SUB_RESET_MODE);
121
122 /* enable the sub sync mode */
123 tmr_sub_sync_mode_set(TMR1, TRUE);
124
125 /* enable the c1/c2 dma */
126 tmr_dma_request_enable(TMR1, TMR_C1_DMA_REQUEST, TRUE);
127 tmr_dma_request_enable(TMR1, TMR_C2_DMA_REQUEST, TRUE);
128
129 /* tmr enable counter */
130 tmr_counter_enable(TMR1, TRUE);
131 printf("\r\nFreq=%dHZ, Duty=%.2f%%\r\n", frequency, dutycycle);
132
133 while(1)
134 {
135 }
136}
137
138void DMA1_Channel2_IRQHandler(void)
139{
140 uint16_t i;
141
142 dma_flag_clear(DMA1_FDT2_FLAG);
143
144 duty_result = 0;
145 freq_result = 0.0;
146
147 for(i = 0; i < SAMPLING_NUM; i++)
148 {
149 duty_result += ((buffer_cc2[i] * 100.0) / buffer_cc1[i]);
150 freq_result += (system_core_clock / buffer_cc1[i]);
151 }
152
153 dutycycle = duty_result / SAMPLING_NUM;
154 frequency = freq_result / SAMPLING_NUM;
155 printf("\r\nFreq=%dHZ, Duty=%.2f%%\r\n", frequency, dutycycle);
156}
157
163void gpio_configuration(void)
164{
165 gpio_init_type gpio_init_struct;
166
167 gpio_default_para_init(&gpio_init_struct);
168
169 gpio_init_struct.gpio_pins = GPIO_PINS_8;
170 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
171 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
172 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
173 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
174 gpio_init(GPIOA, &gpio_init_struct);
175
176 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE8, GPIO_MUX_1);
177}
178
184void crm_configuration(void)
185{
186 /* tmr1 clock enable */
187 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
188
189 /* gpioa clock enable */
190 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
191
192 /* dma clock enable */
193 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
194}
195
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
DMA1_Channel2_IRQHandler
void DMA1_Channel2_IRQHandler(void)
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c:138
dma_init_structure
dma_init_type dma_init_structure
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c:44
tmr1_c2dt_address
#define tmr1_c2dt_address
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c:39
freq_result
uint32_t freq_result
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c:53
duty_result
float duty_result
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c:54
ic1value
__IO uint16_t ic1value
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c:49
tmr1_c1dt_address
#define tmr1_c1dt_address
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c:38
dutycycle
__IO float dutycycle
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c:51
buffer_cc1
__IO uint16_t buffer_cc1[1000]
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c:46
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c:64
gpio_configuration
void gpio_configuration(void)
configure the tmr1 pins.
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c:163
SAMPLING_NUM
#define SAMPLING_NUM
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c:41
tmr_ic_init_structure
tmr_input_config_type tmr_ic_init_structure
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c:43
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c:184
frequency
__IO uint32_t frequency
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c:50
buffer_cc2
__IO uint16_t buffer_cc2[1000]
Definition: project/at_start_f435/examples/tmr/pwm_input_dma/src/main.c:47
system_core_clock
unsigned int system_core_clock
Definition: system_at32f435_437.c:48
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:154
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:163
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f435_437_dma.h:173
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f435_437_dma.h:184
DMAMUX_DMAREQ_ID_TMR1_CH2
@ DMAMUX_DMAREQ_ID_TMR1_CH2
Definition: at32f435_437_dma.h:243
DMAMUX_DMAREQ_ID_TMR1_CH1
@ DMAMUX_DMAREQ_ID_TMR1_CH1
Definition: at32f435_437_dma.h:242
DMA1_FDT2_FLAG
#define DMA1_FDT2_FLAG
Definition: at32f435_437_dma.h:70
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA1MUX_CHANNEL2
#define DMA1MUX_CHANNEL2
Definition: at32f435_437_dma.h:705
DMA1MUX_CHANNEL3
#define DMA1MUX_CHANNEL3
Definition: at32f435_437_dma.h:706
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f435_437_dma.h:698
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f435_437_dma.h:697
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_1
@ GPIO_MUX_1
Definition: at32f435_437_gpio.h:157
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
tmr_dma_request_enable
void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request
Definition: at32f435_437_tmr.c:1358
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f435_437_tmr.c:1245
tmr_input_default_para_init
void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct)
init tmr input default para
Definition: at32f435_437_tmr.c:169
tmr_sub_sync_mode_set
void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode
Definition: at32f435_437_tmr.c:1335
tmr_pwm_input_config
void tmr_pwm_input_config(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
config tmr pwm input
Definition: at32f435_437_tmr.c:1042
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f435_437_tmr.c:1322
TMR_C1_DMA_REQUEST
@ TMR_C1_DMA_REQUEST
Definition: at32f435_437_tmr.h:272
TMR_C2_DMA_REQUEST
@ TMR_C2_DMA_REQUEST
Definition: at32f435_437_tmr.h:273
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f435_437_tmr.h:207
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f435_437_tmr.h:241
TMR_SUB_INPUT_SEL_C1DF1
@ TMR_SUB_INPUT_SEL_C1DF1
Definition: at32f435_437_tmr.h:139
TMR_SUB_RESET_MODE
@ TMR_SUB_RESET_MODE
Definition: at32f435_437_tmr.h:153
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f435_437_tmr.h:251
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
DMA1_Channel2_IRQn
@ DMA1_Channel2_IRQn
Definition: at32f435_437.h:205
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_input_config_type
tmr input capture config type
Definition: at32f435_437_tmr.h:425
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f435_437_tmr.h:428
tmr_input_config_type::input_filter_value
uint8_t input_filter_value
Definition: at32f435_437_tmr.h:429
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f435_437_tmr.h:427
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f435_437_tmr.h:426
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_output_simulate
  • inc
project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_output_simulate
  • inc
project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_output_simulate
  • inc
project/at_start_f435/examples/tmr/pwm_output_simulate/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_simulate
  • src
Functions
project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_output_simulate
  • src
project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_simulate
  • src
Functions | Variables
project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR2_GLOBAL_IRQHandler (void)

Variables

uint16_t | capture = 0
__IO uint16_t | ccr1_val
__IO uint16_t | ccr2_val
__IO uint16_t | ccr3_val
__IO uint16_t | ccr4_val

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_output_simulate
  • src
project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
38uint16_t capture = 0;
39extern __IO uint16_t ccr1_val;
40extern __IO uint16_t ccr2_val;
41extern __IO uint16_t ccr3_val;
42extern __IO uint16_t ccr4_val;
43
49void NMI_Handler(void)
50{
51}
52
58void HardFault_Handler(void)
59{
60 /* go to infinite loop when hard fault exception occurs */
61 while(1)
62 {
63 }
64}
65
71void MemManage_Handler(void)
72{
73 /* go to infinite loop when memory manage exception occurs */
74 while(1)
75 {
76 }
77}
78
84void BusFault_Handler(void)
85{
86 /* go to infinite loop when bus fault exception occurs */
87 while(1)
88 {
89 }
90}
91
97void UsageFault_Handler(void)
98{
99 /* go to infinite loop when usage fault exception occurs */
100 while(1)
101 {
102 }
103}
104
110void SVC_Handler(void)
111{
112}
113
119void DebugMon_Handler(void)
120{
121}
122
128void PendSV_Handler(void)
129{
130}
131
137void SysTick_Handler(void)
138{
139}
140
141void TMR2_GLOBAL_IRQHandler(void)
142{
143 if (tmr_flag_get(TMR2, TMR_C1_FLAG) != RESET)
144 {
145 tmr_flag_clear(TMR2, TMR_C1_FLAG );
146
147 /* Pin PC.06 toggling with frequency = 73.24 Hz */
148 GPIOC->odt ^= GPIO_PINS_6;
149 capture = tmr_channel_value_get(TMR2, TMR_SELECT_CHANNEL_1);
150 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_1, capture + ccr1_val);
151 }
152 else if (tmr_flag_get(TMR2, TMR_C2_FLAG) != RESET)
153 {
154 tmr_flag_clear(TMR2, TMR_C2_FLAG);
155
156 /* Pin PC.06 toggling with frequency = 73.24 Hz */
157 GPIOC->odt ^= GPIO_PINS_7;
158 capture = tmr_channel_value_get(TMR2, TMR_SELECT_CHANNEL_2);
159 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_2, capture + ccr2_val);
160 }
161 else if (tmr_flag_get(TMR2, TMR_C3_FLAG) != RESET)
162 {
163 tmr_flag_clear(TMR2, TMR_C3_FLAG);
164
165 /* Pin PC.06 toggling with frequency = 73.24 Hz */
166 GPIOC->odt ^= GPIO_PINS_8;
167 capture = tmr_channel_value_get(TMR2, TMR_SELECT_CHANNEL_3);
168 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_3, capture + ccr3_val);
169 }
170 else
171 {
172 tmr_flag_clear(TMR2, TMR_C4_FLAG);
173
174 /* Pin PC.06 toggling with frequency = 73.24 Hz */
175 GPIOC->odt ^= GPIO_PINS_9;
176 capture = tmr_channel_value_get(TMR2, TMR_SELECT_CHANNEL_4);
177 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_4, capture + ccr4_val);
178 }
179}
180
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c:97
ccr2_val
__IO uint16_t ccr2_val
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/main.c:42
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c:58
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c:71
ccr3_val
__IO uint16_t ccr3_val
Definition: project/at_start_f435/examples/tmr/oc_high/src/main.c:42
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c:110
TMR2_GLOBAL_IRQHandler
void TMR2_GLOBAL_IRQHandler(void)
Definition: project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c:141
ccr1_val
__IO uint16_t ccr1_val
Definition: project/at_start_f435/examples/irtmr/irtmr_output/src/main.c:41
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c:128
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c:49
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c:84
ccr4_val
__IO uint16_t ccr4_val
Definition: project/at_start_f435/examples/tmr/oc_high/src/main.c:43
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c:137
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c:119
capture
uint16_t capture
Definition: project/at_start_f435/examples/tmr/pwm_output_simulate/src/at32f435_437_int.c:38
RESET
@ RESET
Definition: at32f435_437.h:378
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
tmr_channel_value_get
uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value
Definition: at32f435_437_tmr.c:593
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f435_437_tmr.c:1463
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f435_437_tmr.c:1424
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f435_437_tmr.h:221
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f435_437_tmr.h:223
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f435_437_tmr.h:219
TMR_C1_FLAG
#define TMR_C1_FLAG
Definition: at32f435_437_tmr.h:53
TMR_C2_FLAG
#define TMR_C2_FLAG
Definition: at32f435_437_tmr.h:54
TMR_C3_FLAG
#define TMR_C3_FLAG
Definition: at32f435_437_tmr.h:55
TMR_C4_FLAG
#define TMR_C4_FLAG
Definition: at32f435_437_tmr.h:56
TMR2
#define TMR2
Definition: at32f435_437_tmr.h:896
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_simulate
  • src
Functions | Variables
project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | ccr1_val = 40961
uint16_t | ccr2_val = 27309
uint16_t | ccr3_val = 13654
uint16_t | ccr4_val = 6826
uint16_t | prescalervalue = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_output_simulate
  • src
project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 tmr_output_config_type tmr_oc_init_structure;
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40
41uint16_t ccr1_val = 40961;
42uint16_t ccr2_val = 27309;
43uint16_t ccr3_val = 13654;
44uint16_t ccr4_val = 6826;
45uint16_t prescalervalue = 0;
46
47void crm_configuration(void);
48void gpio_configuration(void);
49
55int main(void)
56{
57 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
58
59 system_clock_config();
60
61 /* system peripheral configuration */
62 crm_configuration();
63
64 /* get system clock */
65 crm_clocks_freq_get(&crm_clocks_freq_struct);
66
67 /* nvic Configuration */
68 nvic_irq_enable(TMR2_GLOBAL_IRQn, 0, 1);
69
70 /* gpio configuration */
71 gpio_configuration();
72
73 /* compute the prescaler value */
74 prescalervalue = (uint16_t) ((crm_clocks_freq_struct.apb1_freq * 2) / 12000000) - 1;
75
76 /* tmr2 time base configuration */
77 tmr_base_init(TMR2, 65535, prescalervalue);
78 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
79 tmr_clock_source_div_set(TMR2, TMR_CLOCK_DIV1);
80
81 tmr_output_default_para_init(&tmr_oc_init_structure);
82 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_OFF;
83 tmr_oc_init_structure.oc_idle_state = FALSE;
84 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
85 tmr_oc_init_structure.oc_output_state = TRUE;
86 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
87 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_1, ccr1_val);
88
89 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_2, &tmr_oc_init_structure);
90 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_2, ccr2_val);
91
92 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_3, &tmr_oc_init_structure);
93 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_3, ccr3_val);
94
95 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_4, &tmr_oc_init_structure);
96 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_4, ccr4_val);
97
98 /* tmr2 int enable */
99 tmr_interrupt_enable(TMR2, TMR_C1_INT | TMR_C2_INT | TMR_C3_INT | TMR_C4_INT, TRUE);
100
101 /* tmr enable counter */
102 tmr_counter_enable(TMR2, TRUE);
103
104 while(1)
105 {
106 }
107}
108
114void gpio_configuration(void)
115{
116 gpio_init_type gpio_init_struct;
117
118 gpio_default_para_init(&gpio_init_struct);
119
120 gpio_init_struct.gpio_pins = GPIO_PINS_6 | GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9;
121 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
122 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
123 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
124 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
125 gpio_init(GPIOC, &gpio_init_struct);
126}
127
133void crm_configuration(void)
134{
135 /* tmr2 clock enable */
136 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
137
138 /* gpioa gpiob clock enable */
139 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
140}
141
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
ccr1_val
uint16_t ccr1_val
Definition: project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c:41
prescalervalue
uint16_t prescalervalue
Definition: project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c:45
ccr2_val
uint16_t ccr2_val
Definition: project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c:42
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c:55
gpio_configuration
void gpio_configuration(void)
configure the tmr1 pins.
Definition: project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c:114
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c:38
ccr4_val
uint16_t ccr4_val
Definition: project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c:44
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c:133
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c:39
ccr3_val
uint16_t ccr3_val
Definition: project/at_start_f435/examples/tmr/pwm_output_simulate/src/main.c:43
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:107
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:128
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOC
#define GPIOC
Definition: at32f435_437_gpio.h:523
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f435_437_tmr.c:1389
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f435_437_tmr.h:221
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f435_437_tmr.h:223
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f435_437_tmr.h:219
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f435_437_tmr.h:97
TMR_OUTPUT_CONTROL_OFF
@ TMR_OUTPUT_CONTROL_OFF
Definition: at32f435_437_tmr.h:174
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:198
TMR_C3_INT
#define TMR_C3_INT
Definition: at32f435_437_tmr.h:78
TMR_C4_INT
#define TMR_C4_INT
Definition: at32f435_437_tmr.h:79
TMR_C1_INT
#define TMR_C1_INT
Definition: at32f435_437_tmr.h:76
TMR_C2_INT
#define TMR_C2_INT
Definition: at32f435_437_tmr.h:77
TMR2
#define TMR2
Definition: at32f435_437_tmr.h:896
TMR2_GLOBAL_IRQn
@ TMR2_GLOBAL_IRQn
Definition: at32f435_437.h:176
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f435_437_crm.h:792
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr3
  • inc
project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr3
  • inc
project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr3
  • inc
project/at_start_f435/examples/tmr/pwm_output_tmr3/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr3
  • src
Functions
project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr3
  • src
project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr3
  • src
Functions
project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr3
  • src
project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr3/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr3
  • src
Functions | Variables
project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | ccr1_val = 333
uint16_t | ccr2_val = 249
uint16_t | ccr3_val = 166
uint16_t | ccr4_val = 83
uint16_t | prescalervalue = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr3
  • src
project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 tmr_output_config_type tmr_oc_init_structure;
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40
41uint16_t ccr1_val = 333;
42uint16_t ccr2_val = 249;
43uint16_t ccr3_val = 166;
44uint16_t ccr4_val = 83;
45uint16_t prescalervalue = 0;
46
47void crm_configuration(void);
48void gpio_configuration(void);
49
55int main(void)
56{
57 system_clock_config();
58
59 /* system peripheral configuration */
60 crm_configuration();
61
62 /* get system clock */
63 crm_clocks_freq_get(&crm_clocks_freq_struct);
64
65 /* gpio configuration */
66 gpio_configuration();
67
68 /* compute the prescaler value */
69 prescalervalue = (uint16_t) ((crm_clocks_freq_struct.apb1_freq * 2) / 24000000) - 1;
70
71 /* tmr3 time base configuration */
72 tmr_base_init(TMR3, 665, prescalervalue);
73 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
74 tmr_clock_source_div_set(TMR3, TMR_CLOCK_DIV1);
75
76 tmr_output_default_para_init(&tmr_oc_init_structure);
77 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
78 tmr_oc_init_structure.oc_idle_state = FALSE;
79 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
80 tmr_oc_init_structure.oc_output_state = TRUE;
81 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
82 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_1, ccr1_val);
83 tmr_output_channel_buffer_enable(TMR3, TMR_SELECT_CHANNEL_1, TRUE);
84
85 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_2, &tmr_oc_init_structure);
86 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_2, ccr2_val);
87 tmr_output_channel_buffer_enable(TMR3, TMR_SELECT_CHANNEL_2, TRUE);
88
89 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_3, &tmr_oc_init_structure);
90 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_3, ccr3_val);
91 tmr_output_channel_buffer_enable(TMR3, TMR_SELECT_CHANNEL_3, TRUE);
92
93 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_4, &tmr_oc_init_structure);
94 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_4, ccr4_val);
95 tmr_output_channel_buffer_enable(TMR3, TMR_SELECT_CHANNEL_4, TRUE);
96
97 tmr_period_buffer_enable(TMR3, TRUE);
98
99 /* tmr enable counter */
100 tmr_counter_enable(TMR3, TRUE);
101
102 while(1)
103 {
104 }
105}
106
112void gpio_configuration(void)
113{
114 gpio_init_type gpio_init_struct;
115
116 gpio_default_para_init(&gpio_init_struct);
117
118 gpio_init_struct.gpio_pins = GPIO_PINS_6 | GPIO_PINS_7;
119 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
120 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
121 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
122 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
123 gpio_init(GPIOA, &gpio_init_struct);
124
125 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
126 gpio_init(GPIOB, &gpio_init_struct);
127
128 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE6, GPIO_MUX_2);
129 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE7, GPIO_MUX_2);
130 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE0, GPIO_MUX_2);
131 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE1, GPIO_MUX_2);
132}
133
139void crm_configuration(void)
140{
141 /* tmr3 clock enable */
142 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
143
144 /* gpioa gpiob clock enable */
145 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
146 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
147}
148
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
ccr1_val
uint16_t ccr1_val
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c:41
prescalervalue
uint16_t prescalervalue
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c:45
ccr2_val
uint16_t ccr2_val
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c:42
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c:55
gpio_configuration
void gpio_configuration(void)
configure the tmr1 pins.
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c:112
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c:38
ccr4_val
uint16_t ccr4_val
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c:44
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c:139
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c:39
ccr3_val
uint16_t ccr3_val
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr3/src/main.c:43
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:129
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_2
@ GPIO_MUX_2
Definition: at32f435_437_gpio.h:158
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
tmr_period_buffer_enable
void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
set tmr period buffer
Definition: at32f435_437_tmr.c:638
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_output_channel_buffer_enable
void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel buffer
Definition: at32f435_437_tmr.c:660
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f435_437_tmr.h:221
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f435_437_tmr.h:223
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f435_437_tmr.h:219
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f435_437_tmr.h:97
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f435_437_tmr.h:180
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:198
TMR3
#define TMR3
Definition: at32f435_437_tmr.h:897
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f435_437_crm.h:792
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr10
  • inc
project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr10
  • inc
project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr10
  • inc
project/at_start_f435/examples/tmr/pwm_output_tmr10/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr10
  • src
Functions
project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr10
  • src
project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr10
  • src
Functions
project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr10
  • src
project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr10/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr10
  • src
Functions | Variables
project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | ccr1_val = 249
uint16_t | prescalervalue = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • pwm_output_tmr10
  • src
project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 tmr_output_config_type tmr_oc_init_structure;
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40
41uint16_t ccr1_val = 249;
42uint16_t prescalervalue = 0;
43
44void crm_configuration(void);
45void gpio_configuration(void);
46
52int main(void)
53{
54 system_clock_config();
55
56 /* system peripheral configuration */
57 crm_configuration();
58
59 /* get system clock */
60 crm_clocks_freq_get(&crm_clocks_freq_struct);
61
62 /* gpio configuration */
63 gpio_configuration();
64
65 /* compute the prescaler value */
66 prescalervalue = (uint16_t) ((crm_clocks_freq_struct.apb2_freq * 2) / 24000000) - 1;
67
68 /* tmr10 time base configuration */
69 tmr_base_init(TMR10, 665, prescalervalue);
70 tmr_cnt_dir_set(TMR10, TMR_COUNT_UP);
71 tmr_clock_source_div_set(TMR10, TMR_CLOCK_DIV1);
72
73 tmr_output_default_para_init(&tmr_oc_init_structure);
74 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
75 tmr_oc_init_structure.oc_idle_state = FALSE;
76 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
77 tmr_oc_init_structure.oc_output_state = TRUE;
78 tmr_output_channel_config(TMR10, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
79 tmr_channel_value_set(TMR10, TMR_SELECT_CHANNEL_1, ccr1_val);
80 tmr_output_channel_buffer_enable(TMR10, TMR_SELECT_CHANNEL_1, TRUE);
81
82 tmr_period_buffer_enable(TMR10, TRUE);
83
84 /* tmr enable counter */
85 tmr_counter_enable(TMR10, TRUE);
86
87 while(1)
88 {
89 }
90}
91
97void gpio_configuration(void)
98{
99 gpio_init_type gpio_init_struct;
100
101 gpio_default_para_init(&gpio_init_struct);
102
103 gpio_init_struct.gpio_pins = GPIO_PINS_8;
104 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
105 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
106 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
107 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
108 gpio_init(GPIOB, &gpio_init_struct);
109
110 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE8, GPIO_MUX_3);
111}
112
118void crm_configuration(void)
119{
120 /* tmr10 clock enable */
121 crm_periph_clock_enable(CRM_TMR10_PERIPH_CLOCK, TRUE);
122
123 /* gpioa gpiob clock enable */
124 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
125}
126
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
ccr1_val
uint16_t ccr1_val
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c:41
prescalervalue
uint16_t prescalervalue
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c:42
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c:52
gpio_configuration
void gpio_configuration(void)
configure the tmr1 pins.
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c:97
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c:38
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c:118
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/tmr/pwm_output_tmr10/src/main.c:39
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_TMR10_PERIPH_CLOCK
@ CRM_TMR10_PERIPH_CLOCK
Definition: at32f435_437_crm.h:165
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_3
@ GPIO_MUX_3
Definition: at32f435_437_gpio.h:159
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
tmr_period_buffer_enable
void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
set tmr period buffer
Definition: at32f435_437_tmr.c:638
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_output_channel_buffer_enable
void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel buffer
Definition: at32f435_437_tmr.c:660
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f435_437_tmr.h:97
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f435_437_tmr.h:180
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:198
TMR10
#define TMR10
Definition: at32f435_437_tmr.h:904
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::apb2_freq
uint32_t apb2_freq
Definition: at32f435_437_crm.h:791
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • timer_base
  • inc
project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • timer_base
  • inc
project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • timer_base
  • inc
project/at_start_f435/examples/tmr/timer_base/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • timer_base
  • src
Functions
project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • timer_base
  • src
project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • timer_base
  • src
Functions
project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • timer_base
  • src
project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/timer_base/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • timer_base
  • src
Functions | Variables
project/at_start_f435/examples/tmr/timer_base/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

int | main (void)
main function. More...
void | TMR1_OVF_TMR10_IRQHandler (void)
this function handles timer1 overflow handler. More...

Variables

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/timer_base/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • timer_base
  • src
project/at_start_f435/examples/tmr/timer_base/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 crm_clocks_freq_type crm_clocks_freq_struct = {0};
39
45int main(void)
46{
47 system_clock_config();
48
49 at32_board_init();
50
51 /* get system clock */
52 crm_clocks_freq_get(&crm_clocks_freq_struct);
53
54 /* turn led2/led3/led4 on */
55 at32_led_on(LED2);
56 at32_led_on(LED3);
57 at32_led_on(LED4);
58
59 /* enable tmr1 clock */
60 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
61
62 /* tmr1 configuration */
63 /* time base configuration */
64 tmr_base_init(TMR1, 9999, (crm_clocks_freq_struct.apb2_freq * 2 / 10000) - 1);
65 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
66
67 /* overflow interrupt enable */
68 tmr_interrupt_enable(TMR1, TMR_OVF_INT, TRUE);
69
70 /* tmr1 hall interrupt nvic init */
71 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
72 nvic_irq_enable(TMR1_OVF_TMR10_IRQn, 1, 0);
73
74 /* enable tmr1 */
75 tmr_counter_enable(TMR1, TRUE);
76
77 while(1)
78 {}
79}
80
86void TMR1_OVF_TMR10_IRQHandler(void)
87{
88 if(tmr_flag_get(TMR1, TMR_OVF_FLAG) == SET)
89 {
90 /* add user code... */
91 at32_led_toggle(LED3);
92 tmr_flag_clear(TMR1, TMR_OVF_FLAG);
93 }
94}
95
at32f435_437_board.h
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/timer_base/src/main.c:45
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/tmr/timer_base/src/main.c:38
TMR1_OVF_TMR10_IRQHandler
void TMR1_OVF_TMR10_IRQHandler(void)
this function handles timer1 overflow handler.
Definition: project/at_start_f435/examples/tmr/timer_base/src/main.c:86
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:154
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f435_437_tmr.c:1463
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f435_437_tmr.c:1424
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f435_437_tmr.c:1389
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_OVF_FLAG
#define TMR_OVF_FLAG
Definition: at32f435_437_tmr.h:52
TMR_OVF_INT
#define TMR_OVF_INT
Definition: at32f435_437_tmr.h:75
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
TMR1_OVF_TMR10_IRQn
@ TMR1_OVF_TMR10_IRQn
Definition: at32f435_437.h:173
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::apb2_freq
uint32_t apb2_freq
Definition: at32f435_437_crm.h:791
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • tmr1_synchro
  • inc
project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • tmr1_synchro
  • inc
project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • tmr1_synchro
  • inc
project/at_start_f435/examples/tmr/tmr1_synchro/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • tmr1_synchro
  • src
Functions
project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • tmr1_synchro
  • src
project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • tmr1_synchro
  • src
Functions
project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • tmr1_synchro
  • src
project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/tmr1_synchro/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • tmr1_synchro
  • src
Functions | Variables
project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timerperiod = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • tmr1_synchro
  • src
project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 tmr_output_config_type tmr_oc_init_structure;
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40uint16_t timerperiod = 0;
41
42void crm_configuration(void);
43void gpio_configuration(void);
44
50int main(void)
51{
52 system_clock_config();
53
54 /* system peripheral configuration */
55 crm_configuration();
56
57 /* get system clock */
58 crm_clocks_freq_get(&crm_clocks_freq_struct);
59
60 /* gpio configuration */
61 gpio_configuration();
62
63 /* tmr3 time base configuration */
64 tmr_base_init(TMR3, 2, 0);
65 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
66 tmr_clock_source_div_set(TMR3, TMR_CLOCK_DIV1);
67
68 tmr_output_default_para_init(&tmr_oc_init_structure);
69 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
70 tmr_oc_init_structure.oc_idle_state = FALSE;
71 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
72 tmr_oc_init_structure.oc_output_state = TRUE;
73 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
74 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_1, 1);
75
76 /* input trigger selection */
77 tmr_trigger_input_select(TMR3, TMR_SUB_INPUT_SEL_IS0);
78
79 /* slave mode selection: hang mode */
80 tmr_sub_mode_select(TMR3, TMR_SUB_HANG_MODE);
81
82 /* tmr4 time base configuration */
83 tmr_base_init(TMR4, 1, 0);
84 tmr_cnt_dir_set(TMR4, TMR_COUNT_UP);
85 tmr_clock_source_div_set(TMR4, TMR_CLOCK_DIV1);
86
87 tmr_output_default_para_init(&tmr_oc_init_structure);
88 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
89 tmr_oc_init_structure.oc_idle_state = FALSE;
90 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
91 tmr_oc_init_structure.oc_output_state = TRUE;
92 tmr_output_channel_config(TMR4, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
93 tmr_channel_value_set(TMR4, TMR_SELECT_CHANNEL_1, 1);
94
95 /* input trigger selection */
96 tmr_trigger_input_select(TMR4, TMR_SUB_INPUT_SEL_IS0);
97
98 /* slave mode selection: hang mode */
99 tmr_sub_mode_select(TMR4, TMR_SUB_HANG_MODE);
100
101 /* tmr1 time base configuration */
102 timerperiod = ((crm_clocks_freq_struct.apb1_freq * 2) / 750000) - 1;
103 tmr_base_init(TMR1, timerperiod, 0);
104 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
105 tmr_clock_source_div_set(TMR1, TMR_CLOCK_DIV1);
106 tmr_repetition_counter_set(TMR1, 4);
107
108 tmr_output_default_para_init(&tmr_oc_init_structure);
109 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_B;
110 tmr_oc_init_structure.oc_idle_state = TRUE;
111 tmr_oc_init_structure.occ_idle_state = FALSE;
112 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
113 tmr_oc_init_structure.occ_polarity = TMR_OUTPUT_ACTIVE_LOW;
114 tmr_oc_init_structure.oc_output_state = TRUE;
115 tmr_oc_init_structure.occ_output_state = TRUE;
116 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
117 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, timerperiod/2);
118
119 tmr_primary_mode_select(TMR1, TMR_PRIMARY_SEL_OVERFLOW);
120 tmr_sub_sync_mode_set(TMR1, TRUE);
121
122 tmr_output_enable(TMR1, TRUE);
123
124 /* tmr enable counter */
125 tmr_counter_enable(TMR1, TRUE);
126 tmr_counter_enable(TMR3, TRUE);
127 tmr_counter_enable(TMR4, TRUE);
128
129 while(1)
130 {
131 }
132}
133
139void gpio_configuration(void)
140{
141 gpio_init_type gpio_init_struct;
142
143 gpio_default_para_init(&gpio_init_struct);
144
145 gpio_init_struct.gpio_pins = GPIO_PINS_6 | GPIO_PINS_8;
146 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
147 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
148 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
149 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
150 gpio_init(GPIOA, &gpio_init_struct);
151
152 gpio_init_struct.gpio_pins = GPIO_PINS_6;
153 gpio_init(GPIOB, &gpio_init_struct);
154
155 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE6, GPIO_MUX_2);
156 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE8, GPIO_MUX_1);
157 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE6, GPIO_MUX_2);
158}
159
165void crm_configuration(void)
166{
167 /* tmr clock enable */
168 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
169 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
170 crm_periph_clock_enable(CRM_TMR4_PERIPH_CLOCK, TRUE);
171
172 /* gpio clock enable */
173 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
174 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
175}
176
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
timerperiod
uint16_t timerperiod
Definition: project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c:40
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c:50
gpio_configuration
void gpio_configuration(void)
configure the tmr1 pins.
Definition: project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c:139
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c:38
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c:165
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/tmr/tmr1_synchro/src/main.c:39
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_TMR4_PERIPH_CLOCK
@ CRM_TMR4_PERIPH_CLOCK
Definition: at32f435_437_crm.h:130
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:129
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:154
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_2
@ GPIO_MUX_2
Definition: at32f435_437_gpio.h:158
GPIO_MUX_1
@ GPIO_MUX_1
Definition: at32f435_437_gpio.h:157
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
tmr_repetition_counter_set
void tmr_repetition_counter_set(tmr_type *tmr_x, uint8_t tmr_rpr_value)
set the repetition counter register(rpr) value
Definition: at32f435_437_tmr.c:265
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f435_437_tmr.c:1245
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f435_437_tmr.c:1499
tmr_sub_sync_mode_set
void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode
Definition: at32f435_437_tmr.c:1335
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f435_437_tmr.c:1322
tmr_primary_mode_select
void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode
Definition: at32f435_437_tmr.c:1222
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f435_437_tmr.h:97
TMR_OUTPUT_CONTROL_PWM_MODE_B
@ TMR_OUTPUT_CONTROL_PWM_MODE_B
Definition: at32f435_437_tmr.h:181
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f435_437_tmr.h:180
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:198
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f435_437_tmr.h:199
TMR_SUB_INPUT_SEL_IS0
@ TMR_SUB_INPUT_SEL_IS0
Definition: at32f435_437_tmr.h:134
TMR_SUB_HANG_MODE
@ TMR_SUB_HANG_MODE
Definition: at32f435_437_tmr.h:154
TMR_PRIMARY_SEL_OVERFLOW
@ TMR_PRIMARY_SEL_OVERFLOW
Definition: at32f435_437_tmr.h:121
TMR3
#define TMR3
Definition: at32f435_437_tmr.h:897
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
TMR4
#define TMR4
Definition: at32f435_437_tmr.h:898
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f435_437_crm.h:792
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f435_437_tmr.h:418
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f435_437_tmr.h:416
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f435_437_tmr.h:414
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • tmr2_32bit
  • inc
project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • tmr2_32bit
  • inc
project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • tmr2_32bit
  • inc
project/at_start_f435/examples/tmr/tmr2_32bit/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • tmr2_32bit
  • src
Functions
project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • tmr2_32bit
  • src
project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • tmr2_32bit
  • src
Functions
project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • tmr2_32bit
  • src
project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/tmr2_32bit/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • tmr2_32bit
  • src
Functions | Variables
project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
uint32_t | ccr1_val = 0x7ffff
uint32_t | ccr2_val = 0x3ffff
uint32_t | ccr3_val = 0x1ffff
uint32_t | ccr4_val = 0xffff

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • tmr2_32bit
  • src
project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 tmr_output_config_type tmr_oc_init_structure;
39
40uint32_t ccr1_val = 0x7ffff;
41uint32_t ccr2_val = 0x3ffff;
42uint32_t ccr3_val = 0x1ffff;
43uint32_t ccr4_val = 0xffff;
44
45void crm_configuration(void);
46void gpio_configuration(void);
47
53int main(void)
54{
55 system_clock_config();
56
57 /* system peripheral configuration */
58 crm_configuration();
59
60 /* gpio configuration */
61 gpio_configuration();
62
63 tmr_32_bit_function_enable(TMR2, TRUE);
64
65 /* tmr2 time base configuration */
66 tmr_base_init(TMR2, 0xfffff, 0);
67 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
68 tmr_clock_source_div_set(TMR2, TMR_CLOCK_DIV1);
69
70 tmr_output_default_para_init(&tmr_oc_init_structure);
71 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
72 tmr_oc_init_structure.oc_idle_state = FALSE;
73 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
74 tmr_oc_init_structure.oc_output_state = TRUE;
75 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
76 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_1, ccr1_val);
77 tmr_output_channel_buffer_enable(TMR2, TMR_SELECT_CHANNEL_1, TRUE);
78
79 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_2, &tmr_oc_init_structure);
80 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_2, ccr2_val);
81 tmr_output_channel_buffer_enable(TMR2, TMR_SELECT_CHANNEL_2, TRUE);
82
83 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_3, &tmr_oc_init_structure);
84 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_3, ccr3_val);
85 tmr_output_channel_buffer_enable(TMR2, TMR_SELECT_CHANNEL_3, TRUE);
86
87 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_4, &tmr_oc_init_structure);
88 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_4, ccr4_val);
89 tmr_output_channel_buffer_enable(TMR2, TMR_SELECT_CHANNEL_4, TRUE);
90
91 tmr_period_buffer_enable(TMR2, TRUE);
92
93 /* tmr2 enable counter */
94 tmr_counter_enable(TMR2, TRUE);
95
96 while(1)
97 {
98 }
99}
100
106void gpio_configuration(void)
107{
108 gpio_init_type gpio_init_struct;
109
110 gpio_default_para_init(&gpio_init_struct);
111
112 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_2 | GPIO_PINS_3;
113 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
114 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
115 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
116 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
117 gpio_init(GPIOA, &gpio_init_struct);
118
119 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE0, GPIO_MUX_1);
120 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE1, GPIO_MUX_1);
121 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE2, GPIO_MUX_1);
122 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE3, GPIO_MUX_1);
123}
124
130void crm_configuration(void)
131{
132 /* tmr clock enable */
133 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
134
135 /* gpio clock enable */
136 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
137}
138
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
ccr2_val
uint32_t ccr2_val
Definition: project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c:41
ccr4_val
uint32_t ccr4_val
Definition: project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c:43
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c:53
gpio_configuration
void gpio_configuration(void)
configure the tmr1 pins.
Definition: project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c:106
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c:38
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c:130
ccr1_val
uint32_t ccr1_val
Definition: project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c:40
ccr3_val
uint32_t ccr3_val
Definition: project/at_start_f435/examples/tmr/tmr2_32bit/src/main.c:42
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:128
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f435_437_gpio.h:133
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_1
@ GPIO_MUX_1
Definition: at32f435_437_gpio.h:157
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f435_437_gpio.h:51
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
tmr_period_buffer_enable
void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
set tmr period buffer
Definition: at32f435_437_tmr.c:638
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f435_437_tmr.c:230
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_32_bit_function_enable
void tmr_32_bit_function_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode)
Definition: at32f435_437_tmr.c:819
tmr_output_channel_buffer_enable
void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel buffer
Definition: at32f435_437_tmr.c:660
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f435_437_tmr.h:221
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f435_437_tmr.h:223
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f435_437_tmr.h:219
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f435_437_tmr.h:97
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f435_437_tmr.h:180
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:198
TMR2
#define TMR2
Definition: at32f435_437_tmr.h:896
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • 6_steps
  • inc
project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • 6_steps
  • inc
project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • 6_steps
  • inc
project/at_start_f435/examples/tmr/6_steps/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • 6_steps
  • src
Functions
project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • 6_steps
  • src
project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • 6_steps
  • src
Functions
project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • 6_steps
  • src
project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133 /* trigger TMR1 hall event */
134 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
135}
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/6_steps/src/at32f435_437_int.c:113
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f435_437_tmr.c:1486
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f435_437_tmr.h:290
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • 6_steps
  • src
Functions | Variables
project/at_start_f435/examples/tmr/6_steps/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | SysTick_Configuration (void)
configures the systick. More...
int | main (void)
main function. More...
void | TMR1_TRG_HALL_TMR11_IRQHandler (void)
this function handles tmr1 trigger and hall interrupts requests. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_brkdt_config_type | tmr_brkdt_config_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
__IO uint32_t | step = 1

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/6_steps/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • 6_steps
  • src
project/at_start_f435/examples/tmr/6_steps/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 tmr_output_config_type tmr_output_struct;
40 tmr_brkdt_config_type tmr_brkdt_config_struct = {0};
41 crm_clocks_freq_type crm_clocks_freq_struct = {0};
42
43__IO uint32_t step = 1;
44/* systick configuration */
45void SysTick_Configuration(void);
51int main(void)
52{
53 system_clock_config();
54
55 at32_board_init();
56
57 /* get system clock */
58 crm_clocks_freq_get(&crm_clocks_freq_struct);
59
60 SysTick_Configuration();
61
62 /* turn led2/led3/led4 on */
63 at32_led_on(LED2);
64 at32_led_on(LED3);
65 at32_led_on(LED4);
66
67 /* enable tmr1/gpioa/gpiob clock */
68 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
69 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
70 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
71
72 /* timer2 output pin Configuration */
73 gpio_init_struct.gpio_pins = GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10;
74 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
75 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
76 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
77 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
78 gpio_init(GPIOA, &gpio_init_struct);
79
80 gpio_init_struct.gpio_pins = GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
81 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
82 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
83 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
84 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
85 gpio_init(GPIOB, &gpio_init_struct);
86
87 gpio_init_struct.gpio_pins = GPIO_PINS_12;
88 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
89 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
90 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
91 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
92 gpio_init(GPIOB, &gpio_init_struct);
93
94 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE8, GPIO_MUX_1);
95 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE9, GPIO_MUX_1);
96 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE10, GPIO_MUX_1);
97 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE13, GPIO_MUX_1);
98 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE14, GPIO_MUX_1);
99 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE15, GPIO_MUX_1);
100 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE12, GPIO_MUX_1);
101
102 /*-----------------------------------------------------------------------------
103 the at32f403a tmr1 peripheral offers the possibility to program in advance the
104 configuration for the next tmr1 outputs behaviour (step) and change the configuration
105 of all the channels at the same time. this operation is possible when the hall
106 event is used.
107 the hall event can be generated by software by setting the hall bit in the tmr1_swevt
108 register or by hardware (on trc rising edge).
109 in this example, a software hall event is generated each 100 ms: using the systick
110 interrupt.
111 the tmr1 is configured in timing mode, each time a hall event occurs,
112 a new tmr1 configuration will be set in advance.
113 the following table describes the tmr1 channels states:
114 -----------------------------------------------
115 | step1 | step2 | step3 | step4 | step5 | step6 |
116 ----------------------------------------------------------
117 |channel1 | 1 | 0 | 0 | 0 | 0 | 1 |
118 ----------------------------------------------------------
119 |channel1n | 0 | 0 | 1 | 1 | 0 | 0 |
120 ----------------------------------------------------------
121 |channel2 | 0 | 0 | 0 | 1 | 1 | 0 |
122 ----------------------------------------------------------
123 |channel2n | 1 | 1 | 0 | 0 | 0 | 0 |
124 ----------------------------------------------------------
125 |channel3 | 0 | 1 | 1 | 0 | 0 | 0 |
126 ----------------------------------------------------------
127 |channel3n | 0 | 0 | 0 | 0 | 1 | 1 |
128 ----------------------------------------------------------
129 -----------------------------------------------------------------------------*/
130 /* tmr1 configuration */
131 /* time base configuration */
132
133 tmr_base_init(TMR1, 4095, 0);
134 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
135
136 /* Channel 1, 2 and 3 Configuration in output mode */
137 tmr_output_default_para_init(&tmr_output_struct);
138 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_OFF;
139 tmr_output_struct.oc_output_state = TRUE;
140 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
141 tmr_output_struct.oc_idle_state = TRUE;
142 tmr_output_struct.occ_output_state = TRUE;
143 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_HIGH;
144 tmr_output_struct.occ_idle_state = TRUE;
145 /* channel 1 */
146 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
147 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, 2047);
148 /* channel 2 */
149 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_2, &tmr_output_struct);
150 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_2, 1023);
151 /* channel 3 */
152 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_3, &tmr_output_struct);
153 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_3, 511);
154
155 /* automatic output enable, break, dead time and lock configuration*/
156 tmr_brkdt_default_para_init(&tmr_brkdt_config_struct);
157 tmr_brkdt_config_struct.brk_enable = TRUE;
158 tmr_brkdt_config_struct.auto_output_enable = TRUE;
159 tmr_brkdt_config_struct.deadtime = 0;
160 tmr_brkdt_config_struct.fcsodis_state = TRUE;
161 tmr_brkdt_config_struct.fcsoen_state = TRUE;
162 tmr_brkdt_config_struct.brk_polarity = TMR_BRK_INPUT_ACTIVE_HIGH;
163 tmr_brkdt_config_struct.wp_level = TMR_WP_OFF;
164 tmr_brkdt_config(TMR1, &tmr_brkdt_config_struct);
165 tmr_channel_buffer_enable(TMR1, TRUE);
166
167 /* hall interrupt enable */
168 tmr_interrupt_enable(TMR1, TMR_HALL_INT, TRUE);
169
170 /* tmr1 hall interrupt nvic init */
171 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
172 nvic_irq_enable(TMR1_TRG_HALL_TMR11_IRQn, 1, 0);
173
174 /* tmr1 output enable */
175 tmr_output_enable(TMR1, TRUE);
176 /* enable tmr1 */
177 tmr_counter_enable(TMR1, TRUE);
178
179 while(1)
180 {}
181}
187void SysTick_Configuration(void)
188{
189 /* setup systick timer for 20 msec interrupts */
190 if (SysTick_Config((crm_clocks_freq_struct.sclk_freq) / 50))
191 {
192 /* capture error */
193 while(1);
194 }
195 NVIC_SetPriority(SysTick_IRQn, 0x0);
196}
197
204void TMR1_TRG_HALL_TMR11_IRQHandler(void)
205{
206 /* clear tmr1 com pending bit */
207 tmr_flag_clear(TMR1, TMR_HALL_FLAG);
208 if(step == 1)
209 {
210 /* next step: step 2 configuration ---------------------------- */
211 /* channel3 configuration */
212 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3, FALSE);
213 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3C, FALSE);
214
215 /* channel1 configuration */
216 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_1, TMR_OUTPUT_CONTROL_PWM_MODE_A);
217 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1, TRUE);
218 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1C, FALSE);
219
220 /* channel2 configuration */
221 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_2, TMR_OUTPUT_CONTROL_PWM_MODE_A);
222 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2, FALSE);
223 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2C, TRUE);
224 step++;
225 }
226 else if(step == 2)
227 {
228 /* next step: step 3 configuration ---------------------------- */
229 /* channel2 configuration */
230 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_2, TMR_OUTPUT_CONTROL_PWM_MODE_A);
231 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2, FALSE);
232 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2C, TRUE);
233
234 /* channel3 configuration */
235 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_3, TMR_OUTPUT_CONTROL_PWM_MODE_A);
236 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3, TRUE);
237 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3C, FALSE);
238
239 /* channel1 configuration */
240 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1, FALSE);
241 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1C, FALSE);
242 step++;
243 }
244 else if(step == 3)
245 {
246 /* next step: step 4 configuration ---------------------------- */
247 /* channel3 configuration */
248 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_3, TMR_OUTPUT_CONTROL_PWM_MODE_A);
249 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3, TRUE);
250 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3C, FALSE);
251
252 /* channel2 configuration */
253 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2, FALSE);
254 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2C, FALSE);
255
256 /* channel1 configuration */
257 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_1, TMR_OUTPUT_CONTROL_PWM_MODE_A);
258 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1, FALSE);
259 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1C, TRUE);
260 step++;
261 }
262 else if(step == 4)
263 {
264 /* next step: step 5 configuration ---------------------------- */
265 /* channel3 configuration */
266 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3, FALSE);
267 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3C, FALSE);
268
269 /* channel1 configuration */
270 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_1, TMR_OUTPUT_CONTROL_PWM_MODE_A);
271 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1, FALSE);
272 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1C, TRUE);
273
274 /* channel2 configuration */
275 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_2, TMR_OUTPUT_CONTROL_PWM_MODE_A);
276 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2, TRUE);
277 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2C, FALSE);
278 step++;
279 }
280 else if (step == 5)
281 {
282 /* next step: step 6 configuration ---------------------------- */
283 /* channel3 configuration */
284 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_3, TMR_OUTPUT_CONTROL_PWM_MODE_A);
285 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3, FALSE);
286 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3C, TRUE);
287
288 /* channel1 configuration */
289 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1, FALSE);
290 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1C, FALSE);
291
292 /* channel2 configuration */
293 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_2, TMR_OUTPUT_CONTROL_PWM_MODE_A);
294 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2, TRUE);
295 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2C, FALSE);
296 step++;
297 }
298 else
299 {
300 /* next step: step 1 configuration ---------------------------- */
301 /* channel1 configuration */
302 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_1, TMR_OUTPUT_CONTROL_PWM_MODE_A);
303 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1, TRUE);
304 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1C, FALSE);
305
306 /* channel3 configuration */
307 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_3, TMR_OUTPUT_CONTROL_PWM_MODE_A);
308 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3, FALSE);
309 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3C, TRUE);
310
311 /* channel2 configuration */
312 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2, FALSE);
313 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2C, FALSE);
314 step = 1;
315 }
316}
317
at32f435_437_board.h
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/tmr/6_steps/src/main.c:38
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f435/examples/tmr/6_steps/src/main.c:39
SysTick_Configuration
void SysTick_Configuration(void)
configures the systick.
Definition: project/at_start_f435/examples/tmr/6_steps/src/main.c:187
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/6_steps/src/main.c:51
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/tmr/6_steps/src/main.c:41
step
__IO uint32_t step
Definition: project/at_start_f435/examples/tmr/6_steps/src/main.c:43
TMR1_TRG_HALL_TMR11_IRQHandler
void TMR1_TRG_HALL_TMR11_IRQHandler(void)
this function handles tmr1 trigger and hall interrupts requests.
Definition: project/at_start_f435/examples/tmr/6_steps/src/main.c:204
tmr_brkdt_config_struct
tmr_brkdt_config_type tmr_brkdt_config_struct
Definition: project/at_start_f435/examples/tmr/6_steps/src/main.c:40
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:154
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f435_437_gpio.h:145
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f435_437_gpio.h:146
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_1
@ GPIO_MUX_1
Definition: at32f435_437_gpio.h:157
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f435_437_gpio.h:64
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f435_437_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f435_437_tmr.c:1463
tmr_channel_buffer_enable
void tmr_channel_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
select tmr channel buffer
Definition: at32f435_437_tmr.c:1287
tmr_output_channel_mode_select
void tmr_output_channel_mode_select(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_control_mode_type oc_mode)
select tmr output channel mode
Definition: at32f435_437_tmr.c:461
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_brkdt_default_para_init
void tmr_brkdt_default_para_init(tmr_brkdt_config_type *tmr_brkdt_struct)
init tmr brkdt default para
Definition: at32f435_437_tmr.c:183
tmr_brkdt_config
void tmr_brkdt_config(tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
config tmr break mode and dead-time
Definition: at32f435_437_tmr.c:1801
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f435_437_tmr.c:1499
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f435_437_tmr.c:1389
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_enable
void tmr_channel_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable
Definition: at32f435_437_tmr.c:940
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_1C
@ TMR_SELECT_CHANNEL_1C
Definition: at32f435_437_tmr.h:218
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f435_437_tmr.h:221
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_SELECT_CHANNEL_2C
@ TMR_SELECT_CHANNEL_2C
Definition: at32f435_437_tmr.h:220
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f435_437_tmr.h:219
TMR_SELECT_CHANNEL_3C
@ TMR_SELECT_CHANNEL_3C
Definition: at32f435_437_tmr.h:222
TMR_WP_OFF
@ TMR_WP_OFF
Definition: at32f435_437_tmr.h:390
TMR_BRK_INPUT_ACTIVE_HIGH
@ TMR_BRK_INPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:382
TMR_OUTPUT_CONTROL_OFF
@ TMR_OUTPUT_CONTROL_OFF
Definition: at32f435_437_tmr.h:174
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f435_437_tmr.h:180
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:198
TMR_HALL_FLAG
#define TMR_HALL_FLAG
Definition: at32f435_437_tmr.h:58
TMR_HALL_INT
#define TMR_HALL_INT
Definition: at32f435_437_tmr.h:80
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
SysTick_IRQn
@ SysTick_IRQn
Definition: at32f435_437.h:143
TMR1_TRG_HALL_TMR11_IRQn
@ TMR1_TRG_HALL_TMR11_IRQn
Definition: at32f435_437.h:174
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f435_437_crm.h:789
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_brkdt_config_type
tmr brkdt config type
Definition: at32f435_437_tmr.h:436
tmr_brkdt_config_type::brk_enable
confirm_state brk_enable
Definition: at32f435_437_tmr.h:443
tmr_brkdt_config_type::deadtime
uint8_t deadtime
Definition: at32f435_437_tmr.h:437
tmr_brkdt_config_type::auto_output_enable
confirm_state auto_output_enable
Definition: at32f435_437_tmr.h:440
tmr_brkdt_config_type::wp_level
tmr_wp_level_type wp_level
Definition: at32f435_437_tmr.h:439
tmr_brkdt_config_type::fcsoen_state
confirm_state fcsoen_state
Definition: at32f435_437_tmr.h:441
tmr_brkdt_config_type::fcsodis_state
confirm_state fcsodis_state
Definition: at32f435_437_tmr.h:442
tmr_brkdt_config_type::brk_polarity
tmr_brk_polarity_type brk_polarity
Definition: at32f435_437_tmr.h:438
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f435_437_tmr.h:418
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f435_437_tmr.h:416
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f435_437_tmr.h:414
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • tmr
  • 7_pwm_output
  • inc
project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • tmr
  • 7_pwm_output
  • inc
project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • tmr
  • 7_pwm_output
  • inc
project/at_start_f435/examples/tmr/7_pwm_output/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • tmr
  • 7_pwm_output
  • src
Functions
project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • tmr
  • 7_pwm_output
  • src
project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • tmr
  • 7_pwm_output
  • src
Functions
project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • tmr
  • 7_pwm_output
  • src
project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133 /* trigger TMR1 hall event */
134 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
135}
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/tmr/7_pwm_output/src/at32f435_437_int.c:113
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f435_437_tmr.c:1486
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f435_437_tmr.h:290
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • tmr
  • 7_pwm_output
  • src
Functions | Variables
project/at_start_f435/examples/tmr/7_pwm_output/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timerperiod = 0
uint16_t | channel1pulse = 0
uint16_t | channel2pulse = 0
uint16_t | channel3pulse = 0
uint16_t | channel4pulse = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/tmr/7_pwm_output/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • tmr
  • 7_pwm_output
  • src
project/at_start_f435/examples/tmr/7_pwm_output/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 tmr_output_config_type tmr_output_struct;
40 crm_clocks_freq_type crm_clocks_freq_struct = {0};
41
42uint16_t timerperiod = 0;
43uint16_t channel1pulse = 0, channel2pulse = 0, channel3pulse = 0, channel4pulse = 0;
44
50int main(void)
51{
52 system_clock_config();
53
54 at32_board_init();
55
56 /* get system clock */
57 crm_clocks_freq_get(&crm_clocks_freq_struct);
58
59 /* turn led2/led3/led4 on */
60 at32_led_on(LED2);
61 at32_led_on(LED3);
62 at32_led_on(LED4);
63
64 /* enable tmr1/gpioa/gpiob clock */
65 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
67 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
68
69 /* timer1 output pin Configuration */
70 gpio_init_struct.gpio_pins = GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11;
71 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
72 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
73 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
74 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
75 gpio_init(GPIOA, &gpio_init_struct);
76
77 gpio_init_struct.gpio_pins = GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
78 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
79 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
80 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
81 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
82 gpio_init(GPIOB, &gpio_init_struct);
83
84 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE8, GPIO_MUX_1);
85 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE9, GPIO_MUX_1);
86 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE10, GPIO_MUX_1);
87 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE11, GPIO_MUX_1);
88 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE13, GPIO_MUX_1);
89 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE14, GPIO_MUX_1);
90 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE15, GPIO_MUX_1);
91
92
93 /* tmr1 configuration ---------------------------------------------------
94 generate 7 pwm signals with 4 different duty cycles:
95 prescaler = 0, tmr1 counter clock = apb2_freq *2
96
97 the objective is to generate 7 pwm signal at 17.57 khz:
98 - tim1_period = (apb2_freq * 2 / 17570) - 1
99 the channel 1 and channel 1n duty cycle is set to 50%
100 the channel 2 and channel 2n duty cycle is set to 37.5%
101 the channel 3 and channel 3n duty cycle is set to 25%
102 the channel 4 duty cycle is set to 12.5%
103 the timer pulse is calculated as follows:
104 - channelxpulse = dutycycle * (tim1_period - 1) / 100
105 ----------------------------------------------------------------------- */
106 /* compute the value to be set in arr regiter to generate signal frequency at 17.57 khz */
107 timerperiod = ((crm_clocks_freq_struct.apb2_freq * 2) / 17570 ) - 1;
108 /* compute ccr1 value to generate a duty cycle at 50% for channel 1 and 1n */
109 channel1pulse = (uint16_t) (((uint32_t) 5 * (timerperiod - 1)) / 10);
110 /* compute ccr2 value to generate a duty cycle at 37.5% for channel 2 and 2n */
111 channel2pulse = (uint16_t) (((uint32_t) 375 * (timerperiod - 1)) / 1000);
112 /* compute ccr3 value to generate a duty cycle at 25% for channel 3 and 3n */
113 channel3pulse = (uint16_t) (((uint32_t) 25 * (timerperiod - 1)) / 100);
114 /* compute ccr4 value to generate a duty cycle at 12.5% for channel 4 */
115 channel4pulse = (uint16_t) (((uint32_t) 125 * (timerperiod- 1)) / 1000);
116
117 tmr_base_init(TMR1, timerperiod, 0);
118 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
119
120 /* channel 1, 2, 3 and 4 configuration in output mode */
121 tmr_output_default_para_init(&tmr_output_struct);
122 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_B;
123 tmr_output_struct.oc_output_state = TRUE;
124 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
125 tmr_output_struct.oc_idle_state = TRUE;
126 tmr_output_struct.occ_output_state = TRUE;
127 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_HIGH;
128 tmr_output_struct.occ_idle_state = FALSE;
129 /* channel 1 */
130 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
131 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, channel1pulse);
132 /* channel 2 */
133 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_2, &tmr_output_struct);
134 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_2, channel2pulse);
135 /* channel 3 */
136 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_3, &tmr_output_struct);
137 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_3, channel3pulse);
138 /* channel 4 */
139 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_4, &tmr_output_struct);
140 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_4, channel4pulse);
141
142 /* tmr1 output enable */
143 tmr_output_enable(TMR1, TRUE);
144 /* enable tmr1 */
145 tmr_counter_enable(TMR1, TRUE);
146
147 while(1)
148 {}
149}
150
at32f435_437_board.h
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/tmr/7_pwm_output/src/main.c:38
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f435/examples/tmr/7_pwm_output/src/main.c:39
channel1pulse
uint16_t channel1pulse
Definition: project/at_start_f435/examples/tmr/7_pwm_output/src/main.c:43
timerperiod
uint16_t timerperiod
Definition: project/at_start_f435/examples/tmr/7_pwm_output/src/main.c:42
main
int main(void)
main function.
Definition: project/at_start_f435/examples/tmr/7_pwm_output/src/main.c:50
channel2pulse
uint16_t channel2pulse
Definition: project/at_start_f435/examples/tmr/7_pwm_output/src/main.c:43
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f435/examples/tmr/7_pwm_output/src/main.c:40
channel3pulse
uint16_t channel3pulse
Definition: project/at_start_f435/examples/tmr/7_pwm_output/src/main.c:43
channel4pulse
uint16_t channel4pulse
Definition: project/at_start_f435/examples/tmr/7_pwm_output/src/main.c:43
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:154
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f435_437_gpio.h:146
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f435_437_gpio.h:142
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f435_437_gpio.h:148
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f435_437_gpio.h:147
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f435_437_gpio.h:141
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_1
@ GPIO_MUX_1
Definition: at32f435_437_gpio.h:157
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f435_437_gpio.h:64
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f435_437_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f435_437_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f435_437_gpio.h:59
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f435_437_gpio.h:66
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f435_437_tmr.c:140
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f435_437_tmr.c:350
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f435_437_tmr.c:152
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f435_437_tmr.c:1499
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f435_437_tmr.c:205
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f435_437_tmr.c:251
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f435_437_tmr.c:543
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f435_437_tmr.h:107
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f435_437_tmr.h:221
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f435_437_tmr.h:217
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f435_437_tmr.h:223
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f435_437_tmr.h:219
TMR_OUTPUT_CONTROL_PWM_MODE_B
@ TMR_OUTPUT_CONTROL_PWM_MODE_B
Definition: at32f435_437_tmr.h:181
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f435_437_tmr.h:198
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f435_437_tmr.h:199
TMR1
#define TMR1
Definition: at32f435_437_tmr.h:895
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::apb2_freq
uint32_t apb2_freq
Definition: at32f435_437_crm.h:791
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
tmr_output_config_type
tmr output config type
Definition: at32f435_437_tmr.h:411
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f435_437_tmr.h:418
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f435_437_tmr.h:413
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f435_437_tmr.h:417
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f435_437_tmr.h:412
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f435_437_tmr.h:416
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f435_437_tmr.h:414
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f435_437_tmr.h:415
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • usart
  • half_duplex
  • inc
project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • usart
  • half_duplex
  • inc
project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • usart
  • half_duplex
  • inc
project/at_start_f435/examples/usart/half_duplex/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • usart
  • half_duplex
  • src
Functions
project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • usart
  • half_duplex
  • src
project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • usart
  • half_duplex
  • src
Functions
project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • usart
  • half_duplex
  • src
project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/usart/half_duplex/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • usart
  • half_duplex
  • src
Macros | Functions | Variables
project/at_start_f435/examples/usart/half_duplex/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | usart_configuration (void)
config usart More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart half-duplex transfer: usart2 -> usart3"
uint8_t | usart3_tx_buffer [] = "usart half-duplex transfer: usart3 -> usart2"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | data_count

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/half_duplex/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • usart
  • half_duplex
  • src
project/at_start_f435/examples/usart/half_duplex/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define COUNTOF(a) (sizeof(a) / sizeof(*(a)))
39#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
40#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)
41
42uint8_t usart2_tx_buffer[] = "usart half-duplex transfer: usart2 -> usart3";
43uint8_t usart3_tx_buffer[] = "usart half-duplex transfer: usart3 -> usart2";
44uint8_t usart2_rx_buffer[USART3_TX_BUFFER_SIZE];
45uint8_t usart3_rx_buffer[USART2_TX_BUFFER_SIZE];
46uint8_t data_count;
47
53void usart_configuration(void)
54{
55 gpio_init_type gpio_init_struct;
56
57 /* enable the usart2 and gpio clock */
58 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
59 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
60
61 /* enable the usart3 and gpio clock */
62 crm_periph_clock_enable(CRM_USART3_PERIPH_CLOCK, TRUE);
63 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
64
65 gpio_default_para_init(&gpio_init_struct);
66
67 /* configure the usart2 tx pin */
68 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
69 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
70 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
71 gpio_init_struct.gpio_pins = GPIO_PINS_2;
72 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
73 gpio_init(GPIOA, &gpio_init_struct);
74 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE2, GPIO_MUX_7);
75
76 /* configure the usart3 tx pin */
77 gpio_init_struct.gpio_pins = GPIO_PINS_10;
78 gpio_init(GPIOB, &gpio_init_struct);
79 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE10, GPIO_MUX_7);
80
81 /* configure usart2 param */
82 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
83 usart_transmitter_enable(USART2, TRUE);
84 usart_receiver_enable(USART2, TRUE);
85 usart_single_line_halfduplex_select(USART2, TRUE);
86 usart_enable(USART2, TRUE);
87
88 /* configure usart3 param */
89 usart_init(USART3, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
90 usart_transmitter_enable(USART3, TRUE);
91 usart_receiver_enable(USART3, TRUE);
92 usart_single_line_halfduplex_select(USART3, TRUE);
93 usart_enable(USART3, TRUE);
94}
95
103uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
104{
105 while(buffer_length--)
106 {
107 if(*pbuffer1 != *pbuffer2)
108 {
109 return 0;
110 }
111 pbuffer1++;
112 pbuffer2++;
113 }
114 return 1;
115}
116
122int main(void)
123{
124 system_clock_config();
125 at32_board_init();
126 usart_configuration();
127
128 /* usart2 transmit and usart3 receive */
129 data_count = USART2_TX_BUFFER_SIZE;
130 while(data_count)
131 {
132 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
133 usart_data_transmit(USART2, usart2_tx_buffer[USART2_TX_BUFFER_SIZE-data_count]);
134 while(usart_flag_get(USART3, USART_RDBF_FLAG) == RESET);
135 usart3_rx_buffer[USART2_TX_BUFFER_SIZE-data_count] = usart_data_receive(USART3);
136 data_count--;
137 }
138
139 /* usart3 transmit and usart2 receive */
140 data_count = USART3_TX_BUFFER_SIZE;
141 while(data_count)
142 {
143 while(usart_flag_get(USART3, USART_TDBE_FLAG) == RESET);
144 usart_data_transmit(USART3, usart3_tx_buffer[USART3_TX_BUFFER_SIZE-data_count]);
145 while(usart_flag_get(USART2, USART_RDBF_FLAG) == RESET);
146 usart2_rx_buffer[USART3_TX_BUFFER_SIZE-data_count] = usart_data_receive(USART2);
147 data_count--;
148 }
149
150 while(1)
151 {
152 /* compare data buffer */
153 if(buffer_compare(usart2_tx_buffer, usart3_rx_buffer, USART2_TX_BUFFER_SIZE) && \
154 buffer_compare(usart3_tx_buffer, usart2_rx_buffer, USART3_TX_BUFFER_SIZE))
155 {
156 at32_led_toggle(LED2);
157 at32_led_toggle(LED3);
158 at32_led_toggle(LED4);
159 delay_sec(1);
160 }
161 }
162}
163
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f435/examples/usart/half_duplex/src/main.c:53
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f435/examples/usart/half_duplex/src/main.c:103
usart3_rx_buffer
uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
Definition: project/at_start_f435/examples/usart/half_duplex/src/main.c:45
USART2_TX_BUFFER_SIZE
#define USART2_TX_BUFFER_SIZE
Definition: project/at_start_f435/examples/usart/half_duplex/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f435/examples/usart/half_duplex/src/main.c:122
usart2_tx_buffer
uint8_t usart2_tx_buffer[]
Definition: project/at_start_f435/examples/usart/half_duplex/src/main.c:42
USART3_TX_BUFFER_SIZE
#define USART3_TX_BUFFER_SIZE
Definition: project/at_start_f435/examples/usart/half_duplex/src/main.c:40
data_count
uint8_t data_count
Definition: project/at_start_f435/examples/usart/half_duplex/src/main.c:46
usart3_tx_buffer
uint8_t usart3_tx_buffer[]
Definition: project/at_start_f435/examples/usart/half_duplex/src/main.c:43
usart2_rx_buffer
uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
Definition: project/at_start_f435/examples/usart/half_duplex/src/main.c:44
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_USART3_PERIPH_CLOCK
@ CRM_USART3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:141
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:140
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f435_437_gpio.h:103
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f435_437_usart.c:413
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f435_437_usart.c:598
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f435_437_usart.c:209
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f435_437_usart.c:115
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f435_437_usart.c:196
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f435_437_usart.c:222
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f435_437_usart.c:425
usart_single_line_halfduplex_select
void usart_single_line_halfduplex_select(usart_type *usart_x, confirm_state new_state)
enable or disable the usart single line bidirectional half-duplex communication.
Definition: at32f435_437_usart.c:509
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f435_437_usart.h:159
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f435_437_usart.h:114
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f435_437_usart.h:59
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f435_437_usart.h:57
USART3
#define USART3
Definition: at32f435_437_usart.h:350
USART2
#define USART2
Definition: at32f435_437_usart.h:349
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • usart
  • hw_flow_control
  • inc
project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • usart
  • hw_flow_control
  • inc
project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • usart
  • hw_flow_control
  • inc
project/at_start_f435/examples/usart/hw_flow_control/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • usart
  • hw_flow_control
  • src
Functions
project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • usart
  • hw_flow_control
  • src
project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • usart
  • hw_flow_control
  • src
Functions
project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • usart
  • hw_flow_control
  • src
project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/usart/hw_flow_control/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • usart
  • hw_flow_control
  • src
Macros | Functions | Variables
project/at_start_f435/examples/usart/hw_flow_control/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 16

Functions

void | usart_configuration (void)
config usart More...
int | main (void)
main function. More...

Variables

uint8_t | rx_buffer [16]
uint8_t | data_count

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/hw_flow_control/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • usart
  • hw_flow_control
  • src
project/at_start_f435/examples/usart/hw_flow_control/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define BUFFER_SIZE 16
39
40uint8_t rx_buffer[BUFFER_SIZE];
41uint8_t data_count;
42
48void usart_configuration(void)
49{
50 gpio_init_type gpio_init_struct;
51
52 /* enable the usart2 and gpio clock */
53 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
54 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
55
56 gpio_default_para_init(&gpio_init_struct);
57
58 /* configure the usart2 tx, rx, cts and rts pin */
59 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
60 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
61 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
62 gpio_init_struct.gpio_pins = GPIO_PINS_3 | GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6;
63 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
64 gpio_init(GPIOD, &gpio_init_struct);
65 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE3, GPIO_MUX_7);
66 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE4, GPIO_MUX_7);
67 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE5, GPIO_MUX_7);
68 gpio_pin_mux_config(GPIOD, GPIO_PINS_SOURCE6, GPIO_MUX_7);
69
70 /* configure usart2 param */
71 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
72 usart_hardware_flow_control_set(USART2, USART_HARDWARE_FLOW_RTS_CTS);
73 usart_transmitter_enable(USART2, TRUE);
74 usart_receiver_enable(USART2, TRUE);
75 usart_enable(USART2, TRUE);
76}
77
83int main(void)
84{
85 system_clock_config();
86 at32_board_init();
87 usart_configuration();
88
89 /* receive a string (BUFFER_SIZE bytes) from the hyperterminal */
90 data_count = BUFFER_SIZE;
91 while(data_count)
92 {
93 while(usart_flag_get(USART2, USART_RDBF_FLAG) == RESET);
94 rx_buffer[BUFFER_SIZE-data_count] = usart_data_receive(USART2);
95 data_count--;
96 }
97
98 /* send a buffer from usart to hyperterminal */
99 data_count = BUFFER_SIZE;
100 while(data_count)
101 {
102 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
103 usart_data_transmit(USART2, rx_buffer[BUFFER_SIZE-data_count]);
104 data_count--;
105 }
106
107 while(1)
108 {
109 at32_led_toggle(LED2);
110 at32_led_toggle(LED3);
111 at32_led_toggle(LED4);
112 delay_sec(1);
113 }
114}
115
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
rx_buffer
uint8_t rx_buffer[16]
Definition: project/at_start_f435/examples/usart/hw_flow_control/src/main.c:40
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f435/examples/usart/hw_flow_control/src/main.c:48
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f435/examples/usart/hw_flow_control/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f435/examples/usart/hw_flow_control/src/main.c:83
data_count
uint8_t data_count
Definition: project/at_start_f435/examples/usart/hw_flow_control/src/main.c:41
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f435_437_crm.h:108
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:140
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOD
#define GPIOD
Definition: at32f435_437_gpio.h:524
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f435_437_usart.c:413
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f435_437_usart.c:598
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f435_437_usart.c:209
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f435_437_usart.c:115
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f435_437_usart.c:196
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f435_437_usart.c:222
usart_hardware_flow_control_set
void usart_hardware_flow_control_set(usart_type *usart_x, usart_hardware_flow_control_type flow_state)
configure the usart's hardware flow control.
Definition: at32f435_437_usart.c:555
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f435_437_usart.c:425
USART_HARDWARE_FLOW_RTS_CTS
@ USART_HARDWARE_FLOW_RTS_CTS
Definition: at32f435_437_usart.h:173
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f435_437_usart.h:159
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f435_437_usart.h:114
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f435_437_usart.h:59
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f435_437_usart.h:57
USART2
#define USART2
Definition: at32f435_437_usart.h:349
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • usart
  • idle_detection
  • inc
project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • usart
  • idle_detection
  • inc
project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • usart
  • idle_detection
  • inc
project/at_start_f435/examples/usart/idle_detection/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • usart
  • idle_detection
  • src
Functions
project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • usart
  • idle_detection
  • src
project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • usart
  • idle_detection
  • src
Functions
project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"
#include "at32f435_437_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | USART2_IRQHandler (void)
this function handles usart2 handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • usart
  • idle_detection
  • src
project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29#include "at32f435_437_board.h"
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
141void USART2_IRQHandler(void)
142{
143 if(usart_flag_get(USART2, USART_IDLEF_FLAG))
144 {
145 usart_data_receive(USART2);
146 at32_led_on(LED2);
147 at32_led_on(LED3);
148 at32_led_on(LED4);
149 }
150}
151
at32f435_437_board.h
USART2_IRQHandler
void USART2_IRQHandler(void)
this function handles usart2 handler.
Definition: project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c:141
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/usart/idle_detection/src/at32f435_437_int.c:114
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f435_437_usart.c:598
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f435_437_usart.c:425
USART_IDLEF_FLAG
#define USART_IDLEF_FLAG
Definition: at32f435_437_usart.h:56
USART2
#define USART2
Definition: at32f435_437_usart.h:349
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • usart
  • idle_detection
  • src
Functions
project/at_start_f435/examples/usart/idle_detection/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | usart_configuration (void)
config usart More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/idle_detection/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • usart
  • idle_detection
  • src
project/at_start_f435/examples/usart/idle_detection/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
43void usart_configuration(void)
44{
45 gpio_init_type gpio_init_struct;
46
47 /* enable the usart2 and gpio clock */
48 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
49 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
50
51 gpio_default_para_init(&gpio_init_struct);
52
53 /* configure the usart2 tx. rx pin */
54 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
55 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
56 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
57 gpio_init_struct.gpio_pins = GPIO_PINS_2 | GPIO_PINS_3;
58 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
59 gpio_init(GPIOA, &gpio_init_struct);
60 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE2, GPIO_MUX_7);
61 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE3, GPIO_MUX_7);
62
63 /* config usart nvic interrupt */
64 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
65 nvic_irq_enable(USART2_IRQn, 0, 0);
66
67 /* configure usart2 param */
68 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
69 usart_transmitter_enable(USART2, TRUE);
70 usart_receiver_enable(USART2, TRUE);
71 usart_interrupt_enable(USART2, USART_IDLE_INT, TRUE);
72 usart_enable(USART2, TRUE);
73}
74
80int main(void)
81{
82 system_clock_config();
83 at32_board_init();
84 at32_led_off(LED2);
85 at32_led_off(LED3);
86 at32_led_off(LED4);
87 usart_configuration();
88
89 /* transmit a data */
90 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
91 usart_data_transmit(USART2, 0x55);
92
93 /* receive a data from the tx pin */
94 while(usart_flag_get(USART2, USART_RDBF_FLAG) == RESET);
95 usart_data_receive(USART2);
96
97 while(1)
98 {
99 }
100}
101
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f435/examples/usart/idle_detection/src/main.c:43
main
int main(void)
main function.
Definition: project/at_start_f435/examples/usart/idle_detection/src/main.c:80
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:140
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f435_437_usart.c:413
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f435_437_usart.c:598
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f435_437_usart.c:209
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f435_437_usart.c:115
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f435_437_usart.c:196
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f435_437_usart.c:222
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f435_437_usart.c:287
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f435_437_usart.c:425
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f435_437_usart.h:159
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f435_437_usart.h:114
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f435_437_usart.h:59
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f435_437_usart.h:57
USART_IDLE_INT
#define USART_IDLE_INT
Definition: at32f435_437_usart.h:72
USART2
#define USART2
Definition: at32f435_437_usart.h:349
USART2_IRQn
@ USART2_IRQn
Definition: at32f435_437.h:186
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • usart
  • interrupt
  • inc
project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • usart
  • interrupt
  • inc
project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • usart
  • interrupt
  • inc
project/at_start_f435/examples/usart/interrupt/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • usart
  • interrupt
  • src
Functions
project/at_start_f435/examples/usart/interrupt/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/interrupt/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • usart
  • interrupt
  • src
project/at_start_f435/examples/usart/interrupt/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/usart/interrupt/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • usart
  • interrupt
  • src
Functions | Variables
project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | USART2_IRQHandler (void)
this function handles usart2 handler. More...
void | USART3_IRQHandler (void)
this function handles usart3 handler. More...

Variables

uint8_t | usart2_tx_buffer []
uint8_t | usart3_tx_buffer []
uint8_t | usart2_rx_buffer []
uint8_t | usart3_rx_buffer []
uint8_t | usart2_tx_counter
uint8_t | usart3_tx_counter
uint8_t | usart2_rx_counter
uint8_t | usart3_rx_counter
uint8_t | usart2_tx_buffer_size
uint8_t | usart3_tx_buffer_size

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • usart
  • interrupt
  • src
project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
38extern uint8_t usart2_tx_buffer[];
39extern uint8_t usart3_tx_buffer[];
40extern uint8_t usart2_rx_buffer[];
41extern uint8_t usart3_rx_buffer[];
42extern uint8_t usart2_tx_counter;
43extern uint8_t usart3_tx_counter;
44extern uint8_t usart2_rx_counter;
45extern uint8_t usart3_rx_counter;
46extern uint8_t usart2_tx_buffer_size;
47extern uint8_t usart3_tx_buffer_size;
48
54void NMI_Handler(void)
55{
56}
57
63void HardFault_Handler(void)
64{
65 /* go to infinite loop when hard fault exception occurs */
66 while(1)
67 {
68 }
69}
70
76void MemManage_Handler(void)
77{
78 /* go to infinite loop when memory manage exception occurs */
79 while(1)
80 {
81 }
82}
83
89void BusFault_Handler(void)
90{
91 /* go to infinite loop when bus fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void UsageFault_Handler(void)
103{
104 /* go to infinite loop when usage fault exception occurs */
105 while(1)
106 {
107 }
108}
109
115void SVC_Handler(void)
116{
117}
118
124void DebugMon_Handler(void)
125{
126}
127
133void PendSV_Handler(void)
134{
135}
136
142void SysTick_Handler(void)
143{
144}
145
151void USART2_IRQHandler(void)
152{
153 if(usart_flag_get(USART2, USART_RDBF_FLAG) != RESET)
154 {
155 /* read one byte from the receive data register */
156 usart2_rx_buffer[usart2_rx_counter++] = usart_data_receive(USART2);
157
158 if(usart2_rx_counter == usart3_tx_buffer_size)
159 {
160 /* disable the usart2 receive interrupt */
161 usart_interrupt_enable(USART2, USART_RDBF_INT, FALSE);
162 }
163 }
164
165 if(usart_flag_get(USART2, USART_TDBE_FLAG) != RESET)
166 {
167 /* write one byte to the transmit data register */
168 usart_data_transmit(USART2, usart2_tx_buffer[usart2_tx_counter++]);
169
170 if(usart2_tx_counter == usart2_tx_buffer_size)
171 {
172 /* disable the usart2 transmit interrupt */
173 usart_interrupt_enable(USART2, USART_TDBE_INT, FALSE);
174 }
175 }
176}
177
183void USART3_IRQHandler(void)
184{
185 if(usart_flag_get(USART3, USART_RDBF_FLAG) != RESET)
186 {
187 /* read one byte from the receive data register */
188 usart3_rx_buffer[usart3_rx_counter++] = usart_data_receive(USART3);
189
190 if(usart3_rx_counter == usart2_tx_buffer_size)
191 {
192 /* disable the usart3 receive interrupt */
193 usart_interrupt_enable(USART3, USART_RDBF_INT, FALSE);
194 }
195 }
196
197 if(usart_flag_get(USART3, USART_TDBE_FLAG) != RESET)
198 {
199 /* write one byte to the transmit data register */
200 usart_data_transmit(USART3, usart3_tx_buffer[usart3_tx_counter++]);
201
202 if(usart3_tx_counter == usart3_tx_buffer_size)
203 {
204 /* disable the usart3 transmit interrupt */
205 usart_interrupt_enable(USART3, USART_TDBE_INT, FALSE);
206 }
207 }
208}
209
USART2_IRQHandler
void USART2_IRQHandler(void)
this function handles usart2 handler.
Definition: project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c:151
USART3_IRQHandler
void USART3_IRQHandler(void)
this function handles usart3 handler.
Definition: project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c:183
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c:102
usart2_rx_buffer
uint8_t usart2_rx_buffer[]
Definition: project/at_start_f435/examples/usart/half_duplex/src/main.c:44
usart3_tx_counter
uint8_t usart3_tx_counter
Definition: project/at_start_f435/examples/usart/interrupt/src/main.c:47
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c:63
usart2_tx_counter
uint8_t usart2_tx_counter
Definition: project/at_start_f435/examples/usart/interrupt/src/main.c:46
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c:76
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c:115
usart2_tx_buffer_size
uint8_t usart2_tx_buffer_size
Definition: project/at_start_f435/examples/usart/interrupt/src/main.c:50
usart2_rx_counter
uint8_t usart2_rx_counter
Definition: project/at_start_f435/examples/usart/interrupt/src/main.c:48
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c:133
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c:54
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c:89
usart3_tx_buffer_size
uint8_t usart3_tx_buffer_size
Definition: project/at_start_f435/examples/usart/interrupt/src/main.c:51
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c:142
usart2_tx_buffer
uint8_t usart2_tx_buffer[]
Definition: project/at_start_f435/examples/usart/half_duplex/src/main.c:42
usart3_tx_buffer
uint8_t usart3_tx_buffer[]
Definition: project/at_start_f435/examples/usart/half_duplex/src/main.c:43
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/usart/interrupt/src/at32f435_437_int.c:124
usart3_rx_counter
uint8_t usart3_rx_counter
Definition: project/at_start_f435/examples/usart/interrupt/src/main.c:49
usart3_rx_buffer
uint8_t usart3_rx_buffer[]
Definition: project/at_start_f435/examples/usart/half_duplex/src/main.c:45
FALSE
@ FALSE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f435_437_usart.c:413
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f435_437_usart.c:598
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f435_437_usart.c:287
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f435_437_usart.c:425
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f435_437_usart.h:59
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f435_437_usart.h:57
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f435_437_usart.h:73
USART_TDBE_INT
#define USART_TDBE_INT
Definition: at32f435_437_usart.h:75
USART3
#define USART3
Definition: at32f435_437_usart.h:350
USART2
#define USART2
Definition: at32f435_437_usart.h:349
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • usart
  • interrupt
  • src
Macros | Functions | Variables
project/at_start_f435/examples/usart/interrupt/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | usart_configuration (void)
config usart More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"
uint8_t | usart3_tx_buffer [] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
volatile uint8_t | usart2_tx_counter = 0x00
volatile uint8_t | usart3_tx_counter = 0x00
volatile uint8_t | usart2_rx_counter = 0x00
volatile uint8_t | usart3_rx_counter = 0x00
uint8_t | usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)
uint8_t | usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/interrupt/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • usart
  • interrupt
  • src
project/at_start_f435/examples/usart/interrupt/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define COUNTOF(a) (sizeof(a) / sizeof(*(a)))
39#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
40#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)
41
42uint8_t usart2_tx_buffer[] = "usart transfer by interrupt: usart2 -> usart3 using interrupt";
43uint8_t usart3_tx_buffer[] = "usart transfer by interrupt: usart3 -> usart2 using interrupt";
44uint8_t usart2_rx_buffer[USART3_TX_BUFFER_SIZE];
45uint8_t usart3_rx_buffer[USART2_TX_BUFFER_SIZE];
46volatile uint8_t usart2_tx_counter = 0x00;
47volatile uint8_t usart3_tx_counter = 0x00;
48volatile uint8_t usart2_rx_counter = 0x00;
49volatile uint8_t usart3_rx_counter = 0x00;
50uint8_t usart2_tx_buffer_size = USART2_TX_BUFFER_SIZE;
51uint8_t usart3_tx_buffer_size = USART3_TX_BUFFER_SIZE;
52
58void usart_configuration(void)
59{
60 gpio_init_type gpio_init_struct;
61
62 /* enable the usart2 and gpio clock */
63 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
64 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
65
66 /* enable the usart3 and gpio clock */
67 crm_periph_clock_enable(CRM_USART3_PERIPH_CLOCK, TRUE);
68 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
69
70 gpio_default_para_init(&gpio_init_struct);
71
72 /* configure the usart2 tx, rx pin */
73 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
74 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
75 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
76 gpio_init_struct.gpio_pins = GPIO_PINS_2 | GPIO_PINS_3;
77 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
78 gpio_init(GPIOA, &gpio_init_struct);
79 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE2, GPIO_MUX_7);
80 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE3, GPIO_MUX_7);
81
82 /* configure the usart3 tx, rx pin */
83 gpio_init_struct.gpio_pins = GPIO_PINS_10 | GPIO_PINS_11;
84 gpio_init(GPIOB, &gpio_init_struct);
85 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE10, GPIO_MUX_7);
86 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE11, GPIO_MUX_7);
87
88 /* config usart nvic interrupt */
89 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
90 nvic_irq_enable(USART2_IRQn, 0, 0);
91 nvic_irq_enable(USART3_IRQn, 0, 0);
92
93 /* configure usart2 param */
94 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
95 usart_transmitter_enable(USART2, TRUE);
96 usart_receiver_enable(USART2, TRUE);
97
98 /* configure usart3 param */
99 usart_init(USART3, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
100 usart_transmitter_enable(USART3, TRUE);
101 usart_receiver_enable(USART3, TRUE);
102
103 /* enable usart2 and usart3 interrupt */
104 usart_interrupt_enable(USART2, USART_RDBF_INT, TRUE);
105 usart_enable(USART2, TRUE);
106
107 usart_interrupt_enable(USART3, USART_RDBF_INT, TRUE);
108 usart_enable(USART3, TRUE);
109
110 usart_interrupt_enable(USART2, USART_TDBE_INT, TRUE);
111 usart_interrupt_enable(USART3, USART_TDBE_INT, TRUE);
112}
113
121uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
122{
123 while(buffer_length--)
124 {
125 if(*pbuffer1 != *pbuffer2)
126 {
127 return 0;
128 }
129 pbuffer1++;
130 pbuffer2++;
131 }
132 return 1;
133}
134
140int main(void)
141{
142 system_clock_config();
143 at32_board_init();
144 usart_configuration();
145
146 /* wait until end of transmission from usart2 to usart3 */
147 while(usart3_rx_counter < usart2_tx_buffer_size);
148
149 /* wait until end of transmission from usart3 to usart2 */
150 while(usart2_rx_counter < usart3_tx_buffer_size);
151
152 while(1)
153 {
154 /* compare data buffer */
155 if(buffer_compare(usart2_tx_buffer, usart3_rx_buffer, USART2_TX_BUFFER_SIZE) && \
156 buffer_compare(usart3_tx_buffer, usart2_rx_buffer, USART3_TX_BUFFER_SIZE))
157 {
158 at32_led_toggle(LED2);
159 at32_led_toggle(LED3);
160 at32_led_toggle(LED4);
161 delay_sec(1);
162 }
163 }
164}
165
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f435/examples/usart/interrupt/src/main.c:58
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f435/examples/usart/interrupt/src/main.c:121
usart3_rx_counter
volatile uint8_t usart3_rx_counter
Definition: project/at_start_f435/examples/usart/interrupt/src/main.c:49
usart2_rx_counter
volatile uint8_t usart2_rx_counter
Definition: project/at_start_f435/examples/usart/interrupt/src/main.c:48
usart2_tx_counter
volatile uint8_t usart2_tx_counter
Definition: project/at_start_f435/examples/usart/interrupt/src/main.c:46
usart3_tx_counter
volatile uint8_t usart3_tx_counter
Definition: project/at_start_f435/examples/usart/interrupt/src/main.c:47
usart2_tx_buffer_size
uint8_t usart2_tx_buffer_size
Definition: project/at_start_f435/examples/usart/interrupt/src/main.c:50
usart3_rx_buffer
uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
Definition: project/at_start_f435/examples/usart/interrupt/src/main.c:45
USART2_TX_BUFFER_SIZE
#define USART2_TX_BUFFER_SIZE
Definition: project/at_start_f435/examples/usart/interrupt/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f435/examples/usart/interrupt/src/main.c:140
usart3_tx_buffer_size
uint8_t usart3_tx_buffer_size
Definition: project/at_start_f435/examples/usart/interrupt/src/main.c:51
usart2_tx_buffer
uint8_t usart2_tx_buffer[]
Definition: project/at_start_f435/examples/usart/interrupt/src/main.c:42
USART3_TX_BUFFER_SIZE
#define USART3_TX_BUFFER_SIZE
Definition: project/at_start_f435/examples/usart/interrupt/src/main.c:40
usart3_tx_buffer
uint8_t usart3_tx_buffer[]
Definition: project/at_start_f435/examples/usart/interrupt/src/main.c:43
usart2_rx_buffer
uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
Definition: project/at_start_f435/examples/usart/interrupt/src/main.c:44
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_USART3_PERIPH_CLOCK
@ CRM_USART3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:141
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:140
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f435_437_usart.c:209
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f435_437_usart.c:115
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f435_437_usart.c:196
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f435_437_usart.c:222
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f435_437_usart.c:287
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f435_437_usart.h:159
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f435_437_usart.h:114
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f435_437_usart.h:73
USART_TDBE_INT
#define USART_TDBE_INT
Definition: at32f435_437_usart.h:75
USART3
#define USART3
Definition: at32f435_437_usart.h:350
USART2
#define USART2
Definition: at32f435_437_usart.h:349
USART2_IRQn
@ USART2_IRQn
Definition: at32f435_437.h:186
USART3_IRQn
@ USART3_IRQn
Definition: at32f435_437.h:187
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • usart
  • irda
  • inc
project/at_start_f435/examples/usart/irda/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • usart
  • irda
  • inc
project/at_start_f435/examples/usart/irda/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • usart
  • irda
  • inc
project/at_start_f435/examples/usart/irda/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • usart
  • irda
  • src
Functions
project/at_start_f435/examples/usart/irda/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/irda/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • usart
  • irda
  • src
project/at_start_f435/examples/usart/irda/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/usart/irda/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • usart
  • irda
  • src
Functions
project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • usart
  • irda
  • src
project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/usart/irda/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • usart
  • irda
  • src
Functions
project/at_start_f435/examples/usart/irda/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void | usart_configuration (void)
config usart More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/irda/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • usart
  • irda
  • src
project/at_start_f435/examples/usart/irda/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
43void usart_configuration(void)
44{
45 gpio_init_type gpio_init_struct;
46
47 /* enable the usart2 and gpio clock */
48 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
49 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
50
51 gpio_default_para_init(&gpio_init_struct);
52
53 /* configure the usart2 tx, rx pin */
54 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
55 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
56 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
57 gpio_init_struct.gpio_pins = GPIO_PINS_2 | GPIO_PINS_3;
58 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
59 gpio_init(GPIOA, &gpio_init_struct);
60 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE2, GPIO_MUX_7);
61 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE3, GPIO_MUX_7);
62
63 /* configure usart2 param */
64 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
65 usart_transmitter_enable(USART2, TRUE);
66 usart_receiver_enable(USART2, TRUE);
67 usart_irda_smartcard_division_set(USART2, 0x01);
68 usart_irda_mode_enable(USART2, TRUE);
69 usart_enable(USART2, TRUE);
70}
71
77int main(void)
78{
79 system_clock_config();
80 at32_board_init();
81 at32_led_off(LED2);
82 at32_led_off(LED3);
83 at32_led_off(LED4);
84 usart_configuration();
85
86#if defined(TRANSMIT)
87 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
88 usart_data_transmit(USART2, 0x55);
89 at32_led_on(LED4);
90#endif
91
92#if defined(RECEIVE)
93 while(usart_flag_get(USART2, USART_RDBF_FLAG) == RESET);
94 if(usart_data_receive(USART2) == 0x55)
95 {
96 at32_led_on(LED4);
97 }
98#endif
99
100 while(1)
101 {
102 }
103}
104
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f435/examples/usart/irda/src/main.c:43
main
int main(void)
main function.
Definition: project/at_start_f435/examples/usart/irda/src/main.c:77
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:140
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f435_437_usart.c:413
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f435_437_usart.c:598
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f435_437_usart.c:209
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f435_437_usart.c:115
usart_irda_smartcard_division_set
void usart_irda_smartcard_division_set(usart_type *usart_x, uint8_t div_val)
config the irda/smartcard division.
Definition: at32f435_437_usart.c:465
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f435_437_usart.c:196
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f435_437_usart.c:222
usart_irda_mode_enable
void usart_irda_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's irda interface.
Definition: at32f435_437_usart.c:523
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f435_437_usart.c:425
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f435_437_usart.h:159
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f435_437_usart.h:114
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f435_437_usart.h:59
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f435_437_usart.h:57
USART2
#define USART2
Definition: at32f435_437_usart.h:349
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • usart
  • polling
  • inc
project/at_start_f435/examples/usart/polling/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • usart
  • polling
  • inc
project/at_start_f435/examples/usart/polling/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • usart
  • polling
  • inc
project/at_start_f435/examples/usart/polling/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • usart
  • polling
  • src
Functions
project/at_start_f435/examples/usart/polling/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/polling/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • usart
  • polling
  • src
project/at_start_f435/examples/usart/polling/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/usart/polling/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • usart
  • polling
  • src
Functions
project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • usart
  • polling
  • src
project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/usart/polling/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • usart
  • polling
  • src
Macros | Functions | Variables
project/at_start_f435/examples/usart/polling/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | usart_configuration (void)
config usart More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"
uint8_t | usart3_tx_buffer [] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | usart2_tx_counter = 0x00
uint8_t | usart3_tx_counter = 0x00
uint8_t | usart2_rx_counter = 0x00
uint8_t | usart3_rx_counter = 0x00
uint8_t | usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)
uint8_t | usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/polling/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • usart
  • polling
  • src
project/at_start_f435/examples/usart/polling/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define COUNTOF(a) (sizeof(a) / sizeof(*(a)))
39#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
40#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)
41
42uint8_t usart2_tx_buffer[] = "usart transfer by interrupt: usart2 -> usart3 using interrupt";
43uint8_t usart3_tx_buffer[] = "usart transfer by interrupt: usart3 -> usart2 using interrupt";
44uint8_t usart2_rx_buffer[USART3_TX_BUFFER_SIZE];
45uint8_t usart3_rx_buffer[USART2_TX_BUFFER_SIZE];
46uint8_t usart2_tx_counter = 0x00;
47uint8_t usart3_tx_counter = 0x00;
48uint8_t usart2_rx_counter = 0x00;
49uint8_t usart3_rx_counter = 0x00;
50uint8_t usart2_tx_buffer_size = USART2_TX_BUFFER_SIZE;
51uint8_t usart3_tx_buffer_size = USART3_TX_BUFFER_SIZE;
52
58void usart_configuration(void)
59{
60 gpio_init_type gpio_init_struct;
61
62 /* enable the usart2 and gpio clock */
63 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
64 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
65
66 /* enable the usart3 and gpio clock */
67 crm_periph_clock_enable(CRM_USART3_PERIPH_CLOCK, TRUE);
68 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
69
70 gpio_default_para_init(&gpio_init_struct);
71
72 /* configure the usart2 tx, rx pin */
73 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
74 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
75 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
76 gpio_init_struct.gpio_pins = GPIO_PINS_2 | GPIO_PINS_3;
77 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
78 gpio_init(GPIOA, &gpio_init_struct);
79 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE2, GPIO_MUX_7);
80 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE3, GPIO_MUX_7);
81
82 /* configure the usart3 tx, rx pin */
83 gpio_init_struct.gpio_pins = GPIO_PINS_10 | GPIO_PINS_11;
84 gpio_init(GPIOB, &gpio_init_struct);
85 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE10, GPIO_MUX_7);
86 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE11, GPIO_MUX_7);
87
88 /* configure usart2 param */
89 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
90 usart_parity_selection_config(USART2, USART_PARITY_NONE);
91 usart_transmitter_enable(USART2, TRUE);
92 usart_receiver_enable(USART2, TRUE);
93 usart_enable(USART2, TRUE);
94
95 /* configure usart3 param */
96 usart_init(USART3, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
97 usart_parity_selection_config(USART3, USART_PARITY_NONE);
98 usart_transmitter_enable(USART3, TRUE);
99 usart_receiver_enable(USART3, TRUE);
100 usart_enable(USART3, TRUE);
101}
102
110uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
111{
112 while(buffer_length--)
113 {
114 if(*pbuffer1 != *pbuffer2)
115 {
116 return 0;
117 }
118 pbuffer1++;
119 pbuffer2++;
120 }
121 return 1;
122}
123
129int main(void)
130{
131 system_clock_config();
132 at32_board_init();
133 usart_configuration();
134
135 /* wait until end of transmission from usart2 to usart3 */
136 while(usart3_rx_counter < usart2_tx_buffer_size)
137 {
138 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
139 usart_data_transmit(USART2, usart2_tx_buffer[usart2_tx_counter++]);
140
141 while(usart_flag_get(USART3, USART_RDBF_FLAG) == RESET);
142 usart3_rx_buffer[usart3_rx_counter++] = usart_data_receive(USART3);
143 }
144
145 /* wait until end of transmission from usart3 to usart2 */
146 while(usart2_rx_counter < usart3_tx_buffer_size)
147 {
148 while(usart_flag_get(USART3, USART_TDBE_FLAG) == RESET);
149 usart_data_transmit(USART3, usart3_tx_buffer[usart3_tx_counter++]);
150
151 while(usart_flag_get(USART2, USART_RDBF_FLAG) == RESET);
152 usart2_rx_buffer[usart2_rx_counter++] = usart_data_receive(USART2);
153 }
154
155 while(1)
156 {
157 /* compare data buffer */
158 if(buffer_compare(usart2_tx_buffer, usart3_rx_buffer, USART2_TX_BUFFER_SIZE) && \
159 buffer_compare(usart3_tx_buffer, usart2_rx_buffer, USART3_TX_BUFFER_SIZE))
160 {
161 at32_led_toggle(LED2);
162 at32_led_toggle(LED3);
163 at32_led_toggle(LED4);
164 delay_sec(1);
165 }
166 }
167}
168
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f435/examples/usart/polling/src/main.c:58
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f435/examples/usart/polling/src/main.c:110
usart3_tx_counter
uint8_t usart3_tx_counter
Definition: project/at_start_f435/examples/usart/polling/src/main.c:47
usart2_tx_counter
uint8_t usart2_tx_counter
Definition: project/at_start_f435/examples/usart/polling/src/main.c:46
usart2_tx_buffer_size
uint8_t usart2_tx_buffer_size
Definition: project/at_start_f435/examples/usart/polling/src/main.c:50
usart3_rx_buffer
uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
Definition: project/at_start_f435/examples/usart/polling/src/main.c:45
usart2_rx_counter
uint8_t usart2_rx_counter
Definition: project/at_start_f435/examples/usart/polling/src/main.c:48
USART2_TX_BUFFER_SIZE
#define USART2_TX_BUFFER_SIZE
Definition: project/at_start_f435/examples/usart/polling/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f435/examples/usart/polling/src/main.c:129
usart3_tx_buffer_size
uint8_t usart3_tx_buffer_size
Definition: project/at_start_f435/examples/usart/polling/src/main.c:51
usart2_tx_buffer
uint8_t usart2_tx_buffer[]
Definition: project/at_start_f435/examples/usart/polling/src/main.c:42
USART3_TX_BUFFER_SIZE
#define USART3_TX_BUFFER_SIZE
Definition: project/at_start_f435/examples/usart/polling/src/main.c:40
usart3_tx_buffer
uint8_t usart3_tx_buffer[]
Definition: project/at_start_f435/examples/usart/polling/src/main.c:43
usart3_rx_counter
uint8_t usart3_rx_counter
Definition: project/at_start_f435/examples/usart/polling/src/main.c:49
usart2_rx_buffer
uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
Definition: project/at_start_f435/examples/usart/polling/src/main.c:44
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_USART3_PERIPH_CLOCK
@ CRM_USART3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:141
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:140
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f435_437_usart.c:413
usart_parity_selection_config
void usart_parity_selection_config(usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config.
Definition: at32f435_437_usart.c:168
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f435_437_usart.c:598
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f435_437_usart.c:209
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f435_437_usart.c:115
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f435_437_usart.c:196
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f435_437_usart.c:222
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f435_437_usart.c:425
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f435_437_usart.h:159
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f435_437_usart.h:114
USART_PARITY_NONE
@ USART_PARITY_NONE
Definition: at32f435_437_usart.h:94
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f435_437_usart.h:59
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f435_437_usart.h:57
USART3
#define USART3
Definition: at32f435_437_usart.h:350
USART2
#define USART2
Definition: at32f435_437_usart.h:349
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • usart
  • printf
  • inc
project/at_start_f435/examples/usart/printf/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • usart
  • printf
  • inc
project/at_start_f435/examples/usart/printf/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • usart
  • printf
  • inc
project/at_start_f435/examples/usart/printf/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • usart
  • printf
  • src
Functions
project/at_start_f435/examples/usart/printf/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/printf/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • usart
  • printf
  • src
project/at_start_f435/examples/usart/printf/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/usart/printf/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • usart
  • printf
  • src
Functions
project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • usart
  • printf
  • src
project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/usart/printf/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • usart
  • printf
  • src
Functions | Variables
project/at_start_f435/examples/usart/printf/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

__IO uint32_t time_cnt = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/printf/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • usart
  • printf
  • src
project/at_start_f435/examples/usart/printf/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38__IO uint32_t time_cnt = 0;
39
45int main(void)
46{
47 system_clock_config();
48 at32_board_init();
49 uart_print_init(115200);
50
51 /* output a message on hyperterminal using printf function */
52 printf("usart printf example: retarget the c library printf function to the usart\r\n");
53
54 while(1)
55 {
56 printf("usart printf counter: %u\r\n",time_cnt++);
57 delay_sec(1);
58 }
59}
60
at32f435_437_board.h
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
main
int main(void)
main function.
Definition: project/at_start_f435/examples/usart/printf/src/main.c:45
time_cnt
__IO uint32_t time_cnt
Definition: project/at_start_f435/examples/usart/printf/src/main.c:38
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f435_437_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • usart
  • receiver_mute
  • inc
project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • usart
  • receiver_mute
  • inc
project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • usart
  • receiver_mute
  • inc
project/at_start_f435/examples/usart/receiver_mute/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • usart
  • receiver_mute
  • src
Functions
project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • usart
  • receiver_mute
  • src
project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • usart
  • receiver_mute
  • src
Functions | Variables
project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | USART3_IRQHandler (void)
this function handles usart3 handler. More...

Variables

uint8_t | usart3_rx_buffer []
uint8_t | rx_counter

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • usart
  • receiver_mute
  • src
project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
38extern uint8_t usart3_rx_buffer[];
39extern uint8_t rx_counter;
40
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
143void USART3_IRQHandler(void)
144{
145 if(usart_flag_get(USART3, USART_RDBF_FLAG) != RESET)
146 {
147 usart3_rx_buffer[rx_counter++] = usart_data_receive(USART3);
148 }
149}
150
USART3_IRQHandler
void USART3_IRQHandler(void)
this function handles usart3 handler.
Definition: project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c:143
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c:107
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c:46
rx_counter
uint8_t rx_counter
Definition: project/at_start_f435/examples/usart/receiver_mute/src/main.c:49
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c:81
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c:134
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/usart/receiver_mute/src/at32f435_437_int.c:116
usart3_rx_buffer
uint8_t usart3_rx_buffer[]
Definition: project/at_start_f435/examples/usart/half_duplex/src/main.c:45
RESET
@ RESET
Definition: at32f435_437.h:378
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f435_437_usart.c:598
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f435_437_usart.c:425
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f435_437_usart.h:57
USART3
#define USART3
Definition: at32f435_437_usart.h:350
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • usart
  • receiver_mute
  • src
Macros | Functions | Variables
project/at_start_f435/examples/usart/receiver_mute/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define | BUFFER_SIZE 7
#define | MATCH_ID_VAL 0x81
#define | ERROR_ID_VAL 0x82
#define | DATA1_VAL 0x7F
#define | DATA2_VAL 0x7A
#define | DATA3_VAL 0x7B
#define | DATA4_VAL 0x7C

Functions

void | usart_configuration (void)
config usart More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [7] = { 0x7F , 0x81 , 0x7A , 0x82 , 0x7B , 0x81 , 0x7C }
uint8_t | usart3_rx_buffer [7]
uint8_t | tx_counter = 0
uint8_t | rx_counter = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/receiver_mute/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • usart
  • receiver_mute
  • src
project/at_start_f435/examples/usart/receiver_mute/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define BUFFER_SIZE 7
39#define MATCH_ID_VAL 0x81
40#define ERROR_ID_VAL 0x82
41#define DATA1_VAL 0x7F
42#define DATA2_VAL 0x7A
43#define DATA3_VAL 0x7B
44#define DATA4_VAL 0x7C
45
46uint8_t usart2_tx_buffer[BUFFER_SIZE] = {DATA1_VAL, MATCH_ID_VAL, DATA2_VAL, ERROR_ID_VAL, DATA3_VAL, MATCH_ID_VAL, DATA4_VAL};
47uint8_t usart3_rx_buffer[BUFFER_SIZE];
48uint8_t tx_counter = 0;
49uint8_t rx_counter = 0;
50
56void usart_configuration(void)
57{
58 gpio_init_type gpio_init_struct;
59
60 /* enable the usart2 and gpio clock */
61 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
62 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
63
64 /* enable the usart3 and gpio clock */
65 crm_periph_clock_enable(CRM_USART3_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
67
68 gpio_default_para_init(&gpio_init_struct);
69
70 /* configure the usart2 tx pin */
71 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
72 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
73 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
74 gpio_init_struct.gpio_pins = GPIO_PINS_2;
75 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
76 gpio_init(GPIOA, &gpio_init_struct);
77 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE2, GPIO_MUX_7);
78
79 /* configure the usart3 rx pin */
80 gpio_init_struct.gpio_pins = GPIO_PINS_11;
81 gpio_init(GPIOB, &gpio_init_struct);
82 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE11, GPIO_MUX_7);
83
84 /* configure usart2 param */
85 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
86 usart_transmitter_enable(USART2, TRUE);
87 usart_enable(USART2, TRUE);
88
89 /* config usart3 nvic interrupt */
90 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
91 nvic_irq_enable(USART3_IRQn, 0 ,0);
92
93 /* configure usart3 param */
94 usart_init(USART3, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
95 usart_receiver_enable(USART3, TRUE);
96 usart_interrupt_enable(USART3, USART_RDBF_INT, TRUE);
97 usart_wakeup_id_set(USART3, 0x01);
98 usart_wakeup_mode_set(USART3, USART_WAKEUP_BY_MATCHING_ID);
99 usart_receiver_mute_enable(USART3, TRUE);
100 usart_enable(USART3, TRUE);
101}
102
108int main(void)
109{
110 system_clock_config();
111 at32_board_init();
112 usart_configuration();
113
114 /* usart2 transmit data */
115 while(tx_counter < BUFFER_SIZE)
116 {
117 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
118 usart_data_transmit(USART2, usart2_tx_buffer[tx_counter++]);
119 }
120
121 /* wait usart2 data transmission complete */
122 while(usart_flag_get(USART2, USART_TDC_FLAG) == RESET);
123
124 while(1)
125 {
126 if((usart3_rx_buffer[0] == MATCH_ID_VAL) && (usart3_rx_buffer[1] == DATA2_VAL) && \
127 (usart3_rx_buffer[2] == MATCH_ID_VAL) && (usart3_rx_buffer[3] == DATA4_VAL))
128 {
129 at32_led_toggle(LED2);
130 at32_led_toggle(LED3);
131 at32_led_toggle(LED4);
132 delay_sec(1);
133 }
134 }
135}
136
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
DATA4_VAL
#define DATA4_VAL
Definition: project/at_start_f435/examples/usart/receiver_mute/src/main.c:44
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f435/examples/usart/receiver_mute/src/main.c:56
usart2_tx_buffer
uint8_t usart2_tx_buffer[7]
Definition: project/at_start_f435/examples/usart/receiver_mute/src/main.c:46
ERROR_ID_VAL
#define ERROR_ID_VAL
Definition: project/at_start_f435/examples/usart/receiver_mute/src/main.c:40
tx_counter
uint8_t tx_counter
Definition: project/at_start_f435/examples/usart/receiver_mute/src/main.c:48
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f435/examples/usart/receiver_mute/src/main.c:38
rx_counter
uint8_t rx_counter
Definition: project/at_start_f435/examples/usart/receiver_mute/src/main.c:49
main
int main(void)
main function.
Definition: project/at_start_f435/examples/usart/receiver_mute/src/main.c:108
DATA2_VAL
#define DATA2_VAL
Definition: project/at_start_f435/examples/usart/receiver_mute/src/main.c:42
DATA3_VAL
#define DATA3_VAL
Definition: project/at_start_f435/examples/usart/receiver_mute/src/main.c:43
MATCH_ID_VAL
#define MATCH_ID_VAL
Definition: project/at_start_f435/examples/usart/receiver_mute/src/main.c:39
usart3_rx_buffer
uint8_t usart3_rx_buffer[7]
Definition: project/at_start_f435/examples/usart/receiver_mute/src/main.c:47
DATA1_VAL
#define DATA1_VAL
Definition: project/at_start_f435/examples/usart/receiver_mute/src/main.c:41
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_USART3_PERIPH_CLOCK
@ CRM_USART3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:141
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:140
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f435_437_usart.c:413
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f435_437_usart.c:598
usart_wakeup_id_set
void usart_wakeup_id_set(usart_type *usart_x, uint8_t usart_id)
set the wakeup id of the usart.
Definition: at32f435_437_usart.c:331
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f435_437_usart.c:209
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f435_437_usart.c:115
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f435_437_usart.c:196
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f435_437_usart.c:222
usart_wakeup_mode_set
void usart_wakeup_mode_set(usart_type *usart_x, usart_wakeup_mode_type wakeup_mode)
select the usart wakeup method in multi-processor communication.
Definition: at32f435_437_usart.c:356
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f435_437_usart.c:287
usart_receiver_mute_enable
void usart_receiver_mute_enable(usart_type *usart_x, confirm_state new_state)
config the usart in mute mode in multi-processor communication.
Definition: at32f435_437_usart.c:370
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f435_437_usart.h:159
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f435_437_usart.h:114
USART_WAKEUP_BY_MATCHING_ID
@ USART_WAKEUP_BY_MATCHING_ID
Definition: at32f435_437_usart.h:105
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f435_437_usart.h:59
USART_TDC_FLAG
#define USART_TDC_FLAG
Definition: at32f435_437_usart.h:58
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f435_437_usart.h:73
USART3
#define USART3
Definition: at32f435_437_usart.h:350
USART2
#define USART2
Definition: at32f435_437_usart.h:349
USART3_IRQn
@ USART3_IRQn
Definition: at32f435_437.h:187
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • usart
  • rs485
  • inc
project/at_start_f435/examples/usart/rs485/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • usart
  • rs485
  • inc
project/at_start_f435/examples/usart/rs485/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • usart
  • rs485
  • inc
project/at_start_f435/examples/usart/rs485/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • usart
  • rs485
  • src
Functions
project/at_start_f435/examples/usart/rs485/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/rs485/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • usart
  • rs485
  • src
project/at_start_f435/examples/usart/rs485/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource */
71 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
72
73 /* enable pll */
74 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
75
76 /* wait till pll is ready */
77 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
78 {
79 }
80
81 /* config ahbclk */
82 crm_ahb_div_set(CRM_AHB_DIV_1);
83
84 /* config apb2clk */
85 crm_apb2_div_set(CRM_APB2_DIV_2);
86
87 /* config apb1clk */
88 crm_apb1_div_set(CRM_APB1_DIV_2);
89
90 /* enable auto step mode */
91 crm_auto_step_mode_enable(TRUE);
92
93 /* select pll as system clock source */
94 crm_sysclk_switch(CRM_SCLK_PLL);
95
96 /* wait till pll is used as system clock source */
97 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
98 {
99 }
100
101 /* disable auto step mode */
102 crm_auto_step_mode_enable(FALSE);
103
104 /* update system_core_clock global variable */
105 system_core_clock_update();
106}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/usart/rs485/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • usart
  • rs485
  • src
Functions
project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • usart
  • rs485
  • src
project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/usart/rs485/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • usart
  • rs485
  • src
Macros | Functions | Variables
project/at_start_f435/examples/usart/rs485/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define | RS485_BAUDRATE 9600
#define | RS485_BUFFER_SIZE 128

Functions

static void | rs485_config (void)
rs485 configiguration. More...
static void | rs485_send_data (u8 *buf, u8 cnt)
rs485 send data More...
int | main (void)
main function. More...
void | USART2_IRQHandler (void)
usart2 interrupt handler More...

Variables

uint8_t | rs485_buffer_rx [128]
uint8_t | rs485_buffer_rx_cnt = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/rs485/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • usart
  • rs485
  • src
project/at_start_f435/examples/usart/rs485/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define RS485_BAUDRATE 9600
39#define RS485_BUFFER_SIZE 128
40
41uint8_t rs485_buffer_rx[RS485_BUFFER_SIZE];
42uint8_t rs485_buffer_rx_cnt = 0;
43
49static void rs485_config(void)
50{
51 gpio_init_type gpio_init_struct;
52
53 /* enable the uart2 and gpio clock */
54 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
55 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
56
57 gpio_default_para_init(&gpio_init_struct);
58
59 /* configure the uart2 tx,rx,de pin */
60 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
61 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
62 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
63 gpio_init_struct.gpio_pins = GPIO_PINS_2|GPIO_PINS_3;
64 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
65 gpio_init(GPIOA, &gpio_init_struct);
66
67 gpio_init_struct.gpio_pins = GPIO_PINS_1;
68 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
69 gpio_init(GPIOA, &gpio_init_struct);
70
71 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE1, GPIO_MUX_7);
72 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE2, GPIO_MUX_7);
73 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE3, GPIO_MUX_7);
74
75 /* configure uart2 param */
76 usart_init(USART2, RS485_BAUDRATE, USART_DATA_8BITS, USART_STOP_1_BIT);
77 usart_rs485_delay_time_config(USART2, 2, 2);
78 usart_de_polarity_set(USART2, USART_DE_POLARITY_HIGH);
79 usart_rs485_mode_enable(USART2, TRUE);
80
81 usart_flag_clear(USART2, USART_RDBF_FLAG);
82 usart_interrupt_enable(USART2, USART_RDBF_INT, TRUE);
83
84 usart_receiver_enable(USART2, TRUE);
85 usart_transmitter_enable(USART2, TRUE);
86 usart_enable(USART2, TRUE);
87
88 nvic_irq_enable(USART2_IRQn, 1, 0);
89}
90
97static void rs485_send_data(u8* buf, u8 cnt)
98{
99 while(cnt--){
100 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
101 usart_data_transmit(USART2, *buf++);
102 }
103}
104
110int main(void)
111{
112 char str[]="start test..\r\n";
113 u8 len = 0;
114
115 system_clock_config();
116 at32_board_init();
117 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
118
119 rs485_config();
120
121 len = sizeof(str);
122 rs485_send_data((u8*)str, len);
123 while(1)
124 {
125 if(usart_flag_get(USART2, USART_IDLEF_FLAG) != RESET)
126 {
127 usart_data_receive(USART2);
128 usart_interrupt_enable(USART2, USART_RDBF_INT, FALSE);
129 rs485_send_data(rs485_buffer_rx, rs485_buffer_rx_cnt);
130 rs485_buffer_rx_cnt = 0;
131 usart_interrupt_enable(USART2, USART_RDBF_INT, TRUE);
132 }
133 }
134}
135
141void USART2_IRQHandler(void)
142{
143 uint16_t tmp;
144
145 if(usart_flag_get(USART2, USART_RDBF_FLAG) != RESET)
146 {
147 tmp = usart_data_receive(USART2);
148 if(rs485_buffer_rx_cnt < RS485_BUFFER_SIZE)
149 {
150 rs485_buffer_rx[rs485_buffer_rx_cnt++] = tmp;
151 }
152 }
153}
154
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
USART2_IRQHandler
void USART2_IRQHandler(void)
usart2 interrupt handler
Definition: project/at_start_f435/examples/usart/rs485/src/main.c:141
rs485_send_data
static void rs485_send_data(u8 *buf, u8 cnt)
rs485 send data
Definition: project/at_start_f435/examples/usart/rs485/src/main.c:97
RS485_BAUDRATE
#define RS485_BAUDRATE
Definition: project/at_start_f435/examples/usart/rs485/src/main.c:38
rs485_config
static void rs485_config(void)
rs485 configiguration.
Definition: project/at_start_f435/examples/usart/rs485/src/main.c:49
main
int main(void)
main function.
Definition: project/at_start_f435/examples/usart/rs485/src/main.c:110
rs485_buffer_rx
uint8_t rs485_buffer_rx[128]
Definition: project/at_start_f435/examples/usart/rs485/src/main.c:41
RS485_BUFFER_SIZE
#define RS485_BUFFER_SIZE
Definition: project/at_start_f435/examples/usart/rs485/src/main.c:39
rs485_buffer_rx_cnt
uint8_t rs485_buffer_rx_cnt
Definition: project/at_start_f435/examples/usart/rs485/src/main.c:42
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:140
u8
uint8_t u8
Definition: at32f435_437.h:364
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f435_437_gpio.h:134
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f435_437_gpio.h:52
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
usart_rs485_mode_enable
void usart_rs485_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's rs485 mode.
Definition: at32f435_437_usart.c:715
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f435_437_usart.c:413
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f435_437_usart.c:598
usart_de_polarity_set
void usart_de_polarity_set(usart_type *usart_x, usart_de_polarity_type de_polarity)
set the usart's de polarity.
Definition: at32f435_437_usart.c:701
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f435_437_usart.c:209
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f435_437_usart.c:115
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f435_437_usart.c:196
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f435_437_usart.c:222
usart_flag_clear
void usart_flag_clear(usart_type *usart_x, uint32_t flag)
clear the usart's pending flags.
Definition: at32f435_437_usart.c:636
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f435_437_usart.c:287
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f435_437_usart.c:425
usart_rs485_delay_time_config
void usart_rs485_delay_time_config(usart_type *usart_x, uint8_t start_delay_time, uint8_t complete_delay_time)
configure the usart's rs485 transmit delay time.
Definition: at32f435_437_usart.c:658
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f435_437_usart.h:159
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f435_437_usart.h:114
USART_DE_POLARITY_HIGH
@ USART_DE_POLARITY_HIGH
Definition: at32f435_437_usart.h:190
USART_IDLEF_FLAG
#define USART_IDLEF_FLAG
Definition: at32f435_437_usart.h:56
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f435_437_usart.h:59
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f435_437_usart.h:57
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f435_437_usart.h:73
USART2
#define USART2
Definition: at32f435_437_usart.h:349
USART2_IRQn
@ USART2_IRQn
Definition: at32f435_437.h:186
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • usart
  • smartcard
  • inc
project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • usart
  • smartcard
  • inc
project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • usart
  • smartcard
  • inc
project/at_start_f435/examples/usart/smartcard/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • usart
  • smartcard
  • src
Functions
project/at_start_f435/examples/usart/smartcard/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/smartcard/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • usart
  • smartcard
  • src
project/at_start_f435/examples/usart/smartcard/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/usart/smartcard/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • usart
  • smartcard
  • src
Functions | Variables
project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"
#include "smartcard_config.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | EXINT9_5_IRQHandler (void)
this function handles external lines 9 to 5 interrupt request. More...
void | SC_USART_IRQHandler (void)
this function handles sc_usart global interrupt request. More...

Variables

uint32_t card_inserted

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • usart
  • smartcard
  • src
project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29#include "smartcard_config.h"
30
39extern uint32_t card_inserted;
40
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
143void EXINT9_5_IRQHandler(void)
144{
145 /* reset smart card cmdvcc */
146 gpio_bits_reset(SC_CMDVCC_PORT, SC_CMDVCC_PIN);
147
148 /* rst low */
149 gpio_bits_reset(SC_RESET_PORT, SC_RESET_PIN);
150
151 /* rst high */
152 gpio_bits_set(SC_RESET_PORT, SC_RESET_PIN);
153
154 /* clear sc exint line pending bit */
155 exint_flag_clear(SC_OFF_EXINT);
156
157 /* smart card detected */
158 card_inserted = 1;
159}
160
166void SC_USART_IRQHandler(void)
167{
168 /* if the sc_usart detects a parity error */
169 if(usart_flag_get(SC_USART, USART_PERR_FLAG) != RESET)
170 {
171 /* enable sc_usart rdbf interrupt (until receiving the corrupted byte) */
172 usart_interrupt_enable(SC_USART, USART_RDBF_INT, TRUE);
173 /* flush the sc_usart dr register */
174 usart_data_receive(SC_USART);
175 }
176
177 if(usart_flag_get(SC_USART, USART_RDBF_FLAG) != RESET)
178 {
179 /* disable sc_usart rdbf interrupt */
180 usart_interrupt_enable(SC_USART, USART_RDBF_INT, FALSE);
181 usart_data_receive(SC_USART);
182 }
183}
184
SC_RESET_PIN
#define SC_RESET_PIN
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:44
SC_RESET_PORT
#define SC_RESET_PORT
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:48
SC_OFF_EXINT
#define SC_OFF_EXINT
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:55
SC_USART
#define SC_USART
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:32
SC_CMDVCC_PORT
#define SC_CMDVCC_PORT
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:49
SC_CMDVCC_PIN
#define SC_CMDVCC_PIN
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:45
EXINT9_5_IRQHandler
void EXINT9_5_IRQHandler(void)
this function handles external lines 9 to 5 interrupt request.
Definition: project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c:143
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c:107
SC_USART_IRQHandler
void SC_USART_IRQHandler(void)
this function handles sc_usart global interrupt request.
Definition: project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c:166
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c:46
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c:81
card_inserted
uint32_t card_inserted
Definition: project/at_start_f435/examples/usart/smartcard/src/main.c:63
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c:134
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/usart/smartcard/src/at32f435_437_int.c:116
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f435_437_gpio.c:308
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f435_437_gpio.c:277
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f435_437_usart.c:598
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f435_437_usart.c:287
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f435_437_usart.c:425
USART_PERR_FLAG
#define USART_PERR_FLAG
Definition: at32f435_437_usart.h:52
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f435_437_usart.h:57
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f435_437_usart.h:73
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • usart
  • smartcard
  • src
Data Structures | Macros | Functions | Variables
project/at_start_f435/examples/usart/smartcard/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include "smartcard_config.h"

Go to the source code of this file.

Data Structures

struct sc_atr_type

Macros

#define | T0_PROTOCOL 0x00 /* t0 protocol */
#define | SETUP_LENGTH 20
#define | HIST_LENGTH 20
#define | SC_RECEIVE_TIMEOUT 0xA000 /* direction to reader */
#define | SC_USART_DIV_VAL 20 /* ISO 7816-3 protocol: SC_CLOCK_FREQ(PCLK/(2*USART_DIV_VAL)) is between 1 and 5 MHz */
#define | SC_F_DIV_D 372 /* ISO 7816-3 protocol: F/D = 372 */

Functions

void | usart_configuration (void)
config usart More...
uint8_t | sc_response_decode (__IO uint8_t *card)
decode the card atr response. More...
int | main (void)
main function. More...

Variables

sc_atr_type sc_a2r_struct
uint32_t | sc_baud_rate = 0
uint32_t | sc_clock_freq = 0
uint32_t | counter = 0
error_status atr_decode_status = ERROR
uint32_t | card_inserted = 0
uint32_t | card_protocol = 1
uint8_t | dst_buffer [50]

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/smartcard/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • usart
  • smartcard
  • src
project/at_start_f435/examples/usart/smartcard/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include "smartcard_config.h"
30
39#define T0_PROTOCOL 0x00 /* t0 protocol */
40#define SETUP_LENGTH 20
41#define HIST_LENGTH 20
42#define SC_RECEIVE_TIMEOUT 0xA000 /* direction to reader */
43
44#define SC_USART_DIV_VAL 20 /* ISO 7816-3 protocol: SC_CLOCK_FREQ(PCLK/(2*USART_DIV_VAL)) is between 1 and 5 MHz */
45#define SC_F_DIV_D 372 /* ISO 7816-3 protocol: F/D = 372 */
46
47/* atr structure - answer to reset */
48typedef struct
49{
50 uint8_t ts; /* bit convention */
51 uint8_t t0; /* high nibble = n. of setup byte; low nibble = n. of historical byte */
52 uint8_t t[SETUP_LENGTH]; /* setup array */
53 uint8_t h[HIST_LENGTH]; /* historical array */
54 uint8_t tlength; /* setup array dimension */
55 uint8_t hlength; /* historical array dimension */
56} sc_atr_type;
57
58 sc_atr_type sc_a2r_struct;
59uint32_t sc_baud_rate = 0;
60uint32_t sc_clock_freq = 0;
61uint32_t counter = 0;
62 error_status atr_decode_status = ERROR;
63uint32_t card_inserted = 0, card_protocol = 1;
64uint8_t dst_buffer[50]= {
65 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1,
66 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1,
67 1, 1, 1, 1, 1, 1, 1, 1, 1, 1
68 };
69
75void usart_configuration(void)
76{
77 gpio_init_type gpio_init_struct;
78 exint_init_type exint_init_struct;
79 crm_clocks_freq_type crm_clocks_struct;
80
81 /* enable gpio_3_5v, sc_usart_gpio_clk, gpio_reset, gpio_cmdvcc, gpio_off and iomux clocks */
82 crm_periph_clock_enable(SC_3_5V_CLK, TRUE);
83 crm_periph_clock_enable(SC_USART_GPIO_CLK, TRUE);
84 crm_periph_clock_enable(SC_RESET_CLK, TRUE);
85 crm_periph_clock_enable(SC_CMDVCC_CLK, TRUE);
86 crm_periph_clock_enable(SC_OFF_CLK, TRUE);
87
88 /* enable sc_usart clocks */
89 crm_periph_clock_enable(SC_USART_CLK, TRUE);
90
91 gpio_default_para_init(&gpio_init_struct);
92 /* configure sc_usart ck pin */
93 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
94 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
95 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
96 gpio_init_struct.gpio_pins = SC_USART_CLK_PIN;
97 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
98 gpio_init(SC_USART_CLK_PORT, &gpio_init_struct);
99 gpio_pin_mux_config(SC_USART_CLK_PORT, GPIO_PINS_SOURCE4, GPIO_MUX_7);
100
101 /* configure sc_usart tx pin */
102 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
103 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
104 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
105 gpio_init_struct.gpio_pins = SC_USART_TX_PIN;
106 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
107 gpio_init(SC_USART_TX_PORT, &gpio_init_struct);
108 gpio_pin_mux_config(SC_USART_TX_PORT, GPIO_PINS_SOURCE2, GPIO_MUX_7);
109
110 /* configure smartcard reset pin */
111 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
112 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
113 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
114 gpio_init_struct.gpio_pins = SC_RESET_PIN;
115 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
116 gpio_init(SC_RESET_PORT, &gpio_init_struct);
117
118 /* set reset pin high */
119 gpio_bits_set(SC_RESET_PORT, SC_RESET_PIN);
120
121 /* configure smartcard 3/5v pin */
122 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
123 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
124 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
125 gpio_init_struct.gpio_pins = SC_3_5V_PIN;
126 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
127 gpio_init(SC_3_5V_PORT, &gpio_init_struct);
128
129 /* select 5 v */
130 gpio_bits_set(SC_3_5V_PORT, SC_3_5V_PIN);
131
132 /* configure smartcard cmdvcc pin */
133 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
134 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
135 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
136 gpio_init_struct.gpio_pins = SC_CMDVCC_PIN;
137 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
138 gpio_init(SC_CMDVCC_PORT, &gpio_init_struct);
139
140 /* set smartcard cmdvcc */
141 gpio_bits_set(SC_CMDVCC_PORT, SC_CMDVCC_PIN);
142
143 /* configure smartcard off pin */
144 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
145 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
146 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
147 gpio_init_struct.gpio_pins = SC_OFF_PIN;
148 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
149 gpio_init(SC_OFF_PORT, &gpio_init_struct);
150
151 /* nvic interrupt init */
152 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
153 NVIC_ClearPendingIRQ(SC_OFF_EXINT_IRQ);
154 nvic_irq_enable(SC_OFF_EXINT_IRQ, 0, 0);
155 nvic_irq_enable(SC_USART_IRQn, 1, 0);
156
157 /* configure smartcard off exint */
158 crm_periph_clock_enable(CRM_SCFG_PERIPH_CLOCK, TRUE);
159 scfg_exint_line_config(SC_OFF_PORTSOURCE, SC_OFF_PINSOURCE);
160
161 exint_default_para_init(&exint_init_struct);
162 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
163 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
164 exint_init_struct.line_select = SC_OFF_EXINT;
165 exint_init_struct.line_enable = TRUE;
166 exint_init(&exint_init_struct);
167
168 /* clear sc exint line pending bit */
169 exint_flag_clear(SC_OFF_EXINT);
170
171 /* sc_usart clock set to (apbclk / (2 * SC_USART_DIV_VAL)) */
172 usart_irda_smartcard_division_set(SC_USART, SC_USART_DIV_VAL);
173 /* sc_usart guard time set to 2 bit */
174 usart_smartcard_guard_time_set(SC_USART, 0x2);
175
176 /* configure sc usart clk */
177 usart_clock_config(SC_USART, USART_CLOCK_POLARITY_LOW, USART_CLOCK_PHASE_1EDGE, USART_CLOCK_LAST_BIT_OUTPUT);
178 usart_clock_enable(SC_USART, TRUE);
179
180 crm_clocks_freq_get(&crm_clocks_struct);
181 sc_clock_freq = crm_clocks_struct.apb1_freq / (2 * SC_USART_DIV_VAL); /* ISO 7816-3 protocol: the CLK frequency is between 1 and 5 MHz */
182 sc_baud_rate = sc_clock_freq / SC_F_DIV_D;
183 /* configure sc usart param */
184 usart_init(SC_USART, sc_baud_rate, USART_DATA_9BITS, USART_STOP_1_5_BIT);
185 usart_parity_selection_config(SC_USART, USART_PARITY_EVEN);
186 usart_transmitter_enable(SC_USART, TRUE);
187 usart_receiver_enable(SC_USART, TRUE);
188
189 /* enable the sc_usart parity error interrupt */
190 usart_interrupt_enable(SC_USART, USART_PERR_INT, TRUE);
191 usart_enable(SC_USART, TRUE);
192
193 /* enable the nack transmission */
194 usart_smartcard_nack_set(SC_USART, TRUE);
195
196 /* enable the smartcard mode */
197 usart_smartcard_mode_enable(SC_USART, TRUE);
198}
199
205uint8_t sc_response_decode(__IO uint8_t *card)
206{
207 uint32_t i = 0, flag = 0, buf = 0, protocol = 0;
208
209 sc_a2r_struct.ts = 0;
210 sc_a2r_struct.t0 = 0;
211 for(i = 0; i < SETUP_LENGTH; i++)
212 {
213 sc_a2r_struct.t[i] = 0;
214 }
215 for(i = 0;i < HIST_LENGTH; i++)
216 {
217 sc_a2r_struct.h[i] = 0;
218 }
219 sc_a2r_struct.tlength = 0;
220 sc_a2r_struct.hlength = 0;
221
222 /* initial character */
223 sc_a2r_struct.ts = card[0];
224
225 /* format character */
226 sc_a2r_struct.t0 = card[1];
227
228 sc_a2r_struct.hlength = sc_a2r_struct.t0 & 0x0F;
229
230 if((sc_a2r_struct.t0 & 0x80) == 0x80) flag = 1;
231
232 for(i = 0; i < 4; i++)
233 {
234 sc_a2r_struct.tlength = sc_a2r_struct.tlength + (((sc_a2r_struct.t0 & 0xF0) >> (4 + i)) & 0x1);
235 }
236
237 for(i = 0; i < sc_a2r_struct.tlength; i++)
238 {
239 sc_a2r_struct.t[i] = card[i + 2];
240 }
241
242 protocol = sc_a2r_struct.t[sc_a2r_struct.tlength - 1] & 0x0F;
243
244 while(flag)
245 {
246 if((sc_a2r_struct.t[sc_a2r_struct.tlength - 1] & 0x80)== 0x80)
247 {
248 flag = 1;
249 }
250 else
251 {
252 flag = 0;
253 }
254 buf = sc_a2r_struct.tlength;
255 sc_a2r_struct.tlength = 0;
256
257 for(i = 0; i < 4; i++)
258 {
259 sc_a2r_struct.tlength = sc_a2r_struct.tlength + (((sc_a2r_struct.t[buf - 1] & 0xF0) >> (4 + i)) & 0x1);
260 }
261 for(i = 0; i < sc_a2r_struct.tlength; i++)
262 {
263 sc_a2r_struct.t[buf + i] = card[i + 2 + buf];
264 }
265 sc_a2r_struct.tlength += buf;
266 }
267
268 for(i = 0;i < sc_a2r_struct.hlength; i++)
269 {
270 sc_a2r_struct.h[i] = card[i + 2 + sc_a2r_struct.tlength];
271 }
272
273 return ((uint8_t)protocol);
274}
275
281int main(void)
282{
283 uint32_t index = 0;
284 system_clock_config();
285 at32_board_init();
286 usart_configuration();
287
288 /* loop while no smartcard is detected */
289 while(card_inserted == 0)
290 {
291 }
292
293 /* read smartcard atr response */
294 for(index = 0; index < 40; index++, counter = 0)
295 {
296 while((usart_flag_get(SC_USART, USART_RDBF_FLAG) == RESET) && (counter != SC_RECEIVE_TIMEOUT))
297 {
298 counter++;
299 }
300
301 if(counter != SC_RECEIVE_TIMEOUT)
302 {
303 dst_buffer[index] = usart_data_receive(SC_USART);
304 }
305 }
306
307 /* decode atr */
308 card_protocol = sc_response_decode(dst_buffer);
309
310 /* test if the inserted card is iso7816-3 t=0 compatible */
311 if(card_protocol == 0)
312 {
313 /* inserted card is iso7816-3 t=0 compatible */
314 atr_decode_status = SUCCESS;
315 }
316 else
317 {
318 /* inserted smartcard is not iso7816-3 t=0 compatible */
319 atr_decode_status = ERROR;
320 }
321
322 /* judge whether the result is correct */
323 if(atr_decode_status == SUCCESS)
324 {
325 /* trun on the led */
326 at32_led_on(LED2);
327 at32_led_on(LED3);
328 at32_led_on(LED4);
329 }
330
331 while(1)
332 {
333 }
334}
335
at32f435_437_board.h
SC_RESET_PIN
#define SC_RESET_PIN
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:44
SC_USART_TX_PIN
#define SC_USART_TX_PIN
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:35
SC_RESET_PORT
#define SC_RESET_PORT
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:48
SC_3_5V_PORT
#define SC_3_5V_PORT
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:47
SC_RESET_CLK
#define SC_RESET_CLK
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:52
SC_USART_CLK_PIN
#define SC_USART_CLK_PIN
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:37
SC_OFF_EXINT
#define SC_OFF_EXINT
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:55
SC_USART
#define SC_USART
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:32
SC_OFF_CLK
#define SC_OFF_CLK
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:54
SC_CMDVCC_CLK
#define SC_CMDVCC_CLK
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:53
SC_USART_GPIO_CLK
#define SC_USART_GPIO_CLK
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:34
SC_3_5V_PIN
#define SC_3_5V_PIN
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:43
SC_OFF_PIN
#define SC_OFF_PIN
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:46
SC_CMDVCC_PORT
#define SC_CMDVCC_PORT
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:49
SC_USART_IRQn
#define SC_USART_IRQn
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:39
SC_USART_CLK_PORT
#define SC_USART_CLK_PORT
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:38
SC_3_5V_CLK
#define SC_3_5V_CLK
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:51
SC_USART_TX_PORT
#define SC_USART_TX_PORT
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:36
SC_OFF_PORTSOURCE
#define SC_OFF_PORTSOURCE
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:56
SC_OFF_EXINT_IRQ
#define SC_OFF_EXINT_IRQ
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:58
SC_USART_CLK
#define SC_USART_CLK
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:33
SC_CMDVCC_PIN
#define SC_CMDVCC_PIN
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:45
SC_OFF_PORT
#define SC_OFF_PORT
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:50
SC_OFF_PINSOURCE
#define SC_OFF_PINSOURCE
Definition: at_start_f435/examples/usart/smartcard/inc/smartcard_config.h:57
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:41
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
sc_baud_rate
uint32_t sc_baud_rate
Definition: project/at_start_f435/examples/usart/smartcard/src/main.c:59
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f435/examples/usart/smartcard/src/main.c:75
sc_response_decode
uint8_t sc_response_decode(__IO uint8_t *card)
decode the card atr response.
Definition: project/at_start_f435/examples/usart/smartcard/src/main.c:205
card_protocol
uint32_t card_protocol
Definition: project/at_start_f435/examples/usart/smartcard/src/main.c:63
counter
uint32_t counter
Definition: project/at_start_f435/examples/usart/smartcard/src/main.c:61
SETUP_LENGTH
#define SETUP_LENGTH
Definition: project/at_start_f435/examples/usart/smartcard/src/main.c:40
SC_USART_DIV_VAL
#define SC_USART_DIV_VAL
Definition: project/at_start_f435/examples/usart/smartcard/src/main.c:44
sc_a2r_struct
sc_atr_type sc_a2r_struct
Definition: project/at_start_f435/examples/usart/smartcard/src/main.c:58
SC_F_DIV_D
#define SC_F_DIV_D
Definition: project/at_start_f435/examples/usart/smartcard/src/main.c:45
atr_decode_status
error_status atr_decode_status
Definition: project/at_start_f435/examples/usart/smartcard/src/main.c:62
main
int main(void)
main function.
Definition: project/at_start_f435/examples/usart/smartcard/src/main.c:281
card_inserted
uint32_t card_inserted
Definition: project/at_start_f435/examples/usart/smartcard/src/main.c:63
dst_buffer
uint8_t dst_buffer[50]
Definition: project/at_start_f435/examples/usart/smartcard/src/main.c:64
SC_RECEIVE_TIMEOUT
#define SC_RECEIVE_TIMEOUT
Definition: project/at_start_f435/examples/usart/smartcard/src/main.c:42
sc_clock_freq
uint32_t sc_clock_freq
Definition: project/at_start_f435/examples/usart/smartcard/src/main.c:60
HIST_LENGTH
#define HIST_LENGTH
Definition: project/at_start_f435/examples/usart/smartcard/src/main.c:41
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f435_437_crm.c:691
CRM_SCFG_PERIPH_CLOCK
@ CRM_SCFG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:163
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f435_437_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
error_status
error_status
Definition: at32f435_437.h:380
ERROR
@ ERROR
Definition: at32f435_437.h:380
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f435_437_gpio.c:277
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f435_437_gpio.h:82
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f435_437_gpio.h:83
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f435_437_gpio.h:103
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
scfg_exint_line_config
void scfg_exint_line_config(scfg_port_source_type port_source, scfg_pins_source_type pin_source)
select the gpio pin used as exint line.
Definition: at32f435_437_scfg.c:152
usart_clock_enable
void usart_clock_enable(usart_type *usart_x, confirm_state new_state)
usart enable the ck pin.
Definition: at32f435_437_usart.c:263
usart_smartcard_nack_set
void usart_smartcard_nack_set(usart_type *usart_x, confirm_state new_state)
enable or disable nack transmission in smartcard mode.
Definition: at32f435_437_usart.c:495
usart_clock_config
void usart_clock_config(usart_type *usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
usart clock config.
Definition: at32f435_437_usart.c:247
usart_parity_selection_config
void usart_parity_selection_config(usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config.
Definition: at32f435_437_usart.c:168
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f435_437_usart.c:598
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f435_437_usart.c:209
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f435_437_usart.c:115
usart_irda_smartcard_division_set
void usart_irda_smartcard_division_set(usart_type *usart_x, uint8_t div_val)
config the irda/smartcard division.
Definition: at32f435_437_usart.c:465
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f435_437_usart.c:196
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f435_437_usart.c:222
usart_smartcard_guard_time_set
void usart_smartcard_guard_time_set(usart_type *usart_x, uint8_t guard_time_val)
config the specified usart smartcard guard time.
Definition: at32f435_437_usart.c:451
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f435_437_usart.c:287
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f435_437_usart.c:425
usart_smartcard_mode_enable
void usart_smartcard_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart smart card mode.
Definition: at32f435_437_usart.c:480
USART_CLOCK_POLARITY_LOW
@ USART_CLOCK_POLARITY_LOW
Definition: at32f435_437_usart.h:141
USART_STOP_1_5_BIT
@ USART_STOP_1_5_BIT
Definition: at32f435_437_usart.h:162
USART_DATA_9BITS
@ USART_DATA_9BITS
Definition: at32f435_437_usart.h:115
USART_PARITY_EVEN
@ USART_PARITY_EVEN
Definition: at32f435_437_usart.h:95
USART_CLOCK_LAST_BIT_OUTPUT
@ USART_CLOCK_LAST_BIT_OUTPUT
Definition: at32f435_437_usart.h:151
USART_CLOCK_PHASE_1EDGE
@ USART_CLOCK_PHASE_1EDGE
Definition: at32f435_437_usart.h:132
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f435_437_usart.h:57
USART_PERR_INT
#define USART_PERR_INT
Definition: at32f435_437_usart.h:76
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f435_437_crm.h:788
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f435_437_crm.h:792
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
sc_atr_type
Definition: project/at_start_f435/examples/usart/smartcard/src/main.c:49
sc_atr_type::t
uint8_t t[20]
Definition: project/at_start_f435/examples/usart/smartcard/src/main.c:52
sc_atr_type::h
uint8_t h[20]
Definition: project/at_start_f435/examples/usart/smartcard/src/main.c:53
sc_atr_type::ts
uint8_t ts
Definition: project/at_start_f435/examples/usart/smartcard/src/main.c:50
sc_atr_type::tlength
uint8_t tlength
Definition: project/at_start_f435/examples/usart/smartcard/src/main.c:54
sc_atr_type::hlength
uint8_t hlength
Definition: project/at_start_f435/examples/usart/smartcard/src/main.c:55
sc_atr_type::t0
uint8_t t0
Definition: project/at_start_f435/examples/usart/smartcard/src/main.c:51
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • usart
  • synchronous
  • inc
project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • usart
  • synchronous
  • inc
project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • usart
  • synchronous
  • inc
project/at_start_f435/examples/usart/synchronous/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • usart
  • synchronous
  • src
Functions
project/at_start_f435/examples/usart/synchronous/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/synchronous/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • usart
  • synchronous
  • src
project/at_start_f435/examples/usart/synchronous/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/usart/synchronous/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • usart
  • synchronous
  • src
Functions
project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • usart
  • synchronous
  • src
project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/usart/synchronous/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • usart
  • synchronous
  • src
Macros | Functions | Variables
project/at_start_f435/examples/usart/synchronous/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | SPI1_TX_BUFFER_SIZE (COUNTOF(spi1_tx_buffer) - 1)
#define | DYMMY_BYTE 0x00

Functions

void | usart_spi_configuration (void)
config usart and spi More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart synchronous example: usart2 -> spi1"
uint8_t | spi1_tx_buffer [] = "usart synchronous example: spi1 -> usart2"
uint8_t | usart2_rx_buffer [((sizeof(spi1_tx_buffer)/sizeof(*(spi1_tx_buffer))) - 1)]
uint8_t | spi1_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | usart2_tx_counter = 0x00
uint8_t | spi1_tx_counter = 0x00
uint8_t | usart2_rx_counter = 0x00
uint8_t | spi1_rx_counter = 0x00
uint8_t | usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)
uint8_t | spi1_tx_buffer_size = ((sizeof( spi1_tx_buffer ) / sizeof(*( spi1_tx_buffer ))) - 1)

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/synchronous/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • usart
  • synchronous
  • src
project/at_start_f435/examples/usart/synchronous/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define COUNTOF(a) (sizeof(a) / sizeof(*(a)))
39#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
40#define SPI1_TX_BUFFER_SIZE (COUNTOF(spi1_tx_buffer) - 1)
41#define DYMMY_BYTE 0x00
42
43uint8_t usart2_tx_buffer[] = "usart synchronous example: usart2 -> spi1";
44uint8_t spi1_tx_buffer[] = "usart synchronous example: spi1 -> usart2";
45uint8_t usart2_rx_buffer[SPI1_TX_BUFFER_SIZE];
46uint8_t spi1_rx_buffer[USART2_TX_BUFFER_SIZE];
47uint8_t usart2_tx_counter = 0x00;
48uint8_t spi1_tx_counter = 0x00;
49uint8_t usart2_rx_counter = 0x00;
50uint8_t spi1_rx_counter = 0x00;
51uint8_t usart2_tx_buffer_size = USART2_TX_BUFFER_SIZE;
52uint8_t spi1_tx_buffer_size = SPI1_TX_BUFFER_SIZE;
53
59void usart_spi_configuration(void)
60{
61 gpio_init_type gpio_init_struct;
62 spi_init_type spi_init_struct;
63
64 /* enable the usart2 and gpio clock */
65 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
67
68 /* enable the spi1 and gpio clock */
69 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
70 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
71
72 gpio_default_para_init(&gpio_init_struct);
73
74 /* configure the usart2 tx, rx and ck pin */
75 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
76 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
77 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
78 gpio_init_struct.gpio_pins = GPIO_PINS_2 | GPIO_PINS_3 | GPIO_PINS_4;
79 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
80 gpio_init(GPIOA, &gpio_init_struct);
81 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE2, GPIO_MUX_7);
82 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE3, GPIO_MUX_7);
83 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE4, GPIO_MUX_7);
84
85 /* configure the spi1 mosi, miso and ck pin */
86 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
87 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
88 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
89 gpio_init_struct.gpio_pins = GPIO_PINS_5 | GPIO_PINS_6 | GPIO_PINS_7;
90 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
91 gpio_init(GPIOA, &gpio_init_struct);
92 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE5, GPIO_MUX_5);
93 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE6, GPIO_MUX_5);
94 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE7, GPIO_MUX_5);
95
96 /* configure usart2 param */
97 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
98 usart_clock_config(USART2, USART_CLOCK_POLARITY_HIGH, USART_CLOCK_PHASE_2EDGE, USART_CLOCK_LAST_BIT_OUTPUT);
99 usart_clock_enable(USART2, TRUE);
100 usart_transmitter_enable(USART2, TRUE);
101 usart_receiver_enable(USART2, TRUE);
102 usart_enable(USART2, TRUE);
103
104 /* configure spi1 param */
105 spi_default_para_init(&spi_init_struct);
106 spi_init_struct.transmission_mode = SPI_TRANSMIT_FULL_DUPLEX;
107 spi_init_struct.master_slave_mode =SPI_MODE_SLAVE;
108 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_LSB;
109 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
110 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_HIGH;
111 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
112 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
113 spi_init(SPI1, &spi_init_struct);
114 spi_enable(SPI1, TRUE);
115}
116
124uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
125{
126 while(buffer_length--)
127 {
128 if(*pbuffer1 != *pbuffer2)
129 {
130 return 0;
131 }
132 pbuffer1++;
133 pbuffer2++;
134 }
135 return 1;
136}
137
143int main(void)
144{
145 system_clock_config();
146 at32_board_init();
147 usart_spi_configuration();
148
149 /* wait until end of transmission from usart2 to spi1 */
150 while(spi1_rx_counter < usart2_tx_buffer_size)
151 {
152 /* usart transmit data */
153 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
154 usart_data_transmit(USART2, usart2_tx_buffer[usart2_tx_counter++]);
155
156 /* wait until spi receive data */
157 while(spi_i2s_flag_get(SPI1, SPI_I2S_RDBF_FLAG) == RESET);
158 spi1_rx_buffer[spi1_rx_counter++] = spi_i2s_data_receive(SPI1);
159
160 /* wait until usart receive data, and clear dummy byte in data register */
161 while(usart_flag_get(USART2, USART_RDBF_FLAG) == RESET);
162 usart_data_receive(USART2);
163 }
164
165 /* wait until end of transmission from spi1 to usart2 */
166 while(usart2_rx_counter < spi1_tx_buffer_size)
167 {
168 /* spi put transmit data in data register */
169 while(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) == RESET);
170 spi_i2s_data_transmit(SPI1, spi1_tx_buffer[spi1_tx_counter++]);
171
172 /* usart transmit a dummy byte to generate clock to slave */
173 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
174 usart_data_transmit(USART2, DYMMY_BYTE);
175
176 /* wait until usart receive data */
177 while(usart_flag_get(USART2, USART_RDBF_FLAG) == RESET);
178 usart2_rx_buffer[usart2_rx_counter++] = usart_data_receive(USART2);
179 }
180
181 while(1)
182 {
183 /* compare data buffer */
184 if(buffer_compare(usart2_tx_buffer, spi1_rx_buffer, USART2_TX_BUFFER_SIZE) && \
185 buffer_compare(spi1_tx_buffer, usart2_rx_buffer, SPI1_TX_BUFFER_SIZE))
186 {
187 at32_led_toggle(LED2);
188 at32_led_toggle(LED3);
189 at32_led_toggle(LED4);
190 delay_sec(1);
191 }
192 }
193}
194
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f435/examples/spi/fullduplex_polling/src/main.c:40
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f435/examples/usart/synchronous/src/main.c:124
usart2_tx_counter
uint8_t usart2_tx_counter
Definition: project/at_start_f435/examples/usart/synchronous/src/main.c:47
spi1_tx_buffer_size
uint8_t spi1_tx_buffer_size
Definition: project/at_start_f435/examples/usart/synchronous/src/main.c:52
usart_spi_configuration
void usart_spi_configuration(void)
config usart and spi
Definition: project/at_start_f435/examples/usart/synchronous/src/main.c:59
SPI1_TX_BUFFER_SIZE
#define SPI1_TX_BUFFER_SIZE
Definition: project/at_start_f435/examples/usart/synchronous/src/main.c:40
DYMMY_BYTE
#define DYMMY_BYTE
Definition: project/at_start_f435/examples/usart/synchronous/src/main.c:41
usart2_tx_buffer_size
uint8_t usart2_tx_buffer_size
Definition: project/at_start_f435/examples/usart/synchronous/src/main.c:51
spi1_tx_buffer
uint8_t spi1_tx_buffer[]
Definition: project/at_start_f435/examples/usart/synchronous/src/main.c:44
usart2_rx_counter
uint8_t usart2_rx_counter
Definition: project/at_start_f435/examples/usart/synchronous/src/main.c:49
USART2_TX_BUFFER_SIZE
#define USART2_TX_BUFFER_SIZE
Definition: project/at_start_f435/examples/usart/synchronous/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f435/examples/usart/synchronous/src/main.c:143
spi1_rx_counter
uint8_t spi1_rx_counter
Definition: project/at_start_f435/examples/usart/synchronous/src/main.c:50
usart2_rx_buffer
uint8_t usart2_rx_buffer[((sizeof(spi1_tx_buffer)/sizeof(*(spi1_tx_buffer))) - 1)]
Definition: project/at_start_f435/examples/usart/synchronous/src/main.c:45
usart2_tx_buffer
uint8_t usart2_tx_buffer[]
Definition: project/at_start_f435/examples/usart/synchronous/src/main.c:43
spi1_rx_buffer
uint8_t spi1_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
Definition: project/at_start_f435/examples/usart/synchronous/src/main.c:46
spi1_tx_counter
uint8_t spi1_tx_counter
Definition: project/at_start_f435/examples/usart/synchronous/src/main.c:48
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:161
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:140
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f435_437_gpio.h:140
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f435_437_gpio.h:139
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f435_437_gpio.h:137
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f435_437_gpio.h:138
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f435_437_gpio.h:112
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_5
@ GPIO_MUX_5
Definition: at32f435_437_gpio.h:161
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f435_437_gpio.h:57
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f435_437_gpio.h:58
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f435_437_gpio.h:55
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f435_437_gpio.h:56
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f435_437_spi.h:54
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f435_437_spi.h:53
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f435_437_spi.c:548
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f435_437_spi.c:583
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f435_437_spi.c:101
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f435_437_spi.c:81
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f435_437_spi.c:560
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f435_437_spi.c:321
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f435_437_spi.h:99
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f435_437_spi.h:118
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f435_437_spi.h:127
SPI_FIRST_BIT_LSB
@ SPI_FIRST_BIT_LSB
Definition: at32f435_437_spi.h:154
SPI_CLOCK_POLARITY_HIGH
@ SPI_CLOCK_POLARITY_HIGH
Definition: at32f435_437_spi.h:109
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f435_437_spi.h:162
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f435_437_spi.h:90
SPI1
#define SPI1
Definition: at32f435_437_spi.h:453
usart_clock_enable
void usart_clock_enable(usart_type *usart_x, confirm_state new_state)
usart enable the ck pin.
Definition: at32f435_437_usart.c:263
usart_clock_config
void usart_clock_config(usart_type *usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
usart clock config.
Definition: at32f435_437_usart.c:247
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f435_437_usart.c:413
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f435_437_usart.c:598
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f435_437_usart.c:209
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f435_437_usart.c:115
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f435_437_usart.c:196
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f435_437_usart.c:222
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f435_437_usart.c:425
USART_CLOCK_POLARITY_HIGH
@ USART_CLOCK_POLARITY_HIGH
Definition: at32f435_437_usart.h:142
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f435_437_usart.h:159
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f435_437_usart.h:114
USART_CLOCK_LAST_BIT_OUTPUT
@ USART_CLOCK_LAST_BIT_OUTPUT
Definition: at32f435_437_usart.h:151
USART_CLOCK_PHASE_2EDGE
@ USART_CLOCK_PHASE_2EDGE
Definition: at32f435_437_usart.h:133
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f435_437_usart.h:59
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f435_437_usart.h:57
USART2
#define USART2
Definition: at32f435_437_usart.h:349
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
spi_init_type
spi init type
Definition: at32f435_437_spi.h:259
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f435_437_spi.h:261
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f435_437_spi.h:263
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f435_437_spi.h:264
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f435_437_spi.h:265
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f435_437_spi.h:267
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f435_437_spi.h:260
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f435_437_spi.h:266
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_interrupt
  • inc
project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_interrupt
  • inc
project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_interrupt
  • inc
project/at_start_f435/examples/usart/transfer_by_dma_interrupt/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_interrupt
  • src
Functions
project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_interrupt
  • src
project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_interrupt
  • src
Functions | Variables
project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1 channel1 handler. More...
void | DMA1_Channel2_IRQHandler (void)
this function handles dma1 channel2 handler. More...
void | DMA1_Channel3_IRQHandler (void)
this function handles dma1 channel3 handler. More...
void | DMA1_Channel4_IRQHandler (void)
this function handles dma1 channel4 handler. More...

Variables

uint8_t | usart2_tx_dma_status
uint8_t | usart2_rx_dma_status
uint8_t | usart3_tx_dma_status
uint8_t | usart3_rx_dma_status

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_interrupt
  • src
project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
38extern uint8_t usart2_tx_dma_status;
39extern uint8_t usart2_rx_dma_status;
40extern uint8_t usart3_tx_dma_status;
41extern uint8_t usart3_rx_dma_status;
42
48void NMI_Handler(void)
49{
50}
51
57void HardFault_Handler(void)
58{
59 /* go to infinite loop when hard fault exception occurs */
60 while(1)
61 {
62 }
63}
64
70void MemManage_Handler(void)
71{
72 /* go to infinite loop when memory manage exception occurs */
73 while(1)
74 {
75 }
76}
77
83void BusFault_Handler(void)
84{
85 /* go to infinite loop when bus fault exception occurs */
86 while(1)
87 {
88 }
89}
90
96void UsageFault_Handler(void)
97{
98 /* go to infinite loop when usage fault exception occurs */
99 while(1)
100 {
101 }
102}
103
109void SVC_Handler(void)
110{
111}
112
118void DebugMon_Handler(void)
119{
120}
121
127void PendSV_Handler(void)
128{
129}
130
136void SysTick_Handler(void)
137{
138}
139
145void DMA1_Channel1_IRQHandler(void)
146{
147 if(dma_flag_get(DMA1_FDT1_FLAG))
148 {
149 usart2_tx_dma_status = 1;
150 dma_flag_clear(DMA1_FDT1_FLAG);
151 dma_channel_enable(DMA1_CHANNEL1, FALSE);
152 }
153}
154
160void DMA1_Channel2_IRQHandler(void)
161{
162 if(dma_flag_get(DMA1_FDT2_FLAG))
163 {
164 usart2_rx_dma_status = 1;
165 dma_flag_clear(DMA1_FDT2_FLAG);
166 dma_channel_enable(DMA1_CHANNEL2, FALSE);
167 }
168}
169
175void DMA1_Channel3_IRQHandler(void)
176{
177 if(dma_flag_get(DMA1_FDT3_FLAG))
178 {
179 usart3_tx_dma_status = 1;
180 dma_flag_clear(DMA1_FDT3_FLAG);
181 dma_channel_enable(DMA1_CHANNEL3, FALSE);
182 }
183}
184
190void DMA1_Channel4_IRQHandler(void)
191{
192 if(dma_flag_get(DMA1_FDT4_FLAG))
193 {
194 usart3_rx_dma_status = 1;
195 dma_flag_clear(DMA1_FDT4_FLAG);
196 dma_channel_enable(DMA1_CHANNEL4, FALSE);
197 }
198}
199
DMA1_Channel2_IRQHandler
void DMA1_Channel2_IRQHandler(void)
this function handles dma1 channel2 handler.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c:160
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c:96
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c:57
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c:70
usart3_rx_dma_status
uint8_t usart3_rx_dma_status
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c:49
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c:109
usart3_tx_dma_status
uint8_t usart3_tx_dma_status
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c:48
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c:127
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c:48
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1 channel1 handler.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c:145
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c:83
DMA1_Channel4_IRQHandler
void DMA1_Channel4_IRQHandler(void)
this function handles dma1 channel4 handler.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c:190
DMA1_Channel3_IRQHandler
void DMA1_Channel3_IRQHandler(void)
this function handles dma1 channel3 handler.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c:175
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c:136
usart2_tx_dma_status
uint8_t usart2_tx_dma_status
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c:46
usart2_rx_dma_status
uint8_t usart2_rx_dma_status
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c:47
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/at32f435_437_int.c:118
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
dma flag clear.
Definition: at32f435_437_dma.c:264
DMA1_FDT4_FLAG
#define DMA1_FDT4_FLAG
Definition: at32f435_437_dma.h:78
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f435_437_dma.h:66
DMA1_FDT2_FLAG
#define DMA1_FDT2_FLAG
Definition: at32f435_437_dma.h:70
DMA1_FDT3_FLAG
#define DMA1_FDT3_FLAG
Definition: at32f435_437_dma.h:74
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f435_437_dma.h:698
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f435_437_dma.h:699
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f435_437_dma.h:697
FALSE
@ FALSE
Definition: at32f435_437.h:379
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_interrupt
  • src
Macros | Functions | Variables
project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | usart_configuration (void)
config usart More...
void | dma_configuration (void)
config dma for usart2 and usart3 More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart transfer by dma interrupt: usart2 -> usart3 using dma"
uint8_t | usart3_tx_buffer [] = "usart transfer by dma interrupt: usart3 -> usart2 using dma"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
volatile uint8_t | usart2_tx_dma_status = 0
volatile uint8_t | usart2_rx_dma_status = 0
volatile uint8_t | usart3_tx_dma_status = 0
volatile uint8_t | usart3_rx_dma_status = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_interrupt
  • src
project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define COUNTOF(a) (sizeof(a) / sizeof(*(a)))
39#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
40#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)
41
42uint8_t usart2_tx_buffer[] = "usart transfer by dma interrupt: usart2 -> usart3 using dma";
43uint8_t usart3_tx_buffer[] = "usart transfer by dma interrupt: usart3 -> usart2 using dma";
44uint8_t usart2_rx_buffer[USART3_TX_BUFFER_SIZE];
45uint8_t usart3_rx_buffer[USART2_TX_BUFFER_SIZE];
46volatile uint8_t usart2_tx_dma_status = 0;
47volatile uint8_t usart2_rx_dma_status = 0;
48volatile uint8_t usart3_tx_dma_status = 0;
49volatile uint8_t usart3_rx_dma_status = 0;
50
56void usart_configuration(void)
57{
58 gpio_init_type gpio_init_struct;
59
60 /* enable the usart2 and gpio clock */
61 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
62 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
63
64 /* enable the usart3 and gpio clock */
65 crm_periph_clock_enable(CRM_USART3_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
67
68 gpio_default_para_init(&gpio_init_struct);
69 /* configure the usart2 tx, rx pin */
70 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
71 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
72 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
73 gpio_init_struct.gpio_pins = GPIO_PINS_2 | GPIO_PINS_3;
74 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
75 gpio_init(GPIOA, &gpio_init_struct);
76 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE2, GPIO_MUX_7);
77 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE3, GPIO_MUX_7);
78
79 /* configure the usart3 tx, rx pin */
80 gpio_init_struct.gpio_pins = GPIO_PINS_10 | GPIO_PINS_11;
81 gpio_init(GPIOB, &gpio_init_struct);
82 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE10, GPIO_MUX_7);
83 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE11, GPIO_MUX_7);
84
85 /* configure usart2 param */
86 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
87 usart_transmitter_enable(USART2, TRUE);
88 usart_receiver_enable(USART2, TRUE);
89 usart_dma_transmitter_enable(USART2, TRUE);
90 usart_dma_receiver_enable(USART2, TRUE);
91 usart_enable(USART2, TRUE);
92
93 /* configure usart3 param */
94 usart_init(USART3, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
95 usart_transmitter_enable(USART3, TRUE);
96 usart_receiver_enable(USART3, TRUE);
97 usart_dma_transmitter_enable(USART3, TRUE);
98 usart_dma_receiver_enable(USART3, TRUE);
99 usart_enable(USART3, TRUE);
100}
101
107void dma_configuration(void)
108{
109 dma_init_type dma_init_struct;
110
111 /* enable dma1 clock */
112 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
113
114 dmamux_enable(DMA1, TRUE);
115
116 /* dma1 channel1 for usart2 tx configuration */
117 dma_reset(DMA1_CHANNEL1);
118 dma_default_para_init(&dma_init_struct);
119 dma_init_struct.buffer_size = USART2_TX_BUFFER_SIZE;
120 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
121 dma_init_struct.memory_base_addr = (uint32_t)usart2_tx_buffer;
122 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
123 dma_init_struct.memory_inc_enable = TRUE;
124 dma_init_struct.peripheral_base_addr = (uint32_t)&USART2->dt;
125 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
126 dma_init_struct.peripheral_inc_enable = FALSE;
127 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
128 dma_init_struct.loop_mode_enable = FALSE;
129 dma_init(DMA1_CHANNEL1, &dma_init_struct);
130
131 /* enable transfer full data intterrupt */
132 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
133
134 /* dma1 channel1 interrupt nvic init */
135 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
136 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
137
138 /* config flexible dma for usart2 tx */
139 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_USART2_TX);
140
141 /* dma1 channel2 for usart2 rx configuration */
142 dma_reset(DMA1_CHANNEL2);
143 dma_default_para_init(&dma_init_struct);
144 dma_init_struct.buffer_size = USART3_TX_BUFFER_SIZE;
145 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
146 dma_init_struct.memory_base_addr = (uint32_t)usart2_rx_buffer;
147 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
148 dma_init_struct.memory_inc_enable = TRUE;
149 dma_init_struct.peripheral_base_addr = (uint32_t)&USART2->dt;
150 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
151 dma_init_struct.peripheral_inc_enable = FALSE;
152 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
153 dma_init_struct.loop_mode_enable = FALSE;
154 dma_init(DMA1_CHANNEL2, &dma_init_struct);
155
156 /* enable transfer full data intterrupt */
157 dma_interrupt_enable(DMA1_CHANNEL2, DMA_FDT_INT, TRUE);
158
159 /* dma1 channel2 interrupt nvic init */
160 nvic_irq_enable(DMA1_Channel2_IRQn, 0, 0);
161
162 /* config flexible dma for usart2 rx */
163 dmamux_init(DMA1MUX_CHANNEL2, DMAMUX_DMAREQ_ID_USART2_RX);
164
165 /* dma1 channel3 for usart3 tx configuration */
166 dma_reset(DMA1_CHANNEL3);
167 dma_default_para_init(&dma_init_struct);
168 dma_init_struct.buffer_size = USART3_TX_BUFFER_SIZE;
169 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
170 dma_init_struct.memory_base_addr = (uint32_t)usart3_tx_buffer;
171 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
172 dma_init_struct.memory_inc_enable = TRUE;
173 dma_init_struct.peripheral_base_addr = (uint32_t)&USART3->dt;
174 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
175 dma_init_struct.peripheral_inc_enable = FALSE;
176 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
177 dma_init_struct.loop_mode_enable = FALSE;
178 dma_init(DMA1_CHANNEL3, &dma_init_struct);
179
180 /* enable transfer full data intterrupt */
181 dma_interrupt_enable(DMA1_CHANNEL3, DMA_FDT_INT, TRUE);
182
183 /* dma1 channel3 interrupt nvic init */
184 nvic_irq_enable(DMA1_Channel3_IRQn, 0, 0);
185
186 /* config flexible dma for usart3 tx */
187 dmamux_init(DMA1MUX_CHANNEL3, DMAMUX_DMAREQ_ID_USART3_TX);
188
189 /* dma1 channel4 for usart3 rx configuration */
190 dma_reset(DMA1_CHANNEL4);
191 dma_default_para_init(&dma_init_struct);
192 dma_init_struct.buffer_size = USART2_TX_BUFFER_SIZE;
193 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
194 dma_init_struct.memory_base_addr = (uint32_t)usart3_rx_buffer;
195 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
196 dma_init_struct.memory_inc_enable = TRUE;
197 dma_init_struct.peripheral_base_addr = (uint32_t)&USART3->dt;
198 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
199 dma_init_struct.peripheral_inc_enable = FALSE;
200 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
201 dma_init_struct.loop_mode_enable = FALSE;
202 dma_init(DMA1_CHANNEL4, &dma_init_struct);
203
204 /* enable transfer full data intterrupt */
205 dma_interrupt_enable(DMA1_CHANNEL4, DMA_FDT_INT, TRUE);
206
207 /* dma1 channel4 interrupt nvic init */
208 nvic_irq_enable(DMA1_Channel4_IRQn, 0, 0);
209
210 /* config flexible dma for usart3 rx */
211 dmamux_init(DMA1MUX_CHANNEL4, DMAMUX_DMAREQ_ID_USART3_RX);
212
213 dma_channel_enable(DMA1_CHANNEL2, TRUE); /* usart2 rx begin dma receiving */
214 dma_channel_enable(DMA1_CHANNEL4, TRUE); /* usart3 rx begin dma receiving */
215 dma_channel_enable(DMA1_CHANNEL1, TRUE); /* usart2 tx begin dma transmitting */
216 dma_channel_enable(DMA1_CHANNEL3, TRUE); /* usart3 tx begin dma transmitting */
217}
218
226uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
227{
228 while(buffer_length--)
229 {
230 if(*pbuffer1 != *pbuffer2)
231 {
232 return 0;
233 }
234 pbuffer1++;
235 pbuffer2++;
236 }
237 return 1;
238}
239
245int main(void)
246{
247 system_clock_config();
248 at32_board_init();
249 usart_configuration();
250 dma_configuration();
251
252 /* wait dma transmission complete */
253 while((usart2_tx_dma_status == 0) || (usart2_rx_dma_status == 0) || (usart3_tx_dma_status == 0) || (usart3_rx_dma_status == 0));
254
255 while(1)
256 {
257 /* compare data buffer */
258 if(buffer_compare(usart2_tx_buffer, usart3_rx_buffer, USART2_TX_BUFFER_SIZE) && \
259 buffer_compare(usart3_tx_buffer, usart2_rx_buffer, USART3_TX_BUFFER_SIZE))
260 {
261 at32_led_toggle(LED2);
262 at32_led_toggle(LED3);
263 at32_led_toggle(LED4);
264 delay_sec(1);
265 }
266 }
267}
268
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c:56
usart3_tx_dma_status
volatile uint8_t usart3_tx_dma_status
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c:48
usart2_tx_dma_status
volatile uint8_t usart2_tx_dma_status
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c:46
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c:226
usart3_rx_buffer
uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c:45
dma_configuration
void dma_configuration(void)
config dma for usart2 and usart3
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c:107
USART2_TX_BUFFER_SIZE
#define USART2_TX_BUFFER_SIZE
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c:245
usart2_rx_dma_status
volatile uint8_t usart2_rx_dma_status
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c:47
usart3_rx_dma_status
volatile uint8_t usart3_rx_dma_status
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c:49
usart2_tx_buffer
uint8_t usart2_tx_buffer[]
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c:42
USART3_TX_BUFFER_SIZE
#define USART3_TX_BUFFER_SIZE
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c:40
usart3_tx_buffer
uint8_t usart3_tx_buffer[]
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c:43
usart2_rx_buffer
uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
Definition: project/at_start_f435/examples/usart/transfer_by_dma_interrupt/src/main.c:44
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_USART3_PERIPH_CLOCK
@ CRM_USART3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:141
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:140
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt.
Definition: at32f435_437_dma.c:164
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:162
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:172
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f435_437_dma.h:183
DMAMUX_DMAREQ_ID_USART3_TX
@ DMAMUX_DMAREQ_ID_USART3_TX
Definition: at32f435_437_dma.h:227
DMAMUX_DMAREQ_ID_USART3_RX
@ DMAMUX_DMAREQ_ID_USART3_RX
Definition: at32f435_437_dma.h:226
DMAMUX_DMAREQ_ID_USART2_TX
@ DMAMUX_DMAREQ_ID_USART2_TX
Definition: at32f435_437_dma.h:225
DMAMUX_DMAREQ_ID_USART2_RX
@ DMAMUX_DMAREQ_ID_USART2_RX
Definition: at32f435_437_dma.h:224
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f435_437_dma.h:52
DMA1MUX_CHANNEL2
#define DMA1MUX_CHANNEL2
Definition: at32f435_437_dma.h:705
DMA1MUX_CHANNEL3
#define DMA1MUX_CHANNEL3
Definition: at32f435_437_dma.h:706
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f435_437_dma.h:698
DMA1MUX_CHANNEL4
#define DMA1MUX_CHANNEL4
Definition: at32f435_437_dma.h:707
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f435_437_dma.h:699
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f435_437_dma.h:697
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f435_437_usart.c:209
usart_dma_receiver_enable
void usart_dma_receiver_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma receiver interface.
Definition: at32f435_437_usart.c:318
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f435_437_usart.c:115
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f435_437_usart.c:196
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f435_437_usart.c:222
usart_dma_transmitter_enable
void usart_dma_transmitter_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface.
Definition: at32f435_437_usart.c:304
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f435_437_usart.h:159
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f435_437_usart.h:114
USART3
#define USART3
Definition: at32f435_437_usart.h:350
USART2
#define USART2
Definition: at32f435_437_usart.h:349
DMA1_Channel2_IRQn
@ DMA1_Channel2_IRQn
Definition: at32f435_437.h:205
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f435_437.h:204
DMA1_Channel3_IRQn
@ DMA1_Channel3_IRQn
Definition: at32f435_437.h:206
DMA1_Channel4_IRQn
@ DMA1_Channel4_IRQn
Definition: at32f435_437.h:207
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_polling
  • inc
project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_polling
  • inc
project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_polling
  • inc
project/at_start_f435/examples/usart/transfer_by_dma_polling/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_polling
  • src
Functions
project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_polling
  • src
project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_polling
  • src
Functions
project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_polling
  • src
project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_polling/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_polling
  • src
Macros | Functions | Variables
project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | usart_configuration (void)
config usart More...
void | dma_configuration (void)
config dma for usart2 and usart3 More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart transfer by dma interrupt: usart2 -> usart3 using dma"
uint8_t | usart3_tx_buffer [] = "usart transfer by dma interrupt: usart3 -> usart2 using dma"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • usart
  • transfer_by_dma_polling
  • src
project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define COUNTOF(a) (sizeof(a) / sizeof(*(a)))
39#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
40#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)
41
42uint8_t usart2_tx_buffer[] = "usart transfer by dma interrupt: usart2 -> usart3 using dma";
43uint8_t usart3_tx_buffer[] = "usart transfer by dma interrupt: usart3 -> usart2 using dma";
44uint8_t usart2_rx_buffer[USART3_TX_BUFFER_SIZE];
45uint8_t usart3_rx_buffer[USART2_TX_BUFFER_SIZE];
46
52void usart_configuration(void)
53{
54 gpio_init_type gpio_init_struct;
55
56 /* enable the usart2 and gpio clock */
57 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
58 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
59
60 /* enable the usart3 and gpio clock */
61 crm_periph_clock_enable(CRM_USART3_PERIPH_CLOCK, TRUE);
62 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
63
64 gpio_default_para_init(&gpio_init_struct);
65 /* configure the usart2 tx, rx pin */
66 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
67 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
68 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
69 gpio_init_struct.gpio_pins = GPIO_PINS_2 | GPIO_PINS_3;
70 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
71 gpio_init(GPIOA, &gpio_init_struct);
72 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE2, GPIO_MUX_7);
73 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE3, GPIO_MUX_7);
74
75 /* configure the usart3 tx, rx pin */
76 gpio_init_struct.gpio_pins = GPIO_PINS_10 | GPIO_PINS_11;
77 gpio_init(GPIOB, &gpio_init_struct);
78 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE10, GPIO_MUX_7);
79 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE11, GPIO_MUX_7);
80
81 /* configure usart2 param */
82 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
83 usart_transmitter_enable(USART2, TRUE);
84 usart_receiver_enable(USART2, TRUE);
85 usart_dma_transmitter_enable(USART2, TRUE);
86 usart_dma_receiver_enable(USART2, TRUE);
87 usart_enable(USART2, TRUE);
88
89 /* configure usart3 param */
90 usart_init(USART3, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
91 usart_transmitter_enable(USART3, TRUE);
92 usart_receiver_enable(USART3, TRUE);
93 usart_dma_transmitter_enable(USART3, TRUE);
94 usart_dma_receiver_enable(USART3, TRUE);
95 usart_enable(USART3, TRUE);
96}
97
103void dma_configuration(void)
104{
105 dma_init_type dma_init_struct;
106
107 /* enable dma1 clock */
108 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
109
110 dmamux_enable(DMA1, TRUE);
111
112 /* dma1 channel1 for usart2 tx configuration */
113 dma_reset(DMA1_CHANNEL1);
114 dma_default_para_init(&dma_init_struct);
115 dma_init_struct.buffer_size = USART2_TX_BUFFER_SIZE;
116 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
117 dma_init_struct.memory_base_addr = (uint32_t)usart2_tx_buffer;
118 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
119 dma_init_struct.memory_inc_enable = TRUE;
120 dma_init_struct.peripheral_base_addr = (uint32_t)&USART2->dt;
121 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
122 dma_init_struct.peripheral_inc_enable = FALSE;
123 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
124 dma_init_struct.loop_mode_enable = FALSE;
125 dma_init(DMA1_CHANNEL1, &dma_init_struct);
126
127 /* config flexible dma for usart2 tx */
128 dmamux_init(DMA1MUX_CHANNEL1, DMAMUX_DMAREQ_ID_USART2_TX);
129
130 /* dma1 channel2 for usart2 rx configuration */
131 dma_reset(DMA1_CHANNEL2);
132 dma_default_para_init(&dma_init_struct);
133 dma_init_struct.buffer_size = USART3_TX_BUFFER_SIZE;
134 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
135 dma_init_struct.memory_base_addr = (uint32_t)usart2_rx_buffer;
136 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
137 dma_init_struct.memory_inc_enable = TRUE;
138 dma_init_struct.peripheral_base_addr = (uint32_t)&USART2->dt;
139 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
140 dma_init_struct.peripheral_inc_enable = FALSE;
141 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
142 dma_init_struct.loop_mode_enable = FALSE;
143 dma_init(DMA1_CHANNEL2, &dma_init_struct);
144
145 /* config flexible dma for usart2 rx */
146 dmamux_init(DMA1MUX_CHANNEL2, DMAMUX_DMAREQ_ID_USART2_RX);
147
148 /* dma1 channel3 for usart3 tx configuration */
149 dma_reset(DMA1_CHANNEL3);
150 dma_default_para_init(&dma_init_struct);
151 dma_init_struct.buffer_size = USART3_TX_BUFFER_SIZE;
152 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
153 dma_init_struct.memory_base_addr = (uint32_t)usart3_tx_buffer;
154 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
155 dma_init_struct.memory_inc_enable = TRUE;
156 dma_init_struct.peripheral_base_addr = (uint32_t)&USART3->dt;
157 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
158 dma_init_struct.peripheral_inc_enable = FALSE;
159 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
160 dma_init_struct.loop_mode_enable = FALSE;
161 dma_init(DMA1_CHANNEL3, &dma_init_struct);
162
163 /* config flexible dma for usart3 tx */
164 dmamux_init(DMA1MUX_CHANNEL3, DMAMUX_DMAREQ_ID_USART3_TX);
165
166 /* dma1 channel4 for usart3 rx configuration */
167 dma_reset(DMA1_CHANNEL4);
168 dma_default_para_init(&dma_init_struct);
169 dma_init_struct.buffer_size = USART2_TX_BUFFER_SIZE;
170 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
171 dma_init_struct.memory_base_addr = (uint32_t)usart3_rx_buffer;
172 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
173 dma_init_struct.memory_inc_enable = TRUE;
174 dma_init_struct.peripheral_base_addr = (uint32_t)&USART3->dt;
175 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
176 dma_init_struct.peripheral_inc_enable = FALSE;
177 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
178 dma_init_struct.loop_mode_enable = FALSE;
179 dma_init(DMA1_CHANNEL4, &dma_init_struct);
180
181 /* config flexible dma for usart3 rx */
182 dmamux_init(DMA1MUX_CHANNEL4, DMAMUX_DMAREQ_ID_USART3_RX);
183
184 dma_channel_enable(DMA1_CHANNEL2, TRUE); /* usart2 rx begin dma receiving */
185 dma_channel_enable(DMA1_CHANNEL4, TRUE); /* usart3 rx begin dma receiving */
186 dma_channel_enable(DMA1_CHANNEL1, TRUE); /* usart2 tx begin dma transmitting */
187 dma_channel_enable(DMA1_CHANNEL3, TRUE); /* usart3 tx begin dma transmitting */
188}
189
197uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
198{
199 while(buffer_length--)
200 {
201 if(*pbuffer1 != *pbuffer2)
202 {
203 return 0;
204 }
205 pbuffer1++;
206 pbuffer2++;
207 }
208 return 1;
209}
210
216int main(void)
217{
218 system_clock_config();
219 at32_board_init();
220 usart_configuration();
221 dma_configuration();
222
223 /* wait dma transmission complete */
224 while((dma_flag_get(DMA1_FDT1_FLAG) == RESET) || (dma_flag_get(DMA1_FDT2_FLAG) == RESET) || \
225 (dma_flag_get(DMA1_FDT3_FLAG) == RESET) || (dma_flag_get(DMA1_FDT4_FLAG) == RESET));
226
227 while(1)
228 {
229 /* compare data buffer */
230 if(buffer_compare(usart2_tx_buffer, usart3_rx_buffer, USART2_TX_BUFFER_SIZE) && \
231 buffer_compare(usart3_tx_buffer, usart2_rx_buffer, USART3_TX_BUFFER_SIZE))
232 {
233 at32_led_toggle(LED2);
234 at32_led_toggle(LED3);
235 at32_led_toggle(LED4);
236 delay_sec(1);
237 }
238 }
239}
240
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c:52
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c:197
usart3_rx_buffer
uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
Definition: project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c:45
dma_configuration
void dma_configuration(void)
config dma for usart2 and usart3
Definition: project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c:103
USART2_TX_BUFFER_SIZE
#define USART2_TX_BUFFER_SIZE
Definition: project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c:216
usart2_tx_buffer
uint8_t usart2_tx_buffer[]
Definition: project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c:42
USART3_TX_BUFFER_SIZE
#define USART3_TX_BUFFER_SIZE
Definition: project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c:40
usart3_tx_buffer
uint8_t usart3_tx_buffer[]
Definition: project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c:43
usart2_rx_buffer
uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
Definition: project/at_start_f435/examples/usart/transfer_by_dma_polling/src/main.c:44
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_USART3_PERIPH_CLOCK
@ CRM_USART3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:141
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f435_437_crm.h:115
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:140
dmamux_enable
void dmamux_enable(dma_type *dma_x, confirm_state new_state)
enable or disable the dmamux.
Definition: at32f435_437_dma.c:391
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channel.
Definition: at32f435_437_dma.c:197
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f435_437_dma.c:281
dmamux_init
void dmamux_init(dmamux_channel_type *dmamux_channelx, dmamux_requst_id_sel_type dmamux_req_sel)
dmamux init.
Definition: at32f435_437_dma.c:442
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
dma flag get.
Definition: at32f435_437_dma.c:221
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset dmax channely register.
Definition: at32f435_437_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init.
Definition: at32f435_437_dma.c:316
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:162
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f435_437_dma.h:153
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f435_437_dma.h:152
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f435_437_dma.h:172
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f435_437_dma.h:183
DMAMUX_DMAREQ_ID_USART3_TX
@ DMAMUX_DMAREQ_ID_USART3_TX
Definition: at32f435_437_dma.h:227
DMAMUX_DMAREQ_ID_USART3_RX
@ DMAMUX_DMAREQ_ID_USART3_RX
Definition: at32f435_437_dma.h:226
DMAMUX_DMAREQ_ID_USART2_TX
@ DMAMUX_DMAREQ_ID_USART2_TX
Definition: at32f435_437_dma.h:225
DMAMUX_DMAREQ_ID_USART2_RX
@ DMAMUX_DMAREQ_ID_USART2_RX
Definition: at32f435_437_dma.h:224
DMA1_FDT4_FLAG
#define DMA1_FDT4_FLAG
Definition: at32f435_437_dma.h:78
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f435_437_dma.h:66
DMA1_FDT2_FLAG
#define DMA1_FDT2_FLAG
Definition: at32f435_437_dma.h:70
DMA1_FDT3_FLAG
#define DMA1_FDT3_FLAG
Definition: at32f435_437_dma.h:74
DMA1MUX_CHANNEL2
#define DMA1MUX_CHANNEL2
Definition: at32f435_437_dma.h:705
DMA1MUX_CHANNEL3
#define DMA1MUX_CHANNEL3
Definition: at32f435_437_dma.h:706
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f435_437_dma.h:698
DMA1MUX_CHANNEL4
#define DMA1MUX_CHANNEL4
Definition: at32f435_437_dma.h:707
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f435_437_dma.h:699
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f435_437_dma.h:696
DMA1MUX_CHANNEL1
#define DMA1MUX_CHANNEL1
Definition: at32f435_437_dma.h:704
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f435_437_dma.h:697
DMA1
#define DMA1
Definition: at32f435_437_dma.h:695
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f435_437_usart.c:209
usart_dma_receiver_enable
void usart_dma_receiver_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma receiver interface.
Definition: at32f435_437_usart.c:318
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f435_437_usart.c:115
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f435_437_usart.c:196
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f435_437_usart.c:222
usart_dma_transmitter_enable
void usart_dma_transmitter_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface.
Definition: at32f435_437_usart.c:304
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f435_437_usart.h:159
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f435_437_usart.h:114
USART3
#define USART3
Definition: at32f435_437_usart.h:350
USART2
#define USART2
Definition: at32f435_437_usart.h:349
dma_init_type
dma init type
Definition: at32f435_437_dma.h:376
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f435_437_dma.h:385
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f435_437_dma.h:380
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f435_437_dma.h:384
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f435_437_dma.h:386
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f435_437_dma.h:381
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f435_437_dma.h:382
dma_init_type::direction
dma_dir_type direction
Definition: at32f435_437_dma.h:379
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f435_437_dma.h:377
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f435_437_dma.h:378
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f435_437_dma.h:383
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • usart
  • tx_rx_swap
  • inc
project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • usart
  • tx_rx_swap
  • inc
project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • usart
  • tx_rx_swap
  • inc
project/at_start_f435/examples/usart/tx_rx_swap/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • usart
  • tx_rx_swap
  • src
Functions
project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • usart
  • tx_rx_swap
  • src
project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • usart
  • tx_rx_swap
  • src
Functions
project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • usart
  • tx_rx_swap
  • src
project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • usart
  • tx_rx_swap
  • src
Macros | Functions | Variables
project/at_start_f435/examples/usart/tx_rx_swap/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"

Go to the source code of this file.

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | usart_configuration (void)
config usart More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"
uint8_t | usart3_tx_buffer [] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | usart2_tx_counter = 0x00
uint8_t | usart3_tx_counter = 0x00
uint8_t | usart2_rx_counter = 0x00
uint8_t | usart3_rx_counter = 0x00
uint8_t | usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)
uint8_t | usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usart/tx_rx_swap/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • usart
  • tx_rx_swap
  • src
project/at_start_f435/examples/usart/tx_rx_swap/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29
38#define COUNTOF(a) (sizeof(a) / sizeof(*(a)))
39#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
40#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)
41
42uint8_t usart2_tx_buffer[] = "usart transfer by interrupt: usart2 -> usart3 using interrupt";
43uint8_t usart3_tx_buffer[] = "usart transfer by interrupt: usart3 -> usart2 using interrupt";
44uint8_t usart2_rx_buffer[USART3_TX_BUFFER_SIZE];
45uint8_t usart3_rx_buffer[USART2_TX_BUFFER_SIZE];
46uint8_t usart2_tx_counter = 0x00;
47uint8_t usart3_tx_counter = 0x00;
48uint8_t usart2_rx_counter = 0x00;
49uint8_t usart3_rx_counter = 0x00;
50uint8_t usart2_tx_buffer_size = USART2_TX_BUFFER_SIZE;
51uint8_t usart3_tx_buffer_size = USART3_TX_BUFFER_SIZE;
52
58void usart_configuration(void)
59{
60 gpio_init_type gpio_init_struct;
61
62 /* enable the usart2 and gpio clock */
63 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
64 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
65
66 /* enable the usart3 and gpio clock */
67 crm_periph_clock_enable(CRM_USART3_PERIPH_CLOCK, TRUE);
68 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
69
70 gpio_default_para_init(&gpio_init_struct);
71
72 /* configure the usart2 tx, rx pin */
73 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
74 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
75 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
76 gpio_init_struct.gpio_pins = GPIO_PINS_2 | GPIO_PINS_3;
77 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
78 gpio_init(GPIOA, &gpio_init_struct);
79 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE2, GPIO_MUX_7);
80 gpio_pin_mux_config(GPIOA, GPIO_PINS_SOURCE3, GPIO_MUX_7);
81
82 /* configure the usart3 tx, rx pin */
83 gpio_init_struct.gpio_pins = GPIO_PINS_10 | GPIO_PINS_11;
84 gpio_init(GPIOB, &gpio_init_struct);
85 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE10, GPIO_MUX_7);
86 gpio_pin_mux_config(GPIOB, GPIO_PINS_SOURCE11, GPIO_MUX_7);
87
88 /* configure usart2 param */
89 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
90 usart_transmitter_enable(USART2, TRUE);
91 usart_receiver_enable(USART2, TRUE);
92 usart_transmit_receive_pin_swap(USART2, TRUE);
93 usart_enable(USART2, TRUE);
94
95 /* configure usart3 param */
96 usart_init(USART3, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
97 usart_transmitter_enable(USART3, TRUE);
98 usart_receiver_enable(USART3, TRUE);
99 usart_enable(USART3, TRUE);
100}
101
109uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
110{
111 while(buffer_length--)
112 {
113 if(*pbuffer1 != *pbuffer2)
114 {
115 return 0;
116 }
117 pbuffer1++;
118 pbuffer2++;
119 }
120 return 1;
121}
122
128int main(void)
129{
130 system_clock_config();
131 at32_board_init();
132 usart_configuration();
133
134 /* wait until end of transmission from usart2 to usart3 */
135 while(usart3_rx_counter < usart2_tx_buffer_size)
136 {
137 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
138 usart_data_transmit(USART2, usart2_tx_buffer[usart2_tx_counter++]);
139
140 while(usart_flag_get(USART3, USART_RDBF_FLAG) == RESET);
141 usart3_rx_buffer[usart3_rx_counter++] = usart_data_receive(USART3);
142 }
143
144 /* wait until end of transmission from usart3 to usart2 */
145 while(usart2_rx_counter < usart3_tx_buffer_size)
146 {
147 while(usart_flag_get(USART3, USART_TDBE_FLAG) == RESET);
148 usart_data_transmit(USART3, usart3_tx_buffer[usart3_tx_counter++]);
149
150 while(usart_flag_get(USART2, USART_RDBF_FLAG) == RESET);
151 usart2_rx_buffer[usart2_rx_counter++] = usart_data_receive(USART2);
152 }
153
154 while(1)
155 {
156 /* compare data buffer */
157 if(buffer_compare(usart2_tx_buffer, usart3_rx_buffer, USART2_TX_BUFFER_SIZE) && \
158 buffer_compare(usart3_tx_buffer, usart2_rx_buffer, USART3_TX_BUFFER_SIZE))
159 {
160 at32_led_toggle(LED2);
161 at32_led_toggle(LED3);
162 at32_led_toggle(LED4);
163 delay_sec(1);
164 }
165 }
166}
167
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/main.c:58
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/main.c:109
usart3_tx_counter
uint8_t usart3_tx_counter
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/main.c:47
usart2_tx_counter
uint8_t usart2_tx_counter
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/main.c:46
usart2_tx_buffer_size
uint8_t usart2_tx_buffer_size
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/main.c:50
usart3_rx_buffer
uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/main.c:45
usart2_rx_counter
uint8_t usart2_rx_counter
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/main.c:48
USART2_TX_BUFFER_SIZE
#define USART2_TX_BUFFER_SIZE
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/main.c:128
usart3_tx_buffer_size
uint8_t usart3_tx_buffer_size
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/main.c:51
usart2_tx_buffer
uint8_t usart2_tx_buffer[]
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/main.c:42
USART3_TX_BUFFER_SIZE
#define USART3_TX_BUFFER_SIZE
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/main.c:40
usart3_tx_buffer
uint8_t usart3_tx_buffer[]
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/main.c:43
usart3_rx_counter
uint8_t usart3_rx_counter
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/main.c:49
usart2_rx_buffer
uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
Definition: project/at_start_f435/examples/usart/tx_rx_swap/src/main.c:44
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f435_437_board.c:280
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f435_437_board.c:358
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f435_437_crm.h:105
CRM_USART3_PERIPH_CLOCK
@ CRM_USART3_PERIPH_CLOCK
Definition: at32f435_437_crm.h:141
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f435_437_crm.h:106
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f435_437_crm.h:140
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f435_437_gpio.h:136
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f435_437_gpio.h:135
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f435_437_gpio.h:143
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f435_437_gpio.h:144
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
GPIO_MUX_7
@ GPIO_MUX_7
Definition: at32f435_437_gpio.h:163
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f435_437_gpio.h:61
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f435_437_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f435_437_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f435_437_gpio.h:54
GPIOB
#define GPIOB
Definition: at32f435_437_gpio.h:522
GPIOA
#define GPIOA
Definition: at32f435_437_gpio.h:521
usart_transmit_receive_pin_swap
void usart_transmit_receive_pin_swap(usart_type *usart_x, confirm_state new_state)
swap the usart's transmit receive pin.
Definition: at32f435_437_usart.c:673
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f435_437_usart.c:413
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f435_437_usart.c:598
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f435_437_usart.c:209
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f435_437_usart.c:115
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f435_437_usart.c:196
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f435_437_usart.c:222
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f435_437_usart.c:425
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f435_437_usart.h:159
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f435_437_usart.h:114
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f435_437_usart.h:59
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f435_437_usart.h:57
USART3
#define USART3
Definition: at32f435_437_usart.h:350
USART2
#define USART2
Definition: at32f435_437_usart.h:349
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • usb_device
  • audio
  • inc
project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • usb_device
  • audio
  • inc
project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • usb_device
  • audio
  • inc
project/at_start_f435/examples/usb_device/audio/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: usb_conf.h Source File

  • at_start_f435
  • examples
  • usb_device
  • audio
  • inc
project/at_start_f435/examples/usb_device/audio/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f435_437_usb.h"
36#include "at32f435_437.h"
37#include "at32f435_437_board.h"
38
50#define USE_OTG_DEVICE_MODE
51
55/* #define USE_OTG_HOST_MODE */
56
61/* use otgfs1 */
62#define OTG_USB_ID 1
63
64/* use otgfs2 */
65//#define OTG_USB_ID 2
66
67#if (OTG_USB_ID == 1)
68#define USB_ID 0
69#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
70#define OTG_IRQ OTGFS1_IRQn
71#define OTG_IRQ_HANDLER OTGFS1_IRQHandler
72#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
73#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
74#define OTG_WKUP_EXINT_LINE EXINT_LINE_18
75
76#define OTG_PIN_GPIO GPIOA
77#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
78
79#define OTG_PIN_DP GPIO_PINS_12
80#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
81
82#define OTG_PIN_DM GPIO_PINS_11
83#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
84
85#define OTG_PIN_VBUS GPIO_PINS_9
86#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
87
88#define OTG_PIN_ID GPIO_PINS_10
89#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
90
91#define OTG_PIN_SOF_GPIO GPIOA
92#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
93#define OTG_PIN_SOF GPIO_PINS_8
94#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
95
96#define OTG_PIN_MUX GPIO_MUX_10
97#endif
98
99#if (OTG_USB_ID == 2)
100#define USB_ID 1
101#define OTG_CLOCK CRM_OTGFS2_PERIPH_CLOCK
102#define OTG_IRQ OTGFS2_IRQn
103#define OTG_IRQ_HANDLER OTGFS2_IRQHandler
104#define OTG_WKUP_IRQ OTGFS2_WKUP_IRQn
105#define OTG_WKUP_HANDLER OTGFS2_WKUP_IRQHandler
106#define OTG_WKUP_EXINT_LINE EXINT_LINE_20
107
108#define OTG_PIN_GPIO GPIOB
109#define OTG_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK
110
111#define OTG_PIN_DP GPIO_PINS_15
112#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE15
113
114#define OTG_PIN_DM GPIO_PINS_14
115#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE14
116
117#define OTG_PIN_VBUS GPIO_PINS_13
118#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13
119
120#define OTG_PIN_ID GPIO_PINS_12
121#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
122
123#define OTG_PIN_SOF_GPIO GPIOA
124#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
125#define OTG_PIN_SOF GPIO_PINS_4
126#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE4
127
128#define OTG_PIN_MUX GPIO_MUX_12
129#endif
130
134#ifdef USE_OTG_DEVICE_MODE
138 /* otg1 device fifo */
139#define USBD_RX_SIZE 128
140#define USBD_EP0_TX_SIZE 24
141#define USBD_EP1_TX_SIZE 64
142#define USBD_EP2_TX_SIZE 16
143#define USBD_EP3_TX_SIZE 16
144#define USBD_EP4_TX_SIZE 0
145#define USBD_EP5_TX_SIZE 0
146#define USBD_EP6_TX_SIZE 0
147#define USBD_EP7_TX_SIZE 0
148
149/* otg2 device fifo */
150#define USBD2_RX_SIZE 128
151#define USBD2_EP0_TX_SIZE 24
152#define USBD2_EP1_TX_SIZE 64
153#define USBD2_EP2_TX_SIZE 4
154#define USBD2_EP3_TX_SIZE 0
155#define USBD2_EP4_TX_SIZE 0
156#define USBD2_EP5_TX_SIZE 0
157#define USBD2_EP6_TX_SIZE 0
158#define USBD2_EP7_TX_SIZE 0
159
163#ifndef USB_EPT_MAX_NUM
164#define USB_EPT_MAX_NUM 8
165#endif
166#endif
167
171#ifdef USE_OTG_HOST_MODE
172#ifndef USB_HOST_CHANNEL_NUM
173#define USB_HOST_CHANNEL_NUM 16
174#endif
175
179/* otg1 host fifo */
180#define USBH_RX_FIFO_SIZE 128
181#define USBH_NP_TX_FIFO_SIZE 96
182#define USBH_P_TX_FIFO_SIZE 96
183
184/* otg2 host fifo */
185#define USBH2_RX_FIFO_SIZE 128
186#define USBH2_NP_TX_FIFO_SIZE 96
187#define USBH2_P_TX_FIFO_SIZE 96
188#endif
189
193/* #define USB_SOF_OUTPUT_ENABLE */
194
198#define USB_VBUS_IGNORE
199
203/* #define USB_LOW_POWER_WAKUP */
204
205void usb_delay_ms(uint32_t ms);
206void usb_delay_us(uint32_t us);
207
215#ifdef __cplusplus
216}
217#endif
218
219#endif
at32f435_437.h
at32f435_437 header file
at32f435_437_board.h
at32f435_437_usb.h
at32f435_437 usb header file
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb low power wakeup handler enable
Definition: project/at_start_f435/examples/usb_device/audio/src/main.c:279
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f435/examples/usb_device/audio/src/main.c:290


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • audio
  • src
Functions
project/at_start_f435/examples/usb_device/audio/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/audio/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • usb_device
  • audio
  • src
project/at_start_f435/examples/usb_device/audio/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/usb_device/audio/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • audio
  • src
Functions
project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • usb_device
  • audio
  • src
project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/usb_device/audio/src/at32f435_437_int.c:111
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • audio
  • src
Functions | Variables
project/at_start_f435/examples/usb_device/audio/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include "usb_conf.h"
#include "usb_core.h"
#include "usbd_int.h"
#include "audio_class.h"
#include "audio_desc.h"
#include "audio_codec.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
int | main (void)
main function. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

otg_core_type otg_core_struct

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/audio/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • usb_device
  • audio
  • src
project/at_start_f435/examples/usb_device/audio/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include "usb_conf.h"
30#include "usb_core.h"
31#include "usbd_int.h"
32#include "audio_class.h"
33#include "audio_desc.h"
34#include "audio_codec.h"
35
44/* usb global struct define */
45 otg_core_type otg_core_struct;
46void usb_clock48m_select(usb_clk48_s clk_s);
47void usb_gpio_config(void);
48void usb_low_power_wakeup_config(void);
49
55int main(void)
56{
57 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
58
59 system_clock_config();
60
61 /* audio codec init */
62 audio_codec_init();
63
64 at32_board_init();
65
66 /* usb gpio config */
67 usb_gpio_config();
68
69#ifdef USB_LOW_POWER_WAKUP
70 usb_low_power_wakeup_config();
71#endif
72
73 /* enable otgfs clock */
74 crm_periph_clock_enable(OTG_CLOCK, TRUE);
75
76 /* select usb 48m clcok source */
77 usb_clock48m_select(USB_CLK_HEXT);
78
79 /* enable otgfs irq */
80 nvic_irq_enable(OTG_IRQ, 0, 0);
81
82 /* init usb */
83 usbd_init(&otg_core_struct,
84 USB_FULL_SPEED_CORE_ID,
85 USB_ID,
86 &audio_class_handler,
87 &audio_desc_handler);
88
89 while(1)
90 {
91 audio_codec_loop();
92 delay_ms(100);
93 }
94}
95
101void usb_clock48m_select(usb_clk48_s clk_s)
102{
103 if(clk_s == USB_CLK_HICK)
104 {
105 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
106
107 /* enable the acc calibration ready interrupt */
108 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
109
110 /* update the c1\c2\c3 value */
111 acc_write_c1(7980);
112 acc_write_c2(8000);
113 acc_write_c3(8020);
114#if (USB_ID == 0)
115 acc_sof_select(ACC_SOF_OTG1);
116#else
117 acc_sof_select(ACC_SOF_OTG2);
118#endif
119 /* open acc calibration */
120 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
121 }
122 else
123 {
124 switch(system_core_clock)
125 {
126 /* 48MHz */
127 case 48000000:
128 crm_usb_clock_div_set(CRM_USB_DIV_1);
129 break;
130
131 /* 72MHz */
132 case 72000000:
133 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
134 break;
135
136 /* 96MHz */
137 case 96000000:
138 crm_usb_clock_div_set(CRM_USB_DIV_2);
139 break;
140
141 /* 120MHz */
142 case 120000000:
143 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
144 break;
145
146 /* 144MHz */
147 case 144000000:
148 crm_usb_clock_div_set(CRM_USB_DIV_3);
149 break;
150
151 /* 168MHz */
152 case 168000000:
153 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
154 break;
155
156 /* 192MHz */
157 case 192000000:
158 crm_usb_clock_div_set(CRM_USB_DIV_4);
159 break;
160
161 /* 216MHz */
162 case 216000000:
163 crm_usb_clock_div_set(CRM_USB_DIV_4_5);
164 break;
165
166 /* 240MHz */
167 case 240000000:
168 crm_usb_clock_div_set(CRM_USB_DIV_5);
169 break;
170
171 /* 264MHz */
172 case 264000000:
173 crm_usb_clock_div_set(CRM_USB_DIV_5_5);
174 break;
175
176 /* 288MHz */
177 case 288000000:
178 crm_usb_clock_div_set(CRM_USB_DIV_6);
179 break;
180
181 default:
182 break;
183
184 }
185 }
186}
187
193void usb_gpio_config(void)
194{
195 gpio_init_type gpio_init_struct;
196
197 crm_periph_clock_enable(OTG_PIN_GPIO_CLOCK, TRUE);
198 gpio_default_para_init(&gpio_init_struct);
199
200 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
201 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
202 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
203 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
204
205 /* dp and dm */
206 gpio_init_struct.gpio_pins = OTG_PIN_DP | OTG_PIN_DM;
207 gpio_init(OTG_PIN_GPIO, &gpio_init_struct);
208
209 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_DP_SOURCE, OTG_PIN_MUX);
210 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_DM_SOURCE, OTG_PIN_MUX);
211
212#ifdef USB_SOF_OUTPUT_ENABLE
213 crm_periph_clock_enable(OTG_PIN_SOF_GPIO_CLOCK, TRUE);
214 gpio_init_struct.gpio_pins = OTG_PIN_SOF;
215 gpio_init(OTG_PIN_SOF_GPIO, &gpio_init_struct);
216 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_SOF_SOURCE, OTG_PIN_MUX);
217#endif
218
219 /* otgfs use vbus pin */
220#ifndef USB_VBUS_IGNORE
221 gpio_init_struct.gpio_pins = OTG_PIN_VBUS;
222 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
223 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_VBUS_SOURCE, OTG_PIN_MUX);
224 gpio_init(OTG_PIN_GPIO, &gpio_init_struct);
225#endif
226
227
228}
229#ifdef USB_LOW_POWER_WAKUP
235void usb_low_power_wakeup_config(void)
236{
237 exint_init_type exint_init_struct;
238
239 crm_periph_clock_enable(CRM_SCFG_PERIPH_CLOCK, TRUE);
240 exint_default_para_init(&exint_init_struct);
241
242 exint_init_struct.line_enable = TRUE;
243 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
244 exint_init_struct.line_select = OTG_WKUP_EXINT_LINE;
245 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
246 exint_init(&exint_init_struct);
247
248 nvic_irq_enable(OTG_WKUP_IRQ, 0, 0);
249}
250
256void OTG_WKUP_HANDLER(void)
257{
258 exint_flag_clear(OTG_WKUP_EXINT_LINE);
259}
260
261#endif
262
263
269void OTG_IRQ_HANDLER(void)
270{
271 usbd_irq_handler(&otg_core_struct);
272}
273
279void usb_delay_ms(uint32_t ms)
280{
281 /* user can define self delay function */
282 delay_ms(ms);
283}
284
290void usb_delay_us(uint32_t us)
291{
292 delay_us(us);
293}
294
at32f435_437_board.h
audio_class.h
usb audio class file
audio_desc.h
usb audio descriptor header file
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:41
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f435/examples/usb_device/audio/src/main.c:101
main
int main(void)
main function.
Definition: project/at_start_f435/examples/usb_device/audio/src/main.c:55
usb_low_power_wakeup_config
void usb_low_power_wakeup_config(void)
usb_gpio_config
void usb_gpio_config(void)
this function config gpio.
Definition: project/at_start_f435/examples/usb_device/audio/src/main.c:193
OTG_IRQ_HANDLER
void OTG_IRQ_HANDLER(void)
this function handles otgfs interrupt.
Definition: project/at_start_f435/examples/usb_device/audio/src/main.c:269
otg_core_struct
otg_core_type otg_core_struct
Definition: project/at_start_f435/examples/usb_device/audio/src/main.c:45
OTG_PIN_VBUS
#define OTG_PIN_VBUS
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:85
OTG_PIN_DM
#define OTG_PIN_DM
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:82
OTG_PIN_DP
#define OTG_PIN_DP
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:79
OTG_PIN_SOF
#define OTG_PIN_SOF
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:93
OTG_WKUP_IRQ
#define OTG_WKUP_IRQ
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:72
OTG_PIN_DP_SOURCE
#define OTG_PIN_DP_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:80
OTG_PIN_GPIO
#define OTG_PIN_GPIO
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:76
OTG_IRQ
#define OTG_IRQ
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:70
OTG_PIN_SOF_GPIO
#define OTG_PIN_SOF_GPIO
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:91
OTG_WKUP_HANDLER
#define OTG_WKUP_HANDLER
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:73
OTG_CLOCK
#define OTG_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:69
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb low power wakeup handler enable
Definition: project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c:304
OTG_PIN_GPIO_CLOCK
#define OTG_PIN_GPIO_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:77
OTG_PIN_SOF_SOURCE
#define OTG_PIN_SOF_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:94
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c:315
OTG_PIN_VBUS_SOURCE
#define OTG_PIN_VBUS_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:86
USB_ID
#define USB_ID
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:68
OTG_PIN_DM_SOURCE
#define OTG_PIN_DM_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:83
OTG_PIN_MUX
#define OTG_PIN_MUX
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:96
OTG_WKUP_EXINT_LINE
#define OTG_WKUP_EXINT_LINE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:74
OTG_PIN_SOF_GPIO_CLOCK
#define OTG_PIN_SOF_GPIO_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:92
ACC_SOF_OTG2
#define ACC_SOF_OTG2
Definition: at32f435_437_acc.h:61
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f435_437_acc.h:52
ACC_SOF_OTG1
#define ACC_SOF_OTG1
Definition: at32f435_437_acc.h:60
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f435_437_acc.c:145
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f435_437_acc.c:155
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f435_437_acc.c:135
acc_sof_select
void acc_sof_select(uint16_t sof_sel)
select sof sourse for acc in acc's ctrl1 register.
Definition: at32f435_437_acc.c:84
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f435_437_acc.c:53
system_core_clock
unsigned int system_core_clock
Definition: system_at32f435_437.c:48
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f435_437_board.c:306
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type value)
set usb division
Definition: at32f435_437_crm.c:521
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f435_437_crm.c:594
CRM_SCFG_PERIPH_CLOCK
@ CRM_SCFG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:163
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:168
CRM_USB_DIV_5
@ CRM_USB_DIV_5
Definition: at32f435_437_crm.h:620
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f435_437_crm.h:616
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f435_437_crm.h:611
CRM_USB_DIV_5_5
@ CRM_USB_DIV_5_5
Definition: at32f435_437_crm.h:619
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f435_437_crm.h:618
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f435_437_crm.h:615
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f435_437_crm.h:614
CRM_USB_DIV_6
@ CRM_USB_DIV_6
Definition: at32f435_437_crm.h:622
CRM_USB_DIV_4_5
@ CRM_USB_DIV_4_5
Definition: at32f435_437_crm.h:617
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f435_437_crm.h:612
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f435_437_crm.h:613
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f435_437_crm.h:763
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f435_437_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
audio_class_handler
usbd_class_handler audio_class_handler
Definition: audio_class.c:66
audio_desc_handler
usbd_desc_handler audio_desc_handler
device descriptor handler structure
Definition: audio_desc.c:62
USB_FULL_SPEED_CORE_ID
@ USB_FULL_SPEED_CORE_ID
Definition: usb_core.h:64
audio_codec_loop
error_status audio_codec_loop(void)
audio codec loop
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:870
audio_codec_init
error_status audio_codec_init(void)
audio codec init
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:811
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f435_437_usb.h:402
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f435_437_usb.h:404
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f435_437_usb.h:403
usbd_irq_handler
void usbd_irq_handler(otg_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
otg_core_type
usb otg core struct type
Definition: usb_core.h:92
usb_core.h
usb core header file
usbd_int.h
usb interrupt header file
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_audio_hid
  • inc
project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_audio_hid
  • inc
project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_audio_hid
  • inc
project/at_start_f435/examples/usb_device/composite_audio_hid/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: usb_conf.h Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_audio_hid
  • inc
project/at_start_f435/examples/usb_device/composite_audio_hid/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f435_437_usb.h"
36#include "at32f435_437.h"
37#include "at32f435_437_board.h"
38
50#define USE_OTG_DEVICE_MODE
51
55/* #define USE_OTG_HOST_MODE */
56
61/* use otgfs1 */
62#define OTG_USB_ID 1
63
64/* use otgfs2 */
65//#define OTG_USB_ID 2
66
67#if (OTG_USB_ID == 1)
68#define USB_ID 0
69#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
70#define OTG_IRQ OTGFS1_IRQn
71#define OTG_IRQ_HANDLER OTGFS1_IRQHandler
72#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
73#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
74#define OTG_WKUP_EXINT_LINE EXINT_LINE_18
75
76#define OTG_PIN_GPIO GPIOA
77#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
78
79#define OTG_PIN_DP GPIO_PINS_12
80#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
81
82#define OTG_PIN_DM GPIO_PINS_11
83#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
84
85#define OTG_PIN_VBUS GPIO_PINS_9
86#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
87
88#define OTG_PIN_ID GPIO_PINS_10
89#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
90
91#define OTG_PIN_SOF_GPIO GPIOA
92#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
93#define OTG_PIN_SOF GPIO_PINS_8
94#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
95
96#define OTG_PIN_MUX GPIO_MUX_10
97#endif
98
99#if (OTG_USB_ID == 2)
100#define USB_ID 1
101#define OTG_CLOCK CRM_OTGFS2_PERIPH_CLOCK
102#define OTG_IRQ OTGFS2_IRQn
103#define OTG_IRQ_HANDLER OTGFS2_IRQHandler
104#define OTG_WKUP_IRQ OTGFS2_WKUP_IRQn
105#define OTG_WKUP_HANDLER OTGFS2_WKUP_IRQHandler
106#define OTG_WKUP_EXINT_LINE EXINT_LINE_20
107
108#define OTG_PIN_GPIO GPIOB
109#define OTG_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK
110
111#define OTG_PIN_DP GPIO_PINS_15
112#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE15
113
114#define OTG_PIN_DM GPIO_PINS_14
115#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE14
116
117#define OTG_PIN_VBUS GPIO_PINS_13
118#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13
119
120#define OTG_PIN_ID GPIO_PINS_12
121#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
122
123#define OTG_PIN_SOF_GPIO GPIOA
124#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
125#define OTG_PIN_SOF GPIO_PINS_4
126#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE4
127
128#define OTG_PIN_MUX GPIO_MUX_12
129#endif
130
134#ifdef USE_OTG_DEVICE_MODE
138 /* otg1 device fifo */
139#define USBD_RX_SIZE 128
140#define USBD_EP0_TX_SIZE 24
141#define USBD_EP1_TX_SIZE 64
142#define USBD_EP2_TX_SIZE 20
143#define USBD_EP3_TX_SIZE 16
144#define USBD_EP4_TX_SIZE 0
145#define USBD_EP5_TX_SIZE 0
146#define USBD_EP6_TX_SIZE 0
147#define USBD_EP7_TX_SIZE 0
148
149/* otg2 device fifo */
150#define USBD2_RX_SIZE 128
151#define USBD2_EP0_TX_SIZE 24
152#define USBD2_EP1_TX_SIZE 64
153#define USBD2_EP2_TX_SIZE 20
154#define USBD2_EP3_TX_SIZE 16
155#define USBD2_EP4_TX_SIZE 0
156#define USBD2_EP5_TX_SIZE 0
157#define USBD2_EP6_TX_SIZE 0
158#define USBD2_EP7_TX_SIZE 0
159
163#ifndef USB_EPT_MAX_NUM
164#define USB_EPT_MAX_NUM 8
165#endif
166#endif
167
171#ifdef USE_OTG_HOST_MODE
172#ifndef USB_HOST_CHANNEL_NUM
173#define USB_HOST_CHANNEL_NUM 16
174#endif
175
179/* otg1 host fifo */
180#define USBH_RX_FIFO_SIZE 128
181#define USBH_NP_TX_FIFO_SIZE 96
182#define USBH_P_TX_FIFO_SIZE 96
183
184/* otg2 host fifo */
185#define USBH2_RX_FIFO_SIZE 128
186#define USBH2_NP_TX_FIFO_SIZE 96
187#define USBH2_P_TX_FIFO_SIZE 96
188#endif
189
193/* #define USB_SOF_OUTPUT_ENABLE */
194
198#define USB_VBUS_IGNORE
199
203/* #define USB_LOW_POWER_WAKUP */
204
205void usb_delay_ms(uint32_t ms);
206void usb_delay_us(uint32_t us);
207
215#ifdef __cplusplus
216}
217#endif
218
219#endif
at32f435_437.h
at32f435_437 header file
at32f435_437_board.h
at32f435_437_usb.h
at32f435_437 usb header file
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb low power wakeup handler enable
Definition: project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c:286
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c:297


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_audio_hid
  • src
Functions
project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_audio_hid
  • src
project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_audio_hid
  • src
Functions
project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_audio_hid
  • src
project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
41void NMI_Handler(void)
42{
43}
44
50void HardFault_Handler(void)
51{
52 /* go to infinite loop when hard fault exception occurs */
53 while(1)
54 {
55 }
56}
57
63void MemManage_Handler(void)
64{
65 /* go to infinite loop when memory manage exception occurs */
66 while(1)
67 {
68 }
69}
70
76void BusFault_Handler(void)
77{
78 /* go to infinite loop when bus fault exception occurs */
79 while(1)
80 {
81 }
82}
83
89void UsageFault_Handler(void)
90{
91 /* go to infinite loop when usage fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void SVC_Handler(void)
103{
104}
105
111void DebugMon_Handler(void)
112{
113}
114
120void PendSV_Handler(void)
121{
122}
123
129void SysTick_Handler(void)
130{
131}
132
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c:89
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c:50
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c:63
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c:102
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c:120
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c:41
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c:76
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c:129
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/usb_device/composite_audio_hid/src/at32f435_437_int.c:111
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_audio_hid
  • src
Functions | Variables
project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include "usb_conf.h"
#include "usb_core.h"
#include "usbd_int.h"
#include "audio_hid_class.h"
#include "audio_hid_desc.h"
#include "audio_codec.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
int | main (void)
main function. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

otg_core_type otg_core_struct
uint8_t report_buf [USBD_AUHID_IN_MAXPACKET_SIZE]

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_audio_hid
  • src
project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include "usb_conf.h"
30#include "usb_core.h"
31#include "usbd_int.h"
32#include "audio_hid_class.h"
33#include "audio_hid_desc.h"
34#include "audio_codec.h"
35
44/* usb global struct define */
45 otg_core_type otg_core_struct;
46void usb_clock48m_select(usb_clk48_s clk_s);
47void usb_gpio_config(void);
48void usb_low_power_wakeup_config(void);
49uint8_t report_buf[USBD_AUHID_IN_MAXPACKET_SIZE];
50
56int main(void)
57{
58 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
59
60 system_clock_config();
61
62 /* audio codec init */
63 audio_codec_init();
64
65 at32_board_init();
66
67 /* usb gpio config */
68 usb_gpio_config();
69
70#ifdef USB_LOW_POWER_WAKUP
71 usb_low_power_wakeup_config();
72#endif
73
74 /* enable otgfs clock */
75 crm_periph_clock_enable(OTG_CLOCK, TRUE);
76
77 /* select usb 48m clcok source */
78 usb_clock48m_select(USB_CLK_HEXT);
79
80 /* enable otgfs irq */
81 nvic_irq_enable(OTG_IRQ, 0, 0);
82
83 /* init usb */
84 usbd_init(&otg_core_struct,
85 USB_FULL_SPEED_CORE_ID,
86 USB_ID,
87 &audio_hid_class_handler,
88 &audio_hid_desc_handler);
89
90 while(1)
91 {
92 audio_codec_loop();
93 if(at32_button_press() == USER_BUTTON)
94 {
95 report_buf[0] = HID_REPORT_ID_5;
96 report_buf[1] = (~report_buf[1]) & 0x1;
97 audio_hid_class_send_report(&otg_core_struct.dev, report_buf, USBD_AUHID_IN_MAXPACKET_SIZE);
98 }
99 delay_ms(100);
100 }
101}
102
108void usb_clock48m_select(usb_clk48_s clk_s)
109{
110 if(clk_s == USB_CLK_HICK)
111 {
112 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
113
114 /* enable the acc calibration ready interrupt */
115 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
116
117 /* update the c1\c2\c3 value */
118 acc_write_c1(7980);
119 acc_write_c2(8000);
120 acc_write_c3(8020);
121#if (USB_ID == 0)
122 acc_sof_select(ACC_SOF_OTG1);
123#else
124 acc_sof_select(ACC_SOF_OTG2);
125#endif
126 /* open acc calibration */
127 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
128 }
129 else
130 {
131 switch(system_core_clock)
132 {
133 /* 48MHz */
134 case 48000000:
135 crm_usb_clock_div_set(CRM_USB_DIV_1);
136 break;
137
138 /* 72MHz */
139 case 72000000:
140 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
141 break;
142
143 /* 96MHz */
144 case 96000000:
145 crm_usb_clock_div_set(CRM_USB_DIV_2);
146 break;
147
148 /* 120MHz */
149 case 120000000:
150 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
151 break;
152
153 /* 144MHz */
154 case 144000000:
155 crm_usb_clock_div_set(CRM_USB_DIV_3);
156 break;
157
158 /* 168MHz */
159 case 168000000:
160 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
161 break;
162
163 /* 192MHz */
164 case 192000000:
165 crm_usb_clock_div_set(CRM_USB_DIV_4);
166 break;
167
168 /* 216MHz */
169 case 216000000:
170 crm_usb_clock_div_set(CRM_USB_DIV_4_5);
171 break;
172
173 /* 240MHz */
174 case 240000000:
175 crm_usb_clock_div_set(CRM_USB_DIV_5);
176 break;
177
178 /* 264MHz */
179 case 264000000:
180 crm_usb_clock_div_set(CRM_USB_DIV_5_5);
181 break;
182
183 /* 288MHz */
184 case 288000000:
185 crm_usb_clock_div_set(CRM_USB_DIV_6);
186 break;
187
188 default:
189 break;
190
191 }
192 }
193}
194
200void usb_gpio_config(void)
201{
202 gpio_init_type gpio_init_struct;
203
204 crm_periph_clock_enable(OTG_PIN_GPIO_CLOCK, TRUE);
205 gpio_default_para_init(&gpio_init_struct);
206
207 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
208 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
209 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
210 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
211
212 /* dp and dm */
213 gpio_init_struct.gpio_pins = OTG_PIN_DP | OTG_PIN_DM;
214 gpio_init(OTG_PIN_GPIO, &gpio_init_struct);
215
216 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_DP_SOURCE, OTG_PIN_MUX);
217 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_DM_SOURCE, OTG_PIN_MUX);
218
219#ifdef USB_SOF_OUTPUT_ENABLE
220 crm_periph_clock_enable(OTG_PIN_SOF_GPIO_CLOCK, TRUE);
221 gpio_init_struct.gpio_pins = OTG_PIN_SOF;
222 gpio_init(OTG_PIN_SOF_GPIO, &gpio_init_struct);
223 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_SOF_SOURCE, OTG_PIN_MUX);
224#endif
225
226 /* otgfs use vbus pin */
227#ifndef USB_VBUS_IGNORE
228 gpio_init_struct.gpio_pins = OTG_PIN_VBUS;
229 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
230 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_VBUS_SOURCE, OTG_PIN_MUX);
231 gpio_init(OTG_PIN_GPIO, &gpio_init_struct);
232#endif
233
234
235}
236#ifdef USB_LOW_POWER_WAKUP
242void usb_low_power_wakeup_config(void)
243{
244 exint_init_type exint_init_struct;
245
246 crm_periph_clock_enable(CRM_SCFG_PERIPH_CLOCK, TRUE);
247 exint_default_para_init(&exint_init_struct);
248
249 exint_init_struct.line_enable = TRUE;
250 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
251 exint_init_struct.line_select = OTG_WKUP_EXINT_LINE;
252 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
253 exint_init(&exint_init_struct);
254
255 nvic_irq_enable(OTG_WKUP_IRQ, 0, 0);
256}
257
263void OTG_WKUP_HANDLER(void)
264{
265 exint_flag_clear(OTG_WKUP_EXINT_LINE);
266}
267
268#endif
269
270
276void OTG_IRQ_HANDLER(void)
277{
278 usbd_irq_handler(&otg_core_struct);
279}
280
286void usb_delay_ms(uint32_t ms)
287{
288 /* user can define self delay function */
289 delay_ms(ms);
290}
291
297void usb_delay_us(uint32_t us)
298{
299 delay_us(us);
300}
301
at32f435_437_board.h
audio_hid_class.h
audio_hid_desc.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:41
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
report_buf
uint8_t report_buf[USBD_AUHID_IN_MAXPACKET_SIZE]
Definition: project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c:49
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c:108
main
int main(void)
main function.
Definition: project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c:56
usb_low_power_wakeup_config
void usb_low_power_wakeup_config(void)
usb_gpio_config
void usb_gpio_config(void)
this function config gpio.
Definition: project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c:200
OTG_IRQ_HANDLER
void OTG_IRQ_HANDLER(void)
this function handles otgfs interrupt.
Definition: project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c:276
otg_core_struct
otg_core_type otg_core_struct
Definition: project/at_start_f435/examples/usb_device/composite_audio_hid/src/main.c:45
OTG_PIN_VBUS
#define OTG_PIN_VBUS
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:85
OTG_PIN_DM
#define OTG_PIN_DM
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:82
OTG_PIN_DP
#define OTG_PIN_DP
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:79
OTG_PIN_SOF
#define OTG_PIN_SOF
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:93
OTG_WKUP_IRQ
#define OTG_WKUP_IRQ
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:72
OTG_PIN_DP_SOURCE
#define OTG_PIN_DP_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:80
OTG_PIN_GPIO
#define OTG_PIN_GPIO
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:76
OTG_IRQ
#define OTG_IRQ
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:70
OTG_PIN_SOF_GPIO
#define OTG_PIN_SOF_GPIO
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:91
OTG_WKUP_HANDLER
#define OTG_WKUP_HANDLER
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:73
OTG_CLOCK
#define OTG_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:69
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb low power wakeup handler enable
Definition: project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c:304
OTG_PIN_GPIO_CLOCK
#define OTG_PIN_GPIO_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:77
OTG_PIN_SOF_SOURCE
#define OTG_PIN_SOF_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:94
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c:315
OTG_PIN_VBUS_SOURCE
#define OTG_PIN_VBUS_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:86
USB_ID
#define USB_ID
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:68
OTG_PIN_DM_SOURCE
#define OTG_PIN_DM_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:83
OTG_PIN_MUX
#define OTG_PIN_MUX
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:96
OTG_WKUP_EXINT_LINE
#define OTG_WKUP_EXINT_LINE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:74
OTG_PIN_SOF_GPIO_CLOCK
#define OTG_PIN_SOF_GPIO_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:92
ACC_SOF_OTG2
#define ACC_SOF_OTG2
Definition: at32f435_437_acc.h:61
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f435_437_acc.h:52
ACC_SOF_OTG1
#define ACC_SOF_OTG1
Definition: at32f435_437_acc.h:60
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f435_437_acc.c:145
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f435_437_acc.c:155
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f435_437_acc.c:135
acc_sof_select
void acc_sof_select(uint16_t sof_sel)
select sof sourse for acc in acc's ctrl1 register.
Definition: at32f435_437_acc.c:84
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f435_437_acc.c:53
system_core_clock
unsigned int system_core_clock
Definition: system_at32f435_437.c:48
USER_BUTTON
@ USER_BUTTON
Definition: at32f435_437_board.h:98
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f435_437_board.c:194
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f435_437_board.c:306
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type value)
set usb division
Definition: at32f435_437_crm.c:521
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f435_437_crm.c:594
CRM_SCFG_PERIPH_CLOCK
@ CRM_SCFG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:163
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:168
CRM_USB_DIV_5
@ CRM_USB_DIV_5
Definition: at32f435_437_crm.h:620
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f435_437_crm.h:616
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f435_437_crm.h:611
CRM_USB_DIV_5_5
@ CRM_USB_DIV_5_5
Definition: at32f435_437_crm.h:619
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f435_437_crm.h:618
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f435_437_crm.h:615
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f435_437_crm.h:614
CRM_USB_DIV_6
@ CRM_USB_DIV_6
Definition: at32f435_437_crm.h:622
CRM_USB_DIV_4_5
@ CRM_USB_DIV_4_5
Definition: at32f435_437_crm.h:617
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f435_437_crm.h:612
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f435_437_crm.h:613
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f435_437_crm.h:763
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f435_437_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
USBD_AUHID_IN_MAXPACKET_SIZE
#define USBD_AUHID_IN_MAXPACKET_SIZE
usb custom hid in and out max packet size define
Definition: audio_hid_class.h:67
audio_hid_class_send_report
usb_sts_type audio_hid_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: audio_hid_class.c:827
audio_hid_class_handler
usbd_class_handler audio_hid_class_handler
Definition: audio_hid_class.c:66
HID_REPORT_ID_5
#define HID_REPORT_ID_5
Definition: audio_hid_desc.h:226
audio_hid_desc_handler
usbd_desc_handler audio_hid_desc_handler
device descriptor handler structure
Definition: audio_hid_desc.c:62
USB_FULL_SPEED_CORE_ID
@ USB_FULL_SPEED_CORE_ID
Definition: usb_core.h:64
audio_codec_loop
error_status audio_codec_loop(void)
audio codec loop
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:870
audio_codec_init
error_status audio_codec_init(void)
audio codec init
Definition: at_start_f437/examples/usb_device/audio/src/audio_codec.c:811
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f435_437_usb.h:402
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f435_437_usb.h:404
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f435_437_usb.h:403
usbd_irq_handler
void usbd_irq_handler(otg_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
otg_core_type
usb otg core struct type
Definition: usb_core.h:92
usb_core.h
usb core header file
usbd_int.h
usb interrupt header file
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_keyboard
  • inc
project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_keyboard
  • inc
project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_keyboard
  • inc
project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: usb_conf.h Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_keyboard
  • inc
project/at_start_f435/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f435_437_usb.h"
36#include "at32f435_437.h"
37#include "stdio.h"
38
39
52#define USE_OTG_DEVICE_MODE
53
57/* #define USE_OTG_HOST_MODE */
58
63/* use otgfs1 */
64#define OTG_USB_ID 1
65
66/* use otgfs2 */
67/* #define OTG_USB_ID 2 */
68
69#if (OTG_USB_ID == 1)
70#define USB_ID 0
71#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
72#define OTG_IRQ OTGFS1_IRQn
73#define OTG_IRQ_HANDLER OTGFS1_IRQHandler
74#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
75#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
76#define OTG_WKUP_EXINT_LINE EXINT_LINE_18
77
78#define OTG_PIN_GPIO GPIOA
79#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
80
81#define OTG_PIN_DP GPIO_PINS_12
82#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
83
84#define OTG_PIN_DM GPIO_PINS_11
85#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
86
87#define OTG_PIN_VBUS GPIO_PINS_9
88#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
89
90#define OTG_PIN_ID GPIO_PINS_10
91#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
92
93#define OTG_PIN_SOF_GPIO GPIOA
94#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
95#define OTG_PIN_SOF GPIO_PINS_8
96#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
97
98#define OTG_PIN_MUX GPIO_MUX_10
99#endif
100
101#if (OTG_USB_ID == 2)
102#define USB_ID 1
103#define OTG_CLOCK CRM_OTGFS2_PERIPH_CLOCK
104#define OTG_IRQ OTGFS2_IRQn
105#define OTG_IRQ_HANDLER OTGFS2_IRQHandler
106#define OTG_WKUP_IRQ OTGFS2_WKUP_IRQn
107#define OTG_WKUP_HANDLER OTGFS2_WKUP_IRQHandler
108#define OTG_WKUP_EXINT_LINE EXINT_LINE_20
109
110#define OTG_PIN_GPIO GPIOB
111#define OTG_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK
112
113#define OTG_PIN_DP GPIO_PINS_15
114#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE15
115
116#define OTG_PIN_DM GPIO_PINS_14
117#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE14
118
119#define OTG_PIN_VBUS GPIO_PINS_13
120#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13
121
122#define OTG_PIN_ID GPIO_PINS_12
123#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
124
125#define OTG_PIN_SOF_GPIO GPIOA
126#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
127#define OTG_PIN_SOF GPIO_PINS_4
128#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE4
129
130#define OTG_PIN_MUX GPIO_MUX_12
131#endif
132
133
137#ifdef USE_OTG_DEVICE_MODE
141/* otg1 device fifo */
142#define USBD_RX_SIZE 128
143#define USBD_EP0_TX_SIZE 24
144#define USBD_EP1_TX_SIZE 20
145#define USBD_EP2_TX_SIZE 20
146#define USBD_EP3_TX_SIZE 20
147#define USBD_EP4_TX_SIZE 20
148#define USBD_EP5_TX_SIZE 20
149#define USBD_EP6_TX_SIZE 20
150#define USBD_EP7_TX_SIZE 20
151
152/* otg2 device fifo */
153#define USBD2_RX_SIZE 128
154#define USBD2_EP0_TX_SIZE 24
155#define USBD2_EP1_TX_SIZE 20
156#define USBD2_EP2_TX_SIZE 20
157#define USBD2_EP3_TX_SIZE 20
158#define USBD2_EP4_TX_SIZE 20
159#define USBD2_EP5_TX_SIZE 20
160#define USBD2_EP6_TX_SIZE 20
161#define USBD2_EP7_TX_SIZE 20
162
166#ifndef USB_EPT_MAX_NUM
167#define USB_EPT_MAX_NUM 8
168#endif
169#endif
170
174#ifdef USE_OTG_HOST_MODE
175#ifndef USB_HOST_CHANNEL_NUM
176#define USB_HOST_CHANNEL_NUM 16
177#endif
178
182/* otg1 host fifo */
183#define USBH_RX_FIFO_SIZE 128
184#define USBH_NP_TX_FIFO_SIZE 96
185#define USBH_P_TX_FIFO_SIZE 96
186
187/* otg2 host fifo */
188#define USBH2_RX_FIFO_SIZE 128
189#define USBH2_NP_TX_FIFO_SIZE 96
190#define USBH2_P_TX_FIFO_SIZE 96
191#endif
192
196/* #define USB_SOF_OUTPUT_ENABLE */
197
201#define USB_VBUS_IGNORE
202
206#define USB_LOW_POWER_WAKUP
207
208void usb_delay_ms(uint32_t ms);
209void usb_delay_us(uint32_t us);
210
218#ifdef __cplusplus
219}
220#endif
221
222#endif
223
at32f435_437.h
at32f435_437 header file
at32f435_437_usb.h
at32f435_437 usb header file
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c:406
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c:417


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_keyboard
  • src
Functions
project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_keyboard
  • src
project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_keyboard
  • src
Functions
project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_keyboard
  • src
project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_keyboard
  • src
Functions | Variables
project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include "usb_conf.h"
#include "usb_core.h"
#include "usbd_int.h"
#include "cdc_keyboard_class.h"
#include "cdc_keyboard_desc.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | keyboard_send_string (void *udev, uint8_t *string, uint8_t len)
keyboard send string More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
void | button_exint_init (void)
configure button exint More...
void | button_isr (void)
button handler function More...
void | EXINT0_IRQHandler (void)
exint0 interrupt handler More...
int | main (void)
main function. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

otg_core_type otg_core_struct
uint8_t | keyboard_send_flag
uint8_t | usb_buffer [256]

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_keyboard
  • src
project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include "usb_conf.h"
30#include "usb_core.h"
31#include "usbd_int.h"
32#include "cdc_keyboard_class.h"
33#include "cdc_keyboard_desc.h"
34
35
44/* usb global struct define */
45 otg_core_type otg_core_struct;
46uint8_t keyboard_send_flag;
47uint8_t usb_buffer[256];
48
49void usb_clock48m_select(usb_clk48_s clk_s);
50void keyboard_send_string(void *udev, uint8_t *string, uint8_t len);
51void usb_gpio_config(void);
52void usb_low_power_wakeup_config(void);
53void button_exint_init(void);
54void button_isr(void);
55
61void button_exint_init(void)
62{
63 exint_init_type exint_init_struct;
64
65 crm_periph_clock_enable(CRM_SCFG_PERIPH_CLOCK, TRUE);
66 scfg_exint_line_config(SCFG_PORT_SOURCE_GPIOA, SCFG_PINS_SOURCE0);
67
68 exint_default_para_init(&exint_init_struct);
69 exint_init_struct.line_enable = TRUE;
70 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
71 exint_init_struct.line_select = EXINT_LINE_0;
72 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
73 exint_init(&exint_init_struct);
74
75 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
76 nvic_irq_enable(EXINT0_IRQn, 0, 0);
77}
78
84void button_isr(void)
85{
86 /* delay 5ms */
87 delay_ms(5);
88
89 /* clear interrupt pending bit */
90 exint_flag_clear(EXINT_LINE_0);
91
92 keyboard_send_flag = 1;
93}
94
100void EXINT0_IRQHandler(void)
101{
102 button_isr();
103}
104
111void keyboard_send_string(void *udev, uint8_t *string, uint8_t len)
112{
113 uint8_t index = 0;
114 usbd_core_type *pudev = (usbd_core_type *)udev;
115 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
116 for(index = 0; index < len; index ++)
117 {
118 while(1)
119 {
120 if(vcpkybrd->g_keyboard_tx_completed == 1)
121 {
122 vcpkybrd->g_keyboard_tx_completed = 0;
123 usb_vcpkybrd_keyboard_send_char(&otg_core_struct.dev, string[index]);
124 break;
125 }
126 }
127 /* send 0x00 */
128 while(1)
129 {
130 if(vcpkybrd->g_keyboard_tx_completed == 1)
131 {
132 vcpkybrd->g_keyboard_tx_completed = 0;
133 usb_vcpkybrd_keyboard_send_char(&otg_core_struct.dev, 0x00);
134 break;
135 }
136 }
137 }
138
139}
140
141
147int main(void)
148{
149 uint16_t data_len;
150
151 uint32_t timeout;
152
153 uint8_t send_zero_packet = 0;
154
155 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
156
157 system_clock_config();
158
159 at32_board_init();
160
161 button_exint_init();
162
163 /* usb gpio config */
164 usb_gpio_config();
165
166#ifdef USB_LOW_POWER_WAKUP
167 usb_low_power_wakeup_config();
168#endif
169
170 /* enable otgfs clock */
171 crm_periph_clock_enable(OTG_CLOCK, TRUE);
172
173 /* select usb 48m clcok source */
174 usb_clock48m_select(USB_CLK_HEXT);
175
176 /* enable otgfs irq */
177 nvic_irq_enable(OTG_IRQ, 0, 0);
178
179 /* init usb */
180 usbd_init(&otg_core_struct,
181 USB_FULL_SPEED_CORE_ID,
182 USB_ID,
183 &cdc_keyboard_class_handler,
184 &cdc_keyboard_desc_handler);
185
186 while(1)
187 {
188 /* get usb vcp receive data */
189 data_len = usb_vcpkybrd_vcp_get_rxdata(&otg_core_struct.dev, usb_buffer);
190
191 if(data_len > 0 || send_zero_packet == 1)
192 {
193 /* bulk transfer is complete when the endpoint does one of the following
194 1 has transferred exactly the amount of data expected
195 2 transfers a packet with a payload size less than wMaxPacketSize or transfers a zero-length packet
196 */
197
198 if(data_len > 0)
199 send_zero_packet = 1;
200
201 if(data_len == 0)
202 send_zero_packet = 0;
203
204 timeout = 5000000;
205 do
206 {
207 /* send data to host */
208 if(usb_vcpkybrd_vcp_send_data(&otg_core_struct.dev, usb_buffer, data_len) == SUCCESS)
209 {
210 break;
211 }
212 }while(timeout --);
213 }
214 if(keyboard_send_flag)
215 {
216 keyboard_send_flag = 0;
217 keyboard_send_string(&otg_core_struct.dev, (uint8_t *)" Keyboard Demo\r\n", 16);
218 }
219
220 }
221}
222
228void usb_clock48m_select(usb_clk48_s clk_s)
229{
230 if(clk_s == USB_CLK_HICK)
231 {
232 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
233
234 /* enable the acc calibration ready interrupt */
235 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
236
237 /* update the c1\c2\c3 value */
238 acc_write_c1(7980);
239 acc_write_c2(8000);
240 acc_write_c3(8020);
241#if (USB_ID == 0)
242 acc_sof_select(ACC_SOF_OTG1);
243#else
244 acc_sof_select(ACC_SOF_OTG2);
245#endif
246 /* open acc calibration */
247 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
248 }
249 else
250 {
251 switch(system_core_clock)
252 {
253 /* 48MHz */
254 case 48000000:
255 crm_usb_clock_div_set(CRM_USB_DIV_1);
256 break;
257
258 /* 72MHz */
259 case 72000000:
260 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
261 break;
262
263 /* 96MHz */
264 case 96000000:
265 crm_usb_clock_div_set(CRM_USB_DIV_2);
266 break;
267
268 /* 120MHz */
269 case 120000000:
270 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
271 break;
272
273 /* 144MHz */
274 case 144000000:
275 crm_usb_clock_div_set(CRM_USB_DIV_3);
276 break;
277
278 /* 168MHz */
279 case 168000000:
280 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
281 break;
282
283 /* 192MHz */
284 case 192000000:
285 crm_usb_clock_div_set(CRM_USB_DIV_4);
286 break;
287
288 /* 216MHz */
289 case 216000000:
290 crm_usb_clock_div_set(CRM_USB_DIV_4_5);
291 break;
292
293 /* 240MHz */
294 case 240000000:
295 crm_usb_clock_div_set(CRM_USB_DIV_5);
296 break;
297
298 /* 264MHz */
299 case 264000000:
300 crm_usb_clock_div_set(CRM_USB_DIV_5_5);
301 break;
302
303 /* 288MHz */
304 case 288000000:
305 crm_usb_clock_div_set(CRM_USB_DIV_6);
306 break;
307
308 default:
309 break;
310
311 }
312 }
313}
314
315
321void usb_gpio_config(void)
322{
323 gpio_init_type gpio_init_struct;
324
325 crm_periph_clock_enable(OTG_PIN_GPIO_CLOCK, TRUE);
326 gpio_default_para_init(&gpio_init_struct);
327
328 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
329 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
330 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
331 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
332
333 /* dp and dm */
334 gpio_init_struct.gpio_pins = OTG_PIN_DP | OTG_PIN_DM;
335 gpio_init(OTG_PIN_GPIO, &gpio_init_struct);
336
337 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_DP_SOURCE, OTG_PIN_MUX);
338 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_DM_SOURCE, OTG_PIN_MUX);
339
340#ifdef USB_SOF_OUTPUT_ENABLE
341 crm_periph_clock_enable(OTG_PIN_SOF_GPIO_CLOCK, TRUE);
342 gpio_init_struct.gpio_pins = OTG_PIN_SOF;
343 gpio_init(OTG_PIN_SOF_GPIO, &gpio_init_struct);
344 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_SOF_SOURCE, OTG_PIN_MUX);
345#endif
346
347 /* otgfs use vbus pin */
348#ifndef USB_VBUS_IGNORE
349 gpio_init_struct.gpio_pins = OTG_PIN_VBUS;
350 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
351 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_VBUS_SOURCE, OTG_PIN_MUX);
352 gpio_init(OTG_PIN_GPIO, &gpio_init_struct);
353#endif
354
355
356}
357#ifdef USB_LOW_POWER_WAKUP
363void usb_low_power_wakeup_config(void)
364{
365 exint_init_type exint_init_struct;
366
367 crm_periph_clock_enable(CRM_SCFG_PERIPH_CLOCK, TRUE);
368 exint_default_para_init(&exint_init_struct);
369
370 exint_init_struct.line_enable = TRUE;
371 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
372 exint_init_struct.line_select = OTG_WKUP_EXINT_LINE;
373 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
374 exint_init(&exint_init_struct);
375
376 nvic_irq_enable(OTG_WKUP_IRQ, 0, 0);
377}
378
384void OTG_WKUP_HANDLER(void)
385{
386 exint_flag_clear(OTG_WKUP_EXINT_LINE);
387}
388
389#endif
390
396void OTG_IRQ_HANDLER(void)
397{
398 usbd_irq_handler(&otg_core_struct);
399}
400
406void usb_delay_ms(uint32_t ms)
407{
408 /* user can define self delay function */
409 delay_ms(ms);
410}
411
417void usb_delay_us(uint32_t us)
418{
419 delay_us(us);
420}
421
at32f435_437_board.h
cdc_keyboard_class.h
usb cdc and keyboard class file
cdc_keyboard_desc.h
usb cdc and keyboard descriptor header file
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:41
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
keyboard_send_flag
uint8_t keyboard_send_flag
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c:46
button_exint_init
void button_exint_init(void)
configure button exint
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c:61
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c:228
main
int main(void)
main function.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c:147
usb_low_power_wakeup_config
void usb_low_power_wakeup_config(void)
usb_gpio_config
void usb_gpio_config(void)
this function config gpio.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c:321
keyboard_send_string
void keyboard_send_string(void *udev, uint8_t *string, uint8_t len)
keyboard send string
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c:111
OTG_IRQ_HANDLER
void OTG_IRQ_HANDLER(void)
this function handles otgfs interrupt.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c:396
EXINT0_IRQHandler
void EXINT0_IRQHandler(void)
exint0 interrupt handler
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c:100
usb_buffer
uint8_t usb_buffer[256]
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c:47
button_isr
void button_isr(void)
button handler function
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c:84
otg_core_struct
otg_core_type otg_core_struct
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c:45
OTG_PIN_VBUS
#define OTG_PIN_VBUS
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:85
OTG_PIN_DM
#define OTG_PIN_DM
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:82
OTG_PIN_DP
#define OTG_PIN_DP
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:79
OTG_PIN_SOF
#define OTG_PIN_SOF
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:93
OTG_WKUP_IRQ
#define OTG_WKUP_IRQ
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:72
OTG_PIN_DP_SOURCE
#define OTG_PIN_DP_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:80
OTG_PIN_GPIO
#define OTG_PIN_GPIO
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:76
OTG_IRQ
#define OTG_IRQ
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:70
OTG_PIN_SOF_GPIO
#define OTG_PIN_SOF_GPIO
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:91
OTG_WKUP_HANDLER
#define OTG_WKUP_HANDLER
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:73
OTG_CLOCK
#define OTG_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:69
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb low power wakeup handler enable
Definition: project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c:304
OTG_PIN_GPIO_CLOCK
#define OTG_PIN_GPIO_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:77
OTG_PIN_SOF_SOURCE
#define OTG_PIN_SOF_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:94
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c:315
OTG_PIN_VBUS_SOURCE
#define OTG_PIN_VBUS_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:86
USB_ID
#define USB_ID
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:68
OTG_PIN_DM_SOURCE
#define OTG_PIN_DM_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:83
OTG_PIN_MUX
#define OTG_PIN_MUX
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:96
OTG_WKUP_EXINT_LINE
#define OTG_WKUP_EXINT_LINE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:74
OTG_PIN_SOF_GPIO_CLOCK
#define OTG_PIN_SOF_GPIO_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:92
data_len
uint16_t data_len
Definition: project/at_start_f435/examples/usb_device/virtual_comport/src/main.c:47
ACC_SOF_OTG2
#define ACC_SOF_OTG2
Definition: at32f435_437_acc.h:61
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f435_437_acc.h:52
ACC_SOF_OTG1
#define ACC_SOF_OTG1
Definition: at32f435_437_acc.h:60
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f435_437_acc.c:145
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f435_437_acc.c:155
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f435_437_acc.c:135
acc_sof_select
void acc_sof_select(uint16_t sof_sel)
select sof sourse for acc in acc's ctrl1 register.
Definition: at32f435_437_acc.c:84
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f435_437_acc.c:53
system_core_clock
unsigned int system_core_clock
Definition: system_at32f435_437.c:48
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f435_437_board.c:306
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type value)
set usb division
Definition: at32f435_437_crm.c:521
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f435_437_crm.c:594
CRM_SCFG_PERIPH_CLOCK
@ CRM_SCFG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:163
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:168
CRM_USB_DIV_5
@ CRM_USB_DIV_5
Definition: at32f435_437_crm.h:620
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f435_437_crm.h:616
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f435_437_crm.h:611
CRM_USB_DIV_5_5
@ CRM_USB_DIV_5_5
Definition: at32f435_437_crm.h:619
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f435_437_crm.h:618
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f435_437_crm.h:615
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f435_437_crm.h:614
CRM_USB_DIV_6
@ CRM_USB_DIV_6
Definition: at32f435_437_crm.h:622
CRM_USB_DIV_4_5
@ CRM_USB_DIV_4_5
Definition: at32f435_437_crm.h:617
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f435_437_crm.h:612
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f435_437_crm.h:613
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f435_437_crm.h:763
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f435_437_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
EXINT_LINE_0
#define EXINT_LINE_0
Definition: at32f435_437_exint.h:52
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
scfg_exint_line_config
void scfg_exint_line_config(scfg_port_source_type port_source, scfg_pins_source_type pin_source)
select the gpio pin used as exint line.
Definition: at32f435_437_scfg.c:152
SCFG_PINS_SOURCE0
@ SCFG_PINS_SOURCE0
Definition: at32f435_437_scfg.h:101
SCFG_PORT_SOURCE_GPIOA
@ SCFG_PORT_SOURCE_GPIOA
Definition: at32f435_437_scfg.h:124
usb_vcpkybrd_vcp_send_data
error_status usb_vcpkybrd_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_keyboard_class.c:610
usb_vcpkybrd_keyboard_send_char
void usb_vcpkybrd_keyboard_send_char(void *udev, uint8_t ascii_code)
usb keyoard send char
Definition: cdc_keyboard_class.c:689
cdc_keyboard_class_handler
usbd_class_handler cdc_keyboard_class_handler
Definition: cdc_keyboard_class.c:205
usb_vcpkybrd_vcp_get_rxdata
uint16_t usb_vcpkybrd_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_keyboard_class.c:580
cdc_keyboard_desc_handler
usbd_desc_handler cdc_keyboard_desc_handler
device descriptor handler structure
Definition: cdc_keyboard_desc.c:62
USB_FULL_SPEED_CORE_ID
@ USB_FULL_SPEED_CORE_ID
Definition: usb_core.h:64
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f435_437_usb.h:402
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f435_437_usb.h:404
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f435_437_usb.h:403
usbd_irq_handler
void usbd_irq_handler(otg_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
EXINT0_IRQn
@ EXINT0_IRQn
Definition: at32f435_437.h:152
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
otg_core_type
usb otg core struct type
Definition: usb_core.h:92
vcp_keyboard_type
Definition: cdc_keyboard_class.h:75
vcp_keyboard_type::g_keyboard_tx_completed
__IO uint8_t g_keyboard_tx_completed
Definition: cdc_keyboard_class.h:88
usb_core.h
usb core header file
usbd_int.h
usb interrupt header file
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_msc
  • inc
project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_msc
  • inc
project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_msc
  • inc
project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: usb_conf.h Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_msc
  • inc
project/at_start_f435/examples/usb_device/composite_vcp_msc/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f435_437_usb.h"
36#include "at32f435_437.h"
37#include "stdio.h"
38
39
52#define USE_OTG_DEVICE_MODE
53
57/* #define USE_OTG_HOST_MODE */
58
63/* use otgfs1 */
64#define OTG_USB_ID 1
65
66/* use otgfs2 */
67/* #define OTG_USB_ID 2 */
68
69#if (OTG_USB_ID == 1)
70#define USB_ID 0
71#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
72#define OTG_IRQ OTGFS1_IRQn
73#define OTG_IRQ_HANDLER OTGFS1_IRQHandler
74#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
75#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
76#define OTG_WKUP_EXINT_LINE EXINT_LINE_18
77
78#define OTG_PIN_GPIO GPIOA
79#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
80
81#define OTG_PIN_DP GPIO_PINS_12
82#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
83
84#define OTG_PIN_DM GPIO_PINS_11
85#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
86
87#define OTG_PIN_VBUS GPIO_PINS_9
88#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
89
90#define OTG_PIN_ID GPIO_PINS_10
91#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
92
93#define OTG_PIN_SOF_GPIO GPIOA
94#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
95#define OTG_PIN_SOF GPIO_PINS_8
96#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
97
98#define OTG_PIN_MUX GPIO_MUX_10
99#endif
100
101#if (OTG_USB_ID == 2)
102#define USB_ID 1
103#define OTG_CLOCK CRM_OTGFS2_PERIPH_CLOCK
104#define OTG_IRQ OTGFS2_IRQn
105#define OTG_IRQ_HANDLER OTGFS2_IRQHandler
106#define OTG_WKUP_IRQ OTGFS2_WKUP_IRQn
107#define OTG_WKUP_HANDLER OTGFS2_WKUP_IRQHandler
108#define OTG_WKUP_EXINT_LINE EXINT_LINE_20
109
110#define OTG_PIN_GPIO GPIOB
111#define OTG_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK
112
113#define OTG_PIN_DP GPIO_PINS_15
114#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE15
115
116#define OTG_PIN_DM GPIO_PINS_14
117#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE14
118
119#define OTG_PIN_VBUS GPIO_PINS_13
120#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13
121
122#define OTG_PIN_ID GPIO_PINS_12
123#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
124
125#define OTG_PIN_SOF_GPIO GPIOA
126#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
127#define OTG_PIN_SOF GPIO_PINS_4
128#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE4
129
130#define OTG_PIN_MUX GPIO_MUX_12
131#endif
132
133
137#ifdef USE_OTG_DEVICE_MODE
141/* otg1 device fifo */
142#define USBD_RX_SIZE 128
143#define USBD_EP0_TX_SIZE 24
144#define USBD_EP1_TX_SIZE 20
145#define USBD_EP2_TX_SIZE 20
146#define USBD_EP3_TX_SIZE 20
147#define USBD_EP4_TX_SIZE 20
148#define USBD_EP5_TX_SIZE 20
149#define USBD_EP6_TX_SIZE 20
150#define USBD_EP7_TX_SIZE 20
151
152/* otg2 device fifo */
153#define USBD2_RX_SIZE 128
154#define USBD2_EP0_TX_SIZE 24
155#define USBD2_EP1_TX_SIZE 20
156#define USBD2_EP2_TX_SIZE 20
157#define USBD2_EP3_TX_SIZE 20
158#define USBD2_EP4_TX_SIZE 20
159#define USBD2_EP5_TX_SIZE 20
160#define USBD2_EP6_TX_SIZE 20
161#define USBD2_EP7_TX_SIZE 20
162
166#ifndef USB_EPT_MAX_NUM
167#define USB_EPT_MAX_NUM 8
168#endif
169#endif
170
174#ifdef USE_OTG_HOST_MODE
175#ifndef USB_HOST_CHANNEL_NUM
176#define USB_HOST_CHANNEL_NUM 16
177#endif
178
182/* otg1 host fifo */
183#define USBH_RX_FIFO_SIZE 128
184#define USBH_NP_TX_FIFO_SIZE 96
185#define USBH_P_TX_FIFO_SIZE 96
186
187/* otg2 host fifo */
188#define USBH2_RX_FIFO_SIZE 128
189#define USBH2_NP_TX_FIFO_SIZE 96
190#define USBH2_P_TX_FIFO_SIZE 96
191#endif
192
196/* #define USB_SOF_OUTPUT_ENABLE */
197
201#define USB_VBUS_IGNORE
202
206#define USB_LOW_POWER_WAKUP
207
208void usb_delay_ms(uint32_t ms);
209void usb_delay_us(uint32_t us);
210
218#ifdef __cplusplus
219}
220#endif
221
222#endif
223
at32f435_437.h
at32f435_437 header file
at32f435_437_usb.h
at32f435_437 usb header file
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c:362
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c:373


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_msc
  • src
Functions
project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_msc
  • src
project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_msc
  • src
Functions
project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_msc
  • src
project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_msc/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_msc
  • src
Functions | Variables
project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include "usb_conf.h"
#include "usb_core.h"
#include "usbd_int.h"
#include "cdc_msc_class.h"
#include "cdc_msc_desc.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
void | button_exint_init (void)
configure button exint More...
void | button_isr (void)
button handler function More...
void | EXINT0_IRQHandler (void)
exint0 interrupt handler More...
int | main (void)
main function. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

otg_core_type otg_core_struct
uint8_t usb_buffer [256]

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • usb_device
  • composite_vcp_msc
  • src
project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include "usb_conf.h"
30#include "usb_core.h"
31#include "usbd_int.h"
32#include "cdc_msc_class.h"
33#include "cdc_msc_desc.h"
34
35
44/* usb global struct define */
45 otg_core_type otg_core_struct;
46uint8_t usb_buffer[256];
47
48void usb_clock48m_select(usb_clk48_s clk_s);
49void usb_gpio_config(void);
50void usb_low_power_wakeup_config(void);
51void button_exint_init(void);
52void button_isr(void);
53
59void button_exint_init(void)
60{
61 exint_init_type exint_init_struct;
62
63 crm_periph_clock_enable(CRM_SCFG_PERIPH_CLOCK, TRUE);
64 scfg_exint_line_config(SCFG_PORT_SOURCE_GPIOA, SCFG_PINS_SOURCE0);
65
66 exint_default_para_init(&exint_init_struct);
67 exint_init_struct.line_enable = TRUE;
68 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
69 exint_init_struct.line_select = EXINT_LINE_0;
70 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
71 exint_init(&exint_init_struct);
72
73 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
74 nvic_irq_enable(EXINT0_IRQn, 0, 0);
75}
76
82void button_isr(void)
83{
84 /* delay 5ms */
85 delay_ms(5);
86
87 /* clear interrupt pending bit */
88 exint_flag_clear(EXINT_LINE_0);
89}
90
96void EXINT0_IRQHandler(void)
97{
98 button_isr();
99}
100
101
102
108int main(void)
109{
110 uint16_t data_len;
111
112 uint32_t timeout;
113
114 uint8_t send_zero_packet = 0;
115
116 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
117
118 system_clock_config();
119
120 at32_board_init();
121
122 button_exint_init();
123
124 /* usb gpio config */
125 usb_gpio_config();
126
127#ifdef USB_LOW_POWER_WAKUP
128 usb_low_power_wakeup_config();
129#endif
130
131 /* enable otgfs clock */
132 crm_periph_clock_enable(OTG_CLOCK, TRUE);
133
134 /* select usb 48m clcok source */
135 usb_clock48m_select(USB_CLK_HEXT);
136
137 /* enable otgfs irq */
138 nvic_irq_enable(OTG_IRQ, 0, 0);
139
140 /* init usb */
141 usbd_init(&otg_core_struct,
142 USB_FULL_SPEED_CORE_ID,
143 USB_ID,
144 &cdc_msc_class_handler,
145 &cdc_msc_desc_handler);
146
147 while(1)
148 {
149 /* get usb vcp receive data */
150 data_len = usb_vcp_get_rxdata(&otg_core_struct.dev, usb_buffer);
151
152 if(data_len > 0 || send_zero_packet == 1)
153 {
154 /* bulk transfer is complete when the endpoint does one of the following
155 1 has transferred exactly the amount of data expected
156 2 transfers a packet with a payload size less than wMaxPacketSize or transfers a zero-length packet
157 */
158
159 if(data_len > 0)
160 send_zero_packet = 1;
161
162 if(data_len == 0)
163 send_zero_packet = 0;
164
165 timeout = 5000000;
166 do
167 {
168 /* send data to host */
169 if(usb_vcp_send_data(&otg_core_struct.dev, usb_buffer, data_len) == SUCCESS)
170 {
171 break;
172 }
173 }while(timeout --);
174 }
175
176 }
177}
178
184void usb_clock48m_select(usb_clk48_s clk_s)
185{
186 if(clk_s == USB_CLK_HICK)
187 {
188 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
189
190 /* enable the acc calibration ready interrupt */
191 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
192
193 /* update the c1\c2\c3 value */
194 acc_write_c1(7980);
195 acc_write_c2(8000);
196 acc_write_c3(8020);
197#if (USB_ID == 0)
198 acc_sof_select(ACC_SOF_OTG1);
199#else
200 acc_sof_select(ACC_SOF_OTG2);
201#endif
202 /* open acc calibration */
203 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
204 }
205 else
206 {
207 switch(system_core_clock)
208 {
209 /* 48MHz */
210 case 48000000:
211 crm_usb_clock_div_set(CRM_USB_DIV_1);
212 break;
213
214 /* 72MHz */
215 case 72000000:
216 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
217 break;
218
219 /* 96MHz */
220 case 96000000:
221 crm_usb_clock_div_set(CRM_USB_DIV_2);
222 break;
223
224 /* 120MHz */
225 case 120000000:
226 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
227 break;
228
229 /* 144MHz */
230 case 144000000:
231 crm_usb_clock_div_set(CRM_USB_DIV_3);
232 break;
233
234 /* 168MHz */
235 case 168000000:
236 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
237 break;
238
239 /* 192MHz */
240 case 192000000:
241 crm_usb_clock_div_set(CRM_USB_DIV_4);
242 break;
243
244 /* 216MHz */
245 case 216000000:
246 crm_usb_clock_div_set(CRM_USB_DIV_4_5);
247 break;
248
249 /* 240MHz */
250 case 240000000:
251 crm_usb_clock_div_set(CRM_USB_DIV_5);
252 break;
253
254 /* 264MHz */
255 case 264000000:
256 crm_usb_clock_div_set(CRM_USB_DIV_5_5);
257 break;
258
259 /* 288MHz */
260 case 288000000:
261 crm_usb_clock_div_set(CRM_USB_DIV_6);
262 break;
263
264 default:
265 break;
266
267 }
268 }
269}
270
271
277void usb_gpio_config(void)
278{
279 gpio_init_type gpio_init_struct;
280
281 crm_periph_clock_enable(OTG_PIN_GPIO_CLOCK, TRUE);
282 gpio_default_para_init(&gpio_init_struct);
283
284 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
285 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
286 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
287 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
288
289 /* dp and dm */
290 gpio_init_struct.gpio_pins = OTG_PIN_DP | OTG_PIN_DM;
291 gpio_init(OTG_PIN_GPIO, &gpio_init_struct);
292
293 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_DP_SOURCE, OTG_PIN_MUX);
294 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_DM_SOURCE, OTG_PIN_MUX);
295
296#ifdef USB_SOF_OUTPUT_ENABLE
297 crm_periph_clock_enable(OTG_PIN_SOF_GPIO_CLOCK, TRUE);
298 gpio_init_struct.gpio_pins = OTG_PIN_SOF;
299 gpio_init(OTG_PIN_SOF_GPIO, &gpio_init_struct);
300 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_SOF_SOURCE, OTG_PIN_MUX);
301#endif
302
303 /* otgfs use vbus pin */
304#ifndef USB_VBUS_IGNORE
305 gpio_init_struct.gpio_pins = OTG_PIN_VBUS;
306 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
307 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_VBUS_SOURCE, OTG_PIN_MUX);
308 gpio_init(OTG_PIN_GPIO, &gpio_init_struct);
309#endif
310
311
312}
313#ifdef USB_LOW_POWER_WAKUP
319void usb_low_power_wakeup_config(void)
320{
321 exint_init_type exint_init_struct;
322
323 crm_periph_clock_enable(CRM_SCFG_PERIPH_CLOCK, TRUE);
324 exint_default_para_init(&exint_init_struct);
325
326 exint_init_struct.line_enable = TRUE;
327 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
328 exint_init_struct.line_select = OTG_WKUP_EXINT_LINE;
329 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
330 exint_init(&exint_init_struct);
331
332 nvic_irq_enable(OTG_WKUP_IRQ, 0, 0);
333}
334
340void OTG_WKUP_HANDLER(void)
341{
342 exint_flag_clear(OTG_WKUP_EXINT_LINE);
343}
344
345#endif
346
352void OTG_IRQ_HANDLER(void)
353{
354 usbd_irq_handler(&otg_core_struct);
355}
356
362void usb_delay_ms(uint32_t ms)
363{
364 /* user can define self delay function */
365 delay_ms(ms);
366}
367
373void usb_delay_us(uint32_t us)
374{
375 delay_us(us);
376}
377
at32f435_437_board.h
cdc_msc_class.h
usb cdc class file
cdc_msc_desc.h
usb cdc descriptor header file
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:41
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
button_exint_init
void button_exint_init(void)
configure button exint
Definition: project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c:59
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c:184
main
int main(void)
main function.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c:108
usb_low_power_wakeup_config
void usb_low_power_wakeup_config(void)
usb_gpio_config
void usb_gpio_config(void)
this function config gpio.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c:277
OTG_IRQ_HANDLER
void OTG_IRQ_HANDLER(void)
this function handles otgfs interrupt.
Definition: project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c:352
EXINT0_IRQHandler
void EXINT0_IRQHandler(void)
exint0 interrupt handler
Definition: project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c:96
usb_buffer
uint8_t usb_buffer[256]
Definition: project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c:46
button_isr
void button_isr(void)
button handler function
Definition: project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c:82
otg_core_struct
otg_core_type otg_core_struct
Definition: project/at_start_f435/examples/usb_device/composite_vcp_msc/src/main.c:45
OTG_PIN_VBUS
#define OTG_PIN_VBUS
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:85
OTG_PIN_DM
#define OTG_PIN_DM
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:82
OTG_PIN_DP
#define OTG_PIN_DP
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:79
OTG_PIN_SOF
#define OTG_PIN_SOF
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:93
OTG_WKUP_IRQ
#define OTG_WKUP_IRQ
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:72
OTG_PIN_DP_SOURCE
#define OTG_PIN_DP_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:80
OTG_PIN_GPIO
#define OTG_PIN_GPIO
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:76
OTG_IRQ
#define OTG_IRQ
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:70
OTG_PIN_SOF_GPIO
#define OTG_PIN_SOF_GPIO
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:91
OTG_WKUP_HANDLER
#define OTG_WKUP_HANDLER
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:73
OTG_CLOCK
#define OTG_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:69
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb low power wakeup handler enable
Definition: project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c:304
OTG_PIN_GPIO_CLOCK
#define OTG_PIN_GPIO_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:77
OTG_PIN_SOF_SOURCE
#define OTG_PIN_SOF_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:94
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c:315
OTG_PIN_VBUS_SOURCE
#define OTG_PIN_VBUS_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:86
USB_ID
#define USB_ID
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:68
OTG_PIN_DM_SOURCE
#define OTG_PIN_DM_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:83
OTG_PIN_MUX
#define OTG_PIN_MUX
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:96
OTG_WKUP_EXINT_LINE
#define OTG_WKUP_EXINT_LINE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:74
OTG_PIN_SOF_GPIO_CLOCK
#define OTG_PIN_SOF_GPIO_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:92
data_len
uint16_t data_len
Definition: project/at_start_f435/examples/usb_device/virtual_comport/src/main.c:47
ACC_SOF_OTG2
#define ACC_SOF_OTG2
Definition: at32f435_437_acc.h:61
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f435_437_acc.h:52
ACC_SOF_OTG1
#define ACC_SOF_OTG1
Definition: at32f435_437_acc.h:60
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f435_437_acc.c:145
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f435_437_acc.c:155
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f435_437_acc.c:135
acc_sof_select
void acc_sof_select(uint16_t sof_sel)
select sof sourse for acc in acc's ctrl1 register.
Definition: at32f435_437_acc.c:84
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f435_437_acc.c:53
system_core_clock
unsigned int system_core_clock
Definition: system_at32f435_437.c:48
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f435_437_board.c:306
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type value)
set usb division
Definition: at32f435_437_crm.c:521
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f435_437_crm.c:594
CRM_SCFG_PERIPH_CLOCK
@ CRM_SCFG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:163
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:168
CRM_USB_DIV_5
@ CRM_USB_DIV_5
Definition: at32f435_437_crm.h:620
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f435_437_crm.h:616
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f435_437_crm.h:611
CRM_USB_DIV_5_5
@ CRM_USB_DIV_5_5
Definition: at32f435_437_crm.h:619
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f435_437_crm.h:618
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f435_437_crm.h:615
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f435_437_crm.h:614
CRM_USB_DIV_6
@ CRM_USB_DIV_6
Definition: at32f435_437_crm.h:622
CRM_USB_DIV_4_5
@ CRM_USB_DIV_4_5
Definition: at32f435_437_crm.h:617
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f435_437_crm.h:612
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f435_437_crm.h:613
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f435_437_crm.h:763
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f435_437_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
EXINT_LINE_0
#define EXINT_LINE_0
Definition: at32f435_437_exint.h:52
SUCCESS
@ SUCCESS
Definition: at32f435_437.h:380
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
scfg_exint_line_config
void scfg_exint_line_config(scfg_port_source_type port_source, scfg_pins_source_type pin_source)
select the gpio pin used as exint line.
Definition: at32f435_437_scfg.c:152
SCFG_PINS_SOURCE0
@ SCFG_PINS_SOURCE0
Definition: at32f435_437_scfg.h:101
SCFG_PORT_SOURCE_GPIOA
@ SCFG_PORT_SOURCE_GPIOA
Definition: at32f435_437_scfg.h:124
usb_vcp_get_rxdata
uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_class.c:339
usb_vcp_send_data
error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_class.c:369
cdc_msc_class_handler
usbd_class_handler cdc_msc_class_handler
Definition: cdc_msc_class.c:72
cdc_msc_desc_handler
usbd_desc_handler cdc_msc_desc_handler
device descriptor handler structure
Definition: cdc_msc_desc.c:66
USB_FULL_SPEED_CORE_ID
@ USB_FULL_SPEED_CORE_ID
Definition: usb_core.h:64
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f435_437_usb.h:402
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f435_437_usb.h:404
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f435_437_usb.h:403
usbd_irq_handler
void usbd_irq_handler(otg_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
EXINT0_IRQn
@ EXINT0_IRQn
Definition: at32f435_437.h:152
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
otg_core_type
usb otg core struct type
Definition: usb_core.h:92
usb_core.h
usb core header file
usbd_int.h
usb interrupt header file
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • usb_device
  • custom_hid
  • inc
project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • usb_device
  • custom_hid
  • inc
project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • usb_device
  • custom_hid
  • inc
project/at_start_f435/examples/usb_device/custom_hid/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: usb_conf.h Source File

  • at_start_f435
  • examples
  • usb_device
  • custom_hid
  • inc
project/at_start_f435/examples/usb_device/custom_hid/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f435_437_usb.h"
36#include "at32f435_437.h"
37#include "at32f435_437_board.h"
38
50#define USE_OTG_DEVICE_MODE
51
55/* #define USE_OTG_HOST_MODE */
56
61/* use otgfs1 */
62#define OTG_USB_ID 1
63
64/* use otgfs2 */
65/* #define OTG_USB_ID 2 */
66
67#if (OTG_USB_ID == 1)
68#define USB_ID 0
69#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
70#define OTG_IRQ OTGFS1_IRQn
71#define OTG_IRQ_HANDLER OTGFS1_IRQHandler
72#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
73#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
74#define OTG_WKUP_EXINT_LINE EXINT_LINE_18
75
76#define OTG_PIN_GPIO GPIOA
77#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
78
79#define OTG_PIN_DP GPIO_PINS_12
80#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
81
82#define OTG_PIN_DM GPIO_PINS_11
83#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
84
85#define OTG_PIN_VBUS GPIO_PINS_9
86#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
87
88#define OTG_PIN_ID GPIO_PINS_10
89#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
90
91#define OTG_PIN_SOF_GPIO GPIOA
92#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
93#define OTG_PIN_SOF GPIO_PINS_8
94#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
95
96#define OTG_PIN_MUX GPIO_MUX_10
97#endif
98
99#if (OTG_USB_ID == 2)
100#define USB_ID 1
101#define OTG_CLOCK CRM_OTGFS2_PERIPH_CLOCK
102#define OTG_IRQ OTGFS2_IRQn
103#define OTG_IRQ_HANDLER OTGFS2_IRQHandler
104#define OTG_WKUP_IRQ OTGFS2_WKUP_IRQn
105#define OTG_WKUP_HANDLER OTGFS2_WKUP_IRQHandler
106#define OTG_WKUP_EXINT_LINE EXINT_LINE_20
107
108#define OTG_PIN_GPIO GPIOB
109#define OTG_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK
110
111#define OTG_PIN_DP GPIO_PINS_15
112#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE15
113
114#define OTG_PIN_DM GPIO_PINS_14
115#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE14
116
117#define OTG_PIN_VBUS GPIO_PINS_13
118#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13
119
120#define OTG_PIN_ID GPIO_PINS_12
121#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
122
123#define OTG_PIN_SOF_GPIO GPIOA
124#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
125#define OTG_PIN_SOF GPIO_PINS_4
126#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE4
127
128#define OTG_PIN_MUX GPIO_MUX_12
129#endif
130
134#ifdef USE_OTG_DEVICE_MODE
138/* otg1 device fifo */
139#define USBD_RX_SIZE 128
140#define USBD_EP0_TX_SIZE 24
141#define USBD_EP1_TX_SIZE 20
142#define USBD_EP2_TX_SIZE 20
143#define USBD_EP3_TX_SIZE 20
144#define USBD_EP4_TX_SIZE 20
145#define USBD_EP5_TX_SIZE 20
146#define USBD_EP6_TX_SIZE 20
147#define USBD_EP7_TX_SIZE 20
148
149/* otg2 device fifo */
150#define USBD2_RX_SIZE 128
151#define USBD2_EP0_TX_SIZE 24
152#define USBD2_EP1_TX_SIZE 20
153#define USBD2_EP2_TX_SIZE 20
154#define USBD2_EP3_TX_SIZE 20
155#define USBD2_EP4_TX_SIZE 20
156#define USBD2_EP5_TX_SIZE 20
157#define USBD2_EP6_TX_SIZE 20
158#define USBD2_EP7_TX_SIZE 20
159
163#ifndef USB_EPT_MAX_NUM
164#define USB_EPT_MAX_NUM 8
165#endif
166#endif
167
171#ifdef USE_OTG_HOST_MODE
172#ifndef USB_HOST_CHANNEL_NUM
173#define USB_HOST_CHANNEL_NUM 16
174#endif
175
179/* otg1 host fifo */
180#define USBH_RX_FIFO_SIZE 128
181#define USBH_NP_TX_FIFO_SIZE 96
182#define USBH_P_TX_FIFO_SIZE 96
183
184/* otg2 host fifo */
185#define USBH2_RX_FIFO_SIZE 128
186#define USBH2_NP_TX_FIFO_SIZE 96
187#define USBH2_P_TX_FIFO_SIZE 96
188#endif
189
193/* #define USB_SOF_OUTPUT_ENABLE */
194
198#define USB_VBUS_IGNORE
199
203/* #define USB_LOW_POWER_WAKUP */
204
205void usb_delay_ms(uint32_t ms);
206void usb_delay_us(uint32_t us);
207
215#ifdef __cplusplus
216}
217#endif
218
219#endif
at32f435_437.h
at32f435_437 header file
at32f435_437_board.h
at32f435_437_usb.h
at32f435_437 usb header file
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb low power wakeup handler enable
Definition: project/at_start_f435/examples/usb_device/custom_hid/src/main.c:279
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f435/examples/usb_device/custom_hid/src/main.c:290


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • custom_hid
  • src
Functions
project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • usb_device
  • custom_hid
  • src
project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • custom_hid
  • src
Functions
project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • usb_device
  • custom_hid
  • src
project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/usb_device/custom_hid/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • custom_hid
  • src
Functions | Variables
project/at_start_f435/examples/usb_device/custom_hid/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include "usb_conf.h"
#include "usb_core.h"
#include "usbd_int.h"
#include "custom_hid_class.h"
#include "custom_hid_desc.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
int | main (void)
main function. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

otg_core_type otg_core_struct
uint8_t report_buf [USBD_CUSTOM_IN_MAXPACKET_SIZE]

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/custom_hid/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • usb_device
  • custom_hid
  • src
project/at_start_f435/examples/usb_device/custom_hid/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include "usb_conf.h"
30#include "usb_core.h"
31#include "usbd_int.h"
32#include "custom_hid_class.h"
33#include "custom_hid_desc.h"
34
43/* usb global struct define */
44 otg_core_type otg_core_struct;
45uint8_t report_buf[USBD_CUSTOM_IN_MAXPACKET_SIZE];
46void usb_clock48m_select(usb_clk48_s clk_s);
47void usb_gpio_config(void);
48void usb_low_power_wakeup_config(void);
49
55int main(void)
56{
57 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
58
59 system_clock_config();
60
61 at32_board_init();
62
63 /* usb gpio config */
64 usb_gpio_config();
65
66#ifdef USB_LOW_POWER_WAKUP
67 usb_low_power_wakeup_config();
68#endif
69
70 /* enable otgfs clock */
71 crm_periph_clock_enable(OTG_CLOCK, TRUE);
72
73 /* select usb 48m clcok source */
74 usb_clock48m_select(USB_CLK_HEXT);
75
76 /* enable otgfs irq */
77 nvic_irq_enable(OTG_IRQ, 0, 0);
78
79 /* init usb */
80 usbd_init(&otg_core_struct,
81 USB_FULL_SPEED_CORE_ID,
82 USB_ID,
83 &custom_hid_class_handler,
84 &custom_hid_desc_handler);
85
86 while(1)
87 {
88 if(at32_button_press() == USER_BUTTON)
89 {
90 report_buf[0] = HID_REPORT_ID_5;
91 report_buf[1] = (~report_buf[1]) & 0x1;
92 custom_hid_class_send_report(&otg_core_struct.dev, report_buf, USBD_CUSTOM_IN_MAXPACKET_SIZE);
93 }
94 }
95}
96
102void usb_clock48m_select(usb_clk48_s clk_s)
103{
104 if(clk_s == USB_CLK_HICK)
105 {
106 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
107
108 /* enable the acc calibration ready interrupt */
109 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
110
111 /* update the c1\c2\c3 value */
112 acc_write_c1(7980);
113 acc_write_c2(8000);
114 acc_write_c3(8020);
115#if (USB_ID == 0)
116 acc_sof_select(ACC_SOF_OTG1);
117#else
118 acc_sof_select(ACC_SOF_OTG2);
119#endif
120 /* open acc calibration */
121 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
122 }
123 else
124 {
125 switch(system_core_clock)
126 {
127 /* 48MHz */
128 case 48000000:
129 crm_usb_clock_div_set(CRM_USB_DIV_1);
130 break;
131
132 /* 72MHz */
133 case 72000000:
134 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
135 break;
136
137 /* 96MHz */
138 case 96000000:
139 crm_usb_clock_div_set(CRM_USB_DIV_2);
140 break;
141
142 /* 120MHz */
143 case 120000000:
144 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
145 break;
146
147 /* 144MHz */
148 case 144000000:
149 crm_usb_clock_div_set(CRM_USB_DIV_3);
150 break;
151
152 /* 168MHz */
153 case 168000000:
154 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
155 break;
156
157 /* 192MHz */
158 case 192000000:
159 crm_usb_clock_div_set(CRM_USB_DIV_4);
160 break;
161
162 /* 216MHz */
163 case 216000000:
164 crm_usb_clock_div_set(CRM_USB_DIV_4_5);
165 break;
166
167 /* 240MHz */
168 case 240000000:
169 crm_usb_clock_div_set(CRM_USB_DIV_5);
170 break;
171
172 /* 264MHz */
173 case 264000000:
174 crm_usb_clock_div_set(CRM_USB_DIV_5_5);
175 break;
176
177 /* 288MHz */
178 case 288000000:
179 crm_usb_clock_div_set(CRM_USB_DIV_6);
180 break;
181
182 default:
183 break;
184
185 }
186 }
187}
188
194void usb_gpio_config(void)
195{
196 gpio_init_type gpio_init_struct;
197
198 crm_periph_clock_enable(OTG_PIN_GPIO_CLOCK, TRUE);
199 gpio_default_para_init(&gpio_init_struct);
200
201 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
202 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
203 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
204 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
205
206 /* dp and dm */
207 gpio_init_struct.gpio_pins = OTG_PIN_DP | OTG_PIN_DM;
208 gpio_init(OTG_PIN_GPIO, &gpio_init_struct);
209
210 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_DP_SOURCE, OTG_PIN_MUX);
211 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_DM_SOURCE, OTG_PIN_MUX);
212
213#ifdef USB_SOF_OUTPUT_ENABLE
214 crm_periph_clock_enable(OTG_PIN_SOF_GPIO_CLOCK, TRUE);
215 gpio_init_struct.gpio_pins = OTG_PIN_SOF;
216 gpio_init(OTG_PIN_SOF_GPIO, &gpio_init_struct);
217 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_SOF_SOURCE, OTG_PIN_MUX);
218#endif
219
220 /* otgfs use vbus pin */
221#ifndef USB_VBUS_IGNORE
222 gpio_init_struct.gpio_pins = OTG_PIN_VBUS;
223 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
224 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_VBUS_SOURCE, OTG_PIN_MUX);
225 gpio_init(OTG_PIN_GPIO, &gpio_init_struct);
226#endif
227
228
229}
230#ifdef USB_LOW_POWER_WAKUP
236void usb_low_power_wakeup_config(void)
237{
238 exint_init_type exint_init_struct;
239
240 crm_periph_clock_enable(CRM_SCFG_PERIPH_CLOCK, TRUE);
241 exint_default_para_init(&exint_init_struct);
242
243 exint_init_struct.line_enable = TRUE;
244 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
245 exint_init_struct.line_select = OTG_WKUP_EXINT_LINE;
246 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
247 exint_init(&exint_init_struct);
248
249 nvic_irq_enable(OTG_WKUP_IRQ, 0, 0);
250}
251
257void OTG_WKUP_HANDLER(void)
258{
259 exint_flag_clear(OTG_WKUP_EXINT_LINE);
260}
261
262#endif
263
269void OTG_IRQ_HANDLER(void)
270{
271 usbd_irq_handler(&otg_core_struct);
272}
273
279void usb_delay_ms(uint32_t ms)
280{
281 /* user can define self delay function */
282 delay_ms(ms);
283}
284
290void usb_delay_us(uint32_t us)
291{
292 delay_us(us);
293}
at32f435_437_board.h
custom_hid_class.h
usb hid header file
custom_hid_desc.h
usb custom hid descriptor header file
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:41
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
report_buf
uint8_t report_buf[USBD_CUSTOM_IN_MAXPACKET_SIZE]
Definition: project/at_start_f435/examples/usb_device/custom_hid/src/main.c:45
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f435/examples/usb_device/custom_hid/src/main.c:102
main
int main(void)
main function.
Definition: project/at_start_f435/examples/usb_device/custom_hid/src/main.c:55
usb_low_power_wakeup_config
void usb_low_power_wakeup_config(void)
usb_gpio_config
void usb_gpio_config(void)
this function config gpio.
Definition: project/at_start_f435/examples/usb_device/custom_hid/src/main.c:194
OTG_IRQ_HANDLER
void OTG_IRQ_HANDLER(void)
this function handles otgfs interrupt.
Definition: project/at_start_f435/examples/usb_device/custom_hid/src/main.c:269
otg_core_struct
otg_core_type otg_core_struct
Definition: project/at_start_f435/examples/usb_device/custom_hid/src/main.c:44
OTG_PIN_VBUS
#define OTG_PIN_VBUS
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:85
OTG_PIN_DM
#define OTG_PIN_DM
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:82
OTG_PIN_DP
#define OTG_PIN_DP
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:79
OTG_PIN_SOF
#define OTG_PIN_SOF
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:93
OTG_WKUP_IRQ
#define OTG_WKUP_IRQ
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:72
OTG_PIN_DP_SOURCE
#define OTG_PIN_DP_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:80
OTG_PIN_GPIO
#define OTG_PIN_GPIO
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:76
OTG_IRQ
#define OTG_IRQ
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:70
OTG_PIN_SOF_GPIO
#define OTG_PIN_SOF_GPIO
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:91
OTG_WKUP_HANDLER
#define OTG_WKUP_HANDLER
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:73
OTG_CLOCK
#define OTG_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:69
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb low power wakeup handler enable
Definition: project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c:304
OTG_PIN_GPIO_CLOCK
#define OTG_PIN_GPIO_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:77
OTG_PIN_SOF_SOURCE
#define OTG_PIN_SOF_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:94
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c:315
OTG_PIN_VBUS_SOURCE
#define OTG_PIN_VBUS_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:86
USB_ID
#define USB_ID
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:68
OTG_PIN_DM_SOURCE
#define OTG_PIN_DM_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:83
OTG_PIN_MUX
#define OTG_PIN_MUX
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:96
OTG_WKUP_EXINT_LINE
#define OTG_WKUP_EXINT_LINE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:74
OTG_PIN_SOF_GPIO_CLOCK
#define OTG_PIN_SOF_GPIO_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:92
ACC_SOF_OTG2
#define ACC_SOF_OTG2
Definition: at32f435_437_acc.h:61
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f435_437_acc.h:52
ACC_SOF_OTG1
#define ACC_SOF_OTG1
Definition: at32f435_437_acc.h:60
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f435_437_acc.c:145
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f435_437_acc.c:155
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f435_437_acc.c:135
acc_sof_select
void acc_sof_select(uint16_t sof_sel)
select sof sourse for acc in acc's ctrl1 register.
Definition: at32f435_437_acc.c:84
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f435_437_acc.c:53
system_core_clock
unsigned int system_core_clock
Definition: system_at32f435_437.c:48
USER_BUTTON
@ USER_BUTTON
Definition: at32f435_437_board.h:98
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f435_437_board.c:194
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f435_437_board.c:306
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type value)
set usb division
Definition: at32f435_437_crm.c:521
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f435_437_crm.c:594
CRM_SCFG_PERIPH_CLOCK
@ CRM_SCFG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:163
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:168
CRM_USB_DIV_5
@ CRM_USB_DIV_5
Definition: at32f435_437_crm.h:620
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f435_437_crm.h:616
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f435_437_crm.h:611
CRM_USB_DIV_5_5
@ CRM_USB_DIV_5_5
Definition: at32f435_437_crm.h:619
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f435_437_crm.h:618
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f435_437_crm.h:615
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f435_437_crm.h:614
CRM_USB_DIV_6
@ CRM_USB_DIV_6
Definition: at32f435_437_crm.h:622
CRM_USB_DIV_4_5
@ CRM_USB_DIV_4_5
Definition: at32f435_437_crm.h:617
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f435_437_crm.h:612
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f435_437_crm.h:613
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f435_437_crm.h:763
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f435_437_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
HID_REPORT_ID_5
#define HID_REPORT_ID_5
Definition: audio_hid_desc.h:226
USB_FULL_SPEED_CORE_ID
@ USB_FULL_SPEED_CORE_ID
Definition: usb_core.h:64
USBD_CUSTOM_IN_MAXPACKET_SIZE
#define USBD_CUSTOM_IN_MAXPACKET_SIZE
usb custom hid in and out max packet size define
Definition: custom_hid_class.h:59
custom_hid_class_send_report
usb_sts_type custom_hid_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: custom_hid_class.c:316
custom_hid_class_handler
usbd_class_handler custom_hid_class_handler
Definition: custom_hid_class.c:57
custom_hid_desc_handler
usbd_desc_handler custom_hid_desc_handler
custom hid device descriptor handler structure
Definition: custom_hid_desc.c:62
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f435_437_usb.h:402
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f435_437_usb.h:404
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f435_437_usb.h:403
usbd_irq_handler
void usbd_irq_handler(otg_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
otg_core_type
usb otg core struct type
Definition: usb_core.h:92
usb_core.h
usb core header file
usbd_int.h
usb interrupt header file
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • usb_device
  • keyboard
  • inc
project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • usb_device
  • keyboard
  • inc
project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • usb_device
  • keyboard
  • inc
project/at_start_f435/examples/usb_device/keyboard/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: usb_conf.h Source File

  • at_start_f435
  • examples
  • usb_device
  • keyboard
  • inc
project/at_start_f435/examples/usb_device/keyboard/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f435_437_usb.h"
36#include "at32f435_437.h"
37#include "stdio.h"
38
39
52#define USE_OTG_DEVICE_MODE
53
57/* #define USE_OTG_HOST_MODE */
58
63/* use otgfs1 */
64#define OTG_USB_ID 1
65
66/* use otgfs2 */
67/* #define OTG_USB_ID 2 */
68#if (OTG_USB_ID == 1)
69#define USB_ID 0
70#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
71#define OTG_IRQ OTGFS1_IRQn
72#define OTG_IRQ_HANDLER OTGFS1_IRQHandler
73#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
74#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
75#define OTG_WKUP_EXINT_LINE EXINT_LINE_18
76
77#define OTG_PIN_GPIO GPIOA
78#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
79
80#define OTG_PIN_DP GPIO_PINS_12
81#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
82
83#define OTG_PIN_DM GPIO_PINS_11
84#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
85
86#define OTG_PIN_VBUS GPIO_PINS_9
87#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
88
89#define OTG_PIN_ID GPIO_PINS_10
90#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
91
92#define OTG_PIN_SOF_GPIO GPIOA
93#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
94#define OTG_PIN_SOF GPIO_PINS_8
95#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
96
97#define OTG_PIN_MUX GPIO_MUX_10
98#endif
99
100#if (OTG_USB_ID == 2)
101#define USB_ID 1
102#define OTG_CLOCK CRM_OTGFS2_PERIPH_CLOCK
103#define OTG_IRQ OTGFS2_IRQn
104#define OTG_IRQ_HANDLER OTGFS2_IRQHandler
105#define OTG_WKUP_IRQ OTGFS2_WKUP_IRQn
106#define OTG_WKUP_HANDLER OTGFS2_WKUP_IRQHandler
107#define OTG_WKUP_EXINT_LINE EXINT_LINE_20
108
109#define OTG_PIN_GPIO GPIOB
110#define OTG_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK
111
112#define OTG_PIN_DP GPIO_PINS_15
113#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE15
114
115#define OTG_PIN_DM GPIO_PINS_14
116#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE14
117
118#define OTG_PIN_VBUS GPIO_PINS_13
119#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13
120
121#define OTG_PIN_ID GPIO_PINS_12
122#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
123
124#define OTG_PIN_SOF_GPIO GPIOA
125#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
126#define OTG_PIN_SOF GPIO_PINS_4
127#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE4
128
129#define OTG_PIN_MUX GPIO_MUX_12
130#endif
131
135#ifdef USE_OTG_DEVICE_MODE
139/* otg1 device fifo */
140#define USBD_RX_SIZE 128
141#define USBD_EP0_TX_SIZE 24
142#define USBD_EP1_TX_SIZE 20
143#define USBD_EP2_TX_SIZE 20
144#define USBD_EP3_TX_SIZE 20
145#define USBD_EP4_TX_SIZE 20
146#define USBD_EP5_TX_SIZE 20
147#define USBD_EP6_TX_SIZE 20
148#define USBD_EP7_TX_SIZE 20
149
150/* otg2 device fifo */
151#define USBD2_RX_SIZE 128
152#define USBD2_EP0_TX_SIZE 24
153#define USBD2_EP1_TX_SIZE 20
154#define USBD2_EP2_TX_SIZE 20
155#define USBD2_EP3_TX_SIZE 20
156#define USBD2_EP4_TX_SIZE 20
157#define USBD2_EP5_TX_SIZE 20
158#define USBD2_EP6_TX_SIZE 20
159#define USBD2_EP7_TX_SIZE 20
160
164#ifndef USB_EPT_MAX_NUM
165#define USB_EPT_MAX_NUM 8
166#endif
167#endif
168
172#ifdef USE_OTG_HOST_MODE
173#ifndef USB_HOST_CHANNEL_NUM
174#define USB_HOST_CHANNEL_NUM 16
175#endif
176
180/* otg1 host fifo */
181#define USBH_RX_FIFO_SIZE 128
182#define USBH_NP_TX_FIFO_SIZE 96
183#define USBH_P_TX_FIFO_SIZE 96
184
185/* otg2 host fifo */
186#define USBH2_RX_FIFO_SIZE 128
187#define USBH2_NP_TX_FIFO_SIZE 96
188#define USBH2_P_TX_FIFO_SIZE 96
189#endif
190
194/* #define USB_SOF_OUTPUT_ENABLE */
195
199#define USB_VBUS_IGNORE
200
204//#define USB_LOW_POWER_WAKUP
205
206void usb_delay_ms(uint32_t ms);
207void usb_delay_us(uint32_t us);
208
216#ifdef __cplusplus
217}
218#endif
219
220#endif
221
at32f435_437.h
at32f435_437 header file
at32f435_437_usb.h
at32f435_437 usb header file
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb low power wakeup handler enable
Definition: project/at_start_f435/examples/usb_device/keyboard/src/main.c:421
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f435/examples/usb_device/keyboard/src/main.c:432


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • keyboard
  • src
Functions
project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • usb_device
  • keyboard
  • src
project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • keyboard
  • src
Functions
project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • usb_device
  • keyboard
  • src
project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/usb_device/keyboard/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • keyboard
  • src
Functions | Variables
project/at_start_f435/examples/usb_device/keyboard/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include "usb_conf.h"
#include "usb_core.h"
#include "usbd_int.h"
#include "keyboard_class.h"
#include "keyboard_desc.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | keyboard_send_string (void *udev, uint8_t *string, uint8_t len)
keyboard send string More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
void | system_clock_recover (void)
system clock recover. More...
void | button_exint_init (void)
configure button exint More...
int | main (void)
main function. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

otg_core_type otg_core_struct
__IO uint8_t hid_suspend_flag

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/keyboard/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • usb_device
  • keyboard
  • src
project/at_start_f435/examples/usb_device/keyboard/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include "usb_conf.h"
30#include "usb_core.h"
31#include "usbd_int.h"
32#include "keyboard_class.h"
33#include "keyboard_desc.h"
34
35
44/* usb global struct define */
45 otg_core_type otg_core_struct;
46extern __IO uint8_t hid_suspend_flag;
47void usb_clock48m_select(usb_clk48_s clk_s);
48void keyboard_send_string(void *udev, uint8_t *string, uint8_t len);
49void usb_gpio_config(void);
50void usb_low_power_wakeup_config(void);
51void system_clock_recover(void);
52void button_exint_init(void);
53
60void keyboard_send_string(void *udev, uint8_t *string, uint8_t len)
61{
62 uint8_t index = 0;
63 usbd_core_type *pudev = (usbd_core_type *)udev;
64 keyboard_type *pkeyboard = (keyboard_type *)pudev->class_handler->pdata;
65 for(index = 0; index < len; index ++)
66 {
67 while(1)
68 {
69 if(pkeyboard->g_u8tx_completed == 1)
70 {
71 pkeyboard->g_u8tx_completed = 0;
72 usb_hid_keyboard_send_char(udev, string[index]);
73 break;
74 }
75 }
76 /* send 0x00 */
77 while(1)
78 {
79 if(pkeyboard->g_u8tx_completed == 1)
80 {
81 pkeyboard->g_u8tx_completed = 0;
82 usb_hid_keyboard_send_char(udev, 0x00);
83 break;
84 }
85 }
86 }
87
88}
89
90
96int main(void)
97{
98 __IO uint32_t delay_index = 0;
99 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
100
101 system_clock_config();
102
103 at32_board_init();
104
105 /* usb gpio config */
106 usb_gpio_config();
107
108#ifdef USB_LOW_POWER_WAKUP
109 /* enable pwc and bpr clock */
110 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
111 button_exint_init();
112 usb_low_power_wakeup_config();
113#endif
114
115 /* enable otgfs clock */
116 crm_periph_clock_enable(OTG_CLOCK, TRUE);
117
118 /* select usb 48m clcok source */
119 usb_clock48m_select(USB_CLK_HEXT);
120
121 /* enable otgfs irq */
122 nvic_irq_enable(OTG_IRQ, 0, 0);
123
124 /* init usb */
125 usbd_init(&otg_core_struct,
126 USB_FULL_SPEED_CORE_ID,
127 USB_ID,
128 &keyboard_class_handler,
129 &keyboard_desc_handler);
130 at32_led_on(LED2);
131 at32_led_on(LED3);
132 at32_led_on(LED4);
133 while(1)
134 {
135 if(at32_button_press() == USER_BUTTON)
136 {
137 if(usbd_connect_state_get(&otg_core_struct.dev) == USB_CONN_STATE_CONFIGURED)
138 {
139 keyboard_send_string(&otg_core_struct.dev, (uint8_t *)" Keyboard Demo\r\n", 16);
140 }
141 /* remote wakeup */
142 if(usbd_connect_state_get(&otg_core_struct.dev) == USB_CONN_STATE_SUSPENDED
143 && (otg_core_struct.dev.remote_wakup == 1))
144 {
145 usbd_remote_wakeup(&otg_core_struct.dev);
146 }
147 }
148
149#ifdef USB_LOW_POWER_WAKUP
150 /* enter deep sleep */
151 if(((keyboard_type *)(otg_core_struct.dev.class_handler->pdata))->hid_suspend_flag == 1)
152 {
153 at32_led_off(LED2);
154 at32_led_off(LED3);
155 at32_led_off(LED4);
156 /* congfig the voltage regulator mode */
157 pwc_voltage_regulate_set(PWC_REGULATOR_LOW_POWER);
158
159 /* enter deep sleep mode */
160 pwc_deep_sleep_mode_enter(PWC_DEEP_SLEEP_ENTER_WFI);
161 /* wait clock stable */
162 for(delay_index = 0; delay_index < 600; delay_index++)
163 {
164 __NOP();
165 }
166 system_clock_recover();
167 ((keyboard_type *)(otg_core_struct.dev.class_handler->pdata))->hid_suspend_flag = 0;
168 at32_led_on(LED2);
169 at32_led_on(LED3);
170 at32_led_on(LED4);
171 }
172 #endif
173
174 }
175}
176
182void usb_clock48m_select(usb_clk48_s clk_s)
183{
184 if(clk_s == USB_CLK_HICK)
185 {
186 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
187
188 /* enable the acc calibration ready interrupt */
189 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
190
191 /* update the c1\c2\c3 value */
192 acc_write_c1(7980);
193 acc_write_c2(8000);
194 acc_write_c3(8020);
195#if (USB_ID == 0)
196 acc_sof_select(ACC_SOF_OTG1);
197#else
198 acc_sof_select(ACC_SOF_OTG2);
199#endif
200 /* open acc calibration */
201 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
202 }
203 else
204 {
205 switch(system_core_clock)
206 {
207 /* 48MHz */
208 case 48000000:
209 crm_usb_clock_div_set(CRM_USB_DIV_1);
210 break;
211
212 /* 72MHz */
213 case 72000000:
214 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
215 break;
216
217 /* 96MHz */
218 case 96000000:
219 crm_usb_clock_div_set(CRM_USB_DIV_2);
220 break;
221
222 /* 120MHz */
223 case 120000000:
224 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
225 break;
226
227 /* 144MHz */
228 case 144000000:
229 crm_usb_clock_div_set(CRM_USB_DIV_3);
230 break;
231
232 /* 168MHz */
233 case 168000000:
234 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
235 break;
236
237 /* 192MHz */
238 case 192000000:
239 crm_usb_clock_div_set(CRM_USB_DIV_4);
240 break;
241
242 /* 216MHz */
243 case 216000000:
244 crm_usb_clock_div_set(CRM_USB_DIV_4_5);
245 break;
246
247 /* 240MHz */
248 case 240000000:
249 crm_usb_clock_div_set(CRM_USB_DIV_5);
250 break;
251
252 /* 264MHz */
253 case 264000000:
254 crm_usb_clock_div_set(CRM_USB_DIV_5_5);
255 break;
256
257 /* 288MHz */
258 case 288000000:
259 crm_usb_clock_div_set(CRM_USB_DIV_6);
260 break;
261
262 default:
263 break;
264
265 }
266 }
267}
268
274void usb_gpio_config(void)
275{
276 gpio_init_type gpio_init_struct;
277
278 crm_periph_clock_enable(OTG_PIN_GPIO_CLOCK, TRUE);
279 gpio_default_para_init(&gpio_init_struct);
280
281 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
282 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
283 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
284 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
285
286 /* dp and dm */
287 gpio_init_struct.gpio_pins = OTG_PIN_DP | OTG_PIN_DM;
288 gpio_init(OTG_PIN_GPIO, &gpio_init_struct);
289
290 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_DP_SOURCE, OTG_PIN_MUX);
291 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_DM_SOURCE, OTG_PIN_MUX);
292
293#ifdef USB_SOF_OUTPUT_ENABLE
294 crm_periph_clock_enable(OTG_PIN_SOF_GPIO_CLOCK, TRUE);
295 gpio_init_struct.gpio_pins = OTG_PIN_SOF;
296 gpio_init(OTG_PIN_SOF_GPIO, &gpio_init_struct);
297 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_SOF_SOURCE, OTG_PIN_MUX);
298#endif
299
300 /* otgfs use vbus pin */
301#ifndef USB_VBUS_IGNORE
302 gpio_init_struct.gpio_pins = OTG_PIN_VBUS;
303 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
304 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_VBUS_SOURCE, OTG_PIN_MUX);
305 gpio_init(OTG_PIN_GPIO, &gpio_init_struct);
306#endif
307
308
309}
310#ifdef USB_LOW_POWER_WAKUP
316void usb_low_power_wakeup_config(void)
317{
318 exint_init_type exint_init_struct;
319
320 crm_periph_clock_enable(CRM_SCFG_PERIPH_CLOCK, TRUE);
321 exint_default_para_init(&exint_init_struct);
322
323 exint_init_struct.line_enable = TRUE;
324 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
325 exint_init_struct.line_select = OTG_WKUP_EXINT_LINE;
326 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
327 exint_init(&exint_init_struct);
328
329 nvic_irq_enable(OTG_WKUP_IRQ, 0, 0);
330}
331
337void system_clock_recover(void)
338{
339 /* enable external high-speed crystal oscillator - hext */
340 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
341
342 /* wait till hext is ready */
343 while(crm_hext_stable_wait() == ERROR);
344
345 /* enable pll */
346 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
347
348 /* wait till pll is ready */
349 while(crm_flag_get(CRM_PLL_STABLE_FLAG) == RESET);
350
351 /* enable auto step mode */
352 crm_auto_step_mode_enable(TRUE);
353
354 /* select pll as system clock source */
355 crm_sysclk_switch(CRM_SCLK_PLL);
356
357 /* wait till pll is used as system clock source */
358 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL);
359}
360
366void button_exint_init(void)
367{
368 exint_init_type exint_init_struct;
369
370 crm_periph_clock_enable(CRM_SCFG_PERIPH_CLOCK, TRUE);
371 scfg_exint_line_config(SCFG_PORT_SOURCE_GPIOA, SCFG_PINS_SOURCE0);
372
373 exint_default_para_init(&exint_init_struct);
374 exint_init_struct.line_enable = TRUE;
375 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
376 exint_init_struct.line_select = EXINT_LINE_0;
377 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
378 exint_init(&exint_init_struct);
379
380 nvic_irq_enable(EXINT0_IRQn, 0, 0);
381}
382
388void OTG_WKUP_HANDLER(void)
389{
390 exint_flag_clear(OTG_WKUP_EXINT_LINE);
391}
392
398void EXINT0_IRQHandler(void)
399{
400 exint_flag_clear(EXINT_LINE_0);
401}
402
403
404#endif
405
411void OTG_IRQ_HANDLER(void)
412{
413 usbd_irq_handler(&otg_core_struct);
414}
415
421void usb_delay_ms(uint32_t ms)
422{
423 /* user can define self delay function */
424 delay_ms(ms);
425}
426
432void usb_delay_us(uint32_t us)
433{
434 delay_us(us);
435}
436
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:41
EXINT0_IRQHandler
void EXINT0_IRQHandler(void)
exint0 interrupt handler
Definition: project/at_start_f435/examples/exint/exint_config/src/main.c:70
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
hid_suspend_flag
__IO uint8_t hid_suspend_flag
button_exint_init
void button_exint_init(void)
configure button exint
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c:61
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f435/examples/usb_device/keyboard/src/main.c:182
main
int main(void)
main function.
Definition: project/at_start_f435/examples/usb_device/keyboard/src/main.c:96
usb_low_power_wakeup_config
void usb_low_power_wakeup_config(void)
usb_gpio_config
void usb_gpio_config(void)
this function config gpio.
Definition: project/at_start_f435/examples/usb_device/keyboard/src/main.c:274
keyboard_send_string
void keyboard_send_string(void *udev, uint8_t *string, uint8_t len)
keyboard send string
Definition: project/at_start_f435/examples/usb_device/keyboard/src/main.c:60
OTG_IRQ_HANDLER
void OTG_IRQ_HANDLER(void)
this function handles otgfs interrupt.
Definition: project/at_start_f435/examples/usb_device/keyboard/src/main.c:411
otg_core_struct
otg_core_type otg_core_struct
Definition: project/at_start_f435/examples/usb_device/keyboard/src/main.c:45
system_clock_recover
void system_clock_recover(void)
system clock recover.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c:141
OTG_PIN_VBUS
#define OTG_PIN_VBUS
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:85
OTG_PIN_DM
#define OTG_PIN_DM
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:82
OTG_PIN_DP
#define OTG_PIN_DP
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:79
OTG_PIN_SOF
#define OTG_PIN_SOF
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:93
OTG_WKUP_IRQ
#define OTG_WKUP_IRQ
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:72
OTG_PIN_DP_SOURCE
#define OTG_PIN_DP_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:80
OTG_PIN_GPIO
#define OTG_PIN_GPIO
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:76
OTG_IRQ
#define OTG_IRQ
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:70
OTG_PIN_SOF_GPIO
#define OTG_PIN_SOF_GPIO
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:91
OTG_WKUP_HANDLER
#define OTG_WKUP_HANDLER
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:73
OTG_CLOCK
#define OTG_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:69
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb low power wakeup handler enable
Definition: project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c:304
OTG_PIN_GPIO_CLOCK
#define OTG_PIN_GPIO_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:77
OTG_PIN_SOF_SOURCE
#define OTG_PIN_SOF_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:94
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c:315
OTG_PIN_VBUS_SOURCE
#define OTG_PIN_VBUS_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:86
USB_ID
#define USB_ID
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:68
OTG_PIN_DM_SOURCE
#define OTG_PIN_DM_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:83
OTG_PIN_MUX
#define OTG_PIN_MUX
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:96
OTG_WKUP_EXINT_LINE
#define OTG_WKUP_EXINT_LINE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:74
OTG_PIN_SOF_GPIO_CLOCK
#define OTG_PIN_SOF_GPIO_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:92
ACC_SOF_OTG2
#define ACC_SOF_OTG2
Definition: at32f435_437_acc.h:61
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f435_437_acc.h:52
ACC_SOF_OTG1
#define ACC_SOF_OTG1
Definition: at32f435_437_acc.h:60
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f435_437_acc.c:145
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f435_437_acc.c:155
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f435_437_acc.c:135
acc_sof_select
void acc_sof_select(uint16_t sof_sel)
select sof sourse for acc in acc's ctrl1 register.
Definition: at32f435_437_acc.c:84
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f435_437_acc.c:53
system_core_clock
unsigned int system_core_clock
Definition: system_at32f435_437.c:48
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
USER_BUTTON
@ USER_BUTTON
Definition: at32f435_437_board.h:98
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f435_437_board.c:194
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f435_437_board.c:306
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type value)
set usb division
Definition: at32f435_437_crm.c:521
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f435_437_crm.c:594
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_SCFG_PERIPH_CLOCK
@ CRM_SCFG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:163
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:168
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_USB_DIV_5
@ CRM_USB_DIV_5
Definition: at32f435_437_crm.h:620
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f435_437_crm.h:616
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f435_437_crm.h:611
CRM_USB_DIV_5_5
@ CRM_USB_DIV_5_5
Definition: at32f435_437_crm.h:619
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f435_437_crm.h:618
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f435_437_crm.h:615
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f435_437_crm.h:614
CRM_USB_DIV_6
@ CRM_USB_DIV_6
Definition: at32f435_437_crm.h:622
CRM_USB_DIV_4_5
@ CRM_USB_DIV_4_5
Definition: at32f435_437_crm.h:617
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f435_437_crm.h:612
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f435_437_crm.h:613
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f435_437_crm.h:763
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f435_437_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
EXINT_LINE_0
#define EXINT_LINE_0
Definition: at32f435_437_exint.h:52
ERROR
@ ERROR
Definition: at32f435_437.h:380
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
pwc_voltage_regulate_set
void pwc_voltage_regulate_set(pwc_regulator_type pwc_regulator)
regulate low power consumption in the deep sleep mode
Definition: at32f435_437_pwc.c:214
pwc_deep_sleep_mode_enter
void pwc_deep_sleep_mode_enter(pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode
Definition: at32f435_437_pwc.c:190
PWC_REGULATOR_LOW_POWER
@ PWC_REGULATOR_LOW_POWER
Definition: at32f435_437_pwc.h:130
PWC_DEEP_SLEEP_ENTER_WFI
@ PWC_DEEP_SLEEP_ENTER_WFI
Definition: at32f435_437_pwc.h:120
scfg_exint_line_config
void scfg_exint_line_config(scfg_port_source_type port_source, scfg_pins_source_type pin_source)
select the gpio pin used as exint line.
Definition: at32f435_437_scfg.c:152
SCFG_PINS_SOURCE0
@ SCFG_PINS_SOURCE0
Definition: at32f435_437_scfg.h:101
SCFG_PORT_SOURCE_GPIOA
@ SCFG_PORT_SOURCE_GPIOA
Definition: at32f435_437_scfg.h:124
USB_FULL_SPEED_CORE_ID
@ USB_FULL_SPEED_CORE_ID
Definition: usb_core.h:64
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f435_437_usb.h:402
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f435_437_usb.h:404
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f435_437_usb.h:403
usb_hid_keyboard_send_char
void usb_hid_keyboard_send_char(void *udev, uint8_t ascii_code)
usb device class report function
Definition: keyboard_class.c:453
keyboard_class_handler
usbd_class_handler keyboard_class_handler
Definition: keyboard_class.c:189
keyboard_desc_handler
usbd_desc_handler keyboard_desc_handler
keyboard device descriptor handler structure
Definition: keyboard_desc.c:63
USB_CONN_STATE_SUSPENDED
@ USB_CONN_STATE_SUSPENDED
Definition: usb_std.h:132
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:131
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:597
usbd_remote_wakeup
void usbd_remote_wakeup(usbd_core_type *udev)
usb device remote wakeup
Definition: usbd_core.c:607
usbd_irq_handler
void usbd_irq_handler(otg_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
EXINT0_IRQn
@ EXINT0_IRQn
Definition: at32f435_437.h:152
keyboard_class.h
usb hid keyboard header file
keyboard_desc.h
usb keyboard descriptor header file
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
keyboard_type
Definition: keyboard_class.h:67
keyboard_type::g_u8tx_completed
__IO uint8_t g_u8tx_completed
Definition: keyboard_class.h:75
otg_core_type
usb otg core struct type
Definition: usb_core.h:92
usb_core.h
usb core header file
usbd_int.h
usb interrupt header file
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • usb_device
  • mouse
  • inc
project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • usb_device
  • mouse
  • inc
project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • usb_device
  • mouse
  • inc
project/at_start_f435/examples/usb_device/mouse/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: usb_conf.h Source File

  • at_start_f435
  • examples
  • usb_device
  • mouse
  • inc
project/at_start_f435/examples/usb_device/mouse/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f435_437_usb.h"
36#include "at32f435_437.h"
37#include "stdio.h"
38
39
52#define USE_OTG_DEVICE_MODE
53
57/* #define USE_OTG_HOST_MODE */
58
63/* use otgfs1 */
64#define OTG_USB_ID 1
65
66/* use otgfs2 */
67/* #define OTG_USB_ID 2 */
68
69#if (OTG_USB_ID == 1)
70#define USB_ID 0
71#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
72#define OTG_IRQ OTGFS1_IRQn
73#define OTG_IRQ_HANDLER OTGFS1_IRQHandler
74#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
75#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
76#define OTG_WKUP_EXINT_LINE EXINT_LINE_18
77
78#define OTG_PIN_GPIO GPIOA
79#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
80
81#define OTG_PIN_DP GPIO_PINS_12
82#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
83
84#define OTG_PIN_DM GPIO_PINS_11
85#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
86
87#define OTG_PIN_VBUS GPIO_PINS_9
88#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
89
90#define OTG_PIN_ID GPIO_PINS_10
91#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
92
93#define OTG_PIN_SOF_GPIO GPIOA
94#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
95#define OTG_PIN_SOF GPIO_PINS_8
96#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
97
98#define OTG_PIN_MUX GPIO_MUX_10
99#endif
100
101#if (OTG_USB_ID == 2)
102#define USB_ID 1
103#define OTG_CLOCK CRM_OTGFS2_PERIPH_CLOCK
104#define OTG_IRQ OTGFS2_IRQn
105#define OTG_IRQ_HANDLER OTGFS2_IRQHandler
106#define OTG_WKUP_IRQ OTGFS2_WKUP_IRQn
107#define OTG_WKUP_HANDLER OTGFS2_WKUP_IRQHandler
108#define OTG_WKUP_EXINT_LINE EXINT_LINE_20
109
110#define OTG_PIN_GPIO GPIOB
111#define OTG_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK
112
113#define OTG_PIN_DP GPIO_PINS_15
114#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE15
115
116#define OTG_PIN_DM GPIO_PINS_14
117#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE14
118
119#define OTG_PIN_VBUS GPIO_PINS_13
120#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13
121
122#define OTG_PIN_ID GPIO_PINS_12
123#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
124
125#define OTG_PIN_SOF_GPIO GPIOA
126#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
127#define OTG_PIN_SOF GPIO_PINS_4
128#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE4
129
130#define OTG_PIN_MUX GPIO_MUX_12
131#endif
132
136#ifdef USE_OTG_DEVICE_MODE
140/* otg1 device fifo */
141#define USBD_RX_SIZE 128
142#define USBD_EP0_TX_SIZE 24
143#define USBD_EP1_TX_SIZE 20
144#define USBD_EP2_TX_SIZE 20
145#define USBD_EP3_TX_SIZE 20
146#define USBD_EP4_TX_SIZE 20
147#define USBD_EP5_TX_SIZE 20
148#define USBD_EP6_TX_SIZE 20
149#define USBD_EP7_TX_SIZE 20
150
151/* otg2 device fifo */
152#define USBD2_RX_SIZE 128
153#define USBD2_EP0_TX_SIZE 24
154#define USBD2_EP1_TX_SIZE 20
155#define USBD2_EP2_TX_SIZE 20
156#define USBD2_EP3_TX_SIZE 20
157#define USBD2_EP4_TX_SIZE 20
158#define USBD2_EP5_TX_SIZE 20
159#define USBD2_EP6_TX_SIZE 20
160#define USBD2_EP7_TX_SIZE 20
161
165#ifndef USB_EPT_MAX_NUM
166#define USB_EPT_MAX_NUM 8
167#endif
168#endif
169
173#ifdef USE_OTG_HOST_MODE
174#ifndef USB_HOST_CHANNEL_NUM
175#define USB_HOST_CHANNEL_NUM 16
176#endif
177
181/* otg1 host fifo */
182#define USBH_RX_FIFO_SIZE 128
183#define USBH_NP_TX_FIFO_SIZE 96
184#define USBH_P_TX_FIFO_SIZE 96
185
186/* otg2 host fifo */
187#define USBH2_RX_FIFO_SIZE 128
188#define USBH2_NP_TX_FIFO_SIZE 96
189#define USBH2_P_TX_FIFO_SIZE 96
190#endif
191
195/* #define USB_SOF_OUTPUT_ENABLE */
196
200#define USB_VBUS_IGNORE
201
205#define USB_LOW_POWER_WAKUP
206
207void usb_delay_ms(uint32_t ms);
208void usb_delay_us(uint32_t us);
209
210
218#ifdef __cplusplus
219}
220#endif
221
222#endif
223
at32f435_437.h
at32f435_437 header file
at32f435_437_usb.h
at32f435_437 usb header file
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f435/examples/usb_device/mouse/src/main.c:390
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f435/examples/usb_device/mouse/src/main.c:401


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • mouse
  • src
Functions
project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • usb_device
  • mouse
  • src
project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • mouse
  • src
Functions
project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • usb_device
  • mouse
  • src
project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/usb_device/mouse/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • mouse
  • src
Functions | Variables
project/at_start_f435/examples/usb_device/mouse/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include "usb_conf.h"
#include "usb_core.h"
#include "usbd_int.h"
#include "mouse_class.h"
#include "mouse_desc.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | keyboard_send_string (uint8_t *string, uint8_t len)
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
void | system_clock_recover (void)
system clock recover. More...
void | button_exint_init (void)
configure button exint More...
int | main (void)
main function. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

otg_core_type otg_core_struct
__IO uint8_t press_mouse = 0

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/mouse/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • usb_device
  • mouse
  • src
project/at_start_f435/examples/usb_device/mouse/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include "usb_conf.h"
30#include "usb_core.h"
31#include "usbd_int.h"
32#include "mouse_class.h"
33#include "mouse_desc.h"
34
35
44/* usb global struct define */
45 otg_core_type otg_core_struct;
46__IO uint8_t press_mouse = 0;
47void usb_clock48m_select(usb_clk48_s clk_s);
48void keyboard_send_string(uint8_t *string, uint8_t len);
49void usb_gpio_config(void);
50void usb_low_power_wakeup_config(void);
51void system_clock_recover(void);
52void button_exint_init(void);
53
59int main(void)
60{
61 __IO uint32_t delay_index = 0;
62 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
63
64 system_clock_config();
65
66 at32_board_init();
67
68 /* usb gpio config */
69 usb_gpio_config();
70
71#ifdef USB_LOW_POWER_WAKUP
72 /* enable pwc and bpr clock */
73 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
74 button_exint_init();
75 usb_low_power_wakeup_config();
76#endif
77
78 /* enable otgfs clock */
79 crm_periph_clock_enable(OTG_CLOCK, TRUE);
80
81 /* select usb 48m clcok source */
82 usb_clock48m_select(USB_CLK_HEXT);
83
84 /* enable otgfs irq */
85 nvic_irq_enable(OTG_IRQ, 0, 0);
86
87 /* init usb */
88 usbd_init(&otg_core_struct,
89 USB_FULL_SPEED_CORE_ID,
90 USB_ID,
91 &mouse_class_handler,
92 &mouse_desc_handler);
93
94 at32_led_on(LED2);
95 at32_led_on(LED3);
96 at32_led_on(LED4);
97 while(1)
98 {
99 if(at32_button_press() == USER_BUTTON)
100 {
101 if(usbd_connect_state_get(&otg_core_struct.dev) == USB_CONN_STATE_CONFIGURED)
102 {
103 usb_hid_mouse_send(&otg_core_struct.dev, RIGHT_BUTTON);
104 press_mouse = 1;
105 }
106 /* remote wakeup */
107 if(usbd_connect_state_get(&otg_core_struct.dev) == USB_CONN_STATE_SUSPENDED
108 && (otg_core_struct.dev.remote_wakup == 1))
109 {
110 usbd_remote_wakeup(&otg_core_struct.dev);
111 }
112 }
113 else if(press_mouse == 1)
114 {
115 delay_ms(10);
116 usb_hid_mouse_send(&otg_core_struct.dev, BUTTON_RELEASE);
117 press_mouse = 0;
118
119 }
120 #ifdef USB_LOW_POWER_WAKUP
121 /* enter deep sleep */
122 if(((mouse_type *)(otg_core_struct.dev.class_handler->pdata))->hid_suspend_flag == 1)
123 {
124 at32_led_off(LED2);
125 at32_led_off(LED3);
126 at32_led_off(LED4);
127 /* congfig the voltage regulator mode */
128 pwc_voltage_regulate_set(PWC_REGULATOR_LOW_POWER);
129
130 /* enter deep sleep mode */
131 pwc_deep_sleep_mode_enter(PWC_DEEP_SLEEP_ENTER_WFI);
132 /* wait clock stable */
133 for(delay_index = 0; delay_index < 600; delay_index++)
134 {
135 __NOP();
136 }
137 system_clock_recover();
138 ((mouse_type *)(otg_core_struct.dev.class_handler->pdata))->hid_suspend_flag = 0;
139 at32_led_on(LED2);
140 at32_led_on(LED3);
141 at32_led_on(LED4);
142 }
143 #endif
144 }
145}
146
152void usb_clock48m_select(usb_clk48_s clk_s)
153{
154 if(clk_s == USB_CLK_HICK)
155 {
156 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
157
158 /* enable the acc calibration ready interrupt */
159 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
160
161 /* update the c1\c2\c3 value */
162 acc_write_c1(7980);
163 acc_write_c2(8000);
164 acc_write_c3(8020);
165#if (USB_ID == 0)
166 acc_sof_select(ACC_SOF_OTG1);
167#else
168 acc_sof_select(ACC_SOF_OTG2);
169#endif
170 /* open acc calibration */
171 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
172 }
173 else
174 {
175 switch(system_core_clock)
176 {
177 /* 48MHz */
178 case 48000000:
179 crm_usb_clock_div_set(CRM_USB_DIV_1);
180 break;
181
182 /* 72MHz */
183 case 72000000:
184 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
185 break;
186
187 /* 96MHz */
188 case 96000000:
189 crm_usb_clock_div_set(CRM_USB_DIV_2);
190 break;
191
192 /* 120MHz */
193 case 120000000:
194 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
195 break;
196
197 /* 144MHz */
198 case 144000000:
199 crm_usb_clock_div_set(CRM_USB_DIV_3);
200 break;
201
202 /* 168MHz */
203 case 168000000:
204 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
205 break;
206
207 /* 192MHz */
208 case 192000000:
209 crm_usb_clock_div_set(CRM_USB_DIV_4);
210 break;
211
212 /* 216MHz */
213 case 216000000:
214 crm_usb_clock_div_set(CRM_USB_DIV_4_5);
215 break;
216
217 /* 240MHz */
218 case 240000000:
219 crm_usb_clock_div_set(CRM_USB_DIV_5);
220 break;
221
222 /* 264MHz */
223 case 264000000:
224 crm_usb_clock_div_set(CRM_USB_DIV_5_5);
225 break;
226
227 /* 288MHz */
228 case 288000000:
229 crm_usb_clock_div_set(CRM_USB_DIV_6);
230 break;
231
232 default:
233 break;
234
235 }
236 }
237}
238
244void usb_gpio_config(void)
245{
246 gpio_init_type gpio_init_struct;
247
248 crm_periph_clock_enable(OTG_PIN_GPIO_CLOCK, TRUE);
249 gpio_default_para_init(&gpio_init_struct);
250
251 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
252 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
253 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
254 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
255
256 /* dp and dm */
257 gpio_init_struct.gpio_pins = OTG_PIN_DP | OTG_PIN_DM;
258 gpio_init(OTG_PIN_GPIO, &gpio_init_struct);
259
260 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_DP_SOURCE, OTG_PIN_MUX);
261 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_DM_SOURCE, OTG_PIN_MUX);
262
263#ifdef USB_SOF_OUTPUT_ENABLE
264 crm_periph_clock_enable(OTG_PIN_SOF_GPIO_CLOCK, TRUE);
265 gpio_init_struct.gpio_pins = OTG_PIN_SOF;
266 gpio_init(OTG_PIN_SOF_GPIO, &gpio_init_struct);
267 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_SOF_SOURCE, OTG_PIN_MUX);
268#endif
269
270 /* otgfs use vbus pin */
271#ifndef USB_VBUS_IGNORE
272 gpio_init_struct.gpio_pins = OTG_PIN_VBUS;
273 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
274 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_VBUS_SOURCE, OTG_PIN_MUX);
275 gpio_init(OTG_PIN_GPIO, &gpio_init_struct);
276#endif
277
278
279}
280#ifdef USB_LOW_POWER_WAKUP
286void usb_low_power_wakeup_config(void)
287{
288 exint_init_type exint_init_struct;
289
290 crm_periph_clock_enable(CRM_SCFG_PERIPH_CLOCK, TRUE);
291 exint_default_para_init(&exint_init_struct);
292
293 exint_init_struct.line_enable = TRUE;
294 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
295 exint_init_struct.line_select = OTG_WKUP_EXINT_LINE;
296 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
297 exint_init(&exint_init_struct);
298
299 nvic_irq_enable(OTG_WKUP_IRQ, 0, 0);
300}
301
307void system_clock_recover(void)
308{
309 /* enable external high-speed crystal oscillator - hext */
310 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
311
312 /* wait till hext is ready */
313 while(crm_hext_stable_wait() == ERROR);
314
315 /* enable pll */
316 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
317
318 /* wait till pll is ready */
319 while(crm_flag_get(CRM_PLL_STABLE_FLAG) == RESET);
320
321 /* enable auto step mode */
322 crm_auto_step_mode_enable(TRUE);
323
324 /* select pll as system clock source */
325 crm_sysclk_switch(CRM_SCLK_PLL);
326
327 /* wait till pll is used as system clock source */
328 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL);
329}
330
336void button_exint_init(void)
337{
338 exint_init_type exint_init_struct;
339
340 crm_periph_clock_enable(CRM_SCFG_PERIPH_CLOCK, TRUE);
341 scfg_exint_line_config(SCFG_PORT_SOURCE_GPIOA, SCFG_PINS_SOURCE0);
342
343 exint_default_para_init(&exint_init_struct);
344 exint_init_struct.line_enable = TRUE;
345 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
346 exint_init_struct.line_select = EXINT_LINE_0;
347 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
348 exint_init(&exint_init_struct);
349
350 nvic_irq_enable(EXINT0_IRQn, 0, 0);
351}
352
358void OTG_WKUP_HANDLER(void)
359{
360 exint_flag_clear(OTG_WKUP_EXINT_LINE);
361}
362
368void EXINT0_IRQHandler(void)
369{
370 exint_flag_clear(EXINT_LINE_0);
371}
372
373#endif
374
380void OTG_IRQ_HANDLER(void)
381{
382 usbd_irq_handler(&otg_core_struct);
383}
384
390void usb_delay_ms(uint32_t ms)
391{
392 /* user can define self delay function */
393 delay_ms(ms);
394}
395
401void usb_delay_us(uint32_t us)
402{
403 delay_us(us);
404}
405
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:41
EXINT0_IRQHandler
void EXINT0_IRQHandler(void)
exint0 interrupt handler
Definition: project/at_start_f435/examples/exint/exint_config/src/main.c:70
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
hid_suspend_flag
__IO uint8_t hid_suspend_flag
button_exint_init
void button_exint_init(void)
configure button exint
Definition: project/at_start_f435/examples/usb_device/composite_vcp_keyboard/src/main.c:61
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f435/examples/usb_device/mouse/src/main.c:152
main
int main(void)
main function.
Definition: project/at_start_f435/examples/usb_device/mouse/src/main.c:59
usb_low_power_wakeup_config
void usb_low_power_wakeup_config(void)
usb_gpio_config
void usb_gpio_config(void)
this function config gpio.
Definition: project/at_start_f435/examples/usb_device/mouse/src/main.c:244
OTG_IRQ_HANDLER
void OTG_IRQ_HANDLER(void)
this function handles otgfs interrupt.
Definition: project/at_start_f435/examples/usb_device/mouse/src/main.c:380
press_mouse
__IO uint8_t press_mouse
Definition: project/at_start_f435/examples/usb_device/mouse/src/main.c:46
keyboard_send_string
void keyboard_send_string(uint8_t *string, uint8_t len)
otg_core_struct
otg_core_type otg_core_struct
Definition: project/at_start_f435/examples/usb_device/mouse/src/main.c:45
system_clock_recover
void system_clock_recover(void)
system clock recover.
Definition: project/at_start_f435/examples/pwc/deepsleep_ertc_alarm/src/main.c:141
OTG_PIN_VBUS
#define OTG_PIN_VBUS
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:85
OTG_PIN_DM
#define OTG_PIN_DM
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:82
OTG_PIN_DP
#define OTG_PIN_DP
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:79
OTG_PIN_SOF
#define OTG_PIN_SOF
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:93
OTG_WKUP_IRQ
#define OTG_WKUP_IRQ
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:72
OTG_PIN_DP_SOURCE
#define OTG_PIN_DP_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:80
OTG_PIN_GPIO
#define OTG_PIN_GPIO
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:76
OTG_IRQ
#define OTG_IRQ
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:70
OTG_PIN_SOF_GPIO
#define OTG_PIN_SOF_GPIO
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:91
OTG_WKUP_HANDLER
#define OTG_WKUP_HANDLER
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:73
OTG_CLOCK
#define OTG_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:69
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb low power wakeup handler enable
Definition: project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c:304
OTG_PIN_GPIO_CLOCK
#define OTG_PIN_GPIO_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:77
OTG_PIN_SOF_SOURCE
#define OTG_PIN_SOF_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:94
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c:315
OTG_PIN_VBUS_SOURCE
#define OTG_PIN_VBUS_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:86
USB_ID
#define USB_ID
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:68
OTG_PIN_DM_SOURCE
#define OTG_PIN_DM_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:83
OTG_PIN_MUX
#define OTG_PIN_MUX
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:96
OTG_WKUP_EXINT_LINE
#define OTG_WKUP_EXINT_LINE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:74
OTG_PIN_SOF_GPIO_CLOCK
#define OTG_PIN_SOF_GPIO_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:92
ACC_SOF_OTG2
#define ACC_SOF_OTG2
Definition: at32f435_437_acc.h:61
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f435_437_acc.h:52
ACC_SOF_OTG1
#define ACC_SOF_OTG1
Definition: at32f435_437_acc.h:60
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f435_437_acc.c:145
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f435_437_acc.c:155
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f435_437_acc.c:135
acc_sof_select
void acc_sof_select(uint16_t sof_sel)
select sof sourse for acc in acc's ctrl1 register.
Definition: at32f435_437_acc.c:84
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f435_437_acc.c:53
system_core_clock
unsigned int system_core_clock
Definition: system_at32f435_437.c:48
LED3
@ LED3
Definition: at32f435_437_board.h:66
LED2
@ LED2
Definition: at32f435_437_board.h:65
LED4
@ LED4
Definition: at32f435_437_board.h:67
USER_BUTTON
@ USER_BUTTON
Definition: at32f435_437_board.h:98
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f435_437_board.c:194
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f435_437_board.c:246
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f435_437_board.c:263
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f435_437_board.c:306
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type value)
set usb division
Definition: at32f435_437_crm.c:521
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f435_437_crm.c:594
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_SCFG_PERIPH_CLOCK
@ CRM_SCFG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:163
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:168
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_USB_DIV_5
@ CRM_USB_DIV_5
Definition: at32f435_437_crm.h:620
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f435_437_crm.h:616
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f435_437_crm.h:611
CRM_USB_DIV_5_5
@ CRM_USB_DIV_5_5
Definition: at32f435_437_crm.h:619
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f435_437_crm.h:618
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f435_437_crm.h:615
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f435_437_crm.h:614
CRM_USB_DIV_6
@ CRM_USB_DIV_6
Definition: at32f435_437_crm.h:622
CRM_USB_DIV_4_5
@ CRM_USB_DIV_4_5
Definition: at32f435_437_crm.h:617
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f435_437_crm.h:612
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f435_437_crm.h:613
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f435_437_crm.h:763
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f435_437_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
EXINT_LINE_0
#define EXINT_LINE_0
Definition: at32f435_437_exint.h:52
ERROR
@ ERROR
Definition: at32f435_437.h:380
TRUE
@ TRUE
Definition: at32f435_437.h:379
RESET
@ RESET
Definition: at32f435_437.h:378
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
pwc_voltage_regulate_set
void pwc_voltage_regulate_set(pwc_regulator_type pwc_regulator)
regulate low power consumption in the deep sleep mode
Definition: at32f435_437_pwc.c:214
pwc_deep_sleep_mode_enter
void pwc_deep_sleep_mode_enter(pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode
Definition: at32f435_437_pwc.c:190
PWC_REGULATOR_LOW_POWER
@ PWC_REGULATOR_LOW_POWER
Definition: at32f435_437_pwc.h:130
PWC_DEEP_SLEEP_ENTER_WFI
@ PWC_DEEP_SLEEP_ENTER_WFI
Definition: at32f435_437_pwc.h:120
scfg_exint_line_config
void scfg_exint_line_config(scfg_port_source_type port_source, scfg_pins_source_type pin_source)
select the gpio pin used as exint line.
Definition: at32f435_437_scfg.c:152
SCFG_PINS_SOURCE0
@ SCFG_PINS_SOURCE0
Definition: at32f435_437_scfg.h:101
SCFG_PORT_SOURCE_GPIOA
@ SCFG_PORT_SOURCE_GPIOA
Definition: at32f435_437_scfg.h:124
USB_FULL_SPEED_CORE_ID
@ USB_FULL_SPEED_CORE_ID
Definition: usb_core.h:64
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f435_437_usb.h:402
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f435_437_usb.h:404
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f435_437_usb.h:403
mouse_class_handler
usbd_class_handler mouse_class_handler
Definition: mouse_class.c:56
usb_hid_mouse_send
void usb_hid_mouse_send(void *udev, uint8_t op)
usb device class report function
Definition: mouse_class.c:314
BUTTON_RELEASE
#define BUTTON_RELEASE
Definition: mouse_class.h:74
RIGHT_BUTTON
#define RIGHT_BUTTON
Definition: mouse_class.h:76
mouse_desc_handler
usbd_desc_handler mouse_desc_handler
mouse device descriptor handler structure
Definition: mouse_desc.c:63
USB_CONN_STATE_SUSPENDED
@ USB_CONN_STATE_SUSPENDED
Definition: usb_std.h:132
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:131
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:597
usbd_remote_wakeup
void usbd_remote_wakeup(usbd_core_type *udev)
usb device remote wakeup
Definition: usbd_core.c:607
usbd_irq_handler
void usbd_irq_handler(otg_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
EXINT0_IRQn
@ EXINT0_IRQn
Definition: at32f435_437.h:152
mouse_class.h
usb hid mouse header file
mouse_desc.h
usb mouse descriptor header file
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
mouse_type
Definition: mouse_class.h:83
otg_core_type
usb otg core struct type
Definition: usb_core.h:92
usb_core.h
usb core header file
usbd_int.h
usb interrupt header file
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • usb_device
  • msc
  • inc
project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • usb_device
  • msc
  • inc
project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • usb_device
  • msc
  • inc
project/at_start_f435/examples/usb_device/msc/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: usb_conf.h Source File

  • at_start_f435
  • examples
  • usb_device
  • msc
  • inc
project/at_start_f435/examples/usb_device/msc/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f435_437_usb.h"
36#include "at32f435_437.h"
37#include "stdio.h"
38
39
52#define USE_OTG_DEVICE_MODE
53
57/* #define USE_OTG_HOST_MODE */
58
63/* use otgfs1 */
64#define OTG_USB_ID 1
65
66/* use otgfs2 */
67/* #define OTG_USB_ID 2 */
68
69#if (OTG_USB_ID == 1)
70#define USB_ID 0
71#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
72#define OTG_IRQ OTGFS1_IRQn
73#define OTG_IRQ_HANDLER OTGFS1_IRQHandler
74#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
75#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
76#define OTG_WKUP_EXINT_LINE EXINT_LINE_18
77
78#define OTG_PIN_GPIO GPIOA
79#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
80
81#define OTG_PIN_DP GPIO_PINS_12
82#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
83
84#define OTG_PIN_DM GPIO_PINS_11
85#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
86
87#define OTG_PIN_VBUS GPIO_PINS_9
88#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
89
90#define OTG_PIN_ID GPIO_PINS_10
91#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
92
93#define OTG_PIN_SOF_GPIO GPIOA
94#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
95#define OTG_PIN_SOF GPIO_PINS_8
96#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
97
98#define OTG_PIN_MUX GPIO_MUX_10
99#endif
100
101#if (OTG_USB_ID == 2)
102#define USB_ID 1
103#define OTG_CLOCK CRM_OTGFS2_PERIPH_CLOCK
104#define OTG_IRQ OTGFS2_IRQn
105#define OTG_IRQ_HANDLER OTGFS2_IRQHandler
106#define OTG_WKUP_IRQ OTGFS2_WKUP_IRQn
107#define OTG_WKUP_HANDLER OTGFS2_WKUP_IRQHandler
108#define OTG_WKUP_EXINT_LINE EXINT_LINE_20
109
110#define OTG_PIN_GPIO GPIOB
111#define OTG_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK
112
113#define OTG_PIN_DP GPIO_PINS_15
114#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE15
115
116#define OTG_PIN_DM GPIO_PINS_14
117#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE14
118
119#define OTG_PIN_VBUS GPIO_PINS_13
120#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13
121
122#define OTG_PIN_ID GPIO_PINS_12
123#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
124
125#define OTG_PIN_SOF_GPIO GPIOA
126#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
127#define OTG_PIN_SOF GPIO_PINS_4
128#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE4
129
130#define OTG_PIN_MUX GPIO_MUX_12
131#endif
132
136#ifdef USE_OTG_DEVICE_MODE
140/* otg1 device fifo */
141#define USBD_RX_SIZE 128
142#define USBD_EP0_TX_SIZE 24
143#define USBD_EP1_TX_SIZE 20
144#define USBD_EP2_TX_SIZE 20
145#define USBD_EP3_TX_SIZE 20
146#define USBD_EP4_TX_SIZE 20
147#define USBD_EP5_TX_SIZE 20
148#define USBD_EP6_TX_SIZE 20
149#define USBD_EP7_TX_SIZE 20
150
151/* otg2 device fifo */
152#define USBD2_RX_SIZE 128
153#define USBD2_EP0_TX_SIZE 24
154#define USBD2_EP1_TX_SIZE 20
155#define USBD2_EP2_TX_SIZE 20
156#define USBD2_EP3_TX_SIZE 20
157#define USBD2_EP4_TX_SIZE 20
158#define USBD2_EP5_TX_SIZE 20
159#define USBD2_EP6_TX_SIZE 20
160#define USBD2_EP7_TX_SIZE 20
161
165#ifndef USB_EPT_MAX_NUM
166#define USB_EPT_MAX_NUM 8
167#endif
168#endif
169
173#ifdef USE_OTG_HOST_MODE
174#ifndef USB_HOST_CHANNEL_NUM
175#define USB_HOST_CHANNEL_NUM 16
176#endif
177
181/* otg1 host fifo */
182#define USBH_RX_FIFO_SIZE 128
183#define USBH_NP_TX_FIFO_SIZE 96
184#define USBH_P_TX_FIFO_SIZE 96
185
186/* otg2 host fifo */
187#define USBH2_RX_FIFO_SIZE 128
188#define USBH2_NP_TX_FIFO_SIZE 96
189#define USBH2_P_TX_FIFO_SIZE 96
190#endif
191
195/* #define USB_SOF_OUTPUT_ENABLE */
196
200#define USB_VBUS_IGNORE
201
205/* #define USB_LOW_POWER_WAKUP */
206
207void usb_delay_ms(uint32_t ms);
208void usb_delay_us(uint32_t us);
209
217#ifdef __cplusplus
218}
219#endif
220
221#endif
222
at32f435_437.h
at32f435_437 header file
at32f435_437_usb.h
at32f435_437 usb header file
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb low power wakeup handler enable
Definition: project/at_start_f435/examples/usb_device/msc/src/main.c:275
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f435/examples/usb_device/msc/src/main.c:286


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • msc
  • src
Functions
project/at_start_f435/examples/usb_device/msc/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/msc/src/at32f435_437_clock.c.


AT32F435/437 Firmwary Library: at32f435_437_clock.c Source File

  • at_start_f435
  • examples
  • usb_device
  • msc
  • src
project/at_start_f435/examples/usb_device/msc/src/at32f435_437_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_clock.h"
29
49void system_clock_config(void)
50{
51 /* enable pwc periph clock */
52 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
53
54 /* config ldo voltage */
55 pwc_ldo_output_voltage_set(PWC_LDO_OUTPUT_1V3);
56
57 /* set the flash clock divider */
58 flash_clock_divider_set(FLASH_CLOCK_DIV_3);
59
60 /* reset crm */
61 crm_reset();
62
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
64
65 /* wait till hext is ready */
66 while(crm_hext_stable_wait() == ERROR)
67 {
68 }
69
70 /* config pll clock resource
71 common frequency config list: pll source selected hick or hext(8mhz)
72 _______________________________________________________________________________________
73 | | | | | | | | | |
74 |pll(mhz)| 288 | 252 | 216 | 180 | 144 | 108 | 72 | 36 |
75 |________|_________|_________|_________|_________|_________|_________|_________________|
76 | | | | | | | | | |
77 |pll_ns | 72 | 63 | 108 | 90 | 72 | 108 | 72 | 72 |
78 | | | | | | | | | |
79 |pll_ms | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 |
80 | | | | | | | | | |
81 |pll_fr | FR_2 | FR_2 | FR_4 | FR_4 | FR_4 | FR_8 | FR_8 | FR_16|
82 |________|_________|_________|_________|_________|_________|_________|________|________|
83
84 if pll clock source selects hext with other frequency values, or configure pll to other
85 frequency values, please use the at32 new clock configuration tool for configuration. */
86 crm_pll_config(CRM_PLL_SOURCE_HEXT, 72, 1, CRM_PLL_FR_2);
87
88 /* enable pll */
89 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
90
91 /* wait till pll is ready */
92 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
93 {
94 }
95
96 /* config ahbclk */
97 crm_ahb_div_set(CRM_AHB_DIV_1);
98
99 /* config apb2clk */
100 crm_apb2_div_set(CRM_APB2_DIV_2);
101
102 /* config apb1clk */
103 crm_apb1_div_set(CRM_APB1_DIV_2);
104
105 /* enable auto step mode */
106 crm_auto_step_mode_enable(TRUE);
107
108 /* select pll as system clock source */
109 crm_sysclk_switch(CRM_SCLK_PLL);
110
111 /* wait till pll is used as system clock source */
112 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
113 {
114 }
115
116 /* disable auto step mode */
117 crm_auto_step_mode_enable(FALSE);
118
119 /* update system_core_clock global variable */
120 system_core_clock_update();
121}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/usb_device/msc/src/at32f435_437_clock.c:49
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f435_437.c:114
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f435_437_crm.c:124
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f435_437_crm.c:143
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, uint16_t pll_ns, uint16_t pll_ms, crm_pll_fr_type pll_fr)
config crm pll pll_rcs_freq * pll_ns pll clock = -----------------------------— pll_ms * pll_fr_n att...
Definition: at32f435_437_crm.c:645
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f435_437_crm.c:465
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f435_437_crm.c:680
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f435_437_crm.c:314
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f435_437_crm.c:497
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f435_437_crm.c:481
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f435_437_crm.c:551
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f435_437_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f435_437_crm.c:666
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:149
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f435_437_crm.h:588
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f435_437_crm.h:561
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f435_437_crm.h:560
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f435_437_crm.h:538
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f435_437_crm.h:571
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f435_437_crm.h:682
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f435_437_crm.h:600
CRM_PLL_FR_2
@ CRM_PLL_FR_2
Definition: at32f435_437_crm.h:547
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f435_437_crm.h:57
ERROR
@ ERROR
Definition: at32f435_437.h:380
FALSE
@ FALSE
Definition: at32f435_437.h:379
TRUE
@ TRUE
Definition: at32f435_437.h:379
SET
@ SET
Definition: at32f435_437.h:378
flash_clock_divider_set
#define flash_clock_divider_set(div)
set the flash clock divider definition
Definition: at32f435_437_flash.h:161
FLASH_CLOCK_DIV_3
@ FLASH_CLOCK_DIV_3
Definition: at32f435_437_flash.h:191
PWC_LDO_OUTPUT_1V3
@ PWC_LDO_OUTPUT_1V3
Definition: at32f435_437_pwc.h:101
pwc_ldo_output_voltage_set
#define pwc_ldo_output_voltage_set(val)
select ldo output voltage.
Definition: at32f435_437_pwc.h:75
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_int.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • msc
  • src
Functions
project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c File Reference

main interrupt service routines. More...

#include "at32f435_437_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c.


AT32F435/437 Firmwary Library: at32f435_437_int.c Source File

  • at_start_f435
  • examples
  • usb_device
  • msc
  • src
project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f435_437_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/usb_device/msc/src/at32f435_437_int.c:113
at32f435_437_int.h
header file of main interrupt service routines.


AT32F435/437 Firmwary Library: main.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • msc
  • src
Functions | Variables
project/at_start_f435/examples/usb_device/msc/src/main.c File Reference

main program More...

#include "at32f435_437_board.h"
#include "at32f435_437_clock.h"
#include "usb_conf.h"
#include "usb_core.h"
#include "usbd_int.h"
#include "msc_class.h"
#include "msc_desc.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | usb_gpio_config (void)
this function config gpio. More...
void | usb_low_power_wakeup_config (void)
int | main (void)
main function. More...
void | OTG_IRQ_HANDLER (void)
this function handles otgfs interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb low power wakeup handler enable More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

otg_core_type otg_core_struct

Detailed Description

main program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/msc/src/main.c.


AT32F435/437 Firmwary Library: main.c Source File

  • at_start_f435
  • examples
  • usb_device
  • msc
  • src
project/at_start_f435/examples/usb_device/msc/src/main.c
Go to the documentation of this file.
1
27#include "at32f435_437_board.h"
28#include "at32f435_437_clock.h"
29#include "usb_conf.h"
30#include "usb_core.h"
31#include "usbd_int.h"
32#include "msc_class.h"
33#include "msc_desc.h"
34
35
36
45/* usb global struct define */
46 otg_core_type otg_core_struct;
47void usb_clock48m_select(usb_clk48_s clk_s);
48void usb_gpio_config(void);
49void usb_low_power_wakeup_config(void);
50
56int main(void)
57{
58 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
59
60 system_clock_config();
61
62 at32_board_init();
63
64 /* usb gpio config */
65 usb_gpio_config();
66
67#ifdef USB_LOW_POWER_WAKUP
68 usb_low_power_wakeup_config();
69#endif
70
71 /* enable otgfs clock */
72 crm_periph_clock_enable(OTG_CLOCK, TRUE);
73
74 /* select usb 48m clcok source */
75 usb_clock48m_select(USB_CLK_HEXT);
76
77 /* enable otgfs irq */
78 nvic_irq_enable(OTG_IRQ, 0, 0);
79
80 /* init usb */
81 usbd_init(&otg_core_struct,
82 USB_FULL_SPEED_CORE_ID,
83 USB_ID,
84 &msc_class_handler,
85 &msc_desc_handler);
86
87 while(1)
88 {
89
90 }
91}
92
98void usb_clock48m_select(usb_clk48_s clk_s)
99{
100 if(clk_s == USB_CLK_HICK)
101 {
102 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
103
104 /* enable the acc calibration ready interrupt */
105 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
106
107 /* update the c1\c2\c3 value */
108 acc_write_c1(7980);
109 acc_write_c2(8000);
110 acc_write_c3(8020);
111#if (USB_ID == 0)
112 acc_sof_select(ACC_SOF_OTG1);
113#else
114 acc_sof_select(ACC_SOF_OTG2);
115#endif
116 /* open acc calibration */
117 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
118 }
119 else
120 {
121 switch(system_core_clock)
122 {
123 /* 48MHz */
124 case 48000000:
125 crm_usb_clock_div_set(CRM_USB_DIV_1);
126 break;
127
128 /* 72MHz */
129 case 72000000:
130 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
131 break;
132
133 /* 96MHz */
134 case 96000000:
135 crm_usb_clock_div_set(CRM_USB_DIV_2);
136 break;
137
138 /* 120MHz */
139 case 120000000:
140 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
141 break;
142
143 /* 144MHz */
144 case 144000000:
145 crm_usb_clock_div_set(CRM_USB_DIV_3);
146 break;
147
148 /* 168MHz */
149 case 168000000:
150 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
151 break;
152
153 /* 192MHz */
154 case 192000000:
155 crm_usb_clock_div_set(CRM_USB_DIV_4);
156 break;
157
158 /* 216MHz */
159 case 216000000:
160 crm_usb_clock_div_set(CRM_USB_DIV_4_5);
161 break;
162
163 /* 240MHz */
164 case 240000000:
165 crm_usb_clock_div_set(CRM_USB_DIV_5);
166 break;
167
168 /* 264MHz */
169 case 264000000:
170 crm_usb_clock_div_set(CRM_USB_DIV_5_5);
171 break;
172
173 /* 288MHz */
174 case 288000000:
175 crm_usb_clock_div_set(CRM_USB_DIV_6);
176 break;
177
178 default:
179 break;
180
181 }
182 }
183}
184
190void usb_gpio_config(void)
191{
192 gpio_init_type gpio_init_struct;
193
194 crm_periph_clock_enable(OTG_PIN_GPIO_CLOCK, TRUE);
195 gpio_default_para_init(&gpio_init_struct);
196
197 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
198 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
199 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
200 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
201
202 /* dp and dm */
203 gpio_init_struct.gpio_pins = OTG_PIN_DP | OTG_PIN_DM;
204 gpio_init(OTG_PIN_GPIO, &gpio_init_struct);
205
206 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_DP_SOURCE, OTG_PIN_MUX);
207 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_DM_SOURCE, OTG_PIN_MUX);
208
209#ifdef USB_SOF_OUTPUT_ENABLE
210 crm_periph_clock_enable(OTG_PIN_SOF_GPIO_CLOCK, TRUE);
211 gpio_init_struct.gpio_pins = OTG_PIN_SOF;
212 gpio_init(OTG_PIN_SOF_GPIO, &gpio_init_struct);
213 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_SOF_SOURCE, OTG_PIN_MUX);
214#endif
215
216 /* otgfs use vbus pin */
217#ifndef USB_VBUS_IGNORE
218 gpio_init_struct.gpio_pins = OTG_PIN_VBUS;
219 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
220 gpio_pin_mux_config(OTG_PIN_GPIO, OTG_PIN_VBUS_SOURCE, OTG_PIN_MUX);
221 gpio_init(OTG_PIN_GPIO, &gpio_init_struct);
222#endif
223
224
225}
226#ifdef USB_LOW_POWER_WAKUP
232void usb_low_power_wakeup_config(void)
233{
234 exint_init_type exint_init_struct;
235
236 crm_periph_clock_enable(CRM_SCFG_PERIPH_CLOCK, TRUE);
237 exint_default_para_init(&exint_init_struct);
238
239 exint_init_struct.line_enable = TRUE;
240 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
241 exint_init_struct.line_select = OTG_WKUP_EXINT_LINE;
242 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
243 exint_init(&exint_init_struct);
244
245 nvic_irq_enable(OTG_WKUP_IRQ, 0, 0);
246}
247
253void OTG_WKUP_HANDLER(void)
254{
255 exint_flag_clear(OTG_WKUP_EXINT_LINE);
256}
257
258#endif
259
265void OTG_IRQ_HANDLER(void)
266{
267 usbd_irq_handler(&otg_core_struct);
268}
269
275void usb_delay_ms(uint32_t ms)
276{
277 /* user can define self delay function */
278 delay_ms(ms);
279}
280
286void usb_delay_us(uint32_t us)
287{
288 delay_us(us);
289}
290
at32f435_437_board.h
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f435/examples/dac/double_mode_dma_sinewave/src/main.c:38
exint_init_struct
exint_init_type exint_init_struct
Definition: project/at_start_f435/examples/dma/dmamux_genertor_exint/src/main.c:41
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/templates/src/at32f435_437_clock.c:57
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f435/examples/usb_device/msc/src/main.c:98
main
int main(void)
main function.
Definition: project/at_start_f435/examples/usb_device/msc/src/main.c:56
usb_low_power_wakeup_config
void usb_low_power_wakeup_config(void)
usb_gpio_config
void usb_gpio_config(void)
this function config gpio.
Definition: project/at_start_f435/examples/usb_device/msc/src/main.c:190
OTG_IRQ_HANDLER
void OTG_IRQ_HANDLER(void)
this function handles otgfs interrupt.
Definition: project/at_start_f435/examples/usb_device/msc/src/main.c:265
otg_core_struct
otg_core_type otg_core_struct
Definition: project/at_start_f435/examples/usb_device/msc/src/main.c:46
OTG_PIN_VBUS
#define OTG_PIN_VBUS
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:85
OTG_PIN_DM
#define OTG_PIN_DM
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:82
OTG_PIN_DP
#define OTG_PIN_DP
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:79
OTG_PIN_SOF
#define OTG_PIN_SOF
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:93
OTG_WKUP_IRQ
#define OTG_WKUP_IRQ
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:72
OTG_PIN_DP_SOURCE
#define OTG_PIN_DP_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:80
OTG_PIN_GPIO
#define OTG_PIN_GPIO
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:76
OTG_IRQ
#define OTG_IRQ
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:70
OTG_PIN_SOF_GPIO
#define OTG_PIN_SOF_GPIO
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:91
OTG_WKUP_HANDLER
#define OTG_WKUP_HANDLER
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:73
OTG_CLOCK
#define OTG_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:69
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb low power wakeup handler enable
Definition: project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c:304
OTG_PIN_GPIO_CLOCK
#define OTG_PIN_GPIO_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:77
OTG_PIN_SOF_SOURCE
#define OTG_PIN_SOF_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:94
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f435/examples/usb_device/vcp_loopback/src/main.c:315
OTG_PIN_VBUS_SOURCE
#define OTG_PIN_VBUS_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:86
USB_ID
#define USB_ID
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:68
OTG_PIN_DM_SOURCE
#define OTG_PIN_DM_SOURCE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:83
OTG_PIN_MUX
#define OTG_PIN_MUX
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:96
OTG_WKUP_EXINT_LINE
#define OTG_WKUP_EXINT_LINE
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:74
OTG_PIN_SOF_GPIO_CLOCK
#define OTG_PIN_SOF_GPIO_CLOCK
Definition: project/at_start_f435/examples/acc/calibration/inc/usb_conf.h:92
ACC_SOF_OTG2
#define ACC_SOF_OTG2
Definition: at32f435_437_acc.h:61
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f435_437_acc.h:52
ACC_SOF_OTG1
#define ACC_SOF_OTG1
Definition: at32f435_437_acc.h:60
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f435_437_acc.c:145
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f435_437_acc.c:155
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f435_437_acc.c:135
acc_sof_select
void acc_sof_select(uint16_t sof_sel)
select sof sourse for acc in acc's ctrl1 register.
Definition: at32f435_437_acc.c:84
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f435_437_acc.c:53
system_core_clock
unsigned int system_core_clock
Definition: system_at32f435_437.c:48
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f435_437_board.c:326
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f435_437_board.c:138
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f435_437_board.c:306
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type value)
set usb division
Definition: at32f435_437_crm.c:521
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f435_437_crm.c:215
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f435_437_crm.c:594
CRM_SCFG_PERIPH_CLOCK
@ CRM_SCFG_PERIPH_CLOCK
Definition: at32f435_437_crm.h:163
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f435_437_crm.h:168
CRM_USB_DIV_5
@ CRM_USB_DIV_5
Definition: at32f435_437_crm.h:620
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f435_437_crm.h:616
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f435_437_crm.h:611
CRM_USB_DIV_5_5
@ CRM_USB_DIV_5_5
Definition: at32f435_437_crm.h:619
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f435_437_crm.h:618
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f435_437_crm.h:615
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f435_437_crm.h:614
CRM_USB_DIV_6
@ CRM_USB_DIV_6
Definition: at32f435_437_crm.h:622
CRM_USB_DIV_4_5
@ CRM_USB_DIV_4_5
Definition: at32f435_437_crm.h:617
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f435_437_crm.h:612
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f435_437_crm.h:613
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f435_437_crm.h:763
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f435_437_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f435_437_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f435_437_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f435_437_exint.h:89
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f435_437_exint.h:98
TRUE
@ TRUE
Definition: at32f435_437.h:379
gpio_pin_mux_config
void gpio_pin_mux_config(gpio_type *gpio_x, gpio_pins_source_type gpio_pin_source, gpio_mux_sel_type gpio_mux)
configure the pin's muxing function.
Definition: at32f435_437_gpio.c:491
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f435_437_gpio.c:103
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f435_437_gpio.c:135
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f435_437_gpio.h:84
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f435_437_gpio.h:93
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f435_437_gpio.h:111
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f435_437_gpio.h:113
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f435_437_gpio.h:102
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f435_437_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f435_437_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f435_437_misc.h:71
USB_FULL_SPEED_CORE_ID
@ USB_FULL_SPEED_CORE_ID
Definition: usb_core.h:64
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f435_437_usb.h:402
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f435_437_usb.h:404
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f435_437_usb.h:403
msc_class_handler
usbd_class_handler msc_class_handler
Definition: msc_class.c:57
msc_desc_handler
usbd_desc_handler msc_desc_handler
device descriptor handler structure
Definition: msc_desc.c:64
usbd_irq_handler
void usbd_irq_handler(otg_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
msc_class.h
usb msc class file
msc_desc.h
usb msc descriptor header file
exint_init_type
exint init type
Definition: at32f435_437_exint.h:107
exint_init_type::line_select
uint32_t line_select
Definition: at32f435_437_exint.h:109
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f435_437_exint.h:111
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f435_437_exint.h:108
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f435_437_exint.h:110
gpio_init_type
gpio init type
Definition: at32f435_437_gpio.h:120
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f435_437_gpio.h:122
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f435_437_gpio.h:123
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f435_437_gpio.h:125
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f435_437_gpio.h:124
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f435_437_gpio.h:121
otg_core_type
usb otg core struct type
Definition: usb_core.h:92
usb_core.h
usb core header file
usbd_int.h
usb interrupt header file
at32f435_437_clock.h
header file of clock program


AT32F435/437 Firmwary Library: at32f435_437_clock.h Source File

  • at_start_f435
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
  • inc
project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CLOCK_H
29#define __AT32F435_437_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif
46
at32f435_437.h
at32f435_437 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_clock.c:49


AT32F435/437 Firmwary Library: at32f435_437_conf.h Source File

  • at_start_f435
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
  • inc
project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_CONF_H
29#define __AT32F435_437_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define ERTC_MODULE_ENABLED
58#define GPIO_MODULE_ENABLED
59#define I2C_MODULE_ENABLED
60#define USART_MODULE_ENABLED
61#define PWC_MODULE_ENABLED
62#define CAN_MODULE_ENABLED
63#define ADC_MODULE_ENABLED
64#define DAC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define EDMA_MODULE_ENABLED
67#define DMA_MODULE_ENABLED
68#define DEBUG_MODULE_ENABLED
69#define FLASH_MODULE_ENABLED
70#define CRC_MODULE_ENABLED
71#define WWDT_MODULE_ENABLED
72#define WDT_MODULE_ENABLED
73#define EXINT_MODULE_ENABLED
74#define SDIO_MODULE_ENABLED
75#define XMC_MODULE_ENABLED
76#define USB_MODULE_ENABLED
77#define ACC_MODULE_ENABLED
78#define MISC_MODULE_ENABLED
79#define QSPI_MODULE_ENABLED
80#define DVP_MODULE_ENABLED
81#define SCFG_MODULE_ENABLED
82#define EMAC_MODULE_ENABLED
83
84/* includes ------------------------------------------------------------------*/
85#ifdef CRM_MODULE_ENABLED
86#include "at32f435_437_crm.h"
87#endif
88#ifdef TMR_MODULE_ENABLED
89#include "at32f435_437_tmr.h"
90#endif
91#ifdef ERTC_MODULE_ENABLED
92#include "at32f435_437_ertc.h"
93#endif
94#ifdef GPIO_MODULE_ENABLED
95#include "at32f435_437_gpio.h"
96#endif
97#ifdef I2C_MODULE_ENABLED
98#include "at32f435_437_i2c.h"
99#endif
100#ifdef USART_MODULE_ENABLED
101#include "at32f435_437_usart.h"
102#endif
103#ifdef PWC_MODULE_ENABLED
104#include "at32f435_437_pwc.h"
105#endif
106#ifdef CAN_MODULE_ENABLED
107#include "at32f435_437_can.h"
108#endif
109#ifdef ADC_MODULE_ENABLED
110#include "at32f435_437_adc.h"
111#endif
112#ifdef DAC_MODULE_ENABLED
113#include "at32f435_437_dac.h"
114#endif
115#ifdef SPI_MODULE_ENABLED
116#include "at32f435_437_spi.h"
117#endif
118#ifdef DMA_MODULE_ENABLED
119#include "at32f435_437_dma.h"
120#endif
121#ifdef DEBUG_MODULE_ENABLED
122#include "at32f435_437_debug.h"
123#endif
124#ifdef FLASH_MODULE_ENABLED
125#include "at32f435_437_flash.h"
126#endif
127#ifdef CRC_MODULE_ENABLED
128#include "at32f435_437_crc.h"
129#endif
130#ifdef WWDT_MODULE_ENABLED
131#include "at32f435_437_wwdt.h"
132#endif
133#ifdef WDT_MODULE_ENABLED
134#include "at32f435_437_wdt.h"
135#endif
136#ifdef EXINT_MODULE_ENABLED
137#include "at32f435_437_exint.h"
138#endif
139#ifdef SDIO_MODULE_ENABLED
140#include "at32f435_437_sdio.h"
141#endif
142#ifdef XMC_MODULE_ENABLED
143#include "at32f435_437_xmc.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f435_437_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f435_437_misc.h"
150#endif
151#ifdef EDMA_MODULE_ENABLED
152#include "at32f435_437_edma.h"
153#endif
154#ifdef QSPI_MODULE_ENABLED
155#include "at32f435_437_qspi.h"
156#endif
157#ifdef SCFG_MODULE_ENABLED
158#include "at32f435_437_scfg.h"
159#endif
160#ifdef EMAC_MODULE_ENABLED
161#include "at32f435_437_emac.h"
162#endif
163#ifdef DVP_MODULE_ENABLED
164#include "at32f435_437_dvp.h"
165#endif
166#ifdef USB_MODULE_ENABLED
167#include "at32f435_437_usb.h"
168#endif
169
170#ifdef __cplusplus
171}
172#endif
173
174#endif
at32f435_437_acc.h
at32f435_437 acc header file
at32f435_437_adc.h
at32f435_437 adc header file
at32f435_437_can.h
at32f435_437 can header file
at32f435_437_crc.h
at32f435_437 crc header file
at32f435_437_crm.h
at32f435_437 crm header file
at32f435_437_dac.h
at32f435_437 dac header file
at32f435_437_debug.h
at32f435_437_dma.h
at32f435_437 dma header file
at32f435_437_dvp.h
at32f435_437 dvp header file
at32f435_437_edma.h
at32f435_437 edma header file
at32f435_437_emac.h
at32f435_437 eth header file
at32f435_437_ertc.h
at32f435_437 ertc header file
at32f435_437_exint.h
at32f435_437 exint header file
at32f435_437_flash.h
at32f435_437 flash header file
at32f435_437_gpio.h
at32f435_437 gpio header file
at32f435_437_i2c.h
at32f435_437 i2c header file
at32f435_437_misc.h
at32f435_437 misc header file
at32f435_437_pwc.h
at32f435_437 pwr header file
at32f435_437_qspi.h
at32f435_437 qspi header file
at32f435_437_scfg.h
at32f435_437 system config header file
at32f435_437_sdio.h
at32f435_437 sdio header file
at32f435_437_spi.h
at32f435_437 spi header file
at32f435_437_tmr.h
at32f435_437 tmr header file
at32f435_437_usart.h
at32f435_437 usart header file
at32f435_437_usb.h
at32f435_437 usb header file
at32f435_437_wdt.h
at32f435_437 wdt header file
at32f435_437_wwdt.h
at32f435_437 wwdt header file
at32f435_437_xmc.h
at32f435_437 xmc header file


AT32F435/437 Firmwary Library: at32f435_437_int.h Source File

  • at_start_f435
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
  • inc
project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/at32f435_437_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F435_437_INT_H
29#define __AT32F435_437_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f435_437.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f435_437.h
at32f435_437 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f435/examples/acc/calibration/src/at32f435_437_int.c:113


AT32F435/437 Firmwary Library: usb_conf.h Source File

  • at_start_f435
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
  • inc
project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f435_437_usb.h"
36#include "at32f435_437.h"
37#include "at32f435_437_board.h"
38#include "stdio.h"
39
51#define USE_OTG_DEVICE_MODE
52
56#define USE_OTG_HOST_MODE
57
62#define USB_ID 0
63#define OTG_CLOCK CRM_OTGFS1_PERIPH_CLOCK
64#define OTG_IRQ OTGFS1_IRQn
65#define OTG_IRQ_HANDLER OTGFS1_IRQHandler
66#define OTG_WKUP_IRQ OTGFS1_WKUP_IRQn
67#define OTG_WKUP_HANDLER OTGFS1_WKUP_IRQHandler
68#define OTG_WKUP_EXINT_LINE EXINT_LINE_18
69
70#define OTG_PIN_GPIO GPIOA
71#define OTG_PIN_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
72
73#define OTG_PIN_DP GPIO_PINS_12
74#define OTG_PIN_DP_SOURCE GPIO_PINS_SOURCE12
75
76#define OTG_PIN_DM GPIO_PINS_11
77#define OTG_PIN_DM_SOURCE GPIO_PINS_SOURCE11
78
79#define OTG_PIN_VBUS GPIO_PINS_9
80#define OTG_PIN_VBUS_SOURCE GPIO_PINS_SOURCE9
81
82#define OTG_PIN_ID GPIO_PINS_10
83#define OTG_PIN_ID_SOURCE GPIO_PINS_SOURCE10
84
85#define OTG_PIN_SOF_GPIO GPIOA
86#define OTG_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
87#define OTG_PIN_SOF GPIO_PINS_8
88#define OTG_PIN_SOF_SOURCE GPIO_PINS_SOURCE8
89
90#define OTG_PIN_MUX GPIO_MUX_10
91#define OTG_PIN_POWER_SWITCH_GPIO GPIOH
92#define OTG_PIN_POWER_SWITCH_CLOCK CRM_GPIOH_PERIPH_CLOCK
93#define OTG_PIN_POWER_SWITCH GPIO_PINS_3
94
95
96#define USB2_ID 1
97#define OTG2_CLOCK CRM_OTGFS2_PERIPH_CLOCK
98#define OTG2_IRQ OTGFS2_IRQn
99#define OTG2_IRQ_HANDLER OTGFS2_IRQHandler
100#define OTG2_WKUP_IRQ OTGFS2_WKUP_IRQn
101#define OTG2_WKUP_HANDLER OTGFS2_WKUP_IRQHandler
102#define OTG2_WKUP_EXINT_LINE EXINT_LINE_20
103
104#define OTG2_PIN_GPIO GPIOB
105#define OTG2_PIN_GPIO_CLOCK CRM_GPIOB_PERIPH_CLOCK
106
107#define OTG2_PIN_DP GPIO_PINS_15
108#define OTG2_PIN_DP_SOURCE GPIO_PINS_SOURCE15
109
110#define OTG2_PIN_DM GPIO_PINS_14
111#define OTG2_PIN_DM_SOURCE GPIO_PINS_SOURCE14
112
113#define OTG2_PIN_VBUS GPIO_PINS_13
114#define OTG2_PIN_VBUS_SOURCE GPIO_PINS_SOURCE13
115
116#define OTG2_PIN_ID GPIO_PINS_12
117#define OTG2_PIN_ID_SOURCE GPIO_PINS_SOURCE10
118
119#define OTG2_PIN_SOF_GPIO GPIOA
120#define OTG2_PIN_SOF_GPIO_CLOCK CRM_GPIOA_PERIPH_CLOCK
121#define OTG2_PIN_SOF GPIO_PINS_4
122#define OTG2_PIN_SOF_SOURCE GPIO_PINS_SOURCE4
123
124#define OTG2_PIN_MUX GPIO_MUX_12
125
129#ifdef USE_OTG_DEVICE_MODE
133/* otg1 device fifo */
134#define USBD_RX_SIZE 128
135#define USBD_EP0_TX_SIZE 24
136#define USBD_EP1_TX_SIZE 20
137#define USBD_EP2_TX_SIZE 20
138#define USBD_EP3_TX_SIZE 20
139#define USBD_EP4_TX_SIZE 20
140#define USBD_EP5_TX_SIZE 20
141#define USBD_EP6_TX_SIZE 20
142#define USBD_EP7_TX_SIZE 20
143
144/* otg2 device fifo */
145#define USBD2_RX_SIZE 128
146#define USBD2_EP0_TX_SIZE 24
147#define USBD2_EP1_TX_SIZE 20
148#define USBD2_EP2_TX_SIZE 20
149#define USBD2_EP3_TX_SIZE 20
150#define USBD2_EP4_TX_SIZE 20
151#define USBD2_EP5_TX_SIZE 20
152#define USBD2_EP6_TX_SIZE 20
153#define USBD2_EP7_TX_SIZE 20
154
158#ifndef USB_EPT_MAX_NUM
159#define USB_EPT_MAX_NUM 8
160#endif
161#endif
162
166#ifdef USE_OTG_HOST_MODE
167#ifndef USB_HOST_CHANNEL_NUM
168#define USB_HOST_CHANNEL_NUM 16
169#endif
170
174/* otg1 host fifo */
175#define USBH_RX_FIFO_SIZE 128
176#define USBH_NP_TX_FIFO_SIZE 96
177#define USBH_P_TX_FIFO_SIZE 96
178
179/* otg2 host fifo */
180#define USBH2_RX_FIFO_SIZE 128
181#define USBH2_NP_TX_FIFO_SIZE 96
182#define USBH2_P_TX_FIFO_SIZE 96
183
184/* usb host vbus power switch */
185#define USBH_5V_POWER_SWITCH
186#endif
187
191/* #define USB_SOF_OUTPUT_ENABLE */
192
196#define USB_VBUS_IGNORE
197
201/* #define USB_LOW_POWER_WAKUP */
202
203#define USBH_DEBUG_ENABLE
204
205#ifdef USBH_DEBUG_ENABLE
206#define USBH_DEBUG(...) printf(__VA_ARGS__);\
207 printf("\r\n");
208#else
209#define USBH_DEBUG(...)
210#endif
211
212void usb_delay_ms(uint32_t ms);
213void usb_delay_us(uint32_t us);
221#ifdef __cplusplus
222}
223#endif
224
225#endif
at32f435_437.h
at32f435_437 header file
at32f435_437_board.h
at32f435_437_usb.h
at32f435_437 usb header file
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c:423
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/main.c:434


AT32F435/437 Firmwary Library: at32f435_437_clock.c File Reference

  • at_start_f435
  • examples
  • usb_device
  • otg1_host_otg2_device_demo
  • src
Functions
project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_clock.c File Reference

system clock config program More...

#include "at32f435_437_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.9
Date
2022-06-28
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f435/examples/usb_device/otg1_host_otg2_device_demo/src/at32f435_437_clock.c.